弥沙塞部和醯五分律

    No. 1421 [cf. Nos. 1422-1424]

弥沙塞部和醯五分律卷第一

        宋罽宾三藏佛陀什共竺道生等译

    第一分初波罗夷法

佛在须赖婆国。与大比丘众五百人俱。诣毗兰若邑住林树下。其邑有婆罗门。名毗兰若。波斯匿王以此邑封之。闻佛释种出家学道。成如来应供等正觉明行足善逝世间解无上调御士天人师佛世尊。普知世间一切心念。为说正法初中后善善义善味。具足清白梵行之相。与诸弟子来游此邑。叹言善哉。我愿见佛。即与五百眷属前后围绕出诣佛所。遥见世尊在林树下。诸根寂定光明殊特。欢喜踊跃下车步进。住立问讯却坐一面。尔时世尊。为说妙法示教利喜。闻法欢悦即白佛言。愿佛及僧。受我安居三月供养。佛言。我此众多。而汝异信异见异乐所奉事异。复白佛言。我虽异信异见异乐。不以世尊此众为多。如是至三。佛乃受之。即从坐起。右绕而去。还家办具安居供养。时魔波旬作是念。今婆罗门请佛及僧安居三月。我当[示*厭]蛊迷乱其意。念已即来[示*厭]之。彼婆罗门为魔所[示*厭]。即入后宫受五欲乐。敕守门者。我今游宴三月在内。外事好恶一不得白。都不复忆请佛及僧。尔时彼国信向邪道。邑里未有精舍讲堂。城北有山林流清净。佛与大众即而安居。时世饥馑乞求难得。入里分卫都无所获。时波利国。有贩马师。驱五百匹马。夏初来至。热时已到。见此邑清凉水草丰茂。便共停止。养食诸马。时诸比丘。至马师所默然而立。时彼马师信佛心净。愍念比丘乞求无获。便作是言。正有马麦。若能食者。当减半分一升相与。足以支身可以行道。诸比丘言。佛未听我食于马分。以是白佛。佛以是事集比丘僧。种种赞叹少欲知足。告诸比丘。自今已后。听食马分。时阿难。即取佛分。倩人为糗供养世尊。诸比丘众舂煮而食

时尊者目犍连。在静处作是念。今此国中乞食难得。我今当与得神通者到郁单越食自然粳米。念已即从坐起至佛所。顶礼佛足却住一面。白佛言。世尊。我向作是念。今此国中乞食难得。当与得神通者到郁单越食自然粳米。佛告目连。汝等可尔。凡夫比丘当如之何。目连白佛。我当以神力接之。佛言。止止。汝虽有是神力。宿对因缘欲置何所。又奈将来诸凡夫何。目连受教。默然而止

时尊者舍利弗。在静处作是念。过去诸佛。何佛梵行不久住。何佛梵行久住。念已即从坐起至佛所。顶礼佛足却住一面。白佛言。我向作是念。过去诸佛。何佛梵行不久住。何佛梵行久住。尔时佛赞舍利弗言。善哉善哉。汝所念善。所问亦善。舍利弗。维卫佛尸叶佛随叶佛梵行不久住。拘楼孙佛拘那含牟尼佛迦叶佛梵行久住。舍利弗白佛言。世尊。以何因缘。三佛梵行不久住。三佛梵行久住。佛告舍利弗。三佛不为弟子广说法。不结戒。不说波罗提木叉。佛及弟子般泥洹后。诸弟子种种名姓出家速灭梵行。譬如槃盛散花置四衢道四方风吹随风飘落。何以故。无綖持故。如是舍利弗。三佛不为弟子广说法不结戒不说波罗提木叉。梵行所以不得久住。又舍利弗。随叶佛与千弟子游恐怖林。所以名曰恐怖林者。未离欲人入此林中衣毛皆竖。是故名曰恐怖林也。彼佛为弟子心念说法。口无所言。诸比丘当思是不思是。当念是不念是。当断是当修是当依是行。诸比丘心知是已。漏尽意解得阿罗汉道。舍利弗。拘楼孙佛拘那含牟尼佛迦叶佛。广为弟子说法。无有疲厌所谓修多罗。祇夜。受记。伽陀。忧陀那。尼陀那。育多伽婆。本生。毗富罗。未曾有。阿婆陀那。忧波提舍。结戒说波罗提木叉。佛及弟子般泥洹后。诸弟子虽种种名姓出家。不速灭梵行。譬如杂华以綖连之置四衢道四方风吹不能令散。何以故。綖所持故。如是舍利弗。三佛广为弟子说如上法。是故梵行所以久住。舍利弗白佛言。世尊。若以不广说法不结戒不说波罗提木叉梵行不久住者。唯愿世尊。为诸弟子广说法结戒说波罗提木叉。今正是时。佛言。且止。我自知时。舍利弗。我此众净。未有未曾有法。我此众中最小者得须陀洹。诸佛如来。不以未有漏法而为弟子结戒。我此众中。未有恃多闻人故。不生诸漏。未有利养名称故。未有多欲人故。未有现神足为天人所知识故。不生诸漏

尔时世尊。三月安居竟。便告阿难。汝来阿难。共至毗兰若所。阿难受教。整衣服从佛。至其门下。时婆罗门。在高楼上五欲自娱。遥见世尊。即便忆悟。疾疾来下拭席迎坐五体投地。为佛作礼。悔过自责。我愚痴人。请佛安居竟不设供。非情中悔亦非无物。正自迷忘不复忆念。唯愿世尊。受我悔过。佛言。汝实愚痴。请佛及僧竟不供养。理应悔过。今当与众受汝忏悔。又告婆罗门。我圣法中。知忏悔者增长善法。彼婆罗门复白佛言。愿佛及僧。留住一月受我供养。佛不受之告言。汝婆罗门异信异见。但能请佛已是大事。如是至三。佛又不受告言。我已在此安居三月。今应游行不得复住。彼婆罗门复白佛言。唯愿世尊。受我明日饯送供养。佛便默然受之。时婆罗门。竟夜办具种种肴膳。至明食时。便敷床座。日时已到。世尊与众弟子俱往就坐。彼婆罗门即设所供。手自斟酌食毕行水。以劫贝四张革屣一緉奉上世尊。僧各两张革屣一緉为安居施。诸比丘言。佛未听我等受安居施。以此白佛。佛种种赞叹少欲知足赞戒。赞持戒已。告诸比丘。因毗兰若。从今已后。听受安居施。即皆受之。于是婆罗门心大欢喜。取小床于佛前坐。佛复为说随喜之偈

  一切天祠中　　奉事火为最
  一切异学中　　萨婆帝为最
  一切众人中　　转轮王为最
  一切众流中　　大海水为最
  一切照明中　　日月光为最
  天上天下中　　佛福田为最

尔时世尊说此偈已。更为说法示教利喜。从坐而起向僧伽尸国。展转游历。后之毗舍离。住猕猴河边重阁讲堂。为诸四众比丘比丘尼优婆塞优婆夷。国王大臣沙门婆罗门。供养恭敬尊重赞叹。尔时迦兰陀邑诸长者事缘入城。闻佛世尊在重阁讲堂皆诣佛所。见佛世尊与无量众围绕说法。时彼众中。有长者迦兰陀子。名须提那。闻法欢喜即作是念。如我解佛所说。夫在家者恩爱所缚。不得尽寿广修梵行。出家无著譬如虚空。我今宁可以家之信出家修道。众会各归。前至佛所。顶礼佛足白佛言。世尊。我向闻佛说法。作如是念。如我解佛所说。夫在家者恩爱所缚。不得尽寿广修梵行。出家无著譬如虚空。我今宁可以家之信出家修道。世尊。我有是念。今欲出家。唯愿与我出家受戒。佛言。甚善。汝父母听未。答言。未听。佛言。一切佛法父母不听不得为道。即白佛言。我今当还启白父母。佛言。今正是时。于是须提那。便从坐起右绕三匝还家。白父母言。我闻佛法。在家缚着。今欲出家广修梵行。父母答言。止须提那。莫作是语。吾先无子。祷祠神祇仅而有汝。一子之爱情念实重。死不相远。如何生离。汝家饶富。金银宝物恣汝修德。现世受乐。何用出家夺吾情志。苦请至三父母不许。便从坐起。住于别处作是誓言。若不得出家。终不复食。于此而死。何用徒生。即便不食至于六日。亲戚闻之咸来慰喻言。汝父母唯汝一子。爱念情重。死尚不远。况闻生离。汝家大富可以树德。道由于心不在形服。何必伤生苦违父母。如是至三。默然不受。又诸时友亦来谏之苦言如上。亦复如是。各舍之去。至父母所。咸作是言。如我所见不可复转。若听出家犹可时见。不乐道者归来有期。绝餐六日余命漏克。数日之间当弃中野。鸱乌吞啄虎狼竞食。人父人母胡宁忍此。父母闻已衔泪答言。听子出家修于梵行。但为我共要时还相见。亲友闻已皆大欢喜。复至其所语言。汝父母已许汝出家。不忘时归便得去矣。须提那即大欢喜。至父母所白言。我今诣佛出家修道。父母悲泣答言。听汝出家广修梵行。但勿忘要时还见我。于是须提那。拜辞父母绕三匝而去。还至佛所顶礼佛足。白佛言。世尊。父母已听。唯愿与我出家受戒。佛言。善来比丘修诸梵行。我善说法断一切苦。佛说是已。须提那须发自落袈裟着身钵盂在手。即成沙门得具足戒。出家未久。时世饥馑。诸比丘入城分卫者。都无所获。须提那在闲静处作是念。今此饥馑乞求难得。我所生处饮食丰乐。当将诸比丘还我本邑令得供养并福度彼。便从坐起。与诸比丘还到本邑住林树下。父母闻之。敕其妇言。汝可庄严。如吾子在家所好服饰。庄严既毕。父母将之。同诣彼林。时须提那。见父母来起迎问讯。父母语言。汝何用毁形在林树间。可还舍道在家修善。白父母言。不能舍道还就下贱。如是至三执心弥固。父母呜咽舍之还家。须提那妇。数日之中便有月水。即以白姑。姑欢喜言。是有子相。即敕庄严如前服饰。父母复将共诣彼林。时须提那问讯如上。父母复言。汝何用毁形在林树间。受此风露饥寒困苦。汝家财富天下所知。但我私宝积没人首。况父母物孰能量计。汝可还家恣意修善。现世受乐后享福庆。白父母言。如子所见五欲伤德欢乐如电忧苦延长。终不以此捐修梵行。如是至三答启弥厉。父母复言。尔虽吾子。今为释种。违我以道。夫复何言。但祖宗辍祠人伦情重。王宪嗣绝财物没官。吾备之矣。汝岂不知余愿所期在汝续种。汝其思之。吾言尽矣。时须提那闻诲。悲泣默然奉命。便与妇同归。在于本室三反行欲。乃有神降。时兜率陀大威德天命终受胎。尔时地神。告虚空神言。迦兰陀子。于未曾僧中作未曾有事。虚空神告四天王。四天王告忉利天。展转相告乃至梵天。其妇月满生子。聪达名曰续种。年大出家成阿罗汉。时须提那犯此恶已。即自悔责。我今失利。云何于佛正法出家。而不究竟修于梵行。羸瘦憔悴才有气息。诸比丘见问言。汝先好颜色。今何憔悴。将无不乐梵行犯恶罪耶。答言。我犯恶罪。是故尔耳。即问汝犯何罪。答言。我共本二作不净行。诸比丘言。汝所作不善。非清净行非沙门法不随顺道。种种呵责。如佛所说呵责已。将至佛所以事白佛。佛以是事集比丘僧。诸佛常法。知而故问。知而不问。知时问。非时不问。有益问。无益不问。诸佛常法。有五百金刚神侍卫左右。若佛问三反。不以实答。头破七分。佛问比丘。欲何所说。诸比丘重以白佛。佛问须提那。汝实尔不。答言。实尔世尊。佛言。汝愚痴人。所作不善。非清净行非沙门法不随顺道。此不能令未信者信令信者退。汝不闻我种种呵欲欲想欲觉欲热。赞叹断欲离欲想除欲觉灭欲热。我常说欲如赤骨聚如大火坑如利刀如利箭如毒蛇如毒药如幻如梦诳惑于人。汝今云何作此大恶。汝岂不闻我所说法。未离欲者能使离欲。已放逸者令不放逸。能断渴爱离有为法。无学离欲向无为道。示人正要毕竟泥洹。汝岂不畏三恶道苦。汝若不作此大恶者。佛正法中必得无量诸善功德。汝初开漏门为此大恶。波旬常伺诸比丘短。汝今便为开魔径路摧折法幢建立魔麾。须提那。宁以身分内大火坑若毒蛇口。不应以此触女人身。汝所犯恶永沦生死。终不复能长养善法。佛种种呵责已告诸比丘。以十利故为诸比丘结戒。何等为十。所谓僧和合故。摄僧故。调伏恶人故。惭愧者得安乐故。断现世漏故。灭后世漏故。令未信者信故。已信者令增广故。法久住故。分别毗尼梵行久住故。从今是戒应如是说。若比丘行淫法。得波罗夷不共住

佛在舍卫城。有阿练若比丘。在空闲处住。有猕猴群住彼左右。时一比丘念雌猕猴。以食诱之遂共行欲。后众多比丘。案行卧具到其住处。时彼比丘入城乞食。雌猕猴来现淫欲相。诸比丘共作是语。观此猕猴必当有故。共伺察之其状必现。先住比丘须臾来还。猕猴即往现受欲相。时彼比丘便共行欲。诸比丘见语言。汝不闻佛结戒比丘行淫得波罗夷耶。答言。佛制人女不制畜生。诸比丘言。人女畜生有何等异。汝所作不善。非清净行非沙门法不随顺道。此不能令未信者信。令信者退。汝不闻世尊种种呵欲欲相欲觉欲热。具说如上。呵已将至佛所以事白佛。佛以是事集比丘僧。问言。汝实尔不。答言。实尔世尊。佛言。汝愚痴人所作非法。种种呵责亦如上说。呵已告诸比丘。从今是戒应如是说。若比丘行淫法乃至共畜生。得波罗夷不共住

佛在舍卫城。尔时众多比丘。不乐修梵行。共作是语。佛法出家甚为大苦。我等当共行白衣仪法外道仪法行白衣事外道事时亦入村。非时亦入村。行杀盗淫饮酒食肉。昼夜观伎歌谣自娱。数作是语。无有惭愧。时有持戒比丘少欲知足。种种呵责已。将至佛所以事白佛。佛以是事集比丘僧。问言。汝实尔不。答言。实尔世尊。佛种种呵责。汝等不应共作是语。行外道仪法白衣仪法。若言行外道仪法。语语偷罗遮。白衣仪法突吉罗

佛在王舍城。时有跋耆邑比丘。名孙陀罗难陀。众所知识供养恭敬。不乐修梵行。作外道仪法白衣仪法。行杀盗淫种种恶事。彼诸居士不信乐佛法者呵责言。云何沙门释子作如此恶。处处咸言。孙陀罗比丘亦受五欲乐。此等比丘。无沙门行无婆罗门行。不受沙门法不受婆罗门法。此等比丘。所不游处皆得善利。恶声流布遍闻天下。时孙陀罗还至众中作是言。与我出家受戒。诸比丘言。须白世尊。即以白佛。佛以是事集比丘僧。告诸比丘。孙陀罗非比丘。若已受戒。应白四羯磨作灭摈。若上座若上座等知法律者。应如是白。大德僧听。孙陀罗比丘戒羸不舍行淫法。今僧与孙陀罗比丘作灭摈。若僧时到僧忍听。白如是。大德僧听。孙陀罗比丘戒羸不舍行淫法。今僧与孙陀罗比丘作灭摈。谁诸长老忍默然不忍者说。第二第三亦如是。僧与孙陀罗比丘作灭摈竟。僧忍默然故。是事如是持。佛告比丘。若比丘言行白衣仪法外道仪法。不名舍戒。若口言我舍戒。名为舍戒从今是戒应如是说。若比丘共诸比丘同学戒法。戒羸不舍行淫法乃至共畜生。是比丘得波罗夷不共住

比丘者。乞比丘。持坏色割截衣比丘。破恶比丘。实比丘。坚固比丘。见过比丘。一语受戒比丘。二语受戒比丘。三语受戒比丘。善来受戒比丘。如法白四羯磨受戒比丘。是名比丘。同学者。如佛所说尽形寿不犯。同学是学。是名同学。戒法者。所受不缺戒。不生恶法戒。成就善法戒。定共戒。戒羸不舍者睡眠舍戒。向睡眠人舍戒。不名舍戒。醉舍戒。向醉人舍戒。狂舍戒。向狂人舍戒。散乱心舍戒。向散乱心人舍戒。病坏心舍戒。向病坏心人舍戒。向非众生向非人向畜生舍戒。遣使遣书舍戒。作相舍戒。动手舍戒。相似语舍戒。独独想独不独想不独独想舍戒。中国语向边地人边地语向中国人舍戒。戏笑舍戒。不定语舍戒。嗔心舍戒。强逼舍戒。不应向舍戒。而向舍戒。皆不名舍戒。不发言舍戒不名舍戒。是名不舍戒。反上名舍戒。或戒羸非舍戒。或舍戒非戒羸。或戒羸亦舍戒。或非戒羸非舍戒。云何戒羸非舍戒。若比丘不乐修梵行。不乐修梵行已。犹敬佛法僧。敬戒敬沙门法。敬比丘法敬毗尼。敬波罗提木叉。敬和尚阿阇梨同和尚阿阇梨。敬同梵行人不谤三尊。而忆乡土园观浴池山林树木父母兄弟姊妹儿女乃至奴婢。如是忆念愁忧不乐。而尽形寿不犯梵行。是名戒羸非舍戒。云何舍戒非戒羸。若比丘不乐修梵行。不乐修梵行已。犹敬佛乃至敬同梵行人。彼作是念。欲作沙弥若优婆塞。乃至欲作外道梵志非沙门释子。复作是念。我今欲舍佛法僧舍戒舍毗尼舍波罗提木叉舍和尚阿阇梨同和尚阿阇梨舍同梵行人。即作是言。我今舍佛。何用佛为。佛有何义。我今于佛得脱乃至言。我今得脱同梵行人。复作是言。作非沙门释子畜我作如是谤佛法僧乃至谤同梵行人。作如是等心念口言向人说。是名舍戒非戒羸。云何戒羸亦舍戒。若比丘不乐修梵行。少敬佛法僧。乃至少敬同梵行人。忆念乡土乃至奴婢。作是念。我今欲舍佛法僧乃至舍同梵行人。即作是言。我今舍佛。何用佛为。佛有何义。我今于佛得脱。乃至脱同梵行人。复作是言。作非沙门释子畜我作如是谤佛法僧。乃至谤同梵行人。作如是等心念口言向人说。是名戒羸亦舍戒。云何非戒羸非舍戒。若比丘于所受戒坚持不舍不动不转。是名非戒羸非舍戒。行淫法者。淫法名非梵行法懈怠法狗法可恶法。二身交会出不净。是名行淫法。波罗夷者。名为堕法。名为恶法。名断头法。名非沙门法。不共住者。如先白衣时。不得与比丘共一学等学不等学不余学。不与比丘共一羯磨等羯磨不等羯磨不余羯磨。不与比丘共一说戒等说戒不等说戒不余说戒。是名不共住。诸佛世尊。善说正法亦善说譬说。犯淫者。如针鼻决不可复用。如人命尽不可复活。如石破不可复合。如断多罗树心不可复生

是中比丘。与三种众生行淫犯波罗夷。人非人畜生。比丘与三种女行淫犯波罗夷。人女非人女畜生女。与三种男。人男非人男畜生男。三种黄门。人黄门非人黄门畜生黄门。三种无根。人无根非人无根畜生无根。三种二根。人二根非人二根畜生二根。行淫亦如是。比丘与人女非人女畜生女三处行淫。大小行处口中。眠时醉时狂时散乱心时病坏心时死时啖半时波罗夷。过半时骨时出不净僧伽婆尸沙。不出不净偷罗遮。无根女时二根亦如是。比丘与人男非人男畜生男二处行淫。大行处口中。眠时乃至啖半时波罗夷。过半时骨时出不净僧伽婆尸沙。不出不净偷罗遮。无根男时黄门亦如是。于上诸处行淫。外方便内出不净。内方便外出不净。眠时乃至啖半时波罗夷。过半时骨时出不净僧伽婆尸沙。不出不净偷罗遮。比丘若为强力所逼。于上诸处行淫。入时受乐。出住不受。出时受乐。入住不受。住时受乐。出入不受。出入受乐。住时不受。入住受乐。出时不受。出住受乐。入时不受。出入住时受乐。眠时乃至啖半时波罗夷。过半时骨时出不净僧伽婆尸沙。不出不净偷罗遮。出入住时都不受乐不犯。若比丘淫欲心。以男根内上诸处一分。皆波罗夷。若以指一切外物内上诸处。皆偷罗遮。比丘尼亦波罗夷。式叉摩那沙弥沙弥尼突吉罗驱出。不犯者。狂心乱心病坏心初作。此四种不犯。下一切诸戒皆如是。悉不复出

佛在王舍城。尔时有比丘。名达尼迦。是陶家子。于乙罗山作草庵住。至时持钵入城乞食。取樵人于后辄坏其庵持材木去。食后还已复更治之。如是至三。心转怀恨。便作是念。我身幸能善于和泥。何为不作完成瓦屋以勉斯患。即便作之。脊栋栌栿榱柱桁梁绮疏牖户巧妙若神。积薪烧成色赤严好。大风吹时作箜篌声。佛在耆阇崛山。遥见其屋种种刻画色赤严好。问阿难言。彼是何屋。阿难白佛。是达尼迦身力所作。佛告阿难。是达尼迦所作非法。云何出家。为此恶业残害物命。而无哀愍。我先种种说慈忍法。如何比丘无此慈心。世尊如是种种呵已告诸比丘。汝等往彼破其所作比丘受教。即往屋所。时达尼迦从屋内出。问诸比丘。我不相犯。何为群党欲破我屋。诸比丘言。奉世尊敕。非我等心。达尼迦言。法王所坏我复何言。诸比丘即共破之。将达尼迦还至佛所。以事白佛。佛以是事集比丘僧。问达尼迦。汝实作不。答言。实作世尊。佛种种如上呵责已告诸比丘。从今若比丘作烧成瓦屋偷罗遮。自现工巧突吉罗。时达尼迦复作是念。我先结草庵。辄为樵人所坏。后作瓦屋。复违法王出家之体。今宁可更求好材建立大屋。必得久住无复苦恼。复作是念。王舍城典材令。是我知识。当往从索。念已便往语言。我须材木。可以与我。典材令言。我于材木不得自由。问言。由谁。答言。由王。达尼迦言。王已与我。典材令言。若王已相与。随意取之。达尼迦便取城防大材断截持去。时雨舍大臣案行诸处。遇见于道。即问典材令。何以乃持城防大材与彼比丘。答言。非是我与。复问。是谁。答言。是王。雨舍即启。不审大王。何以乃以城防大材与达尼迦。王言。谁道我与。雨舍言。是典材令。王即敕左右。收典材令。受教即收。将诣王所。时达尼迦入城乞食。道路见之问言。汝何所犯系缚乃尔。答言。由大德故致此大罪。愿见救免全其性命。达尼迦言。汝且在前吾寻后到。时典材令既至王所。王问。汝何以乃持城防大材与达尼迦。白言。大王。不敢专辄。达尼迦言。王教使与。王便敕呼。时达尼迦已在门外。王敕令前。即前见王。王问言。我以何时与比丘材。达尼迦言。王岂不忆初登位时以一切境内草木及水施沙门婆罗门耶。王言。我本所施不及有主。怪哉比丘。乃作此方便而取人物。复语言。我是灌顶王。如何当囚杀沙门。如今便可速还。诣佛法王自当以法治汝。时有闻者皆惊愕言。达尼迦犯罪应死。云何呵责而便放遣。如此得脱谁不为盗。又讥呵言。沙门释子。亲受王供而盗王材。况复我等当得无畏。沙门释子。常赞叹不盗教人布施。如何于今躬行贼法。此等无沙门行破沙门法。如此恶声展转流布。国中不信乐佛法长者居士婆罗门等。遥见沙门辄种种骂。诸比丘闻。更相问言。谁盗王材致是恶声。达尼迦言。是我所作。时诸比丘种种呵责。汝所作非法不随顺道。世尊种种毁呰不与取赞叹不盗。汝今云何躬行贼法。诸比丘如是呵责已。将诣佛所以事白佛。佛以是事集比丘僧。问达尼迦。汝实尔不。答言。实尔世尊。佛种种呵责如须提那。尔时摩竭大臣。出家修道侍佛左右。佛问比丘。阿阇世王。人盗齐几便得死罪。比丘白佛。五钱已上便与死罪。佛复以此更呵责已告诸比丘。以十利故为诸比丘结戒。从今是戒应如是说。若比丘盗五钱已上。得波罗夷不共住

佛在舍卫城。时有众多比丘作是语。佛所制戒为聚落中物。非谓空地。又有诸比丘作是语。犯与非犯制与不制但取无苦。便各以盗心取空地有主无主物。取已各生疑悔。到阿难所问阿难。阿难即以白佛。佛以是事集比丘僧。问言。汝实尔不。答言。实尔世尊。佛种种呵责。聚落空地有何等异。呵责已告诸比丘。从今是戒应如是说。若比丘若聚落若空地盗心不与取。若王若大臣若捉若缚若杀若摈。语言汝贼汝小汝痴。是比丘得波罗夷不共住。若城堑若篱栅周回围绕三由旬乃至一屋。是名聚落。聚落外除聚落所行处。是名空地。聚落外尽一箭道。有惭愧人所便利处。是名聚落所行处。物属他。他所护。不与而取。是名盗心。又以谄心曲心嗔恚心恐怖心取他物。亦名盗心。若自取若使人取物离本处。是名不与取。国主聚落主灌顶王转轮王名为王。典领国事者名为大臣。捉其手发名为捉。杻械枷锁名为缚。以刀杖等断其命名为杀。驱出一住处乃至一国名为摈。离善法无记法堕不善处名为贼。无所识名为小。入黑闇名为痴。是中犯者。地中物地上物虚空物聚落聚落物坫坫物田田物园园物屋屋物乘乘物担担物船船物池池物寄还遮路伺路示处导道教取共取不输税

地中物者。若物在地中。比丘作念。我当盗是物。发心及方便皆突吉罗。掘地波逸提。捉物突吉罗。动物偷罗遮。离本处直五钱波罗夷。减五钱偷罗遮

地上物者。物在地上若床架机橙户楣梁栋乃至屋上树上。如是等尽名地上物。比丘作念。我当盗是物。发心及方便乃至捉物。皆突吉罗。动物偷罗遮。离本处直五钱波罗夷。减五钱偷罗遮

虚空物者。若以神力置物空中或有主鸟衔或风吹来。比丘作念。我当盗是物。发心及方便皆突吉罗。动物偷罗遮。离本处直五钱波罗夷。减五钱偷罗遮

聚落者。周围三由旬乃至一屋处。比丘作是念。我当盗是聚落。发心及方便皆突吉罗。打杙椎椎波逸提。绳量诤得直五钱波罗夷。减五钱偷罗遮。聚落物者。随聚落中所有物。比丘作念。我当盗是物。得者波罗夷

坫者。比丘作念。我当盗是坫。发心及方便皆突吉罗。打杙椎椎波逸提。绳量诤得波罗夷。坫物者。随坫中所有物。比丘作念。我当盗是物。得者波罗夷

田者水陆诸田。比丘作念。我当盗是田。发心及方便皆突吉罗。打杙椎椎波逸提。绳量诤得波罗夷。田物者。随田中所出五谷诸物。比丘作念。我当盗是物。得者波罗夷

园者果菜诸园。比丘作念。我当盗是园。发心及方便皆突吉罗。打杙椎椎波逸提。绳量诤得波罗夷。园物者随园中所出物。比丘作念。我当盗是物。得者波罗夷

屋者。在家出家人所居屋若重屋。比丘作念。我当盗是屋。发心及方便皆突吉罗。打杙椎椎波逸提。绳量诤得波罗夷。屋物者。随屋中所有物。比丘作念。我当盗是物。得者波罗夷

乘者。象马车舆诸乘。比丘作念。我当盗是乘。发心及方便乃至捉时皆突吉罗。动物偷罗遮离本处直五钱波罗夷。减五钱偷罗遮。乘物者。随乘上所有物。比丘作念。我当盗是物。得者波罗夷

檐者。头戴肩檐背负手提尽名为檐。比丘作念。我当盗是檐。发心及方便皆突吉罗。动时偷罗遮。离本处直五钱波罗夷。减五钱偷罗遮。檐物者。随檐中所有物。比丘作念。我当盗是物。得者波罗夷。船者。皮船瓶船木船箄筏尽名为船。比丘作念。我当盗是船。发心及方便皆突吉罗。动时偷罗遮。离本处直五钱波罗夷。减五钱偷罗遮。船物者。随船上所有物。比丘作念。我当盗是物。得者波罗夷

池者。陂湖诸水尽名为池。比丘作念。我当盗是池。发心及方便皆突吉罗。打杙椎椎波逸提。绳量诤得直五钱波罗夷。减五钱偷罗遮。池物者。随池所出物。比丘作念。我当盗是物。得者波罗夷

寄者。人寄比丘物。盗心不还物。主心舍。直五钱波罗夷。减五钱偷罗遮

寄还者。比丘受他寄物。盗心不与彼人。直五钱波罗夷。减五钱偷罗遮

遮路者。比丘为贼遮路不听异人来。伺路者。伺候见人便往语贼

示处者。比丘示贼路处

导道者。比丘在贼前导

教取者。教贼取物之方

共取者。共贼取物

不输税者。比丘应输税而不输。如上诸事取物直五钱波罗夷。减五钱偷罗遮。若人物不与取五钱已上。比丘比丘尼波罗夷。式叉摩那沙弥沙弥尼突吉罗驱出。非人物不与取。比丘比丘尼偷罗遮。式叉摩那沙弥沙弥尼突吉罗。畜生物不与取皆突吉罗。四种取人重物不犯。自想取同意取暂用取非盗心取

五分律卷第一五分律卷第二(弥沙塞)

        宋罽宾三藏佛陀什共竺道生等译

    第一分初第三事

佛在毗舍离。尔时世尊告诸比丘。修不净观得大果利。时诸比丘即皆修习。深入厌恶耻愧此身。譬如少年好喜净洁澡浴涂身着新净衣。忽以三尸婴加其颈。脓血逼身虫流满体。其人苦毒无复余想。但念何当脱此耻辱。诸比丘厌恶此身亦复如是。其中或有自杀展转相害。或索刀绳。或服毒药。有一比丘厌恶身已。便往弥邻旃陀罗所语言。为我断命衣钵相与。时旃陀罗。为衣钵故。即以利刀而断其命。有血污刀。持至婆求末河洗之。寻生悔心作是念。我今不善。云何为小利故。而断持戒沙门性命得无量罪。时自在天魔知其心念。譬如壮士屈伸臂顷。来至其前。从水踊出立于水上。赞言善哉。汝得大利。断持戒沙门命。未度者度福庆无量。天神记录。故来告汝。时旃陀罗便生恶邪见。心大欢喜。我今当更度未度者。彼旃陀罗。善知厌身未厌身相。若凡夫比丘未离于欲。举刀向时心恐怖者是未厌身。我若杀之得福甚少。我今当求已得道果无恐怖者。于是手执长刀。从房至房。从经行处至经行处。高声唱言。欲灭度者我当度之。时诸比丘厌恶身者皆出就之。寻断其命。于一日中杀十二十乃至六十。以是因缘僧数减少。大德声闻悉不复现。尔时世尊从三昧起。在露处坐大众围绕。观视僧众告阿难言。今日僧众何故减少。阿难白佛。世尊一时为诸比丘说不净观。比丘修习。厌恶身苦转相残杀。乃至弥邻一日之中伤害梵行六十人命。是故今日僧众减少。善哉世尊。唯愿更说余善道法。令诸比丘得安乐住。佛告阿难。汝今宣令依止毗舍离比丘。皆使来集普会讲堂。阿难受教。即呼来集。集已白言。唯圣知时。世尊从坐起。至讲堂就座而坐。问诸比丘。实有上事不。答言。实尔世尊。佛种种呵责。汝等愚痴。所作非法。岂不闻我所说慈忍护念众生。而今云何不忆此法。呵已告诸比丘。若自杀身得偷罗遮罪。又告。从今已后。应修安般念。乐净观乐喜观。观已生恶。不善法即能除灭。以十利故为诸比丘结戒。从今是戒应如是说。若比丘手自杀。人断其命。是比丘得波罗夷不共住

尔时众多比丘得重病。有诸比丘来问讯言。大德。病宁有损苦可忍不。病比丘言。病犹未损苦不可忍。便语诸比丘。与我刀绳。与我毒药。与我增病食。将我至高岸边。时诸比丘。皆随与之。病比丘或以刀自刺。或以绳自绞。或服毒药。或食增病食。或坠高岸自断其命。诸比丘见其死已。便生悔心。以白阿难。阿难将至佛所。以事白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言。实尔世尊。佛种种呵责。汝等愚痴。自断人命与刀令死。有何等异。从今是戒应如是说。若比丘自断人命持刀授与。得波罗夷不共住。复有比丘得重病。诸比丘来问讯。如上语诸比丘。与我刀绳毒药。诸比丘言。佛不听我与人自杀之具。然我有知识猎师。当为汝唤令断汝命。病比丘言。为我速唤。彼比丘走语猎师言。此有比丘。得重病不复乐生。汝为断命可得大福。猎师言。若杀生得大福者。屠脍之人得大福耶。汝等比丘自言。有慈悲心。今教人杀。教人杀与自杀。有何等异。时诸比丘皆生悔心。往白阿难。阿难将至佛所。以事白佛。佛以是事集比丘僧。问诸比丘。汝实尔不。答言。实尔世尊。佛种种呵责。语诸比丘言。自杀教人杀。有何等异。从今是戒应如是说。若比丘自杀教人杀。得波罗夷不共住

复有比丘得重病。诸比丘问讯如上。语病者言。汝等戒行具足。应受天福。若自杀者必得生天。何用如是久受苦为。病比丘言。若当如是。虽有此苦不能自杀。何以故。若自杀者犯偷罗遮罪。又复不得广修梵行。又呵言。自手杀人教人自杀。有何等异。而汝比丘为此恶业。诸长老比丘闻。种种呵责。将至佛所以事白佛。佛以是事集比丘僧。问诸比丘。汝实尔不。答言。实尔世尊。佛种种呵责。汝等愚痴。自手杀人教人自杀。有何等异。从今是戒应如是说。若比丘自手杀人教人自杀。得波罗夷不共住

复有比丘得重病。诸比丘问讯如上。亦语病者言。汝等梵行已立。死受天乐。何用久受如此病苦而不自杀。病比丘言。我等虽尔不能自杀。何以故。佛制自杀犯偷罗遮。又我病差得修梵行。尔时彼国又有贼难。诸白衣骨肉分离备诸痛恼。比丘语言。汝等已修生天福业。何用受此骨肉生离忧悲之苦而不自杀。答言。我虽忧悲不能自杀。何以故。在世遭苦知修道业。又呵言。沙门之道慈忍众生。云何赞死欲人自杀。自杀赞死。有何等异。诸长老比丘闻。种种呵责。将至佛所以事白佛。佛以是事集比丘僧。问诸比丘。汝实尔不。答言。实尔世尊。佛种种呵责。汝所作非法。自杀赞死。有何等异。从今是戒应如是说。若比丘。若人若似人。若自杀若与刀药杀。若教人杀。若教自杀。誉死赞死。咄人用恶活为。死胜生。作是心随心杀。如是种种因缘。彼因是死。是比丘得波罗夷不共住

入母胎已后至四十九日名为似人。过此已后尽名为人。自以手足刀杖毒药等杀。是名自杀。彼欲自杀。求杀具与之。是名与刀药杀。使人杀。是名教人杀。教人取死。是名教自杀。言死胜生。是名誉死赞死。随心遣诸鬼神杀。是名作是心随心杀

是中犯者。自杀遣使展转使重遣使指示言说眠时说向眠说醉时说向醉说狂时说向狂说乱心说向乱心说病坏心说向病坏心说遣书作相手语相似语独独想不独独想独不独想戏语色声香味触优波头优波奢优波害

自杀者。自以手足刀杖等杀。彼人死者波罗夷。遣使者。遣使杀彼人。彼人死者波罗夷。展转使者。遣某甲杀。某甲不自杀。转使乙杀。死者波罗夷。重遣者。始受使人不得杀。还报比丘。比丘更遣使杀。死者波罗夷。指示者。指示日月星宿。语人言。汝福应生彼。汝可自杀。从而死者波罗夷。言说者。说生过恶赞叹死。好因此死者波罗夷。眠时说者。比丘眠中说先所念言。汝功德已成应可自杀。彼人闻已。待觉问言。汝何故说此。答言我眠中欲利益汝故作是语。汝今觉亦作是语。汝可随我语死。彼因是死者波罗夷。向眠说者。向眠人作是语。汝功德已成。可以刀等自杀。鬼神令眠中闻。即觉问言。汝何故说此。答言。汝眠时我欲利益汝故作是语。汝今觉亦作是语。汝可随我语死。因是死者波罗夷。醉时说者。醉中说先所念言。汝功德已成。应以刀等自杀。彼人闻已。待醒问言。汝何故说此。答言。我醉时欲利益汝故作是语。今醒亦作是语。汝可随我语死。因是死者波罗夷。向醉说者。作是言。汝功德已成。汝可以刀等自杀。醉醒已问言。汝何故说此。答言。我欲利益汝故。汝醉时作是语。汝今醒亦作是语。汝可随我语死。因此死者波罗夷。狂时说向狂说。乱心说向乱心说。病坏心说向病坏心说亦如是。遣书者。比丘遣书令杀。彼作书。字字偷罗遮。书至彼。彼因是杀。死者波罗夷。作相者。比丘语人言。汝看我坐起举手下手口言寒暑时便杀彼。彼见相便杀。死者波罗夷。手语者。作手语教人杀彼随此杀。死者波罗夷。相似语者。比丘作相似语教人杀彼随此杀。死者波罗夷。独独想者突吉罗。不独独想独不独想者偷罗遮。戏语者。比丘戏笑语。汝功德已成。可应自杀。彼人问言。何故说此。比丘答言。我先虽是戏言。今意实尔。汝可自杀。因此死者波罗夷。色者。若比丘作咒术。召恶色鬼神。使恐怖人。因此死者波罗夷。声者。若比丘作是语。汝父母儿女已死。财物破散。作如是语。欲令忧恼自杀。因此死者波罗夷。香者。以毒合和诸香令嗅便死。因是死者波罗夷。味者。以毒着食中令食。因是死者波罗夷。触者。以迦毗毒药涂身杀。因是死者波罗夷。优波头者。为一切众生作阱杀。若人堕死波罗夷。非人堕死偷罗遮。畜生堕死波逸提。优波奢者。作弱床薄覆其。上下安杀具使人坐上。因是死者波罗夷。优波害者。作蛊毒杀。因是死者波罗夷。若比丘作是念。我当杀彼人。发心时突吉罗。作方便时偷罗遮。死者波罗夷。若杀非人偷罗遮。若杀畜生波逸提。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗。不犯者。慈愍心无杀心(第三事竟)

佛在毗舍离。时世饥馑乞食难得。诸比丘入城分卫。都无所获。尔时世尊告诸比丘。汝等各随知识就彼安居。莫住于此受饥馑苦。比丘受教。有往摩竭国者。有往婆求末河边聚落中者。往河边诸比丘集共议言。今乞食难得。此聚落中有信乐者。我等当共更相赞叹。某得初禅我亦得之。某得二禅三禅四禅四无量处四无色定我亦如是。某得四念处乃至八正道分三解脱门我亦如是。某得八解脱九次第定十一切入十直道我亦如是。某得坚信坚法四沙门果三明六神通我亦如是。诸居士闻。必生希有心。作是语。我得善利。乃有如是得道圣人安居我邑。便当具诸肴膳供养我等。我等无乏得安乐住。议已即便入城到诸富家共相称赞如上所说语言。汝得大利。圣众福田依汝聚落。诸居士闻生希有心叹未曾遇。皆减己分不复祭祠。断施余人并以供养。诸佛常法。二时大会春夏末月。诸方比丘皆来问讯。摩竭国诸比丘安居竟。羸瘦憔悴来诣佛所。顶礼佛足却住一面。诸佛常法。客比丘来皆加慰问。问言汝等安居和合乞食易得道路不疲耶。诸比丘言。安居和合道路不疲。但乞食难得。时佛为说种种妙法示教利喜。令随所住。婆求末河诸比丘身体充悦。来诣佛所顶礼佛足却住一面。佛亦如上慰问。诸比丘白言。安居和合乞食易得道路不疲。佛即问言。今世饥馑乞求难得。汝等云何而独言易。诸比丘白佛。我等在彼以乞食难得。更相赞叹具说如上。佛即问言。汝等赞叹为实为虚。比丘白佛。有实有虚。佛种种呵责虚者。汝等非法不随顺道。出家之人所不应作。宁啖烧石吞饮洋铜。不以虚妄食人信施。汝等岂不闻我毁呰妄语之罪种种赞叹不妄语德耶。而今云何为利养故。虚诳自说得过人法。复呵责言。诸比丘世间有五大贼。一者作百人至千人主破城聚落害人取物。二者有恶比丘将诸比丘游行人间邪命说法。三者有恶比丘于佛所说法自称是我所造。四者有恶比丘不修梵行自言我修梵行。五者有恶比丘为利养故空无过人法自称我得。此第五贼。名为一切世间天人魔梵沙门婆罗门中之最大贼。汝等云何为小利养作最大贼。如是呵责已告诸比丘。以十利故。为诸比丘结戒。从今是戒应如是说。若比丘不知不见过人法圣利满足。自称我如是知如是见。后时若问若不问。为出罪求清净故。作是言。我不知言知不见言见。虚诳妄语。是比丘得波罗夷不共住

佛在舍卫城。有众多少闻比丘。不学不问无过人法。自谓我知我见我证。彼于后时。闻诸比丘讲论得道未得道相。乃悟非道生惭愧心。作是念。我等先未得谓得。将无犯波罗夷罪。复有少闻比丘。不学不问无过人法。自谓我知我见我证。彼于后时。广学诸经生惭愧心。作是念。如我今解佛所说法。先未得谓得。是增上慢。将无犯波罗夷罪。复有少闻比丘。不学不问无过人法。自谓我知我见我证。彼于后时。广修梵行得入道果。生惭愧心作是念。我先未得谓得。是增上慢。将无犯波罗夷罪。诸比丘念已。各诣阿难。皆以问之。阿难将至佛所。具以白佛。佛以是事集比丘僧。各随其事问诸比丘。汝实尔不。答言实尔世尊。佛告诸比丘。有五种现过人法。一者愚痴。二者乱心。三者随恶。四者增上慢。五者实有。若愚痴乱心增上慢实有。而自言我得。犯波罗夷者无有是处。从今是戒应如是说。若比丘不知不见过人法圣利满足。自称我如是知如是见。是比丘后时若问若不问。为出罪求清净故。作是言。我不知言知不见言见虚诳妄语。除增上慢。是比丘得波罗夷不共住

不知不见者。不知不见过人法。一切出要法。谓诸禅解脱三昧正受诸圣道果。是名过人法。于佛所说苦集灭道。已办已足更无所求。是名圣利满足。自说我如是知见法。法亦知见我。是名自称我如是知如是见。若一月乃至一岁。后问汝云何得。何处得。从谁得。以何法得。若不问而自发露所犯。求戒净心净见净疑净言。我不知不见苦集灭道。言知言见虚诳妄语。虽作如此发露。故得波罗夷

是中犯者。有二种得波罗夷。一者先作是念我当虚说得过人法。二者当说时作是念我今虚说得过人法。复有三种得波罗夷。二如上说。三者作是念我已虚说得过人法。复有四种得波罗夷。三如上说。四者异见说过人法。复有五种得波罗夷。四如上说。五者异想说过人法。复有六种得波罗夷。五如上说。六者异忍说过人法。复有七种得波罗夷。六如上说。七者异乐说过人法。复有八种得波罗夷。七如上说。八者不随问答说过人法。有四种非圣语四种圣语。非圣语者。不见言见不闻言闻不觉言觉不知言知。圣语者。见言见闻言闻觉言觉知言知。又八种非圣语八种圣语。非圣语者。不见言见见言不见不闻言闻闻言不闻。不觉言觉觉言不觉不知言知知言不知。反上名八圣语。又十六非圣语十六圣语。非圣语者。不见言见不闻言闻不觉言觉不知言知。见言不见闻言不闻觉言不觉知言不知。见疑言不疑闻疑言不疑觉疑言不疑知疑言不疑。见不疑言疑闻不疑言疑觉不疑言疑知不疑言疑。反上名十六圣语

若比丘向人自称得过人法。解者波罗夷。不解者偷罗遮。向非人说偷罗遮。向畜生说突吉罗。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗。不犯者实语(第四戒竟)

    五分律第一分之二僧残法

佛在舍卫城。尔时长老优陀夷。为欲火所烧。身体羸瘦才有气息。以手出不净得安乐住。有异比丘亦复羸瘦。优陀夷问。汝何故尔。答言长老。我为欲火所烧。是故如是。优陀夷言。我先亦尔。以手出不净得安乐住。汝若法我亦当如是。彼比丘言。汝所作非法。非清净行破沙门法。不随顺道。世尊种种呵欲欲想欲觉欲热。断欲想除欲觉灭欲热。说欲如赤骨如毒药。汝今云何。以此手出于不净受人信施。复以教人。呵责已将至佛所。以事白佛。佛以是事集比丘僧。问优陀夷。汝实尔不。答言实尔世尊。佛亦种种如上呵责已。告诸比丘。以十利故。为诸比丘结戒。从今是戒应如是说。若比丘故出不净僧伽婆尸沙

尔时诸比丘。不一其心梦失不净。觉作是念。我梦中亦有心亦动身失不净。将无犯僧伽婆尸沙耶。或有发露者。或有行摩那埵者。或有出罪者。或有直白佛者。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言实尔世尊。佛种种呵责。汝等不应散乱心眠。若散乱心眠犯突吉罗。散乱心眠有五过失。一者恶梦二者善神不护三者不得明想四者无觉法心五者失不净。不散乱心眠有五德。无恶梦善神护得明想有觉法心不失不净。有五因缘眠时形起。一者大便盛二者小便盛三者风盛四者虫啮五者欲盛。复告诸比丘。若未离欲恚痴散乱心眠必失不净。虽未能离。以系念心眠者无有是过。从今是戒应如是说。若比丘故出不净。除梦中僧伽婆尸沙。故出不净者。发心身动出不净也。僧伽婆尸沙者。此罪有残犹有因缘。尚可治有恃怙。得在僧中求除灭也。不净有十种。一者青色二者黄色三者红色四者黑色五者赤色六者白色七者乳色八者酥色九者油色十者蜜色。若发心身动。欲出青色而黄色乃至蜜色出。皆僧伽婆尸沙。若发心身动。欲出黄色乃至蜜色。而余色出亦如是。有十种发心。身动出不净。皆僧伽婆尸沙。一者自试二者除病三者为颜色四者为力五者为乐六者为布施七者为生天八者为外道祠天会九者为种子十者为火祠。有五种发心。身动出不净。皆僧伽婆尸沙。内色外色虚空风水。内色者己身。外色者他身。虚空者空中动身。风者向风行。水者逆水行。又有五种发心。身动出不净。僧伽婆尸沙。大便盛小便盛风盛虫啮欲盛。若发心身不动不出不净。发心身不动出不净皆突吉罗。发心身动不出不净偷罗遮。不发心身动不出不净。不发心身动出不净。不发心身不动出不净皆不犯。眠时出不净觉时发心身动偷罗遮。眠时身动觉时发心出不净突吉罗。眠时发心觉时身不动出不净。不犯沙弥突吉罗(一戒竟)

佛在舍卫城。尔时长老优陀夷。为欲火所烧。作是念。故出不净世尊已制。今当方便与女人相触取细滑乐。便扫洒房内敷好床座。取一小床于露地坐。有诸女人同来游观。语优陀夷言。我等故来欲看房舍。答言。姊妹随意看之。便将入房。闭户开窗种种摩触。或捉或抱或案或摩。或举上或举下。或骑或越。其中喜者便语之言。何不正作徒用此为。优陀夷言。佛不听我作根本事。其不喜者便嗔恚言。本谓此处安隐。而今反成恐怖之地。水中火然未足为喻。白衣在家犹耻此事。云何比丘乃作是恶。即归其家。人人宣语诸不信乐佛法者。种种呵骂言。我等白衣摩触女身。沙门释子亦复如是。徒剃此头与我何异。无沙门行破沙门法。如是恶名流布天下。复有一婆罗门将妇游观。次到优陀夷房语言。我欲与妇同看房舍。优陀夷言。不得一时。可前后入。婆罗门言。若不得俱。听妇先入。妇既入房。优陀夷亦复如前种种摩触。久久乃出。夫语妇言。何以乃久。不复欲看余房舍耶。妇言。止止莫作是语。但入一房垂死得出。何应复看诸余房舍。夫问所以。妇具以答。时婆罗门即便骂言。沙门释子云何乃作如此恶业。入舍卫城四衢道中街巷市里。处处唱言。沙门释子摩触我妇。诸不信佛法者。种种呵骂沙门释子行恶如此。云何自称净修梵行。诸长老比丘闻。种种呵责。具以白佛。佛以是事集比丘僧。问优陀夷。汝实尔不。答言实尔世尊。佛种种呵责已告诸比丘。以十利故与诸比丘结戒。从今是戒应如是说。若比丘欲盛变心触女人身。若捉手若捉发若捉一一身分。摩着细滑僧伽婆尸沙

欲盛变心者。向欲心深发心事几成。变善法无记法堕不善处。女人者。人女乃至初生。触者。身上处处种种摩触乃至一发。比丘五事触女人僧伽婆尸沙。女女想人女活女心染。以亲近情摩触觉而受乃至触发亦如是。五事触女人偷罗遮。女女想人女活女心染。不以亲近情摩触觉而受乃至触发亦如是。女人触比丘亦如是。五事触女人不犯。女女想人女活女心染。不以亲近情。而女人捉比丘。比丘作方便求脱。虽觉触而不受乃至触发亦如是。又女女想女疑女无根想女二根想触僧伽婆尸沙。女男想女黄门想触偷罗遮。男男想男疑男黄门想触突吉罗。男女想男无根想男二根想触偷罗遮。黄门亦如是。无根无根想无根疑无根二根想无根女想触僧伽婆尸沙。无根男想无根黄门想触偷罗遮。二根亦如是。比丘与无衣女人相触僧伽婆尸沙。与有衣女人相触偷罗遮。女人捉无衣比丘僧伽婆尸沙。捉有衣比丘偷罗遮。比丘与女人俱有衣相触突吉罗。比丘捉女人衣。女人舍衣与比丘偷罗遮。女人捉比丘衣。比丘不舍衣与女人突吉罗。比丘触死人女非人女偷罗遮。捉畜生女突吉罗。沙弥突吉罗

佛在舍卫城。尔时长老优陀夷。为欲火所烧。作是念。故出不净触女人身世尊已制。今当更作方便向诸女人作粗恶语取悦欲乐。复扫洒房于露地坐。女人来观。将入闭户皆如上说。便于房内与女人种种粗恶语。作如是问。汝手脚髀膊腰腹颈乳头面爪发大小便处何似。复言姊妹。汝手脚乃至大小便处恶。又言姊妹。汝手脚乃至大小便处好。又问汝夫近汝时。云何又教汝。若随我意与汝珍宝。又从乞愿。与我从事。一切天神皆证我心。诸女人闻。喜不喜者亦如上说。长老比丘闻。种种呵责。以事白佛。佛以是事集比丘僧。问优陀夷。汝实尔不。答言实尔世尊。佛种种呵责已告诸比丘。以十利故与诸比丘结戒。从今是戒应如是说。若比丘欲盛变心。向女人粗恶语。随淫欲法说。僧伽婆尸沙

是中犯者。毁誉乞愿问反问教。比丘五事与女人粗恶语。女女想人女活女心染。以亲近情从毁誉乃至教。彼解者僧伽婆尸沙。不解者偷罗遮。毁者。毁呰女人三处。若小若大形色恶誉者。赞叹女人三处不小不大形色好。乞者。从女人乞三处。若能与我我能随汝意。愿者。愿得汝三处。得汝三处是福乐人。问者。问汝夫于三处中几种行欲几时作。反问者。问汝夫于三处中不如是作耶。教者。教言汝以三处随男子意。则为男子之所敬爱。女女想乃至二根二根想皆如上说。又有五种。遣使书作相动手相似语。彼解者偷罗遮。不解者突吉罗。比丘面与人女粗恶语。解者僧伽婆尸沙。不解者偷罗遮。向非人女粗恶语偷罗遮。向畜生女粗恶语突吉罗。沙弥突吉罗(三戒竟)

佛在舍卫城。尔时长老优陀夷。为欲火所烧作是念。故出不净摩触女身向女人粗恶语。佛皆已制。我今当向女人自赞供养身取悦意乐。又扫洒房种种如上。便于房内语女人言。姊妹汝供养沙门婆罗门乃至入禅定得四道果。不如以淫欲供养持戒者。诸女人闻。有喜不喜乃至佛种种呵责皆如上说。呵责已告诸比丘。以十利故为诸比丘结戒。从今是戒应如是说。若比丘欲盛变心。向女人自赞供养身言。姊妹。淫欲供养是第一供养。僧伽婆尸沙

若作种种语赞欲供养身。语语突吉罗。若言不如以淫欲供养。语语偷罗遮。若言淫欲供养是第一供养僧伽婆尸沙。以五事自赞供养身。女女想人女活女心染。以亲近情言淫欲供养是第一供养。解者僧伽婆尸沙。不解者偷罗遮。女女想乃至二根二根想。遣使乃至相似语面与女语。向非人女畜生女皆如上说。沙弥突吉罗(四戒竟)

佛在舍卫城。尔时有长者名迦留。聪明利根善断人疑。舍卫城人凡有所作。乃至婚姻无不咨问。言与便与不与便不与。得好者言。由迦留故我得是好。当使迦留亦得是乐。得恶者言。由迦留故我得是恶。亦使迦留受是苦剧。如是丑名善誉充塞一国。迦留后时以信出家。诸咨问者日月更甚。乃至波斯匿王亦自亲诣咨问国事。喜怒之声转倍于前。时有寡妇。其女色貌邑里第一。求婚者众。皆不许之。答言。若就我居如子法者乃当相与。时有婆罗门。财富无量。语寡妇言。与我儿婚汝女。可得长处安乐。答亦如初。于是婆罗门。便访众人。谁数来往此人家者。有人语言。沙门迦留与此家数。即请迦留长供养之。既相狎习。便以事白。我欲为儿求某甲女。愿屈大德为我语之。迦留便着衣持钵。往到彼舍。寡妇即出礼拜问讯。迦留语言。汝可以女与某甲婚。其家饶富必得安乐。答由如初。迦留复言。若不与者此女后大必当委叛。何为失女又去好婿。寡妇闻此僶俯从许。迦留还报。即便成婚。其后夫家遇妇甚苦。遣信白母。愿语夫家小得闲乐。母报女言。须迦留来当使语之。迦留后日到寡妇家。寡妇具白女之辛苦。婚本相由。愿为语之。迦留答言。此女无福致此苦剧。若有福者何缘至此。我沙门法不应知人此世俗事。寡妇骂言。先知人事今云不应。如此恶人终令不吉。种种咒骂言辞苦切。邻人闻之咸来谏言。汝女薄相致此苦剧。何豫沙门。而苦咒骂。寡妇答言。汝岂不知由此沙门使我稚女致此苦剧。时不信乐佛法者。皆作是言。汝信沙门女受此苦。若复用其语方当剧是。复呵骂言。我等白衣行媒嫁法。沙门释子亦复如是。徒剃此头着坏色衣。所行如此与我何异。于是恶名流布远近。诸长老比丘闻种种呵责。将至佛所以事白佛。佛以是事集比丘僧。问迦留汝实尔不。答言实尔世尊。佛种种呵责已告诸比丘。以十利故为诸比丘结戒。从今是戒应如是说。若比丘行媒法。僧伽婆尸沙

尔时舍卫城中诸豪姓。欲得年长童女共行私通。耻自宣意因无行人。便语六群比丘。汝可为我宣此意旨。若须物者。一日一宿乃至一会为须几许。六群比丘即诣诸女。具以意问。有人见之。皆共讥论。沙门释子净修梵行。而今云何行此恶业。构合耶非白衣所耻。此诸沙门无有惭愧。诸长老比丘闻。种种呵责。将至佛所以事白佛。佛以是事集比丘僧。问六群比丘。汝实尔不。答言实尔世尊。佛种种呵责已告诸比丘。从今是戒应如是说。若比丘行媒法。若为私通事。持男意至女边。持女意至男边。乃至一交会僧伽婆尸沙

有十种女十种男。十种女者父母所护兄姊所护亲里所护。自护法护自任衣物共誓有主作信。父母所护者。女有父母。父母能与能夺。兄姊亲里亦如是。自护者。自得自在。自与自夺。法护者。正法出家修行梵行。自任者。自随所乐。衣物者。受他衣物。共誓者。与人要誓。有主者。女人属夫。作信者。受他片致。要一日一月乃至一交会。十种男亦如是。若比丘受父母所护男语突吉罗。语父母所护女乃至作信女偷罗遮。不许致报偷罗遮。许还报僧伽婆尸沙。若比丘受父母所护男语。语父母所护女。女言可语我父母。比丘以此语还报偷罗遮。父母所护男。又令比丘语彼女父母。受此语突吉罗。语彼女父母。及不许还报偷罗遮。许还报僧伽婆尸沙。受父母所护男语。语兄姊亲里所护女亦如是。乃至受作信男语。语父母所护女。乃至语作信女亦如是。若比丘受父母所护女乃至作信女语。语父母所护男乃至语作信男亦如是。有六种语。自使书使使相似语相。若比丘受自语自语彼自还报僧伽婆尸沙。若比丘受自语使语彼自还报。受自语自语彼使还报。受自语使语彼使还报。皆僧伽婆尸沙。受自语乃至相语彼相还报亦如是。若比丘乃至受相语亦如是。若比丘为人男人女边行媒法僧伽婆尸沙。人男非人女边行媒法偷罗遮。人男畜生女边行媒法突吉罗。为人女亦如是。为非人男人女边行媒法偷罗遮。畜生男人女边行媒法突吉罗。为人女黄门边行媒法突吉罗。若比丘为男借女为女借男长使偷罗遮。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗。不犯者。为和合故(五戒竟)

佛在舍卫城。尔时阿荼髀邑诸比丘。自乞作房。从诸居士求车求车直求人求人直材木草竹皆从求索。居士厌之见皆逃避。诸比丘乞不复能得。便自斫伐草木掘地取土。有一大德比丘。自斫神树。树神小儿时戏树间。斫断其指。树神痛恼。便兴恶意欲来打之。复作是念。此大威德。若我打者或以之死。使我长夜受诸苦恼。又作是念。世尊今在此城。当往白之。佛有教敕我当奉行。即诣只桓具以白佛。尔时世尊赞叹树神。善哉善哉汝所念善。今此比丘实有威德。若当打者必受苦报。复告树神。某处有大树未有所属。汝可依之。受教即往。于是世尊。渐渐游行到阿荼髀邑。长老大迦叶。晨朝着衣持钵入城乞食。居士见之悉皆逃走。迦叶怪之问于行人。行人答言。此诸比丘造作房舍乞求无厌。邑人患苦。所以见仁皆悉逃走。迦叶食后。还到佛所以事白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言实尔世尊。佛种种呵责。汝等应修少欲知足。不应多事乞求无厌。又告比丘。乃过去世于恒水边有一仙人住于石窟。尔时龙王日从水出。以身七匝围绕仙人。舒头在上下向敬视。仙人后时游行人间。弟子守窟。龙亦如前日来恭敬。弟子怖畏即大羸瘦。我于尔时行菩萨道。游恒水边见其如此。即问其故。具答如是。我复问言。汝今欲不复见龙耶。答言尔。又问汝见龙咽下有何等物。答言有摩尼珠。吾复语言。龙若来时汝便合掌向龙。作如是语。我今须汝咽下摩尼。愿以施我。尔时仙人弟子。闻我语已。龙从水出便从索之。龙闻乞珠。不前不却默然而住。时仙人弟子。复为龙王说此偈言

  龙王今须汝　　咽下摩尼珠
  意甚爱乐之　　如何默无言

龙即以偈答

  我一切所须　　皆由此珠得
  汝今从吾乞　　永绝不复来
  如火急爆声　　使人心恐惧
  我今闻汝言　　惶怖踰于是

于是世尊引古说偈

  乞者人不爱　　数则致怨憎
  龙王闻乞声　　一去不复还

又告比丘。龙王受自然业报。犹尚不喜闻于乞声。今诸居士营求孜孜困苦所得。汝等云何数数从乞。又告比丘。吾昔一时在舍卫城。有比丘安居竟。来至我所。我时问言。何处安居。安居安隐乞食易得道路不疲耶。彼答我言。在雪山胁林下安居。安居安隐乞食易得行路不疲。唯患众鸟夜鸣所乱不得专一坐禅思惟。我问比丘。汝等今犹乐彼林不。答言甚乐。我言汝便还彼。众鸟暮来合掌向言。我今须汝毛羽。可以见与。中夜后夜亦复如是。比丘受教如敕从乞。于是众鸟夜共议言。今此比丘从我等乞。为当与不。皆曰不可。便飞而去。永不复还。告诸比丘。鸟犹不喜闻有乞声。况于人乎。又告比丘。过去世时有迦夷国王。好喜布施给诸穷乏。时有梵志王甚爱重。未尝从王有所求乞。尔时彼王。为说偈言

  人皆从远来　　无方从吾乞
  而汝今在此　　不求有何意

梵志即以偈答

  乞者人不喜　　不与致怨憎
  所以默无求　　恐离亲爱情

王复说偈

  智者不恶乞　　思闻来求声
  况汝所亲爱　　岂容有吝心
  守贫愧有求　　应得处不取
  丧人虚心福　　而自困于己
  安贫不耻求　　应得处便取
  既成人之善　　而自长安乐
  乞非伤德行　　亦无身口过
  损有以补无　　何为而不索

梵志复以偈答

  贤人不言乞　　言乞必不贤
  默然不有求　　是谓为大人

时王闻说贤人之偈。心大欢喜。即以牛王一头及余千牛而施与之。告诸比丘。王与梵志虽相爱重。犹难有求。况诸居士。于汝无爱而多求乎。又告比丘。昔有族姓子。名罗吒波罗。父母重爱自以出家。不从父母有所求索。时父母亦以偈问

  人皆从远来　　无方从吾乞
  汝亲吾爱子　　不求有何意

罗吒波罗。即以偈答

  乞者人不喜　　不与致怨憎
  我既已出家　　不应复有求

诸比丘罗吒波罗。父母爱重。尚以出家不还求索。况诸居士。于汝无亲而多求乎。如是种种呵责已告诸比丘。以十利故为诸比丘结戒。从今是戒应如是说。若比丘自乞作房。无主为身。应如量作。长佛十二砾手。广七砾手。应将诸比丘求作处。诸比丘应示作处。无难处有行处。若不将诸比丘求作处。若过量僧伽婆尸沙

自乞者。比丘为己从他乞。房者于中可得行立坐卧行四威仪。无主者。无有檀越。为身者。为己不为人亦不为僧。应将诸比丘求作处者。应将知法持律比丘示己作处。诸比丘应示作处无难处有行处者。难处名四衢道中多人聚戏处淫女处市肆处放牧处师子虎狼恶兽处崄岸处水汤湥处社树大树处好园田处坟墓处或逼村或去村远道路崄巇。是名难处。无此诸难是名无难处。有行处者。绕四边得通车。是名有行处。若有上诸难处无行处者。诸比丘应语彼比丘。汝莫取是处。若无上诸难处有行处。诸比丘应语是比丘。汝取是处。是比丘应从僧乞示作处。偏袒右肩脱革屣胡跪合掌。作如是言。大德僧听。我某甲比丘自乞作房无主为身。今从僧乞示作处。愿僧现前示我作处。如是三乞。僧中应一人白。大德僧听。此某甲比丘自乞作房无主为身。从僧乞示作处。今僧为某甲示作处无难处有行处。若僧时到僧忍听。白如是。大德僧听。此某甲比丘自乞作房无主为身。从僧乞示作处。今僧为某甲示作处无难处有行处。谁诸长老忍默然不忍者说。僧已为某甲示作处无难处有行处竟。僧忍默然故是事如是持。若僧示难处无行处。僧突吉罗。若于此处作者亦如是。若不将诸比丘示作处。从发心及治地至粗泥。皆突吉罗。细泥偷罗遮。作竟僧伽婆尸沙。杂金银珍宝作。及完成瓦屋。乃至僧地中作。皆偷罗遮。沙弥突吉罗(六戒竟)

五分律卷第二五分律卷第三(弥沙塞)

        宋罽宾三藏佛陀什共竺道生等译

    第一分之二第七事

佛在拘舍弥国。尔时阐陀比丘。常出入诸家为说法。料理官事疗治众病。国王大臣长者居士无不亲敬。有诸人等同来问讯。遇于经行所头面礼足。为说妙法示教利喜。已各归其家。阐陀便还。上座已据其房。如是展转乃至小房亦复如是。既不得住。便游人间。后诸人等复来问讯。见诸比丘露处经行。问言。我师阐陀今在何处。诸比丘言。我等不知。遍求不得。便各还归。阐陀行还。着衣持钵往到其家。皆出问讯。白言长老。我等近至僧房。不得相见。今从何来。答言我最下座。一切诸房上座已满。是故游行。致此乖互。诸人白言。可求屋处。我等当为长老作之。既以见福。而使长老得安隐住。又令我等不乖问讯。阐陀答言。我不能自作以废行道。年长自当以次得之。诸人又言。我幸有物及有善心。财物无常善心难保。愿为求处必欲作之。阐陀见其殷勤难相违逆。即便游行求作屋地。见神树处最可建立。即便伐之。此树有神国人所奉。诸祈请者多得如愿。忽见斫伐莫不惊怪。不信乐佛法者皆呵骂言。沙门释子无道之甚。苟欲自利伤害天人。信乐佛法者便言。此树有神众人畏敬。夙夜虔恭不敢堕慢。而诸比丘伐之无疑。一切色心晏安如故。可谓大神大贵可重。毁誉之声充满国内。诸长老比丘闻。种种呵责。将至佛所以事白佛。佛以是事集比丘僧。问阐陀。汝实尔不。答言实尔世尊。佛种种呵责已告诸比丘。以十利故为诸比丘结戒。从今是戒应如是说。若比丘有主为身作房。应将诸比丘求作处。诸比丘应示作处无难处有行处。若不将诸比丘求作处僧伽婆尸沙。有主者有檀越。余如上无主中说(七戒竟)

佛在王舍城。尔时瓶沙王。日日次请五百僧食城内。臣民亦复如是。时诸比丘各各行道。未有专知差次请者。六群比丘常往好处。诸人问言。我等为僧次第设食。何故长老常来不见余人。如是呵责。而犹不已。时陀婆力士子年十四出家为道。在静处作是念。今瓶沙王日日次请五百僧食城内。臣民亦复如是。而僧无有差次会者。致使六群选择好处以失众望丧人施意。若我二十受具足戒得阿罗汉获六神通。当为众僧作差会及分卧具人。至年十六便成罗汉得六神通年满二十受具足戒。便作是念。我先愿为众僧作差会及分卧具人。今时已至便应作之。即诣王舍城诸比丘所说先所愿。诸比丘即以白佛。佛以是事集比丘僧。问陀婆。汝实欲为僧作差会及分卧具人不。答言实尔世尊。佛种种赞少欲知足赞戒赞持戒已。告诸比丘。今听陀婆为僧作差会及分卧具人。僧应白二羯磨。差一比丘白言。大德僧听。今此陀婆比丘欲为僧作差会及分卧具人。若僧时到僧忍听。白如是。大德僧听。此陀婆比丘欲为僧作差会及分卧具人。谁诸长老忍默然若不忍者说。僧已听陀婆比丘作差会及分卧具人竟僧忍默然故。是事如是持

于是陀婆。即为僧作差会及分卧具。分卧具时。少欲知足少欲知足共。乐静乐静共。诵修多罗诵修多罗共。持律持律共。法师法师共。呗[口*匿]呗[口*匿]共。阿练若阿练若共。乞食乞食共。坐禅坐禅共。如是等众行不同。各得其类。随宜示导诸房舍处。一切比丘咸得所安。诸方比丘有暮至者。辄诣陀婆求住止处。陀婆即入火光三昧。左手出光右手示卧具处。莫不允合。时诸远方闻陀婆比丘。为王舍城僧差会及分卧具有如是德。皆作是念。我当往彼问讯世尊并见陀婆及睹神力。于是发来投暮到城。至陀婆所求住止处。陀婆皆悉如法安处。次差会人亦复如是

时王舍城有善饭长者。见法得果。日为二比丘作上美食自来请之。慈地兄弟并薄福德分。卧具差会时。常得粗恶阶次。幸遇差至其家。善饭知已便生是念。此等恶人无清净行。云何受我上美供养。即便还归语其妇言。汝可更作粗恶之食。慈地等来。门外敷座使婢下之。妇即受教。设办粗恶。慈地兄弟至时持钵到善饭家就座而坐。群婢于是持粗食出。慈地见便问言。姊妹汝家常作好食。今何故粗。婢言我是下人不知所以。食讫便还。道中行骂陀婆力士子。要当令汝受苦剧。我到所住已向诸上座言。陀婆力士子随爱嗔痴畏。若畏与好不畏与恶。诸比丘言。汝等莫作是语。陀婆比丘随爱恚痴畏。何以故。陀婆比丘得阿罗汉备六神通。随爱恚痴畏无有是处。慈地言。正以得神通故。观见诸家有好有恶。好与余人恶辄差我。是故我言。随爱恚痴畏。作是语已。出于余处。先为陀婆作恶名声。然后至王舍城。到其妹尼弥多罗所。弥多罗见二兄来。迎礼问讯。慈地兄弟皆不共语。弥多罗言。不忆犯。兄何故如此。慈地答言。汝不助我。故致使陀婆苦我如是。弥多罗言。兄欲令我云何相助。答言。汝若助我。可到佛所白言。世尊。无恐惧中反致怖畏。我今无处而得安隐。本谓陀婆是梵行人。忽来污我犯波罗夷。弥多罗言。陀婆清净。我若谤之。僧必当作自言摈我。我既出众。当何所依。慈地等言。我当证汝摈于陀婆。何缘使汝得自言摈。弥多罗言。若僧摈陀婆。我岂得异。慈地等言。但令世尊斥逐陀婆为吾受摈。亦复何苦。我等自当好相安处。妹敬重兄不敢违命。便到佛所如上白佛。尔时陀婆及罗睺罗在佛左右。佛问陀婆。汝闻弥多罗所说不。答言。已闻佛自知之。如是三问答亦如是。于是罗睺罗白佛言。世尊。何须三问陀婆。但当斥摈此比丘尼。佛言。若弥多罗。以此谤汝。汝当云何。答言。当言此事佛自知之。佛言。汝可如是。陀婆亦然乎。佛语陀婆。汝起自明。今非默时。汝当忆念。有当言有。无当言无。不得直言佛自知之。陀婆便从座起。更整衣服长跪合掌。白佛言。世尊。我从生来。未曾梦中有此念想。于今云何得有忆知。佛赞言。善哉善哉。汝快自明。欲自明者应当如此。佛告诸比丘。应与陀婆忆念比丘不应举事。应与弥多罗白四羯磨自言灭摈。一比丘唱言。大德僧听。此弥多罗比丘尼自言陀婆污我。僧今与自言灭摈。若僧时到僧忍听。白如是。大德僧听。此弥多罗比丘尼自言陀婆污我。僧今与自言灭摈。谁诸长老忍默然若不忍者说。如是第二第三。僧已与弥多罗比丘尼自言灭摈竟。僧忍默然故。是事如是持

弥多罗比丘尼被灭摈已。出游人间。慈地兄弟犹语诸比丘言。陀婆力士子坏我妹梵行故致使如是。诸比丘复以白佛。佛以是事集比丘僧。告诸比丘。汝等应捡问慈地。汝言陀婆坏汝妹梵行。为实为虚。诸比丘受教。即问慈地。慈地答言。我言是实。僧复问。汝何处见何时见云何见。答言。我某处见某时见如是见。僧次问陀婆。汝尔时为在何处。答言。我在某处。僧复语慈地。处不相应时不相应。汝云何言某处某时如是见耶。复语慈地。若于一坚信比丘前妄语。罪重伤杀无数众生。于一坚法其所获罪。过百坚信。如是展转于僧前妄语。其罪重于百阿罗汉。又语慈地。僧今集会。不随爱恚痴畏。汝可更说。为实为虚。慈地言。陀婆随爱恚痴畏故我作是语。诸比丘种种呵责。将至佛所以事白佛。佛以是事集比丘僧。问慈地。汝实以无根波罗夷谤陀婆不。答言。实尔世尊。佛种种呵责。汝愚痴人。云何以无根波罗夷谤于清净梵行比丘。汝岂不闻三种人堕地狱耶。一者犯戒无沙门法自言已有。不修梵行自言已修。于佛法中犹如败种。二者作如是见如是说淫欲非恶而为放逸。三者以无根波罗夷谤于清净梵行比丘。此三种人必堕地狱。汝今云何作此恶事。佛更种种呵责已。告诸比丘。以十利故。为诸比丘结戒。从今是戒应如是说。若比丘自不如法。恶嗔故。以无根波罗夷。谤无波罗夷比丘。欲破彼梵行。是比丘后时。若问若不问。言我是事无根住嗔故谤。僧伽婆尸沙

自不如法者自已事事不如法恶嗔者九恼也。无根者。不见不闻不疑。无波罗夷者。于四波罗夷一一无犯。欲破彼梵行者。欲使还俗若作外道。后时若问若不问者。后捡挍何处何时云何见也。事有四种。言诤事教诫诤事犯罪诤事事诤事。若比丘不见不闻不疑他犯波罗夷。若以此谤僧伽婆尸沙。见疑闻疑疑疑见忘闻忘疑忘。而以无根法谤僧伽婆尸沙。若面前谤解者僧伽婆尸沙。不解者偷罗遮。若书使相相似语手语谤解者偷罗遮。不解者突吉罗。若谤比丘尼式叉摩那沙弥沙弥尼突吉罗。比丘尼谤比丘尼僧伽婆尸沙。谤比丘波逸提谤式叉摩那沙弥沙弥尼突吉罗。式叉摩那沙弥沙弥尼谤五众皆突吉罗(八事竟)

佛在王舍城。尔时偷罗难陀比丘尼。以陀婆比丘神通大德故。数来问讯共一处坐听受法教。慈地见之复欲诽谤。后从耆阇崛山下。见二猕猴合会行欲。便作念言。我今当与彼二猕猴作假名字。雄者名陀婆。雌者名偷罗难陀。作是念已。便语诸长老比丘言。我先以无根法谤陀婆。今亲自见与偷罗难陀作不净行。诸比丘以是白佛。佛告诸比丘。应集僧捡问慈地。汝言先以无根法谤陀婆。今亲自见与偷罗难陀作不净行。为实为虚。诸比丘受教。集僧问慈地。乃至汝可更说。为实为虚皆如上说。如是问已。慈地言。我实不见陀婆作不净行。我见偷罗难陀数来往陀婆所。意欲谤之。从耆阇崛山下。见猕猴雄雌共合。我便假名雄者为陀婆雌者为偷罗难陀。故言亲见为不净行耳。诸比丘种种呵责。汝云何于异分中。取片若似片。作波罗夷。谤无波罗夷比丘。将至佛所以事白佛。佛以是事集比丘僧。问慈地。汝实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。以十利故。为诸比丘结戒。从今是戒应如是说。若比丘自不如法。恶嗔故。于异分中。取片若似片作波罗夷。谤无波罗夷比丘。欲破彼梵行。是比丘后时。若问若不问。言我是事异分中取片若似片法住嗔故谤僧伽婆尸沙

事者。言诤事教诫诤事。犯罪诤事事诤事。若比丘见他犯僧伽婆尸沙。定生僧伽婆尸沙想。嗔故。于异分中取片若似片。谤无波罗夷比丘。僧伽婆尸沙。闻疑亦如是。见闻疑他犯偷罗遮。犯波逸提犯波罗提提舍尼犯突吉罗。以波罗夷谤亦如是。余如上说(九戒竟)

佛在弥那邑阿[少/兔]林下。尔时贵族诸释种子。多于佛所出家学道。时释摩男。语阿那律言。今诸贵族并皆出家修于梵行。我等兄弟如何独不。我若出家汝知家事。汝若舍家我当断理。阿那律言。愿兄出家我知家事。释摩男言。汝先由我在家受乐不知艰难。然出家行道亦复辛苦。汝今住家。吾当语汝营家之法。便种种语之。昼应尔夜应尔。田商货殖驱役之法。悉以语之。阿那律言。若营家如此乃得成立。我乃不能一日为之。愿兄住家我当修道。释摩男言。诸佛世尊。父母不听不得为道。汝今自可启白于母。阿那律即便往启。我欲于佛法出家学道。母言。我唯有汝兄弟二人。爱念情重如何生离。汝家大富快修功德。何须出家夺吾此意。苦请至三。母乃答言。若跋提王出家者我亦听汝。时跋提王。与阿那律阿难难提调达婆婆金鞞卢等甚相爱重。若有所为誓不相违。于是阿那律。往白跋提王言。今有微愿。愿必见从王言。吾等本要誓不相违。若相违者头破七分。但令卿愿必可从耳。阿那律即以母言白王。王言。如卿此愿我未能从。所以者何。我愿作王今日始果。亲族富贵无有外忧。何能舍此出家学道。阿那律言。若王出家吾愿乃果。贪着宠荣吾则永沦。愿王三思不违先誓。王言。当从汝愿。宽我七年。然后共汝出家学道。阿那律言。却后七年佛不必在。又我危脆性命难保。王今云何以此为期。王复言。七年若远六年可乎。答亦如上五四三二至于一年。七月至于一月。七日至于一日。皆亦如是。王言。我等长者如何便得率尔而去。当设方便严驾出游因此微行乃可得耳。汝今便可语阿难陀等令知此意。阿那律即宣语五人。五人欣然莫逆于心。即便竟夜严四种兵。极世仪饰晨朝出游。尽游观已。密将剃头人优波离。舍诸傧从至隐僻处。宝衣与之。令其剃发变服而去。去未久优波离作是念。诸释豪强。若知剃诸人发。必当杀我。如此贵族尚能舍家。我今何为不舍剃具及诸宝衣随彼而去。即自剃头。以诸宝衣挂着树上。作是念须者取之。于是疾行须臾相及。语七人言。我今亦欲相随出家。七人即受。同诣佛所头面礼足。白言。世尊。我等今欲出家净修梵行。而优波离是我等仆。愿佛先与受具足戒。然后度我。当令我等及诸释种于彼人所破大憍慢。佛即先度七人后度。尔时世尊作是念。迦维罗卫去此不远。诸释知者或有留难。便将八人诣跋提罗城。住网林树下为说妙法。眼无常色无常眼识眼触眼触因缘生受无常乃至意无常法无常意识意触意触因缘生受无常。汝圣弟子。应作是观生厌离心得解脱智。所作已办梵行已立不受后身。说是法时。六人漏尽得阿罗汉。阿难侍佛不尽诸漏。调达一人空无所获。跋提王既得罗汉心净无畏。若在树下露坐经行。辄自庆言。快哉快哉。有异比丘。闻此声已作是念。跋提比丘必忆世乐不乐梵行。即往白佛。我向于彼闻跋提言快哉快哉。必忆为王时乐不乐梵行。佛告比丘。汝可呼来。便往语言。大师呼汝。跋提即到佛所。头面礼足却住一面。佛问跋提。汝实言快哉不。答言。实尔世尊。又问跋提。汝见何义而言快哉。跋提白言。我昔在家。住于七重城堑之里。七行象七行马七行车七行步四兵围绕。忽闻异声心惊毛竖。今在树下空露之地坦然无忧。是故称快。佛告比丘。跋提已得罗汉。不乐梵行无有是处。尔时世尊。因跋提而说偈言

  快哉阿罗汉　　无复恩爱缚
  已破欲恚痴　　无复诸结网
  既到于泥洹　　无有秽浊心
  不染着于世　　解脱无诸漏
  了达于五阴　　游于七法林
  大龙所行处　　已伏诸恐怖
  成就十种分　　龙德三昧禅
  一切有漏尽　　世间之第一
  不动无所畏　　不复受后身
  已息寂灭处　　永无苦乐报
  住于无学智　　此身最后边
  梵行坚固立　　无诸不可信
  天上天下中　　无复诸欲乐
  此名师子吼　　无能胜佛者

于是世尊。与诸大德声闻。受阿耨达龙王请。调达未得神通。不能得去羞耻益深。便作是念。我今当问修神通道。便往白佛。愿佛为我说修通法。佛即为说。调达受学。安居之中便获神通。获神通已作是思惟。谁应先化。复作是念。瓶沙王太子名曰众乐。先化导之。然后余人乃从我教。作是念已。即于网林下没。在太子床上现作小儿[口*數]指仰卧。太子见之即大惶怖。问言。汝为是天为是鬼神。答言。我是调达勿恐勿怖。太子语言。若是调达复汝本形。即自变复威仪如本。太子欢喜而师事之。日出问讯乘五百乘车。调达复化作五百小儿。在于车上仰卧[口*數]指。复以五百乘车载上美食种种肴膳而供养之。时诸国人。生希有心作是言。调达有大神力作此变化。使太子日出问讯。种种肴膳而以供养。于是调达遂不自量。便欲招引畜养徒众。尔时世尊。从网林出游行人间。到拘舍弥国住瞿师罗园。尔时目连住一别处。此国先有憍陈如子。名曰柯烋。净修梵行得阿那含果生于梵天。中夜寂静从天来下。放大光明诣目连所。头面礼足白言调达今化众乐太子现诸神变。恐其必欲招引徒众破和合僧。作是语已忽然不现。于是目连。晨朝整衣服往诣佛所以柯烋言具以白佛。佛问目连。汝意云何。当谓审如柯烋语不。答言。意以为然。佛告目连。莫说此语。所以者何。于天上天下。不见沙门婆罗门诸天魔梵有能领佛徒众者。又告目连。世间有五种师。今皆现在。一者戒不清净自言戒净。其诸弟子如实知之覆藏其过以望利养。二者邪命谄曲自言正直。而诸弟子亦覆藏之。三者所说不善自言善说。而诸弟子叹以为善。四者见不清净自言清净。而诸弟子称言见净。五者说非法律言是法律。而诸弟子亦云是法而不能使智者信受。目连。如来戒净无有谄曲。言无不善。知见清净。所说是法。智者信受。不须弟子共相称覆

尔时有异比丘。于王舍城安居竟。着衣持钵来诣佛所。白佛言。世尊。调达化众乐太子。现作小儿乃至种种肴膳而以供养。佛告比丘。莫羡调达作此变化。以致利养。若有恭敬供养之者。增其长夜受诸苦痛。犹如恶狗以杖打之更增其恶。调达如是。多得供养烦恼转增。尔时世尊。欲重宣此义。而说偈言

  愚人增其恶　　由于利养生
  痴断清白法　　犹如身首分
  不修清净行　　而志招学徒
  欲居众人上　　望一切归宗
  有人求利养　　或有求泥洹
  利养伤清白　　寂灭却悭贪

复告诸比丘。芭蕉竹芦以实而死。駏驉怀妊亦丧其身。今调达贪求利养。亦复如是。尔时世尊。欲重宣此义。而说偈言

  芭蕉以实死　　竹芦实亦然
  駏驉坐妊死　　士以贪自丧

于是世尊。从拘舍弥国渐渐游行。向王舍城住耆阇崛山。为比丘比丘尼优婆塞优婆夷国王大臣沙门婆罗门梵志居士。供养恭敬尊重赞叹衣食卧具及诸医药。无所染着犹如莲华。尔时世尊。与无央数大众围绕说法。调达便从坐起。更整衣服偏袒右肩。头面礼足胡跪合掌。白佛言。世尊。唯愿安住。我今自当领理众僧。佛语调达。舍利弗目连。犹尚不能领我徒众。况汝愚痴食涎唾乎。于是调达生忿恨心。云何世尊。于大众前乃作如此底下呵辱。以生恶心向佛故初损神足。复作是念。佛称赞舍利弗目连而毁呰我。复生恶心向舍利弗目连。是第二损其神足。便还所住。为国王大众围绕说法。其众中有一比丘。来白佛言。今调达为国王大众围绕说法。佛告比丘。调达不但今世得此大众。过去世时亦曾得此诸比丘。乃往古昔有一摩纳。在山窟中诵刹利书。有一野狐住其左右专听诵书。心有所解作是念。如我解此书语。足作诸兽中王。作是念已。便起游行逢一羸瘦野狐。便欲杀之。彼言何故杀我。答言我是兽王。汝不伏我。是以相杀。彼言。愿莫杀我。我当随从。于是二狐便共游行。复逢一狐。又欲杀之。问答如上。亦言随从。如是展转伏一切狐。便以群狐伏一切象。复以众象伏一切虎。复以众虎伏一切师子。遂便权得作兽中王。既作王已复作是念。我今为兽王。不应以兽为妇。便乘白象。帅诸群兽不可称数。围迦夷城数百千匝。王遣使问。汝诸群兽。何故如是。野狐答言。我是兽王。应取汝女。与我者善。若不与我当灭汝国。还白如此。王集群臣共议。唯除一臣。皆云应与。所以者何。国之所恃唯赖象马。我有象马彼有师子。象马闻气惶怖伏地。战必不如。为兽所灭。何惜一女而丧一国。时一大臣聪睿远略。白王言。臣观古今。未曾闻见人王之女与下贱兽。臣虽弱昧。要杀此狐。使诸群兽各各散走。王即问言。计将焉出。大臣答言。王但遣使克期。战日先当从彼求索一愿。愿令师子先战后吼。彼谓吾畏。必令师子先吼后战。王至战日。当敕城内皆令塞耳。王用其语。遣使克期并求上愿。至于战日复遣信求。然后出军。军锋欲交。野狐果令师子先吼。野狐闻之心破七分。便于象上坠落于地。于是群兽一时散走。佛以是事。而说偈言

  野狐憍慢盛　　欲求其眷属
  行到迦夷城　　自称是兽王
  人憍亦如是　　规统于徒众
  在摩竭之国　　法主以自号

告诸比丘。尔时迦夷王者我身是。聪睿大臣者舍利弗是。野狐王者调达是。诸比丘。调达往昔诈得眷属。今亦如是。舍利弗。汝往调达众中。作是唱言。若受调达五法教者。彼为不见佛法僧。舍利弗言。我昔已曾赞叹调达。今日云何复得毁訾。佛言。汝昔赞叹为是实不。答言是实。佛言。今应毁訾。而毁訾亦复是实。告诸比丘。今应白二羯磨差舍利弗往调达众中毁訾调达。一比丘唱言。大德僧听。今差舍利弗往调达众中。作是言。若受调达五法教者。彼为不见佛法僧。若僧时到僧忍听。白如是。大德僧听。今差舍利弗往调达众中。作是言。若受调达五法教者。彼为不见佛法僧。谁诸长老忍默然不忍者说。僧已差舍利弗竟。僧忍默然故。是事如是持

于是舍利弗。即往调达众中高声唱言。若受调达五法教者。彼为不见佛法僧。时彼众会皆悉唱言。沙门释子更相憎嫉。见调达多得供养。便作是语。时瓶沙王。在彼众中即宣令言。莫作此语。所以者何。佛众清净。无憎嫉故。于是调达。便语众人欲见天上曼陀罗华不。咸言欲见。调达即于众前没。到华池边。适欲取华便失神足。还在本坐。调达既失神足。便生恶心欲害于佛。白太子言。今汝父王正法御世如我所见衰丧无期。人命无常眴息难保。何必长年克此王位。自可图之早有四海。我当害佛代为法主。新王新佛于摩竭国共弘道化不亦善乎。太子答言。父母恩重过于二仪。顾复长育欲报罔极。汝今云何导吾此逆。调达闻之心无惭愧。犹以巧言引诱其意。遂便迷没受悦其语。太子后时。蜜带利剑向于王门。内怀恶逆不觉战怖。于王门前倒地复起。门官见已便作是念。太子常来威仪庠序。今日如此必当有故。即往问之。太子答言。我欲杀王是故如此。又问。太子为受谁教。答言调达。门官共议。当如之何。第一议言。一切沙门太子众乐皆应杀之。第二议言。佛已先遣舍利弗唱其恶逆。云何乃欲滥杀沙门。罪正应止太子调达二人而已。第三议言。我等不应辄判此罪。当以白王。王有教敕。当奉行之。作是议已便以白王。王问。汝等众臣议意云何。即具以上答。王即斥逐第一议者第二议者。免所居官。称第三议者加其名位。更命群臣共议此事。诸臣咸言。上第二议并谓允合。而王乃免所居之位。观王圣心不忍有害。正刑既弛当从下计。王立太子本为国嗣。志速为王故怀此逆。逊位与之其恶必息。议合王心即便舍位。拜之为王号阿阇世。初登王位受五欲乐。杀逆之心便得暂息。如是少时乃以无事而害父命

尔时阿阇世王。有大恶象。调达密至象师所语言明日瞿昙当行此路。汝可为吾饮象令醉放走于道。佛慢心多必不避之。因此蹋杀厚雇汝物。世尊明日食时着衣持钵。从五百弟子入城乞食。象师先已饮象令醉。遥见佛来即便放之。信乐佛法者见放醉象。皆往白佛。唯愿世尊。更从余路。五百弟子及阿难亦如是白。佛皆答之三言无苦。龙不害我。诸弟子众皆不觉舍佛从余路去。唯有阿难独从后行。时观者四塞。各各议言。今二龙斗看谁得胜。外道辈言。象龙力大必胜于人。佛弟子言。人龙道尊象必降伏。空辩无征。遂乃积敛金钱共赌胜负。于是醉象遥见佛来。奋耳鸣鼻大走向佛。阿难怖惧恍惚不觉入佛腋下。佛语阿难。汝向三闻无苦。如何不信犹作此惧。佛见象来。入慈心三昧。而说偈言

  汝莫害大龙　　大龙出世难
  若害大龙者　　后生堕恶道

象闻偈已。以鼻布地抱世尊足。须臾三反上下观佛。右绕三匝却行而去。从是已后遂成善象。莫不雅奇。同声叹言。瞿昙沙门不用刀杖伏此恶象。国中人民无复恐怖。何其快哉。诸外道辈皆悉惭愧。佛弟子众踊跃欢喜。敛得金钱七十余万。佛既降象。复说偈言

  象醉含嗔忿　　来向天中天
  百姓莫不观　　敛钱赌胜负
  其形如太山　　力胜六十象
  声响振人心　　一吼破敌阵
  大力天中天　　愍众出于世
  欲度恶象故　　住立在其前
  象伏众人见　　道俗皆踊跃
  叹佛降恶象　　犹如师子王

时调达见已作是念。今以此事不得害佛。当更求凶人不识佛者。厚相货诱令往杀之。即四出求索。见一壮夫。便语之言。汝为我杀佛。当厚相报。其人贪货应募而去。尔时世尊在露处经行。遥见彼人。以慈心三昧遍满其身。举手呼之。于是彼人不觉舍刀。疾行趣佛头面礼足。白佛言。我今痴狂。欲害世尊。自知过重。愿听忏悔。佛言。汝实愚痴。云何为货欲害如来。于我法中。若知有罪而忏悔者。增长善根。次为说法。所谓施论戒论生天之论。在家染累出要为乐。彼人内喜。佛知其意更为说法。所谓苦集尽道闻法开解。于诸法中远尘离垢得法眼净。见法得果已。自归三尊受持五戒。世尊发遣从异路归。调达复募二人。令杀前人以灭恶声。复遣四人。如是展转乃至三十二人。皆前至佛所。佛亦如前次第说法。尽得须陀洹果

时诸比丘闻调达遣人害佛。皆持器仗卫护世尊。分部相着各在一面。诸佛常法日再出房。于晨朝出见诸比丘。悉在左右。问言。汝等何故持仗住此。诸比丘言。闻调达遣人欲害世尊。不能自安。所以住此。佛告比丘若如来横死无有是处。世间五师须防护耳。我不须汝。各随所安自护其心

调达知已复作是念。我复不能以此害佛当更觅人躬自将去。故应必果。即得一人共上耆阇崛山。尔时世尊在山下石上经行。调达便使彼人推石害佛。其人发心推石四支便不得举。心念佛功德大手足还复。调达见此益嗔忿言。汝何儜困速疾灭去。即自捉大石推下害佛山下有神。名金鞞卢。接之远弃。片迸着佛伤足大指。世尊见已语调达言。汝今便得无间之罪。若以恶心出佛身血。必堕无间阿鼻地狱

调达复作是念。我既不能得害于佛。唯当破其和合僧耳。佛大神力。若我能破其僧。名必远振。佛知其意。语调达言。汝莫破和合僧。若僧已破能和合者。其人生天一劫受乐。若僧和合而破之者。堕地狱中一劫受苦。调达闻已暂舍是心。后寻复生如上所念。佛止如初。便说偈言

  众聚和合乐　　和合常安隐
  若破和合僧　　一劫地狱苦
  众聚和合乐　　和合常安隐
  若和合破僧　　一劫生天乐
  若分部分别　　常作不善语
  以破和合僧　　一劫地狱苦
  不分部分别　　常能说善法
  以和合破僧　　一劫生天乐

调达闻已复暂舍是心。后寻复生方便过前。时诸比丘闻。调达欲破和合僧。即往白佛。佛以是事集比丘僧。种种遥责调达已。语诸比丘。应差一比丘与调达亲厚者往谏言。汝莫破和合僧。莫作破僧事。当与僧和合。僧和合故欢喜无诤。一心一学如水乳合。共弘师教安乐行。若受者善。若不受应遣众多比丘。若复不受应僧往谏。诸比丘受教。如是三反皆悉不受。诸比丘种种呵责已。以是白佛。佛以是事集比丘僧。更种种遥责调达已。告诸比丘。以十利故。为诸比丘结戒。从今是戒应如是说。若比丘为破和合僧勤方便。诸比丘语彼比丘。汝莫为破和合僧勤方便。当与僧和合。僧和合故欢喜无诤。一心一学如水乳合。共弘师教安乐行。如是谏坚持不舍。应第二第三谏。第二第三谏。舍是事善。不舍者僧伽婆尸沙

为破者。求为破僧因缘。和合者。同布萨自恣羯磨常所行事。僧者从四人已上。彼比丘欲破僧。余僧见闻知。差一与亲厚比丘往谏。若舍者应一突吉罗悔过。若不舍应遣众多比丘往谏。若舍者应二突吉罗悔过。若复不舍应僧往谏。若舍者应三突吉罗悔过。若不舍复应白四羯磨谏一比丘唱言。大德僧听。此某甲比丘为破和合僧勤方便。僧已谏汝。莫为破和合僧勤方便。如是谏坚持不舍。僧今羯磨谏。若僧时到僧忍听。白如是。白已应语彼比丘。僧已白竟余。三羯磨在。汝当舍是事。莫犯僧伽婆尸沙。彼若舍应三突吉罗一偷罗遮悔过。若不舍复应唱言。大德僧听。此某甲比丘为破和合僧勤方便。乃至僧今羯磨谏。谁诸长老忍默然不忍者说。复应语彼比丘。僧已一羯磨竟。余二羯磨在。汝当舍是事。莫犯僧伽婆尸沙。彼若舍应三突吉罗二偷罗遮悔过。若不舍复应如上第二羯磨。第二羯磨竟。复应如上语。若舍应三突吉罗三偷罗遮悔过。若不舍复应如上第三羯磨。第三羯磨未竟。舍者三突吉罗三偷罗遮悔过。第三羯磨竟。舍不舍皆僧伽婆尸沙。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗。若白不成。三羯磨皆不成。若作余羯磨。遮羯磨非法羯磨。不谏自舍。皆不犯(十事竟)

佛在王舍城。尔时助调达比丘语诸比丘言。调达所说。是知说非不知说。说法不说非法。说律不说非律。皆是我等心所忍乐。诸长老比丘闻种种呵责。汝云何言。调达所说。是知说非不知说。说法不说非法。说律不说非律。皆是我等心所忍乐。呵责已以事白佛。佛以是事集比丘僧。种种遥责助调达比丘已。语诸比丘。应差一比丘与助调达比丘亲厚者往谏。莫言调达所说是知说非不知说。说法不说非法。说律不说非律。皆是我等心所忍乐。何以故。调达非知说非说法非说律。汝等莫助破和合僧。当助和合僧。僧和合故欢喜无诤。一心一学如水乳合。共弘师教安乐行。若受者善。若不受应遣众多比丘及僧往谏。诸比丘受教。如是三反。助调达比丘悉皆不受。诸比丘种种呵责已。以事白佛。佛以是事集比丘僧。更种种遥责助调达比丘已。告诸比丘。以十利故。为诸比丘结戒。从今是戒应如是说。若比丘助破和合僧。若一若二若众多。语诸比丘言。是比丘所说。是知说非不知说。说法不说非法。说律不说非律。皆是我等心所忍乐。诸比丘语彼诸比丘。汝莫作是语。是比丘所说。是知说非不知说。说法不说非法。说律不说非律。皆是我等心所忍乐。何以故。是比丘非知说不说法不说律。汝莫乐助破和合僧。当乐助和合僧。僧和合故欢喜无诤。一心一学如水乳合。共弘师教安乐行。如是谏坚持不舍应第二第三谏。第二第三谏舍是事善。不舍者僧伽婆尸沙。助破者。助成破僧因缘。和合者同布萨自恣。差一亲厚谏。若舍一突吉罗悔。乃至不谏自舍。皆如上说(十一竟)

佛在拘舍弥国。尔时阐陀比丘数数犯罪。入白衣舍上床下床皆不如法。别众食数数食非时入聚落不白善比丘。诸比丘见语言。汝犯如是。如是罪。汝应见罪悔过。莫不清净修于梵行。无得长夜受诸苦恼。勿令施主失大功德。答言。大德。汝等不应教我。我应教汝。何以故。圣师法王是我之主。法出于我无豫大德。譬如大风吹诸草秽并聚一处。诸大德等。种种姓种种家种种国出家亦复如是。云何而欲教诫于我。诸大德。莫语我若好若恶。我亦不语大德若好若恶。诸比丘复语阐陀。莫作自我不可共语。汝当语诸比丘若好若恶。诸比丘亦当语汝若好若恶。如是展转相教转相出罪成如来众。诸比丘如是谏。坚持不舍将至佛所。以事白佛。佛以是事集比丘僧。问阐陀。汝实尔不。答言。实尔世尊。佛种种呵责。汝愚痴人不应作不可共语。诸比丘见汝犯罪。欲不共汝布萨自恣羯磨常所行事。哀愍汝故呵谏于汝。汝今云何而不信受。佛种种呵责已语诸比丘。应差一比丘与阐陀亲善者往谏如上。次众多比丘次僧。诸比丘受教。三反不受。以是白佛。佛以是事集比丘僧。更种种遥责阐陀已。告诸比丘。以十利故。为诸比丘结戒。从今是戒应如是说。若比丘恶性难共语。与诸比丘同学经戒数数犯罪。诸比丘如法如律谏其所犯。答言。大德。汝莫语我若好若恶。我亦不以好恶语汝。诸比丘复语言。汝莫作自我不可共语。汝当为诸比丘说如法。诸比丘亦当为汝说如法。如是展转相教转相出罪成如来众。如是谏坚持不舍。应第二第三谏。第二第三谏。舍是事善。不舍者僧伽婆尸沙。恶性难共语者。不受教诲无恭敬心。自是非彼。同学经戒者。经谓一切佛教。戒谓波罗提木叉。差一亲厚谏若舍一突吉罗悔乃至不谏自舍皆如上说(十二竟)

佛在舍卫城。尔时吉罗邑有二比丘。一名頞髀二名分那婆。薮行恶行污他家。作种种非威仪事。自结华鬘亦教人结。自着教人着。与女人同床坐。共槃食饮酒啖肉歌舞伎乐。作诸鸟兽种种之声。亦作鸟兽斗诤时像蒱博嬉戏倒行掷绝弹指眴眼。向于女人角戾面目吐舌张口。作如是等身口意恶。破于戒见威仪正命。时五百比丘威仪具足。从迦夷国来到此邑。至时持钵入村乞食。诸居士见咸作是言。此诸比丘从何处来。低头默然状如孝子。不知与人交接言语。我此自有二贤比丘。多才多艺善悦人心。何用此辈久留邑里。并不与食空钵而出。时舍利弗目连。亦从迦夷来向此邑。頞髀等闻作是念。此二人来。必为我等作恶名声断我供养。便往语诸居士言。须臾当有二比丘来。一名目连。善知幻术现种种变。二名舍利弗。善知咒法巧言惑人。汝若同心不为彼惑。我当住此。若不能者正尔便去。诸居士言。长老安住。我终不为彼之所惑。二人既到。诸居士皆将大小迎逆问讯头面礼足却坐一面。于是目连为现神变。分身百千还合为一。石壁皆过履水如地。坐卧空中如鸟飞翔。身至梵天手扪日月。身上出火身下出水。身上出水身下出火。或现半身或现全身。东踊西没西踊东没。南踊北没北踊南没。中踊边没边踊中没。现神变已还坐本处。时诸居士窃相谓言。目连善知幻术。此则然矣。于是舍利弗为说妙法。初中后善善义善味具足清白梵行之相。说是法已默然而住。时诸居士亦复相语。舍利弗善知咒法。亦复验矣。于是众人都不信受。无有供养。尔时彼邑有二优婆塞。一名富阇。二名优楼伽。信乐佛法见谛得果。常好布施供养沙门。闻舍利弗目连从迦夷来。共出迎之头面礼足。为说妙法示教利喜。闻法已白舍利弗言。此邑有二比丘。常作种种非威仪事。广说如上。近有五百比丘。威仪庠序入村乞食。空钵而出唯愿大德。以此白佛。于是二人。为优婆塞更说妙法示教利喜已。还舍卫城。具以白佛。佛以是事集比丘僧。告阿难。汝往彼邑与二比丘作驱出羯磨。阿难白佛。彼恶比丘非沙门。自言沙门常作不净。心已败坏。我若独往。彼必肆恶随意恼我。佛告阿难。如是如是如汝所说。汝今便可将诸比丘随意多少到彼集众。然后乃举頞髀等罪。白四羯磨驱出彼邑。一比丘唱言。大德僧听。此某甲比丘行恶行污他家。行恶行皆见闻知。污他家亦见闻知。僧今驱出此邑。若僧时到僧忍听。白如是。大德僧听。此某甲比丘。行恶行污他家。行恶行皆见闻知。污他家亦见闻知。僧今驱出此邑。谁诸长老忍默然不忍者说。如是第二第三。僧已驱出某甲竟。僧忍默然故是事如是持。阿难受教。将五百比丘往到彼邑。诸居士闻阿难与五百比丘来。出迎问讯头面礼足。却坐一面。阿难即集众乃至羯磨。羯磨竟。彼二比丘犹故不去。诸比丘问。汝何故不去。答言。阿难等随爱恚痴畏。是故不去。何以故。有如是等同罪比丘。有驱者有不驱者。诸比丘言。汝莫说阿难等随爱恚痴畏。有如是等同罪比丘。有驱者有不驱者。汝等行恶行污他家。行恶行皆见闻知。污他家亦见闻知。汝出去不应住此。诸比丘如是谏。坚持不舍。以是事白佛。佛以是事集比丘僧。种种遥责彼比丘已语诸比丘。应差一与彼亲厚比丘往谏如上。次众多比丘次僧。诸比丘受教。三反不受。以是白佛。佛以是事集比丘僧。重遥责已告诸比丘。以十利故。为诸比丘结戒。从今是戒应如是说。若比丘依聚落住。行恶行污他家。行恶行皆见闻知。污他家亦见闻知。诸比丘语彼比丘。汝行恶行污他家。行恶行皆见闻知。污他家亦见闻知。汝出去不应此中住。彼比丘言。诸大德。随爱恚痴畏。何以故。有如是等同罪比丘。有驱者有不驱者。诸比丘复语言。汝莫作是语。诸大德随爱恚痴畏。有如是等同罪比丘。有驱者有不驱者。汝行恶行污他家。行恶行皆见闻知。污他家亦见闻知。汝舍是随爱恚痴畏语。汝出去不应此中住。如是谏坚持不舍。应第二第三谏。第二第三谏。舍是事善。不舍者僧伽婆尸沙

行恶行者。作身口意恶行。污他家者。令他家不复信乐佛法。见者眼自见。闻者从可信人闻。知者远近皆知。差一亲厚谏。若舍一突吉罗悔。乃至不谏自舍。皆如上说(十三竟)

五分律卷第三五分律卷第四(弥沙塞)

        宋罽宾三藏佛陀什共竺道生等译

    第一分之三不定法

佛在舍卫城。尔时跋难陀。常出入一居士家。晨朝着衣持钵往到其舍。敷尼师檀与居士妇独屏处坐。说淫欲粗恶语。时毗舍佉鹿子母。闻跋难陀与居士妇独屏处坐说淫欲粗恶语。念言。若居士还见。必生恶心向余比丘。使其长夜受诸苦痛。我当遣人往白世尊。即语常供养婆罗门那邻伽言。汝往佛所头面礼足广说此事。婆罗门即往白佛。佛为说种种妙法已发遣令还。佛以是事集比丘僧。问跋难陀。汝实尔不。答言。实尔世尊。佛种种呵责。如淫事中说已告诸比丘。以十利故。为诸比丘结不定法。从今是戒应如是说。若比丘共一女人独屏处可淫处坐。可信优婆夷见。于三法中一一法说。若波罗夷若僧伽婆尸沙若波逸提。若比丘言。如优婆夷所说。应三法中随所说法治。是名不定法

独者。一比丘一女人。更无第三人。屏处者。眼所不见处。可信者。见四真谛。不为身不为人。不为利而作妄语。优婆夷者。受三自归绝于邪道。不定者。若于三法中说一事。诸上坐比丘。应问是比丘。汝往彼家不。若言往未应治。复应软语问。汝与女人独屏处坐粗恶语行淫欲不。若言不。上坐下坐比丘。应切语问。汝实语莫妄语。如优婆夷说不。若言如优婆夷说。然后乃应随所说法治。沙弥突吉罗。第二不定法。与女人在露处坐。除若波罗夷。余皆如上说。露处者。眼所见处也

    五分律第一分之四舍堕法

佛在舍卫城。尔时世尊。教诸比丘唯畜三衣。而六群比丘食前食后晡时皆着异衣。诸比丘见问言。世尊不听畜长衣。汝不闻耶。答言。我亦闻之。但我此衣。或僧中得。或居士间得。或是粪扫衣。彼以着故与我。本不使我为五家畜。诸比丘种种呵责。将至佛所以事白佛。佛以是事集比丘僧。问六群比丘。汝实尔不。答言。实尔世尊。佛种种呵责。汝等不闻我先赞叹少欲知足衣裁蔽形食足支命耶。譬如众鸟毛羽自随。比丘如是三衣常俱。汝今云何畜积非法。种种呵责已。告诸比丘。以十利故。为诸比丘结戒。从今是戒应如是说。若比丘畜长衣过一宿尼萨耆波逸提

尔时诸比丘。若须一一衣。众僧羯磨。所应分物与之。时阿那律衣粗弊坏。诸比丘语言。汝衣弊坏。何不从僧取作使一日成。阿那律言。我不敢取。恐一日不成。犯尼萨耆波逸提罪

尔时波利邑诸比丘。来舍卫城欲后安居。时到不及。便于娑鞞陀邑结坐安居讫。十六日便进佛所。道经埿水。三衣粗重极大疲极。到礼佛足却坐一面。佛问诸比丘。安居和合乞食不乏道路不疲耶。答言。安居和合乞食不乏。我等先住波利邑。欲来此安居。多诸知识不得早发。欲及后坐而复不及。遂往娑鞞陀结坐安居讫。十六日便来。道经埿水。三衣粗重极大疲极。诸比丘因是具以阿那律事白佛。佛以是事集比丘僧。赞少欲知足赞戒赞持戒已。告诸比丘。从今听受迦絺那衣。得不犯五事。一者别众食。二者数数食。三者食前食后行至余家不白余比丘。四者畜长衣。五者别宿不失。三衣时。诸比丘作是念。佛以受迦絺那衣。听畜长衣。为得几时。念已白佛。佛言。受迦絺那衣时听畜。从今是戒应如是说。若比丘三衣竟舍迦絺那衣已。长衣过一宿尼萨耆波逸提。尔时阿难。得二张劫贝。为舍利弗故受。时舍利弗于异处住。阿难作是念。世尊不听畜长衣过一宿。舍利弗今不在此。此当云何。念已白佛。佛问阿难。舍利弗几日当还。答言。或十日或不至十日。佛以是事集比丘僧。种种赞少欲知足赞戒赞持戒已。告诸比丘。从今是戒应如是说。若比丘三衣竟。舍迦絺那衣已。长衣乃至十日。若过尼萨耆波逸提

三衣竟者。浣染缝竟。舍迦絺那衣者。白二羯磨舍。长者。三衣之外皆名长。衣者。劫贝衣。钦波罗衣野蚕绵衣纻衣麻衣。十日者。若一日得衣。应即日舍。若受持若施人若净施。若即日不舍。二日更得衣。应此日皆舍。若此日不舍。三日乃至十日更得衣。亦应此日皆舍。若此日不舍。至十一日明相出时。十日中所得衣皆尼萨耆波逸提。若有过十日衣。应舍与比丘僧。若与一二三比丘。不得舍与余人及非人。舍已然后悔过。若不舍而悔过者罪益深。除长三衣。若长余衣乃至手巾过十日皆突吉罗。比丘尼亦如是。式叉摩那沙弥。沙弥尼突吉罗。若净施不犯(一事竟)

佛在舍卫城。尔时十七群比丘。安居竟欲游行。作是念。我寻还此。一衣便足何须多为。作是念已。即便襆结余衣。置于架上。寄住比丘。于是而去。时六群比丘于他处还。语住比丘言。差房与我。时住比丘即差十七群所置衣房与之。六群比丘见架上衣问言。汝何以故畜此长衣。答言。此是十七群比丘安居竟游行人间不能持去留寄我耳。时六群比丘种种呵责以事白佛。佛以是事集比丘僧。问十七群比丘。汝实尔不。答言。实尔世尊。佛种种呵责。汝等愚痴。不闻我说。比丘应与三衣钵俱。譬如鸟飞毛羽自随耶。呵责已告诸比丘。以十利故。为诸比丘结戒。从今是戒应如是说。若比丘三衣竟。舍迦絺那衣已。三衣中若离一一衣。宿过一夜尼萨耆波逸提。尔时有一粪扫衣比丘。欲向娑竭陀邑。衣重不能持去欲舍。不知云何。以是白诸比丘。诸比丘将至佛所。以事白佛。佛以是事集比丘僧。告诸比丘。若比丘持粪扫衣重。欲游行余处。不能持去者。是比丘应从僧乞不失衣羯磨。脱革屣头面礼足胡跪合掌作是言。大德僧听。我某甲比丘欲游行某处。粪扫衣重不能持去欲留。今从僧乞不失衣羯磨。如是第二第三乞已。僧中一比丘唱言。大德僧听。此某甲比丘欲游行某处。粪扫衣重不能持去欲留。从僧乞不失衣羯磨。今僧与作不失衣羯磨。若僧时到僧忍听。白如是。大德僧听。此某甲比丘欲游行某处。粪扫衣重不能持去欲留。从僧乞不失衣羯磨。今僧与作不失衣羯磨。谁诸长老忍默然不忍者说。僧已与某甲比丘作不失衣羯磨竟。僧忍默然故。是事如是持。时诸比丘见世尊听羯磨离衣。便常作羯磨离衣宿。亦羯磨尽离三衣着弊坏衣行。长老比丘见问言。汝何故着弊坏衣行。答言。佛听羯磨离衣。是故我等常羯磨离衣宿。亦羯磨尽离三衣。诸比丘种种呵责。将至佛所以事白佛。佛言。汝等不应常羯磨离衣宿及羯磨尽离三衣。此二非法羯磨。比丘及僧二突吉罗。以此羯磨离衣宿。一衣一宿皆犯失衣罪。今听诸比丘羯磨留衣。前安居者九月日。后安居者八月日。不得羯磨留僧伽梨安陀会。听羯磨优多罗僧。有贼难处。三衣中割截衣最胜者。听随所留。从今是戒应如是说。若比丘三衣竟舍迦絺那衣已。三衣中若离一一衣。宿过一夜。除僧羯磨。尼萨耆波逸提

离衣者。园同界异界。屋同界异界。比丘尼精舍同界异界。聚落同界异界。重屋同界异界。乘同界异界。船同界异界。场同界异界。树下同界异界。露地同界异界。行道同界异界。园同界者。僧羯磨作不失衣界。而于中得自在往反。异界者。僧不羯磨作不失衣界。虽作而于中不得自在往反。屋比丘尼精舍聚落重屋亦如是。乘同界者。于中得自在。若取若举。异界者于中不得自在。若取若举。船亦如是。场同界者。践谷麦处得自在取。异界者。不得自在取。树下同界者。树荫所覆处。异界者。树荫不覆处。露地同界者。结加趺坐面去七尺。异界者。七尺之外。行道同界者。面去身七弓。异界者。七弓之外至明相出。时比丘还到界。乃至一脚入界不失衣。若口言我舍是衣亦不失衣。若不言舍。至明相出时。尼萨耆波逸提。比丘三衣外。余所受用衣。离宿突吉罗。比丘尼亦如是。式叉摩那沙弥沙弥尼。突吉罗(二事竟)

佛在舍卫城。尔时诸比丘。三衣竟舍迦絺那衣已得非时衣。诸比丘惭愧言。佛未听我等受非时衣。以是白佛。佛以是事集比丘僧。问诸比丘。汝等实得非时衣惭愧言。佛未听我等受非时衣不。答言实尔世尊。佛种种赞少欲知足赞戒赞持戒已。告诸比丘。从今听受非时衣。时六群比丘作是念。世尊听我等受非时衣。便多受不受持不施人不净施。诸比丘见问言。汝不闻世尊制不得畜长衣耶。答言。佛虽制畜长衣。而听受非时衣。又问。汝等一切时畜非时衣。不受持不施人不净施耶。答言如是。诸长老比丘种种呵责。以事白佛。佛以是事集比丘僧。问六群比丘。汝实尔不。答言实尔世尊。佛种种呵责。汝愚痴人。不应多求多欲。外道法中受者无厌。施者筹量。我正法中少欲知足。施者虽无厌。受者应少取。呵责已告诸比丘。若比丘得非时衣。不受持不施人不净施。乃至一宿突吉罗。尔时有一住处。诸比丘多得衣。受持施人净施。余段与诸比丘。诸比丘不受言。佛未听我等受不具足衣。语言且受。当足令足。时长老伽毗。得一狭短衣。日日舒挽欲令广长。佛常五日案行诸房。见伽毗牵挽衣。问言。汝作何等。答言。得此衣小不得受持。佛复问。汝更望得衣处不。答言有。又问几时可得。答言。若一月若灭一月。佛以是事。种种赞少欲知足赞戒赞持戒已。告诸比丘。从今听畜非时衣。不足望足至一月。佛既听畜非时不足衣。诸比丘便持此衣游行过一月。诸比丘见问言。佛不听畜非时不足衣过一月。汝等云何担此衣游行过于一月。种种呵责将至佛所。以事白佛。佛以是事集比丘僧。告诸比丘。以十利故为诸比丘结戒。从今是戒应如是说。若比丘三衣竟舍迦絺那衣已。得非时衣。若须应受速作受持。若足者善。若不足望更有得处令具足成。乃至一月若过。尼萨耆波逸提

非时衣者。舍迦絺那衣已。有所得衣。皆名非时衣。须者三衣中有故坏须以补易。望更有得处者。应更有得衣处望。一日乃至一月得。若比丘一日得不具足衣。即日有望若得应足成。受持若施人若净施。若不受持不施人不净施。至十一日明相出时。尼萨耆波逸提二日乃至十日亦如是。十一日有望。若得即此日应足成。受持若施人若净施。若不受持不施人不净施。至十二日明相出时。尼萨耆波逸提。乃至三十日亦如是。比丘尼亦如是。式叉摩那沙弥沙弥尼。突吉罗(三竟)

佛在舍卫城。尔时优善那邑。有年少居士出行游戏。见一女人名莲华色。色如桃华女相具足。情相敬重即娉为妇。其后少时妇便有身。送归其家月满生女。以妇在产不得附近。遂乃私窃通于其母。莲华色知便欲委之。绝夫妇道恐累父母。顾愍婴孩吞忍耻愧。还于夫家养女八岁。然后乃去至波罗奈。饥渴疲极于水边坐。时彼长者出行游观。见甚重爱。即问乡居父母氏族。今为系谁而独在此。莲华色言。我某氏女。今无所属。长者复问。若无所属。能为我作正室不。答言。女人有夫何为不可。即便载归拜为正妇。莲华色料理其家。允和大小夫妇相重。至于八年。尔时长者语其妇言。我有出息在优善那邑。不复债敛于今八年。考计生长乃有亿数。今欲往债与汝暂乖。妇言。彼邑风俗女人放逸。君往或能失丈夫操。财物粪土亦何足计。答言。吾虽短闇不至此乱。妇复言。若必宜去思闻一誓。答言甚善。便言。若我发此至还入门。一生邪心与念同灭。于是别去到于彼邑。债敛处多遂经年岁。去家日久思室转深。作是思惟。我当云何。不违先誓而遂今情。复作是念。我若邪淫乃负本誓。更取别室不为违要。于是推访。遇见一女。颜容雅妙视瞻不邪。甚相敬爱。便往求婚。父以长者才明大富。欢喜与之。债索既毕。将还本国安处别宅。然后乃归。晨出暮反异于在昔。莲华色怪之。密问从人。从人答言。外有少妇是故如此。其夫暮还。莲华色问。君有新室何故藏隐。不令我见。答言。恐卿见恨。是故留外。妇言。我无嫌妒。神明鉴识。便可呼归。助君料理。即便将还。乃是其女。母子相见不复相识。后因沐头谛观形相。乃疑是女。便问。乡邦父母姓族。女具以答。尔乃知之。母惊惋曰。昔与母共夫。今与女同婿。生死迷乱乃至于此。不断爱欲出家学道。如此倒惑何由得息。便委而去到祇洹门。饥渴疲极坐一树下。尔时世尊。与无央数众围绕说法。莲华色见众多人往反出入。谓是节会当有饮食。便入精舍。见佛世尊为众说法。闻法开解饥渴消除。于是世尊。遍观众会谁应得度。唯莲华色应得道果。即为说四真谛法苦集尽道。便于坐上远尘离垢得法眼净。既得果已。一心合掌向佛而住。佛说法已众会各还。莲华色前礼佛足长跪合掌白佛言。于佛法中愿得出家。佛即许之。告波阇波提比丘尼。汝今可度此女为道。受教。即度与出家受戒。勤行精进遂成罗汉。成罗汉已游戏诸禅解脱。颜容光发倍胜于昔。到时持钵入城乞食。一婆罗门见生乐着。心作是念。此比丘尼今不可得。唯当寻其住处方便图之。莲华色乞食毕。还安陀园入所住房。彼婆罗门。随后察之知其住处。后日时到复行乞食。彼婆罗门。于后逃入伏其床下。是日诸比丘尼竟夜说法。疲极还房仰卧熟眠。于是婆罗门。从床下出作不净行。比丘尼即觉踊升虚空。时婆罗门。便于床上生入地狱。莲华色因从空中往诣佛所。头面礼足以是白佛。佛问。汝当尔时。意为云何。答言。如烧铁烁身。佛言。如此无罪。复白佛言。独宿当有犯不。佛言。得道者无犯。时有群贼聚共议言。我等当于何处分物用易美食又得好色。咸言。此安陀园比丘尼住处必有好色亦当多有上美供养。往彼分物必得所欲。时彼贼帅信乐佛法。闻此不悦。即作是念。此诸人等。必当恼乱诸比丘尼。我当密遣一人先往告语。即便遣之语比丘尼言。暮当有恶人往。恐必相恼。幸可避去。诸比丘尼闻。即入舍卫城。彼城大臣。先以一宅施比丘僧。而无僧住。诸比丘尼暮到往宿。时彼群贼。夜入安陀园。都无所见。贼帅欢喜念言。比丘尼脱此艰难。何其快哉。即以最上衣盛满生熟上美饮食。悬着树枝。念言。若有得道神通比丘尼。取此衣食。于是莲华色比丘尼。如力士屈伸臂顷。从舍卫城往安陀园树上取之。明日食时。以所得食。为长老优波斯那及跋难陀设供。时至皆往。下种种食。食讫行水。取小床于众前坐。请说妙法。优波斯那。为说法已从坐而去。跋难陀留后。语莲华色言。姊妹何从得此美食。莲华色具以事答。跋难陀言。可示我衣。即以示之。跋难陀见便生贪着。即从索之。莲华色言。此不可得。何以故。女人薄福应畜五衣。跋难陀言。如人以象马布施不与鞍鞯。汝亦如是。云何种种肴膳供养。惜此一衣而不见与。如是无数方便苦索。遂不获已便持与之。跋难陀得衣还归所住。诸比丘见语言。汝福德人得此好衣。答言。我无福德。强说比丘尼仅乃得之。诸比丘闻。种种呵责。汝云何强说夺比丘尼衣

尔时世尊。患于四众来往愦闹。告诸比丘。我今欲三月入静室。不听有人来至我所。除一送食比丘。汝等亦当相与立制。奉教即立。从今不听辄至佛所。唯除一送食比丘。犯者波逸提。时长老优波斯那。不闻僧制。后到舍卫城问异比丘。佛在何房。比丘指示。即至房前以手叩房。佛自为开。前礼佛足却坐一面。佛问优波斯那。汝众清净威仪具足。云何教化而得如此。答言。若人从我求出家者。教行十二头陀。汝当尽形寿作阿练若乞食一坐食一种食一受食次第乞食冢间粪扫衣三衣随敷坐树下坐露坐。世尊。若人能尽形寿行如此法。得入我众。我与作师。佛叹言。善哉善哉。如汝可谓善教徒众。复问。汝知此众僧有制不。答言不知。何以故。我从佛闻。佛未制不得辄制。已制应奉行。佛具以上事语之。答言。我不能随僧制波逸提悔过。佛言。善哉如汝所说。时旧住比丘住立房前。待优波斯那出语言。汝犯僧制。应作波逸提悔过。答言。我犯何波逸提。诸比丘具说上事。答言。我不随僧制悔过。何以故。我亲从佛闻。佛若不制僧不得制。若佛制已僧不得违。于是佛自出。语诸比丘。从今若有阿练若比丘如优波斯那。听至我所。诸比丘闻已作是念。我亦当行此头陀可得辄至佛所。便各修行。时诸居士所设房舍供养。无复人受。以是白佛。佛语诸比丘。今听四众自在见我。时波阇波提比丘尼。闻佛此教。便与五百比丘尼来向佛所。中路逢优波斯那。优波斯那众中一比丘衣粗弊坏。问言。长老何故着此。答言无有余衣。比丘尼便指己衣语言。能着此不。答言能。又问。长老所著能与我不。答言能。即便易之。前至佛所头面礼足却坐一面。佛问瞿昙弥。汝何故着此弊坏衣。答以上事。佛为说法遣还所住。佛以是事集比丘僧。问彼比丘。汝实以粗弊衣与比丘尼易好衣不。答言。实尔世尊。佛种种呵责。汝愚痴人不应多欲。诸比丘因此。以跋难陀事白佛。佛问跋难陀。汝实尔不。答言。实尔世尊。佛种种诃责已。告诸比丘。以十利故为诸比丘结戒。从今是戒应如是说。若比丘从比丘尼取衣。尼萨耆波逸提。有诸比丘。有亲里比丘尼。多诸知识能得衣物。而诸比丘着粗弊衣。诸比丘尼问言。何故着此恶衣。答言。无有得处。语言何不就我取。答言。佛制不听就比丘尼取衣。诸比丘尼言。唯亲知可取知可与。愿以白佛。诸比丘即以白佛。佛以是事集比丘僧。种种赞少欲知足赞戒赞持戒已告诸比丘。从今是戒应如是说。若比丘从非亲里比丘尼取衣。尼萨耆波逸提。尔时舍卫城比丘比丘尼。共得衣施便共分之。或比丘宜着比丘尼得。或比丘尼宜着比丘得。诸比丘尼白诸比丘。与我易衣。答言。佛不听我取非亲里比丘尼衣。诸比丘尼言。以衣易衣如何言取。便往白佛。佛以是事集比丘僧。种种赞少欲知足赞戒赞持戒已告诸比丘。从今是戒应如是说。若比丘从非亲里比丘尼取衣。除贸易。尼萨耆波逸提

非亲里者。于父母乃至七世无亲。贸易者。彼此有益。又各随所宜。从式叉摩那沙弥尼取衣突吉罗。若亲里犯戒邪见。从取衣突吉罗。沙弥从比丘尼式叉摩那沙弥尼取衣突吉罗。若无心求自布施。知彼有长乃取。不犯(四竟)

佛在舍卫城。尔时跋难陀。晨朝着衣持钵。往偷罗难陀比丘尼所。坐起轻脱不觉露形。跋难陀见失不净。比丘尼知语言。长老与我衣浣。便脱与之。彼既得衣。即以不净自内形中。又诸比丘。亦与诸比丘尼衣。令浣染打。时诸比丘尼。以此多事。妨废诵读坐禅行道。诸白衣见。种种呵责言。诸比丘尼常以浣染打衣为业。与在家人有何等异。时波阇波提比丘尼。与五百比丘尼俱诣佛所。头面礼足却坐一面。佛问瞿昙弥。诸比丘尼手足何故尽有染色。具以事答。佛为诸比丘尼说妙法已。各还所住。佛以是事集比丘僧。问诸比丘。汝等实使比丘尼浣染打衣不。答言。实尔世尊。诸比丘因此以跋难陀事白佛。佛种种呵责已告诸比丘。以十利故为诸比丘结戒。从今是戒应如是说。若比丘使比丘尼浣故衣若染若打。尼萨耆波逸提。有诸老病比丘。不能自浣染打衣。有亲里比丘尼能浣染打。皆来从索欲为作之。诸比丘言。佛不听我等使比丘尼浣染打衣。诸比丘尼言。唯亲知可知不可。愿以白佛。诸比丘即以白佛。佛以是事集比丘僧。赞少欲知足赞戒赞持戒已告诸比丘。从今是戒应如是说。若比丘使非亲里比丘尼浣故衣若染若打。尼萨耆波逸提。故衣者。经体有垢若令浣浣。不染不打。若令染染。不浣不打。若令打打。不浣不染。若令浣染浣染。不打。若令浣打浣打。不染。若令染打染打。不浣。若令浣染打浣染打。皆尼萨耆波逸提。若令浣不浣而染。若令浣不浣而打。若令浣不浣而染打。皆突吉罗。令染不染而浣而打而浣打。令打不打而浣而染而浣染。令浣染不浣染而打。令浣打不浣打而染。令染打不染打而浣亦如是。若令非亲里浣染打而亲里浣染打。若令非亲里浣染打。而亲里非亲里共浣染打。若令亲里非亲里共浣染打。而亲里浣染打。若令亲里非亲里共浣染打。而非亲里浣染打。若令亲里非亲里共浣染打。而亲里非亲里共浣染打。皆尼萨耆波逸提。若衣未可浣染打。而令非亲里浣染打突吉罗。若令亲里浣染打。而非亲里浣染打不犯。余皆如取衣中说(五事竟)

佛在舍卫城。尔时城中有好衣长者。信乐佛法常往听受。时彼长者重着好衣。将诸傧从从城中出。问讯世尊及诸比丘。佛为说法示教利喜已。顶礼辞归。遇跋难陀。跋难陀复为说法。临别白言。长老明日见顾蔬食。答言。我不乏食。若无衣服。汝能与我身上一衣不。长者言当与。至家筹量。不得便相与。跋难陀言。我闻长者好喜布施。如何于我而独疏薄。又言。我说法能离生老病死忧悲苦恼。为度汝等废不营已。汝今云何惜此一衣。于是长者即脱与之。去至城门。守门者问。汝向重衣出而今轻还。为与女人为遇劫夺耶。答言。我不与女人亦不遇劫。为沙门释子所强乞耳。守门者言。莫作是语。我闻沙门释子少欲知足。若人布施尚不肯受。如何于今强乞人物。答之如上。有不信乐佛法者。闻便唱言。快正应夺。汝若更亲近当复剧。是沙门释子常叹布施毁不与取。而今强夺人衣物。何异于劫。长者还家。家中问答亦皆如上。诸长老比丘闻。种种呵责已。将至佛所以事白佛。佛以是事集比丘僧。问跋难陀。汝实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。以十利故为诸比丘结戒。从今是戒应如是说。若比丘从居士居士妇乞衣。尼萨耆波逸提。尔时诸比丘着粗弊衣。诸亲里见语言。何以着此坏衣。不从我取。答言。佛不听我等就居士居士妇乞衣。可以与僧。当从僧取。诸亲里言。我正欲与比丘。不欲与僧令余人得。诸比丘言。若佛听我从亲里居士居士妇乞衣者。亦当不着如此弊恶。诸亲里言。唯亲知可与知可取。愿以白佛。诸比丘即以白佛。佛以是事集比丘僧。告诸比丘。从今是戒应如是说。若比丘从非亲里居士居士妇乞衣。尼萨耆波逸提。尔时众多比丘随估客行。失道遇劫剥夺。赤肉裸形而还向舍卫城。行者问言。汝是何人。答言。我是沙门释子。复问。汝衣钵何在。答言。为劫所夺。进到祇洹。诸比丘问答亦如是。又问。汝若是比丘。云何受戒布萨自恣。答言。如是受戒布萨自恣。诸比丘竟不与衣。便至佛所。佛呵责言。汝等何以裸形见佛。岂不能得树叶及草以蔽身耶。告诸比丘。从今裸形至佛前者突吉罗。诸比丘白佛。佛不听我从非亲里居士居士妇乞衣。我等亲里去此甚远。云何得衣。佛言。汝等已到旧比丘所未。答言已到。又问何以不与汝衣。答言。诸比丘方共见问。云何受戒布萨自恣。虽如法答。犹不见与。佛遥呵责旧住比丘。云何眼见比丘裸形。而不经恤。为失衣比丘。赞少欲知足。赞戒赞持戒已。告诸比丘。从今是戒应如是说。若比丘从非亲里居士居士妇乞衣。除因缘。尼萨耆波逸提。因缘者。夺衣失衣烧衣漂衣衣坏。是名因缘。若夺衣乃至衣坏。故有余衣。及有衣在余处。皆不得乞。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(六竟)

佛在舍卫城。尔时众多比丘从波利邑来向佛所。遇劫失衣共作是言。佛虽听五事因缘得从非亲里居士居士妇乞衣。我今不知当从谁乞。时六群比丘作是念。此诸比丘失衣。不知从谁乞。我当为索。若有长者当自取之。念已。即以是语语失衣比丘。失衣比丘言大善。于是六群比丘。遍语城中诸居士居士妇言。有诸比丘从波利邑来。欲觐世尊。遇劫失衣。汝等可共减割施之。诸居士居士妇闻已。各各减割大得衣服。人人皆足。失衣比丘言。我等已足不须更乞。六群比丘言。汝等有乞衣因缘。而我等无听。我以汝因缘更有所乞。失衣比丘言。随长老意。时六群比丘复更遍乞。得衣甚多。时诸居士集共议言。失衣比丘未有几人。我等城中男女大小减割布施已应过足。何以复索。将无欲以积畜贩卖货易不修梵行耶。时诸长老比丘闻。种种呵责。以事白佛。佛以是事集比丘僧。问六群比丘。汝实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。以十利故为诸比丘结戒。从今是戒应如是说。若比丘夺衣失衣烧衣漂衣衣坏。从非亲里居士居士妇乞衣。若居士居士妇欲多与衣。是比丘应受二衣。若过是受。尼萨耆波逸提。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(七竟)

佛在舍卫城。尔时跋难陀。常出入一居士家为说法。疾病官事皆为料理。有一比丘。晨朝着衣持钵入城乞食。遇到此家。闻其夫妇共议。跋难陀于我有恩。当以如是衣直作衣与之。彼比丘乞食还。语跋难陀。汝有福德。跋难陀言。有何福德。答言。我今乞食到某居士家。闻夫妇共议。跋难陀于我有恩。当以如是衣直作衣与之。汝今往彼必得无疑。跋难陀明旦食时。着衣持钵往到其家。居士即出问讯。跋难陀言。汝为我以如是衣直作衣耶。答言如是。跋难陀言。汝自知我不着恶衣。若作好衣我当自着。常忆念汝疾病官事。当相料理。若不好者当与弟子。或藏器中。徒去此物无施用福。时彼居士语左右言。此人无厌难养难满。我发心所与。五倍六倍犹不惬意。先虽厚善于今薄矣。遂不与之。时诸长老比丘闻。种种呵责。将至佛所以事白佛。佛以是事集比丘僧。问跋难陀。汝实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。以十利故为诸比丘结戒。从今是戒应如是说。若比丘非亲里居士居士妇共议。当以如是衣直作衣与某甲比丘。是比丘先不自恣请。便往问居士居士妇言。汝为我以如是衣直作衣不。答言如是。便言。善哉居士居士妇。可作如是衣与我。为好故。尼萨耆波逸提

先不自恣请者。先不问比丘为须何衣。为好者。求令极好胜先所许。若从亲里索好衣突吉罗。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(八竟)

佛在舍卫城。跋难陀。复有常出入家。其夫妇共议。我当各为跋难陀以如是衣直作衣与之。乞食比丘闻复语之。跋难陀即往。问居士居士妇言。我闻汝等为我各以如是衣直作衣。为实尔不。答言如是。跋难陀言。可合作一衣令极好。若极好我当自着。常忆念汝。若不好者当置器中。徒去此物无施用福。时居士居士妇便大嗔言。此人无厌难养难满。虽求合作一衣。而于我发心所许。五倍六倍犹不惬意。如此恶人不足存在。于是不听复得来往。时诸长老比丘闻。种种呵责。将至佛所以事白佛。佛以是事集比丘僧。问跋难陀。汝实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。以十利故为诸比丘结戒。从今是戒应如是说。若非亲里居士居士妇共议。我当各以如是衣直作衣与某甲比丘。是比丘先不自恣请。便往问居士居士妇言。汝各为我以如是衣直作衣不。答言如是。便言。善哉居士居士妇。可合作一衣与我。为好故。尼萨耆波逸提。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(九事竟)

佛在王舍城。尔时王舍大臣。语左右人言。汝往跋难陀所。以我名字作礼问讯。持此衣直而供养之。使受敕。至跋难陀所语言。某甲大臣问讯起居。送此衣直供养大德。大德受之。跋难陀言。我不应受此衣直。若得净衣当手受持。使言。大德。有执事人不。跋难陀即指示处。使便到执事人所语言。某甲大臣送此衣直与跋难陀。汝为受作。来取便与。使既与已。还跋难陀所白言。大德所示执事人。我已与竟。大德须衣便可往取。白已便还。大臣后时。复更遣信问跋难陀。我近遣使送衣直付某执事。大德为已着此衣未。跋难陀言。我未取着。还白如此。大臣作是念。我作衣已。久而犹未取。必薄我衣故致如此。即复遣信语跋难陀言。我送衣已。久何故不着。若不须者可以还我。跋难陀言。我甚须之。便于非时。到执事人所语言。我今须衣。可以见与。答言小待。今众人会。我应往赴。若不及期。便应罚我金钱五百。跋难陀言。汝常信乐勤于法缘。今日何故忽重俗事彼闻此语便作是念。正使彼罚要当付衣。然后乃去。即便料理与之。事毕星驰已遂稽后。众人问言。汝来何晚。答言。跋难陀索衣。料理还之。所以致此。众人咸言。为一比丘而轻众制。理不可恕。即便罚之彼既得罚。便嗔恨言。沙门释子。自言有道利益于物。而今乃反令我得罚。不信乐佛法者。咸皆语言。汝信敬沙门致此重罚。若复亲近方当剧是。恶名流布遍舍卫城。诸长老比丘闻。种种呵责。将至佛所以事白佛。佛以是事集比丘僧。问跋难陀。汝实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。以十利故为诸比丘结戒。从今是戒应如是说。若王若大臣婆罗门居士。为比丘故遣使送衣直。使到比丘所言。大德彼王大臣婆罗门居士。送此衣直。大德受之。是比丘言。我不应受衣直。若得净衣当手受持。便言。大德有执事人不。比丘即指示处。使便到执事所语言。某王大臣。送此衣直与某甲比丘。汝为受作。取便与之。使既与已。还比丘所白言。大德所示执事人。我已与竟。大德须衣便可往取。是比丘二返三返。到执事所语言。我须衣我须衣。若得者善。若不得。四返五返六返到执事前默然立。若得者善。若过求得者。尼萨耆波逸提。若不得衣。随使来处。若自往若遣信。语言。汝为某甲比丘送衣直。是比丘竟不得。汝还自索莫使失。是事应尔。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(十竟)

佛在舍卫城。尔时众僧多得缕施。即共分之。诸比丘用缝僧伽梨优多罗僧安陀会一切余衣。又作腰绳禅带乃至户纽。犹故不尽。时六群比丘便雇织师织作一衣。犹有余缕。复更雇作綖少不足。便行求乞。长者居士悉皆与之。于是六群比丘作是念。我得善利。从今但当恒作此业。便多乞缕。一切织师悉皆雇织。时有居士。诣一织师雇织作衣。答言。我已许比丘。不得复作。遍诣余处皆亦如是。于是居士便嗔骂言。沙门释子少欲知足。而今遍雇一切织师。无有厌足。与世贪人有何等异。无沙门行破沙门法。诸长老比丘闻。种种呵责以事白佛。佛以是事集比丘僧。问六群比丘。汝实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。以十利故为诸比丘结戒。从今是戒应如是说。若比丘自行乞缕。雇织师织作衣。尼萨耆波逸提。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(十一竟)

佛在舍卫城。尔时跋难陀。常出入一估客家说法治病。估客语妇言。跋难陀于我有恩。可以此缕雇织师作衣。我还当与。行后妇便持缕诣织师所雇令作之。语言。筹量令足勿使少长。跋难陀闻即往其家。妇出问讯言。我夫教我为大德作衣。我已雇人令作。跋难陀言。汝雇谁作。答言某甲。跋难陀便往织师所语言。汝知不。此衣为我作。汝好织令致广。自当少多私相报。织师言。彼妇语我。筹量令足我今云何。令得致广。跋难陀言。但好作之。若綖不足。持我意索。自当与汝。织师随语用尽往索。估客妇言。我先语汝。筹量令足。何故复索。织师具以事答。妇便更与。估客行还。问妇言。我先令汝为跋难陀作衣。为已作未。答言已作。可取来看。妇即取示。衣甚致好。问言。用少许缕那得如此。答言。跋难陀更来取缕。所以得尔。估客便嗔骂言。跋难陀难养难满无有厌足。如我本意此衣数倍。先虽有恩于今绝矣。遂不与之。如是恶声流布远近。长老比丘闻。种种呵责。将至佛所以事白佛。佛以是事集比丘僧。问跋难陀。汝实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。以十利故为诸比丘结戒。从今是戒应如是说。若居士居士妇。为比丘使织师织作衣。是比丘先不自恣请。便到织师所作是言。汝知不。此衣为我作。汝好为我织令极致广。当别相报。后若与一食若一食直。得者。尼萨耆波逸提。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(十二竟)

佛在舍卫城。尔时跋难陀。语弟子达摩言。今欲与汝游行到拘萨罗国。达摩言。彼寒无衣不能得去。跋难陀言。若能去者当与汝衣。达摩言。先与我衣然后当去。即便与之。既得衣已便不肯去。跋难陀言。汝言得衣当去。如何得衣而复不肯。若不能去以衣还我。达摩言。师已见施云何复索。跋难陀言。我非施汝。欲共游行故相与耳。汝今不去。欲以何理而不还我。便强夺之。彼即高声大哭。长老比丘问。汝何故哭。答言。师夺我衣。诸比丘种种呵责跋难陀。云何名比丘。强夺人衣。答言。我欲共行至拘萨罗国以衣雇之。彼既得衣便不肯去。是以取之。非为强夺。诸比丘复种种呵责达摩。汝云何欺师。索衣许行。得而不去。便将二人同至佛所。以事白佛。佛以是事集比丘僧。问跋难陀。汝实以衣与弟子还夺取不。答言。实尔世尊。佛复问达摩。汝实诳师不。答言。实尔世尊。佛种种呵责二比丘已告诸比丘。以十利故为诸比丘结戒。从今是戒应如是说。若比丘与比丘衣。还夺尼萨耆波逸提。尔时六群比丘与诸比丘衣。复使沙弥守园人夺。诸比丘问言。汝不闻佛制与比丘衣不得还夺耶。答言闻我今使沙弥守园人夺。不违佛教。诸比丘言。自夺教人。有何等异。种种呵责已。以事白佛。佛以是事集比丘僧。问六群比丘。汝实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。从今是戒应如是说。若比丘与比丘衣。若自夺若使人夺。尼萨耆波逸提。有诸客比丘。寄旧住比丘衣。行还日久。恐犯此戒。不敢复索。复有诸比丘在路行。寄比丘衣。行路既远。恐犯此戒亦不复索。或有已索便生惭愧。谓犯此戒作舍堕悔过者。诸比丘以是白佛。佛以是事集比丘僧。问诸比丘。汝实尔不。答言。实尔世尊。佛种种赞少欲知足。赞戒赞持戒已。告诸比丘。若索寄衣犯舍堕者。无有是处。从今是戒应如是说。若比丘与比丘衣。后嗔不喜。若自夺若使人夺。作是语。还我衣不与汝。尼萨耆波逸提。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(十三竟)

五分律卷第四五分律卷第五(弥沙塞)

        宋罽宾三藏佛陀什共竺道生等译

    初分舍堕法下

佛在王舍城。尔时众多居士。共请佛及僧。其中有破薪者取水者扫洒地者敷坐具者布华者敷高座者办具食者。时跋难陀晨朝着衣持钵。先往请家至诸人所。随其所为而赞叹之。复语言。汝今所作欢喜善好。诸人言。我实欢喜作诸供养。务令饮食种种甘美。亦当以衣布施众僧。跋难陀言。众人施僧衣物甚多。汝若复施。正当积聚成无用物。何为徒去有用之福。而不与我。若与我者。我当自着恒相忆念。疾病官事当相料理。诸人闻已。便共集议。其中有言。若僧不须可以施之。使我等得施用之福。或复有言。本为施僧。如何复得回与一人。言与者众遂便与之。时跋难陀担重担衣还归僧坊。诸比丘叹。汝福德人。如何暂出乃得此衣。跋难陀言。巧辩所获非福德也。即便具说得衣所由。谓长老比丘闻种种呵责。汝愚痴人。云何回与僧物而自入己。时彼居士食具已办。遣使白佛。于是世尊着衣持钵。与比丘僧前后围绕。往诣其家就座而坐。诸居士手自下食。食毕行水而无布施。先不欲与跋难陀者。窃共议言。我等今日食无不备。某等无故。持施僧物独与一人。阙此达嚫。宁无惭愧。诸比丘问。汝等窃语。为何所说。具以事答。诸比丘种种呵责跋难陀汝愚痴人。云何回与僧物自以入己。尔时世尊为诸居士说妙法已。从坐起去。诸长老比丘以是白佛。佛以是事集比丘僧。问跋难陀。汝实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。以十利故为诸比丘结戒。从今是戒应如是说。若比丘回与僧物入己。尼萨耆波逸提。有诸比丘。不知是与僧物回以入己。后知生惭愧。或已悔过。以是白佛。佛以是事集比丘僧。赞少欲知足。赞戒赞持戒已。语诸比丘。若不知与僧物而回入已。犯舍堕者无有是处。从今是戒应如是说。若比丘知檀越欲与僧物回以入己。尼萨耆波逸提。

知者。若自知若从他闻。欲与僧物者。若人发心作是语。我当持此物与彼众僧。若回欲与僧物与余人。波逸提。与余僧比丘尼僧二部僧四方僧与塔皆突吉罗。若回欲与比丘尼僧二部僧四方僧物亦如是。若回欲与塔物入己。与比丘僧比丘尼僧。二部僧四方僧余人余塔皆突吉罗。若回欲与人物亦如是。乃至回与此畜生一搏饭。与彼畜生亦突吉罗。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗。若白僧僧与。若施主自回欲与僧物。与已不犯(十四竟)

佛在王舍城。尔时毕陵伽婆蹉住楞求罗山。飞在空中涂洒所住房。时瓶沙王往至彼山。毕陵伽见王来。忽还在地。白言。善来大王。可就此坐。王坐已问言。何故自作。无守园人耶。答言无。王即语一臣。可给此比丘守园人。毕陵伽言。佛不听我畜守园人。王言。可以白佛。王去之后。便以白佛。佛以是事集比丘僧。赞少欲知足赞戒赞持戒已。告诸比丘。从今听诸比丘畜守园人。王所敕臣。不信乐佛法。竟不与之。毕陵伽亦不从索后。时着衣持钵入城乞食。王与群臣楼上遥见。便生是念。我先许彼比丘守园人。不知得未。即问前所敕臣。臣言未与。王复问言。五敕来几日。臣言。已五百日。王言。随此日数与之。大臣奉教。即以五百家家一人与之。时五百家。日差一人扫除房舍承受所为。时彼村人至节会日。男女庄饰衣服璨丽出行游戏。有一贫女。行大啼哭。时毕陵伽入村乞食。见女啼哭。问其母言。汝女何故啼哭如是。答言。今日诸人皆盛服饰出行游戏。我家贫穷不及于人。是以悲哭。时毕陵伽见牛啖草。语其母言。取少草来。即取与之。毕陵伽便结草。变成二金华鬘。与彼女母。语言。天下有二种金胜。阎浮檀金。及神足所化。汝可持此与女令着。彼女得已极大欢喜。便着出入。人无不羡。时有一人。见生憎嫉。即白瓶沙王言。某村某家得好伏藏。其女所著华鬘天下无比。大王后宫之所未有。王即呼语汝得伏藏可以示我。答言。我实不得。王复问。汝女所著何处得之。答言。是毕陵伽结草化作。王闻是语极大嗔怪。云何化草得成金鬘。便敕有司收系着狱。毕陵伽后时复至彼村。见先女人方大啼哭。问言。汝今何故复大啼哭。答言。家亲在狱。问言。为何等罪。答言。由大德施金华鬘。语言莫哭。我当为汝令寻得出。毕陵伽即便先往典狱官所。典狱官见皆问讯言。大德。何故抂屈来此。答言。守园人系在狱。我所以来。汝今可为放出之不。答言。此人得好伏藏不以示王。若以示王乃可得出。毕陵伽言。我结草作。非是伏藏。彼人言。结草作金无有是处。毕陵伽即变其所坐皆作金床语言。汝今自见坐于何座。即皆自见坐金床上。便大惶怖。下床叩头。愿见垂恕。速为解之。若王闻我坐金床上。必重见罪。毕陵伽言。放守园人然后解汝。彼言。此不见由。问言由谁。答言由王。毕陵伽即为灭已。飞往王所住于空中。时王在高楼上。见即作礼问言。大德以何故来。答言。守园人系在狱。我所以来。愿为放出。王言。彼人得好伏藏。若以示我乃得出耳。毕陵伽言。我结草作。非是伏藏。王言。结草作金无有是处。时毕陵伽便以杖叩王楼柱。即化成金楼。问言。王此高楼用何物作。王见欢喜即敕放之。毕陵伽如是展转四现神足。时诸人民闻见神变。于佛法众。生信乐心。施僧前食后食怛钵那非时浆洗浴众具涂身涂足及然灯油。尔时众僧多得生熟酥油蜜石蜜。食不能尽。积聚在地处处流漫。污埿衣服床席卧具。诸居士见问言。此是谁物。有人答言。是沙门释子之所蓄积。诸居士言。沙门释子自言节食。积聚如此恣意啖之。此等为求解脱离生老死。而今但求如此美味。无沙门行破沙门法。诸长老比丘闻。种种呵责以事白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。从今不听食宿受酥油蜜石蜜。犯者突吉罗。时众多比丘病。不能得净人从日日受。亦无钱直又无买处。诸比丘不知云何。以是白佛。佛以是事集比丘僧。赞少欲知足。赞戒赞持戒已。告诸比丘。从今听诸病比丘食宿受酥油蜜石蜜乃至六夜。时诸比丘复过六夜。长老比丘种种呵责。以是白佛。佛以是事集比丘僧。问诸比丘汝等实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。以十利故为诸比丘结戒。从今是戒应如是说。若比丘病。得服四种含消药。酥油蜜石蜜。一受乃至七日。若过尼萨耆波逸提

若一日得受。二日更得受。至七日更得受。留至八日。明相出时。皆尼萨耆波逸提。应白舍与僧。僧舍与白衣沙弥。若用然灯。若用涂足。唯舍药比丘不得用。一切比丘不得啖。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(十五竟)

佛在舍卫城。尔时有八月贼。常伺捕人杀以祠天。一切人民及诸比丘。无不惊怖。祠日垂至。而未有所获。贼共议言。阿练若处必有比丘。取之易得。即往一处。诸比丘闻。各各逃走。贼无所得。复共议言。当至余处。不得懈惰以失祠日。时彼众中有一罢道者。语众人言。我闻佛教。不听比丘离衣一宿。但共守之向晓必还。众人言。若彼不还便当杀汝。汝若不恨吾等当住。答言甚善。于是群贼便住。时诸比丘。惧犯离衣宿罪。后夜悉还。贼问言。汝谓吾已去耶。答言。我知汝在。佛不听我离衣宿。是故还耳。贼即杀之。须血取血须肉割肉。余不死者作是念。世尊若听我等未满八月日寄一一衣着界内白衣家者不遭此难。以是白佛。佛以是事集比丘僧。赞少欲知足。赞戒赞持戒已。告诸比丘。从今听诸阿练若处比丘安居三月未满八月寄一一衣着界内白衣家离宿无罪。有诸比丘近聚落住。亦寄一一衣着界内白衣家离宿。诸比丘以是白佛。佛言。不听近聚落住离衣宿。复有比丘于阿练若无恐怖处离衣宿。诸比丘以是白佛。佛言。亦不听阿练若无恐怖处离衣宿。有疑恐畏然后乃听。时诸比丘寄衣他家。都不往视。日久湿秽虫啮腐烂。诸比丘以是白佛。佛言。应往视晒。时诸比丘便数数往。居士恶厌。诸比丘以是白佛。佛言。听十日一视。时诸比丘有僧事塔事和尚阿阇梨事及以他事。须出界外。为衣故不敢出。以是白佛。佛言。若有事要须自出界外。听离衣一宿。诸比丘出界外一宿。其事未毕复还白佛。佛言听六宿。既听六宿。诸比丘便着粗弊衣行过六宿者。长老比丘以是白佛。佛以是事集比丘僧。问诸比丘。汝实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。以十利故为诸比丘结戒。从今是戒应如是说。若比丘住阿练若处。安居三月未满八月。若处有恐怖。听寄一一衣着界内白衣家。若有因缘出界外。离此衣宿乃至六夜。若过尼萨耆波逸提

安居三月者。前安居。未满八月者。后安居。一一衣者。若僧伽梨若优多罗僧。随所重寄一衣。不得寄安陀会。以着身故。礼拜入僧乞食。不得单着故。不得寄二。有因缘出界外六宿者。若有塔事和尚阿阇梨及以他事。留一一衣白衣家出界外极至六宿。若一宿二宿乃至五宿。事讫不还突吉罗。沙弥突吉罗(十六竟)

佛在舍卫城。尔时毗舍佉鹿子母。请佛及僧明日设食。其日正遇天恐怖雨。其雨如力士屈伸臂顷。便满一钵地受此水。如一渧油落热沙聚。若不尔者浩成大海。佛告诸比丘。如今祇洹中雨。遍阎浮提亦复如是。汝等可出于中洗浴。此是最后平等之雨。诸比丘即出雨中裸形而浴。时毗舍佉。遣婢白佛。食具已办。婢至祇洹。见诸比丘皆裸形浴。作是念。此是外道非是比丘。还白如是。毗舍佉作是念。必是比丘露地洗浴。痴婢不知。谓是外道。即复遣言。汝至祇洹门作如是唱。食具已办唯圣知时。婢即复往至祇洹门。欲如敕唱。时诸比丘浴竟还房不见一人。复作是念。向满中外道今不复见。即便还归。复白如此。毗舍佉复作是念。必是比丘浴竟宴息。复更遣言。汝可入门于庭中唱。即复受教。入祇洹门庭中唱之。佛闻唱声告诸比丘。毗舍佉已白时到。汝等皆着衣持钵。共受彼请。诸比丘奉敕。尽集普会讲堂。婢方进前更白佛言。食具已办唯圣知时。佛言。汝可先去当随后到。于是世尊如力士屈伸臂顷。与诸比丘没普会讲堂。踊出毗舍佉所敷座上衣服不湿。毗舍佉见佛及僧忽然在座衣服不湿作是念。我得善利。供养如是圣师及圣弟子。天雨洪注而衣服不湿。欢喜踊跃。种种美食手自下之。食毕行水。叉手合掌在一面立。白佛言。愿世尊与我愿。佛告毗舍佉。佛于世间诸愿永离。毗舍佉复白言。愿佛与我清净可得之愿。佛言大善。毗舍佉白佛言。世尊。我晨朝遣婢白食具已办。见诸比丘皆裸形浴。便还语我。祇洹中尽诸外道。无有比丘。世尊。云何比丘于和尚阿阇梨前裸形浴。愿佛听诸比丘畜雨浴衣。我当尽命供给舍卫城诸比丘雨浴衣。又言。我近小缘至阿夷罗河。见诸比丘尼在于河中裸形洗浴。时人见之咸形笑言。女人着衣犹尚无好。况出家人而裸形体。愿佛亦听诸比丘尼畜水浴衣。我亦尽命供给舍卫城诸比丘尼水浴衣。又言。佛说有三种病。一种得药不得药死。二种得药不得药差。三种得药差不得药死。愿听诸比丘服诸药。我亦尽命供给舍卫城诸比丘药。又言。佛说三种病。一种得随病食不得随病食死。二种得随病食不得随病食活。三种得随病食活不得随病食死。愿听诸比丘食随病食。我亦尽命供给舍卫城诸比丘随病食。又言。看病人若乞食则有所废。愿听诸比丘受看病人食。我亦尽命供给舍卫城看病人食。又言。客来比丘行路疲极始至不知何处乞食。愿听诸比丘受我客比丘食令息疲极知乞食处。我亦尽命供给舍卫城客比丘食。又言。若有远行比丘入村乞食便不及伴至迥道中或遇八月贼或失道径。愿听远行比丘受我远行食。我亦尽命供给舍卫城远行比丘食。又言。我闻世尊听阿那频头国诸比丘食粥。愿听诸比丘受我粥。我亦尽命供给舍卫城诸比丘粥。又白佛言。愿世尊。受我尽命衣食汤药。佛问毗舍佉。汝见何义利索是九愿。答言。此国当有诸方比丘来问讯世尊。若云彼处某甲比丘命过得须陀洹斯陀含阿那含阿罗汉。我当问之。彼比丘曾来此不。答言曾来。我作是念。彼比丘必曾受我乃至一种供养。便生欢喜增益善根。于是世尊语毗舍佉。听汝八愿。一愿不可得。时毗舍佉取小床于佛前坐。佛为说随喜偈

  欢喜施饮食　　佛及圣弟子
  设福破悭贪　　受报常欣乐
  生天寿命长　　还此离染尘
  行法之大果　　长处净天乐

尔时世尊更为说。种种妙法。示教利喜。还祇洹集诸比丘。赞少欲知足。赞戒赞持戒已告诸比丘。从今听诸比丘受雨浴衣诸比丘尼受水浴衣。受随病药。随病食。看病人食。客比丘食。远行比丘食及粥。时诸比丘作是念。佛听我等畜雨浴衣。便常乞畜。不受持不施人不净施。担重担衣行。诸比丘见问言。汝不闻佛制畜长衣耶。答言。佛虽有制。而听畜雨浴衣。诸比丘又问。汝等常畜雨浴衣。不受持不施人不净施耶。答言如是。诸长老比丘种种呵责。以是白佛。佛以是事集比丘僧。问诸比丘。汝实尔不答言。实尔世尊。佛种种呵责已告诸比丘。以十利故为诸比丘结戒。从今是戒应如是说。若比丘春余一月。应求雨浴衣。余半月应持。若未至一月求先半月持。尼萨耆波逸提

雨浴衣者。雨浴时用。夏浴时亦用。若至春余一月。先有许施雨浴衣者。知识比丘应为往语言。今是缝染作雨浴衣时。若得者善。若不得应更为语。诸处皆已缝染作雨浴衣。若得者善。若不得复应为语。汝先许与某比丘雨浴衣。今正是时。若得者善。若不得彼比丘应更余处乞畜至八月半百三十五日持。若过此不作余衣。不受持不施人不净施突吉罗。沙弥突吉罗(十七竟)

佛在舍卫城。尔时六群比丘到估客村。估客言。长老住此安居。我等行还当施安居物。六群比丘言。欲令我住便可施我。我安居中作衣。安居竟着问讯佛。估客共议。我等先施安居物。比丘当住。家中大小得闻法言。受八分戒净身口意。便敛物与之然后乃行。时六群比丘得安居施物。估客去后便至余处。时诸估客得利还归。语家人言。我先虽施诸比丘安居物。今既得利安隐来还。当更供养。汝等安意听法。家人答言。诸比丘。行后便去。诸估客更于近处请诸比丘。诸比丘答言。汝可供养先所请者。我等不得受汝供养。时诸估客便嗔恚言。我本自施住此安居。受物而去与偷何异。诸长老比丘闻。种种呵责以是白佛。佛以是事集比丘僧。问六群比丘。汝实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。从今不听于安居内受安居施。犯者突吉罗。尔时波斯匿王边境有贼。违乙师达多富兰那往讨伐之。二人共议。我等今行或能没命。当共出物供养比丘。即持财物诣比丘所语言。我今讨贼。恐不得还。以此物施。愿为受之。诸比丘作是念。世尊不听我等安居内受安居施。不知云何。以是白佛。佛以是事集比丘僧问阿难言。自恣余几日。答言。余十日。佛种种赞少欲知足。赞戒赞持戒已告诸比丘。从今听诸比丘前后安居未至自恣十日受急施衣。佛既听受急施衣。诸比丘便常畜。不受持不施人不净施。檐重檐衣处处游行。诸长老比丘见问言。汝不闻佛制畜长衣耶。答言。佛虽有制而听受急施衣。诸比丘又问。汝等常畜急施衣。不受持不施人不净施耶。答言如是。诸长老比丘种种呵责。以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。从今不听常畜急施衣。不受持不施人不净施听至衣时。既听至衣时。诸比丘犹过衣时畜。长老比丘以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。以十利故为诸比丘结戒。从今是戒应如是说。若比丘前后安居十日未至自恣得急施衣。若须应受乃至衣时。若过尼萨耆波逸提。急施衣者。若军行若垂产妇。如是等急时施。过时不复施。衣时者。受迦絺那衣时。舍迦絺那衣已。名非衣时。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(十八竟)

佛在舍卫城。尔时跋难陀从一估客非时乞钵。语言。我今须钵。可以见与。答言。大德小待。今诸估客会。若不及者罚金钱五百。跋难陀言。我闻汝精进供给行道。而今云何舍功德业先于俗事。估客闻已作是念。正使被罚要当先施。便为买钵与之乃往。遂不及期。众人见已皆言应罚。估客言。我不以私违众人制。沙门从我乞钵。不能得舍。故不及耳。不信乐佛法者皆言。为一沙门公违众制。正应苦罚即便罚之。估客既被罚已。便嗔恚言。沙门释子不知时宜。小待不肯。使我被罚。诸人种种讥呵。此辈沙门常说知时少欲知足。而今非时强从人乞。无沙门行破沙门法。诸长老比丘闻。种种呵责。以是白佛。佛以是事集比丘僧。问跋难陀。汝实尔不。答言。实尔世尊。佛种种呵责已。问诸比丘。于意云何。钵无缀是钵不。答言是。复问。一缀乃至五缀是钵不。答言是。告诸比丘。无缀一缀乃至四缀是钵。五缀非钵。以十利故为诸比丘结戒。从今是戒应如是说。若比丘钵未满五缀。更乞新钵。为好故。尼萨耆波逸提

是钵应僧中舍。僧应取众中最下钵与之语言。汝受是钵乃至破。是法应尔。钵有三种。铁钵苏摩钵瓦钵。复有三种上中下。上者。受三钵他饭除羹菜。下者。受一钵他饭除羹菜。中者。上下之中。为好者。求牢求胜。若已有无缀钵乃至四缀钵。更乞无缀。至四缀得者。皆尼萨耆波逸提。若已有无缀钵乃至四缀钵。更乞五缀钵。得者皆突吉罗。应僧中舍者。所得新钵。应舍与众僧。不得舍与一二三人舍法。应到僧中白言。大德僧听。我某甲比丘有钵未满五缀。更乞新钵犯舍堕。今舍与僧。白如是。僧应白二羯磨差知法比丘于僧中行之。一比丘唱言。大德僧听。此某甲比丘钵未满五缀。更乞新钵。今舍与僧。僧今差某甲比丘作行钵人。若僧时到僧忍听。白如是。大德僧听。此某甲比丘钵未满五缀。更乞新钵。今舍与僧。僧今差某甲比丘作行钵人。谁诸长老忍默然不忍者说。僧已差某甲比丘作行。钵人竟。僧忍默然故。是事如是持。是比丘应唱使诸比丘各持钵出。然后持所舍钵至上座前问。须是钵不。若言须应取上座钵看。若无钵若太大若太小若穿缺若喎斜不应与。若无五事应与。与竟取上座钵行。从第二上座乃至新受具足戒人前亦如是。僧应取最后钵与舍钵比丘。若行钵都无人取听还与之。僧应教言。此是汝钵。好爱护之。莫着地。莫用除粪扫。莫用盛残宿食。莫用暖汤。莫用盛香。莫用盛药。如是爱护。若破者听汝更乞。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(十九竟)

佛在舍卫城。尔时跋难陀多得诸钵。五六日用便举置。如是故钵处处皆有。诸长者见问言。谁积聚此。有人言。是跋难陀。诸长者言。沙门释子常说少欲知足。而今无厌。收敛积聚如贩钵人。无沙门行破沙门法。诸长老比丘闻。种种呵责。将至佛所。以是白佛。佛以是事集比丘僧。问跋难陀。汝实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。以十利故为诸比丘结戒。从今是戒应如是说。若比丘畜长钵至一宿尼萨耆波逸提。尔时有一比丘。独得二钵作是念。佛不听我畜长钵一宿。即持一钵施余比丘。施后钵破。无钵游行。诸比丘问言。汝先得二钵今何故无。答以上事。诸比丘以是白佛。佛以是事集比丘僧。问彼比丘。汝与他钵。几日后钵破。答言十日。佛赞少欲知足。赞戒赞持戒已告诸比丘。从今是戒应如是说。若比丘长钵乃至十日。若过尼萨耆波逸提。得二钵应问和尚阿阇梨。此二钵何者胜。若和尚阿阇梨不善分别。应各五日用。自知胜者受持。不如者与人。沙弥突吉罗(二十竟)

佛在阿荼髀邑。尔时诸比丘为身作憍赊耶卧具。自作亦使人作。自担茧亦使人担。自煮亦使人煮。诸居士见作是言。我等煮茧。比丘亦尔。沙门释子与我何异。此等常说慈忍众生。而今亲自煮茧。无沙门行破沙门法。有一比丘。以成擘野蚕绵。倩诸比丘作卧具。绵少不足。便到绵家语言。我卧具绵少。少多布施。彼人答言。未有成绵。比丘复言。可为我作。彼人即于比丘前煮茧蛹动作声。比丘教言按着汤中。彼人即呵骂言。汝常说不杀生法。而今教人杀生。无沙门行破沙门法。诸长老比丘闻种种呵责。以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。以十利故为诸比丘结戒。从今是戒应如是说。若比丘新憍赊耶作卧具。尼萨耆波逸提

憍赊耶者。蚕所作绵。卧具者。卧褥乃至始成三振不坏。名为卧具。应舍与僧。不得舍与余人。僧以敷地若敷绳床及卧床上。除舍褥比丘。余一切僧随次坐卧。发心欲作及方便皆突吉罗。作成尼萨耆波逸提。虽不自作不使人作。他施而受。尼萨耆波逸提。沙弥突吉罗(二十一竟)

佛在拘舍弥城。时众多跋耆子用纯黑毛氊光泽可爱。皆悉以为服饰卧具跋耆诸比丘亦效作之。时诸居士入房观见便大畏怖。谓是跋耆豪族游集。便问行人。此是何等贵人服饰。答言。非贵人物。是跋耆比丘许耳。诸居士便讥呵言。诸比丘如国王如大臣如豪族。乘车马时之所服饰。我闻比丘着割截衣求无为道。而今如此。无沙门行破沙门法。诸长老比丘闻种种呵责。以是白佛。佛以是事集比丘僧。问彼比丘。汝实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。以十利故为诸比丘结戒。从今是戒应如是说。若比丘纯黑羺羊毛作新卧具。尼萨耆波逸提

纯黑者。生黑及染黑。应舍与僧。僧以敷绳床卧床上。不得敷地。余如憍赊耶卧具中说(二十二竟)

佛在拘舍弥城。尔时跋耆诸比丘作黑羺羊毛卧具着少白色及下色毛。便言已净时诸长老比丘见问言。汝不闻佛制纯黑羺羊毛作卧具耶。答言闻。但我已着白色及下色毛。非复纯黑。诸比丘言。纯黑少杂何足为异。种种呵责。以是白佛。佛以是事集比丘僧。问彼比丘。汝实尔不。答言。实尔世尊。佛告诸比丘。从今听诸比丘作卧具用二分纯黑羺羊毛。第三分白第四分下。以十利故为诸比丘结戒。从今是戒应如是说。若比丘作新卧具。应用二分纯黑羺羊毛第三分白第四分下。若过是作。尼萨耆波逸提。若比丘作四十波罗卧具。应用二十波罗纯黑十波罗白十波罗下。若黑长一波罗。尼萨耆波逸提。余如纯黑羊毛卧具中说(二十三竟)

佛在拘舍弥城。尔时跋耆诸比丘作是念。佛听我等用二分纯黑羺羊毛第三分白第四分下作卧具。便多乞三色毛自作使人作。于所住处无处不有。诸居士来看见。而问言。此是谁物。答言跋耆比丘。诸居士讥呵。如长钵中说。长老比丘闻种种呵责。以是白佛。佛以是事集比丘僧。问彼比丘。汝等实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。以十利故为诸比丘结戒。从今是戒应如是说。若比丘作新卧具。应六年畜。未满六年若舍若不舍。更作新卧具。尼萨耆波逸提。尔时一比丘畜粪扫卧具见中利。欲从舍卫城至娑竭陀邑。卧具重不能持去。不知云何。以是白诸比丘。诸比丘将到佛所。以是白佛。佛以是事集比丘僧。告诸比丘。此比丘欲至娑竭陀邑。卧具重见中利不能舍。复不能持去。僧应白二羯磨与易轻者。彼比丘应从僧乞言。我某甲比丘。自畜卧具见中利。今欲游行某处。以重故不能持去。愿僧与我易僧轻者。如是第二第三乞。僧中应一比丘白。大德僧听。此某甲比丘自畜卧具见中利。今欲游行某处。以重故不能持去。从僧乞易轻者。僧今与易。若僧时到僧忍听。白如是。大德僧听。此某甲比丘自畜卧具见中利。欲游行某处。以重故不能持去。从僧乞易轻者。僧今与易。谁诸长老忍默然不忍者说。僧已与某甲比丘易僧轻卧具竟。僧忍默然故。是事如是持。从今是戒应如是说。若比丘作新卧具。应六年畜。未满六年若舍若不舍。更作新卧具。除僧羯磨。尼萨耆波逸提。六年者。数日满六年。余如纯黑羊毛卧具中说(二十四竟)

佛在拘舍弥城。尔时诸跋耆子。作纯黑羺羊毛尼师檀。跋耆比丘亦乞作之。诸居士厌患乞索。后日到僧房看。见诸比丘多畜纯黑羺羊毛坐褥。便讥呵。如纯黑卧具中说。诸长老比丘闻。以是白佛。佛以是事集比丘僧。问彼比丘。汝等实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。以十利故为诸比丘结戒。从今是戒应如是说。若比丘纯黑羺羊毛作新尼师檀。应用故尼师檀一修伽陀磔手坏好色。若不坏。尼萨耆波逸提。一修伽陀磔手者。方二尺。坏好色者。随意覆新者上。余如纯黑羊毛卧具中说(二十五竟)

佛在舍卫城。尔时诸比丘担负羊毛随路行。路人见之皆讥呵言。我等家累担负羊毛。诸比丘亦复如是。徒着坏色割截衣剃头乞食。与我何异。无沙门行破沙门法。有一比丘。山居串乐担负羊毛道路疲极。既至僧坊庭中倒地。诸比丘见谓是鬼着。即以小便洒之。彼言。长老何以见洒。答言。恐见鬼着是以洒耳。彼言。我非鬼着。担羊毛重道路疲顿热闷故耳。诸比丘言。佛制比丘畜三衣钵。譬如飞鸟与毛羽俱。汝岂不闻而犹担此。种种呵责。以是白佛。佛以是事集比丘僧。问彼比丘。汝实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。以十利故为诸比丘结戒。从今是戒应如是说。若比丘担羊毛道路行。尼萨耆波逸提。时有居士为僧作一房。念言。若比丘来此房中者。我当供养亦给施衣。有一比丘来止其房。便施羊毛。比丘不受。居士言。我集羊毛。本为比丘不自为身。比丘答言。佛不听我自担羊毛。如何得受。复有比丘须羊毛作卧具。自不知作。欲倩余比丘。而不敢受。以是白佛。佛以是事集比丘僧。问彼比丘。所欲倩人去此远近。答言。去此三由旬。于是世尊赞少欲知足。赞戒赞持戒已。告诸比丘。从今是戒应如是说。若比丘得羊毛。须持有所至。若自持乃至三由旬。若过尼萨耆波逸提。比丘得羊毛须持有所至。应使净人担。若无净人乃听自持。不得担担头戴背负。犯者突吉罗。沙弥突吉罗。不犯者。三由旬内。若展转持。若有人代。若于三由旬持反。及持五六波罗。为作腰绳帽綖等(二十六竟)

佛在舍卫城。尔时诸比丘使比丘尼浣染擘羺羊毛。诸比丘尼为供养故不敢辞惮。便多事多务妨废读诵坐禅行道。诸居士见闻讥呵。波阇波提比丘尼与五百比丘尼俱。往到佛所亦如上浣故衣中说。于是世尊以是事集比丘僧。问诸比丘。汝等实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。以十利故为诸比丘结戒。从今是戒应如是说。若比丘使比丘尼浣染擗羺羊毛。尼萨耆波逸提。尔时诸比丘有亲里比丘尼。亦如上浣故衣中说。即以白佛。佛以是事集比丘僧。赞少欲知足。赞戒赞持戒已。告诸比丘。从今是戒应如是说。若比丘使非亲里比丘尼浣羺羊毛。若染若擗。尼萨耆波逸提。余如上浣故衣中说(二十七竟)

佛在舍卫城。尔时跋难陀种种贸易能得人利。而人无能得其利者。有一外道得未成衣。持到外道家语言。为我缝成。诸人答言。我家多务不得作之。沙门释子闲逸无事又多施衣。可就借倩亦可贸易。然彼沙门常能强得大名估客。汝往宜慎。于是外道持至僧坊访。问言。谁能为我缝此衣者。皆言不能。又白跋难陀。我闻大德多已成衣。可以一衣与我贸不。答言。汝诸外道。心不坚正变悔无常。既得便言贵贱不等。若后无言当以相与。答言。余人或尔。我终不悔。于是跋难陀以浊染汁染粗劫贝湿打致密而以与之。彼得衣已还外道众。外道问言得成衣不。答言。已得贸易。取来看之。彼即出示。诸外道见咸言。咄哉去大价衣得此弊服。非是五倍六倍之挍。可还取之。当共废事为汝缝成。彼即持还。语跋难陀言。汝释种子。云何以此弊服欺诳于我。可以见还。不扬汝恶。跋难陀言。我知外道心不坚正变悔无常。不欲相与汝云不悔。是故相从。云何于今方作此言。遂不与之。彼便大哭。诸居士问。汝何故哭。具以事答。诸居士便讥呵言。白衣卖买七日犹悔。如何沙门须臾不得。形服与人异。而贩卖过于人。如是恶名流布远近。诸长老比丘闻种种呵责。以是白佛。佛以是事集比丘僧。问跋难陀。汝实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。以十利故为诸比丘结戒。从今是戒应如是说。若比丘种种贩卖求利。尼萨耆波逸提

以作易作。以作易未作。以作易作未作。以未作易未作。以未作易作。以未作易作未作。以作未作易作未作。以作未作易作。以作未作易未作。皆尼萨耆波逸提。若比丘欲贸易。应使净人语言。为我以此物易彼物。又应心念。宁使彼得我利。我不得彼利。若自贸易。应于五众中。若与白衣贸易突吉罗。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(二十八竟)

佛在王舍城。尔时难陀跋难陀。用金银金银钱杂钱买物亦卖物取之。时有群劫到王舍城伺觅富室。见二比丘大以金银及钱买物又卖物取之。便共议言。观此邑里。无胜沙门释子之富。阿练若处劫之又易。便于后日。至阿练若处捉诸比丘。拷责金银及诸钱物。诸比丘言。我等已离金银及钱。不复受畜此不净物。劫言。汝等妄语。我亲见比丘用以卖买。拷之垂死尽夺衣钵而去。此诸比丘即遥呵责难陀跋难陀。如何出家积畜宝物以殃我等。以是白佛。佛以是事集比丘僧。问难陀跋难陀。汝实尔不。答言。实尔世尊。佛种种呵责。汝愚痴人。若不作是。彼诸比丘何由遭此。种种呵责已告诸比丘。以十利故为诸比丘结戒。从今是戒应如是说。若比丘以金银及钱种种卖买尼萨耆波逸提

应僧中舍。不得与一二三人。是比丘应白僧言。大德僧听。我某甲比丘。以金银及钱卖买犯舍堕。今于僧中舍。白如是。僧应白二羯磨。差一比丘作弃金银及钱人。一比丘白言。大德僧听。此某甲比丘用金银及钱卖买犯舍堕。今舍与僧。僧差某甲比丘作弃金银及钱人。若僧时到僧忍听。白如是。大德僧听。此某甲比丘用金银及钱卖买犯舍堕。今舍与僧。僧差某甲比丘作弃金银及钱人。谁诸长老忍默然不忍者说。僧已差某甲比丘作弃金银及钱人竟。僧忍默然故。是事如是持。彼比丘应弃此物。着坑中火中流水中旷野中。不应记处。若捉着余处。不得更捉。彼比丘不应问僧此物当云何。僧亦不应教作是作是。若不弃不问僧。而使净人以贸僧所衣食之物来与僧。僧得受。若分者唯犯罪。人不得受分。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗。不犯者。虽施比丘比丘不知。净人受之为买净物(二十九竟)

佛在王舍城。尔时难陀跋难陀。手自捉金银及钱。教人捉人施亦受。诸居士见讥呵。如担羊毛中说。诸长老比丘闻。种种呵责。以是白佛。佛以是事集比丘僧。问难陀跋难陀。汝实尔不。答言。实尔世尊。佛种种呵责已告诸比丘以十利故为诸比丘结戒。从今是戒应如是说。若比丘自捉金银及钱。若使人捉若发心受。尼萨耆波逸提。余如用金银钱中说(三十竟)

五分律卷第五五分律卷第六(弥沙塞)

        宋罽宾三藏佛陀什共竺道生等译

    初分之五堕初(九十一堕法)

佛在舍卫城。尔时有法师比丘。名沙兰。聪明才辩。一切四众外道沙门婆罗门。无能及者。遂乃以非为是以是为非。知言非知非知言知。恒以辩巧胜人之口。诸比丘见莫不叹伏。问言。汝与人论议。以非为是。意为谓是为知非耶。答我实知非。耻堕负处故妄语耳。诸长老比丘种种呵责。佛常赞叹不妄语。亦教人不妄语。汝今云何为胜负故作此妄语。以是白佛。佛以是事集比丘僧。问沙兰。汝实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘妄语波逸提。尔时诸比丘。见比丘尼言是比丘。见比丘言是比丘尼。或见男言女。或见女言男。或见外道言是释子。或见释子言是外道。如是种种见异言异。便生惭愧。我等将无犯波逸提耶。以是白佛。佛以是事集比丘僧。告诸比丘。若比丘从心想说。犯波逸提者无有是处。从今是戒应如是说。若比丘故妄语波逸提。故妄语者。如妄语得过人法中说。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(一事竟)

佛在舍卫城。尔时诸比丘与和尚阿阇梨同和尚阿阇梨共勤学问。初夜后夜未曾睡眠。六群比丘作是念。今诸比丘展转相教昼夜不废。如是不久当胜我等。当见我过。当求我失。我等当共毁呰恼使废业。便往语言。汝是下贱种姓工师小人。汝曾作诸大恶无仁善行。诸比丘闻。便生忧恼废退学业。六群比丘语余人言。我已坏彼读诵坐禅行道。诸长老比丘种种呵责。汝云何毁坏诸比丘令废学业。以是白佛。佛以是事集比丘僧。问六群比丘。汝实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。往昔有城名得叉尸罗。时彼城中彼婆罗门。有一特牛。行疾多力。复有居士亦有一牛。与彼无异。二人便共捔二牛力。要不如者赌金钱五十。彼婆罗门牛即便得胜。于是居士耻失金钱。更得一牛倍胜前者。重断倍赌。彼婆罗门即语牛言。彼居士更得一牛。其力非凡。欲倍赌之。汝能为不。答言我能。即集一处捔二牛力。时婆罗门恐牛不如。便毁呰摧督。曲角痛挽薄领痛与。汝今行步何以不正。牛闻此语。便大失力。不如彼牛。彼婆罗门倍输物已。而问牛言。汝向云能。今何故不如。答言。我实堪能。闻毁呰故力便都尽。可更断赌。复使倍上。要牵百车上于峻阪。当捔力时美言见诱。可言觠角汝行步周正形体姝好闲挽百车上于峻阪。于是更赌。果便得胜。佛因是事。即说偈言

  当说可意言　　勿为不可语
  畜生闻尚悦　　引重拔峻阪
  由是无有敌　　获倍生欢喜
  何况于人伦　　毁誉无增损

诸比丘。彼畜生闻毁呰语。犹尚失力。况于人乎。今为诸比丘结戒。从今是戒应如是说。若比丘毁呰比丘波逸提。毁呰者。言下贱工师种如是等。虽说实而欲毁之。若彼闻解。语语波逸提。若不闻不解突吉罗

若言汝是下贱。而彼言非。犹证为是。语语波逸提。若比丘毁呰比丘尼式叉摩那沙弥沙弥尼突吉罗。比丘尼毁呰比丘比丘尼波逸提。毁呰式叉摩那沙弥沙弥尼突吉罗。式叉摩那沙弥沙弥尼毁呰五众突吉罗。不犯者。欲利益语教诫语同意语(二事竟)

佛在舍卫城。尔时诸比丘精勤学问如毁呰中说。六群比丘复恐胜已。便斗乱之。至此比丘间语言。汝与我知厚。而彼说汝是下贱种姓工师小人。曾作大恶无仁善行。我闻其语与说我无异。至彼比丘间亦复如是。彼此闻之。心皆散乱废退学业。更相忿恚不复共语。有一比丘问诸比丘。汝等何故。不共我语。比丘答言。有人云汝道说我恶。彼言谁道。答言六群比丘。彼言。六群比丘亦云汝等道说我恶。诸长老比丘闻种种呵责。六群比丘。汝等云何两舌斗乱。以是白佛。佛以是事集比丘僧。问六群比丘。汝实尔不。答言。实尔世尊。佛种种呵责。汝愚痴人。如何同在一法而两舌斗乱。告诸比丘。过去世时有师子。名曰善牙。有虎名曰善抓。共作亲厚。有一野狐常随觅食。师子及虎不与共语。野狐后时作是念今此二兽甚相爱重。我当斗乱使各求食。所残必多。我当得之。便至虎边。而说偈言

  善抓汝雄猛　　生处色力妙
  善牙说汝恶　　我闻心不喜

复至师子边。亦说偈言

  善牙汝雄猛　　生处色力妙
  善抓说汝恶　　我闻心不喜

二兽闻偈各不相喜。善牙聪明寻作是念。善抓不与我语。必是野狐斗乱所致。后得一犊与虎。虎不肯食。于是善牙即以偈问

  辍我持相与　　何故而不食
  亲厚谓无过　　反更不相喜
  将无信狐言　　以间吾子意
  若遂怀恨情　　终当成怨结
  推此非有他　　必是野狐谗
  下贱离吾好　　今当杀去之

告诸比丘。畜生尚以斗乱为非。况于人乎。今为诸比丘结戒。从今是戒应如是说。若比丘两舌斗乱比丘波逸提。余如毁呰中说(三事竟)

佛在舍卫城。尔时跋难陀。常出入一居士家为其说法。断理官事。救诸病苦。其家后时衰丧殆尽。余唯妇姑二人而已。时跋难陀以亲厚意为姑说法。妇来则止为妇说法。姑来亦尔。各生疑意。谓其必欲作不净行。遂相道说闻乎远近。诸不信乐佛法者便讥呵言。沙门释子行于非法。过于世间荡逸之人。无沙门行破沙门法。诸长老比丘闻种种呵责。以是白佛。佛以是事集比丘僧。问跋难陀。汝实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘为女人说法波逸提。尔时有大威德比丘。至时着衣持钵入城乞食。次到一家。妇人出为敷座设美饮食。食讫以小床于前坐。白言大德。为我说法。比丘观之。知此妇人须臾之间刀风当发死堕地狱。若为说法。便于座上远尘离垢。虽见知此而作是念。佛制不听为女人说法。乃至没命不应有犯。便答言。姊妹且安。不得有说。语已而去。去未久妇人果风发而死。比丘愍之。还至僧房向余人说。诸比丘将至佛所。以是白佛。佛以是事集比丘僧。问彼比丘。汝实尔不。答言。实尔世尊。佛又问比丘。汝若为说法。几语得解。答言。五六语。于是佛赞少欲知足。赞戒赞持戒已。告诸比丘。从今听诸比丘为女人说法至五六语。从今是戒应如是说。若比丘为女人说法。过五六语波逸提。尔时诸比丘入他家。妇人请说法。比丘为说五六语已默然而住。诸妇人言。我等未解。愿更说之。诸比丘言。姊妹。佛不听我等为女说法过五六语。诸妇人言。可为余比丘说。我因得解。诸比丘言。佛未听我等因比丘为女人说法。以是白佛。佛以是事集比丘僧。告诸比丘。从今听因比丘为女人说法。尔时有一比丘。入大臣家无比丘伴。诸妇人请说法。答言。佛不听我为女人说法过五六语。诸妇人便呼小儿在前立。白言大德。可为此儿说法。我因得解。答言。佛未听我因小儿为女人说法。以是白佛。佛以是事集比丘僧。告诸比丘。从今听因有知男子为女人说法。时诸比丘作是念。佛虽听我因有知男子为女人说法。而有知男子虽知难遇复不为说。以是白佛。佛以是事集比丘僧。告诸比丘。从今听因别知善恶语男子为女人说法。从今是戒应如是说。若比丘为女人说法。过五六语。除有别知善恶语男子。波逸提。尔时有优婆塞。取不奉法家女为妇。语诸比丘。大德为我妇说法。令信乐三宝。为受三归五戒八分戒。为说十善十不善道。诸比丘悉不为说。以是白佛。佛以是事集比丘僧。告诸比丘。从今听与女人受三归五戒八分戒说十善十不善道。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗。五语者。色无常受想行识无常。六语者。眼无我耳鼻舌身心无我。若比丘为女人说五六语竟。语言。姊妹。法正齐此。从坐起去。更有因缘还复来坐为说不犯。若说五六语竟。更有女人来。为后女人说。如是相因。为无量女人说皆不犯。若自诵经女人来听。若女人问义。要使得解。过五六语。皆不犯(四事竟)

佛在舍卫城。尔时六群比丘有势力。余善比丘无势力。六群比丘恒遮其五种羯磨。呵责羯磨驱出羯磨依止羯磨举罪羯磨下意羯磨。若比丘被五种羯磨。僧欲解亦遮不听。后六群比丘无势力。诸善比丘有势力。众僧应有羯磨事。六群比丘作衣时至。诸比丘言。今当呼六群比丘共行僧事。若不舍衣来。自当嘱授。我等便得如法行事。即便集僧遣人。语六群比丘。汝等可来。僧今集会。六群比丘言。我等有事今遣嘱授。即嘱授一比丘来诣大众。僧应与作五种羯磨者。与作五种羯磨。应与解五种羯磨者。与解五种羯磨。羯磨已。所嘱授比丘。还到六群比丘所。六群问言。僧作何事。答言。我等所欲羯磨。僧都不作。所不欲者。僧反作之。六群比丘。便往彼羯磨比丘所语言。汝等莫愁。我当与汝作力。我向不知为汝作羯磨故嘱授耳。若知者当废事往。何缘使彼成此羯磨。复往解羯磨比丘所语言。我不与汝解羯磨不受汝忏悔。诸长老比丘闻。呵责六群比丘。云何僧如法断事竟。还发起。将至佛所以是白佛。佛以是事集比丘僧。问六群比丘。汝实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘僧断事竟。还发起。波逸提。时诸比丘不知僧断事竟还发起。后知生惭愧心。或有出罪悔过者。诸长老比丘以是白佛。佛以是事集比丘僧。告诸比丘。若不知僧断事竟还发起。犯波逸提者无有是处。从今是戒应如是说。若比丘知僧断事竟还发起波逸提。复有不如法断事诸比丘。作是念。佛若听我等不如法断事还发起者善。以是白佛。佛以是事集比丘僧。告诸比丘。今听僧不如法断事还发起。从今是戒应如是说。若比丘知僧如法断事竟还发起波逸提。若僧如法断事而发起者波逸提。若僧不羯磨断事而发起者突吉罗。若发起私事突吉罗。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(五事竟)

佛在舍卫城。与五百比丘僧至阿荼脾邑。时彼居士作是念。佛久乃来此。寻当复去。我等应亲近诸比丘学诵经偈问所不解。世尊去后得有所怙。即到诸比丘所作是语。大德教我诵读经偈。诸比丘言。佛未听我等教白衣诵经。以是白佛。佛言。听教白衣诵经。时诸比丘种种国出家。诵读经偈音句不正。诸居士便讥呵言。云何比丘昼夜亲承。而不知男女黄门二根人语及多少语法。诸比丘闻各各羞耻。以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言。实尔世尊。佛即遥责诸居士。汝愚痴人。如何讥呵异国诵经音句不正。告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘教未受具戒人诵经波逸提。后复有诸居士求受诵经。诸比丘言。汝之等辈嫌我音句。不从我受。汝今复来徒自劳苦。答言。大德我不毁佛法。不求余福田。岂可以彼人有过而不教我耶。复有诸沙弥亦欲受经。诸比丘言。须受具戒当教授汝。诸沙弥言。我等出家应诵经偈。如何受具戒乃当教授。诸比丘以是白佛。佛以是事集比丘僧。告诸比丘。今听教未受具戒人诵经不得并诵从今是戒应如是说。若比丘教未受具足人经。并诵者波逸提。并诵者俱时诵。或授声未绝彼已诵。或彼诵未竟此复授。句句皆波逸提。先应教言。待我语竟然后诵。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(六事竟)

佛在阿荼脾邑。彼诸居士以佛当去。皆来至比丘所。共诸比丘同屋坐禅或共经行。初夜后夜都不睡卧。时诸比丘。五日则一竟夜说法。疲极而卧。有一比丘不专系念便大睡眠。蹋衣离身形起露现。居士见之以衣还覆。如是至三。便嗔呵言。此等常闻种种呵欲。而今发露形起。如是若不乐道。何不还俗。彼比丘闻生羞耻心。诸长老比丘闻。亦大惭愧。以是白佛。佛以是事集比丘僧。问彼比丘。汝实尔不。答言。实尔世尊。佛种种呵责彼比丘我常赞叹不乱心眠无有五恶。汝今何故而不系念若比丘于经行坐禅坐。立卧处作非威仪。人见不喜不生信心。已信者退。则非为世而作大明。告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘与未受具戒人共宿波逸提。后诸居士复欲就诸比丘坐禅行道。诸比丘驱出不听。诸居士言。大德莫见驱遣。我等不求余福田。唯归大德。岂可以一人有过都见弃忽。诸居士中有势力者便突入房。诸比丘不能制止。便出露宿。为蚊虻风雨尘土所困。时佛从阿荼脾邑到拘舍弥国瞿师罗园。罗睺罗别到婆耆罗僧坊。扫洒一房敷卧具取水竟闭户至佛所。去后分卧具比丘更与余人。彼比丘即入房住。罗睺罗初夜听法已还所得房。彼比丘闻。问言是谁。答言。是罗睺罗。彼比丘言。汝何以来。答言。此是我房。彼比丘言。分卧具比丘以此与我。罗睺罗言。我先扫除敷置卧具。暂至佛所听受法教。如何便欲不复还我。彼比丘言。汝虽料理。我是上座应得此住。罗睺罗言。得共我住不。彼言不得。求入坐立及住檐前。皆亦不得。于是罗睺罗作是念。我至余房亦当如是。唯有厕上乃得安耳。便往厕中。尔时厕中有一黑蛇。佛天眼见。念言。我若不往罗睺罗须臾之间为蛇所杀。便往厕前弹指[口*磬]咳。罗睺罗亦作声应。佛问言。汝是谁。答言。是罗睺罗。又问。何以在此。具以事答。于是世尊。将罗睺罗还所住房。于夜过已集比丘僧。问彼比丘。汝实不容罗睺罗不。答言。实尔世尊。佛种种呵责。汝愚痴人。云何野狐驱逐师子。时诸比丘因此复以上诸居士入房露宿白佛。佛种种赞少欲知足。赞戒赞持戒已。告比丘。今听诸比丘共未受具戒人二宿。从今是戒应如是说。若比丘与未受具戒人宿。过二夜波逸提。共宿者。共一房宿。若上有覆有四壁。或上有覆无一壁二壁。皆波逸提。无三壁不犯。若有四壁上已覆半若未半若过半皆波逸提。若少多覆不犯。于此诸处。若过二宿至后夜时。以胁着床及转侧。皆波逸提。不犯者。同覆各有隔。若病不能起居。若有诸难。若常坐不卧。若彼卧比丘坐。彼坐比丘卧。比丘尼亦如是(七事竟)

佛在毗舍离。时世饥馑乞求难得。告诸比丘。各随知识安居。有诸比丘在婆求末河边安居者。种种因缘如自称得过人法中说。乃至佛问。汝等更相赞叹为实为虚答言。有实有虚。佛言。虚者得波罗夷。种种呵责实有比丘言。汝等云何。向未受具戒人自说得过人法。呵已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘向未受具戒人自说得过人法言。我如是知如是见。实者波逸提。过人法如上说。若向未受具戒人。自说得过人法。语语波逸提。若受大戒人不问而向说。语语突吉罗。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗。不犯者。泥洹时说。受具戒人问而后说(八事竟)

佛在舍卫城。尔时诸比丘犯僧伽婆尸沙罪。或故出不净。或与女人身相触。或向女人粗恶语。或向女人自叹供养身有从僧乞别住僧与别住者。或行摩那埵。或行本日。或有出罪者。时六群比丘于僧中皆调弄之。诸比丘倍增羞耻。复有一比丘犯故出不净。僧与别住。时彼比丘檀越。请僧中食。别为彼比丘敷好坐具。六群比丘先往请家在好坐具上坐。居士言。莫坐是处。我供养比丘当于上坐。六群比丘言。彼比丘不应坐此。居士言。应与不应我自知之。六群比丘言。先应坐此。而今乃应在最下坐。居士复问。何故如是。答言。彼比丘有罪。居士复问。为犯何罪答言。犯故出不净。居士便讥呵言。此等沙门常说除欲想灭欲热断欲觉。而今如此为道作秽。无沙门行破沙门法。诸长老比丘闻。种种呵责六群比丘。汝等云何向未受具戒人说他粗罪。以是白佛。佛以是事集比丘僧。问六群比丘。汝实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘向未受具戒人说他粗罪波逸提。有诸比丘。不知是粗罪向未受具戒人说。后知生疑。我将无犯波逸提。以是白佛。佛以是事集比丘僧。告诸比丘。若比丘不知他是粗罪向未受具戒人说。犯波逸提者无有是处。从今是戒应如是说。若比丘知他粗罪向未受具戒人说波逸提。尔时世尊敕僧。羯磨差舍利弗。往调达众中唱言。若有受调达五法者。彼为不见佛法僧。诸比丘作是念。若向未受具戒人说他粗罪。为要须羯磨为不必耶。以是白佛。佛以是事集比丘僧。告诸比丘。若僧不羯磨。不得向未受具戒人说他粗罪。从今是戒应如是说。若比丘知他比丘粗罪向未受具戒人说。除僧羯磨。波逸提。粗罪者。若波罗夷若僧伽婆尸沙。僧所羯磨人。当随僧所教。若教向甲说而向乙说。教说此罪而说彼罪。皆波逸提。比丘说比丘尼粗罪突吉罗。比丘尼说比丘比丘尼粗罪波逸提。式叉摩那沙弥沙弥尼。说比丘比丘尼粗罪突吉罗。若未受具戒人。已闻彼比丘犯粗罪。问比丘。比丘反问。汝所闻云何。彼言。我闻如是如是。然后言。我闻亦如是。不犯(九事竟)

佛在舍卫城。尔时世尊种种赞叹比尼。赞叹诵比尼。赞叹持比尼。赞叹优波离说。持律比丘有五功德。一自坚护戒品。二能断惭愧者疑。三自住正法中。四于僧中所说无畏。五降伏怨敌。时诸比丘作是念。佛为我等作如是说。我等云何而不勤修诵问比尼。即苦诵习昼夜不懈。时六群比丘作是念。今诸比丘昼夜勤受诵问比尼。必大聪明解诸罪相。见我等过终为我损。我今当共毁呰比尼学比尼者。令其废业不复诵习。便往诸比丘所问言。汝诵习何等。答言比尼。六群比丘言。何用诵习杂碎戒为。何不诵习五阴六入等诸义经耶。诵比尼不过四事十三事二不定法。何用多知。多知多见增益人疑。诸比丘言。多知多疑我亦谓尔。便不复诵习。六群比丘自相谓言。彼诸比丘不复诵习比尼。我等泰然快得安乐。诸比丘闻。问言。汝等何所说。即如实答。时诸长老比丘种种呵责。以是白佛。佛以是事集比丘僧。问六群比丘。汝实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘作是语。何用是杂碎戒为。说是戒时令人忧恼。作如是毁呰戒者波逸提。戒者。波罗提木叉半月布萨所说戒经。若比丘发心作念。欲令人远离比尼不诵不读而毁呰戒波逸提。若比丘发心作是念。我当毁呰令波罗提木又不得久住。而毁呰戒偷罗遮。若教人远离佛所说诸经。而毁呰者波逸提。若欲令法不久住。而毁呰者偷罗遮。若比丘毁呰比丘戒波逸提。毁呰比丘尼式叉摩那沙弥沙弥尼戒突吉罗。若比丘尼。毁呰比丘比丘尼戒波逸提。毁呰式叉摩那沙弥沙弥尼戒突吉罗。若式叉摩那沙弥沙弥尼。毁呰五众戒皆突吉罗。若五众毁呰优婆塞优婆夷戒皆突吉罗。若恐新受戒人生疑废退心。教未可诵戒。不犯(十事竟)

佛从拘萨罗国与五百比丘俱。向阿荼脾邑。时彼比丘闻佛当来。作是念。此诸居士不信乐佛法。无大讲堂。佛与大众当于何住。即集共议。便自斫伐草木而营理之。时诸居士讥呵言。我等白衣斫伐草木。出家之人何缘复尔。此等常说慈忍护念众生。而今斫伐伤害无道。无沙门行破沙门法。佛既至已。到新讲堂。就座而坐。问诸比丘。此堂谁造。答言。我等所造。又问。草木谁所斫伐。答言。亦是我等。佛种种呵责言。汝愚痴人。不应作此。草木之中人生命想。汝作此事使人怀恶。呵已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘杀生草木波逸提。时诸比丘使守园人若沙弥斫伐草木。诸长老比丘问言。佛岂不制杀生草木耶。答言。我等使人为之不违佛制。诸长老比丘言。自杀使人杀有何等异。以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。从今是戒应如是说。若比丘自杀生草木若使人杀波逸提。时诸比丘作新房舍。有诸居士案行所住。语比丘言。善哉大德。此房舍物皆我所施。速作成之。使我等得施用之福。诸比丘言。佛不听我自杀草木若使人杀。云何得成。于是诸比丘。无房舍住。庭草没人。又欠齿木。不知云何。以是白佛。佛以是事集比丘僧。告诸比丘。有四种种子。根种子茎种子节种子实种子。凡诸草木从四种子生。若比丘一一所须。语净人言。汝知是。若不解复语言。汝看是。若不解复语言。我须是。若不解复语言。与我是。从今是戒应如是说。若比丘自伐鬼村若使人言伐是波逸提。若生草生草想生草疑皆波逸提。干草生草想干草疑突吉罗。干草干草想不犯。若以刀斧斫斫斫波逸提。比丘尼亦如是。式叉摩那沙弥沙弥尼无故杀生草木突吉罗。若为火烧。若析若斫。知必不生不犯(十一事竟)

佛在舍卫城。尔时六群比丘数数犯罪。上床下床皆不如法。数数食别众食。非时入聚落不白善比丘。诸比丘见语言。汝等莫数数犯此诸罪。当自见罪向人悔过。勿负信施长夜受苦。六群比丘言。我犯何罪。诸比丘言。汝犯如是如是罪。六群比丘不答犯不犯。更说余事。诸比丘言。我不问汝。汝何以不答犯不犯。而说是事。六群比丘言。我知汝等不问是事我自说耳。诸比丘种种呵责。以是白佛。佛以是事集比丘僧。问六群比丘。汝等实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘不随顺答。而作余语波逸提。时六群比丘犹犯前恶。诸比丘复如上教诲。六群比丘默然不应。诸比丘问言。佛制戒不听不随顺答。汝何故默然。六群比丘言。佛制不随顺答。我今不语有何等罪。诸比丘言。余语不语有何等异。种种呵责已。以是白佛。佛以是事集比丘僧。问六群比丘。汝等实尔不。答言。实尔世尊。佛种种呵责。余语不语有何等异。呵责已告诸比丘。从今是戒应如是说。若比丘故不随问答波逸提。若不随问答。问问皆波逸提。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗。若误取他语而答。及先相恨不共语故不答不犯(十二竟)

佛在王舍城。尔时慈地比丘作是语。陀婆比丘随欲恚痴畏。诸比丘闻。呵责言。汝何以诬说僧所差人随欲恚痴畏。以是白佛。佛以是事集比丘僧。问慈地比丘。汝实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘人前诬说僧所差人波逸提。于是慈地不复得在人前诬说。便独处诬说陀婆比丘随欲恚痴畏。诸长老比丘闻呵责言。佛已前制。汝何故犹诬说僧所差人。以是白佛。佛以是事集比丘僧。问慈地。汝实尔不。答言。实尔世尊。佛种种呵责。人前独语有何等异。呵已告诸比丘。从今是戒应如是说。若比丘诬说僧所差人波逸提。若僧白羯磨白二羯磨白四羯磨所差人。而诬说此人随欲嗔痴畏。语语皆波逸提。若僧差而不羯磨及余人作此诬说。语语突吉罗。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗。若实随欲恚痴畏。语言。我当说彼听不犯(十三竟)

佛在毗舍离。有一住处下湿。有比丘得下湿房。出卧具露地敷晒。至时着衣持钵入城乞食。去后大雨水涨漂没。食还不见。即便急觅。或得大床或得小床或得拘摄或得被褥。诸比丘见问言。汝何从得此卧具诸物。答以上事。诸长老比丘呵责言。汝所作非法。为僧作卧具人难得。既敷又无能随收敛者。云何去时不举致使漂没。若当遂失便空此一房。呵已白佛。佛以是事集比丘僧。问彼比丘。汝实尔不。答言。实尔世尊。佛种种如上呵责已。告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘露地敷僧卧具。去时不举波逸提。尔时六群比丘。使守园人沙弥露地敷僧卧具。去时不教举。为鸟啄啮埿雨烂破。诸长老比丘见语言。汝不闻佛制不听露地敷僧卧具去时不举耶。答言。我使人敷不违佛制。诸比丘言。自敷使人有何等异。以是白佛。佛以是事集比丘僧。问六群比丘。汝实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。从今是戒应如是说。若比丘于露地自敷僧卧具若使人敷。去时不自举不教人举波逸提。有诸比丘。于露地敷僧卧具。六群比丘。后来于卧具上或坐或卧。去时不举。前比丘谓六群比丘应举。六群比丘谓前比丘应举。诸比丘不知云何。以是白佛。佛以是事集比丘僧。告诸比丘。前比丘应嘱后比丘。后比丘应举。从今是戒应如是说。若比丘于露地自敷僧卧具若使人敷若他敷若坐若卧。去时不自举不教人举不嘱举波逸提。有诸比丘。见僧卧具污埿不净。或以灰土或以牛屎着上晒之。在于界内不敢远离。以是白佛。佛言。若雨得收听离。有诸比丘。晒僧卧具不敢出界外。以是白佛。佛言。若审还不雨听出界外。复有诸比丘。晒僧卧具在边坐禅或熟眠寝语。诸比丘以是白佛。佛言。不听晒卧具于边坐禅熟眠。犯者突吉罗。复有诸比丘晒僧卧具不即收举日曝损坏。诸比丘以是白佛。佛言。若不时收举突吉罗。复有诸比丘。见僧卧具敷在露地。以不自敷不使人敷。已不坐卧而不收举。诸比丘以是白佛。佛言。若见僧卧具敷在露地。而不举者波逸提。有诸白衣。来入僧坊索僧卧具欲露地敷。诸比丘不与。便大讥嫌。以是白佛。佛言。听与。既与。欲得早举。教令速去。白衣复嗔。以是白佛。佛言。不应教令速去。应伺候去时举。若不举波逸提。复有白衣请僧借僧卧具于家敷之。诸比丘坐去不举。佛言。应举若不举波逸提。若诸比丘。到比丘尼僧坊。露地敷比丘尼僧卧具。谓非僧卧具。而不举者亦波逸提。复有诸比丘自担床席。诸居士讥呵言。此诸沙门如诸伎儿如作幻人。诸比丘以是白佛。佛言。不听自担。犯者突吉罗。又大会时露地敷僧卧具。诸比丘一坐一起辄皆举之。由是速坏。以是白佛。佛言。若不雨听事都毕然后举之。佛既听嘱后来坐卧卧具比丘。便嘱和尚阿阇梨同和尚阿阇梨等诸大德及病比丘。诸比丘以是白佛。佛言。不应嘱和尚阿阇梨同和尚阿阇梨等诸大德及病比丘。犯者突吉罗。诸比丘嘱一比丘。一比丘独举疲顿。以是白佛。佛言。随卧具多少。若少嘱少比丘。若多嘱多比丘。诸比丘不知云何。名受嘱不受嘱。以是白佛。佛言。使彼知受。是名受嘱。若不自举不教人举不嘱举。一脚出界外突吉罗。两脚出波逸提。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(十四竟)

佛在毗舍离。有一住处下湿。时十七群比丘在一房中安居。去时不举僧卧具。悉皆烂坏。后六群比丘来。语旧住比丘言。为我开房示卧具处。旧比丘即开十七群比丘所安居房与之。入已手摸卧具烂坏成土。问旧比丘。先谁住此。答十七群比丘。于是六群比丘。种种呵责十七群比丘。以是白佛。佛以是事集比丘僧。问十七群比丘。汝实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘于僧房内自敷僧卧具。若使人敷若他敷若坐若卧。去时不自举不教人举不嘱举波逸提。余皆如露地敷卧具中说(十五竟)

佛在舍卫城。尔时十七群比丘新作房舍。六群比丘后来语旧住比丘言。为我次第开房。旧比丘问。汝乐何者。答言。我乐十七群比丘所作新屋。便差与之。六群比丘即到其所语言汝出去。我等当于中住。十七群比丘言。此房幸大自可共住。时六群比丘作是念。此诸比丘有惭愧学戒法。初夜后夜不睡不卧。必见我罪不宜共住。便语言。我等不乐共住。汝可更索余房。十七群比丘言。若不乐共住。上座可在前房。我等住于后屋。六群比丘言。此亦不得。复求在檐下庭中露住。皆悉不听。彼既不听。此不肯去。便强牵出。十七群比丘即大唤。诸比丘出问。汝何故大唤。答言。六群比丘强牵我出。诸比丘呵责六群比丘。汝云何强牵人出。以是白佛。佛以是事集比丘僧。问六群比丘。汝实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘于僧房中强牵比丘出波逸提。六群比丘既不得自牵。便使守园人沙弥牵出。诸比丘见问言。佛不制牵比丘出僧房耶。答言。我不自牵。诸比丘言。自牵使人有何等异。以是白佛。佛以是事集比丘僧。问六群比丘。汝实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。从今是戒应如是说。若比丘于僧房中牵比丘出。若自牵若使人牵波逸提。有病比丘在房。欲出庭中不能起居。语诸比丘。善哉长老。牵我出房。诸比丘言。佛不听我牵比丘出房。复有比丘浴室中浴热闷倒地。诸比丘不敢牵出气绝而死。并以白佛。佛以是事集比丘僧告诸比丘。若病人须牵出房牵出。犯波逸提者无有是处。从今是戒应如是说。若比丘嗔不喜。于僧房中自牵比丘出若使人牵。作是语。出去灭去莫此中住。波逸提。若于后屋牵至前屋。若于前屋牵出户外。若于户外牵至庭中。若于庭中牵出庭外。皆波逸提。若牵出其衣钵突吉罗。若将其所不喜人来共房住。欲令自出若出若不出皆突吉罗。比丘牵比丘尼出突吉罗。比丘尼牵比丘比丘尼出波逸提。比丘比丘尼牵式叉摩那沙弥沙弥尼出突吉罗。式叉摩那沙弥沙弥尼牵五众出突吉罗。若牵无惭愧人。若欲降伏弟子。而牵出者皆不犯(十六竟)

佛在拘萨罗国。与大比丘僧千二百五十人俱。尔时诸比丘分卧具。或得房中或得树下。六群比丘至时着衣持钵入村乞食。食后于四衢道中。共诸居士外道沙门婆罗门。论说王事斗战事利害事如是等种种俗事。彼诸人等皆讥呵言。我等俗人家事因缘故。在此中有所论说。沙门释子亦复在此论说俗事。与我何异。投暮来还于所住处。与守园人诸沙弥辈复更语说。乃至夜闇。方觅房舍到一屋中。问先住比丘。汝等几岁。答言。我若干岁。六群比丘言。汝小出去。上座应住。诸比丘言。长老何意闇来。答言。我随佛后来。诸比丘言。我亦随佛后来。我若更索余房。复应恼诸比丘。如今长老恼触于我。六群比丘便敷卧具在其中住。初夜后夜高声经呗。更相问难。中夜鼾睡妨诸比丘坐禅行道。诸长老比丘闻。种种呵责六群比丘。汝作此恼诸比丘非惜佛法。以是事白佛。佛以是事集比丘僧。问六群比丘。汝实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘诸比丘先敷卧具竟。后来复敷波逸提。有诸比丘先敷卧具竟暂出。六群比丘于后使白衣复敷卧具。诸比丘见问言。汝不闻佛制他敷卧具竟不得复敷耶。答曰。我使白衣不违此制。诸比丘言。自敷。使人有何等异。以是白佛。佛以是事集比丘僧。问六群比丘。汝实尔不。答言实尔世尊。佛种种呵责已告诸比丘。从今是戒应如是说。若比丘诸比丘先敷卧具竟。后来若自敷若使人敷波逸提。有诸比丘先敷卧具竟暂出。后来比丘不知。复敷卧具。先敷卧具比丘还。后敷卧具比丘便生疑。我将不犯波逸提耶。以是白佛。佛以是事集比丘僧。告诸比丘。若不知比丘先敷卧具。后来复敷。犯波逸提者。无有是处。从今是戒应如是说。若比丘知他先敷卧具。后来若自敷若使人敷波逸提。尔时大会多比丘集。房舍虽大而间数少。后来比丘无有住处。先敷卧具比丘呼入共住。彼恐犯堕不敢入。以是白佛。佛以是事集比丘僧。告诸比丘。若不相触恼犯堕无有是处。从今是戒应如是说。若比丘知他先敷卧具。后来强自敷若使人敷。作是念。若不乐者自当出去波逸提。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(十七竟)

佛在舍卫城。时一住处有重阁屋。有一比丘止住其上。敷尖脚床。常系其念坐卧上下初不卒暴。时有客比丘来。以上座故转以与之此比丘身体重大。不一其心顿身床上。床脚下脱打下比丘头。头破大唤。阁上比丘即下辞谢。阁下比丘呵责言。先住比丘我初不闻坐起之声。汝云何适来便有是事。汝岂不闻世尊赞叹系念耶。诸长老比丘闻。即来问之。答以上事。诸比丘种种呵责。以是白佛。佛以是事集比丘僧。问彼比丘。汝实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘僧重阁上尖脚绳床木床用力坐卧波逸提。住阁屋应以尖脚床着下。非尖脚者着上。若无非尖脚。应以大物支。若无支应缚横。若无横应覆着地。若不尔而坐卧。乃至坐卧一脚尖床。皆波逸提。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗。若板覆阁及木箦。知必不下脱不犯(十八竟)

佛在拘舍弥国。尔时阐陀比丘。常出入诸家。乃至见其殷勤难相违逆皆如上。有主为身作房中说。阐陀于是。求于屋地得一好处便起高基以墼薄累。作于四壁极重覆之。覆重壁圯一时崩倒。填押伤杀婆罗门麦彼便嗔呵言。此沙门辈。为欲住寿一劫。为欲为子孙计。一两重覆足以终身。何为过厚致此崩倒。复言。此辈所用不损父母。自可极意作此恶业。无沙门行破沙门法。诸长老比丘闻。种种呵责以是白佛。佛以是事集比丘僧。问阐陀。汝实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘作大房舍。从平地累留窗户处。极令坚牢。再三重覆若过波逸提。若至第四重。若草若瓦若板覆。一一草瓦板。皆波逸提。方便及烧斫时皆突吉罗。覆竟波逸提。沙弥突吉罗(十九竟)

佛在拘舍弥国。尔时阐陀作大房舍。用有虫水浇于埿草亦使人浇。优陀夷用有虫水饮食浇浴。诸居士见阐陀用有虫水浇于泥草。从优陀夷索饮以虫水与之。居士语言。此水有虫。答言。但饮水勿饮虫。诸居士言。大德既饮水。如何不饮虫。便不复答。诸居士讥呵言。此等沙门常说慈愍护念众生。而今以虫水浇埿饮食浇浴。无怜愍心无沙门行破沙门法。诸长老比丘闻。种种呵责。以是事白佛。佛以是事集比丘僧。问阐陀优陀夷。汝等实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘知水有虫。若取浇埿若饮食诸用波逸提。有虫水者囊漉所得。肉眼所见。若浇埿若饮食。虫虫波逸提。若有虫虫想有虫疑皆波逸提。无虫虫想无虫疑皆突吉罗。用虫水有内外用。内用者。饮食之属。外用者。浇埿洗浴浣濯之属。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗。若谛视不见囊漉不得不犯(二十竟)

佛在舍卫城。尔时诸比丘。不教诫比丘尼不为说法。由此故空无所得。而反呵骂。由汝辈故。令佛正法减五百岁。使一切人不敬沙门轻贱比丘不加供养。时波阇波提比丘尼。与五百比丘尼来诣佛所。头面礼足却住一面。佛问瞿昙弥。颇有上座比丘。教诫比丘尼为说法有所得不。答言无也。世尊。由诸比丘不教诫不说法故。诸比丘尼空无所得。而反呵骂。由汝辈故。令佛正法减五百岁。众人不复恭敬供养沙门。于是世尊。为比丘尼种种说法。示教利喜已遣还所住。佛以是事集比丘僧。问诸比丘。汝等上座。实不教诫比丘尼不为说法而反呵骂不。答言。实尔世尊。佛种种呵责已告诸比丘。不应如是呵骂。犯者突吉罗。从今诸比丘。应教诫比丘尼应为说法。于是诸比丘。便教诫比丘尼为说法。即有所得。后六群比丘。亦往比丘尼住处语言。诸姊妹集。我当教诫说法。诸比丘尼即集一处。六群比丘便为说淫欲粗恶语。诸比丘尼中。有得诸禅解脱三昧正受者。皆不听受。时六群比丘尼咸赞叹言。此诸比丘善能教诫无复过者。于是波阇波提比丘尼。复与五百比丘尼往到佛所。佛问瞿昙弥。诸比丘教诫比丘尼为说法不。答言。有诸比丘教诫比丘尼为说法多有所得。复有六群比丘来。令比丘尼集云当教诫。反说淫欲粗恶语。六群比丘尼赞以为善无复过者。佛为诸比丘尼说法已遣还所住。以是事集比丘僧。问六群比丘。汝等实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。若僧不差教诫比丘尼。而教诫者波逸提。时六群比丘。便出界场自共相差教诫比丘尼。便往比丘尼住处语言。僧今差我来教诫汝。诸比丘尼如上集一处。六群比丘复为说粗恶语。乃至波阇波提比丘尼往到佛所。遣还所住亦如上说。佛以是事集比丘僧。问六群比丘。汝等实出界场自共相差教诫比丘尼不。答言。实尔世尊。佛种种呵责已告诸比丘。比丘成就十法。僧应差教诫比丘尼。何等为十。一者戒成就威仪成就恒畏小罪。二者多闻谛能了达知佛所说初中后善善义善味具足清白梵行之相。三者善能诵解二部戒律。四者善能言说畅理分明。五者族姓出家诸根殊特。六者于佛法中未曾秽浊。七者举止安详身无倾邪被服法衣净洁齐整。八者为比丘尼众之所敬重。九者能随顺说法示教利喜。十者满二十岁若过二十。有五法不应差。若已差应舍。一者所诵经戒而悉忘失。二者诸根不具。三者多欲。四者现为恶相。五者教比丘尼亲近恶人。今为诸比丘结戒。从今是戒应如是说。若比丘僧不差教诫比丘尼波逸提。不差者。不白二羯磨差教诫者。说八敬法。若不差教诫比丘尼。语语波逸提。教诫式叉摩那沙弥尼突吉罗。沙弥突吉罗(二十一竟)

五分律第六五分律卷第七(弥沙塞)

        宋罽宾三藏佛陀什共竺道生等译

    第一分之五第二十二事

佛在舍卫城。尔时诸比丘。次第教诫比丘尼。语比丘尼言。明日般陀比丘次教诫汝。汝当就彼听受法教。作是语已还到所住。语般陀。汝明日应教诫比丘尼。长老般陀。明日食时着衣持钵入城乞食。食后还归扫除内外。取清净水办手脚巾。露地敷座自取绳床于边坐禅。时诸比丘尼到般陀所。头面礼足就座而坐。于是般陀问诸比丘尼。曾闻八敬法不。答言曾闻。复语。姊妹更听。一者比丘尼众半月。应从比丘众乞教诫人。二者比丘尼众安居时要当依比丘僧众。三者比丘尼自恣时。应白二羯磨遣三比丘尼。从比丘众请见闻疑罪。四者式叉摩那。二岁学六法已。应于二部众求受具足戒。五者比丘尼不得骂比丘。不得于白衣家道说比丘若犯戒若犯威仪若邪见若邪命。六者比丘尼不得举比丘罪。而比丘得呵责比丘尼。七者比丘尼犯粗罪。应在二部僧中求半月行摩那埵。行摩那埵已。次阿浮呵那。应在二十比丘二十比丘尼众中出罪。八者比丘尼虽先受具戒百岁。故应礼新受大戒比丘。说此八敬法已。即说偈言

  欲得好心莫放逸　　圣人善法当勤学
  若有智慧一心人　　乃能无复忧愁患

说此偈已闭目正坐。时诸比丘尼窃相语言。此比丘唯知此一偈。云何当能教诫我等。般陀闻已作是念。此诸比丘尼轻贱于我。于是踊在虚空。现分一身作无量身。还合为一石壁皆过。履水如地入地如水。或现半身或现全身。或身上出烟身下火然。或身上火然身下出烟。或身上出水身下出火。或身上出火身下出水。或坐卧空中如鸟飞翔。或手摸日月。或身平立至梵自在。现神变已还坐本处说偈如前。诸比丘尼见此神变。心大欢喜白言。大德。愿更以神足教化。于是般陀东踊西没西踊东没。余方亦尔。作如是种种神变。然后还坐复说上偈。乃至日没然后舍去。时诸比丘尼暮至城门。城门已闭。扣门索入。守门者问。汝是谁。答言。是比丘尼。守门者问。夜何处来。答言。尊者般陀教诫我等。是以还晚。守门者言。可还本来处。正使王来亦不敢开。诸比丘尼既不得入。或在门下或在堑边或依树下。夜为蚊虻风尘所恼。明日门开最在前入。时诸居士自相问言。此诸比丘尼开晨先入从何处来。或有人言。正当是求男子还耳。诸不信乐佛法者。种种呵责言。我等白衣不修梵行。汝比丘尼亦复如是。空剃此头着坏色衣。诸长老比丘闻。呵责般陀。云何教诫比丘尼。乃至日没。以是白佛。佛以是事集比丘僧。问般陀言。汝实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘僧差教诫比丘尼至日没波逸提。僧差者。白二羯磨差。若比丘僧已差应语比丘尼。姊妹。若非难时当教诫。难时不得教诫。若就比丘尼住处教诫。应语。汝等敷座我当往。若不得往。应在所住处扫洒如前。应将大比丘为伴量无然后独往。为说八敬法已。若日早能更说余法亦善。应筹量日早晚要使及日得至所住。若说法竟。应前去者便去。若有恐怖处。比丘应送比丘尼至所在。若比丘教诫比丘尼至日没。语语波逸提。沙弥突吉罗(二十二竟)

佛在舍卫城。尔时诸比丘。次第教诫比丘尼。比丘尼皆得诸禅解脱三昧正受。时六群比丘。僧不差亦往教诫。但说粗恶不善之语。诸长老比丘尼默然不听。六群比丘尼赞言。善哉无过是者。于是波阇波提比丘尼。与五百比丘尼俱往到佛所。以是白佛。佛以是事集比丘僧。问六群比丘。汝实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘入比丘尼住处波逸提。时诸比丘。有因缘事塔事僧事私事。应入比丘尼住处惭愧不敢。不知云何。以是白佛。佛以是事集比丘僧。告诸比丘。若不为教诫因缘不听入。从今是戒应如是说。若比丘僧不差以教诫因缘入比丘尼住处波逸提。有诸比丘。僧虽差犹惭愧不敢入。诸比丘尼无教诫故空无所得。以是白佛。佛以是事集比丘僧。告诸比丘。僧所差比丘听入。从今是戒应如是说。若比丘僧不差为教诫故入比丘尼住处波逸提。尔时跋陀比丘尼病。遣信白舍利弗。愿大德来。为我作最后说法。舍利弗言。佛不听僧不差为教诫故入比丘尼住处。以是白佛。佛以是事集比丘僧。告诸比丘。听僧不差为病比丘尼说法。从今是戒应如是说。若比丘僧不差为教诫故入比丘尼住处。除因缘。波逸提。因缘者比丘尼病。是名因缘。若僧不差为教诫故入比丘尼住处。随入多少。步步波逸提。若一脚入门突吉罗。沙弥突吉罗(二十三竟)

佛在舍卫城。尔时诸上座比丘。次第教诫比丘尼。诸比丘尼或别请供养。或以钵囊或以腰绳。或以灯油衣食汤药而用布施。时六群比丘见已语诸比丘。可差我等为教诫人。诸比丘言。如佛所说成就十法。汝等无有。云何求差。六群比丘便作是语。诸比丘为供养利故教诫比丘尼。诸比丘种种呵责。以是白佛。佛以是事集比丘僧。问六群比丘。汝实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘作是语。诸比丘为养利故教诫比丘尼波逸提。若言为供养利故教诫比丘尼。式叉摩那沙弥沙弥尼突吉罗。若言比丘行十二头陀坐禅诵经作诸功德皆为供养利故。语语突吉罗沙弥突吉罗(二十四竟)

佛在舍卫城。尔时诸比丘。与比丘尼独屏处坐。遂生染着不乐梵行。或有反俗或作外道。诸居士见皆讥呵言。此等沙门与比丘尼独屏处坐。正似白衣对于淫女。食人信施而为此事。无沙门行破沙门法。诸长老比丘闻。种种呵责以是白佛。佛以是事集比丘僧。问彼比丘。汝实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘与比丘尼独屏处坐波逸提。与式叉摩那沙弥尼独屏处坐亦如是。沙弥突吉罗。若众多比丘比丘尼共坐。若诸难起。须与独屏处坐皆不犯(二十五竟)

佛在舍卫城。尔时有一阿练若比丘。住阿练若处。初不亲近一切道俗。彼比丘晨朝着衣持钵入村乞食。道逢二比丘尼一比丘尼语一比丘尼言。我今欲与此比丘相识。汝能同不。答言甚善。比丘既至。便为作礼。比丘默然不与共语。二比丘尼复共议言。今此比丘不欲道中与我相识。当共至其住处礼拜问讯。二比丘尼明朝。早往至比丘所礼拜问讯。一礼二礼皆不共语。至第三礼乃言老寿。二比丘尼礼竟而去。彼比丘后复入村乞食。二比丘尼于巷中见礼拜问讯。乃共语言。二比丘尼便以片衣段及染色綖布施比丘。比丘受之。白言。大德疲极。至我住处小息。然后乞食。即便往息。息已临欲乞食。比丘尼复言。此有菜酱。若得食已可还此食。比丘复受其语。得食持还。如是非一。或比丘乞食前还待比丘尼。或比丘尼乞食。前还待比丘。遂至他家更相赞叹。彼比丘后得一好衣。便生谄曲心作是念。我今当以此衣与彼比丘尼。彼必不受。我幸可得惠施之厚。作是念已。先于诸比丘前赞彼比丘尼言。某甲比丘尼。族姓出家信心坚正少欲知足。诸比丘言。夫出家者。应当如是赞。已持衣与彼比丘尼。比丘尼即便受之。失本所图。心怀恼恨。还语诸比丘。某比丘尼信心浅薄多欲无厌。诸比丘言。汝向说某少欲知足。今何以故复说如此。具以上答。诸比丘种种呵责。云何心不舍物。诈以施人。量其不受虚望人感。以事白佛。佛以是事集比丘僧。问彼比丘。汝实尔不。答言。实尔世尊。佛种种呵责。汝岂不闻我赞叹舍物与人然后得大功德耶。汝今云何心不舍物。而诈与人。呵已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘与比丘尼衣。波逸提时诸比丘有亲里比丘尼。衣服卧具悉皆粗弊。疾病医药亦不能得。诸比丘作是念。若世尊听我与亲里比丘尼衣物者。当无此苦。以是白佛。佛以是事集比丘僧。告诸比丘。今听诸比丘与亲里比丘尼衣物。从今是戒应如是说。若比丘与非亲里比丘尼衣波逸提。尔时舍卫城二部僧。得已成衣即共分之。或比丘得比丘尼所宜着。或比丘尼得比丘所宜着。欲共贸易而不敢。以是白佛。佛以是事集比丘僧。告诸比丘。今听诸比丘与比丘尼贸衣。从今是戒应如是说。若比丘与非亲里比丘尼衣除贸易波逸提。若与破戒邪见亲里比丘尼衣突吉罗。若与非亲里式叉摩那沙弥尼衣突吉罗。沙弥突吉罗。若为料理功业事。若为善说经法。或为多诵经戒。与衣皆不犯(二十六竟)

佛在舍卫城。尔时有一少知识比丘尼。得未成衣不知自作。语诸比丘尼言。我不知作衣。愿为作之。诸比丘尼言。姊妹。我多事不得作。可往比丘众中问。有怜愍心者。必为汝作。即往比丘众中言。我少知识。得此未成衣。不知自作。愿为我成。诸比丘答亦如上。复诣长老优陀夷白之如上。优陀夷言。我能作耳。莫数数来催。随我意作。当为汝作。答言。随长老意。于是优陀夷取衣裁缝。经时不得。彼比丘尼来问。大德衣已成未。优陀夷言。先已有要何故来催。答言。我来参问不敢相催。即还所住。优陀夷于后以种种色綖。在中叶上绣作男女交会。时像成已。呼比丘尼还即来取之。优陀夷语言。未可舒视亦莫示人。波阇波提比丘尼往诣佛所时。于都路头。然后舒披。彼比丘尼得衣持去。竟不舒视亦不示人。波阇波提比丘尼至佛所时。乃于都路头披。路人见之。无不抚掌大笑。共相语言。此比丘尼乃能如是巧绣作所欲像自着衣上。彼比丘尼甚大羞耻。即还所住。波阇波提比丘尼卷叠此衣。持到佛所舒以白佛。唯愿世尊视此所作。佛为瞿昙弥说种种法已遣还所住。以此事集比丘僧。问优陀夷。汝实尔不。答言。实尔世尊。佛种种呵责。汝愚痴人。云何作此污辱人衣。呵已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘为比丘尼作衣波逸提。有诸比丘。有亲里比丘尼。衣服败坏乞得衣段。而不知作。诸比丘作是念。若世尊听我与亲里比丘尼作衣者。当无此苦。以是白佛。佛以是事集比丘僧。告诸比丘。今听诸比丘为亲里比丘尼作衣。从今是戒应如是说。若比丘与非亲里比丘尼作衣波逸提。比丘为非亲里比丘尼取衣时突吉罗。割截时染时皆波逸提。缝时针针波逸提。余如与衣中说(二十七竟)

佛在舍卫城。尔时诸比丘于摩竭提国。与诸比丘尼人间游行。或一比丘与一比丘尼俱。乃至众多。或渡深水或上高阪。更相见形生染着心。不复乐修梵行。遂至反俗或作外道。诸白衣见便讥呵言。此辈沙门如人将妇及淫女行。种种讥呵如上独屏处坐中说。诸长老比丘闻。种种呵责。以是白佛。佛以是事集比丘僧。问诸比丘。汝实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘与比丘尼共道行波逸提。有诸比丘与众多伴共道行。见诸比丘尼亦行此路。便作是念。我等将无犯波逸提。以是白佛。佛以是事集比丘僧。告诸比丘。若先不共期。犯波逸提无有是处。从今是戒应如是说。若比丘与比丘尼先期共道行波逸提。有诸比丘。与比丘尼先期共道行。后不敢去。或两相避。以先期致疑。以是白佛。佛以是事集比丘僧。告诸比丘。若先与比丘尼期共道行。若不去若两相避。犯波逸提无有是处。从今是戒应如是说。若比丘与比丘尼先期共道行。从此聚落到彼聚落波逸提。尔时有一比丘尼。于险路中见一比丘。呼言。大德速来。共同道去。彼比丘便往语言。姊妹。佛制不听与比丘尼共道行。比丘尼言。此路险难。而我女弱。依怙大德尔乃得过。答之如前。比丘便去。比丘尼于后为贼剥脱。裸形大唤言。贼剥我贼剥我。彼比丘遥闻。到所住处向诸比丘说。诸比丘将至佛所。以是白佛。佛以是事集比丘僧。告诸比丘。今听诸比丘若险难处有疑畏处与比丘尼共道行。从今是戒应如是说。若比丘与比丘尼先期共道行。从此聚落到彼聚落。除因缘波逸提因缘者。若多伴有疑畏处。是名因缘。若比丘与比丘尼先期共道行无聚落处半由旬波逸提。若与式叉摩那沙弥尼先期共道行亦如是。沙弥突吉罗(二十八竟)

佛在舍卫城。尔时诸比丘于摩竭提国。与诸比丘尼共舡游行。或一比丘与一比丘尼共舡。乃至众多上下舡时相见形体。白衣讥呵。诸长老比丘闻。乃至佛告诸比丘。皆如上共道行中说。今为诸比丘结戒。从今是戒应如是说。若比丘与比丘尼先期共舡行波逸提。有一比丘尼。在阿夷罗河边待舡欲渡。后有一比丘来。比丘尼语言。大德。此间险难可共俱渡。比丘答言。佛制不听我等与比丘尼共载一舡。舡师复言。但俱上舡各在一头。比丘不听。比丘尼言。若不得者大德先渡。比丘即在前渡。舡未到岸。比丘尼被剥赤肉。舡师见之便讥呵言。汝等同共出家。不能相护。况于余人。无沙门行破沙门法。彼比丘还到僧坊。向诸比丘说。诸比丘将到佛所。以是白佛。佛以是事集比丘僧。问彼比丘。汝实尔不。答言。实尔世尊。佛种种呵责。汝愚痴人。云何舍比丘尼使贼剥脱。呵已告诸比丘。从今是戒应如是说。若比丘与比丘尼先期共舡行。若上水若下水除直渡波逸提。余如共道行中说(二十九竟)

佛在王舍城。尔时难陀跋陀。食比丘尼所赞叹食。诸比丘见种种呵责。时舍利弗目犍连游行人间。到王舍城。有一居士闻二人来。便出迎之。头面礼足却坐一面。为说妙法示教利喜。居士即请明日作客比丘食。默然受之。居士即还其家。办种种饮食敷好坐具。舍利弗目犍连。至时着衣持钵往到其舍。舍利弗在前欲入。偷罗难陀比丘尼先在此家。闻其语声即住不入。彼比丘尼见办种种饮食敷好坐具。问言。为欲请王为是婚姻。答言。今不请王亦非婚姻。欲供养尊者舍利弗大目揵连耳。比丘尼言。云何不请大龙。而供养此小德比丘。居士问言。谁是大龙。答言。六群比丘。又言。若欲请族姓出家行头陀四念处乃至八圣道分须陀洹乃至阿罗汉比丘。欲求好婿好儿生天解脱现世富贵。当供养六群比丘。如是赞叹已默然而住。舍利弗目犍连然后乃入。彼比丘尼前问讯言。善哉尊者可就此坐。复语居士言。善哉居士。汝今大得福利。请如是大龙比丘。居士便呵言。汝向言小德。今言大龙。作此反覆。如何无耻。从今已去莫入我家。我亦不复供养于汝。于是居士手自下食。食竟行水。取小床于二比丘前坐。为说妙法已从坐起去。还向佛所。佛遥见便语言。善来舍利弗目犍连。从何处食客比丘食。答言。世尊向到一居士家有一比丘尼。或见名为小德。或见名为大龙。佛问。所说何等。具以事答。佛以是事集比丘僧。问六群比丘。汝等实食比丘尼赞叹食不。答言。实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘食比丘尼赞叹食波逸提。有诸比丘尼于屏处赞叹。比丘食后乃知便生惭愧。我将无犯波逸提耶。以是白佛。佛以是事集比丘僧。告诸比丘。若不知比丘尼赞叹得食食。犯波逸提者无有是处。从今是戒应如是说。若比丘知比丘尼赞叹得食食波逸提。尔时有一家请五百比丘食。其家先所供养比丘尼作是言。与诸比丘食莫使失时。诸比丘闻便生惭愧。不敢复食。还以白佛。佛以是事集比丘僧。告诸比丘。若比丘尼先不赞叹。临食时作是语。好与诸比丘食。比丘食此食。犯波逸提者无有是处。从今是戒应如是说。若比丘知比丘尼赞叹因缘得食食。除檀越先发心作。波逸提。赞叹者。赞叹得过人法。若式叉摩那沙弥沙弥尼比丘赞叹因缘得食食突吉罗。沙弥突吉罗(三十竟)

佛在王舍城。时有一大臣。常供养佛及比丘僧。有一贫人见作是念。今此大臣得大善利。乃能如此供佛及僧。若我有物亦当如是。复作是念。我今无物。正当佣赁以用供养。即便客作。日食一食留一食分。主人问言。汝何以留一食分。答言。我且留之后当并取。如是经时。知所得已足。语主人言。可尽以作直为我办种种食具。主人问言。汝今贫穷。云何尽以作直。顿办种种饮食之具。答言。我见王舍大臣常请佛及僧种种供养。我作是愿。亦当如是。是以客作欲遂此意。今计作直足一供养。所以于今顿办食具。主人闻之生希有心。如是贫人苦身佣赁。得少财物尚用供养。况我财富。发心之顷饮食已具。而不能为。即雇数倍使其任意办众甘美。于时作人。即持财物来诣佛所。供办极世殊味饮食。缘其意至鬼神来助。倏忽之顷自然都办。正遇节日多饶供养。众人竞来请就家食。诸比丘共相语言。今日贫人竭力作会。人人皆当为之稍食。虽相诲语所食极少。而请处多遂至饱满。时彼贫人食具已办。唱言时到。于是诸比丘皆集就坐。唯佛住房。时彼贫人。手自斟酌欢喜下食。比丘虽受所食甚少。贫人作是念。诸比丘为是愍我贫穷恐食不足。为是食恶不可进啖。即以问之。诸比丘中少惭愧者答言。恐汝食少。故于余家处处先食。贫人恨言。云何先受我请。而余家食我本肆力期尽供养。今诸大德虽不能啖。愿随意持去。勿令有余。诸比丘闻已便复强食。然犹不尽所供之半。众僧食讫贫人复作是念。我强劝僧食故当不得罪耶。以是白佛。佛言。善哉贫士。汝能见人作福。佣力慕及。虽受人身。生天因缘皆已具足。从汝发心欲供养佛及僧已来。随事皆得无量功德。正使众僧不食一粒。于汝功德无不具足。汝今当复得现世报。贫人闻已欢喜踊跃。佛更为说种种妙法。即于坐上远尘离垢得法眼净。彼见法已。受三自归奉持五戒从坐起头面礼足右绕而退

尔时有五百贾客。从优禅那国来。道路迥绝。绝粮三日。前遣马使募求熟食。遍语人言。我等五百贾客从优禅那国来。绝粮三日。故先遣我求诸熟食。若有熟者不计价直。城中人言。此间无有。唯一贫人于僧坊设会。大有余长。汝往求之。必得无疑。于是彼使。即便驰往。具以情告。贫人答言。我今设食不为财利。但当速来莫论价直。使人闻之。出非本望欢喜还报。须臾俱至。咸言。速与我食当厚相报。答亦如初。即便下食。既饱满已。借问余人。此人有何事业。乃能如此种种施设。有人具以事答。众贾闻已倍增希有。即敛百千两金以酬其施。又复借问。此城某甲今为在不。答言已死。又问。彼有子孙不。答言。向之施主即是其子。诸贾客等闻之。依然语贫人言。汝父是我等师。又与百千两金以敦旧情。王舍大臣及所赁主。闻见此事益怀欢喜。复各送百千两金以结新好。即日瓶沙王复拜为大臣。一日之中蔚然富贵。国人号为忽起长者。诸比丘以是白佛。佛以是事集比丘僧。问诸比丘。汝等实受人请而先食他食不。答言。实尔世尊。佛种种呵责。汝愚痴人。云何已受人请而先食他食。呵已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘数数食波逸提。尔时毕陵伽婆蹉等八十比丘。皆得重病不能顿食。以是白佛。佛以是事集比丘僧。告诸比丘。今听病比丘数数食。从今是戒应如是说。若比丘数数食除因缘波逸提。因缘者病时。是名因缘

尔时世尊。听诸比丘受迦絺那衣。不犯五事。诸比丘作是念。为是衣时不犯数食。衣竟亦不犯耶。以是白佛。佛以是事集比丘僧。告诸比丘。衣时不犯。过衣时犯。从今是戒应如是说。若比丘数数食。除因缘波逸提。因缘者。病时衣时。是名因缘。有诸白衣。知比丘不得数食。作是念。我当作方便为诸比丘作衣。比丘来受并得供养。即便作衣请诸比丘。诸比丘言。我等不得食但与我衣。诸白衣言。大德。若受我食乃当与衣。诸比丘作是念。世尊若听我以施衣故数食者可不乏衣。以是白佛。佛以是事集比丘僧。告诸比丘。今听诸比丘为施衣数数食。从今是戒应如是说。若比丘数数食。除因缘波逸提。因缘者。病时衣时施衣时。是名因缘。尔时阿难诣长者家。长者家设诸饮食。阿难忘先受请。便受彼食。垂食乃忆。语主人言。可还摄食。我先受请不得复食。长者恨言。云何已受我食。而忽中悔。于是阿难驰还白佛。佛言。若有如是因缘。应先心施。作是念。我请分与某甲比丘。然后可食。若不念施人而食突吉罗。尔时或有前请后设食。或有后请前设食。诸比丘不知云何。以是白佛。佛言。请时应语言。随前设食者当食。数数食者。先受他请后于余处食。是名数数食。比丘尼亦如是式叉摩那沙弥沙弥尼突吉罗。若僧所差。若别房食。若白衣来受八戒设供养。若常食不犯(三十一竟)

佛在王舍城。尔时调达。为求援助故。教化诸居士。或令一家请四僧或五或十。诸长老比丘。呵责受请比丘言。云何为援助调达故受别请众食。以是白佛。佛以是事集比丘僧。问诸比丘。汝实受调达别请众食不。答言。实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘受别请众食波逸提

有病比丘。牵病乞食其患增甚。诸居士语言。莫牵病乞可就我食。答言。世尊结戒不听我等受别请众食。若以供养众僧我等便自得分。诸居士言。我等家贫不能得广。正可力办供养病者。太德若须便可来取。诸比丘不知云何。以是白佛。佛以是事集比丘僧。告诸比丘。今听病比丘受别请众食。衣时施衣时。如数数食中说。从今是戒应如是说。若比丘受别请众食。除因缘波逸提。因缘者。病时衣时施衣时。是名因缘。有诸比丘欲作衣。为乞食故衣不即成。妨废行道。作是念。若作衣时。佛听我受别请众食者。衣得速成不废行道。以是白佛。佛以是事集比丘僧。告诸比丘。今听诸比丘作衣时受别请众食。从今是戒应如是说。若比丘受别请众食。除因缘波逸提。因缘者。病时衣时施衣时作衣时。是名因缘。有诸比丘共伴行到一聚落。语诸伴言。我等入村乞食可小见待。答言。不须乞食我当相与。比丘言。世尊不听我等受别请众食。遂入村乞。诸伴舍去。比丘乞食已。不复及伴。被贼赤肉。诸比丘作是念。世尊若听我行路时受别请众食者不遭此难。有诸比丘。寄载人舡至时乞食。舡主舍去。致诸苦难亦复如上。皆以白佛。佛以是事集比丘僧。告诸比丘。从今听诸比丘行路时舡上行时受别请众食。从今是戒应如是说。若比丘受别请众食。除因缘波逸提。因缘者。病时衣时施衣时作衣时行路时舡上行时。是名因缘。诸佛常法。岁二大会春夏末月。诸方比丘皆来问讯。以众多故。次请甚疏乞食难得。诸比丘作是念。若世尊听我等大会时受别请众食者不致此苦。以是白佛。佛以是事集比丘僧。告诸比丘。今听诸比丘大会时受别请众食。从今是戒应如是说。若比丘受别请众食。除因缘波逸提。因缘者。病时衣时施衣时作衣时行路时舡上行时大会时。是名因缘。尔时瓶沙王弟。名曰迦留。事一种道。而年年普请九十六种沙门作一大会。闻释子沙门不受别请众食。而力不得能广及众僧。以阙无佛道沙门故愁忧不乐。作是念。我当云何致沙门释子。唯当委王。然后可果。便以白王。王以是事即出诣佛。具说弟之情愿。王去后。佛以是事集比丘僧。告诸比丘。今听诸比丘沙门会时受别请众食。从今是戒应如是说。若比丘受别请众食。除因缘波逸提。因缘者。病时衣时施衣时作衣时行路时舡上行时大会时沙门会时。是名因缘。别请众食者。若于众中别请四人已上。是名别请众食。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗。若始受别请众食。既往而分。言受异请。不复成众不犯(三十二竟)

佛在王舍城。尔时诸处饥馑乞食难得。一切比丘尽集王舍城。四远人言。我等先时朝暮见诸比丘。今何以断绝不复见之。有人言。此间乞食难得。悉往王舍城。是以不见。诸人言。我等宁可建立小屋。日作一比丘一宿一食。若无来食者便当聚集俟后来众。即便作之。时有一家恒作美食。六群比丘游行人间常住其家。余诸比丘都不复得。语居士言。汝为僧故作一宿食。如何使我不得一豫。居士答言。我本为僧作此处所。而六群比丘住不肯去。使我不复得见余僧。此是彼过。非是我咎。诸长老比丘闻。种种呵责六群比丘。以事白佛。佛以是事集比丘僧。问六群比丘。汝等实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘施一食处。过一食者波逸提。时舍利弗得风病。到一食处食一食已。便欲余行。诸比丘言。长老疾患不须余行。我等当以食分相供养。答言。世尊不听一宿处过一食。有诸居士。闻舍利弗疾患。亦共请住。答亦如初。于是舍利弗牵病而去。诸比丘作是念。若世尊听病比丘于一食处过一食者便无此苦。以是白佛。佛以是事集比丘僧。告诸比丘。今听诸病比丘于一食处过一食。从今是戒应如是说。若比丘无病施一食处。过一食波逸提施一食处。众多比丘暮同时至。若檀越施非时浆若涂足油。听次第受。明日随次受食。若无则止一食已应去。若檀越留听住。若去已有缘事宜还。当白主人。主人听住则住不听应去。若后来比丘应得一食食。有余应与主人所留比丘。若比丘来。而一食处多。诸比丘应分张住。若亲里家过一食突吉罗。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗。若有诸难不得去不犯(三十三竟)

佛在王舍城。时有女人欲还夫家。办种种饼以为道粮。有一比丘次第乞食。往到其舍。女问言。欲须何等。答言须食。复问。能啖佉阇尼不。答言能。即取钵盛种种饼与之。彼比丘得已。语余比丘言。某甲家多有美食。汝可往乞。诸比丘闻。皆往从乞。所有熟食施之都尽。时彼夫家遣人催之。答言。资粮未办。复作种种食如是至三。比丘来乞皆尽与之。夫家三催。答皆如初。便大嗔忿。谓有异意。遣使报言。我已更求婚。不复用汝瞎女。于是女家咸嗔恨言。由沙门释子使我女寡。复种种骂詈丑言溢口。邻人语言。他薄汝女何预沙门。即具以答。不信乐佛法者。咸皆言快。由敬沙门致有此事。若复亲近剧当过是。尔时复有贾客主。语诸贾人言。可办资粮。某日最吉。当共发去。即皆备办种种饮食。有一比丘次第乞食。到一贾人家。贾人问言。欲须何等。答言须食。问能食饼糗不。答言能。即取钵盛满与之。比丘得已语诸比丘言。某甲家多有美饮食。汝可往乞。诸比丘皆往悉得。粮食遂尽。贾客主言。吉日今到。应共发去。此贾人言。粮食未办。贾客主言。我先宣令备办粮食。何故于今方言未办。答言。沙门来乞与之悉尽。贾客主言。今是吉日不得不发。我便先去。汝可后来。于是便发。后还安隐大得宜利。彼一贾人后去。遭贼失物荡尽。便啼哭言。由沙门释子遭此穷厄。贼问言。我夺汝物何以怨人。具以事答。诸贼闻已复语之言。汝亲近沙门。正应打杀正应夺物。若复有亲近者。亦当如是。诸长老比丘闻。种种呵责。以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘到白衣家。自恣多与饮食。若饼若糗。若须二三钵应受。过是受者波逸提。有诸病比丘入村乞食。有一居士自恣多与。过二三钵不敢复受。以是白佛。佛以是事集比丘僧。告诸比丘。今听病比丘过二三钵受。从今是戒应如是说。若比丘到白衣家。自恣多与饮食。若饼若糗。若须二三钵应受。若无病过是受者波逸提。有诸比丘就请家食。食已复从主人索食持去。诸比丘以是白佛。佛言。若就请家食。不得更索持去。若不就请家食听持去。有诸比丘。受二三钵持去已。不与诸比丘共食。以是白佛。佛以是事集比丘僧。告诸比丘。应与诸比丘共食。从今是戒应如是说。若比丘到白衣家。自恣多与饮食。若饼若糗。若不住其家食须二三钵应受。出外与余比丘共食。若无病过是受。及不与余比丘共食波逸提。自恣与食者。来乞辄与。若比丘第一钵受。还应语余比丘。我已某家受一钵。余二钵在。须者往取。若第二钵受。应言。我已某家受二钵。余一钵在。须者往取。若第三钵受。应言。我已某家受三钵食。莫复往取。若不宣语突吉罗。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(三十四竟)

佛在王舍城。尔时诸处饥馑乞求难得。诸比丘尽还王舍城。王舍城诸居士。问诸比丘。僧有几人食有几许。答言。僧有若干食有尔许。时诸居士共作议言。我等当为诸比丘随力作食。于是或有一人。作一比丘食。乃至十比丘食。或有二人乃至十人。共作一比丘食乃至十比丘食。办食具已。诸居士主复作是念。我等虽复随力作食食一人十人。必不周普。今当敛物普为作食。若不足者我当足之。即便敛取。其中有贫穷者。虽心无惜而无好米。随家所有豆麦之属以充此敛。彼居士主。即差次作之。饮食粗恶。老病比丘皆不饮食。持与乞人或与外道。更往知识家食。诸居士知。便讥呵言。我等减割身口妻子之分种福田中。云何比丘薄我此食。用乞乞人及诸外道更求美味。此辈本求解脱离老病死。如何于今反求美好。无沙门行破沙门法。时跋难陀主人次至监食。跋难陀众中食已。复就其家索美好食。彼人问言。大德向不在众中食耶。答言。在众中食。恐檀越失别施福。是以更来。彼人便讥呵言。今世饥俭众人罄竭共作众食。云何薄此更求美好。诸比丘闻。种种呵责。以是白佛。佛以是事集比丘僧。问跋难陀。汝实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘食竟更食波逸提。尔时毕陵伽婆蹉等八十比丘得病。诸比丘为其请食。食不尽弃着房前。诸居士见问言。此是何等食。答言。是病比丘残食。诸居士言。何不少取。答言。诸病比丘或有多食或有少食。我等所以不得小取。居士复言。今世饥俭以一粒施乃可生天。云何弃之而不惠施。或复有言。此辈沙门宁弃于地不以施人。我等既已施僧。一粒堕地便谓大罪。如何比丘不惜此物。诸长老比丘闻。种种呵责。以是白佛。佛问阿难。颇有人能食此食不。答言。看病比丘为请此食而其自食初不充足。欲啖此残食而复不敢。佛以是事集比丘僧。告诸比丘。今听诸比丘食病比丘残食。尔时王舍城众僧食竟。有比丘于外得食持还。诸比丘不知云何。以是白佛。佛言。可以此食与病比丘。即便与之。病比丘言。此食增病我等不须。以是白佛。佛言。听诸比丘于病比丘人边作残食法食。尔时王舍城众僧食竟起去。复有比丘于外得食持还。病比丘已差。不知云何。复以白佛。佛言。应在食未竟比丘边作残食法食。若无应在未食比丘边作。若众中无未食比丘。应近处觅。若近处复不得者。与应受具足戒沙弥速受戒。然后于是人边作残食法食。佛以是事集比丘僧。告诸比丘。从今是戒应如是说。若比丘食竟不作残食法食波逸提。有比丘晨朝请诸比丘作小食与。时饮佉陀尼食赊陀尼食。诸比丘谓已是足食不敢复食。以是白佛。佛言。此不名为足食。有五种食。名为足食。饭干饭饼糗鱼肉。于此五食。一一食中有五事。名为足食。一者有食二者授与。三者受啖。四者不复受益。五者身离本处。若离本处已。更得时食饭饼。不作残食法食。口口波逸提。诸比丘不知作残食法白佛。佛言。持食着钵中手擎。偏袒右肩右膝着地作是言。长老一心念。我某甲食已足。为我作残食法。彼比丘为取钵。问言。是食与我耶。答言与。便为食少许。余残还之。若都不食。但取已还之。语言。此是我残与汝。亦名残食。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(三十五竟)

佛在王舍城。尔时有二比丘共为亲友。一人聪明一人闇钝。其闇钝者数数犯恶。其聪明者恒语其罪教令悔过。其闇钝者心转怀忿。作是念。我今亦当伺其过罪。伺之不得。便于彼食竟。以不作残食呼令食之。彼比丘以亲厚故都不怀疑。即便为食。食已语言。汝食非残食犯罪应悔。莫不修梵行长夜受苦。时彼比丘呵责言。我欲益汝故相教呵。云何以此见恨陷我于罪。诸长老比丘闻种种呵责。以是白佛。佛以是事集比丘僧。问彼比丘。汝实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘不作残食法。强劝已食。比丘食。欲使他犯罪。波逸提。有比丘足食已。诸比丘不知。复呼令食。彼比丘言。我已食竟。诸比丘便生疑。我故当不犯波逸提耶。以是白佛。佛以是事集比丘僧。告诸比丘。若不知他食竟呼食犯波逸提无有是处。从今是戒应如是说。若比丘知他比丘食竟。不作残食法强劝令食。欲使犯罪波逸提。若劝已食。比丘食。不作残食法食。若彼食时。口口波逸提。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(三十六竟)

佛在王舍城。尔时世尊。未制比丘受食食。诸比丘各在知识家不受食食。诸白衣讥呵言。我等不喜见此恶人着割截坏色衣不受食食。不受食食是为不与取。尔时大迦叶着粪扫衣。于街巷处处拾弃食而食。诸居士见讥呵言。此沙门正似狗。趣得食食不净可恶。云何令彼入我等家。诸长老比丘闻二事已。以是白佛。佛以是事集比丘僧。先问诸比丘。汝等实不受食食不。答言。实尔世尊。佛种种呵责已。又语迦叶。汝虽少欲而为人恶贱。不应食弃去食。若食突吉罗。告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘不受食着口中波逸提。时诸比丘为作人作食。不敢尝或碱或淡。作人嗔恨不肯复作。以是白佛。佛以是事集比丘僧。告诸比丘。今听为作人尝食。但不得咽。从今是戒应如是说。若比丘不受食着口中除尝食波逸提。时诸比丘不受杨枝及水。便不敢嚼及漱口。口臭眼闇。共人语时人闻其气。问言。大德口何以臭。诸比丘甚羞耻。便乞受杨枝及水。诸人言。汝自懒取。谁为汝惜杨枝及水。诸比丘以是白佛。佛以是事集比丘僧。告诸比丘。今听不受杨枝及水。从今是戒应如是说。若比丘不受食着口中。除尝食杨枝及水波逸提。尔时舍利弗得风病。目连往问。汝在家时曾有此病不。答云有。何方治差。答言食藕。于是目连。到阿耨达池取藕与之。舍利弗问。何处得此。答言阿耨达池。又问从谁受。答言从龙。便不敢食以是白佛。佛言。听从龙受食。时大迦叶从贫家乞食。释提桓因作是念。今大德迦叶从贫家乞。我今当作方便使受我食。即于迦叶乞食之次。作一贫穷织师在机上织。复化作一女人为其作纬。迦叶从乞。即取钵盛百味饮食与之。迦叶得已作是念。此人贫穷何从得此。即入定观。知是帝释。语言憍尸迦。后莫复作。遂不敢食以是白佛。佛言。今听诸比丘从天受食。尔时世尊。行于迥路暮至旷野鬼村。时彼鬼神见佛欢喜。便请佛及僧设明日供。佛默然受之。鬼即竟夜作种种饮食。晨朝敷坐请佛及僧。佛敕诸比丘。共受彼请。即皆就坐。鬼神手自下食。诸比丘不敢受。以是白佛。佛言。今听诸比丘从鬼受食。尔时世尊游娑罗树林时有一猕猴。从树上下取佛钵欲持去。诸比丘捉不听。佛告比丘。听猕猴取钵。即持钵到一树上取满钵蜜上佛。佛见有虫不受。猕猴谛视见虫即便拾去复以上佛。佛为受之。于是猕猴欢喜踊跃却行而退。佛持此蜜与诸比丘。诸比丘不敢食。以是白佛。佛言。听食猕猴授食。尔时有贩马人。请佛及僧行水已。有人语言。火烧马屋。彼以此不展授食。语比丘言。可自取食。言已便去诸比丘疑不敢食。以是白佛。佛言。若无净人听诸比丘以施主语食为受食。复有诸白衣。遥掷食与比丘。比丘以是白佛。佛言。不得受遥掷食。有诸老病比丘眼闇。受食时触净人手数洗烦劳。以是白佛。佛言。应受草叶敷之以手按边令食着上。此亦名受。诸比丘便广敷草叶。以是白佛。佛言不应广敷。敷齐手所及处。有诸白衣。恶贱比丘不肯亲授。以食着比丘前地。语令自取。诸比丘不知云何。以是白佛。佛言。若施主恶贱不肯授食。亦听以彼语取为受食。有四种受。身授身受。物授物受。手授手受。教取而受。有碱水比丘不受不敢饮之。以是白佛。佛言。若不着盐性碱。听不受饮。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(三十七竟)

五分律卷第七五分律卷第八(弥沙塞)

        宋罽宾三藏佛陀什共竺道生等译

    初分堕法

佛在王舍城。尔时未为比丘制非时食。诸比丘于暝夜乞食。或堕沟堑。或触女人。或遇贼剥。或为虫兽之所伤害。食无时节废修梵行。时迦留陀夷着杂色衣。面黑眼赤闇中乞食。有一怀妊妇人。电光中见。便大惊唤言。毗舍遮毗舍遮。迦留陀夷言。我是沙门乞食。非毗舍遮。便苦骂言。汝何以不以刀决腹。而于暝夜闇中乞食。余沙门婆罗门一食便足。汝今云何食无昼夜。诸长老比丘闻。种种呵责。以是白佛。佛以是事集比丘僧。问迦留陀夷。汝实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘非时食波逸提。尔时有比丘。服吐下药不及时食腹中空闷。诸比丘不知云何。以是白佛。佛言以酥涂身。犹故不差。佛言以糗涂身。犹故不差。佛言酥和糗涂身。犹故不差。佛言以暖汤澡洗。犹故不差。佛言与暖汤饮。犹故不差。佛言以盆盛肥肉汁坐着中。以如此等足以至晓。一切不得过时食。非时者。从正中以后至明相未出。名为非时。若比丘非时非时想非时疑非时时想皆波逸提。时非时想时疑突吉罗。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(三十八竟)

佛在王舍城。尔时世尊。未为比丘制食残宿食。彼有神庙。是游戏处。众人竞赍美食就中观看。或经信宿肴膳丰多。诸比丘于彼得食。食不能尽。房中殷积无处不有。来致虫鼠穿坏屋壁。诸居士见问言。谁积此食。有人言。沙门释子。即皆讥诃。此秃头辈。唯知贪受不计损费。无沙门行破沙门法。复有一阿练若比丘。住阿练若处作是念。日日乞食妨废行道。便并乞种种食。或直尔举。或曝令燥。时诸比丘游行见之语言世尊不说衣趣蔽形食趣支身耶。何以多积饮食曝晒狼藉。彼比丘言。此去村远。日日乞食妨废行道。是以并乞用息烦劳。诸比丘以是白佛。佛以是事集比丘僧。问彼比丘。汝实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘食残宿食波逸提。残宿食者。已受之食留之经宿。名为残宿食。若食此食口口波夜提。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(三十九竟)

佛在王舍城。尔时此国饥馑。乞食难得。二十八鬼神将军。来诣佛所头面礼足白佛言。世尊。今世饥馑。愿佛游行人间。我等当化众人使发善心。世尊默然许之。时四天王释提桓因娑婆世界主梵天王。亦来诣佛头面礼足却住一面。如上白佛。佛亦默然许之。于是世尊。从王舍城。与大比丘僧千二百五十人俱。复有五百比丘尼五百优婆塞五百优婆夷。共游摩竭国。复有外道男女千人五百乞儿。皆随佛后求乞残食。世尊所至之处。无不倾竭供养。四远持供来者皆不得设。饮食丰长极有所兼。诸比丘各以所食之余。与外道男女及乞食人。诸白衣见便讥呵言。沙门释子得便尽受。食之不尽与诸邪见。不如构乳之人知留犊子。或复有言。沙门释子尚供养外道。我等何为而不奉事。于是世尊。进至安那频头邑。时有大婆罗门。名曰沙门。以五百乘车重载饮食逐佛。五月余日求次设供。竟未能得。其家追言。农时欲过。可还附业。时婆罗门到阿难所。语阿难言。我五百乘车载诸饮食。欲供佛及僧。逐佛已来五月余日。犹未得设。家信见追不得复住。欲以食具散布道中令佛及僧踏上而过。于我宿心便为得遂。阿难答言。当白世尊。即以白佛。佛语阿难。汝可将婆罗门看供食家。若有所无教令作之。阿难受教。将婆罗门看供食家。见无有粥及油蜜煎饼。彼便作七种粥二种饼。晨朝白佛。饼粥已办。佛语阿难。汝助下之。阿难受教。助下粥饼。时有外道。母人抱一小女。阿难以其有儿偏与二饼。诸外道言。此比丘染着母人偏与二饼。复有言。政当以其抱儿。非偏之谓。共诤纷纭遂乱座席。阿难见已心不自安。便到佛所。并以前事白佛。佛以是事集比丘僧。问阿难。汝实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘与外道若男若女食波逸提。复有诸比丘。与裸形外道食。彼裹一裹饼入王舍城。诸人问言。从何处来。答言。从秃头居士间来。复问裹中何物。答言是蜜煎饼。复问从谁得。答言。诸居士以沙门释子为福田。沙门释子复以我为福田。从彼受得。诸人便讥呵言。沙门释子不知节量。贪受无厌。我等减割妻子身口之分。以用供养。乃持与此邪见恶人。若应供养我当供养。何假沙门。诸长老比丘闻种种呵责。以此白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言。实尔世尊。佛种种呵责。有衣无衣有何等异。种种呵责已告诸比丘。从今是戒应如是说。若比丘与外道裸形若男若女食波逸提。有诸外道食时来乞。诸比丘不敢与。便嗔骂言。沙门释子教人布施。而自悭惜何道之有。而致信敬诸白衣闻。亦讥呵言。云何沙门恒就人乞。而不乞人。复有比丘外道亲亲来乞。亦不敢与以是白佛。佛以是事集比丘僧。告诸比丘。今听诸比丘与外道食。但莫自手与。从今是戒应如是说。若比丘自手与外道裸形若男若女食波逸提。若外道来乞。应以己分一揣别着一处使其自取。不应持僧食与。若乞乞儿乞狗乞鸟。应量己食多少取分然后减以乞之。不得取分外为施。沙弥突吉罗。若父母是外道。自手与不犯(四十竟)

佛在王舍城。尔时有诸白衣来诣僧坊。问诸比丘。僧有几人。诸比丘言。僧有若干人。诸白衣言。我等明日尽请众僧顾临薄食。六群比丘语言。汝若与我乳酪酥油鱼肉者当受汝请。诸人答言。当须假贷市买办之。语已各还其家。或假贷不果。或市买不得。明日食具已办。唱言时到。众僧着衣持钵。往诣其家就坐而坐。行水下食。六群比丘言。何以无有乳酪酥油鱼肉。答言。假贷不果市买不得。六群比丘便倒钵而去。诸白衣咸作是言。此等不得美食倒钵而去。为是国王为是大臣。夫出家者。为求解脱乞食趣足。而今云何反着美味。无沙门行破沙门法。诸长老比丘闻。种种呵责。以是白佛。佛以是事集比丘僧。问六群比丘。汝实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘到白衣家。求乳酪酥油鱼肉者波逸提。后诸比丘得诸美食。不敢啖或啖已出罪悔过。以是白佛。佛以是事集比丘僧。告诸比丘。若不索美食自得而啖。犯波逸提者无有是处。从今是戒应如是说。若比丘到诸白衣家。求如是美食乳酪酥油鱼肉。若得啖波逸提。有诸病比丘。医教食美食。诸比丘言。佛不听我索。云何可得。作是念。佛听我索此食者病乃得差。以是白佛。佛以是事集比丘僧。告诸比丘。今听病比丘索美食。从今是戒应如是说。若诸家中有如是美食乳酪酥油鱼肉。若比丘无病为己索得食者波逸提。若为病比丘索。若从亲里家。若知识家索。皆不犯。沙弥突吉罗(四十一竟)

佛在舍卫城。尔时跋难陀。常受一婆罗门供养。后时着衣持钵往到其家。婆罗门不在。便与其妇独坐共语。时婆罗门淫欲心发。中道而还。见跋难陀与妇共语。作是念。今此比丘说法非行欲时。便还出外。欲心转盛。须臾复入。跋难陀犹故未去。复如前念。抑制而出。须臾复入。语其妇言。速与比丘食发遣令去。勿废其行道。妇知其意。不欲令夫违道从欲。答言。令比丘徐徐食。有何急事。如是三反。跋难陀犹不肯去。婆罗门便语言。我等白衣多诸缘事。于空缺时宜近房室。汝不知时坐不肯去。谁知汝辈修于梵行。诸长老比丘闻。种种呵责。以是白佛。佛以是事集比丘僧。问跋难陀。汝实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘食家中与女人坐波逸提。食者男女情共相食。坐者知妨其事而故坐。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗。若多人共坐。若有障隔。若夫妇受八戒日不犯(四十二竟)

佛在舍卫城。尔时跋难陀。常受一婆罗门供养。后到其家。婆罗门不在。与其妇屏处坐。婆罗门还。语其妇言。汝与比丘屏处坐。我诚无疑。人见必当谓汝作恶。损毁沙门辱我门户。复语跋难陀。我诚不疑大德。大德不当慎此恶名。其妇自猗好颜色力多儿女力巧致财力。便呵夫言。我与比丘坐。要不累汝。汝今不须作此过言。婆罗门便大嗔恚。责跋难陀言。我等白衣尚不与人妇女独屏处坐。汝等沙门反便作此。无沙门行破沙门法。诸长老比丘闻种种呵责。以是白佛。佛以是事集比丘僧。问跋难陀。汝实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘与女人独屏处坐波逸提。沙弥突吉罗(四十三竟)

佛在舍卫城。尔时跋难陀。常受一婆罗门供养。后到其家。婆罗门不在。与其妇露处共坐。乃至佛种种呵责。皆如屏处坐中说。告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘与女人独露处坐波逸提。沙弥突吉罗(四十四竟)

佛在舍卫城。尔时边境有事。波斯匿王严四种兵欲往讨伐。六群比丘共相语言。我闻灌顶王征伐之时军仪严饰。我等未见。可共往观。便往路侧。前锋军见皆悉嗔言。今日云何见不吉人。我等在家厌见此等。于今军行复不得免。若王不敬信当断其头。时王遥见六群比丘。亦复不喜。即遣人问。诸大德何以在此。答言。我等闻灌顶王出军之时军容严饰。未曾所见故来看耳。王作是念。谁能以此白佛。复作是念。若白不白。佛自当知。即以石蜜干姜寄六群比丘言。大德。为我持此奉上世尊。致敬无量。军尽之后各还所住。以王所寄奉上于佛。白佛言。王致敬无量。佛问六群。汝何由见王。具以事答。佛以是事集比丘僧。种种呵责六群比丘言。汝等愚痴。所作非法。军发行时。以见沙门为不吉。此必众军嗔嫌王恨汝。故持物与我。呵已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘观军发行波逸提。若发心欲观及作方便。已行步步。若见不闻。若闻不见。皆突吉罗。若闻若见别军容饰。若前若却皆波逸提。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗。若行路若经行处遇见不住看不犯(四十五竟)

佛在舍卫城。尔时异道作是议。今波斯匿王及信法大臣皆不在。及今无能与我作阂。我等当共并力于祇洹中凿渠通水。诸比丘闻之。语诸优婆塞优婆夷言。可往白王。非是我等力所能制。会王及大臣乙师达多富兰那须达多等。久不见比丘。遣使来迎。诸比丘议言。若佛听我往到军中者。必不使异道于祇洹中凿渠通水。以是白佛。佛言。今听诸比丘往军中。诸比丘奉教便受王请。到已具以白王。王即有令。若有于祇洹中通渠者。当族诛之。然后为诸比丘设种种供养。诸比丘既得肴膳。便不复欲还。军人讥呵言。此非阿练若住处。我等白衣不得免此。沙门何为复在其中。或复有言。此辈比丘不信乐佛法。得美食处便住耳。无沙门行破沙门法。诸长老比丘闻种种呵责。以是白佛。佛以是事集诸比丘僧。问诸比丘。汝等实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘有因缘到军中乃至二三宿。若过波逸提。虽有因缘。若遣书信得了。应遣书信。要须自往。然后得往。事讫便还。不得经宿。若不了应一宿。一宿不了应再宿。若复不了应三宿。若了不了过三宿波逸提。若事即了不应宿而宿突吉罗。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(四十六竟)

佛在舍卫城。尔时诸比丘。到军中再三宿。观军着仗列阵乃至战时。战士见之咸嗔忿言。此不吉人已复来此。王若不信乐。佛法。我当先断其头然后击贼。遂因乱战。射诸比丘多所伤害。诸比丘共相负辇还归所住。路人见之亦大忿言。如此沙门正应射杀。何以无故观战阵为。无沙门行破沙门法。诸长老比丘闻。种种呵责以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘有因缘到军中二三宿观军阵合战波逸提。若观鸟兽斗突吉罗。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(四十七竟)

佛在舍卫城。尔时有比丘。名阿梨吒。生恶邪见言。我解佛所说。佛说障道法实不障道。诸比丘问言。汝实作是语。我解佛所说。佛说障道法实不障道不。答言如是。诸比丘复问。汝云何作是解。答言。此间有质多须达多二长者及诸优婆塞。皆在五欲为欲所吞为欲所烧。今得须陀洹斯陀含阿那含道。又诸外道不舍本见。于正法出家。亦得四沙门果。以是故我作是解。诸比丘欲令舍此恶邪见故。谏言。汝莫作是语。莫谤佛莫诬佛。佛不作是语。应舍是恶邪见。佛种种方便呵欲。说欲如赤骨聚乃至如毒。若受五欲为欲所烧欲觉所迷。及诸外道不舍本见得四沙门果。皆无是处。诸比丘如是谏。更增邪见坚持不舍。诸比丘便到舍利弗所。白言。大德阿梨吒作是邪见。具说如上。愿哀愍故谏喻令舍。舍利弗默然许之。即到其所。共相问讯却坐一面。问言。汝实作是语不。答言。实尔。更广说如前。舍利弗谏言。汝莫作是语。汝之所说非法非律。种种呵责言。彼比丘坚持不舍。从坐起去往到佛所。广以白佛。唯愿世尊怜愍故教此比丘舍恶邪见。佛便敕一比丘。汝呼阿梨吒来。即受教往语。大师呼汝。阿梨吒即来。头面礼足在一面住。佛问阿梨吒。汝实作是语不。答言实尔世尊。佛又问。汝作云何解我所说。答亦如前。佛言。汝愚痴人。莫谤如来莫诬如来。何以故。我说障道法实能障道。若受五欲欲火所烧欲觉所迷。及外道不舍本见得四沙门果。无有是处。世尊为说。彼犹不舍。佛复语言。我已见汝作恶邪见。是为谤我是为诬我。汝还所住。我自更问余诸比丘。阿梨吒去。佛欲明彼比丘恶邪见故。问诸比丘。汝等解我所说如阿梨吒不。诸比丘言。我等不如是解。又问云何。答言。佛说障道法实能障道。广说如上。佛言。善哉汝等善解我意。告诸比丘。应使一比丘与阿梨吒亲善者于屏处软语谏言。汝莫作是语。莫谤佛莫诬佛。佛说障道法实能障道。汝舍是恶邪见。若舍者善。若不舍应众多比丘往谏如上。若舍者善。若不舍复应僧往谏亦如上。若舍者善。诸比丘受教。如是三反。坚持不舍。诸比丘以是白佛。佛以是事集比丘僧。遥责阿梨吒已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘作是语。如我解佛所说。障道法不能障道。诸比丘语是比丘。汝莫作是语。莫谤佛莫诬佛。佛说障道法实能障道。汝舍是恶邪见。如是谏坚持不舍。应第二第三谏。第二第三谏。舍是事善。不舍者波逸提。彼比丘不舍恶邪见。诸比丘若见若闻。遣一比丘屏处谏。若舍者应作一突吉罗悔过。若不舍应众多比丘往谏。若舍者应作二突吉罗悔过。若不舍应僧往谏。若舍者应作三突吉罗悔过。若不舍应白四羯磨谏。一比丘唱言。大德僧听。某甲比丘生恶邪见作是语。如我解佛所说。障道法不能障道。僧已谏。莫作是语莫谤佛莫诬佛。佛说障道法实能障道。僧如是谏。坚持不舍。今僧羯磨谏。若僧时到僧忍听。白如是。白已应语言。僧已白竟。汝可舍是恶邪见。若舍者应作四突吉罗悔过。若不舍复应唱言。大德僧听。此某甲比丘作是语。如我解佛所说。障道法不能障道。僧已谏。莫作是语。莫谤佛莫诬佛。佛说障道法实能障道。僧如是谏。彼坚持不舍。僧今羯磨谏。谁诸长老忍默然若不忍者说。复应语言。僧已一羯磨竟。汝可舍是恶邪见。若舍者应作五突吉罗悔过。若不舍复第二唱如上。第二唱竟。复应语。僧已二羯磨竟。汝可舍是恶邪见。若舍者应作六突吉罗悔过。若不舍复应第三唱。第三唱未竟舍。亦应作六突吉罗悔过。第三羯磨竟若舍若不舍波逸提。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(四十八竟)

佛在舍卫城。尔时有比丘。知阿梨吒不舍恶邪见。共坐共语共宿共事。余比丘呵责言。阿梨吒不舍恶邪见。僧已羯磨竟。汝等云何共坐共语共宿共事。诸比丘闻不以介意。诸长老比丘种种呵责。以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。今为诸比丘结戒。从今是戒应如是说。若诸比丘。知彼比丘不如法悔不舍恶邪见。共坐共语共宿共事波逸提随久近共语。语语波逸提。共坐坐坐波逸提。共宿宿宿波逸提。共事事事波逸提。虽舍恶邪见僧未解羯磨亦波逸提。若作恶邪见僧未羯磨突吉罗。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗。若不知及不如法羯磨不犯(四十九竟)

佛在舍卫城。尔时跋难陀有二沙弥。生恶耶见作是语。如我解佛所说。受五欲不能障道。乃至舍利弗以是白佛。如阿梨吒生恶邪见中说。佛便敕一比丘。汝呼彼二沙弥来。即受教往语。大师呼汝。二沙弥即随教来。顶礼佛足却住一面。佛问二沙弥。汝实作是语不。答言实尔世尊。又问沙弥。汝云何解我所说法。沙弥答亦如阿梨吒所说。佛告诸比丘。此沙弥应呼僧中教舍。第二第三教。若舍者善。不舍者僧应白四羯磨灭摈。一比丘唱言。大德僧听。某甲沙弥不舍恶邪见。今僧与作灭摈。若僧时到僧忍听。白如是。复唱大德僧听。某甲沙弥不舍恶邪见。今僧与作灭摈。谁诸长老忍默然。若不忍者说。如是第二第三。僧与某甲沙弥灭摈竟。僧忍默然故。是事如是持。彼二沙弥僧既灭摈已。便游行人间。时跋难陀。畜彼沙弥共语共宿。诸比丘语言。僧已羯磨灭摈此沙弥。汝莫畜莫共语莫共宿。跋难陀言。此是我兄沙弥。我若不看谁应视者。能护狐苦自致安乐。诸长老比丘闻种种呵责。以是白佛。佛以是事集比丘僧。问跋难陀。汝实尔不。答言实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若沙弥作是语。如我解佛所说。受五欲不能障道。诸比丘语是沙弥。汝莫作是语。莫谤佛莫诬佛。佛说五欲障道实能障道。汝沙弥舍是恶邪见。如是教坚持不舍。应第二第三教。第二第三教。舍是事善。若不舍诸比丘应语是沙弥。汝出去。从今莫言佛是我师。莫在比丘后行。如余沙弥得共比丘二宿。汝亦无是事。痴人出去灭去。莫此中住。若比丘知如法摈沙弥。畜使共住共语波逸提。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(五十竟)

佛在舍卫城。尔时长老迦留陀夷。以不喜见恶比丘故。亦不喜见乌。诸白衣捉弹来看。时有群乌集于屋上。语言。此乌成就弊恶比丘十法。一者悭惜二者贪余三者强颜四者耐辱五者蛆弊六者无慈悲七者悕望八者无厌九者藏积十者喜忘。此乌有是十法。汝等欲杀不。有不信罪福者。答言欲杀。即取其弹语诸人言。欲弹何处。有言可弹左眼。即着左眼而死。又言可弹右眼。即着右眼而死。如是须臾乃至数十。诸不信乐佛法者。便讥呵言。此辈沙门常说慈愍护念众生。而今残害无道。无沙门行破沙门法。诸长老比丘闻。种种呵责以是白佛。佛以是事集比丘僧。问迦留陀夷。汝实尔不。答言实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘夺畜生命波逸提。有诸比丘在道路行。或牵财物或熏钵。时误杀诸虫皆生惭愧。亦有悔过出罪者。以是白佛。佛以是事集比丘僧。告诸比丘。若误杀众生。犯波逸提。无有是处。从今是戒应如是说。若比丘故夺畜生命波逸提。畜生者。除龙余畜生是。故夺命者。先有杀心而断其命。若夺畜生命随多少。一一波逸提。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(五十一竟)

佛在舍卫城。尔时十七群比丘。至六群比丘住处。六群比丘作是念。此比丘有惭愧少欲知足。今来在此必见我过。我等当作方便令生疑悔。生疑悔已必还师所。念已语言。汝等善受具足戒不。受戒有界场不。羯磨如法不。不犯波罗夷僧伽婆尸沙波逸提波罗提提舍尼突吉罗不。好护身口不。汝和尚阿阇梨先善受具足戒乃至好护身口不。答言。我等不自知。亦不知和尚阿阇梨云何。我今问大德。大德语我。我受具足戒时。及和尚阿阇梨尽如法不。答言。我若实语汝会不信。自可问汝所信之人。时十七群比丘便往师所问如此事。师答汝事事如法。我昔受戒亦复如是。谁为汝等作此疑悔。答言六群比丘。诸长老比丘闻种种呵责。以是白佛。佛以是事集比丘僧。问六群比丘。汝实尔不。答言实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘令他比丘生疑悔波逸提。有诸比丘犯罪。心生疑悔。问诸比丘。犯如是如是事。得何等罪。诸比丘作是念。佛结戒不听令他比丘生疑悔。便答言不知。以是白佛。佛以是事集比丘僧。告诸比丘。若不欲令人生疑悔语其所犯。犯波逸提无有是处。从今是戒应如是说。若比丘故令比丘生疑悔。作是念。令是比丘乃至少时恼波逸提。疑悔者。生处疑受戒疑犯戒疑衣疑。若令比丘尼式叉摩那沙弥沙弥尼疑悔突吉罗。若比丘尼令比丘比丘尼疑悔波逸提。令式叉摩那沙弥沙弥尼疑悔突吉罗。式叉摩那沙弥沙弥尼令五众疑悔。皆突吉罗(五十二竟)

佛在舍卫城。尔时六群比丘有势力。遮僧羯磨及解羯磨。僧不从便起去。时至被摈比丘所语言。汝莫愁忧。我已助汝。遮僧羯磨。僧不从我。我便起去。是为羯磨不成。复至解羯磨比丘所语言。汝莫谓僧解汝羯磨。僧解羯磨时我已遮之。僧不从我。我便起去。是不成解羯磨。汝今自可更求僧解。诸长老比丘闻。种种呵责以是白佛。佛以是事集比丘僧。问六群比丘。汝实尔不。答言实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘僧断事时起去波逸提。尔时诸比丘。有事欲去而不敢。以是白佛。佛以是事集比丘僧。告诸比丘。今听诸比丘有事与欲竟起去。与欲者。应语一人言。长老一心念。僧今断事。我某甲比丘如法僧事中与欲。从今是戒应如是说。若比丘僧断事时不与欲起去波逸提。僧断事者。白羯磨白二白四羯磨。若屋下羯磨随几过出。一一出皆波逸提。若露地羯磨出去。去僧面一寻波逸提。若神通人去离地四指波逸提。若僧不羯磨断事出去突吉罗若私房断事来而去突吉罗。比丘尼亦如是。若僧不羯磨断事及私房断事。沙弥得在其中。若起去突吉罗。式叉摩那沙弥尼亦如是。若僧不如法羯磨。不与欲起去不犯(五十三竟)

佛在舍卫城。尔时十七群比丘。至六群比丘住处。共相击擽。有一比丘众共击擽。不胜笑故气绝而死。十七群比丘为之悲哭。诸长老比丘问。何以悲哭。答言。有一比丘戏笑命终。是以悲哭。又问何由致此。答言我等共击擽。笑不自胜遂便气绝。诸比丘种种呵责。以是白佛。佛以是事集比丘僧。问十七群比丘。汝等实尔不。答言实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘击擽比丘波逸提。比丘击擽沙弥乃至畜生突吉罗。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(五十四竟)

佛在舍卫城。尔时十七群比丘。至阿夷罗河中取水。即因洗浴泅戏沐没互相浇灒。时波斯匿王。共末利夫人登楼遥见。语夫人言。看汝福田。夫人白王。是佛未制戒年少出家未解法耳。王莫见此生不信敬于余比丘长夜受苦。十七群比丘种种戏已立水上着衣。夫人白王言。王试看我所事福田。着衣已。以瓶水掷空中。飞而逐之。从楼上过犹如雁王。夫人复白王。更看我所事福田。王大欢喜信敬转增。于是夫人告那邻伽婆罗门。汝往佛所以是白佛。即受教往。佛为说法示教利喜发遣令还。以是事集比丘僧。问十七群比丘。汝等实尔不。答言实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘水中戏波逸提。若水中戏乃至器盛水共相浇灒皆波逸提。若抟雪及弄草头露戏皆突吉罗。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗。若不为戏皆不犯(五十五竟)

佛在舍卫城。尔时世尊未制比丘与女人同室宿。或一比丘一女人。或多比丘少女人。或少比丘多女人。同室宿生染着心。有反俗者作外道者。诸居士见讥呵言。此等沙门与女人同室宿。与白衣何异。无沙门行破沙门法。时有一年少妇人。夫丧作是念。我今当于何许更求良对。复作是念。我今不能门到户至。当作一客舍令在家出家人任意宿止。于中择取。即便作之。宣令道路须宿者宿。时阿那律暮至彼村。借问宿处。有人语言。某甲家有。即往求宿。阿那律先好容貌。既得道后颜色倍常。寡妇见之作是念。我今便为已得好婿。即指语处可于中宿。阿那律即前入室。结加趺坐。坐未久。复有贾客来求宿。寡妇答言。我虽常宿客。今已与比丘不复由我。贾客便以主人语。从阿那律求宿。阿那律语寡妇言。若由我者可尽听宿。贾客便前。寡妇复作是念。当更迎比丘入内。若不尔者后来无期。即于内更敷好床然灯语阿那律言。可进入内。阿那律便入。结加趺坐系念在前。寡妇于众人眠后。语言。大德知我所以相要意不。答言姊妹。汝意正当在于福德。寡妇言。本不以此。便具以情告。阿那律言。姊妹。我等不应作此恶业。世尊制法亦所不听。寡妇言。我是族姓年在盛时。礼仪备举多饶财宝。欲为大德给事所当。愿垂见纳。阿那律答之如初。寡妇复作是念。男子所惑唯在于色。我当露形在其前立。即便脱衣立前笑语。阿那律便闭目正坐作赤骨观。寡妇复作是念。我虽如此彼犹未降。便欲上床与之共坐。于是阿那律踊升虚空。寡妇便大羞耻生惭愧心。疾还着衣合掌悔过。白言大德。我实愚痴。于今不敢复生此意。愿见哀恕受我悔过。阿那律言。受汝忏悔。因为说种种妙法。初中后善善义善味。具足清白梵行之相。寡妇闻已远尘离垢得法眼净。阿那律即如其像往至佛所。兼以前比丘事具白世尊。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘与女人同室宿波逸提。女人乃至初生及二根女同室宿皆波逸提。室者如与未受具戒人宿中说。若与非人女畜生女黄门同室宿皆突吉罗。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗。若同覆异隔。若大会说法。若母姊妹近亲疾患。有有知男子自伴不卧。皆不犯(五十六竟)

佛在拘舍弥国。尔时世尊未制比丘饮酒。有诸比丘。于酒肆中或白衣家饮酒大醉。或堕坑堑或突壁物或破衣钵伤坏身体。诸白衣见讥呵言。我等白衣尚有不饮酒者。沙门释子舍累求道。而皆洪醉过于俗人。空着坏色割截之衣。无沙门行破沙门法。尔时世尊。从拘舍弥国往跋陀越邑。时彼编发梵志住处有一毒龙。常雨大雹坏诸田苗。彼诸居民常作是念。沙门婆罗门中。谁有威德能降此龙者。闻佛与千二百五十弟子俱来此邑莫不欢喜。皆出奉迎头面礼足。白佛言。世尊。此邑常有一恶毒龙。破坏田苗。我恒愿得大威德人而降伏之。时沙竭陀在佛后扇佛。佛即顾问。汝听此诸居士所说不。答言听。第二第三问答亦如是。沙竭陀作是念。世尊反覆三问。已为敕我降此恶龙。即前礼佛足右绕而去。向彼龙所作是念。我今当降此龙令不坏形。而使其身微细如[木*著]。即入其室却坐一面。龙身便出烟。沙竭陀身亦出烟。龙举身火然。沙竭陀亦举身火然。龙火出五色。沙竭陀火亦出五色。于是化龙身令如[木*著]。内着钵中持至佛所。白佛言。此恶毒龙今已降伏。当着。何处。佛言。可着世界中间。沙竭陀受教。如人屈申臂顷。持着世界中间。须臾便还。于是世尊。从跋陀越邑欲还拘舍弥。时跋陀越邑诸居士。闻沙竭陀降伏恶龙。皆大欢喜。问诸比丘。谁是沙竭陀。时沙竭陀在佛后诸比丘言。佛后者是。诸居士即前礼足白言。愿受我请。默然受之。诸居士言。大德须何等食。答言。我白衣时性好酒肉。居士欢喜即为办之。沙竭陀往到其家食肉饮酒。极饱满已还拘舍弥。于僧坊外醉卧吐泄衣钵纵横。于时世尊天眼遥见告阿难。共汝僧坊外看。受教从佛出外见之。佛与阿难舁还着井边。佛自汲水使阿难洗。着衣卧绳床上令头向佛。须臾转侧申脚踏佛。佛以是事集比丘僧问诸比丘。沙竭陀先敬佛不。答言敬。又问今能敬不。答言不能。又问。应饮是酒失本性不。答言不应。又问。沙竭陀先能伏恶龙今能降虾蟆不。答言不能。诸比丘复以前事具白世尊。佛以彼此因缘种种呵责诸比丘已。告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘饮酒波逸提。时沙竭陀。佛制戒已不敢复饮。以先习故气绝欲死。饮食不消。不知云何。以是白佛。佛言。令嗅酒器。嗅酒器不差。佛言。以酒着饼中若羹粥中令啖。啖不差。佛言。听以酒与之。沙竭陀得已便差。即以白佛。佛言。已差应渐渐断之。乃至嗅酒器。不复恶者不得复嗅。有酒酒色酒味酒香。有酒酒色酒香无酒味。有酒酒色酒味无酒香。有酒无酒色香味。饮令人醉。若饮皆波逸提。有非酒酒色酒味酒香。饮使人醉若饮突吉罗。有非酒酒色酒香酒味。不令人醉。欲饮听屏处饮。若比丘饮酒。咽咽波逸提。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(五十七竟)

佛在舍卫城。尔时六群比丘。不敬和尚阿阇梨不敬戒。有诸比丘亦效如是。诸长老比丘见种种呵责。以是白佛。佛以是事集比丘僧。问六群及诸比丘。汝等实尔不。答言实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘轻师波逸提。若比丘轻三师及戒一一波逸提。若轻余比丘突吉罗。乃至师令扫地不扫。教顺扫而逆扫。皆突吉罗。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(五十八竟)

佛在拘萨罗国。与大比丘僧五百人俱。向阿荼脾邑。时彼诸比丘闻佛当来。无有堂舍。便共自作伐草掘地。乃至佛种种呵责。如上作讲堂中说。告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘自掘地取土波逸提。时六群比丘使守园人沙弥掘地取土。诸比丘见言。佛制不得掘地。汝今云何作此恶业。答言我使人掘。诸比丘言。使人掘自掘有何等异。以是白佛。佛以是事集比丘僧。问六群比丘。汝实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。从今是戒应如是说。若比丘自掘地若使人掘波逸提。有诸白衣送物为僧作房。久久来视见房不成。问作房比丘。何不为我速成此福。答言。佛不听我等自掘地使人掘。云何得成。以是白佛。佛以是事集比丘僧。告诸比丘。若须土应语净人言。知是看是。我须是与我是。从今是戒应如是说。若比丘自掘地若使人掘言掘是波逸提。比丘尼亦如是。式叉摩那沙弥沙弥尼。无事掘地突吉罗。若取燥土不犯(五十九竟)

佛在舍卫城。尔时六群比丘。与诸比丘共斗。共斗已在户外听语。听已语诸比丘言。汝何以作如是语。问言汝从谁闻。答言。我在户外听。诸长老比丘闻。种种呵责。以是白佛。佛以是事集比丘僧。问六群比丘。汝等实尔不。答言实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘于屏处默听他比丘所说波逸提。时诸比丘与比丘诤理辩是非。有比丘隔壁听生疑。我故当不犯波逸提耶。或有出罪悔过者。以是白佛。佛以是事集比丘僧。告诸比丘。若比丘默听诤理辩是非。犯波逸提者无有是处。从今是戒应如是说。若比丘共诤已默听。作是念。诸比丘所说我当忆持波逸提。默听比丘尼式叉摩那沙弥沙弥尼语突吉罗。比丘尼听比丘比丘尼语波逸提。听式叉摩那沙弥沙弥尼语突吉罗。式叉摩那沙弥沙弥尼。默听五众语突吉罗(六十竟)

佛在舍卫城。尔时十七群童子。父母爱念。母作是言。我子不串勤苦。体性软弱。教何技术得终安乐。父言。当教算计书画。母言。若教书画恐坏其眼。若算恐其指痛。若计恐其心病。复共议。当使于释子中出家。现世无为后世长乐。彼十七群童子欲出家。共相语言。我要当待优波离来与共辞别。时优波离行还。到诸童子所。诸童子言。汝知不。我等欲于如来法中出家待汝辞别。优波离闻亦乐共去。还白父母。父母即听作是念。当令谁作师。又作是念。毕陵伽婆蹉。从贼中拔其将还。今当与为弟子。便各将其子。诣毕陵伽婆蹉。白言大德。大德于此儿有大恩。今以奉给。愿纳为弟子。毕陵伽婆蹉即便度之。与受具足戒。既受戒已。夜不能独至厕上及洗手处。恒自送之。有时闇中见师不识便谓是鬼。失声大唤言。毗舍遮毗舍遮。师言。莫怖是我非鬼也。或夜索食。师言。僧有食晓当与汝。又问。僧若无食当何处得。师言。僧若无当乞食。闻是语已便大啼言。比丘乞食还我等已死。佛夜闻之。则问阿难。是谁啼声。阿难具以白佛。佛以是事明旦集比丘僧。问毕陵伽婆蹉。汝实尔不。答言实尔世尊。佛种种呵责。汝不应与未满二十人受具足戒。未满二十多所不堪致有破戒。呵已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘与不满二十岁人受具足戒波逸提。尔时童子迦叶。不满二十受具足戒。后方生疑。不知云何。以是白佛。佛以是事集比丘僧。问诸比丘。童子迦叶有所得不。答言得须陀洹。佛言。此人乃是第一受具足戒。然不名白四羯磨如法受戒。今听数胎中年足为二十。若犹不满。又听以闰月足。若复不满。又听以沙门年足。从今是戒应如是说。若比丘知不满二十岁与受具戒波逸提。是人不得戒。诸比丘亦可呵是法应尔。未满二十未满二十想未满二十疑波逸提。满二十未满想满二十疑突吉罗。若知不满二十。生念欲与受具戒。及作方便。至第四羯磨未竟。皆突吉罗。第四羯磨竟。和尚波逸提。余师僧突吉罗(六十一竟)

佛在拘萨罗国。与大比丘僧五百人俱。向迦维罗卫城。诸释种闻佛从彼国来。共立制。若不出迎佛罚金钱五百。便各将大小出迎世尊。头面礼足却住一面。佛为说法示教利喜。共请佛及僧夏四月安居。世尊默然许之。诸人各随力设供。或一家作一日乃至十日。或二家共作一日。乃至十家或但作前食。或但作后食。或但作怛钵那。或但作粥。或作浴者。或作过中饮者。或施涂身油及涂足然灯油者。尔时释摩男不在。未有受其施者。问左右人言。竟谁受我施。答言。未有受者。又问。佛及僧未受何等施。答言唯未受药。便请佛及僧施夏坐药。或自送或使人送。又到六群比丘所言。大德须药恣意来取。六群比丘作是念。今王请佛及僧。安居四月给药。或使人送乃至自送。而令我等自往取之。观王此心是轻我等。我等当伺其五亲会时从索最难得药。彼必不办使其羞耻。复作是念。此王福德或能无药不有。先当访索人所无者。然后从乞。即访索之唯无一种。于是伺王五亲会时。便从其乞。王即令人国中遍觅。悉不能得。王语六群比丘。诸处求索。绝不可得。六群比丘便语王言。王自请佛及僧四月给药。而今不能与我一种。王言大德。非不欲与亦非无物。但访索此药绝不可得。又四月已过何为相苦。六群比丘便于众前折辱王言。先请我等随所求药。而今不能得此一种。余比丘闻。问六群比丘。汝说何等。六群比丘以实而答。诸比丘种种呵责。以是白佛。佛以是事集比丘僧。问六群比丘。汝等实尔不。答言实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘受四月自恣请。若过是受波逸提。尔时诸比丘得秋时病。释摩男入房见之问言大德所患何等。答言我得秋病。即请诸比丘言。可从我取药。诸比丘言。王先请四月于今已过。佛不听我过此受药。王即更请一月。诸比丘言。佛未听我更受请。不知云何。以是白佛。佛以是事集比丘僧。告诸比丘。今听诸比丘更受一月请。从今是戒应如是说。若比丘受四月自恣请过是受。除更请波逸提。又诸居士来僧房看。见诸比丘得秋病。问言。须何等药我当送之。诸比丘言。佛未听我等受自送药。不知云何。以是白佛。佛以是事集比丘僧。告诸比丘。今听诸比丘受自送请。从今是戒应如是说。若比丘受四月自恣请过是受。除更请自送请波逸提。时释摩男作是念。六群比丘以药故于众人前折辱我。我今宁可多集诸药。即多集之。集已作是念。如我此药尽寿用之。不能令尽。我今当请诸比丘尽寿与药。即往长请诸比丘。诸比丘言。佛未听我等受长请。不知云何。以是白佛。佛以是事集比丘僧。告诸比丘。今听诸比丘受长请。从今是戒应如是说。若比丘受四月自恣请若过是受。除更请自送请长请波逸提。若人施僧药。佐助众事比丘应问。此药当留聚落中为着僧坊内。若言留着聚落中。须时应语。我须如是药。为我办勿使有乏。若言着僧坊内。应着中央房令取易得。僧应作白二羯磨。一比丘唱言。大德僧听。今以某房安僧药。若僧时到僧忍听白如是。大德僧听。今以某房安僧药。谁诸长老忍默然若不忍者说。僧已用某房安僧药竟。僧忍默然故。是事如是持。诸比丘不知谁应守僧药。以是白佛。佛言。僧应白二羯磨差一比丘作守药人。一比丘唱言。大德僧听。今差某甲比丘为僧作守药人。若僧时到僧忍听。白如是。大德僧听。今差某甲比丘为僧作守药人。谁诸长老忍默然谁不忍者说。僧已差某甲比丘。作守药人竟。僧忍默然故。是事如是持。时诸比丘差无智比丘不堪守药。以是白佛。佛言。不应差无智比丘。若成就五法。应差作守僧药人。何等五。不随爱恚痴畏知药非药。彼守僧药比丘。应以新器盛呵梨勒阿摩勒鞞醯勒毕跋罗干姜甘蔗糖石蜜。若器不漏。应盛酥油蜜。应持皮结口题上作药名。若病比丘须者应欢喜与。若病者自知须此药。应自取服。若不知应问医。若无医应问和尚阿阇梨。我如是如是病。应服何药。若和尚阿阇梨不知。应取药再三服。不差复应取余药服。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(六十二竟)

佛在舍卫城。尔时六群比丘数数犯戒。诸比丘谏言。汝等数数犯戒。当自见罪如法悔过。莫以此行负人信施长夜受苦。六群比丘言。我不学是戒。我当先问持法持律智慧胜汝者。诸比丘种种呵责。以是白佛。佛以是事集比丘僧。问六群比丘。汝等实尔不。答言实尔。世尊。佛种种呵责。汝愚痴人。不应作此恶业。诸比丘欲不与汝共布萨自恣作诸羯磨。愍念汝故如法谏汝。汝云何言。我不学是戒。我当先问持法持律智慧胜汝者。呵责告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘数数犯罪。诸比丘如法谏。作是语。我不学是戒。当问余比丘持法持律者波逸提。比丘欲求解。应问持法持律者。是法应尔。持法者。持诵佛所说法。持律者。有五事。一者诵四事至二不定法。二者诵四事乃至三十事。三者广诵二百五十戒。四者广诵二部戒。五者广诵一切律。若比丘不诵戒。非安居时。应依前四种持律。安居时。要应依广诵一切律者。若不依突吉罗。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(六十三竟)

五分律卷第八五分律卷第九(弥沙塞)

        宋罽宾三藏佛陀什共竺道生等译

    第一分之五第六十四事

佛在舍卫城。尔时六群比丘数数犯戒。诸比丘谏。乃至莫长夜受苦。皆如上说。六群比丘问言。佛于何处制此法。诸比丘言。汝不知耶。答言不知。诸比丘言。今当语汝制法处所。于说戒时便语言。佛于此中制法。六群比丘言。我今始知是法半月布萨戒经中说。诸比丘种种呵责。以是白佛。佛以是事集比丘僧。问六群比丘。汝等实尔不。答言实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘说戒时。作是语。我今始知是法半月布萨戒经中说。诸比丘知是比丘已再三说戒中坐。是比丘不以不知故得脱。随所犯罪如法治。应呵其不知所作不善。说戒时不一心听不着心中波逸提。若比丘与比丘受具足戒。即应教为广说。若二若三于说戒中坐。若知若不知作是语波逸提。比丘尼亦如是(六十四竟)

佛在舍卫城。尔时诸比丘。数入波斯匿王宫。见诸美女生染着心。不乐修梵行。或有反俗作外道者。诸大臣见作是言。王何以不深藏宫女。乃使种种异姓见之。尔时阿难常受王供养。晨朝着衣持钵入于后宫。时王与末利夫人同寝未起。夫人见阿难来。即便狼狈被衣下床。所被之衣极细而滑。不觉堕落惭羞蹲地。王便讥呵言。我王事鞅掌昏夜寝息起不得早。如何比丘晨朝迳来。阿难惭耻即还佛所。具以诸比丘入宫及已事白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言。实尔世尊。佛复自说阿难事。种种呵责。告诸比丘。入王后宫有十过失。一者若王醉时近余宫女。醉醒便忘。彼忽有娠必疑比丘。二者宫女见比丘或有戏笑疑有情故。三者若王有密谋外人得知。便当疑是比丘所传。四者若王宫内亡失宝物。便当疑是比丘所取。五者若夺一臣位。外人必言。由比丘故。六者若有遭罪。外人必疑比丘所为。七者若有未应得官而王与之。亦复疑是比丘之力。八者若王好出游观劳费事多。亦复疑嫌比丘使。然。九者宫内多诸美色珍玩服饰。比丘见之必生染着犯戒反俗。十者若王子中有反逆者。必复疑是比丘所教。呵责已告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘入王宫过门限波逸提。时诸比丘。佛制戒后便不敢踰城门限乞食。不知云何。以是白佛。佛以是事集比丘僧。告诸比丘。今听入宫。但不得过后宫门限。从今是戒应如是说。若比丘入王宫过后宫门限者波逸提。尔时波斯匿王。年年与诸宫女出行国界。处处皆有离宫别观。有诸比丘暮至村落求索宿处。诸居士言。王今不在此宫。可入中宿。王信乐佛法。闻必欢喜。诸比丘不敢。便无宿处。以是白佛。佛以是事集比丘僧。告诸比丘。今听诸比丘入王空宫。从今是戒应如是说。若比丘王未出宝未藏宝若入过后宫门限波逸提。宝者。所重之物及诸女色。皆名为宝。未出者。女在宫中。未出。未藏者。女在此宫未使藏隐。尔时入后宫门限双脚过波逸提。随入远近步步波逸提。若一脚过突吉罗。入余大臣长者家过内门限突吉罗。沙弥突吉罗。若王请入不犯(六十五竟)

佛在舍卫城。尔时拘萨罗摩竭二国互相抄掠。二国中间道路断绝。王舍城比丘安居竟。作是念。我今正当与贼同伴。乃得自致问讯世尊。设彼戍逻。以共贼伴。收捉我者。波斯匿王信乐佛法。必不见罪。便与贼俱到彼国界。果为所捉。将逻将所。白言。此是贼。逻将言。着袈裟者复是何等。答言。亦是贼。比丘便自说言。我非贼是沙门释子。于王舍城安居竟。应问讯世尊。道路难崄故与共伴耳。逻将言。汝非沙门释子。必假此服来作细作。便送王所。比丘自说如前。王便放之。左右群臣。有不信是沙门者言。此贼假比丘服。王信乐佛法。其于放之。诸长老比丘闻。种种呵责。以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘共贼伴行波逸提。有诸比丘共贼道路行。不知是贼。既知便惭愧。谓犯波逸提。或下道避之。或留在后。贼即问言。汝何故尔。答言。佛制不听共汝伴行。贼闻是语便大嗔恚。打诸比丘剥衣赤肉。诸比丘还以是白佛。佛以是事集比丘僧。告诸比丘。若不知是贼共行。犯波逸提无有是处。从今是戒应如是说。若比丘知是贼共伴行波逸提。有诸比丘在道路行。与贼相遇。便生惭愧。谓犯波逸提。以是白佛。佛以是事集比丘僧。告诸比丘。若不期共贼行道路相遇。犯波逸提无有是处。从今是戒应如是说。若比丘与贼期共伴行波逸提。有诸比丘。与贼期共近道行。有不去者。有从异道者皆生疑。我等将无犯波逸提耶。以是白佛。佛以是事集比丘僧。告诸比丘。虽与贼期共近道行。竟不去及从异路去。犯波逸提者无有是处。从今是戒应如是说。若比丘与贼期共道行。从此聚落到彼聚落波逸提。若共恶比丘期行突吉罗。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗。若诸难起共期行不犯(六十六竟)

佛在舍卫城。尔时诸比丘。与女人共道行。或一比丘与一女人。乃至众多或二比丘。乃至众多与一女人。乃至众多共行渡水。更相见形生染着心。或有反俗作外道者。诸居士见讥呵言。沙门释子共女人同道。与将妇行有何等异。谁知此辈行于梵行。无沙门行破沙门法。尔时有一居士数打其妇。打已出行。妇作是念。夫数打我。密能见杀。今当避之。于是便去出聚落外。见一比丘。往趣问言。大德何行。答言。欲至某处。于是女人便随后去。彼夫作是念。我向打妇。或能自杀。即便还家觅之不见。问邻人言。见我妇不。皆言。不见。便出聚落见一外道女。问言。颇见如是如是妇人不。答言。见沙门释子将去。彼人即急追之。及已语比丘言。何故将我妇走。比丘答言。我不作恶业。汝妇与我同道行耳。妇复语夫言。勿生恶心于此比丘。我共同道如亲无异。夫闻妇言作是念。乃尔相欺必已有恶事。便打比丘垂死乃置。彼比丘作是念。我今委顿不任进路。当入火光三昧以自消息。使身有力然后前进。念已收敛衣钵。入火光三昧身中出烟。彼妇见已语其夫言。不信我语。观彼比丘身之所出。彼比丘须臾举身洞然。妇复语言。不信我语。复观比丘其身云何。彼比丘即以此三昧力往到佛所。并以前事具白世尊。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘与女人共道行波逸提。有诸比丘共行。中道见诸女人亦行此路。心生疑悔。我等将无犯波逸提耶。以是白佛。佛以是事集比丘僧。告诸比丘。若比丘不期与女人共道行。犯波逸提无有是处。从今是戒应如是说。若比丘与女人期共道行波逸提。有诸比丘与女人期共道行。后不敢去或从余道。犹生疑悔。以是白佛。佛以是事集比丘僧。告诸比丘。若比丘虽先与女人期共道行。竟不去或从余路去。犯波逸提无有是处。从今是戒应如是说。若比丘与女人期共道行。从此聚落到彼聚落波逸提。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(六十七竟)

佛在拘萨罗国。与大比丘僧千二百五十人游行人间。诸比丘或得屋中或在树下或在露地。时六群比丘。共十七群比丘。大聚薪草露地然火。在边坐炙。时有一蛇。从木孔出。诸比丘见以物掷之。蛇即还入。得热复出。诸比丘复更掷之。蛇复还入。须臾顷复出。掷一比丘啮之即死。诸比丘围绕啼泣。诸长老比丘问。汝等何故啼泣。答言。此比丘为蛇啮命过。具说上事。诸长老比丘种种呵责。汝等云何见蛇再三出。犹故不避致令啮死。以是白佛。佛以是事集比丘僧。问六群诸比丘。汝等实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘然火波逸提。时六群比丘使守园人沙弥然火。诸长老比丘见呵责言。汝岂不闻佛制不得然火耶。答言。我使守园人沙弥然。非为有犯。诸比丘言。自然使人然有何等异。以是白佛。佛以是事集比丘僧。问六群比丘。汝实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。从今是戒应如是说。若比丘自然火若使人然波逸提。有诸病比丘问医。医言。应服如是药然火洗浴。病比丘言。佛不听我自然火及使人然。愿更教我服于余药。医言。大德。正应服此药然火洗浴。诸比丘作是念。佛若听我自然火若使人然。病乃得差。以是白佛。佛以是事集比丘僧。告诸比丘。今听病比丘然火若使人然。从今是戒应如是说。若比丘无病若自然火若使人然波逸提。有诸比丘须煮羹粥。不敢然火。以是白佛。佛以是事集比丘僧。告诸比丘。今听诸比丘煮羹粥。不得为炙。从今是戒应如是说。若比丘无病为炙故然火波逸提。诸比丘欲熏钵然火及遮恶兽然灯烛。不知云何。以是白佛。佛以是事集比丘僧。告诸比丘。今听诸比丘有如是因缘自然火若使人然。从今是戒应如是说。若比丘无病为炙故自然火若使人然波逸提。若为炙然火炎高乃至四指波逸提。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(六十八竟)

佛在舍卫城。尔时诸比丘。往知识家见严身宝捉看。还着故处。后为人所偷。主还觅之。不知所在。有人言。我见比丘捉。便往问比丘言。我失如是如是宝。比丘见不。答言。我向捉还着故处。主言。从比丘捉便不复见。可以还我。比丘答言。我实不取。主不信。便与比丘作恶名声。尔时有一外道。囊盛五百金钱。到水边饮忘不持去。有一比丘从后来见。作是念此是唯物。即四顾望。见前一人。便作是念。必是彼许当持还之。即取持去。彼人未远还忆金囊。即便驰还。比丘问。汝何故还。彼人便嗔言。不吉利物何以问我。比丘言。纵使我不吉利。汝应语我还意。彼言。我忘一囊在水边故还觅耳。比丘即出示之。此是汝囊非。彼人既见囊已。复更嗔言。不吉利物何以捉我囊汝小住待。我数囊中物。比丘答言。我竟不解此囊亦不看之。若欲取者岂当示汝。恐汝失之。故持相还耳。彼人复言。我囊中有千金钱。今少五百。可以还我。比丘答之如初。彼人便强牵比丘。到断事人所。时断事人不信乐佛法。便非理断。即取反缚。打驴鸣鼓。于四衢道头欲杀之。时波斯匿王在高楼上。遥见问左右言。彼是唯。答言。是沙门释子。王即敕。将还断事处。吾当自出。即出问彼人。汝何以苦此比丘。彼人如上白王。王复问比丘。亦如上答王。王问彼人。此实汝囊非。答言是。王即以五百金钱盛彼囊中。而囊不受。王复语言。汝云。囊中有千金钱。今何故不受。彼人便自首言。本实五百。我嗔故诬比丘耳。王即问断事者。若人面欺王。当与何罪。断事人言。此人应死财物没官。王即用此法。藉取其财。反缚此人。打驴鸣鼓。于四衢道头杀之。有人语言。汝诬沙门释子。应受此罪。若复诬谤。后当剧是。或复有言。沙门释子有曾取我宝恐今是实。时比丘白王言。愿赐此人命。勿令佛法致恶名声。王即放之。呵责断事人言。若后复有如此断事。当如向治汝。诸不信乐佛法者。种种讥呵。我等俗人犹耻捉宝。沙门释子何故复尔。无沙门行破沙门法。诸长老比丘闻。种种呵责。以前后事具白世尊。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘若捉宝若宝等物波逸提

尔时毗舍佉母。着极上宝严身之具。与诸亲里游戏园林。林近祇洹。观察众人欢畅未已。作是念。我今不宜同此放逸。幸可因此问讯世尊。便将婢诣祇洹到门。复作是念。我今不宜着此饰好觐于世尊。即脱宝衣着于堑边。时舍利弗经行遥见。毗舍佉母前礼佛足。却住一面。佛为种种说法示教利喜。须臾而退。系念所闻忘所著宝。还城门闭后乃忆之。作是念。若我语人失此宝者。或损佛法。默然至晓。时舍利弗以是白佛。佛告舍利弗。汝往取来。受教即取。语舍利弗。明日晨朝自送还之。受教即送。毗舍佉母赞言。善哉我有如是大师及同梵行。若余外道。得此物者何缘还我。我昨夜已舍。今应卒之。即持施四方僧。白舍利弗。可以此作招提僧堂。舍利弗不敢受。以是白佛。佛言。受之。复有诸居士。五日一入僧坊问讯。或脱指环或脱耳宝。去时皆忘。诸比丘见不敢取。有异人见便取持去。诸居士还入僧坊求觅。问诸比丘。我失如是如是宝。比丘见不。答言。我见不敢取。诸居士言。大德见之。如何不取。可以还我。出家之人何须此物。答言。我实不取。彼遂不信。便与比丘作恶名声。复有诸比丘共伴行一处宿。伴中有忘物去者。比丘见不敢取。余人取之。诸伴问比丘。我失如是如是物。大德见不。答言。我见不敢取。诸伴言。大德见之如何不取。可以还我。出家之人何须此物。答言。我实不取。彼遂不信。便与比丘作恶名声。诸比丘作是念。若世尊听我等于僧坊内及宿处。若自取宝若使人取者。居士可不失宝。亦使我等不致恶名。以是白佛。佛以是事集比丘僧。告诸比丘。今听诸比丘于僧坊内若宿处。自取宝若使人取。从今是戒应如是说。若比丘若宝若宝等物。若自取若教人取。除僧坊内及宿处波逸提。若僧坊内及宿处。取宝宝等物。后有主索应还。是事应尔。宝者。真珠摩尼琉璃珂玉金银。宝等物者。一切余物。僧坊内者。僧住处属僧地。宿处者。僧坊外他家宿。及共伴行野宿处。比丘僧坊内见物。应使净人取。若无净人。应自取举之。若有人索。应集僧问其所失物相然后还之。若取举已欲余行者。应嘱后人。若比丘到他家见有物。应使净人举。若无净人应自举。若有人应即嘱此人而后去。若无人应呼主人出付嘱然后去。比丘共伴同道行。若见物应使净人取。若无净人应自取还之。还时应集众人先问。汝失物不。若言失。应问何物。若如其语然后还之。若与伴别道行。而不相及至聚落。应寄信乐优婆塞还之。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(六十九竟)

佛在王舍城。尔时诸比丘日再三浴多用澡豆。诸居士见讥呵言。此诸比丘数数浴。所用澡豆如王大臣。其本出家欲求解脱。不念诵经恶露等观。而反日夜修饰身体。无沙门行破沙门法。时有相师。语瓶沙王言。寻当有一不吉星出。王应在某泉水中浴以穰其灾。若不尔者。或致失国或忧身命。王便敕左右。料理彼泉。即受教往。见诸比丘满中洗浴。还以白王。王言。待比丘浴竟。如是昼夜各三遣参。一去一来都无空缺。婆罗门复语王言。此星垂出。若出后浴便无所益。王闻此语。即便严驾出。到泉水所。于下流浴。诸臣以此讥呵。沙门释子不知时宜。不勤不念观身恶露。但志修饰洗浴身体。无沙门行破沙门法。诸长老比丘闻。种种呵责。以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘半月内浴波逸提。有诸病比丘。医言洗浴乃差。诸比丘言。佛不听我等数浴。愿思余方。医言。唯有洗浴更无余法。诸比丘作是念。佛听病时数浴者。我病便差复有诸比丘种种作埿土污身衣被垢秽。以此益疲。作是念。佛听作时数浴者。疲极必差衣被净洁。复有诸比丘。在路行疲极。欲洗浴而不敢。作是念。佛听行路时数洗浴者。疲极得差。复有诸比丘。风雨尘坌埿污衣服。作是念。佛听风雨尘坌埿污时数洗浴者。可得不为尘埿所污。春余一月半夏初一月。诸比丘热闷汗出。作是念。佛听热时数洗浴者。可无此患。各以白佛。佛以是事集比丘僧。告诸比丘。今听诸比丘病时。作时行路时风雨时热时数洗浴无犯。从今是戒应如是说。若比丘半月内浴除因缘波逸提。因缘者。病时作时行路时风雨时热时。是名因缘。病时者。疾病须浴。作时者断理种种事乃至扫房内地。行路时者。一由旬二由旬乃至行半由旬。风雨时者。为风雨尘埿之所污埿。热时者。热闷汗出。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗。若洗浴师及病人。身体已湿因浴不犯(七十竟)

佛在舍卫城。尔时十七群比丘作新房。六群比丘欲在中住。驱十七群比丘。十七群比丘不肯出。便打之。彼即大唤。诸长老比丘。问何故大唤。答言。六群比丘打我。诸长老比丘种种呵责。以是白佛。佛以是事集比丘僧。问六群比丘。汝等实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘打比丘波逸提。有比丘食噎。倩比丘捶背。诸比丘不敢便死。以是白佛。佛以是事集比丘僧。告诸比丘。若比丘不以嗔心打比丘。犯波逸提无有是处。从今是戒应如是说。若比丘嗔故打比丘波逸提。若打比丘尼式叉摩那沙弥沙弥尼余人及畜生突吉罗。若比丘尼打比丘比丘尼波逸提。打式叉摩那沙弥沙弥尼余人及畜生突吉罗。式叉摩那沙弥沙弥尼打五众余人及畜生突吉罗(七十一竟)

佛在舍卫城。尔时六群比丘。复来十七群比丘房中求住。彼不肯出。便以手拟如打相。彼复大唤。诸长老比丘闻。出问。汝何故大唤。答言。六群比丘欲打我。诸长老比丘种种呵责。以是白佛。佛以是事集诸比丘僧。问六群比丘。汝等实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘以手拟比丘波逸提。有诸比丘。说法时以手语或示处所。便生疑悔。我无将犯波逸提耶。以是白佛。佛以是事集比丘僧。告诸比丘。若比丘不以嗔心手拟比丘。犯波逸提无有是处。从今是戒应如是说。若比丘嗔故以手拟比丘波逸提。若拟手及波逸提。拟手不及突吉罗。余如上打比丘中说(七十二竟)

佛在舍卫城。尔时十七群比丘受所作房。六群比丘以上坐故。次入中住。彼便避在左右房。六群比丘作是议言。十七群比丘惭愧畏慎。逼近我住必见我过。我等当作方便令其远去。便往语言。此先是空房。多有恐怖事。汝等莫于中住。十七群比丘言。我坚闭户何所应畏。六群比丘于是夜闇中作种种恐畏相。明旦问十七群比丘。汝等昨夜得安眠不。答言。我等闻恐畏相。闭户思惟都无所畏。六群比丘复共议言。我等不能以此令其恐怖。当伺其出外入其床下。即便盗入。于夜闇时。或牵其衣或牵其脚。或举其床移着异处。于是十七群比丘便大惊唤。诸长老比丘来问。何故大唤。答言。此间不应有贼。不知谁牵我衣谁牵我脚。谁举我床移着异处。诸长老比丘即持火照见。六群比丘蹲其床下。问言。汝等何为在此。答言。欲恐怖十七群比丘。诸长老比丘种种呵责。以是白佛。佛以是事集比丘僧。问六群比丘。汝等实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘恐怖比丘波逸提。有客比丘问旧比丘。言此房中应何所畏。或不敢语或语已生疑。惧犯波逸提罪。以是白佛。佛以是事集比丘僧。告诸比丘。若比丘不故恐怖比丘。犯波逸提无有是处。从今是戒应如是说。若比丘故恐怖比丘波逸提。余如打比丘中说(七十三竟)

佛在舍卫城。尔时达摩比丘作是念。跋难陀先夺我衣。佛由是呵责我。为诸比丘结戒。我今当于僧中说其犯僧伽婆尸沙。念已即往上座比丘所。语言。跋难陀与女人身相触。粗恶语赞叹自供养身。诸比丘问。汝云何知。答言我共行见作此事。诸长老比丘呵责言。汝云何不嗔时覆藏嗔便发露。呵已以事白佛。佛以是事集比丘僧。问达摩。汝实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘覆藏比丘粗罪波逸提。有诸比丘不知他所犯是粗罪。后乃知之生疑悔。我将无犯波逸提耶。以是白佛。佛以是事集比丘僧。告诸比丘。若不知比丘所犯是粗罪。犯波逸提无有是处。从今是戒应如是说若比丘知比丘犯粗罪覆藏过一宿波逸提。若从平旦至明相未出。一一时突吉罗。明相出波逸提。沙弥突吉罗若欲说无人。若恐难起。覆藏不犯(七十四竟)

佛在舍卫城。尔时跋难陀作是念。达摩比丘。许我共行。以衣与之。既不肯去。还取其衣。世尊以此见责。为诸比丘结戒。彼后复出我罪。我今当以无根僧伽婆尸沙谤之。作是念已。语诸长老比丘言。我实触女人身。作粗恶语自叹供养身。达摩比丘亦复如是。诸比丘问。汝云何知。答言。我共行见。诸比丘呵责言。汝云何以无根僧伽婆尸沙谤比丘。以是白佛。佛以是事集比丘僧。问跋难陀。汝实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘以无根僧伽婆尸沙谤比丘波逸提。谤比丘尼式叉摩那沙弥沙弥尼突吉罗。比丘尼谤比丘比丘尼波逸提。谤式叉摩那沙弥沙弥尼突吉罗。式叉摩那沙弥沙弥尼。谤五众突吉罗(七十五竟)

佛在舍卫城。尔时跋难陀作是念。达摩比丘许我共行。乃至复出我罪亦如上说。我以无根僧伽婆尸沙谤之。不能有损。我今当复以余事治之。便至其所语言。汝是我弟子。我是汝师。汝先犯我。我亦犯汝。今共和解勿复相嫌。便可如先共至诸家食多美食。彼即和解随从而行。跋难陀辄将至无食处。有来请者。便眴眼手语作相令去。筹量还寺不复及中。便发遣之。语言。此今无食。汝可还寺。彼既去已。至所请家食多美食。达摩还寺遂不及中。跋难陀食后还归。问达摩言。汝及食不。答言。不及。复诈慰喻言。汝今虽失一食。明当令汝得极美者。明日所往亦复如上。如是至三。语达摩言。我比将汝所诣。皆是得美食处。而不得之。恐是汝先人所责天神所忿。或复是汝罪业所致。勿怨于我。汝可速归及中至寺。达摩驰还复不及中。积日饥羸不能复起。跋难陀食后还至所住。复问汝及食不。答言。不及。便语言。汝欺诳师。应如是治。汝后若复作。当使剧是。达摩于是始觉师诈。大唤嗔言。云何比丘作是欺诳。使我三日绝食殆死。诸长老比丘问。汝何故大唤。答言。跋难陀三日恼我使我绝食。诸长老比丘种种呵责。以是白佛。佛以是事集比丘僧。问跋难陀。汝实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘语比丘。共到诸家与汝多美饮食。而不与发遣令还波逸提。有诸比丘。将诸比丘共至诸家。不能得食生惭愧心。作是念。我将无犯波逸提耶。以是白佛。佛以是事集比丘僧。告诸比丘。若比丘不为恼他不得食。犯波逸提无有是处。从今是戒应如是说。若比丘语彼比丘。共到诸家与汝多美饮食。为恼故不与发遣令还波逸提。有诸比丘。将看病比丘到诸家。为病比丘请食。恐病人失中。遣令速还。既发遣已便生惭愧。我故当不犯波逸提耶。以是白佛。佛以是事集比丘僧。告诸比丘。若比丘不为独食故发遣他比丘。犯波逸提无有是处。从今是戒应如是说。若比丘语彼比丘。共到诸家与汝多美饮食。既到不与作是言。汝去。共汝若坐若语不乐。我独坐独语乐。欲令彼恼波逸提。若比丘作此恼比丘尼式叉摩那沙弥沙弥尼乃至畜生突吉罗。若比丘尼作此恼比丘比丘尼波逸提。恼式叉摩那沙弥沙弥尼乃至畜生突吉罗。式叉摩那沙弥沙弥尼作此恼五众突吉罗(七十六竟)

佛在舍卫城。尔时众多比丘共伴行入拘萨罗国。遇贼剥脱衣钵都尽。到一逻所。逻将问言。大德。何处遇贼。答言。某处。即与逻人共议。若王闻比丘在我等界遇贼。必当罪我。便语比丘言。大德。小住。我当逐取此贼。便出追逐须臾及之。即便重围索诸衣物皆悉得之。染衣白衣各着一处。逻人议言。当先还谁。有人言。应先还比丘。王信乐佛法闻者必喜。便语比丘言。可各取衣。诸比丘于衣上生疑。或言是我衣。或言非我衣。遂不敢取。逻人问。何以不取。答言。我不自识衣。是以不取。逻人言。次识者取。于是外道便取比丘好衣。比丘后得外道恶者。逻人知沙门释子皆着好衣。而今反得外道恶服。语言。汝等沙门有何奇特。尚不知衣相。云何知心。若知衣相。外道何由得汝好服。诸比丘往到佛所。以是白佛。佛以是事集比丘僧。更问诸比丘。汝实不识衣相不。答言。实尔世尊。佛种种呵责已。告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘新得衣应三种色作帜。若青若黑若木兰。若不以三色作帜。波逸提。若不作帜若着。着着波逸提若不着宿宿波逸提。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗。若新得衣先已作帜。不作不犯(七十七竟)

佛在舍卫城。尔时十七群比丘衣钵什物布散诸处不得收敛。六群比丘便取藏之。彼既觉失。问六群比丘言。我如是如是物。在此在彼谁持去者。答言。向来人非一故当不持去耶。即问。向者来人皆何处去。答言。东西南北莫知所之。时十七群比丘四出追逐及向来人。语言。我失衣钵坐具针筒。可以还我。诸人言。大德。我为法来。不为作偷。得此语已羞惭而反。六群比丘问言。汝等竟见向来人不。答言见。得衣不。答言。不得。于是六群比丘出衣钵示之。此是汝衣钵非。答言是。诸比丘见种种呵责。以是白佛。佛以是事集比丘僧。问六群比丘。汝等实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘自藏比丘若衣若钵坐具针筒。如是一一生活具若使人藏。波逸提。复有比丘不举衣钵什物。诸比丘不敢为举便失去。以此被疑得恶名声。作是念。若佛听我等为人举衣物者。彼既不失。我等不致此恶名声。以是白佛。佛以是事集比丘僧。告诸比丘。若不为藏故为人举衣。犯波逸提无有是处。从今是戒应如是说。若比丘为戏笑故。藏比丘若衣若钵坐具针筒。如是一一生活具若使人藏波逸提。若藏比丘尼式叉摩那沙弥沙弥尼乃至畜生物突吉罗。若比丘尼藏比丘比丘尼物波逸提。藏余人物突吉罗。式叉摩那沙弥沙弥尼。藏五众物突吉罗(七十八竟)

佛在舍卫城。尔时六群比丘有势力。余善比丘无势力。六群比丘遮善比丘羯磨乃至佛种种呵责。皆如前如法断事中说。告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘僧断事时。如法与欲竟。后更呵波逸提。后更呵者。言我本不作如是与欲。若僧不作羯磨断事。后呵突吉罗。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(七十九竟)

佛在舍卫城。尔时诸比丘须一一衣。众僧已与。后时更得。现成三衣。共议言。今此衣应当与谁或有言。应先与世尊。或有言。应先与大迦业。大迦叶。世尊常所赞叹。又是上座。六群比丘言。应先与瞿伽梨。诸比丘以是白佛。佛问诸比丘。迦叶少多求衣不。答言。不求与然后取。佛因是说偈言

  此衣无欲衣　　不施有欲者
  不能调其意　　不任此袈裟
  已能离贪欲　　于戒常一心
  如是调心者　　乃应此衣服

佛语诸比丘。应以此衣与迦叶。即以与之。于是六群比丘作是言。今诸比丘随知识回僧物与。诸长老比丘闻种种呵责。以是白佛。佛以是事集比丘僧。问六群比丘。汝实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘作是语。诸比丘随知识回僧物与波逸提。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(八十竟)

佛在舍卫城。尔时达摩比丘作是念。跋难陀先夺我衣。佛呵责我。为诸比丘结戒。我说其犯僧伽婆尸沙。彼复以无根僧伽婆尸沙谤我。又断我食至于三日。我当云何以报此怨。复作是念。彼于我间作净施衣。不复还之足以报耻。便不复还。跋难陀后从索衣。达摩言。师先布施今云何索。跋难陀言。我作净施不作布施。犹不还之。跋难陀便强夺取。彼即大唤。诸长老比丘闻皆出问。何故大唤。答言。跋难陀强夺我衣。诸长老比丘呵责跋难陀。云何净施与不可信人。而复还夺。复呵责达摩。人净施汝云何不还。以是白佛。佛以是事集比丘僧。问跋难陀。汝愚痴人。实净施与不可信人不。答言。实尔世尊。复问达摩。汝愚痴人。他实净施汝。汝不肯还不。答言。实尔世尊。佛种种呵责已。告诸比丘。不应净施与五种人。一者不相识。二者未相谙悉。三者未相狎习。四者非亲友同师。五者非时类。无此五法然后可以净施与之。复有二法不应净施。一者不能赞叹人。二者不能与人作好名称。复有二法不应净施。一者不能为人受重物净施护如己有。二者己有重物不能净施彼用不恨。复有二法不应净施。一者不知彼在世以不。二者不知彼在道以不。诸比丘作是念。佛听我等净施。便净施父母兄弟姊妹。以是白佛。佛言。不应净施白衣。应净施五众。有诸比丘独住房中。有长衣不知云何作净施。以是白佛。佛言。应作遥示净施。若于三衣中须有所易。应偏袒右肩脱革屣胡跪捉衣心生口言。我此某衣若干条今舍。第二第三亦如是说。然后受所长之衣。亦如前法心生口言。我此某衣若干条受。第二第三亦如是说。如是受已。所舍之衣应用净施。复应如前法心生口言。我此长衣净施某甲从彼取用。若不须易受者。所长之衣应即如是净施。独净施法。至十一日。复应如前法心生口言。我此长衣从某甲取还。然后更如前法受持净施。若对人净施。应作展转净施如前法。捉衣作是言。我此长衣于长老边作净施。彼比丘应问言。长老此衣于我边作净施。我持与谁。答言。于五众中随意与之。彼比丘即应语言。我今与某甲。长老若须从彼取用好爱护之。彼受作净施比丘。后以此事语所称名比丘。所称名比丘。恐犯长衣罪不敢受。不知云何。以是白佛。佛以是事集比丘僧。告诸比丘。不应语所称名比丘。今为诸比丘结戒。从今是戒。应如是说。若比丘与比丘比丘尼式叉摩那沙弥沙弥尼净施衣还夺波逸提。比丘尼亦如是。若与彼衣从索彼还而取不犯(八十一竟)

佛在王舍城。尔时跋难陀。常受一家供养。彼后请僧。时跋难陀晨朝着衣持钵。入城到诸家处处语说。彼唱时至。诸比丘着衣持钵。往到其舍众坐已久。语主人言。日时欲过何不下食。答言。我为跋难陀故请僧须待其到。时跋难陀逼中方至。诸比丘有食者有少食者有不食者。主人以此嫌呵跋难陀言。沙门释子有何急事。先受我请而过诸家逼中方来。令诸比丘不得食我所供养食。使我多办饮食而成无用。诸比丘种种呵责跋难陀言。汝不能饶益佛法。乃作如是苦恼众僧。以是白佛。佛以是事集比丘僧。问跋难陀。汝实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘受他请食前至余家波逸提。后时跋难陀主人。自担熟食诣僧坊供养僧及跋难陀。跋难陀食先竟便去行到余家。使更集僧欲下异食。以跋难陀不在久不下之。诸比丘语言。日时垂过何不下之。答言。我本为跋难陀。须来便下。跋难陀竟不来。遂不得下。彼种种讥嫌跋难陀。诸比丘亦呵责。以是白佛。佛以是事集比丘僧。问跋难陀。汝实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。从今是戒应如是说。若比丘受他请食前食后行到余家波逸提。有诸比丘。有僧事塔事私事。须入余家不敢去。以是白佛。佛以是事集比丘僧。告诸比丘。今听诸比丘白余比丘然后得去。从今是戒应如是说。若比丘受他请食前食后行到余家。不白余比丘波逸提。或有诸比丘。相嫌不共语。或坐禅或熟眠。不知白谁。出门见诸比丘。便走逐大唤遥白。诸居士见讥呵言。诸比丘如鹿走如兔走如秃枭鸣。无沙门行破沙门法。诸长老比丘闻种种呵责。以是白佛。佛以是事。集比丘僧。问诸比丘。汝等实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。不应遥白。从今是戒应如是说。若比丘受他请食前食后行到余家。不近白余比丘波逸提。诸比丘作是念。衣时亦当白不。以是白佛。佛以是事集比丘僧。告诸比丘。除衣时从今是戒应如是说。若比丘受他请食前食后行到余家。不近白余比丘除因缘波逸提。因缘者。衣时是名因缘。若白至东家而至西家。不名为白。若不白到诸家一脚入门突吉罗。两脚入门波逸提。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗。若白至一家因此至余家不犯。若无比丘可白亦不犯(八十二竟)

佛游拘萨罗国。与大比丘千二百五十人俱。诸比丘或得房宿。或得树下或在露地。时六群比丘晨朝着衣持钵。于街巷中共诸白衣。论说世事至于日暮。行人见之讥呵言。此非出家语论之处。何不住阿练若处守摄诸根。或有言。此辈不乐佛法不敬戒律。得语戏处便忘日暮耳。诸长老比丘闻。种种呵责。以是白佛。佛以是事集比丘僧。问六群比丘。汝等实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘非时入聚落波逸提。有诸比丘。有缘事须非时入聚落。而不敢入。以是白佛。佛以是事集比丘僧。告诸比丘。今听有缘事非时入聚落。从今是戒应如是说。若比丘非时入聚落。不近白善比丘。除因缘波逸提。因缘者难时。是名因缘。沙弥突吉罗。若行路经聚落。若暮须往宿。若八难起皆不犯(八十三竟)

佛在王舍城。尔时去城不远有一神树。众人奉事。至节会时七日乃止。四种兜罗贮荐弃之而去。诸比丘于后收取以贮。绳床木床及作枕褥。诸白衣见讥呵言。此物臭秽好生诸虫。云何比丘坐卧其上。无沙门行破沙门法。诸长老比丘。闻种种呵责。以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘以兜罗贮坐卧具波逸提。兜罗者。柳华白杨华蒲梨华睒婆华若发心及方便欲贮皆突吉罗。作成波逸提。若不坏若坐。坐坐波逸提。若卧。卧卧波逸提。若他与受波逸提。要先弃然后得悔过。若不尔罪益深。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(八十四竟)

佛在舍卫城。尔时诸比丘畜高床老病比丘上下床时。堕地破伤或露形体。诸白衣见讥呵言。此诸沙门如王如贵人奢豪无俭。时波斯匿王。以所坐卧床与跋难陀。跋难陀得已于房内敷。世尊常法。五日一按行诸房。跋难陀白佛言。看我住床。佛呵责言。汝愚痴人如何安生死窟宅无求出意。汝不应自畜高床敷锦绣褥。犯者突吉罗。即以是事集比丘僧。告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘自作坐卧绳床木床。足应高修伽陀八指除入髀。若过波逸提。若自作床若使人作。若高皆应截。罪应悔过。若得高床施。受时应作是念。此床不如法。我当更截。若不作是念受波逸提。亦应先截然后悔过。比丘尼亦如是。式叉摩那沙弥沙弥尼突吉罗(八十五竟)

佛在王舍城。尔时诸比丘用骨牙角作针筒。便诸处求若粪扫中拾用作之。诸居士见讥呵言。此诸沙门如狗如鸟如牙角师不净可恶。复有诸比丘至屠杀处。见欲杀时豫从乞之。诸屠杀者皆讥呵言。观此沙门。唯欲多杀见杀便喜。昼夜常说慈愍护念众生。而今无有仁恻之心。时有牙角师。信乐佛法常供给诸比丘。或自出牙角为作。或索牙角而为作之。以是致弊。余人不得复有所作。家人自相谓言。若常为沙门作奴。我等便应各分生活。邻人语言。汝信敬沙门方当穷困。诸长老比丘闻种种呵责。以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘用骨牙角作针筒波逸提。若比丘发心及方便欲作突吉罗。成已波逸提。亦应先坏然后悔过。作灌鼻筒不犯。余如床中说(八十六竟)

佛在舍卫城。尔时诸比丘不敷坐具。坐僧床褥垢腻污之。复有一比丘失于大便谓是风出。既觉洗浣于房前晒。世尊问阿难。此是谁褥。即具以答。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。不应不敷坐具坐僧床褥。犯者突吉罗。今听诸比丘。护身护衣护僧床褥。故畜坐具。诸比丘作是念。佛已听我等作坐具。便广大作垂地污埿。诸居士见问诸比丘。此是何衣垂地。答言。是我等坐具。便讥呵言。大德。何不称身作之。虽复出家财岂应不惜。释子常说。少欲知足。而今如此。无沙门行破沙门法。诸长老比丘闻种种呵责。以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘作尼师檀应如量作。长二修伽陀磔手广一磔手半。若过波逸提。长老优陀夷身大坐具小不足容膝。于佛按行房时。牵挽坐具如牵皮法。佛问何故作此。答言。世尊。我身大而坐具小。作此牵挽欲令广长。佛呵责言汝愚痴人。犹不离戏笑。今听更益头磔一手。即以是事集比丘僧。告诸比丘。从今是戒应如是说。若比丘作尼师檀。应如量作。长二修伽陀磔手广一磔手半。若续方一磔手。若过波逸提。续方一磔手者。截作三分续长头。余一分帖四角。不帖则已。除比丘尼式叉摩那沙弥尼。余如床中说(八十七竟)

佛在舍卫城。尔时毗罗荼比丘。体生痈疮脓血流溢。衣服着疮脱时剥痛。佛行房见。问彼比丘。汝病小差苦可忍不。答言。病不差苦不可忍。衣服着疮脱辄剥痛。佛以是事集比丘僧。告诸比丘。今听诸比丘护身护衣护僧坐褥。故畜覆疮衣用细滑物作。诸比丘作是念。佛听我等作覆疮衣。便大作通裹头足曳地污埿。诸居士见种种讥诃。如尼师檀中说诸长老比丘闻。种种呵责以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘作覆疮衣。应如量作。长四修伽陀磔手广二磔手。若过波逸提。覆疮衣病疮时着。疮差应净施。余如坐具中说(八十八竟)

佛在舍卫城。尔时佛听毗舍佉母施僧雨浴衣。诸比丘便广大作。诸居士讥呵。乃至诸比丘以是白佛。皆如上说。告诸比丘。今为诸比丘结戒从今是戒应如是说。若比丘作雨浴衣。应如量作。长五修伽陀磔手广二磔手半。若过波逸提。余如覆疮衣中说(八十九竟)

佛在舍卫城。时诸比丘。作修伽陀衣已量衣若过。居士讥呵。乃至诸比丘以是白佛。皆如上说。告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘作修伽陀衣已量衣若过波逸提。修伽陀衣已量者。长九修伽陀磔手广六磔手。是名修伽陀衣已量。难陀短佛四指。不知云何作衣。以是白佛。佛言。听难陀衣短佛衣二指。复有诸比丘短小。不知云何作衣。以是白佛。佛言。听随身长短作衣。余如雨浴衣中说(九十竟)

佛在王舍城。尔时难陀跋难陀共作是议。世尊已制回欲与僧物入已犯尼萨耆波逸提。我等今当回以相与。便各说诸檀越更互得之。诸长老比丘闻。种种呵责以事白佛。佛以是事集比丘僧。问难陀跋难陀。汝实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。今为诸比丘结戒。从今是戒应如是说。若比丘知檀越欲与僧物回与余人波逸提。余如回欲与僧物入已中说(九十一竟)

五分律卷第九五分律卷第十(弥沙塞)

        宋罽宾三藏佛陀什共竺道生等译

    第一分之六悔过法

佛在舍卫城。尔时和伽罗母优婆夷。信乐佛法常供养沙门。为人长雅。其后以信出家。少欲知足多致供养。乞食持归。见一比丘问言。何故行此。答言。乞食。又问。能受我此食不。答言能。即便与之。复入一家乞食。彼比丘语余比丘言。和伽罗母比丘尼能得饮食。可从彼取。诸比丘闻即便往就彼。比丘尼得食辄复与之。作是念。我最后所得当持归食。既得持出。复逢一比丘如前问讯。又以与之。空钵而还。诸比丘食后集议言。彼比丘尼幸能多得饮食。我等何烦余处求乞。但当日日共随其后。于是明旦入聚落中而寻随之。彼比丘尼得食辄与。空钵而归。至第三日。晨朝行乞时。有长者乘马车行。彼比丘尼适欲避之。即便倒地。时波斯匿王有令。若于国内轻慢释子沙门者。当重治之。彼长者即大惶怖。下车扶起谢言。我不相犯。何以忽尔。答言。实不见犯。我饥乏故。又问。乞食不得耶。答言。我所得食尽与比丘。故致此恶。又言。愿受我食。默然许之。即以施与还与比丘。长者下车人众已多。皆讥呵言。此比丘尼施虽无厌受者应自知量。此辈常说少欲知足。而今贪取苟困同道。诸长老比丘闻种种呵责以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。今为诸比丘结波罗提提舍尼法。从今是戒应如是说。若比丘从比丘尼受食。是比丘应向诸比丘悔过。我堕可呵法。今向诸大德悔过。是名悔过法。有诸比丘。亲里比丘尼能得饮食。见诸比丘乞食艰难。语言。莫自苦困。从我取之。诸比丘言。佛不听我等从比丘尼受食。诸比丘尼言。唯亲知应与知应取。愿以白佛。诸比丘以是白佛。佛以是事集比丘僧。告诸比丘。今听诸比丘从亲里比丘尼受食。从今是波罗提提舍尼法应如是说。若比丘从非亲里比丘尼受食。是比丘应向诸比丘悔过。我堕可呵法。今向诸大德悔过。是名悔过法。又有诸病比丘牵病乞食。病辄增剧。诸比丘尼语言。莫自苦困。从我受食。病比丘言。佛不听我从非亲里比丘尼受食。以是白佛。佛以是事集比丘僧。告诸比丘。今听病比丘从非亲里比丘尼受食。从今是波罗提提舍尼法应如是说。若比丘无病从非亲里比丘尼受食。是比丘应向诸比丘悔过。我堕可呵法。今向诸大德悔过。是名悔过法。时诸比丘尼。或于僧坊或于自住处或在诸家。为诸比丘设前食后食怛钵那及粥。又与作浴施诸油酥。诸比丘不知云何。以是白佛。佛以是事集比丘僧。告诸比丘。今听受诸比丘尼施食。不得于街巷中受。从今是波罗提提舍尼法应如是说。若比丘无病。在街巷中从非亲里比丘尼自手受食。是比丘应向诸比丘悔过。我堕可呵法。今向诸大德悔过。是名悔过法。若比丘在聚落外。比丘尼在聚落内受食。若比丘在聚落内。比丘尼在聚落外受食。若比丘在空。比丘尼在地受食。若比丘在地。比丘尼在空受食。皆突吉罗。沙弥突吉罗(一竟)

佛在王舍城。尔时有居士请二部僧食。六群比丘与六群比丘尼对坐。互教下食人令相益。余善比丘不复得食。语主人言。汝今请僧何不益食。答言。今此比丘乱我意。不知谁应益谁不应益。主人便讥呵六群比丘言。此等更相劝食。正似将妇共受人请。无沙门行破沙门法。诸长老比丘闻种种呵责。以是白佛。佛以是事集比丘僧。问六群比丘。汝等实尔不。答言。实尔世尊。佛种种呵责已。告诸比丘。今为诸比丘结波罗提提舍尼法。从今是戒应如是说。若比丘白衣家请食。是中有比丘尼作是语。与是比丘饭与是比丘羹。诸比丘应语是比丘尼。姊妹小却。待诸比丘食竟。若比丘中乃至无一比丘语是比丘尼姊妹小却待诸比丘食竟者。是诸比丘应向诸比丘悔过。我堕可呵法。今向诸大德悔过。是名悔过法。尔时有五百比丘。在一长者家食。彼常所供养比丘尼来。诸比丘便齐声言。小却小却。彼比丘尼极大羞耻。即便还去。主人见已问诸比丘。此比丘尼有何相犯。齐声驱遣。或复有言。此辈沙门恐比丘尼夺其食分。是故如是。同共出家。而相嫉妒自不相善。况于余人。诸长老比丘闻以是白佛。佛以是事集比丘僧。告诸比丘。若比丘食时。比丘尼不随欲嗔痴畏教益食及默然住。犯波罗提提舍尼者无有是处。从今是波罗提提舍尼法应如是说。若比丘白衣家请食。有比丘尼教益食人言。与是比丘饭与是比丘羹。诸比丘应语是比丘尼。姊妹。小却。待诸比丘食竟。若众中乃至无一人语者。是比丘应向诸比丘悔过。我堕可呵法。今向诸大德悔过。是名悔过法。若有比丘尼教益比丘食。第一上座应语。若不用上座语。第二上座次应语。如是转下乃至新受戒者。若式叉摩那沙弥尼教益比丘食。比丘不语小却突吉罗。若比丘教益比丘食不平等而食者突吉罗。沙弥突吉罗(二法竟)

佛在拘舍弥国。尔时长者瞿师罗。信乐佛法见法得果。常供养佛及比丘僧。彼于后时财物竭尽。中表亲戚送食与之。诸比丘犹到其家取满钵去。其家内人不堪饥苦。邻人见之皆讥呵言。施主虽无厌受者应知足。如何侵损他家。财物竭尽我等以食分与之。犹复割夺。无慈愍心苟欲快意。无沙门行破沙门法。诸长老比丘闻。种种呵责以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言实尔世尊。佛种种呵责已告诸比丘。今听诸比丘为瞿师罗长者作学家白二羯磨。乃至不听一比丘入其家。应一比丘唱言。大德僧听。此瞿师罗长者。诸比丘往到其家。取种种食满钵而还。不留遗余。遂使其家财物竭尽。今作学家羯磨。乃至不听一比丘复入其舍。若僧时到僧忍听。白如是。大德僧听。此瞿师罗长者。诸比丘往到其家。取种种食满钵而还。不留遗余。遂使其家财物竭尽。今作学家羯磨。乃至不听一比丘复入其舍。谁诸长老忍默然不忍者说。僧已与瞿师罗作学家羯磨竟。僧忍默然故。是事如是持。时诸比丘便处处与余家作学家羯磨。以是白佛。佛言。不听处处与余家作学家羯磨。若妇是圣人婿是凡夫。或妇是凡夫婿是圣人。皆不应与作学家羯磨。若夫妇俱圣无悭贪心财物竭尽。然后乃与作学家羯磨。时诸比丘皆不敢复往瞿师罗家。彼家大小莫不思见。时瞿师罗到僧坊白诸比丘言。我归三尊不复更求诸余福田。愿诸大德来往我家。诸比丘以是白佛。佛言听往。诸比丘虽往而不饭食。长者言。我归三宝不复更求诸余福田。愿受我食。诸比丘以是白佛。佛言。听受钵中三分之一。佛既听受三分之一。诸比丘便尽往乞。家财竭尽复甚于前。诸长老比丘闻。种种呵责以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结波罗提提舍尼法。从今是戒应如是说。有诸学家。僧作学家羯磨。若比丘于是学家受食。是比丘应向诸比丘悔过。我堕可呵法。今向诸大德悔过。是名悔过法。彼瞿师罗财物未尽时别立一出息坫。请僧中病比丘以供养之。复有一药坫亦如是。诸病比丘后惭愧不敢受。长者言。我本为僧中病比丘出此财物及立药坫若使不受终不持归。诸比丘以是白佛。佛以是事集比丘僧。告诸比丘。是彼财物未竭尽时请施。今听诸比丘随意受。从今是戒应如是说。有诸学家。僧作学家羯磨。若比丘无病先不受请。于是学家受食。是比丘应向诸比丘悔过。我堕可呵法。今向诸大德悔过。是名悔过法。复有一比丘无病。从羯磨学家取食。受已心疑。我故当不犯波罗提提舍尼耶。持还与余比丘。余比丘食已问言。汝何故不食。答言我无病从羯磨学家取此食。恐犯波罗提提舍尼。彼比丘言。如汝所疑我今犯之。以是白佛。佛以是事集比丘僧。告诸比丘。若从羯磨学家取食不食。而与他食皆不犯。从今是戒应如是说。有诸学家。僧作学家羯磨。若比丘无病先不受请。于是学家自手受食。是比丘应向诸比丘悔过。我堕可呵法。今向诸大德悔过。是名悔过法。若学家财物竭尽。僧有园田应与令知。使异常限余以自供。若无园田。僧有异供养时令其学家作使得遗余。若复无此。乞食得已应就其家食与其所余。若不能尔应将至僧坊给其房舍卧具次第与食。非时浆饮皆悉与之。若有可分之衣亦应与分。彼学家妇女诸比丘尼。亦应如是料理。沙弥突吉罗(三法竟)

佛在迦维罗卫城尼拘类园。尔时有诸比丘住阿练若处。诸白衣饷食为贼所劫。便嫌呵言。何以不语我。我若知之当持杖自卫。亦可不来。诸比丘以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结波罗提提舍尼法。从今是戒应如是说。若比丘住阿练若处。有疑恐怖。先不伺视。在僧坊内受食。是比丘应向诸比丘悔过。我堕可呵法。今向诸大德悔过。是名悔过法。尔时诸释五百奴叛。住阿练若处。诸释妇女欲往问讯布施众僧。诸奴闻已共议言。我等当于道中抄取。诸比丘闻便往语诸释妇女。此中有贼欲抄取汝。汝等莫来。诸女便止。诸奴复言。诸释妇女所以不来。必是诸比丘先往语之。即问诸比丘。诸比丘不妄语以实而答。奴便打诸比丘。尽夺衣钵垂死乃置。诸比丘以是白佛。佛言不应语有贼。但语使莫来。时诸比丘不知外人当来。以是白佛。佛言。应恒远望。若见人来。驰往说之。有食为取速遣令反。从今是波罗提提舍尼法应如是说。若比丘住阿练若处。有疑恐怖。先不伺视。在僧坊内自手受食。不出外受。是比丘应向诸比丘悔过。我堕可呵法。今向诸大德悔过。是名悔过法。有人送食忽至已入僧坊。诸比丘不知云何。以是白佛。佛言。听一人即为受自出一分余行与众。以己一分从众中一人贸食令速去。若不得去。应藏送食人勿令贼见。若不得藏。应与袈裟披送令去。若复不得。应权剃头着法服令去。沙弥突吉罗。若军行经过与食。若贼自持食与。不犯(四悔法竟)

    五分律第一分之七众学法

佛在王舍城。尔时诸比丘着下衣。或太高或太下。或参差或如多罗叶。或如象鼻。或如圆奈。或细襵。居士见讥呵言。此诸沙门着下衣。或似妇人或似伎儿。以此为好无有风法。尚不知着衣何况于理。诸长老比丘闻。种种呵责以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结应学法。从今是戒应如是说。不高不下不参差不如多罗叶不如象鼻不如圆奈不细襵着下衣应当学。高著者。半踁已上。下著者。从踝已下。参差著者。四角不齐。如多罗叶著者。前高后下。如象鼻者。垂上一角。如圆奈者。撮上令圆以摄腹前。细襵者。绕腰作细襵。若不解不问而作此着突吉罗。若解不慎作此着突吉罗。若解轻戒轻人作此着波逸提。比丘尼亦如是。式叉摩耶沙弥沙弥尼突吉罗。若病时泥雨时不犯。佛在王舍城。尔时诸比丘披衣。或太高或太下或参差。居士讥呵。乃至为诸比丘结应学法。皆如上说。从今是戒应如是说。不高不下不参差披衣应当学。高下参差义如上说

佛在王舍城。尔时诸比丘。不好覆身入白衣舍。或以此白衣舍坐。或反抄衣着右肩上入白衣舍。或以此白衣舍坐。或反抄衣着左肩上入白衣舍。或以此白衣舍坐。或左右反抄衣着两肩上入白衣舍。或以此白衣舍坐。或摇身或摇头或摇肩或携手或隐人或叉腰或拄颊或掉臂入白衣舍。或以此白衣舍坐。或高视或左右顾视入白衣舍。或以此白衣舍坐。或企行入白衣舍。或以此白衣舍坐。或蹲行入白衣舍。或以此白衣舍。坐或覆头入白衣舍。或以此白衣舍坐。或戏笑入白衣舍。或以此白衣舍坐。或高声入白衣舍。或以此白衣舍坐。或不庠序入白衣舍。或以此白衣舍坐。诸居士见讥呵如前诸长老比丘闻。种种呵责以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结应学法。从今是戒应如是说。好覆身入白衣舍应当学。乃至庠序白衣舍坐应当学

佛游婆伽国。与大比丘僧五百人俱。到首摩罗山住恐怖林。尔时有菩提王太子。于此山新立讲堂。未有沙门婆罗门入中坐者。彼太子闻佛来到此山住恐怖林。告萨阇子摩纳。汝以我名问讯世尊。少病少恼起居轻利不。我于此山新立讲堂。未有沙门婆罗门入中坐者。唯愿世尊及与众僧。先受此堂。于中薄设供养。使我长夜安隐。若佛有教。我当谛受。以此白佛。速还报我。摩纳受教。到已头面礼足却住一面。具宣太子意。佛默然受之。时萨阇子知佛许已。还白太子。太子通夜办多美饮食。明日自送至彼讲堂。其家内外皆敷杂色之衣。时至白佛。愿屈威神。佛与五百比丘前后围绕。到彼讲堂住阶道下。太子偏袒右肩右膝着地合掌白佛。唯愿世尊登此陋堂使我长夜受获安乐。佛犹不上如是至三。最后请时佛顾视阿难。阿难承佛圣旨。语太子言。收此杂色衣。佛不蹈上。愍后世故。太子即敕收衣。复如前白。于是世尊。与众僧俱上就坐。太子手自下食。诸比丘以一指或以二指捻钵而受下食着中。即皆失钵饮食流漫污其水精之地。诸居士见讥呵言。此诸比丘正似憍儿又如狡戏。诸长老比丘闻。种种呵责以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结应学法。从今是戒应如是说。一心受食应当学。一心受食者。左手一心擎钵右手扶缘

佛在王舍城。尔时诸比丘溢钵受食弃捐羹饭。诸白衣讥呵。此诸比丘贪受无厌如饥饿人。复有诸比丘于白衣家得饭食尽不待羹得羹复食尽不待饭。诸白衣讥呵言。此诸比丘贪食如狗。复有诸比丘于钵中处处取食。复有诸比丘刳中央食。复有诸比丘曲指收钵食。复有诸比丘嗅食食。诸居士见皆讥呵。长老比丘闻。以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结应学法。从今是戒应如是说。不溢钵受食。羹饭俱食。不于钵中处处取食。不刳中央食。不曲指收钵食。不嗅食食。应当学

佛在王舍城。尔时诸比丘左右顾望食。诸白衣讥呵。此诸比丘如狗如鸟。自食并视人。食尚不知食法。况余深理。诸长老比丘闻。以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言实尔世尊。佛种种呵责已告诸比丘。不应左右顾视食。时诸比丘便不敢顾视闭目而食不见益羹饭。六群比丘取其可食物开目问言谁取我食。答言。汝等自不视乎。反问傍人。余比丘种种呵责已白佛。佛以是事集比丘僧。问六群比丘。汝等实尔不。答言实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结应学法。从今是戒应如是说。谛视钵食应当学。谛视钵者。系视在钵视益食时

佛在王舍城。尔时诸比丘弃捐饭食。诸居士讥呵。此诸比丘如小儿食。复有五百比丘于一居士家食。诸白衣中。有言比丘食都不弃饭有言弃者。二人遂共赌之。诸比丘今日偶不弃饭。后时见于余处食弃饭。讥呵如上。诸比丘闻。种种呵责以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结应学法。从今是戒应如是说。不弃饭食应当学

佛在王舍城。尔时诸比丘以食手捉净饭器肥腻污秽。余比丘恶之。诸居士见讥呵言。云何以食手捉净饭器。长老比丘闻。种种呵责以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言实尔世尊。佛种种呵责已告诸比丘。食时不应以右手捉净饭器。后时诸白衣行饭。比丘以左手受。白衣不与。作是言。不告诸比丘。以是白佛。佛以是事集比丘僧。告诸比丘。应净洗手捉饭器。今为诸比丘结应学法。从今是戒应如是说。不以食手捉净饭器应当学。食手者。食污其手及肥腻

佛在王舍城。尔时诸比丘吸食食。复有诸比丘嚼食作声。诸居士见讥呵言。此诸比丘食如狗嗒水。复有婆罗门请诸比丘与粥。诸比丘歠粥作声。有一比丘言。今诸比丘食如寒战时。作是语已心生疑悔。我今毁呰僧不知云何。以是白佛。佛以是事集比丘僧。问彼比丘。汝以何心作是语。答言有恨心有戏心。佛言恨心呵无犯。戏心呵犯突吉罗。告诸比丘。今为诸比丘结应学法。从今是戒应如是说。不吸食食。不嚼食作声。应当学

佛在王舍城。尔时诸比丘舐取食。诸居士见讥呵言。此诸比丘犹如牛食。诸长老比丘闻。种种呵责以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结应学法。从今是戒应如是说。不舐取食应当学

佛在王舍城。尔时诸比丘满手食食弃落堕地。复有诸比丘大张口食。复有诸比丘饭未至大张口待蝇入口食竟多吐。复有诸比丘缩鼻食。诸居士见皆讥呵。长老比丘闻。种种呵责以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结应学法。从今是戒应如是说。不满手食食应当学。不大张口食应当学。饭未至不大张口待应当学。不缩鼻食应当学。诸比丘饭至口犹不敢开污口边流堕地。以是白佛。佛言不远不近便应开

佛在王舍城。尔时诸比丘含食语食。或落地或落衣上或落钵中。诸居士见皆讥呵。诸长老比丘闻。种种呵责以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结应学法。从今是戒应如是说。不含食语应当学。诸比丘后时白衣益食问须不。不敢答。便讥呵言。诸比丘憍慢不共人语。以是白佛。佛言。益食时听言须不须

佛在王舍城。尔时诸比丘满口食两颊胀起。诸居士见讥呵言。此诸比丘如猕猴食。复有诸比丘啮半食残还钵中。诸居士见讥呵言。此诸比丘饮食不净。复有诸比丘舒臂取食。诸居士见讥呵言。此诸比丘如象用鼻。复有诸比丘振手食。诸居士见讥呵言。此诸比丘如象掉鼻。复有诸比丘吐舌食。诸居士见讥呵言。此诸比丘如狗吐舌。复有诸比丘全吞食。复有诸比丘揣饭遥掷口中。诸居士见皆讥呵。长老比丘闻。种种呵责以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结应学法。从今是戒应如是说不胀颊食应当学。不啮半食应当学。不舒臂取食应当学。不振手食应当学。不吐舌食应当学。不全吞食应当学。不揣饭遥掷口中应当学

佛在王舍城。尔时诸比丘以荡钵水泻白衣屋内。诸居士见讥呵言。此诸比丘不知荡钵恶水所应泻处况知远事。诸长老比丘闻。种种呵责以是白佛。佛以是事集比丘僧。问诸比丘汝等实尔不。答言实尔世尊。佛种种呵责已告诸比丘。不应以荡钵水泻白衣屋内。有诸白衣新作屋。得比丘钵中水洒地以为吉祥。诸比丘不敢洒。诸居士言。此诸比丘不堪人敬。诸比丘以是白佛。佛以是事集比丘僧。告诸比丘。听诸比丘以钵中无食水用洒地。今为诸比丘结应学法。从今是戒应如是说。不以钵中有食水洒白衣屋内应当学

佛在王舍城。尔时诸比丘以饭覆羹。诸白衣谓未得更与之。既知已讥呵言。此诸比丘以饭覆羹如小儿。诸长老比丘闻。种种呵责以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言实尔世尊。佛种种呵责已告诸比丘。不应以饭覆羹。有诸病比丘不敢以饭覆羹。虫落羹中不能得去。以是白佛。佛以是事集比丘僧。告诸比丘。听以饭覆羹。不应更望得。今为诸比丘结应学法。从今是戒应如是说。不以饭覆羹更望得应当学

佛在王舍城。尔时有诸比丘至白衣家嫌呵食。复有诸比丘自索益食。诸居士皆讥呵。诸长老比丘闻。种种呵责以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言实尔世尊。佛种种呵责已告诸比丘。不应嫌呵食自索益食。诸比丘便不敢为病比丘索益食。以是白佛。佛以是事集比丘僧。告诸比丘。听为他比丘索益食。不应自为。今为诸比丘结应学法。从今是戒应如是说。不嫌呵食应当学。不为已索益食应当学

佛在王舍城。尔时诸比丘视比坐钵中多少。诸居士见讥呵言。此诸比丘如小儿视他钵中。汝得多我得少汝得少我得多。诸长老比丘闻。种种呵责以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言实尔世尊。佛种种呵责已告诸比丘。不应视比坐钵中多少。时五百比丘在一家食。食已共相语言。希有此食。下座比丘言。上座得好我等不得。诸比丘作是念。佛听我等视他钵者。得知谁得谁不得。不得者教与。以是白佛。佛以是事集比丘僧。告诸比丘。听视比坐钵。不得生嫌心。今为诸比丘结应学法。从今是戒应如是说。不嫌心视比坐钵应当学

佛在王舍城。尔时诸比丘立大小便。诸居士见讥呵言。此诸比丘如驴如马。诸长老比丘闻。种种呵责以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结应学法。从今是戒应如是说。不立大小便应当学。时诸比丘病不能蹲地。以是白佛。佛以是事集比丘僧告诸比丘。听诸比丘病时立大小便。从今是戒应如是说。不立大小便除病应当学

佛在王舍城。尔时诸比丘水中大小便。诸居士讥呵。长老比丘闻。种种呵责以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结应学法。从今是戒应如是说。不大小便水中应当学。有诸病比丘。医语言。汝可水中大小便。我当视之知可治不。诸比丘不敢语言。愿作余方。医言。唯视此然后知。诸病比丘作是念。佛若听大小便水中者乃当得愈。以是白佛。佛以是事集比丘僧。告诸比丘。今听病比丘水中大小便。从今是戒应如是说。不大小便净水中除病应当学。若大小便木上。因此流入水中不犯

佛在王舍城。尔时诸比丘大小便生草叶上。诸居士见讥呵言。此诸比丘似牛羊。诸长老比丘闻。种种呵责以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结应学法。从今是戒应如是说。不大小便生草叶上除病应当学。若大小便木上。因此流草叶上不犯

佛在王舍城。尔时诸比丘为着屐革屣人说法。诸居士见讥呵言。是法尊贵第一微妙。而诸比丘为着屐革屣人说。轻慢此法。诸长老比丘闻。种种呵责以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结应学法。从今是戒应如是说。不为着屐人说法应当学不为着革屣人说法应当学。有诸病人不得脱屐革屣而欲闻法。诸比丘不敢说。以是白佛。佛以是事集比丘僧。告诸比丘。今听诸比丘为着屐革屣病人说法。从今是戒应如是说。人着屐不应为说法除病应当学。人着革屣不应为说法除病应当学。法者。佛所说声闻所说仙人所说诸天所说及一切如法说者。若多人着屐革屣不能令脱。但因不著者为说不犯

佛在王舍城。尔时诸比丘为现胸人乃至拄杖人说法。诸居士见讥呵如上。诸长老比丘闻。种种呵责以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言实尔世尊。佛种种呵责已告诸比丘。今为诸比丘结应学法。从今是戒应如是说。人现胸不应为说法应当学。有诸病人欲闻法。诸比丘不敢为说。以是白佛。佛以是事集比丘僧。告诸比丘。听为现胸病人说法。从今是戒应如是说。人现胸不应为说法除病应当学。人坐比丘立。人在高坐比丘在下。人卧比丘坐。人在前比丘在后。人在道中比丘在道外。为覆头人。为反抄衣人。为左右反抄衣人。为持盖覆身人。为骑乘人。为拄杖人说法。皆如上说

佛在王舍城。尔时诸比丘为捉刀捉弓箭人说地狱苦。彼人闻已便大嗔恚斫射比丘。比丘即死。诸长老比丘闻。以是白佛。佛以是事集比丘僧。告诸比丘。今为诸比丘结应学法。从今是戒应如是说。人捉刀不应为说法应当学。人捉弓箭不应为说应当学。佛在王舍城。尔时六群比丘。为十七群比丘于请家取食分。六群比丘靳固十七群比丘不早还。日逼中。十七群比丘上树望之。诸长老比丘见以事白佛。佛以是事集比丘僧。告诸比丘。今为诸比丘结应学法。从今是戒应如是说。树过人不得上应当学。时有比丘向拘萨罗国道遇恶兽。不敢上树为兽所害。诸比丘以是白佛。佛言。从今是戒应如是说。树过人不得上除大因缘应当学。大因缘者。恶兽诸难。是名大因缘。比丘尼除大小便生草菜上。余皆如上。式叉摩那沙弥沙弥尼突吉罗(众学竟)

    五分律第一分之八七灭诤法

于何处起。应与现前比尼与现前比尼。答言瞻婆城。因谁起。答言六群比丘。于何处起。应与忆念比尼与忆念比尼。答言王舍城。因谁起。答言陀婆力士子

于何处起。应与不痴比尼与不痴比尼。答言王舍城。因谁起。答言伽伽比丘。于何处起。应与自言与自言。答言舍卫城。因谁起。答言因异比丘

于何处起。应与多人语与多人语。答言舍卫城。因谁起。答言因众多比丘。于何处起。应与草布地与草布地。答言舍卫城。因谁起。答言因众多比丘。于何处起。应与本言治与本言治。答言舍卫城。因谁起。答言优陀夷

五分律卷第十五分律卷第十一(弥沙塞)

        宋罽宾三藏佛陀什共竺道生等译

    第二分初尼律波罗夷法

佛在舍卫城。尔时长老优波离问佛。世尊已为诸比丘结戒。若比丘共诸比丘同学戒法。戒羸不舍行淫法乃至共畜生。是比丘得波罗夷不共住。是戒我当云何持。为应作一部僧持二部僧持。佛言。应作二部僧持。从今是戒应如是说。若比丘尼共诸比丘尼同学戒法。戒羸不舍随意行淫乃至共畜生。是比丘尼得波罗夷不共住。尔时长老优波离复问佛。世尊已为诸比丘结戒。若比丘若聚落若空地盗心不与取乃至不共住。我当云何持。佛言。应作二部僧持。从今是戒应如是说。若比丘尼若聚落若空地盗心不与取。若王若大臣若捉若缚若杀若摈。语言汝贼汝痴。是比丘尼得波罗夷不共住。尔时优波离复问佛。世尊已为诸比丘结戒。若比丘若人若似人若自杀乃至不共住。我当云何持。佛言。应作二部僧持。从今是戒应如是说。若比丘尼若人若似人。若自杀若与刀药杀。若教人杀若教人自杀。誉死赞死。咄人用恶活为死胜生。作是必随心杀。如是种种因缘。彼因是死。是比丘尼得波罗夷不共住。尔时优波离复问佛。世尊已为诸比丘结戒。若比丘不知不见过人法乃至不共住。我当云何持。佛言。应作二部僧持。从今是戒应如是说。若比丘尼不知不见过人法圣利满足。自称我如是知如是见。是比丘尼后时若问若不问。为出罪求清净故。作是言。我不知言知不见言见虚诳妄语。除增上慢。是比丘尼得波罗夷不共住。尔时毗舍佉婿名鹿子。鹿子敬毗舍佉犹如敬母。时人遂名为毗舍佉鹿子母。其孙名尸利跋。尸利跋常系念于偷罗难陀比丘尼。后请比丘尼僧。偷罗难陀托病不往。共一小沙弥尼坐守僧房。时到比丘尼僧皆诣其家。尸利跋手自下食。问言。偷罗难陀何故不来。诣比丘尼答言。以其病僧差守房。是故不来。彼下上坐食已。便驰往问。何所患苦。答言骨节皆痛。彼即为按摩。比丘尼言。听汝处处按摩。但不得行欲。既按摩已问言。汝须何物。答言。我须干枣。便买与之。比丘尼以手捧枣问言。汝见是干枣不。答言见。比丘尼言。若人系心于不可行欲处。神明干缩亦如此也。于是尸利跋与此比丘尼种种身相触已便出。诸比丘尼食还入门。遥见咸疑。已共偷罗难陀作不净行。问言汝已破梵行耶。答言我不破梵行。唯与男子身相触耳。小沙弥尼亦云如此。诸比丘尼种种呵责言。佛种种毁訾与男子身相触。种种赞叹不触男子身。汝今云何作此恶事。诃已往到佛所。以事白佛。佛以是事集二部僧。问偷罗难陀。汝实尔不。答言实尔世尊。佛如上种种诃责已告诸比丘。以十利故今为诸比丘尼结戒。从今是戒应如是说。若比丘尼欲盛变心。受男子种种摩触。发际已下膝已上肘已后。是比丘尼得波罗夷不共住。比丘尼者。白四羯磨受具足戒。释欲盛变心已下。如比丘触女人身戒中说。尔时诸比丘尼。受男子捉手捉衣共期独共行独共住独共语独共一座坐身亲近男子。以此欲染心不复乐道。或有反俗及作外道者。时偷罗难陀比丘尼。着新染衣摩拭身体画治眉目往多人处。有诸男子捉其手捉其衣言。汝手柔软好汝衣细滑好。诸长老比丘尼见种种呵责。以事白佛。佛以是事集二部僧。问诸比丘尼。汝等实作上八法不。答言实尔世尊。佛种种呵责已告诸比丘。今为诸比丘尼结戒。从今是戒应如是说。若比丘尼欲盛变心。受男子捉手捉衣共期独共行独共住独共语独共一座坐身亲近男子。八法具者。是比丘尼得波罗夷不共住。捉手者。从肘已前。捉衣者。身所著衣。共期者。期至某处行淫法或摩触身往到彼。独共行者。独共男子一道行。独共住者。独共男子一处住。独共语者。独共男子一处语。独共一座坐者。独共男子一床上坐。身亲近男子者。共一座坐时身转就男子。若犯捉手乃至身转就男子。一一皆偷罗遮。若犯七事虽已随悔。后犯一事满八亦成波罗夷。式叉摩那沙弥尼突吉罗

尔时阐陀比丘数数犯罪。上床下床皆不如法。数数食别众食非时入聚落不白善比丘。比丘僧与作不见罪羯磨。其姊比丘尼名优蹉。来往共语及与衣食。诸比丘尼见语言。姊妹。此比丘。比丘僧已和合。与作不见罪羯磨。诸比丘已不共住不共事不共语。汝今云何来往共语与其衣食。优蹉言。此是我弟。我若不视谁当视者。诸长老比丘尼种种呵责。以事白佛。佛以是事集二部僧。问优蹉。汝实尔不。答言实尔世尊。佛种种呵责已告诸比丘。应令一比丘尼与优蹉亲善者往屏处谏。汝莫随顺僧羯磨不见罪比丘。若受者善。若不受应众多比丘尼往谏。若受者善。若复不受复应比丘尼僧往谏。诸比丘受教。敕诸比丘尼。令一比丘尼往谏。乃至比丘尼僧往谏。皆不受。诸长老比丘尼以事白佛。佛以是事集二部僧。种种遥呵责优蹉已。告诸比丘。今为诸比丘尼结戒。从今是戒应如是说。若比丘尼知僧如法与比丘作不见罪羯磨。诸比丘不共住不共事不共语。而随顺之。诸比丘尼语是比丘尼。姊妹。此比丘。比丘僧已作不见罪羯磨。诸比丘不共住不共事不共语。汝莫随顺。如是谏坚持不舍。应第二第三谏。第二第三谏。舍是事善。不舍者是比丘尼得波罗夷不共住。余皆如调达破僧中说。不犯亦如彼说。尔时修休摩比丘尼。婆颇比丘尼。常共行止。后婆颇命过。修休摩为之悲泣。诸比丘尼语言。汝莫如是。一切有为悉皆磨灭。如佛所说恩爱别离无长存者。若有为法不坏不散无有是处。修休摩言。我今不复为其啼哭。何以故。彼生时不修梵行。诸比丘尼问言。汝云何知。答言。彼与我共行亲见与男子行淫欲事。诸比丘尼诃责言。汝云何生时覆藏其罪。死乃发露。诸长老比丘尼种种诃责。以事白佛。佛以是事集二部僧。问修休摩。汝实尔不。答言实尔世尊。佛种种呵责已告诸比丘。今为诸比丘尼结戒。从今是戒应如是说。若比丘尼见比丘尼犯波罗夷覆藏。彼比丘尼后时若在若死若远行若被摈若罢道若形变。作是语。我先亲见其犯波罗夷。是比丘尼得波罗夷不共住。覆藏。从晨朝至初夜初分。时时皆突吉罗。从初夜初分至明相未出。时时皆偷罗遮。至明相出波罗夷。式叉摩那沙弥尼突吉罗。若欲说而无比丘尼未得说。若入大舍定。及八难起皆不犯。八难者。一病二王三贼四水五火六衣钵七命八梵行(八重法竟)

    五分律第二分之二尼律僧残法

尔时长老优波离问佛。世尊已为诸比丘结戒。若比丘行媒法乃至一交会僧伽婆尸沙。我当云何持。佛言。应作二部僧持。从今是戒应如是说。若比丘尼行媒法若为私通事。持男意至女边。持女意至男边。乃至一交会。是比丘尼初犯僧伽婆尸沙可悔过

长老优波离又问。世尊已为诸比丘结戒。若比丘自不如法。恶嗔故以无根波罗夷。谤无波罗夷比丘。乃至僧伽婆尸沙。我当云何持。佛言。应作二部僧持。从今是戒应如是说。若比丘尼自不如法。恶嗔故以无根波罗夷。谤无波罗夷比丘尼。欲破彼梵行。是比丘尼后时若问若不问言。我是事无根住嗔故谤。是比丘尼初犯僧伽婆尸沙可悔过

长老优波离又问佛。世尊已为诸比丘结戒。若比丘自不如法。恶嗔故于异分中取片若似片。乃至僧伽婆尸沙。我当云何持。佛言。应作二部僧持。从今是戒应如是说。若比丘尼自不如法。恶嗔故于异分中取片若似片作波罗夷。谤无波罗夷比丘尼。欲破彼梵行。是比丘尼后时若问若不问言。我是事异分中取片若似片住嗔故谤。是比丘尼初犯僧伽婆尸沙可悔过

尔时诸释共作是要。我等不与庶姓婚姻。若有犯者当重罪之。时释种黑离车女丧夫。夫弟欲取为妇。彼女不从。如是三返誓不相许。便作是念。彼女必有外通意我当杀之。便托为兄作会语言。为汝夫作会。汝来行香。彼女便往到已。饮酒令醉共行不净。然后以爪掴伤其肉。告官司言。黑离车女是我妇。今与外人私通。官即遣收。彼女醉醒。自见身体处处伤破。作是念。此人必当见杀。便叛走向舍卫城。到比丘尼所出家学道。官收不得。知向舍卫城。便作移书与波斯匿王言。我国女人犯罪应死。叛入彼国可送还我。若彼有罪人叛来我国亦当送之。时波斯匿王即问左右。有此女人入我国不。答言有。诸比丘尼已度为道。王先有令。若我国内有犯比丘比丘尼者当与重罪。今已出家无敢毁辱者。王便报移书言。实有此女来入我国。今已出家不可追罪。若有余事敬如来示。诸释便讥诃言。凡有此罪不复得治乱我国矣。诸比丘尼无复可度不可度者何道之有。无沙门行破沙门法。诸长老比丘尼闻。种种诃责以事白佛。佛以是事集二部僧。问诸比丘尼。汝等实尔不。答言实尔世尊。佛种种诃责已告诸比丘。今为诸比丘尼结戒。从今是戒应如是说。若比丘尼知有罪女度为比丘尼者。是比丘尼初犯僧伽婆尸沙可悔过。复有诸贼女偷女应死女。诸居士言。若能出家我当活汝。便求出家即白诸比丘尼。愿见度脱。诸比丘尼言。佛未听我等度如汝辈。以事白佛。佛以是事集二部僧告诸比丘。若主听者。听比丘尼度之。从今是戒应如是说。若比丘尼知有罪女主不听而度者。是比丘尼初犯僧伽婆尸沙可悔过。复有犯罪女。不得于佛法出家。便入外道。诸居士后见有言。此是我等犯罪女。当夺其外道衣服。或有言。外道出家已是重罚自可宜去。即便放之。此诸女等。后来投诸比丘尼。作是言。姊妹。我等本非不敬信佛法于外道出家。诸姊妹不肯见度。逼不获已入外道耳。我等所畏今已见听出家。愿见愍度。诸比丘尼不知云何。以是白佛。佛以是事集二部僧。告诸比丘。若有罪女先已出家今听度之。从今是戒应如是说。若比丘尼知有罪女。主不听度为道。除先出家。是比丘尼初犯僧伽婆尸沙可悔过。有罪者。若犯奸若偷盗。是名有罪。主者。杀活所由。是名为主。若比丘尼发心度此女及方便乃至集僧。三羯磨未竟皆突吉罗。三羯磨竟。和尚僧伽婆尸沙。余尼师僧皆偷罗遮

尔时优蹉比丘尼数数犯罪。上床下床皆不如法。数数食别众食非时入他家。比丘尼僧。与作不见罪摈。时偷罗难陀比丘尼。知优蹉心未调伏不敬顺僧。便不随众自与眷属于界外为其解摈。彼比丘尼既得解摈。倍更憍慢不敬众僧。诸长老比丘尼见。种种诃责。以事白佛。佛以是事集二部僧。问偷罗难陀。汝实尔不。答言实尔世尊。佛种种诃责已告诸比丘。今为诸比丘尼结戒。从今是戒应如是说。若比丘尼知僧如法摈比丘尼。比丘尼心未调伏不随顺僧。自与眷属于界外解其摈者。是比丘尼初犯僧伽婆尸沙可悔过。欲解摈及方便乃至三羯磨未竟皆突吉罗。三羯磨竟。羯磨师僧伽婆尸沙。余僧皆偷罗遮

尔时诸比丘尼独行道路。诸白衣见调弄作粗恶淫欲语。或捉扪摸或欲共为不净行。复有众多比丘尼与估客伴行。偷罗难陀见一男子心生染着渐迟在后。诸比丘尼语言。汝何不速行及伴。此处可畏勿为恶人之所剥脱。答言汝见后来人不。诸比丘尼言见。偷罗难陀言。我见此人心甚乐着。诸比丘尼呵责言。汝云何于行路中染着男子。复有众多比丘尼渡河取牛屎。既渡水涨不得还为贼抄掠。复有诸比丘尼独宿失衣钵破梵行。诸长老比丘尼见闻种种呵责。具以白佛。佛以是事集二部僧。问诸比丘尼。汝等实尔不。答言实尔世尊。佛种种呵责已告诸比丘。今为诸比丘尼结戒。从今是戒应如是说。若比丘尼独行独宿独渡水。于道中独在后染着男子。是比丘尼初犯僧伽婆尸沙可悔过。时有诸比丘尼在路行。有疑恐怖。便走向聚落至亲里家。复有诸比丘尼行路疲极。又有老病不能相及。或有小水或有桥船不敢独渡。或有宿处畏诸男子。不敢独于余处宿。诸比丘尼不知云何。以事白佛。佛以是事集二部僧。告诸比丘。有因缘听随意独去。从今是戒应如是说。若比丘尼独行独宿独渡水。于道中独在后染着男子除因缘是比丘尼初犯僧伽婆尸沙可悔过。因缘者。恐怖走时。老病疲极不及伴时。水狭浅有桥船处。畏男子处。是名因缘。若独行无聚落处半由旬。若有聚落处。从一聚落至一聚落。皆僧伽婆尸沙。若在后遥见比丘尼不闻声或闻声不见形皆突吉罗。若不见不闻僧伽婆尸沙。若独渡水水广十肘深半髀僧伽婆尸沙。若减突吉罗。若宿时应使手相。及若不相及初夜及中夜偷罗遮。明相出僧伽婆尸沙。式叉摩那沙弥尼突吉罗

尔时有一长者以宅布施比丘僧。比丘僧与比丘尼众贸安陀林。末利夫人后以王园施比丘尼僧。比丘尼僧坏前所贸处屋。于王园更起。先处便成空地。时施宅长者子作是念。我父昔以施僧。僧与比丘尼贸。今诸比丘尼不复住中。我可还取于中耕种。即便取之。诸比丘尼语言。汝莫取僧地。答言。我父虽以施僧僧不复用。应还属我。诸比丘尼言。我等不舍此地。勿使诣官言汝更大输物。彼不肯还。即诣官言之。便大输物。诸居士见讥诃言。云何此比丘尼诣官言人。使大失物。此辈受彼供养犹尚言之。况于余人。无沙门行破沙门法。诸长老比丘尼闻。种种诃责以事白佛。佛以是事集二部僧。问诸比丘尼。汝等实尔不。答言实尔世尊。佛种种诃责已告诸比丘。今为诸比丘尼结戒。从今是戒应如是说。若比丘尼诣官言人。是比丘尼初犯僧伽婆尸沙可悔过。若比丘尼为人轻倰。应语其父母。若无父母应语其亲族。若无亲族应语比丘比丘尼优婆塞优婆夷。若比丘比丘尼有势力。不援护者突吉罗。语时应云彼轻倰我。为我诃谏不应言之。若诣官言人。一往返一僧伽婆尸沙。式叉摩那沙弥尼突吉罗

尔时有一估客丧妇。作是念。我今当于何处求索好妇。时旃茶修摩那比丘尼。有弟子名修摩。色貌殊特。彼见生染着。心作是念。以食诱之或可得果。便语言。汝若须酥油蜜石蜜蒲阇尼佉阇尼皆从我取。彼比丘尼即便往取。既相狎习便问比丘尼言。汝知我与汝食意不。答言。汝为求福故与我食。彼言不以此事。我丧失妇。见汝清修甚相贪乐。能降意不。答言不能。其人复言。与我作妇当以奇珍相与。衣服极丽饮食随时。要令无乏。亦答如初。余估客见。便助迫胁言。汝若不欲为他作妇。何故受他饮食。若必不能。当夺汝衣钵。或复有言。速遣令去勿使人闻。若王得知必重治我等。诸居士闻讥呵言。云何比丘尼受他染着男子饮食。此辈无沙门行破沙门法。诸长老比丘尼闻。种种诃责以事白佛。佛以是事集二部僧。问修摩比丘尼。汝实尔不。答言实尔世尊。佛种种诃责已告诸比丘。今为诸比丘尼结戒。从今是戒应如是说。若比丘尼受他染着心男子饮食。是比丘尼初犯僧伽婆尸沙可悔过。有诸男子请比丘尼前食后食。于中生染着心。诸比丘尼知不敢受。以事白佛。佛以是事集二部僧。告诸比丘若比丘尼无染着心。受他染着心男子饮食。犯僧伽婆尸沙无有是处。从今是戒应如是说。若比丘尼有染着心。受他染着心男子饮食。是比丘尼初犯僧伽婆尸沙可悔过。复有一比丘尼有染着心。从一染着心男子受饮食。受已生疑。我将无犯僧伽婆尸沙。即持归与余比丘尼。余比丘尼问。此美饮食汝何故不啖。具以事答。余比丘尼言。汝所畏我亦应畏。以事白佛。佛以是事集二部僧。告诸比丘。若比丘尼有染着心。自手受染着心男子食。不食而与他食皆不犯。从今是戒应如是说。若比丘尼有染着心。自手受染着心男子食食。是比丘尼初犯僧伽婆尸沙可悔过。式叉摩那沙弥尼突吉罗

尔时彼估客复作是念。我先以食诱彼比丘尼。日月浅近是以不果。今当更以食诱引久意或回。便到其所语言。我先虚戏遂至不逊。愿受我悔过。从今如先从我取食。彼比丘尼言。止止男子。汝先恼我。使佛苦责。为诸比丘尼结戒。今日何应再见点辱。彼比丘尼和尚语言。汝先能得多美饮食。今何故不复能得。答言。彼人先恼触我。佛因制戒。不敢复取。和尚复言。汝但莫生染着取食何苦。若他生染着何豫汝事。彼比丘尼嫌诃和尚言。佛种种毁訾亲近男子赞叹远离。云何教我取染着心男子饮食。诸比丘尼闻。诃责彼师言。云何教弟子受染着心男子食。种种呵责已。以事白佛。佛以是事集二部僧。问旃荼修摩那。汝实尔不。答言。实尔世尊。佛种种诃责已告诸比丘。今为诸比丘尼结戒。从今是戒应如是说。若比丘尼教他比丘尼作是语。汝但莫生染着。受染着男子饮食何苦。是比丘尼初犯僧伽婆尸沙可悔过。若作此教。语语僧伽婆尸沙。式叉摩那沙弥尼突吉罗

优波离又问。世尊已为诸比丘结戒。若比丘为破和合僧勤方便乃至僧伽婆尸沙。我当云何持。佛言。当作二部僧持。从今是戒应如是说。若比丘尼为破和合僧勤方便。诸比丘尼语是比丘尼。汝莫为破和合僧勤方便。当与僧和合。僧和合故欢喜无诤。一心一学如水乳合。共弘师教安乐行。如是谏坚持不舍。应第二第三谏。第二第三谏。舍是事善。不舍者是比丘尼三谏。犯僧伽婆尸沙可悔过

优波离又问。世尊已为诸比丘结戒。若比丘助破和合僧乃至僧伽婆尸沙。我当云何持。佛言。应作二部僧持。从今是戒应如是说。若比丘尼助破和合僧。若一若二若众多。语诸比丘尼言。是比丘尼所说。是知说非不知说。说法不说非法。说律不说非律。皆是我等心所忍乐。诸比丘尼语是比丘尼。汝莫作是语。是比丘尼所说。是知说非不知说。说法不说非法。说律不说非律。皆是我等心所忍乐。何以故。是比丘尼非知说非说法非说律。汝莫乐助破和合僧。当乐助和合僧。僧和合故欢喜无诤。一心一学如水乳合。共弘师教安乐行。如是谏坚持不舍。应第二第三谏。第二第三谏。舍是事善。不舍者是比丘尼三谏。犯僧伽婆尸沙可悔过

优波离又问。世尊已为诸比丘结戒。若比丘恶性难共语。与诸比丘同学戒经。数数犯罪乃至僧伽婆尸沙。我当云何持。佛言。当作二部僧持。从今是戒应如是说。若比丘尼恶性难共语。与诸比丘尼同学戒经数数犯罪。诸比丘尼如法如律谏其所犯。答言。阿姨。汝莫语我若好若恶。我亦不以好恶语汝。诸比丘尼复语言。汝莫作自我不可共语。汝当为诸比丘尼说如法语。诸比丘尼亦当为汝说如法语。如是展转相教转相出罪成如来众。如是谏坚持不舍。应第二第三谏。第二第三谏。舍是事善。若不舍者是比丘尼三谏。犯僧伽婆尸沙可悔过

优波离又问。世尊已为诸比丘结戒。若比丘依聚落住。行恶行污他家乃至僧伽婆尸沙。我当云何持。佛言。当作二部僧持。从今是戒应如是说。若比丘尼依聚落住。行恶行污他家。行恶行皆见闻知。污他家亦见闻知。诸比丘尼语是比丘尼。汝行恶行污他家。行恶行皆见闻知。污他家亦见闻知。汝出去不应是中住。彼比丘尼言。诸阿姨随爱恚痴畏。何以故。有如是等同罪比丘尼。有驱者有不驱者。诸比丘尼复语言。汝莫作是语。诸阿姨随爱恚痴畏。有如是等同罪比丘尼。有驱者有不驱者。汝行恶行污他家。行恶行皆见闻知。污他家亦见闻知。汝舍是随爱恚痴畏语。汝出去不应是中住。如是谏坚持不舍。应第二第三谏。第二第三谏。舍是事善。不舍者是比丘尼三谏。犯僧伽婆尸沙可悔过

尔时修休摩比丘尼婆颇比丘尼。共作恶行有恶名声。更相覆罪触恼众僧。诸比丘尼语言。汝等作恶行有恶名声。汝相远离舍是作恶触恼僧事。于佛法中增广得安乐住。二比丘尼言。我等不作恶行无恶名声。亦不触恼众僧。此中有余二比丘尼。共作恶行有恶名声触恼众僧。诸比丘尼言。汝等莫作是语。何以故。此中无有余二比丘尼作恶恼僧。唯有汝等可相远离舍是作恶触恼僧事。于佛法中增广得安乐住。如是谏坚持不舍。诸比丘尼以事白佛。佛以是事集二部僧。问彼二比丘尼。汝等实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。应令一比丘尼与彼二比丘尼亲善者往屏处谏。若受者善。若不受应众多比丘尼往谏。若受者善。若不受应比丘尼僧往谏。诸比丘受教。即敕诸比丘尼往谏。三返皆不受。诸长老比丘尼种种呵责。以事白佛。佛以是事集二部僧。种种遥诃责彼二比丘尼已。告诸比丘。今为诸比丘尼结戒。从今是戒应如是说。若二比丘尼共作恶行有恶名声更相覆罪触恼众僧。诸比丘尼语言。汝二比丘尼作恶行有恶名声更相覆罪触恼众僧。汝相远离舍是作恶触恼僧事。于佛法中增广得安乐住。彼二比丘尼言。我等不作恶行无恶名声不相覆罪不触恼僧。此中有余二比丘尼。共作恶行触恼众僧。诸比丘尼复语言。莫作是语。何以故。此中更无余二比丘尼作恶恼僧。唯有汝等可相远离舍是作恶触恼僧事。于佛法中增广得安乐住。如是谏坚时不舍。应第二第三谏。第二第三谏舍是事善。不舍者是比丘尼三谏。犯僧伽婆尸沙可悔过。更相覆罪者。若僧伽婆尸沙若偷罗遮若波逸提若波罗提提舍尼若突吉罗若不护口。恼僧者。若布萨若自恣若诸羯磨。皆如调达破僧中说。式叉摩那沙弥尼突吉罗

尔时修休摩比丘尼婆颇比丘尼。共作恶行有恶名声。乃至于佛法中增广得安乐住。亦如上说。二比丘尼言。我等不作恶行亦不触恼众僧。僧见我等羸弱。轻易我故作如是语。诸比丘尼复言。汝等莫作是语。何以故。僧不见汝羸弱轻易汝等。汝等自作恶行触恼众僧。可相远离舍是作恶触恼僧事。于佛法中增广得安乐住。如是谏坚持不舍。诸长老比丘尼诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若二比丘尼共作恶行有恶名声更相覆罪触恼众僧。诸比丘尼语言。汝二比丘尼莫共作恶行有恶名声更相覆罪触恼众僧。汝相远离舍是作恶触恼僧事。于佛法中增广得安乐住。二比丘尼言。我等不作恶行无恶名声不相覆罪不触恼僧。僧是我等羸弱。轻易我故作如是语。诸比丘尼复言。莫作是语。何以故。僧不见汝羸弱轻易汝等。汝等可相远离舍是作恶触恼僧事。于佛法中增广得安乐住。如是谏坚持不舍。应第二第三谏。第二第三谏。舍是事善。不舍者是比丘尼三谏。犯僧伽婆尸沙可悔过。余如上说。式叉摩那沙弥尼突吉罗

尔时阐陀母名修摩那。为人恶性。时人遂号为旃荼修摩那。好共他斗。僧断其事。便言僧随爱恚痴畏。诸比丘尼语言。汝莫好共他斗。莫作是语。僧随爱恚痴畏。何以故。僧不随爱恚痴畏。汝舍是语。于佛法中增广得安乐住。如是谏坚持不舍。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼好共他斗。僧断其事。便言僧随爱恚痴畏。诸比丘尼语言。汝莫好共他斗。莫作是语。僧随爱恚痴畏。何以故。僧不随爱恚痴畏。汝等舍是语。于佛法中增广得安乐住。如是谏坚持不舍。应第二第三谏。第二第三谏。舍是事善。不舍者是比丘尼三谏。犯僧伽婆尸沙可悔过。余如上说

尔时旃荼修摩那比丘尼好共他斗。僧断其事。便嗔恚言。我舍佛舍法舍僧舍戒作外道。余沙门婆罗门亦学戒亦惭愧。我当于彼净修梵行。诸比丘尼语言。汝莫好共他斗。莫作是语。我舍佛乃至于彼净修梵行。何以故。余沙门婆罗门无学戒无惭愧。汝云何于彼得修梵行。汝舍是恶见。于佛法中增广得安乐住。如是谏坚持不舍。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼好共他斗。僧断其事。便言我舍佛舍法舍僧舍戒作外道。余沙门婆罗门亦学戒亦惭愧。我当于彼净修梵行。诸比丘尼语言。汝莫好共他斗。莫作是语。我舍佛法僧。何以故。余沙门婆罗门无学戒无惭愧。汝云何于彼得修梵行。汝舍是恶见。于佛法中增广得安乐住。如是谏坚持不舍。应第二第三谏。第二第三谏。舍是事善。不舍者是比丘尼三谏已。犯僧伽婆尸沙可悔过。余如上说(僧残竟)

五分律卷第十一五分律卷第十二(弥沙塞)

        宋罽宾三藏佛陀什共竺道生等译

    第二分之三尼律舍堕法

佛在舍卫城。尔时优波离问佛。世尊已为诸比丘结戒。若比丘三衣竟舍迦絺那衣已长衣乃至十日。若过尼萨耆波逸提。乃至若比丘自捉金银及钱若使人捉若发心受尼萨耆波逸提。我当云何持。佛言。应作二部僧持。从今是戒应如是说

若比丘尼三衣竟舍迦絺那衣已长衣乃至十日若过尼萨耆波逸提。若比丘尼衣竟舍迦絺那衣已五衣中若离一一衣宿过一夜除僧羯磨尼萨耆波逸提。若比丘尼衣竟舍迦絺那衣已得非时衣。若须应受速作受持。若足者善。若不足望更有得处令具足成乃至一月。若过尼萨耆波逸提。若比丘尼从非亲里居士居士妇乞衣除因缘尼萨耆波逸提。因缘者。夺衣失衣烧衣漂衣衣坏。是名因缘。若比丘尼夺衣失衣烧衣漂衣衣坏。从非亲里居士居士妇乞衣。若居士居士妇欲多与衣。是比丘尼应受二衣。若过是受尼萨耆波逸提。若非亲里居士居士妇共议。当以如是衣直作衣与某甲比丘尼。是比丘尼先不自恣请。便往问居士居士妇言。汝为我以如是衣直作衣不。答言如是。便言善哉。居士居士妇。可作如是如是衣与我。为好故尼萨耆波逸提。若非亲里居士居士妇共议。我当各以如是衣直作衣与某甲比丘尼。是比丘尼先不自恣请。便往问居士居士妇言。汝各为我以如是衣直作衣不。答言如是。便言善哉。居士居士妇。可合作一衣与我。为好故尼萨耆波逸提。若王若大臣婆罗门居士。为比丘尼故遣使送衣直。使到比丘尼所言。阿姨。彼王大臣送此衣直。阿姨受之。是比丘尼言。我不应受衣直。若得净衣当手受持。使言。阿姨。有执事人不。比丘尼即指示处。使便到执事所语言。某王大臣送此衣直与某甲比丘尼。汝为受作。取便与之。使既与已。还比丘尼所白言。阿姨。所示执事人。我已与竟。阿姨须衣便可往取。是比丘尼二反三反到执事所作是言。我须衣。我须衣。若得者善。若不得四反五反六反到执事前默然立。若得者善。若过是求得者尼萨耆波逸提。若不得衣。应随使来处若自往若遣信语言。汝为某甲比丘尼送衣直。是比丘尼竟不得。汝自还索莫使失。是事应尔。若比丘尼自行乞缕雇织师织作衣尼萨耆波逸提。若居士居士妇为比丘尼使织师织作衣。是比丘尼先不自恣请。便到织师所作是言。汝知不。此衣为我作。汝为我好织令极致广。当别相报。后若与一食若一食直。得者尼萨耆波逸提。若比丘尼与比丘尼衣。后嗔不喜。若自夺。若使人夺。作是语。还我衣不与汝尼萨耆波逸提。若比丘尼知檀越欲与僧物。回以入己尼萨耆波逸提。若比丘尼病得服四种含消药酥油蜜石蜜。一受乃至七日。若过尼萨耆波逸提。若比丘尼前后安居十日未至自恣。得急施衣若须应受乃至衣时。若过尼萨耆波逸提。若比丘尼钵未满五缀。更乞新钵为好故尼萨耆波逸提。若比丘尼种种贩卖求利尼萨耆波逸提。若比丘尼以金银及钱种种卖买尼萨耆波逸提。若比丘尼自捉金银及钱若使人捉若发心受尼萨耆波逸提。(十八)

尔时偷罗难陀比丘尼从坐坫人乞钵。彼即买钵与之。既得便言。我不复须。可以酥见施。即复与之。卖所买钵。比坫人见语言。汝卖坫上物不得活耶。乃复作贩钵人为。答言。偷罗难陀从我乞钵。我买欲与。彼不复用。更从我乞酥。以酥与之故卖此钵耳。诸人言。乞人之法应随所乞取。何缘既得不取复索余物。此辈常说少欲知足。而今无厌。无沙门行破沙门法。诸长老比丘尼闻。种种诃责以事白佛。佛以是事集二部僧。问偷罗难陀比丘尼。汝实尔不。答言。实尔世尊。佛种种诃责已告诸比丘。今为诸比丘尼结戒。从今是戒应如是说。若比丘尼先乞是既得不用更乞余物尼萨耆波逸提。随更乞多少一一尼萨耆波逸提。式叉摩那沙弥尼突吉罗

尔时诸比丘尼非时衣作时衣受。诸客比丘尼便不能得衣。诸长老比丘尼见。种种诃责以事白佛。佛以是事集二部僧。问诸比丘尼。汝等实尔不。答言。实尔世尊。佛种种诃责已告诸比丘。今为诸比丘尼结戒。从今是戒应如是说。若比丘尼非时衣作时衣受尼萨耆波逸提。此衣应舍与僧。不应舍与一二三比丘尼。式叉摩那沙弥尼突吉罗

尔时有一下坐比丘尼少于知识。得未成衣不知作之。持至诸比丘尼所语言。我最下坐少于知识。愿为我作。诸比丘尼言。我事务多。不得为汝作。汝可至偷罗难陀所问之。彼多成衣。或与汝贸易。彼比丘尼即持往问偷罗难陀。便以成衣易之。彼比丘尼得已还到所住处。诸比丘尼问言。汝得衣不。答言得。又问从谁得。答言。偷罗难陀。诸比丘尼言。取来共看。便出衣示。诸比丘尼言。此衣胜汝衣数倍。由来无人能得彼利。汝今忽得甚为希有。时偷罗难陀隔壁闻。便语彼比丘尼。还我衣来不与汝贸。诸长老比丘尼闻。种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼。与比丘尼贸衣。后悔还索得者尼萨耆波逸提。式叉摩那沙弥尼突吉罗。若两悔若得衣。不如本要还取不犯

尔时毗舍佉母。请比丘尼僧与遮月水衣。遣信索身量。即皆与之。唯偷罗难陀不与。更遣信索。答言。我已离欲无复月水不须此衣。毗舍佉母作衣竟。遣信白诸比丘尼。衣已竟愿各来取。诸比丘尼皆往就坐。时偷罗难陀月水正出。便先取衣。诸比丘尼次第取之。衣少不足。下坐一人不得。毗舍佉母问。尽得衣不。答言。下坐一人不得。问何以故。答言。偷罗难陀先言不须。不付身量。今便先取。是以不足。毗舍佉母言。云何先言不须。临时便取令他不得。诸长老比丘尼种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼诸比丘尼语。汝取遮月水衣。自言不用临时先取尼萨耆波逸提。此衣应僧中舍。不得与一二三比丘尼。式叉摩那沙弥尼突吉罗。先虽言不用最后有长而取不犯

尔时偷罗难陀比丘尼。常出入波斯匿王宫内。王言。阿姨。若有所须就我取之。便语言。我须重衣。王言。就后宫取。即复言。我欲得王所著钦婆罗。王即与之。诸臣讥诃言。此比丘尼于无为法中出家着坏色割截衣。而今云何乃索王所著者。王虽无惜受者自应知量。此辈常说少欲知足。而今无厌。无沙门行破沙门法。时黑离车比丘尼。为毗舍离诸离车恭敬供养。诸人若有官事能为救解。莫不欢喜言我蒙阿姨恩得免罪厄。今有所须当以相奉。便言。我须重衣。复言。须几价重衣。答言。须千钱价衣。诸人便讥诃言。我曹官事虽复费用。五倍六倍不及此价。此辈常说少欲知足。而今无厌。诸长老比丘尼闻种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼乞重衣。应取贱价直四大钱者。若受贵价衣尼萨耆波逸提。重衣者寒时衣。式叉摩那沙弥尼突吉罗

尔时偷罗难陀比丘尼。复就波斯匿王索所著轻衣。黑离车比丘尼。从诸离车索五百钱价轻衣。诸臣诸人讥诃。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼乞轻衣。应取贱价直二大钱半者。若受贵价衣尼萨耆波逸提。轻衣者热时服。式叉摩那沙弥尼突吉罗

尔时差摩比丘尼到舍卫城在露地布萨。为风雨尘土蚊虻所恼。旧住比丘尼语一居士言。今比丘尼僧露地布萨。有如是如是恼。如佛所说。若施僧堂舍最为第一。善哉居士。可为僧作布萨堂。答言。我多事不得自作。今以此物付阿姨。可共断理作竟语我。我当自往施僧。诸比丘尼既得物已共作是议。我等衣服弊坏。可分此物各用作之。兼御露地布萨之恼。议已便分作衣。作衣竟语居士言。汝宜应欢喜。诸比丘尼衣服弊坏。汝所与物分用作衣。作衣已竟。居士闻已便讥诃言。我不欢喜。何以故。前云作布萨堂最为第一。而今云何持用作衣。诸长老比丘尼闻种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼为僧为是事。从一居士乞而余用者尼萨耆波逸提。若发心欲分及方便皆突吉罗。是物应舍与僧。不得舍与一二三比丘尼。式叉摩那沙弥尼突吉罗。若虽为是事乞檀越后自令作余用不犯

尔时差摩比丘尼露地布萨。乃至为蚊虻所恼如前说。诸比丘尼为作布萨堂故处处乞索。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼为僧为是事。从众多居士乞。而余用者尼萨耆波逸提。余如上说

尔时差摩比丘尼无住止处。诣一居士语言。我无住止处。为我作精舍。居士答如前便与物。得物已作是念。我衣粗弊坏。当用作之。住处自多。便用作衣。作衣竟往语居士。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼自为是事从一居士乞。自作余用者尼萨耆波逸提。余如上说

尔时差摩比丘尼无住止处。从众多居士乞。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼自为是事从众多居士乞。自作余用者尼萨耆波逸提。余如上说

尔时诸比丘尼多聚积器物。前后屋中处处皆有。遇火烧屋辇出诸物无有极已。诸白衣救火见问言。此是谁物。答是诸比丘尼物。便讥诃言。此辈大不吉利。于无为法中出家。着坏色割截衣。而聚积器物如王大臣。常说少欲知足。而今藏积无厌。无沙门行破沙门法。诸长老比丘尼闻种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼藏积器物尼萨耆波逸提。器物者。资生器物。唯听畜盛酥油蜜香药酱酢各一瓶。又听畜釜枪杓各一及一小瓮盛米食。过是畜尼萨耆波逸提。式叉摩那沙弥尼突吉罗

尔时诸比丘尼多聚积钵。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼多积聚钵尼萨耆波逸提。听畜七种粗钵。一以盛饮食。二以盛香。三以盛药。四以盛残食。五以除唾。六以除扫。七以除小便。式叉摩那沙弥尼突吉罗(舍堕竟)

    五分律第二分之四尼律堕法

佛在舍卫城。尔时优波离问佛。世尊已为诸比丘结戒。若比丘故妄语波逸提。乃至若比丘知檀越欲与僧物回与余人波逸提。我当云何持。佛言。应作二部僧持。从今是戒应如是说。若比丘尼故妄语波逸提。若比丘尼毁訾比丘尼波逸提。若比丘尼两舌斗乱比丘尼波逸提。若比丘尼为男子说法若过五六语。除有别知好恶语女人波逸提。若比丘尼知僧如法断事已。还更发起波逸提。若比丘尼教未受具戒女人经并诵波逸提。若比丘尼与未受具戒女人同室宿。过二夜波逸提。若比丘尼向未受具戒女人。自说得过人法。言我如是知如是见。实者波逸提。若比丘尼知比丘尼粗罪。向未受具戒女人说。除僧羯磨波逸提。若比丘尼作是语。何用是杂碎戒为。说是戒时令人忧恼。作如是毁訾戒者波逸提(十事竟)

若比丘尼自伐鬼村。若使人伐言伐是波逸提。若比丘尼故不随问答波逸提。若比丘尼诬说僧所差人波逸提。若比丘尼于露地自敷僧卧具。若使人敷若他敷若坐若卧。去时不自举不教人举不嘱举波逸提。若比丘尼于僧房内自敷僧卧具。若使人敷若他敷若坐若卧。去时不自举不教人举不嘱举波逸提。若比丘尼嗔不喜。于僧房中自牵比丘尼出若使人牵。作是语出去灭去莫此中住波逸提。若比丘尼知他先敷卧具。从来强自敷若使人敷作是念。若不乐者自当出去波逸提。若比丘尼僧重阁上尖脚绳床木床用力坐卧波逸提。若比丘尼知水有虫若取浇泥若饮食诸用波逸提。若比丘尼数数食除因缘波逸提。因缘者。病时衣时施衣时。是名因缘(二十竟)

若比丘尼受别请众食。除因缘波逸提。因缘者。病时衣时施衣时作衣时行路时船上行时大会时。是名因缘。若比丘尼无病施一食处。过一食者波逸提。若比丘尼到白衣家。自恣多与饮食若[麩-夫+并]若糗。若不住其家食。受二三钵应受出外。应与余比丘尼共食。若无病过是受及不与余比丘尼共食波逸提。若比丘尼食竟不作残食法食波逸提。若比丘尼知比丘尼食竟。不作残食法强劝令食。欲使他犯波逸提。若比丘尼不受食着口中。除尝食杨枝及水波逸提。若比丘尼非时食波逸提。若比丘尼食残宿食波逸提。若比丘尼食家中与男子屏处坐者波逸提。若比丘尼观军发行波逸提。(三十竟)

若比丘尼。有因缘到军中乃至二三宿若过波逸提。若比丘尼有因缘到军中二三宿观军阵合战波逸提。若比丘尼作是语。如我解佛所说。障道法不能障道。诸比丘尼语是比丘尼。汝莫作是语。莫谤佛莫诬佛。佛说障道法实能障道。汝舍是恶邪见。如是谏坚持不舍。应第二第三谏。第二第三谏。舍是事善。不舍者波逸提。若比丘尼知是比丘尼不如法悔不舍恶邪见。共语共坐共宿共事波逸提。若沙弥尼作是语。如我解佛所说。若受五欲不能障道。诸比丘尼语是沙弥尼。汝莫作是语。莫谤佛莫诬佛。佛说五欲障道实能障道。汝沙弥尼舍是恶邪见。如是教坚持不舍。应第二第三教。第二第三教舍是事善。若不舍诸比丘尼应语是沙弥尼。汝出去从今莫言佛是我师。莫在诸比丘尼后行。如余沙弥尼得共诸比丘尼二宿。汝亦无是事。痴人出去灭去。莫此中住。若比丘尼知如法摈沙弥尼。畜使共住共语波逸提。若比丘尼故令比丘尼生疑悔作是念。令是比丘尼乃至少时恼波逸提。若比丘尼僧断事时不与欲起去波逸提。若比丘尼击擽比丘尼波逸提。若比丘尼水中戏波逸提。若比丘尼与男子同室宿波逸提。(四十竟)

若比丘尼饮酒波逸提若比丘尼轻师波逸提。若比丘尼自掘地若使人掘言掘是波逸提。若比丘尼共诤已默听作是念。诸比丘尼所说我当忆持波逸提。若比丘尼受四月自恣请。过是受除更请自送请及长请波逸提。若比丘尼数数犯罪。诸比丘尼如法谏。作是语我不学是戒。当问余比丘尼持法持律者波逸提。若比丘尼说戒时。作是语我今始知是法半月布萨戒经中说。诸比丘尼知是比丘尼已再三说戒中坐。是比丘尼不以不知故得脱。随所犯罪如法治。应诃其不知。汝所作不善。说戒时不一心听。不着心中波逸提。若比丘尼与贼期共道行从此聚落到彼聚落波逸提。若比丘尼与男子期共道行从此聚落到彼聚落波逸提。若比丘尼无病为炙故自然火若使人然波逸提。(五十竟)

若比丘尼若宝若宝等物。若自取若使人取。除僧坊内及宿处波逸提。若僧坊内及宿处。取宝宝等物。后有主索应还。是事应尔。若比丘尼半月内浴。除因缘波逸提。因缘者。病时作时行路时风雨时热时。是名因缘。若比丘尼嗔故打比丘尼波逸提。若比丘尼嗔故以手拟比丘尼波逸提。若比丘尼故恐怖比丘尼波逸提。若比丘尼以无根僧伽婆尸沙谤比丘尼波逸提。若比丘尼语彼比丘尼。共到诸家与汝多美饮食。既到不与作是语。汝去共汝若坐若语不乐。我独坐独语乐。欲令恼故波逸提。若比丘尼新得衣应三种色作帜。若青若黑若木兰。若不以三色作帜波逸提。若比丘尼为戏笑故。藏比丘尼若衣若钵若坐具针筒。如是一一生活具。若使人藏波逸提。若比丘尼僧断事时如法与欲竟。后更诃波逸提。(六十竟)

若比丘尼作是语。诸比丘尼随知识回僧物与波逸提。若比丘尼与比丘比丘尼式叉摩那沙弥沙弥尼净施衣强夺取波逸提。若比丘尼受他请。食前食后行到诸家。不近白余比丘尼。除因缘波逸提。因缘者。衣时是名因缘。若比丘尼以兜罗贮坐卧具波逸提。若比丘尼自作坐卧绳床木床。足应高修伽陀八指除入梐孔。若过波逸提。若比丘尼用骨牙角作针筒波逸提。若比丘尼作修伽陀衣量衣。若过波逸提。修伽陀衣量者。长九修伽陀搩手广六搩手。是名修伽陀衣量。若比丘尼知檀越欲与僧物。回与余人波逸提(六十八)

尔时诸比丘尼中前中后啖生熟蒜。若空啖若合食啖房舍臭处。诸居士来看闻蒜臭讥诃言。正似白衣家作食处。复有诸比丘尼至长者家。长者闻啖蒜臭。便语言。阿姨远去口中蒜臭。诸比丘尼羞耻。复有一卖蒜人。请诸比丘尼与蒜。以此致贫饮食不继。家人语言。若不能与我食放我令去。汝自长与比丘尼作奴。邻人闻之诃言。汝家自无食。何豫诸比丘尼。具以事答。有不信乐佛法者语言。由汝亲近比丘尼故致如此苦。若复亲近方当剧是。此等出家本求解脱。而今贪着美味。无沙门行破沙门法。诸长老比丘尼闻种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼啖蒜波逸提。若啖生蒜咽咽波逸提。啖熟蒜突吉罗。式叉摩那沙。弥尼突吉罗。若病时啖强力伏令啖不犯

尔时诸比丘尼以手拍女根生爱欲心。遂有反俗作外道者。偷罗难陀亦以手拍女根。女根大肿不能复行。弟子为到常供养家云。师病为索食。彼即与之。其家妇女寻来问讯言。阿姨何所患苦。答言我病。又问是何等病。同是女人。何以不道。便具以事答。于是诸女讥诃言。此等常毁訾欲欲想欲热欲觉。而今作如此事。何不罢道受五欲乐。无沙门行破沙门法。诸长老比丘尼闻种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼以手拍女根波逸提。若以手拍拍拍波逸提。出不净偷罗遮。式叉摩那沙弥尼突吉罗(七十竟)

尔时诸比丘尼用胡胶作男根内女根中生爱欲心。遂有反俗作外道者。复有一比丘尼作系着脚根内女根中。时一式叉摩那煎油失火烧屋。彼比丘尼惶怖忘解着脚出外。诸救火人见问言。阿姨脚边何等。具以实答。即便讥诃。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼作男根内女根中波逸提。出不净偷罗遮。式叉摩那沙弥尼突吉罗

尔时诸比丘尼或以一指乃至五指内女根中洗。伤肉血出以此致病。诸长老比丘尼见种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼以水洗女根波逸提。佛既不听洗。便臭秽不净热时生虫。波阇波提比丘尼。与五百比丘尼俱至佛所。白佛言。世尊。我等女人形体臭秽。正赖水洗愿见听许。佛告诸比丘。今听诸比丘尼以水作净。佛既听已复如前法。诸比丘尼见种种诃责。乃至告诸比丘。亦如上说。从今是戒应如是说。若比丘尼以水洗女根。应用二指齐一节。若过波逸提。式叉摩那沙弥尼突吉罗。若根内生疮。若有虫入。若草石入。用指过一节不犯

尔时诸比丘尼剃二处毛。腋下隐处。生爱欲心。遂有反俗作外道者。时偷罗难陀亦自剃隐处毛。其主人家嫁女。女欲见之。便遣信呼。比丘尼即往。时家为女作浴。女言。先使比丘尼浴。即呼令浴。答言。我不须浴。诸女人便强脱衣令浴。因见其剃隐处毛。即问阿姨何故剃此。便反问言。汝等何以剃之。诸女言。我为男子故。比丘尼言。我亦如是。诸女便讥诃言。此等常毁訾欲。而今作如是事不修梵行。何不还俗自恣五欲。无沙门行破沙门法。诸长老比丘尼闻种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼剃腋下隐处毛波逸提。若剃刀刀波逸提。式叉摩那沙弥尼突吉罗。若为生疮须剃。若人强捉剃皆不犯

尔时诸比丘尼与比丘。独屏处共立共语生染着心。遂有反俗作外道者。诸白衣见作是言。此比丘比丘尼独屏处共立共语必说淫欲事。无沙门行破沙门法。诸长老比丘尼见闻种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼与比丘。独屏处共立共语波逸提。式叉摩那沙弥尼突吉罗。若众多比丘尼一比丘若八难时不犯

尔时诸比丘尼与白衣及外道。独屏处共立共语。致使摩触身体说粗恶淫欲语或强逼作淫欲事。诸长老比丘尼见种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼与白衣及外道独屏处共立共语波逸提。余如上说

尔时诸比丘尼与比丘。独露处共立共语生染着心。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼与比丘独露处共立共语波逸提。余如上说

尔时诸比丘尼与白衣及外道。独露处共立共语。致使摩触身体。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼与白衣及外道独露处共立共语波逸提。余如上说

尔时诸比丘尼与比丘。独街巷中共立耳语。遣伴比丘尼令远去。诸居士讥诃。长老比丘尼闻种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼与比丘。独街巷中共立耳语。遣伴比丘尼令远去波逸提。余如上说

尔时诸比丘尼与白衣及外道。独街巷中共立耳语。遣伴比丘尼令远去。居士见讥诃。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼与白衣及外道。独街巷中共立耳语。遣伴比丘尼令远去波逸提。余如上说

尔时诸比丘尼裸形洗浴。诸白衣见围绕调笑。诸长老比丘尼闻种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼裸形洗浴波逸提。式叉摩那沙弥尼突吉罗。若遮人不使来。若屏处浴。若树若衣物障。皆不犯(八十)

尔时诸比丘尼离水浴衣行。不知着何物浴。诸长老比丘尼见种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼离水浴衣行波逸提。式叉摩那沙弥尼突吉罗。若染浣打若火烧水漂及坏不犯

尔时旃荼修摩那比丘尼弟子。独得五新衣。白和尚言。为我先着使我获福。和尚既着便不复还。弟子着粗弊衣行。诸比丘尼见问言。汝独得五新衣。何故不着。答言。我先用供养和尚。和尚不复见还。诸比丘尼诃责旃茶修摩那。云何弟子得新衣。先以供养。便不复还。诸长老比丘尼以事白佛。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼得新衣先以供养便不复还波逸提。若比丘尼得新衣供养彼比丘尼。彼比丘尼应一日着。若令更着复应为着。随主意久近。若过限波逸提。式叉摩那沙弥尼突吉罗

尔时有比丘尼遮僧分衣。余比丘尼待之妨坐禅行道。诸长老比丘尼诃责。云何比丘尼遮僧分衣。种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼遮僧分衣波逸提。式叉摩那沙弥尼突吉罗。若病不得往若不闻不犯

尔时有一下坐比丘尼得未成衣。少知识自不知作。持至偷罗难陀比丘尼所求作。答言我多事不得为汝作。复持至余比丘尼所。余比丘尼为作作成。偷罗难陀问言。谁为汝作。取来看。为如法不。即以示之。便言。此衣不如法可速撤坏。我更为汝作。彼即撤坏持往。便不为作。彼比丘尼不能得成。着粗弊衣行。所坏衣叚晒于屋上。尔时失火为火所烧。风吹堕白衣屋上延烧诸家。白衣见火从比丘尼住处来。便嗔诃言。我等供养此比丘尼反成怨家。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼自撤比丘尼衣若使人撤。不还缝成波逸提。复有比丘尼撤比丘尼衣。一日不得成。四五日乃竟。以事白佛。佛以是事集二部僧。告诸比丘。今听诸比丘尼撤衣四五日成。从今是戒应如是说。若比丘尼撤比丘尼衣若使人撤。过四五日不成波逸提。复有比丘尼撤比丘尼衣。得病不能成。以是白佛。佛以是事集二部僧。告诸比丘。今听诸比丘尼撤他衣已病不得成。从今是戒应如是说。若比丘尼撤比丘尼衣已。无病过四五日不成波逸提。式叉摩那沙弥尼突吉罗

尔时诸比丘尼离五衣着粗弊衣至诸家。诸长老比丘尼见种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼离五衣行波逸提。离五衣者。从一家至一家乃至出所住门波逸提。式叉摩那沙弥尼突吉罗。若浣染打缝时不犯

尔时诸比丘尼。以比丘尼衣与白衣及外道女。彼便着行。余白衣见向作礼。彼言。我是白衣。我是外道。诸白衣便讥诃言。云何比丘尼。以比丘尼衣与白衣及外道女。诸长老比丘尼闻种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼以比丘尼衣与白衣及外道女波逸提。比丘尼衣者。有叶有缘有帖。式叉摩那沙弥尼突吉罗。彼有比丘尼衣。从贸易若负债用偿。皆不犯

尔时差摩比丘尼欲来舍卫城。旃茶修摩那比丘尼闻其欲来。便到其主人家语言差摩比丘尼当来。可为少多设供。答言。我亦闻其当来乃欲自竭办美饮食及以衣施。彼比丘尼便言。何不以衣施僧。僧中有正趣正行人。无所不摄。何用施一比丘尼为。主人闻已即转施僧。差摩比丘尼到。为设多美饮食。手自斟酌。食竟窃语。今正是施衣时。而旃荼修摩那比丘尼断我此事。诸比丘尼问。汝等何所说。具以事答。长老比丘尼种种诃责。云何断施人物与僧。种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼断施人物与僧波逸提。施人者。于僧中别有所与。名为施人。式叉摩那沙弥尼突吉罗

尔时差摩比丘尼到舍卫城。旃茶修摩那比丘尼语言。我当嘱主人令看视汝。差摩言。不须汝嘱。旃荼修摩那复言。汝受我嘱既得利养又福度彼。于是差摩默然许之。彼即将到诸家。差摩比丘尼有大眷属。行慈心三昧莫不宗敬。无复供养旃荼修摩那比丘尼。便生嫉妒心言。我嘱诸家令彼多得供养。而彼反更道说我恶使我不复得食。诸比丘尼种种诃责言。云何比丘尼护惜他家。诸长老比丘尼闻种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼护惜他家波逸提。护惜他家者。欲使他家供养己不供养余人。式叉摩那沙弥尼突吉罗

五分律卷第十二五分律卷第十三(弥沙塞)

        宋罽宾三藏佛陀什共竺道生等译

    第二分之四第八十九事

尔时诸比丘尼不安居游行人间。或遇八月贼。或遇水火诸难。诸长老比丘尼见种种诃责。云何名比丘尼不夏安居。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼不安居波逸提。安居者。前后安居。若无缘事待后安居突吉罗。式叉摩那沙弥尼突吉罗。若八难起不犯(九十)

尔时诸比丘尼于无比丘众处安居。便有诸疑可应度不可应度。可与受戒不可与受戒。作衣如法不如法。于戒中有如是等种种疑。不知问谁。又为恶人外道之所轻陵。诸长老比丘尼见种种诃责。以事白佛。佛以是事集二部僧。问诸比丘尼。汝等实尔不。答言。实尔世尊。佛种种诃责言。我先不说八敬法比丘尼应依比丘众安居耶。诃已告诸比丘。今为诸比丘尼结戒。从今是戒应如是说。若比丘尼不依比丘众安居波逸提。虽依比丘众而无教诫者突吉罗。式叉摩那沙弥尼突吉罗。若安居中比丘众移去死亡罢道。若为强力所制。若病皆不犯。尔时诸比丘尼虽安居。于中游行遇贼火诸难。诸长老比丘尼见种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼于安居内游行波逸提。游行者。若从一聚落至一聚落。若无聚落半由旬波逸提。式叉摩那沙弥尼突吉罗。若八难起不犯

尔时诸比丘尼安居竟。不于比丘僧中请见闻疑罪。无人教诫愚无所知不能学戒。诸长老比丘尼种种诃责。以事白佛。佛以是事集二部僧。问诸比丘尼。汝等实尔不。答言。实尔世尊。佛种种诃责言。我先不说八敬法比丘尼安居竟应从比丘众请见闻疑罪耶。诃已告诸比丘。今为诸比丘尼结戒。从今是戒应如是说。若比丘尼安居竟。不从比丘僧请见闻疑罪波逸提。若僧不和集若八难时不犯

尔时诸长者。请差摩比丘尼于舍卫城安居。作是言。若受我请当随时供给。便受其请。遂长住不复余行。彼诸长者讥诃言。我等应作余事。诸比丘尼不知筹量不复知去。此等常说少欲知足。而今无厌。诸长老比丘尼闻种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼就安居请竟一宿不去波逸提。式叉摩那沙弥尼突吉罗。若病若恐怖若不齐限请若非受请处安居不去不犯

尔时诸比丘尼于国内恐怖处行。无救护者。为恶人剥夺。诸长老比丘尼见种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼于国内恐怖处无所依怙而独行者波逸提。虽众多比丘尼共行。而无白衣强伴。名为独行。从一聚落至一聚落。若无聚落行半由旬波逸提。式叉摩那沙弥尼突吉罗。若急难叛走皆不犯

尔时诸比丘尼。出国境恐怖处行。亦无救护者。为恶人剥夺。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼出国境恐怖处无所依怙而独行者波逸提。余如上说

尔时诸比丘尼。在毗舍佉母所作精舍安居竟。无所嘱付空寺出行。于后火起。有人见之。语毗舍佉母言。汝所作比丘尼精舍为火所烧。彼便遣奴婢往救。得不烧尽。诸比丘尼后还。毗舍佉母问言。阿姨汝不失物不。答言。我失如是如是物。遂过长说所失物。毗舍佉母诃责言。云何在我精舍安居。不付嘱而去致使火烧。而复过长说所失物。诸长老比丘尼闻种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼安居竟不付嘱精舍出行者波逸提。若不付嘱行一脚出门突吉罗。两脚出门波逸提。式叉摩那沙弥尼突吉罗。若更有比丘比丘尼来住。若无人可付嘱不犯

尔时诸比丘尼在毗舍佉母精舍安居竟。不舍精舍还主而去。于后火起有人见之。语毗舍佉母言。汝所作比丘尼精舍为火所烧。毗舍佉母言。置使烧尽。先诸比丘尼不付嘱出行致使失火。后还复过长说所失物贻我恶名。彼比丘尼后复还来。毗舍佉母问言。阿姨去时留物精舍中不。答言无。便诃责言。云何去不还我精舍致使烧尽。若语我者。自当守护不使致此。诸长老比丘尼闻种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼安居竟。不舍精舍还主去者波逸提。余如上说

尔时诸比丘尼。看王宫殿及看画舍。又游观诸嬉戏处到华池上。彼处多人聚看。比丘尼语诸男子言。汝可小避莫逼近我。诸男子言。不吉利人剃头着割截衣不应来此。而来此者。是欲求男子。云何使我避去。便捉牵曳作粗恶淫欲语。诸长老比丘尼闻种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼种种游看波逸提。发心及方便突吉罗。若发行步步波逸提。式叉摩那沙弥尼突吉罗。不为看戏往皆不犯

尔时诸比丘尼半月布萨。不来比丘僧中乞教诫师。以无人教诫故。愚闇无知不能学戒诸长老比丘尼见种种呵责。以事白佛。佛以是事集二部僧。问诸比丘尼。汝等实尔不。答言。实尔世尊。佛种种诃责诸比丘尼。我先不说八敬法教汝等半月乞教诫师耶。诃责已告诸比丘。今为诸比丘尼结戒。从今是戒应如是说。若比丘尼半月不于僧中乞教诫师波逸提。式叉摩那沙弥尼不求教诫悔过突吉罗。若请不得若病不犯(一百)

尔时差摩比丘尼命过。诸比丘尼于比丘僧坊中为起骨塔。其眷属日三反围绕啼哭言。施我法者。施我衣食床卧具医药者。如何一旦舍我长逝。诸比丘厌患妨废坐禅行道。时优波离来入僧坊。问旧住比丘。此是何声。具以事答。优波离即使人坏之。诸比丘尼闻。共作是议。我等皆当持杖打彼比丘。若不同往不复共住。议已皆执杖诣僧坊。见比丘便围绕欲打。知非乃止。进前于狭路逢优波离。前后共遮举杖欲打。优波离即以神力飞到佛所。以事白佛。佛以是事集二部僧。问诸比丘尼。汝等实尔不。答言。实尔世尊。佛种种诃责比丘尼言。汝等所作非法。云何比丘尼打比丘。诃责已告诸比丘。今为诸比丘尼结戒。从今是戒应如是说。若比丘尼入比丘住处波逸提。有诸比丘尼行路见空僧坊欲入礼拜而不敢入。以事白佛。佛以是事集二部僧。告诸比丘。今听比丘尼入空僧坊。从今是戒应如是说。若比丘尼入有比丘住处波逸提。有诸比丘尼。于僧坊内有因缘事须入而不敢入。以事白佛。佛以是事集二部僧。告诸比丘。今听比丘尼有缘事须入僧坊白比丘。比丘听然后入。从今是戒应如是说。若比丘尼入有比丘住处不白比丘波逸提。有诸比丘尼有缘事欲入僧坊。诸比丘或坐禅或眠不能得白。以事白佛。佛以是事集二部僧。告诸比丘。今听诸比丘尼进入坊内见比丘便白。从今是戒应如是说。若比丘尼入有比丘住处见比丘不白波逸提。有诸比丘尼急难时欲避难入僧坊而不敢入。或为贼所夺。或为恶兽所害。以事白佛。佛以是事集二部僧。告诸比丘。今听比丘尼若急难时随意入僧坊。从今是戒应如是说。若比丘尼入有比丘住处见比丘不白。除急难时波逸提。若不见比丘不得白而入。须见比丘便往白。彼比丘应筹量。若可入时应听入。若不可入时不应听入。见而不白及不听而入波逸提。式叉摩那沙弥尼突吉罗

尔时诸比丘尼未满十二岁畜眷属。不能教诫不能摄取。弟子愚闇无知不能学戒。诸长老比丘尼见种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼不满十二岁畜眷属波逸提。不满十二岁者受戒。未满十二岁畜眷属者。为人作和尚。若发心欲畜众至白四羯磨未竟突吉罗。白四羯磨竟和尚波逸提。余尼师僧突吉罗

尔时诸比丘尼虽满十二岁。而聋盲喑哑种种诸病。无所知而畜弟子。不能教诫不能摄取。弟子愚闇无知不能学戒。诸长老比丘尼见种种诃责。以事白佛。佛以是事集二部僧。问诸比丘尼。汝等实尔不。答言。实尔世尊。佛种种诃责言。云何比丘尼盲聋喑哑种种诸病。而畜弟子。不能教诫不能摄取。使弟子愚闇无知不能学戒。诃已告诸比丘。今听诸比丘尼白二羯磨畜众。彼比丘尼。应到比丘尼僧中脱革屣偏袒右肩胡跪合掌白言。阿姨僧听。我某甲比丘尼已满十二岁欲畜众。从僧乞畜众羯磨。善哉僧。与我作畜众羯磨。如是三乞。诸比丘尼应筹量观察。此比丘尼堪畜众不。若不堪不应与作畜众羯磨。若堪应与作。应一比丘尼若上座若上座等知法知律者唱言。阿姨僧听。此某甲比丘尼已满十二岁欲畜某甲为众。从僧乞畜众羯磨。僧今与作畜众羯磨。若僧时到僧忍听。白如是。阿姨僧听。此某甲比丘尼已满十二岁欲畜某甲为众。从僧乞畜众羯磨。僧今与作畜众羯磨。谁诸阿姨忍者默然。若不忍者便说。僧已与某甲比丘尼作畜众羯磨竟。僧忍默然故。是事如是持。今为诸比丘尼结戒。从今是戒应如是说。若比丘尼满十二岁。僧不与作畜众羯磨畜众者波逸提。余如上说

尔时诸比丘尼与未满十二岁已嫁女受具足戒。愚闇无知不堪学戒。诸长老比丘尼见种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼与未满十二岁已嫁女受具足戒波逸提。未满十二岁者。虽已嫁而未满十二岁。嫁者已经男子。余如上畜眷属中说

尔时诸比丘尼虽满十二岁已嫁女。而女聋哑种种诸病与受具足戒。愚痴无知不能学戒。诸长老比丘尼见种种诃责。乃至今听诸比丘尼白四羯磨与满十二岁已嫁女受具足戒。彼欲受具足戒人。应到比丘尼僧中白言。阿姨僧听。我某甲已嫁满十二岁。求某甲和尚受具足戒。今从僧乞受具足戒。善哉僧。与我受具足戒。怜愍故。如是三乞已。诸比丘尼应筹量可与受不可与受。应一比丘尼羯磨依如上说。告诸比丘。今为诸比丘尼结戒。从今是戒应如是说。若比丘尼满十二岁已嫁女。僧不作羯磨与受具足戒波逸提。余如畜眷属中说

尔时诸比丘尼与未满十八岁童女受学戒。愚闇无知不堪学戒。诸长老比丘尼见种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼与未满十八岁童女受学戒波逸提。童女者。未经男子。发心及方便乃至白二羯磨未满突吉罗。白二羯磨波逸提。余师众皆突吉罗

尔时诸比丘尼虽满十八岁童女。而女聋哑种种诸病与受学戒。乃至今听诸比丘尼白二羯磨与满十八岁童女受二岁学戒。欲受学戒人应到比丘尼僧中白言。阿姨僧听。我某甲和尚某甲。今从僧乞二岁学戒。善哉阿姨僧。与我受二岁学戒。怜愍故。如是三乞已。诸比丘尼应善筹量可与受不可与受。应一比丘尼羯磨依如上说。告诸比丘。今为诸比丘尼结戒。今从是戒应如是说。若比丘尼虽满十八岁童女。僧不作羯磨与受学戒波逸提。余如上说

尔时偷罗难陀比丘尼主人妇求欲出家。偷罗难陀言。汝先与我衣我当度汝。主人妇便诃责言。我是主人。云何先索我衣然后见度。不欲度我生老病死反利我衣。此等无沙门行破沙门法。诸长老比丘尼闻种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼语白衣妇女。先与我衣我当度汝波逸提。若比丘尼语式叉摩那沙弥尼突吉罗。若彼负债债偿然后度不犯

尔时偷罗难陀比丘尼。语诸比丘尼言。与我作畜众羯磨。诸比丘尼言。如佛所说应与作畜众羯磨者。汝无是事。不得与汝作畜众羯磨。彼比丘尼便言。诸比丘尼随爱恚痴畏。畏者便与作。不畏者便不与作。诸长老比丘尼闻种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼。诸比丘尼语言。如佛所说应与作畜众羯磨汝无是事。便诃诸比丘尼者波逸提

尔时诸比丘尼。教诫时不往听。羯磨时亦不往听。便愚闇无知不能学戒。诸长老比丘尼种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼教诫及羯磨时不往听波逸提。教诫者。说八敬等法。羯磨者。白羯磨白二白四羯磨(一百一十)

尔时诸比丘尼有学戒尼。满二岁不与受具足戒。彼后时得重病。聋盲喑哑种种诸病。遮受戒法。差摩比丘尼弟子学戒满二岁。亦不与受具足戒。语言。汝且学是戒。彼后时得白癞病。不知云何。诸长老比丘尼种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼。式叉摩那满二岁无难。不与受具足戒。语言。汝且学是戒波逸提

尔时诸比丘尼度淫女不受教诫。譬如窈领牛不堪驾车若驾车时但欲出辕。诸长老比丘尼种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼度淫女波逸提。发心乃至白四羯磨未竟突吉罗。白四羯磨竟。和尚波逸提。余尼师众突吉罗。彼厌恶女身度之不犯

尔时诸比丘尼与未满二岁学戒尼受具足戒。彼愚闇无知不能学戒。诸长老比丘尼见种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼与未满二岁学戒尼。受具足戒波逸提。余如畜眷属中说

尔时诸比丘尼虽满二岁学戒尼。而聋盲喑哑种种诸病与受具足戒。诸长老比丘尼见种种诃责。乃至今为诸比丘尼结戒。亦如上说。满十二岁已嫁女中说。从今是戒应如是说。若比丘尼满二岁学戒尼。僧不作羯磨与受具足戒波逸提。余如畜眷属中说

尔时诸比丘尼与满二岁学戒尼不学戒者受具足戒。愚闇无知不能学戒。诸长老比丘尼种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼与满二岁学戒尼不学戒者受具足戒波逸提。余如畜眷属中说

尔时诸比丘尼与怀妊女受具足戒入村乞食。诸白衣见戏弄言。此比丘尼担重担应速与食。或有言且观其腹。或有言此等不修梵行。或有言此修梵行是未出家时事。便诃责诸比丘尼言。何不待产竟然后出家。以此毁辱梵行。诸比丘尼不知可度不可度。无沙门行破沙门法。诸长老比丘尼闻种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼与怀妊女受具足戒波逸提。发心乃至白四羯磨竟。皆如上说。若欲与受具足戒应先看乳。若无儿相不犯。若受戒竟方知怀妊亦不犯

尔时诸比丘尼与新产妇受具足戒。一手捉钵一手抱儿行乞食。诸白衣见戏弄言。速与二人食。诸白衣讥嫌诃责。长老诸比丘尼种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼与新产妇受具足戒波逸提。余如上畜眷属中说

尔时诸比丘尼。年年与弟子受具足戒。弟子众多不能一一教诫。愚闇无知不能学戒。诸长老比丘尼见种种呵责乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼年年与弟子受具足戒波逸提。比丘尼隔一年得与一弟子受具足戒。余如畜眷属中说

尔时诸比丘尼。于比丘尼僧中授弟子具足戒。经宿然后就比丘僧受戒。受戒人于一宿中得遮受戒。病比丘僧不复与受。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼异宿与弟子受具足戒波逸提。从发心乃至明相未出突吉罗。明相出。和尚波逸提。余师僧突吉罗。若僧不和集及八难起不犯

尔时诸比丘尼新受戒。不依承和尚无人教诫故。愚无所知不能学戒。诸长老比丘尼见种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼新受具足戒。不六年依承和尚。若使人依承者波逸提。式叉摩那沙弥尼突吉罗。若和尚不须依承者不犯(一百二十)

尔时诸比丘尼。与弟子受具足戒已。不摄取不教诫不教诵习。愚闇无知不能学戒。诸长老比丘尼见种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼畜弟子六年中。不自摄取不教人摄取波逸提。若弟子不受教不犯

尔时诸比丘尼。与弟子受具足戒。不将离其本处。先知识男子见生染着心。便调弄共作粗恶淫欲语。诸长老比丘尼见种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼畜弟子不自将不使人将离本处五六由旬波逸提。本处者。若生处若嫁处。若弟子不从者不犯

尔时诸比丘尼。同学病不看视故。或不时差或至命过。诸长老比丘尼见种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼同学病。不自看不教人看波逸提。同学者。同和尚阿阇梨及常共伴。式叉摩那沙弥尼突吉罗。若住止不同不犯

尔时诸比丘尼度属人妇女。诸白衣讥诃言。此诸比丘尼无可度不可度者。诸居士有言。应夺取衣钵将付官者。有言波斯匿王有令。若轻陵比丘尼者当与重罪。应速放去莫令人闻。皆言此等无沙门行破沙门法。诸长老比丘尼闻种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼度属人妇女波逸提。属人者。若属官若余人。发心乃至白四羯磨竟亦如上说。若主听不犯

尔时诸比丘尼度长病女人。不堪学戒愚闇无知。诸长老比丘尼见种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼度长病女人波逸提。长病者。长患寒热发作有常。发心乃至白四羯磨竟亦如上说。若受戒后得此病不犯

尔时诸比丘尼度属夫妇人。白衣讥诃或欲夺衣或欲放遣乃至今为诸比丘尼结戒。皆如属人妇女中说。从今是戒应如是说。若比丘尼度属夫妇人波逸提。发心乃至白四羯磨竟亦如上说

尔时诸比丘尼度负债女人。乃至今为诸比丘尼结戒。皆如上度属人妇女中说。从今是戒应如是说。若比丘尼度负债女人波逸提。发心乃至白四羯磨竟亦如上说。若言出家竟然后还债。度此人不犯

尔时诸比丘尼。于闇处与男子共立共语。生染着心不乐修梵行。致有反俗作外道者。诸长老比丘尼闻种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼与男子闇处共立共语波逸提。若闇处语。语语波逸提。式叉摩那沙弥尼突吉罗。若疑怖处若灯卒灭不犯

尔时诸比丘尼随所知识家辄坐其床。诸白衣讥呵言。不喜见此不吉利物。不知可坐不可坐。无有风法。诸长老比丘尼闻种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼不语主人辄坐其床波逸提。式叉摩那沙弥尼突吉罗。若主人教坐不犯

尔时诸比丘尼。自手与白衣及外道男子食。彼作是念。此比丘尼必以染着心与我食。便调弄说粗恶淫欲语。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼自手与白衣及外道男子食波逸提。式叉摩那沙弥尼突吉罗。若不自手与。及自手与亲里。皆不犯(一百三十)

尔时诸比丘尼。向诸白衣说诸比丘过失言。彼比丘破戒破威仪破见。诸比丘闻便嗔不复教诫。诸长老比丘尼闻种种诃责。以事白佛。佛以是事集二部僧。问诸比丘尼。汝等实尔不。答言实尔世尊。佛种种诃责言。我先不为汝说八敬法耶。种种诃责已告诸比丘。今为诸比丘尼结戒。从今是戒应如是说。若比丘尼向白衣说比丘过波逸提。式叉摩那沙弥尼突吉罗。若白衣先闻而问。应反问言。汝云何闻。若言我如是如是闻。诸比丘尼闻亦如是。然后以实答不犯

尔时旃茶修摩那比丘尼。与人斗诤已自椎自打大唤啼哭。诸长老比丘尼闻种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼与人斗已自打啼哭波逸提。若自椎自打。下下皆波逸提。式叉摩那沙弥尼突吉罗

尔时诸比丘尼。共遥指点旃茶修摩那说其斗事。便谓骂已。复大唤言。诸比丘尼骂我。诸比丘尼即往问言。我等作何等骂。汝便不知何道。诸长老比丘尼闻种种诃责言。云何比丘尼不谛了人语。而妄云骂已。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼不谛了人语妄嗔他波逸提。式叉摩那沙弥尼突吉罗

尔时诸比丘尼共诤。各作咒誓言。我若如是当堕地狱。如调达瞿伽梨受罪。我亦当尔。我若不如是。汝当受如是罪。诸长老比丘尼闻种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼自咒誓实以咒彼波逸提。作此咒誓。语语波逸提。式叉摩那沙弥尼突吉罗

尔时诸比丘尼。掷屎溺于篱墙外。污泥人及非人。时有婆罗门大臣。被冕斋洁清净。晨朝洗浴着香熏衣。欲至天祠求复其官。裹头行路恐见剃发割截衣人。至比丘尼墙外遇。值掷屎灌其头上。举体流漫。便大恚言。我畏见此不吉人。而今乃为掷屎所灌。必是我命不吉祥事。然我要当至波斯匿王所言杀秃婢。于是便还。逢一相师婆罗门。婆罗门问言。何故如此。俱以事答。相师言。乃是大吉。汝今当得金钱一千复本官位。犹嗔不已。持此屎污之形。迳诣王所。王问。何故如此。即具以事答。王拍手大笑。即敕赐金钱一千复先官位。王诸傍臣便讥诃言。掷屎污人。岂是求道济物之意。诸长老比丘尼闻种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼掷屎溺于篱墙外若使人掷波逸提。式叉摩那沙弥尼突吉罗

尔时诸比丘尼。掷粪扫及残食于篱墙外。污泥人及非人。诸白衣见讥诃言。云何比丘尼隔墙掷粪扫污泥于人。此等无有法则。诸长老比丘尼闻种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼掷粪扫及残食于篱墙外若使人掷波逸提。式叉摩那沙弥尼突吉罗

尔时王园精舍前。地极平正生软好草。众人常于中嬉戏。乱诸比丘尼坐禅行道。诸比丘尼厌患。便共于中大小便。污使不净以却众人。众人后来如常嬉戏。污其手脚衣服器物。便大恚言。谁于此处漫纵屎溺。有人言是比丘尼。皆讥诃言。此等出家求道清净。如何秽污如此好处断人乐事。诸长老比丘尼闻种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼于生草上大小便波逸提。式叉摩那沙弥尼突吉罗。若急病不犯

尔时诸比丘尼。复掷粪扫残食于王园精舍前地。以却众人。诸白衣讥嫌。长老比丘尼闻种种诃责。乃至今为诸比丘尼。结戒亦如上说。从今是戒应如是说。若比丘尼掷粪扫残食生草上波逸提。式叉摩那沙弥尼突吉罗。若掷坑中非净洁处不犯

尔时诸比丘尼于有食家宿。闻彼夫妇交会时声。生爱欲心不复乐道。遂有反俗作外道者。诸长老比丘尼闻种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼于有食家宿波逸提。有食者。有男女情相食入。式叉摩那沙弥尼突吉罗。若病须宿及诸难起皆不犯

尔时诸比丘问诸比丘尼。某甲家在何处。此路向何处。诸比丘尼轻慢不答。诸比丘嗔嫌不复教诫。便愚闇无知不能学戒。诸长老比丘尼闻种种诃责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼比丘问不答波逸提。时六群比丘作粗恶语问比丘尼。比丘尼虽答而怀羞耻。以事白佛。佛以是事集二部僧。告诸比丘今听诸比丘尼若比丘如法问应答。从今是戒应如是说。若比丘尼若比丘如法问不答波逸提。式叉摩那沙弥尼突吉罗。若先相嫌不共语不答不犯(一百四十)

尔时诸比丘尼乘乘诣诸白衣。诸白衣讥诃言。此诸比丘尼如王夫人贵家妇女。乘乘行来无有仪法。诸长老比丘尼闻种种诃责。乃至今为比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼乘乘行来波逸提。乘者。车舆象马乃至着屐。皆名为乘。式叉摩那沙弥尼突吉罗。若老若病。若为强力所逼。若行路乃至脚指病。皆不犯(一百四十一)

五分律卷第十三五分律卷第十四(弥沙塞)

        宋罽宾三藏佛陀什共竺道生等译

    第二分之四

尔时诸比丘尼。着革屣持盖诣诸白衣。诸白衣讥呵言。此诸比丘尼如淫女行来。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼着革屣捉盖行来波逸提。盖者。乃至草盖。革屣者。乃至一重。式叉摩那沙弥尼突吉罗。不犯如上

尔时有夫妇二人俱时出家。彼夫比丘乞食持还至妇比丘尼住处食。其妇比丘尼捉水瓶立前以扇扇之与水辄问冷暖。彼夫比丘低头食不视不共语。彼比丘先白衣时有私通女人。亦出家在彼住来出见之。比丘便笑。其妇比丘尼嫉姤心发。即以水瓶打比丘头破。诸比丘尼呵言。云何比丘尼捉水瓶及扇立比丘前给水及扇。遂复打其头破。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼捉水瓶及扇立比丘前若给水若扇波逸提。若欲给水与竟应远去不应住前立。式叉摩那沙弥尼突吉罗

尔时诸比丘尼诵治病经方。诸白衣讥呵言。此等但学医术无求道意。何不以此诵读佛经。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼诵治病经方波逸提。式叉摩那沙弥尼突吉罗。若为自病若慈愍若强力所逼差读不犯

尔时诸比丘尼教他诵治病经方。诸白衣讥呵。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒亦如上说。从今是戒应如是说。若比丘尼教他诵治病经方波逸提。余如上说

尔时诸比丘尼为人治病合和煮捣诸药。初夜后夜未曾休息。诸白衣见讥呵言。此等如医如医弟子。何不求道疗生死病。而反营此世俗事为。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼为人治病以为生业波逸提。式叉摩那沙弥尼突吉罗。若怜愍若强力所逼不为利养不犯

尔时诸比丘尼教人治病。诸白衣来语言。为我说法。便语言。治热如是。治冷如是。治风如是。治诸病如是。诸白衣言。我为法来不为治病。复讥呵言。此等唯学医术不知道法。若不尔者何不以法教我。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒亦如上说。从今是戒应如是说。若比丘尼教他治病以为生业波逸提。余如上说

尔时诸比丘尼为知识家作。诸居士讥呵言。此等舍本家作为他家作。无沙门行破沙门法。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼以饮食故为白衣家作波逸提。式叉摩那沙弥尼突吉罗。若怜愍若强力所逼不犯

尔时诸比丘尼。与白衣及外道妇女同衣卧身体相触。生爱欲心不乐梵行。遂致反俗作外道者。诸妇女后随知识语言。某甲比丘尼身体有如是如是好。诸白衣后见比丘尼。便指弄言。好身体者。此比丘尼是。彼比丘尼是。诸比丘尼以此羞耻。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼共白衣及外道妇女同衣卧波逸提。若同床共被内衣应使有隔。式叉摩那沙弥尼突吉罗

尔时诸比丘尼。与比丘尼式叉摩那沙弥尼同衣卧。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼与比丘尼式叉摩那沙弥尼同衣卧波逸提。余如上说

尔时诸比丘尼。与白衣及外道妇女更相覆眠相见形体生爱欲心。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼与白衣及外道妇女更相覆眠波逸提。余如上说。若先已有覆重覆不犯

尔时诸比丘尼。与比丘尼式叉摩那沙弥尼更相覆眠相见形体。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼与比丘尼式叉摩那沙弥尼更相覆眠波逸提。余如上说(一百五十)

尔时诸比丘尼。以香涂身亦使人涂。生爱欲心不乐修梵行。遂致反俗作外道者。诸白衣闻其香气。讥呵言。此等以香涂身同于淫女。无沙门行破沙门法。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼以香涂身波逸提。香者。根香茎香叶香华香虫香胶香。式叉摩那沙弥尼突吉罗。若为治病若强力所逼涂不犯

尔时诸比丘尼以泽枯揩身令有光润。诸白衣讥呵言。此等以泽枯揩身令有光润如淫女人。无沙门行破沙门法。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼以泽枯揩身波逸提。时跋陀迦毗罗比丘尼身体少润枯燥擗裂问医。医言应用泽枯揩身。答言佛不听我泽枯揩身。愿更思余治。医言更无余治。比丘尼作是念。若世尊听病时泽枯揩身。我乃不复有此苦患。以是白佛。佛以是事集二部僧。告诸比丘。今听比丘尼病时以泽枯揩身。从今是戒应如是说。若比丘尼无病以泽枯揩身波逸提。式叉摩那沙弥尼突吉罗

尔时诸比丘尼畜华鬘或着。生染着心不乐修梵行。遂致反俗作外道者。诸长老比丘尼见种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼畜华鬘若着波逸提。乃至以草叶系头为好。皆名著华鬘。式叉摩那沙弥尼突吉罗。若强力所逼不犯

尔时比丘尼着宝璎珞。生爱欲心不乐修梵行。遂致反俗作外道者。诸长老比丘尼见种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼着宝璎珞波逸提。乃至以木作璎珞亦如是。式叉摩那沙弥尼突吉罗。不犯如上

尔时诸比丘尼着卑身衣。使形佣纤得中生爱欲心。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼着卑身衣波逸提。式叉摩那沙弥尼突吉罗。不犯如上

尔时诸比丘尼畜种种严身具生爱欲心。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼畜种种严身具波逸提。式叉摩那沙弥尼突吉罗

尔时诸比丘尼畜发。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼畜发波逸提。比丘尼发长波逸提。式叉摩那沙弥尼畜发及发长不剃突吉罗。半月一剃。过此名为发长。若无人剃。及强力所逼不得剃。皆不犯

尔时诸比丘尼。着白衣女人严身具生爱欲心。时偷罗难陀比丘尼主人新取妇。妇以严身具与令着。着已覆头眠床上。婿从外还欲近其妇。发头方知。呵言。我若不发头便行欲者。岂不致大罪耶。云何比丘尼作如此事。无沙门行破沙门法。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼着严身具波逸提。式叉摩那沙弥尼突吉罗。不犯如上

尔时诸比丘尼为他作严身具。诸白衣讥呵言。此等如淫女人作严身具。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼为他作严身具波逸提。式叉摩那沙弥尼突吉罗

尔时诸比丘尼绩缕。诸白衣讥呵言。此等衣食仰他。不念行道以报信施。绩缕何为。无沙门行破沙门法。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼绩缕波逸提。式叉摩那沙弥尼突吉罗。若作腰绳禅带络囊缝衣缕不犯(一百六十)

尔时诸比丘尼随知识白衣家敷卧具住。诸白衣讥呵言。云何出自家住他家。我等不喜见此不吉利物。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼不问白衣辄在其家敷卧具住波逸提。式叉摩那沙弥尼突吉罗。若亲里家住不犯

尔时诸比丘尼在白衣家。敷主人坐卧具若使人敷。去时不自举不教人举。诸白衣讥呵言。云何比丘尼敷人坐卧具去复不举。我等常为此等作奴婢。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼至白衣家敷。主人坐卧具若使人敷去时不自举不教人举波逸提。式叉摩那沙弥尼突吉罗。若嘱举不犯

尔时诸比丘尼自煮生物作食。诸白衣讥呵言。云何比丘尼自煮生物既自煮作食何为复就人乞耶无沙门行破沙门法。诸长老比。丘尼闻种种呵责。乃至今为诸比丘尼结戒亦如上说。从今是戒应如是说。若比丘尼自煮生物作食波逸提。若为病不犯

尔时差摩比丘尼来至舍卫城。旃荼修摩那比丘尼以精舍借令住止。差摩得慈心三昧。有大威德。眷属成就。旃荼弟子皆共尊重。并欲随逐。旃荼觉之便嗔骂言。我以精舍借汝令住。反更诱人弟子。诸长老比丘尼闻种种呵责。云何借他精舍而后嗔谤。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼先听住后嗔谤者波逸提式叉摩那沙弥尼突吉罗。若有实而嗔恨不犯

尔时跋陀伽毗罗比丘尼髀里生痈。不白僧辄使男子医破出脓洗讫布药。诸长老比丘尼见呵责言。汝已离欲故可如此。若未离欲人不当犯大事耶。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼不白僧辄使男子治病波逸提。若欲令男子治病。应打犍稚集僧来在病人前。然后衣裹身体。唯留可应治处。式叉摩那沙弥尼突吉罗。若使女人治不犯

尔时诸比丘尼。夜辄开都门出。不语后人令闭。夜有贼来夺诸比丘尼衣钵。诸长老比丘尼种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼夜辄开都门出不语余比丘尼令闭波逸提。式叉摩那沙弥尼突吉罗。无恐怖处不犯

尔时诸比丘尼非时到白衣家。有一家大富。贼常欲劫之而未得便。借问行人。谁出入此家者。有人言。偷罗难陀比丘尼与此家善数相往返。贼便往语偷罗难陀言。阿姨某甲唤汝。即从语暮往。主人为开门。贼便突入劫物荡尽。主人嗔呵言。若此比丘尼不非时来。我不开门不遭此难。供养望福而反致祸。与养怨家有何等异。诸长老比丘尼种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼非时入白衣家波逸提。复有诸比丘尼白衣呼不敢往。以是白佛。佛以是事集二部僧告诸比丘。今听比丘尼白衣唤得往。从今是戒应如是说。若比丘尼白衣不唤非时入其家波逸提。非时者。从中后至明相未出。若白衣唤应详察。彼使是可信人不。又应审问知其虚实。若犹有疑至门应先问。其家竟为唤不。然后乃入复应筹量。非是可畏时不。若非时往白衣家。一脚出门突吉罗。两脚出波逸提。式叉摩那沙弥尼突吉罗

尔时有居士请比丘尼僧食。诸比丘尼食前着衣持钵往到其家。从作食人索饮或索釜燋或索饭。作食人作是念。今办此食正为此辈。前与后与亦复何在。便尽与之饭饮都尽主人至时打犍槌集僧敕使下食。作食人具以事答。居士便讥呵言。此诸比丘尼如小儿不能小忍。贪食如此何道之有。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼受请。主人未唱随意食。食者波逸提。若未唱随意食食。口口波逸提。式叉摩那沙弥尼突吉罗(一百七十)

尔时诸比丘尼如法作驱出羯磨竟。被驱比丘尼不肯去。诸长老比丘尼种种呵责言。被驱出羯磨与不被驱出羯磨有何等异。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼被驱出羯磨不去者波逸提。驱出羯磨者。白四羯磨。式叉摩那沙弥尼突吉罗。若病若八难起若非法羯磨皆不犯

尔时诸比丘尼如法集僧时。有比丘尼不即往。诸比丘尼待之以妨行道。诸长老比丘尼种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼僧如法集会不即往波逸提。式叉摩那沙弥尼突吉罗。若病若不闻若八难起不犯

尔时诸比丘尼往观歌舞作伎。生染着心不复乐道。遂有反俗作外道者。诸白衣见讥呵言。此等观歌舞作伎如淫女人。无沙门行破沙门法。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼观歌舞作伎波逸提。式叉摩那沙弥尼突吉罗。不犯如上观王宫观画中说

尔时诸比丘尼往至边地。边地人抄取作婢。或夺衣钵或破梵行。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼往边地波逸提。边地者。无比丘比丘尼处。式叉摩那沙弥尼突吉罗。若飞行不犯

尔时诸比丘尼度二根人。诸白衣讥呵言。云何比丘尼度二根人。无可度不可度者无沙门行破沙门法诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼度二根人波逸提。若疑应先看。发心乃至三羯磨未竟突吉罗竟。和尚波逸提。余尼师僧突吉罗

尔时诸比丘尼度二道合作一道女人。诸长老比丘尼种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼度二道合作一道女人波逸提。若度竟有是病不犯。余如上说

尔时诸比丘尼度常有月水女人。行乞食血流污脚。诸白衣见恶贱讥呵言。诸比丘尼无可度不可度。度如此辈污人床席。无沙门行破沙门法。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼度常有月水女人波逸提。余如上说

尔时诸比丘尼不礼比丘不迎不送亦不请坐。诸比丘嗔不复教诫。诸比丘尼愚闇无知不能学戒。诸长老比丘尼见种种呵责。以是白佛。佛以是事集二部僧。问诸比丘尼。汝等实尔不。答言实尔世尊。佛种种呵责言。我先不说八敬法应礼比丘耶。从今是戒应如是说。若比丘尼见比丘不起不礼不请坐波逸提。式叉摩那沙弥尼突吉罗。若病若先有怨嫌不共语不犯

尔时诸比丘尼作是念。佛不听我等剃隐处毛。今当火烧即便烧之。时有婆罗门失羊觅之。到比丘尼巷闻烧毛气。谓比丘尼偷杀其羊。便至王所以事白王。王即呼比丘尼问言。阿姨杀婆罗门羊不。答言不杀。问若不杀那得有烧羊毛气。便以实答。王闻大笑即放令去。诸臣闻之讥呵言。云何比丘尼不念行道乃烧隐处毛。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼烧隐处毛波逸提。余如剃隐处毛中说

尔时诸比丘尼不着僧祇支往白衣舍。风吹上衣露其身体。诸白衣见便弄共说粗恶语以此羞耻。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼不着僧祇支入白衣家波逸提。式叉摩那沙弥尼突吉罗。若浣染打缝若无皆不犯(一百八十)

尔时诸比丘尼。与白衣对坐临身相近说法。似若私语。于中生染着心。遂致返俗作外道者。诸白衣讥呵。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼与白衣对坐临身相近说法波逸提。式叉摩那沙弥尼突吉罗

尔时诸比丘尼自歌舞。诸居士讥呵言。此比丘尼自歌舞如淫女人。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼自歌舞波逸提。式叉摩那沙弥尼突吉罗

尔时诸比丘尼遮受迦絺那衣。诸比丘尼待久不至妨废行道。诸长老比丘尼种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼遮受迦絺那衣波逸提。若病若不闻不犯

尔时诸比丘尼遮舍迦絺那衣。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼遮舍迦絺那衣波逸提。余如上说

尔时差摩比丘尼聪明机辩。难问诸比丘。诸比丘不能答便大羞耻。后见诸比丘尼辄下路避之。遂无复教诫比丘尼者。愚闇无知不能学戒。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼问难比丘波逸提。有诸比丘尼有疑不敢问难。以此复愚闇无知不能学戒。以是白佛。佛以是事集二部僧。告诸比丘。今听诸比丘尼先白比丘听问者问。从今是戒应如是说。若比丘尼不白比丘辄问义者波逸提。式叉摩那沙弥尼突吉罗

尔时跋难陀。常出入偷罗难陀比丘尼所。后时着衣持钵往到彼所。坐起轻脱更相见形。跋难陀遂失不净。偷罗难陀取内衣浣。以不净自内形中遂致有娠。诸比丘尼见问言汝不修梵行耶。答言非不修梵行。我以男子不净自内形中致此娠耳。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼以男子不净自内形中波逸提。式叉摩那沙弥尼突吉罗

尔时诸比丘尼作外道事火法。然火及诵其咒语。诸居士讥呵言。此等尚不能净其见。何得有道。无沙门行破沙门法。诸长老比丘尼闻种种呵责。乃至今为。诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼作外道事火法然火波逸提。若以邪见作之偷兰遮。若作种种诸外道事皆波逸提。式叉摩那沙弥尼突吉罗

尔时诸比丘尼在有人处浴。众人见之观看戏弄。诸长老比丘尼见种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼在有人处浴波逸提。式叉摩那沙弥尼突吉罗

尔时诸比丘尼诵外道咒术。诸白衣讥呵。此等诵外道咒无求道心。乃至今为诸比丘尼结戒。皆如诵治病经方中说。从今是戒应如是说。若比丘尼诵外道咒术若教人诵波逸提。式叉摩那沙弥尼突吉罗

尔时诸比丘尼众自授具足戒。彼愚闇无知不能学戒。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼一众授具足戒波逸提。发心乃至白四羯磨未竟突吉罗竟。和尚波逸提。余师僧突吉罗(一百九十)

尔时诸比丘尼。自作畜众羯磨。自作二岁学戒羯磨。自授二岁学戒。不能教诫弟子。愚闇无知不能学戒。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼自作畜众羯磨波逸提。若比丘尼自作二岁学戒羯磨波逸提。若比丘尼自授二岁学戒波逸提。余如上说

尔时诸比丘尼。作二岁学戒竟羯磨。经宿乃与授具足戒。中间有难遂不得受具足戒。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼作二岁学戒竟羯磨经宿乃授具足戒波逸提。发心乃至明相未出突吉罗。明相出已和尚波逸提。余师众突吉罗。若病若难起若僧不集会不犯

尔时诸比丘尼。作二岁学戒羯磨竟。经宿乃授其学戒。其中难起遂不得受。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼作二岁学戒羯磨竟经宿乃授其学戒波逸提。发心乃至明相未出突吉罗。明相出已和尚波逸提。余师众突吉罗。不犯如上说

尔时诸比丘尼自织作衣。诸白衣讥呵言。云何比丘尼不念行道身自织作如余织师。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼自织作衣着波逸提。若织掷梭。掷掷波逸提。式叉摩那沙弥尼突吉罗。若织腰绳禅带不犯

尔时波斯匿王左右人及诸比丘尼。于恐怖处游看为贼所剥。或破梵行或虏将去。余比丘尼以是白王。王言。我今不得自在。当奈比丘尼何。诸长老比丘尼闻种种呵责言。何以于恐怖处游行。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼国内恐怖处于中游行波逸提。式叉摩那沙弥尼突吉罗。若先在路行。后有难起不犯

尔时诸比丘尼自作己像亦使人作。时偷罗难陀亦使人作。见己像已生染着心作是念。我色貌如是。云何毁之修于梵行。诸长老比丘尼见种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼自作己像若使人作波逸提。作己像者。或画或以木或以泥。式叉摩那沙弥尼突吉罗。若人密作示之不犯

尔时诸比丘尼庄严女人。便生不乐道心。遂致反俗作外道者。诸白衣讥呵言。云何比丘尼庄严女人如庄母耶。与自庄严有何等异。不念行道但作邪饰。无沙门行破沙门法。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼庄严女人波逸提。庄严者。为其梳头乃至插一华着一钏。一一波逸提。式叉摩那沙弥尼突吉罗

尔时诸比丘尼水中洗浴逆流行。为水所触生爱欲心。遂致反俗作外道者。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼水中逆流行波逸提。若逆流行。步步波逸提。失不净偷罗遮。式叉摩那沙弥尼突吉罗。若无欲心不犯

尔时诸比丘尼仰卧屋溜处。渧入形中生爱欲心。遂致反俗作外道者。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼仰卧水来下处波逸提。余如上说

尔时诸比丘尼。以绳缠腰欲使细好生爱欲心。诸白衣讥呵言。此等治腰使细如淫女人。无有道心但作邪事。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒亦如上说。从今是戒应如是说。若比丘尼治腰使细波逸提。式叉摩那沙弥尼突吉罗(二百)

尔时诸比丘尼。种种治身令好生爱欲心。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼种种治身波逸提。余如上说

尔时诸比丘尼如妓女法着衣。生不乐道心遂至反俗。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼如妓女法着衣波逸提。式叉摩那沙弥尼突吉罗

尔时诸比丘尼如白衣妇女法着衣。生不乐道心。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼如白衣妇女法着衣波逸提。余如上说

尔时诸比丘尼。以欲心自观形体生爱欲意。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼以欲心自观形体波逸提。式叉摩那沙弥尼突吉罗

尔时诸比丘尼照镜生不乐道心。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼照镜波逸提。若水中照突吉罗。式叉摩那沙弥尼突吉罗。若面有疮照看不犯

尔时诸比丘尼种种自卜亦从他卜。诸白衣讥呵言。此等不舍邪见何应得道。诸长老比丘尼闻种种呵责。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼自卜若就他卜波逸提。式叉摩那沙弥尼突吉罗

尔时诸比丘尼共私论议。我等出家当得究竟为不得究竟为。应罢道不应罢道。若罢道者得好婿不。儿子多少相禄云何。因此论说生世俗情。不复乐道。遂致反俗作外道者。诸长老比丘尼闻种种呵责言。云何比丘尼作世俗论以忘道意。乃至今为诸比丘尼结戒。亦如上说。从今是戒应如是说。若比丘尼随世俗论者波逸提。式叉摩那沙弥尼突吉罗(二百七竟)

    五分律第二分之五尼律悔过法

尔时诸比丘尼好食酥数从人乞。诸白衣讥呵言。酥令人悦泽。世人所食。云何比丘尼不求法味。贪着嗜美求好颜色与淫女何异。无沙门行破沙门法。诸长老比丘尼闻种种呵责。以是白佛。佛以是事集二部僧。闻诸比丘尼。汝等实尔不。答言实尔世尊。佛种种呵责已告诸比丘。今为诸比丘尼结波罗提提舍尼法。从今是戒应如是说。若比丘尼食酥应诸比丘尼边悔过。我堕可呵法。今向诸阿姨悔过。是名悔过法。时诸比丘尼于僧中食请家食及乞食得酥不敢啖。以是白佛。佛以是事集二部僧。告诸比丘。今听比丘尼不乞得酥应啖。从今是戒应如是说。若比丘尼乞酥食。是比丘尼应诸比丘尼边悔过。我堕可呵法。今向诸阿姨悔过。是名悔过法。有诸病比丘尼须。酥不敢乞。以是白佛。佛以是事集二部僧。告诸比丘。今听病比丘尼乞酥食。从今是戒应如是说。若比丘尼无病自为乞酥食。是比丘尼应诸比丘尼边悔过。我堕可呵法。今向诸阿姨悔过。是名悔过法。式叉摩那沙弥尼突吉罗

比丘尼。乞油。乞蜜。乞石蜜。乞乳。乞酪。乞鱼。乞肉。皆如上说

    五分律第二分之六尼律众学法

尔时优波离问佛。世尊已为诸比丘结应学法。不高着下衣应当学。乃至树过人不得上除大因缘应当学。我当云何持。佛言。应作二部僧持。从今是戒应如是说。不高着下衣应当学。不下着下衣。不参差着下衣。不如多罗叶着下衣。不如象鼻着下衣。不如圆奈着下衣。不细襵着下衣

不高被衣。不下被衣。不参差被衣

好覆身入白衣舍。好覆身白衣舍坐。不反抄衣着右肩上入白衣舍。不反抄衣着右肩上白衣舍坐。不反抄衣着左肩上入白衣舍。不反抄衣着左肩上白衣舍坐。不左右反抄衣着两肩上入白衣舍。不左右反抄衣着两肩上白衣舍坐。不摇身入白衣舍。不摇身白衣舍坐。不摇头入白衣舍。不摇头白衣舍坐。不摇肩入白衣舍。不摇肩入白衣舍坐。不携手入白衣舍。不携手白衣舍坐。不隐人入白衣舍。不隐人白衣舍坐。不叉腰入白衣舍。不叉腰白衣舍坐。不拄颊入白衣舍。不拄颊白衣舍坐。不掉臂入白衣舍。不掉臂白衣舍坐。不高视入白衣舍。不高视白衣舍坐。不左右顾视入白衣舍。不左右顾视白衣舍坐。不蹲行入白衣舍。不蹲行白衣舍坐。不企行入白衣舍。不企行白衣舍坐。不覆头入白衣舍。不覆头白衣舍坐。不戏笑入白衣舍。不戏笑白衣舍坐。不高声入白衣舍。不高声白衣舍坐。庠序入白衣舍。庠序白衣舍坐

一心受食。不溢钵受食。羹饭俱食。不于钵中处处取食。不刳中央食。不曲指收钵食。不嗅食食。谛视钵食。不弃饭食。不以食手捉净饮器。不吸食食。不嚼食作声。不舐取食。不满手食食。不大张口食。饭未至不大张口待。不缩鼻食。不含食语。不胀颊食。不啮半食。不舒臂取食。不振手食。不吐舌食。不含吞食。不揣饭遥掷口中。不以钵中有饭水洒白衣屋内。不以饭覆羹更望得。不嫌呵食。不为己索益食。不嫌心视比坐钵食

不立大小便除病。不大小便净水中除病。不大小便生草菜上除病。人着屐不应为说法除病。人着革屣不应为说法除病。人现胸不应为说法除病。人坐比丘尼立不应为说法除病。人在高坐比丘尼在下不应为说法除病。人卧比丘尼坐不应为说法除病。人在前比丘尼在后不应为说法除病。人在道中比丘尼在道外不应为说法除病。不为覆头人说法除病。不为反抄衣人说法除病。不为左右反抄衣人说法除病。不为持盖覆身人说法除病。不为骑乘人说法除病。不为拄杖人说法除病。不为捉刀人说法。不为捉弓箭人说法。树过人不得上除大因缘应当学。大因缘者。恶兽诸难。是名大因缘

五分律卷第十四五分律卷第十五(弥沙塞)

        宋罽宾三藏佛陀什共竺道生等译

    第三分初受戒法上

佛在王舍城告诸比丘。过去有王名曰郁摩。有四庶子。一名照目二名聪目三名调伏象四名尼楼。聪明远达并有威德。第一夫人有子。名曰长生。顽薄丑陋众人所贱。夫人念言。我子虽长才不及物。而彼四子并有威德。国祚所归必钟此等。当设何计固子基业。复作是念。王见信爱兼余夫人。正当先以情求次以理成耳。即如其念。便自严饰于王入时倍如承敬。王欲亲近。即便啼泣。王问其故夫人答言。微愿不遂。于是尽矣。王言。汝愿理苟可从誓不相违。便白王言。王之四子并有威德。我子虽长才不及物。承系大业必为倰夺。若王摈斥四子我情乃安。王言。四子孝友于国无愆。我今云何而得摈黜。夫人又言。我心劬劳实兼家国。王此四子并有威德。民各怀附已。一旦竞逐必相殄灭大国之祚何必王后。王言。止止勿复有言。即呼四子敕令出国。四子奉命。即便装严。时四子母及同生姊妹咸求同去。又诸力士百工婆罗门长者居士一切人民多乐随从。王悉听之。于是四子拜辞而去。渡傍耆罗河到雪山北。土地平广四望清净。又多名果异类禽兽。四子见之。呼婆罗门长者居士住共议言。所经诸处无胜此者。可以居乎。咸无异议。即便顿止营建城邑。数年之中归者如市。渐渐炽盛遂成大国。去后数年父王思子。问群臣言。我四子者今在何许。答言。在雪山北近舍夷林筑城营邑。人民炽盛地沃野丰衣食无乏。王闻三叹我子有能。如是三叹。从是遂号为释迦种也。尼楼有子名象头罗。象头罗子名瞿头罗。瞿头罗子名尼休罗。尼休罗有四子。一名净饭二名白饭三名斛饭四名甘露饭。净饭王有二子。一名菩萨二名难陀。白饭有二子。一名阿难陀二名调达。斛饭有二子。一名摩诃男二名阿那律。甘露饭有二子。一名婆婆二名拔提。菩萨有子名罗睺罗。菩萨少有出家志。父王恐其学道。常以五欲而娱乐之。至年十四严驾游观出东城门。逢见老人头白背偻拄杖羸步。问御者曰。此为何人。答曰老人也。又问何谓为老。答曰。年耆根熟形变色衰。坐起苦极余命无几。故谓之老。菩萨曰吾免之乎。答曰未也。便回驾还宫。自念。未离老法愁忧不乐。王问御者。太子出为乐不。答言不乐。又问何故。答曰。逢见老人是故不乐。王恐。相师言。实出家不久。复增五欲以娱乐之。菩萨久后复敕御者严驾游观出南城门。逢见病人形体羸瘦倚门喘息。问御者曰。此为何人

答曰病人也。又问何谓为病。答曰。四大增损饮食不能。气息羸微命在漏刻。故谓之病。又问吾免之乎。答曰未也。便回驾还宫。自念。未离老病更增愁忧。王复问御者。太子此出乐不。答言逾更不乐。又问何故。答曰逢见病人是故不乐。王恐出家不久。复增五欲昼夜娱乐。菩萨久后复敕御者严驾游观出西城门。逢见死人舁尸在前。室家男女哀号随后。问御者曰。此为何人。答曰死人也。又问何谓为死。答曰。气绝神逝无所复知。弃之空野长离亲戚。故谓之死。又问吾免之乎。答曰未也。菩萨自念。未离老病死法更增愁忧。即回车还。逢见一人剃除须发法服擎钵视地而行。问御者曰。此为何人衣服异世。答曰出家人也。又问何谓出家。答曰。善自调伏具诸威仪。常行忍辱怜愍众生。故谓出家。菩萨闻已三称善哉。惟是为快。至便下车恭敬而问。何故形服与世绝异。答亦如上。菩萨复三称善哉。惟是为快。登车向宫。有一女人遥见菩萨生欲爱心。即说偈言

  母有此子乐　　其父亦甚欢
  女人有此婿　　乐过于泥洹

菩萨闻说泥洹声。欢喜踊跃自念。我何当得此无上泥洹。还宫思惟。未离生老病死之法。王问御者。太子今出乐不。答言。始出不悦。还时甚乐。又问何故。答曰。出逢死人是故不悦。还见比丘是故欢乐。王复念曰。相师言实出家必矣。复增五欲昼夜娱乐。菩萨为诸妓女所娱乐已。便得暂眠。众妓女辈皆淳惛而寐。菩萨寻觉。观诸妓直更相荷枕。或露形体如木人状。鼻涕目泪口中流涎。琴瑟筝笛纵横在地。又见宫殿犹如丘墓。菩萨见已三反称言。祸哉祸哉。走视父王所住宫殿。宫殿变状亦复如是。复称祸哉深生厌离。于是菩萨敕奴阐陀。汝起被马勿令人闻。阐陀白言。夜非行时不应游观。又无怨敌逼于上宫。不审何故夜敕被马。太子答言。有大怨敌汝不知耶。老病死怨。怨之大者。汝速被马勿得稽留。即被白马牵至中庭。白言马已来此。菩萨便到马所。将欲跨之。马大悲鸣。天神恐有留难。即散马声令人不闻。菩萨跨马向合。合即自开。复向城门。门亦自开。既出门已向阿[少/兔]耶林。去城不远。便下马脱宝衣。语阐陀言。汝可牵马并持宝衣还宫道。吾拜白父母。今辞学道不久当还。愿不垂忧。阐陀涕泣长跪白言。相师昔记太子。当为转轮圣王七宝千子王四天下正法御世不用兵杖自然太平。而今云何弃此王位脱身宝衣受苦山野。菩萨反问。相师尔时复何所记。答言。若不乐天下。出家学道当成无上等正觉道。菩萨语言。汝闻此语。今何为忧。但速还归启白父母。设我骸骨枯腐不尽生老病死之原。终不还反。于是阐陀悲泣前礼。右绕三匝。牵马持宝衣还宫

菩萨前行。见一猎人着袈裟衣。往至其所。以所著衣价直百千。用以贸之得着而去。菩萨复前向须摩那树。树下有剃头师。求令除发。即为剃之。释提桓因如屈伸臂顷至菩萨前。以衣承发持还天宫。剃已作是念。我今已为出家自然具戒。于是渐渐游行到王舍城瓶沙王少有五愿。一者父王登遐我当绍位。二者愿为王时遇佛出世。三者愿身见佛亲近供养。四者愿发喜心得闻正法。五者愿闻法已即得信解。菩萨入城乞食。威仪庠序视地而行。时未有钵持莲华叶。展转道路叶不离根。时王与诸群臣于高楼上。遥见菩萨以为奇雅。顾语众臣。未曾见闻若斯人比。必是神圣。咸皆白言。昔闻雪山北迦维罗卫城王名净饭。生子名菩萨。相师相之。若在家者当为转轮圣王主四天下七宝自至。所谓轮宝象宝马宝珠宝女宝臣宝主兵宝。王有千子勇健多力。以法御世兵杖不用自然太平。若不乐世间出家学道。道成号佛度人生死。闻已出家此人必是。王闻是语。便大欢喜言。吾昔五愿一愿已果。余有四愿今必获矣。即敕二人往视菩萨。于何憩止吾当出诣。受教驰往。见菩萨乞食毕还波罗奈山向波旬国结跏趺坐。一人往视。一人还白。王即严驾出诣。菩萨止顿山下。王步上山。至菩萨所。菩萨言。善来大王得无疲极。王即稽首礼足却坐一面。白菩萨言。本生何国何姓出家。菩萨答曰。生雪山北舍夷国迦维罗卫城。父名净饭。姓曰瞿昙。王欲试菩萨。语言。比丘族姓尊贵。世为王胄。圣德自然应君四海。四海颙颙莫不企仰。若能降志亦当称蕃北面相事。菩萨答曰。位莫尊转轮王。吾已弃之况四海乎。所以出家求道。欲度一切生死大苦。何不请我道成先度。乃反区区。以此相要。王言。善哉斯语甚快。道成之日愿先度我及此国人菩萨许之。王大欢喜礼足辞退。王去后菩萨便向菩提树。去树不远见一人刈草。名曰吉安从乞少草。持至树下敷已结跏趺坐。直身正意系念在前。即除五盖离欲恶不善法。乃至得第四禅游戏其中。通三十七道品之行。以此净心三明洞照。所谓宿命明他心明漏尽明。如瑞应本起中说。于是起到郁鞞罗聚落。始得佛道坐林树下。初夜逆顺观十二因缘。缘是故有是缘灭则是灭。所谓无明缘行行缘识识缘名色名色缘六入六入缘触触缘受受缘爱爱缘取取缘有有缘生生缘老死忧悲苦恼。若无明灭则行灭。行灭则识灭。识灭则名色灭。名色灭则六入灭。六入灭则触灭。触灭则受灭。受灭则爱灭。爱灭则取灭。取灭则有灭。有灭则生灭。生灭则老死忧悲苦恼皆灭。见此义已即说偈言

  生缘法皆尔　　梵志初始禅
  既知此缘法　　能除一切疑
  生缘法皆尔　　梵志初始禅
  既知此缘法　　能除一切苦
  生缘法皆尔　　梵志初始禅
  破魔之闇冥　　如日升虚空

尔时世尊身有风患。摩修罗山神。即取诃梨勒果奉佛。愿佛食之以除风患。佛受为食风患即除。结跏趺坐七日受解脱乐。过七日已从三昧起游行人间。时有五百贾客。乘五百乘车。中有二大人。一名离谓。二名波利。二人昔善知识死为善神恒随逐之。作是念。今佛始成大道。未有献食者。我今当令二人饭佛使长夜获安。即以神力车牛皆踬。众人怖惧四向求神。彼神于空中语言。汝等莫怖。汝等莫怖。今佛世尊初成大道。静坐七日从定起。游行坐彼树下。未有献食者。汝奉上糗蜜长夜获安。众人欢喜即和糗蜜。俱诣树下遥见世尊。姿容挺特诸根寂定。有三十二大人之相。圆光一寻犹若金山。前礼佛足奉上糗蜜。世尊作是念。过去诸佛皆以钵受。当来诸佛亦复如是。我今亦应用钵受施。四天王知佛意。各取一自然香净石钵以奉世尊。白言。惟愿哀纳我等此器受贾人施。佛复惟念。若取一王钵。不可余王意。便悉受四钵。累左手中。右手按之合成一钵。以用受施。受已语言。汝等当归依佛归依法。即受二自归。是为人中二贾客最初受二自归。便为说随喜咒愿之偈

  二足汝安隐　　四足亦安隐
  去亦得安隐　　还亦得安隐
  如耕田有望　　下种亦有望
  汝今入海望　　获果亦如彼

尔时世尊说此偈已。更为贾人说种种妙法。示教利喜已。复至一树下食糗蜜。食糗蜜已。复结跏趺坐入定七日受解脱乐。过七日已。到文鳞龙所坐一树下。龙从水出以非人食奉上世尊。佛受食已。复入定七日受解脱乐。时雨七日其云甚黑。使人毛竖。龙作是念。今雨可畏。我宁可化作大身绕佛七匝。头覆佛上勿使风雨蚊虻恼乱世尊。即便作之。世尊过七日已从三昧起。龙见雨止空中清明。舍其本形化作年少。稽首白佛。我化大身围绕七匝头覆佛上。欲以障蔽风雨蚊虻不为触恼。佛以此义便说偈言

  静处远离乐　　闻法见法乐
  不恼世间乐　　能慈众生乐
  世间离欲乐　　等度恩爱乐
  能伏我慢者　　是为最上乐

佛说偈已。起到郁鞞罗斯那聚落入村乞食。次到斯那婆罗门舍。于门外默然立。彼女须阇陀。见佛威相殊妙。前取佛钵盛满美食以奉世尊。佛受食已语言。汝可归依佛归依法。即受二自归。是为女人中须阇陀最初受二自归为优婆夷。佛食已复还菩提树下。结跏趺坐三昧七日受解脱乐。过七日已从三昧起。着衣持钵复到其舍。斯那奉食受二自归亦如上说。佛后复往其舍。其妇见佛奉食。受二自归亦如上说。佛后复往其舍。彼姊妹四人见佛奉食。受二自归亦如上说。佛食已复还菩提树下三昧七日。起向阿豫波罗尼拘类树。中路见一女人钻酪作酥。便从乞食。彼女取钵盛满酪奉佛。受二自归亦如上说。佛食已前到树下三昧七日。过七日已从三昧起。作是念。我所得法甚深微妙难解难见寂寞无为。智者所知非愚所及。众生乐着三界窟宅集此诸业。何缘能悟十二因缘甚深微妙难见之法。又复息一切行截断诸流。尽恩爱源无余泥洹。益复甚难。若我说者徒自疲劳唐自枯苦。尔时世尊欲重明不可说义。而说偈言

  我所成道难　　若为窟宅说
  逆流回生死　　深妙甚难解
  染欲之所覆　　黑闇无所见
  贪恚愚痴者　　不能入此法

尔时世尊以此默然而不说法。时梵天王于梵天上。遥知佛意作是念。今佛正觉兴出于世。不为众生说所悟法。世间长衰永处盲冥。死即当复堕三恶道。念已如力士屈伸臂顷。于梵天没涌出佛前。头面礼足却住一面。白佛言。惟愿世尊。哀愍众生时为说法。自有众生能受佛教。若不闻者便当退落如是三返。复以此义说偈请佛

  先此摩竭界　　常说杂秽法
  愿开甘露门　　为演纯净义
  自我在梵宫　　皆见古佛说
  惟愿今普眼　　亦敷法堂教
  众生没忧恼　　不离生老死
  然多乐善者　　愿说战胜法

尔时世尊默然受之。即以佛眼普观世间。见诸众生根有利钝。有畏后世三恶道者。有能受法如大海者。有若莲华萌芽在泥出水未出水不污染者。而说偈言

  先恐徒疲劳　　不说甚深义
  甘露今当开　　一切皆应闻

尔时梵天闻此偈已欢喜踊跃。前礼佛足右绕三匝。忽然不现还于天宫。佛作是念。甘露当开谁应先闻。郁头蓝弗聪明易悟。此人应先。念已欲行。天于空中白言。郁头蓝弗亡来七日。佛言。苦哉彼为长衰。甘露法鼓如何不闻。复更惟曰。甘露当开谁应次闻。阿兰迦兰聪明易悟。次应得闻。适起欲行。天复白言。阿兰迦兰昨夜命终。佛言。苦哉甘露法鼓而不得闻。生死往来何由得息。复更惟曰。甘露当开谁应次闻。父王昔遣五人随侍劳苦此功应报。今此五人在波罗奈国仙人鹿苑中。念已便行。未至中间道逢梵志。名优婆耆婆。遥见世尊姿容挺特诸根寂定。圆光一寻犹若金山。便问曰。本事何师行何道法以致斯尊。尔时世尊以偈答曰

  一切智为最　　无累无所染
  我行不由师　　自然通圣道
  唯一无有等　　能令世安隐
  当于波罗奈　　击甘露法鼓

梵志复问。自说最胜。愿闻其义。佛复以偈答曰

  能除一切结　　灭尽三界漏
  摧破诸恶法　　是故我为胜

梵志不受拍髀而去。彼梵志宿世善神。即于空中为说偈言

  佛始出世间　　天上天下尊
  如何汝遇之　　而反弃舍去

梵志虽闻此偈犹去不顾。于是世尊之波罗奈趣五人所。五人遥见佛来共作要言。瞿昙沙门昔日食一麻一米。尚不得道。今既多欲去道远矣。但为敷一小座慎莫起迎礼拜问讯。世尊既到。五人不觉起礼。为捉衣钵更敷好座。以水洗足。然犹轻如来。面呼姓名。某甲可就此坐。佛告五人。汝等愚痴立要。云何而不牢固。汝莫轻于佛面称姓名。自使长夜受大苦报。吾今已成无上正觉。应共一心听受教诫。汝若随顺无违无逆。不久当得族姓出家净修梵行现证道果。生死已尽梵行已立所作已作。解了五阴止宿泥洹。五人复言。卿先如是难行苦行。尚不得过人法圣利满足。况今失道放恣多欲。过人之法其可得乎。佛复告曰。汝等莫轻如来无上正觉。佛不失道亦不多欲。五人闻已乃舍本心。佛复告曰。世有二边不应亲近。一者贪着爱欲说欲无过。二者邪见苦形无有道迹。舍此二边便得中道。生眼智明觉向于泥洹。何谓中道。所谓八正。正见正思正语正业正命正方便正念正定。是为中道。复有四圣谛。苦圣谛苦集圣谛苦灭圣谛苦灭道圣谛。何谓苦圣谛。所谓生苦老苦病苦死苦忧悲恼苦怨憎会苦爱别离苦所求失苦。以要言之。五盛阴苦。是谓苦圣谛。何谓苦集圣谛。所谓有爱及俱生烦恼处处乐着。是谓苦集圣谛。何谓苦灭圣谛。所谓爱断无余灭尽泥洹。是谓苦灭圣谛。何谓苦灭道圣谛。所谓八正道。是谓苦灭道圣谛。是法我先未闻。眼生智生明生觉生通生慧生。是法应知。我先未闻眼生乃至慧生。是法已知。我先未闻眼生乃至慧生。是苦圣谛。是苦圣谛应知。是苦圣谛已知。我先未闻眼生乃至慧生。是苦集圣谛。是苦集圣谛应断。是苦集圣谛已断。我先未闻眼生乃至慧生。是苦灭圣谛。是苦灭圣谛应证。是苦灭圣谛已证。我先未闻眼生乃至慧生。是苦灭道圣谛。是苦灭道圣谛应修。是苦灭道圣谛已修。我先未闻眼生乃至慧生。我已如实知。是三转十二行法轮得成无上正觉。说是法时。地为六返震动。憍陈如远尘离垢。于诸法中得法眼净。佛问憍陈如解未。憍陈如解未。憍陈如答言。已解世尊。地神闻已告虚空神。虚空神告四天王天。四天王天告忉利天。如是展转至于梵天言。佛今于波罗奈转无上法轮先所未转。若沙门婆罗门若天若魔若梵一切世间所未曾转。诸天欢喜雨种种花。皆有光明如星坠地。于虚空中作天伎乐。于是憍陈如。从坐起顶礼佛足。白佛言。世尊。愿与我出家受具足戒。佛言。善来比丘受具足戒。于我善说法律能尽一切苦净修梵行。憍陈如须发自堕。袈裟着身钵盂在手。是为憍陈如已得出家受具足戒。自是已后。名为阿若憍陈如。佛便为四人说法教诫。跋提婆颇二人得法眼净。见法得果。见法得果已。从坐起顶礼佛足。白佛言。世尊。愿与我出家受具足戒。佛言。善来比丘。乃至钵盂在手。亦如上说。复为二人说法教诫。頞鞞摩诃纳得法眼净。见法得果。见法得果已。从坐起顶礼佛足。白佛言。世尊。愿与我出家受具足戒。佛言。善来比丘。乃至钵盂在手。亦如上说。佛告五比丘。汝等一心求正断烦恼。我先亦一心求正断烦恼。故得成无上正觉。于意云何。色为是常为无常乎。答言无常。又问。若无常者。为苦为乐。答言苦。又问。若苦为我为非我。答言非我。受想行识亦如是。问答亦如上。是故诸比丘。色若内若外若过去未来现在。皆应如实见于非我。受想行识亦如是。夫为圣弟子应作是观。厌离无染便得解脱。得解脱智。梵行已立。所作已作。说是法时。五比丘一切漏尽。得阿罗汉道。尔时世间有六阿罗汉。复有长者子。名曰耶舍。本性贤善。厌离世间。喜乐闻法。世尊作是念。彼耶舍长者子。当以信出家。便往婆罗水边敷草坐宿。时彼长者子五欲自娱已便得暂眠。一切伎直悉皆眠卧。长者子须臾便觉。视己屋舍犹若丘冢。观诸伎直皆如木人。更相荷枕鼻涕目泪口中流涎。琴瑟筝笛乐器纵横。甚大惊怖生厌离心。走向父所住处。见亦如是。益生厌离。即便向合。合忽自开。向门及大城门皆自然开。迳趣婆罗水边高声大唱。我今忧厄无所归趣

尔时世尊伸金色臂招言。童子来此此处无为无有忧厄。耶舍闻佛语声。一切忧厄豁然消除。即脱琉璃屐着于岸边渡水诣佛。遥见世尊姿容殊特。犹若金山生欢喜心。到已头面礼足却坐一面。佛为说种种妙法示教利喜。次说四谛苦集灭道。即于坐上远尘离垢得法眼净。后伎直觉。共求耶舍不知所在。白其父母。父母四向推求络绎而追。兼募人言。若知我子所在。即以其身所著宝衣与之。其父夜至城门。待开出城。见其屐迹寻迹追之。既到水边见琉璃屐在岸上。乍喜乍悲即舍屐渡水。佛遥见之。恐坏子善心。化令有障使子见父而父不见子。父问佛言。沙门见我子不。佛言且坐。若在此者何忧不见。闻此语已念言。沙门必不妄语。便前礼佛足却坐一面。佛为说种种妙法示教利喜。所谓施论戒论生天之论。五欲过患出生诸漏。在家染累出家无著。说如是种种助菩提法。然后更说诸佛常所说法。所谓苦集尽道。彼即于坐上远尘离垢得法眼净见法得果。见法得果已。受三自归次受五戒。是为诸优婆塞于人中耶舍父最初受三归五戒。耶舍闻佛为父说四真谛法漏尽意解。然后令其父子两得相见。父语子言。汝起还家。汝母失汝忧愁殆死。佛语其父言。若人解脱于漏。宁能还受欲不。答言。不能。佛言。我为汝说法。时耶舍观诸法漏尽心得解脱。其父白佛言。佛为我说法而使耶舍快得善利。于是耶舍从坐起。白佛言。世尊。愿与我出家受具足戒。佛言。善来比丘。乃至钵盂在手。亦如上说。尔时世间有七阿罗汉

时耶舍父从坐起顶礼佛足。白佛言。惟愿世尊。与耶舍受我明日食。佛默然受之。更顶礼足绕三匝而去。还家办种种多美饮食。佛至时将耶舍着衣持钵往到其家就座而坐。长者夫妇手自下食。食已行澡水毕。妇取小床于佛前坐。佛言。姊妹汝归依佛归依法归依比丘僧。即受三归次受五戒。是为耶舍母初受三自归五戒。尔时世尊为耶舍母举家大小。说种种妙法示教利喜。皆远尘离垢得法眼净。见法得果。见法得果已。皆受三自归次受五戒。尔时耶舍有四友人。一名满足。二名善博。三名离垢。四名牛主。闻耶舍于沙门瞿昙所出家修梵行。共议言。其道必胜。乃使豪族不顾世荣。我等可共到大沙门所净修梵行。四人欣悦慕道于心。便往耶舍所问言。汝所修梵行。岂能具足为最胜乎。答言。此道无量为最胜也。便将四人往到佛所。顶礼佛足却住一面。佛为说种种妙法示教利喜。皆于坐上远尘离垢得法眼净。见法得果。见法得果已。顶礼佛足。白佛言。世尊。愿与我出家受具足戒。佛言。善来比丘。乃至钵盂在手。亦如上说。受戒未久勤修不懈得阿罗汉。尔时世间有十一阿罗汉。耶舍昔所交游。复有五十人。闻耶舍于瞿昙所修行梵行。共议出家乃至得阿罗汉。皆如上说。尔时世间有六十一阿罗汉

相师阿夷知菩萨成佛。当在波罗奈国仙人鹿苑中转于法轮。又念。我命过后诸弟子中那罗摩纳当绍继我。我之供养悉当属彼。彼必贪着无复忆佛出兴世意。我今宁可于鹿苑边为立舍宅。教令日日三念佛当出世。若出世时汝当于彼净修梵行。念已即为立宅。如念教之。阿夷不久便命过。那罗果得供养贪着心深。都不复忆佛当出世

时伊罗钵龙王作是念。昔迦叶佛记我。于当来过百千万亿岁。释迦牟尼佛出现于世。佛当记汝脱龙身时。时今应至当往见佛。彼龙为见佛故。于六斋日在恒水中。用金钵盛银粟。银钵盛金粟。又庄严二女。而说偈言

  何者王中上　　染与非染等
  云何得无垢　　何者名为愚
  何者流所[漂*寸]　　得何名为智
  云何流不流　　而名为解脱

龙王说此偈已念言。若人有能解此偈者即是佛。若从佛闻必示我佛处。我今不见余沙门婆罗门诸天魔梵一切世间有能解此偈者。念已唱言。若有能解此偈。我当与金银钵满金银粟及此二女。尔时众多余沙门婆罗门长者居士竞欲为龙解此偈义。龙王为说皆不能解。尔时那罗摩纳。为摩竭国人所共宗敬。皆言。此摩纳有大知见。必能解之。便共往请。摩纳念言。我为一国所宗。若言不能。便当为彼众人所弃。我虽未解当作方便保全此誉。便语众人。汝皆共我往到龙所。我当解之。于是众人与摩纳俱恭敬围绕。往到龙所语龙言。可说汝偈我当敷演。龙即说偈。摩纳言。此甚易解。我七日后当来解之。即诵其偈。先问余沙门婆罗门不兰迦叶六师等。悉不能解。皆诡嗔骂咸言。无义欲以掩藏不解之短。摩纳复念言。师昔告我佛当出世于彼净修梵行。今沙门瞿昙在鹿苑中。必能解之。我当往问。复作是念。此六师等年耆博见。尚不能解。况沙门瞿昙既自年少。出家始尔而能解乎。复念。明闇自然不可以先后相挌。瞿昙虽少不可轻也。念已便到佛所。顶礼佛足却住一面。说龙王偈。以问于佛。佛即为说

  第六王为上　　染者与染等
  不染则无垢　　染者谓之愚
  愚者流所[漂*寸]　　能灭者为智
  舍流不复流　　是名为解脱

摩纳闻说偈已。深知是佛诵习受持。至第七日往到龙所。时八万四千人。在恒水两岸欲听摩纳解说偈义。摩纳更语龙言。说汝先偈。龙王便说。摩纳即说佛所说偈。而为解之。龙王闻偈欢喜踊跃念言。佛已出世。我今便为已得见佛。所以者何。我不见余沙门婆罗门诸天魔梵。一切世间。有能解此义者。念已问摩纳言。汝实语我。汝所说偈为从谁闻。我今不见诸余沙门婆罗门。一切世间有能说此偈者。唯除佛若从佛闻。答言。我实语汝。佛已出世我从其闻。龙王欢喜问言。佛今在何处我欲见之。摩纳胡跪舒右手指佛处方言。佛今在彼。龙王益复欢喜。三返称南无如来应供等正觉。便语摩纳言。汝可送我往至佛所问讯世尊。答言可尔。龙王即自复身。身体长大眼如大钵喘息如雷。口出火光水中逆上。八万四千人皆亦随从既达渚。次化作转轮圣王上岸诣佛。遥见世尊姿容殊特犹若金山。龙王欢喜加敬无量。佛见龙王称其名。曰善来伊罗钵龙王。龙王闻已复加喜敬。世尊知我名。修伽陀识我名。前顶礼足却住一面。更说本偈以问于佛。佛为说摩纳所受之偈。龙王闻已先大欢喜然后悲泣。佛问龙王。何故须臾乍喜乍悲。答言。世尊。我忆过去迦叶佛所净修梵行。于后时捉紫华茎往到佛所问言。世尊。若比丘杀此草得何等罪。佛答我言。以此因缘或有堕最苦地狱者。我闻此语不信不敬。便故刺伊罗树叶作是念。试看有何果报。竟不舍此见亦不悔过。命终之后今生长寿龙中。因是业故。名我为伊罗钵龙。既受身已复往佛所问言。我何时当得脱此龙身。佛答我言。当来过于百千亿万岁。有释迦牟尼佛出现于世。彼佛当记汝得解脱。时我今既见世尊生希有心。始知诸佛言无虚妄。是以欣笑。又念昔违佛教。今复不能受佛明戒。是以悲泣。复白佛言。愿记我何时当得脱此龙身。佛言。当来过百千亿万岁。有弥勒佛出现于世。汝于尔时得脱龙身。出家受戒广修梵行得尽苦源。佛便为龙受三自归为优婆塞。复为八万四千人。说种种妙法示教利喜。所谓施论乃至出要为乐。皆欢喜已。更为说诸佛常所说法苦集尽道。八万四千人即于坐上远尘离垢得法眼净。见法得果。见法得果已。受三自归次受五戒。于是龙王语摩纳言。汝今何为须此龙女。龙女多恚。或以毒火共相伤害。随汝所须金银宝物尽当相与。答言。止止龙王。我不须龙女亦不须金银。我闻佛最后说偈。得离欲界欲故。佛说法已语龙王言。汝可还归所住。龙王受教顶礼而退。龙王去后。摩纳前礼佛足白佛言。世尊。愿与我出家受具足戒。佛言。善来比丘。乃至钵盂在手。亦如上说。出家未久。勤行不懈。得阿罗汉。尔时世间有六十二阿罗汉。于是世尊从鹿苑渐渐游行到娑罗林在树下坐。去林不远有一园观。时有同友三十人。各将其妇于中游戏。一人无妇。雇一淫女假好衣服共游此园。方欲极情肆乐。而彼淫女着其好衣忽然叛去。相助追觅至娑罗林。遥见世尊姿容挺特犹若金山。见已生希有心。皆到佛所顶礼佛足却坐一面。问佛言。大沙门见有一女人来不。佛言。宁欲自求为欲求他。答言。我宁自求不求妇女。佛言。且坐为汝说法。皆受教更礼而坐。佛为说种种妙法示教利喜。乃至苦集尽道。三十人皆远尘离垢得法眼净。见法得果。见法得果已。白佛言。愿与我出家受具足戒。佛言。善来比丘。乃至得阿罗汉亦如上说。尔时世间有九十二阿罗汉。时复有六十人为婚姻事行过娑罗林。遥见世尊姿容挺特犹若金山。皆前到佛所顶礼佛足。佛为说法乃至得阿罗汉皆如上说。尔时世间有百五十二阿罗汉

五分律卷第十五五分律卷第十六(弥沙塞)

        宋罽宾三藏佛陀什共竺道生等译

    第三分初受戒法中

于是世尊告诸比丘。汝等各各分部游行世间。多有贤善能受教诫者。吾今独往优为界郁鞞罗迦叶所而开化之。诸比丘受教分部而去。世尊便到迦叶所。迦叶事一毒龙。着别静室无敢入者。唯除迦叶。佛故投暮往到其所。求索寄止。龙室中宿。答言。甚不爱也。中有毒龙恐相害耳。佛言。无苦龙不害我。答言。若不畏者随意入宿。佛即持草入室敷座而坐。作是念。我当稍化龙身使形如櫡。内于钵中以调伏彼。适坐须臾龙大嗔忿身皆烟出。佛亦出烟。龙举身火然。佛亦举身出火。二火俱盛龙室炯然。时迦叶及诸弟子来绕龙室悲叹言。可惜大沙门不用我语为龙所害。明旦佛以钵盛龙而出。语迦叶言。此钵毒龙众人所畏今以降矣。迦叶心念。是大沙门虽神。不如我道真。世尊即以神力如力士屈伸臂顷。持龙着世界中间还迦叶所。迦叶问佛。龙着何所。答言。置世界中间。迦叶复念。是大沙门极神。须臾之间持龙乃着世界中间。虽然故不如我已得阿罗汉道

迦叶白佛。愿大沙门住此我自供养佛言。汝若能日日自来请我当受汝请。答言甚善。去迦叶不远有一茂林。佛于中止。夜四天王来下侍卫并欲听法。四天王光明犹四火聚。迦叶夜起见佛边。有似四大火聚。不知何等。明日请佛白言。食具已办愿见顾食。又问。昨夜此间有四光聚。似火而非为是何等。佛言。昨夜四天王来下供养听法是其光耳。迦叶复念。是大沙门极大威神。乃使四天王自来供养。虽然故不如我已得阿罗汉道。佛语迦叶。汝且前去吾随后到。迦叶适去。佛如屈伸臂顷到阎浮提树取其果还。迦叶未至已在其坐。迦叶后至见佛问言。我不从余道还。亦无经过处。不见大沙门。大沙门为复何道来。佛言。汝适去后。我至阎浮提树取其果还。香美可食。今以与汝可试食之。迦叶复念。大沙门有大神力。然不如我已得阿罗汉道

佛食已还彼林中。夜释提桓因自下侍卫并欲听法。帝释光明遍照林中倍四天王。迦叶夜见亦复不知是何等光明。日复来请佛白。食已办并问光意。佛言。昨夜释提桓因供养听法是其光耳。迦叶复念。是大沙门神则神矣。乃使帝释自来供养。然不如我已得阿罗汉道。佛语迦叶。汝且前去吾随后到。迦叶适去。佛到阎浮提边诃梨勒林取其果还。迦叶未至已在其坐。迦叶后至如上而问。佛言。汝适去后。我到阎浮提边诃梨勒林取其果还。香美可食。今以与汝可试食之。迦叶复如上念。佛食已还彼林中。夜娑婆世界主梵天王自下侍卫并欲听法。梵王光明倍于帝释。迦叶夜见亦复不知是何等光明。日复来请佛白。食已办并问光意。佛言。昨夜梵天王来下供养听法是其光耳。迦叶复念。是大沙门神则神矣。乃使梵王自来供养。然不如我已得阿罗汉道。佛语迦叶。汝且前去吾随后至。迦叶适去。复到阎浮提边阿摩勒林取其果还。余如上说

佛食已还彼林中。尔时世尊须水澡洗。尼连禅河自然曲流。经佛边过令佛得用。明日迦叶复来请佛白食已办。见河曲流即问。谁曲此流。佛言。我昨须水水自曲来。迦叶复念。是大沙门神则神矣。发心念水水为曲流。然不如我已得阿罗汉道。佛语迦叶。汝且前去吾随后到。迦叶适去。佛到俱耶尼取彼牛乳。余如上说

佛食已还彼林中。尔时有斯那婆罗门婢死弃衣冢间。佛取持还。念当于何浣。适发心时。释提桓因来下以手指地水出成池。白佛言。可于此浣。阿毗释迦山神送大石盆。亦白佛言。可用浣之。复念我拄何物用浣此衣。去池不远有柯睺树。其神曲枝令佛攀之。佛浣衣竟于虚空中晒。迦叶明日复来请佛白食已办。见浣衣事皆以问佛。佛具以答。迦叶心念如前。佛语迦叶。汝且前去吾随后到。迦叶适去。佛到郁单越取自然粳米。余如上说。佛食已还彼林中。尔时迦叶明日节会。念言。今不请佛。若众人见者。必当舍我竞奉事之。便止不请。佛即遥知。复到郁单越取食而食。过其日已。迦叶复来请佛白食已办。又问。佛昨不来竟于何食。佛言。汝昨节会念言。佛若来者众人共见。必当舍我竞奉事之。是故我到郁单越取食而食。迦叶复念。是大沙门神则神矣。乃知人念。然不如我已得阿罗汉道。于是佛与迦叶俱到其家食已还彼林中。尔时迦叶五百弟子皆共破薪而斧不举。以事白师。师言。恐大沙门所为。汝往问之。即以问佛。佛问欲使举不。答言欲举。佛言。可去斧自当举。既举复不肯下。复以白师。师教问佛。佛问欲使下不。答言尔。佛言。可去斧自当下。既下斧皆着薪又不得举。复以白师。师教问佛。佛问欲使举不。答言尔。佛言。可去自举得用。即皆得用。复欲然火火不肯然。复以白师。师教问佛。佛问欲使然不。答言尔。佛言。可去火自当然。火即自然。既然复不肯灭。复以白师。师教问佛。佛问欲使灭不。答言尔。佛言。可去火自当灭。火即自灭。复欲泻水灭炭。水住瓶中终不肯出。复以白师。师教问佛。佛言。欲使出不。答言尔。佛言。可去水自当出。水即自出。既出复不肯止。复以白师。师教问佛。佛言。欲使止不。答言尔。佛言。可去水自当止。水即自止。尔时黑云大雨七日。佛所住林及迦叶家浩成一水。迦叶恐佛为水所漂乘船来视。乃见世尊在尼连禅河水上经行。迦叶复念。是大沙门神则神矣。水大瀑涨不为漂没乃方在上经行。然不如我已得阿罗汉道

于是世尊。飞升虚空告迦叶言。汝非罗汉。何为虚妄自称得道。迦叶白言。实尔世尊。实尔世尊。复白佛言。愿得于大沙门所出家受具足戒。佛言。报汝弟子未。答言未。佛言。可先报之。迦叶受教。即还语弟子言。汝等知不。我欲于大沙门所净修梵行。汝等从我为善不乐随意。五百弟子同声言。我等见佛降龙已生信心但待师耳。愿皆随从。于是师徒共往佛所。白佛言。我等师徒俱欲出家受具足戒。佛言。善来比丘。受具足戒。于我善说法律。能尽一切苦净修梵行。迦叶及五百弟子须发自堕袈裟着身钵盂在手。既受戒已以先被服事火之具。皆弃尼连禅河中。是为迦叶及五百弟子受具足戒

迦叶有二弟。大名那提迦叶。小名伽耶迦叶。大弟有三百弟子。小弟有二百弟子。去兄一由旬居在下流。见兄事火之具随水来下。恐兄为恶人所害大水所漂。二弟即将五百弟子逆水而上。见兄师徒皆作沙门怪而问之。何故如此。答言。此道最胜出要之法无有过者。二弟及其五百弟子皆共议言。我兄智慧第一而今乐之此道必胜。皆当相与同兄出家。即共诣佛顶礼佛足。白佛言。愿与我等出家受具足戒。佛言。善来比丘。乃至钵盂在手。亦如上说

于是世尊作是念。何处多有饮食卧具。于中教诫此故梵志千比丘僧。彼伽耶山多有饮食卧具。念已将千比丘往到彼所。以三事教诫。一者神足教诫。二者说法教诫。三者教敕教诫。何谓神足教诫。如神通中说。何谓说法教诫。言比丘当思是。不可思是。当忆念是。不忆念是。当修是。当断是。当依是行。何谓教敕教诫。言比丘一切炽然。云何一切炽然。眼炽然色炽然。眼识眼触眼触因缘生受亦炽然。以何炽然。欲火炽然嗔欲痴欲炽然。乃至意法亦如是。圣弟子闻如是法。生于厌离无有染着。便得解脱解脱智生。所作已办梵行已立不复受有。说是法时。千比丘漏尽心得解脱也

尔时世尊作是念。吾昔与瓶沙王要得道度之。今应诣彼。便与千比丘前后围绕渐渐游行向王舍城。瓶沙王闻佛成道度优为迦叶兄弟三人及千弟子今来此邑。即敕国界四万二千聚落。一聚落出豪杰二人出共迎佛。八万四千人乘象马车前后导从。尔时春末月热已极盛。众人各念。愿得微阴。时释提桓因知彼念。即化作云盖凉风微起。自化为梵天。着黄色衣执七宝杖七宝柄拂。离地一肘于佛前导。时摩竭人欲当佛前帝释驱逐。悉皆嫌之而说偈言

  形如梵天像　　执杖而蹑虚
  口宣柔软语　　是谁之给使

时释提桓因以偈答言

  解说一切缚　　最上调御士
  应供已善逝　　我为彼给使

时瓶沙王作是念。佛止宿处。我当即以此处施佛立于精舍。佛知其意暮宿迦兰陀竹园。于时大众咸生疑念。不知佛与优为迦叶谁是弟子。佛知众念。便向优为迦叶而说偈言

  优为汝何见　　而舍事火法
  吾今亲问汝　　汝可如实答

优为迦叶以偈答言

  常贪于美味　　心驰声色中
  我见有斯垢　　故舍事火业

尔时大众虽闻佛与迦叶各说一偈。未悟义旨犹有疑虑。佛知众心复以偈问

  五味甘人口　　声色悦人心
  汝见此为垢　　于何而得无

优为迦叶复以偈答

  我见休息道　　一切无有着
  不异不可异　　于此舍火祠

尔时大众虽重闻偈犹怀犹豫。佛知其心便告迦叶。汝起扇佛。即受教起扇。又语迦叶。现汝神变。即复示现种种神化。分身百亿还合为一。石壁皆过。入地如水履水如地。坐卧空中如鸟飞翔。举身炯然烟若云起。手扪日月平立至梵自在无碍。或身上出水身下火然。或身上火然身下出水。然后来下稽首佛足。右绕三匝长跪合掌。白佛言。世尊是我师。我是世尊弟子。如是三白已。语大众言。吾之所知下及神变皆大师恩。于是大众始知迦叶是佛弟子。便于佛所喜敬无量。诸佛常法。人心未转不为说法。佛知大众既已喜敬。为说种种妙法示教利喜。及说佛常所说法苦集尽道。瓶沙王及八万四千人。即于坐上远尘离垢得法眼净。见法得果已受三自归及受五戒。于是瓶沙王稽首。请佛及僧明日中食。佛默然受。欢喜还宫。敕办种种美膳。明旦于竹园敷座。自出白食具已办。佛与大众随次而坐。王手自斟酌欢喜无惓。食已行水在一面立。白佛言。今以此竹园奉上世尊。佛言。可以施僧其福益多。王复白佛。愿垂纳受。佛言。但以施僧我在僧中。王便受教。以施四方僧。然后取小床于佛前坐。为说随喜咒愿偈。如为毗兰若所说。已更为说种种妙法遣还所住。王从坐起顶礼佛足右绕三匝而退

尔时世尊在罗阅只竹园精舍。彼有一邑名那罗陀。有故梵志名曰沙然。受学弟子二百五十。门徒之中有二高足。一名优波提舍。二名拘律陀。尔时頞鞞着衣持钵入城乞食。颜色和悦诸根寂定。衣服齐整视地而行。时优波提舍出游。遥见頞鞞威仪庠序叹未曾有。待至便问。何所法像衣服反常。宁有师宗可得闻乎。頞鞞对曰。瞿昙沙门是我大师。我等所尊从而受学。优波提舍言。汝等大师说何等法。頞鞞言。我年幼稚学日初浅。岂能宣师广大之义。今当为汝略说其要。我师所说。法从缘生亦从缘灭。一切诸法空无有主。优波提舍闻已。心悟意解得法眼净。便还所住为拘律陀说所闻法。拘律陀闻。亦离尘垢得法眼净。即问言。如来游化今在何住。答言。今在迦兰陀竹园。拘律陀言。如来是我等师。便可共往礼敬问讯。优波提舍言。二百五十弟子。师临终时嘱吾等成就。岂可不告而独去乎。二人即往弟子所语言。我等欲从瞿昙沙门净修梵行。汝等各各随意所乐。时二百五十弟子皆悉乐从。二人便将弟子俱诣竹园。世尊遥见告诸比丘。彼来二人。一名优波提舍。二名拘律陀。此二人者。当于我弟子中为最上首。智慧无量神足第一。须臾来到。佛为渐次说法。布施持戒生天之论。诃欲不净赞叹出离。即于坐上漏尽意解。皆前白佛。愿得出家净修梵行。佛言。善来比丘。于我法中修行梵行。得尽苦源即名出家受具足戒

尔时世尊游罗阅只。郁鞞罗迦叶兄弟及千弟子。舍利弗目揵连及二百五十弟子。皆出家学道。罗阅只诸豪贵族姓长者居士。亦皆出家。大众围绕集于彼国。而为说法

佛在王舍城。尔时世尊未教诸比丘有和尚阿阇梨。无和尚阿阇梨故。威仪失节。着上下衣皆不如法。不知净不净事。不系念在前。不善护诸根。入聚落乞食受不净食。自手取食不从人受。人授食时就彼手中抄拨而取。手捻钵缘不擎钵受。食时高声乱语。不信乐佛法者讥诃言。此诸沙门甚于外道。无有威仪乃至高声乱语。无沙门行破沙门法。其所不经过处皆得善利。复有一病比丘。无瞻视者由此命过。诸长老比丘闻种种诃责。以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言。实尔世尊。佛种种诃责言。汝等云何散乱其心。行止坐卧皆不如法。诃已告诸比丘。若披着上下衣不如法。乃至食时高声乱语皆突吉罗。从今以十利故。听诸比丘有和尚。和尚自然生心爱念弟子如儿。弟子自然生心敬重和尚如父。勤相教诫更相敬难。则能增广佛法使得久住

请和尚法。应偏袒右肩脱革屣胡跪两手捧和尚足作是言。我某甲今求尊为和尚。尊为我作和尚。我乐尊为和尚依止。尊为和尚故。得受具足戒。如是三求。和尚应答言可尔。当教诫汝。汝莫放逸

弟子应承奉和尚。若不白和尚入聚落突吉罗。若欲共余比丘行。亦应白和尚。若不白若不听而去皆突吉罗。若余比丘呼共行亦如是。若欲就余比丘取衣钵革屣之属亦应白。若不白若白不听而取皆突吉罗。若欲与余比丘衣钵亦如是。若余比丘欲为担衣钵及为取亦应白。若不白若白不听而辄作皆突吉罗。若余比丘请担衣钵及令取亦如是。凡有所作乃至剃头若为人剃皆应白。唯除大小便及用杨枝。若和尚犯粗恶罪。弟子应勤作方便令速除灭。若不作方便突吉罗。若僧应与和尚作别住。若行摩那埵。若行本日。若行阿浮诃那。弟子应勤作方便求僧速与作别住乃至阿浮诃那。若不勤作突吉罗。若和尚出罪之日。弟子应为扫洒敷坐办舍罗筹集僧。求羯磨比丘。若不尔突吉罗。若僧与和尚作诃责羯磨驱出羯磨依止羯磨举罪羯磨下意羯磨。弟子应勤求僧令莫作。若不求僧突吉罗。若僧必应作此诸羯磨。弟子应求莫违法。若不求突吉罗。若和尚病。弟子应扶侍左右。若和尚有物。应白取易随病食随病药。若和尚无物。自有应为易。若复自无。应为索。又应朝暮为病和尚说法。和尚病未差不得游行。若不尔突吉罗。若弟子犯粗恶罪乃至病未差。和尚看视亦应如是

尔时诸比丘一语授戒言。汝归依佛。又有比丘二语授戒言。汝归依佛归依法。又有比丘三语授戒言。汝归依佛归依法归依僧。以是白佛。佛言。不应一语二语三语授戒。又有比丘作善来比丘授戒。诸长老比丘诃责。汝云何如佛作善来比丘授戒。以是白佛。佛言。不应作善来比丘授戒

尔时诸比丘作是念。但佛与比丘授戒。我等亦得。若得者应云何授。以是白佛。佛言。今听汝等与比丘授戒。应作白四羯磨授。欲授戒者。偏露右肩脱革屣礼僧右膝着地作是白。大德僧听。我某甲。从某甲和尚受具足戒。今从僧乞受具足戒。愿僧济度我。慈愍故。如是三白。众中应一知法比丘若上座若上座等僧中白言。大德僧听。此某甲欲受具足戒。某甲为和尚。僧今与某甲受具足戒。和尚某甲。若僧时到僧忍听。白如是。大德僧听。此某甲欲受具足戒。某甲为和尚。僧今与某甲受具足戒。和尚某甲。谁诸长老忍默然。若不忍者说。第二第三亦如是。僧已忍某甲受具足戒和尚某甲竟。僧忍默然故。是事如是持。时诸比丘便四人乃至九人。与一人乃至众多人授具足戒。诸长老比丘诃责。以是白佛。佛言。听十众授具足戒。诸比丘便以非人白衣灭摈人被举人自言人不同见人狂人散乱心人病坏心人比丘尼式叉摩那沙弥沙弥尼足为十众授具足戒。以是白佛。佛言。应如法比丘十人授具足戒。诸比丘授眠人醉人狂人散乱心人病坏心人异见人具足戒。以是白佛。佛言。不应授眠人乃至异见人具足戒。应如法十比丘授如法人具足戒。诸比丘以眠人醉人狂人散乱心人病坏心人为和尚。以是白佛。佛言。不应以此人为和尚。诸比丘复以二人乃至十人为和尚。以是白佛。佛言。应以一人为和尚。不应以二人乃至十人。有诸人欲受具足戒。不能得集十如法比丘。作是念。若佛听我于布萨时自恣时僧自集时受具足戒者无如是苦。以是白佛。佛言。听因布萨时自恣时僧自集时受具足戒

时六群比丘与其和尚阿阇梨不和合。便与受戒人作难。以是白佛。佛言。受戒人若无难不应为生难。若为生难突吉罗。复有诸比丘。以小似片事强与受戒人作难。或言似瞎或言以跛。见其短小便言未满二十。或言父母似未听出家。以是白佛。佛言。不应以小似片事与受戒人作难。若作难突吉罗。诸比丘犹为作难。以是白佛。佛言。若合和尚阿阇梨意应与受戒

复有诸比丘。于界内作别众授戒。以是白佛。佛言。应出界外白二羯磨作小界授戒。先应一比丘唱四方界相。一比丘白。大德僧听。如某甲比丘所唱界相。今僧结作戒坛共住共布萨共得施。若僧时到僧忍听。白如是。大德僧听。如某甲比丘所唱界相。今僧结作戒坛共住共布萨共得施。谁诸长老忍默然若不忍说。僧已结某甲比丘所唱界相作戒坛共住共布萨共得施竟。僧忍默然故。是事如是持。诸比丘既结戒场不舍而去。以是白佛。佛言。应白二羯磨舍界而去。一比丘白。大德僧听。此结界处。僧今舍是界。若僧时到僧忍听。白如是。大德僧听。此结界处。僧今舍是界。谁诸长老忍默然若不忍者说。僧已舍是界竟。僧忍默然故。是事如是持。时诸比丘将欲受戒人至受戒处。语上座言。为作羯磨。答言。我不诵羯磨。乃至下座亦如是。不得为受戒。以是白佛。佛言。皆应诵羯磨。若十岁已后不诵突吉罗。诸比丘将二欲受戒人至受戒处。欲为受戒二人诤先不得为受。以是白佛。佛言。先到受戒处者应先与受戒。若二人俱到。年大者应先与受。若同年。和尚大者应先与受。若和尚复同。应一时羯磨。先称名者先受。三人亦如是。优波离问佛。余事亦得羯磨三人不。佛言得。又问。得与四人作羯磨不。佛言。一切不得羯磨四人

诸比丘将欲受戒人至受戒处。欲为受戒遇贼被剥殆死而还。诸比丘作是念。若世尊听我等于僧坊内立受戒坛者不遭此难。以是白佛。佛言。今听于僧坊内白二羯磨结作受戒场。应先白二羯磨舍僧坊界。一知法比丘唱言。大德僧听。此一住处僧共住共布萨共得施。先结此界今解。若僧时到僧忍听。白如是。大德僧听。此一住处僧共住共布萨共得施。先结此界今解。谁诸长老忍默然若不忍者说。僧已解先所结界竟。僧忍默然故。是事如是持。解僧坊界已然后结戒场。应一比丘唱戒坛四方相。更一比丘白二羯磨如上说。结戒坛已更结僧坊界。应一比丘唱四方界相。又唱除内地。更一比丘白。大德僧听。此某甲比丘唱四方界相及除内地。今僧结作大界共住共布萨共得施。若僧时到僧忍听。白如是。大德僧听。此某甲比丘唱四方界相及除内地。今僧结作大界共住共布萨共得施。谁诸长老忍默然若不忍者说。僧已结某甲比丘唱四方界相及除内地。作僧大界共住共布萨共得施竟。僧忍默然故。是事如是持

尔时有一外道摩纳。欲于正法中出家受具足戒。到舍利弗所白言。与我出家受具足戒。舍利弗不为受。如是遍至五百比丘所。皆不与受。便啼哭还归。佛以天眼观见。问舍利弗言。此摩纳何故哭啼而归。具以事答。又问。此人曾有一善言向诸比丘不。答言有。又问。有何善言。答言。我先乞食此人赞我言。此沙门释子善好有德应与食。佛言。此恩应报汝可度之舍利弗受教。即与受具足戒。复有一外道摩纳。薄福乞食不能得。作是念。沙门释子乞食易得。病瘦医药人所乐与。我今宁可就彼出家受具足戒。念已便到僧坊。白诸比丘言。与我出家授具足戒。诸比丘即与授具足戒。薄福故遇僧次请食断。诸比丘语言。汝可着衣持钵乞食。答言。大德我畏乞食故。于佛法中出家。而今云何教我乞食。诸长老比丘呵责。云何度不能乞食人。以是白佛。佛言。不应度此人。度者突吉罗。若度人时应先问。汝为何等出家。若言为饮食故不应度。若言为求善法厌生老病死忧悲苦恼者。此应度。若授具足戒时应先为说四依。依粪扫衣依乞食依树下坐依残弃药。能尽寿依此四事不。若言能。应为授。若言不能。不应为授。有大长者婆罗门厌患世间。作是念。沙门释子等行正法广修梵行。于彼出家得尽苦际。念已即到僧坊。求出家受具足戒。诸比丘言。如来应供等正觉说四依。汝若能尽寿依此。当与汝出家授具足戒。婆罗门言。云何为四依。诸比丘即为说。婆罗门言。此四依世所薄贱。我等不能依此。复言。若大德先与我授具足戒。然后说者我不获已或能行之。于是还归。诸比丘念言。佛若听我等受具足戒已然后为说四依者。不使此人于佛法退。以是白佛。佛言。听受具足戒已然后说四依

尔时诸比丘受具足戒已在前还归新。受戒人于后见昔私通淫女。淫女言。汝不能生活故入道耶。答言。我厌生老病死忧悲苦恼欲尽苦源故。于此中等行正法广修梵行。彼女复言。若如汝语交会无期。今可共我作最后行欲。即共行之际暮乃还。诸比丘问。汝何故住后。彼以实答。诸比丘便驱出言。汝出去汝灭去。比丘法中若行此事。非沙门非释种子。彼比丘闻闷绝躄地作是言。若受戒时语我者。正使失命岂当犯此。诸比丘以是白佛。佛言。受具足戒竟便应为说十二法四堕法四喻法四依法

尔时佛未听诸比丘有阿阇梨。诸比丘和尚丧。以无和尚阿阇梨故。披着上下衣不如法乃至食时乱语皆如上说。诸长老比丘以是白佛。佛言。从今以十利故。听诸比丘有阿阇梨。阿阇梨自然生心视弟子如儿。弟子自然生心视阿阇梨如父。事事如和尚中说。佛既听有阿阇梨。不知有几种阿阇梨。以是白佛。佛言。有五种阿阇梨。出家阿阇梨。教授阿阇梨。羯磨阿阇梨。受经阿阇梨。依止阿阇梨。诸比丘不知云何是出家乃至依止阿阇梨。以是白佛。佛言。始度受沙弥戒。是名出家阿阇梨。受具足戒时教威仪法。是名教授阿阇梨受具足戒时为作羯磨。是名羯磨阿阇梨。就受经乃至一日诵。是名受经阿阇梨。乃至依止住一宿。是名依止阿阇梨。佛既听有依止阿阇梨。便依止比丘尼式叉摩那沙弥沙弥尼狂心乱心病坏心人被举人灭摈人异处住人别住人行摩那埵人行本日人应出罪人自言人多人语人诸羯磨人。以是白佛。佛言。不听依止如上诸人。唯听依止如法比丘

此中有成乞依止。有不成乞依止。有成与依止。有不成与依止。有成受依止。有不成受依止。不成乞依止者。若比丘从比丘尼乞依止。若从式叉摩那沙弥沙弥尼乃至诸羯磨人乞依止。是名不成乞依止。若从如法比丘乞依止。而不作是语。我某甲今求尊依止。尊为我作依止。我依止尊住。尊当教诫我。我当受尊教诫。是亦不成乞依止。成乞依止者。从如法比丘作如上乞。是名成乞依止

不成与依止者。若比丘尼式叉摩那沙弥沙弥尼乃至诸羯磨人与比丘依止。是名不成与依止。若于如法比丘如法乞竟。彼不语言汝莫放逸。是亦不成与依止。是名不成与依止。成与依止者。于如法比丘如法乞竟。彼言汝莫放逸。是名成与依止

不成受依止者。若比丘从比丘尼式叉摩那沙弥沙弥尼乃至诸羯磨人受依止。皆不名受依止。若于如法比丘不作如上语。我某甲今求尊依止。乃至我当受教诫。亦不成受尊依止。是名不成受依止。成受依止者。于如法比丘作如上语。我某甲今求尊依止。乃至我当受尊教诫。是名成受依止。尔时诸比丘便隔壁障受依止。或不恭敬覆头覆肩着革屣坐卧受依止。诸长老比丘以是白佛。佛言。应偏袒右肩脱革屣胡跪合掌面前作如上语。我某甲今求尊依止乃至我当受尊教诫

尔时六群比丘不敬和尚阿阇梨不敬戒。诸余比丘亦有效者。诸长老比丘以是白佛。佛问六群及诸比丘。汝等实尔不。答言。实尔世尊。佛种种诃责。汝等愚痴。云何不敬师不敬戒。诃已告诸比丘。从今诸比丘若不敬和尚阿阇梨不敬戒突吉罗。诸比丘犹有不敬者以是白佛。佛言。应作不共语法。诸比丘便与作尽形寿不共语法。亦不相见。或驱出所住。亦与痴比丘无罪比丘作不共语法。复不语其罪作不共语法。以是白佛。佛言。不应尽寿与不敬和尚阿阇梨者作不共语法。痴人无罪人不应与作不共语法。亦不应不语其罪作不共语法

不共语有五种。一者语言汝莫共我语。二者汝有所作莫白我。三者莫入我房。四者莫捉我衣钵及助我作众事。五者莫来见我。诸比丘便以小事作不共语法。以是白佛。佛言。不应以小事作不共语法。若弟子成就五事。师应与作不共语法。于师无惭无愧不敬不爱不供养。是为五事。无此五事不应为作不共语法。有诸比丘。既与弟子作不共语法。还复共语共住。弟子倍更憍慢。以是白佛。佛言。不应作不共语竟复还共语。我不欲令彼失依止故作不共语。为调伏休息向泥洹故作不共语法。若还共语突吉罗。复有诸比丘。为弟子作不共语法。余比丘辄与共语。弟子以此倍慢于师。以是白佛。佛言。不应他与弟子作不共语法而共语。佛既不听他人与共语。便以此事还俗或作外道。以是白佛。佛言。若欲教彼悔过于师者听得共语。时有师与弟子作不共语。弟子不肯悔过。以是白佛。佛言。不应不悔过。应作如是悔过。偏袒右肩右膝着地以两手捧师足极自卑下白言。我小我痴后不敢复作。尔时有师不受弟子悔过。以是白佛。佛言。若还有惭愧敬爱供养。不应不受悔过。受悔过者罪则除灭

尔时复有诸师不知弟子犯戒不犯戒。不知悔过不悔过。见弟子犯戒不教诃。以是白佛。佛言。师应知弟子犯戒不犯戒悔过不悔过。见犯戒应教诃。若不知不教诃突吉罗

尔时常住比丘不礼来去比丘。来去比丘亦不礼常住比丘。常住比丘亦不相礼。有一比丘到一住处。不礼诸比丘。诸比丘问言。从何处来。答言某处来。诸比丘言。当知汝住处诸比丘。皆如此憍慢。我等不应共住。以是白佛。佛言应尽礼。若不礼突吉罗。复有诸比丘。或隔壁障礼。或遥礼。或卧口言和南。或直举手。或小低头。诸长老比丘种种诃责。以是白佛。佛言。不应作如是礼。应一心恭敬脱革屣偏袒右肩两膝着地接足而礼。有比丘一一礼诸比丘便失伴。以是白佛。佛言。但礼师总礼余人而去

尔时优波斯那比丘二岁。将一岁弟子到佛所。头面礼足却坐一面。弟子后次礼佛。衣囊堕佛膝上。佛问优波斯那。此是谁弟子。答言是我弟子。佛问汝几岁。答我二岁。又问弟子几岁。答言一岁。佛种种诃责。汝所作非法。云何自未离乳而便乳人。诃已告诸比丘。不应一岁乃至九岁授人具足戒。十岁如法然后得授。若未满十岁及不如法授人具足戒突吉罗。九岁犹应依止他

五分律卷第十六五分律卷第十七(弥沙塞)

        宋罽宾三藏佛陀什共竺道生等译

    第三分初受戒法下

佛在王舍城。尔时有一裸形外道。极大聪明。摩竭国人谓之知者见者。来至僧坊言。沙门释子谁敢共我论议者。时诸比丘游戏诸禅不共论议亦不共语。舍利弗作是念。彼作此语。若无人共论议者必毁辱佛法。我今宁可与共论议。复念。此尼揵为摩竭国人之所宗敬。若我以一句义问不能通者必失名闻不归大法。今当与之七日论议。念已语言。我当与汝七日论议。时王舍城长者居士沙门婆罗门咸共议言。沙门释子舍利弗为第二师。期与尼揵第一师七日论议。当共往听。至期一日至于六日。论说余事皆使结舌。至第七日。舍利弗说欲从思想生。尼揵子说欲从对起。时舍利弗而说偈言

  世间诸欲本　　皆从思想生
  住世间欲本　　而有染着心

尼揵即以偈难

  欲若思想生　　而有染著者
  比丘恶觉观　　便已失梵行

舍利弗复以偈答

  欲非思想生　　从对而起者
  汝师见众色　　云何不受欲

尼揵闻此偈已。不能加报便生善心。欲于佛法出家学道。时跋难陀在彼众中色貌姝长。而舍利弗形容短小。彼作是念。此短小比丘才智若斯。而况堂堂者乎。便往跋难陀所白言。与我出家受具足戒。跋难陀即便度之。舍利弗论议竟。往到佛所头面礼足却坐一面。佛问言。汝何故与尼揵七日论议。具以事答。佛赞言。善哉善哉舍利弗。汝多所怜愍多所利益。彼尼揵比丘。问跋难陀经律悉不能答。便轻贱佛法。谓诸比丘都无所知还复外道。诸长老比丘问诃责言。云何比丘十岁而不知法。不能为弟子解疑使还复外道。以是白佛。佛问跋难陀。汝实尔不。答言。实尔世尊。佛如上诃责已告诸比丘。若自不知法与人出家受具足戒突吉罗

若比丘成就十法得授人具足戒。成就戒成就威仪畏慎小罪。多闻能持佛所说法。善诵二部律分别其义。能教弟子增戒学．增心学．增慧学。能除弟子疑亦能使人除其疑。能治弟子病亦能使人治其病。若弟子生恶邪见能教令舍亦能使人教其令舍。若弟子国土觉起能回其意亦能使人回之。若满十岁若过十岁。又成就十法应授人具足戒。知重罪知轻罪。知粗罪知非粗罪。知有余罪知无余罪。知有羯磨罪知无羯磨罪。知罪因缘。满十岁若过十岁。又成就五法应授人具足戒。能教弟子增戒学增心学增慧学所行审谛系念在前。又成就五法。三法如上。聪明辩才。又成就五法。戒成就定成就慧成就解脱成就解脱知见成就。又成就五法自住戒教他住戒。自住定教他住定。自住慧教他住慧。自住解脱教他住解脱。自住解脱知见教他住解脱知见。又成就五法。成就无学戒众无学定众无学慧众无学解脱众无学解脱知见众。又成就五法。能教弟子增上戒增上梵行。知犯不犯知悔过未悔过。满十岁若过十岁。应授人具足戒。度沙弥为人作依止亦如是

有一出家外道。来到僧坊语诸比丘言。大德与我出家受具足戒。诸比丘不知云何。以是白佛。佛言。应先与作四月日别住白二羯磨试之。若合诸比丘意然后与出家受具足戒。羯磨法应教外道。脱革屣偏袒右肩一一礼僧足。胡跪合掌白言。大德僧听。我某甲先外道今求此法律中出家。从僧乞四月日别住。愿僧怜愍故。与我作别住法。若合诸比丘意然后与我出家受具足戒。如是三乞。应一知法比丘白言。大德僧听。此某甲先外道欲于此法律中出家受具足戒。今从僧乞四月日别住法。僧今与四月日别住法。若合僧意当与出家受具足戒。若僧时到僧忍听。白如是。大德僧听。此某甲先外道欲于此法律中出家受具足戒。今从僧乞四月日别住法。僧今与四月日别住法。若合僧意当与出家受具足戒。谁诸长老忍默然若不忍者说。僧已与某甲外道四月日别住法竟。僧忍默然故是事如是持。不合僧意者。若早入聚落际暮乃归。若数往寡妇淫女年长童女家。数与共语作求色欲种种方便。若闻毁呰本所事外道而怀嗔忿。闻赞叹三宝不喜不乐。不乐比丘威仪。不乐诵习佛经。不乐受教诫。是名不合僧意。若无此名为合。应与出家受具足戒

尔时诸比丘度负债人与受具足戒。受具足戒已入王舍城乞食。债主见语言。汝负我债。谁听汝出家。有言应夺取衣钵捉以付官。或有言已入无畏城应放使去。何以故。瓶沙王有令。若国内有毁辱比丘比丘尼者。当与重罪。债主便讥诃言。此诸沙门。无有可度不可度者。云何度负债人。无沙门行破沙门法。诸长老比丘闻种种诃责。以是白佛。佛问诸比丘。汝等实尔不。答言。实尔世尊。佛种种诃责已。告诸比丘。不应度负债人与受具足戒。度及授具足戒时。皆应先问。汝负债不。若言不负应度应受。若言负不应度不应受。若度若受皆突吉罗。若不问亦如是。度奴亦如是

尔时有一小儿。父母教就师学书及诸技术。彼师兼使余作又数与杖。便舍师归。父母即遣还师所。便作是念。师既苦我父母复不念惜。我今于何许得脱此患。唯当出家受具足戒。念已即往僧坊白诸比丘。与我出家受具足戒。诸比丘即便度之。彼师既失问其父母。父母言。我即遣还何以不至。于是父母及师四出追觅。到僧坊问诸比丘。诸比丘皆言不见。唯师默然而住。不得而归。此儿后入王舍城乞食。师见讥诃言。沙门释子常说不应妄语。如何度我作人而言不见。诸长老比丘闻种种诃责。以是白佛。佛言。不应度他作人亦如上说。从今若度人应房房礼僧自称名字令僧尽识

尔时舍卫城十七群童子不满二十。毕陵伽婆蹉与受具足戒。不堪忍饥唤呼求食。如戒缘中说。与受具足戒时。应问年满二十不

尔时诸比丘。度阿练若贼与受具足戒。后入王舍城乞食。诸居士见言。此人先杀我如是如是。亲里劫我财物。有言应捉付官。乃至告诸比丘。不应度亦如上说。复有诸贼。厌作恶业。求出家受具足戒。诸比丘不知云何。以是白佛。佛言。听将至人不识处与出家受具足戒

尔时有一人为邑里所患。白王。愿王敕之勿复作恶。王言。汝等将来我为汝杀。彼人闻之即便叛走。遍求不得。复以白王。王即与敕令。若有得者听即杀之。彼人复闻作是念。我今于何得全性命。唯有沙门释子道中乃可济耳。便到僧坊求出家。诸比丘即度之。后入王舍城乞食。诸人见便欲捉杀。或有人言。既已出家便是已死不须复杀。或复有言。此人已入无畏城。乃至告诸比丘。不应度亦如上说

尔时跋难陀有二沙弥。一名骞茶。二名磨竭陀。更互行淫。诸长老比丘闻。以是白佛。佛问跋难陀。汝实畜二沙弥不。答言实尔世尊。佛种种诃责已。告诸比丘。不应畜二沙弥。畜者突吉罗

尔时有一家为非人所害。唯有父子二人。父作是念。我家丧破恐殃未已。且复饥穷当于何处得免斯患。复作是念。沙门释子多诸供养疾病医药。我今便可将儿出家受具足戒。念已往到僧坊白诸比丘。与我出家受具足戒。诸比丘便与出家受具足戒。入城乞食一手抱儿一手擎钵。诸白衣见讥诃言。此沙门释子不修梵行。或有言当是未出家时有此儿耳。但诸比丘何不待大然后度之。乃使此人抱儿乞食。谁不谓此破于梵行。诸长老比丘闻以是白佛。佛言。不应度小儿

尔时摩竭国人得七种重病。举身恶疮痈白癞半身枯鬼着赤斑脂出。治此诸病唯有耆域。余无能者。而瓶沙王有令。敕耆域言。汝当治我宫内及比丘比丘尼病。不得治余人。由是诸病人皆求出家受具足戒。诸比丘皆与出家受具足戒。为索药草和合煮捣多事多务妨废行道。诸白衣见讥诃言。此诸沙门如医如医弟子。常合汤药度重病人。无复可度不可度者。无沙门行破沙门法。复有一长者。顿得七种重病。往语耆域为我治之。答言。汝岂不闻王有令乎。长者复言。密为我治。当雇汝百千金钱。答之如初。长者复加二百三百四百五百千金钱乃至合家财物。及于妻子悉为奴婢。答亦如初。彼长者复作是念。如此不果。唯当出家受具足戒。便往僧坊白诸比丘。与我出家受具足戒。诸比丘即与出家受具足戒。耆域为治七日都差。不复得治王宫人。宫人病已有死者。彼长者既差即便还俗。耆域见问言。汝已出家何以罢道。答言。我本无出家意。以汝不肯为我治病故权出家。病既已差是故还俗。于是耆域往到佛所。具以白佛。王若知此罪我不少。愿佛教诸比丘不应度重病人。佛为耆域说种种妙法遣还所住。佛问诸比丘。汝等实度重病人不。答言实尔世尊。佛种种诃责已。告诸比丘。不应度重病人。亦如上说

尔时诸比丘度属官人。后入王舍城乞食。诸居士见识讥诃言。云何沙门释子度属官人。此辈无可度不可度者。无沙门行破沙门法。又阿阇世王有一健将。力当千人。时人号曰千人力士。厌恶世苦作是念。诸沙门释子等行正法。我当往彼出家以尽苦源。即到僧坊求度。诸比丘即便度之。王后欲出军不见此人。即问所属。所属白王。不知所在。王便令曰。若军集不至。当以军法罪之。至军集日复问。彼人来未。答言未来。王言。步军无此人犹如象军无第一象军甲既解。方闻沙门释子度令出家。王便嗔言。如是不久沙门当度我兵尽。王即立严制。若复有度官人者。当折其和尚肋骨截其阿阇梨舌。与余僧重生革沙鞭八下驱出国界。诸长老比丘闻种种诃责。以是白佛。佛问诸比丘。汝等实尔不。答言实尔世尊。佛种种诃责已。告诸比丘不应度属官人。亦如上说

尔时诸比丘长住王舍城。诸居士讥呵言。外道尚知随时移止。沙门释子乐着一处四时不动与世人何异。诸比丘以是白佛。佛告阿难。汝可宣语诸比丘。如来今当游行南方。若欲从者任意同去。阿难受教遍宣此旨。诸比丘中有一岁至九岁聪明惭愧欲学戒者。作是念若我和尚阿阇梨去者当从。不去则止。何以故。若我此请依止彼当复请。则多事多务妨废行道。佛既发行从者甚少。佛与少比丘游行南方。渐渐还王舍城。佛以是事集比丘僧。问阿难言。从我南行比丘何以太少。阿难具以事答。佛种种赞少欲知足赞戒赞持戒已。告诸比丘。成就五法得离依止。戒成就定成就慧成就解脱成就解脱知见成就。皆如得授人戒中说

尔时世尊在释迦国。诸比丘度父母所不听人。诸居士讥呵如上。于后世尊。晨朝着衣持钵到净饭王宫。时罗睺罗母。将罗睺罗在高楼上。遥见佛来语言。汝见彼沙门不。答言见。又语言。彼是汝父。可往索父余财。佛既入宫于中庭露地坐。罗睺罗驰下趣佛。头面礼足立佛影中。白言。是影甚乐愿佛与我父余财。佛语言。汝审欲得不。答言欲得。佛便将还所住告舍利弗。汝可度之。舍利弗白佛。世尊先制不得畜二沙弥。我已有周那不复得度。佛言。今听如汝等能教诫者畜二沙弥。应作如是度。先授优婆塞三归法。教言。我某甲归依佛归依法归依比丘僧。如是三说。复教言。我某甲归依佛已归依法已归依比丘僧已亦三说。我是佛婆伽婆优婆塞。复应教言。我某甲尽寿不杀生尽寿不盗尽寿不邪淫尽寿不妄语尽寿不饮酒。复应教言。我某甲归依佛归依法归依比丘僧。如是三说。我今于释迦牟尼如来应供等正觉所出家作沙弥。和尚某甲。即应语言。尽寿不杀生是沙弥戒。尽寿不盗是沙弥戒。尽寿不淫是沙弥戒。尽寿不妄语是沙弥戒。尽寿不饮酒是沙弥戒。尽寿不歌舞作倡伎乐不往观听是沙弥戒。尽寿不着华香涂身是沙弥戒。尽寿不坐卧高大床上是沙弥戒。尽寿不受畜金银及钱是沙弥戒。尽寿不过时食是沙弥戒。是为沙弥十戒。时净饭王。闻佛已度罗睺罗。便大懊恼。出诣佛所白佛言。佛昔出家尚有难陀。不能令我如今懊恼。难陀已复出家。余情所寄唯在此子。今复出家。家国大计永为断绝。未能忘情何能自忍。王又推己而白佛言。子孙之爱彻过骨髓。如何诸比丘诱窃人子而度为道。愿佛从今敕诸比丘。父母不听不得为道。佛为王说种种妙法示教利喜已。辞退还宫。即以是事集比丘僧。问诸比丘。父母不听汝等实度与受具足戒不。答言实尔世尊。佛种种诃责已。告诸比丘。从今父母不听不得度。亦如上说

尔时王舍城有大富长者。信乐佛法常饭食比丘比丘尼优婆塞优婆夷。后为非人所害。唯二小儿在。遂大贫穷恒拾残食。二儿先数见诸比丘故。遥见比丘便走往趣。为捉衣钵坐比丘膝上。诸比丘恐污衣钵辄避远去。诸居士见讥诃言。此家先富。一切沙门无日不往。今见孤穷。便舍远避不知恩养。唯食是亲。无沙门行破沙门法。诸长老比丘闻种种诃责。以是白佛。佛问诸比丘。汝等实尔不。答言实尔世尊。佛种种诃责已。问阿难。彼二小儿为已几岁。能于食上驱乌未。答言已能。大者八岁小者七岁。佛告诸比丘。今听度小儿。乃至能驱乌者。诸比丘既度二小儿已。恒教驱食上乌而不与正食。诸居士见此诸沙门。常赞叹施平等食。而今度二小儿但令驱乌不与正食。诸长老比丘闻。以是白佛。佛言。如上座所得食分。亦应以此与沙弥。驱乌小儿亦应等与

尔时有一摩纳害母。思惟罪重常有悔惧。不知云何得灭此罪。念言。沙门释子等行正法净修梵行。我若于彼出家罪应微轻。便到僧坊白诸比丘。与我出家受具足戒。诸比丘问摩纳。汝外道不敬信佛法。今何故欲于中出家。便以实答。诸比丘不知云何。以是白佛。佛言。害父母人于我法中不复生。不应与出家受具足戒。若已受具足戒应灭摈

尔时有阿练若贼。杀一住阿练若处比丘。从是已后心常恼热。犹如热灰自炮其身。昼夜苦痛无有暂宁。作是念。沙门释子等行正法净修梵行。我若于彼出家可得离此热恼。念已即到僧坊求出家。诸比丘语言。汝是阿练若贼。恒欲杀人夺人财物无怜愍心。今何故欲于佛法律中出家。便以实答。诸比丘不知云何。以是白佛。佛言。彼比丘是阿罗汉此人于我法中不复生。不应与出家受具足戒。若已受具足戒应灭摈

尔时调达恶心出佛身血。诸比丘不知云何待遇。以是白佛。佛言。恶心出佛身血。于我法中不复生。不应与出家受具足戒。若已受具足戒应灭摈。调达破僧不应与出家亦如是

尔时佛游拘萨罗国。与大比丘僧千二百五十人俱。渐渐游行到黑闇河边止娑罗林下。有一比丘从坐起偏袒右肩右膝着地合掌白佛言。世尊。此娑罗林是破众多比丘尼梵行处。佛问汝云何知。答言我时在此。又问汝破比丘尼梵行耶。答言如是。佛告诸比丘。淫比丘尼人于我法中不复生。不应与出家受具足戒。若已受具足戒应灭摈

尔时有一阿修罗子。厌生老病死。作是念。沙门释子等行正法净修梵行。我当于彼出家尽诸苦源。念已化作人形往僧坊求出家。诸比丘即与受具足戒。食一人分食乃至七人分食犹故不饱。复食僧残食亦复不足。时王舍城有二居士。同日各请五百僧。诸比丘同往一家。唯化比丘独至一处须臾食五百人分尽。诸居士讥诃言。云何诸比丘度非人。彼比丘觉人知已忽便还本。诸长老比丘闻。以是白佛。佛言。于我法中非人不生。不应与出家受具足戒。若已受具足戒应灭摈。受具足戒时。应问汝是非人不。尔时善自在龙王。厌生老病死念欲出家。化作一摩纳。乃至诸比丘度与受具足戒亦如上。龙法二时不能变形。行欲时睡眠时。于后眠熟身满一屋喘息声如雷震。妨诸比丘坐禅皆出往视。彼闻人声便觉。还作比丘形结跏趺坐。唤令开户彼即开户。诸比丘问汝是谁。答言我是沙门释子。又语汝莫妄语。彼化比丘便以实答。诸比丘不知云何。以是白佛。佛言。畜生于我法中不生。不应与出家受具足戒若已受具足戒应灭摈。从今受戒不相识者应七日试看

尔时诸比丘度黄门与受具足戒。便呼诸沙弥及守园人共作不净行。出外见人亦如是。诸白衣见讥诃言。沙门释子度诸黄门。必当共作不净事。此辈无可度不可度。乃至若已受具足戒应灭摈。亦如上说。受具足戒时应先问。汝是丈夫不。二根亦如是

尔时有一家为非人所害。唯家主一人在。作是念。我今穷饿当作何方救全性命。彼沙门释子。多得衣食疾病医药。我今当自剃头着袈裟住家中恒往僧坊案次食。念已即自剃头作比丘。往比丘住处觅食。诸比丘礼皆受。亦礼诸比丘。诸比丘问。汝何故礼他。复受他礼。汝为几岁。何时受戒。和尚阿阇梨为是谁。答言。我自剃头着法服。无有和尚受戒年月。诸比丘不知云何。以是白佛。佛言。若自剃头自称比丘。于我法中不生。不应与出家受具足戒。若已受具足戒应灭摈

尔时跋难陀弟子尼揵比丘。昔罢道者后复来求出家。诸比丘不知云何。以是白佛。佛言。舍内法外道人。于我法中不生。不应与出家受具足戒。若已受具足戒应灭摈

尔时孙陀罗难陀跋耆子。不舍戒行淫法。彼后自说所犯。诸比丘不知云何。以是白佛。佛言。若自说犯边罪。于我法中不生。不应与受具足戒。若已受具足戒应灭摈。受戒时应问。汝先出家净修梵行不

尔时诸比丘不受依止住。无人教诫愚闇无知不能学戒。诸长老比丘。以是白佛。佛言。应受依止。若一宿不受依止。乃至不听饮僧坊内水。若饮突吉罗。佛既不听不受依止。便不敢复住僧坊内。时有一比丘避住止处往到佛所。头面礼足却坐一面。佛问。汝从何方来。答言从某方来。又问。彼住处第一上座第二第三上座为谁。答言不识。又问。彼左右住处上座复是谁。答亦不识。又问。汝何故不识。答言。我避住处不入彼众。是故不识。又问汝何故避住处。答言。佛不听不受依止。若不受依止乃至不听饮僧坊内水。是故避之。佛种种诃责彼比丘。汝所作非法。不应为受依止故避住处。呵已告诸比丘。若为受依止避住处突吉罗

复有诸比丘。在道行见僧坊。便入受依止。值诸比丘坐禅或遇相嗔不得受。以此失伴。或受依止已即去。诸比丘问。汝何故受依止已即去。答言。世尊不听为受依止避住处。我今见僧住止处。不敢不过受依止。复应及伴。是以便去。彼失伴者道中遇贼。诸长老比丘。以是白佛。佛言。今听一宿不受依止。虽得一宿犹有诸难。复以白佛。佛言。今听不受依止乃至六宿。复有诸比丘过六宿不受依止。以是白佛。佛言。不听过六宿。过者突吉罗

时诸比丘。趣与人作依止。亦趣依止人。以是白佛。佛言。皆不应尔。应依止长老如法比丘善能教诫者。若受依止人欲移余处。应先问和尚阿阇梨。知彼有可依止人然后可往。有诸弟子临行时辞和尚阿阇梨。佛言。不听临行时辞。要先二三日白师。师应筹量所往处。有可依止人乃听去。到彼住处应先礼塔。次礼上座索房舍。然后求依止。作依止比丘应问。汝和尚阿阇梨是谁。先住何处诵何经。答若如法。应与作依止。若不如法。应语言。汝不识我我不识汝。汝可往识汝处求依止。若疑应语小住。受依止人应小住。乃至六宿观之。合意者应与依止。若不合意应语如上。复有病比丘求依止。彼比丘作是念。佛教比丘应如是如是视弟子。今此人病我不能看。便不与依止病比丘。不知云何。以是白佛。佛言。今听病时不受依止。病差然后受。复有看病比丘求依止。彼比丘语言。佛教比丘应如是如是视和尚阿阇梨。汝今看病不得与汝依止。看病比丘不得依止惭愧。便舍病去求依止。病人无有看者。或更增剧或有命过。以是白佛。佛言。今听看病比丘不受依止。须病人差然后受。复有诸比丘。于称意行道得道果处求依止。诸比丘不与便失道果。以是白佛。佛言。若是称意行道得道果处。无人与作依止者。听于彼众中上座若上座等心生依止敬如师法而住。时诸比丘。阿阇梨或丧或罢道或远行或作外道或出界外。不知失依止不。以是白佛。佛言。失依止有八种。若依止师远行。若罢道若死。若作外道。若见先和尚。若依止师语汝更就某甲受依止。若依止师出界经宿。若满五岁聪明辩才至明相出时。是为八。皆失依止

尔时诸比丘。与沙弥等分安居施物。沙弥便不敬僧。以是白佛。佛言。应以一比丘分与三沙弥。沙弥犹不恭敬。复以白佛。佛言应罚之。诸比丘不问沙弥师便罚。师不悦。以是白佛。佛言应语其师。其师作非法助沙弥。以是白佛佛言。师不应非法助沙弥。复有一沙弥僧罚断其食。彼主人后请僧食。诸比丘往次第坐。主人不下食。诸比丘言。日时已至何故不下食。答言须僧集。诸比丘言僧已集。主人言。我所供养沙弥未至。诸比丘言彼不得来。问何故。答僧罚不与食。主人言。余罚不少何忍断其食。以是白佛。佛言不应断食。应罚扫地除粪辇石治经行处作阶道。作如是等种种罚之

时有一比丘男根灭女根生。诸比丘不知云何。以是白佛。佛言。应即以此受戒即以此请师即以此年岁往比丘尼住处依比丘尼法住。若先犯共比丘尼戒应于比丘尼中悔。若先犯不共戒不复悔。比丘尼根变亦如是。有一式叉摩那根变。不知云何。以是白佛。佛言。应即以此出家若年满二十于比丘众中十人与受具足戒。若年未满二十即是沙弥。沙弥尼亦如是。有一沙弥根变。不知云何。以是白佛。佛言。应即以此出家若年满应与二岁戒。即于比丘尼众受二岁戒。若年未满不应与二岁戒。即是沙弥尼

尔时有一比丘为欲火所烧。不能堪忍自截其形。诸比丘以是白佛。佛诃责言。汝愚痴人。不应截而截应截便不截。告诸比丘。若截头及半突吉罗。若都截偷罗遮。若去一卵偷罗遮。若去两卵应灭摈。若为恶兽啮。若怨家所害。及自烂坏。不复能男。皆应灭摈

时诸比丘度被截手脚人为受具足戒。诸居士见讥诃言。沙门释子无可度不可度。无沙门行破沙门法。诸长老比丘闻。以是白佛。佛言。不应度此等人。若度得名受具足戒。师僧突吉罗。从今截手截脚截手脚截耳截鼻截耳鼻截指截男根头挑眼出得鞭坏好相遭官罪挛躄失声内外瘿身内曲身外曲身内外曲睐眼一臂偏长一臂偏短左手作哑聋盲干痟病癫狂极老无威仪极丑。毁辱众僧者。如是比皆不得度。若已度得名受具足戒如上说。诸比丘度吃人。佛言。不应度吃人与受具足戒

复有诸比丘。不先与受沙弥戒。便与受具足戒。复有诸比丘。不请和尚便与受具足戒。复有诸比丘。不乞受具足戒。便与受具足戒。复有诸比丘。与裸形人受具足戒。复有诸比丘。与不具衣钵人受具足戒。以是白佛。佛言皆不应尔

时有一比丘借他衣钵受具足戒。受具足戒已诸比丘语。汝着衣持钵共行乞食。答言我无衣钵。诸比丘言。佛不制无衣钵不得受具足戒耶。答言佛制。我借他衣钵受。诸比丘不知云何。以是白佛。佛以是事集比丘僧。告诸比丘。听将欲受戒者着戒坛外眼见耳不闻语处。请十众在戒坛上。和尚应语羯磨师。长老今作羯磨。复应语教师。长老今受羯磨。羯磨师应如是白僧。大德僧听。某甲求某甲受具足戒。某甲作教师。若僧时到僧忍听。白如是。教师应从坐起至和尚前问言。已度此人未。若言未度。应语言先度之。若言已度。应问已为作和尚未。若言未作。应语先为作和尚。若言已为作和尚。应问弟子衣钵具未。若言未具。应语先为具衣钵。若言已具。应问自有从人借。若言从人借。应语可令主舍之。若言自有。便应往慰劳欲受戒人言。汝莫怖惧。须臾持汝着高胜处。若先不相识。不应云雾闇时受其具戒。教师因教着衣时。应密如法视。无重病不。复应问。汝三衣何者是僧伽梨何者是优多罗僧何者是安陀会。彼若不知。应语此是僧伽梨此是优多罗僧此是安陀会。应与受三衣钵。复应语言。汝某甲听。今是实语时我今问汝。若实言实。不实言不实。人有如是等病。癞白癞痈疽干痟癫狂痔漏热肿脂出。汝有不。若言无。复应问。汝不负人债不。非官人不。非奴不。是丈夫不。是人不。年满二十不。衣钵具不。受和尚未。汝字何等。和尚字何等。汝曾出家不。若言曾出家。应问。汝本出家持戒完具不。父母听不。欲受具足戒不。众中当更如是问汝。汝亦应如实答

若一一问答皆如法。教师应还坛上立语羯磨师言。我已教授某甲如法竟。羯磨师复应白僧。大德僧听。某甲求某甲受具足戒。某甲如法教授竟。应使将来。若僧时到僧忍听。白如是。教师应将来次第礼僧足。礼僧足已。在羯磨师前。向羯磨师右膝着地合掌教乞受具足戒。教言。我某甲求某甲和尚受具足戒。今从僧乞受具足戒。愿僧拔济我。怜愍故。如是三乞。教师教竟。还就本坐

羯磨师应白僧。大德僧听。此某甲求某甲受具足戒。从僧乞受具足戒。我今当问其难事及为作受具足戒羯磨。若僧时到僧忍听。白如是

次应语受戒人言。今是实语时。我今问汝。实言实不实言不实。人有如是等病癞白癞。乃至欲受具足戒不亦如上问。皆答如法已。羯磨师言。大德僧听。此某甲求某甲受具足戒。某甲自说清净无诸难事三衣钵具已受和尚父母听许已。从僧乞受具足戒。僧今与某甲受具足戒和尚某甲。若僧时到僧忍听。白如是

大德僧听。此某甲求某甲受具足戒。某甲自说清净无诸难事三衣钵具已受和尚。父母听许已。从僧乞受具足戒。僧今与某甲受具足戒和尚某甲。谁诸长老忍默然若不忍者说。第二第三亦如是说。僧已与某甲受具足戒和尚某甲竟。僧忍默然故。是事如是持。应语受戒人言。汝某甲听世尊应供等正觉说是四堕法。若比丘犯一一法。非沙门非释种子。汝终不得乃至以欲染心视女人。若比丘行淫法乃至畜生。非沙门非释种子。汝尽形寿不应犯。若能当言能

汝终不得乃至草叶不与而取。若比丘若聚落中若空地他所守护物盗五钱若五钱物。非沙门非释种子。汝尽形寿不应犯。若能当言能

汝终不得乃至杀蚁子。若比丘若人若人类自手杀若教人杀若求刀与若教死若赞死咄丈夫用恶活为死胜生。非沙门非释种子。汝尽形寿不应犯。若能当言能

汝终不得乃至戏笑妄语。若比丘实无过人法。自称得过人法。诸禅解脱三昧正受及诸道果。非沙门非释种子。汝尽形寿不应犯。若能当言能

诸佛世尊为示现事善说譬喻。犹如人死终不能以此身更生。如针鼻决永不复得为针用。如多罗树心断更不生不增不广。如石破不可复合。若比丘犯一一堕法。还得比丘法。无有是处

复语言。汝某甲听。世尊应供等正觉说四依法。比丘尽形寿依粪扫衣住出家受具足戒。汝若能当言能。若后得劫贝衣钦婆罗衣拘舍耶衣他家衣。皆是长得

比丘尽形寿依乞食住出家受具足戒。汝若能当言能。若后得僧前食后食请食。皆是长得。比丘尽形寿依树下住出家受具足戒。汝若能当言能。若后得大小屋重屋。皆是长得。比丘尽形寿依残弃药住出家受具足戒。汝若能当言能。若后得酥油蜜石蜜。皆是长得。复应语言。汝某甲听。汝已白四羯磨得如法受具足戒竟。诸天龙鬼神皆作是愿。我何时当得人身于正法律中出家受具足戒。汝今已得。如人受王位。汝受比丘法亦如是。当忍易共语恭敬受教诫余戒。和尚阿阇梨当广为汝。说汝当早得具足学戒。学三戒灭三火离三界。无复诸垢成阿罗汉

尔时受具足戒人。不知年岁不知受戒时。以是白佛。佛言应教令知语言。汝今受戒时。某年某月某日某时。汝应尽寿忆是事

复有诸犯粗罪别住比丘。厌别住便舍戒罢道。又行摩那埵本日治阿浮诃那被诃责羯磨驱出羯磨依止羯磨举罪羯磨下意羯磨。如是诸比丘皆厌罢道。后复欲于正法律出家受具足戒。诸比丘不知云何。以是白佛。佛言。应先问。汝能还行先事。能随顺僧。求僧除灭先事不。若言不能。不应与出家受具足戒。若言能。应与出家受具足戒。若受具足戒已。若先别住使还别住。乃至先作下意羯磨。还与作下意羯磨

复有诸比丘。和尚阿阇梨罢道。后来就弟子求出家受具足戒。诸比丘不知云何。以是白佛。佛言。听与出家受具足戒。先弟子应与衣钵助使得成出家受具足戒。彼人即求先弟子作师。诸比丘不知云何。以是白佛。佛言。听先弟子与作师。复不知谁应恭敬。诸比丘以是白佛。佛言。后更受戒者。应如法敬师

尔时优波离白佛。诸比丘先已作一语受戒。二语三语受戒。及善来比丘受戒。眠时受戒。醉时狂心散乱心病坏心受戒。和尚眠时乃至病坏心。二人乃至十人皆作和尚受戒。是等得名受具足戒不。佛言。若未制前得名受具足戒。制后不名受具足戒

尔时舍利弗摩诃目揵连大迦叶摩诃拘絺罗摩诃迦旃延阿那律富楼那弥多罗尼子罗睺罗阿难难陀。此等诸大阿罗汉到世尊所头面礼足却坐一面。同声如优波离问佛。佛答亦如上。

尔时诸比丘无上下坐不相恭敬。诸居士见讥诃言。此辈沙门不知上中下坐无有长幼。无沙门行破沙门法。诸长老比丘闻种种诃责。以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言实尔世尊。佛种种诃责已。问诸比丘。谁应受第一座第一施第一恭敬礼拜。诸比丘或言。刹利婆罗门长者居士出家者应受。或言。诵毗尼法师阿练若行十二头陀乃至得阿罗汉者应受。佛言不应尔。诸比丘白佛。若不尔谁应受。佛言。过去世时海边有尼拘律树。覆五百乘车。时有三兽住彼树下。一者雉。二者猕猴。三者象。虽为亲友而不相推敬。后作是议。我等既为亲友。如何不相推敬。应计年长者为尊少者为卑议已问象。汝忆何久远事。象言。我忆此树至我腹时。复问猕猴。猕猴言。忆我平立啮此树头时。复问雉。雉言。我忆昔于某处食此树子来此吐核遂生此树。于是推雉为上。猕猴处中。象为下焉。若欲行时猕猴负雉象负猕猴。雉教二兽行十善业。皆共受行。世人闻之皆受其化。遂名行善为雉梵行。行其法者命终生天。诸比丘。畜生犹尚知有尊卑。况我正法而不相敬。汝等从今先受具足戒者。应受第一坐第一施第一恭敬礼拜。如是奉行(受戒法竟)

五分律卷第十七五分律卷第十八(弥沙塞)

        宋罽宾三藏佛陀什共竺道生等译

    第三分之四布萨法

佛在王舍城。尔时外道沙门婆罗门。月八日十四日十五日。共集一处和合布萨说法。多有众人来往供养。瓶沙王见之作是念。若正法弟子亦如是者不亦善乎。我当率诸官属往彼听法恭敬供养令一切人长夜获安。尔时世尊亦作是念。我为诸比丘结戒。而诸比丘有不闻者不能诵学不能忆持。我今当听诸比丘布萨说戒。瓶沙王念已到佛所。头面礼足却坐一面。以所念白佛。佛为王说种种妙法示教利喜已。即便还宫。佛以是事集比丘僧。以瓶沙王所白及已所念。告诸比丘。今以十利故。听诸比丘布萨说戒

佛既听布萨说戒。诸比丘便日日布萨。以是白佛。佛言不应尔。诸比丘复二日三日至五日一布萨。以是白佛。佛言亦不应尔。听月八日十四日说法十五日布萨。诸比丘不知应说何法。以是白佛。佛言。应赞叹三宝念处正勤神足根力觉道。为诸施主赞叹诸天。诸比丘便合声赞叹三宝。以是白佛。佛言不应尔。听请一人。诸比丘请破戒破见比丘因此得势。以是白佛。佛言不应尔。应请学戒者。诸比丘复请睐眼诸病比丘。毁辱众僧者。以是白佛。佛言不应尔。应请诸根具足成就记论持阿含者。时众中多有此人。诸比丘不知请谁。以是白佛。佛言应次第请。所请比丘说法疲极。以是白佛。佛言应更请代。诸比丘作歌咏声说法。以是白佛。佛言不应尔。说法时众会不得尽闻。以是白佛。佛言。应敷高座在上说法。犹不尽闻。以是白佛。佛言应立听。久立脚肿以是白佛。佛言应行听

时诸比丘露地布萨。为蚊虻风雨尘土所困。以是白佛。佛言听作布萨堂。彼布萨堂无地敷。污诸比丘脚。数洗生病。以是白佛。佛言应以泥涂地净治令好。亦听敷十种衣及婆婆等柔软草。佛既听敷衣。便以锦布地。诸居士见讥诃言。此诸沙门如王大臣。以是白佛。佛言不应锦上经行。时诸比丘以华散高座上比丘。诸居士讥诃言如王大臣。以是白佛。佛言不应尔。复有诸白衣。为供养法故。欲以华散高座上比丘。诸比丘不听。便嗔诃言。诸比丘不堪受供养。以是白佛。佛言。白衣欲散华随意。若落比丘头及衣上应拂去落高座上无苦。时诸白衣闻法欢喜欲布施。诸比丘恐堕客作数不敢受。以是白佛。佛言为法供养听受。时诸比丘说法少时便止。诸天鬼神谓竟便去。须臾复说彼复来还如是非一。便嗔恨言。此诸比丘不齐限说法如小儿戏。诸比丘。以是白佛。佛言应作齐限说法。说法竟应咒愿

尔时劫宾那住乙师罗山。作是念。我今当往僧集会处布萨不。复作是念。我常清净何须复往。尔时世尊知其所念。于王舍城没涌出其前。就座而坐语言。汝莫作是念。我常清净何须复往布萨。若汝等不往不敬重布萨。谁当敬重者。世尊如是教已。便与俱没彼处出王舍城。以是事集比丘僧。说劫宾那念及已教敕。告诸比丘。今听诸比丘和合布萨。若不往突吉罗。应一知法比丘若上座若上座等说言。大德僧听。今十五日布萨说戒。僧一心作布萨说戒。若僧时到僧忍听。白如是。诸大德。今布萨说波罗提木叉。一切共听善思念之。若有罪应发露无罪者默然。默然故当知我及诸大德清净。如圣默然我及诸大德亦如是。若比丘如是众中乃至三唱。忆有罪不发露。得故妄语罪。故妄语罪佛说遮道法。发露者得安乐

是中波罗提木叉者。以此戒防护诸根增长善法于诸善法最为初门故。名为波罗提木叉。复次数此戒法分别名句。总名为波罗提木叉

诸比丘不知应几种布萨。以是白佛。佛言。有五种布萨。一心念口言。二向他说净。三广略说戒。四自恣布萨。五和合布萨。诸比丘不知应几种说戒。以是白佛。佛言。有五种说戒。一说戒序已。言余僧所常闻。二说戒序及四堕法已。言余僧所常闻。三说戒序至十三言余僧所常闻。四说戒序至二不定法。言余僧所常闻。五广说诸比丘不知有几种持律。以是白佛。佛言。有五种持律如前说。持律比丘有五种功德亦如前说。持律比丘有七种宜。一多闻诸法。二能筹量是法非法。三善筹量比尼。四善摄师教。五若到他处所说无畏。六自住比尼。七知共不共戒。复有七宜一自住戒威仪成就畏慎小罪。二多闻能持佛所说法。三诵二部戒。四知犯。五知不犯。六知悔过。七知不悔过。复有七宜。三如上。四不随爱。五不随恚。六不随痴。七不随畏

时诸比丘在界内。作别众不如法布萨。复有和合不如法布萨。复有如法别众布萨。复有如法和合布萨。以是白佛。佛言。前三布萨有过。羯磨不成。犯突吉罗。后一布萨无过。羯磨成就无犯

尔时瓶沙王。作五岁一闰。外道沙门婆罗门皆悉依承。而诸比丘独不肯用。诸臣及民皆讥诃言。沙门释子在王境内不用王闰。诸比丘以是白佛。佛言。应随王法。诸比丘不知云何随王法。以是白佛。佛言听少一夜布萨。诸比丘便常少一夜布萨。以是白佛。佛言。不应常少一夜布萨听。三足一少如。是五岁为长一月以顺王闰。

时诸比丘。说戒日至诸处布萨。或遇野火或遇水涨或遭八月贼。有梵行难衣钵难命难。以是白佛。佛言。不应说戒日为说戒至他处。去者突吉罗。听所住处若有平地若有柔软草若有大树若有大盘石应白二羯磨结作布萨处。一比丘白。大德僧听。今结此作布萨处。若僧时到僧忍听。白如是。大德僧听。今结此作布萨处。谁诸长老忍默然若不忍者说。僧已结作布萨处竟。僧忍默然故。是事如是持。诸比丘于露地布萨。为风雨蚊虻所困。以是白佛。佛言。听当中央房来往易处如上。白二羯磨结作布萨堂。诸比丘复欲羯磨众多房作布萨处。以是白佛。佛言听作。诸比丘便复诤先。以是白佛。佛言不听羯磨众多房作布萨处。有诸居士来入僧坊。语诸比丘。若于我所作房中布萨者。我当供前食后食怛钵那与涂足涂身然灯油。诸比丘作是念。若世尊还听羯磨众多房作布萨处者。不使我等失此供养。以是白佛。佛言。还听羯磨众多房作布萨处。次第于中布萨。房小不相容受。以是白佛。佛言。听在前后檐下庭中坐。诸比丘闻声不了语恐不成布萨。以是白佛。佛言。若为布萨在中。得名布萨。

诸比丘布萨时不肯时集废坐禅行道。以是白佛。佛言。应唱时至。若打揵椎若打鼓若吹蠡。诸比丘便作金银鼓。以是白佛。佛言。应用铜铁瓦木以皮冠头。不知谁应打。以是白佛。佛言。应使沙弥守园人打。彼便多打。以是白佛。佛言。应三通打。打竟悬着中庭。外人来数打。诸比丘谓行僧事。皆出废行道。或雨湿不作声。以是白佛。佛言。应举屋下屏处。有客沙弥次打。不知处失时节。以是白佛。佛言。旧住人应打。听畜僧鼓私鼓四方僧鼓备豫一鼓。诸比丘又作金银蠡。以是白佛。佛言。应吹海蠡若用角作。沙弥守园人吹。乃至备豫一蠡亦如上说。诸比丘不知以何木作揵椎。以是白佛。佛言。除漆树毒树。余木鸣者听作。若无沙弥比丘亦得打。余如上。诸比丘不知谁应三唱时至。以是白佛。佛言。听使沙弥守园人。僧住处多不得遍闻。以是白佛。佛言。应上高处唱。诸比丘不知为集未集。以是白佛。佛言。比坐比丘应更相语知。后有客比丘来不知。以是白佛。佛言。应数之。诸比丘数复忘。以是白佛。佛言。应行筹收取数之。一人行自收杂乱。以是白佛。佛言。应别使一人收。诸比丘便作金银筹。以是白佛。佛言。应用铜铁牙角骨竹木作。除漆毒树。诸比丘有短作有长作。以是白佛。佛言。短应长并五指。长应长拳手一肘。诸比丘作或粗或细。以是白佛。佛言。粗不过小指细不减[木*著]。应漆以筒盛悬着布萨堂上。诸比丘不知谁应行筹。以是白佛。佛言。应使下坐比丘行。下坐比丘不知行。以是白佛。佛言。应取知者。有比丘便掷筹与僧。以是白佛。佛言。应手授。收已不数数已不唱。以是白佛。佛言。收已应数数已应唱。唱云。比丘。若干沙弥。若干出家。合若干人。时有白衣听布萨。后诸比丘犯罪白衣举之。以是白佛。佛言。不应令白衣听。沙弥亦如是。诸比丘虽遣沙弥在不见处而犹得闻。以是白佛。佛言。应着不见不闻处。复有诸沙弥知当布萨预入床下犹得闻戒。以是白佛。佛言。应看床下以火遍照。火照熏屋。或烧地敷。以是白佛。佛言。应作灯笼灯趺。僧及私畜皆得。诸比丘便以金银作。以是白佛。佛言。应用铜铁瓦木

有诸白衣新作屋竟。请诸比丘先于中布萨说法为入舍供养。诸比丘不知云何。以是白佛。佛言。听受。复有白衣家为非人所恼。请诸比丘家中布萨说法以为安乐供养。诸比丘不知云何。以是白佛。佛言。听受。有居士行甘蔗。诸比丘不敢受。以是白佛。佛言。应受。有诸居士问诸比丘。今日几。诸比丘不知。便讥诃言。沙门释子日尚不知。何况深理。以是白佛。佛言。若欲往白衣家应先问师日数。师若不知应问余人

时诸居士。布萨日持时食时饮七日药终身药至僧坊供养。欲听法受八分戒。诸比丘都不看视。便嗔恚持归。以是白佛。佛言。上座应令下座扫地取水使净人办器盛其所赍物。诸比丘食都不与客。客便讥诃言。沙门释子常赞叹布施。唯受人施而不施人。以是白佛。佛言。应与客食。既与着其手中。不与器物。便讥诃言。诸比丘作小儿遇我。以是白佛。佛言。应与器物下食。食竟上座若上座等为说法咒愿。客去后若四人若过四人应广布萨。若二人若三人应相向说净言。今僧十四日十五日布萨。我某甲比丘清净长老忆持。如是三说。若一人应小待。若有人来共布萨。若无人来。应偏袒右肩胡跪合掌心念口言。今十四日十五日众僧布萨。我今心受布萨。如是三说。告诸比丘。是布萨法。从今应尽寿如是奉行。不者突吉罗

时诸居士入僧坊问诸比丘。僧有几人。答言。僧有若干。彼言。我等请僧明日食。诸近处比丘闻。明日尽往坐席不足饮食又少。诸比丘言。汝等请僧何以不与我食。答言。我昨问僧随数设食。先不相请而强求索。不请而食甚于外道。此辈无沙门行破沙门法。诸长老比丘闻种种诃责。以是白佛。佛言。不请不应往。往者突吉罗。复有诸比丘。以因缘事应会。日至请家惭愧不敢。以是白佛。佛言。不为食听往

尔时有居士请僧食。有客比丘来。诸比丘不知云何。以是白佛。佛言。应语主人。有客比丘听入不。若听入善。若不听复应语言。与我等食分。我自平等共食。若得者善。若不得应各以钵受分出外共食。若得者善。若复不得。僧坊内有食应将与之

时世饥馑乞食难得。余处比丘尽舍住处集王舍城。僧房皆空无人守护。房舍卧具。或为火烧。或为水渍。或为虫啮。以是白佛。佛言。近王舍城左右诸住处。皆应白二羯磨如上舍界。然后白二羯磨如上通结作一大界。使诸比丘不舍本住而得施分。后时余处还复丰乐。思见比丘遣信白言。愿游人间我等供给衣食。时瓶沙王亦欲令诸比丘游行教化。语言。愿为游行。若有乏短。当敕所在供给所须。诸比丘以是白佛。佛言。先白二羯磨如上舍王舍城大界。然后各随意更唱界相还结小界

有诸阿练若比丘。不知己界应齐几许。以是白佛。佛言。自然界去身面二句楼赊。若结界随远近。时诸比丘结无边界。以是白佛。佛言。若结无边界不成结界。犯者突吉罗。诸比丘复结十二由旬或十由旬界。说戒时往四五日行。乃至或遇野火。或遇暴水。或遇贼剥。便有梵行难衣钵难及命难。以是白佛。佛言。若结十二由旬若十由旬界。不成结界。犯者突吉罗。今听极远三由旬。时诸比丘不唱四方界相而结界。以是白佛。佛言。若不唱界相不成结界。犯者突吉罗。时诸比丘以众生及烟火作界相。或并界。或两界相入。以是白佛。佛言。皆不成结界。犯者突吉罗

有二住处。诸比丘欲共布萨共得施结界。以是白佛。佛言。听各白二羯磨解本界。然后共集白二羯磨结共界。复有诸比丘欲共住共布萨异得施结界。以是白佛。佛言。听解本界然后集结。复有诸比丘欲共住共得施异布萨结界。以是白佛。佛言。不应尔。犯者偷罗遮。复有一住处诸比丘欲异住异布萨异得施结界。以是白佛。佛言。听解本界已各更结。复有诸比丘欲异住异布萨共得施结界。以是白佛。佛言。听结。告诸比丘。一切河一切湖池一切海皆不得结作界。若水中行。以众中有力人水洒所及处。为自然界

佛在竹园。阿若憍陈如在楞求罗山。布萨日辄化作青虹。在中结跏趺坐。来至佛所。众人多来看之。以此故后便步出。粪扫衣重道路疲极。诸比丘作是念。若世尊听诸比丘于聚落中若聚落界结作不失衣界者。不使长老疲极如此。以是白佛。佛种种赞戒。赞持戒已。告诸比丘。今听诸比丘于聚落中若聚落界白二羯磨结作不失衣界。应一比丘白。大德僧听。此结界处聚落中若聚落界共住共布萨共得施。今结作不失衣界。若僧时到僧忍听。白如是。大德僧听。此结界处聚落中若聚落界共住共布萨共得施。今结作不失衣界。谁诸长老忍默然。若不忍者说。僧已结作不失衣界竟。僧忍默然故。是事如是持

时诸比丘先结不失衣界后结大界。以是白佛。佛言。应先结大界后依此结不失衣界。诸比丘便一切时结衣界着粗弊衣行。以是白佛。佛言。不应尔。应白二羯磨解。一比丘白。大德僧听。此结界处聚落中若聚落界。先结作不失衣界。僧今解之。若僧时到僧忍听。白如是。大德僧听。此结界处乃至僧今解之。谁诸长老忍默然若不忍者说。僧已解先不失衣界竟。僧忍默然故。是事如是持。时诸比丘先解大界后解衣界。以是白佛。佛言。应先解衣界后解大界。时诸比丘为护夏故失衣。为护衣故失夏。以是白佛。佛言。听还结衣界

时有一住处。布萨日弟子辞和尚欲行至某处。和尚不知云何。以是白佛。佛言。和尚应筹量。若道路有疑恐怖。和尚听去突吉罗。若不听弟子强去。得轻师波逸提。若道路虽无疑恐怖。而彼方乞食难得。若共行伴无所知。不诵戒不知布萨不知布萨羯磨。若彼方无持法持律解律仪人。若彼方好共斗诤。若彼方有破僧事。若彼方得病无随病食汤药卧具看病人。若彼方衣食难得听去。皆突吉罗。若无如是诸事听去无犯

有一住处。十五日诸比丘集布萨说波罗提木叉。请第一上座说戒。上座云诵忘。第二至下皆云不诵。不得布萨。诸比丘以是白佛。佛言。应白二羯磨一比丘令往他众诵戒。若略若广及日还。若不得不应住此处。住者突吉罗。时六群比丘犯罪不悔过布萨。以是白佛。佛言。不应尔。犯者突吉罗。复有诸比丘向犯罪人悔过。以是白佛。佛言。不应尔。有一住处。布萨日一切僧犯罪。诸比丘不知云何。以是白佛。佛言。听白二羯磨一比丘令往他众悔过清净还。余人于此比丘边悔过。若得者善。若不得应尽集布萨堂一比丘白二羯磨。大德僧听。僧今皆有此罪不能得悔过。今共置之后当悔过。若僧时到僧忍听。白如是。大德僧听。僧今皆有此罪。乃至后当悔过。谁诸长老忍默然若不忍者说。僧已置此罪竟。僧忍默然故。是事如是持。然后布萨。不应不布萨。有一病比丘犯罪。语一比丘言。大德我犯罪。彼答我亦犯罪。不得悔而命终。诸比丘作是念。若世尊听向有罪比丘悔过者。不使此比丘不悔而终。以是白佛。佛言。听向有罪比丘悔过。但不得向同犯者悔过。有一住处僧皆同犯一罪。不知云何。以是白佛。佛言。亦应如上置罪。有一病比丘犯罪。语一比丘。大德我犯此罪。彼言。我亦犯此罪。不得悔过而终。诸比丘作是念。若世尊听向同犯一罪比丘悔过者。不使此比丘不悔而终。以是白佛。佛言。今听同犯不同犯皆得向悔

有一住处。诸比丘集布萨说戒。有一比丘语说戒比丘言。住我忆有罪我欲悔过。诸比丘诃责。云何说戒时作此留难。以是白佛。佛言。若说戒时忆有罪。听向比坐说。若口言若心念。我有此罪说戒竟当悔。不应作留难。疑亦如是

有一住处。诸比丘不知布萨。不知布萨羯磨。有知法持律解律仪比丘来。诸比丘不看视不与卧具。彼比丘便去。以是白佛。佛言。应好看视与卧具。若不尔突吉罗

有一住处。僧皆犯罪。不知犯何篇罪。有一知法持律解律仪比丘来。诸比丘中一比丘往问言。犯如是。如是为是何篇罪。彼答言。是某篇罪。便语言。此住处一切僧犯如是罪。即于彼比丘边悔过。悔过已还语诸比丘。我等先犯如是如是某篇罪。应共悔过。莫污染修梵行长夜受苦。诸比丘嗔恚言。汝何故向我说如是语。以是白佛。佛言。诸比丘应在彼知法比丘边悔过。非不应语。但不应趣人语。语者突吉罗。时舍利弗至六群比丘住处。见其犯戒语言。汝等莫作此罪。六群比丘便触恼问言。何等应作。何等不应作。竟夜恼之。舍利弗以是白佛。佛种种诃责六群比丘。汝愚痴人。上座比丘怜愍教汝。云何而反竟夜恼触。诃已告诸比丘。非不应教。但不应趣教人。若犯罪自知有过。然后教之

时舍利弗目连游行人间。为诸四众国王大臣沙门婆罗门之所师敬。到一比丘住处。诸檀越为二人故。供养众僧布施衣物。及守园人复共得钦婆罗直。估金钱一万二千。三反唱令。须者取之。竟无人取。即还施主。时会比丘渐渐游行还到佛所。佛如常法。慰问诸比丘已问言。舍利弗目连游行丰足不。答言甚丰。世尊复见一希有事。众僧共得一钦婆罗直。估金钱一万二千。三唱与诸比丘。无人取者以还施主。时有二磨诃卢比丘。去佛不远闻已。一人作是言。彼诸上座愚痴。自失利养而使施主不得大福。若我在彼当为取之。一人复言。我是上座我应取。遂致纷诤。佛见已即说偈言

  汝二摩诃卢　　不在于彼众
  由此无诤讼　　贵衣还本主

佛在舍卫城。尔时优波离与诸持律游行。到比丘住处。应为作诃责羯磨驱出羯磨依止羯磨举罪羯磨下意羯磨者悉为作之。应为作别住摩那埵本日阿浮诃那者皆为作之。若界应解为解。若应结为结。应为作教诫比丘尼羯磨为作教诫羯磨。不堪教诫。应为解教诫羯磨。为解教诫羯磨。余诸比丘闻作是念。此诸持律比丘来。必使我等多有疑悔。便举卧具闭户舍住处而去。又诸比丘尼见优波离嗔骂言。坐此比丘恒问世尊。此戒应作二部僧持作一部僧持。佛便令作二部僧持。由此使我多受困苦。优波离所将比丘有先还者。佛如常法问已。又问。优波离游行处供养丰足不。答言不足。又问何故。具以诸比丘舍住处及比丘尼嗔骂答佛。佛以是事集比丘僧。问彼诸比丘。汝等实尔不。答言。实尔世尊。佛种种诃责。汝等愚痴。不恭敬持律比丘谁应恭敬。诃已告诸比丘。今为诸比丘结初应学法。若比丘闻持律比丘来。不应避去。应为扫洒整理房舍卧具。若闻欲至。出半由旬迎。若有疑难要当出门。若持律比丘有衣物应代担。为办澡洗水拭手脚巾。为作浴具。设过中饮。请说法。若实求解。持律比丘应如法答。若触恼问不应答。明旦为作前食怛钵那次作后食。应为求请主请留安居。复应为求施衣檀越。应作如是供养。若不尔突吉罗

佛在王舍城。尔时世尊。布萨日与诸比丘前后围绕露地而坐。告诸比丘。汝等寂默今当布萨说波罗提木叉。有一比丘从坐起白佛言。伽伽比丘近得狂病。有时来有时不来。亦复不忆来与不来。以是废行僧事。今复不来。佛言。遣一比丘呼来。受教往呼。遍求不得还。以是白佛。佛言。今听诸比丘遥与作狂白二羯磨。一比丘白言。大德僧听。此某甲比丘狂病。或来或不来。亦复不忆来与不来。以是废行僧事。僧今遥与某甲作狂羯磨。若现在若不现在行僧事。若僧时到僧忍听。白如是。大德僧听。此某甲比丘狂病。乃至若不现在行僧事。谁诸长老忍默然若不忍者说。僧已与某甲作狂羯磨竟。僧忍默然故。是事如是持

彼后得差求解羯磨。以是白佛。佛言。听白二羯磨为解。病差比丘应到僧中偏袒右肩脱革屣胡跪合掌白言。大德僧听。我某甲比丘先得狂病。或来或不来。亦复不忆来与不来。僧已与我作狂羯磨。我今已差。从僧乞解狂羯磨。如是三乞。应一比丘白。大德僧听。此某甲比丘先狂。或来或不来。亦复不忆来与不来。僧与作狂羯磨。今已差。从僧乞解狂羯磨。僧今与解狂羯磨。若僧时到僧忍听。白如是。大德僧听。此某甲比丘先狂病。乃至僧今与解狂羯磨。谁诸长老忍默然若不忍者说。僧已与某甲比丘解狂羯磨竟。僧忍默然故。是事如是持。尔时世尊。布萨日与诸比丘前后围绕露地而坐。告诸比丘。汝等寂默今布萨说戒。有一比丘从坐起白佛言。某甲比丘得病不来。佛言。应令一比丘将来。诸比丘不知云何将来。以是白佛。佛言。教拄杖使人扶。若不堪以衣舁之。即受教舁来。劳动故病更困笃。或有死者。以是白佛。佛言。应取清净欲来

是中或有得名与清净欲。或有不得。或有得名受清净欲。或有不得。或有得名持清净欲来或有不得。不得名与清净欲者。若与比丘尼式叉摩那沙弥沙弥尼清净欲。与狂心乱心病坏心灭摈人被举人自说罪人异界住人清净欲。若不如法三说我今与汝清净欲。汝受我清净欲。至如法僧事中。为我称名说及捉筹。皆不名与清净欲。若反上名与清净欲。不名受清净欲者。自不如法不识他姓名余如上。皆不名受清净欲。反此名受清净欲。得名持清净欲来者。若持清净欲比丘来至布萨中。便睡眠若狂心散乱心病坏心。若僧与作不见罪羯磨不舍恶邪见羯磨不悔过羯磨。若变成二根黄门无根若忘说。是亦得名持清净欲来。若睡眠若忘不说皆犯突吉罗罪。若中路睡眠乃至忘说。皆不得名持清净欲来。复有诸病比丘不能口语说清净欲。以是白佛。佛言。应身与清净欲。诸比丘不知云何身与清净欲。以是白佛。佛言。若举手举指摇身摇头乃至举眼。得名身与清净欲。复有诸病比丘不能身与清净欲。以是白佛。佛言。应举众到病人所使说戒比丘于中央坐说戒令诸病比丘向说戒人。复有诸病比丘不能向说戒人背而坐卧。以是白佛。佛言。应出界外布萨。不得在界内作别众布萨

尔时世尊。说戒日与诸比丘前后围绕露地坐。告诸比丘。汝等寂默今当布萨说戒。有一比丘从坐起白佛言。某甲比丘为官所执不得来。佛言。应遣一比丘语所由求还布萨。若听者善。若不听。应语白衣小却。为取清净欲。若得者善。若不得应语言。一切僧当来就此比丘布萨。若得者善。若不得应出界外布萨。不得界内别众布萨

有一阿练若处。诸比丘十五日集布萨说戒。时有贼来。诸比丘见便止不诵戒。诸贼问言。何故默住。答言。我等所说不应使白衣闻。贼复问。所说非佛语耶。答言是。复问。若是佛语谁不应闻。汝等今集必欲论说不利我等。便打夺诸比丘衣钵。以是白佛。佛言。从今诸比丘若见贼来。应即诵余经不令断绝

尔时有王名优陀延。善知相法。有一夫人名月光。容颜姝妙音妓兼人。后于高阁上在王前舞。王见死相不出一年。谛视心念颜色不悦。夫人觉之便白王言。我舞不好耶。何以不悦。王言。不须问我。夫人苦问至三。王不获已便具以告。夫人白王。若实尔者愿听出家。王言。我相敬爱死不相离。余欢少日如何生离。夫人复白王言。少染世荣迷味道业。即此促期唯与苦会。愿必垂愍听遂出家。王言。汝年少修道识见明决必得生天。若还相见当遂汝意。夫人白言。若此愿果誓不违要。便听出家。于是辞去。行道不久得阿那含果。即便命终生于梵天。便作是念。我得出家是王之恩。恩重宜报。要不可违。即下在王宫上虚空中立。语王言。月光夫人即我身是。先与王要。故来赴信。王语言。我不识天可现本身。即变为昔形于王前立。王见情重欲附近之。便飞升虚空语王言。王何故犹习此爱欲。为欲为无常苦空不净。若思此义可得解脱。若不尔者必堕三涂。自拔良难。王闻此语心即调柔。即舍王位以付太子出家学道。在城左右山林树下。太子见父出家而不远去。恒恐变悔还夺其位。常愿父王远之他国。时王比丘作是念。我奉佛教而未见佛。今当往彼礼敬世尊。念已便行。时太子与诸婆罗门在高楼上见出林去。语新王言。王比丘今已去矣。太子欣悦。王比丘忘坐具。须臾忆之即便还取。诸婆罗门复语新王言。王比丘已复还。将无有以太子惶怖。便敕左右。汝速往杀。凡是沙门释子亦尽杀之。复敕言。彼或畏死多作方便。慎莫不杀而来见我。受教即往语言。新王敕我杀比丘。比丘问言。何故杀我。答言。以比丘出林还反恐夺其位是以相杀。王比丘言。我不贪王位。向忘坐具故暂还取。如何以此而便见杀。使复言。重被王敕。彼必畏死多作方便。慎莫不杀而还见我。我今云何而得徒反。王比丘复言。我出家所求未有所获。汝小宽我待彼树影至。使者听之。即勤思惟得须陀洹。树影既至。使者复语树影已至。比丘复言。我出家所求犹未尽获。可复见宽。更待一影。使者复听。如是四反得四沙门果。便语使者。汝可随意。还语汝王。我不贪王位行忘坐具所以暂还。汝为此杀我。便是杀父杀阿罗汉。念汝长夜受大苦耳。言已就死。使者杀已还到王所。王遥见之即生悔心。到已问言。汝已杀耶。答言。已杀。王复问言。父王临终有何所说。使者呜咽具以上答。王闻此语血从口出。即以生身入大地狱。时瓶沙王。与其邻国。先闻其教尽杀沙门释子。恐入己界。敕诸杖士守护比丘。杖士受敕动止不离。时王舍城一住处。有五百比丘十五日集。语令小却。我欲布萨。杖士答言。我等受敕不得暂离。岂敢公违大王之令。诸比丘不知云何。以是白佛。佛言。若不肯去者。但说戒序竟。言余僧所常闻。应作如是布萨。不得不布萨

时诸比丘。布萨日集欲说戒。六群比丘诤讼不住不得说戒。瓶沙王来便得暂止去。后续复共斗不得说戒。不知云何。以是白佛。佛言。若有如瓶沙王。比丘有所畏难。斗暂止时。便说戒序。说戒序竟言。余僧所常闻。应作如是布萨。不得不布萨。僧布萨时欲作羯磨。六群比丘受他清净欲竟不至僧中。便出界外欲使僧羯磨不成。诸比丘以是白佛。佛言。僧得成羯磨。受他清净欲者。犯突吉罗

时诸比丘常略说戒。诸年少比丘言。大德广说我等未曾闻。以是白佛。佛言。不听常略说戒。有十因缘听略说戒。一有贵人。二有恶兽。三有毒虫。四地有生草。五地有棘刺。六有毒蛇窟。七病。八闇。九地有泥。十坐迮。是名十因缘。若犹得五种说戒者善。若不得应言。今十四十五日布萨时。各共正身口意莫放逸。此亦得名布萨。应作如是布萨。不得不布萨

有一住处。说戒时更有比丘来。若多若等若少。复有一住处。说戒竟一切未起去。更有比丘来。若多若等若少。复有一住处。说戒竟诸比丘有起去有未起去。更有比丘来。若多若等若少。复有一住处。说戒竟一切比丘起去。更有比丘来。若多若等若少。诸比丘不知云何。以是白佛。佛言。若说戒时更有比丘来若多若等。应更为布萨说戒。若少应听次后戒。若说戒已竟一切比丘未起。更有比丘来若多若等。应更为布萨说戒。若少应在僧中胡跪说清净。若说戒竟诸比丘有起去者有未起去更有比丘来若多若等。应更为布萨说戒。若少应求先比丘和合更布萨说戒。若得者善。若不得应出界外布萨。不应界内别布萨。若说戒竟一切比丘起去。更有比丘来亦如是。若旧比丘集。若旧比丘来。若客比丘来。若旧客比丘来。若客比丘集。若客比丘来。若旧比丘来。若客旧比丘来。若旧客比丘集。若旧客比丘来。若旧比丘来。若客比丘来。若多若等若少。乃至一切比丘起去。皆如上说

有一住处。布萨时诸比丘集欲说戒。见异绳床衣钵而不见比丘。诸比丘。不念此中有比丘无比丘。便共说戒。有一住处。布萨时诸比丘集欲说戒。见异绳床衣钵而不见比丘。诸比丘作是念。此中无比丘便说戒。有一住处。布萨时诸比丘集欲说戒。见异绳床衣钵而不见比丘。诸比丘作是念。此中有比丘无比丘但说戒便说戒。有一住处。布萨时诸比丘集欲说戒。见异绳床衣钵而不见比丘。诸比丘作是念。此中有比丘灭去失去。以破和合僧心说戒。有一住处。布萨时诸比丘集欲说戒。见异绳床衣钵而不见比丘。诸比丘作是念。此中有比丘不求不觅便说戒。有一住处。布萨时诸比丘集欲说戒。见异绳床衣钵而不见比丘。诸比丘作是念。此中有比丘求觅不得便说戒。有一住处。布萨时诸比丘集欲说戒。见异绳床衣钵而不见比丘。诸比丘作是念。此中有比丘求觅得共说戒。诸比丘不知云何。以是白佛。佛言。第一第二第三第五。此四说戒皆有过。羯磨不成犯突吉罗。第四亦有过。羯磨不成犯偷罗遮第六无过。羯磨不成无犯。第七无过。羯磨成无犯

若旧比丘集。不见旧比丘。不见客比丘。不见旧客比丘。若客比丘集。不见客比丘。不见旧比丘。不见客旧比丘。若旧客比丘集。不见旧客比丘。不见旧比丘。不见客比丘。有过无过皆如上。有一住处。布萨时诸比丘集。闻比丘若[口*磬]咳若缩鼻若振衣声。不作是念。此中有比丘无比丘便说戒。乃至有一住处。布萨时诸比丘集。闻比丘若[口*磬]咳若缩鼻若振衣声。作是念。此中有比丘求得共说戒。诸比丘不知云何。以是白佛。佛答。有过无过亦皆如上。有一比丘。受一比丘清净欲。一比丘布萨。有二比丘。受二比丘清净欲。二比丘布萨。有三比丘。受三比丘清净欲。三比丘布萨。有众多比丘。受众多比丘清净欲。众多比丘布萨。以是白佛。佛言。皆不应尔。今听多比丘集少比丘持清净欲来

有一住处。诸比丘集欲布萨说戒。见异住比丘作同住想。见已不忆不问便说戒。有一住处。诸比丘集欲布萨说戒。见异住比丘作同住想。见已忆不问便说戒。有一住处。诸比丘集欲布萨说戒。见异住比丘作同住想。见已忆问共说戒。有一住处。诸比丘集欲布萨说戒。见异住比丘。于界疑于比丘无疑。不忆不问便说戒。有一住处。诸比丘集欲布萨说戒。见异住比丘。于界疑于比丘无疑。忆而不问便说戒。有一住处。诸比丘集欲布萨说戒。见异住比丘。于界疑于比丘无疑。忆问共说戒。有一住处。诸比丘集欲说戒。见异住比丘。于比丘疑于界无疑。不忆不问便说戒。有一住处。诸比丘集欲布萨说戒。见异住比丘。于比丘疑于界无疑。忆不问便说戒。有一住处。诸比丘集欲布萨说戒。见异住比丘。于比丘疑于界无疑。忆问共说戒。诸比丘不知云何。以是白佛。佛言。六有过羯磨不成犯突吉罗。三无过羯磨成无犯。同住亦如是

客比丘言十四日。旧比丘言十五日。诸比丘不知云何。以是白佛。佛言。客比丘应从旧比丘。无旧比丘而客比丘自共作。异如上。不知云何。以是白佛。佛言。后来应从先至。有客比丘一时来。以是白佛。佛言。应问近处比丘。若近处无比丘。应问官日数从之

尔时诸比丘。从有比丘住处。往有比丘住处布萨。往无比丘住处布萨。往有比丘无比丘住处布萨。往斗诤比丘住处布萨。往破僧比丘住处布萨。以是白佛。佛言。布萨日往前四处突吉罗。往后一处偷罗遮

有一住处。布萨日跋难陀为上座。众僧请说戒。答言诵忘。诸比丘言。若忘何以坐上座处。以是白佛。佛言。应上座说戒。若不说突吉罗。诸比丘不知齐几为上座。以是白佛。佛言。上无人皆名为上座

诸比丘说戒时中忘。以是白佛。佛言。应傍人授犹忘更复授。三忘应更差人续次诵。不应重诵。时六群比丘布萨夜斗诤妨僧说戒。以是白佛。佛言。若容得说戒起者犹少。应还集说戒。起者若多若半。应置听明日布萨。若说律说法论议若多得布施。不容说戒皆听至明日。诸比丘先不请诵戒人。以此稽留说戒。以是白佛。佛言。应先请说戒人。时诸比丘先说戒后作诸羯磨。六群比丘说戒竟便去。不与僧和合作诸羯磨。作诸羯磨不如法。以是白佛。佛言。应先作诸羯磨然后说戒。以是摄僧令不得去。时诸比丘并诵戒。以是白佛。佛言。不应并诵戒。应请一人说。有比丘作歌咏声说戒。以是白佛。佛言。应直说之

时一住处布萨。跋难陀为上座唱言。今僧十五日布萨说戒。不来诸比丘说欲及清净。僧今何所作。为诸比丘作何事。诸比丘答言。某甲比丘应与作诃责羯磨驱出羯磨依止羯磨举罪羯磨下意羯磨。某甲比丘应与别住磨那埵本日阿浮诃那。跋难陀言。我不知羯磨。诸比丘问。若不知何故问僧及诸比丘作何事。以是白佛。佛言。上座应说戒。持律应羯磨。时诸比丘或反抄衣或叉腰或着革屣或覆头或卧或倚。作如是等不恭敬听说戒。以是白佛。佛言。宜加恭敬。不得反抄衣乃至卧倚而听说戒。犯者突吉罗。布萨日有一比丘熟眠。说戒竟方惊起言。僧集共说戒。以是白佛。佛言。从今昼日都不得眠。复有诸被羯磨执事比丘。不得眠疲乏身不得安。以是白佛。佛言。听在隐避处眠。应语知识比丘。我在某处眠。若有僧事呼我。复有一比丘。说戒上眠觉。方语诸比丘。何不说戒。诸比丘问汝忆何等。答言。得眠。以是白佛。佛言。不应说戒上眠。犯者突吉罗

有一住处布萨。诸比丘在隐避处说戒。客比丘来不知处所。以是白佛。佛言。若无难事不应避隐处说戒。有诸比丘不知说戒时至。以是白佛。佛言。上座应知时至。教下座比丘扫除敷置办筹及灯火。诸比丘。以小事便嘱授。以是白佛。佛言。不听以小事嘱授诸比丘。欲庄严布萨堂悬缯散华兼施僧过中饮亦因施衣物。又欲以偈赞叹佛法僧。以是白佛。佛言。皆听。若有种种福事。应及时作

五分律卷第十八五分律卷第十九(弥沙塞)

        宋罽宾三藏佛陀什共竺道生等译

    第三分之三安居法

佛在舍卫城。尔时诸比丘春夏冬一切时游行。蹈杀虫草担衣物重疲弊道路。诸居士见讥诃言。此诸外道沙门婆罗门。尚知三时夏则安居。众鸟犹作巢窟住止其中。而诸比丘不知三时应行不行。常说少欲慈愍护念众生。而今践蹈无仁恻心。无沙门行破沙门法。诸长老比丘闻种种诃责。以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言。实尔世尊。佛种种诃责已告诸比丘。不应一切时游行。犯者突吉罗。从今听夏结安居。结安居法。应偏袒右肩脱革屣胡跪合掌向一比丘言。长老一心念。我某甲比丘。于此住处夏安居。前三月依某聚落某房舍。若房舍坏当补治。如是三说。答言我知

诸比丘便日日结安居。或二日乃至五日一结以是白佛。佛言。不应尔。应于春末布萨日分房舍卧具于夏初一日结安居。有比丘欲依象下或依车舆结安居。复有比丘欲依覆钵安居。以是白佛。佛言。皆不应尔。犯者突吉罗。听在结跏趺坐及衣钵雨漏所不及处依此安居。有诸比丘在无救护处安居为贼劫夺。复有诸比丘在冢间安居为非人所恼。复有诸比丘在空树中安居为毒虫所困。复有诸比丘在皮覆屋中安居鼻内生肉。复有诸比丘露地安居肌皮剥脱。以是白佛。佛言。皆不应尔

时诸白衣。请比丘于无救护处安居。白言。大德。可于彼安居。我当遥作救护。以是白佛。佛言。听受。复有冢间比丘。患人间无房舍卧具。欲还冢间安居。以是白佛。佛言。若能系念在前无所畏者听。复有诸比丘。欲治护空中树于中安居。以是白佛。佛言听。应先以石掷树若以杖打听有何声有何物出。若无异声无有物出者然后入中。仰塞泥合得使平立。作土埵泥四边地。安户作开闭处

尔时阿耨达龙王。请诸比丘于宫五百金银众宝窟中安居。诸比丘不敢往。以是白佛。佛言。听往。诸比丘欲作阶道安置坐石及洗脚石。而皆是金银。惭愧不敢。以是白佛。佛言。彼金银犹此土石。随意用之

复有诸比丘安居。有贼难王难亲里难。以是白佛。佛言。应避去余处安居。有二种安居。前安居后安居。若无事应前安居。有事听后安居。后安居比丘至余处。彼比丘不与房舍卧具。以是白佛。佛言。应与。既与不住夺他住房。以是白佛。佛言。应随所得而住。比丘欲安居时。应先筹量此处有难无难。无难应住。有难应去

尔时舍卫城。有长者名忧陀延。信乐佛法。常供给诸比丘。安居中为僧作房。设入舍食欲因以房施。请左右住处诸比丘。诸比丘惭愧不受。长者便嫌诃言。我散财物作此饮食。而诸比丘不肯受请。诸比丘以是白佛。佛言。听受。若作比丘尼屋及外道房。乃至为垒阶道设食请施皆听受。若有请若无请须出界外。一切皆听七日往返。有一比丘。自不知律不依持律。安居中生疑作是念。世尊不听我安居时游行。无有问处。不知云何。以是白佛。佛言。听依有持律比丘处安居。若持律住处房舍迮狭。听近持律七日得往返处。于中心念遥依持律而安居。有一比丘。分房卧具竟。不作是念。我今安居口亦不言。后生疑悔。我不结安居为成安居不。以是白佛。佛言。为安居受房舍敷卧具。虽不发心口言。结之亦得名安居

时舍卫城人欲于祇洹作渠通水。波斯匿王闻令言。若有于祇洹通水者当与大罪。后边境有事王自出征。后诸外道欲并力通渠。诸比丘以此语诸优婆塞。诸优婆塞言。此非我等所制。可往白王。诸比丘言。世尊不听安居中过七日往返。王去此远何由得往。便以白佛。佛以是事集比丘僧。告诸比丘。从今若有佛法僧事若私事。于七日外更听白二羯磨受十五日若一月日出界行。一比丘唱言。大德僧听。此某甲比丘为某事欲出界行。于七日外更受三十夜还此安居。若僧时到僧忍听。白如是。大德僧听。此某甲比丘为某事欲出界行。于七日外更受三十夜还此安居。谁诸长老忍默然不忍者说。僧已与某甲更受三十夜出界行竟。僧忍默然故。是事如是持。有一比丘安居。粗食不足。作是念。我此中安居。粗食不足。而世尊不听破安居。我当云何。以是白佛。佛言。听以此因缘破安居无罪。复有一比丘安居。有一比丘尼诱共作不净行。作是念。人心易转后或失意。而世尊不听破安居。我当云何。以是白佛。佛言。听以此因缘破安居无罪。式叉摩那乃至黄门亦如是。若国王欲坏其梵行乃至父母亲戚亦如是。有一比丘安居。见伏藏作是念。此藏足我一生用。若久住此或能失意。而世尊不听破安居。我当云何。以是白佛。佛言。听以此因缘破安居无罪。若见国王尊贵乃至见父母亲戚苦乐恐失道意皆亦如是。有一比丘安居。闻有比丘欲破僧作是念。若有破僧事僧不和合不得安乐。而世尊不听破安居。我当云何。以是白佛。佛言。听以此因缘破安居无罪。复有一比丘安居。闻异住处有比丘欲破僧是已亲厚。作是念。若我往谏必受我语。而世尊不听破安居。我当云何。以是白佛。佛言。听以此因缘破安居无罪。若能使人谏为此而去。若彼处僧已破若自和合。若使人和合为此而去皆亦如是。比丘尼能和合僧亦如是。时有估客营住诸比丘欲依安居。以是白佛。佛言。听依彼估客安居内。忽然复去。诸比丘不知云何。以是白佛。佛言。听随去。诸估客分作两部。诸比丘不知云何。以是白佛。佛言。若一部信乐所之丰乐随去。比丘有持律彼处亦多持律听随此部去。若依牧牛羊人作椑筏人船行人安居皆亦如是。有诸比丘安居中烧房舍卧具无有住处。不知云何。以是白佛。佛言。若火烧若水漂王难贼难非人难师子虎狼诸毒虫难乃至蚁子水虱难。皆听破安居无罪。时跋难陀受安居请布萨竟。往中路见二住处。多有衣食施。便住其中。二处各半皆欲取分。诸比丘以是白佛。佛以是事集比丘僧。问跋难陀。汝实尔不。答言。实尔世尊。佛种种诃责言。汝愚痴人。云何已受他请。为利养故住二处安居。告诸比丘。从今若比丘受他前安居请。布萨竟往中路。见二住处多有衣食施便住。无前后安居得违言突吉罗罪。若比丘受他前安居请。布萨竟往不至。至十七日明相出。是比丘无前安居有后安居。不破安居得违言罪。若受他前安居请。布萨竟往结安居。不受七日出界外。七日内还不还。是比丘无前安居有后安居。不破安居得违言罪。若受他前安居请布萨竟往结安居。受七日出界外不还。无前安居有后安居。不破安居得违言罪。若七日内还。不破安居不犯违言罪。若受他前安居请。布萨竟往结安居。未至自恣七日。无七日法出界外。亦无前安居有后安居。不破安居得违言罪。若有七日法出界外。不破安居不犯违言罪。若比丘受他前安居请。往彼布萨亦如是

若比丘受他后安居请。布萨竟往中路。见二住处多有衣食施便住不往。破安居违言二突吉罗罪。若受他后安居请。布萨竟往不至。至十七日明相出。是比丘破安居违言二罪。若受他后安居请。布萨竟往结安居。不受七日出界外。七日内若还若不还。及受七日七日内不还。皆破安居违言二罪。若七日内还。不破安居不犯违言罪。若受他后安居请。布萨竟往结安居。未至自恣七日无七日法出界外。破安居违言二罪。若有七日法出界外。不破安居不犯违言罪。若受他后安居请。往彼布萨亦如是

有一比丘求安居处。见有空窟作是念。我当于此安居。复有众多比丘见皆作是念。而不相知。至安居前布萨日俱集于彼。皆言我已先取此窟。不知谁应得住。以是白佛。佛言。若先至者应作相。若题壁作自名。若语窟左右人。后引为证。此人应得。复有比丘。先占住处后竟不来。余比丘不敢住。遂空置此处。以是白佛。佛言。应坏相若语人令知。使余比丘得住

    五分律第三分之四自恣法

佛在舍卫城。尔时众多比丘住一处安居。共议言。我等若共语者。或致增减。当共立制。勿复有言。若乞食先还。便扫洒食处。以瓶盛水出拭手脚巾。敷诸坐具置盛长食器。量食有长减着其中。如其得少从此取足。食竟次第除屏物事。若独不胜招伴共举。如此安居得安乐住。无复是非增减之患。作此议已即便行之。安居既竟。诸佛常法。岁二大会。往到佛所头面礼足却坐一面。佛慰问言。汝等安居和合乞食不乏道路不疲耶。答言。安居和合乞食不乏道路不疲。又问汝等安居云何和合。诸比丘即具以答。佛种种诃责。汝等愚痴。如怨家共住。云何而得和合安乐。我无数方便教汝等共住。当相诲诱转相觉悟以尽道业。于今云何而行哑法。从今若复立不共语法得突吉罗罪

尔时六群比丘数数犯罪。诸比丘以佛教应相诲语。便语言。汝等数数犯罪。应自见过而修改悔。勿得污染梵行自贻大苦。负人信施空无所获。六群比丘不自改过。反更诬谤长老比丘犯种种罪。彼闻已惭愧便往佛所。以是白佛。佛以是事集比丘僧。问六群比丘。汝实尔不。答言。实尔世尊。佛种种诃责已告诸比丘。若有比丘犯罪。应先问言。我欲诲汝。汝听我不。言听则诲。不听则已。若不听犯突吉罗罪。六群比丘后时犯罪。便逆问长老比丘。我欲诲汝。汝听我不。彼作是念。佛制不得不听。便答言。随意说之。六群比丘复言。若随我意当随我说。何罪何时说何处说。彼闻此语便逐其后不敢远离。以是白佛。佛复问六群比丘。汝实尔不。答言。实尔世尊。佛种种诃责已告诸比丘。若成就五法。不应问听语罪。无惭愧愚痴少闻自不如法苟彰人恶。若有惭愧多闻智慧自如法实欲使人离恶。乃应问听说罪。复有五法。不应问听说罪。随爱随恚随痴随畏。不知时非时。反上应问听说罪。若成就五恶法而问。不应敬听说罪。若成就五善法而问。应敬听说罪

时诸比丘作是议。如世尊所说。应问听不应问听。应敬听不应敬听。唯有罗汉然后应问。我等云何而得行此。以是白佛。佛以是事集比丘僧。问诸比丘。汝等实作此议不。答言。实尔世尊。佛告诸比丘。从今以十利故。为诸比丘作自恣法。应求僧自恣说罪言。诸大德。若见我罪。若闻我罪。若疑我罪。怜愍故自恣说。我当见罪悔过。如是三说

时诸比丘作是念。世尊教我等自恣应共奉行。便日日自恣。或二日三日至五日一自恣。以是白佛。佛言。不应尔。应夏三月最后日自恣。诸比丘便于比丘尼式叉摩那沙弥沙弥尼前自恣。若白衣外道狂心乱心病坏心被举灭摈异见人前自恣。以是白佛。佛言。不应尔。应在如法比丘众中自恣。有诸比丘坐床上自恣。以是白佛。佛言。不应尔。诸比丘既下地自恣污衣服。以是白佛。佛言。应好泥治地布草于上自恣。六群比丘言。若次至我然后下地。以是白佛。佛言。不应尔。应一比丘先唱言。大德僧听。今僧自恣时到。僧当和合作自恣。白如是。然后俱下地胡跪自恣。诸比丘自恣未竟。上座老病不堪久跪。以是白佛。佛言。听自恣竟者还坐。诸比丘已自恣竟便出去。以是白佛。佛言。不应先出。要待都竟。诸比丘一时向上座自恣。不知谁已自恣谁未自恣。以是白佛。佛言。不应一时自恣。诸比丘便复一一从上座自恣。有诸白衣欲布施听法久不能得。便讥诃言。我等多务废业来此。而诸比丘不时受施为我说法。诸比丘以是白佛。佛言。不应一一自恣。听上座八人一一自恣。自下同岁同岁一时自恣。诸比丘不知自恣已至何处。以是白佛。佛言。应白二羯磨差自恣人若二若多。一比丘唱言。大德僧听。此某甲某甲比丘。能为僧作自恣人。僧今差某甲某甲作自恣人。若僧时到僧忍听。白如是。大德僧听。此某甲某甲比丘。能为僧作自恣人。僧今差某甲某甲作自恣人。谁诸长老忍默然不忍者说。僧已差某甲某甲作自恣人竟。僧忍默然故。是事如是持。诸比丘差无智比丘作自恣人。以是白佛。佛言。五法成就不应差。随欲恚痴畏不知时非时。反上应差。被差比丘应起语诸比丘言。同岁同岁一处坐。自恣人不知。已何时当应自恣。以是白佛。佛言。次第至已便应自恣。诸比丘作如是自恣犹故迟。诸白衣如上讥诃。以是白佛。佛言。被差人复应唱言。各各相向自恣。诸比丘自恣竟复更布萨。以是白佛。佛言。自恣羯磨亦名布萨

尔时世尊。自恣日与诸比丘前后围绕露地而坐。告诸比丘。今僧和合自恣时到应共自恣。有一比丘起白佛。有病比丘不来。佛言。应差一比丘将来。乃至出界自恣。如说戒中说。时六群比丘有罪自恣。以是白佛。佛言。不应尔。犯者突吉罗。彼犹故有罪自恣。以是白佛。佛言。应住。其自恣诸比丘未羯磨时便住。他自恣复有自恣竟方住。以是白佛。佛言。不应尔。羯磨竟未自恣时应住

告诸比丘。有四不如法住自恣。四如法住自恣。何谓四不如法住自恣。谓住无根破戒。无根破见。无根破威仪。无根破正命。若反上为四如法住自恣。复有七不如法住自恣。七如法住自恣。何谓七不如法住自恣。谓住无根波罗夷。无根僧伽婆尸沙。无根偷罗遮。无根波逸提。无根波罗提提舍尼。无根突吉罗。无根恶说。反上为七如法住自恣。复有八不如法住自恣。八如法住自恣。何谓为八不如法住自恣。谓住无根破戒无作。无根破见无作。无根破威仪无作。无根破正命无作。反上为八如法住自恣。复有九不如法住自恣。有九如法住自恣。何谓九不如法住自恣。谓住无根破戒作不作。无根破见无根破威仪亦如是。反上为九如法住自恣。复有十如法住自恣。十不如法住自恣。何谓十如法住自恣。有一比丘以此相以此事受如法治罪羯磨。若比丘见其以此相以此事受如法治罪羯磨。是比丘后于余僧中说其已受如法治罪羯磨住其自恣。是谓如法住自恣。若住其自恣时。有难起僧皆散去。后见之复如前住其自恣。是谓如法住自恣。若舍戒。若犯波罗夷。若犯僧伽婆尸沙。若犯偷罗遮。若犯波逸提。若犯波罗提提舍尼。若犯突吉罗。若犯恶说。若比丘以此相以此事于僧中说其犯住其自恣。是名如法住自恣。反上名为不如法住自恣。时优波离问佛言。世尊。比丘以几法住他自恣。佛言。以五法住他自恣。以实不以虚。以时不以非时。以有利益不以无利益。以慈心不以恶意。以柔软语不以刚强。又问世尊。欲住他自恣。应几法自筹量。佛言。应以五法自筹量。应量我住彼自恣。为实为虚若虚不应住。若实应更审定。为时为非时。若非时不应住。若时应更审定。为有利益为无利益。若无利益不应住。若有利益应更审定。为当因此起诤破和合僧为不破。若破不应住。若不破应更审定。复应量我住彼自恣。持法持律解律仪聪明辩才学戒比丘如法助我不。若彼必助亦应更审。审已以时住自恣

又问世尊。欲住他自恣。应几法自观。佛言。应五法自观。自观身行清净口行清净意行清净多诵修多罗善解阿毗昙不。若身口意行不清净。诸比丘便当言。汝身口意行不清净。云何住他。若不多诵修多罗。诸比丘便当言。汝从谁闻何经中说。未能不师人何能师物。若不善解阿毗昙。诸比丘便当言。汝所说有何义。汝自不知义云何住人

又问世尊。有几法住他自恣后无悔。佛言。有五法住他自恣后无悔。怜愍故。利益故。欲济拔故。使从恶戒出故。住全戒中故。又告优波离。有五种住他自恣后生悔心。诸比丘语言。汝说他罪不实汝应止。汝所说非时汝应止。汝所说无有利益汝应止。汝以恶意说他罪非是慈心汝应止。汝所说刚强非柔软语汝应止。若反上后不生悔心

此彼住自恣比丘。有五事不应忧。诸比丘语言。彼不实住汝自恣。汝不应忧。彼非时住汝自恣汝不应忧。彼无利益住汝自恣。汝不应忧。彼以恶意住汝自恣。汝不应忧。彼非软语住汝自恣。汝不应忧

优波离问佛若比丘入僧中应以几法。佛言。应以五法。一下意。二慈心三恭敬。四知次第坐处。五不论说余事。复有五法。不应反抄衣不应左右反抄衣。不应叉腰。不应覆头。应恭敬僧。优波离问佛。比丘有几法得与僧和合羯磨。佛言。有五法得与僧和合羯磨。应同见应随僧应信有事应自往若与欲复语。优波离。若有僧事不应不往。若不往则异于僧。有五种见。于僧事为不如法。应心念而口语。应口语而心念。非法助僧。助非法人。犯言不犯。若反上为如法

有一比丘。自恣日犯突吉罗罪。向余比丘说。半云是突吉罗。半云是恶说。二部中各有持律聪明智慧有惭愧心乐学戒法。共诤不决。以住自恣。诸比丘不知云何。以是白佛。佛言。应一比丘将至眼见耳不闻处教作恶说悔过还白僧。彼比丘已作法。僧应自恣。诸比丘不得问作何等法。问者突吉罗。复有一比丘。自恣日犯突吉罗罪。向余比丘说。半云是波罗提提舍尼。半云是突吉罗。乃至半云是波罗夷。半云是突吉罗。二部中各有持律聪明智慧有惭愧心乐学戒法。共诤不决。以住自恣。诸比丘不知云何。以是白佛。佛言。应一比丘将至眼见耳不闻处教作突吉罗悔过还白僧。彼比丘已作法。僧应自恣。诸比丘不得问作何等法。问者突吉罗。犯波罗提提舍尼乃至偷罗遮亦如是。若犯僧伽婆尸沙。若犯波罗夷。应白羯磨停此事。大德僧听。今停此事。自恣后当如法断。白如是。作此白已应自恣。不得不自恣

有一比丘。自恣日语诸比丘言。有物无人因共空论。半云有物无人。半云有人无物。共诤纷纭。诸比丘不知云何。以是白佛。佛言。应白停此事自恣。不得不自恣。若白停已有还发此论者。犯波逸提

有病比丘住病比丘自恣。病比丘住无病比丘自恣。无病比丘住病比丘自恣。不相顺从。诸比丘不知云何。以是白佛。佛言。不应尔。犯者皆突吉罗。若病比丘住病比丘自恣。诸比丘应语言。汝今病何以住他。若病比丘住无病比丘自恣。亦应如是语。若无病比丘住病比丘自恣。诸比丘应语言。汝且止。此比丘病。可待差住之。有诸比丘遣使住他自恣。诸比丘以是白佛。佛言。不应遣使住他自恣。犯者突吉罗。时跋难陀犹遣使住他自恣。诸比丘以是白佛。佛言。受使人得突吉罗。跋难陀犯波逸提。或愚痴比丘住愚痴比丘自恣。或愚痴比丘住智慧比丘自恣。或智慧比丘住愚痴比丘自恣。不相顺从。诸比丘以是白佛。佛言。不应尔。犯者突吉罗

若比丘住他比丘自恣。众僧知见彼人身口意业不清净少闻愚痴者。不应受其语。但当自恣。若僧见彼人身口意业有清净有不清净及少闻愚痴亦如是。若僧见彼人身口意净多闻智慧。应受其语。当问言。汝见彼有何等过。为破戒为破见为破威仪为破正命。若言破戒。应问。汝知破戒相不。若言不知。诸比丘应诃令惭。语言。汝不知破戒相。而在僧中说他破戒。僧若不作此诃。皆犯突吉罗。若言知。诸比丘应问。何等是破戒。答言犯波罗夷僧伽婆尸沙。若言破见。应问。汝知破见相不。若言不知。诸比丘应如上诃。若不诃皆犯突吉罗。若言知。应问。何等是破见。答言。无今世后世无罪福报应无父无母无阿罗汉。若言破威仪。应问。汝知破威仪相不。若言不知。诸比丘应如上诃。若不诃皆犯突吉罗。若言知。应问。何等是破威仪。答言。犯波逸提波罗提提舍尼突吉罗恶说。若言破正命。诸比丘应问。汝知破正命相不。若言不知。诸比丘亦应如上诃。若不诃皆犯突吉罗。若言知。应问。何等是破正命。若言谄曲心以求利养。僧复应更问。汝为见为闻为疑。若言见。应问。云何见何时见何处见。汝在何处彼在何处。若作是问不能答。应如法治已自恣。不应不自恣。闻疑亦如是

有一住处。众僧于中安居三月皆得道证。作是念。若三月竟便自恣者。便应移去则失此乐。诸比丘不知云何。以是白佛。佛言。今听诸比丘三月自恣日皆集一处。应一比丘唱言。大德僧听。我等于此安居得一心乐。若自恣便去者则失此乐。今共停此至八月满作四月自恣。白如是。如是白竟。若有欲远行比丘听自恣便去。若有欲住其自恣者。僧应为如法捡校使得自恣而去。若去比丘欲住后比丘自恣。诸比丘应语言。我等未自恣。汝云何得住。若彼去已至后自恣时。还住诸比丘自恣者。诸比丘应如法检校竟应自恣

有诸比丘一处安居。闻某处好斗比丘当来。作是议言。彼来必住我等自恣。诸比丘不知云何。以是白佛。佛言。未至自恣二三日。应自恣而去。若闻今日至。应即自恣而去。若闻已入界内。应疾出界外自恣而还。若不得。应出迎礼拜问讯。为捉衣钵办洗浴具。将入浴室与涂身油蜜。出界外自恣。若复不得。应为办食随在界内外。若在界内食。食时应出界外自恣。若在界外食。食时应住界内自恣。若复不得。应共集自恣后。一旧比丘白诸旧比丘言。大德僧听。今共布萨说戒后四月黑十五日当自恣。白如是。客比丘若言何故四月黑十五日自恣。旧比丘应答言。本不共安居不应问我。若客比丘复至黑十五日者。旧比丘复应如上白。后白十五日当自恣。乃至不应问我亦如上。客比丘复至白十五日者。复应为作食如上。若得者善。若不得便应强共和合自恣。不得不自恣

五分律卷第十九五分律卷第二十(弥沙塞)

        宋罽宾三藏佛陀什共竺道生等译

    第三分之五衣法上

佛在王舍城。尔时耆域乳母洗浴耆域。谛观其身而有恨色。耆域觉之即问。何故恨颜视我。乳母言。恨汝身相殊特而意未亲佛法众僧。耆域闻已赞言。善哉善哉乃能教我如此之事。便着新衣往至佛所。遥见世尊容仪挺特有三十二大人之相圆光一寻犹若金山。即生信敬前礼佛足却坐一面。佛为说种种妙法示教利喜。所谓施论戒论生天之论。在家染累出家无著。示现如是助道之法。次为说诸佛常所说法苦集灭道。即于座上远尘离垢得法眼净。见法得果已。归依佛法僧。次受五戒。耆域善别音声本末之相。佛将至冢间示五人髑髅。耆域遍叩。白佛言。第一叩者生地狱。第二叩者生畜生。第三叩者生饿鬼。第四叩者生人道。第五叩者生天上。佛言。善哉皆如汝说。复示一髑髅。耆域三叩不知所之。白佛言。我不知此人所生之处。佛言汝应不知。何以故。此是罗汉髑髅无有生处

尔时世尊身小有患。语阿难言。我病应服吐下药。阿难白佛。当语耆域。即往语之。耆域言。我不可以常药令如来服。当合转轮圣王所应服者。便以药薰三优钵罗华。持至佛所白佛言。愿嗅此华。嗅一华应十行下。三华三十。病乃都差。世尊即嗅二华。得二十行下。余一华得九行下。耆域须臾来至佛所白言。药得下不。下为多少。佛言。药虽得行下犹少一。耆域白佛。应服暖水。即便服之。更得一行病即除差。耆域复白。应须补养。我当随时供养所应。佛默然受。耆域便作栴檀糁羹以奉世尊。世尊服已。复白佛言。我为国王臣民治病。或得百千两金七宝无数。或得聚落或得一邑。唯愿世尊与我微愿。佛言。诸佛如来已过诸愿。复白佛言。愿佛与我可得之愿。佛言。若是可得不违汝意。于是耆域即以一贵价衣价直半国奉上于佛。白佛言。此衣于诸衣中最为第一。愿哀愍受。又愿听诸比丘受家衣施。佛即受之。亦听诸比丘受家衣施。为说种种妙法遣还所住。佛以是事集比丘僧。告诸比丘。耆域治我病差。持一上衣施我。又愿听诸比丘受家衣施。我为受之。亦听诸比丘受家衣施。从今诸比丘欲着家衣听受。然少欲知足着粪扫衣我所赞叹。尔时王舍城诸居士。闻佛听诸比丘受家衣施。共持青黄赤黑纯色劫贝三千张施诸比丘。诸比丘以色为疑。以是白佛。佛言。听受。应浣坏好色更染而着。有诸比丘往冢间观死尸。从足至头作不净观。起尸鬼入死尸中张眼吐舌踏诸比丘。诸比丘恐怖。非人得便。夺其精气。有命过者。复有一比丘。至冢间从足至头观新死女人。生欲心便行不净。以是白佛。佛言。不应先从足观

复有比丘于傍观死人。起尸鬼复入尸中。张眼吐舌以手打之。以是白佛。佛言。莫于傍观应在头前观

复有诸比丘。为衣故掘出新死人。诸居士见讥诃言。此释子沙门臭秽不净。云何以此入我家中。诸长老比丘闻。以是白佛。佛言。不应掘出死人。犯者突吉罗

复有诸比丘。持死人骨着僧坊中。有持死人髑髅着经行处若床下。诸居士见讥诃言。诸比丘不净可恶。云何持死人骨着僧坊内。犹如冢间畜死人髑髅犹如畜钵。诸比丘以是白佛。佛言不应尔。亦不应以手捉死人骨。犯者突吉罗

有诸比丘患眼。医言。以人额骨磨着眼中。诸比丘言。佛不听我等捉死人骨。更说余方。医言更无余治。诸比丘作是念。若世尊听病时捉死人骨者病可得差。以是白佛。佛言。听屏处取骨如二指大磨着眼中

有诸比丘。食麻蜜鱼肉。往冢间求粪扫衣。鬼神不喜。以是白佛。佛言。不应食此诸物往至冢间

有诸比丘。于佛僧中及白衣家食麻蜜鱼肉。行路经由冢间而辄避去。由此失伴。以是白佛。佛言。若不畏者听从边过

有诸比丘常住冢间乞得鱼肉食不敢复还。以是白佛。佛言。若不畏者听还。有诸比丘。月八日十四日十五日。往来冢间求粪扫衣。诸鬼神此日亦集。语诸比丘言。今是我等集日汝何为来。诸比丘以是白佛。佛言。不应以此日往冢间。常住冢间及行路比丘此日皆不敢往。以是白佛。佛言。若不畏者听

有诸比丘大小便冢间。诸鬼神讥诃言。云何于我住处大小便。以是白佛。佛言不应尔。有冢间旷远诸比丘经过不敢起止。由此致病。以是白佛。佛言。应先弹指然后便利。若鬼神欲闻经典赞呗说法。应为作之。时迦夷王以钦婆罗宝衣与耆域。耆域即持至僧坊施僧。诸比丘不知云何。以是白佛。佛言应受用庄严塔

有诸比丘得长短毛及无毛杂色氀氀不敢受。以是白佛。佛言听受。杂色者听浣坏色乃着。若不能令纯色坏者。听在僧坊内着

有诸比丘。得已成毡及未成者不敢受作。以是白佛。佛言听受作

有诸比丘欲于街巷中拾粪扫衣。以是白佛。佛言听拾。时有白衣。于街巷中脱衣大小便。诸比丘谓是粪扫衣便取。彼言大德。莫取我衣。比丘答言。我谓是粪扫衣是以取耳。白衣复言汝不顾视而便取之。是为偷衣。诸比丘以是白佛。佛言。应谛看之若尘坌日曝有久故相顾视问人然后取之。诸比丘拾粪扫衣未浣着房中臭秽不净。以是白佛。佛言。不应未浣持入房。有诸比丘拾粪扫衣不即浣生虫。以是白佛。佛言应即净浣

有诸比丘于净池中及上流浣粪扫衣。以是白佛。佛言不应尔

有诸比丘以净器浣粪扫衣。以是白佛。佛言不应尔

佛从王舍城。与大比丘僧千二百五十人游行人间。诸比丘担粪扫衣。佛见已作是念。我当为诸比丘作齐限受家衣施。时瓶沙王闻。佛与千二百五十人游行人间。作是念。我今宁可将四种兵侍卫世尊游我境内。念已敕严四种兵侍从佛后。佛展转到恒水欲渡到跋耆国。目连念言。若用舡渡恐王久留或有所废。我今当以神力令此水浅。念已即令水浅。佛与比丘一时涉渡。佛度彼岸而说偈言

  精进为舟筏　　能济深广河
  孰有睹若斯　　不发信敬心

于是瓶沙王作是念。佛已出我界便应回还。即合掌遥礼而归。佛到屈茶聚落告诸比丘。有四法我及汝未得时。于生死中轮转无际。何谓为四。所谓圣戒圣定圣慧圣解脱。今既得之。生死已尽梵行已立所作已办。即为诸比丘而说偈言

  戒定慧解脱　　我今如是觉
  已尽诸苦源　　故为汝等说

时佛将五百比丘游行跋耆国欲到毗舍离城彼有淫女名阿范和利。闻佛世尊有大名德号如来应供等正觉。所可说法初中后善具足清白梵行之相。游行诸国将到此城。叹言善哉我愿欲见。即严四马车从五百妓女出迎世尊。佛遥见之告诸比丘。汝等各当系念在前自防护心。是诸佛教。何谓系念。谓行四念处观内身循身观除无明世间苦观。外身内外身及痛心法亦如是。何谓在前。所谓若行若立若坐若卧若睡若觉若去若来若前后视瞻若屈伸俯仰若着衣持钵若食饮便利若语若默常一其心。此是我教。阿范和利遥见世尊容颜殊特诸根寂定有三十二大人相圆光一寻犹若金山。便生信乐前至佛所头面礼足却住一面。佛为说种种妙法示教利喜已。白佛言。世尊。愿佛及僧于我园宿受明日请。佛默然受之。阿范和利知佛受已礼绕而退。时五百离车闻佛与比丘僧游行国界来向此城。共要迎佛。若不出者罚金钱五百。要已皆出。或乘青马青车。一切眷属衣服皆青。黄黑赤白皆亦如是。阿范和利中道相逢不避其路。诸离车言。何以不避使车马相突。阿范和利言。我请佛及僧于园宿明日设食不暇相避。诸离车言。我等亦欲请佛。汝听我先。答言。已受我请不得相让。诸离车言。与汝五百千两金。听我在先。答亦如上。诸离车复言。与汝半国财物可乎。答言。正使举国亦不可得。若能保我三事无失。尔乃相许。诸离车言。何谓二事。答言。一者保我身命必无夭夺。二者保我财物必无损失。三者保佛常住必无余行。诸离车言。若财物损失我能相与。若佛余行我能请留。汝命危脆谁能保者。便嗔恚而去。佛遥见诸离车来。告诸比丘。欲知忉利诸天出入与此无异。诸离车见佛容颜殊特乃至犹若金山。下车步进前至佛所头面礼足却坐一面。时彼众中有一摩纳名宾只耶。从坐起偏袒右肩胡跪合掌白佛言。我欲以偈赞叹世尊。佛言随意。即便说之

  瓶沙得善利　　鸯伽持珠铠
  佛昔出其国　　声若雷霆震
  亦如花新开　　其香甚芬馥
  观佛身光耀　　如日丽于天
  又如月盛满　　升空无云翳
  世尊光明身　　灼灼复踰此
  佛慧无不鉴　　消灭阴谋情
  能施世间眼　　决断诸疑惑

诸离车闻偈欢喜。即与五百领衣。摩纳言。我不须衣。愿先请佛。佛语离车。可听先请。即便听之。与衣如故摩纳得衣即以上佛。佛为受之。告诸离车。世有五宝甚为难遇。一者诸佛世尊二者善说佛所说法三者闻法善解四者如闻能行五者不忘小恩。诸离车闻法欢喜共作是议。佛不久住人人别供不得周遍。今当敛物随日供设。非我种族不听豫之。阿范和利竟夜作种种美食。旦持至园敷坐具毕白时已到。佛告诸比丘。汝等系念共受彼食即皆就坐。奈女手自斟酌欢喜无乱。食毕行水却住一面。白佛言。毗舍离诸园观中此园第一。我修此园本欲为福。今奉世尊。愿垂纳受。佛言。可以施僧得大果报。奈女重以上佛。佛言。但以施僧我在僧数。奈女受教即以施僧。便取小床于佛前坐。佛为说随喜偈。如为毗兰若所说。复更为说种种妙法示教利喜。即于坐上得法眼净。次受三归五戒从坐起礼佛而去。诸离车于后如议供养。佛从毗舍离渐渐游行到钵遮罗塔。时冬大寒着一衣露地而宿。初夜过已觉寒复着一衣。中夜过已觉寒复着一衣。不复苦寒。作是念。未来诸比丘若不耐寒。着此三衣足以御之。我今宁可为诸比丘制畜三衣。明旦以是集比丘僧。告诸比丘。我先于王舍城游行。见诸比丘担重担衣。尔时欲为制家施衣齐限。昨夜极寒吾先着一衣。中夜初觉寒复着一衣。后夜初觉寒复着一衣。便不复苦寒。即作是念。未来诸比丘有不耐寒者。着此三衣足以御之。我今宁可为诸比丘制畜三衣。今以十利故。为诸比丘制畜三衣。不听有长。若衣弊坏。听补治以复綖却刺亦听直缝。时诸比丘畜拘修罗衣。诸居士见讥诃言。比丘着拘修罗。何异我等着贯头衣。以是白佛。佛言。不听着拘修罗衣。犯者突吉罗。有一比丘安陀会坏。权缝合作拘修罗着之后生疑悔。以是白佛。佛言。听暂作着。有诸比丘畜贯头及有袖衣拘摄披上。以是白佛。佛言。不听畜贯头及有袖衣。犯者突吉罗。若得听受坏作余衣。有一外道。以杂色綖缝着衣上作条幅处。后于佛法中出家犹着此衣。诸居士见讥诃言。沙门释子着外道衣不可分别。诸比丘以是白佛。佛言。不听着外道衣。犯者偷罗遮。若不知是外道衣而非佛所听皆应坏之。若知是外道衣应擿綖布地令人蹈上速使坏尽

有诸比丘在树下坐禅。众鸟作声乱其禅思屎污身体。以是白佛。佛言听驱鸟若作禅屋

有诸比丘欲往冢间取死人衣。以是白佛。佛言听取。即便取之。后有比丘亦往取衣。见前比丘语言。与我共分。比丘不与。以是白佛。佛言应共分。有诸比丘。先在冢间得衣。与后来比丘共分。分时复有比丘来索分。诸比丘不与。以是白佛。佛言亦应共分。分衣已各欲还。复有比丘来索分。诸比丘不与。以是白佛。佛言亦应共分。分已各还垂出冢界。复有比丘来索分。诸比丘不与。以是白佛。佛言。亦应共分。分已各还已出冢界。复有比丘来索分。诸比丘不与。以是白佛。佛言不应共分

有一比丘着衣持钵入村乞食作是念。我今乞食犹早。便往冢间多得诸衣。得已复作是念。若持入村担重可耻。若先持归。时或复过。便束藏之。然后乞食。复有一比丘。食后前至冢间求衣。见前比丘所得衣便持归。前比丘后往取衣。不知所在还到僧坊。见一比丘浣之。语言莫浣我衣。彼比丘言非是汝物。前比丘具以事语。彼比丘言。冢间无主物如何占护。以是白佛。佛言。应属前比丘。从今若先得衣。置冢间者应作帜有。比丘以死人骨作。帜后诸比丘谓是鸟衔着上即便取之以是白佛。佛言不应以死人骨为帜。又有比丘以绛汁作帜。诸比丘谓是血污。即便取之。以是白佛。佛言不应以绛汁作帜。应用青黑木兰。若以袈裟衣片帖上

有诸比丘共要半入村乞食。半冢间求衣还共分之。要已而去。往冢间者大得诸衣。悔言。我得衣属我。彼得食属彼。不能复共。乞食比丘还以食与之。得衣比丘不受如上语之。乞食比丘言。先共明要。如何中悔。以是白佛。佛言应共分。取衣比丘得衣时共要。若能担此衣还所住者。当与二分。既担还复悔不与。以是白佛。佛言应与浣亦如是

有一比丘往冢间见一新死人欲取其衣。起尸鬼入身中起语言。大德莫取我衣。答言。汝已死非是汝衣便强夺取。死人大唤逐到僧坊。诸善鬼神不听入。便住门外见出入比丘语言。有一比丘夺我衣来。可令见还。诸比丘入问。外有一人云。有比丘夺其衣来。谁持来者。得衣比丘言。此是死尸非生人也。诸比丘以是白佛。佛言。若新死身未有坏处。起尸鬼犹着。不应取其衣。可以还之。若取未伤坏死人衣突吉罗。彼比丘即以衣还之。死尸得衣便倒地。彼比丘以是白佛。佛言可持着冢间。比丘即持衣行。死尸彼起逐后。既到冢间以衣着地。尸复还倒。有一比丘往冢间。见一人着新钦婆罗卧冢荫中。谓是死人作是念。佛不听我取未伤坏死人衣。便打其头破。彼即惊起言。大德有何相犯打我头破。答言。谓汝是死人。彼言汝岂不知有喘息耶。如何为衣欲断我命。诸比丘以是白佛。佛言。不应自打若使人打死尸令伤坏。犯者突吉罗

时诸比丘得劫贝衣不截头须而着。诸居士见讥诃言。沙门释子亦着此衣。与我何异。诸比丘以是白佛。佛言不应着。犯者突吉罗

尔时世尊。与大比丘僧千二百五十人俱游行南方人间。从山上下见有水田善作畦畔。作是念。我诸比丘应作如此衣。即问阿难。汝见此田不。答言已见。又告阿难。诸比丘宜着如此衣。汝能作不。答言能。即受教自作。亦教诸比丘作。或一长一短。或两长一短。或三长一短。左条叶左靡。右条叶右靡。中条叶两向靡。作竟着之极是所宜。佛见已告诸比丘。阿难有大智慧。闻我略说作便如法。此名为割截不共之衣。与外道别异。怨家盗贼所不复取。从今听诸比丘割截作三衣。若破应补。佛在毗舍离城。有一住处。地极卑湿多诸蚊虻。诸比丘不得住。皆往舍卫城．瞻婆城．迦维罗卫城．王舍城安居。所住处空。诸居士言。大德可住此安居。我等当供给饮食。诸比丘言。此间多有蚊虻不能得住。诸居士复言。大德但住当送蚊幮。诸比丘不知得受不。以是白佛。佛言听受。诸比丘不知大小作。以是白佛。佛言应随床大小作

诸比丘常着一衣入聚落及还僧坊。初不易脱垢秽不净。诸居士见讥诃言。沙门释子不净可恶。常着一衣出入聚落。诸比丘以是白佛。佛言。于僧坊内应着衬身衣。不应着入聚落衣。诸比丘无房舍住欲作新房。以是白佛。佛言。听于僧坊内为僧作。余比丘不助。以是白佛。佛言应助。诸比丘便长助。妨坐禅行道。以是白佛。佛言不应长助。若力少不足然后助之。诸比丘作时坏污其衣。数数补浣妨坐禅行道。以是白佛。佛言。僧应作作时衣作时令着。诸比丘惭愧不敢衬身着。以是白佛。佛言。为僧作时听自恣着。诸比丘着僧衣小污便浣由是速坏。以是白佛。佛言。不应数数浣。作都竟然后浣举

诸比丘欲作新经行处。以是白佛。佛言听作。诸比丘便曲作。以是白佛。佛言应直作。诸比丘欲高作经行道。以是白佛。佛言听高作。两两经行道数数坏。以是白佛。佛言。听白墡渥亦听用衣及婆婆草布上

大会时人多房少诸比丘无住处。以是白佛。佛言。房内有容膝处听衣布地坐留中央。诸比丘既同房住便相闹乱。以是白佛。佛言。应以衣隔之亦听作窟。诸比丘倚壁坐。诸居士见讥诃言。此沙门释子为是老出家为是无威仪。云何倚壁而坐。以是白佛。佛言不应倚壁坐。有诸老病比丘。不能自持取草束倚坐污秽房中。以是白佛。佛言。不应倚草束听作隐机禅带。诸比丘广作禅带。以是白佛。佛言。不应过人八指。诸比丘复狭作禅带。以是白佛。佛言不应减五指。诸比丘复作杂色禅带。以是白佛。佛言应一种色作。若杂种色应浣坏色然后听畜。时长老柯休得一衣。欲作安陀会太长。欲作僧伽梨优多罗僧皆少。数数牵挽。佛行房见之问言。汝作何等。具以事答。佛言。若不足应三长一短。若复不足听两长一短。若复不足听一长一短。若复不足听帖作叶。长老柯休复得一衣。少不足作割截三衣。以是白佛。佛言听作割截僧伽梨优多罗僧漫安陀会。有大众会时诸白衣以衣布施。以是白佛。佛言听受。诸白衣欲得咒愿。以是白佛。佛言。应为咒愿。诸比丘不知咒愿。以是白佛。佛言。应使维那咒愿。不知持着何处。以是白佛。佛言。应如前白二羯磨当中央房着中。不知谁应守护。以是白佛。佛言应如前白二羯磨一比丘令守护。诸比丘便羯磨。无知比丘不别衣好恶。以是白佛。佛言。成就五法不应差守衣。随爱恚痴畏不知衣好恶。诸比丘于闹处分失衣。守衣比丘得恶名声。以是白佛。佛言。应静处分。分衣时有客比丘来。旧比丘问。汝某日在何处。答在某处。诸比丘言。我等得衣日此比丘在我界内今不成分衣。以是白佛。佛言。得衣日有比丘有比丘想不成分衣得突吉罗罪。有比丘疑亦如是。无比丘有比丘想成分衣得突吉罗罪。无比丘疑亦如是。无比丘无比丘想成分衣无犯

时诸比丘不衬体卧僧卧具垢污不净。复有一比丘不衬体卧僧卧具申脚蹋破。以是白佛。佛言。为护身护衣护僧卧具听畜单敷敷僧卧具上。时六群比丘以佛不听衬身卧僧卧具便以广数寸物敷僧卧具上。以是白佛。佛言。广长应如卧具。诸比丘不系念眠失不净污于单敷。以是白佛。佛言应以坐具敷单敷上。有诸比丘为壁虱所恼。以是白佛。佛言。听别作广长单敷敷着敷下垂床四边各一尺。时优波离问佛。世尊。几种衣应受持。佛言。三衣应受持。衬身衣被衣雨浴衣覆疮衣蚊幮敷经行处衣障壁虱衣单敷衣坐具护髀衣护[跳-兆+尃]衣护头衣拭体巾拭手面巾针綖囊钵囊革屣囊漉水囊。如此诸衣若似衣皆应受持。有一比丘白佛言。世尊。常为我等赞叹少欲知足我甚乐之。愿听我等裸形。佛言。愚痴人欲作外道仪法。犯者偷罗遮

有诸比丘白佛。或欲作人发衣鹿皮衣羊皮衣鸟毛衣马鬣衣牦牛尾衣草树皮叶衣。佛言。愚痴人欲作外道仪法。一切外道仪法皆不得作。作者偷罗遮

有一比丘白佛。愿听我等内着贯头衣跋那衣披上。佛言。愚痴人欲作白衣仪法。犯者突吉罗

有诸比丘。欲内着贯头衣外披劫贝衣。或欲作苏摩衣斑劫贝衣。或欲着指镮画眉眼着杂色革屣。以是白佛。佛言。愚痴人此是白衣仪法。一切白衣仪法皆不得作。犯者突吉罗

有一比丘白佛。愿听我等着纯青黄赤白黑色衣。佛言。纯黑色衣产母所著。犯者波逸提。余四色突吉罗。时诸比丘患头冷病。以是白佛。佛言。听以衣覆亦听作帽暖则止。有诸比丘不着僧祇支入聚落露现胸臆诸女人见笑弄。诸比丘以是白佛。佛言不应尔。入聚落应着僧祇支。犯者突吉罗

有诸比丘着僧祇支风吹落地。以是白佛。佛言应着带

有诸比丘在高上作诸女人在下见其形体笑弄。诸比丘羞耻。以是白佛。佛言。听作时取衣后从岐间过摄着前。时跋难陀知未分安居施物处。辄往语言。何不速分。若不分或有虫啮水火等难。若分可得自用。若与弟子及作福事。诸比丘即便分之。跋难陀言。汝等不别贵贱。诸比丘言。汝若善别为我等分。亦自取分即为分之。得分持去。复往余处如是非一。得重担衣。还归所住。诸比丘见赞言。汝大福德得如此衣。答言。非福所致。诸安居处巧说得耳。诸比丘种种诃责。云何一处安居诸处受施分。以是白佛。佛以是事集比丘僧。问跋难陀。汝实尔不。答言。实尔世尊。佛种种诃责言。我常说少欲知足。汝今云何多受无厌。诃已告诸比丘。不应一处安居诸处受安居施分。犯者突吉罗

时诸比丘但着上下衣入聚落。以是白佛。佛言。不应尔。犯者突吉罗

有比丘反着衣入聚落。诸比丘见语言。反着衣与着不割截衣有何异。以是白佛。佛言。不应尔。犯者突吉罗

有诸比丘未入村及出村草木钩衣破裂尘土入叶中欲反着不敢。以是白佛。佛言。为护衣故未入村及出村听反着

有诸比丘染漫衣作条又有缝叶着衣或摄作衣叶或半上向半下向作叶。以是白佛。佛言。不应尔。犯者皆突吉罗

有诸比丘着杂色衣。以是白佛。佛言。不应尔。犯者突吉罗

有诸比丘雨时倒着衣水入叶中烂坏。以是白佛。佛言。雨时不应倒着若不雨随意

尔时诸比丘有衣钵余物欲以施僧白佛。佛言。九种得施皆听施僧。一者界得施二者要得施三者限得施四者僧得施五者现前僧得施六者安居僧得施七者二部僧得施八者教得施九者人得施。界得施者。施主言。施此界内僧。是名界得施。要得施者。安居时异界住僧共要若一处得施尽共分。是名要得施。限得施者。施主言。施如是如是人。是名限得施。僧得施者施主施僧僧应知所施物随宣处分。是名僧得施。现前僧得施者。施主对面施僧。是名现前僧得施。安居僧得施者。施主言。施此安居僧。是名安居僧得施。二部僧得施者。施主施二部僧。若比丘多比丘尼少。若比丘尼多比丘少。皆应中分。若有比丘无比丘尼。比丘应尽分。若有比丘尼无比丘。比丘尼应尽分。是名二部僧得施。教得施者。施主教僧作如是如是用若共分。是名教得施。人得施者。施主言。我施某甲。是名人得施。复有五种得施。施佛及僧施佛及比丘尼僧施佛及二部僧为人施僧长请施

有一沙弥命过。诸比丘不知云何处分其物。以是白佛。佛言。若生时已与人应与之。若生时不已与人现前僧应分。有一少知识比丘命过。有上下衣及非衣。诸比丘不知云何。以是白佛。佛言。若生时不已与人现前僧应分。若生时已与人而未持去者。僧应白二羯磨与之。一比丘唱言。大德僧听。某甲比丘于此命过。生存时所有若衣若非衣。现在僧应分今与某甲。若僧时到僧忍听。白如是。大德僧听。某甲比丘于此命过。生存时所有若衣若非衣。现在僧应分今与某甲。谁诸长老忍默然若不忍者说。僧已与某甲衣竟。僧忍默然故。是事如是持。有一多知识比丘。为国王大臣众人所供养命过其物甚多。诸比丘不知云何。以是白佛。佛言。若生时先已与人。应白二羯磨与。若生时不已与人。有可分不可分者。若婆那衣苏摩衣劫贝衣拘摄毛长五指。若僧伽梨优多罗僧安陀会若下衣若舍勒若单敷若衬身衣若被若坐具若针綖囊漉水囊钵囊革屣囊若大小钵户钩。如是等物是可分者。现在僧尽应分。若锦若绮若毛[旁*毛]若毡若拘摄毛过五指。若雨浴衣若覆疮衣若蚊幮若经行敷若遮壁虱单敷若坐卧床及踞床。除大小瓦钵瓦澡灌。余一切瓦器。除大小铁钵户钩截甲刀针。余一切铁器。除铜揵镃铜多罗盛眼药物。余一切铜器若伞盖锡杖。如是等物是不可分者应属僧用

有诸比丘得安居施未分。或有命过者反俗者作外道者远行者作沙弥者更受大戒者变成二根者根灭者。诸比丘不知云何。以是白佛。佛言。安居得施未分。若命过者生时已与人。应白二羯磨与之。若生时不已与人。现前僧应分。反俗作外道远行变成二根根灭亦如是。作沙弥者应与沙弥分。更受大戒者应与大比丘分。有诸比丘于安居中未得安居施。或命过乃至根变。后得施亦如是。比丘尼亦如是。时调达得安居施未分破僧。诸比丘不知云何。以是白佛。佛言。若僧未破得物应等分。若破后得物应随所施分

有诸比丘同界僧破。后欲作诸羯磨与人受具足戒。不知云何。以是白佛。佛言。若僧已破虽同界听作羯磨行僧事不犯别众

有一住处一比丘住。非安居时得施僧衣。作是念。佛说四人已上名僧。我今一人不知云何。以是白佛。佛言。应受持若净施若施人。若不尔余比丘来应共分

若有比丘住处。非安居时得施僧物。若无比丘。比丘尼应分

若有比丘尼住处。非安居时得施比丘尼僧衣。若无比丘尼比丘应分

若有比丘住处。非安居时比丘命过。无比丘比丘尼应分。若有比丘尼住处。非安居时比丘尼命过。无比丘尼比丘应分。安居时得施皆亦如是

有一外道弟子于佛法律中出家。其诸亲族咸作是言。云何舍我阿罗汉道。于沙门释子中出家。当还取之。复作是言。彼若闻者或能逃避沙门释子不破安居。尔时往取必得无疑。彼比丘闻不知云何。以是白佛。佛言。听破安居去。彼比丘便从一住处至一住处。不知应于何处受安居施分。以是白佛。佛言。若住日多处应于彼受分。有二比丘共在道行。一比丘病。一比丘看之。彼遂命过。看病比丘持其衣钵来至佛所。以是白佛。佛以是事集比丘僧。告诸比丘。看病甚难。今听以三衣钵白二羯磨与之。一比丘唱言。大德僧听。某甲比丘命过。三衣钵现在僧应分今以与看病人。若僧时到僧忍听。白如是。大德僧听。某甲比丘命过。三衣钵现在僧应分今以与看病人。谁诸长老忍默然若不忍者说。僧已与某甲比丘衣钵竟。僧忍默然故。是事如是持

有一比丘懒惰初不佐助众事。亦不给侍和尚阿阇梨。得病无人看视屎尿污身不净臭秽。佛按行房见自为洗浴浣濯其衣除去不净扶卧床上在边安慰。汝莫恐怖汝今终不以此命过。彼比丘闻已欢喜。佛复为说种种妙法。远尘离垢于诸法中得法眼净。佛以是事集比丘僧问阿难。某房比丘何以无人看。阿难具以事答。佛语阿难。汝等所作非法。比丘无有父母。自不相看谁看。汝等今听诸比丘看病人。诸比丘不知谁应看病。以是白佛。佛言。弟子应看和尚。和尚应看弟子。阿阇梨同和尚阿阇梨亦如是。有客来比丘病。无和尚阿阇梨亦无同师无有看者。诸比丘不知云何。以是白佛。佛言。应先劝一人看之。若无此人应日日次第差一人。若不肯如法治。时诸比丘竞往看视恼乱病者。以是白佛。佛言不应尔。应两三人往为料理病所宜事。时看病人求药艰难。而病人不肯服妨废行道。以是白佛。佛言。病人有五事难看。不能节量食。不肯服病所宜药。不肯向看病人说病状貌。不从看病人教。不能恒观无常。有五事不能看病。不知病所宜药。不能得随病食。不能为病人说法示教利喜。恶厌病人屎尿涕唾。为利故看不以慈心。有诸看病人。或为病人或为私。行去后病人命过。余人得其衣钵。以是白佛。佛言。不应趣与人应与究竟看病者。有一比丘病看病人多。诸比丘不知几人应得衣。以是白佛。佛言。若比丘命过。应与二人衣。比丘沙弥。虽父母兄弟亦不应与。若比丘尼命过。应与三人衣。比丘尼式叉摩那沙弥尼。有诸比丘分看病沙弥物与沙弥三分之一。以是白佛。佛言应等分与。有命过比丘。先以衣净施诸比丘。诸比丘不肯还。以是白佛。佛言。若彼本非亲里善意施皆应还

时舍利弗目连自恣竟于左右游行。同安居及近住处诸比丘多有随从。诸白衣见。人人各念。当为舍利弗目连施僧安居衣。即便施之。大有所得。彼得施处诸比丘。语舍利弗目连言。共分此衣。答言我等不同安居。正可得食无此衣分。以是白佛。佛言应尽共分

时乙师达多跋陀罗自恣竟亦与众多比丘于左右游行。诸白衣见作是言。若比丘于我住处安居者。我施此衣所得亦多。彼诸客比丘索共分之。答言。施我界内安居比丘不得与汝。以是白佛。佛言不应共分

时有估客。赍钦婆罗从波利国来到拘舍罗。闻佛出世有大威神诸弟子亦复如是。便大持钦婆罗衣施僧。诸比丘言。佛未听我等受钦婆罗衣。以是白佛。佛言听受。复别与上座。亦不敢受言。佛未听我等别受钦婆罗衣。以是白佛。佛言亦听别受

时毗舍佉母作是言。若住我所作房者。应着用我三衣衬身衣被衣雨浴衣覆疮衣单敷衣遮壁虱衣蚊幮。不得着用余人衣。诸比丘谓此属四方僧。不敢衬身着之。以是白佛。佛言。若施主现在听衬身着

有诸比丘尼以衣钵余物施诸比丘。诸比丘不敢受。诸比丘尼言。我当于何处更求福田。以是白佛。佛言听随意受。时诸比丘得劫贝经钦婆罗纬衣不敢受。以是白佛。佛言听受。时舍卫城治钦婆罗人。见诸比丘着钦婆罗衣。语言。大德所著若浣若蹋。使毛出者极好鲜文。诸比丘不敢。以是白佛。佛言听浣蹋。若不知听雇人。有诸比丘于露地浣蹋钦婆罗。诸白衣见讥诃。此比丘正似蹋钦婆罗师。以是白佛。佛言应在屏处蹋。欲截钦婆罗头。不知以何截。以是白佛。佛言应作剪刀

诸比丘着斑色綖织衣。诸白衣见讥诃言。沙门释子与世人何异。诸比丘以是白佛。佛言不应着斑色綖织衣。犯者突吉罗

有一女人生儿辄死。后生一男将至诸比丘所。索袈裟衣与着。诸比丘不敢与。以是白佛。佛言听与。有一少知识比丘无衣。诸女人乞不得与。彼言我自出物与我染之。诸比丘不敢为染。以是白佛。佛言听为染。时毕陵伽婆蹉父母贫穷。欲以衣供养而不敢。以是白佛。佛以是事集比丘僧。告诸比丘。若人百年之中。右肩担父左肩担母。于上大小便利。极世珍奇衣食供养。犹不能报须臾之恩。从今听诸比丘尽心尽寿供养父母。若不供养得重罪

五分律卷第二十五分律卷第二十一(弥沙塞)

        宋罽宾三藏佛陀什共竺道生等译

    第三分之五衣法下

尔时舍夷国犹遵旧典。不与一切异姓婚姻。波斯匿王贪其氏族自恃兵强遣使告言。若不与我婚当灭汝国。诸释共议。当设何方免彼凶虐而不违我国之旧典。佥曰。正当简一好婢有姿色者极世庄严。号曰释种而以与之。如议即与波斯匿王备礼娉迎。后生一男颜貌殊绝。敕诸相师依相立字。诸相师言。王本以威而得其母。依义应当字曰琉璃。至年八岁王欲教学。作是念。诸艺之中射为最胜。阎浮提界唯有释种。佛为菩萨时射一由旬又一拘楼舍。释摩南射一由旬。最下手者不减一拘楼舍。当令吾子就外氏学。即敕大臣子弟侍从太子。就释摩南请受射法

尔时诸释新造大堂共作重要。先供养佛及诸弟子。然后我等乃处其中。琉璃太子与其眷属辄入游戏。诸释见之嗔忿骂言。下贱婢子我不以汝为良福田。云何世尊未入中坐而敢在先。琉璃太子即大忿恨。敕一人言。汝忆在心。我为王时便以白我。即便出去。诸释于后掘去堂土更为新地。然后请佛及僧于中设食演说妙法。琉璃太子知射法已还舍卫城。少年之中便绍王位。先共学人皆居要职。昔受教臣便白王言。王忆某时诸释骂不。王言我忆。臣复白言。今不报之复欲何待。王闻其语。即严四种兵往伐诸释。世尊闻之。即于路侧坐无荫舍夷树下。王遥见佛下车步进头面礼足白佛言。世尊。好树甚多。何故乃坐此无荫树下。世尊答言。亲族荫乐。王知佛意。愍念诸释即回军还。如是再反。彼臣又复如前白王。王便严驾往伐诸释。佛知诸释宿对叵避便止不出。诸释闻琉璃王来伐其国。亦严四兵出相御逆。去一由旬以箭射之。或从耳穿中过。或断其发铲发。令尽须眉无余。及诸战具一时断坏而不伤肉。琉璃王问左右言。诸释去此近远。答言去此一由旬。王大怖言。军锋未交已尚如此。若当相接吾军败矣。不如反国图全为幸。时彼一臣白言。释种皆持五戒。宁失身命终不害物。王但进军勿忧丧败。王即从之。敕军进前。释种还城闭门自守。琉璃王遣使语言。若即开门当有免者。若吾攻得不赦一人。时目连闻琉璃王欲攻舍夷。白佛言。愿佛听我化作铁笼笼彼大城。佛告目连。汝虽有神力何能改此定报因缘。佛以此义即说偈言

  夫业若黑白　　终不有腐败
  虽久要当至　　还在现前受
  非空非海中　　非入山石间
  莫能于是处　　得免宿命殃
  报应之所牵　　无近远幽深
  自然趣其中　　随处无不定

尔时诸释见彼军盛。或言开门取全。或言以死固守。纷纭不定。便共行筹以少从众。时魔波旬在开门众中。七反取筹开门筹多。即便开之。琉璃王得城已宣令三军。一切释种皆悉杀之。若非释种慎勿有害。三亿释闻皆捉芦出言。我是持芦释。屯门者信放令得去。于是释摩南到琉璃王所。琉璃王以为外家公。白言。阿公欲求何愿。答言愿莫复杀我诸亲。王言。此不可得更求余愿。又言。愿从我没水至出。于其中间听诸释出。凡得出者不复杀之。琉璃王作是念。水底须臾何为不可。即便许之。释摩南便解头沐没。以发系水中树根遂不复出。王怪其久使人入水看之。见其已死发系树根。以此白王。王便叹言。乃能为亲不惜身命。即宣令三军。若复有杀释种者军法罪之。时诸比丘闻琉璃王诛杀舍夷国人。以是白佛。佛告诸比丘。琉璃王愚痴。却后七日当受害学人罪。其眷属大小亦俱并命。琉璃王闻佛此教。心念佛无空言。余苦尚可唯畏火烧。即与眷属乘船入阿夷河。七日期至水忽暴涨。于是覆没一时死尽。诸释破灭之余被剥赤肉。到诸比丘所语言。我是释种世尊亲族。愿乞少衣。诸比丘不敢与。作是念。佛未听我等与诸释衣。以是白佛。佛言听与。复有五戒优婆塞被剥。来至诸比丘所借衣。诸比丘不敢借。语言。佛未听我等借优婆塞衣。以是白佛。佛言听借。若还应取。若不还则与。时跋难陀。为安居施故二处结安居。诸比丘以是白佛。佛言。二处皆应各与半分。时诸比丘在路行不收摄衣曳地污裂。以是白佛。佛言不应尔。犯者突吉罗。应作囊盛。诸比丘作囊太长。以是白佛。佛言不应尔。极长使前至脐后至腰。诸比丘以贵价物作衣囊。以是白佛。佛言不应尔。应用粗物作。有诸比丘在路行。趣倩人担衣亦趣为人担。或自失衣或失他衣。以是白佛。佛言不应尔。若倩人担衣应先出示。若为人担衣应出看之。诸比丘盛衣囊中缝合其口欲取艰难。以是白佛。佛言不应尔。应作带系。若非常须亦听缝之。诸比丘举钦婆罗劫贝衣各着一处生虫咬坏。以是白佛。佛言。应以劫贝间钦婆罗然后用屈尸罗香那毗罗香青木香如是诸香辟虫者着中。诸比丘后取衣不复识。以是白佛。佛言应题名作帜。若比丘举衣经十二年不还取者。应集僧平价作四方僧用。若彼比丘后还。以四方僧物偿。若不受者善。时阿难得施衣不须。为舍利弗受。即使一比丘持衣与之。彼比丘作是念。舍利弗幸多供养。而我无衣。我今当作同意取。即便着之后生疑。以是白佛。佛言。彼虽为受而未是已舍。若于所与比丘。作同意取受持。非善取受持。若于所受比丘。作同意取受持。是善取受持。阿难复得腰绳不须。为阿那律受。亦使一比丘持往语言。此绳已属阿那律。彼比丘亦如上念取后生疑。以是白佛。佛言。彼言已属阿那律。是为已舍。若于所与比丘。作同意取受持。是善取受持。若于能使比丘。作同意取受持。非善取受持

时诸比丘不着衬身衣披僧被污泥不净为鼠咬坏。以是白佛。佛言不应尔。犯者突吉罗

时六群比丘作衬身衣。大小如僧祇支。或如泥洹僧。以是白佛。佛言不应尔。应三种作。上者从覆头下至踝舒覆左手掩令等没。中者从覆头下至半胫舒覆左臂掩等至腕。下者从覆头下至膝舒覆左臂掩等半肘。诸比丘不以衬身衣通覆右肩。而通披僧被污泥不净为鼠所咬。以是白佛。佛言不应尔

有诸比丘。受经时问讯和尚阿阇梨时。披僧被偏袒垂地。或夜起行不能收摄。亦委于地泥土污之。以是白佛。佛言。受经问讯应偏袒举使离地。夜起时应收摄通披勿令污泥。诸比丘着僧被裂不补治。以是白佛。佛言应补治。不知谁应补治。佛言。若冬四月夏三月用者应治

有诸比丘于阿练若处住。去时不举僧卧具致使烂坏。以是白佛。佛言应寄聚落中。若无寄处应还作房主。若有疑畏聚落人民皆悉移去。亦应运持至安隐处。诸比丘不随后视卧具致有零落。以是白佛。佛言应随后看。既到安隐处。彼诸比丘不与房住。亦不与房安诸衣物。以是白佛。佛言皆应与之。若先处不复立。应即在住处用之。若后还立。应持余者还。若已尽无余。彼处比丘应少多分与。有诸比丘。以此房卧具于彼房用。诸房主讥呵言。云何以我房物于余房用。此则不与取也。以是白佛。佛言不应尔。有诸客比丘欲问讯师及受经。着住房卧具至彼房。房主比丘不听。以是白佛。佛言。应先语本房比丘。若听者善。若不听亦着持去。若于彼远行应送还本房。有诸比丘着僧衣入温室及作食处入僧中食及左右便利烟熏污泥。以是白佛。佛言不应尔。有诸病比丘须着至诸处不敢。以是白佛。佛言有病听着至余处。但爱护之。唯不得着大小便利

时六群比丘着上下衣持广五指衣片当三衣而入聚落。诸比丘见问言。世尊不制不着三衣不得入聚落耶。六群比丘即以衣片示言。此是我三衣。诸长老比丘种种呵责。以是白佛。佛以是事集比丘僧。问六群比丘。汝实尔不。答言实尔世尊。佛种种呵责已告诸比丘。不应尔。犯者突吉罗。从今听作上中下三衣如衬身衣量

有一住处僧得可分衣。一比丘持至戒坛上独取受持。以是白佛。佛言不应尔。犯者突吉罗。现在僧应分。有一上座比丘。与诸比丘游行人间。其中有客有旧得可分衣少不足分。以是白佛。佛言。旧比丘应语客比丘言。长老此衣少不可分。客比丘若言并持相与应取。若言乃至一缕亦不相与便应共分。客比丘语旧比丘亦如是。有比丘取覆冢衣。冢主失衣。借问谁取我覆冢衣。有人答言诸比丘取。便嗔呵言。诸比丘偷我先人衣。诸长老比丘闻。以是白佛。佛言不应取。若聚落移去于后有者。听作粪扫衣意取。有诸比丘取神庙中幡盖亦如是。有诸比丘往斗战处取死人衣。军人讥呵言。此诸比丘欲令我等多杀人。诸长老比丘闻。以是白佛。佛言不应尔。有诸比丘少知识。欲斗战处取死人衣不敢往。以是白佛。佛言听军人去后取。有诸白衣。军人去后。收敛骨肉尸丧。见诸死尸悉被剥脱不可复识。便讥呵言。云何比丘剥我亲里衣。若有衣者便应可识。诸比丘以是白佛。佛言听无人见时取。至杀人处取衣亦如是。有诸比丘取死人衣不坏作比丘衣畜。诸白衣见言。此是我亲里衣。便向啼泣。诸比丘以是白佛。佛言应速坏作比丘衣畜。若铁器应速用作大小钵户钩诸所须物。有一家大富。贼劫之不能尽持去。留藏粪扫中。后还欲取昼。日未敢进。遥伺望之。有比丘拾粪扫衣。到彼藏物处。见衣角出便取之。贼遥语言。大德莫取我物。遭劫家闻识是贼。缚送官中。官即杀之。贼被缚时作是语。若比丘不取我衣。彼何由识我。是为比丘杀我。非是彼人。诸比丘以是白佛。佛言若举时重不应取。有诸比丘于街巷中视地而行。诸白衣见或言觅钱。或言觅粪扫衣。有一外道弟子。以衣裹钱着道中。比丘见拾取。便语众人言。诸比丘果是觅钱。诸比丘以是白佛。佛言。不应取街巷中裹物。有一比丘为衣故至冢间。见一新死女人头前有函。比丘谓是空函。便取持归到所住处开视。见有诸严身具。不知云何。以是白佛。佛言取时应先开视。若不视取突吉罗。有诸比丘与外道共道行为贼所杀。比丘便取其衣不坏色作比丘衣。余外道见之言。此是我亲里衣。诸比丘必杀而取。诸比丘以是白佛。佛言不应取。若已取即应坏色作比丘衣。有诸比丘少欲知足不受他家施衣。诸居士作是议。我等何方令彼比丘受我施衣。正当裂破火烧处处着街巷中伺其入聚落时语言。汝看左右若有所见取之。即如议作。彼比丘见作是念。我等不受家施衣。必是诸居士为我等作此。以是白佛。佛言应作粪扫想取。有一比丘命过。诸比丘仰着中庭不以衣覆。露其身体男根胀起。诸居士见讥呵言。沙门释子不修梵行。乃使男根如此之大。诸比丘以是白佛。佛言不应仰露。应以衣覆。犯者突吉罗。有一肥大比丘命过。诸比丘举着生草上。脂出流漫杀诸生草。诸外道见讥呵言。沙门释子自云慈念。而今云何伤杀生命。诸比丘以是白佛。佛言不应着生物上。应埋若火烧若着石上

有一比丘水所[漂*寸]杀。衣钵挂着界内树枝。诸比丘见谓入僧界内应属僧不敢取。以是白佛。佛言听作粪扫衣取。诸比丘不知有几种粪扫衣。以是白佛。佛言。粪扫衣有十种。王受位时所弃故衣冢间衣覆冢衣巷中衣新嫁女所弃故衣女嫁时显节操衣产妇衣牛嚼衣鼠咬衣火烧衣

时诸比丘着光色衣。白衣讥呵。以是白佛。佛言不应着光色衣。犯者突吉罗。有比丘畜不满五肘雨浴衣。以是白佛。佛言雨浴衣不应减五肘。犯者波逸提。时诸居士于安居内为儿女剃头故以衣施僧。诸比丘受已欲回为安居施。以是白佛。佛言不应尔。此名随事施。现在僧应分。犯者突吉罗。有诸比丘。先所受三衣不舍更受余衣。以先所受衣净施及施人。后忆白佛。佛言。得名更受亦名净施施人。但不舍得突吉罗。时诸比丘有尼萨耆衣。未舍未悔过。而为火所烧水所[漂*寸]贼所夺失坏。不知云何。以是白佛。佛言此即名舍。但应作波逸提悔过。时诸比丘畜衣不以净施。以是白佛。佛言不应尔。犯者突吉罗。有一住处众僧得锦施诸比丘。不知云何。以是白佛。佛言。应受回庄严塔若作塔用若僧用。有一住处僧欲分衣。有少欲比丘不受分。而须腰绳禅带帽漉水囊。诸比丘以是白佛。佛言应与。既与复索。以是白佛。佛言。分物时应先问。汝受分不。若言受应等与。若言须腰绳等。应三分与一。若复索不应与。有一比丘有拘摄四方僧有僧伽梨欲贸易之。诸比丘不敢与。以是白佛。佛言听易。若拘摄价多僧应倍与比丘。若僧伽梨价多比丘应倍与僧。若贫无物可倍与僧。而必是少欲知足亦听与之。余衣亦如是。时离婆多比丘苦脚冷。从一婆罗门乞裹脚钦婆罗衣。既乞生疑世尊制戒不听我等从非亲里乞衣。不知云何。以是白佛。佛言。如是因缘听乞所应受持衣若护[跳-兆+專]衣护髀衣护头衣拭手面身体巾等。时诸比丘于僧四方僧及塔不同意人边皆作同意取衣。以是白佛。佛言不应尔。于和尚阿阇梨同和尚阿阇梨若弟子及诸同意人边乃得作同意取。有诸比丘未命过。处分衣物言。我死后以此衣物施某甲。以此衣物作如是如是用。以是白佛。佛言不应尔。犯者突吉罗。与不成与。用不成用。时阿难常出入芦夷力士家。后往不在作同意取贵价劫贝。寻生疑悔作是念。佛未听我等于白衣作同意取衣。以是白佛。佛言。亦听于白衣作同意取衣。时诸比丘离雨浴衣。不知浴时应着何衣。以是白佛。佛言。有五因缘得离雨浴衣。不雨不疑雨不渡水食病时作未成。有五因缘得留僧伽梨。雨时疑雨渡水食病时作未成。有一住处僧欲分衣。有客比丘来。诸比丘得分少不欲分。以是白佛。佛言。乃至得一腰绳直应分。若少不足分。应白二羯磨与一无衣比丘。一比丘唱言。大德僧听。此僧得衣若非衣。今并与某甲比丘。若僧时到僧忍听。白如是。大德僧听。此僧得衣若非衣乃至若不忍者说。僧已与某甲比丘衣竟。僧忍默然故。是事如是持

    五分律第三分之六皮革法

佛在舍卫城。尔时摩诃迦旃延。在阿湿波阿云头国波楼多山中住。彼国有长者名沙门亿耳。信乐佛法常供给诸比丘。见法得果受三归五戒。恒入僧坊听受法教。时沙门亿耳屏处自念。如佛所说在家染着不能广修梵行。出家无著犹如虚空。我今何不于无为法中剃除须发出家学道。念已晨旦到迦旃延所。头面礼足具宣所念。欲求出家受具足戒。迦旃延言。在家染着诚如汝言。但出家苦节净修梵行独坐树下常应一食。汝本富乐此事甚难。亿耳闻已便归其家。如是至三。见其意至便与出家。彼国无有十众作沙弥经历六年。迦旃延乃以神通力。于余国集十众授具足戒。亿耳受戒已念言。我闻如来应供等正觉而未奉见。今当往诣问讯世尊。念已到迦旃延所。头面礼足白求诣佛。迦旃延言甚善。吾随汝喜宜知是时。可以吾名问讯世尊。复以五法白佛。一阿湿波阿云头国无有十众。亿耳作沙弥经历六年不得受具足戒。迦旃延以神通力于余国集僧然后得受。愿世尊听此国不满十众得受具足戒。又此国多有沙石棘刺。愿听此国比丘畜重底革屣。又此国皆以皮敷地作坐卧具。愿听此国比丘以皮敷地。又此国人日日洗浴。愿听此国比丘日日洗浴。又有比丘寄衣与余方比丘。衣未至有比丘语所与比丘。比丘生疑恐犯长衣。愿为除其此疑。于是亿耳受教而去。既到佛所稽首佛足宣和尚问讯。佛语阿难。汝为此客比丘敷卧具。阿难念言。佛欲与此比丘共宿故。令我为敷卧具。即于佛房而为敷之。佛与亿耳共一房宿。初夜中夜默然无言。至后夜时佛作是念。此族姓子威仪调伏。当令说法。便语言。汝可说法。亿耳受教。即说十六义品经。说已默然而住。佛言善哉。彼国人语皆如此不。答言有胜我者。又问。汝何以久住彼国不来见我。答言。我早知欲之过患。有因缘故不得早来。尔时世尊因说偈言

  见世之过患　　身自依法行
  贤者不乐恶　　为恶不乐善

于是亿耳作是念。和尚敕我以五法白佛。今正是时。便以白佛。佛过夜已集比丘僧告亿耳。汝可更说迦旃延所白五法。亿耳即更说之佛种种赞叹少欲知足赞戒赞持戒。已告诸比丘从今听阿湿波阿云头国及一切边地少比丘处持律五人授具足戒。亦听有沙石棘刺之处着重底革屣。亦听有皮革处作皮敷卧具。亦听有须浴处日日洗浴。若比丘寄衣与余处比丘。比丘虽先闻知。衣未入手不犯长衣。尔时诸比丘作种种形种种色革屣。以是白佛。佛言不听作异形异色革屣。犯者突吉罗。有诸比丘作马皮象皮人皮革屣。以是白佛。佛言不听作。若用人皮偷兰遮。若马象皮突吉罗。时跋难陀常出入一牧牛家。着衣持钵往到其舍。彼有斑色犊子。跋难陀谛视生念。欲得此皮作敷具。主人问言何故谛视此犊。答言。此犊斑色可爱耐可作敷具。彼即白言。大德常料理我家。岂惜一犊而不相与。即于犊母前杀而与之。跋难陀得已持还僧坊。犊母随后悲鸣逐之。诸比丘问言。此牛何故悲鸣逐汝。答言不知。又问。此牛逐汝不逐余人。云何不知。乃具以事答。诸比丘种种呵责。以是白佛。佛以是事集比丘僧。问跋难陀。汝实尔不。答言实尔世尊。佛种种呵责已告诸比丘。从今不听畜一切皮。诸比丘后须小片皮而不敢用。以是白佛。佛言听用小片皮作物。有诸比丘从外还徒跣上僧卧具污泥不净。以是白佛。佛言听着出入革屣。有老病比丘于恐怖处共伴道行迟不相及。诸伴语。大德速行勿使被剥。答言我等老病不能行。伴言。此有象马驴骡骆驼车牛可骑乘。诸比丘不敢。以是白佛。佛言从今听老病比丘骑乘。但不得乘骑雌畜生。有诸白衣以皮舆施僧。诸比丘不敢受。以是白佛。佛言听受。去皮以余衣代。有诸白衣以皮舆别施上座。不敢受以是白佛。佛言亦听私受。去皮如上法。诸上座老病比丘。欲乘舆入聚落不敢乘。以是白佛。佛言听。不知使谁舆之。以是白佛。佛言使净人舆。有诸比丘于恐怖处欲渡水无船。有牧牛人驱牛渡水。语言。可捉牛尾。诸比丘不敢。以是白佛。佛言听捉。时六群比丘捉牸牛尾渡水。以手刺其疮中。以是白佛。佛言不听捉雌畜生尾渡水。有诸比丘欲渡水亦无畜生可捉。不知云何。以是白佛。佛言听缚草木作筏。自今听诸比丘畜浮囊。若羊皮若牛皮作。僧及四方僧皆应畜

佛在王舍城。尔时瓶沙王摩竭鸯伽二国。有四万二千聚落。彼诸豪杰无有不信佛法僧者。唯除瞻婆城中有长者子名首楼那。其人大富有二十亿钱时人号曰首楼那二十亿。是人生便受乐手脚柔软足下生毛。瓶沙王作是念。我界内唯有二十亿。未信佛法。我当云何令彼信乐。我若自往当大惊怖。若呼召之必生疑畏。正当通命瞻婆城中六十家诸豪杰观王子婚因此相见诲以道法。念已即便呼之。时诸亲族皆白王言。二十亿未曾履地。足下生毛如人顶发。不堪恭到。愿王特赐停此一人。王言。可乘象马车舆。答言。其身极软亦不堪之。王言。今王子婚必宜相见。听汝亲族尽自致方。亲族共议。唯当凿渠通船日行数里乃可不劳。恭王命耳。便共以此致之到王舍城。亲族白王。二十亿今始得至。愿听如家法。王言家法云何。答言以衣敷地行上舁之。王言可尔。即敕为敷。又为敷细软衣为座令坐其上。王问言。汝足下实生毛不。答言。实尔大王。王言我欲见之。答言愿使可信人看。王言我欲自见。答言愿听舒脚。王言可尔。即舒脚示王。果如所闻。光曜王目不得熟视。生希有心念言。我国乃生如此大福德人。顾视左右先有三大居士。并二十亿为四。问言。汝各有几财得为居士。第一人言。我钱有十三亿。第二人言。我有十四亿。第三人言。我有十四亿。又有一无价摩尼珠。二十亿言。我有二十亿。复有五百摩尼珠一摩尼宝床。王问二十亿。汝所从得此答言。此宝非父余财。亦不营得。我于高楼上眠。眠觉便在我前。王闻此语。倍生希有。复作是念。此人福德唯佛当知。余无能了。即便严驾出诣佛所头面礼足白佛言。世尊。二十亿有五百摩尼珠一摩尼宝床。从何而来。佛言。此人先在忉利天。有五百天女极相爱乐。从彼来生天女皆念。我等天子今于何生。以天眼观见生在此。各持一摩尼珠及先所卧宝床。化令称其今身。着前而去。王闻佛说礼毕退。还集瞻婆城六十豪杰语言。我今令二十亿为彼城中最大居士。汝等宗之。复语二十亿及六十人等。我为汝王以法治化。已与汝等作现世利益。今佛世尊在耆阇崛山。各可往彼求后世利。受敕皆往。时长老婆竭陀。于山中盘石上经行。诸居士到其所语言。大德为我白佛。瞻婆城二十亿及六十居士欲问讯世尊。娑竭陀于盘石上居士前没踊出佛前。具以白佛。佛言。汝可先去于盘石上敷座吾寻后往。受教于佛前没踊出盘石众居士前。为佛敷座。佛以常威仪步行后至。诸居士念言。此比丘有大神力出没盘石犹如入水。咸共恭敬而慢世尊。世尊既至就座而坐。诸佛常法。先使发欢喜心然后说法。佛语娑竭陀。汝起扇佛。受教起扇。须臾现种种神变如优为。迦叶还在佛前。稽首礼足白佛言。佛是我大师我是佛弟子。如是三返已复坐本位。于是诸居士作是念。弟子神力犹尚如是。况于如来应供等正觉。便回心注仰。佛为说种种妙法示教利喜。乃至苦集尽道。皆于坐上得法眼净。受三归五戒。二十亿从坐起跣足至佛前稽首作礼。佛便微笑。娑竭陀作是念。佛何因缘笑。念已从坐起偏袒右肩胡跪白佛。今何因缘而发微笑。佛语娑竭陀。此二十亿九十一劫来始今足蹈于地。又问。二十亿何因缘。九十一劫足不蹈地。佛言。过去世时有佛世尊出现于世。名毗婆尸。父王治城。长十二由旬广七由旬。多诸人众安隐丰乐。彼佛与大比丘僧六万八千人俱。皆是阿罗汉于彼止住。其王日日请佛及僧于宫中食。时大众中有一人名修毗赊。共众人往诣王所。白言。王今作诸功德。愿听我等亦得豫之。王言。今佛僧众有六万八千人。恐汝等不办。或更恼僧。复白王言。我自堪办。愿必听许。王言大善。犹恐不办敕作食如常。彼若不周当以足之。于是诸人设供过于王食。如是多日。王所作食竟不复设。修毗赊次应设供。使人掘路更以细软土填香泥泥之。两边竖八十宝柱。以杂色摩尼珠置于柱头。悬杂色幡张杂色幔。弥覆路上处处。路上安种种浆。于家敷六万八千座。一比丘坐一座。各以五百釜羹而供养之。一一比丘施劫贝二张革屣一緉。复为四方僧作一房。地敷卧具皆悉妙好。尔时修毗赊者今二十亿是。从是已后受天上人中福等无有异。若今不见我者足犹不蹈地

时二十亿胡跪白佛。愿听出家受具足戒。佛言父母听汝未。答言未。佛言。父母不听不得出家。答言我当还家启白父母。佛言大善。今正是时。于是二十亿礼佛足右绕还瞻婆城。白其母言。我今欲出家学道。母言。止止何缘出家。我唯有汝。死尚不欲相离。如何生离。今我财物珍宝奴婢田宅无有限数。可恣意作福受五欲乐。苦请至三。然后听许。前礼母足右绕三匝还诣佛所。头面礼足胡跪白佛。母已听许。愿便与我出家受具足戒。佛言。比丘来出家受具足戒广修梵行我善说法能尽苦源。说是语时。二十亿须发自堕僧伽梨着身钵盂在手。出家不久于尸陀林精进经行足伤血流乌随啄吞。二十亿作是念。佛弟子中精进无胜我者。而今未得尽诸苦源。我家幸多财宝。亦可反俗快作功德。佛知其念。从耆阇崛山来下见乌啄吞其血。问阿难。何故有此血乌竞啄之。答言。二十亿于此经行足伤血出。世尊便往到其所。问二十亿。汝实作是念不。答言实尔世尊。佛复语言。我今问汝随意答我。汝在家时善弹琴不。答言善。又问琴弦急时声调好不。答言不好。又问。琴弦缓时声调好不。答言不好。又问云何得好。答曰。不急不缓然后乃好。佛言。于我法中亦复如是。太缓太急何缘得道。若精进处中不久尽苦。二十亿闻佛说已。即于经行处漏尽无余。世尊以二十亿足下伤破。告诸比丘。今听二十亿着一重革屣。二十亿白佛言。世尊。我舍二十亿钱五百摩尼宝珠一摩尼宝床二十夫人无量婇女。若着一重革屣人当讥我。舍如此财宝而犹贪受一重革屣。世尊若听一切比丘著者我当着之。佛便赞叹少欲知足赞戒赞持戒已告诸比丘。从今听诸比丘着一重革屣

有诸比丘着两重革屣。以是白佛。佛言不听。犯者突吉罗。时六群比丘着革屣在和尚阿阇梨前后经行。有余比丘亦皆效之。诸比丘以是白佛。佛言不应和尚阿阇梨前着革屣。犯者突吉罗。有因缘于和尚阿阇梨前着革屣无犯。若地有棘刺。若地有刺脚草。若地有沙石。若病时若闇时。时诸比丘着金银象牙石屐。诸居士见。讥呵言。此诸比丘如王大臣。常说少欲知足。而今奢费无度。无沙门行破沙门法。诸长老比丘闻种种呵责。以是白佛。佛以是事集比丘僧。告诸比丘。从今不听着如上屐。犯者突吉罗

佛在毗舍离。有一住处下湿。着皮革屣臭烂虫生。诸比丘以是白佛。佛言。听诸比丘作婆婆草迦尸草文柔草鸠尸草等屧。诸比丘着水从下出渍脚。以是白佛。佛言听用生皮底下。有诸比丘畜着木屐木屧于僧坊内行作声乱诸比丘坐禅。复有一比丘着木屐下利夜踏杀蛇。以是白佛。佛以是事集比丘僧。告诸比丘。从今不听着木屐木屧。犯者突吉罗。听于三处着非行来屐。大便处小便处洗手脚处。有诸比丘着兜罗贮革屣。以是白佛。佛言不应尔。犯者突吉罗。有诸比丘革屣鼻破脚指。以是白佛。佛言听以软物贮鼻。有诸比丘脚跟劈裂。以是白佛。佛言听以熊膏涂熊皮裹。时毕陵伽婆蹉常一心行不觉蹴脚指破。佛见之告诸比丘。从今听诸比丘着富罗。诸比丘作[革*雍]大深。诸居士讥呵言。此比丘所著富罗如我等靴。以是白佛。佛言不应深作[革*雍]听至踝上。有诸比丘作[革*雍]如靴。诸居士讥呵如上。以是白佛。佛言应开前。有诸比丘着画革屣。以是白佛。佛言不应着。犯者突吉罗。若得听坏色着

时离婆多。在陀婆国人间游行遇寒雪脚冻坏。还到祇洹头面礼佛足却坐一面。佛问言。脚何故尔。具以事答。佛问彼国人颇有所著不。答言。彼国人着富罗着革屣。佛种种赞叹少欲知足赞戒赞持戒已告诸比丘。从今听雪寒国着富罗着革屣。若彼国更有所著听随意着之。有诸比丘雪寒中行脚冻坏。以是白佛。佛言。听用酥盐熊膏涂以熊皮作靴。有诸比丘在道行不知用何物盛粮。以是白佛。佛言。听用羊皮牛皮鹿皮及劫贝作囊。有诸比丘以盛食污泥白佛。佛言应净浣。诸比丘便浣皮囊烂坏虫生白佛。佛言不应浣皮囊。应反揩拭。若净善若不净勿复畜。有诸阿练若住处比丘畜皮敷具。诸恶兽闻气来杀诸比丘。诸比丘以是白佛。佛言。于阿练若处不应畜皮敷具。应持与聚落住处以藉函梯道。有比丘在佛后。刺刺脚不能行。诸居士见语言。大德佛去已远何不驶行。答言刺刺我脚不能行。诸居士言。能着靺不。比丘不敢着。前至佛所白佛。佛言听着。有比丘于冢间得革屣复不敢取。以是白佛。佛言听取。有诸比丘得种种形色种种皮革屣不敢取。以是白佛。佛言。除人马象皮余听取坏本形色。若形色不可坏。于僧坊内着不得出外。有诸比丘得新革屣不敢受。以是白佛。佛言听受。应令净人着行七步然后着之。有诸比丘革屣富罗及履破坏不知令谁补治。以是白佛。佛言应借人补治。若无人比丘能自补。亦听畜大小锥大小刀缝皮綖。有诸比丘为破见比丘补治革屣等物。以是白佛。佛言不应为如此人作。应为惭愧欲学戒者作。诸比丘不知用何物安皮作具。以是白佛。佛言听皮囊盛之

五分律卷第二十一五分律卷第二十二(弥沙塞)

        宋罽宾三藏佛陀什共竺道生等译

    第三分之七药法

佛在王舍城。尔时诸比丘得秋时病。佛行房见作是念。世人以酥油蜜石蜜为药。我今当听诸比丘服。以是事集比丘僧告言。从今听诸病比丘服四种药酥油蜜石蜜。诸比丘服酥苦臭。以是白佛。佛言。听熟煎若自煎若使人煎。若无净地听非净地煎。诸比丘服酥呕逆欲吐。以是白佛。佛言。听以呵梨勒阿摩勒果若蜜若蒜若糗诸所宜物排口。有一比丘得热病应服酥。诸比丘为乞不得而得乳。以是白佛。佛言。应使净人作酥煎令熟作无食气受七日服。有一比丘得风病应服油。诸比丘为乞不得而得油麻。以是白佛。佛言。应使净人作油作无食气受七日服。有一比丘得热病应服石蜜。诸比丘为乞不得而得甘蔗。以是白佛。佛言。应使净人作石蜜作无食气受七日服。诸比丘不知几时应熟。以是白佛。佛言。以杓举泻相续不断为熟。有诸比丘得风病应服牛驴骆驼鳣脂。诸比丘为乞不得而得四种肥肉。以是白佛。佛言。应使净人煮接取膏更煎。若时煮时煎时漉。非时受不得经宿服。若时煮时煎时漉时受得七日服。有诸比丘得秋时病应服根药。以是白佛。佛言。一切根药听服。果药亦如是。有诸比丘得秋时病应服草药。以是白佛。佛言一切草药听服。有比丘风病应取汗。以是白佛。佛言听取。有比丘风病应服赤白诸盐。以是白佛。佛言听服。有比丘风病应合和小便油灰苦酒用摩身体。以是白佛。佛言听合和摩之。有比丘患疥疮欲治。以是白佛。佛言听治。有比丘患痈应以刀破药涂。以是白佛。佛言听。有比丘患脚须着熊皮靴熊膏涂。复须用面蛇皮熊膏酥着苦瓠中渍。以是白佛。佛言皆听。有比丘隐处痈。医为刀破。佛经前过。医白佛言。刀已至大便门世尊视之。佛言。此是难护之处若使凡夫命过便失大利。从今不听刀破隐处。犯者偷罗遮。有比丘得时行热病。佛言。应服吐下药消息节量食随病食。有比丘患眼。佛言。听作眼药。时离婆多非时食石蜜。阿那律语言。莫非时食。我见作石蜜时捣米着中。彼即生疑。以是白佛。佛以是事集比丘僧。问阿那律。汝言见作石蜜。时捣米着中。彼何故尔。答言作法应尔。佛种种赞叹少欲知足已告诸比丘。从今若合药如此者听非时服。时长老优波离问佛言。世尊。若时药非时药合受应几时服。佛言。应从时药不得非时服。七日药终身药亦如是。又问。若非时药七日药合受应几时服。答言。应从非时药不得经宿服。终身药亦如是。又问。若七日药终身药合受应几时服。答言。应从七日药不得终身服

    五分律第三分之八食法

佛在波罗奈国。尔时五比丘。到佛所头面礼足。白佛言。世尊。我等当于何食。佛言。听汝等乞食。复白佛言。当用何器。佛言听用钵。时诸比丘乞得粳米饭不敢受。以是白佛。佛言。听随意受食。时诸比丘乞。或得种种饭。或得种种饼。或得种种糗。或得种种熟麦豆。或得种种烧麦及糯米。或得种种羹。或得种种苦酒及酱。或得种种盐。或得种种肉。或得种种鱼或得种种乳酪。或得种种菜。或得种种根藕根等。或得种种茎甘蔗等。或得种种果庵罗椰子等。皆不敢受。以是白佛。佛言皆听随意受食

佛在毗舍离。时世饥馑乞食难得。诸比丘持食着余处失之。作是念。若世尊听我等共食一处宿者不致此苦。以是白佛。佛言。听共食一处宿。诸比丘于余处作食失之。便作是念。若世尊听我等于住处作食者不致此苦。以是白佛。佛言。听在住处作食。诸比丘雇人作食与价与食彼人复偷。作是念。若佛听我等自作食者。可无此费。以是白佛。佛言。听自作食。诸比丘既自作食。求人授之复索雇直。作是念。若世尊听我等自持食求不倩雇人授者可无此费。以是白佛。佛言。听自持食求不倩雇人令授。诸比丘得木果无人授。以是白佛。佛言。听如木想取食。诸比丘得池果无人授。以是白佛。佛言。听就池水受。诸比丘欲食果无净人使净。以是白佛。佛言。听先去核然后食之

佛在毗舍离。尔时世尊患风。阿难自煮药粥上佛。佛问阿难。谁煮此药。答言。是我所煮。佛告阿难。我先听诸比丘共食宿住处。作食自作食。自持从人受汝等今犹用此法耶。答言犹用。佛言。汝等所作非法。我先饥馑时听。今云何犹用此法。从今犯者突吉罗。佛在舍卫城。问阿难。我先听诸比丘如木想取木果。就池水受池果无净人净果。先除核食。汝等今犹用此法不。答言犹用。佛言。汝等所作非法。我先饥馑时听。今云何犹用此法。从今犯者突吉罗

时舍卫城中。有优婆夷。字须卑。信乐佛法见法得果归依三宝。常请一切僧供给汤药。彼于后时来入僧坊。见一比丘服吐下药。问言。大德今何所须。答言。我吐下虚乏思欲食肉。语言。大德我明日当送。愿为受之。于是归家晨朝遣人持钱买肉。尔日波斯匿王有令。若有杀者当与重罪。买不能得。还白如此。复更与钱令遍求之。语言。勿计价直。若一钱得如一钱大亦当买之。犹不能得。优婆夷作是念。我昨已许。若不得者彼或命过。即持利刀入屋割髀里肉与婢令煮送与比丘。比丘得便食之病即除差。时婿行还。不见其妇行来出入。即问须卑何在。答言在内病。即入问言。何所患苦。妇具以事答。婿言。恐汝此病无复活理。及未死顷。可请佛及僧明设中食。妇言甚善。即令婿请佛及僧头面礼足白佛。愿佛及僧明日顾食。佛默然受。还归其家通夜作多美饮食。晨旦敷座遣白时到。佛与众僧前后围绕往到其家就座而坐。婿自行水。佛不受之。语言。呼须卑优婆夷令出。即遣人语。世尊呼汝。答言。可以我名问讯世尊。病不堪出。即以白佛。佛犹呼之。如是至三。乃以衣舁至佛所。既见世尊疮即除愈。肉色如先。生希有心。我有如是大师及诸同梵行人。欢喜踊跃手自下食。食毕行水取小床于佛前坐。佛为说随喜偈。如为毗兰若所说。更为说种种妙法。示教利喜已还归所住。佛以是事集比丘僧。问彼比丘。汝昨食何等。答言食肉。又问肉美不。答言美。佛言。汝愚痴人。云何不问而食人肉。从今食肉不问犯突吉罗。若食人肉偷罗遮。有诸比丘食象肉。波斯匿王象死辄送诸鬼神。以沙门食象肉故便杀诸象。比丘使净人取肉持还。诸居士见讥呵言。此沙门释子无肉不食。过于鸱乌。云何啖此不净臭秽来入我家。无沙门行破沙门法。诸长老比丘闻以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言。实尔世尊。佛种种呵责已告诸。比丘。从今食象肉突吉罗。马肉亦如是。诸比丘食师子肉虎肉豹肉熊肉。诸兽闻气遂杀比丘。诸居士见问何故尔。有人言由食其类肉。便讥呵乃至告诸比丘亦如上。从今食此四种肉突吉罗。诸比丘食狗肉。诸狗闻气随后吠之。诸居士见问言。狗何以偏吠比丘。有人言由食狗肉。便讥呵乃至告诸比丘亦如上。从今食狗肉突吉罗。诸比丘食蛇肉。诸居士讥呵。善自在龙王化作人身。来诣佛所稽首白言。我诸龙等有大神力。作种种形色游行世间。今诸比丘食蛇肉。或能是龙伤害比丘。愿佛制诸比丘不食蛇肉。佛为说种种妙法。示教利喜已遣还所住。佛以是事集诸比丘。以善自在龙王语告诸比丘。从今食蛇肉突吉罗。佛在王舍城。尔时有长者。请佛及僧。诸长老比丘问佛言。世尊。若人请僧为请谁。佛言。若正趣正向人皆已被请。诸比丘作是念。如此诸人四方及天上无处不有。我等将无犯别众食耶。便不敢往。以是白佛。佛言。若于界内别请四人已上名别众食。若次请不犯。有请比丘作是念。诸比丘尼式叉摩那沙弥沙弥尼优婆塞优婆夷亦在界内。将无犯别众食耶。以是白佛。佛言。若请僧应二众食。比丘及沙弥。若请二部僧应五众食。比丘比丘尼式叉摩那沙弥沙弥尼。有诸凡夫坐禅比丘作是念。如世尊说。若请僧正趣正向人皆既被请。我今凡夫未是正趣正向。将无食不与取食。以是白佛。佛问彼诸比丘。汝等不为解脱出家耶。答言。我为解脱。佛言。若请僧时圣人坐禅人皆应食。有诸诵经凡夫比丘作是念。我非坐禅亦如上生疑。以是白佛。佛言。诵经人亦应食。有诸劝佐众事凡夫比丘作是念。我非坐禅诵经亦如上生疑。以是白佛。佛言。劝佐众事人亦应食。告诸比丘。若请僧时。除恶戒人。余一切僧皆应食

佛游阿那频头邑。彼邑有一大臣名好少。请佛及僧办多美饮食。明日食时敷座自白。食具已办唯圣知时。时诸比丘更受他前食请皆已饱满。佛与大众前后围绕往到其家就座而坐。好少大臣手自斟酌。而诸比丘皆不能食。大臣言。何不自恣食。为谓食少为不甘口耶。诸比丘答言。食非不甘亦不谓少。朝已饱食是以不能耳。彼大臣便嗔恨言。云何既受我请于余饱食。诸比丘以是白佛。佛言。若已受他请。听歠画不成字粥。若得强粥及食。应语主人。我先已受请可施余人

时佛与大比丘僧千二百五十人俱游行。从王舍城向毗舍离。二国中间有王舍城。长者名象行。乘五百乘车。从毗舍离来。遥见世尊容颜殊特犹若金山。发欢喜心前到佛所。头面礼足白佛言。世尊。有少石蜜欲奉世尊及比丘僧。佛默然受。即便自下。诸比丘不敢受。以是白佛。佛赞叹少欲知足告诸比丘。从今听诸比丘饥时食渴时以水和饮。彼长者行一瓶石蜜遍佛大众。犹故不尽。白佛言。我一瓶石蜜行遍大众。而犹有余更应与谁。佛言。汝可持着无生草地若无虫水中。即受教着无虫水中。水即大沸烟起作声。如烧铁投水。长者恐怖还以白佛。佛为说种种妙法示教利喜。所谓施论戒论生天之论。欲为过患在家染累出家无著。次为说诸佛常所说法苦集尽道。即于座上远尘离垢。于诸法中得法眼净。佛复前行有一工师。其女善能作羹。请佛及僧纯以羹施用当后食。诸比丘不敢食言。佛未听我等以羹当食。以是白佛。佛言。听作后食意食

佛渐游行到毗舍离。住猕猴江边重阁讲堂。有一将军名曰师子。是尼犍弟子。闻佛世尊来游此城有大名声称号如来应供等正觉。叹言善哉。愿见如是请佛。即严驾出。遥见世尊容颜殊特犹若金山。前到佛所头面礼足却坐一面。佛为说种种妙法乃至苦集尽道。即于座上得法眼净。即从坐起胡跪白佛。愿佛及僧明日顾我薄食。佛默然受之。将军知佛受已。还归其家敕市买人。此间所有死肉莫计贵贱尽皆买之。如教悉买。通夜办种种美食。晨朝敷座自往白佛。食具已办唯圣知时。佛与比丘僧前后围绕往到其家就座而坐。将军手自下食欢喜不乱。时诸尼犍。闻师子将军请佛及僧极设肴膳。生嫉妒心。即于街巷穷力唱言。师子将军叛师无义。今乃反事沙门瞿昙。手杀牛羊而以供养。诸比丘闻不敢食。师子将军胡跪白佛。此诸尼犍长夜毁佛。我今乃至绝命终不故杀。愿敕比丘勿生嫌疑。自恣饱食。佛即告诸比丘。随意饱食。食毕行水。取小床于佛前坐。佛为如前说随喜偈从坐起去。佛以是事集比丘僧。告诸比丘。有三种肉不得食。若见若闻若疑。见者。自见为己杀。闻者。从可信人闻为己杀。疑者。疑为己杀。若不见不闻不疑。是为净肉。听随意食若为比丘杀。比丘及沙弥不应食。听比丘尼式叉摩那沙弥尼优婆塞优婆夷食。若为比丘尼优婆塞优婆夷杀亦如之

时摩竭国鸯伽国迦夷国拘萨罗国跋耆国满罗国苏摩国。此诸国人闻佛出世有大威德弟子亦尔。皆来云集毗舍离城。城中家家。各各七宝车马宾从皆已侧塞。余有万二千乘车。城中不受营住城外。皆竞持时食非时食七日食终身食。奉佛及僧积于中庭遂成大[卄/積]。纵横狼藉尘土污泥鸟兽集啖。世尊行房见顾问阿难。何故有此饮食弃于中庭。具以事答。无有安处所以致此。佛赞少欲知足。告诸比丘。今听以中房白二羯磨作安食净处。一比丘唱言。大德僧听。今以某房作僧安食净处。若僧时到僧忍听。白如是。大德僧听。今以某房作僧安食净处。谁诸长老忍默然若不忍者说。僧已以某房作僧安食净处竟。僧忍默然故。是事如是持。僧食尽后诸比丘于中煮羹粥合汤药。食前食后初中后夜。有刀机男女狗吠之声。佛问阿难。何故房中有此诸声。具以事答。佛种种呵责言。云何于僧房安食净处作食合药。从今犯者突吉罗。佛在王舍城。诸比丘得秋时病。为合汤药作随病食故时非时皆入聚落。遭水火劫贼。有衣钵难梵行难身命难。有一织师中路起屋于中织作。见诸比丘时非时入聚落。便语言。若有所作可于此作。欲有所留亦可留此。诸比丘不敢。以是白佛。佛言。听于白衣舍作净屋。遂复闹乱主人妨其织作。织师作是念。我本为织作此屋。今既不得织。便当正以施僧作净屋。即以施僧。诸比丘以是僧屋不敢复于中作食合药。以是白佛。佛言。听于施僧净屋中作食。有诸比丘新作住处。未有僧净屋不知云何。以是白佛。佛言。若作新住处。应先指某处作净地。便可以食置中。若未羯磨比丘不得入中至明相出。有一住处诸比丘久已舍去。后来比丘不知何者是净屋。以是白佛。佛言。若十二年空。听诸比丘随意更作净屋。有一住处无僧净屋。复未十二年。比丘后来不知何处作净地。以是白佛。佛言。若有非行来及不须用处应权以作净处。有诸比丘着食净屋中为人所偷。以是白佛佛言。应羯磨中房作净处。有诸比丘欲羯磨一房墙内作净地。以是白佛。佛言听。有诸比丘欲羯磨一房齐屋溜处作净地。以是白佛。佛言听。有诸比丘欲羯磨中庭作净地。以是白佛。佛言听。有诸比丘欲羯磨房一角或半房作净地。以是白佛。佛言听。有诸比丘欲羯磨机架作净处安食。以是白佛。佛言不听。要应依地。犯者突吉罗。有诸比丘欲羯磨重屋上层作净处。以是白佛。佛言不听。犯者突吉罗。有诸比丘欲羯磨重屋下及通结作净处。以是白佛。佛言听。有诸比丘欲羯磨乘作净处。以是白佛。佛言不听。犯者突吉罗。有诸比丘欲通羯磨僧坊内作净地。以是白佛。佛言听。应白二羯磨。一比丘唱言。大德僧听。此一住处共住共布萨共得施。僧今结作净地除某处。若僧时到僧忍听。白如是。大德僧听。此一住处乃至除某处。谁诸长老忍默然若不忍者说。僧已结作净地竟。僧忍默然故。是事如是持。佛在王舍城。尔时。跋提城有长者名文茶。有大福德。妇儿儿妇及奴婢皆有福德。长者入仓时空中雨谷出然后止。妇取饭器分布内外。随取随满无有穷尽。儿捉金囊写出金钱注而不竭。儿妇出米一斛得家内外一月日食而亦不尽。其奴耕时辄成七垄。其婢磨半两涂香涂家内外亦不减尽。四方人闻莫不来观。瓶沙王闻亦欲往视。不豫敕外。忽与眷属而至其家。长者闻王来至。即出迎之。见王问讯。善来大王。愿垂临幸。王问言。汝先闻我来不。答言不闻。王言。我军众多不可卒供。长者白言。我自供王及诸大臣。儿供太子。妇供后宫。奴婢足供一切士卒。谷草亦足供军象马。愿便赐降。王到其家坐已语言。吾闻长者及妇儿儿妇奴婢皆有福德。今悉欲见。答言。不敢有隐。即敕除仓中米扫洒左右。更敷御座请王入坐然后入仓。自然五谷空中雨下。王甚奇叹。复欲见其妇福德之力。即取一器饭着于妇前妇取分布。一切军众皆悉充足。犹不减尽。复欲见其儿福德之力。即敕捉一金囊写金。献王及与大众。皆随意取而亦不竭。复欲见其儿妇福德之力。即敕出一斛米供王大众一月不尽。复欲见其奴福德之力。即敕令耕辄成七垄。复欲见其婢福德之力。即敕令磨半两涂香。半由旬内闻之不异遍涂大众。犹故不尽。王与大众见福德力莫不雅叹欢。即便还宫

尔时世尊与大比丘僧千二百五十人俱。游行人间到跋提城。文茶长者闻佛世尊今来到此罔林树下。欲出奉迎礼拜问讯。诸外道闻便往语言。汝勿出迎沙门瞿昙。沙门瞿昙应来见汝。何以故。汝福德过人。一切沙门婆罗门国王长者。无不应来诣汝门者。长者闻已此心便息。后复作是念。沙门瞿昙到此已久。不来见我。彼道必胜。何缘安住不往修敬。便严驾出城。遥见世尊容颜殊特犹若金山。前到佛所头面礼足却住一面。佛为说种种妙法乃至苦集尽道。即于座上得法眼净。便从坐起白佛言。愿佛及僧受我明日请食。佛默然受。长者还家办多美饮食。明日食时自行白佛。唯圣知时。佛与比丘僧前后围绕。往到其家就座而坐。长者手自下食。食毕行水。与家大小于佛前坐。佛为说种种妙法乃至苦集尽道。皆得法眼净受三归五戒。长者白佛言。世尊。我妇及儿儿妇奴婢皆云。是已福德竟是谁力。愿佛说之。佛言。汝等共有此福。又问云何共有。答言。昔王舍城有一织师。织师有妇。妇有一儿。儿又有妇。其家正有一奴一婢。一时共食。有一辟支佛来就乞食。织师言。汝等但食以我分与。妇言。持我分与。儿乃至奴婢亦皆云尔。辟支佛言。汝等皆已舍分与我。善心为毕。便可各分少许与我。使汝食不少。我亦得足。即人减一匙已满彼钵。辟支佛得食。食已于虚空中现种种神变。然后乃去。彼诸人命终生四天王天。寿尽上生忉利天。展转至于他化自在天。如是七反余福来生。尔时织师眷属今汝等是。于是长者在佛前请僧言。我今请一切僧修无限施。若有所须随时多少皆从我取。诸比丘不敢受。念言。佛未听我等受无齐限施。以是白佛。佛言。听随意受。有诸比丘欲远行从索道粮。长者即使人赍金银钱物送之。既至所在所长甚多。使还白言。所赍资粮今大有余。长者语言。我已为施不应还取。汝可持去至僧房施僧。即以施僧。诸比丘不知云何。以是白佛。佛言。听僧净人为僧受以易僧所须物。诸比丘不应知事。于是世尊从罔林出游行人间。文茶长者赍食具随后。欲于旷野无人处设之。千二百五十象。千二百五十牸牛。千二百五十特牛。人载五百乘车种种美食。既至旷野顿止之处。通夜办之。明日晨朝。于一象荫下敷一比丘座。最大象荫敷世尊座。时到白办。诸比丘不敢坐。念言。佛未听我等在众生荫下坐。以是白佛。佛言听坐。众坐已定。长者先令一人构一牛乳与一比丘。诸比丘不敢受。念言。佛未听我等饮热牛乳。以是白佛。佛言听饮。饮已长者手自下食。食毕行水。在佛前坐。佛为说随喜偈。如为毗罗若说。更为说种种妙法。示教利喜已还归其家

佛与大众从坐起去。渐渐北行向罽那编发外道住处。罽那闻佛释种出家成如来应供等正觉今暮当至。作是念。过去诸仙修梵行者。中后不食而饮非时诸浆。所谓庵婆果浆阎婆果浆周陀果浆波楼果浆蒲桃果浆俱罗果浆甘蔗浆蜜浆。沙门瞿昙亦应饮此。吾当预办至便设之。办已与五百弟子出迎世尊。遥见世尊容颜殊特犹若金山。益生欢喜。前至佛所立慰世尊。善来瞿昙。顾我室坐。佛即到其家与诸比丘次第而坐。梵志便下非时浆。诸比丘不敢受。念言。佛未听我饮非时浆。以是白佛。佛言听饮。诸比丘复问。佛以何因缘得饮。佛言。渴便得饮。梵志复作是念。我今当为瞿昙诸沙门办仙人。食以供明日。即作穄米粟米稗米[禾*秀]米拘留米饭。明日食时白食已办。佛与大众俱就其坐。梵志手自下食。诸比丘不敢食。念言。佛未听我等食仙人食。以是白佛。佛言听食。食毕行水。取小床于佛前坐。佛为说随喜偈。如为毗罗若说。更为说种种妙法。示教利喜已。便从坐起向阿牟聚落。时彼有剃头师父子出家。闻世尊欲至。作是议。此诸居士不敬三宝。佛若至此必无人设粥。我等当共为人剃头取直作之。议已即行得物办粥。晨旦请佛及僧。僧既食已。佛问二比丘。汝等云何得办此粥。具以事答佛。佛种种呵责言。汝所作非法。云何赁与白衣剃头。从今若剃头师出家。不听畜剃刀。犯者突吉罗

佛之波旬邑。波旬诸力士闻佛欲至。即共议言。若不出迎罚金钱五百。皆与大小出迎世尊。头面礼足却坐一面。佛为说种种妙法。示教利喜已。即请佛及僧夏安居。四月佛默然受诸力士知佛受已。或有一人办一日食。或二日乃至十日。或二人共办一日。乃至十人共办一日。或但供前食。或但作粥者。或但作怛钵那者。时有一人字卢夷。是阿难白衣时亲友。问诸比丘。阿难今在何许。答言。阿难敬佛法僧今在佛后。彼即到阿难所礼足却住。阿难语言。我见汝迎佛甚用欢喜。答言。我非敬佛故来。但亲族共要。若不出迎佛。罚金钱五百。是以来耳。阿难闻已为之怅然。如何我亲友而不敬信佛法众僧。即至佛所白佛言。世尊。我愿此人信敬佛法。佛语阿难。此人信佛不难汝勿怀忧。佛即以慈心遍满其身已。进入房中闭房而坐。卢夷于后思念。世尊。如犊慕母。见众多比丘露地经行。问言。佛在何处。诸比丘指示言。在彼闭户大房中。汝可徐往謦咳叩户。世尊怜愍汝故。当为汝开。即如语得开。卢夷入已。手捧佛足自称姓名稽首作礼。佛为说种种妙法示教利喜。所谓施论乃至苦集尽道。即远尘离垢得法眼净。见法得果已受三归五戒。白佛言。世尊。我愿佛及比丘僧恒受我食不受余请。佛言。凡诸学人皆有此愿。吾已受此诸人夏四月请。无复空缺。彼作是念。复有何施佛未受者。使我不失如此福田。唯未见有设佉陀尼者。即便办之食时辄行。诸比丘不敢受。念言。佛未听我等食时食佉陀尼。以是白佛。佛言听食

尔时毗舍佉母。与僧作斋限施某时取尔所。诸比丘以是白佛。佛言听受。有诸居士请诸比丘随己意施。诸比丘白佛。佛言。不应受随意施。施者不应以金银宝物女色施僧。若比丘可其此施。犯者突吉罗。若受应如法治。有诸白衣次第请僧。诸比丘以是白佛。佛言。应次第差受。请比丘不知谁差。以是白佛。佛言。应白二羯磨一比丘作差受请人。一比丘唱言。大德僧听。僧今差某甲比丘作差受请人。若僧时到僧忍听。白如是。大德僧听。僧今差某甲比丘作差受请人。谁诸长老忍默然若不忍者说。僧已差某甲比丘作差受请人竟。僧忍默然故。是事如是持。诸比丘便差无智比丘不知次第。以是白佛佛言。不应差无智比丘。若有五法不应差。随欲恚痴畏不知已差未差。有诸白衣常作食饷诸比丘。诸比丘不知云何。以是白佛。佛言听受。有诸白衣为僧新作房舍温室浴室竟。作施房饮食使比丘往取。不知谁应往取。以是白佛。佛言。住其房中比丘应往取

佛在毗舍离城。时世饥馑乞食难得故。诸梵志比丘作是念。若世尊听我等种果者可以充饥。以是白佛。佛言听种。果成实已。诸比丘以自手种疑不敢啖。以是白佛。佛言。听随意啖。有诸比丘就树上捉果试看生熟。以是白佛。佛言。不应就树上触果。有诸比丘见果落非净地。使人拾聚一处经宿。不知云何。以是白佛。佛言。若不知地是净非净听食。若知是非净地不应食。时六群比丘先取好果啖。余善比丘不得。以是白佛。佛言。应白二羯磨差一比丘作分果人。若果多随意食。六群比丘以僧果饷白衣。白衣复从余比丘索。以是白佛。佛言。不应以僧果饷白衣。犯者突吉罗。有诸白衣来入僧坊见果。从诸比丘乞诸比丘不敢与。即便讥呵。以是白佛。佛言应与。佛在毗舍离。时世饥馑乞食难得。故梵志比丘作是念。若世尊听我等种菜者饥时可以足食。以是白佛。佛言听。皆如上种果中说。若白衣僧地中种菜。僧若须得三过从索。诸比丘使净人于非净处洗菜未竟明相已出生疑。以是白佛。佛言无犯。诸比丘无净人。不知谁应行僧食。以是白佛。佛言。比丘应受已行之。有诸木器行食肥腻不净。以瓦石揩洗破坏僧器。以是白佛。佛言。不应以瓦石揩洗。应沸汤灰洗。有酥油蜜瓶应覆盖无有净人。以是白佛。佛言。应用新物覆勿令手近。瓶倾倒卒无净人可正。以是白佛。佛言。应自正但勿使器离地。有一比丘嗔嫌他。持其酥瓶着非净地经宿。欲令不复得食。以是白佛。佛言。于彼比丘为不净。酥主比丘得食。彼持着不净地犯突吉罗。诸比丘以船乘载饮食。无净人御乘行船。以是白佛。佛言。若无净人听比丘自御乘自行船

尔时众僧以车运米。有一婆罗门以僧不净米一把投车中。以是白佛。佛言。若可别除去。若不可别除去一把。有野狐偷比丘酥瓶着不净地经宿。不知云何。以是白佛。佛言。听啖无犯。有果树根在不净地枝覆净地。比丘亦在不净地持饮食着树枝上经宿。不知云何。以是白佛。佛言。枝着根为不净地不得食。有果树根在净地枝覆不净地。比丘亦在净地持饮食着枝上经宿。不知云何。以是白佛。佛言。听食无犯。有果树根在净不净地枝覆净不净地。比丘亦随在净不净地。果落净不净地经宿。不知云何。以是白佛。佛言。非比丘所为皆得食无犯。有比丘净地取土不净地起屋。比丘持食着中谓以为净。以是白佛。佛言。本依地为净不净不得食。有比丘不净地取土净地起屋。不敢持食着中。以是白佛。佛言。着食无犯。有水漂獐鹿等死肉无净人取。比丘自入水取之。不知云何。以是白佛。佛言。至岸令净人截去比丘手所捉处。余得食无犯。有住处比丘大得庵罗果。食饱以余与净人。净人明日持作羹与比丘。比丘不敢食。以是白佛。佛言本不作还食意皆听食无犯。有诸比丘食时不分与不得者。诸白衣讥呵言。沙门释子如猫狸食不相分与。诸比丘以是白佛。佛言。应相分与。乃至不分与一人犯突吉罗。有一婆罗门持糗寄比丘。比丘持着不净地经宿。明日来取分与比丘。比丘以已着非净地不敢受食。以是白佛。佛言。本是白衣糗听受食无犯。复告诸比丘。虽是我所制。而于余方不以为清净者。皆不应用。虽非我所制。而于余方必应行者。皆不得不行

    五分律第三分之九迦絺那衣法

佛在舍卫城。尔时诸比丘三衣中。若须一一衣于僧中取。时阿那律衣坏。诸比丘语言。大德可于僧中取物作。答言。世尊不听畜长衣。我作不能使一日成。恐犯长衣罪。复有波利邑众所知识比丘。来舍卫城后安居挍一宿不至于娑竭陀安居。安居竟十六日担重衣冒泥雨至佛所头面礼足却住一面。世尊常法。慰问客比丘言。汝等安居和合乞食易得道路不疲耶。答言。安居和合乞食不乏。道路遇泥雨担重衣极大疲极。诸比丘亦以阿那律事白佛。佛以二事集比丘僧。种种赞少欲知足赞持戒已。告诸比丘。从今听诸比丘受迦絺那衣。受迦絺那衣得不犯五事。别众食数数食不白余比丘。行入聚落畜长衣离衣宿。若檀越持迦絺那衣物施僧。诸比丘中少衣者应白二羯磨与之。一比丘唱言。大德僧听。僧得此迦絺那衣物。今与某甲比丘。若僧时到僧忍听。白如是。大德僧听。僧得此迦絺那衣物。今与某甲比丘。谁诸长老忍默然若不忍者说。僧已与某甲比丘迦絺那衣物竟。僧忍默然故。是事如是持。彼比丘得已应即日浣染打缝。若独能办者善。若不能成。僧应白二羯磨。差一比丘二三乃至众多比丘助之。一比丘唱言。大德僧听。今差某甲。某甲比丘助某甲比丘作衣。若僧时到僧忍。听白如是。大德僧听。今差某甲。某甲比丘助某甲比丘作衣。谁诸长老忍默然若不忍者说。僧已差某甲。某甲比丘助某甲比丘作衣竟。僧忍默然故。是事如是持。若衣竟僧所与物。比丘应持衣到僧中偏袒右肩脱革屣胡跪白言。僧得此迦絺那衣物已浣染打缝如法作竟。愿僧受作迦絺那衣。如是白已。又起遍示众僧。诸比丘应答言。长老我等随喜与汝共之。然后僧应白二羯磨受。一比丘唱言。大德僧听。僧得此迦絺那衣物。浣染打缝如法作竟。今受作迦絺那衣。若僧时到僧忍听。白如是。大德僧听。僧得此迦絺那衣物。浣染打缝如法作竟。今受作迦絺那衣。谁诸长老忍默然。若不忍者说。僧已受作迦絺那衣竟。僧忍默然故。是事如是持。僧所与衣物比丘复应遍行。言此衣僧已受作迦絺那衣。诸比丘一一应言。此衣僧已受作迦絺那衣。是为善受。此中所有功德尽属于我。是中有成受迦絺那衣。有不成受迦絺那衣。不成受者。若浣染打缝不如法。若小若大若是锦绮衣。若未自恣竟受。若贪利养。若欲故舍五事。皆不成受。反上成受。有八事失迦絺那衣。一时竟二失衣三闻失四远去五望断六衣出界七人出界八白二羯磨舍。有二因缘不得受迦絺那衣。一作衣未竟。二舍住处去。受迦絺那衣有三十日。舍亦有三十日。若前安居七月十六日受。至十一月十五日舍。若七月十七日乃至八月十五日受。至十一月十六日乃至十二月十四日舍。若后安居八月十六日受。至十二月十五日舍。若衣时竟。应白二羯磨舍。应一比丘唱言。大德僧听。僧今舍迦絺那衣。若僧时到僧忍听。白如是。大德僧听。僧今舍迦絺那衣。谁诸长老忍默然若不忍者说。僧已舍迦絺那衣竟。僧忍默然故。是事如是持

五分律卷第二十二五分律卷第二十三(弥沙塞)

        宋罽宾三藏佛陀什共竺道生等译

    第四分初灭诤法

佛在舍卫城。尔时诸比丘好共斗诤更相言讼。比丘比丘共诤。比丘比丘尼共诤。比丘尼比丘尼共诤。比丘尼比丘共诤。时阐陀舍比丘助比丘尼。未生诤便生。已生便增广。未灭者不灭。已灭者更起。诸比丘以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言。实尔世尊。佛种种呵责。汝等所作非法不随顺道。呵已告诸比丘。从今比丘比丘共诤乃至舍比丘助比丘尼皆犯突吉罗。有四种诤。一言二教诫三犯罪四事。以此事故。为诸比丘结七灭诤法若有诤起得以除灭。应与现前毗尼与现前毗尼。应与忆念毗尼与忆念毗尼应与不痴毗尼与不痴毗尼。应与自言与自言。应与多人语与多人语。应与草布地与草布地。应与本言治与本言治。何谓言诤。若比丘共诤。有言是法有言非法。是律非律。是犯非犯。是重非重。是有余非有余。是粗罪非粗罪。是用羯磨出罪不用羯磨出罪。是佛所说非佛所说。是佛所制非佛所制。以此致忿更相骂詈。是名言诤。何谓教诫诤。若比丘教诫比丘言。汝忆犯波罗夷不。忆犯僧伽婆尸沙偷罗遮波逸提波罗提提舍尼突吉罗恶说不。彼比丘不喜不受。以此致诤。是名教诫诤。何谓犯罪诤。若比丘犯波罗夷乃至恶说。又若斗诤相骂起身口意恶。是名犯罪诤。何谓事诤。僧常所行事一切羯磨及诸有所作。以此致诤是名事诤。优波离问佛言。世尊。言诤以几事灭。佛言。以现前毗尼多人语灭。又问。云何得灭。答言。若比丘与比丘诤是法非法乃至是佛制非佛制。僧如法如毗尼如佛教灭。若彼言是法是佛教受是忍是。是名现前毗尼灭。何谓现前。现前有三种僧现前人现前毗尼现前。何谓僧现前。僧和合集。是名僧现前何谓人现前。共诤人现前。是名人现前。何谓毗尼现前。应以何法以何律以何佛教得灭而以灭之。是名毗尼现前。若如是灭已还更发起。犯波逸提罪。又若如是灭言诤。言诤比丘不喜闻。异住处有一比丘。若二若三乃至一众。聪明智慧解波罗提木叉。作是念。往灭此事。为善者应往灭之。应先向彼众中知法比丘具说本末然后求集僧。僧集已应语言。汝且远去。我等共议汝事。彼比丘远去已僧应共议。若彼比丘如实说求我等如法如律灭此事者。我等当共如法如律灭之。若彼比丘不如实说。我等不得如法如律灭其此事。彼言诤比丘亦应共议。若僧如法如律作齐限。今日明日后日灭我等事者。我等当于僧中具说本末委僧灭之。既至僧中具说本末。若僧作二种语。或言应尔或言不应尔。不可定者。僧应语言。随汝所取二种语中各取四人作断事。僧言诤比丘各取四人已。僧当白二羯磨差之。应先再羯磨三人后羯磨二人。一比丘唱言。大德僧听。僧今差某甲某甲比丘作断事人。如法如律。灭彼言诤。若僧时到僧忍听。白如是。大德僧听。僧今差某甲某甲比丘作断事人。如法如律灭彼言诤。谁诸长老忍默然不忍者说。僧已差某甲某甲比丘作断事人竟。僧忍默然故。是事如是持。时诸比丘差无智比丘作断事人。以是白佛。佛言。成就五法应差。受他语不嗔。受他语不失。善察语意。问语不问不语。语时不笑。反此五法不应差。复有五法应差。不随欲恚痴畏不窃语。反此五法不应差。若不被差比丘若一若二若三。虽聪明智慧于座中坐。欲干乱断事者。僧应驱出。若复有比丘虽多诵习不解其义。而干乱断事者。断事人应语言。经义不如此。作如是灭言诤者。是名现前毗尼灭。若如是灭言诤时。有比丘言。应以多人语灭此事。僧应语言。汝此语善。汝解多人语不。若言不解。僧应人人呵言。汝不解多人语。云何言应以多人语灭此事。若僧不呵。皆犯突吉罗罪。若言解。僧应问。以何为多人语。答言。以多人语羯磨灭。又问。以何知多。答曰应行筹。僧复应语言。汝所说善。汝解几种行捉筹如法几种不如法。若言不解。僧亦应如上呵。若言解。僧应令说有十种行捉筹不如法十种如法。何谓十种不如法。若以小事行筹而捉。若不知事根本行筹而捉。若以不应求事根本行筹而捉。若非法行筹而捉。若欲多不如法行筹而捉。若知多不如法行筹而捉。若行破僧筹而捉。若行知僧必破筹而捉。若不随善知识行筹而捉。若僧不和合行筹而捉。反上为如法。若成就十四法。僧应差作行筹人。知十如法又不随欲恚痴畏。是为十四。僧应作二种筹。一名如法。二名不如法。唱言。若言如法捉如法筹。若言不如法捉不如法筹。唱已行之。自收取于屏处数。若不如法筹多。应更令起相远坐人人前窃语言。此是法语律语佛之所教。大德当舍非法非律非佛所教。如是语已复更行筹。若不如法人犹多应复唱。僧今未断是事。可随意散。后当更断。如是不应以非法断事。若如法人多。应白二羯磨灭之。一比丘唱言。大德僧听。僧今以多人语灭此诤事。若僧时到僧忍听。白如是。大德僧听。僧今以多人语灭此诤事。谁诸长老忍默然不忍者说。僧以多人语灭此诤事竟。僧忍默然故。是事如是持。是名以多人语灭言诤。优波离复问佛。教诫诤以几事灭。佛言。以现前毗尼忆念毗尼不痴毗尼本言治灭。又问云何得灭。答言。若比丘问一比丘言。汝忆犯重罪波罗夷及波罗夷边罪不。答言不忆。又再三问答亦如初。如是比丘。僧应白四羯磨与忆念毗尼。不应从彼比丘而治其罪。被问比丘。应至僧中偏袒右肩脱革屣礼僧足胡跪白言。我某甲比丘彼某甲比丘再三来至我所问我。汝忆犯重罪波罗夷若波罗夷边罪不。我亦再三答言不忆。今从僧乞忆念毗尼。愿僧与我忆念毗尼。使彼不复数数问我。如是第二第三乞。僧应筹量此比丘。先不缺戒威仪如法不。身口意行清净不。好学戒不。向一比丘语。二人三人及僧语不异不。僧如是筹量。若知此比丘先缺戒。具诸不善者不应与。若知不犯波罗夷及波罗夷边罪。应白四羯磨与忆念毗尼。一比丘唱言。大德僧听。此某甲比丘于僧中乞言。彼某甲比丘再三来至我所问我。汝忆犯重罪波罗夷若波罗夷边罪不。我亦再三答言不忆。今从僧乞忆念毗尼。愿僧与我忆念毗尼。使彼比丘不复数数问我。僧今与某甲忆念毗尼。使彼比丘不复数数问其罪。若僧时到僧忍听。白如是。大德僧听。此某甲比丘于僧中乞言。彼某甲比丘再三来至我所问我。汝忆犯重罪波罗夷若波罗夷边罪不。我亦再三答言不忆。今从僧乞忆念毗尼。愿僧与我忆念毗尼。使彼比丘不复数数问我。僧今与某甲忆念毗尼。使彼比丘不复数数问其罪。谁诸长老忍默然不忍者说。如是第二。第三僧与某甲比丘忆念毗尼竟。僧忍默然故。是事如是持。是名现前毗尼忆念毗尼灭教诫诤。若比丘至比丘所语言。汝忆犯重罪波罗夷若波罗夷边罪不。彼比丘答言不忆。我先狂心散乱心病坏心多作非沙门法。又再三问答亦如初。如是比丘。僧应与不痴毗尼。不应从彼比丘而治其罪。彼比丘应至僧中偏袒右肩脱革屣礼僧足胡跪白言。大德僧听。我某甲比丘。彼某甲比丘再三来至我所问我言。汝忆犯重罪波罗夷若波罗夷边罪不。我亦再三答言不忆。我先狂心散乱心病坏心多作非沙门法。今从僧乞不痴毗尼。愿与我不痴毗尼。使彼比丘不复数数问我。如是三乞。僧应筹量此比丘。先不缺戒威仪如法不。身口意业清净不。好学戒不。向一比丘语二三比丘及僧语不异不。若僧知其先有如此诸恶不应与。若不尔应白四羯磨与不痴毗尼。一比丘唱言。大德僧听。此某甲比丘从僧乞言。彼某甲比丘再三来至我所问我言。汝忆犯重罪波罗夷若波罗夷边罪不。我亦再三答言不忆。我先狂心散乱心病坏心多作非沙门法。今从僧乞不痴毗尼。愿僧与我不痴毗尼。使彼比丘不复数数问我。僧今与不痴毗尼。使彼比丘不复数数问其罪。若僧时到僧忍听。白如是。大德僧听。此某甲比丘从僧乞言。彼某甲比丘再三来至我所。乃至僧今与不痴毗尼。使彼比丘。不复数数问其罪。谁诸长老忍默然不忍者说。如是第二第三僧。已与某甲比丘不痴毗尼竟。僧忍默然故。是事如是持。是名现前毗尼不痴毗尼灭教诫诤。若比丘至比丘所问言。汝忆犯重罪波罗夷若波罗夷边罪不。答言不忆。三问乃答言。我忆犯轻罪。又再问。汝犯轻罪犹不语人。况复重罪汝善思之。答言。我都不忆。复更问。乃答言。我忆犯波罗夷若波罗夷边罪。作是答已。寻复言。我不忆犯重罪。向戏言耳。如是比丘。僧应与本言治。本言有二种。一可悔。二不可悔。彼比丘本言犯重罪。应与作尽寿不可悔白四羯磨。应一比丘唱言。大德僧听。此某甲比丘。彼某甲比丘至某所问言。汝忆犯重罪波罗夷若波罗夷边罪不。答言不忆。再问亦言不忆三问然后言。不忆犯重罪忆犯轻罪。又问汝犹不发露轻罪况于重者。汝今谛忆犯重罪不。答言不忆。又问亦言不忆。乃至第六问然后言。我忆犯重罪波罗夷若波罗夷边罪。作是答已寻复言。我不忆犯重罪向戏言耳。僧今与作本言治尽寿不可悔羯磨。若僧时到僧忍听。白如是。大德僧听。此某甲比丘。彼某甲比丘至其所问言。汝忆犯重罪。乃至僧今与作本言治尽寿不可悔羯磨。谁诸长老忍默然不忍者说。如是第二第三。僧已与某甲比丘本言治尽寿不可悔羯磨竟。僧忍默然故。是事如是持。是名现前毗尼本言治灭教诫诤。优波离问佛言。世尊。犯罪诤以几事灭。佛言。以现前毗尼草布地自言灭。又问云何得灭。答言。若一比丘至一比丘所偏露右肩胡跪合掌作如是言。大德我某甲犯某罪。今向大德悔过。彼比丘应问。汝自见罪不。答言。我自见罪。又应问。汝欲悔过耶。答言。我欲悔过。彼比丘应语言。汝后莫复作。是名现前毗尼自言灭犯罪诤。若一比丘至二比丘三比丘众多比丘所。若二比丘乃至众多比丘。至一比丘乃至众多比丘所亦如是。若有比丘斗诤相骂作身口意恶业。后作是念。我等斗诤相骂作身口意恶业。今宁可于僧中除罪作草布地悔过不。此诸比丘听僧中除罪。僧应与作白二羯磨草布地悔过。彼斗诤比丘应尽来僧中偏袒右肩脱革屣胡跪白言。大德僧听。我等共斗相骂作身口意恶业。后作是念。我等共斗相骂作身口意恶业。今宁可于僧中除罪作草布地悔过不。今从僧乞草布地悔过。如是三说已。皆舒手脚伏地。向羯磨师一心听受羯磨。羯磨师唱言。大德僧听。此诸比丘共斗相骂作身口意恶业。后作是念。我等共斗相骂作身口意恶业。今宁可于僧中除罪作草布地悔过不。今从僧乞草布地悔过。僧今与其草布地悔过。若僧时到僧忍听。白如是。大德僧听。此诸比丘共斗相骂。乃至僧今与其草布地悔过。谁诸长老忍默然不忍者说。僧已与此诸比丘草布地悔过竟。僧忍默然故。是事如是持。是名现前毗尼草布地灭犯罪诤。何谓草布地。彼诸比丘不复说斗原。僧亦不更问事根本。优波离问佛言。世尊。事诤以几事灭。佛言。随事诤用七事灭。若一比丘。至一比丘所。作非法非律非佛教。灭事诤言。是法是律是佛教。若以此灭事诤。名为非法灭。若一比丘。至二比丘乃至僧所。若二比丘乃至僧。至一比丘乃至僧所亦如是。若一比丘。至一比丘所。作如法如律如佛所教灭事诤言。是法是律是佛所教。若以此灭事诤名为如法灭。若一比丘。至二三比丘乃至僧所。若二比丘乃至僧。至一比丘乃至僧所亦如是

    五分律第四分之二羯磨法

佛在舍卫城。尔时有一比丘。故出不净犯僧伽婆尸沙不覆藏。不知云何。问诸比丘。诸比丘亦不知。以是白佛。佛以是事集比丘僧。告诸比丘。是比丘犯僧伽婆尸沙不覆藏。今听僧与彼比丘作白四羯磨六夜行摩那埵。犯罪比丘应偏袒右肩脱革屣礼僧足已胡跪白。大德僧听。我某甲比丘故出不净犯僧伽婆尸沙不覆藏。今从僧乞六夜行摩那埵。愿僧与我六夜行摩那埵。如是三乞。应一比丘唱言。大德僧听。此某甲比丘故出不净犯僧伽婆尸沙不覆藏。从僧乞六夜行摩那埵。僧今与某甲六夜行摩那埵。若僧时到僧忍听。白如是。大德僧听。此某甲比丘故出不净。乃至僧今与某甲六夜行摩那埵。谁诸长老忍默然不忍者说。如是第二第三。僧与某甲比丘六夜行摩那埵竟。僧忍默然故。是事如是持。彼比丘应日日至僧中偏袒右肩脱革屣礼僧足胡跪白言。大德僧听。我某甲比丘故出不净犯僧伽婆尸沙不覆藏。从僧乞六夜行摩那埵。僧已与我六夜行摩那埵。我今行摩那埵已若干日。余若干日在。诸大德忆知。过六夜已。应从僧乞阿浮呵那。白言。大德僧听。我某甲比丘故出不净犯僧伽婆尸沙不覆藏。从僧乞六夜行摩那埵。僧已与我六夜行摩那埵。我六夜行摩那埵竟。今从僧乞阿浮呵那。愿僧与我阿浮呵那。如是三乞。应一比丘唱言。大德僧听。此某甲比丘故出不净犯僧伽婆尸沙不覆藏。从僧乞六夜行摩那埵。僧已与六夜行摩那埵。彼比丘六夜行摩那埵竟从僧乞阿浮呵那。僧今与某甲阿浮呵那。若僧时到僧忍听。白如是。大德僧听。此某甲比丘故出不净。乃至僧今与某甲阿浮呵那。谁诸长老忍默然不忍者说。如是第二第三。僧与某甲比丘阿浮呵那竟。僧忍默然故。是事如是持。有一比丘故出不净犯僧伽婆尸沙覆藏一夜。不知云何。问诸比丘。诸比丘亦不知。以是白佛。佛以是事集比丘僧。告诸比丘。今听僧白四羯磨与此比丘作一夜别住法。犯罪比丘应至僧中如是白。大德僧听。我某甲比丘故出不净犯僧伽婆尸沙覆藏一夜。今从僧乞一夜别住法。愿僧与我一夜别住法。如是三乞。应一比丘唱言。大德僧听。此某甲比丘故出不净犯僧伽婆尸沙覆藏一夜。从僧乞一夜别住法。今僧与某甲一夜别住法。若僧时到僧忍听。白如是。大德僧听。此某甲比丘故出不净。乃至僧今与某甲一夜别住法。谁诸长老忍默然不忍者说。如是第二第三。僧已与某甲比丘一夜别住竟。僧忍默然故。是事如是持。彼比丘一夜别住竟。应从僧乞行摩那埵乃至阿浮呵那。僧亦如上与之。有一比丘故出不净犯僧伽婆尸沙不覆藏。从僧乞行摩那埵。于六夜中复犯亦不覆藏。不知云何。问诸比丘。诸比丘亦不知。以是白佛。佛以是事集比丘僧。告诸比丘。今听彼比丘更从僧乞行摩那埵。僧亦应白四羯磨更与彼比丘行摩那埵。彼比丘六夜行竟。应复更从僧乞行本摩那埵。僧亦应白四羯磨与之。彼比丘更从僧乞言。我某甲比丘先故出不净犯僧伽婆尸沙不覆藏。从僧乞行摩那埵。僧与我行摩那埵。我于六夜中更犯不覆藏。今从僧更乞行摩那埵。愿更与我行摩那埵。如是三乞。应一比丘如其乞辞白四羯磨与之。彼六夜行竟。复更从僧乞行本六夜摩那埵言。我某甲比丘先故出不净犯僧伽婆尸沙不覆藏。从僧乞行摩那埵。僧与我行摩那埵。我于六夜中更犯不覆藏。复从僧乞行六夜摩那埵。我已六夜行摩那埵竟。今从僧乞行本六夜摩那埵。愿僧与我行本六夜摩那埵。如是三乞。应一比丘如其乞辞白四羯磨与之。彼比丘行本六夜摩那埵竟。应如上乞阿浮呵那。僧亦如上与之。有一比丘故出不净犯僧伽婆尸沙覆藏一夜。僧与一夜别住。于中复犯亦覆藏一夜。不知云何。问诸比丘。诸比丘亦不知。以是白佛。佛以是事集比丘僧。告诸比丘。今听彼比丘更从僧乞一夜别住。僧亦应白四羯磨更与一夜别住。彼一夜别住竟。应复更从僧乞本一夜别住。僧亦应白四羯磨与之。彼比丘更从僧乞一夜别住言。我某甲比丘先故出不净犯僧伽婆尸沙覆藏一夜。从僧乞一夜别住。僧与我一夜别住。我于中复犯亦一夜覆藏。今更从僧乞一夜别住。愿僧更与我一夜别住。如是三乞。应一比丘如其乞辞白四羯磨与之。彼一夜别住竟。复应更从僧乞本一夜别住言。我某甲比丘先故出不净。犯僧伽婆尸沙一夜覆藏。从僧乞一夜别住。僧与我一夜别住。我于中复犯亦一夜覆藏。复从僧乞一夜别住。僧复与我一夜别住。我已一夜别住竟。今从僧乞本一夜别住。愿僧与我本一夜别住。如是三乞。应一比丘如其乞辞白四羯磨与之。彼比丘本一夜别住竟。应如上乞行六夜摩那埵。行摩那埵竟。复应如上乞阿浮呵那。僧皆应如上白四羯磨与之。有一比丘故出不净犯僧伽婆尸沙覆藏一夜。僧如上与一夜别住。于中复犯亦覆藏一夜。僧复如上更与一夜别住。行竟。僧复如上与本一夜别住。行竟。僧复如上与六夜摩那埵。于中复犯不覆藏。僧复如上与六夜摩那埵。彼六夜行竟。僧复如上与行本摩那埵。行竟。然后如上与阿浮呵那。若比丘犯一僧伽婆尸沙乃至众多。覆藏二夜乃至众多夜。僧若与别住者。但计覆藏最久者。随日数与别住。若僧与别住后于中更犯。若覆藏。僧应随日更与别住。若不覆藏。僧应如上与六夜摩那埵。更别住竟摩那埵竟。僧复应如上更与本别住。与本别住竟。与六夜摩那埵。若于中复犯僧复应与六夜摩那埵。行竟。僧复应如上与本摩那埵。然后如上与阿浮呵那。有一比丘。犯二僧伽婆尸沙。同覆藏一夜。而向僧说犯一覆藏一夜。僧与一夜别住。一夜别住竟。心生悔。我实犯二僧伽婆尸沙。云何但说犯一覆藏一夜。复来僧中白言。我实犯二僧伽婆尸沙同一夜覆藏。诸比丘以是白佛。佛言。听更与一夜别住。彼比丘应具说上事三乞。应一比丘如其乞辞白四羯磨与之。有一比丘犯一僧伽婆尸沙覆藏二夜。向僧说覆藏一夜。僧与一夜别住。一夜别住竟。心生悔。我实二夜覆藏。云何说一夜。复来僧中以事白僧。诸比丘以是白佛。佛言。听僧更与一夜别住。彼比丘应具说上事三乞。僧亦如其乞辞白四羯磨与之。有一比丘犯僧伽婆尸沙覆藏罢道。后更出家受具足戒。即日说先所犯。诸比丘以是白佛。佛言。应随彼比丘未罢道时覆藏日数与别住。有比丘犯僧伽婆尸沙不覆藏未行摩那埵罢道。后还受具足戒已覆藏。以是白佛。佛言。应随彼比丘后受戒来日数与别住。若比丘犯二僧伽婆尸沙。覆藏一不覆藏一罢道。后还受具足戒已。先所不覆藏更覆藏。先所覆藏更不覆藏。应随彼比丘前覆藏至罢道日数后覆藏从更受戒日数与别住。若比丘犯僧伽婆尸沙覆藏罢道。后还受具足戒已复覆藏。应随彼比丘前后覆藏日数与别住。若比丘犯僧伽婆尸沙不覆藏罢道。后还受具足戒已亦不覆藏。应与其六夜摩那埵。若比丘犯僧伽婆尸沙。作沙弥狂心散乱心病坏心。僧与作不见罪羯磨不悔过羯磨不舍恶邪见羯磨。皆如罢道说。若比丘犯僧伽婆尸沙知数多少。或一罪或异罪覆藏罢道。后还受具足戒已不覆藏。或先不覆藏罢道。后受具足戒已覆藏。或先半覆藏半不覆藏。后受戒已。先覆藏者更不覆藏。先不覆藏者更覆藏。或先后皆覆藏。行别住法皆如前说。若前后皆不覆藏。行六夜摩那埵亦如上。若作沙弥乃至不舍恶邪见羯磨亦如是。若比丘于别住中罢道后还受具足戒。应计先别住日数但更足。令足行本别住亦如是。若作沙弥乃至不舍。恶邪见羯磨亦如是。若比丘于行摩那埵中罢道后还受具足戒。足日亦如是。行本摩那埵亦如是。若作沙弥乃至不舍恶邪见羯磨亦如是。若比丘行别住竟及行本别住竟。未与摩那埵罢道后还受具足戒。应令行摩那埵。若行摩那埵竟及行本摩那埵竟。未与阿浮呵那。后还受具足戒。应与阿浮呵那。若作沙弥乃至不舍恶邪见羯磨亦如是。若比丘犯僧伽婆尸沙。知所犯数知覆藏日。如法从僧乞别住。如法从僧乞摩那埵如法从僧乞本日。如法从僧乞阿浮呵那。僧若皆如法与。是人名为清净。僧若一事不如法与。是人不名清净。有二比丘犯僧伽婆尸沙。一比丘知犯一比丘不知犯俱覆藏。以是白佛。佛言。知犯者应与别住。不知犯者应与摩那埵。忆不忆亦如是。有二比丘犯僧伽婆尸沙覆藏。一比丘作一想。一比丘作异想。或言是波罗夷。或言偷兰遮乃至恶说。以是白佛。佛言。作一想者应与别住。作异想者应与摩那埵。有诸比丘。或行别住时或行摩那埵时或阿浮呵那时命过。诸比丘以是白佛。彼为是具戒命过。为是破戒命过。佛言。皆是具戒。有比丘犯僧伽婆尸沙不知罪数亦忘覆藏久近。以是白佛。佛言。从其忆犯已来与别住。疑亦如是。有比丘于一切人覆藏。有比丘于彼人覆藏于此人不覆藏。有比丘在此土覆藏在彼土不覆藏。诸比丘以是白佛。佛言。一切覆藏名为覆藏。若于和尚阿阇梨所敬畏人间覆藏不名覆藏于余人间覆藏名为覆藏。若于此土以多人识重不欲令知覆藏不名覆藏。于彼土覆藏名为覆藏

五分律卷第二十三五分律卷第二十四(弥沙塞)

        宋罽宾三藏佛陀什共竺道生等译

    第四分之二羯磨法下

佛在拘舍弥城。尔时有一比丘犯戒不知所犯。语诸比丘。诸比丘或谓有犯或谓无犯。谓无犯者语言。汝不犯戒。彼闻已便生不犯戒想。谓有犯者语言。汝犯戒应自见罪悔过。勿污染梵行负人信施长夜受苦。彼比丘言。我无所犯。云何应自见罪悔过。谓是犯戒诸比丘便与作不见罪羯磨。彼被举已便入拘舍弥城求助伴傥语言。我不犯罪彼诸比丘强言我有罪。与我作不见罪羯磨。是为羯磨不成。诸大德当如法如律救助于我。复往城外诸比丘所如上求助。诸比丘闻皆共佐助。尔时世尊知僧已破。从坐起往到助被举比丘众中。语言。汝等莫作是语言。彼比丘不犯罪。若彼比丘实不犯罪而被举者。汝等犹应语言。应自见罪悔过。彼便当作是念。若我言不见罪。僧当与我作不见罪羯磨。不共我住不共我布萨。自恣作诸僧事。汝等以此致诤。令僧不和别住生诸尘垢。当畏此事应令彼人自见罪悔过。世尊。说此已。复至举罪比丘众中语言。汝等勿强举他罪。若彼实犯罪。僧应语自见罪。彼若言我无罪可见。僧犹应筹量。若我等与作不见罪羯磨。不共住不共布萨。自恣作诸僧事。以此致诤更相骂詈。令僧不和别住生诸尘垢。汝等当畏此事舍置勿举。诸比丘虽闻佛语犹诤不息。便于食上高声骂詈更相打击。佛复告言。不应相骂不应食上高声。犯者皆突吉罗。若相打者偷罗遮。诸比丘虽闻佛语犹诤不息。便于界内别作僧事。佛复告言。若僧已破。于界内别作羯磨。如法如律者。亦名羯磨成就。所以者何。二部异见不同住故。不同住有二种。有自作不同住。有僧羯磨与作不同住。诸比丘虽闻佛语犹诤不息。佛复告诸比丘。汝等勿共斗诤更相诽谤更相骂詈。应共和同集在一处。如水乳合共弘师教。诸比丘白佛言。世尊。愿安隐住佛虽法主我等自知。佛三止之。诸比丘答亦如初。佛复告诸比丘。乃往过世拘萨罗有王名曰长寿。所统处少兵众寡弱。邻国迦夷王名梵达。所统处广兵众强盛。渐渐侵夺遂吞其国。梵达王得长寿王一臣。甚宠遇之仕以国事。时长寿王赤身将妇作婆罗门。向波罗奈国住陶师家。妇忽作是念。愿得日初出时四衢道中四种兵战磨刀汁饮。念已白王。若此愿不遂于此便死。王言。此不可果。汝今此病必死无疑。复语妇言。若梵达闻此知我所在。必反缚我打驴鸣鼓。分裂我身作五分矣。汝可小待。吾当密就先臣问此意故。语已便往具以问之。先臣答言。须见夫人当自相之。便往至夫人所。遥见夫人。便偏袒右肩头面作礼。三反称言。夫人今怀大福德子。拘萨罗国国嗣有继。复语王言。明旦当使夫人所念得果。语已便还梵达所。白言。大王知不。有如是星出。应集四种兵明旦日初出时。在四衢道作两阵共战而皆磨刀以攘其灾。若不尔者必大凶衰。梵达王言便可为之。于是大臣即敕严四种兵。明旦日初出时。于四衢道两阵共战而皆磨刀。密令夫人住于一处以磨刀汁与之。夫人即饮长养于胎。月满生子颜貌殊妙。字曰长生。至年十岁父语之言。梵达侵夺我国。我与汝母逃走至此。其日已久汝复长大。彼或得闻父子。便当一时并命。汝可远去勿恋父母。长生悲泣礼父母足绕三匝而去。修学伎艺算书射御乘调象马音乐之事莫不过人。偏奉象师尽调象术。长寿王昔剃发师。后与梵达作剃发人。往至其所求令剃发。彼即识之不敢藏隐。具问舍止逃伏所在以告梵达。梵达闻已即敕收之。反缚夫妇打驴鸣鼓。遍令里巷于四衢道分作五分。受教即收。长生闻之。便往道侧见已内崩。便作是念。父母之怨不同天地。我今云何而安忍此。匹夫之诚足以有感。便欲没命以报仇耻。父母遥见之。知其必怀报怨之念。便如狂人高声独语。汝莫见长亦莫见短。以怨报怨怨无由息。报怨以德其怨乃已。顺父母心乃曰孝子。率情肆志非吾谓道。于时观者咸言。长寿王怖惧狂语。唯长生闻深得父意。克己只承情得暂息。虽内崩绝而不形外。即自抑夺还象师所。而犹不忘报怨之术。后于象厩中夜弹琴。其声清和。梵达闻之。即问。厩中谁能作此。答言。某甲象师有一弟子。是其所作。即呼令更弹。闻已念言。自我为王未曾闻此。遂便信任恒在左右。彼王后时严四种兵。将诸宫人群臣太子田猎游戏。兵众四散竞逐诸鹿。长生时御王车。逸出军前三由旬。人无觉者。王体疲极语长生言。我欲小卧汝能护我不。答曰。王但安眠我能护王。王即住树下枕其膝眠。王防身剑自然拔出在长生前。长生见之便生是念。此王于我有是大怨。今日之遇岂可不乘。即起捉剑欲刎王颈。寻复念言。父母恩重过于二仪。临终敕我。汝莫见长亦莫见短。以怨报怨怨无由息。我今云何而违此诲。即还致剑侍寝如故。王便惊觉。长生问言。王何故惊。答言。我梦见长寿王子执剑欲断我命。长生言。此空野中何缘忽有长寿王子。必是山神恐怖王耳。王但安寝勿怀忧虑。如是至三。王最后眠。长生复作是念。父母临终诲我苦切。报怨以德其怨乃已。向来云何三欲违逆。从今克念事王如亲。终不复生一毫害意。作是念已。王觉大喜。长生问言。何故大喜。答言。我梦长寿王子欲事我如亲不复怀害。是以大喜。于是长生即白王言。长寿王子即我身是。王害我父母。我志欲杀王。三复遗敕。王所以免。然此心难保后或复生。愿王图之勿贻后虑。王言。我行无道汝父子怀仁。我今云何而有图虑。汝施我命誓不相负。便即还军集群臣共议。若得长寿王子当云何治。或言当截其手足。或言当截其耳鼻。或言应以斧锉。或言应以木丳炙。王即指言。此人便是长寿王子。其人已施我命。我今亦当以命报之。一切不得怀恶意向。于是还宫以女妻之。左手捉金澡盘。右手捉金澡罐。灌长生手还其本国。复为拘萨罗王。邻国和好如是累世。告诸比丘。国王世人构此大怨。犹以不念反成亲厚。汝等出家求无为道。如何小事便共斗诤以失大利。当舍此心还共和同。如水乳合共弘师教得安乐住。诸比丘复白佛言。世尊。愿安隐住。佛虽法主我自知之。犹故不舍。佛便飞升虚空。说是偈言

  更相出诸恶　　终无有胜法
  僧破成二分　　靡不由是事
  断骨夺人命　　劫盗牛马财
  破国灭族怨　　犹尚得和合
  譬两木相揩　　俱出火自焚
  无所不延及　　愚忿亦如之
  汝等相骂辱　　执而不舍者
  怨祸无由息　　日夜增根栽
  种种恶声骂　　若能不加报
  此忍不致怨　　有怨自然除
  若以怨除怨　　怨终不可息
  不念怨自除　　是则最勇健

世尊说此偈已。即以神力飞到波罗聚落。住跋陀婆罗树下。无诸翼从。时彼有一大象。为众象所恼。若欲饮水其众象子前混令浊。若欲食草其诸象子于前食啖践踏污秽。彼象念言。我今为群象所困。宁可避去。念已即去。常得清水美草。渐向跋陀婆罗林见佛欢喜。为佛取水除左右草。佛以此象离众快乐亦自乐静。而说偈言

  二龙自同心　　俱患群众恼
  皆已舍独游　　今乐此空林

佛说偈已。从跋陀婆罗林之舍卫城住祇洹精舍。时优婆塞优婆夷国王大臣长者居士外道沙门婆罗门。供养恭敬尊重赞叹。多得饮食衣服布施。世尊无著犹若莲花。时拘舍弥城诸优婆塞。咸作是言。我等今失大利。由诸比丘好斗诤故。世尊不住。当作方便令其远去。便共立要不复共语及施衣食。彼诸比丘亦作是语。由我等罪致使世尊舍此而去。我今宁可共往佛所苦自悔过。便着衣持钵来诣佛所。时舍利弗闻彼斗诤比丘来。与五百比丘俱到佛所。头面礼足白佛言。拘舍弥斗诤比丘今来。我等当云何待。佛告舍利弗。汝当听彼二众语。若如法如律如佛所教者。善待遇之与为伴傥。又问。世尊有几事知彼语如法如律如佛所教。几事知彼语非法非律非佛所教。佛言。若成就十四法。法言非法乃至是佛所制言非佛所制。是为非法非律非佛所教。若反上。是法是律是佛所教。时摩诃波阇波提比丘尼闻彼斗诤比丘来。与五百比丘尼往到佛所头面礼足白佛言。世尊。拘舍弥斗诤比丘今来。我等当云何待。佛言。汝当听彼二众语。若如法律如佛所教者。善待遇之。应从如法如律如佛教比丘求五事。比丘尼半月应从如法比丘乞教诫人。比丘尼要依有如法比丘处夏安居。安居竟应从如法比丘请见闻疑罪。式叉摩那学二岁戒已。应在二部僧中受具足戒。若比丘尼犯粗恶罪。应在二部僧中半月行摩那埵。行摩那埵已。应于二部众各二十人中求出罪。若比丘尼僧更有余事。应求如法比丘。时给孤独长者闻彼斗诤比丘来。与五百优婆塞往至佛所头面礼足白佛言。世尊。拘舍弥斗诤比丘今来。我等云何敬待。佛言。汝当听彼二众语。若如法如律如佛所教者。受其教诫。至于敬待供养。悉应平等。所以者何。譬如真金断为二段不得有异。毗舍佉母与五百优婆夷往至佛所白佛。佛答亦如是。时阿难见彼比丘入舍卫城。便往白佛。彼斗诤比丘已入。我当云何为敷卧具。佛言。应与边房。若不足者与中房。不得令彼上座无有住处。阿难受教即敷令住。尔时彼被举比丘于屏处作是念。我竟有罪为无有罪。为成被举为不成被举。羯磨如法为不如法。我今宁可谨依经律而思惟之。既思惟已。知己有罪。知成被举羯磨如法。便到伴傥比丘所语言。我已自见罪。诸大德为我求和合解先羯磨。诸比丘便将到与作不见罪羯磨比丘所语言。此比丘已自见罪。愿为解先羯磨。于是二部僧。将被举比丘往到佛所。头面礼足以是白佛。佛以是事集比丘僧。告诸比丘。此比丘犯罪非不犯罪。成被举非不成被举。羯磨成就非不成就。僧今应与解先羯磨。更白二羯磨为作和合。彼比丘应至僧中礼僧足白言。我比丘某甲。僧为我作不见罪羯磨。我今顺僧悔过。乞解不见罪羯磨。愿僧哀愍为我解。如是三说。一比丘唱言。大德僧听。此等比丘。先共斗诤更相骂詈。或言犯。或言不犯。或言成被举。或言不成被举。或言羯磨成就。或言羯磨不成就。此比丘今自见犯罪非不见犯罪。成被举非不成被举。羯磨成就非不成就。僧今为解不见罪羯磨还作和合。若僧时到僧忍听。白如是。大德僧听。此等比丘先共斗诤乃至还作和合。谁诸长老忍默然不忍者说。僧为某甲比丘解羯磨还作和合竟。僧忍默然故。是事如是持。佛言。羯磨竟。应即与共作和合布萨。时优波离问佛言。世尊。比丘成就几法得举事。佛言。如住自恣中说

佛在瞻婆国住恒水边。去王舍城不远。一住处有一比丘。姓迦叶。作摩摩谛。作是愿。愿四方比丘多来集此。令诸优婆塞优婆夷因此多作功德。彼住处宽博于后所愿得果。时有众多知识比丘到彼住处。迦叶比丘出迎礼拜问讯。为持衣钵办洗浴具设过中饮。明日供前后食亦施衣服。如是多日。客比丘共作议言。此比丘有惭愧修梵行。欲令我等久住。我等宁可于此安居。作是议已即便共住。迦叶比丘后作是念。此客比丘疲极已息。知聚落处所。我不能复日日劝化供前后食。念已便止。客比丘恨之。复作是议。此比丘欲令我等早去。定是恶比丘无有惭愧不修梵行。我等当与作不见罪举羯磨。议已便共举之。迦叶比丘作是念。我为有罪为无有罪。为成被举为不成被举。羯磨成就为不成就。世尊今在恒水边。当往问之。若有教敕我当奉行。念已着衣持钵往到佛所。头面礼足却住一面。佛慰问言。汝从何来乞食不乏道路不疲耶。答言。乞食不乏道路不疲。去王舍城不远。有一住处。我作摩摩谛。从彼处来。便以上事因缘本末具向佛说。佛言。汝不犯罪无罪可见。汝便还去安意住彼。迦叶受教。礼足右绕而退。诸客比丘见其还已。复共议言。我等不善。云何举此清净无罪比丘。当共至佛所悔过除罪。安居自恣竟。往到佛所头面礼足却住一面。佛慰问言。乞食不乏道路不疲耶。于何处安居。答言。乞食不乏道路不疲。去王舍城不远。有一住处于彼安居。佛问言。汝等于彼住处与彼比丘作不见罪举羯磨不。答言作。又问。以何事举之。答言无事。佛种种呵责言。汝等所作非法。不应作此恶业。云何与清净无罪比丘作不见罪举羯磨。诸比丘白佛言。世尊。我等愚痴。既作是事皆生悔心。今来悔过。唯愿哀愍受我悔过。佛以是事集比丘僧。告诸比丘。若比丘以无事作诸羯磨。羯磨皆不成。有诸比丘遥作呵责羯磨驱出羯磨依止羯磨举罪羯磨下意羯磨。又遥作别住本日摩那埵阿浮呵那。又遥结界解界。又遥解僧所差人。更遥差僧未差者。诸比丘以是白佛。佛以是事集比丘僧。告诸比丘。若遥作呵责羯磨乃至遥差僧未差人羯磨。此皆不如法羯磨。羯磨不成。时六群比丘于界外作不如法呵责羯磨。乃至下意羯磨。作已来入界内语诸比丘言。我等于界外与某甲某甲比丘作呵责羯磨乃至下意羯磨。诸大德当听令成如法羯磨。诸比丘以是白佛。佛以是事集比丘僧。告诸比丘。若比丘于界外作不如法五种羯磨乃至差僧所未差人羯磨。虽还语界内比丘令听成羯磨一切皆不成。时诸比丘。一比丘与一比丘。乃至与众多比丘作羯磨。二比丘乃至与众多比丘亦如是。诸比丘以是白佛。佛言。此皆羯磨不成得突吉罗罪。佛又言。若作羯磨。直羯磨而不白。不成羯磨。若羯磨应前说而后说。应后说而前说。亦皆不成。若羯磨时有得呵人不同亦不成。皆犯突吉罗罪。时诸比丘以余法余律作羯磨。诸比丘以是白佛。佛言。不成羯磨。时诸比丘作非法别众羯磨非法和合羯磨如法别众羯磨如法和合羯磨。诸比丘以是白佛。佛以是事集比丘僧。告诸比丘。我不听三种羯磨。唯听如法和合羯磨。有五种羯磨。非法羯磨。别众羯磨。似法别众羯磨。似法和合羯磨。如法羯磨。何谓非法羯磨。应来不来。应嘱授不嘱授。有得呵人不同。而强羯磨。应白二羯磨。而但白不羯磨。但羯磨不白。或再白不羯磨。再羯磨不白。应白四羯磨。而但白不三羯磨。但三羯磨不白。是名非法羯磨。何谓别众羯磨。应来不来。应嘱授不嘱授。羯磨时得呵人不同。而强羯磨。是名别众羯磨。何谓似法别众羯磨。应来不来。应嘱授不嘱授。若白二白四羯磨。先羯磨后白。羯磨时得呵人不同。而强羯磨。是名似法别众羯磨。何谓似法和合羯磨应来者来。应嘱授者嘱授。若白二白四羯磨。先羯磨后白。羯磨时有得呵人不呵。是名似法和合羯磨。何谓如法羯磨。应来者来。应嘱授者嘱授。羯磨时得呵人不呵。若白二白四羯磨。皆先白后羯磨。是名如法羯磨。若为比丘作非法呵责羯磨时。僧中有七人共诤。一人言此是非法羯磨。一人言此是别众羯磨。一人言此是似法别众羯磨。一人言此是似法和合羯磨。一人言此是如法和合羯磨。一人言成作羯磨。一人言不成作羯磨。此七人中二人语如法。谓是非法羯磨不成作羯磨者。若为比丘作别众呵责羯磨似法别众呵责羯磨似法和合呵责羯磨亦如是。若为比丘作如法呵责羯磨时。有七人语。二人语如法。谓是如法和合羯磨成作羯磨者。驱出羯磨依止羯磨举罪羯磨下意羯磨亦如是。有比丘斗诤。诸比丘作是议。此比丘好斗诤数有事。我等宁可和合与作如法呵责羯磨。即共和合欲与作如法呵责羯磨。而反作不如法呵责羯磨。羯磨不成。乃至反作似法和合呵责羯磨亦如是。彼比丘复移余住。余住诸比丘作是议。此比丘好斗诤。彼诸比丘为作似法和合呵责羯磨。羯磨不成。我等宁可与作如法和合呵责羯磨。便欲共作如法和合呵责羯磨。而反作不如。法驱出羯磨。乃至反作如法驱出羯磨。羯磨皆不成。乃至反作下意羯磨亦如是。有比丘行恶行污他家。诸比丘作是议。此比丘行恶行污他家。我等宁可和合与作如法驱出羯磨。便欲共作如法驱出羯磨。而反作不如法驱出羯磨。羯磨不成。乃至反作似法和合驱出羯磨亦如是。彼比丘便移余住。余住诸比丘作是议。此比丘行恶行污他家。被诸比丘为作似法和合羯磨。羯磨不成。我等宁可与作如法驱出羯磨。便欲共作如法驱出羯磨。而反作不如法依止羯磨。羯磨不成。乃至反作如法依止羯磨。羯磨皆不成。乃至反作呵责羯磨亦如是。有比丘愚痴无智数数犯罪。诸比丘作是议。此比丘愚痴无智数数犯罪。我等宁可和合与作如法依止羯磨。便欲共作如法依止羯磨。而反作不如法依止羯磨。羯磨不成。乃至反作似法和合依止羯磨亦如是。彼比丘便移余住。余住诸比丘作是议。此比丘愚痴无智数数犯罪。彼诸比丘为作似法和合依止羯磨。羯磨不成。我等宁可为作如法依止羯磨。便欲与作如法依止羯磨。而反作不如法举罪羯磨。羯磨不成。乃至反作如法举罪羯磨。羯磨亦皆不成。乃至反作驱出羯磨亦如是。有比丘犯罪。而不见罪不悔过不舍恶邪见。诸比丘作是议。此比丘犯罪。而不见罪不悔过不舍恶邪见。我等宁可和合与作如法举罪羯磨。便欲共作如法举罪羯磨。而反作不如法举罪羯磨。羯磨不成。乃至反作似法和合举罪羯磨亦如是。彼比丘便移余住。余住比丘作是议。此比丘犯罪不见罪不悔过不舍恶邪见。彼诸比丘为作似法和合举罪羯磨羯磨不成。我等宁可为作如法举罪羯磨。便欲共作如法举罪羯磨。而反作不如法下意羯磨。羯磨不成。乃至反作如法下意羯磨。羯磨亦皆不成。乃至反作依止羯磨亦如是。有比丘粗恶语骂诸白衣。诸比丘作是议。此比丘粗恶语骂诸白衣。我等宁可和合与作如法下意羯磨。便欲共作如法下意羯磨。而反作不如法下意羯磨。羯磨不成。乃至反作似法和合下意羯磨亦如是。彼比丘移余住。余住诸比丘作是议。此比丘粗恶语骂诸白衣。彼比丘为作似法和合下意羯磨。羯磨不成。我等宁可为作如法下意羯磨。便欲共作如法下意羯磨。而反作不如法呵责羯磨。羯磨不成。乃至反作如法呵责羯磨。羯磨亦皆不成。乃至反作举罪羯磨亦如是。有五种僧。四比丘僧。五比丘僧。十比丘僧。二十比丘僧。无量比丘僧。四比丘僧者。除受戒羯磨出罪羯磨。余羯磨皆得共作。五比丘僧者。中国除受戒出罪羯磨。边国除出罪羯磨余羯磨皆得共作。十比丘僧者。除出罪羯磨。余羯磨皆得共作。二十比丘僧者。一切羯磨皆得共作。若四比丘僧羯磨。第四人非法非比尼。羯磨不成。僧有过。优波离问佛。世尊。若僧羯磨时。有人呵。谁成呵谁不成呵。佛言。受羯磨人呵。为不成呵。若比丘隔壁呵。为不成呵。若比丘尼式叉摩那沙弥沙弥尼呵。皆不成呵。若同界比丘呵。乃至使比坐闻为成呵。有三种人。不应与解羯磨。若与解为不成解。何谓三。若比丘犯罪而不见罪。若比丘应悔过而不肯悔过。若比丘应舍恶邪见而不肯舍恶邪见。是为三。若未与作应与作。若已与作羯磨。是名善作羯磨。若反上。未与解羯磨应与解。若已与解。是名善解。佛在舍卫城。尔时有二比丘。一名盘那二名卢醯。好共斗诤亦斗乱他。未生斗诤便生。已生增广。诸比丘以是白佛。佛以是事集比丘僧。问彼二比丘。汝实尔不。答言。实尔世尊。佛种种呵。汝愚痴人。所作非法。不应作此恶业。呵已告诸比丘。从今若有如此比丘。僧应与呵责羯磨。若不罢者。应随其事白四羯磨重加其罪。若有三法。应与作呵责羯磨。既自斗诤复斗乱他前后非一。复有三法。亲近恶知识。与恶人为伴。自乐为恶。亦应与作呵责羯磨。复有三法。破增上戒。破增上见。亲近随顺白衣。亦应与作呵责羯磨。有三种呵责羯磨不成。所呵责人应现在前而遥呵责。应问僧言应与作呵责羯磨不。而不问应使所呵责人自说其过而不使自说。复有三种羯磨不成。应现前作羯磨而不现前。非法别众。应使自说其过而不使自说。受呵责羯磨比丘应正顺僧。何谓正顺。不应度人。不应授人具足戒。不应与人作依止。不应畜沙弥。不应作行筹人。若僧差亦不应受。不应教诫比丘尼。若僧差亦不应受。凡僧所差皆不应受。若行僧事时不得有语。不得骂余比丘。不得倚王势。不得自倚力。不得倚亲族力。唯应依佛法僧力。应悔过自责不逆僧意求解羯磨。彼二比丘后正顺于僧。改悔自责求解呵责羯磨。诸比丘以是白佛。佛言。僧应白四羯磨与解。彼比丘应至僧中礼僧足三乞解呵责羯磨。应一比丘唱言。大德僧听。此某甲比丘。好共斗诤斗乱彼此。未生斗诤便生已生增广。僧先与作呵责羯磨。若不罢者重加其罪。某甲已正顺僧。悔过自责求解羯磨。僧今与解羯磨。若僧时到僧忍听。白如是。大德僧听。此某甲比丘好共斗诤。乃至僧今与解羯磨。谁诸长老忍默然不忍者说。如是第二第三。僧与某甲比丘解呵责羯磨竟。僧忍默然故。是事如是持

尔时去舍卫城不远。有庵摩勒林。彼林侧有长者名质多罗。信乐佛法常供给诸比丘。庵摩勒林中有比丘名善法。旧住于彼作摩摩谛。质多罗长者。若请僧与衣食及施人物时。要先语之。时舍利弗目连。与五百比丘共游彼林。长者闻之便自出迎。到已头面礼足却住一面。为说妙法示教利喜已。白言。愿明日受我客比丘食。默然受之。知受已还归其家。到善法比丘所语言。我请舍利弗目连明日食。大德亦当来食。善法比丘作是念。此恶长者意已坏败。由来请僧要先语我。而今请舍利弗目连等五百比丘。不使我知。念已语言。明日当往。长者还归。竟夜办种种美食。世间珍味无不具有。晨朝敷座。善法比丘已到见其所办。奇珍必备。以其家押油。便语言。汝众味皆有。唯少一种胡麻饼。长者闻已便嗔恚言。大德多怀法宝而出此恶言。即为说譬。昔有估客。从北方担一雌鸡到波旬国。波旬国无雄鸡。与乌共合生卵。伏乳既成大鸟。作鸡鸣不成。作乌声亦不得。今大德如是。多怀法宝而出此恶言。善法比丘闻已便嗔恨言。长者苦见骂辱。何宜复住今当远去。长者复言。大德勿嗔。且留住此。我当依常供给衣食。如是再三犹不肯住。长者问言。大德欲至何处。答言欲往佛所。长者言。若至佛所愿为问讯世尊。具说此事勿令增减。答言可尔。于是长者敷坐具讫。往白时到食具已办。舍利弗目连大众围绕往到彼舍就座而坐。长者自下食。食毕行水。取小床于前坐。为说种种妙法示教利喜已从坐起去。食后善法比丘还林。着衣持钵往到佛所。头面礼足却坐一面。以质多罗长者所说具白世尊。佛便呵责言。汝愚痴人云何以下贱语加彼长者。即以是事集比丘僧。告诸比丘。从今应与如此等比丘作下意白四羯磨谢彼白衣。一比丘唱言。大德僧听。此某甲比丘以下贱声加某白衣。今僧与作下意羯磨谢彼白衣。若僧时到僧忍听。白如是。大德僧听。此某甲比丘以下贱声加某白衣。僧今与作下意羯磨谢彼白衣。谁诸长老忍默然不忍者说。如是第二第三。僧与某甲比丘作下意羯磨竟。僧忍默然故。是事如是持。复应白二羯磨差一比丘伴彼比丘谢彼白衣。一比丘唱言。大德僧听。僧今差某甲比丘伴某甲比丘辞谢白衣。若僧时到僧忍听。白如是。大德僧听。僧今差某甲比丘伴某甲比丘辞谢白衣。谁诸长老忍默然不忍者说。僧差某甲比丘伴某甲比丘辞谢白衣竟。僧忍默然故是事如是持。彼比丘应将僧所差比丘往捉白衣手谢言。我先作下贱声相加。我今悔过受我悔过。若受者善。若不受。僧所差比丘。应将彼比丘至眼见耳不闻处教作突吉罗悔过。应言。我某甲比丘作粗恶语加某甲白衣犯突吉罗罪。今向长老悔过。如是第二第三说。然后僧所差比丘。独还白衣所语言。僧已治彼比丘。我向亦重治之。可受其悔过。然后彼比丘复应来如上辞谢白衣。应正顺僧。如呵责羯磨中说。彼正顺僧已。悔过自责求解羯磨。僧应与解羯磨。羯磨亦如上说

五分律卷第二十四五分律卷第二十五(弥沙塞)

        宋罽宾三藏佛陀什共竺道生等译

    第五分初破僧法

尔时调达第三念言。我今破沙门瞿昙僧得大名称。一切当言沙门瞿昙有大神力而调达能破其僧。念已便语眷属頞鞞分那婆薮般那卢醯伽卢帝舍瞿伽离骞荼陀婆三闻达多等。其众中三闻达多最大聪明。语调达言。沙门瞿昙有大威德。其僧云何而可得破。答言。我当于僧申明五法。应尽寿持。一不食盐。二不食酥乳。三不食鱼肉若食善法不生。四乞食若受他请善法不生。五春夏八月日露坐冬四月日住于草庵若受人屋舍善法不生。此摩竭鸯伽二国人皆信乐苦行。我等行此五法。从者必多足以破之。三闻达多。闻已亦谓调达。可得与佛中分僧众振名远近。即便从之。时调达有优婆塞弟子名和修达。常供养调达。调达次以语之。亦相然可。于是调达十五日布萨时。于僧中说上五事。自行筹唱言。若忍乐此五法者可捉此筹。时五百比丘皆取筹。唯除阿难及一须陀洹比丘。时舍利弗目连诸大罗汉皆不在彼布萨会中。调达行筹毕。即与五百比丘和合布萨。阿难及一须陀洹比丘既不受筹便即出去。往到佛所头面礼足。以是事白佛。佛因说偈

  善人共会易　　恶人善会难
  恶人共会易　　善人恶会难

时舍利弗目连闻此事往到佛所。佛遥见逆叹言。善来舍利弗目连。汝等可往调达众中将五百比丘还。二人受教礼足而去。时须陀洹比丘随阿难来者。见舍利弗目连去。既便啼泣。佛问比丘。何故啼泣。答言。舍利弗目连是佛第一弟子。今往调达众中。恐学其法是以啼泣。佛语比丘。汝止勿泣。舍利弗目连须臾自当将五百比丘还。于是舍利弗目连往诣彼众。三闻达多遥见便走语调达言。今沙门瞿昙第一弟子舍利弗目连来。或破诸比丘意。当莫共语亦莫令坐。调达自以五法为道。不受其语不着心中。舍利弗目连既至。调达便言。善来舍利弗目连可就此坐。语言。若人有智先所未闻闻便受行。汝等先是沙门瞿昙第一弟子。今复来为吾作第一弟子不亦善乎。舍利弗目连默然不答。调达便谓已受其语。即效佛常法。告舍利弗目连。汝可为众说法。吾背小痛当自消息。便四叠僧伽梨枕之。右胁着地累脚而卧。不系念在前须臾眠熟。转左胁着地呼声骇人。时目连现种种神力如常所说。舍利弗说种种妙法初中后善善义善味梵行之相。五百比丘闻已。即于座上远尘离垢于诸法中得法眼净。见法得果已。更相语言。我等可起还到佛所。舍利弗目连即从坐起。与五百比丘俱还佛所。时三闻达多以足指蹴调达骂言。释奴起舍利弗目连以余方便将诸比丘去矣。调达惊起骂言。是恶欲比丘始有善意。如何忽生恶心以方便将我比丘去。便大怖惧热血从鼻孔出。即以生身堕大地狱。舍利弗目连到佛所已。头面礼足却坐一面。目连白佛言。世尊。我欲使此五百比丘更受具足戒。佛言。不须更受。所以者何。此五百比丘愚痴故以法想取筹。今但听僧令作偷罗遮悔过

目连白佛言。奇哉世尊。调达效佛堕如是苦处。佛言。调达不但今效我堕于地狱。昔亦曾效我堕于苦处。目连又问。其事云何。佛言。过去世时空闲处有一池水。有一大象入池取藕净洗而食色力充足。复有一象亦效取藕不洗而食。以此致病遂便命终。佛因是事即说偈言

  勿得效大龙　　大龙不可效
  以效大龙故　　食泥致死苦

佛告目连。彼大象者我身是。异象者调达是。昔效我故致于命终。今复效我受斯大苦。目连白佛言。奇哉世尊。调达从佛闻法诵八万四千法藏得五神通。如何而反憍慢世尊。佛言。不但今世昔亦曾从我闻法而慢于我。目连白佛。其事云何。答言。过去世时有一象师。极善调象。王供给甚厚。时有一人往诣其所语言。教我调象我为弟子。象师即便教之都无所隐。其人既知便生嫉心。往到王所白言。彼人所知不胜于我。云何供给远不相及。王即呼彼象师问言。汝与弟子孰为胜负。答言。愿听却后七日现调象法。王即听之。象师于七日中更调诸象。语进而退语退而进语坐而立语立而坐。作如是等反教调象。七日期至。便于王前与弟子共现调象之术。始者二人未有一异。王问弟子汝更有异法不。答言无。复问彼师。汝更有异法不。答言有。王言便可现之。即便反教象皆从之。王于是始知弟子前言为虚。便嗔言。如何面欺于我。彼调象师白王言。此人是我弟子。我先教之都无所隐。未能尽知便见轻忽。今当说譬。愿王听之。昔有一人于春末月着一重革屣。地热革燥啮破其脚。本欲护脚而反更伤。我亦如是先教弟子欲望其益而反为害。尔时世尊因说偈言

  如人着革屣　　本欲护其足
  得热燥急时　　而更反自伤
  世间愚恶人　　不念恩在己
  从师学技术　　而反倰诬之

佛言。彼象师者我身是也。弟子者调达是也。世世从吾受学而反轻慢于我

目连白佛言。希有世尊。舍利弗一说法破调达众。佛言。不但今世昔亦曾说法以破其众。又问。其事云何。答言。过去世时有一射师名拘和离。有人从学射法。六年教之语言。应作如是捉弓如是批箭。而未教放法。弟子后时念言。我六年中学捉弓批箭。而未一放。今试放之。便放箭射一大树。彻过入地。其师闻之问言。汝已放箭耶。答言已放。又问汝射何处。即示所射之树。师言汝已成射。我为第一汝为第二。又语言。某处有五百贼断路一切无敢从中过者。汝可往破以清其路可有大功。即与马车一乘美女一人并以金钵箭五百发。于是弟子乘车载女执如意弓带五百发箭受敕而去。正遇彼贼共分诸物使人逻于要道。逻人遥见驰白贼帅。贼帅语众人言。我等作贼未曾有人独将好妇于此路。行此必勇健不畏强敌。宜共听过勿得扰之。彼人便住一处。令妇持金钵往贼所称己名乞食。众贼皆乐其妇又贪金钵。即便议言。女色如是金钵如此。我等云何而听其去。贼帅又言。彼必自量无所畏故敢作此事。且当忍抑慎莫招祸。贼众闻已便与满钵美饭。妇持食还。复令往语。汝等分物与我一分。众贼大忿。此为何人乃以一夫敢轻大众。当共杀之勿抱此耻。贼帅如前语之。即复与分。妇得分还。复遣语贼言。可共我战俱不相置。众贼复言。此人转见轻蔑不可复忍。贼帅晓喻不能令止。勇忿忘难便共齐力往击彼人。彼人便射一发杀一人。四百九十九发。杀四百九十九人。余有一发以俟贼帅。更相觅便而不能得。彼人便令妇裸形贼帅前立。贼帅心乱。因此放发即复杀之。于是其妇即说偈言

  虽有利弓箭　　未曾落一发
  杀伤既狼籍　　如何不生悔

彼人亦以偈答

  我有此妙技　　弓箭应心手
  杀一辄生喜　　以何应致悔
  吾本行此路　　为人除怨害
  不自顾身命　　以成勇健名

佛言。彼射师者即我身是。射弟子者舍利弗是。五百贼者今五百比丘是。贼帅者调达是。舍利弗昔以一一箭破彼群贼。今一说法破调达众

目连复白佛言。奇哉世尊。调达骂云恶欲比丘。便以生身堕大地狱。佛言。不但今世昔亦曾以恶口生身受大苦。又问。其事云何。答言。过去世时阿练若池水边有二雁。与一龟共结亲厚。后时池水涸竭。二雁作是议。今此池水涸竭。亲厚必授大苦。议已语龟言。此池水涸竭汝无济理。可衔一木。我等各衔一头。将汝着大水处。衔木之时慎不可语。即便衔之。经过聚落诸小儿见皆言。雁衔龟去雁衔龟去。龟即嗔言何预汝事。即便失木堕地而死。尔时世尊。因此说偈

  夫士之生　　斧在口中　　所以斫身
  由其恶言　　应毁反誉　　应誉反毁
  自受其殃　　终无有乐
  若以财利诤　　此恶未为大
  恶心向佛者　　斯乃为大恶
  阿浮有百千　　尼罗三十六
  恶意向贤人　　当堕此地狱

佛言。彼龟者调达是也。昔以嗔语致有死苦。今复嗔骂堕大地狱。告诸比丘。我若见调达有一毫善法者。终不记堕大地狱受一劫苦。譬人没大粪坑。若人欲救不见一毫净处可捉。我观调达亦复如是。又告诸比丘。我不见余法坏人无上道意如名闻利养。调达所以破僧由利养故。调达成就八非法故破僧。利不利称无称敬不敬乐恶随恶知识

优波离问佛。云何得名破僧。佛言。有四事名破僧。说五法自行筹捉筹于界内别行僧事。又问。云何名僧不和合而非破。佛言。若王助破僧令僧不和合而非破。若大臣优婆塞优婆夷比丘尼式叉摩那沙弥沙弥尼一比丘乃至七比丘助破僧亦如是。若不问上座而行僧事。是即不和亦非僧破。若不共同食于食时异坐斗诤骂詈亦如是。要于界内八比丘分作二部别行僧事乃名为破。又问。是中谁破僧。佛言。作主者。又问。谁一劫堕大地狱不可救。佛言。作主者。又问。凡破僧者皆一劫受大地狱苦耶。佛言。不必皆一劫受大地狱苦。有八人破僧受一劫大地狱苦。若法法想说言非法。若非法非法想说言是法。若法非法想说言是法。若非法法想说言非法。若法非法法想说言非法。若法非法非法想说言是法。若法非法疑说言是法。若法非法疑说言非法。有六人破僧不堕大地狱一劫受苦。若法法想说言是法。若非法非法想说言非法。若法非法想说言非法。若非法法想说言是法。若法非法非法想说言非法。若法非法法想说言是法

    五分律第五分之二卧具法

佛在王舍城。尔时頞髀比丘侍佛左右。后时着衣持钵入城乞食。威仪庠序视地而行。有一长者见之作是念。我未曾见如此人比。便往问言。汝是谁谁之弟子。从谁出家行谁道法。时佛始成道。世皆称之为大沙门。答言。我名頞髀。大沙门是我之师。从彼出家行其道法。长者闻已叹言。未曾有也自有如是威仪而从大沙门出家行其道法。又问。汝今住何处。答言。阿练若处山岩树下露地冢间是我住处。长者闻已倍生欢喜。叹言。威仪庠雅所师已胜。乃复住止如斯之处。又问。敷何敷具。答言。如尸草拘尸草婆婆草文柔草及树叶等。下至沙土皆我敷具。长者闻已复加喜敬。叹言。乃能复作如是少欲。又问。我若为大德作房能受用不。答言。世尊未听我等受用房舍。又言。大德。可以此白佛。我亦当自白。頞髀默受其语。于食后还到佛所。头面礼足以是白佛。佛以是事集比丘僧。赞少欲知足赞戒赞持戒已。告诸比丘。从今听诸比丘受房舍施。彼长者后来佛所。遥见世尊容颜殊特犹若金山。内怀喜敬前礼佛足却坐一面。佛为说种种妙法乃至苦集尽道。即于座上得法眼净。见法得果受三归五戒。白佛言。世尊。我欲作房舍施诸比丘。愿听受之。佛默然许。彼长者知佛听已从坐起。前礼佛足右绕三匝而去。即以其日造六十房舍。复作施房饮食。其家眷属皆共供办。世间珍味无不必备。有破薪者有取水者作食者扫地者香汁洒地者敷座者散华者敷高座者

时舍卫城有长者名须达多。出三十万金钱与王舍城人年年来债。长者常出一由旬迎以设大馔。不复得出。须达多作是念。彼或遭王难水火盗贼人非人难故不迎耶。既至先到其舍。见其供办种种肴膳。问言。汝为婚烟节会为请王耶。答言。非婚姻节会亦不请王。又问。何故乃办奇妙饮食。答言。佛出于世有大威德。其诸弟子亦皆如是。我今请之故设此供。所以不获出相迎耳。须达多言。我亦闻有佛当出于世。号如来应供等正觉明行足善逝世间解无上调御丈夫天人师佛世尊。汝今所请为是佛耶为非佛耶。答言是佛。又问。今在何处。彼长者即偏露右肩。右膝着地右手指佛所在言。佛在彼处。须达多闻已欢喜踊跃。偏袒右肩遥向佛礼三反。称南无佛竟夜念佛。疲极得眠。其宿世善知识作神护之。神作是念。我当令此长者不经宿而得见佛。即令夜明。须达多谓日已出。起趣城门。城门自开。既出已门便自闭。忽然还闇。须达多怖惧念言。我向者将不狂耶。神知其念。即说偈言

  今是趣佛时　　若举一步者
  利重千金施　　象马所不及

又语。莫恐莫怖前进。前进须臾见佛。须达多闻已恐怖即除即便前进遥见世尊仪则殊特犹若金山。世尊见之赞言。善来须达多。须达多闻之欢喜。佛乃知我父母所作名字。头面礼足却坐一面。佛为说种种妙法乃至苦集尽道。即于座上得法眼净。见法得果已受三归五戒。白佛言。世尊。愿佛及僧受我舍卫城夏安居。如是三请。佛皆默然。至第四请乃告之言。若住处无有愦闹寂寞无声。诸佛乃当于中安居。长者白佛。已解世尊。愿差一比丘为经营之。佛问言。汝今乐谁。答言。欲得舍利弗。佛即语舍利弗。汝便可往为经营之。舍利弗受教而去。时前长者晨朝自往白佛。食具已办唯圣知时。佛与比丘僧着衣持钵前后围绕。往到其舍次第而坐。长者手自下食。食毕行水。白佛言。世尊。我以此园房舍施四方僧。佛默然受。知佛受已取小床于佛前坐。佛便为说随喜咒愿偈

  为遮风寒热　　及障诸恶兽
  蔽防雨露尘　　亦除蚊虻患
  以施持戒人　　坐禅诵说法
  若闻解其义　　得尽诸苦源

佛说偈已。更说种种妙法。示教利喜已便还所住

于是须达长者。将舍利弗还舍卫城。所经聚落处处唱言。佛出于世有大威德。其诸弟子亦复如是。我已请之于舍卫城安居。汝等皆当共安顿处修治道路及诸桥梁预办供俱以待世尊。彼诸人等闻其此唱。知佛世尊当从此过。皆大欢喜敬承其语。须达长者既到舍卫作是念。何处极好堪作精舍。唯此城童子祇林。园果美茂其水清洁。流泉浴池香华悉备。当买作之。念已往到其所。语言。我欲买园宁能见与不。答言。若能以金钱布地令无空缺然后相与。须达便以金钱布地。只言。我说此譬不欲相与。须达复言。说此为价岂得中悔。共诤纷纭遂便彻官。官即依法断与须达。只问须达。何故不惜金宝而买此园。须达答言。佛出于世有大威德。其诸弟子亦复如是。我已请之于此安居。是以倾竭无所爱惜。只复言。若听我更作园名名为祇园精舍者当以相与。须达言善。即令人出金钱布地。量树处所皆补令满。舍利弗然后以绳量度。作经行处讲堂温室食厨浴屋及诸房舍。皆使得宜。时诸房舍泥治不密。风尘蛇鼠坏僧卧具恼诸比丘。以是白佛。佛言。听表里及仰泥。僧应畜斧凿刀锯铧锹梯橙泥墁种种作屋之具。亦听垩洒画之作窗户扇钩锁作丘钩。不听如刀柄带着腰中。犯者突吉罗。有诸比丘执作尘土污身须浴。佛言听浴。浴处有泥。佛言。听塼砌地安床板。有诸比丘于冢间得敷具绳床不敢取。佛言听取。若大应截。时王舍舍卫二城中间有一住处。诸居士以施诸比丘无有住者。佛言。听诸白衣请摩摩谛留住护视供给所须。时诸住处无有篱障。牛马唐突坏经行处。佛言。听周围作篱掘堑。牛马犹故得入。佛言。听种刺棘作援。牛马犹得唐突。佛言。听筑墙若累塼墼草瓦覆上。听作门屋。亦听重作。听作两扇。有诸比丘于房内嚼杨枝洗手面及洗脚湿地坏僧卧具。佛言不应尔。有诸老病比丘寒时不能出洗。佛言。听用澡盘及盆承水。有房舍患尘起。佛言。应泥泥地以十种衣随一一衣敷上。有诸下座比丘先洗脚上座后来洗脚未竟驱令去。佛言。若下座先已洗应听竟。有诸比丘露处经行。雨时渍衣以废经行。佛言。听作步廊。有诸比丘庭中行雨时坏地污脚。佛言。听累塼石作阶道。有诸住处无水。佛言。听掘井若作净池。诸比丘欲作卧褥敷床上。佛言。听以十种衣随一一衣作用羊毛驼毛劫贝华乃至软草贮之。诸比丘作褥大厚。佛言。极厚听至八指。听僧作四方僧作及私作。僧敷具坏不知云何。佛言。应差人补浣

时诸比丘日日分僧卧具。佛言。不应尔。听春末日分卧具。夏初日结安居时。六群比丘选择好房好卧具住。佛言。不应尔。应白二羯磨差一比丘作分卧具人。所差比丘应题卧具识在何处房。随上座次分。若有长好者。上座须应与。若不须次下随坐随与。若有后来比丘随大小以次安之。自下展转就于下房。若下座无房则已。诸比丘欲作新绳床木床佛言听作。若无巧师。比丘能自作亦听。听十种缕一一缕作绳。有诸比丘欲贮绳床。佛言听贮。有诸比丘绳床上行立绳断。佛言不应行立绳床上。有诸比丘短小。欲于架上取衣举衣不及。佛言。听系念在前立绳床髀上取之。有诸比丘尼坐贮绳床上月水污不净烂坏。佛言。比丘尼不应坐贮绳床上。有诸小沙弥住贮绳床上失溺不净烂坏。佛言。小沙弥亦不应住贮绳床上。有诸比丘在高床上受经问义。佛言。受经问义皆应在下处坐。诸比丘住处庭中生草。佛言。听使净人知。房中尘土污床卧具。佛言。听随意作拂拂之。大会时诸比丘来多房舍大而少无有住处。佛言。于房中次第敷卧具足使容身满而止。若欲以衣遮前。听各各遮。若足者善。若不足外有空处听作庵屋。旧住比丘应为作之。既作庵屋过大会已。为火所烧延及住处。佛言。过大会已应坏而去。若旧住比丘惜不听坏者。客比丘但嘱旧住比丘而去。大雨时诸比丘无集聚处。佛言。听作大堂。寒时诸比丘聚集患寒。佛言。听作温室。时舍利弗为毗舍佉母经营作新大堂。彼持谷米来施四方僧。诸比丘不敢食。佛言。若为四方僧作时听随意食。有诸比丘乞食还施四方僧不知谁应食。佛言。为四方僧作者得食。有房舍破坏诸比丘不治。佛言。应劝化白二羯磨与道俗欲治者令治。一比丘唱言。大德僧听。某房故坏无人治。某甲欲治今僧与令治。若僧时到僧忍听。白如是。大德僧听。某房故坏。乃至今僧与令治。谁诸长老忍默然若不忍者说。僧与某甲故坏房治竟。僧忍默然故。是事如是持。若欲题名是某甲檀越房听题之。卧具亦如是。有一住处大水所渍。诸比丘各各举所住房卧具。无比丘住房无人举水[漂*寸]渍烂。后时房主檀越见嗔呵诸比丘言。云何独使我房卧具为水渍烂佛言。若有水火时。应大声唱打揵捶令一切僧尽共相助举。若有一人不相助举得突吉罗罪

时罗睺罗至那罗聚落。为一优婆塞深所敬信。为起房。作房竟。罗睺罗有小缘事游行人间。时阿难往彼聚落。彼优婆塞即复以房施阿难。罗睺罗还令阿难出。阿难言。先虽施汝。汝行后更以施我。便是我房。于是俱至彼优婆塞所问言。定是谁房。答言。我虽先施罗睺罗。罗睺罗舍行去。我于后时更施阿难。应是阿难房。诸比丘以是白佛。佛以是事集比丘僧。告诸比丘。此优婆塞不但今世昔亦曾尔。诸比丘又问。其事云何。佛言。过去世时有王名婆楼。其国界有二仙人。一名罗睺罗常好坐禅。一名阿难多闻无畏。彼王先见罗睺罗甚敬重之为其作房。作竟出行人间。阿难后来王亦重之。便以先所作房施之罗睺罗行还。令阿难出云是我房。阿难亦如上言是我房。共至王所问言。定是谁房。答言。我虽先施罗睺罗。罗睺罗舍行去。我于后更施阿难应是阿难房。尔时诸天龙鬼神皆作是言。此王非法。云何先以房施罗睺罗。后夺以施阿难。我今当坏其眷属。即共往王宫以石打掷杀王眷属。佛因是事而说偈言

  王施无前后　　仙人共诤之
  致使鬼神忿　　自招灭眷属
  若随爱行事　　智者所不誉
  以是应舍爱　　欢喜随义说

佛言。彼罗睺罗仙人者今罗睺罗是。阿难仙人者今阿难是。国王者今优婆塞是。告诸比丘。从今不听受他先施房。犯者突吉罗

时佛与大比丘僧千二百五十人俱。于拘萨罗国游行人间。向讫罗讫列邑。彼有五比丘旧住。闻佛与大众当来。共议言。彼众中有舍利弗目连必恼我等。我等宁可分此住处房舍卧具园果之属以为五分各为私有。议已便分。佛众既至。诸比丘往语言。汝等开房敷卧具我等须住。五比丘言。佛是法主当开第一房令住。余处我等已分尽。是私物不复属僧。自可于聚落中随知识求其所安。时舍利弗目连无有住处便依佛檐下宿。明日佛以是事集比丘僧。告诸比丘。四方僧有五种物。不可护不可卖不可分。何谓五。一住处地二房舍三须用物四果树五华果。一切沙门释子比丘皆有其分。若护若卖若分皆犯偷罗遮罪。彼五比丘所分处。于后四方僧来集复共分之。后更有客比丘来语言。为我开房当于中住。先来诸比丘言。我等于四方来是我等分。已共分之不复属汝。汝可往聚落中更求所安。后来比丘便往聚落中求住。诸白衣言。大德。彼有僧房何不住中而来此为。诸比丘便还向僧房。比尔已闇于道中为虎所害。诸比丘以是白佛。佛以是事集比丘僧。告诸比丘。我先不说四方僧有五种物不可护不可卖不可分耶。云何护僧住处不与后来比丘乃使为虎所害。种种呵责已复言。若护若卖若分四方僧物皆偷罗遮。有诸比丘住海岸边。材木难得无可作屋。彼多有大鱼骨欲取作之。以是白佛。佛言。听作。诸比丘患鱼骨臭。佛言。听以香泥泥之。有诸比丘经营作僧住处。作竟客比丘来是上座驱令出住其房中。彼嗔恚言。我经营辛苦而反不得安住。以是白佛。佛言。听经营主随意所乐住。诸比丘便长与之。以是白佛。佛言。应量其功夫多少。极多听至十二年住。应白二羯磨与之。一比丘唱言。大德僧听。此某甲比丘作经营主。僧今与随所乐房若干年住。若僧时到僧忍听。白如是。大德僧听。此某甲比丘作经营住。僧今与随所乐房若干年住。谁诸长老忍默然若不忍者说。僧与某甲比丘随所乐房若干年住竟。僧忍默然故是事如是持。有诸比丘作木床绳床置房中。或泥地或小小治护。便求随意住。佛言不应求。若治房功夫极少三分之一。听从僧求随意住

五分律卷第二十五五分律卷第二十六(弥沙塞)

        宋罽宾三藏佛陀什共竺道生等译

    第五分杂法

佛在王舍城。尔时诸比丘与白衣共器食手相触数数洗。诸比丘以是白佛。佛言。不应与白衣共器食。有比丘往亲里家。亲里言。我等非他亦非不净何不共食。诸比丘以是白佛。佛言。听系念在前共食。但莫令手相触。有比丘共白衣食器小手相触。以是白佛。佛言。听左手捉器而食。诸比丘食时相礼。僧食时歠粥时啖果时。经行时不着三衣时。闇时不共语时礼。相嗔于屏处礼。诸比丘以是白佛。佛言。此时皆不应礼。犯者突吉罗。又有五种不应礼。呵责羯磨驱出羯磨依止羯磨举罪羯磨下意羯磨。复有五种不应礼。被举不共语举本言治比丘尼沙弥。复有五种不应礼。狂心散乱心病坏心白衣外道。复有五种不应礼。别住应行摩那埵行摩那埵本日阿浮呵那。有五种应礼。佛辟支佛如法上座和尚阿阇梨。时诸比丘养发令长。心不乐道。有反俗作外道者。诸白衣讥呵言。我等白衣养发。沙门释子亦复如是。有何等异。但着坏色割截衣而已耳。诸比丘以是白佛。佛言。不应养发。犯者突吉罗。诸比丘于作食处及讲堂温室中剃发。以是白佛。佛言。不应尔。若老病不堪寒听在温室中。时诸比丘随次剃发。以是白佛。佛言。不须随次。若有急事听先剃若无急事先洗者先剃。有诸比丘于庭中处处剃发不扫除。以是白佛。佛言。应在一处剃。剃已扫除。着水中火中若埋之。若无剃发师。比丘能剃者亦听。听畜剃刀。有诸比丘鼻中毛长。佛言。听畜镊拔之。诸比丘便以金银作镊佛言不应尔。听用铜铁牙角竹木除漆树。有诸比丘耳中物塞。佛言。听畜挑耳物余亦如上。有诸比丘食入齿间以致口臭。佛言。听畜擿齿物余亦如上。时瓶沙王作是思惟。我未以何物施僧。遍思皆施。唯未施擿齿物。便作满车。施诸比丘因作食供。诸比丘不敢受。以是白佛。佛言皆听受

佛在苏摩国。自作钵坯以为后式。令陶师烧。陶师便多作合烧。开窖口视皆成金钵。惧怖言。此是大沙门神力。若王闻者必当谓我多有金宝。便取埋藏。佛复作令烧。皆成银钵。亦怖惧埋藏。佛复作令烧。乃成铜钵。色青好如阎浮树。与诸比丘。诸比丘不敢受。佛言听畜。有比丘钵破无钵游行。佛言应更求钵。若能自作听作。有诸比丘烧钵色赤。佛言应熏。有诸比丘畜金银七宝牙铜石木钵。诸居士讥呵言。此诸比丘如王如大臣。常说少欲知足。而今畜此好钵。诸比丘以是白佛。佛以是事集比丘僧。告诸比丘。从今不听畜上诸钵。若畜金银乃至石钵皆突吉罗。若畜木钵偷兰遮。时有婆罗门名优柯罗。有一女。常用白铜钵食。彼女出家后犹用先器乞食。诸居士讥呵言。沙门释子用铜钵。与外道不可分别。诸比丘以是白佛。佛言。不听用外道铜钵。犯者突吉罗。听用三种钵。铁钵瓦钵苏摩钵。时毗舍离诸离车得栴檀钵。共议。此钵应与谁。或言应与世尊。或言应与萨遮尼犍子。多人欲与世尊。以少从多便盛满钵白石蜜欢喜丸奉上世尊。白言。我等共得此钵以奉世尊。唯愿哀受。佛受欢喜丸以钵还之。语言。此是外道钵。佛所不畜。复共议言。我等以钵奉上世尊。世尊不受。我今宁可用施众僧。议已即复持钵往至僧坊施诸比丘。诸比丘不敢受。以是事白佛。佛言。听受破作香用。后诸离车复得牛头栴檀钵着高标头唱言。若有神力能取者与之。时宾头卢语目连言。世尊说汝神足第一。何不取之。答言。汝亦有神足便可往取。即便取之以施于僧。诸比丘不知云何。以是白佛。佛言。听受破作香用。时四大声闻迦叶目连阿那律宾头卢共议。今王舍城有不信乐佛法僧者。我等当共令其信乐。作是议已。遍观近远。唯见跋提长者及其姊。不信乐佛法僧。三声闻言。能化跋提不。宾头卢言能化其姊。彼长者作七重门。有三部伎。若欲食时七门皆闭。一食作一部伎。阿那律于其食时在其前乞食长者问言。从何处入。答言。从门入。长者即问守门者。汝何以听乞人入。答言。门闭如常不见人入。长者便以一片麻饼着其钵中。语言出去。汝若有物当作此食。阿那律得已即去。于后食时。迦叶复在前乞。问答如前。后问守门者。汝何故再听乞人突入我门。答言。门闭如常不见人入。长者复以一片鱼着其钵中。语言出去。汝若有物当作此食。迦叶去后。其妇问言。于意云何。谓此比丘不能得食而来乞耶。答言如是。妇言识前来比丘不。答言不识。妇言。彼名阿那律。释种之子舍三时殿五欲之乐出家学道。又问识后来比丘不。答言不识。妇言。彼是毕波罗延摩纳大姓之子。舍九百九十田宅犁牛出家学道。愍念君故来乞食耳。长者闻妇语已内怀敬伏。于是目连飞在空中为其说法示教利喜。乃至即于座上。远尘离垢得法眼净。见法得果已即受三归五戒。自是已后常供给比丘比丘尼优婆塞优婆夷及诸外道。时三声闻语宾头卢言。我等已化跋提令其信乐。汝今宜行次化其姊。于是宾头卢晨朝着衣持钵入城乞食。次到其舍。时长者姊手自作[麩-夫+并]。忽见宾头卢便低头闭目。宾头卢亦一心视钵。便语言。决不与汝。一心视钵欲以何为。宾头卢便身中烟出。复语言。举身烟出亦不与汝。宾头卢便举身火燃复语言。举身火燃亦不与汝。宾头卢便飞腾虚空。复语言。飞腾虚空亦不与汝。宾头卢便倒悬空中。复语言。倒悬空中亦不与汝。宾头卢作是念。世尊不听我等强从人乞便出去。去王舍城不远有大石。宾头卢坐其上合石飞入王舍城。城中人见皆大怖惧。恐石落地莫不驰走。至长者姊家上。便住不去。彼见已即大恐怖。心惊毛竖叉手白言。愿施我命。以石着本处我当与食。宾头卢便持石还着先处至其前住。长者姊作是念。我不能以大饼施。当更作小者与之更作小丸转反成大。如是三反转大于前。乃作念言。我欲作小皆反成大。我今便可趣与一饼。即以一饼授与。诸饼相连至于饼器亦相连着。以手捉器手亦着之。便语宾头卢言。汝若须饼尽以相与。器亦不惜何须我为。而令我手着器不离。答言。我不须饼及器亦不须汝。我等四人共议。度汝及汝弟三人。已化汝弟。我应度汝。所以尔耳。问言。今欲令我何所施作。答言。姊妹可戴此[麩-夫+并]随我施佛及僧。即便戴[麩-夫+并]随宾头卢。宾头卢即化导皆经他门使人见之。既至佛所。手自供佛及千二百五十比丘。皆悉饱满犹故不尽。持往白佛。我此少饼供佛及千二百五十比丘。皆悉饱满犹故不尽。今当持此着于何处。佛言。可着无生草地若无虫水中。彼女人便持着无虫水中。水沸作声如以热铁投于小水。便生恐怖衣毛皆竖。还至佛所头面礼足却坐一面。佛为说种种妙法。乃至得法眼净。受三归五戒。供给四众求道如弟无异。诸长老比丘以是白佛。佛以是事集比丘僧。问宾头卢。汝实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。从今不听现神足。若现突吉罗。时瓶沙王有庵罗果园。三时茂好。长以华果施诸比丘随所须用。诸比丘便食其果。前食后食无时不啖。或满钵持去。或啖半掷地。后时邻国遣使。使白王言。我闻王有庵罗果园三时茂盛。愿见其果。王便敕取。时诸比丘啖之都尽。以是白王。王左右诸臣共讥呵言。沙门释子无有厌足。王虽无惜受者自应筹量。云何一园之果都共啖尽诸长老比丘闻。以是白佛。佛以是事集比丘僧。问诸比丘。汝等实尔不。答言。实尔世尊。佛种种呵责已告诸比丘。从今不听食未净果。若食突吉罗。有一居士请僧啖果。比丘使人一一净之。日遂过中不得复食。便讥呵言。此诸沙门犹如小儿。使人一一净果不复及中。我今当奈此诸果何。以是白佛。佛言。有五种子。根种子接种子节种子果种子子种子。若食果应作沙门法五种净。火净刀净鸟净伤净未成种净。若食根亦应作沙门法五种净。剥净截净破净洗净火净。若食茎叶应作沙门法三种净。刀净火净洗净。若作净时应作总净。于一聚一器中若净一。名为总净。有一比丘欲燃浴室中火破薪。蛇从木孔中出螫脚即死。诸比丘以是白佛。佛言。彼比丘不知八种蛇。名不慈心向。又不说咒。为蛇所害。八种蛇者。提楼赖吒蛇。怛车蛇。伊罗漫蛇。舍婆子蛇。甘摩罗阿湿波罗呵蛇。毗楼罗阿叉蛇。瞿昙蛇。难陀跋难陀蛇。咒蛇者

  我慈诸龙王　　天上及世间
  以我此慈心　　得灭诸恚毒
  我以智慧力　　用之杀此毒
  味毒无味毒　　破灭入地去

佛言。若彼比丘以此咒自护者。不为毒蛇之所伤杀。复有比丘被蛇所螫。诸比丘白佛。佛言。汝以此咒咒彼令得安隐。受教往咒彼即得差。复有诸比丘处处为蛇所螫。以是白佛。佛言。听作咒术随宜治之。时诸比丘食多美食以增诸病。耆域晨朝往至佛所。头面礼足白佛言。世尊。今诸比丘食多美食以增诸病。愿听浴室中浴除其此患。佛以是事集比丘僧。以耆域语告诸比丘。从今听诸比丘作浴室为除病故于中浴。有诸比丘裸形浴更相揩摩。又裸形出浴处。诸白衣讥呵言。此诸沙门皆如尼揵无有风法。诸比丘以是白佛。佛以是事集比丘僧。呵责已告诸比丘。从今听着浴衣。不听裸形浴裸形相揩。一一皆突吉罗。有诸比丘浴时出外以背揩壁树木还入水灌伤破其身。佛言不应尔。听用蒲桃皮摩楼皮澡豆等诸去垢物。诸比丘随知识与澡豆等。佛言应等与。佛在舍卫城。尔时跋难陀反披拘摄于闇中。作四脚行怖诸比丘。诸比丘以是白佛。佛言不应尔。若反披拘摄作四脚行皆突吉罗。诸比丘房内患热欲反披拘摄。佛言房内听。有诸比丘眠时无枕。佛言。听作枕。有诸比丘患虱。佛言听拾去。诸比丘拾着房内还人衣中。佛言。听拾着房外。诸比丘雨时拾着水中。佛言。应拾着弊物中慈心举之。有诸比丘患蚤。佛言。听敷物着地扫去。若在荐席中听日曝去。有诸比丘患壁虱。佛言。听除却密泥。有诸老病比丘患寒欲于房内燃火。佛言寒时听燃。诸比丘燃火烧坏地敷熏屋。佛言。听作火炉在屋外燃。烟尽将入。诸比丘不知以何物作。佛言。听用铜铁泥石作之。听僧四方僧私畜。又听因地作火炉。诸比丘过中用钵饮。佛言。过中不应用钵饮。听别作饮器用铜铁瓦作。有一比丘于德叉尸罗国夏安居竟。到舍卫祇洹至佛所。头面礼足白佛言。如此国歠粥。彼国饮糗浆。愿听诸比丘晨朝饮糗浆。佛言听饮。诸比丘饮时须盐。佛言听畜盐。听僧四方僧私畜。听作抄盐物。诸比丘便作众生形或作人手持抄盐。佛言。不听作此诸形。时诸白衣以盘器奠食与诸比丘。诸比丘不敢受。便讥呵言。沙门释子不堪受供养。以是白佛。佛言听受。有诸比丘于钵中歠粥苦热不可捉。佛言。听别作歠粥器。诸比丘擎食患重。佛言听安机。诸比丘便作种种形脚机。佛言不听作。诸比丘至白衣舍。白衣以种种形脚机下食。诸比丘不敢食。佛言白衣家听受。但不听自畜。诸比丘须犍恣佛言听畜。用铜铁瓦石作。有诸白衣持粥与诸比丘。诸比丘不知着何处分之。佛言。听作盆杅安环耳。行粥时应问。别有病人粥不。若无应先与病人。时毗舍佉母欲令众僧于住处煮粥。佛言听。诸比丘不知着米处。佛言。应着[竺-二+發]席上。米中有谷不知云何。佛言。听畜臼杵令净人簸之。不知以何物簸米。佛言。听畜簸箕。诸比丘须釜。佛言听畜。用铜铁瓦石作。诸比丘须杓。佛言亦听作。除漆树余木皆听用。有病比丘欲得美粥。佛言。听净人为作。若无净人。听比丘净洗烧器着水。令净人洮豆米着中。比丘然后燃火。粥熟更从净人受持与病人。诸比丘米多无著处。佛言。听细泥一房净扫地以安之。米尽诸比丘住闻米臭。佛言。听香泥涂地

佛在拘萨罗国游行人间。与大比丘千二百五十人俱。到都夷婆罗门聚落。在道侧娑罗树下敷座坐息。佛便微笑。阿难作是念。诸佛不以无缘而笑。今佛微笑必有因缘。即偏露右肩胡跪问佛。佛言。阿难过去世时有王名禁寐。有一女生时自然着金华鬘。即集诸臣议为作字。皆言应问相师婆罗门。即敕相师皆集令为作字。相师言。此女生着自然金华鬘。应字为摩梨尼。即用字之。王甚爱重。访问国中与同日生女取给左右。时国内有五百女人与同日生。皆录其名以充驱使。年既长大。王所供养五百婆罗门。敕令供养。告言。汝当如我。日作五百釜羹随彼所。好而供养之。女即如敕供养诸婆罗门。食竟辄与五百女人乘四马车游戏园观。从园至园从观至观日日常尔。时迦叶佛于一园中住。御者至佛所住园。辄回车不入。女问御者。我于国界无园不入。汝何故常避此园。答言。此中有一秃头沙门名曰迦叶。不宜见之是故不入。女言。沙门迦叶何豫人事。便可回车入此园观。即回车入尽通车处。步进园中。遥见迦叶佛容颜殊特犹若金山。见已发欢喜心。前至佛所头面礼足却住一面。佛为说种种妙法示教利喜。乃至见法得果已受三归五戒。从坐起礼佛足右绕而去。去不久作是念。我常以五百釜羹日再供养五百婆罗门。此非福田不应受施。宁可更作极美饮食供养迦叶世尊。念已敕作日送供养。时诸婆罗门闻摩梨尼已作迦叶佛弟子更以上馔供养迦叶生嫉姤心作是议。我等当作方便共杀此女。于时禁寐王夜得十一种梦。梦见树长四指便生华。梦见华即成果。梦见犊子耕大牛住视。梦见三釜并煮饭而两边釜饭各跳相入不堕中央。梦见骆驼两头食草。梦见马母反饮驹乳。梦见金钵于空中行。梦见野狐尿金钵中。梦见猕猴坐金床上。梦见卖牛头栴檀犹如腐草。梦见水中央浊四边清净。旦集诸群臣广说上梦而访问之。为是何梦。众臣言。应问相师婆罗门。即召问之。诸婆罗门作是念。我等志杀此女今得之矣。便语王言。此梦不吉或当失国或以命终。王又问。颇有方便免斯灾乎。答言有。而是王所爱念必不能用。王言但说。相师言。王某甲象某甲马某甲大臣某甲大婆罗门。将五百特牛五百水牛五百牸犊五百特犊五百羖羊五百犍羊王女摩梨尼及其五百眷属。却后七日于四衢道中。杀以祠天此灾可灭。若不作是祸不可免。王闻信之即敕令办。便呼其女具以事语。听六日内随意所愿。女白王言。甚不惜死。愿第一日与城中人民男女大小到迦叶佛所。王即听之。于是悉召城内前后围绕往到迦叶所。佛为说种种妙法示教利喜。乃至见法得果受三归五戒。愿第二日与王众臣共往佛所。愿第三日与诸王子共往佛所。愿第四日与诸王女共往佛所。愿第五日与王夫人婇女共往佛所。愿第六日与王共往佛所。王悉听之。皆见法得果。受三归五戒亦如上说。王得果已以十一种梦问迦叶佛。此梦有何报应。佛言。此十一梦乃为当来不为今也。梦见小树生华者。于当来世有佛。出于百岁人中。名释迦牟尼如来应供等正觉。尔时人年三十便已头白。梦见华即成果者。尔时二十岁人便已生儿。梦见犊子耕大牛住视者。尔时人儿领家事父母不得自在。梦见三釜并煮饭两边釜饭各跳相入不堕中央釜者。尔时富者更相惠施而贫者不得。梦见骆驼两头食草者。尔时王有群臣既食王禄复取民物。梦见马母反饮驹乳者。尔时母嫁女已反从求食。梦见金钵于虚空中行者。尔时雨不时节亦不周普。梦见野狐尿金钵中者。尔时人民唯富是婚不择本姓。梦见猕猴坐金床上者。尔时国王用非法治政暴虐无道。梦见牛头栴檀卖与腐草同价者。尔时释种沙门贪利养故与白衣说法。梦见水中央浊四边清者。尔时佛法中国先灭边国反盛。佛言。王十一梦所为如此。于大王身无有不祥。王即于座上敕诸群臣。所欲祠天之物今悉施以无畏。吾从今宁自失命不故杀生。况杀人乎。不故伤虫蚁。况女及诸人等乎。佛告阿难。彼迦叶佛般泥洹后。其王为佛起金银塔。纵广半由旬高一由旬。累金银墼一一相间。今犹在地中。佛即出塔示诸四众。迦叶佛全身舍利俨然如本。佛因此事取一抟泥。而说偈言

  虽得阎浮檀　　百千金宝利
  不如一团泥　　为佛起塔庙

示已还复故处。佛便以四抟泥泥塔没处。千二百五十比丘亦各上泥四抟。于是诸比丘欲于所泥处为迦叶佛起塔。佛言听起。即便共起。是时于阎浮提地上最初起塔。其后诸比丘欲为阿罗汉诸声闻辟支佛起塔。佛言。听有四种人应起塔。如来圣弟子辟支佛转轮圣王。诸比丘欲作露塔屋塔无壁塔。欲于内作龛像于外作栏楯。欲作承露盘。欲于塔前作铜铁石木柱上作象师子种种兽形。欲于塔左右种树。佛皆听之。时诸外道亦自作塔种种供养。众人见起信乐心。诸比丘作是念。佛若听我等种种供养塔者。众人亦当起信乐心。佛亦听之。诸比丘便自歌舞以供养塔。诸白衣讥呵言。白衣歌舞。沙门释子亦复如是。与我何异。诸比丘以是白佛。佛言。比丘不应自歌舞供养塔。听使人为之。听比丘自赞叹佛华香幡盖供养于塔。诸比丘乞食时得华不敢受。诸白衣讥呵言。沙门释子不堪受供养。又不欲供养塔。诸比丘以是白佛。佛言。听受。不知着何处。佛言。听作三种囊。花囊食囊漉水囊。有诸比丘自行采华。从一聚落至一聚落。出聚落外为贼所剥。诸白衣讥呵言。此诸沙门正似结华鬘师若华鬘弟子。佛言。不听出聚落外采华。诸比丘以缦连花供养。白衣所呵亦如上说。佛言。不应以缦连但散用供养。若有萎叶其外青者。皆听擿去手三捼茎华自开好。佛在舍卫城。尔时诸比丘养爪令长。生染着心不乐修梵行。遂有反俗作外道者。诸白衣讥呵。此诸沙门如受欲人。修饰手爪无厌离心。有一比丘长爪入聚落乞食。一女人见呼共行欲。比丘言。我出家人不作此事。女人言。若不从我我当与汝作恶名声。便以爪自攫破衣伤肉。大唤言。比丘强牵挽我。我不从之。辄便攫我。破衣伤肉。众人来看。有信有不信。信者言。此比丘爪长必作此事。不信者言。此女人由来不良谤比丘耳。皆共讥呵。云何比丘畜此长爪。诸比丘以是白佛。佛言。不听养爪令长。犯者突吉罗。听畜截爪刀一头作挑耳物。有诸比丘染爪令赤。诸白衣讥呵。诸比丘以是白佛。佛言。不应尔。犯者突吉罗。时诸比丘为饰好故作衣。佛言。不听为饰好故作衣。犯者突吉罗。有一比丘守僧房。送食比丘来迟。缘树望之堕树折胁。佛言。不听上树。犯者突吉罗。有诸比丘小小因缘须上树。佛言。听上。不得上过人处。有诸比丘欲于高树头取枯枝为薪。佛言。听缘梯取。不得缘树。复有诸比丘。遇水火恶兽贼难欲上树不敢。遂为所困。佛言。如此诸难听任意上。有二比丘共道行。无漉水囊。渴欲饮水。见中有虫。一比丘饮。一比丘不饮而死。饮水比丘往至佛所。以事白佛。佛言。彼比丘有惭愧心。乃能守戒而死。从今不听无漉水囊行。犯者突吉罗。有诸比丘欲近处行无漉水囊便不敢去。佛言。听于半由旬内无漉水囊行。复有二比丘共道行。一比丘有漉水囊。一比丘无。不相借极渴乏。以是白佛。佛言。我先不制无漉水囊行不得过半由旬耶。若是无漉水囊。有衣角可漉水者听。欲行时心念用以漉水。亦听畜漉水筒。诸比丘便用金银宝作。佛言。不应尔。听用铜铁竹木瓦石作之。以十种家施衣细者漫口。不听用粪扫衣。犯者突吉罗。时舍利弗患风。有一呵梨勒果着床脚边。瞿伽离来。以是上座驱舍利弗。舍利弗即避之忘呵梨勒。瞿伽离见语诸比丘。世尊赞叹舍利弗少欲知足。而今藏积我等所无。舍利弗闻作是念。我今云何以此小事堕讥嫌中。便取弃之。诸比丘语言。大德风患所须。勿弃此药。可还取之。答言。以此小物乃使同梵行人致此嫌怪。我已弃之终不复取。诸比丘以是白佛。佛言。舍利弗不但今弃此药不肯复取。过去世时亦曾如是。乃往过去时有一黑蛇。螫一犊子。还入穴中。有一咒师。以羖羊咒。咒令出穴。不能令出。咒师便于犊子前燃火咒之。化成火蜂。入蛇穴中。烧螫黑蛇。蛇不堪痛然后出穴。羖羊以角抄着咒师前。咒师语言。汝还舐毒。不尔投此火中。黑蛇即说偈言

  我既吐此毒　　终不还收之
  若有死事至　　毕命不复回

于是遂不收毒自投火中。佛言。尔时黑蛇者舍利弗是。昔受如此死苦犹不收毒。况今更取所弃之药。从今听诸比丘畜药。六群比丘便多积聚药。诸白衣讥诃言。此诸沙门为欲作医为欲贩卖。自言小欲知足。而无厌已。诸比丘以是白佛。佛言。不应多畜药。听畜种种杂药各一阿陀罗。若有长病听随宜更畜。有诸比丘无刀用竹芦片割衣衣坏。佛言。听畜割截物刀。诸比丘便作大刀。贼来得以害比丘。佛言。不听作大刀。犯者突吉罗。听长一指一边作刃以木作柄除漆树。诸比丘得针不敢受。佛言。听受畜之。诸比丘便多畜。佛言。不应多畜。听畜三针。余者净施。时毗舍离阿[少/兔]耶住处下湿多蚊虻蒸热。诸比丘患之。佛言。听畜扇拂。诸比丘用马尾作拂杀虫。佛言。不听用马尾作拂。犯者突吉罗。有诸比丘以钵盛食着地翻之。佛言。听作钵支。用铜铁牙角瓦石竹木除漆树。乃至结草着下亦听。有诸比丘钵熏剥脱。佛言。应更熏。诸比丘与作人食不量多少虽多犹嗔。佛言。听畜斗斛升合。僧四方僧及私亦听畜。亦应有一储备。诸比丘雇作人酥油蜜石蜜不称与虽多犹嗔。佛言。听畜称亦如上。时诸比丘学书。诸白衣讥呵言。沙门释子何不勤读诵用学书为。诸比丘以是白佛。佛言。不听学书后诸比丘差会次不知书记随忘。佛言。听学书。但不听为好废业。诸比丘欲学咒咒蜂蛇等诸毒。佛言。听学。诸比丘畜田宅店肆。诸白衣讥呵。我等有妻子累故畜田宅店肆。诸比丘亦复如是。与我何异。诸比丘以是白佛。佛言。皆不听畜。犯者突吉罗。有诸白衣以田宅店肆布施僧。诸比丘不敢受。便复讥呵言。此诸比丘不堪受供养。以是白佛。佛言。听僧受。使净人知。有诸比丘往问讯富兰那迦叶末伽离等诸外道师。佛言。不应问讯。犯者突吉罗。诸比丘学种种卜。诸白衣讥呵言。沙门释子不能自净其见。何能知未然事。诸比丘以是白佛。佛言。不听。犯者突吉罗。诸比丘学迷人咒。佛言。不听。犯者偷兰遮。诸比丘学起死人咒。佛言。不听。犯者偷兰遮。诸比丘问卜相师欲自知吉凶。佛言不听。犯者突吉罗。诸比丘读诵外书。诸白衣见讥呵言。此沙门释子不信乐梵行。舍佛经戒读诵外书。诸比丘以是白佛。佛言。不听。有诸比丘与外道论不知羞耻。念言。佛听我等读诵外书者不致此耻。佛言。为伏外道听读外书。但不得随书生见。有诸比丘多畜小小铜鏂。诸白衣讥呵言。此沙门释子多畜此器与我何异。诸比丘以是白佛。佛言。不听多畜小小铜鏂。犯者突吉罗。有婆罗门兄弟二人诵阐陀鞞陀书。后于正法出家。闻诸比丘诵经不正讥呵言。诸大德久出家而不知男女语一语多语现在过去未来语长短音轻重音。乃作如此诵读佛经。比丘闻羞耻。二比丘往至佛所。具以白佛。佛言。听随国音读诵。但不得违失佛意。不听以佛语作外书语。犯者偷兰遮。有诸比丘不系下衣入聚落堕地露形。诸女人笑之羞惭。佛言。不听不系下衣入聚落。犯者突吉罗。听畜腰绳。诸比丘作腰绳太长绕腰四五匝。佛言。不听长。极可二三匝。诸比丘作腰绳太阔。佛言。听广极至四指狭不减一指。诸比丘以杂色綖作。佛言不听。听随用一色。有诸比丘着轻衣入聚落。风吹露形。诸女人笑羞耻。佛言。听作衣纽钩钩之。应用铜铁牙角竹木作钩除漆树。乃至作带带之。诸比丘一向着衣下易坏。佛言。听颠倒着衣上下皆安钩纽及带。有诸比丘诵咒时。不啖盐不眠床上。称言南无婆伽婆。生疑我将无随异见受余师法耶。以是白佛。佛言。神咒法尔。但莫随其见。尔时慈地比丘语庐夷力士子言。陀婆比丘与汝妇通。庐夷闻已即问陀婆。汝实尔不。陀婆不答。庐夷便言。陀婆犯欲羞耻无辞答我。诸比丘以是白佛。佛言。听与庐夷力士子作覆钵白二羯磨。一切不得复入其家。应一比丘唱言。大德僧听。庐夷力士子虚谤陀婆淫通其妇。僧今与作覆钵羯磨。一切不得往入其家。若僧时到僧忍听。白如是。大德僧听。庐夷力士子虚谤陀婆淫通其妇。僧今与作覆钵羯磨。一切不得往入其家。谁诸长老忍默然不忍者说。僧已与庐夷力士子作覆钵羯磨竟。僧忍默然故是事如是持。若僧与作覆钵羯磨。一切四众皆不得与来往语言。有诸比丘与诸优婆塞小小诤讼。便与作覆钵羯磨。佛言。不应以小小事便与白衣作覆钵羯磨。若成就八法乃应作之。若优婆塞于诸比丘前毁呰三宝及戒。欲不利诸比丘。与诸比丘作恶名声。欲夺比丘住处。犯比丘尼。是为八。阿难白衣时与庐夷亲厚。佛告阿难。汝往庐夷所语言。僧已与汝作覆钵羯磨。阿难受教往到其门。守门人白。阿难在外。彼言令入。阿难语言。我今不得复入汝门。庐夷闻之便疾出问。汝忽何故不入我门。答言。僧已与汝作覆钵羯磨。一切四众不得来往共汝语言庐夷言。若如汝语便是杀我闷绝倒地。阿难言。汝起往谢陀婆。僧当与汝解覆钵羯磨。庐夷即从地起往到佛所。头面礼足白佛言。我实不见陀婆与我妇通。慈地语我信其语耳。佛言。汝可辞谢陀婆。僧当与汝解覆钵羯磨。受教即往陀婆所头面礼足手捉其脚白言。我愚痴故信于人言诽谤大德。愿受我悔过。陀婆比丘即为受之。庐夷既辞谢已还到佛所。白言。我已辞谢陀婆比丘竟。佛告诸比丘。听僧白二羯磨为解之。庐夷力士子应至僧中偏袒右肩脱革屣一一礼僧足胡跪合掌作如是白。大德僧听。我庐夷力士子虚谤陀婆与我妇通。僧与我作覆钵羯磨。不听一切四众来往我家。我已辞谢陀婆竟。今正顺僧从僧乞解覆钵羯磨。愿僧慈愍故为我解之。如是三乞。应一比丘唱言。大德僧听。庐夷力士子虚谤陀婆淫通其妇。僧与作覆钵羯磨。不听一切四众来往共语。某已辞谢陀婆。从僧乞解覆钵羯磨。僧今与解。若僧时到僧忍听。白如是。大德僧听。庐夷力士子虚谤陀婆。乃至僧今与解。谁诸长老忍默然不忍者说。僧已与庐夷力士子解覆钵羯磨竟。僧忍默然故是事如是持。有诸优婆塞以小小嗔嫌比丘便不复敬信。佛言。优婆塞不应以小小事不敬信比丘。若比丘成就八法然后不应敬信。毁訾三宝及戒。欲不利诸优婆塞。与优婆塞作恶名声。欲夺优婆塞住处。以非法为正欺优婆塞。是为八。若优婆塞嗔比丘。比丘不应往其家。若聚落皆嗔比丘。比丘不应往此聚落

时跋难陀捉盖着革屣络囊盛钵挂杖担行。有优婆塞共一外道弟子在后。遥见谓是外道。语外道弟子言。看汝师在路行无有仪威。外道弟子言。汝等见无威仪者皆谓是外道。而今此人实是释子。二人共诤遂便共赌。逐及问之。果是释子。优婆塞既输所赌又大惭愧。诸比丘以是白佛。佛言。不听作此仪法在道路行。犯者突吉罗。有诸比丘在路行为塔得盖伞不敢受。诸居士讥呵言。此沙门释子不欲供养塔。白佛。佛言。听受。但不得如外道威仪持行。有诸老病比丘须拄杖络囊盛钵乞食。佛言。听从僧乞。彼比丘应至僧中乞言。大德僧听。我某甲比丘老病。今从僧乞听拄杖络囊盛钵乞食。愿僧听之。如是三乞。僧应筹量应与不应与。若实不老病不应与。若实老病应白二羯磨与之。一比丘唱言。大德僧听。此某甲比丘老病。今从僧乞听拄杖络囊盛钵乞食。僧今听之。若僧时到僧忍听。白如是。大德僧听。此某甲比丘老病。乃至僧今听之。谁诸长老忍默然不忍者说。僧已听某甲比丘老病拄杖络囊盛钵乞食竟。僧忍默然故。是事如是持。有诸比丘欲畜杖络囊。佛言。应作僧所羯磨人有而畜杖络囊。若有亲里比丘尼亦听作彼有而畜。有诸比丘触雨乞食坏衣色。佛言。听捉盖至门放地乞食得已还捉持去。有诸比丘持盖乞食还着温室讲堂食处余霤湿地成泥佛言。听作屋安之勿令相妨。有诸比丘欲私作盖。佛言。听作。方圆随意木作头子除漆树。若叶若草作覆。亦听十种衣一一衣覆之。僧四方僧及私皆听畜。亦听长一以为备豫。有一比丘患眼。佛言。听着眼药灌鼻以油酥摩顶上以盐酥摩脚下。诸比丘不知用何物作灌鼻筒。佛言。除漆树余竹木铜铁牙角作之。有一比丘名瞿夷食后辄齝。诸比丘见疑犯非时食。以是白佛。佛言。诸比丘。此比丘前五百世常生牛中。余报生人间。凡有所食非齝不消。从今如此等比非时齝无犯。有诸比丘或依止僧住。或依止四方僧住。或依止塔住。无人教诫愚痴无知不能学戒。以是白佛。佛言不听依止僧四方僧及塔住。犯者皆突吉罗。听依止上座及如法比丘能教诫者。时诸比丘同覆眠更相触身生染着心不乐修梵行。佛言。不听同覆眠。犯者突吉罗。若无衣覆者。听异衬身衣上得同覆。若住处迮不相识。听同床坐。皆不得眠。若眠突吉罗。有一阿练若处野火欲至。不知云何。以是白佛。佛言。汝往灭之。受教往灭。不能令灭。还白佛。佛言。可以我名语火神言。世尊欲令汝灭。受教往语火即灭。还白佛。佛言。此火神不但今世闻我名火便灭。过去世时海中有洲。于七岁中常为火所烧。彼洲上丛草中有雉生一鶵。父母见火欲至便舍而去。其鶵于后帐舒翅脚示火神。说偈言

  有脚未能行　　有翅未能飞
  父母见舍去　　唯愿活我命

火神即以偈答

  卵生非所求　　而今从吾乞
  我今当施汝　　四面各一寻

佛言。尔时雉鶵者则我身是。火神者今火神是。昔已为我灭火。今复为我灭之。若野火来时。应打揵捶若唱令。僧同集使净人刈左右草以火逆烧水土浇坋湿衣扑灭。有诸住处塔中幡盖盈长弃于庭中纵横践蹋。诸白衣讥呵言。此诸沙门不惜他物毁败供养非沙门法。诸比丘以是白佛。佛言。除佛辟支佛塔余塔。长物听作四方僧用。若此塔后须取四方僧物还之。时诸比丘啖生熟蒜。前食后食无时不啖。亦空啖之房舍臭处。诸白衣入房闻臭讥呵言。此诸沙门住处蒜臭犹如庖厨。诸比丘以是白佛。佛言。不听无因缘啖蒜。若有因缘啖时。不得在诸比丘上风行立。有一比丘以小因缘啖蒜。如来说法不敢往听。佛问。何故不来听法。答言。世尊。不听啖蒜在诸比丘上风行立。是以不敢。佛种种呵责彼比丘。汝愚痴人所作非法。贪食臭秽失于无量法味之利。呵已告诸比丘。从今不听以小因缘啖蒜。犯者突吉罗。啖蒜比丘应正顺诸比丘。正顺者。七日不得入温室讲堂食堂浴室厕上他房聚落塔边过。七日后。卧具应抖擞者抖擞应浣者浣。应晒者晒。应香熏者香熏。洒扫房中遍泥其内。自浣衣服洗浴身体然后入。时诸比丘畜大铜鏂。诸白衣见问言。此是谁器。有人答言。是诸比丘许。便讥呵言。此沙门如王大臣。何用畜此大铜鏂为。诸比丘以是白佛。佛言。从今不听畜大铜鏂。若畜一升以上突吉罗。时诸比丘处处小便臭处不净。诸白衣讥呵言。此沙门释子无有威仪法。小便无有常处。臭处不净。有一比丘在不应小便处小便。鬼神捉其男根牵至屏处。语言。大德应在此处小便。诸比丘以是白佛。佛言。不听漫小便。应屏处作处所。犯者突吉罗。有诸客比丘不知小便处。佛言。听问旧比丘。有诸老病比丘不能至小便处。佛言。听畜小便器。诸比丘便内小便器着房中臭处。佛言。不应着房中。诸比丘既着房外恶虫入中。佛言。若须内房中应密塞口。若着房外与水满中。有诸比丘处处大便。诸白衣讥呵如上。佛言。不应尔。听屏处掘地作厕屋覆上作上下道及栏格。厕满应除去。若生虫应作坑安之。若未生虫。持麴末着厕陷中。虫则不生。有诸比丘不嚼杨枝。口臭食不消。有诸比丘与上座共语恶其口臭。诸比丘以是白佛。佛言。应嚼杨枝。嚼杨枝有五功德。消食。除冷热唌唾。善能别味。口不臭。眼明。有诸比丘趣嚼木。佛言。有五种木不应嚼。漆树毒树舍夷树摩头树菩提树。余皆听嚼。时诸比丘欲庄严自恣处。佛言。听庄严。至自恣日竟夜说法经呗。不知谁应作。佛言。应差能者。诸比丘以小病辞不肯说法经呗。佛言。不应以小病辞说法经呗。有住处诸恶兽来入。佛言。听打鼓打木大唤作声及燃火。有住处毒虫来入。佛言。应取远弃。诸比丘手捉螫手。佛言。听以物挟着瓶中持去。有住处不闭户失衣钵。佛言。应作关钥令人不知开。舍利弗患风波斯匿王语言。应以干虾蟆薰鼻。不敢用。佛言。听用。有比丘欲染衣。佛言。听用根茎华叶皮染。有比丘欲染钦婆罗。佛言。听用尸尸婆树佉他罗树胡桃树染。诸比丘便染作纯黑色。佛言。不应作纯黑色衣。难陀有三十二相。虽不及佛。诸比丘遥见谓是世尊。恒为之起。难陀惭愧不知云何。以是白佛。佛言。听难陀作衣与佛衣异相。有诸比丘受阿练若十二头陀法不舍。在人间住受请乃至受屋舍等。以是白佛。佛言。一一皆突吉罗。听近聚落乃至一拘芦赊。若不能皆应舍。有诸比丘祀祠鬼神。佛言。不应尔。犯者突吉罗。不得为鬼神及外道师作塔亦如是。有诸比丘既作鬼神塔。鬼神依之。后坏鬼神嗔。佛言。已作不听坏。犯者突吉罗。有诸比丘大小便鬼神塔中。或左绕而去。鬼神嗔。佛言。不应尔。犯者突吉罗。若路从左边去听随路行。有诸比丘克木作男女像鸟兽形。又作种种戏具。与白衣小儿。佛言。不应作与。犯者突吉罗。有比丘自歌舞教人歌舞。自作乐教人作乐。佛言。不应尔。犯者突吉罗

五分律卷第二十六五分律卷第二十七

        宋罽宾三藏佛陀什共竺道生等译

    第五分之四威仪法

佛在舍卫城。尔时有一婆罗门出家好净过常。自恶大小便用利厕草割伤其肉。血污衣服及僧卧具。诸比丘种种呵责。汝尚自恶大小便。云何能看诸比丘病。以是白佛。佛言。不听用厕草。时诸比丘裸形上厕。诸白衣讥呵言。此比丘正似尼犍子。诸比丘以是白佛。佛言。不应裸形上厕。裸形上厕突吉罗。有阿练若处比丘去厕远。急大便不能忍至厕。以是白佛。佛言。良不能忍。听未至厕四向顾望无人便起。有比丘先在厕中。后有比丘不系念上厕。不弹指不[口*磬]欬迳入突之。先比丘羞惭恨责。后比丘悔谢。又上厕比丘虽弹指。而厕中比丘不作声。亦入致恨。俱以白佛。佛言。不应散乱心上厕。散乱心上厕突吉罗。今为诸比丘制上厕等初应学法。是中比丘应尽形寿学。若不学突吉罗

若比丘上厕时应一心看前后左右。至厕前[口*磬]欬弹指令厕中人非人知。厕中人亦应弹指[口*磬]欬。既入厕复应看前后左右仰视屋间。无蛇蚖毒虫不。不应以衣突户两边。好收敛之一心安足。勿令前却以污厕上。若先有污及己所污皆应治事。须洗洗之。须拭拭之。须除草秽除之。然后出去。徐下护衣勿使污秽。往小便处及洗大小便处亦应如是。若用水时。应先看水有虫无虫。不得多用水。然要使周事。以器卷水极令安徐。不得使器相撑以致破损。用水若尽。应更取使满。若有急事。要应取令得一人用覆头而去。有诸比丘于厕边坐禅眠卧染缝衣服受经经行。妨诸比丘上厕。诸比丘以是白佛。佛言。不应尔。有诸比丘住处狭小不得避厕。以是白佛。佛言。若住处狭小。听以衣物遮之令不相妨。有诸比丘于厕上嚼杨枝。诸比丘恶贱。又妨诸比丘上厕。以是白佛。佛言。不应尔。有诸比丘厕边嚼杨枝。佛言。亦不应尔。有诸比丘嚼杨枝竟插着厕壁钩。坏诸比丘衣。或伤其肉。佛言。不应尔。诸比丘嚼杨枝竟。着树根下树神嗔恨。佛言。不应尔。有诸比丘大便竟。无物雪拭污身衣服。佛言。听用厕草。诸比丘便用竹片芦片伤坏其肉。佛言。不应用利物作厕草。应削去楞。除漆树余木尽听用。诸比丘作厕草太长或太短或粗或细。佛言。应使得中。诸比丘用厕草竟着厕孔中。佛言。不应尔。诸比丘散乱掷厕草着地。佛言。听作器盛。若满。见者应除着坑中。若教火烧。诸比丘洗大小便污手。佛言。听用灰土牛屎净洗。诸比丘洗大小便竟。以手揩壁洗之坏诸墙壁。佛言。不应揩壁。应以塼石揩洗。诸比丘用灰土牛屎着地污秽。佛言。应以器盛。有诸比丘作杨枝太长。佛言。不应尔。极长听一搩手。有一比丘嚼短杨枝。见佛恭敬便吞咽之。佛威神令得无患。佛言。不应尔。极短听长并五指。亦不应大粗大细。诸比丘不住一处嚼杨枝处处污地。佛言。不应尔。有阿练若处比丘住一处嚼杨枝。路远妨乞食。又失僧得施。佛言。阿练若处比丘听一心行嚼杨枝。有诸比丘临井嚼杨枝。佛言。不应尔。有诸比丘用杨枝竟不洗虫食而死。佛言。不应尔。用竟净洗乃弃。有诸比丘乏杨枝。佛言。听截去已用处余更畜用。有一比丘以盛革屣囊盛杨枝革屣粪污之。佛言。应更以余物盛。有诸比丘于温室讲堂食堂作食处和尚阿阇梨上座前嚼杨枝。佛言。不应尔。有诸比丘病。和尚阿阇梨上座看之。不敢于前嚼杨枝。佛言。病时听。诸比丘白衣前嚼杨枝。白衣讥呵言。沙门释子唯勤治齿。佛言。不应尔。诸比丘便不敢于一切白衣前嚼杨枝。佛言。不应尔。若贵白衣不应于前嚼。有诸比丘于外道前嚼杨枝。亦如上呵责。佛言。亦不应尔。诸比丘便不敢于一切外道前嚼杨枝。彼便复言。沙门释子恭敬我等。不敢于我前嚼杨枝。佛言。不应尔。若能于佛法作损益者不应于前嚼。佛言。我为诸比丘制上厕等初学法。应尽形寿持

时有一乞食比丘。不系念在前。入他家不忆出处。更从余处出。见一女人在屋中露形仰卧。见已恐怖疾疾走出。彼家主还。见比丘恐怖疾出。作是念。此比丘于我家内必有事衅。即看家中见妇露形仰卧。便谓已通其妇。急追比丘语言。小住。汝于我家作如是如是事。比丘答言。汝莫作是语。我比丘法不作是恶。彼人不信打之几死夺衣钵而放。彼比丘既还僧房具向诸比丘说。诸比丘种种呵责。汝云何不系念在前入他家不忆出处。以是白佛。佛言。今为乞食比丘制初学法。应尽形寿学。若不学突吉罗

乞食比丘应一心早起。下床着革屣。取内衣着。抖擞去尘。腰绳亦如是。齐整着下衣。从脚跟下。上量一搩手。左掩其上两边两襵。当后两襵应抽系绳。徐取行路革屣不应错着。一心取僧伽梨及钵。洗钵时应互跪不得立。若洗铁钵听离地一尺。苏摩钵离地四指。瓦钵二者之中。洗竟不应着危崄处。亦不应着上有物堕处。不得不拭着日中曝。应可饮水着荫中。应洗钵水着日中。若出去时应一心。若须闭门户下钵着两脚间然后闭之。钩钥应藏勿令人见。去聚落不远其地平正有好软草。以钵着上已抖擞僧伽梨及中下衣齐整着之。左手摄衣右手擎钵低头视前而去。应善取街巷相善分别他门合相。至门合时应弹指[口*磬]欬叩使作声。若内有人非人令知。若入门已应筹量。应于何处立。若有人言。大德来入。便一心入。若人与食。不应临食上受。若女人授食。不应共语不应谛视不应取好恶相。若一家足者善。若不足复至余家。足然后止。得食已出聚落。离人远。应下钵着地脱僧伽梨抖擞去尘。若有泥污。应净除拭还摄着肩上。归到住处开门入。以衣钵着常着处。抖擞革屣揩拭令净。然后一心洗脚拭使燥。还着革屣向房。开房户入。举衣钵着本处。若欲以油涂脚。听涂脚底。净扫食处敷坐具。取净水办拭手脚巾。若住处先有生熟菜苦酒盐酱。应豫受着一处。洗盛长食器。量食有长。应先减着中。若见上座持食后还。应起迎为捉衣钵着上座本处语言。衣钵在此。为脱革屣有土者着户外。时至。打揵稚若唱令集坐。集坐已。先遍行盛长食器若有长者应减着中。若有少者应就取足。然后行菜医。若当食时。有比丘后来。应授水与彼。若授水与长食食器中食若不受水彼则已食。众食已。应收坐具扫地除粪远弃。净洗盛长食器覆着本处举水瓶先。到和尚阿阇梨房中。应有所作作之。然后还房。若读诵若坐禅若经行。以清净心除诸盖缠。和尚阿阇梨亦不得以小小事留弟子。若和尚阿阇梨当为四众说法。弟子应扫除说法处敷坐具具水瓶拭手脚巾。若有非时浆应净漉着一处。说法竟还举坐具诸物。若和尚阿阇梨须洗浴者应办浴具。若须冷取冷须暖为暖。师既入浴室应白。须已入不。若须便入若入。应在背后。师出应扶侍须还房。而不能去者应背负若衣举。须非时浆应与。若令呼某甲比丘应为呼。若须灯应然灯。若无灯。授饮时应白言。饮在此已净漉竟。夜应问师。须在此宿不。若言须则住。若言不须应还房。如上行道清旦应往问讯。得安眠不。应为求前食后食粥怛钵那。若僧中有应为请分。若有次请处亦应请分。若师欲入聚落应问。须着轻重衣授与之师若言。汝随我去应随去。至他家若不得入门不应恨。若入门不得坐亦不应恨。应立师背后。若檀越与食应受。若不得亦不应恨。师有残食与取啖亦不应恨。若在白衣家说法不应乱语。若师出鄙拙之言应令觉知。师归从归如上行道。是为阿练若比丘乞食初学法。应尽形寿持。时众多比丘于一住处夏安居。既结坐已。无人劝佐作前食后食及粥怛钵那。诸比丘安居中极乏食。自恣竟便去。去后旧住比丘向诸居士说言。汝等应生欣庆心。有如是如是好比丘住此安居。诸居士言。若尔我等不善与。汝等共作知识。云何有如是如是好比丘来而不语我。我常远请困不能得。而今自来不得供养。时六群比丘至他住处。语旧住比丘言。与我开房户敷卧具。即安处之。六群比丘中一比丘先入。不系念在前。蛇从上堕螫杀。余比丘啼哭懊恼。诸长老比丘疾出问之。以事而答。诸长老比丘呵责言。云何不系念在前入于空房。诸比丘以上事具白佛。佛言。今为客旧比丘制初学法。应尽形寿学。若不学突吉罗

若旧住比丘。闻上座客比丘游行人间当来至此。应修饰房舍抖擞床席晒卧具扫除房内铲治房前取净水覆着一处办拭手脚巾。若闻来至应出门迎令下座比丘为捉衣钵。既入已为敷座给洗脚水为洗脚。授拭手脚巾及革屣巾。若客上座衣物眷属多应与二房。应问。衬身衣何似。随上中下衣与所宜卧具。客比丘若病应与近厕房。若须浴为办浴具。若须非时浆亦应与应竟夜为集说法。明旦为办前食后食及粥怛钵那。请留夏安居。劝化一切令设供养。彼客比丘欲至僧坊。若先反抄衣应下之。若先叉腰不应复叉。若先戴衣应下着肩上。脱革屣抖擞拭令净。以草叶裹持入。入已应一处坐小息。应问旧比丘。何者是上座房。知处已应往礼拜问讯共语。若日早应礼塔。礼塔已次第礼诸上座。然后洗手脚。洗手脚已应问。此住处谁是分僧卧具人。知已往问。我若干岁有房分不。若言有。便言与我。若与复应问。此房先有人住不。若言无应到房户前。先以瓦石掷房中听声。若有声不应入。若无声。便开户避之户前。若无物出然后入。小待眼明遍看房中以杖按床上视床下地。无毒虫不。徐徐开窗。若日早应出卧具抖擞晒。若先无卧具。应至分卧具比丘边索。若得取敷复应问。彼房初夜何所畏。中夜后夜复何所畏。若言初夜畏阿练若贼。应问。我当作何计。若答应作如是自防。应受用之。中夜后夜亦如是。复应问。此房有食无。此聚落作食为早晚。何处巷。僧与作学家羯磨。何处巷。僧与作覆钵羯磨。何处巷有恶狗。何处巷。有淫女年长童女及寡妇。此中何处布萨何时布萨。何处是歠粥处何处是食处。其中若有僧事皆应疾赴。不得稽留。是为客旧比丘初学法。应尽形寿持

佛在王舍城。尔时有众多居士请僧食。或有诸比丘方着衣欲往食者。或有已还脱衣者。或有持钵欲往者。或有已还洗钵者。或有始出僧坊者。或有已还始入者。或有始食竟者。或有始欲食者。诸居士讥呵言。余外道尚知俱就请俱时食。而沙门释子反无法则。我等不知谁已食谁未食。诸长老比丘闻种种呵责。以是白佛。佛言。今为上座诸比丘制食时初学法。应尽形寿学。若不学突吉罗

若有白衣请僧。彼白衣家常出入比丘。应为白上座。上座应令遍语诸比丘。今受某甲檀越请。皆当齐集整持威仪。并遣主人出入比丘先语令知至。若日早食未办。上座须至余处。听将一比丘去。要当速还不得稽。于集时入请家门。皆应系念在前知次座处留未至者处。有绳床未有绳以衣覆上。比丘不知坐时反倒露形羞惭。佛言。若欲坐时先以手按然后坐。有诸比丘坐绳床上敷急烈破。佛言。应先举敷令宽然后坐。若檀越行水时应问。有承水器不。若有不应令水堕地。若无不应令水聚一处成泥。若得根茎叶果不知啖者。应待左右人食然后啖之。有比丘下食未遍便食。白衣讥呵言。此诸比丘不待等得食便食甚于小儿。佛言。不应尔。要须等得然后听食。有处僧多上座不知等得食时。佛言。应高声唱僧跋。诸比丘食竟默然而去。诸白衣讥呵言。诸余外道食人食竟皆咒愿而去。沙门释子默然无言。施主不知悦意以不。佛言。上座应咒愿已去。诸比丘去不待上座。佛言。听上座八人相待余人随意。有一住处舍利弗最上座罗睺罗最下座。受请主人以酥羹与上座。油羹与次座。泽枯羹与下座。罗睺罗食后往到佛所。头面礼足却坐一面。佛问罗睺罗。汝今日何所食。罗睺罗即说偈答

  食油者有力　　食酥者有色
  若食泽枯羹　　无力况有色

白佛言。今日用泽枯羹食。舍利弗食后往到佛所。头面礼足却坐一面。佛问舍利弗。汝今日何所食。答言。用酥羹食。佛呵言。汝今日不善食。云何比丘。上座酥食中座油食下座泽枯食。舍利弗默然不答。便于屏处吐食使尽。佛言。从今若受请时。上座应语主人言。一切与平等与。若檀越送食来。上座应语下座比丘令扫除食处敷座取净水出盛长食器。凡是所须皆应供办。时至应唱若打揵稚令齐受集食。若主人办食迟。应催令速勿使失时。是为上座食时初学法。应尽形寿持

时有阿练若处比丘。为人懒堕。不取饮水。不取洗手脚水。不取厕边水。时有众多阿练若贼往求饮水。答言无。复求洗手脚水厕边水。答亦复无。便语比丘言。汝等沙门释子常具三种水。今何故无。答言。我不取是故无。贼复言。今但与我水后不复来。答亦如初。复问。何故无水。答言。为人懒堕故不畜水。贼便夺其衣钵打之几死而去。复有阿练若处比丘。不别星宿。诸贼寄宿语比丘言。我等小眠。欲晓语我。贼小眠已。问比丘早晚。比丘言尚早。如是三问。夜已际晓。犹故言早。逐贼人至捉贼将去。贼便嗔言。比丘若语我早晚。睡不至晓。今被此捉便是比丘。诸比丘具以白佛。佛言。今为阿练若处比丘制初学法。应尽形寿学。若不学突吉罗

若阿练若处比丘。应善知四方相。应善知机宜。应善别星宿知时节早晚。应记月半月日数。亦应记岁月日数。以何利故应知四方相。若知贼来处方得以避之。以何利故应善知机宜。若贼来时应作是思惟。为宜避走。为宜起迎。为宜说法。为宜供。当知机宜已随而为之。以何利故应善知星宿。应知初夜星相中夜星相后夜星相。得以自知今是眠时今是行道时。若有贼问得语早晚。若贼将去放还。观星得知归路。以何利故应善知月半月日数。以此知布萨日至往聚落中求悔过清净布萨。以何利故应善知岁月日数。若至春时。知若干日过应结夏安居。安居中过若干日自恣时至。应往聚落中求悔过清净自恣。若阿练若处比丘。应在平正处若树下作洗脚庵安洗脚物畜洗脚水在常坐处坐。若有人来。应欢喜问讯。若贼索水。应脱革屣净洗手擎水与之。若问水冷暖。随宜答之。若优婆塞索水。亦应如是。若外道来索水。有能与佛法作损益者亦如上。若无能为。便应着革屣两手擎水与之。勿使彼言比丘恭敬我

时有一比丘于聚落中乞食还。不覆钵上鸱尿堕钵中。比丘不觉食得干痟病。复有一比丘亦从聚落中乞食还。不覆钵上拘楼荼鸟衔蛇飞。当钵上失蛇堕钵中。比丘虽去上饭食下饭即死。诸比丘具以白佛。佛言。若欲于聚落中食听住食。若欲持还应覆钵上。有诸老病比丘乞食擎钵还手寄。佛言。听作络囊盛钵挂掖。有诸比丘挂钵掖下汗流污之。佛言。听以手巾襆持归。时有一比丘乞食还。阿练若处贼逐后。作是念。若此比丘乃至不与我一搏食我当杀之。既至所住遥见彼贼来便请令食。贼食已作是言。希有汝今大得功德自施命复施我命。便自说上念。彼比丘以是白佛。佛言。若比丘持食至阿练若处。若有人来应与食。若无人来应小待。待久未有人来者。比丘饥应先食半。复未有人来应更食半。最后应留一。搏有诸阿练若处比丘食竟食尽。贼来从比丘乞食无食与。以是白佛。佛言。听阿练若处比丘畜食。若食难得。聚落比丘应与。若无净人。听自持还净不净地随意安之。有诸比丘自持食还阿练若处着不净地贼不来乞。不知云何。佛言。应与作人若守园人若沙弥。若有阿练若处比丘须瓶盆器物。聚落比丘应与。若须卧具亦应与。所行道中有树若草。妨比丘行或钩坏衣。佛言。听编草披着道外若以物遮之。听反系树枝着树。编系草木时枝折叶落。佛言。不故不犯。有阿练若处比丘晨朝来出露湿衣坏色。佛言。听高着亦听以杖扑去露。近聚落应还如法着衣。扑露杖藏着一处还时取归。有阿练若处比丘须土作泥。佛言。若无净人听取崩岸土。若无崩岸上。听水浇地挫草布上蹋使成泥取用。有阿练若处比丘。行时不举僧绳床木床卧具。烂坏火烧佛言。应举着一处钥户藏户钩着无雨处记之而去。若余比丘往。应语所藏处

时诸比丘作衣。不舒张裁便截之。或长或短或偏邪。不得成衣更索不能得。又有诸比丘常着一衣。住处亦着入聚落亦着。又有诸比丘以三衣裹果蓏草木叶牛屎。有诸比丘用食钵除粪扫。盛残食盛过中饮盛香及药。或不洗举或着日中或着地或着危崄处。诸比丘皆以白佛。佛言。今为诸比丘制衣钵初学法。应尽形寿学。若不学突吉罗

若比丘得新衣。应先浣舒张度量然后裁截。截已应缝。缝已应染颠倒晒燥。染已敷地若欲悬上下安纽。若僧伽梨。应如僧伽梨法畜。不得以裹诸物。优多罗僧。安陀会。诸受持衣亦皆如是。应谨护如身薄皮。持钵应如钵法。不得如上遇之。谨护应如眼

五分律卷第二十七五分律卷第二十八(弥沙塞)

        宋罽宾三藏佛陀什共竺道生等译

    第五分之五遮布萨法

佛在瞻婆国恒水边。尔时世尊十五日布萨时。与比丘众前后围绕于露地坐。遍观众僧默然而住。初夜过已。阿难从坐起。前礼佛足胡跪合掌白佛言。世尊。初夜已过众坐已久。愿为诸比丘说戒。世尊默然。阿难还坐。中夜过已复如是白。佛亦默然。后夜复白言。明相欲出众坐已久。愿为诸比丘说戒。佛语阿难。众不清净。如来不为说戒。时目连作是念。今此众中谁不清净。乃使世尊作如是语。便遍观察。见一比丘近佛边坐。非比丘自言比丘。非沙门自言沙门。不修梵行自言修梵行。成就恶法覆藏其罪不舍邪见。即从坐起往到其前。语言。如来已见汝。汝出去灭去莫此中住。便牵臂出着门外还坐本处。佛语目连。怪哉目连。未曾有也此愚痴人。不自知罪乃使他人牵其臂出。于是阿难复从坐起白佛言。世尊。众已清净。愿为诸比丘说戒。佛告阿难。从今汝等自共说戒。吾不复得为比丘说。所以者何。若众不清净。如来为说。彼犯戒人头破七分。又告阿难。大海有八未曾有。阿修罗乐居其中。何谓八。大海渐渐深。潮不过限。不宿死尸。百川来会无复异称。万流悉归而无增减。出真珠摩尼珊瑚琉璃珂玉金银颇梨诸宝。大身众生皆住其中。同一碱味。是为八。我此正法亦复如是。有八未曾有。诸比丘皆共乐之。何谓八。渐渐制渐渐教渐渐学我诸弟子于所制戒终不敢越。有犯必黜不宿容之。杂类出家皆舍本姓称释子沙门。诸善男子善女人。出家多得无余泥洹而无增减。有种种法宝所谓四念处。乃至八圣道分诸助道法。有诸大人。阿罗汉向阿罗汉乃至须陀洹向须陀洹住正法中。若有入者同一解脱味。是为八。时六群比丘犯罪不悔而布萨。有比丘亦效之。诸比丘以是白佛。佛言。不应尔。犯者突吉罗。诸比丘犹故犯罪不悔布萨。佛言。应住其布萨。有诸比丘或未布萨便住。或已布萨竟乃住。如是等诸住布萨。皆如住自恣中说

    五分律第五分之六别住法

时诸别住比丘。度沙弥与受具足戒。作依止师畜沙弥。诸比丘以是白佛。佛言。不应尔。复有别住比丘。受他善比丘恭敬。使令担衣钵革屣。佛言。不应尔。复有别住比丘。见如法比丘来便避藏。恐知已别住。佛言。不应尔。复有别住比丘。请僧食还私房食。佛言。不应尔。应在大比丘下行食。复有别住比丘。在如法比丘前行。佛言。不应尔。复有别住比丘。欲往白衣家共如法比丘行。佛言。不应尔。复有别住比丘。或更犯本罪。或更犯余恶罪。佛言。不应尔。复有别住比丘。于如法比丘前不披衣。佛言。不应尔。复有别住比丘。常着三衣作泥污。佛言。不应尔。复有别住比丘。共如法比丘一床坐。或自坐好床。佛言。不应尔。复有别住比丘。与如法比丘并经行。或自在胜经行处。佛言。不应尔。复有别住比丘。受僧差说戒经呗。佛言。不应尔。复有别住比丘。作诸羯磨呵责羯磨驱出羯磨依止羯磨举罪羯磨下意羯磨。佛言。不应尔。复有别住比丘。与如法比丘共语。佛言。不应尔。复有别住比丘。欲为四众说法。佛言。不应尔。复有别住比丘。不忆别住日数月半月一岁。佛言应知。复有别住比丘。于如法比丘前反抄衣叉腰着革屣覆头通肩覆或坐或卧。佛言。皆不应尔。复有别住比丘。不顺别住比丘法。佛言。不应尔。复有别住比丘。不白客来比丘不白去比丘。佛言应白。复有别住比丘。日日白僧。佛言。应布萨时白。若行摩那埵应日日白。复有别住比丘。欲远行白佛。佛言。应舍竟去。应作如是舍。向一如法比丘言。大德听。我今舍别住法后更行之。如是三说。若不舍而去。于路上见比丘。便应自说别住。诸别住比丘于路上便广说别住。诸白衣见言。此比丘有何罪而悔过。诸比丘以是白佛。佛言。路上不应广说。但言。大德。我某甲比丘行别住法。已若干日余若干日。大德。忆持。彼比丘舍别住到余处。应求彼僧更行别住。彼僧应听行别住法。若不听突吉罗。复有别住比丘。受别住法已往无比丘处住。于别住中更犯恶罪。佛言。别住比丘不得独住一处。不应更犯恶罪。犯者皆突吉罗。复有诸别住比丘。受别住已往不如法比丘处住。佛言。不应尔。彼若有一如法比丘听住。犯者突吉罗。复有别住比丘。与如法比丘同屋住。佛言。不应尔。复有别住比丘。与如法比丘同浴室浴。佛言。不应尔。听担樵内浴室中。洗浴室扫除之具灰土澡豆敷床座。与诸比丘脱衣革屣为油摩身体。随彼受者作之。复有同别住比丘共浴室浴。佛言。听但次第供给所须。别住比丘有三。最下最在大比丘下行。与最下卧具最下房舍。别住比丘有三事随本次。僧得施物时自恣时行钵时。别住比丘有八事失别住法。往地处不白。外来比丘不白。自出不白。他出不白。独住一处。于别住中更犯恶罪。与如法比丘同屋宿。不舍别住远行。路上见比丘不白。行摩那埵亦以八事失。除独住一处于不满二十僧中行之。余七如上

    五分律第五分之七调伏法

尔时长老优波离问佛。世尊。须提那迦兰陀子。是犯波罗夷不。佛言。初作皆不犯。又问。阿练若处比丘是犯不。佛言犯。有一比丘狂病行淫狂差。生疑问佛。佛言。狂者皆不犯。散乱心病坏心亦如是。孙陀罗难陀跋耆子。不舍戒行淫法。后疑问佛。佛言犯。有一比丘共二根女人行淫。有一比丘共二道合女人行淫。有一比丘共黄门行淫。有一比丘共男子行淫。有一比丘共小儿行淫。后皆生疑问佛。佛言。皆犯。有一比丘共小女行淫。女即死。疑犯二波罗夷问佛。佛言。淫犯波罗夷。女死犯偷罗遮。有一比丘作木女像行淫。后疑问佛。佛言。出不净僧伽婆尸沙。不出偷罗遮。泥画女像亦如是。有一比丘共象行淫。后疑问佛。佛言犯。一切畜生亦如是

时王舍城有一愚信优婆夷。作是见以淫欲施是第一施。便请诸比丘施之。诸比丘言。姊妹不应尔。是佛所制。女人复言。卧行是犯。立行不名犯。比丘即从其语。后疑问佛。佛言犯。坐行淫女背。女动比丘不动亦如是。时舍卫城有愚信优婆夷名善轻。作是见。以淫欲法施是第一施。便请诸比丘施之。诸比丘言。姊妹不应尔。是佛所制。女人复言。三处是犯。岐股脐中一切诸处不名犯。比丘即从其语。后疑问佛。佛言。出不净皆僧伽婆尸沙。不出皆偷罗遮。时阿练若处有比丘露地熟眠。有女人见于上行淫。比丘觉见不净污身。复见女人从其间去。生疑问佛。佛问汝受乐不。答言不受。佛言不犯。露地熟眠突吉罗。开房户眠亦如是。复有比丘露地熟眠。女人于上行淫。比丘觉出时受乐。生疑问佛。佛言犯。毗舍离有一阿罗汉比丘。得风病举体强直。看病人举着露地入聚落为乞食。有女人来于上行淫。行淫已比丘男根强直如故。诸女人言。此是雄士。即以香涂华鬘结头作礼而去。看病人还见不净污其身体。作是念。此比丘不修梵行破于净戒。我当住其布萨。又念。世尊不听住病比丘布萨。当待其差。彼病差已。便住其布萨。语言。汝先病时破戒。答言。我尔时病。身体强直不能自摄。非为破戒。诸比丘以是白佛。佛言。是比丘已得阿罗汉。风病强直不能自摄。不受乐故不犯。看病比丘置露地而去。犯突吉罗

时有比丘以男根刺比丘口中。后俱生疑问佛。佛言。若刺者戏偷罗遮。受者非戏波罗夷。若受者戏偷罗遮。刺者非戏波罗夷。若俱戏俱偷罗遮。若俱非戏俱波罗夷。时诸比丘共白衣浴室中浴。白衣取其形相语诸女人。又身相触生染着心。遂致反俗作外道者。诸比丘以是白佛。佛言。不应尔。若共白衣浴室中浴偷罗遮。有一摩诃罗比丘。梦中与本二行淫。觉已出房高声大唤。我非沙门非释种子。诸比丘问其故。答言。我与本二行淫。又问。汝本二今在何许。答言。在我本生聚落。又问。彼来耶汝往耶。答言。彼不来我不往。又问。云何得共行淫。答言。梦中行淫。诸比丘以是白佛。佛言不犯。不系念在前眠得突吉罗罪。有一比丘立小便。狗来衔其男根。生疑问佛。佛言不犯。立小便得突吉罗罪。比丘住处不应畜如是畜生。犯者突吉罗。有一比丘男根长。以欲心自刺大便道中。生疑问佛。佛言犯。有一比丘身体弱。以男根自刺口中亦如是。有一比丘坐禅。魔女来至其前。比丘见生染着心。不觉起捉彼女。女便走比丘亦走逐之。彼女至一死马中没。比丘便于马上行淫。即生悔心语诸比丘。诸比丘以是白佛。佛言。听僧与彼比丘作波罗夷白四羯磨。彼比丘应至僧中脱革屣偏袒右肩礼僧足胡跪合掌作如是白。我某甲比丘犯淫即生悔不覆藏。今从僧乞波罗夷羯磨。愿僧与我波罗夷羯磨。如是三乞。应一知法比丘唱言。大德僧听。此某甲比丘犯淫即生悔不覆藏。从僧乞波罗夷羯磨。僧今与作波罗夷羯磨。若僧时到僧忍听。白如是。大德僧听。此某甲比丘犯淫。乃至僧今与作波罗夷羯磨。谁诸长老忍默然不忍者说。如是第二第三说。僧与某甲比丘作波罗夷羯磨竟。僧忍默然故。是事如是持。佛言。彼比丘尽寿不得授大比丘食而自从净人受。若布萨自恣作诸羯磨时。若来者善。若不来彼此无犯。有比丘共天女龙女阿修罗女行淫。生疑问佛。佛言皆犯。有一比丘至他作食处取一钵羹。生疑问佛。佛言。汝以何心取。答言。以盗心。佛言。若直五钱犯波罗夷。若减五钱偷罗遮。入他园中盗心取一果菜亦如是。有一比丘为贼所剥诤得衣物。生疑问佛。佛言不犯。复有比丘为贼所剥。已入贼手或已持去。后追夺得。生疑问佛。佛言。汝心舍衣未。答言未舍。佛言。未舍不犯。已舍便犯。有阿练若处比丘。见野猪被箭走来。共相语言。当莫导见。猎师寻至问比丘。见我所射猪不。答言。何处有猪。是谁猪无有猪。后作是念。我言无猪将无得藏猪罪。生疑问佛。佛言不犯。若有如是因缘作余语破其问皆无罪。有阿练若处比丘。见猎师得生鹿系已舍去。比丘以怜愍心解放。生疑问佛。佛言不犯。然不应于他物方便放之。犯者突吉罗。怜愍心放他一切众生亦如是。有比丘见拘楼荼衔肉飞戏逐令放。生疑问佛。佛言不犯。然不应于无益处方便令彼失。犯者突吉罗。有一比丘见他牛随路行盗心驱即悔而舍。生疑问佛。佛言不犯。得偷罗遮罪。有比丘见水[漂*寸]物盗心接得。生疑问佛。佛言。若直五钱波罗夷。有比丘去祇洹不远。见他耕田语言。此是僧田汝勿耕之。耕者念言。诸比丘有势力。若讼我或致失物。便止不耕。比丘还祇洹问诸比丘。此是谁田。诸比丘言。是某居士田。便生疑问佛。佛言不犯。若于无益处作方便欲令失。皆突吉罗。时十七群童子为贼所抄。父母啼哭懊恼。毕陵伽婆蹉乞食见之。问其意故。具以事答。毕陵伽婆蹉即入定观见。贼将着阿夷罗河洲上。便以神足取还。各着其家阁上语其父母言。勿复啼哭。汝儿今皆还家重阁上戏。后疑问佛。佛言不犯。得突吉罗罪。有比丘为利养故。自长己年大于他人。后疑问佛。佛言不犯。故妄语得波逸提罪。有一住处比丘与白衣共井。白衣以盗心偏多取水。比丘亦以盗心作是念。我今何为独不多取未取。生疑问佛。佛言。若长取他水直五钱波罗夷。有比丘于彼处盗他衣直五钱。来此卖不直五钱谓不犯波罗夷。生疑问佛。佛言。本处直五钱波罗夷。若于彼处不直五钱。来此卖直五钱。偷罗遮。有比丘盗他佛经谓是佛语无犯。后疑问佛。佛言。计纸笔书功直五钱犯

尔时拘舍弥有一长者。见法得果常供给诸比丘。长者及姊各有一子。二人常共供养长老阿酬比丘。长者临欲终时。示阿酬比丘宝藏处所。语言。我命终后。彼二子中若信乐佛法。于诸比丘常无所爱者可示此藏。言已气绝。阿酬比丘后察二子。其子背正而姊子信乐。便语姊子令得宝藏。其子闻之。即往阿难所问言。父之遗财应属谁耶。答言。应属子。便语阿难言。我父宝藏阿酬比丘与我姑子。阿难即往语阿酬言。汝非沙门非释种子。阿酬答言。我是沙门是释种子。自可依诸经律共判此事。阿难言。此事居然何须经律。时诸长老比丘。皆是阿酬而佐助之。阿难阿酬二众于是各别。不复和合六年之中共安居住处皆不布萨自恣。声闻遐迩彻于梵天。时罗睺罗游迦维罗卫城。诸释种女皆共出迎。具说此事。如何世尊泥洹未久。众僧便不和合乃经六年。我等欲和合之不知方便。罗睺罗言。我当教汝令彼和合。阿难寻来。诸有婴儿皆抱迎之。以儿着地。儿必当啼。阿难必问。何不抱取。汝当答言。若长老与阿酬和合。我等然后乃当取儿。以此方便可令和合。阿难须臾便至。五百释女抱儿出迎。皆着阿难前地儿即大啼。阿难果言。何不抱取。同声答言。若长老与阿酬和合。我等乃当还取此儿。阿难感其此意。又愍婴孩语言。姊妹取儿。我当与彼和合。便还集僧。优波离问阿难。比丘不与取。有几种。非沙门非释种子。答言。有三种。自取。教人取。遣人取。又问阿酬。汝自取教人取遣人取不。答言不。又问阿难。阿酬比丘有何过。阿难言。阿酬无愆是我之过。于是阿难僧中遍唱。是我之过阿酬无愆。便向阿酬忏悔和合。有一比丘本是偷儿。语诸比丘。可共至彼聚落取物。诸比丘便从其语先往取之。彼比丘于后生疑问佛。我如是教人盗犯波罗夷不。佛言不犯。得偷罗遮罪。有比丘取他覆冢衣冢上幡冢间衣神庙中物他所护者。生覆问佛。佛言。他心未舍取。直五钱皆波罗夷。庙中物虽无主。而是官所护者亦如是。有比丘嗔他故。或烧其家。或烧其田谷财货。生疑问佛。佛言不犯。得偷罗遮罪。嗔故破坏他物亦如是。有比丘于鼠穴中得千两金囊盗心取。生疑问佛。佛言。属鼠物不犯。得偷罗遮罪。若盗心夺鸟兽物亦如是。有比丘于食上辄食他分。他问谁食我分。答言。我食彼嗔。生疑问佛。佛言。非盗心不犯。不应辄作同意食他分。犯者突吉罗。有比丘蒲博赌取人物。生疑问佛。佛言不犯。得突吉罗罪。有二比丘同意更相着衣。后相嗔谤以为偷。生疑问佛。佛言不犯。不应辄同意着他衣。犯者突吉罗

时跋难陀与估客共道行到关税处。估客从跋难陀借囊。密以大价珠着囊中还之。跋难陀不觉。出关已索囊中珠。跋难陀言。我不取汝珠。估客言。汝实不取我向借汝囊以珠着中耳。即还其珠。生疑问佛。佛言不犯。若欲出关。人从借物。还已应抖擞看。犯者突吉罗

时旃荼修摩那比丘尼弟子。至师檀越家诈云。师病索三种药粥。得已于外自食。其家妇女后往问讯言。阿姨病差不。答言。我都不病。何以问我。便以具说。师语弟子。汝偷我粥答言。我实不偷。于和尚作同意取耳。生疑问佛。佛言。不以盗心不犯。得故妄语波逸提罪。有比丘见主人田无水。决属他水浇之。生疑问佛。佛言。若直五钱犯。有高处比丘掷他衣与下处比丘。俱生疑问佛。佛言。若盗心掷波罗夷。无盗心取偷罗遮。若无盗心掷偷罗遮。盗心取波罗夷。俱盗心俱波罗夷。俱无盗心俱偷罗遮。有比丘盗心贸僧好物。生疑问佛。佛言。贸直五钱犯。时有比丘以石掷蛇。误着人死。生疑问佛。佛言。汝以何心。答言。欲掷杀蛇。佛言。人死无犯。掷蛇犯突吉罗。有比丘杀猕猴以似人。生疑问佛。佛言。夺畜生命犯波逸提。有一妇人夫行不在。傍通有娠。从常供养比丘乞堕胎药。与之儿死母不死。生疑问佛。佛言犯。若欲堕胎。母死儿不死犯偷罗遮。若俱死犯波罗夷。若俱不死犯偷罗遮。按腹堕胎亦如是。有诸比丘不乐修梵行。而不罢道还就下贱。于高处自坠取死。堕下人上下人死已不死。生疑问佛。佛言。汝以何心。答言。欲自堕死。佛言。彼死无犯。作方便自杀皆偷罗遮。有二比丘先相嗔。后共道行于路相打。一人遂死。生疑问佛。佛言。汝以何心。答言嗔心。佛言。无杀心不犯嗔他比丘得波逸提罪。从今不听相嗔未相悔谢共道行。犯者突吉罗。有比丘打杀鬼。生疑问佛。佛言。犯偷罗遮。有比丘欲杀彼而误杀此。生疑问佛。佛言不犯。得偷罗遮罪

时诸比丘为利养故。种种赞叹他戒成就。定慧解脱解脱知见成就。而密以自美。生疑问佛。佛言。若如是等不分明自说皆犯偷罗遮

毗舍离有一大树名尼拘类。荫五百乘车。花色比丘尼见语诸比丘尼言。我在天上时捶耳边华如此树大。诸比丘尼谓无此理。种种呵责。云何比丘尼自说得过人法。以是白佛。佛言。天上实有此华。华色比丘尼实语无犯。毗罗茶私呵比丘身生五百痈疮。痈疮溃烂不可视。华色比丘尼。与五百比丘尼俱共问讯。见已便笑。诸比丘尼呵责。云何无怜愍心见比丘如此方更笑之。华色答言。此比丘过去世。时作大国王。名毗竭婆。我时为作第一夫人。其王强取五百童女破其当世。以此因缘无数百千万岁堕大地狱苦毒烧煮。余报受此五百痈疮。诸比丘尼谓无此理。种种呵责。云何比丘尼自称得过人法。以是白佛。佛言。彼比丘实尔。华色说实无犯。时长老目连语诸比丘言。我见阿耨达池有莲华大如车轮。诸比丘不信。谓是虚说得过人法。以是白佛。佛言。实有此华。目连说实无犯。有诸比丘虚说得过人法。作如是言。我有业报因缘天眼天耳他心智。后疑问佛。佛言不犯。得偷罗遮罪。有诸比丘虚说得过人法作如是言。我得天眼天耳他心智诸漏已尽。后疑问佛。佛言犯。有一婆罗门请僧食。言大德诸罗汉来坐食。食竟言。诸罗汉还去。诸比丘生疑问佛。佛言。人自作此赞叹皆无犯。有诸比丘为利养故。坐起行立言语安详。以此现得道相欲令人知。后疑问佛。佛言。如是等现异皆犯偷罗遮。有诸比丘。临欲命终应堕地狱。悉见地狱诸相阿傍在前。又有比丘应生天。悉见诸天宫殿闻音乐声。天子天女在前语言。皆以语人。生疑问佛。佛言。是应生瑞相非妄语无犯。有诸比丘本欲说余事后非意说过人法。生疑问佛。佛言。非是本意不犯。得偷罗遮罪。有诸比丘语白衣言。若有住汝房者。皆成就如是如是道法。后自往住。生疑问佛。佛言。作如是等方便皆犯偷罗遮。有诸比丘自说得过人法。欲令人闻而非人闻。又欲令非人闻而人闻。又欲令人非人闻而无闻者。皆生疑问佛。佛言。皆犯偷罗遮。时目连语诸比丘。某甲居士妇当生男。彼当产时转为女。波斯匿王与阿阇世王共战。目连言。波斯匿王当胜而反不如。后更集战。复言。阿阇世王当胜亦反不如。诸比丘呵责言。云何虚说得过人法。以是白佛。佛言。如目连语但观其前不观后耳。时有比丘搔隐处不净出。生疑问佛。佛言汝以何心。答言。始末无有出意。佛言无犯。若欲出而出僧伽婆尸沙。欲出不出偷罗遮。以暖水浴向火炙不净出皆如是。有比丘忆行欲事不净出。生疑问佛。佛言。汝以何心。答言。我忆行欲事不净自出。佛言不犯。忆行欲事突吉罗。有比丘故以形撑衣出不净。谓不犯僧伽婆尸沙。问佛。佛言。如是比丘出不净僧伽婆尸沙。不出偷罗遮。有比丘于女像边出不净。生疑问佛。佛言。若出不净僧伽婆尸沙。不出偷罗遮

时有比丘以肘筑女人身。复有比丘以钵钩牵女人。生疑问佛。佛言。皆犯偷罗遮。若捉其衣牵捉其绳杖亦如是。有比丘女人在床上船车上树上欲心摇之。生疑问佛。佛言。若如是比丘皆犯偷罗遮

时有女人着青衣。比丘见语言。姊妹汝许青。生疑问佛。佛言。犯偷罗遮。若如是因形而作恶语皆如是。时有夫妇共斗不和合。比丘往和合之生疑问佛。佛言。若夫妇义已离。和合者僧伽婆尸沙。若未离无犯

五分律卷第二十八五分律卷第二十九(弥沙塞)

        宋罽宾三藏佛陀什共竺道生等译

    第五分之八比丘尼法

尔时世尊。还归舍夷。未至迦维罗卫城。止尼拘类树下。净饭王出迎。遥见世尊容颜殊特犹若金山。前礼佛足而说偈言

  生时相师记　　我闻致初敬
  树倾时稽首　　道成今三礼

说此偈已却坐一面。佛为说种种妙法。乃至见法得果。从坐起偏袒右肩胡跪合掌白佛言。世尊。愿与我出家受具足戒。佛即观之。见王出家更无所得。便白王言。莫放逸次第自当得此妙法。于是求受三归五戒。受五戒已。佛更为说种种妙法。示教利喜还归所住。王归宫已庭中三唱。若欲于如来正法律中出家者听。时摩诃波阇波提瞿昙弥。闻王此唱。即与五百释女前后围绕。持二新衣出到佛所。头面礼足白佛言。世尊。我自织此衣。今以奉上愿垂纳受。佛言。可以施僧得大果报。复如上。白佛言。可以施僧我在僧数。复如上白。佛言。我受一。以一施僧。然后受教。施佛及僧。瞿昙弥复白佛言。愿听女人于佛正法出家受具足戒。佛言。止止莫作是语。所以者何。往古诸佛皆不听女人出家。诸女人辈自依于佛。在家剃头着袈裟衣勤行精进得获道果。未来诸佛亦复如是。我今听汝以此为法。瞿昙弥如上三请。佛亦如上三不应许。于是瞿昙弥。便大啼哭礼足而退

佛从迦维罗卫与大比丘众千二百五十人俱。游行人间。瞿昙弥与五百释女自共剃头。着袈裟衣啼泣随后。恒于世尊宿处而宿。佛渐游行到舍卫城。住于祇洹。瞿昙弥及五百释女泣涕在门。阿难晨出见其如此。即问其故。答言。大德。世尊不听女人出家受具足戒。我等是以自悲悼耳。愿为启白令得从志。阿难即还头面礼足。具以白佛。佛止阿难亦如上说。阿难复白佛言。佛生少日母便命终。瞿昙弥乳养世尊至于长大。有此大恩如何不报。佛言。我于瞿昙弥亦有大恩。其依我故识佛法僧而生敬信。若人依善知识识佛法僧。生信敬者。于彼人所若以衣食医药尽寿供养所不能报。阿难复白佛言。若女人出家受具足戒能得沙门四道果不。佛言。能得。阿难言。若得四道。世尊何为不听出家受具足戒。佛言。今听瞿昙弥受八不可越法。便是出家得具足戒。何谓八。比丘尼半月应从比丘众乞教诫人。比丘尼不应于无比丘处夏安居。比丘尼自恣时应从比丘众请三事见闻疑罪。式叉摩那学二岁戒已应在二部僧中受具足戒。比丘尼不得骂比丘。不得于白衣家说比丘破戒破威仪破见。比丘尼不得举比丘罪。而比丘得呵比丘尼。比丘尼犯粗恶罪。应在二部僧中半月行摩那埵。半月行摩那埵已。应各二十僧中求出罪。比丘尼虽受戒百岁。故应礼拜起迎新受戒比丘。阿难受教。即出语瞿昙弥。汝谛听我说佛所教。瞿昙弥更整衣服遥礼佛足。长跪合掌一心而听。阿难具说如上。瞿昙弥言。犹如年少男女净洁自喜沐浴身体着新净衣。有人惠与瞻婆花鬘婆师华鬘优钵罗华鬘阿提目多伽花鬘。其人欢喜两手棒取举着头上。我今顶受。世尊法教亦复如是。复白阿难。愿更为我入白世尊云。我已顶受八法。于八法中欲乞一愿。愿听比丘尼随大小礼比丘。如何百岁比丘尼礼新受戒比丘。阿难复为白佛。佛告阿难。若我听比丘尼随大小礼比丘者。无有是处。女人有五碍。不得作天帝释魔天王梵天王转轮圣王三界法王。若不听女人出家受具足戒。佛之正法住世千岁。今听出家则减五百年。犹如人家多女少男。当知其家衰灭不久。又告阿难。若女人不于我法出家受具足戒。我般泥洹后诸优婆塞优婆夷。当持四供随比丘后白言。大德。怜愍我故受我供养。若出门见便当牵臂言。大德于我有恩。乞暂过坐使我获安若。道路相逢皆当解发拂比丘足布令蹈上。今听出家此事殆尽。阿难闻已悲恨流泪。白佛言。世尊。我先不闻不知此法。求听女人出家受具足戒。若我先知岂当三请。佛告阿难。勿复啼泣。魔蔽汝心是故尔耳。今听女人出家受具足戒。当应随顺我之所制。不得有违。我所不制不得妄制。阿难即出。具以佛教语瞿昙弥。瞿昙弥欢喜奉行。即成出家受具足戒。复白阿难。此五百释女今当云何受具足戒。愿更为白。阿难即以白佛。佛言。即听波阇波提比丘尼为作和尚在比丘十众中白四羯磨受具足戒。听一时羯磨三人。不得至四。既受戒已。摩诃波阇波提比丘尼。与五百比丘尼俱到佛所。头面礼足白佛言。世尊。我等云何着衣。佛言。如比丘法。又白。云何食。答言。听乞食。又白。云何布萨。答言。听别布萨。半月从比丘僧乞教诫人。又白。云何结安居。答言。听于屋下结三月安居。又白。云何自恣。答言。听别自恣往比丘僧中请见闻疑罪。又白。云何受迦絺那衣。答言。听白二羯磨四月日受。又白。云何畜皮革。答言。听作行来革屣。又白。云何灭诤。佛言。听以七灭诤法灭四事诤

尔时诸比丘尼不先授弟子二岁戒便授大戒。愚痴无知不能学戒。以是白佛。佛言。不应尔。犯者突吉罗。应如是先授二岁不得杀生二岁不得偷盗二岁不得淫二岁不得妄语二岁不得饮酒二岁不得非时食。时有一比丘尼媒嫁。犯僧伽婆尸沙。不知云何。以是白佛。佛以是事集二部僧。告诸比丘。听二部僧白四羯磨与彼比丘尼半月摩那埵。彼比丘尼应到僧中偏袒右肩脱革屣礼二部僧足白言。大德僧听。我某甲比丘尼媒嫁。犯僧伽婆尸沙罪。今从僧乞半月摩那埵。愿僧与我半月摩那埵。如是三乞。应一比丘唱言。大德僧听。此某甲比丘尼媒嫁。犯僧伽婆尸沙罪。从僧乞半月摩那埵。僧今与半月摩那埵。若僧时到僧忍听。白如是。大德僧听。此某甲比丘尼媒嫁。犯僧伽婆尸沙罪。从僧乞半月摩那埵。僧今与半月摩那埵。谁诸长老忍默然不忍者说。如是三说。僧已与某甲比丘尼半月摩那埵竟。僧忍默然故。是事如是持。僧既与行摩那埵。应晨起扫洒比丘尼住处诸房泥治壁地。应有水处皆取令满。诸有可作皆应作之。若客比丘尼来比丘尼去亦皆应白。又应将一比丘尼为伴至比丘住处。若有可作皆应如上作之。若客比丘来若比丘去。亦皆应白。日欲暮还比丘尼住处。如是半月行已。于二部僧各二十人中求出罪羯磨。如比丘法

时诸比丘尼不礼比丘。无人教诫愚痴无知不能学戒。以是白佛。佛呵责言。我先说八不可越法。百岁比丘尼礼新受戒比丘。云何于今而不礼敬。呵已告诸比丘。从今听诸比丘随次礼上座。诸比丘尼礼一切比丘。亦随次自相礼。式叉摩那礼一切比丘比丘尼。亦随次自相礼。沙弥亦如是。沙弥尼礼一切比丘比丘尼式叉摩那沙弥。亦随次自相礼。有比丘尼在高处礼下处比丘。或在比丘后。或于傍边礼。或手捉足。或膝着地礼。以是白佛。佛言。皆不应尔。听比丘尼去比丘不近不远。合掌低头作是言和南

时诸比丘尼发长。佛言。应求女人剃之。若无女人听使男子。但不得独不得令捉。有余比丘尼伴为捉。然后使剃。时诸比丘尼。从比丘尼受经。诵不能得。复有一比丘尼。从比丘尼受一波罗提木叉。多日不能得。后从比丘受即得。以是白佛。佛言。听比丘尼从比丘受经。若经中有粗恶语听书授。若不知书听隔障授。若无障隔听相背授。有诸比丘尼与比丘共布萨。见比丘犯罪便欲举之。以是白佛。佛言。比丘尼不得共比丘布萨。应半月请一比丘令从比丘僧乞教诫人。诸比丘不肯为乞。佛言。听比丘尼为作供养钵囊漉水囊腰绳香油前食后食。或未布萨为白。或已布萨乃白。佛言。不应尔。应于唱说不来诸比丘欲清净时从坐起在僧前立白言。大德僧听。某精舍和合比丘尼僧。顶礼和合比丘僧足乞教诫人。若僧先已差教诫人。上座应答从某甲比丘受。若僧无所差人有能说法者。应答往某甲比丘边受。若复无者应答此无差教诫人。又无能说法者汝等莫放逸。诸比丘尼明日应来问。乞教诫比丘竟为白僧不。此比丘应传上座语语之

有诸比丘尼共比丘自恣。比丘尼欲往阿练若处就比丘自恣。道中遇贼水火。有命难梵行难衣钵难。又更相待稽留自恣。以是白佛。佛言。比丘尼不得共比丘自恣。应别自恣从比丘僧请见闻疑罪。时聚落中无比丘。诸比丘尼往阿练若处请见闻疑罪。或道远不达。或彼比丘不为和合。遂不得请。以是白佛。佛言。听阿练若处比丘为比丘尼来聚落自恣为其和合。诸比丘尼应先集众自恣。然后差比丘尼就比丘僧请见闻疑罪。至已偏袒右肩脱革屣遥礼僧足。然后入僧中合掌曲身白言。某精舍和合比丘尼僧。顶礼和合比丘僧足。我等比丘尼僧和合。请大德僧自恣说见闻疑罪。如是三请

时诸比丘语波阇波提比丘尼言。汝无和尚不成出家受具足戒。彼便生疑。以是白佛。佛言。汝受八不可越法时。已是出家受具足戒。有比丘尼诱弄比丘言。我是族姓礼仪备举女工具足。意欲给侍彼比丘。便生染着心。不复乐道遂致反俗。诸比丘以是白佛。佛言。比丘尼不应诱弄比丘。犯者突吉罗。有诸比丘尼来比丘住处。或露胸胁。或露髀膞诸比丘见生染着心。不复乐道遂致反俗。诸比丘以是白佛。佛言。不应尔。从今不听比丘尼入比丘住处。既不得入便无教诫。愚闇无知不能学戒。以是白佛。佛言。若如法比丘尼听入。亦应唤来。既唤不来。佛言。唤不来突吉罗。时诸比丘尼不共比丘语。无人教诫。愚闇无知不能学戒。诸比丘尼以是白佛。佛言。不应尔。犯者突吉罗

时优蹉比丘尼数数犯罪。比丘尼僧与作不见罪羯磨。便啼哭言。我愚痴。僧与我作不见罪羯磨。我或于中更犯粗罪。愿僧为我解此羯磨。诸比丘尼以是白佛。佛言。不应为解羯磨。应白二羯磨差一比丘尼伴之共语共同行止。一比丘尼唱言。阿姨僧听。今差某甲比丘尼。伴优蹉比丘尼。共语共同行止。若僧时到僧忍听白如是。阿姨僧听。今差某甲比丘尼伴优蹉比丘尼共语共同行止谁诸阿姨忍默然不忍者说。僧已差某甲比丘尼。伴优蹉比丘尼竟。僧忍默然故。是事如是持。有比丘尼月水出污脚及衣。入聚落乞食。诸白衣见讥呵。佛言。若比丘尼月水出时。不听入聚落乞食。听聚粮。亦听弟子并为乞。若无弟子听着月水衣乞食。有诸贵姓女出家不着覆肩衣。诸白衣见其肩臂共调弄之。皆怀惭耻。诸比丘尼以是白佛。佛言。听着覆肩衣。时诸比丘尼弟子。学二岁戒不合意。便与受具足戒。佛言。不应尔。犯者突吉罗。从令听合和尚阿阇梨意乃为集十众至受戒处。将欲受戒又着眼见耳不闻处。和尚应为求羯磨师及教诫师。得已羯磨师应羯磨。教诫师令出外教唱言。阿姨僧听。某甲求某甲受具足戒某甲作教诫师。若僧时到僧忍听。白如是。彼教诫师应行初法。先问和尚。此欲受具足戒人。学二岁戒日满不。衣钵具不。若言不具。应语令具。若言具复应问。为是己有为是借。若言借应语借主舍与。然后乃往欲受戒人所语言。汝莫恐怖。须臾当着汝于高胜处。若先不谙悉应小披衣观看。无遮受戒法不问言。何者是汝僧伽梨忧多罗僧安陀会覆肩衣水浴衣。彼若不识应语令识。次与受衣钵。如比丘中说。复应语言。汝某甲听。今是实语时。我今问汝。若有当言有。若无当言无。女人有如是病。癞病白癞病干痟病癫狂病痈疽漏病脂出病。如是等重病汝有不。不负债不。非他妇不。夫主听不。不属官不。非婢不。是人不。是女人不。女根具足不。汝非黄门不。非石女不。非二道合不。月水出不。不常出不。学二岁戒日满不。已求和尚未。父母听不。欲受具足戒不。如我今问。后僧中亦当如是问汝。汝亦当如是答彼。教诫师应还僧中立白言。我已问竟。羯磨师应白僧言。阿姨僧听。某甲求某甲受具足戒。某甲已问竟。今听将来。若僧时到僧忍听。白如是。教师应往将来教礼僧足。礼已将至羯磨师前。教胡跪合掌向羯磨师。从僧乞受具足戒。教言。我某甲求某甲和尚受具足戒。今从僧乞受具足戒。和尚某甲僧济拔我怜愍故。如是三乞。教师然后还复坐。羯磨师应白僧。阿姨僧听。此某甲求某甲受具足戒。彼从僧乞受具足戒。和尚某甲。我今于僧中问诸难事。若僧时到僧忍听。白如是。应语言。汝听。今是实语时。我今问汝。若有便言有。若无便言无。乃至欲受戒不。皆如上问。如上问已。羯磨师复应唱言。阿姨僧听。此某甲求某甲受具足戒。彼从僧乞受具足戒。自说无诸难事。学二岁戒满。五衣钵具。已求和尚。父母已听。欲受具足戒。僧今与某甲受具足戒和尚某甲。若僧时到僧忍听。白如是。阿姨僧听。某甲求某甲受具足戒。乃至和尚某甲谁诸阿姨忍默然不忍者说。如是第二第三说。僧已与某甲受具足戒和尚某甲竟。僧忍默然故。是事如是持。彼和尚阿阇梨。复应集十比丘尼僧。将受戒人往比丘僧中。在比丘羯磨师前小远。两膝着地乞受具足戒。羯磨师应教言。我某甲求某甲和尚受具足戒。已于一众中受具足戒竟。清净无诸难事。已学二岁戒满。衣钵具足。已求和尚。父母已听。不犯粗恶罪。欲受具足戒。今从僧乞受具足戒。和尚某甲僧济拔我怜愍故。如是三乞

三乞已。羯磨师应白。大德僧听此某甲求某甲受具足戒。已于一众中受具足戒竟。清净无诸难事。已学二岁戒满。先所应作已作。衣钵具足。已求和尚。父母已听。不犯粗恶罪。欲受具足戒。今从僧乞受具足戒。和尚某甲。僧今与某甲受具足戒和尚某甲。若僧时到僧忍听。白如是。大德僧听。此某甲求某甲受具足戒。乃至僧今与某甲受具足戒和尚某甲。谁诸长老忍默然不忍者说。如是第二第三说。僧已与某甲受具足戒和尚某甲竟。僧忍默然故。是事如是持

复应语言。某甲听。如来应供等正觉说八波罗夷法。若比丘尼犯此一一法。非比丘尼非释种女。一切不得淫乃至以染着心看他男子。若比丘尼行淫法乃至畜生。非比丘尼非释种女。是中尽形寿不应犯。若能持当言能。一切不得偷盗乃至草叶。若比丘尼若聚落若空地。他所守护物。盗五钱若过五钱。非比丘尼非释种女。是中尽形寿不得犯。若能持当言能。一切不得杀生乃至蚁子若比丘尼若人若似人。自手断命持刀授与教人杀教死赞死。非比丘尼非释种女。是中尽形寿不应犯若能持当言能。一切不得妄语乃至戏笑。若比丘尼自无过人法。若言有诸禅解脱三昧正受若道若果。非比丘尼非释种女。是中尽形寿不应犯。若能持当言能。一切不得亲近男子。若比丘尼欲盛变心。摩触男子身发已下膝已上。若男子作如此摩触亦不得受。若按若掐若举若下若捉若牵。非比丘尼非释种女。是中尽形寿不应犯。若能持当言能

一切不得与男子共住共语。若比丘尼欲盛变心。受男子若捉手若捉衣若期行若独共行若独共住若独共语若独共坐若以身相近具是八事。非比丘尼非释种女。是中尽形寿不应犯。若能持当言能

一切不得随顺非法比丘语。若比丘尼知和合比丘僧如法举比丘。而随顺此比丘。诸比丘尼语言。姊妹。此比丘为和合比丘僧如法举。汝莫随顺。如是谏坚持不舍。应第二第三谏。第二第三谏舍是事善。不舍者非比丘尼非释种女。是中尽形寿不应犯。若能持当言能。一切不应覆藏他粗恶罪。若比丘尼知他比丘尼犯波罗夷罪。彼后时若罢道若死若远行若被举若根变。语诸比丘尼作如是语。我先知是比丘尼犯波罗夷罪不白僧不向人说。非比丘尼非释种女。是中尽形寿不应犯。若能持当言能

诸佛世尊善能说喻示现现事。犹如针鼻缺不复任针用。犹如人死终不能以此身更生。犹如多罗树心断不生不长。犹如石破不可还合。若比丘尼于此八法犯一一法。还得比丘尼无有是处

复应语言。汝某甲听。如来应供等正觉说是八不可越法。汝尽形寿不应越。比丘尼半月应从比丘众乞教诫人。比丘尼不应于无比丘处夏安居。比丘尼自恣时应从比丘众请三事见闻疑罪。式叉摩那学二岁戒已。应在二部僧中受具足戒。比丘尼不得骂比丘。不得于白衣家说比丘破威仪破戒破见。比丘尼不应举比丘罪。比丘得呵比丘尼。比丘尼犯粗恶罪应在二部僧中半月行摩那埵。半月行摩那埵已。应各二十僧中求出罪。比丘尼虽先受戒百岁。故应礼拜起迎新受戒比丘。复应语言。汝某甲听。如来应供等正觉说是四依法。尽形寿依是出家受具足戒。依粪扫衣出家受具足戒。若能当言能。若得长衣劫贝衣钦婆罗衣俱舍耶衣刍摩衣刍弥衣婆舍那衣阿呵那衣瞿茶伽衣麻衣应受。依乞食法出家受具足戒。若能当言能。若得长食僧食前食后食请食应受

依粗弊卧具出家受具足戒。若能当言能。若长得庵屋重屋大小房方圆屋应受。依下贱药出家受具足戒。若能当言能。若长得酥油蜜石蜜应受。复应语言。某甲听。汝已白四羯磨受具足戒竟羯磨如法。诸天龙鬼神乾闼婆常作是愿。我等何时当得人身出家受具足戒。汝今已得。如人得受王位。汝今受比丘尼法亦如是。汝当忍易共语易受教诫。当学三戒灭三毒出三界成阿罗汉果。余所不知者。和尚阿阇梨当为汝说

时有一淫女名半迦尸。于正法律出家。欲往阿练若住处受具足戒。诸贼闻之欲逆道伺取。彼女人亦闻不敢去。诸比丘尼以是白佛佛言。听白四羯磨遥为受具足戒。彼和尚阿阇梨先为集十比丘尼僧与受戒竟。置受戒人着一处。将十比丘尼僧往阿练若处。皆礼比丘僧足。羯磨师为从僧乞戒言。大德僧听。某甲求某甲受具足戒已。于一众中受具足戒竟。清净无诸难事。已学二岁戒满。先所应作已作。衣钵具足。已求和尚。父母听许。不犯粗恶罪。欲受具足戒。今从僧乞受具足戒和尚某甲。愿僧济拔之。怜愍故。如是三乞。比丘羯磨师应以其乞辞如上白四羯磨。羯磨已和尚阿阇梨。将十比丘尼僧还至本受戒处。呼受戒人令礼僧足在羯磨师前胡跪合掌。羯磨师为说僧所作白四羯磨令听已。然后如上具说八堕法四譬喻法八不可越法四依法。乃至余所不知者。和尚阿阇梨当为汝说。有诸比丘尼着光色衣以为饰好。诸白衣讥呵言。此比丘尼似淫女欲求男子。诸比丘尼以是白佛。佛言。不应尔。犯者突吉罗。有诸比丘尼画眼。佛言。不应尔。犯者突吉罗。有诸比丘尼患眼须画。佛言。病者听画。有诸比丘尼在比丘前行。佛言。不应尔。犯者突吉罗。有诸比丘尼遥见比丘来。便住不敢前去妨乞食。佛言。若去远者听在前行。有诸比丘尼在比丘前嗅气唾地。佛言。不应尔。犯者突吉罗。有诸比丘尼加趺坐月水出污脚跟。人见讥呵。又有一比丘尼加趺坐蜣蛝虫入女根中以此致病。白佛。佛言。一切比丘尼皆应累趺坐若加趺坐应互伸一脚。犯者突吉罗。有居士欲与比丘尼贸易住处。诸比丘尼不敢。佛言。听与贸易。有诸比丘尼如刺靴法张衣刺。佛言。不应尔。若衣卷缩听安綦。有诸比丘尼于住处处处大小便臭秽。佛言。不应尔。犯者突吉罗。应作厕。诸比丘尼深作厕坑落胎着中。除粪人见讥呵言。此辈常赞叹离欲欲想欲热而行其事恐人知之落胎厕中。何不罢道受五欲乐。诸比丘尼以是白佛。佛言。不应深作厕坑。极深听卷手一肘小作口。有诸比丘尼以钵及囊盛胎晨朝弃之。时波斯匿王边境有事遣军征之。有信乐佛法者作是念。我今当先与出家人食然后乃行。即遣信觅。遇见彼比丘尼请还施食。比丘尼言。汝并前去。我随后往。便苦请之强将俱还。出钵下食见小儿胎。便种种讥呵言。此等常说慈愍护念众生。而今亲自杀儿。无沙门行破沙门法。诸比丘尼以是白诸比丘。诸比丘以是白佛佛言。若比丘尼乞食时见比丘应出钵示。诸比丘尼便都出钵倾侧示之以妨乞食。佛言。但粗示令知其空。有比丘尼产一男儿。不知云何。以是白佛。佛言。听白二羯磨差一比丘尼伴之。应一比丘尼僧中唱言。阿姨僧听。此某甲比丘尼生男儿。今差某甲比丘尼伴之。若僧时到僧忍听。白如是。阿姨僧听。此某甲比丘尼生男儿。今差某甲比丘尼伴之。谁诸阿姨忍默然不忍者说。僧已差某甲比丘尼伴某甲比丘尼竟。僧忍默然故。是事如是持。二比丘尼捉儿生疑。佛言无犯。二比丘尼共儿眠生疑。佛言亦无犯。庄严儿共鸣。佛言。不应尔。听洗浴与乳哺。若离怀抱应与比丘令出家。若不欲令出家。应与亲亲养令长成。有诸比丘尼比丘僧请不次第往。佛言。不应尔。应次第差往。有诸比丘尼入聚落不系下衣堕地露形。佛言。应以腰绳系之。作腰绳大长。佛言。听绕腰一匝。作腰绳大广。佛言。极广听广一指。作杂色腰绳。佛言。不应尔。听纯一色。有诸比丘尼着轻衣入聚落风吹露形。佛言。听上下安钩纽带系之。有诸贵姓女出家擎钵乞食手寄。佛言。听作络囊盛钵乞食。挂腋下汗污尘入。佛言。听作覆钵巾。有诸比丘尼作蛊道欲杀众生。佛言。若作蛊道欲杀众生偷罗遮。作咒术起死人欲杀众生亦如是。有诸比丘尼畜种种杂色衣。诸白衣讥呵言。此诸比丘尼正似淫女。佛言。不应尔。犯者突吉罗。诸比丘有宿食。诸比丘尼无食不敢与。佛言。听与无犯。比丘尼宿食与比丘亦如是。有诸比丘至比丘尼住处。无净人授食。佛言。无净人时听比丘尼授食与比丘无犯。比丘授食与比丘尼亦如是。有诸比丘尼作酒沽。多人讥呵。佛言。不应尔。犯者偷罗遮。有诸比丘尼畜田犁牛奴自看耕种。诸白衣讥呵。此诸比丘尼亦自看耕田与我何异。佛言。不应自看。应使净人知。犯者突吉罗。有诸比丘尼出息。多人讥呵。佛言。不应尔。犯者偷罗遮。有诸比丘尼畜淫女坐肆赁之。多人讥呵。佛言。不应尔。犯者偷罗遮。有诸比丘尼压油卖。多人讥呵。佛言。不应尔。犯者偷罗遮。有诸比丘尼跶脚戏。多人讥呵。佛言。不应尔。犯者突吉罗。悬绳自挂戏亦如是。有诸比丘尼住处失火。佛言。应打揵捶若唱令集皆共救火土坋水浇以水渍衣扑灭。时有众多居士请比丘尼僧食。诸比丘尼晨朝着衣持钵到请家方相问。大小日时遂过。居士讥呵。此诸比丘尼正似婆罗门女。相问知经多少多者为大。我今设供日时已过。当如之何。以是白佛。佛言。若大众会时听上座八人相问大小以次坐。余人得座便坐

五分律卷第二十九五分律卷第三十(弥沙塞)

        宋罽宾三藏佛陀什共竺道生等译

    第五分之九五百集法

尔时世尊泥洹未久。大迦叶在毗舍离猕猴水边重阁讲堂。与大比丘僧五百人俱。皆是阿罗汉唯除阿难。告诸比丘。昔吾从波旬国向拘夷城。二国中间闻佛世尊已般泥洹。我时中心迷乱不能自摄。诸聚落比丘比丘尼优婆塞优婆夷或躄或踊宛转于地。莫不哀号叹速叹疾世间空虚世间眼灭。时跋难陀先游于彼。止众人言。彼长老常言。应行是不应行是。应学是不应学是。我等于今始脱此苦。任意所为无复拘碍。何为相与而共啼哭。吾闻其语倍复忧毒。佛虽泥洹比尼现在。应同勖勉共结集之。勿令跋难陀等别立眷属以破正法。诸比丘咸以为善。白迦叶言。阿难常侍世尊聪睿多闻具持法藏。今应听在集比丘数。迦叶言。阿难犹在学地。或随爱恚痴畏不应容之。时阿难在毗舍离恒为四众昼夜说法。众人来往殆若佛在。有跋耆比丘于彼阁上坐禅。以此闹乱不得游诸解脱三昧。作是念。阿难今于学地应有所作为无所作。而常在愦闹多有所说。既入定观见应有所作。复作是念。我今当为说厌离法使其因悟。便往阿难所为说偈言

  静处坐树下　　心趣于泥洹
  汝禅莫放逸　　多说何所为

诸比丘亦语阿难言。汝应速有所作。大迦叶今欲集比尼法。而不听汝在此数中。阿难既闻跋耆比丘所说偈。又闻迦叶不听在集比尼数中。初中后夜勤经行思惟望得解脱。而未能得。后夜垂过身体疲极。欲小偃卧头未至枕。豁然漏尽。诸比丘知即白迦叶。阿难昨夜已得解脱。今应听在集比尼数。迦叶即听。于是迦叶作是念。何许多有饮食床坐卧具。可得以资给集比尼。唯见王舍城足以资给。便于僧中唱言。此中五百阿罗汉应往王舍城安居。余人一不得去

作是制已。五百罗汉至王舍城。于夏初月补治房舍卧具。二月游戏诸禅解脱。三月然后共集一处。于是迦叶白僧言。大德僧听。我今于僧中问优波离比尼义。若僧时到僧忍听。白如是。时优波离亦白僧言。大德僧听。我今当答迦叶比尼义。若僧时到僧忍听。白如是。迦叶即问优波离。佛于何处制初戒。优波离言在毗舍离。又问因谁制。答言。因须提那迦兰陀子。又问以何事制。答言。共本二行淫。又问有二制不。答言有。有比丘共猕猴行淫。迦叶复问。于何处制第二戒。答言。在王舍城。又问因谁制。答言。因达腻吒。又问以何事制。答言。盗瓶沙王材。迦叶复问。于何处制第三戒。答言。在毗舍离。又问因谁制。答言。因众多比丘。又问以何事制。答言。自相害命。迦叶复问。于何处制第四戒。答言。在毗舍离。又问因谁制。答言。因婆求摩河诸比丘。又问以何事制。答言。虚称得过人法。迦叶作如是等问一切比尼已。于僧中唱言。此是比丘比尼。此是比丘尼比尼。合名为比尼藏

迦叶复白僧言。大德僧听。我今欲于僧中问阿难修多罗义。若僧时到僧忍听。白如是。阿难亦白僧言。大德僧听。我今当答迦叶修多罗义。若僧时到僧忍听。白如是。迦叶即问阿难言。佛在何处说增一经。在何处说增十经大因缘经僧祇陀经沙门果经梵动经。何等经因比丘说。何等经因比丘尼优婆塞优婆夷诸天子天女说。阿难皆随佛说而答。迦叶如是问一切修多罗已。僧中唱言。此是长经今集为一部。名长阿含。此是不长不短今集为一部。名为中阿含。此是杂说为比丘比丘尼优婆塞优婆夷天子天女说。今集为一部名杂阿含。此是从一法增至十一法。今集为一部名增一阿含。自余杂说今集为一部。名为杂藏。合名为修多罗藏。我等已集法竟。从今已后。佛所不制不应妄制。若已制不得有违。如佛所教应谨学之

阿难复白迦叶言。我亲从佛闻。吾般泥洹后若欲除小小戒听除。迦叶即问。汝欲以何为小小戒。答言不知。又问何故不知。答言不问世尊。又问何故不问。答言时佛身痛恐以恼乱。迦叶诘言。汝不问此义犯突吉罗。应自见罪悔过。阿难言。大德。我非不敬戒不问此义。恐恼乱世尊。是故不敢。我于是中不见罪相。敬信大德今当悔过。迦叶复诘阿难言。汝为世尊缝僧伽梨以脚指押犯突吉罗。亦应见罪悔过。阿难言。我非不敬佛。无人捉綦是以脚押。我于是中亦不见罪相。敬信大德今当悔过。迦叶复诘阿难言。汝三请世尊求听女人于正法出家。犯突吉罗。亦应见罪悔过。阿难言。我非不敬法。但摩诃波阇波提瞿昙弥。长养世尊至大出家致成大道。此功应报是以三请。我于此中亦不见罪相。敬信大德今当悔过。迦叶复诘阿难言。佛临泥洹现相语汝。若有得四神足。欲住寿一劫若过一劫便可得之。如来成就无量定法。如是三反现相语汝。汝不请佛住世一劫若过一劫。犯突吉罗。亦应见罪悔过。阿难言。我非不欲请佛久住。恶魔波旬厌蔽我心。是故致此。我于此中亦不见罪相。敬信大德今当悔过。迦叶复诘阿难言。佛昔从汝三反索水。汝竟不奉。犯突吉罗。亦应见罪悔过。阿难言。我非不欲奉。时有五百乘车上流厉渡水浊未清。恐以致患是以不奉。我于此中亦不见罪相。敬信大德今当悔过。迦叶复诘阿难言。汝听女人先礼舍利。犯突吉罗。亦应见罪悔过。阿难言。我非欲使女人先礼舍利。恐其日暮不得入城。是以听之。我于此中亦不见罪相。敬信大德今当悔过。阿难敬信大迦叶故。即于众僧中作六突吉罗悔过

迦叶复诘阿难言。若我等以众学法为小小戒。余比丘便言。至四波罗提提舍尼亦是小小戒。若我等以至四波罗提提舍尼为小小戒。余比丘便复言。至波逸提亦是小小戒。若我等以至波逸提为小小戒。余比丘便复言。至尼萨耆波逸提亦是小小戒。俄成四种何可得定。迦叶复言。若我等不知小小戒相而妄除者。诸外道辈当作是语。沙门释子其法如烟。师在之时所制皆行。般泥洹后不肯复学。迦叶复于僧中唱言。我等已集法竟。若佛所不制不应妄制若已制不得有违。如佛所教应谨学之

时长老富兰那在南方。闻佛于拘夷城般泥洹诸长老比丘共集王舍城论比尼法。自与眷属如屈伸臂顷来到众中语迦叶言。我闻佛泥洹上座比丘皆共集此论比尼法。为实尔不。迦叶答言。大德实尔。富兰那言。可更论之。迦叶即如上更论。论已富兰那语迦叶言。我亲从佛闻。内宿内熟自熟自持食从人受自取果食就池水受无净人净果除核食之。迦叶答言。大德。此七条者。佛在毗舍离时世饥馑乞食难得故权听之。后即于彼还更制四。至舍卫城复还制三。富兰那言。世尊不应制已还听听已还制。迦叶答言。佛是法主于法自在。制已还听听已还制有何等咎。富兰那言。我忍余事于此七条不能行之。迦叶复于僧中唱言。若佛所不制不应妄制。若已制不得有违。如佛所教应谨学之。尔时拘舍弥阐陀比丘触恼众僧不共和合。有一比丘安居竟往迦叶所。具以事白。迦叶语阿难言。汝往拘舍弥。以佛语僧语作梵坛法罚之。阿难受使。与五百比丘俱往。阐陀闻阿难与五百比丘来出迎。问阿难言。何故来此。将无与我欲作不益耶。答言。乃欲益汝。阐陀言云何益我。答言。今当以佛语僧语作梵坛法罚汝。即问。云何名梵坛法。答言。梵坛法者。一切比丘比丘尼优婆塞优婆夷不得共汝来往交言。阐陀闻已闷绝躄地。语阿难言。此岂不名杀于我耶。阿难言。我亲从佛闻。汝当从我得道。汝起为汝说法彼便起听。阿难为说种种妙法示教利喜。即远尘离垢于诸法中得法眼净

集比尼法时。长老阿若憍陈如为第一上座。富兰那为第二上座。昙弥为第三上座。陀婆迦叶为第四上座。跋陀迦叶为第五上座。大迦叶为第六上座。优波离为第七上座。阿那律为第八上座。凡五百阿罗汉不多不少。是故名为五百集法

    五分律第五分之十七百集法

佛泥洹后百岁。毗舍离诸跋耆比丘始起十非法。一盐姜合共宿净。二两指抄食食净。三复坐食净。四越聚落食净。五酥油蜜石蜜和酪净。六饮阁楼伽酒净。七作坐具随意大小净。八习先所习净。九求听净。十受畜金银钱净。彼诸比丘常以月八日十四日十五日盛满钵水。集坐多人众处。持钵着前以为吉祥。要人求施。时诸白衣男女大小经过前者。便指钵水言。此中吉祥。可与衣钵革屣药直。有欲与者与之。不欲与者便讥呵言。沙门释子不应受畜金银及钱。设人自与不应眼视。而今云何作此求施。时长老耶舍迦兰陀子。在彼猕猴水边重阁讲堂。语诸比丘言。汝莫作此求施。我亲从佛闻。若有非法求施施非法求二俱得罪。语诸比丘已。复语诸白衣男女大小。汝等莫作此施。我亲从佛闻。若非法求施施非法求二俱得罪

彼诸比丘得金银钱已。语耶舍言。大德可受此分。答言。我不受非法求得施分。复语言。若不自受可以施僧。答言。我既不受云何施僧。于是诸比丘便以耶舍前教白衣为骂白衣。与作下意羯磨。羯磨已耶舍言。我亲从佛闻。若僧与作下意羯磨。应差一比丘为伴谢诸白衣。诸比丘便白二羯磨差一比丘伴之。耶舍即将至白衣所。正值五百优婆塞聚在一处。便语之言。诸君当知。是法我说是法。非法我说非法。是比尼我说是比尼。非比尼我说非比尼。是佛教我说是佛教。非佛教我说非佛教。我先所说使诸优婆塞嗔。今来谢过。诸优婆塞皆大惊言。大德。何时为我等说是法是比尼是佛教。使我等嗔而来见谢。耶舍更语诸人言。世尊一时在王舍城耆域庵罗园。时瓶沙王诸大臣共集王门作如是议。沙门释子应受畜金银珠宝及用贩卖。时彼众中有一大臣名珠髻语众人言。勿作此议。沙门释子不应受畜金银珠宝及用贩卖。即以此事往白世尊。我之所说将无过谬。佛言。汝之所说正得其中。所以者何。我常说此沙门释子不应受畜金银珠宝及用贩卖。复白佛言。唯愿世尊。遣告众人令知非谬。佛言大善。又告珠髻。譬如日月为烟云尘阿修罗四曀所蔽不明不净。沙门婆罗门有四种曀亦复如是。或不断爱欲行于淫法。或耽酒食不能除断。或专作邪命以自给活。或受畜金银珠宝及用贩卖。若人以五欲为净。是人则以受畜金银珠宝及用贩卖为净。若人以受畜金银珠宝及用贩卖为净。是人则以五欲为净。若人依我出家受具足戒。而以受畜金银珠宝及用贩卖为净者。当知是人必定不信我之法律。我虽常说须车求车须人求人随所须物皆听求之。而终不得受畜金银珠宝及用贩卖。耶舍说此已又言。我先说是法非法是律非律是佛教非佛教是佛所说非佛所说。诸优婆塞言。我等于此语中无不信乐。今毗舍离唯有大德。是沙门释子。愿受我等尽寿住此四事供养

耶舍谢诸优婆塞已。与僧使比丘俱还僧坊。跋耆比丘问僧使比丘言。耶舍比丘已谢诸优婆塞未。答言已谢。但诸白衣皆信其语。咸作是言。今毗舍离唯有大德。已请尽寿四事供养。于我等辈无复宜利。跋耆比丘复以耶舍前教诸比丘为骂僧犯波逸提。语言。汝当见罪悔过。耶舍答言。我无罪可见云何悔过。跋耆比丘便聚集。欲与作不见罪羯磨。于是耶舍便以神足飞往波旬国。时波利邑有六十比丘。皆是阿练若三衣乞食粪扫衣常坐露地坐具足三明六通。悉是阿难弟子。俱共飞来向毗舍离。耶舍见之。便置衣钵于虚空中犹如着地。与彼比丘共相问讯。具说跋耆比丘十种非法。语言大德。我等当共论比尼法以灭斯事。勿使跋耆比丘破于正法。彼比丘莫逆于心欲共同灭。复有三十波利邑比丘。德皆如上。亦是阿难弟子。在摩偷罗国。耶舍与六十比丘作是议言。得彼三十比丘同我等者。必得如法灭彼恶事。议已便共飞往彼比丘所。具如上说彼亦莫逆于心欲共同灭。复有波利邑三十比丘听皆如上。亦是阿难弟子。在阿腊脾邑。耶舍复与九十人作如上议。往到其所具如上说。彼亦同心欲共灭之。时长老三浮陀在阿哹山上。耶舍复共百二十人作如上议。往到其所具如上说。彼亦同心欲共灭之。时长老离婆多在拘舍弥城。得慈心三昧有大眷属。耶舍复与百二十一人亦如上议。往到其所具如上说。彼亦同心欲共灭之。时跋耆诸比丘。闻耶舍往拘舍弥离婆多所。便载满船沙门衣钵诸所须物。亦欲往彼行货求助。其船中伴有一持律比丘名沙兰。窃独思惟。跋耆比丘为如法不。即依诸经律察其所为。为不如法。时空中神三反唱言。如是如是。跋耆比丘所行非法。如汝所见。跋耆诸比丘到拘舍弥。皆共上岸到长老离婆多所白言。我等多载沙门所须之物来奉大德。愿为纳受。答言。我衣钵具足不复须之。又白言。若不多须愿受少许。答言。我衣钵已备不得为汝亏法有受。离婆多有一弟子名曰达磨。常侍左右。跋耆诸比丘便往其所语言。我有沙门所须之物。若有短乏便可取之。答言。我皆自有无所乏少。跋耆诸比丘复言。佛在世时人来施佛。佛不受者以施阿难。阿难皆受。阿难既受则是佛受。达磨闻之为受一物。受已问言。汝等何意强施我物。答言。欲汝为我白汝和尚以力见助不令耶舍坏我法律。达磨便为往和尚所白言。和尚可助跋耆比丘。答言。行非法人我所不助。达磨复白。愿更筹量。答言。汝今劝我助非法人非我弟子。从今勿复在我左右。我亦不复共汝语言。达磨愧惧。出到跋耆诸比丘所。彼皆问言。汝和尚有助我意不。答言无有。徒令我今为汝受责得不共语摈。跋耆诸比丘问言。汝今几岁。答言二十岁。便言汝年德如此。何忍作此不共语摈。于是长老离婆多作是念。我若于此灭彼事者。彼造事人必更发起。今当共往就彼灭之。念已便与大众俱之毗舍离城。彼城先有比丘名一切去。于阎浮提沙门释子中最为上座。得阿罗汉三明六通。亦是阿难最大弟子。耶舍于僧坊外语离婆多。可往上座房敷卧具宿并具白上事。我晨朝亦当问讯上座。众人既入僧房。彼上座为办浴具设过中浆。离婆多独往上座房中敷卧具宿。离婆多夜作是念。此一切去羸老上座。犹尚克厉竟夜坐禅。我今何宜而得安寝。一切去亦作是念。此客比丘行路疲极复兼洗浴。犹尚竟夜坐禅行道。我今云何而得安卧。二人相推遂竟夜坐禅。至后夜时。一切去问离婆多言。汝今夜多游何定。答言我性多慈。今夜多游此定。一切去言。此是粗定。又问汝是阿罗汉非。答言是。离婆多次问一切去言。上座今夜多游何定。答言我性好空观。今夜多游此定。离婆多言。比是大人所行。何以故。空三昧是大人法。又问上座。是阿罗汉不。答言是。后夜竟已。耶舍比丘到房前弹指。上座开户。即入问讯。问讯已。离婆多问一切去言。盐姜合共宿净不。答言。此事应僧中问。若独问我。恐非法人以我为私。不容我作论比尼数。于是离婆多即集僧。欲论比尼而多乱语。便白僧言。今日欲共论毗尼法。而多乱语不得有断。彼此众应各求四人僧为白二羯磨差为断事主。跋耆比丘先求四人。一名一切去。二名离婆多。三名不阇宗。四名修摩那。波利邑比丘亦求四人。一名三浮陀。二名沙兰。三名长发。四名婆沙蓝。诸上座被僧差已共作是议。何许地闲静平旷。可共于中论比尼法。即遍观察。唯毗罗耶女所施园好。离婆多即使弟子达磨往彼敷座。若上座至汝便避去。受敕即敷。诸上座至次第而坐。于是离婆多问一切去上座言。盐姜合共宿净不。答言不净。又问在何处制。答言在王舍城。又问因谁制。答言因一阿练若比丘。又问犯何事。答言犯宿食波逸提。离婆多言。此是法此是律此是佛教。跋耆比丘所行非法非律非佛教。今下一筹。离婆多复问。两指抄食食净不。上座问。云何名两指抄食食净。离婆多言。比丘足食已更得食以两指抄食之。答言不净。又问在何处制。答言在王舍城。又问因谁制。答言因跋难陀。又问犯何事。答言犯不作残食法食波逸提。离婆多言。此是法乃至非佛教。今下第二筹。复坐食净越聚落食净亦如是。下第三第四筹。离婆多复问。酥油蜜石蜜和酪净不。上座问。云何名酥油蜜石蜜和酪净。离婆多言非时饮之。答言不净。又问在何处制。答言在舍卫城。又问因谁制。答言因迦留陀夷。又问犯何事。答言犯非时食波逸提。离婆多言。此是法乃至非佛教。今下第五筹。离婆多复问。饮阇楼伽酒净不。上座问。云何名阇楼伽酒。离婆多言。酿酒未熟者。答言不净。又问在何处制。答言在拘舍弥。又问因谁制。答言因沙竭陀。又问犯何事。答言饮酒波逸提。离婆多言。此是法乃至非佛教。今下第六筹。离婆多复问。作坐具随意大小净不。答言不净。又问在何处制。答言舍卫城。又问因谁制。答言因迦留陀夷。又问犯何事。答言犯波逸提。离婆多言。此是法乃至非佛教。今下第七筹。离婆多复问。习先所习净不。上座问。云何名习先所习。离婆多言。习白衣时所作。上座言。或有可习或不可习。离婆多言。此是法乃至非佛教。今下第八筹。离婆多复问。求听净不。上座问。云何为求听。离婆多言。别作羯磨然后来求余人听。答言不净。又问何处制。答言在瞻婆国。又问因谁制。答言因六群比丘。又问犯何事。答言随羯磨事。离婆多言。此是法乃至非佛教。今下第九筹。离婆多复问。受畜金银及钱净不。答言不净。又问在何处制。答言在王舍城。又问因谁制。答言因难陀跋难陀。又问犯何事。答言犯受畜金银及钱尼萨耆波逸提。离婆多言。此是法乃至非佛教。今下第十筹。问竟共还更都集僧。离婆多于大众中。更一一如上问一切去。下一筹乃至第十筹。于是离婆多唱言。我等已论比尼法竟。若佛所不制不应妄制。若已制不得有违。如佛所教应谨学之。尔时论比尼法众。第一上座名一切去。百三十六腊。第二上座名离婆多。百二十腊。第三上座名三浮陀。第四上座名耶舍。皆百一十腊。合有七百阿罗汉。不多不少。是故名为七百集法

五分律卷第三十罽宾律师佛陀什。弥沙塞部僧也以大宋景平元年秋七月达于扬州。冬十一月。晋侍中琅琊王练比丘释慧严竺道生。请令出焉。佛陀什谨执梵文。于填沙门智胜为译。至明年十二月都讫。考正理归文存简备。虽不穷原庶无大过。愿以尘露崇广山海。贻于万代同舟云尔


弥沙塞羯磨本

    No. 1424 [cf. No. 1421]

弥沙塞羯磨本

        大开业寺沙门爱同录五分羯磨

夫羯磨众轨溥应圣凡秉告详唱称为办事。事既尘沙法宁限局。规猷浩博岂可胜言。且开十法以总诸务。各依其位具列轨仪

  第一作法缘起　　第二诸界结解
  第三诸戒受舍　　第四衣药受净
  第五布萨仪轨　　第六安居法则
  第七自恣清净　　第八受施分衣
  第九忏悔诸犯　　第十住持杂法

第一作法缘起(要具七缘。方成羯磨。有不具者。开制故然)

一量事如非(羯磨既称办事。所办必须如法。违教亏戒圣所未听。事类虽多大分三种。一情如受戒。第二非情如结界。第三二合如示处等。或言三者谓人法事也。人即受戒等。法谓自恣等。事谓结净等。此二三种称事。并如或具或单离合无准。必须约教。不违于戒无犯。如亏此限。法定不成。法等落非。亦准于此)

二法起假处(僧祇律云。非羯磨地。不得受欲行于僧事。四分律云。若作羯磨必先结界。然界有二种。若自然界。唯秉结界羯磨一法。自余僧法并作法界中。若对首心念二法。则通二界)

三集僧分限(法起托处。依界集僧。界有二种。自然作法。二别谓大界戒场。据四分中有三小界。此律辩界或有或无。小界一种无外可集。大界戒场尽限集之。若自然界。则四分聚落兰若道行水界。聚落有二种。可分不可分。若不可分别。僧祇七树之量。计有六十三步。可分别者。十诵尽界集之。兰若亦二。有难无难。若无难者。此律云。练若比丘不知己界齐几许。佛言。自然界面去身二拘卢舍。诸部多云。一拘卢舍者。大小不定。且依杂宝藏经云。五里为准。若有难者如善见论。七盘陀罗。盘陀罗者。二十八肘。通计而论。五十八步四尺八寸。道行界者。十诵律纵广有六百步。言水界者。此律所明船上作法。以有力人若水若沙掷所及处。此之六种并是自然。皆取身面所向方隅。分限之内僧须尽集。集僧方轨诸教共明。此律集僧自分四别。一三唱。时至应使沙弥守园人于高处唱。二打揵捶。除漆树毒树。以鸣木作三打鼓。除金银。以铜铁瓦木作。四吹螺。应吹海螺。然揵捶一种。若也无人。比丘打之。亦不得过三通。付法藏传令有长打。三千威仪中具明杵下之数)

四简众是非(体是比丘如法清净是作法人。余非此限。故须简择。此律有一十三人。不足僧数。一非人。二白衣。三灭摈。四被举。五自言。六不同见。七狂。八散乱心人。九病坏心人。十比丘尼。十一式叉摩那。十二沙弥。十三沙弥尼。然四分中具彰四例。一者得满数不得呵。谓呵责等四羯磨人是。二者不得满数应呵。谓若欲受大戒人。三不得满数不得呵谓尼等四众十三难人三举二灭若别住若戒场若在空。若隐没若离见闻。若所为人。此二十八人是人覆藏等四及覆藏竟本日治竟六夜竟。此上七人不相足数。十诵律又云。睡眠人乱语人愦闹人入定人哑人聋人狂人乱心人病坏心人树上人白衣人。十二人不成受戒足数。磨德勒伽论云。重病人边地人痴钝人。此三人不成满众。僧祇云若与欲人若隔障若半覆申手不相及若众僧行作羯磨住坐卧等皆不足数。此律病人皆羯磨说戒。佛言。别众如舍戒中中边不相解等皆非足数。此上诸人并是不得满数不得呵。四者得满数呵。若善比丘同一界住。不离见闻处。乃至语谤人等是。即上诸不足数人。若以相足并不羯磨)

五和合无别(故律云。应来不来。应嘱授不嘱授。羯磨时得诃人不同。而强羯磨。是名别众。即此文中。有三别众及别名目和。和唯是一嘱授之法。具如下列)

六问答所作(秉法者应问云。今僧和合先作何事。众中一人应答云。作某羯磨。但事有总别。答亦通两。若结界理无双答)

七羯磨如法(具上六缘。合秉羯磨。羯磨之法又有如非。具离诸非方名办事。略显非相。及以成如也)

僧法羯磨文有六非(文中辩非或一四五。据相总论不过六种。若准余文及四分律。有呵不止非。即可为七)

一余法余律羯磨(谓僧法处事随一不如。所作羯磨皆不成就。非正轨则正调伏。并名为余。此据总说。下约别明也)

二非法别众羯磨(谓词句增减不依圣教。翻非即如。验文可晓。别众三种如上所陈。三种和合相翻即是也)

三非法和合羯磨(人虽和合法落非中)

四如法别众羯磨(羯磨虽如众不详集)

五似法别众羯磨(词句颠倒别众如前)

六似法和合羯磨(似法同前。和合为异。准文更有无事作非法事。不现前界界外施秉体未成僧不应解等。此并僧界事中不应圣教。并初非摄。不别陈之)

第二结解诸界法(界有三种一摄僧界。摄人以同法令无别众愆。二摄衣界。摄衣以属人令无离宿罪。三摄食界。摄食以障僧令无二内过。今依此三次第辩相也)

第一结解僧界法(律云。时世饥馑。余处比丘集王舍城。僧房皆空无人守护。因开各解本界通结一界。后时丰足。解通已还结小界。又初缘时为界内不集别众受戒。遂开界外结小界受。名曰戒坛。若受戒竟。应舍于坊内作受戒。又为比丘将受戒人至坛处遇贼被剥。因听于坊内作受戒场。应先舍僧坊界然后结界戒场。唱相除内地更结僧坊界。此则先结戒场后结大界。先界外结者。是对难结小界。非即是戒场。若是者。何故令舍。古今皆云。五分初缘安置戒场在界外者据文不然。今依次第有其二位。一戒场二大界。今且依此。依具结解之仪)

第一结戒场法(欲结之时依前集僧。四分律云。不得说欲。此虽无文理亦同彼。集众问和具方便已。先唱四方界相。然后白二结之)

唱四方界相法(律云。先应一比丘唱四方界相。若不唱相不成结界。犯突吉罗。不得以众生及烟火作相。不得两界相并相入。皆不成结。犯突吉罗。四分云。应令旧住比丘唱相。意取谙委界相。纵非旧住。但委识方所。亦得令唱。相之人应具威仪。敷尼师坛脱革屣。礼众僧已。合掌白云也)

大德僧听。我比丘为僧唱四方戒场相。从此东南角某标。至西南角某标。从此至西北角某标。从此至东北角某标。从此还至东南角某标。此戒场相一周讫(三说。必有屈曲门户多少。并须具牒称事分明。所标相极须彰显。若错涉差互乖文及唱相违失。并不成结界。既不成后秉诸法并不成就。此既根本。特须详审也)

正结戒场法

大德僧听。如某甲比丘所唱界相。今僧结作戒坛共住共布萨共得施。若僧时到僧忍听。白如是。大德僧听。如某甲比丘所唱界相。今僧结作戒坛共住共布萨共得施。谁诸长老忍默然不忍者说。僧已结某甲比丘所唱界相作戒坛共住共布萨共得施竟。僧忍默然故。是事如是持(依四分律不牒二同。此摽三共。与彼宗异)

解戒场法(诸比丘既结戒场。不舍而去。佛言。应白二羯磨舍界。方便如前)

大德僧听。此结界处。僧今舍是界。若僧时到僧忍听。白如是。大德僧听。此结界处。僧今舍是界。谁诸长老忍默然不忍者说。僧已舍是界竟。僧忍默然故。是事如是持(文无三共者以背界故也)第二结大界法(律云。结戒坛已更结僧坊界。应一比丘唱四方界相。又唱除内地。即据此文。应安两重标相。一大界外相二大界内相。其外相者。住处方圆斜正大小规矩无定。故诸论中。界形有五或十七等。随其前事即以为标。牓标内外任以为相。其内相者。标相。准前所除多少住处宽狭。但分两界勿相并入。古云。一肘实为胶柱。作法方便唱相法则。一准于前)

唱相法(威仪同前)

大德僧听。我比丘为僧唱四方大界内外相。唱外相。从此东南角某标。乃至还至东南角某标。此是大界外相一周讫(三说。内相准此。但称内相为异。各三说讫。后总云。彼为外相此为内相。此是大界内外相三周讫)

正结大界法

大德僧听。此某甲比丘。唱四方界相及除内地。今僧结作僧大界共住共布萨共得施。若僧时到僧忍听。白如是。大德僧听。此某甲比丘。唱四方界相及除内地。今僧结作僧大界共住共布萨共得施。谁诸长老忍默然不忍者说。僧已结某甲比丘唱四方界相及除内地作僧大界共住共布萨共得施竟。僧忍默然故。是事如是持(若无戒场不除内地。但除内地一句为异)

解大界法(方便如前)

大德僧听。此一住处。僧共住共布萨共得施。先结此界今解。若僧时到僧忍听。白如是。大德僧听。此一住处。僧共住共布萨共得施。先结此界今解。谁诸长老忍默然不忍者说。僧已解先所结界竟。僧忍默然故是事如是持(此解界文牒三共者。表与戒场大小为异)

第二结解衣界法(因憍陈如持粪扫衣路行疲极。故开此法。界大蓝小。方可须结。蓝大或等。并不用之)

大德僧听。此结界处聚落中(谓城堑篱栅之内也)

若聚落界(谓城堑等外人所行处。及有惭愧人大小行处。上之二处。四分十诵并悉除之。今不除者宗殊故也)

共住共布萨共得施。今结作不失衣界。若僧时到僧忍听。白如是。大德僧听。此结界处聚落界共住共布萨共得施。今结作不失衣界。谁诸长老忍默然不忍者说。僧已结作不失衣界竟。僧忍默然故。是事如是持

解衣界法

大德僧听。此结界处聚落中若聚落界。先结作不失衣界。僧今解之。若僧时到僧忍听。白如是。大德僧听。此结界处聚落中若聚落界。先结作不失衣界。僧今解之。谁诸长老忍默然不忍者说。僧已解不失衣界竟。僧忍默然故。是事如是持(初结僧先后解僧后)

第三结食界法(净有三种并文具显)

一他处净(有一织师。中路起屋。比丘欲于屋中作食安食。佛言。听于白衣舍作净屋。后以施僧。亦听为净屋)

二处分净(佛言。若作新住处。应先指某处作净地。便可安食。若未羯磨不得入中至明相出。有云。未羯磨者谓简净地羯磨。今正以处分为羯磨)

三羯磨净(诸比丘着食净屋中为人所偷。佛言。应羯磨中房作净处。诸比丘欲羯磨一房墙内。或齐屋溜处。或于中庭。或房一角。或半房等作净地。佛言听。应在院外结之律。虽无文义。应唱相言也)

大德僧听。我比丘为僧唱安食净处。此僧伽蓝内东厢厨院中。结作净地(三说若庭中房内或诸果树下并随处称之)

大德僧听。今以某房作僧安食净处。若僧时到僧忍听。白如是。大德僧听。今以某房作僧安食净处。谁诸长老忍默然不忍者说。僧已以某房作僧安食净处竟。僧忍默然故。是事如是持解法(律无解文翻结为解)

大德僧听。彼某房先作僧安食净处。僧今解之。若僧时到僧忍听。白如是。大德僧听。彼某房先作僧安食净处。僧今解之。谁诸长老忍默然不忍者说。僧已解某房安食净处竟。僧忍默然故。是事如是持(若有多处一时。标名解结亦得若处分净。还以处分解之也)

通结僧坊作净地法(有比丘欲通羯磨僧坊内作净地。佛言听)

大德僧听。此一住处共住布萨共得施僧。今结作净地。除某处(有云。除某处者。谓除净地。故知此是简净地法。今云。除者谓僧住处。为通结故。所以言除。此即结文。非简法也)

若僧时到僧忍听。白如是。大德僧听。此一住处共住共布萨共得施。僧今结作净地。除某处。谁诸长老忍默然不忍者说。僧已结作净地竟。僧忍默然故。是事如是持解法大德僧听。此一住处先结作净地。僧今解之。若僧时到僧忍听。白如是。大德僧听。此一住处先结作净地。僧今解之。谁诸长老忍默然不忍者说。僧已解净地竟。僧忍默然故。是事如是持

(净地之所为。防二。内煮宿。食药。教称不净。以此而啖垢业滋深。护净诸教明显。但食为同命。凡圣所凭。信教存道。特宜诫慎)

第三诸戒受舍(受之意者。一拟防非断。除业惑。二为生福证显法身故。戒经云。戒为净身。定为净心。慧清烦恼。若无明慧烦恼不除。若无正定明慧不发。若无禁戒正定不成也。以圣人业惑虽尽犹持禁戒固若金刚。三教显功诚说非一。然禁通俗戒分多品。始微终着。位列五科。一三归。二五戒。三八戒。四十戒。五具戒。能受之人约位有七。即谓七众。如下具彰也)

第三受三归法(佛法与僧。真归依处。能生福智。能为覆护。归趣依投。越四魔境。多论云。以三宝为所归。欲令救护不得侵陵。涅槃经三跳明过厄难。既创翻邪。故标为首。佛谓清净法身。二智显证五分成立。法谓灭谛。僧谓第一义。僧于此境诚心决定崇重僧向受无疑二师授资顺明了方成也)

我某甲尽形受。归依佛。归依法。归依比丘僧(三说)我某甲尽形受。归依佛已归依法已。归依比丘僧已(三说)

第二受五戒法(希有希有校量功德经云。佛告阿难若三千大千世界满中如来。如稻麻竹[竺-二+韋]。若人四事具足供养。满二万岁。诸佛灭后各起宝塔。复以香华种种供养。其福虽多。不如有人以淳净心归依佛法僧所得功德。百分不及一。千分百千分乃至算数譬喻所不能及。复以一弹指顷十善戒福转胜前。一日一夜受持八戒。若尽形受持五戒。若沙弥戒。沙弥尼戒。式叉摩那戒。比丘尼戒。若比丘戒。福转胜前不可为喻。然于受戒前。须具问遮难。故善生经云。汝不盗现前僧物不。于六亲所比丘比丘尼所行不净行。父母师长有病弃去。不杀发菩提心众生。如具问已。若言无者。应为说法开导心怀令生信乐。智度论中。时局尽形数定。谓一分少分多分满分断淫等五。俱舍论中。五种定限不发律仪。教既被机任时行用。阿含经云。于受戒前忏悔罪已。然后与受也)

我某甲。归依佛归依法归依僧。尽形寿为优婆塞。如来至真等正觉。是我世尊(三说)我某甲。归依佛竟归依法竟归依僧竟。尽形寿为优婆塞。如来至真等正觉。是我世尊(三说已得戒竟应为说相)尽形寿不杀生。是优婆塞戒。能持不。(答言能持)尽形寿不偷盗。是优婆塞戒。能持不。(答言能持)尽形寿不邪淫。是优婆塞戒。能持不。(答言能持)尽形寿不妄语。是优婆塞戒。能持不。(答言能持)尽形寿不饮酒。是优婆塞戒。能持不。(答言能。前四轻重一同具戒。如优婆塞五戒相经说。及有六重二十八轻。如善生等经广说。然应发愿引行令增。然有经云。设有持戒。不发愿者。得少许福。引古证之)

第三受八戒法(善生经增一阿含经云。佛告优婆塞。当于八日十五日。诣长老比丘所受八戒。论中总许五众受之。若无人时自受亦得。成实论中。五戒八戒俱通长短。或一年一月半日半夜。重受减受并得戒法)

我某甲。归依佛归依法归依僧。(一日一夜随长短称)为净行优婆塞。(三说)我某甲。归依佛竟归依法竟归依僧竟。(一日一夜随长短称)为净行优婆塞。(三说)如诸佛尽形寿不杀生。某甲一日一夜不杀生。能持不。(答言能持)如是不偷盗。不淫。不妄语。不饮酒。离花香璎珞香油涂身。离高广胜床上座。离作倡伎乐故往观听。非时食。(并如上问答。然有以前八是戒。后离非时食一是斋。或有以第七第八合为第七离。非时食为第八戒)

第四受十戒法(此下三品。是出家戒。但出家之益难以言宣。出家功德经云。出家功德。高于须弥。深于巨海。广于虚空。无量无边胜明千人之眼。又胜救千人之目。僧祇律云。一日出家修梵行。灭二十劫恶道苦。大悲经云。若以袈裟四寸着身。五种功德不。出贤劫之中当证三乘圣果。若障出家罪。则极重广有成教。何能繁述)

先明作畜众法(准受戒法中。若授人具足戒。度沙弥。为人作依止。皆应具多种德。谓成就戒。成就威仪。畏慎小罪。多闻能持佛所说法。善诵二部律分别其义。能教弟子增戒增心增慧。能除弟子疑。能使人除。能治弟子病。能使人治。能教弟子舍恶邪见。能令人教舍。能回弟子国土觉。能使人回。若满十岁等。违者突吉罗。尼戒中云。比丘尼虽满十二岁。种种诸病及无所知。而畜弟子不教诫故。愚闇无知不能学戒。佛言。听诸比丘尼白二羯磨然后畜众。比丘准尼义亦应有。又四分中。时诸比丘辄便度人。不知教授种种起过。佛言。听僧与受具足者白二羯磨畜。依止沙弥亦尔。文言。应到僧中脱革屣偏袒右肩胡跪合掌乞云)

大德僧听。我某甲比丘。已满十岁欲畜众。从僧乞僧畜众羯磨。善哉僧。与我作畜众羯磨。(如是三乞。佛言。诸比丘应筹量观察。此比丘堪畜众不。不堪不应与作羯磨。若堪应与作羯磨也)

大德僧听。此某甲比丘。已满十岁欲畜某甲为众。从僧乞畜众羯磨。僧今与作畜众羯磨。若僧时到僧忍听。白如是。大德僧听。某甲比丘已满十岁。欲畜某甲为众。从僧乞畜众羯磨。僧今与作畜众羯磨。谁诸长老忍默然不忍者说。僧已与某甲比丘作畜众羯磨竟。僧忍默然故。是事如是持

初度沙弥法(律中。听度七岁小儿能驱乌者。僧祇云。若过七十坐起须人不得度。若能修习诸业亦听出家。应为说苦事。一食一住一眠多觉。若能者应度此律。若欲度人。房房礼僧足。自称名字。令僧尽识。依四分律。作形法二问。单白羯磨度之。仪式钞中委述)

正受十戒法我某甲。归依佛归依法归依比丘僧。我今于释迦牟尼如来应供等正觉所。出家作沙弥。和上某甲。(三说)我某甲。归依佛竟归依法竟归依比丘僧竟。我今于释迦牟尼如来应供等正觉所。出家作沙弥。和上某甲。(三说)尽形寿不杀生。是沙弥戒。能持不(答言能持)不偷盗。不淫。不妄语。不饮酒。不歌舞作倡伎乐。不往观听。不着花香涂身。不坐高广大床上。不受畜金银及钱(皆如上问答。依请僧福田经。沙弥应知五德十数。此既常行应如钞列)

第五受大戒法(戒为生死舟船。定慧根本。三身四智无不凭斯。必须缘法相应称教具足。如一乖阙戒品不生。但缘繁多岂能委叙。今且大概要具五如。一能受人如。此有五种。一报是人道。二诸根具足。三身器清净。四出家相具。五得少法。二所对境如。此有七种。一结界成就。二有能秉法僧。三僧数满足。四界内尽集。五羯磨如法。六资缘具足。七佛法时中。三发心乞戒。四心境相应。五事成究竟。谓从请终千受竟。前后不亏方成办事。正授戒中须具九法)

一请和上法(律云。诸比丘无和上阿阇梨故威仪失节不系念在前。不善护诸根入聚落乞食。高声乱语被讥呵。复有病比丘。无人瞻视由此命终。佛从今以十利故。听诸比丘有和上。和上自然生心爱念弟子如儿。弟子生心敬重和上如父。勤相教诫更相敬叹。能增广佛法使得久住。所请和上须具德位。谓成就威仪畏罪多闻诵二部律。能教弟子增戒心慧。能为弟子除疑治病使舍邪见国土觉等。若满十岁。律有多法不能备载。度沙弥依止亦如是。其共别行法如律具明。请之法式。应偏袒右肩脱革屣胡跪合掌请云)

我某甲。今求尊为和上。尊为我作和上。我乐尊为和上故。得受具足戒(三说和上应答云)可尔(或言)当教授汝(或言)汝莫放逸(二阿阇梨亦须加请)二安受戒人(佛言。听将受戒人着戒坛外眼见耳不闻处)

三差教师法(和上应语羯磨师云)长老今作羯磨(复语教师云)长老今受羯磨(如是差已羯磨师云)大德僧听。某甲求某甲受具足戒。某甲作教师若僧时到僧忍听。白如是。四教师捡(一问和上二问受人。先问和上。应起至和上前云)

已度此人未(若言未应语言)先度之(若言已度应语言)为作和上未(若言未应语为作和上若言已作应问云)

弟子衣钵具不(若言未具。应语为具。若言已具应问云)

为自有从人借(若言从人借令舍。若自有。便往慰劳受者云)

汝莫怖惧。须臾持汝着高胜处。何者是僧伽梨。何者是优多罗僧。何者是安陀会(若言不解者。应教诫之。应与三衣钵。若先不相识。不应云雾闇时为教。着时应密[禾*見]。无重病不。又应语云)

汝某甲听。今是实语时。我今问汝。若实言实。不实言不实(僧祇云。汝若不实答。便欺诳天魔梵沙门婆罗门诸天世人。亦欺诳如来及以众僧。自得大罪也)

汝不杀父耶。汝不杀母耶。汝不杀阿罗汉耶。汝不恶心出佛身血耶。汝不破和合僧耶。汝不犯比丘尼耶。汝非非人耶。汝非畜生耶。汝非黄门耶。汝非二形耶。汝非自剃头自称比丘耶。汝非舍内外道耶。汝不曾出家持戒不完具耶(随问答皆言无者又应问言)人有如是等病。癞痈疽干痟癫狂漏热肿脂出有不。汝非负债人不。非官人不。非奴不。年满二十不。衣钵具不。受请和上未。汝字何等。和上字何等。父母听不。欲受具足戒不(如是问答又应教云)众中更当如是问汝。汝亦应如实答(一一问答皆如法已)五召入众法(教师应还坛上立语羯磨师云)我已教授某甲如法竟(羯磨师应作白)大德僧听。某甲。求某甲受具足戒。某甲如法教授竟应使将来。若僧时到僧忍听。白如是

六教乞戒法(教师应将来至僧。次第礼僧足。向羯磨师右膝着地合掌。教师教乞戒云)

大德僧听。我某甲。求某甲和上受具足戒。今从僧乞受具足戒。愿僧拔济我。怜愍故(三说已教师还就本坐)七戒师问白法(羯磨师应作白云)大德僧听。此某甲。求某甲受具足戒。今从僧乞受具足戒。我今当问诸难事。及为作受具足戒羯磨。若僧时到僧忍听。白如是八羯磨师问法(应问言。今是实语时。乃至欲受具足戒不。一一如上教师问法也)

九正授戒法(萨婆多论云。凡欲受戒。先为说法开导心怀。令于一切有情境上起慈悲心。誓救一切众生。令离五趣证三乘果。勿求自度。受持禁戒。起此增上心。便得增上戒。又戒是诸善根本菩提正因。惟人道中无遮难者得受此戒。汝今生处人中。身无遮难。堪受具戒。甚为希有。当一心专注凭仗众僧求此戒法。如病念医。如饥须食。羯磨神验众僧力大。须臾能举法界功德置汝身中。汝当欢喜一心谛受。如是教已应作白言)

大德僧听。此某甲。求某甲受具足戒。某甲自说清净。无诸难事。三衣钵具。已受和上。父母听许。已从僧乞受具足戒。僧今与某甲受具足戒和上某甲。若僧时到僧忍听。白如是(僧祇律云。作白已问僧成就不。乃至羯磨第一第二第三亦如是问。问已须答成与不成。十诵云。羯磨时当一心听。莫余觉余思惟。敬重正思惟。心心忆念应分别之。违者突吉罗)

大德僧听。此某甲。求某甲受具足戒。某甲自说清净。无诸难事。三衣钵具。已受和上。父母听许。已从僧乞受具足戒。僧今与某甲受具足戒和上某甲。谁诸长老忍默然不忍者说(三说)僧已与某甲受具足戒和上某甲竟。僧忍默然故。是事如是持次说堕相(时诸比丘受具戒已。在前归还。新受戒人犯重罪。佛言。受具戒竟应为说十二法四堕法四喻法四依法)

汝某甲听。世尊应供等正觉说是四堕法。若比丘犯一一法非释种子。汝终不得乃至以欲染心视女人。若比丘行淫法乃至共畜生。非沙门非释种子。汝尽形寿不应犯。能持不(答言能持)汝终不得乃至草叶不与而取。若比丘盗五钱若五钱物。非沙门非释种子。汝尽形寿不应犯。能持不(答言能持)汝终不得乃至杀蚁子。若比丘若人若人类。自手杀若教人杀若求刀与若教死若赞死。咄丈夫用恶活为死胜生。非沙门非释种子。汝尽形寿不应犯。能持不(答言能持)汝终不得乃至戏笑妄语。若比丘实无过人法。自称得过人法。诸禅解脱三昧正受及诸道果。非沙门非释种子。汝尽形寿不应犯。能持不(答言能持)诸佛世尊。为示现事善说譬喻。犹如人死终不能以此身更生。如针鼻决永不复得为针用。如多罗树心断更不生不增不广。如石破不可复合。若比丘犯一一堕法。还得比丘法。无有是处

受四依法(应语言)汝某甲听。世尊应供等正觉说四依法。比丘尽形寿依粪扫衣住。出家受具足戒。能持不(答言能)若后得劫贝衣钦婆罗衣拘舍那衣他家衣。皆是长得。比丘尽形寿依乞食住。出家受具足戒。能持不(答言能)若后得僧前食后食请食。皆是长得。比丘尽形寿依树下住。出家受具足戒。能持不(答言能)若后得大小屋重屋。皆是长得。比丘尽形寿依残弃药住。出家受具足戒。能持不(答言能)若后得酥油蜜石蜜。皆是长得(复应语言)汝某甲听。汝白四羯磨得如法受具足戒竟。诸天龙鬼神皆作是愿。我何时当得人身于正法律中出家受具足戒。汝今已得。如人受王位。汝受比丘法亦如是。当忍易共语恭敬受诫余戒。和上阿阇梨当广为汝说。汝当早得具足学三戒灭三火离三界。无复诸垢成阿罗汉(时受戒人。不知年岁及受戒时。佛言。应教令知。汝受戒时某年月日。汝应尽寿忆是事。诸律及论并云。和上阇梨为记。春夏之冬时。某月某日乃至量影。此律又云。时诸比丘无上下坐。不相恭敬。为俗讥呵。佛言。畜生尚有尊卑。况我正法而不相敬。汝等从今。先受戒者。应受第一坐第一施恭敬礼拜。如是奉行。四分律云。当令受具戒者在前而去)

请依止师法(诸比丘和上丧。以无和上阿阇梨故。着上下衣不能如法皆如上说。佛言。从今以十利故。听诸比丘有阿阇梨。自然生心视弟子如儿。弟子自然生心视阿阇梨如父。事如和上中说。至阇梨所文云。偏袒右肩脱革屣胡跪合掌请云)

大德一心念。我某甲今求尊依止。愿尊为我作依止。我依止尊住。尊当教诫我。我当受尊教诫(律不云三但一具得阇梨应答云)汝莫放逸五种不共语法(时六群比丘不敬戒。于师无惭无愧。不敬不爱不供养。佛言。应作五种不共语法)

一语言汝莫共我语。二汝所有莫白我。三莫入我房。四莫捉我衣钵及助我众事。五莫来见我。弟子悔过(佛言。师作不共语时。弟子应悔过。偏袒右肩右膝着地。以两手捧师足。极自卑下白言云)

我小我痴。后不敢复作。(若师受悔过者弟子罪则除灭)

尼众授戒法(善见论云。尼者女也。摩者母也。重尼故称之。智度论云。尼得无量律仪故。应次比丘后。佛以仪式不便故。在沙弥后)

授沙弥尼戒法(其畜众羯磨及剃发出家等法。一一如比丘中说。唯和上须满十二岁。加尼字为异。其度沙弥尼式叉摩那。大比丘尼并须别作畜众羯磨。以其年年度弟子犯罪故。或舍畜众法故。乞与之法并可准知。更不重述也)

受式叉摩那戒法(律云。时诸比丘尼。不先授弟子二岁戒。便受大戒。愚痴无知不能学戒。佛言。不应尔。犯者突吉罗。十诵中。辄度妊娠女人招致呵责。佛言。与二岁羯磨可知有无。然六法净心二岁净心。准四分律。十八童女十岁曾嫁各二岁学戒。满二十十二已受具足戒。依此律中。或可如是。或十八童女。以不劳苦志节未成与二岁法。十二曾嫁。为经劳苦操行以成即与受具足。不须学戒但作白四羯磨。量其堪不故。尼戒云。虽满十二岁已嫁女。而女聋哑种种诸病。诸比丘尼与受具足戒。愚痴无知不能学戒。佛言。今听诸比丘尼白四羯磨与满十二岁已嫁女人受具足戒。彼欲受戒人。应到比丘尼僧中白言。阿姨僧听。我某甲已嫁满十二岁。求某甲和上受具足戒。今从僧乞受具足戒。善哉僧与我受具足戒。怜愍故。如是三乞。诸比丘尼应筹量。可与受不可与受)

应一比丘尼羯磨如上(谓如上与畜众法中说。或可作羯磨词句。如上乞词中说。更不别说羯磨之词)

有诸德云。此文(即是受具足戒。今以多义知非受具。但是请僧量宜可不请。秉法者幸自详之)

乞二岁学戒法(佛言。欲受学戒人。到比丘尼僧中三乞。应具威仪。偏露右肩脱革屣。礼僧足胡跪合掌。白言)

阿姨僧听。我某甲。和上某甲。今从僧乞二岁学戒。善哉阿姨僧。与我二岁学戒。怜愍故(三说乞已。沙弥尼应住不闻处眠见处立)

与二岁学戒法(律云。诸比丘尼。应善筹量可与不与。应作白二羯磨云)

阿姨僧听。此某甲沙弥尼和上某甲。今从僧乞二岁学戒。僧今与某甲沙弥尼和上某甲二岁学戒。若僧时到僧忍听。白如是。阿姨僧听。此某甲沙弥尼和上某甲。今从僧乞二岁学戒。谁诸长老忍者默然不忍者说。僧已与某甲沙弥尼和上某甲二岁学戒竟。僧忍默然故是事如是持

次说戒相法(佛言应与说六法名字)某甲听。如来应供等正觉说六法不得犯一切不得淫乃至以染着心看他男子。若式叉摩那行淫法乃至畜生。非式叉摩那非释种女。是中尽形寿不得犯。能持不(答言能)一切不得偷盗乃至草叶。若式叉摩那若聚落若空地他所守护物盗五钱。非式叉摩那非释种女。是中尽形寿不得犯。能持不(答言能)一切杀生乃至蚁子。若式叉摩那若以人自手断命持刀授与教人杀教死赞死。非式叉摩那非释种女。是中尽形寿不得犯。能持不(答言能)一切不得妄语乃至戏笑。若式叉摩那自无过人法。若言有诸禅解脱三昧正受若道若果。非式叉摩那非释种女。是中尽形寿不得犯。能持不(答言能)不饮酒。若式叉摩那饮酒。非式叉摩那。是中尽形寿不得犯。能持不(答言能)不得非时食。若式叉摩那非时食。非式叉摩那。是中尽形寿不得犯。能持不(答言能。前四根本后二喜为故。别令其二岁修学。若犯前四应当驱摈。若犯后二。准四分律。应更与戒。然四分中。后二同此前四。即是四重方便。谓与男子身相触。盗减五钱。断畜生命作小妄语。若犯此四。亦更与戒。一切尼戒法并皆应学除自手取食授食与他。若依僧祇。随顺行十八事。若日月不满二岁。不应与受具足戒故。四分云。一岁者十二月)受比丘尼戒法(依此宗中尼六种受戒之法。一八敬。二十一众。三二十众。四遥受。五十二曾嫁。六义立边地十人。初局波阇一人。二准五百释女。余之四受通于一切也)

先明本法(须具八缘)一请和上法(须请之意。比丘中已释。应偏袒右肩脱革屣胡跪合掌请云)

我某甲。今求尊为和上。尊为我作和上。我乐尊为和上。依止尊为和上故。得受具足戒(三说和上应答言)可尔(或言)当教诫汝(或言)汝莫放逸二安受戒人(律云。诸比丘弟子。学二岁。戒不合意。便与受具足。戒佛言不应尔。犯者突吉罗。从今听合和上。阿阇梨意。乃为集十众。至受戒处将受戒人着眼见耳不闻处)

三差教受师法(和上应语羯磨师云)

长老今受羯磨(如是差已羯磨师云)阿姨僧听。某甲。求某甲受具足戒。某甲作教授师。若僧。时到僧忍听。白如是四教授师捡问法(一问和上。二问受戒人先应。起至和上前问云)

已度此人未(答言未。应言先度之若言已度。应语言)

为作和上未(若言未。应语为作和上。若言已作。应问云)

此欲受戒人。学二岁戒日满不。衣钵具不(答言不具。应语令具若言具复应问云)

为是己有。为从人借(答言借。应语主令舍。然后乃往欲受戒人所。语言)

汝莫恐怖。须臾当着汝于高胜处(答言尔。若先不谙悉。应小披衣观看。无遮受戒法应问言)

何者是汝僧伽梨优多罗僧安陀会覆肩衣欲衣(彼若不识。应语令识。次应与受衣钵。复应语言)

汝某甲听。今是实语时。我今问汝。若有当言有。若无当言无。汝不杀父耶。汝不杀母耶。汝不杀阿罗汉耶。汝不恶心出佛身血耶。汝不破和合僧耶。汝不犯净行比丘耶。汝非非人耶。汝非畜生耶。汝非黄门耶。汝非二形耶。汝非自剃头自称比丘尼耶。汝非舍内外道耶。汝不曾出家持戒不完具耶(若随问答皆言无者又应问言)女人有如是病。癞病白癞病干痟病癫狂病痈疽漏病脂出病。如是等重病汝有不。汝非负债人不。汝非他妇不。夫主听不(随当时有者问之)汝非属官不。汝非婢不。汝是人不。女根具足不。汝非黄门不。汝非石女不。汝非二道合不。月病常出不。汝学二岁戒日满不。汝已求和上未。父母听不。欲受具足戒不(若随问皆如法答者又应教言)如我今问。后僧中亦当如是问汝。汝亦当如是答

五召入众中法(彼教诫师应还僧中立白言)我已问竟(羯磨师应白言)阿姨僧听。某甲。求某甲受具足戒。某甲已问竟。今听将来。若僧时到僧忍听。白如是(教师应往将来教礼僧众)

六教乞戒法(礼僧足已。将至羯磨师所。胡跪合掌白羯磨师。从僧乞受具足戒。教言)我某甲。求某甲和上受具足戒。今从僧乞受具足戒和上某甲。愿僧拔济我。怜愍故(三乞已教诫师然后复坐)

七戒师白和上(羯磨师应白云)阿姨僧听。此某甲。求某甲受具足戒。从僧乞受具足戒和上某甲。我今于僧中问诸难事。及为作受具足戒羯磨。若僧时到僧忍听。白如是八羯磨师问法(应语言。汝某甲听。今是实语时。乃至欲受具足戒不一如上教授师问法彼皆具。答已)

九正授本法(羯磨师应随机示导令发上心。使具本法已。应作白言)

阿姨僧听。此某甲。求某甲受具足戒。彼从僧乞受具足戒。自说清净。无诸难事。学二岁戒满。五衣钵具。已求和上父母已听。欲受具足戒。善哉僧。今与某甲受具足戒和上某甲。若僧时到僧忍听。白如是阿姨僧听。此某甲。求某甲受具足戒。彼从僧乞受具足戒。自说清净。无诸难事。学二岁戒满。五衣钵具。已求和上父母已听。欲受具足戒。善哉僧。今与某甲受具足戒和上某甲。谁诸阿姨忍默然不忍者说(三说)僧已与某甲受具足戒和上某甲竟。僧忍默然故。是事如是持

本法尼往大僧中受戒法(律云。彼和上阿阇梨复应集十比丘尼僧。将受戒人往比丘僧中义准尼僧自结大界护别众过之)

请羯磨师法(律无正文准前比丘受戒亦令加请应教言)我某甲。今请大德为羯磨阿阇梨。愿大德为我作羯磨阿阇梨。我依大德故得受大戒。慈愍故(三请已彼应答言)可尔乞受大戒法(律云。应在比丘羯磨师前。小远两膝着地乞受具足戒。尼羯磨师应教言)

我某甲。求某甲和上受具足戒。已于众中受具足戒竟。清净无诸难事。已学二岁戒满。衣钵具足。已求和上。父母已听不犯粗恶罪。欲受具足戒。今从僧乞受具足戒和上某甲。愿僧拔济我。怜愍故(三说)羯磨师问法(律云。问法。又乞戒中已言清净问。然诸部中共行问法。故须捡问。羯磨师索欲问和讫。应作白云)

大德僧听。此某甲。求某甲受具足戒。彼从僧乞受具足戒。我今当问诸难事。及为作受具足戒羯磨。若僧时到僧忍听白如是正问遮难法(先应安慰如上说已。又应问云。今是实语时。乃至欲受具足戒不。一一如上。师问法已)

正受戒体法(说法开导诫令专心承受戒法如前所说)大德僧听。此某甲。求某甲受具足戒。已于一众中受具足戒竟。清净无诸难事。已学二岁戒满。先所应作已作。衣钵具足。已求和上。父母已听。不犯粗恶罪。欲受具足戒。今从僧乞受具足戒和上某甲。善哉僧。今与某甲受具足戒和上某甲。若僧时到僧忍听。白如是。大德僧听。此某甲。求某甲受具足戒。已于一众中受具足戒竟。清净无诸难事。已学二岁戒满。先所应作已作。衣钵具足。已求和上。父母已听。不犯粗恶罪。欲受具足戒。今从僧乞受具足戒和上某甲。善哉僧。今与某甲受具足戒和上某甲。谁诸长老忍默然不忍者说(三说)僧已与某甲受具足戒和上某甲竟。僧忍默然故。是事如是持说堕相法(应语云)某甲听。如来应供等正觉说堕法。若比丘尼犯此一一法。非比丘尼非释种女。一切不得淫乃至以染着心看他男子。若比丘尼行淫法乃至畜生。非比丘尼非释种女。是中尽形寿不得犯。能持不(答言能)一切不得偷盗乃至草叶。若比丘尼若聚落若空地他所守护物盗五钱若过五钱。非比丘尼非释种女。是中尽形寿不得犯。能持不(答言能)一切不得杀生乃至蚁子。若比丘尼若人若似人自手断命持刀受与教人杀教死赞死。非比丘尼非释种女。是中尽形寿不得犯。能持不(答言能)一切不得妄语乃至戏笑。若比丘尼自无过人法。若言有诸禅解脱三昧正受若道若果。非比丘尼非释种女。是中尽形寿不得犯。能持不(答言能)一切不得亲近男子。若比丘尼欲盛变心。摩触男子身发已下膝已上。若男子作如是摩触亦不得受。若按若押若举若下若捉若牵。非比丘尼非释种女。是中尽形寿不得犯。能持不(答言能)一切不得与男子共住共语。若比丘尼欲盛变心。受男子若捉手。若捉衣。若期行。若独共行。若独共住。若独共语。若共坐。若以身相近。具是八事。非比丘尼非释种女。是中尽形寿不得犯。能持不(答言能)一切不得随顺非法比丘尼语。若比丘尼知和合比丘僧如法举比丘。而随顺此比丘。诸比丘尼语言。姊妹。此比丘为和合比丘僧如法举。汝莫随顺。如是谏坚持不。舍应第二第三。第二第三谏舍是事善。不舍者非比丘尼非释种女。是中尽形寿不得犯。能持不(答言能)一切不应覆藏他粗恶罪。若比丘尼知他比丘尼犯波罗夷罪。彼后时若罢道若死若远行若被举若根变。语诸比丘尼作如是语。我先知是比丘尼犯波罗夷罪。不白僧不向人说。非比丘尼非释种女。是中尽形寿不得犯。能持不(答言能)诸佛世尊。善能说喻示现事。犹如针鼻决不复任针用。犹如人死终不能以此身更生。犹如多罗树心断不生不长。犹如石破不可还合。若比丘尼于此八法犯一一法。还得成比丘尼无有是处

次说八敬法(应语言)汝某甲听。如来应供等正觉说是八不可越法。汝尽形寿不应越。比丘尼半月应从比丘众乞教诫人。比丘尼不于无比丘处夏安居。比丘尼自恣时应从比丘众请三事见闻疑罪。式叉摩那学二岁戒已。应在二部僧中受具足戒。比丘尼不得骂比丘。不得于白衣家说比丘破戒破威仪破见。比丘尼不应举比丘罪。比丘得呵。比丘尼犯粗恶。应在二部僧中半月行摩那埵。半月行摩那埵已。应各二十僧中求出罪。比丘尼虽先受戒百岁。故应礼拜起迎新受戒比丘

次说四依法(应语言)汝某甲听。如来应供等正觉说是四依法。尽受依是出家受具足戒。依粪扫衣出家受具足戒。能持不(答言能)若得长衣劫贝衣钦婆罗衣俱舍耶衣瞿荼伽衣麻衣应受。依乞食法出家受具足戒。能持不(答言能)若得长得僧食前食后食请食应受。依粗弊卧具出家受具足戒。能持不(答言能)若得长庵屋重屋大小房方圆屋应受。依下贱药出家受具足戒。能持不(答言能)若得长酥油蜜石蜜应受(复应语言)某甲听。汝已白四羯磨受具足戒竟。羯磨如法。诸天龙神乾闼婆常作是愿。我等何时当得人身出家受具足戒。汝今已得。如人得受王位。汝今受比丘尼法亦如是。汝当忍易共语易受教诫当学三戒灭三毒。出三界成阿罗汉果。余所不知者。和上阿阇梨当为汝说

第四衣药受净法受持衣法(三衣道摽贤圣同服。既异外道。又息贪嗔。解脱僮相。须加圣法反邪异俗。故制有三。又多论云。为立义故。遮障寒热除无惭愧。为入聚落在道生。善威仪清净。方制三衣。尼制五衣。亦为斯立。功能既然体须依法。四如具足方堪受持。一[毯-炎+旁]二色三量四作。体谓十种之衣。异于草木皮发舍堕邪命毛[毯-炎+旁]锦绮皆不成衣。色谓坏色。非俗五彩斑文绮绣。亦不听许。量谓三肘然五肘然。多论中二肘四肘之衣亦听作安多会。作谓条齿有轨缝刺如法。下二条数。诸教并同。僧伽梨一。多论分为九品。若互增减成受有愆。彼着受用。律有诚说。护净敬奉同之于塔恶心毁坏。得罪亦然。去即随身如鸟毛羽。教既繁广。岂具言哉也)

受安陀会法(律有独受之文。今准作其对首)大德一心念。我比丘某甲。此安多会五条受(三说)受郁多罗僧法大德一心念。我比丘某甲。此郁多罗僧七条受(三说)受僧伽梨法大德一心念。我比丘某甲。此僧伽梨九条受(随其条数多少称之三说)受僧祇支法大德一心念。我比丘某甲。此僧祇支如法作。我受持(三说)受覆肩衣法大德一心念我比丘某甲。此覆肩衣如法作。我受持(三说)舍衣法(应偏袒右肩脱革屣胡跪捉衣心生口言)大德一心念。我此僧伽梨九条。今舍(三说余衣准知。心念受舍。一同于此。但余大德一心念一句。尼五衣等受舍亦同然)受尼师坛法大德一心念。我比丘某甲。此尼师坛。应量作。今受持。(三说)受钵多罗法大德一心念。我比丘某甲。此钵多罗应量受。常用故受药法(患累之。躯有所资待。无病凭食。有疾须药。通论诸药总分四种。要不获已故圣并开。一时药。二非时药。三七日药。四尽形药。前一时药但有手受。后之三种有语手二受。多论。手受有其五义。恐失手受故加语法。准十诵及论。具有语受之法。诸律皆无此文)

受时药(此律。时药体分十种。四分。五正及五非正。并时药摄。识名体已。心境相应威仪如法依教而受。然此律中。受有其四)一身授身受。二物授物受。三手授手受。四教取而食(谓施主情速不及受食。及恶贱比丘不肯亲授。以食着地言可取食。亦听以彼语即为受食)

受非时药法(谓庵婆果等诸八种浆。不杂时食。如法作净。有渴等缘。然后如法。义加云)大德一心念。我比丘某甲。今为渴病因缘。此是庵婆果浆。为欲经非时服故。今于大德边受(三说余浆准此。若无渴病犯罪)

受七日药法(时诸比丘得风热病。佛言。听以酥油蜜石蜜等四种为药受七日服。义加云)大德一心念。我比丘某甲。今为热病因缘。此酥七日药。为欲经宿服故。今于大德边受(三说)受尽形药法(有诸比丘得秋时病。佛言。应根果等药及余一切碱苦辛酢不任为食有病因听尽形服。义加云)

大德一心念。我比丘某甲。今为气病因缘。此姜椒尽形受药。今欲共宿长服故。于大德边受(三说)长衣说净法(长衣之体。据律唯二。若长三衣过十日者方犯舍堕。若长余衣乃至手巾皆突吉罗。针三綖一。此等已外皆须说净。不尔皆结。净施有二。一者真实物付彼人。二者展转称名作法。强夺犯罪。唯真实有展转称名。无强夺义)请施主法(真实净主。律制。简择一五两二。如文具明展转。若准余文。应求持戒多闻者充。律无请法以义加云)

大德一心念。我比丘某甲。今请大德为衣药钵展转净施主。愿大德为我作衣药钵展转净施主。慈愍故(三说)

正说净法(若众多衣物。段段说之若束缚一处。亦得总说)大德(长老)一心念。我此长衣于大德(长老)边作净施(彼应问言)长老此衣于我边作净施。我持与谁(答言某甲彼应语言)我今与某甲。长老若须从彼取用。好爱护之(不应语所称比丘知)

独住作净法(有比丘独住房中。不知云何净施。佛言。听作遥示净施。心生口言也)

我此长衣。净施某甲。从彼取用(独净施法。至十一日复应如前法。心生口言)我此长衣。从某甲取还(然后更如前法净施口言)

今粟净施法(萨婆多云。钱宝谷米。并同长衣。十日说净。四分云。当持至可信优婆塞所。若守园人所告云)此是我所不应。汝当知之

第五僧等布萨法(托外为因缘请而制。识相遵奉。遣犯僧持。摩德勒伽论云。云何名布萨。舍诸恶不善法。证得白法究竟梵行。半月自观犯与不犯。清净身口)

众僧说戒法(律云。诸比丘欲庄严布萨堂。悬缯散花施过中饮亦施衣物。又欲以偈赞佛法僧。佛言。皆听。若有种种福事应及时作。圣教既然。特须敬重各相勉励准法修行。至布萨日。扫洒庭院装饰堂中。说戒之座种种庄严。唱时至等。四种集僧。使众咸知详心赴集。然戒为净法非犯所闻。若有愆违悔令清净。未遑忏洗圣开发露。今依次第具列轨仪)

僧犯忏悔法(有一住处。布萨日一切僧犯罪。佛言。应白二羯磨一人往他众悔过。然后余人向彼除罪。若不得尔。尽集布萨堂。白二置其犯云)大德僧听。僧今皆有此罪(须陈名种)不能得悔过。今共置之。后当悔过。若僧时到僧忍听。白如是。大德僧听。僧今皆有此罪。不能得悔过。今置之。后当悔过。谁诸长老忍默然不忍者说。僧已置此罪竟。僧忍默然故。是事如是持(然后布萨不应不布萨)临欲布萨时。一人发露法(应向比坐心念口言)我有此罪(应说名种不得直云此罪)说戒竟当悔(疑亦如是)教诫尼众法(尼禀碍形恒拘障累阙其游方咨受法训。大圣悲鉴故制此仪。令尼诣僧请人教诫。僧差具德诲以未闻。然法有广略。律教备明并合遵承。无宜怠废。但今僧尼慢教。又具德者稀。广诫之仪未闻。行用且施。略轨以备于时。尼差使人诣僧请已。受嘱比丘代某甲乞此律尼法云。应于唱说不来诸比丘说欲清净时。受嘱之人应从坐起在僧前立白言)

大德僧听。某寺和合比丘尼僧。顶礼和合比丘僧足。乞教诫人(三说已。应至上座所云。大德慈愍能教授尼不。若言不堪者。乃至二十夏已来。一一具问。若无有者。还至上座所白言。遍问众僧无有堪者。上座即应作略教诫法云。明日比丘尼来。应报言。昨夜为尼遍求。无有堪者。语诸尼众。精勤行道谨慎莫放逸。明日宣上座教告使尼。尼使还寺中集众说欲。使尼问和合。宣上座教敕已。尼众合掌恭谨听受。应各云顶戴持。然后礼佛而散之)

与清净欲法(时说戒日。有病比丘不来。佛言。应令柱杖人扶衣舁将来。若恐困笃。应取清净欲来。若不能口语。若举手。举手指。摇头。举眼。得名身与清净欲。若复不能。应舆到彼令诸病者面向说戒人。若复不能向说戒人。应出界外布萨。若与尼等。四众狂乱等三灭摈。此等并不名与清净欲。若至僧中狂乱等起。并名持欲。睡若忘得名持欲。犯突吉罗。又僧断事时起去。戒云。今听诸比丘有事与欲竟去。应设威仪对如法境说云)

长老一心念。僧今断事。我某甲比丘。如法僧事中与欲(不言三说一说应得)僧中说云。大德僧听。比丘某甲。如法僧事中与欲清净(一说)转与欲法(四分律云。持欲比丘自有事起不及诣僧。听转授与比丘。应作是言)

长老一心念。我比丘某甲。与众多比丘受欲清净。彼及我身。如法僧事中与欲清净(彼至僧中但直说之)

告清净法(佛言。若说戒竟一切未起。有比丘来若多若等。应更布萨。若少应僧中胡跪合掌云)

大德僧听。我比丘某甲清净(文无准说)五种说戒法(如余部说八难余缘。开略说戒。此虽无缘所开相似。一广四略。合为五说)

一说戒序已(应云)诸大德。是四堕法。僧常闻(十三僧残。二不定法。三十舍堕。九十一堕。四提舍尼。及众学法。一一列名言僧常闻之)

三说戒序四堕十三二不定已(余言僧常闻)五广诵使周三人二三语布萨法(设威仪已合掌说云)今僧十五日布萨。我某甲比丘清净(三说)一人心念布萨法(威仪同前)今十五日。众僧布萨(心念口言三说)第六僧等安居法(无事游行。复践物命。招讥废道。事无过此。举外况内。故制斯法)

三语安居法(修设威仪对如法境云)长老一心念。我某甲比丘。于此住处夏安居。前三月依某僧伽蓝(随处称之)若房舍坏当治补(三说答言)我知(律云。当依持律者安居。若处所迮闹者。应七日得往返处心念遥依。四分云。夏中当依第五律师广诵二部律者。若违波逸提。准律意应问云)

衣谁持律(答言)依某甲律师(告言)有疑当问(若非伽蓝。须除房舍破修治之言。若后安居。唯称后三月为异)

心念安居法(准前三语。但除初句)

受房舍安居法(时有分房舍卧具。竟不作心念。亦不口言。生疑。白佛。佛言。为安居故受房舍敷具。亦成安居。既言。亦不心念。应有心念安居云)

受日出界法(文言。长者请僧。惧不敢受。因致嫌呵。佛言。若有请若无请须出界外。一切皆听七日往返。又诸外道欲只桓中通水。王出征罚欲往咨启。佛言。若有佛法僧事若私事。于七日外更听白二受十五日夜。若三十夜约夜为数。不同他部缘如缘非。教自明显。重不重受任依恒式。若有二难听破无罪。开无重故夏不破成。或可准文。既许彼处受夏衣分。安居彼成义亦无失)

羯磨受日法大德僧听。此某甲比丘。为某事欲出界行。于七日外更受(十五夜若三十夜)还此安居。若僧时到僧忍听。白如是。大德僧听。此某甲比丘。为某事欲出界行。于七日外更受(十五夜若三十夜)还此安居。谁诸长老忍默然不忍者说。僧已与某甲更受(十五夜若三十夜)出界行竟。僧忍默然故。是事如是持三语受日法(律无受词。准羯磨说)

长老一心念。我比丘某甲。为某事欲出界行。受七日法还此安居(三说)

第七僧等自恣法(共居习道或有愆违。故令夏三月最后日。于如法比丘众。涂地布草于上自恣请他举罪)

差受自恣人法(作相集僧并依常轨。具五种德应差令受。谓不随欲恚痴畏知时。非时若二若多文中并许)

大德僧听。此某甲某甲比丘。能为僧作自恣人。僧今差某甲某甲作自恣人。若僧时到僧忍听。白如是。大德僧听。此某甲某甲比丘。能为僧作自恣人。僧今差某甲某甲作自恣人。谁诸长老忍默然不忍者说。僧已差某甲某甲作自恣人竟。僧忍默然故。是事如是持

五德被差已单白摄众法(以诸比丘杂乱无次自恣前后故。制作白俱设威仪)

大德僧听。今僧自恣时到。僧和合作自恣。白如是(然后俱下胡跪自恣)正自恣法诸大德。若见我罪。若闻我罪。若疑我罪。怜愍故自恣说。我当见罪悔过(三说)略自恣法(以诸白衣欲布施及听法。诸比丘自恣淹久致彼讥呵。因开除上八人一一自恣。自下同岁同岁一时自恣。余缘八难他部所开。简德差人如前。已辩五德被差已。应起白众云)

除上八人。自下同岁一处坐自恣(若自恣犹迟应白众云也)

各各相向自恣四人已下自恣法(自恣法中虽无此文。准于布萨及他部。说三语心念。亦通有云也)

四人对首自恣法三大德一心念。今日众僧自恣。我某甲比丘清净(三说。人各施设表已清净。应他自恣。三人二人亦如是)

一人心念自恣法今日众自恣。我心念受自恣(三说。其说欲如前布萨。俱改自恣为异。僧祇自恣不听说欲。恐避举罪故。今不同之)

尼差人自恣法(佛言。比丘尼不得共比丘自恣。应先集众自恣。然后差人就比丘僧请见闻疑罪。四分云。若僧尼满五不至自恣。然后差人就比丘僧请见闻疑罪。四分云。若僧尼不满五至自恣日。比丘尼至比丘所礼拜问讯。义准若各满五。应集僧索欲问缘答云差。自恣羯磨应云)

阿姨僧听。今差比丘尼某甲。为比丘尼僧故往大僧中请见闻疑罪。若僧时到僧忍听。白如是。阿姨僧听。今差比丘尼某甲。为比丘尼僧故。往大僧中请见闻疑罪。谁诸长老忍默然不忍者说。僧已差比丘尼某甲为比丘尼僧故往大僧中请见闻疑罪竟。僧忍默然故。是事如是持(四分云。被独行无护者。应差二三尼为伴。此律云。彼尼至比丘僧已。偏袒右肩脱革屣遥礼僧。然后入僧中。合掌白言)

某精舍和合比丘尼僧。顶礼和合比丘僧足。我等比丘尼僧和合。请大德僧自恣说见闻疑罪(如是三请已良久。若无人举者。众中上座应告使人言)

比丘尼众三请见闻疑罪。徒众上下各默然者。实由尼众如法行道谨慎莫放逸(使尼礼拜辞退。至本寺已集尼众。等传僧敕。如教诫中说)

第八受施分衣法(着粪扫衣圣先赞叹。因耆域请受家施衣。但粪扫衣既无施主。约缘有十家施衣者。约心差别。文分九种)

一界得施(谓施主心约界而施。还随施意。与界内僧)

二要得施(谓异处僧)安居共要一处得施(两界共分。后有施物。随要而受)

三限得施(谓施主心摽人数定故。律文言。施如是人)

四僧得施(谓施普通十方凡圣。心既弥廓福亦弘多。还据本心四方僧受)

五现前僧得施(施主对面约境为定)

六安居僧得施(无心拟施此安居僧)

七二部僧得施(施主本意施二部僧。纵数多少皆中为分。若唯一部一部受之。四分文中乃至无一沙弥。比丘分。无一沙弥尼。比丘应分。义应准彼。即亡人衣物。佛判属僧二部。互无随一摄。虽无施主。亦此中收分摄方轨。具如下列)

八教得施(施三教僧非如是因)

九人得施(施主自云施某甲人。以前九施唯局内众。内众之中该于僧别及时非时。僧得一种若是常住将入四方。若非常住约此宗中直尔分之。不须羯磨。故文云。有一住处。非安居时得施僧衣。作是念。佛说四人已上名僧。我今一人不知云何。佛言。应受持。若净施人。若不尔余比丘来应分。此既一人言受持等。不云心念明。纵有僧亦无羯磨。又云。有一人处僧得可分衣。一比丘持至戒坛上独取受持。佛言。不应尔。犯突吉罗。现前僧应分。若依余部。僧伽羯磨。以物既施僧。分须僧法。三人已下对首等分。杖既齐金准用无爽。余之八种并直分之。约事虽殊皆无羯磨)

分亡比丘物法(脱俗樊笼清升入道。内蕴圣戒外饰圣仪。为代福田堪消物供养。利既依僧得。身亡还以入僧。即同非时僧得施摄。但教分开制物异重轻。两僧分摄具有明轨。欲显其相须作十门)

一同活共财(结要共财俱为物主。随身已外皆合中分。如有不怕准数科结。共居同活通局有殊。则住在者筹量处分。必须明审依教据情。若涉私曲便招二损)

二负债征偿(若负他物理合先偿。若他负物征取分摄。若轻重相当二僧随入。互得轻重亦依其本)

三嘱授成不(亡人临终以物与人。言嘱手受并有成不。诸部共显其相可知。此律所明其唯二种。与已持去。即彼人如在本处。须僧作法。故律云。若生时不以与人。现前僧应分。若以与人未持者。僧应白二羯磨与之。作法云)大德僧听。某甲比丘于此命过。生存时所有若衣若非衣。现前僧应分。今与某甲。若僧时到僧忍听。白如是。大德僧听。某甲比丘于此处命过。生存时所有衣若非衣。现前僧应分。今与某甲。谁诸长老忍默然不忍者说。僧已与某甲衣竟。僧忍默然故。是事如是持

(作此法已。物付彼人)

四分物时处(时谓殡送已了。处谓大界之中。僧祇云。若比丘死。弟子不可信者。应持户钩付僧知事然后供养舍利。母论云。先将亡者律殡。送后取亡者物着僧前。集僧分之。此律云。一比丘持至戒坛上独取持。佛言。犯告。现前僧应分)

五断割轻重(欲断轻重先令舍物故。四分云。彼持亡者物来在众中。当作是言。义准应设威仪已胡跪合掌白云)

大德僧听。某甲比丘(此彼)命过。生存时所有若衣若非衣。现前僧应分(三说)我比丘某甲。今舍与僧(如是舍已应正处分。律云。有一多知识比丘命过。其物甚多。佛言。若生时已与人。应白二羯磨与之。若不与人。有可分不可分。可分者。若婆那衣苏摩衣劫贝衣拘执毛长五指三衣若下衣。舍勒单敷若衬身衣被坐具针綖囊漉水囊大小钵户钩。如是等现前僧应分。若锦绮毛[毯-炎+旁]毡拘执毛过五指雨浴衣蚊厨经行敷遮壁虱坐卧床床踞。除大小瓦钵澡灌。余一切瓦器。除大小铁钵户钩截甲刀。针余一切铁器。除铜揵镃铜[金*沙]锣成眼药物。余一切铜器若伞盖锡杖。如是等是不可分。应属僧。但凡躯有待资具极多。随身所用事物繁杂。文准梗概岂尽资缘。对事准文可为轻重。诸部断决乖互极多。但据宗文以为准的。广如仪述不可穷言)

六量德赏物(律云。有一懒堕比丘。不佐助众事不供师长。病无人看委卧粪秽中。世尊穷为洗浣除秽扶持。安慰说法离垢证道。因告比丘。汝等无有父母。不自相看谁看汝等。因制。师弟更相瞻视。无师弟者劝喻次差。然病者有难看。瞻病德有具不具。难看有五种。一不能善量食。二不服所宜药。三不说病状。四不从人教。五不观无常。易看反之。不能看病有五种。一不知所宜药。二不能得随病食。三不能为病人说法。四恶厌病人便利吐唾。五为利故不以慈心。能者及说。余部所明大概如此。对众捡问量德具已。然后赏之。若为病人经理汤药。身虽在外亦须依赏)

七正明赏法(余律所赏。三衣六物或以残药。此律唯以衣钵与之)

大德僧听。某甲比丘命过。三衣钵现前僧应分。今以与看病人某甲。若僧时到僧忍听。白如是。大德僧听。某甲比丘命过。三衣钵现前僧应分。今以与看病人某甲。谁诸长老忍默然不忍者说。僧已与某甲比丘衣钵竟。僧忍默然故。是事如是持(三衣钵等或具随有赏之。比丘尼命过。应与二人。若持尼命过。应与三人。各谓当众。余众纵看不得辄赏。劳不满故。谓教并然。纵赏下众等具人分)

八正分轻物(律云。分物无羯磨法。准前僧得似直分之。以其此已属僧。僧分已物不更别属。知用何法。答以此与于别人文加白二。以此僧物不属别人。若不用法何辄嘱彼。故赏看病人及属受与人。物少不分并与一人。皆有羯磨。又准余律咸皆白二。以此僧物并属四方。若非以法定之。现前僧云何能摄。然准文行事取舍不同。或一二三局能备述辞。详文定理二法为长。一即差人。二即分付。虽非己部终为[疊*毛]准。用无失故具列之。若有五人须作两重白二。一者差人。二者分付。若但有四不合差人。准毗尼母论。直作分付一法)

差分衣人法(物既属僧。僧差作分。若非羯磨事无由办故。文中分卧具人。差受请人。守物人等。咸有差法。四分。差人亦同。于此义准云)

大德僧听。此某甲比丘。能为僧作分衣人。僧今差某甲作分衣人。若僧时到僧忍听。白如是。大德僧听。此某甲比丘。能为僧作分衣人。僧今差某甲作分衣人。谁诸长老忍默然不忍者说。僧已差某甲作分衣人竟。僧忍默然故。是事如是持以物付分法大德僧听。某甲比丘于(此彼)命过。生存时所有衣若非衣。现前僧应分。僧今持与比丘某甲。某甲当还与僧。若僧时到僧忍听。白如是。大德僧听。某甲比丘于(此彼)命过。生存时所有衣若非衣。现前僧应分。僧今持与比丘某甲。某甲当还与僧。谁诸长老忍默然不忍者说。僧已忍持与比丘某甲某甲当还与僧竟。僧忍默然故。是事如是持四人直分法大德僧听。某甲比丘于(此彼)命过。生存时所有衣若非衣。现前僧应分。若僧时到僧忍听。白如是。大德僧听。某甲比丘于(此彼)命过。生存时所有衣若非衣。现前僧应分。谁诸长老忍默然不忍者说。僧已分是衣物竟。僧忍默然故。是事如是持(若欲赏看病人。应三人口法和以衣钵物与之。应云)

诸大德。某甲比丘命过。以衣钵物。与看病人某甲(三说二人和赏亦如是)

众多人三语分衣法

二大德。某甲比丘命过。若衣非衣。应属我等(三说余二人亦如是。二人分衣亦如是也)

一人心念分衣法。某甲比丘命过。若衣非衣。皆应属我(三说)并与一人法(律云。若衣少不欲分。应白二与一无衣比丘)

大德僧听。此僧得衣若非衣。今并与某甲比丘。若僧时到僧忍听。白如是。大德僧听。此僧得衣若非衣。今并与某甲比丘。谁诸长老忍默然不忍者说。僧已忍与某甲比丘衣竟。僧忍默然故。是事如是持(亡人衣物。义亦应尔也)

九二众互摄(文言。若有比丘住处。非安居时比丘命过。无比丘比丘尼应分。若比丘尼住处非安居时。比丘尼命过无比丘尼。比丘应分。安居时亦如是。僧得施物亦如是。四分律中。乃至无一沙弥。比丘尼应分等。如前已说。彼律又云若无住处僧尼命过。出家五众先来者与。若无来者。送与近处伽蓝)

十诸部杂明(诸部受分。大论十种。一粪扫取。如此律水漂死者。二见前取。如十诵学悔人守戒共住互死者。三同见取。如四分律二部互死。四功能取。如四分律二举死同入羯磨举僧。五二部取。如四分律无住处死。六面所向取。如论二界中死。七入和上。如僧祇沙弥死。八入所亲白衣。如多论灭摈人死。九随所得取。如十诵寄人等。十羯磨取。如余律在众死。此律应同)

第九忏悔诸犯法(夫业如幻化。性相无定。遇缘而生。无而忽有。逢缘而灭。有已还无。若不深生愧耻悔责前非。经百千劫终不失灭。时熟缘会必当现受。若悔恨彻心克己修改。一念之顷消灭。无余故未曾有经云。前心作恶如云覆日。后心起善如炬消闇。又业报差别经云。若人造重罪。作已深自责悔更不造。能拔根本业。又涅槃经云。若人修习身戒心慧。能令地狱重苦现世轻受。圣教既繁曷能备述。然犯有性遮。悔分理事。二忏之中又分大小。若修明慧观我法空。福体尚无罪何容有此理。约机自含大小。大乘事忏方轨不同。观礼佛像诵持神咒。罪无轻重亦尽消灭。律中事忏但清违教。上来所列条贯各殊。既没根机任情所好。然律宗事法但取见闻。既破律仪终须轨定。于戒有犯必依法忏。然教法该罗无简凡圣。今依轻重各具陈之)

忏悔波罗夷法(犯波罗夷名坏根本。折石断首岂更生全。大乘忏中虽云除灭。然于宗法永无僧用。此既本禁不类余愆。特须谨克碎身坚护。但凡情易逸对境容亏。若无一念覆藏。律中许其改悔。但可清其犯业。僧法岂得预哉。犯悔既稀。具如钞说)

忏悔僧伽婆尸沙法(既曰刑残。邻于断命。要凭清众业累方除。覆等四法文中具显。自部他部咸有轨仪。法既繁多此岂能尽。临机行用别有钞文)

忏偷兰遮法(此罪约缘通因及果。因果轻重又分三品。如破法轮僧盗食盗四钱等及初篇重因。名为上品。应僧中悔。若破羯磨盗三钱已下。互有依触及初篇轻因一篇重因。名为中品。应对二三人悔。若食人肉用人发等。着外道衣及二篇轻因。名为下品。应一人前悔。前对僧中。先应三乞别请忏主单白和僧三说而悔。若二三人。除乞反白。加问边人一人。一人又除问边人一白。余词句如忏波逸提中说。唯罪名有异事既稀简。略辩大纲临机行用。钞中详委)

忏波逸提法(舍堕因财以成。单提不局衣。犯别论舍。虽异据堕即同三十。忏通僧别。单提唯对别悔。故分先后义在于兹)

先忏舍堕对僧作法(文云。应舍与僧。若一二三人不得。与余人及非人。舍已应忏悔。若不舍而悔。其罪益深。四分律中。有其四法。一舍财。二舍罪。三还财。四不还财结罪。罽分俱[疊*毛]准用无失。今依前三辩仪戒)

一舍财(此舍财中须识五法。一舍财心。谓以贪心取此物。违教成业当苦报。圣应所制真实不虚。若不忏除当来定受。如是思已。于此财物生极厌心。永以舍弃必无余吝。二所舍财。谓衣钵药宝等。但制舍者。皆须总集而尽舍之。三舍财境。谓僧等三。谓四分律云。不得别众舍。若舍不成突吉罗。四舍财威仪。谓敷尼师坛脱革屣作礼互跪合掌。若对小者不须礼拜。五舍财法。对僧者应云)

大德僧听。我比丘某甲。故畜(若干)长衣。犯舍堕(或离衣等随事称之)

是衣今舍与僧(一说。如是舍已。即付与僧。对下境词句亦然。但改初后二言。为异也)

二舍罪(对僧忏悔罪须具六。法一乞二请三白四悔五诫六受。此之六法诸教互明。必须周具。方成悔过也)

一对众陈乞(具修威仪胡跪合掌)大德僧听。我某甲比丘。故畜尔所长衣。犯舍堕。是衣已舍与僧。今有(若干)波逸提罪。从僧乞忏悔。愿听我某甲比丘忏悔。慈愍故(三说)二请忏悔主(夫忏悔主必须清净。彼自有缚岂能解他时为重病无清净人。初开不同犯。后开同犯作)

大德一心念。我比丘某甲。今请大德作波逸提忏悔主。愿大德为我作波逸提忏悔主。慈愍故(三说)

三单白和僧(既对清众义无辄受。故须咨白。取众情和方便如常。答云受波逸提忏悔羯磨)

大德僧听。某甲比丘故畜长衣犯舍堕。此衣已舍与僧。是中有波逸提罪。今从僧乞忏悔。我某甲受某甲忏悔若僧时到僧忍听。白如是(众既和许告示可尔)

四正忏悔除罪(畜长之过数类稍多。或一二三。乃至于九犯于名种。惟吉与提。六是从生。三为根本。今依次第略显其相。第一且如畜一长衣犯提罪。识知是罪作覆藏心。清净人同界而宿。即犯覆藏突吉罗。此一品罪随衣而生。约位总定名覆藏罪。但覆藏吉罗亦须发露。而隐不发露亦生覆藏。以覆藏而生。名随覆藏突吉罗罪。此一品罪亦随夜生。显数虽多。总名随覆上三品罪。一提二吉。提为根本吉罗从生。覆即二三。不覆但一。第二犯长之衣举体生过。若其着用即犯吉罗罪。据于心脱即无过。隐而不发亦有覆藏。如前三品轻重为异。第三犯前诸罪经僧说戒。三问不发犯吉罗。二覆从生亦同于上。上来二三合成九。品有具不具。据事而思。行忏之人特须明识。称名历数厌而生愧。立对治道谨克身心。词句无乱方成忏悔。先轻后重次第而除。二件标牒方尽其类。第一先忏三位覆随覆六。以其种类轻重同故。第二忏着用默妄二根本吉。第三忏犯长之提。据事虽然。今明轨则。先辩忏提。余次轻者。准此而用。文云。犯罪比丘应偏露右肩胡跪合掌。余文对大须具五法。此加露肩。总成六法也)

大德。我某甲。故畜(若干)长衣犯波逸提罪。向大德悔过(三说。诸部更有余词。据宗但合如此)

五戒勖令断(彼应问言)汝自见罪不(答言)我自见罪(彼又问言)汝欲悔过耶(答言)我欲悔过(彼又语言)汝后莫作六承受立要(应答言)尔(或言)顶戴持(上来至此。名忏悔竟)

三还衣(若对僧舍。须僧还衣。对别人舍。别人还之。良以罪累已除身心清净。堪消物养为资道缘故。四分云。僧应还此比丘衣白二羯磨。若其不还及故坏等皆突吉罗。唯除五敷二宝及七日药。此八无还。四分律中。锦缛斩坏亦无还法。然彼僧还有其两种。一即坐转付。谓众僧多集。或此比丘有因缘欲远行。僧应问言。汝此衣与谁。随彼说便与。若无此二缘明日直还。二即坐直付。谓不须经宿故付之。然有五人得作转还。若但四人唯得直付。三人已下作口法还)

即坐转付法大德僧听。此某甲比丘。故畜(若干)长衣犯舍堕。此衣已舍与僧。僧今持是衣与某甲比丘。某甲当还此比丘若僧时到僧忍听。白如是

大德僧听。此某甲比丘。故畜(若干)长衣犯舍堕。此衣已舍与僧。僧今持是衣与某甲比丘。某甲当还此比丘。谁诸长老忍默然不忍者说。僧已持是衣与某甲比丘。某甲当还此比丘。竟僧忍默然故。是事如是持即坐直付法大德僧听。某甲比丘。故离僧伽梨宿(余衣随称)犯舍堕。此衣已舍与僧。僧今持是衣还某甲比丘。若僧时到僧忍听白如是。大德僧听。某甲比丘故离僧伽梨宿犯舍堕。此衣已舍与僧。僧今持是衣还某甲比丘。谁诸长老忍默然不忍者说。僧已持此衣还某甲比丘竟。僧忍默然故。是事如是持(作羯磨竟。以衣付彼)

对众多人舍忏法(舍财同上。须口和余人。不用单白。余可准知之)

受忏口和法。二长老听。我受某甲比丘忏悔。者我当受(受忏还衣。可准前用)

对一人舍忏法(应将比丘至自然界。或戒场上集所犯财。勿使遗落具修威仪同上僧法。但称境有异。既唯独一不须口和。正忏还衣亦准而作)

忏二根本突吉罗(应请忏悔主。如前威仪说)大德。我某甲。犯着用不净衣及经僧说戒默妄语。并犯突吉罗罪。各不忆数。今向大德悔过(余诫受等准前可知)忏覆藏及随覆藏突吉罗法。大德。我某甲。犯故畜长衣波逸提罪。及着用不净衣经僧说戒默妄语突吉罗。各有覆藏及随展转覆藏突吉罗罪不忆数。今向大德悔过(余三问答准前而说)

忏单波逸提法(摽名为异忏法同前)

忏波罗提提舍尼法(请忏悔主。修威仪同前。诸犯摽罪。为异也)

大德。我某甲。犯从非亲里比丘尼自手授食波罗提提舍尼罪(若干)今向大德悔过(余三问答同前)

忏突吉罗法(律云。高下着衣等。若不解不问而作者突吉罗。若解不慎而作亦突吉罗。此二种吉。应无轻重齐责心忏。若解轻戒轻人而作。犯波逸提罪。忏此提罪同前可知。责心吉罗不须对境。应具威仪已云)

我某甲。犯高下着衣突吉罗(若干)今自责心忏悔过(一说)第十杂行住持法(止作具修。自他并利。教行因果据要陈之。先述当宗。后障异部之说)

作六念法(律云。比丘应知月半月日数知布萨日悔过清净。又云。应先心施食。若不念施人而食突吉罗。然文散落而不次第。六念之轨出在僧祇。今依彼文义准为法。既恒须作故录在初)

第一念知日月数(应云)今朝黑月小一日(乃至十四日。若大言大。白月恒大而无小。可随称之)

第二念知食处(若常乞食应云)我常乞食(若食僧食应云)我食僧食(若食自食应云)我食自食(若受人一请欲自赴者应云)我食某甲家食(若受多请不能遍赴者。应自赴一请。余者施与人。施之人比丘沙弥。但得应对所施人作法嘱云)

长老。某甲檀越施我五正食。我有因缘不得往。今以施汝(若时逼促无人可施者。律开心念施人。应作念云)

我请分与某甲比丘(若有背请缘亦随事说。之若无定食。处应云)我不背请食。第三念知受时夏数(应云)我于某年月某日时一尺木(若干)影。受具足戒无夏(一夏多夏随数称之)

第四念知衣钵受净(应云)我三衣钵具足。并受持长衣并说净(若阙衣钵或未受持。未说净等。念持念说。随事称之)

第五念知身强羸(应云)我今不病堪行道(若有病应云)我有病须疗治

作残食法(佛言。持食着钵中。手擎对未足食比丘。偏袒右肩右膝着地。作是言)

长老一心念。我某甲食已足。为我作残食法(彼比丘为取残已问言云)是食与我耶(答言)与(便为食少许。余残还之者。若都不食。但取已还之。语言)此是我残与汝(亦名残食)白同利食前后入聚落法大德一心念。我某甲比丘。先受某甲请。今有某缘事。欲入某处聚落至某家。白大德知。白非时入聚落法。长老。我非时入聚落(十诵律云)至某城邑聚落某甲舍(前人答言)可尔防护贩卖求利法(律云。若比丘欲货易。应使净人语言)

为我以此物货易之(又应心念)宁使彼得我利。我不得我利(若自货易。应于五众中。若与白衣货易。突吉罗)

弟子欲辞行和上量宜法(若路有疑怖。或行伴无知。不知诵戒布萨羯磨。或彼方乞食。难得持法律解律仪人。若好斗讼希破僧事。若彼方得病。无随病食药。无看病人。诸有一事。皆勿听去。弟子强去。得轻师波逸提。和上若不筹量听去。得突吉罗罪也)

持律比丘来承迎只供法(佛言。今为诸比丘结初应学法。若闻持律者来。不应避去。应为扫洒整理戾舍及卧具半由旬迎。疑难要当出代担衣物。办水具中设过中饮。应请说法。若实求解应如法说。若触恼问即不应答。旦为设前食后食。为求留安居。复应为求施衣檀越。应如是供养。若不尔突吉罗罪)

持律比丘有七种宜(一多闻诸法。二能筹量是法非法。三筹量比丘尼。四善摄师教。五若到他处所说无畏。六自住毗尼。七知共不共戒之)

应说戒人法(有一住处。跋难陀为上座。众僧请说戒。答曰。诵忘。诸比丘言。若忘何故在上座处。以是白佛。佛言。上座说戒。若不说突吉罗。不知齐几为上座。佛言。于上无人。皆名上座)

僧尼二众尊卑礼敬法(佛言。从今听诸比丘随次礼上座。诸比丘尼礼一切比丘。亦随次相礼。式叉摩那礼一切比丘比丘尼亦随次相礼。沙弥亦如是。沙弥尼礼一切比丘比丘尼式叉摩那沙弥。亦随次相礼。礼敬之法。听比丘尼去比丘不近不远合掌低头作是言。和南。四分律云。塔亦应礼。佛言。食时。歠粥时。啖果时。经行时。不着三衣时。闇时。不共语时。相嗔于屏处。此等皆不应礼。犯者突吉罗。五羯磨人。被举。不共语本言治。狂心。散乱心。病坏心。别住。行摩那埵。本日。阿浮呵那。皆不应礼)

净五生种(根接节果子)若食果。应五种净(火净刀净鸟净伤净未成种净)若食根。应五种净(剥净截净破净洗净火净)若食茎叶。应三种净(刀净火净洗净。于聚一器中若净一名为总净之)

着衣高下法(佛言。着下衣。从脚跟下上量一搩手。左掩其上。两边两摄。当后两摄之)

受请应供法(时有长者。请佛及僧。比丘问佛。若人请僧为请谁。佛言。若正趣正向人皆已礼请。虽非正趣正向。若为解脱出家。若坐禅人。若读诵经人。若劝作众事人。除恶戒人。余一切僧皆应食。若请僧应二众食。比丘及沙弥。若请二部。应五众食)

四方众僧有五种物。不可护不可卖不可分(一住处地。二房舍。三须用分。四果树。五花果。一切沙门释子比丘皆有其分。若护若卖若分。皆偷兰遮罪)

佛告诸比丘。汝等各当系念在前自防护心(何谓系念。谓行四念处观。内身观除无明世间若护观外身及痛心法亦如是。何谓在前。所谓若行若立。若卧若睡。若觉。若去若来。前后瞻视。若屈申俯仰。若着衣持钵。若食饮便利。若语若默。常其心。此是我教)

佛告诸离车。世有五宝。甚为难遇(一一切诸佛世尊。二善说佛所说法。三闻法善解。四如闻能行。五不忘小恩)

供养父母法(佛告诸比丘。若人百年之中。左肩担父右肩安母。于上大小便利。极世珍奇衣食供养。犹不能报须臾之恩。从今听诸比丘尽心尽寿供养父母。若不供养得重罪)

弥沙塞羯磨本


弥沙塞五分戒本

    No. 1422 [cf. No. 1421]

弥沙塞五分戒本一卷

        宋罽宾三藏佛陀什等译

大德僧听。春时一月过少一夜。余有一夜三月在。老死至近佛法欲灭。诸大德。为得道故一心勤精进。所以者何。诸佛一心勤精进故得阿耨多罗三藐三菩提。何况余善道法。未受具戒者已出。僧今和合先作何事。(一人答言布萨说戒)诸大德不来诸比丘。说欲及清净(一人答言说欲讫)

  合十指爪掌　　供养释师子
  我今欲说戒　　僧当一心听
  乃至小罪中　　心应大怖畏
  有罪一心悔　　后更莫复犯
  心马驰恶道　　放逸难禁制
  佛说切戒行　　亦如利辔勒
  佛口说教诫　　善者能信受
  是人马调顺　　能破烦恼军
  若不受教敕　　亦不爱乐戒
  是人马不调　　没在烦恼军
  若人守护戒　　如牦牛爱尾
  系心不放逸　　亦如猴着锁
  日夜常精进　　求实智慧故
  是人佛法中　　能得清净命

大德僧听。今十五日布萨说戒。僧一心作布萨说戒。若僧时到僧忍听。一心共作布萨。白如是诸大德今布萨。说波罗提木叉。一切共听善思念之。若有罪应发露。无罪者嘿然。嘿然故当知我及诸大德清净。如圣嘿然我及诸大德亦如是。若比丘如是众中乃至三唱。忆有罪不发露。得故妄语罪。故妄语罪佛说遮道法。发露者得安乐。不发露罪益深

诸大德已说戒经序。今问诸大德是中清净不(第二第三亦如是说)

诸大德是中清净。嘿然故是事如是持

诸大德。是四波罗夷法。半月半月戒经中说

若比丘共诸比丘同学戒法。戒羸不舍。行淫法乃至共畜生。是比丘得波罗夷不共住

若比丘。若聚落若空地盗心不与取。若王若大臣。若捉若缚若杀。若摈语言。汝贼汝小汝痴。是比丘得波罗夷不共住

若比丘。若人若似人。若自杀若与刀药杀。若教人杀。若教自杀。誉死赞死。咄人用恶活为死胜生。作是心随心杀如是种种因缘彼因是死。是比丘得波罗夷不共住

若比丘。不知不见过人法。圣利满足。自称我如是知如是见。是比丘后时若问若不问。为出罪求清净故。作是言我不知言知不见言见。空诳妄语除增上慢。是比丘得波罗夷不共住。诸大德已说四波罗夷法。若比丘犯一一戒。不得共住如前后亦如是。是比丘得波罗夷罪不应共住。今问诸大德是中清净不(第二第三亦如是说)诸大德是中清净。嘿然故。是事如是持

诸大德是十三僧伽婆尸沙法。半月半月戒经中说

若比丘。故出不净除梦中。僧伽婆尸沙

若比丘。欲盛变心触女人身。若捉手。若捉发。若捉一一身分摩着细滑。僧伽婆尸沙

若比丘。欲盛变心向女人。粗恶语随淫欲法说。僧伽婆尸沙

若比丘。欲盛变心向女人。自赞身言。姊妹淫欲供养。是第一供养。僧伽婆尸沙

若比丘。行媒法若为私通事。持男意至女边。持女意至男边。乃至一交会。僧伽婆尸沙

若比丘。自乞作房无主。为身应如量作。长佛十二搩手广七搩手。应将诸比丘求作处。诸比丘应示作处无难处有行处。若不将诸比丘求作处。若过量作。僧伽婆尸沙

若比丘。有主为身作房。应将诸比丘求作处。诸比丘应示作处无难处有行处。若不将诸比丘求作处。僧伽婆尸沙

若比丘。自不如法恶嗔故。以无根波罗夷谤无波罗夷比丘。欲破彼梵行。是比丘后时。若问若不问。言我是事无根。住嗔故谤僧伽婆尸沙

若比丘。自不如法恶嗔故。于异分中取片若似片。作波罗夷。谤无波罗夷比丘欲破彼梵行。是比丘后时若问若不问言。我是事异分中取片若似片。住嗔故谤僧伽婆尸沙

若比丘。为破和合僧。勤方便诸比丘语彼比丘。汝莫为破和合僧。勤方便当与僧和合。僧和合故欢喜无诤。一心一学如水乳合。共弘师教安乐行。如是谏坚持不舍。应第二第三谏。第二第三谏舍是事善。若不舍者僧伽婆尸沙

若比丘。助破和合僧。若二若三若众多。语诸比丘言。是比丘所说是知说非不知说。说法不说非法。说律不说非律。皆是我等心所忍乐。诸比丘语彼比丘。汝莫作是语是比丘所说是知说非不知说。说法不说非法。说律不说非律。皆是我等心所忍乐。何以故。是比丘非知说不说法不说律。汝莫乐助破和合僧。当乐助和合僧。僧和合故欢喜无诤。一心一学如水乳合。共弘师教安乐行。如是谏坚持不舍。应第二第三谏。第二第三谏舍是事善。不舍者僧伽婆尸沙

若比丘。恶性难共语。与诸比丘同学经戒。数数犯罪。诸比丘如法如律谏其所犯。答言。大德汝莫语我若好若恶。我亦不以好恶语。汝诸比丘复语言。汝莫作自我不可共语。汝当为诸比丘说如法。诸比丘亦当为汝说如法。如是展转相教转相出罪成如来众。如是谏坚持不舍。应第二第三谏。第二第三谏舍是事善。不舍者僧伽婆尸沙

若比丘。依聚落住行恶行污他家。行恶行皆见闻知。污他家亦见闻知。诸比丘语彼比丘。汝行恶行污他家。行恶行皆见闻知。污他家亦见闻知。汝出去不应此中住。彼比丘言。诸大德随爱恚痴畏。何以故。有如是等同罪比丘。有驱者有不驱者。诸比丘复语言。汝莫作是语。诸大德随爱恚痴畏。有如是等同罪比丘。有驱者有不驱者。汝行恶行污他家。行恶行皆见闻知。污他家亦见闻知。汝舍是随爱恚痴畏语。汝出去不应此中住。如是谏坚持不舍应第二第三谏。第二第三谏舍是事善。不舍者僧伽婆尸沙

诸大德。已说十三僧伽婆尸沙法。九初罪四乃至三谏。若比丘犯一一戒。知故覆藏随几时应与波利婆沙。行波利婆沙已。六夜行摩那埵。次到阿浮呵那。如法作已。应二十僧中出罪。若少一人不满二十。是比丘不得出罪。诸比丘应如法呵。是法应尔。今问。诸大德是中清净不(第二第三亦如是说)诸大德是中清净。默然故。是事如是持

诸大德。是二不定法。半月半月戒经中说

若比丘。共一女人独屏处可淫处坐。可信优婆夷见。于三法中一一法说。若波罗夷。若僧伽婆尸沙。若波逸提。若比丘言。如优婆夷所说。应三法中随所说治。是初不定法

若比丘。共一女人独露处坐。说粗恶淫欲语。可信优婆夷见。于二法中一一法说。若僧伽婆尸沙。若波逸提。若比丘言。如优婆夷所说。应二法中随所说治。是二不定法

诸大德。已说二不定法。今问。诸大德是中清净不(第二第三亦如是说)

诸大德。是中清净。默然故。是事如是持

诸大德。是三十尼萨耆波逸提法。半月半月戒经中说

若比丘。三衣竟。舍迦絺那衣已。长衣乃至十日。若过尼萨耆波逸提

若比丘。三衣竟。舍迦絺那衣已。三衣中离一一衣宿。过一夜除僧羯磨尼萨耆波逸提

若比丘三衣竟。舍迦絺那衣已。得非时衣。若须应受速作受持。若足者善。若不足望更有得处。令具足成。乃至一月若过尼萨耆波逸提

若比丘。从非亲里比丘尼取衣除贸易。尼萨耆波逸提

若比丘。使非亲里比丘尼浣故衣。若染若打。尼萨耆波逸提

若比丘。从非亲里居士居士妇乞衣。除因缘尼萨耆波逸提。因缘者。夺衣失衣烧衣漂衣。衣坏是名因缘

若比丘。夺衣失衣烧衣漂衣。衣坏从非亲里居士居士妇乞衣。若居士居士妇。欲多与衣。是比丘应受二衣。若过是受尼萨耆波逸提

若比丘。非亲里居士居士妇。共议当以如是衣直作衣。与某甲比丘。是比丘先不自恣请。便往问居士居士妇言。汝为我以如是衣直作衣不。答言如是。便言善哉居士居士妇。可作如是衣与我为好。故尼萨耆波逸提

若非亲里居士居士妇。共议我当各以如是衣直作衣。与某甲比丘。是比丘先不自恣请。便往问居士居士妇言。汝各为我以如是衣直作衣不。答言如是。便言善哉居士居士妇。可合作一衣与我为好。故尼萨耆波逸提

若王若大臣婆罗门居士。为比丘故。遣使送衣直使到比丘所言。大德。彼王大臣送此衣直。大德受之。是比丘言。我不应受衣直。若得净衣当手受持。使言。大德有执事人不。比丘即指示处。使便到执事所语言。某王大臣送此衣直。与某甲比丘。汝为受作取便与之。使既与已还比丘所。白言大德。所示执事人我已与竟。大德须衣。便可往取。是比丘二返三返到执事所语言。我须衣我须衣。若得者善。若不得四返五返六返到执事前。默然立。若得者善。若过求得者尼萨耆波逸提。若不得衣随使来处。若自往若遣信语言。汝为某甲比丘送衣直。是比丘竟不得汝还自索莫使失是事应尔

若比丘。自行乞缕雇织师织作衣。尼萨耆波逸提

若居士居士妇。为比丘使织师织作衣是比丘先不自恣请。便到织师所作是言。汝知不。此衣为我作。汝好为我织。令极致广当别。相报后若与一食若一食直得者。尼萨耆波逸提

若比丘。与比丘衣后嗔不喜。若自夺若使人夺。作是语还我衣不与汝。尼萨耆波逸提

若比丘。知檀越欲与僧物。回以入己。尼萨耆波逸提

若比丘。病得服四种含消药。酥油蜜石蜜一受。乃至七日若过。尼萨耆波逸提

若比丘。住阿炼若处。安居三月未满八月。若处有恐怖听。寄一一衣着界内白衣家。若有因缘出界离此衣。宿乃至六夜若过。尼萨耆波逸提

若比丘。春余一月应求雨浴衣。余半月应持。若未至一月求先半月持。尼萨耆波逸提

若比丘。前后安居十日未至自恣。得急施衣。若须应受。乃至衣时若过。尼萨耆波逸提

若比丘。钵未满五缀。更乞新钵为好故。尼萨耆波逸提。是钵应僧中舍。僧应取众中最下钵与之语言。汝受是钵乃至破。是法应尔

若比丘。长钵乃至十日若过。尼萨耆波逸提

若比丘。新憍赊耶作卧具。尼萨耆波逸提

若比丘。纯黑羺羊毛作新卧具。尼萨耆波逸提

若比丘。作新卧具应用二分纯黑羺羊毛。第三分白。第四分下若过。是作尼萨耆波逸提

若比丘。作新卧具应六年畜。未满六年若舍若不舍。更作新卧具除僧羯磨。尼萨耆波逸提

若比丘。纯黑羺羊毛作新尼师坛应用。故尼师坛一修伽陀搩手坏好色若不坏。尼萨耆波逸提

若比丘。得羊毛须持有所至。若自持乃至三由旬若过。尼萨耆波逸提

若比丘。使非亲里比丘尼浣染擘羺羊毛。尼萨耆波逸提

若比丘。种种贩卖求利。尼萨耆波逸提

若比丘。以金银及钱种种卖买。尼萨耆波逸提

若比丘。自捉金银及钱。若使人捉若发心受。尼萨耆波逸提

诸大德。已说三十尼萨耆波逸提法。今问。诸大德是中清净不(第二第三亦如是说)

诸大德。是中清净。默然故。是事如是持

诸大德。是九十一波逸提法半月半月戒经中说

若比丘故妄语。波逸提

若比丘。毁呰比丘。波逸提

若比丘。两舌斗乱比丘。波逸提

若比丘。为女人说法过五六语。除有别知善恶语男子。波逸提

若比丘。知僧如法断事竟还发起。波逸提

若比丘。教未受具戒人经并诵者。波逸提

若比丘。与未受具戒人。宿过三夜。波逸提

若比丘。向未受具戒人。自说得过人法。言我如是知如是见实者。波逸提

若比丘。知他比丘粗罪。向未受具戒人说除僧羯磨。波逸提

若比丘。作是语何用是杂碎戒。为说是戒时令人忧恼作。如是毁呰戒者。波逸提

若比丘。自伐鬼村若使人伐。波逸提

若比丘。故不随问答。波逸提

若比丘。诬说僧所差人。波逸提

若比丘。于露地自敷僧卧具。若使人敷。若他敷若坐若卧去时。不自举不教人举不嘱举。若见僧卧具敷在露地而不举者。波逸提

若比丘。于僧房内自敷僧卧具。若使人敷。若他敷若坐若卧去时。不自举不教人举不嘱举。波逸提

若比丘。嗔不喜于僧房中自牵比丘出。若使人牵作是语出去灭去莫此中住。波逸提

若比丘。知他先敷卧具。后来强自敷。若使人敷作是念。若不乐者自当出去。波逸提

若比丘。僧重阁上尖脚绳床木床用力坐卧。波逸提

若比丘作大房舍从平地垒留窗户处。极令坚牢再三重覆。若过波逸提

若比丘。知水有虫若取浇泥。若饮食诸用。波逸提

若比丘。僧不差教诫比丘尼。波逸提

若比丘。僧差教诫比丘尼至日没。波逸提

若比丘僧不差为教诫故。入比丘尼住处。除病因缘。波逸提

若比丘。作是语。诸比丘为供养利故。教诫比丘尼。波逸提

若比丘。与比丘尼。式叉摩那沙弥尼。独屏处坐。波逸提

若比丘。与非亲里比丘尼衣除贸易。波逸提

若比丘。与非亲里比丘尼作衣。波逸提

若比丘。与比丘尼先期共道行。从此聚落到彼聚落。除因缘。波逸提。因缘者。若多伴有疑畏处。是名因缘

若比丘。与比丘尼先期共船行。若上水若下水。除直渡。波逸提

若比丘。知比丘尼赞叹因缘。得食食。除檀越先发心作。波逸提

若比丘。数数食。除因缘。波逸提。因缘者。病时衣时施衣时。是名因缘

若比丘。受别请众食。波逸提。除因缘。因缘者。病时衣时施衣时作衣时。行路时船上行时。大会时沙门会时。是名因缘

若比丘。无病施一食处过一食。波逸提

若比丘。到白衣家自恣多与饮食。若饼若糗。若不住其家食须二三钵。应受出外与余比丘共食。若无病过是受及不与余比丘共食。波逸提

若比丘。食竟不作残食法。波逸提

若比丘。知他比丘食竟。不作残食法。强劝令食欲使犯罪。波逸提

若比丘。不受食着口中。除尝食杨枝及水。波逸提

若比丘。非时食。波逸提

若比丘。食残宿食波逸提

若比丘。自手与外道裸形若男若女食。波逸提

若诸家中有如是美食。乳酪酥油鱼肉。若比丘无病为己索得食者。波逸提

若比丘。食家中与女人坐。波逸提

若比丘。与女人独屏处坐。波逸提

若比丘。与女人独露处坐。波逸提

若比丘。观军发行。波逸提

若比丘。有因缘到军中乃至二三宿若过。波逸提

若比丘。有因缘到军中。二三宿观军阵合战。波逸提

若比丘。作是语。如我解佛所说。障道法不能障道。诸比丘语彼比丘。汝莫作是语莫谤佛莫诬佛。佛说障道法实能障道。汝舍是恶邪见。如是谏坚持不舍。应第二第三谏。舍是事善。不舍者波逸提

若比丘。知彼比丘不如法悔。不舍恶邪见。共坐共语共宿共事。波逸提

若沙弥作是语。如我解佛所说。受五欲不能障道。诸比丘语是沙弥。汝莫作是语莫谤佛莫诬佛。佛说五欲障道实能障道。汝沙弥舍是恶邪见。如是教坚持不舍。应第二第三教。第二第三教舍是事善。若不舍诸比丘应语。是沙弥汝出去。从今莫言佛是我师。莫在比丘后行如余沙弥得。共比丘二宿汝亦无是事。痴人出去灭去莫此中住。若比丘知如法摈沙弥。畜使共住共语。波逸提

若比丘。故夺畜生命。波逸提

若比丘。故令比丘生疑悔作是念。令彼比丘乃至少时恼。波逸提

若比丘。僧断事时不与欲起去。波逸提

若比丘击擽比丘。波逸提

若比丘。水中戏。波逸提

若比丘。与女人同室宿。波逸提

若比丘。饮酒波逸提

若比丘。轻师及戒。波逸提

若比丘。自掘地若使人掘言掘者。波逸提

若比丘。共诤己默听作是念。诸比丘所说我忆持。波逸提

若比丘。知不满二十岁与受具足戒。波逸提

是人不得戒。诸比丘亦可呵。是法应尔

若比丘。受四月自恣请药。若过是受。除更请自送请长请。波逸提

若比丘。数数犯罪。诸比丘如法谏作是语。我不学是戒。当问余比丘持法持律者。波逸提。比丘欲求解应问持法持律者。是法应尔

若比丘。说戒时作是语。我今始知是法半月布萨戒经中说。诸比丘知是比丘已再三说戒中坐。是比丘不以不知故。得脱随所犯罪如法治。应呵其不知所作不善说戒时。不一心听。不着心中。波逸提

若比丘。王未出未藏宝。若入过后宫门限。波逸提

若比丘。与贼期共道行。从此聚落到彼聚落。波逸提

若比丘。与女人期共道行。从此聚落到彼聚落。波逸提

若比丘。无病为炙故自然火。若使人然。波逸提

若比丘。若宝若宝等物。若自取若教人取。除僧坊内及宿处。波逸提。若僧坊内及宿处取宝等物。后有主索应还。是事应尔

若比丘半月内浴除因缘波逸提。因缘者。病时作时行时风雨时热时。是名因缘

若比丘。嗔故打比丘。波逸提

若比丘。嗔故以手拟比丘。波逸提

若比丘。故恐怖比丘。波逸提

若比丘。知比丘犯粗罪。覆藏过一宿。波逸提

若比丘。以无根僧伽婆尸沙谤比丘。波逸提

若比丘。语彼比丘共到诸家。与汝多美饮食。既到不与作是言。汝出去共汝若坐若语不乐。我独坐独语乐。欲令彼恼。波逸提

若比丘。新得衣应三种色作帜。若青若黑若木兰。若不以三色作帜。波逸提

若比丘。为戏笑故。藏比丘若衣若钵坐具针筒。如是一一生活具。若使人藏。波逸提

若比丘。僧断事时如法与欲竟后更呵。波逸提

若比丘。作是语。诸比丘随知识回僧物与。波逸提

若比丘。与比丘比丘尼。式叉摩那沙弥沙弥尼。净施衣还夺。波逸提

若比丘。受他请食前食后食。行诣余家不近白余比丘。除因缘。波逸提。因缘者衣时。是名因缘

若比丘。非时入聚落不近白善比丘。除因缘。波逸提。因缘者。难时。是名因缘

若比丘。以兜罗贮坐卧具。波逸提

若比丘。自作坐卧绳床木床。足应高修伽陀八指。除入梐。若过波逸提

若比丘。用骨牙角作针筒。波逸提

若比丘。作尼师坛应如量作。长二修伽陀搩手。广一搩手半。若续方一搩手。若过波逸提

若比丘。作覆疮衣应如量作。长四修伽陀搩手。广二搩手。若过波逸提

若比丘。作雨浴衣应如量作。长五修伽陀搩手。广二搩手半。若过波逸提

若比丘。作修伽陀衣量衣。若过波逸提。修伽陀衣量者。长九修伽陀搩手。广六搩手。是名修伽陀衣量

若比丘。知檀越欲与僧物。回与余人。波逸提

诸大德。已说九十一波逸提法。今问。诸大德是中清净不(第二第三亦如是说)

诸大德。是中清净。默然故。是事如是持

诸大德。是四波罗提提舍尼法。半月半月戒经中说。若比丘。无病在街巷中。从非亲里比丘尼自手受食。是比丘应向诸比丘悔过。我堕可呵法。今向诸大德悔过。是名悔过法

若比丘。白衣家请食。有比丘尼。教益食人与是比丘饭与是比丘羹。诸比丘应语是比丘尼。姊妹小却待。诸比丘食竟若众中乃至无一人语者。是诸比丘应向诸比丘悔过。我堕可呵法。今向诸大德悔过。是名悔过法

有诸学家僧作学家羯磨。若比丘无病先不受请。于是学家自手受食。是比丘应向诸比丘悔过。我堕可呵法。今向诸大德悔过。是名悔过法

若比丘。住阿炼若处。有疑恐怖先不伺视。在僧坊内自手受食不出外受。是比丘应向诸比丘悔过。我堕可呵法。今向诸大德悔过。是名悔过法

诸大德。已说四波罗提提舍尼法。今问。诸大德是中清净不(第二第三亦如是说)诸大德。是中清净。默然故。是事如是持

诸大德。是众学法半月半月戒经中说

不高着内衣。应当学

不下着内衣。应当学

不参差着内衣。应当学

不如多罗叶着内衣。应当学

不如象鼻着内衣。应当学

不如圆奈着内衣。应当学

不细摄着内衣。应当学

不高披衣。应当学

不下披衣。应当学

不参差披衣。应当学

好覆身入白衣舍。应当学

好覆身入白衣舍坐。应当学

不反抄衣着右肩上。入白衣舍。应当学

不反抄衣着右肩上。白衣舍坐。应当学

不反抄衣着左肩上。入白衣舍。应当学

不反抄衣着左肩上。白衣舍坐。应当学

不左右反抄衣着两肩上。入白衣舍。应当学

不左右反抄衣着两肩上。入白衣舍坐。应当学

不摇身入白衣舍。应当学

不摇身白衣舍坐。应当学

不摇头入白衣舍。应当学

不摇头白衣舍坐。应当学

不摇肩入白衣舍。应当学

不摇肩白衣舍坐。应当学

不携手入白衣舍。应当学

不携手白衣舍坐。应当学

不隐人入白衣舍。应当学

不隐人白衣舍坐。应当学

不叉腰入白衣舍。应当学

不叉腰白衣舍坐。应当学

不拄颊入白衣舍。应当学

不拄颊白衣舍坐。应当学

不掉臂入白衣舍。应当学

不掉臂白衣舍坐。应当学

不高视入白衣舍。应当学

不高视白衣舍坐。应当学

不左右顾视入白衣舍。应当学

不左右顾视白衣舍坐。应当学

不蹲行入白衣舍。应当学

不蹲行白衣舍坐。应当学

不企行入白衣舍。应当学

不企行白衣舍坐。应当学

不覆头入白衣舍。应当学

不覆头白衣舍坐。应当学

不戏笑入白衣舍。应当学

不戏笑白衣舍坐。应当学

不高声入白衣舍。应当学

不高声白衣舍坐。应当学

庠序入白衣舍。应当学

庠序白衣舍坐。应当学

一心受食。应当学

不溢钵受食。应当学

羹饭俱食。应当学

不于钵中处处食。应当学

不刳中央食。应当学

不曲指抆钵食。应当学

不嗅食食。应当学

谛视钵食。应当学

不弃饭食。应当学

不以食手捉净饭器。应当学

不吸食食。应当学

不嚼食作声食。应当学

不舐饭食。应当学

不满手食。应当学

不大张口食。应当学

饭未至不大张口待。应当学

不缩鼻食。应当学

不含食语。应当学

不胀颊食。应当学

不啮半食。应当学

不舒臂取食。应当学

不振手食。应当学

不吐舌食。应当学

不全吞食。应当学

不抟饭遥掷口中。应当学

不以钵中有食水洒白衣屋内。应当学

不以饭覆羹更望得。应当学

不嫌呵食。应当学

不为己索益食。应当学

不嫌心视比坐钵。应当学

不立大小便。除病应当学

不大小便净水中。除病应当学

不大小便生草菜上。除病应当学

人着屐不应为说法。除病应当学

不为着革屣人说法。除病应当学

人现胸不应为说法。除病应当学

人坐比丘立。不应为说法。除病应当学

人在高坐比丘在下。不应为说法。除病应当学

人卧比丘坐。不应为说法。除病应当学

人在前比丘在后。不应为说法。除病应当学

人在道中比丘在道外。不应为说法。除病应当学

不为覆头人说法。除病应当学

不为反抄衣人说法。除病应当学

不为左右反抄衣人说法。除病应当学

不为持盖覆身人说法。除病应当学

不为骑乘人说法。除病应当学

不为拄杖人说法。除病应当学

不为捉刀人说法。除病应当学

不为捉弓箭人说法。除病应当学

树过人不得上。除大因缘。应当学

诸大德。已说众学法。今问。诸大德是中清净不(第二第三亦如是说)诸大德。是中清净。默然故。是事如是持

诸大德。是七灭诤法。半月半月戒经中说

应与现前比尼。与现前比尼

应与忆念比尼。与忆念比尼

应与不痴比尼。与不痴比尼

应与本言与本言治

应与自言。与自言治

应与多人语。与多人语

应与草布地。与草布地

诸大德。已说七灭诤法。今问诸大德是中清净不(第二第三亦如是说)

诸大德。是中清净。默然故。是事如是持

诸大德。已说戒经序。已说四波罗夷法。已说十三僧伽婆尸沙法。已说二不定法。已说三十尼萨耆波逸提法。已说九十一波逸提法。已说四波罗提提舍尼法。已说众学法。已说七灭诤法。是法入佛戒经中。半月半月波罗提木叉中说。及余随道戒法。是中诸大德。一心和合欢喜不诤。如水乳合安乐行。应当学

比婆尸如来应正遍知。为寂静僧。略说波罗提木叉

  忍辱第一道　　涅盘佛称最
  出家恼他人　　不名为沙门

尸弃如来应正遍知。为寂静僧。略说波罗提木叉

  譬如明眼人　　能避险恶道
  世有聪明人　　能远离诸恶

比叶婆如来应正遍知。为寂静僧。略说波罗提木叉

  不恼不说过　　如戒所说行
  饭食知节量　　常乐在闲处
  心寂乐精进　　是名诸佛教

拘留孙如来应正遍知。为寂静僧。略说波罗提木叉

  譬如蜂采花　　不坏色与香
  但取其味去　　比丘入聚落
  不破坏他事　　不观作不作
  但自观身行　　谛视善不善

拘那含牟尼如来应正遍知。为寂静僧。略说波罗提木叉

  欲得好心莫放逸　　圣人善法当勤学
  若有知寂一心人　　尔乃无复忧愁患

迦叶如来应正遍知。为寂静僧。略说波罗提木叉

  一切恶莫作　　当具足善法
  自净其志意　　是则诸佛教

释迦牟尼如来应正遍知。为寂静僧。略说波罗提木叉

  护身为善哉　　能护口亦善
  护意为善哉　　护一切亦善
  比丘护一切　　便得离众苦
  比丘守口意　　身不犯众恶
  是三业道净　　得圣所得道
  若人打骂不还报　　于嫌恨人心不恨
  于嗔人中心常静　　见人为恶自不作
  七佛为世尊　　能救护世间
  所可说戒经　　我已广说竟
  诸佛及弟子　　恭敬是戒经
  恭敬戒经已　　各各相恭敬
  惭愧得具足　　能得无为道

诸大德。已说波罗提木叉竟。僧一心得布萨

沙弥塞五分戒本一卷按此戒本国本同于宋本。丹本独异。如何去取。今以本律捡之。此丹本乃正也。彼国宋两本。即此随函中十诵比丘波罗提木叉戒本。鸠摩罗什译者。错重写为五分戒本。而云佛陀什译。其间虽有小不同处。但是写笔之错耳。故今取此丹本入藏


摩诃僧祇比丘尼戒本

    No. 1427 [cf. No. 1425]

摩诃僧祇比丘尼戒本

        东晋平阳沙门法显共觉贤译

阿梨耶僧听。冬时一月过少一夜。余有一夜三月在。老死至近佛法欲灭。诸阿梨耶。为得道故一心勤精进。所以者何。诸佛一心勤精进故得阿耨多罗三藐三菩提。何况余助道法。未受具足者已出。僧今和合先作何事(一人应答布萨说戒)

诸阿梨耶不来。诸比丘尼说欲及清净

  合十指爪掌　　供养释师子
  我今欲说戒　　僧当一心听
  乃至小罪中　　心应大怖畏
  有罪一心悔　　后更莫复犯
  心马驰恶道　　放逸难禁制
  佛说切戒行　　亦如利辔勒
  佛口说教诫　　善者能信受
  是人马调顺　　能破烦恼军
  若不受教敕　　亦不爱乐戒
  是人马不调　　没在烦恼军
  若人守护戒　　如[犛-未+牙]牛爱尾
  系心不放逸　　亦如猴着锁
  日夜勤精进　　求实智慧故
  是人佛法中　　能得清净命

诸阿梨耶僧听。今十五日布萨说波罗提木叉。若僧时到。僧忍听。相当一心共作布萨说波罗提木叉。白如是。诸阿梨耶。今共布萨说波罗提木叉。僧一心善听。有罪者应发露。若无罪者默然。默然故当知诸阿梨耶清净。如一一比丘尼问答。是比丘尼众中三唱亦如是。若比丘尼。如是比丘尼众中第二第三唱。忆有罪者不发露得故妄语罪。诸阿梨耶。故妄语罪佛说遮道法。比丘尼于是中欲求清净。忆有罪应发露。发露则安隐。不发露罪益深。诸阿梨耶。已说波罗提木叉序。今问诸阿梨耶。是中清净不。第二第三如是问。诸阿梨耶。是中清净默然故。是事如是持

诸阿梨耶。是八波罗夷法。半月半月波罗提木叉。中说。若比丘尼。于和合二部僧中受具足戒。不还戒。戒羸不出。相行淫法。乃至共畜生。是比丘尼犯波罗夷罪不应共住

若比丘尼。于聚落若空地。不与取随盗。物王或捉或杀或缚或摈出言。咄女人。汝贼汝痴。比丘尼如是不与取波罗夷不应共住

若比丘尼。自手夺人命。求持刀与杀者。教死叹死。咄人用恶活为死胜生。作如是意如是想。方便叹誉死快。因是死非余。是比丘尼波罗夷不应共住

若比丘尼。未知未了自称得过人法圣知见殊胜。我如是知如是见。彼于后时若检校若不检校犯罪。欲求清净故便作是言。阿梨耶。我不知言知不见言见。空诳不实语除增上慢。是比丘尼得波罗夷不应共住

若比丘尼漏心。漏心男子边。肩以下膝以上摩触受乐者。是比丘尼波罗夷不应共住

若比丘尼漏心。漏心男子伸手内住共语。受捉手捉衣。来欢喜请坐。曲身就共期去。是比丘尼波罗夷不应共住

若比丘尼。知比丘犯重罪不向人说。是比丘尼若离处若死若罢道。后作是言。我先知是比丘尼犯重罪。不向人说。不欲令他知。是比丘尼波罗夷不应共住

若比丘尼。知僧和合如法如比尼与比丘作举羯磨。未作如法而随顺。诸比丘尼应谏是比丘尼。阿梨耶。是比丘。僧和合如法如比尼。作举羯磨。未作如法莫随顺。是比丘尼。诸比丘尼谏时作是语。我不随顺谁当随顺。诸比丘尼如是第二第三谏。舍是事好。若不舍者。是比丘尼波罗夷不应共住

诸阿梨耶。已说八波罗夷法若比丘尼犯一一法。是比丘尼不应共住。如前后亦如是。比丘尼得波罗夷罪不应共住。今问诸阿梨耶。是中清净不第二第三亦如是问诸阿梨耶。是中清净默然故。是事如是持

诸阿梨耶。是十九僧伽婆尸沙法。半月半月波罗提木叉中说

若比丘尼。受使行和合男女。若取妇若私通。乃至须臾顷。是法初罪僧伽婆尸沙

若比丘尼。嗔恨不喜故。于清净无罪比丘尼。以无根波罗夷法谤。欲破彼比丘尼净行。彼于后时若检校若不检校便作是言。是事无根。我住嗔恨故作是语。是法初罪僧伽婆尸沙

若比丘尼。嗔恨不喜故。以异分中小小事非波罗夷。比丘尼以波罗夷法谤。欲破彼梵行。彼于后时若检校若不检校以异分中小小事。是比丘尼住嗔恨故。是法初罪僧伽婆尸沙

若比丘尼诤讼相言。若俗人若出家人昼日须臾。乃至与园民沙弥共斗相言。是法初罪僧伽婆尸沙

若比丘尼。无比丘尼伴行不得出聚落界。除余时。余时者。不欲病是名余时。是法初罪僧伽婆尸沙

若比丘尼。离比丘尼一夜宿。除余时。余时者。若病时贼乱围城时。是名余时。是法初罪僧伽婆尸沙

若比丘尼。其主不听而度。是法初罪僧伽婆尸沙

若比丘尼。知他犯罪女众亲欲治而度。除余时。余时者。先外道度是名余时。是法初罪僧伽婆尸沙

若比丘尼。于船渡处独渡河者。是法初罪僧伽婆尸沙

若比丘尼。知比丘尼僧和合如法比尼作举羯磨。未作如法。先不语僧自与舍。是法初罪僧伽婆尸沙(十事竟)

若比丘尼无漏心。漏心男子边取衣钵饮食疾病汤药者。是法初罪僧伽婆尸沙

若比丘尼语比丘尼作是语。可取此男子施。漏心不漏心何预汝事。但汝莫漏心。可取施已随因缘用。诸比丘尼应谏是比丘尼。莫作是语。应取是施。男子漏心不漏心何预人事。但使汝无漏心。可取施已随因缘用。如是应第二第三谏。舍是事好。若不舍者僧伽婆尸沙

若比丘尼。欲破和合僧故。执持破僧事共诤。诸比丘尼应语是比丘尼。阿梨耶。莫破和合僧勤方便执持破僧事共诤。当与僧同事。何以故。僧和合欢喜不诤。共一学如水乳合。如法说安乐住。是比丘尼。诸比丘尼谏时。坚持不舍者。应第二第三谏。舍者善。若不舍者。是法乃至三谏。僧伽婆尸沙

若诸比丘尼同意相助。若一若二若众多。同语同见欲破和合僧。是比丘尼。诸比丘尼谏时。是同意比丘尼言。阿梨耶。莫说是比丘尼好恶。何以故。是法语比丘尼律语比丘尼。是比丘尼所说。皆是我等所欲。是比丘尼所见欲忍可事。我等亦欲忍可。是比丘尼知说非不知说。诸比丘尼应谏是同意比丘尼。阿梨耶莫作是语。法语比丘尼律语比丘尼。何以故。此非法语比丘尼律语比丘尼。阿梨耶。莫助破僧事当乐和合僧。何以故。僧和合欢喜不诤。共一学如水乳合。如法说安乐住。是比丘尼。诸比丘尼谏时。坚持不舍者。应第二第三谏。舍是事善。若不舍是法乃至三谏。僧伽婆尸沙

若比丘尼嗔恚非理谤僧。作如是言。僧随爱随嗔随怖随痴。僧依爱嗔怖痴。是故呵责。是比丘尼。诸比丘尼应谏作是言。阿梨耶。莫作是语。僧随爱随嗔随怖随痴。僧依爱嗔怖痴。何以故。僧不随爱嗔怖痴。汝莫嗔恚非理谤僧。是比丘尼。诸比丘尼谏时。坚持不舍者。应第二第三谏。舍是事好。若不舍。是法乃至三谏。僧伽婆尸沙

若比丘尼。自用戾语。诸比丘尼共法中如法如律教。便自用意作是言。汝莫语我若好若恶。我亦不语汝若好若恶。诸比丘尼应谏彼比丘尼言。阿梨耶。诸比丘尼共法中如法如律教。汝莫自用语。诸比丘尼教汝。汝当信受。汝亦应如法如律教诸比丘尼。何以故。如来弟子中展转相教展转相谏。共罪中出故善法得增长。是比丘尼。诸比丘尼谏时。坚持不舍者。应第二第三谏。舍是事善。若不舍是法乃至三谏。僧伽婆尸沙

若二比丘尼习近住。迭相覆过。诸比丘尼应谏是比丘尼言。阿梨耶。莫习近住迭相覆过。习近住不生善法。是比丘尼。诸比丘尼谏时。坚持不舍应第二第三谏。舍是事善。若不舍是法乃至三谏。僧伽婆尸沙

若比丘尼见相远住。便劝作是言。当习近住迭相藏过。莫相离住不妨生长善法。余人亦有如是相近住者。僧不能遮。轻易汝故相禁制耳。诸比丘尼应谏是比丘尼言。阿梨耶。某甲某甲相远住。莫劝习近住迭相覆过。习近住不妨生善法。莫作是语。余人亦有习近住。僧不能遮。轻易汝故相禁制耳。是比丘尼。诸比丘尼谏时。坚持不舍者。应第二第三谏。舍是事善。若不舍者。是法乃至三谏。僧伽婆尸沙

若比丘尼。嗔恚欲舍戒。作是言。我舍佛舍法舍僧。舍说舍共住共食。舍经论舍沙门尼释种。用是沙门尼释种为。余更有胜处。我于彼中修梵行。诸比丘尼应谏是比丘尼言。阿梨耶。莫嗔恚舍戒作是言。我舍佛乃至舍沙门尼释种。舍佛者不善。诸比丘尼如是谏时。故坚持不舍者应第二第三谏。舍是事好。若不舍是法乃至三谏。僧伽婆尸沙(十九事竟)

诸阿梨耶已说十九僧伽婆尸沙法十一初罪八乃至三谏若比丘尼犯一一罪。半月二部众中行摩那埵。次到阿浮呵那二十众二部僧中应出罪。称可众人意。二十人中若少一人。此比丘尼不名出罪。诸比丘比丘尼应呵责。是名时。今问诸阿梨耶。是中清净不。第二第三亦如是问。诸阿梨耶。是中清净默然故。是事如是持

诸阿梨耶。是三十尼萨耆波夜提法。半月半月波罗提木叉中说

若比丘尼。衣已竟迦絺那衣已舍。若得长衣得至十日畜。若过者尼萨耆波夜提

若比丘尼衣已竟迦絺那衣已舍。五衣中若离一一衣余处一宿。除僧羯磨尼萨耆波夜提

若比丘尼。衣已竟迦絺那衣已舍。若得非时衣。比丘尼若须应取疾作衣受。若不足者有望处。为满故听一月畜。若过畜者。足不足尼萨耆波夜提

若比丘尼。自手捉生色似色。若使人捉举染著者。尼萨耆波夜提

若比丘尼。种种卖买尼萨耆波夜提

若比丘尼。从非亲里居士居士妇乞衣。尼萨耆波夜提。除余时。余时者。失衣时。是名余时

若比丘尼失衣时。得从非亲里居士居士妇乞衣。若自恣与得取上下衣。过是受者。尼萨耆波夜提。若居士居士妇为比丘尼办衣价。如是言。我办如是衣价。买如是衣。与某甲比丘尼。是比丘尼。先不自恣请。为好故便往劝言。善哉优婆夷。办如是衣价。买如是色衣与我。若得衣者。尼萨耆波夜提

为比丘尼故若二居士居士妇。各各办衣价。如是言。我等办如是如是衣价。买如是如是衣。与某甲比丘尼。是比丘尼。先不自恣请。为好故便到居士所言。为我各各办如是如是衣价。共作一衣与我为好故。若得是衣。尼萨耆波夜提

为比丘尼故若王若大臣。遣使送衣直与比丘尼。使到比丘尼所白言。阿梨耶。是衣直。若王若大臣所送。阿梨耶。应受是衣价。是比丘尼。应语使如是言。诸比丘尼法。不应受是衣价。我须衣时。得清净衣者。得自手受作比丘尼衣畜。使语比丘尼。阿梨耶。有执事人。常为诸比丘尼执事不。是比丘尼。应示使执事人。若园民。若优婆塞。应语使到。言善哉执事。如是如是衣价。买如是如是衣。与某甲比丘尼。是比丘尼须衣时。当来当与衣。是使若自劝喻。若使人劝喻已。还到比丘尼所白言。阿梨耶。所示执事人。我已劝喻作衣。阿梨耶须衣时往取。当与阿梨耶衣。须衣比丘尼。应到执事所索衣。应作是言。我须衣我须衣。第二第三亦如是索。若得衣者好。若不得。第四第五第六应在执事前默然立。若得衣者善。若不得。过是求。若得衣。尼萨耆波夜提

若不得衣。随衣价来处自去。若遣使应作是言。汝为某甲比丘尼送衣价。是比丘尼竟不得用。汝自知。莫使失。是事法尔。

若比丘尼。为床褥乞。而自作衣钵饮食疾病汤药者。尼萨耆波夜提

若比丘尼。人为作是与。而作彼用者。尼萨耆波夜提

若比丘尼为食乞作衣钵饮食汤药受用者。尼萨耆波夜提

若比丘尼畜长钵尼萨耆波夜提

若比丘尼畜长衣尼萨耆波夜提

若比丘尼。于住止处弃故僧伽梨唱言。有欲取者取。后还夺者。尼萨耆波夜提

若比丘尼。故僧伽梨若自擿若使人擿。过五六日不自缝不使人缝。除病尼萨耆波夜提

若比丘尼。语式叉摩尼言。与我衣当与汝受具足。取衣已不与受具足者。尼萨耆波夜提

若比丘尼。过四羯利沙槃市重衣。尼萨耆波夜提

若比丘尼过两羯利沙槃半。市细轻衣者。尼萨耆波夜提

若比丘尼。长钵得十日畜。若过者尼萨耆波夜提

若比丘尼。所用钵减五缀。更乞新钵为好故。尼萨耆波夜提。是钵应僧中舍。比丘尼众中。最下钵应与应如是教。汝比丘尼受是钵乃至破是事法尔

若比丘尼病所应服药酥油蜜石蜜生酥及脂如是病比丘尼听畜七日服。过七日有残不舍而服者。尼萨耆波夜提

若比丘尼。与比丘尼衣。后嗔恨不喜。若自夺若使人夺作是言。比丘尼还我衣来不与汝。得衣者尼萨耆波夜提

若比丘尼。种种贩卖生色似色者。尼萨耆波夜提

若比丘尼。自行乞缕。使非亲里织师织者。尼萨耆波夜提

若居士居士妇。使织师为比丘尼织作衣。是比丘尼先不请。便往劝织师言。汝知不。此衣为我作。汝好织令致长广。当与汝钱钱直食食直。是比丘尼如是劝。与钱钱直食食直得衣者尼萨耆波夜提

若比丘尼。十日未满。夏三月得急施衣。比丘尼须者得取畜至衣时。若过时畜尼萨耆波夜提

若比丘尼。知他市得而抄买者。尼萨耆波夜提

若比丘尼。知他物向僧自回向已。尼萨耆波夜提(三十事竟)

诸阿梨耶。已说三十尼萨耆波夜提法。今问诸阿梨耶。是中清净不。第二第三亦如是问。诸阿梨耶。是中清净默然故。是事如是持

诸阿梨耶。是百四十一波夜提法。半月半月波罗提木叉中说

若比丘尼。知而妄语波夜提

若比丘尼。种类形相语波夜提

若比丘尼。两舌者波夜提

若比丘尼。知僧如法如律灭诤事已更发起言。此羯磨不了当更作。作是因缘不异波夜提

若比丘尼。故夺畜生命波夜提

若比丘尼。教未受具戒人说句法波夜提

若比丘尼。自称向未受具戒人得过人法。我如是知如是见。说实者波夜提

若比丘尼。知他比丘尼粗罪。向未受具戒人说。除僧羯磨波夜提

若比丘尼。僧应分物。先听与而后遮言。阿梨耶。汝亲友意回僧物与波夜提

若比丘尼。半月诵波罗提木叉经时作是言。阿梨耶。用说是杂碎戒为使诸比丘尼生疑悔作是轻呵戒因缘不异波夜提(十事竟)

若比丘尼。坏种子破鬼村波夜提

若比丘尼。异语恼他波夜提

若比丘尼。嫌责者波夜提

若比丘尼。僧住处露地敷卧床坐床褥枕。若自敷若使人敷。去时不自举不使人举。波夜提

若比丘尼。僧房内覆处自敷床褥若使人敷。去时不自举不使人举。波夜提

若比丘尼在僧房内。若自牵比丘尼出。若使人牵出。下至言比丘尼汝出去。作是语者波夜提

若比丘尼。知僧房内比丘尼先敷床褥。后来敷欲扰乱故敷置。不乐者自当出去。作是因缘不异波夜提

若比丘尼。僧房阁屋上敷尖脚床。若坐若卧波夜提

若比丘尼。知水有虫浇草泥。若使人浇波夜提

若比丘尼。故令他比丘尼起疑悔须臾不乐。是因缘不异波夜提(二十事竟)

若比丘尼施一食处。不病比丘尼应一食。过者波夜提

若比丘尼处处食除余时波夜提。余时者病时施衣时是名余时

若比丘尼。净施比丘比丘尼式叉摩那沙弥沙弥尼衣已后不舍而受用者波夜提

若比丘尼。知彼食已足。离坐不作残食法。欲恼故劝食者。波夜提

若比丘尼。不与不受着口中。除水及杨枝波夜提

若比丘尼。非时食波夜提

若比丘尼。停食食波夜提

若比丘尼。往白衣家。自恣与饼糗得受两三钵。出外共不病比丘尼食。若过受出外不共不病比丘尼食者。波夜提

若比丘尼。戏笑藏他衣钵尼师坛针筒。若使人藏波夜提

若比丘尼。别众食。除余时波夜提。余时者。病时衣时行时船上时大众时外道施食时(三十事竟)

若比丘尼。无病为身然草木牛屎。若自然若使人然。除因缘波夜提

若比丘尼。与未受具戒人同屋过三宿者波夜提

若比丘尼与羯磨欲已。后嗔恨不喜作是言。我不与欲不好与。此羯磨不成就。我不与此欲。波夜提

若比丘尼语比丘尼言。阿梨耶。共入聚落。到彼当与汝食。若自与若使人与。后欲驱故便言汝去我。共汝住不乐。我独住乐。作是因缘不异波夜提

若比丘尼作是语。阿梨耶。我知世尊说障道法。习此法者不能障道。诸比丘尼应谏言。阿梨耶。汝莫谤世尊。谤世尊者不善。世尊不作是语。世尊说障道法实障道。汝舍此恶事。如是谏时坚持不舍应第二第三谏。舍者善。若不舍。僧应作举羯磨。是比丘尼波夜提

若比丘尼知是比丘尼恶见不舍僧如法如律作举羯磨。未作如法如律。共食共同室住波夜提

若沙弥尼作是言。如来说淫欲是障道法。我知习淫欲不能障道。诸比丘尼应谏言。汝沙弥尼莫谤世尊。谤世尊者不善世尊不作是语。世尊说淫欲实障道。汝舍此恶见。如是谏时若坚持不舍者。应第二第三谏。若舍者善。若不舍者应驱出言。从今日。汝沙弥尼不应言佛是我师。亦不得共比丘尼三宿。汝去不得此中住。若比丘尼知沙弥尼恶见不舍驱出。未作如法诱唤畜养共食共住波夜提

若比丘尼得新衣。当三种坏色。若一一坏色青黑木兰。若不若不作三种一一坏色受用者波夜提

若比丘尼若宝若名宝园内自取若使人取除余时波夜提。余时者。比丘尼若宝若名宝。若自取若使人取作是。念有主求者与。是名余时

若比丘尼。恐怖比丘尼波夜提(四十事竟)

若比丘尼。知水有虫而饮者波夜提

若比丘尼。无衣外道出家男女自手与食波夜提

若比丘尼。知食家淫处坐波夜提

若比丘尼。知食家屏处坐波夜提

若比丘尼。观军发行波夜提

若比丘尼。有因缘事得到军中三宿。若过者波夜提

若比丘尼。有因缘事得到军中三宿。若看军发行牙旗斗势波夜提

若比丘尼。嗔恨不喜打比丘尼者波夜提

若比丘尼。嗔恨不喜掌刀拟比丘尼者波夜提

若比丘尼。水中戏波夜提(五十事竟)

若比丘尼。以指相指波夜提

若比丘尼。知贼众期共道行。下至聚落中波夜提

若比丘尼。自手掘地若使人掘。指示语掘是地。波夜提

若比丘尼。四月别请应受。若过受波夜提。除更请长自恣请

若比丘尼。语比丘尼言。阿梨耶。当学莫犯五众罪。是言。我不随汝语。若见余阿梨耶寂根多闻持法深解。我当从咨问。彼有所说我当受行。除余时作是语者波夜提。比丘欲得法利者应学。亦应问余比丘尼

若比丘尼。饮酒咽咽波夜提

若比丘尼。轻他比丘尼波夜提

若比丘尼。诸比丘尼诤讼时。默然立听。彼有说者我当忆持作是因缘不异波夜提

若比丘尼僧欲断事不与欲。出去不白。波夜提

若比丘尼。半月说波罗提木叉经时作是言。我今始知是法入修多罗半月波罗提木叉中说。诸比丘尼知彼比丘尼本若二若三。说波罗提木叉经中坐况复多。彼比丘尼不以不知故无罪。随所犯罪如法治。应呵言。阿梨耶。汝失善利。半月说波罗提木叉。汝不尊重不一心念。不摄耳听法。呵已波夜提(六十事竟)

若比丘尼。同食处。食前食后不白比丘尼。行至余家。除衣时波夜提

若比丘尼。入刹利灌顶王宫夫人宝物未藏下至过门限波夜提

若比丘尼。骨牙角作针筒。破已波夜提

若比丘尼作床脚。应量作长修伽陀八指。除入梐。若过截已波夜提

若比丘尼。兜罗绵贮褥。若坐若卧。出已波夜提

若比丘尼。作尼师坛应量。作长二修伽陀磔手。广一磔手半。更益一磔手。若过截已波夜提

若比丘尼。作覆疮衣。应量作长四修伽陀磔手。广二磔手半。若过截已波夜提

若比丘尼。效如来衣量等作衣。若过量截已波夜提。如来衣量长九修伽陀磔手。广六磔手

若比丘尼。嗔恨不喜。无根僧伽婆尸法谤波夜提

若比丘尼。知物向僧回向与人波夜提(七十事竟)

若比丘尼。不语主而着他衣波夜提

若比丘尼。自手与俗人外道沙门衣波夜提

若比丘尼。作安陀会应量作长。四修伽陀磔手广二磔手。若过作截已波夜提

若比丘尼。僧祇支应量作。长四修伽陀磔手广二磔手。若过作截已波夜提

若比丘尼。作雨浴衣应量作。长四修伽陀磔手广二磔手。若过作截已波夜提

若比丘尼。诣不能办衣家。为僧乞伽絺那衣波夜提

若比丘尼。不病所受持衣不随身者波夜提

若比丘尼。得佉陀尼食蒲阇尼食。更煮使人煮。更熬使人熬。更煎使人煎。不病比丘尼食者波夜提

若比丘尼。比丘食以水扇供给波夜提

若比丘尼。食蒜者波夜提(八十事竟)

若比丘尼。俗人外道自手与食波夜提

若比丘尼。作医师活命波夜提

若比丘尼。授俗人外道医方者波夜提

若比丘尼。为俗人作者波夜提

若比丘尼。知食家先不语而入者波夜提

若比丘尼。与俗人外道习近住若竟日若须臾。下至园民沙弥波夜提

若比丘尼。自咒誓他者波夜提

若比丘尼。自打而啼泣泪者波夜提

若比丘尼。语比丘尼作是言。阿梨耶。共往某甲家。彼于后不忍某甲比丘尼。无因缘不审谛闻。而呵责者波夜提

若比丘尼。悭嫉心护他家者波夜提(九十事竟)

若比丘尼。对面呵骂比丘者波夜提

若比丘尼。减十二雨畜弟子者波夜提

若比丘尼。满十二雨。十法不具足而畜弟子者波夜提

若比丘尼。十法具足。不羯磨而畜弟子者波夜提

若比丘尼。知他犯戒捉户钩开他房户共男子住。与受具足者波夜提

若比丘尼。与减二十雨童女。受具足者波夜提

若比丘尼。满二十岁童女。不与学戒而与受具足者波夜提

若比丘尼。受学戒不满学。与受具足者波夜提

若比丘尼。学戒满。不羯磨与受具足者波夜提

若比丘尼。适他妇减十二雨。与受具足者波夜提(一百事竟)

若比丘尼。适他妇满十二雨。不学戒与受具足者波夜提

若比丘尼。已适他妇受学戒不满学。与受具足者波夜提

若比丘尼。已适他妇学戒满不羯磨与受具足者波夜提

若比丘尼。与弟子受具足已。应二年教诫。若不教者波夜提

若比丘尼。受具足已。应二年供给随逐和上尼。若不供给随逐波夜提

若比丘尼。年年畜弟子波夜提

若比丘尼。一众清净停宿受具足波夜提

若比丘尼。度弟子有事。不自送不使人送。下至五六由旬波夜提

若比丘尼。诸比丘尼作是语。阿梨耶。十法不具足度弟子应教诫。而反嫌责者波夜提

若比丘尼语式叉摩尼言。学戒满。当与汝受具足。后不与受不使人受。又不遣去者波夜提(百一十事竟)

若比丘尼。不病载乘者波夜提

若比丘尼。不病持伞盖着革屣者波夜提

若比丘尼。过量佉啁床褥上。若坐若卧波夜提

若比丘尼。同敷床褥卧波夜提

若比丘尼。僧房床褥不舍而去波夜提

若比丘尼。先不白。入比丘僧伽蓝者波夜提

若比丘尼。知食家淫处宿除余时波夜提。余时者。风时雨时夺命时伤梵行时。是名余时若比丘尼。无商人伴向异国行波夜提

若比丘尼。自境界内观园林故墟波夜提

若比丘尼。共一比丘空静处坐波夜提(百二十事竟)

若比丘尼。与丈夫屏处坐者波夜提

若比丘尼。与男子伸手内住。若耳语波夜提

若比丘尼。知闇中男子坐。无灯而入波夜提

若比丘尼。观伎乐行波夜提

若比丘尼。斗诤不和合住。众主不料理断灭者波夜提

若比丘尼。俗人妇女涂香油揩摩洗浴。除病时波夜提

若比丘尼。不病使比丘尼揩摩洗浴者波夜提

若比丘尼。不病令沙弥尼揩摩者波夜提

若比丘尼。不病令式叉摩尼揩摩者波夜提

若比丘尼。不病令俗人妇女揩摩者波夜提(一百三十事竟)

若比丘尼。半月清净布萨。不恭敬者波夜提

若比丘尼。半月僧教诫。而不恭敬不来波夜提

若比丘尼。膝已上肩已下隐处有痈疮。先不白。听男子破洗者波夜提

若比丘尼。安居中游行者波夜提

若比丘尼。安居竟不游行者波夜提

若比丘尼。语比丘尼作是语。阿梨耶。此处安居。后嫌呵恼触波夜提

若比丘尼。知比丘尼先安居已。后来若自娆乱。使人娆乱波夜提

若比丘尼。隔墙不观。掷弃不净波夜提

若比丘尼。生草上大小便波夜提

若比丘尼。水中大小便波夜提

若比丘尼。知众利回与一众波夜提(一百四十一事竟)

诸阿梨耶。已说百四十一波夜提法。今问诸阿梨耶。是中清净不。第二第三亦如是问。诸阿梨耶。是中清净默然故。是事如是持

诸阿梨耶。是八波罗提提舍尼法半月半月波罗提木叉中说

若比丘尼。不病为身白衣家乞酥。若使人乞若啖若食。是比丘尼应向余比丘尼悔过。如是言。阿梨耶。我堕可呵法。此法悔过。是波罗提提舍尼法。如是二油三蜜四石蜜五乳六酪七鱼八肉

诸阿梨耶。已说八波罗提提舍尼法。今问诸阿梨耶。是中清净不。第二第三亦如是问。诸阿梨耶是中清净默然故。是事如是持

诸阿梨耶。是众学法。半月半月波罗提木叉中说

  不下着内衣　　不高着内衣
  不参差着内衣　　不百襵着内衣
  不石留华着内衣　　不麦饭团着内衣
  不鱼尾着内衣　　不多罗树叶着内衣

不象鼻着内衣(此上九戒丹本及本律大僧戒中并无)

齐整着内衣应当学(十事竟)

不下披衣应当学

不高披衣应当学

不婆罗天披衣应当学

不婆薮天披衣应当学(此上四戒丹本及本律大僧戒中并无)

齐整披衣应当学

好覆身入家内应当学

谛视入家内应当学

小声入家内应当学

不得笑入家内应当学

不得覆头入家内应当学

不得反抄衣入家内应当学

不得脚指行入家内应当学

不得叉腰入家内应当学

不得摇身入家内应当学

不得摇头入家内应当学

不得掉臂入家内应当学

好覆身家内坐应当学

谛视家内坐应当学

小声家内坐应当学

不得笑坐家内应当学

不得覆头坐家内应当学

不得反抄衣坐家内应当学

不得抱膝坐家内应当学

不得交脚坐家内应当学

不得叉腰坐家内应当学

不得动手足坐家内应当学

一心受食应当学

羹饭等受应当学

不得口中回食食应当学

不得偏刳食应当学

不得吐舌食应发学

不得大团饭食应当学

不得张口待饭食应当学

不得挑团饭食应当学

不得啮半食应当学

不得含食语应当学

不得指抆钵食应当学

不得舐手食应当学

不得嗽指食应当学

不得[口*專][口*集]作声食应当学

不得吸食食应当学

不得全吞食应当学

不得落饭食应当学

不得振手食应当学

不得嫌心看比坐钵食应当学

端心视钵食应当学

不病不得为己索食应当学

不得以饭覆羹更望得应当学

不得以腻手受饮器应当学

不得以钵中残食弃地应当学

人坐比丘尼立不得为说法除病应当学

人卧比丘尼坐不得为说法除病应当学

人在高床比丘尼卑床不得为说法除病应当学

不得为着革屣人说法除病应当学

不得为着屐人说法除病应当学

不得为覆头人说法除病应当学

不得为缠头人说法除病应当学

不得为抱膝蹲人说法除病应当学

不得为翘脚人说法除病应当学

不得为持刀人说法除病应当学

不得为持弓箭人说法除病应当学

不得为持杖人说法除病应当学

不得为持盖人说法除病应当学

在后不为在前人说法除病应当学

不得为骑乘人说法除病应当学

在道外不为道中人说法除病应当学

不得立大小便除病应当学(七十七事竟)

诸阿梨耶。已说众学法。今问诸阿梨耶。是中清净不。第二第三亦如是问。诸阿梨耶。是中清净默然故。是事如是持

诸阿梨耶。是七灭诤法。半月半月波罗提木叉中说

若随事随顺人。应与现前毗尼人与。现前毗尼

应与忆念毗尼人。与忆念毗尼

应与不痴毗尼人。与不痴毗尼

应与自言治人。与自言治

应与觅罪相人。与觅罪相

应与多处觅人与多处觅

应与如草布地比尼人。与如草布地比尼

诸阿梨耶。已说七灭诤法。今问诸阿梨耶。是中清净不。第二第三亦如是问。诸阿梨耶。是中清净默然故。是事如是持

诸阿梨耶。已说波罗提木叉序

已说八波罗夷法

已说十九僧伽婆尸沙法

已说三十尼萨耆波夜提法

已说百四十一波夜提法

已说八波罗提提舍尼法

已说众学法

已说七灭诤法

是事入佛经中。半月半月波罗提木叉中说。及余随道法。诸阿梨耶。一心欢喜不诤。一学一道如水乳合。安乐行应当学

佛告比丘尼毗婆尸佛如来应供正遍知为寂静僧。最初说波罗提木叉

  忍辱第一道　　涅槃佛称最
  出家恼他人　　不名为沙门

尸弃佛如来应供正遍知为寂静僧。最初说波罗提木叉

  譬如明眼人　　能避崄恶道
  世有聪明人　　能远离诸恶

毗叶婆佛如来应供正遍知。为寂静僧最初说波罗提木叉

  不恼不说过　　如戒所说行
  饭食知节量　　常乐在闲处
  心净乐精进　　是名诸佛教

拘留孙佛如来应供正遍知。为寂静僧最初说波罗提木叉

  譬如蜂采华　　不坏色与香
  但取其味法　　比丘入聚落
  不破坏他事　　不观作不作
  但自观身行　　谛视善不善

拘那含牟尼佛如来应供正遍知为寂静僧最初说波罗提木叉

  欲得好心莫放逸　　圣人善法当勤学
  若有智寂一心人　　乃能无复忧愁患

迦叶佛如来应供正遍知。为寂静僧最初说波罗提木叉

  一切恶莫作　　当具足善法
  自净其志意　　是则诸佛教

释迦牟尼佛如来应供正遍知。为寂静僧最初说波罗提木叉

  护身为善哉　　能护口亦善
  护意为善哉　　护一切亦善
  比丘护一切　　便得离众苦
  比丘守口意　　身不犯众恶
  是三业道净　　得圣所得道
  若人挝骂不还报　　于嫌恨人心不恨
  于嗔人中心常净　　见人为恶自不作
  七佛为世尊　　能救护世间
  是佛说戒经　　我已广说竟
  诸佛及弟子　　恭敬是戒经
  恭敬戒经已　　各各相恭敬
  惭愧得具足　　能得无为道

已说波罗提木叉竟僧一心得布萨

摩诃僧祇比丘尼戒本

若比丘尼。从非亲里居士若居士妇乞依除余时。余时者。失衣时尼萨耆波夜提

若比丘尼。失衣得从非亲里居士居士妇乞衣。若自恣与得取上下衣。若过受尼萨耆波夜提

若比丘尼居士居士妇。为比丘尼办衣价。言我办如是衣价。买如是衣。与某比丘尼。是比丘尼先不请。为好故便往劝言。善哉优婆夷。如是衣价买如是色衣与我。若得衣尼萨耆波夜提

若比丘尼居士居士妇。名办衣价言。我等办如是衣价。买如是衣。与某甲比丘尼。是比丘尼先不请。为好故便往劝言。善哉优婆塞优婆夷各辨如是衣价。共作一如是色衣与我若得衣尼萨耆波夜提

为比丘尼故。若王大臣。遣使送衣直与比丘尼。使到言。是衣直若王大臣送。阿梨耶。应受比丘尼言我不得受是衣直。送净衣来者应受。使言。阿梨耶。有执事人不比丘尼若须衣应示使若园民若优婆夷。言是人能为比丘尼执事使到言。善哉执事。如是衣价。买如是净衣。与某甲比丘尼。是比丘尼来取时与彼使敕已。还到比丘尼所。言阿梨耶。所示执事人。我已劝作已须衣。时往取比丘尼若须衣应到执事人所言。我须衣我须衣。第二第三亦如是。若得衣者好。若不得第四第五。第六在执事前默然立。得衣者善。不得过是求。若得衣尼萨耆波夜提。若不得随。衣直来处若自去若遣使。言汝为某比丘尼送衣直是比丘尼于汝衣直竟不得用。汝自知莫令失。是事法尔

若比丘尼。不病为身白衣家乞酥。若使人乞。若啖若食。是比丘尼应向余比丘尼悔过。如是言。阿梨耶。我堕可呵法。此法悔过。是波罗提提舍尼法

若比丘尼。不病为身白衣家乞油。若使人乞。若啖若食。是比丘尼应向余比丘尼悔过。如是言。阿梨耶。我堕可呵法。此法悔过。是波罗提提舍尼法

若比丘尼。不病为身白衣家乞蜜。若使人乞。若啖若食。是比丘尼应向余比丘尼悔过。如是言。阿梨耶。我堕可呵法。此法悔过。是波罗提提舍尼法

若比丘尼。不病为身白衣家乞石蜜。若使人乞。若啖若食。是比丘尼应向余比丘尼悔过。如是言。阿梨耶。我堕可呵法。此法悔过。是波罗提提舍尼法

若比丘尼。不病为身白衣家乞乳。若使人乞。若啖若食。是比丘尼应向余比丘尼悔过。如是言。阿梨耶。我堕可呵法。此法悔过。是波罗提提舍尼法

若比丘尼。不病为身白衣家乞酪。若使人乞。若啖若食。是比丘尼应向余比丘尼悔过。如是言。阿梨耶。我堕可呵法。此法尼悔过。是波罗提提舍尼法

若比丘尼。不病为身白衣家乞鱼。若使人乞。若啖若食。是比丘尼应向余比丘尼悔过。如是言。阿梨耶。我堕可呵法。此法悔过。是波罗提提舍尼法

若比丘尼。不病为身白衣家乞肉。若使人乞。若啖若食。是比丘尼应向余比丘尼悔过。如是言。阿梨耶。我堕可呵法。此法悔过。是波罗提提舍尼法

诸阿梨耶。已说八波罗提提舍尼法。今问诸阿梨耶。是中清净不(如是三说)

诸阿梨耶。是中清净默然故。是事如是持

诸阿梨耶。是众学法。半月半月次说波罗提木叉

齐整着内衣应当学

齐整被衣应当学

好覆身入家内应当学

谛视入家内应当学

小声入家内应当学

不笑入家内应当学

不覆头入家内应当学

不反抄衣入家内应当学

不脚指行入家内应当学

不叉腰入家内应当学

不摇身入家内应当学

不摇头入家内应当学

不掉臂入家内应当学

好覆身家内坐应当学

谛视家内坐应当学

小声家内坐应当学

不笑家内坐应当学

不覆头家内坐应当学

不反抄衣家内坐应当学

不抱膝家内坐应当学

不交脚家内坐应当学

不叉腰家内坐应当学

不动手足家内坐应当学

一心受食应当学

羹饭等食应当学

不偏刳食应当学

不口颊食食应当学

不吐舌食应当学

不大抟饭食应当学

不张口待饭食应当学

不挑抟饭食应当学

不啮半食应当学

不含食语应当学

不指抆钵食应当学

不舐手食应当学

不[口*數]指食应当学

不[口*專][口*集]作声食应当学

不吸食食应当学

不全吞食应当学

不落饭食应当学

不振手食应当学

不嫌心视比坐钵食应当学

端心视钵食应当学

无病不得为身索食应当学

不以饭覆羹更望得应当学

不以腻手受饮器应当学

不以钵中残食弃地应当学

己立不为坐人说法除病应当学

己坐不为卧人说法除病应当学

在下不为高床上人说法除病应当学

不为着革屣人说法除病应当学

不为着屐人说法除病应当学

不为覆头人说法除病应当学

不为缠头人说法除病应当学

不为抱膝蹲人说法除病应当学

不为翘脚人说法除病应当学

不为持刀人说法除病应当学

不为捉弓箭人说法除病应当学

不为捉杖人说法除病应当学

不为捉盖人说法除病应当学

在后不为在前人说法除病应当学

不为骑乘人说法除病应当学

在道外不为道中人说法除病应当学

不立大小便除病应当学

树过人不应上除大因缘应当学

诸阿梨耶。已说众学法。今问诸阿梨耶。是中清净不(如是三说)诸阿梨耶。是中清净默然故。是事如是持

诸阿梨耶。是七灭诤法。半月半月次说波罗提木叉。若随事随顺人

应与现前毗尼人。与现前毗尼

应与忆念毗尼人。与忆念毗尼

应与不痴毗尼人。与不痴毗尼

应与自言治人。与自言治毗尼

应与觅罪相人与觅罪相毗尼

应与多觅毗尼人。与多觅毗尼

应与如草布地毗尼人。与如草布地毗尼

诸阿梨耶。已说七灭诤法。今问诸阿梨耶。是中清净不(如是三说)诸阿梨耶。是中清净默然故。是事如是持

诸阿梨耶。已说戒序。已说八波罗夷法。已说十九僧伽婆尸沙法。已说三十尼萨耆波夜提法。已说百四十一波夜提法。已说八波罗提提舍尼法。已说众学法。已说七灭诤法。已说随顺法。是名如来应供正遍知法比丘尼法。入波罗提木叉经中。是法随顺法一切学莫犯


摩诃僧祇律

    No. 1425 [cf. Nos. 1426, 1427]

摩诃僧祇律卷第一(初比丘僧戒法学)

        东晋天竺三藏佛陀跋陀罗共法显译

    明四波罗夷法之一(淫戒之一)

若笃信善男子。欲得五事利益者。当尽受持此律。何等五。若善男子。欲建立佛法者。当尽受持此律。欲令正法久住者。当尽受持此律。不欲有疑悔请问他人者。当尽受持此律。诸有比丘比丘尼犯罪恐怖。为作依怙者。当尽受持此律。欲游化诸方而无碍者。当尽受持此律。是名笃信善男子受持此律得五事利益

  若能尽受持　　调御威仪戒
  五事功德利　　世尊之所说
  受持此律者　　如其义善听
  若能尽受持　　调御戒律仪
  建立世尊教　　是名真佛子
  佛法得久住　　能行正法施
  亦无疑悔起　　请问于他人
  比丘比丘尼　　犯罪得依怙
  游化于诸方　　所往无挂碍

婆伽婆三藐三佛陀。从本发意所修习者今已成就。欲度人故住舍卫城。诸天世人恭敬供养尊重赞叹。名闻十方供养中最。为求福众生得建立于福。求果众生得建立于果。苦恼众生而得安隐。为诸天人开甘露门。于十六大国莫不宗伏。知见自觉佛所住者。住于天住。住于梵住。住贤圣住。住最胜住。住一切智心。得自在随意所住。是故如来住舍卫国。尔时尊者舍利弗。独一静处结加趺坐正受三昧。三昧觉已作是思惟。有何因缘。诸佛世尊灭度之后法不久住。有何因缘。诸佛世尊灭度之后法教久住。于是尊者舍利弗。晡时从三昧起诣世尊所。头面礼足却坐一面。坐一面已白佛言。世尊。我于静处正受三昧。三昧觉已作是思惟。有何因缘。诸佛世尊灭度之后法不久住。有何因缘。诸佛世尊灭度之后法教久住。尔时佛告舍利弗。有如来不为弟子广说修多罗祇夜授记伽陀忧陀那如是语本生方广未曾有经。舍利弗。诸佛如来不为声闻制戒。不立说波罗提木叉法。是故如来灭度之后法不久住。舍利弗。譬如鬘师鬘师弟子以种种色花着于案上不以线连。若四方风吹则随风散。何以故无线连故。如是舍利弗。如来不广为弟子说九部法。不为声闻制戒。不立说波罗提木叉法。是故如来灭后法不久住。舍利弗。以如来广为弟子说九部法。为声闻制戒。立说波罗提木叉法。是故如来灭度之后教法久住。舍利弗。譬如鬘师鬘师弟子以种种色花以线连之。若四方风吹不随风散。所以者何。以线连故。如是舍利弗。如来广说九部经。为声闻制戒。立说波罗提木叉法。是以如来灭后法得久住。舍利弗。以是因缘故。教法有久住有不久住者。尔时尊者舍利弗。白佛言。唯愿世尊。广说九部经。善为声闻制戒。立说波罗提木叉法。令教法久住。为诸天世人开甘露门。尔时佛告舍利弗。如来不以无过患因缘而为弟子制戒立说波罗提木叉法。舍利弗。譬如转轮圣王不以无过而为婆罗门居士而制刑罚。如是舍利弗。如来亦复如是。不以无过患因缘而为弟子制戒立说波罗提木叉法。然舍利弗。当来有正信善男子。于佛法中信家非家舍家出家。或有心乱颠倒起于净想。三毒炽盛而犯诸罪。舍利弗。是时如来当为弟子制戒立说波罗提木叉法。止舍利弗。如来自当知时。舍利弗言。唯然世尊。如来自当知时

  是时舍利弗　　偏袒而合掌
  随顺转法轮　　请求最胜说
  劝请于世尊　　今正是其时
  愿为弟子众　　广制戒律仪
  能令佛正法　　长夜得久住
  显示甘露门　　开化天人众
  彼住最后身　　作此劝请已
  尔时最胜告　　尊者舍利弗
  弟子未有罪　　众僧悉清净
  诸佛未曾有　　无过而制戒
  譬如世界主　　王领其国土
  无有无过人　　而加其刑罚
  彼喻此亦然　　世尊天人师
  未有无过患　　而制弟子戒
  过患既已起　　时有犯恶者
  是时天人师　　为众制律仪
  过去未来世　　佛眼靡不见
  随其事轻重　　随其轻重制
  说此正法时　　在于祇洹林
  舍利弗劝请　　世尊答如是

尔时诸比丘白佛言。世尊云何尊者舍利弗。诸比丘未有过患。而请世尊制戒立说波罗提木叉法。佛告诸比丘。舍利弗不但今日未有过患而请制戒。彼于昔时在一城邑聚落。人民居士未有过患。亦曾请我制诸刑罚。诸比丘白佛言。世尊。乃往昔时已有此耶。佛言如是。诸比丘白佛言。世尊。愿乐欲闻。佛告诸比丘。过去世时有城名波罗奈。国名迦尸。彼时国王号曰大名称。以法治化无有怨敌。布施持戒泛爱人物。善摄眷属法王御世。人民殷盛。富乐丰实。聚落村邑鸡飞相接。举国人民更相敬爱。种种众伎共相娱乐。时有大臣名曰陶利。多诸策谋作是思惟。今此王境自然富乐人民炽盛。城邑聚落鸡飞相接。举国人民更相敬爱。种种众伎共相娱乐。时彼大臣往白王言。今日境界自然富乐人民炽盛。城邑聚落鸡飞相接。举国人民更相敬爱。种种伎乐共相娱乐。愿王当为斯等制立刑罚。莫令极乐生诸过患。王言止止。此言不可。所以者何。过患未起而欲制罚。臣复白王。当防未来。莫令极乐生诸过患。时王作是思惟。今此大臣聪明智谋。多诸朋党不可卒制。今若呵责或生咎衅。尔时国王欲微诲大臣。即说偈言

  势力喜嗔恚　　难可卒呵制
  横生人过患　　此事甚不可
  大人多慈愍　　知人实有过
  犹尚复观察　　哀愍加其罚
  恶人喜恼他　　不审其过罪
  而加其刑罚　　自损恶名增
  如王好威怒　　枉害加良善
  恶名流四远　　死则堕恶道
  正法化黎庶　　身口意清净
  忍辱行四等　　是谓人中王
  王为人中上　　宜制忿怒心
  仁爱恕有罪　　哀愍加刑罚

尔时大臣闻王所说。心大欢喜而说偈言

  最胜人中王　　愿永荫黎庶
  忍辱自调伏　　道化怨自降
  王德被无外　　祚隆永无穷
  以道治天下　　常为天人王

佛告诸比丘。尔时国王大名称者。岂异人乎则我身是。时大臣陶利者。舍利弗是。尔时城邑聚落长者居士未有过患。而彼请我令制刑罚。今诸比丘过患未起。而复请我为诸弟子。制戒立说波罗提木叉法。尔时世尊。从舍卫城随所乐住已。于憍萨罗国人间游行。与大比丘众五百人前后围绕。诣憍萨罗国耕田婆罗门聚落。到已于耕田林中住。于是世尊晡时从三昧起。周遍观察上下诸方。又复视前平地而发微笑往来经行。时舍利弗。见世尊从三昧起周遍观察上下诸方。又复视前平地而发微笑往来经行。见已往诣众多比丘所。语比丘言。诸长老我向见世尊从三昧起。观察诸方乃至往来经行。诸长老如来应供正遍知。不以无因缘而起微笑。若往请问。必当闻说过去宿命久远之事。我等今日当诣。世尊问如此义。如佛所说我当奉行。诸比丘闻舍利弗说已。即与舍利弗。共诣世尊所头面礼足。礼足已随佛经行。时尊者舍利弗白佛言。向见世尊从三昧起观察诸方乃至往来经行。我即往诣众多比丘所。语比丘言。诸长老我向见世尊从三昧起观察诸方乃至往来经行。诸长老如来应供正遍知。不以无因缘而笑。若往请问。必当闻说过去宿命久远之事。我等今日当诣世尊问如此义。如佛所说我当奉行。不审世尊。有何因缘而发微笑。尔时世尊。出金色臂指地告舍利弗。汝见此地不。舍利弗言。唯然已见。佛言。此地是迦叶佛故园林处。此一处是迦叶佛精舍处。此一处是经行处。此一处是坐禅处。尔时尊者舍利弗。即取僧伽梨襞为四褺即布是地。布是地已。偏袒右肩右膝着地合掌白佛言。唯愿世尊。坐此座上。当令此地为二佛坐处。尔时世尊即受而坐。尊者舍利弗礼佛足已。于一面坐而白佛言。世尊有几事利益。如来应供正遍知。为弟子制戒立说波罗提木叉法。佛告舍利弗。有十事利益故。诸佛如来为诸弟子制戒立说波罗提木叉法。何等十。一者摄僧故。二者极摄僧故。三者令僧安乐故。四者折伏无羞人故。五者有惭愧人得安隐住故。六者不信者令得信故。七者已信者增益信故。八者于现法中得漏尽故。九者未生诸漏令不生故。十者正法得久住。为诸天人开甘露施门故。以是十事。如来应供正遍知。为诸弟子制戒立说波罗提木叉法

  是时舍利弗　　偏袒而合掌
  随顺转法轮　　请问于最胜
  彼住最后身　　合掌请问已
  尔时最胜告　　尊者舍利弗
  有十功德利　　如来所知见
  故为诸弟子　　广制戒律仪
  摄僧极摄故　　令僧安乐住
  折伏无羞人　　惭愧得安隐
  不信令入信　　已信者增益
  现法得漏尽　　未生漏不生
  正法得久住　　开甘露施门
  说是正法时　　在于耕田林
  舍利弗请问　　世尊答如是

尔时世尊。于耕田聚落随所乐住已。从憍萨罗国游行向跋耆国。尔时世尊与五百比丘俱。到跋耆国毗舍离城。住大林重阁精舍。尔时毗舍离城。人民饥馑五谷不熟。白骨纵横乞食难得。毗舍离城有长者子。名曰耶舍。信家非家舍家出家。其父名迦兰陀。故诸梵行者皆称为迦兰陀子。时世饥馑乞食难得。每至食时多还家食。其母告耶舍言。子汝甚为大苦。剃除须发着弊纳衣。持钵乞食为世人所笑。今此家中大有财物。汝父母钱及余先祖财宝。恣汝所欲。且汝爱妇今犹故在。当共生活。何以如是受诸勤苦。汝当归家受五欲乐。自恣布施种诸功德供养三宝。尔时耶舍白母言。愿母止止我乐修梵行。其母复第二第三所劝如初。耶舍答亦如先。母复重言。汝若不乐在家者。当乞我种以续继嗣。莫令门户断绝财物没官。尔时耶舍即白母言。今欲使我于此中留种子者。当奉此敕。母即欢喜疾入妇房语新妇言。汝速庄严。着耶舍本所爱乐严身之服。与之相见。新妇答言尔。即便庄严如教所敕。尔时耶舍即与其妇共相娱乐。如其俗法。于是其妇遂便有娠。月满生子。其家议言。本为乞种故。今当立字名为续种。尔时世人皆名为续种。父续种母续种祖续种。钱财一切皆名续种。所有如是恶名流布道俗悉闻。尔时耶舍闻恶名已。为续种子父大自惭愧。耻其所闻作是思惟。沙门释种中。未曾见闻有如此事。此为法耶为非法耶。我今当以此事广白尊者舍利弗。舍利弗当以此事具白世尊。如世尊教我当奉行。时耶舍疾往诣尊者舍利弗所。广说上事。尊者舍利弗。与耶舍共诣世尊所。头面礼足却坐一面。坐已尊者舍利弗具以上事广白世尊。佛问耶舍。汝实有是事不。答言实尔。佛言。耶舍是为大过。比丘僧中未曾有此。汝愚痴人最初开大罪门。未有漏患而起漏患。天魔波旬常求诸比丘短而不能得。汝今最初开魔径路。汝今便为毁正法幢建波旬幢。汝愚痴人。宁以利刀割截身生。若着毒蛇口中若狂狗口中。若大火中若灰炭中。不应与女人共行淫欲。耶舍汝常不闻我无数方便呵责淫欲。欲为迷醉。欲如大火烧人善根。欲为大患。我常种种方便称叹离欲断欲度欲。汝今云何作是不善。耶舍此非法非律非如佛教。不可以是长养善法。时诸比丘白佛言。世尊云何是耶舍比丘僧中未曾有此。而彼耶舍初开罪门。未有漏患而起漏患。佛告诸比丘。是人不但今日于我法中未有漏患而起漏患。诸比丘白佛言。彼过去时已曾有是事耶。佛言如是。诸比丘白佛言。世尊愿乐欲闻。佛告诸比丘。过去世时此世界劫尽时。诸众生生光音天上。而此大地还已成立。诸众生等从光音天还来至此。时彼众生身有妙光。神足自在禅悦为食。诸有所须随意所欲。是诸众生身光相照。无有日月星宿亦无昼夜。亦无一月半月四时岁数。时此大地便有自然地味。色香美味皆悉具足。如天甘露等无有异。时有一轻躁贪欲众生。尝此地味觉其香美。渐取食之即生着心。其余众生见其如此。展转相效皆竞取食。尔时众生食地味已。身体沉重光明即灭。贪着五欲退失神足。然后世间便有日月星宿昏明半月一月春秋冬夏。佛告诸比丘。尔时轻躁众生者。岂异人乎。即耶舍比丘是。彼时耶舍于诸众生。漏患未起而先起漏。今日复于清净僧中先开漏门。诸比丘白佛言世尊。彼耶舍比丘先世已来乃如是耶。云何其母巧作方便以淫欲诱诳其子。佛告诸比丘。是耶舍母不但今日巧作方便诱诳其子。过去世时亦曾诱诳。诸比丘白佛言。世尊已曾尔耶。佛言如是。诸比丘白佛言。世尊愿乐欲闻。佛告诸比丘。过去世时有城名波罗奈。国名迦尸。时彼国王号大名称。离诸怨敌。布施泛戒持爱人物。以法治化善摄眷属。时王第一夫人。晨朝上高楼上观察星宿。见一金色鹿王从南方来陵虚北逝。夫人见已即作是念。我若得此金色鹿皮。持作褥者没无遗恨。若不得者。用作此王夫人为。即自念曰。若我语人见金色鹿王谁当信者。又作是念。若言是鹿不应乘虚。若乘虚行不应言鹿。夫人愁忧恐不。信故。即脱璎珞着垢弊衣入忧恼房。王于殿上治政事讫。还入其室不见第一夫人。即问侍者。侍者答言。夫人向入忧恼房住。王便往就问夫人言。谁犯汝者。为大臣王子。为余夫人及余侍者。若犯汝者。我当为汝重治其罪。汝今将无有所须耶。若欲须金银珍宝香花璎珞当相供给。若欲杀罚便可见语。王种种问已夫人不答。王即出去。告余夫人大臣太子及余人等。卿等率往问夫人意。诸人受教各各问已。夫人犹故默然不对。王使耆旧青衣更问夫人。此青衣者生长王宫多有方便。即往入房问夫人言。王是夫人之所恃怙。如何王问而默然不答。若有所求何缘可得。谁犯夫人。为大臣王子及余夫人。欲有杀罚宜应白王。夫人默恨无乃失耶。夫人若丧。王终不能相与俱死。正可忧恼。月日之间。国中自有刹利婆罗门长者居士等。皆各有女端正妙好。与相娱乐足以忘忧。夫人正可徒自死耳。喻若哑人眠中得梦谁能瞻者。夫人不语难知亦尔。尔时夫人闻青衣语。即自惟曰此是名语。便答青衣无犯我者。别有所忆故不语耳。汝听我说。吾近晨朝登楼观看星宿。时见有一金色鹿王。乘空南来凌虚北逝。若语人言鹿能乘虚。谁能信者。我欲得其皮持用作褥而不能得。是以生恼自念。用作王夫人为。是时青衣闻此语已具白大王。王知其意甚大欢喜。即问傍臣。谁能得此金色鹿皮。我今须之持用作褥。诸臣答言。当问猎者。王告大臣敕我境内。国中猎师尽使令集。如偈所说

  诸天随念感　　王者随声至
  富者以财得　　贫人以力办

如是王教出已。国中猎师一切皆集。猎师白王。何所约敕。王告猎者。我今急须金色鹿皮持用作褥。卿等为吾疾速求之。猎师答王。愿听小还共论此事。王曰可尔。猎师还已共相谓言。汝等游猎颇曾见闻金色鹿不。彼各对曰。我等先祖已来常行游猎。未曾有闻金色鹿名。况复眼见。时诸猎师共作要言。今往答王无使不同。既见王已各白王言。我先祖已来相承游猎。初未曾闻金色鹿名。况复眼见如所说

  王者力自在　　所求欲如教

王即敕有司令执诸猎者系着牢狱。时有一猎师名曰删阇。勇健多力走及奔兽。仰射飞鸟箭无空落。彼即念言。我诸猎党自惟无罪而见囚执。当设权计脱此苦难。我当白王应募求鹿。若得者善若不得者。我且游散诸伴得出。便白王言。颇有见闻金色鹿不。王告猎者。汝等自可往问夫人。尔时猎者即诣王宫白夫人曰。谁有见闻金色鹿者。夫人答言我亲自见。猎师白言见在何处。夫人答言。我于楼上观于星宿。晨朝见一金色鹿王。从南方来陵虚北逝。时彼猎师善相禽兽。知此鹿王止宿在南食处在北。止宿之处永无可得。当于食处而求取之。于是猎师便持弓箭。渐次北行到彼雪山。时彼山中有仙人住。流泉浴池花果茂盛。彼中仙人以二事除欲。一者苦行。二者闲居。尔时猎师藏诸猎具假以人服。诣仙人所礼拜问讯。彼仙人者处在山泽久不见人。得猎者至甚大欢喜。命令就坐。与甘果美浆共相慰劳。猎师白言。止此久近。答言止此以来经尔所时。复白仙人止此已来。颇曾见有奇异事不。答言曾见。复问为见何等。答曰。此山南有一树名尼拘律。常有金色鹿王飞来在上。食彼树叶饱已而去。猎师闻此甚大欢喜。作是念言。必是夫人所见金色鹿王。今已得闻我愿将果。猎师方便更说余事。然后乃问。趣尼俱律树道在何处。仙人答言。从此而去中间曲路委悉语之。猎师闻喜咒愿而去。还执持猎具顺道而进。渐次前行遥见。彼树枝叶扶疏荫覆弥广。至彼树下寻觅鹿王。不见踪迹又无食处。猎师便于树下潜微伺之。伺之不久便见鹿王。譬如雁王陵虚而来止此树上。形色光明照耀山谷。食彼树叶饱则还南。寻复思惟。此树高远非是网罥弓矢所及。云何可得。我今当还波罗奈城。彼有大臣王子聪明智德。我当问之。即还其国便白王言。如夫人所见但鹿所止住。非网罥弓矢所及。无由得之。王告猎师。汝可自往具白夫人。猎师即白夫人已。见金色鹿王。都非网罥弓矢所及。不知何由而得。夫人问言。彼鹿所住为在何处。答言住在尼拘律树上。食彼树叶饱已还南。如所说

  刹利百方便　　婆罗门增倍
  王有千种计　　女人策无量

如是王夫人多诸方便。便教猎者。汝持蜜去至彼树上蜜涂树叶。鹿闻蜜香必食树叶。啖尽次第涂下至彼施网罥处。猎师如教还于山中。持蜜上树涂其树叶。彼鹿来食随蜜食尽。蜜不涂处鹿辄不食。随蜜食叶渐次而下。如所说

  野兽信其鼻　　梵志依相书
  王者委有司　　各各有所信

彼鹿寻香食彼树叶。渐下到其施网罥处即便着罥。猎师念言。我若杀取其皮不足为贵。当活将去于是驱还。猎师笼羁过仙人处。仙人遥见惊而叹曰。咄哉祸酷。虽能乘虚而不能免此恶人之手。即问猎者恶人汝用是为。猎师答言。迦尸国王第一夫人须此鹿皮持用作褥。仙人复言。汝谓此鹿死后色如是耶。内有生气故外色如是。可活将去汝可得赏。仙人复问。汝作何方便而得此鹿。答言我作如是方便而得此鹿。尔时仙人自庆善寂无此诸恶。悲念夫人能为巧恶方便。痛彼鹿王贪味受困。尔时仙人即说偈言

  世间之大恶　　莫过于嗜味
  欺诳凡夫人　　及诸林野兽
  因风着香味　　受斯苦恼患

猎师问曰。我作何方便养育此鹿得生归我国。仙人答言。以蜜涂树叶而用养之。若到人间以蜜和糗。如是教令养之。渐渐还国遂到人间。此鹿形貌端正色若天金。角白如珂。目紫绀色。一切人见莫不雅奇。渐次行诣波罗奈城。王闻鹿至。敕诸城内平治道路。扫洒烧香捶钟击鼓往迎鹿王。观者如云莫不欢喜。庆贺大王吉祥远至。夫人见已欢喜踊跃不能自胜。以爱心重故前抱鹿王。以昔染污心重故。令彼鹿王金色即灭。王告夫人此鹿金色忽变当如之何。夫人答王此今便是无施之物。放使令去。尔时佛告诸比丘。彼时金色鹿王岂异人乎。今耶舍比丘是。时夫人者今耶舍母是。往昔已来曾作方便诱诳其子。令堕贪着受诸苦恼。佛告诸比丘。依止毗舍离比丘皆悉令集。尔时世尊以是因缘向诸比丘。广说过患事。起种种因缘呵责过患起已。为诸比丘随顺说法。有十事利益。如来应供正遍知。为诸弟子制戒立说波罗提木叉法。十事利益广说如上。是故如来从今日当为诸比丘制戒。未闻者令闻。已闻者当重闻。若比丘于和合僧中受具足戒行淫法。是比丘得波罗夷。不共住

复次佛住毗舍离。广说如上。时毗舍离城有二离车子。信家非家舍家出家。于毗耶离众所知识。能致供养四事具足。彼比丘时至着入聚落衣持钵入城乞食。不能摄身口意系念在前。心意驰乱不摄诸根。染着色欲取色净相。欲心炽盛便作是念。我着法服为此欲事甚为不可。我当舍于法服着彼俗衣。七日之内不还僧中随意所为。作是念已。即脱袈裟着彼俗衣便行欲事。过七日已还着法服而来入僧。入僧已还自厌污愧身所行。便作是念。都不见闻余诸沙门有如是事。我今当以此事白尊者舍利弗。舍利弗当向世尊具陈此事。若佛有所教敕我当奉行。时二比丘往诣尊者舍利弗所广说如上。时尊者舍利弗将二比丘往诣世尊礼足已。却住一面。以上因缘广白世尊。佛告舍利弗。应遣令去。是愚痴人。不复得在如来法中更出家受具戒。时舍利弗以哀愍故。偏袒右肩胡跪合掌白佛言。世尊当来有善男子。于世尊法中信家非家舍家出家。迷意颠倒起于净想。无惭无愧三毒炽盛。唯愿世尊为开方便。令是善男子更于如来法中得出家受具足戒。尔时佛告诸比丘依止毗舍离诸比丘皆悉令集。为诸比丘制戒。乃至已闻者当重闻。若比丘于和合僧中受具戒。若不还戒而行淫法。是比丘得波罗夷罪不应共住

复次佛住毗舍离。广说如上。时诸比丘处处安居。安居已还诣毗舍离。到世尊所礼拜问讯。问讯已次第付房而住。房尽不受。有依屋栏草庵空地树下住者。尔时有一比丘依树下坐。作是思惟佛法出家甚为大苦。修习梵行亦为甚难。昼则风飘日炙。夜则蚊虻毒虫所啮。我欲不堪于佛法中修净梵行。彼比丘作是心念口言。诸比丘闻已便谓此比丘言汝舍戒耶。答言不舍我但作是念。我不堪于如来法中修净梵行。诸比丘以是因缘往白世尊。是比丘舍戒尔时世尊告诸比丘。唤彼比丘来。来已佛问比丘。汝实舍戒耶。答言不舍。佛言何缘致此。世尊。我于树下作是心念口言。于佛法中舍家出家甚为大苦。我不堪于如来法中修净梵行。佛告比丘。汝云何于如来法中信家非家舍家出家。而作是念。我不堪忍于如来法中修净梵行。佛言。是比丘不名舍戒。是名戒羸彼作戒羸说语。得偷兰罪。尔时佛告诸比丘。依止毗舍离比丘皆悉令集。乃至未闻者当闻已闻者重闻。若比丘于和合僧中受具足戒。不还戒戒羸不舍戒。便行淫法。是比丘得波罗夷罪。不应共住

复次佛住舍卫城。广说如上。时舍卫城有长老名难提。信家非家舍家出家。于舍卫城众所知识。能致供养四事具足。余多有名难提是。但是长老行时亦禅。住时亦禅。坐时亦禅。卧时亦禅。时人名之为禅难提。时难提于开眼林中作草庵舍。彼于其中初中后夜修行自业。得世俗正受乃经七年。过七年已退失禅定。复依一树下还习正受乃求本定。时魔眷属常作方便。于行正法人伺求其短。变为人形端正无比。种种花香璎珞以严其身。于难提前住。谓难提言。比丘共相娱乐行淫事来。时难提言。恶邪速灭恶邪速灭。口作此言而目不视。天女复第二第三所说如上。时难提第二第三亦如是说。恶邪速灭恶邪速灭。而不观视。时天女便脱璎珞之服露其形体。立难提前语难提言。共行淫来。时难提见其形相而生欲心。答言可尔。时天女渐渐却行。难提唤言。汝可小住共相娱乐。难提往就。天女疾疾而去。难提追逐到祇洹堑。堑中有王家死马。天女到死马所隐形不现。时难提欲心炽盛即淫死马。欲心息已便作是念。我甚不善非沙门法。以信出家而犯波罗夷罪。用着法服食人信施为。即脱法服着右手中。左手掩形而趣祇洹语比丘言。长老我犯波罗夷我犯波罗夷。时诸比丘在祇洹门间。经行仿佯思惟自业。共相谓言。此是坐禅难提修梵行人。不应犯波罗夷。难提复言。诸长老不尔。我实犯波罗夷。诸比丘即问其因缘。难提具说上事。诸比丘以是事具白世尊。佛告诸比丘。是难提善男子自说。所犯重罪。应当驱出。时诸比丘如教驱出诸比丘白佛言。世尊云何长老难提久修梵行。而为此天女之所诳惑。佛告诸比丘。是难提比丘不但今日为天女所惑退失梵行。过去世时亦为彼所惑失于梵行。诸比丘白佛言。已曾尔耶。佛言如是。佛告诸比丘。过去世时有城名波罗奈。国名迦尸。时南方阿槃提国。有迦叶氏外道出家。聪明博识综练群籍。众技妙术靡不开达。彼外道者助王治国。时彼国王执持奸贼种种治罪。或截手足髡其耳鼻治之甚苦。时彼外道深自惟念。我已出家云何与王共参此事。便白王言听我出家。王即答言师已出家。云何方言复欲出家。答言大王。我今豫此种种刑罚苦恼众生。何名出家。王即问言。师今欲于何道出家。答言大王。欲学仙人出家。王言可尔随意出家。去城不遥有百岩山。有流泉浴池花果茂盛。即造彼山起立精舍。彼于山中修习外道。得世俗定起五神通。于春后月食诸果蓏四大不适。因其小行不净流出。时鹿爱群共相驰逐。渴乏求水饮此小便。不净着舌舐其产道。众生行报不可思议因是受胎。常在庐侧食草饮水。至期月满产一小儿。尔时仙人出行采果。鹿产难故即大悲鸣。仙人闻鹿鸣急谓为恶虫所害。欲往救之。遂见生一小儿。仙人见已怪而念曰。云何畜生而生于人。寻入定思惟见本因缘。即是我子。于彼小儿便生爱心。裹以皮衣持归养之。仙人抱举鹿母乳之。渐渐长大名为鹿斑。依母生故体斑似母。是故作字名曰鹿斑。是童子渐渐长大至年七岁。逊弟尊长仁爱孝慈。采取水果供养仙人。是时仙人念言。天下可畏无过女人。即便教诫子言。可畏之甚无过女人。败正毁德靡不由之。于是教以禅定化以五通。如所说

  一切众生类　　靡不归于死
  随其业所趣　　自受其果报
  为善者生天　　恶行入地狱
  行道修梵行　　漏尽得泥洹

尔时仙人便即命终。于是童子净修梵行得外道四禅。起五神通有大神力。能移山住流扪摸日月。尔时释提桓因乘白龙象案行世间。谁有孝顺父母供养沙门婆罗门。有能布施持戒修梵行者。案行世界时见是仙人童子。天帝念言。若是童子欲求帝释梵王。皆悉能得宜应早坏。如所说

  诸天及世人　　一切众生类
  莫不为结缚　　命终堕恶道

皆为悭嫉二结所缚。诸天有三时鼓。诸天阿修罗共战时打第一鼓。俱毗罗园众花开敷时打第二鼓。集善法讲堂听善法时打第三鼓。释提桓因扣说法鼓。无数百千天子皆悉来集。俱白帝释何所诲敕。帝释告言。阎浮提有仙人童子。名曰鹿斑。有大功德欲方便坏之。时无数天子闻此不乐。便自念言坏此人者。将减损诸天众增益阿修罗。中有平心无当成败无在。又复欢喜助欲坏之。有一天子而唱是言。谁应行者。时有答言是天女应行。是诸天人游观诸园。在欢喜园者。在杂色园者。在粗涩园者。天女应行。而便召之。应时百千天女皆悉来集。有一天女名阿蓝浮。其发杂色。发有四色青黄赤白。故名杂色。差此天女往阎浮提坏鹿斑。童子。时彼天女白帝释言。我自昔以来数坏人梵行令失神通。愿更遣余天女端正严好令人乐者。时天帝释复于众中种种说偈劝喻天女。阿蓝浮。汝可使行坏俱舍频头。如生经中说。于是天女即坏仙人童子。佛告诸比丘。尔时仙人童子俱舍频头者岂异人乎。即今禅难提是。天女阿蓝浮者。今此天女是。而难提曾已为其所坏。今作比丘复为其所坏。尔时世尊。语诸比丘。乃至非人中亦犯波罗夷。不应共住

复次佛住王舍城。广说如上。时诸比丘处处夏安居。安居已来诣王舍城礼拜问讯世尊。各随所乐住。或住毗婆罗精舍。或住白山精舍。或住方山精舍。或住仙人窟。或住耆阇崛山窟。或住辩才岩窟。或住拘利园精舍。或住赖咤园精舍或住师子园精舍。或住七叶园精舍。或住温泉精舍。或住散盖窟。或住庵罗窟。或住卑尸窟。或住猿猴精舍。时有客比丘到此猿猴精舍。诣先住知识比丘所共相慰劳。相慰劳已彼旧住比丘供给澡水。洗于手足与中后浆示房舍处。时客比丘各得止息。尔时山头有一雌猿猴。从上来下到旧比丘前背住。现受淫相。时旧比丘呵叱令去。如是复至余比丘前背住。现受淫相。时客比丘作是念。野兽之法甚易恐怖。而今驱遣不能令去。此必有以。是中将无有共此雌猿猴作不净行耶。时客比丘语旧比丘言。长老我今欲去。汝可还摄床褥。旧比丘言。诸长老。今此住处有好床褥前食后食。安隐快乐。幸可留意共于此住。答言不住。旧比丘殷勤三请。客比丘不受彼请。于是而去时客比丘心无疑者出便即去。心有疑者便于近处隐身各共伺之。时旧比丘见客比丘去已便摄卧具。摄卧具已洗足而坐。尔时山顶雌猿猴。复从山上下至比丘前背住。时旧比丘便共此猿猴行于非法。客比丘遥见已共相谓言。如我所疑今已显露。以是因缘往白世尊。长尾园中旧住比丘作如是恶法。佛言。呼是比丘来。来已佛问比丘。汝实作是事不。答言实尔世尊。佛告比丘。汝不知佛制戒不得行淫法耶。世尊我知制戒。自谓不得与人非人。不谓畜生。佛言比丘犯畜生者。亦波罗夷。比丘当知有三事犯波罗夷。何等三。人非人畜生是为三

复次佛住舍卫城。广说如上。有一比丘。时到着入聚落衣持钵入城。次行乞食至一家。有一女人语比丘言。可入大德共作是事。比丘答言。世尊制戒不得行淫。女人复言。我知不得常道中行。自可于非道中行。时此比丘即共女人于非道行淫。行淫已寻起疑悔。往白世尊。佛告比丘。汝不知佛制戒不得行淫耶。世尊我知制戒。自谓不得常道行淫。不谓非道。佛告比丘。非道亦犯波罗夷

复次佛住舍卫城。广说如上。有一比丘。时到着入聚落衣持钵入城。次行乞食至一家。尔时家中有一男子谓比丘言可前大德共作如是事来。比丘答言。世尊制戒不得行淫。彼言。我知制戒。不得与女人行淫。而我是男子。是比丘便随彼意。随彼意已寻生疑悔。具白世尊。佛告比丘。汝不知佛制戒不得行淫耶。世尊我知制戒。自谓不得与女人行淫。不谓男子。佛言。比丘男子亦犯波罗夷

复次佛住舍卫城。广说如上。有一比丘。时到着入聚落衣持钵入城。次行乞食至一家。有一黄门谓比丘言。可前大德共作如是事来。比丘言。世尊制戒不得行淫。彼言我知制戒。不得与男女行淫。我非男非女。是比丘便随彼意。随彼意已即生疑悔。具白世尊。佛告比丘。汝不知佛制戒不得行淫耶。世尊我知制戒。自谓不得与男女行淫。今此黄门非男非女。佛言比丘淫黄门亦犯波罗夷。佛言比丘三处犯波罗夷。何等三。男女黄门是为三

复次佛住毗舍离。广说如上。时有一比丘。时至着入聚落衣持钵入城。次行乞食至一家。有一女人语比丘言。可前大德共作如是事来。比丘答言。世尊制戒不得行淫。女言我知不得。汝可裹身我便露形。是比丘便随彼意。随彼意已即生疑悔。具白世尊。佛告比丘。汝不知佛制戒不得行淫耶。世尊我知制戒。但我裹身彼则露形。佛告比丘。裹身露形亦犯波罗夷

复次佛住毗舍离。广说如上。有一比丘。时至着入聚落衣持钵入城。次行乞食至一家。时有一女人语比丘言。可入大德共作此事。比丘答言。世尊制戒不得行淫。女言。我知。汝但露形我自覆身。比丘便随彼意。随彼意已寻生疑悔。具白世尊。佛告比丘。汝不知佛制戒不得行淫耶。世尊我知制戒。但彼覆身我露形。佛言。彼覆汝露。亦犯波罗夷。乃至齐如胡麻。亦犯波罗夷

复次佛住舍卫城。广说如上。尔时有比丘从异方来。身生长大自于后道行欲。行欲已然后疑悔。具白世尊。佛告比丘。汝不知佛制戒不得行淫耶。世尊。我知制戒。谓为制他。不谓自己。佛言。于自己行欲。亦犯波罗夷

复次佛住舍卫城。广说如上。有一比丘从南方来。先是伎儿。支节调柔淫欲炽盛。便于自口中行淫。行淫已即生疑悔。具白世尊。佛告比丘。汝不知佛制戒不得行淫耶。世尊。我知制戒。非谓自口。佛言。自口亦犯波罗夷。比丘于三处行淫。口大小便道。尽犯波罗夷

复次佛住王舍城。广说如上。有一比丘。时到着入聚落衣持钵。次行乞食到一淫女家。淫女语比丘言。大德可前共作是事。比丘言。世尊制戒不得行淫。女人答言。我亦知不得行淫。但身内行欲外出不净。比丘便随彼意。随彼意已心生疑悔。具白世尊。佛告比丘。汝不知我制戒不得行淫耶。答言。世尊。我知制戒。但身内行淫外出不净。佛言。内行于欲外出不净。外行于欲内出不净。乃至齐如胡麻。亦犯波罗夷

复次佛住王舍城。广说如上。时北方有诸商客。从远方来到。作是思惟。我从彼来安隐至此。不逢贼难宜应自庆。便办种种饮食。集诸伎乐欲自娱乐。尔时王舍城中有五百淫女共在一处。时商人遣信唤彼最胜第一淫女言。汝来娱乐我等。淫女答言。我先与王期夜辄往宿。君若见唤昼当相诣。商人忿言。无知弊物汝常到王所为何所得。汝今若来娱乐我等。我等当多与汝种种宝物。时淫女贪宝物故即许商人。便诈庄严一端正婢遣令诣王。便敕婢言。汝诣王所善作方便如我形相。莫令王觉知非我身。时王沐浴庄严待彼淫女。迟想其至须臾便到。王遥见婢来便知其非。即逆骂言。汝是何人而来至此。婢时惶怖以实白王。北方商人持宝远至。大持宝物与我大家。大家利其财重。故遣我来以副先期。冀王不觉。王闻婢言即大嗔骂。何弊女人敢见轻欺。即遣使者割去女形。时商人等遥见使来。知王所遣即便奔走。使者即捉淫女割去女形。王使既返。商人即还见淫女如此心各怜念。重赏良医以治其患。此医多方疮遂平复。时尊者优波离。因此淫女知时而问世尊。若有人割去其形。若有比丘于坏形中行淫。犯波罗夷罪不。佛言。波罗夷。又复问言。世尊。若形离其身。就此离形行淫。波罗夷不。佛言。得偷兰罪。又复问言。世尊。此形还合疮未愈于中行淫。犯波罗夷不。佛言。波罗夷

复次佛住王舍城。广说如上。时阿阇世王生一童子。字优陀夷跋陀罗。此儿阴为虫所食。以种种药治不能令差。见儿患此疮故。时抱养者常以口含其阴。暖气嘘之其痛小差。数数含之不止。彼得暖气便失不净。失不净时虫便随精而出。此儿于是得差苦痛除愈。从是已后常习此法。口中行淫如是转久。乃至强牵余母人于口中行淫。其儿有妇即作是念。彼习此不已当复及我。宜豫作方便止此恶法。于是脱衣裹面露其形体。往诣姑所礼拜问讯。时姑呵言。汝痴狂耶。何得如是。答言。不狂。但大家子舍于常道而用其口。是故覆之。即向其姑具说上事。尔时宫内展转相语。乃至外舍尽共闻知。多共为此口中行欲。时王舍城婆罗门居士。诣阿阇世王所白言。大王。国中有此恶法流行。云何口中是饮食处而行不净。王闻此言甚用不可即作教令。从今已去若有作此及教他者。当重治其罪。尔时尊者优波离知时而问世尊。若比丘比丘共口中行淫者。犯波罗夷不。佛言。俱波罗夷。又复白佛言。世尊。比丘与沙弥共口中行淫。犯波罗夷不。佛言。比丘波罗夷。沙弥驱出。又复白言。世尊。比丘与白衣共口中行淫云何。佛言。比丘波罗夷。白衣知如之何。又白世尊。比丘比丘尼共口中行淫。犯波罗夷不。佛言。俱波罗夷。乃至外道出家比丘共口中行淫云何。佛言。比丘波罗夷。外道知如之何

摩诃僧祇律卷第一摩诃僧祇律卷第二

        东晋天竺三藏佛陀跋陀罗共法显译

    明四波罗夷法之二(淫戒之余)

复次佛住舍卫城。广说如上。时郁阇尼国有一男子。其妇邪行与人共通。其夫嗔恨面相呵责。后复尔者要苦相治。其妇不止。夫伺其淫时。执彼男子俱送与王。白言。大王。此妇不良与是人通。愿王苦治以肃将来。时王大怒。敕其有司令兀其手足弃于冢间。时治罪者。即于冢间兀其手足仰卧着地。时有比丘在冢间行。见此女人裸身在地。彼不正思惟便生欲想。语此女言。共作是事。女即答言。此形如是犹可尔耶。比丘言。可尔。女人即许便共行欲。行欲已而去。尔时此女亲里知识共相谓言。当往冢间看此女人。为死为活。便共俱行往诣冢间。见彼兀女仰卧在地身上犹有新行欲处。皆共嗔言。汝于苦痛中犹复为此。人之无耻乃至如是耶。彼女答言。人来见逼。此非我咎。问言。逼者何人。答言。沙门释子。众人惊怪自相谓言。沙门释子是女人身坏如是犹故不舍。况复全形者。宜共防护无令近门。此等败人何道之有。彼比丘寻自疑悔。具白世尊。佛言。比丘汝不闻我制戒不得行淫耶。比丘答言。我知制戒。谓为全身。但此兀女形坏。佛言兀者若左手及右脚。若右手及左脚。是名兀女。若淫者犯波罗夷

复次佛住舍卫城。广说如上。有一比丘于祇洹中食已。入开眼林中坐禅。时祇洹开眼林中间。有一女狂发眠地。风吹衣起形体露现。时比丘不正思惟欲心内发。便共行淫。行淫已寻即疑悔。具白世尊。佛告比丘。汝不知我制戒不得行淫耶。比丘答言。我知制戒。但是女狂眠。佛言。淫狂眠女者。亦犯波罗夷

复次佛住毗舍离。广说如上。时有一居士妇父母家住久。夫家遣信呼妇令速还。妇将欲还作种种饮食自送之具。时风刀起吹裂女身。即便命终。毗舍离土地下湿。死人不得久停。时宗亲都集。即时送此死尸。往着旷野送死尸出。共相谓言当速疾去。莫令坏烂使人厌污。送出死尸值大风雨。置尸一处以草覆之。明当来烧。夜则雨止天清月出。时有比丘。夜游冢间过到是处。闻新死尸身有涂香。便谓是生人。是比丘不正思惟欲心即起。便淫死尸。行欲已犹故不厌。即担死尸到自住处通夜行欲。晨朝闭户入村乞食。死女亲里。明日持香油樵火欲烧死尸。到其本处不见死尸。复不见鸟兽所食踪迹。遍求不得。开比丘草庵。见死尸在中。尸上看见新行欲处。见已便相谓言。异哉沙门释子。死者尚不舍。况复生人。从今已去宜各防护。莫令沙门得入人舍。此等败物有何道哉。彼比丘寻自疑悔。具白世尊。佛言。比丘汝不闻佛制戒不得行淫耶。比丘答言。我知制戒。但彼是死女。佛言。淫死女。亦犯波罗夷。有三事比丘行淫犯波罗夷。何等三。死眠觉

尔时世尊告诸比丘。依止毗舍离比丘皆使令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘于和合僧中受具足戒。不还戒戒羸不出相行淫法。乃至共畜生。是比丘得波罗夷。不应共住。初波罗夷缘讫

比丘者。受具足善受具足。如法非不如法。和合非不和合。可称叹非不可称叹。满二十非不满。是名比丘义。于和合僧中受戒者。若比丘受具足时善受具足。一白三羯磨无障法。和合僧非别众。满十僧若过十。是为比丘于和合僧中受戒。不还戒者。欲先明还戒还戒者。是比丘还戒时。若愁忧不乐。心定欲舍沙门法。不乐行比丘事。不乐释种子言。我欲作沙弥。我欲作外道。我欲作俗人受本五欲。若向比丘比丘尼式叉摩尼沙弥沙弥尼外道出家在家俗人言。我舍佛舍法舍僧舍学舍说舍共住舍共利舍经论舍比丘舍沙门舍释种。我非比丘非沙门非释种。我是沙弥是外道是俗人。如本五欲我今受之。是名还戒。云何舍佛。舍佛者。舍正觉舍最胜舍一切智身舍一切见舍无余智见舍罗睺罗父舍金色身舍圆光舍三十二相舍八十种好。若舍一一佛名号。皆名舍佛。如是舍佛是名舍戒。若言舍过去未来佛。是不名舍戒。得偷兰罪。若不言舍过去未来佛。直言舍佛者。是名舍戒。若言舍辟支佛。是名舍戒过去未来同如舍佛。又外道一切出家六师弟子各言有佛。若比丘实欲舍此佛。假言舍外道佛。是不名舍戒。得偷兰罪。若戏笑舍佛。得越比尼罪若误说心狂无罪。云何舍法。法者非三世所摄。其相常住。所谓无为涅槃离众烦恼。一切苦患永尽无余若言舍此法者。是名舍戒。若言舍过去未来法。是不名舍戒。得偷兰罪。若不称过去未来。直言舍法。是名舍戒。一切外道各自有法。若比丘实欲舍此正法。假言舍彼法者。是不名舍戒。得偷兰罪。若戏笑舍法者。越比尼罪若误说心狂无罪。云何舍僧僧者。世尊弟子。僧等向政向智向法。次法向随顺法行。谓四双八辈。信成就。戒成就。闻成就。三昧成就。慧成就。解脱成就。解脱智见成就。应所恭敬为无上福田。若比丘言我舍是僧。是名舍戒。若言舍过去未来僧。是不名舍戒得偷兰罪。若不称过去未来。直言舍僧。是名舍戒。如比丘僧。比丘尼僧亦如是。若言我舍众多比丘是不名舍戒。得偷兰罪。若言我舍过去未来众多比丘。是不名舍戒。得越比尼罪。若不称舍过去未来众多比丘。直言舍众多比丘者。是不名舍戒。得偷兰罪。如众多比丘。众多比丘尼亦如是。若言我舍一比丘。是不名舍戒。得越比尼罪。若言舍过去未来一比丘。是不名舍戒。得越比尼心悔若不称言我舍过去未来一比丘。直言舍一比丘。是不名舍戒。得越比尼罪。如一比丘。一比丘尼亦如是。若言舍和上。是名舍戒。差别如舍僧中说。若言舍阿阇梨。是不名舍戒。得偷兰罪。若言舍过去未来阿阇梨。是不名舍戒得越比尼罪。若不称过去未来。直言舍阿阇梨。是不名舍戒。得偷兰罪。若戏笑言舍。得越毗尼罪。若误说心狂无罪。如彼外道名自称为僧。若比丘实欲舍此僧。假言舍外道僧。是不名舍戒。得偷兰罪。若戏笑言舍僧。得越比尼罪。若误说心狂无罪。云何舍学。学有三种。有增上戒学。增上意学。增上慧学。增上戒学者。谓波罗提木叉广略说。增上意学者。所谓九次第正受。增上慧学者。所谓四真谛。彼增上戒学增上意学增上慧学。尽名为学若比丘言舍此学。皆名舍戒。如前舍佛中说。世间各自有学。如工巧书算技术等。皆名为学。若比丘欲舍此学。假言舍彼学者。是不名舍戒。得偷兰罪。如外道各自有学。若比丘欲舍此学。假言舍外道学。是不名舍戒。得偷兰罪若戏笑言舍学。得越比尼罪。若误说心狂舍戒无罪。云何舍说。说有三种。若十四日。若十五日。若中间布萨。十四日者。冬第三第七布萨。春第三第七布萨。夏第三第七布萨。一岁中此六布萨。是名十四日。余十八布萨十五日。合二十四布萨。是名十四日十五日布萨。中间布萨者。有比丘布萨时。若僧不和合。一比丘于僧中唱。若僧和合时。当作布萨。若无一比丘唱者。一切僧得越比尼罪。一比丘唱者。一切僧无罪。若十五日不和合。应初日布萨。初日不和合者。二日乃至应十二日布萨。若十二日不和合。应十三日布萨。若十四日应正布萨者十三日。不应作中间布萨。便就十四日布萨。亦是中间布萨。亦名正布萨。若月大者。乃至十三日和合得作中间布萨。若不和合不得。十四日应就。十五日布萨亦名中间布萨。亦名正布萨。何以故。不得频日布萨。应当隔日布萨。是名中间布萨。应十四日布萨者。不得停至十五日。应十五日布萨者。不得逆十四日。若有因缘者。得作布萨。若十四日若十五日若中间布萨。尽名为说若如是言我舍是说是名舍戒。如前舍佛中说。彼诸外道亦各有说。若实欲舍此说。假言舍外道说者。是不名舍戒。得偷兰罪。若戏笑舍说者得越比尼罪。若误说心狂舍说无罪。云何舍共住。共住有二种。一者清净共住。二者相似共住。清净共住者。众悉清净共作布萨。是名清净共住。相似共住者。不清净作清净相。与清净者共作布萨。是名相似共住。彼清净共住相似共住。尽名共住。若言我舍共住。是名舍戒。如上舍佛中广说。彼诸外道亦有共住。若实欲舍此共住。假言舍彼共住。是不名舍戒。得偷兰罪。若戏笑说舍共住。得越比尼罪。若误说心狂舍共住者无罪。云何舍共利。共利者有二种。一者法利。二者衣食利。法利者。名受诵问答。衣食利者。同受一施。彼法利衣食利者尽名共利。若比丘言我舍此利。是名舍戒。余如上舍佛中广说。若言舍法利。是名舍戒。如上舍佛中广说。若但言我舍衣食利。是不名舍戒。得偷兰罪。若言我舍过去未来衣食利。是不名舍戒。得越比尼罪。若不称过去未来。直言舍衣食利者。是不名舍戒。得偷兰罪。彼诸外道亦有共利。若实欲舍此共利。假言舍彼共利者。不名舍戒。得偷兰罪。若戏笑言舍共利者。得越比尼罪。若误说心狂舍共利者无罪。云何舍经论。诸经论有九部。若比丘言我舍此经论者。是名舍戒。若言我舍过去未来经论者。是不名舍戒。得偷兰罪。若不称过去未来。直言舍经论者。是名舍戒。若作伎中。以佛语作歌颂。若言我舍此歌颂中佛语者。是名舍戒。彼诸外道亦有经论。若实欲舍此经论。假言舍。彼经论者。是不名舍戒。得偷兰罪。若戏笑言舍经论者。不名舍戒。得越比尼罪。若误说心狂舍经论者无罪

复次若比丘言。我舍佛佛舍我。我离佛佛离我。我远佛佛远我。我厌佛佛厌我。我休佛佛休我。如是皆名舍戒。乃至舍诸经论亦如是。是名还戒。不还戒者。若嗔恚若卒说。若独说若不了说。若因诤说若独想说。若说前人不解。若向眠者说。向狂者说。向苦恼者说。向婴儿说。向非人说。向畜生说。如是诸说还戒。是不名舍戒。戒羸者。彼作是念。我不如舍佛法僧。乃至舍诸经论。彼复作是念。我当作沙弥作俗人作外道。彼心念口言。未决定向他人说。是名戒羸。若说戒羸事者。语语得偷兰罪。复作心念口言。我不如舍佛。乃至言我不如作本俗人。复作是言。我舍佛者胜。乃至我习本俗人者胜。是名戒羸。若说戒羸事。语语得偷兰罪。是名戒羸。若戒羸行淫法。淫法者。谓与女人有命三处中行淫初中后受乐。是名行淫法。若比丘戒羸行淫法。得波罗夷罪。不应共住。人女有命及死。三处行淫初中后受乐。如是非人女有命及死。畜生女有命及死。三处行淫三时受乐。是比丘得波罗夷罪。不应共住。若人男有命及死。非人男有命及死。畜生男有命及死。二处行淫三时受乐。是比丘得波罗夷罪。不应共住。人黄门有命及死。非人黄门有命及死。畜生黄门有命及死。二处初中后三时受乐。得波罗夷罪。畜生者。从象马乃至鸡。是名畜生。若犯此畜生者。得波罗夷罪。象身大乃至鸡身小。得偷兰罪。若象身小乃至鸡身大者。得波罗夷罪。是故说乃至共畜生。得波罗夷罪。波罗夷者。谓于法智退没堕落无道果分。是名波罗夷。如是未知智等智他心智苦习尽道智尽智无生智。于彼诸智退没堕落无道果分。是名波罗夷。又复波罗夷者。于涅槃退没堕落无证果分。是名波罗夷。又复波罗夷者。于梵行退没堕落无道果分是名波罗夷又复波罗夷者。所可犯罪不可发露悔过。故名波罗夷。若比丘以染污心欲看女人得越比尼心悔。若眼见若闻声。犯越比尼罪。各各裸身相触。得偷兰罪。乃至入如胡麻。波罗夷。若彼身大。虽入不触其边者。得偷兰罪。有众生一道。从是处食。是处大小便。若生若死。若淫此众生。初中后受乐者。波罗夷。若女人身裂为二分。就一一分行淫者。得偷兰罪。若系缚令合行淫者。波罗夷。若女人段为三分。比丘于下分行淫波罗夷。中分行淫偷兰罪。上分行淫波罗夷。若女人身青瘀膖胀。于此行淫者波罗夷。身若坏烂偷兰罪。身全枯乾者亦偷兰罪。若以酥油水渍润不坏行淫者。波罗夷。若形坏偷阑罪。骨琐相连脓血涂着行淫者。犯越比尼罪。白骨枯乾者。越比尼心悔。石木女人画女人。越比尼罪。若比丘不说还戒不说不还戒。若戒羸不说还戒不说不还戒。便作俗人。随其所犯如法治罪。若作外道亦如是。若裹不覆。若覆不裹。亦覆亦裹。不覆不裹。乃至入如胡麻。波罗夷。若比丘不还戒。若戒羸不出相。便作俗人形服而犯罪者。随其所犯得罪。若比丘于比丘尼边强行淫者。比丘得波罗夷。若比丘尼受乐者亦波罗夷。若比丘尼于比丘边强行淫者。比丘尼波罗夷。若比丘受乐者亦波罗夷。若比丘比丘展转共行淫。俱波罗夷。若比丘比丘尼共行淫者。俱波罗夷。比丘沙弥展转共行淫。比丘波罗夷沙弥驱出。比丘俗人展转共行淫。比丘波罗夷。俗人不犯。乃至外道亦如是。若比丘三种行淫。人非人畜生。复有三种。女男黄门。复有三种。上中下道。复有三种。若觉若眠若死。皆波罗夷。若比丘眠心狂入定。有母人强就比丘行淫。比丘若觉初中后受乐者。波罗夷。是比丘若眠乃至入定。若母人强就比丘行淫。彼觉已初不受乐中后受乐。亦波罗夷。是比丘若眠乃至入定。若母人强就比丘行淫。彼觉已初中不受乐后受乐者。波罗夷。是比丘若眠乃至入定。若母人就比丘行淫。若比丘觉已初中后不受乐。无罪。云何名受乐。云何名不受乐。受乐者。譬如饥人得种种美食。彼以食为乐。又如渴人得种种好饮。彼以饮为乐受。欲乐者亦复如是。不受乐者。譬如好净之人以种种死尸系其颈上。又如破痈热铁铄身。不受乐者亦复如是。若比丘行淫。若买得若雇得。若恩义得知识得调戏得试弄得未更事。得如是一切。得而行淫者。皆波罗夷。若心狂不自觉者无罪。是故说。若比丘于和合僧中受具戒。不还戒戒羸不出相行淫法。乃至共畜生。是比丘犯波罗夷。不应共住。世尊于毗舍离城成佛五年冬分第五半月十二日中食后。东向坐一人半影为长老耶舍迦兰陀子。制此戒。已制。当随顺行。是名随顺法(淫戒竟)

    盗戒之一

佛住王舍城。广说如上。尔时瓦师子长老达腻伽。劝化立僧房。种种庄严高大妙好雕文刻镂。香油涂地如绀琉璃色。常有供办种种饮食。时有长老比丘来问达腻伽。长老几岁。答言尔所岁。客比丘言。汝小我应是中住。达腻伽既与上座房住。复更劝化起立第二房。复有长老比丘来。如前次第与房。复更劝化起第三房。复有长老比丘来。亦复如前。是时达腻伽念言。我种种辛苦作房而不得住。我当何处复得材木人功更造房舍。常为风雨寒热蚊虻所困苦。办此房始得成已。傍人常待如猫伺鼠。成便见夺。奈何可办。便作是念。我自工巧并有身力。当于仙人山窟边黑石上。烧作完成瓦屋。时达腻伽作是念已。便于仙人窟边黑石上。烧作完成瓦屋种种刻画安施户牖。唯除户扇户钥衣架。余者一时烧成。其色纯赤如优昙钵花。尔时世尊雨后天晴于耆闇崛山侧往来经行。如来佛眼。无事不见。无事不闻。无事不识。以是因缘欲说契经令毗尼久住。知而故问诸比丘。仙人山窟边黑石上。如优昙钵色。为是何等。诸比丘白佛言。世尊。是达腻伽比丘先劝化作僧房。雕文刻镂极好庄严。成已上坐次受。复作第二第三亦复如是。便于仙人山窟边黑石上。私作烧成瓦屋。其色妙好如优昙钵花。今仙人山窟边黑石上者是。尔时世尊告阿难。持我衣来。阿难持衣授与如来。尔时世尊着衣已。往到仙人山窟黑石上。世尊成就最上威仪。所谓行住坐卧。世尊不复用心行此威仪。所以者何。业行功德自然殊胜。非是诸天梵王所能及者。如威仪修多罗中广说。尔时世尊以殊胜威仪往到达腻伽烧成瓦屋所。天神令屋户自开。其户下小。如来平入。虽下不碍小而不迮。尔时世尊入达腻伽烧成屋已。便以金色手合缦掌。摩扪屋壁语诸比丘。汝等观此达腻伽比丘善能严饰作此好屋。是达腻伽比丘。虽得出家犹故不能厌本所习。工巧技术犹未能舍。而复焚烧伤杀众生。又此瓦屋寒则大寒热则大热。能坏人眼令人多病。有是诸患。汝等当坏此屋。莫使当来诸比丘习此屋法。来世比丘当言。世尊在时诸比丘各各自作屋住。是故宜坏。时诸比丘即坏此屋。世尊坏此屋已还耆阇崛山。时长老达腻伽比丘从村乞食还见屋已坏。即作是言。谁坏此屋。时有比丘语达腻伽。汝今大得善利。何以故。如来降屈顾临此屋。汝蒙此屋受用之福。世尊知时故坏此屋。时达腻伽闻是语已。喜悦情至。七日之中忘其饥渴。过七日后便作是念。我当何处更得材木起立房舍。瓶沙王木匠大臣耶输陀者。是我本知识。必有材木。即便着入聚落衣持钵。诣耶输陀家共相慰劳言。无病长寿。我欲起立房舍未有材木。汝能见施材木不。大臣答言。家自无材王材亦尽。若迎材至当相给与。达腻伽复言莫作是语。云何王家而言材尽。大臣又言。尊者。若不见信可自往看。时达腻伽即便往诣作所求诸材木。见有五枚飞梯材。即便取二枚持归作屋。先王旧法。五日一游历观府库。金银宝藏宫人倚直。象马栏厩车舆武效。次行木坊见飞梯材少无二枚。即问耶输陀。飞梯材何以少无二枚。答言。大王。尽在不少。如是第二第三案行。复问耶输陀。飞梯材何故少无二枚。答言。大王。尽在不少。王即嗔言。汝不烧我材耶。不持我材与敌国耶。即使有司摄系耶输陀。耶输陀被摄已即便思念。近尊者达腻伽。曾来索材无乃持去。即便遣信白达腻伽言。尊者。曾来索材。不持此二枚飞梯材去耶。答言。持来。复遣使白尊者。我坐失此飞梯材故。被摄在狱。尊者。当作方便。自得无过令我早出。达腻伽即报言。汝但白王。先达腻伽比丘从我索材。脱能持去愿敕捡挍。王即遣使唤达腻伽。达腻伽便至王所。长老达腻伽为人端正。仪容详雅天人所敬。王见欢喜即问言。尊者达腻伽。不取我二枚飞梯材耶。答言。我取。王言。尊者云何出家人不与而取。达腻伽言。大王。先与非是不与。王问。谁与。答言。王自见与。王言。尊者。我为国王。虽复多事不忆相见。云何言与。达腻伽言。王不忆初受位时。国中大臣集聚一切河池泉水。一切诸药一切种子以水渍之。白象牙上水渧灌顶拜之为王。王时口自发言。我今为王。国中所有水草树木。施与沙门婆罗门。是故王与。非是不与。王言。尊者。我与国中无守护者。不与有守护者。何得倚傍先言伪辞见诬。王言。放此耶输陀令去。国中诸婆罗门及敬信士女皆欢喜言。善哉尊者达腻伽。方便智慧巧答大王得免斯过。又令耶输陀安隐得出。时王舍城诸不信佛法者。咸有恚言。云何是沙门达腻伽倚傍伪理欺罔于王苟得免罪。恐自今已往我等家中所有材木亦当取去。而言王先见与。当奈之何。如是败人何道之有。诸比丘以是因缘具白世尊。佛言。呼达腻伽比丘来。来已佛问达腻伽。汝实取王家飞梯材不。答言。实取。佛言。汝出家人云何他物不与而取。达腻伽言。世尊。王先见与非是不与。佛言。云何王与。达腻伽言。王初登位时。口自发言。国中所有水草树木。施与沙门婆罗门。是故言与非是不与。佛言。痴人。王与无守护者。不与有守护者。今此王材有守护者云何言与。达腻伽汝常不闻佛种种因缘呵责不与取。种种称赞与而后取耶。云何汝今不与而取。达腻伽此非法非律非是佛教。不可以是事增长善法。诸比丘白佛言。世尊。云何是达腻伽比丘最初开不与取。佛告诸比丘。是达腻伽不但今日犯最初不与取。过去世时已曾最初犯不与取。诸比丘白佛言。已曾尔耶。佛言。如是。过去世时。此世界劫尽时。诸众生生光音天上。世界还成。光音诸天来下世间。时诸天人行住虚空。以禅悦为食。快乐善住所在游行。身光相照不以日月为明。尔时众生无有昼夜日月。岁数时节。时水既去地味便生如天甘露。时有一贪味轻躁众生。尝此地味觉色香美味。心便贪着。其余众生效而食之。亦觉其美皆共取食。食已其身粗重。退失神通光明悉灭。世间便有日月昏明岁数时节。尔时众生非男非女。食地味久形色并异。其食多者身色粗丑。其食少者身色端正。时端正者自言己胜。见粗丑者轻彼不如。恃端正故便起憍慢。起憍慢罪故地味即灭。更生地肤味如纯蜜。时诸众生皆惊叹言。如何地味忽然而灭。便复相与共食地肤。其食多者形色粗丑。其食少者身色端正。其端正者憍慢转增。如是已后地肤复灭。地肤灭已次生地脂味如石蜜。其食多者丑。食少者好。亦复如前。其端正者倍起慢心。于是地脂忽然复灭地脂灭已。次有自然化生粳米。取已还复不觉增减。朝取暮复。暮取朝复。比丘当知。时诸众生。见地脂灭已遂生忧恼。譬如丈夫忧恼所逼。彼时众生虽心忧怖。而自不知己之过罪。尔时众生复食彼自然粳米。食米渐久便有男女形生。更相染着淫欲转炽遂成夫妇。余众生见已嗔恚打掷。云何世间非法忽生。是会非生天法。从今已后当修善法生天之会。佛告比丘。时有众生为非法者。惭愧厌污藏隐不出。或一日二日乃至一月。于是便兴屋舍而自障蔽。为非法故。彼时众生便作是念。我等何为竟日疲苦。不如晨旦并取粳米兼明日食。明日有众生来唤共取粳米。此众生答言我昨并取。彼众生言。此是好法。便相效并取。乃至十日二十日一月二月。以贪意储畜故。粳米变生糠糩朝取处暮则不生。尔时众生便共聚会。聚会已便相谓言。我等本时皆自然飞行。禅悦为食快乐安隐。转食地味。时彼众生未有恶法。以恶法起故地味即灭而地肤生。地肤既生犹香且美。次生地脂乃至粳米犹故香美。我等今日当立制限。分其米地令有畔界。即便封之。此分属我。彼分属汝。时有一众生作是念。若我自取己分不久当尽。宁可少取他分令我分久在。彼诸众生见此众生不与而取。便语之言。汝今云何不与而取。勿复更作。然此众生犹取不止。乃至再三。然彼众生重见如此。便言。云何众生行不与取。乃至再三。从今已往若不与取者。当加刑罚。彼遂不已。便即捉得痛加鞭杖。彼得杖已便大唤言。云何世间有此恶法。使是众生以杖见打。是时打者投杖放地。亦大唤言。云何世间有是恶法。何种众生不与而取。妄有所说不知羞愧。于是世间便有三恶法出。何等为三。一者不与取。二者妄言。三者以杖打人。是为最初三恶法出。佛告诸比丘。是时众生最初不与取者。岂异人乎。今瓦师子达腻伽比丘是也。是达腻伽。从过去最初时不与取。今复于我正法中。亦最初不与而取。时诸比丘复白佛言。云何是达腻伽比丘。蒙世尊恩被袈裟。瓶沙王见已便放令去。佛言如是。诸比丘是达腻伽比丘。不但今日蒙我袈裟而得免罪。过去世时已蒙我恩着袈裟亦得度脱。过去世时。大海边有睒婆梨树。上有金翅鸟是鸟身大。两翅相去百五十由旬。是金翅鸟法。以龙为食。欲食龙时。先以两翅抟海令水两辟。龙身便现。即取食之。诸龙常法。畏金翅鸟。常求袈裟着宫门上。鸟见袈裟生恭敬心。便不复前食彼诸龙。尔时是鸟以翅。抟海见龙欲食。龙甚惊怖。便取袈裟戴着顶上寻岸而走。是时彼龙化为人像。金翅鸟化为婆罗门像。追逐此龙而并种种骂言。汝何不早放袈裟。此龙畏死急捉袈裟死死不放。尔时海边有仙人住处。花果茂盛。时龙恐怖无所依怙。便往投趣仙人住处。仙人有大威德。金翅鸟不敢便入。遥向仙人而说偈言

  今此弊恶龙　　自变为人身
  畏死求解脱　　而来入是中
  仙人德力故　　我当忍饥渴
  宁自失身命　　不复食此龙

尔时仙人作是念。谁说是偈。便起出看。见此龙为金翅鸟所逐。即便说偈。答金翅鸟言

  当令汝长寿　　常食天甘露
  忍饥不食龙　　敬心于我故

时金翅鸟蒙仙人威神饥渴即除。是时仙人复告金翅鸟。汝坐犯戒受此鸟身。今复习杀当堕地狱。广说十恶乃至邪见。如是一一皆堕地狱畜生饿鬼及阿修罗。汝今宜当共此龙更相忏悔后无余怨。彼即忏悔。忏悔已各还本处。佛告诸比丘。尔时仙人者。岂异人乎。即我身是。金翅鸟者。瓶沙王是。龙者。达腻伽比丘是。是达腻伽比丘。本已蒙我袈裟。得脱金翅鸟难。今复蒙我袈裟得脱王难。时诸比丘白佛言。云何是瓶沙王。见是达腻伽比丘着袈裟故。放令解脱。佛告诸比丘。不但今日。本已曾尔。诸比丘白佛言。已曾尔耶。佛言如是。过去世时有王。善化人物离诸怨敌。五谷丰熟民多受乐。节义恩良仁德孝慈布施持戒。时彼国有猎象师。其家贫穷又多儿子。儿子各各求索饮食。时猎师妇语其夫言。居家贫穷饥寒如是。何不勤于家业。猎师答妇。欲作何等。妇言。何不勤修先人之业。时彼猎师即办粮食执持猎具到雪山边。时有六牙白象。住在山下。凡生象中有如是智。便自念言。以何等故人欲杀我。欲杀我者以我牙故。是时彼象其祖先死。象取其牙藏着一处。其父续死。复取其牙藏着一处。出群象外仿佯游食。彼时猎师次第游猎。历诸山林遂至象所。象遥见猎师便生念言。是何丈夫乃至此中。将非猎者欲来见杀。即便举鼻招唤猎师。猎师明练相象之法。若我不去此必见害。便至象所。象即问言。汝来何求。猎师即向说其来意。象言。汝更不来者。当给汝所须。猎师答言。我有所得不欲出门。何况至此。时象即以先藏祖牙与之。猎师得已欢喜还国。彼作是念我持此牙。归妻子衣食未得几时。我当屏处独自食之。若我强健便有妇儿。一旦无我无五钱分便持象牙诣酤酒家。时沽酒者遥见彼来。便作是念此何处来。我于今日必得少利。便敷床褥代担象牙请彼令坐。乘彼饥渴与酒令醉。醉复更索便共书券。得酒甚少上券甚多。后日醉醒复更索酒。酤酒者言。何故更索。君似未解当共计钱。若钱有余当更相与。算计既竟无一余钱。彼即念言。我当何处更得钱财。正当入山还杀彼象。即便入山至先象所。象见猎师。问言。何故复来。猎师对象说其来意。象言。先与汝者。今为所在。答言。无智所致放逸用尽。象言。汝能更不放逸者。当复与汝。猎师答言。我已悔前所为何缘重尔。若能更惠真不出门。象复持父牙而用与之。猎师即持象牙还国。复如前法无道用尽。即作是念。当杀彼象。今若往者不令见我。彼大象者于春后月天时大热。入池洗浴。浴已还出。在众象前凉息树下。尔时猎师便以药箭射彼大象。中其眉间血流入眼。象便举头看箭来处。即见猎师便遥诲之。汝弊恶人无有反复。如我今者力能相杀。但恭敬袈裟故不杀汝。即唤猎师汝可速来截取我牙。以身障彼猎师不令余象害之。尔时林中有诸天神。即说偈言

  内不离痴服　　外托被袈裟
  心常怀毒害　　袈裟非所应
  三昧寂无想　　永灭烦恼患
  内心常寂灭　　袈裟应其服

佛告诸比丘。尔时大象王者。岂异人乎。即今瓶沙王是。猎师者。今比丘达腻伽是。瓶沙王曾已恭敬袈裟故恕彼猎师。今复以达腻伽被袈裟故而不与罪。诸比丘复白佛言。世尊。云何是瓶沙王。见达腻伽威仪庠序不起恶心。佛告诸比丘。是瓶沙王。不但今日爱乐威仪不起恶心。诸比丘白佛言。世尊。已曾尔耶。佛言如是。过去世时有王。善化人物离诸怨敌。五谷丰熟民多受乐。节义恩良仁德孝慈。布施持戒泛爱人物。王有一象。名曰大身。凶恶难伏威震远近。时诸敌国莫能当者。有所讨伐皆悉摧破。诸有犯王法者。皆令此象足蹈杀之。王有此象恃之无畏。彼象厩坏。象便逸走到精舍边。见诸比丘威仪庠序。又闻诵经杀生受苦不杀获福。象闻此言。心即调柔。时有罪人犯法应死。王敕有司令象蹈杀。时象以鼻三嗅罪人都无杀心。彼监杀者即以白王。象见罪人直以鼻嗅绝无杀意。王闻此言甚大愁怖。便语来者象审尔耶。答言实尔。王召大臣共论此事。大臣既集。王告之言。吾今为王无能胜者正恃此象。今忽如是当如之何。大臣是时即呼象子而问之言。近象厩坏象至何处。象子答言。至精舍所。大臣聪明豫知此象。见诸比丘必闻经法。心意柔软不欲杀生。便教象子近象厩边。作博戏舍作屠儿舍作囚系舍。汝便系象近此诸舍。彼象见博者张目舞手高声大唤。见彼屠者残杀众生。又见狱囚考掠楚毒。象见是已恶心还生。王送罪人象即蹈杀。尔时诸天即说偈言

  象见善律仪　　又闻罪福声
  善心日夜增　　恶行渐得灭
  习近诸恶业　　先心还复起
  唯有明智人　　直进而不还

佛告诸比丘。尔时大身象者。岂异人乎。即瓶沙王是。瓶沙王宿世时。曾见比丘威仪庠序爱乐欢喜。今具达腻伽威仪庠序。甚大欢喜不问其罪。时达腻伽即作是念。我作第一房。上坐次受驱我令出。第二第三亦驱我出。后续作烧成瓦屋。世尊复敕令坏。取王家材持用作舍。世尊复见种种呵责。徒自辛苦用多事为。自今已后止此苦事。依随众僧苦乐任意。时达腻伽便习无事。昼夜精诚专修道业。得诸禅定成就道果。起六神通自知作证。时达腻伽深自庆慰。而说偈言

  欲得寂灭乐　　当习沙门法
  止则支身命　　如蛇入鼠穴
  欲得寂灭乐　　当习沙门法
  衣食系身命　　精粗随众等
  欲得寂灭乐　　当习沙门法
  一切知止足　　专修涅槃道

尔时佛告诸比丘。依止王舍城诸比丘皆悉令集。乃至已闻者当重闻。若比丘不与盗取者波罗夷。不应共住。复次佛住王舍城广说如上。有一比丘时至着入聚落衣持钵。入城求粪扫衣。于王舍城遍求不得。便至冢间亦复不得。寻水而求亦复不得。最后至浣衣处求。时浣衣者浣衣已竟。别在一处与人共语。时比丘往至衣所。有异男子语浣衣者言。彼出家人欲取汝衣。衣主问言。何道出家。答言。释种出家。浣衣者言。无苦。沙门释子不与不取。须臾比丘便取此衣。向异男子复告浣衣者言。沙门已取汝衣。浣衣者犹故答言。无苦。沙门释子不与不取。时彼比丘便挟衣而去。彼男子复告浣衣者。沙门释子已担衣去。衣主便起看之。咄哉实持衣去。便逐唤言。尊者尊者。是衣是王大臣许长者许。各各有主。愿莫担去。比丘故去犹不放衣。主便骂言。败行沙门。若不还我衣。当如是如是治汝。比丘持衣往至住处。开户以衣敷绳床上闭户而坐。时浣衣者持五种灰逐入祇洹。有余比丘在祇洹门间经行。复有坐思惟者。比丘便谓浣衣者言。何以高声大唤。浣衣者言。今我失衣。何以问我高声唤为。诸比丘言。谁持汝衣去。答言。出家人。即问何道出家。答言。释种子。诸比丘问言。持至何处。浣衣者。言入此房中。诸比丘便往彼房以指打户。唤言。长老开户。彼比丘默然不应。有年少比丘多力强排户入。盗衣比丘即大惭愧低头不语。时年少比丘便于床上取衣而出。以其领数谓浣衣者言。衣数相应不。答言。相应。时诸比丘语浣衣者言。此中出家有种种人。譬如一手五指不齐。杂姓出家何得一种。汝好贤者莫广语人。我等自当上白世尊。时浣衣者即作是言。沙门释子有王者力婆罗门长者力。我向但恐都失此衣。今既还得何所复说。时诸比丘以是因缘广白世尊。佛言。唤是比丘来。即便唤来。佛问比丘。汝实尔不。答言。实尔世尊。佛告比丘。汝不闻佛制戒不得不与取耶。世尊我知制戒。自谓城邑聚落。不谓空地。佛言。痴人。聚落中不与空地不与。有何等异。此非法非律非是佛教。不可以是长养善法。诸比丘白佛言。世尊。云何是浣衣者不信傍人。为彼比丘所欺耶。佛告诸比丘。是浣衣者。不但今世不信。过去世时亦曾不信。诸比丘白佛言。世尊。已曾尔耶。佛言如是。过去世时有二婆罗门。往南天竺。学外道经论。学已还其本国。当其还时道由旷野经放牧处。见二羝羊当道共斗。羊相触法。将前而更却。时在前行者专愚直信。语后伴言。看是羝羊四脚之兽而用议让。知我婆罗门持戒多闻。数数为我却行开路。后伴答言。婆罗门。汝莫轻信谓羊有议。此非相重开路相避。羊斗之法。将前而更却。在前行者不信其语。为羊所触即时绝倒。伤破两膝闷绝躃地。衣服伞盖裂坏荡尽。彼时有天而说偈言

  衣服裂坏尽　　体伤闷躃地
  此患痴所招　　斯由愚信故

佛告诸比丘。时前行婆罗门岂异人乎。今失衣者是。时后行婆罗门者。今告异男子是。时羝羊者。取衣比丘是。失衣人先已不信为羊所困今复不信自致失衣。本曾不信后行者语。今虽告诚亦复不信。佛告诸比丘。依止舍卫城比丘皆悉令集乃至已闻者当重闻。若比丘聚落空地不与盗数取者。波罗夷不应共住

摩诃僧祇律卷第二摩诃僧祇律卷第三

        东晋天竺三藏佛陀跋陀罗共法显译

    明四波罗夷法之三(盗戒之余)

复次佛住王舍城。广说如上。瓶沙王先祖时治罪人法。有作贼者。以手拍头以为严教。贼大惭愧与死无异。后更不作至祖王时治罪人法。有作贼者。以灰围之须臾放去。贼大惭愧与死无异。后更不作。至父王时治罪人法。有作贼者。驱令出城。贼自惭愧与死无异。后更不作。瓶沙王法。有作贼者。驱令出国。以是为教。时有一贼七反驱出。犹故来还劫杀村城。尔时有人捉得此贼缚送与王。白王言。此贼七反驱出。犹故来还劫杀村城。愿王苦治。王告大臣。将是贼去以罪治之。大臣白言。止止大王。王自治罪莫付臣下。何有舍王臣下专辄。大王教令时所尊重。正出于王治法久存。王言。将去截其小指。尔时有司速将罪人急截其指恐王有悔。时王即自试咬指看痛殊难忍。即便遣信敕语大臣。莫截彼指臣答王言。已截其指。王甚愁悔即自念言。我今便为法王之末。非法王始。夫为王者忧念民物。何有人王伤截人指。尔时瓶沙王。疾敕严驾往诣世尊。顶礼佛足却坐一面。白佛言。世尊。我曾祖先王治罪人法。唯以手拍头。次第诸王及至我身。恶法日滋正化渐薄。谬得为王伤截人体。自惟无道愧惧实深。佛告大王。治国盗齐几钱罪应至死。盗齐几钱应驱出国。盗齐几钱应用刑罚。尔时瓶沙王白佛言。世尊。以十九钱为一罽利沙槃。分一罽利沙槃为四分。若盗一分若一分直罪应至死。尔时世尊为瓶沙王。随顺说法示教利喜。示教利喜已。忧愦即除。礼佛而退。王去不久。尔时世尊往众多比丘所。敷座而坐告诸比丘。向瓶沙王来至我所。为我作礼于一面坐。而白我言。世尊。我先曾祖治罪人法以手拍头。正化相承乃至我身。我即问言。大王。盗至几钱罪应至死。乃至应罚。王言。十九钱为一罽利沙槃。分一罽利沙槃以为四分。若盗一分若一分直罪应至死。我为瓶沙王随顺说法。欢喜而去。佛告诸比丘。从今当知十九故钱名一罽利沙槃。分一罽利沙槃为四分。若盗一分若一分直。犯波罗夷。时诸比丘白佛言。世尊。云何是瓶沙王畏罪乃尔。佛告诸比丘。是瓶沙王。不但今世如是畏罪。过去世时亦曾畏罪。诸比丘白佛言。世尊。已曾尔耶。佛言如是。过去世时。有城名波罗奈。国名迦尸。尔时有王。号曰名称。时国人民皆工巧技术以自生活。所谓伎乐歌颂。或作金银宝器花鬘璎珞严饰之具。或调象马及诸道术。种种工巧无不备悉。以是生活。若无工巧技术者。谓之愚痴。若有作贼者。亦名愚痴。时有一人作贼。国人缚送与王。白言。大王。此人作愚痴事。愿王治之。王言。止止。世人失财世人作贼。我复何用共作恶为。王便思惟当作何方便我治王事。令群臣不知恶法不起。复更思惟自昔以来始有一愚痴人。是愚痴人不能满千。我便命终即将愚人付一大臣。我须千愚痴人用作大会。若当数满白我令知。臣即执持愚人系在一处王寻念言。是愚痴者。将无饥死。便告大臣将愚人来。重告臣曰好看此人莫令羸瘦。着我无忧园中。五欲娱乐伎乐供给。大臣受教。即将愚人如王所敕。尔时复有愚人。闻王捕得愚人。乃至安置无忧园中伎乐供给。便自送身诣大臣所。白言。我是愚痴人。大臣欲取王意。来便送着无忧园中。如是不久其数满千。臣白王言。愚人者数已满千。更须何等当速办之。王闻此言甚大愁忧。昔来久远始有一愚痴人。如何今者未经几时已有千数。将是末世恶法增长。王敕群臣于无忧园中。洒扫烧香悬缯幡盖。备办种种肴膳饮食。臣即如教备王所敕。时王出游。与诸群臣十八部众诣无忧园中。王既坐已问诸群臣。愚人今在何处可唤将来。愚人尽至。王见愚人久在园中。衣被垢腻爪长发乱。即敕群臣。将愚人去。沐浴新衣剪发截甲。然后将来。来已与种种饮食。赐以财宝恣其所须。即敕愚人。汝等还家供养父母。勤修家业莫复作贼。尔时愚人闻王告敕。欢喜奉行。时彼国王即以王位授与太子。出家入山学仙人法。是时国王而说偈言

  本求千愚人　　作会谓难得
  如何未几时　　千数忽已满
  恶法日夜增　　大会于是止
  欲离世恶人　　宜时当出家

佛告诸比丘。尔时国王名称者岂异人乎。即瓶沙王是。瓶沙王先世以来常畏罪报。今既为王续亦畏罪。诸比丘白佛言。世尊。云何是瓶沙王。教令行已寻复还悔。佛告诸比丘。是瓶沙王。不但今日教令行已寻复还悔。过去世时。亦曾还悔。诸比丘白佛言已曾尔耶。佛言如是。佛告诸比丘。过去世时有婆罗门。无有钱财以乞自活。是婆罗门有妇不生儿子。家有那俱罗虫便生一子。时婆罗门以无子故。念彼那俱罗子如其儿想。那俱罗子于婆罗门亦如父想。时婆罗门于他舍会。或得乳酪及得饼肉。持还归家与那俱罗。又于后时婆罗门妇忽便有娠。月满生子便作是念。是那俱罗生吉祥子能使我有儿。时婆罗门欲出行乞食。时便敕妇言汝若出行。当将儿去慎莫留后。婆罗门妇与儿食已。便至比舍借碓舂谷。是时小儿有酥酪香。时有毒蛇乘香来至。张口吐毒欲杀小儿。那俱罗虫便作是念。我父出行母亦不在。云何毒蛇欲杀我弟。如所说

  毒蛇那俱罗　　飞乌及兔枭
  沙门婆罗门　　系母及前子
  常共相憎嫉　　怀毒欲相害

时那俱罗便杀毒蛇。段为七分。复作是念。我今杀蛇令弟得活。父母知者必当赏我。以血涂口当门而住。欲令父母见之欢喜。时婆罗门始从外来。遥见其妇在于舍外。便嗔恚言我教行时。当将儿去何以独行。父欲入门。见那俱罗口中有血。便作是念。我夫妇不在。是那俱罗于后将无杀食我儿。嗔恚而言徒养此虫为其所害。即前以杖打杀那俱罗。既入门内自见其儿。坐于庭中[口*束]指而戏。又见毒蛇七分在地。见是事已即大忧悔。时婆罗门深自苦责。是那俱罗善有人情救我子命。我不善观察卒便杀之。可痛可怜。即便迷闷躄地。时空中有天。即说偈言

  宜审谛观察　　勿行卒威怒
  善友恩爱离　　枉害伤良善
  喻如婆罗门　　杀彼那俱罗

佛告诸比丘。尔时婆罗门者岂异人乎。即瓶沙王是。彼于昔时。以曾轻躁作事寻悔今复如是。佛告诸比丘。依止王舍城比丘皆悉令集。乃至已闻者当重闻。若比丘于聚落空地。不与取随盗物。王或捉或杀或缚或摈出言。咄男子汝贼耶汝痴耶。比丘如是不与取者。波罗夷不应共住(第二戒缘竟)

比丘者。比丘名受具足善受具足。一白三羯磨无遮法和合十众。十众已上年满二十。此名比丘。聚落者。聚落名若都墙围绕。若水渠沟堑篱栅围绕。又复聚落者。放牧聚落。伎儿聚落。营车聚落。牛眠聚落。四家及一积薪亦名聚落。空地者。空地名垣墙院外。除聚落界余者尽名空地。聚落界者。去篱不远。多人所行踪迹到处。是名聚落界。如是水渠沟堑篱栅外。除聚落界余者尽名空地。放牧聚落者。最边巷舍外。除聚落界余者尽名空地。伎儿聚落者。最边车外。除聚落界余者尽名空地。营车聚落者。最边车外。除聚落界余者尽名空地。牛眠聚落者。最边家外。除聚落界余者尽名空地。四家及一积薪聚落者。最边家外。除聚落界余者尽名空地。不与者。若男若女若黄门二形在家出家。无有与者盗心取。随盗物者。物有八种。一者时药。二者夜分药。三者七日药。四者尽寿药。五者随物。六者重物。七者不净物。八者净不净物。是名为八。取者。取名捉物移离本处。是名为取。随其所盗者。不如十六督监。盗取王家一枚小钱。买瓜食之为王所杀。王无定法自随其意。或小盗便杀。或盗多不死。当如世尊问瓶沙王法。大王治国。盗齐几钱至死。几钱驱出几钱刑罚。瓶沙王答佛。十九钱为一罽利沙槃。一罽利沙槃分为四分。若取一分若取一分直。罪应至死。今随所盗义以此为准。王者。王名刹利婆罗门长者居士受职为王。王捉者。王使人执或捉其手及余身分。是名捉。杀者。夺其命是名为杀。缚者。或以屋缚。或以城缚。或以材缚。或着锁绊。或着杻械。是名为缚。摈出者。驱出聚落驱出城驱出国。是名摈出。咄男子。汝贼汝痴汝愚痴者。呵责之辞。比丘如是者。犯波罗夷不应共住。波罗夷者。谓于法智退没堕落无道果分。是名波罗夷。如是乃至尽智无生智。于彼诸智退没堕落无道果分。是名波罗夷。又复波罗夷者。于涅槃退没堕落无证果分。是名波罗夷。又复波罗夷者。离于不盗法退没堕落。是名波罗夷。又复波罗夷者。所可犯罪不可发露悔过故。名波罗夷。时药者。一切根一切谷一切肉。根者。治毒草根藕根[竺-二+兒]楼根芋根萝葡根葱根。是名根。谷者。有十七种。一稻二赤稻。三小麦四[麩-夫+廣]麦。五小豆六胡豆。七大豆八豌豆。九粟十黍。十一麻子十二姜句。十三阇致。十四波萨陀。十五莠子。十六脂那句。十七俱陀婆。是名十七种谷。肉者。水陆虫肉。云何水虫。水虫者。鱼龟提弥只罗修罗修修罗修修磨罗。如是等水中诸虫可食者。是名水虫。云何陆虫。陆虫者。两足四足无足多足。如是等名陆虫。如是根食谷食肉食。皆名时食。何以故。时得食。非时不得食。是名时食。若比丘盗心触时药。犯越比尼罪。动彼物得偷兰罪。离本处满者波罗夷。夜分药者。十四种浆。一庵罗浆。二拘梨浆。三安石榴浆。四巅哆梨浆。五蒲桃浆。六波楼沙浆。七揵揵浆。八芭蕉浆。九罽伽提浆。十劫颇罗浆。十一婆笼渠浆。十二甘蔗浆。十三呵梨陀浆。十四呿波梨浆。此诸浆。初夜受初夜饮。中夜受中夜饮。后夜受后夜饮。食前受至初夜饮。是故名夜分药。若比丘盗心触夜分药。犯越比尼罪。动彼物偷兰遮罪。离本处满者波罗夷。七日药者。酥油蜜石蜜脂生酥。酥者。牛水牛酥羖羊羺羊酥骆驼酥。油者。胡麻油芜菁油。黄蓝油阿陀斯油。菎麻油。比楼油。比周缦陀油迦兰遮油。差罗油阿提目多油。缦头油大麻油。及余种种油。是名为油。蜜者。军荼蜜布底蜜黄蜂蜜黑蜂蜜。是名为蜜。石蜜者。槃拖蜜那罗蜜缦阇蜜摩诃毗梨蜜是名石蜜。脂者。鱼脂熊脂罴脂修修罗脂猪脂。此诸脂无骨无肉无血无臭香无食气。顿受听七日病比丘食。是名脂。生酥者。牛羊等诸生酥。净漉洗无食气。顿受听七日病比丘食。此诸药清净无食气。一时顿受得七日服。故名七日药。若比丘盗心触七日药。越比尼罪。动彼物偷兰罪。离本处满者波罗夷。尽寿药者。呵梨勒毗醯勒阿摩勒。荜茇胡椒姜。长寿果仙人果。乳果豆色果。波罗悉多果槃那果。小五根大五根一切盐。除八种灰余一切灰。除石蜜滓地余一切地。此诸药无食气。顿受病比丘终身服。是名终身药。若比丘盗心触终身药。越比尼罪。动彼物偷兰罪。离本处满者波罗夷。随物者。三衣尼师檀覆疮衣雨浴衣。钵大揵镃小揵镃钵囊。络囊漉水囊二种腰带。刀子铜匙钵支针筒。军持澡罐盛油支瓶。锡杖革屣伞盖扇。及余种种所应畜物。是名随物。复有俗人随物。军器刀杖衣服。及余种种白衣所畜众物。亦名随物。若比丘盗心触随物。得越比尼罪。动彼物偷兰罪。离本处满者波罗夷。重物者。床卧具及余重物。床卧具者。卧床坐床小褥大褥拘[疊*毛]枕。及余重物者。一切铜器一切木器竹器一切瓦器。铜器名者。铜瓶铜釜铜镬铜杓。及余种种铜器。是名铜器。木器竹器者。木臼木瓶木盆木碗木杓。竹筐竹席乃至竹筥。及余种种一切木器竹器。是名竹器木器。瓦器者。从大瓮乃至灯盏。是名瓦器。床卧具及种种余物。是名重物。若比丘盗心触此重物等。得越比尼罪。动彼物偷兰罪。离本处满者波罗夷。不净物者。钱金银。比丘不得触故名不净物。若比丘盗心触不净物。得越比尼罪。若动彼物偷兰罪。若离本处满者波罗夷。净不净物者。真珠琉璃珂贝珊瑚颇梨车磲马瑙璧玉。是诸宝物得触不得着故。名净不净物。若比丘盗心触此净不净物。得越比尼罪。若动彼物偷兰罪。若离本处满者波罗夷。复有十六种物。地地中物。水水中物。船船中物。乘乘中物。四足四足上物。两足两足上物。无足无足上物。虚空虚空中物。云何地。金矿银矿赤铜矿铅锡矿白镴矿。空青雌黄石胆盐石灰赤土白墡。乃至瓦师取土地。是名地。若比丘盗心触此诸地者。得越比尼罪。若动彼物偷兰罪。若离本处满者波罗夷。地中物者。若人藏物着地中。所谓钱金银颇梨珂贝真珠车磲马瑙。酥瓶油瓶石蜜瓶。根茎枝叶果等诸药。乃至八种物藏着地中。是名地中物。若比丘盗心触此地中物者。得越比尼罪。若动彼物偷兰罪。若离本处满者波罗夷。水者。水有十种。河水池水。井水龙渊水。清水温泉水。不病水雨涝水。空中水长流水。有处水贵有处水贱。或一钱得四五瓶。或一切所有物得一瓶。如近村城邑而有好水。一钱得五六瓶。有估客远行路由旷远。或五由旬或十乃至五百由旬。道路无水。彼诸估客皆各负水去。或有自供或有卖者。时有一估客水少不足。为热渴所逼。便作是念。若我存者自能得钱。若我渴死钱复何用。尽以钱物买一瓶水。时有比丘随估客行。估客常供给比丘水。未至所在水便欲尽。时估客语比丘言。道路犹远水复欲尽。尔许水以供尊者。尔许水我自当饮。如估客所施。比丘应当如其量饮若盗心多饮。满者波罗夷。不满者偷兰罪。估客复言。今供给尊者水饮。愿莫与他。时有老病人。为热渴所逼。来从比丘乞水饮。比丘慈心给彼病者。作是思惟。主人虽作是言彼病可愍。我今以水施之。主人故当不见怪责。以同意故不犯。有人乘船载水。比丘为渴所逼。盗心触彼船上水者。得越比尼罪。若以钵若揵镃盛彼水。未离船者偷兰罪。若持水去身衣尽离船。满者波罗夷。穿彼水器得越比尼罪。若以筒就穿孔饮水。满者波罗夷。若稍稍饮数数止者。口口偷兰罪。若水器先有塞孔。以盗心拔塞。得越比尼罪。水注器中得偷兰罪。若水注断满者波罗夷。若水连注未断。即起悔心畏犯重罪。还以水倒本器中者偷兰罪。若欲合船盗者。顺牵船尾过船头处波罗夷。若倒牵船者。船头过船尾处。若右边傍牵左过右者。波罗夷。若左边傍牵亦如是。若小船易动。比丘盗心触者。得越比尼罪。若动彼小船偷兰罪。若离本处满者波罗夷。若人有溉灌渠流水。或一宿直一钱。乃至二三四五钱。若比丘若为佛法僧自为有盗心坏彼渠者。得越比尼罪。水流入田偷兰罪。满者波罗夷。若比丘不欲直坏渠。方便假牵塼木令水决出。牵时得越比尼罪。水流入田偷兰罪。满者波罗夷。若作方便驱牛羊骆驼坏渠者亦如是。若比丘嫉妒心坏渠弃水者。得越比尼罪。若比丘共估客行旷野中。有人言明后日当至水。时有估客大担水行。比丘甚渴乞水不得。便嗔恚言。弊恶人汝何乃悭贪。多持水行亦不能自饮。亦不与畜生。亦不与沙门婆罗门。不久当弃。何用水为。比丘便坏彼水器。以恶心故得越比尼罪。若人家中以器储水。若比丘亲里知识被烧。比丘以盗心取水救火。若触得越比尼罪。动彼水器得偷兰罪。以水浇火满者波罗夷。若忆念言当还水。若与直取用。不犯。若彼家被烧。即以彼水助浇火者。不犯。若时世遭旱十年二十年。有人守护池水若井水。比丘以盗心持器取水。触彼水者越比尼罪。盛水时偷兰罪。若担水离池。满者波罗夷。若池有院闭门。比丘以盗心持筒遥饮水。水连续不断。满者波罗夷。口口饮息者。口口偷兰罪。若井水比丘以盗心下罐时。得越比尼罪。若水入器时得偷兰罪。持水离井。满者波罗夷。有诸外道家以器储水。其家被烧外道荒惧。比丘尔时便作是念。如是如是子恶邪外道。常妒佛法毁呰沙门释子。今当中汝。便前以杖打水器破。以恶心坏他物故。得越比尼罪。有诸名水。所谓瞻波国有恒水。王舍城有温泉水。巴连弗邑有恕奴河水。波罗奈国有佛游行池水。沙只国有玄注水。舍卫城有蒲多梨水。摩偷罗国有摇蒲那水。僧伽舍国有石蜜水。有诸贵人。遣使取此诸水在道止息。有比丘为渴所逼。以盗心触彼水者。得越比尼罪。水入器中偷兰罪。若水注断满者波罗夷。若水注未断。中起悔心畏犯重罪。以水还倒本器者。得偷兰罪。有诸贵人。游戏园中作香池水。有比丘以盗心取彼水。而水不直钱。计其香价随时犯罪。是谓水。水中物者。有物在水中生。所谓优钵罗钵昙摩拘物头分陀利须健提藕根等。及余种种水生物。若比丘以盗心触此诸水中生物者。得越比尼罪。若动彼物得偷兰罪。若离本处满者波罗夷。若一花直满者波罗夷。不满者一一偷兰罪。但取花着地。未波罗夷。花束大重不能胜曳去虽远。未波罗夷。举离地波罗夷。乃至一切水生物亦复如是。若诸贵人于游戏浴池中。作金银花及诸戏船凫雁鸳鸯异类之鸟。若比丘以盗心触彼物时。得越比尼罪。若动彼物得偷兰罪。若离本处满者波罗夷。若复持金银琉璃车渠。马瑙珊瑚琥珀珂贝赤宝及余八种。若人持此众物。藏着水中。比丘以盗心。触彼物者。得越比尼罪。若动彼物偷兰罪。若离本处满者波罗夷。是名水中物。船物者。毗俱罗船俱呵吒船。拔瞿梨船毗尸伽船。马面船象面船。鱼面船羊面船。或一重乃至七重。或有壁或无壁者。若载象船载马船。载财物船载瓦器船。载皮船载铁器船乃至[竺-二+稗]筏。若是船筏系着一处。若比丘盗心触彼船。得越比尼罪。若动彼船偷兰罪。离本处波罗夷。虽复断绳船。未离本处者偷兰罪。虽复离处未断绳者。亦偷兰罪。若断绳离本处者波罗夷。若本欲盗船不盗物。畏人觉故合物乘去。虽离本处未波罗夷。若舍物已船离本处波罗夷。若本欲盗物不盗船。畏人觉故合船乘去。未波罗夷。舍船已持物去者波罗夷。若欲船物合盗者。船离本处波罗夷。若欲水底持去者。没时波罗夷。若有人系船岸边于屏处坐。有比丘欲盗船。时有余人语船主言。有出家人欲盗汝船。时船主问言。何道出家。答言。沙门释子。船主言无苦。沙门释子不与不取。是时比丘身以触船时。异人复语船主言。是比丘已取汝船。船主便疑。是比丘将无欲盗我船耶。即起问言。尊者欲作何等。时比丘默然不应。便以篙擿船而去。船主追唤言尊者莫乘船去是船是王若大臣若婆罗门长者居士许。是作福船是渡人船。又复恐怖比丘言。弊恶人汝若乘我船去者。我后当苦治汝。是比丘虽乘船去远。而船主不作失想。比丘亦不作得想。未波罗夷。船主若作失想。比丘作得想者。波罗夷。若船主系船着岸边。有客比丘来语船主言。长寿。借我船渡。船主答言。我独一人那得相渡。比丘复言。长寿。我食时欲至莫令我失食。汝今渡我者。便为与我食便为施我乐。我今与汝今世后世更互相渡。船主复言。汝亦无雇直。云何而欲虚渡。汝脚如饿乌东西不住。谁当渡汝。比丘又复卑辞苦求。船主复言。自可度。尊者今正一人何办相渡。比丘答言。长寿。汝但捉柁我自作力。船主即许便唤大德上船。彼至河中。比丘捉杖便打彼船主骂言。弊恶人敢毁辱沙门释子。骂讫伤打船主手臂脚。腨伤破劳熟。已便排着水中。得偷兰罪。船主若死。比丘先有杀心者波罗夷。若先无杀心偷兰罪。尔时比丘若盗彼船。若盗行具满者波罗夷。不满偷兰罪。若比丘恶心沈彼船。若破彼船。若放随流去。以坏失他物故。得越比尼罪。有人为福故。常以船渡人。比丘若渡。应系着岸边令后人得渡。若比丘盗彼船。若行具满者波罗夷。若没着水中。若破若放令随流去。得越比尼罪。比丘若乘筏渡至彼岸。当牵筏着岸上现处令后人得渡莫着屏猥处。是名船物船上物者。船上所有诸物谓金银真珠钱财虎珀琉璃珂具珊瑚车磲赤宝缕劫贝。乃至一切衣服谷食及八种物。若覆藏若不覆藏。比丘以盗心触彼船上诸物。得越比尼罪。若动彼物者偷兰罪。若离本处满者波罗夷。乘者。若车乘若舆若辇若步挽车乃至小儿戏车。是名为乘。若盗两轮车顺牵后过前。满者波罗夷。若逆推前过。后满者波罗夷。若傍牵左轮过右轮。右轮过左轮。满者波罗夷。若比丘坏彼乘稍稍取若盗一一木。满者波罗夷。不满者偷兰罪。若小乘可全檐去者。若触得越比尼罪。动彼乘偷兰罪。若离本处满者波罗夷。是名乘物。乘上物者。若师子皮覆虎皮覆黄钦婆罗覆。及诸种种覆物。一切敷具一切庄严乘物。乘上一切物者。所谓金银琉璃车磲马瑙真珠珂贝珊瑚琥珀及赤宝等。衣被饮食及八种物。若覆藏若不覆藏。比丘以盗心触彼物者。越比尼罪。若动彼物偷兰罪。若离本处满者波罗夷。是名乘上物。四足物者。所谓象马驼牛驴骡羊乃至鼠狼。若比丘欲盗象。若牵若驱举一足乃至三脚。偷兰罪。四足离本处满者波罗夷。如是马驼乃至羊亦如是。若小可全担者。若触得越比尼罪。若动者偷兰罪。若离本处满者波罗夷。是名四足物。四足上物者。庄严象具乃至庄严鼠狼具及八种物。若覆藏若不覆藏。若比丘以盗心触此诸物。越比尼罪。若动彼物得偷兰罪。若离本处满者波罗夷。是名四足上物。两足物者。所谓人及鸟等。若比丘盗彼人。及诱去若刀杖驱。举一足偷兰罪。举两足波罗夷。若小可担负者。若触越比尼罪。若动偷兰罪。若离本处满者波罗夷。乃至鸟亦如是。是为两足物。两足上物者。所谓女人庄严具。男子庄严具。乃至鹦鹉鸟庄严具。女人庄严具者。钗钏衣服等。男子庄严具者。衣冠璎珞等。乃至鹦鹉鸟庄严具者。种种珠铃等系其颈脚。及余八种物。若覆藏若不覆藏。比丘以盗心触彼两足上物者。得越比尼罪。若动彼物偷兰罪。若离本处满者波罗夷。是名两足上物。无足物者所谓蛇蟒食花食果食肉吸气等。蛇若着瓶中若着箧中。有一比丘。本是弄蛇师后出家。此比丘欲盗彼蛇。即欲取蛇。恐其主觉。举箧持去。未波罗夷。若出蛇离箧。满者波罗夷。若本欲盗箧不盗蛇。畏主觉故合蛇持去。未波罗夷。若弃蛇持箧去。满者波罗夷。若欲蛇箧合盗者。担去离本处满者波罗夷。若盗瓶中蛇。蛇尾未离瓶口者。未波罗夷。若头尾都离满者波罗夷。若嗔嫌彼便骂言。恶人何以笼系众生。即开瓶令蛇得出者。得越比尼罪。比丘盗心触无足物者。越比尼罪。若动彼物偷兰罪。若离本处满者波罗夷。是名无足物。无足上物者。所谓金银真珠车磲琥珀珊瑚珂贝琉璃赤宝。乃至八种物。若覆藏若不覆藏。人畏是无足物故无敢取者。比丘以盗心触此无足上物者。得越比尼罪。若动彼物偷兰罪。若离本处满者波罗夷。是名无足上物。虚空物者。所谓庵罗树薝卜树。阎浮树椰子树。只波罗树龙花树吉祥果树乃至一切诸花果树。若比丘。以盗心盗此诸树。若一树满者波罗夷。不满者随其拔树栽偷兰罪。若拔树栽积在一处。未波罗夷。举离地满者波罗夷。若重不能胜。曳去不离地。虽远未波罗夷。若举离地波罗夷。若比丘盗心触此虚空物。得越比尼罪。若动偷兰罪。若离本处满者波罗夷。是名虚空物。虚空中物者。所谓庵罗果乃至吉祥果。若比丘盗心食此诸果。若食一果满者波罗夷。若不满者口口偷兰罪。比丘动树落果在地。未波罗夷。若取果持去满者波罗夷。二人偷果。一人上树落果一人在下拾果。未波罗夷。若树上人下树。持果去满者波罗夷。取一切诸果亦如是。若佛生处。若得道处。转法轮处。尊者阿难大会处。罗睺罗大会处。般阇于瑟大会处。是诸处皆种行树。树上各各以众宝庄严其树。及八种物。若覆藏若不覆藏。若比丘以盗心触彼众宝者。得越比尼罪。动彼物偷兰罪。若离本处满者波罗夷。是名虚空中物。是谓十六种物。若比丘以盗心触彼物。越比尼罪。若动彼物偷兰罪。若离本处满者波罗夷

复有十三种分齐物。何等十三。一物分齐。二处分齐。三不定分齐。四垣墙分齐。五笼分齐。六寄分齐。七杂分齐。八幡分齐。九相因分齐。十杙分齐。十一园分齐。十二贼分齐。十三税分齐。物分齐者物有八种。何等八。一时药。二夜分药。三七日药。四终身药。五随物。六重物。七不净物。八净不净物。是名物分齐。若比丘以盗心触此诸物。得越比尼罪。若动彼物偷兰罪。若离本处满者波罗夷。处分齐者。地地中物。水水中物。船船中物。乘乘中物。四足四足上物。两足两足上物。无足无足上物。空空中物。是名处分齐。若比丘盗心触此诸物。得越比尼罪。若动彼物偷兰罪。若离本处满者波罗夷。不定分齐者。如所说知而妄语波夜提。非知而妄语皆波夜提。或知而妄语波罗夷。或知而妄语僧伽婆尸沙。或知而妄语偷兰罪。或知而妄语越比尼罪。或知而妄语波夜提。知而妄语波罗夷者。若比丘不实得过人法。自言我得阿罗汉。是知而妄语。非波夜提是波罗夷。知而妄语僧伽婆尸沙者。若比丘以无根波罗夷罪。谤清净比丘。是知而妄语。非波夜提是僧伽婆尸沙。知而妄语偷兰罪者。比丘说言。我阿罗汉。是知而妄语。非波夜提是偷兰罪。知而妄语越比尼罪者。比丘自作是言。谓我是阿罗汉耶。是知而妄语。非波夜提是越比尼罪。知而妄语波夜提者除上尔所事。余一切妄语者。此是知而妄语波夜提。又复有伤杀草木波罗夷。有伤杀草木偷兰罪。有伤杀草木。波夜提。有伤杀草木波罗夷者。如树木花果有主守护。比丘盗心取伤杀草木。非波夜提满者是波罗夷。伤杀草木偷兰罪者。若树木花果有主守护。比丘盗心取。若不满者非波夜提是偷兰罪。伤杀草木波夜提者。伤杀一切草木波夜提。又复非一切非时食波夜提。有非时食波罗夷。有非时食偷兰罪。有非时食波夜提。非时食波罗夷者。若比丘盗心取他食非时啖。满者非波夜提是波罗夷。非时食偷兰罪者。若比丘盗心取他食非时啖。不满者非波夜提是偷兰罪。非时食波夜提者。若比丘以理得食非时啖。波夜提。又复饮酒非一切波夜提。有饮酒波罗夷。有饮酒偷兰罪。有饮酒波夜提。饮酒波罗夷者。若比丘盗心取他酒饮。满者波罗夷。饮酒偷兰罪者。若比丘盗心取他酒饮。不满偷兰罪。饮酒波夜提者。若比丘以理得酒饮者。波夜提。若比丘于不定分齐物。若盗心触。得越比尼罪。若动彼物偷兰罪。若离本处。满者波罗夷。是名不定分齐。垣墙分齐者。象厩马厩驼厩驴牛羊栏。芦卜园菜园瓜园甘蔗园。若比丘盗心取彼象。象举一足乃至四足度厩门。身分未离门者偷兰罪。身分离门波罗夷。乃至驴亦如是。若比丘盗心取他羊。驱羊惊走嗔羊打杀者波夜提。若比丘割肉掷篱外。未波罗夷。比丘出篱外担肉离地。满者波罗夷。若就栏中食肉。满者波罗夷。若比丘二人盗羊。一人篱外一人篱内。割肉掷栏外。未波罗夷。彼出已举肉离地。满者波罗夷。若比丘盗心取芦卜根。若拔一根。满者波罗夷。若不满者。拔时根根偷兰罪。若拔积大聚。未波罗夷。持举离园。波罗夷。若拔束大重不能胜曳去。虽远未波罗夷。若离地满者波罗夷。一切菜乃至瓜亦如是。若比丘盗心取他甘蔗时食一甘蔗。满者波罗夷。若不满者根根偷兰罪。若截着篱外时。未波罗夷。是波夜提。若出园持去。满者波罗夷。若比丘以盗心作巧诈。以甘蔗系脚曳去。虽远未波罗夷。若离地满者波罗夷。若比丘一人园外一人园内。掷甘蔗园外。未波罗夷。若彼出已举离地。满者波罗夷。若比丘持甘蔗去时。茎叶触园未离者。未波罗夷。离已波罗夷。若比丘盗心触此诸物。得越比尼罪。若动彼物偷兰罪。若离本处。满者波罗夷。笼分齐者。所谓鹦鹉等种种鸟。师子等种种兽。若比丘盗心取彼诸鸟时。若欲盗鸟不盗笼。畏人觉故合笼持去者。未波罗夷。若舍笼持鸟去。满者波罗夷。若欲盗笼不盗鸟。畏人觉故合鸟持去未波罗夷。若出鸟持笼去。满者波罗夷。若笼鸟合盗者持去离本处。满者波罗夷。若比丘盗心取鸟内手笼中。得越比尼罪。挽一脚出偷兰罪。两脚出翅尾未出笼口。未波罗夷。离已满者波罗夷。若比丘盗心取师子内手栏中。越比尼罪。挽一脚出偷兰罪。乃至四脚出尾未离栏。未波罗夷。离已波罗夷一切兽亦如是。若比丘盗心触彼笼分齐物。得越比尼罪。若动彼物偷兰罪。若离本处。满者波罗夷。寄分齐者。若和上阿阇梨弟子知识。寄物互相饷致。若钵若衣及余诸物。若受寄者作是念。寄者已远。所与者不知。此物我自取。即生盗心取。从地着膝上。从膝着地。从左肩着右肩。乃至从头着肩。一一移。满者波罗夷。若比丘受寄已。或渡河或渡池。或渡涝水或复逢雨。恐衣湿故便出看之。见彼衣好作是念言。彼寄者已远。前人不知。此物我当自取。即生盗心取。从地着膝上。从膝着地。从左肩着右肩。乃至从肩着头。一一移。满者波罗夷。彼受寄比丘随道行。见异比丘从前而来。便问异比丘。长老何处来。答言某处来。问识某比丘不。答言识。复问某比丘平安不。答言已死若泥洹。此诸衣物应属现前僧。若受寄比丘知法多诈。便作是念。我何为与是比丘分。默舍异比丘去。离见闻处便说是言。某甲比丘无常若般涅槃。彼比丘有是衣钵若余杂物。现前僧应分。现前无僧我今应受。受已是比丘诈心故独受。得越比尼罪。受寄比丘乘船欲渡水。有异比丘从彼岸渡来。此比丘问言。汝从何处来。答言从某处来。又问识彼比丘不。答言识。复问某比丘平安不。答言若死若般泥洹。尔时此诸衣物应属现前僧。是比丘知法多诈。乃至诈心羯磨得越比尼罪。若受寄比丘乘船渡水在于中流。有异比丘从彼来渡。中流相遇。此比丘问言。长老从何处来。乃至诈心羯磨得越比尼罪。若受寄比丘到彼岸下船。有异比丘从彼始欲上船。乃至诈心羯磨得越比尼罪。受寄比丘上岸去。有异比丘从彼道来。问言。长老何处来。答言某处来。乃至诈心羯磨得越比尼罪。是比丘若思惟。当前看多有同名者竟。知云何须至彼处。至彼处已复问彼比丘平安不。即答言。若死若般泥洹。尔时衣物应属现前僧。是比丘知法多诈。便作是念。是衣何为与多人共分。密唤知识比丘出界外作是言。某甲比丘无常若般泥洹。所有衣钵及众杂物。应现前僧分。我今现前我等应受。受已诈心羯磨故。得越比尼罪。比丘若作是念。此衣钵本不语我与塔与僧。所与者已死已般泥洹。持是物还本比丘者无罪。是名寄分齐。若比丘盗心触此寄分齐物。得越比尼罪。乃至离本处。满者波罗夷。杂物分齐者。如放牧人放杂种种畜生。所谓若象若马若牛若驼若驴若羊等。象者象有多种。若良善好色健走者。若比丘盗心取象。骑已摄钩牵向一方。若欲向东方象狂趣南西北方。未波罗夷。若盗心取象欲向南方。若象狂趣西北东方。未波罗夷。西北方亦如是。若欲盗象向东。象即向东者波罗夷。南西北方亦如是。若先无定方随处而去。象举四足则波罗夷。马者马有多种。有良善好色健走者。若比丘盗心欲取此马。乘马已欲向东方。马狂趣南西北方。未波罗夷。如是南西北方亦如是。马随方去如上说。若无定方随处而去者。马举四足波罗夷。若比丘盗良马乘走。而马主觉即乘马逐。其主不作失想。比丘不作得想。未波罗夷。若马主作失想。比丘不作得想。未波罗夷。若马主作失想。比丘作得想。波罗夷。若比丘盗心。若以盐若以草。诱他马将去。离见闻处波罗夷。牛者牛有多种。有良善软毛好色健走者。若比丘以盗心持杖驱牛向东方。犯不犯如象中说。乃至若牛主觉已追逐。其主不作失想。比丘不作得想。未波罗夷。若牛主作失想。比丘作得想者。波罗夷。若盗心以盐以草。诱他牛将去。若长绳牵去离见闻处。波罗夷。如牛余驼驴羊亦如是。是为杂分齐。若比丘盗心触此杂分齐者。得越比尼罪。乃至离本处。满者波罗夷。幡分齐者。若佛生处。得道处。转法轮处。阿难大会处。罗睺罗大会处。般遮于瑟大会处。是诸大会处种种庄严。悬缯幡盖及众宝铃。若比丘盗心取幡解绳一头。未波罗夷。解两头已。满者波罗夷。若比丘盗心诈分布诸幡。处处间取。未波罗夷。取已持去。满者波罗夷。若比丘盗花鬘解一头。未波罗夷。解两头竟。满者波罗夷。若二比丘闇处盗幡俱不相知。各从一头解绳收摄。共合中间相问汝是谁。怖畏舍幡而走。得偷兰罪。此二比丘互相问时。各言偷幡便共盗取。满者波罗夷。若众多色幡共一绳大重。各解一头堕地。担不能胜从地曳去。虽远未波罗夷。举离地时。俱波罗夷。若此比丘作是念。此庄严塔物。取者大罪。我唯须一色物。即取一色物。满者波罗夷。若言我须半色。取半色不满偷兰罪。满者波罗夷。若二比丘闇处盗幡俱不相知。各从一头解绳收摄。共合中间相问汝是谁。怖畏舍幡而走。得偷兰罪。有比丘晨朝绕塔。见此幡在塔下。便盗心持去。满者是比丘波罗夷。有人供养菩提树七宝庄严。金银珠镊种种幡花。金绳连绵金锁悬铃。博山金光以用供养。若比丘盗心取彼诸物。满者波罗夷。又复诸外道塔亦种种缯彩供养。比丘盗心取。满者波罗夷。若风吹落地。知是塔上供养具者不应取。若风吹远处尘垢黑污。作粪扫想取者无罪。若天寺中有杂衣物。比丘盗心取。满者波罗夷。若风吹远处尘垢黑污。粪扫想取者无罪。是名幡分齐。若比丘盗心触此幡分齐物。得越比尼罪。若动彼物偷兰罪。若离本处。满者波罗夷。相因分齐者。若长者家。有不收敛物在异处。所谓衣服璎珞等。是时比丘将沙弥入长者家。时此比丘盗心取长者衣物。内着囊中令沙弥担去时。得越比尼罪。沙弥持去出家界时偷兰罪。作得想满者波罗夷。时主人觉语比丘言。长老作何等。答言长寿。我为自动手耳。作是语时得越比尼罪。使俗人持去亦如上说。如因长毛羊中持物去亦如是。若比丘入长者家。犊子见比丘衣色。谓是其母来趣比丘。比丘应驱还。若以盐若以草诱彼犊子。得越比尼罪。将未出界得偷兰罪。出界已波罗夷。若比丘食时盗心取比坐揵镃。着自钵中令弟子持去。得越比尼罪。弟子出界偷兰罪。若作得想波罗夷。若彼比丘觉已即语长老。作何等。答言。我戏弄耳。作是语得越比尼罪。若比丘共估客共行。复有估客从彼而来。中道相遇共宿一处。比丘夜中起盗心。捉他车系着他车。捉他男系着他男。捉他女系着他女。捉他小儿系着他小儿。欲令各各相牵而去。作是方便得越比尼罪。出住处界得偷兰罪。作得想波罗夷。是名相因分齐物。若比丘盗心触此相因分齐物。得越比尼罪。若动彼物得偷兰罪。若离本处满者波罗夷。杙分齐者。若佛生处。得道处。转法轮处。阿难大会处。罗睺罗大会处。般遮于瑟大会处。是诸精舍内庄严校饰。处处椓杙悬杂幡盖。种种众宝悬于杙上。若比丘盗心取此杙上诸宝。以手举宝。宝虽举绳未离杙。未波罗夷。离杙已波罗夷。若绳坚劲。举宝时绳离杙者。波罗夷。合杙盗。手触时得越比尼罪。若动彼杙者偷兰罪。若离本处满者波罗夷。若杙上悬酥瓶油瓶蜜瓶若钵缕丸。若比丘盗心取此酥瓶者。以手举时。若绳软杙直。虽举未波罗夷。一切离杙波罗夷。若绳坚劲杙曲。虽举未波罗夷。一切离杙下已。满者波罗夷。若绳软杙曲。虽举未波罗夷。一切离杙下已。满者波罗夷。若绳坚劲而杙复直。举则波罗夷。若穿瓶者犯越比尼罪。若以器承入器者。偷兰罪。流注断满者波罗夷。流注未断便悔畏犯重罪。还倒本器中者得偷兰罪。油瓶蜜瓶亦如是。若比丘欲盗钵者。以手举时。绳软杙直。虽举未波罗夷。钵离杙下已波罗夷。若绳坚劲而杙曲。虽举未波罗夷。离杙已波罗夷。绳软杙曲者。举持未波罗夷。离杙下已波罗夷。若绳坚劲杙直。举则波罗夷。若盗缕丸时。缕丸绳杙如上说。又复盗丸时若作是念。我须少许缕。就杙上缠取缕。不断者未波罗夷。若缕断满者波罗夷。此比丘缠缕时。缕未断寻悔畏犯重罪。还着本处者偷兰罪。是名杙分齐。若比丘盗心触此杙分齐物者。得越比尼罪。若动彼物得偷兰罪。若离本处满者波罗夷。园分齐者。时有长者。其家大富。有一比丘名俱卢。常入出其家。主人兄弟父母在时共活。父母终没家内不和。弟欲分财其兄不肯。欲共义居弟求分不已。兄不免情即便许之。相与义言。谁能分财。答言阿阇梨俱卢是。父母在时所重供养。家中有无悉知。皆言大善。时弟谄曲即诣俱卢礼拜问讯。问讯已作是言。阿阇梨是我父母所尊兄弟所敬。家中有无皆悉知之。父母平存兄弟共居。今父母终没家内不和。欲共分财故来上启。我分居之后当供养阿阇梨。供养之余当以自活。愿阿阇梨分财之日。好者见与。比丘受彼语者犯越比尼罪。若留好物时偷兰罪。分物决已波罗夷。欲分物时比丘问言。先分何等。主人言先分二足四足。比丘便为先分二足。奴婢之中老病难使不可信者。分作一分。年少无病易使可信者。作一分。分四足时。群牛之中羸老无力。粗弊难用不产少乳。有产难[(殼-一)/牛]。以为一分。少齿肥壮调利易用。种产多乳良善易[(殼-一)/牛]。复作一分。若分房舍。朽故弊者持作一分。若新好者复作一分。楼阁店肆亦复如是。乃至分田。薄[塉-月+目]多秽持作一分。肥好良者复作一分。园中不如少花果者持作一分。园林花果茂盛胜者以为一分。复欲分谷米金银钱财。尔时彼兄语比丘言。阿阇梨是我父母所敬兄弟所重。云何分财乃如是耶。阿阇梨且还思惟。佛语若比丘作如是心分他财者。主虽不听得越比尼罪。俱卢还已。彼兄弟寻更论议。复应有谁是父母所重者。耆旧大德知家有无。屈令分财。若不速分恐王闻者或能税夺。寻思大德无过。俱卢宜当更请令分此财。兄弟义合。即诣俱卢礼拜问讯。在一面坐白俱卢言。阿阇梨父母所重。家中有无阿阇梨所知。今当为我分此财物。彼时俱卢恨其前时不受分处。告言。汝兄弟薄义多疑少信。谁当堪忍为汝分财。彼兄弟言。前实仓卒有愧阿阇梨。阿阇梨是由来家中多少是所谙。悉今愿见为分此钱财。王脱知者或能税夺。是故欲速分之。比丘答言。汝等必欲令我分耶。答言。实尔阿阇梨。彼比丘言。若必尔者当作言要。分物之后得分便取无余言者当为汝分。彼各答言。随教不敢复违。是比丘受彼请已应作等分。彼分田时牵绳量地。若偏心量地觉一麦者。是比丘得波罗夷。以地无价故。是名园分齐。若比丘盗心触此园分齐物。得越比尼罪。乃至满者波罗夷。贼分齐者。有比丘在道行为贼所劫。贼少比丘多。时诸比丘自相谓言。今此贼少我等人多。当共合力还取本物。即便相与共捉塼石追逐彼贼。并遥骂言。弊恶罪贼。我等自可剃除须发。汝复谓我剃去手脚。时贼恐怖便放衣钵各自散走。彼比丘若未作失想者。还取本物无罪。已作失想而还取者。便为贼复劫贼。满者波罗夷。有比丘在道行为贼所劫。诸比丘失衣钵已入林中藏。时贼思惟我伴党多。而此物少宁可相与。更求少物即藏衣钵覆着一处。而复于道更劫余人。尔时比丘见彼藏物。伺贼去后便取衣钵。是比丘若先不作失想。还取本物者无罪。若作失想不应取。若取者便为贼复劫贼。满者波罗夷。又比丘在道行为贼所劫。时贼劫诸比丘衣钵顺道而去。时诸比丘随后遥望看彼群贼所至何处。追之不止渐近聚落。贼便分物。比丘便语贼言。长寿。我出家人仰他活命。汝等可乞我衣钵。汝复何用此衣钵为。若比丘如是得者无罪。若贼骂言。弊恶沙门。我已乞汝命。何敢复来欲得衣钵。比丘念言。是贼已近聚落必不害我。当恐怖之。即语贼言。汝等谓我无所恃耶。我当白王及诸大臣知汝为贼。若恐怖得者无罪。贼复嗔言。终不与汝欲去任意。若比丘告聚落主。捉得诸贼若缚若杀。不应告。若语聚落主方便慰喻。得衣钵者无罪。有比丘多有衣钵大畜弟子。彼诸弟子不修戒行。作是念言。可往和上阿阇梨房中盗诸衣钵。自己衣钵亦师房中。便共作要。汝得衣物者与我共分。若我得者亦共汝分。便入房中。就衣架上。捉和上阿阇梨衣徙就己衣。不离本架者犯偷兰罪。若举师衣离架。着己衣上者波罗夷。若师衣带衣角。若綖缕未离衣架者。未波罗夷。一切离已波罗夷。彼和上阿阇梨疑是弟子或能偷我衣钵。便自藏衣钵更着余处。其弟子便入闇中误偷自己衣钵。出外不分故。是中半衣边满者波罗夷。有一比丘摩诃罗出家。不善戒行。有比丘语言。长老共作贼来。摩诃罗言。我本在家初不作贼。我今出家云何作贼。彼比丘言。汝不欲作贼者汝但守门。当与汝分。摩诃罗念言。我不作贼与我等分。何以不去。答言可尔。即俱共去。使摩诃罗守门。彼比丘便入。盗心触物时二俱得越比尼罪。若动彼物时二俱得偷兰罪。若离本处满者二俱得波罗夷。若有客比丘来。或在食堂或在禅房止宿。晨朝便去。或忘衣钵及诸物等。时旧比丘摩摩谛安行房舍。欲知客比丘去未。便见衣钵。即生盗心。取已徙着异处覆藏。得波罗夷。更异比丘来复见是衣物。亦生盗心。即取复徙异处覆藏。亦波罗夷。复第三人复生盗心徙覆藏余处。亦波罗夷。随人多少起盗心转徙。一切悉得波罗夷。彼衣物主远去已忆念。还来取得者无罪。有比丘忘衣钵。余比丘见即生盗心。不自手取便语一摩诃罗比丘令取。摩诃罗比丘谓为是其衣钵。便为取之。触时是盗心。比丘得越比尼罪。动时得偷兰罪。离本处满者得波罗夷。摩诃罗不作盗心故。三时都无罪。若先语摩诃罗。取此衣钵当共分之。摩诃罗盗心触时。俱越比尼罪。动时俱偷兰罪。若离本处满者俱波罗夷。若摩诃罗看已作是念。何为与彼分。我当独取。即便持去得波罗夷罪。彼比丘得偷兰罪。若比丘作摩摩帝塔无物。众僧有物。便作是念。天人所以供养众僧者。皆蒙佛恩。供养佛者便为供养众僧。即持僧物修治塔者。此摩摩帝得波罗夷。若塔有物众僧无物。便作是念。供养僧者佛亦在其中。便持塔物供养众僧。摩摩帝用者得波罗夷。若塔无物僧有物者。得如法贷用。但分明疏记言。某时贷用某时得当还。若僧无物塔有物者。得如法贷用亦如是。彼知事人若交代时。应僧中读疏分明付授。若不读疏得越比尼罪。是名贷用。有二比丘共财应分。一比丘盗心独取除自分他分。满者波罗夷。若同意取者无罪。若作是念。我今用后当还偿无罪。有二教化比丘。共作制限言。长老从今已后若我与汝得物。当二人共分。后时一人得好衣段。便作是念。若后更得不必及是。便语伴言。从今日始各任相录。若汝得者汝自取。若我得者我自取。先所得物违制故。是中半满者波罗夷。若此比丘受施咒愿已语施主言。且置汝边我后当取。便还语伴言。长老。自今日始各任相录。若汝得者汝自取。若我得者我自取。作是语时得偷兰罪。若此比丘闻彼欲施衣。便预语伴言。长老。自今日始各任相录。若汝得者汝自取。若我得者我自取。作是语时得越比尼罪。有二粪扫衣比丘。共要。从今日始。若得粪扫衣当共分。时一比丘得好粪扫衣。便作是念。是衣甚好。设后更得不必及是。便语伴言。长老。自今日始各任相录。若汝得者汝自取。若我得者我自取。是比丘违本要故。是中半满者波罗夷。若此比丘得好粪扫衣不取。即以草若塼石覆之。便还解要如上说。是比丘得偷兰罪。若此比丘见好粪扫衣已。不取不覆。便还解要如上说。是比丘得越比尼罪。若比丘知僧物。有应与有不应与。云何应与。若损者若益者应与。云何损者。有贼来诣寺索种种饮食。若不与者或能烧劫寺内。虽不应与畏作损事故。随多少与。云何益者。若治众僧房舍。若泥工木工画工。及料理众僧物事者。应与前食后食。及涂身油非时浆等。若王及诸大势力者。应与饮食。是名益者应与。有比丘失衣钵物。若未作舍想后。知处应从彼索。索者不犯。若已作舍想后。虽知处不应从索。索者得越比尼罪。若先生心言。后若知处者当从索取。如是索取者无罪。有二比丘作制限。当共受经。当共诵经。后不受不诵者得越比尼罪。是名贼分齐物。若比丘盗心触此贼分齐物。得越比尼罪。若动彼物。得偷兰罪。若离本处满者波罗夷。税分齐者。有比丘与估客共道行。比丘有大徒众。时估客便语一比丘言。汝师大德至关税处谁敢检校。汝为我持此物。寄着汝师衣囊中过此税处。是弟子即然许。持其所寄物着师囊中。是弟子得越比尼罪。师不知无罪。若到税处弟子得偷兰罪。师不犯。若过税处已弟子得波罗夷。师不犯。若估客语彼师言。阿阇梨福德之人。徒众共行谁当检校。唯愿为我持此少物。寄着阿阇梨弟子囊中过税处。彼师即便然可。取着弟子囊中时得越比尼罪。弟子不知无罪。若至税处师得偷兰罪。弟子无罪。若过税处师得波罗夷。弟子无罪。若此俱语俱然许者。俱得越比尼罪。若至税处俱得偷兰罪。若过税处俱得波罗夷。若比丘与估客共道行。至聚落边比丘洗手。估客问言。长老欲作何等。答言。我欲乞食去。估客言。阿阇梨莫乞食。我当与食。便与比丘种种美食。食已语比丘言。阿阇梨为我持少物过此税处。比丘言。世尊制戒。不听我持应税物过关逻处。估客念言。官税亦失。与比丘亦失。二俱失者。与比丘可得福德。便语诸比丘可次第住。我欲布施。估客即便次第布施。各满钵宝物既布施已。便先出关外住待诸比丘。诸比丘寻后到。是估客便礼诸比丘足。白言诸尊见识不。比丘答言识知。我向者布施不。答言知。若知者我何以布施。答言。汝欲作福。估客言实尔。但我妻子当须衣食负债当偿。愿见还向物。比丘应语言。弊恶人汝敢欺我。前言作福而今还索。作是语已彼犹故索。比丘还者不犯。若本知不实施。比丘为受过税处。还者波罗夷。若比丘与估客共行。乃至言。佛不听受寄应税物持过关。估客语比丘言。不令比丘持此物出关且为我守。我欲暂见守关者。须臾便还。比丘受寄。估客迳出关外住待比丘。比丘住久此物无所付。便持过关。过关者波罗夷。若比丘与估客共道行。乃至佛不听比丘受寄应税物持过关。估客言。我不令比丘持此物过关。但为我守。我欲暂见守关者。须臾便还。比丘便为守。语言汝若不来我舍汝物去。估客复作是念。比丘虽作是言。终不舍我物去。便出关外住待比丘。比丘住久而彼不还。便舍物过关而去。估客语比丘言。我物在何处。比丘嗔言。汝敢戏弄我耶。我向不言汝须臾不还当舍汝物去耶。汝物故在本处。自可还取。比丘如是者不犯。比丘与估客共为伴行。乃至佛不听比丘受寄应税物持过关。估客语比丘言。我不令比丘持物过关。但为我守。我欲暂见守关者。须臾便还。比丘为守。即语言。汝若不还我持汝物寄着守关人边。估客念言。比丘虽作是语。何有当持我物寄守关人边。便出关外住待比丘。比丘住久而彼不还。即持其物寄守关人语言。有如是状类如是名字估客来者。汝便取其税直。余者还之。比丘出关。估客问言。我物在何处。比丘嗔言。汝敢戏弄我耶。我向不言汝须臾不还我持汝物寄守关人边耶。汝物今在守关人边。自可往取。比丘如是者不犯

比丘精舍近大道边。有比丘在道边经行。估客语比丘言。我有应税物。愿长老为我持入城。比丘答言。世尊不听我持应税物过彼税处。然我今当教汝方便。汝便从我穿墙间去。若篱间去若水渎中去。又可寄着已税者车上。又可寄着王家器中。又可寄着婢水瓶中。又可寄着羺羊毛中去。如是指授令入者得越比尼罪。在内指授出外亦如是。若比丘知物应税。而不知过税物。得波罗夷罪。过此税物。满者波罗夷。比丘知过税物。得波罗夷。而不知是物应税过此物。满者波罗夷。比丘知物应税亦知过税物。得波罗夷。过此物满者波罗夷。比丘不知应税物。亦不知过税物。得波罗夷。而过者不犯。何等物不应税。何等物应税。世尊弟子比丘比丘尼一切外道出家人物。是名不应税。若卖买者应输税。是名税分齐。若比丘盗心触此税分齐物。得越比尼罪。乃至满者波罗夷。若一比丘盗心触时药。得越比尼罪。动彼物得偷兰罪。离本处满者波罗夷。若二若三乃至众多比丘。盗心触时药。得越比尼罪。乃至满者波罗夷。若比丘遣一比丘盗心触时药。得越比尼罪。乃至满者波罗夷。若遣二遣三乃至遣众多比丘。盗心触时药。得越比尼罪。乃至满者波罗夷。若受遣比丘复遣一比丘。如是第二第三乃至众多比丘。盗心触时药。得越比尼罪。动时得偷兰罪。离本处满者波罗夷。如是夜分七日终身。乃至净不净亦如是。比丘有五法具足不与取。满者波罗夷。何等为五。所谓满足。有主。知有主生盗心。离本处。复有五法具足不与取。满者波罗夷。何等五。于彼物不与想。非己想。有主想。不同意想。不暂用想。有五法具足不犯波罗夷何等五。与想。自己想。无主想。同意想。暂用想。是名五比丘不与取非波罗夷。若比丘不与取。至东方南西北方虚空所住处。皆波罗夷。若比丘不与取。若遣奴若作人。若知识若试作。若未曾作而作若无知无羞净想皆犯。不犯者。若狂心乱无罪。是故说。若比丘于聚落空地不与取。随盗物王或捉或杀或缚或驱出。言咄男子。汝贼耶汝痴耶。比丘如是不与取者波罗夷。不应共住

世尊于王舍城。成佛六年冬分第二半月十日。东向坐食后两人半影为瓦。师子长老达腻伽。因瓶沙王及粪扫衣。比丘制此戒。已制当随顺行。是名随顺法(盗戒竟)

摩诃僧祇律卷第三摩诃僧祇律卷第四

        东晋天竺三藏佛陀跋陀罗共法显译

    明四波罗夷法之四(杀戒)

佛住毗舍离。时毗舍离有一病比丘。婴患经久治不时差。看病比丘心生疲厌。便语病比丘言。长老我看病。久不得奉侍和上阿阇梨。亦不得受经诵经思惟行道。长老疾病既久治不可差。我亦疲苦。病比丘言。当奈之何。我亦患厌苦痛难忍汝若能杀我者善。是比丘即便杀之。诸比丘闻已。以是因缘具白世尊。佛言。呼彼比丘来。来已佛广问上事。比丘汝实作是事不。答言。实尔世尊。佛言痴人。汝常不闻我无量方便称赞于梵行人所身行慈口行慈意行慈。供养供给所须。汝今云何手自断人命根。此非法非律非如佛教。不可以是事长养善法。佛告诸比丘。依止毗舍离比丘皆悉令集以十利故为诸比丘制戒乃至已闻者当重闻。若比丘手自断人命根。是比丘波罗夷不应共住

复次佛住毗舍离。时有一病比丘。得患经久治不能差。看病比丘心生疲厌。便语病比丘言。长老我看病来。久不得奉事和上阿阇梨。不得受经诵经思惟行道。长老疾病既久治不可差。我亦疲苦。病比丘言。当奈之何。我亦患此苦痛难忍。汝若能杀我者善。是比丘言。世尊制戒不得自手杀人。病比丘言。汝若不能自手杀我者。汝可为我求持刀者来。是时看病比丘便往鹿杖外道所语言。长寿汝能杀某比丘者。当与汝衣钵。彼便如语杀之取其衣钵。诸比丘闻已以是因缘具白世尊。佛言。呼看病比丘来。来已佛问看病比丘。汝实作是事不。答言实尔。佛言痴人。汝常不闻我无量方便称赞于梵行人所身行慈口行慈意行慈。供养供给所须。汝今云何求持刀者断人命根。此非法非律非是佛教。不可以是事长养善法。佛告诸比丘。依止毗舍离比丘皆悉令集。以十利故为诸比丘制戒。乃至已闻者当重闻。若比丘自手断人命。求持刀者令夺人命。是比丘得波罗夷。不应共住

复次佛住毗舍离。时有长病比丘。有看病比丘。乃至语长病比丘言。我不得受经诵经思惟行道。又复从人求索随病饮食汤药。人皆厌我。我亦疲苦。病比丘言。当如之何。我亦患此苦痛难忍。汝能杀我者善。是比丘言。汝不闻世尊制戒。不得手自杀人耶。病比丘言。若尔者汝为我呼持刀者来。比丘复言。汝不闻世尊制戒。不得求持刀者令杀人耶。病比丘言。今当奈何。看病比丘言。汝但自求活不欲死。若欲死者汝自有刀。可用自杀。亦可饮毒。用绳自戮。投坑赴火。抱石沉渊。自杀之法亦甚众多。作是赞说已乃避出外。时病比丘于后自杀。诸比丘以是事贝白世尊。佛言。呼彼看病比丘来。来已佛广问上事。汝实尔不。答言。实尔。佛言。汝常不闻我无量方便称赞于梵行人所身行慈口行慈意行慈。供养供给所须耶。汝今云何誉死叹死。此非法非律非如佛教。不可以是事长养善法。佛告诸比丘。依止毗舍离比丘皆悉令集。以十利故为诸比丘制戒。乃至已闻者当重闻。若比丘自手断人命。求持刀与杀者。教死誉死。是比丘得波罗夷。不应共住

复次佛住毗舍离。广说如上。时鹿杖外道杀比丘已。甚大忧恼作是念言。我今云何断梵行人命作是恶法。我命终后将无堕恶道入泥犁中。尔时天魔波旬常作方便增长诸恶。便于空中语外道言。汝莫愁恼畏堕恶道。所以者何。汝今所作脱人苦患。未度者度功德无量。时彼外道即作是念。我杀比丘乃获大福。能使诸天随喜赞善。作是念已。后持利刀至僧房中及经行处。处处唱令语诸比丘。谁欲离苦谁求度者。我能脱苦能令得度。尔时世尊为诸比丘说不净观。时诸比丘修不净观患厌身苦。中有以绳自戮。饮服毒药。以刀自害。投坑赴火。自杀者众。又为鹿杖外道前后所杀者。非是一人二人三四五人十人乃至六十人。尔时世尊月十五日坐于僧中。前后围绕欲作布萨。世尊左右观察见众僧少。问阿难言。今比丘僧何以故希。何以不见某甲比丘等。阿难白佛言。世尊。先为诸比丘说不净观赞叹修习不净观功德。是诸比丘勤修不净观。修不净观已极厌患身。或有以刀自杀。乃至使鹿杖外道断其命者。半月之中乃至六十人。诸不来者皆悉命过。唯愿世尊更开余法。不令诸比丘厌身自杀。令诸贤圣久存于世利益天人。于是佛告阿难。更有三昧。使诸比丘快乐善学不极厌身。何等三昧快乐善学不极厌身。所谓阿那般那念。阿难。云何比丘修阿那般那念。作证成就游安乐住。若比丘依止城邑聚落住。时到着衣持钵入城乞食。摄身口意善住身念。心不驰乱常行正受。摄持诸根入城乞食。乞食已还至彼寂静处安坐。谓于空地山涧岩窟冢间。敷草正坐。除诸贪欲嗔恚睡眠掉悔疑盖灭诸障碍。心慧力明系心在息。息入时知息入。息出时知息出。息入长时知息入长。息出长时知息出长。息入短时知息入短。息出短时知息出短。息入遍身时知息入遍身。出息遍身时知出息遍身。入息身行舍时知入息身行舍。出息身行舍时知出息身行舍。入息喜时知入息喜。出息喜时知出息喜。入息乐时知入息乐。出息乐时知出息乐。入息意行时知入息意行。出息意行时知出息意行。入息意行舍时知入息意行舍。出息意行舍时知出息意行舍。入息知心时知入息知心。出息知心时知出息知心。入息心悦时知入息心悦。出息心悦时知出息心悦。入息心定时知入息心定。出息心定时知出息心定。入息心解脱时知入息心解脱。出息心解脱时知出息心解脱。入息无常时知入息无常。出息无常时知出息无常。入息断时知入息断。出息断时知出息断。入息无欲时知入息无欲。出息无欲时知出息无欲。入息灭时知入息灭。出息灭时知出息灭如是阿难作是念者。名为快乐善学不极厌身。令诸贤圣久住于世利益天人。佛告诸比丘。依止毗舍离比丘皆悉令集。以十利故为诸比丘制戒。乃至已闻者当重闻。若比丘自手夺人命。求持刀与杀者。教死叹死。咄男子用恶活为死胜生。如是意如是想。方便叹誉死快令彼死。非余者是比丘波罗夷。不应共住。比丘者。乃至年满二十受具足。是名比丘。自手者。自身身分身势力。自身者。全身堆压杀人波罗夷。是名自身也。身分者。若手若肘若脚若膝。及余身分杀人者波罗夷。是名身分。身势力者。若杖若石若塼。遥掷杀人波罗夷。是名身势力。人者。有命人趣所摄。夺命者。令彼命根不相续四大分散。是名夺命。求者。求持刀人。若男女大小在家出家。刀者。若剑戟长刀短刀鉾槊铁轮。一切利器乃至针等。叹死者。言用恶活为死则胜生。如是意者杀意也。如是想者杀想也。叹誉死快者。令彼人死。非余者。因是死是比丘波罗夷。不应共住。波罗夷者。为于法智退没堕落无道果分。如是乃至尽智无生智。于此诸智退没堕落无道果分。是名波罗夷。又复波罗夷者。于泥洹退没堕落无证果分。是名波罗夷。又复波罗夷者。离于不杀退没堕落。是名波罗夷。又复波罗夷者。所可犯罪不可发露悔过。是名波罗夷。比丘杀人者。若用刀杀若毒杀若涂杀若吐杀若下杀若堕胎杀。若说相杀叹誉杀。刀者。若剑大小刀乃至针等。杀心身动。时得越比尼罪。触彼身时偷兰罪。因是死非余者。波罗夷。是名刀杀。毒药杀者有三种药。有生毒药。有作毒药。有蛊毒药。生毒药者。有国土地生毒药。如倪楼国生胜渠毒药。郁阇尼国生伽罗毒药。是名生毒药。作毒药者。如猎师作毒药。根茎花叶合和为药。是名作毒药。蛊毒药者。若蛇毒那俱罗毒猫子毒鼠毒狗毒罴毒人毒。如是种种毒。是名蛊毒。若比丘以杀人心取此三种药。得越比尼罪。到彼身偷兰罪。若因是药死者。波罗夷。是名毒药杀。涂药杀者。若比丘欲杀人故。手捉毒药时得越比尼罪。涂彼身分得偷兰罪。彼因是死波罗夷。是名涂药杀。吐杀者。若比丘欲杀人故。合吐药作是念。我持是药与彼当令吐脓血内藏。得越比尼罪。与彼药得偷兰罪。彼因是药吐死波罗夷。下药者。比丘欲杀人故。作下药时作是念。持是药与彼。令下脓血及下内藏。得越比尼罪。若与彼药。得偷兰罪。若因是下药死者得波罗夷。是名下药杀。堕胎杀者。若比丘欲杀母人而胎堕者。得越比尼罪。欲堕胎而母死者。得越比尼罪。欲杀母母死者。得波罗夷。欲堕胎胎分乃至身根命根堕者波罗夷。若人坏畜生胎堕者。得越比尼罪。是名为堕胎杀。说相者。若比丘语人言。我今所见汝必定死。便可自杀用是苦活为。是人因是死者。是比丘得波罗夷。又复言。如我梦所见汝今定死。又复言。我闻野干土枭乌鹊鸣。我今见汝面色鼻曲。汝将定死。便可自杀用苦活为。是人因是死者。是比丘得波罗夷。又复问言。汝几岁。答言。我尔许岁。又言。我解一切性命。汝今年必死。汝不如自杀用恶活为。因是死者。是比丘得波罗夷。又复言。汝属何星。答言。我属某星。便言我知彼星。当知汝今必死无疑。何不自杀用苦活为。是人因是死。是比丘得波罗夷。又复问言。汝名何等。答言我名某甲复言我解一切名字。汝必定死。复问汝何姓。答言我姓某。复言我解一切名姓。汝今必死。复问汝何所食。答言食如是食。便教令吐。吐已语言。汝食此食必死无疑。复问汝何处食。答言某处食。复教令吐。吐已语言某处有毒汝今必死。何不自杀用苦活为。是人因是死。是比丘得波罗夷。若比丘欲杀人故说相得越比尼罪。彼作方便欲自杀。得偷兰罪。若自杀已得波罗夷。是名说相杀。叹誉杀者。施戒果施者。比丘问言。汝布施不。答言布施。比丘言。汝已作功德必生善处。何不自杀用苦活为。是名施戒者。比丘问人。汝持戒不。答言持戒。世尊说持戒生二处。若天上若人中。用是苦活为。是名赞持戒果者。比丘言。汝已得须陀洹果不堕恶趣。极至七反天人往来。便尽苦边闭恶趣门。何不自杀用苦活为。又言汝已得斯陀含。一来世间便尽苦边。何不自杀用苦活为。复言汝已得阿那含。不还世间便尽苦边。何不自杀用苦活为。复言汝已得阿罗汉淫怒痴尽。不随烦恼心得自在。何不自杀用苦活为。若比丘欲杀人故。赞叹施戒果者得越比尼罪。彼方便欲自杀时。得偷兰罪。若自杀已波罗夷。若行若独废。若毗陀罗咒若屑药。若乌满吐若坑陷。若阿波钦满若示道。若河若大臣。若僧坊若虎若外道。行者。若十人若二十人共随道行。比丘先有怨嫌。欲害前人误害中人。得越比尼罪。欲害中人误害后人。得越比尼罪。欲害后人误害中人。得越比尼罪。欲害中人误害前人。得越比尼罪。欲害前人害前人者。波罗夷。欲害中后人害中后人者。波罗夷。若都一切有杀心者。随所害人得波罗夷。是名行杀。独废杀者。若比丘有杀心作独废。若于道中安施独废时。得越比尼罪。彼受苦痛时得偷兰罪。若彼死者得波罗夷。是名独废杀。毗陀罗咒者。若比丘欲杀人故。作毗陀罗咒。害心作咒时得越比尼罪。令彼生恐怖时得偷兰罪。彼死者得波罗夷。是名毗陀罗咒杀。屑药杀者。若比丘欲杀人故。作末屑药时作是念。持是药当杀彼人者。得越比尼罪。若药着彼身者得偷兰罪。若彼死者波罗夷。是名屑药杀。乌满吐者。若比丘欲杀人故。于道中作乌满吐。若比丘杀心作时得越比尼罪。彼受苦痛得偷兰罪。若死者波罗夷。是名乌满吐杀。坑陷杀者。若比丘欲杀人故。当道中作坑安种种利枪。以草土覆上令彼堕死。杀心作时得越比尼罪。若受苦痛时得偷兰罪。若死者波罗夷。是名坑陷杀。阿波钦满杀者。若比丘欲杀人故。于道中安施阿波钦满。比丘杀心作时得越比尼罪。若受苦痛时得偷兰罪。若死者得波罗夷。是名阿波钦满杀。示道杀者。若比丘在道边经行。有人来问比丘言。长老我欲至某聚落。道在何处。比丘先与彼人有怨嫌。便作是念我今得是人。便当示恶道令死使无一活。便指示恶道。若王难若师子虎狼难若毒螫难。示是等恶道时得越比尼罪。若受苦痛时得偷兰罪。若死者波罗夷。是名示道杀。河杀者。若比丘在河边经行。有人来问言。长老我欲至某处应从何处渡。是比丘于彼人先有怨嫌。便作是念。我今得是人。便示此非济处勿令一人得脱。便示非济处。若洄澓处。伏石机激尸收摩罗等处。若上彼岸处。有王禁难有贼难。有师子虎狼毒虫等难。示彼非济处时得越比尼罪。若受苦痛时得偷兰罪。若死者波罗夷。是名河杀。大臣者。若有大臣暴虐无道。贪取人物用自供给。不畏罪罚。恣意放逸作是念言。宁作今日乌。不作明日孔雀。王闻是已摄录囚系责之以罪。彼畏死故一切资财用持赎命。尔时有比丘出入其家。便往慰劳问其家苦乐。其妇答言。家主有事系闭在狱。何得有乐。阿阇梨当知。今我家主恐罪至死。故一切资财尽持赎命。钱财若尽便当贫穷无由自活。比丘言。汝莫愁悒。我当语汝夫不令用财。便至狱上慰劳言。无病长寿。大臣见比丘来心大欢喜言。阿阇梨外何所闻。比丘答言。闻汝当死欲尽持家财自用赎命。若如是者汝后妻子。当遭贫困饥寒乞丐。又汝家门户恶名流布。大臣答言。当如之何。比丘言。是王无道设使尽输汝财会不相活。慎莫与物。但当任其裁量。若彼大臣然可其语时。是比丘得越比尼罪。若受苦痛时得偷兰罪。若死者波罗夷。若大臣闻彼比丘语。答言阿阇梨是我知识。而惜钱财不用活我。我死之后。假使日月不出非我所忧。况复余事。阿阇梨还去思惟。佛语吉凶好恶无豫尊事。尔时得越比尼罪。大臣寻即思惟。如比丘语是王无道。设尽与财会必杀我。我既唐死妻子饥寒无由自活。门户耻辱痛甚于死。我今身自当之不与财物。以不即用比丘语故是人死者。是比丘以先教方便故。得偷兰罪。有人犯王法。有伺捕得缚送与王。王教将去随罪治之。时典刑者。以伽毗罗花庄严罪人头反缚两手打鼓吹贝周匝唱令。唱令已将出城门向刑罪人处。时有摩诃罗比丘不善知戒相。愍此罪人苦痛。语典刑者言。此人可愍莫使苦痛。汝持刀为作一疮尔时魁脍答言如教。便持利刀。为作一疮。是摩诃罗比丘得波罗夷。若魁脍答比丘言。汝用知是为。如王教令我自行之。汝且还去思惟。佛语尔时得越比尼罪。魁脍寻便思惟。用比丘语为作一疮。以不即用比丘语故。是摩诃罗比丘得偷兰罪。是名大臣。僧坊者。有客比丘来。应次受房舍。时知房舍比丘与客比丘先有嫌。便作是念。我今得子便当与破房令其必死。便与败房柱壁危坏。近毗多罗恐怖之处。富单那诸恶鬼处。近蚖蛇处。若示与时得越比尼罪。彼受苦痛时得偷兰罪。若死者波罗夷。彼客比丘晨朝起。从旧比丘索洗手物。旧比丘取蜂蝎蜈蚣蚖蛇着瓶中。覆口语客比丘言。是瓶中有洗手物。汝恣意取用。客比丘取时得越比尼罪。受苦痛时得偷兰罪。若死者波罗夷。是名僧坊杀。虎者。阿练若住处常有虎害人。时众集聚一处作是议言。诸长老是中阿练若住处。有虎恐伤害人。谁能伏此虎者。尔时众中有一比丘。与一比丘有嫌。语众人言。我能伏虎。是比丘向暮持弓箭出。彼时所嫌比丘着黄色衣头面黑。出到大小行处。是比丘尔时欲杀比丘而杀虎者。得越比尼罪。若欲杀虎而杀比丘者。得越比尼罪。欲杀比丘而杀比丘者波罗夷。欲杀虎而杀虎者波逸提。若二处俱有杀心而害者。随其所杀得罪。比丘则波罗夷。虎则波逸提。是名虎。外道者。有诸外道奉事日月。日月蚀时诸婆罗门群傥相逐。手执器杖举声唤呼。为救日月故过精舍边。见诸比丘便嗔恚言。是沙门释子是阿修罗党。今当杀之。时比丘闻是恶音声。闻是恶音声已即打揵椎集僧。有比丘言。我等今日当共作要。治此恶邪外道无使一人得活。作非法要故一切僧得越比尼罪。彼受苦痛一切僧得偷兰罪。若彼死者一切僧得波罗夷。若共要言。莫令使死但受苦痛改恶思善。若作此要一切僧得越比尼罪。受苦痛时一切僧得偷兰罪。尔时诸比丘言。诸长老不应害彼。亦不应加痛于人。如世尊说。比丘若贼怨家。若以锯刀割截身体。尔时不应起恶心。口不应恶语加人。当起慈心饶益心忍辱心。诸比丘当共思惟。世尊锯刀喻经。少作方便能行忍辱。然后但牢闭门户。举声大唤恐彼外道无罪。一切僧共作法要誓。一切僧无罪。有一比丘打婆罗门子垂死。便自思惟。此人若死者破沙门释子法。今当求医治之令差。若更有异比丘语是比丘。汝作何等。答言我。打是婆罗门垂死。我还自念。若当死者破沙门释子法。今欲求医治之令差。若异比丘言。汝去觅医我为汝守之。是打比丘去后。异比丘于后便竟其命。前打比丘得偷兰罪。后杀比丘得波罗夷。此名外道。若一比丘为杀人故。捉刀得越比尼罪。若触彼身得偷兰罪。若彼死波罗夷。若二若三乃至众多。为杀人故捉刀得越比尼罪。乃至死得波罗夷。若一比丘遣一比丘。为杀人故捉刀时得越比尼罪。乃至死波罗夷。遣二人遣三人乃至众多比丘。为杀人故捉刀时得越比尼罪。乃至死波罗夷。受遣比丘为杀人故。复遣一比丘捉刀得越比尼罪。乃至死犯波罗夷。如是第二第三。乃至遣众多比丘捉刀时得越比尼罪。乃至死波罗夷。如是毒杀涂杀。吐下杀堕胎杀。说相杀叹誉杀。亦如是。有五事具足杀人犯波罗夷。何等五。一者人。二者人想。三者兴方便。四者杀心。五者断命。是名五事。若遣奴杀若作人若知识。若试作若未曾作而作。无智无羞净想皆犯。不犯者狂痴心乱无罪。是故说。若比丘自手夺人命。求持刀与杀者。教死叹死。咄人用恶活为死胜生。作是意作是想。方便叹誉死快令彼人死。非余者。是比丘波罗夷。不应共住

世尊于毗舍离城成佛六年。冬分第三半月九日。食前北向坐一人半影。为众多看病比丘因鹿杖外道制此戒。已制当随顺行。是名随顺法(第三戒竟)

佛住舍卫城。广说如上。尔时一聚落中有二众安居。时一众安居讫还舍卫城。问讯世尊顶礼佛足在一面坐。世尊知而故问。比丘汝何处安居来。答言某处聚落安居。佛问比丘安居乐不。乞食易得不。行道如法不。安居讫已得安居衣不。诸优婆塞数来往不。诸比丘白佛言。世尊。夏安居乐。行道如法。乞食难得。衣物不足。诸优婆塞不数来往。佛告诸比丘。出家人何能恒得世利。比丘当知。世间八法常随世人。世人亦常随世八法。何等为八。一利二不利三称四不称五誉六毁七乐八苦。如是比丘愚痴凡夫少闻少知。于正法中心不调伏。于贤圣法心未开解。若世利起不善观察。是世利生即是无常磨灭之法。若法真实无常磨灭者。当知是利虽生速灭不住。若不观察此真实义。是为凡夫无实智慧随顺世法。如是不利乃至乐苦亦不观察。是乐虽生即是无常磨灭之法。若法真实无常磨灭者。当知是乐苦虽生速灭不住。若不观此真实义者。是为凡夫无实智慧随顺世法。比丘当知。于此世法不观察故。若世利起则生贪着。若利不起则生忧患。乃至乐苦亦复如是。比丘如是三受增长。三受既增四取炽然。四取炽然故则有生缘。生老病死忧悲苦恼心乱发狂如是习起苦阴增广。比丘当知贤圣弟子多闻智慧。于正法中心善调伏。贤圣法中心得开解。世利既生当善观察。世利起者皆悉无常磨灭之法。若法真实无常磨灭者。当知是利虽起速灭不住。乃至乐苦皆悉如是。比丘当知。作是观者若世利起不生贪着。世利不起心不忧戚。乃至乐苦亦复如是。爱憎不生诸觉随顺离诸忧戚。乃至乐苦苦阴灭尽则得涅槃。尔时世尊说是法已。重说偈言

  利衰及毁誉　　称讥若苦乐
  八法常相寻　　往复若回转
  八法不牢固　　磨灭变化法
  所谓圣弟子　　执照无常镜
  谛观世八法　　俄顷不暂停
  于四乐利中　　未尝有倾动
  若遭毁讥谤　　忧戚不经心
  若离世八法　　是名智慧士
  能出欲河流　　度脱生死海

是时诸比丘闻佛所说皆大欢喜。俱白佛言。世尊善哉善巧方便说世八法。未曾有也。佛告诸比丘。如来应供正遍知三达无碍。智慧之明如月盛满。说世八法何足为奇。我于昔时畜生道中作鹦鹉鸟。能为余鸟说世八法。此乃为奇。诸比丘白佛言。已曾尔耶。佛言如是。过去世时有一国王。养二鹦鹉。一名罗大。二名波罗。皆解人语。王甚爱念盛以金笼食辄同案。时有大臣。持一猕猴儿奉上大王。人情乐新。王即爱念饮食饲养胜于鹦鹉。时波罗鹦鹉子。便为罗大而说偈言

  先与王同食　　世间之上馔
  今为猕猴夺　　宜共陵虚逝

尔时罗大答言。斯皆亦无常。今此猕猴子不久复当失此利养。即为波罗而说偈言

  利衰及毁誉　　称讥若苦乐
  斯皆非常法　　何足致忧喜

是时波罗复说偈言

  触目睹不欢　　无有爱乐相
  但闻毁呰声　　永无称誉者
  肆我飞禽志　　何为受斯苦

是猕猴子小时毛色润泽跳踉超掷。人所戏弄。渐至长大衣毛憔悴人所恶见。竖耳张口恐怖小儿。尔时罗大鹦鹉子。便说此偈谓波罗言

  竖耳[皮*叔][皮*宿]面　　啀喍怖童子
  坐自生罪累　　不久失利养

是猕猴转大。王爱意遂尽。即敕左右令系马槽柱。时王子年小。手捉饮食至猕猴边。猕猴索食王子不与。猕猴嗔怒爴王子面伤坏裂衣服。王子惊怖举声大唤。王问傍人儿何以涕。傍人以事答王。王便大嗔敕人打杀。掷着堑中令曼陀食。时波罗鹦鹉子。即为罗大而说偈言

  汝为智慧者　　预睹彼未然
  禽兽无知丧　　为彼曼陀食

佛告诸比丘。尔时罗大鹦鹉子岂异人乎。即我身是。波罗鹦鹉子者即阿难是。我为鹦鹉时。以能为彼说世八法无常迁变不可久保。况复今成正觉说世八法。何足为奇。时彼第二众安居竟。寻即来至礼世尊足于一面坐。世尊知而故问。比丘何处安居来。答言世尊。某处安居。佛问比丘。安居乐不。行道疲不。乞食易得不。夏安居竟得安居衣不。诸优婆塞数来往不。诸比丘白佛言。夏安居乐。行道不疲。乞食易得。多得安居衣。诸优婆塞来往者众。佛问比丘。有何因缘二众俱共依一聚落安居。一众独多得供养。一众不得。诸比丘白佛言。世尊。我等无量方便赞叹三宝。亦常赞叹佛大弟子尊者舍利弗大目揵连等。及自赞叹所修习功德。佛问比丘。汝所赞叹为实尔不。世尊我所赞叹三宝及尊者舍利弗等是实。自赞叹不实。佛言比丘。此是恶事。云何为身利养不实空自赞叹。宁啖灰炭吞食粪土利刀破腹。不以虚妄称过人法而得供养。佛告比丘。我常赞叹少欲知足。汝等云何多欲难满广求无厌。此非法非律非是佛教。不可以是长养善法。世尊种种呵责是比丘已。诸比丘在彼聚落安居时。入村乞食有自称誉者乞食易得。不自称誉者极甚难得时有一长老比丘。便作是念。我何为虚妄而自赞叹。得过人法以自活命。我从今日不复虚妄而自称誉。晨朝着入聚落衣持钵乞食。时有人问言。长老汝于圣果有所得不。是比丘便不自称誉。即时乞食处处不得。日时欲过饥乏羸顿。复自称誉即有所得。有异比丘闻是。长老须臾妄语须臾实语。便白佛言。世尊。云何是长老比丘志弱无恒轻躁乃尔。佛告诸比丘。是长老不但今日志弱无恒轻躁。过去世时亦复如是。诸比丘白佛言。世尊。已曾尔耶。佛言如是。过去世时非时连雨七日不止。诸放牧者七日不出。时有饿狼饥行求食遍历聚落。乃至七村都无所得。便自克责。我何薄相经历七村都无所得。我今不如守斋而住。便还山林自于窟穴咒愿言。使一切众生皆得安隐。然后摄身安坐闭目思惟天帝释法至斋日月八日十四日十五日。乘伊罗白龙象下观察世间。何等众生孝顺父母。供养沙门婆罗门。布施持戒修梵行受八戒者。时释提桓因周行观察到彼山窟。见此狼闭目思惟。便作是念。咄哉狼兽甚为奇特。人尚无有此心。况此狼兽而能如是。便欲试之知其虚实。释即变身化为一羊在窟前住。高声命群。狼时见羊便作是念。奇哉斋福报应忽至。我游七村求食不获。今暂守斋肴膳自来。厨供已到今但当食。食已然后守斋。即便出穴往趣羊所。羊见狼来便惊奔走。狼便寻逐羊去不住。追之既远羊化为狗。方口耽耳反来逐狼急声吠之。狼见狗来惊怖还走。狗急追之。劣乃得免。还至窟穴便作是念。我欲食彼反欲啖我。尔时帝释复于狼前。作跛脚羊鸣唤而住。狼作是念。前者是狗。我饥闷眼花谓为是羊。今所见者此真是羊。复更谛观看耳角毛尾真实是羊。便出往趣羊复惊走。奔逐垂得。复化作狗反还逐狼亦复如前。我欲食彼反欲见啖。时天帝释即于狼前化为羔子鸣群唤母。狼便嗔言。汝作肉段我尚不出。况为羔子而欲见欺。还更守斋静心思惟。时天帝释知狼心念还斋。犹故作羊羔于狼前住。时狼便说偈言

  若真实为羊　　犹故不能出
  况复作虚妄　　如前恐怖我
  见我还斋已　　汝复来见试
  假使为肉段　　犹尚不可信
  况作羊羔子　　而诈唤咩咩

于是世尊而说偈言

  若有出家人　　持戒心轻躁
  不能舍利养　　犹如狼守斋

尔时世尊告诸比丘。彼时狼者岂异人乎。即此比丘是。本为狼时志操无恒。今虽出家心故轻躁。尔时世尊告诸比丘。依止舍卫城诸比丘皆悉令集。以十利故为诸比丘制戒。乃至已闻者当重闻。若比丘未知未了。自称得过人法圣知见殊胜如是知如是见者。是比丘得波罗夷。不应共住

复次佛住舍卫城。广说如上。时有二比丘在阿练若处住。其一比丘暂成就根力觉道贪恚不起。语第二比丘言。长老是我善知识所敬重者。今欲向长老说密事。彼言汝欲说何等。便言长老我得阿罗汉。彼即答言。长老。世尊在世亲受法教。勤修精进得成道果。是其宜耳。是比丘后时游诸聚落。放纵诸根废习止观。便起烦恼觉痴爱生。便语其伴。我本谓有所得。定自未得。何以知之。自觉心中烦恼犹在。彼比丘言。长老妄称得过人法。犯波罗夷。是比丘言。我非知而妄语。谓为实耳。诸比丘以是事具白世尊。某甲比丘妄语自称得过人法。佛言呼来。来已佛问比丘。汝实虚妄自称得过人法耶。世尊。我不虚妄自称得过人法。我想谓得。如是想说耳。佛问比丘。汝何因缘而作是说。比丘白佛言。世尊。我于阿练若处住。修习根力觉道烦恼不起。我谓得阿罗汉。便语同伴说已所得。我于余时游行聚落。不摄诸根烦恼便起。即生疑悔语是比丘。非是虚妄。尔时世尊告诸比丘。是比丘非故虚妄说得过人法。当知此比丘是增上慢。佛告比丘。云何于正法中信家非家舍家出家起增上慢。汝当方便除增上慢可得罗汉。时彼比丘大自惭愧。即于佛前精进方便修行正观。除增上慢得罗汉果。诸比丘白佛言。甚奇世尊。是比丘蒙佛慈恩。精勤方便修行正观。除增上慢得罗汉果。佛告诸比丘。是比丘不但今日蒙我恩故。精勤方便修习正观。除增上慢得罗汉果。过去世时亦蒙我恩。精勤不懈获大果报。诸比丘白佛言。已曾尔耶。佛言如是。佛告诸比丘。过去世时有国名迦尸城名波罗奈。时彼国中人民丰乐三毒炽盛。有一贫穷婆罗门。从外聚落来入城内。是节会日。城中诸人有乘象者有乘马者。有乘车者有乘舆者。洗浴涂香着新衣服。五欲自恣种种戏乐。时婆罗门渴爱心生便问人言。此诸人辈作何因缘得是快乐。答言婆罗门。汝不知耶。答言不知。时人便语婆罗门。是辈先世修行功德。又复今世勤为家业故得斯乐。时婆罗门便作是念。此诸人等手足四体与我无异。我今但当勤身佣力。可得财物自恣快乐与彼无异。便自还家谓其妇言。我欲远行佣力求财。其妇答言。随在近处乞索趣得饮食儿子何用远行。婆罗门言。事不获已宜当远行。其妇心念其欲去者知复如何。语婆罗门。去留随意深自保重。婆罗门敕妇言。汝自谨慎好看儿子。时婆罗门于是便去至一海边聚落。见诸商人祠祀聚会宣令里巷。谁能随我入海共取珍宝。婆罗门答言。我欲入海。商人问言汝有何钱货。答言我无钱货。唯欲从汝乞食为汝咒愿。时诸商人皆为福故语令上船。即得便风至一海渚聚落。时婆罗门入村乞食。并役力求财。得纯金三十二段。摩尼珠十四枚。便随伴还阎浮提船着岸渚。时婆罗门便大夸说诸商人等。持财物往今得物还。有何奇特。我本空去今得此宝。可谓为奇。不胜欢喜。便捉宝物手中挑弄不止。即失宝物落海水中。时婆罗门甚大忧恼。我极辛苦得是宝物。如何一旦忽然落水。我要当抒海求觅此宝。即便上岸求得好木。持诣木师所语言。烦君为我作木魁。木师为作已。旋师为旋之。铁师为鍱之。得木魁已持诣海。次褰衣袒臂欲抒海水。时有海神作是思惟。是婆罗门欲作何等。我当问之。即化作婆罗门形往至其所。以偈问言

  褰衣而袒臂　　匆匆似急事
  我故来问汝　　为欲作何等

时婆罗门以偈答言

  今此大海水　　深广众流主
  我今作方便　　要欲抒令尽

时海神复说偈言

  大海众流主　　于汝有何过
  而汝作方便　　要欲抒令尽

时婆罗门复说偈言

  我经大苦难　　渡海得珍宝
  真金三十二　　摩尼有十四
  舍船欲上岸　　宝囊落海中
  我求宝珠故　　抒尽此大海

时海神复说偈言

  大海甚深广　　百川众流主
  假使百千岁　　抒之不可尽

时婆罗门复说偈答言

  日月长谢无穷尽　　木魁铁鍱难可坏
  勤力专精不休息　　何忧此海不枯竭

时婆罗门说此偈已便抒海水。抒着岸上水还入海。是时海神观彼婆罗门意为懈怠耶当实坚固。观已见婆罗门志意专精永无退期。时海神便作是念。假使百年抒此海水。终不能减如毛发许。感其专精即还其宝。是时海神为婆罗门而说偈言

  精勤方便士　　志意不休息
  专精之所感　　虽失复还得

佛告诸比丘。时海神者岂异人乎。即我身是也。婆罗门者此比丘是。过去世时已曾蒙我精勤方便得大果报。今复蒙我精勤方便。修习正观除增上慢得阿罗汉。佛告诸比丘。依止舍卫城比丘皆悉令集。以十利故为诸比丘制戒。乃至已闻者当重闻。若比丘未知未了。自称得过人法圣知见殊胜我如是知如是见。彼于后时若捡挍若不捡挍。犯罪欲求清净故作如是言。长老我不知言知。不见言见。虚诳不实语。除增上慢。是比丘得波罗夷。不应共住。比丘者。乃至年满二十受具足。是名比丘。未知者无智故。未了者未断故。自称者称己也。得过人法者。人法者。所谓五欲五下分结。六趣六诤根七使八邪世八法。九慢九恼。十善行迹十恶行迹。复次人法者如诸天子以偈问佛

  何等人趣善　　何等人生天
  何等人昼夜　　长养善功德

尔时世尊以偈答天子言

  旷路作好井　　种植园果施
  树林施清凉　　桥船渡人民
  布施修净戒　　智慧舍悭贪
  功德日夜增　　常生天人中

是为人法。复次孝顺父母。供养沙门婆罗门。及诸尊重修梵行者。是为人法。过人法者。十智法智未知智等智他心智苦集灭道智尽智无生智。灭尽解脱增上善心。淳熟善根净不净解脱。明法须陀洹果及所摄三昧。善入出住正受作证。所谓止观三三昧三明。四念处四正勤四如意足四禅四无量心四无色定四圣道四圣种四圣谛四沙门果。五枝定五根五力五解脱处。六无上法六圣法六出要界六念六通。七财七无著法七三昧七漏尽力七觉支。八正道八胜处八解脱八向道迹。九想九欢喜法九净行满足九次第定。十贤圣住处十一切入十离炽然法十无学法十种漏尽力。此名过人法。圣知见者。所谓佛及佛弟子所有知见。或自称知非见。或自称见非知。或自称知见。或非知非见。知非见者。言我知苦习灭道。不言我天眼清净。见人死此生彼善趣恶趣若贵若贱。不言我得天耳过人所闻。人声非人声若近若远。又不言我知他人心。神足陵虚自识宿命。是名知而非见。见而非知者。自言我得天眼清净乃至自知宿命。不言我知四真谛是名见非知。云何知见。言我知四真谛乃至自识宿命。是名知见云何名非知非见。亦不言我知四真谛乃至自识宿命。是名非知非见。得殊胜者。如是知。如是见。实不知言知。不见言见。后若捡挍若不捡挍。捡挍者有人问言。长老。汝得圣道果耶。从何等法师学得此果。汝何处得。得时云何。是名捡挍。不捡挍者无人问。若问若不问。不实自言得过人法。犯波罗夷。波罗夷者四波罗夷中。若一一犯也。求清净者欲得清净。故言我不知言知。不见言见。虚者空也。诳者不如实。妄语者妄自称说。除增上慢者。世尊所除。波罗夷者如上说。复次波罗夷者。离不妄语退没堕落。是名波罗夷。复次有波罗夷者。所可犯罪不可发露悔过。是名波罗夷。若比丘自言我法智耶。犯越比尼罪。若言我法智。偷兰罪。若言我得法智。波罗夷。如是断如是修如是作证。如是一一广说。乃至言我漏尽力耶。得越比尼罪。若言我漏尽力。得偷兰罪。若言我得漏尽力。波罗夷。如是断如是修。如是作证亦如是。若教化比丘至檀越家语女人言。优婆夷。某处安居比丘尽非凡夫。得越比尼罪。若言我亦在中。得偷兰罪。问言长老。得是法耶。答言得。波罗夷。若比丘言。优婆夷某处比丘夏安居尽得阿罗汉。乃至言我得是法。犯波罗夷。又比丘言。某处比丘夏安居尽得妙胜法。乃至言我得是法。波罗夷。若言某处比丘夏安居竟亦如是。若比丘语优婆塞优婆夷言。某处自恣比丘皆非凡夫。皆是阿罗汉皆得殊胜法。乃至言我得是法。犯波罗夷。若比丘言。优婆夷某处院内住比丘皆非凡夫。皆阿罗汉得妙胜法。乃至言我得是法。犯波罗夷。若比丘语优婆夷言。某处坐上比丘皆非凡夫。皆是阿罗汉皆得胜妙法。乃至问言。长老得是法耶。答言。我亦得是法。犯波罗夷。大王家大臣家。长者家居士家。城中院中亦如是。若比丘言。汝家住比丘汝家食比丘。为汝家眷属授经比丘皆非凡夫。是阿罗汉得胜妙法。乃至我得是法。犯波罗夷。若言持如是钵着如是衣食如是食。如是行如是住如是卧皆非凡夫。皆是阿罗汉得胜妙法。乃至自得是法。犯波罗夷。若言是上诸比丘皆得法智。自言我法智耶。得越比尼罪。我法智偷兰罪。若言我得法智证不实。波罗夷。如是知如是断如是修如是证。乃至漏尽力作证亦如是。若比丘以中国语向边地说。若以边地语向中国说。若中国语向中国说。若边地语向边地说。若说义不说味。得偷兰罪。若说味不说义。越比尼罪。若说味说义。得波罗夷。若不说义不说味。得越比尼罪。说义不说味者。自称说我不称说罗汉。说味不说义者。称说罗汉不自称说我。说义说味者。自称说我是罗汉。不说义不说味者。作罗汉相。或合眼以手自指。语优婆夷言。汝愚痴人不知其尊。譬如优昙钵花时时一出而不知贵。作如是相者得越比尼罪。比丘若作书印。若作手相。现义不现味者。得越比尼罪。现味不现义者。越比尼心悔。现义现味得偷兰罪。不现义不现味无罪。除根力觉道种乃至世间善法。小小威仪不应赞叹但赞叹佛法僧大弟子舍利弗目连无罪。不得自赞叹自身。唯有同意问说实者无罪。是故说若比丘未知未了。自称得过人法圣知见。殊胜如是知如是见。后于异时若捡挍若不捡挍。犯罪欲求清净故作如是言。长老。我不知言知。不见言见。空诳不实语。除增上慢。是比丘得波罗夷。不应共住。世尊于舍卫城。成佛六年冬分第四半月十三日。食后东向坐三人半影。为聚落中众多比丘制此戒。及增上慢比丘。已制当随顺行。是名随顺法(妄语戒竟)

摩诃僧祇律卷第四摩诃僧祇律卷第五

        东晋天竺三藏佛陀跋陀罗共法显译

    明僧残戒之一

佛住舍卫城。广说如上。时有比丘名尸利耶婆。于舍卫城中信家非家舍家出家。时到着入聚落衣持钵入城乞食。不善摄身口意。放纵诸根。始入一家得食饱足已。复入第二家。第二家有一女人。露身而坐。是比丘见已还自住处。念彼女人身。心想驰乱忧悴发病颜色痿黄。尔时诸比丘问尸利耶婆。汝今何故颜色痿黄忧悴不乐。欲须酥油石蜜诸汤药不。答言。不须自当差耳。诸比丘尼优婆塞优婆夷问讯亦复如是。彼比丘于昼卧。觉心念形起。手自触身生。即失不净。失不净已便得安乐。所患即差。便作是念。此好方便可得除患。不妨出家。净修梵行受人信施。世尊以五事利益故。五日一案行僧坊。何等为五。一者我声闻弟子不著有为事不。二者不着世俗言论不。三者不着睡眠妨行道不。四者看病比丘不。五者为年少新出家比丘见如来威仪庠序起欢喜心是为五事。如来五日观历诸房。时长老尸利耶婆昼眠觉已。于自房后小行身生起。世尊畏彼尸利耶婆比丘惊怖惭愧故。世尊作小声令其先觉。时尸利耶婆见世尊已。疾行着衣随世尊后礼足而住。尔时世尊问尸利耶婆。汝先病患颜色痿黄。何缘得差。便白佛言。世尊。我于舍卫城中信家非家舍家出家。亲里知识给我衣服床卧医药不乏。我于一时着衣持钵入城乞食。至一家见一女人露身而坐。见已还精舍欲心驰乱。遂便不乐生病不欲饮食。时诸比丘比丘尼优婆塞优婆夷来慰问我。皆欲与我医药。我言不须。我于一时昼日眠觉身生起。手触即失不净。失不净已得眠安隐。病得除愈。我作是念。是好方便可得除患。不妨出家受人信施以是故。世尊。病得除愈。身既安隐得修梵行。佛言。痴人。此甚不可。此非梵行而言梵行。此非安隐而言安隐。痴人。云何以是手受人信施。复以此手触失不净。汝常不闻我无量方便呵责欲想赞叹断欲耶。汝今作此恶不善事。此非法非律非如佛教。不可以此长养善法。佛告诸比丘。依止舍卫城比丘皆悉令集。以十利故。为诸比丘制戒。乃至已闻者当重闻。若比丘故出精。僧伽婆尸沙

复次佛住舍卫城。广说如上。是时长老尸利耶婆。数数犯僧伽婆尸沙。如波夜提。如波罗提提舍尼。如越比尼罪忏悔。诸比丘见尸利耶婆数数犯僧伽婆尸沙罪。乃至如越比尼罪悔过。便语尸利耶婆言。长老。世尊已作制限分齐竟。汝云何轻为数数犯耶。尸利耶婆言。诸长老。我犯罪悔过。尚不厌倦。汝等受我悔过。何足为难。诸比丘以是事具白世尊。佛言。唤尸利耶婆来。来已佛问尸利耶婆。汝实数数犯僧伽婆尸沙罪。乃至语诸比丘言。我犯罪悔过尚不厌倦。汝等受我忏悔何足为难也答言。实尔世尊。佛告尸利耶婆。此是恶事。从今日后。若犯僧伽婆尸沙罪者。应六日六夜比丘僧中行摩那埵。行摩那埵已。应二十比丘僧中出罪

复次佛住舍卫城。广说如上。时尸利耶婆。数数犯僧伽婆尸沙罪。便作是念。世尊制戒。犯僧伽婆尸沙罪者。应六日六夜行摩那埵。行摩那埵已。应二十比丘僧中出罪。我今已犯僧伽婆尸沙罪。人不知者则无六日六夜。无六日六夜者。亦无二十僧中出罪。我今当覆藏。覆藏已便自疑悔。我为不善甚不如法。善男子信心出家知佛制戒。而故违覆藏。设梵行人不知者。诸天知他人心者。岂不知耶设诸天不知者世尊岂当不知耶便语诸比丘。与我摩那埵。比丘问言。何以求摩那埵。答言。我犯僧伽婆尸沙罪。复问犯来几时答言。尔许时。复问。何不即语人耶。答言。我惭羞故不即说。我复念言。犯僧伽婆尸沙罪。世尊制戒应六日六夜行摩那埵。乃至言。诸天不知者。世尊岂不知耶。以是事故。今向长老说。诸比丘以是事具白世尊。佛言。唤尸利耶婆来。来已佛具问上事。汝实尔不。答言。实尔世尊。佛言。痴人。此是恶事。犯戒尚不惭羞悔过。何以惭羞。尔时世尊即说偈言

  覆盖者则漏　　开者则不漏
  是故诸覆者　　当开令不漏

佛告诸比丘。从今日犯僧伽婆尸沙罪覆藏者。应与波利婆沙。行波利婆沙已。当与六日六夜行摩那埵。六日六夜行摩那埵已。当应二十僧中出罪。二十僧中少一比丘欲出罪者。是比丘不得出罪。诸比丘应可诃

复次复住舍卫城。广说如上。时有二学人二凡夫人梦中出精。彼各各思惟。世尊制戒故出精者。犯僧伽婆尸沙罪。我今将不犯僧伽婆尸沙耶。当以是事具白尊者舍利弗。舍利弗当问世尊。若佛有教我当奉行。是诸比丘便诣尊者。舍利弗所。以是因缘白舍利弗。时舍利弗将是比丘诣世尊所。尊者舍利弗白佛言。此四比丘梦中失精。便自疑悔。世尊制戒。我将不犯僧伽婆尸沙罪耶。故来白佛。世尊。是事云何。佛告舍利弗。梦者虚妄不实。若梦真实。于我法中修梵行者。无有解脱。以一切梦皆不真实。是故舍利弗。诸修梵行者于我法中得尽苦际。佛告诸比丘。依止舍卫城比丘皆悉令集。以十利故。为诸比丘制戒。乃至已闻者当重闻。若比丘故出精。除梦中僧伽婆尸沙罪。故者。心调方便也。出精者。出不净也。除梦中者。世尊说梦中失精无罪。僧伽婆尸沙者。僧伽谓四波罗夷。婆尸沙者。是罪。有余应羯磨治故。说僧伽婆尸沙。复次是罪僧中发露悔过。亦名僧伽婆尸沙。梦者有五种。何等五。一者实梦。二者不实梦。三者不明了梦。四者梦中梦。五者先想而后梦。是为五。何者实梦。所谓如来为菩萨时。见五种梦如实不异。是名实梦。不实梦者。若人见梦觉不实。是名不实梦。不明了梦者。如其梦不记前后中间。是谓不明了梦。梦中梦者如见梦即于梦中为人说梦。是名梦中梦。先想而后梦者。如昼所作想夜便辄梦。是名先想后梦。有五事因缘起于淫欲。眼见色染着爱乐。生淫欲想。如眼见色染著者。耳鼻舌身亦如是先与女人情相娱乐。后续忆念即生淫欲心。是名五种因缘起淫欲。身生起有五事因缘。欲心起。大行起。小行起。风患起。若非人触起。是为五事因缘起。弄出精有三事。有欲心故弄出。弄出者。为取精故为乐故。若自念言。久来不通脱生诸患。欲令通故。若戏故。若自试故。若未曾故。或自弄出。若使人弄出。是为弄出精者。若酥色油色乳色酪色。若青黄赤白。如是种种色。若一一色出者。僧伽婆尸沙。欲心起身生有出想。而不弄不出。是为心悔过。若欲心起身生有出想故。弄而不出得偷兰罪。欲心起身生有出想故。弄而出得僧伽婆尸沙。若欲心起身生无出想。不故弄出无罪。如是大行小行风患非人起亦如是。若欲心起身生有出想。故弄精欲出。而不出外者偷兰罪。若欲心起身生有出想。不弄不出当责心。若欲心起身生无出想。弄而不出是亦责心。若欲心起身生无出想。不故弄出是亦责心。若欲心起身生有出想。故弄而出得僧伽婆尸沙。乃至非人亦复如是。出精者。若身若身分。若身合身者。一切身动跳掷。时作方便而出。出者僧伽婆尸沙。身分者。若以手若以脚若膊若以肘。作方便出者僧伽婆尸沙。身合者。地水火风。地者。若床若褥若壁孔木孔竹筒等。若一一坚物触身欲令出。出者僧伽婆尸沙。水者。诸流水逆触身。酥油等如是。诸水物中湿润物。身触欲令出。出者僧伽婆尸沙。火者。若于诸暖处暖具身触。若向火向日欲令出。出者僧伽婆尸沙。风者。若口风若扇风若衣风。触身欲令出。出者僧伽婆尸沙。若比丘语人言。汝弄我身生令出。精出者僧伽婆尸沙。若复语人言。汝莫令我数语。汝常知是事。而后弄出。出者僧伽婆尸沙。若比丘在空闲处住。见有禽兽交会。见已欲心起失不净者。是应责心。若复为受乐故。更方便逐看禽兽欲令出。出者僧伽婆尸沙。若有人强力。捉比丘弄令出者。是应责心。若为乐故。更就彼人令弄。出者僧伽婆尸沙。若比丘入聚落。见他男女行淫。见已欲心起失不净者。是应责心。若复为乐故。更逐往看令失者僧伽婆尸沙。若比丘见男子造淫女家。便作是念。此中更无余事。正当作淫欲。而自欲心起失不净者。是应责心。为乐故。更往看令失者僧伽婆尸沙。若比丘见女人裸身洗浴。见已欲心起失不净者。是应责心。若为乐故。逐往看令出者僧伽婆尸沙。若见男子裸身亦复如是。若比丘行道中欲心自起而失不净者。是应责心。行时故作方便令出。出者僧伽婆尸沙。如行住坐卧亦如是。若因涂油洗浴失者。是应责心。若故作方便。涂油洗浴令失者。僧伽婆尸沙。是故世尊说。故弄失精。除梦中僧伽婆尸沙(一戒竟)

佛住王舍城迦兰陀竹园。广说如上。时优钵罗比丘尼。有沙弥尼字支梨。优钵罗比丘尼。遣沙弥尼支梨。持衣与优陀夷。时优陀夷于自房前缝衣。支梨礼优陀夷足于前而住。白优陀夷言。我师优钵罗。遣我持衣与长老。答言。好持着房中。时优陀夷。寻后逐入房内。便手把持抱适意已须臾放去。支梨行涕还师优钵罗问言。汝何以涕。答言。长老优陀夷。随我入房把持抱弄。极恼触我。优钵罗言。汝莫涕也。我当白佛令罚优陀夷

复次佛住舍卫城。广说如上。长老优陀夷。时到着入聚落衣持钵入城次行乞食。入一家见一女人磨豆。便捉发编举案牵推。手捉抱弄适意已须臾放去。彼便嫌责言。此非法非善。优陀夷。汝呼我家是淫女家耶。当以是事白诸比丘。优陀夷言。白与不白当随汝意。便出而去

复次佛住舍卫城。广说如上。时优陀夷。时到着入聚落衣持钵入城。次行乞食入一家。时有妊娠女人。舂极坐臼上息。时优陀夷脚蹴臼。臼转母人倒地身形裸露。优陀夷即便扶起言。姊妹起。我已见竟。时女人嗔恚言。沙门释子此非是辞谢法。我宁受汝舂杵打死。不欲令此覆藏处出现于人。我当以是事白诸比丘。优陀夷言。白与不白自随汝意。言已便去

复次佛住舍卫城。广说如上。时长老优陀夷直次守房。时优陀夷先有一知识婆罗门。将妇来诣优陀夷。其妇端正。夫语优陀夷言。可开诸房示此妇人。优陀夷言。汝若不语我亦欲示此妇人房舍。况复汝请。即将至阁上示诸房舍。雕文刻镂种种严饰。地作青豆色。于一屏处。便捉妇人手把持抱。妇人念言此优陀夷必欲作如是如是事。弄已还放。语婆罗门言。我已示竟。婆罗门言好。更可示余房舍。时彼妇以优陀夷不共行欲故。便嗔恚言。用看房舍为。此是薄福黄门出家。遍摩触我身而无好事。时婆罗门语优陀夷言。汝实于我知识而生非知识想耶。而于平地更生堆埠耶。而于水中更生火也即便系优陀夷颈牵去。优陀夷言。婆罗门放我。莫使须臾作破头事。婆罗门言。我不放汝。汝有负我事。诸比丘闻斗诤声出看语婆罗门言。置置放优陀夷。婆罗门言。我终不放。要将诣世尊。时佛见已语婆罗门言。放优陀夷。婆罗门白佛言。世尊。我今不放。要当说其罪状然后放去。时优陀夷便力诤得脱走去。时婆罗门以上因缘具白世尊。尔时世尊。为婆罗门随顺说法示教利喜。嗔恚即除得法眼净。辞还请退佛言。宜知是时。即礼佛足右绕三匝而去。婆罗门去不久。佛告诸比丘。唤优陀夷来。即唤来已。佛以上事广问优陀夷。汝实尔不。答言。实尔世尊。佛言。优陀夷。此是恶事诸比丘白佛言。世尊。此优陀夷不但作此一恶事。先时世尊。在王舍城伽兰陀竹园。时优钵罗比丘尼遣沙弥尼支梨。持衣与优陀夷。优陀夷便捉抱弄适意已放去。佛问优陀夷。有是事不。答言。实尔世尊。佛言。此是恶事。复有比丘白佛言。不但作此恶事。世尊在舍卫城时。优陀夷时到着入聚落衣持钵次行乞食入一家。家中有一女人磨豆。时优陀夷便捉其发编抱捉恼弄放去。佛问优陀夷。实有是事不。答言。实尔世尊。佛言。此是恶事。复有比丘言。世尊。何但有此恶事。又复一时世尊在舍卫城。时优陀夷着入聚落衣持钵乞食入一家。有一妊娠女人。舂极坐臼上息。优陀夷以脚蹴臼令其倒地。观其形体然后出去。佛言。优陀夷汝复有是事不。答言。实尔世尊。佛言。何以故尔。答言。世尊。我未曾见妊娠女形故试看耳。佛言。痴人。宁观粪厕。不观彼妊娠女形。我常不种种呵责欲想赞叹离欲耶。汝云何作此恶不善行。此非法非律非如佛教。不可以是长养善法。诸比丘白佛言。世尊。云何是优陀夷。为婆罗门所捉。蒙世尊恩故得脱。佛告诸比丘。是优陀夷不但今日蒙我得脱。过去世时以曾被捉蒙我得脱。诸比丘白佛言。已曾尔耶。佛言如是。过去世时香山中有仙人住处。去山不远有一池水。时池水中有一鳖。出池求食。食已向日张口而眠。时香山中有诸猕猴。入池饮水已上岸。见此鳖张口而眠。时彼猕猴便欲作淫法。即以身生内鳖口中。鳖觉合口藏六甲里。如所说偈言

  愚痴人执相　　犹如鳖所咬
  失修摩罗捉　　非斧则不离

时鳖急捉猕猴却行欲入水。猕猴急怖便作是念。若我入水必死无疑。然苦痛力弱。任鳖回转。流离牵曳遇值崄处。鳖时仰卧。是时猕猴两手抱鳖。作是念言。谁当为我脱此苦难。猕猴曾知仙人住处。彼当救我。便抱此鳖向彼处去。仙人遥见便作是念。咄哉异事。今是猕猴为作何等。欲戏弄猕猴故。言婆罗门。是何等宝物满钵持来。得何等信而来向我。尔时猕猴即说偈言

  我愚痴猕猴　　无辜触恼他
  救厄者贤士　　命急在不久
  今日婆罗门　　若不救我者
  须臾断身生　　困厄还山林

尔时仙人以偈答言

  我令汝得脱　　还于山林中
  恐汝猕猴法　　故态还复生
  尔时彼仙人　　为说往昔事
  鳖汝宿命时　　曾号字迦叶
  猕猴过去世　　号字憍陈如
  汝作淫欲行　　今可断因缘
  迦叶放憍陈　　令还山林去

佛告诸比丘。尔时仙人岂异人乎。即我身是。鳖者婆罗门是。是时猕猴者优陀夷是本为兽时蒙我得脱。今复蒙我重得解脱。诸比丘白佛言。世尊。云何是优陀夷。于支梨沙弥尼如女乃起欲想。佛告诸比丘。不但今日是优陀夷。于支梨如女而起欲想。过去世时已曾于是女起淫欲想。诸比丘白佛言。世尊。已曾尔耶。佛言如是。过去世时有婆罗门。姓嵩渠氏。田作生活。索得一妇。端正姝好共相娱乐。便生一女亦复端正。为作名字。以嵩渠姓故。字为嵩渠。至年长大。诸种种姓婆罗门遣信来索。时女问母。此何客来。答言索汝。其女白母。我不欲嫁乐修梵行。母言不尔。男女之法要有嫁娶。女复白言。若父母见爱念者愿莫嫁我。时父母爱女故。不能苦违。答言任意。时邻里知识皆悉知之。云何是女端正姝好。而能守志乐修梵行。皆爱念之。时婆罗门入田耕作。妇常送食。遇于一时其妇有事。遣女嵩渠送食与父。时婆罗门不正思惟便生欲想。忆念妇至当共行欲。见持食来。便舍犁往迎。欲心迷醉不能自觉。不应触处父辄触之。时女嵩渠便涕泣而住。时婆罗门即便念言。此女嵩渠常不乐欲。众人所叹。今我触之而不大唤。似有欲意即说偈言

  今我触汝身　　低头长叹息
  将不欲与我　　共行淫欲法
  汝先修梵行　　众人之所敬
  而今软相现　　似有世间意

尔时嵩渠女以偈。答父言

  我先恐怖时　　仰凭于慈父
  本所依怙处　　更遭斯恼乱
  今在深榛中　　知复何所告
  喻如深水中　　而更生于火
  根本荫覆处　　而今恐怖生
  无畏处生畏　　所归反遭难
  林树诸天神　　证知此非法
  不终生养恩　　一朝见困辱
  地不为我开　　于何逃身命

时婆罗门闻女说颂。大自惭愧即便而去。佛告诸比丘。尔时婆罗门者。岂异人乎。今优陀夷是。时婆罗门妇者。今优钵罗比丘尼是。时女嵩渠者。今支梨沙弥尼是。本已曾于此女生欲想故。今续复起。佛告诸比丘。依止舍卫城住者皆悉令集。以十利故。为诸比丘制戒。乃至已闻者当重闻。若比丘淫欲变心。与女人身相摩触。若捉手若捉发编。及余身分摩触。受细滑者僧伽婆尸沙。比丘者如上说淫欲者。染污心也。变心者。变名过去心。灭尽变易是亦名变。但此中变易者。于根力觉道种变易也。心者。意识也。女人者。母姊妹亲里非亲里。若大若小在家出家。捉手者。若捉手若捉腕乃至一指。是名捉手。编者。有八种。何等八。一者发编。二者珠编。三者线编。四者花鬘编。五者树皮编。六者草编。七者毛编。八者韦编。若合发捉。此八种编者。犯八种僧伽婆尸沙。离发捉七种编者。犯七种偷兰罪。身相触者。身身相触也。余身分者。除发编。余身分是也。摩者。逆顺遍摩也。着细滑者。逆顺摩时。身触受细滑也。僧伽婆尸沙者如上说。若比丘染污心捉女人发编。若举若按若牵若推若抱若呜若推若拍者。僧伽婆尸沙。若比丘欲捉此而触余。欲触余而触此。欲触此而触此。欲触余而触余。乃至推拍者。僧伽婆尸沙。意谓是女而是黄门。捉发乃至推拍得偷兰罪。谓是黄门而是女人。乃至推拍僧伽婆尸沙。谓是女人而是女人。乃至推拍僧伽婆尸沙。谓是黄门而是黄门。乃至推拍偷兰罪。谓是女人而是男子。乃至推拍得越比尼罪。谓是男子而是女人。乃至推拍僧伽婆尸沙。谓是女人而是女人。乃至推拍僧伽婆尸沙。谓是男子而是男子。乃至推拍得越比尼罪。黄门男子亦如是。若比丘欲心逐女人。女人走入众女间。就中牵此女人者。僧伽婆尸沙。若欲心触众女人者。随所触僧伽婆尸沙。而不触者得偷兰罪。若比丘欲心逐女人。女人走入众黄门中。就中牵此女人者。僧伽婆尸沙。比丘若欲心触众黄门者。随所触得偷兰罪。而不触者。得越比尼罪。若比丘欲心逐女人。女人走入众男子中。就中牵女人者。得僧伽婆尸沙。若欲心触诸男子者。随所触得越比尼罪。而不触者。得越比尼心悔。若比丘欲心逐黄门。黄门走入众黄门中。就中牵此黄门者。得偷兰罪。若欲心触除黄门者。随所触得偷兰罪。而不触者。得越比尼罪。若比丘欲心走逐黄门。黄门走入众女人中。就中牵黄门者。得偷兰罪。若欲心触余女人者。随所触僧伽婆尸沙。而不触者得偷兰罪。若比丘欲心逐黄门。黄门走入众男子中。就中牵者得偷兰罪。若欲心触余男子。随所触得越比尼罪。而不触者。得越比尼心悔。若比丘欲心逐男子。男子走入众男子中。就中牵此男子者。得越比尼罪。若欲心触余男子。随所触得越比尼罪。而不触者。得越比尼心悔。若比丘欲心逐男子。男子走入众女人中。就中牵此男子者。得越比尼罪。若欲心触余女人者。得僧伽婆尸沙。而不触者得偷兰罪。若比丘欲心走逐男子。男子走入众黄门中。就中牵此男子者。得越比尼罪。若欲心触余黄门者。随所触得偷兰罪。而不触者。得越比尼罪。若比丘欲心一时触众多女人。得一僧伽婆尸沙。若一一别触。一一得僧伽婆尸沙。若比丘坐时。有女人来礼比丘足。比丘若起欲心。当正身住。应语女人言。小远作礼。抄女人笃信卒来接比丘足者。尔时应自咬舌令痛不令觉女人细滑。若女人从比丘索水者。应语知水家与。不应自捉灌浇女人手。应以器盛与。若无器者令净人与。若无净人者。比丘应着灌若床上若机上授与。语言。可取水饮。若比丘与女人共一床坐非威仪。若起欲心越比尼罪。故动床不相触者偷兰罪。若共一器食若共盘食。一床坐卧亦如是。若比丘与女人共床卧相触。犯僧伽婆尸沙。若中间比丘坐女人卧。女人坐比丘卧。随坐时卧时随相触。一一僧伽婆尸沙。若比丘知法多诈与女人相抱共卧共起。竟宿不移者。犯一僧伽婆尸沙。若比丘与女人共结鬘者非威仪。若染污心越比尼罪。若欲心动鬘不相触者偷兰罪。若比丘与女人共蹈井上危木汲水者非威仪。若有欲心越比尼罪。若欲心动木者偷兰罪。若不动者无罪。若中间有男子者无罪。若比丘与女人共一绳汲水非威仪。若起欲心越比尼罪。若欲心动绳偷兰罪。若比丘与女人共井汲水。若比丘下灌时女人欲下。当语言。姊妹小住。待我灌出竟然后下。若井栏动共汲水者非威仪。若起欲心者越比尼罪。欲心动井栏得偷兰罪。若井栏不动无罪。中间有净人者无罪。若比丘入聚落中。到信心优婆塞家。时优婆塞优婆夷言。我欲得一宿供养佛。愿师佐我施供养具。比丘言可尔。若比丘共女人举柱欲竖者非威仪。若有欲心越比尼罪。若欲心动柱者偷兰罪。若比丘与女人共张施供养具。若竹木苇各捉一头者非威仪。若有欲心。得越比尼罪。若欲心动竹木苇者。得偷兰罪。如是帐缦衣锦罽画像乃至花鬘诸物。比丘与女人共各捉一头非威仪。若有欲心得越比尼罪。若欲心动彼物者得偷兰罪。若比丘共女人舁石蜜瓶非威仪。若有欲心得越比尼罪。若欲心动瓶。得偷兰罪。乃至一切诸动器物亦如是。若比丘与女人共行香花油者。女人捉器。比丘过花。比丘捉器。女人过花。非威仪。若有欲心。得越比尼罪。若欲心动器。得偷兰罪。若竟夜听法者。当各于异壁下相远敷座。若无是处。当于露地。若不容受者。中间当以木为齐限。听法讫已。持种种杂物布施。所谓床褥若衣等若宝器等。若比丘共女人捉物咒愿者非威仪。若有欲心。得越比尼罪。若欲心动彼物。得偷兰罪。明旦比丘与女人共行。种种饮食乃至行盐若比丘捉器女人行。若女人捉器比丘行。非威仪。若有欲心。得越比尼罪。若欲心动器。得偷兰罪。若比丘于女人边受器行者不犯。若有女人欲担重物。不能上肩。便请比丘佐扶。比丘不应佐扶。若有余男子女人者。比丘应教令佐扶。若无余人者。比丘应自举。是物着高处令其就担。若比丘与女人共于虚动地行非威仪。若有欲心。得越比尼罪。若有欲心动地。得偷兰罪。若比丘与女人共行。可动辂上渡水非威仪。若有欲心。得越比尼罪。若欲心动辂得偷兰罪。若辂不动无罪。中间有男子者无罪。若比丘下辂。时见女人来。当返还使女人过竟。比丘便下。若道宽不动无罪。中间有男子者不犯。若比丘与女人共行长板上者非威仪。若有欲心。得越比尼罪。若有欲心动板。得偷兰罪。若板不动中间有男子者无罪。若比丘与女人共行水中。比丘在后脚蹴水灒女人者。非威仪。若有欲心。得越比尼罪。若欲心蹴水着女人者。得偷兰罪。若比丘与女人共船上行。比丘当在男子所住处住若正有一住处者。比丘当正念而住。若有异心相触者。僧伽婆尸沙。若船没时。女人水漂向比丘。比丘作地想持出水不犯。若有欲心。得僧伽婆尸沙。若比丘河边经行。有女人落水中。作哀苦声。求比丘救者。比丘作地想捉出不犯。若授竹木绳牵出不犯。若比丘言知汝虽苦当任宿命者无罪。若女人急捉比丘者。比丘当正念住。若心有异。合粗厚衣捉者。得偷兰罪。若软薄衣合捉者。得僧伽婆尸沙。若比丘入城时。若王出若大会日多人出入。比丘当住伺人小希然后乃入。若随多人男女比入者非威仪。乃至有欲心触。僧伽婆尸沙。若比丘入城乞食。过到淫女家淫女捉比丘者。当正思惟若比丘乞食时。有端正女人持食与比丘。比丘见女人起欲想者。应放钵着地令余人授。若女人持食与比丘。若女人一手过食。一手承钵底者非威仪。若有欲心乃至触。僧伽婆尸沙。若比丘陜道巷中与女人相逢。比丘应住待女人过。若竞行者非威仪。若有欲心乃至触。僧伽婆尸沙。若比丘与母姊妹亲里等久别相见。欢喜抱捉比丘。比丘当正忆念住。若有异心者。僧伽婆尸沙。若比丘至檀越家时。女人抱小儿。着比丘膝上。不犯。若比丘就女人手中。捉小儿者非威仪。若有欲心者。得越比尼罪。展转相动者。得偷兰罪。若手触彼女人。僧伽婆尸沙。若比丘入城。若王出若大会日。若多男女出入。比丘应住须人小希比丘便入。若时有狂象狂马狂牛奔车失火逼时。诸恐怖事疾入者无罪。若比丘诸大会时。所谓佛生处。得道处。转法轮处阿难大会处。罗睺罗大会处。般遮于瑟大会处。是诸大会时多人来看。若女人持珠环璎珞衣物寄比丘。若不净物应令净人取。若净物应自手取。女人还索时。不净物令净人还。若净物自手还。不得为女人着。著者犯越比尼罪。若触女人身者僧伽婆尸沙。若触黄门偷兰罪。若触男子越比尼罪。若触一切畜生女者。越比尼罪。若紧那罗女及猕猴女偷兰罪。若人女边僧伽婆尸沙。黄门边偷兰罪男子边越比尼罪。若女人边偷兰罪。黄门边越比尼罪。男子边越比尼心悔。若女人边越比尼。黄门边越比尼心悔。男子边不犯。若女人边越比尼心悔。黄门男子不犯。是故说。若比丘淫欲变心。与女人身相摩触。若捉手若捉发编。及余身分摩触。受细滑者僧伽婆尸沙(第二戒竟)

佛住王舍城迦兰陀竹园。广说如上。时净居天。以转轮王所应服。药价直百千授与耆旧耆旧药师作是念。今日世间谁最尊重。世间第一。当持此药以奉上之寻复念言。唯有如来。最尊第一。当以此药奉上世尊。尔时耆旧童子往诣世尊所。礼世尊足却住一面白佛言。净居天与我是治转轮王药价直百千。我作是念。世间谁最尊重第一应与此药。寻复念言。唯有如来。世之尊重。今以此药奉上世尊。唯愿哀愍纳受此药。佛告耆旧。如来应供正遍知。淫怒痴垢习障永尽。唯有坚固平等妙身。无有众患应服此药。尔时耆旧复白佛言。世尊。如来应供正遍知平等妙身。虽无众患。哀愍我故。愿受此药。当为来世弟子开示法明。病者受药施者得福。尔时世尊默然而受。耆旧复念。今不可令世尊如常人法服药。当取青莲花叶熏药令香与世尊嗅之。尔时世尊。便嗅青莲花叶香药。势十八行下。世尊下已光相不悦。时瓶沙王。与诸群臣眷属俱往问疾。时王舍城有五百淫女。亦诣世尊礼拜问疾。时瓶沙王诣世尊所问疾已。群臣侍从次入问疾。时五百淫女。或乘象马车舆欲来问疾。中有入者有不入者。有与年少入园林中游诸浴池。五欲自娱。歌舞戏笑。有一淫女。贫穷弊衣无人共语。便诣优陀夷所白言。阿阇梨。我欲入看。优陀夷言。可尔。汝若不请尚欲呼汝况汝求请。即便入房。时优陀夷亦示诸房舍种种彩画。优陀夷问言。姊妹房舍好不。答言实好。便问姊妹。能共作是事不。答言。阿阇梨。我仰作是事活。若男子者来。优陀夷言。姊妹。汝可卧地。即时卧地。复言右胁卧。即右胁卧。复教左胁卧。即左胁卧。复教仰卧。即便仰卧。复教匍匐。即便匍匐。时优陀夷即便唾之脚蹴令倒。便言姊妹起。我已作竟。尔时淫女便嗔恚言。此非沙门辞谢之法。时有坐禅比丘。先入房闇处坐遥见是事。语诸比丘。诸比丘即以是事往白世尊。佛言。呼优陀夷来。即便呼来。来已佛问优陀夷。汝实尔不。答言。实尔。佛问优陀夷。汝以何心。答言。欲心。复问优陀夷。汝欲作淫事耶。答言。不欲作。我但戏耳。佛言。此是恶事。优陀夷。我常不种种呵责淫欲想赞叹离欲耶。汝今云何作此恶行。优陀夷。此非法非律非是佛教。不可以是长养善法。佛告诸比丘。依止王舍城比丘皆悉令集。以十利故。为诸比丘制戒。乃至已闻者当重闻。若比丘淫欲变心。与女人说丑恶语。随顺淫欲法。如年少男女者。僧伽婆尸沙。比丘者。如上说。淫欲者。染污心也。变心者。变名过去心。灭尽变易。是亦名变易。但此中变易者。于根力觉道种变易也。心者。意识也。女人者。亲里非亲里若大若小在家出家。说淫欲语者。向彼说。恶语者。呵骂形呰。称说顺淫欲者。说非梵行事。如年少男女者。如年少少年年少中年年少老年。如中年年少中年中年中年老年。如老年年少老年中年老年老年。如年少男女法者。皆僧伽婆尸沙。僧伽婆尸沙者。如上说。若比丘于女人起欲心说。若欲作若不欲作。誉毁语问求请睹骂直说。作者。欲舍沙门法为淫欲事。是名作。不作者。不欲舍沙门法。虽言我当作淫欲。而实不为。是名不欲作。誉毁者。于八处若誉若毁。所谓两唇两腋两乳两胁腹脐两髀两道。唇者。言好唇赤唇齐整唇石榴花唇。作是称誉者。僧伽婆尸沙。若言丑唇垂唇粗唇猪唇唇如井口。作是毁者。僧伽婆尸沙。腋者。好腋平腋无毛腋香腋。若言臭腋深腋多毛腋垢腋。作如是誉毁者。僧伽婆尸沙。乳者。好乳圆乳石榴乳金撄乳两乳齐出。若言丑乳垂乳大乳猪乳狗乳药囊乳。如是等誉毁者。僧伽婆尸沙。胁者。好胁平胁辘轳胁。若言丑胁垂胁。如是等誉毁者。僧伽婆尸沙。腹者。好腹平腹。若言丑腹大腹垂腹。如是等誉毁者。僧伽婆尸沙。脐者。好脐深脐水漩脐。若言丑脐大脐凸脐。作如是誉毁者。僧伽婆尸沙。髀者。好髀圆髀佣髀象鼻髀。若言恶髀瘦髀。作如是誉毁者。僧伽婆尸沙。两道者说名僧伽婆尸沙。是名八事。染污心誉毁者。僧伽婆尸沙。语者。语女人言。如汝母姊妹曾从事人。若夫若叔语汝者。汝当随作。作是语者。僧伽婆尸沙。问者。问女人言。汝曾从事人。若夫若叔在何处作。夜几时作。作如是问者。僧伽婆尸沙。求者。比丘言。如人求汝母姊妹。曾从事人法求汝。以是事可得衣食。作如是说者。僧伽婆尸沙。请者。语女人言。我已请诸天神。得与汝和合。当报此愿。作如是说者。僧伽婆尸沙。睹者。作是言今当共比知。谁唇好我耶汝耶。不好当顾物。如是两腋两乳两胁腹脐两髀。皆当共比知。谁好我耶汝耶。不好当顾物。及两道称名。僧伽婆尸沙。骂者。欲心骂言。如驴马等。种种字名者。僧伽婆尸沙。直说者。直言当共作是事。僧伽婆尸沙。比丘欲心于女人。若欲作若不欲作。誉毁语问求请睹骂直说。僧伽婆尸沙。起欲心欲向此而向余。欲向余而向此。欲向此而向此。欲向余而向余。乃至直说僧伽婆尸沙。若比丘于女人起欲心。向黄门乃至直说。偷兰罪。若比丘于黄门起欲心。向女人乃至直说。僧伽婆尸沙。若比丘于女人起欲心。向女人乃至直说。僧伽婆尸沙。若比丘于黄门起欲心。向黄门乃至直说。偷兰罪。若比丘于女人起欲心。向男子乃至直说。越比尼罪。若比丘于男子起欲心。向女人乃至直说。僧伽婆尸沙。女人向女人亦尔。若比丘于男子起欲心。向男子乃至直说。越比尼罪。黄门男子亦如是。若比丘欲心向女人。说淫欲。顺淫欲。隐覆。傍语。妊身。淫欲者。言姊妹共作是事。是名淫欲。顺淫欲者。比丘言女人所欲得物。若男子若涂香若花鬘衣服璎珞。当作是事是名顺淫欲。隐覆者。若比丘向女人。作隐覆语言。姊妹沐浴来啖果来出毒来。作如是等种种谬语。是名隐覆。傍语者。若比丘于一女人有欲心。向傍女人说八处。若此一女人。知比丘欲心向己者。是比丘得八僧伽婆尸沙罪。此一女人不知者。得六偷兰罪二僧伽婆尸沙。若比丘欲心于一女人。即向此女人誉毁余女人八处。若此女人知此比丘欲心向己者。是比丘得八僧伽婆尸沙。不知者得六偷兰罪二僧伽婆尸沙。若比丘于女人有欲心。即向此女人说黄门八处。是女人知比丘有欲心向己者。犯八僧伽婆尸沙。不知者六偷兰罪二僧伽婆尸沙。若比丘于一女人有欲心。即向此女人说男子八处。是女人知比丘有欲心向己者。犯八僧伽婆尸沙罪。不知者六偷兰罪二僧伽婆尸沙。若比丘于一黄门有欲心。向余黄门誉毁八处。若此黄门知比丘有欲心向己者。得八偷兰罪。若不知者得六越比尼二偷兰罪。若比丘于一黄门有欲心。即向此黄门。誉毁余黄门八处。若是黄门知比丘有欲心向己者。是比丘得八偷兰罪。若不知者。得六越比尼罪二偷兰罪。若比丘于此黄门有欲心。即向此黄门誉毁女人八处。若此黄门知比丘有欲心向己者。是比丘犯八偷兰罪。不知者得六越比尼罪二偷兰罪。若比丘于此黄门有欲心。即于黄门前誉毁男子八处。若此黄门知比丘有欲心向己者得八偷兰罪。若不知者得六越比尼罪二偷兰罪。若比丘于一男子有欲心。向余男子誉毁八处。是男子知比丘有欲心向己者。得八越比尼罪。若不知者。六越比尼心悔二越比尼罪。若比丘于此男子有欲心。即于此男子前誉毁余男子八处。是男子知比丘有欲心向己者。犯八越比尼罪若不知者。得六越比尼心悔二越比尼罪。若比丘于男子有欲心。即此人前誉毁女人八处。是男子知比丘有欲心向己者。得八越比尼罪。若不知者。六越比尼心悔二越比尼罪。若比丘于男子有欲心。即向男子说黄门八处。若是男子知比丘有欲心向己者。得八越比尼罪。若不知者。得六越比尼心悔二越比尼罪。是名傍说。妊娠者。若妊娠女人来入寺中礼比丘足。语女人言。咄咄奇。优婆夷。汝已开门已受染色。汝夜都不眠。作不净业。此非梵行。是淫欲果耳。作是语者。僧伽婆尸沙。是名妊身。若女人前誉毁。得僧伽婆尸沙。黄门前得偷兰罪。若男子前得越比尼罪。若向紧那罗女猕猴女。得偷兰罪。向余畜生女说。得越比尼罪。若女人边。得僧伽婆尸沙。黄门边偷兰罪。男子边越比尼罪。若女人边偷兰罪。黄门边越比尼罪。男子边越比尼心悔。若女人边越比尼罪。黄门边越比尼心悔。男子边无罪。若女人边越比尼心悔。黄门男子边无罪。是故说若比丘淫欲变心。与女人作粗恶语。随顺淫欲法。如年少男女者。僧伽婆尸沙(第三戒竟)

佛住舍卫城。广说如上。时长老优陀夷有旧知识婆罗门。语优陀夷言。我欲余行。长老。能时时往返看我家中妇儿不。优陀夷言。婆罗门汝不相嘱。尚欲经营。况复嘱。我婆罗门便余行去时。优陀夷着人聚落衣持钵到婆罗门舍。婆罗门妇见长老优陀夷来。恭敬起迎言。善来阿阇梨。久不相见。今乃屈顾。请令入坐。即便就座。优陀夷言。我今希来。汝能少有所与不。婆罗门妇言。有种种饮食。随有所敕尽当相与。优陀夷言。此诸饮食诸信心家处处皆得。但我出家人所难得者。汝得自在。当持与我。婆罗门妇言。不知何者是出家人之所难得物。我得自在。当见示语。若我家有者当持相与。家中无者当于余处求索相与。优陀夷言。汝足知是事。何以不知。汝多情诈如贼有四眼。何所不知。婆罗门妇言。我实不知。当见告语。家中有者。当持相与。家中无者当于余处买索相与。为何所须。优陀夷言。汝足知是事。何以不知此最第一供养。所谓交通。如我沙门持戒行善法修梵行。以此法供养我。所谓随顺淫欲法。时婆罗门诸妇中有少年者。即便惭愧低头徐行。各还自房。有中年者。亦各惭愧低头而住。有年老者即便呵责言。阿阇梨优陀夷。此非善事不应作是非类语。此是婆罗门家。而作淫女家法相待耶。我当以是事白诸比丘。优陀夷言。白与不白当随汝意。作是语已。便舍出去。出是家已。复入诸淫女舍。诸淫女辈皆起迎恭敬问讯言。善来阿阇梨优陀夷。久不相见今乃屈意。便请令就坐优陀夷言。今我希来。汝能少有所与不。诸淫女言。有种种饮食随有所须。有所约敕尽当相与。优陀夷言。此饮食诸信心家处处皆得。但我出家人所难得者。汝得自在。当持与我者善。诸淫女言。我今不知何物是出家人所难得者。当见示语。家中有者当持相与。家中无者当于余处求索相与。优陀夷言。汝足知是事。何以不知。汝多情诈如贼有四眼。何所不知。如是乃至三说。诸淫女辈犹言不知。优陀夷言。汝足知是事。何以不知此最第一供养。所谓交通。如我沙门持戒行善法修梵行。以此法供养。所谓随顺淫欲法。时淫女中有年少者。便拍手大笑。有中年者。便作是言。我正仰是活命。汝若是男子者便可来。中有老年者。便作是言。阿阇梨优陀夷。我虽以是自活。汝不护沙门法耶。我当以是事白诸比丘。优陀夷言。白与不白。自随汝意。作是语已。便舍而去。诸淫女辈。即语诸比丘。诸比丘以是事具白佛。佛言。唤优陀夷来。来已佛以上事。广问优陀夷。汝实尔不。答言。实尔。世尊。佛言。优陀夷。此是恶事。汝常不闻。我种种因缘呵责淫欲。种种因缘赞叹离欲耶。汝云何作此恶不善事。优陀夷此非法非律。非是佛教。不可以是长养善法。佛告诸比丘。依止舍卫城比丘。皆悉令集。以十利故。为诸比丘制戒。乃至已闻者当重闻。若比丘淫欲变心。于女人前叹自供养身。言姊妹。如我沙门持戒行善法修梵行。以是淫欲法。供养赞叹者。僧伽婆尸沙。比丘者。如上说。淫欲者。染污心也。变心者。变名过去心灭尽变易。此亦名变易。但此中变易者于根力觉道种变易也。心者。意识也。女人者。亲里非亲里。若大若小在家出家。叹自供养身者。叹自己身也。言姊妹如我沙门持戒行善法修梵行。以淫欲法供养第一者。僧伽婆尸沙。僧伽婆尸沙者。如上说。若比丘染污心。于女人前语女人言。汝若欲得第一胜长。自在大自在。无比无相似。得最胜处。得长处。得解脱处。得无比处。得无相似处。身无病。母无病。父无病。亲里无病。眷属无病。福德名称。多人爱多人念。多人喜多人所尚。得寿得色得乐。得势力。得眷属。得善趣。得三十三天。得天后。得天眼。清净耳垂埵者。如我沙门持戒行善法修梵行。应以此法奉之事之。恭敬尊重。承望供养。所与不惜。舒展广舒展。随顺取随顺受。是中初三十事。一一犯越比尼罪。次八事一一犯偷兰罪。后十二事一一犯僧伽婆尸沙。若比丘起欲心。欲向此而向余。欲向余而向此。欲向此而向此。欲向余而向余。若比丘于女人起欲心。向黄门说第一乃至随顺受。初三十事犯越比尼心悔。次八事犯越比尼罪。后十二事犯偷兰罪。若比丘于黄门有欲心。向女人说第一乃至随顺受。初三十事犯越比尼罪。次八事犯偷兰罪。后十二事犯僧伽婆尸沙。女人于女人亦如是。若比丘于黄门有欲心。向黄门说第一乃至随顺受。初三十事犯越比尼心悔。次八事犯越比尼罪。后十二事犯偷兰罪。若比丘于女人有欲心。向男子说第一乃至随顺受。初三十事及次八事犯越比尼心悔。后十二事犯越比尼罪。若比丘于男子起欲心。向女人说第一乃至随顺受。初三十事犯越比尼罪。次八事犯偷兰罪。后十二事犯僧伽婆尸沙。女人于女人亦复如是。若比丘于男子起欲心。向男子说第一乃至随顺受。初三十事次八事犯越比尼心悔。后十二事犯越比尼罪。黄门男子四句亦如是。若于女人叹自供养。僧伽婆尸沙。于黄门得偷兰罪。于男子得越比尼罪。于紧那罗女猕猴女。犯偷兰罪。畜生女犯越比尼罪。若比丘女人边。得僧伽婆尸沙。黄门边得偷兰罪。男子边犯越比尼罪。若女人边偷兰罪。黄门边越比尼罪。男子边越比尼心悔。若女人边越比尼罪黄门边越比尼心悔。男子边不犯。若女人边越比尼心悔。黄门男子边无罪是故世尊说。若比丘淫乱变心。于女人前叹自供养身言。姊妹。如我沙门持戒行善法修梵行。以是淫欲法供养赞叹者。僧伽婆尸沙(第四戒竟)

摩诃僧祇律卷第五摩诃僧祇律卷第六

        东晋天竺三藏佛陀跋陀罗共法显译

    明僧残戒之二

佛住舍卫城。广说如上尔时有长老比丘。名迦罗。时到着入聚落衣持钵入城。次行乞食。到一田家。其家母人遥见长老迦罗。便起迎之。恭敬问讯。善来阿阇梨。久不相见。莫如余家作疏外意。如自家想。请令入坐。迦罗即坐。时母人礼迦罗足已。于一面立。其家男女皆来礼迦罗足已。于一面立。时有大儿后来礼足已。于一面立。迦罗问言。是谁家儿。母人答言。此是我儿。迦罗问言。为婚娶未。答言。未婚。迦罗言。应为娶妇。莫令在外作诸过恶。迦罗复问。颇有拟宜处不。答言。有某家。有女遣信。往索不得。问言。何故不得。答言。彼作是语。我欲令无子有子无女有女。如我一目。亦为我子亦为女婿。我当与之。我今何为。为彼女故。放子令去。迦罗言。如汝所言。彼是愚人。谁当为女放舍。其子如人所说。女生外向。虽生王家。随嫁娶法。会当出去。如汝本时。亦从外来。然我亦出入彼家。当为汝男求索。彼女答言。善哉阿阇梨。迦罗比丘。即出是家。往诣彼家。彼家母人见迦罗来。即出来迎恭敬问讯。善来阿阇梨。久不问讯莫如余家作疏外意。今于我家如自己想。请令入坐。坐已礼迦罗足。于一面立。其家男女亦前礼足。于一面立。时有一大女。后来礼足。迦罗问言。此是谁女。答言。我女。问言。嫁未。答言。未嫁。迦罗言。应早处分。莫令在外脱生诸过。迦罗复问。颇有来索者不。答言。有某甲家。曾索不与。问何故不与。答言。阿阇梨。我欲令无子有子无女有女。如我一目。亦为我女婿。亦如我儿。来就我家。当以女与之。我今何为为他男故。舍女令去。迦罗言。怪哉汝是愚人。何闻由来嫁男就女。如汝本时。云何来就他人。如所说。女生外向。虽生王家。亦随嫁娶法。会当出门。然彼男家是我檀越。汝嫁女与之可得富乐。其母答言阿阇梨意欲尔耶。答言。欲尔即便许可。迦罗即还男家语男家妇言。已得彼女。所应为者宜及时为。时二家俱富。各送礼具成其婚姻。女适男家。每执苦事遂生劳患。卧到日出时。姑唤言。何以不起。汝不知妇礼。晨朝当起扫洒执作。瞻视宾客如是再三语。妇故不从教。其姑极生苦厌。而作是言。坐是迦罗遗我此苦。为我求此无手足物。尔时儿妇复啼泣言。坐是迦罗遗我此苦。云何持我陷火坑中。尔时女母闻之。复嗔恚言。我女在家婉乐少事。今在男家多务辛苦。终日啼泣。云何迦罗。安我女着弊恶家。迦罗比丘为二家所嗔。诸比丘以是因缘。广白世尊。佛言。唤迦罗比丘来。即便唤来已。佛问迦罗。汝实作是事不。答言。实尔世尊。佛言。迦罗。汝常不闻。我无数方便呵责和合欲法。无数方便赞叹离欲法。汝今云何和合欲法。是为恶事。今因汝故当为诸比丘制戒。佛告诸比丘。依止舍卫城比丘。皆悉令集。以十利故。为诸比丘制戒。乃至已闻者当重闻。若比丘受他使行和合男女。若娶妇若私通。乃至须臾顷者。僧伽婆尸沙。比丘者。如上说。使者。受使事。行者。往来。和合者。和合男女也。妇者。终身妇也。私通者暂交会也。乃至须臾顷者。乃至和合令须臾间会者。亦犯僧伽婆尸沙。僧伽婆尸沙者。如上说。若孤女无父无母无亲里。若俱无。若自立若依他立。若依亲里立。若俱立。孤无母者。谓女无母。依父生活。是名无母。若有男子欲求此女为妇。倩比丘往求。比丘许者。犯越比尼罪。往向彼说犯偷兰罪。得不得还报时。犯僧伽婆尸沙。孤女无父者。有女无父依母生活。是名无父孤女。若有男子。欲求此女为妇。倩比丘往求此女为妇受彼使者。犯越比尼罪。往向彼说犯偷兰罪。得不得还报时。犯僧伽婆尸沙。无亲俱无亦复如是。自立者。无父无母。无亲里自活。若有男子欲求此女为妇。倩比丘往女所。受彼使者。犯越比尼罪。往向女说。得偷兰罪。得不得还报时。犯僧伽婆尸沙。依他立者。若女无亲而依他立。若有男子欲得此女为妇。倩比丘往。受彼使者。犯越比尼罪。往向彼说偷兰罪。得不得还报时。犯僧伽婆尸沙。依亲及俱亦复如是。若孤儿无母无父无亲。俱无自立。依他依亲。依俱无母者。若孤儿无母。依父生活。此儿欲求他女为妇。倩比丘往受彼使者。犯越比尼罪。往向彼说犯偷兰罪。得不得还报时。僧伽婆尸沙。乃至依俱亦复如是。若家内同产。先要罚榛王绩缕。作食取水。无子继嗣家内者。若有人养他小儿。教习长大。家中有所生女年亦长大。便作是念。我今此女年已长大。当出嫡他今日此儿是我所养。今已长大。何不以女嫁与此儿。当如我子。亦为女婿。不能自语。便倩比丘语此男儿言。我养育汝教学成就。年已长大。今我有女向当出门。欲令汝为我女婿。亦如我子。比丘受彼使者得越比尼罪。往向彼说犯偷兰罪。得不得还报时。犯僧伽婆尸沙。若彼养儿先自欲得其女。倩比丘往白其父亦复如是。同产者。若有同产兄丧。欲执嫂为妇。倩比丘往语其嫂。乃至得不得还报时。犯僧伽婆尸沙。先要者若有男子。共他妇通。其妇语此男子言。若我夫嗔苦治我罪。驱出门者汝当取我。答言。可尔。时彼妇人便故恼其夫。令其忿恚。苦治驱出。彼男子闻已。不能自往。便倩比丘。往语妇人。汝已为夫苦治驱出。当来就我。比丘受使。乃至得不得还报时。犯僧伽婆尸沙。若复女人欲乐男子。不能自语。便倩比丘。往语男子。我已为夫苦治驱出今欲就汝为我作夫。比丘受使。乃至得不得还报时。犯僧伽婆尸沙。若是女人欲还。从本夫不能自语。倩比丘往语其夫言。还共生活。更不作过。比丘受使。乃至得不得还报时。僧伽婆尸沙。若复夫主还欲娶妇。不能自语。倩比丘往语本妇言。今听汝还。莫更作过。比丘受使。乃至得不得还报时。犯僧伽婆尸沙。罚者。若王欲取人女。不能自语。倩比丘往语其家言。我能罚汝家而取汝女。但不欲尔汝与我女。可得衣食庄严之具。自然不乏。又可饶益汝家。比丘受使。乃至得不得还报时。犯僧伽婆尸沙。榛王者。贼主也。若贼主欲取他女。不能自语。倩比丘往语其家言。我是林中王。能为汝作不饶益事。汝当送女。与我可得衣食严具。自恣并护汝家。比丘受使乃至得不得还报时。僧伽婆尸沙。绩缕者。若有寡妇纺绩自活。有男子欲得不能自语。倩比丘往语寡妇言。为我作妇。彼寡妇言。我若相就不能余作。唯能绩缕。须者当往。乃至得不得还报时。僧伽婆尸沙。作食者。若有寡妇。有男子欲得而不能自语。倩比丘往语寡妇言。来共生活。寡妇言。我但能作食不能余作。须者当往。乃至得不得还报时。僧伽婆尸沙。取水者。若有寡妇。有男子欲取此妇。不能自语。倩比丘往语寡妇言。来共生活。寡妇答言。我但能取水不能余作。须者当往。乃至得不得还报时。僧伽婆尸沙。无子者。若有男子都无子息。复有寡妇。亦无儿子。有男子欲得此寡妇。不能自语。倩比丘往语寡妇言。俱无子息来共合活。比丘受使。乃至得不得还报时。僧伽婆尸沙。若彼寡妇欲求男子。而不能自语。倩比丘往亦复如是。继嗣者。若有男女俱无子息。恐其死后。若堕饿鬼无所继嗣。时有男子欲得寡妇。不能自语。倩比丘往语寡妇言。来共汝生活。若我先死堕饿鬼者。汝当祠我。若汝先死我当祠汝。乃至得不得还报时。僧伽婆尸沙。若彼寡妇欲求男子亦复如是。若有女人母所护父所护。兄弟护姊妹护。自护种姓护。钱所护。童女寡妇他护母护者。有女人依母住有人欲得此女。遣比丘往语其母言。欲得此女为妇。乃至得不得还报时。僧伽婆尸沙。父护兄弟护姊妹护亦复如是。自护者。有女人无父母亲里。自作生活持戒自护。若有男子欲得此女。倩比丘往语。乃至得不得还报时。僧伽婆尸沙。姓护者。有女人无父母依同姓住。若有男子。欲求此女。倩比丘往语其同姓。乃至得不得还报时。僧伽婆尸沙。钱护者若女人负人钱未满。有男子欲得此女。倩比丘往语其家言。与我此女。我代与钱。乃至还报。僧伽婆尸沙。童女寡妇他妇亦复如是。若女人谷买得钱买得。若输钱女。半输女。尽输女。若一月住。若随意住。抄掠与花鬘无种须臾谷买得者。若女以谷买得。有男子欲得此女。倩比丘往语彼女言。为我作妇。乃至得不得还报时。僧伽婆尸沙。钱买得者亦复如是。输钱者。若有人养女索税钱。唯除自供。余者尽取。若有男子。欲求此女人。倩比丘往语。乃至还报。僧伽婆尸沙。半输尽输亦复如是。一月住者。若寡妇有男子。欲求为妇。倩比丘往语寡妇。寡妇答言。我不能长住。为可一月相就。若须者当往。乃至还报。僧伽婆尸沙。随意住者。有寡妇。男子欲求为妇。倩比丘往语寡妇。寡妇言。我不能长住。随我意几时住。须者当往。乃至还报。僧伽婆尸沙。抄掠得者。若人破他聚落抄得女人。若有男子欲求此女。倩比丘往语。乃至还报。僧伽婆尸沙。持花鬘者。有国土法。男子欲求女人为妇时。直遣人持花鬘往与女人家。若受花鬘便知得妇。若不受花鬘。便知不得。即遣比丘。持花鬘往与女家。乃至还报。僧伽婆尸沙。无种者。若男子无父亲。亦无母亲。又无知识。彼女亦尔是男子欲求彼女。倩比丘往语。乃至还报。僧伽婆尸沙。须臾者。若端正女人。有男子倩比丘往求须臾交会。乃至还报。僧伽婆尸沙。无子妇婢妇出家放淫女。淫女使人外淫女外淫女使人。若弃女。乞女。被遣女。下钱女。无子妇者。若有家富儿小便。为娶妇儿死。此儿妇小依止姑住。至其长大。有男子欲求此女。倩比丘往语言。汝儿既丧。我今便如汝儿无异。与我此妇。我当以衣食共相供给。乃至还报。僧伽婆尸沙。婢妇者。如诸国土有卖生口。若男子欲求为妇。欲言买为妇。恐责钱多。便倩比丘往密语妇言。我今买汝为婢。实持作妇。乃至还报。僧伽婆尸沙。出家者。若端正女人。于诸外道出家。有男子欲求此出家女为妇。倩比丘往语。乃至还报。僧伽婆尸沙。放者。放有二种。若卖若离婚。卖者。如颇梨国法有妇小嫌便卖。离婚者。有国土法。夫妇不相乐。乐便诣王所。输三钱半二张劫贝。而求断当听。使离婚。或有女人与他私通。共作要言。若我与夫离婚。当为汝作妇。答可尔。即持钱物求得离婚。彼男子闻已。便倩比丘。往语女人言。汝已离婚。来作我妇。乃至还报。僧伽婆尸沙。若彼女人倩比丘往语彼男子言。我已离婚。当为作妇。乃至还报。僧伽婆尸沙。淫女者。有男子倩比丘语淫女。与我交通。乃至还报。僧伽婆尸沙。淫女使人者。淫女婢也。亦如上说。外淫女者。有淫女恒在田野求人。有男子倩比丘往语。外淫女与我交通。乃至还报。僧伽婆尸沙。外淫女使人亦复如是弃女者。若女人他行妊娠。然后于诸外道中出家。月满生女。弃着四衢道中。有人取养。至年长大。有男子欲得此女。倩比丘往语。乃至还报者。僧伽婆尸沙。乞女者。若有人多男无女。从他乞女。养至年长大。有男子欲求为妇。倩比丘往语。乃至还报。僧伽婆尸沙。被遣女者。若有女人未出嫁时。共他私通。然后出嫡。婿知非童女。便遣还家。索本财物。先共通男子闻女被遣。便作是念此女由我令其被遣。我当取之。倩比丘往语彼父母。乃至还报。僧伽婆尸沙。下钱女者。若人娶妇输钱未毕。此女父母多索其钱。不能令满。而不得妇。女亦不得更嫁。有异男子。欲求此女。倩比丘往语其父母。与我此女。当与钱还本夫家。并复与汝。乃至还报。僧伽婆尸沙。若男子男子使语彼比丘。是比丘若从男子。及男子使闻已越比尼。往语彼者。偷兰罪。若自往。若遣使往得不得还报。僧伽婆尸沙。若孤女依外祖母。依外祖父。依外曾祖。依外舅。依外姨母。依祖父依祖母。依曾祖。依父舅。依父姨母。亦如上说。直曲相堪能。出入病王说法师。伴党共杂直者。有男子欲求他女。不能自语。倩比丘往语。受语者。犯越比尼罪。向彼说偷兰罪。若女家说言彼是刹利。我婆罗门。彼毗舍。我婆罗门。彼首陀罗。我婆罗门。或言。我刹利。彼婆罗门我毗舍彼婆罗门。我首陀罗。我婆罗门。或复言。彼是刹利。我毗舍。彼刹利。我首陀罗。或言。彼婆罗门。我亦婆罗门。彼刹利。我亦刹利。彼毗舍。我亦毗舍。彼首陀。我亦首陀。若得不得还报。僧伽婆尸沙。曲者。若男子欲求他女。不能自语。倩比丘往。比丘言。世尊制戒不得使行。口虽不许心然可者。犯越比尼罪。往语彼偷兰罪。得不得还报。犯僧伽婆尸沙。相者。若男子欲求他女。不能自语。倩比丘往。比丘言。佛制戒不得使行。然我当为汝作相。汝若见我着垢腻衣持破空钵。坐卑床上。口说奴婢语。当知不得。若复见我着鲜净衣。执持好钵。坐大床上。口说夫妇儿女。共汝言语。当知得相。如是作相得不得还报。僧伽婆尸沙。堪能者。若比丘众多诣檀越家食。食已优婆夷白比丘言。我欲取某家女作儿妇。当为我语之。诸比丘言。优婆夷。世尊制戒不得使行。其中有二三比丘。堪能行者。得越比尼罪。往语彼得偷兰罪。还报。犯僧伽婆尸沙。出入者。若比丘入出他家。受供养时。主人语言。我欲索某家女作儿妇尊者为我求之。比丘言。汝为我作饮食。当为汝求。主人言。为我儿得妇竟。当为尊者作饮食。比丘言我若动口无不得理。但当作食。即为作食者。犯越比尼罪。往语彼家言。汝知不。问言。何等。比丘言。我欲有所道。随我语者当道。主人言。但说。比丘言。人欲索汝女。问言。是谁。答言。某家子。主人嗔曰。我宁持女着水火中闇冥之处。终不与彼。比丘怖畏便走去。犯偷兰罪。若女人存在未嫁。是比丘先以夸说食他饮食惭羞。便还报言不得。僧伽婆尸沙。若彼女人或嫁或死。还报者。犯偷兰罪。病者。若比丘常出入一家。其家语比丘言。我欲索彼家女为妇。为我求之。比丘受语。得越比尼罪。往语彼得偷兰罪。彼家言。我女病知当死活。若男病者。彼言。彼家儿病。知当死活。而女与之。彼脱死者。令我女寡。比丘复言。夫人得病。皆当死耶。或自当差耳但当与之作是语时。偷兰罪。得不得还报。僧伽婆尸沙。王者。若王欲得他女。语比丘僧言。我今欲得索某家女。当为我求。一切僧许者。一切得越比尼罪。一切僧往求者。一切僧得偷兰罪。得不得还报者。一切僧犯僧伽婆尸沙。若众僧遣使。语彼家者一切僧得越比尼罪。语时一切僧得偷兰罪。得不得还报。时一切僧得僧伽婆尸沙。若受使者。作是思惟。我若还众中。俱使我白王。我不如即往白王。王当识我。如是者是比丘。得不得还报时。僧伽婆尸沙。一切僧故得先偷兰罪。法师者。有优婆塞家。欲索一优婆塞家女。彼不欲与彼言。我宁嫁与邪见外道。胜与优婆塞家。男家便作是念。谁能为我和合。唯有沙门。多诸方便。能说法者。当能为我和合之。便诣精舍。白法师言。我索彼家女。不欲与我。法师问言。彼何所道。答言。彼作是语。宁与邪见外道。不与是家。法师为我说同道之义。令彼与我。比丘许者。越比尼罪。若通请法师徒众令去。去者举众。得越比尼罪。若月八日十四日十五日说法时。男家女家二家尽来听法。尔时法师方便为说法。如佛契经告诸比丘。诸众生随性相得不信。不信者。共为亲好。如是犯戒犯戒相。亲无威仪。无威仪相亲无愧。无愧相亲懈怠。懈怠相亲乱心。乱心相亲无智。无智相亲。各随其类。共相亲好。过去当来及现在诸众生类。皆悉如是。譬如臭秽不净。自相和合。如是诸比丘诸众生类。各随其性笃信。笃信自相亲好。如是持戒。持戒相好有威仪。有威仪相好有愧。有愧相好精进。精进相好定意。定意相好智慧。智慧相好。过去当来及现在诸众生类。皆悉如是。譬如白净香熏之物。自相和合。法师作是说法已。语女家言。我闻彼儿欲索汝女。报彼言。宁与邪见外道。不与彼家。汝不闻。世尊说若有杀贼及以怨家。手执利剑。常伺人便欲得杀人。彼怨家子宁入其家。不入邪见外道之家。汝今云何欲嫁子女。与邪见家。与优婆塞者。时时可得见。诸比丘受斋持戒时。女家言。阿阇梨欲尔耶。答言。欲尔。彼言当与法师。尔时默然不语者。得偷兰罪。若法师不能忍。即坐上语。彼得者。僧伽婆尸沙。若复法师徒众中。唱言得者。亦得僧伽婆尸沙。共者。共受别说。别受共说。共受共说。别受别说。共受别说者。若比丘各各夏安居竟。游诸聚落与知识主人。别向余国行。尔时聚落中诸优婆夷言。为我儿索妇。为我兄弟索妇。为我叔索妇。如是种种诸优婆夷。各各说比丘一过。答言。可者犯一越比尼罪。诣彼处各别为求。各各犯偷兰罪。来还各别报者。各犯僧伽婆尸沙。别受共说者。若比丘各各夏安居竟。人间游行与诸檀越别。欲诣他国土。尔时诸优婆夷有语比丘言。为我儿求妇。有言为我兄弟求妇。为我叔求妇。若比丘各各许者。各各犯越比尼罪。若诣彼各别为求妇。各各别犯偷兰罪。来还已一语通报言。得犯一僧伽婆尸沙。共受共说者。若比丘各各夏安居竟。游行人间与诸檀越别。欲诣他国时。诸优婆夷语比丘言。为我儿求妇。为我兄弟求妇。为我叔求妇者。若比丘通。答言。可尔。犯一越比尼罪。若诣彼各别为求。各别偷兰罪。来还已通。答言。得犯一僧伽婆尸沙。别受别说者。若比丘夏安居竟。人间游行与诸檀越别。诸优婆夷言。为我儿求妇。为我兄弟求妇。为我叔求妇。比丘各别答言。可尔。各各犯越比尼罪。往诣彼各别为求各各犯偷兰罪。来还已。各各别报。各各得僧伽婆尸沙。杂者。有一比丘多知识将诸徒众。诣一家请食。食已时。家母人白上座言。我欲为儿求某家女为妇。上座当为我语。时上座不善知律相。即便许之。得越比尼罪。时诸徒众少知戒律。恐坏人心。不敢谏之。出彼家已。白上座言。何以作是。问言。何等事。答言。上座不知。世尊制戒不得和合男女耶。上座答言。不知中有。比丘言。上座莫求。我当为求彼求者得偷兰罪。得不得还报。僧伽婆尸沙。上座犯越比尼罪。若先优婆夷语彼徒众言。我为儿求某家女。当为我求。时徒众不知戒律。便答言。可尔。犯越比尼罪。尔时上座少知戒律。恐坏人心。不时呵止。出彼家已语徒众言。汝等不善而作是事。问言。作何等事。上座言。汝不知。世尊制戒不得使行耶。答言。不知。上座复言汝且莫求我当为求上座。求时得偷兰罪。得不得还报时。犯僧伽婆尸沙。彼徒众得越比尼罪。若先优婆夷通白大众。大众皆可一切得越比尼罪。一切共求一切偷兰罪。得不得还报时。一切僧伽婆尸沙。若男子有众多妇。有念者不念者。有比丘出入其家时。有妇人礼比丘足。恭敬问讯已。比丘问言。安隐乐不。彼即答言。何处得乐。问何以故。妇人言。是男子常与一人共起共卧。我独为彼薄贱。譬如穿器无用。那得不苦。比丘答言。但莫愁忧。我当为汝语令平均。便语其夫。汝无所知。云何效人多畜妻妇。不能平均。偏与一人共起共卧。答言。当如之何。比丘言。当等看视。务令平均。答言。当如师教。比丘尔时得偷兰罪。若人有多妇。犹复更求他童女。不能自语。倩比丘往语。乃至得不得还报时。僧伽婆尸沙。若人夫妇斗诤。比丘便劝喻和合。得偷兰罪。若彼夫妇不和。或于佛事僧事有斗。为福事故。劝令和合无罪。若有妇女还家。比丘往到其舍。其家男女皆为作礼。比丘见彼妇女便言汝故住此耶。不应久住。汝夫故钱取。汝持作何等。汝应还彼。作是语时得偷兰罪。有人多畜马而无好种生者。倩比丘语某家。有生马为我求之。比丘为求。得偷兰罪复次佛住舍卫城。有二摩诃罗。一摩诃罗舍妻子出家。一摩诃罗舍妇女出家。各于人间游行。来还舍卫城。共一房住。彼舍妇女者。便自念言。我当还家看本妇女。着入聚落衣。往到本家。其妇遥见摩诃罗来。即嗔恚言。汝摩诃罗薄福无相。不能养活妻子。又避官役舍家远走。女年长大。不得嫁处今用来为汝促还去。若不去者。当双折汝脚。谁喜见汝。时摩诃罗还本住处。如贾客失财。愁忧苦住。时舍妇儿出家者。还家亦复如是。共在一房住。舍儿出家者。少有智慧。语第二摩诃罗言。长老。何故愁忧苦住。答言。长老。何须问是事。又言。必欲知得知。云何我等二人共在一房。好恶之事而不相知。不向我说。更应语谁。彼摩诃罗即广说上事。舍儿摩诃罗言。汝何足愁。我家亦尔。汝今知作方便不。汝可以女作我儿妇。彼答言好。尔时二摩诃罗俱得越比尼罪。是摩诃罗明日时到。着入聚落衣。各归本家时。舍女者。谓其妇言。我为汝求得女婿。妇即问言。是谁家儿。答言。某家子。舍男出家者。谓其妇言。我已为汝求得儿妇。问言。谁家女。答言。某家女。作是语时。俱得偷兰罪。时彼男女游戏里巷。一摩诃罗语其女言。此是汝婿。第二摩诃罗语其儿言。此是汝妇。作是语时。俱得僧伽婆尸沙。时二摩诃罗展转作婚姻已。各各欢喜。如贫得宝。更相爱敬。如兄如弟。诸比丘闻已。以是事具白世尊。云何世尊此二摩诃罗共结婚姻已。欢喜相敬。乃如是耶。佛告诸比丘。此二摩诃罗不但今日作如是事。过去世时已曾尔也。佛告诸比丘。过去世时。有城名波罗奈。国名伽尸。有一婆罗门。有摩沙豆陈久煮不可熟。持着肆上。欲卖与他。都无人买。时有一人。家有一态驴。市卖难售时陈豆主。便作是念。我当以豆买此驴。用便往语言。汝能持驴贸此豆耶。驴主复念。用是态驴为当取彼豆。即便答言。可尔。得驴已欢喜。尔时豆主便作是念。今得子。便即说颂曰

  婆罗门法巧贩卖　　陈久冰豆十六年
  唐尽汝薪煮不熟　　足折汝家大小齿

尔时驴主亦作颂曰

  汝婆罗门何所喜　　虽有四脚毛衣好
  负重着道令汝知　　针刺火烧终不动

尔时豆主复说颂曰

  独生千秋杖　　头着四寸针
  能治败态驴　　何忧不可伏

尔时驴主复嗔即说颂曰

  安立前二足　　双飞后两蹄
  折汝前板齿　　然后自当知

豆主谓驴颂曰

  蚊盲毒虫螫　　唯仰尾自防
  当截汝尾脚　　令汝知辛苦

驴复答言

  从先祖已来　　行此[怡-台+龍]悷法
  今我故承习　　死死终不舍

尔时豆主知此弊恶畜生。不可以苦语。便更称誉。颂曰

  音声鸣彻好　　面白如珂雪
  当为汝取妇　　共游林泽中

驴闻软爱语即复说颂曰

  我能负八斛　　日行六百里
  婆罗门当知　　闻妇欢喜故

佛告诸比丘。尔时二人者今二摩诃罗是。尔时驴者今摩诃罗儿是。尔时已曾更相欺诳和合已。然后欢喜。今亦如是。更相欺诳。和合已然后欢喜。若比丘和合女人得僧伽婆尸沙罪。和合黄门得偷兰罪。和合男子及畜生。得越比尼罪。和合紧那罗女及猕猴女。得偷兰罪。是故说(五戒竟)

佛住旷野精舍。广说如上。尔时诸比丘于旷野中作五百私房。皆人人自乞索而作。有比丘晨朝着入聚落衣。持钵入旷野聚落。为乞作房。故有一估客。手执户钩来。向市肆开自店舍。遥见比丘疾行而来。估客念言。是比丘来必为乞作。房故我晨朝至此市卖未售谁能乞是物者。便闭肆户还家去。比丘念言。是估客见我便闭户还家去。知我来乞不欲与故。便于余道。往截其前。问言。长寿。汝欲何处去。不得相置。我依阿谁而起房舍。正依汝等。信佛法者。知有罪福业行果报。而不欲与谁当与者。长寿当知。如世尊说。当起慈心不乐闻者方便使闻诸不信者教令立信。乃至手捉其头。强劝令施。所以然者。彼于此终当生天上。色力寿命眷属自然。来生人中。亦受快乐。色力寿命眷属成就。修习佛法增益功德。建其道果。是故长寿。如世尊说偈

  为福受乐报　　所欲皆自然
  超踰生死流　　上寂之涅槃
  若人为福者　　天神自然护
  所愿皆自成　　众魔莫能坏
  薄德多诸恼　　福能消众患
  福德既牢强　　速成坚固定
  生天受快乐　　人中亦自在
  斯由功德故　　所往皆自然
  因斯福方便　　永离生死苦
  得道至涅槃　　不没不复生

尔时比丘说此偈已。复言。长寿。助我起房舍。其福最大。是时估客闻说法已。便少多布施。尔时估客作是思惟。若入市肆。多诸乞索。更不。得利折减钱本。宁坐家住可全其本。故胜市中子本俱失。作是念已。便还家坐时。估客妇嗔其夫言。何以诣市速疾来归。如是懒惰。当何由养活男女。充官赋役。估客答言。莫嗔且听。我今晨朝诣市店肆。广说乃至畏失钱本。故还家住。其妇知已。默然不言。尊者舍利弗来入聚落。次行乞食。至其门住。尔时估客妇笃信恭敬。见舍利弗即持净器盛食。持出着钵中。识舍利弗头面礼足。恭敬问讯。时舍利弗而慰劳之。家中何如生活好不。其妇答言。家内悉佳。但生活顿弊。问何以故尔。即以上因缘广白舍利弗。家中生活饮食衣服供。王赋役。正仰市肆。而今夫主在家中住。畏人乞索。实在言行。实觉言眠。阿阇梨。是我家所供养恭敬。尊重无所藏隐。故白此意。时舍利弗为估客妇。种种说法得欢喜心。即还精舍。即以上事具白世尊。佛言。呼是营事比丘来。即便呼来已。佛问营事比丘。汝实乞作房舍恼诸檀越。令向舍利弗嫌说汝不。答言。实尔世尊。佛告比丘。此是恶法。私乞作房恼诸檀越。佛告诸比丘。汝等莫复为房舍。故恼乱檀越。钱财难得布施亦难。婆罗门居士割损财物。供养沙门。衣服饮食床卧病瘦医药此亦甚难。佛告营事比丘。过去世时有比丘。名跋懅。止住林中。时有释军多鸟。亦栖集此林。晨暮乱鸣恼彼比丘。尔时跋懅比丘诣世尊所。顶礼佛足。于一面立。尔时世尊。慰问林中比丘言。云何少病少恼乐住林中不。林中比丘白世尊言。少病少恼乐住林中。但晨暮时为诸释军多鸟。鸣唤恼乱不得思惟。佛告比丘。汝欲令释军多鸟一切不来耶。答言。愿尔。世尊。佛言。比丘汝于日暮释军多鸟来时。便从众鸟。各乞一毛。晨朝去时。亦如是乞。比丘白佛言。善哉世尊。即还林中正坐思惟。至日向暮鸟集乱鸣便作是言。汝释军多鸟各乞一毛。我今须用。尔时众鸟少时无声寂然不得。已后各拔一毛着地。晨朝复乞。尔时众鸟。即便移去异处一宿不乐。彼处寻复来还。尔时比丘复从索毛。一一复与。众鸟念言。今此沙门奇异喜乞。恐我不久毛衣都尽。肉段在地不能复飞。当如之何。便共议言。此比丘常住林中。我等当去。更求余栖不复宜还。佛告诸比丘。飞鸟畜生尚嫌多求。况复世人。汝等比丘莫为营事。多欲多求。令彼信心婆罗门居士苦舍财物。供给沙门衣服饮食床卧病瘦医药。诸比丘白佛言。世尊。云何此林中比丘怯劣喜乱畏恶鸟声。佛告比丘。是林中比丘不但今日怯劣。昔已曾畏诸比丘。言已曾尔耶。佛告诸比丘。过去世时有一龙象住。在林中空闲之处。大风卒起吹折树木。象闻树木折声惊怖奔走。怖心小止。住一树下彼树复折。即复奔走。尔时有天见象惊走。念言。云何此象横自狂走。即说偈言

  暴风卒起树木折　　龙象惊怖狂奔走
  假使大风普天下　　尔时龙象何处避

佛告诸比丘。尔时象者今林中比丘是。佛复告营事比丘。过去世时。有五百仙人。住雪山中。有一仙人。于别处住。有好泉水花果茂盛。去是不远。有萨罗水。中有龙住。见是仙人威仪庠序。心生爱念。时此水龙来诣仙人。正值仙人结跏趺坐。龙即以身绕仙人七匝。以头覆其顶上而住。日日如是。唯有食时不来。仙人以龙绕身故。日夜端坐不得休息。身体萎羸便生疥疮。尔时近处有人居止。有供养仙人者。彷徉游行诣仙人所。见是仙人羸劣疥[癈-(弓*殳)+虫]。即问仙人。何故如是。仙人具为广说上事。彼语仙人言。欲令此龙。不复来耶。答言。欲尔。复问。仙人是龙有所著不。答言。唯有咽上璎珞宝珠。彼人教言。但从索珠龙性极悭。终不与汝。可使不来。言已便去。须臾龙来。便从索珠。龙闻乞珠声。心即不喜。徐舍而去。明日龙来。未至之间仙人见已。遥说偈言

  光耀摩尼宝　　璎珞庄严身
  若龙能施我　　乃为善亲友

时龙即说偈答言

  畏失摩尼珠　　犹执杖呼狗
  宝珠不可得　　更不来看汝
  上馔及众宝　　由此摩尼尊
  是终不可得　　何足殷勤求
  多求亲爱离　　由是更不来

尔时有天于虚空中。而说偈言

  厌薄所以生　　皆由多求故
  梵志贪相现　　龙则潜于渊

佛告营事比丘。龙是畜生。尚恶多求。岂况于人。汝等比丘莫为多营事务。广索无厌。令彼信心婆罗门居士。苦舍财物。供给沙门衣服饮食床卧病瘦医药。佛告诸比丘。有十事法为人所不爱。何等为十。不相习近。轻数习近。为利习近。爱者不爱。不爱者爱。谛言不受。好豫他事。实无威德而欲陵物。好屏私语。多所求欲。是为十事起他不爱。佛告诸比丘。依止旷野比丘。皆悉令集。以十利故。为诸比丘制戒。乃至已闻者当重闻。若比丘自乞作房舍。无主为身。当如量作。应长十二修伽陀搩手。内广七搩手应将诸比丘。示作房处。无难处无妨处。若比丘于难处妨处。自乞作房。无主为身。亦不将诸比丘示作房处。而过量作者。僧伽婆尸沙。比丘者。如上说。自乞者。自行乞求。若一钱二钱家家行乞。乃至百千钱房舍者。佛所听也。作者。自作若教他作。无主者。无有主。若男若女在家。出家人为主也。自身者。自己也。当如量者。应法量也。长者。纵量也。广者。横量也。十二修伽陀搩手者。修伽陀者。名善逝也。搩手者二尺四寸也。内七搩手者。作屋法有内外量。令纵横量壁内也。屋高下量者。边壁一丈二尺。将诸比丘示作房处者示地也。诸比丘者。若僧若僧使僧者。作房比丘入僧中。先作求听羯磨。然后听乞羯磨。羯磨者。作是说。大德僧听。某甲比丘自乞作房。无主为身欲于僧中乞指授处。若僧时到。僧为某甲比丘欲从僧乞指授房处。诸大德僧听。某甲比丘乞指授处。僧忍默然故。是事如是持。是比丘入僧中。胡跪合掌作如是言。大德僧忆念。我某甲比丘自乞作房。无主为身。今从僧乞指授房处。唯愿僧与我指授处。如是三乞羯磨人应作是说。大德僧听。某甲比丘自乞作房。无主为身。已于僧中乞指授房处。若僧时到。僧为某甲比丘指授作房处。如是白。大德僧听。某甲比丘自乞作房。无主为身。已从僧中乞指授房处。僧今为某甲比丘指授房处。诸大德忍。为某甲比丘指授房处。忍者僧默然。若不忍便说。僧已忍。为某甲比丘指授作房处竟。僧忍默然故。是事如是持。若一切僧中都无有说羯磨者。一切僧往就作房处。一比丘僧中唱。一切僧为某甲比丘指授房处。如是三说。僧使者若作房处远。或隔水。若大寒时。大热时。大雨时。或大雪时。若僧中多老病。不能一切往者。彼比丘于僧中。乞指授竟僧应差一比丘二比丘三比丘。不得羯磨众故。极至三人羯磨者应作是说。大德僧听。某甲比丘自乞作房。无主为身。已于僧中乞指授作房处。若僧时到。僧差某甲某甲比丘。为某甲比丘指授作房舍处。如是白。大德僧听。某甲比丘自乞作房。无主为身。已于僧中乞指授作房处。僧今差某甲某甲等比丘。为某甲比丘指授作房处。诸大德忍。差某甲某甲比丘。指授作房处者默然。若不忍便说僧已忍差某甲某甲比丘。指授作房处竟。僧忍默然故。是事如是持。时使比丘往作房处。观察处所。若彼房处多有诸虫。及生花果树。不应语除。若无是事观察已亦如前说。一比丘唱言。僧已示作房处。如是三说。无难处者。若彼处无生花果树木。无诸虫蛇非妨处者。四边各容十二桄梯。桄间各一卷肘。令作事者周匝来往涂治覆苫。若比丘于难处者有生花果树木及诸虫蛇妨处者。周匝不得容十二桄梯令作事者。不得周旋往返覆苫涂治也自乞作房。无主为身亦不将诸比丘指授处所。过量作者。僧伽婆尸沙。僧伽婆尸沙者。如上说。若比丘自乞作房。有难处妨处不将诸比丘指授处所。若减量作教他作。乃至作竟时。得僧伽婆尸沙罪。受用时得越比尼罪。如是二比丘众多比丘亦如是。若一比丘自乞作房。无主为身。难处妨处。不将诸比丘指授处所。如量作。若教他作。乃至作房竟时。得僧伽婆尸沙罪。受用时得越比尼罪。若二若多亦复如是。若比丘自乞作房。无主为身难处妨处。亦不将诸比丘指授处所。过量作教他作房竟时。得僧伽婆尸沙罪。受用时得越比尼罪。若二若多亦复如是。若比丘是处不名指授。若异界僧指授。若先年豫指授。若水中非沙地。非碎石地。非石上非被烧地。若僧中一人不作房者。若二人三人不作房者。尽不应指授。若僧中不作房者。多听作指授。若比丘作净房。即欲持当住房者不应作。若作净房。即持当[卄/積]薪屋者不应作。若作净房。即持当井屋者不应作。若作净房。即持当浴室者不应作。若比丘难处妨处。不指授作过量作房时。若授甎泥团者。尽得越比尼罪。垒甎安行行。作房比丘一一得越比尼罪。乃至若户牖成已得偷兰罪。乃至屋成若塼覆者。最后一塼时。得僧伽婆尸沙罪。若瓦覆若木覆。若板覆若石灰覆。若泥团覆若草覆。乃至最后一把草覆时。得僧伽婆尸沙。作房未成中止者。得偷兰罪。后更成时。僧伽婆尸沙。作房者若房主安处房已。令余人作。乃至房成时。作房者。比丘得僧伽婆尸沙。若房主安处房已。后他人成者。偷兰罪。若比丘于难处妨处。不将诸比丘指授处。过量作房。是房主比丘不舍戒。不死不与僧。若有比丘。于此房中。若熏钵作衣。若受诵若思惟一切受用者。得越比尼罪。二人多人作房亦如是。若比丘自乞作房。无难处无妨处。将诸比丘指授处。减量作。若教他作至房竟时。是比丘无罪。受用者亦无罪。二人多人亦如是。若比丘自乞作房。无难处非妨处。将诸比丘指授如量作者若教他作。乃至房成。是比丘无罪。受用者无罪。若二若多亦复如是。若比丘将诸比丘指授房处。非他界僧指授。非先年指授。不水中若沙地若碎石地若磐石上若被烧地。非僧中一人不作房者。非僧中二人三人不作房者。若不作房者。多听作定作。住止房定作。净房定作。井屋定作。浴室者听作。是比丘作房。无难处非妨处。不过量作。将诸比丘示作房处。是诸比丘若助治泥团。若治塼授与时。一一是助比丘无罪。若累一行二行。乃至安户牖时是比丘无罪。若塼覆者。最后一塼时。是比丘无罪。若瓦覆木板覆草覆。石灰覆泥团覆。最后泥团覆时无罪。作半止者。是比丘无罪。后还成者。是比丘无罪。自作方便令他成者。是比丘无罪。自作后他人成者。是比丘无罪。若比丘自乞作房。无难处非妨处。将诸比丘指授。不过量作。是比丘不舍戒。不死不与僧诸比丘于中若熏钵作衣。诵经思惟一切受用尽无罪。若比丘于佛生处。得道处转法轮处五年大会处。是诸尊处。为供养作草庵树叶庵帐幔旃庵。暂住者听作。是故说。若比丘自乞作房。无主为身。乃至过量作者僧伽婆尸沙(六戒竟)

佛住俱睒弥国。广说如上。尔时俱舍弥国五百比丘各作私房。尔时阐陀比丘无人为作房。时阐陀比丘主人名阿跋吒。时阐陀比丘着入聚落衣。往诣其家。时主人见比丘来恭敬礼足。共相问讯。时主人言。阿阇梨我闻。俱舍弥作五百间私房。颇有与阿阇梨作房者不答言实如所闻。有主人者皆作房舍。我薄福德。譬如秃枭无有主人。谁当与作。主人答言。阿阇梨。莫恨。我当为作。尔时即与五百金钱。白言。阿阇梨。持去作房尔时阐陀即持钱去。寻便安处欲作大房。尽五百金钱。正得起基起少墙壁。钱物已尽。复诣其家。主人礼足。共相慰劳。问言。阿阇梨作房竟未。答言。始起屋基作少墙壁。钱物已尽。尔时主人复与五百金钱。阐陀持五百金钱。作墙壁竟。安施户牖。钱物复尽。更诣主人。主人礼足复问。阿阇梨房舍竟耶。答言。墙壁户牖始竟。钱物已尽。尔时主人生不信心。语阐陀言阿阇梨。是出家人。用作大房舍。为用千金钱。可起楼阁而作一房。云何不足。尊者且还。不能复与。尔时阐陀即便愁忧。云何方便得成是房舍。有萨罗林树。便伐之持用成房。尔时林中有鬼神。依止此林。语阐陀言。莫斫是树。令我弱小儿女暴露风雨无所依止。阐陀答言。死鬼促去。莫住此中。谁喜见汝。即便伐之时。此鬼神即大啼哭。将诸儿子诣世尊所。佛知而故问。汝何以啼哭。答言。世尊。尊者阐陀伐我林树。持用作房。世尊。我男女劣小风雨漂露。当何所依。尔时世尊为此鬼神。随顺说法示教利喜。忧苦即除。去佛不远。更有林树。世尊指授令得住止。佛告诸比丘。唤阐陀来。即便唤来来已。佛广问上事。汝实尔不。答言。实尔。世尊。佛言。痴人。此是恶事。汝不知耶。如来应供正遍知一宿住止。是处左右有树木。与人等者。便为塔庙。是故神祇乐来依止。云何比丘恶口骂之。阐陀是非法非律。非是佛教。不可以是长养善法。诸比丘白佛言。世尊。云何是阐陀比丘。巧作方便营事。得彼主人千旧金钱。佛告诸比丘。是非巧便。若巧便者应当更得。何但齐千。诸比丘白佛言。实如世尊说。善知是阐陀比丘不善方便。佛告比丘。不但今日知此比丘不善方便。过去世时已知阐陀比丘不善方便。佛告诸比丘。过去有城。名波罗奈。国名伽尸。时国有王。以法治化人民安乐无诸患难。时王无子夫人忽然怀妊。十月生子而无眼鼻。生子七日施设大会。集诸群臣相师道士。为子立字。时王土法。或因福相。或因星宿。或因父母而立名字。婆罗门问言。王子身体有何异相。傍人答言。今此王子其面正平都无眼鼻之处。婆罗门言。今此王子应名镜面。以四乳母供给抱养。一人摩拭洗浴。一人除弃不净。一人怀抱。一人乳哺。此四乳母昼夜给侍。譬如莲花日日增长。至年长大。父王命终。即拜镜面绍尊王位。然此太子宿殖德本。虽生无目而有天眼。堪为国王福德力大。国中人民闻镜面太子为王。无不奇怪。时有大臣。便欲试之。不能得便。遇王出令敕诸群臣。更立新殿。雕文刻镂种种彩画。大臣念言。恒欲试王。今正是时。将一猕猴与着衣服。作巧作具。革囊盛之。串其肩上。将到王前白言。大王。被敕立殿。巧匠已至。愿王指授殿舍方法。王即心念彼将试我。便说偈言

  观此众生类　　睒睒面皱赧
  趌[起-巳+厥]性轻躁　　成事彼能坏
  受分法如是　　何能起宫殿
  残害花果树　　不能亲近人
  况能造宫殿　　催送归野林

佛告诸比丘。尔时镜面王者。今我身是。时猕猴者。今阐陀比丘是。我于尔时生无两目。已曾知彼无所堪施。况复今日。佛告诸比丘。依止俱舍弥城住者。皆悉令集。乃至已闻者当重闻。若比丘作大房舍。有主为身应将诸比丘指授处所。无难处非妨处。是比丘于难处妨处。有主为身。亦不将诸比丘指授处所者。僧伽婆尸沙。比丘者。如上说。大者过量。是名大也。房者。世尊所听。作者。若自作若教他作。有主者。若有男子女人。在家出家为作主也。为身者为己。不为僧也。将诸比丘指授处者。谓僧若僧。使如上小房中说无难处非妨处者。亦如上说。若比丘于难处妨处。不将诸比丘指授作房处者。僧伽婆尸沙。若一比丘于难处妨处。作大房。若自作教他作。乃至房成时。僧伽婆尸沙。受用者。得越比尼罪。若二若多亦复如是。除其过量。一切有罪无罪。皆亦如上小房中说。是故说。若比丘作大房舍。有主为身。乃至不将诸比丘指授处者。僧伽婆尸沙(七戒竟)

佛住舍卫城广说如上。尔时有比丘。名陀骠摩罗子。众僧拜典知九事。九事者。典次付床座。典次差请会。典次分房舍。典次分衣物。典次分花香。典次分果蓏。典次知暖水人。典次分杂饼食。典次知随意举堪事人。是名僧拜典知九事。付床座时。是长老右手小指出灯明随品。次付若阿练若。阿练若者。共乞食。乞食者。共粪扫衣。粪扫衣者。共一坐食。一坐食者。共常坐。常坐者。共露坐。露坐者。共敷草坐。敷草坐者。共经呗。经呗者。共法师。法师者。共学律。学律者。共须陀洹。须陀洹者。共斯陀含。斯陀含者。共阿那含。阿那含者。共阿罗汉阿罗汉者。共三明。三明者。共六通。六通者。共无威仪。无威仪者共

尔时慈地比丘及六群比丘等。来索房舍。时尊者陀骠摩罗子答言。小住。待汝等下坐房。次当与汝房到下坐。次如其次第。付房与之。得不好房。是六群比丘等见房舍中卧床坐床被褥诸物。皆悉朽故。又别房食亦复粗恶。共相谓言。长老陀骠摩罗子。如我生怨。与我弊房。饮食粗涩。若是长老。久在梵行。者当令我等常受众。苦今当以波罗夷法谤之。即语言。长老。汝犯波罗夷罪。我当举之。答言。我无是罪。彼言。谁复作贼。言我是贼。但汝今日犯波罗夷。至众多人中谤。复到僧中谤尊者陀骠摩罗子犯波罗夷。陀骠摩罗子往白世尊。慈地比丘以无根波罗夷法见谤。佛言。汝有是事耶。答言。无也。世尊。佛言。比丘。如来知汝清净他人谤汝。当如之何。陀骠言。世尊。虽知我清净无罪。唯愿世尊哀愍语彼令生信心。莫令长夜得不饶益。佛言。唤六群比丘来。即唤来已。佛问六群比丘。汝等实以无根波罗夷罪谤他陀骠摩罗子比丘耶。答言。实尔世尊。佛言。何以故。答言。是长老与我故坏房舍。乃至若是长老。久在梵行者我等恒得苦恼。便以波罗夷法谤。佛告六群比丘。此是恶事。我常不说于梵行人。当起恭敬。慈身口意行耶。汝今云何于梵行无罪比丘。无根波罗夷法诽谤。此非法非律。非是佛教。不可以是长养善法

佛告诸比丘。依止舍卫城比丘。皆悉令集。以十利故。为诸比丘制戒。乃至已闻者当重闻。若比丘嗔恨不喜故。于清净无罪比丘。以无根波罗夷法谤。欲令破彼比丘净行。彼于后时。若捡挍若不捡挍。便作是言。是事无根。我住嗔恨故。作是语者。僧伽婆尸沙。比丘者。如上说。嗔者。九恼及非处起嗔。第十恨者。凡夫及学人有不喜者。乃至阿罗汉有无根者。事根不现。又不见彼事。不闻彼事。不疑彼事。波罗夷者。四波罗夷中一一也。谤者。无事横说过也。欲破彼净行者。欲令彼非比丘非沙门非释种子。欲令作沙弥作俗人作园民作外道。彼于后时。若捡挍若不捡挍。捡挍者。问言。汝见何事淫耶。盗五钱耶。故杀人耶。不实称过人法耶。云何见何因见何处见是为捡挍。若不如是问者。是名不捡挍也。是事无根住嗔恨故。说作是语者。僧伽婆尸沙。僧伽婆尸沙者。如上说。若比丘嗔恨谤二相似者。不净者。清净者。清净者。言见我犯。何等罪。四事中。若一若二耶。十三事中。若一若二耶。若不见不闻不疑不决了。便谤若屏处。若众多人中。若众僧中。我见彼犯波罗夷。我闻彼犯波罗夷。我疑彼犯波罗夷。见不实见根本不实。闻不实闻根本不实。疑不实疑根本不实。本曾见妄闻妄疑妄见。不尔闻不尔疑不尔对面。四目谤语。语僧伽婆尸沙。是比丘于四波罗夷中。一一谤犯僧伽婆尸沙。以十三僧伽婆尸沙中一一谤。犯波夜提。以波夜提罪一一谤。得越比尼罪。波罗提提舍尼众学法。及威仪法谤者。犯越比尼。心悔若谤比丘尼八波罗夷。十九僧伽婆尸沙。若一一谤。波夜提。三十尼萨耆。百四十一波夜提。若一一谤犯越比尼罪。八波罗提提舍尼。众学及威仪。一一谤犯越比尼心悔学戒尼十八事。若一一谤言。当更与学戒犯偷兰罪。沙弥沙弥尼十戒。若一一谤言。当更与出家犯越比尼罪。下至俗人五戒。若一一谤犯越比尼心悔。是故说若比丘嗔恨不喜故。乃至作是语者。僧伽婆尸沙(八戒竟)

摩诃僧祇律卷第六摩诃僧祇律卷第七

        东晋天竺三藏佛陀跋陀罗共法显译

    明僧残戒之余

佛住舍卫城。广说如上。时尊者陀骠摩罗子众僧拜典知九事。如上说。乃至六群比丘。受得下房粗食。心常愁苦。乃至念言。是长老陀骠摩罗子久在梵行者。我等常得苦恼。又世尊制戒。不听以无根波罗夷法谤。今当求其罪过。根原作是语已。常随逐尊者陀骠摩罗子。若行若住若坐若卧。常随左右至月八日十四日十五日。诸比丘尼来礼佛足。是时尊者陀骠摩罗子去佛不远。于一面坐。诸比丘尼礼佛足已。次来礼尊者陀骠摩罗子。陀骠摩罗子。时有姊妹比丘尼。礼拜时风吹衣角。堕陀骠摩罗子膝上。即以手举去。时六群比丘便作是言。长老陀骠汝犯波罗夷。陀骠言。我无是事。六群比丘复言。我已见事。何所复疑。谁复作贼。自言是贼。便于屏处及多人中。乃至僧中说是事。尔时陀骠以是因缘。具白世尊。佛言。呼六群比丘来。即便呼来。佛问六群比丘。汝实以无根波罗夷谤陀骠摩罗子耶。答言。不也世尊。实有根本。佛言。有何根本。六群比丘白佛言。时一斋日有诸比丘尼来。礼世尊次。礼长老陀骠。尔时风吹尼衣。拂陀骠膝上。尔时陀骠手捉彼衣。是为根本。佛言。痴人。此非波罗夷根本。此是异分中小小事。佛语六群比丘。汝常不闻。世尊种种因缘。于梵行人所起恭敬心慈身口意耶。汝今云何于清净无罪比丘。欲破彼净行故。以异分中小小事非波罗夷。比丘以波罗夷法谤。此非法非律。非是佛教。不可以是长养善法。佛告诸比丘。依止舍卫城比丘。皆悉令集。以十利故。为诸比丘制戒。乃至已闻者当重闻。若比丘嗔恨不喜故。以异分中小小事非波罗夷。比丘以波罗夷法谤。欲破彼梵行。彼于后时。若捡挍若不捡挍。以异分中小小事。是比丘住嗔恨故。说僧伽婆尸沙。比丘嗔恨不喜者。如上说异分者。除四波罗夷。十三僧伽婆尸沙。是为异分小小事者。众学法及威仪也。非波罗夷比丘。以波罗夷法谤者。四波罗夷中。若一一事谤者。无事说过。欲破彼梵行者。欲令彼非比丘非沙门非释种子。欲令作沙弥作俗人作园民作外道。后时若捡挍若不捡挍。捡挍者。汝见何事淫耶盗耶故杀人耶。不实称过人法耶。云何见何因缘见何处见。是名为捡挍。若不如是问者。是名不捡挍。清净无罪比丘。以异分中小小事。住嗔恨故。说者僧伽婆尸沙。僧伽婆尸沙者如上说。若比丘嗔恨谤二相似者。净不净。清净者言。见我犯何罪。一切如上无根中说。乃至谤俗人越比尼心悔。是故说若比丘嗔恨不喜故。以异分中小小事。乃至住嗔恨故说。僧伽婆尸沙

佛住王舍城。广说如上。是时提婆达多欲破和合僧故勤方便执持破僧事。于十二修多罗戒序四波罗夷。十三僧伽婆尸沙。二不定法。三十尼萨耆波夜提。九十二波夜提。四波罗提提舍尼。众学法。七灭诤法。随顺法。不制者制。已制者。便开。乃至在家出家共行法。所谓九部经修多罗祇夜。授记伽陀优陀那。如是语经本生经方广未曾有法。于此九部经更作异句异字异味异义。各各异文辞说自诵习。持亦教他诵持。时诸比丘语提婆达多。汝莫作方便坏和合僧。莫执持破僧事。汝莫为破和合僧。故勤方便莫受破僧事。故共诤。长老当与僧同事。何以故。僧和合欢喜不诤。共一学如水乳合。如法说法照明安乐住。如是一谏不止。第二第三谏亦复不止。诸比丘以是因缘。往白佛言。世尊。提婆达多欲破和合僧故。勤方便执持破僧事。从戒序乃至九部法异句异字异味异义。各各异文辞说。自诵习亦教他。时诸比丘一谏不止。二谏三谏犹故不止。佛告诸比丘。若是提婆达多愚痴人。欲破和合僧故。勤方便执持破僧事。乃至九部法作异句异字异味异义。各各异文辞说。三谏不止者。汝去应当屏处三谏。多人中三谏。僧中三谏。令舍是事。比丘屏处谏者。应作是说。汝提婆达多实欲破和合僧。执持破僧事。乃至九部法。异句异字异味异义。异文辞说。自诵习。亦复教他不。答言。实尔。复应语提婆达多。汝莫破和合僧故勤方便。莫执持破僧事。长老提婆达多破和合僧。最是大恶重罪。当堕恶道入泥犁中。经劫受罪。提婆达多我今慈心饶益故。当受我语。一谏已过二谏在。舍此事不。不舍者。第二第三谏亦如是。复于多人中三谏亦如是。犹不止者。将诣僧中应作求听羯磨。羯磨者作如是说。大德僧听。是长老提婆达多欲破和合僧故。勤方便执持破僧事住。于十二事。乃至九部经。异句异字。异味异义。异文辞说。自诵亦教他。已屏处三谏。多人中三谏。犹故不止。若僧时到僧今于僧中当三谏令止。僧中应问提婆达多。汝实于十二法。乃至九部经。异句异字。异味异义。异文辞说。自诵复持教他。诸比丘已屏处三谏。多人中三谏。犹故不止耶。答言实尔。僧中应谏言。汝提婆达多莫为破和合僧故勤方便莫执持破僧事。乃至于九部经中。异句异字。异味异义。异文辞说。汝莫破和合僧。破和合僧者。是大恶事。是重罪堕恶道入泥犁中。经劫受罪。今日众僧中慈心谏汝。欲饶益故。当受僧语。一谏已过二谏在。当舍此事若不舍如是第二第三谏犹故不止。诸比丘复以是事。往白世尊。是提婆达多已于屏处三谏。多人中三谏。僧中三谏。此事犹故不舍。佛语诸比丘。是提婆达多痴人。破和合僧勤方便。执持破僧事已屏处三谏。多人中三谏。僧中三谏。此事犹故不舍者。僧应与作举羯磨诸比丘白佛言。世尊。云何是提婆达多不受诸比丘谏自受苦恼。佛告诸比丘。不但今日不信他语自受苦恼。过去世时已曾如是。诸比丘白佛言。已曾尔耶佛言。如是。过去世时有城。名波罗奈。国名伽尸。时有一婆罗门。于旷野中造立义井。为放牧取薪草人行来者。皆就井饮。并洗浴。时日向暮有群野干。来趣井饮地残水。有野干主。不饮地水。便内头罐中饮水。饮水已戴罐高举。扑破瓦罐。罐口犹贯其项。诸野干辈语主野干。若湿树叶可用者。常当护之。况复此罐利益行人。野干主言。我作是事乐。但当快心。那知他事。时行人语婆罗门。汝井上罐已破。复更着之。犹如前法。为野干所破。如是非一。乃至破十四罐。诸野干辈数数谏之。犹不受语。时婆罗门便自念言。是谁于我福德义井作障碍者。今当往观。知其所以。即持罐往着井上。于屏处微伺见之。诸行人饮水而去。无破罐者。至日向暮见群野干来饮地残水。唯野干主。饮罐中水。然后扑破。见已便作是念。正是野干于我福德井而作留难。便作木罐坚固难破。令入头易出头难。持着井边。捉杖屏处伺之。行人饮讫。向暮野干群集。如前饮地残水唯野干主饮罐中水讫。便扑地不能令破。时婆罗门捉杖来出打杀野干。时空中有天。说此偈言

  知识慈心语　　佷[仁-二+戾]不受谏
  守顽招此祸　　自丧其身命
  是故痴野干　　遭斯木罐苦

佛告诸比丘。尔时野干主者。今提婆达多是。时群野干者。今诸比丘谏提婆达多者是比丘当知。于过去时。已曾不受知识软语。自丧身命。今复不受诸比丘谏。当堕恶道长夜受苦。佛告诸比丘。依止舍卫城比丘。皆悉令集。以十利故。为诸比丘制戒。乃至已闻者当重闻。若比丘欲破和合僧故勤方便。执持破僧事故共诤。诸比丘语是比丘言。长老。莫破和合僧故勤方便。执持破僧事故共诤。当与僧同事。何以故。和合僧欢喜不诤。共一学如水乳合。如法说法照明安乐住。长老舍此破僧因缘事。是比丘诸比丘如是谏时。坚持是事不舍者。诸比丘应第二第三谏。为舍是事故。第二第三谏时。舍是事好。若不舍者。僧伽婆尸沙。比丘者。如上说。和合僧者。不别众。诸比丘虽复斗诤更相导说。但一界一众一处住。一布萨自恣故。名为和合僧。齐几许当言破和合僧勤方便执持破僧事。若比丘于十二事戒序。四波罗夷。十三僧伽婆尸沙。二不定。三十尼萨耆波夜提。九十二波夜提。四波罗提提舍尼。众学法。七灭诤法。随顺法。不制者制。制者便开。是名破和合僧事。复次五众罪不制者制。制者便开。是名破和合僧事。复次四众罪不制者制。制者便开。是名破和合僧事。复次三众罪。二众罪。一众罪。四波罗夷。不制者制。制者便开。是名破和合僧事。复次六作舍法。折伏羯磨。不语羯磨。发喜羯磨。摈出羯磨。举羯磨。别住羯磨。于此六作舍法。不制者制。制者便开。是名破和合僧事。破和合僧比丘者。如提婆达多也。诸比丘者。若一若二若众多若众僧。三谏者。屏处三谏。多人中三谏。众僧中三谏。屏处三谏者。问言。长老汝实破和合僧。故勤方便执持破僧事。乃至十二法不制者。制制者便开耶。答言。实尔是比丘即便谏言。长老。汝莫为破和合僧故勤方便执持破僧事。于十二事不制者制。制者便开。破僧者。此是大罪堕恶道入泥犁中。长夜受苦。我今慈心谏汝。饶益故。受我语。一谏已过余二谏在。舍此事不。若不舍第二第三亦如是。多人前三谏。亦如是。复不止者。将至僧中。应作求听羯磨。大德僧听。是某甲比丘为破和合僧故勤方便执持破僧事。已于屏处三谏。多人中三谏。犹故不止。若僧时到。今于僧中三谏令止。僧中复问言。长老。汝实为破和合僧故勤方便执持破僧事。乃至不制者制制者便开耶。答言。实尔。即应谏言。今众僧谏汝。长老。莫为破和合僧故勤方便执持破僧事。乃至不制者制。制者便开。破僧者。最大恶深重。当于恶道中长夜受苦。今日众僧慈心呵汝。当止此事。若不舍者复第二第三谏。亦如是说。如是谏时。若舍者善。若不舍者。僧伽婆尸沙。僧伽婆尸沙者。如上说。是比丘于屏处谏时。一谏不止。犯越比尼罪。第二第三亦如是谏。多人中谏时。一谏不止犯越比尼罪。第二第三谏时。亦如是。至僧中初谏时。说未竟。越比尼罪。说竟偷兰罪。第二谏。说未竟越比尼罪。说竟偷兰罪。第三谏说。未竟偷兰罪。说竟得僧伽婆尸沙。僧伽婆尸沙罪起已。屏处谏。多人中谏。及僧中谏。诸越比尼罪。诸偷兰罪。一切尽合成一僧伽婆尸沙。若中间止者。随所止处治罪。是故说。若比丘欲破和合僧故勤方便执持破僧事。乃至三谏不舍者。僧伽婆尸沙(第十戒竟)

佛住舍卫城。广说如上。尔时诸比丘为提婆达多。作举羯磨时初羯磨竟。无有遮者。第二羯磨竟。亦无有遮者。第三羯磨时。提婆达多看六群比丘面。而作是言。六群比丘汝等长夜承事我。共我从事。今众僧为我作举羯磨已。至再说而皆默然。汝等今日持我任。于众人如酪涂糗与乌。如酥涂饼与那俱罗。如油和饭与野干。修梵行者。为人所困。而坐观之。六群比丘即起作是言。如是如是。长老。是法语比丘。律语比丘。是比丘所说。皆是我等欲忍可事。是比丘所见。欲忍可事。我等亦欲忍可。是比丘知说非不知说。是时有多人遮羯磨不成。时诸比丘语六群比丘。长老。莫助提婆达多作破和合僧同语同见。当与僧同事。一切僧和合欢喜不诤。共一学如水乳合。如法说法照明安乐住作。如是一谏不止。第二第三谏犹故不止诸比丘以是因缘。具白世尊佛告诸比丘。是六群比丘与愚痴提婆达多欲破和合僧同语同见。已一谏二谏三谏不止者。汝去屏处三谏。多人中三谏。应僧中三谏。令舍是事。比丘受教。即于屏处问六群比丘。汝等实与愚痴提婆达多破和合僧同语同见为党。诸比丘已再三谏故不止耶。答言。实尔。即便谏之。汝六群比丘莫与提婆达多破和合僧同语同见。汝等当与僧同事。一切僧和合欢喜无诤。同一学如水乳合。如法说法。照明安乐住。诸长老破和合僧。是最大罪。堕恶道入泥犁中。长夜受苦。我今慈心谏汝。欲饶益故。当受我语。一谏已过二谏在。当舍是事。若不止第二第三亦如是说。复于多人中三谏。亦如是。复不止者。僧中应作求听羯磨。大德僧听。是六群比丘与提婆达多破和合僧同语同见。已于屏处三谏。多人中三谏。犹故不止。若僧时到。当于僧中三谏令止。即于僧中问六群比丘。汝等实与提婆达多。破和合僧。同语同见。已屏处三谏。多人中三谏。犹故不止耶。答言。实尔。即复谏言。六群比丘汝等莫与提婆达多共破和合僧同语同见。破和合僧。最是恶事。堕恶道入泥梨中。长夜受苦。今僧慈心谏汝。饶益故。当受僧语。一谏已过二谏在。汝舍是事。若不止者。第二第三亦如是谏。犹故不舍。诸比丘复以是事具白世尊佛言。呼六群比丘来。即呼来。来已佛问六群比丘。汝等实与愚痴提婆达多同语同见破和合僧。诸比丘已屏处三谏。多人中三谏。僧中三谏。犹故不舍耶。答言。实尔世尊。佛言。比丘。此是恶事。汝常不闻我种种因缘呵责[怡-台+龍]悷难谏种种因缘赞叹柔软易谏耶。汝等云何[怡-台+龍]悷难谏。此非法非律。非是佛教。不可以是长养善法。诸比丘白佛言。世尊。云何是六群比丘共提婆达多同语同见徒自受苦。佛告诸比丘。是六群比丘不但今日同语同见徒自受苦。过去世时已曾如是。诸比丘白佛言。已曾尔耶。唯愿说之。佛告诸比丘。过去世时。有城名波罗奈。国名伽尸。于空闲处有五百猕猴。游行林中。到一尼俱律树。树下有井。井中有月影现。时猕猴主见是月影。语诸伴言。月今日死落在井中。当共出之。莫令世间长夜闇冥。共作议言。云何能出。时猕猴主言。我知出法。我捉树枝。汝捉我尾。展转相连。乃可出之。时诸猕猴即如主语。展转相捉。小未至水。连猕猴重。树弱枝折一切猕猴堕井水中。尔时树神便说偈言

  是等騃榛兽　　痴众共相随
  坐自生苦恼　　何能救世间

佛告诸比丘。尔时猕猴主者。今提婆达多是。尔时余猕猴者。今六群比丘是。尔时已曾更相随顺受诸苦恼。今复如是。佛告诸比丘。依止王舍城比丘。皆悉令集。以十利故。为诸比丘制戒乃至已闻者当重闻。若比丘同意相助。若一若二若众多同语同见。欲破和合僧。是比丘诸比丘谏时。是同意比丘言。长老莫说是比丘好恶事。何以故。是法语比丘。律语比丘。是比丘所说。皆是我等欲忍可事是比丘所见。欲忍可事。我等亦欲忍可。是比丘知说非不知说。诸比丘谏。是同意比丘。长老莫作是语。是法语比丘。律语比丘。何以故。是非法语比丘。非律语比丘。诸长老莫助破僧事。当乐助和合僧。何以故。僧和合欢喜不诤。共一学如水乳合。如法说法照明安乐住。诸长老。当舍此破僧事。是同意比丘。诸比丘如是谏时。坚持不舍者。诸比丘应第二第三谏。舍此事故。第二第三谏时。舍是事好。若不舍者。僧伽婆尸沙。比丘者。提婆达多是。同语同见比丘者。六群比丘也。若一若二若众多同语同见者。或有同语不同见。或有同见不同语。或有同语亦同见。或非同语非同见。同语非同见者。言语相助不同彼见。是名同语非同见。同见不同语者。同彼所见而不助说。是名同见不同语。同语同见者。助彼言语同其所见。是名同语同见。非同语非同见者。不助彼语亦不同见。是名非同语非同见。是中同语非同见。及同语同见者。当呵谏。云何名为同语同见法。于十二法不制者制。制者便开。是名同语同见法。复次五众罪不制者制。制者便开四众三众二众一众罪。亦如是。不制者制。制者便开。复次六作舍法不制者制。制者便开。是名同语同见法。诸比丘当谏是比丘言。长老莫与破和合僧。勤方便同语同见。诸比丘谏是比丘时。执是事坚持者。谓六群比丘也诸比丘者。若僧若多人若一人也。三谏者。屏处三谏。多人中三谏。僧中三谏也。屏处谏者。汝诸长老实与破和合僧。勤方便同语同见耶。答言实尔。复言。长老。汝莫与破和合僧。勤方便同语同见。破僧者。最大恶事。当堕恶道长夜受苦我今慈心谏汝。当舍是事一谏已过二谏在舍。此事好若不舍者。第二第三亦如是说。多人中三谏。亦复如是。复于僧中三羯磨谏。犹不止者。僧伽婆尸沙僧伽婆尸沙者。如上说。是比丘屏处一谏不止。越比尼罪。第二第三亦如是。多人中三谏。亦如是僧中初羯磨未竟。不止越比尼罪。说竟偷兰罪第二羯磨未竟不止越比尼罪。说竟偷兰罪。第三羯磨未竟偷兰罪。说竟僧伽婆尸沙。僧伽婆尸沙罪。起已屏处三谏。越比尼罪。多人中三谏。越比尼罪及僧中偷兰罪。一切尽共成一僧伽婆尸沙。中间止者。随止处治罪。是故世尊说。若比丘同意相助。若一若二若众多同语同见。乃至三谏不舍者。僧伽婆尸沙(十一戒竟)

佛住俱舍弥国。广说如上。尔时长老阐陀恶性难共语。诸比丘如法如律教。作不可共语。如是言。诸长老莫语我若好若恶。我亦不语诸长老若好若恶。何以故。汝等皆是杂姓。我家民吏。譬如乌鸟衔杂类骨聚在一处。何能教我佛法僧事。皆是我许从菩萨出家。我常随侍。至于今日。唯佛教我。我当受持。时诸比丘语阐陀言。长老。诸比丘善说所犯波罗提木叉中事。汝莫自身作不可共语。汝身当作可共语。长老。汝当为诸比丘说。如法如律教。诸比丘亦当为汝说。如法如律教。何以故。如来众得如是增长。所谓共语共说共谏。共罪中出故。长老舍自身。作不可共语。一谏不舍。第二第三谏犹故不止。诸比丘以是因缘。往白世尊。长老阐陀自身作不可共语。乃至三谏不止。佛告诸比丘。是阐陀自用不可共语。乃至三谏不止者。汝去屏处三谏。不止者。复于多人中三谏。复不止者。乃至僧中作求听羯磨。应作是说。大德僧听。是长老阐陀恶性难共语。诸比丘如法善说所犯波罗提木叉中事。自用作不可共语。乃至已于屏处三谏。多人中三谏。犹故不止。若僧时到。今于僧中三谏。令止此事。即于僧中谏。长老阐陀汝实恶性难共说。诸比丘如法如律。说汝自作。不可共语。乃至已屏处三谏。多人中三谏。犹故不止耶。答言。实尔。应僧中谏言。长老汝莫恶性难共语。诸比丘如法善说所犯波罗提木叉中事。汝莫自身作不可共语。乃至如来众得如是增长。所谓共语共说共谏共罪中出故。僧今慈心谏汝。饶益故。一谏已过二谏在。当止此事。若不舍者。更第二第三亦如是谏。犹故不止。诸比丘复以是事。往白世尊。佛言。呼阐陀来。即便呼来。佛问阐陀。汝实恶性难共语。乃至僧中三谏不止耶。答言。实尔。佛言。阐陀。此是恶事。汝常不闻我种种因缘。呵责自用赞叹不自用。汝今云何自用反戾。此非法非律。非是佛教。不可以是长养善法。诸比丘白佛言。世尊。云何是阐陀比丘而自用意作是言。唯有佛语。我当受佛语。诸比丘。是阐陀比丘。不但今日不受余人语。但信我语。过去世时。亦曾如是。诸比丘白佛言。已曾尔耶。唯愿乐闻。佛言。如是。过去世时有城。名波罗奈。国名伽尸。尔时有一长者。有奴字阿磨由。为性凶恶。尔时长者与诸婆罗门子游戏园林。诸从人辈皆在园门外住。时阿磨由在园门外。打诸从人时。诸从人被打者。各告其主。时诸婆罗门子尽出呵之。时阿磨由不受其语。答诸婆罗门子言。不随汝语我大家来。呵我者。当受其语遂打不止即来。告阿摩由主。阿摩由主生得天眼。观是斗处下有金银伏藏。其他凶故令其斗耳。即往诃之。时奴即止。佛告诸比丘。尔时长者岂异人乎。即我身是。尔时阿摩由者。今阐陀比丘是。诸比丘白佛言。世尊。云何是阐陀恃怙世尊。陵于他人。佛言。比丘是阐陀比丘。不但今日恃我轻于他人。过去世时。已曾恃我轻于他人。诸比丘白佛言。已曾尔耶。佛言。如是。过去世时有城名波罗奈。国名伽尸。时有弗卢醯大学婆罗门。为国王师。常教学五百童子。时婆罗门家生一奴。名迦罗呵常使供给诸童子等。婆罗门法。余姓不得妄闻。以奴亲近供养故。得在其边。为诸童子说婆罗门法。是奴利根闻说法言尽能忆持。此奴一时共诸童子。小有嫌恨。便走他国。诈自称言我是弗卢醯婆罗门子。字耶若达多。语此国王师婆罗门言。我是波罗奈国王师。弗卢醯子。故来至此。欲投大师学婆罗门法。师答言。可尔。是奴聪明本已曾闻。今复重闻。闻悉能持其师大喜。即令教授五百门徒。五百童子言。汝代我教。我当往来王家。是师婆罗门无有男儿。唯有一女。便作是念。今可以女妻之耶。若达多常在我家。便如我子。即告之曰。耶若达多当用我语。答言。从教。复告之言。汝莫还波罗奈。常住此国。我今以女妻汝。答言。从教。即与。其女在家。如儿共作生活。家渐丰乐。是耶若达多为人难可。妇为作食恒怀嗔恚。甜酢咸淡生熟不能适口。妇常念言。脱有行人。从波罗奈来者。当从彼受作饮食法。然后作供养夫主。彼弗卢醯婆罗门具闻是事。便作是念。我奴迦罗呵逃在他国。当往捉来。或可得奴。直便诣彼国。时耶若达多与诸门徒。诣园游戏在于中路。遥见本主。即便惊怖密语门徒。诸童子汝等还去。各自诵习。门徒去已便到主前。头面礼足。白其主言我来此国。称道大家。是我之父。便投此国师。大学婆罗门为师。以大学经典故。师婆罗门。与女为妇。愿尊今日勿彰我是事。当与奴直奉上大家主。婆罗门善解世事。即便答言。汝实我儿何所复言。但作方便早见发遣。即将归家。告家中言。我所亲来。其妇欢喜。办种种饮食。奉食已讫。小空闲时。密礼婆罗门足。而问之曰。我奉事夫耶若达多。饮食供养常不可意。愿今指授本在家时何所食啖。当如先法为作饮食。客婆罗门便即嗔恚。而作是念。如是如是。子困苦他子女。语此女言。汝但速发遣我。我临去时。当教汝一偈。汝诵是偈时。当使汝夫无言。是女即语夫言。尊婆罗门故从远来。宜早发遣。夫即念言。如妇所说。宜应早遣莫令久住。言语漏失。损我不少。便大与财物。教妇作食。自行为主求伴妇。于后奉食讫已。礼足辞别请求先偈。即教说偈言

  无亲游他方　　欺诳天下人
  粗食是常食　　但食复何嫌

今与汝此偈。若彼嗔恚嫌食恶时。便在其边。背面微诵。令其得闻作是教已。便还本国。是耶若达多送主去已。每至食时。还复嗔恚。妇于夫边试诵其偈。时夫闻是偈已。心即不喜。便作是念咄是老物。发我臭秽。从是已后常作软语。恐妇向人说其阴私佛告诸比丘。时波罗奈国弗卢醯婆罗门者。岂异人乎即我身是。时奴迦罗呵者。今阐陀比丘是。彼于尔时已曾恃我陵易他人今复如是。恃我势力陵易他人。佛告诸比丘。依止俱舍弥比丘。皆尽令集。乃至已闻者。当重闻

若比丘自用戾语。诸比丘如法如律教时。便自用意。作是言。汝莫语我若好若恶。我亦不语汝若好若恶。诸比丘谏彼比丘言。长老。诸比丘如法如律教。汝莫自用意。诸比丘教汝应当信受汝亦应如法如律。教诸比丘。何以故。如来弟子众展转相教。展转相谏。共罪中出故善法得增长。诸比丘谏是比丘时。应舍是事。若不舍者。复第二第三谏。舍者善。若不舍者。僧伽婆尸沙。比丘自用戾语者。阐陀比丘也。诸比丘如法如律教者。谓戒序四波罗夷。十三僧伽婆尸沙。二不定法。三十尼萨耆。波夜提。九十二波夜提四波罗提提舍尼。众学法。七灭诤法。随顺法。以此法律展转相教。复次五众罪法。四众罪法。三众罪法。二众罪法。一众罪法。复次六作舍法展转相教。复次波罗夷法。僧伽婆尸沙。波夜提。乃至越比尼罪。实非不实。时非不时。饶益非不饶益。软语非粗言慈心故。不求过。是名如法如律展转相教也。是比丘者。阐陀是也。诸比丘者谓一人多人僧三谏者屏处三谏。多人中三谏。僧中三谏也。屏处者。问言。长老汝实自用戾语。诸比丘如法如律教。汝自身作不可共语耶。答言。实尔。即便谏言。长老。汝莫自用戾语。诸比丘如法如律教。汝应当受。莫自身作不可共语。乃至展转相教。得善法增长故。我今慈心教。汝当舍此事。一谏已过二谏在。若不舍者。第二第三亦复如是谏。多人中三谏亦如是。犹不止者。僧中作求听羯磨。白言。大德僧听。是某甲比丘自用戾语。诸比丘如法如律教。不受其语。已于屏处三谏。多人中三谏。犹故不止。若僧时到当于僧中三谏。令止此事。即僧中问言。长老实自用戾语。诸比丘如法如律教。不受其语。屏处三谏。多人中三谏。犹故不受耶。答言。实尔。即复僧中谏言。长老莫自用意。诸比丘如法如律教。乃至展转相教。得善法增长故。今僧慈心谏汝。饶益故。当受僧语舍此事。僧一谏已过。二谏在。若不止者至第二第三谏舍者善。不舍者。僧伽婆尸沙僧伽婆尸沙者。如上说若比丘于屏处三谏。若多人中三谏时不止者。谏谏犯越比尼罪。僧中谏时。初谏时未竟越比尼罪。羯磨说竟。偷兰罪。第二羯磨未竟。越比尼罪。说竟偷兰罪。若第三羯磨未竟。偷兰罪。说竟僧伽婆尸沙。僧伽婆尸沙罪。起已屏处谏。乃至僧中一切越比尼罪。一切偷兰罪。皆合成一僧伽婆尸沙。中间止者。随止处治罪是故世尊说。若比丘自用戾语。乃至三谏不舍者。僧伽婆尸沙(十二戒竟)

佛住舍卫城。广说如上。时六群比丘于迦尸黑山聚落。作诸非威仪事。身非威仪。口非威仪。身口非威仪。身非威仪者。若走来走去。跳行跳踯。倒行匍匐。扣盆戏笑。递相担负。作如是比种种身戏。口非威仪者。作象鸣驼鸣。牛鸣羊鸣。长声短声。或相唃耳。作如是比种种音声戏笑身口非威仪者。令身斑驳半边白。涂面令黑。染发令白拍鼓弹琴击节舞戏。时诸优婆塞来诣比丘。欲礼拜听法。见如是事。心生不喜。便作是言。阿阇梨。沙门之法所为善行。当令不信者信。信者增信。而今所为悉皆非法。更令不信增长。信者心坏。六群比丘即嗔恚言。汝为我师。为我和尚。此是逆理。我当教汝。汝反教我。嗔恚增盛。作身害口害身口害。身害者。入其家中牵曳小儿。打拍推扑。破损器物。折犊子脚。刺坏羊眼。至市肆上种种谷米小麦大麦。盐糗酥油乳酪。悉和杂合。不可分别。田中生苗。其须水者开水令去。不须水者决令满中。刈杀生苗焚烧熟谷。是名身暴害。口暴害者。诣王谗人加诬良善。是名口暴害。身口暴害者。屏处藏身恐怖其人。牵挽无辜。是名身口暴害诸优婆塞皆嗔恚言。沙门释子作是非法。我等从今莫与供养。时彼比丘遂持钵乞食。其家见已。犹故与食。不至大惜。诸优婆塞复作是要。沙门释子作是暴害。我等从今莫令入门。然后是比丘便到诸不信家乞食。初时与食后续闻优婆塞断食不与。定是恶人。我何以与食。复不听入。然后便作身邪命。口邪命。身口邪命。身邪命者。作水瓶木器。卖作盛酥革囊绳索结网缝衣。学作饼卖学卖医药。为人传信。如是种种求食。是名身邪命。口邪命者。诵咒行术咒蛇咒龙咒鬼咒病。咒水咒火。如是种种求食。是名口邪命。身口邪命者。手自然火。口说咒术。手灌酥油洒散芥子。如是种种求食。是名身口邪命时黑山聚落诸优婆塞。来诣舍卫城。料理官事。官事讫已。往诣世尊。顶礼佛足已。却住一面白佛言世尊我是黑山聚落优婆塞。六群比丘在彼间住。于彼聚落作诸非法。广说如上。唯愿世尊。当约敕之。令不在彼住者善

尔时世尊为优婆塞。随顺说法示教利喜已。礼足而去。尔时世尊告阿难言。汝往黑山聚落。为六群比丘作驱出羯磨。尔时阿难白佛言。我不敢去。佛言。何故。阿难答言世尊六群比丘躁性强暴。我若往者譬如甘蔗田人乘车载甘蔗归。诸童子辈逆出村外。捉甘蔗乱取就外啖食。彼六群比丘亦复如是。闻我往者逆来道边作非法事。或能为我作驱出羯磨是故难去。佛告阿难。汝与三十人众俱去。足能伏彼。是时阿难与三十人。前后围绕。往到黑山聚落。复有三十比丘。闻尊者阿难往到黑山聚落。自相谓言。我未曾闻作驱出羯磨当随阿难到彼聚落。听作驱出羯磨。并前三十人合六十比丘。大众而去。时六群比丘闻尊者阿难与六十人俱眷属而来。为我作驱出羯磨。即生恐怖。时三文陀达多摩醯沙达多走到王道聚落长老阐陀迦留陀夷。便一由旬迎尊者阿难。即忏悔言。长老我所作非善。犯诸过恶。从今已去不敢复作。尔时众僧受其忏悔。尊者阿难前到聚落。彼二人已忏悔。二人已走去。余有残住者。为作驱出羯磨。世尊不听众羯磨。羯磨众故。二人三人为作羯磨。羯磨者。应作是说。大德僧听。是某甲比丘等。于此聚落身非威仪数作不止。道俗悉知。若僧时到。僧当为某甲比丘等身非威仪故作驱出羯磨如是白大德僧听是长老某甲。比丘等身非威仪。数数不止。道俗悉知僧今为某甲比丘等。作驱出羯磨。诸大德忍某甲比丘等身非威仪作驱出羯磨。忍者默然。若不忍者便说。是初羯磨说竟。第二第三亦如是说。僧已与某甲比丘等身非威仪作驱出羯磨竟。僧忍默然故。是事如是持。如是口非威仪身口非威仪亦如是。身害口害身口害。亦如是。身邪命。口邪命。身口邪命。亦如是。说白三羯磨。羯磨已。是六群比丘被驱出者语诸比丘言。阐陀比丘迦留陀夷比丘亦行非法。何故独驱我出而不驱彼。众僧语彼言。是二比丘于一由旬迎僧忏悔僧已听悔三文陀达多摩醯沙达多走到王道聚落。汝等现在既不迎僧忏悔。又复不走。故作羯磨驱出彼复作是言。长老僧今随爱随嗔随怖随痴。俱共同罪。有驱出者。有不驱者。诸比丘复谏。长老莫以。非理谤僧。僧不随爱不随嗔。不随怖不随痴不于同罪有驱出者有不驱者诸比丘如是谏时。彼故不止。复第二第三谏。坚持不止。尊者阿难为诸优婆塞。随顺说法。令其欢喜。供养众僧还复如前。尊者阿难及诸大众欲还舍卫。时诸比丘白尊者阿难。今僧悉还。是僧伽蓝与谁典知。阿难言。谁应任知。诸比丘言长老阐陀应住。阿难复言。阐陀先已有过。令他生不信。何可留住。便更安余比丘已。尊者阿难还舍卫城。礼世尊足。于一面立。世尊知而故问。阿难。汝等已于黑山聚落。作驱出羯磨耶。答言。已作世尊。阐陀比丘迦留陀夷比丘。于一由旬迎僧忏悔。三文陀达多摩醯沙达多。即便走到王道聚落。余诸比丘不来忏悔。复不走去。众僧为作驱出羯磨。彼见阐陀迦留陀夷不被驱出。便以非理谤僧言。僧随爱随嗔随怖随痴。有同共犯罪有驱出者。有不驱者。佛告比丘。是六群比丘以非理谤僧言。随爱随嗔随怖随痴。有同共犯罪有驱出者。有不驱者。作是语者。汝当去屏处三谏。多人中三谏。僧中三谏。令止此事。屏处问言。汝等实以阐陀比丘迦留陀夷故。非理谤僧言。随爱随嗔随痴随怖。俱共犯罪有驱出者。有不驱者耶。答言。实尔。即屏处谏言。长老。莫以非理谤僧。何以故。众僧不随爱不随嗔。不随怖不随痴。不于同罪有驱出者。有不驱出者。汝等莫作随爱随嗔随怖随痴。语言。长老。我今慈心谏汝。饶益故。当舍此事。一谏已过。二谏在。若不舍者。第二第三亦如是谏。及多人中三谏。犹复不止者。僧中作求听羯磨。羯磨人应作是说。大德僧听。是六群比丘以非理谤僧已。于屏处三谏。多人中三谏不止。若僧时到。当于僧中三谏令止此事。即于僧中问是比丘。汝实非理谤僧。已于屏处三谏多人中三谏不止耶。答言。实尔。僧应谏言。长老。莫以非理谤僧。何以故。僧不随爱不随嗔。不随怖不随痴。不同犯罪有驱出者。有不驱者。今僧慈心谏汝。饶益故。当舍此事。一谏已过二谏在。若不止者。第二第三亦如是谏。犹故不止。诸比丘以是因缘。具白世尊。六群比丘已屏处三谏。乃至僧中三谏。犹故不止。佛言。呼六群比丘来。来已佛问六群比丘。汝实非理谤僧。已屏处三谏。乃至僧中三谏。故不止耶。答言。实尔世尊。佛告六群比丘此是恶事。汝不闻世尊常赞叹易谏呵责难谏耶。汝今云何难谏。执持不舍。六群比丘。此非法非律非如佛教。不可以是长养善法。诸比丘白佛言。世尊。云何此六群比丘以阐陀迦留陀夷不驱出故。非理谤僧。佛言。此六群比丘不但今日以非理谤僧。过去世时。已曾非理谤僧。诸比丘言。已曾尔耶。佛言。曾尔。唯愿欲闻。佛言。过去世时有城。名波罗奈。国名伽尸。时王家畜养二狗。以金银锁系食用宝器。夜则解放令备守门户。时王得头痛病。经十二年疗治不差。后渐得差。时王于眠中闻狗吠声。王即惊觉头痛便增。王问侍者。向何等声。答言。狗吠。王即嗔怒。教敕侍者现狗驱出。即如教驱出。时有一狗问驱者言。何故驱我。驱者答言。王病小差。眠中闻狗吠声。惊觉增病。是故驱汝。狗复问言。一切狗尽被驱出耶。答言。尽驱出。又问。王家二狗亦被驱耶。答言。王家二狗不驱。余者尽驱。狗便嗔恚言。是王无道。随爱随嗔。随怖随痴。狗即说颂曰

  若以狗为患　　一切应驱出
  而今不尽驱　　如是王无道
  家自养二狗　　不遣独驱我
  当知是恶王　　随爱嗔怖痴

佛告诸比丘。时王家狗者。今阐陀迦留陀夷比丘是。余狗者。今余六群比丘是。尔时被驱以二狗不驱故。非理诽谤。今日被驱亦复如是。以阐陀迦留陀夷比丘不被驱故。非理谤僧。诸比丘白佛言。世尊。云何是阐陀比丘众人欲安处知事。而阿难不听。佛告诸比丘。是阐陀比丘不但今日欲还知事阿难不听。过去世时。已曾欲举为王。阿难不听。诸比丘白佛言。世尊。已曾尔耶。佛言如是。唯愿欲闻佛言。过去世时。雪山根底曲山壅中。有向阳暖处。有众鸟类云集其中。便共议言。我等今日当推举一鸟为王。令众畏难不作非法。众鸟言善。谁应为王。有一鸟言。当推鸧鹄。有一鸟言。不可。何以故。高脚长颈众鸟脱犯啄。我等脑众咸言尔复有一鸟言。当推鹅为王。其色绝白众鸟所敬众鸟复言。此亦不可。颜貌虽白项长且曲。自颈不直。安能正他。又复言。正有孔雀毛衣彩饰。观者悦目。可应为王。复言。不可。所以者何。衣毛虽好而无惭愧。每至舞时丑形出现。是故不可。有一鸟言。秃枭应为王。所以者何。昼则安静夜则勤伺。守护我等。堪为王者。众咸言可。尔时有一鹦鹉鸟。在一处住。有智慧。作是念。众鸟之法夜应眠息。是秃枭法。夜则不眠。而诸众鸟围侍左右。昼夜警宿不得眠睡。甚为苦事。我今设语。彼当嗔恚拔我毛羽。正欲不言。众鸟之类长夜受困。宁受拔毛不越正理。便到众鸟前。举翅恭敬。白众鸟言。愿听我说一偈。时众鸟即说偈答言

  黠慧广知义　　不必以年耆
  汝年虽幼小　　智者宜时说

时鹦鹉闻众鸟说偈。听已即说偈言

  若从我意者　　不用秃枭王
  欢喜时睹面　　尚令众鸟怖
  况复嗔恚时　　其面不可观

时众鸟咸言。实如所说。即共集议。此鹦鹉鸟聪明黠慧。堪应为王。便拜为王。佛告诸比丘。彼时秃枭者。今阐陀比丘是。鹦鹉鸟者。今阿难是。彼于尔时已曾遮彼。不听为王。今复遮彼。不听知事。佛告诸比丘。依止舍卫城比丘。皆悉令集。乃至已闻者当重闻。有诸比丘依止城。若聚落住。污他家行恶行。污他家亦见亦闻。行恶行亦见亦闻。诸比丘应语是比丘言。长老。汝等污他家行恶行。污他家亦见亦闻。行恶行亦见亦闻。长老。汝等出去不应是中住。是比丘语诸比丘言。大德。僧随爱随嗔。随怖随痴。何以故。有如是同罪比丘。有驱者。有不驱者。诸比丘应语是比丘言。长老。汝等莫作是语。僧随爱随嗔。随怖随痴。有如是同罪比丘。有驱者。有不驱者。何以故。僧不随爱不随嗔。不随怖不随痴。诸长老。汝等污他家行恶行。污他家亦见亦闻。行恶行亦见亦闻。汝等出去莫此中住。是比丘。诸比丘如是谏时。若坚持是事不舍者。诸比丘应第二第三谏。舍是事故。第二第三谏时。舍者善。若不舍者。僧伽婆尸沙。诸比丘者。若僧若多人。若一人依止城。若聚落住者。云何依止聚落住。若比丘于彼聚落中得衣被饮食床卧病瘦汤药等。是名依止住。若复不得衣食床卧病瘦汤药等。但依止聚落。得免诸难。亦名依止住。若复比丘不依聚落免难。但依止聚落界住者。亦名依止住。污他家者。他家名若刹利家。婆罗门家。若毗舍家。首陀罗家。是名他家。污者。若比丘于聚落中作非梵行。饮酒非时食。是不名污他家。若聚落中人先有信心供养众僧。兴立塔寺。令彼退灭。是名污他家。行恶行者。身非威仪。口非威仪。身口非威仪。身暴害口暴害身口暴害。身邪命口邪命身口邪命。污他家行恶行亦见亦闻者。作诸恶行聚落中人亦见亦闻。诸比丘语是比丘言。长老。汝等污他家行恶行。污他家亦见亦闻。行恶行亦见亦闻。莫此中住。是比丘作是言。诸长老。僧随爱随嗔。随怖随痴。有同罪比丘。有驱者。有不驱者。诸比丘复语是比丘言。长老。莫作是语僧不随爱不随嗔。不随怖不随痴。汝舍是事。是比丘故坚持不舍。非理谤僧者。六群比丘是也。诸比丘者。若僧若众多人。若一人三谏者。屏处三谏。多人中三谏。僧中三谏也。屏处谏者。屏处问言。汝长老。实以非理谤僧言。随爱随嗔。随怖随痴。有同罪比丘。有驱者。有不驱者耶。答言。实尔。即复呵言。长老。莫作是语。非理谤僧。何以故。僧不随爱不随嗔。不随怖不随痴。不于同罪中有驱者有不驱者。我今慈心谏汝。饶益故。当止此事。一谏已过二谏在。若不止者。复第二第三谏。多人中三谏。犹故不止者。僧中作求听羯磨。唱言。大德僧听。某甲比丘非理谤僧已。于屏处三谏。多人中三谏。犹故不止。若僧时到。今于僧中三谏。令止是事。僧中应问。长老汝实非理谤僧。作是语。僧随爱随嗔。随怖随痴。乃至屏处三谏。多人中三谏。犹故不止耶。答言。实尔。僧应谏言。长老。汝莫非理谤僧。何以故。僧不随爱不随嗔。不随怖不随痴。不于同罪有驱者有不驱者。今众僧慈心谏汝。饶益故。一谏已过二谏在。当舍此事。若不舍者。应第二第三谏。舍者善。若不舍僧伽婆尸沙。僧伽婆尸沙者。如上说。是比丘屏处谏时。三谏不止。谏谏越比尼罪。多人中三谏。亦复如是。僧中初说未竟。越比尼罪。说竟偷兰罪。第二说未竟。越比尼罪。说竟偷兰罪。第三说未竟。偷兰罪。说竟僧伽婆尸沙。僧伽婆尸沙。起已除四偷兰罪。非理谤僧诸余屏处三谏。多人中三谏。僧中三谏。一切越比尼罪。一切偷兰罪。都合成一僧伽婆尸沙。中间止者。随止处治罪。是故说。有诸比丘依止城。若聚落住。乃至第二第三谏时。舍者善。若不舍者。僧伽婆尸沙(十三戒竟)

    二不定法初

佛住舍卫城。广说如上。尔时长老优陀夷同聚落。旧知识婆罗门有一女。新到夫家。愁忧不乐。遣信白父愿来看我。若不能得来者。语阿阇梨优陀夷来看我。其父闻已。诣优陀夷所语言。我女新到夫家。愁忧不乐。遣信唤我。并唤阿阇梨。我今俗人多事不能得往。愿阿阇梨数数往看。优陀夷言。可尔。汝不嘱我尚欲往看。何况相嘱。长老优陀夷明日晨朝着入聚落衣。往到其家时彼女人。掩户而坐。优陀夷在外唤言。某甲在不。女言是谁。答言。我是优陀夷。女言。阿阇梨来入。阿阇梨来入。即入其房。于房内坐。与共语言时。姑毗舍佉鹿母。有三十二子。亦有三十二儿。妇皆悉福德吉相成就。是时毗舍佉鹿母。常教诫儿子。诸妇劝导父母亲属。次到是女房前。是毗舍佉鹿母。善解时宜不卒入房。踟蹰户外。户孔中见房内有人剃发着染衣。睩瞬细语。知是出家人。但不知是比丘。为是比丘尼。便唤此妇。妇应曰。是谁。答言。是我。白言。大家来前。问汝边是谁妇。答言。阿阇梨优陀夷。优陀夷言。优婆夷。何以不前。鹿母即入而作是言。阿阇梨优陀夷。此间坐耶。答言。如是。白言。阿阇梨此坐非明白处。设有善恶。谁证知者。当以此事。语诸比丘。优陀夷言。汝说何等。毗舍佉鹿母言。见优陀夷与女人共坐。优陀夷言。我亦当向佛说汝。毗舍佉鹿母言。欲说何等。优陀夷言。我见毗舍佉鹿母。与他男子共坐。毗舍佉鹿母言。何等男子。优陀夷言。我非男子耶。毗舍佉鹿母言。阿阇梨。佛不制我不与男子共坐。然阿阇梨是出家人。应护沙门法。优陀夷言。咄哉。汝恼我不少。便起出去。复在一露处。与女人共坐。毗舍佉鹿母教诫儿妇已出。复见优陀夷与女人露处共坐语。往到其边。语优陀夷言。此是不善。非沙门法。云何与女人露处共坐。当以是事语诸比丘。优陀夷言。何所说。毗舍佉鹿母言。见优陀夷独与女人露处共坐。语优陀夷言。我亦当向佛说汝事。毗舍佉鹿母言。为何所说。优陀夷言。我见鹿母与男子露处共坐语。毗舍佉鹿母言。何等男子。答言。我非男子耶。毗舍佉母言。我是俗人共男子坐。佛法所听。尊是沙门应自防护。云何尔耶。优陀夷言。汝处处恼我。作是语已。即便起去。时毗舍佉母即以是事白诸比丘。诸比丘以是事。具白世尊。佛言。唤优陀夷来。即便唤来。佛问优陀夷。汝实尔不。答言。实尔世尊。佛告优陀夷。此是恶事。汝愚痴人。俗人尚知出家宜法应行不应行。汝出家人而更不知坐起言语。应与不应与。汝常不闻世尊种种因缘呵责随顺淫欲赞叹离欲耶。汝今云何作此恶事。此非法非律。非如佛教。不可以是长养善法。佛告诸比丘。依止舍卫城比丘皆悉令集。集已。尔时世尊以是因缘。向诸比丘广说过患事。起种种因缘。呵责过患。起已为诸比丘随顺说法。有十事利益故。如来应供正遍知为诸弟子制戒。立说波罗提木叉法。何等十。一者摄僧故。二者极摄僧故。三者令僧安乐故。四者折伏无羞人故。五者有惭愧者得安乐住故。六者不信者令信故。七者已信者增益信故。八者于现法中得漏尽故。九者未生诸漏令不生故。十者正法得久住为诸天世人开甘露施门故。是名十。如来应供正遍知为诸弟子制戒。未闻者闻。已闻者当重闻。若比丘与女人独屏覆处。可淫处坐。可信优婆夷。于三法中一一法说。若波罗夷。若僧伽婆尸沙。若波夜提。比丘自言。我坐是处。三法中一一如法治。若波罗夷。若僧伽婆尸沙。若波夜提。应随可信优婆夷。所说如法治。彼比丘是初不定法。若比丘与女人独露现处。不可淫处坐。可信优婆夷。于二法中一一法说。若僧伽婆尸沙。若波夜提。比丘自言。我坐是处。二法中一一如法治。若僧伽婆尸沙。若波夜提。应随可信优婆夷。所说如法治。彼比丘是二不定法。比丘者受具足善受具足。一白三羯磨。无遮法和合。非不和合十众。十众已上年满二十。非不满二十。是名比丘。女人者。若母姊妹亲里非亲里。若老若少在家出家。屏覆者。若闇处。若覆障处。可淫处者。男女共事无可羞处。独者。一男一女。更无余人。设有余人。若眠若狂若婴儿非人畜生。亦名独。共坐者。相近坐。可信优婆夷者。成就十六法。名可信优婆夷。何等十六。归佛归法归僧。于佛不坏净。于法不坏净。于僧不坏净。僧未得利能令得。已得利能令增长。僧未有名称能令名闻远着。僧有恶名能速令灭。不随爱不随嗔。不随怖不随痴。离欲向成就圣戒。是十六法成就者。是名可信。是比丘自言知事。不知坐应治是事。若言知坐不知事应治坐。若言知事知坐应二俱治。若言不知事不知坐者。应如优婆夷所说。应作觅罪相羯磨治。比丘者。如上说。女人者。若母姊妹。若大若小。在家出家。独者。一男一女。更无余人。设有人者。若眠若狂婴儿非人畜生。是亦名独。露现处者。明中露地。无诸屏障。是名露现处。不可淫处者。若男女共事可羞耻处。坐者。相近坐也。可信优婆夷处。成就十六法。如上说是名可信也。是比丘自言知事。不知坐应治是事。若言知坐不知事。应治是坐。若言知事。知坐应二俱治。若言不知事亦不知坐者。应如可信优婆夷所说。应作觅罪相羯磨治。是故说。若比丘与一女人独屏覆处。可淫处坐。乃至可信优婆夷所说。如法治彼比丘。是初不定法。若比丘与女人独露现处。不可淫处坐。乃至可信优婆夷所说。如法治彼比丘。是二不定法(二不定竟)

摩诃僧祇律卷第七摩诃僧祇律卷第八

        东晋天竺三藏佛陀跋陀罗共法显译

    明三十尼萨耆波夜提法之初

佛在毗舍离大林重阁精舍。广说如上。尔时长老难陀优波难陀游诸聚落。多得衣物满车载来。尔时世尊晨朝时闻重车声。知而故问。诸比丘何等车声。诸比丘白佛言。世尊。是长老难陀优波难陀。游诸聚落多得衣物满车载来。是彼车声。世尊即时便作是念。我诸弟子乃尔多求衣物。后于一时冬中八夜大寒雨雪。时世尊初夜着一衣。在有觉有观三昧。至中夜时。觉身小冷。复着第二衣至后夜时。复觉身冷。着第三衣。便作是念。我诸弟子齐是三衣。足遮大寒大热。防诸蚊虻覆障惭愧不坏圣种。若性不堪寒者。听弊故衣。随意重纳。于是世尊夜过晨朝。诣众多比丘所。敷尼师檀坐。语诸比丘。我一时晨朝闻重车声。问诸比丘。何等车声。诸比丘言。长老难陀优波难陀。游诸聚落多得衣物。是彼车声。我作是念。我诸弟子多求衣物。广生乐着。我复一时冬中八夜。乃至重着三衣。便作是念。我诸弟子齐此三衣。足止大寒大热防诸蚊虻。覆障惭愧不坏圣种。我从今日听诸比丘。齐畜三衣。若得新者两重作僧伽梨。一重作郁多罗僧。一重作安陀会。若性不堪寒者。听弊故衣。随意重纳

复次佛住毗舍离。广说如上。时一聚落中有三摩诃罗比丘共住。一摩诃罗死。有多衣物。而不知分。一比丘言。我须僧伽梨。第二复言。我亦须之。如是一一物皆竞欲得不能断。当尔时优波难陀游诸聚落。过彼住处。是摩诃罗等遥见彼来。便作是念。是释种子端正姝好。佛种出家。当为我等止此诤事。即便白言。我此住处有诸衣物。各竞欲取不能得分。尊者。今日为我止此诤事。得分衣物。优波难陀答言。我今为汝分物多起怨嫌。摩诃罗言。不为我分者。谁当分之。我等宁可诣诸外道。求分物耶。优波难陀复言。当先作要随我语者。我当为分。答言从教。语言。尽出物来。即便出之。随为分作三分。时摩诃罗作是念。我正有二人而作三分。彼故当欲取一分耶。宁使取一分。且止我诤分为三分已。复问摩诃罗言。物尽出来。莫使后复致诤。有不欲出者。第二人复持来出。答言已尽。时优波难陀在二分中间立。二摩诃罗中间着一分。作是言。汝等。听我说羯磨。答言尔。便作是言。是二分并我如是。我有三。汝二共一如是。汝有三是三彼三。二三平等不是。摩诃罗已先作要。又复畏难释种子故。不敢复言。是二摩诃罗共得一分。故不知分。复白言。长老。我今此分当云何分。尔时优波难陀即与分作二分。摩诃罗便各持去。尔时诸比丘以是因缘。往白佛言。云何世尊。是优波难陀欺彼摩诃罗比丘。佛语诸比丘。是优波难陀不但今日欺彼比丘。过去世时已曾欺彼。诸比丘白佛言。已曾尔耶。答言曾尔。过去世时南方国土。有无垢河河中有二水獭。一者能入深。二者入浅。时入深水者。捕得一鲤鱼。如生经中广说

复次佛在毗舍离。广说如上。有五事利益故。如来五日一行诸比丘房。尔时世尊遍行诸房。至难陀房中。见其房内多畜衣物。有桁晒衣物者。有缝衣者。染衣者。打衣者。作净者。难陀如是分处。喻如欲作大会布施一切僧物。时世尊知而故问难陀。是谁衣物。答言我许。佛言。比丘此衣太多。难陀白佛言。世尊。先听两重僧伽梨。一重郁多罗僧。一重安陀会。佛言。此衣故多。答言。世尊。我有共行弟子。依止弟子等衣物。各作两重僧伽梨。一重郁多罗僧。一重安多会。及作沙弥等衣。佛言。此衣犹多。又白世尊。我出家人临时难得。是故此诸衣物浣染作竟。举着器中。若衣坏时。当取易代。佛告难陀。此是恶事。汝出家人。云何计常贪着。汝常不闻世尊呵责多求多欲难满。赞叹少欲知足耶。汝今多欲难满。广求衣物积畜余长。此非法非律。非如佛教。不可以是长养善法。云何畜长衣受用。从今已去。若有长衣听一宿。诸比丘白佛言。世尊。云何是难陀多畜诸衣不知厌足。佛告诸比丘。是难陀不但今日多畜诸衣不知厌足。过去世时已曾多畜不知厌足。如鸟生经中广说

复次佛住俱舍弥。为诸天世人恭敬供养。世尊时到着入聚落衣。持钵入俱舍弥城。次行乞食。尔时国王夫人名舍弥。以千五百张[疊*毛]。奉上世尊。佛告阿难。持是[疊*毛]衣与诸比丘。长老阿难即持与诸比丘。诸比丘不受。语阿难言用劫贝为浣染。未竟已不如法。时阿难以是因缘。往白世尊。佛告阿难。从今已去若得长衣听至十日。有诸比丘。长衣满十日。持是诸衣往白世尊。此衣满十日。今当云何。佛告比丘。若知识比丘边。作净施法。若复舍故受新。十日一易。复次佛在毗舍离。毗舍离人年年饭僧食已。布施衣物。诸比丘不受。诸檀越诣佛所。礼足已白佛言。颇有方便。听诸比丘取衣受用。令施者得福。受者得利不。佛言得。如上广说

尔时世尊告诸比丘。依止毗舍离比丘。皆悉令集。以十利故。为诸比丘制戒。乃至已闻者当重闻。若比丘衣已竟。迦絺那衣已舍。若得长衣得至十日畜。过十日者。尼萨耆波夜提。衣已竟者。比丘三衣已成。是名衣竟。不受迦絺那衣。亦名衣竟。已舍迦絺那衣。亦名衣竟。浣染衣讫亦名衣竟。衣者钦婆罗衣。劫贝衣。刍摩衣。俱舍耶衣。舍那衣。麻衣。躯牟提衣。复有衣名僧伽梨。郁多罗僧。安陀会。尼师檀。雨浴衣。覆疮衣。纳衣。居士衣。粪扫衣。若作若不作。如法衣。不如法衣。知识衣。迦絺那衣。已舍者。舍迦絺那衣。有十事舍。受衣舍。衣竟舍。时竟舍。闻舍。出去舍。失去舍。坏舍。送衣舍。时过舍。究竟舍。齐十日者。数极至十日也。长衣者。除所受持衣。余衣是过十日尼萨耆波夜提。尼萨耆波夜提者。是长衣应僧中舍。波夜提罪忏悔。不舍而悔者。越比尼罪。波夜提者。能堕恶道。开罪现罪举罪。施设罪名也。若比丘一日得十领衣乃至十日不作净。过十日一切尼萨耆波夜提。若比丘一日得十领衣。半作净。半不作净。若作净者。是应净法。半不作净者。过十日尼萨耆波夜提。若比丘一日得衣。二日作净。二日复得衣。三日作净。三日复得衣。四日复作净。四日复得衣。五日作净。五日复得衣。六日作净。六日复得衣。七日作净。七日复得衣。八日作净。八日复得衣。九日作净。九日复得衣。十日作净。十日复得衣。至十一日。一切尽尼萨耆波夜提。以相续不断故。若比丘一日得衣。即日作净乃至十日得衣。十日作净。十一日得衣。十一日作净。犯越比尼罪。以无间故。间者。比丘一日得衣。更停九日。二日得衣更停八日。三日得衣更停七日。四日得衣更停六日。五日得衣更停五日。六日得衣更停四日。七日得衣更停三日。八日得衣更停二日。九日得衣更停一日。十日得衣即十日作净。十一日得衣不应受。是名间。若比丘前得衣多后得衣少。以前衣力故。得尼萨耆波夜提。若比丘前得衣少后得衣多。以前衣力故。尼萨耆波夜提。若比丘前衣有中间无。若有者尼萨耆波夜提。若比丘前衣无中间有。若有者尼萨耆波夜提。比丘不受迦絺那衣。谓受想。舍迦絺那衣不舍想。不受衣谓受想。不作净谓净想。不与谓与衣想。不记识谓记识想。愚内心非处作净。不受迦絺那衣谓受想者。比丘不受迦絺那衣。自谓已受。长衣过十日尼萨耆波夜提。舍迦絺那衣不舍想者。比丘已舍迦絺那衣。而自谓未舍长衣。过十日犯尼萨耆波夜提。不受衣谓受想者。若比丘三衣自不受。便谓已受想。不作净过十日尼萨耆波夜提。不作净谓净想者。比丘畜长衣不作净施。而谓已作净施。过十日尼萨耆波夜提。不与谓与想者。是衣不与塔。不与僧。不与人。而谓呼与过十日尼萨耆波夜提。不记识谓记识想者。若比丘不记识。言此是尼师檀。此是覆疮衣。此是雨浴衣。而谓记识不作净。过十日尼萨耆波夜提。愚者。若比丘得衣愚闇故。不作净。过十日尼萨耆波夜提。内心者。内心说净。而口不言。是名非法净。犯越比尼罪。若口说者无罪。非处者。若俗人若畜生。若无心边作净。是不名作净。过十日尼萨耆波夜提。优波离白佛言。世尊比丘长衣应作净。何等人边作净。佛告优波离。当于比丘比丘尼式叉摩尼。沙弥沙弥尼边作净。又问。相离近远。得从彼作净。佛言。齐三由旬。知其存亡。优波离白佛言。世尊。长衣沙弥边作净。是沙弥受具足。当云何。佛言。称无岁比丘名作净。优波离复问。是无岁比丘若死者云何。佛言。得停十日。于余知识边作净。复问齐几许应作净。几许不作净。佛言广一肘长二肘。应作净。若比丘二人共物未分不犯。若分得已应作净。若不作净过十日者尼萨耆波夜提。若比丘婆罗门舍。请僧食并施衣物。有病比丘。嘱人取衣分。是比丘持衣分来。虽久未与不犯。若得已应作净。不作净者。过十日尼萨耆波夜提。若比丘闻若师若弟子送衣。与未得虽久不犯。若得已应作净。若不作净。过十日尼萨耆波夜提。若比丘令织师织衣。衣竟虽久。未与比丘不犯。得衣已应作净。若不作净。过十日尼萨耆波夜提。若比丘买衣。虽价决了。未得不犯。得已应作净。若不作净。过十日尼萨耆波夜提。若比丘为佛为僧供养故求衣物集在一处。虽久未用不犯。若比丘于佛生处。得道处转法轮处。阿难设会处。罗云设会处。五岁会处。大得布施诸衣物。是物入僧。末分者虽久不犯。是物已分。多人共得一分。中有善毗尼人。能为众人同意作净者无罪。若不作净者。过十日犯尼萨耆波夜提。若比丘道路行恐畏处。藏衣而去。过十日取者尼萨耆波夜提。若有人取是衣物。持来与比丘者。亦尼萨耆波夜提。若比丘为贼所逐。遂便舍衣走。过十日已有人得衣来。还比丘者无罪。不失失想失不失想若失失想。皆不犯。过十日无罪。不失不失想。过十日尼萨耆波夜提。若比丘长衣过十日。欲舍衣者。当求持律比丘。能羯磨人请诸知识比丘。出界外。若无界场应结小界羯磨者。应作是说。大德僧听。若僧时到僧于此地。齐僧坐处外。一寻以内。于其中作羯磨。诸大德听。于此处齐僧坐处。外一寻已内。于其中作羯磨。僧忍默然故。是事如是持不羯磨地者。不得作僧事。若作者得越比尼罪。律师应语是比丘言。汝舍此衣。是比丘应胡跪合掌作如是言。大德僧忆念。我某甲比丘是长衣过十日。犯尼萨耆。我今于僧中舍。持律复问。汝是衣曾受用不。若言受用。应语。汝得波夜提罪。受用不净衣故。随用得越比尼罪。若言不受用者。语言。汝得波夜提罪。是比丘于持律前胡跪合掌白言。长老忆念。我某甲长衣过十日已。于僧中舍。此中犯波夜提罪。今于长老前悔过。不敢覆藏持律问言。汝自见罪不。答言见。应教更莫复作。答言尔。如是第二第三说。若受用者长老忆念。我某甲比丘长衣。过十日已于僧中舍。此中犯波夜提罪。及受用不净衣随用。得越比尼罪。是一切罪。今向长老诚心悔过。不敢覆藏。持律问言。汝自见罪不。答言见。汝更莫作。答言顶戴持。如是第二第三说。律师问。此众中谁是汝知识。答言某甲。即语随次坐。应说羯磨。大德僧听。某甲比丘长衣过十日已。于僧中舍已如法作。若僧时到。僧持此衣。与某甲知识比丘如是白。大德僧听是某甲比丘长衣过十日已。于僧中舍已如法作。僧今持此衣与某甲。知识比丘诸大德忍。持此依与某甲。知识比丘者。默然。若不忍者便说。是初羯磨。如是第二第三说。僧已忍。持此衣与某甲知识比丘竟。僧忍默然故。是事如是持。是知识比丘应即日若明日还彼衣。亦不得于众僧前还。亦不得停久过半月还也。是比丘得衣已。若受持若作净。若不知受持。及不知作净者。当教言。我某甲此僧伽梨。此郁多罗僧。此安多会。尽受不离宿受持。如是三说。若作净者。应教言。我某甲比丘。是长衣净施与某甲。某甲于我边不计意。若浣染缝有因缘事。当随意用。如是三说。若比丘衣已竟。迦絺那衣已舍。长衣齐十日。畜过十日者。尼萨耆波夜提。是故说

佛住舍卫城。广说如上。有一婆罗门请众僧经宿供养。并施衣物。诸比丘闻彼请僧。各作是念。今时和适不寒不热。我等但着上下衣往。若彼得施衣。当作三衣受持。即便着。上下衣去

尔时世尊以五事利益故。五日一行诸比丘房。开一房户见架上多衣。世尊知而故问。架上多衣者为是谁许。有病比丘白世尊言。有婆罗门。请诸比丘经宿供养布施衣物。是诸比丘以天时暖。留此诸衣。着上下衣去。若彼得施衣。当受作三衣。佛告诸比丘当知如来应供第一乐人。出家离第一乐。而随所住处。常三衣俱持钵乞食。譬如鸟之两翼。恒与身俱。汝等比丘云何舍本族姓。以信出家应当如是所至到处法衣随身。不应离宿。复次佛在舍卫城。安居讫诣王舍城。时有一比丘。王舍城中以信出家。于余聚落安居讫。闻世尊安居讫诣王舍城。我今当往问讯世尊。并从佛去过看亲里。天时不寒不热。我当留一衣。但着上下衣去。乃至。世尊种种呵责比丘之法。法衣应器常与身俱。譬如鸟飞毛羽自随。不应离宿。复次佛住王舍城迦兰陀竹园精舍。长老舍利弗作是念。我今当为饶益亲里故往诣那罗聚落安居。意复不欲远离世尊。以恭敬故。难往白佛。诸比丘闻已。即以是事广白世尊。佛告诸比丘。从今日听王舍城竹园精舍。僧那罗聚落僧共作一布萨界。令舍利弗安乐住羯磨者。应作是说。大德僧听。从今日王舍城竹园精舍那罗聚落。作一布萨界。若僧时到。僧今从王舍城竹园精舍那罗聚落。共作一布萨界。如是白。白一羯磨。乃至僧忍默然故。是事如是持。尔时尊者舍利弗于那罗聚落结安居。日日诣竹园精舍。礼世尊足。值天七日连雨。便作是念。我今体羸。是僧伽梨重。正欲持去。被雨遂重若不持去脱不得还。便应舍堕。且住待雨晴已。往诣世尊。道逢诸外道。即共论议。如沙门果经中说。然后往诣世尊。礼拜问讯。佛知而故问。舍利弗何以多日不现。即向世尊。广说上事。尔时世尊告诸比丘。从今日后王舍城竹园精舍那罗聚落。作不离衣宿界。令诸比丘得安乐住羯磨者。当作是说。大德僧听。今从王舍城竹园精舍至那罗聚落。除聚落及聚落界。作不失衣法。若僧时到僧从王舍城至那罗聚落。除聚落及聚落界。作不失衣法。如是白。大德僧听。从王舍城竹园精舍。至那罗聚落。除聚落及聚落界。僧今于是中作不失衣法。诸大德忍从王舍城至那罗聚落。除聚落及聚落界。是中作不失衣法者默然。若不忍者便说。僧已忍。从王舍城至那罗聚落。除聚落及聚落界。作不失衣法竟。僧忍默然故。是事如是持。作不失衣法已。此王舍城趣那罗聚落道两边。各二十五肘名为界。若衣在道中得道。左右各二十五肘置衣。王舍城得至那罗聚落无罪。置衣那罗聚落。亦如是。王舍城竹园精舍那罗聚落。亦复如是。如舍利弗因缘目揵连因缘。亦复如是。复次世尊住舍卫城祇洹精舍有一比丘。食后欲诣开眼林坐禅。便作是念。我或于彼中宿。便失僧伽梨。即持三衣去。过见世尊。佛知而故问。比丘何以多持衣行。答言。世尊。我欲往开眼林坐禅。暮脱不还。恐失僧伽梨故。持三衣去。佛告诸比丘。从今日后从祇洹林。至开眼林。东坊精舍。西坊精舍。东林精舍。西林精舍。王园精舍。受筹塔婆罗林精舍。尽同作不失衣法。令诸比丘得安乐住。羯磨者。应作是说。大德僧听。今从祇洹至开眼林。东林精舍乃至受筹塔。是中除聚落及聚落界。若僧时到僧从祇洹林。乃至受筹塔羯磨。作不失衣法。如是白。大德僧听。从祇洹林乃至受筹塔。是中除聚落及聚落界。僧今作不失衣法。诸大德忍。从祇洹林至开眼林。乃至受筹塔。作不失衣法。忍者僧默然。若不忍便说。僧已忍。从祇洹林至开眼林。乃至受筹塔。作不失衣法竟。僧忍默然故。是事如是持。复次佛住舍卫城祇洹精舍。尔时舍卫城中失火。时城中诸人象马车乘男女担负衣物出城。诸比丘多于城中寄衣畏火烧衣故。急走向城。城中诸人不信佛者。皆呵责言。我等火逼出城避难。是沙门等向城而走。如蛾赴火。有何急事。时有人言。汝莫语此沙门辈不顺正理。欲取人物。譬如贼伺人慢藏。如医治病。以自济活。是沙门辈亦复如是。伺人灾患向城而走是坏败人有何道哉。诸比丘闻已。以是因缘。具白世尊。佛言。呼是比丘来。即呼来已。佛问诸比丘。汝等何故向城而走。为世人所嫌。答言。我等衣物先在城中。城中失火。畏火烧故。走往取之。佛问比丘。汝等云何僧不作羯磨。而离衣宿。答言作羯磨。复问云何作。答言。通结舍卫城。佛告比丘。汝等云何阿练若处。通结聚落。从今已后不听阿练若处通结聚落。应阿练若处通结阿练若处。聚落处通结聚落处。若阿练若处通结聚落。聚落处通结阿练若处者。得越比尼罪。佛告诸比丘。依止舍卫城比丘。皆悉令集。以十利故。为诸比丘制戒。乃至已闻者当重闻。若比丘衣已竟。迦絺那衣已舍若三衣中离一一衣余处。一宿除僧羯磨。尼萨耆波夜提。衣竟者。三衣已成是名衣竟。不受迦絺那衣亦名衣竟。舍迦絺那衣亦名衣竟。浣染竟亦名衣竟。衣者。劫贝衣。钦婆罗衣刍摩衣。憍奢耶衣。舍那衣。麻衣。躯牟提衣。舍迦絺那衣者。有十事。从受衣舍。乃至究竟舍。一宿者。从日未没至明相出时。三衣者。僧伽梨。郁多罗僧。安陀会除僧羯磨者僧不作羯磨。不听离衣宿。设作羯磨白不成就。羯磨不成就。众不成就。若羯磨一一不如法。是名不作作。羯磨者。白成就。羯磨成就众成就一一羯磨如法。是名僧作羯磨。世尊说无罪。尼萨耆波夜提者。此衣应僧中舍。波夜提。应悔过。不舍而悔者。得越比尼罪。波夜提者。如上说。界者。羯磨界。游行界。依止界。七庵婆罗界。羯磨界者。广略聚落称名标帜。随曲避难。诸方广者。如摩头罗国。有丛林精舍。摩头罗东有遥扶那河河东有仙人聚落精舍。时仙人聚落精舍。比丘遣使白丛林精舍僧言。我欲共结一布萨界。问言。何以故。答言。彼间多好饮食。得别房衣。得安居衣是故欲同应报言。为衣食来者。此非所宜。但彼间住。若言我所住处多年少比丘。不善契经比尼阿毗昙。不善观阴界入十二因缘是故欲来就诸长老学契经毗尼阿毗昙。阴界入观十二因缘。彼应语言。汝后僧作羯磨法事时。不作障碍者。当共汝同应。语一切比丘尽来。若不来者。一切尽出界去。若来若出界去。已当作羯磨。羯磨者。应作是说。大德僧听。从今丛林精舍仙人聚落精舍。是中内界外界内外界中间界。若僧时到。僧是丛林精舍仙人聚落精舍。是中共作一布萨界。如是白大德僧听。是丛林精舍仙人聚落精舍。是内界外界内外界中间界。僧今共作一布萨界。诸大德忍。从丛林精舍仙人聚落精舍。是二界共作一布萨界者默然。若不忍便说。僧已忍。磨头罗丛林精舍。仙人聚落精舍。是二界共作一布萨界竟僧忍默然故。是事如是持。若中间无河水者。应一处作羯磨。中有河水者。应三处作羯磨。一摩头罗精舍。二水中。三仙人聚落精舍。若河水中有洲者。应五处作羯磨。一摩头罗精舍。二水中。三洲上。四水中。五仙人聚落。如陆地道两边。各二十五肘。水中亦尔。一时夏水涨。比丘受欲来应羯磨。为水所漂出界去。殆死得出。白诸比丘。我向持欲来为水所漂。殆死得出。今可广结界不。诸比丘言得。汝去上下水三由旬作识。若树若石若堆。如是等作识来。说羯磨者。应作是言。大德僧听。从磨头罗精舍至仙人聚落精舍。从分齐以来内界外界内外界中间界。上下水中。若僧时到。僧从摩头罗精舍至仙人聚落精舍。河水上下从分齐已来。作一羯磨布萨界。如是白。白一羯磨。乃至僧忍默然故。是事如是持。复有一时持欲来赴羯磨。就船欲渡。船师挽船上流。然后当渡。语比丘言。船重难牵。汝可步去。至应渡处便上。是比丘以持欲故。不应上岸。出界失欲故。便于岸底涉水而进。船去疾。遂出界分。比丘即于界内。直浮趣船。水复漂船下过三由旬。比丘复应舍船。直浮趣岸。到彼已涉水寻岸而上。到道口入界内。然后上。岸是名广说。略说者。羯磨人应作是说。大德僧听。今从摩头罗精舍。至仙人聚落精舍。内界外界内外界中间界。若僧时到。僧今从摩头罗精舍。仙人聚落精舍。共作一布萨界。如是白。白一羯磨。乃至僧忍默然故。是事如是持。是名略说界。聚落界者。如磨头罗西精舍。聚落精舍。欲共作一布萨界者。应称名齐三由旬内诸精舍。作一羯磨。羯磨者。应如是说。大德僧听。从今日恬精舍车精舍。胜精舍。不乱精舍。贤精舍。戒次第精舍。螺精舍。酪村精舍。黄精舍等。是诸精舍内界外界内外界中间界。若僧时到。僧是诸精舍共作一布萨界。如是白。白一羯磨。乃至僧忍默然故。是事如是持。是名聚落界称名界者。说羯磨比丘不知诸精舍名。令旧比丘知名字者。僧中唱诸精舍名字已。羯磨者。应作是说。大德僧听。从今日是某甲比丘所说诸精舍名字。内界外界内外界中间界。是诸精舍共作一布萨界。若僧时到僧某甲比丘所说诸精舍名字。共作一布萨界。如是白。白一羯磨。乃至僧忍默然故。是事如是持。是为称名界。幖帜界者。作如是言。大德僧听。从今日齐幖帜。若石若山。若井若埠。若树内界外界内外界中间界。作一布萨界。若僧时到。僧齐幖帜若石若山。若井若树。共作一布萨界。如是白。白一羯磨。乃至僧忍默然故。是事如是持。若羯磨人不知幖帜者。先令旧比丘僧中唱。如上称名界。说是名幖帜界。随曲界者。有聚落边精舍故坏多。有供养众僧敷具。欲与诸精舍比丘共作一布萨界。修治精舍。共用此物。诸处比丘有欲共者有不欲共者诸欲共者。应尽来集。若出界去。其不欲者。自当精舍界作标帜住。诸欲共者。来集一处已羯磨者应作是言。大德僧听从今日此一住处某甲住处。齐幖帜内界外界内外界中间界。共作一布萨界。若僧时到僧此住处某甲比丘住处齐幖帜以来共作一布萨界。如是白。白一羯磨。乃至僧忍默然故。是事如是持是名随曲界。避难界者一住处。诸比丘。前安居后安居日已过。有事难起。若贼难王难。若夺命若破戒。若水多虫漉不能净欲至余精舍避此诸难去三由旬内。若彼有比丘。若呼来若出界去。羯磨者。作是说大德僧听。今日是住处彼某甲聚落精舍。内界外界内外界中间界。共作一布萨界。若僧时到。僧从今日是中住处。彼某甲聚落精舍。共作一布萨界。如是白白一羯磨。乃至僧忍默然故。是事如是持。若到彼处。复欲就余精舍者。当舍先界。应作是说。大德僧听。是住处先住处作别说戒。若僧时到僧。是住处先某住处。作别说戒。如是白。白一羯磨。乃至僧忍默然故。是事如是持。僧复欲进前精舍者。复取三由旬内。共作一布萨界。复欲进前者。当舍后结前。乃至前求适意住处。如是随意结随意舍。是名避难界。诸方界者。若比丘夏安居中。若诸难起。若王难若贼难。若夺命难若破戒。若水多虫漉不可净。随四方各三由旬内。自在结界。亦如上说。若难卒至不得作羯磨。出去无罪。是名诸方。是谓羯磨界。游行界者。六十家聚落界隔障界。楼阁界两道界。井界树界。园界连蔓界。暂宿界船界。舍内界并界。六十家聚落界者。如释迦梨国大聚落。苏弥国大聚落。摩头罗国大聚落。巴连弗邑大聚落。是诸聚落各别起屋。若比丘置衣在一屋。人在第三屋宿。日光未灭去至明相出时还。尼萨耆。日光灭去至明相。出还无罪。日光未灭去明相未出还无罪。一切屋中尽有比丘住者无罪。若结界者无罪。周匝有垣墙者无罪。周匝有堑者无罪。周匝有渠水者无罪。共一门者无罪。若道于聚落中过。若比丘衣在道左。身度道右。日光未灭去至明相出。亦如上说。若比丘道中卧。持三衣枕头。衣离头者尼萨耆。以不可截衣故。一切应舍。若聚落周匝墙围绕。若堑若篱。若一门门有闭者。皆无罪是名六十家聚落界。隔障界者。亦如是。楼阁界者。若挮阁道外。各二十五肘为界。若比丘置衣阁上。过二十五肘。日光未灭去至明相出还。尼萨耆。日光灭去明相出还无罪。日光未灭去明相未出还无罪。若比丘楼阁上住畏贼来攻楼阁。故持衣出楼阁外。二十五肘外藏。还楼阁上宿。日光未灭去至明相出还。尼萨耆。亦如上说。若比丘夜中大小行。离衣二十五肘内。与衣合无罪。是名楼阁界。两道界者。步道车道步道者有比丘畏寒故。至诸暖国。或畏热故。诣诸凉国道行时。师与诸伴共行。并论议而去。弟子持衣钵。从后来不及师。师至日没时。畏离衣宿故。出道外。待弟子。弟子持衣直过不见师。至天晓相待。若是师待衣处。离道二十五肘内。与衣合者不犯。过二十五肘外者。尼萨耆若弟子持衣在前行日没时。作是念。莫令我师离衣宿。即住道外待。师行。极眠不觉。师过至晓相问。亦如上说。是名步道。车道者。比丘与乘车估客共行。置衣车上畏尘坌故。在前去。至日没时畏离衣宿故。应住道外二十五肘内。令车尽过。与衣合故不犯。若比丘置衣车上。随车后行。至日没时不识。何者是己衣车。比丘尔时应去车二十五肘内。绕车营一匝。与衣合故不犯。若高大车一蹬两蹬三蹬挮上者。比丘置衣车上在下住。从日光未灭至明相出时。尼萨耆。亦如上说。若于夜中暂内手车上者不犯。若比丘在车上宿。置衣车下。若在车前置衣车后。若在车后置衣车前。若在车左置衣车右。若在车右置衣车左。日光未灭至明相出时。皆尼萨耆。若比丘置衣车上。离车二十五肘外。静处宿者。日光未灭去至明相出时还。尼萨耆。亦如上说。若比丘畏贼故。于车外过二十五肘。藏衣还车上宿。日光未灭至明相出时。尼萨耆。亦如上说。若夜中起大小行。离衣二十五肘内。与衣合无罪。若车营内以长绳横断为系牛故。比丘于绳一边住。置衣绳一边。日光未灭至明相出时。尼萨耆。亦如上说。是名两道界。井界者。比丘与估客共行。于井边宿。井栏外二十五肘内。名为井界。衣着井栏上。比丘去井过二十五肘。日光未灭去至明相出时。尼萨耆。亦如上说。若畏贼故藏衣井外。过二十五肘来井边宿。日光未灭去。至明相出时还尼萨耆。若藏衣井半龛中。于井上宿。日光未灭去至明相出时。尼萨耆。若绳连衣着身宿者不犯。置衣井底。于井上宿。置衣井上。井底宿。亦复如是。若夜暂垂手脚井中。与衣合者无罪。是名井界。树界者。于树一切枝叶外。二十五肘为树界。若比丘置衣树下。过二十五肘外。日光未灭去至明相出。应如上说。若比丘树下畏贼。藏衣树外。过二十五肘。日光未灭去至明相出时还。尼萨耆。日光未灭去至明相未出还不犯。日光灭去至明相出还不犯。若夜中暂到衣所。与衣合不犯。若置衣树上。树下宿若置衣树下。树上宿。日光未灭去。至明相出时。尼萨耆。若绳连着身者无罪。是名树界。园界亦如是。连蔓界者。若蒲萄蔓架。不破蔓架。不楼藤蔓架。瓠蔓架。解脱花蔓架。如是一切蔓架外。各二十五肘。名为速蔓界。比丘与估客共道行。至此蔓下宿。比丘求静处置衣蔓架底。出二十五肘外。日光未灭去明相出时还。尼萨耆。日光灭去。明相出还无罪。日光未灭去至明相未出还无罪。若畏贼故藏衣二十五肘外。于蔓架底宿。日光未灭去至明相出时。如上说。若夜中大小行暂到衣所。与衣合无罪。若着衣蔓架上。在下宿。着衣蔓下。在上宿。亦复如是。若绳连身者无罪。是名连蔓界。暂宿界者。客舍中种种杂人。比丘于中止宿。客舍主言。此中畏贼。各自警备。比丘问客舍主言。长寿何处牢固客舍主答言。阁上牢固。或言。阁下牢固比丘藏衣阁下。于阁上宿。或置衣阁上于阁下宿。日光未灭去至明相出时还。皆尼萨耆。如上说。若是中梯蹬道通者不犯。若比丘道行至天祠中宿。天祠主言。此中畏贼盗各自守备。比丘问。天祠主。何处牢固。天祠主言。若舍里牢固。若舍外牢固。比丘便置衣舍内。自于舍外头首向户而卧。日光未灭去至明相出时。尼萨耆。如上说。若户钩在比丘边者不犯。比丘道行于空聚落中宿。置衣第一房。自于第三房宿者。日光未灭去至明相出。如上说。若一切房尽有比丘者不犯。若羯磨作界。若篱墙沟渠围绕。若水围绕者不犯。是名暂宿界。船界者。若比丘载船上水下水。船上有众多住处。若比丘住处。若外道住处。比丘住处不牢密故。持衣寄外道住处。日光未灭去至明相出时还。尼萨耆。亦如上说。若外道听自在置衣物者不犯。若船着岸者。比丘置衣船上。离船过二十五肘外。日光未灭至明相出时。如上说。若船上畏贼持衣上岸。二十五肘外藏。还船上宿。日光未灭至明相出时。尼萨耆。夜中大小行暂诣衣所者。与衣合不犯。若比丘浣衣于船上。晒风鼓衣尽外向。经宿者尼萨耆。若夜中风吹衣暂入船内者不犯。若晒衣时半在船内半在船外者。尼萨耆。不可截故尽舍。是名船界。家内界者。若兄弟二人共一家住。于家中别作分齐。若兄不听弟入。弟不听兄入。若比丘在兄分齐内。衣在弟分齐内。日光未没至明相出者。如上说。若兄弟语比丘言。俗人自违于法不碍任意住止者。尔时随意置衣无罪。若比丘至白衣家宿。畏贼故。问白衣何处牢固。答言。舍内牢固。比丘置衣舍内。于舍外宿。日光未灭至明相出时。如上说。若夜于孔中暂内一手屋内者不犯。是名家内界。并界者。若四聚落界相接。比丘衣枕头卧。比丘头在一界。两手各在一界。脚在一界。衣在头底。衣离头者尼萨耆。若夜中手脚暂到衣所者不犯。若车于此四界上住车轭在一界。车后在一界。左轮在一界。右轮在一界。若置衣车前车后宿。置衣车后车前宿。置衣车左车右宿。置衣车右车左宿。日光未灭去至明相出时。尼萨耆。日光灭已去至明相出时还不犯日光未灭去至明相未出还不犯。是名并界。聚落界者。若比丘着上下衣入聚落。有主人语比丘言。我今夜欲供养形像作福德。比丘当助。我料理之。是比丘即助庄严形像。悬缯花盖敷置床座。至日没时比丘报主人言。日暮还精舍。是主人殷勤留比丘宿。若彼住处诸比丘有长衣者。应暂借受持。若无者随近有诸比丘住处者。应从彼借。若无比丘。有比丘尼住处者。亦从彼借。若无者是处俗人。若有衣被者应从借作净安施纽。然后受持。若无是事后夜分城门开者。当疾还寺。莫踰城出到精舍门。犹未开者当索开门。若不得开者。应住门屋底。若无门屋者。应内手着孔中。孔有二种。若门孔若水渎孔。若门无孔者。于水渎孔中。若内手若内脚。莫先内手脚。脱有蛇蝮应先以杖惊之。然后内手与衣合。若无水渎者。应踰垣墙入。应作相令内人识。莫令内人疑是贼相惊动也。若不得入者。当疾舍衣。宁无衣犯越比尼罪。以轻易重故。若比丘于精舍内浣衣。悬当垣墙上晒。若夜风吹出垂着垣墙外者。犯尼萨耆。在内者不犯。以不可截故尽应舍。若比丘于精舍外脱衣。热作忘衣在外。夜忆即出求之不见。晨朝出看见衣去。夜行迹二十五肘内者不犯。二十五肘外者。尼萨耆。是名聚落界。七庵婆罗树界者。佛在舍卫城。时有一婆罗门。能种庵婆罗树。是婆罗门闻沙门瞿昙在舍卫城。具足一切知见。有所问者皆能记说。作是思惟。我今当往问种庵婆罗树法。云何种庵婆罗树。能使根茎坚固枝叶茂盛。花果成就扶疏生长。不相妨碍。作是念已。诣世尊所。共相问讯已。于一面坐。白世尊言。沙门瞿昙。云何方便种庵婆罗树。能使根茎坚固枝叶茂盛。花果成就扶疏生长。不相妨碍。时世尊告婆罗门言。以五肘弓量七弓种一树。如是种者。能令彼树根茎坚固枝叶茂盛。花果成就扶疏生长。各各不相妨碍。时婆罗门欢喜。便作是言。善哉。沙门瞿昙。知种殖法。真一切智。从坐起而去。婆罗门去不久佛告诸比丘。是婆罗门今大有所失。应问者不问。不应问者问。若彼问苦习义者。可得道迹。虽然彼婆罗门今于我所发欢喜心。亦为大有所得。尔时优波离知时而白佛言。世尊。已闻庵婆罗树分齐。今复请问。若有处所城邑聚落界分。不可知者。若欲羯磨应齐几许。名为善作羯磨。使令异众僧各各相见而得成就羯磨。不犯别众耶。佛告优波离。五肘弓量七弓种一庵婆罗树。齐七庵婆罗树。相去尔所作羯磨者。名善作羯磨。虽异众相见而无别众之罪。是名为七庵婆罗树界。若比丘离衣宿已。应白持律能羯磨者。言长老我与是衣别宿。应舍长老为我作羯磨。羯磨法如上。过十日衣中说。是故说。若比丘衣已竟。迦絺那衣已舍若三衣中若离一一衣。余处宿。除僧羯磨。尼萨耆波夜提

佛住舍卫城。广说如上。尔时尊者阿那律于阿耆罗河边住。得一小段衣。与众多比丘俱。诣阿耆罗河边水洒引令长广。尔时世尊于自住处没。当阿耆罗河边现。知而故问阿那律。汝作何等。答言。世尊。得一小段衣。尺量不足。欲引令长广。佛语阿那律。汝颇有更得衣望处不。答言有。世尊问何时可得。答言。一月佛言从今日听不足衣有衣望处者。停至一月为满足故。佛告诸比丘。依止舍卫城比丘尽集。乃至已闻者当重闻。若比丘衣已竟。迦絺那衣已舍。若得非时衣。比丘须衣应取。疾作衣受。若不足者有望处为满故。听一月畜。若过畜者。足不足尼萨耆波夜提。衣竟者。三衣已成。亦名衣竟。不受迦絺那衣。亦名衣竟。已舍迦絺那衣。亦名衣竟。浣染竟亦名衣竟。已舍迦絺那衣者。有十事舍如上说。得者。若男若女在家出家人边得衣也。非时者。若受迦絺那衣。有七月名非时。若不受迦絺那衣者。有十一月是名非时于此非时中得衣。是名非时衣。衣者。如上说。须者。是比丘实须衣也。即取疾成受持作而少不足者。停至一月一月者三十日。齐是应畜。为求满足故。有望者是比丘实闻有得衣处。待令满足。得至一月畜。过是一月畜者。尼萨耆波夜提。尼萨耆波夜提者。是衣应僧中舍。波夜提忏悔不舍而悔。犯越比尼罪。波夜提者。如上说。若比丘前十日得有望衣无望。衣微小望。衣无力望。羸望。因生望。断望。更起余望。此皆无事停。若得此衣满足已半作净。半不作净。是中作净者。名善作净。不作净者。过十日尼萨耆。若比丘于前十日中。若得居士衣。若粪扫衣。不自作不教作。不受持不作净。彼衣若作。若不作。衣及衣余前十日过。尼萨耆。若比丘前十日中得衣。若故衣若纳衣。是比丘得已。不自作不教作。乃至过前十日者。尼萨耆。若比丘中十日中得衣。若以染净。若未净。是比丘得是衣。不自作不教作。不受持不作净。彼若作衣。若不作衣及衣。余中十日过。尼萨耆。若比丘中十日得衣。若得应法衣。不应法衣。取已不自作不教作。乃至过中十日。尼萨耆。若比丘后十日中得衣。应作一衣而欲作二衣。余比丘语是比丘言。长老是先欲作一衣。今何故作二衣。今应如先作一衣。是比丘得衣已。不自作不教作。乃至过后十日。尼萨耆。若比丘后十日中得衣。欲作小割截衣。而作大割截衣。余比丘语是比丘言。长老。本欲作小割截衣。今何以作大割截衣。应如本作。是比丘得衣。不自作不教作。不受持不作净若作若不作。衣及衣余过后十日。尼萨耆。若比丘前十日得衣。应即前十日作中十日得衣。应即中十日作。后十日得衣。应即后十日作。若比丘前十日。五日已过得望衣。前十日中后五日中十日前五日。此十日应作衣。若比丘中十日前五日已过得望衣。应中十日。后五日后十日前五日。此十日应作衣。若比丘后十日前五日。已过得望衣。即应此五日中应作衣。若比丘后十日中。六日已过得望衣。应四日中作。七日已过得衣。三日应作。八日已过得衣。二日应作。九日已过得衣。一日应作。十日得衣即日应作。作衣时应余人相助。浣染牵截絣篸却刺。刺横刺长。刺缘施纽煮染。染衣作净已受持。若一日恐不竟者。粗行隐令竟受持后更细刺。是故世尊说。若比丘衣已竟。迦絺那衣已舍。乃至足不足。尼萨耆波夜提

佛住舍卫城。广说如上。优钵罗比丘尼因缘应广说。时优钵罗比丘尼。以僧祇支与尊者。阿难陀。是衣垢腻不净。阿难陀持是衣。泥涂日中晒。佛知而故问。阿难陀。汝作何等。答言。世尊。是优钵罗比丘尼与我此僧祇支垢腻不净。涂泥而晒佛问阿难陀。汝与直贸易不。答言。不与世尊。佛告阿难陀。应当与贸易。母人少利。阿难陀不欲与。佛语阿难陀。何以不与。阿难陀白佛。与何物。佛语阿难陀。王波斯匿所施劫贝。长十六肘广八肘者与之。阿难陀犹故不与。如劫贝契经广说

复次佛住舍卫城。广说如上。时善生比丘尼将徒众皆着弊坏衣。礼世尊足。佛知而故问。诸比丘。此何等比丘尼。着弊坏衣而来诣我。诸比丘白佛言。世尊。此是善生比丘尼。佛问诸比丘。是善生比丘尼为得衣故不着。为无衣耶。诸比丘言。但得已持与优陀夷

复次佛住舍卫城。广说如上。时偷兰难陀比丘尼将徒众。皆着弊坏衣来诣世尊。头面礼足。佛知而故问诸比丘。此何等比丘尼。着弊坏衣而来诣我。诸比丘白佛言。世尊。此是偷兰难陀比丘尼。佛问诸比丘。是偷兰难陀比丘尼。为得衣故不着。为不得衣故不着。诸比丘言。但得已持施阿难陀

复次佛住舍卫城。广说如上。时苏毗提比丘尼将徒众。皆着弊坏衣来诣世尊头面礼足。佛知而故问诸比丘。此何等比丘尼着弊坏衣而来诣我。诸比丘白佛言。世尊。此是苏毗提比丘尼。佛问诸比丘。是苏毗提比丘尼为得衣不着。为不得衣耶。诸比丘言。但得已持施善解比丘

复次佛住舍卫城。广说如上。有失利摩比丘尼将徒众。皆着弊坏衣来诣世尊。头面礼足。佛知而故问诸比丘。此何等比丘尼。着弊坏衣来诣我所。诸比丘白佛言。世尊。此是失利摩比丘尼。佛问诸比丘。是失利摩比丘尼为得衣不着。为不得衣耶。诸比丘言。但得已持施僧。佛问诸比丘。若亲里比丘尼着如是弊坏衣者。是亲里比丘应取彼衣不。答言。不取。世尊复问。若亲里比丘尼自衣弊坏。持衣物与亲里比丘不。答言。不也世尊。佛言。是故比丘不应从非亲里比丘尼边取衣。除贸易。佛告诸比丘。依止舍卫城比丘。皆悉令集。以十利故。为诸比丘制戒。乃至已闻者当重闻。若比丘从非亲里比丘尼取衣。除贸易。尼萨耆波夜提。比丘者如上说。非亲里比丘尼者。非父亲相续。非母亲相续。是名非亲里比丘尼。一亲里多非亲里多。亲里一非亲里。沙弥尼亲里。比丘尼非亲里。沙弥尼非亲里。比丘尼亲里。是中得衣犯。离此二众无罪。衣者。钦婆罗衣。劫贝衣。憍舍耶衣。刍摩衣。舍那衣。麻衣。躯物提衣。取者。受彼施也。除贸易者。佛说若贸易无罪。尼萨耆波夜提者。是衣应僧中舍。波夜提忏悔。不舍衣而悔者。得越比尼罪。波夜提者如上说。非亲里比丘尼。自与使受。使与自受。自与自受。使与使受。自与使受者。比丘尼自手与衣比丘。遣使受使与自受者。比丘尼遣使持衣与比丘。比丘自受自与。自受者。比丘尼自与衣。比丘自受。使与使受者。比丘尼遣使持衣与比丘。比丘遣使受。若比丘从非亲里比丘尼取衣。许贸易不与。不教与。不自语不教人语。还本衣截本衣。减与与异物离见闻处离界。是比丘得波夜提罪。不与者。自不与。不教与者。不教他人与。不自语者。不自语比丘尼言。后尔许时当与汝衣。不教语者。不使他人语。比丘尼言。后尔许时当与汝衣。还本衣者。还比丘尼先衣。是不应与。应与余衣。截者。截本衣还彼。是不名贸。减与者。得彼全衣已。与减小衣。是不名与。应与全足衣。与异物者。取彼衣已与钵。若小钵若键镃。若以饮食及余物与。是不名贸。应与衣也。离见闻处者。若比丘取非亲里比丘尼衣已不与直。不教与。不自语不教语。舍去离见闻处。波夜提罪。离界者。若比丘取非亲里比丘尼衣已不与直。不自与不教与。不自语不教语。舍去出界二十五肘。波夜提。若比丘取非亲里比丘尼衣已不与直。不自与不教与。不自语不教语。若坐若卧。若入定。皆得波夜提罪。若非亲里比丘尼。与知识沙弥衣。作是言。沙弥。我与汝是衣。汝持是衣。与某甲比丘。可得福德。比丘取者。无罪。如是沙弥尼式叉摩尼优婆塞。乃至诸优婆夷言。我与汝此衣。汝持此衣施与尊者某甲比丘。可得功德。比丘取者无罪。若比丘尼语比丘言。借尊者此衣。随意着。比丘得着。乃至破还无罪。若众多比丘尼与一比丘衣。是一比丘应各各与众多比丘尼贸衣亦得以一衣与众多比丘尼。语言。姊妹。通贸衣。一比丘尼若别与众多比丘衣。众多比丘应各各别与一比丘尼贸易衣。亦得共与一衣语言。姊妹。此衣通贸衣。若众多比丘尼。与众多比丘衣。众多比丘应还与众多比丘尼贸衣。若一比丘尼与一比丘衣。一比丘应还与一比丘尼贸衣。若比丘尼与比丘。若钵若小钵。若键镃若饮食。及余小小物尽得取无罪。是故说。若比丘从非亲里比丘尼取衣。除贸易。尼萨耆波夜提

摩诃僧祇律卷第八摩诃僧祇律卷第九

        东晋天竺三藏佛陀跋陀罗共法显译

    明三十尼萨耆波夜提法之二

佛住舍卫城。尔时尊者优陀夷。持衣与大爱道比丘尼作是言。善哉瞿昙弥。此衣为我浣染打。时大爱道即为浣染打已。送还语优陀夷言。此衣已浣染打讫。今故送还。优陀夷即咒愿。得乐无病。送置房里。时大爱道持衣与优陀夷已。往诣佛所头面礼足却住一面。佛知而故问。瞿昙弥汝手上何以有染色。答言。世尊。我为优陀夷浣染衣。故手有染色。瞿昙弥去不久。佛告诸比丘。云何优陀夷乃使行道比丘尼浣染衣妨废比丘尼业。复次佛住舍卫城。尔时长老阿难陀。是偷兰难陀比丘尼。本二不善观察。与不净衣浣。作是言。姊为我浣染打此衣。时偷兰难陀。即持此衣到精舍。舒看见不净着衣。即以此衣示诸比丘尼作是言。汝等看此衣上。是丈夫丈夫相。时诸比丘尼语偷兰难陀言。如是应覆藏之物云何示人。若欲浣者应浣。若不浣者应举。时偷兰难陀比丘尼。语诸比丘尼言。此有何可耻使我藏之。此是丈夫丈夫之相。更复举示诸比丘尼。时六群比丘。去比丘尼不远闻是语已拍手大笑。奇事奇事。时诸比丘闻是语已。即以是事往白世尊。佛言呼阿难陀来。即呼来已。佛问阿难陀。汝实尔不。答言实尔。不善看故与。佛告诸比丘。设使亲里比丘有此不净衣。当与亲里比丘尼浣不。答言。不与世尊。佛言。设使亲里比丘尼。见亲里比丘有此可覆藏之事。当出示人不。答言。不示世尊。佛告诸比丘。亲里比丘尼。尚不应使浣不净衣。云何使非亲里比丘尼浣故衣。从今已后不听。佛告诸比丘。依止舍卫城比丘皆悉令集。以十利故为诸比丘制戒。乃至已闻者当重闻。若比丘使非亲里比丘尼浣故衣。若染若打。尼萨耆波夜提。比丘者如上说。非亲里者。非父亲相续。非母亲相续故衣者乃至经一枕头。名为故。衣者如上说。浣者除垢腻。染者根染皮染叶染花染果染。如是等种种染。打者乃至手打一下。尼萨耆者。是衣应僧中舍。波夜提。罪应悔过。不舍而悔。越比尼罪。波夜提者如上说。自与使受。使与自受。自与自受。使与使受自。与使受者。比丘自与。比丘尼遣使受。比丘尼自浣。使与自受者。比丘遣使持衣与。比丘尼自受浣。自与自受者。比丘手自与。比丘尼自受浣。使与使受者。比丘遣使与。比丘尼遣使受自浣染打。尼萨耆波夜提。若比丘语浣即浣语染便染。语打即打。尼萨耆。若比丘使非亲里比丘尼浣衣便染。教染便打教打便浣。教作而不作。不教作便作。越比尼罪。若比丘语非亲里比丘尼。浣衣便染打。教染便浣打。教打便浣染。教作而不作。不教作便作。越比尼罪。若比丘与亲里衣非亲里浣。若与非亲里亲里浣。若与亲里亲里浣。若与非亲里非亲里浣。与亲里非亲里浣者。若比丘母姊妹出家。比丘持衣与令浣。彼比丘尼。持衣还精舍。是尼有弟子尼语言。阿阇梨有作事我当作。便取衣浣染打。是比丘无罪。是名与亲里非亲里浣。与非亲里亲里浣者。若比丘与非亲里比丘尼衣令浣染打。是比丘尼持衣还精舍。是比丘有母姊妹出家。识是衣便问。是比丘尼言。彼是谁衣。答言。某比丘衣。是亲里尼便作是念。某甲不知比尼。无令此比丘得尼萨耆罪。即取衣浣。是比丘犯越比尼罪。是名与非亲里亲里浣。与亲里亲里浣者。若比丘母姊妹出家。是比丘持衣与浣。彼比丘尼言我羸病。比丘言。汝有弟子强健者。应使浣便教浣。教浣已自持来。是比丘得尼萨耆罪。若不教而自使浣者无罪。是名与亲里亲里浣。若比丘与非亲里比丘尼衣。非亲里比丘尼浣染打者。尼萨耆波夜提是名与非亲里非亲里浣。若比丘持衣及染。具寄比丘尼精。舍去余闲靖处安居。是比丘尼夏后因自浣染衣过。为比丘浣染衣比丘安居竟。还索衣欲浣染。比丘尼言我已浣染竟。是比丘不犯。若比丘寄衣时作是念。彼当为我浣染打。后浣染打者。尼萨耆波夜提。若比丘着垢腻衣。诣比丘尼精舍非亲里比丘尼礼比丘足问言。衣被何以垢腻无人浣染耶。答言无人浣。是比丘尼信心。即便入房取衣与比丘着。留此衣与浣染打无罪。是比丘于余时作意。故着垢腻衣去作是念。比丘尼见已自当为我浣。作是意浣者。尼萨耆波夜提。若比丘入聚落中。若值狂象车马灒泥。污比丘衣。即往到比丘尼精舍。令比丘尼湔者。尼萨耆波夜提。以不可截故都舍。若比丘尼灌水。比丘自浣者无罪。若比丘于一处浣染衣时。斋日比丘尼游行。礼诸精舍过。礼诸比丘足。见比丘浣衣。诸比丘尼言。阿阇梨无人浣衣耶。答言无人。是比丘尼信心故语比丘言止。我当为浣。比丘听随意浣者无罪。若是比丘于斋日故浣衣。作是念言。比丘尼必来当为我浣。若与浣者。尼萨耆波夜提。若比丘有多尼弟子。虽不得令浣染打得令拾薪取水煮染取食行水。持扇扇食竟收钵。一切事得作。若教令浣染打者。尼萨耆波夜提。若为和尚阿阇梨持衣使比丘尼浣。越比尼罪。为塔僧使比丘尼浣染打无罪。是故说若比丘使非亲里比丘尼。浣故衣若染若打。尼萨耆波夜提

佛住舍卫城。广说如上。月八日十四日十五日。城中众人皆出礼世尊足。时有一人名阿跋吒。着两张白[疊*毛]。来入只桓精舍礼世尊足已。次到长老优波难陀住处言。和南阿阇梨。答言。无病长寿。阿跋吒言。我欲看诸房舍。时优波难陀答言。可尔汝等不欲看尚当示汝。况复欲见。即将至两重阁上语言。看是长老雕文刻镂五种彩画绀琉璃地。床褥卧具看已答言。实好阿阇梨优波难陀言。长寿汝是[疊*毛]衣亦好长广细致。时阿跋吒白言。我欲更看余房舍。时优波难陀。将至第三重阁上看。广说如上。乃至汝衣亦好长广细致。时彼作是念。是沙门赞叹我衣必当欲得。是比丘是王及诸大臣所识有大力势。若不与者或嫌恨我。阿跋吒言。阿阇梨欲得此衣耶。答言欲得。阿跋吒言。阿阇梨随我归去。当更与余衣。优波难陀言。呜呼长寿汝何以言更与我余衣。我亦更有种种好[疊*毛]。但不相似所以欲得汝此[疊*毛]者。欲令相似作一种衣耳。复言汝意欲施者正以此衣与我。其余好者非我所须。阿跋吒言。我着此衣诣国王长者。礼觐世尊事不可废。优波难陀复言。汝何以言更与我余衣。汝实。谓我更无好[疊*毛]。汝欲施者正以此衣与我。其余好者非本所须。阿跋吒言。必须此衣者随我归去到舍当与。优波难陀言。汝不晓方便不知家中诸难。若父母兄弟姊妹。或当悭惜不听。汝施者我不得此衣。汝不成施福二俱失利以此难故正应此间施我。时阿跋吒苦辞不免。即脱上衣与已便去。着下衣向舍卫城。时城中人多出礼觐世尊。时阿跋吒问众人言。汝等今欲那去。答言。欲诣只桓。语言莫去。问言何故。答言。沙门劫人。复问强夺人物耶。答言。何所复问。汝但看我着两张[疊*毛]去今正有一张在其中。不信佛者即还入城中。闻者生疑为尔不尔。沉吟而住。信佛法者即作是念。终无是事沙门释子不与不取何有劫人。或能方便说法取耳。以是故少人诣只桓礼觐世尊。世尊知而故问阿难。今日何故少人来入只桓。时尊者。阿难即以上事具白世尊。佛言。呼优波难陀来。即便呼来已。佛问优波难陀汝实尔不。答言。实尔世尊。佛言。比丘此是恶事。云何比丘强乞人衣。汝常不闻世尊赞叹少欲呵责多欲无厌耶。从今日后不听从非亲里居士居士妇乞衣

复次佛住舍卫城。广说如上。尔时北方有六十比丘。来诣舍卫城礼觐世尊。中道被贼失衣。裸形入只桓精舍。礼诸比丘。诸比丘问言。汝是何人。答言。出家人。又问。何道出家。答言。释种出家。又问。汝衣何在而裸形耶。答言。我道中遇贼失衣。尔时诸比丘各各与衣。有与僧伽梨者。郁多罗僧者。安陀会者。尼师檀者。是比丘着衣已。往到佛所头面礼足却住一面。佛知而故问诸比丘。汝等何处来。答言。世尊我等从北方来。佛问诸比丘。汝忍苦乞食不难道路不疲极耶。答言。世尊我等忍苦乞食不难道路不疲。但道中遇贼失衣裸形入只桓。佛问比丘汝等道中。为无聚落城邑耶。答言有。佛言何以不乞。诸比丘白佛言。我闻世尊制戒。不得从非亲里乞衣。复无亲里。亦无檀越施者。以是故我等不敢乞衣裸形而来。佛赞持戒言。善哉善哉诸比丘汝等正随顺直信出家。乃至失命因缘不应故犯戒。从今日后听失衣时得乞。佛告诸比丘。依止舍卫城比丘。皆悉令集。以十利故与诸比丘制戒。乃至已闻者当重闻。若比丘从非亲里居士居士妇乞衣。尼萨耆波夜提除余时。余时者失衣时是名余时。比丘者如上说。非亲里者。非父亲相续。非母亲相续。无亲因缘。一亲里多非亲里。多亲里一非亲里。离此二众得罪。居士者家主也。衣者钦婆罗衣劫贝衣。刍摩衣憍舍耶衣。舍那衣麻衣躯牟提衣。乞者若自乞。若使人乞。除余时乞衣无罪。余时者失衣时。失衣有十因缘若王夺若贼夺。若火烧若风飘若水漂若女人起欲心夺。若父母亲里欲令罢道故夺。若自藏后忘不知处。若藏衣腐烂若岁久朽坏不可承案。是名十除余时。世尊说无罪。尼萨耆波夜提者。是衣应僧中舍。波夜提。罪应忏悔。不舍而悔。越比尼罪。波夜提者如上说。若比丘三由旬内有衣者。若失僧伽梨。郁多罗僧。在不应乞。若失僧伽梨。郁多罗僧。安陀会。在不应乞。若失三衣。若覆疮衣在不应乞。若失三衣覆疮衣。若雨浴衣在不应乞。若比丘失三衣覆疮衣雨浴衣。若覆卧褥具在不应乞。若比丘失三衣覆疮衣雨浴衣覆卧褥具。若任衣在长两肘广一肘不应乞。何以故是比丘。应着是下衣往三由延受先衣。若是道中有诸难事。不得往趣衣者得乞雨衣无罪。若比丘从非亲里乞衣。若自乞。若使人乞。若作相乞。若说法乞。自乞者自身往乞。使乞者遣人往乞。作相乞者作寒相热相。云何寒相。若比丘冬中八夜雨雪时。着弊故衣诣檀越家现冻战相。尔时檀越礼比丘足问言。阿阇梨无有时衣耶。何以寒冻乃尔。答言无有。汝父母在时恒为我作时衣。今汝父母去世。谁当为我作者。非但汝父母死。亦是我父母无常。檀越即言阿阇梨莫怨恨我当为作时衣。是名寒相乞。若得衣者尼萨耆波夜提。云何热相。若比丘五六月大热时。着厚纳衣流汗诣檀越家现热相。尔时檀越礼比丘足问言。阿阇梨无时衣耶何以热之流汗乃尔。答言无有。汝父母在时恒为我作时衣。今汝父母去世。谁当为我作者。非但汝父母死。亦是我父母无常。檀越即言。阿阇梨莫怨恨。我当为作时衣。是名热相乞。若得衣者。尼萨耆波夜提。云何说法乞。是比丘为衣故。与檀越。说偈言

  若人以衣施　　得生最胜处
  以乐布施者　　人天受福报
  生天得妙色　　天宝冠庄严
  衣施比丘故　　生生自然衣

是名说法乞若得衣者尼萨耆波夜提。若乞漉水囊。若乞小补衣物。若系头物。若裹疮物。若衣缘。若乞衣中一条。如是等物不犯若乞是物。时檀越施全物及衣裁。取者不犯。若比丘作是念。我但索小小物檀越自当与我。全衣得者。尼萨耆波夜提。若为和尚阿阇梨乞。越比尼罪。若为塔僧乞不犯。是故说。若比丘从非亲里居士居士妇乞衣。尼萨耆波夜提。除余时余时者失衣时。佛住舍卫城。六十比丘从北方来向舍卫城。路中被贼失衣。入只桓精舍。时优波难陀。见已语是失衣比丘言。诸长老世尊听比丘失衣时。得从非亲里乞。何以不乞。答言诸梵行人。已与我衣足是故不乞。时优波难陀言。若今不乞者徒失此利。答言我已得衣失利不失利。复何在耶。优波难陀语失衣比丘言。汝若不能乞者。我当为汝乞。彼言。汝自知时优波难陀。晨朝着入聚落衣。持纸笔入舍卫城。语诸优婆塞言。汝等助我乞衣。优婆塞问言。何以故乞答言有比丘从北方来道中遇贼都失衣物。为彼故乞衣。优婆塞言可尔。即将至市种种店肆上。为劝化。时人多有信敬者。或得一张。或得两张。如是渐渐多得衣物。重担而行于诸信心家四分。始从一分家乞。方欲更乞。优婆塞言。阿阇梨可足还去。优波难陀言。呜呼长寿何乃浅促。我乞始有次第。不应还去。何以故多人布施多人得福。我等出家人食有时限。犹未欲去。汝等在家人。遇食便食不畏失时。有何急事匆匆欲去。如是复更行乞。优婆塞复言可足阿阇梨。优波难陀复言犹故未足。优婆塞言有几人耶。答言多人。复问为有几人。长引声言乃有六十比丘。优婆塞言。阿阇梨此诸衣可供五百比丘。何况六十。何以为乞欲坐[疊*毛]肆耶。即掷纸笔放地。而嗔恚言。何处生是多求无厌不知止足人。是中有少欲知足比丘。闻是语已。往白世尊。佛言呼优波难陀来。即便呼来佛广问上事。汝实尔不。答言实尔世尊。佛问优波难陀。何以故乞。答言我为失衣比丘故乞。佛即呼失衣比丘来来已。佛语汝等比丘。实使优波难陀乞衣耶。答言不也世尊。佛复问失衣比丘。优波难陀。何因缘故作如是言。失衣比丘。即以上事具白世尊。佛告优波难陀。此是恶事痴人。不应乞者便乞。应乞者不乞。佛语优波难陀。汝常不闻我无数方便赞叹少欲毁呰多欲。此非法非律非如佛教。不可以是长养善法。佛种种呵已告诸比丘。依止舍卫城比丘。皆悉令集。以十利故。为诸比丘制戒。乃至已闻者当重闻。若比丘失衣时。得从非亲里居士居士妇乞衣。若非亲里居士居士妇。自恣多与衣。是比丘得受上下衣。过是受者。尼萨耆波夜提。比丘者如上说。失衣有十事如上说。衣者钦婆罗衣[疊*毛]衣刍摩衣憍舍耶衣舍那衣麻衣躯牟提衣。非亲里者。非父母亲相续。是名非亲里。居士者家主也。乞者若自乞若使人乞若劝化。檀越欲自恣施得。取上下衣。自恣者随意与。上下衣者。广三肘长五肘。得取二衣。若过是取者。尼萨耆波夜提。尼萨耆者。是衣应僧中舍。波夜提罪应悔过。若不舍而悔越比尼罪。波夜提者。如上说。若比丘三由延内有衣者。若失僧伽梨。郁多罗僧在不应乞。乃至任衣在不应乞。何以故是比丘应着是下衣。往三由延。受先衣若道中有诸难事。不得往。取衣者得乞雨衣无罪。寒相热相说法相如上说。若比丘共估客着道行。若贼从一方二方三方来随便远贼走。若四方俱来不应走。当正身住不得格贼。若贼言取僧伽梨来。答言与长寿。如是一一衣物随索多少与之。不得高声大唤嗔骂贼。与物已当徐徐去入林草中藏。遥望看。若贼去后余有不。受持衣在者应受持。若无余衣者。是中有比丘。若外道出家。为贼所杀者。应取是衣受持。若无出家人死。有俗人死者。应取俗人衣截缕作净然后受持。若无死人衣。估客有遗弃好衣物者。不应取若弃弊衣物者应取受持。若估客还来唤比丘。与是好衣者应取。取已截缕牛屎染作净受持。若是估客语比丘言。我借汝此衣。着到前住处。还我莫令损减。是比丘应取是衣。摄缕在内篸缝令缕。不现作净。受持到住处应还。若无是事应篸树叶遮前后而去。若无是事。不得如尼揵子掉臂当道行。当以手遮前。障形体在道侧行。莫入深榛中行。令贼谓是伺捕者。应在道边浅草中行。行时若逢人来。当即于浅草中。小现处坐。令行人见之。若人问言汝是何人。答言出家人何道出家。答言释种出家。何以裸形。答言被贼。若不乞而自多与衣者取无罪。若不自与者应从乞。乞时多与衣者。应取二领。广三肘长五肘衣。若无是事。当诣阿练若住处。彼知识边得衣者应受。若无阿练若住处。应至冢间。若有守墓人应语言。我欲拾弊衣。若守墓人教取。取已示我当取示之。若取死女人衣时。女身未坏者。应往头边而取。若身已坏得随意取。若死男子衣亦随意取。若死人衣有宝者。应足蹑却宝持衣而去。若不觉有宝持衣还。乃知有宝者。应付净人持作汤药。若守墓者。语比丘言。听汝取不好衣。好者勿取。是比丘到冢间。不见弊者多有好衣。即持还语守墓人言。正有是好衣耳。守墓人听取便取。若言是好不听汝取。比丘应还更求余者。若彼语比丘。取在地者。即取在地者。若言取空中者。即取空中者。若是好衣半在地。半在空中。应截半取。若无是事者。当到聚落中。问比丘住处。不应昼日入聚落。应待闇放牧人还时俱入聚落。不应依牸牛边。当在羸小牛中行。若见人时加趺而坐。若人问言汝是何人。答言出家人。何道出家。释种出家。汝衣何处。答言被贼失尽。若不求自与者。得随意多取。若不与者。应从乞。乞时多与者。应取二领衣广三肘长五肘。若复无是事者。应到精舍中问旧比丘。此中谁是维那谁是知床褥人。答言某甲是。尔时是比丘。应到是知事比丘所问言。尔所岁比丘。应得何等床褥卧具。答言尔所岁比丘。应得如是床褥卧具。是比丘得是褥。取摘开以毛举着一处。取表里作泥洹僧。若得枕亦摘开以毛举着一处取表里。作僧祇枝。得卧具取着已。应礼塔礼上座。问讯下座应语言。我道中被贼失衣。当助我乞衣。若旧比丘言。汝如饿乌脚不能住。谁当助汝。正是沽酒家搏掩家劫汝。或用易食而言披劫索人助乞。若尔应往至优婆塞所言。长寿我道中被贼失衣。汝等当助我乞衣。答言可尔。阿阇梨即时为乞。得多衣者。比丘应取两衣广三肘长五肘。尔时优婆塞。语比丘言。可得方便。为我尽取是衣不。答言汝可转易两张细[疊*毛]者持来。若优婆塞巧作方便。将比丘出界外语言。阿阇梨此衣布施现前僧现前无僧。阿阇梨现前应受。尔时比丘受无罪。若优婆塞与大张[疊*毛]。当裁取两衣段。问言何故。答言世尊制戒。正得取两衣。优婆塞言。阿阇梨但且取染。比丘取染已送还。优婆塞言。未染时是俗人衣。我尚不欲。况今染坏色。是出家人衣。我不复取。比丘尔时得取。作衣随意用。是比丘先所摘褥枕表里。作泥洹僧祇枝者。浣已还复本褥枕卧具付知事人。然后便去。若欲即住此处者。随意更请不得即留。是故说。若比丘失衣时。得从非亲里居士居士妇乞衣。非亲里居士居士妇自恣多与衣。是比丘得取上下衣。过是受者。尼萨耆波夜提。佛住舍卫城。尔时有乞食比丘。时到着入聚落衣持钵入城。次行乞食到一家。其家妇人语比丘言。我某日当饭僧施衣。比丘言善哉姊妹。作三坚法身命财。中间莫有留难。言已便去。比丘乞食还已至温室中。语诸比丘言。我语长老好事。答言有何好事。我闻某甲优婆夷。某日欲请僧食布施衣。时难陀优波难陀闻已即问言。长老其家门巷在何处。姓字何等。问知已明日清旦。着入聚落衣到其家言。无病优婆夷。优婆夷言和南阿阇梨。比丘言。我闻好消息。问言闻何等事。答言闻汝欲请僧设供施衣。答言有是心。但恐中间诸难不成。比丘言汝请僧设供施衣。欲与长老比丘好恶衣。若与粗者。正当与沙弥。园民及着衣架上。若与我好者。我当着入王家贵胜边当礼佛。有人问者。我当语言。某甲信心优婆夷与我。汝可得名称受用功德。答言更无正有是已许僧。若有者亦当别施。比丘言与不与任汝意。言已便去。檀越作是念。若与彼不与僧者僧是良福田。若不与彼与僧者。彼有王力能作不饶益事。畏彼故不与僧。因彼发不喜心故二俱不与。诸比丘问乞食比丘。汝前所闻绝无消息。乞食比丘言。我知定克明日。乞食比丘明旦。着入聚落衣到其家。即问优婆夷言。何故不见供办作诸饭食。答言阿阇梨因难陀优波难陀破我善心。问言何故即具说上事。乞食比丘闻已。语诸比丘。诸比丘以是因缘往白世尊。佛言呼难陀优波难陀来。来已佛问比丘汝实尔不。答言实尔。佛言痴人此是恶事。汝作二不饶益。施者失福。受者失利。佛言汝常不闻我无量方便毁呰多欲赞叹少欲。汝云何先不自恣请而为好故往劝。此非法非律非如佛教。不可以是长养善法。佛告诸比丘。依止舍卫城比丘皆悉令集。以十利故为诸比丘制戒。乃至已闻者当重闻。为比丘故若居士居士妇为办衣价。如是言我办如是如是衣。价买如是如是衣。与某甲比丘。是比丘先不自恣请为好故。便到居士所作如是言。为我作如是衣为好故。若得衣者。尼萨耆波夜提。为比丘者若僧若众多若一人。居士者如上说。衣者钦婆罗衣劫贝衣刍摩衣憍舍耶衣舍那衣麻衣躯牟提衣。衣价者金银宝物等。办者若今日若明日若半月若一月。我办如是如是衣。价买如是如是衣。与某甲比丘是名办。先不自恣请者。先知不自恣请。便谓自恣请。知自恣请。余比丘便谓自恣请。我知自恣请与余物。便谓自恣请与我衣。往者若到居士田上若到家若入屋里。索者我须青若黄若赤若黑若种种茜色等。若长若广若长广。若随所索者与。若更与余者。皆尼萨耆波夜提。为好者。知足好。不知足好。粗足好。云何知足好。若与细衣时便言。我须粗者。是名知足好。得者尼萨耆。不知足好者。若与粗衣时。便作是言。若与我粗衣者。不中触我脚。我是贵人。应与我好衣。是名不知足好。得尼萨耆。粗足好者。若与细衣时便言。我不用是好衣。我是阿练若如鹿在林中。住在空地与我粗者足障寒热风雨。是名粗足好。若得者尼萨耆波夜提。尼萨耆波夜提者。是衣应僧中舍。波夜提罪应悔过。若不舍而悔越比尼罪。波夜提者如上说。是故世尊说为比丘故。若居士居士妇。乃至为好故。若得衣者尼萨耆波夜提。佛住舍卫城。有乞食比丘。时到着入聚落衣持钵入城。次行乞食。有居士妇语比丘言如上。一居士中说。此中但二居士为异耳。乃至已闻者当重闻为比丘故若二居士居士妇。各各办衣价作如是言。我等办如是如是衣。价买如是如是衣。与某甲比丘。是比丘先不自恣请为好衣故。便到居士所言。为我各各办如是如是。衣价共作一衣与我为好故。若得是衣。尼萨耆波夜提。此中如上。一居士中广说。但二居士为异耳。佛住舍卫城。瓶沙王有二大臣。一名尼提。二名婆利沙。秋时人民收获讫运致入城。天时寒雪。时二大臣作是念。我常年年请师。难陀优波难陀。施食并施衣。今日当在何处。有人语言。在舍卫城。尔时大臣遣使。赍书持旧钱八百。饷难陀优波难陀。敕使言。汝当还得报书。使向只桓精舍到已问言。难陀优波难陀房在何处。时诸比丘示言此房是。使即入房中礼已问言。是优波难陀不。答言是。汝何以问。答言。瓶沙王大臣尼提婆利沙。遣我赍书持旧钱八百饷师。并索答书。时有优婆塞名法豫。优波难陀即语优婆塞言。汝知料理数此衣直与书相应不。即料计取与。书相应。即与答书遣使令去。时法豫优婆塞欲去。白言尊者此衣直当置何处。答言当置汝边。即便持去到家已。待一日二日三日不来取。优波难陀多缘多事忘不往取。是优婆塞家中小俭。即便贷用后当还偿。用已即日。难陀语优波难陀往取衣直即往索。优婆塞言。我持来已。停待。尊者一日二日三日不来取我家中小俭。即便贷用须得当还。优波难陀即嗔恚言。汝不可寄付。此是我物云何取辄用。难陀谓优波难陀此物不可直尔索得。即语官人牵挽将去。时众人见已种种呵责沙门。释子自言善好。是其檀越常相供给而能苦困如是。况复余人失沙门法行恶如此何道之有。优波难陀。闻已羞愧即便放去。诸比丘闻已往白世尊。佛言。呼优波难陀来。来已佛问优波难陀汝实尔不。答言。实尔世尊佛语优波难陀此是恶事。汝常不闻我无数方便。呵责多欲赞叹少欲。此非法非律不如佛教。不可以是长养善法。从今已后不听往索

复次佛住舍卫城。法豫优婆塞常僧中次第请比丘食。时次食比丘到其家已。法豫问言。优波难陀何以不来取钱。我未得时乃众人中苦从我索。我今得直而不来取。诸比丘言。佛制戒不得来索。法豫言。若不听索者。何不来此默然。我自知意。是比丘食已还语诸比丘。诸比丘闻已。即以是事往白世尊佛告诸比丘。是法豫优婆塞。聪明黠慧乃有是方便。从今日听诸比丘三反往索六反默然住。佛告诸比丘。依止舍卫城比丘皆悉令集。以十利故与诸比丘制戒。乃至已闻者当重闻。为比丘故若王若大臣。遣使送衣直与比丘使到比丘所白言尊者是衣直。若王若大臣所送尊者受是衣价。是比丘应语使如是言。诸比丘法不应受衣价。我须衣时得清净衣。须者得自手受。作比丘衣畜。使语比丘言。尊者有执事人。常为诸比丘执事不是比丘应示使。执事人若园民若优婆塞。应语使者言。是人等能为诸比丘执事。使到执事人所语言。善哉执事如是如是衣价买如是如是衣。与某甲比丘是比丘须衣时当来取当与衣。是使若自劝喻。若使人劝喻已。还到比丘所白言。尊者所示执事人。我已劝喻作衣竟。尊者须衣时往取。当与尊者衣。须衣比丘应到执事。人所索衣。应作是言。我须衣第二第三亦如是索。若得衣者好若不得。第四第五第六应在执事前默然立。得衣者好若不得。为得衣故过是求。若得是衣尼萨耆波夜提。若不得衣随衣价来处。若自去若遣使往应作是言。汝为某甲比丘送衣价。某甲比丘竟不得。汝自知财莫使失是事法尔。比丘者若僧若众多若一人。王者如盗戒中说。王臣者乃至小吏帅知。任官事者皆名为臣。使者若男若女若大若小。若在家若出家。衣者如上说。衣价者钱金银镴珠琉璃珂贝珊瑚琥珀砗磲马瑙赤宝铜铁白镴铅锡等。是名衣价。园民者供养众僧净人。是名园民。优婆塞者三归一分行少分行多分行满分行随顺行。此法是名优婆塞。三语者非一往反中三语。乃至三往反索是名三语。若四五六反默然者。非一往默然乃至六反往默然。一自往索一遣使默然住。一自往索二遣使默然住。一自往索三遣使默然住。一自往索四遣使默然住。一自往索五遣使默然住。一自往索六遣使默然住。二自往索门。三自往索门亦如是。一遣使索一自往默然住。一遣使索二自往默然住。一遣使索三自往默然住。一遣使索四自往默然住。一遣使往索五自往默然住。一遣使索六自往默然住。二遣使索门三遣使索门亦如是。自往索自往默然住。三门亦如是。遣使索遣使默然住三门亦如是。三反往索六默然住。时或缓期。或急期。云何缓急。若比丘至檀越所索衣时。语言长寿与我衣直。答言。尊者更一月来。比丘满一月往索。若檀越复言。更一月来。比丘满一月复往索。若檀越复言。尊者更一月来。比丘满一月复往索。过三月已不得复索。若言半月来过三。半月不得复索。若言十日。若言五日四日三日二日一日须臾过三。须臾不得复索。是比丘六反往。时檀越言。我知尊者住立意。更一月来。是比丘满一月复往默然住。如是满六月往默然已不得复往。若言半月。若言十日五日四日三日二日一日须臾过六。须臾已不得复往默然住。齐几名默然住。时如人入库取物着髻上顷。又如裹襆物顷即应去。若比丘作方便现行。相持衣钵锡杖水瓶过寄物人前。若彼人问言。尊者欲那去。答言欲去。先送物主边语。令自知此物莫使失。受寄者言久已办物。不须复往。即时与物比丘。取者尼萨耆波夜提。若不作方便道由彼前。若彼人问尊者那去。答言。欲至先送物主边。语令自知此物莫使失。受寄者言。久已办物不须复往。即时与物取者无罪。受寄者若言任意去。设能破我如破多罗树。亦不与汝一钱。比丘尔时应到物主边。语令自知此物莫使失。若是物主言。我先施比丘随方便更索。比丘尔时得如前三反语索六反默然住。是故世尊说。若王若大臣。送衣直乃至莫使失。是事应当尔。是初跋渠竟

佛住毗舍离大林重阁精舍。广说如上。尔时诸比丘一切作毡衣僧伽梨。郁多罗僧。安陀会。尼师檀。唯除漉水囊及络囊。一切毡作。诸比丘处处乞羊毛作毡衣。如是众多为世人所厌。时有一比丘。晨起着入聚落衣入毗舍离。为乞毛故。有一估客。手执户钩来向市肆开自店舍。遥见比丘疾行而来。沽客念言。是比丘来必为乞毛故。晨朝至此。市卖未售谁能先乞是毛。便闭肆户还自家去。比丘念言。是估客见我便闭肆户还去。不欲乞我毛故。便于余道往截至前问言。长寿汝何处去不得相置。我从何谁乞毛。正欲从汝乞。汝等信佛法者。知有罪福行业果报而不与我。谁当与我。长寿当知。如世尊说当起慈心。不乐闻者方便使闻。诸不信者教令立信。乃至手总其头强劝令施。所以然者。彼于此终当生天上。色力受命眷属自然。来生人中亦受快乐色力寿命眷属成就。修习佛法增益功德。逮甘露果。是故长寿世尊说言

  为福受乐报　　所欲皆自然
  超踰生死流　　上寂之涅槃
  若人为福者　　天神自然护
  所愿皆自成　　众魔莫能坏
  薄福多诸恼　　福能消诸患
  福德既牢强　　速成坚固定
  生天受快乐　　人中亦自在
  斯由功德故　　所往皆自然
  因斯福方便　　永离生死苦
  得道至涅槃　　不没不复生

尔时比丘说是偈已。复言长寿施我羊毛其福最大。是时估客闻说法已即施少毛。尔时估客作是思惟。若入市肆便多乞毛更不得利。折减钱本宁坐家住可全其本。故胜市中子本俱失。作是念已。便还家坐。时估客妇嗔其夫言。何以诣市速疾来归。如是懒堕何由得活男女充官赋役。估客答言。莫嗔且听。我今朝晨诣市店肆广说上事。乃至不如还家坐住。其妇闻已默然而止。是时尊者舍利弗次第乞食。至估客舍于门中住。尔时估客妇笃信恭敬。识舍利弗即持器盛食。出门着舍利弗钵中。头面礼足恭敬问讯。时舍利弗亦慰劳之。家中何如生活好不。其妇答言。家内悉佳但生理顿弊。问何以故。即以上因缘具白舍利弗。居家生活饮食衣服。供官赋税正仰市肆。而今夫主在家中住。畏人乞羊毛。实在言行。实觉言眠。师今是我家所供养恭敬尊重无所藏隐。又毛大贵。或一钱得一两。乃至二三四金钱得一两然此毛极细软。触眼睛不泪出甚为难得。尊者此羊毛出四大国。毗舍离国。弗迦罗国。得刹尸逻国。难提跋陀国。尊者我夫主及诸亲属。为求是毛故。或时得还。或死不还。以毛难得。是故极贵。而诸比丘人人来乞破我家业。遂至穷乏。尔时尊者舍利弗。广为说法令发欢喜。即还精舍。食后以上因缘具白世尊。佛言。呼是比丘来。来已佛问比丘。汝实作毡衣乞羊毛。乃至估客妇。向舍利弗说不。答言。实尔世尊。佛言。比丘汝常不闻我以无数方便呵责多欲赞叹少欲耶。此非法非律不如佛教。不可以是长养善法。佛告诸比丘。依止毗舍离者尽集。以卜利故。与诸比丘制戒。乃至已闻者当重闻。若比丘纯黑羊毛。作新敷具者。尼萨耆波夜提比丘者如上说。纯者不杂羊毛者有十种。相续羊羖羊。不具色羊山羊。游行羊羺羊。等羊鸣羊。众多耳羊木莲羊。新者初成也。敷具者[疊*毛]也。作者若自作若使人作。尼萨耆波夜提者。是敷具应众僧中舍。波夜提罪应悔过。若不舍而悔越比尼罪。波夜提者如上说。相续羊者有六种毛。生青染青。生黑染黑。生青黑染青黑。若自作若使人作。作成尼萨耆波夜提。受用越比尼罪。乃至木莲羊亦如是。此敷具应众僧中舍。众僧不应还。亦不得余用。正得敷地及作遮向帘帐幔。是故说若比丘纯黑羊毛作新敷具者。尼萨耆波夜提。佛住毗舍离大林重阁精舍。广说如上。尔时比丘作一切毡衣。僧伽梨。郁多罗僧。安陀会。尼师檀。唯除漉水囊及络囊。除一切毡作。佛未制戒前。尔时诸比丘着毡衣。露地如庵慢安隐住。制戒已不复着毡衣故。多病不安隐住。即以是事语尊者阿难。佛未制戒时。我等着毡衣犹如屋下得安隐住。佛制戒已不复得毡衣。故多病不安隐。善哉阿难。当为我等具白世尊。还听持毡衣。尔时尊者阿难往至佛所。头面礼足即以上事具白世尊。唯愿世尊。听诸比丘还得着毡衣。佛言听诸比丘杂作。佛告诸比丘。依止毗舍离者尽集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘欲作新敷具。应用二分。纯黑羺羊毛。第三分白。第四分下。若比丘不用二分。纯黑羺羊毛。第三分白。第四分下。作新敷具者。尼萨耆波夜提。比丘者如上说。新者初作敷具者。毡作者。若自作若使人作。纯者不杂羊毛者。十种如上说。二分者多用黑毛而作等想。等用作减想而更益。第三分白者。多用白毛而作等想。等用作减想而更益。第四分下者。少用下毛而作等想。如是作新敷具。若自作若使人作。作成尼萨耆波夜提。受用犯越比尼罪。尼萨耆波夜提者。是敷具应僧中舍。波夜提罪。应悔过。不舍而悔者越比尼罪。波夜提者如上说。前四种羊毛众僧中舍。僧不得还。亦不得余用。正得敷地及作遮向帘帐幔。后六种亦众僧中舍。僧不应还。僧得用不得用儭身着。是故说

佛住毗舍离大林重阁精舍。尔时有比丘欲作毡羊毛少。诸比丘问言。作毡竟未。答言未竟。问何以故。答言。羊毛少。诸比丘语言。汝欲使作毡细软暖不。答言欲尔。诸比丘语言。汝去到广野聚落乞憍舍耶合羊毛作。即如其言到广野聚落。往到憍舍耶家语言。长寿施我憍舍耶。答言小住待取憍舍耶还当与。是比丘在外须臾复来问还未。答言。始还待我小息须煮竟当与。其家有机让比丘坐。即坐小待复起以指内釜中看汤热不。即语言。汤已热可着茧。主人欲嗤弄比丘故问言。尊者。汤实热可着不。答言。实热可与。主人即持茧。内釜中啾啾作声。主人嫌言。我闻沙门瞿昙。无数方便赞叹不杀毁呰杀者。云何沙门释子。故杀众生失沙门法。何道之有。主人无欢喜心正施少许。比丘得已即合作敷具。诸比丘复问汝作敷具竟未。答言已竟。但于作中少利多过。诸比丘问言。云何少利多过。即具说上事。诸比丘闻已往白世尊。佛言。呼此比丘来。来已佛问比丘汝实尔不。答言。实尔世尊。佛言此是恶事。汝常不闻我无数方便呵责杀生赞叹不杀。汝今云何乃作此恶事。此非法非律不如佛教。不可以是长养善法。佛告诸比丘。依止毗舍离者尽集以十。利故。与诸比丘制戒。乃至已闻者当重闻。若比丘以憍舍耶杂纯黑羊毛。作新敷具。尼萨耆波夜提。比丘者如上说。憍舍耶杂者。憍舍耶有二种。一者生。二者作。生者细糸。作者纺糸。羊者十种如上说。新者初成。敷具者毡。作者若自作若使人作。作成尼萨耆波夜提。受用越比尼罪。尼萨耆波夜提者。是敷具应僧中舍。波夜提罪应悔过。若不舍而悔。越比尼罪。若比丘。用憍舍耶作僧伽梨。羊毛作郁多罗僧。若羊毛作僧伽梨。憍舍耶作郁多罗僧。若自作若使人作。作成尼萨耆波夜提受用越比尼罪。若比丘用憍舍耶作僧伽梨。羊毛作安陀会若用羊毛作僧伽梨。憍舍耶作安陀会。若自作若使人作。作成尼萨耆波夜提。受用越比尼罪。若经是憍舍耶纬是羊毛。若经是羊毛纬是憍舍耶。若自作若使人作。作成尼萨耆波夜提。受用越比尼罪。若边是羊毛中是憍舍耶若中是羊毛边是憍舍耶。若自作若使人作。作成尼萨耆波夜提。受用越比尼罪。若憍舍耶间紃羊毛中。羊毛间紃憍舍耶中。亦如上说若衣是羊毛缘是憍舍耶。若衣是羊毛纽褋是憍舍耶。若衣是羊毛补是憍舍耶。若自作若使人作。皆如上说。此毡衣众僧中舍。僧不得用。亦不应还。得敷地及作遮向帘帐幔。是故说

佛住毗舍离大林重阁精舍。广说如上。以五事利益故。世尊五日一行诸比丘房。尔时世尊行房。见故毡处处在地。粪扫中故屋中屋檐下。乌鸟衔作巢鼠曳入穴。佛知而故问诸比丘。此是何等故毡处处狼藉比丘言。世尊此是。诸比丘舍弃故毡。为好故更作新敷具。佛告诸比丘从今日作新敷具。应至六年持

复次佛住舍卫城。广说如上。尔时有一比丘。老病持重毡僧伽梨。诸比丘语言。汝持是重毡僧伽梨当乏死。可舍是毡持轻僧伽梨。是比丘答言。未满六年。复言汝不舍此衣当乏死。答言。我宁死不敢违戒。诸比丘即以是事具白世尊。佛告诸比丘。是老病比丘为着重毡衣增病者。僧应当与作毡衣羯磨。是比丘应从僧乞。僧与作求听羯磨。羯磨者应如是说。大德僧听。比丘某甲老病。毡衣重故增病羸瘦。若僧时到僧听。某甲比丘欲从僧乞毡衣羯磨。诸大德听。某甲比丘欲从僧乞毡衣羯磨。僧忍默然故。是事如是持。此比丘应从僧乞。偏袒右肩右膝着地。作如是言。我某甲比丘老病。毡衣重羸瘦增病。我今僧中乞毡衣羯磨。愿僧与我毡衣羯磨。如是第二第三。乞羯磨人应作是说。大德僧听。某甲比丘老病毡衣重。已从僧中乞毡衣羯磨。若僧时到。僧与某甲比丘毡衣羯磨。白如是。如是白三羯磨。佛问诸比丘已与老病比丘毡衣羯磨未。答言已与

佛告诸比丘。依止舍卫城者尽集。以十利故与诸比丘制戒。乃至已闻者当重闻。若比丘作新敷具应至六年持。若减六年故敷具若舍若不舍作新敷具。除僧羯磨。尼萨耆波夜提。比丘者如上说。新者初成。敷具者毡。作者若自作若使人作。六年者六夏。夏四月当屋下住。为毡故夜应三出。不得初夜并三出。初夜出。中夜后夜不出。二越比尼罪。中夜出。初夜后夜不出亦二越比尼罪。后夜出。初夜中夜不出亦二越比尼罪。初中后夜都不出者三越比尼罪。初中后夜三出者无罪。减六年者不满六夏。故敷具者于六年内畜持。若舍若不舍者。故毡现前若舍更作犯。故毡现前不舍作亦犯。故毡不现前若舍作亦犯。故毡不现前不舍作新敷具。若自作若使人作。作成皆尼萨耆波夜提。受用越毗尼罪。为好故者嫌太小太大。太轻太重。穿破太冷太热。我有檀越有人作。我有羊毛。当更作新敷具。为好故尼萨耆。除僧羯磨者。世尊开故无罪。羯磨或成或不成。不成者若是比丘。身不羸颜色不恶。筋力不减粗食能饱。若白不成就羯磨不成就众不成就。如是比事事不成就。是名羯磨不成就若是老病比丘。身羸颜色恶筋力减少细食不能饱。何况粗。白不成就羯磨。不成就众不成就。如是比事事有失。是亦名羯磨不成就。成就者若是比丘羸瘦颜色恶筋力减少细食不能饱白成就羯磨成就众成就。如是比事事无失。是名羯磨成就。是老病比丘僧羯磨已。应当自疏记。先受持故毡年月日数。病差已还受持此故毡。从前满六年。若是比丘病差不还补六年。尼萨耆波夜提。尼萨耆波夜提者如上说。众僧中舍已僧不应还。僧得受用但不得儭身。是故说

佛住毗舍离大林重阁精舍。广说如上世尊以五事利益故。五日一行诸比丘房。见故毡处处在地。若粪扫中故屋中。屋檐下。乌鸟衔作巢鼠曳入穴。佛知而故问诸比丘。此是何等故毡处处狼藉。诸比丘白佛言。世尊。有诸比丘。或罢道或死者。或现在弃舍故毡狼藉。佛语诸比丘。若施者不知筹量。受者应筹量。比丘受施应当用不应弃从今日若比丘作新敷具毡尼师檀当着。故敷具毡辟方一修伽陀搩手。为坏好色故。佛告诸比丘。依止毗舍离比丘皆悉令集。以十利故与诸比丘制戒。乃至已闻者当重闻。若比丘作新敷具毡尼师檀当着。故敷具毡辟方一修伽陀搩手。为坏好色故。若比丘作新敷具毡尼师檀不着。故敷具毡辟方一搩手。尼萨耆波夜提。比丘者如上说。新者初成。敷具者毡。尼师檀者如佛所听。作者若自作若使人作。故敷具者先六年所持者是。修伽陀者等正觉。一搩手者长二尺四寸。取故毡时不得从少闻者。犯戒者。无闻者。住房坏不补治者。恶名人。断灭见人远离和尚阿阇梨不喜咨问者。不能破魔人。不分别魔事者。如是人边不应取。应从多闻乃至能分别魔事人边取。着修伽陀辟方一搩手取故。毡时不得缺角麦形如杵形车形垂乱举下。缺角者无角。麦形者中央广两头狭。杵者两头广中央狭。车形者一头广一头狭。垂者掇着。乱者不周正。举者凸起。下者凹四边缝处高中央下。是如不得着。着时方圆令周正。若穿坏者补。若垢腻当浣。擗杂余毛作。是比丘作新尼师檀。若不着故者。是尼师檀应众僧中舍。僧不应还。僧得受用不为儭身。是故说

佛住毗舍离大林重阁精舍。广说如上。尔时尊者优陀夷。担重羊毛。偻身而行从城里出。为世人所嫌。看沙门优陀夷。如骆驼如驴如客负人。如是负羊毛去。失沙门法何道之有。诸比丘以是因缘往白世尊。佛言。呼优陀夷来。来已佛问优陀夷。汝实担重羊毛。为世人所讥耶。答言。实尔世尊。佛言。此是恶事。从今日后不听担负

复次佛住舍卫城。广说如上。有诸比丘到北方赞叹佛。赞叹舍利弗目连诸长老比丘及须达居士。毗舍佉鹿母。只桓精舍。开眼林种种赞叹。诸比丘闻已有六十比丘欲来礼拜。即问来比丘。我欲往彼少供养。梵行人。赍何等物。当得适彼所须。答言。长老彼诸比丘一切皆着[疊*毛]衣。唯除漉水囊及络囊。可持羊毛往彼。尔时有六十比丘。各各持羊毛重担而行。从聚落至聚落。从城至城。时世人讥嫌。汝等看是沙门释子持重担而行。如驼如驴如客作人如商人。如是担重担。复有人言。汝不知耶此间贱买欲彼间贵卖。失沙门法何道之有。诸比丘渐向舍卫城。到已礼世尊足却住一面。佛知而故问诸比丘。汝等从何处来。答言。世尊从北方来。佛问诸比丘。道路不疲乞食不难耶。答言。世尊道路不疲乞食不苦。但于道中为世人所讥。佛问诸比丘。世人所讥何等。答言世尊我等六十人皆担羊毛。如上广说。佛言比丘汝等正应为世人所嫌。从今日后不听比丘自担羊毛。佛告诸比丘。依止舍卫城者尽集。以十利故为诸比丘制戒。乃至已闻者当重闻。若比丘行道中得羊毛欲取。是比丘得自手取至三由延。若过三由延担者。尼萨耆波夜提。比丘者若一人若众多。若僧行道者。三由延二由延一由延半由延一拘卢舍。得者。若男若女若大若小。若在家若出家人边得。羊毛者。十种如上说。欲取者实所须自担。三由延者五肘弓。二千弓名一拘卢舍。四千弓半由延。八千弓一由延。十六千弓二由延。二十四千弓为三由延。三由延者自担齐三由延。若过尼萨耆波夜提尼萨耆波夜提者。是毛应众僧中舍。波夜提罪应悔过。若不舍而悔越比尼罪。若比丘持羊毛。着道行至一由延有所忘还取。取已还至本处即满三由延不得复过。过者尼萨耆波夜提。若一由延半忘物得还。还已不得复去。去者尼萨耆波夜提。若直行齐三由延。过一脚越比尼罪过两脚尼萨耆波夜提若二人各有担齐三由延已转易各复得三由延三人九由延。四人十二由延。若如是众多人随人为限。唯不得更重檐。曾檐者若贸易若更得。得更至三由延。若比丘持羊毛着衣囊中。从一家至一家。计满三由延不得复去。若持羊毛着钵囊中。乞食从一聚落至一聚落亦如是。若持羊毛着囊中经行亦如是。若持绕塔亦如是若未成作物。乃至齐塞针筒毛亦犯。若已成物若作毡若枕若褥等不犯若檐骆驼毛跶毛。得偷兰遮罪。若担[牧/(厂@牛)]牛尾。越比尼罪。若施柄无罪。若担师子毛猪毛越比尼。心悔若成器无罪。是故说

佛住毗舍离大林重阁精舍。广说如上。时尊者优陀夷是善生比丘尼本二。时尊者优陀夷。持羊毛与善生比丘尼作是言。善哉姊妹与我浣染擗治。比丘尼即持去至自住处。与浣染擗竟盛着箱中。以掖下粗毛屏处粗毛覆上。即遣使持与优陀夷。优陀夷得已开箱见是粗毛。欢喜示诸比丘言。看此长老非亲里比丘尼。与少毛得多毛来。时诸比丘见已语言。此是覆藏之物。云何出示人。即答言此有何覆藏物。我与少毛得多毛来。时六群比丘遥闻已。拍手大笑怪哉怪哉。诸比丘闻已往白世尊。佛言呼优陀夷来。来已佛问优陀夷。汝实尔不。答言实尔。佛言此是恶事。乃至佛问比丘。设使亲里比丘尼。应藏之物当出示亲里比丘不。答言不也世尊。设使亲里比丘。得亲里比丘尼应藏之物。当出示人不。不也世尊。佛语诸比丘。从今日不得使非亲里比丘尼。浣染擗羊毛

复次佛住舍卫城。广说如上。时尊者优陀夷。持羊毛与大爱道比丘尼。善哉姊妹与我浣染擗治。时大爱道比丘尼即为擗染治讫。还送与优陀夷已。往至世尊所。头面礼足却住一面。佛知而故问。手上何以故有染色。答言我与尊者优陀夷。浣染擗羊毛。佛语诸比丘。云何优陀夷。使非亲里比丘尼。浣染擗羊毛。佛言呼优陀夷来。来已佛问优陀夷。汝实使大爱道比丘尼。浣染擗羊毛耶。答言实尔世尊。佛言优陀夷。汝云何令行道比丘尼作。从今日后不听使非亲里比丘尼。浣染擗羊毛。佛告诸比丘。依止舍卫城者皆悉令集。以十利故。为诸比丘制戒。乃至已闻者当重闻。若比丘使非亲里比丘尼浣染擗羊毛。尼萨耆波夜提比丘非亲里及羊毛如上说。浣染如上第五戒中说。擗者分析。尼萨耆波夜提者。此毛应众僧中舍。波夜提罪应悔过。不舍而悔。越比尼罪。波夜提者。如上说。此中增擗一事。除打着泥污衣。着垢腻衣。往尼寺。余如上第五戒中广说

摩诃僧祇律卷第九摩诃僧祇律卷第十

        东晋天竺三藏佛陀跋陀罗共法显译

    明三十尼萨耆波夜提法之三

佛住王舍城迦兰陀竹园。广说如上。尔时周罗聚落主。到世尊所。头面礼足却住一面。白佛言。世尊。前日众多大臣婆罗门居士长者。集王殿上。作如是论。有言沙门释子应畜金银。有言不应畜。何者实语法语。随顺法于现法中不逆论。佛言。沙门释子不应畜金银。若有人言应畜金银。是诽谤我非实非法非随顺。于现法中是为逆论。何以故。若得畜金银者。亦应得畜五欲。何等五。一者眼分别色爱染着。乃至身受触爱染着。当知是非沙门释种法。聚落主言。甚奇世尊。未曾有也世尊。如世尊说。沙门释子不应畜金银。若畜金银者。非沙门法非释种法。是故我今归依佛归依法归依僧。我是佛优婆塞离杀生。世尊当证知。如是三说。乃至不饮酒。我先时有是念。沙门释子不应畜金银。若畜者无异受五欲人。尔时世尊即为聚落主。随顺说法示教利喜。如染净[疊*毛]易为受色。即于坐上见四圣谛。见四圣谛已白佛言。世尊。俗人多务当还请辞。佛言。宜知是时。起礼佛足右绕而去。去不久佛往众多比丘所。敷尼师檀坐已。语诸比丘。向周罗聚落主来到我所。如上广说。乃至右绕而去。佛告诸比丘。汝等当如是学。不得畜金银。我无有方便得畜金银

复次佛住舍卫城。广说如上。世尊以五事利益故。五日一行诸比丘房。见难陀优波难陀住处。时难陀优波难陀。数钱手上着土。往诣世尊头面礼足却住一面。佛知而故问。手上何以着土。答言世尊。我数钱故手上有土。佛语难陀。汝等云何手自捉生色似色从今日不听手自持生色似色

复次佛住毗舍离大林重阁精舍。广说如上。时优陀夷。时到着入聚落衣持钵。至一泥师家。其家始作节会讫。其妇出迎作礼问言。尊者。昨日何以不来。若来者当得好饮食。答言。昨日今日复何在耶。若有好食便可持来。白言。好食已尽。今与尊者钱。可于店上易好食。答言。世尊制戒。不听我自手捉钱。汝可以钱系我衣角。即如其言系钱而去。至市肆上语言。长寿与我饼来。答言。尊者示我钱来。优陀夷言。但与我饼。我不动此处。当与汝钱。白言。尊者持钵来。即与钵盛满种种饼食。与已语言与我钱来。答言。汝自衣角头解取。肆上人欲调弄故不与解。语言。汝自解与我。答言。佛不听我捉生色似色。汝自解取。解取已即呵责言。云何沙门释子。以少方便谓此为净。我等亦不常以手捉。及着口中。我亦不系衣角头及囊器中。此失沙门法。何道之有。时优陀夷。持饼到自房中。唤余比丘共食。诸比丘即问。此饼甚好为何处得。此非家中作饼。答言。诸长老此中少利多过。诸比丘问言。何故多过。答言。我如是如是因缘是故多过。诸比丘以是事具白世尊。佛言呼优陀夷来。来已。佛问优陀夷。汝实尔不。答言。实尔世尊。佛言。此是恶事。从今日后衣系亦不听

复次佛住迦维罗卫城广说如上。世尊以五事利益故。五日一行诸比丘房。见一比丘痿黄羸瘦。佛知而故问。比丘忍苦不安隐住不。答言。世尊。我不安隐疾病苦恼。佛语比丘。汝不能索随病食随病药耶。答言。我闻世尊制戒。不得自手捉生色似色。复无人与我。是故受苦恼。佛言。从今日后。听病人得使净人畜莫贪着。佛告诸比丘。依止迦维罗卫城比丘。皆悉令集以十利故与诸比丘制戒。乃至已闻者当重闻。若比丘自手捉生色似色。若使人捉举。贪著者尼萨耆波夜提。比丘者如上说。自手者若身若身分若身相续。身者一切身。身分者若手若脚若肘若膝。身相续者。若系僧伽梨。郁多罗僧。安陀会。覆疮衣。僧祇枝。雨浴衣。若钵小钵键[金*咨]铜盂中。如是比是名身相续。生色者是金也。似色者是银。生色似色者。钱等市用物。捉者若自捉若语人捉。举者若自举若教人举。贪著者作是念。我当用此物得五欲。谓色声香味触等。是名贪着。不贪著者。如清净持戒比丘。自担粮食糗糒米面等。时作是念。我无有方便欲食此食。但于此不净物中生清净物想。我当受用尼萨耆波夜提。尼萨耆波夜提者。是金银钱应僧中舍。波夜提罪应悔过。若不舍而悔得越比尼罪。此金银若钱。若作不作。若多若少。若纯若杂。若成器不成器等。僧中舍已不得还。彼比丘僧亦不得分。若多者应着无尽物中。于此无尽物中。若生息利得作房舍。中衣不得食用。比丘凡得钱及安居讫。得衣直时不得自手取。当使净人知。若无净人指示脚边地语言。是中知着地已。自得用草叶塼瓦等物。遥掷覆上待净人来令知。若净人来知已持去。若不可信者。教使在前行使知置一处。若可信净人者从意使知置一处。若比丘知佛事僧事。多有金银钱当举时。若是生地教净人使知。若是覆处死土。若自掘。若使年少比丘掘。若净人不可信者。裹眼三旋。然后使知地。知地已。使知内钱坑中。犹复裹眼使去。若钱堕坑岸上者得捉塼瓦掷钱使入坑中。得自填坑。后欲取时。若是生地使净人知。若是死地得自掘。抒土到钱。净人不可信者。复裹眼三旋。将来取之。若襆裹中有金银钱。在橛上不得自捉。当使净人知。若净人小不及者。得抱举使知。取抱时应作是言。我举净人。我举净人。得下物已。当使解。若不知解者得捉。净人手教使解。解已教知数。若不知数者。得捉净人手数。数已余者。还教着囊中。若不知着囊中者得捉净人手教着囊中着囊中已。教净人系若不知系者。使净人手捉囊底。比丘得自系。系已还置橛上。若净人短不及者。得抱举。若槛匮箱箧等在架上。橛上取时举时覆时。亦复如上。若行道时净人檐金银。净人若小得手牵去。若渡水时得抱渡。应作是言我渡净人。我渡净人。若比丘将净人行。若净人小不能上船。得抱上。应作是言。我举净人。我举净人。下船时亦如是。是比丘若道行食息时。若河若井。若池上食。食已净人忘囊去。有长老比丘。在后看诸人不忘物耶。见有遗物。作是念。此必是比丘许。即便持去行及伴已问伴言。是谁许。有人言。此是净人囊。即速放地。净人尔时应即取去。不得字名。若比丘行道共净人一处宿。夜发去时。净人捉比丘襆。比丘捉净人襆。到地了见襆。是净人襆。即应放地。净人应取不得字名。若比丘多有金银钱失去。若疑在床间。欲求觅故。出床时。越比尼罪。若得尼萨耆。若比丘多有钱物。疑在毡褥中。欲求故出毡时越比尼罪。得已尼萨耆。若比丘多有钱物。疑在地。欲求故扫地时。越比尼罪若得尼萨耆。若比丘多有钱物。疑在粪扫中。欲求故出粪扫时。越比尼罪。得尼萨耆。若病比丘有人与药直钱病故得着敷褥底。眼闇求时。手摩触在不无罪。若檀越新作金银床机。信心故欲令比丘最初受用。比丘言。我出家人法不得用。檀越复言。尊者。为我故颇有开通。得受用不。比丘应语言。厚敷一一人自重坐具者得坐。比丘坐已不得动床。亦不得赞叹。若檀越新作金银承足机。信心故欲令比丘最初受用。比丘言。我出家人法不得受用。复言。尊者。为我故可得方便开通受用不。应语言。机上若着树叶若[疊*毛]覆上者得安脚。安脚已不得动足。亦不得赞叹。有檀越作金银盘。信心故欲令比丘最初受用。比丘言。我出家人法不得用。复言。尊者。为我故。颇有方便开通得受用不。应语。若草叶若[疊*毛]覆盘上者得。不得手捉。应指示着地。若檀越新作金银器。信心故。欲令比丘最初受用。比丘言。我出家人法不得受用。复言。尊者。为我故。颇有方便开通得受用不。应语。汝当净洗置盘上持食来。来时应舒手指器。应作是言。受受。如是三说。名为受受。已在器中食不得触器四边。若四月八日及大会供养时。金银塔菩萨像。及幢幡盖供养具。一切有金银涂者。比丘不得自手捉。使净人捉。若倒地者。当捉无金银处。若遍有金银涂者。当以衣物花等裹手捉。若无物裹手。若像上随有未涂处得捉。若金银香炉灯盛拂柄。如是比一切有金银。若涂者不得捉。及浴金银菩萨形像。不得自洗。当使净人。若大会时有金银像。使净人持出。比丘得佐不得捉。有金银处。比丘不得先捉后放。若比丘随国土。若有铜钱。若具子钱若铁钱。若胡胶钱竹筹钱皮钱。如是一切随国土中所用。比丘不得捉。或有国土所用。相不成就捉者。越比尼罪。国土不用相成就捉者。越比尼罪。国土所用相成就捉者。尼萨耆波夜提。国土所不用相不成就。作铜铁捉无罪。是故说

佛住舍卫城。广说如上。时六群比丘在市中。买酥油蜜石蜜。乳酪鱼肉。种种买食。为世人所嫌。云何沙门释子不能乞食。到诸市中买食而食。失沙门法。何道之有。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。来已佛问六群比丘。汝实市中种种买食。为世人所嫌耶。答言。实尔世尊。佛言。此是恶事。正应为世人所嫌。汝常不闻我赞叹少欲呵责多欲耶。此非法非律。不如佛教。不可以是长养善法。佛告诸比丘。依止舍卫城比丘。皆悉令集以十利故。为诸比丘制戒。乃至已闻者当重闻。若比丘种种买卖。尼萨耆。波夜提。比丘者如上说。种种者。若自问价。若使人问价。若自上价。若使人上价。若自下价。若使人下价。问价者。此物直几许。答言。尔许与汝。尔许取不作不净问故。越比尼罪。得者尼萨耆。使人问者。语言汝往问彼物索几许。若言索尔许者。汝便与尔所作不净语。遣人问故。越比尼罪。得者尼萨耆。上价者。此价直几许。答言。尔许与汝。尔许欲取。故诤上价作不净语故。越比尼罪。得者尼萨耆。使人上者。语前人言。汝往上尔许。尔所得者。取是名不净。遣使语越比尼罪。得者尼萨耆。下者此价直几。答言一千。我与汝八百。若言九百。语言。我与汝七百。如是至十。下求他物不净语故。越比丘罪。得者尼萨耆。使人下者。亦如是。若以时物还买时。物买夜分。物买七日。物买终身。物买随身。物买重物。买不净物。买净不净物。语时犯越比尼罪。得者尼萨耆。如是夜分七日。终身随身物。重物净不净物。各各作问。亦如是。尼萨耆波夜提者。如上说。肆上衣先已有定价。比丘持价来。买衣置地时。应语物主言。此直知是衣。若不语默然。持去者。犯越比尼罪。买伞盖箱革屣扇箧甘蔗。鱼脯酥酪油蜜种种亦如是。有国土市买有常法赍直来着物边。卖物主摇头。当知相与比丘亦应语言。此直知是物。前人若解不解。要应作是语。若不作是语。默然持物去者。犯越比尼罪。若估客卖物应直五十而索百钱。比丘言。我以五十。如是如是求者。不名为下。若比丘知前人欲买物。不得抄市。应问言。汝止未若言未我方坚价。比丘尔时不得中间抄买。买者。犯越比尼罪。若言我休。当语物主言。我以此价知是物。若比丘共展转贸易衣钵时。不得中间抄。抄者。犯越毗尼罪。若前人放已取者无罪。若众僧中卖物。得上价。取无罪。若和尚阿阇梨欲取者不得抄。若比丘还共比丘。市买博易作不净语。买者无罪。一切九十六种出家人边。作不净语。买者无罪。若比丘见人卖钵时。作是念。此钵好至某方。当得利。买时犯越比尼罪。若作是念。我有是物无有净人。此是净物。得买去无罪。到某方或和尚阿阇梨所须。或自为病。或作功德。买去本不为利。临时得贵价卖无罪。如是一切物。若比丘籴谷时。作是念。此后当贵籴时。犯越毗尼罪。粜时尼萨耆。若作是念。恐某时谷贵。我今籴此谷。我当依是得诵经坐禅行道。到时谷大贵。若食长。若与和尚阿阇梨。若作功德。余者粜得利无罪。若比丘储药草时作是念。此后当贵买时。犯越比尼罪。后卖者尼萨耆。若比丘买药草时。作是念。为后病时。药草贵难得故。买后若不病。或服残卖得利者无罪。若营事比丘。雇窑师木师。作不净语。犯越比尼罪。若泥师画师。一切作师。亦如是。若僦赁车马牛驴驼人船等。亦如是。若比丘为僧作直月行。市买酥油籴米豆麦面糗糒。求一切物时。作不净语者。犯越比尼罪。若自为买酥油等物。一切作不净语越比尼罪。得者犯尼萨耆。若比丘市买时。得诃嫌说实前人物。此好此恶。若粗若细。斗秤大小香臭等无罪。若前人言。当与满量平斗。应当语言。以此价知是。若乞食比丘。有长糗糒。持到肆上。买酥油乳酪时。作不净语。越比尼罪。得者尼萨耆波夜提。比丘不得至人闹处店肆上市买。得到边少人肆上。言以此价知是。如是一切尽皆应言知。若乞食比丘有残糗。雇治革屣。作不净语。犯越比尼罪。若前与糗后治。若前治后与糗无罪。若比丘以钵中残食。雇人使治经行处。作不净语。犯越比尼罪。应语知是若先与食后使作。若先使作后与食无罪。有檀越为比丘故。与店上钱语言。若某比丘日日来有所索。从意与彼比丘。后来索时作净不净语无罪。是比丘所索物店上无即与比丘钱余处买。比丘往至余处。求物时作不净语。得者尼萨耆波夜提。若比丘店肆上。不净语分别价。净语取净语分别价。不净语取不净语分别价。不净语取净语分别价。净语取不净语分别价。净语取者。问前人。此物卖索几许。我欲知此物。净语分别价不净语取者。知是物分别卖索几许。我与如是买。不净语分别价不净语取者。如是分别卖索几许。我如是买。净语分别价净语取者。如是价知如是知取。不净语分别价净语取者。犯越毗尼罪。净语分别价不净语取者。犯越比尼罪。不净语分别价不净语取者。尼萨耆波夜提。净语分别价净语取者无罪。是故说

佛住毗舍离大林重阁精舍。广说如上。时难陀优波难陀从王家买金。使王家金银师。作璎珞严饰之具。作成已莹治发光。盛着箱中菁[疊*毛]莲花覆上。与沙弥先教言。我将汝到贵胜家。若语汝。开时汝但开现一角头。即将至贵胜家。贵胜家妇女见来头面礼足。却住一面即问言。此箱中是何等。答言。用问此为非汝所问以不示故复更殷勤。语沙弥言。出示与看。沙弥即示一角。菁助发色。日光照金晃昱耀目。问言。尊者。此是谁许。答言。用问此为。有金有作者。即是其主。复问。金价直几作功用几。即如实答。金直尔许功夫尔所。即言大贵汝云何嫌贵。我与汝尔许直。汝能作不。中有直信者。作是言。诚如师教。作亦甚难。非可卒得。中有妇人。或自有财。或父母财。或姑嫜财。或伯叔财。或夫婿财。或家中密取财持买璎珞。时人不复肆上买金。亦不雇金银师作。时诸肆上人及金银师。皆嫌言。云何沙门释子夺人息利。诸比丘即以是事。往白世尊。佛言。唤难陀优波难陀来。来已佛问难陀优波难陀。汝实从王家买金使金师作不。答言实尔。世尊。佛言。优波难陀。此是恶事。汝常不闻。我无数方便呵责多欲。赞叹少欲。此非法非律。不如佛教。不可以是长养善法。佛告诸比丘。依止毗舍离比丘尽集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘种种贩卖生色似色。尼萨耆波夜提。比丘者。如上说。生色者金。似色者银。若以金买金金买银金买金银。若以银买银银买金银买金银。若以金银买金金银买银金银买金银。以不作金买不作金。以不作金买作金。以不作金买作不作金。以不作金买作金不作金。及作不作金。以作金买作金四句。作金不作金四句。作金不作金及作不作金四句。皆如上。若以不作金买不作银。以不作金买作银。以不作金买作不作银。以不作金买作银不作银。及作不作银作金四句。作不作金四句。作金不作金及作不作金四句。亦如上。若以不作金买不作金银。以不作金买作金银。以不作金买作不作金银。以不作金买作不作。及作不作金银。余作金门作不作金门作金不作金。及作不作金门四句。亦如上。银门十二四句。金银合作门十二四句。广说如上。是故说第二跋渠竟

佛住舍卫城。广说如上。时有瓦师字法豫。有比丘到时。着入聚落衣。往到其家。法豫见已。头面礼足。却住一面。比丘言。我须钵即作钵持与。不大不小。适得其中烧熟滑泽。即持还到祇洹。诸比丘问。长老何处得此钵。不大不小。适得其中烧熟滑泽。答言。瓦师法豫施我。诸比丘问已。复往索尽得。如是众多。法豫作是念。诸比丘多有须钵。我不如请众僧与钵众僧者。是良福田。果报无量。即往至祇洹精舍上座前。头面礼足。胡跪合掌。白言。我瓦师法豫。请大德众僧施钵。须者来取。时比丘或取一。或取二三四。乃至十。法豫作不供。时尊者舍利弗时到着入聚落衣。持钵入舍卫城。次行乞食往到其家。其家妇人信心欢喜。净洗铜器盛食出到。着钵中。其妇先识尊者舍利弗。头面礼足。却住一面。尊者舍利弗问言。家中生业何似。答言。家中生业不举。问言何故。答言。我家夫主请僧与钵。诸比丘或取一二。乃至十。作钵不供家业不办。何以故。我家仰是瓦作生活。大小饮食衣服供王赋税。阿阇梨是我家供养尊重故。说是语耳。时舍利弗广为说法。生欢喜心已而去。时尊者舍利弗以是因缘。往白世尊。佛言。呼是比丘来。即呼来已。佛问比丘。汝实尔不。答言。实尔世尊。佛语诸比丘。施主不知筹量受者应筹量。佛言。从今日比丘长钵听一日畜

复次佛住毗舍离大林重阁精舍。广说如上。毗舍离人年年请僧食。食已施钵。时比丘不受用此钵。为世尊听。我长钵正得一日畜。未得受用。便成不净。时施主言。我当从世尊乞是愿。施主到世尊所。头面礼足。却住一面白佛言。世尊。我等年年请僧食。食已施钵。诸比丘不受作是言。我用此钵为未得受用。便成不净。善哉世尊。颇有因缘得开通。令施者得功德。受者得利不。佛言。听先一日更与九日。时诸比丘畜钵满十日。持钵往至世尊所。白言。此钵满十日。今当云何。佛言。诸比丘。此钵应知识比丘边作净。若十日里舍故受新。十日一易。佛告诸比丘。依止毗舍离比丘。皆悉令集。以十利故。为诸比丘制戒。乃至已闻者当重闻。若比丘长钵得畜十日。若过者。尼萨耆波夜提。比丘者。如上说。十日者。得畜齐十日。长钵者。受持外钵也。钵者。一参婆钵。二乌迦斯魔钵。三优迦吒耶钵。四多只耶钵。五铁钵。六致叶尼钵。七毕荔偷钵。上钵中钵下钵。过钵非钵随钵。上者摩竭提国一阿罗米作饭及受羹菜。一阿罗者可此间斗六升。中者半阿罗米作饭及受羹菜。下者一钵他米作饭及受羹菜。三分饭一分羹菜。过钵者煮一阿罗米饭。并羹菜不满。是名过钵。非钵者。不受一钵他米饭并羹菜。是名非钵。随钵者。随钵中所用器。此中上钵中钵下钵畜过十日。尼萨耆波夜提。余者不犯。尼萨耆波夜提者。是钵应僧中舍波夜提罪。应悔过。若不舍而悔。得越比尼罪。波夜提者。如上说。若比丘月生一日得十钵畜不作净。过十日。一切尼萨耆波夜提。乃至不晓受持不晓作净。当教如是受持。如是作净。皆如第一长衣戒中说。此中但以钵为异。是故说

佛住舍卫城。广说如上。时舍卫城中瓦师法豫。请僧施钵。诸比丘为好故。持故钵来易新钵者。如是众多遂不相供。尔时尊者舍利弗到时。着入聚落衣持钵入城。次行乞食到法豫门前住。法豫妇与尊者舍利弗旧是相识。信心欢喜。乃至言。尊者我家夫主请僧与钵。诸比丘为好故。持故钵来易新者。我家中积聚故钵成聚如山。我俗人家新钵尚不用。何况故者。尊者我家仰瓦作生活。乃至舍利弗为随顺说法。发欢喜心已。礼足而退。舍利弗还到精舍。以是因缘。具白世尊。佛言。呼此比丘来。来已佛问比丘。汝实尔不。答言。实尔。世尊。佛言。从今日后不听比丘索钵

复次佛住舍卫城。广说如上。北方有六十比丘来欲礼拜世尊于道中被贼失钵。无钵入祇洹精舍。尔时诸梵行者各各与钵。得钵已往到世尊所。头面礼足。却住一面。佛知而故问。诸比丘。汝从何处来。答言。北方来。佛问比丘。道路安隐不。答言。不安隐。道路被贼失钵。无钵入祇洹诸梵行者各各与我钵。佛问诸比丘。道中无有聚落城邑耶。答言有。问言。何故不乞。答言我闻世尊制戒不听乞钵。复无施者。佛言。善哉善哉。比丘。汝等信心出家。法正应尔。乃至失命不故犯戒。从今日听失钵时乞

复次佛住舍卫城。广说如上时北方六十失钵比丘来到只桓。尊者难陀优波难陀语言。长老。世尊听失钵得乞何故不乞。答言。诸梵行人已与我钵。复言汝若不乞所应得者。便失此利答言我已得钵失以不失无在。难陀言。我当为汝乞。答言。汝自当知。乃至优婆塞言。尊者欲作瓦肆耶。如乞衣中广说。诸比丘闻已往白世尊。佛言呼难陀优波难陀来。来已佛问。难陀优波难陀汝实尔不答言。实尔。世尊。佛言何故乞耶答言我为失钵比丘乞。佛言。呼失钵比丘来。来已佛问比丘。汝使难陀优波难陀乞钵耶。答言。不也世尊。佛言何因缘乞。答言如是如是。佛语诸比丘。是难陀优波难陀不应乞者便乞。应乞者不乞。佛语难陀优波难陀。此是恶事汝常不闻我以无数方便。赞叹少欲毁呰多欲。此非法非律。不如佛教。不可以是长养善法。佛告诸比丘。依止舍卫城者尽集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘所用钵减五缀。更乞新钵为好故。尼萨耆波夜提。是钵应僧中舍。比丘众中最下钵。应与应如是教。汝比丘受是钵。乃至破是事法尔。比丘者。如上说。减五缀者。若有一缀量减五。是名减。若有二缀乃至有五缀量减五。是名减满。五缀者。已有五缀量。亦满是名满。若四三二一缀。若无缀量满五。是名满。五缀量者。破处缀间相去足一大指。钵者如上说。新者。初成。更求者。若乞若劝化。为好故者。嫌太大太小太重太轻若粗涩。我有檀越有泥有手力。当更作好钵。是比丘应持是新钵。众僧中舍众僧中选下钵应与。是比丘应如是教。汝长老受此钵。乃至破不得故。打破。波夜提。悔过。是新钵应众僧中舍。波夜提罪。应悔过。若不舍而悔。犯越比尼罪。波夜提者。如上说。是比丘钵减五缀为好故。更求新者。尼萨耆。是比丘应请持律知羯磨者。乃至五法成就。僧当羯磨作行钵人。何等五。不爱不嗔不怖不痴与不与知。是名五。羯磨人应作是说。大德僧听。某甲比丘五法成就。若僧时到。僧差某甲比丘作行钵人。如是白。大德僧听。某甲比丘五法成就。僧今差某甲比丘。作行钵人。诸大德忍。某甲比丘作行钵人。忍者僧默然。若不忍便说僧已忍。使某甲比丘作行钵人竟。僧忍默然故。是事如是持。作羯磨讫。应僧中唱。大德僧所受持钵。一切持来。若不唱者。犯越毗尼罪。诸比丘应各各赍己所受持钵来。若有比丘舍先所受钵。更受下钵持来者。得越比尼罪。羯磨人应当语此比丘。舍此钵偏袒右肩。右膝着地言。我某甲比丘钵减五缀。为好故。更求新钵。我今僧中舍。律师应问。汝受用未。若言受用。应语言。此中用不净钵。得无量越比尼罪。应忏悔应言。长老。我某甲钵减五缀。更乞新钵已。僧中舍。此中犯波夜提。受用不净钵。犯无量越比尼罪。一切悔过。问汝见罪不。答言见。谨慎莫复犯。答言。顶戴持。行钵人应持此钵与僧上座。上座若取应持上座钵与第二上座。如是次第。乃至无岁比丘。若都无人取者。应还本主。若是钵大贵者。应卖取十钵直。九钵直入僧净厨。一钵还本主。应语言。汝持此钵。乃至破是持缀钵。比丘入聚落。乞食食已。应解缀。若灰若土。净洗洗时不得持坚物。刺孔中令破。当以鸟翮刺中。洗钵时。不得以沙灰洗。令脱色。当用无沙巨摩根汁叶汁。花汁果汁洗。洗时不得临坑岸上危险处。不得熟果树下。若石上塼上。当平地洗钵。若地泥污。若粪扫。若无坐处。当偻身去地一磔手。洗已晒令燥。还持绳缀缀已。举着一处。不得着临坑岸上危崄处。熟鞞醯勒果树下。椰子树下。石上塼上行来处。开户处。若着钵囊中。若安置壁上龛中。以物遮口。若有事匆匆不得。好洗者当以根汁叶汁等。涂拭事讫当洗。明日洗已持入聚落乞食。设缀钵难用一日乃了。要当洗净。若故打破。得波夜提罪。若和上阿阇梨知识作是念。此贤善比丘。以洗钵故。妨坐禅受经诵经。若打破若藏去。不见已更乞无罪。无钵乞得一钵应受持。若乞得两钵一钵。应受持。一钵应入众僧净厨。如是乃至得十钵。一钵自受持。九钵应入众僧净厨。若比丘无钵。求钵得一钵。直者是名有钵。若乞得两钵直。一钵直入众僧净厨。如是乃至十钵直九钵直。应入众僧净厨。是故说

佛住舍卫城祇洹精舍。广说如上。世尊以五事利益故。五日一历诸比丘房。见难陀优波难陀住处。满瓶酥油蜜石蜜。流出根药茎药叶药花药果药。佛知而故问。诸比丘此谁住处。有此满瓶酥油蜜等。处处溢流如是。诸比丘答言。世尊此是难陀优波难陀住处。尔时世尊言。待来当问

复次佛住毗舍离大林重阁精舍。广说如上。世尊到时着衣持钵。共众多比丘。入毗舍离大城。见优波难陀持满钵蜜出城。见已知而故问。此钵中何等。答言。世尊。是蜜。复问欲作何等。答言。难陀病须。佛言。太多。答言。竟日须服。佛言。云何畜药竟日服耶。从今日不得畜药竟日服

复次佛住迦维罗卫尼拘律树释氏精舍。世尊以五事利益故。五日一行诸比丘房。何等五一者我声闻弟子不著有为事不。二者不着世俗戏论不三者不着睡眠妨行道不四者为看病比丘不。五者为年少比丘新出家。见如来威仪。起欢喜心。是为五事如来五日。观历诸房。见一病比丘颜色痿黄羸瘦。佛知而故问。比丘汝调和不。答言。世尊。我病苦不调和。佛言比丘。汝不能索随病食及随病药治耶。答言世尊制戒畜药。时服不得久停。是故我苦。佛告诸比丘。从今日听病比丘停药一日。尔时佛问难陀汝舍卫时多畜酥油蜜石蜜耶。答言。实尔。世尊。佛言。汝云何多欲无厌种种呵责已。自今已后不听多畜

复次佛住波罗奈仙人鹿野苑广说如上。时有六十病比丘。有一医师出家为道。疗治诸病比丘。是医比丘来问讯世尊。头面礼足。却住一面。佛知而故问。医师比丘。诸病比丘调和不答言。世尊诸病比丘安隐。但我疲苦。佛言。何故疲苦。答言。世尊。波罗奈城去此半由旬。为求所须。日日往返。以是疲苦。又世尊。听病比丘停药一日。病疾已过。佛问医师。比丘欲使畜药几日得安隐耶。答言。世尊。药势相接七日可知。佛言。从今日听先一日。更与六日七日畜

佛告诸比丘。依止波罗奈住者尽集。以十利故。为诸比丘制戒。乃至已闻者当重闻。若病比丘所应服药。酥油蜜石蜜生酥脂。如是病比丘听畜七日服。若过七日残不舍而服者。尼萨耆波夜提。比丘者。如上说。病应服药者。酥油蜜石蜜生酥脂。如上盗戒中说。病者。有四百四病。风病有百一。火病有百一。水病有百一。杂病有百一。若风病者。当用油脂治。热病者当用酥治。水病者。当用蜜治。杂病者当尽用上三种药治。七日者数极。齐七日畜者。自受七日服。过七日服者。尼萨耆波夜提。尼萨耆波夜提者。是药应众僧中舍。波夜提悔过。若不舍而悔。得越比尼罪。波夜提者。如上说。若比丘一日得十种药酥油蜜石蜜生酥五种脂。一切服不作净。过七日。一切尼萨耆。若比丘一日得十种药。半作净半不作净。是中作净者。应法不作净者。过七日。尼萨耆。若比丘一日得十种药。如前长衣戒中广说。但此中以药七日为异。乃至不记识作记识想。此不言作。然灯油涂足油涂身油。不记识不作净。过七日。尼萨耆。不如法作净者。若无心意人边。作净过七日。尼萨耆。应比丘比丘尼。式叉摩尼。沙弥沙弥尼。俗人畜生边作净。畜药利。畜药利相污畜药利。不畜药利相污。不畜药利畜药利。不相污不畜药利。不畜药利不相污。俗人药利污比丘药利。比丘药利污俗人药利。俗人药利污俗人药利。比丘药利污比丘药利。客比丘利污旧比丘利。旧比丘利污客比丘利。客比丘利污客比丘利。旧比丘利污旧比丘利。僧利污比丘利。比丘利污僧利。僧利污僧利。比丘利污比丘利。有食间非受间。有受间非食间。有食间有受间。有非食间非受间。石蜜瓶然灯酪坑脂畜药利畜药利相污者。若比丘食前得石蜜杂食。残不作净食。后更得石蜜复不作净而取畜者。是名畜药利。畜药利相污畜药利。不畜药利相污者。是比丘食前得石蜜杂食啖。不作净食。后更得石蜜作净而受畜。是名畜药利不畜药利相污。不畜药利畜药利不相污者。若比丘食前得石蜜。不杂食作净食。后更得余石蜜不作净而受。是名不畜药利畜药利不相污。不畜药利不畜药利不相污者。若比丘食前得石蜜不杂食。即作净食。后更得石蜜作净而受。是名不畜药利不畜药利不相污。云何俗人利污比丘利。时有优婆塞。来礼比丘足。比丘有第七日石蜜。语优婆塞言。汝欲饮石蜜浆不。答言。欲饮。时优婆塞即持此石蜜去。礼余比丘足。即语余比丘言。尊者。欲饮石蜜浆不。答言。欲饮。是比丘即日得石蜜。不作净而取。是名俗人利污比丘利。云何比丘利污俗人利。有一优婆塞。持石蜜来过礼比丘足。比丘有第七日石蜜。语优婆塞言。欲饮石蜜浆不。答言。欲饮。即取合瓶中而去。更有优婆塞。持石蜜来。于道中相逢。先优婆塞问后优婆塞言。汝欲那去。答言。我欲持此石蜜与某甲。比丘即语言。汝可过持此石蜜去。亦与某甲。比丘即受持去。是名比丘利污俗人利。云何俗人利污俗人利。正以二俱为异。云何比丘利污比丘利。比丘有第七日石蜜。语比丘言。欲饮石蜜浆不。答言。欲饮。是比丘即日得石蜜。不作净而受。是名比丘利污比丘利。云何客比丘利污旧比丘利。客比丘有第七日石蜜。语旧比丘言。汝欲饮石蜜浆不。答言。欲饮。旧比丘即日得石蜜。不作净而受。是名客比丘利污旧比丘利。云何旧比丘利污客比丘利。有客比丘来。旧比丘有第七日石蜜。语客比丘言。欲饮石蜜浆不。答言。欲饮。此客比丘即日受石蜜。不作净而取。是名旧比丘利污客比丘利。云何客比丘利污客比丘利。有二客比丘众来。一众中有第七日石蜜。客比丘语第二众比丘言。欲饮石蜜浆不。答言。欲饮。此一众客比丘即日得石蜜。不作净而受。是名客比丘利污客比丘利。云何旧比丘利污旧比丘利。旧比丘有第七日石蜜。语一旧比丘言。欲饮石蜜浆不。答言。欲饮。此旧比丘即日受石蜜。不作净而受。是名旧比丘利污旧比丘利。云何僧利污比丘利。僧有第七日石蜜。分作分是比丘。即日得石蜜。不作净而受。是名僧利污比丘利。云何比丘利污僧利。比丘有第七日石蜜。即持施僧僧即日得石蜜。不作净而取。是名比丘利污僧利。云何僧利污僧利。僧有第七日石蜜。持与彼僧。彼僧即日得石蜜。不作净而受者。是名僧利污僧利。云何比丘利污比丘利。比丘有第七日石蜜。语比丘言。汝欲饮石蜜浆不。答言。须是比丘即日得石蜜。不作净而受者。是名比丘利污比丘利。云何有食间非受间。若比丘七日啖石蜜。而并受八日复食者。以不作间得越毗尼罪。当作一日间。是名食间非受间。云何受间非食间。若比丘受石蜜七日不食。八日更受石蜜。无间受。得越毗尼罪。当作一日间。是名受间非食间。云何受间食间。若比丘七日受石蜜食。已八日更受更食。得二越比尼罪。云何非受间非食间。若比丘多诵经胸痛吐血。药师言。此病当长服石蜜。食前得食石蜜。食后水净已得食。是名非受间非食间。云何石蜜瓶如武罗国。欲受具足人。在戒场上受具足已。布施僧石蜜。各一瓶。诸比丘。信心喜作功德。即持石蜜瓶施僧上座。上座有信心言僧者是良福田。即复施僧。诸比丘有第七日石蜜。即取此石蜜。是名相污。若比丘食上。大得甘蔗。食残笮作浆得夜分受。若饮不尽。得煎作石蜜七日受。石蜜不尽烧作灰。终身受。若有事不得压。即中前应以水作净。当作是言。此中有净物生。我当受。若食上多得果食不尽。得笮作浆夜分受。若有事不得笮。即时应当作是言。此中净物生我当受。若时过不应作。然灯者。若笃信女人施众僧食。并作饼盛然灯施僧。僧不应合明受。当使净人取。若无净人者。当语使放地。灭灯已然后受。若女人信心故。不欲灭。殷勤故得受。受已持刀去腻。然后得食。是名然灯。酪瓶者。食时得多酪食不尽。得即煎作生酥七日受若生酥长得煎作熟酥七日受。若比丘乞食时多得酥。若是少知识比丘。即以细致[疊*毛]净漉取酥。得七日受。若有事缘不得中前作。当作是言。此中净物生。我当作七日药受。若误忘不受。不作净时过。是名不净。若乞食时得多油如上酥中说。若食上得多胡麻食残不尽得。即笮作油七日受。若事缘不得作。如上酥中说。是名酪瓶。脂者。僧中行鱼脂熊脂。罴脂猪脂。失修摩罗脂。少知识比丘得持细致[疊*毛]漉取。得七日受。若事缘不得作。如上酥中说。若众僧中分油时。或欲持作净油。或作七日油。或作然灯油。或作涂足油。或作涂身油。若分不足还敛着一处者。一切不净。若净油还着净油。一处洗盛令净与净人。如是七日油还着七日油。一处洗盛令净与净人。如是然灯油涂足油得已应受。若比丘欲服灰饮油者。灰是终身药。油是七日药。不得先服灰后服油。当先服油洗手澡口令净已。然后服灰。若比丘下分有病者。应先服酥。酥者七日药。澡手洗口令净。然后乃食。若比丘上分有病者。欲令食上服酥者。酥是七日药。食竟洗口澡手令净。然后服酥。若比丘服油讫。有残油欲作然灯油。若涂足油。和上阿阇梨来。见已嫌多。若更饮者。得越比尼罪。若比丘食石蜜欲饮夜分浆者。当先洗口令净然后饮浆。若饮浆已欲食石蜜。亦如是。若比丘欲煮石蜜。当使净人煮。若比丘自受酥。如酥触酥酥触油。酥触蜜酥触石蜜。酥触生酥酥触脂。如是油蜜石蜜生酥。乃至脂触酥脂。触油脂触蜜脂。触生酥脂。触石蜜脂触脂。亦复如是。时食夜分七日。终身共杂者。得时服。夜分七日终身共杂者。得夜分服。七日终身共合者。得七日服。若少知识比丘乞食时。得赤盐紫盐等。应净洗盐终身受。若得胡椒荜钵。亦复如是。若少知识比丘乞食时。得黑石蜜。得白石蜜净洗除食气。作七日药受。是故说

摩诃僧祇律卷第十摩诃僧祇律卷第十一

        东晋天竺三藏佛陀跋陀罗共法显译

    明三十尼萨耆波夜提法之四

佛住舍卫城。广说如上。尔时长老难陀优波难陀冬盛寒时。着厚纳衣。敷暖床褥。头上着帽脚着富罗。前然炉火。有二外道。黑色碧眼寒颤而来。在前立住。外道见已心生乐着。即语比丘言。汝等出家得如是乐。时外道心乐佛法。便作是言。我等亦名出家。而值弗兰迦叶教。我等裸形拔发投岩赴涧。五热炙身而行乞食。徒受辛苦而无乐事。比丘报言。汝若乐此法者。便来出家。亦复如我得是乐住。外道答言。我无沙门僧伽梨。比丘报言。但来我当与汝。外道即来。便与出家受具足已。语言。我今度汝出家受具足。汝当作如是给事。我晨当早起问讯安眠不。出唾壶器及小便器。着常处净洗手。授澡水齿木。持钵迎粥。小食已洗钵令燥。安着常处。若有请处。当迎食。我欲入聚落时。当持入聚落衣。授我取我常着衣。料理卷叠安着常处。我从聚落还时。汝当敷小床座。与我水并授树叶食时。以扇扇食已洗钵令干。举着常处。脱入聚落衣。卷举复授我。常所著衣。汝食已。当取薪草浣衣煮染。净扫房内。巨磨涂地。我欲入林坐禅时。汝当持坐具随后。还时随还。当与我水洗手。授香花供养讫。当敷床与我洗足水。复以油摩敷置卧具。内唾壶及小便器然灯。如是种种供给。安隐我已然后自事。时彼比丘答师言。此非出家法。便是婢作。师言。汝若不能作者。当还我僧伽梨。彼即脱衣着地而去

复次佛住舍卫城。广说如上。尔时尊者难陀。是优波难陀兄。时优波难陀语兄共行弟子言。我共汝入聚落。当与汝物。我若作非威仪事。汝勿语他人。我是汝叔父。答言。若我见父作非法。亦当向人说。况复叔父优波难陀。复言若汝如此。当使汝知。即将至贵家檀越留食。欲不与彼食。故作是思惟。相望日时。使此不得乞食。还复失时。即便告言。汝还精舍。即便还畏失时故。疾疾看日而行至精舍。见诸比丘。皆悉食已。门前经行。遥见疾行疑必有以。即问汝。今日共多知识比丘处处教化。得何等好食唇腻如是。答言。我今失食。况得好者。优波难陀遣彼还已。于后食种种饮食。食已恐事情露。疾还见诸比丘丛聚而论。便作是思惟。众人集论。必彼比丘向诸梵行人。说我过恶。即语难陀言。长老汝弟子向诸梵行人说我过恶。彼即嗔恚语弟子言。汝今云何说我弟过汝可还我僧伽梨来。诸比丘闻已。共相谓言。此比丘今日遭二苦恼。一者失食。二者失衣。佛闻是已。知而故问诸比丘。此何比丘高声大语。诸比丘白佛言。世尊。此难陀夺共行弟子衣。是故大声。佛言。呼难陀来。来已佛广问难陀。汝实为自供给故。度人与衣。令弟子嗔。不能作婢作。乃至夺共行弟子衣耶。答言。实尔。佛语难陀。汝云何度人出家。不教法律。但令执作供给自己。佛种种因缘呵已。告诸比丘。从今日不得立心为供给自己。故度人出家度者。得越毗尼罪。应作如是念。当使彼人因我度故。修诸善法得成道果。佛告诸比丘。依止舍卫城住者尽集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘与比丘衣后嗔恚不喜。若自夺若使人夺作是言。比丘还我衣来。不与汝。得者尼萨耆波夜提。比丘者。如上说。衣者。七种如上说。嗔恚不喜者。九恼如上说夺者。若自夺若使人夺。作如是言。还我衣来。不与汝。得者尼萨耆波夜提。尼萨耆波夜提者。如上说。或自与使人夺。或使人与自夺。或自与自夺。或使与使夺。合与别夺。别与合夺。合与合夺。别与别夺。合与别夺者。比丘一时与三衣已。别夺言还我僧伽梨。还我郁多罗僧。还我安陀会。如是夺者。得众多波夜提。是名合与别夺。别与合夺者。比丘非一时与僧伽梨。与郁多罗僧。与安陀会。还一时尽夺。汝还我衣来。如是夺者。得一波夜提罪。是名别与合夺。合与合夺者。比丘一时与衣。后言尽还我衣来。如是夺者。得一波夜提。别与别夺者。比丘非一时与僧伽梨。与郁多罗僧。与安陀会。比丘渐夺。还我僧伽梨。还我郁多罗僧。还我安陀会。如是索得者众多波夜提。若比丘与比丘衣时。作是言。汝住我边者。当与汝衣。若不住者夺无罪。若比丘与比丘衣时。作是言。汝此处住者。当与。若不住者。夺无罪。若比丘与比丘衣汝适我意者与。不适意还夺无罪。为受经者与。不受经者还夺。无罪。若比丘卖衣未取直。若钱直未毕。若还取衣者无罪。若比丘与共行弟子依止弟子衣已。不可教诫。为折伏故夺。后折伏已。还与无罪。夺比丘衣者。尼萨耆波夜提。夺比丘尼衣者。偷兰罪。夺式叉摩尼沙弥沙弥尼衣者。越毗尼罪。乃至夺俗人衣者。越毗尼心悔。是故说

佛住舍卫城。四方各十二由旬内。施僧雨浴衣。如毗舍佉鹿母因缘广说。复次佛住憍萨罗国游行时。有一摩诃罗比丘。下着雨衣上着安陀会。捉长柄扫彗扫地。佛见已语诸比丘。汝见是摩诃罗不。云何颠倒着衣。是摩诃罗见佛已。往到佛所。头面礼足却住一面。佛知而故问。摩诃罗。汝下着何衣。答言。雨衣。上着何衣。答言。安陀会。佛言。比丘。汝云何应在上衣而反在下。下衣在上。汝今云何一切时受用雨衣。佛语诸比丘。汝等待如来从憍萨罗国游行还舍卫城时。汝当语我。当为诸比丘制雨浴衣。佛憍萨罗国游行还已。诸比丘白佛言。世尊。在憍萨罗国游行时。作是言。如来从憍萨罗国游行还舍卫时。汝便语我。当为诸比丘制雨浴衣。今正是时。愿制雨衣。佛告诸比丘。依止舍卫城住者尽集。以十利故。为诸比丘制戒。乃至已闻者当重闻。若比丘春残一月在。比丘当求雨衣。半月当作成受用。若比丘未至春残一月求雨衣。半月作成受用者。尼萨耆波夜提。春残一月者。三月后十五日四月初十五日。是名春残一月。雨衣者。如世尊所听。衣者。有十种。如上说。求者乞索劝化。求时不应从小家处处求。一尺二尺应从殷。有大家中求。若一人边。若众多人边得。是名求残半月者。从三月十六日。应作浣染。缝至四月一日。应受用。若比丘未至求者。未至三月十六日前。求作成。受用者。尼萨耆波夜提。尼萨耆波夜提者。如上说。比丘有五法成就僧应羯磨。作分雨衣人。何等五。不随爱不随嗔不随怖不随痴得不得知。是名五羯磨人。应作是说。大德僧听。某甲比丘五法成就。若僧时到。僧拜某甲比丘作分雨衣人。白如是。大德僧听。某甲比丘。五法成就。僧今拜某甲比丘。作分雨衣人。诸大德忍。某甲比丘作分雨衣人。忍者僧默然。若不忍便说。僧已忍。拜某甲比丘作分雨衣人竟。僧忍默然故。是事如是持。作羯磨已。应众中唱言。大德僧听。若衣有大小。降四指八指不等不计者。我当分。若不唱者。得越毗尼罪。此人作羯磨已。当为僧求。求时不应从小家处处求。一尺二尺应从殷。有大家中。若一人边得。若众多人边得。下至。得一雨衣是名求。若三月十六日已后。送衣来者。应分应语。僧上座言。为欲今取为欲待后后。或有胜者上座。若言今取便与。若言后取待后应与。若有客比丘者。应问汝欲何处夏安居。若言此处应与。若言我欲余处安居。欲此处取雨衣者。亦应与。语言。汝于余处更莫取。若言我不此间取。待安居处当取。随其意。若多得雨衣者。一人应与两沙弥。应与一。若少不周接者。安居讫分衣时。应偏与雨衣直。此衣不得受。当三衣不得作净。施不得着雨衣。入河中池中浴。不得小小雨时着。浴亦不得裸身。浴当着舍勒。若余故衣。不得着雨衣种种作事。当须大雨时被浴。若雨卒止垢液者。得着入余水中浴无罪。若比丘食时。欲以油涂身。若病时若多人行处得系两头作障。此雨浴衣得四月半受用。至八月十五日。应当舍。舍法者。一比丘应众中作是唱。大德僧听。今日僧舍雨浴衣。如是三说。若至十六日舍者。得越毗尼罪。舍已得用作三衣。亦得知识比丘边作净。亦得入余水中浴。种种著作无罪。是故说

佛住舍卫城。广说如上。尔时尊者难陀优波难陀持缕入居士家。语优婆夷言。施我缕。诸居士妇女作是念。此比丘欲买缕。各持缕出。比丘见已。即取比已缕而作是言。我正欲求此缕比。今得相似。若见好者。便作是言。我欲求此比而更得胜者。若见粗者便作是言。此缕虽粗可作好者。因如是赍缕来者都无。得脱重担而来。去祇洹精舍不远。有一穷巷。在中起织坊度织师出家。使织衣。尊者阿难到时。着入聚落衣。持钵次行乞食。到其门前。见难陀优波难陀。捉线丸共张[疊*毛]经。见已共相问讯。阿难问言。长老作何等。答言。欲织衣。彼即念言。我今日见侍者阿难。必语世尊。当作方便。即持线丸与尊者阿难。可持缝衣阿难不取。食后以上因缘。广白世尊。佛言。呼难陀优波难陀来。来已佛问优波难陀。如上事。乃至阿难不受。汝线汝实尔不。答言。实尔。佛言。此是恶事。汝不闻。我无数方便赞叹少欲毁呰多欲。此非法非律。不如佛教。不可以是长养善法。佛告诸比丘。依止舍卫城住者尽集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘自行乞缕。使织师织作衣者。尼萨耆波夜提。比丘者。如上说。自乞者。劝化索。或一两二两缕者。七种缕织师者。今毗提波昼俱利织师。织作衣者。尼萨耆波夜提。尼萨耆波夜提者。如上说。若比丘自行乞缕。越毗尼心悔。得者。越毗尼罪。织成者。尼萨耆波夜提。迦尸国土法比丘安居竟。与缕与织直。比丘欲织[疊*毛]时。应语织师。作是言。与汝此缕为我知织[疊*毛]。织师答言。尊者。我不解此语。应问言。汝家作何等业。答言。织[疊*毛]。便语言。汝可为我知织[疊*毛]。若复不解此语者。应持线与净人。令知织一切不得作雇织语。若比丘知织腰带。欲使比丘织者。应持线与。作是言。长老。为我作带。是故说。佛住舍卫城祇洹精舍。尔时毗舍佉鹿母常日日众僧中请食时。有比丘次到其家食见。毗舍佉鹿母持缕与织师语。言汝。为我织[疊*毛]。欲施尊者难陀优波难陀。彼人难可。汝当为好织。比丘食已。还精舍。语难陀言。长老。我欲语汝好事。问言。有何好事。答言。我见毗舍佉鹿母。欲施汝衣。答言。此不施我衣。何以故。此优婆夷当施贤圣。复言不尔。我眼见毗佉舍鹿母。以缕与织师作是言。与汝此缕。为我好织作[疊*毛]。欲施难陀。彼人难可。问言。汝知织师家处不。答言。知处。即复问言。彼家在何处何巷陌。门户那向。示我标相。具问知处已。明日着入聚落衣。往到其家。见织师张经。见已问织师言。长寿。为谁张经。答言。我为鹿母毗舍佉张经。复问言。汝知不。此为谁作。答言。我知为难陀优波难陀。复问。汝识难陀不。答言。我不识。即便语言。难陀优波难陀正我等是。汝当好作长广细致织。织师答言。缕自有限量。亦已定。我能无纬织耶。即复言。汝但如我语好作。彼家大富。自当更与汝缕。织师复言。彼家与我缕作直。谁当与我。即言。汝但好织织作直。我当与汝。织师言。若尊者与我织作直。彼复足我缕者。当如教织。织师即为好织。缕尽复往索。如是三索。毗舍佉鹿母念言。此人但来索缕不求作直。我何以不足与缕。与缕织成。广长细好。送与鹿母。鹿母取已作是言。此是好[疊*毛]不应与彼。是重供养。虽然本为其作。即便送与难陀。[疊*毛]未成时。日日到织师家。既得[疊*毛]已远离其舍异巷而行。譬如老乌远离射方。织师作务多不得来索作直。后织师营署率会来到舍卫城。织师尔时便作是念。众人未集。我今可往索织直。故往祇洹到已。问诸比丘。难陀优波难陀在何处住。比丘语言。是处房中。即入房中见已礼足问讯。彼佯不识。如未曾相见。即问言。尊者得[疊*毛]未反。问言。何等[疊*毛]。答言。我为鹿母织者。答言得。问言。[疊*毛]为称尊者意不。答言。为复可耳。便言。阿阇梨当与我织价。问言。何等织价。答言。乃至优婆夷足缕许与我织作直。彼即嗔恚言如是如是。子赐谷物。汝识难陀优波难陀不。欲拔汝眼睫取虚空中烟。我欲五指撮取净。洗釜已欲望故。得多食。裸形外道犹欲剥取两张[疊*毛]。于死老乌足上望剥取五百两肉。以一把糠散恒水漩渊中。欲收敛取如是等处求物。况复汝望得我物。即语弟子言。汝取我僧伽梨来。我欲着诣王家呼人来缚取。此人付官织师。作是念。此沙门有大身力。又出入王家。必能为我作不饶益事。用是作直。为但得活命去。怖畏却行。出户走到率会人中。彼众人嫌言。我等各各废家事。到此间共料理官事。汝今云何妨废众人。彼即答言。汝听鹿母与我缕织[疊*毛]。难陀优波难陀。乃至[疊*毛]未成时。日日来得[疊*毛]已。犹如老乌远于射方。乃至思惟。但得活命。广说上事。是故来晚耳。众人即嗔恚言。此比丘轻易我等。不与作直。而反欲使王力缚人。我等今日当作制限。后更不复为沙门织[疊*毛]。有人言。我等当在隐处共作制限。莫使人知。我知沙门衣量。长五肘广三肘。长五肘广二肘。如是衣量不得织。若彼人知者。此沙门有力。能使王家以力使人。乃至能为人作不饶益事。莫使人知。到受岁时。众人担缕来诣织师所。欲雇织师织。织师问言。汝欲作何等量衣。答言。长五肘广三肘。长五肘广二肘。织师念言。此是沙门衣量。即答言。我已为人织不复得作。如是遍问。都无织者。尔时诸富贵家即取家中成织[疊*毛]施僧。诸贫人等先无成织者无衣施僧。尔时僧得布施衣少。佛知而故问。阿难。僧何以得布施衣少。阿难即以上事。乃至织师发不喜心。共作要命。具白世尊。佛言。呼难陀来。来已佛具问难陀优波难陀。汝等实尔不。答言。实尔世尊。佛言。此是恶事。汝常不闻我赞叹少欲毁呰多欲耶

佛告诸比丘。依止舍卫城者。皆悉令集。以十利故与诸比丘制戒。乃至已闻者当重闻。若居士居士妇使织师。为比丘织作衣。是比丘先不请。便往劝织师言。汝知不。此衣为我作。汝当好织。令致长广。当与汝钱。钱直食食直。是比丘如是劝与钱。钱直食食直。得衣者。尼萨耆波夜提。居士者家主。妇者。家主妇。为比丘者。若僧若众多人。若一人。织师者。如上说。衣者。十种如上说。先不请者。本不请谓请想。请余人谓己想。请与余物谓衣想。便往者。往田中家中。劝者。语令细致。若长广钱者。种种钱。钱直者。余物食者。糗饭麦饭鱼肉食。直者。钱物得衣者。尼萨耆波夜提。尼萨耆波夜提者。如上说。若比丘语织师言。与我好织坚织致打。作是语时。越毗尼罪。织师下手打织时下下。波夜提。作成得者。尼萨耆波夜提。若比丘与织师说法。织师手支颐住听。比丘语织师言。此应耳听。不应手听。手可并作。作是语时。得越毗尼罪。若比丘闻为作衣往劝不许价得衣。越比尼罪。闻而往劝。亦许直得衣者。尼萨耆波夜提。不闻而往劝自与得衣者。越毗尼罪。不闻不劝亦不与直得衣者无罪。若寡妇施众僧衣。比丘若僧中次第应得此衣。妇人语比丘言。我家无人。尊者可到织师所经营。此衣尊者若自能往料理者。可得疾成。亦可得好。比丘尔时得往织师所。作如是言。长寿。汝知疾织知致织。作是语者无罪。是故说

佛住舍卫城。广说如上。时六群比丘在一聚落夏安居。初安居时。晨朝着入聚落衣。捉纸笔入聚落中。语诸优婆塞言。汝等和义与我夏安居衣诸优婆塞言。非索安居衣时。待至秋谷熟。尔时诸人多有欢欣心。当施衣。六群比丘言。汝不知世间多有诸难。若王水火盗贼难。或为汝父母所遮。不得布施。汝便不成功德。我则失利。优婆塞言。尊者。但示我诸难。而自不见诸难。尊者得安居钱已。欲罢道欲余行去耶。何以多欲贪求。如是何道之有。诸比丘闻已。即以上事具白世尊。佛言。呼六群比丘来。来已佛问六群比丘。汝实初安居时。从诸优婆塞索安居衣。为诸优婆塞呵责耶。答言。实尔。佛告比丘。此是恶事。安居未讫。而先求衣。从今日安居未讫。不得先求安居衣

复次佛住舍卫城。尔时波斯匿王大臣名弥尼刹利。叛逆。王遣一大臣名仙人达多。往讨伐之。此大臣临欲行时。往到尊者阿难所。白言尊者。波斯匿王大臣叛逆。王今遣我往伐。方向强敌身命难保。我常年年安居竟。饭僧施衣。我今为官所使不得待。时欲先施衣得安隐。还者后当施食。尊者阿难。即以上事具白世尊。佛知而故问阿难。汝安居余有几日在。答言十日。佛言。从今日听。未到自恣十日得受急施衣。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若十日未满夏三月得急施衣。比丘须者得自手取。畜至衣时。若过时畜者。尼萨耆波夜提。十日者从七月六日至七月十五日。是名十日。得急施衣者。若女若男若大若小。若在家出家。若欲军征行时与。征还时与。死时与。女人还归时与。商人去时与。施主语比丘言。若今日不取明日无。是名急施衣。衣者。七种如上说。欲取者。若须此物应取畜至衣时衣时者。若无迦絺那衣。得至八月十五日有迦絺那衣。得至腊月十五日若过时畜者。尼萨耆波夜提。尼萨耆波夜提者。如上说比丘者。有五法成就。僧应拜作劝化分衣人。何等五。不随爱不随嗔不随怖不随痴得不得知。是名五法。作羯磨法者应作是说。大德僧听。某甲比丘五法成就。若僧时到。僧拜某甲比丘。作劝化分衣人。白如是。大德僧听。某甲比丘五法成就。僧今拜某甲比丘。为劝化分衣人。诸大德忍。某甲比丘。为僧作劝化分衣人者僧默然。若不忍便说。僧已忍拜某甲比丘作劝化分衣人竟。僧忍默然故。是事如是持。受羯磨已。应白僧作是言。诸大德。衣相降四指八指不等。若通此者。我当分。若不白而分。越毗尼罪如上。白已当分。是比丘从三月十六日。应语诸檀越。捉纸笔条房舍。讲堂温室。禅坊门屋。食厨净水屋。厕屋薪屋浴室。树下坐处。经行处。尽疏名。应僧中唱。大德僧听。某甲住处有尔许床褥。尔许安居衣。尔许食。尔许斋日饮食。尔许咒愿物。某住处有尔许阿练若住处。若左右诸精舍远者十二日十三日。时应分房舍。若是住处不相容受者。得余处去。若近聚落中有精舍者。十四日十五日。当分条疏。此房舍床褥与上座。当白僧某甲住处。有尔许房舍床褥。与上座随意取。取已次与第二第三。乃至无岁比丘。上座应作是言。房舍次第住布施物。应平等与。尔时应随上座处分。上座取已。应次第与第二第三。亦如是。乃至无岁比丘。若房多者应一人与二房。与二房时。若不肯取者。应语言。此为治事故与。不为受用故与。不得与沙弥二房。若房舍少者。二人共房。如是房犹不足者。当三人共。若四人共。五人乃至十人共。与一房。若有大堂若温室。若禅坊若讲堂。一切共入中。若不受者。上座与卧床。年少与坐床。若复不受者。上座与坐床。年少敷地床。若复不受者。与上座草褥。年少结跏趺坐。若复不受诸。上座应坐。年少应立住若复不受者。上座当立。年少出去。若树下若余处。是比丘六月十六日已后。应当语诸檀越。长寿。各各办衣。尔时檀越若与者。应语言。且着汝边。须待时与。若欲军征去与。若征还与。若死时与。商人去时与。女人归家时与。若今日不取明日无。尔时应取。七月五日已后有此衣来取着一处。若树叶树皮当取数记。尔许时衣。尔许非时衣。尔许急施衣。时衣时分非时衣。非时分急施衣。时分若分衣人。若罢道若死不得分衣。若时过应如是贸衣分。比丘尼衣应与比丘。比丘衣应与比丘尼。若如是不得者。沙弥衣应与比丘。比丘衣应与沙弥。若复不得者。应众僧中白言。诸大德。衣时已过众僧和合。作四方僧卧具。若听者得作四方僧卧具。若有人言。我等夏安居住。得此衣分。何以作四方僧用。应语此人。待来年衣时。当与汝。是故说

佛住舍卫城尔时诸比丘阿练若处。夏安居。诸比丘时到入聚落乞食后。放牛羊人。取薪草人。持户钩来开诸比丘房户。偷衣物。时诸比丘畏偷故。尽持衣物入聚落。佛知而故问。此何等比丘运致来此。诸比丘白佛言。世尊。是诸比丘在阿练若处安居乞食去。后有人持户钩。于后开户。偷诸衣物。是以运致来此。佛言。从今日后恐畏时听三衣中。若一一衣。得寄着聚落内。复次佛住舍卫城祇洹精舍沙只国。夏安居中众僧有诤事起。如法灭。佛语优波离。汝往沙只国与。众僧如法灭此诤事。时长老优波离辞不去。佛问优波离。汝何以不去。答言。世尊。我僧伽梨重。若被雨者不可胜。而今半安居中。若留衣者。尼萨耆。佛问优波离。汝几日可得往还。优波离白佛言。世尊。计去二日停二日来二日。都计六宿。可得往返。佛言。从今日后留衣得齐六宿。优波离到彼已。见此诤事。难可卒灭。即便来还。还已礼世尊足。却住一面。佛知而故问。优波离。汝来还何故速。僧中诤事竟得灭不。答言。未灭。世尊。佛言。何以故。答言。诤事难灭非可卒断。复畏日过失衣。犯尼萨耆。是故来还。佛言。从今日听一月不失衣宿。作羯磨。僧应与。求听作一月不失衣宿羯磨。羯磨者。应作是说大德僧听。长老优波离。今向沙只国。为僧灭诤事。若僧时到优波离。欲从僧乞一月不失衣宿羯磨。诸大德听。优波离。欲从僧乞一月不失衣宿羯磨。僧忍默然故。是事如是持。应从僧中乞。作是言。大德僧听。我优波离比丘。欲向沙只国为僧灭诤事。唯愿大德僧。与我一月不失衣宿羯磨。如是第二第三乞。羯磨人当作是说。大德僧听。长老优波离。欲往沙只国为僧灭诤事已。从僧中乞一月不失衣宿羯磨。若僧时到。僧与优波离一月不失衣宿羯磨。白如是。大德僧听。长老优波离。欲向沙只国为僧灭诤事已。从僧乞一月不失衣宿。僧今已与长老优波离一月不失衣宿羯磨。诸大德忍。与优波离一月不失衣宿羯磨者。默然。若不忍便说。是初羯磨第二第三亦如是说。僧已与优波离一月不失衣宿竟。僧忍默然故。是事如是持。佛问诸比丘已。与优波离一月不失衣宿羯磨未。答言已与。佛告诸比丘。依止舍卫城住者尽集。以十利故。与诸比丘制戒。乃至已闻者当重闻。夏三月未满。比丘在阿练若处住。有恐怖疑。比丘三衣中若一一衣得寄着家内。比丘有因缘事。得齐六宿。若过者除僧羯磨。尼萨耆波夜提。安居三月者。从四月十六日至七月十五日。未满者未至八月十五日。比丘未至末月中。在阿练若处住。阿练若处者。长五肘弓五百弓中间无有放牧人屋。是名阿练若处。恐怖者。若杀劫夺。疑者。虽无杀劫夺有疑心畏须臾间当杀人夺人衣。若比丘知如是恐怖处。三衣中若一一衣者僧伽梨郁多罗僧安陀会不得寄僧伽梨安陀会得寄郁多罗僧着聚落中家。内者。俗人家不得寄。可信人家当还寄。可疑家疑家。作是念。诸比丘等皆不可复得皆悉防备。诸比丘等若有因缘。为塔为僧事得齐六夜。六夜者。限齐六宿除僧羯磨者世尊说无。罪若僧羯磨不成就。不名羯磨羯磨不成就者。众不成就。白不成就。羯磨不成就。若白成就。羯磨成就。众成就是名僧作羯磨。若僧中受羯磨已。不得为待供养故住。应当疾去。若食前作羯磨。食后应去。食后受羯磨者。明日晨朝应去。去时不得回道逐檀越。当直道去若直道有难者。若师子难。虎狼难。毒虫难。失命难。尔时回道去无罪。到彼已不得停待供养。客比丘饮食。若食前到。食后便集僧灭诤事。若食后到清旦便集僧灭诤事若食后断事讫。便清旦还。若食前断事讫。食后便还。不得住待客比丘供养。还时不得从回道来。当从直道还。若有难者。如上说。初往到彼时不得诵经熏钵染衣。若断事讫。有长功夫得诵经作余事。若事难断者。中间得诵经熏钵。亦得受。客比丘供养饮食无罪。灭诤事时不得辄尔取人。当于众中若堪能。有威德力势者。若阿练若住处寄衣。得着家内。六夜若过六夜者。尼萨耆波夜提。是比丘欲舍衣法。当请持律。如上第一戒中说。是故说。佛在舍卫城。有一乞食比丘。时到着入聚落衣。持钵入城。次行乞食。到一家。有一女人。语比丘言。尊者某日我当供养僧并。施僧衣。比丘言。善哉姊妹。以三不坚法。易三坚法身命财也。应疾为之。财物无常多有诸难。作是语已。便还精舍。语诸比丘言。我欲语汝好事。诸比丘言。有何等好事。答言。我闻某甲优婆夷欲供僧饭食布施僧衣。时六群比丘闻此语已。更问言。汝说何等。答言。我闻某甲优婆夷欲供僧饭食并布施衣。问言。汝知其家处不为在何巷。门户那向。具问已。晨朝着入聚落衣。往到其家见已。问言。长寿安隐不。答言安隐语优婆夷言。我闻汝欲供僧饭食布施僧衣。为实尔不。答言。尊者。我有是心。但恐中间多有难事。知得成不即语言。如我先出家长宿比丘。汝若施衣者。我当着入王家。礼敬世尊。若贵胜家。若人问我汝何处得。我当答某信心优婆夷边得。如是汝得好名称。为众所识。优婆夷言我家更无有物。我正欲与僧者。若与阿阇梨。我已许僧我若有者亦当别与。阿阇梨亦与僧。比丘言。与以不与自从汝意。作是语已。便出去。去已优婆夷作是思惟。我若当与是比丘。不与僧者。僧是良福田。若不与是比丘者。是比丘于王边有力。能为我作不饶益事。以是故不与。僧嗔比丘故。亦复不与。诸比丘闻已。以是事往白世尊。佛言。呼难陀优波难陀来来已佛广问上事。汝实尔不。答言。实尔。佛言。此是恶事。有二不可。令施者失福受者失衣。佛语难陀优波难陀。汝常不闻我以无数方便赞叹少欲毁呰多欲。此非法非律非如佛教。不可以是长养善法。佛告诸比丘。依止舍卫城住者。皆悉令集以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘知物向僧。自回向已。尼萨耆波夜提。比丘者。如上说。知者。若自知若从他闻。物者。八种物。时分夜分七日终身。随物重物不净物。净物净不净物。向者意趣选物向僧。僧者八种比丘僧。比丘尼僧。客僧。去僧。旧住僧。安居僧。和合僧不和合僧自向者。自畜自用自入。尼萨耆波夜提此物应僧中舍波夜提。罪应悔过。若不舍而悔者。得越毗尼罪。波夜提者。如上说。若有人来欲有布施问比丘言。尊者我欲布施应施何处耶。比丘应答言随汝心所敬处便与。施主复问。何处果报多。答言。施僧果报多。施主复言。何等清净持戒。有功德僧。比丘应答言。僧无有犯戒不清净。若人持物来施。比丘应语言。施僧者得大果报。若言我已曾施僧。今正欲施尊者。比丘受者无罪。若人问比丘言。我欲以此物布施。为置何处。使我此物长见受用。尔时应语。某甲比丘是坐禅诵经持戒。若施彼者长见受用。若知物向僧回向已。尼萨耆波夜提。回与余人波夜提。知物向此僧回与余僧者。越毗尼罪。知向此众多人回与彼众多人。越毗尼罪。知物向此畜生回与余畜生。越毗尼心悔。知物向僧自回向己者。尼萨耆波夜提。是物众僧应不与。众僧应受用。是故说。(三十事竟)

摩诃僧祇律卷第十一摩诃僧祇律卷第十二

        东晋天竺三藏佛陀跋陀罗共法显译

    明单提九十二事法之一

佛住舍卫城。广说如上。尔时众僧集在一处。欲作羯磨。长老尸利耶婆不来。即遣使往呼言。长老众僧集。欲作法事。尸利耶婆念言。正当为我故作羯磨耳。即心生畏怖不得止而来。来已诸比丘问言。长老。汝犯僧伽婆尸沙耶。答言犯。彼心生欢喜。作是念。诸梵行。人于我边举可忏悔事。非不可治事。白众僧言。听我小出。诸比丘于后作是言。此比丘多端不定出去已。须臾当作妄语。应三过定实问之。是尸利耶婆出已。作是念。我何故无事而受是罪。此诸比丘恒数数治我罪。我今不应受是罪。今宁妄语众僧。当治我妄语罪。虽治故轻诸比丘。即呼尸利耶婆入。入已问言。汝犯僧伽婆尸沙罪耶。答言。不犯。诸比丘问言。汝向者何故言犯。答言。众僧向者欲使我犯。是故我答言。犯耳。我今不忆有罪。诸比丘以是因缘。具白世尊。佛言。呼尸利耶婆来。来已具问上事。汝实尔不。答言。实尔世尊。佛言。此是恶事。汝常不闻。我无量方便呵责妄语称叹实语耶。汝今云何知而妄语。此非法非律。非如佛教。不可以是长养善法。佛告诸比丘。依止舍卫城比丘尽集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘知而妄语。波夜提。比丘者。如上说。知者。先念知妄者。事不尔语者。口业说。波夜提者。分别制罪名也。贤圣语八事直说妄不妄疑不疑。决定非决定。一向说贤圣语八事者。见言见闻言闻。妄言妄识言识。不见言不见。不闻言不闻。不妄言不妄。不识言不识。是名八事贤圣语。无罪。八事非贤圣语者。见言不见。闻言不闻。妄言不妄。识言不识。不见言见。不闻言闻。不妄言妄。不识言识。是名八事非贤圣语。得波夜提罪。直说者。见闻知识。不见不闻。不知不识。是名直说。得波夜提罪。妄者见妄言不妄。闻妄言不妄。知妄言不妄。识妄言不妄。不见不闻。不知不识。妄言不妄。得波夜提罪。不妄者。见闻知识不妄言妄。不见不闻不知不识。不妄言妄。得波夜提罪。疑者。见闻知识。疑言不疑。不见不闻不知不识。疑言不疑。得波夜提罪。不疑者。见闻知识不疑言疑。不见不闻不知不识。不疑言疑。得波夜提罪。决定者。见闻知识决定言不决定不见不闻不知不识。决定言不决定。得波夜提罪。不决定者。见闻知识不决定言决定。不见不闻不知不识。不决定言决定。得波夜提罪。一向说者。见闻知识。言不见不闻不知不识。得波夜提罪。知有而言无。知而妄语。得波夜提罪。知无言有知而妄语。得波夜提罪。实有谓无而言有知而妄语。得波夜提罪。实无谓有而言无知而妄语。得波夜提罪。实有有想而言。无知而妄语。得波夜提罪。实无无想而言。有知而妄语。得波夜提罪。实有无想而言。有知而妄语。得波夜提罪。实无有想而言。无知而妄语。得波夜提罪。有五法成就知而妄语。得波夜提罪。何等五。实有有想转心背想异口说。是为五事。知而妄语。波夜提。有四法成就。知而妄语。波夜提。何等四。有想转心背想异口说。是为四。知而妄语。波夜提。有三法成就。知而妄语。波夜提。何等三。转心背想异口说。知而妄语。波夜提。有二法成就。知而妄语。波夜提。何等二。背想异口说知而妄语。波夜提。有一法成就。知而妄语。波夜提。何等一。异口语知而妄语。波夜提。是故说

佛住舍卫城。广说如上。尔时六群比丘软语诱问诸年少比丘言。汝名字何等。汝家姓何等。父母名字何等。汝家本作何生业。年少比丘其性质直。以实而答。我家如是。如是姓名。如是生业。彼六群比丘于后嫌恨时。便作是言。汝是极下贱种。汝是旃陀罗。剃发师织师。瓦师皮师。年少比丘闻此语已。极怀惭羞。诸比丘闻已。往白世尊。佛言。呼六群比丘来。来已佛问六群比丘。汝实软语诱问诸年少比丘。后嫌恨便说。乃至瓦师皮师耶。答言。实尔。佛言。此是恶事。六群比丘汝云何。于梵行人边作种类形相语。如难提本生经中广说。乃至佛告诸比丘。畜生尚恶毁呰。况复人乎。佛告诸比丘。依止舍卫城住者。尽集以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘种类形相语。波夜提。比丘者。如上说。种类毁呰有七事。种姓业相貌病罪骂结使。种姓者。下中上。下者汝是旃陀罗。剃毛师织师瓦师皮师种姓。若作此语。使彼惭羞。得波夜提罪。若言汝父母。是旃陀罗。乃至皮师。作是语使彼惭羞。波夜提。若言汝和上阿阇梨是旃陀罗。乃至皮师。使彼惭羞。得偷兰遮。若言汝同友知识。是旃陀罗。乃至皮师。作是语。使彼惭羞。越毗尼罪。是名下。中者言。汝等是中间种姓。作是语。欲使彼人惭羞者。得偷兰罪。若言汝父母是中间种姓。得偷兰罪。若言汝和上阿阇梨。是中间种姓。欲使彼惭羞者。越毗尼罪。若言汝同友知识。是中间种姓。欲使彼惭羞者。得越毗尼心悔。是名中间。上者。语其人言。汝是刹利婆罗门种。作是语。欲使彼惭羞者。越毗尼罪。若言汝父母是刹利婆罗门种。作是语。欲使彼惭羞者。得越毗尼罪。若言汝和上阿阇梨是刹利婆罗门种。作是语。欲使彼惭羞者。得越毗尼罪。若言汝同友知识是刹利婆罗门种。欲使彼惭羞者。得越毗尼心悔。是名种姓。业者下中上。下者若言汝是屠儿卖猪人渔猎人。捕鸟人张弶人。守城人魁脍人。作是语。欲使彼人惭羞者。得波夜提罪。父母亦如是。若言汝和上阿阇梨是屠儿乃至魁脍。得偷兰罪。若言汝同友知识是屠儿乃至魁脍。得越毗尼罪。是名下业。中者。言汝是卖香人坐店肆人。田作人种菜人。汝是通使人。作是语。欲使彼惭羞者。得偷兰罪。父母亦如是。若言汝和上阿阇梨者。得越毗尼罪。若言汝同友知识欲使彼惭羞者。得越毗尼心悔。是名中业。上业者。若言汝是居金。银摩尼铜器。店肆人。作是语。欲令彼人惭羞者。得越毗尼罪。父母和上阿阇梨亦如是。若言同友知识。得越毗尼心悔是名上业。相貌者。下中上。下者。若言汝是瞎眼曲脊跛脚臂。如鸟翅榼头锯齿。作是语。使彼惭羞者。得波夜提罪。父母亦尔。和上阿阇梨偷兰罪。同友知识。越毗尼罪。是名下相貌。中者。如是大黑大白大黄大赤。作是语。使彼惭羞者。得偷兰罪。父母亦尔。和上阿阇梨。得越毗尼罪。同友知识得越毗尼心悔。是名中相貌。上者。言汝有三十二相圆光金色。作是语。欲使彼惭羞者。得越毗尼罪父母和上阿阇梨亦尔。同友知识。得越毗尼心悔。是名上相貌。病者。无有下中上。一切病尽名下。汝等癣疥黄烂。癞病痈疽。痔病不禁。黄病疟病。痟羸病癫狂。如是等种种病。作是语。欲使彼惭羞者。得波夜提罪。父母亦尔。和上阿阇梨。得偷兰罪。同友知识。越毗尼罪。是名病。罪者无上中下。一切罪尽名下。汝犯波罗夷。僧伽婆尸沙波夜提。波罗提提舍尼。越毗尼罪。作是语。使彼惭羞者。波夜提。父母亦尔。和上阿阇梨偷兰罪同友知识。越毗尼。是名罪。骂者。无有下中上。一切骂尽名下。作世间骂淫逸污秽一切恶骂。作是语。欲使彼惭羞者。得波夜提。父母亦尔。和上阿阇梨偷兰罪。同友知识。得越毗尼罪。是名骂结。使者。无下中上。一切结使尽名下。汝是愚痴闇钝无知人。犹如泥团。如羊白鹄角鸱作。如是种种语。使彼惭羞者。得波夜提。父母亦尔。和上阿阇梨。偷兰罪。同友知识。得越毗尼罪。若比丘作如上七事种类毁呰者。得波夜提。种类毁呰比丘尼者。偷兰罪。式叉摩尼。沙弥沙弥尼。得越毗尼罪。种类俗人。得越毗尼心悔。是故说

佛住舍卫城。广说如上。时六群比丘方便诱问诸年少比丘。汝识某甲比丘父母种姓事业不。彼年少比丘其性质直。随事而说。六群比丘于后嗔恚时。作是言。汝是旃陀罗。剃发师织师瓦师皮师种姓。作是语已。复言。我自不知是某甲比丘说汝耳。比丘闻是语已。极生惭羞。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。来已佛问六群比丘。汝实诱问诸年少比丘。乃至比丘惭羞不。答言。实尔世尊。佛言。汝何故如是耶。答言。我作是事。用以快乐。佛言。痴人。此是恶事。于梵行人边作两舌。此是苦事。方言为乐。佛无数方便呵责已。为说因缘。如三兽本生经中广说。佛告诸比丘。依止舍卫城者尽集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘两舌者。波夜提。比丘者。如上说。两舌者。有七事。何等七种。姓业相貌病罪骂结使。种姓者。下中上。下者。汝是旃陀罗。乃至皮师。复言。谁知汝是某甲。说作是念。欲离彼令与己合。若彼离不离。得波夜提。若言汝父母是旃陀罗。乃至皮师。复言。谁知汝是某甲。比丘说作是念。欲别离彼令与己合。若彼离不离。皆波夜提。若言汝和上阿阇梨是旃陀罗。乃至皮师。亦波夜提。同友知识。亦如是是名下。中者。言长老汝是中间姓。吏兵姓伎儿姓。复言。我不知汝是某甲说耳。若作是念。欲离彼令与己合。若离不离。皆波夜提。若父母和上阿阇梨同友知识。皆波夜提。是名中。上者。若言长老汝是刹利婆罗门种。复言我不知汝是某甲说。若作是念。欲别离彼令向己。若彼离不离。波夜提。若言汝父母和上阿阇梨同友知识。皆波夜提。是名上。是谓种姓。业者。下中上。下者。汝是屠儿乃至魁脍。复言。我不知汝是某甲说耳。若作是念。欲别离彼令向己。彼若离不离。皆波夜提。若父母和上阿阇梨同友知识。皆波夜提。是名下。中者。汝是卖香肆上人。乃至通使人。复言。我不知汝是某甲说耳。若作是念。欲别离彼令向己。若离不离。皆波夜提。若父母和上阿阇梨同友知识。皆波夜提。是名中。上者。汝是金银肆乃至铜肆上人。复言。我不知汝是某甲说耳。若作是念。欲别离彼令向己。彼若离不离。波夜提。若父母和上阿阇梨同友知识。皆波夜提。是名上。是谓业。相貌者。下中上。下者。若言汝瞎眼乃至锯齿。复言。我不知汝是某甲说耳。若作是念。欲别离彼令向己。彼若离不离。波夜提。若父母和上阿阇梨同友知识。皆波夜提。是名下。中者。若言汝大黑大白大黄大赤。复言。我不知汝是某甲说耳。若作是念。欲别离彼令向己。若彼离不离。波夜提。父母和上阿阇梨同友知识。皆波夜提。是名中。上者。若言汝有三十二相圆光金色。复言。我不知汝是某甲说耳。若作是念。欲别离彼令向己。若彼离不离。波夜提。父母和上阿阇梨同友知识。皆波夜提。是名上。病者。无下中上。一切病皆名下。若言汝有癣疥乃至癫狂。复言。我不知汝是某甲说耳。若作是念。欲别离彼令向己。若彼离不离。波夜提。若父母和上阿阇梨同友知识。皆波夜提。是名病。罪者。无有下中上。一切罪皆名下。若言汝犯波罗夷。乃至越毗尼罪。复言。我不知汝是某甲说耳。作是念。欲别离彼令与己合。若彼离不离。波夜提。若父母和上阿阇梨同友知识。皆波夜提。骂者。无下中上。一切骂皆名下。作世间恶骂淫秽丑恶语。若作如是骂。乃至离不离。波夜提。若言汝父母和上阿阇梨同友知识。皆波夜提。是名骂。结使者。无有下中上。一切结使皆名下。汝是愚痴人。闇钝无知。犹如泥聚。亦如牛羊白鹄角鸱。作如是种种语。复言。我不知汝是某甲说耳。若作是念。欲别离彼令向己。若彼离不离。波夜提。若父母和上阿阇梨同友知识皆波夜提。是名结使。于比丘所两舌。波夜提。于比丘尼所两舌。偷兰罪。于式叉摩尼沙弥沙弥尼。越毗尼。于俗人越毗尼心悔。是故说

佛住舍卫城。广说如上。时六群比丘。知众僧如法如律灭诤事已。作是言。此事不了。当更断。六群比丘作此语已。还诤事起。不和合住。诸比丘。以是事往白世尊。佛言。呼六群比丘来。来已佛问六群比丘。汝实知众僧如法如律灭诤已。更发起耶。答言。实尔。佛言。何故如是。答言。我作如是方便以为乐。佛言。痴人。恼乱梵行人。此是恶事。云何为乐。佛语六群比丘。汝常不闻。我以无数方便赞叹于梵行人所。身常行慈。口心行慈耶。常应恭敬。汝今云何作是恶事。此非法非律。不如佛教。不可以是长养善法。佛告诸比丘。依止舍卫城住者尽集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘。知僧如法如律灭诤事已。还更发起。作是言。此羯磨不了。当更作如是因缘。不异者。波夜提。比丘者。如上说。知者。若自知若从他闻。僧者。八种如上说。诤事者。有四种。相言诤。诽谤诤。罪诤。常所行事诤。如法如律灭诤事者。七灭诤事中。一一如法如律。灭已更发。举如是因缘。不异者。波夜提。波夜提者。如上说。四诤者。相言诤。诽谤诤。罪诤。常所行事诤。相言诤事。用三毗尼一一灭。何等三。现前毗尼灭。多觅毗尼灭。布草毗尼灭。现前毗尼者。佛住舍卫城。时拘睒弥比丘斗诤相言。同止不和合法言。非法律言。非律罪言。非罪重罪轻罪。可治不可治法。羯磨非法羯磨。和合羯磨。不和合羯磨。应作不应作。尔时坐中一比丘作是语。诸大德。此非法非律。与修多罗不相应。毗尼不相应。优波提舍不相应。与修多罗毗尼优波提舍相违。起诸染漏。如我所说。是法是律。是佛教与修多罗毗尼优波提舍。相应不生染漏。是比丘言。诸大德。我不能灭此诤。我诣舍卫城。到世尊所。当问灭此诤事。是比丘到已头面礼佛足却住一面。白佛言。世尊。拘睒弥诸比丘斗诤相言。同止不和合。所谓法非法。乃至我不能灭此诤事。当往世尊所。问灭此诤事。唯愿世尊。为诸比丘灭此诤事。尔时世尊告优波离。汝往诣拘睒弥国。如法如律灭此诤事。所谓现前毗尼灭。优波离诤事。有三处起。若一人若众多。若僧亦应三处。舍三处。取三处灭。优波离汝往诣拘睒弥比丘所。如法如律灭此诤事。所谓现前毗尼灭。尊者优波离白佛言。世尊。比丘成就几法。能灭此诤事。佛告优波离。比丘成就五法。能灭诤事。何等五。知是实非是不实。是利益非不利益。得伴非不得伴。得平等伴非不得平等伴。得时非不得时。优波离。若非时断事。或破僧或僧诤。或僧离散。若得时灭诤者。僧不破不诤不分散。是为五法成就。比丘能灭诤事。为诸梵行者。爱念称赞。今汝往至拘睒弥比丘所。如法如律如佛教断事。所谓现前毗尼灭。尔时尊者优波离礼世尊足已。往拘睒弥比丘所言。长老。还去到彼诤事起处。当彼间灭。莫此间断事。何以故。此间众僧和合欢喜不诤。共一学住。不应扰乱。尔时拘睒弥比丘白尊者优波离言。大德。我若能于彼灭诤事者。不来诣此。唯愿尊者。为我至彼灭此诤事。优波离言。我若往到彼应作羯磨者。作羯磨。应治罚者。当罚之。应作折伏羯磨不语羯磨。发喜羯磨。摈出羯磨。举羯磨。别住羯磨。摩那埵羯磨。阿浮呵那羯磨。有如是如是过。我当作如是羯磨治。汝等尔时心莫不悦。彼使比丘白尊者优波离言。我等若有如是过。当受如是治。心无不悦。时尊者优波离复至佛所。白佛言。世尊。欲灭彼比丘诤事。当云何用心。佛告优波离。欲灭诤事者。当先自筹量身力福德力辩才力无畏力。知事缘起。比丘先自思量有如是等力。又此诤事起来。未久此人心调软诤事易可灭。此比丘尔时应作灭诤。若自思量无上诸力。诤事起已久。其人刚强非可卒灭。当求大德比丘共灭此事。若无大德比丘者。当求多闻比丘。若无多闻者。当求阿练若比丘。若无阿练若比丘者。当求大势力优婆塞。彼诤比丘见优婆塞已。心生惭愧诤事易灭。若复无此优婆塞者。当求于王。若大臣有势力者。彼诤比丘见此豪势。心生敬畏诤事易灭。若在冬时灭此诤事者。当于无风寒温暖屏处治。客比丘来当与炉火。若是春时。当于凉处。若树下敷床座。行冷水浆饮。当以扇扇若是夏时。当于高凉处。随时所须事事供给。尔时当举一堪能比丘有黠慧。知事因缘不怯弱。不求他过。不畏众人。若优婆塞来。当为赞叹和合僧功德。复语优婆塞。如世尊说。一法出世令天人苦恼天人失利。所谓一法者。坏乱众僧身坏命终。直入泥黎。又优婆塞如世尊说。一法出世天人安乐天人得利。所谓一法者。和合众僧身坏命终。得生善处。天上人中。如是优婆塞欲得大功德者。当和合众僧。二众语时。是比丘应谛观其事。取其语字句义味。时坐中有比丘。非闼赖吒比丘。作闼赖吒相。作是语。听诸大德。本作如是语。今作如是语。不相应时。此人皆性软可折伏者。应僧中语令羞愧。汝不善作不和合事。作不和合见众僧。今日为是事故。于此中集。若是恶人执性刚暴。能增长诤事。应作软语。语言。长老。众僧今日聚集为灭此事故。我当共长老作伴和合灭此诤事。若是比丘心意柔软已尔时僧断事人语。有事比丘言。汝今出此事。此比丘作如是言。我今出此事。愿僧与我如法如律断。尔时应呵责此人令惭羞。应语汝不善。何有众僧非法非律断事。彼比丘若言。我未曾僧中语。愿众僧教我仪法。尔时应教作是言。我今出此诤事因缘。随僧教敕我当奉行。彼比丘若不随僧语。复应语言。汝若不受僧教者。我当僧中拔筹驱汝出众。是比丘若复不随语者。尔时复应遣优婆塞。问是比丘言。汝当随僧教不。若不随者。我当与汝白衣法。驱汝出聚落城邑。知是比丘所诤事。若是小小诤事者。僧即优婆塞前灭。若是鄙秽事慰喻优婆塞令出已。僧如法如律如修多罗。随其事实用现前毗尼除灭。尔时尊者阿难往到佛所。头面礼足白世尊言。所谓现前毗尼灭云何名为现前毗尼灭。佛告阿难。比丘诤事。法非法律非律。罪非罪。轻罪重罪。可治罪不可治罪。法羯磨非法羯磨。和合羯磨。不和合羯磨。应作不应作羯磨。阿难。若有如是事起。应疾集僧。疾集僧已检校此事。如法如律如修多罗。随其事实用现前毗尼除灭。若成就五非法。不成与现前毗尼。何等五。不现前与。不问。不受过。不如法。不和合与。是名五非法不成与。现前毗尼。若成就五如法成与现前毗尼。何等五。现前与问受过如法和合与。是名五法成就与。现前毗尼。如是阿难。如法如律如佛教。用现前毗尼灭诤事已。若有客比丘。若去比丘。若与欲比丘。若见不欲比丘。若新受戒比丘。若在坐睡比丘。是诸比丘。作是言。如是不好羯磨。别佛别法别僧。如牛羊僧。不善羯磨。羯磨不成就。阿难。如是更发起者。得波夜提罪。是名相言诤。以现前毗尼灭诽谤诤者。若比丘不见不闻不疑。比丘犯波罗夷。僧伽婆尸沙。波夜提。波罗提提舍尼。越毗尼以是五篇罪谤。是名诽谤诤。用二毗尼灭。所谓忆念毗尼灭。不痴毗尼灭。忆念毗尼者。佛住王舍城。慈地比丘尼作非梵行。遂便妊身到六群比丘所。作是言。我作非梵行事。今者有娠。尊者。与谁有嫌。我能谤之。六群报言。善哉姊妹。乃欲为我作饶益事。陀骠摩罗子。是我生怨。与我破房舍及不好床。蓐粗恶饮食。若此人久在梵行者。我等长夜受苦。汝看此比丘斋日大众说法时。在中者汝当往彼众中以非梵行谤。答言。当如尊者教。是比丘尼若月八日十四日十五日。大众说法时。往到众前。而作是言。尊者。为我办酥油粳米诸饮食。具修治房舍。并求佐产人。我产时至是长老。答言。姊妹。汝自知之。我无此事。比丘尼复言。奇怪奇怪。汝是丈夫。晨去夜来。共我从事。而今说言。我无此事。勿复多言。但当与我办酥油等。我今产时已至长老。复言。姊妹。汝自知我无是事。如是三说而去。是时众中诸不信者。便作是念。此等二人皆是年少。必有此事。忠信之人。皆生疑惑。为有为无。诸上信者便作是言。此尊者已灭三毒恶法。永尽无有此事。尔时尊者陀骠摩罗子。作非梵行。恶名流布。屏处亦闻。众多亦闻。僧中亦闻。诸比丘以上因缘。具白世尊。佛言。比丘是陀骠摩罗子。非梵行事。恶名流布。汝等当于屏处三问。众多人中三问。僧中三问。屏处问者。应作是问。陀骠摩罗子长老。慈地比丘尼作是语。是事知不。时长老言。我不知。作不忆作。如是第二第三问。众多人中三问亦如是众僧中问言。陀骠摩罗子长老。慈地比丘尼作是言。是事知不。答言。我不知。作不忆作。第二第三问亦如是。诸比丘以是事。往白世尊。长老陀骠摩罗子已屏处三问。多人中三问。僧中三问。自言。我不知。作不忆作。佛告诸比丘。此陀骠摩罗子清净无罪。是慈地比丘尼自言犯。应驱出。时王舍城比丘尼。嫌世尊作如是言。看是断事不平等。二人俱犯罪。云何置比丘。驱比丘尼。若俱有罪当俱出。若无罪当俱置。云何世尊驱一置一。诸比丘以是因缘。具白世尊。佛告阿难。汝往呼王舍城比丘尼僧来。唯然世尊。尔时阿难至比丘尼所。作是言。诸姊妹。世尊呼汝等。时比丘尼语尊者阿难言。我于世尊所。无有事缘。何故呼我。若有事缘不呼自往。尊者还去。我无缘事。不能往。时阿难作是念。此是奇异。蒙世尊恩。得出家为道。云何于佛不起敬心不从教命。尔时阿难还到世尊所。头面礼足。以是因缘。具白世尊。佛告阿难。汝往语王舍城比丘尼言。汝有过。世尊敕汝令去。不得住此。阿难受教。即往比丘尼所。作是言。姊妹。汝有过。世尊敕汝令去。不得住此。比丘尼答尊者阿难言。我于城外无诸缘事。不能去。若有缘者不敕自去。尔时阿难作是念。奇异蒙世尊恩。得出家为道。云何于佛不生敬心。呼来不来。遣去不去。阿难即还佛所。头面礼足。以是因缘具白世尊。佛语阿难。如来应供正遍知。若于城邑聚落比丘比丘尼僧。呼来不来。遣去不去者。如来自当避去。阿难汝取我僧伽梨来。时尊者阿难即授僧伽梨。世尊于中时不语比丘僧。唯将阿难。经过五通居士聚落。向舍卫城。尔时韦提希子阿阇世王杀父王已。深怀愁毒。常日三诣世尊忏悔。清旦日中晡时。晨朝忏悔。已中时复来不见世尊。即问诸比丘世尊所在。诸比丘答言。世尊已去。王作是言。世尊每行时一月半月。常语我。今何因缘默然而去。时诸比丘闻佛向所说。即答言。大王。王舍城诸比丘尼不从世尊教命。呼来不来。遣去不去。如是大王当知。如来应供正遍知若于城邑聚落比丘比丘尼僧。语来不来。遣去不去。如来便自避去。今王舍城比丘尼僧不从佛教是故世尊默然而去。王闻是语。极大嗔恚。敕语诸臣。现我境内。诸比丘尼僧。一切驱出。时有智臣。即谏王言。非境内诸比丘尼一切有过。但王舍城比丘尼违世尊教。王即用臣言。敕诸有司。驱王舍城比丘尼出。尔时诸司皆捉杖木土块瓦石。打掷诸比丘尼。驱令出城作是责言。汝弊恶人。蒙世尊恩。得出家为道。而不恭敬。违背佛教。速出去坐。汝弊恶老妪。使我不见世尊不闻正法。汝等速出不得住此。尔时里巷诸人见是事已。皆遥骂言。乃至使我不见世尊不闻正法。汝等速出不得住此。尔时优陀夷亦捉杖驱出诸比丘尼。呵责亦如上说。王敕诸臣。汝等观比丘尼。若随世尊后去者。汝等当为作法护。令得安隐。若向余处去者。便随其意。不须作护。时诸比丘尼出城已。各作是言。若我等向余方者。在在处处皆见驱逐。无得住处。我等今当随世尊后去。世尊朝所发处。诸比丘尼暮到。如是在道。恒降一日。尔时世尊欲化度故。过五通居士聚落。向舍卫城。五通居士常法闻比丘比丘尼僧来。至一由延。迎设种种供养。尔时五通居士闻此诸比丘尼来。即入正受观之。诸比丘尼为何因缘故来。观已见彼诸比丘尼一切有过。皆被驱罚。未得解过。非是净器。无圣法分。作是观已。都不往迎设诸供养。诸比丘尼展转借问。来至其门。语言。王舍城诸比丘尼。今在门外。令居士知。居士即敕使人与破屋弊床褥。不供给暖水洗足及涂足油。亦不与非时浆。亦不问讯安慰。夜不然灯。明旦复不供给齿木净水。与粗饮食食已。遣令速去。诸比丘尼出外已。自相谓言。我闻此居士常有信心。恭敬供养众僧。如今观之。无有信敬。中有比丘尼。谓诸人言。止止阿姨。当自观察。我等违世尊教。得此供给已自过分。诸比丘尼渐渐前行。到舍卫城。诣阿难所。头面礼足。却住一面。白阿难言。我等欲见世尊礼觐问讯。愿为比丘尼僧白世尊。唯哀听许。阿难答言。善哉诸姊。即诣佛所。头面礼足。却住一面。白佛言。王舍城比丘尼僧。欲来奉觐世尊。听者当命使前。佛告阿难。汝莫令王舍城比丘尼僧来见我。阿难言。善哉礼佛即还。至比丘尼所告言。诸姊。世尊有教不听汝前。第二第三亦如是。佛告阿难。汝何故为王舍城比丘尼殷勤乃尔。阿难白佛言。世尊。我不作比丘尼想。何以故世尊呼来不来。遣去不去。故但世尊语有余理。言王舍城比丘尼僧。以僧故。是故殷勤。佛言。听王舍城比丘尼僧前阿难即还比丘尼所。语言。诸姊。大得善利。世尊听汝等前。诸比丘尼闻已。皆称善哉善哉。阿难即前佛所。头面礼足。却住一面。白佛言。世尊。我等不善。如小儿愚痴。不识福田。不知恩养。不受世尊教。我今自知见罪。唯愿世尊受我悔过。佛告王舍城比丘尼。汝等不善。如小儿愚痴。不识福田。不知恩养。世尊。呼来不来遣去不去。汝今自见罪听汝悔过。于圣法中能悔过者。增长善根自今已去勿复更作。若比丘僧如法唤比丘尼僧比丘尼僧法应即来。若不来者。得越毗尼罪。比丘僧应遮此比丘尼僧布萨自恣若来时不听入门。若比丘僧如法唤众多比丘尼呼一比丘尼亦如是。若众多比丘如法唤比丘尼僧。法应即来。若不来者。得越毗尼罪应遮此比丘尼布萨自恣若来时不听入门若众多比丘如法唤众多比丘尼。唤一比丘尼亦如是。若一比丘如法唤比丘尼僧。唤众多比丘尼唤一比丘尼。比丘尼法应即来。若不来者。得越毗尼罪。应遮此比丘尼布萨自恣。若来时不听入门若尼僧。若众多比丘尼若一比丘尼。向比丘僧。向众多比丘。向一比丘悔过法如前向佛悔过法中广说尔时世尊为王舍城比丘尼随顺说法。示教利喜。时一比丘尼得法眼净。佛告诸比丘尼。汝等可去还案来时。道若五通居士。若有所说。汝当受行。尔时王舍城诸比丘尼。即还趣五通聚落。时五通居士即入定。观见此诸比丘尼已。向佛忏悔。悉皆清净。成就法器。时五通居士案如常法。乘白草马车一由延迎。遥见诸比丘尼僧。便下车步进。褊袒右肩右膝着地。合掌白言。善来阿姨。行道不疲极耶。居士即请诸比丘尼。在前行从后而归。到家中已。与好新房床褥卧具。与暖水洗足与涂足油。与非时浆。暮然灯火安慰问讯言。阿姨。安隐住。明旦供给齿木澡水。与种种粥。至时与随适饮食。食已偏袒右肩右膝着地。合掌白言。我今请阿姨。夏安居。我当供给所须衣食床卧病瘦医药。当教学受诵经偈。唯除布萨自恣。尔时诸比丘尼作是念。今已四月十二日夏坐已逼。又世尊复敕当受五通居士语。思惟是已。即便受请夏安居。居士日日为比丘尼说四念处。诸比丘尼闻此法已。初夜后夜精勤不懈。修习圣道。成就得证。诸比丘尼受自恣竟。我等当诣世尊。礼敬问讯。自说果证时。诸比丘尼向舍卫城。到阿难所。头面礼足。却住一面。白尊者阿难言。如来应供正遍知。为诸声闻说四念处。我等初夜后夜精进不懈。修习圣道成就得证。作是语已。便还所住。诸比丘尼众去不久。时尊者阿难。诣世尊所。头面礼足。却住一面。以王舍城诸比丘尼所说。具白世尊。乃至修道得证。尊者阿难说是语已。复白佛言。是事云何。唯愿解说。佛告阿难。如诸比丘尼所说真实无异。何以故。若比丘比丘尼优婆塞优婆夷。其有能于四念处精勤修习。一切皆得成就得证。如四念处经中广说。时诸比丘白佛言。世尊。有何因缘王舍城比丘尼于世尊不识恩分。来舍卫城。诣阿难所。不觐世尊。使优陀夷捉杖驱逐。尊者阿难殷勤请救。唯愿解说。佛告诸比丘此诸比丘尼不但今日于我不识恩分。优陀夷捉杖驱逐。阿难殷勤请救。过去世时。已曾如是。如象王本生经中广说

摩诃僧祇律卷第十二摩诃僧祇律卷第十三

        东晋天竺三藏佛陀跋陀罗共法显译

    明单提九十二事之二

佛住舍卫城。广说如上。时城中有大富淫女家。多饶财宝种种成就。库藏盈溢守备牢固。外贼伺求无能得者。时有一贼主。善作方便。遣使语淫女言。我等欲诣某池上。多请淫女设种种饮食。自恣娱乐。汝便可好自庄严。诣彼池上勿令不好。为彼所嗤。女人之心以妒胜为先。名衣上服珠玑璎珞。尽以严身。种种庄饰光焰曜目。往赴彼请。时此贼主方便诱导。将诣避隐深邃之处。淫女问言。向请诸女今何所在。答言。须臾当至。且作欢乐。彼时淫女便作是念。今观此人是贼无疑。何以知之。此非本期处。又诸女悉皆不来。日遂向暮。淫女便言。我欲还家。贼主报言。且相娱乐。何乃匆匆。时女思惟。此定作贼。必为彼所困。我有妙术六十四种。今正是时。若不用者。何以免济。尔时此女伪现姿媚爱相。与贼交杯。似自饮酒。劝贼令尽。外现殷勤。妖媚亲附。内心与隔。使彼贼心耽惑悦乐。不复有疑。时贼主独将淫女。至一屏处。酒势遂发。醉无所觉。此女徐自敛身离贼。收襆严饰。向舍卫城。城门已闭。回向祇洹寺门亦闭。尔时门外有一长老比丘。字迦卢。去门不远。在一屏处。敷绳床而坐。衣四垂下。此淫女于恐怖中来趣安隐处。即入长老床下。迦卢尔时入三昧。不察床下。贼夜半后醉醒。欲剥淫女。觅而不见。贼帅问诸伴言。汝等见此女人不。皆言。不见。各各把火求觅。都不知处。复相谓言。若如是不得者。当求脚迹。即寻迹到舍卫城门。门闭复寻迹遂至祇洹门下。便失其迹。不知所向。贼虽见是比丘。无有疑心。尔时天遂向晓。舍卫城中已打明鼓。复闻象马鸡狗之声。尔时贼帅便相谓言。今失此女。不知所在。天复欲晓。不宜久停。当还林中避隐之处。作是念已。即还林中。天晓。城中人民象马车乘出城。又诸优婆塞亦皆出城。礼觐世尊。已过礼迦卢比丘。见此淫女。于床下而出。众人见已。皆讥嫌言。此阿练若。云何纳衣乞食。通夜与淫女从事。晓乃放去。失沙门法。何道之有。尔时长老陀骠摩罗子迦卢比丘丑名流布。诸比丘闻已。具白世尊。佛言。比丘是陀骠迦卢比丘。非梵行恶名流布。汝等当于屏处三问。多人中三问。僧中三问。屏处问者。应作是问。长老陀骠迦卢诸梵行人。作是语是事知不。答言。不知作不忆作。如是第二第三多人中三问。众僧中三问亦如是。诸比丘白佛言。世尊。是陀骠迦卢比丘已于屏处三问。多人中三问。众僧中三问。自言不知作不忆作。佛告诸比丘。是陀骠迦卢比丘清净无罪。僧应与忆念毗尼灭。清净共住。作求听羯磨羯磨者应作是说。大德僧听。是长老陀骠迦卢诸梵行人。作是语。自言不知作不忆作。若僧时到。僧长老陀骠迦卢欲从僧乞忆念毗尼灭。清净住。诸大德听。是陀骠迦卢比丘欲从僧。乞忆念毗尼灭。清净住。僧忍默然故。是事如是持。乞法者。是陀骠迦卢比丘偏袒右肩脱革屣右膝着地。作是言。我陀骠迦卢比丘诸梵行人。作是语。我不知作不忆作。我陀骠迦卢今从僧。乞忆念毗尼灭。清净住。唯愿僧与我忆念毗尼灭。清净住。如是第二第三乞。羯磨人当作是说。大德僧听长老陀骠迦卢诸梵行人。作是语。自言不知作不忆作已。从僧乞忆念毗尼灭。清净住。若僧时到。僧与长老陀骠迦卢忆念毗尼灭。清净住。白如是。大德僧听。是长老陀骠迦卢诸梵行人。作是语。自言不知作不忆作已。从僧乞忆念毗尼灭。清净住。僧今与长老陀骠迦卢忆念毗尼灭。清净住。诸大德忍。与长老陀骠迦卢忆念毗尼灭。清净住者默然。若不忍便说是初羯磨。如是第二第三说。僧已与长老陀骠迦卢忆念毗尼灭清净住竟。僧忍默然故。是事如是持

佛问诸比丘。已与陀骠迦卢忆念毗尼未。答言。已与佛言。比丘五法成就非法与忆念毗尼。何等五。不清净清净想与。清净不清净想与。不先检校。非法不和合。是名五非法与忆念毗尼。五如法与忆念毗尼。何等五。清净清净想与。不清净不清净想与。先检校。如法和合。是名五如法与忆念毗尼。时诸比丘白佛言。云何世尊。是淫女人为贼所逐。佛言。不但今日为贼所逐。过去世时以曾为彼所逐。如怨家本生经中广说

尔时尊者阿难往至佛所。头面礼足。却住一面。白佛言。世尊。云何名为忆念毗尼。佛语阿难。若比丘谤比丘若波罗夷。僧伽婆尸沙。波夜提。波罗提提舍尼。越毗尼。当疾集僧。疾集僧已。问是比丘和上阿阇梨同友知识作是言。长老。汝知某比丘先来为人戒行。何似与谁为知识。彼知识为善恶。若言某甲先来持戒行清净。与善知识同友犯小小罪。心怀惭愧速疾除悔。如是人僧应与忆念毗尼。若言我知彼比丘先来戒行不清净。又与恶知识从事。犯罪不能如法悔过。阿难。如是比丘僧不应与忆念毗尼灭。如是阿难。如法如律。与忆念毗尼灭。诽谤诤已。若客比丘。若去比丘。若与欲比丘。若见不欲比丘。若在坐睡比丘。新受戒比丘。是诸比丘言。作如是羯磨不成就。不如法愚痴无智。别佛别法别僧。犹如牛羊不善羯磨不成就。作如是更发起者。波夜提罪。是名诽谤诤忆念毗尼灭。云何诽谤诤不痴比尼灭

佛住舍卫城。广说如上。尊者劫宾那有二共行弟子。一名难提。二名钵遮难提。是二比丘本狂痴病。病时作种种非法。今已差诸梵行人。犹故说其痴狂时所作。是二比丘闻是语时。用为羞愧。以是因缘。语诸比丘。诸比丘。以是事具白世尊。佛言。是难提钵遮难提本痴狂病。时作种种非法。今痴已差诸梵行人。犹故说其本痴狂时所作。佛告诸比丘。汝等当于屏处三问。多人中三问。僧中三问。屏处问者。应作是言。长老诸梵行人作是语。汝知不。答言。不知作不忆作。如是第二第三多人中三问。众僧中三问亦如是诸比丘。以是事往白世尊。已屏处三问。多人中三问。众僧中三问。自言不知作不忆作。佛告诸比丘。是二比丘本痴今不痴。诸梵行人说。前痴时所行。自言不知作不忆作。僧应与作不痴毗尼灭。作法者应作求听羯磨。唱言大德僧听是长老难提钵遮难提本痴今不痴。诸梵行人说前痴行。自言不知作不忆作。若僧时到。僧是难提钵遮难提比丘。欲从僧乞不痴毗尼灭。诸大德听。是难提钵遮难提欲从僧乞不痴毗尼灭。僧忍默然故。是事如是持。乞法者。是难提钵遮难提偏袒右肩胡跪合掌。作是言。我某甲本痴今不痴。诸梵行人说前痴行。我不知作不忆作。今从僧乞不痴毗尼灭。唯愿僧与我不痴毗尼灭。如是第二第三乞。僧应语彼比丘言。僧无有说汝事者。说汝事者。汝当往语。使勿复说。此比丘应往彼比丘所言。长老。我先狂痴时所作。我今不知作不忆作。愿长老勿复说我痴时所作。彼比丘若止善。若不止应语彼和上阿阇梨及同友知识。作是言。长老。汝弟子若同友知识。说我本痴时所作。我不知作不忆作。愿长老为我呵语彼勿复更说。彼和尚阿阇梨。应当呵语汝不善。不知戒相。不闻。世尊说痴狂心乱作无罪耶。彼说事人。若受者善。尔时僧应作羯磨。羯磨人如是唱。大德僧听。长老难提钵遮难提本痴今不痴。诸梵行人说前痴行自言。不知作不忆作已。从僧乞不痴毗尼灭。若僧时到。僧与难提钵遮难提作不痴毗尼灭。白如是。大德僧听。是难提钵遮难提本痴今不痴。诸梵行人说前痴行。自言不知作不忆作已。从僧乞不痴毗尼灭。僧今与某甲作不痴毗尼灭。诸大德忍。与难提。钵遮难提不痴毗尼灭忍者默然。若不忍便说是初羯磨。如是第二第三说。僧已与某甲。某甲不痴毗尼灭竟。僧忍默然故。是事如是持。佛问诸比丘。已与难提钵遮难提不痴毗尼未。答言。已与世尊。佛言。五法成就非法与不痴毗尼。何等五。不痴痴想与。不请求举事。人使心柔软。不从僧乞不痴毗尼。非法不和合。是名成就五非法。与不痴毗尼灭成就五如法。与不痴毗尼。何等五。不痴不痴想与。求请举事人。使心柔软。从僧乞不痴毗尼。如法和合。是名成就五如法与不痴毗尼。时尊者阿难。往诣佛所。头面礼足。白佛言。世尊。所谓不痴毗尼云何名不痴毗尼。佛告阿难。有比丘本痴今不痴。诸梵行人说前痴行。尔时应疾疾集僧。集僧已。如修多罗如毗尼。随此比丘事实。与不痴毗尼。如是阿难如法如律。如世尊教。以不痴毗尼灭诽谤诤事已。若客比丘乃至愚痴无智。犹如牛羊更发起者。得波夜提罪。是名不痴毗尼灭。诽谤诤罪诤者。若比丘比丘相说罪过。若波罗夷。乃至越毗尼。此罪诤用二毗尼灭。所谓自言。毗尼觅罪相毗尼。自言毗尼者

佛住舍卫城时慧命罗睺罗到时。着入聚落衣。持钵入舍卫城。次行乞食。得还精舍。食已执衣持钵着常处。持尼师坛。向得眼林。欲坐禅中路。见一比丘与女人作非梵行见已。此恶比丘作是念。佛子罗睺罗见我作非梵行。必语世尊。及其未语间。我当诣世尊所。先说其过。时恶比丘诣佛所。头面礼足白言世尊。我见尊者罗睺罗趣得眼林中路。共女人作非法事。尔时世尊默然不答。时尊者罗睺罗在一树下。正受三昧。从禅定起。来诣世尊所。不忆恶比丘事。如常法头面礼足。却住一面。尔时世尊欲使罗睺罗忆向事故。即化作恶比丘在其前。罗睺罗见已。即发本识。白世尊言。我向林中中路。见此比丘共女人作非梵行。佛言。罗睺罗。若彼比丘亦作是语。我见罗睺罗中路作非梵行。是事云何。尊者罗睺罗白佛言。世尊。我无是法。佛告罗睺罗。若彼比丘亦作是言。我无是法。是事云何。罗睺罗复白佛言。世尊。若如是者。唯世尊知我。佛言。彼复作如是言。唯世尊。知我此事云何。罗睺罗复白佛言。唯愿世尊。与我自言治。佛复告罗睺罗。若彼比丘亦如是言。愿世尊与我自言治者。复当云何。罗睺罗白佛言。若尔者愿世尊。俱与我二人自言治。尔时世尊。诣众多比丘所。敷尼师坛坐已。为诸比丘广说上事。说已告诸比丘。与此比丘自言毗尼灭。何以故。未来世或有恶比丘。诽谤清净。比丘不得自言治。便驱出故。佛告诸比丘。有八非法。与自言毗尼。何等八。问重而说轻。轻事不实。是名非法。与自言治。问轻说重。问残说无残。问无残说残。问轻说轻。问重说重。问残说残。问无残说无残。如是一一皆不。说实罪。是名非法。与自言治有八如法。与自言治。何等八问重说轻。实有轻罪而说轻。是名如法。与自言治。问轻说重。问残说无残。问无残说残。问重说重。问轻说轻。问残说残。问无残说无残。如是一一皆说实。是名八如法。与自言治。尔时尊者阿难往诣佛所。头面礼足。白佛言。世尊。所谓自言毗尼灭。云何名自言毗尼灭。佛告阿难。若比丘比丘相说罪过。若波罗夷乃至越毗尼罪。阿难尔时应疾集僧。疾集僧已。如修多罗。如毗尼。如世尊教。随此比丘事实。与自言毗尼灭。如是阿难如法如律。如世尊教。用自言毗尼灭诤事已。若客比丘乃至更发起者。得波夜提罪。是名自言毗尼灭。罪诤觅罪相毗尼者

佛住舍卫城时。长老尸利耶婆数数犯僧伽婆尸沙罪。众僧集欲作羯磨事时尸利耶婆不来。即遣使往唤。长老尸利耶婆众僧集欲作法事。尸利耶婆念言。正当为我故作羯磨耳。即心生恐怖。不得已而来。诸比丘问言。长老。犯僧伽婆尸沙罪耶。答言犯。彼生欢喜心。作是念。梵行人于我边举可忏悔事。非不可治事。白众僧言。听我小出。诸比丘于后作是言。此比丘轻躁。是不定人出去已。须臾当作妄语。应当三过。定实问已。然后作羯磨。尸利耶婆出已。作是念。我何以故。受此罪。诸比丘数数治我罪。我今不应受是罪。诸比丘即呼尸利耶婆入。入已问言。汝实犯僧伽婆尸沙罪耶。答言。不犯。诸比丘问。言向汝何故僧中说有是罪。复言不犯。尸利耶婆言。我不忆是事。诸比丘以是事白佛。佛言。呼尸利耶婆来。来已佛以是事。广问尸利耶婆。汝实尔不。答言实尔。佛告诸比丘。尸利耶婆众僧中见罪言不见。不见复言见。作是语。我不忆僧。当与觅罪相比尼灭羯磨者。应作是说。大德僧听。尸利耶婆比丘僧中见罪言不见。不见复言见。自言不忆。若僧时到。僧与尸利耶婆比丘觅罪相毗尼灭。白如是。大德僧听。尸利耶婆比丘僧中见罪言不见。不见复言见。自言不忆。僧今与尸利耶婆比丘觅罪相毗尼灭。诸大德忍。与尸利耶婆比丘觅罪相毗尼灭。忍者默然。若不忍便说是第一羯磨。第二第三亦如是说。僧已忍与尸利耶婆比丘觅罪相毗尼灭竟。僧忍默然故。是事如是持。佛告诸比丘。是比丘僧为作觅罪相毗尼羯磨已。是比丘应尽形寿行八法。何等八。不得度人。不得与人。受具足戒不得受人。依止不得受僧。次请不得作僧。使行不得与僧作说法人。不得与僧作说比尼人不得与僧作羯磨人。僧作羯磨已。是比丘尽寿不听舍。是名八法。尔时尊者阿难往诣佛所。头面礼足。白佛言。所谓觅罪相毗尼。云何名为觅罪相毗尼。佛告阿难。若比丘僧中见罪言不见。不见复言见。自言不忆作抵慢。尔时应疾疾集僧。集僧已。如修多罗如毗尼如法。随此比丘。与觅罪相毗尼灭已。僧应语是比丘言。长老。汝不得善利。云何僧中见罪言不见不见复言见。自言我不忆作。以汝僧中作是语故。僧与汝作觅罪相羯磨。如是阿难。如法如毗尼如世尊教。与觅罪相毗尼灭诤已。若客比丘乃至更发起者。得波夜提。是名罪诤用觅罪相毗尼灭竟。相言诤。用三毗尼灭。前已说现前毗尼竟。多觅毗尼灭。相言诤者

佛住舍卫城拘睒弥。时有二部大众。各有一师。一名清论。二名善释清论。有一共行弟子。名雹口。善释有一共行弟子。名坫雹。第一依止弟子名头头伽。第二依止弟子名吒伽。第一有优婆塞弟子名头磨。第二优婆塞弟子名无烟。第一有檀越名优陀耶王。第二檀越名渠师罗居士。第一优婆夷弟子名舍弥夫人。第二优婆夷弟子魔揵提女。名阿[少/兔]波磨。第一后宫青衣弟子名频头摩逻。第二后宫青衣弟子名波驮摩逻人。各有五百比丘。五百比丘尼。五百优婆塞。五百优婆夷。第一众主入厕行讫。欲用水见水中有虫。以草横器上为相。第二众主依止弟子。后来入厕。见水器上有草。便作是言。是何无羞人。持草着水器上。第一众主共行弟子。闻此语已。语其人言。汝云何乃持我和上。名无羞人。因此事故。二部四众遂生大诤。时拘睒弥国举城内外诤斗之声。内外娆动。犹如金翅鸟王入海取龙。水大波涌。如是大诤唯正共诤草非草。是故诸比丘斗诤同止不和。说法非法律。非律重罪轻罪。可治不可治。法羯磨非法羯磨。和合羯磨不和合羯磨。应作不应作。尔时坐中有一比丘。作是语。诸大德。此非法非律。与修多罗不相应。与毗尼不相应。与优波提舍不相应。与修多罗毗尼优婆提舍相违。但起诸染漏。如我所知。是法是律。是佛教与修多罗毗尼优波提舍相应。如是不生染漏。是比丘言。诸大德。我不能灭此诤。当诣舍卫城。到世尊所。当问灭此诤事。是比丘到已。头面礼佛足。却住一面白世尊言。拘睒弥诸比丘斗诤。更相言说同止不和。乃至我不能灭诤事。我当往白世尊灭此诤事。唯愿世尊。为诸比丘灭此诤法。尔时佛告优波离。汝往与拘睒弥比丘如法如律。如佛教。所谓多觅毗尼灭此诤事。如是诸释种及诸离车等断事。时不可即了者。亦与多觅毗尼灭。优波离诤事有三处起。若一人。若众多若僧。亦应三处舍三处。取三处灭。优波离。汝往诣拘睒弥比丘所。如法如律如佛教灭此诤事。所谓多觅毗尼如上现前毗尼中广说。乃至是比丘心软已。僧应行舍罗。比丘有五法成就。僧应羯磨作行舍罗人。何等五不随爱。不随嗔。不随怖。不随痴。知取不取。羯磨者。应作是说。大德僧听。某甲比丘五法成就。能为众僧作行筹人。若僧时到僧立某甲比丘作行筹人。白如是。大德僧听。某甲比丘五法成就僧今立某甲比丘作行筹人。诸大德忍某甲比丘作行筹人忍者默然。若不忍便说。僧已忍立某甲比丘作行筹人竟。僧忍默然故。是事如是持。羯磨已。此比丘。应作二种色筹。一者黑。二者白。不应唱言非法者。捉黑筹。如法者捉白筹。应如是唱。如是语者取黑筹。如是语者取白筹。行筹人行筹时。当立心在五法内然后行筹。不应作不如法伴。当作如法伴行筹讫。数若非法筹。乃至多一者。不应唱。非法人多如法人少。当作方便解坐。若前食时欲至者。应唱令前食。若后食时至。应唱令后食。若洗浴时至。当唱令洗浴。若说法时。欲至当唱。令说法时到。若说毗尼时至。当唱说毗尼时到若非法者。觉言我等得胜。为我故解坐。我等今不起。要即此坐决断是事。尔时精舍边若有小屋无虫者。应使净人放火已。唱言火起火起即便散起救火。知近住处有如法者。应往唤言。长老向行筹讫。非法人多如法人少。长老。当为法故往彼。使如法者筹多得佛法增长。亦得自益功德。若彼闻此语不来者。得越毗尼罪。来已当更行筹。行筹已数看。若白筹多一不应唱言。多一应作是唱。如是语人多。如是语人少。作是唱已。应从多者。更有五法成就。不如法行筹。何等五。如法语人少。非法语人多。说法语人不同。见说非法语人同。见非法说法法说非法因。是行筹当破僧。乃至僧别异。是名五非法。翻上名成就五如法行筹。尔时尊者阿难往到佛所。头面礼足。白佛言。世尊。所谓多觅毗尼灭云何名为多觅毗尼灭。佛告阿难。诸比丘于修多罗中毗尼中威仪中。言此是罪非是罪。是轻是重。是可治是不可治。是残罪是无残罪。斗诤相言。尔时应疾疾集僧。如法如律如佛教。随其事实。如法如律断灭。若复不能了者。闻某方住处有长老比丘。诵修多罗。诵毗尼。诵摩帝利伽。如是若中年若少年比丘。诵修多罗。诵毗尼。诵摩帝利伽者。应疾往问。若请。来随彼比丘所说。与多觅毗尼灭诤事灭已。如是阿难。若客比丘乃至新受戒比丘。更发起者。波夜提。是名相言诤用多觅毗尼灭。如草布地毗尼灭。相言诤者

佛住舍卫城时。拘睒弥比丘共诤同止不和。说法非法律非律。乃至尊者优波离语彼比丘言。长老。我往彼已应作羯磨。当作种种羯磨。治摈汝等。尔时莫心不悦。是使比丘言。我欲小出。出已作是念。我若随尊者优波离去者。或能苦治我罪。我等今当独还拘睒弥自共灭此诤事。到拘睒弥已。复不能灭诤事。复言长老。我自不能得灭此诤事今当还到舍卫城灭此诤事。作是语已。即往舍卫城。往至尊者优波离所。作如是言善哉尊者。为拘睒弥比丘灭此诤事。优波离语彼比丘言。故如我先语。汝随彼有事。当种种如法治。汝尔时莫心不悦。当随汝去彼比丘答言。不敢复违。优波离言。去还至彼灭莫乱此间僧。尔时拘睒弥比丘往到佛所。头面礼足。白佛言。世尊。拘睒弥比丘同止不和更相言说。唯愿世尊灭此诤事。佛告拘睒弥比丘。汝莫斗诤更相言说。同止不和。何以故。过去久远世时。有城名迦毗罗。王名婆罗门达多。如长寿王本生经中广说。佛告拘睒弥比丘。彼有如是破国亡家。乃至太子长生不报父仇。犹更和合不生恶心。汝等云何于正法中。以信出家而更忿诤。同止不和。佛告优波离。汝往为拘睒弥比丘。如法如律如佛教。如草布地毗尼灭此诤事。佛复告优波离。诤事三处起。三处取。三处舍。三处灭。乃至是诤事净者。当共优婆塞断。莫是。不净事。当喻遣优婆塞出随是比丘事实。如法如律。为作如草布地毗尼灭。佛告优波离。若是下座有过失。应诣上座所。头面礼足。作是言。长老。我所作非法侵犯过罪。我今忏悔不敢复作。上座应以手摩其头。扶起手抱语言。慧命。我亦有过。于汝当见善恕。若上座有过。应至下座所捉手言。我所作非法有过。于汝我忏悔。不复作。下座应起礼上座足。亦如上忏悔。尔时尊者阿难往至佛所。头面礼足。白佛言。世尊。所谓布草毗尼。云何名布草毗尼。佛语阿难。若比丘诤事起同止不和。二部众不忍生恶心。共相言。各各说不随顺法。不忍事起。阿难尔时应疾疾集僧。如法如律。应一部众中有宿德知事。因缘辩才明了说法。不怯赞叹和合众僧功德。应从坐起。偏袒右肩胡跪合掌。向第二部众。作是言。诸大德。我等云何同一法中。以信出家而起诤事。同止不和。二部众不忍。各各生恶心。共相言说。不随顺法。不忍事起。一切皆是不善思惟所致。今世苦住。后堕恶道。诸大德。当各各弃此诤事。如草布地。我今向诸长老忏悔。各各下意和合共住。阿难。若第二部众一切默然住者。第二众中宿德聪明辩才者。即应起忏悔。忏悔法亦如上说。阿难。僧中有如是诤事起。应疾疾集僧。如法如律。如草布地灭此诤事。佛告阿难。此一切诤事如相打相搏牵。出房种类。两舌无根谤。如是等罪。皆应如草布地。毗尼中灭。如是如草布地灭已。客比丘。乃至新受戒比丘。更发起者。波夜提。常所行事诤者。若僧所作事如法办。如法结集。如法出。如法舍。如法与。如是世尊弟子比丘众所行无量事。皆于七灭诤止。一一事灭。是名常所行事。诤是故说

佛住舍卫城。广说如上。尔时尊者优陀夷。到时着入聚落衣持钵入城。次行乞食到一家。为众多女人说法。时尊者阿难次行乞食到其家。见已问言。长老作何等。答言。我为此诸女说法。尊者阿难语优陀夷言。云何名比丘。无有知男子而独为女人说法。阿难乞食。食已往世尊所。头面礼足以上因缘具白世尊。佛言。呼优陀夷来。来已佛问优陀夷。汝实作是事不。答言。实尔世尊。佛言。此是恶事。汝云何无有知男子为女人说法。从今以后不听无有。知男子为女人说法

复次佛住舍卫城。广说如上。尔时尊者优陀夷。到时着入聚落衣持钵入城。次行乞食到一家。为众多女人说法。时尊者阿难行乞食到其家。见已问言。长老作何等。答言。为女人说法。阿难言。长老不闻世尊言无男子不得为女人说法耶。答言。阿难汝不见此石人木人草人画人耶。一人便足。况复众多。尊者阿难乞食。食已以此因缘具白世尊。佛言。呼优陀夷来。来已世尊问优陀夷。汝实尔不。答言实尔。佛言。优陀夷汝云何以无心男子当净人而为女人说法。佛言。从今日不听以无心男子当净人而为女人说法

复次佛住舍卫城。广说如上。尔时优陀夷。时到着入聚落衣。持钵入舍卫城。乃至答尊者阿难言。汝不见此抱上小儿饮乳小儿卧小儿耶。一人便足。何况多人。尊者阿难乞食。食已以上因缘具白世尊。佛言。呼优陀夷来。来已佛问优陀夷。汝实尔不。答言实尔。佛言。优陀夷汝云何以婴儿当净人。而为女人说法。从今日不得以乳下婴儿当男子。而为女人说法

复次佛住舍卫城。广说如上。尔时毗舍佉鹿母病。尊者阿难晨起着入聚落衣。往问疾言。优婆夷所患何似不大苦恼不。答言。所患不差。不可堪忍。愿尊者为我说法。阿难答言。世尊不听无净人为女人说法。优婆夷言。若不得多说者。得为我说五六语不。阿难答言。我不知得不。未敢便说。优婆夷言。和南阿阇梨。阿难言。疾患速除。言已便去。尊者阿难还至佛所。头面礼足却住一面。佛知而故问。阿难。汝从何来。阿难即以上因缘具白世尊。佛告阿难。毗舍佉鹿母是智慧人。阿难汝若为说五六语。彼病便差得安乐住。从今日后。听无男子得为女人说五六语。佛告诸比丘。依止舍卫城住者皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘无净人为女人说法。过五六语波夜提。除有知男子。比丘者如上说。无有知男子者。若盲若聋。亦名无净人。若一盲一聋。有此二人者得当一净人。虽有净人眠亦名无男子。女人者。若母若姊妹。若大若小在家出家。法者佛所说佛印可。佛所说者。佛口自说。佛印可者。佛弟子余人所说佛所印可。说者教诵解说五六语者。有二种长句短句。长句者一切恶莫作。短句者眼无常。除有知男子者。若减七岁不解好恶语义味。名为无知男子。虽过七岁不解好恶语义味。亦名无知男子。若七岁若过七岁。解好恶语义味。是名有知男子

复次有女人。清旦来礼塔。礼塔已来礼比丘足。白言尊者我欲闻法。愿为我说。比丘尔时得为说一偈半。是比丘入聚落。若更为先女人说五六语者。波夜提。世尊所以制五六语者。一日中得说。若比丘在阿练若处住。有女人来礼塔。礼塔已次来礼比丘足。白言尊者愿为我说法。比丘应语彼女人言。世尊制戒无净人不得为女人说法。女人白比丘言。我知佛法。如世尊所听愿为我说。比丘尔时得为此女说一偈半。若二女人得齐三偈无罪。若比丘入聚落教化。有众多女人来欲听法。各各得为说六句。应语第一女言。我为汝说六句。说已复语第二女言。我为汝说六句。如是众多无罪。比丘出已诸女送出。礼比丘足与别比丘。尔时若咒愿言使汝速尽苦际。得波夜提。若言使汝得无病安乐住者。无罪。出已复诣余家说法。先女人复随来在外遥听。比丘见已语言。汝复来听耶。答言尔。比丘言。汝深乐法可听。是比丘得波夜提罪。虽见此女人不共语。直为余女人说法。先女人虽闻无罪。若比丘为女人说法。时虽无净人在坐。听有作人行来住息。向外向内。或阁上阁下。遥相见闻者无罪。若俗人家向道。比丘在内为女人说法。虽无净人但路上行人不断得见闻者。亦无罪。若路上行人断无见闻者。不得为说。若有女人来礼塔。礼塔已白比丘言。尊者此是何等塔。愿语我名处。比丘尔时得语言。此生处塔。得道处塔。转法轮处塔。涅槃处塔。随所问事事得答。无罪。净人有四种。或见非闻。或闻非见。或亦见亦闻。或非见非闻。见而非闻者。眼遥见比丘。女人不闻语声。广说如是四句。见而不闻者得越毗尼罪。闻而不见亦如是。非见非闻波夜提。亦见亦闻无罪。是故说

佛住旷野城。广说如上。尔时有营事比丘。教众多童子句句说波罗耶那。时一婆罗门作是念。何处有善胜法。我当于彼出家。作是念已。便往旷野精舍欲求出家。见比丘教诸童子学诵。如似童子在学堂中受诵之声。时婆罗门作是念。我今欲求胜法从彼出家。而此中喡喡似如童子在学堂中学诵声。亦复不知何者是师谁是弟子。彼人见已生不敬信心。竟不见佛即便还归。不复出家。诸比丘以是因缘往白世尊。佛言。呼营事比丘来。来已佛问营事比丘。汝实尔不。答言。实尔世尊。佛言。此是恶事。汝云何教未受具戒人诵句法。从今日后不听为未受具戒人说句法。佛告诸比丘。依止旷野城者。皆悉令集以十利故为诸比丘制戒。乃至已闻者当重闻。若比丘教未受具戒人说句法。波夜提。比丘者如上说。未受具戒者。除比丘比丘尼。比丘尼虽受具足亦不得教。句法者。若句味字。句味字共诵。法者佛所说佛所印可。佛说者佛自说。佛所印可者。声闻弟子及余人说。佛印可之。诸善法乃至涅槃是名为法。教者为说示语。波夜提者如上说。若比丘教未受具戒人言眼无常声。一时举一时下一时断声。合为乐不遮。波夜提。耳鼻舌身意。十八界五阴六界。乃至诸法苦空无常非我亦如是。若比丘受共行弟子依止弟子八群经。波罗耶那经。论难经。阿耨达池经。缘觉经。如是等种种经。若共举共下共断。应如是教弟子言。汝待我诵断汝当诵。若如是教不受语者。不复得教。若彼弟子作是言。愿阿阇梨更授我经。师尔时应语言。若汝不复俱诵者我当授汝如是等弟子乃至优婆塞优婆夷不得授。若比丘共诵经上座应诵。下座心中默逐。若上座诵不利者下座应诵。上座应心默诵逐。乃至优婆夷亦如是。若僧中唱说偈时。不得同说一偈。得同时各各别说余偈。是故说

佛住舍卫城。广说如上。如第四戒妄语中事事因缘广说。但此中以说实为异。乃至佛语比丘。此是恶事。譬如淫女卖色自活。汝等亦尔。乃以微妙实法向人说。为口腹故卖色活命。佛告诸比丘。依止舍卫城住者尽集。以十利故与诸比丘制戒。乃至已闻者当重闻。若比丘自称得过人法。我如是知如是见。说实者波夜提。比丘者如上说。自称过人法。过人法如上说。若自言我法智耶。越毗尼心悔。若言我法智。越毗尼罪。若言我得法智作证。波夜提。句句如上广说。乃至十无学法。说实者波夜提。若比丘语女人言。某处夏安居比丘尽非凡夫。得越毗尼心悔。问言。尊者亦在中耶。答言。亦在中。得越毗尼罪。若优婆夷问言。尊者亦得此法不。答言得。说实者波夜提。若比丘语优婆夷言。某处自恣比丘非凡夫。皆是阿罗汉。得越毗尼心悔。优婆夷言。尊者亦彼间自恣耶。答言。如是。得越毗尼罪。复问。尊者亦得阿罗汉耶。答言得。说实者波夜提罪。若复言某处绳里比丘。王家大臣家长者家居士家汝家。为汝家眷属授经。比丘乃至如是去。比丘住坐卧。着如是衣。捉如是钵。食如是食。亦如是。若中国语向边地说。若边地语向中国说。若中国语向中国说。若边地语向边地说。若说义不说味越毗尼罪。若说味不说义越毗尼心悔。若说义说味得波夜提。非说义非说味无罪。若作书手相印。现义不现味得越毗尼罪。若现味不现义越毗尼心悔。现义现味偷兰遮。不现义不现味无罪。下至现阿罗汉相越毗尼心悔。是故说

摩诃僧祇律卷第十三摩诃僧祇律卷第十四

        东晋天竺三藏佛陀跋陀罗共法显译

    明单提九十二事法之三

佛住舍卫城。广说如上。尔时有居士。请众多知识比丘。是诸比丘中有一长老比丘。行摩那埵在下行坐。檀越优婆夷见已问言。尊者坐处先在上。今何故乃坐此中耶。答言得坐处便坐。何须问也。优婆夷言。我知尊者坐处。正应在此。我亦悉知诸尊者坐处。时难陀语优婆夷言。汝何故为呼汝阿阇梨在上座坐。汝阿阇梨小儿时戏犹故未除。优婆夷闻已心不欢喜作是念。我阿阇梨故当犯小小戒故在此下坐。即捉饭筐饮食掷地而去。作是言。尊者自于此中取食。作是语已入房里掩户一扇。而说偈言

  出家已经久　　修习于梵行
  童子戏不止　　云何受信施

诸比丘以是因缘往白世尊。佛言。呼难陀来。来已佛问难陀。汝实尔不。答言。实尔世尊。佛语难陀。此是恶事。梵行人中间放逸已还作如法。云何嗤弄向未受具戒人说其粗罪。从今日后不听向未受具戒人说他粗罪

复次佛住舍卫城。广说如上。时有乞食比丘。时到着入聚落衣持钵入城。次行乞食到一家舍。时男子即语女人言。汝施出家人食。女人问言。何道出家。答言。释种出家。女人言。我不与食。问言。何故不与。答言。此非梵行人。是故不与。比丘语女人言。姊妹我。是梵行人。女人言。尊者迦卢比丘。大名德人犹尚不能修梵行。汝今云何自言我是梵行人。比丘闻是恶语心怀愁恼。更不乞食即还精舍一日断食。断食故四大羸弱。往世尊所头面礼足却住一面。佛知而故问。汝今何故四大羸弱。以上因缘具白世尊。佛言。比丘汝何不语彼。纵令迦卢比丘非是梵行。何妨我修梵行。答言。世尊。我能向彼说。但世尊制戒。不得向未受具戒人说他粗罪。是故不说。佛言。善哉善哉。善男子。乃能不为命故违佛教戒。佛告诸比丘。是迦卢比丘在家出家人皆知非梵行。僧应与作非梵行羯磨。作法者应作是说。大德僧听。是迦卢比丘在家出家人悉知非是梵行。若僧时到僧忍听。说迦卢比丘非梵行。白如是如是。白三羯磨。佛问诸比丘。已与迦卢比丘作说非梵行羯磨未。答言已作

佛告诸比丘。依止舍卫城者皆悉令集。以十利故与诸比丘制戒。乃至已闻者当重闻。若比丘知他比丘粗罪。向未受具戒人说。除僧羯磨。波夜提。比丘者如上说。知者若自知若从他闻。粗罪者。四事十三事。未受具足者。除比丘比丘尼。虽比丘尼受具足亦不得向说。说者语前人令知。除僧羯磨。羯磨者若白不成就。众不成就。羯磨不成就。是不名羯磨。若白成就众成就羯磨成就。是名羯磨。世尊说无罪。波夜提者。如上说。若比丘知他粗罪。僧未作羯磨者。不得说彼粗罪。若有人问。某甲比丘犯淫饮酒者。应答言。彼自当知。若僧已作羯磨者。不得循巷唱说。若有问言。彼比丘犯淫饮酒者。比丘应问彼言。汝何处闻。答言。我某处闻。比丘应答言。我亦如是处闻。若比丘向未受具戒人。说比丘四事十三事。得波夜提。说三十尼萨耆九十二波夜提。越毗尼罪。说四波罗提提舍尼法众学威仪。越毗尼心悔。说比丘尼八波罗夷十九僧残。得偷兰罪。三十尼萨耆百四十一波夜提八波罗提提舍尼众学威仪。得越毗尼心悔。说沙弥沙弥尼十戒。得越毗尼罪。下至俗人五戒。得越毗尼心悔。是故说

佛住舍卫城。广说如上。尔时尊者陀骠摩罗子。僧羯磨典知九事。如十三事中广说。尔时有舍那粪扫衣不可分。是陀骠白僧作是言。是舍那粪扫衣不可分可与长老摩诃迦叶不。诸比丘咸言可与。是陀骠恐后有诤言故。即更于僧中唱言。是粪扫舍那衣与长老摩诃迦叶。如是三唱。唱已六群比丘从坐起作是言。阿谁言与。六群比丘为与不。汝作是唱非平等心。汝私相亲爱故。回僧物与诸比丘。以是因缘往白世尊。佛言。呼六群比丘来。来已佛问六群比丘。汝实尔不。答言。实尔世尊。佛语比丘。此是恶事。如是梵行人须汝皮肉血髓犹尚当与。况是粪扫衣不可分。僧中唱与而复还遮。汝先默然与时似贵人相。今还更遮似贱人相。此非法非律非如佛教。不可以是长养善法。佛告诸比丘。依止舍卫城者尽集。以十利故与诸比丘制戒。乃至已闻者当重闻。若比丘僧应分物先和合听与。后还遮者波夜提。比丘者如上说。僧者八种如上说。物者八种。时药乃至净不净。先听者先僧中分物共和合与。后遮者作如是言。长老随亲厚以僧物与。波夜提。波夜提者如上说。若僧中分物。僧伽梨郁多罗僧安陀会尼师坛覆疮衣雨浴衣腰带编绳钵小钵铜盂扇伞盖盛油革囊刀子革屣澡瓶。如是等一切应分物。来当次应取。若意不欲取者。听过不取若人问言。汝何以不取应答言。此非我所须。欲取余物。后来须者应取无罪。若行物者唱言。随意自恣取。比丘尔时随所须者得自恣取无罪。遮者有三种。或与已遮与时遮。未与遮。与已遮者得波夜提。与时遮得越毗尼。未与时遮者得越毗尼心悔。是故说

佛住。舍卫城。广说如上。尔时六群比丘半月诵波罗提木叉经时。诵四事时默然。十三事时嗔。三十事时便语。九十二事时便起作如是言。诸长老谁能持是戒用诵是。为诸天当能持此戒。不使诸比丘生疑悔。尔时诵波罗提木叉者惭愧。诸比丘以是因缘往白世尊。佛言。呼六群比丘来。来已佛问六群比丘。汝实尔不。答言。实尔世尊。佛言。此是恶事。如来欲饶益故。为诸弟子制半月说波罗提木叉。汝云何于中轻呵遮说。佛语比丘。此非法非律不如佛教。不可以是长养善法。佛告诸比丘。依止舍卫城者尽集。以十利故与诸比丘制戒。乃至已闻者当重闻。若比丘半月诵波罗提木叉经时。作如是言。长老用半月诵杂碎戒为。使诸比丘生疑悔。作如是轻呵戒者波夜提。比丘者如上说。半月者若十四日十五日。波罗提木叉者十修多罗也说者和合僧半月半月说。杂碎戒者。除四事十三事。余者是也。使诸比丘生疑悔者。得波夜提。波夜提者如上说。轻呵有三种。有未说时呵。有说时呵。有说已呵。未说时呵者。先语如是言。长老莫为说是杂碎戒。我欲疾疾竟故。是名未说呵。说时呵者。说戒时作如是言。长老用说是杂碎戒为。使诸比丘生疑悔。是名说时呵。说已呵者。说已作如是言。汝向说是杂碎戒。汝何故广说使我坐久疲极欲死。是名说已呵。未说时呵越毗尼罪说时呵波夜提。说已呵越毗尼心悔。是故说

  妄语及种类　　两舌以更举
  无净及句法　　过人说粗罪
  亲厚轻呵戒　　是初跋渠竟

佛住旷野精舍。广说如上。尔时营事比丘。自手斫树折枝弃自摘花果。为世人所嫌作是言。汝等看是沙门。瞿昙无量方便毁呰杀生赞叹不杀生。而今自手斫树采华伤杀物命。失沙门法。何道之有。诸比丘以是因缘往白世尊。佛言。呼营事比丘来。来已佛问比丘。汝实尔不。答言。实尔世尊。佛告比丘此是恶事。是中虽无命不应使人生恶心。汝等亦可少作事业舍诸缘务从今日不听自手斫断种子伤破鬼村。佛告诸比丘。依止旷野住者尽集以十利故与诸比丘制戒。乃至已闻者当重闻。若比丘坏种子破鬼村者。波夜提。比丘者如上说。种子者有五种根种茎种心种节种子种。是为五种。鬼村者树木草坏者斫伐毁伤。斫伐毁伤者波夜提。波夜提者如上说。根种者。姜根藕根芋根萝卜根葱根。如是等根种用火净若刀中析净。是名根种。茎种者。尼拘律秘钵罗优昙钵。罗杨柳如是比茎种应火净。若刀中析净。是名茎种。节种者。竹苇甘蔗。如是等当火净若刀中析净。若甲摘却芽目。是名节种。心种者。萝卜蓼蓝。如是比心生者当火净若手揉修净。是名心种子种者。十七种谷如第二戒中说。当作火净若脱皮净。是名子种。裹核种肤裹种。[穀-禾+卵]裹种[禾*會]裹种。角裹种鹦鹉喙。完出火烧。时种非时种水种陆种。先作更生种。裹核种者。呵梨勒鞞醯勒阿摩勒佉殊罗酸枣如是比应爪甲净去核而食。若欲合食核者当火净。是名裹核种。肤裹种者。秘钵罗破求优昙钵罗梨奈。如是等肤裹种应作火净。若熟时烂从树上自落。下时触木石等伤皮。如蚊脚者即名为净。不得合食子。若欲食者当火净。是名肤裹种。[穀-禾+卵]裹种者。椰子胡桃石榴。如是等[穀-禾+卵]裹种者当作火净。若破。是名[穀-禾+卵]裹种。[禾*會]裹种者。香菜苏荏。如是等若未有子手揉修净。若有子火净。是名[禾*會]裹种。角裹种者。大小豆摩沙豆。如是等若未成子手揉修净。若子成火净。是名角裹种。鹦鹉喙者。若鸟喙破落地伤如蚊脚。即名为净。去核得食。若欲食子者当火净。是名鹦鹉净。完出者。啖食已从粪中出。如牛马猕猴粪中出者。是名完出。即名为净。火烧者。若树果为野火所烧落地。即名为净。是名火烧净。时种者。谷时种谷麦时种麦。此种当用火净。若脱皮净。如拘驎提国土作谷聚。畏非人偷以灰火绕上作识。此即为净。如摩摩帝有仓谷未净。畏年少比丘不知法。使净人火净。至仓谷尽。比丘恒得语言。舂去不犯罪。是名时种。非时种者。谷至麦时。麦至谷时。应火净。若剥皮净。是名非时种。水种者。优钵罗花拘物头花香亭花。如是等根当火净。若刀中劈。是名水种。先作后生者。有粳米若萝卜根。当火净刀中劈。是名先作后生。陆种者。十七种谷。当脱皮净若火净。是名陆种。若自截若使人截。自破使人破。自碎使人碎。自烧使人烧。自剥皮使人剥皮。自截者若自方便截五种生竟日不止。得一波夜提。若中间息已更截。随息一一波夜提。使人截者。一方便语使人一日截。得一波夜提。若中间语言疾疾截。随一一语。波夜提。如是一切破碎烧剥皮四事。自作若使人作亦如是若为僧作知事人。一切不得语净人言截。是破是碎是烧是剥是。若尔者有罪。皆应言知是净是无罪。以五种生掷池水中。若井中若大小便中粪扫中。得越毗尼罪。若种烂坏者得波夜提罪。若比丘欲使草不生故。在中经行。行时得越毗尼罪。若伤草如蚊脚许。得波夜提。如是立坐卧亦如是。若以锥画树伤如蚊脚。得波夜提。若石上生衣比丘欲浣衣者不得自除却。应使净人知然后浣衣。若日炙干燥得自剥却无罪。若雨后材木着地。比丘不得自举。举者得越毗尼罪。若伤草如蚊脚许得波夜提。若净人先举比丘后佐无罪。若比丘僧伽梨郁多罗僧安陀会尼师坛枕褥革屣衣上生湄使净人知。着日中暴已得自揉修去。若饼上生湄。当使净人知已然后得食。若僧中行豆胡麻果蓏甘蔗。如是等上座应问作净未。若言未作应使作净。若言已作应食。若在一器中有众多果。若一果处作净。余者亦通得为净。若在异器者当别一一器作净。若甘蔗着叶者当茎茎别作净。若无叶者得合束。如果得总作净。若比丘在阿练若处住。夏安居中草生覆道。畏失道故揽两草相结。得越毗尼罪。若以余物结作识而去。还已解者无罪。若比丘在山中住。泥雨滑行欲倒地时。捉草挽断复更捉。如是比无罪。若为水所漂。若捉草随断。断亦无罪。若泥作时渴欲饮水者。若手有泥得树叶中饮。若无净人取叶者。得就树上生叶中饮。但不得挽令断。高不可得者。得捶树取干落叶取水饮。若比丘断新生青软叶。波夜提。若断长足坚强叶。波夜提。若叶已衰黄断者。越毗尼。若风吹三种叶落。取用无罪。若比丘摘生果波夜提。半熟者得越毗尼罪。熟取者无罪。若比丘道行夜宿时。挽生草枯草想。得越毗尼罪。干草生想得越毗尼罪。生草生想波夜提干草干想无罪。若城若聚落中。有人祠树枝叶。虽燥皆不得折取。折者得越毗尼罪。树木四句亦如上生草中说。若比丘大小行须水者当诣池水。水中若有浮萍遍满水上。欲取水用者。不得以手拨开取水用。当觅牛马行处若蛇若虾蟆行处。若无诸行处者捉土块仰掷。作如是言。至梵天上去。若块石下时打水开处。得用无罪。若翻覆水中浮萍草。得越毗尼罪。若捉掷岸上得波夜提。入水浴时水草着身者。当以水浇令下入水。若断朝菌得越毗尼罪。若拾干牛屎时。合生草者波夜提罪。是故说

佛住拘睒弥。广说如上。尔时僧集欲作羯磨事。尊者阐陀不来。僧遣人语阐陀言。僧集欲作羯磨事。长老来。阐陀作是念。今唤我者正当欲治罚我罪。更无余事。复作是思惟。我今当扰乱阿谁。能使一切僧皆共扰乱不得作羯磨。正当扰乱尊者大目揵连可办此事。然目连有大神力知我不可。或能捉我掷他方世界。此事不可。复更思惟。若扰乱大迦叶者可办此事。然大迦叶有大威德。或能于众中折辱我。此事不可。复作是念。尊者舍利弗心柔软质直易共语。若扰乱彼者。可使一切僧扰乱不得与我作羯磨。阐陀来入僧中已。作如是言。尊者舍利弗我欲问义。舍利弗言。今为余事集僧此非问义时。阐陀复语尊者舍利弗言。如佛正法。无有非时。得现法中善果除烦恼热。诸贤圣悦可尽不择。时尊者舍利弗言。听所问。阐陀言。世尊说四念处。何等是四念处。时尊者舍利弗为说四念处。阐陀复言。我不问四念处。我问四正勤长老但为我说四正勤。舍利弗言。汝欲闻四正勤者听。即为说四正勤。阐陀复言。我问四如意足。如是五根五力七觉分八圣道分。如四念处反覆三问。时诸比丘坐久疲乏。各各散出僧不和合。遂不成羯磨。诸比丘以是因缘往白世尊。佛言。呼阐陀来。来已。佛问阐陀。汝实尔不。答言。实尔。佛言。阐陀。此是恶事。我常不为汝无量方便呵责扰乱语赞叹随顺语耶。汝今云何作扰乱事。此非法非律不如佛教。不可以是长养善法。佛告诸比丘。依止拘睒弥者皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘异语恼他。波夜提。比丘者如上说。异语恼他有八事。何等八。一者作羯磨时。二者如法论时。三者论阿毗昙时。四者论毗尼时。五者不异论。六者不异人。七者停论。八者异语恼他。作羯磨者。比丘和集作折伏羯磨。乃至别住羯磨。是名作羯磨。如法论者。说非常非断。是名如法论。阿毗昙者。九部修多罗。是名阿毗昙。毗尼者。广略波罗提木叉。是名毗尼。不异论者。不得离本所论更论余事。是名不异论。不异人者。不得离先问人更问余人。是名不异人。停论者。当说法时语言住后当更论。是名停论。异语恼他者。如尊者阐陀异语恼他。是名八事。于中异语恼他者波夜提。离此八事非波夜提。若人问比丘言。从何处来。答言。过去中来。何处去。答言。向未来中去。何处眠。八木上眠。汝今日何处食。答言。五指食。如是问不正答者。越毗尼罪。若贼来入寺中问比丘言。示我僧物。比丘尔时不得示珍宝等诸物。复不得妄语。应示房舍床座等。贼若言示我塔物。亦不得示塔宝物。复不得妄语。应示塔边供养具诸器物等。贼若言示我净厨。比丘不得妄语。复不得示钱物处。应示釜镬盆器等。若屠家畜生走。问比丘见不。比丘不得妄语。复不得示处。应言。看指押看指押(梵音与不见同)若比丘在阿练若处住。有囚逃走问比丘。如上畜生中答。若比丘僧中问异答异。得波夜提。众多人中和上阿阇梨前。诸长老比丘前。问异答异。得越毗尼罪。是故说

佛住舍卫城。广说如上。尔时世人信敬深厚。多持饮食供养世尊。并奉众僧。尊者舍利弗目连。供佛者侍者收摄。与众僧及舍利弗目连者。或行或不行。无人料理停置臭秽。尔时尊者陀骠在学地。作是念。若我得无学者当营理僧事使得安乐。作是念已。初夜后夜精勤行道。即成阿罗汉。得三明六通已作是念。我何须作有为事。我应当修习乐于少欲无事。佛语陀骠。汝本在学地时。作如是言。我若得无学者当料理僧事。汝作如是语不。答言。实尔世尊。佛言。陀骠。如汝先愿。今者应作。答言。当如世尊教。尔时僧即拜知九事如先说。尔时随宜差食。若是长老上座与上食。中坐与中间食。下座与粗食。六群比丘怨情嫌恨。以是事往白世尊。佛语陀骠。凡出家人法应平等与食。汝当知得少不足得多者亦无厌。得好得恶俱不周悉。于是长老陀骠即作三品食。精粗次第周而复始。尔时难陀优波难陀。晨起着入聚落衣持钵往至食家。语优婆夷言。与我食。优婆夷言。尊者。食时未至。我未得洗面及洗器物。未得作出家人食。时檀越妇女弱小方起。澡浴裸露形体者。时难陀比丘不摄诸根纵看女色。优婆夷作是念。此比丘非毗尼人或生过恶。不中久停。且与作人粗食速遣令去。作是念已。即与作使人粗食。是比丘得食已即还精舍。尔时有长老比丘。时到着入聚落衣持钵。威仪庠序往至食家。檀越施种种美食满钵而还。时难陀优波难陀见已作如是言。长老陀骠世尊说平等分食。观此二食为平等不。陀骠言。汝往太早。非是食时。明日难陀着入聚落衣持钵入城。路中看象斗马斗。听俗人言论。时优婆夷念言。阿阇梨昨日来不得食。今应早办。檀越家作食久办。至时不来。优婆夷复作是念。尊者昨日来早。今日何故不来。祇洹精舍中或有供僧。是故不来。即共夫主小儿食尽。时难陀逼中方来。语优婆夷言。与我食。优婆夷言。我作食早办待尊者不来。谓祇洹中有人供僧。谓受彼请。此所供食我已啖尽。难陀语言。汝欲断我食耶。尔时优婆夷即以家中作人残宿食与之。得已还诣精舍。广说如上。陀骠言。汝去太晚。时尊者陀骠以是因缘往白世尊。佛言。呼难陀来。来已。佛问难陀。汝实尔不。答言。实尔世尊。佛言。此是恶事。汝常不闻我以无数方便毁呰多欲赞叹少欲。此非法非律非如佛教。不可以是长养善法。佛告诸比丘。依止舍卫城住者皆悉令集。以十利故与诸比丘制戒。乃至已闻者当重闻。若比丘嫌责者波夜提。比丘者如上说。嫌责者。若拜人拜嘱人拜嘱嘱人。拜人者如尊者陀骠。是名拜人。拜嘱人者如陀骠摩罗子。倩余人料理僧事。是名拜嘱人。拜嘱嘱人者。所倩人复转倩人料理僧事。是名拜嘱嘱人。嫌责是人者得波夜提。波夜提者如上说。若僧中行种种饼。当次第来应取。若意中不欲者令过去。若净人问何以不取。答言。戒不用是。欲更取余者无罪。若行乳粥酪粥胡麻粥鱼肉粥。若行如是种种粥时。若满杓与上座。上座不应便受。上座应言。平等与。若行肉时偏与上座多者。上座应问。一切尽尔耶。答言。止与上座多耳。上座应语。平等与。若不须多者少取。少取已语余人平等与。如是好食应平等与。若沙弥行食时偏与师者。知事人应言。平等与。若沙弥言。汝何以不自行。是知事人应推此沙弥出。更使余人行。若行食人见僧中大德人便多与。余人便少与。知事人应语行食人言。僧中无高下汝平等与。或有嫌而非呵责。或有呵责非嫌。或亦嫌亦呵责。或非嫌非呵责。嫌而非呵责者。持己器中食比比坐器中食。作如是言此平等不。是名嫌而非呵责。如是四句广说。嫌而不呵责得越毗尼罪。呵责而不嫌者得越毗尼罪。亦嫌亦呵责者得波夜提罪。非嫌不呵责无罪。是故说

佛在跋只国人间游行。与比丘众俱至一故河边。时诸捕鱼人捉网捕鱼。诸比丘见已白佛言。世尊。是捕鱼人不应作是事而勤作世尊因诸比丘问已。即说偈言

  已得难得身　　云何作诸恶
  染爱着身故　　命终入恶道

时捕鱼人捉大网。沈石浮瓠顺水而上。边各二百五十人。叫唤挽网向岸。诸比丘见已白佛言。世尊此人若于佛法中如是精进者。大得法利。尔时世尊。因事说偈言

  所谓勤精进　　非名一切欲
  谓能离众恶　　以法自活命

如迦毗罗本生经中广说。尔时众鱼堕网中。有一大鱼。有百头。头头各异。世尊见之便唤其字。即应世尊。世尊问言。汝母在何处。答言。某圊厕中作虫。佛言。此大鱼。迦叶佛时作三藏比丘。恶口故受杂类头报。母受其利养故作厕中虫。佛说此因缘。时五百人即止网出家修道。皆得罗汉。住跋渠河边。佛告阿难。为此诸客比丘敷床座。乃至阿难白佛。愿佛安慰客比丘。佛告阿难。汝自不知我已入四禅中安慰客比丘。尔时各在露地敷床褥欲乞食。时至此诸比丘各以神力。有至北郁单越者三十三天者。龙王宫乞食者。床褥在露地日炙风飘尘坌污秽。佛知而故问。诸比丘以上因缘具白世尊。佛言。待此诸比丘来。来已。佛问诸比丘。汝实尔不。答言。实尔。佛言。从今日因汝为诸比丘制戒。佛告诸比丘。依止跋渠河者皆悉令集。以十利故与诸比丘制戒。乃至已闻者当重闻。若比丘僧住处。露地卧床坐床褥枕。若自敷若使人敷。去时不自举不使人举。波夜提。比丘者如上说僧住处者。若阿练若住处。若聚落住处。卧床坐床者。有十四种。团脚卧床团脚坐床。卧褥坐褥开藤卧床开藤坐床。乌那陀卧床乌那陀坐床。陀弥卧床陀弥坐床。褥者。劫贝褥毛毳褥。毡褥迦尸褥。草褥。枕者。劫贝枕。毛毳枕。毡枕。迦尸枕。敷者。若自敷若使人敷。去者余行。不举者。不自举不使人举。波夜提。波夜提者如上说若欲露地说法者知床褥人敷床褥已若去离二十五肘不嘱者波夜提罪若二人共知者一人欲行时。应嘱第二人。第二人欲行者。应待第一人还付嘱已然后当去。若敷床褥讫有后人来坐知敷人得舍去无罪。若春月露地敷置。年少比丘坐上眠。即嘱彼比丘。若床上无比丘者。若比丘夜起大小行触僧床一一触已舍去。随所触一一得波夜提。若是床上有比丘者。即嘱彼人无罪。若僧知事人欲付床褥故。出着露地舍离二十五肘。得波夜提。若受得僧床褥暴晒时。舍去离二十五肘亦波夜提。若比丘病在露处眠。弟子来礼师。若师起去弟子应举覆处。若有二人共坐一床。若上坐欲去时应嘱下坐。下坐欲去时应白上坐言。我欲去此床当举何处上坐若言。汝自去此床我自当举。尔时去无罪。若比丘为和上阿阇梨。敷床褥已而去者越毗尼罪。若和上阿阇梨知为我敷。去时应嘱。若不嘱去者越毗尼罪。二十五肘者得极大粗雨时不彻。两重衣故也。若比丘众僧床上安形像。余比丘来礼拜。手触而不举者波夜提。若众多比丘次第礼拜。手触属最后者。或嘱授非是属。或属非是嘱授或亦嘱亦属。或非嘱非属。嘱而非属者沙弥是。属而非嘱者上座比丘是。亦嘱亦属者下座比丘是。非嘱非属者俗人是。若大德比丘多有弟子。为敷床褥。若师知为己敷。去时应嘱人举不嘱者得越毗尼罪。若众僧床褥在众僧住处露地敷。去时不举者得波夜提。众僧床褥在私住处露地敷。去时不举越毗尼。若私床褥在僧露地敷。去时不举得越毗尼罪。若私床褥在私露地敷。去时不举越毗尼罪僧床褥在白衣家敷。去时不举者越毗尼罪若俗人床褥在露地敷去应语令知。是故说。佛住舍卫城。广说如上。时有婆罗门。宿请众僧供食施衣诸比丘僧房内敷僧坐具不收敛便径去世尊以五事利益故。五日一行诸比丘房。见诸比丘房内敷具上。有虫鼠粪秽尘土不净。佛知而故问。诸比丘以是因缘具白世尊。佛告诸比丘。汝等出家人更无给使为汝料理后事。去时何故不举。此非法非律不如佛教。不可以是长养善法。佛告诸比丘。依止舍卫城住者尽集以十利故与诸比丘制戒乃至已闻者当重闻。若比丘内覆处自敷床褥若使人敷去时不自举不使人举波夜提。比丘者如上说。内者是覆处。床座者十四种如上说。枕褥者亦如上说。敷者若自敷若使人敷。去者余处去。不自举者不自举。不使人举者不使他人举。波夜提。波夜提者如上说。若比丘欲余行去时。房舍内水洒扫地令净。以巨磨涂地。褥枕晒令燥语知床褥人作如是言。长老是床褥枕。一切应付嘱示语。若知床褥人是下座者应语言。当摄此床褥。答言尔。若上座者付嘱此床褥。答言尔。去不白者波夜提若不白去时。有比丘即入房住。不空故得越毗尼罪。若已去忘衣钵。还来取而白者无罪。若比丘随道行天阴欲雨。年少比丘先去往至精舍。为和上阿阇梨取床褥已。天晴欲去者当白若不白去者波夜提。若众多比丘在聚落精舍中宿。共受僧床褥。各各作是念。某甲故当付嘱。去已道中展转相问。都无嘱者。诸比丘当差遣二人还付嘱。若比丘在路行至精舍中宿。去不嘱床褥。行远已转展相问。尽无付嘱。道逢比丘即问言。长老欲何处去。答言。我欲到某处。是比丘即白言。我昨夜彼宿。来时忘不嘱床褥。长老到彼当为我付嘱。是比丘复言。我来时亦忘不付嘱。长老往彼精舍为我付嘱。如是二人展转相嘱已。乃至齐入精舍界。得名嘱授。若比丘在俗人家宿。得床褥卧具。去时应示语去。若得草敷者。去时应语言。此草欲安何处。随主人语应安之。若檀越言但去我自当料理。比丘应小敛一角而去。若比丘行路挽乱草敷坐。去时聚已当去。是故说

佛住舍卫城。广说如上。时有客比丘。来到六群比丘房里。六群比丘言。善来长老。作是语已与洗脚水涂足油非时浆止息已语客比丘言。长老汝欲何处住。答言。此房中住六群比丘言汝知此是谁房。答言。我知是众僧房六。群比丘言。此虽僧房。我等六群比丘已先在此住。客比丘言。此是四方僧房。纵使十六群比丘先在中住。我亦当依次而住。何况六群比丘。六群比丘语比丘言。若长老欲住便住。客比丘住已。六群比丘即各各捉其手脚。或捉头高举欲出之。时世尊以神足在虚空中来。六群比丘见世尊已即扑地而去。佛语客比丘汝但在房中住。复次尊者难陀是优波难陀兄难陀共行。弟子乃至驱出房。出房已弟子大呼。诸比丘闻声已皆惊出看。作如是言。此比丘今日失二种利断食失房。如是诸比丘以是因缘往白世尊。佛言。呼六群比丘来。来已。佛问难陀优波难陀。汝实尔不。答言。实尔。佛言。汝等云何于四方僧房中住。牵出客比丘。此是恶事。汝常不闻我无量方便赞说于梵行人所应修慈身行修慈口意行修慈常供养供给耶。此非法非律非如佛教。不可以是长养善法。佛告诸比丘。依止舍卫城住者皆悉令集。以十利故与诸比丘制戒。乃至已闻者当重闻

若比丘在僧房内。若自牵出若使人牵出乃至言比丘汝出去。作是语者波夜提。比丘者如上说。若比丘牵比丘出时彼比丘若抱柱。若捉户。若倚壁。如是牵离一一处。一一波夜提。若口呵叱遣彼比丘随语离一一处者。一一波夜提。若方便驱直出门者。得一波夜提。若比丘嗔恚蛇鼠驱出。越毗尼罪。若作是言。此是无益之物驱出无罪。若骆驼牛马在塔寺中。畏污坏塔寺驱出者无罪。若比丘驱比丘出波夜提。若驱比丘尼出偷兰遮。若驱式叉摩尼沙弥沙弥尼。得越毗尼罪。下至驱俗人出。越毗尼心悔。是故说(十六竟)

摩诃僧祇律卷第十四摩诃僧祇律卷第十五

        东晋天竺三藏佛陀跋陀罗共法显译

    明单提九十二事法之四

佛在拘睒弥人间游行。尔时世尊初夜为诸声闻说法。说法已是诸比丘各各还住房。时六群比丘于余处谈话。经久乃还扣房户。房内人问言谁。答言我是六群比丘。欲此间宿房内比丘言。此房已满六群比丘复更软语。苦求与我少许。容一坐处。如是苦求不得。复至余房亦复不得。复到诸下座比丘宿处。若温室若禅坊若讲堂扣户。堂内比丘问谁。六群比丘言。我欲来此宿。堂内比丘言。此堂已满。六群比丘复重苦求不止。堂内比丘即为开户。得入房已趣纵横身床上而卧。或以手肘膝叉筑边人。又作是言。诸长老作一色去。作是语已即吹灯灭。更唤外伴比丘言。诸梵行人可来入。来入已。在前者膝头蹴在后者肘头筑。放气调戏。诸比丘作是念。谁能共此非威仪人共在一处。即持尼师坛出去。诸比丘以是因缘往白世尊。佛言。待我从憍萨罗行还舍卫城时更白此事。当为诸比丘制戒。复次佛住舍卫城。广说如上。先客比丘次得六群比丘房宿。夜闭户眠。时六群比丘协先嫌故。盗以滑埿涂户阃上。当行处着滑埿及塼石。此比丘夜出脚蹈滑处倒塼石上。作如是言。诸长老六群比丘杀我折我颈故。作如是事欲扰乱我。谁能共此住。诸比丘以是因缘往白世尊。佛言。呼六群比丘来。来已佛问六群比丘。汝实尔不。答言。实尔世尊。佛言。此是恶事。诸比丘白佛言。六群比丘非但此一恶事。世尊在憍萨罗国游行时。扰乱诸比丘。乃至各各持尼师坛出去。佛问六群比丘。汝实尔不。答言实尔。佛言。汝云何知他先敷置。后来扰乱欲使他去。此是恶事。非法非律非如佛教。不可以是长养善法。佛告诸比丘。依止舍卫城者皆悉令集。以十利故与诸比丘制戒。乃至已闻者当重闻。若比丘知他比丘先敷置床褥。后来欲扰乱故敷置。作是念不乐者自当出去。作如是因缘不异者波夜提。比丘者如上说。知者若自知若从他闻。先敷者是初敷也。床褥者如前说。后来敷置者。欲扰乱使他出故。作如是因缘不异者波夜提。波夜提者如上说。若住处少。一比丘当一柱间敷床褥尼师坛。覆上已向和上阿阇梨。或礼拜问讯或受诵去。后比丘来却先尼师坛。自敷尼师坛。坐已作细声呗。先住比丘来见已作是念。谁能断他法。即自持尼师坛去。是比丘波夜提罪。坐禅诵经病亦如是。若后来眠他床上。若是上座者应语言。长老不知世尊制戒耶。若眠比丘是下座者应呵责。汝不善知戒相。汝不知世尊制戒。云何后来眠他床上。若比丘在他处经行者。见先比丘来应当避去。若比丘夜眠时虽振动[穴/(爿*臬)]语。不作扰乱意无罪。扰乱比丘波夜提。比丘尼偷兰遮。式叉摩尼沙弥沙弥尼。得越毗尼罪。俗人得越毗尼心悔。是故说

佛住旷野精舍。有二比丘共住。上座阁下下座阁上。上座坐禅下座诵经。上座时到着入聚落衣持钵。入旷野聚落乞食。疾得速还。下座方去。上座食已澡钵举置常处。洗足结跏趺坐。下座晚得食乃还。还已上重阁上置钵常处。并作是言嘘极即纵身而坐。床脚下脱即伤上座头。头血流出。上座作如是言。杀我杀我。诸比丘闻声已即来聚集。问何故如是上座具说其事。诸比丘以是因缘往白世尊。佛言呼彼比丘来。来已佛问比丘。汝实尔不。答言实尔。佛问比丘。汝云何阁上敷尖脚床用力坐。从今日后不听阁上敷尖脚床坐。佛告诸比丘。依止旷野住者皆悉令集。以十利故为诸比丘制戒。乃至已闻者当重闻。若比丘在阁屋上敷尖脚床。若坐若卧波夜提。比丘者如上说。阁者第二重。屋者如世尊所听。尖脚者如橛。床者有十四种如上说。若坐若卧波夜提波夜提者如上说。若以埿土作地坚牢。若板作密若圆脚若边阁。阁下无人坐皆无罪。若疏作地尖脚卧床坐床。若坐若卧者波夜提。若反床而坐者。得越毗尼罪。若着横椅越毗尼罪。若一脚尖三脚圆波夜提。如是若二若三四脚尖波夜提。四脚圆无罪。是故说

佛住旷野精舍。时营事比丘以虫水浇草埿。为世人所讥。沙门瞿昙无量方便。毁呰杀生赞叹离杀。而今沙门以虫水浇草埿。此是败坏人何道之有。诸比丘闻已以是因缘往白世尊。佛言。呼营事比丘来。来已佛具问上事汝实尔不。答言。实尔世尊。佛言。此是恶事。正应为世人所嫌。此非法非律非如佛教。不可以是长养善法。从今日后不听虫水浇草埿。佛告诸比丘。依止旷野精舍住者皆悉令集。以十利故为诸比丘制戒。乃至已闻者当重闻若比丘知虫水浇草埿。若使人浇波夜提。比丘者如上说。知者若自知若从他闻。虫者乃至微细有命。水者有十种如上说。草者茅芒等。埿者草埿[卄/告]埿象马屎埿牛屎埿等。浇者自浇使人浇。波夜提者如上说

若比丘知水有虫。方便浇一息一波夜提。随息多少一一波夜提。使人浇者。一方便语一波夜提。若更语疾疾浇。语语波夜提。若比丘营作房舍温室者须水。若池若河若井漉取满器。看无虫然后用。若故有虫者当重囊漉之谛观。若故有虫者乃至三重。若故有虫者当更作井如前谛观。若故有虫者当舍所营事至余处去。漉水法当交竖三杖缚上头。以漉囊系之以器承下。漉囊中恒停水数到着井中。虫生无常或先无今有。或今有后无。是故比丘日日谛观无虫便用。若比丘知虫水浇草浇埿。若自浇教人浇。得波夜提若用有虫水与和上阿阇梨洗浴。得波夜提若洗器水米[泳-永+(米*番)]一切浆苦酒。诸有虫者用浇草埿。得波夜提是故说

佛住拘睒弥广说如上。尔时尊者阐陀劝化作房。时阐陀集覆屋具。草木竹等办已。往语覆屋师言。我众事已办。与我覆屋覆屋人言阿阇梨与我食直作价。尔时阐陀随其价直而断与之。时作人即往诣屋所。阐陀语作人此是覆屋具覆屋人言。覆屋有三种厚薄不同。欲作何等覆阐陀言。汝用问三种厚薄为现所有草尽当用覆覆屋人言。当有齐限。那得尽用。如是至三屋师复言一切世间皆有法限。如法限者世所称赞。阐陀言。但尽用覆。何须多言。师如其言尽用覆之。草多厚故系缚不禁。始得时雨悉皆断解。如华开敷竟夜被雨衣钵尽湿。阐陀清旦往到屋师所作如是言。汝云何为我覆屋。乃至如是。覆屋人言。何以故。阐陀言。竟夜被雨衣钵尽湿。覆屋人言。我先不语阿阇梨。覆屋有三种厚薄不同。乃至随语一切尽与阐陀言。汝当更为我覆覆屋人言。更与我食直作价。阐陀言。价直汝先已得。屋师言。先已得者先已作讫。若欲更作者价三倍于先。乃至阐陀自恃王力。强使更覆而不与直。阐陀复自绕其房苦言呵责。时有行人。屋师语言。诸人看是沙门释子恃王力势。强使我作而不与直行人即嫌。云何释子恃王势力。强使人作而不与价。甚为不可。自绕其屋犹如盘马伤杀生草。此败坏人何道之有。诸比丘以是因缘具白世尊。佛言。呼阐陀来。即呼来已佛问阐陀。汝实尔不。答言实尔。佛告阐陀。此是恶事。非法非律不如佛教。不可以是长养善法。佛告诸比丘。依止拘睒弥住者尽悉令集。以十利故为诸比丘制戒。乃至已闻者当重闻。若比丘作大房施户牖。经营齐再三覆。当于少草地中住。若过者波夜提。比丘者如上说。作者若自作若使人作。大者过量。房者世尊所听。作户者通人出入处。牖者通明处。经营者教语指授。覆者有十种。若草若埿若板若石灰若阿槃头国。覆摩竭提国。拘睒弥国。山国。恭敬国覆。藏语国覆再三者。非五六极齐三。少草地者少生草处。波夜提者如上说。雇覆屋人断价时。当如实价不得高下。应语作人言汝若如是知覆。当与如是价若不如是知覆。不与如是价。如是要令分明。三处分已。比丘作是念。当作方便持草木竹往彼。彼若见我当疾好覆屋师见已好不好。得波夜提。如是作方便。欲使屋师见故。往礼拜和上阿阇梨。受经诵读。若经行若入聚落。屋师见我已当疾好覆。见已好不好。俱得波夜提如是一切作方便。得波夜提。若不作方便。往见已为好疾覆无罪。是故说

  种子及异语　　嫌责露地敷
  内敷并牵出　　先敷置重阁
  虫水作大房　　第二跋渠竟

佛住舍卫城。广说如上。尔时长老比丘次第教诫比丘尼。时难陀优波难陀不得次第教诫。自相谓言。诸长老比丘悉次第教诫比丘尼。我等不得次第教诫。我等今当自先往教诫即作是念。我当依谁次第而去当依大目揵连次第而去。彼尊者有大神力。脱不可者或捉我等远掷他方世界。当依尊者大迦叶次第而去。彼尊者有大威德若不合理或能在大众中摧辱我等。尊者舍利弗柔软和雅。当依其次。作是念已即依其次。清旦着衣往诣比丘尼精舍。作如是言诸姊妹和集。我等来相教诫。时诸比丘尼即集众。彼难陀比丘多闻辩才善能说法。即为比丘尼众随宜说法。时尊者舍利弗教诫时到。着衣诣比丘尼门屋下住。闻说法声。时诸比丘尼遥见尊者舍利弗。以恭敬法故不起迎逆。时尊者舍利弗见是事已。即作是念。我今为不断法故。即还往诣佛所。头面礼足却住一面。佛知而故问舍利弗。汝已教诫比丘尼耶。答言。不教诫世尊。佛言何故。舍利弗以上因缘具白世尊。佛言。呼难陀优波难陀来。即呼来已。佛问难陀优波难陀。汝实尔不。答言。实尔世尊佛言汝云何僧不差而教诫比丘尼。此非法非律不如佛教。不可以是长养善法。佛告诸比丘。依止舍卫城住者皆悉令集。以十利故为诸比丘制戒。乃至已闻者当重闻。若比丘僧不差而教诫比丘尼者。波夜提。比丘者如上说。不差者僧不作羯磨名不差。十二事不成就者不名为差。众不成就。白不成就。作羯磨不成就亦名不差。教诫者若阿毗昙若毗尼。波夜提者如上说。若比丘僧不差。教诫比丘尼者。波夜提。是故说

佛住舍卫城。广说如上。时长老比丘次第教诫比丘尼。时尊者难陀次第教诫比丘尼。而不肯去。尔时大爱道憍昙弥比丘尼。往至佛所头面礼足白佛言。世尊。尊者难陀次应教诫比丘尼。而不肯去。谁当应去。作是语已头面礼佛足而去。佛语比丘呼难陀来。来已佛问难陀。汝次应教诫比丘尼。何故不去。难陀白佛言。世尊。未被僧羯磨。是以不去。佛语诸比丘。有十二事成就。僧当拜作教诫比丘尼人。何等十二。一持戒清净。二多闻阿毗昙。三多闻毗尼。四学戒。五学定六学慧。七能为人除恶邪。八能自毗尼能毗尼他。九有辞辩。十不污梵行。十一不坏比丘尼重禁。十二二十腊若过二十腊。是为十二法。羯磨人应作是说。大德僧听。尊者难陀十二法成就。若僧时到。僧拜难陀作教诫比丘尼人。如是白。大德僧听。尊者难陀十二法成就。僧今差难陀教诫比丘尼。诸大德忍难陀教诫比丘尼者默然。若不忍者便说。僧已忍差难陀教诫比丘尼竟。僧忍默然故是事如是持。尔时尊者难陀为诸比丘尼广说法。遂至日没。诸比丘尼逼暮还入城。为世人所嫌。作是言。沙门释子将是比丘尼竟日自娱乐。日没乃还。女人可愍不得自在。乃至如是此坏败人何道之有。诸比丘闻已以是因缘往白世尊。佛言。呼难陀来。来已佛问难陀。汝实尔不。答言实尔。佛语难陀。此是恶事非法非律非如佛教。不可以是长养善法。佛告诸比丘。依止舍卫城住者皆悉令集。以十利故与诸比丘制戒。乃至已闻者当重闻。若比丘僧差教诫比丘尼。从日没乃至明相未出者。波夜提。比丘者如上说。僧差者。十二法成就。众成就白成就羯磨成就。教诫者若阿毗昙若毗尼。冥者从日没至明相未出。波夜提。波夜提者如上说。日没作未没想教诫者越毗尼。日未没作没想得越毗尼。日没作没想波夜提。日未没作未没想无罪。明相四句亦如是。比丘尼式叉摩尼想教诫。得波夜提。式叉摩尼作比丘尼想。得越毗尼罪。式叉摩尼作式叉摩尼想教诫无罪。比丘尼作比丘尼想教诫波夜提。沙弥尼。外道出家尼。优婆夷。四句亦如是。若比丘尼夜礼比丘足。比丘言苦尽解脱者波夜提。若言善来者无罪。若一切四部众会竟夜说法时。比丘作方便。欲为比丘尼说大爱道出家经。黑瞿昙弥经。法豫比丘尼经者。得波夜提罪。若正诵此经更不知余经。次第诵者无罪。若夜比丘在高座上。说法时作如是言。一切众坐明听者。得波夜提。若不作是言为说者无罪。是故说

佛住舍卫城。广说如上。时诸长老比丘次第教诫比丘尼。时六群比丘作是念。诸长老比丘次第教诫比丘尼。我等不得。我等当先在前去教诫比丘尼。有言世尊制戒。僧不差不得教诫比丘尼。六群比丘言。我等知作羯磨事。即便出界作羯磨。展转相拜已。即往比丘尼精舍。作如是言。姊妹汝等和合僧我当教诫。时六群比丘尼疾疾集。时众中如法者作如是言。谁能受此非毗尼人教诫。时六群比丘尼即自聚集。论说俗事已便去。时尊者难陀到时着衣。往比丘尼精舍作如是言。诸比丘尼尽集我当教诫。时诸善比丘尼即和合。六群比丘尼不来。难陀问言。比丘尼僧和合未。答言未复问谁不来。答言。六群比丘尼不来。即遣使往唤。复不来。作如是言。我等先已从六群比丘受教诫。难陀言。尼僧不和合者不得教诫。言已便还。到世尊所头面礼足却住一面。佛知而故问。汝已教诫比丘尼耶。难陀即以上因缘具白世尊。佛言呼六群比丘来。来已佛具问上事。汝实尔不。答言实尔。佛言。六群比丘汝云何僧不差而教诫比丘尼。答言。我等已受差竟。佛言。痴人谁差汝等。答言我等出界自展转相差。佛言从今已去。不听界外展转相差往比丘尼精舍

复次佛住舍卫城。大爱道瞿昙弥病。时尊者阿难往问讯如是言。体力何如。所患损不。不至增耶。答言。尊者苦患无损。善哉尊者为我说法。阿难言。世尊制戒。不白界内比丘不得为比丘尼说法。比丘尼言。和南。尊者答言。安隐住。作是言已便还往世尊所。头面礼足却住一面。佛知而故问。阿难即以上事具白世尊。佛言。汝若为说法者。彼病即差身得安乐。从今日后听为病比丘尼说法。佛告诸比丘。依止舍卫城住者皆悉令集。以十利故与诸比丘制戒。乃至已闻者当重闻。若比丘往比丘尼住处。欲教诫不白善比丘。除余时波夜提。余时者病时。比丘者如上说。教者教诏也。善比丘者界内现前非眷属现前。不白者。若言我非时入聚落。若言离同食。是不名为白。白者当作如是言。长老忆念白。入比丘尼精舍教诫。彼应言莫放逸。除余时。余时者比丘尼病时世尊说无罪。波夜提者如上说。若二人在阿练若住处。若一人欲入比丘尼精舍。当白第二人作是言。长老忆念白。入比丘尼精舍教诫。彼应言莫放逸。答言。顶戴受。若二人俱欲往者。当展转相白。若一人已往。一人后复欲往者。当作如是念。我若道中见比丘当白。若聚落中见者当白。若到比丘尼精舍门。不得即入。应问有比丘在内不。若有唤来出白。白已当入。若不白一脚入门得越毗尼罪。若二脚入者得波夜提。若比丘尼请比丘食。众僧上座应作如是白。入比丘尼住处教诫去。若第一上座不能答对者。第二上座应白。若僧已入坐。比丘尼问事。众中年少比丘有辩才。现前答对说法者无罪。若比丘尼比丘住处隔墙相接。比丘作细妙声呗。比丘尼遥问言。尊者谁能作如是呗。答言我呗。比丘尼言。尊者能作如是好呗。比丘言。汝欲更闻耶。答言欲闻。比丘即更呗者波夜提罪。若比丘尼病。比丘为呗者无罪。若此比丘尼已死。比丘尼弟子语比丘言。师已死。比丘应即止。若为作无常呗者。得波夜提。若比丘尼礼比丘足。时比丘作如是咒愿。使汝一切苦尽得解脱。波夜提。应语言善来。是故说

佛住舍卫城。广说如上。尔时六群比丘晨朝着衣。在祇洹门下住。时有教诫尼比丘出门。六群比丘见已作如是言。汝等今入城得放恣诸根。不为余事为好饮食故去。时教诫尼比丘惭愧。诸比丘闻已以是因缘往白世尊。佛言。呼六群比丘来。即呼来来已。佛问六群比丘。汝实尔不。答言实尔。佛言。此是恶事。非法非律不如佛教。不可以是长养善法。佛告诸比丘。依止舍卫城比丘皆悉令集。以十利故与诸比丘制戒。乃至已闻者当重闻。若比丘语比丘言。长老为食故教诫比丘尼波夜提比丘者如上说。食者糗面饭鱼肉。复次有食名色声香味触。教诫者若阿毗昙若毗尼。波夜提者如上说。若比丘语比丘作如是言今为饮食故教诫比丘尼者波夜提若言为医药故教诫比丘尼者。得越毗尼罪。若比丘语比丘尼作如是语。彼比丘为饮食故教诫汝等。得越毗尼罪。若比丘语比丘尼作如是语。彼比丘为医药故教诫汝等。得越毗尼心悔。若比丘语比丘言。汝为饮食故教诫式叉摩尼沙弥尼。得越毗尼罪。若言为医药者。得越毗尼心悔。如是广说乃至优婆塞优婆夷。为饮食故教诫汝等。得越毗尼罪若言为医药故教诫汝等。得越毗尼心悔。是故说

佛住舍卫城广说如上。尔时尊者优陀夷善生比丘尼是本二。善生比丘尼语尊者优陀夷言。我明日当次守房可来共语。明日诸比丘尼各各入聚落乞食时优陀夷往善生比丘尼所。在屏处蹲。相向展转生欲心。身生起相看而住尔时有老病比丘尼。出行遇见已心生惭愧。即便却还。病比丘尼即以是事向诸比丘尼说。诸比丘尼语善生比丘尼言。汝出家人云何乃作此非法事。甚为可耻。善生比丘尼即嗔恚言。奇哉奇哉。是我亲里比丘时时来看我。若我不与共相娱乐者。谁复应尔。是我家法有何可怪如是诸比丘尼一一难诘。是善生比丘尼辩才能一一答。诸比丘尼即以是事白大爱道。大爱道即白世尊。佛言呼优陀夷来。即便呼来。佛问优陀夷。汝实尔不。答言实尔。佛言。此是恶事。汝常不闻我无量方便。赞叹梵行毁呰淫欲耶。汝云何作是恶不善法。此非法非律不如佛教。不可以是长养善法。佛告诸比丘。依止舍卫城住者尽集。以十利故与诸比丘制戒。乃至已闻者当重闻。若比丘与一比丘尼共空屏处坐者。波夜提。比丘者如上说。一者一比丘一比丘尼。虽有人若狂痴心乱眠非人畜生。虽有如是比人。故名无人。空屏者僻静处坐者共坐。波夜提者如上说。若比丘尼请一比丘食。一比丘尼共比丘坐。一比丘尼来往益食。益食比丘尼去时。比丘随一一时得波夜提。若比丘尼坐者。比丘尔时应起。不得默然而起。使比丘尼疑欲作非法事。应当语言我欲起。若比丘尼问言。何以故起。应答言。世尊制戒不得与比丘尼共坐。若比丘尼言。尊者但坐我当起。比丘尔时坐者无罪。乃至沙弥尼。若在阁道板蹬上坐。移一一蹬上坐。比丘尔时随一一移坐波夜提。若沙弥尼乃至减七岁。亦犯波夜提。比丘与比丘尼独屏处坐波夜提。若精舍户向道。若行人不断。一切如与女人说法中广说。是罪是覆处非是露处。亦是夜亦是昼。是一人非众多。是近非是远。是故说

佛住舍卫城。广说如上。尔时六群比丘。与六群比丘尼共道行。日冥欲到聚落在池水边止息。欲求宿处。时比丘尼白六群比丘言。尊者住此我当入聚落觅宿处即入聚落求宿处。得主人唱从所安。得宿处已便出迎六群比丘。白言尊者。我已得住处。可共入安隐。比丘住已。白言。尊者我欲入村劝化明日饮食。到诸女人所作如是言。比丘比丘尼二众梵行僧俱到。汝当办明日食非时浆涂足油。诸女人闻已或有办一人供二人供者。如是人人悉办供具。饮食饱满余者持去。在道行时并共语笑调戏。为世人所嫌。汝看沙门释子。皆是年少同共剃发。似如淫女迭相调戏。是辈败人何道之有。诸比丘闻已往白世尊佛言。呼六群比丘来。即呼来已。佛问六群比丘。汝实尔不。答言实尔。佛言。此是恶事。非法非律不如佛教。不可以是长养善法。从今已去。不听与比丘尼期共道行

复次佛住舍卫城毗舍离。诸比丘夏安居讫。欲来礼觐世尊。诸比丘尼闻已即问比丘言。诸大德欲往礼觐世尊。何日当发。诸比丘即语去日。女人长情计日即先往道次住。待诸比丘。诸比丘见已问言。姊妹欲何所至。答言。欲往祇洹礼觐世尊。诸比丘闻已恐畏犯戒故。即疾疾舍去。诸比丘尼中有年少者。即褰衣随后疾行而逐。诸尼中有羸老者。行不及伴为贼所剥。诸比丘尼以上因缘白大爱道。大爱道即往世尊所头面礼足却住一面。以上因缘具白世尊。乃至诸比丘不将接诸比丘尼者。谁当将接。佛言。从今日后。听恐怖时得共道行。佛告诸比丘。依止舍卫城住者尽集以十利故与诸比丘制戒。乃至已闻者当重闻。若比丘与比丘尼期共道行。除余时波夜提。余时者恐怖时。比丘者如上说共期者若今日若明日。若半月若一月。道者若三由延若二由延。若一由延若一拘卢舍。除余时者。恐怖时世尊说无罪恐怖者须臾畏夺命。若失物欲毁梵行。虽无是事若有疑。是中须臾夺命失物毁梵行。波夜提者如上说。若比丘共比丘尼共一道行。一聚落中间一波夜提。若空地无聚落。一拘卢舍一波夜提。若比丘共母姊妹出家共随车伴行。车伴止息发去时。比丘唤比丘尼来。速勿使不及伴。作是语者波夜提。若言去去姊妹勿使失伴无罪。若比丘尼下道止息。比丘唤言。来来姊妹已名为期。若举一足得越毗尼。举二足波夜提。语言。去去勿使不及伴者无罪。比丘共商人随道行。商人先入聚落。比丘不知道处借问。见比丘尼问言。姊妹示我道来即名共期。若比丘尼来举一足得越毗尼。举二足波夜提。得言。去去示我道者不犯。若聚落中请比丘食。比丘不知檀越家处。见比丘尼即问言。知某甲檀越家处不。示我处来。即名为期。若举一足越毗尼罪。二足得波夜提。若言去去姊妹示我家处无罪。若比丘尼期而不去者越毗尼罪。不期默然而去者无罪。共期共去波夜提。不期不去者无罪。共发别入越毗尼罪。别发同入越毗尼罪。共发共入波夜提罪。别发别入无罪。是故说

佛住舍卫城广说如上。尔时是吉祥日清旦。男女集在阿耆罗河上。饮食伎乐游观。时六群比丘。晨起着入聚落衣。往六群比丘尼所。问言。今是吉祥日。汝有饮食不。当共诣河上游观。六群比丘尼言。正尔当办。大德可并觅船乘。六群比丘即往至王家船官。上请取好船及种种庄严。即持食具置船上。共比丘尼同载顺流上下嘲话戏笑。为世人所讥。汝等看此沙门释种子。放逸无道犹如俗人本共交通。此坏败之人何道之有。诸比丘闻已以是因缘往白世尊。佛言呼六群比丘来。即便呼来。来已佛问六群比丘。汝实尔不。答言实尔。佛言。此是恶事。从今日后不得与比丘尼共期载船

复次佛住舍卫城。尔时阿耆罗河彼岸。请二部僧比丘比丘尼。当受请渡。时不听比丘尼上船。而比丘或一人一船。或二人一船。如是三四船乃至极轻。而不载比丘尼。诸比丘渡已方渡比丘尼。比丘尼渡已至共食处。次第岁数如是中间日时已过。悉皆断食。大爱道瞿昙弥失食。即往至佛所头面礼足却住一面。佛知而故问。瞿昙弥何故羸极。大爱道即以上因缘具白世尊。佛言。从今日去听直渡。佛告诸比丘。依止舍卫城住者皆悉令集。以十利故与诸比丘制戒乃至已闻者当重闻。若比丘与比丘尼期共载船上水下水。除直渡。波夜提。比丘者如上说。期者若今日若明日若半月若一月。除直渡者世尊说无罪。波夜提者如上说。若比丘共比丘尼共期同载。经一聚落间得一波夜提。若无聚落空地者。一拘卢舍一波夜提。若比丘与比丘尼共载船岸边住。比丘尼下船大小行。时船欲去。比丘唤比丘尼言姊妹来。已名为期若举一足越毗尼罪。二足得波夜提。若共期而不去者得越毗尼罪。若不期而去者无罪。共期共去者波夜提不期不去者无罪。后四句亦如上。是故说

佛住舍卫城。广说如上。尔时有无岁比丘。着新好染衣来至佛所。头面礼足而去。乃经七年着弊故衣来至世尊所。头面礼足却住一面。佛知而故问。比丘汝先无岁时着新好染衣。今何故着弊故衣。答言。我从七年已来。得好衣与比丘尼。佛告诸比丘。设使亲里比丘着如是弊故衣。以好衣与亲里尼者。当取不。答言不取。设使亲里比丘着如是弊故衣能以好衣与亲里比丘尼不。答言不与。佛言。从今日不听与非亲里尼衣

复次佛住舍卫城。尔时南方有一比丘来。多有衣钵。是比丘有姊于佛法中出家。即语尊者阿难。送我往看姊尼去。尊者阿难易倩。即送到比丘尼精舍门住。问某甲比丘尼在不。比丘尼问言。唤者是谁。答言。我是阿难及某甲比丘。比丘尼言。尊者小住。即为敷床褥已。入内开半户唤言。尊者来入坐。即入坐已。共相问讯须臾便出。时彼比丘语尊者阿难言。我故远来看姊姊。不出看我为何以故。尊者阿难善知相法。语此比丘言。汝不知汝姊不出意耶。答言不知。阿难言。汝姊衣裳弊坏羞故不出。汝多有衣何故不与。是比丘言。世尊制戒不得与比丘尼衣。阿难言。汝但与我当为汝从佛乞听。阿难即往佛所头面礼足却住一面。以上因缘具白世尊。听与亲里比丘尼衣不。佛言从今日后听与亲里尼衣。佛告诸比丘。依止舍卫城住者皆悉令集。以十利故与诸比丘制戒。乃至已闻者当重闻。若比丘与非亲里比丘尼衣。除贸易。波夜提。比丘尼亲里衣者。皆如上说。除贸易者世尊说无罪。波夜提者如上说。如上三十事取比丘尼衣中广说。是故说

佛住舍卫城广说如上。尔时善生比丘尼。是尊者优陀夷本二。持衣财与优陀夷言。尊者为我作衣。优陀夷即受为作衣竟。作男女和合像作已襞叠置箱中与比丘尼。比丘尼得已持还精舍。开看见已欢喜示诸比丘尼言。诸阿夷看此尊者优陀夷作事巧妙。诸比丘尼嫌言。此是覆藏之物。云何出现示人诸比丘尼见已往白大爱道。大爱道即以是因缘往白世尊。佛言呼优陀夷来。即呼来已。佛问优陀夷。汝实尔不。答言实尔。佛言。此是恶事非法非律不如佛教。不可以是长养善法。佛告诸比丘。依止舍卫城住者尽集。以十利故与诸比丘制戒。乃至已闻者当重闻。若比丘与非亲里比丘尼作衣波夜提。比丘非亲里尼者如上说。作衣者若自刺若使人刺。波夜提。波夜提者如上说。不得与非亲里比丘尼刺衣针针。越毗尼罪。綖尽脱针波夜提。若使人刺亦如是。是故说

佛住舍卫城广说如上。尔时有檀越。宿请尊者舍利弗。大目连。离波多。劫宾那。阿若憍陈如等。唯尊者大迦叶不受宿请。明日时到着入聚落衣。持钵次行乞食到其门。时檀越妇女见已欢喜。即前头面礼足却住一面。白言。诸大德比丘今日尽集受我家请。惟愿尊者亦受我请。时尊者大迦叶作是念。此是现前即受其请。更不余行即先入内坐。时偷兰难陀比丘尼乞食到其家中。庭见檀越妇洒扫地荡器办诸供具。即问言优婆夷汝作何等。时妇人营事忙懅不得应。如是第二第三问不答。偷兰难陀即言。汝今奇事大自憍重唤而不应。妇人答言。我今日请诸大德声闻舍利弗目连等。以是总务不容得应。偷兰难陀即言。汝今所请于大象群中不取大象而取小象。大鸟群中不取孔雀而取老乌。所谓大象者。阐陀迦留陀夷三文陀达多摩醯沙满多马师满宿及侍者大德阿难。汝若使我请者。我当为汝请如是大德。时尊者大迦叶闻已大謦咳作声。偷兰难陀闻已问言。此是谁声。妇人答言。此是长老大迦叶比丘尼即赞叹言。汝大得善利。乃请如是大龙象。我若当请者亦请是长老。时尊者大迦叶闻此语已心不喜悦。即问言。姊汝向言是小象老乌。今复言是龙象大德。若前言实者后言虚。若后言实者前言虚。二言之中何者为实。尊者大迦叶威德尊重。以此二句诘责比丘尼。比丘尼恐惧便走倒地伤破身体。阐陀见已即问尼言。汝触扰谁乃如是伤破身体。答言。我恼乱大迦叶。即语言汝不可触者便触。诸比丘闻已以是因缘往白世尊。佛语诸比丘。此中不赞叹犹有过患况复赞叹。从今日后不听比丘受比丘尼赞叹食

复次尊者阿难于舍卫城有福德名称。世尊说三事具足。姓字眷属成就。于学地中多闻第一给侍第一。令舍卫城有福德里。作新舍处尽请阿难。若入舍时剃发时贯耳时。一切尽请阿难。时有长者请尊者阿难设新舍会。云何新。新屋新床新器新饭新酥油新儿妇着新衣持新扇。阿难食时有一乞食比丘在外。阿难即语檀越。可与外乞食比丘食檀越闻阿难教已欢喜盛满钵种种美食持与乞食比丘。乞食比丘得已立待阿难。阿难食讫咒愿已便出乞食比丘见阿难已问言尊者食未答言已食。复问阿难食适意好不。阿难问言。汝何故不食乃问我食适不适耶。乞食比丘言。尊者所食食是比丘尼所赞叹。阿难言实尔耶。答言如是。阿难即以鸟翮擿吐是日失食四大饥羸。往至佛所头面礼足却住一面。佛知而故问。阿难汝何故四大饥羸。阿难即以上因缘具白世尊。佛问阿难汝知不。答言不知。佛言。此罪是知非是不知。诸比丘白佛言。世尊。云何是乞食比丘使阿难不乐。佛言。不但今日使阿难不乐。如贤鸟生经中广说

复次佛住舍卫城。尔时长老比丘时到着入聚落衣。持钵入城次行乞食。来去屈伸威仪庠序。时有一长者作如是言。善哉大德大得善利。施如是出家人衣服饮食病瘦医药者。又作是念。我若有人力者亦当供养如是等出家人。时有比丘尼。闻已语长者言。长寿汝但出食直。我当相为料理。是檀越信心欢喜即与食直。比丘尼言。长寿汝当请比丘。答言我不知愿为我请。比丘尼即办种种饮食已语檀越言。长寿食具已办。汝往至比丘所白言时至。檀越言我不知。尼但为我往白时至。比丘尼即往白时至。比丘来入檀越家坐。坐讫比丘尼语檀越言。此种种供食汝可自行。檀越言阿姨为我行。诸比丘作是念。此是比丘尼所赞叹食不。疑已即出。如是一人二人乃至一切众都出。檀越问比丘尼言。诸尊者何故尽出不复来还。尼答言我不知。汝往世尊所广问斯事。当为汝说。是檀越即往佛所。头面礼足却住一面。以上因缘广白世尊。佛言。呼诸比丘来。呼来已佛具问上事。汝实尔不。答言。实尔世尊。佛言。从今日后听除旧檀越。佛告诸比丘。依止舍卫城住者皆悉令集。以十利故与诸比丘制戒。乃至已闻者当重闻。若比丘知比丘尼赞叹食。除旧檀越波夜提。比丘者如上说。知者若自知若从他闻。赞叹者称美其德食者五种。糗面饭鱼肉。除旧檀越者世尊说无罪。波夜提者如上说。唱等供时叹始下食时叹有初作食时叹作食办已叹有请时叹。唱等供时叹者下食都讫唱等供时更有余比丘来比丘尼语优婆夷言。更有比丘来。优婆夷言。善哉我欢善故遣使请尚不能得何况自来。是不名赞叹。若比丘尼言。此是阿练若乞食粪扫衣露坐草蓐。如是叹得食。食者波夜提。下食时者。初下食时更有余比丘来。亦如上说作时叹者初作时更有余比丘来。亦如是说作竟叹者一切作供办讫更有余比丘来比丘尼语优婆夷言。更有比丘来优婆夷言。善哉我故遣请犹不能得何况自来不名赞叹。优婆夷言。当多与糗饼饭好食平等与。不名赞叹。若饮食少。更语檀越。为作一掬糗者。波夜提。请者称名请。比丘尼语檀越言。某甲徒众多闻精进。当通请一切。名赞叹食。若言某甲众主多闻精进。为是比丘故通请二十人。是一人名为赞叹。余者不犯。若有如是赞叹食者。当展转贸食不得舍食而去。若比坐垢秽不净不喜与贸者当作是念。此钵中食是某甲比丘许我当食无罪。若比丘尼语优婆夷言。尊者某甲可长请供养。此即名赞叹。若言尊者某甲可常乞食。不名为赞叹。是故说

  僧不差日冥　　不白为食故
  共坐同道行　　船上及与衣
  作衣赞叹食　　第三跋渠竟

摩诃僧祇律卷第十五摩诃僧祇律卷第十六

        东晋天竺三藏佛陀跋陀罗共法显译

    明单提九十二事法之五

佛住舍卫城。广说如上。时有比丘。在聚落中安居竟。来向舍卫城。欲礼觐世尊。时有居士。在聚落中作福舍。施四方僧一食。此比丘来。居士见已。欢喜言。善来大德。即敷床褥与水洗脚。给涂足油及非时饮。夜燃灯明敷置卧具。安隐令寝。晨起又给杨枝净水。施以适身美食。比丘食已。便作是念。我远来饥乏。今日得如是适身饮食。且可小停消息四大。然后当往奉觐世尊。如是念已。昼在阿练若处住。暮则还舍。檀越见之如前。欢喜如是。乃至三日。檀越问言。大德。今日在何处食。答言此间又问。昨日何处。亦言此间。又问先日何处。又言此间。檀越嫌言。我家穷俭自力于此为四方僧。作一食施处。大德不应久停。若我家丰饶当自恣施一切僧。比丘念言。檀越出此恨声。我自当去。于是渐行前至佛所。稽首礼足。却住一面。佛知而故问。汝在何处安居。答言。在某聚落。发来几时。答言尔许。时佛问比丘。有何因缘道里不远。来日经久。比丘即以上事。具白世尊。佛言此事不可。汝云何以身口故。为檀越所嫌。从今日施一食处。比丘不得过一食

复次佛住舍卫城。尔时有比丘在聚落中夏安居讫。来诣舍卫。欲礼觐世尊。时有檀越。在聚落中作福舍。施四方僧一食。是比丘行过此舍。供给所须。如前所说。比丘食已。而出风病发动。自念。我不能行世尊制戒施一食处。不听过一食。我今且住。但不受其食。念已即还入舍。檀越如初供给所须。比丘不受。至明日复与前食。亦复不受。于是即去心念我到某村。当乞食。比丘至聚落。日时已过。即便失食。四大饥羸。至世尊所。稽首礼足。却住一面。佛知而故问。即以上事。具白世尊。佛言。善哉善哉比丘。汝随顺正法信心出家。少欲顺行不为命故。世尊制戒护而不犯。佛言。从今已后福德舍中。若病比丘听过一食。佛告诸比丘。依止舍卫城住者尽集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘施一食处。不病比丘应一食。若过一食者。波夜提。比丘者如上说施一食处者。世尊所听。食者。五种食。如上说。不病者。身无疾患。身有疾患不能进路住食无罪。若不病过一食者。波夜提。波夜提者。如上说。若十六间屋一间中。一家施一食处。若在我屋中宿者。我当与食。若比丘为僧事。为塔。事自为事到一间中宿。一食已欲料理。事事不了者。应到第二间中宿食已当去。若事复不了者。乃至十六间中宿食已事讫当去。若复不了不得更食。当乞食乞食。时当余处乞不得还。从其家乞。若复本作舍时。同村相助者。亦不得从乞。当往余村中乞食已。当即彼村中宿。宿已更来料理事。若事不了。复得如上十六间中食。若事不了者。复离去隔一宿已。复来得食料理事。若彼家遣女迎妇入新舍。作如是言。我遣使往请师。犹恐难得。何况今见而欲去。比丘尔时受请食者无罪。是故说

佛住舍卫城。广说如上尔时僧园民年年谷麦新熟时。供僧食。云何年年新熟。稻熟时麦熟时。豆熟时苏油石蜜时。各取少许分置一处。拟供众僧。时园民语比丘言。我当年年新谷熟时。施僧食。若祇洹无人供日唯愿见语。我当设供。令僧自恣饱满。尔时诸居士信心供养种种饮食前食后食少有缺日中间遇有一空日。便往语言长寿明日祇洹无供。汝先欲设供。今可及时。园民闻已。即诣祇洹头面礼僧足。右膝着地。合掌白言我园民某甲明日设供。请一切僧。唯愿受请。僧即受请。尔时有长者。用旧钱五百。买得二牛得已欲试。看驾着车中打走往返一由延。车鞅急故。一牛即死便大忧恼。苦住不乐。云何贵价买牛未用便死。有知识居士语言汝何故不乐如是。居士具说上事。即语言汝何以不作坚法。问云。何坚法。答言。坚法者。汝往诣祇洹。请僧持此肉供饭众僧。彼人闻已。即到祇洹。入僧中头面礼僧足。胡跪合掌。作如是言。我某甲明日请僧薄设微供。愿受我请有旧知识比丘。即往语言。汝不解请法。何不先语我。我当教汝请僧。彼即答言。阿阇梨。我五百旧钱买得二牛。一牛已死我今欲以此牛肉作坚法。比丘言。僧已受人请。檀越言。我已作食。今当云何。知识比丘言。我今教汝更往白众僧我请僧明日前食。若问汝作何等前食。汝当答言。作麦饭肉段。教已即往到僧所。头面礼足。胡跪合掌。作如是言。我某甲请僧明日设前食愿受我请比丘问言。汝作何等前食。答言。作麦饭肉段。语言。长寿。汝明日清旦早办。答言尔。愿诸尊者。明旦早来。即便还家。通夜煮肉作种种饮食。清旦敷置床褥。漉净水已。往白僧。时到。僧着衣持钵来到其家。次第坐已。檀越自下种种美食。自恣饱满。即还精舍。园民作是念。阿阇梨。是一食人。当须早食。通夜办具种种饮食。敷置床耨。漉净水已。往只祇洹。头面礼僧足。胡跪合掌白言。时到。尔时诸比丘以前食饱满故。虽见请至。犹如不闻。时园民念言。甚奇甚奇。诸阿阇梨是一食人。法应饥想。今闻请食。犹如不闻。若外道闻请食者。便捉三奇杖军持。在前而去。如是第二第三赞叹已。诸比丘方起。彷佯大小行。嚬伸缓带威仪。安详往到其舍。次第坐已。园民手自下食。满杓而与上座。举手现少着相。园民复作是言。诸阿阇梨是一食人。于此种种食中都无贪想。园民作是念。若上座食少。下座应食多。如是第二第三。乃至年少。复作是言。阿阇梨是一食人。于此饮食都无贪想。尔时下座中有一晚学摩诃罗。作如是言。我等今日不为食来。意为汝意故来。我等已于余处饱食竟。汝若不信者。看我脚上肉汁。园民闻已。心中不悦。即弃食器置地而嫌恨言。诸阿阇梨先受我请。云何复于余处而食。心嫌不止。即往佛所。头面礼足。却住一面。白佛言。云何诸比丘先受我请。而于余处食。佛即为园民随顺说法。示教利喜已。即白佛言。世尊。我供僧余食当置何处。佛言。汝到某甲池上净扫治地。持食置彼。波斯匿王与弥尼刹利共斗不如军今退还。当于彼住。汝可以此食上之。王来入池洗浴更着新衣。即持向者种种饮食。奉献大王并及将士。于饥渴中来。得是种种饮食。皆大欢喜。敕令赏赐种种珍宝园民现得善利喜庆无量。佛言。呼彼食比丘来。即呼来已。佛问比丘。汝云何先受人请。而于余处食。比丘汝不知耶。如人所事宅神树神。若欲余行。先当食主人食已。然后余行。汝等不随顺行。先受人请而于余处食。从今以后不听处处食

复次佛住舍卫城。广说如上。世尊五事利益故。五日一行诸比丘房。见有病比丘。佛知而故问。比丘。汝所患何等。今为增损。答言我患苦无损。我先得数数食时。身得安乐。世尊制戒不得数数食故。我病不损。佛言。从今日听病时数数食

复次佛住舍卫城毗舍佉鹿母年年请僧饭食施衣。时祇洹精舍有六十病比丘。来到其家。毗舍佉鹿母言。阿阇梨祇洹精舍有五百众僧。今有何因缘。正有六十比丘来。诸比丘语优婆夷言。世尊制戒不得处处食。唯听病者。是故诸病比丘来。毗舍佉鹿母言。阿阇梨。世人正以请食为限。若食我食者。我当施衣。若不食者我不施衣。阿阇梨。此施衣时可往白佛。或有开听。诸比丘以是因缘往白世尊。佛告诸比丘。毗舍佉鹿母是黠慧聪明。从今日听施衣时

复次佛住舍卫城。尔时众人劝化欲设大会。供养饭食九十六种出家人。有至优婆塞所。劝化索物者。优婆塞言。我欲作要。若使我诸师作上座者。当与汝物。劝化人言。汝听若有信向外道者。亦作是言。若使我诸师作上座者。当与汝物我当云何得人。人许其上座。汝但与我物。我当某月某日在阿耆河岸上。庄严其处施竖幢幡。行列宝树间。敷妙座细软快乐。设供肴膳。作斯大会。诸出家人中有先至者。即为上座。诸优婆塞以佛僧是良福田故。即便与物。与物已。往尊者阿难所。头面礼足具白上事。尊者当以何方便。令诸比丘得为上座。使外道耻辱尊者。阿难即往佛所。头面礼足。却住一面。以上因缘具白世尊。诸劝化人办具食已。请九十六种诸出家人。复请波斯匿王及群臣太子。诸聚落主宿旧长者并萨薄主。至于某时。皆诣阿耆河上大会处。受我供食。先前一日。佛告目连。宜知是时。尊者目连即以神足。使河水瀑涨泡沫弥岸。诸外道各作是言。我当先渡取第一坐处。诸外道各各通夜竞縳[竺-二+淠]筏。皆欲先渡而水激急。适欲渡岸。还复漂还。竟夜疲苦[竺-二+淠]筏散坏。没溺寒冻。在于岸边。向日而蹲。乃至食时无能渡者。尔时祇洹精舍有人供僧。佛住待时。诸比丘中有年少者。皆作是言。世尊今出何乃太晚。恐诸外道得上座处。尔时世尊时到。着衣持钵威仪庠序。与大众俱诣河上。诸外道见已。各相谓言。我等竟夜造诸方便。如是苦恼无能渡者。此剃发沙门。当云何渡。尔时佛告目连。汝自知时。使诸比丘得安隐渡。尔时目连即以神力。造作七宝桥。种种杂宝以为栏楯。上施宝缦七宝绞络。罗覆其上。雨众名花。作众伎乐。烧众名香。香烟如云。诸外道见是桥已。皆大欢喜。各作是言。此诸沙门徐徐而来。我等当先渡取第一坐处。即皆奔走竞抄趣桥。各欲先渡。足蹈桥上。皆悉堕水。诸外道服饰三奇杖军持等物。皆落水中随流而去。佛神力故。令无死者。于是世尊与诸比丘威仪庠序俨然而进。佛最在前。诸比丘次第而行。目连最后随进步处。宝桥即灭。佛与诸比丘渡已。佛告目连。汝可使河还复如故。诸外道等各各方便乘[竺-二+淠]筏渡。佛既渡已。一切回身而说偈言

  先渡此岸众　　已渡生死海
  不为世流漂　　正智渡彼岸

佛说偈已。安详就坐。诸比丘亦次第坐。诸外道后渡。在比丘下行而坐。尔时檀越手自斟酌种种饮食。供养世尊及弟子众。尔时诸比丘心疑。世尊制戒不得处处食。我等云何当复得食。即起白佛。佛言。听作施食法。应作如是言。我今日得食施与某甲比丘乃至沙弥尼。彼于我不计。我当食。如是三说。尔时檀越各各念言。谁应咒愿。或有言尼干子。或言不兰迦叶。如是外道等。各云。应咒愿。尔时有多人言。沙门瞿昙上座法。应咒愿。尔时世尊在九十六种道中。不自高显。不轻他人。随顺咒愿。如生经中广说。尔时世尊复广为众人随顺说法。示教利喜。欢喜而去。佛还祇洹。告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘处处食。除余时波夜提。余时者。病时衣时。是名余时。比丘者。如上说。处处食者。数数食。除余时者。病时。病者。热病风冷。如是等病。若食已更食。身得安隐食者。无罪。衣时者。无迦絺那衣。一月有迦絺那衣。五月彼衣中间得舍五戒无罪。所谓别众食处处食。不白离同食处。畜长衣离衣宿。余时者。世尊说无罪。波夜提者。如上说。比丘要当知日数应施食。知腊数忆所受持衣。别众食病不病。若人问今日几。不得逆问昨日是几日。当知月一日二日。乃至十四十五日。月大月小悉应知。比丘清旦当作施食念今日得食施某甲。某甲于我不计。我当食如是三说。日日自忆。若干腊数。当忆受持。三衣及不受作净施者。念别众食。若病若不病。齐几名为比丘食。若麦饭三钵他逻。若糗二钵他逻。若一钵他逻米作饭鱼肉。若一钵若半钵。是中若得一一。是名比丘食若僧伽蓝中作食。食未熟。若比丘受糗作糗浆饮犯处处食。得波夜提。若作施食法。若病不犯。若衣时者。二俱不犯。若外有请家者。即名比丘食。比丘尔时倩人迎食。迎食未至。比丘若受糗作糗浆送食至送食。比丘若知戒相者。应小住。待彼比丘作施食法己。然后授食。若送食比丘不知。戒相。便疾授食。不容作施食法者。比丘尔时口中有食应含食说施食法。以轻贸重故。若比丘到一家。檀越语言。阿阇梨。今日当我家食。此即名食处。比丘作是念。此食未熟。我今欲到余家。尔时应白已去。若不白去。波夜提。若彼间得五正食。五杂正食。食者。二波夜提。处处食离食处不白。若病若作施食法。食者无罪。衣时者二俱无罪。若檀越作如是言。阿阇梨。若无食时来我家食。比丘往到其家。作是言。长寿。我今日当此间食。优婆夷言。善哉。正尔当办。若食未熟。此比丘欲往余家者。当白去。若不白者。如上说得罪。若比丘次行乞食。到一家。檀越言。今日此间请诸比丘食。愿阿阇梨亦受我请。勿复余处食。若比丘受请者即名食处。若乞食比丘受请已。作是念。谁能受是重信施食。若欲舍去者。应白已去。若不白去者。如上说得罪。若比丘有大功德名称。有众多人送食来。欲取诸檀越意。一切受诸食者犯处处食。得波夜提。若作施食法。若病无罪。若衣时者。二俱无罪。有二比丘。各各别受一家长请。第一比丘语第二比丘言。长老。今日共到我檀越家食去。第二比丘应白已去。若不白去者。如上说。若第二比丘请者。亦如是。比丘食处者。麦饭三钵他逻。糗二钵他逻。米一钵他逻。作饭鱼肉。若一钵半钵。是中一一是比丘食。若一家。或得三升。或二升或一升半升。如是众多乞得无罪。若一家得三钵他麦饭糗二钵他。若一钵他米作饭鱼肉若一钵半钵。余处更不得取。此中何等是犯。何等不犯。若粥初出釜画成字者犯。若不成字者不犯。一切菜一切糗。一切饼一切果。非处处食。非别众食。非足食。多积舍里不犯。是故说

佛住舍卫城。广说如上。尔时有婆罗门。请僧施食。时办种种饮食讫。漉净水敷床褥已。作如是念。阿阇梨是一食人。当须早食。即往到祇洹。头面礼僧足。胡跪合掌。作如是言。我某甲请僧食食具已办。愿僧知时。尔时比丘到时。着衣持钵往到其家。次第坐已。时婆罗门自手下种种饮食。自恣饱满。婆罗门复自持食。顺行强劝。诸比丘皆言。不用饱满。诸比丘食讫无缘者。径还精舍。有缘者过诸檀越。檀越见已。欢喜礼拜问讯。作是言。阿阇梨须前食不。须果蓏不。须粥不。若阿阇梨有所须者。我当作。比丘言。我于某甲。婆罗门家。食已饱满。时檀越知比丘食时未过。作是言。阿阇梨。日故早。可持此饼还精舍食。比丘即授钵与盛满钵饼。还到祇洹门间坐食此饼。复唤余比丘共食。时婆罗门自食讫。语其妇言。以余食饷诸邻近。我欲往诣世尊所。礼觐问讯。遥见比丘在祇洹门间坐共食饼。见已往一经行比丘所。问言。此是客比丘耶。答言非也。是欲行比丘耶。答言非也。又问。是我家食比丘耶。答言是。复问言。作何等。比丘言。婆罗门汝不知耶。答言不知。此比丘食少。更足令满。时婆罗门心即不悦。作是言。沙门释子是实语人。而今不实。不足言足。用言不用。不满言满。此坏败人有何道哉。以心嫌故竟不诣佛。于是便还。诸比丘闻已。往白世尊。佛言。呼是比丘来。来已佛问比丘。汝实尔不。答言。实尔世尊。佛言。比丘汝云何食足已起。离坐而更食。从今以后不听食足已离坐更食

复次佛住舍卫城。广说如上。尔时诸比丘啖菜言足。啖盐言足。饮水已。皆名为足。离坐处更不啖食。身体羸瘦。诸比丘以是因缘。往白世尊。佛言。从今已后。听食五正食。五杂正食。是名为足。尔时诸比丘在坐处。得少食已。名作足食更不复食。犹故羸劣。诸比丘以是因缘。往白世尊。佛言。一坐食。五正食。五杂正食。自恣与是名足

复次佛住舍卫城。尔时祇洹精舍有六十比丘。病比丘迎六十分食。病比丘食残不尽。弃着墙边。乌鸟共啖斗诤作声。佛知而故问。比丘此众鸟。何以声大。诸比丘白佛言。有六十比丘。病为迎食分食不能尽。弃着墙边。众鸟诤此残食故出大声耳。佛语诸比丘。若病比丘食不尽者。听看病比丘作残食法已得食

复次佛住舍卫城。尔时看病比丘作残食法。食已犹故不尽。众鸟共诤。如上说。佛知而故问比丘。众鸟何以斗诤。诸比丘白佛言。看病比丘作残食法。食已犹不能尽。弃着墙边。以是故众鸟诤食作声。佛言。从今日听一人作残食。余人尽得食。佛告诸比丘。依止舍卫城者皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘食已足起离坐。不作残食。食者波夜提。比丘者如上说。食者有五种。糗饭麦饭鱼肉。复有五杂正食。是名食。足有八种。一者自恣足。二者少欲足。三者秽污足。四者杂足。五者不便足。六者谄足。七者停住足。八者自己足。自恣足者。檀越自恣与糗饭麦饭鱼肉。及杂正食。自恣劝食。比丘言。我已满足。如是起离坐不作残食。食者波夜提。是名自恣足。少欲足者。檀越自恣与五正食。及五杂正食。比丘动手现少取相。如是离坐已。不作残食。食者波夜提。是名少欲足。秽污足者。行食时净人手疥疮及诸不净。比丘见污之言不用过去。起离坐处。不作残食。食者波夜提。是名秽污足。杂足者。净人持乳酪器盛糗饭行。比丘见已。恶之言不用过去。起离坐。不作残食。食者波夜提。是名杂足。不便足者。净人行食。比丘问言。是何等。答言糗。比丘言。此动我风病。我不便过去。如是起离坐。不作残食。食者波夜提。若行饭时。比丘问言。为坚软。答言坚。比丘言。此硬米难消。我不便过去。若言软。比丘言此烂难食。我不便过去。若行肉时。比丘问言。是何等肉。答言牛肉。比丘言。牛肉性热。我不便下过若言水牛肉。比丘言。冷性难消下过。若言鹿肉。比丘言。此肉风性下过。是名不便足。如是起离坐已。不作残食。食者波夜提。是名不便足。谄足者。净人行五正食五杂正食。比丘畏多口不言足。现手作相。若摇头。若缩钵作相。起离座不作残食。食者波夜提。是名谄足。停住足者。净人行五正食五杂正食。比丘言。长寿。莫先行饭抟恐触足当先下菜盐冷水。如是起离坐已。不作残食。食者波夜提。若作直月维那等指示现相。不名足。是名停住足。自己足者。比丘乞食至一家。放糗囊置一处。从檀越乞水欲饮。檀越作是念。此比丘必当须糗。即问言。须糗不。比丘作是念。此檀越必欲家中取糗与我。答言须。时檀越即捉比丘糗囊授比丘。比丘以惜己糗故。便言置置。如是语已。起离坐。不作残食食者波夜提。是名自己足。起离座者。离有八处。行住坐卧长床坐床船乘。住者。比丘立食自恣与食。应立足中间。若行若坐若卧。皆名离本处不作残食。食者波夜提。行坐卧亦如是。若比丘在长床上坐。自恣与食。若见上座。若和上阿阇梨来不得起离坐避。得曳身不离床移避。若床脚折者。即名离本处。若不作残食。食者波夜提。是名长床坐。床者。若比丘在独坐床上座。自恣与食。若坐方觉背后有塔。若僧若和上阿阇梨。应不离床回身。若雨者当持伞盖覆上。若无盖者。得合床举着覆处。若举时到地。即名离本处。若不作残食。食者波夜提。是名坐床。船者。若比丘在船上自恣与食。若船筑岸。若触木石。若回波比丘身离本处。不作残食。食者波夜提。乘者。若比丘在乘上自恣与食。若乘上阪下阪若乘翻身离本处。不作残食。食者波夜提。是名乘。有五非法不名作残食。何等五。离处离食离境界离申手离语。离处者。若为作残食。比丘行时与啖食。住时坐时卧时。说残食法。是不名作。如是住坐卧时。与啖食。行时住时坐时。说残食法。是名离处。离食者。不与啖作残食。即便说与不名作是名离食。离境界者食放地作残非手中不名作。是名离境界。离申手者。舒手外作残食。非申手内不名作。是名离申手。离语者。口不作是言。我手中钵中食。我今一切不须是残食。与长老。是名离语不名作。是名五非法。不成作残食。有五如法。名如法作残食。何等五不离处不离食不离境界不离申手内不离语。不离处者。若为作残食。比丘行时与啖。即行时说残食法。是名作。如是住时坐时卧时亦如是。是名不离处。不离食者。啖食已即说残食法与。是名不离食。不离境界者。在手中作残食。非在地。是名不离境界。不离申手者。申手内作残食。非申手外。是名不离申手。不离语者。为啖已作是言。我手中钵中所有饭食。我今一切不须是残食。与长老。是名不离语。是名五如法作残食。若成就五非法。尽命不得作残食食。何等五。于处不善。于食不善。于境界不善。于申手不善。于遮不善。处不善者。不知行时食行足。住时食住足。坐时食坐足。卧时食卧足。是名处不善。食不善者。不知五正食五杂正食。是足余者非足。是名食不善。境界不善者。不知在手中者是足。在地者不足。是名境界不善。申手不善者。不知在申手内是足。申手外是不足。是名申手不善。遮不善者。不知遮是足。不遮是不足。是名遮不善。如是成就此五非法。尽命不听作残食食。若成就五如法。听尽寿作残食食。何等五。善处善食善境界善申手善遮。善处者。知行时食行足。知立时食立足。知坐时食坐足。知卧时食卧足。是名善处。善食者。知五正食。五杂正食是足。余者非足。是名善食。善境界者。知食在手中是足。在地非足。是名善境界。善申手者。知申手内是足。申手外非足。是名善申手。善遮者。知遮是足不遮非足。是名善遮。成就此五法。尽命听作残食食。若比丘持食来欲作残食时。即于钵上碗中作残者。正得碗中名作残食。钵中食不名作。若碗中食汁流入钵中。得俱名残食。若比丘并两钵索作残食。若前人正食一钵中食者。正一钵得作残食。若二钵上若饼若菜通覆钵横上者。二俱得名作残食。余种种器亦如是。若比丘食足已。往檀越家。主人言。阿阇梨。能食饼不。答言。我食已足。知法优婆塞作是言。某甲家有比丘未足。若须食者。我当往作残食法。比丘若须者。应答言。可尔。檀越净洗器盛满中种种美食。比丘受取持好细[疊*毛]裹。莫使外尘土得入。着净人手中。作是言。汝去作残食已持来。净人持食。到彼比丘所。作如是言。尊者。我家中有食未足食比丘。愿尊者为我作残食。彼比丘应净洗手。受此食已。语净人言。汝近我边在申手内立。比丘于彼钵中食。一口已作如是言。我手中器中所有食。一切不须作残食与汝。净人持来授与比丘。比丘得食。若更有余已足。比丘须者亦得共食。若国土少比丘处。比丘食已。有大檀越。持种种饮食至。比丘已起去。当云何。若彼间有直月维那。诸知事人。未食足者。当从彼人边作残食。若彼已食足。若上座未足者。当于上座边作残食。若上座羞不能人中作者。当合坐举。上座至屏处作残食。若上座已足者。有客比丘来者当问。长老今日自恣足未。若客比丘答言。我未得夏安居。云何得自恣足。当知是人不知律相。更应问。汝食未。若言已食。复问。檀越自恣与不。若言长老何处得自恣食。水菜尚不足。况复余食。当知是不足。应从彼比丘作残食法。若言我檀越家自恣与食。当知已足。僧应作方便。不应破檀越善心。若众中有大沙弥。将至戒场上。与受具足。教作残食法已。然后当食。若比丘食五杂正食。离五正食作残食。是不名作。若不足更食者无罪。若足起离坐更食者。得越毗尼罪。若比丘食五正食。离五杂正食作残食。不名作。若不足食无罪。若食足离坐更食者。波夜提。若比丘离五正食。离五杂正食。作残食者不名作。残食不足更食者无罪。若足起离坐更食者。得越毗尼罪。若比丘食五正食。五杂正食作残食。是名如法作残食。若食未足更食无罪。若足起离坐更食犯罪。此中何者犯。何者非犯。若一切粥新出釜画不成字。一切果一切菜。非别众食。非处处食。非足食。多积屋里不犯。是故说

佛住舍卫城。广说如上。尔时阿难有二共行弟子一名满荼。二名阿毗耆。共尊者大目连二共行弟子。一名阿阇都。二名舍舍都。各各作如是言。谁多闻谁辩才。时阿难共行弟子辩才利根。目连弟子论议不如。行住坐卧常随逐左右伺求其短。或时二人同受一请。时尊者目连弟子得饼。食半持半出外语阿难弟子。如是言。长老。汝欲食饼不。问言。汝何处得饼。答言。我于彼食处持来。即便取食。食已便作是言。长老。汝犯罪。问言。何等罪。答言。世尊制戒不听比丘食足已离坐。不作残食法更食。阿难弟子言。汝云何欲中我不作残食法。而教我食。目连弟子言。汝前论议时。何故以辩才强折辱我。遂共诤竞。往世尊所。头面礼足。却住一面。以上因缘。具白世尊。佛语诸比丘。于意云何我为诸声闻。说九部法。所谓修多罗。祇夜。授记。伽陀。优陀那。如是语本生。方广。未曾有。诸声闻闻说此九部法已。为欲使诸弟子论议诤胜负耶。答言。不也世尊。佛语诸比丘。若不尔者。我为诸声闻说此九部法。欲使诸声闻如说修行不。答言。如是世尊。时二比丘即于世尊前。相向悔过。佛言。不得自恃知法轻他。亦不听知比丘食已足。不作残食法。强劝令食。佛告诸比丘。依止舍卫城住者皆悉令集。以十利故。为诸比丘制戒。乃至已闻者当重闻。若比丘知彼食已足。离坐不作残食法。欲恼故劝食者。波夜提。比丘者如上说。知者若自知若从他闻。食者五正食。五杂正食。足者有八种。如上说。离本处者。八种如上说。恼者触扰前人欲使不乐。不作残食者。五非法成就不名作残食。五法成就名如法作残食。强劝食食者。波夜提。波夜提者。如上说。五非法成就。比丘尽命。不得作残食食。五法成就尽命听作残食食。中间广说如上。乃至足不足想劝食。越毗尼罪。不足足想劝食。越毗尼罪。足作足想劝食。波夜提。不足不足想劝食无罪。此中不犯者。一切粥初出釜画不成字。一切果一切菜。是不犯。是故说

佛住舍卫城。广说如上。尔时尊者阿那律一切粪扫。粪扫钵。粪扫衣。粪扫食。粪扫革屣云何粪扫钵。比丘破钵满五缀掷弃者。阿那律取已。更缀受持。是名粪扫钵。粪扫衣者。里巷中弃弊故衣。取净浣补染受持。是名粪扫衣。粪扫食者。若他弃祠祀鬼神食。是长老自取食。是名粪扫食。粪扫革屣者。诸比丘所著革屣断坏弃者。拾取更补治着。是名粪扫革屣。是长老时到着衣持钵入城欲乞食。初入城门见一妇女。挟箧持饭。持草牛屎并火祭祀之具而出。是尊者见已。作是念。此中可有得食理。于我为乐。当更求。即便舍去。从巷至巷。遍无所得。到池水边。还见前妇人洒扫涂地。敷净草安置祭具祭祀已讫。以饭洒散四边。作如是言。贤乌来食。贤乌来食。尔时尊者在一树下立。尊者威神力故。众乌无来食者。时此妇人见尊者已。作如是言。汝如瞎眼乌。常随逐人。妇人骂已即还。时尊者收拾祭食还向精舍。诸比丘见已。更相谓言。是尊者求食极苦难得。诸比丘问言。尊者得食不。答言得。但彼中有多过不甘。即问有何过。答言。如是如是。诸比丘闻已。往白世尊。此骂女人为得几罪。佛言。得多罪。比丘复问。齐几为多。佛语比丘。此女人五百世中常作瞎眼乌。一切受身皆当饿死。佛言。呼阿那律来。即呼来已。佛问阿那律。汝实尔不。答言实尔。佛语阿那律。汝虽欲少事。从今日不听不与自手取

复次佛住舍卫城。尔时世尊制不得自手取。诸比丘闻已。水及齿木皆从人受。有净人者便得。无净人者苦不能得。尔时世尊为大众说法。有比丘自闻口边臭。在众人下风而坐。不欲令口臭气熏诸梵行人。佛知而故问。比丘何故在彼坐。如嗔恨人。诸比丘白佛言。世尊制戒不授不得取。诸比丘水及齿木。皆从人受。有净人者得。无净人者苦不能得。口中气臭恐熏诸梵行人故。在下风而住。佛言从今日听除水及齿木。佛告诸比丘。依止舍卫城住者皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘不与取。着口中除水及齿木。波夜提。比丘者如上说。不与者。他不与。不从前人受。着口中食者。除水及齿木。水有十种如前说。若水浊者应受。若水性黄色者饮无罪。齿木者有二种。一擗。二团。若比丘口中有热气生疮。医言。应嚼齿木。咽汁者应当受除水及齿木。世尊说无罪。波夜提者。如上说。食上。树上。井中。屋上。净厨。器受非器。受床。船乘。心念受道路。食上者。若食时敷床。若长板。若甘蔗束。若萝卜束。若谷豆囊上。敷种种坐床褥覆上。比丘坐时不应动身。不应问。若动若问。此是何等。是名不净。若比丘食时。风吹尘来坋钵。下草不坋。食者得食。草叶当受。若坋草叶及食者。一切更受。比丘食时。若牛若骆驼等行。脚下尘来坋不污食者得食。坋草叶者。当更受。若坋草叶及食者。一切更受。若畜生振身尘来。若作意受者。得名为受。若众鸟尘来亦如是。若比丘食时。女人行衣曳地尘起来坋。亦复如是。若净人行草叶时。比丘应语言悬放。若行盐果菜。应语悬放。若净人行果堕草上。即转去者。不名为受。小停者。得名为受。果坚者得取洗。啖烂者不应取。若净人行糗抖擞糗器。糗坋堕器中。若作意受者。即名为受。若不作意者。当更受。若净人持器行糗器堕比丘钵中。即堕时。以手拨去者。器故名净。若停须臾即名不净。若是铜器者。当净洗用。若是木器腻入中当弃。若腻不入者。得削用。若行饭时。抖擞器饭迸空中来。比丘作受意者。即名为受。若不作受心者。当更受。行酥乳酪肉菜酱等。亦复如是。若作五年大会时。佛生日得道日转法轮日。阿难大会时。罗睺罗大会时。若净人难得。比丘应到菜聚边受菜。行盐糗饭亦如是。若净人举不离地。亦得名为受。但非威仪比丘。应语净人。汝举离地授我。若净人小不能举者。应言。汝稍稍分授我。受羹饼饮食时。亦复如是。若受酥瓶时。绳着地者。应语。合是绳举。若净人小不能举者。应教稍稍减授我。如是一切若铛镬热不得受者。当以两木横置地。比丘脚蹑上。当作是言受受。是名食上。树上者。净人树上食果。比丘言。与我果。净人即摇树落果。堕比丘。器中者。得名为受。但非威仪如是。若以脚若以手。若以口下果时。果触枝叶。比丘当更生心言受受。得名受。若绳系悬下。若脚若手放绳下时。若触枝叶者。亦当言受受。是名为受。若净人食糗豆时比丘欲得。即从索作是言。与我糗豆。净人不欲与比丘。擗净人手。泻着衣裓中。言受受。得名为受。但非威仪猕猴树上啖果。比丘欲得果。语猕猴言。与我果。猕猴动树下果。比丘以器承取。堕器中者。得名为受。但非威仪如是。若手若脚口中下果时。若[打-丁+棠]枝叶。当更生心言受受。得名为受。是名树上。井中者。若比丘在阿练若处住。井水满。无净人。比丘自抒井有比丘言时到可出食。井中比丘言。我若出者。水更还满。我欲此间食。可下食来。净人应盛饮食着一器中。以绳纽系下食时。井底比丘应语净人言。下绳手捉。若井腹边有生草木者。应教令避之。下至井底已。比丘应一毛挽绳一手承捉。作是言受受。是名受。若井水清者。自得取饮。若浊者语净人言。持新净瓶纽系下水。如上说。是名井中。屋上者。若比丘在阿练若处住。无净人。比丘自覆屋。有比丘语屋上比丘言。食时至。可下食。比丘言。废作上下亦复难。欲此间食。可上食来。语净人言。持食着器中上。比丘下长竿拘。语净人。着是拘上。作是言受受。是名受。下绳亦如是。是名屋上。净厨者。若新作僧伽蓝。不应在东厢北厢作厨屋。应在南厢西厢作厨屋。应开风道。通利水道。出荡涤[泳-永+(米*番)]水。厨屋中当作食。栈作食时。若净人小者。比丘得自净洗。铜釜镬着水已。应语净人。汝知洗米。若净人小不能作者。得捉手教。洗教泻抒饭。若食器不覆者语令覆。若无净人者。若有净席净毡净板。得自覆。但悬放覆上。若晒谷时。比丘在谷上行者。当脚处使净人[打-丁+先]去。若师子虎狼逐。女人欲心逐比丘。舍走不看虽蹈无罪。若谷聚天雨者。当使净人覆。若无净人者。净席得遥掷覆上。得捉净塼石掷镇上。若新作僧伽蓝。净厨里有种种物。有净油。有七日油。或糗瓶石灰瓶。盐瓶草屑瓶。石蜜瓶。埿瓶甘蔗束竹束脯束。染树皮束。净屋中在。一处比丘语比丘言。汝取七日油来。比丘误捉净油来。比丘虽遥见知是净油。不得即语。恐其惊惧破器物故。待来至已问言。长老。是何等油。答言。七日油。当语置置。不得名字。得作七日受持。若言长老汝取净油来。比丘误持七日油来。不得即语。应待来至已问言。长老。是何等油。答言净油。当语置置。故名七日油。如是语取石灰瓶。误持糗瓶。语取屑末瓶。误持盐瓶。语取埿瓶。误取石蜜瓶。语取竹束误取甘蔗束。语取染树皮束。误持脯束来。广说如上。比丘语比丘言。长老。汝往审悉看灰瓶已持来。此比丘往内手瓶中把糗。看此瓶故是净。若把糗还着瓶中者。即名不净。如是屑末瓶埿瓶亦如是。若言汝审悉看竹已持来。比丘往拔甘蔗看时。故是净。若还刺束中举束不净。如是脯束亦尔。若净厨屋破穿漏语净人言出。厨里一切物。出已当塞鼠孔。扫地用拒磨埿之。壁底作塼埵。以次大者在下。小者着上。比丘得在中央立。指示安置。乳酪酥油蜜石蜜盐。不得见。厨屋坏而不治。当随法律治事。是名厨屋。器受非器者。一切叶若卷者是器。舒者非器。若盘有缘深没穬麦者。名为器。若床若坐床绳。致织者是器。若希织者非器。船在水中。非器在岸上者是器。若车驾牛时非器。无牛时是器。若比丘乞食时。店肆家以斗盛糗。与比丘。斗琐连诸升。或五升四升三升二升一升相连。比丘尔时应语施主言。解后升令相离已授我。若琐不可得解者。比丘当从索叶已。令泻叶上受。是名器受非器受。床受者。若比丘床上坐。若禅若眠。净人持食来着抱中。若觉者即名受。若不觉者。觉时欲食者。当从净人更受。若不欲食者。当自捉。已授与净人。如是着床上。悬床边亦如是。若比丘栈阁上有净食。若衣钵取衣钵时。动净物。一切尽不净。若坚不动无罪。若比丘衣架上。有酥瓶油瓶。比丘取衣时。动者亦如是。是名床。船者。船上载十七种谷。谷上敷籧篨。若席覆上。比丘得在上坐。不应名字。若名字者。是名不净。若此船卒为风吹。若下流。若回波漂船上岸者。一切皆不净。若绳若竹篙不离水者。是净。是名船。乘者。若大车上载十七种谷。谷上敷籧篨席覆上。比丘在上坐。不应字名。字名者。即不净。若小车上有净物。若衣钵。若比丘取衣钵时。动净物者。一切不净。应语净人。与我取衣钵。不得以牛作净。上时应使净人先上。然后比丘上下时。比丘先下。净人后下。若载下阪时。车翻离地离牛。一切皆不净。若下阪。若车翻牛身。及绳尾不离车者。一切是净。是名乘。心念受者。有登瞿国。是边地邪见人。恶比丘故不授食。尔时当满荼逻规地作相。若叶弊钵下。遥作是言。受受。下时觉堕钵中。时不觉得名为受。但非威仪。堕时觉。初下时不觉。得名为受。但非威仪。下时堕钵中时尽觉是名善受。若比丘乞食时。若乌鸟堕肉叚。比丘钵中下时觉非堕时。是名为受。但非威仪堕时觉。非下时。是名受。但非威仪下时觉。堕时觉是名善受。是名心念受道路者。若比丘欲共商人行。语商人言。借我净人。答言。可尔。临发时。便言。我无净人有牛。尊者须者当取。使净人长囊盛种种粮食。计日日食分。作一齐已。纽结着牛上。至食时。当使净人取。若无净人者。一人挽纽。一人承取口言受受是名受。若囊中粮食尽。道里未至所在者。当解囊净浣已。更求粮食。着囊中。纽结如前。在道行时。当随时与牛食着凉处。不得使苦恼。到已牛还本主。若比丘随道行。过甘蔗园边。从守甘蔗园人。乞作如是言长寿。施我甘蔗。答言。尊者自取。比丘言。长寿。我不得自取。又复言。若欲食者。便自取。若不欲食者便去。比丘尔时以绳纽系好甘蔗着牛头。作如是言。知是众生甘蔗园边。有火聚。即驱牛行过火。不使烧牛。使甘蔗得作净已。一人扶举牛头。一人解纽。作是言。受受是名为受。芜菁根亦如是。若牛食芜菁根时。比丘捉牛头顿逊受受。得名为受。但非威仪。比丘随道行时。净人边合囊受糗。绳未离地。得名为受。但非威仪。当教合绳授。是故说

摩诃僧祇律卷第十六摩诃僧祇律卷第十七

        东晋天竺三藏佛陀跋陀罗共法显译

    明单提九十二事法之六

佛住舍卫城。广说如上。尔时佛告诸比丘。如来以一食故。身体轻便。得安乐住。汝等亦应一食。一食故身体轻便。得安乐住。尔时尊者跋陀利白佛言。世尊。我不堪一食。何以故。我朝暮食者乃得安乐。佛告跋陀利。汝不能一食者。晨起持二钵入村乞食。一钵朝食。一钵中食故。是二食。如是第二第三教。犹言不堪。尔时诸弟子尽。受世尊教。唯除跋陀利。跋陀利惭愧故。三月不到佛所。如跋陀利线经中广说

复次佛住舍卫城。尔时诸比丘非时乞食。为世人所讥。云何沙门释子非时乞食。忘失道果。何道之有。诸比丘闻已。以是因缘。往白世尊。佛语诸比丘。汝等出家人。非时乞食。正应为世人所讥。从今日后不听非时乞食。此中亦应如优陀夷线经中广说。复次佛住舍卫城。广说如上。尔时比丘日暝食。为世人所讥。云何沙门释子夜食。我等在家人尚不夜食。此辈失沙门法。何道之有。诸比丘闻已。以是因缘。往白世尊。佛告诸比丘。汝等夜食。正应为世人所嫌。从今日后前半日听食。当取时。若作脚影若作刻漏

复次佛住舍卫城。广说如上。尔时诸比丘食前入聚落乞食。食后诣诸园池水上。世人聚集游戏处乞食。为世人所讥。汝等看是沙门释子。于我等家中乞。今来池上。复从我乞。坏失道法。何道之有。诸比丘闻已。以是因缘。往白世尊。佛言。呼是比丘来。即呼来已佛问上事。汝实尔不。答言。实尔世尊。佛问比丘。汝晨朝乞食用作何等。答言时食。复问。汝食后乞者。复作何等。答言。举作明日食。佛告比丘。汝云何停宿食食。从今日不听非时食。不听停食食

复次佛住王舍城广说如上。尔时尊者跋陀利惭愧得意故。入聚落时。如入军阵。尔时捉两钵。入聚落乞食。得已一钵作今日食。一钵作明日食。时诸比丘欲入聚落乞食。呼跋陀利言。长老。共入聚落乞食去来。答言。汝等自去。我不能去。诸比丘言。长老。大得善利。汝能一食得二日安隐。答言。我不一食得二日安隐。我入聚落时。如入军阵。故便持两钵。并乞二日食。诸比丘闻已。以是因缘往白世尊。佛言。呼跋陀利来。即呼来已。佛问跋陀利。汝实尔不。答言。实尔。佛言汝虽欲省众缘事。从今日后不听汝非时食。不听停食食。如跋陀利线经中广说

复次佛住舍卫城。广说如上尔时阿那律在仙人山岐黑方石上。晒秽烂麦饭。佛即以神力。往至其所。知而故问。汝作何等。答言。世尊。声闻弟子有信心欢喜。明日欲依。是故不入聚落乞食。佛言。汝虽欲省众因缘。从今日后不听汝非时食停食食。佛以神力即还舍卫佛告诸比丘依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘非时食。波夜提。若比丘停食食。波夜提。比丘者。如上说。非时者。若时过如发瞬。若草叶过。是名非时。食者。糗饭麦饭鱼肉。若杂食者波夜提。波夜提者如上说。比丘者如上说。停食者。名过时须臾。须臾者。二十念名一瞬顷。二十瞬名一弹指。二十弹指名一罗豫。二十罗豫名一须臾。日极长时有十八须臾。夜极短时有十二须臾夜极长时有十八须臾。日极短时有十二须臾。食者。五正食。五杂正食。若一一停食者。波夜提。波夜提者。如上说。时受非时受故受。不故受。少受多受。疾疾受。徐徐受。雪冰时受者。时受时食无罪。若时过发瞬。若草叶。过此时食者。一波夜提。停置过须臾食者。犯二波夜提。犯非时食。停食食。非时受者。非时受非时食。得一波夜提。停过须臾食者。得二波夜提。非时食停食食。如是故受。不故受多受少受。疾疾受。徐徐受。如是种种差别。受雪者。比丘欲食雪。当从净人受。若无净人者。当洗手令净。自取食。冰雹亦如是。是名冰雪。比丘晨起应净洗手。不得直粗。洗五指头。复不得齐腋。当齐腕以前令净。不得粗鲁。洗不得楷。令血出。当以巨磨草末若灰土净洗手楷令作声。净洗手已。若更相楷者。便名不净。应更洗。若洗钵已。湿时重摩拭者。已名不净。当停使燥。比丘食前时当护净手。若摩头。若捉泥洹僧革屣。若捉盛酥油革囊。当更净洗如前。若捉僧伽梨郁多罗僧当更以水洗。比丘欲出乞食时。应净洗手。着入聚落衣。着入聚落衣已。复洗手持钵入聚落。若冬寒时内钵着囊中。欲到聚落边。若池水。若流水上。应净洗手。若无水者。当入聚落中。到比丘住处。乞水洗手。若复无者往比丘尼精舍中求水。若复无者。当到信心优婆塞家求净水若复无者。当开钵囊出钵捉一处乞食。得食已还。出聚落到池水。若泉流水当置钵净草上然后净洗手净洗石。若草叶。洗已钵中指所触饭。当扟弃。已泻饭置石上。若草叶上。泻饭时不得于不净手捉处泻。泻已当更净洗钵。还盛着钵中而食。食已若有残食。当泻聚石上舍去。比丘明日复入聚落乞食。都无所得。空钵而出。不作意还从本道来。见本石上饭聚故在。若有净人。当使净人授已得食。若无净人者。有乌鸟食处。当净扟。却得自取食。若净人持不净手。行糗饭僧。上座得不净。余者得名为净。若净人持净糗。泻不净糗上得扟其上。若持不净糗。泻净糗上。一切不净。若持净糗。泻置不净器中。得扟取中央。若抖擞筐一切不净。若比丘食糗时。以手摩口。即名不净。当更洗手。若两手相楷摩者。即名不净。当更洗。若比丘病须粥当使净人煮。若阿练若处。净人难得者。得自净。洗不受腻。枪铫着水。得自然火令沸。使净人知着米。着米已。比丘不得复然。当使净人。然沸已。若净人欲去。得受取自然煮熟。熟已与病人。若比丘。服吐下药。医言应与清粥。若不得者便死当云何。尔时应以洮米泔汁。槽盛渍病比丘。若病人不堪者。取不破稻穬麦七过净洗。盛着囊中系头。净洗器煮之。不得令稻头破。若破者不得与病比丘。若阿练若处。净人病还使净人煮粥与。若无净人者。得净谷已。比丘得自舂。作粥与净人。净人若食不尽。比丘不得自食亦不得与余。比丘是故说

佛住舍卫城。广说如上。时有居士生一女。端正无双。父母欢喜。满月已为作吉祥会。父母作是念。此女端正。世之希有。若国王闻者。或能强取。我当为作不吉之字。即字为瞎眼。此女渐渐长大。王相师见之。即问言。此谁家女。有人答言。某甲居士女。王相师作是念。此女人相应。为王大夫人。相师即白王言。某甲有女。贵相应为皇后。便可纳之。王即遣人往问此女名字何等。即答言。字瞎眼。即还报王。王言。此字不吉。非我所须。后有人娶已。父母呼归家中。夫主遣使呼妇。妇家答言。当送即办送女之具。作种种饼。比丘次行乞食到其家。女母见比丘。信心欢喜言。尊者须饼不。答言须。即与种种饼。满钵持去。是比丘得是饼已。还精舍唤诸知识比丘共食诸比丘言长老。此饼甚好。汝何处得。答言。瞎眼女家得。诸比丘闻已。复往其家。复得如前。如是一一往索。送女之具都尽。如是第二第三日。夫复遣人唤复言。小待作送礼具。诸比丘日日往乞都尽。以妇不时还故。其夫大嗔作是言。我今遣信往唤。但言礼具不办而遂不来。必有外心。即便遣去。更求他女。瞎眼母闻女被遣。即大悲泣。女亦愁恼坐。母不时送故。便见被遣。诸比舍人问言。汝等何故愁忧涕泣即以上事具答。邻里。邻里人责言。汝何不先送女已。别作饮食施诸比丘。诸比丘闻已。以是因缘往白世尊。佛言。呼此诸比丘来。来已佛问比丘。汝实尔不。答言实尔。佛言。从今日后不听受送女食

复次佛住王舍城。广说如上。时城中有估客主。名无畏。与诸估客欲共远行。时估客妇家中为办种种行粮。诸比丘次行乞食。往到其家。估客妇见已。信心欢喜。问言。尊者须糗不。答言须。即分行粮。盛满钵施与比丘。比丘得已持还入迦兰陀竹园精舍。唤诸知识比丘共食。诸比丘问言。汝何处得是好食。答言。某甲估客家得。诸比丘闻已即往其家。如是人人往乞行粮都尽。如是第二第三日办粮。诸比丘随来乞尽。乃至第四日。办粮已行不及伴。为贼所劫。财物都尽。估客妇闻已忧恼悲泣。邻人问言。汝何故如是。即具以上事答邻人。邻人言。汝何不先办粮发遣行人。然后别作施诸比丘。诸比丘闻已。以是因缘。具白世尊。佛言。呼是诸比丘来。来已佛问诸比丘。汝等实尔不。答言实尔。佛言此是恶事。施者不知量。受者应知量。此非法非律非如佛教。不可以是长养善法。从今日后不听乞行粮。佛告诸比丘。依止王舍城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘往白衣家。自恣与饼糗。得受两三钵出外。共不病比丘食。若过受出外。不共不病比丘食者。波夜提。比丘者。若一若二若众多。白衣家者。刹利婆罗门毗舍首陀罗家。自恣与若饼若糗。饼者所谓大小麦米豆。如是等种种饼。糗者。大小麦米豆。如是等种种糗三钵者。极得受三钵。持出外者。从意所向不病比丘者。有力能往其家。不病比丘共食者。所赍食来应共食。若不共食者。波夜提。波夜提者。如上说。送饷行粮饼糗不为比丘为送粮。自恣与送饷者。如送瞎眼女等。行粮者如无畏估客主等。饼糗者。如上说。不为比丘者。本为余人作为送粮。自恣与者。如瞎眼女瞎眼母。自恣与如估客估客妇。自恣与比丘。得受三钵。持出外应共不病比丘食。若比丘作是念谁能作多事。为语优婆夷言。盛一钵着器中。复盛一钵着余器中。自受一钵已。语女人言。若有比丘来者。与是一钵。复有来者与是第二钵。后若复有来者。更莫与。若与者。汝少福德。比丘持食出已。道中若逢比丘者。应作如是言。某甲家有食。汝当自取分。第二比丘亦复如是非送女饼。非行道粮。为比丘不为送粮。不自恣与。非送女饼者。非如送瞎眼女。非道粮者。非如无畏估客等。为比丘者。为比丘作不为余人。不为送粮者。除此二事。为余人作。得取不犯。不自恣与随得持去。若瞎眼女去。后母与得取无罪。若女至婿家。已与得取无罪。若估客发去已。估客妇后与得取无罪。若估客到所在已。与得取无罪。若彼家嫁女娶妇饮食节会日比丘往到其家主人作如是言。尊者。我欲遣信请恐不可得。何况自来如是得自恣取无罪。是故说

佛住舍卫城。广说如上。尔时六群比丘到酥家乞酥。油家乞油。乳家乞乳。酪家乞酪。蜜家乞蜜。石蜜家乞石蜜。鱼家乞鱼肉家乞肉。为世人所讥。作如是言。瞿昙沙门。无量方便赞叹少欲知足。易养易满。毁訾多欲。无厌难养难满。而今是沙门不能乞粗食。而从酥家乞酥。乃至肉家乞肉。此坏败人。何道之有。诸比丘。以是因缘往白世尊。佛言。呼六群比丘来。来已佛问六群比丘。汝实尔不。答言实尔。佛语六群比丘。此是恶事。汝常不闻。我无量方便赞叹少欲。毁訾多欲耶。此非法非律非如佛教。不可以是长养善法。从今日后不听乞美食食。复次佛住迦维罗卫国释氏尼拘律树精舍。佛以五事饶益故。五日一行诸比丘房。见病比丘。佛知而故问汝病何似为有损不。答言不损。佛言。汝不能索随病食随病药耶。答言能乞。但世尊制戒不听乞美食。故不敢乞。我无檀越无人与者。佛言。从今日后听病比丘乞美食。佛告诸比丘。依止迦维罗卫住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若诸家中有如是美食。酥油蜜石蜜乳酪鱼肉。如是美食不病比丘为身索者。波夜提。家者。如上说。酥油蜜石蜜乳酪鱼肉。如上第二盗戒中说。如是名为美食。病者世尊说无罪。病者。黄烂痈痤痔病不禁。黄病疟病。咳嗽痟羸风肿水肿。如是种种。是名为病。为身者为己索。若自索。若使人索食者。波夜提。波夜提者。如上说。若比丘热病。医言。此病应服酥。得乞酥不得。往不信家索。何以故。索时讥比丘。但贪美味故索酥。讥嫌比丘长短者。不得往索。当到信心优婆塞家索。得时当自筹量。若比丘风病。医言。应服油。尔时得乞油不得从笮油家乞。亦不得到不信家。如酥中说。若比丘水病医言。此应服蜜。尔时复得乞蜜不得。到采蜜家乞。亦不得。到不信家乞。如酥中说。若比丘干痟病。医言。此应服石蜜。不得到笮甘蔗家。索不得。到不信家索。如酥中说。若比丘中冷。医言。应用石蜜酪二种合服。不得到不信家索。如酥中说。若比丘下病。医言。此应服乳。尔时得从放牛人边乞乳。得时当筹量取。若比丘欲使吐下服吐下药。医言。当先服鱼汁。尔时得乞鱼汁不得。从捕鱼家乞不得。到不信家乞。如上说。若比丘欲刺头出血。若服吐下药。医言。此应服肉汁。尔时得乞肉汁不得。到屠家不信家乞。如上说。若比丘乞食行到量酥人边。量酥人言。尊者。欲求何等。答言。欲乞食。白言。无食。正有此酥。若须当与。比丘尔时须者得受满钵无罪。若有伴者。得劝与无罪如是。量油蜜石蜜乳酪亦如是。若比丘乞食得糗饭满钵键镃中无所得。得从索浆。若檀越言无浆。正有肉汁须者当与。尔时得取。若复问言。亦有肉。须者当与。尔时得满器取无罪。亦得从笮甘蔗家索甘蔗浆。若言无甘蔗浆。正有石蜜须者当与。比丘须者得取满钵无罪。亦得劝与伴。亦得到笮油家乞麻滓。若主人言我无麻滓。须油者当与。须者得取满钵无罪。亦得劝与伴。得乞酪底清汁。若言我无酪底清汁。正有乳酪须者当与。比丘须者得取满钵无罪。亦得劝与伴。得乞甘蔗得。为客比丘远行。比丘乞美食。若自在道行时。亦得乞。若比丘一处乞得八种美食。各各别食。得众多。波夜提。若比丘八种食异处乞一处食。得一波夜提。众多处乞各各别食。得众多波夜提。一处并索得种种食。合一时食。得一波夜提。不病时乞病时食。得越毗尼罪。病时乞不病时食无罪。病时乞病时食无罪。不病时乞不病时食。波夜提。不随病煮随病食无罪。随病煮不随病食。得越毗尼罪。随病煮随病食无罪。不随病煮不随病食无罪。何以故。出家人因他活命故。是故说

  施一食处处　　食足强劝彼
  不受食而食　　非时停食食
  两三钵美食　　别众食在后

第四跋渠竟(只桓精舍中梵本虫啖脱无此别众食戒)

佛住舍卫城祇树给孤独园。尔时世人笃信恭敬尊重。供养衣食床卧病瘦医药。尔时出家外道亦在舍卫城。世人不恭敬供养尊重衣食床卧病瘦医药。时有众多出家外道。集论议堂作如是论。是沙门瞿昙住舍卫城祇树给孤独园。世人深信恭敬尊重。供养衣食床卧病瘦医药。我等不得尊重供养衣食床卧病瘦医药。谁能往沙门瞿昙法中出家修梵行。诵习彼法已。还我法中我等展转相教。亦当还得供养。与彼无异。时外道作如是论已。皆言。须深摩者于我众中最为第一。可遣到沙门瞿昙法中出家受彼律仪还来入此。时彼外道语须深摩。作如是言。沙门瞿昙在只桓精舍。多人供养尊重。我等不得此利。汝今可往沙门瞿昙法中出家修梵行。受诵彼经已。还我法中展转相教。亦当还得供养与彼无异。须深摩闻是语已。出舍卫城。往只桓精舍。精舍门间。见有诸比丘经行坐禅。须深摩即往诸比丘所。共相问讯。在一面坐。作是言。我本是外道。今欲于如来法中出家受具足。此中应作何等。诸比丘答言。若本是外道。欲于如来法中出家者。当试之四月。四月过已。得诸比丘意者。当与出家。时须深摩即受教行四月。过已得诸比丘意。便与受具足。受具足已。往世尊所。头面礼足。却住一面。尔时有众多比丘。来到佛所。头面礼足。却住一面。作是言。我已得证。我生已尽。梵行已立。更不受后有。说是语已。头面礼佛足而退。是诸比丘。去未久须深摩头面礼佛足已。诣彼比丘所。共相问讯。问讯已在一面坐。问诸比丘言。长老。向在佛所自言我已得证。我生已尽梵行已立。更不受后有。答言如是。时须深摩复问言。长老。如是知如是见。得清净天眼。见众生死此生彼。好色恶色善趣恶趣。见众生身行恶。口行恶。意行恶诽谤贤圣。自行邪见。教人行邪见。身坏命终堕三恶道。又见众生身行善。口行善。意行善。自行正见。教人行正见。身坏命终生于善处。天上人中。如是过人清净天眼。长老得不。答言不得复问。尊者如是知如是见得宿命智。知过去一生二生三生四生五生十生百生千生。乃至劫成劫坏。名姓种族。死此生彼。死彼生此。如是无数劫事。长老知不。答言不知。复问。离色过色无色寂灭解脱身证具足住。是诸解脱。长老得不。答言不得。须深摩言。向者所问诸法皆言不得。云何于世尊前。自言我已得证。我生已尽梵行已立。更不受后有。谁当信者。诸比丘答言。长老。我是慧。解脱人。须深摩言。所说简略义相未现。可更广说。比丘言。虽义相未现。我自了知。慧解脱人。时须深摩闻诸比丘语已。作是念。我当往诣世尊所。问如是事。世尊有所解说我当受持。作是念已。从坐起往诣佛所。头面礼足。却住一面具以上事广白世尊。是事云何。佛告须深摩。先法智后比智。须深摩又白佛言。世尊所说隐略。我犹未解。佛告须深摩。汝虽未解故。先法智后比智。须深摩白佛言。善哉世尊。我犹未解。唯愿世尊。广为我说。佛告须深摩。我还问汝。随汝所解答我。须深摩于意云何。缘生故有老死不。答言如是世尊。佛言。善哉须深摩。于意云何。无明缘故。生诸行不。答言如是。佛言。善哉须深摩。于意云何。生缘灭故老死灭不。乃至无明灭故诸行灭不。答言如是。善哉须深摩。佛告须深摩。若比丘于此法中正观正知。所应得者。尽皆得不。答言如是。又问须深摩。汝知缘生故有老死不。答言如是。缘无明故有诸行不。答言如是。又问。生缘灭故老病死忧悲苦恼盛阴灭不。答言如是。无明灭故诸行灭不。答言如是。佛告须深摩。汝知如是法者。汝得天眼宿命智诸解脱得不。答言。不得世尊。佛告须深摩。汝自言知如是诸法而复言不得。是诸功德谁当信者。须深摩白佛言。世尊。我为无明恶邪所缠缚故。生如是邪见。我从世尊所。广闻正法灭恶邪见。得法眼净。须深摩即头面礼佛足。胡跪合掌白佛言。世尊。我于如来正法中。贼心出家。为偷法故。世尊大慈唯愿受我悔过。佛告须深摩。汝痴如小儿。于佛正法中为偷法故。贼心出家。我受汝悔过。佛告须深摩。譬如有人犯罪于王。王使人裂解支节。刵劓耳鼻。锯解刀折。段段斫截。象蹈马踏。如是种种若毒断命。汝于佛法中贼心出家。为偷法故罪过。于是我受汝悔过。于贤圣法中得增长故。从今日后勿复更作。以世尊度须深摩故。毗舍离栴檀钵降伏外道。目连作神足故。人民倍生敬信得利养。因是故诸外道横作诽谤世尊。如孙陀利经中广说。佛未出世时。外道得种种供养。佛既出世一切外道皆失利养。何以故。知佛法深妙故。如孔雀鸟本生经中广说

尔时世尊厌世供养。还向舍卫城。到时着入聚落衣。持钵入舍卫城。次行乞食。食已彷徉经行。自收床褥不语众僧及侍者。佛独游行憍萨罗国。尔时诸比丘往阿难所。语阿难言。长老。世尊食后彷徉经行已。自收床褥。不语众僧及侍者。佛独游行憍萨罗国。阿难答言。长老。若如来应供正遍知食后彷徉经行。自收床褥。不语诸比丘及侍者。独游行者欲求寂静故。诸比丘不应随从。尔时世尊从憍萨罗国。游行到波利耶娑罗林贤树下住。时五百群象游行。象王恒在后。得浊水残草厌患。群众故亦复独来。诣此树下。象王既至树下。见佛已即以鼻拔草蹈地令平。以鼻盛水洒地掩尘。又取软草敷以为座。屈膝请佛令坐。见佛坐已。即便请佛。三月供养。佛知象王意。即受其请。佛因是事而说颂曰

  独善无忧　　如空野象　　乐戒学行
  奚用伴为

尔时象王取好藕根。净洗已授与世尊。佛住三月受象王供养。尔时五百比丘三月不见佛故。往诣尊者阿难所白言。长老。我等久不见佛。又不闻法。我等今欲往礼觐世尊。听受法教。阿难答言诸长老可小停此。须待我还。答言。善哉。阿难即往尊者大目连所。作如是言。长老。五百比丘来诣我所言。久不见佛。不闻正法。欲往诣佛礼觐供养听受法教。长老。观佛为在何处。目连即入三昧。观一切世间。见佛在波利耶娑罗林贤树下。受象王供养。见已即向阿难说此颂曰

  舍离莲花池　　身体鲜满足
  身无垢清净　　乐独静林中
  得甘露深法　　相好身具足
  心清净无垢　　舍众乐静林

目连说此偈已。语尊者阿难。世尊今在波利耶娑罗林贤树下。受象王供养。汝欲往者今正是时。尊者阿难还到诸比丘所。作如是言。世尊今在波利耶娑罗林贤树下。受象王供养。我等今共往世尊所。礼觐问讯。诸比丘闻阿难语已。即便共去。往波利耶娑罗林贤树下。去世尊不远。阿难语诸比丘言。长老。如来应供正遍知在阿练若处。不应径往。长老等可小住此。我当先往。答言。善哉阿难。即往诣佛。佛遥见阿难来。作如是言。善来阿难。久不见汝。尊者阿难头面礼佛足已。作如是言。世尊。少病少恼安乐住不。佛言。如来少病少恼安乐住受象王供养。问阿难言。比丘僧少病少恼安乐住不。乞食不疲行道如法不。答言。世尊。比丘僧少病少恼安乐住。乞食不疲。行道如法。即复白言。五百比丘今在林外。欲来奉觐。唯愿听许。佛言。听入。阿难即往诸比丘所语言。长老。得大善利。世尊听入。诸比丘即随阿难。俱到佛所。头面礼足。却住一面。时坐中有一比丘。作如是念。云何比丘如是知如是见。次第得漏尽。作是默念。不敢问佛。世尊知彼比丘心之所念。即告阿难言此坐中有一比丘。作如是念。云何比丘如是知如是见。次第得漏尽。默作是念。而不敢问佛告阿难。我先已为诸比丘。说阴界入十二因缘观。若比丘如是知如是见。得尽诸漏。是比丘闻世尊语已。即作是念。色是我。尔时世尊知是比丘心之所念。复告阿难。是比丘作如是念。色是我。阿难当知。若有比丘作如是观色是一切诸行。无明触受生爱。阿难爱何因何缘。何生何转。阿难当知。爱者。受因受缘受生受转。阿难当知受者。触因触缘。触生触转。阿难当知。触者。六入因六入缘。六入生六入转。阿难当知。六入是有为法因缘和合生。无常摩灭法。触是有为法。因缘和合生无常摩灭法。受是有为法。因缘和合生无常摩灭法。爱是有为法。因缘和合生无常摩灭法。行是有为法。因缘和合生无常摩灭法。无明是有为法。因缘和合生无常灭法。如是阿难。若比丘如是知如是观。次第得尽有漏。是比丘闻是语已。作如是念。色非我色是我所有。佛知彼比丘心中所念。复告阿难言。是比丘作如是念。色非我色是我所有。阿难当知。若比丘作如是观。色一切诸行。无明触受生爱。爱何因何缘。何生何转。阿难当知。爱是受因受缘。受生受转。乃至无明有为行。因缘和合生。无常摩灭法。是比丘闻是语已。作如是念。色非是我亦非是我所有。我中有色。佛知是比丘心中所念。乃至无明有为行。因缘和合生。无常摩灭法。是比丘闻是语已。作如是念。色非是我非是我所有。亦非我中有色。色中有我。佛知是比丘心中所念已。乃至无明有为行。因缘和合生。无常摩灭法。是比丘闻是语已。作是念。若色非是我非是我所有。非我中有色非色中有我者。受是我。想行识亦如是。若五阴非是我非我所有。非我中有五阴。非五阴中有我者。云何而有我。佛告阿难。若如是观五阴一切诸行无明触受生爱。阿难爱何因何缘。何生何转。爱受因受缘。受生受转。阿难当知。受触因触缘。触生触转。阿难当知。触六入因六入缘。六入生六入转。阿难当知。六入是有为行。因缘和合生。无常摩灭法。乃至无明有为行。因缘和合生。无常摩灭法。如是阿难。若比丘如是知如是观次第得尽有漏。是比丘闻是语已。得法眼净。比丘复重思惟。一切诸法皆悉空寂。无我无我所有。佛语阿难。是比丘作是思惟时。不受一切法。得尽诸漏。心得解脱。佛为比丘说是法时。五百比丘心得解脱。皆成罗汉。尔时世尊与诸比丘共住。秋月非时寒雨。比丘持空中大木然火。木中先有大蛇。蛇得火热即出擎头。逐诸比丘。诸比丘展转相语。高声大唤。蛇出蛇出。佛知而故问。诸比丘何故高声大唤。答言。非时寒雨诸年少比丘持空中木然火。木中有蛇。得热故出逐诸比丘。诸比丘见已展转相语。是故大声。佛言。呼是比丘来。来已佛告诸比丘。然火有七事无利益何与七。一者坏眼。二者坏色。三者身羸。四者衣垢坏。五者坏床褥。六者生犯戒因缘。七者增世俗言论。有此七过故。从今日后不听然火

复次佛住舍卫城。广说如上世尊五事利益故。五日一行诸比丘房。见一比丘患疥[癈-(弓*殳)+虫]。佛知而故问。比丘调适不。不苦不。答言。我病疥[癈-(弓*殳)+虫]不乐。火炙身得安乐。世尊制戒不得然火。是故不乐。佛言。从今日后听病比丘得然火

复次佛住舍卫城。广说如上。尔时尊者难提金毗鲁跋提在塔山安居竟。至舍卫城。礼观世尊。着被雨衣染色脱坏。佛知而故问。比丘。何故着被雨衣。答言。世尊制戒不得然火。是故不得煮染更染。佛言。从今日后除因缘。佛告诸比丘。依止舍卫城比丘皆令集。以十利故。为诸比丘制戒。乃至已闻者当重闻。若比丘无病自为然火。若草木牛屎。若自然。若使人然。波夜提。除因缘。比丘者如上说。病者无罪。病者若癣疥[癈-(弓*殳)+虫]黄。烂风病。如是种种病须火得乐者听然。草者。一切草及芦荻竹等。木者。一切木若破若完牛屎者。若自然。若使人然。除因缘。世尊说无罪。因缘者。若直月若鉴知食事。若次直然火然灯。温室中然火。若为和上阿阇梨然火。若暖水若熏钵染衣然火无罪。除因缘。波夜提。波夜提者如上说。若持薪火着薪上。着草上牛屎上。木札上粪扫上。波夜提。如是乃至持粪扫火着薪上草上。牛屎上木札上亦如是。比丘向草木火中。有已然者有未然者。比丘跋聚者波夜提。若跋火落未烧地越毗尼罪。得持铁抟瓦跋火聚无罪。若旋火作轮波夜提。若比丘向火。火上截草着火中随截一一波夜提。若然草木火波夜提。若然茎种得二波夜提。犯然火杀种。若破若火净。若有因缘事然无罪。若秸有谷。若穰有谷然者。得二波夜提。然火杀种应火作净。有因缘然无罪。若然发马毛骆驼毛等。得越毗尼罪。若然皮得越毗尼罪。若烧饼越毗尼罪若烧毒药及炭越毗尼罪。若食不消得烧铁铄脚案腹无罪。若革屣跋火越毗尼罪。是故说

佛住旷野精舍。广说如上。尔时营事比丘雇人作塼作泥。是作人或宿僧食堂中禅坊中温室中。涕唾不净大小便处处秽污。妨诸比丘坐禅行道。诸比丘以是因缘往白世尊。佛言。呼营事比丘来。来已佛问比丘。汝实雇作人处处秽污。妨诸比丘坐禅行道不。答言实尔。佛言。何故尔。答言。我欲使作人早作晚止。得尽价直。佛言。虽尔从今日后不得与未受具足人同室宿

复次佛为菩萨时。在家父王爱惜。恐转轮王种灭。愁忧泣泪不听出家。以怀妊罗睺罗故便舍出家。佛告诸比丘。如来柔软乐人无有能过父王。为作三时殿春夏冬。如柔软线经中广说。乃至如来得成等正觉。诸比丘白佛言。世尊。何故乃六年苦行如是。佛言。非但今日。如鸟本生经中广说。诸比丘白佛言。云何魔波旬恒欲坏乱世尊。佛言。不但今日。如鳖本生经中广说。迦维罗卫国父子相见。应此中广说乃至大爱道耶输陀罗罗云出家。应此中广说。佛为亲里故。还迦维罗卫国。诸清信人为佛作厕屋。佛虽不须顺世人故受。时尊者罗睺罗露地眠。时夜风雨。即往尊者舍利弗房前扣户。问汝是谁。答言。和上。我是罗睺罗。语言。汝但彼住复到尊者大目连房前扣户。问言。汝是谁。答言。阿阇梨。我是罗睺罗。语言。汝但彼住。如是复至余房。皆言彼间住。即往到世尊厕屋中枕厕板而卧。夜有黑蛇。亦畏风雨故。欲来入厕屋中。佛常观众生。见此黑蛇欲入厕屋。畏蛇恼罗睺罗故。即放光明自至厕上。作是言。汝是谁。世尊。我是罗睺罗。佛言。罗睺罗。汝乃在此耶。答言。世尊。我得是处已为过多。佛即以金色细滑手扶令起。佛拭身上尘土已将入自房。指示床前言。汝此中住。时如来已与诸弟子制戒。是故顺行此戒。是故世尊跏趺坐。到地了已。告诸比丘。如来慈心故。因罗睺罗使诸弟子得安乐住。从今日后听未受具戒人得三夜同室宿。四夜时应别住。诸比丘白佛言。世尊。有何因缘罗睺罗六年在胎。佛告诸比丘。往昔有仙人。名梨波都。诣王求相见。王报仙人。汝且住无忧园中。须臾当与相见。作是教已。乃至六日不与相见。尔时王者罗睺罗是。以是因缘故。六年在胎。如生经中广说佛告诸比丘。依止迦维罗卫住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘与未受具戒人同室过三宿者波夜提。比丘者如上说。未受具足者除比丘比丘尼。比丘尼虽受具足。亦不听共三宿。三宿者限齐三宿。同室者共一覆一障宿者波夜提。波夜提者如上说。一房别户有隔无罪。异房共户波夜提。一房一户波夜提。异房异户无罪。有障有覆波夜提。有障半覆越毗尼罪。有障无覆无罪。有覆有障波夜提。有覆半障越毗尼罪。有覆无障无罪。比丘房内宿。未受具戒人房内宿波夜提。比丘房内宿。未受具戒人半身在内越毗尼罪。若尽出外无罪。未受具戒人房内宿。比丘房内宿波夜提。未受具戒人房内宿。比丘半身在内越毗尼罪。若尽出外无罪。若比丘在房内先卧。未受具足人后来入卧一一波夜提。若比丘若未受具足人。夜中若起大小行。若起已还眠。如是一一波夜提。若众多未受具足人先入眠。比丘后来眠犯一波夜提。中间若起大小行已还卧随起一一波夜提。若三宿与未受具戒人同室宿。第四宿时当异房。若露地露地天大风雨雪寒时当还入房坐。至地了。若比丘老病不堪坐者。当以缦障。若齐顶若齐腋缦下。至地当用致物。作不得容猫子过。若比丘在道行时。得共未受具戒人同屋三宿。第四夜当别宿。若露地宿。若天风雨雪寒时当入屋。如是如上张缦作障。若无障缦坐至地了。若老病不能坐者。若未受具足人。可信者应语言。汝眠我当坐。比丘欲眠时当呼使觉。我眠时汝坐。若眠者汝无福德。此同室宿戒罪未悔过。复共宿者罪转增长。悔过已。当别房宿。更得共宿。是故说

佛住舍卫城。广说如上。尔时比丘僧集欲作羯磨。时优波难陀不来。即遣使往唤言。长老。僧集欲作羯磨。唤长老。优波难陀知戒律相与羯磨。欲与羯磨。欲已取欲。比丘言。汝与欲后勿复有余言。时优波难陀共行弟子僧中。作举羯磨。作举羯磨已。来到和上边。作是言和上。何以与是欲。师言何以故。弟子言。众僧为我作举羯磨。师言。我不知。闻是语已。便作是言。长老。我不与欲不好不好。与羯磨不成就。我不与此羯磨欲。时诸比丘闻已。惭愧不乐。以是因缘。往白世尊。佛言。呼优波难陀来。来已乃至佛言。此是恶事。汝云何与欲已。复言。不与羯磨不成就。我不与是欲。汝云何不问便与欲。从今日后不听不问事与欲。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘与欲已。后嗔恚不喜。作如是言。我不与欲不好。与羯磨不成就。我不与此欲波夜提。比丘者如上说。与欲有二种。不问与问与。问与者问取欲人作何等事。答言。作折伏羯磨。与折伏羯磨欲。乃至举羯磨。与举羯磨欲。如是一一羯磨。问已与欲。是名问与。不问与者我与羯磨欲。如是三说。如是得通名与一切羯磨欲。唯除布萨自恣。是名不问与欲。后者作羯磨竟嗔恚不喜。嗔恚不喜者嗔名为九恼及非处起嗔。第十恚名学人凡夫有乃至罗汉亦有不喜。作如是语。我不与欲不好。与羯磨不成就。我不与是欲者波夜提。波夜提者如上说。若比丘僧集欲作羯磨一切尽应来。若有缘事。若熏钵染衣。若病塔事僧事有缘事。尔时当与欲。不得与欲已后作是言。我若彼闻者。此事不应如是作。若先已与欲羯磨者。后当随喜。若僧中与欲已后更违者波夜提。若众多人中若长老比丘前若和上阿阇梨前。与欲已后更违者越毗尼罪。是故说

佛住舍卫城。广说如上尔时优波难陀是难陀弟。语难陀共行弟子。作如是言共汝入聚落。到彼当与汝美饮食。我若作非威仪事。汝勿向人说。我是汝叔父。此中应如卅事中广说乃至语难陀言。汝弟子云何在梵行人前说我过。难陀即嫌弟子。汝是弊物。云何在梵行人前说我弟过。诸比丘以是因缘。往白世尊。佛言。呼优波难陀来。来已佛问。汝实尔不。答言。实尔。佛语优波难陀。此是恶事。汝云何语比丘作是言。共汝入聚落。到彼当与汝美食。到已发遣令还。从今日后不听遣还。佛告诸比丘。依止舍卫城住者皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻若比丘语比丘。作如是言。共入聚落到彼当与汝食。若自与若使人与。后欲驱去。作是言。汝去。我共汝住共语不乐我独住独语乐。作是因缘。不异驱者波夜提。比丘者如上说。聚落者。如上盗戒中说。后不与者。自不与。又不使人与。作是言。长老。汝去。我共汝住共语不乐。我独住独语乐。驱者波夜提。波夜提者如上说。欲道中作非威仪事。即精舍中留者越毗尼罪。欲道中作非威仪。道中遣还者越毗尼罪。欲聚落中作非威仪事。聚落中遣者波夜提。不得将去已驱还。若力不能得。二人食得遣还无罪。若能得二人食应共食。若为取药呼医师遣者无罪。若不能得者。应时发遣。若有请食处。应遣请食处食。若无请食处。精舍中有食者。遣还精舍中食。若无精食无精舍中食得。语言。长老。汝自行求食。若彼作非威仪事。视瞻不端。发遣者无罪。若作熏钵染衣事。发遣者无罪。驱比丘者波夜提。驱比丘尼者偷兰遮。驱学戒尼沙弥沙弥尼者越毗尼罪。下至俗人越毗尼心悔。是故说

佛住舍卫城。广说如上。时尊者阿利吒谤契经。作如是言。如来所说法我知。世尊说障道法者。习此法不能障道。时诸比丘作是言。长老。阿利吒莫谤契经。此是恶见不善见。堕恶道入泥犁中。一谏二谏三谏不止。诸比丘以是因缘。往白世尊阿利吒。谤契经。作是言如来说法我知。世尊说障道法。习此法不能障道。一谏二谏三谏不止。佛告诸比丘。是阿利吒谤契经。作是言。如来说法我解知。世尊说障道法。习此法不能障道。一谏二谏三谏不止者。汝等当于屏处三谏。多人中三谏。众僧中三谏。屏处谏者。应当问作是言。长老阿利吒。汝谤契经。作是言。如来说法我知。世尊说障道法。习此法不能障道已三谏不止耶。答言。实尔。尔时屏处应谏作是言。阿利吒。汝谤契经。此是恶见不善见。当堕恶道入泥犁中。长老。我慈心谏。汝欲饶益故。汝当舍此事。一谏已过二谏在。汝当舍此事。阿利吒言。是好见善见。我相承已来父母知识常用此见我今不能。不问父母知识而舍此见。若如是第二第三谏。犹故不止者。乃至众多人中三谏。若不止者。应众僧中作求听羯磨。大德僧听。阿利吒谤契经。作是言。如来说法我知。世尊说障道法。习此法不能障道。已屏处三谏。多人中三谏不舍此事。若僧时到。僧今亦复于僧中三谏。令舍此事。众僧中应问。长老阿利吒。汝实谤契经。作是言。如来说法我知。世尊说障道法。习此法不能障道。已屏处三谏。多人中三谏。不舍此事耶。答言。实尔。僧中应谏。谏法者作是言。阿利吒。如莫谤契经。谤契经者堕恶道。入泥犁中。长老。僧欲饶益汝。汝当受僧语。一谏已过余二谏在。汝当舍此事。阿利吒言。此是好见善见。我父母已来相承用此见。我不能不问父母而舍此见。如是第二第三谏。犹故不止诸比丘以是因缘。往白世尊。佛语诸比丘。阿利吒比丘谤契经。作是言。如来说法我知。世尊说障道法。习此法不能障道。已屏处三谏。多人中三谏。僧中三谏。不舍此事。汝等应与阿利吒比丘作举羯磨。佛告诸比丘。依止舍卫城比丘。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘作是语。长老。世尊说法我知。世尊说障道法。习此法不能障道。诸比丘应谏。是比丘作是言。长老。汝莫谤世尊。谤世尊者不善。世尊不作是语。世尊说障道法。实能障道。汝舍此恶事。诸比丘谏是比丘。故坚持不舍。如是第二第三谏。舍者善。若不舍。僧应与作举羯磨。已得波夜提。比丘者如上说。世尊者。是一切智人。一切见人。法者。世尊所说。世尊所印可。世尊说者。世尊自说。印可者。诸弟子说世尊印可。说者句句分别说。知者。是等智知。障道法者。五欲眼见色爱念。心悦生欲着。如是耳鼻舌身细滑亦如是。习者。行是事。不能障道者。不障初禅二禅三禅四禅。须陀洹斯陀含。阿那含阿罗汉果。诸比丘者。若一人。若众多人。若僧。是比丘者。如阿利吒比丘。莫谤世尊者。不实取不好取。三谏者。若一人。若众多人。若僧。波夜提者如上说。乃至三谏。若舍者好若不舍者。僧应与作举羯磨。波夜提悔过。是故说

摩诃僧祇律卷第十七摩诃僧祇律卷第十八

        东晋天竺三藏佛陀跋陀罗共法显译

    明单提九十二事法之七

佛住舍卫城。广说如上。时阿利吒比丘不舍恶见。众僧作举羯磨已。往尊者难陀优波难陀所。见已赞言善来。即起迎与小床坐洗足水。与涂足油非时浆。与房舍床褥卧具。共法食味食。阿利吒比丘到祇洹精舍门前。语诸比丘言。长老。汝等与阿利吒比丘。作举羯磨。谓更无住处耶。我乃更得诸梵行比丘共住。与我房舍床褥卧具。共我法食味食。汝等早举我者。当早得如是好住处。诸比丘闻是语已。惭愧不乐。即以是因缘。往白世尊。佛言。呼难陀等来。来已佛问难陀。汝等实尔不。答言。实尔世尊。佛言。此是恶事。汝云何知众僧作举羯磨已。复共法食味食。此非法非律。非如佛教。不可以是长养善法。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故与诸比丘制戒。乃至已闻者当重闻。若比丘知比丘作恶见不舍。僧作举羯磨。若未作如法共食共同室住波夜提。比丘者如上说。知者若自知若从他人闻。恶见者如阿利吒等谤契经。未作如法者。僧未与解举摈羯磨。共食者。共法食味食。共住者同界。同室者共同一覆一障。波夜提者。如上说。若有一比丘为和上阿阇梨所嫌。比丘不得诱引。言我与汝衣钵疾病医药床褥卧具。汝当在我边住。受经诵经。若观彼比丘因缘。若是必当舍戒就俗者。得诱取。诱取已。当教言。汝当知。和上阿阇梨其恩甚重难报。汝应还彼目下住无罪。举不举想共住共食。越比尼罪。不举举想共住共食。越毗尼罪。举举想。波夜提。不举不举想无罪。是故说

佛住舍卫城。广说如上。尔时阿利吒有沙弥。字法与。作是言。长老。如来说法我解知世尊说淫欲障道法。习淫法不能障道。时诸比丘作是言。沙弥。汝莫谤世尊。谤世尊者不善。汝不善取世尊说习淫法实障道。一谏二谏三谏不止。诸比丘以是因缘。往白世尊。佛语诸比丘。是法与沙弥作是语。如来说法我解知。世尊说淫法障道。习淫不能障道。汝等当屏处三谏。多人中三谏。僧中三谏。令舍此事。屏处应问言。汝沙弥。实作是语。如来说法我解知。世尊说习淫欲障道法。习淫法不能障道。汝已三谏不止耶。答言。实尔。尔时屏处应谏。沙弥。汝莫谤世尊。谤世尊者不善。汝不善取世尊说习淫欲实障道。我今慈心谏汝。欲饶益故。汝取我语。一谏已过余二谏在。汝舍此事不。若不舍应第二第三谏。亦复如是。多人中三谏。亦复如是若不舍者。僧中应作求听羯磨。大德僧听。是法与沙弥。作是言。如来说法我解知。世尊说淫欲障道法。习淫欲不能障道。已屏处三谏。多人中三谏而不舍。若僧时到。僧今亦应三谏。令舍此事。僧中应问。沙弥。汝实作是语。如来说法我解知。世尊说淫欲障道法。习淫欲不能障道。已屏处三谏。多人中三谏而不舍耶。答言。实尔。僧中应作是谏。汝沙弥。莫谤世尊。谤世尊者不善汝不善取习淫欲实障道。众僧慈心谏汝。为饶益故。汝当取僧语。一谏已过余二谏在。汝当舍此事。若不舍第二第三亦如是谏。犹故不舍。诸比丘以是因缘。往白世尊。佛告诸比丘。是法与沙弥作如是言。世尊说淫欲障道法。我解知习淫欲不能障道法。已屏处三谏。多人中三谏。僧中三谏不舍者。应驱令出众。驱出已往。至六群比丘所。见已赞言。善来。与非时浆。与房舍与床褥卧具。与衣钵病瘦医药。沙弥得是种种供给已。到祇洹门前。语诸比丘言。长老等。驱我出众。谓我更不能得住处。我今乃更得梵行人共住。与我房舍床褥卧具。共我法食味食。与我衣钵病瘦医药。诸长老。若早驱我者。我当早得如是乐住。诸比丘闻是语已。心不悦。即以是事。往白世尊。佛言。呼六群比丘来。来已佛问六群比丘。汝实尔不。答言。实尔。佛告六群比丘。此是恶事。汝云何知沙弥恶见不舍。众僧如法驱出。汝云何共住法食味食。此非法非律。非如佛教。不可以是长养善法。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻若沙弥作如是言。如来说淫欲障道法我解知。习淫欲不能障道。诸比丘应谏沙弥作是言。汝沙弥莫谤世尊。谤世尊者不善。世尊说习淫欲实障道。汝舍此恶见。诸比丘谏是沙弥。故不舍者。应如是第二第三谏。若舍者善。若不舍诸比丘应作是言。从今日汝沙弥不应言。佛是我师。亦不得共比丘三宿。汝去不得此中住。若比丘知沙弥恶见不舍驱出。未作如法诱唤畜养。共食共同室住。波夜提。沙弥者。如法与沙弥等。世尊者。一切良福田一切智人一切见人。法者。佛所说佛所印可。佛所说者。佛自说。印可者。诸弟子说佛印可。说者。句句分别解说。知者。是等智知。障道法者。五欲眼见色爱念。心悦生欲着。如是耳鼻舌身细滑。亦如是。习者。行此事。不障道者。不障初禅二禅三禅四禅四无色定。不障须陀洹果斯陀含果。阿那含果阿罗汉果。诸比丘者。若一人。若多人若僧。是沙弥者。如法与沙弥等。谤世尊者。不实取不善取。三谏者。若一人。若众多人。若僧。谏舍者善。若不舍者应驱出。比丘者。如上说。知者。若自知若从他闻。驱出者。驱出僧伽蓝。沙弥者。如法与沙弥等。未作如法者。未舍恶见。僧未听入畜者。与依止养者。与衣钵疾病医药。共食者。法食味食。共住者。共一僧伽蓝住。同室者。共一覆一障。波夜提者。如上说。若沙弥为和尚阿阇梨所嫌。比丘不得诱呼共住。我当与汝衣钵医药。当教汝经。若彼知是沙弥。因此还俗者。得软语诱取。诱取已。应语沙弥言。和尚阿阇梨恩重难报。汝当还彼目下。若驱不驱想。越毗尼罪。不驱驱想。越毗尼罪。驱驱想。波夜提。不驱不驱想无罪。是故说

佛住王舍城。广说如上。尔时诸比丘着未截缕叠衣。外道亦着未截缕衣。时优婆塞欲礼比丘。而礼外道。闻咒愿已。乃知是外道。优婆塞心怀惭愧。外道弟子欲礼外道。而礼比丘。闻咒愿已。乃知是比丘。外道弟子心怀惭愧。诸比丘以是因缘。往白世尊。佛言。从今日后当作异衣截缕染色。比丘即截缕染作异色。时外道持赤石染衣作色。留周罗持三奇杖作异

复次佛住舍卫城。广说如上。尔时旷野比丘得憍舍耶衣。煮染汁欲染。世尊乘神足空中往比丘所。知而故问。比丘。欲作何等。答言。煮染汁欲染憍舍耶衣。佛言。憍舍耶软细染汁粗涩损坏此衣。佛言。从今日后憍舍耶衣作二种净。截缕净青净

复次佛住舍卫城。广说如上。尔时毗舍离比丘得软钦婆罗衣。煮染汁欲染。佛以神足往到其所。知而故问。比丘。汝作何等。答言。煮染汁欲染钦婆罗。佛言。钦婆罗软细染汁粗涩损坏破衣。佛言。从今日后听钦婆罗衣作二种净。截缕净青净

复次佛住舍卫城。广说如上。尔时尊者孙陀罗难陀佛姨。母子大爱道所生。有三十相。少白毫相耳垂埵相。乞食已。从舍卫城中出。时尊者阿难在后。诸比丘食已。在祇洹精舍门间经行坐禅。遥见其来谓是世尊。即皆起迎叉手合掌言。世尊来世尊来。孙陀罗难陀亦叉手合掌作是言。诸长老。我是孙陀罗难陀。我是孙陀罗难陀。诸比丘闻其语已。各怀惭愧。以是因缘往白世尊。佛言。从今日后当作点坏色衣。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘得新衣。当三种坏色。若一一坏色青黑木兰。若不作三种。一一坏色受用者。波夜提比丘者。如上说。得者。若男若女。若在家出家人边得新衣者。最初成衣者。钦婆罗衣。叠衣。刍摩衣憍舍耶衣。舍那衣。麻衣。驱牟提衣。三种坏色。若一一坏色者。青黑木兰。青者。铜青长养青石青。铜青者。持铜器。覆苦酒瓮上着。器者。是名铜青长养。青者。是蓝淀青石。青者是空青。持是等作点净。黑者。名字泥不名字泥。名字泥者。呵梨勒。[酉*卑]醯勒。阿摩勒。合铁一器中。是名名字泥。不名字泥者。实泥若池泥井泥。如是一切泥。木兰者。若呵梨勒。[酉*卑]醯勒。阿摩勒。如是比生铁上磨持作点净。是名木兰。比丘得新衣不作净受用者波夜提。波夜提者如上说。若得新僧伽梨作净者善。不作净者波夜提。如是郁多罗僧。安陀会。雨浴衣。覆疮衣。尼师坛。作净者善。不作净者波夜提。钦婆罗衣作二种净。截缕净。青点净。作截缕净。不作青净波夜提。作青净不作截缕净越毗尼罪。不作青净不作截。缕净。得一波夜提一越毗尼罪。作截缕净作青净者无罪。叠衣作三种净。截缕净染净青净作截缕净作染净不作青净。得一波夜提。作青净不作截缕净。不作染净。得二越毗尼罪。不作截缕净。不染净。不作青净。犯一波夜提二越毗尼罪。作上三种净无罪。刍麻衣三种净。同叠衣。憍舍耶二种净。同钦婆罗衣。舍那衣。麻衣驱牟提衣。三种净。同叠衣。青黑木兰作净。亦复如是。作净时不得大。不得小。极大齐四指。极小如豌豆。若持呵梨勒。[酉*卑]醯勒。阿摩勒。铁上研取汁。作点净。不得并作。或一或三。或五或七或九。不得如华形作净。若浣叠时有泥堕上。若乌鸟泥足蹈上。即名为净。若得众多杂碎新物。若合补一处者。一处作净。若各各别补者。一一作净。若新作僧伽梨。趣一角作净。若一条若半条补者。亦作净郁多罗僧安陀会。及一切衣。乃至新纽褋。亦作净。是故说

佛住王舍城。广说如上。尔时韦提希子阿阇世王十五日月盛满时。洗浴涂身着新净衣。与诸群臣在正殿上。时王语一大臣言。今是月盛满日。我等当诣何处沙门婆罗门。能得长养善根处。大臣答言。不兰迦叶在王舍城中。是大沙门亦有大众。王应往彼能长养善根。王默然不答。复有一臣言。是萨遮尼干子在王舍城中。是大沙门。可往诣彼能长养善根。如是一一大臣是外道弟子者。各各称赞其师。皆言。应往诣彼能长养善根。尔时耆旧童子在阿阇世王后。执盖而侍。王告童子。众人皆语。汝何故默然不言。今月盛满应诣何处。得长养善根。童子白王。世尊今在我庵婆罗园中。与千二百五十比丘共在彼住。若往彼者。可长养善根。王即可其所言。便告耆旧童子。汝速严驾五百牸象。一一象上载一夫人。时耆旧童子即如教严驾。严驾讫往白王言。严驾已办。宜知是时。时阿阇世王与五百夫人。夜半时执炬灯明前后围绕。出王舍城。诣庵婆罗园。欲到园门时。诸比丘皆悉坐禅。王即悚然。顾谓童子。汝云。有千二百五十比丘在。汝园中云何如是大众寂然无声。汝将无欺诳我耶。童子报言。实不欺王但当直前。童子即指示言。此大堂中燃灯明处。世尊当中坐。威德特尊巍巍无上。犹如牛王在牛群中。如师子王在众兽中。如雪山六牙白象王在象群中。犹如恒河深渊澄静无声。大众默然亦复如是。又如大海无量水归。世尊大众功德无量亦复如是。尔时阿阇世王小复前行。下乘步进至佛所绕佛大众三匝而住。语童子言。世尊大众寂然清净功德成就。愿使我子优陀夷跋陀功德成就。亦得如是。佛告大王。随所求愿皆当得之。时王敷座。请佛令坐。佛语大王自坐佛自有座。时王头面礼佛足。礼佛足已却坐一面白佛言。世尊。欲有所问。唯愿听许。佛告大王。恣所欲问。当为汝说。王白佛言。世尊。此中种种工师于佛法中出家。可现世得沙门果不。如现法沙门果经中广说。尔时说法经久。诸夫人着宝璎珞重故。各各解置座前。时阿阇世王有杀父罪故。心常惊怖。闻城中鼓声吹贝声象声马声。王大怖畏。即告诸夫人。可还入城。可还入城。夫人去速忘不取璎珞。还宫中已。到明清旦。王大夫人欲着璎珞求觅不得。着衣人言。昨来仓卒恐忘在彼。如是诸夫人皆云忘璎珞。如是众多若白王者王或嫌责。尔时有青衣白王言。诸夫人昨夜还速多忘璎珞。时有外道婆罗门。是王师共王在坐。即语王言。若忘在彼诸沙门皆当藏去。假令往求会不可得。时王遣可信人。试往推求。见佛大众俨然而坐。及见诸夫人璎珞悉在本处。日光照曜光焰赫然。即收持还。具以白王。王大欢喜言。佛诸沙门真良福田。无贪无欲。特可信者。无过是众。愿常在我国中。我当尽形供养。王即告诸夫人。是汝璎珞各各还取。不得杂乱竞取好者。诸比丘闻王外道师作是语。以是因缘。往白世尊。佛告诸比丘。宝悉现在不取。已生人谤。况复取者。从今日后不听取宝

复次佛住毗舍离。广说如上。尔时梨昌童子着杂宝腰带。价直千万。乘驷马车出城游戏。宝带重滑不觉堕地。时有比丘。从后而来。见宝带在地。即呼言。童子童子。取汝宝带。车声响故。童子不闻。是比丘恐后人得故。在边立住。童子前行乃觉失带。即驼车还。遥见比丘。即便问言。汝于后来。颇见带不。比丘答言。我见有带。向遥唤汝。汝自不闻。童子即复问言。为在何处。答言在此童子即前取带。带腰已。便捉比丘痛打手脚令熟。种种嫌骂言。若我不还者。汝持带去。诸比丘以是因缘。往白世尊。佛言。不取已生过患。况当取者

复次佛住毗舍离。广说如上。尔时比丘在苏河上脱衣洗浴。时有梨车童子。亦诣河浴即脱耳环。以衣覆上。入水而浴浴已上岸着衣忘环而去。比丘后出见此耳环。即遥呼言。童子童子。耳环在地。童子去疾不闻其唤。行渐渐远觉耳无环。即便还觅。遥问比丘言。见我耳环不。比丘答言。耳环在此。我向见已。即遥唤汝。但汝去疾不闻唤声。时童子言。今在何处。答言。在此童子即取耳环。着已捉比丘反覆熟打骂言。如是如是。子我若不来。汝当持我环去。诸比丘以是因缘。往白世尊。佛告诸比丘。不取宝已生过患。况复取者

复次佛住迦维罗卫国释氏尼俱律树园。广说如上。时有释子饭诸比丘。与诸宗亲共行食。着金钏重行食不便。即脱钏置比丘脚边而作是言。此钏置阿阇梨足边。比丘食已。舍起后人见之。即便持去。是释子行食讫已。即便还归。忘不取钏还家已。乃觉无钏。便还本处求索不见。即复觅所寄比丘见已白言。阿阇梨。还我向所寄钏。比丘答言。我忆汝寄钏故在本处。我不取来。释子言。我寄不得所而失此钏。心中不悦。即往佛所。头面礼足。即白佛言。我向以钏寄某比丘。不为掌视而今失之。佛为释子随顺说法。示教利喜。发欢喜心而去。去不久。佛言。呼彼比丘来。即呼来已。佛问比丘。汝实尔不。答言。实尔。佛告比丘。汝若受人寄者。当为掌视。若不为受者。当言不受。汝云何受人寄物而不为掌。从今日后听园内。若宝若名宝。若自取。若使人取举。佛告诸比丘。依止迦维罗卫住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘若宝若名宝。园内若自取若使人取。除余时。波夜提。余时者。比丘若宝若名宝若自取若使人取。作是念。有主求者与。是名余时。比丘者。如上说。园内者。塔园内僧园内。宝者。已成器。所谓天冠宝盖璎珞拂柄宝屐如是等宝所成器也。名宝者。钱金银真珠琉璃珂贝珊瑚琥珀颇璃。赤宝铜赤铜铅锡白镴铁等。取者。净者得自手取。若不净者使净人取。波夜提者如上说。余时者若塔园内。若僧园内。若见有宝若名宝。若净者自取。若不净者使人取举。作是念。有主求。当与作如是念不异。若佛生时。大会得道时。转法轮时。阿难罗睺罗大会时。尔时诸人若忘衣及严身具种种诸物。比丘忘衣钵等物。若比丘见者当取。取应唱令。问此是谁物。若是主者与。若无识者应悬着柱上显现处。令人见之。若有人言此是我物。应问言。汝何处失。答相应者应与。若无人识者应停。至三月已。若塔园中得者。即作塔用。若僧园中得者。当作四方僧物用。若是贵重物。宝璎珞金银者。尔时不得露现。唱令得宝。比丘应审谛数看。有何相貌。然后乃举。若有人来问我忘宝物有见者不。比丘尔时应问。汝何处忘。汝宝有何相貌。若不相应者应语言。此僧伽蓝广大。汝为可广求。若相应者应出宝示言。长寿此是汝物不。若言是。比丘不得于一人前与。应集众多人教言汝归依佛法僧。若世尊不制戒者。汝眼看犹不可得。若言我此宝边更有余物。应言。长寿。我正得此。更不见余物。应语言汝是恶人。汝但得此已为过多。云何方欲更索余物谤人。若世尊不制戒者。汝不见此物。若如是犹复不了者。应将至优婆塞边。应作是言。我本正得此物。尽以还归。而今方见诬谤。尔时优婆塞应骂言。如是如是。子汝得此物已。为过多而今反谤比丘。汝但去。我当与汝。作对料理此事。若无有人来者。至三年如上随所得处。当界用之。若比丘入聚落。见地遗物不应取。若有人取与比丘。得受与者。即是施主故无罪。若比丘入聚落。见有遗衣物。或风吹来者不得。便作粪扫衣想取。若旷路无人见有衣物应取。若见衣上有宝。应以脚蹑断弃之持去。去时不应隐藏。应露捉使人见之。若衣上有秽污。为人所贱者。得覆以持去。若取时不觉衣里有宝物者。还至住处。见已应与净人。知掌作医药直。若出聚落时。若道中见衣。衣上有久尘土当取。取已不得覆藏。当露现持去。若有主逐比丘应语。长寿。何故走。答言。我失衣。应言。此是汝衣不。若言是者应还。应作是教言。汝当归佛法僧。若世尊不制戒者。汝设见此衣。亦不可得。若故坏僧坊。欲更治掘地起基。得宝藏者。若净人不可信者。应当白王王言。此物应入我。我今施比丘作功德。即名施主。若已用半半在。王言。汝何以用我物。若已用者止。在者送来。比丘应送在者还。王若言何以用我物。尽送来。比丘已用物者。应用僧物还。若僧无物应乞物还。若言已用者止。功德属我。即名彼用。若治故塔得金银宝物。若净人不可信者。当白王。净人可信者得取。停至三年。三年已应用。作塔事种种用。若王家觉问比丘言。汝此中得宝藏不。应答言得。若已用者应答言得。已用作此塔。王言已作者止。此功德属我。若已用半半在者。王言已用者止。在者归我。在者应与王。若王言汝不知地中宝物。应属我耶。汝何以用尽还我来。比丘尔时应以塔物还。若塔无物者。应为塔乞物还。若王问言。佛法戒律中云何。比丘应答言。佛法中若塔地中得物。即作塔用。若僧地中得物。即作僧用。王若言从佛法用者无罪。若宝藏上有铁券姓名。若彼王问。诸大德见宝藏上有如是姓名不。比丘应答言见。已用。作塔成。若彼言此是我家先人物。汝何以用。用者应还我。若言已作塔成者。功德属我无罪。若已用半半在者还我。比丘尔时应还在者。若言汝何以用我家先人物。一切尽还我来。尔时应尽还。若塔有物应用还。若无者乞还。若言此先人物。先人已死。此功德即属彼者无罪。作新僧伽蓝。作新塔得物亦复如是。是故说

佛住王舍城。广说如上。王舍城有三温泉。王温泉。比丘温泉。象温泉。王温泉者。王王后宫夫人。及佛诸比丘浴。比丘温泉者。佛比丘僧浴。象温泉者。象及一切人浴。尔时诸比丘入王温泉浴。时王以油涂身。欲入温泉浴。问泉监言。温泉空不。泉监答言。泉中不空。有诸比丘浴。王言听诸比丘浴讫。我今先诣世尊还当浴。到世尊所。头面礼足已。还复问监言。池中空未。答言。未空。如是至三。犹有比丘洗浴不止。王言。听浴勿唤令出。我当还宫中浴。诸人闻已。皆嫌责言。沙门释子自言善好有德而固。池中不令大王得浴。诸比丘闻已。以是因缘往白世尊。佛语诸比丘。何处有王尽能忍是。从今日不听浴

复次佛住舍卫城。广说如上。尔时世尊制戒不听浴。诸比丘不得浴故身垢污臭。尔时世尊为诸大众说法。诸比丘在下风处坐。恐污臭熏诸梵行人故。佛知而故问。诸比丘何故独一处坐。似如恨人。诸比丘白佛言。世尊制戒不听浴故身垢污臭。恐熏梵行人。故在下风而住。佛言。从今日后听半月一浴复次佛住舍卫城。广说如上。尔时诸比丘春。月热。不得洗故身体痒闷。诸比丘以是因缘往白世尊。佛言。从今日后听热时二月半得浴。春后一月半夏初一月。是名二月半

复次佛住舍卫城安居竟。与诸比丘往憍萨罗国。人间游行道中草木深邃。下则热气所吸。上则为日所炙。大生苦恼。驼走向水。如鹿赴池。佛知而故问。诸比丘具说上事。以如是苦故。诸比丘竞走赴水。佛言。从今日后听行时得浴

复次佛住舍卫城。广说如上。有五事利益故。世尊五日一行诸比丘房。有比丘病疥[癈-(弓*殳)+虫]。佛知而故问。比丘汝调适不。答言。不调适。我病疥[癈-(弓*殳)+虫]痒。得数数浴便乐。世尊制戒不得浴。是故不乐。佛言。从今日听病比丘浴

复次佛住旷野精舍。广说如上。尔时营事比丘辇泥辇塼。作种种作事。不敢浴故。即便持卧。明日清旦脚上有泥土处。佛知而故问。比丘汝脚上何故泥处。答言。世尊。我营事泥污身。畏犯戒故不敢浴。是故脚有泥土。佛言。从今日听作时浴

复次佛住舍卫城。广说如上。尔时诸比丘值大风起。尘土坌身。复值天雨。诸比丘不敢浴故。即便持卧。明日清旦问讯世尊。佛知而故问。比丘汝身上何以垢污如是。答言。世尊。昨日风吹尘土坌身。复值天雨。不敢浴故。身上有垢污。佛言。从今日听大风时浴

复次佛住舍卫城。广说如上。尔时天晴有少云起。须臾大雨。佛告诸比丘。此是阎浮提最初吉雨。汝等应雨中洗浴。能除身中诸病疮癣。诸比丘心疑。世尊制戒不得浴。我等云何当浴。佛言。从今日后听雨时浴。佛告诸比丘。依止舍卫城比丘尽集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘减半月浴。除余时波夜提。余时者。春后一月半。夏初一月。是二月半。是热时病时作时。风时雨时行时。是名余时。比丘者如上说。半月者。若十五日浴数满十五日。复应浴。若十四日。十三十二十一十九八七六五四三二一日浴。应从浴日数。要满十五日。乃应更浴。除余时者。世尊说无罪。热时者。春后一月半。夏初一月。是二月半。名热时。不得取前后。当取现在。病时者。若比丘癣疥[癈-(弓*殳)+虫]痈痤。如是种种病。须浴得适意者听浴。是名病时。不得取前后。当取现在。作时者。若僧一切作时。比丘作泥作治房舍。若通水沟。若抒井若泥房舍。若扫地若洗浴。和尚阿阇梨。乃至扫塔院僧院。下至五六动扫帚。得名作时。浴无罪。不得取前后。当取现在。风时者。若比丘风吹尘土坌身。得洗浴无罪。不得取前后。当取现在。雨时者。若天雨洗浴无罪。不得取前后当取现在。行时者。三由延二由延下至一拘卢舍。若来若去。是名行时。洗浴无罪。不得取前后。当取现在。波夜提者如上说。若比丘无上诸时。当作陶家浴法。先洗两髀两脚。后洗头面腰背臂肘胸腋。是故说

  然火过三宿　　与欲入聚落
  谤经摈同止　　沙弥三色衣
  取宝半月浴　　第五跋渠竟

佛住毗舍离。广说如上。尔时尊者优陀夷行道渴极。入聚落从女人索水。姊妹。施我水。女人即以水与之。水中有虫。优陀夷见已。作是念。我但饮此无虫处。饮时虫随水入口。饮已心生疑。即以是因缘。往白世尊。佛言。汝云何知水有虫而饮。此非法非律。非如佛教。不可以是长养善法。从今日后知水有虫不得饮

复次佛住舍卫城。广说如上。时南方波罗脂国有二比丘。共伴来诣舍卫。问讯世尊。中路渴乏无水。前到一井。一比丘汲水便饮。一比丘看水见虫不饮。饮水比丘问伴比丘言。汝何不饮。答言。世尊制戒不得饮虫水。此水有虫。是故不饮。饮水比丘复重劝言。长老。汝但饮水。勿令渴死不得见佛。答言。我宁丧身不毁佛戒。作是语已。遂便渴死。饮水比丘渐渐往到佛所。头面礼足却住一面。佛知而故问。比丘汝从何来。答言。我从波罗脂国来。佛言。比丘汝有伴不。答言。有二人为伴。道中渴乏无水到一井。井水有虫。我即饮之。因水气力得奉觐世尊。彼守戒不饮。即便渴死。佛言。痴人。汝不见我谓得见我。彼死比丘已先见我。若比丘放逸懈怠不摄诸根。如是比丘虽共我一处。彼离我远。彼虽见我我不见彼。若有比丘在海彼岸。能不放逸精进不懈。捡摄诸根。虽去我远我常见彼。彼常近我。佛告比丘。此是恶事非法非律。非如佛教。不可以是长养善法。从今日后知水有虫不得饮。佛告诸比丘。依止舍卫城比丘尽集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘知水有虫饮者波夜提。比丘者如上说。知者。若自知若从他闻。虫者。非鱼鳖失收摩罗等。谓小小倒孑诸虫。乃至极细微形眼所见者。水者。十种如上说。饮者。齐入腹。波夜提者。如上说。比丘受具足已。要当畜漉水囊。应法澡盥。比丘行时应持漉水囊。若无者下至受持郁多罗僧。一角头看水时。不应以天眼观。亦不得使闇眼人看。下至能见掌中细文者得使看水。看水时不得厌课当至心看。不得太速。不得太久。当如大象一回顷。若载竹车一回顷。无虫应用。若有虫者。应漉用水。有三阶下中上。若下分无虫。中分上分有虫者。应取下分无虫水用。若中分无虫。上分下分有虫者。应取中分水用。若上分无虫。应取上分水用。若上分有虫者。应以手拍水。令虫入水底已取用。若三分尽有虫者。尔时应漉水用。若水中虫极细微者。不得就用。洗手面及大小行。若檀越家请比丘食。尔时应问汝漉水未。若言未漉。应看前人。是可信者应教漉水。若不可信者不得语令漉。莫伤杀虫。比丘应自漉用。虫水应着自器中。应问从何处取水。随来处还送虫水泻中。若先取水处远者。若见有池水。七日内不消尽者。得以虫水着中。若无池水者。当器中盛水持来养之。若天大雨有瀑流水。以虫泻中。作是念言。汝入大海去。若比丘道中行渴须水。到井取水时当细看。无虫得用。若有虫者。当如上法净漉得用。若知水有虫。不得持汲水罐器绳借人。若池水汪水。当看已用。若见有虫者不得。唱言长老。此水有虫有虫。令前人生疑不乐。若前人问言。此水有虫不。应答者。长老自看。若知识同和上阿阇梨者应语。此水有虫。当漉水用。若有虫无虫想用。越毗尼罪。若无虫有虫想越毗尼。若有虫有虫想用波夜提。若无虫无虫想用无罪。是故说

佛住舍卫城。广说如上。尔时尊者阿难名字吉具足。性吉具足。家吉具足。此三事故。为世人所重。每至吉日。若入新舍嫁娶穿耳时。恒先请阿难。时有一家。请尊者阿难食。有一外道出家人。黑色青眼大腹。来阿难所索食。阿难即与手掬啖已。以手拭身而去。复有一外道来。问言。汝何处得食。答言。我从此剃发居士边得。阿难闻此语已心不悦。后来乞者不与。阿难以是因缘。往白世尊。佛语阿难。此人不识思分。从今日不听自手与无衣外道出家人食

复次佛住舍卫城。广说如上。尔时世尊四月一剃发。世人闻佛剃发故。送种种供养。时世饥俭。有五百人。常随世尊乞残食。佛问阿难。有残食不。答言有饼。佛言。分与乞食人。阿难即付人人与一番。中有外道出家女。阿难捉饼与。时两番相着去。彼得已共在一处食。作是言。此饼乃极美好。但恨少止得一番耳。得两番者。作是言。我得两番。得一番者言。阿难故当是汝婿何故独与汝两番。阿难闻已不悦。以是因缘具白世尊。佛言。从今日不听自手与无衣外道出家男女食。诸比丘白佛言。云何是外道不知恩分。佛言。不但今日不知恩分。过去世时已曾如是。如仙人猕猴本生经中广说。佛告诸比丘。依止舍卫城住者尽集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘无衣外道出家男女自手与食波夜提。比丘者如上说。无衣者。若无衣入有衣出。有衣入无衣出。有衣入有衣出。无衣入无衣出。出家者。外道出家不兰迦叶。乃至尼揵子。自手者。若手与手受器与器受。食者。五正食。五杂正食。与者。波夜提。波夜提者。如上说。若比丘父母兄弟姊妹。在外道中出家来者。亦不得自手与食。当使净人与食。若无净人者。语令自取食。若恐外道啖尽者。应语言。授与我来。得已应随意减取已。若着床机地上应语言。汝自取食。若是亲里外道。作是嫌言。汝今便作旃陀罗。遇我比丘。应答言。汝出家不得处世尊制戒。如是汝若食者便食。若不食者随意。若比丘使外道作时。亦不得自手与食。当使净人与。若无净人如上法与。若外道来索米[米*番]汁饭汁浆。亦不得自手与。若外道从众僧中乞食不得自手与。当放地与。若外道有信心。欲供养比丘。尔时亦不得自手与饮食。得使外道作饮食。得使授食。食已残者与。与法如上说。是故说

佛住舍卫城。广说如上。尔时尊者优陀夷与知识婆罗门同村住。此婆罗门女出嫁。在异村住。遣信还白父言。时时来看我。若尊不得来者。愿令阿阇梨优陀夷时时来看我。如前二不定中广说。乃至佛语优陀夷。此是恶事在家人。尚知沙门仪法。汝等出家人。云何不知应坐。不应坐处。此非法非律。非如佛教。不可以是长养善法。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘知食家淫处坐者。波夜提。若比丘知食家屏处坐者。波夜提。比丘者。如上说。知者。若自知若从他闻。食者。糗饭麦饭鱼肉。如是种种名为食。复有食名。眼识见色起爱念生欲着。耳鼻舌身亦如是。复有食名。釜以盖为食。臼以杵为食。[百*斗]以斗为食。如是比皆名为食。复有食名。男子是女人食。女人是男子食。家者。婆罗门刹利毗舍首陀罗家。淫处者。夫妇行欲处。坐者。共一处坐。波夜提。比丘者。如上说。知者。若自知若从他人闻。食家者。如上说。屏处者。男女可行淫不羞处。复有名屏处。若闇中若闭户。皆名屏处。坐者。共一处坐。波夜提。波夜提者。如上说。若比丘与彼夫妇一处坐者。一波夜提。外比丘遥不见者。二波夜提。淫处坐屏处坐。闭户扇坐。外比丘遥不见者。二波夜提。若外比丘见。一波夜提。共门屋中坐亦如是。中庭若甘蔗聚障。若谷聚障。若墙障亦如是。若有比丘伴不犯。虽有众多白衣伴。亦犯一切是男无罪。一切是女无罪。是故说

佛住舍卫城。广说如上。尔时憍萨罗大臣名弥尼。刹利反叛。时波斯匿王集四种兵。选择良日。与诸大臣椎钟击鼓。欲往讨伐。尔时尊者难陀优婆难陀往到军前而立。王见已。即却盖曲躬遥敬。时诸臣见已。即嫌言。看是沙门释子不知时。今大王欲讨伐逆寇。当军前立。又嫌大王将士众。如是吉日求利见一剃发沙门而便却盖曲躬遥敬。诸比丘闻已。以是因缘。往白世尊。佛言。呼难陀优波难陀来。来已佛问。汝实尔不。答言。实尔。佛告诸比丘。何有一切诸王。皆得信心如是。从今日后不听入军中与相见。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘观军发行。波夜提。比丘者。如上说。军发行者。执持戎器诣他国。军有四种。象军马军。车军步军。象军者。四人护象足。是名象军。马军者。八人护马足。是名马军。车军者。十六人护车。是名车军。步军者。三十二人执持兵仗。是名步军。是名四种军。若比丘于此四种军。若观一一军。波夜提。若比丘欲观军。从聚落中往阿练若处。阿练若处往聚落中。下处至高高处至下。覆处至露处。露处至覆处。往观见者。波夜提。若比丘入聚落城邑道中。逢军阵不作意见无罪。若作心举头下头窥望。欲见见者。波夜提。若王出若大象出时。街巷中窄满。比丘尔时在一处住。不作意看无罪。若作意欲看者。得越毗尼罪。若比丘看象马牛等斗。乃至鸡斗。得越毗尼罪。若军来诣精舍。不作意看无罪。若作意看。得越毗尼罪。下至人口诤看者。越毗尼罪。是故说

佛住舍卫城。广说如上。尔时憍萨罗国有刹利大臣名曰弥尼。叛逆不顺。时波斯匿王遣大臣。征人达多领四种兵。欲往讨伐。尔时征人达多遣信白世尊言。我今征行。愿遣诸比丘为我说妙法。于时世尊告阿难。汝往军中为征人达多说法。阿难到已。大臣即为设种种供养。尔时六群比丘知为阿难设种种供养。复往军中食已。又观试兵处。见不能者因毁呰言。汝等效人乘象。如似骑猪。费王饮食以此入阵。必自丧身。又失王象。若见能者。因赞叹言。善能乘象。捉钩甚工。左右回转明晓斗法。应食官禄。以此入阵。能自济身。又不失象。若观乘马见不能者。便毁訾言。汝效人乘马。如似骑驴。费王饮食。以此入阵。必自丧身。又失王马。若见能者。便赞叹言。汝善能乘马。执辔甚工。左右回转皆有方便。应受王禄。以此入阵。必能济身。又不失马。若观乘车见不能者。毁訾言。汝效人乘车。如上床法。费王饮食。以此入阵。必自丧身。又失王车。若见能者。赞叹言。工能执御。善于进退。左右回转甚有方便。应受王禄。以此入阵。必能济身。又不失车。若观步军见不能射者。便毁訾言。效人执弓。似如拼毳徒食官禄。以此入阵。必自丧身命。又失官弓。见好射者。赞叹言。平正美满实为工射。应受官禄。以此入阵。必自济身。又不失弓。观持刀楯见不能者。便毁訾言。效人持楯。如捉布刀。以此入阵。必自丧身命。又失官仗。若见能者。又赞叹言。善用刀楯。至为巧能。以此入阵。必自全身。又不失王仗。如是毁訾赞叹四种兵已。得毁訾者。各各怒曰。何但弥尼刹利。是我等怨。今此沙门亦复是贼。毁辱我等当共杀之。得称赞者语得毁者言。此诸沙门皆是王种。或大臣种。或刹利种。皆本习兵法。明晓战阵。如彼所言。汝等宜学而反怨彼。甚为大痴。诸得毁者闻此语已。深自惭愧。尊者阿难见此事已。念曰。我今宜去。若久住此。或生过患。即还精舍。佛知而故问阿难。汝已为征人达多说法讫耶。阿难即以上事。具白世尊。佛言。呼六群比丘来。来已佛问六群比丘。汝实尔不。答言。实尔。佛言。此是恶事。非法非律。非如佛教。不可以是长养善法。从今日后有因缘听入军中三宿。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘有因缘得到军中三宿。若过者。波夜提。比丘者。如上说。因缘者。若僧事塔事私己事。军者。如上说。三宿者。极齐三宿。若过者。波夜提。波夜提者。如上说。若比丘一夜时在步军。二夜在象军。三夜在马军。四夜在车军中宿者。波夜提。若一夜在象军。二夜在马军。三夜在车军。四夜在步军中宿者。波夜提。若一夜在马军。二夜在车军。三夜在弓军。四夜在槊军中宿者。波夜提。若一夜在车军。二夜在弓军。三夜在矛军。四夜在刀军中宿者。波夜提。若一夜在弓军。二夜在槊军。三夜在刀军。四夜在外逻军中宿者。波夜提。若一夜在矛军。二夜在刀军。三夜外逻军。四夜离见闻处无罪。若为塔为僧营事不讫。应离军一宿。已得更宿。若城邑远不能往者应离军见闻处宿。宿时应语军外逻人言。我夜欲在某处宿。勿谓是异人。若军人来到僧伽蓝中住。不应舍去。虽多宿无罪。是故说

佛住舍卫城。广说如上。尔时六群比丘再三军中宿已。到试兵处见不能乘象者。即毁訾言。此人乘象似如乘猪。若入军阵者。必自丧身。复失官象。费王廪禄。见能乘象者。如是赞言。此人善能乘象。捉钩牵挽。左旋右旋。皆悉巧便。若入阵者。必能破贼。又全身命。如是人者。应食王禄。见不能乘马乘车捉弓刀楯矛槊。乃至一一毁訾赞叹已。即便教言。汝应作如是如是。乘象乘马。御车捉弓。捉楯捉槊。诸不能者。闻是语已。即嗔恚言。何处更觅怨贼。此即是贼。我等当共杀之。彼得赞者。作如是言。此诸比丘皆是王种。大臣刹利种。皆知兵法。汝等何不善学而反怨他。诸被毁者。闻是语已。嗔心即灭。内自惭愧。诸比丘闻是语已。往白世尊。佛言。呼六群比丘来。来已佛具问上事。汝实尔不。答言。实尔。佛言。此是恶事。非法非律。非如佛教。不可以是长养善法。佛告诸比丘。依止舍卫城住者。皆悉令集以十利故。为诸比丘制戒。乃至已闻者当重闻。若比丘有事缘。得军中三宿。若观军发行牙旗诤斗势力者。波夜提。比丘者。如上说。三宿者。极齐三宿。观者方便故往。若高处至下。下处至高。军者。四种军。如上说。牙旗者。若师子形若半月形。诤者。口诤。斗者。两众交刃势力者。强弱相倾。观其事势。是名势力。波夜提者。如上说。若比丘道路行逢军。不故看见者无罪。若作方便看见者。波夜提。若抄贼从村中来。比丘道中相逢。不故看无罪。作方便看见者。波夜提。若比丘林野中经行时群贼来不故看见无罪作方便看见者。波夜提。若比丘于林楙经行时。群贼劫村已。从比丘边过。后逐贼人寻贼至比丘所。问比丘。见贼不。比丘不得妄语。复不得语处。得语言看指押。若比丘城里住。有贼来围城。王语比丘。尽出上城现多人相。不故看见者无罪。作方便看见者。波夜提。是故说

佛住舍卫城。广说如上。尔时六群比丘于禅坊中起。以拳触十六群比丘头。即便大啼。佛闻啼声。知而故问。是中何等小儿啼声。答言。是六群比丘于禅坊中起。以拳触十六群比丘头。是故啼声。佛言。呼六群比丘来。来已佛具问上事。汝实尔不。答言。实尔。佛言。何以故尔。答言。为戏乐故。佛言。痴人。此是恶事。恼诸梵行人而反言乐。佛语六群比丘。莫轻彼人。彼人若入定者。以神足力掷汝着他方世界。汝常不闻。我以无量方便。于梵行人所应起身口意行慈。供养恭敬。云何作是恶不善事。此非法非律。非如佛教。不可以是长养善法。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘打比丘者波夜提。比丘者。如上说。打者。若身身分身方便。身者。一切身是名身。身分者。若手若脚。若肘若膝。若齿若爪甲。是名身分。身方便者。若捉杖木瓦石等打若遥掷。是名身方便。波夜提者。如上说。若比丘打比丘。波夜提。打比丘尼。偷兰遮。打式叉摩尼沙弥沙弥尼。越毗尼罪。下至俗人。越毗尼心悔。若恶象马牛羊狗。如是种种恶兽来不得打得捉杖木瓦石等打地作恐怖相。若畜生来入塔寺中。触突形像坏花果树。亦得以杖木瓦石等打地恐怖令去。是故说

佛住舍卫城。广说如上。世尊制戒不听比丘相打尔时六群比丘于禅坊中起以侧掌刀拟十六群比丘。作如是言。我以掌刀斫堕汝面彼恐怖故。即便大啼。佛闻啼声。知而故问诸比丘。是何等小儿啼声。答言。是六群比丘于禅坊起。以侧掌刀拟十六群比丘。作是言我以掌刀斫堕汝面。彼恐怖故。即便大啼。佛言。呼六群比丘来。来已佛具问上事。汝实尔不。答言。实尔。佛言。何故如是。答言。以戏乐故。佛言。痴人。此是恶事。恼诸梵行人而言戏乐。佛言。汝莫轻彼人。彼人若入定。能以神力掷汝着他方世界。汝常不闻。我以无量方便。于梵行人所应起身口意行慈恭敬供养。此非法非律。非如佛教。不可以是长养善法。从今日后不听以掌刀相拟。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘以掌刀拟比丘者。波夜提。比丘者。如上说。掌者手掌。刀者手指。拟者现打相。波夜提者。如上说。举一指拟。波夜提。乃至五指亦如是。一切手指拟。波夜提拳拟。偷兰遮掌刀拟比丘。波夜提。比丘尼。偷兰遮。拟式叉摩尼沙弥沙弥尼。越毗尼罪。下至俗人越毗尼心悔。若恶象马牛羊狗。如是等种种恶兽来者。不得以掌刀拟。得以杖木瓦石打地恐怖令去。若是诸兽畜来入塔寺坏诸形像及花果树。亦得打地恐怖令去。是故说(五十九竟)

摩诃僧祇律卷第十八摩诃僧祇律卷第十九

        东晋天竺三藏佛陀跋陀罗共法显译

    明单提九十二事法之八

佛住舍卫城。广说如上。尔时优波难陀语兄难陀。共行弟子作如是言。阿浮婆共汝入聚落。彼间当与汝饮食。我若彼作非威仪事。汝当覆藏。莫向人说。我是汝叔父。我亦覆汝和上罪。答言。正使我父祖翁及和上有罪。尚不覆藏。况复叔父汝自可覆藏我和尚罪我终不能覆藏汝罪。优波难陀闻是语已。即作是念。今日当令汝得苦恼事。即共入城。到长者家。檀越见已。欢喜问讯。即请留食。优波难陀复作是念。我当观望。日时欲至遣还精舍。令不及众食。复失此供。进退失食时足得苦恼。作是念已。时至即遣彼还恐失食。故并看日时。疾疾而还众食已讫。出祇洹门间。傍佯经行。遥见彼来。口唇干燥。似未得食即戏调言。汝朝随教化比丘入城。得何等种种美食。答言。唯有苦恼。何处得食。诸比丘闻已。以是因缘。往白世尊。佛言。呼优波难陀来。来已佛具问上事。汝实尔不。答言。实尔。佛言。此是恶事非法非律。非如佛教。不可以是长养善法。从今日后知比丘粗罪。不得覆藏。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。为诸比丘制戒。乃至已闻者。当重闻。若比丘知他比丘犯粗罪覆藏者波夜提。比丘者如上说。知者。若自知。若从他闻粗罪者。四波罗夷。十三僧伽婆尸沙。是名粗罪。覆藏者。不欲令他知。波夜提者。如上说。比丘见他犯粗恶罪。不得覆藏。覆藏者。波夜提应向人说。说时不得辄向人说。当向善比丘说。若同和上阿阇梨。若彼犯罪比丘凶暴。若依王力大臣力凶恶人力。或起夺命因缘毁伤梵行者。应作是念。彼罪行业必自有报。彼自应知。喻如失火。但自救身焉知余事。尔时但护根相应无罪。若比丘知他比丘犯四事十三僧伽婆尸沙。若一一覆藏者。波夜提三十尼萨耆。九十二波夜提。若一一覆藏者。越毗尼罪。四波罗提提舍尼众学法。一一覆藏者。越毗尼心悔。若覆藏比丘尼八波罗夷。十九僧伽婆尸沙。一一覆藏者。偷兰遮三十尼萨耆。百四十一波夜提。若一一覆藏者。越毗尼罪。八波罗提提舍尼众学法。若一一覆藏者。越毗尼心悔。式叉摩尼十八行法。更受学法。若一一覆藏者。越毗尼罪。沙弥沙弥尼十戒。若一一覆藏更与出家法越毗尼罪。下至俗人五戒。若一一覆藏者。越毗尼心悔是故说

  虫水及无衣　　淫处屏处坐
  往观三军阵　　打掌刀覆藏
  第六跋渠竟

佛住毗舍离。广说如上。尔时有人着铠持弓箭。入精舍中。脱铠放仗止息树下。精舍中庭前沙地有众鸽鸟。在中戏食。时尊者优陀夷见鸟已。即语长寿。借我弓箭试我手看。答言。可尔。即捉弓并注五箭。挽弓放发射杀五鸽。即取搣毛以木贯之。持授世尊。此是鸟肉。佛言。何处得。答言。有人着铠持弓箭至精舍庭前。止息树下。从借弓箭。试手射鸟。本习射法犹故不失。佛言。痴人。此是恶法。应早舍弃。方言本习手犹故在。汝常不闻。我以无量方便。毁訾杀生。赞叹不杀。而今作是恶不善法。此非法非律。非如佛教。不可以是长养善法。诸比丘白佛言。世尊。众生应起慈心救护。云何优陀夷反夺其命而无慈心。佛言。不但今日不起慈心。过去世时已曾如是。如释提桓因本生经中广说。佛告诸比丘。依止毗舍离城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘故夺畜生命波夜提。比丘者。如上说。故者先作方便。夺畜生命者。若身身分身方便。身者一切身。于众生身上跳蹈。若堆压欲令彼死。死者。波夜提。身分者。欲害众生故。若手若脚。若膝若肘。若齿若爪等一一用杀。是名身分。身方便者。若手捉杖木瓦石等。若就打若遥掷欲令死。死者。波夜提。波夜提者。如上说。若比丘欲断畜生命。若刀药涂吐下堕胎刀者。大小刀乃至针。若比丘杀心捉刀时。越毗尼心悔。触彼身。越毗尼罪。命根断者。波夜提。是名刀药者。有三种生合毒生者。如尼楼国土郁阇尼国土。有毒草名迦罗。是名生合者。如猎师合药若根若茎。若叶若花。若果众草和合药。是名合毒者。蛇毒鼠毒。狼毒猫毒。狗毒熊罴毒人毒。如是种种若生若合若毒。如是一切是名药。若比丘杀心欲杀畜生合药时。越毗尼心悔。触彼身。越毗尼罪。命根断。波夜提。是名药涂者。若比丘杀心以药欲涂畜生时。作是念。若涂头脚身令枯干死。捉药时越毗尼心悔。触彼身者。越毗尼罪。因是死者。波夜提。是名涂吐者。若比丘杀心合吐药。欲令吐脓血吐肠死合药时。越毗尼心悔。触彼身者。越毗尼罪。因是死者。波夜提。是名吐下者。若比丘杀心作下药。欲令彼下脓血肠肚死。作药时越毗尼心悔。触彼身。越毗尼罪。因是死者。波夜提。堕胎者。若比丘杀心欲堕畜生胎作方便时。越毗尼心悔。触彼身越毗尼罪。欲杀母而堕胎者。越毗尼罪。欲杀胎而母死者。越毗尼罪。欲杀母母死者。波夜提。欲杀胎胎死者。亦波夜提。若畜生怀人胎越毗尼罪。是名堕胎行毗陀罗咒。屑末罥弶坑陷道河行者。有畜生。若五若十若二十。作行列行时。若欲杀前误杀中。欲杀中误杀后。欲杀后误杀中。欲杀中误杀前。皆越毗尼罪。若欲杀前前死。欲杀中中死。欲杀后后死者。皆波夜提。若一切无当死者。波夜提。是名行毗陀罗咒者。若比丘为杀畜生。读毗陀罗咒。起死人诵咒时。越毗尼心悔。心惊毛竖。越毗尼罪。因是死者。波夜提。是名毗陀罗咒。屑末者。若比丘为杀畜生故。作屑末坌众生身。欲令干枯死。作方便时。越毗尼心悔。触彼身越毗尼罪。因是死者。波夜提。罥者。若比丘杀心于畜生常行处食处饮水处。施罥时。越毗尼心悔。触彼身者。越毗尼罪。因是死者。波夜提。是名罥弶者。若比丘杀心于畜生。常行处食处饮水处。施弶时。越比尼心悔。触彼身者。越毗尼罪。因是死者。波夜提。是名弶坑陷者。若比丘杀心于畜生常行处食处饮水处。作坑陷。以草土覆上作时。越毗尼心悔。堕中时。越毗尼罪。因是死者。波夜提。是名坑陷道者。若比丘于道头经行见畜生来。见已作是念。今当令此无一得脱者。杀心驱向师子虎狼恐怖处。若国王猎处驱时。越毗尼心悔。受苦痛时。越毗尼罪。因是死者波夜提。是名道河者。若僧伽蓝近河边。比丘在岸上经行。有畜生来。比丘见已。作是念。今当令此畜生无一得活者。杀心驱向非济处。若回波旋覆处。尸收摩罗处。渡彼岸。复有师子虎狼处。及王游猎处驱时越毗尼心悔。受苦痛时。越毗尼罪。因是死者波夜提。是名河。一比丘杀心捉刀时。越毗尼心悔。受苦痛时。越毗尼罪。因是死者波夜提。如是二比丘众多比丘亦如是。若比丘为杀故与刀遣使。若一人若二人。乃至众多人。亦如是使复转遣使。乃至众多人与刀时。越毗尼心悔。受苦痛越毗尼罪。因是死者。波夜提。如是药毒涂吐下堕胎。如刀中广说。若比丘成就五法断畜生命。波夜提。何等五。畜生。畜生想。杀心。起身业。命根断是名五法。是故说

佛住舍卫城。广说如上。尔时六群比丘欲令十六群比丘疑悔故。作如是言。世尊制戒年满二十。听受具足。汝等未满二十而受具足。不名受具足。闻是语已。即便大啼。佛闻啼声。知而故问。是何等小儿啼声。比丘答言。是六群比丘。欲令十六群比丘疑悔故。作如是言。世尊制戒年满二十。听受具足。汝等未满二十而受具足。非受具足。闻是语已。是故啼耳。佛言。呼六群比丘来。来已佛具问上事汝实尔不。答言。实尔。佛言。何故如是。答言。我戏乐故。佛言。痴人。此是恶事恼梵行人而言戏乐。佛言。汝莫轻彼。彼若入定以神足力能掷汝着他方世界。此非法非律。非如佛教。不可以是长养善法。从今日后不听令他比丘疑悔。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。为诸比丘制戒。乃至已闻者当重闻。若比丘故令他比丘起疑悔。须臾不乐波夜提。比丘者。如上说。故者。先作方便。疑悔者。有七事生羯磨形相病罪骂詈结使。波夜提者。如上说。生者。作是言。长老世尊制戒年满二十听受具足。汝不满二十而受具足。不名受具足。作是语欲令生疑。前人若疑若不疑。皆波夜提。是名生羯磨者。作如是言。长老世尊制戒。一白三羯磨。无遮法。汝白不成就。羯磨不成就。众不成就。如是一一不成就。非受具足。不名受具足。作是语。欲令他疑悔。前人若疑悔。若不疑悔。皆波夜提。是名羯磨形相者。作如是言。长老世尊制戒。身体成就听受具足。汝曲脊跛蹇眼瞎尪脚。搕头锯齿身不具足。而受具足不名受具足。作是语。欲令他疑悔。前人若疑悔。若不疑悔。皆波夜提。是名形相。病者。作是言。长老世尊制戒。无病听受具足。汝癣疥黄烂痈痤痔病。如是种种诸病而受具足。不名受具足。作是语。欲令起疑悔。彼若疑悔。若不疑悔。皆波夜提。是名病罪者。作是言。长老世尊制戒。清净者听受具足。汝犯波罗夷。僧伽婆尸沙。波夜提波罗提提舍尼。越毗尼罪。而受具足不名受具足。作是语。欲令疑悔。彼若疑悔。若不疑悔。皆波夜提。是名罪骂詈者。作是言。长老世尊制戒。欢喜者听受具足。汝不欢喜嗔恚骂詈而受具足。不名受具足。作是语时。欲令疑悔。彼若疑悔。若不疑悔。皆波夜提。是名骂詈。结使者。作是言。长老世尊制戒。黠慧人听受具足。汝痴不黠如泥团。如羊角鸱白鹄受具足。不名受具足。作是语时。欲令疑悔。彼若疑悔。若不疑悔。皆波夜提。是名结使。若有人来欲受具足。若满二十与受具足。若不满者。语言且住待满二十。若彼便于余处。受具足来者。不得语令疑悔语者。越毗尼罪。若比丘临受具足时。若羯磨不成就。应弹指语言。长老汝羯磨不成就。若临时不语者。后不得语。令起疑悔言。汝受具足时白不成就。羯磨不成就。众不成就语者越毗尼罪。若瞎眼偻脊脚跛身体不成就。未受具足者。应语言且尔住彼。若于余处受具足来者。不得语。令疑悔语者。越毗尼罪。若病人来欲受具足。应语且尔住。若彼便于余处受具足来者。不得语。令疑悔语者。越毗尼罪。若疑悔比丘者。波夜提。比丘尼偷兰遮。式叉摩尼沙弥沙弥尼者。越毗尼罪。若俗人越毗尼心悔。是故说

佛住舍卫城。广说如上。尔时六群比丘数数易着衣。食前着一衣。食后着余衣。佛知而故问。是何等衣。答言。是我净施衣。佛言。汝云何净施衣。与他不舍而作三衣受用。从今日后不听净施衣不舍而受用。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘与比丘比丘尼。式叉摩尼沙弥沙弥尼衣。后不舍而受用者。波夜提。比丘者。如上说。与者。净施与五种人。不舍者。后不舍。受用者。作三衣受用。波夜提。波夜提者。如上说。若比丘有多衣忘不识。应取一切衣集着一处。当舍作是言。此衣净施与某甲。某甲于我不计意。今还舍。若是三衣者应别舍。是我三衣数。此僧伽梨先受持。今舍此僧伽梨。是我三衣数。今受持此郁多罗僧。是我三衣数。先受持。今舍此郁多罗僧。是我三衣数。令受持此安陀会。是我三衣数。先受持。今舍此安陀会。是我三衣数。今受持。此是我三衣数。不离宿受持。余衣长二肘。广一肘以上。尽应净施。净施法者。作是言。长老我此长衣施与某甲。某甲于我不计意。若浣染时缝时。有因缘事。我当舍用受持已。净施已着衣架上。日日当忆念记识。若忘者当语共行弟子依止弟子。此是我三衣汝当日日助我忆识。若无弟子者。应衣角头书作字。若自身对面净施不舍而受用者。波夜提。若不对面而自说净施。不舍而受用者。越毗尼罪。若对他面净施不舍而受用者。波夜提。复对余人不舍受用者。波夜提。不识衣。越毗尼罪。无三衣越毗尼罪。一时舍一时受。越毗尼罪。不舍作三衣受用。波夜提。不舍作塔用僧用与人。越毗尼罪。不得对面前说净施。当余人边说净施。是故说

佛住舍卫城。广说如上。尔时六群比丘食前取他僧伽梨取他钵藏着异处。是比丘乞食时到。欲入聚落。求僧伽梨不得。复有比丘求钵不得。是比丘问诸比丘长老谁持我僧伽梨去。复问谁持我钵去。时六群比丘便笑言。长老。此僧伽蓝大但求之。即求经久不得。复言。长老。雇我何物当助汝求。闻是语已。知是彼藏。食后复藏尼师檀及针筒。诸比丘食已。欲林中坐禅求尼师檀不得即言。长老谁持我尼师檀去。复有比丘言。谁持我针筒去。六群比丘笑言。长老此僧伽蓝大但遍求。即求经久不得。复语言。汝雇我何物当助汝求。闻是语已。知是彼藏。诸比丘以是因缘往白世尊。佛言。呼六群比丘来。来已佛具问上事。汝实尔不。答言。实尔。佛言。何以故尔。答言。为戏乐故。佛言。痴人此是恶事。恼诸梵行人而言戏乐。此非法非律。非如佛教。不可以是长养善法。佛言。从今已后不听戏笑藏他衣钵尼师檀针筒。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘藏他衣钵尼师檀针筒。乃至戏笑。波夜提。比丘者。如上说。衣者。七种衣也。钵者。瓦钵铁钵。钵有三种上中下。尼师檀者。如世尊所听。针筒者。筒中有针。藏者。若自藏。若使人藏。乃至戏笑。波夜提。波夜提者。如上说。三衣中若藏一一衣者。波夜提。若僧祇支及余衣等。越毗尼罪。三种钵中若一一藏。波夜提。若键镃及余器。越毗尼罪。藏尼师檀者。波夜提。藏余敷具越毗尼罪。针筒者。有针合藏波夜提。无针越毗尼罪。藏有缕针。波夜提。无缕针。越毗尼罪。有缕针但脱取缕藏。越毗尼罪。戏笑藏比丘衣。波夜提。比丘尼偷兰遮。式叉摩尼沙弥沙弥尼越毗尼罪。下至俗人。越毗尼心悔。是故说

佛住舍卫城。广说如上。尔时六群比丘从禅坊中起在屏处闇地立。悚耳皱面反眼吐舌。作喡喡声恐怖十六群比丘。十六群比丘闻已。即心恐怖举声啼唤。佛知而故问。是何等小儿啼声。诸比丘以是因缘具白世尊。佛言。呼六群比丘来。来已佛问六群比丘。汝实尔不。答言。实尔。佛言。何以故尔。答言。戏乐故。佛言。痴人此是恶事。恼梵行人而言戏乐。佛言。汝莫轻彼。彼若入定。能以神力掷汝着他方世界。此非法非律。非如佛教。不可以是长养善法。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘恐怖比丘者。波夜提。比丘者。如上说。恐怖者。色声香味触。波夜提。波夜提者。如上说。色者。在闇地悚耳皱面反眼吐舌。乃至曲一指喡喡作恐怖相。彼若畏若不畏。波夜提。是名色声者作象声马声驴声。如是等种种声。或长声卒止卒声长引。乃至觳耳作恐怖相。彼若畏若不畏。波夜提。是名声。香者作是言长老。是中有蛇香富单那恶鬼香蝎香。作是种种恐怖相。彼若畏若不畏。波夜提。是名香。触者。热冷轻重滑涩热者。若以火若以日炙。衣钵键镃揩户钥使热触彼身。作是言长老。火起火起。作如是恐怖相。彼若畏若不畏。波夜提。是名热。冷者。若以扇风衣风若水洒。作是言。长老。雨雪雨雪。作如是恐怖相。彼若畏若不畏。波夜提。是名冷重者。持重拘摄重旃押上。作是言。长老。壁倒壁倒。作如是恐怖相。彼若畏若不畏。波夜提。是名重。轻者。以诸轻细衣覆上。作是言。长老云堕云堕。作如是恐怖相。彼若畏若不畏。波夜提。是名轻滑者。若优钵罗花茎。拘牟头华茎。须揵提花茎。若户拘触彼身。作是言。长老。是蛇是蛇。作如是恐怖相。彼若畏若不畏。波夜提。是名滑涩者。钵头摩花茎。分陀利花茎触彼身。作是言。长老。此是百足虫。作如是恐怖相。彼若畏若不畏波夜提。是名涩。恐怖比丘者。波夜提。比丘尼偷兰遮。式叉摩尼沙弥沙弥尼越毗尼罪。下至俗人越毗尼心悔。是故说。

佛住舍卫城。为诸天世人之所供养。多所利益。尔时舍卫城中有姊妹二人。妊身未产。在家有信出家为道。诸比丘尼见其腹相。即便驱出。以是因缘往白世尊。佛言。在家妊身无罪。此比丘尼后生男儿。字童子迦叶。至年八岁出家为道。成阿罗汉。共十六群比丘。各持澡盥。到阿耆罗河边澡浴入水。仰覆浮戏渡河来往。拍水沐浴。尔时波斯匿王在重楼阁上。四望观看。王未信佛法。见是事已。倍生不信。即语末利夫人言。看汝家所事福田。夫人深信无疑不回顾看。即答言。大王。或是年少出家始受具足。未知戒律。或世尊未制此戒。是故尔耳。王语夫人言。喻如家长语时眷属随从。如和上阿阇梨语时。弟子随从沙门瞿昙语时。弟子皆言如是世尊。如是修伽陀。我共汝语。而汝不回顾看。尔时尊者童子迦叶。于其水中入顶第四禅。以天耳闻王语声。即语诸伴比丘作是言。长老王倍生不信。末利夫人心生不悦。今当令彼发欢喜心。皆言。善哉。各各即提澡盥盛满中水。以着于前。结跏趺坐。次第行列陵虚而逝。于王殿上空中而过。时末利夫人在露处坐。见其坐影已。即便仰观。见次第行列。结跏趺坐前皆有澡盥乘虚而去似如雁王。见是事已。心大欢喜。即白王言。看我家福田神德如是。王见已。心大欢喜。作如是言。善哉。我得善利。愿世尊及比丘僧尽寿在我国内。为良福田。诸比丘闻王嫌故。以是因缘往白世尊佛言。呼十六群比丘来。来已佛具问上事。汝实尔不。答言。实尔。佛言。我今罚汝。因汝当为诸比丘制戒。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。为诸比丘制戒。乃至已闻者当重闻。若比丘水中戏者。波夜提。比丘者。如上说。水者。有十种。戏者。跳渡还渡没出拨拍浇[泳-永+羨]。波夜提。波夜提者。如上说。跳者。戏故跳入水中。波夜提。若行岸崩堕水。若船行冲岸木石拨堕水中者无罪。是名跳。渡者。以戏故渡水。波夜提。若行欲渡。若渡物。若河彼岸有僧事塔事。宜数数经理。若欲学浮渡者无罪。还者。以戏故还渡水。波夜提。若有所忘失为物故。还渡取无罪。没者。以戏故沐没。波夜提。若钵小钵铜釬器物堕水没取者无罪。为澡洗故没无罪。出入者。以戏故入水出水。波夜提。为取物故无罪。拨者。以戏故拨水。波夜提。若水上热为取冷水故。拨取下水无罪。拍者。以戏故拍水。波夜提。若水上有倒孑虫拍。令入下取无虫水无罪。浇[泳-永+羨]者。以戏故在水中浇[泳-永+羨]岸上。越毗尼罪。岸上浇[泳-永+羨]水中者。越毗尼罪。水中浇[泳-永+羨]水中。波夜提。陆地浇[泳-永+羨]陆地者。越毗尼罪。非比丘病刺头出血迷闷。若热病迷闷。以冷水洒无罪。若比丘诵经时眠睡。以冷水洒无罪。若比丘食上沙弥挠乱。恐俗人不信故。知事者以水浇[泳-永+羨]无罪。是名浇[泳-永+羨]。若为和上阿阇梨洗以浴画背。越毗尼罪。若比丘食上戏故。以水画钵键镃器上作字越毗尼罪。若浇脚时以水画木上及画盆瓮瓶一一越毗尼罪。以指弹水作声。越毗尼罪。以水跳空中接取越毗尼罪。是故说

佛住舍卫城广说如上。尔时月八日十四日十五日斋日。比丘尼来诣佛所。头面礼拜问讯。时十六群比丘去佛不远。在一处坐。优钵罗比丘尼。脂梨沙弥尼。亦来礼拜问讯。礼拜问讯已。往十六群比丘所。以同年少相好乐故。至彼中坐。坐不正故彼见已更相指示而笑。时有婆罗门极丑陋偻脊尪脚。将一年少端正妇来见。诸比丘笑。已作是念。此诸沙门见我丑陋。将端正妇。必当笑我。即嗔恚言。沙门释子不知仪则。而形笑我。诸比丘即答言。我不笑汝。婆罗门言。不尔正笑我耳。作是语已。往至佛所。作是言。奇异。瞿昙。沙门释子不知仪则。见我丑陋。将端正妇而形笑我。佛即与婆罗门随顺说法示教利喜。欢悦而去。去已佛言。呼十六群比丘来。来已佛问比丘。有婆罗门极丑陋。将端正妇汝见已实笑不。答言。不笑婆罗门。汝笑谁。答言。世尊。斋日优钵罗比丘尼脂梨沙弥尼来到我所。坐不正故。我见已互相指示。是故笑耳。佛言。梵行尼坐不正。汝当方便令起。云何笑之。今当罚汝。因是为诸弟子制戒。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。为诸比丘制戒。乃至已闻者当重闻。若比丘以指相指。波夜提。比丘者。如上说。以一指指。波夜提。乃至五指亦如是。一切手指。波夜提。以拳指。偷兰遮。若木若竹指。越毗尼罪。若比丘共诤以指相指。波夜提。若直月若知事人差次食以指。指言某甲去。波夜提。若捉竹木指。越毗尼罪。应语言某甲。当次食去。若沙弥眠欲唤起者。应弹指。若不觉者。不得以指挃。当牵衣挽令觉。若诸比丘在俗人家坐。摩诃罗比丘坐不正者。应语汝正坐。若不觉者。应语正。汝衣复不觉者。应语言摩诃罗覆汝形体。若比丘至比丘尼精舍中坐。比丘尼礼比丘足已。在比丘前坐。若坐不正者。不得语令惭愧。应作方便。令起取物。若檀越家坐。妇女来礼比丘足。在前坐不正者。不得语令惭愧。当作方便。发遣取物。若奸淫女来试弄比丘。故不正坐者。不得语。但当避去。是故说

佛住毗舍离。广说如上。时有一人其妇不可意。嗔恚极打。便出妇。作是念。彼嗔不息。若更打者定死无疑。今当走避。即便出门。见有比丘乞食还欲出城。妇人即问言。阿阇梨欲何处去。答言欲出城去。妇人言。我欲随尊去。比丘言。姊妹。此是王道何为见问。即随后去。其夫后作是念。我妇得打。或能走去。即入不见其妇。即问余人言。何处去。答言。适出随是道去。即从后逐见其妇。随比丘后去。即生嗔恚。作是骂言。弊恶沙门诱我妇去。便捉比丘熟打。将诣断事官所。作是言。此比丘诱我妇去。断事人言。一一将来捡问事实。即问比丘。汝出家人云何将他妇走。答言。不尔。何因相随。答言。我乞食还欲出城去。妇人问我。欲何处去。我答言。欲出城去。妇人言。我欲随出。我答言姊妹。此是王道何用见问。事实如是。断事人言。将比丘出。唤妇人来。问言是沙门。偷汝去耶。答言不尔。何因相随。答言。夫主见打以夫嗔未息。复恐重打。因惧失命故。是故避走遇见比丘。即问言。尊者何处去。答言。我欲出城。我言。欲随尊去。比丘言。此是王道何用见问。事实如是。非彼所偷。即遣妇人出。复呼比丘来。问言。汝出家人偷他妇去。云何妄语。望得脱耶。向者女人言。汝实偷汝何言不。比丘答言。不尔。复更重问。答辞如初。遣比丘出。复唤女人问言。弊死女人。弃夫逃走。妄语欺官望得脱耶向者比丘言。实偷汝。汝何言不。答言。实不尔。如是三问答辞如初。即留女人唤比丘来。对验情状。观望颜色知其虚实。答辞如初。官问比丘。汝钵何以破。答言。破耳。衣何故裂坏。答言。裂耳。肘膝何以伤破。答言。伤耳。妇嗔夫未息。怜彼比丘受苦如是。而不语官。即向官说。官闻是已。极大嗔恚。作如是言。弊恶罪人。汝便是王更无余人。即敕官人料理比丘给其汤药。与其衣钵。即取是人系着狱中。籍家财物没入官库。诸比丘以是因缘往白世尊。佛语比丘。何处一切王家得是信心。此不与共期过患。如是况复共期从。今日后不听与。女人共期道行。佛告诸比丘。依止毗舍离城住者。皆悉令集。以十利故。为诸比丘制戒。乃至已闻者当重闻。若比丘与女人共期道行。乃至聚落中间。波夜提。比丘者。如上说。女人者。若母若姊妹。若大若小。在家出家。共期者。若今日若明日半月一月。道者。三由延两由延一由延半由延。一拘卢舍半拘卢舍。乃至聚落中间者。波夜提。波夜提者。如上说。若比丘与女人共期道行经一一聚落中间。一一波夜提。若还来者。亦一一波夜提。余如九十二第三跋渠中。与比丘尼共期。着道行中广说。此中以女人为异耳。是故说

佛住舍卫城。广说如上。尔时尊者阿那律在塔山夏安居竟。还舍卫城礼觐问讯世尊。行路中间日冥欲入聚落求宿止处。时聚落中有一母人。将一女欲出村取水。道路相逢。女见比丘颜貌端正威仪庠序。即生欲想。比丘入聚落。遍求宿处不得。作是念。当还出外于树下宿。即便还出。复逢彼母子。时女问母言。此沙门向冥欲何处去。答言。不知。女言。阿母可问。母即问言。沙门向冥出聚落欲至何所。答言。我入聚落求宿处不得。欲还出外树下止宿。女语母言。可将归家借其宿处。母即语言。沙门随我还家。当借宿处。比丘即随还至家与一房语言。沙门此中可宿。比丘即敷草蓐结跏趺坐。母子食讫。还自眠处。是比丘道行疲极偃息而卧。女伺母眠熟已。除除窃起至比丘所牵其草蓐。比丘觉已。起正身坐。女人性弱即便却去。去已比丘。还复卧。此女须臾复来。如世尊所说。有五种人。夜多不眠。何等五。女人起欲想忆男子故。夜多不眠。男子起欲想。忆女人故。夜多不眠。贼有盗心。夜多不眠。王忧念国事故。夜多不眠。精进比丘修习道业。夜多不眠。此女人不得眠。复窃起来牵其草蓐。比丘觉已起正身坐。乃至。夜了。明日至佛所。佛遥见已。知而故问。谁娆触汝。颜色不悦。即以上事具白世尊。佛告诸比丘。依止舍卫城住者。皆悉令集以十利故。为诸比丘制戒。乃至已闻者当重闻。若比丘与女人同室宿。波夜提

比丘者。如上说。女人者。若母姊妹。若大若小。在家出家。室者。同障同覆。宿者俱眠。波夜提。波夜提者。如上说。共一房有隔别户无罪。异房无隔。波夜提。共房共隔。波夜提。别房异户无罪。有覆有障。波夜提。有覆半障。越毗尼罪。有覆无障无罪。有障有覆波夜提。有障半覆。越毗尼罪。有障无覆无罪。比丘女人俱室内。波夜提。比丘室内女人半身在屋内。越毗尼罪。比丘屋内。女人屋外无罪。女人比丘俱屋内。波夜提。女人屋内比丘半身在屋内。越毗尼罪。女人屋内比丘在外无罪。若佛生日大会。得道日大会。转法轮日大会。罗云大会。阿难大会。般遮于瑟大会。若通夜说法者。当在露地。若风雨若雪堕寒者。当入屋里正身坐。若老若病不能坐者。当施障隔。障隔不得用疏物高齐肩腋。若比丘道路行入聚落宿时。当别房别隔。若无屋者。当露地宿。若风雨寒雪当入屋内正身坐。若老病劣弱不能坐者。当作障隔。若无障者。女人可信者。应语言。优婆夷。汝先眠我坐。比丘欲眠时。语令起我。欲眠汝莫眠。眠者汝无福。若雌象乃至鸡。若骆驼牛驴擎头时未得罪。委头眠者。波夜提。若雌狗舒头时无罪。屈头眠时。波夜提。鹅孔雀鸡舒头无罪。屈头着翅下。波夜提。象正立时无罪。倚时。波夜提。若众多比丘在房内眠。母人抱眠女儿入者。一切眠比丘。波夜提。若维那知事。人应语母人言。汝正竖儿抱入。是故说

佛住舍卫城。广说如上。尔时尊者优陀夷与一知识同聚落婆罗门。婆罗门女出嫁。至异聚落。遣信语父若阿阇梨。时时来看。我如二不定法中。因缘广说。乃至佛告优陀夷。痴人。在家俗人尚知出家人所应行法。不应行法汝信心出家而不知出家所应行法。此非法非律。非如佛教。不可以是长养善法。从今日后不听共女人独空静处坐。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。为诸比丘制戒。乃至已闻者当重闻。若比丘与女人独空静处坐。波夜提。比丘者。如上说。女人者。若母姊妹。若大若小。在家出家。独者独一女人。更无余人。设有余人。若眠痴狂心乱苦痛。婴儿非人。畜生虽有是人。故名独。空静者。寂静处。坐者。共坐波夜提。波夜提者。如上说。若比丘与女人共坐竟日。坐者。一波夜提。若比丘女人中间起。更坐一一波夜提。若比丘受请到檀越家坐。女人下食已坐比丘前。复起益食。如是复起复坐。一一波夜提。一女人比丘边坐一女人来往益食。女人出时比丘应起。起时不得辄尔起。恐彼女疑。谓呼比丘有异想。应先语。姊妹。我欲起。问言何故起。答言。世尊制戒不听共女人独空静处坐。是故起耳。女言。尊者莫起。我自起。起者无罪。减七岁女在阶道板上坐。坐已复第二板上坐。坐已复起第三板上坐。如是一一徙处坐。一一波夜提。若家中作务净人来往不断者。无罪。若门向道道中行人如比丘乞食顷不断。彼即当净人无罪。若比丘女人于阁上共坐。阁下净人遥见比丘。比丘亦见净人无罪。比丘女人在阁下坐。阁上人亦如是。或见而非闻。或闻而非见。亦见亦闻。非见非闻见而非闻者。净人遥见比丘女人共坐。不闻语声越毗尼罪。闻而非见者。闻语声不见其人。越毗尼罪。亦见亦闻者。见共坐闻语声。无罪。非见非闻者。波夜提。盲净人。越毗尼罪聋净人。越毗尼罪。盲聋净人者。波夜提。一盲一聋净人者无罪。若净人眠者。当动令觉此罪。亦是聚落。亦阿练若处。亦是时亦非时。亦是昼亦是夜。是屏处非露处。是空静非众多是近非远。是故说

  故夺及疑悔　　不舍藏畏怖
  水戏指相拟　　共行同室宿
  空静处亦然　　第七跋渠竟

佛住舍卫城。广说如上。尔时毗舍佉鹿母。长请祇洹僧。次第到其舍食时。毗舍佉鹿母头面礼僧足。次第而下。到十六群比丘所。见其年少身色柔软而能舍家。女人多慈起儿子想。亦敬法故。即便问言。祇洹众僧无供时。尊者何处得食。答言。时到着衣持钵。家家乞食。即语尊者。若无供时来我家食。我自今已后若无人供日。我当施食。年少比丘闻是语已。即便受请。至无供日。到其家食。鹿母长请佛时。尊者阿难日日到彼。为请食故。见十六群比丘在其家食。此诸年少起憍恣言。母此食太多。答言。子减之。复言。太少。答言。子当益如是。或嫌冷热坚软甜酢咸淡。如是种种难可称适。鹿母信心多慈。答言。子随索随与。阿难见已。作是念。若此是不信家。便起恶心。以是因缘往白佛言。善哉世尊。愿从今日勿与小儿受具足戒。佛言。从今日后年未满二十。不得与受具足

复次佛住舍卫城。广说如上。尔时摩诃罗父子二人在家有信舍家修道。其子沙弥供给五百比丘。诸比丘或索杨枝。或索树叶。如是众多不能得供。时摩诃罗念曰。我正有一子。供给五百比丘。所索众多不能得供。如是不久。必当生病然世尊制戒年未满二十。不应与受具戒。虽知不应且与受之。令其免苦。即将比丘出到戒场上。与受具足。受具足已。诸比丘犹如前法唤言。沙弥与我知净杨枝及草树叶。彼即答言。我已受具足。云何故唤沙弥。诸比丘言。谁与汝受。答言。我婆楼醯诸比丘。以是因缘。具白世尊。佛言。呼摩诃罗来。来已。佛具问上事。汝实尔不。答言实尔。佛言。此是恶事。摩诃罗。汝云何知人年未满二十。而与受具足。佛言。从今日后。不听年未满二十而受具足。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。为诸比丘制戒。乃至已闻者。当重闻。若比丘知人年不满二十。与受具足。波夜提。诸比丘应诃责。是人不名受具足。比丘者。如上说。知者。若自知。若从他人闻。不满者。不满二十雨减二十年。是名不满。二十减二十雨满二十年。是名不满二十。减二十雨过二十年是名不满。二十冬时生还冬时受。未经安居竟。是名不满。春时生还春时受。未经安居竟。是名不满。前安居生还前安居受。未经前安居竟。是名不满。后安居生还后安居受。未经后安居竟。是名不满。此人减二十时人。半谓减半谓满。半谓减者。波夜提。谓满者。无罪。此人名受具足。此人年减二十时。人一切谓不满与受具足。一切波夜提。此人不名受具足。此人年减二十时。人一切谓满与受具足。一切无罪。此人名受具足满二十雨减二十年。是名满。二十满二十雨满二十年。是名满。二十满二十雨过二十年。是名满。二十冬时生经安居竟受具足。是名满。二十春时生安居竟受具足。是名满。二十前安居时生前安居竟受具足。是名满。二十后安居时生后安居竟受具足。是名满。二十雨满二十雨时。人半谓满半谓不满。谓不满者。越毗尼罪。谓满者无罪。是人名受具足。满二十雨时。人一切谓不满。一切越毗尼罪。是人不名受具足。满二十雨一切谓满一切无罪。是人善受具足。若比丘知人不满二十与受具足。此诸比丘应呵责已。波夜提。悔过波夜提者。如上说。若有人来欲受具足月满者。应与受具足。不满者应语令待满。若前人不知者。当问其父母亲里。若复不知当看生年板。若复无是者当观其颜状。观时不得直观形体。或贵乐家子形大年少。当观其手足成就不。若如是复不知者。当问何王何岁国土丰俭旱涝时节。是故说

佛住舍卫城。广说如上。尔时舍卫毗舍离二国有嫌。年年互相抄伐。时毗舍离人来舍卫。抄劫人民得物去。还入本界生安隐想。解仗止息。舍卫王作是念。我为国王。应却邻敌安民。云何使贼劫掠人物。即敕将士。仰汝追捕必使擒获。若不得者不足空还。将士念言。王教严重事应宜速。即集兵众寻踪掩袭。时舍卫比丘安居竟。欲诣毗舍离。诸比丘失道。堕彼贼中。贼便惊愕。问比丘。比丘汝是何人。答言我出家人何道出家。答言。释种出家。问言。大德。汝欲那去。答言。欲向毗舍离失道到此。即示其道。时比丘问贼长寿。汝欲何去。答言。向毗舍离。比丘复言。当共作伴。彼即答言。我等是贼劫夺他物。径涉榛木行不择路。汝是善人。云何随我。此是直道可从是去。比丘复请愿。将我去勿复令我重遭失道。贼答如初。如是至三语。言未竟追捕寻至。合捉比丘。将至王所。作如是言。大王此是群贼。王言。先将比丘来。来已王言。汝出家人。云何作贼。比丘答言。我非是贼。何故相随。比丘以上事具向王说。王言。遣比丘去。将此贼来来已。问贼言。此出家人是汝伴不。答言。非伴。何故相随。贼以上事具向王说。王言。将贼去。更唤比丘来。来已。王问比丘。汝出家人。云何作贼妄语欺官。望得脱耶。贼道汝是伴。何以言非。比丘答如初。王即教敕禁官放比丘去。贼如法治罪。便取五百群贼。着迦毗罗华鬘。打鼓摇铃四交道头。唱唤而出。欲将杀之。贼大啼哭。佛知而故问。比丘是何等众多人声。比丘答言。世尊。是五百群贼。被王教令。将欲杀之是其声耳。佛告阿难。汝往语王。汝是人王当慈民如子。云何一时杀五百人。阿难受教。即诣王所。具说佛语。王言。尊者阿难。我知是事若杀一人罪报甚多。况复五百人。但是贼数数来坏我聚落抄掠人民。若世尊能使是人不复作贼者。可放令活。阿难即还以王所说具白佛。佛语阿难。更往语王。王但放去。我能令此人从今日后更不作贼。阿难受教已。先到刑处。语监杀者言。是诸罪人世尊已救。未可便杀。复语贼言。汝能出家不。贼言。尊者我本若出家不遭此苦。今甚愿乐。何由可得。阿难即至王所。作是言世尊语王。我能令此人从今日后更不作贼。王即敕监官。可原生命。且未解缚。送诣世尊。佛自放之。尔时世尊欲度彼人故。在露地坐。贼遥见佛系缚自解。头面礼足。却住一面。佛观其宿缘随顺说法。布施持戒行业报应。苦习尽道。四真谛法。即于是时得须陀洹道。问言。汝等乐出家不。答言世尊。我等先若出家不遭此苦。唯愿今者度我出家。佛言。善来比丘。作是语时。五百群贼举身被服变为三衣。自然钵器威仪庠序。如似百岁旧比丘。皆成罗汉。诸比丘白佛言。世尊。云何五百群贼蒙世尊恩自然解脱。佛言。不但今日蒙我解脱。过去世时已曾蒙我。如猕猴本生经中广说。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。为诸比丘制戒。乃至已闻者当重闻。若比丘与贼期共道行。乃至聚落间。波夜提。比丘者。如上说。贼者。劫盗。期者。若今日明日一月半月。道者。三由延。二由延。一由延。一拘卢舍。半拘卢舍。乃至聚落。波夜提。波夜提者。如上说。不得与贼共期道行。若比丘欲行时。当求车伴人伴。贼相貌有三事可知香色庄严。香者。在旷野中食熟肉生肉气色者。常恐怖色。庄严者。终日结束面黑发黄凶恶。似阎罗人。是三种名为贼相不应共行。若贼诈称作好人着好衣服。到空迥处。展转相语。今日当入是聚落。破坏墙壁劫夺财物。不问沙门婆罗门。一切尽取。当知是贼是时不得。即便舍离。且随顺去。若近聚落方便舍去。若贼觉者应语长寿。我正到此耳。若与贼共期道行。波夜提。与女贼共行。亦如是。与偷金贼共行。波夜提。与叛负债人共行。越毗尼罪。是故说

佛住旷野精舍。广说如上。尔时营事比丘。自掘地作基作塼作泥。为世人所讥。沙门瞿昙无量方便。毁呰杀生赞叹不杀。而今自手掘地作基作塼作泥。故伤破根命。此是败人何道之有。诸比丘以是因缘。往白世尊。佛言。呼营事比丘来。来已。佛问比丘。汝实尔不。答言实尔。佛语比丘。此中虽无命根。出家之人所不应作。当少事少务。莫为世人所讥。失他善福。从今日后不得自手掘地。佛告诸比丘。依止旷野诸比丘皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘自手掘地。若使人掘指示语掘。波夜提。比丘者。如上说。自手者。若身身分身方便。身者。举身跳踯走来走去。欲令坏地者。波夜提。是名身。身分者。若手若脚。若膝若肘。若指爪。是名身分。身方便者。若锹钁斧凿竹木自手掘地。若遥掷欲令坏。坏者。波夜提。地者。生作。生者。大地是名生。作者。基作上作。基作者。露地墙壁。上作者。重阁屋上覆土是名上作。自掘者。自掘使人掘。乃至言掘是地。波夜提。波夜提者。如上说。若自方便多掘。一波夜提。若中间止住一一波夜提。使人者使他人掘。前人多掘。一波夜提。若重语使掘疾掘语语。波夜提。若比丘欲使地平作方便扫地。越毗尼罪。若伤如蚊脚。波夜提。不作方便无罪。若方便牵曳木欲使破地牵时。越毗尼罪。若伤如蚊脚。波夜提。不作方便无罪。若驱牛马欲使破地。亦如是不作方便无罪。若欲使地平故经行行时。越毗尼罪。伤如蚊脚。波夜提。住坐卧亦如是。不故者无罪。若比丘河边坎上以脚踏堕踏踏波夜提。池坎岸边行土崩无罪。若土块一人不胜破者。波夜提。破减一人重者。无罪。若比丘捉木石塼瓦锹钁掷地。不故虽伤无罪。若营事比丘多有塔物僧物。欲藏地中。若在露处生地不得。自掘当使净人知若在覆处。死地得自掘藏。若地打杙。越毗尼罪。伤如蚊脚。波夜提。拔杙时。越毗尼罪。伤如蚊脚。波夜提。若比丘欲张毡[疊*毛]须钉四角。若覆处死地自钉无罪。若露处生地。当使净人知拔时。当使净人知。若比丘房内钉壁毁损成功。越毗尼罪。若先有故孔无罪。若比丘外被雨地伤如蚊脚。波夜提。若欲画地。越毗尼罪。伤如蚊脚。波夜提。画末土无罪。若营事比丘欲作摸式。当画板木塼上。若泥覆朽故房舍。欲撤时不得自撤。当使净人。若欲坏壁时。当使净人却泥。然后自得摘塼至基际使净人摘。若壁不泥者。以曾被雨。使净人摘两三行。然后自摘至地际。复使净人摘。若塼坏聚被雨已。不得自取。使净人取上。两三重。然后自取至地际。复使净人取若覆上者。得自取到地际。应使净人取塼聚。亦如是。若死土被雨已。比丘不得自取。使净人取尽雨所洽际。然后自取无罪。若鼠壤被雨不得取。应使净人取。若新雨后比丘不得自抒井。应使净人抒。若净人小不能者。当先下净人扰令浊。然后自抒。若池水洸水。新雨后比丘不得自抒若牛马先涉得自抒。若泥被雨后不得自取。使净人取。若池泥洸泥新雨后。比丘不得自取。使净人取。若水渎若屋流水道。新雨后比丘不得自抒。使净人抒。若大小行用水时手摩地。波夜提。当用灰土豆末。若雨涝推土聚一处。比丘不得自取。使净人取。若瓮瓶器物在露地经雨已。比丘不得自取。使净人取。若洗脚木经雨后不得自取。若木石塼瓦种种诸物在露地。雨后比丘不得自取。使净人知掘地。波夜提半沙越毗尼罪。纯沙无罪。石礓石粪灰亦如是。是故说

摩诃僧祇律卷第十九摩诃僧祇律卷第二十

        东晋天竺三藏佛陀跋陀罗共法显译

    明单提九十二事法之九

佛住舍卫城广说如上。尔时梨车摩诃男请僧施药。时六群比丘闻摩诃男请僧施药。当试恼之。明日早起着入聚落衣到其家。共相问讯。我闻檀越请僧施药。为实尔不。答言实尔。尊者。有所须耶。答言。须药须何等药。答言。须尔所酥尔所油。尔所蜜尔所石蜜。尔所根药叶药花药果药。彼言。即日未具。须办当与。比丘言。汝当备药。然后请僧供一比丘药如给一大象。我今一人索药。尚不能得。况复众多。汝但求名誉。无有实心。彼言。尊者王家库藏尚无尔所药。况复我家须办当与。比丘言。与以不与当任汝意。言已便出去。檀越于后即办众药。自往白言。先所索药今者已办。便可来取。比丘闻已。并笑而言。我前但试汝。实不须药。彼曰。何故相试。我家中所有于佛比丘僧无有匮惜。比丘言。檀越嗔耶。答言。实嗔。若嗔者我当悔过。彼曰。我不受悔过。自可向佛悔过。比丘即向佛悔过。佛言。何故。即以上事具白世尊。佛言。痴人梨车摩诃男家所有爱重。于佛比丘无所匮惜。何故扰乱。从今日后听四月别请。应受除更请长请。佛告诸比丘。依止舍卫城比丘。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘四月。别自恣请应受。若过受。波夜提。除更请长请自恣请。比丘者。如上说四月者。或夏四月。或冬四月。或春四月。别请者。私请。过者。过四月除。更请者。世尊说无罪。除长请者。尽形寿请。波夜提者。如上说。若檀越语比丘言。尊者受我夏四月请。比丘若受不应过至八月十六日。受者。波夜提。若受冬请春请亦如是。檀越请不必定。或四月。或一月。或半月。若期满已不得更受。若檀越言。尊者常此间住者。我长施食。若比丘离一宿行者不得复食。若檀越言。尊者何以故不来。答言。汝先言常住此者当施食。我已离宿。是故不来。檀越言离不离。从今日但来如是受者无罪。檀越言。尊者受我请食。尽此仓谷。比丘受之应数数问典仓者。若言啖尽不得复食。若檀越言。尊者何以不来。答言。我先受请尽此仓谷。谷今已尽。是故不来。若言尊者我非谓一仓。更有余仓。从今日但来如是受者无罪。请食酥甘蔗亦复如是。若檀越言尊者受我请食。尽此牛乳。比丘受之应数数问[穀-禾+牛]乳者。若言[穀-禾+牛]休不得复受。若言何以不来。答言。我先受请尽此牛乳。乳今已尽。是故不来。若言我非一牛更有余牛。从今日但来。如是受者无罪。若檀越言尊者受我请食。齐女夫住此比丘应受。若女夫去者不得复受。若言何故不来。答言。我先受请。齐女夫住。女夫今去。是故不来。若言更受我请。如是受者无罪。若言尊者受我前食。不得索后食。若请后食不得索前食。若请与非时浆不得索药及余物。若请与涂足油不得索非时浆。若请与药者应从索药。若言尊者尽寿受我请衣食卧具医药。尔时得随意索无罪。是故说

佛住拘睒弥国。广说如上。尔时诸比丘语阐陀言。长老当学莫犯五众罪。答言。我今不随汝语。我若见余长老寂根多闻持法深解。我当从咨问。彼若有所说我当受行。诸比丘以是因缘。往白世尊。佛言。呼此阐陀比丘来。来已。佛具问上事。汝实尔不。答言。实尔。佛语阐陀。此是恶事汝常不闻我无量方便称叹随顺毁呰违逆。汝云何[怡-台+龍]悷自用。此非法非律。非如佛教。不可以是长养善法。佛告诸比丘依止拘睒弥国住者。皆悉令集。以十利故。为诸比丘制戒。乃至已闻者当重闻。若诸比丘教语当学莫犯五众罪。若作是言。我今不随汝语。若见余长老寂根多闻持法深解。我当咨问。彼有所说我当受行。作是语者。波夜提。比丘欲得法利者应学。亦应问余比丘。比丘者。如上说。五众罪者。波罗夷。僧伽婆尸沙。波夜提。波罗提提舍尼。越毗尼罪。莫犯者。教令学十二事。十二事者。所谓戒序。四波罗夷。十三僧伽婆尸沙。二不定。三十尼萨耆波夜提。九十二波夜提。四波罗提。提舍尼。众学法。七灭诤法。随顺法。当学莫犯。作是语时。答言。我不随汝语。若见余长老寂根多闻持法深解。当从咨问。彼有所说我当受行。作是语者。波夜提。若言长老五众罪中波罗夷。僧伽婆尸沙。波夜提。波罗提提舍尼。越毗尼罪。当学莫犯。作是语时。答言。不随汝语。若见余长老寂根多闻持法深解。当从咨问彼有所说我当受行。作是语者。波夜提。如是四众罪三众罪二众罪一众罪。四波罗夷。应当学莫犯。作是语时。答言。我不随汝语。若见余长老寂根多闻持法深解。当从咨问。彼有所说我当受行。作是语者波夜提。若作是语。长老六作舍法。所谓作折伏羯磨不语羯磨。驱出羯磨。发喜羯磨。举羯磨。别住羯磨。当学莫犯。作是语时。答言。我不随汝语。若见余长老寂根多闻持法深解。当从咨问。彼有所说我当受行。作是语者波夜提。若作是语。长老此六舍法已作折伏羯磨。随顺行法折伏柔软。如是应舍。乃至别住羯磨亦复如是。当学莫犯。作是语时。答言。我不随汝语。若见余长老寂根多闻持法深解。当从咨问彼有所说我当受行。作是语者。波夜提。若言长老当学贤善持戒受诵经法。当得须陀洹斯陀含阿那含阿罗汉果。作是教时。不得答言有常。当学应答言。我为是故出家。是故说

佛住拘睒弥国。广说如上。尔时拘睒弥界有恶龙。名庵婆罗。能使亢旱不雨苗稼不收。人民饥馑。如是种种灾患。时尊者善来比丘往降恶龙。如善来比丘经中广说降伏恶龙已。乃至国土丰乐人民感德。知恩报恩。有五百大家为善来故。各立常施幢幡施设床座。请僧供养别请。善来比丘其所造家。则设种种美食。时有一家施食之后。因渴施酒色味似水得而饮之。还向精舍。尔时世尊大会说法。酒势发盛。昏闷躃地。当世尊前舒脚而卧。佛知而故言。是何比丘在如来前舒脚而卧。比丘答言。善来比丘饮酒过多是故醉卧。佛问诸比丘。此善来比丘先曾昼寝不。不也世尊。复问比丘善来。未醉之时颇曾佛前舒脚卧不。不也世尊。复问比丘多饮酒已。欲使不醉可得尔不。不也世尊。复问诸比丘。设使善来比丘不饮酒时闻说微妙不死之法。当欲失是善利。不听受不。不也世尊。佛语诸比丘。是善来。比丘本能降伏恶龙。今者能降虾蟆不。答言。不能。佛言。设使庵婆罗龙闻者生其不乐。从今日后不听饮酒

复次佛住舍卫城。广说如上。尔时尊者那夷翅饮石蜜酒过多。来还精舍。尔时世尊大会说法。酒势发盛昏闷躃地。在世尊前舒脚而卧。佛知而故问。是何比丘在如来前舒脚而卧。答言。世尊。是那夷翅比丘饮石蜜酒过多。是故醉卧。佛问诸比丘。那夷翅比丘先曾昼寝不。不也世尊。复问比丘那夷翅。未醉之前颇曾舒脚佛前卧不。不也世尊。复问比丘。若多饮酒已欲使不醉。可得尔不。不也世尊。复问比丘那夷翅。不饮酒时闻说如是微妙不死之法。当欲失是善利。不听受不。不也世尊。佛言。从今日后不听饮石蜜酒。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。为诸比丘制戒。乃至已闻者当重闻。若比丘饮石蜜酒。波夜提。比丘者。如上说。酒者。十种和甜成动酢渍黄屑淀清。和者。饭屑麴屑水和着器中。如是不得草滴发滴入口。况复器饮。波夜提。是名和。甜者。和酿已讫始变生甜。乃至饮者。波夜提。是名甜。成者。气味成就。乃至饮者。波夜提。是名成。动者。酒势已坏乃至饮者。波夜提。是名动。酢者。酒味坏变成酢。乃至饮者。波夜提。是名酢。渍者。净浣白[疊*毛]渍着酒中。数数出晒晒已复渍。远行旷野时渍[疊*毛]绞取。乃至饮者波夜提。是名渍。黄者。澄黄未清乃至饮者。波夜提。是名黄。淀者。酒下浊淀乃至饮者。波夜提。是名淀清者。上澄清如油色。如是不得草滴发滴入口。况复器饮。波夜提。是名清。石蜜酒者。十种和甜成动酢渍黄屑淀清。和者。石蜜[薜/米]水和着器中。如是不得草滴发滴入口。况复器饮。波夜提。余九事如上说。波夜提者。如上说。[麩-夫+黃]麦人醪。米饭醪。麦饭醪。木麦醪。糗醪[麩-夫+黃]麦人醪者。[麩-夫+黃]麦人[薜/米]水于器中酿。如是不得草滴发滴入口。况复器饮波夜提。米饭醪者米饭[薜/米]水于器中酿。乃至饮者。波夜提。麦饮醪者。麦饭[薜/米]水于器中酿。乃至饮者。波夜提。木麦醪者。木麦饭[薜/米]水于器中酿。乃至饮者。波夜提。糗醪者。糗[薜/米]水于器中酿。如是不得草滴发滴入口。况复器饮波夜提。食后饮水无罪。食麴越毗尼罪饭麴和饮者。波夜提。食石蜜饮水无罪食[薜/米]越毗尼罪。三种合饮者。波夜提饮谷酒石蜜酒波夜提饮葡萄酒。越毗尼罪饮修楼饮难提啖糟皆越毗尼罪。食墟逻果迦比哆果。比逻婆果。拘陀罗果。此诸果食者令人醉食者越毗尼罪。除十四种浆庵婆罗浆。乃至耶婆果浆得澄清一切听饮。若变酒色酒味酒香一切不听饮酢浆令人醉者亦不听饮除甘蔗苦酒葡萄苦酒及酢浆是故说

佛住拘睒弥国广说如上。尔时僧和合欲作羯磨。时尊者阐陀不来遣使往唤语阐陀比丘僧和合欲作羯磨。长老来而不肯来。诸比丘言。阐陀佷戾若唤来必不来若语莫来脱有来理即遣使语长老莫来。彼言住住汝等尽往语。我莫来即便来。入僧中比丘语令坐而不肯坐。诸比丘复语。长老莫坐即言。汝等尽坐语我莫坐。便坐比丘复语。长老汝可论是事。答言我不语。比丘复语长老莫语。即言汝等尽语语我莫语。便语不止妨废余人诸比丘复语长老可小出而不肯出。比丘复语长老莫出即便出去故。僧不和合各各起去不得作羯磨。诸比丘以是因缘往白世尊。佛言。唤阐陀比丘来。来已佛具问上事。汝实尔不。答言。实尔。佛言此是恶事。阐陀汝常不闻。我无量方便叹说随顺软语毁呰佷戾。汝云何佷戾自用。此非法非律非如佛教不可以此长养善法。佛告诸比丘。依止拘睒弥住者皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘轻他波夜提。比丘者如上说。轻他者有八事。语来而不来。莫来而来。坐而不坐。莫坐而坐。语而不语。莫语而语。去而不去。莫去而去。波夜提。波夜提者。如上说。若比丘僧集欲作折伏羯磨。不语摈出发喜举别住羯磨一切尽应来。若轻他不来者波夜提。若比丘作衣钵事。若病因缘不得来者与欲无罪。若语莫来轻他来者。波夜提若僧中有事欲。须见僧白。僧听来无罪。若言长老坐轻他不坐者波夜提。若坐处有疮痈。白僧听者不坐无罪。若语莫坐轻他坐者。波夜提。若老病羸弱久立闷极。白僧听者坐无罪。若语令语轻他不语者。波夜提若才劣言轻人不敬用。设语羯磨不成就。僧不和合。白僧听者不语无罪。若语莫语轻他语者。波夜提。若作是念。设不语者羯磨不成就僧不和合。事须我语。白僧听者语无罪。若语令去轻他不去者波夜提。若作是念。若我去者。此中羯磨不成就。事不断。当白僧听者不去无罪。若语莫去轻他去者波夜提。若作是念。若我不去者羯磨不成就。事不断。当白僧听者去无罪。若僧中语来不来莫来而来坐而不坐莫坐而坐。语而不语莫语而语去而不去。莫去而去。一一得波夜提罪。若众多人中师徒中语来而不来。乃至去而不去。一一得越毗尼罪。若和上阿阇梨语来而不来。乃至去而不去。一一得越毗尼罪。是故说

佛住舍卫城。广说如上。尔时诸比丘诤讼同住不和。时六群比丘屏处盗听闻此语已向彼人说闻彼语已向此人说。于是此彼更生诤讼。同止不和。云是法非法是律非律。乃至是应羯磨。是不应羯磨诸比丘以是因缘往白世尊。佛言。唤是六群比丘来。来已佛具问上事。汝实尔不。答言。实尔。佛语六群比丘。此是恶事。非法非律非如佛教。不可以此长养善法。佛告诸比丘。依止舍卫城住者皆悉令集。以十利故。为诸比丘制戒。乃至已闻者当重闻。若比丘诸比丘诤讼时。默然立听彼有说者我当忆持。作是因缘不异者波夜提比丘者如上说诤讼者是法非法。是毗尼非毗尼。乃至是应羯磨。是不应羯磨立听者。若隔壁。若隔篱若户边。若隔幔。若隔石若隔草立听。彼有说者我当忆持。作是因缘不异者。波夜提。波夜提者。如上说。若二比丘在堂里私语。若比丘欲入者应弹指动脚作声。若前人默然者应还出。若前人故语不止者入无罪。若一比丘先在堂内坐。二比丘私语从外入来。堂内比丘不得默然应弹指动脚作声。若默然者堂内比丘应出若比丘共余比丘斗诤结恨。作是骂詈我。要当杀此恶人。然后舍去。比丘闻已得语彼人。长老好自警备。我闻有恶声。有诸客比丘来。若在讲堂温室禅坊中。若摩摩帝若知事人往看。客比丘闻客比丘作是言。长老我等当盗某库藏某塔物。某僧净厨某比丘衣钵。闻是语已默然应还。还已应众僧中唱言。诸大德。某库藏某塔物。某僧净厨某比丘衣钵。当警备。我闻恶声。应使前人知。若比丘多有弟子日暮窃来。按行诸房知如法不。若闻说世俗谈话。若说王说贼。如是种种言说不得便入呵责。待自来已。然后诲责曰。汝等信心出家。食人信施。应坐禅诵经。云何论说世俗非法之事。此非出家随顺善法。若闻论经说义问难答对。不得便入赞叹待自来已。然后赞美。汝等能共论经说义讲佛法事。如世尊说。比丘集时当行二法。一者贤圣默然。二者讲论法义。若比丘入聚落行语而去。后比丘来不得默然。应謦欬动脚作声。若前人故语者。随进无罪。若比丘前去后比丘行语而来。前比丘不得默然。应謦欬动脚作声。若比丘绕塔时食后欲入林中坐禅时。亦复如是。是故说

佛住舍卫城。广说如上。尔时比丘僧集欲与优波难陀共行弟子依止弟子。作举羯磨。时优波难陀闻与弟子作举。羯磨即便起去。后比丘见坐处空检校。谁来谁不来。是谁坐处。比丘言。是优波难陀坐处。如是僧不和合。各各起去。不得作羯磨。诸比丘以是因缘往白世尊。佛言。唤优波难陀来。来已佛具问上事。汝实尔不。答言。实尔。佛语优波难陀。此是恶事。汝云何僧欲断事。默然起去。不白比丘此非法非律非。如佛教。不可以是长养善法。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘僧欲断事。默然起去不白比丘。波夜提。比丘者。如上说。僧欲断事者。有二种。一者说法毗尼。二者作折伏羯磨。乃至别住羯磨。默然起去者。起离座去。不白者若白非时。入聚落。不名为白。白往尼精舍教诫。不名为白。白离食处不名为白。若僧集说法毗尼者。应白言。离说法座去。答言尔。若僧集作折伏羯磨。乃至别住羯磨者。应白并与欲比丘。现前僧中不白去者。波夜提。波夜提者。如上说。若僧集欲作折伏。乃至别住羯磨比丘欲去者。应白并与欲不白与欲者。波夜提。白而不与欲。越毗尼罪。不白不与欲。一波夜提。一越毗尼。白并与欲无罪。若欲大小便须臾还不废僧事无罪。若作是念。设晚来者应白并与欲。若说法说毗尼者应白去不白去者。越毗尼罪若比丘听众多比丘诵经。应白去。不白去者。越毗尼罪。若诵经者止诵作余语去者无罪。若比丘听他比丘受经。应白去。不白去者。越毗尼罪。若比丘听他读经。应白去。不白去者。越毗尼罪。是故说

佛住舍卫城。广说如上。尔时诸比丘阿练若处住。非时入聚落。为世人所嫌。云何沙门释子阿练若处住。非时入聚落。何所欲求。诸比丘以是因缘。往白世尊。佛言。唤是比丘来。来已佛具问上事。汝实尔不。答言。实尔。佛语比丘汝云何阿练若处住。非时入聚落。正应为世人所讥。从今日后不听阿练若处住。不白比丘非时入聚落

复次佛住舍卫城。广说如上。尔时有二比丘阿练若处住。时一比丘涂房为蛇所螫。语伴言。长老。我为蛇所螫。答言。待我取僧伽梨。当往呼耆域医。师取衣中间即便失音彼取衣已白言。长老。我非时入聚落时比丘不能言。如是至三白言。长老。我非时入聚落。犹故不言彼作是念。世尊制戒不听阿练若处不白比丘非时入聚落。是比丘而不报。我当任其行业知复如何即便命终。诸比丘以是因缘。往白世尊。佛言唤是比丘来。来已佛具问上事。汝实尔不。答言。实尔。佛语诸比丘。彼若慈心称四大龙王名者。应不至死。何等四。持国龙王。伊罗国龙王。善子龙王。黑白龙王。我有慈无足众生。我有慈两足众生。我有慈四足众生。我有慈多足众生我有慈无足众生莫害我两足众生。莫害我四足众生。莫害我多足众生。莫害我一切众生。应得无漏一切贤圣善。心相视莫兴恶意。设使比丘称是四大龙王名者。应不致死。从今日后听除急时。佛告诸比丘依止舍卫城住者。皆悉令集。以十利故与诸比丘制戒。乃至已闻者当重闻。若比丘阿练若处住。非时入聚落。不白比丘。除余时波夜提。比丘者。如上说。阿练若处住者。若离城邑聚落。五百弓弓长五肘。于其中间无人住。是名阿练若处。非时者后食已竟。时虽早犹是非时聚落者。垣墙障乃至乱居聚落白者。若言白离食家不名为白。若言白往尼精舍教诫。不名为白。若言白离说法处。不名为白应白言。长老。我非时入聚落。前人言可尔。比丘者界内现前。非徒众现前。除余时者。若比丘种种疾病为蛇所螫。为唤医故。世尊说无罪。若二比丘在阿练若处住。若欲俱行展转相白。若一人先行。后人复欲行者。应白余比丘。若无余比丘者。应作是念。若道中若门若聚落。若尼精舍。见比丘当白。白已然后非时入聚落。若比丘道路行。从聚落中过聚落中路边有塔。若天祠。当顺道直过。若下道左旋右旋去者。波夜提。若火起若种种恶兽来。逐人者随意去无罪。若比丘远行道路。日暮欲入聚落。宿不得荷负囊襆而入。若村外有水应林中止息。先令二比丘净洗浴。着僧伽梨施纽展转相白。遣入聚落。求宿止处。若得宿处。应从坛越索随所安。还出聚落。语诸比丘。已得宿处。尔时诸比丘应净洗手足。欲饮非时浆者。即于此饮之。若入聚落勿令人讥沙门。夜食衣囊襆器。分张持去。着僧伽梨安纽。捉杖持革屣展转相白。然后当入已到宿处。复欲出取薪草水者。若从本道出者无罪。若更从余道行。应白不白去者。波夜提。若欲求涂足油。非时浆劝化。明日食者。白已当去。不白去者。波夜提。若聚落中有僧伽蓝。道上有屋连接覆去者无罪。余道去者应白。不白去者。波夜提。是故说

  不满共贼伴　　掘地四月请
  未学并饮酒　　轻他默然听
  默起非时入　　第八跋渠竟

佛住舍卫城。广说如上。尔时尊者优波难陀晨起着入聚落衣。到檀越家。语优婆夷言。凡夫人若死命尽多堕恶道。汝当听我说法。时优婆夷料理家业。众事匆务无暇听法。便嫌比丘言。置令凡夫人。若死堕恶道。阿阇梨但自忧己莫忧他人。后食竟。令弟子荡钵复入其家。如前语曰。优婆夷凡夫人若死堕恶道。汝当听我说法。时优婆夷饮食夫主儿子竟。后自食不容得听。复嫌比丘言。置令凡夫人若死堕恶道。阿阇梨但自忧己莫忧他人。诸比丘闻已。以是因缘往白世尊。佛言。呼优波难陀来。来已。佛具问上事。汝实尔不。答言实尔。佛问比丘。汝食后去作何等事。答言。多事世尊。我欲作医疗治众病。佛言。汝云何同食处食前食后不白。比丘行至余家从今日后不听同食。处食前食后不白。比丘行至余家

复次佛住舍卫城。广说如上。尔时佛告阿难。汝语诸比丘。安居已讫。诸檀越施安居衣。阿难即语诸比丘。诸比丘言。世尊制戒。不听同食处食前食后不白。比丘行至余家。我等与诸梵行人同食。共住敬难故不敢数白。阿难以是因缘。往白世尊。佛言。从今日后听衣。时佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘同食处食前食后不白。比丘行至余家。除余时。波夜提。余时者。衣时是名余时。比丘者。如上说。同食者。或米四升作饭。或糗八升。或麦饭斗二升鱼肉。若半钵若一钵是名同食。食前者。未食。食后者。食已日虽早故名食后。行至余家者。刹利家婆罗门家。毗舍家。首陀罗家。白者。若白非时入聚落。若白往比丘尼精舍。若白离说法处。不名为白。应白言长老忆念。我某甲离同食行至余家。答言尔。除余时者。世尊说无罪。余时者衣时。衣时者。无迦絺那衣。一月有迦絺那衣。五月衣时中间舍五罪别众食处处食离同食不白。畜长衣离衣宿无罪。波夜提者。如上说若比丘离同食欲余行者。应白去不白去者波夜提。若于他处食。五正食五杂正食。二波夜提。不白离同食处处食。若作施食法。若衣时者。二俱无罪。若比丘住处无食。若有人请食。即彼处名为同食。若于彼处欲余行者应白去不白去者。如上说。若比丘受聚落中请。即彼处名同食。日旱欲余行经过。应白去。不白去者。如上说若聚落中请僧食有比丘过到其家。檀越言。尊者。我今日饭僧尊者。亦受我请。比丘受者。即名同食。日时尚早。比丘复欲余行。应当白去。不白去者。波夜提。余如上说。若檀越请僧食比丘乞食。过到其家。檀越言。我今请僧食尊者亦受我请。若比丘受者。亦名同食。比丘寻自思惟。檀越信施心重。我不能消不如行乞趣得支命。欲舍去者应白去不白去者。波夜提。余如上说。若二比丘各有食处。俱向聚落道中议言。我等今日先一家食。然后次第共余家食后食。一比丘应白去。不白去者。波夜提。若至先食家得五正食五杂正食。二波夜提。离同食处处食。若作施食法若衣时二俱无罪。第二人亦如是。若比丘乞食家。家得一升二升。乃至一斛取无罪。若一家或得四升米饭。或糗八升。或麦饭一升二升。若鱼肉半钵一钵更不得余处求。是中何者犯。何者不犯。一切粥除鱼肉粥。粥者取新出釜。画不成字。一切饼一切糗一切果。非别众食。非处处食非满足食。是故说

佛住舍卫城。广说如上。是中应说末利夫人因缘。如中阿含中说。乃至长老比丘。次第入宫教诫。尔时尊者优陀夷。次入教诫。时末利夫人着细涂施衣。金银珠玑庄校衣上在宫内坐。时优陀夷入宫。夫人见已。敬心卒起。金银珠玑重涂施衣滑坠地。夫人惭愧。即便蹲住。诸侍人以身障之。时优陀夷见已却行而出。还到精舍。语诸比丘言。长老。波斯匿王覆藏宝器。我今已见诸比丘。问言。汝见何等。答言。见末利夫人。诸比丘言。长老汝出家人若入聚落当作阿练若意。莫恋着色。见如不见闻如不闻。答言我实见可言不见耶。诸比丘以是因缘。往白世尊。佛言。从今日后不听比丘入王宫。诸比丘不入宫故。诸夫人语末利夫人坐。汝使诸比丘不复来入。我等不得闻法礼僧末利夫人言。何故怨我汝自求王。诸夫人即白王言。大王诸比丘何故不复入宫教诫。时波斯匿王闻此语已往诣佛所。稽首礼足。却坐一面。白佛言。世尊。诸比丘何故不复入宫教诫。佛言。大王是中有过如来见已不听复入。波斯匿王白佛言。是中有何过患。可得闻不。佛告大王。有十事过患。比丘不得入王宫十事者。如中阿含綖经中说。比丘不得入王宫。王白佛言。世尊。佛见过患制比丘不得入王宫。我本未生信时自身右手犹尚不信。况复比丘佛已制戒。但当随顺。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。为诸比丘制戒。乃至已闻者当重闻。若比丘入刹利灌顶王宫王夫人。宝未藏入过门限者。波夜提。比丘者。如上说。王者。刹利种婆罗门种。优伽罗王种。舍伽耶王种。婆那王种如是等比或是王非刹利入者无罪。是王是刹利非灌顶入无罪。是王是刹利。是灌顶无国土入无罪。是王是刹利是灌顶有国土不得入。入宫者入内宫。王夫人未藏宝者王夫人未出宝未藏者。王宝未出至过门限者。波夜提。波夜提者。如上说若王新作宫殿信心欢喜。语比丘言。尊者为我故愿先受用。比丘应语。世尊制戒不得入宫。王复言。尊者颇有方便。得开通不。应答言。王夫人宝尽出。然后得入。若已出者应入。比丘入已。王夫人宝物从后。次第入比丘不得舍出。尔时坐无罪。若比丘中间为大小行出不得复入。入者波夜提。若王常游观池林。于中作王行宫。王夫人宝物尽出。在中有七重门。若入一门二三乃至六门无罪。第七门一脚入。越毗尼罪。两脚过门限者。波夜提。若王游观已夫人宝物尽出行宫已空。众人入者。比丘入无罪。若王信心爱敬手牵比丘入无罪。是故说

佛住舍卫城。广说如上。舍卫城内有作象牙师。字法与。时有比丘到其家语。檀越为我作针筒。即便为作不大不小光色滑泽。持来还房。诸比丘见已问言。长老。何处得是不大不小光色滑泽。答言。象牙师字法与。为我作之。诸比丘闻已。各各往索牙师念曰。诸比丘皆当须用又念众僧是良福田。我当请僧布施。针筒即诣祇洹头面礼僧足已。白言。我法与请僧欲施针筒。诸比丘闻已。各各往取。或取一去。或取二三。乃至取十象牙遂尽。檀越言。牙已尽。今唯有骨。须者当作。答言。皆须骨尽。复白骨亦尽。今唯有角。须者当作。答言。皆须索者众多无以供命。尔时尊者舍利弗。时至着入聚落衣持钵入舍卫城乞食。次至其家。时法与妇信心欢喜。持食出施。先识舍利弗。即头面礼足在前而立。舍利弗问言。姊妹。家内何似事业增不。答言。家内粗可但事业不增。问言。何故。答言。尊者我家夫主请诸比丘。施与针筒。诸比丘或取一去。或取二三。乃至取十牙尽。取骨骨尽取角。索者众多无以供命。尊者。我家仰是生活衣食儿子供官赋调。尊者是我敬重作是言耳。以是故。夫主在言不在觉而言眠。尔时尊者舍利弗为是女人随顺说法发欢喜已。来还精舍。以是因缘具白世尊。佛言。呼诸比丘来。来已佛具问上事。汝实尔不。答言实尔。佛言。从今日后不听象牙骨角作针筒。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。为诸比丘制戒。乃至已闻者当重闻。若比丘牙骨角作针筒破已波夜提。比丘者。如上说。牙者。象牙鱼牙摩伽罗牙猪牙。如是诸余牙等。骨者。象骨马骨牛骨驼骨龙骨。如是诸余骨等。角者。牛角水牛角犀角鹿角羊角。如是诸角等。作者。若自作若使人作破已。波夜提。悔过不破悔过者。越毗尼罪。波夜提者。如上说。尔时世尊。制戒不听牙骨角作针筒。时诸比丘。便持金银琉璃颇梨玉宝作之。佛言不听金银宝等作针筒。应用铜铁白镴。铅锡鋀石。白铜竹木。钦婆罗[疊*毛]旃鸟翮。乃至钵囊带。是故说

佛住舍卫城。广说如上。尔时斋日月八日十四日十五日。城内人民出城礼拜世尊。时波斯匿王子亦来礼拜。次第至难陀优波难陀所。头面礼足已白言。我欲观看。愿示我处。答言甚善。即将至阁上。语言童子。看是柱梁榱栋栌枓枅衡。雕文刻镂种种彩画。次至难陀住处。见青色地敷高大床。施置重蹬敷拘执褥。两头施枕见已。即问尊者。是谁床褥。答言。我许。王子言。此大严丽非比丘所宜。即复问言。若非我所宜。谁应畜者。答言。若王王子所应服饰。比丘言。我非王子耶。若世尊不出家者。应作转轮圣王。君四天下。汝等一切是我人民。然世尊不乐是处。出家成佛作法轮王。我是法轮王子。设复服饰。过此犹尚是宜。况此粗物。王子闻已。惭愧无言。诸比丘以是因缘。往白世尊。佛言。呼难陀优波难陀来。来已佛具问上事。汝实尔不。答言实尔。佛言。汝等云何严饰床褥。为世人所讥。从今日后不听过量作床。复次佛住舍卫城。广说如上。世尊制戒不听过量作床。诸比丘如量截已。即以断头还榰床脚。尔时斋日月八日十四日十五日。城内人民出礼拜世尊。波斯匿王子亦来礼拜。次至难陀优波难陀所。语曰。尊者。示我观看处。乃至到难陀房中。见已即问。何故截此床脚。答言。齐截已上世尊所听。王子言。若世尊听齐截已上。而今还以榰床与本何异。诸比丘以是因缘。往白世尊。佛言。从今日后床脚应量不听复榰。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。为诸比丘制戒。乃至已闻者当重闻。若比丘作床脚。应量作高。修伽陀。八指除入梐。若过量作截已。波夜提。比丘者。如上说。卧床坐床各十四种。如上说。是中过量者犯。作者。若自作若使人作。修伽陀者。如来应供正遍知。八指者。佛八指。过者。过量。入梐者齐孔已下截已。波夜提。悔过不截悔者。越毗尼罪。波夜提者。如上说。若自作终日坐上。一波夜提。若起已还坐随坐一一波夜提。他床而坐上者。越毗尼罪。榰脚床亦应量当使坚牢。若客比丘来次第付床褥。得过量床。应语知事者言。借我锯来问作何等。答言。此床过量欲截令如法。若知事者。言莫截檀越。见者或能不喜。若不久住者。凿地埋脚齐量止。若久住者应齐埋处。木筒盛脚勿使烂坏。若比丘入聚落。至檀越家坐。若床脚高者不得悬脚坐。若是知旧应索承足机。若非知旧应索塼木承足而坐。若福德舍中床高坐者无罪。是故说

佛住舍卫城。广说如上。尔时斋日月八日十四日十五日。城内人民出礼觐世尊。波斯匿王子亦出礼拜。次至难陀优波难陀所。语言。比丘。示我观看处。答言甚善。即将至阁上。示言。王子。看是柱梁榱栋栌欂枅衡。雕文刻镂种种彩画次至已房。见青色地敷好坐床。敷兜罗纻褥。两头安枕。以白[疊*毛]覆上。见已即问。是谁所有。答言。我许。王子言。此大严丽非尊者所宜。答言。若非我所宜。谁复应畜。王子答言。王王子大臣所应服饰。复言。我非王子耶。世尊。若不出家。应作转轮圣王。王四天下。汝等一切是我人民。然世尊不乐是处。出家成佛作法轮王。我是法轮王子。服饰设复过此犹尚是宜。况此粗物。王子闻已。惭愧无言。诸比丘以是因缘。往白世尊。佛言。呼难陀优波难陀来。来已佛具问上事。汝实尔不。答言实尔。佛言。汝云何以兜罗绵纻褥。为世人所讥。从今日后不听兜罗绵纻褥。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。为诸比丘制戒。乃至已闻者当重闻。若比丘兜罗绵纻褥。若坐若卧。挽出已。波夜提。比丘者。如上说。兜罗者。阿伽兜罗。婆迦兜罗。鸠吒阇兜罗。角兜罗。草兜罗。迦尸兜罗。华兜罗。诸余兜罗等。是名兜罗。是中兜罗纻褥挽出已。波夜提。悔过挽出时抖擞令尽。若不尽者。以水沾手摩治令净。然后波夜提。波夜提者。如上说。若自作终日坐。一波夜提。起已还坐随坐。一一波夜提。他许坐者。越毗尼罪。若纻枕枕头榰足。越毗尼罪。若病枕头榰足无罪。若以兜罗纻皮枕。得二越毗尼罪。皮及兜罗。若比丘入聚落兜罗风吹着比丘衣。合衣坐者。越毗尼罪。应拂去而坐。若车载兜罗若担若负风吹着比丘衣。合衣坐者。越毗尼罪。应拂去而坐。若敷草兜罗比丘不得坐。若比丘角兜罗田中行着衣不得坐。应拂去。若草兜罗华兜罗田中行着衣不得坐。应拂去。若敷草华兜罗坐上。越毗尼罪。敛草华兜罗坐。越毗尼罪。作田中亦越毗尼罪。若为律师法师敷师子座。散华。着上不。得坐拂去而坐。无罪是故说

佛住舍卫城。广说如上。有五事饶益故。如来应供正遍知。五日一行诸比丘房。见诸比丘床褥卧具。垢腻不净处处沾污。如曼陀罗着日中曝晒。佛问诸比丘。是谁床褥卧具垢秽不净。答言。是诸比丘卧具不以物覆。是故污耳。佛言。从今日后听作尼师坛。复次佛听作尼师坛已。诸比丘合缕作五事饶益故。如来应供正遍知。五日一行诸房舍。见合缕[疊*毛]垢腻不净处处沾污。如曼陀罗着日中曝晒。佛知而故问。是谁合缕作尼师坛垢腻不净。答言。世尊听作尼师坛。诸比丘合缕作。佛告诸比丘。汝等云何合缕作尼师坛。从今日后当应量作长二修伽陀搩手广一搩手半

复次佛住舍卫城。广说如上。尔时众多比丘在讲堂上论议作是言。长老。世尊制尼师坛。大小若敷坐处。两膝则无。若敷两膝坐处复无。诸比丘。以是因缘往白世尊。佛问比丘。僧中上座是谁。答言。舍利弗。佛语舍利弗。众多梵行人作是论。汝云何默然而听。今当罚汝在日中立。舍利弗受罚。即立日中。时诸比丘各前悔过。白言。世尊尊者舍利弗身体软弱。愿恕其愆。勿令不乐。佛语诸比丘。非为不乐彼身风冷病得日乃适然。日月星宿在虚空中。尚可回转。舍利弗以受如来罚心不可回转。诸比丘白佛言。世尊。云何尊者舍利弗心不可回转。佛言。不但今日心不可回转。过去世时以曾如是。如蛇本生经中广说。尔时蛇者即舍利弗是。彼时心坚不可回转

复次佛住舍卫城。广说如上。五事饶益故。如来应供正遍知五日一行诸比丘房。见僧褥卧具中央鲜好。两边垢污。佛知而故问。比丘是何等卧具。中央鲜好两边垢污。答言。世尊制尼师坛。小不得尽覆故。齐覆处净不覆处污。佛言。从今日后听两重作。不得辄尔厌课。持小故[疊*毛]覆当两重作。若用钦婆罗一重作。劫具二重作。复次佛住舍卫城。广说如上。尔时尊者阿那律持尼师坛。着肩上礼世尊足。佛知而故问。汝肩上是何等。答言。小尼师坛。世尊。是尼师坛太小唯愿更益。佛言。更益几许乃足。答言。一搩手。佛言。听益一搩手。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘作尼师坛。应量作长二修伽陀搩手广一搩手半。更益一搩手。若过作截已。波夜提。比丘者。如上说。作者。若自作。若使人作。尼师坛者。世尊所听。应量者长二修伽陀搩手广一搩手半。长者纵。广者横。修伽陀者。如来应供正遍知。搩手者。如来搩手长二尺四寸。益一搩手者。二重三重。对头却刺。若过量者。截已波夜提。悔过不截而悔。越毗尼罪。波夜提者。如上说。长应量广过量。若自作若使人作。作成波夜提。受用越毗尼罪。广应量长过量。中央应量边过量。边应量中央过量若自作若使人作。作成波夜提。受用越毗尼罪。[疊*毛]量缩量水洒量欲令干已长大。若作成波夜提。受用越毗尼罪。作时当应量作。不得过量。尼师坛是随坐衣不得作三衣。不得净施。及取薪草盛巨磨。唯得敷坐。若道路行得长[疊*毛]着衣囊上肩上担。是故说

佛住舍卫城。广说如上。世尊五事饶益故。五日一行诸比丘房。见脓血疮痂着衣在日中晒。佛知而故问。是何等衣不净。若此答言。世尊。诸比丘病疥疮是故污衣。佛言。从今日后听作覆疮衣。复次佛住舍卫城。广说如上。尔时世尊听作覆疮衣已。诸比丘不截缕合缕作。世尊以五事饶益故。五日一行诸比丘房。见合缕作覆疮衣脓血垢污日中晒。佛知而故问。是何等衣。合缕作不净若此。答言。世尊。听作覆疮衣。诸比丘合缕作脓血垢污。佛语诸比丘。汝云何合缕作覆疮衣。从今日后应量作覆疮衣。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘作覆疮衣。应量作长四修伽陀搩手广两搩手半。若过作截已。波夜提。比丘者。如上说。覆疮衣者。世尊所听。应量长广修伽陀。搩手者。如上说。若过量者截已。波夜提。悔过不截而悔。越毗尼罪。波夜提者。如上说。长应量广过量。广应量长过量。中央应量边过量。边应量中央过量。若自作若使人作。作成波夜提。受用者越毗尼罪。屈量缩量水洒量。欲令干已长大。作成波夜提。受用越毗尼罪。当作应量是覆疮衣。随身衣不得作三衣。不得净施。不得取薪草盛巨磨。欲入聚落时。当先著然后着僧伽梨。施纽出聚落已。脱僧伽梨抖擞襞[疊*毛]举着。常处覆疮衣。勿令燥脱剥疮血出。当合著入水不得入。僧常所浴处。当在屏处。浸渍令液。然后脱之浣濯令净。浴已得持拭身后。日用时亦复如是。乃至疮差。差已得作三衣及净施除用。是故说

佛住舍卫城。广说如上。如三十事中毗舍佉鹿母广说。乃至十二由延内。布施比丘雨浴衣。复次佛住舍卫城。广说如上。尔时世尊听比丘作雨浴衣。时诸比丘不截缕合缕作。世尊以五事利故。五日一行诸比丘房。见合缕[疊*毛]垢污不净日中晒。佛知而故问。是何等衣。合缕作不净如此。答言。世尊。如来听作雨浴衣。诸比丘合缕作垢污不净。佛语诸比丘。汝等云何合缕作雨浴衣。从今日后应量作长六修伽陀搩手广二搩手半。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。为诸比丘制戒。乃至已闻者当重闻。若比丘作雨浴衣。应量作长六修伽陀搩手广二搩手半。若过量截已。波夜提。比丘者。如上说。雨浴衣者。世尊所听。应量者。长六修伽陀搩手广二搩手半。长广修伽陀。搩手者。如上说。若过量者。截已。波夜提。悔过不截悔者。越毗尼罪。波夜提者。如上说。长应量广过量。广应量长过量。中应量边过量。边应量中过量。若自作若使人作。作成波夜提。受用越毗尼罪。屈量缩量水洒量。欲令干已长大。若自作若使人作。作成波夜提。受用越毗尼罪。比丘五法成就。僧应拜作分雨浴衣。何等五。不随爱不随嗔不随怖不随痴知得不得。羯磨者。应作是说。大德僧听。某甲比丘五法成就。若僧时到僧拜某甲比丘分雨浴衣。白如是

大德僧听。某甲比丘五法成就。僧今拜某甲比丘分雨浴衣。诸大德忍某甲比丘分雨浴衣。忍者僧默然。若不忍者便说。僧已忍拜某甲比丘分雨浴衣竟。僧忍默然故。是事如是持作羯磨已。应众僧中唱言诸大德。是中分物参差不同。相降四指八指理不得计。若不唱者。得越毗尼罪。从四月一日得雨浴衣。从上座次第付得已。不听裸浴。又不得着雨浴衣。应着余故衣。若在屏处。若深水裸浴无罪。不得着雨浴衣作。众僧治堂舍作。及白灰作泥作。覆屋作。通水沟抒井作。当着余故衣。是雨浴衣不得作。三衣不得净施。不得余用持取薪草及盛巨磨。不得着入池水汪水中浴。大雨时得着。小小雨不得着。若大雨卒止垢腻未净。得着入池水。汪水中浴。若比丘病服药吐下刺头出血。及露地食时。得持作幔障。此雨浴衣四月半受用。至八月十五日。应僧中唱言。诸大德。今日僧舍雨浴衣。如是三唱舍已得受持作三衣。若净施得作余用。是故说

佛住王舍城。广说如上。尔时诸比丘着留缕衣。诸外道亦着留缕衣。时优婆塞欲礼比丘。误礼外道。闻咒愿异知非比丘。即便惭愧。时外道弟子欲礼外道。误礼比丘。如是参错。诸比丘以是因缘。往白世尊。佛言。从今已后。比丘衣应截缕作净染作净。外道欲与比丘作异故。留朱罗赤石染衣。捉三奇杖持军持。复次佛住舍卫城。旷野比丘得拘舍耶衣。欲染煮染汁。如上三种染衣色中说

复次佛住舍卫城毗舍离。比丘得钦婆罗。亦如上说。复次佛住舍卫城时。尊者孙陀罗难陀。是佛姨母子。有三十相。食后从舍卫城出。阿难随后。亦如上三色衣中说。复次佛住舍卫城。尔时尊者阿罗军荼。效佛衣量作衣。着入舍卫城。是比丘身短衣长曳地而行。为世人所讥。沙门释子曳衣而行。又人呵言。汝不知耶。瞿昙沙门衣非己父母作。败复更得。是故如是。诸比丘以是因缘。往白世尊。佛言。呼阿罗军荼来。来已佛具问上事。汝实尔不。答言实尔。佛言。从今日后。当随自身量作衣。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒乃至已闻者当重闻。若比丘效如来衣量作衣。若过量截已。波夜提。如来衣量长九修伽陀搩手广六搩手。是名如来衣量。比丘者。如上说。如来衣量者。长九修伽陀。搩手广六修伽陀搩手。长者纵。广者横。修伽陀者。如来应供正遍知。搩手者。如来搩手长二尺四寸。若过者截已。波夜提。悔过不截悔者。越毗尼罪。波夜提者。如上说。长应量广过量。若自作若使人作。作成波夜提。受用越毗尼罪。广应量长过量。中应量边过量。边应量中过量。若屈量缩量水洒量。欲令干已长大。若自作若使人作。作成已波夜提。受用越毗尼罪。作时当减量。不得过量。当随自身量。僧伽梨有三种上中下。上者长五肘广三肘。中者长五肘。一不舒手广三肘。一不舒手。下者长四肘半广三肘。一不舒手着衣时。缘相降二指作。郁多罗僧有三种上中下。上者长五肘广三肘。中者长五肘一不舒手。广三肘一不舒手。下者长四肘半广三肘一不舒手。作安陀会亦有三种上中下。上者长五肘广三肘。中者长五肘一不舒手。广三肘一不舒手。下者长四肘半广三肘一不舒手。下至覆三曼陀罗作泥洹僧。是故说

摩诃僧祇律卷第二十摩诃僧祇律卷第二十一

        东晋天竺三藏佛陀跋陀罗共法显译

    明单提九十二事法之十

佛住舍卫城。广说如上。尔时尊者陀骠摩罗子。僧拜典知九事如上说。乃至陀骠摩罗子。右手小指放光作明。随次付房阿练若。阿练若共乞食。乞食共粪扫衣。粪扫衣共一坐食。一坐食共常坐。常坐共露坐。露坐共草蓐。草蓐共经呗。经呗共法师。法师共学律学。律共阿罗汉。阿罗汉共三明。三明共六通。六通共无威仪。无威仪共。尔时六群比丘语陀骠言长老。与我等六人共一处住。答言。待汝伴中最下坐。次得房随意共住。时是伴下坐。次得弊房卧床坐床褥枕诸物。皆悉弊故。又别房食。亦复粗恶。自相谓言。长老陀骠如我生怨与我弊房粗食。是长老。若久住梵行者。方令我等得大苦恼。然世尊制戒不得无根波罗夷法谤。今当以僧伽婆尸沙法谤。即往到其所。作是言。长老。汝犯僧伽婆尸沙罪。答言。我无是罪。彼言。谁复作贼。言我是贼。但汝犯僧伽婆尸沙罪。即屏处谤。众多人中谤。僧中谤陀骠比丘犯僧伽婆尸沙罪。时陀骠比丘以是因缘。往白世尊。佛言。汝有是事不。答言无也。佛言。汝无此罪。世尊知汝清净。陀骠言。世尊。虽知我无罪。唯愿世尊。当语彼人令生信心。莫令长夜诽谤得不饶益。佛言。呼六群比丘来。来已佛具问上事。汝实尔不。答言实尔。佛语六群比丘。此是恶事。汝常不闻我无量方便。说于梵行人应起恭敬。身行慈口行慈意行慈。汝今云何以无根僧伽婆尸沙法谤。此非法非律非如佛教。不可以是长养善法。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘嗔恨不喜。以无根僧伽婆尸沙法谤他比丘。波夜提。比丘者。如上说。嗔者。九恼事及非处起嗔。第十恨者。凡夫及学人有不喜者。乃至阿罗汉有无根者。事原不现。又不见彼事。不闻彼事。不疑彼事。僧伽婆尸沙者。十三事中若一一谤。波夜提。波夜提者。如上说。若比丘嗔恨有二相似清净不清净。清净者。言汝见我犯何罪十三事中若一若二。彼不见不闻不疑不决了。若屏处若众多。若僧中作是言。我见汝犯僧伽婆尸沙。我闻汝犯僧伽婆尸沙。我疑汝犯僧伽婆尸沙。闻不实闻根不实。疑不实疑根不实。本曾见忘闻忘疑忘。见不尔。闻不尔。疑不尔。对面四目谤语语波夜提。清净不清净想。谤偷兰遮欲驱出。波夜提。不清净清净想谤。越比尼罪。欲驱出。偷兰遮。清净清净想谤偷兰遮。欲驱出。波夜提。不清净不清净想毁呰。波夜提。谤比丘。波夜提。谤比丘尼。偷兰遮。谤式叉摩尼沙弥沙弥尼。越比尼罪。谤俗人。越比尼心悔。是故说

佛住舍卫城。广说如上。时有比丘乞食时到。着衣持钵。入城次行乞食到一家。妇人言。尊者我至某日当饭僧并施衣。比丘答言。善哉优婆夷。当及时为于身命财修三坚法。常修习行勿令留难。乞食比丘还精舍已。语诸比丘。长老。我语汝善事。问何等善事。答言。某甲家到彼日当饭僧并施衣。时难陀优波难陀去不远。闻语声即问。彼家在何处姓字何等门户那向具问知已。明日晨朝往到其家。谓优婆夷。我闻好声。尊者闻何等声闻。汝欲饭僧施衣为实尔不。答言。始有是心。但恐中间有留难。知当果不。优波难陀语优婆夷曰。汝可持是衣施与。难陀答言。我家更无余物。正有是衣。本欲施僧。今不可回转。优婆难陀即毁呰言。何等是僧。老乌亦僧。老鸱亦僧。僧如穿臼漏槽不可满足。僧于汝有何利益。能为汝活男活女。能至王家断理官事那。难陀能为汝作多利益事。但持是衣施与难陀。优婆夷答辞如初。时难陀复劝与优波难陀。如上说。优婆夷犹言。我家更无余物。适欲回施尊者。然先以许僧不可回转。优波难陀言。与以不与任汝意。作是语已。即便舍去。时优婆夷作是念。此衣适欲与难陀。然僧是良福田。适欲施僧。然难陀有大力势。恐与我作不饶益事。思惟是已。遂不复施。诸比丘闻已。以是因缘。往白世尊。佛言。呼优波难陀来。来已佛具问上事。汝实尔不。答言实尔。佛言。痴人。作此三恶事施者失福。受者失利。轻毁众僧。佛语优婆难陀。汝常不闻。我以无量方便。赞叹少欲毁呰多欲耶。此非法非律非如佛教。不可以是长养善法。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘知物向僧回向余人。波夜提。比丘者。如上说。知者。若自知若从他闻。物者。八种乃至净不净。向者。物分处已定。僧者。八种如上说回者。转与余人。波夜提。波夜提者。如上说。若人持物来问比丘言。尊者。我欲以此物施。当施何处。应语随汝心乐处。便可与之。若复问何处。得大果报。应语施僧得大果报。复问。何处僧持戒。我欲施之。应语无有犯戒僧。若复问。何处比丘精勤修业。能爱护物恒住于此。使我常见得。语某甲比丘精勤修业。能爱护物。常住于此。施彼比丘。恒可得见。若言我欲。持此物施与。尊者应语施僧。若言我已施僧意欲施。尊者。愿为受之。取无罪。若比丘知物向僧回向已者。尼萨耆波夜提。回向余人者。波夜提。若比丘知向僧物回向余僧。越比尼罪。众多人物回向众多人。越比尼罪。乃至畜生回与彼畜生。越比尼罪。心悔是故说。佛住舍卫城。广说如上。尔时六群比丘半月说波罗提木叉时。说四事时默然。说十三事时嗔。三十事时语。九十二波夜提时便起。作是言。长老。此是世尊说耶。世尊在何处说。若我久在世者。如是事比所闻转多。此便是法母更生禁戒遂滋。诸比丘闻是语惭愧。以是因缘。往白世尊。佛言。呼六群比丘来。来已佛具问上事。汝实尔不。答言实尔佛语六群比丘。此是恶事如来欲饶益故。为诸弟子制戒。半月说波罗提木叉。汝云何嫌遮此非法非律非如佛教。不可以是长养善法。佛告诸比丘依止舍卫城住者。皆悉令集以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘半月说波罗提木叉时。作是言。我今始知是法。入修多罗。半月波罗提木叉中说。诸比丘知彼比丘本。若二若三说波罗提木叉中坐。况复多彼比丘不以不知故。得脱随所犯罪。如法治应呵言。长老汝失善利。半月说波罗提木叉时。汝不尊重不一心念。不摄耳听法呵已。波夜提。比丘者。如上说。半月者。若十四日十五日。波罗提木叉者。十二修多罗。说者。谓作是语。我今始知是法半月波罗提木叉中摄。是比丘知彼若二若三。说波罗提木叉中坐。况复多彼比丘不以不知故无罪。随所犯罪。如法如比尼治。应呵言。长老。汝失善利。半月说波罗提木叉时。汝不尊重。不一心念。不摄耳听法呵已。波夜提悔过。波夜提者。如上说。受具足已。应诵二部比尼。若不能诵二部。当诵一部。若不能诵一部。当广诵五众戒。若不能者当广诵四众戒。若复不能者当广诵三众戒。若复不能者当广诵二众戒。若复不能者当广诵一众戒及偈。若布萨时广说五众戒。若复不能者当广诵四众戒。若复不能者当广诵三众戒。若复不能者当广诵二众戒。若复不能者当广诵一众戒及偈。余者僧常闻不诵者。越比尼罪。僧中应使诵利者说。余人专心听。佛言。诵波罗提木叉时。余比丘不得坐禅及作余业。皆应专心共听。若四事听十三事不听。越比尼罪。十三事听。二不定法不听。越比尼罪。二不定听。三十事不听。越比尼罪。三十事听。九十二事不听。越比尼罪。九十二事听。四波罗提提舍尼不听越比尼罪。四波罗提提舍尼听。众学不听。越比尼罪。众学听。七灭诤不听。越比尼罪。若中间随不听。随得越比尼罪。一切不听。波夜提。此罪不得趣向人悔过。当于众中持戒有威德人所敬难者。于前悔前人应呵言。长老。汝失善利半月说波罗提木叉时。汝不尊重。不一心念。不摄耳听法呵已。波夜提悔过。是故说

  食家入王宫　　针筒床二褥
  坐具覆疮衣　　雨衣如来衣
  无根谤第十　　回向遮布萨

第九跋渠竟

    四提舍尼初

佛住迦维罗卫释氏精舍。广说如上。尔时诸比丘在阿练若处时。诸释种父母姊妹亲里家。遣使赍饮食送与比丘所。赍食人于道中食半。或食三分中一分。或都食尽。是诸比丘有归家看者。亲里问言。我先送种种饮食。为悉达不。其中到者言到。半到者言半到。三分中一分到者。言一分到。不到者言不到。亲里闻已。即嗔恚言。弊恶死人。使汝送食。何敢取食即便鞭。打此使人得苦痛。大啼唤言。坐是沙门令我得打。诸比丘以是因缘。往白世尊。佛言。呼是诸比丘来。来已佛具问上事。汝实尔不。答言实尔。佛语诸比丘。汝云何阿练若处住。先不语外。外不受内。自手取而食。从今日后不听阿练若处住。先不语外。外不受内。自手取

复次佛住迦维罗卫释氏精舍。广说如上。如来应供正遍知五事利益故。五日一行诸比丘房。见比丘羸病颜色萎黄知而故问。比丘气力足不。答言。病苦。世尊。佛问比丘。汝不能服随病药随病食耶。白言。世尊。制戒不。听阿练若处住。先不语外。外不受内。自手取。世尊。我病不能出外。是故羸瘦病苦。佛言从今日听病比丘内取。佛告诸比丘。依止迦维罗卫住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘阿练若处住。先不语不病比丘外不受内。自手取。若啖若食。是比丘应余比丘边悔过。如是言。长老。我堕可呵法。此法悔过初波罗提提舍尼法。比丘者。如上说。阿练若处者。如上说。先不语者。语有二种分数不分数。分数者。先语当送尔许尔许种饮食。不分数者。直言当送食不列种数。外不受者。不精舍外。受内者。精舍内。病者。下病冷病风病。如是比病不堪出外取食。是故世尊说无罪。自手受者。手从手受器。从器受。啖者。饼果等。食者五正食。若啖若食。是比丘应向余比丘悔过言。长老。我堕可呵法。此法悔过前人应问。汝见罪不。答言见。应语慎莫更作。答言。顶戴持。波罗提提舍尼者。是罪向人发露不覆藏。若为是比丘送食。语余比丘。余比丘受无罪。若为是比丘送食。语是比丘。余比丘受无罪。若为是比丘送食。语是比丘。是比丘受无罪。若为余比丘送食。语余比丘。余比丘受无罪。若送食先语有分数无分数。有分数者。比丘得在内。当忆种数相应者取不相应者。语令还。若有疏来者。看疏相应取不相应遣还。若印封来者看封印。完者取不完者遣还。若先语无分数来者。当出精舍门外受。若卒来入门者不得受。若有净人应语与净人。若无净人语令放地待净人来。应语净人持此食出外。出外已比丘应受。若比丘病不能出外内受无罪。若比丘亲里持饮食到园。若池林中游观处持食。与比丘者随意受无罪。若比丘道行时。作是念。至某精舍当食。过余处食者。应悔过。若至某精舍。值彼僧受请随去无罪。是故说

佛住毗舍离。广说如上。尸利摩比丘尼因缘。应广说。乃至佛语诸比丘。我声闻尼中福德第一尸利摩比丘尼。是时世饥俭乞食难得尔时尸利摩比丘尼时到着入聚落衣。持钵入毗舍离城。次行乞食。见比丘即问言。尊者。得食不。比丘即以空钵示之比丘尼见已。作是念。是我所尊而乞食不得。便持己钵中食。与比丘。比丘得食还到精舍。唤余比丘共食。诸比丘问言。长老。何处得是好食。答言尸利摩比丘尼边得。诸比丘闻已。各各往索。如是次第。乃至五百比丘尽皆得食。然后自求日时已过。失食还到精舍明日晨朝诸比丘复着衣持钵。至比丘尼精舍门立。比丘尼见已。即入语尸利摩言。诸比丘今在门外相待尸利摩闻已。语弟子言。取衣钵来。我为诸上尊乞食。如是次第供给五百人已。然后自求日时。复过失食而还。至第三日亦复如是。乃至次第供给五百人。唯一人未得。此比丘随尸利摩后。入一家。以先三日失食故。身体虚羸迷闷倒地。时诸妇人见已惊起欲扶。比丘尼言。住住。待我思惟。何故倒地即便忆念。为诸上尊乞食自失食。故闷极倒地起已自拂拭尘土正衣服已作是思惟。

能布施者有无上利。忆念布施生欢喜心。因欢喜故得清净三昧。以三昧观见五阴生灭。布施庄严心调伏诸根。即入金刚三昧。尽一切漏。于佛法中三明作证。尸利摩比丘尼得证已。尔时妇人将入洗浴已敷床令坐。然后与食。彼比丘故在门外立。妇人见已。恐复索食故。当户而立。比丘尼见遮户立心生疑。何故遮户倾头看见比丘衣角言。是我上尊乞食不得。即语言。尊者。可入取食。妇人言。阿尼且食。我当更求与之比丘尼言。今世饥俭何处更得复持食与妇人。嫌言沙门释子无有慈心云何三日失食饥极垂命。而复从索食。诸比丘以是因缘往白世尊佛言。呼是诸比丘来。来已佛具问上事。汝实尔不。答言实尔。佛言。从今日后不听白衣家内非亲里比丘尼边自手取食。复次佛住毗舍离。广说如上。尔时尊者阿利吒身有疮痍为人恶贱。人不与食。每行乞食时。若未入门闭门不前若已入门驱出不与。如来应供正遍知五事利益故。五日一行诸比丘房。见阿利吒身有疮痍。佛知而故问。比丘汝身力调和不。答言。世尊。但患饥苦。佛问比丘汝不能乞食耶。答言。世尊。我能乞食。但身体疮痍人所恶贱每行乞食。若未入门闭门不前。若得入门驱出不与。佛言。汝不能往尸利摩比丘尼边乞食耶。答言。世尊。制戒白衣家内非亲里比丘尼边。不得自手受食。彼非我亲里。是故不往。佛言。从今日后听病比丘往。佛告诸比丘。依止毗舍离住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘不病白衣家内非亲里比丘尼边自手受食。若啖若食。是比丘应余比丘边悔过言。长老。我堕可呵法。此法悔过。是名波罗提提舍尼法。比丘者。如上说。非亲里者非父亲非母亲。病者。世尊说无罪。不谓小小病谓疥黄烂疮痍痈痤人所恶贱。是名为病。白衣家内者。俗人家内。比丘尼者。二部众中受具足。自手受者。手从手受器从器受。啖者。饼果等。食者。五正食。是比丘应向余比丘悔过长老我堕可呵法此法悔过前人应问。汝见罪不。答言见。应语慎莫更作。答言顶戴持。波罗提提舍尼者。如上说。若比丘不病在俗人家内非亲里比丘尼边。自手受食受时。越比尼罪。食时犯悔过法。非亲里非亲里想受食者。犯悔过。非亲里疑想受食者。犯悔过。非亲里亲里想受食者。越比尼罪。亲里非亲里想受食者。越比尼罪亲里疑想受食者。越比尼罪。亲里亲里想无罪为余人受者。越比尼罪。病人无罪为病人受无罪。食病人残无罪。若式叉摩尼沙弥尼持食来语。令放地。然后余人边受无罪。比丘尼自持来放地已作是言。尊者为我故受。受者无罪。比丘尼住处受无罪。是故说

佛住王舍城迦兰陀竹园精舍。广说如上。尔时偷兰难陀比丘尼知识家请僧食。偷兰难陀比丘尼。六群比丘前立。指示语檀越言。与是比丘饭。与是比丘羹。与是比丘鱼肉。檀越闻已。偏益六群比丘。诸比丘嫌言。云何六群比丘。受比丘尼偏教益食而不呵。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。来已佛问上事。汝实尔不。答言。实尔佛言。汝云何受比丘尼偏教益食而不呵。佛告诸比丘。依止王舍城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。若比丘白衣家内请食。比丘尼立指示言。与是饭与是羹鱼肉。诸比丘应语是比丘尼言姊妹小住待诸比丘食竟。若诸比丘中乃至无一比丘语是比丘尼言。姊妹。小住待诸比丘食竟者。是诸比丘应向余比丘边悔过。如是言。长老。我堕可呵法。此法悔过。是名波罗提提舍尼法。比丘者。如上说。白衣家者。俗人家。请者。若今日若明日。食者。五正食五杂正食。比丘尼者。二部众中受具足。与者。益是饭与是羹与是鱼肉。应语比丘尼者。齐见闻知应教作是言。姊妹。小住待诸比丘食竟。若止者善。若不止者第二第三语。若不语受者。越比尼罪。食者。犯悔过法。是比丘应向余比丘边悔过如是言。长老。我堕可呵法。此法悔过。前人应问。汝见是罪不。答言见。应语慎莫更作。答言。顶戴持。波罗提提舍尼者。如上说。不满三呵而食者。越比尼罪。满三呵不止食者无罪。一人呵已一切食无罪。不见不闻者食者无罪。尼自作檀越无罪。若檀越未曾请僧不知仪法。尔时比丘尼得教安置形像教益食法。然后应坐。若不请。若非五正食教无罪。是故说

佛住舍卫城。广说如上。大臣毗阇因缘此中应广说。乃至仙弥尼刹利。佛告诸比丘。大臣毗阇布施太过。钱财竭尽。僧应为作学家羯磨。羯磨法者。应作是说。大德僧听。大臣毗阇布施太过。钱财竭尽。若僧时到。僧为大臣毗阇作学家羯磨。白如是。大德僧听。大臣毗阇布施太过。钱财竭尽。僧今为大臣毗阇。作学家羯磨。诸大德忍与大臣毗阇作学家羯磨者默然。若不忍者便说。是第一羯磨。第二第三亦如是。僧已与大臣毗阇。作学家羯磨竟。僧忍默然故。是事如是持。大臣毗阇乃至仙弥尼刹利还。疲极身蒙尘土。先问家中。诸阿阇梨颇数来不。答言来。但有所施。时一切不受。毗阇闻已。心生不乐。竟不洗浴。往诣世尊头面礼足。却住一面。白佛言。世尊。诸比丘何故不受我家供养。佛告毗阇。汝布施太过。钱财竭尽。如来欲饶益故。为汝作学家羯磨以是因缘。诸比丘不受汝施。毗阇即白佛言。世尊。我家今者富。于往昔三倍。唯愿世尊。从今日已后听诸比丘受我家施。佛告毗阇。今是十五日汝且还家。沐浴身体着新净衣。与诸眷属来诣众僧。乞汝所愿。毗阇如教还。后佛告诸比丘。毗阇本以布施太过。僧欲饶益故。作学家羯磨。毗阇今自说居业富足三倍于先。今欲从僧乞舍学家羯磨。僧应与舍。毗阇归家洗浴身体。易着新衣。与诸眷属来入僧坊。具说上事。尔时僧与作舍学家羯磨。应作求听羯磨。如是说。大德僧听。大臣毗阇布施太过。钱财竭尽。僧欲饶益故。与作学家羯磨。而今财业富足。若僧时到僧为大臣毗阇。欲于僧中乞舍学家羯磨。诸大德僧听。大臣毗阇乞舍学家羯磨。僧忍默然故。是事如是持。尔时大臣毗阇来。入僧中头面礼足。胡跪合掌。如是白言。大德僧听。我毗阇先富后贫。僧怜愍故。与我作学家羯磨。我今生业具足三倍于前。今从僧乞舍学家羯磨。唯愿僧与我舍学家羯磨。如是三乞。尔时应置。毗阇着眼见不闻处。羯磨者应作是说。大德僧听。是大臣毗阇布施太过。钱财竭尽。僧欲饶益故。与作学家羯磨。是毗阇自说家业具足三倍于先。已于僧中乞舍学家羯磨。若僧时到。僧今与毗阇舍学家羯磨。白如是。大德僧听。大臣毗阇布施太过。钱财竭尽。僧欲饶益故。与作学家羯磨。毗阇今自说家业具足三倍于前。已于僧中乞舍学家羯磨。僧今与毗阇舍学家羯磨。诸大德忍。僧与毗阇舍学家羯磨默然。若不忍者便说。是第一羯磨。第二第三亦如是说。僧已与毗阇舍学家羯磨竟。僧忍默然故。是事如是持。是舍学家羯磨。众现前非徒众现前。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。有诸学家僧作学家羯磨。比丘先不请而往自手受食。若啖若食。是比丘应向余比丘边悔过言。长老。我堕可呵法。此法悔过。是波罗提提舍尼法。学家者。妇须陀洹夫斯陀含。妇须陀洹夫阿那含。妇斯陀含夫须陀洹。妇斯陀含夫阿那含。妇阿那含夫须陀洹。妇阿那含夫斯陀含夫须陀洹妇斯陀含。夫须陀洹妇阿那含。夫斯陀含妇须陀洹。夫斯陀含妇阿那含。夫阿那含妇须陀洹。夫阿那含妇斯陀含。二俱须陀洹。二俱斯陀含。二俱阿那含。家者。四姓家。刹利家。婆罗门家。毗舍家。首陀罗家。比丘先不请者。先不请谓请想请余人谓己想而往者。若家中若园里。若田中。自手取者。手从手受器从器受。啖者。饼果等。食者。五正食。是比丘应向余比丘边悔过如是言。长老。我堕可呵法。此法悔过。前人应问。汝自见罪不。答言见。应语莫更犯。答言。顶戴持。波罗提提舍尼者。如上说。若僧已作学家羯磨者。不得如乌鸟避射方绝不往。应时时往看。为说法论法事。若学家欲布施者。应语且置汝边。我自知时。若先请僧后作羯磨。不得取大价重物。得取小小轻物。若学家言。尊者何故不受是施。谓我贫耶。尔时应语。汝不贫。如世尊所说。须陀洹人成就四法。于声闻中最为大富。何等四。一者于如来应供正遍知。生坚固信根。沙门婆罗门诸天世人所不能坏。二者于法生坚固信根。三者于僧中生坚固信根。四者于戒生坚固信根。沙门婆罗门诸天世人所不能坏。是名四法成就。如来声闻中不贫最为大富。若来精舍中饭僧作众供养。及非时浆者。不得舍去。当佐敷床褥施供养具。应为受用。已广为说法。是故说

  阿兰若处住　　无病受尼食
  比丘尼指授　　羯磨学家食
  四悔过法竟

    明众学法之初

佛住舍卫城。广说如上。尔时六群比丘下着内衣高着内衣。参差着内衣。百襵着内衣。石榴花着内衣。麦饭团着内衣。鱼尾着内衣。多罗树叶着内衣。象鼻着内衣。下者。齐踝。高者齐膝。参差者。不齐正。百襵者。多作襵。石榴花者。一边花奄。麦饭团者。总头如麦饭团。鱼尾者。垂两角似鱼尾。多罗树叶者。垄起如多罗树叶。象鼻者。一角偏垂。如是过故。为世人所讥。看沙门释子着衣。如王子大臣淫欲人。如是高下参差。乃至象鼻。此坏败人何道之有。诸比丘闻已。以是因缘往白世尊。佛言。呼六群比丘来来已佛问。比丘汝实尔不。答言。实尔。佛言。汝云何高下乃至象鼻着内衣。为世俗人所讥。从今日后不听如是着内衣。佛告诸比丘。依止舍卫城住者。皆悉令集集已佛于僧前。自着内衣。告诸比丘。汝等当如是着内衣。如净居天法屈右边襵左边着内衣。以十利故。与诸比丘制戒。乃至已闻者当重闻。齐整着内衣。应当学。齐整着内衣时。不得如缠轴。当反执右边执左边上角屈着内。应齐整着。不得如淫女法卖色左右顾视为好不好。应看令如法齐整着。若放恣诸根不欲学齐整。着内衣者。越学法。狂痴心乱无罪。是故说齐整着内衣。应当学

佛住舍卫城。广说如上。尔时六群比丘下被衣高被衣。婆罗天被衣婆薮天被衣。下被衣者。齐踝。高被衣者齐膝。婆罗天被衣者。衣加顶上。从两腋下外出。是名婆罗天被衣。婆薮天被衣者。衣加背上。从两腋下入挑着两肩上。是名婆薮天被衣。如是过故为世人所讥。云何沙门释子如王大臣童子贵乐人。如是高被衣下被衣。此坏败人为有何道。诸比丘闻已。以是因缘往白世尊。佛言。呼六群比丘来。来已佛问比丘。汝实尔不。答言。实尔。佛言。从今日后不听高下被衣。乃至婆薮天被衣。当齐整被衣。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。齐整被衣应当学。齐整被衣时不得如缠轴。应当通肩被着纽齐两角左手捉。捉时不得手中出角头如羊耳。不得如淫女卖色法。左右顾视为好不好。应看如法齐整不高不下。若泥时手得抄举。若放恣诸根不如法被衣者。越学法。狂痴心乱无罪。是故说齐整被衣。应当学

佛住舍卫城广说如上。尔时难陀优婆难陀。着细生疏衣形体露现。又复六群比丘着垢腻破衣。腰胁背肘露现。共入檀越家。为世人所嫌。看沙门释子。如王大臣。着细生疏衣形体露现。见着弊衣者作是言。看沙门释子。着如是衣服形体露现。似如奴仆客作贱人。入家内。此坏败人为有何道。诸比丘闻已。以是因缘往白世尊。佛言。呼六群比丘来。来已佛问比丘。汝实尔不。答言。实尔佛言。从今日后当好覆身入家内。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。好覆身入家内应当学。若作安陀会。当用致物作。若疏者当两重三重作。若安陀会疏者郁多罗僧当用致物作。若郁多罗僧疏者僧伽梨当用致物作。若放恣诸根不好覆身入家内者。越学法。若狂痴心乱无罪。是故说好覆身入家内。应当学

佛住舍卫城。广说如上。尔时六群比丘入白衣舍。看象看马。看骆驼看鸟。看伎儿歌舞。为世人所讥。云何沙门释子东西顾视。如似细作问言。尊者为失何物。左右顾视。如有所觅。出家之人应谛视入家内。此坏败人为有何道诸比丘以是因缘往白世尊。佛言。呼六群比丘来。来已佛问比丘。汝实尔不。答言。实尔。佛言。从今日后当谛视入家内。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。谛视入家内。应当学谛视。行时不得如马低头行。当平视行。防恶象马牛。当如担辇人行。不得东西视瞻。若欲看时。回身向所看处。若放恣诸根。不学谛视入家内者。越学法。狂痴心乱无罪。是故说谛视入家内。应当学

佛住舍卫城。广说如上。尔时六群比丘高声大唤。入白衣家内。为世人所讥。作是言。尊者如贾客失伴。如放牧人高声大唤。汝出家人。应小声入家内。此坏败人为有何道。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。来已佛问比丘。汝实尔不。答言。实尔。佛言。从今日后当小声入家内。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。小声入家内。应当学。不得高声大唤入家内。若欲唤时应弹指。若前人不闻者。应语比坐。若放恣诸根。不学小声行入家内者。越学法。狂痴心乱无罪。是故说小声入家内。应当学

佛住舍卫城。广说如上。尔时六群比丘共调戏语笑入白衣家内。为世人所讥。云何沙门释子如王子大臣淫欲放逸人。共相调戏语笑入内。问言。尊者何故现龂欲卖齿耶。此中亦无伎儿为笑何等。此坏败人为有何道。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。来已。佛问比丘。汝实尔不。答言。实尔。佛言。汝云何于圣人毗尼中现龂而笑相与调戏。从今日后不得戏笑入家内。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。不得笑入家内。应当学。不得笑。若有可笑事者。不得出龂现齿呵呵而笑。应制忍之。当起无常苦空无我想。思惟死想。若不可止当自啮舌。若复不能止者。当以衣角遮口徐徐抑制。若放恣诸根。大笑入家内者。越学法。狂痴心乱无罪。是故说不得笑入家内。应当学

佛住舍卫城。广说如上。尔时六群比丘覆头入白衣家内。为世人所讥。云何沙门释子如放逸淫女。如贼细作如新妇。如采蜜人。覆头行入家内。问言。尊者。患眼痛耶。畏日炙头耶。何故覆头。此坏败人何道之有。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。佛问比丘。汝实尔不。答言。实尔。佛言。从今日后不得覆头入白衣家内。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。不得覆头入家内。应当学。覆头者。尽覆及两耳。不得覆头行入白衣家。若大寒雨雪患头风。得覆半头一耳。若放恣诸根。覆头入家内者。越学法。狂痴心乱无罪。是故说不得覆头入家内。应当学

佛住舍卫城。广说如上。尔时六群比丘反抄衣入白衣家。为世人所讥。云何沙门释子如王子大臣。如淫劮女人卖色。反抄衣入人家内坐。露现肘胁。问言。尊者。欲来共斗耶。何故反抄衣现胁。此坏败人为有何道。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。来已佛问比丘。汝实尔不。答言。实尔。佛言。从今日后不得反抄衣入家内。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。不得反抄衣入家内。应当学。抄衣者。两边反抄着肩上。不得反抄衣行入家内。若风雨时得抄一边。若偏袒右肩。得抄左边。若通肩被得抄右边。不得令肘现。乞食时畏污衣故。得反抄肘不现无罪。若放恣诸根。反抄衣入家内者。越学法。狂痴心乱无罪。是故说不得反抄衣入家内。应当学

佛住舍卫城。广说如上。尔时六群比丘脚指行入白衣家。为世人所讥云何沙门释子如淫女偷人。如虾蟆行。此坏败人为有何道。诸比丘闻已。以是因缘往白世尊。佛言。呼六群比丘来。来已。佛问比丘。汝实尔不。答言。实尔。佛言。从今日后不得脚指行入白衣家。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。不得脚指行入家内。应当学。入内若埿水时不得先下脚指后下脚跟。当先下脚跟然后下脚指。若脚心有疮当侧脚行。作蔽疮物系之。先下脚跟后下脚指。若放恣诸根。不学平脚行者。越学法。狂痴心乱无罪。是故说不得脚指行入家内。应当学

佛住舍卫城。广说如上。尔时六群比丘叉腰入白衣家。为世人所讥。云何沙门释子如王子大臣力士。叉腰入人家内。此坏败人何道之有。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。来已佛问比丘。汝实尔不。答言。实尔。佛言。此是恶事。从今日后不得叉腰入白衣家。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。不得叉腰入家内。应当学。叉腰者。两手叉腰。不得叉腰行入家内。若腰脊痛若风肿者。得叉腰无罪。若痈疮癣以药涂上畏污衣故。叉腰无罪。若放恣诸根。叉腰入家内者。越学法。狂痴心乱无罪。是故说不得叉腰入家内。应当学

  内衣被上服　　好覆谛视入
  小声不得笑　　覆头反抄衣
  指行及叉腰　　学初跋渠竟

佛住舍卫城。广说如上。尔时六群比丘摇身入白衣家。为世人所讥。云何沙门释子如王子大臣淫女。摇身入家内。此坏败人。何道之有。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。来已佛问比丘。汝实尔不。答言。实尔。佛言。从今以后不得摇身入家内。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。不得摇身入家内。应当学。若老病身振风雨寒雪振摇无罪。若放恣诸根。摇身入家内者。越学法。狂痴心乱无罪。是故说不得摇身入家内。应当学

佛住舍卫城广说如上。尔时六群比丘摇头入白衣家内。为世人所讥。云何沙门释子如淫劮人。如鼠如狼。振动头入家内。此坏败人有何道法。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。来已佛问比丘。汝实尔不。答言。实尔。佛言。从今日后不得摇头入白衣家。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。不得摇头行入家内。应当学。若老羸病若痏头。若风雨寒振摇头无罪。若放恣诸根。摇头入家内者。越学法。狂痴心乱无罪。是故说不得摇头入家内。应当学

佛住舍卫城。广说如上。尔时六群比丘掉臂入白衣家。拨触檀越面破他手中酥油瓶器。为世人所讥。云何沙门释子如力士凶人。掉臂入家内。此坏败人有何道法。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。来已佛问比丘。汝实尔不。答言。实尔。佛言。从今日后不得掉臂入白衣家内。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。不得掉臂入家内。应当学。不得掉臂行入家内。若先是王子大臣本习未除。应当教言。汝今出家当舍此俗仪。从比丘法若欲唤人不得双举两手。当以一手招。若放恣诸根。掉臂入家内者。越学法。狂痴心乱无罪。是故说不得掉臂入家内。应当学

佛住舍卫城。广说如上。尔时六群比丘着垢腻破衣。露肘腰胁。难陀优波难陀着细生疏衣形体露现。共白衣家坐。为世人所讥。云何沙门释子如王子大臣贵人。着细生疏衣。见着弊衣者。复言。似如奴扑客作贱人。着破坏垢衣。肘胁露现坐家内。沙门释子应好覆身坐家内。此坏败人有何道法。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。来已佛问比丘。汝实尔不。答言。实尔。佛言。从今日后应好覆身坐家内。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。好覆身坐家内。应当学。好覆身者。应用致物作内衣。若用疏物者。应两重三重。若内衣疏者郁多罗僧应用致物。郁多罗僧疏者僧伽梨应用致物。僧伽梨疏者郁多罗僧应用致物。坐时不得坐衣上。当一手褰衣一手案坐具。然后安详而坐。若精舍中食上和上阿阇梨长老比丘前。应好覆身坐。若放恣诸根。不学好覆身家内坐者。越学法。狂痴心乱无罪。是故说好覆身家内坐。应当学

佛住舍卫城。广说如上。尔时六群比丘入白衣家内坐。看他妇女小儿行来出入上阁下阁。为世人所讥。云何沙门释子如淫劮人。如盗贼。在他家内坐看他妇女。问言。尊者。为失何物。东西顾视。出家之人应谛视坐家内。此坏败人有何道法。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。来已佛问比丘。汝实尔不。答言。实尔。佛言。从今日后应谛视坐家内。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。谛视坐家内。应当学。谛视家内坐时。不得如马延颈低视当平视。勿令不觉檀。越持热器来汤突手面。若精舍中食上。若在和上阿阇梨长老比丘前坐时。不得左右顾视。当平视坐。若放恣诸根。不谛视坐家内者。越学法。狂痴心乱无罪。是故说谛视坐家内。应当学

佛住舍卫城。广说如上。尔时六群比丘入白衣家内坐。高声大唤共相嘲话。为世人所讥。云何沙门释子高声大唤。如商人失伴。如放牧人大唤。问言。尊者。何故大唤。出家之人应小声坐。云何大唤。此坏败人有何道法。诸比丘以是因缘往白世尊。佛言。呼六群比丘来。来已佛问比丘。汝实尔不。答言。实尔。佛言。从今日后应小声坐家内。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。小声坐家内。应当学。不得高声大唤坐家内。若欲唤者。应弹指。若前人不觉者。当语近边人。若精舍中食上。若和上阿阇梨长老比丘前坐。不得高声大唤。若欲语时。语比坐。如是展转第二第三令彼得知。若放恣诸根。高声大唤坐家内者。越学法狂痴心乱无罪。是故说小声坐家内。应当学

佛住舍卫城。广说如上。尔时六群比丘白衣家内坐。展转调戏而共大笑。为世人所讥。云何沙门释子如王子大臣淫劮女人。作姿而笑坐家内。问言。尊者。此中有何事可笑。何故出龂。欲卖齿耶。此坏败人。有何道法。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。佛问比丘。汝实尔不。答言。实尔。佛言。汝出家人。云何贤圣毗尼中出龂大笑。从今日后不得家内坐笑。佛告诸比丘依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。不得笑坐家内。应当学。不得白衣家内笑坐。若精舍内食上。和上阿阇梨长老比丘前坐不得笑。若有可笑事者。不得出龂现齿大笑。应当忍之。起无常苦空无我想思惟死想。当自啮舌。若复不止者不得现龂大笑。当以衣角遮口制之。若放恣诸根。白衣家内坐笑者。越学法。狂痴心乱无罪。是故说不得笑坐家内。应当学

佛住舍卫城。广说如上。尔时六群比丘覆头坐白衣家内。为世人所讥。云何沙门释子如淫劮女人覆头坐家内。如采蜜人。问言。尊者。为患头痛畏日炙头耶。何故覆头。此坏败人。有何道法。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。佛问六群比丘。汝实尔不。答言。实尔。佛言。从今日后不得覆头坐家内。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。不得覆头坐家内。应当学覆头者。全覆头及两耳。不得覆头坐家内。若精舍中食上和上阿阇梨长老比丘前。不得覆头坐。若风寒雨时。若病若头患风。不得全覆。当覆半令一耳现。若见长老比丘时当[打-丁+勉]却。若屏处私房覆头无罪。若放恣诸根覆头坐家内者。越学法。狂痴心乱无罪。是故说不得覆。头坐家内。应当学

佛住舍卫城。广说如上。尔时六群比丘抄衣白衣家坐。为世人所讥。云何沙门释子如王子大臣淫劮女人卖色。抄衣坐家内露现肘胁此坏败人。有何道法。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。佛问比丘。汝实尔不。答言。实尔佛言。从今日后不得抄衣坐家内。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒乃至已闻者当重闻。不得抄衣坐家内。应当学。抄衣者。一边抄两边抄不得抄衣坐家内。若乞食若取食时。畏污衣故得抄衣。但莫令肘现无罪。若精舍中食上和上阿阇梨长老比丘前坐。不得抄衣。若抄者得抄一边不得抄两边。若偏袒者抄左边。若通肩被者得抄右边。若见长老比丘应还下。若放恣诸根。反抄衣坐家内者。越学法。狂痴心乱无罪。是故说不得反抄衣坐家内。应当学

佛住舍卫城。广说如上。尔时六群比丘抱膝坐白衣家内。为世人所讥。云何沙门释子如王子大臣憍逸俗人抱膝而坐。此坏败人。有何道法。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。来已佛问比丘。汝实尔不。答言。实尔。佛言。从今日后不得蹲坐家内。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。不得抱膝坐家内应当学。抱膝者。手抱衣抱不得抱膝坐家内。若精舍中食上和上阿阇梨长老比丘前不得抱膝坐。若病时得衣裹。着禅带见长老比丘时当脱。若屏处私房中得抱膝坐。若见长老比丘来还正坐。若放恣诸根抱膝坐家内者。越学法。狂痴心乱无罪。是故说不得抱膝坐家内。应当学

  摇身并摇头　　掉臂好覆身
  谛视并小声　　不笑覆头坐
  反抄抱膝坐　　第二跋渠竟

摩诃僧祇律卷第二十一摩诃僧祇律卷第二十二

        东晋天竺三藏佛陀跋陀罗共法显译

    明众学法之余

佛住舍卫城。广说如上。尔时六群比丘交脚白衣家坐。为世人所讥。云何沙门释子如王子大臣交脚坐家内。此坏败人有何道法诸比丘以是因缘。往白世尊。佛言呼六群比丘来。来已佛问比丘。汝实尔不。答言。实尔。佛言。从今日后不得交脚家内坐。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。不得交脚坐家内。应当学。交脚者。髀着髀上膝着膝上。膊肠着脚胫上脚着脚趺上不得交脚坐家内。应正两足。若精舍中食上和上阿阇梨长老比丘前。不得交脚坐。若病得交脚坐。见上座来当正坐若涂足挑刺交脚坐无罪。若放恣诸根交脚坐家内。越学法。狂痴心乱无罪。是故说不得交脚坐家内。应当学

佛住舍卫城。广说如上。尔时六群比丘叉腰白衣家内坐。为世人所讥。云何沙门释子如王子大臣力士。叉腰坐家内。此坏败人。有何道法。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。来已佛问比丘。汝实尔不。答言。实尔。佛言。从今日后不得叉腰坐家内。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。不得叉腰坐家内应当学。叉腰者。一手叉两手叉。不得叉腰坐家内。若精舍中食上和上阿阇梨长老比丘前。不得叉腰坐。若老病若风动腰痛叉腰无罪。若痈痤疮癣以药涂之。畏污衣故叉腰无罪。若见上座来应下。若放恣诸根叉腰坐家内者。越学法。狂痴心乱无罪。是故说不得叉腰坐家内。应当学

佛住舍卫城。广说如上。尔时六群比丘白衣家摇足坐舞手并复折草。为世人所讥。云何沙门释子如放逸伎儿在家内坐。手足不住此坏败人。有何道法。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。来已佛问比丘。汝实尔不。答言。实尔。佛言。从今日后不得动手足白衣家内坐。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。不得动手足坐家内。应当学。不得动手足家内坐者。不得动手动足舞手舞足。并折草坐。当安详靖住。若有所问者。当先护戒随顺而答。若问四塔者。得指示。是生处是得道处转法轮处般泥洹处无罪。若檀越欲令比丘起精舍者。应观地形势随作便指示。此中可起精舍。此中可起讲堂。此中可起温室。此中可起僧房。得指示无罪。若放恣诸根动手足坐家内者。越学法。狂痴心乱无罪。是故说不得动手足坐家内。应当学

佛住舍卫城广说如上。尔时有檀越于精舍中设供饭僧下食。时六群比丘方索水洗手涤钵。檀越闻已。即持热饭筐扑地。嫌言。我废家务就寺设供。望众僧斋同净心修福。今欲下食。方有所索。出家之人应专心受食。云何食上多有所索。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。来已佛问比丘。汝实尔不。答言。实尔。佛言。从今日后应一心受食。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。一心受食应当学一心受食。时不得两手按钵在脚前。当先净洗手涤钵。行食至当一心受。若直月监食人后来得索水洗手涤钵无罪。若放恣诸根不一心受食者。越学法。狂痴心乱无罪。是故说一心受食。应当学

佛住舍卫城。广说如上。尔时有长者就精舍中饭僧。六群比丘先多受羹。后受饭。时钵中溢出堕地。檀越嫌言。我夺妻子分饭食众僧。欲尽令食而今弃地。尊者不知耶。此一粒饭中而有百功。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。来已佛问比丘。汝实尔不。答言。实尔。佛言。从今日后羹饭等受。佛言。诸比丘。依止舍卫城住者。皆悉令集。以十利故与诸比丘制戒。乃至已闻者当重闻。羹饭等受应当学。羹饭等受者。不得先取羹后取饭。当先取饭按已后取羹。若国俗法先行羹后行饭者。当取揵镃拘钵受。若无者当用树叶碗受。复无叶者得以钵受羹但受饭时应以手遮徐徐下钵中。莫令溢出。若比丘病宜多须羹者。多取无罪。若放恣诸根不羹饭等受者。越学法。狂痴心乱无罪。是故说羹饭等受应当学

佛住舍卫城。广说如上。尔时有居士就精舍中设供饭僧。时六群比丘刳四边食留中央。为世人所讥。云何沙门释子如放逸人。周匝刳食留中央。此坏败人有何道法。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。来已佛问比丘。汝实尔不。答言。实尔。佛言。从今日后不得偏刳食。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。不得偏刳食。应当学。刳食者。刳四边留中央。当先受饭。按着一边。后受羹和合而食。若酥腻入饭中。不得以羹故偏刳取食当次第取。若欲与人者。得截半与若放恣诸根。周匝刳食者。越学法。狂痴心乱无罪。是故说不得偏刳食。应当学

佛住舍卫城。广说如上。尔时居士就精舍中设供饭僧。时六群比丘口中回食食。为世人所讥。云何沙门释子如放逸人。如驼牛羊口中回食食。此坏败人有何道法。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。来已佛问。汝实尔不。答言。实尔。佛言。从今日后不得口中回食食。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。不得口中回食食。应当学。口中回食者。含饭团从一颊回至一颊。当一边嚼即嚼边咽。若比丘食糗粳米者。当一边浸一边嚼无罪。若放恣诸根口中回食食者。越学法。狂痴心乱无罪。是故说不得口中回食食。应当学

佛住舍卫城。广说如上。尔时居士就精舍中设供饭僧。时六群比丘吐舌食。为世人所讥。云何沙门释子如放逸人。如蛇如鼠。如狗如猫。吐舌食。此坏败人有何道法。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。来已佛问。汝实尔不。答言。实尔。佛言。从今日后不得吐舌食。佛告诸比丘。依止舍卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。不得吐舌食。应当学。吐舌食者。吐出舌以食着舌上然后合口。若直月及监食人。欲知生熟咸淡甜酢。得着掌中。舌舐无罪。若病得置盐掌中舐无罪。若放恣诸根吐舌食者。越学法。狂痴心乱无罪。是故说不吐舌食应当学

佛住舍卫城。广说如上。尔时有居士就精舍中设供饭僧。时六群比丘大团饭食。为世人所讥。云何沙门释子如放逸人。如牛羊骆驼。如狱中饿囚大团饭食。此坏败人有何道法。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。来已佛问。汝实尔不。答言。实尔。佛言。从今日后不得大团饭食。佛告诸比丘。皆悉令集。以十利故。为诸比丘制戒。乃至已闻者当重闻。不得大团饭食。应当学。不得大不得小。如淫女人两粒三粒而食。当可口食。若比丘食粳米满口无罪。若放恣诸根大团饭食者越学法。狂痴心乱无罪。是故说不得大团饭食。应当学

佛住舍卫城。广说如上。尔时有居士就精舍中设供饭僧。时六群比丘张口待饭食。为世人所讥。云何沙门释子如放逸人。如龟鳖虾蟆张口待食。此坏败人有何道法。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。来已佛问。汝实尔不。答言。实尔。佛言。从今日后不得张口待饭食。佛告诸比丘。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。不得张口待饭食。应当学。不得张口待饭食者。比丘食时当如雪山象王食法。食入口已。并以鼻作后口分齐。前食咽已。续内后团不得张口而待食。若口有疮得豫张口无罪。若放恣诸根张口待饭食者。越学法。狂痴心乱无罪。是故说不得张口待饭食。应当学

佛住舍卫城。广说如上。尔时居士于精舍中设供饭僧时。六群比丘张口掷团食。为世人所讥。云何沙门释子如淫劮人掷团而食。此坏败人有何道法。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。来已佛问。汝实尔不。答言。实尔。佛言。从今日后不得掷团食。佛告诸比丘。皆悉令集。十利故。与诸比丘制戒。乃至已闻者当重闻。不得掷团食。应当学。掷团食者。不得团饭遥掷口中。若酸枣若葡萄。如是种种乃至熬豆挑掷啖无罪。若放恣诸根掷团食者。越学法。狂痴心乱无罪。是故说不得掷团食。应当学

佛住舍卫城。广说如上。尔时有居士于精舍设供饭僧。时六群比丘啮半食半还着钵中。为世人所讥。云何沙门释子如放逸人啮半食。此坏败人有何道法。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。来已佛问。汝实尔不。答言。实尔。佛言。从今日后不得啮半食。佛告诸比丘。皆悉令集。十利故。与诸比丘制戒。乃至已闻者当重闻。不得啮半食。应当学不得啮半食半还着钵中。当段段可口食。若糗团大当手中分令可口。若欲食果蓏甘蔗若芜菁根等得啮无罪。若饼当手作分齐令可口。若放恣诸根啮半食者。越学法。狂痴心乱无罪。是故说不得啮半食。应当学

佛住舍卫城。广说如上。尔时有居士于精舍设供饭僧。时六群比丘含食语。为世人所讥。云何沙门释子如放逸人。如驼牛羊驴含食鸣唤。此坏败人有何道法。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。来已佛问。汝实尔不。答言。实尔。佛言。从今日后不得含食语。佛告诸比丘。皆悉令集。十利故。与诸比丘制戒。乃至已闻者当重闻。不得含食语。应当学。不得含食语者。若食上和上阿阇梨长老比丘唤时。咽未尽能使声不异者得应。若不能得者咽已然后应。若前人嫌者。应答言。我口中有食。是故不即应。若放恣诸根含食语者。越学法。狂痴心乱无罪。是故说不含食语。应当学

  交脚坐家内　　叉腰动手足
  专意等饭羹　　偏刳回颊食
  吐舌及大团　　张口与遥掷
  啮半含食语　　第三跋渠竟

佛住舍卫城。广说如上。尔时有居士于精舍设供饭僧。时六群比丘以指抆钵食。为世人所讥。云何沙门释子如小儿食。如狱中饿囚食。问言。尊者。饮食极丰何以故为抆钵。此坏败人有何道法。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。来已佛问。汝实尔不。答言。实尔。佛言。从今日后不得指抆钵食。佛告诸比丘。皆悉令集。十利故。与诸比丘制戒。乃至已闻者当重闻。不得指抆钵食。应当学。不得指抆钵食者。不得曲指抆钵。若酥油蜜着钵者。不得曲指抆钵。当以指拘聚然后撮食。若放恣诸根指抆钵食者。越学法。狂痴心乱无罪。是故说不得指抆钵食。应当学

佛住舍卫城。广说如上。尔时有居士精舍中设供饭僧。时六群比丘舐手食。为世人所讥。云何沙门释子如小儿得食舐手而食。问言。尊者我自恣饱食。何故舐手。此坏败人有何道法。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。来已佛问。汝实尔不。答言。实尔。佛言。从今日后不得舐手食。佛告诸比丘。皆悉令集。十利故。与诸比丘制戒。乃至已闻者当重闻。不得舐手食。应当学。不得反覆舐手食。若酥油蜜石蜜着手者。当就钵缘上概聚着一处。然后取食。若放恣诸根舐手食者。越学法。狂痴心乱无罪。是故说不得舐手食。应当学

佛住舍卫城。广说如上。尔时有居士于精舍中设供饭僧。时六群比丘[口*束]指食。为世人所讥。云何沙门释子如小儿[口*束]指食。问言。尊者。我自恣施食。何以[口*束]指食。此坏败人有何道法。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。来已佛问。汝实尔不。答言。实尔。佛言。从今日后不得[口*束]指食。佛告诸比丘。皆悉令集。十利故。与诸比丘制戒。乃至已闻者当重闻。不得[口*束]指食。应当学。不得[口*束]指食者。若比丘食羹臛甜腻物着指不得[口*束]。当钵缘上概聚一处。然后取食。若蜜石蜜盐着指头得[口*束]无罪。若放恣诸根[口*束]指食者。越学法狂痴心乱无罪。是故说不得[口*束]指食。应当学

佛住舍卫城。广说如上。尔时有居士于精舍中设供饭僧。时六群比丘[口*專][口*集]作声食。为世人所讥。云何沙门释子如猪鼠食声。此坏败人有何道法。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。来已佛问。汝实尔不。答言。实尔。佛言。从今日后不得[口*專][口*集]作声食。佛告诸比丘。皆悉令集。十利故。与诸比丘制戒。乃至已闻者当重闻。不得[口*專][口*集]食。应当学。不得[口*專][口*集]作声。若放恣诸根[口*專][口*集]食者。越学法。狂痴心乱无罪。是故说不得[口*專][口*集]作声食。应当学

佛住舍卫城。广说如上。尔时有檀越于精舍中设供饭僧。时六群比丘吸饭作声食。为世人所讥。云何沙门释子如骆驼牛驴吸食食。此坏败人有何道法。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。来已佛问。汝实尔不。答言。实尔。佛言。从今日后不得吸食作声食。佛告诸比丘。皆悉令集。十利故。与诸比丘制戒。乃至已闻者当重闻。不得吸食食。应当学。若食薄粥乳酪羹饭不得吸使作声。当徐徐咽。若放恣诸根吸食食。越学法。狂痴心乱无罪。是故说不得吸食食。应当学

佛住舍卫城。广说如上。尔时有居士于精舍中设供饭僧。时六群比丘全吞食嗗嗗作声。为世人所讥。云何沙门释子如牛驴骆驼食嗗嗗作声。此坏败人有何道法。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。来已佛问。汝实尔不。答言。实尔。佛言。从今日后不得全吞食。佛告诸比丘。皆悉令集。十利故。与诸比丘制戒。乃至已闻者当重闻。不得全吞食。应当学不得全吞食。使嗗嗗作声。若比丘咽喉病作声无罪。若咽喉干燥。当以水通之。然后咽食。若放恣诸根全吞食者。越学法。狂痴心乱无罪。是故说不得全吞食。应当学

佛住舍卫城。广说如上。尔时有居士于精舍中设供饭僧。时六群比丘落饭食半入口中半堕地。为世人所讥。云何沙门释子如放逸人落饭食。问言。大德。谓呼此食是无种钱作耶。我夺妻子分布施求福。计此一粒百功乃成。当应尽食。何故弃地。此坏败人有何道法。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。来已佛问。汝实尔不。答言。实尔。佛言。从今日后不得落饭食。佛告诸比丘。皆悉令集。十利故。与诸比丘制戒。乃至已闻者当重闻。不得落饭食。应当学。受食时不得令一粒落地。若净人泻时堕地无罪。食着口中时勿令落地。误落地者无罪。若啖鱼肉果蓏甘蔗时。皮核滓骨不得纵横弃地。当聚足边。若放恣诸根落粒食者。越学法。狂痴心乱无罪。是故说不得落饭食。应当学

佛住舍卫城。广说如上。时有居士于精舍中设供饭僧。时六群比丘振手食污比坐比丘衣。比坐即问。长老。何故振手为蜈蚣蜂虿所螫耶。诸比丘。以是因缘往白世尊。佛言。呼六群比丘来。来已佛问。汝实尔不。答言。实尔。佛言。从今日后不得振手食。佛告诸比丘。皆悉令集。十利故。与诸比丘制戒。乃至已闻者当重闻。不得振手食。应当学。若振手食时不得向比坐振手。若食着手当向己前振手。若钵中抖擞。若放恣诸根振手食者。越学法。狂痴心乱无罪。是故说不得振手食。应当学

佛住舍卫城。广说如上。尔时有居士于精舍中设供饭僧。时六群比丘嫌心看比坐钵。若见少者便言贞廉自节。若饱不用当与我。若见捉大钵者。复言咄咄。此贪食人钵如似大釜。檀越所供正可满。是我等余人当复那得。诸比丘闻已惭愧。以是因缘往白世尊。佛言。呼六群比丘来。来已佛问。汝实尔不。答言。实尔。佛言。从今日后不得嫌心看比坐钵。佛告诸比丘。皆悉令集。十利故。与诸比丘制戒。乃至已闻者当重闻。不得嫌心看比坐钵。应当学。不得嫌心视比坐钵者。若监食人看食何处得。何处不得。得看无罪。若共行弟子若依止弟子病者。看其钵中。是应病食不得看无罪。若看上下坐为得不无罪。若放恣诸根嫌心看比坐钵者。越学法。狂痴心乱无罪。是故说不得嫌心看比坐钵。应当学

佛住舍卫城广说如上。尔时有居士于精舍中设供饭僧。时有比丘置钵在前回顾。共比坐语。六群比丘取钵着余处行食。次至不视钵扪摸地污手。从檀越索水洗手时。檀越弃饭筐着地。嫌言。我废家务修福饭僧。僧应齐集受食。今行食时。方索水洗手。出家之人当端心观钵食。此坏败人有何道法。诸比丘以是因缘往白世尊。佛言。呼六群比丘来。来已佛问。汝实尔不。答言。实尔。佛言。从今日后当端心观钵食。佛告诸比丘。皆悉令集。十利故。与诸比丘制戒。乃至已闻者当重闻。端心观钵食。应当学。端心观钵者不得放钵。在前共比坐语。若有因缘须共左右语者。左手抚钵上。若行食人到第三人时。当先涤钵豫擎待至。若放恣诸根不学端心观钵食者。越学法。狂痴心乱无罪。是故说端心观钵食。应当学

佛住舍卫城。广说如上。尔时有居士于精舍中设供饭僧。时六群比丘索饭索羹。为檀越所讥。云何沙门释子食上索饭索羹。问言。尊者。我自恣与食。何故唤索。诸比丘以是因缘往白世尊。佛言。呼六群比丘来。来已佛问。汝实尔不。答言。实尔。佛言。从今日后。不听索食

复次佛住迦维罗卫国释氏精舍。如来应供正遍知以五事利益故。五日一行诸比丘房。见一病比丘羸瘦痿悴。佛知而故问。比丘。汝病何似。答言。世尊。我病苦不适。佛语比丘。汝不能索随病食随病药耶。答言。世尊。制戒不听索食。佛言。从今日后听病比丘索食。佛告诸比丘。依止迦维罗卫城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。不得无病为已索食。应当学。不得无病为己索羹饭。若病须多羹得索无罪。若放恣诸根无病为己索食者。越学法。狂痴心乱无罪。是故说比丘不病不得为己索食。应当学

佛住舍卫城。广说如上。尔时有居士于精舍中设供饭僧。时六群比丘先受鱼肉羹后以饭覆上。监食人看见已。即问言。长老。得鱼肉羹不。答言。长寿。汝见色自知。何故复问。监食人问行食人。何以不与此中鱼肉羹。答言。何处不得此中未得。又言。我已与。何故言不得。诸比丘以是因缘往白世尊。佛言。呼六群比丘来。来已佛问。汝实尔不。答言。实尔。佛言。从今日后不得以饭覆羹更望得。佛告诸比丘。皆悉令集。十利故。与诸比丘制戒。乃至已闻者当重闻。不得以饭覆羹更望得。应当学。若比坐迎食虑污衣者。不得尽覆当露一边。若一切覆者前人问得未。应答已得。若放恣诸根以饭覆羹更望得者。越学法。狂痴心乱无罪。是故说不得以饭覆羹更望得。应当学

佛住舍卫城。广说如上。尔时有居士于精舍中设供饭僧。时六群比丘腻手捉饮器比坐恶不受。诸比丘以是因缘往白世尊。佛言。呼六群比丘来。来已佛问。汝实尔不。答言实尔。佛言。从今日后不得腻手捉饮器。佛告诸比丘。皆悉令集。十利故。与诸比丘制戒乃至已闻者当重闻。不得腻手受饮器。应当学。不得腻手受饮器者。比丘食时应护左手令净。当以右手受饮器。拄唇而饮。不得口深含器缘。亦不得令缘触鼻额。不得尽饮当留少许当口处泻弃之更以水涤。次行与下座。若左手病疮者。右手就钵缘上。概去腻净水。洗若不净以叶承取饮已如上说。若放恣诸根以腻手捉饮器者。越学法。狂痴心乱无罪。是故说不得以腻手受饮器。应当学

佛住舍卫城。广说如上。尔时有居士于精舍中设供饭僧。时六群比丘钵中余食荡已弃地檀越嫌言。尊者谓此食是无子钱作耶。我夺妻子分为福德。故一粒百功。云何泻地。此坏败人有何道法。诸比丘以是因缘往白世尊。佛言。呼六群比丘来。来已佛问。汝实尔不。答言。实尔。佛言。从今日后不得钵中残食泻地。佛告诸比丘。皆悉令集。十利故。与诸比丘制戒。乃至已闻者当重闻。不得以钵中残食弃地。应当学。不得钵中残食弃地者。食时当称腹而取不得多受。若净人卒与多者。未啖时应减与比坐。若比坐不取应与沙弥及园民。若洗钵时不得一粒泻弃地。若有者当聚着板上叶上。若细粒若糗不可得聚者无罪。若放恣诸根以钵中残食泻地者。越学法。狂痴心乱无罪。是故说不得以钵中残食弃地。应当学

  抆舐[口*束]作声　　全吞并落粒
  振手看他钵　　端心为己索
  覆羹腻手弃　　四跋渠说竟

佛住毗舍离。广说如上。尔时难陀优波难陀立为坐梨车童子说法。为世人所讥。云何沙门释子如彼伎人立为坐人说法。此坏败人有何道法。然此童子无恭敬心。说如是微妙法时。应与床坐。云何坐听。令彼立说。诸比丘以是因缘往白世尊。佛言。呼难陀优波难陀来。来已佛问上事。汝实尔不。答言。实尔。佛言。汝云何立为无病坐人说法。从今日后不得立为坐人说法。佛告诸比丘。依止毗舍离城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。人坐比丘立不得为说法除病。应当学。病者世尊说无罪。说者。为前人开解其义分别演说。欲令如说修行。法者。佛所说佛所印可。佛所说者。如来应供正遍知自说。佛所印可者声闻所说。佛赞善哉。是名印可。不得立为坐人说法。前人病者无罪。若比丘为塔事。为僧事诣王若地主。彼言。比丘为我说法。不得语令起恐彼疑故。若边有立人者。即作意为立人说法。王虽听比丘无罪。若放恣诸根立为无病坐人说法者。越学法。狂痴心乱无罪。是故说人坐比丘立不得为说法。除病。应当学

佛住毗舍离。广说如上。尔时难陀优波难陀坐为卧人说法。为世人所讥。云何沙门释子如伎人坐为卧人说法。此坏败人有何道法。此听法人无恭敬心。闻说如是微妙法。云何卧听。诸比丘以是因缘往白世尊。佛言。呼难陀优波难陀来。来已佛问。汝实尔不。答言。实尔。佛言。汝云何坐为无病卧人说法。从今日后人卧比丘坐不得为说法。除病。佛告诸比丘。皆悉令集。十利故。与诸比丘制戒。乃至已闻者当重闻。人卧比丘坐不得为说法。除病。应当学。病者世尊说无罪。说法者如上说。若比丘为塔为僧事。若诣王若地主时。彼言比丘为我说法。不得语。令起恐生疑故。若边有坐人者。当为坐人说法。王虽听比丘无罪。若放恣诸根坐为无病卧人说法者。越学法。狂痴心乱无罪。是故说人卧比丘坐不得为说法。除病。应当学

佛住毗舍离。广说如上。尔时难陀优波难陀坐卑小床。为高床上军将师子说法。为世人所讥。云何沙门释子如似伎儿自坐卑小床为高床上人说法。此坏败人何道之有。然此师子军将无恭敬心。闻如是微妙法时。云何自坐高床。使彼坐卑小床而为说法。诸比丘以是因缘。往白世尊。佛言。呼难陀优波难陀来。来已佛问。汝实尔不。答言。实尔。佛言。汝云何坐卑下床为高床上人说法。从今日后人在高床上。己在下不得为说法。除病。佛告诸比丘。皆悉令集。十利故。与诸比丘制戒。乃至已闻者当重闻。人在高床比丘在卑床。不得为说法。除病。应当学。卑床有二种。一者下床名卑。二者粗弊亦名卑。高者二种。高大名高。妙好者亦名高。病者世尊说无罪。说法者。如上说。不得坐卑床为坐高床上人说法。病人无罪。若比丘为塔为僧事诣王若地主。彼言。比丘为我说法。尔时不得语令起易坐恐生疑故。若边有下人应作意为下人说。王虽坐高床听比丘无罪。若放恣诸根在卑床为坐高床人说法者。越学法。狂痴心乱无罪。是故说人在高床比丘在卑床。不得为说法。除病。应当学

佛住毗舍离。广说如上。尔时难陀优波难陀为着革屣梨车童子说法。为世人所讥。云何沙门释子如诸伎儿为着革屣人说法。此坏败人有何道法。而此童子闻说妙法无恭敬心。不脱革屣听法。诸比丘以是因缘。往白世尊。佛言。呼难陀优波难陀来。来已佛问比丘。汝实尔不。答言。实尔。佛言。汝云何为无病着革屣人说法。从今日后不得为着革屣人说法。除病。佛告诸比丘。皆悉令集十利故。与诸比丘制戒。乃至已闻者当重闻。不得为着革屣人说法。除病。应当学。革屣者若一重若两重。说法者。如上说。不得为无病着革屣人说法。病者佛说无罪。若比丘为塔事僧事。乃至边有净人者当立意为彼人说。王听无罪。若比丘在崄路恐怖处。防卫人言。尊者。为我说法。彼虽着革屣为说无罪。若放恣诸根为无病着革屣人说法者。越学法。狂痴心乱无罪。是故说不得为着革屣人说法。除病。应当学

佛住毗舍离。广说如上。尔时难陀优波难陀为着木屐梨车童子说法。为世人所讥。云何沙门释子如伎儿为着屐人说法。此坏败人有何道法。而此童子无恭敬心。闻如是微妙法。应当脱屐。云何着屐听法。诸比丘以是因缘。往白世尊。佛言。呼难陀优波难陀来。来已佛问比丘。汝实尔不。答言。实尔。佛言。汝云何为无病着屐人说法。从今日后不得为着屐人说法除病。佛告诸比丘。皆悉令集。十利故。与诸比丘制戒。乃至已闻者当重闻。不得为着屐人说法。除病。应当学。病者世尊说无罪。屐者有十四种。金屐银屐。摩尼屐牙屐。木屐多罗屐。皮屐钦婆罗屐。綖屐芒屐。树皮屐婆迦屐草屐。如是等种种屐。是名屐。说法者。如上说。若比丘为塔为僧事。诣王若地主。彼言。比丘为我说法。不应语令脱屐恐生疑故。若边有净人者应作意为净人说。王听无罪。若放恣诸根为无病着屐人说法者。越学法。狂痴心乱无罪。是故说不得为着屐人说法。除病。应当学

佛住毗舍离。广说如上。尔时难陀优波难陀为覆头梨车童子说法。为世人所讥。云何沙门释子如伎儿为覆头人说法。此坏败人有何道法。而此童子无恭敬心。闻如是微妙法。应却头上覆。云何覆头听法。诸比丘以是因缘。往白世尊。佛言。呼难陀优波难陀来。来已佛问。汝实尔不。答言。实尔。佛言。汝云何为无病覆头人说法。从今日后不得为覆头人说法。除病。佛告诸比丘。皆悉令集。十利故与诸比丘制戒。乃至已闻者当重闻。不得为覆头人说法。除病。应当学。病者世尊说无罪。覆头者一切覆头。说法者。如上说得为病人说法无罪。若比丘为塔为僧事。诣王若地主时。乃至边有净人者当立意为彼人说。王听无罪。若比丘在怖畏崄道行时。防卫人言。尊者。为我说法。彼虽覆头为说法无罪。若放恣诸根为无病覆头人说法者。越学法。狂痴心乱无罪。是故说不得为覆头人说法。除病。应当学

佛住毗舍离。广说如上。尔时难陀优波难陀为缠头梨车童子说法。为世人所讥。云何沙门释子如伎说人为缠头人说法。此坏败人有何道法。然此童子无恭敬心。闻是妙法。云何缠头听说法。诸比丘以是因缘。往白世尊。佛言。呼难陀优波难陀来。来已佛问。汝实尔不。答言。实尔。佛言。汝云何为无病缠头人说法。从今日后不得为缠头人说法。除病。佛告诸比丘。依止毗舍离城住者。皆悉令集。以十利故与诸比丘制戒。乃至已闻者当重闻。不得为缠头人说法。除病。应当学。病者世尊说无罪。缠头者。若衣缠若绢缠。说法者如上说。得为病缠头人说法无罪。若比丘为塔为僧事故。诣王若地主。彼作是言。比丘为我说法。不得语令解缠恐生疑心故。若边有净人者当作意为彼说。王虽听无罪。若比丘在怖畏崄道行时。防卫人言。尊者。为我说法。彼人虽缠头为说无罪。若放恣诸根为无病缠头人说法者。越学法。狂痴心乱无罪。是故说不得为缠头人说法。除病。应当学

佛住毗舍离。广说如上。尔时难陀优波难陀为梨车童子抱膝蹲人说法。为世人所讥。云何沙门释子如伎说人为抱膝蹲人说法。此坏败人有何道法。而此童子无恭敬心。闻如是微妙法。应如法坐。云何抱膝蹲听。诸比丘以是因缘。往白世尊。佛言。呼难陀优波难陀来。来已佛问。汝实尔不。答言。实尔。佛言。汝云何为无病抱膝蹲人说法。从今日后不得为抱膝蹲人说法。除病佛告诸比丘。皆悉令集。十利故。与诸比丘制戒。乃至已闻者当重闻。不得为抱膝蹲人说法。除病。应当学。病者世尊说无罪。抱膝者手抱衣抱带抱。说法者。如上说。为病人说无罪。若比丘为塔为僧事。诣王若地主时。乃至边有净人应作意为净人说。王虽听为说无罪。若放恣诸根为无病抱膝人说法者。越学法。狂痴心乱无罪。是故说不得为抱膝蹲人说法。除病。应当学

佛住毗舍离。广说如上。尔时难陀优波难陀为翘脚坐梨车童子说法。为世人所讥。云何沙门释子如伎说人为翘脚人说法。此坏败人有何道法。然此童子无恭敬心。闻是妙法应正坐。云何翘脚坐。诸比丘以是因缘。往白世尊。佛言。呼难陀优波难陀来。来已佛问。汝实尔不。答言。实尔。佛言。汝云何为无病翘脚人说法。从今日后不得为翘脚人说法。除病。佛告诸比丘。皆悉令集。十利故。与诸比丘制戒。乃至已闻者当重闻。不得为翘脚人说法。除病。应当学。病者世尊说无罪。翘脚者。髀着髀上膝着膝上。膊着胫上脚着脚趺上。说法者。如上说。不得为无病翘脚人说法。病者为说无罪。若比丘为塔为僧事。诣王若地主。彼言。比丘为我说法。不得语彼令正坐恐生疑心故。彼边有净人者。当作意为彼人说。王虽听无罪。若放恣诸根为无病翘脚人说法者。越学法。狂痴心乱无罪。是故说不得为翘脚人说法。除病。应当学

  为坐及卧说　　高床着革屣
  着屐并覆头　　缠头抱膝蹲
  不为翘脚说　　第五跋渠竟

佛住毗舍离。广说如上。尔时难陀优波难陀为持刀梨车童子说法。为世人所讥。云何沙门释子如伎人为捉刀人说法。此坏败人有何道法。然此童子无恭敬心。闻是妙法。应当一心合掌。云何如屠儿捉刀听法。诸比丘以是因缘。往白世尊。佛言。呼难陀优波难陀来。来已佛问。汝实尔不。答言。实尔。佛言。汝云何为捉刀人说法。从今日后不得为持刀人说法。佛告诸比丘。依止毗舍离城住者。皆悉令集。以十利故。与诸比丘制戒。乃至已闻者当重闻。不得为持刀人说法。应当学。持者手捉刀者。大刀小刀剑。说法者。如上说。不得为持刀人说法。若比丘为塔为僧事。诣王若地主。彼言。比丘为我说法不得语令放刀恐生疑心故。若边有净人当作意为净人说。王虽听无罪。若比丘在崄道恐怖处行时。防卫人言。尊者为我说法。彼虽捉刀为说无罪。若放恣诸根为捉刀人说法者。越学法。狂痴心乱无罪。是故说不得为持刀人说法。应当学

佛住毗舍离。广说如上。尔时难陀优波难陀为持弓箭梨车童子说法。为世人所讥。云何沙门释子如伎人为持弓箭人说法。此坏败人有何道法。然此童子无恭敬心。闻是妙法应放弓箭。云何如猎师捉弓箭听法。诸比丘以是因缘。往白世尊。佛言。呼难陀优波难陀来。来已佛问。汝实尔不。答言。实尔佛言。汝云何为持弓箭人说法。佛言。从今日后不得为持弓箭人说法。佛告诸比丘。皆悉令集。十利故。与诸比丘制戒乃至已闻者当重闻。不得为持弓箭人说法。应当学。持者手捉。弓箭者。防卫仗也。说法者。如上说。不得为持弓箭人说法。若比丘为塔为僧事。诣王若地主。彼言比丘为我说法。不得语令放弓箭。恐彼人生疑。若边有净人者。应作意为净人说。王虽听无罪。若比丘在怖畏崄道行时。防卫人言。尊者。为我说法。彼虽捉弓箭为说无罪。若放恣诸根为捉弓箭人说法者。越学法。狂痴心乱无罪。是故说不得为持弓箭人说法。应当学

佛住毗舍离。广说如上。尔时难陀优波难陀为持杖梨车童子说法。为世人所讥。云何沙门释子如伎人为捉杖人说法。此坏败人有何道法。然此童子无恭敬心。闻是妙法应当舍杖。云何捉杖听法。诸比丘以是因缘。往白世尊。佛言。呼难陀优波难陀来。来已佛问。汝实尔不。答言。实尔。佛言。汝云何为无病捉杖人说法。从今日后不得为持杖人说法。除病。佛告诸比丘。皆悉令集。十利故。与诸比丘制戒。乃至已闻者当重闻。不得为持杖人说法。除病。应当学。病者世尊说无罪。捉杖者。一切杖。说法者。如上说。不得为无病持杖人说法。病者无罪。若比丘为塔为僧事。诣王若地主。彼言。比丘为我说法。不得语令放杖。恐生疑心故。若边有净人者。应作意为净人说。王虽听无罪。若比丘在怖畏崄道行时。防卫人言。尊者。为我说法。彼虽捉杖为说法无罪。若放恣诸根为无病捉杖人说法者。越学法。狂痴心乱无罪。是故说不得为持杖人说法。除病。应当学

佛住毗舍离。广说如上。尔时难陀优波难陀为持盖梨车童子说法。为世人所讥。云何沙门释子如伎人。为持盖人说法。此坏败人有何道法。然此童子无恭敬心。闻是妙法应当却盖。云何捉盖听法。诸比丘以是因缘。往白世尊。佛言。呼难陀优波难陀来。来已佛问。汝实尔不。答言。实尔。佛言。汝云何为无病持盖人说法。从今日后不得为持盖人说法。除病。佛告诸比丘。皆悉令集。十利故。与诸比丘制戒。乃至已闻者当重闻。不得为持盖人说法。除病。应当学。病者。世尊说无罪。盖者。树皮盖。多罗叶盖。多梨叶盖。竹伞盖。叠伞盖。孔雀尾盖。如是等种种能遮雨日者。皆名伞盖。说法者。如上说。不得为无病捉盖人说法。病者无罪。若比丘为塔为僧事。诣王若地主。彼言。比丘为我说法。不得语令却盖恐生疑故。若边有净人应作意为净人说。王虽听无罪。若法师若律师风雨寒雪大热时。捉盖为说无罪若放恣诸根为无病捉盖人说法者。越学法。狂痴心乱无罪。是故说不得为持盖人说法除病。应当学

佛住毗舍离。广说如上。尔时难陀优波难陀随梨车童子后行说法。为世人所讥。云何沙门释子如伎人随人后为说法。此坏败人有何道法。然此童子无恭敬心。闻是妙法应当在后而听。诸比丘以是因缘。往白世尊。佛言。呼难陀优波难陀来。来已佛问。汝实尔不。答言。实尔。佛言。汝云何随无病人后为说法。从今日后人在前不得随后为说法。除病。佛告诸比丘。皆悉令集。十利故。与诸比丘制戒。乃至已闻者当重闻。人在前不得随后为说法。除病。应当学。病者世尊说无罪。后者人在前比丘在后说法者。如上说。不得随无病人后而为说法。病者无罪。若比丘为塔为僧事。诣王若地主。彼言。比丘为我说法。不得语令在后恐生疑心故。若边有净人者。应作意为净人说。王虽听无罪。若比丘在怖畏崄道行时。防卫人言。此处贼常喜在前发。我当在前。尊者在后为我说法。为说无罪。若比丘眼恶前人捉杖牵前为说法无罪。若放恣诸根在无病人后说法者。越学法。狂痴心乱无罪。是故说人在前比丘在后不得为说法。除病。应当学

佛住毗舍离。广说如上。尔时难陀优波难陀为骑乘梨车童子说法。为世人所讥。云何沙门释子如伎人为骑乘人说法。此坏败人有何道法。而此童子无恭敬心。闻是妙法应当下乘。云何骑乘听法。诸比丘以是因缘。往白世尊

佛言。呼难陀优波难陀来。来已佛具问上事。汝实尔不。答言。实尔。佛言。汝云何为无病骑乘人说法。从今日后骑乘人不得为说法。除病。佛告诸比丘。皆悉令集。十利故。与诸比丘制戒。乃至已闻者当重闻。骑乘人不得为说法。除病。应当学。病者世尊说无罪。乘者。有八种。象乘马乘。牛乘驴乘。船乘车乘。舆乘辇乘。说法者。如上说。不得为无病骑乘人说法。病者无罪。若比丘为塔为僧事。诣王若地主。彼言。比丘为我说法。不应语令下乘。恐生疑心故。若边有净人者。应作意为净人说。王虽听无罪。若比丘在怖畏崄道行时。防卫人言。尊者。为我说法。彼骑乘人为说无罪。若放恣诸根为无病骑乘人说法者。越学法。狂痴心乱无罪。是故说不得为骑乘人说法。除病。应当学

佛住毗舍离。广说如上。尔时难陀优波难陀。在道外为道中梨车童子说法。为世人所讥。云何沙门释子如伎人己在道外。为道中人说法。此坏败人有何道法。而此童子无恭敬心。闻是妙法应避道听。令比丘道中。云何自在道中。诸比丘以是因缘。往白世尊。佛言。呼难陀优波难陀来。来已佛问。汝实尔不。答言。实尔。佛言。汝云何在道外人。在道中为说法。从今日后不得道外为道中人说法。除病。佛告诸比丘。皆悉令集。十利故。与诸比丘制戒乃至已闻者当重闻。不得道外为道中人说法。除病。应当学。病者世尊说无罪。道外者比丘在道外。道中者前听人。说法者。如上说。不得道外为无病道中人说法。病者无罪。若比丘为塔为僧事。诣王若地主。彼言。比丘为我说法。比丘不得语令在道外。恐彼生疑故。若边有净人者。当作意为净人说。王虽听无罪。若比丘在怖畏崄道行时。防卫人言。尊者在道外。我在道中。若有贼出我当拒之。尊者。为我说法。彼虽在道中为说无罪。若放恣诸根在道外为无病道中人说法者。越学法。狂痴心乱无罪。是故说不得在道外为道中人说法。除病。应当学

佛住舍卫城。广说如上。尔时波斯匿王欲诣东库园林池观。语侍者言。明当与夫人婇女出东园游看。可扫洒庄严敷施床褥。时六群比丘闻已。先往到彼。于软草上[口*弟]唾。复取树叶裹不净。着池水中浮。其日王出夫人婇女在宫日。久常思游看。今得从意如囚出狱。到园中见诸软草各各驰趣。并遥占言。此是我许此是我许。即便坐上[口*弟]唾污衣。各趣池水洗手溅衣。见池水上有诸叶裹。又作是念。将是诸年少闻我等当出。必裹诸香。着此水中。以待我辈。各各诤之。此是我许此是我许。竞捉叶裹不净灒出污诸衣物展转相谓言。奇事奇事。本谓是香。乃是不净。即白王言。此是奇怪。王先敕扫洒今不净乃尔。王问园民。谁污此园。园民白王。昨日六群比丘在此中戏良久乃去。或是彼污。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。来已佛具问上事。汝实尔不。答言。实尔。佛言。汝等云何生草上及水中大小便涕唾。从今日后不听生草上水中大小便[口*弟]唾。佛告诸比丘。皆悉令集。十利故。与诸比丘制戒。乃至已闻者当重闻。不得生草上大小便[口*弟]唾。应当学。不得水中大小便[口*弟]唾。应当学。不得生草上大小便唾。当在无草地。若夏月生草普茂无空缺处者。当在骆驼牛马驴羊行处。若复无是者。当在塼瓦石上。若复无者。当在干草叶上。若复无者。当以木枝承令粪先堕木枝上。后堕地。若比丘经行时。不得[口*弟]唾生草上。经行头当着唾壶。瓦石草叶以细灰土著唾壶中。然后唾上。若大小便[口*弟]唾。污手脚不得拭。生草水者十种。如上说。不得大小便[口*弟]唾水中当在陆地。若雨时水卒起浮满当在土块上。若无是者当于瓦石上。若竹木上先堕木上。然后堕水中。若掘地作圊厕底水出者。比丘不得先在上起止。当先使净人行。然后比丘行无罪。若圊厕底有流水。当以木承已后堕水中。若大小便[口*弟]唾。污手脚得水洗。水中洗大小便行无罪。若比丘入水浴时。不得唾中。若远岸者当唾手中。然后弃之。若放恣诸根生草上大小便涕唾者。越学法。狂痴心乱无罪。若放恣诸根水中大小便涕唾者。越学法。狂痴心乱无罪。是故说不得生草上大小便涕唾。应当学。不得水中大小便涕唾。应当学

佛住舍卫城。广说如上。尔时六群比丘立大小便。为世人所讥。云何沙门释子如牛驴骆驼立大小便。此坏败人有何道法。诸比丘以是因缘。往白世尊。佛言。呼六群比丘来。来已佛问。汝实尔不。答言。实尔佛言。汝云何立大小便。从今日后不得立大小便。佛告诸比丘。皆悉令集。十利故。与诸比丘制戒乃至已闻者当重闻。不得立大小便。应当学。不得立大小便。若脚有埿土畏污衣者得立无罪。脚若病若疮若肿得立无罪。若放恣诸根立大小便者。越学法。狂痴心乱无罪。是故说不得立大小便。应当学

  捉刀持弓箭　　持杖并伞盖
  后行骑乘人　　道外生草上
  水中立便利　　第六跋渠竟

佛住舍卫城广说如上尔时佛告阿难。僧有诤事。汝往断灭。令止诤事。阿难白言。云何僧诤事断当令灭。佛言。六群比丘知僧如法如律。如毗尼断诤灭已。后更举诸比丘诤事。更起作是言。是法非法。乃至是处羯磨非处羯磨。如波夜提中广说。乃至世尊弟子僧无量常所行事。一切七止诤法灭。是名常所行事七止诤法灭。是故说若比丘知僧如法如毗尼灭。乃至后更举波夜提。七灭诤法竟。法随顺法者。如二部毗尼。随顺者顺行此法也。波罗提木叉分别竟

摩诃僧祇律卷第二十二摩诃僧祇律卷第二十三

        东晋天竺三藏佛陀跋陀罗共法显译

    明杂诵跋渠法之一

世尊成道五年比丘僧悉清净。自是已后渐渐为非。世尊随事为制戒。立说波罗提木叉。四种具足法。自具足。善来具足。十众具足。五众具足自具足者。世尊在菩提树下。最后心廓然大悟。自觉妙证善具足。如线经中广说。是名自具足。善来具足者。佛住王舍城迦兰陀竹园。佛告诸比丘。如来处处度人。比丘比丘尼优婆塞优婆夷。汝等亦当效如来广行度人。尔时诸比丘闻世尊教已游行诸国。见有信善男子求出家者。诸比丘亦敩如来唤善来比丘。度人出家。威仪进止。左右顾视。着衣持钵。皆不如法。为世人所讥。作是言。世尊所度善来比丘威仪进止。左右顾视着衣持钵。皆悉如法。诸比丘所度。亦名善来威仪进止。左右顾视。着衣持钵。皆不如法。尔时尊者舍利弗闻是语已。在闲静处加趺而坐作是思惟。俱是善来。何故世尊所度善来比丘。皆悉如法。诸比丘所度善来比丘。皆不如法。云何令诸比丘度人善受具足。皆悉如法。共一戒一竟。一住一食一学一说。舍利弗晡时从禅觉已往诣佛所。头面礼足。却坐一面。白佛言。世尊。我向静处作是思惟。俱名善来。何故世尊所度皆悉如法。诸比丘所度皆不如法。云何使诸比丘度人善受具足。皆悉如法。共一戒一竟。一住一食一学一说。唯愿世尊具为解说。佛告舍利弗。如来所度阿若憍陈如等五人。善来出家善受具足。共一戒一竟一住一食一学一说。次度满慈子等三十人。次度波罗奈城善胜子。次度优楼频螺迦叶五百人。次度那提迦叶三百人。次度伽耶迦叶二百人。次度优波斯那等二百五十人。次度汝大目连各二百五十人。次度摩诃迦叶阐陀迦留陀夷优波离次度释种子五百人。次度跋度帝五百人。次度群贼五百人。次度长者子善来。如是等如来所度善来比丘出家善受具足。共一戒一竟。一住一食一学一说。舍利弗。诸比丘所可度人。亦名善来出家善受具足。乃至共一说。是名善来受具足十众受具足者。佛告舍利弗。从今日制受具足法十众和合一白三羯磨无遮法。是名善受具足。欲受具足人。初入僧中。一一头面礼僧足已先求和上偏袒右肩。胡跪接足。作是言。我从尊乞求和上。尊为我作和上。与我受具足如是至三。和上应语发喜心。答言我顶戴持。和上先已与求衣钵与求众。与求戒师。与求空静处。教师推与众僧。羯磨师应问。谁与某甲空静处。作教师。答言。我能。羯磨师应作是说。大德僧听。某甲从某甲受具足。若僧时到僧某甲和上某甲。某甲能空静处。作教师。诸大德听。某甲和上某甲。某甲能空静处。作教师。僧忍默然故。是事如是持。教师应将离众不近不远。教有二种。若略若广。云何略。今僧中当问。汝有者言有。无者言无。云何广。如后僧中一一说。教师来入僧中。白言。某甲问已讫。自说清净无遮法。羯磨师应作是说。大德僧听。某甲从某甲。受具足。某甲已空静处教问讫。若僧时到僧某甲和上某甲。某甲听入僧中。诸大德听。某甲和上某甲。某甲听入僧中。僧忍默然故。是事如是持。欲受戒人应入僧中。一一头面礼僧足已。在戒师前。胡跪合掌。授与衣钵。教受作是言。此是我钵多罗。应量受用。乞食器今受持。如是三说。此是僧伽梨。此是郁多罗僧。此是安陀会。此是我三衣此三衣不离宿受持。如是三说。羯磨师应作是说。大德僧听。某甲从某甲。受具足。某甲已空静处教问讫。若僧时到僧某甲和上某甲。某甲欲从僧乞受具足。诸大德听。某甲和上某甲。某甲欲从僧乞受具足。僧忍默然故。是事如是持。戒师应教乞作是言。大德僧听。我某甲从和上某甲。受具足。阿阇梨某甲已空静处教问讫。我某甲和上某甲。今从僧乞受具足。唯愿僧与我受具足。哀愍我故。如是至三。羯磨师应作是说。大德僧听。某甲从某甲受具足。某甲已空静处教问讫。已从僧中乞受具足。若僧时到僧某甲和上某甲。某甲欲于僧中问遮法。诸大德听。某甲和上某甲。某甲欲于僧中问遮法。僧忍默然故。是事如是持善男子听。今是至诚时。是实语时。于诸天世间天魔诸梵沙门婆罗门诸天世人阿修罗。若不实者。便于中欺诳。亦复于如来应供正遍知声闻众中欺诳。此是大罪。今僧中问汝有者言有。无者言无。父母听不求和上。未三衣钵具不。是男子不年满二十不。非是非人不。非是不能男不。汝字何等。若言字某和上字谁。答言字某。不坏比丘尼净行不。非贼盗住不。非越济人不。非自出家不。不杀父母不。不杀阿罗汉不。不破僧不。不恶心出佛身血不。(佛久已般泥洹故依旧文)汝本曾受具足不。答言曾受不犯四事不。若言犯应语去。不得受具足。若言不犯。次问十三事。一一事中有犯不。若言犯受具足讫。此罪能如法作不。答言能。本舍戒不。答言舍汝非奴不。非养儿不。不负人债不。非王臣不。不阴谋王家不。汝黄门不。汝非二根不。汝是丈夫不。汝无如是诸病癣疥。黄烂癞病痈痤痔病不禁黄病疟病。欬嗽消尽。癫狂热病。风肿水肿腹肿。如是种种更有余病着身不。答言无。羯磨师应作是说。大德僧听。某甲从某甲。受具足。某甲已空静处教问讫。某甲已从僧中乞受具足父母已听。已求和上三衣钵。具是男子。年满二十。自说清净无遮法。若僧时到。僧今与某甲受具足和上某甲如是白白三羯磨。乃至僧忍默然故。是事如是持。佛住舍卫城。广说如上。尔时有无岁比丘。着好新净染衣。往世尊所礼拜问讯。是比丘后于余时着垢腻破衣。往世尊所。礼拜问讯。佛知而故问。比丘汝先着好新净染衣来到我所今所著衣何故破坏乃尔。白言此故是先衣但岁久破坏。佛言。汝不能补治耶。白佛言。能治。但无物可补。佛言。汝不能巷中拾故弊衣净浣染补耶。白言。世尊。粪扫衣不净我甚恶之。不能受持。佛语比丘止止。莫作是语。粪扫衣少事易得应净。无诸过随顺沙门法服。依是出家。尔时世尊往众多比丘所。敷尼师坛坐。为诸比丘具说上事。佛告诸比丘。如来应供正遍知欲饶益故。于声闻众中正说制初依。若堪忍直信善男子。与受具足。不堪忍者。不应与受。佛住迦维罗卫尼拘律树释氏精舍。如来应供正遍知五事利益故。五日一行诸比丘房。何等五。我声闻弟子中不好有为事不。不乐说无益语不。不乐着睡眠不。为看病比丘故。为信心善男子。见如来威仪庠序。发欢喜心故。以是五事。行诸比丘房。见一比丘病痿黄羸瘦。佛知而故问。比丘汝气力调和不。白佛言。世尊。我患饥气力不足。佛语比丘。汝不能乞食耶。白言。世尊。是拘萨罗国但乞人残食不乞非残。是残食不净。我不能啖。是故羸瘦。佛语比丘。止止。莫作是语。乞残食少事易得。应净无诸过。依是出家。尔时世尊往众多比丘所。敷尼师坛坐。为诸比丘具说上事。佛告诸比丘。从今日如来应供正遍知欲饶益故。于声闻众中正说制第二依。若堪忍直信善男子。与受具足。不堪忍者。不应与受。佛住舍卫城。广说如上。如来应供正遍知五日一行诸比丘房。见一比丘坐树下。作是语。沙门出家修梵行在树下苦。昼则风吹日炙。夜则蚊虻所螫。我不堪。佛语比丘。止止。莫作是语。树下坐少事易得。应净无诸过。随顺沙门法依是出家。尔时世尊往众多比丘所。敷尼师坛坐。为诸比丘具说上事。佛告诸比丘。从今日如来应供正遍知欲饶益故。于声闻众中正说制第三依。若堪忍直心善男子。与受具足。不堪忍者。不应与受。佛住迦维罗卫尼拘律树释氏精舍。如来应供正遍知五日一行诸比丘房。见一病比丘羸瘦痿黄。佛知而故问。比丘气力调和不。答言。世尊。我病苦气力不和。佛问比丘汝不能服随病药随病食耶。白言世尊。我无药直复无施者。是故病苦。佛问比丘。汝不能服陈弃药耶。白言。世尊。是陈弃药不净。我不能服。佛语比丘。止止莫作是语。陈弃药少事易得。应净无诸过。随顺沙门法。依是出家。尔时世尊往众多比丘所。敷尼师坛坐。为诸比丘具说上事。佛告诸比丘。从今日如来应供正遍知欲饶益故。于声闻众中正说制第四依。若堪忍直心善男子。与受具足。不堪忍者。不应与受。佛住舍卫城。广说如上。尔时都夷聚落有年少婆罗门。求诸比丘出家受具足已。然后受四依粪扫衣少事易得。应净无诸过。随顺沙门法。依是出家。受具足。是中尽寿能堪忍不。答言。不能忍。问言。汝何故出家。答言。我见沙门释子着好细轻衣。我贪着此衣。是故出家。诸比丘言。何有一切比丘出家皆得此好衣。复授第二依乞残食少事易得。应净无诸过。随顺沙门法。依是出家。受具足。是中尽寿能堪忍不。答言。我不堪忍。问言。汝何故出家。答言。我见沙门释子食白粳米饭。种种饼肉饮食。我贪此好食。是故出家。诸比丘言。何有一切比丘出家皆得此好食。复受第三依树下坐少事易得。应净无诸过。随顺沙门法。依是出家。受具足。是中尽寿能堪忍不。答言。不堪忍。诸比丘言。汝何故出家。答言。我见沙门释子坐大房舍重楼阁舍。我贪住此舍。是故出家。诸比丘言。何处一切出家比丘皆得此好舍。复受第四依陈弃药少事易得。应净无诸过。随顺沙门法。依是出家。受具足。是中尽寿能堪忍不。答言。不堪忍。问言。汝何故出家。答言。我见沙门释子服酥油蜜石蜜及余种种药。我贪服此药。是故出家。诸比丘言。何有一切比丘出家皆得此好药。诸比丘以是因缘。往白世尊。佛言。汝云何先与受具足。后授四依。从今日后不得先受具足后授四依。当先授四依。能堪忍者与受具足。若言不堪。不应与受具足。若先授具足。后授四依者。得名受具足一切僧。得越比尼罪。授四依时。应先作求听羯磨。大德僧听。某甲从某甲受具足。某甲已空静处教问讫已。于僧中乞受具足。父母已听已。求和上三衣钵具。是男子年满二十。自说清净无遮法。若僧时到僧某甲和上。某甲欲于僧中说四依。诸大德僧听。某甲和上某甲欲于僧中说四依。僧忍默然故。是事如是持。善男子听。此是如来应供正遍知欲饶益故。于声闻众中正说制四依。若堪忍直信善男子。与受具足。不堪忍者。不应与受依。粪扫衣少事易得。应净无诸过。随顺沙门法。依是出家受具足。得作比丘。是中尽寿能堪忍持粪扫衣不。答言能。若长得钦婆罗衣叠衣。刍摩衣。拘舍耶衣。舍那衣麻衣。丘牟提衣。依乞残食少事易得。应净无诸过。随顺沙门法。依是出家受具足。得作比丘。是中尽寿能堪忍乞食不。答言能。若长得月八日十四日十五日。说戒食筹食请食。依树下坐少事易得。应净无诸过。随顺沙门法。依是出家受具足。得作比丘。是中尽寿能堪忍。树下坐不。答言能。若长得大舍重楼阁舍门舍窟舍。依陈弃药少事易得。应净无诸过。随顺沙门法。依是出家。受具足。得作比丘。是中尽寿能堪忍服陈弃药不。答言能。若长得酥油蜜石蜜生酥及脂。依此四圣种。当随顺学。羯磨师应作是说。大德僧听。某甲从某甲受具足。某甲已空静处教问讫。某甲已从僧中乞受具足。父母已听。已求和上三衣钵具。是男子年满二十。自说清净无遮法。已堪忍四依。若僧时倒。僧今与某甲受具足。和上某甲白如是。大德僧听。某甲从某甲。受具足。某甲已空静处教问讫。某甲已从僧中乞受具足。父母已听已求和上三衣钵具足。是男子年满二十。自说清净无遮法。已堪忍四依。僧今与某甲受具足。和上某甲。诸大德忍僧与某甲受具足。和上某甲忍者僧默然。若不忍便说。是第一羯磨。成就不第二第三亦如是说。僧已忍与某甲受具足竟。和上某甲僧忍默然故。是事如是持。善男子汝已受具足。善受具足一白三羯磨无遮法众僧和合非不和合。十众十众已上。汝今当敬重于佛。敬重于法敬重于比丘僧。敬重和上。敬重阿阇梨。汝已遭遇莫复失。人身难得。佛世难值。闻法亦难。众僧和合意愿成就。难顶礼释师子及诸声闻众。已得具足。如无忧华离于尘水。当依傍修习泥洹善法。已得受具足。此戒序法四波罗夷。十三僧伽婆尸沙。二不定法。三十尼萨耆波夜提。九十二纯波夜提。四波罗提提舍尼。众学法七灭诤法。随顺法。我今略说教诫汝如是。后和上阿阇梨当广为汝说。是名十众受戒五众受具足者。佛住王舍城尸陀林中。时城中有居士。名曰郁虔。宗室豪强财产无量。闻如来出现于世。在尸陀林中。欢喜踊跃。欲请佛及僧施设饭食。庄严室内洒扫涂地时。舍卫城中有居士。名阿那邠坻。素与郁虔特相亲友。来到其家。见其匆务庄严洒扫即问言。居士。何故匆务欲嫁女娶妇。请婆罗门。请王大臣耶。答言。我不嫁女娶妇请婆罗门王及大臣也。汝不闻。白净王子出家成佛。号曰如来应供正遍知。出现于世间耶。今在尸陀林中。我今洒扫严饰。正欲请佛及僧。是故匆务。邠坻闻已。心大欣悦。即便问言。我欲礼觐可得见不。答言。可见。佛者普润见无不益。宜知是时。闻是语已。敬心内发企迟明相。佛照其心。夜放光明。普耀城内邠坻见明。谓是天晓即便起行。门自然开。适向城门。城门复开。出门已有一天祠。近于道侧。欲先礼敬。然后诣佛回向祠门。于时天地还闇。彼即恐怖进退。迷惑。莫知所向。时空中有天。语邠坻言。今正是时。但行莫怖。即说偈言

  牛马车百乘　　皆七宝庄严
  尽持用布施　　计彼之功德
  比汝行一步　　十六不及一
  雪山百龙象　　亦以七宝严
  持用行布施　　功德之福报
  比汝行一步　　十六不及一
  百好天玉女　　七宝璎珞身
  持用行布施　　计彼之福报
  比汝行一步　　十六不及一

尔时阿那邠坻闻此偈已。倍生敬信。寻诣佛所。头面礼足。却住一面。佛为说法。示教利喜。白佛言。世尊。我欲还舍卫城起立精舍。请佛及僧。唯愿世尊哀受我请。复愿世尊遣一比丘鉴理处分。如比罗经中广说。乃至佛告舍利弗目连。汝等往彼观地形势。随僧住便料理处分。安置房舍。舍利弗目连受教。即往至彼。时居士邠坻以十八亿金买地。十八亿金作僧房舍。十八亿金供养众僧。合五十四亿金。是居士方欲更兴供养故。遣富楼那入海采宝。佛威神护念故。四大天王帝释。及梵天王卫护此人。往还七反。大获珍宝。不遭留难。富楼那白邠坻言。唯愿居士听我出家。居士即许。将至佛所。头面礼足。却住一面。白佛言。此人欲出家。唯愿世尊哀愍度脱。佛即度之。既出家已。白佛言。世尊。唯愿为我略说教诫。我欲到输那国土。如说修行。佛即为随顺教诫。如綖经中广说。富楼那受教诫已。到输那国。彼国中有一长者。名曰闼婆。为立栴檀房。此中应广说亿耳因缘。乃至求请出家。富楼那度令出家。作沙弥。乃至七年众僧难得。不得受具足。七年已闼婆作栴檀房成。庄挍严饰。广请众僧施设供养。以房施富楼那。尔时众僧通持律十人。富楼那因僧集故。与亿耳受具足。受具足已。即白和上言。我欲到舍卫礼觐世尊。唯愿听许。答言。随意。汝持我名问讯世尊。并乞五愿。亿耳受教。便行到佛所。头面礼足。却住一面。佛语阿难。为客比丘敷床褥。若语阿难敷床褥者。当知与世尊同房宿。若语尊者陀骠摩罗子者。当知随次与房。如来初夜为诸声闻说法。中夜还房圆光常明。佛问比丘。汝诵经不。答言诵。诵何等经。诵八跋只经。佛言。汝可诵之。即细声诵已。问于句义。一一能答。佛言。善哉。比丘。汝所诵者文字句义。如我先说。尔时世尊即说偈言

  圣人不乐恶　　恶人不乐圣
  若见世间过　　发心趣泥洹

佛言。善哉。我弟子中捷疾解悟亿耳第一。亿耳即起头面礼佛足。持和上名。从佛乞五愿。如来闻是语已晨起往众多比丘所。敷尼师坛坐。佛告诸比丘。富楼那在输那边国。遣亿耳来。从我乞五愿。从今日后听输那边国五愿。何等五。一者输那边地净洁。自喜听日日澡洗。此间半月二者输那边地多礓石土块。及诸刺木听着两重革屣。此间一重。三者输那边地少诸敷具多诸皮韦听彼皮韦作敷具。此间不听四者输那边地少衣物多死人衣。听彼着死人衣。此间亦听。五者输那边地少于比丘听彼五众受具足。此间十众自受具足善来受具足。十众白三羯磨。受具足。输那边地五众白三羯磨。受具足。是名四种受具足。复次佛住舍卫城。广说如上。尔时尊者优波离有二沙弥。一名陀婆伽。二名婆罗伽。此二沙弥小小长养年满二十。欲受具足作是念。若当先与一受者后者必有恨心。得同一和上一众一戒师。一时并受具足不。优波离作是念已。往至佛所。头面礼足却坐一面。具以上事。白佛言。世尊得共一和上一戒师一众。得并受具足不佛言得。如是二人三人亦得并受。不得众受是名受具足。一人二和上三和上众多和上不名受具足。无羯磨师不名受具足。二人三人共一羯磨师。别和上共一众并受。不名受具足。二人羯磨二人三人羯磨三人别。和上共一众并受。不名受具足。复有不名受具足。和上在十人数不名受具足。以欲受具足人足十人数。以比丘尼足十人数。以与欲人足十人数者。不名受具足。若不称和上名字。不称受具足人名字。不称僧名字。不名受具足。若和上说羯磨。受具足人说羯磨比丘尼说羯磨皆不名受具足。若和上在空中。受戒人在空中。僧在空中。一切在空中。皆不名受具足。若半在地半在空中。不名受具足。若隔障不名受具足。半在覆处中间隔障不名受具足。半覆半露地申手不相及不名受具足一切露处坐身手不相及一切覆处不得离见闻处。离者不名受具足。复次不名受具足者。若眠若痴若狂若心乱。若苦病所缠不名受具足。复次不名受具足者。若受具足人不语。若心念若大唤。不名受具足。复次不名受具足者。若遣书遣印举手作相不名受具足。人不现前不问前人。不欲非法不和合众。不成就白。不成就羯磨。不成就。若一一不成就。不名受具足。复次不名受具足者。坏比丘尼净行。贼盗住越济人。五逆六种。不男太少太老。截手截脚。截手脚截耳。截鼻复截耳鼻。若盲若聋。若盲聋若哑。若躄若哑躄。若鞭瘢印瘢。若拔筋克筋曲脊。王臣负债。病外道儿。奴身不具。陋色坏比丘尼净行者。佛住毗舍离。尔时奄婆罗离车童子坏法豫比丘尼弟子梵行。时法豫比丘尼。往世尊所。头面礼足却住一面。白佛言。世尊。离车童子坏我弟子梵行。作是语已。礼佛而去。佛语阿难。汝取我僧伽梨来。入毗舍离城。阿难即取僧伽梨来。授与世尊。如来应供正遍知从成佛已来。未曾食后入城邑聚落。尔时世尊与阿难共入毗舍离城。时五百离车集在论议堂上。欲论余事。遥见世尊来。展转自相谓言。如来有何事故。食后入城。故当有以时梨车等。即起与佛敷座往迎世尊。胡跪合掌。白佛言。善来世尊。唯愿世尊。坐此座上。尔时世尊敷尼师坛坐。诸梨车头面礼佛足。却坐一面。佛语梨车。汝等眷属宜应防护。如我弟子比丘尼。亦应防护。设人侵犯。若欲不欲坏梵行者。如我法中尽寿不共语。不共住。不共食。梨车白佛舍。如世尊法中坏梵行者。不共语。不共住。不共食。我俗法中亦复如是。尽寿不共语。不共住。不共食。尔时世尊为诸梨车随顺说法。发欢喜心已而去。去不久。法豫比丘尼寻至梨车所。作是语。诸居士奄婆罗。梨车童子坏我弟子梵行。此是不善非是顺法。诸梨车闻已。自相谓言。世尊向所说正为此耳。即大惭愧。语比丘尼言。欲使我等作何等治。比丘尼言。当易其姓唱非梨车回门西向。破其食厨。坏其屋檐。周匝一肘。答言。受教。即唱非梨车回门西向。乃至毁其屋檐。尔时世尊往众多比丘所。敷尼师坛坐。以是上事。具为诸比丘说。破尼净行者。若阿罗汉尼阿那含尼。若初中后一切皆名坏尼净行。若斯陀含尼须陀洹尼凡夫持戒尼。初若受乐者。是名坏尼净行。中后不名坏。尔时有摩诃罗。本俗人时坏比丘尼净行。心生疑惑。即白佛言。世尊。我本俗人时。坏比丘尼净行。佛告诸比丘。是摩呵罗自言。坏比丘尼净行驱出。诸比丘即驱出。若坏比丘尼净行。不应与出家。若已出家者应驱出。若度出家受具足。越比尼罪。是名坏比丘尼净行盗住者

佛住舍卫城。广说如上。尔时有檀越。就精舍中饭僧。时有一人。黑色大腹来在上座处坐。须臾僧上座来问。汝几腊。答言。坐处食饭一种用。苦问岁为上座。威德严肃。言咄。汝下去。复坐第二上座处。须臾第二上座来问。汝几岁。答言。坐处食饭一种用。苦问为如是展转。乃至沙弥中沙弥推排。问言。谁是汝和上。谁是汝师沙弥有几戒。沙弥应数有几。初名何等。一者一切众生皆仰食。二二名色。三三痛想。四四圣谛。五五阴。六六入。七七觉意。八八正道。九九众生居。十十一切入沙弥法。应如是数。答言。我是难陀优波难陀上众弟子。诸比丘以是因缘。往白世尊。佛言。非难陀优波难陀上众弟子。此是自出家人。若如是人比未曾入布萨自恣中。后有好心得与出家受具足。若曾入布萨自恣中者。是名盗住。不听出家受具足。若王子若大臣子避难故。自着袈裟。未经布萨自恣者。得与出家。若曾经布萨自恣者。不听出家。若沙弥作是念。说戒时论说何等。即先入上座床下盗听。若沙弥聪明。若觉知初中后语者。后不得受具足。若闇钝若眠。若意缘余念。不记初中后语者。后得受具足。若盗住不应与出家。若已出家者。应驱出。若度出家受具足者。得越比尼罪。是名盗住。越济者。佛住舍卫城。广说如上。尔时有人。食前着沙门标帜。手捉黑钵入聚落乞食。食后着外道标帜。手捉木钵。复逐人入林中池水园观处乞食。为世人所嫌。云何沙门释子入聚落中。从我家乞食。今来入林。复不得脱。复有人言。汝不知耶。此沙门谄曲为衣食故。兼两入。诸比丘以是因缘。往白世尊。佛言。此名越济人舍沙门标帜。执外道标帜。舍外道标帜复执沙门标帜。如是越济人不应与出家。若与出家者。应驱出。若度出家受具足者。得越比尼罪。是名越济人五无间者。佛住舍卫城广说如上。尔时都夷婆罗门。是舍利弗旧善知识。来至舍利弗所作是言。尊者。与我出家。舍利弗答言。此是好事。汝婆罗门常与沙门相反。何处得信心。从谁闻法。发欢喜心。世尊边耶。诸比丘边耶。婆罗门言我亦无信心。复无欢喜。亦不从他闻。但我杀母欲除此罪。是故出家。舍利弗言。待我问世尊还。舍利弗以是因缘。往白世尊。佛言。此人杀母作无间罪。腐败烂种。于正法中不生圣法。不应与出家。复次佛住舍卫城。广说如上。都夷婆罗门是阿难旧善知识。往阿难所作是言。尊者。我欲出家。阿难言。此是好事。乃至佛语阿难。此人杀父作无间罪。腐败坏烂。于正法中不能生道根栽。正使七佛一时出世。为其说法。于正法中终不生善。喻如多罗树头断则不生。不青亦不中种。是五无间罪亦复如是。于正法中不生圣种。若作五无间罪者。不应与出家。已与出家者。应驱出。若度出家受具足。越比尼罪。余三无间亦如是。是名五无间罪。六种不能男者。佛住舍卫城。广说如上。尔时诸比丘夜房中眠。有人来摸索脚摸索髀腹。复至非处。比丘欲捉取。便走出去。复到余处。堂上温室处处如是。明日诸比丘共聚一处。自相谓言。诸长老。昨夜眠时有人来。处处摸索。乃至非处。正欲捉取。即便走去。复有比丘言。我亦如是。乃至众多亦复如是。有一比丘作是念。我今夜要当伺捕捉取。是比丘至暮。先眠伺之。诸比丘眠已。复来摸索如前。即便捉得。作是语。诸长老。使持灯来。来已问言。汝是谁。答言。我是王女。复问云何是女。答言。我是两种非男非女。复问。汝何故出家。答言。我闻沙门无妇。我来欲为作妇。诸比丘以是因缘。往白世尊。佛言。是不能男。不能男者有六种。何等六。一者生。二者捺破三者。割却四者因他。五者妒。六者半月生者。从生不能男。是名生。捺破者妻妾生儿。共相妒嫉。小时捺破。是名捺破。不能男割去者。若王大臣取人割却男根。以备门合。是名割却不能男。因他者。因前人触故。身生起。是名因他不能男。妒者。见他行淫事。然后身生起。是名妒不能男。半月者。半月能男半月不能男。是名半月不能男。是中生不能男。捺破不能男。割却不能男。此三种不能男。不应与出家。若已出家者。应驱出。因他起不能男。妒不能男。半月不能男。是三种不能男。不应与出家。若已出家者。不应驱出。后若淫起者。应驱出。是六种不能男。不应与出家。若度出家受具足者。越比尼罪。是名六种不能男大少者。佛住舍卫城广说如上。尔时诸比丘度小儿出家。卧起须人扶持。出入屎尿不净污僧卧褥。眠起啼唤。为世人讥嫌。云何沙门释子度小儿出家。未知宜法语言好恶此坏败人何道之有。复有人言。汝知不耶是沙门无儿。养他小儿作己生想。以自娱乐。复有人言。是诸沙门唯不度二种人。一者死人。二者前人不乐出家。若不度者。众不增长。是故多度。诸比丘以是因缘。往白世尊。佛言。唤是比丘来。来已佛具问上事。汝实尔不。答言。实尔。佛言。从今日后太少不应与出家。太少者。若减七岁若满七岁。不知好恶。皆不应与出家。若满七岁解知好恶。应与出家。若小儿先已出家。不应驱出。若度出家者。越毗尼罪。是名太少。太老者。佛住舍卫城广说如上。尔时诸比丘度八十九十人出家。头白背偻脊屈隐现。诸根不禁。或小便时大便漏出。进止须人。不能自起。若于房中温室中。洗脚处经行处。短气连欶洟唾流迸湔。污僧净地。为世人所讥。云何沙门释子度此老翁头白背偻欬嗽振动。起止须人。出家之人宜应康健。坐禅诵经修习诸业。此坏败人何道之有。复有人言。汝不知耶沙门释子出家无父。养此老翁当作父想。复有人言。此诸沙门唯二种人不度。一者死人。二者不欲出家。若不度者。众不增长。诸比丘以是因缘。往白世尊。佛言。唤是比丘来。来已佛具问上事。汝实尔不答言。实尔。佛言。从今日后太老不应与出家。太老者过七十。若减七十。不堪造事。卧起须人。是人不听出家。若过七十能有所作。是亦不听。年满七十康健能修习诸业。听与出家。若太老不应与出家。若已出家者。不应驱出。若度出家受具足者。越比尼罪。是名太老。截手者。佛住舍卫城。广说如上。尔时有比丘。度截手人出家。为世人所讥。云何沙门释子度犯王法截手人出家。出家之人应身体完具。此坏败人有何道法。诸比丘以是因缘。往白世尊。佛言。唤是比丘来。来已佛问比丘。汝实尔不。答言。实尔。佛言。从今日后截手人。不应与出家。截手者。若截手若截腕。若截小指若大指。不应与出家。若已出家不应驱出。若度出家受具足者。越比尼罪。是名截手。截脚者。佛住舍卫城。广说如上。尔时有比丘。度截脚人出家。为世人所讥乃至佛言从今日后截脚人。不应与出家。截脚者。若截脚若截腕若小指若大指。不应与出家。若已出家者。不应驱出。乃至得越比尼罪。是名截脚。截手脚者。佛住舍卫城。广说如上。尔时比丘度截手脚人出家。为世人所讥。云何沙门释子度犯王法截手脚人。一事不具尚不得出家。况复两事。此坏败人何道之有。诸比丘以是因缘。往白世尊。佛言。唤是比丘来。来已佛问比丘。汝实尔不。答言。实尔。佛言。从今日后截手脚人不应与出家。截手脚者。若截右手左脚。若截左手右脚。若截左手左脚。若截右手右脚。不应与出家。若已出家者。不应驱出。若与出家受具足者。越比尼罪。是名截手脚。截耳者。佛住舍卫城。广说如上。尔时有比丘。度截耳人出家。为世人所讥。云何沙门释子度犯王法截耳人。乃至佛言。从今日后。截耳人不应与出家。截耳者若截耳若截耳轮。若先穿耳决能令还合者。得与出家截耳人不应与出家。若已出家者。不应驱出。若度出家受具足者。越比尼罪。是名截耳。截鼻者。佛住舍卫城。广说如上。尔时诸比丘度截鼻人出家。为世人所嫌。云何沙门释子度犯王法截鼻人出家。此坏败人有何道法。诸比丘以是因缘。往白世尊。乃至佛言。从今日后。截鼻人不应与出家。截鼻者若截鼻若决鼻。不应与出家。乃至是名截鼻。截耳鼻者。佛住舍卫城。广说如上。尔时比丘度截耳鼻人出家。为世人所讥。云何沙门释子度截耳鼻人出家。截一尚不得出家。况复截两。此坏败人何道之有。诸比丘以是因缘。往白世尊。乃至佛言。从今日后。截耳鼻人不应与出家。乃至是名截耳鼻。盲者。佛住舍卫城。广说如上。尔时有比丘度盲人出家。牵臂将行。为世人所讥。云何沙门释子度盲人出家。不能自行。捉手牵之。出家之人宜当诸根具足。此坏败人何道之有。诸比丘以是因缘。往白世尊。佛言。唤是比丘来。来已佛问比丘。汝实尔不。答言。实尔。佛言。从今日后。盲人不应与出家。盲者眼一切不见色。若见手掌文者。若雀目不得与出家。若已出家不应驱出。若与出家受具足者。越比尼罪。是名盲。聋者。佛住舍卫城。广说如上。尔时比丘度聋人出家。为世人所讥。云何沙门释子度聋人出家不闻善恶语言。何能听法。此坏败人何道之有。诸比丘以是因缘。往白世尊。乃至佛言。从今日后。聋人不应与出家。聋者不闻一切声。若闻高声者。得与出家。乃至是名聋。盲聋者。佛住舍卫城。广说如上。尔时有比丘度盲聋之人出家。为世人所讥。云何沙门释子度盲聋之人出家。不能见闻。出家之人宜当诸根具足。盲者尚不得。况复盲聋。此坏败人何道之有。诸比丘以是因缘往白世尊。乃至佛言。从今日后盲聋人不应与出家。乃至是名盲。聋哑者。佛住舍卫城。广说如上。尔时比丘度哑人出家。手作相语。为世人所讥。云何沙门释子度哑人出家。不能语言。而作手相语。此坏败人何道之有。诸比丘以是因缘。往白世尊。乃至佛言。从今日后哑人不应与出家。哑者不能语用。手示语。相不应与出家。若已出家者。不应驱出。乃至是名哑。躄者。佛住舍卫城。广说如上。尔时比丘度躄人出家。为世人所讥。云何沙门释子度躄不能行人出家。此坏败人何道之有。诸比丘以是因缘。往白世尊。乃至佛言。从今日后躄人不应与出家。躄者两手捉屐曳尻而行。不应与出家。若已出家不应驱出。乃至是名躄。哑躄者。佛住舍卫城。广说如上。尔时诸比丘度哑躄人出家。乃至与出家受具足者。越比尼罪。是名哑躄。鞭瘢者。佛住舍卫城。广说如上。尔时比丘度鞭瘢人出家。为世人所讥。云何沙门释子度犯王法鞭瘢人出家。出家之人应当身体完净。此坏败人何道之有。诸比丘以是因缘。往白世尊。佛言。唤是比丘来。来已佛问。汝实尔不。答言。实尔。佛言从今日后鞭瘢人不应。度出家鞭瘢者。若凸若凹。若能治瘢还平复。与肉肤不异者。得与出家。鞭瘢人不应与出家。若已出家者不应驱出。若与出家受具足者。越比尼罪。是名鞭瘢。印瘢者。佛住舍卫城。广说如上。尔时比丘度印瘢人出家。为世人所讥。云何沙门释子度犯王法印瘢人出家。出家之人宜当完净。此坏败人何道之有。诸比丘以是因缘。往白世尊。乃至佛言。从今日后印瘢人不应与出家。印瘢者。破肉以孔雀胆铜青等画作字作种种鸟兽像。不应与出家。若已出家者。不应驱出。若与出家受具足者。越比尼罪。是名印瘢。克筋者。佛住舍卫城。广说如上。尔时有比丘。度克筋人出家。曳脚而行。为世人所讥。云何沙门释子度克筋人出家。曳脚而行。出家之人应身体完具。此坏败人何道之有。诸比丘以是因缘。往白世尊。乃至佛言。从今日后克筋人不应与出家。克筋者克。脚踵筋。不应与出家。乃至越比尼罪。是名克筋。拔筋者。佛住舍卫城。广说如上。尔时比丘度拔筋人出家。为世人所讥。云何沙门释子度拔筋人出家。出家之人应当身体完具。诸比丘以是因缘。往白世尊。乃至佛言。从今日后拔筋人不应与出家。拔筋者。从脚跟抽至项顀。从项顀抽至脚跟。不应与出家。乃至越比尼罪。是名拔筋。伛脊者。佛住舍卫城广说如上。尔时比丘度曲脊侏儒人出家。为世人所讥。云何沙门释子。度王家戏弄曲脊人出家。出家之人应当身体调直。此坏败人何道之有。诸比丘以是因缘。往白世尊。乃至佛言。从今日后曲脊人不应与出家。曲脊者不正直也。侏儒者。或上长下短。或上短下长。一切最短者。是不应与出家。乃至越比尼罪。是名侏儒

摩诃僧祇律卷第二十三摩诃僧祇律卷第二十四

        东晋天竺三藏佛陀跋陀罗共法显译

    明杂诵跋渠法之二

王臣者。佛住王舍城迦兰陀竹园。广说如上。尔时有比丘度王臣出家。受具足已。禁官见已。合捉比丘送与断事官所。作是言。此沙门私度王臣。断事官言。取和上打三肋折。取戒师挽舌。出十众合。各与八下鞭。受具足者极法治罪。尔时众多人即卫送出城时。频婆娑罗王欲诣世尊。见此众人。王问言。是何等人。即以上事具白王。王闻已大嗔。即敕令放从今日已后欲出家者。恣听师度。王言。呼断事官来。来已王问言。此国中谁是王。臣答言。大王是王。便问。若我是王者何故不白辄治人罪。王即敕有司取断事者。夺其官位。家中财物没入官库。诸司官即如王教。夺其官位。籍其家财没入官库。诸比丘以是因缘。往白世尊。佛语比丘。何处一切王皆信心如是。从今日后王臣不听与出家。臣者四种。或有名而无禄。或有禄而无名。或有禄有名。或无名无禄。是中有名无禄。有名有禄者。此国不听出家。余国亦不听。有禄无名此间不听。余处听。无名无禄此间听。余处亦听。王臣不应与出家。乃至越比尼罪。是名王臣。负债者。佛住舍卫城。广说如上。尔时有比丘度负债人出家。债主来见。即捉将诣断事官所。作是言。此人负我债不偿而便出家。断事官信心佛法。语彼人言。此人舍弃财产出家。何故复债。即便放去。债主嫌言。云何沙门释子此负债人。食我钱财而度出家。此坏败人何道之有。诸比丘以是因缘。往白世尊。佛言。呼是比丘来。来已佛问。比丘。汝实尔不。答言。实尔佛言。从今日后负债人不应与出家。若来欲与出家者。当先问。汝不负人债不。答言负。我家中有人妇儿田宅财物。自有偿者。应与出家若言不负应与出家。出家已债主来者。若是小小债持彼衣钵偿。若复不足。当自以衣钵偿。若乞索助偿。若多不能得偿者。应语。我先问汝。非负债人不。汝自言不负。汝自去乞索偿之。若负债人不应与出家。若已出家不应驱出。乃至越比尼罪是名负债。病者。佛住舍卫城迦兰陀竹园。广说如上。尔时有病人。至耆域医所作是言。耆域与我治病。当雇五百两金两张细[疊*毛]。答言。不能。我唯治二种人病。一者佛比丘僧。二王王后宫夫人。病人即向难陀优波难陀房。到已难陀问言。长寿四大调适不。答言。病不调适。我往诣耆域所。以五百两金两张细[疊*毛]。雇治病而不肯治言。我唯治二种人病。佛比丘僧王王后宫夫人。难陀言。汝用弃五百两金两张[疊*毛]。为汝但舍二种事。一者舍发。二舍俗衣。病人言。阿阇梨。欲令我出家耶。答言然。即度出家受具足已。晨起着入聚落衣。到耆域所。作是言。童子。我有共行弟子。病与我治之。答言。可尔。正当持药往。即持药。往见已。便识问言。尊者已出家耶。答言尔。赞言善哉。今当为治。即与药疗治。治已以两张细[疊*毛]施与。作是言。尊者。于佛法中净修梵行。受取已即罢道。脱去袈裟着两张细[疊*毛]。巷中作如是骂言。耆域医师众多人子。我雇五百两金两张细[疊*毛]。而不肯治。见我出家便与我治反更得[疊*毛]。耆域闻已。心怀怅恨。往世尊所。头面礼足却住一面。白佛言。世尊。此人蒙我得活反见骂辱。世尊。我是优婆塞。增长佛法故。唯愿世尊。从今日后勿令诸比丘度病人出家。尔时世尊为耆域童子。随顺说法。示教利喜。礼足而退。尔时世尊往众多比丘所。敷尼师坛坐已。具以上事为诸比丘说佛言。从今日后病人不应与出家。病者。癣疥黄烂。癞病痈痤痔病不禁。黄病疟病。謦嗽消尽。癫狂热病风肿水肿腹肿。乃至服药未得平复。不应与出家若疟病者。若一日二日三日四日中间不发时得与出家。若病人不应与出家。若已出家者。不应驱出。若度出家受具足者。越比尼罪。是名病外道者。佛住舍卫城。广说如上。尔时有比丘度外道出家。出家已在其前。说外道过言。外道不信邪见。犯戒无惭无愧。如是毁呰外道过。彼闻已作是言长老。莫作是语。彼间亦有贤善。亦有持戒。一切尽有须陀洹斯陀含阿那含阿罗汉。诸比丘以是因缘。往白世尊。佛言。呼是比丘来。来已佛具问上事。汝实尔不。答言。实尔。佛言。汝云何外道不试而与出家。从今日后外道不试不应与出家。若外道来欲出家者。当共住试之四月。所投比丘应白僧。白僧已。僧先应与作求听。羯磨。然后听乞羯磨人应作是说。大德僧听。某甲外道。欲于如来法中出家。若僧时到僧某甲外道。欲于僧中乞试四月。诸大德听。某甲外道。欲于僧中乞试四月。僧忍默然故。是事如是持。此人应从僧中乞。作如是言。大德僧听我外道某甲。欲于如来法律中出家受具足。我某甲从僧乞试四月住。唯愿大德。僧哀愍故。与我四月住法。如是三乞羯磨人应作是说。大德僧听。外道某甲。欲于如来法中出家受具足。已从僧中乞试四月。若僧时到僧今与外道某甲。试四月住。白如是。大德僧听。外道某甲欲于如来法中出家受具足。已从僧中乞试四月。僧今与外道某甲。试四月住。诸大德忍僧与外道某甲。试四月住忍者默然。若不忍者便说僧已。与外道某甲试四月住竟。僧忍默然故是事如是持。作羯磨已。若能如沙弥随僧作务者。在沙弥下。次第取食若不能者应语。汝自求食。应日日在前毁呰外道。不信邪见。犯戒无惭无愧。如是种种毁呰。若言长老莫作是语。彼间亦有贤善。亦有持戒。一切尽有须陀洹斯陀含阿那含阿罗汉。应语言。汝还去。彼间求阿罗汉。若言。实如长老所说外道邪见。乃至无惭无愧。作泥犁行长老愿拔济我。若试满四月心不动移者应与出家。若中间得圣法者即名试竟。若舍外道幖帜。着俗人服来者。应与出家。若着外道幖帜来者。不试四月。与出家受具足者越比尼罪。是名外道儿者。佛住迦维罗卫国尼拘律树释氏精舍。广说如上。尔时释家童子父母不放。诸比丘度出家。后诸子辈父母教诲嗔恨言。世尊临得转轮圣王。犹舍出家。我何所顾恋。而不出家。尔时释种往白净王所白言。大王。我子不放而诸比丘便度出家。余在家者不可教诲。设加教诲怀恨出家而言。世尊临得转轮圣王位犹舍出家。我何所顾恋而不出家。唯愿大王。从世尊乞。愿父母不放勿令出家。尔时白净王与众多释种。往世尊所。头面礼足却坐一面。王白佛言。世尊。诸比丘释种。童子。父母不放而与出家余在家者。设有。教诲怀恨出家言世尊临得转轮圣王位。犹舍出家。我何所顾恋而不出家。世尊。父母念子爱彻骨髓我亦曾尔。世尊。出家七年之中坐起食饮无日不啼。惟愿世尊。制诸比丘。父母不听勿令出家。尔时世尊为白净王。随顺说法发欢喜心。头面礼足而退。王去不久。世尊往众多比丘所。敷尼师坛坐。具以上事为诸比丘说。佛言。从今日后父母不放不应与出家。儿者有三种。亲儿。养儿。自来儿。亲儿者。父母所生。养儿者小小乞养之。自来儿者。自来依附作儿。是中亲儿者此国不听余国亦不听养儿自来儿。此国不听。余国听。若父母不放不应与出家。若已出家者。不应驱出。若与出家受具足者。越比尼罪是名儿。奴者。佛住迦维罗卫国尼拘律树释氏精舍。广说如上。时释种家奴不放诸比丘度出家。后诸奴辈大家教诲分处作务而。不肯顺从怼恨而言。尊者阐陀犹尚出家。我何所顾恋。当舍出家。反受礼拜恭敬供养。时诸释种往白净王所白言。大王。我等家奴不放。诸比丘度出家。余者不可分处作务。怼恨而言。尊者阐陀犹尚出家。我何所顾恋。当舍出家。反受礼拜恭敬供养。大王。我等释种多诸奴仆。赖此作使。唯愿大王。从佛乞愿奴主不放勿令出家。尔时白净王与诸释种往世尊所。头面礼足却坐一面。即以上事具白世尊。唯愿世尊。从今日后制诸比丘。奴主不放勿令出家。尔时世尊为白净王。随顺说法。发欢喜心已。王即头面礼足而退。王去不久。世尊往众多比丘所。敷尼师坛坐。具以上事为诸比丘说。佛告诸比丘。从今日后奴主不放。不应与出家。奴者五种。家生。买得。抄得。他与。自来。家生者。家中婢妾生。买得者雇钱买得。抄得者。抄邻国得。他与者。他人与。自来者。自来作奴。是中家生钱买抄得此三种。此间不听。余处亦不听。他与自来此二种。此间不听。余处听。若奴主不放不应与出家。若已出家者。不应驱出。若与出家受具足者。越比尼罪。是名奴。身分不端正者。佛住舍卫城。广说如上。尔时诸比丘度人出家。种种身分不端正。为世人所讥。云何沙门释子度人身分不端正。出家之人应身端严。此坏败人何道之有。诸比丘以是因缘。往白世尊。佛言。呼是比丘来。来已佛具问上事。汝实尔不。答言。实尔。佛言。从今日后身分不端正人。不应与出家。身分不端正者。眼瞎偻脊。跛脚脽脚。龋齿瓠卢头。如是种种身分不端正。不应与出家。若已出家者。不应驱出。若度出家受具足者。越比尼罪。是名身分不端正。陋形者。佛住舍卫城。广说如上。诸天世人之所供养。尔时诸比丘度陋形人出家。太黑太白太黄太赤。太长太短太粗太细。为世人所讥。云何沙门释子度陋形人出家。出家之人形应端严。此人丑陋人不喜见。此坏败人有何道法。复有人言。此沙门唯二种人不度。一者死人。二者不乐出家。若不度此众不增长。诸比丘以是因缘。往白世尊。佛言。呼是比丘来。来已佛具问上事。汝实尔不。答言。实尔。佛言。从今日后陋形人不应与出家。陋形者太黑太白太黄太赤。太长太短衣粗太细。复次陋形之人喜尚不喜见。况复嗔恚时。是陋形人不应与出家。若已出家不应驱出。若度出家受具足者。越比尼罪。是名陋形。是谓不名受具足。是中清净如法者。名受具足羯磨羯磨事羯磨者。佛住舍卫城。尔时瞻波比丘诤讼起不和合住。一比丘举一比丘。二比丘举二比丘。众多比丘举众多比丘。诸比丘以是因缘。往白世尊。佛言。从今日后不听一人举一人。乃至众多人举众多人。佛告诸比丘。从今日后应作羯磨。羯磨者。四羯磨。二羯磨。白一羯磨。白三羯磨。四众作羯磨。五众作羯磨。十众作羯磨。二十众作羯磨。成就五非法不和合作羯磨已。后悔成就五如法和合。作羯磨已。后不悔四羯磨者。有非法和合羯磨有如法不和合羯磨。有如法和合羯磨。有不如法不和合羯磨。是名四羯磨。二羯磨者。布萨羯磨恭敬羯磨。是名二羯磨。白一羯磨者。有二十八。何等二十八。出羯磨不离衣宿。离衣宿示房处。示作大房处。有示作前房处。行钵人行舍罗人试外道。持杖络囊。典知床褥。典知鉴食。典知差次食。典知分房。典知取衣。典知掌衣。典知分衣。典知取[疊*毛]。典知举[疊*毛]。典知分[疊*毛]。典知分华。典知分香。典知分果。典知分温水。典知分杂饼。典知随意举。典知分粥人。典知分小小杂物。是名二十八。白三羯磨有八。何等八。一折伏二不语三摈出。四发喜。五举六别住。七摩那埵。八阿浮呵那。是名白三羯磨。四众羯磨者。布萨羯磨一切拜人四人得作。是名四众羯磨。五众羯磨者。受自恣输那边地受具足。一切尼萨耆五人得作。是名五众羯磨。十众羯磨者。比丘受具足比丘尼受具足。十人得作。是名十众羯磨。二十众羯磨者。比丘阿浮呵那。比丘尼阿浮呵那。二十人得作。是名二十众羯磨。成就五非法作羯磨已。后悔者人不现前。不问不引过。非法不和合。是名五非法。作羯磨已后悔。成就五如法作羯磨已。后不悔者。人现前问。问已自引过。如法和合。是名五如法。作羯磨。已后不悔是。中应二十众作羯磨。十众作不成就应。十众作羯磨。五众作不成就。应五众作羯磨。四众作不成就。应作白三羯磨。白一不成就应作白一羯磨。单白不成就。应单白羯磨而作求听羯磨不成就。应作求听羯磨白成就。应作白羯磨。白一羯磨成就。应作白一羯磨。作白三成就。应作四众羯磨。若五众作成就。应五众作羯磨。十众作成就。应十众作羯磨。二十众作成就。是名羯磨。羯磨事者。比丘受具足羯磨事。比丘尼受具足羯磨事。支满羯磨事。遮法清净羯磨事。不具足清净羯磨事。不生戒羯磨事。罪根羯磨事。不舍根羯磨事。舍根羯磨事。和合根羯磨事。比丘受具足羯磨事者。受具足人求和上。和上与求衣钵。与求众与求戒师。与求空静处教师。是诸事能生羯磨。白羯磨。是二俱名比丘受具足羯磨事。比丘尼受具足羯磨事者。比丘尼已与受具足竟。向比丘僧中。僧应问比丘尼。清净无遮法不。答言。已清净。是诸事能生羯磨。白羯磨。是二俱名比丘尼受具足羯磨事。支满羯磨事者。受具足人已求和上。和上已与求衣钵。与求众与求戒师。与求空静处教师。教师推与僧。从僧中乞受具足。问无遮法。已说四依。是诸事能生羯磨白羯磨。是二俱名支满羯磨事。遮法清净羯磨事者。遮法中清净。是诸事能生羯磨。白羯磨。是二俱名遮法清净。羯磨事不具足。清净羯磨事者。支分不具足清净。是诸事能生羯磨。白羯磨是二俱名不具足清净羯磨事。不生戒羯磨事者。污比丘尼净行。盗住越济人。五无间罪犯波罗夷。沙弥恶邪见。是诸事不生羯磨。白羯磨。是二俱名不生戒羯磨事。罪根羯磨事者。五众罪波罗夷。僧伽婆尸沙。波夜提。波罗提。提舍尼。越比尼罪。是诸事能生羯磨。白羯磨。是二俱名罪根羯磨事。不舍根羯磨事者。比丘屏处三谏。多人中三谏。众僧中三谏。不舍是诸事。能生羯磨。白羯磨。是二俱名不舍根羯磨事。舍根羯磨事者。屏处三谏。众多人中三谏。僧中三谏。舍是诸事。能生羯磨。白羯磨。是二俱名舍根羯磨事。和合根羯磨事者。比丘僧集行舍罗。不来者。与欲唱和合僧。是诸事能生羯磨。白羯磨。是二俱名和合根羯磨事。是谓羯磨事。折伏羯磨事者。佛住舍卫城。瞻婆比丘诤讼。相言不和合住。诸比丘以是因缘。往白世尊。佛言。应与作折伏羯磨。折伏羯磨有五事。一切折伏羯磨。佛在舍卫城。制何等五。一习近八事。二数数犯罪。三太早入太冥出。恶友恶伴非宜处行。四诤讼相言。五恭敬年少。习近八事者。佛住舍卫城。尔时慈地比丘。身习近住。口习近住。身口习近住。身习近住者。共床坐共床眠。共器食迭互着衣。共出共入。是名身习近住。口习近住者。迭互染污心语。是名口习近住。身口习近住者。共床坐共床眠。共器食迭互着衣。共出共入。语时展转相为染污心语。是名身口习近住。诸比丘谏言。长老慈地比丘莫身习近住。口习近住身口习近住。一谏不止。乃至三谏不止。诸比丘以是因缘。往白世尊。佛言。是慈地比丘身习近。口习近。身口习近住。三谏不止者。僧应与作身习近住折伏羯磨。羯磨人应作是说。大德僧听。是慈地比丘身习近住。三谏不止。若僧时到僧与慈地比丘身习近住。作折伏羯磨。白如是。大德僧听。慈地比丘身习近住。三谏不止。僧今与慈地比丘身习近住。作折伏羯磨。诸大德忍。僧与慈地比丘身习近住。作折伏羯磨。忍者僧默然。若不忍者。便说是第一羯磨。第二第三亦如是说。僧已忍。与慈地比丘作身习近住折伏羯磨竟。僧忍默然故。是事如是持。口习近住身口习近住。亦如是说。复次佛住舍卫城。尔时优陀夷与好生比丘尼。身习近住。口习近住。身口习近住。身习近住者。申手内共坐迭互着衣。是名身习近住。口习近住者。展转染污心语。是名口习近住。身口习近住者。申手内共坐迭互着衣更相为语。共染污心语。是名身口习近住。诸比丘谏言。长老。优陀夷莫与好生比丘尼。身习近住。口习近住。身口习近住。一谏二谏三谏不止。诸比丘以是因缘。往白世尊。佛告诸比丘。是优陀夷与好生比丘尼。身习近住。口习近住。身口习近住。三谏不止者。僧应与作身习近住折伏羯磨。羯磨人应作是说。大德僧听。是优陀夷与好生比丘尼。身习近住。三谏不止。若僧时到僧与优陀夷。作身习近住折伏羯磨。如是白。白三羯磨。乃至僧忍默然故。是事如是持。口习近住。身口习近住。亦如上说。复次尔时跋陀梨比丘。与跋陀尸利比丘尼。身习近住。口习近住。身口习近住。亦如上优陀夷中广说。复次佛住舍卫城。尔时苏毗提比丘。与苏毗提夷比丘尼。身习近住。口习近住。身口习近住。如好生比丘尼中广说。复次尔时有比丘。到居士家内。与妇人身习近住口习近住。身口习近住。身习近住者。与母人申手内坐。以香花果蓏相授。为其走使。是名身习近住。口习近住者。共染污心语。是名口习近住。身口习近住者。是上二事俱是名身口习近住。诸比丘谏言。长老。莫与妇人身习近住。口习近住。身口习近住。如是三谏不止。诸比丘以是因缘。往白世尊。亦如上优陀夷中广说。复次佛住舍卫城。尔时有比丘与不能男身习近住。口习近住。身口习近住。身习近住者。申手内坐共出共入。是名身习近住。口习近住者。共染污心语。是名口习近住。身口习近住者。上二事俱是名身口习近住。诸比丘谏言。长老。莫与不能男身习近住。口习近住。身口习近住。乃至三谏不止。诸比丘以是因缘。往白世尊。亦如上优陀夷中广说。复次佛住舍卫城。尔时优陀夷与共行弟子身习近住。口习近住。身口习近住。亦如上慈地比丘中广说。复次佛住舍卫城。尔时阐陀与童子身习近住。口习近住。身口习近住。亦如上慈地比丘中广说。是名八事习近住。数数犯罪者。佛住舍卫城。尔时尸利耶婆比丘五众。一一罪中数数犯。诸比丘谏言。长老。五众一一罪中莫数数犯。一谏不止。二谏不止。三谏不止。诸比丘以是因缘。往白世尊。佛告诸比丘。是尸利耶婆五众。一一罪中若数数犯者。作数数犯罪折伏羯磨。羯磨人应作是说。大德僧听。是尸利耶婆比丘数数犯罪。三谏不止。若僧时到僧与尸利耶婆比丘作数数犯罪折伏羯磨白如是。大德僧听。尸利耶婆比丘数数犯罪。三谏不止。僧今与尸利耶婆比丘。作数数犯罪折伏羯磨。诸大德忍。僧与尸利耶婆比丘作数数犯罪折伏羯磨。忍者僧默然。若不忍者。便说是第一羯磨。第二第三亦如是说。僧已与尸利耶婆比丘。作数数犯罪折伏羯磨竟。僧忍默然故。是事如是持。是名数数犯罪。太早入太冥出恶友恶伴非处行者。佛住舍卫城。尔时迦露比丘太早入聚落太冥出聚落。恶友恶伴非处行。太早入者。太早入聚落乞。太冥出者。冥出聚落。恶友者。与象子马子偷儿劫贼摴蒱儿。如是等共相亲厚。恶伴者。如恶友。同非处行者。寡妇家大童女家淫女家。不能男家。丑名比丘尼丑名沙弥尼。如是非处行。诸比丘谏言。长老。莫太早入太冥出。乃至丑名沙弥尼处行。一谏不止。二谏三谏不止。诸比丘以是因缘。往白世尊。佛告诸比丘。是迦露比丘太早入太冥出。乃至非宜处行。三谏不止者。僧应作太早入折伏羯磨。羯磨人应作是说。大德僧听。迦露比丘太早入聚落。三谏不止。若僧时到。僧今与迦露比丘作太早入聚落折伏羯磨。如是白。白三羯磨。乃至僧忍默然故。是事如是持。如是太冥出恶友恶伴非宜处行。亦如是。诤讼相言者。佛住舍卫城。尔时马宿比丘自高自用诤讼相言。诸比丘谏言。长老马宿比丘莫诤讼相言。如是一谏不止。二谏三谏不止。诸比丘以是因缘。往白世尊。佛告诸比丘。五法成就。当知诤讼。更起何等五法羯磨言非法。如法集言非法。如法出过言非法。如法舍言非法。如法与言非法。是名五非法。反上五事名如法。诸比丘应如是教。长老。比丘必应成就五法入众。何等五。小声入众闻羯磨已。当信信已奉行。若羯磨不如法不能遮者。应与欲。若不能与欲者。应与比坐见不欲。比丘闻是教时。便言。我能善语。何故小声入众。我亦多闻。何故闻羯磨已。当信我善知法。何故闻已当行。我亦善于羯磨。何故闻羯磨不如法。不能遮应与欲。我当自往。何故与比坐见不欲。我当遮。佛告诸比丘。五法成就诤讼更起。僧应与作折伏羯磨。何等五。一者自高。二者粗弊凶性。三者无义语。四者非时语。五者不亲附善人。是名五法成就。僧应与作折伏羯磨。羯磨人应作是说。大德僧听。马宿比丘自高诤讼相言。三谏不止。若僧时到。僧今与马宿比丘自高作折伏羯磨。白如是。大德僧听。马宿比丘自高诤讼相言。三谏不止。僧今与马宿比丘自高作折伏羯磨。诸大德忍。僧与马宿比丘自高作折伏羯磨。忍者僧默然。不忍者。便说是第一羯磨。第二第三亦如是说。僧已与马宿比丘自高作折伏羯磨竟。僧忍默然故。是事如是持。后四事亦如是说。恭敬年少者。佛住舍卫城。广说如上。尔时阐陀比丘度年少出家。身自供给晨起问讯。与出大小行器唾壶着常处。与按摩身体授与衣钵。共入聚落令在前行到檀越家。令在上座处坐。先受供养供养已。与收钵荡涤还着常处。食后与染衣熏钵。与敷床褥日冥。与燃灯火内唾壶大小行器。诸比丘谏言。长老莫供给年少。年少应供给长老。答言。如长老语。但此年少先乐人出家。是故我爱念。恭敬惭愧。随逐供给。如是一谏不止。二谏三谏不止。诸比丘以是因缘。往白世尊。佛言。呼阐陀来来已佛具问上事。汝实尔不。答言实尔。佛言。痴人。汝于如来所无有爱念恭敬惭愧随逐而更于年少所。爱念恭敬惭愧随逐。佛告诸比丘。是阐陀比丘于年少所爱念。僧应与作爱念供给年少折伏羯磨羯磨人应作是说。大德僧听。是阐陀比丘爱念恭敬给侍年少。三谏不止。若僧时到。僧今与阐陀比丘爱念供给年少作折伏羯磨。白如是。大德僧听。阐陀比丘爱念供给年少三谏不止。僧今与阐陀比丘爱念供给年少作折伏羯磨。诸大德忍。僧与阐陀比丘爱念供给年少比丘作折伏羯磨忍者默然。若不忍者。便说是第一羯磨。第二第三亦如是说。僧已与阐陀比丘爱念供给年少作折伏羯磨竟。僧忍默然故。是事如是持。恭敬惭愧随逐亦如是说。是名折伏羯磨。不共语羯磨者。佛住舍卫城。尔时马宿比丘作折伏羯磨已。不随顺行。所应行事而不行。所应舍事而不舍。诸比丘以是因缘。往白世尊。佛言是马宿比丘作折伏羯磨已。不随顺行。所应行事而不行。所应舍事而不舍。僧应与作不共语羯磨。羯磨人应作是说。大德僧听。是马宿比丘作折伏羯磨已。不随顺行。所应行事而不行。所应舍事而不舍。若僧时到僧与马宿比丘作不共语羯磨。白如是。白三羯磨。乃至僧忍默然故。是事如是持。复次佛住舍卫城。尔时有摩诃罗出家数犯小戒。别众食处处食。停食食共器食女人同室宿。过三宿。共床眠共床坐。不净果食。受生肉受生谷受金银。诸比丘谏言。长老不应作是事。答言。长老当语我。我当受行。诸比丘言。是摩诃罗有修学意。后复数数犯小小戒。别众食乃至受金银。诸比丘复谏言。摩诃罗不应作是事。答言。长老应语我。我当受行后复数数犯。诸比丘言。是摩诃罗出家。不知恩教。不顺教诲谄曲不实。不欲修学。诸比丘以是因缘。往白世尊。佛言。是摩诃罗出家不知恩教。不顺教诲。僧应与作不共语羯磨。羯磨人当作是说。大德僧听。是摩诃罗出家不知恩教。不随教诲。若僧时到僧与摩诃罗作不共语羯磨白如是。白三羯磨乃至僧忍默然故。是事如是持。是名不共语羯磨。摈出羯磨者。佛住舍卫城尔时六群比丘在迦尸邑住。作身非威仪。口非威仪。身口非威仪。作身害口害身口害。作身邪命口邪命身口邪命如上僧伽婆尸沙黑山聚落中广说。是名摈出羯磨。发喜羯磨者。喜优婆夷。舍那阶。油熬鱼子迦露。摩诃南。六群比丘。喜优婆夷者佛住舍卫城。尔时难陀游行诸国还到舍卫。时难陀着入聚落衣。持钵往至优婆夷家。喜优婆夷见已欢喜。问讯言。善来阿阇梨。何故希。行即请令坐。坐已难陀言。我希行欲与我何物。答言。随所须与。若前食若后食。若粥若饼若果。随所须当作。难陀言。我须前食当好作。答言。如教。我当好作。唯愿明日早来。作是语已便去。后优婆夷晨起。作好前食敷座踟蹰而待。难陀多事遂忘不往优婆夷待见时过不来故。即于此食中可停者。举不可停者便食。如是第二日第三日待不来。便尽取食。到第四日方来问言。少病优婆夷。优婆夷嫌言。阿阇梨受我请前食。何故不来。答言。优婆夷嗔耶。彼言嗔。若尔者我悔过。优婆夷言。向世尊悔过去。难陀即便向佛悔过。佛言。何故悔过。难陀具以上事。白佛。佛言。痴人此优婆夷于佛比丘僧无所匮惜。汝何故扰乱。佛告诸比丘。是优婆夷在家笃信。难陀扰乱令发不喜。僧今应与难陀作发喜羯磨。羯磨人应作是说。大德僧听。是难陀比丘扰乱俗人。生不喜心。若僧时到。僧与难陀作俗人发喜羯磨。白如是。大德僧听。难陀比丘扰乱俗人。发不欢喜。僧今与难陀作俗人发喜羯磨。诸大德忍。僧与难陀作俗人发喜羯磨。忍者僧默然。若不忍者。便说是第一羯磨。第二第三亦如是说。僧已与难陀作俗人发喜羯磨竟。僧忍默然故。是事如是持。是名喜优婆夷。舍那阶者佛住舍卫城。尔时质帝隶居士请僧与药。时六群比丘闻已。自相谓言。居士请僧与药。当往试之。到时着入聚落衣持钵。往到其家。共相问讯相问讯已。作是言。我闻居士请僧与药。审尔不。答言尔。阿阇梨有所须耶。答言。我须舍那阶一担。居士言。须我办当与。比丘言。奇怪不先办药。而欲请僧。汝不知耶。一比丘服药。如雪山一大龙象食等。汝不实施。而但求名。居士言。阿阇梨。王家库中尚无储药。况复我家待办相与。比丘言。与以不与自随汝意。言已便出。后居士遣人到拘邻提国象聚落。得舍那阶来。白阿阇梨已。得舍那阶。可来取之。闻是语已。相看面笑。居士嫌言。何故相看笑。我未办时。殷勤苦索。今者已办而笑。不取我家所有。于佛比丘僧无所爱惜。尊者何故相试。比丘言。居士嗔耶。答言嗔。比丘言。若嗔者我悔过。居士言。向世尊悔过。如喜优婆夷中广说。油熬鱼子者佛住舍卫城。尔时质帝隶居士作百味食请僧。僧食讫。还精舍。居士敕家中妇儿言。遗余饮食料理。与诸比舍。我欲往问讯世尊。尔时六群比丘在祇洹门间。俗论言话。居士见已。作是念。此非毗尼人。设我不往彼或有恨。即往和南问讯。比丘言。善来檀越。如大龙象。居士问言。尊者。今日我家中食不。答言。往食。复问。尊者。食适意不。答言。善好。但少一种。问少何等。比丘答言。若得油盐熬鱼子者。便是名食施主。得好名誉。居士言。尊者。我先不知。若当知者应益多作人与一钵。居士复言。尊者。听我说譬喻。过去世时有群鸡依奈林住有狸侵食。雄鸡唯有雌。在后乌来覆之。共生一子。子作声时。翁说偈言

  此儿非我有　　野父聚落母
  共合生儿子　　非乌复非鸡
  若欲学翁声　　复是鸡所生
  若欲学母鸣　　其父复是乌
  学乌似鸡鸣　　学鸡作乌声
  乌鸡二兼学　　是二俱不成

如是尊者。非是俗人。复非出家。比丘言。居士嗔耶。答言嗔。比丘言。嗔者。我悔过。居士言。向世尊悔过。六群比丘即往佛所。向佛悔过。佛言。何故悔过。六群比丘以其上事具白世尊。佛言。痴人。是质帝隶居士家中所有。于佛比丘僧无所匮惜。何故扰乱。佛告诸比丘。是居士以宿命通。见六群比丘本昔时。曾作鸡乌子。是故作如是说。佛言。僧应与六群比丘作俗人发喜羯磨。如喜优婆夷中广说。迦露者佛住舍卫城。尔时有乞食比丘。时到着衣持钵入城乞食。次到一家门时夫在中庭坐。语妇言。汝施出家人食。妇言。何道出家。夫言。释种出家。妇言不与。夫言。何故不与。妇言。是人非梵行。比丘言。姊妹。我非是非梵行。妇人言。尊者。迦露尚不能修梵行。况汝能修梵行耶。比丘闻是语已。惆怅不乐。遂不乞食。于是而还坐禅。晡时禅觉已身极饥乏。往世尊所。头面礼足却住一面。佛知而故问。比丘何故饥色。白言。失食。世尊。佛言汝不能乞食耶。即以上事具白世尊。佛告诸比丘。是迦露比丘于俗人间令发不喜。僧应与作俗人发喜羯磨。如喜优婆夷中广说。是名迦露。摩诃南者佛住舍卫城。尔时摩诃南释种请僧施药时。难陀优婆难陀闻已。自相谓言。当往试之。到时着入聚落衣。往到其家。共相问讯言。我闻檀越请僧与药审尔不。答言尔。尊者欲须药耶。答言。须尔许[土*瓦]酥。尔许[土*瓦]油尔许[土*瓦]蜜。尔许石蜜。尔许根药叶药华药果药。答言。尊者即日无尔许药。须辨相与。六群比丘言。异事。檀越。先不储药。而请比丘僧。汝不知耶。一比丘服药如雪山一大龙象食等。汝不欲施。但求名誉。彼言。尊者王家库中尚无尔许药。何况我家须办当与。难陀言。与以不与自任汝意。作是语已。便出。居士后办药已。白言。尊者。今可来取。彼闻已相视而笑。檀越嫌言。何故试我相视而笑未办之时。殷勤来索。今办而不取。难陀言。檀越嗔耶。答言嗔。若嗔者我悔过。答言。向世尊悔过。难陀即往佛所。悔过。佛言。何故悔过。即以上事。具白世尊。佛言。痴人。是释摩南家中所有。于佛比丘僧无所匮惜。何故扰乱。佛告诸比丘。僧应与难陀作俗人发喜羯磨如喜优婆夷中广说。是名摩诃南。六群比丘者佛住舍卫城。尔时六群比丘在迦尸邑。身非威仪。口非威仪。身口非威仪。身害口害身口害。身邪命口邪命身口邪命。乃至发俗人不欢喜。佛告诸比丘僧。应与六群比丘作俗人发喜羯磨。如喜优婆夷中广说。是名六群比丘。是谓发喜羯磨

具足不名受支满不清净

羯磨及与事折伏不共语

摈出发欢喜初跋渠说竟

举羯磨者佛住舍卫城。广说如上。尔时阐陀比丘五众罪中犯一一罪。诸比丘言。长老。见此罪不。答言。不见。汝用问我见不见为。诸比丘以是因缘往白世尊。佛告诸比丘。是阐陀比丘五众罪中犯一一罪。自言不见者。僧应与作不见罪举羯磨。羯磨人应作是说。大德僧听。是阐陀比丘五众罪中犯一一罪。而自言不见。若僧时到。僧与阐陀比丘作不见罪举羯磨。白如是。大德僧听。是阐陀比丘五众罪中犯一一罪。而自言不见。僧今与阐陀比丘作不见罪举羯磨。诸大德忍。僧与阐陀比丘作不见罪举羯磨。忍者僧默然。若不忍者。便说是第一羯磨。第二第三亦如是说。僧已与阐陀比丘。作不见罪举羯磨竟。僧忍默然故。是事如是持。作举羯磨已。语诸比丘言。长老。我见是罪所应行事。我随顺行哀愍我故。与我舍不见罪举羯磨。诸比丘以是因缘。往白世尊。佛告诸比丘。是阐陀比丘五众罪中犯一一罪而言不见。僧欲饶益故。作举羯磨。彼所应行事已随顺行。自言见罪。僧应作舍不见罪举羯磨。羯磨人应作是说。大德僧听。是阐陀比丘五众罪中犯一一罪。而言不见。僧欲饶益故作不见罪举羯磨。所应行事。彼随顺行。今自见罪。若僧时到。僧与阐陀比丘。欲于僧中乞舍不见罪举羯磨。诸大德僧听。阐陀比丘。欲于僧中乞舍不见罪举羯磨竟。僧忍默然故。是事如是持。此人应从僧中乞。作是言。大德僧听。我阐陀比丘。五众罪中犯一一罪。而言不见。僧欲饶益故作不见罪举羯磨。所应行事已随顺行。自说见罪。今从僧乞舍不见罪举羯磨。惟愿大德僧哀愍故。与我舍不见罪举羯磨。如是三乞。羯磨人应作是说。大德僧听。是阐陀比丘。五众罪中犯一一罪。自言不见。僧欲饶益故。作不见罪举羯磨。所应行事已随顺行。今自见罪已。从僧中乞舍不见罪举羯磨。若僧时到。僧今与阐陀比丘。舍不见罪举羯磨。白如是。大德僧听。是阐陀比丘五众罪中犯一一罪自言不见。僧欲饶益故与作不见罪举羯磨。所应行事已随顺行。今自见罪已。从僧中乞舍不见罪举羯磨。僧今与舍不见罪举羯磨。诸大德忍。僧与阐陀比丘舍不见罪举羯磨。忍者僧默然。若不忍者便说是第一羯磨。第二第三亦如是说。僧已与阐陀比丘。舍不见罪举羯磨竟。僧忍默然故。是事如是持。僧已与舍不见罪举羯磨竟。诸比丘语言。长老。此罪应如法作。答言。汝用教我如法作。为我不能作。诸比丘以是因缘。往白世尊。佛告诸比丘。是阐陀比丘五众罪中犯一一罪。不能如法作者。僧应与犯罪。不能作举羯磨。羯磨人应作是说。大德僧听。是阐陀比丘五众罪中犯一一罪。不肯如法作。若僧时到。僧今与阐陀比丘犯罪不肯如法作举羯磨。白如是。大德僧听。是阐陀比丘五众罪中犯一一罪。不肯如法作。僧今与阐陀比丘犯一一罪。不肯如法作举羯磨。诸大德忍。僧今与阐陀比丘犯罪不肯如法作举羯磨。忍者僧默然。若不忍者便说是。第一羯磨。第二第三亦如是说。僧已与阐陀比丘犯罪不肯如法作举羯磨竟。僧忍默然故。是事如是持

摩诃僧祇律卷第二十四摩诃僧祇律卷第二十五

        东晋天竺三藏佛陀跋陀罗共法显译

    明杂诵跋渠法之三

复次佛住舍卫城。尔时阿梨吒比丘谤契经。作是说言。长老。世尊说法。我解知行障道法。不能障道。诸比丘语言。长老。莫谤契经。谤契经者。是恶邪见。堕恶道入泥犁中。答言。此是好见善见。父母先师相承已来。作如是见。诸比丘以是因缘。往白世尊。佛告诸比丘。是阿梨吒比丘作是说世尊说法。我解知行障道法不能障道。应屏处三谏多人中三谏。众僧中三谏。屏处谏者。应先问。长老阿梨吒汝实谤契经。作是说。世尊说法。我解知行障道法不能障道耶。答言实尔。尔时屏处应谏作是言。长老莫谤契经。谤契经者。此是恶邪见堕恶道入泥犁。我慈心饶益故谏汝。汝当舍此事。一谏已过二谏在。舍此事不。答言。此是好见善见。父母先师相承已来作如是见。我不能舍。如是二谏三谏不止。如是众多人中三谏。若不舍者。僧中应作羯磨。羯磨人应作如是说。大德僧听。是阿梨吒比丘谤契经。作是说。世尊说法我解知。行障道法不能障道。已屏处三谏。众多人中三谏不舍。若僧时到。僧亦应三谏。僧中应问。长老。汝实谤契经。作是说。世尊说法我解知。行障道法不能障道已。屏处三谏。众多人中三谏。不舍此事耶。答言尔。僧中应谏。长老汝莫谤契经。谤契经者。此是恶邪见堕恶道入泥犁。僧今慈心饶益故。谏汝。一谏已过二谏在。舍此事不。答言。此是好见善见。父母先师相承已来作如是见。我不能舍。如是第二第三谏不止。诸比丘以是因缘。往白世尊。佛告诸比丘。是阿梨吒比丘谤契经已。屏处三谏。众多人中三谏不舍者。僧应作谤契经不舍举羯磨。羯磨人应作是说。大德僧听。是阿梨吒比丘谤契经。作是说。世尊说法。我解知。行障道法不能障道已。屏处三谏。众多人中三谏。众僧中三谏。而不舍。若僧时到。僧今与阿梨吒比丘作谤契经不舍举羯磨。白如是如是白三羯磨

复次佛住舍卫城。尔时尸利耶婆恶邪见起作是说。杀生自杀教人杀。乃至作恶无殃。为善无福。无今世后世善恶果报。诸比丘言。长老。尸利耶婆莫起恶见。起恶见者。是不善堕恶道入泥犁。答言。此是好见善见。我父母先师相承已来作如是见。诸比丘以是因缘。往白世尊。佛言。是尸利耶婆起恶邪见。乃至无善恶果报应。屏处三谏。众多人中三谏。僧中三谏。屏处三谏者。应先问。长老。尸利耶婆汝实起恶邪见。作是说杀生自杀教人杀。乃至作恶无殃为善无福。无今世后世善恶果报耶。答言尔。是时应谏言。长老莫起恶邪见。起恶邪见者。是不善堕恶道入泥梨。我今慈心饶益汝故谏。汝一谏已过二谏在。舍是见不。答言。此是好见善见。父母先师相承已来作如是见。我不能舍。如是第二第三谏不止。众多人中三谏。如是不止者。僧中应作举羯磨。羯磨人应作是说。大德僧听。是尸利耶婆起恶邪见。作是说杀生自杀教人杀。乃至作恶无殃为善无福。无今世后世善恶果报。已屏处三谏。众多人中三谏。而不舍。若僧时到。僧今应三谏。是时僧中应问。长老。尸利耶婆汝实作是说。杀生自杀教人杀。乃至作恶无殃为善无福。无今世后世善恶果报。已屏处三谏。众多人中三谏。不舍此事耶。答言。实尔僧中应谏。长老。汝莫起恶邪见。此是不善堕恶道入泥犁中。众僧慈心欲饶益故谏。汝一谏已过二谏在。舍此见不。答言。此是好见善见。父母先师相承已来作如是见。我不能舍。如是一谏不止。乃至三谏不止。诸比丘以是因缘。往白世尊。佛告诸比丘。是尸利耶婆起恶邪见。三谏不止。僧应与作不舍恶邪见。举羯磨。羯磨人应作是说。大德僧听。是尸利耶婆比丘起恶邪见。已屏处三谏。众多人中三谏。众僧中三谏不止。若僧时到。僧今与尸利耶婆作不舍恶邪见。举羯磨。白如是。白三羯磨。乃至僧忍默然故。是事如是持

复次佛住舍卫城。尔时摩楼伽子比丘起边见。作是说。世界有边世界无边。诸比丘言。长老。莫起边见。此是恶见堕恶道入泥犁。答言。此是好见善见。父母先师相承已来作如是见。我不能舍。诸比丘以是因缘。往白世尊。佛告诸比丘。是摩楼伽子比丘起边见。作是说。世界有边世界无边。应屏处三谏。众多人中三谏。众僧中三谏。屏处谏者。应问。长老。汝实起边见作是说。世界有边世界无边耶。答言。实尔。尔时应谏言。长老。此是恶见堕恶道入泥犁。我今慈心饶益故。谏汝。一谏已过二谏在。舍此见不。答言。此是好见善见。父母先师相承已来作如是见。我不能舍。如是第二第三谏不止。众多人中亦如是三谏。若不止者。僧中应作举羯磨。羯磨人应作是说。大德僧听。是摩楼伽子比丘起边见。说世界有边世界无边。已屏处三谏。众多人中三谏不止。若僧时到僧亦应三谏。僧中应先问。长老。汝实起边见。说世界有边世界无边。已屏处三谏。众多人中三谏。不舍此见耶。答言实尔。尔时应僧中谏。长老。莫起边见。此是恶见堕恶道入泥犁。僧慈心饶益故。谏汝。一谏已过二谏在。舍此见不。答言。此是好见善见。父母先师相承已来作如是见。我不能舍。如是第二第三谏不止。诸比丘以是因缘。往白世尊。佛告诸比丘。以是摩楼伽子比丘起边见。已屏处众多人中三谏不止者。僧应与作不舍边见举羯磨。如上说。是名举羯磨

佛住舍卫城。尔时尸利耶婆比丘数数犯僧伽婆尸沙罪。语诸比丘言。长老。与我摩那埵。诸比丘问言。长老。何故索摩那埵。答言。我犯僧伽婆尸沙罪。诸比丘先知数数犯僧伽婆尸沙罪。语言。长老。尸利耶婆僧和合集作羯磨难。长老所犯一切尽说。当一时作羯磨。如是第二第三。答言。我正犯是罪。作羯磨已。作是念。我何故。再作羯磨。应一切尽说一时作羯磨。语诸比丘言。长老。与我摩那埵。诸比丘问言。何故复索摩那埵。答言。我犯僧伽婆尸沙罪。诸比丘问。长老。何时犯答言。尔时犯诸比丘言。我先已语长老。僧和合集作羯磨难。长老所犯一切尽说。当一时作羯磨。尔时何故不说。答言。我惭愧故。不尽说。诸比丘以是因缘。往白世尊。佛言。呼尸利耶婆来。来已佛具问上事。汝实尔不。答言。实尔。佛言。痴人。犯时不知羞惭求清净时。何以羞惭。此是恶事。非法非律。非如佛教。不可以是长养善法

佛告诸比丘。持律比丘与他出罪时。他语有罪亦知。无罪亦知。覆亦知。不覆亦知。发露亦知。不发露亦知。应与别住亦知。不应与别住亦知。如法与别住亦知。不如法与别住亦知。如法行波利婆沙亦知。不如法行波利婆沙亦知。中间有罪亦知。中间无罪亦知。夜断亦知。夜不断亦知。随顺行亦知。不随顺行亦知。应与摩那埵亦知。不应与摩那埵亦知。如法与摩那埵亦知不如法与摩那埵亦知。究竟摩那埵亦知。不究竟摩那埵亦知。中间有罪亦知。中间无罪亦知。夜断亦知。夜不断亦知。随顺行亦知。不随顺行亦知。应与阿浮呵那亦知。不应与亦知。如法与阿浮呵那亦知。不如法与亦知。共覆亦知。不共覆亦知。无量覆亦知。比舍遮脚亦知。或有罪合。非夜合。或有夜合。非罪合。或有罪合。夜亦合。或有非罪合。非夜合。本罪中间罪比丘成就四法。名为持律。何等四知罪。知无罪。知重知轻。是名四法。复成就四法。名为持律知罪。知无罪。不以重罪作轻。不以轻罪作重。是名四法。复成就四法。知罪。知无罪。无罪人不言有罪。有罪人不言无罪。是名四法。复成就四法。不以重作轻。不以轻作重。不以不犯罪人作犯罪。不以犯罪人作不犯罪。是名四。复成就五法。名为持律。善知诤。善知诤缘起处。善知断诤事。善知断诤分别。善知断诤灭止。是名五。复成就六法。即上五事更增善断诤结集。是名六。复成就七法。知罪。知无罪。知重。知轻。不以重罪作轻。不以轻罪作重。善知羯磨。是名七。复成就八法即上七事更增善诵波罗提木叉。广略毗尼识知缘起。是名八。复成就九法。何等九。即上八事更增善诵毗尼。善知义不妄见彻。善知羯磨。是名九。复成就十法。即上九事更增善调伏诸根梵行满足。深知羯磨是名十。复成就五法。名为持律。何等五。持戒知罪。知无罪。诵波罗提木叉。略广义。知其缘起。善知羯磨。是名五。复成就四法。何等四。持戒善知罪。知无罪。善知羯磨。是名四。复成就三法。知罪。知无罪。知羯磨。是名三。复成就二法。何等二。知罪。知无罪。是名二。复成就一法。何等一善知羯磨。是名持律。乃至成就十四法。是名持律最第一。除如来应供正遍知。何等十四知罪。知无罪。知重。知轻。知覆。知不覆。知可治。知不可治。知得清净。知不得清净。得四禅功德住现法乐。得天眼天耳宿命通。尽有漏。得无漏。是名十四法。一切持律中最第一。除如来应供正遍知

佛告诸比丘。优波离比丘成就是十四法。持律第一。有罪亦知。无罪亦知。乃至尽有漏得无漏慧解脱有罪亦知者。知五众罪波罗夷。僧伽婆尸沙。波夜提。波罗提提舍尼。越毗尼。波罗夷者。淫盗断人命。自称过人法。僧伽婆尸沙者。故出精相触恶口语。乃至聚落中污他家。波夜提者。三十尼萨耆。九十二纯波夜提波罗提。提舍尼者。阿练若处。无病比丘尼边取食。比丘尼指示食拜学家。越毗尼者。有十三事。阿遮与。偷兰遮。丑偷兰。不作。不语。突吉罗。恶声。威仪。非威仪。恶威仪。恶邪命。恶见。心生悔毗尼。阿遮与者。如外道须深摩如尊者跋陀梨。如王舍城比丘尼。如是比向佛悔过。是名阿遮与。偷兰遮者。盗减五钱动五钱物不离地。是名偷兰遮。丑偷兰者。染污心弄身生。是名丑偷兰。不作者。和上阿阇梨语作是事。共法中应作。若不作者。越毗尼罪。若语唤妇人来取酒来。应语和上。阿阇梨我闻法中不得作。是名不作。不语者。和上阿阇梨共语闻而不报者。越毗尼罪。若口中有食。若能使声不异者。应答。若不能者咽已然后答。若和上阿阇梨作是语。何以闻我语。而不应。应语和上阿阇梨。我口中有食。是故不得答。是名不语。突吉罗者。如世尊语优陀夷六群比丘。及余比丘等作是事不好。是名突吉罗。恶声者。作象声马声牛驴骆驼。如是等一切畜生声。长引促断。促引长断。是名恶声。威仪者。晨起当除洗大小便行处。当益大小行处。瓮水应当扫。塔院僧坊院。若取与作事。乃至纽一线不白。和上依止阿阇梨者。越毗尼罪。是名威仪。非威仪者。治发庄眼。作好色捣衣。光生帛带系腰。熏钵光现以镜照面。是名非威仪。恶威仪者。身恶威仪。口恶威仪。身口恶威仪。身害口害身口害。身邪命。口邪命。身口邪命。是名恶威仪。恶邪命者。身曲口曲心曲现亲爱希望供养。是名恶邪命。恶见者。断常等一切诸见。是名恶见。心生悔毗尼者。众学威仪心念恶。不故触女人。如是比皆名心悔。是名心生悔毗尼

复次或有罪从欲生。或有罪从嗔恚生。或有罪从愚痴生。或有罪不从欲嗔恚愚痴生。或有罪是身行非口行。或是口行非身行。或是身口行。或非身口行。或有罪从自身生。非他身。或从他身生。非自身。或从自身他身生。或非自身非他身生。或有罪从自口生。非他口。或有从他口。非自口。或从自口。亦从他口。或非自口。非他口或有罪取心不取事。或有罪取事不取心。或有罪事重非心重。或有心重非事重。或有事重心亦重。或有非事重非心重。或有罪自物非他物。或有他物非自物。或自物亦他物。或有非自物非他物。或有罪是一处犯众多。或有众多处犯一罪。或有众多处犯众多罪。或有一处犯一罪。或缘无罪至有罪。或缘有罪至无罪。或缘有罪至有罪。或缘无罪至无罪。或有罪重而缘轻。或有罪轻而缘重。或有罪重缘亦重。或有罪轻缘亦轻。有受时罪有食时罪。事成罪不受得罪。受无罪。不与得罪。与无罪。或有罪是聚落非阿练若。或有是阿练若非聚落。或有是聚落亦阿练若。或有非聚落亦非阿练若。或有罪是时非非时。或是非时非是时。或是时亦非时。或有罪亦非是时亦非非时。或有罪是夜非昼。或有罪是昼非夜。或有罪是夜亦是昼。或有罪亦非夜亦非昼。或有罪是覆处非露处。或有罪是露处非覆处。或有罪亦是覆处亦是露处。或有罪亦非覆处亦非露处。或有罪是行非住。或有罪是住非行。或有罪亦是行亦是住。或有罪亦非行亦非住。或有罪是住非坐。或是坐非住。或是坐是住。或非坐非住。或有罪是坐非眠。或是眠非坐。或是坐是眠。或非坐非眠。或有罪是眠非行。或是行非眠。或亦是行亦是眠。或非眠非行。或有罪是屏处非众多。或是众多非屏处或亦是屏处亦是众多。或非屏处亦非众多。或有罪是众多非僧中。或是僧中非众多。或亦是众多亦是僧中。或非众多亦非僧中。或有罪是僧中非屏处。或是屏处非僧中。或是僧中亦是屏处。或非僧中非屏处。或有罪是冬非春。或是春非冬。或亦是冬亦是春。或亦非冬亦非春。或有罪是春非夏或是夏非春。或亦是春亦是夏。或有亦非春亦非夏或有罪是夏非冬。或是冬非夏。或亦是夏亦是冬。或亦非夏亦非冬。有罪从欲生者。故弄身生摩触。恶口自称。媒嫁一切染污心语。是名从欲生有罪从嗔恚生者。无根谤毁呰两舌斗乱驱出。知食已足故恼。聚落驱出。拳打手拟屏处听等。是名从嗔恚生。有罪从愚痴生者。愚痴心谓真实世界有常。世界无常。如是一切见。是名从愚痴生。有罪非欲嗔恚愚痴生者。阿罗汉犯。是名非欲嗔恚愚痴生。有罪是身非口者。女人同室未受具足人。过三宿同床眠。同床坐处处食别。众食同器食。是名身非口。有罪是口非身者。一切口跋渠。是名口非身。有罪是身口者。无根谤毁呰两舌斗乱驱出。知食已足故恼。聚落驱出。拳打手拟屏处听等。是名身口有罪非身口者。从心生是名非身口。有罪从自。身非他身者。嗔恚自打身。是名从自身非他身。有罪从他身非自身者。见他淫盗杀人覆藏。是名从他身非自身。有罪从自身他身生者。共女人同室宿未受具足人。过三宿同床眠。同床坐。处处食别众食同器食。是名从自身他身生。有罪非自身非他身者。一切口跋渠除未受具足人说句法。是名非自身非他身。有罪从自口非他口者。一切口罪除未受具足人说句法。是名从自口非他口。有罪从他口非自口者。若比丘僧中非法断事不与欲。复不与见不欲。默然听过。是名从他口非自口。有罪从自口从他口者。与未受具足人说句法。是名从自口从他口。有罪非自口非他口者。从身心生。是名非自口非他口。有罪取心不取事者。应当问以何心盗。何心杀人。何心触女人。何心断生草。何心掘地。是名取心不取事。有罪取事不取心者。不应问。以何心淫。何心非时食。何心饮酒。何心与女人同室宿。未受具足人。过三宿。若犯者当如法治。是名取事不取心。有罪事重非心重者。比丘非时谓是时食者。波夜提。是名事重非心重。有罪心重非事重者。比丘时谓非时食者。越毗尼罪。是名心重非事重。有罪事重心亦重者。非时谓非时食者。波夜提。是名事重心亦重。有罪事轻心亦轻者。众学及威仪。是名事轻心亦轻。有罪从自物生非他物者。比丘自财物盗心取犯偷兰遮。是名自物生非他物生。有罪从他物非自物者。比丘盗心偷他物减五钱。偷兰遮。满五钱。波罗夷。是名他物生非自物。有罪从自物他物生者。比丘共他物盗心取减五钱。偷兰遮。满者波罗夷。是名从自物他物生。有罪非自物非他物者。比丘盗心取无主物。越毗尼罪。是名非自物非他物。有罪是一处犯众多者。比丘一处并乞得八种好食。各各别食者。得八波夜提。是名一处犯众多。有众多处犯一罪者。比丘众多处乞。得八种美食。一坐食者得一波夜提。是名众多处犯一罪。有众多处犯众多者。比丘八处乞得八种美食。各各食者。得八波夜提。是名众多处犯众多罪。一处犯一罪者。一处乞得八种美食。一坐食。是名一处犯一罪。缘无罪。得有罪者。比丘无罪。作罪悔过。得越毗尼罪。是名缘无罪而得罪缘。有罪得无罪者。作小房大房毡一切。乃至三谏。是名缘有罪得无罪缘。有罪至有罪者。僧中说波罗提木叉时。乃至三问有罪者。如法作无罪者。默然尔时有罪不如法作。复不语人。又不作念我待清净。同意人当如法作。默然者。得越毗尼罪。是名缘有罪至有罪。缘无罪得无罪者。不作不犯。是名缘无罪至无罪。缘重至轻者。比丘犯波夜提。向恶邪边见被举人悔过。是名缘重至轻罪缘轻至重者。比丘犯越毗尼罪。向谤线经被举人悔过。得波夜提。是名缘轻至重。缘重至重者。比丘犯波夜提。向谤线经被举人悔过。得波夜提。是名缘重至重。缘轻至轻者。比丘犯越毗尼罪。向未受具足人悔过。不名作更得越毗尼罪。是名缘轻至轻。受时罪者。受生肉生谷金银象马驼驴牛羊。奴婢妇女田宅屋舍。是名受时罪有食时罪者。别众食处处食。同器食不净果食。是名食时罪事成罪者。作小房大房一切二谏是名事成罪有不受得罪受无罪者。受迦絺那衣。得舍五戒别众食处处食。离同食不白长衣离衣宿。是名不受得罪。受无罪不与得罪。与无罪者比丘得新衣。不三种坏色。若一一坏色作净受用者。波夜提。是名不与得罪与无罪。或有罪是聚落非阿练若者。不着僧伽梨入聚落。不着纽入聚落。不着系腰绳。不持钵。不白离同食。非时入聚落。是名聚落非阿练若。阿练若非聚落者。比丘与贼伴与女人比丘尼共期道行。是名阿练若非聚落。亦阿练若亦聚落者。拳打掌刀拟。是名亦阿练若亦聚落。有罪非阿练若。非聚落者。王门侧。是名非阿练若。非聚落有罪。是时非非时者别众食处处食同器食。挑食八种美食。不作净果食。是名时非非时。有罪是非时非是时者。不白非时。入聚落。非时食日暮教诫比丘尼。是名非时非是时。有罪亦是时亦非时者。拳打掌刀拟。是名亦时亦非时。有罪非时非非时者。正中时是名非时亦。非非时。有罪是夜非昼者。若女人同室宿未受具足人。过三宿日没教诫比丘尼。是名夜非昼。有罪是昼而非夜者。别众食乃至不净果食是名昼而非夜有罪。亦是昼亦是夜者。拳打掌刀拟。是名亦是昼亦是夜。有罪亦非昼亦非夜者。明相出时。是名亦非昼亦非夜。有罪是覆处非露处者。女人同室宿。未受具足人。过三夜内敷置淫处坐。屏处坐。是名覆处非露处。有罪是露处非覆处者。众僧床褥露地自敷。若教人敷不白去离二十五肘。波夜提。是名露处非覆处。有罪亦覆处亦露处者。拳打掌刀拟。云何罪非覆处。非露处者。屋檐下。云何罪是行非住。比丘与女人贼伴比丘尼共期道行。僧和上阿阇梨语莫去而去者。得罪。是名行非住。云何罪是住非行淫女边住。沽酒边住。摴蒱边住。狱囚边住。当门立住。僧和上阿阇梨语莫住而住。得罪。是名住非行。云何罪亦行亦住拳打掌刀拟云何罪非行非住坐时眠时。云何罪是立非坐淫女边立。乃至和上阿阇梨语莫立而立者。得罪。云何罪是坐非立坐。过量床兜罗绵贮褥皮坐具。及淫女边坐。沽酒家。摴蒲边狱囚边坐。僧和上阿阇梨语莫坐而坐者。得罪。云何罪亦立亦坐拳打掌刀拟。云何罪非立非坐。若行若眠时。云何罪是坐非眠坐。过量床乃至僧和上阿阇梨语莫坐而坐者。得罪云何罪是眠非坐女人。同室宿。未受具足人。过三夜过量床。兜罗贮褥坐皮坐具。云何罪亦是坐亦是眠拳打掌刀拟。云何罪非坐非眠行时立时。云何罪是眠非行女人同室宿乃至皮褥上眠。云何罪是行非眠比丘。与女人贼伴。乃至和上阿阇梨语莫去而去者。得罪。云何罪亦眠亦行拳打掌刀拟。云何罪非眠亦非行坐立时。云何罪是屏处非众多屏处。三谏不舍。云何罪是众多非屏处。众多人中三谏不舍。云何罪亦屏处亦众多拳打掌刀拟。云何罪非屏处。非众多众僧中。云何罪是众多。非僧中众多人中三谏不舍。云何罪是僧中非众多僧中。三谏不舍。云何罪亦众多。亦僧中拳打掌刀拟。云何罪非众多非僧中屏处三谏不舍。云何罪是僧中非屏处僧中三谏不舍。云何罪是屏处。非僧中屏处。三谏不舍。云何罪亦僧中亦屏处。拳打掌刀拟云何罪非僧中非屏处。众多人中三谏不舍。云何罪是冬非春。比丘到八月十五日。不舍雨浴衣至十六日舍得越毗尼罪云何罪是春非冬。比丘受迦絺那衣至腊月十五日应舍。若不舍至十六日者越毗尼罪云何罪亦冬亦春拳打掌刀拟。云何罪非冬非春安居时。云何罪是春非夏。比丘受迦絺那衣不舍。至腊月十六日越毗尼罪。云何罪是夏非春比丘至四月十六日应安居不安居者。越毗尼罪。到后安居复不安居者。得二越毗尼罪。云何罪亦是春亦是夏拳打掌刀拟。云何罪非春非夏。是冬时云何罪是夏非冬者。于二安居时而不安居。得二越毗尼罪云何罪是冬非夏八月十五日应舍雨浴衣。而不舍。至十六日得罪。云何罪亦是夏亦是冬。拳打掌刀拟。云何罪非夏非冬。是春时是名罪非夏非冬复有罪名不摄身不摄口不摄身。口身犯口犯身口犯。身恶行口恶行身口恶行。是名罪无罪者。摄身摄口摄身口身不犯口不犯身口不犯。身不恶行口不。恶行身口不恶行。是名无罪

佛告诸比丘。持律比丘与他出罪时。有罪亦知。无罪亦知。覆亦知。不覆亦知。覆亦知者。比丘明相出时。犯僧伽婆尸沙。知是罪不作覆藏心。至日出时作覆藏心。至明相出时。是名一夜覆。复有覆名。比丘明相出时。犯僧伽婆尸沙。知是罪不作覆藏心。至食时作覆藏心。至明相出时。是名一夜覆。如是中时晡时日没初夜中夜时。亦如是。比丘至明相出时。犯僧伽婆尸沙。知是罪不作覆藏心。乃至后夜知是罪作覆藏心。至明相出时。是名二时一夜覆。复有覆名比丘明相出时。犯僧伽婆尸沙。不知是罪。至日出时知是罪。不作覆藏心。到食时作覆藏心乃至明相出时。是名一夜覆中时。晡时日没初夜时。亦如是。比丘明相出时。犯僧伽婆尸沙。不知是罪。乃至中夜知是罪。不作覆藏心。至后夜作覆藏心。至明相出时。是名三时一夜覆。复有覆名。比丘明相出时犯僧伽婆尸沙不知是罪。到食时知是罪不作覆藏心。至日中作覆藏心。至明相出时。是名一夜覆晡时。日没初夜亦如是。比丘明相出时。犯僧伽婆尸沙。不知是罪。乃至中夜知是罪。不作覆藏心。到后夜作覆藏心。至明相出时。是名四时一夜覆复有覆名比丘明相出时。犯僧伽婆尸沙。知是罪覆不覆犹豫。至日出时作覆藏心。乃至明相出时。是名一夜覆如是食时中时晡时日没时初夜中夜。乃至后夜作覆藏心。至明相出。是名二时一夜覆。复有覆名。比丘明相出时。犯僧伽婆尸沙不知是罪。至日出时。知是罪。覆不覆犹豫到食时。作覆藏心。至明相出时。是名一夜覆。如是中时晡时日没初夜亦如是。比丘明相出时。犯僧伽婆尸沙。不知是罪。乃至中夜知是罪。覆不覆犹豫到后夜。作覆藏心。至明相出时。是名三时一夜覆。复有覆名。比丘明相出时。犯僧伽婆尸沙。不知是罪。乃至食时知是罪。覆不覆犹豫到中时。作覆藏心。至明相出时。是名一夜覆。如是晡时日没初夜亦如是。比丘明相出时。犯僧伽婆尸沙。不知是罪。乃至中夜知是罪。覆不覆犹豫到后夜作覆藏心。至明相出时。是名四时一夜覆。复有覆名。比丘明相出时。犯僧伽婆尸沙。知是罪作覆藏心。至日出时作不覆藏心。乃至后夜作覆藏心。至明相出时。是名一夜覆。复有覆名。比丘犯僧伽婆尸沙。若隔壁若隔堑。若闇中小声说他名某甲比丘犯僧伽婆尸沙。是不名发露。知而妄语。得波夜提是名覆。复有不覆名。若隔障若隔堑。若闇中小声自称说他名犯僧伽婆尸沙。得名发露。但谄曲作。得越毗尼罪。复有不覆名。比丘犯僧伽婆尸沙。不隔壁不隔堑。不闇中不小声。不说他自说名字犯。是名不覆。复有不覆名。非罪想罪疑覆不覆疑夜疑。若发露是名不覆。复有不覆。不作覆藏心。未得发露。若忘若罢道。若入定若命终。是名不覆

佛告诸比丘。持律比丘与他出罪时。有罪应知。无罪应知。覆应知。不覆应知。发露应知。不发露应知。或有覆非发露。或有发露非覆。或有覆亦发露。或有非覆非发露。云何覆非发露。比丘犯僧伽婆尸沙。知是罪作覆藏心。不向他说。是名覆非发露。云何是发露非覆藏。比丘犯僧伽婆尸沙。知是罪不作覆藏心。向他说。是名发露非覆。云何是覆亦发露。比丘犯僧伽婆尸沙。知是罪覆藏已后向他说。是名覆亦发露。云何非覆非发露。比丘犯僧伽婆尸沙。知是罪不作覆藏心作是念。待时待方待人。当如法作。是名非覆非发露

佛告诸比丘。持律比丘与他出罪时。有罪应知。无罪应知。覆应知。不覆应知。发露应知。不发露应知。与别住应知。不与别住应知者。云何不应与无罪。不应与不覆。不应与罪不决定。覆不决定。夜不决定。前人不索不问不应与。云何应与有罪应与覆。应与罪决定覆决定。夜决定前人索问。应与如法与不如法与。云何不如法与无罪。罪不决定。覆不决定。夜不决定。前人不索不问。众不成就。白不成就。羯磨不成就。是名不如法与。云何如法与有罪。罪决定。覆决定。夜决定。前人索问。众成就。白成就。羯磨成就。若一一成就。是名如法与不如法。行婆利婆沙。如法行婆利婆沙。云何不如法行。僧伽蓝无比丘中间有罪。更举与比丘同房同障住。客比丘来不白。时集非时集不白。是名不如法行。云何如法行。僧伽蓝有比丘住。行婆利婆沙中间。不犯不举。与比丘别房别障住。客比丘来白时。集非时集白。是名如法行夜断夜不断。云何夜不断。僧伽蓝中有比丘住。乃至时集非时集白。是名夜不断。云何夜断僧伽蓝中无比丘住。乃至时集非时集不白。是名夜断中间有罪中间无罪。云何中间有罪发露已。僧未与波利婆沙。更犯行波利婆沙中间犯。是名中间罪。云何中间无罪中间不犯。是名无罪。行波利婆沙比丘。应随顺行七事。何等七。一比丘事。二比丘尼事。三眷属事。四入聚落事。五执众苦事。六受拜事。七王事。云何比丘事不得受比丘礼。不得说比丘罪。不得与比丘语论。不得说沙弥罪。不得福罚沙弥。不得与沙弥语论。不得作比丘使。不得在比丘前后行入聚落众集时。不得为众作说法人除别处。是名比丘事。云何比丘尼事。不得受比丘尼礼。不得说比丘尼罪。不得与比丘尼语论。不得说式叉摩尼罪沙弥尼罪。不得福罚式叉摩尼沙弥尼。不得与式叉摩尼沙弥尼语论。不得遮比丘尼布萨自恣。不得遮比丘尼齐门止。不得往教诫比丘尼。若已受者不得往。是名比丘尼事。云何眷属事。不得度人不得与人受具足。不得受人依止及畜沙弥。不得受比丘供给。不得授人经。不得从他受经本所诵经。当细声诵。若先有依止弟子。教令依止他当断眷属。是名眷属事。云何入聚落事。不得太早入聚落太晚出。不得在前后行沙门入聚落。不得到知识檀越家。不得无比丘僧伽蓝中住。坐时食时在比丘下。不得使人迎。食不得与人迎食除次到。是名入聚落事。云何执众苦事。晨起扫塔院僧院。授僧水。洗僧大小行处。如是一切可作事应随力作。不得与欲。不得受他欲除次到。是名执众苦事。云何受拜事。不得受一切拜白一羯磨。白三羯磨。尽不得受。是名受拜事。云何王事。不得恃王大臣居士凶人力势。不得嫌佛嫌法嫌僧嫌羯磨人。但自责不得嫌他。是名王事。波利婆沙比丘行此七事。是名随顺行。不行者是名不随顺行。不应与摩那埵。应与摩那埵。云何不应与无罪。不应与覆藏。未与别住不应与半覆半不覆。不应与罪不决定。覆不决定。夜不决定。不应与波利婆沙不决定。不应与不索不问。不应与云何应与有罪。覆行波利婆沙竟。罪决定。覆决定。夜决定。波利婆沙决定。前人索问。应与不如法与如法与。云何不如法与无罪。乃至不索不问。众不成就。白不成就。羯磨不成就。若一一不成就是名不如法与。云何如法与有罪。乃至索问众成就。白成就。羯磨一一成就。是名如法与。不究竟行摩那埵。究竟行摩那埵。云何不究竟行摩那埵。众不满不名行摩那埵。中间犯更举与比丘一房一障住。不白客比丘。时集非时集。不白不日日白界内僧是名不究竟行。云何究竟行众满。是名究竟中间不犯不举。不共比丘一房一障住。客比丘来白。时集非时集。白日日白界内僧。是名究竟行。夜断夜不断。云何夜断夜中间众不满。乃至不日日白界内僧。是名夜断。云何夜不断中间众满。乃至日日白界内僧。是名夜不断中间有罪。中间无罪。云何中间有罪。未与摩那埵中间犯。与摩那埵中间犯。究竟中间犯。是名中间罪。云何中间无罪。无上诸事。是名中间无罪。行摩那埵比丘。应随顺行。七事如上说。是名摩那埵。比丘随顺行不行者。是名不随顺。应与阿浮呵那。不应与。不应与者无罪。不应与覆未与别住。不应与摩那埵。不究竟不应与不覆。未行摩那埵。不应与覆不覆。不应与罪不决定。覆不决定。夜不决定。别住不决定。摩那埵不决定。不索不问。是名不应与阿浮呵那。应与者有罪。应与覆罪应与别住。摩那埵究竟。应与不覆摩那埵。究竟应与罪决定。覆决定。夜决定。别住决定。摩那埵决定。前人索问。是名应与阿浮呵那。如法与阿浮呵那。不如法与阿浮呵那。不如法与者无罪。不应与乃至众不成就。白不成就。羯磨不成就。若一一不成就。是名不如法与如法与者有罪。应与乃至众成就。白成就。羯磨成就。若一一成就。是名如法与。阿浮呵那共覆者。比丘月一日犯一僧伽婆尸沙。知是罪。不作覆藏心。如是二日三日乃至十日。一切知是罪。作覆藏心。至明相出时。是十罪一切共一夜覆。应作十别住羯磨。十摩那埵。十阿浮呵那。亦得作一别住羯磨。一摩那埵。一阿浮呵那。是名共覆。复有共覆名。比丘月一日犯一僧伽婆尸沙。知是罪。不作覆藏心。如是二日犯二三日犯。三乃至十日犯。十僧伽婆尸沙。一切知是罪。一切作覆藏心。至明相出时。是五十五僧伽婆尸沙罪。一切共一夜覆。应作五十五别住羯磨。五十五摩那埵。五十五阿浮呵那。亦得作一别住羯磨。一摩那埵。一阿浮呵那。是名共覆。复有共覆名。比丘月一日犯一僧伽婆尸沙。不知是罪。如是二日三日乃至十日。一切知是罪。一切作覆藏心。至明相出时。是十罪共一夜覆。乃至亦得作一别住羯磨。一摩那埵。一阿浮呵那。是名共覆。复有共覆名。比丘月一日犯一僧伽婆尸沙。不知是罪。不作覆藏心。乃至十日犯十僧伽婆尸沙。一切知是罪。作覆藏心。至明相出时。是五十五罪共一夜覆。乃至亦得作一别住羯磨。一摩那埵一阿浮呵那。是名共覆。参差覆者。比丘月一日犯一僧伽婆尸沙。知是罪作覆藏心。至二日向他说已。复犯僧伽婆尸沙。乃至十日向他说已。复犯知是罪。作覆藏心。至十一日向他说。是十僧伽婆尸沙。如是一切各一夜共参差。覆应作十别住羯磨。十摩那埵。十阿浮呵那。亦得作一别住。一摩那埵。一阿浮呵那。是名参差覆。复有参差覆名。比丘月一日犯一僧伽婆尸沙。知是罪作覆藏心至二日向人说已。复更犯如是。乃至十日犯十僧伽婆尸沙。知是罪作覆藏心。至十一日向人说。是五十五僧伽婆尸沙。如是一切各一夜参差覆。应作五十五别住羯磨。五十五摩那埵。五十五阿浮呵那。亦得作一别住羯磨。一摩那埵。一阿浮呵那。是名参差覆。无量覆者。或忆罪不忆夜。或忆夜不忆罪。或忆罪亦忆夜。或不忆罪亦不忆夜。忆罪不忆夜者。忆知犯罪多少不忆。若干夜忆夜不忆罪者。忆知尔许夜。不忆罪多少。亦忆罪亦忆夜者。忆知罪多少忆知若干夜。不忆罪不忆夜者。不忆犯罪多少。亦不忆若干夜。是中忆罪不忆夜者。应当问。汝何时犯未有岁时耶。若前人默然者。应随年与别住。若言不尔。更问一岁耶。二岁耶。五岁耶。可随默然处与别住。是名忆罪不忆夜。忆夜不忆罪者。随夜多少应与作无量罪别住。是名忆夜不忆罪。忆罪亦忆夜者。忆罪多少随所忆夜与别住。是名忆罪亦忆夜。不忆罪不忆夜者。应当问无岁时犯耶。若默然者。随年与作无量罪别住。若言不尔更问未有岁耶。一岁二三四五岁耶。随默然处与作无量罪别住。是名无量覆共覆参差。覆无量覆。是三俱名为覆。别覆者。比丘月一日犯一僧伽婆尸沙。知是罪作覆藏心。不向他说。二日复犯。知是罪作覆藏心。不向他说。乃至十日复犯知是罪作覆藏心。不向他说。是十罪各别覆。最后罪一夜覆。如是二夜三夜。乃至初罪有十夜覆。应与作十别住羯磨。十摩那埵。十阿浮呵那。亦得作一别住。一摩那埵。一阿浮呵那。复有别覆名。比丘月一日犯一僧伽婆尸沙。知是罪作覆藏心。不向他人说。乃至十日犯十僧伽婆尸沙。知是罪作覆藏心。不向他说。是五十五罪各别覆。最后罪一夜覆。如是二夜三夜。乃至初罪有五十五夜覆。应与五十五夜别住羯磨。五十五摩那埵。五十五阿浮呵那。亦得作一别住。一摩那埵。一阿浮呵那。是名别覆同覆别覆。是二俱名覆。比舍遮脚者。或有罪长非夜长。或有夜长非罪长。或有罪长夜亦长。或有非罪长非夜长。罪长非夜长者。比丘竟日犯僧伽婆尸沙。知是罪向人说。是名罪长非夜长。有夜长非罪长者。比丘犯一僧伽婆尸沙。知是罪作覆藏心。不向他人说。是名夜长非罪长。有罪长夜亦长者。比丘日日犯僧伽婆尸沙。知是罪覆半说半。是名罪。长夜亦长。有非罪长亦非夜长者。比丘犯僧伽婆尸沙。知是罪不作覆藏心。向他人说更不犯。是名非罪长亦非夜长是中罪长夜不长罪。亦长夜亦长者。行波利婆沙时。当少与食多与作务。若故不止者。当使净人缚手脚着床。应语言。若更犯者。僧复重治。汝是名比舍遮脚。或有罪合非夜合。或有夜合非罪合。或有罪合夜亦合。或有非罪合亦非夜合。罪合非夜合者。比丘犯十僧伽婆尸沙。一切十夜覆僧合与百夜别住羯磨。比丘言。长老。我羸病不堪得与。略行波利婆沙不应语言得。百夜羯磨合。作十夜别住。是名罪合非夜合。夜合非罪合者。比丘犯十僧伽婆尸沙。一切十夜覆僧合与十夜别住。比丘言。长老。我惭愧我欲广行波利婆沙。应语言得。是名夜合非罪合。罪合夜亦合者。比丘犯十僧伽婆尸沙。十夜覆藏僧合。与作十夜别住。是名罪合夜亦合。非罪合非夜合者。各各别作波利婆沙羯磨。是名非罪合非夜合

摩诃僧祇律卷第二十五摩诃僧祇律卷第二十六

        东晋天竺三藏佛陀跋陀罗共法显译

    明杂诵跋渠法之四

本罪者。比丘覆藏罪乞别住已。复语比丘言。长老。我更有僧伽婆尸沙。比丘问言。是本罪中间罪。答言。是本罪。复问覆不覆。答言。覆比丘语言。长老。先别住者。已如法行。今所说覆者。当更乞别住。已是两罪合行。波利婆沙共行摩那埵。共阿浮呵那。是名别乞共行波利婆沙。共行摩那埵。共阿浮呵那。比丘覆藏罪索别住行至半。复语比丘言。长老。我更有僧伽婆尸沙。比丘问言。是本罪中间罪。答言。是本罪。复问覆不覆。答言覆。比丘应语。汝先别住者已如法行。今所覆者。应更乞别住。已是两罪。合行波利婆沙。共行摩那埵。共阿浮呵那。是名别乞。共行波利婆沙。共行摩那埵。共阿浮呵那。比丘覆藏罪乞别住。行竟。复语比丘言。长老。我更有僧伽婆尸沙。比丘问言本罪中间罪。答言本罪。复问覆不覆。答言覆。应语言先别住者。已如法行。今所覆者。应更乞别住行。已是二罪合乞摩那埵共阿浮呵那。是名别乞别行波利婆沙。共行摩那埵。共阿浮呵那。比丘覆藏罪行波利婆沙竟。乞摩那埵已。复言。长老。我更有僧伽婆尸沙应问。是本罪中间罪。答言。是本罪。问覆不覆。答言覆。应语先波利婆沙。摩那埵已。如法行。今所覆者应更乞波利婆沙行竟。更乞摩那埵。是二罪合行。已共阿浮呵那。是名别乞别行波利婆沙。别乞合行摩那埵。共阿浮呵那。比丘覆藏罪行波利婆沙竟。乞摩那埵行至半。复语比丘言。长老。我更有僧伽婆尸沙。乃至应语。先摩那埵已。如法行。今所覆者。应更乞波利婆沙行已。更乞摩那埵。是二罪合行摩那埵。共阿浮呵那。是名别乞别行波利婆沙。别乞共行摩那埵。共阿浮呵那。比丘覆藏罪行波利婆沙摩那埵竟。复语比丘言。长老。我更有僧伽婆尸沙。乃至应语。先波利婆沙摩那埵已如法行。今所覆者。应更乞波利婆沙摩那埵行已。是二罪合乞阿浮呵那。是名别乞别行波利婆沙。摩那埵。共阿浮呵那。比丘覆藏罪行波利婆沙摩那埵阿浮呵那竟。复语比丘言。长老。我更有僧伽婆尸沙。乃至应语言。先波利婆沙摩那埵阿浮呵那已。如法行。今所覆者应更乞波利婆沙摩那埵阿浮呵那。是名别乞别行波利婆沙摩那埵阿浮呵那。比丘覆藏罪与波利婆沙已。语比丘言。长老。我更有二僧伽婆尸沙。应问。是本罪中间罪。答言。是本罪。问言。覆不覆。答言。一覆一不覆。应语言。先波利婆沙已。如法行。今不覆者停覆者。更乞波利婆沙合行。已共行摩那埵。共阿浮呵那。如是别住中别住竟。摩那埵初中竟。阿浮呵那竟。亦如上说。比丘覆藏罪。与波利婆沙已。复语诸比丘言。长老。我更有三僧伽婆尸沙。应问言。是本罪中间罪。答言。是本罪。复问。覆不覆。答言。一覆一不覆。一疑应语言。先波利婆沙已。如法行。今不覆者停疑者。当决定覆者。当乞波利婆沙共行摩那埵共阿浮呵那。如是别住中别住竟。摩那埵初中竟。阿浮呵那竟。亦如上说。是名本罪。中间罪者。比丘覆藏罪行别住竟。语比丘言。长老。我更有僧伽婆尸沙。应问言。是本罪中间罪。答言。是中间罪。问言。何时犯。答言。别住中犯。问言。覆不覆。答言覆。应语言。长老。先别住者。已如法行。但少一夜。今覆者应更乞别住。合行共行摩那埵。共阿浮呵那。是名别乞共行别住。共行摩那埵。共阿浮呵那。比丘覆藏罪行别住已。行摩那埵。语比丘言。长老。我更有僧伽婆尸沙。应问言。是本罪中间罪。答言。中间罪。问言。何时犯。答言。摩那埵中。问言。覆不覆。答言覆。应语长老。先别住摩那埵已。如法行。但摩那埵中少一夜。今覆者应更乞别住行已。更乞摩那埵合行。共阿浮呵那。是名别乞别行别住。别乞摩那埵。共行摩那埵。共阿浮呵那。比丘覆藏罪行别住。摩那埵阿浮呵那竟。复语比丘言。长老。我更有僧伽婆尸沙。应问是本罪中间罪。答言。中间罪。问言。何时犯。答言。别住中间犯。问言覆不覆。答言覆。应语言。长老。先别住已。如法行。但少一夜摩那埵阿浮呵那。不成就。今覆罪应更乞别住合行已。更合乞摩那埵。共阿浮呵那。是名别乞共行别住。合乞摩那埵。共阿浮呵那。比丘覆藏罪行波利婆沙。摩那埵。阿浮呵那竟。复语比丘言。长老。我更有僧伽婆尸沙。应问是本罪中间罪。答言。中间罪。问言。何时犯。答言。摩那埵中。问言。覆不覆。答言覆。应语言。先别住摩那埵者已如法行。但摩那埵中少一夜。阿浮呵那不成就。今所覆者。应更乞别住。行已更乞摩那埵合行共阿浮呵那。是名别乞别行别住。别乞合行摩那埵。共阿浮呵那。比丘覆藏罪行别住中。语比丘言。长老。我更有二僧伽婆尸沙。问言。是本罪中间罪。答言。中间罪。问何时犯。答言。别住中。问覆不覆。答言。一覆一不覆。应语先别住者。已如法行。但少一夜不覆者。停覆者更乞别住。合行共行摩那埵。共阿浮呵那。是名别乞合行别住共行。摩那埵。共阿浮呵那。比丘覆藏罪行别住已。行摩那埵中。语比丘言。长老。我更有二僧伽婆尸沙。应问言。是本罪中间罪。答言。中间。问何时犯。答言。摩那埵中。问覆不覆。答言。一覆一不覆。应语先别住摩那埵。已如法行。但摩那埵中少一夜今不覆者停覆者应更乞别住行已。更合乞摩那埵。共阿浮呵那。是名别乞别行别住。合乞共行摩那埵。共阿浮呵那。比丘覆藏罪行别住摩那埵阿浮呵那竟。语比丘言。长老。我更有二僧伽婆尸沙。应问言。是本罪中间罪。答言。中间。问何时犯。答言。别住中。问言。覆不覆。答言。一覆一不覆。应语先别住已。如法行。但少一夜摩那埵。阿浮呵那不成就。今不覆者停覆者。应更乞别住。合行行已。合乞摩那埵共阿浮呵那。比丘覆藏罪行别住。摩那埵阿浮呵那竟语比丘言。长老。我更有二僧伽婆尸沙。应问是本罪中间罪。答言。中间。问何时犯。答言。摩那埵中。问覆不覆。答言一覆一不覆应语先别住摩那埵已如法行。但摩那埵中少一夜。阿浮呵那不成就今不覆者停覆者应更乞别住行已合乞摩那埵共阿浮呵那。复有比丘覆藏罪行别住中。语比丘言。长老。我更有三僧伽婆尸沙。应问言。是本罪中间罪。答言。中间。问言。何时犯。答别住中。问言。覆不覆。答言。一覆一不覆一疑。应语先别住者。已如法行。但少一夜。今不覆者停疑者。当决定。覆者应更乞别住合行。共行摩那埵。共阿浮呵那。至摩那埵中更说亦如是。比丘覆藏罪行别住摩那埵。阿浮呵那竟。语比丘言。长老。我更有三僧伽婆尸沙。应问言。是本罪中间罪。答言。中间。问何时犯。答言别住中。问覆不覆。答言。一覆一不覆一疑。应语先别住者。已如法行。但少一夜摩那埵。阿浮呵那不成就。不覆者停疑者。当决定。覆者应更乞别住。合行共行摩那埵。共阿浮呵那。摩那埵中更犯三罪。亦如上说。是名别乞别行别住。别行摩那埵。共阿浮呵那。是名中间罪。比丘故出精。犯僧伽婆尸沙。覆藏罪欲行别住。应请善知羯磨比丘。作是言。长老。与我作波利婆沙羯磨。将得意比丘至戒场上。作求听羯磨。羯磨人应作是说大德僧听。某甲比丘故出精。犯一僧伽婆尸沙罪。十夜覆藏。若僧时到。僧某甲比丘故出精。犯一僧伽婆尸沙罪。十夜覆藏欲从僧乞十夜别住法者。诸大德听。某甲比丘故出精。犯一僧伽婆尸沙罪。十夜覆藏欲从僧乞十夜别住僧忍默然故。是事如是持。此人应偏袒右肩胡跪合掌。作是言大德僧听。我某甲比丘故出精犯。一僧伽婆尸沙罪十夜覆藏。今从僧乞十夜别住哀愍故。唯愿僧与我十夜别住法。如是三乞。羯磨人应作是说。大德僧听。某甲比丘故出精。犯一僧伽婆尸沙罪十夜覆藏已。从僧乞十夜别住。若僧时到。僧某甲比丘故出精。犯一僧伽婆尸沙罪。十夜覆藏与十夜别住。白如是。大德僧听。某甲比丘故出精。犯一僧伽婆尸沙罪十夜覆藏已。从僧乞十夜别住法。僧今与某甲比丘故出精。犯一僧伽婆尸沙罪。十夜覆藏与十夜别住。诸大德忍。某甲比丘故出精。犯一僧伽婆尸沙。十夜覆藏。与十夜别住者默然若不忍者。便说是第一羯磨。第二第三亦如上说。僧已与某甲比丘。故出精犯一僧伽婆尸沙罪十夜覆藏与十夜别住竟。僧忍默然故。是事如是持。羯磨已此人即入界内应白僧偏袒右肩胡跪合掌。作是言大德僧听。我某甲比丘故出精。犯一僧伽婆尸沙罪十夜覆藏。我已从僧乞十夜别住。僧已哀愍故。与我十夜别住法。大德僧。我某甲比丘故出精。犯一僧伽婆尸沙罪。十夜覆藏。我今行别住法。僧忆念持如是三说。白言。我随顺行七事如是。若二若三乃至犯十罪者。应合乞别住羯磨羯磨人应作是说。大德僧听。某甲比丘犯十僧伽婆尸沙罪。故出精。乃至十罪。一切十夜覆藏若僧时到。僧某甲比丘犯十僧伽婆尸沙罪。故出精。乃至十罪一切十夜覆藏。欲从僧乞一切通合十夜别住诸大德听。某甲比丘犯十僧伽婆尸沙罪。十夜覆藏。欲从僧乞一切通合十夜别住。僧忍默然故。是事如是持。此人应从僧乞。偏袒右肩胡跪合掌作是言。大德僧。忆念我某甲比丘犯十僧伽婆尸沙罪。故出精。乃至十一切十夜覆藏今从僧乞一切通合。十夜别住。哀愍故。唯愿僧与我一切通合十夜别住法。如是三乞。羯磨人应作是说大德僧听。某甲比丘犯十僧伽婆尸沙罪。故出精。乃至十一切十夜覆藏已。从僧乞一切通合十夜别住法。若僧时到。僧某甲比丘犯十僧伽婆尸沙罪。十夜覆藏。一切通合与十夜别住法。白如是。大德僧听。某甲比丘犯十僧伽婆尸沙罪。故出精。乃至十一切十夜覆藏已。从僧乞一切通合十夜别住法。僧今与某甲比丘犯十僧伽婆尸沙罪。一切通合十夜别住诸大德忍。某甲比丘犯十僧伽婆尸沙罪。十夜覆藏。一切通合与十夜别住者默然若不忍者。便说是第一羯磨。第二第三亦如是说。僧已与某甲比丘犯十僧伽婆尸沙罪。十夜覆藏一切通合。与十夜别住竟。僧忍默然故。是事如是持若欲此中行者。即日应白僧偏袒右肩胡跪合掌。作是言。大德僧听。我某甲比丘犯十僧伽婆尸沙罪。故出精。乃至十一切十夜覆藏已。从僧乞一切通合乞十夜别住法。僧已哀愍故与我一切通合十夜别住法。大德僧听。我某甲比丘犯十僧伽婆尸沙罪。故出精。乃至十一切十夜覆藏。我今合行别住法。僧忆念持。如是三说。白言。我随顺行七事。此人当日日忆数满。应如是白。大德僧听。我某甲比丘犯十僧伽婆尸沙罪。故出精。乃至十一切十夜覆藏。我已从僧乞一切通合十夜别住法。僧已与我十夜别住法。我已行十夜别住法竟。僧忆念持。如是三说。若此间众满者。应行摩那埵。若不满者应求众满处。应请善知羯磨比丘得意人。将至戒场上。若无戒场者。不羯磨地。不得作僧事。羯磨地如上说。羯磨人应问。行别住满不。不空僧伽蓝行别住不。无本罪中间罪不。不共比丘同一房一障住不。客比丘来白不。时集非时集白不。如是捡挍如法已。若犯一若二若三乃至十罪。应合乞摩那埵。羯磨人应作是说。大德僧听。某甲比丘犯十僧伽婆尸沙罪。故出精。乃至十一切十夜覆藏已。从僧乞十夜别住。某甲比丘行十夜别住竟。若僧时到。僧某甲比丘犯十僧伽婆尸沙罪。十夜覆藏行别住竟。欲从僧乞通合六夜摩那埵。诸大德听某甲比丘犯十僧伽婆尸沙罪。十夜覆藏。行别住竟。欲从僧乞通合六夜摩那埵。僧忍默然故。是事如是持。此人应从僧中乞偏袒右肩胡跪合掌。作是言。大德僧听。我某甲比丘犯十僧伽婆尸沙罪。故出精。乃至十一切十夜覆藏。我已从僧乞十夜别住。我已行十夜别住竟。今从僧乞通合六夜摩那埵。哀愍故。唯愿僧与我通合六夜摩那埵。如是三乞羯磨人应作是说。大德僧听。某甲比丘犯十僧伽婆尸沙罪。故出精。乃至十一切十夜覆藏已。从僧乞十夜别住。某甲比丘行十夜别住竟。已从僧乞通合六夜摩那埵。若僧时到。僧某甲比丘犯十僧伽婆尸沙罪。故出精。乃至十一切十夜覆藏。行别住竟。一切通合与六夜摩那埵。白如是。大德僧听。某甲比丘犯十僧伽婆尸沙罪。故出精。乃至十一切十夜覆藏已从僧乞一切通合十夜别住。某甲比丘已行十夜别住竟。已从僧乞一切通合与六夜摩那埵。僧今与某甲比丘犯十僧伽婆尸沙罪。十夜覆藏行别住竟。通合与六夜摩那埵。诸大德忍。某甲比丘犯十僧伽婆尸沙罪。十夜覆藏行别住竟。通合与六夜摩那埵者。默然。若不忍者。便说是第一羯磨。第二第三亦如是说。僧与某甲比丘。犯十僧伽婆尸沙罪。十夜覆藏行别住竟。通合与六夜摩那埵竟。僧忍默然故。是事如是持。羯磨已。应即日入僧中白作如是说。大德僧听。我某甲比丘犯十僧伽婆尸沙罪。故出精。乃至十一切十夜覆藏已。从僧乞十夜别住法。我已行十夜别住竟。已从僧乞通合六夜摩那埵。僧已与我六夜摩那埵。大德僧听。我某甲比丘犯十僧伽婆尸沙罪。十夜覆藏。行别住竟。一切通合行六夜摩那埵。僧忆念持如是三说。白言我随顺行七事。如是三说。第二日应白作是说。大德僧听。我某甲比丘犯十僧伽婆尸沙罪。故出精。乃至十一切十夜覆藏。我已从僧乞十夜别住僧已与我十夜别住。我已行十夜别住竟。已从僧乞通合六夜摩那埵。僧已与我六夜摩那埵。我行摩那埵一夜已。过五夜在僧忆念持。如是三说。如是日日应白。乃至六夜应白作是说。大德僧听。我某甲比丘犯十僧伽婆尸沙罪。故出精。乃至十一切十夜覆藏。我已从僧乞十夜别住。僧已与我十夜别住。我已行十夜别住竟。已通合乞六夜摩那埵。僧已与我六夜摩那埵。我已行六夜摩那埵竟。至阿浮呵那。僧忆念持。若此间众满者。应请善知羯磨人作如是言。长老。与我作羯磨。羯磨人应问不减众行摩那埵不。究竟摩那埵不。无本罪中间罪不。不共比丘一房一障住不。客比丘来。白不时集非时集白不。日日白界内僧不。若一一如法者。羯磨人应作是说大德僧听。某甲比丘犯十僧伽婆尸沙罪。故出精。乃至十一切十夜覆藏已。从僧乞十夜别住。僧已与十夜别住。某甲已行十夜别住竟。已从僧乞通合六夜摩那埵。僧已与六夜摩那埵。某甲比丘已六夜行摩那埵竟。若僧时到僧某甲比丘犯十僧伽婆尸沙罪。十夜覆藏。行十夜别住摩那埵竟。欲从僧乞通合阿浮呵那。诸大德听。某甲比丘犯十僧伽婆尸沙罪。十夜覆藏通合行别住摩那埵竟。欲从僧乞通合阿浮呵那僧忍默然故。是事如是持。此人应从僧中乞偏袒右肩胡跪合掌作是言。大德僧听。我某甲比丘犯十僧伽婆尸沙罪。故出精。乃至十一切十夜覆藏已。从僧乞通合十夜别住。僧已与我十夜别住。我已行十夜别住竟。已从僧中乞通合六夜摩那埵。僧已与我六夜摩那埵。我已行六夜摩那埵竟。今从僧乞十夜覆藏罪。通合阿浮呵那。哀愍故。唯愿僧与我十夜覆藏罪。通合阿浮呵那。如是三乞。羯磨人应作是说。大德僧听。某甲比丘犯十僧伽婆尸沙罪。故出精。乃至十一切十夜覆藏。已从僧乞通合十夜别住。僧已与十夜别住法。某甲比丘已行十夜别住法竟。已从僧乞通合六夜摩那埵。僧已与六夜摩那埵。某甲比丘已行六夜摩那埵竟。已从僧乞十夜覆藏罪。通合阿浮呵那。若僧时到。僧某甲比丘犯十僧伽婆尸沙罪。故出精。乃至十一切十夜覆藏。通合行别住摩那埵竟。通合与阿浮呵那。白如是。大德僧听。某甲比丘犯十僧伽婆尸沙罪。故出精。乃至十一切十夜覆藏已。从僧乞通合十夜别住僧已与十夜别住。某甲比丘已行十夜别住竟。已从僧乞通合六夜摩那埵。僧已与六夜摩那埵。某甲比丘已行六夜摩那埵竟。已从僧乞十夜覆藏罪。通合阿浮呵那。僧今与某甲比丘犯十僧伽婆尸沙罪。故出精。乃至十一切十夜覆藏。通合行十夜别住。六夜摩那埵竟。通合与阿浮呵那。诸大德忍某甲比丘犯十僧伽婆尸沙罪。十夜覆藏。通合行十夜别住摩那埵竟。通合与阿浮呵那者。默然。若不忍者。便说是第一羯磨。第二第三亦如是说。僧已与某甲比丘十夜覆藏。一切通合十夜别住摩那埵。阿浮呵那竟。僧忍默然故。是事如是持。善男子听。汝已如法出罪。一白三羯磨。众僧和合满二十众。集僧作羯磨事难汝当谨慎莫复更犯。是名别住摩那埵。阿浮呵那。比丘摄竟。应羯磨不应羯磨者

佛住舍卫城。广说如上。瞻波比丘相言诤讼。不和合住。一人举一人二人举二人。众多人举众多人。诸比丘以是因缘。往白世尊。瞻波比丘非法生。一比丘举一比丘。二比丘举二比丘。众多比丘举众多比丘。佛告诸比丘。有四羯磨。何等四。有非法不和合羯磨。有非法和合羯磨。有如法不和合羯磨。有如法和合羯磨。非法不和合羯磨者。比丘无事僧与作折伏羯磨。诸比丘知非法故。遮不来。比丘不与欲持欲来不说。比丘无事僧与作折伏羯磨。不行随顺。与舍诸比丘知非法故。遮不来比丘不与欲持欲来者不说。是二俱名非法不和合羯磨非法。和合羯磨者。比丘无事僧与作折伏羯磨诸比丘不知非法故不遮不来。诸比丘与欲持欲来者。说比丘。无事僧与作折伏羯磨。不行随顺。与舍诸比丘。不知非法故不遮不来。诸比丘与欲持欲来者。说是二俱名非法和合羯磨。如法不和合羯磨者。比丘有事僧与作折伏羯磨。诸比丘不知如法故。遮不来。诸比丘不与欲持欲来者不说比丘有事。僧与作折伏羯磨。行随顺与舍诸比丘。不知如法故。遮不来。诸比丘不与欲持欲来者不说。是二俱名如法不和合羯磨如法和合羯磨者。比丘有事僧与作折伏羯磨。诸比丘知如法故。不遮不来。诸比丘与欲持欲来者。说比丘有事僧与作折伏羯磨。行随顺法与舍。诸比丘知如法故。不遮不来。诸比丘与欲持欲来者说。是二俱名如法和合羯磨。是中如法和合羯磨。是名应羯磨。余者不应。复有不应羯磨。比丘非折伏事。作折伏羯磨。诸比丘知非法故。遮人不现前。不问不引过。非法不和合。众不成就。白不成就。羯磨不成就。若一一不成就。是名不应羯磨。行随顺已应舍。舍者有六。作折伏羯磨。作不语羯磨。作摈出羯磨。作发喜羯磨。作举羯磨。作别住摩那埵羯磨。作折伏羯磨者。应随顺行五事。比丘事。比丘尼事。眷属事。羯磨事。王事。作折伏羯磨已。应语言长老。汝莫复更犯。犯者僧更重治汝。是五事应一一随顺行。行已折伏下意。僧应与作舍羯磨。是名舍作。不语羯磨者应随顺行五事。比丘事。比丘尼事。眷属事。羯磨事。王事。作羯磨已。应随顺行五事。虽复百岁应驱依止持戒下至知二部律十岁比丘。晨起应问讯。与出大小行器唾壶。举置常处与齿木。与扫地迎食。浣衣熏钵。一切尽供给。唯除礼拜按摩。若病时得令按摩。应教二部律。若不能者。教一部律。若复不能者。应广教五众戒。应教善知阴界入十二因缘。应教善知罪相非罪相。威仪应教非威仪应遮。若学已。即名为舍。作摈出羯磨者。应随顺行五事。比丘事。乃至王事羯磨已。应安着僧伽蓝边住。随顺行五事。一一如法已应与舍。是名舍摈出作发喜羯磨者。应随顺行五事。比丘事。乃至王事。羯磨已。应遣到所犯俗人家悔过。若俗人言。尊者。故在精舍中住耶。若故在彼住者。我当断彼食及衣钱物僧应语言。此非僧过。汝应更往向彼下意。令其欢喜。若彼喜者。即名为舍。作举羯磨者。应随顺行五事。比丘事乃至王事羯磨已。应安着僧伽蓝外边门。向阿练若处。若来入塔院僧院中。扫地者。比丘应逆扫其迹。若来益洗脚处水。大小行处水者。应还泻弃。若共行弟子依止弟子者。不得唤作和上阿阇梨弟子。不应语言。被举余人。应语随顺行。应舍恶邪。恶邪比丘不应共语。不应共住。不应共法食。不共佛。不共法。不共僧。不共布萨。不共自恣。不共羯磨。得语外道欲坐便坐。不得语。被举令坐。若病者。不应看病得语。彼檀越若亲里言。被举人病。汝往看。若无常者不应与华香供养尸不应为作饮食非时浆。供养僧不应分衣钵。不应与烧身取其所眠床。以尸着上。衣钵系咽曳床而出。作是言。众僧事净众僧事净。于恶邪比丘。不应起恶心。何以故。乃至燋柱不应起恶。应作是念。莫令后人习此邪见。若放牧人。取薪草人。持衣钵来施者得取。即彼为施主。若被举人。随顺行五事。得正见心意调软者。得与舍行。波利婆沙摩那埵。比丘应随顺行七事。比丘事乃至王事。广解如上说。是名舍。作他逻咃者。佛住舍卫城。广说如上。尔时须达居士语姊言。姊住。是聚落中为我料理。客僧时瞻波比丘众来。见已欢喜。共相问讯。善来大德。与敷置床褥。请令就座。坐已与洗脚水涂足油非时浆。夜与灯火已。头面礼足胡跪合掌。作是言。大德僧。为我故明日受我食。即受请已。须臾第二众来。复为敷床褥。请令就坐。与洗脚水涂足油非时浆已。头面礼足胡跪合掌。作是言。大德僧。明日为我故受我食。此众言。我不共彼食。问言。何故。答言。是被举人。彼言。我非被举。复言。汝是被举人。何故言非如是被举。不被举竟。夜共诤。邻比俗人发不喜心。居士姊闻已嫌言。云何沙门竟夜共诤。被举不被举。生不喜心。晨起竟不与前食后食。驾草马车还舍卫城。诣须达居士所。具说上事。乃至竟不料理。居士闻已。心怀不乐。语姊言。此是恶事应与。何故不与。是法非法事在沙门。尔时须达。往世尊所。头面礼足却坐一面。具以上事乃至被举不被举。具白世尊。被举人我等当云何恭敬供养。唯愿世尊。具分别说。佛告居士。有义应知无义亦应知。是法非法。是律非律。皆悉应知。是中有义如法如律。行者应供给。无有方便。被举比丘得共从事。佛告居士。但当行施作诸功德。是法非法。沙门自知时。大爱道比丘尼。往世尊所。头面礼足却住一面。白佛言。世尊。我等当云何。乃至无有方便。被举比丘得共从事。尔时尊者阿难优波离。往世尊所亦复如是

尔时尊者舍利弗白佛言。世尊。被举比丘我等云何得知。乃至无有方便。被举比丘得共从事。尔时舍利弗白佛言。世尊。云何名他逻咃。佛语舍利弗。有七事。非他逻咃。似他逻咃。二他逻咃。何等七。或有狂故不着。此众不着彼众。谓是他逻咃。是最初非他逻咃。似他逻咃。如是心乱钝痴病。病故不着。此众不着彼众。复次舍利弗。或有人为利故。作是念。若我着此众失彼利。若着彼众失此利。是二俱不着。复次或有人得二众利故。作是念。我为得二边利故。不着此众。不着彼众。舍利弗。是名七事。非他逻咃。似他逻咃。二他逻咃者。自护心待时自护心者。见他是非。作是念。业行作者自知。譬如失火。但自救身。焉知他事。是名自护心。待时者。或有人见他诤讼相言。作是念。此诤讼相言时到。自当判断。是名二他逻咃。尔时舍利弗白佛言。世尊。云何名中他逻咃。佛告舍利弗。有一人共此众法食味食。亦共彼众法食味食请断当事。复次舍利弗。中他逻咃亦共此众法食味食。亦共彼众法食味食。人不请而断当事。时舍利弗白佛言。世尊。他逻咃比丘欲料理被举比丘。当云何佛告舍利弗。被举人行随顺法。心柔软欲料理者。不得时集非时集。为料理当先于房若温室。若讲堂上。若众多人集处应往诱问年少比丘。长老颇闻。汝和上阿阇梨语。若中间有人料理。被举人当听不。若言我闻和上阿阇梨语。若被举人行随顺法。心柔软。设有人为语者。合此人治。若闻是语默然而止。若言我闻和上阿阇梨语。被举人行随顺法。心柔软可怜。无人为其料理。闻是语者。不得故集众。当因时集非时集。如是舍利弗。被举人到布萨自恣日。应至僧中作是言。我被举比丘行随顺法。心柔软与我舍。如是三说已。应还出出时不得默然而去应偏袒右肩合掌却行。若众中有人语者。他逻咃比丘应问。长老此人本何事。故被举。复有人嫌言。此人被举。何故不知应当合治。若闻是语应默然止。若言长老此人被举行随顺法。心柔软无人料理。可与舍他逻咃。比丘应语言。长老。世尊说有二人刚强未治者。应治已治。柔软者应舍。若如是得众人意者。应作求听羯磨已听乞。羯磨人应作是说。大德僧听某甲比丘有是事。僧欲饶益故。作举羯磨。彼行随顺法。心柔软。若僧时到。僧某甲比丘欲从僧乞舍举羯磨。诸大德听。某甲比丘欲从僧乞舍举羯磨。僧忍默然故。是事如是持。此人应乞偏袒右肩胡跪合掌作是言。大德僧听。我某甲比丘有是事僧欲饶益故。作举羯磨。我已行随顺法。心柔软。舍本恶见。今从僧乞舍举羯磨。哀愍故。唯愿僧与我舍举羯磨。如是三乞。羯磨人应作是说。大德僧听。某甲比丘有是事。僧欲饶益故。作举羯磨。彼行随顺法心柔软。舍本恶见。已从僧中乞舍举羯磨。若僧时到。僧与某甲比丘舍举羯磨白如是。大德僧听。某甲比丘有是事。僧欲饶益故。作举羯磨。彼行随顺法心柔软。舍本恶见。已从僧中乞舍举羯磨。僧今与某甲比丘舍举羯磨。诸大德忍。僧与某甲比丘舍举羯磨者默然。若不忍者便说是第一羯磨。第二第三亦如是说。僧已与某甲比丘舍举羯磨竟。僧忍默然故。是事如是持。是名他逻咃。异住者

佛住舍卫城。广说如上。尔时须达居士语姊言。住是聚落中。有客僧来。为我供给。时瞻波比丘众来见已欢喜。请令就座。随宜供给已胡跪合掌。作是言。唯愿大德。明日受我施食。须臾第二众来。即请就座种种供给已。请明日食。此众言。我不共彼众食。问言。何故。答言。彼众破僧。彼言。我不破僧。复言。汝实破僧。何故言不如是。竟夜共诤。邻比俗人闻已发不喜心。居士姊不悦。遂不供给。早起驾草马车还舍卫城。向须达具说上事。居士闻已。往世尊所。头面礼足却住一面。即以上事。具白世尊。世尊。此破僧人我等得恭敬供养不。唯愿世尊。具分别说。佛告居士。有义应知。无义亦应知。是法非法。是律非律。皆悉应知。此中有义如法如律应供给。无有方便。破僧人应与共住。佛语居士。但当行施。作诸功德。是法非法事在沙门。尔时大爱道比丘尼白佛言。世尊。此破僧人我等云何得知。如上广说。尔时尊者阿难舍利弗优波离。往世尊所。头面礼足却住一面。白佛言。世尊。破僧人我等云何得知。佛语优波离。有义应知。无义亦应知。是法非法。是律非律。此中有义如法如律。当行无一方便。破僧人应共住。尔时尊者优波离白佛言。世尊。云何名破僧。佛告优波离。有二事名破僧。何等二。一者增恶法。二者增恶人。复问。非法众满如法众减名破僧不。不也。复问。非法众减。如法众满名破僧不。不也。复问。非法众满如法众若减十若十五名破僧不。不也。复问。非法众满。如法众满。若减十若十五。是中若一一法语人坐。名破僧不。不也。复问。若非法众满。如法众满。若减十若十五。是中若一一法语人。不坐不与欲。不与见不欲。名破僧不。不也。复问。若非法众满。如法众满。若减十若十五。若一一法语人。不坐不与欲。不与见不欲强牵。未受具足人足数。名破僧不。不也。复问。若非法众满。如法众满。若减十若十五。若一一法语人。不坐不与欲。不与见不欲。不强牵。未受具足人足数。一切尽欲破僧。名破僧不。不也。佛告优波离。非法众满。如法众满。若减十若十五。若一一法语人不坐不与欲。不与见不欲。不强牵。未受具足人足数。复不一切欲破僧。但一住处。共一界。别众布萨。别自恣。别作僧事。是名破僧。若知是欲破僧人者。诸比丘应语长老。莫破僧。破僧罪重堕恶道。入泥犁。我当与汝衣钵。授经诵经。问事教诫。若故不止者。应语有力势优婆塞言。长寿。此人欲破僧。当往谏晓。语令止优婆塞。应语尊者。莫破僧。破僧罪重。堕恶道入泥犁中。我当与尊者衣钵病瘦汤药。若不乐修梵行者。可还俗。我当与汝妇。供给所须。若故不止者。应拔舍罗筹驱出。出已应当唱令作是言。诸大德。有破僧人来。宜当自知。若如是备犹故破僧者。是名破僧。若于中布施故。名良福田。于中受具足故。名善受具足。若觉已应去。若不去者。是名破僧伴。是破僧伴党。尽寿不应共语共住共食。不共佛法僧。不共布萨安居。自恣不共羯磨。得语余外道。出家人有床座。欲坐便坐。不得语彼坐。是名异住。与波罗夷学悔者

佛住舍卫城。广说如上。尔时舍卫城中。有难提不乐在家。舍家出家。行亦禅住。亦禅坐。亦禅卧。亦禅时。亦有众多难提即名此禅难提。如波罗夷中广说。诸比丘即驱出。出已在只桓门间立啼。作是言。长老。我犯波罗夷。无一念覆藏心。我乐袈裟。不欲舍离佛法。时难提母来复啼。作是言。我儿乐出家而世尊驱出。难提姊复来亦啼。作是言。我弟乐作沙门。而世尊驱出。诸比丘以是因缘。往白世尊。佛告诸比丘。是难提犯波罗夷。无一念覆藏心。僧应与波罗夷学悔羯磨。此人应从僧乞。偏袒右肩胡跪合掌。作是言。大德僧听。我难提犯波罗夷。无一念覆藏心。今从僧乞波罗夷学悔。哀愍故。唯愿僧与我波罗夷。学悔羯磨如是三乞。羯磨人应作是说。大德僧听。难提比丘犯波罗夷。无一念覆藏心。已从僧乞波罗夷。学悔羯磨。若僧时到。僧与难提波罗夷。学悔羯磨。白如是。大德僧听。难提比丘犯波罗夷。无一念覆藏心。已从僧乞波罗夷。学悔羯磨。僧今与难提比丘波罗夷。学悔羯磨诸大德忍僧与难提比丘波罗夷学悔羯磨者默然。若不忍者便说是第一羯磨。第二第三亦如是说。僧已与难提比丘波罗夷学悔羯磨竟。僧忍默然故。是事如是持。此人应在一切比丘下坐一切沙弥上。不得与比丘同屋过三宿。复不得与沙弥过三宿。比丘不净食彼亦不净。彼不净食。比丘亦不净。得与比丘授食。除火净五生种及金银。彼应从沙弥受食。比丘不得向说波罗提木叉。波罗夷罪。僧伽婆尸沙乃至越毗尼罪。得语言不得作非梵行。不得盗。不得杀。不得妄语。不得饮酒。如是一一得教授。若本诵波罗提木叉者。不得高声诵。若敬法者。得心诵。不得听布萨受自恣。布萨受。自恣日。到僧中作如是言。我清净僧忆持。如是三说已应还四波罗夷中。若有犯者。应驱出十三僧伽婆尸沙已下一切作突吉罗悔。是名与波罗夷学悔羯磨随顺行。觅罪相者。佛住舍卫城。广说如上。尔时尸利耶婆比丘。数数犯僧伽婆尸沙罪。僧集欲作羯磨。尸利耶婆不来。即遣使往唤。作是言。长老。众僧集欲作羯磨。何故不来。尸利耶婆言。僧必为我故。作羯磨耳。即心生恐怖而来。诸比丘问长老。犯僧伽婆尸沙罪耶。答言犯。彼心生欢喜。作是念。诸梵行人于我起慈心。举可悔过罪非不可悔。即白听我小出。出已诸比丘于后作是言。此比丘轻躁不定出去。须臾当作妄语。应当三过定实。然后作羯磨。是尸利耶婆出外作是念。我何故而受是罪。诸比丘数数治我罪。我不应受。诸比丘唤尸利耶婆入。入已问言。汝实犯僧伽婆尸沙罪不。答言不犯。复问汝何故僧中说有是罪。而言不犯。答言。我不忆是事。诸比丘以是因缘。往白世尊。佛言。呼尸利耶婆来。来已佛广问上事。汝实尔不。答言实尔。佛告诸比丘。是尸利耶婆于众僧中言见罪。复言不见。不见复言见。作是语言不忆。僧应与作觅罪相羯磨。羯磨人应作是说。大德僧听。尸利耶。婆比丘僧中见罪言不见。不见复言见。自言不忆。若僧时到。僧与尸利耶婆觅罪相羯磨。白如是。大德僧听。尸利耶婆比丘僧中见罪言不见。不见言见。自言不忆。僧今与作觅罪相羯磨。诸大德忍僧与尸利耶婆觅罪相羯磨者默然。若不忍者便说是第一羯磨。第二第三亦如是说。僧已与尸利耶婆觅罪相羯磨竟。僧忍默然故。是事如是持。此人尽寿应行八事。何等八。不得度人。不得与人受具足。不得与人依止。不得受比丘按摩供给。不得作比丘使。不得受次第差会。不得为僧作说法人。尽寿不与舍。僧和合作觅罪相羯磨。已行此八事。尽寿不应与舍。是名觅罪相随顺行

  举羯磨别住　　摩那埵出罪
  应不应随顺　　他逻咃异住
  学悔觅罪相　　第二跋渠竟

举事者。佛住舍卫城。广说如上。尔时瞻波比丘斗诤相言。不和合住。一比丘举一比丘。二比丘举二比丘。众多比丘举众多比丘。作是言。我举长老。我举长老。尔时尊者优波离以是因缘。具白世尊。瞻波比丘非法生。一比丘举一比丘。乃至众多比丘举众多比丘。世尊有几事比丘。得举他人。佛告优波离。有三事三因缘。比丘得举他人。何等三事戒不净。见不净命不净。何等三因缘。见闻疑是名三。复次比丘自身成就五法。得举他人。何等五。是实非虚。是时非非时。是饶益非不饶益。是软语非粗犷。是慈心非嗔恚。是名五法得举他人。又复成就五法。得举他人。何等五。净身业。净口业。正命。多闻阿毗昙。多闻毗尼。优波离若身业不净。举他者前人应语。长老。自身业不净。何故举他。应先自净身业。然后举他。是故优波离欲举他者。先当净身业净口业正命亦如是。若少闻阿毗昙举他者。前人应语。长老。何故少闻阿毗昙而举他罪。善哉长老先当多闻阿毗昙。然后举他。是故优波离欲举他者。先当多闻阿毗昙。若少闻毗尼。欲举他者。前人应语。长老。何故少闻毗尼而举他罪。长老亦不知因何事制此戒。在何国聚落城邑制此戒。善哉长老。欲举他者。先当多闻毗尼。然后举他。是故优波离欲举他者。应先多闻比尼。是名自身成就五法得举他人。复次优波离。有五非法举他何等五。有骂而后举有举而后骂。有即举而骂有骂而不举。有举而不骂。骂而后举者先恶骂已后五众罪中。若举一一罪。是名骂而后举。举而后骂者先五众罪中。若举一一罪。已后恶骂是名举而后骂即举而骂者恶骂已汝犯波罗夷。恶骂已汝犯僧伽婆尸沙罪乃至越毗尼罪。是名即举而骂。举而不骂者五众罪中若一一罪举而不恶骂。是名举而不骂骂而不举者。作种种恶骂而不举罪是名骂而不举是中先骂后举举已后骂。即举而骂者。僧不应问。不应受。是中举而不骂者。僧应检校。若欲举他时。应先语长老我欲举事听举不前人言。欲举者可尔。若不问听而举者。越毗尼罪。优波离他戒不净不见不实非时非饶益粗犷非软语。嗔恚非慈心举人者越毗尼罪。闻疑亦如是。他见不净不见非实。非时非饶益粗犷非软语嗔恚非慈心举他者。越毗尼罪。闻疑亦如是。他命不净不见不实非时非饶益。粗犷非软语。嗔恚非慈心举他者越毗尼罪。闻疑亦如是优波离。他戒不净见实时。是饶益是软。语非粗犷。是慈心非嗔恚。不语前人。前人不印可举者。越毗尼罪闻疑亦如是。他见不净见实时。见饶益是软语非粗犷。是慈心非嗔恚。不语前人。前人不印可举者越毗尼罪。闻疑亦如是。他命不净见实时。是饶益是软语非粗犷。是慈心非嗔恚不语前人。前人不印可举者。越毗尼罪。闻疑亦如是。复有五法成就。众僧中不应举他。何等五。随爱随嗔随怖随痴为利故。若成就此五事。举他者身坏命终。堕恶道入泥犁。复有五法成就得举他何等五。不随爱不随嗔不随怖不随痴不为利故。若成就此五法得举他。身坏命终得生善道。梵行人所赞叹。是名举。治事者。云何治犯波罗夷罪。应还俗人。作沙弥僧应驱出。犯僧伽婆尸沙罪。若覆者与波利婆沙。摩那埵。阿浮呵那。不覆者行摩那埵。阿浮呵那。犯尼萨耆波夜提罪者。此长物应僧中舍已。在长老比丘前。偏袒右肩胡跪合掌。作是言。我长衣过十日已。众僧中舍犯波夜提罪悔过。前人问言。汝见。此罪不。答言见。语言莫更作。答言我顶戴持。乃至羯磨衣与一人。后应还犯波夜提。乃至越毗尼罪亦如是。悔驱出者。有七事坏尼净行盗住越济五逆。不能男。犯四波罗夷。沙弥恶见是名七事应驱出。异住者

佛住王舍城如提婆达多因缘中广说。乃至提婆达多走向伽耶城。佛于后向伽耶城。其日应布萨。佛语阿难。汝去语提婆达多来今日僧作布萨羯磨事阿难即往作是言长老今日僧作布萨羯磨。世尊唤提婆达多。答言。我不去。从今日后不共佛法僧不共布萨自恣羯磨。从今日后波罗提木叉欲学不学自从我意。阿难闻是语已作是念。此是奇事。出是恶声。将无坏僧耶。阿难还以上事具白世尊佛语阿难汝更往提婆达多所。乃至阿难作是念。奇事出是恶声。将无坏僧。阿难还后六群比丘自相谓言沙门瞿昙必当三遣使来我等各各正意先作布萨事。我等作后世名誉。佛在世时。提婆达多六群比丘共破僧。即布萨竟。阿难以是因缘。具白世尊。佛言。汝更第三往语提婆达多来。今日僧作布萨羯磨。阿难即往。作是言。世尊唤。今日僧作布萨羯磨答言我不去。自今日后不共佛法僧。不共布萨自恣羯磨。从今日后波罗提木叉毗尼。欲学不学自从我意但我等已作布萨竟。阿难闻已。作是念。奇哉已坏僧竟。即还以上因缘具白世尊。世尊闻已。即说此偈

  清净如月满　　清净得布萨
  身口业清净　　是乃应布萨

佛告阿难。非法人已作布萨竟。如法人应作布萨。尔时提婆达多破僧。六群比丘破僧伴党。是名异住

摩诃僧祇律卷第二十六摩诃僧祇律卷第二十七

        东晋天竺三藏佛陀跋陀罗共法显译

    明杂诵跋渠法之五

羯磨法者。佛住舍卫城。广说如上。尔时瞻波比丘诤讼相言不和合住。诸比丘以是因缘。往白世尊。佛语诸比丘。从今日僧应羯磨。优波离为瞻波比丘断当事。羯磨人应作是说。大德僧听。长老优波离五法成就。若僧时到。僧拜长老优波离。为瞻波比丘断当事。白如是大德僧听。长老优波离五法成就。僧今拜优波离为瞻波比丘断当事。诸大德忍僧拜优波离为瞻波比丘断当事忍者默然。若不忍者便说。是第一羯磨第二第三亦如是。僧已拜优波离为瞻波比丘断当事竟。僧忍默然故。是事如是持。羯磨法者有二十。八白一羯磨如前说。八白三羯磨。拜断事人。拜教诫比丘尼人。拜一月羯磨[袖-由+(旃-方)]羯磨痴羯磨发露羯磨覆钵羯磨。拜学家羯磨。是名八白三羯磨。是中拜断事人拜教诫比丘尼人。众僧应求不离衣宿羯磨一月[袖-由+(旃-方)]羯磨。前人应从僧乞痴羯磨说他罪羯磨。是羯磨应内界僧现前作羯磨非外界。学家羯磨覆钵羯磨应界内僧现前作羯磨非外界。断事人受拜已不得停住。若晨起受拜晡时应发。脯时受拜晨起应发。去时不得从檀越迂回道。应从直道。若直道有难者回道无罪。到彼已不得停住。待客比丘食。若晡时到者晨起应断。晨起到者晡时应断。不得染衣熏钵坐禅诵经。若事难断中间闲者作无罪。断事竟还亦如是。是名羯磨法。园田法者

佛住舍卫城。广说如上。尔时诸比丘。以僧田地或借人。或卖或自私受用。诸比丘以是因缘。往白世尊。佛告诸比丘。从今日后众僧田地不得借人。不得卖不得私受用。正使一切集僧亦不得借人。不得卖不得私受用。若集僧借人卖私受用者。越毗尼罪若园田地好恶人欲侵者得语檀越知是地。若檀越言。此是好园田何故知。应答言。此园田虽好恶人欲侵。任檀越转易

复次佛住舍卫城。广说如上。尔时僧地王地并王地入僧地中。时王波斯匿语尊者阿难言。王地入僧地中。可持绳来共分地。阿难答言。须我白佛。阿难以是事往白世尊。佛语阿难。汝往语王。王是地主。沙门释子依王而住。不应共王分地阿难受教即诣王所作是言。佛语大王。王是地主。沙门释子依王而住。不得与王分地王言若然者一切并施与僧。今日故名王园后人得知。复次佛住舍卫城。广说如上。尔时僧有空地。时有长者来问。是谁空地。答言是僧地。长者言。若僧地者可与我。我欲为僧作房。僧即与。经久不作。复有一居士问言。是谁空地。答言僧地。居士言。可与我。我欲为僧作房。比丘答言。本已有长者索但不作。居士言。尊者但与我。何忧不作。比丘即与居士为功德。倾家财宝作好房舍。办种种饮食供养众僧。即以房舍施僧。复请前长者来共随喜。长者见已问言。尊者。是谁作房。答言。某甲居士。长者言。此地已先与我。何故复与居士。诸比丘以是因缘。往白世尊。佛言。何故不先作要持地与他。从今日后。不听应不先作要持地与人。僧有空地若人来索与僧作房者。应先与要齐几时得作。若前人言齐尔许时作。应语言。若尔许时不作者。当更与余人。若二人俱索。一人言。我为众僧作一重阁。一人言。我作二重阁。僧应与二重者。如是三四重乃至七重。若俱言作七重者。尔时当相望其人。应与能成办者。若二人俱能成办。应与眷属多者。若不先作要与地者。越毗尼罪

复次佛住舍卫城。广说如上。尔时比丘于僧地中作草屋。时上座来次第付房。此比丘不与。诸比丘以是因缘。往白世尊。佛告诸比丘。若僧地中作房。上座来次第不与者。应持草木更余处去。若僧地中作房。上座来不次第与者。越毗尼罪田宅法者。若众僧有好田宅贵价。与恶人邻接欲侵欺者。得语檀越知是田宅。若檀越言。此贵价田宅。何故欲知。应语言。此田宅虽好恶人邻接常欲侵夺。若言欲转易耶。答言任檀越知。若檀越转易者无罪。是名田宅法。僧伽蓝法者

佛住舍卫城。广说如上。尔时比丘逼僧伽蓝作房。旧知事人语言长老。莫逼僧住处起房。此比丘言长老。我为僧作房。莫于中作障碍。二人共诤不解。遂至佛所。以上事具白世尊。佛言。从今日后不得逼僧旧住处为僧作房。旧比丘亦不得于中作障碍。若二知事比丘意相得者。得共一覆别障。别覆共障。共覆共障。别覆别障。若二人不相喜者。别覆别障作。若逼旧房。为僧作屋者。越毗尼罪。为僧作房于中障碍者。亦越毗尼罪

复次佛住舍卫城。广说如上。尔时比丘多人行处。起声闻塔。诸居士来欲礼拜世尊。见已嫌言。来欲礼拜世尊足。未见世尊先见死人冢。诸比丘以是因缘。往白世尊。佛告诸比丘。汝云何多人行处。先不羯磨地而起声闻塔。从今日后不听多人行处先不羯磨地而起声闻塔。应当先作求听羯磨。羯磨人应作是说。大德僧听。某甲比丘无常若般泥洹若僧时到。僧某甲比丘无常若般泥洹。于此处起声闻塔。诸大德僧听。若甲比丘于此处起声闻塔。僧忍默然故。是事如是持。若不和合者应语长老。世尊说四人应起塔起相轮悬施幡盖。如来声闻辟支佛转轮圣王是。无常比丘若是须陀洹应语须陀洹。斯陀含阿那含阿罗汉应语阿罗汉。若言持律若言法师。若言营事德望比丘。应语长老。是人持戒贤善。多供养僧执事有劳。应与起塔。如是语已当为起塔。作声闻塔。不得先见塔后见世尊。当令先见世尊后见塔。不得在多人行处当在屏处。不得在比丘经行处。若多人行处起声闻塔者。越毗尼罪

复次佛住舍卫城。广说如上。尔时尊者迦露。在迦尸耆梨大邑住。时有上座比丘来次第付房而不肯与。嗔恚捉[钁-(目*目)+賏]自斲房破。诸比丘以是因缘。往白世尊。此比丘犯何等罪。佛言。破六种得偷兰遮。何等六。破钵破衣破塔破房破僧破界。破钵者。钵有三种上中下。若一一嗔恚破者。得偷兰罪。若钵破欲缀。误钻破者无罪。若拘钵多罗键镃。嗔破者。得越毗尼罪。破衣者。三衣中若一一。衣嗔裂者。得偷兰罪。若欲易边着中中着边。若补作两重无罪。若尼师坛及余种种衣。嗔裂破。越毗尼罪。破塔者。若嗔恚破世尊塔者。得偷兰罪。业行罪报多。若欲治更作好者无罪。若尼揵塔及余外道塔。嗔恚破者。越毗尼罪。破房者。嗔恚破僧房者偷兰罪。若欲更好作者无罪。若嗔恚破外道僧房者。越毗尼罪。破僧者。嗔恚破和令僧。偷兰罪。业行果报一劫泥梨中。破界者。若嗔恚过界作不名作。偷兰罪。得舍界已更羯磨界是名破六种偷兰罪

复次佛住舍卫城。广说如上。尔时尊者罗睺罗。跋耆国游行。渐渐至波罗柰林聚落。此聚落中有一居士。为罗睺罗起房。罗睺罗受已复游行。是居士以此房更施余比丘。罗睺罗还。如线经中广说。乃至罗睺罗白佛言。世尊。此房谁应得。佛语罗睺罗。若居士居士儿。信心欢喜作房施僧。施僧已还转施众多人。是非法施非法受用。若施众多人已还转与一人。是非法施非法受用若施一人已转与众多人。若施众多人已转与众僧。是非法施非法受用。施僧已不转与众多人施众多人已不转与一人。是名如法施如法受用。佛语罗睺罗。前与者是施。后与者非施是王地依止住是中。前作前施功德日夜增长罗睺罗汝应得房。后者不应得。是名僧伽蓝法。营事法者

佛住王舍城。广说如上如尊者达腻迦瓦师子作房。如第二波罗夷中说。乃至作是嫌言。我辛苦作房。不避寒暑作房才成。上座已夺。如猫伺鼠。诸比丘以是因缘。往白世尊。佛告诸比丘。是营事比丘作房甚苦。应羯磨与营事比丘五年住。羯磨人应作是说。大德僧听。某甲比丘欲为僧作房。若僧时到。僧某甲营事比丘为僧作房。欲从僧中乞五年住。诸大德听。某甲营事比丘欲从僧乞五年住。僧忍默然故。是事如是持。是比丘应乞。偏袒右肩胡跪合掌作是言。大德僧听。我某甲比丘为僧作房。今从僧乞营事五年住。哀愍故惟愿僧与我营事五年住。如是三乞。羯磨人应作是说。大德僧听。某甲比丘为僧作房已。从僧乞五年营事住。若僧时到。僧与某甲比丘五年营事住。白如是。大德僧听。某甲比丘为僧作房已。从僧乞五年营事住。僧今与某甲比丘营事五年住。诸大德忍僧与某甲比丘营事五年住者默然。若不忍者便说。是第一羯磨。第二第三亦如是说。僧已与某甲比丘五年营事住竟。僧忍默然故。是事如是持。僧已羯磨与五年住。还得自所作房。复应次第得僧房。若有上座来次第得者应与。羯磨得者不应与。若欲游行者。是二房应付僧随次第住。我来时当还取后来时从前日令满。若先是僧房破坏。更易户向二年三年。随功夫多少。应羯磨与住。若空房不任住治事者。应与一时住。若床机枕褥垢腻破更浣染补治事者。应与一时住。若中间比丘嫌者。越毗尼罪。是名营事法。床褥法者

佛住舍卫城。广说如上。尔时比丘安居中间。上座来随次第取房。比丘运辇出房。佛知而故问比丘。是客比丘耶。非也世尊。是去比丘耶。非也世尊。是何等比丘运辇。答言世尊。随次第取房。是故运徙。佛告诸比丘。汝等云何一切时随上座次第起。从今日后不听一切时随上座次第起。僧应拜成就五法人。知付房舍床褥。何等五法。不随爱不随嗔不随怖不随痴知得不得。是名五。羯磨人应作是说。大德僧听。某甲比丘五法成就。若僧时到。僧拜某甲比丘。典知付房舍床褥。白如是。大德僧听。某甲比丘五法成就僧今拜典知付房舍床褥。诸大德忍僧拜某甲比丘典知付房舍床褥。忍者默然。若不忍者便说。僧已忍拜某甲比丘典知付房舍床褥竟。僧忍默然故。是事如是持羯磨已。从三月十六日已去。应语檀越浣治床褥房舍。治禅坊讲堂温室厕屋。治门屋井屋僧伽蓝所有及斋日饮食安居衣应一一条疏。若城邑聚落僧住处远者。至四月十三日应付房。若不相容受者得余处去。若住处相近者。十五日应付房。应众僧中读此疏。某甲僧伽蓝。有尔许房舍尔许床褥尔许斋日饮食尔许衣。上座应语付房舍共一安居施。作是语已应付房舍。不得与沙弥房。若和上阿阇梨言。但与房舍我自料理得与。若房舍多者。一人与两房。若不肯取两。我正得一房足。尔时应语。是不为受用故与。为治事故与。若比丘多房舍少者。应两人三人共与一房。若故不足。应五人十人共与一房。若正有一大堂者。一切比丘应入中住。上座应与卧床。余者与坐床。若故不足者。上座与坐床。余者敷草蓐。若故不足者。上座敷草蓐。余者跏趺坐。若复不足者。上座跏趺坐。余者立住。若复不足者。上座立。余者出外树下若空地。若冬时付房舍。治事故与。受用故与。若上座来随次第住。春时付房舍。治事故与。受用故与。若上座来随次第住。安居时付房舍。治事故与。受用故与。上座来不应次第住。若比丘不知法。安居中索次第房。不得即嫌。应语住须我问知房舍人。应语知房人言。长老。有客比丘上座来语我起。知房人应呵责言。长老。汝不善知戒相。云何安居中起他。汝不知耶不得一切时驱他起。若冬春上座来次第应起不起者。越毗尼罪。若比丘不善知戒相。安居时驱他起者。越毗尼罪。是名床褥法。恭敬法者。佛拘萨罗国游行。世尊。初夜为声闻说法。中夜自还房。尔时诸比丘。有供给人先为取房。听法已各到房眠。尔时尊者舍利弗目连无供给人。初夜听法已。中夜到房挠户。问言是谁。答言是舍利弗。房已满。大智。复有挠户。问言是谁。答言我是大目连。房已满。大神足。二人不得房。已一人在屋檐下坐。一人在树下坐。时天夜雨。檐下坐者。说是偈言

  檐下跏趺坐　　屋漏两膝头
  已得安乐住　　当断后边身

树下坐者。说是偈言

  树下知止足　　乞食草蓐坐
  是二不贪着　　当断后边身

时有优婆塞。晨起来欲礼觐世尊。见已嫌言。云何沙门释子无恭敬法。如是大德人而不与房住。诸比丘以是因缘。往白世尊。佛言。是正应为世人所嫌。佛告诸比丘。待我拘萨罗国游行还舍卫城语我。当为诸比丘制恭敬法。还已诸比丘以是因缘。往白世尊。佛告诸比丘。谁应最上坐。先取水先受食。谁应受礼谁应起迎。谁应合掌低头恭敬。或有比丘言。世尊子应受。有比丘言。世尊亲里应受。复有言。世尊侍者应受。复有言阿罗汉应受。刹利出家者言。刹利应受。婆罗门出家者言。婆罗门应受。毗舍出家者言。毗舍应受。首陀罗出家者言。首陀罗应受。佛告诸比丘。汝等各各长慢故作是语。与世尊子乃至首陀罗。非是人法。如来应供正遍知。当为汝等说人法。如线经中广说。乃至佛告诸比丘。从今日后制戒。先出家者应受礼起迎合掌低头恭敬。先出家者应作上座。应先受请先坐先取水先受食。诸比丘叹言。世尊能赞说应恭敬长老。佛言。不但今日能赞说恭敬长老。过去世时已曾如是。诸比丘白佛言。愿欲闻之。佛告诸比丘。乃往过去久远世时。有三兽巅多鸟猕猴象。共在尼拘类树下。象言。我等三类共在一处此中谁大。谁应受恭敬。象言。我曾骑此树过。猕猴言。我本曾尿此树上。鸟言。我本雪山下啖此果。来于粪于此。遂生此树。尔时鸟最大。二兽恭敬鸟故。命终皆生善处。尔时象者我身是。汝等应恭敬上座如是。毗尼得增长。是名恭敬法。初受请者。有人来请应先请上座。若檀越未曾为福。请年少比丘者。应语上座处。是名初受请。在上座坐者敷座时。不得使年少座高上座座卑。应当上座座高年少座卑。当令齐整正直坐具。好者应与上座。不好者与下座。若檀越家请为知识比丘敷好床褥者。不得诤从施主意。若五年大会时。众人猥多。下至上座八人应当如法敷座。下座随宜。是名上座坐法。先受食者行食时。应先与上座。若檀越未曾设福。先与年少者。应当语上座处。行饭时应取好者与上座。如是行一切饮食时。应教好者与上座。若檀越家请食时。差别与者。从施家意不得与诤。若五年大会时。众人猥多。从上座下至八人应与好者。下座随宜与之。是名先受食。礼拜恭敬起迎低头合掌者。尔时礼膝礼胫。诸比丘以是因缘。往白世尊。佛言。从今日后应当礼足。时诸比丘从他索足作礼。扰乱修行者。诸比丘以是因缘。往白世尊。佛言。从今日后当口说和南。时比丘调戏故作是言。和南尊者。和南尊者。复扰乱他。诸比丘以是因缘。往白世尊。佛言。从今日后和南有三种身口心。身者。前人若坐若立住头面礼足是名身。口者。若前人远遥合掌低头作是言和南是名口。心者。若以背去应合掌作敬是名心恭敬。若见上座来。不起迎和南恭敬者。越毗尼罪。是名恭敬上座法

  举他及治罪　　驱出并异住
  僧断事田地　　僧房拜五年
  床褥恭敬法　　是名三跋渠

布萨法者。佛住王舍城。广说如上。尔时九十六种出家人皆作布萨。时比丘不作布萨。为世人所嫌。云何九十六种出家人皆作布萨。而沙门释子不作布萨。诸比丘以是因缘。往白世尊。佛告诸比丘。正应为世人所嫌。从今日后应作布萨所谓偈。十四日十五日示布萨。昼日布萨。堂贼王。阿那律。二种数。不利不一切利顺逆。欲闻初未受具足人。太早说。一住处。二众。二已说二未说。与欲取欲与欲多等欲。瞿师罗。大爱道。阐陀。病。阿练若。不应与而与。阿脂罗河。十一事不名与欲。转欲宿界外。比丘尼。未受具足。持欲出。与欲出。取欲已还戒。与欲已还戒。失欲。坏众四布萨。四说。七事应语遮。二事应语遮。偈者。佛告比丘。毗婆尸佛如来应供正遍知。为寂静僧最初说波罗提木叉。忍辱第一道涅槃佛称最出家。恼他人不名为沙门。第二尸弃佛如来应供正遍知。为寂静僧最初说波罗提木叉。譬如明眼人能避崄恶道。世有聪明人能远离诸恶。第三毗钵施佛如来应供正遍知。为寂静僧最初说波罗提木叉。不恼不说过。如戒所说行。饭食知节量。常乐在闲处。心净乐精进。是名诸佛教。第四拘留孙佛如来应供正遍知。为寂静僧最初说波罗提木叉。譬如蜂采花不坏色与香但取其味去。比丘入聚落。不破坏他事。不观作不作。但自观身行。谛视善不善。第五拘那含牟尼佛如来应供正遍知。为寂静僧最初说波罗提木叉。欲得好心莫放逸。圣人善法。当勤学。若有智寂一心人。尔乃无复忧愁患。第六迦叶佛如来应供正遍知。为寂静僧最初说波罗提木叉。一切恶莫作。当具足善法。自净其志意。是则诸佛教。第七释迦牟尼佛如来应供正遍知。为寂静僧最初说波罗提木叉。护身为善哉。能护口亦善。护意为善哉。护一切亦善。比丘护一切便得离众苦。比丘守口意身不犯诸恶。是三业道净。得圣所得道。是名偈布萨。十四日十五日者。佛住舍卫城。广说如上。尔时尊者阿难共行弟子。欲行摩那埵。白佛言。世尊。我共行弟子。欲诣聚落中小住处行摩那埵。时是十四日。佛语阿难。此十四日星宿随顺时随顺众随顺。应作布萨竟然后去。十四日者。冬第三布萨第七布萨。春第三第七。夏第三第七。十五日者。十八布萨。一岁中二十四布萨。六十四日十八十五日。是名十四日十五日布萨。示布萨者

佛住王舍城耆阇崛山中。尔时诸比丘不知布萨处。或得布萨。或不得布萨。诸比丘以是因缘。往白世尊。佛告诸比丘。耆阇崛山应羯磨示作布萨处。羯磨人应作是说。大德僧听。于是处若僧时到。僧从今日。耆阇崛山。某处常作布萨。白如是。大德僧听。于是处僧今耆阇崛山某处常作布萨。诸大德忍某处常作布萨。忍者默然。若不忍便说。僧已忍某处常作布萨竟。僧忍默然故。是事如是持。是名示作布萨处。昼日布萨者

佛住王舍城耆阇崛山中。尔时诸比丘夜作布萨。道崄倒地劣极而来。以是因缘。往白世尊。得昼日布萨不佛言得。若昼日布萨。若僧远住者。应唱诸长老。今日僧十四日若十五日。若食前若食后。尔许人影应集某处。若讲堂禅坊温室树下。若不唱者。越毗尼罪。是名昼日布萨。堂者

佛住王舍城。尔时阿阇贳王。耆阇崛山作布萨堂。种种严饰作金莲叶鍱。僧坐后世尊已坐。诸比丘悉入欲作布萨。有金华鍱堕地。有恶比丘盗心取挟腋下。佛比丘僧坐久不作布萨。时尊者阿难从坐起偏袒右肩胡跪合掌。白佛言。世尊。初夜已过僧坐疲久。唯愿世尊。为诸比丘说波罗提木叉作布萨。时世尊默然。如是中夜乃至后夜。复白佛言。世尊。明相已出众僧坐久。唯愿世尊。说波罗提木叉作布萨。佛告阿难。众不清净。尔时尊者大目连作是念。为谁故世尊说众不清净。目连即入定。观见是恶比丘敛身众中而坐。见已即从坐起往到其所。左手擒牵至户。右手推出说是言。恶比丘。从今日汝非沙门非比丘。不复得在众中。驱出已。佛言自今已后不听曳人。佛语阿难。从今日后汝等当自说波罗提木叉。何以故。如来应供。正遍知。众不清净不得为说。佛告阿难。如来法律中犹如大海。有八未曾有。如线经中广说。我诸弟子见已生爱乐心是名堂贼者

佛住王舍城耆阇崛山。尔时诸比丘作布萨说波罗提木叉。至波夜提后跋渠。截已波夜提。破已波夜提挽出已波夜提。当诵时贼来。诵人默然贼立须臾便出。复重诵如是至三。贼作是念。此是恶沙门作是说。截已破已挽已波夜提。正当截我破我挽我等耳即便入打诸比丘。诸比丘心生疑惑。贼前得说戒不。以是因缘。往白世尊。佛言。贼是林中王。能作不饶益事得说。汝等云何重诵本语。从今日后不听若比丘布萨说波罗提木叉时。贼入者即应更诵余经。若波罗延若八跋耆经若牟尼偈若法句。若贼知比丘法作是言。沙门我已知。但说先所诵者。尔时比丘应急诵。使章句不辨。令彼不知初中后。若更诵本语。越毗尼罪。是名贼王者

佛住王舍城耆旧庵婆罗园如沙门果线经中广说。乃至比丘生疑。得王前说戒不。以是因缘。往白世尊。佛言。王者能作不饶益事。如上贼中广说。是名王。阿那律者

佛住王舍城耆阇崛山。诸比丘作布萨羯磨时。尊者阿那律不来。诸比丘遣使往唤长老阿那律。比丘僧集欲作布萨羯磨事。答言。世尊。说清净是布萨。世间清净者我即是。我不去。诸比丘以是因缘。往白世尊。佛言。汝往唤来。莫用天眼来。是长老失肉眼故涉山崄道极苦乃到。佛语阿那律。汝不恭敬布萨。谁当恭敬。佛言。从今日后布萨时尽应来。若不来若病不与欲。越毗尼罪。是名阿那律。二种数者。佛语优波离。汝诵毗尼不。答言诵。但杂碎句难持。佛言。当作筹数诵。时优波离即作筹数诵。佛复问优波离。汝作筹数诵毗尼不。答言。杂碎句筹数诵犹故难持。佛言。从今日后作二种数。一者五百。二者七百。若欲诵时应先净洗手已捉筹下至数齐五犹当洗手若有者应作香汁浴筹。余人欲捉筹者亦复如是。是名二种数不利者

佛住舍卫城。尔时聚落中有比丘住。僧集欲作布萨羯磨。语上座言。说波罗提木叉。答言我不利。如是第二第三。乃至下座亦复如是。诸比丘心生疑惑。以是因缘。往白世尊。佛言。从今日后受具足已应诵二部毗尼。若不能诵二部者应诵一部。若复不能者应诵五线经。若复不能者应诵四三二一。布萨时应广诵五綖经。若有因缘不得者。应诵四三二一乃至四波罗夷及偈余者僧常闻。若不诵作布萨者。越毗尼罪。若如是比举众不利者应遣上座出界外。心念口言作布萨余。三人界内作三语布萨即是罚上座是名不利不一切利者

佛住舍卫城。尔时聚落中有比丘住。僧集欲作布萨。语上座诵波罗提木叉。答言我一篇利。复语第二上座。答言。我二篇利。如是次第各诵一篇利即便递诵共作布萨已心生疑惑。诸比丘以是因缘。具白世尊。佛言。从今日后不听合诵作布萨。若有如是比者。应共授一聪明者使利已令诵。若诵时忘者余人得授若合诵作布萨者。越毗尼罪。是名不一切利。顺逆者

佛住舍卫城。尔时有比丘。聚落中住。僧集作布萨。有一比丘诵波罗提木叉。利顺逆诵。从戒序乃至法随顺法。从法随顺法乃至戒序布萨已心生疑悔诸比丘以是因缘具白世尊。佛言。从今日后。不听逆诵应顺诵。若诵时有忘失者得还补诵。顺逆诵作布萨者越毗尼罪。是名顺逆。欲闻初者

佛住舍卫城。尔时诸比丘僧集作布萨。诵波罗提木叉。乃至法随顺法。时客比丘来言。长老我在聚落中住。未曾闻广诵波罗提木叉。愿长老为我广诵。诵者即为更从戒序乃至法随顺法。诸比丘心生疑惑。以是因缘。具白世尊。佛言。汝等云何为欲从初闻者更诵。从今日后不听若比丘僧集作布萨诵波罗提木叉乃至法随顺法有客比丘来及坐者即名得布萨。若客比丘言。我聚落中住。未曾闻广诵波罗提木叉。愿为我广诵。待僧罢已然后与诵。若僧未罢为诵者越毗尼罪。是名欲闻初。未受具足者

佛住舍卫城。尔时比丘为未受具足人。说五众罪波罗夷乃至越毗尼罪。后比丘入聚落中。俗人言。长老。汝犯波罗夷罪乃至越毗尼罪。诸比丘闻已惭愧。以是因缘。具白世尊。佛言。汝等云何为未受具足人。说波罗提木叉五篇罪。从今日后不听向未受具足人说得教语汝不得作非梵行不得盗不得杀生不得妄语。如是比得为说。若为未受具足人。说波罗提木叉五篇名者。越毗尼罪。是名未受具足人。太早者

佛住舍卫城。尔时有一比丘在聚落中住。晨起作布萨竟。有客比丘来语旧比丘言。长老来共作布萨。答言。我已布萨竟。客比丘言长老作布萨乃太早。比丘以是因缘。具白世尊。佛言。从今日后不应早作布萨。若一比丘聚落中住者。布萨日应扫塔及僧坊中。若有者香汁洒地散华然灯。待客比丘来共作布萨。若无客比丘来。有罪者应作是念。若得清净比丘。此罪当如法除。作是念已。应心念口言。今十五日僧作布萨。我某甲比丘清净受布萨。如是三说。若布萨竟。有客比丘来者应随喜言。长老。已作布萨。我某甲随喜。若不随喜应出界外作布萨。若晨朝作布萨。越毗尼罪。是名太早。一住处者

佛住舍卫城。尔时诸比丘道路行。天阴闇谓日暮。入聚落至比丘住处作布萨。布萨已天晴日故早。诸比丘作是念。我应前行去已。须臾第二众来。复于此处作布萨。即于中宿明日去。与前布萨比丘相见。见已谓言长老。汝昨何处宿。答言某处。何处布萨。答言某处。我亦彼处作布萨。诸比丘心生疑惑。以是因缘。具白世尊。佛言。从今日后一住处不得再作布萨。若比丘远行。布萨日入聚落至比丘住处。作布萨已不得默然去。应嘱沙弥若园民若放牧者。若有比丘来语令知。此中已作布萨。若无人者。应书桂户扇。若散华作相。若后来者应问应求相。不得辄作布萨。若前人不嘱不作相。后人不问不求相。俱得越毗尼罪。是名一住处。二众者。二众客比丘来。一众十四日布萨。一众十五日布萨。应从谁从前入者。二众同时入应从上座。若无大小应从持律。若俱持律应从先发声者。若十四日若十五日。应从布萨。是名二众。二已说二未说者。客比丘来。客比丘十四日布萨。旧比丘十五日。旧比丘语客比丘。长老共作布萨来。客比丘不得言我已作布萨。与和合若出界外。若旧比丘十四日。客比丘十五日。客比丘言。长老作布萨来。旧比丘应言我已作布萨。是客比丘应随喜言。长老已作布萨我随喜。若不随喜。应出界外作布萨。是名二已说二未说。与欲者。众僧集布萨。时有比丘为衣钵事不得往。诸比丘以是因缘具白世尊。佛言。从今已后。听与欲。与欲法者。应作是言。长老听。今日僧布萨。若十四日十五日。我比丘某甲与清净布萨欲。为我说。如是三说。与欲时不得趣与人。应与能持欲入僧中说者。若作衣钵事布萨时不与欲者越毗尼罪。是名与欲。取欲者

佛住舍卫城。尔时比丘僧集作布萨羯磨。比丘病为衣钵事。与欲比丘不受。诸比丘以是因缘具白世尊。佛言。从今已后。应取欲若取欲时应自思惟能传欲不。不得取众欲得至三人与欲时应作是说长老忆念今日僧作布萨。某甲比丘与布萨清净欲。若忘字者忆岁数。应言尔所岁比丘若客言客若病言病。比丘与布萨清净欲。若病为衣钵事与欲不取者越毗尼罪是名取欲。欲多者

佛住舍卫城。尔时比丘僧布萨。时与欲者多。集者少。诸比丘以是因缘具白世尊。佛言。从今已后。不听与欲者多集者少作布萨。作者越毗尼罪是名与欲多。欲等者

佛住舍卫城。尔时比丘僧布萨。时与欲比丘与集者等作布萨。诸比丘以是因缘具白世尊。佛言。从今已后。不听欲等作布萨。应集者多。若等欲作布萨者。越毗尼罪。是名欲等。瞿师罗者

佛住俱睒弥瞿师罗园。尔时比丘僧集作布萨。断事羯磨语声高。时瞿师罗居士来入。僧默然。须臾还出。僧复断事高声如前。如是至三。居士作是念。我入便默。我出便高声。我今当入更不复出。如瞿师罗问尊者阿难。如六入线经中广说。尔时诸比丘心生疑惑。以是因缘。具白世尊。佛言。如是大德胜人欲听众僧断事者。得闻断事若众中有辩才能语使事相分明者说。若凡庶人前断事者。越毗尼罪。是名瞿师罗居士。大爱道者

佛住舍卫城。尔时大爱道瞿昙弥与欲比丘不受。时大爱道瞿昙弥往到世尊所。头面礼足却住一面。以是因缘具白世尊。比丘不受我欲谁当受。尔时世尊为大爱道瞿昙弥。随顺说法。发欢喜心已头面礼足而退。佛言。唤彼比丘来。来已。佛问言。汝实尔不。答言。实尔。佛言。从今已后。比丘尼与欲应受。若上坐。应言我是僧上座不应受。若教诫尼人若诵波罗提木叉人。应各自说不应受。若守房人。若病人。应言我不至僧中更与余人。若言我是乞食。我是阿练若。我是粪扫衣。我是大德人。不取欲者。越毗尼罪。若言我是上座。是教诫尼人。是诵戒人者。不取无罪。是名瞿昙弥。阐陀者

佛住俱睒弥瞿师罗园。尔时僧集作布萨。时阐陀比丘不肯来。诸比丘以是因缘具白世尊。是犯何等罪。佛言。得偷兰罪。如是比丘布萨不肯来者。得偷兰罪。若为衣钵事不来不与欲者。越毗尼罪。病者

佛住舍卫城尔时比丘僧集欲布萨。有一比丘风病。动语比房言。长老。我风病动与清净欲。比丘不受。即往至上座前。脱革屣胡跪合掌作如是言。我某甲清净僧忆念持。如是三说已便去。诸比丘心生疑惑以是因缘具白世尊。得尔不。佛言。善已如法作竟。但不受欲者。越毗尼罪。是名病阿练若者

佛住舍卫城阿练若聚落中。比丘常共作布萨。时阿练若入聚落作布萨已去。去不久有客比丘来。复于此处布萨。即于中宿。明日共相见。问长老昨何处宿。答此处。何处布萨。答言此处。闻已心生疑惑。以是因缘具白世尊。佛言。从今日后。不听一住处再布萨。若阿练若入聚落中布萨者。不得默然去应嘱沙弥若园民若放牧人。若后有比丘来者。语令知此中已作布萨若无人者。应书柱户扇作字。若散花作相。后来者应问应求相。若去不嘱不作相后来者不问不求相。俱越毗尼罪。是名阿练若。不应与而与者

佛住舍卫城尔时诸比丘。时集与羯磨欲。非时集与清净欲。诸比丘以是因缘具白世尊。佛言。从今日后。不听时集与羯磨欲非时集与清净欲。非时集应与羯磨欲。时集应与清净欲。时集亦得与两欲。长老忆念。今僧若十四日十五日作布萨。我某甲比丘与布萨清净欲。与我说如是三说与羯磨欲亦三说。若非时集与清净欲。时集与羯磨欲。越毗尼罪。是名不应与而与。阿脂罗河者

佛住舍卫城。尔时诸比丘到阿脂罗河边。敷尼师坛坐诵波罗提木叉。时水泛涨渐渐齐膝。如是转上齐口。极苦乃竟。还至佛所。以是因缘具白世尊。得立作布萨不。佛言。得。得行住坐卧作布萨。行者。若比丘共商人行。至布萨日。有恐怖难。商人行不待。得行作布萨。先应筹量齐几许得诵戒竟。若山若石作幖帜伸手相。及羯磨作布萨界。羯磨已然后作布萨。是名行布萨。住者。比丘多无床座。一切伸手相及作布萨。是名住布萨。坐者。有床座作布萨。是名坐布萨。卧者。比丘老病不能久坐。床角相接得卧作布萨。是名卧布萨。是名阿脂罗河。十一事不名与欲转欲者。我与长老欲。我向取某甲欲并与。是名转欲。宿与者。明日当布萨。今日与欲。是名宿与欲。界外者。出界与欲。是名界外。比丘尼者。与比丘尼欲。是名比丘尼。未受具足者。与未受具足人欲。是名未受具足。持欲出者。取欲已出界外。是名持欲出。与欲出者。与欲已出界外。是名与欲出。取欲已还戒者。取欲已还戒受具足。是名取欲已还戒。与欲已还戒者。与他欲已还戒受具足。是名与欲已还戒。失欲者。比丘病与欲已。闻僧中法师说法持律说毗尼。自力就听。坐久疲苦。已先与欲。默离座去。不名与欲。应更与。是名失欲。坏众者。布萨日。比丘僧集不来。诸比丘与清净欲。若暴风雨若火若贼。诸比丘尽惊散。不名持欲到僧中。若一人在。是名到僧。是名十一不名与欲。四布萨者。一人受。二人说。三人说。四人广诵。一人受者。有一比丘聚落中住。至布萨日。应扫塔及僧院。若有者应香汁洒地然灯散华待客比丘。若无来者。有罪应作是念。得清净比丘者。此罪当如法除。作是念已。胡跪合掌心念口言。今僧若十四日十五日布萨。我某甲比丘清净受布萨。如是三说。是名一人受。二人说者。二比丘聚落中住。至布萨日。应扫塔及僧院。若有者应香汁洒地散华然灯。若有罪者展转如法悔已。应胡跪合掌作是说长老忆念。今僧若十四日十五日作布萨。我某甲比丘清净。长老忆念持。是名说。三人亦如是广诵者。四人应广诵波罗提木叉。是名广诵。四说者。一从戒序尽四波罗夷。余者僧常闻诵偈。二者尽十三事二不定法。余者僧常闻诵偈。三者尽三十尼萨耆。余者僧常闻诵偈。四者入九十二波夜提应尽广诵。是名四说。布萨有七事应遮。一不共住人。二者别住人。三未受具足人。四未说欲。五未行舍罗。六为和合义故七和合未竟。是名七应遮复次二事应遮布萨。一者若作布萨者僧斗诤。二者僧破。是名二事应遮。是名布萨法与欲法受欲法。安居法者

佛住舍卫城。广说如上。尔时诸比丘。雨时游行多所践害。为世人所嫌。九十六种出家人尚知安居。如鸟隐巢而自守住。沙门释子自称善好而不安居。诸比丘以是因缘具白世尊。佛言。正应为世人所嫌。从今已后。雨时应安居。安居法者。至四月十六日。应偏袒右肩胡跪合掌。应作是说。长老忆念。我某甲比丘。于此僧伽蓝雨安居前三月。如是三说。若比丘行道未到住处。安居日至。即于路侧若依树若车。应受安居。至明相出趣所住处。到后安居日。应偏袒右肩胡跪合掌。作是言。长老忆念。我某甲比丘。于此僧伽蓝雨安居后三月。如是三说。比丘行道前安居日不受安居。一越毗尼罪。到所住处后安居日不受安居。二越毗尼罪。是人破安居不得衣施

复次佛住舍卫城。尔时有比丘。依聚落雨安居。有檀越营僧事。须水溉灌。求比丘白王通水。时比丘衣钵随身。数诣王门。不时得见。道路不近。恐失安居时。世尊见已知而故问。汝是客比丘耶。非也世尊。汝是去比丘耶。非也世尊。何故持衣钵自随。比丘以上因缘具白世尊。佛言。从今已后。雨安居时。若为塔事为僧事。应作求听羯磨。大德僧听。某甲比丘。于此处雨安居。若僧时到僧某甲比丘。于此处雨安居。为塔事僧事出界。行还此处住。诸大德听。某甲比丘。为塔事僧事出界。行还此处安居。僧忍默然故。是事如是持。若有如是为塔为僧所求索者。要有所得。若衣若钵若小钵若键镃鉹若腰带等及诸一切。要使得一物。若不得者。越毗尼罪。如是事讫应还。若半月若一月若二月。乃至后自恣应还若不还者。越毗尼罪。若道路恐怖贼难畏失命者。于彼自恣无罪。是名安居法。自恣法者

佛住舍卫城。广说如上。尔时诸比丘俱萨罗国游行。见渠磨帝河边有丛林。林中有一大空。中萨罗树其荫厚密。树下平正宽博。去聚落不远不近。作是念。此中好可安居。如是前后人人见者皆作是念。至安居日一比丘先至。修治空树安置衣钵敷草而坐。须臾复有比丘来。问言。长老。欲此安居耶。答言。尔善好。如是相续乃至六十人。最初至者语后诸比丘言长老。尽欲此中安居耶。答言。尔善好。此树中可容衣钵。其下左右足以安居。受安居法已复作是言。诸长老。我等当作何法得安乐住。诸人答言。所生患恼皆由身口。既得静处宜共默然。应立不语制。立不语制竟。三月已还舍卫城往世尊所头面礼足却住一面。佛知而故问。比丘汝何处安居。答言某处。佛问比丘。少病少恼乞食不。苦行道如法安乐住不。答言世尊。少病少恼乞食易得。默然乐住三月不语已别去。佛言。此是恶事。如怨家共住法。应共语。

复次佛住舍卫城。广说如上。阿那律金毗卢跋提。预在塔山安居竟还舍卫城。至佛所头面礼足却住一面。佛知而故问。何处安居。答言。某处。复问。比丘少病少恼乞食不。苦行道如法安乐住不。答言。世尊。少病少恼乞食易得。默然乐住三月不语竟已别去。佛言。此是恶事。如怨家共住。从今日后不听不共语欲方便少事不语得半月至布萨日。应共语共相问讯问事答事咒愿。过布萨日续复如前。若憍慢若嗔恚不共语者。越毗尼罪。自恣法者。佛告诸比丘。从今日为诸弟子制自恣法。三月三语安居竟。是处安居是处自恣。从上座和合。三月者。从四月十六日。至七月十五日。三语者。见闻疑。安居竟者。前安居从四月十六日。至七月十五日。后安居从五月十六日。至八月十五日。若安居众中有一人前安居者。至七月十五日。举众应同此一人受自恣。自恣讫。坐至八月十五日。若一切后安居。一切应八月十五日自恣。是名安居竟。是处安居是处自恣者。若比丘聚落中安居。闻城中自恣日种种供养竟夜说法。众欲往者应十四日自恣已得去。若此处安居。余处自恣者。越毗尼罪。从上座者。不得从小逆作次第。应从上座次第下。不得行行置人如益食法。不得超越。不得总唱言一切大德僧见闻疑罪自恣说。是名从上座。应拜五法成就者作自恣人。若一若二不得过。羯磨人应作是说。大德僧听。某甲某甲比丘五法成就若僧时到。僧拜某甲某甲比丘作自恣人。诸大德听。某甲某甲比丘作自恣人。僧忍默然故。是事如是持。受羯磨人应作是说大德僧听。自恣时至若僧时到。一切僧受自恣。白如是。是自恣人应从上座为始。上座应偏袒右肩胡跪合掌作是说。长老忆念。今僧十五日受自恣。我比丘某甲。长老及僧自恣说若见闻疑罪当语我。怜愍故。我若知若见当如法除。如是三说。次至第二人。第二人若是下座。应接足言。大德为异。若二人作自恣人者。一人受上座自恣。一人应下。座前立。上座说已下座复说。如是展转次第下到自坐处。应受自恣不得受僧自恣竟然后自恣。和合者不得不和合受自恣。不得与欲受自恣。若病者应将来。若将来有危命忧者。僧应往就。若病人多者应舁床来。若床角相接。若床舁来有危命忧者。不病比丘应连座相接。若不周者不病比丘应出界外作自恣。病比丘即界内自恣。大众多者若一万二万。应一切集在一处。若讲堂若食堂若浴室受自恣。余人并嚼齿木并大小行并食如是竟日通夜未离坐不得远。乃至明相未出于中自恣。若大众多六万八万。畏不竟者。应减出界外作自恣。若一人受自恣。若二人说。若三人若四人说自恣。五人广自恣。一人受者。若一比丘聚落中安居。至自恣日。应扫塔及僧院。若有者应香汁洒地散花然灯。若有罪者应作是念。若得清净比丘来者。此罪当如法除。作是念已。胡跪合掌心念口言。今僧十五日自恣。我某甲比丘清净受自恣。如是三说。二人说者。有罪展转如法作已。偏袒右肩胡跪合掌言。长老忆念。今僧十五日自恣。长老自恣说。若见闻疑罪语我。怜愍故。我若知若见当如法除。如是三说。三人四人亦如是。五人应广自恣。是名自恣法

摩诃僧祇律卷第二十七摩诃僧祇律卷第二十八

        东晋天竺三藏佛陀跋陀罗共法显译

    明杂诵跋渠法之六

迦絺那衣法者。佛住俱睒弥瞿师罗园。为诸天世人之所供养。尔时俱睒弥王夫人。以五百张[疊*毛]奉上世尊。佛告阿难。汝持是[疊*毛]与诸比丘。诸比丘不受。语阿难言。世尊不听畜长衣。用是[疊*毛]为。浣染未竟已不如法。阿难以是因缘具白世尊。佛告阿难从今已后。长衣听十日畜。诸比丘长衣满十日。持是诸衣往白世尊。此衣已满十日。佛言。从今已后。听受迦絺那衣。迦絺那衣者。时众僧众多人一人五事利新未受不停截净染净点净刀净。时者。从七月十六日。至八月十五日是名时。众僧者僧作迦絺那衣不得与众多人。不得与一人。众多人作迦絺那衣。不得与一人。五事利者。离五罪。何等五别众食。处处食。食前食后行。不白畜长衣。离衣宿。是名五事利。新者。新[疊*毛]未受者。未曾受作三衣。不停者。净施衣舍已得作迦絺那衣。僧伽梨郁多罗僧安陀会覆疮衣雨浴衣。如是等诸衣及钩刺未曾[隹/(至-土)]用。皆得作迦絺那衣。截净者。截缕作净。染净者。染作净。点净者。点角作净。刀净者。离角头四指于一处三下刀断三缕。是名刀净。若外人施僧迦絺那衣财。不得默然受。受者应作是说我今受僧迦絺那衣财。受已到僧中。竖[疊*毛]手捉长垂高擎应作是说。大德僧听僧得此时衣财。若僧时到。僧取此迦絺那衣财。白如是大德僧听。僧得此时衣财。僧今取此迦絺那衣财。诸大德忍取此迦絺那衣财者默然。若不忍者便说。僧已取迦絺那衣财竟。僧忍默然故。是事如是持。僧中有能料理作迦絺那衣者。若一人若二人若三人。羯磨人应作是说。大德僧听。僧得此时衣财。若僧时到。僧拜某甲某甲比丘及余人。作僧迦絺那衣。白如是。大德僧听。僧得此时衣财。僧今拜某甲某甲比丘及余人。作迦絺那衣。诸大德忍某甲某甲比丘及余人作迦絺那衣者默然。若不忍者便说。僧已忍拜某甲某甲比丘作迦絺那衣竟。僧忍默然故是事如是持。羯磨人中一人为主受衣财时。应作是言。受此迦絺那衣财。僧当受。如是三说。浣时应作是说浣是迦絺那衣。僧当受。如是截时缝时染时点作净时。随所作如上说。刀净者。离角头四指。一下刀时作是说。此迦絺那衣僧当受。第二第三亦如是说。作净时一一应作是说。不说而作净。得名迦絺那衣。得越毗尼罪。若一一说而不作净。不名迦絺那衣。得越毗尼罪。若一一起心而作净。得名迦絺那衣无罪。若僧得时衣作已。一切和合。羯磨人纵叠衣手捉长垂高擎。应作是说。大德僧听。僧得此时衣作竟。若僧时到。僧受此迦絺那衣。白如是。大德僧听。僧得此时衣作竟。僧今受此迦絺那衣。诸大德忍受此迦絺那衣者默然。若不忍者便说。僧已受迦絺那衣竟。僧忍默然故。是事如是持。应襞叠此衣着箱中。众华散上。应从上座次第作随喜言。长老忆念。僧于此住处受迦絺那衣。我某甲比丘随喜受齐冬四月。随所住处满。我当舍。如是三说。若大众一万二万。和合难者。众多人得别作迦絺那衣。一切如大众。但称众多为异。四人以上不得别作。若一人独作者。取时应言。此迦絺那衣财我今受。如是三说。截时缝时浣时染时点时刀净时截时。应作是言此迦絺那衣我当受。缝时浣时染时点时刀作净时如上说。作成已应心念口言我比丘某甲受此迦絺那衣如是三说。受迦絺那衣者。有作时非受时。有受时非作时。有作时受时。有非作时非受时。作时非受时者。是中有值作时受。不值受时受得名受。受时非作时者。值受。时受非作时受。得名受。有作时受时者。值作时受时受。是名作时受时。非作时非受时者。不值作时受受时受。应随喜言。长老忆念。是住处僧受迦絺那衣。我某甲比丘随喜受齐冬四月。随彼住处满。我当舍。是名迦絺那衣法。非迦絺那衣者

佛住舍卫城。广说如上。尔时尊者孙陀罗难陀。持头鸠罗(生疏也)作迦絺那衣。佛言。不听头鸠罗作迦絺那衣。尔时尊者阿难。持[革*茸]劫贝作迦絺那衣。复有比丘。持小段物作。复有比丘。持故物作。复有比丘。持牂羊毛钦婆罗作。复有比丘。持发钦婆罗作。复有比丘。持草衣作。复有比丘。持韦衣作。复有比丘。持树皮衣作。复有比丘。持板衣作。佛言。如是一切不应作。一切非衣。不名迦絺那衣。复有不名迦絺那衣。非时作不截缕净不染净不点净不刀净。是不名迦絺那衣。舍迦絺那衣法者

佛住舍卫城。广说如上。尔时有比丘数易衣着。食前着异衣。食后着异衣。佛知而故问。汝衣数数异。是谁衣。答言。世尊。是我衣。佛言。何故太多答言。我受迦絺那衣。佛言。汝云何一切时受迦絺那衣。从今日后应舍。舍者有十事。何等十。一衣竟舍二受时舍。三时竟舍。四闻舍。五送舍。六坏舍。七失舍。八出去舍。九时过舍。十究竟舍。衣竟舍者。受迦絺那衣时作是念。我作衣竟当舍迦絺那衣。作衣成已即名舍。是名衣竟舍。受时舍者。作是念。受此衣时当舍迦絺那衣。受衣时即名舍是名受时舍。时竟舍者。作是念。尔许时我当舍迦絺那衣。期满已即名舍。是名时竟舍。闻舍者。作是念。我闻和上阿阇梨舍迦絺那衣时。我当舍。后闻和上阿阇梨说今日僧舍迦絺那衣。尔时即名舍。是名闻舍送舍者。作是念。我是衣与他已当舍迦絺那衣。后送衣已即名舍。是名送舍。坏舍者。受迦絺那衣已。中间自言。我今舍迦絺那衣。作是语时即名舍。是名坏舍。失舍者。作是念。是衣中间坏败失不现我当舍。后衣坏败若失即名舍。是名失舍。出去舍者。作是念。我此中住出去时。当舍迦絺那衣若出去时即名舍。是名出去舍时。过舍者。腊月十五日不舍。至十六日即名舍。越毗尼罪。是名时过舍。究竟舍者。至腊月十五日应舍。一人僧中应作是唱。大德僧听。今日僧舍迦絺那衣。如是三说。是名究竟舍。是十事名舍迦絺那衣法。衣法者。安居未竟安居竟。是中安居畏失命畏失梵行非时衣时衣俱睒弥。安居未竟者

佛住舍卫城。广说如上。尔时六群比丘聚落中安居未竟。至檀越所作是言。长寿。与我安居衣施。答言。尊者。今非时待安居竟。修获讫。人民欢喜念恩故生施心。尔时乃可有施耳。比丘言。长寿。汝不知世间无常。或王或水火偷劫。如是我则失利汝便失福。檀越言。尊者。但示我无常而自不见。尊者。欲速得安居物为持余处去为欲罢道匆匆乃尔。奇哉可怪多欲无厌。发不喜心已而去。诸比丘以是因缘具白世尊。佛问六群比丘。汝实尔不。答言实尔世尊。佛言。比丘。汝云何安居未竟索安居施衣。自今以后。不听安居未竟索安居施衣者。越毗尼罪。是名安居未竟。安居竟者

佛住舍卫城。广说如上。尔时诸比丘。只桓精舍安居竟分安居衣。时六群比丘余处安居已来在坐中。作如是言。长老世尊制安居竟应得安居衣。我亦安居竟应得安居衣。与我安居衣分。诸比丘以是因缘具白世尊。佛言余处安居。不应得此处衣分。随安居处受分。是名安居竟。是中安居者

佛住舍卫城广说如上。尔时六群比丘至安居时。受房舍已。着革屣染具及余小小物。置房中已作是言。诸长老。我此中安居。莫复起厌患。我知汝等常不喜我。即倩人取安居衣分。便余处安居。诸比丘以是因缘具白世尊。佛言。要是中安居。是处受衣分。畏失命者

佛住舍卫城。广说如上。尔时毗舍离大饥馑乞食难得。诸比丘趣舍卫城。值只桓比丘安居竟分衣。毗舍离比丘在座中。祇洹比丘问言。长老。世尊制。要是处安居得是处衣分。汝何处安居。答言。长老。我畏失命故来。若不来者便饥死。诸比丘以是因缘具白世尊佛言。若为失命故来应与衣分。是名畏失命。畏失梵行者。尔时王舍城中有外道儿出家。时父母欲罢儿道余人言。沙门重安居。安居中必无东西尔时可罢。其姊深信佛法。语弟言。父母欲罢汝道。可速避去。弟即趣舍卫。值只桓比丘安居竟分衣。是比丘在座中。只桓比丘问言。长老。世尊制。要是处安居。是处受衣分。畏失命来者得分。汝云何答言。父母欲罢我道。若不来者失梵行。诸比丘以是因缘具白世尊。佛言。畏失梵行来者应与衣分。是名畏失梵行。非时衣者

佛住舍卫城。广说如上。尔时有比丘在人间游行。载满车衣来。佛知而故问。是谁衣。答言。世尊。是我衣。复问。此是时衣为非时衣。答言。世尊。非时衣。净施未。答言未。佛言。是一切衣应与众僧。是名非时衣。时衣者

佛住舍卫城。广说如上。尔时有比丘人间游行。载满车衣来。佛知而故问。是谁衣。答言。世尊。是我衣。复问。此是时衣非时衣。答言。时衣。佛言。是衣太多。减半与僧。是名时衣。俱睒弥者

佛住舍卫城。广说如上。俱萨罗国抄俱睒弥聚落至舍卫城有诸比丘。先依此聚落安居。即便随来。时只桓比丘到此聚落。索安居施衣。俱睒弥比丘言。长老。我先依此聚落安居。我应先索。二人诤已共诣佛所。以是因缘具白世尊。佛言是中安居应先索。然后余人索。若二人共索者应共分。若是中安居比丘未索。余人索者。越毗尼罪。复次时尊者劫宾那。有二共行弟子。有所嫌故舍戒。不坏梵行还受具足。时只桓比丘安居竟分衣不与分。彼作是言。长老。我有所嫌故舍戒。不坏梵行还受具足。应与我分。共往白佛。佛言。有所嫌故舍戒。不坏梵行还受具足。应等与分。佛言。有五事不应与。何等五。被举罢道。无常。破安居。去不嘱。举者。三见中若一一见谤线经恶邪见边见。谏不舍作举羯磨。是名举。罢道者。舍戒不应与。若依王力。若依大臣力。若依贼党力。作是说。沙门若不与我分。我当作不饶益事。如是人虽不应得。应与。是名罢道。无常者。死不应得分。安居衣已集虽未分。命垂终时嘱与某甲。死已应与。是名无常。破安居者。比丘不前安居不后安居不应得。若依王力大臣力贼力。若不与我者。当作不饶益事。如是人虽不应得应与。去不嘱者。不嘱取衣分而去者不应与。分物人应问。谁取某甲分。若有取者应问。去时嘱取不。答言。不嘱。应语言。汝莫忧是事。若言嘱者。应相前人。若是可信人者应与。若非是可信人者。应语言。汝莫忧是事。若二人先是同意。常相为取者应与。是名五事

佛住舍卫城。广说如上。尔时有一比丘安居竟。往至本生聚落。诸亲里以此比丘来故。广设供养布施衣物。此聚落中先住安居僧。以坐后施故。不与是比丘分。诸亲里问言。得衣分不。答言。不得。诸亲里言。我为汝故设此供养。何故不得。诸比丘以是因缘具白世尊。佛言。檀越为此比丘设供。应与分。佛言。有五声施。是衣施安居僧。是衣直施安居僧。是物施安居僧。是物直施安居僧。是处安居者施。是名五。若施家欲通与余比丘。随檀越意应与。复有四种物随语应属现前僧。何等四。我施衣衣直物物直。是名四种物属现前僧。复有十种得应属现前僧何等十。时药。夜分药。七日药。尽寿药。死比丘物。施住处。大会。非时衣。杂物。请食。时药者。前食后食哆波那食现前僧应得是名时药。夜分药者。十四种浆应广说是名。夜分药。七日药者。酥油蜜石蜜生酥膏应广说。是名七日药。尽寿药者。呵梨勒鞞醯勒阿摩勒。如第二戒中广说。是名尽寿药。死比丘物者。若比丘死时所有衣钵杂物。现前僧应得。是名死比丘物。施住处者。若檀越作僧房精舍已设大会。以此住处及余杂物施。现前僧应得。是名住处施。大会者。佛生大会。菩提大会。转法轮大会。阿难大会。罗睺罗大会。五年大会。是中施物。现前僧应得。非时衣者。无迦絺那衣十一月。有迦絺那衣七月于中施物。现前僧应得。是名非时衣。杂物者。钵钵支鉹腰带刀子针筒革屣盛油革囊军持澡瓶。如是比杂物施。现前僧应得。是名杂物。请食者。檀越请现前僧食次第往。是名请食。是名十事现前僧应得。复次佛住王舍城。尔时诸比丘不截缕作衣。广说如上波夜提三种坏色中说

复次佛住舍卫城。广说如上。尔时有一比丘。往至佛所头面礼足白佛言。世尊。听我着一衣。少欲少事。佛告比丘。汝持三衣瓶钵。即是少欲少事。复有比丘言。听我着三衣。复有比丘言。听我着牂羊毛钦婆罗。复有比丘言。听我着发钦婆罗。复有比丘言。听我着马尾钦婆罗。复有比丘言。听我着草衣。复有比丘言。听我着树皮衣。复有比丘。言听我着韦衣。佛言。如是诸衣尽。不应着。复有比丘言。听我裸形。少欲少事。佛言。比丘。此是外道法。应持三衣瓶钵。即是少欲少事

复次佛住舍卫城。广说如上。尔时诸比丘着上色衣。为世人所嫌。云何沙门释子着上色衣。如俗人无异。诸比丘以是因缘具白世尊。佛言。不听着上色衣。上色者。丘佉染。迦弥遮染。俱鞞罗染。勒叉染。卢陀罗染。真绯郁金染。红蓝染。青染。皂色华色。一切上色不听。应用根染叶染华染树皮染下至巨磨汁染

复次佛住王舍城天帝释石窟前经行。见摩竭提稻田畦畔分明差互得所。见已语诸比丘。过去诸佛如来应供正遍知衣法。正应如是。从今日后。作衣当用是法。复次尔时尊者大迦叶作僧伽梨。世尊自手捉尊者阿难为截。复有比丘篸缀。有比丘刺短。有比丘刺长。有比丘刺缘。有比丘安细怗。复次有比丘作衣画作叶。佛言。不听画作叶。有比丘叠作叶。佛言。不听叠作叶。应割截。有比丘对头缝。佛言。不听对头缝。应作叶。极广齐四指。极狭如[麩-夫+廣]麦。复有比丘一向作叶。佛言。不听。应两向。有比丘作衣横叶相当。佛言。不听。五条应一长一短。七条乃至十。三条两长一短。十五条三长一短。复有比丘作衣缝叶与衣相着。佛言。不听。后衣宣脱。佛言。应作马齿。有比丘衣上下破。佛言。应作缘。有比丘作四种色衣。佛言。不听。应一种色。有比丘得上色衣欲浣坏色。佛知而故问。比丘。欲作何等。答言。世尊。制不听着上色衣。欲浣坏色。佛言。不须浣。听余染坏色。衣者有七种。一钦婆罗衣。二劫贝衣。三刍摩衣。四俱舍耶衣。五舍那衣。六麻衣。七躯牟提衣。是名衣法

  布萨及羯磨　　与欲说清净
  安居并自恣　　受迦絺那衣
  非迦絺那衣　　舍迦絺那衣
  安居竟施衣　　第四跋渠竟

病比丘法者。佛住舍卫城。广说如上。佛语阿难。取户钥来。如来欲按行僧房。答言。善哉世尊。即取户钥随世尊后。时世尊到一破房中。见有一病比丘卧粪秽中不能自起。佛问比丘。气力何似。所患增损。答言世尊。患但有增无损。复问比丘。今日得食不。不得世尊。昨日得不。不得世尊。先昨得不。不得世尊。我不得食来已经七日。佛问比丘。为得已不食为。不得不食。答言。不得世尊。佛问比丘。汝此间有和上不。无有世尊。有同和上不。无有世尊。有阿阇梨不无有世尊。有同阿阇梨不。无有世尊。无比房比丘耶。答言。世尊。以我臭秽不喜故徙余处去。我孤苦世尊。我孤独修伽陀。佛语比丘。汝莫忧恼。我当伴汝。佛语比丘。取衣来我为汝浣。尔时阿难白佛言。置世尊。是病比丘衣我当与浣。佛语阿难。汝便浣衣。我当灌水。阿难即浣世尊灌水。浣已日曝。时阿难抱病比丘举着露地。除去粪秽出床褥诸不净器。水洒房内。扫除已巨磨涂地。浣晒床褥。更织绳床敷着本处。澡浴病比丘。徐卧床上。尔时世尊以无量功德庄严金色柔软手。摩比丘额上问言。所患增损。比丘言。蒙世尊手至我额上。众苦悉除。尔时世尊为病比丘随顺说法发欢喜心已。重为说法。得法眼净。比丘差已。世尊至众多比丘所。敷尼师坛而坐。以上事具为诸比丘说。问比房比丘是谁。答言。我是世尊。佛告比丘。汝等同梵行人病痛不相看视谁当看者。汝等各各异姓异家信家非家舍家出家。皆同一姓沙门释子。同梵行人不相看视谁当看者。比丘。譬如恒河遥扶那萨罗摩醯。流入大海。皆失本名合为一味。名为大海。汝等如是。各舍本姓皆同一姓沙门释子。汝等不相看视。谁当相看。譬如刹利婆罗门鞞舍首陀罗。各各异姓。共入大海皆名海商人。如是比丘。汝等各各异姓异家信家非家舍家出家。皆同一姓沙门释子。不相看视谁当看者。若比丘病。和上应看。若无和上。同和上应看。若不看者越毗尼罪。若有阿阇梨。阿阇梨应看。若无阿阇梨。同阿阇梨应看。若不看者越毗尼罪。若有同房。同房应看。若无同房。比房应看。若不看者越毗尼罪。若无比房者。僧应差看。随病人宜须几人应与。若不看者。一切僧越毗尼罪。佛语比丘。汝还看本比房病比丘去。去佛不远。佛化作一病沙弥。佛言。汝通看是病沙弥。此即神罚汝。复次佛住舍卫城。广说如上。尔时南方有二比丘。共来问讯世尊。道中一比丘病。一比丘待经二三日。语病比丘言。我欲并去问讯世尊。汝差已后来。病比丘言。长老。待我差已共去。答言长老。我不见世尊。久思慕如渴。不容相待。汝差已后来。彼比丘来诣佛所。头面礼足却住一面。佛知而故问。汝何处来。比丘以上因缘具白世尊。佛言。比丘。此是恶事。若有比丘。心怀放逸懈怠不精进。不能执持诸根驰骋六欲。虽近我所为不见我。我不见彼。若有比丘。能执诸根心不放逸。专念在道。虽去我远即为见我。我亦见彼。所以者何。随顺如来法身故。破坏诸恶故。离贪欲故。修寂静故。汝等比丘同出家修梵行。汝不相看谁当看者。汝还看病比丘去。复次佛住舍卫城。广说如上。尔时钵罗真国有二比丘。共作伴来问讯世尊。至蜂聚落一比丘病。一比丘待经二三日。语病比丘言。我欲并去问讯世尊。汝差已徐来。病比丘言。长老。待我差已共去。答言。长老。我不见世尊。久思慕如渴。不容相待。病比丘言。汝必欲去者。可为我嘱质帝利居士。比丘即往至居士所。作是言。长寿。我二人从远来欲往诣佛。今一人得病。欲权留此。长寿。为我经纪所须。我欲前行问讯世尊。居士言。尊者。宜住共相看视差已俱去。答言居士不尔。我不见佛久。思慕如渴。居士言。尊者去。世尊。但当遣还徒自疲劳。比丘故去往至佛所。头面礼足却住一面。佛知而故问。汝从何来。比丘以上因缘具白世尊。佛言比丘。此是恶事。汝等各各异姓信家非家舍家出家。同一释种。病痛不相看视谁当看者。汝还看病比丘去。复次佛住舍卫城。广说如上。尔时有一比丘从北方来欲问讯世尊。闻道边有病比丘即作是念。世尊制戒。病者应看。我若见者不得前进。即回道而去。往到佛所头面礼足却住一面。佛知而故问。汝从何来答言。世尊我从北方来从何道来。答言。从某道来。佛言。有何因缘。舍正道从回道来。比丘以上因缘具白世尊。佛言。比丘。此是恶事。如是乃至汝还看病比丘去。看病比丘法者。若比丘共商人行至旷野得病。同伴比丘不得相舍。应当将去代担衣钵。应亲近扶接不应远离。若不能行者。应从商人贾借乘驮。作如是言。长寿。是出家人病不堪及伴。为我载致使得脱难。若得者善。若言尊者我乘重。应言。长寿。我当与谷草直。若得者。不得载牸牛车乘草马等。当载特牛车乘[馬*父]马。若病笃无所分别者。趣乘无罪。若乘不可得者。应留能看病人。若一人若二人若三人。汝看病人。我到聚落当求乘来迎。应留粮食。使住者不乏。若各言谁能弃身命于旷野。无肯住者。不得便尔舍去。应作庵舍敷草蓐作烟火与取薪水。留时药夜分药七日药尽寿药。语病者言。长老。安意住。我到前聚落。当求乘来迎。到聚落中不得绕塔问讯和上阿阇梨。应语聚落中诸比丘言。旷野中有病比丘。共迎去来。若言在何处。答言。某处。若言彼处多有虎狼。恐当食尽。万无一在。虽闻此语不得便住。要当往看。若遥见乌鸟。不得便还。要到其所。若已死者应供养尸。若活者应将至。聚落语旧比丘言。长老。此是某处病比丘。我于旷野供养已。今来至此。次长老看。若不看者越比尼罪。若无比丘。应语优婆塞。长寿。旷野中有病比丘。借我乘往迎。檀越言在何处。如是乃至迎来至檀越家。安别障处。若人多应取二三人能看病者看。若病人言须多人乐住者。应尽住共劝化。索前食后食时。药夜分药七日药尽寿药。供给使无渴乏。若有客比丘来者。不得便语。长老汝看病比丘。应言。善来长老。应代担衣钵为敷床座。与水洗足及涂足油。若时来者应与前食后食。若非时来者应与非时浆。止息已应语言。长老。是病比丘我看已久。长老。次复应看。若无常者应供养舍利。若比丘比丘尼共商人行。若比丘尼病。比丘不得舍去。应语去去姊妹将接之。宜如比丘中说。唯除抱撮。若须按摩油涂身者。应倩女人为之。若无常者。彼有衣钵应雇人阇维。若无者应舍去。有俗人嫌言。何以留是死尸去。若能作地想者。应担着远处。尔时尊者优波离白佛言。世尊。若大德比丘病者。当云何看视。佛告优波离。大德比丘病。不得着边陋小房中。不得着避回处。应着显现房中。共行弟子依止弟子常侍左右。扫洒房中巨磨涂地。烧众名香勿令臭秽。敷置床座。若比丘来问疾者。应与前食后食。非时来者。应与非时浆。若有问事。病者应答。病人力劣。应侍者答。若优婆塞来问讯者。应言。善来长寿。语令就座而为说法。汝大得功德。如世尊说。看持戒病比丘。如看我无异。若有供养为咒愿受。若病人患下。问疾者不得久停。应速发遣。若病人不能出。应畜三除粪器。一授病人。一持出。一洗已油涂日曝。如是迭用。一人应户边住。莫令人卒入。一人在病人边住。时时为随顺说法。如是优波离。大德比丘病。应如是看视。时尊者优波离复问世尊。小德比丘病。当云何看视。佛告优波离。小德比丘病者不应着显现处。臭秽熏外。不得着屏猥处。死时人不知。应安人中。若病人有和上阿阇梨若共行弟子依止弟子应看。若无者众僧应差看病人。若一二三人看。若病人衣钵外有医药直者。应取还供给。若无者众僧应与。若僧无者彼有重价衣钵。应转贸轻者供给病人。病人惜者应白众僧言。大德僧。某甲病比丘。不知无常悭惜衣钵不肯贸易。白僧已软语说法使得开解。然后贸易。若复无者应乞与。若不能得者。应僧食中取好者与。若复无者。看病人应持二钵入聚落乞食。持好者与。优波离。是名看小德病比丘法。病人成就五法难看。何等五。不能服随病药随病食。不从看病人语。病增损不知。苦痛不能忍苦。懈怠无慧。是名五法病人难看。病人成就五法易看。何等五。能服随病药随病食。随看病人语。人问知病增损。能忍苦痛。精进有慧。是名五法病人易看。五法成就不能看病。何等五。多污不能出大小行器唾盂等。不能为病人索随病药随病食。不能时时为病人随顺说法。有希望心。惜自业。是名五法不能看病。五法成就能看病人。少污能出大小行器唾盂等。能为病人索随病药随病食。能时时为病人随顺说法。无希望心。不惜自业。是名五法能看病人。病人九法成就。命虽未尽而必横死。何等九。一知非饶益食贪食。二不知筹量。三内食未消而食。四食未消而擿吐。五已消应出而强持。六食不随病食。七随病食而不筹量。八懈怠。九无慧。是名九法成就而必横死。复次成就九法终不横死。何等九。一知非饶益食便少食。二善知筹量。三内食消已而食。四不强吐。五不强持六不食不随病食。七食随病食食能筹量八不懈怠。九有智慧。是名成就九法终不横死。佛语优波离。有三种病人。何等三。有病人得随病药随病食如法看病而死。或有病人不得随病药随病食如法看病而活。有病人得随病药随病食。得如法看病人。病必差不得便死。优波离。病比丘中。有不得如法看便死。得如法看便活者。是故应好看。务令如法安隐。即为施命。是故看病得大功德。诸佛赞叹。是名看病人法。药法者

佛俱萨罗国游行。尔时尊者舍利弗风动。诸比丘以是因缘具白世尊。佛问比丘。宜须何药。答言。世尊。呵梨勒。佛言。从今日听病比丘服呵梨勒。佛告诸比丘。待我还舍卫城时语我。当为诸弟子制药法。佛还舍卫城。诸比丘白佛言。世尊。当为诸弟子制药法。今正是时。佛告诸比丘。从今日后听诸病比丘服药。药法者。时根非时根。如是茎皮叶果浆。时根者。芜菁根葱根紧叉根阿蓝扶根芋根摩豆罗根藕根。如是等与食合者。是名时根。非时根者。婆吒根荜茇罗根尼俱律根佉提罗根苏揵阇根。如是比不与食合者。是名非时根。茎皮叶华果亦如是。浆者。时浆非时浆。时浆者。一切米汁饙汁乳酪浆。是名时浆。非时浆者。一切豆一切谷一切麦渍头不坼苏油蜜石蜜。是名非时浆。若比丘病。医言。与食便活不与便死者。应净洗器七遍淘谷致囊盛系已。器中煮令头不破。然后与饮。一切地亦时亦非时。除八种灰。余一切灰亦时亦非时。是名药法。和上阿阇梨共行弟子依止弟子法者

佛住舍卫城。广说如上。尔时有一岁比丘。将无岁弟子。两肩上各有衣囊头上戴一。左手捉钵及革屣。右手提澡瓶及盛油革囊。共诣佛所头面作礼。头上衣囊堕世尊膝上。世尊即自却已。知而故问。是谁许。答言。世尊。是我共住弟子。汝几岁。答言。一岁。弟子几岁。答言无岁。佛语比丘。喻如溺人而复救溺。汝始一岁。已畜无岁弟子。佛告诸比丘。不能自降伏欲降伏他人。无有是处。不能自调而欲调御他人。无有是处。不能自度而欲度人者。无有是处。自未解脱欲解脱余人者。无有是处。佛语比丘。已能自降伏降伏余人。斯有是处。能自调御调御他人。斯有是处。已能自度兼度余人。斯有是处。已自解脱解脱余人。斯有是处。佛言。从今日后。不听减十岁比丘度人出家受具足。复次佛制戒。不听未满十岁度人出家受具足。尔时难陀优波难陀满十岁。度人出家受具足已不教诫。如天牛天羊戴标荡逸无制御者。清净不具足。威仪不具足。不知承事和上阿阇梨。不知承顺长老比丘。不知入聚落法。不知阿练若法。不知入众法。不知着衣持钵法。诸比丘以是因缘具白世尊佛言。从今日有十法成就。听度人出家受具足。何等十。一持戒。二多闻阿毗昙。三多闻毗尼。四学戒。五学定。六学慧。七能出罪能使人出罪。八能看病能使人看。九弟子有难能送脱难能使人送十满十岁。是名十事听度人出家受具足。下至满十岁知二部律亦得。复次佛住舍卫城。广说如上。尔时有比丘命终。有二共住弟子。感思忧恼共坐树下。如商人失财。佛知而故问。是何等比丘。诸比丘以是因缘具白世尊。佛言。从今日后。听请依止敬如和上。请依止法者。应偏袒右肩胡跪接足。作如是言。尊忆念。我某甲从尊乞求依止。尊为我作依止。我依止尊住。第二第三亦如是说。复次有一岁比丘。受无岁比丘依止。乃至九岁比丘受八岁比丘依止。诸比丘以是因缘具白世尊。佛言。从今日后。不听减十岁受人依止。时六群比丘满十岁。受人依止已不教诫。如天牛天羊。乃至不知着衣持钵法。诸比丘以是因缘具白世尊。佛言。从今日后。成就十法听受人依止。何等十。持戒乃至满十岁。是名十事得受依止。下至满十岁知二部律亦得。欲请依止时。不得趣请。有五法成就然后得请。何等五。一爱念。二恭敬。三惭。四愧。五乐住。是名五法应请依止。阿阇梨有四。何等四。一依止师。二受法师。三戒师。四空静处教师。复有四种阿阇梨。何等四。有阿阇梨不问而去。有阿阇梨须问而去。有阿阇梨苦住尽寿应随。有阿阇梨乐住虽遣尽寿不离。不问而去者。有师依止住。无衣食病瘦汤药。复不能说出家修梵行无上沙门果法。如是师不问而去。问而去者。有阿阇梨依止而住。虽有衣食病瘦汤药。而不能说出家修梵行无上沙门果法。如是师须问而去。苦住者。有阿阇梨依止而住。虽无衣食病瘦汤药。善说出家修梵行无上沙门果法。如是阿阇梨共住虽苦尽寿不应去。有乐往者。有阿阇梨依止而住。能与衣食病瘦汤药。善说出家修梵行无上沙门果法。如是阿阇梨虽驱遣。尽寿不应去。是名四。复有四种。何等四。受法依止调伏贪欲嗔恚愚痴。是中能为弟子善说法除贪欲嗔恚愚痴。如是阿阇梨最上最胜。喻如从乳得酪从酪得酥从酥得醍醐醍醐最上最胜。和上阿阇梨应教共住弟子依止弟子。教法者。不净应遮。非行处。被羯磨。恶邪见自解使人解。自出罪使人出罪。病自看使人看。难起若自送若使人送。王贼。不净应遮者。若弟子犯小小戒。别众食处处食。女人同屋。未受具足人过三宿。截生草不净果食。应教言。莫作是。若言和上阿阇梨我更不作者善。若言和上阿阇梨但自教教他为。若如是者应语知床褥人夺床褥。知食人断食。若前人凶恶。依王力大臣力。能作不饶益者。若是和上应避去。若是依止阿阇梨。应担衣钵出界一宿还。即离依止。共住弟子依止弟子作不净行。和上阿阇梨不教者。越毗尼罪是名不净应遮。非行处者。大童女家寡妇家摴蒱家酤酒家。恶名比丘尼恶名沙弥尼。在是诸处往反者。和上阿阇梨应教。莫此处来往。是非可习近处。若受者善。乃至出界一宿还。即名离依止。共住弟子依止弟子在非行处往反。若不教者。越毗尼罪。是名非行处。被羯磨者。应断理僧。若作折伏羯磨不语羯磨发喜羯磨摈出羯磨。于三见中。若一一见谤线经恶邪见边见。谏不舍作举羯磨。和上阿阇梨应为弟子悔谢诸人。诸长老。此本恶见。今已舍行随顺法。凡夫愚痴何能无过。此小儿晚学实有此过。从今日当教敕更不复作。悦众意已。求僧为解羯磨。共住弟子依止弟子僧作羯磨不为解者。越毗尼罪。是名被羯磨。恶邪见起自解使人解者。若弟子起恶邪见若谤线经。若恶邪见若边见。和上阿阇梨应教莫起此见。此是恶事。堕恶道入泥犁长夜受苦。如是种种为说舍者善。若不舍者应语彼知识。如是言。长老为彼说令舍恶见。若不自解不使人解。越毗尼罪。是名恶见自解使人解。自出罪使人出者。若弟子犯可治罪。若犯僧伽婆尸沙。覆藏者。应自与波利婆沙。若不覆藏者。应与摩那埵。乃至越毗尼罪。应自治若不能者使人治若共住弟子依止弟子犯罪。师不自与出不使人与出。越毗尼罪。是名自出罪使人出罪。病自看使人看者。若弟子病应自看使人看。不得使人看。己自不经营。一日应三往看。语看病人。汝莫疲厌。展转相看佛所赞叹。若共住弟子依止弟子病。师不看者。越毗尼罪。是名病自看使人看。难起若自送若使人送者。若弟子亲里欲罢其道。师应教远避成就出家功德。应自送。若老病若知僧事应嘱人送。若不自送不使人送。越毗尼罪。是名难起若自送若使人送。王贼者。若弟子为王收录。师不应便逐去。应在外伺候消息。若王家问。谁是和上阿阇梨尔时应入。若事枉横应求知识证明。若须财物追逐应与衣钵。若无者应乞求与。若弟子为贼抄卖远在他方者。师应推求追赎。若弟子王贼所捉。和上阿阇梨不救赎者。越毗尼罪。若和上阿阇梨。共住弟子依止弟子亦应如是谏。不得粗语。如教诫法。应软语谏和上阿阇梨。不应作是事。若言子我更不作若尔者善。若言止止汝非我和上阿阇梨。我当教汝。汝更教我。如逆捋竹节。汝莫更说。若是和上者。应舍远去。若依止阿阇梨。应持衣钵出界一宿还依止余人。若师有力势应远去。若不去应依止有德重人。若非行处应谏若被羯磨应料理。若起恶见当自解倩人解。自出罪倩人出罪。病不病应供给。若师有难应送去。若王贼捉应追救。若共住弟子依止弟子师犯小小戒不谏。乃至王贼捉不追救者。越毗尼罪。共住弟子依止弟子于和上阿阇梨边。应行是事。起迎报语。作是事自作与他作。衣钵事。自剃与他剃。刀治与取受经。授他与欲取欲。服药迎食与他迎食。离境界大施。不问去。起迎者。弟子遥见和上阿阇梨。应起迎。若食五正食。若受一食法。不得起者应低头。若受一食法时应白师。师应问。汝堪一食不。堪者应受。若言不堪。应语莫受。若弟子见师不起者。越毗尼罪。是名不起迎。报语者。和上阿阇梨共语弟子应报。若口中有食。能使声不异者应报。若不能者待咽已然后报。师言何故闻我语不报。应语言。弟子口中有食。若师语不报者。越毗尼罪。是名报语。作事者。和上阿阇梨语弟子作是事。如法应作。若言唤彼女来取酒来。应软语言。我闻如是等非法事不应作。师若语作如法事。不作者越毗尼罪。是名作事。自作与他作者。若欲有所作应问。我欲共某甲作是事。师应观相。前人若不善持戒者。应语莫与从事。若是善持戒者。应语共作。若次到作维那直月应白师。如威仪中广说。是名自作与他作。衣钵事者。若欲熏钵。若取巨磨泥炉及熏时。一一应白。若不能一一白者。但言我欲作熏钵事。一白通了。熏钵时应问和上阿阇梨。钵欲熏不。若言熏。应问为先熏后熏。为一处熏。若言一处。应问着上着下。随师教应作。若欲染衣时应白。若浣时缝时煮染时一一应白。若不能者但言。我欲作染衣事。一白通了。染衣时应先问和上阿阇梨。衣欲染不。若言染者。应问欲前染后染为一时。若言一时。应先染和上阿阇梨衣。如是缝时染时举时。不得持师衣裹己衣。应持己衣裹师衣作衣钵事不白师。越毗尼罪。是名衣钵事。自剃与他剃者。自欲剃发时应白师。师应问谁与汝剃。答言。某甲某甲知剃不。答言。此是眼见事。师言。不可。若言知。师应观前人不善持戒亦言不可。若善持戒应言剃。若欲与他剃发者。应白师。我与某甲比丘剃发。师应问。汝能不。答言。此是眼见事。何故不能。应语不可。若言我能。应相前人。若不善持戒者。应言不可。若善持戒者。应言好用意。若和上阿阇梨入聚落后。剃发人来欲令剃发者。应白余长老。比丘我欲剃发。师还应白师。师行后得剃发人剃发。是名自剃与他剃。刀治者。欲与他破疮时应白师。与某甲比丘破疮。师应问汝能不。答言。此眼见事。何故不能。师言。不可。若言能。师应相前人。若不善持戒者。应语不可。若善持戒者。应问何处病。若言猥处者。应语离谷道边各四指莫触。若刺头出血。若除处痈痤等应作。若自欲破疮时应白师。师应问在何处。若言在猥处者。应语不可。若在余处如上说。是名刀治。与取者。若欲与他物时应白师。师应问与谁。若言与寡妇童女淫女樗蒱凶恶人恶名比丘尼恶名沙弥尼不持戒比丘。应语。不应与此人等相习近。若父母不信三宝者。应少经理。若有信心者。得自恣与无乏。若欲取他物。时应白师。师应问谁与汝。若言大童女乃至不善持戒比丘与我。应语莫与此人等相习近。若言善持戒者。应语取。问齐几许。得不白与取。半条线半食。是名不白与取。与他迎食自迎食者。若他倩迎食时应白师。与某甲比丘迎食。师应问彼比丘何故不去。答言。彼间食苦。此间食乐应语若求乐者莫为请。若为维那。若病人请者。当相望其人。不善持戒者应言不可。若言当次与迎应语取彼钵净洗。合自钵持去。若言彼善持戒者应言与迎。若欲请人迎食者应白师。师应问。汝何故不去。答言。彼间食苦。此间食乐。应语汝为乐故不可。若作维那若病。应问使谁迎答言。某甲。若彼不善持戒应言不可。若言彼次应与我迎食。应语更请余人。若同和上阿阇梨。若善持戒者与迎是名自迎食与他迎。受经授经者。若欲授他经时应白师。师应问授谁经。答言。与某甲比丘授经。授何经。若言沙路伽耶陀。应语不可世尊所不听。若言咒经。应语可。应教彼莫以此活命。若言阿含师应相彼人。不善持戒。应言。不可。若善持戒者。应语。汝经利不。答言。不利。他边问已当授。应言。不可。若言利者。应语授。若欲自受经时亦应白师。如上说。是名自受授他。与欲取欲者。若与欲取欲时应白师。如上迎食中广说。服药者欲服药时当先白师。若已坐欲先饮酥后食者。虽不白而服无罪。离境界者出僧伽蓝门过二十五肘应白而去。若经行若坐禅。应白令知处所。欲大小行时。若在师前应低头设敬而去。不在师前不敬无罪。作大施者。若欲大施应白师言。我一切所有尽欲布施。师应语。出家人要须三衣钵盂尼师坛漉水囊。革屣。弟子言。我除是外。一切尽欲布施师应相望。若不善持戒。不受诵习行道。应言听。若善持戒。能受诵习行道。应语布施非是坚法。汝依是诸物以备汤药。得坐禅诵经行道。若言我有亲里自供给我衣食病瘦汤药。师应语。若尔者听。是名大施。白去者。若欲行时应白和上阿阇梨。不得临行乃白。应先前一月半月豫白。弟子欲至某方国土师应问。何事故去。若言此间僧作事苦受经诵经苦。和上阿阇梨复言。少食少饮多觉少眠。彼间住乐。师应语汝为是故出家。何得辞苦。若言和上阿阇梨经营事务不授我经。是故欲去。若能授者。应语莫去。若不能者。众中有善持戒诵利者。应语于彼授。若复无者。彼间有知识多闻比丘应遥嘱。若行时不白和上依止阿阇梨而去者。越毗尼罪。是中共住弟子依止弟子。于和上阿阇梨所。应行是事。是名白和上阿阇梨而去

摩诃僧祇律卷第二十八摩诃僧祇律卷第二十九

        东晋天竺三藏佛陀跋陀罗共法显译

    明杂诵跋渠法之七

复次佛游俱萨罗国。尔时诸比丘持和上阿阇梨衣钵在前。去界内聚坐待师。畏失依止故不出界。佛知而故问。此是何等比丘聚坐。诸比丘以是因缘具白世尊。佛告诸比丘。此非是离依止待。如来俱萨罗国游行。还舍卫城时语我。当为诸弟子制舍依止法。佛还舍卫城。诸比丘以上因缘具白世尊。今正是时。唯愿世尊为诸比丘制舍依止法。佛告诸比丘。若和上命终时离依止。若罢道被举和上出界宿。若共住弟子出界宿。是名离依止。若依止阿阇梨若命终罢道被举若出界宿。若依止弟子出界宿。若满五岁善知法善知毗尼得离依止。是名舍依止。若比丘不善知法不善知毗尼。不能自立不能立他。如是比丘尽寿应依止住。若比丘满十岁善知法善知比尼。能自立复能立他。如是比丘得受人依止。是名和上阿阇梨共住弟子依止弟子法。沙弥法者。世尊不乐欲父母爱重为之泣泪临得转轮王舍家出家。乃至尊者罗睺罗出家因缘应广说。佛告舍利弗。汝去度罗睺罗出家。舍利弗言。我云何度罗睺罗出家。佛言。汝往教言。我罗睺罗。归依佛归依法归依僧。如是三说我罗睺罗。归依佛竟归依法竟归依僧竟。尽寿不杀生不盗不邪淫不妄语不饮酒。佛婆伽婆出家。我罗睺罗随佛出家如是三说佛婆伽婆出家。我罗睺罗随佛出家。舍俗服着袈裟。尽寿不杀生持沙弥戒。尽寿不盗持沙弥戒。尽寿不淫。持沙弥戒。尽寿不妄语持沙弥戒。尽寿不饮酒持沙弥戒。尽寿不着华香持沙弥戒。尽寿不观听歌舞作乐时沙弥戒。尽寿不坐卧高广床上持沙弥戒。尽寿不过时食持沙弥戒。尽寿不得捉金银及钱持沙弥戒如是忆念持

复次佛住舍卫城广说如上。尔时尊者阿难。有一知识檀越家。合门疫病死尽。唯有一小儿在。恒在市肆前拾粒自活。时尊者阿难行过时。小儿见已随后而唤翁翁。阿难不闻遂去。为世人讥嫌。言云何沙门释子他有父时。强亲如父如子。今见衰丧而不顾录。小儿追唤不已。阿难顾视识之。呼言子来。时小儿随后入祇洹精舍。佛见已知而故问。是谁小儿。阿难以上因缘具白世尊。此小儿得出家不。佛告阿难。汝作何心。答言。慈愍心。佛言。得出家。世尊当云何与出家。如上罗睺罗出家中广说

复次佛住舍卫城。广说如上。尔时有摩诃罗出家。聚落中安居竟。欲诣世尊问讯。将十沙弥。尔时世尊在露处坐。摩诃罗遥见世尊。便指语诸沙弥言。是汝祖翁。时诸小沙弥竞前趣佛。或捉床座。或牵捉衣或摩足。或捉澡罐。佛知而故问。是谁沙弥。答言。是我许。佛言。汝云何多度沙弥。从今日后。不听畜众。若畜一极至三听畜。若大德比丘多人宗重。应语与余人。复白言。我知有余人。但欲在阿阇梨下受诵经法增长修学。是故与阿阇梨。如是应语与余人得自教诏。若畜众沙弥。得越毗尼罪

复次佛住舍卫城。广说如上。尔时有比丘将一沙弥归看亲里路经旷野。中道有非人化作龙右绕沙弥。以华散上。赞言善哉。大得善利。舍家出家不捉金银及钱。比丘到亲里家。问讯已欲还时。亲里妇言。汝今还去道迥多乏。可持是钱去市易所须。沙弥受取系着衣头而去。中道非人见沙弥持钱在比丘后行。复化作龙来左绕沙弥。以土坌上。说是言。汝失善利。出家修道而捉钱行。沙弥便啼。比丘顾视问沙弥。汝何故啼。沙弥言。我不忆有过。无故得恼。师言。汝有所捉耶。答言。持是钱来。师言舍弃。弃已非人复如前供养。比丘以是因缘往白世尊。佛言。从今日后。不听沙弥持金银钱。若比丘使沙弥最初捉金银钱者。得越毗尼罪。若见沙弥先已捉。后使捉者无罪。复次佛住舍卫城。为诸天世人之所供养。广说如上。尔时尊者大目连。共专头沙弥。食后到阎浮提阿耨大池上坐禅。时专头沙弥见池边金沙。便作是念。我今当盛是沙。可着世尊澡罐下。尊者目连从禅觉。即以神足乘虚而还。时专头沙弥为非人所持。时目连回见唤沙弥来。答言。我不能得往。问汝有所持耶答言。持是金沙。汝应舍弃。舍已即乘虚而去。诸比丘以是因缘具白世尊。佛言。从今日后。不听沙弥捉金银及钱

复次佛住迦维罗卫尼拘律树释氏精舍。诸檀越设供饭僧。时有沙弥在中逐鸟驱蝇。并拾遗饭骨菜果蓏而啖。时有诸母人情多怜愍。见已作如是言。沙门释子无有慈心食不平等。如畜犊子先乳后[穀-禾+牛]。而今比丘畜此小儿独食不与。此坏败人何道之有。诸比丘以是因缘具白世尊。佛言。从今日后。出家人食应等与。沙弥法者。沙弥有三品。一者从七岁至十三。名为驱乌沙弥。二者从十四至十九。是名应法沙弥。三者从二十上至七十。是名名字沙弥。是三品皆名沙弥。尔时尊者优波离。知时而问世尊。沙弥云何与安居衣分。佛言。若得比丘意应与。若半若三分之一。得比丘意者。持戒能作净事。优波离复白佛言。云何与沙弥非时衣分。佛言。等与。若沙弥得多衣。畏作非法去者。若与半若与三分之一。若彼和上阿阇梨言等与是沙弥无他。应随师语与。亡人衣分亦如是。是名沙弥法钵法者。佛住尸利曼荼罗林中。成佛不久。时有商人。一名帝隶浮娑。二名跋梨伽。应广说乃至持糗蜜往诣世尊。世尊作是念。过去诸如来应供正遍知为手受食。为器受食耶。作是念已。时四大天王各持金钵来奉世尊。佛言。不应受如是银钵。一切宝钵皆不应受。复各持石钵来。佛复作是念。若受一钵。恐诸王意不悦。即时受四钵。累置左手中。右手按之合成一钵。令四际现。佛受钵已受商人糗蜜。广说咒愿尔时商人欢喜前白佛言。愿赐爪发还起支提。佛即剪爪剃发与之起塔

复次佛住孙婆白土聚落。尔时孙婆天神来至佛所白佛言。世尊。是中过去诸如来应供正遍知受用此间瓦钵。唯愿世尊听诸比丘受用瓦钵。佛言。从今日后听受用瓦钵。复次佛住舍卫城。尔时有比丘往至法豫瓦师所。作如是言。长寿。为我作钵。尔时作好瓦钵。令色如金与比丘。佛言。不听作金色。复作银色。佛言。不听作银色。佛语诸比丘。今是斋日。唤法豫优婆塞。洗浴着净衣受布萨。时优婆塞洗浴着净衣来至佛所受布萨已。世尊示土处。汝知是土。如是和如是打如是[土*廷]如是作如是熏作钵。熏作钵成就已作三种色。一者如孔雀咽色。二者如毗陵伽鸟色。三者如鸽色。佛言。熏时当伺候使作如是色

复次佛住舍卫城。尔时有比丘。优婆尸婆国土持钵来白佛言。世尊。听用是钵不。佛言。听用。如是迦絺耶国持钵来。佛言。听用。北方比丘持赤钵来白佛言。听用是钵不。佛言。不听用。复次佛住舍卫城。五事利益故。如来应供正遍知五日一行诸比丘房。见一比丘痏手。佛知而故问。比丘汝安乐不。答言。世尊。我手痏失钵堕地。破钵故是以不乐。佛言。从今日后。听诸比丘用铁钵。用铁钵时。应作钵炉熏熏时当用阿摩勒核佉陀罗核巨摩竹根熏

复次佛住王舍城。尔时王阿阇世作大新堂竟。作如是念。此堂谁能知其过失。唯有诸沙门释子。聪明智慧能知此过失。又作是念。我不可直唤诸比丘来看此堂。正当设会处处着人微听所说。尔时诸比丘来入。有一比丘作是言。此堂都好。唯一角差降一[麩-夫+廣]麦许。复有一比丘作是言。此堂都好。唯阁道上户楣额太下。王刹利种羽仪扇盖不得平行出入。时有一摩诃罗比丘。见地断材头作是念。此好可作钵。比丘食讫还去。尔时诸人各白王所闻。王即唤巧匠以綖量度。如说无异。即敕巧匠使令改之。王忆摩诃罗语。诸比丘故当须钵。即唤巧师旋作木钵。作种种饭食盛满钵复持瓦钵铁钵盛满饭食。遣人送往奉上世尊。佛言。不听用木钵。受垢腻故。亦是外道幖帜故不得受。此中净者。世尊即受。不净者不受。复次佛住王舍城。尔时阿阇世王未与毗舍离离车有怨。时南国商人持一段摩尼来与王阿阇世。得已作是念。此宝是诸舅所须。即遣人送与离车。离车得已作是念。此宝不可分。即着摩尼库中。离车后行诸库见摩尼已。此宝可中作器饮释伽罗浆。即唤摩尼师来作器。器成偶似钵形。离车作是念。此是出家人器。非俗人所宜。应与萨遮尼揵子。复有言。应与姊子尼健。复有言。何故与是啖酒糟驴。应与世尊。如是众多各各不同。即行筹取定。与佛者多。众人议言我等不可空钵与佛应当庄严校饰。即以碎宝满钵置宝笼中。复持瓦钵铁钵盛种种食奉献世尊。佛语诸离车。此摩尼钵不应受。是中碎宝及宝笼亦不应受。听铁钵瓦钵不听宝钵。净者应受。不净者不应受。离车即持宝钵还归。众人议言。应与姊子尼犍。复有人言。是啖酒糟驴。不应与宝笼及碎宝。应作绳络囊盛空钵与。即作绳络盛空钵。遣人送与。时有一离车信敬尼揵。先往具白此事。彼送钵来者慎莫与受。钵至已。尼犍言。是空钵不应受。麻绳作络亦不应受。先与瞿昙沙门后与我。故亦不应受。我今唯受一事。若截诸年少离车舌。合盐油熬。盛满钵来我当受。信还具白诸离车。诸离车言。此是我姊子。怨伤故作是言耳。但当送与。如是三反。所言不异。诸离车言。此是奇事。我以厚施反生怨毒。即遣人往持搏打杀。诸比丘以是因缘具白世尊。云何萨遮尼揵子坐舌害身。佛言。非但今日坐舌害身。如举吉罗本生经中广说。巅多利鸟生经中说。如鳖生经中说。如鹦鹉生经中说复次佛住舍卫城。尔时有比丘。钵中安隔盛种种食。佛知而故问。比丘。汝钵中作何等。答言。世尊。是中一处安饭。一处安羹。一处安肉菜。佛言。汝贪着种种味耶。从今日不听钵中安隔。若安隔者越比尼罪。若以饼隔及饭隔者无罪。复有比丘。用生钵食故而吐。佛言应熏。当用阿摩勒核熏佉陀罗核巨摩竹根熏。尔时诸比丘钵底尽佛言。底应安曼荼罗鍱。尔时诸比丘用金银宝物作。佛言。不应用金银作。应用赤铜白镴铅锡。尔时诸比丘尽通遍覆钵。佛言。不听一切尽覆。极大者去缘四指。极小者如尸舍树叶。诸比丘曼荼罗上作鸟兽形像。佛言。不听作鸟兽形像。若作钵鍱者若方若圆。曼荼罗法者。若钵无曼荼罗不得着地。若着地者得越毗尼罪。应着钵支上若叶若草上。若钵安曼荼罗者着地无罪。若泥地曼荼罗者着地无罪。下至水洒地安钵无罪。若停钵置地者。越毗尼罪。是名钵法。粥法者

佛住舍卫城。时城内难陀母。忧婆斯荼罗母半月中三受布萨。八日十四日十五日。布萨日作食先饭比丘后自食。至明日复作布萨。食作釜饭逼上。饭汁自饮。即觉身中内风除宿食消。觉饥须食。作是念。阿阇梨是一食人。应当须粥。取多水着少米。合煎去两分。然后内胡椒荜茇。粥熟已盛满瓮。持诣祇洹精舍。至已稽首佛足却住一面白佛言。唯愿世尊听诸比丘食粥。佛言。从今日后听食粥。其日有檀越。精舍中饭僧。诸比丘心生疑。世尊制戒不得处处食。我等云何作净得食。佛言。若粥初出釜。画不成字者。是非处处食非别众食。非满足食。若粥初出釜。画成字者。名处处食。亦名别众食满足食。尔时世尊说偈咒愿

  持戒清净人所奉　　恭敬随时以粥施
  十利饶益于行者　　色力寿乐辞清辩
  宿食风除饥渴消　　是名为药佛所说
  欲生人天常受乐　　应当以粥施众僧

复次佛俱萨罗国游行。渐渐至呵帝钦婆罗门聚落。应广说。乃至婆罗门车载粳米豆胡麻酥油石蜜。随逐世尊六月中。欲伺无人作供时我当作供。佛在世人民信心欢喜多设供养。前食后食都无空缺。世尊还舍卫城。时婆罗门家遣信来追。种作时至宜应速还。时婆罗门问尊者阿难。世尊明日从何门出趣舍卫城。阿难言。婆罗门汝何故问。婆罗门言。我所有米豆欲散道中。愿佛比丘僧蹈上而去。便为受用。阿难言。婆罗门须我问佛。尔时尊者阿难。以是因缘具白世尊。佛言。阿难。谁曾教化受彼供养。答言。尊者舍利弗。佛问舍利弗。汝曾受彼供养耶。世尊。我曾受彼一食。佛言。汝即是教化彼者。可往语彼婆罗门。明日能为僧作粥不。舍利弗即往说法。乃至能为众僧作粥不。婆罗门言。我乃欲以米豆布地令佛及僧蹈上过。作粥何以不能。即夜办种种粥酥粥乳粥油粥酪粥肉粥鱼粥。晨朝佛比丘僧坐已。手自行粥。佛知而故问。米置何处。答言此处。何处煮。答言。此处。佛言。内宿不听。内煮亦不听。听余净粥不听是粥。复次佛俱萨罗国游行。至故石婆罗门聚落。尔时有剃发师摩诃罗父子。出家住此聚落。时摩诃罗闻世尊来即语儿言。汝持剃发具入聚落。求米豆酥油石蜜。世尊至当作种种粥。儿即入聚落。众人问言。汝剃发欲得何物。答言。我须米豆酥油石蜜。汝用何为。答言。明日世尊至。当作种种粥。时诸居士闻已信心欢喜加倍与之。即持还住处。世尊至已。摩诃罗自作种种粥。至明旦佛比丘僧坐已。摩诃罗自洗手躬自行粥。佛知而故问。比丘。此何等粥。答言。世尊。我本在家时供养诸比丘。常作是念。何时当得自手供养世尊。今故作此粥。佛言。何处得米。答言。小儿客作剃发得。佛言。内宿不听。内煮不听。自煮不听。客作得亦不听。听余净粥净作得食。复次佛鸯求多罗国游行。时鸡尼耶螺髻梵志闻世尊来。作种种粥酥粥胡麻粥乳粥酪粥油粥鱼肉粥。佛比丘僧坐已行种种粥。诸比丘心生疑。世尊制戒不得处处食我等云何得净而食。佛言。若粥初出釜画不成字者。听除肉粥鱼粥余一切粥。非处处食。非别众食。非满足食。若比丘乞食。煮饭未熟合泔汁[戀-心+廾]与食者无罪。若但取饭与食者。名别众食处处食满足食。是名粥法

饼法者。佛住舍卫城。世尊四月一剃发。剃发时世人持种种饼食来看世尊。时有一婆罗门问妇言。家中有饼具不。答言有。粳米二斗油四升。用作何等。答言。沙门瞿昙今日剃发。诸人悉持饼往。汝可疾疾作饼。我欲随伴供养沙门瞿昙。即作饼盛着器中。以净巾覆上持去。尔时世尊大众围绕。国王大臣刹利婆罗门十八大聚落主。悉在会中。此婆罗门疑惧不敢逆前。独在一处作是念。若沙门瞿昙一切智一切见者。常观世间无不见无不知。若照世间我今亦是世间。亦应知见我心。佛知婆罗门心念已。即遥唤婆罗门来。来已佛知而故问。婆罗门。汝器中何等。答言。是饼世尊。佛语婆罗门。行与众僧人人与一[米*番]。答言。此大众五百。今饼甚少不能得遍。佛言。汝但行。婆罗门即行饼人与一[米*番]。饼故不减。乃至三遍犹故不减。时婆罗门作是念。沙门瞿昙有大神力。如是少饼大众三遍。犹故不减。佛知婆罗门心欢喜已。随顺说法示教利喜。婆罗门即得须陀洹道。诸比丘白佛言。世尊。云何婆罗门以少因缘得大果报。佛言。不但今日以少因缘得大果报。过去世时已曾如是。如本生经中说。饼者。大麦饼[麩-夫+廣]麦饼小麦饼米饼豆饼油饼酥饼摩睺罗饼钵波勒饼牛耳饼波利斯饼刍徒饼曼坻罗饼欢喜丸肉饼。如是比一切皆名饼。除肉饼宾荼饼。余一切饼。非别众食。非处处食。非满足食。是名饼法。菜法者。佛住南山频头大邑。尔时有二优婆夷。一名娑婆居。二名叉波能。煮菜令如肉味。煮好菜已奉诸比丘。比丘不受心生疑悔。世尊制戒不得处处食。我等云何作净得食。以上事具白世尊。佛言。一切菜非处处食。非别众食。非满足食。菜者。干菜芜菁菜葱菜瓠菜。如是比是名菜法。糗法者。大麦糗小麦糗[麩-夫+廣]麦糗蒙具糗磨沙糗加罗那糗伊离糗胡麻糗。如是比一切糗。非别众食。非处处食。非满足食。是名糗法

浆法者佛住王舍城。尔时优伽梨居士作大施。象马奴婢各五百。种种杂施中有浆停久。诸比丘饮已醉闷。以是因缘具白世尊。佛言。从今日坏浆不听饮。复次佛住南山频头婆罗门聚落。尔时婆罗门聚落中婆罗门居士。节会日饮食相饷。尔时世尊时到着入聚落衣。持钵入村乞食。时魔波旬作是念。沙门瞿昙入聚落乞食。我当先往聚落惑彼人心使不与食。时世尊入聚落乞食遍无所得。空钵而出到一树下坐。时魔波旬复作是念。沙门瞿昙乞食遍无所得。我今当往扰乱其意。即到佛所在一面立作是言。沙门瞿昙。可往聚落乞食。当令入村便得种种好食。尔时世尊为波旬说偈言

  汝今失善利　　以扰如来故
  自得无量罪　　如来无苦事
  离一切烦恼　　常得安乐住
  念法禅悦食　　喻如光音天

时魔波旬忽然不现。其日世尊失食。诸比丘闻已。食者悔食。食半者止。未食者不食。时沙门婆罗门闻佛比丘僧失食。即持五百瓶石蜜奉献世尊。佛语比丘以水作净受取。病不病比丘尽得食。复次佛住梨耆阇河边。时世尊钵比丘钵共在露处。时有弥猴行见树中有无蜂熟蜜来取世尊钵。诸比丘遮。佛言莫遮。此无恶意。弥猴便持钵取蜜奉献。世尊不受。须待水净。弥猴不解佛意。谓呼有虫。转看见钵边有流蜜。持到水边洗钵。水湔钵中持还奉佛。佛即受取。佛受已弥猴大欢喜。却行而舞堕坑命终。时诸比丘即说偈言

  十力世雄在榛林　　佛钵僧钵在露处
  野兽殖德有情智　　见好成熟无蜂蜜
  直前往取世尊钵　　比丘欲遮佛不听
  得钵盛蜜来献佛　　如来慈愍为受之
  心悦欢喜却行舞　　脚趺坠坑而命终
  即生三十三天上　　下生出家成罗汉

复次佛鸯求多罗国游行。尔时鸡尼耶螺髻梵志闻世尊来。办种种浆待世尊。世尊至已。以种种浆奉佛及僧。诸比丘心生疑。世尊制戒。不得饮坏浆。我等云何得饮。诸比丘以是因缘具白世尊。佛言。听饮浆。浆者有十四种。何等十四。一名奄罗浆。二拘梨浆。三安石榴浆。四巅多浆。五葡萄浆。六波楼沙浆。七楼楼筹浆。八芭蕉果浆。九罽伽提浆。十劫颇罗浆。十一波笼渠浆。十二石蜜浆。十三呵梨陀浆。十四佉披梨浆。是名十四种浆。澄清一切听饮。若变酒色酒味酒香。一切不听饮。若持浆来者应作净。若器底有残水即名作净。若天雨堕中即名作净。若洗器有残水亦名为净。若车载石蜜被雨者即名为净。若船载水湔即名作净。若净人洗手水湔亦名为净。是名浆法。苏毗罗者。佛憍萨罗国游行。尔时尊者舍利弗风患动。诸比丘以是因缘具白世尊。佛言。当须何药治。答言。世尊。须苏毗罗浆。佛言。听服。佛告诸比丘。待如来从憍萨罗国游行还舍卫城语我。我当为诸弟子制苏毗罗浆法。行还已。诸比丘白佛言。世尊。先敕还舍卫城时当为诸比丘制苏毗罗浆。今正是时。佛告诸比丘。作苏毗罗浆法者。取[麩-夫+廣]麦轻捣。却芒尘土。勿令头破。以水七遍净淘置净器中。卧苏毗罗浆时。不得着东不得着北。应着南边西边开通风道。勿使臭气来入不得安着塔院中。不得着显现处。应着屏处。以呵梨勒鞞醯勒阿摩勒胡椒荜茇如是比尽寿药等置中。以净[疊*毛]覆之。以绳鸡足系以木盖上。受苏毗罗浆时。随浆多少以水中解然后饮。若不与水解饮。越毗尼罪。若麦头不破。时非时得饮。若麦头破。时得饮非时不得饮。是名苏毗罗浆法

  病药和上法　　阿阇梨共住
  依止弟子法　　沙弥法钵法
  粥法饼菜法　　糗法众浆法
  苏毗罗浆法　　第五跋渠竟

非羯磨者。佛住舍卫城。尔时瞻波比丘同住不和更相诤讼。一比丘举一比丘言我举长老。二比丘举二比丘。众多比丘举众多比丘。诸比丘以是因缘具白世尊。瞻波比丘非法生。云何一人举一人。二人举二人。众多人举众多人。佛告诸比丘。有四羯磨。何等四。有如法不和合羯磨。有如法和合羯磨。有非法和合羯磨。有非法不和合羯磨。孙陀罗难陀新染色。此处举余处舍。开眼林。外道出家。共期。空静想。苏河。善法讲堂。师子军将。男儿。离车童子。四凶斗人。阁上。转石。温泉。淫女。三婆蹉。索油。迎食。看病。鸟肉段。贼肉段。猪肉段。蹴女人。磨糗。放犊。舍妇。摩诃罗。隔壁。布萨。二苏毗罗浆。塼。粪。乞食。郁詶。孙陀罗难陀者。佛住波罗柰城尔时孙陀罗难陀在枳陀罗罽钵精舍。初夜后夜经行坐禅。晨起结跏趺坐久倾卧身露形起眠不自觉。时波罗柰城有淫女姊妹二人。一名加尸。二名半加尸。夜出城外。于园林中共诸年少行。爱欲法。晨朝还入因行过看。半加尸见比丘身生起语姊言。我欲共比丘行此欲事。姊小待我。答言。此是阿罗汉。已除贪欲嗔恚愚痴。不乐此事。汝不闻释家孙陀罗难陀有好端正妇弃舍出家耶。答言。不尔。但待我。即往就上作世俗法比丘即觉。以脚蹴堕破伤五处。两肘两膝及额上半加尸即起抖擞衣土。往至姊所语姊言。比丘见辱如是。姊言。我先不语汝耶。今复怨谁。比丘心生疑。以是因缘语诸比丘。诸比丘言。汝犯波罗夷罪。答言。我是阿罗汉不受乐。诸比丘以是因缘具白世尊。佛言。此比丘已除贪欲嗔恚愚痴。是阿罗汉无罪。如是毗尼竟。是名孙陀罗难陀

新染色者。佛住舍卫城。广说如上。尔时有比丘时到着入聚落衣。持钵入舍卫城次行乞食至一家。其家女人着新染色衣。坐不正故形体露现。比丘见已欲心起即语言。姊妹太赤。答言。阿阇梨。此新染色。是比丘心生疑。以是因缘具白世尊。佛言。汝以何心。答言。欲心。佛言。遣一比丘问彼女人解不。比丘即往问姊妹。有比丘来到此中耶。答言有。问言。彼比丘说何等。答言。我着新染衣坐。彼言大赤。我言。如阿阇梨语新染色故如是。时比丘以是因缘具白世尊。佛言。解义不解味。偷兰遮。解味不解义。偷兰遮罪。解味解义僧伽婆尸沙。不解义不解味。越毗尼罪。如是比尼竟。是名新染衣色。余处举者。尔时有比丘一处住。僧与作举羯磨已至余处僧中作如是言。长老。我被举。我今行随顺法心柔软。僧与我舍举羯磨。诸比丘即与作舍举羯磨。作舍举羯磨已问长老。汝为何事故被举。答言。长老。僧已与我舍举羯磨竟复问我为。诸比丘以是因缘具白世尊。佛言如比丘语僧与舍举羯磨时应先问。若不问已舍。不应复问。汝等云何余处僧作举羯磨此处僧舍。若余处僧作举羯磨此处僧舍者。得越毗尼罪。若比丘被举至余处者应作是语。长老。我被举。行随顺法心柔软。为我舍。僧应问。长老。汝以何事被举。若言我无事被举。应语长老。汝无事被举。我共汝法食味食。若言有事被举。僧应语。长老。汝还彼处僧中舍去。若彼处僧伽蓝空。若无常若罢道。若余处去都无僧者。应问汝以何事被举。若言我以是事被举。心柔软见过行随顺法已。应与舍。如是毗尼竟。是名余处举羯磨。开眼林者。尔时世尊未遮比丘尼阿练若处。时大爱道瞿昙弥。与五百比丘尼在开眼林中坐禅。尽是释种女。摩罗女。离车女出家。女皆年少端正。初夜坐禅时有淫荡年少。来欲侵逼诸比丘尼。比丘尼各以神足得脱。如是中夜后夜复还坐。年少复来。若不眠利根者。复以神足而去。若眠钝根者。则为彼侵逼心生疑。余比丘尼语是比丘尼言。汝等犯波罗夷。答言。我不受乐。如是我不知。诸比丘尼以是事语大爱道。大爱道即以是因缘具白世尊。佛言。是阿罗汉尼。已除贪欲嗔恚愚痴不受欲乐无罪。如是毗尼竟。是名开眼林。外道出家者。佛住迦维罗卫释氏精舍。尔时有比丘。时到着入聚落衣。入迦维罗卫城。时外道出家女。名字孙陀利。年少颜容端正着新染色衣。捉三掎杖。手执军持在店肆前行。比丘见已生欲心随后而行。有一新产牸牛。以角抵比丘掷女人上。尔时比丘心生疑。诸比丘以是因缘具白世尊。佛问比丘。汝有何心。答言。欲心。复问比丘。牛角举时汝有何心。答言。恐怖心。佛言。若欲心时无怖心。若怖心时无欲心。佛言。欲心随女人后行。步步得越毗尼罪。如是毗尼竟。是名外道出家。共期者。佛住舍卫城。尔时有比丘。时到着入聚落衣。持钵入舍卫城。次行乞食至一家。有一女人语比丘言。作是事来。答言。我比丘法不得作是事。女人言。若不作是事者。我当自伤破身。大唤言。比丘。强牵我行欲。比丘答言。须我到精舍已当还。女人言。汝沙门释子不妄语。要当来。答言尔。比丘以是因缘具白世尊。佛言。此是非法语。不应听已听。不应许已许。应将众多比丘共往。即将众多比丘往到已如是言。姊妹。我已来。女人言。和南阿阇梨。如是毗尼竟。是名共期。空静想者。佛住舍卫城。尔时有比丘。独坐树下作空静想。言我得阿罗汉此比丘说是语时。余比丘闻已作是言。长老。汝不实自称得过人法。犯波罗夷罪。答言。长老。我不自称得过人法。我独坐树下作空静想。言得阿罗汉耳。诸比丘以是因缘往白世尊。佛问比丘。汝实不得过人法而称得过人法耶。比丘言。世尊。我不自称得过人法我独坐树下作空静想。言得阿罗汉。佛言。是空静想称过人法者。犯偷兰罪。如是毗尼竟。是名空静想

苏河者。佛住毗舍离。尔时比丘僧集在一处尔时尊者大目连。作如是言。长老。我入无色定。闻苏河边龙象饮已抖擞耳声。诸比丘言无有是处。入无色定过一切色想。云何闻声。汝妄语不实。应作举羯磨。即集比丘僧。佛乘神足从空中来。知而故问诸比丘。汝作何等。诸比丘以上因缘具白世尊。乃至妄语不实作举羯磨。佛告诸比丘。目连实得无色定。不善知出入相。出定闻非入定闻。佛语目连。汝当应善分别知。如是毗尼竟。是名苏河

讲堂者。佛住舍卫城。尔时诸比丘集在一处。共作是论。善法讲堂柱拄梁不。尊者目连言。柱梁。有一无岁比丘言。不拄齐几不柱如毛许。即遣神足比丘往看。为柱不拄看已还来。言不拄齐几不拄。如毛许不拄。诸比丘。语目连言。不知拄不柱。何故言拄。汝妄语不实。应作举羯磨。即集僧作举羯磨。佛乘神足从空而来。知而故问。诸比丘。汝作何等。答言。尊者大目连乃至不拄言拄。不实妄语。欲作举羯磨。佛问无岁比丘。汝云何知不拄。答言。世尊。我曾一时在善法讲堂坐禅。佛语大目连。汝何故不自看。汝应审实。如是毗尼竟。是名善法讲堂。师子将军者。佛住毗舍离城。时阿阇世王与毗舍离离车有怨。时阿阇世王将四种兵欲伐离车。时毗舍离师子将军闻王贼欲至。即往尊者大目连所问言。尊者。谁得胜。王得胜我得胜。答言。王得胜。问言。有何瑞应。答言。我见二国非人共斗。王非人胜王亦应胜。师子将军闻已。即便国中募得五百健儿。师子将军语诸人言。我等宁作非丈夫而死。宁作丈夫入火坑而活。诸人答言。宁作丈夫而活得济眷属。时阿阇世王闻大目连语。宽闲不怖。徐徐顺恒水而上渡河。时师子将军奄其未阵。逆战大破。时阿阇世王非济而渡危而得免单马还国。即便嫌言。坐是尊者大目连。倾吾国事。时毗舍离离车师子将军破军已。大欢喜作是语。目连恐怖我。因此获大利。虽为不实语。蒙是虚诳恩。时诸比丘。闻阿阇世王嗔离车复嫌。诸比丘言。尊者大目连不知谁胜谁不胜而作妄语不实。集比丘僧欲作举羯磨。佛即乘神足来。知而故问。比丘。汝等欲作何事。答言。世尊。大目连乃至妄语不实欲作举羯磨。佛语诸比丘。目连见前不见后。佛语目连。汝应审谛。如是毗尼竟。是名师子将军男儿者。佛住舍卫城。尔时大目连有知识檀越。家妇妊身。问阿阇梨我生男生女。答言。生男。如是三重问。故言生男。后至产时生女。时母人嫌言。目连长夜作妄语言。生男而生女。取悦人情而作是言。诸比丘闻已。云何尊者大目连不善分别而作妄语。应作举羯磨。即集比丘僧。佛乘神足来。知而故问。比丘汝作何等。答言。世尊。大目连乃至妄语不实欲作举羯磨。佛言。目连见前男儿。不见中间尼。弥素夜叉。须女家持男与。须男家持女与。佛言。汝去往语彼家。世尊说言。女是汝许男是我许。即便往交共相贸易。如是毗尼竟。是名男儿。离车童子者。佛住毗舍离。时到着入聚落衣。持钵与众多比丘入毗舍离城。尔时有离车童子在重阁上。与五百妓女共相娱乐。佛遥见而笑。诸比丘白佛言。世尊。有何因缘故笑。佛言。此人却后七日当命终入地狱。阿难白佛言。颇有因缘得不入不。佛言。此人若于如来法中出家者得不入。佛告阿难。汝往教化此人劝令出家。阿难即受佛教往劝。乃至出家已。佛告阿难。汝语诸比丘。当守护此人。勿令犯戒使得重罪。时诸比丘受教已。安此比丘置一房中。外封闭其户。此比丘命尽。刀风解其形。时诸比丘亲里来见其命终甚大悲恼。佛为说偈言

  若人百千岁　　供养百罗汉
  不如一夜中　　出家修梵行
  缘此之福祚　　得离于六百
  六千六十岁　　三涂之苦恼

时闭户比丘心生疑悔。以是因缘具白世尊。佛问比丘。汝以何心。答言。世尊。饶益心。恐彼犯戒得重罪故。佛言。封闭户故越毗尼罪。如是毗尼竟。是名离车童子。四人舍斗者。佛住毗舍离。四人舍斗欲出家。共入毗舍离城门中。见本仇家。时守门人有弓杖。一人即捉弓一人张弓。一人射而不死。一人射断命根。是中一人射死一人射不死。是二人不应度出家。已出家者应驱出。是中一人捉弓一人张弓。是二人不应度出家。已度出家者置。若后作恶时应驱出。如是恶人不应度出家。若度出家受具足者。得越毗尼罪。是名四人舍斗。阁上者。佛住王舍城。尔时有一比丘得不净观。厌身故从阁上自投而下。时阁下有父子二人竹作。堕其父上。其父即死。儿即牵比丘至王所作是言。是比丘杀我父。王问比丘。尊者出家人。云何杀人。答言。大王。我自厌身阁上投下堕彼父上。其实如是。王言。放比丘去。其子称怨大王云何杀人而不问罪。王善方便欲解喻其意。汝去阁上令比丘在下。汝便自投其上。杀彼比丘以报父仇。其人自爱命重不能自投。时比丘心生疑悔。以是因缘具白世尊。佛言。汝以何心。答言。世尊。以厌身故。佛言。比丘。汝不看下自投。得越毗尼罪。如是毗尼竟。是名阁上

转石者。佛住王舍城。尔时摩诃罗父子出家。共上耆阇崛山。儿在前行。道中有石。作是念。我当除道使净。令婆路醯行无所碍安乐来上。便转石。石下磓杀摩诃罗。其子懊恼心生疑悔。我作二不饶益事杀人杀父。以是因缘具白世尊。佛言。汝以何心。答言。世尊。我为父通道欲使得乐。佛言。道中转石。得越毗尼罪。如是毗尼竟。是名转石。温泉者。佛住王舍城迦兰陀竹园。尔时有比丘。入温泉中洗浴。欲心起动身生触水失不净。心生疑悔。以是因缘具白世尊。佛言。汝以何心。答言。世尊。欲心。佛言犯僧伽婆尸沙。如是毗尼竟。是名温泉。淫女者。佛住王舍城。尔时有比丘。时到着入聚落衣。持钵入城次行乞食至一淫女家。淫女言。比丘共作是事来。比丘言。世尊制戒。不得行。淫女言。我知世尊制戒不得行淫。汝但来内作外弃。比丘即共行欲已心生疑悔。以是因缘具白世尊。佛言。内作外弃。外作内弃。内作内弃。若入一节。乃至如胡麻。犯波罗夷罪。如是毗尼竟。是名淫女。三婆蹉者。佛住王舍城。尔时尊者毕陵伽婆蹉。在聚落中住。时到着衣持钵次行乞食。得食已至一放牧家食。其家女到尊者边立啼。即问女言。何故啼。答言。阿阇梨。今是节会日诸人集戏。我无衣裳独不得往。那得不啼。时尊者即化作种种衣服珠宝璎珞金银校饰。与已便去。乃至王闻。闻已即唤女问。汝何处得此好璎珞。答言。尊者毕陵伽婆蹉见与。王即唤比丘来问。尊者何处得此好金。非世所有。比丘即捉杖打壁打床。一切化成金。作如是言。首陀罗何处得金。此即是也。王言。阿阇梨有大神足还去。放牧牛女还家。诸比丘闻已见毕陵伽婆蹉现异。乃至放牧女被执。应作举羯磨。即集比丘僧。世尊乘神足来。知而故问。汝作何等答言。世尊。毕陵伽婆蹉现异乃至放牛女被执。佛问毕陵伽婆蹉。汝实现异令牧牛女被执耶。答言。世尊。我不故现异令牧牛女被执。我慈心故耳。佛言。毕陵伽婆蹉大神足故无罪。如是毗尼竟

复次尊者毕陵伽婆蹉在聚落中住。自泥房舍。时瓶沙王来。见尊者自泥治房舍。问阿阇梨作何等。答言。首陀罗。泥治房舍。王言。阿阇梨。无人使耶。我当与园民。答言。不须首陀罗。如是至三。犹故不受。聚落中人闻已来到其所。求言。阿阇梨。愿取我等作园民。我当供给。比丘言。汝等一切能持五戒者。我当取汝。答言能。取已尽受五戒奉斋修德。聚落殷富遂致外贼来劫抄掠妇女及财物。聚落中人往告师言。阿阇梨。贼来劫我儿女钱财即日荡尽。尊者毕陵伽婆蹉入慈心定见贼驱去。比丘语贼言。首陀罗。汝何故劫我园民。即化作大坑。使园民在此岸贼在彼岸。语言。首陀罗汝去。诸比丘闻已作如是言。毕陵伽婆蹉贼复劫贼。应作举羯磨。即集比丘僧。检校此事。时世尊乘神足来。知而故问。汝作何等。答言。世尊。毕陵伽婆蹉贼复劫贼。欲作举羯磨。佛问毕陵伽婆蹉。汝实尔不。答言。世尊。我不贼复劫贼。但聚落人民啼来告我。我慈心故。佛言。是大神足无罪。如是毗尼竟

摩诃僧祇律卷第二十九摩诃僧祇律卷第三十

        东晋天竺三藏佛陀跋陀罗共法显译

    明杂诵跋渠法之八

复次佛住王舍城尔时尊者毕陵伽婆蹉。在聚落中住。日日渡恒水乞食。到恒水上作是言。首陀罗住。我欲过。水即住。过已作如是言。首陀罗汝去。如是水流如故。水神不乐。往到佛所。头面礼足却住一面白佛言。世尊。尊者毕陵伽婆蹉语太苦住首陀罗去首陀罗。佛言。呼毕陵伽婆蹉来。来已。佛言。汝实尔不。答言。实尔。佛言。恒神如是嫌汝。汝向忏悔。毕陵伽婆蹉言。我悔过首陀罗。恒神言向首陀罗今首陀罗为有何异而言悔过。毕陵迦婆蹉唯除佛八大声闻。余一切尽言首陀罗和上阿阇梨诸上座皆言首陀罗。诸比丘言。尊者毕陵伽婆蹉。乃至和上阿阇梨皆是首陀罗。正有是一人婆罗门出家耶。尊者大迦叶舍利弗目连等如是比皆是婆罗门出家。都不作是语。应作举羯磨。即集比丘僧。时毕陵伽婆蹉坐禅不来。遣使往唤。使便打户言。众僧集唤长老。时毕陵伽婆蹉即观见比丘僧集欲与我作举羯磨。即以神力制使比丘。着户令不得去。众僧怪使久不还。更遣比丘往唤。后比丘至。捉前使比丘手去来。长老即复相着不得去。如是使使相着皆不得去。诸比丘嫌言。众中正有此一人大神足耶。尊者大目连岂无此力耶。齐水际作福罚羯磨。佛以神足乘空而来。知而故问。汝作何等。答言。世尊。毕陵伽婆蹉唯除如来八大声闻。余乃至和上阿阇梨尽言首陀罗。欲作举羯磨。僧集不来。遣使往唤。神足复制。便使使相着不来。故欲作齐水际福罚羯磨。佛言。汝来。毕陵伽婆蹉发心顷在佛前立。佛语毕陵伽婆蹉。汝首陀罗语过。诸梵行人嫌汝。答言。世尊。我当如何。我不憍慢。亦不自大。轻蔑于人。然我唤和上阿阇梨诸长老比丘时。发声便成首陀罗。佛语比丘。是毕陵伽婆蹉非憍慢。亦非自大轻蔑余人。从五百世来常生婆罗门家首陀罗语习气不尽。佛语毕陵伽婆蹉。汝本从无始生死已来贪欲嗔恚愚痴尚能永拔。五百世习气而不能除。从今日后。莫作首陀罗语。闻世尊教恭敬故永不复作。如是毗尼竟。是名三婆蹉。一升油者。世尊涅槃后。长老比丘毗舍离住。尔时有一商人。自恣请法豫比丘尼。比丘尼有一依止弟子。常遣往取所须。时依止弟子不称师名又不自称直言须油。檀越即与。得已自用。檀越后便检挍油不入师。依止弟子心生疑悔语诸比丘尼。诸比丘尼言。汝犯波罗夷。诸比丘尼不了往问长老比丘。长老比丘言。虽隐覆取。檀越与故犯偷兰罪。如是毗尼竟。是名一升油。迎食者。舍卫城尔时精舍中有檀越饭僧。有一比丘自食己分。复迎一分。益食人问言。长老为谁取分。答言。我取。食者谁分。复言。我分。时比丘言。汝犯波罗夷罪。诸比丘不了往问长老比丘。长老比丘言。有不应得而取。但有主与故。得偷兰罪。如是毗尼竟。是名迎食

看病者。佛住舍卫城。尔时祇洹精舍有病比丘。共看病比丘诤已。时精舍中有檀越饭僧。病比丘作是念。彼人今日何能为我取食。即便倩余比丘取食。时看病比丘作是念。今日谁当与彼取食。时二人俱取食。益食人问看病比丘。为谁取食。答言。某病人食。复问倩迎食人。为谁取食。答言。某病人食。诸比丘言。汝犯波罗夷。时诸比丘不了往问长老比丘。长老比丘言。此倩取食者无罪病比丘共看病比丘诤已。不语看病人更倩余人者。越毗尼罪。看病人共病比丘诤已。不问与迎食者。越毗尼罪。如是毗尼竟。是名看病。鸟肉段者。佛住舍卫城祇洹精舍。尔时有比丘时到着入聚落衣。持钵入城乞食。时有鸟衔肉段堕比丘钵中。时比丘持还精舍煮已自食。分与诸比丘。诸比丘言。长老。汝何处得此肉。即具说上事。诸比丘言。汝犯波罗夷。诸比丘不了往问长老比丘。长老比丘言。畜生无属。如是毗尼竟。是名鸟肉段。贼肉段者。世尊涅槃后。长老比丘依王舍城住。时有盗贼偷牛。夜在尸陀林中杀啖有残。语林中坐禅比丘言。尊者须肉不。答言须。即与满钵。比丘取已持还精舍自食。分与余比丘。余比丘问言。长老。何处得此肉。具说上事。诸比丘言。长老。汝贼边取物。满五钱波罗夷。诸比丘不了往问长老比丘。长老比丘言。出家人前人如法不如法有主施无罪。如是毗尼竟。是名贼肉段。猪肉者。尔时俱睒弥提婆聚落边有贼偷猪啖。余残头脚舍弃而去。时有比丘见已持还精舍。煮已自食亦分与诸比丘。诸比丘言汝何处得此肉。即具说上事。比丘言。直五钱得波罗夷。时诸比丘不了往问长老比丘。长老比丘言。汝何心取。答言。无主想。无主想取无罪。如是毗尼竟。是名猪肉。蹴女人者。舍卫城只桓精舍。时有比丘。到时着入聚落衣。持钵入城次第乞食到一家。妇人言。比丘来入共作如是事来。比丘言。世尊制戒不得行淫。妇人言。若不从我者。当如是如是谤。强牵我。是比丘畏故便入。入已妇人语婢守门。我与比丘行欲。女人入已欲心炽盛即卧。比丘蹴已而去。守门婢问。尊者作事竟耶。答言。已竟。时比丘心生疑悔往问长老比丘。长老比丘言。汝以脚蹴女人。得偷兰遮。不作言作。波夜提。如是毗尼竟。是名蹴女人。

磨糗者。舍卫城只桓精舍。时比丘着入聚落衣。持钵入城次行乞食至一家。见女人蹲地磨糗。衣不覆形。比丘见已即生欲心语。姊妹。我欲食糗。女人即与糗比丘心生疑悔。往问长老比丘。长老比丘言。汝以何心。答言。欲心。即遣使问彼女人。女人答言。我蹲地磨糗。比丘乞糗。我便与之。使还答如上。长老比丘言。解义不解味。偷兰遮。乃至不解义不解味。得越毗尼罪。如是毗尼竟。是名磨糗。

犊子者。跋只国有人。去精舍不远放犊子。犊子来入精舍。践食华果抵突形像。知事人语放犊人。好看汝犊莫令纵暴。如是再三语。犹故不止。知事人嗔。牵犊子着房中。反闭户入聚落乞食。在道中作是念。房中多有夜叉。不能杀是犊耶。即还精舍开户见犊已死。比丘怖畏即持着众僧厕中。便舍而去。放犊人来问。阿阇梨见我犊不。答言。不见。比丘心生疑悔。问诸比丘。诸比丘不能决。往问长老。长老言。牵犊入房反闭户。得越毗尼罪持着僧厕中。得偷兰遮。见言不见。波夜提。如是毗尼竟。是名放犊

舍妇者。迦尸耆利大邑。时有摩诃罗端正。舍妇出家。其妇逐来在房外纺绩。摩诃罗语言。汝去。我出家人不须汝。答言。尊者。我在此作有何妨事。为欲时时见尊者。不能相离耳。摩诃罗以是数数语。犹故不去。即持衣钵弃舍而去有女人见已语言。汝本二已去。闻已即逐及已。便捉衣当前而立。作是言。阿阇梨为我故莫去。我当供给衣钵病瘦医药。摩诃罗言。我出家人。法不应尔。如是犹故不放。摩诃罗心生嗔恚。举衣钵着一处熟打而去。摩诃罗心生疑悔具以上事问持律比丘耶舍。耶舍言。嗔打妇人者。得波罗夷。诸比丘言。此非好断汝欲决疑者。可往枝提山中问持律尊者树提陀娑。必能决了。闻已即去。路经俱睒弥道逢一卖酪女。女见摩诃罗端正。便生欲心语。沙门共行欲来。摩诃罗作是念。我已犯波罗夷复何在。便共行欲。前至持律所具白上事持律言。云何耶舍。制五波罗夷法。嗔打妇人。得偷兰遮。共卖酪女行淫。得波罗夷。如是毗尼竟。是名舍妇

隔壁者。弗迦罗国有比丘比丘尼。精舍隔壁住。时比丘起欲心。通夜共比丘尼隔壁语。比丘心生疑悔。往问长老比丘。长老比丘言。汝有何心语。答言。欲心。如是欲心。语语得越毗尼罪。如是毗尼竟。是名隔壁

布萨者。弗迦罗聚落比丘。共阿练若比丘共一布萨。时阿练若住处比丘名弗絺虏。有大德名称。聚落中比丘见得利养起嫉妒心。时长老弗絺虏。至十四日布萨来入聚落。语聚落中比丘。长老。共作布萨来。答言。我十五日当布萨。弗絺虏言。我知日数今应十四日布萨。答言。我不作。十五日当布萨。如是至三不从。弗絺虏便去。去已聚落中比丘即布萨。明日弗絺虏复来。长老共作布萨来。答言。已布萨竟。聚落比丘言汝叛布萨。我不复与汝共法食味食。时弗絺虏。十四日便十四日来。十五日便十五日来。如是二十年中初不得布萨。时有善鬼神敬重弗絺虏。往至枝提山中尊者树提陀娑所作是言。尊者。不善不随顺尊者。在世聚落中比丘作如是非法。常恼乱弗絺虏。唯愿尊者。自往料理。尊者树提闻已即来。便作是念。我若先至阿练若处。聚落中比丘凶恶。闻者不共我法食味食。作是念已。即到聚落中比丘所。时善鬼神语尊者弗絺虏。尊者树提陀娑。今在聚落。可往问讯。闻已即往共相问讯。问讯已在一面坐。树提陀娑即问言。汝是弗絺虏耶。答言尔。慧命。汝叛布萨耶。答言。叛布萨不叛布萨。今当知。我二十年已来。十四日布萨十四日来。十五日布萨十五日来。如是叛布萨不。叛布萨耶。尊者自知。答言。慧命。是顺佛法。但聚落中比丘不随顺。二十年中受具足不名受具足。羯磨。不名羯磨。如是毗尼竟。是名布萨

二浆者。尔时优阇尼国。有人犯王法。截手脚已持着尸陀林中。近阿练若比丘处。宛转来至比丘所言。阿阇梨。我甚饥苦乞我少食。答言。无食。复言。阿阇梨。怜愍我。我有二种苦痛。一截手脚苦。二饥苦。答言。无食。正有苏毗罗浆须不。答言。须。即与浆。不得食久。饮已便死。比丘心生疑悔。问诸比丘不能得了。往问长老比丘。长老比丘言。汝以何心与。答言。饶益心。饶益心无罪。如是毗尼竟

复次优阇尼国。有人犯王法。截手脚已持着尸陀林中。近阿练若比丘住处。时有摩诃罗出家。次守房舍。无手脚人宛转来至其所。作是言。阿阇梨。我甚苦痛不可堪忍。颇有少药施我。我欲疾死。答言。我非旃陀罗杀人贼。云何从我索药不尔阿阇梨。我苦痛难忍。时摩诃罗起慈心。作是念。曾有如是比丘饮苏毗罗浆便死。即语言。汝欲饮苏毗罗浆不。答言。欲饮。即与浆饮。饮已便死。摩诃罗心生疑悔。往问长老比丘。长老比丘言。汝以何心与。答言。慈心遂彼意。长老比丘言。汝虽有慈心。无有智慧。断他命根。得波罗夷。如是毗尼竟。是名二浆

甎者。舍卫城只桓精舍。时比丘作房舍。园民授甎。比丘取捉不坚故落园民头上。破即便死。比丘心生疑悔。往问长老比丘。长老比丘言。汝以何心落甎。答言。捉不坚故。长老比丘言。应坚捉。如是毗尼竟。是名甎

粪者。舍卫城只桓精舍。五日一扫除粪秽。时有年少比丘。持粪掷墙外。有病摩诃罗出家。在墙下大小行。粪来镇上。未能得起后粪续至。如是便死。当墙比丘以粪聚高恐盗贼登入。即便除却。见死比丘心生疑悔。往问长老比丘。长老比丘言。汝以何心除粪。答言。不看。长老比丘言。若不看掷粪者。得越毗尼罪。如是毗尼竟。是名粪

乞食比丘者。佛般泥洹后。诸比丘在迦维罗卫国释氏精舍住。时有比丘着入聚落衣。持钵入城次行乞食。时有释种女端正。澡浴讫着新净衣。持食施比丘。施已头面礼足。比丘见已欲心起不能自制。失不净落女头上。女无嫌心。即持衣拭已作是言。阿阇梨。大得善利。有如是欲心。能于世尊法中修梵行。时比丘心生疑悔。往问长老比丘。长老比丘言。汝以何心。答言。我见前相心不能制。长老比丘言。应善观相制伏其心。如是毗尼竟。是名乞食

郁詶者。佛般泥洹后。长老比丘在迦维罗卫尼俱律树释氏精舍。尔时尊者郁詶。与一释种知旧。时释种病。有二儿各异母。一儿是释家女。一儿是异姓女。释种垂终时。嘱尊者郁詶。阿阇梨。我无常后。是二儿中有爱乐佛法得阿阇梨心者。示是地中藏。命终后。释女儿与恶友相逐不乐佛法。不来受经不乐诵读。时异姓女儿与善友相逐爱乐佛法。来到郁詶所受诵经戒。得长老心。即语。汝父亡时嘱我。儿中有乐法者。可示此藏。即示处。大得金银珍宝。家道富乐。释女儿闻已即白尊者阿难。阿阇梨。此非善非随顺。尊者郁詶。持我父财与异姓母儿。我释家法。释家女儿应继父业。所有财物皆应属我。阿难言。是非法分处我不共法食味食。时罗睺罗来到郁詶所。二人同和上。即语罗睺罗言。莫与尊者阿难同法食味食。问言。何故。具说上因缘。我无事阿难不共我法食味食。罗睺罗我共汝法食味食。阿难闻罗睺罗与郁詶共法食味食。时阿难亦不共罗睺罗法食味食。时有人送食与尊者阿难。阿难语。与世尊子罗睺罗去。如是有送食。与尊者罗睺罗者。罗睺罗言。持与世尊侍者去。如是迦维罗卫国七年中不作布萨自恣。尊者优波离在支提山中住。时释种子往至尊者优波离所。作如是言。阿阇梨。我不善不随顺阿阇梨在世。迦维罗卫是世尊生地。云何七年中不作布萨自恣。唯愿尊者往和合。优波离即来。教诸释种。严饰大堂敷好坐具散华烧香。为饭客比丘。并请尊者阿难。先唤罗睺罗安一屏处。抱一小儿放坐中地。尊者阿难坐已见地小儿。若言取者应语不取。愿尊者与罗睺罗和合者我当取。如是教已。尊者优波离坐已。次尊者阿难坐。诸比丘次第坐讫。时释家女抱孩儿。手捉生酥而[口*數]。放坐中地。儿便啼唤。阿难见已爱念心生。语言。取此小儿。答言。不取。若尊者与罗睺罗和合者当取。不和合者不取。阿难言。此沙门法。非汝俗人事。但抱小儿。答言。不尔。如是至三。阿难言。唤罗睺罗来。来已。尊者优波离语阿难言。如阿难有檀越如是如是。嘱长老。我命终之后。长老如是与有何过失。尊者郁詶亦复如是。阿难云何以是事与世尊子罗睺罗而不和合。如是毗尼竟。是名郁詶。是名毗尼法

障碍不障碍法者。佛住舍卫城。广说如上。尔时尊者难陀优波难陀。游行诸国还只桓精舍。着入聚落衣入舍卫城。至喜悦优婆夷家。优婆夷见已言。善来阿阇梨。何乃希现即请令坐。头面礼足却住一面。共相问讯已。比丘言。优婆夷。我希行。与我作何等好饮食。优婆夷答言。从阿阇梨教。前食后食若饼若肉。随所须当办。即请言。尊者明日受我食。愿时早来。即便受请。其家明日作种种饮食。敷座而待。时比丘多事因缘忘不来赴。日时已过。食可停者留。不可停者便取食之。如是二日三日待不来已便取尽食。至第四日方来。优婆夷见已心不悦。作是言。阿阇梨。云何受我请而不来。诸比丘闻已。以是因缘具白世尊。佛言。唤难陀优波难陀来。来已。佛言。是喜悦优婆夷。于佛比丘僧都无爱惜。何故于中娆乱。汝云何一向受请。不开障碍因缘。障碍因缘法者。若有人言。尊者明日受我请前食。若须者应言尔。彼复言。尊者。必当来。应言。中间无障碍当来如是。后食一切请亦如是。若比丘安居竟去时檀越言。尊者。后更来。若欲来者答言尔檀越复言。尊者。其必当来。应语。若中间无障碍当来。若言阿阇梨礼塔。不得语言中间无障碍。应语当礼。若言尊者为我礼塔。应语言若忆当礼。若言尊者礼长老比丘。不得言无障碍。应语当礼。若言尊者为我礼长老比丘。应语若忆当礼。若言尊者受经诵经持戒坐禅。不得语中间无障碍。当受诵经。应语我为是故出家。若言学须陀洹斯陀含阿那含阿罗汉果。不得语中间无障碍当学。应语我为是故出家。是中应作障碍而不作。不应作而作。俱越毗尼罪。是名障碍不障碍法

比丘尼法者。佛住迦维罗卫国释氏精舍。尔时大爱道瞿昙弥。与五百释女求佛出家。如线经中广说。乃至佛告诸比丘尼。从今日大爱道瞿昙弥比丘尼僧上坐。如是持。尔时大爱道瞿昙弥白佛言。世尊。为比丘尼制八敬法。我等得广闻不。佛言。得八敬法者。比丘尼虽满百腊。应向新受戒比丘起迎恭敬作礼。不得言待我百腊然后向新受戒比丘作礼。一切比丘尼应向长老中间年少比丘起迎恭敬作礼。若比丘尼至比丘精舍时。应头面一一礼一切比丘足。若老病不能者。随力多少礼。余不遍者得总礼。应言我比丘尼某甲。头面礼一切僧足。若比丘至比丘尼精舍时。一切比丘尼应起迎礼足。亦如上说。若比丘尼作是分别。是犯戒。是医师。是摩诃罗无所知。憍慢不恭敬起迎作礼者。越敬法(第一敬法竟)

二年学者。满十八岁女欲于如来法律中受具足者。和上尼应供给所须与。白僧料理。尼众中能作羯磨人。应作是说。阿梨耶僧听。十八岁女某甲。欲于如来法律中受具足。若僧时到。僧某甲欲从僧乞二岁学戒。诸阿梨耶听。某甲欲从僧乞二岁学戒。僧忍默然故。是事如是持。此女人入僧中。应一一头面礼僧足。礼僧足已胡跪合掌。教作如是言。阿梨耶僧忆念。我满十八岁女某甲。欲于如来法律中受具足。我今从僧乞二岁学戒。唯愿阿梨耶僧怜愍故。与我二岁学戒。如是三说。尼羯磨师应作是说。阿梨耶僧听。某甲女年满十八已。从僧乞二岁学戒。若僧时到。僧与某甲二岁学戒。白如是。阿梨耶僧听。某甲女年满十八已。从僧乞二岁学戒。僧今与某甲二岁学戒。阿梨耶僧忍与某甲二岁学戒和上尼某甲者默然。若不忍便说。第一羯磨竟。第二第三亦如是说。僧已与某甲二岁学戒竟。僧忍默然故。是事如是持。是式叉摩尼得二岁学戒已。应随顺行十八事。何等十八。一切大比丘尼下。一切沙弥尼上。于式叉摩尼不净。于大尼净。于大尼不净。于式叉摩尼亦不净。大尼得与式叉摩尼三宿。式叉摩尼得与沙弥尼三宿。式叉摩尼得与大尼授食。除火净五生种取金银及钱。自从沙弥尼受食。尼不得向说波罗夷乃至越毗尼罪。得语不淫不盗不杀不妄语如是等。式叉摩尼。至布萨自恣日入僧中。胡跪合掌作如是言。阿梨耶僧。我某甲清净。僧忆念持。如是三说而去。后四波罗夷犯者。更从始学十九僧伽婆尸沙已下。若一一犯。随所犯作突吉罗悔。若破五戒。随犯日数更学。何等五。非时食。停食食。捉钱金银。饮酒。着华香。是名十八事。是式叉摩尼二岁学戒满已。欲于如来法律中受具足者。和上尼应白僧乞畜弟子羯磨。尼羯磨师应作是说。阿梨耶僧听。某甲式叉摩尼二岁学戒满二十欲于如来法律中受具足。若僧时到。僧和上尼某甲欲从僧乞畜弟子羯磨。阿梨耶僧听。某甲欲从僧乞畜众羯磨。僧忍默然故。是事如是持。和上尼应胡跪合掌作如是言。阿梨耶僧忆念。是式叉摩尼二岁学戒满二十欲受具足。我某甲今从僧乞畜弟子羯磨。唯愿僧与我畜弟子羯磨。如是至三。羯磨人应作是说。阿梨耶僧听。某甲式叉摩尼。二岁学戒已满二十欲于如来法律中受具足。尼某甲已从僧中乞畜弟子羯磨。若僧时到。僧与尼某甲畜弟子羯磨。白如是。阿梨耶僧听。某甲式叉摩尼。二岁学戒已满。二十欲于如来法律中受具足。尼某甲已从僧乞畜弟子羯磨。僧今与尼某甲畜弟子羯磨。诸阿梨耶忍与尼某甲畜弟子羯磨者默然。若不忍便说。是第一羯磨。第二第三亦如是说。僧已忍与尼某甲畜弟子羯磨竟。僧忍默然故是事如是持。是式叉摩尼二岁学戒已满。二十欲于如来法律中受具足者。入僧中先头面礼僧足。礼僧足已先请和上尼。胡跪合掌作如是言。尊忆念。我某甲从尊乞求和上。尊为我作和上。与我受具足。如是至三。和上尼应语发喜心弟子言。我顶戴持和上尼已。先与求衣钵。与求众。与求二戒师。与求空静处教师。推与众僧。羯磨师应作是说。此中谁能与某甲空静处作教师。答言我能。羯磨师应作是说。阿梨耶僧听。某甲从某甲受具足。若僧时到。僧某甲和上尼某甲某甲。能空静处作教师。诸阿梨耶僧听。某甲和上尼某甲某甲空静处作教师。僧忍默然故。是事如是持。教师应将欲受具足人离众不近不远。教有二种若略若广。云何是略众僧中当问。汝有当言有。无当言无。云何是广。善女听。今是至诚时。是实语时。于诸天世间天魔诸梵沙门婆罗门诸天世人阿修罗若不实者。便于中欺诳。亦复于如来应供正遍知声闻尼众中欺诳。此是大罪。今当问汝。有者言有。无者言无父母夫主在不。若言在应问。父母夫主听不。求和上尼未。五衣钵具不。学戒二岁满不。作畜众羯磨未。汝字何等。答言字某。和上尼字谁。答言字某。汝不杀父母不。不杀阿罗汉不。不破僧不。不恶心出佛身血不(佛久已涅槃而故依旧文)不坏比丘净戒不。非贼盗住不。非越济人不。不自出家不。本曾受具足不。若言曾受。应语去不得受具足。若言不者应问汝非婢不。非养女不。不负人债不。非兵妇不。非阴谋王家不。汝是女不。非石女不。非烂堕不。非二道通不。非破不。不无乳不。非一乳不。非常血病不。非无血不。非一月常血不。非不能女不。汝无如是种种诸病着身不。癣疥黄烂癞病痈痤痔病不。禁黄病疟病謦欬消尽癫狂热病风肿水肿腹肿如是种种。更有余病着身不。答言无。教师来入僧中白言。某甲问已讫。自说清净无遮法。羯磨师应作是说。阿梨耶僧听。某甲从某甲受具足。某甲已空静处教问讫。若僧时到。僧某甲和上尼某甲听入僧中。阿梨耶僧听。某甲和上尼某甲听入僧中。僧忍默然故。是事如是持。此人入僧中。一一头面礼僧足。在戒师前胡跪合掌授与衣钵。此钵多罗应量受用乞食器我受持。如是三说。此是僧伽梨。此是郁多罗僧。此是安陀会。此是覆肩衣。此是雨衣。此是我五衣。此五衣尽寿不离宿受持。如是三说。羯磨师应作是说。阿梨耶僧听。某甲从某甲受具足。某甲已空静处教问讫。若僧时到。僧某甲和上尼某甲。欲从僧乞受具足。诸阿梨耶听。某甲和上尼。某甲欲从僧乞受具足。僧忍默然故是事如是持。羯磨师应教乞。阿梨耶僧听。我某甲从和尚尼某甲受具足。阿阇梨某甲已空静处教问讫。我某甲和上尼某甲。今从僧乞受具足。唯愿僧哀愍故与我受具足。如是至三。羯磨师应作是说。阿梨耶僧听。某甲从某甲受具足。某甲已空静处教问讫已。从僧乞受具足。若僧时到。僧某甲和上尼某甲。我欲于僧中问遮法。阿梨耶僧听。某甲和上尼某甲。我欲于僧中问遮法。僧忍默然故是事如是持。善女听今是至诚时。是实语时。乃至如是种种更有余病着身不。答言无。羯磨师应作是说。阿梨耶僧听。某甲从某甲受具足。某甲已空静处教问讫已从僧乞受具足。父母夫主已听。已求和上五衣钵具。是女人二岁学戒满已。作畜众羯磨。自说清净无遮法。若僧时到。僧某甲和上尼某甲。我欲于僧中说三依法。阿梨耶僧听。某甲和上尼某甲。我欲于僧中说三依法。僧忍默然故。是事如是持。善女听。此是如来应供正遍知欲饶益故。于声闻尼众中正说制三依。若堪忍直心善女人与受具足。不堪忍者不与受具足。何等三。粪扫衣少事易得应净无诸过。比丘尼随顺法。依是出家受具足。得作比丘尼。此中尽寿能堪忍持粪扫衣不。答言能。若长得钦婆罗衣[疊*毛]衣刍摩衣俱舍耶衣舍那衣麻衣躯牟提衣。依乞食少事易得应净无诸过。比丘尼随顺法。依是出家受具足。得作比丘尼此中尽寿能堪忍乞食不。答言能。若长得半月食八日十四日十五日说戒食筹食请食。依陈弃药少事易得应净无诸过。比丘尼随顺法。依是出家受具足。得作比丘尼。是中尽寿能堪忍服陈弃药不。答言能。若长得酥油蜜石蜜生酥及脂。依此三圣种当随顺学。阿梨耶僧听。某甲从某甲受具足。某甲已空静处教问讫已。从僧乞受具足。父母夫主已听。已求和上尼五衣钵具。是女人二岁学戒满已。作畜弟子羯磨。自说清净无遮法。已堪忍三依若僧时到。僧与某甲受具足。和上尼某甲。白如是。阿梨耶僧听。某甲从某甲受具足。某甲已空静处教问讫已。从僧乞受具足。父母夫主已听。已求和上五衣钵具。是女人二岁学戒满已。作畜弟子羯磨。自说清净无遮法。已堪忍三依。僧今与某甲受具足。和上尼某甲。诸阿梨耶忍与某甲受具足。和上尼某甲。忍者僧默然。若不忍便说。是第一羯磨。第二第三亦如是说。僧已与某甲受具足竟。和上尼某甲。僧忍默然故。是事如是持。善女听。汝已受具足。一白三羯摩无遮法和合僧十众。汝今当敬重于佛敬重于法敬重于僧。敬重和上敬重阿阇梨。汝已遭遇人身难得佛世难值闻法亦难众僧和合意愿成就难。已得具足当随顺学。如无忧华离于尘水。汝当依倚修习泥洹善法。得具足此戒序法。八波罗夷。十九僧伽婆尸沙。三十尼萨耆波夜提。百四十一波夜提。八波罗提提舍尼众学法。七灭诤法随顺法。我今略说教诫汝。后和上阿阇梨当广教汝。受具足已即日和上尼应将到比丘僧所。和上尼应为乞。胡跪合掌作如是言。大德僧忆念。我已与某甲受具足。今从僧乞为某甲受具足。哀愍故与某甲受具足。如是三说。羯磨师应问。比丘尼众中清净无遮法不。若不问者越毗尼罪。羯磨师应作是说。大德僧听。某甲从某甲尼受具足。已比丘尼众中清净无遮法。尼某甲已从僧乞受具足。若僧时到。僧某甲和上尼某甲。欲从僧乞受具足。诸大德听。某甲和上尼某甲。欲从僧乞受具足。僧忍默然故。是事如是持。羯磨师应教胡跪合掌作如是言。大德僧忆念。我某甲从和上尼某甲受具足。已比丘尼众中清净无遮法。我某甲和上尼某甲。我今从僧乞受具足。唯愿僧哀愍故与我受具足。如是至三。羯磨师应作是说。大德僧听。某甲从某甲受具足。已比丘尼众中清净无遮法。已从僧乞受具足。若僧时到。僧某甲和上尼某甲。我欲于僧中问遮法。诸大德僧听。某甲和上尼某甲。我欲于僧中问遮法。僧忍默然故。是事如是持。羯磨师应问。今是至诚时。是实语时。于诸天世间天魔梵沙门婆罗门诸天世人阿修罗。若不实者。便于中欺诳。亦复于如来应供正遍知二部僧中欺诳。此是大罪。我今僧中当问汝。有者言有。无者言无。父母夫主在不。乃至除女人隐处。余如上尽问。羯磨师应作是说。大德僧听。某甲从某甲受具足。已比丘尼众中问清净无遮法。已从僧乞受具足。父母夫主已听。已求和上五衣钵具。二岁学戒满已。乞畜众羯磨竟。自说清净无遮法。若僧时到。僧某甲和尚尼某甲。我欲于僧中说三依。诸大德听。某甲和上尼某甲。我欲于僧中说三依。僧忍默然故。是事如是持。善女听。此是如来应供正遍知欲饶益故。于声闻尼众中正说制三依。若堪忍直心善女人与受具足。不堪忍者不与受具足。粪扫衣少事易得应净无诸过。随顺比丘尼法。依是出家受具足得作比丘尼。是中尽寿能堪忍持粪扫衣不。答言能若长得钦婆罗衣[疊*毛]衣刍摩衣俱舍耶衣舍那衣麻衣驱牟提衣。如是依乞食依陈弃药如上广说。大德僧听。某甲从某甲受具足。已比丘尼众中清净无遮法。已从僧乞受具足。父母夫主已听。已求和上五衣钵具。二岁学戒满已。作乞畜众羯磨竟。自说清净无遮法已堪忍三依。若僧时到。僧与某甲受具足。和上尼某甲白如是。大德僧听。某甲从某甲受具足。已比丘尼众中清净无遮法。已从僧乞受具足。父母夫主已听。已求和上五衣钵具。二岁学戒满已。作乞畜众羯磨竟。自说清净无遮法。已堪忍三依。僧今与某甲受具足。和上尼某甲。诸大德忍与某甲受具足。和上尼某甲。忍者默然。若不忍便说。是第一羯磨。第二第三亦如是说。僧与某甲受具足竟。和上尼某甲僧忍默然故。是事如是持。善女听。汝已受具足。善受具足。一白三羯磨无遮法和合僧二部众十众已上。汝今当敬重于佛敬重于法敬重于僧。敬重和上敬重阿阇梨。汝已遭遇人身难得佛世难值闻法亦难众僧和合意愿成就难。顶礼释师子及诸声闻众已得具足。如无忧华离于尘水。汝当依倚修习泥洹。善法得具足

佛住毗舍离大林重阁精舍。尔时法豫比丘尼弟子欲受具足。时庵婆罗离车童子。闻法豫弟子欲受具足。便作是念。此女于我有如是不饶益事。今若出精舍门者。我当更捉坏其梵行。令不得受具足。法预比丘尼闻已往到世尊所。头面礼足却住一面白佛言。世尊。我有弟子欲受具足。若出精舍者畏坏梵行彼间住。此间僧得与遥受具足不。佛言得。先比丘尼众与受具足已。往比丘僧中乞使受具足。尼僧与受具足已。法预即往白比丘僧乞使受具足。羯磨人应作是说。大德僧听。法预比丘尼弟子某甲欲受具足。若来者畏伤梵行。若僧时到。僧法预比丘尼弟子某甲。欲从僧乞使受具足。诸大德僧听。法预比丘尼弟子某甲欲乞使受具足。僧忍默然故。是事如是持。和上尼应僧中胡跪合掌作如是言。大德僧忆念。我法预比丘尼弟子某甲欲受具足。若来者畏伤梵行。已比丘尼众中受具足无遮法。我某甲为弟子某甲乞使受具足。唯愿大德僧哀愍故。与我弟子某甲使受具足。如是至三。僧中应羯磨堪能者若二若三不得羯磨众。羯磨人应作是说。大德僧听。法预比丘尼弟子某甲欲受具足。已比丘尼众中受具足无遮法。若来者畏伤梵行。法预比丘尼为弟子某甲。已从僧乞使受具足。若僧时到。僧今羯磨。某甲某甲比丘为法预弟子某甲受具足。白如是。大德僧听。法预比丘尼为弟子某甲受具足。已比丘尼众中受具足无遮法。若来者畏伤梵行。法预比丘尼为弟子某甲。已从僧乞使受具足。僧今羯摩。某甲某甲比丘使为法预比丘尼弟子某甲受具足。诸大德忍羯磨某甲某甲比丘使为法预比丘尼弟子某甲受具足者默然。若不忍便说。是初羯磨。第二第三亦如是说。僧已羯磨某甲某甲比丘使为法预比丘尼弟子某甲受具足竟。僧忍默然故。是事如是持。是比丘受羯磨竟即应往比丘尼精舍。受具足人应向使乞。胡跪合掌作如是言。大德僧忆念。我某甲从和上尼某甲受具足。已比丘尼众中受具足清净无遮法。我若出此间者畏伤梵行此间住。我某甲和上尼某甲。今从僧乞受具足。唯愿僧哀愍故与我受具足。如是至三。和上尼应共使到僧中。和上尼应乞。胡跪合掌作如是言。大德僧忆念。我法预比丘尼弟子某甲欲受具足。已比丘尼众中受具足清净无遮法。若来者畏伤梵行彼间住。我法预弟子某甲今从僧乞受具足。唯愿僧哀愍故与受具足。如是三乞。羯磨人应作是说。大德僧听。某甲从某甲受具足。已比丘尼众中受具足清净无遮法。若来者畏伤梵行彼间住。和上尼某甲已从僧乞受具足。若僧时到。僧与某甲受具足。和上尼某甲。白如是。一白三羯磨已。和上尼共使还至比丘尼精舍。作如是言。善女听。汝已受具足。一白三羯磨无遮法十众以上和合二部众。受具足竟。汝应恭敬三宝。汝已遭遇人身难得佛世难值闻法亦难。是名二岁学戒二部众中受具足。是名第二敬法。说罪者。比丘尼不得说比丘实罪非实罪。比丘得说尼实罪。不得说非实罪。尼不得说言医师比丘犯戒比丘摩诃罗比丘。若亲里者得软语谏不得呵责。若是年少应语。汝今不学待。老当学耶。汝后当教诏弟子。汝不学者后弟子亦当学汝作恶。是故汝应随顺学受经诵经。若比丘尼说比丘。过言医师比丘犯戒比丘摩诃罗比丘者。越敬法。比丘得说比丘尼实过。不得呵责言剃发老妪淫荡老妪摩诃梨老妪。若是亲里作非法者。得语言莫作是事。不得呵骂应软语谏。若年少者应语。汝今不学待老当学耶。汝后当教诏弟子。汝不学者后弟子亦当学汝作恶。是故当受经诵经。若比丘呵骂比丘尼。言剃发老妪淫荡老妪摩诃梨不善不识恩养者。越毗尼罪。是名比丘尼不得说比丘实罪非实罪。比丘得说比丘尼实罪。是名第三敬法。不先受者。比丘尼不先比丘受食房舍床褥。若有人请比丘尼食者。应语先请上尊众。若言我于彼无敬心正欲请诸比丘尼者。应语我亦不受。若言我先已曾请僧前食后食。已曾共人请。未曾请诸尼。若尔者应受。下至先与僧一抟食者。比丘尼后得种种好食无罪。若有人来言。我欲与尼作房。应语先与上尊众作。若言我于彼无敬心正欲与尼作。应语我亦不受。若言我先已曾与僧作房舍讲堂温室食堂门屋井屋厕屋洗脚处屋。曾共众人作。未曾为尼作。若尔者应受。下至先与僧一蚊厨。后比丘尼受大房无罪。若有人来与比丘尼床褥者。应语先与上尊众。若言我于彼无敬心。应语我亦不受。若言我先已曾与比丘僧床褥枕俱执卧具。未曾与尼。若尔者得受。下至先与比丘僧一小床。比丘尼后受好床褥无罪。若檀越未曾饭僧施床褥。比丘尼先受者。越敬法。是名比丘尼不先受食床褥。第四敬法竟。半月摩那埵者。若比丘尼越敬法。应二部众中半月行摩那埵。若犯十九僧伽婆尸沙。应二部众中半月行摩那埵。比丘尼众中行随顺法。应日日白二部僧。是名二部僧。是名比丘尼二部众中半月行摩那埵。第五敬法竟。半月问布萨求教诫者。比丘尼至布萨日。若一切尼僧。若遣使至比丘精舍礼塔已。至知识比丘所。与清净欲。作如是言。一切比丘尼僧和合礼比丘僧足。问布萨请教诫。如是三说。僧布萨时。诵戒比丘应作是说。大德僧听。今布萨尔所日已过。余尔所日在。佛声闻僧常所行事。诸大德不来。诸比丘说欲清净。谁与比丘尼取欲。取尼欲人应至上座前偏袒右肩合掌作如是言。比丘尼僧和合礼比丘僧足。与清净欲。问布萨请教诫。如是三说。诵戒人应问。谁教诫比丘尼。若先有教诫人。后人应问言。尼何日来何处教诫。先人应语。某日来在某处。若无教诫人者。先取尼清净欲。比丘应语尼言。姊妹。无有教诫人。当谨慎莫放逸。若比丘成就十二法。僧应羯磨作教诫人。何等十二。一持戒。二多闻不忘。三持律广略。四辩才能说。五学戒。六学定。七学慧。八能除恶邪。九梵行清净。十不污比丘尼净行。十一忍辱。十二满二十岁。若过是名成就十二法。僧应拜作教诫比丘尼人。羯磨者应作是说。大德僧听。某甲比丘十二法成就。若僧时到。僧拜某甲比丘教诫比丘尼。如是白。大德僧听。某甲比丘十二法成就。僧今拜某甲比丘教诫比丘尼。诸大德忍拜某比丘教诫比丘尼者默然。若不忍者便说是第一羯磨。第二第三亦如是说。僧已拜某比丘作教诫尼人竟。僧忍默然故。是事如是持。是比丘受羯磨已。应教诫比丘尼。教法者有八事。何等八。一非时。二非处。三过时。四时未至。五不和合。六眷属。七长句说法。八迎教诫。非时者。从日没至明相未出教诫。是名非时。若比丘非时教诫比丘尼者。波逸提。非处者。不得深猥处。不得露现处。当在不深不露处。若讲堂若树下。若比丘非处教诫比丘尼。越毗尼罪。是名非处。过时者。十四日十五日是名过时。时未至者。月一日若二日三日。是名时未至。应从四日至十三日往教诫。时未至教诫比丘尼者。越毗尼罪。是名时未至。不和合者。比丘尼僧不和合不应教诫。和合已然后教诫。教诫人到已应问。尼僧和合未。若言和合。应遣使呼言比丘尼来听教诫。若老病服药作衣钵事不得来者。应与欲。如是言。我某甲与教诫欲。如是三说。若比丘尼僧不和合教诫者。越毗尼罪。是名不和合。眷属者。不得偏教诫。应一切尼僧和合已然后教诫。是名眷属。长语说者。如尊者难陀长语教诫尼。应作是说。诸恶莫作诸善奉行自净其意是诸佛教。姊妹。此是教诫。欲听者便听。去者任意。若比丘长语教诫比丘尼者。越毗尼罪。是名长语说法。迎教诫人法者。若比丘尼城邑聚落住。闻教诫比丘某日来。若无供给人者。应倩诸年少比丘赍持华香幡盖往迎。若无者随其多少。下至合掌设敬代担衣钵。若一由延半由延。若一拘卢舍半拘卢舍。下至出城邑聚落外迎。若不迎者越毗尼罪。来已应劝化作前食后食非时浆尽心供养。及眷属七日勿令有乏。若无者出己衣钵中余持用供养。若复无者下至合掌恭敬。教诫尼法者。若阿毗昙。若毗尼。阿毗昙者。九部修多罗。毗尼者。波罗提木叉广略教诫人。若尼来时。不得低头而住。应观相威仪。若见油泽涂头庄眼着上色衣捣令光泽白带系腰。如是者应呵。若是年少者。应语。姊妹。汝今年少不学。待老当学耶。汝后当教诏弟子。汝不学者弟子亦当学汝作恶。是故汝应随顺学受经诵经。若有俗人者不得教。勿令前人起不善心。言沙门教敕妇。若尔不得教。应问余尼。此是谁共行弟子谁依止弟子。问已。应语彼和上。阿阇梨教呵。令随顺行法。勿令作非威仪事。比丘教诫比丘尼时应如女想。比丘尼于教诫人如佛想。是名半月问布萨求教诫。第六敬法竟。不依比丘不得住安居者。若亲里欲请比丘尼安居者。尼应语檀越先请上尊。若言我于彼无敬心正欲请尼。尼应语我亦不去。若为亲里欲去者。应自请比丘。到彼已应料理前食后食非时浆安居衣。勿令有乏。若亲里不与者。当自出己衣钵中余供给。若安居中比丘若死若罢道若余处去。尼不得去。三由延内有僧伽蓝者。应通结界。半月应往问布萨。若道路贼难恐怖畏夺命伤梵行。有此等诸难者。至后安居。末应往自恣。若故有众难者。当语亲里。为我请比丘来。来已供给所须前食后食及非时浆。勿令有乏。自恣已应还本处。若比丘尼欲住安居处。无比丘不得住安居。若住安居者。越敬法。是名无比丘住处比丘尼不得安居。第七敬法竟。比丘尼安居竟二部僧中受自恣者。比丘尼至自恣日受自恣已。明日清旦应一切往比丘僧所受自恣。尼僧中应羯磨。一尼能受自恣者。羯磨人应作是说。尼僧听。某甲比丘尼能为尼僧作自恣人。若僧时到僧羯磨某甲比丘尼为尼僧作自恣人。诸尼僧听。某甲比丘尼为尼僧作自恣人。僧忍默然故。是事如是持。比丘尼僧二众各和合者。应作是说。比丘尼僧和合比丘僧和合自恣说。若见闻疑罪。僧当语。我哀愍故。若见闻疑罪当如法除。第二第三亦如是说。若比丘僧和合。众多比丘尼者应作是说。众多比丘尼比丘僧和合自恣说。若见闻疑罪。僧当语。我哀愍故若知若见当如法除。第二第三亦如是说。若比丘僧和合。一比丘尼者应作是说。我比丘尼比丘僧和合自恣说。若见闻疑罪。僧当语我哀愍故若知若见当如法除。第二第三亦如是说。若众多比丘比丘尼僧和合者。应作是说。比丘尼僧和合诸大德自恣说。若见闻疑罪。诸大德当语。我哀愍故若知若见当如法除。第二第三亦如是说。若众多比丘众多比丘尼者应作是说。众多比丘尼诸大德自恣说。乃至第二第三亦如是说。一比丘乃至一比丘尼者应作是说。我比丘尼大德自恣说。若见闻疑罪。当语我哀愍故若知若见当如法除。第二第三亦如是说。比丘尼安居竟。应如是二众中受自恣。若比丘尼十六日不诣比丘僧受自恣。至十七日往受自恣者。越敬法。是名比丘尼第八敬法

摩诃僧祇律卷第三十摩诃僧祇律卷第三十一

        东晋天竺三藏佛陀跋陀罗共法显译

    明杂跋渠法之九

内宿内煮自煮者。佛住旷野精舍。诸天世人之所供养。尔时僧院内作食厨。潘汁荡器恶水流出巷中。为世人所嫌。云何沙门释子住处食厨不别。诸比丘以是因缘。往白世尊。佛告诸比丘汝等正应为世人所嫌。从今日不听内作净厨潘汁流外。作净厨法不应东方北方作净厨应南方西方作。若比丘内作净厨潘汁流外者。越比尼罪

复次佛俱娑罗国游行。至呵帝钦婆罗门聚落。如上粥缘中广说。乃至不听内宿内煮。复次佛俱萨罗国游行。至固石婆罗门聚落。时有剃发师摩诃罗父子出家。闻佛来欲作粥。如上粥缘中广说乃至不听内宿内煮自煮

复次佛鸯求多罗国游行。尔时支尼耶螺发梵志。闻世尊来作僧坊净厨。遣人请佛。佛告优波离。汝于先去为僧处分受食厨。勿令初夜过。若过者即名僧住处不得作。时优波离白佛言。世尊。得一覆别隔不。佛言得。复问得通隔别覆不。佛言得。复问得通覆通隔不。佛言得。复问得别隔别覆不。佛言得。复问得一边二边三边一切尽得不。佛言得。隔道得不。佛言得。得阁上阁下不。佛言得。或有树根在净地。枝叶在不净地。或有树根在不净地。枝叶在净地。或有树根枝叶俱在不净地。或有树根枝叶俱在净地。一覆别隔者。僧得受作净屋。如是乃至别隔别覆僧得受作净屋。一边二边三边一切尽得作净屋。隔道者。道两边净中间不净。若置酥[土*瓦]等在中间者。应穿两边流入净地者听取。若谷麦豆囊横置中间者。得解两头取。若萝卜葱甘蔗在道中者。得截取净者。阁上阁下者。若阁上若阁下得受作净屋。树根在净地枝叶在不净地者。树根在净地生。枝叶荫不净地。若果落地者应时取内净屋中。若不取至初夜过者。即名不净。树根在不净地枝叶在净地者。树在不净地生。枝叶荫净地。若果落地即名为净。随时欲取便取。二俱不净者。树不净地生。枝叶亦荫不净地。果落应时取内净屋中。若不时取至初夜过者。即名不净。二俱净者。树净地生。枝叶亦荫净地。果落者。即名为净。随时欲取便取。是名二俱净。若不净地生萝卜葱菜若取应。时取。内置净屋中。若不时取。至初夜若过。即名不净若贼来偷果菜。觉已恐怖舍果菜而去。应即取内净屋中。若言明日当取。至初夜过者。即名不净。若不觉弃时。早晚即见时。应取内净屋中。若不取至初夜过者。即名不净。若不净地中生若瓜瓠者。擿取应时内净屋中若不内过初夜即名不净。若僧住处有檀越施僧谷。泻着不净地中。应时取着净屋中。若不取至初夜过者。即名不净。若白衣持饼糗粮食来寄宿。明日去。时与比丘者。即名净。若比丘作是念。明日去必当与我。若与者即名不净。持果菜来宿亦如是。若运致谷米。净屋仓满已。若着讲堂中温室中若井屋若薪屋中庭若非净地者。初中后夜随时应徙。若不徙至初夜过者。即名不净。若欲作新住处者。营事比丘应以绳量度作分齐。尔许作僧净屋。尔许作僧住处。应作是说。此中尔许作僧净屋。受若不受者。至初夜过即名不净。随事定净屋。净屋定。如是住处温室讲堂门屋浴室薪屋井屋。井屋定。若檀越言莫预分处。须待成设饭施僧已。僧随意分处。成已应作是说。下阁中阁上阁僧净屋受(受已即名净亦得住)若复不受。国土乱时王未立。尔时得受。若复一王逝。一王众人未举。尔时得受。

若复不受者住处聚落停废二年得受。是中或有聚落停废。非住处停废。或住处停废。非聚落停废。或聚落停废。住处亦停废或非聚落停废。非住处停废。是中不受即名不净。若停可食物。是名内宿内煮。自煮者。比丘不得自煮食。若病应使净人煮。若无净人者。有净铜器不受腻者。应净洗自炊令沸。使净人知着米。着米已比丘不得自燃。应使净人燃。沸已净人欲去。得受取自煮令熟。当慎莫令不受物落中。如是煮肉令脸菜令萎。受已得自煮令熟。下至煮姜汤亦不得自煮使净人煮。若乞食。食冷得自温无罪。若净人病。应使他净人煮粥与。若无净人者。净米已得自煮。若有长粥不得自食。是名内宿内煮自煮

受生肉者佛住旷野。尔时六群比丘持肉段生鱼。为世人所嫌。云何沙门不能乞食。持肉段生鱼而行。此坏败人何道之有。诸比丘以是因缘往白世尊。佛言。呼六群比丘来。来已佛问比丘。汝实尔不。答言实尔世尊。佛告诸比丘。从今日后。不听受生肉。若比丘病得使净人知煮脸已。受取得自煮令熟。若比丘林中经行坐禅。若见树下有死獐鹿残。若须者不得自取。当使净人知。若自取者不得自食。应与园民若与沙弥。若见鹰残亦如是。若比丘乞食时得燥脯火上燎。已得受。有众生名俱耶。无肠肚。吞肉段还完出。若须者得受。不听受生谷。谷者。白米谷赤米谷。[麩-夫+黃]麦小麦悉不听受。若生痈痤疖。须小麦涂者。应使净人作净已得自取。研破用涂之不听受。若净屋中有谷[麥*弋]麦[麥*弋]。若须者得自取不听受。若蒙具豆摩沙豆大豆小豆如是比。若须者得受。是名受生谷

自取更受皮净者。佛住舍卫城。时王波斯匿有庵拔罗园。时果茂盛。王问园民。诸比丘颇来食果不。园民答言。大王不请何由来食。王言。汝可往请比丘来食果。即往诣僧所。头面礼足胡跪合掌白言。王请僧食果。诸比丘即往就园食果。狼藉弃地或复持还。于是园民不得送果。王问园民。何故不送果。园民即以上事具白王。王闻已其心不悦。作是言。诸比丘但当食果。何故弃地复持而去与谁。诸比丘以是因缘往白世尊。佛言呼是比丘来。来已佛具问上事。汝实尔不答言实尔。佛问比丘。汝但当食果。何故弃地复持还为。答言世尊。我持来受已更食。佛言。汝云何自取已后受更食。佛言。从今日不听食庵拔罗果

复次佛住王舍城耆旧童子庵拔罗园。时耆旧童子问园民言。诸比丘食庵拔罗果不。答言。世尊不听。时耆旧童子闻是语已。往到世尊所。头面礼足却住一面白佛言。世尊。庵拔罗是时果。愿世尊听诸比丘食。佛言。从今日听净果皮食。时诸比丘使净人尽剥果皮而食。净人嫌言。合皮可食。何故使我尽剥皮为。诸比丘以是因缘往白世尊。佛言。不须尽去皮。当爪净听食。不听自取后受食。应先使净人爪净然后受食。若比丘园林中行。见落果在地。须者应使净人取。若自取者不得自食。应与园民若沙弥若果熟落地伤破。即名爪净。应受取却核得食。若鸟啄若器中伤破。下至如蚊脚。即名皮净。却核得食。若欲食核者。火净已听食。若皮净不火净食核者。波夜提。若火净不皮净。皮核俱得食。若不火净不皮净食者。一波夜提一越比尼。若俱作无罪。是名自取后受皮净

比尼断当事障碍非障碍

比丘尼内宿内煮并自煮

受生肉并谷自取后更受

皮净并火净第六跋磲竟

重物者。佛住舍卫城。尔时诸比丘卖僧床褥。或借人或私受用。诸比丘以是因缘往白世尊。佛言。呼是比丘来。来已佛问比丘。汝实尔不。答言实尔世尊。佛言。从今日不听比丘卖僧床褥借人私受用。设一切僧集亦不听卖借人私用。若卖借人私用。越比尼罪。云何名重物。床褥铁器瓦器木器竹器。如盗戒中广说。是名重物檀越施僧床褥俱襵氍[叟*毛]杭[疊*毛]腰带刀子鉹伞盖扇革屣针筒剪爪刀澡罐。是中床褥俱襵杭氍[叟*毛]如是重物。应入四方僧。其余轻物应分。若檀越言一切尽分。应从檀越意分。若言一切施四方僧者。不应分。若比丘道路行。俗人见比丘心生欢喜。持种种杂物布施比丘。是中有重物。应与随近精舍。当语檀越持是床褥与某精舍比丘。若言我已决意施。复用问我为。比丘言。亦可置此间供给客僧得其功德。复言不能我已决意。应语。长寿此是重物难致。可此间贸取直彼间还作不。若言任尊者意。得贸取直至彼住处。床直买床褥直贸褥。如是一切随直贸易。若言一切尽分者。应随施主意分。若言一切施四方僧者。不应分。请有二种。一僧次二私请。彼间得。种种杂施。僧次得物入僧。私请得物自入已。若床褥多釜镬少。当语檀越令知已。得转床褥作釜镬。若釜镬多贸易床褥亦如是。若有破器得融作大者是名重物。无常物者。佛住旷野。尔时尊者。阿若憍陈如在巨摩帝住。时有放牧人名渠尼。妇名尸婆离。憍陈如时到着衣持钵入聚落乞食。得已常到放牧人家食。时妇人信心欢喜。常供给乳酪生酥熟酥。饮已还住处。便作是念。用是苦器久在世为。我厌患此身。便持衣钵着一处。在林树下以头枕象团右胁着地。心不乱即入无余涅槃。尸婆离知时节应来。即敷床座扫地办乳酪浆待。时过不来。时尸婆离便作是念。阿阇梨常日日来。今何故不来。将不病耶。不为恶虫所伤。即往看之。见树下卧作是念。阿阇梨故当眠。默然立听。不闻喘息。以手摩心。身体已冷。便言。奇哉已无常。我当供养舍利。即归语夫。取斧折好薪[卄/積]置一处。即便阇维舍利。在一面立看。见有四鸟种种异色从四方来。鸟身即自变白而去。时夫渠尼苦住不乐作是念。是比丘衣钵当输王。王法难了恐复更索余物。即持诣王白言。此憍陈如比丘无常。有是衣钵输王。王即评此衣钵价直五钱。官断言。此沙门无常。衣钵还归比丘。即持还白僧言。尊者阿若憍陈如无常。有此衣钵。诸比丘见已识彼衣钵。即问言。颇见异事不。答言见。我阇维时。见有四鸟有种种色。乃至比丘以是因缘往白世尊。是事云何。佛告比丘。此是四魔天。来欲观其识神。不见已变白而去。诸比丘白佛言。此衣钵应属谁。佛言应属僧

复次佛住舍卫城。时有病比丘。语比丘言。看我当与长老衣钵。时病比丘无常。诸比丘僧集欲分彼衣钵。看病比丘言。是病比丘存在时语我言。看我当与汝衣钵。诸比丘以是因缘往白世尊。佛言已与未。答言未佛言。不与已无常。得越比丘罪。彼不应得

复次佛住舍卫城。时有病比丘。语比丘言。看我当与长老衣钵。即便与。得已不作净。还置病人边。时病比丘无常。乃至诸比丘以是因缘往白世尊。是事云何。佛言为作净不作净答言不作。佛言不应得

复次佛住舍卫城。时有病比丘。语比丘言。看我当与长老衣钵。即便与。得已作净。还置病比丘边。乃至佛问作净不。答言作。佛言应得

复次佛住舍卫城。有沙弥无常。诸比丘问佛。此衣钵物应属谁。佛言属和上。复次看病比丘作是恨言。我看病不避寒暑。执众苦事求索汤药。乃至除大小行器。其实如是。是谁应得。言众僧得耶。诸比丘以是因缘。往白世尊。佛言。看病比丘甚苦。应与三衣钵盂及所受残药

时尊者优波离知时而问世尊。病比丘得嘱与人物不。佛言得。复问得嘱与医药不。佛言得。若嘱言我不差当与。若差即名舍。若嘱言我向彼聚落。若不到当与。若到者即名舍。若嘱言我行去。若无常者当与。还者即名舍。若决定嘱言。我若死若活。其心决定与者应与。若嘱与众多者。最后人应得。若与众多人。在前者应得。若比丘无常若般泥洹。不应便闭其户。彼若有共行弟子依止弟子持戒可信者。得与户钩。若不可信者。当持户钩与僧知事人已。供养舍利料理竟然后出彼衣物。若有共行依止弟子持戒可信者使出。若不可信。应使知事人出。若比丘作是言。我此中亦有衣钵者。当观前人持戒。可信者应与。不可信者不应与。若有可信人证明者。应先与。然后僧受。受有三种。羯磨受。分分受。贸易分受。羯磨受者。羯磨人应作是说。大德僧听。某甲比丘无常若般泥洹。所有衣钵及余杂物。应现前僧分。若僧时到。僧现。前羯磨与某甲比丘受。白如是

大德。僧听。某甲比丘无常若般泥洹。所有衣钵及余杂物。现前僧应分。僧今现前持是衣钵及余杂物。与某甲比丘受。诸大德忍。持是衣钵及余杂物与某甲比丘受。忍者僧默然。若不忍者便说。僧已忍持是衣钵及余杂物与某甲比丘受竟。僧忍默然故。是事如是持。是名羯磨受。分分受者。作分已唱言。各各自取分。是名分分受贸易分受者。互相贸易。是名贸易分受。若四比丘聚落中住。一比丘无常者。三比丘应受。应作是说。诸长老。某甲比丘无常若泥洹。有是衣钵及余杂物。现前僧应分。此处无僧。我等现前应分。若三比丘住。一比丘无常者。二比丘应受。应作是说。乃至此处无僧。我现前应得。若二比丘共住。一比丘无常者。一比丘得受。应心念口言。某甲比丘无常若涅槃。有是衣钵。现前僧应分。此处无僧。我现前应得。若欲与看病比丘物者。应行舍罗知人多少。知已应与亡人所受持衣钵及所受残药。羯磨者应作是说。大德僧听。某甲比丘无常若涅槃。所有衣钵现前僧应分。若僧时到。僧持是衣钵及所受残药。与看病比丘某甲。如是白。白一羯磨。乃至僧已与看病比丘某甲衣钵及余残药竟。僧忍默然故。是事如是持。看病人云何应得不应得。不应得者。暂作不应得。差作不应得。乐福德作不应得。邪命作不应得。暂作者。暂作不作是名暂作。差作者。僧次差是名差作。乐福德作者。自为福德故看是名乐福德。邪命者。希望故看病是名邪命。应得者。佛言。欲饶益故。下至然一灯炷。欲令病人除差应得。作羯磨已应量影。若有客比丘来者。应知在羯磨前在羯磨后。或值死不值羯磨。有值羯磨不值死。或有值死值羯磨或不值死不值羯磨。是中值羯磨不值死值死值羯磨者应得。是中值死不值羯磨不值死不值羯磨者不应得。若为病人求医药。若为塔事僧事去应与。是名无常物法

痴法者。佛住王舍城。尔时长老劫宾那。有二共行弟子。一名难提。二名钵遮难提。痴病。有时来有时不来。破僧羯磨。诸比丘以是因缘往白世尊。佛语诸比丘。难提钵遮难提痴病。有时来有时不来破僧羯磨者。僧应与作痴羯磨。羯磨人应作是说。大德僧听。难提钵遮难提痴病。有时来有时不来破僧羯磨。若僧时到。僧与难提钵遮难提痴病羯磨。白如是。大德僧听。难提钵遮难提痴病。有时来有时不来破僧羯磨。僧今与难提钵遮难提痴病羯磨。诸大德忍与难提钵遮难提痴病羯磨者默然。若不忍者便说。是第一羯磨。第二第三亦如是说。僧已与难提钵遮难提痴病羯磨竟。僧忍默然故。是事如是持。作是羯磨已。若来若不来不破羯磨。若痴病差得本心。即名舍。是名痴羯磨

见不欲者。佛住舍卫城。尔时瞻波比丘。斗诤相言同止不和。一比丘举一比丘。二比丘举二比丘。众多比丘举众多比丘。诸比丘以是因缘往白世尊。佛言。从今日听作见不欲。见不欲者。若僧中作非法羯磨事。若有力者应遮言。诸长老是非法非比尼不应作。若前人凶恶力势。恐有夺命伤梵行者。应作见不欲。作是说。此非法羯磨。我不忍与见不欲。如是三说。作见不欲时。不得趣人边作。应同意人边作。不得众作见不欲。得二人三人作。余者当与如法欲已舍去。若僧中非法断事。不遮不与欲。不作见不欲。越比尼罪。若作是念。随其业行如火烧屋。但自救身得护心相应无罪。是名见不欲

破信施者。佛住舍卫城。尔时鹿长者次请僧食时优波难陀次到其家。长者问言。欲此间食欲持去。答言欲持去。即取其钵盛满中种种饮食。优波难陀得食已。即持到淫女家。问言。欲得食不。答言欲得。取汝器来。即与饮食罗列槃上。复更乞去。时长者子食已往淫女家。女言。大家郎欲食不。答言取来。即持槃上食与。见已便识。问言。汝何处得此食。女言大家郎但食。用问为。诸年少边得。不尔。我欲知处问不止。便言阿阇梨优波难陀见与。长者子嫌言。我以众僧为良福田。而优波难陀反以淫女为良福田

复次佛住王舍城。时有无畏萨薄主。施僧两张细[疊*毛]。时优波难陀僧中知得已。即持与淫女。淫女得已便被着入市肆。时无畏萨薄主见已便识。问言。汝何处得此[疊*毛]。答言。大家郎何故问耶。诸年少边得。复问不尔我欲知之问不止。便言。尊者优波难陀见与。时萨薄主嫌言。我以众僧为良福田。而优波难陀反以淫女为良福田。诸比丘闻已。以是因缘往白世尊。佛言。呼优波难陀来。来已。佛问优波难陀。汝实尔不。答言实尔。佛言。此是恶事。汝云何坏信施物。从今日不听坏信施物。信者。信心与欢喜与。施者有八种。时食夜分乃至净不净。破者。欲心与淫女寡妇大童女不能男恶名比丘尼恶名沙弥尼。下至欲心与畜生。得越比尼罪。有人僧中乞食得与一抟。若人多者等分与。若于前人有欲心者不应与。若父母贫苦无信心者得少多与。若有信心者得自恣与。有二种应与。益者损者。益者。若檀越若优婆塞。作塔事僧事应与损者若贼若王。若凶恶人不与者。能作不饶益事。此人应与。是名破信施

革屣法者。佛住王舍城。时难陀优波难陀。着金革屣行。为世人所嫌。云何沙门释子如王大臣贵胜人。着金革屣。诸比丘以是因缘往白世尊。乃至佛言。从今日后。不听着金革屣。复次世人吉祥日时。六群比丘有着种种异色革屣。有着一重革屣者。共期游观。为世人所嫌。云何沙门释子着种种革屣。如王大臣见着恶者。复作是言。云何沙门释子如下贱人。着一重革屣。此坏败人何道之有。诸比丘以是因缘。往白世尊。佛言。从今日不听着一重革屣

复次佛住王舍城尸陀林。尔时。世尊身少不和。耆旧童子往至佛所。头面礼足白佛言。世尊。闻世尊不和。可服下药。世尊虽不须。为众生故愿受此药。使来世众生开视法明。病者受药施者得福。尔时世尊默然而受。耆旧复念。不可令世尊如常人法服药。当以药熏青莲华授与世尊。世尊三嗅药势。十八行下。下已光相不悦。尔时阿难语尊者大目连言。世尊服药何处有随病食。时目连即观见瞻波国。恕奴二十亿子日煮五百味食。是时目连。即以神力到其前立。时二十亿子。见尊者目连威仪神德。心怀踊跃叹未曾有。目连尔时即说偈言

  天尊甚奇妙　　无量功德聚
  身中小不和　　宜须随病食
  汝今得善利　　当获大果报
  声闻诸弟子　　仰比于世尊
  喻如须弥山　　得一芥子分

时长者子闻说此偈。心大欢喜。叹言善哉。今得斯利。即办肴膳请目连住。食时目连作是念。我为世尊索随病食。不宜先食。即便受食置虚空中。然后自食。二十亿童子语尊者目连言。我欲令世尊先食然后我食。云何得知。目连言。此食器须臾当还。自知食讫。尔时目连屈申臂顷。到世尊所奉食世尊。世尊食已器乘空而还。时恕奴二十亿童子遥见器还。起迎顶戴而受。时瓶沙王来问讯世尊。闻食香问言。此何香。答言食香。佛语大王。欲食如来残食不。白言欲食世尊。我大得善利。得如来残食。食已白佛言。世尊。我生王家已来。未曾得如是食。世尊。此为是天食龙食郁单越食鬼神食耶。佛言。此非天食乃至非。鬼神食也。此是王土恕奴二十亿童子家常所食耳。世尊即为王说恕奴二十亿童子脚下金色毛长四寸福德如是。王闻已即欲往看。臣白王言。云何此是王之民。应当命来不宜自往。即遣人往唤。语父母言王欲见童子。父母言。王唤正当欲方便罚我钱耳。宁输千万不能令子诣王。即连车载金银宝物送诣王所。白王言。童子软弱。不堪自致。所有珍宝今送献王。王言。我自有金银宝物。不须是为。但欲见童子身耳。使还白王言。童子是极乐人。柔弱不堪车乘。王言。若尔者装船载来。若至不通船处。凿地作渠。以芥子填满牵来。即便牵来至山口。童子柔弱以衣褥敷地蹑上而来。遥见世尊在露地坐。见已即却衣褥蹑地而来。世尊见已而发微笑。诸比丘白佛言。世尊何因而笑。佛告诸比丘。汝见此童子不。答言见。佛言此童子从九十一劫已来。足未曾蹑地。今见如来恭敬故非是福德尽也。前至佛所。头面礼足却坐一面。佛为随顺说法示教利喜。得法眼净。佛教童子。若王来入者。当下地跏趺坐现脚。时王来入。童子即下地跏趺现脚而坐。时王侍者即拔剑欲向。王即呵之。时童子见已心生恐畏。即白王言。听我出家。王言欲何道出家耶。答言。欲佛法出家。王即遣使语其父母听出家不。父母听已即求佛出家受具足。诸比丘白佛言。是童子有何因缘。九十一劫足不蹈地。佛告诸比丘。过去世时九十一劫。有佛名毗钵施如来应供正遍知。出现于世。时有长者子九十人。请佛及僧八十千众。三月安居。一人供一日。是长者子最后设供。加以白[疊*毛]敷地供养众僧。因是果报九十一劫生天人中未曾蹈地。尔时长者子即今恕奴二十亿童子是也。童子出家已在尸陀林中经行不倦。脚底伤破血出在地。佛见已知而故问。比丘此谁经行处血出乃至如是。比丘答言。是恕奴二十亿童子经行处。佛告诸比丘。是恕奴二十亿童子设使精进经行。须弥山碎如粉尘。不能得道。况复伤皮。时恕奴二十亿童子闻是语已。至一空静处结跏趺坐作是思惟。佛声闻弟子中。精进不懈无过于我。世尊方言不能得道。不如舍戒还家作诸功德供养佛及比丘僧。佛知其心。即以神足乘虚而来在其前坐。佛语比丘。我今问汝。随汝意答。汝本能弹琴不。答言能弹。弦急时得成音不。不也世尊。复问。弦缓时得成音不。不也世尊。复问比丘。弦不急不缓得成音不。答言尔。佛告比丘。精进太急心生结使。精进太缓心生结使。不急不缓心渟鉴彻一切。如增一线经中广说。佛告比丘。汝信心舍二十亿出家。云何于正法中起增上慢自生苦恼。佛告比丘。我因汝听诸比丘着革屣。恕奴二十亿童子白佛言。但听诸比丘着革屣。我渐渐习行以当着革屣。佛言。从今以后。听着一重革屣。时阿难邠低姊。闻世尊听诸比丘着一重革屣持五百緉革屣到世尊所。头面礼佛足却住一面白佛言。唯愿世尊。受此革屣。佛即为说偈咒愿

  身口意离恶　　清净梵行人
  革屣布施者　　人天中受乐
  金地种种报　　庄严诸宫殿
  得如意神足　　清净无障碍
  施少得大利　　清净福田故
  智者愿清净　　能得福田果

复次佛住舍卫城。尔时世尊五日一按行诸比丘房。见诸革屣狼藉在地。知而故问。比丘。此何等革屣。狼藉乃尔。比丘答言世尊。此革屣破。畏两重故不敢补。佛言听补。复次佛住舍卫城。时南方比丘来礼拜世尊。中路革屣破故脚底穿坏。曳脚而行顶礼佛足。佛知而故问。何故曳脚而行。答言世尊。我着一重革屣中路破。不敢着两重。是故脚破。佛言。从今日听作尼目呵革屣法。着福罗不听遮前应遮后。革屣法不听羝羊角白羊角金革屣真珠革屣琉璃水精马瑙。种种色革屣不听着。若得新重革屣者不听着。应使净人知着。下至五六步然后着。若得著者越比尼罪。是名革屣法

屐法者。佛住王舍城耆旧童子庵拔罗园。佛为阿阇世王竟夜说沙门果经。时优波难陀听久疲极还自房宿。至后夜起着屐而来。唧唧作声。象马闻之竞惊而鸣。时王闻已恐怖即还入城。诸比丘以是因缘往白世尊。佛言。呼优波难陀来。来已佛问优波难陀。汝实尔不。答言实尔。佛言。从今日后。不听着屐。复次佛住王舍城。时比丘在天。帝释石室边坐禅。有比丘着屐在前经行。时坐禅比丘闻声已心不得定。诸比丘以是因缘往白世尊。乃至佛言。从今日后不听着屐。屐者。金屐银屐摩尼屐牙屐木屐皮屐马尾屐麻屐钦婆罗屐綖屐芒草屐树皮屐。如是比。一切屐不听着。脚穿屐时越比尼罪若欲洗脚得横屐蹑上不犯。比丘着革屐时应牵根上。若不牵上者越比尼心悔。若着无根者得越比尼罪。是名屐法。浴法者。佛住舍卫城时六群比丘至阿脂罗河上洗浴。用揩石揩身。为世人所嫌。云何沙门释子用揩石揩身如王家斗人力士此坏。败人何道之有诸比丘以是因缘往白世尊乃至佛言从今已后不听用揩石揩身。揩石者木作若石若塼。如是比皆不听用。若水中有柱亦不得就揩身。若浴时当使一人揩。揩时不得俱举两臂。应一臂自遮次第而揩。若无人者当自揩。不得立浴如俗人法。应坐。亦应次第洗手臂。若身体有垢腻者。不得以拳揩。应舒手揩。若用揩石洗浴者。越比尼罪。是名浴法

屑末者。佛住舍卫城。时难陀优波难陀。持种种香屑来诣阿脂罗河上浴。时有外道弟子。见已作是念。我等当共扰沙门优婆塞去。即往其所。作如是言。谁师少欲知足。时优婆塞言。我师少欲知足。外道弟子复言。我师少欲知足。优婆塞言。汝师无惭无愧啖酒糟驴。我师少欲知足有惭愧。外道弟子言。若汝师少欲知足者。当共赌物。答言。欲赌何物。外道答言。欲赌五百旧钱。优婆塞言。可尔。便共议言。当作何等试之。即作种种香屑末已。欲先至谁师所。外道弟子言。先至我师。即先遣人往语己师。我持香屑末往可现少欲相慎莫受。寻即持往语言。诸师哀愍故愿受香屑。答言。我出家人非王子大臣。用是香屑为。不受已。复持诣祇洹精舍。作如是言。诸师哀愍我故受是香屑。优婆塞质直先不语故。比丘即打揵椎。集僧欲分香屑。有不来者。有弟子为迎分言。与我和上阿阇梨迎分。如是竞索语声高大。外道弟子见已拍手大笑。我得子便今日得胜。时优婆塞惭愧无言。往至佛所头面礼足却住一面。具说上事白佛言。世尊我不惜钱。但以外道得胜是故惭愧。佛即为优婆塞说法示教利喜。发喜心已头面礼足而退。世尊往众多比丘所。敷尼师檀而坐。具以上事为诸比丘说。佛告诸比丘。从今日不听用香屑。复次佛住王舍城。如来以五事利益故。五日一行诸比丘房。见比丘癣病。佛知而故问。比丘。汝调适安乐住不。答言世尊。我病癣[癈-(弓*殳)+虫]。得香屑末洗浴便差。世尊制戒不得用香屑是故苦住。佛言。从今日听病比丘用香屑。香屑者。于尸屑马耳屑七色屑栴檀屑俱哆屑庵拔罗屑阎浮尸利屑阿淳屑伽比罗屑。如是比一切不听。若比丘病癣[癈-(弓*殳)+虫]。须屑末涂浴差者得用无罪。听用迦罗屑摩沙屑摩瘦罗屑沙坻屑涂土。是名末屑法

杖络囊法者。佛住王舍城。尔时六群比丘难陀优波难陀。持宝络囊盛钵。复有持黑绳络囊以杖串肩上而行为世人所嫌。云何沙门释子如王大臣。持宝络囊盛钵肩上而行。有见恶者复言。云何沙门释子如下贱使人。持黑络囊盛钵串肩上而行。此坏败人何道之有。时诸比丘以是因缘往白世尊。乃至佛言。从今已后。不听畜杖络囊。复次佛住舍卫城。如来五日一行诸比丘房。见比丘痏手。知而故问。比丘。调适安乐住不。答言世尊。我痏手故破钵。世尊复制不听畜杖络囊。是故不乐。佛言。从今日后。病比丘听从僧乞畜杖络囊。僧应与作羯磨。乞法者。偏袒右肩胡跪合掌作如是言。大德僧听。我某甲痏手故破钵。今从僧乞畜杖络囊羯磨。唯愿僧与我羯磨。第二第三亦如是说。羯磨人应作是说。大德僧听。某甲比丘痏手故破钵已从僧乞畜杖络囊羯磨。若僧时到。僧与某甲比丘畜杖络囊羯磨。如是白。白一羯磨。乃至僧已与某甲比丘畜杖络囊羯磨竟。僧忍默然故是事如是持。作羯磨已欲行时。手捉杖及络囊。不得举着肩上而行。若持杖者得越比尼心悔。持络囊者。亦越比尼心悔。若持杖络囊及钵者。越比尼罪。若道路行时。得系漉水囊杖头手捉而行。不听着肩上。若不作羯磨持杖者。越比尼罪。持络囊亦越比尼。若持杖络囊者。得二越比尼罪。是名持杖络囊法

  重物亡人衣　　痴狂见不欲
  坏信施革屣　　着屐揩身石
  香屑杖络囊　　第七跋渠竟

蒜法者。佛住王舍城。尔时弥只居士请僧食蒜。时六群比丘诣园食蒜。狼藉弃地。复持还归。时居士按行蒜园。见已即问园民。何故如是。园民即具说上事。居士言。比丘但当食。何故弃地如是。复持去与谁。诸比丘以是因缘往白世尊。乃至佛告诸比丘。从今日不听食蒜。复次佛住王舍城。尔时世尊为大众说法。时有比丘食蒜在下风而坐。畏熏诸梵行人。佛知而故问。此是何等比丘。独坐一处如斗诤人。诸比丘白佛言。世尊。是比丘食蒜。畏熏梵行人故在下风独住。佛语诸比丘。当知是比丘若不啖蒜时。当欲得失如是甘露法不。答言不也。佛言。是比丘以食蒜故。失如是不死之法。佛言。从今已后不听食蒜

复次佛住迦维罗卫释氏尼拘律精舍。如来五日一行诸比丘房。见比丘病羸瘦瘀黄。佛知而故问。比丘调适安隐住不。答言世尊。我病不调。本俗人时食蒜便差。世尊制不听食蒜。是故不乐。佛言。从今日听病比丘食蒜。应随顺行。蒜者。若种生若山蒜。如是比蒜及余一切。若生若熟若叶若皮悉不得食。若痈肿若癣疮得用蒜涂。蒜涂已不得于众中住。应在屏处。差已当净洗浴还入僧中。病时医言。长老。此病比丘服蒜当差。若不服不差。若更无余方治者听服。服已应七日行随顺法。在一边小房中。不得卧僧床褥。不得上僧大小便处行。不得在僧洗脚处洗脚。不得入温室讲堂食屋。不得受僧次差会。不得入僧中食及禅坊。不得入说法布萨僧中。若比丘集处一切不得往。不应绕塔。若塔在露地者。得下风遥礼。七日行随顺法已。至八日。澡浴浣衣熏已得入僧中。若比丘不病食蒜病食蒜。不行随顺法。二俱越比尼罪。是名蒜法。覆钵法者。佛住舍卫城。时城内法预优婆塞。常请僧次食。比丘到已诘问其义。能解释者。便大欢喜手自与种种食。若不能答者。即便毁呰使下人与粗食。以是故僧次上座应去不去。皆言下过。乃至年少尽不能去。于是便高声大语。佛知而故问。何故高声大语。答言世尊。法预优婆塞常请僧次食。乃至应去不去。因是故高声大语。佛告诸比丘。法预优婆塞轻慢诸比丘僧。应作覆钵羯磨。优婆塞有八事。僧应与作覆钵羯磨。何等为八。现在前诽谤比丘。现前诃责比丘。作如是言。汝是恶行人。现前嗔恚轻骂比丘。断比丘利养。不乐与比丘共事。骂佛骂法骂僧。是名八事。僧应作覆钵羯磨。羯磨者应作是说。大德僧听。是法预优婆塞轻慢比丘。若僧时到。僧。法预优婆塞轻慢比丘与作覆钵羯磨。白如是。白三羯磨。乃至僧已与法预优婆塞轻慢比丘作覆钵羯磨竟。僧忍默然故。是事如是持。法预优婆塞常饭比丘已。然后自食。其日待比丘。时过不来。便往佛所头面礼足却住一面白佛言。世尊。诸比丘何故不来食。佛言。汝轻慢诸比丘僧。欲饶益故与汝作覆钵羯磨。尔时去佛不远有一罗汉。佛语优婆塞。汝往问是比丘。云何名盐。盐有几种。即往到。和南阿阇梨。比丘言善来。便问言。尊者云何名盐盐有几种。比丘言。我已知。汝是法预优婆塞。轻慢比丘僧。已与汝作覆钵羯磨。故不足耶。我此间乐住复来恼我。盐正是盐。闻比丘语已心怀惘然。还到佛所佛知而故问。汝问盐义得悉意不答言世尊。是比丘少闻未从师学。问盐故言盐。时去佛不远复有一法师比丘。名弗絺卢。佛语法预。汝往问彼比丘盐义。即往其所言。阿阇梨和南。答言善来檀越。即语令坐。虽未问义且闻命坐。便大欢喜寻即就坐。问言尊者盐有何义。比丘答言。此是好问。今当为汝解盐义者。二种味性。味者。如海水同一碱味。性者。黑盐赤盐辛头盐味拔遮盐毗揽盐迦遮盐私多盐比迦盐。略说二种。若生若煮是名盐。闻已心中喜悦来至佛所。头面礼足却住一面白佛言。世尊。是比丘善解分别广略盐义。顺逆能答。佛言。此是凡夫。于我法中未得法味。前比丘者是阿罗汉。而汝憍慢不识真伪。长夜作不饶益事。于是法预闻佛语已即生怖惧。头面礼足白佛言。世尊。我今忏悔唯愿。世尊哀愍我故。令诸比丘从今已后还受我供养。佛言。汝还去沐浴着新衣。与眷属相随往到僧中。乞舍覆钵羯磨。僧当与汝舍。法预如教还归沐浴着新净衣来入僧中。胡跪合掌作如是言。大德僧忆念。我优婆塞法预。轻慢比丘僧。欲饶益故作覆钵羯磨。我今见过行随顺法心已柔软。唯愿僧哀愍故。与我舍覆钵羯磨。如是三乞已。僧应语令在界内。应安法预置眼见耳不闻处。现前僧与作羯磨。非徒众现前。羯磨者应作是说。大德僧听。是法预优婆塞轻慢比丘僧。欲饶益故先与作覆钵羯磨。今日见过行随顺心柔软已。从僧乞舍覆钵羯磨。若僧时到。僧与法预优婆塞舍覆钵羯磨。如是白。白三羯磨。乃至僧已与法预优婆塞舍覆钵羯磨竟。僧忍默然故。是事如是持。若僧与作覆钵羯磨已。比丘比丘尼式叉摩尼沙弥沙弥尼优婆塞优婆夷尽不听往。应持袈裟系其门上。应巷中唱言。某甲家作覆钵羯磨。若有客比丘来者。应语言。某甲家作覆钵羯磨不应往。作覆钵羯磨时不得越趣作。若彼言沙门不入我家者好。若如是人不应作。若有惭愧者应与作。若自见过已行随顺心柔软应与舍。是名覆钵法。衣纽帖法者。佛住舍卫城。尔时有乞食比丘。一手捉钵一手捉俱钵。有旋风来吹衣去。着内衣入祇洹。佛知而故问。比丘。衣在何处。答言世尊。旋风吹去。佛言。从今日后。应安纽帖。尔时诸比丘便用金银作纽帖结。佛言。一切金银宝物不听作纽帖结。应用铜铁白蜡若木竹具线安纽作结。不听不着纽入聚落。若无者应用针缀。若复无针者下至手捉。若衣无纽着入聚落。得越比尼罪如是若入家家。随得越比尼心悔。若有而不着。得越比尼心悔。不犯者。若入比丘尼精舍外道精舍。若檀越唱言随所安者无罪。是名衣纽帖结法。腰带法者。佛住王舍城。时有乞食比丘。一手捉钵一手捉俱钵。旋风吹内衣去。着上衣入祇洹精舍。佛知而故问。比丘汝安陀会何处。答言世尊。旋风吹去。佛言。从今已后应着腰带。复次诸比丘散缕作带纽缕作空中作者。佛言。散缕纽缕作尽不听。空中者应当中缝。若织编作若团作尽听着。着时不听四匝一匝系。应再匝乃至三匝。若比丘身软不堪系者应持去。至聚落边欲入时应系。出已还解。若不着腰带入聚落。越比尼罪。有而不着越比尼心悔。若一匝着越比尼罪。若再匝三匝着无罪。是名腰带法。带结法者。佛住舍卫城。时比丘带头不作结在店肆前行带解曳地而行。为世人所嫌。云何沙门释子曳肠而行。诸比丘以是因缘往白世尊。佛言。从今日后应带头作结。复次有比丘。金银作带结。佛言比丘。一切宝物不听作系带头若二若三结不听作一结四结若一切不作结得越比尼罪。是名带结法。乘法者。佛住舍卫城。时节会日人民出看。时六群比丘乘象乘马有乘驴者。为世人所嫌。云何沙门释子如王大臣。乘象马行有见乘驴者。复言是沙门释子如下贱使人。乘驴而行。诸比丘以是因缘往白世尊。佛言。从今已后。不听乘驴乘马。复次佛住王舍城耆旧童子庵婆罗园精舍。如来五事利益故。五日一按行诸比丘房。佛见一比丘病瘦瘀黄。佛知而故问。比丘。汝病增损气息调不。答言世尊。我病苦气息不调。佛言。汝不能到耆旧医看病耶。答言。世尊制不听骑乘。我病苦不能得往。佛言。从今日听病比丘骑乘。乘者。象乘马乘驴乘驼乘船乘牛乘车乘辇乘。如是一切乘不病不听乘。若病者得。不听乘雌乘。应乘雄乘。若病重不分别者乘无罪。若有因缘。上下水行及直渡。应作是念。我有缘事。尔时得乘渡。若比丘无病乘乘者得越比尼罪。是名乘法。共床卧法者。佛住舍卫城。时六群比丘。二人三人共床而卧。床褥故破在地。如来五事利益故。五日一行诸比丘房。见破床在地。知而故问。比丘。此是谁破床。狼藉在地。诸比丘具说上事。佛言。从今日后。不听同床眠。床褥者如上说。一人应一床眠。若坐床者。二人得连三床眠。但申脚时不得过膝头。若横褥者。听三人横眠。若方褥者。得二人连三褥眠。但申脚时不得过膝。若草敷各各敷尼师檀坐具卧不犯。若寒者得通覆上下。不得大相近。中间相去一肘不舒手大小降三腊得共床坐不得共床眠。若共床眠越比尼罪。是名共床法。共坐法者。佛住舍卫城时六群比丘。三人四人共坐一床。床座折破。如来五事利益故。五日一按行诸比丘房。见床破狼藉在地。佛知而故问比丘。此是何等破床。狼藉在地乃尔诸比丘闻已具白世尊。佛言。从今日后。不听共床坐。复次佛住舍卫城。尔时世尊语优波离。诸比丘受诵比尼不。答言诵但诵少。佛语优波离。何故少。答言。世尊制戒不听共床坐。诸比丘一人独固一床。是故受诵者少。佛言。从今日后。听降三岁比丘得共床坐。无岁比丘得共三岁比丘坐。如是乃至七岁。比丘得共十岁比丘坐。若卧床得三人坐。坐床应二人共坐。若床长。一肘半。相降三岁得二人共坐。若减应并与上座。若卧床过三肘。得与降四岁比丘共坐。若减者不得共坐。若大会众集床座少者。得连床相接系。令相着系时。当令坚牢勿使动褥得共坐。若方褥长三肘。得共四岁比丘坐。若减不得。若散草敷地共坐无罪。是名共坐法

摩诃僧祇律卷第三十一摩诃僧祇律卷第三十二

        东晋天竺三藏佛陀跋陀罗共法显译

    明杂跋渠法之十

共食法者。佛住舍卫城。尔时六群比丘共食。为世人所嫌。云何沙门释子。如世间淫泆人共食。乃至佛言呼六群比丘来。来已佛语比丘。汝实尔不。答言实尔世尊。佛言。从今日后不听共食。共食者。共一器食。食者。五正食五杂正食。应别器食。若无钵者。应用钩钵若键[金*慈]。若复无者。应团饭着左手中右手食。若复不能者。应置钵着草叶上更互取食。不得俱下手离。五正食五杂正食。若糗若饼果菜共食无罪。若共器食者。越比尼罪。是名共食法。机食者。佛住舍卫城。如来以五事利益故。五日一行诸比丘房。见难陀优波难陀房中食机种种画色。佛知而故问。此是谁食机种种画色。诸比丘答言。是难陀优波难陀食机。佛言。从今日后。不听机上食。复次佛住舍卫城。如来五事利益故。五日一行诸比丘房。见一痏手比丘。佛知而故问。比丘调适安乐不。答言世尊。我痏手破钵。世尊制戒不听机上食故不乐。佛言。从今日听病比丘机上食。不听种种画色。若僧食机种种画色无罪。若私有。听一种色。病比丘机上食。应先立心作念得用无罪。若比丘不病。一切不听机上食。若老病痏手刺头出血。若钵重若满。若热若冷。得机上食无罪。若比丘不病机上食者。得越比尼罪。是名机法

  食蒜并覆钵　　钩纽及腰带
  骑乘及同床　　共坐同器食
  食机种种色　　第八跋渠竟

为杀者佛住舍卫城时。难陀优波难陀游。行还舍卫城时。有一旧檀越名。阿跋吒是。比丘时到着入聚落衣持钵入其家。檀越见已作是言。阿阇梨何故希行多时不见。比丘言。长寿。我希行来。欲与我作何等好食。答言。我明日当与阿阇梨作食。比丘言。汝莫作织师食。便问言。何等名织师食。比丘言。粗饭豆羹是。檀越言。我不与阿阇梨粗饭豆羹。当与肉食。比丘言。汝莫与我冷肉。答言。我不与阿阇梨冷肉食。当热煮与。比丘言。我所言热不谓此热。问言。何等热。比丘答言。新死热肉。檀越言。若欲尔者明日早来。当在阿阇梨前杀者可得热。比丘答言可尔。到明旦着衣持钵往至其家。檀越即牵羊猪鸡。罗列在比丘前杀。供食已去。檀越嫌言。沙门瞿昙无数方便。毁呰杀生赞叹不杀。而此沙门目前教杀。与自杀何异诸比丘以是因缘往白世尊。佛言。呼难陀优波难陀来。来已佛问比丘。汝实尔不。答言实尔世尊。佛言比丘。此是恶事。乃至佛言汝云何现前教杀。从今日后。不听为杀。为杀者为比丘杀。为比丘杀者一切比丘比丘尼式叉摩尼沙弥沙弥尼优婆塞优婆夷尽不得食。如是乃至为优婆夷杀。一切比丘不得食。乃至优婆夷亦不得食。为有三事。见闻疑。见者。现前眼见为杀不听食。是名见。闻者。耳自闻或从他闻为杀不听食。若前人是不可信。故欲扰乱比丘者。不应受语。当从可信人边取定。是名闻。疑者。比丘至檀越家常见羊。后往正见头脚在地。见已心即生疑。应问前所见羊为在何处。若言已为阿阇梨杀者不应食。若言尊者我为祠天故杀食不尽与得食。是名疑。如是一切众生若见若闻疑亦如是。是名为杀。人肉者。佛住舍卫城。尔时舍卫城中有优婆塞。名[口*束]卑。其妇亦名[口*束]卑。有客比丘来亦名[口*束]卑。时优婆塞闻已便作是念。阿阇梨与我等同字。当往请食。即诣精舍请来家中。设种种饮食供养已。头面礼足胡跪合掌。白言尊者。唯愿受我四事请。衣食床卧具病瘦汤药。比丘即便受请。时夫主欲逐商人远行。嘱妇言。我远行。汝在后当好供养阿阇梨。勿使有乏。去后比丘不和。欲服下药。语优婆夷言。我欲服下药。能随时次第料理食不。答言可尔。服下药已随次第应病与食。清粥滰粥次须肉。持罽利沙槃与婢言。持是往买肉来。其婢入市。值斋日都无杀者而不得还。时优婆夷心生不悦言。阿阇梨服药。若不得随病食者。或能增动。即磨芜菁子以油渍之。便入房内即以利刀割髀肉。诸婢言。汝持此肉。以芜菁子油净洗作食与阿阇梨。问阿阇梨明日复须何等食。其婢如教办食送往。问言明日复须何食。答言止。莫复更送。时优婆夷患疮而卧。其夫商人行还作是念。我常远行。还时妇出二门三门迎我。今何故不出。入房见妇卧床上。便嗔恚言。汝何故慢我不出耶。其妇答言。此行有何功。夫欲使我迎答言。我行得百千万来。其妇答言。此是外财何足为奇。我自割身肉供给阿阇梨。其夫问言。为割何处。即褰衣示之。其夫见已迷闷倒地。时有鬼神即语比丘。时比丘闻已便入慈三昧。定力感之平复如故。其妇语夫言。起起勿怖。阿阇梨威神故我疮已平复。其夫起已见疮平复。即大欢喜。往到店肆上作如是言。我家妇精进如是割身供养。众人闻已嫌言。云何沙门释子啖人肉。诸比丘以是因缘往白世尊。佛言。呼是比丘来。来已佛问比丘。汝实尔不。答言实尔世尊。我不入定故。佛言。从今日后。不听食人肉。复次佛住波罗奈仙人鹿野苑。时有比丘黄病。医师言。尊者服人血者可差。若不服者便死。更无余方。时有人犯王事。反缚两手着迦毗罗华鬘。打鼓唱令诣其刑处。比丘至魁脍边作是言。长寿。施我人血饮。魁脍言。若欲食肉亦当相与。何况血耶。即坐罪人在地。以刀刺两喉脉出血。比丘两手承取血饮。为世人所嫌。此非比丘。是啖人鬼。即以瓦石土块掷是比丘劣而得脱。诸比丘以是因缘往白世尊。佛言。呼是比丘来。来已佛问比丘。汝实尔不。答言实尔世尊。佛言比丘。此是恶事。爱命乃尔。佛言。从今已后。不听饮人血。乃至人髓一切不听。若比丘头生疮。医言须人骨灰涂得差者得涂。涂已不得众中住。应在边小房中住。差已应净洗浴还入众中。复次佛住毗舍离。时有一种姓食龙肉。诸比丘亦有食龙肉者。是故杀者众多。时有一龙女到世尊床前立住而啼。佛知而故问。汝何故啼耶。时龙女白佛言。世尊。毗舍离人食龙。诸比丘亦食。以是故杀者众多。唯愿世尊勿令诸比丘食龙。尔时世尊。为龙女随顺说法。示教利喜而去。时世尊往到众多比丘所。敷尼师檀而坐。即为比丘具说上事。从今日后。不听食龙肉。龙血龙骨龙筋龙髓一切不听食。若身外有诸病。须骨灰涂者得用无罪

佛住王舍城。时瓶沙王象死。有诸小姓旃陀罗食肉。诸比丘亦有食者。时耆旧童子至佛所。头面礼足却住一面白佛言。世尊瓶沙王象死。有诸小姓旃陀罗啖肉。诸比丘亦有啖者。比丘者出家人。人所敬重。唯愿世尊。莫令食象肉。世尊为童子随顺说法示教利喜。头面礼足而退。时世尊往至众多比丘所。敷尼师檀坐。为诸比丘具说上事。佛言。从今已后不听食象肉。乃至象髓亦不听食。听以象牙骨作钵支衣细结无罪

佛住王舍城。时瓶沙王马死。亦如上象中说若外有癣疥病。须马血涂者无罪。涂已不得众中住。应在边小房中住。佛住舍卫城。时诸比丘食狗肉。入聚落时为狗所逐竞吠。诸比丘以是因缘往白世尊。乃至佛言。从今日后。不听食狗肉。乃至狗髓不听食。若为狗所啮。须烧狗毛涂疮者得用无罪。佛住舍卫城时有比丘食乌肉。比丘入聚落乞食。或林中经行时。群乌逐鸣。诸比丘以是因缘往白世尊。乃至佛言。从今日后。不听食乌肉。乃至乌髓亦不听食。若须翅翮外用者无罪

佛住舍卫城。时有比丘食鹫鸟肉。比丘近林中经行。有诸群鹫逐比丘鸣唤。诸比丘以是因缘往白世尊。乃至佛言。从今已后。不听食鹫鸟肉。乃至鹫髓亦不听食。若须翅翮外用者无罪。一人肉。二龙肉。三象肉。四马肉。五狗肉。六乌肉。七鹫鸟肉。八猪肉。九猕猴肉。十师子肉。蒜者。生熟皮叶。一切尽不听食。若须外用涂疮听用。若涂已不得众中住。当在边小房中住。差已应净洗浴还听入众。是名肉蒜法

皮法者。佛住舍卫城。时难陀优波难陀。至牧牛家坐床上。有新生犊子。见比丘衣色似母。跳踉来趣。比丘即以手摩额上。细滑触手。便作是言。此皮软好可作坐具。时牧牛人便作是念。此比丘是王大臣贵胜所识。有大力势故当欲得是皮。即问。阿阇梨欲须皮耶我当与。比丘便言。正与我此犊皮。牧牛人言。我家中有成死犊皮亦软好。当鞣治相与。比丘言。审与我者。正与我是。更不须余者。时牧牛人便作是念。此比丘有大势力。能作不饶益事。畏难故即比丘前杀犊。剥皮与之。时犊母牧还不见其子。循篱鸣唤。牧牛人嫌言。沙门释子而无慈心。使沙门在犊母处者。意当云何。诸比丘以是因缘往白世尊。佛言。呼难陀优波难陀来。来已佛问比丘。汝实尔不。答言实尔世尊。佛言比丘。此是恶事。汝云何现前教杀。从今已后不听用皮。皮者。牛皮水牛皮虎皮豹皮罴皮鹿皮。如是一切皮不听坐唯听恕奴边地羊皮。羊皮有二种。一者羖羊。二者羺羊。羖羊羺羊各有十种。如上说。若坐皮上。越比尼罪。若坐皮兜罗褥上者。二越比尼罪。若坐革屣上。越比尼罪。若卧革屣上齐膝以上。越比尼罪。膝已下无罪。若皮织床坐上无罪

揩脚物者。佛住舍卫城。时难陀优波难陀。作种种揩脚物洗足。外道弟子见已便作是念。我等当共试扰乱优婆塞去。如上屑末中广说乃至佛言。从今日后。不听用种种物揩洗脚。揩物者。若方若圆。刻上如摩沙豆蒙具豆形。一切不听用。脚底有垢破。得圆草若塼瓦听用。是名揩脚物。眼药者。佛住王舍城。时世人节日男女出城游观。时六群比丘以空青黑物庄眼。为世人所嫌。云何沙门释子如贵胜童子。以空青庄眼。有见黑物庄者。复言沙门释子如下贱使人。黑物庄眼而行。此坏败人何道之有。诸比丘以是因缘往白世尊。乃至佛言。从今日后。不听庄眼。复次佛住舍卫城耆旧童子庵婆罗园。时诸比丘眼痛。耆旧童子言。尊者。可以此药涂眼。诸比丘言。世尊制戒不听涂眼。童子言。我当往从世尊乞此愿。即往佛所头面礼足却住一面白佛言。世尊。诸比丘是一食人。眼是人之所重。唯愿世尊。听诸比丘着眼药。佛言。从今已后。听用眼药。除空青。若医言。尊者此眼痛得空青屑涂便差更无余方。若尔者得涂。涂已不得众中住。应在边小房中。差已当净洗得还入众。是名眼药。眼药筒者。佛住舍卫城。时诸比丘持树叶盛眼药。佛知而故问。比丘此是何等。答言。是眼药。佛言。眼药是贵物。应用筒盛。时诸比丘作金银筒盛。佛言。金银及一切宝不听用。应用铜铁白腊竹苇筐鸟翮下至皮裹。是名药筒。眼药筹者。佛住舍卫城。时有比丘。持竹作眼药筹。佛知而故问。比丘此是何等。答言世尊。是眼药筹。佛言。眼是软物。应用滑物作筹。时有比丘便以金银作。佛言。不听金银及一切宝物作。应用铜铁牙骨栴檀坚木作。揩摩令滑泽。下至用指头。是名眼药筹法。盖法者。佛住王舍城。时世人节会日男女游观。时六群比丘持种种杂色伞盖。有持树皮伞盖者。为世人所嫌。云何沙门释子如王子大臣。持种种杂色伞盖。见持树叶者。复作是言。云何沙门释子。如下贱使人。持树叶伞盖行。此坏败人何道之有。诸比丘以是因缘往白世尊。乃至佛言。从今已后。不听持伞盖。复次佛住舍卫城。时长老阿那律金毗罗。在塔山安居竟。还舍卫城礼拜世尊。佛知而故问。比丘衣何故碱污乃尔。比丘答言。世尊制戒不听持伞盖。我乞食被雨是故如是。佛言从今日后。听持伞盖。伞盖者。树皮盖树叶盖竹盖。如是等盖听用。不听种种杂色伞盖。是名伞盖法也

扇法者。世人节会日男女游观。六群比丘持云母庄挍扇。有持草扇者。为世人所嫌。云何沙门释子。如王子大臣。持云母庄挍扇。见有持草扇者。复言。云何沙门释子如下贱人持草扇行。此坏败人何道之有。诸比丘以是因缘往白世尊。乃至佛言。从今已后。不听持扇。复次佛住毗舍离。诸比丘在禅坊中患蚊子。以衣扇作声。佛知而故问。比丘作何等。如象振耳作声。比丘答言。世尊制戒不得捉扇。诸比丘患蚊。以衣拂故作声。佛言。从今已后。听捉竹扇苇扇树叶扇。除云母扇及种种画色扇。若僧扇作种种色无罪。若私扇坏色。若有持种种香涂扇来施者。听洗已受用。是名扇法。拂法者。佛住王舍城。世人节会日男女游观。时六群比丘持白[犛-未+牙]牛尾拂。以金银作柄。有持马尾拂者。为世人所嫌。乃至佛言。从今已后。不听捉拂。复次佛住毗舍离。诸比丘禅坊中患蚊故。以树叶拂蚊作声。佛知而故问。比丘此何等声。答言。世尊制戒不听捉拂。是故诸比丘以树叶拂蚊作声。佛言。从今已后。听捉拂。拂者。线拂裂[疊*毛]拂芒草拂树皮拂。是中除白[犛-未+牙]牛尾白马尾金银柄。余一切听捉。若有白者当染坏色已听用。捉拂时不得如淫女捉拂作姿作相。是名拂法

  为杀食人肉　　眼药并筒筹
  牛皮揩脚物　　伞盖及扇拂
  第九跋渠竟

刀治者。佛住舍卫城。时有比丘痔病语医言。长寿。能为我刀治不。答言尔。医便作是念。是诸沙门聪明智慧。见我治者便当学得。不复求我。即遣诸比丘。去已欲作非法。时此比丘即生疑。唤诸比丘言长老来此。医欲作非法。诸比丘闻即便来入。医怖畏弃刀而走。诸比丘以是因缘往白世尊。佛言。呼彼比丘来。来已佛问比丘。汝实尔不。答言实尔世尊。佛言比丘。汝云何用刀治爱处。从今已后。不听用刀治爱处。爱处者。离谷道边各四指。若有痈痤疖听嚼小麦鸡屎涂上使熟。当令同和上阿阇梨擿破。若余处有痈痤疖等诸病。须刀治者听用。用刀治爱处者。偷兰罪。是名刀治

灌筒者。佛住舍卫城。有比丘[病-丙+干]痟病。语医言。长寿。能为我灌病不。答言可尔。即作是念。此诸沙门聪明智慧。见我灌者更不唤我。乃至弃筒而足。诸比丘以是因缘往白世尊。乃至佛言。汝云何用筒灌病。从今已后。不听用筒。筒者。牛皮筒水牛皮筒羊皮筒。如是一切不听用灌。若医言此病须油灌者。应在浴室中穿板盛油褰衣坐上口含甘蔗。若复以[疊*毛]衣絮等内着油中。临孔上按之。令油流入者无罪若筒灌者偷兰罪。是名筒灌法

剃发法者。佛住舍卫城。南方国土有邑名大林时有商人。驱八牛到北方俱哆国。复有一商人。共在泽中牧牛。时离车捕龙食之。捕得一龙女。龙女受布萨法无害心。能使人穿鼻牵行。商人见之形相端正。即起慈心。问离车言。汝牵此欲作何等。答言。我欲杀啖。商人言勿杀我与汝一牛贸取放之令去。捕者不肯。乃至八牛。方言此肉多美今为汝故我当放之。即取八牛放龙女去。时商人寻复念言。此是恶人恐复追逐更还捕取。即自随逐看其向到池边。龙变为人语商人言。天施我命。我欲报恩。可共入宫。当报天恩。商人答言不能。汝等龙性卒暴嗔恚无常。或能杀我。答言不尔。前人系我我力能杀彼。但以受布萨法故都无杀心。何况天今施我寿命而当加害。若不去者小住此中。我今先入拼挡宫中。即便入去。是龙门边见二龙系在一处。见已商人问言。汝为何事被系。答言。此龙女半月中三日受斋法。我弟兄守护此龙女不坚固。为离车所捕得。以是故被系。唯愿天慈语令放我。此龙女若问欲食何等食者。龙宫中有食。尽寿乃能消者。有二十年消者。有七年消者。有阎浮提食。若索者当索阎浮提人间食。龙女拼挡已。即便呼入坐宝床褥上龙女白言。天今欲食何等食。为欲食一食尽寿乃至。答言。欲食阎浮提人间食。即持种种饮食与。问龙女言。此何故被系。龙女言。天但食用问为。不尔我要欲知之。为问不已。即语言。此人有过。我欲杀之。商人言。汝莫杀。不尔要当杀之。商人言。汝放彼者我当食耳。白言。不得直尔放之。当罚六月摈置人间。即罚六月人间。商人见龙宫中种种宝物庄严宫殿。商人问言。汝有如是庄严。用受布萨为。答言。我龙法有五事苦。何等五。生时龙。眠时龙。淫时龙。嗔时龙。死时龙。一日之中三过。皮肉落地热沙爆身。复问。汝欲求何等。答言。我欲求人道中生。所以者何。畜生道中苦不知法故。我已得人身应求何等。龙女言。出家难得。又问。当就谁出家。答言。如来应供正遍知今在舍卫城。未度者度未脱者脱。汝可就出家。便言。我欲还归。龙女即与八鉼金。语言。此是龙金。足汝父母眷属终身用不尽语言。汝合眼。即以神变持着本国。行伴先至语其家言。入龙宫去。父母谓儿已死。眷属宗亲聚在一处悲啼哭。时放牧者及取薪草人。见已先还语其家言。某甲来归。家人闻已即大欢喜出迎入家。入家已为作生会。作会时以八鉼金持与父母。此是龙金。截已更生。尽寿用之不可尽也。唯愿父母听我出家。其父母不放。即便走诣祇洹精舍。比丘即度出家。父母寻后来至精舍门。问诸比丘。汝识某甲不。皆言不见不闻。有比丘语言。汝但此门间住。若有者须臾自当出入。即如其言须臾待之。便见儿出。作是嫌言。沙门释子妄语。见言不见闻言不闻。儿语父母。莫作不饶益事。我此间出家谁都得知。即往至佛所头面礼足却坐一面。佛为说法示教利喜。得法眼净已。即语儿言。我等便是更生。汝今出家大得善利。诸比丘闻向嫌言。以是因缘往白世尊。佛言。呼彼比丘来。来已佛问比丘。汝实尔不。答言实尔。佛语比丘。汝云何不白众度人出家。从今日后。不听不白僧度人出家。应白剃发出家。白者。白一切众僧。下至白上座八人。应语令使如法。白剃发。不白出家得越比尼罪。若俱白出家俱无罪。若都不白出家不白剃发二越比尼罪。二俱白者无罪。若出界度者无罪。是名剃发。复次佛住王舍城迦兰陀竹园。如来处处度人。比丘比丘尼优婆塞优婆夷国王长者外道沙门婆罗门。佛告比丘。汝等从今已后亦当度人出家受具足。尔时诸比丘亦学如来善来。度人出家须发故在。佛语诸比丘。何处一切得如来无畏口须发自落。从今已后应剃发。剃发时诸比丘剃发不剃须。有比丘剃须不剃发。诸比丘以是因缘往白世尊。佛言。应一切剃。剃者应先剃须后剃发。若剃发人难共语者前剃发无罪。若欲新出家者。不得便说出家乐。应说出家苦。一食一住一眠少食少饮多觉少眠。长寿能不。若言能应与剃。比丘先剃发后剃须无罪。是名剃发。剃发具者。佛住俱萨罗国游行。故名婆罗门聚落。摩诃罗父子持剃发具出家。乃至佛言。汝等云何剃发人持作具与出家。从今日后不听合剃发具与出家。若剃发人持剃发具。欲求出家者。应语舍剃发具。然后与汝出家。出家已后欲须时得从借用。如是锻师木师金银师皮师织师。如是工师比不听持作具度出家若合度者。越比尼罪。是名作具

破僧者。佛住舍卫城。时尊者优波离往至佛所。头面礼足却住一面白佛言。世尊说破僧。云何名破僧。佛告优波离。如大德比丘如法如律善解深理。是比丘应礼拜恭敬随顺法教。若比丘谓彼比丘所说非法不随顺行僧诤非破僧。乃至一界一住同说戒共作羯磨。我已制一界一住中别作布萨自恣羯磨。是名破僧。尊者优波离复白佛言。破僧者得何等罪。佛言。一劫泥犁罪。是名破僧

和合僧者。佛住舍卫城。尔时尊者优波离白佛言。世尊说和合僧。云何名和合。佛告优波离。我已制如大德比丘如法如律善解深理。是比丘应礼拜恭敬。诸比丘随顺行法。共一界住共一布萨自恣。共作羯磨。是名僧和合。尊者优波离往至佛所。头面礼足却住一面白佛言。世尊。和合僧有何功德。佛言。一劫善报。是名和合僧

五百比丘集法藏者。佛住王舍城。尔时阿阇世王韦提希子。与毗舍离有怨。如大泥洹经中广说。乃至世尊在毗舍离于放弓杖塔边舍寿。向拘尸那城熙连禅河侧力士生地坚固林中双树间般泥洹。于天冠塔边阇维。乃至诸天使火不然。待尊者大迦叶故。时尊者大迦叶在耆阇崛山宾钵罗山窟中坐禅。时尊者大迦叶作是念。世尊已舍寿。欲何处般泥洹。今在何处。少病少恼安乐住不。作是念已即入正受三昧。以天眼观一切世界。见世尊在拘尸那竭城熙连河侧力士生地坚固林中双树间天冠塔边阇维。乃至火不然。见已惨然不悦复作是念。及世尊舍利未散。当往礼敬。寻复念言。我今往见世尊最后身。不宜乘神足往。宜应步诣。时尊者大迦叶语诸比丘言。诸长老。世尊已般泥洹。各持衣钵共诣拘尸那竭。礼觐世尊。诸比丘闻已皆言善哉。时尊者摩诃迦叶。即与众多比丘俱诣拘尸那竭路经一聚落。聚落中有一摩诃罗比丘。先在中住。尊者摩诃迦叶告摩诃罗言。持衣钵来。共汝诣拘尸那竭城礼觐世尊。摩诃罗言。长老大迦叶。且待前食后食讫。然后当去。迦叶答言。不宜待食。摩诃罗勤勤至三。迦叶故言不宜待。时摩诃罗恚言。沙门有何急事匆匆乃尔。如死乌不直一钱。且待须臾。食已当去。尊者大迦叶复言。宜且置食。世尊今已泥洹。及未阇维宜应速往。时摩诃罗闻佛已般泥洹。语尊者摩诃迦叶言。我今永得解脱。所以者何。彼阿罗诃在时常言。是应行是不应行。今已泥洹。应行不应行自在随意。时大迦叶闻此语已惨然不悦。即弹右指火出。右足蹈地。摩诃罗见已大怖而走。乃至大迦叶往诣佛所。世尊即现两足。从棺双出。时尊者大迦叶见佛足已。偏袒右肩头面作礼。说此偈言

  如来足踝满　　千辐相轮现
  指纤长柔软　　合缦网文成
  是故我今日　　顶礼最胜足
  最胜柔软足　　曾游行世间
  大悲济群生　　从今永不会
  是故我今日　　稽首如来足
  如来救济我　　解脱得应真
  我今最后见　　永已不复觐
  断世众疑惑　　离欲中最上
  利益一切众　　无不得欢喜
  是故我今日　　顶礼最胜足
  佛有如是德　　善答决众疑
  今日时已过　　慈慧光永灭
  是故我今日　　稽首最胜足
  我证四真谛　　说佛功德宝
  偈赞礼敬讫　　还摄双足入

诸比丘各议言。谁应阇维。时尊者大迦叶言。我是世尊长子。我应阇维。是时大众皆言善哉。即便阇维。阇维已。迦叶忆聚落中摩诃罗比丘语。乃至欲行便行。不行则止。即语诸比丘言。长老世尊舍利非我等事。国王长者婆罗门居士众求福之人自当供养。我等事者宜应先结集法藏。勿令佛法速灭。寻复议言。我等宜应何处结集法藏。时有言。向舍卫者。有言向沙只。有言向瞻婆。有言向毗舍离。有言向迦维罗卫。时大迦叶作是言。应向王舍城结集法藏。所以者何。世尊记王舍城韦提希子阿阇世王声闻优婆塞无根信中最为第一。又彼王有五百人床卧供具。应当诣彼。皆言尔。世尊先语尊者阿那律言。如来般泥洹。汝应守舍利。勿使诸天持去。所以然者。过去世时如来般泥洹。诸天持舍利去。世人不能得往。失诸功德。诸天能来人间供养。世人不能往彼。除其神足。是故应好守护。侍者阿难复以供养故不去。时大迦叶即与千比丘俱。诣王舍城至刹帝山窟。敷置床褥庄严世尊座。世尊座左面敷尊者舍利弗座。右面敷尊者大目连座。次敷大迦叶座。如是次第安置床褥已办四月供具。结集法藏故悉断外缘。大众集已。中有三明六通德力自在者。于中有从世尊面受诵。一部比尼者。有从声闻受诵一部比尼者。有从世尊面受诵二部比尼者有从声闻受诵二部比尼者。众共论言。此中应集三明六通德力自在从世尊面受诵二部比尼者。从声闻受二部比尼者。集已数少二人。不满五百。复议言。应满五百。长老阿那律后到犹少一人。时尊者大迦叶为第一上座。第二上座名那头卢第三上座名优波那头卢。时尊者大迦叶自升己座。唯留尊者舍利弗目连阿难座已。诸比丘各随次而坐。时尊者大迦叶告尊者目连共行弟子梨婆提长老。汝至三十三天呼[口*束]提那比丘来。世尊已般涅槃。比丘僧集欲结集法藏。即受命往三十三天白。长老。世尊已般泥洹。比丘僧集欲结集法藏故来相呼。比丘闻已惨然不悦。世尊已般泥洹耶。答言尔。便言。世尊在阎浮提者当往。世尊已般泥洹世间眼灭。即以神足上升虚空。入火光三昧以自阇维。见已即还。来入僧中具说上事。乃至言入火光三昧。复遣至三十三天尸利沙翅宫。呼憍梵波提。次长老善见在香山。长老颇头洗那在游戏山。长老拔佉梨在瞻婆山。复有长老郁多罗在净山。尊者目连弟子名大光在光山。尊者舍利弗弟子摩薮卢在慢陀山。尊者罗杜在摩罗山。如是等乃至闻唤。皆般泥洹。复遣使往毗沙门天宫。唤修蜜哆。使至已作是言长老世尊已般泥洹。比丘僧集欲结集法藏。故来相唤。比丘闻已惨然不悦言。世尊已般泥洹耶。答言尔便言。世尊在阎浮提者我当诣彼。世尊般泥洹后世间眼灭。即以神足上升虚空。入火光三昧以自阇维。入于般泥洹。使还僧中具白僧如上。大迦叶言。诸长老且止勿复唤余诸闻唤者便自泥洹。若更唤者复当般泥洹。如是世间便空无有福田。有比丘言。诸长老。尊者阿难是佛侍者亲受法教。又复世尊记阿难有三事。第一宜应唤来。大迦叶言不尔。如此学人入无学德力自在众中。犹如疥[癈-(弓*殳)+虫]野干入师子群中。时尊者阿难料理供养讫。来到一聚落中作是言。我今此中宿。明日当往王舍城。时有天来语阿难言。大迦叶言。尊者是疥[癈-(弓*殳)+虫]野干。阿难作是念。世尊已泥洹。我今正欲依附。云何持我作疥[癈-(弓*殳)+虫]野干。心生不悦。复作是念。是大迦叶。足知我眷属姓字。正当以我结使未尽故作是言耳。时尊者阿难勤加精进经行不懈欲尽有漏。时尊者阿难以行道疲苦。又复世尊泥洹忧恼缠心。先所闻持不复通彻。寻作是念。世尊记我。于现法中心不放逸。得尽有漏用太苦为。心不舍定倾身欲卧。头未至枕得尽有漏。三明六通德力自在。即以神足乘空而去。到刹帝窟户外。而说偈言

  多闻有辩才　　给侍世尊者
  瞿昙子阿难　　今在门外立
  由不与开门

又复说偈言

  多闻利辩才　　给侍世尊者
  已舍结使担　　瞿昙子在外

尔时大迦叶而说偈言

  汝舍烦恼担　　自说言得证
  未入瞿昙子　　来入瞿昙子

阿难入已。礼世尊座讫次礼上座。到己座处便坐。时大迦叶语阿难言。我不自高。亦不轻慢于汝。故作是言。但汝求道不进。欲使精勤尽诸有漏故。说此言耳。阿难言我亦知。但以我。结使未尽。欲使勤进断诸有漏。时尊者大迦叶问众坐言。今欲先集何藏。众人咸言。先集法藏。复问言。谁应集者。比丘言。长老阿难。阿难言不尔。更有余长老比丘。又言。虽有余长老比丘。但世尊记汝多闻第一。汝应结集。阿难言。诸长老若使我集者。如法者随喜。不如法者应遮。若不相应应遮。勿见尊重而不遮。是义非义愿见告语。众皆言。长老阿难。汝但集法藏。如法者随喜。非法者临时当知。时尊者阿难即作是念。我今云何结集法藏。作是思惟已便说经言。如是我闻。一时佛住郁毗罗尼连河侧菩提曼陀罗。尊者阿难适说是语。五百阿罗汉德力自在者。上升虚空咸皆喟叹。我等目见世尊。今已言闻。悉称南无佛已还复本座。尔时阿难说此偈言

  勤修习正受　　见诸法生灭
  知法从缘起　　离痴灭烦恼
  勤修习正受　　见诸法生灭
  知法从缘起　　证诸法灭尽
  勤修习正受　　见诸法生灭
  知法从缘起　　摧伏诸魔军
  勤修习正受　　见诸法生灭
  知法从缘起　　如日除众冥

尊者阿难诵如是等一切法藏。文句长者集为长阿含。文句中者集为中阿含。文句杂者集为杂阿含。所谓根杂力杂觉杂道杂。如是比等名为杂。一增二增三增乃至百增。随其数类相从。集为增一阿含。杂藏者。所谓辟支佛阿罗汉自说本行因缘。如是等比诸偈诵。是名杂藏。尔时长老。阿难说此偈言

  所有八万诸法藏　　如是等法从佛闻
  所有八万诸法藏　　如是等法从他闻
  如是等法我尽持　　是佛所说趣泥洹
  是名撰集诸法藏

次问。谁复应集比尼藏者。有言长老优波离。优波离言不尔。更有余长老比丘。有言。虽有长老比丘。但世尊记长老成就十四法。除如来应供正遍知。持律第一。优波离言。诸长老。若使我集者。如法者随喜。不如法者应遮。若不相应应遮。勿见尊重。是义非义愿见告示。皆言。长老优波离但集。如法者随喜。非法者临时当知。尊者优波离即作是念。我今云何结集律藏。五净法。如法如律随喜。不如法律者应遮。何等五。一制限净。二方法净。三戒行净。四长老净。五风俗净。制限净者。诸比丘住处作制限。与四大教相应者用。不相应者舍。是名制限净。方法净者。国土法尔。与四大教相应者用。不相应者舍。是名方法净。戒行净者。我见某持戒比丘行是法。若与四大教相应者用。若不相应者舍。是名戒行净。长老净者。我见长老比丘尊者舍利弗目连行此法。与四大教相应者用。不相应者舍。是名长老净。风俗净者。不得如本俗法。非时食饮酒行淫。如是一切本是俗净。非出家净。是名风俗净。如是诸长老。若如法者随喜。若不如法应遮。诸比丘答言。相应者用。若不相应者临时应当遮。时尊者优波离语阿难。长老有罪。清净众中应当悔过。阿难言。有何等罪。答言。世尊乃至三制不听度女人出家。而汝三请。是越比尼罪。时尊者大迦叶掷筹置地言。是第一筹。即时震动三千大千世界。复次佛在毗舍离。佛告阿难。毗舍离般乐放弓杖塔可乐。若得四神足者可住。寿一劫一劫有余。若佛在世世人得见汝言。如是世尊。如是修伽陀。汝不请佛住世。越比尼罪。次掷第二筹。复次汝右脚指蹑世尊僧伽梨衣缝而汝不知是僧伽梨。是诸天世人塔应恭敬耶。是越比尼罪。次下第三筹。复次佛告阿难取水来。如是至三汝不与。世尊取水。是越比尼罪。下第四筹。复次佛告阿难。我临般泥洹时当语我。我当为诸比丘舍细微戒。而汝不白。越比尼罪。下第五筹。复次佛般泥洹。而汝以佛阴马藏示比丘尼。是越比尼罪。下第六筹。复次佛般泥洹已。力士诸老母临世尊足上啼。泪堕足上。汝为侍者不遮。是越比尼罪。下第七筹。尔时阿难不受二罪作是言。长老。过去诸佛皆有四众。是故三请度比丘尼。佛在毗舍离。三告不请佛住世者。我尔时是学人。为魔所蔽。是故不请。是中犯五越比尼罪。长老如法作已。时尊者优波离作是言。诸长老是九法序。何等九。一波罗夷。二僧伽婆尸沙。三二不定法。四三十尼萨耆。五九十二波夜提六四波罗提提舍尼。七众学法。八七灭诤法。九法随顺法。世尊在某处为某甲比丘制此戒。不皆言如是优波离如是优波离。复言。比尼有五事记。何等五。一者修多罗。二比尼。三义。四教。五轻重。修多罗者。五修多罗。比尼者。二部比尼略广。义者。句句有义。教者。如世尊为刹利婆罗门居士说四大教法。轻重者。盗满五重。减五偷兰遮。是名五事记比尼。长老如是应学。复有五比尼。何等五。一者略比尼。二者广比尼。三者方面比尼。四者坚固比尼。五者应法比尼。略比尼者。五篇戒。广比尼者。二部比尼。方面比尼者。输奴。边地听五事。坚固比尼者。受迦絺那衣舍五罪别众食乃至。不白离同食。应法比尼者。是中法羯磨和合羯磨。是名应法比尼。余者非羯磨。如是集比尼藏竟。唤外千比丘入。语言诸长老。如是集法藏。如是集比尼藏。有比丘言。诸长老。世尊先语阿难。欲为诸比丘舍细微戒。为舍何等。有比丘言。世尊若舍细微戒者。正当舍威仪。有言。不正舍威仪亦当舍众学。有言。亦舍四波罗提提舍尼。有言。亦应舍九十二波夜提。有言。亦应舍三十尼萨耆波夜提。有言。亦应舍二不定法。时六群比丘言诸长老。若世尊在者一切尽舍。大迦叶威德严峻犹如世尊。作是言。咄咄莫作是声。即时一切咸皆默然。大迦叶言。诸长老。若已制复开者。当致外人言。瞿昙在世仪法炽盛。今日泥洹法用颓毁。诸长老。未制者莫制。已制者我等当随顺学。此法从何处闻。从尊者道力闻比尼阿毗昙杂阿含。增一阿含。中阿含。长阿含。道力复从谁闻。从尊者弗沙婆陀罗闻。尊者弗沙婆陀罗复从谁闻。从尊者法胜闻。法胜从谁闻。从尊者僧伽提婆闻。僧伽提婆从谁闻。从尊者龙觉闻。龙觉从谁闻。从尊者法钱闻。法钱从谁闻。从尊者提那伽闻。提那伽从谁闻。从尊者法护闻。法护从谁闻。从尊者耆婆伽闻。耆婆伽从谁闻。从尊者弗提罗闻。弗提罗从谁闻。从尊者耶舍闻。耶舍从谁闻。从尊者差陀闻。差陀从谁闻。从尊者护命闻。护命从谁闻。从尊者善护闻。善护从谁闻。从尊者牛护闻。牛护从谁闻。从尊者巨舍罗闻。巨舍罗从谁闻。从尊者摩求哆闻。摩求哆从谁闻。从尊者摩诃那闻。摩诃那从谁闻。从尊者能护闻。能护从谁闻。从尊者目哆闻。目哆从谁闻。从尊者巨醯闻。巨醯从谁闻。从尊者法高闻。法高从谁闻。从尊者根护闻。根护从谁闻。从尊者耆哆闻。耆哆从谁闻。从尊者树提陀娑闻。树提陀娑从谁闻。从尊者陀娑婆罗闻。陀娑婆罗从谁闻。从尊者优波离闻。优波离从谁闻。从佛闻。佛从谁闻。无师自悟更不从他闻。佛有无量智慧。为饶益诸众生故授优波离。优波离授陀娑婆罗。陀娑婆罗授树提陀娑。树提陀娑如是乃至授尊者道力。道力授我及余人

  我等因师教　　从无上尊闻
  闻持诵比尼　　贤圣所行法
  世尊内法藏　　绍继释迦后
  各各共护持　　令法得久住

是名五百结集法藏竟

摩诃僧祇律卷第三十二摩诃僧祇律卷第三十三

        东晋天竺三藏佛陀跋陀罗共法显译

    明杂诵跋渠法之十一

七百集法藏者。佛般泥洹后。长老比丘在毗舍离沙堆僧伽蓝。尔时诸比丘从檀越乞索。作如是哀言。长寿。世尊在时得前食后食衣服供养。世尊泥洹后。我等孤儿谁当见与。汝可布施僧财物。如是哀声而乞。时人或与一罽利沙槃二罽利沙槃乃至十罽利沙槃。至布萨时盛着盆中。持拘钵量分次第而与。时持律耶舍初至次得分。问言。此是何物。答言。次得罽利沙槃医药直。耶舍答言过去。问言何故过去施僧。耶舍答言不净。诸比丘言。汝谤僧言不净。此中应作举羯磨。即便为作举羯磨。作举羯磨已。时尊者陀娑婆罗在摩偷罗国。耶舍即往诣彼作是言。长老。我被举行随顺法。问言。汝何故被举。答言。如是如是事。彼言。汝无事被举。我共长老法食味食。耶舍闻是语已作是言。诸长老。我等应更集比尼藏。勿令佛法颓毁。问言。欲何处结集。答言。还彼事起处。时摩偷罗国僧伽舍羯闹耆舍卫城沙只。尔时中国都有七百僧集。有持一部比尼二部比尼者。又从世尊面受者。又从声闻受者。时有凡夫学人无学人三明六通得力自在七百僧集毗舍离沙堆僧伽蓝。严饰床褥。尔时大迦叶达头路优波达头路尊者阿难皆已般泥洹。尔时尊者耶输陀僧上座。问言。谁应结集律藏。诸比丘言。尊者陀娑婆罗应结集。陀娑婆罗言。长老。更有余长老比丘应结集。诸比丘言。虽有诸上座。但世尊记长老和上成就十四法。持律第一。汝从面受。应当结集。陀娑婆罗言。若使我结集者。如法者随喜。不如法者应遮。若不相应者应遮。勿见尊重。是义非义愿见告示。皆言。尔时尊者陀娑婆罗作是念。我今云何结集律藏。有五净法。如法如律者随喜。不如法者应遮。何等五。一者制限净乃至风俗净。作是语。诸长老。是九法序。何等九。从四波罗夷乃至法随顺法。世尊在某处某处为某甲某甲比丘制戒。我从和上闻。为如是制此戒不皆言如是如是。五事记比尼广说如上。乃至诸长老。是中须钵者求钵须衣者求衣。须药者求药无有方便得求金银及钱。如是诸长老应当随顺学。是名七百结集律藏。略说比尼者。佛在迦维罗卫尼拘律树释氏精舍。时有二比丘尼。一名难陀。二名郁多罗。随佛六月求教诫法。白佛言。善哉世尊。愿为我略说比尼。使我得解佛告比丘尼。贪欲不解因缘。共相习狎论说俗事。增长受阴。多欲不知止足。增贪欲嗔恚愚痴。诤讼不和合。非寂非觉非泥洹。当知非法非比尼非佛教。当作是知。无欲解因缘。不相狎习离俗言论。不增受阴。少欲知足。无贪欲嗔恚愚痴。离诤讼和合。寂静觉泥洹。如是当知。是法是比尼是佛教。是名略说比尼

  刀治及灌筒　　剃发并作具
  和合不和合　　五百与七百
  略说比尼后　　第十跋渠竟

毁呰者。佛住舍卫城。时六群比丘方类毁呰比丘。诸比丘以是因缘具白世尊。佛言。呼六群比丘来。来已佛问比丘。汝实尔不。答言实尔。佛言。此是恶事。从今日后不听毁呰。毁呰者。业方面姓形貌病罪骂结使。业者。说自解有人说者。长老。此中有旃陀罗竹师皮师瓦师乃至狱卒魁脍。是名说自解者。长老。我非旃陀罗乃至魁脍狱卒。是名自解。有人者。此中或有人是旃陀罗乃至狱卒。是名有人。如是方面姓形貌病罪结使亦如是。是中毁呰越比尼罪。是名毁呰

伎乐者。佛住王舍城加兰陀竹园。时六群比丘先至作乐处。视占如坐禅比丘。伎儿既集作众伎乐。众人悦乐喜笑。比丘默然。众人笑已。比丘方更拍手大笑。众人竞看。伎儿不得雇直。嫌言。坐是比丘令我等不得财物。此败坏人何道之有。诸比丘闻已以是因缘具白世尊。佛言。呼六群比丘来。来已佛问比丘汝实尔不。答言。实尔世尊。佛言。此是恶事。从今日后。不听观看伎儿。伎儿者。打鼓歌舞弹琵琶铙铜。钹如是比种种伎。乐下至四人聚戏不听。看若比丘入城聚落若天象出若王出。翼从作种种伎乐。过行观见无罪。若作方便看越比尼罪。若佛生日大会处。菩提大会处。转法轮大会。五年大会。作种种伎乐供养佛。若檀越言。诸尊者。与我和合翼从世尊。尔时得与和合在坐。若坐中有种种伎乐生染着心者。即应起去。是名伎乐

香华者。佛住王舍城。时节会日。六群比丘难陀优波难陀。以香涂身。着优钵罗华鬘瞻卜华鬘。有着草华鬘共行。为世人所嫌。云何沙门释子。着优钵罗华瞻卜华鬘。犹如王子大臣。又如作使贱人。着草华鬘。此坏败人何道之有。诸比丘闻已以是因缘往白世尊。佛言。呼六群比丘来。来已佛问比丘。汝实尔不。答言。实尔世尊。佛言。从今日后。不听着香花。香者。栴檀沉水。如是比一切香皆不应着。若热病。医言。当须旃檀香涂。尔时得用香涂。若欲涂时。先应供养佛泥塔。然后涂身。涂身已不得在众中。当在屏处。病差净澡。浴身然后入众。华者。优钵罗瞻卜须摩那。如是一切华不应着。若比丘患眼痛头痛。医教言当须华鬘系头差者得系。若欲系者当先供养佛塔。然后得系。系已不得在众人中。当在屏处。差已当舍。若着香不着华。一越比尼罪。若着华不着香一越比尼罪。二俱着犯二罪。俱不着无罪。是名香华法

镜法者。佛住舍卫城只桓精舍。有檀越饭僧打揵椎。时难陀优波难陀照镜自观。停久不至。为檀越所嫌。我舍弃家业故来饭僧。而诸比丘不时来集。诸比丘以是因缘往白世尊。佛言。呼难陀优波难陀来。来已佛问难陀优波难陀。汝实尔不。答言实尔。佛言。从今日后。不听照镜。镜者。油中水中镜中。不得为好故照面自看。若病差照面自看病差不差若新剃头自照看净不净。头面有疮照看无罪。为好故照镜。越比尼罪。是名镜法

担法者。佛住旷野精舍。尔时营事比丘。持担辇塼泥土。为世人所讥。云何沙门释子。似奴仆使人客作人担负泥土。此坏败人何道之有。诸比丘以是因缘往白世尊佛言。呼营事比丘来。来已佛问比丘。汝实尔不。答言实尔。佛言。从今日后不听担。担者。绳囊担笼担。担杖不担囊。越比尼心悔。担囊不担杖。越比尼心悔二俱担越比尼罪。若精舍院内石竹木重者得担。若僧次作使瓨瓶得绳连担。若前后担衣囊前后担钵。俱越比尼罪。若长衣囊拖着肩上钵串肩无罪。是名担法

抄系衣者。佛住旷野精舍。时营事比丘。抄系衣辇塼石泥土。为世人所讥。云何沙门释子。如奴仆使人。抄系衣作。是坏败人何道之有。诸比丘闻已以是因缘往白世尊。佛言。呼营事比丘来。来已佛问比丘。汝实尔不。答言实尔。佛言。从今已后。不听抄系。抄系者。一边两边抄系尽不得。若泥土作为覆屋泥屋。得抄系内衣。是名抄系法

上树者。佛住舍卫城。尔时世尊往郁单越乞食。时诸比丘作是念。世尊还者。必乘神足来。或上树上墙遥望世尊。世尊知诸比丘心念。即隐身自坐本座。佛知而故问。诸比丘何处去。比丘即以上事具白世尊。佛言。从今日后不听上树。树者。树共人等不得上。若作菩提大会。欲庄严菩提树。一脚登树一脚登墙。越比尼心悔。二脚上树。越比尼罪。二脚上墙无罪。登梯亦如是。若道路行失道。迷不知方面。得上树望无罪。若为虎狼师子。如是比恐怖得上树无罪。是名树法。火法者。佛住舍卫城。尔时世尊到时着入聚落衣。持钵入城次行乞食还。自并床褥不语侍者及比丘僧。往拘萨罗国波利邪娑罗林贤树下。受象王三月供养。乃至非时寒雪。诸比丘自然火向。为世人所嫌。沙门瞿昙无量方便毁呰杀生赞叹不杀。而今比丘然火烧地扰傍一根。诸比丘以是因缘往白世尊。乃至佛言。从今已后不听然火火者。薪火草火牛屎火糠火札火。不得烧未烧地。若次直温室若直月若熏钵。先使净人知。然后自烧无罪。若持炬行欲抖擞。炬者不得在未烧地。当在灰上若瓦上。若炬火自落地。即在上抖擞无罪。若未烧地中然火。越比尼罪。是名火法

铜盂法者。佛住王舍城。尔时郁竭居士大施五百象五百马五百牛五百水牛五百婢五百奴。种种杂施中有铜盂。诸比丘心生疑往问世尊。是净不净应受不受。佛言。一切铜盂不听受。若施僧净器应为咒愿受。若私畜铜盂。越比尼罪。得施净人已用无罪。是名铜盂法

回向者。佛住舍卫城。诸天世人信心尊重。持种种饭食来供养佛比丘僧。尊者舍利弗大目连及诸比丘。时六群比丘晨朝至精舍门下立。见世人持饭食来。问言。此食与谁。答言与世尊。即语言。世尊应供养。次问。此复与谁。答言与僧。即语言。僧应供养。次问。此复与谁。答言。与尊者舍利弗大目连。语言。此人应供养。次问。此复与谁。答言。与某甲比丘。即便语言。某甲老病不能啖食。但弃汝食当施我。我为汝咒愿。使汝得食用功德。时人直信即便施之有黠慧者不与。作是言。我何故与是无惭愧人。诸比丘以是因缘往白世尊。乃至佛问比丘。汝实尔不。答言实尔。佛语六群比丘。此是恶事。汝云何知物向他。而回向己。从今日后。不听知物向他自回向己。物者八种。时食乃至净不净。如上广说。若人问言。尊者。我欲布施当施何处。答言施僧。若复问言。何处有持戒僧。应语言。无有犯戒僧汝但施。若问言。何处有比丘。能常一处修习行业。令物久在使我常见。尔时得语某甲比丘可与。知物向僧自回向己。尼萨耆波夜提。知物向僧回向他。波夜提。知物向众多人回向众多人。知物向一人回向一人。越比尼罪。下至知物向畜生回向余畜生。越比尼心悔。是名回向法

  毁呰观伎儿　　华鬘并镜法
  担持抄系衣　　上树自然火
  铜盂回向物　　十一跋渠竟

众生者。佛住王舍城。尔时郁竭居士大施五百象乃至五百奴婢。诸比丘心生疑悔往问佛言。净不净应受不应受。佛言一切众生不听受。众生者。象马牛水牛驴羊獐鹿猪奴婢如是及余一切众生不应受。若人言我施僧婢不听受。若言我施僧园民妇不听受。若言施僧奴不听受。若言施僧使人不应受。若言供给僧男净人听受。若别施一人婢不听受。若奴若使人若园民不听受。若施净人为料理僧故得受。若施尼僧奴不听受若施园民不听受。若施婢不听受。若言供给尼僧女净人听受。若别施一比丘尼奴不听受。若施园民不听受。若施净女人为料理僧故得受。若檀越作佛生日大会菩提大会转法轮大会罗睺罗大会阿难大会五年大会檀越信心欢喜庄严象马布施众僧者不听受。若檀越持鹦鹉孔雀鸡羊獐鹿与不听受。若言不受者我当杀之。应语言。汝自放已。应与水食守护勿令众生伤害。不得剪翅羽笼系。若能飞能行自活放去莫拘制。若受众生者。越比尼罪。是名众生法

树法者。佛住舍卫城。尔时檀越僧园中种庵婆罗树。有一比丘截取。为一居士作房。房成施床褥请僧供养。时种庵婆罗树檀越亦在会中。见已问言。尊者此是谁房。比丘言。是某甲居士房。时檀越言。尊者何故取我树为他作房。此房即是我房。心犹不悦。即往诣佛所头面礼足却住一面。即以上事具白世尊。佛为说法示教利喜。前礼佛足欢喜而去。佛言。呼彼比丘来。来已佛问比丘。汝实尔不。答言实尔。佛言。汝云何斫截华果树作房。从今已后不听斫华果树。斫华果树者。庵婆罗树阎浮树毗罗树迦毗陀树叵那娑树椰子树无忧树瞻婆树枳萨罗树阿提目多树。如是比一切华果树不听斫作房。若树老无华果者。应语檀越言。长寿。是树已老。又须作房舍安置比丘得受用福。若主听得取。不听不得取。若必须木用复妨地者。使净人以鱼骨刺。若灰汁浇。若树已死。应语檀越言。此树已干欲须用。若听者取用。若比丘斫花果树者。越比尼罪。是名树法

樵木法者。佛住舍卫城尔时聚落边有精舍。客比丘来斫伐樵薪。旧比丘言。汝何故斫截我等勤苦种殖。汝客来但逐荫凉坐。不能助爱护。而狼藉称意。明日便去不知我苦。如是语已。旧比丘乞食去后。客比丘干生合斫房前积聚然火。旧比丘乞食还见已即言。汝何故干生合斫积聚然火。客比丘言。汝何故自取然火而反遮我。如是诤已。二比丘往诣佛所。头面礼足具白上事。佛语诸比丘。汝不得自取遮他。亦应当护。不得干生合斫房前积聚然樵薪。然法者。然有准则。尔许温室中然。尔许厨下然。尔许浴室中然。尔许别房中然。当分应从限。不得过取。若然无定限者。多亦无罪。不听斫湿树木应取乾者。僧坊内树木观望好者不得斫。山林无主守护者斫无罪。是名樵薪法

华法者。佛住舍卫城。聚落边有僧伽蓝。时客比丘来取华。旧比丘言。汝何以取华。我等勤苦种殖守护溉灌。汝客来但逐凉坐。不欲料理狼藉称意。明日便去不知我苦。如是语已。旧比丘乞食去后。客比丘成华不成华。合折狼藉积置房前。旧比丘乞食还见花聚即言。汝何故取华。客比丘言。汝何故自取而反遮我。如是诤已。俱往诣佛具白上事。佛语旧比丘。汝不得自取遮他。应当爱护。客比丘复不得成不成合折积聚房前。有五法成就。应拜作分花人。何等五。不随爱不随嗔。不随痴。不随怖。知得不得。是名五法。羯磨者应作是说。大德僧听。某甲比丘五法成就。若僧时到。僧拜某甲比丘作分花人。如是白。白一羯磨。乃至僧忍默然故。是事如是持。是比丘受羯磨已。应使净人知花。若花小者应器量分若手作准则。若优钵罗花瞻卜钵头摩分陀利。如是等大花应数分。若佛花者应上佛。若僧花者随意供养若转易。若花多者可与华鬘家。语言。汝日日与我尔许鬘。余者与我尔许直。得直已得用作别房衣。若前食后食。若犹多者当着。无尽财中。是名花法。果法者。如上花中说。乃至拜羯磨已。当使净人知。果若细者当量分。若以手为限。若大者如多罗果毗罗果椰子果娑那沙果庵婆罗果。如是等当数分。若多者应与贩果人。日日应与我尔许果。余者与我尔许直。得直已应着前食后食中。若犹故多者当着无尽财中。是名果法。种树法者。佛住舍卫城。尔时有比丘。于僧地中种庵婆罗果。长养成树。自取其果不令他取。诸比丘言。汝何故自取遮他。答言。我种此树护令长大。诸比丘以此因缘往白世尊。佛言。此种殖有功听。一年与一树。年法者。若比丘僧地种庵婆罗果树阎浮树。如是比果树应与一年取。若树大不欲一年并取者。听年年取一枝。枝遍则止。若种一园树者。应与一年。若言我欲年取一树亦听若种芜菁若葱。如是比菜应与一剪。若种瓜瓠。应与一番熟取。是名种树法。治罪法者。有行口行身口行。身不摄故犯。口不摄故犯。身口不摄故犯。身作口作身口作。是名罪法。无罪者。身无行口无行身口无行。身摄故不犯。口摄故不犯。身口摄故不犯。身不作口不作身口不作。是名非罪治罪者。波罗夷罪当云何治。若作俗人。若与作学沙弥。若僧中驱出。僧伽婆尸沙罪云何治。若不覆藏应行摩那埵阿浮呵那。覆藏者与别住行摩那埵阿浮呵那。尼萨耆者当云何治。随前物应僧中舍舍已若上座应头面作礼执足。若下座应胡跪合掌作如是言。长老。我犯长衣已僧中舍。波夜提罪我今悔过。应问。汝见是罪不。答言见。应语言。更莫作。答言顶戴。持波夜提波罗提提舍尼越比尼罪。但名差别亦如是治。是名治罪法

  众生并种树　　薪积与华果
  种殖听一年　　罪非罪治法
  十二跋渠竟

灭者有七。何等七。现前比尼。忆念比尼。不痴比尼。自言比尼。觅罪相比尼。多觅比尼。草布地比尼。是名灭。诤事者四诤事。何等四。相言诤。诽谤诤。罪诤。常所行事诤。是名四灭诤事。调伏者。折伏羯磨。不语羯磨。驱出羯磨。发喜羯磨。举羯磨别住羯磨。是名调伏。调伏事者。五众罪。波罗夷。僧伽婆尸沙。波夜提。波罗提提舍尼。越比尼罪。是名调伏事

听法者。佛住舍卫城。尔时诸比丘白佛言。世尊。听我作草屋不。佛言听。如是作壁作户扇作户楣格作白泥作五种画不。佛言听。佛告诸比丘。如过去世。时有王名曰吉利。为迦叶佛作精舍。一重二重乃至七重。雕文刻镂。种种彩画唯除男女和合像。种种者。所谓长老比丘像葡萄蔓摩竭鱼鹅像死尸之像山林像。如是比一切是名五种画。佛住舍卫城听作房。毗舍离听乳酪酥。旷野听鱼肉。如是一切听一切制皆在八大城。一舍卫。二沙只。三瞻婆。四波罗柰。五拘睒弥。六毗舍离。七王舍城。八迦毗罗卫。是九部经若忘说处者。是八大城趣举一。即名是处世尊所印。是名听法。涂面油者。佛住舍卫城。尔时精舍中檀越饭僧。时难陀优波难陀。闻揵椎鸣方以油涂面。住不时出故。为檀越所嫌。诸比丘以是因缘往白世尊。佛言。唤是比丘来。来已佛问比丘。汝实尔不。答言实尔。佛言。从今已后。不听油涂面。油者。胡麻油大麻油阿提目多华油瞻婆花油。如是等比香油。为好故涂面者。越比尼罪。若洗浴时得用油。若澡豆屑末涂足油着手得用拭面无罪。是名油法

粉法者。佛住舍卫城。尔时祇洹精舍有檀越设供饭僧。时六群比丘闻揵椎鸣。方以粉拭面不时出。为檀越所嫌。诸比丘以是因缘往白世尊。乃至佛言。从今日后不听比丘以粉拭面。粉者。摩那石粉铅锡粉如是比。若为好故。乃至赤土涂面。越比尼罪。若面有疮痈痤肿起得涂无罪。涂时不得在众人中。当在屏处。是名粉法

刷法者。佛住舍卫城。乃至六群比丘刷头住不时出。为檀越所嫌。诸比丘以是因缘往白世尊。乃至佛言。不听比丘用刷刷头。刷者。毛刷草刷草根刷。如是比下至手刷为。好故越比尼罪。若剃发已得手摩无罪。是名刷法

梳法者。佛住舍卫城。世尊制戒。不听用刷。时有檀越饭僧。难陀优波难陀。闻揵椎鸣方以梳梳头。而住不时得出。为檀越所嫌。乃至佛言。不听用梳。梳者。牙梳骨梳角梳木梳。如是比一切梳不听用。下至以手梳头为好故。越比尼罪。是名梳法。发簪者。佛住舍卫城。世尊制戒不得用梳。乃至六群比丘用簪搔头。不时得出。为檀越所嫌。乃至佛言。不听用簪。簪者。金银铜铁鋀石牙骨角竹木。如是比一切不听。乃至以豪猪猎。为好故用刷头。越比尼罪。若手已净头故痒者。得持物搔。是名簪法

  七灭并灭事　　调伏调伏事
  听法油涂面　　粉刷梳以簪
  十三跋渠竟

塔法者。佛住拘萨罗国游行。时有婆罗门耕地。见世尊行过。持牛杖住地礼佛。世尊见已便发微笑。诸比丘白佛。何因缘笑。唯愿欲闻。佛告诸比丘。是婆罗门今礼二世尊。诸比丘白佛言。何等二佛。佛告比丘。礼我当其杖下有迦叶佛塔。诸比丘白佛。愿见迦叶佛塔。佛告比丘。汝从此婆罗门。索土块并是地。诸比丘即便索之。时婆罗门便与之。得已尔时世尊即现出迦叶佛七宝塔。高一由旬。面广半由延。婆罗门见已即便白佛言。世尊。我姓迦叶。是我迦叶塔。尔时世尊即于彼处作迦叶佛塔。诸比丘白佛言。世尊。我得授泥不。佛言得授。即时说偈言

  真金百千担　　持用行布施
  不如一团泥　　敬心治佛塔

尔时世尊自起迦叶佛塔。下基四方周匝栏楯。圆起二重方牙四出。上施槃盖长表轮相。佛言。作塔法应如是。塔成已世尊敬过去佛故。便自作礼。诸比丘白佛言。世尊我等得作礼不。佛言得。即说偈言

  人等百千金　　持用行布施
  不如一善心　　恭敬礼佛塔

尔时世人闻世尊作塔。持香华来奉世尊。世尊恭敬过去佛故。即受华香持供养塔。诸比丘白佛言。我等得供养不。佛言得。即说偈言

  百千车真金　　持用行布施
  不如一善心　　华香供养塔

尔时大众云集。佛告舍利弗。汝为诸人说法。佛即说偈言

  百千阎浮提　　满中真金施
  不如一法施　　随顺令修行

尔时坐中有得道者。佛即说偈言

  百千世界中　　满中真金施
  不如一法施　　随顺见真谛

尔时婆罗门得不坏信。即于塔前饭佛及僧。时波斯匿王闻世尊造迦叶佛塔。即敕载七百车塼来诣佛所。头面礼足白佛言。世尊。我欲广作此塔为得不。佛言得。佛告大王。过去世时。迦叶佛般泥洹时。有王名吉利。欲作七宝塔。时有臣白王言。未来世当有非法人出。当破此塔得重罪。唯愿王当以塼作金银覆上。若取金银者塔故在得全。王即如臣言以塼作。金薄覆上。高一由延。面广半由延。铜作栏楯。经七年七月七日乃成。作成已香华供养及比丘僧。波斯匿王白佛言。彼王福德多有珍宝。我今当作不及彼王。即便作经七月七日乃成。成已供养佛比丘僧。作塔法者。下基四方周匝栏楯。圆起二重方牙四出。上施槃盖长表轮相。若言世尊已除贪欲嗔恚愚痴用是塔为。得越比尼罪。业报重故。是名塔法。塔事者。起僧伽蓝时。先预度好地作塔处。塔不得在南不得在西。应在东应在北。不得僧地侵佛地。佛地不得侵僧地。若塔近死尸林。若狗食残持来污地。应作垣墙。应在西若南作僧坊。不得使僧地水流入佛地。佛地水得流入僧地。塔应在高显处作。不得在塔院中浣染晒衣着革屣覆头覆肩涕唾地。若作是言。世尊贪欲嗔恚愚痴已除用是塔为。得越比尼罪。业报重。是名塔事。塔龛者。尔时波斯匿王往诣佛所。头面礼足白佛言。世尊。我等为迦叶佛作塔。得作龛不。佛言得。过去世时。迦叶佛般泥洹后。吉利王为佛起塔。四面作龛。上作师子象种种彩画。前作栏楯安置花处。龛内悬缯幡盖。若人言世尊贪欲嗔恚愚痴已除。但自庄严而受乐者。得越比尼罪。业报重。是名塔龛法。塔园法者佛住舍卫城。尔时波斯匿王往至佛所。头面礼足白佛言。世尊。我得为迦叶佛塔作园不。佛言得作。过去世时。有王名吉利。迦叶佛般泥洹后。王为起塔。塔四面造种种园林。塔园林者。种庵婆罗树阎浮树颇那娑树瞻婆树阿提目多树斯摩那树龙华树无忧树。一切时华。是中出华应供养塔。若檀越言。尊者是中华供养佛果与僧。应从檀越语。若花多者得与华鬘家。语言。尔许华作鬘与我。余者与我尔许直。若得直得用然灯买香以供养佛得治塔。若直多者得置着佛无尽物中。若人言佛无淫怒痴用是华果园为。得越比尼罪。果报重。是名塔园法

塔池法者。佛住舍卫城。乃至佛告大王。过去迦叶佛泥洹后。吉利王为迦叶佛塔。四面作池。种优钵罗华波头摩华拘物头分陀利种种杂华。今王亦得作池。池法者。得在塔四面作池。池中种种杂华供养佛塔。余得与华鬘家。若不尽得置无尽物中。不得浣衣澡洗手面洗钵。下头流出处得随意用无罪。是名塔池法。塔枝提者。佛住舍卫城。乃至佛语大王。得作枝提。过去迦叶佛般泥洹后。吉利王为迦叶佛塔。四面起宝枝提。雕文刻镂种种彩画。今王亦得作枝提。有舍利者名塔。无舍利者名枝提。如佛生处得道处转法轮处般泥洹处菩萨像辟支佛窟佛脚迹。此诸枝提得安佛华盖供养具。若有言佛贪欲嗔恚愚痴已断用是精舍供养为。得越比尼罪。业报重。是名塔枝提

供养具者。佛住舍卫城。乃至诸比丘白佛言。世尊。得持塔供养具供养枝提不。佛言得。若佛生日得道日转法轮日五年大会日。当此时得持供养中上者供养佛塔。下者供养枝提。若有言佛淫怒痴已尽用是幡盖供养为。得越比尼罪。业报重。是名枝提法

伎乐供养者。佛住舍卫城。时波斯匿王往诣佛所。头面礼足却住一面而白佛言。世尊。得持伎乐供养佛塔不。佛言得。迦叶佛般泥洹后。吉利王以一切歌舞伎乐供养佛塔。今王亦得。佛言。若如来在世若泥洹后。一切华香伎乐种种衣服饮食尽得供养。为饶益世间令一切众生长夜得安乐故。若有人言世尊无淫怒痴用此伎乐供养为。得越比尼罪。业报重。是名伎乐法。收供养具者。佛住舍卫城。尔时诸比丘白佛言。世尊。我等得收枝提供养具不。佛言得。收者。若佛生日得道日转法轮日五年大会日。名出幡盖供养枝提。若卒风雨一切众僧应共收。不得言我是上座。我是阿练若。我是乞食。我是粪扫衣。我是大德。汝等依是活者自应收。若风雨卒来应共收。随近房应安。不得护房言着先处。若湿者应晒。尘土坌者应抖擞叠举。若言我是上座我是阿练若我是乞食我是粪扫衣我是大德者。得越比尼罪。是名收供养具法

难者。佛住舍卫城。时尊者优波离往诣佛所。头面礼足白佛言。世尊。若塔物僧物难起者当云何。佛言。若外贼弱者。应从王求无畏。王若言。尊者但住莫畏若我后事不立者随意。尔时应量王力强弱。贼强者应密遣信往贼主所求索无畏。王若言我今自恐不立何得无畏。尊者自可从贼索救护者应去。若贼是邪见不信佛法者。不可归趣者。不得便舍物去。应使可信人藏佛物僧物。当先探候看贼。不可令奄尔卒至。若贼来急不得藏者。佛物应庄严佛像。僧坐具应敷安置。种种饮食令贼见相当使年少比丘在屏处伺看贼至。贼见供养具若起慈心作是问。有比丘不。莫畏可来出。尔时年少比丘应看。若贼卒至不得藏物者。应言一切行无常。作是言已舍去。是名难法

  塔法并塔事　　塔龛及塔园
  塔池及枝提　　伎乐供养具
  收捡香花难　　十四跋渠竟
  具足举羯磨　　举事并布萨
  病法比尼事　　重物及食蒜
  为杀并刀治　　方便受众生
  灭偷婆法后

摩诃僧祇律卷第三十三摩诃僧祇律卷第三十四

        东晋天竺三藏佛陀跋陀罗共法显译

    明威仪法之一(上坐法)

佛住舍卫城。尔时比丘僧集欲作布萨。比丘尽集。时难陀为僧上座不来。有檀越持物来。待僧和合已欲布施。问僧集未。答言未集。复问谁不来。答言。僧上座不来。檀越嫌言。我待僧集欲有所施。而上座不来。待良久便布施而去。上座逼暮方来。竟不行舍罗。复不唱不来。诸比丘说欲清净。直略说四事而去。年少比丘问言。上座来未。答言。上座来已还去。年少比丘嫌言。云何上座来亦不使人知。去亦不使人知。诸比丘以是因缘往白世尊。佛言。呼难陀来。来已佛问难陀。汝实尔不。答言实尔。佛言。从今日后。僧上座应如是知。云何如是知上座法应知。今十四日若十五日布萨。中间布萨若昼若夜。当知处所。若温室讲堂若林中。应广诵五篇戒下至四事及偈。余者僧常闻。若城邑聚落中有比丘者。上座应令人唱。今僧十四日若十五日若食前食后。尔许人影在某处布萨。应先使人扫地泥治散众花已。谁应咒愿诵戒行舍罗。上座应知。说戒时僧未集有檀越来者。上座应为说法共相劳问。若不能者。应请第二上座。若法师为说法布萨时至者。应问檀越欲去住。若言去者。应与咒愿发遣令去。住者应遣出已作布萨。有者应香汤洗舍罗已行。若坐希者应一人行一人收。不得覆头覆肩行筹。应脱革屣偏袒右肩行筹。受筹人亦如是。先行受具足人筹。然后行沙弥筹行已应白。尔许受具足人。尔许沙弥。合有尔许人。僧上座应诵戒。若不能者。次第二上座诵。若复不能。乃至能诵者应诵。诵时若逼暮天阴风雨。有老病人不堪久坐。住处远有王难贼难。尔时得略诵。若日早无上诸难者应广诵。若上座自诵。若余人诵。若和合竟夜说法论议问答咒愿。上座布萨法应如是。若不尔者越威仪法

佛住。舍卫城。尔时比丘僧集欲作布萨。第一上座来。第二上座不来。时檀越持物来欲布施。问僧集未。答言未集。问谁不来。答言。第二上座不来。檀越嫌言。我欲少有所施。第二上座不来。待良久不来。便布施而去。第二上座逼暮方来。上座嫌言。世尊独制我。第二上座便不问耶。诸比丘以是因缘往白世尊。佛言。呼是比丘来。来已佛问比丘。汝实尔不。答言实尔。佛言。从今日后。布萨时第二上座亦应如是知。云何如是知。一切如上座中广说。但以第二上座为异耳。若僧上座不能者。第二上座应知。若不如是者越威仪法

佛住舍卫城。尔时比丘僧集欲作布萨。上座第二上座来。余人彷徉不时来集。上座第二上座嫌言。世尊独制我。不制余人耶。诸比丘以是因缘。往白世尊。佛言。呼是诸比丘来。来已佛问。汝实尔不。答言。实尔世尊。佛言。从今日后。布萨事一切僧应如是知。云何如是应知。月一日二日乃至十四日十五日。布萨中间布萨日处所应知。若人问今是几日。不得逆问昨日是几日。要当知。若恐忘者。应作筹绳穿悬讲堂前若食厨前。直月知事人日过一筹。布萨日广诵五篇戒乃至四事及偈。余者僧常闻。一切如上座中广说。但一切为异。若上座第二上座复不能者。余一切尽应知。若不如是越威仪法

佛住舍卫城。尔时祇洹精舍檀越设供饭比丘僧。第一上座不来。羹饭已冷。檀越言。比丘僧集未。答言未集。谁不来。答言。第一上座不来。檀越嫌言。我舍家业来欲饭僧。而比丘不集。上座时至方来。亦不叹食咒愿。狼狈食已便去。年少问言。上座来未。答言。已来食竟便去。年少嫌言。上座来亦不令人知。去亦不令人知。诸比丘以是因缘往白世尊。佛言。呼难陀来。来已佛问汝实尔不。答言实尔。佛言。从今日后。僧上座食应如是知。云何如是知。今日谁施食。为二部众。为一部众。为别房请。聚落中若精舍中应知。若有人请明日饭僧。僧上座不得即受。应知前请人姓名客旧巷陌处所。恐有人试弄比丘故不应即受。若有人识彼请人男女得受请。受请已不得便随去。至明旦应遣直月若园民若沙弥往看之。或遭县官水火盗贼产生死亡不能得办。若有此难。僧应自办食。若无者语令乞食。使往问请主食办未若言是何人是何食。当知彼诳。若僧伽蓝有食应办常食。若无应唱言比丘僧被诳。各自乞食。若请主言尊者正尔办。是时上座应知时。若冬时应一切集已共去。若春夏时。应前后去。若到彼请家日早食未办欲余行。应白比丘。我欲至某甲家。若食办者莫待我。去已应早还。入檀越家时。上座应知坐左右。若檀越作吉祥会。右敷座者应坐。若为饿鬼会。左敷座者亦应坐。若敷长净坐具。急者应以手按令缓。徐徐坐不得使裂。若不急者不得顿身坐。或下有器物眠小儿。先应一手按座。不得持腻钵及饼果着上。不得用拭手。上座当知谁看房谁病。应语与食。若檀越惜者。应语言。长寿。法应与。不得不与。若日早者应着行取。若日晚者应先取发遣令去。僧上座应知前人为何等施。当为应时咒愿。若檀越行食时。多与上座者。上座应问一切僧尽得尔许不。答言止上座得耳。应语言一切平等与。若言尽得者应受。若须少取少。下者应语多与。若乳酪饼肉酥如是比好食。尽应语平等与。僧上座法不得随下便食。应待行遍唱等供已然后得食。上座法当徐徐食。不得速食竟住看令年少狼狈食不饱。应相望看。不得食竟便在前出去。应待行净水。随顺咒愿已然后乃出。若为亡人施福者。不应作是吉祥叹

  贤善已无常　　今是吉祥日
  种种设肴膳　　供养良福田

应作如是咒愿

  一切众生类　　有命皆归死
  随彼善恶行　　自受其果报
  行恶入地狱　　为善者生天
  若能修行道　　漏尽得泥洹

若生子设福者。不应作如是说

  僮子弃冢间　　[口*束]指七日活
  不遭蚊虻害　　僮子功德力
  应如是咒愿
  僮子归依佛　　如来毗婆施
  尸弃毗叶婆　　拘楼拘那鋡
  迦叶及释迦　　七世大圣尊
  譬如人父母　　慈念于其子
  举世之乐具　　皆悉欲令得
  令子受诸福　　复倍胜于彼
  室家诸眷属　　受乐亦无极

若入新舍设供者。不得作是说

  若火烧屋时　　得出中所有
  必为己财宝　　不为火所焚

应作如是咒愿

  屋舍覆荫施　　所欲随意得
  吉祥贤圣众　　处中而受用
  世有黠慧人　　乃知于此处
  请持戒梵行　　修福设饮食
  僧口咒愿故　　宅神常欢喜
  善心生守护　　长夜于中住
  若入于聚落　　及以旷野处
  若昼若于夜　　天神常随护

若估客欲行设福者。不应作是说

  一切诸方面　　贼难不可行
  今正是其时　　出家修梵行

应作如是说

  诸方皆安隐　　诸天吉祥应
  闻已心欢喜　　所欲皆悉得
  两足者安隐　　四足者亦安
  去时得安隐　　来时亦安隐
  夜安昼亦安　　诸天常护助
  诸伴皆贤善　　一切悉安隐
  康健贤善好　　手足皆无病
  举体诸身分　　无有疾苦处
  若有所欲者　　去得心所愿

东方有七星。常护世间令得如愿。一名吉利帝。二名路呵尼。三名僧陀那。四名分婆[口*束]。五名弗施。六名婆罗那。七名阿舍利。是名七星。在东方常护世间。今当护汝令得安隐得利早还。一切星宿皆当护汝。复次东方有八天女。一名赖车摩提。二名尸沙摩提。三名名称。四名耶输陀罗。五名好觉。六名婆罗湿摩。七名婆罗浮陀。八名阿毗呵罗。是名八天女。在东方常护世间。有天王名提头赖吒。揵闼婆王及一切诸天常护汝等。普令安隐得利早还。东方有支提名弓杖。常出光明。诸天恭敬供养。是一切供养天。当护汝令得财利安隐早还。南方有七星。常护世间。一名摩伽。二三同名颇求尼。四名容帝。五名质多罗。六名私婆帝。七名毗舍佉。是名七星。在南方常护世间。今当护汝令安隐得利早还。一切星宿皆当护汝。南方有八天女。一名赖车魔帝。二名施师魔帝。三名名称。四名名称持。五名好觉。六名好家。七名好力。八名非断。常护世间。有天王名毗留荼。俱魔荼鬼神王。共护汝等得利早还。南方有支提名阿毗钵施。常放光明。诸天恭敬供养。一切供养支提诸天。常护汝等安隐得利早还。西方有七星。常护世间。一名不灭。二名逝吒。三名牟逻。四名坚强精进。五六同名阿沙荼。七名阿毗阇摩。是名七星。常护世间。当护汝等得利早还。一切星宿皆当护汝。西方有八天女。一名阿蓝浮婆。二名杂发。三名阿利吒。四名好光。五名伊迦提舍。六名那婆私迦。七名既色尼。八名沙陀罗。是名八天女。有天王名毗留博叉。常护世间。有龙王名婆留尼。及一切诸龙当护汝等得利早还。西方有山名饶益。日月居中。若有所求得心所愿。北方有七星。常护世间。一名檀尼吒。二三同名世陀帝。四名不鲁具陀尼。五名离婆帝。六名阿湿尼七名婆罗尼。是名七星。常护世间。当护汝等得利早还。一切星宿皆当护汝。北方有八天女。一名尼罗提毗。二名修罗提毗。三名俱吒毗。四名波头摩。五名呵尼。六名波利。七名遮逻尼。八名迦摩。是名八天女。有天王名婆留那。常护世间。当护汝等得利早还。北方有山名枳罗苏。鬼神常居中。一切诸鬼神当护汝等得利早还。二十八宿并日月三十二天女并四大天王治世有名称。东方提头罗吒王。西方毗留博叉王。南方毗留荼王。北方婆留那王。八沙门八婆罗门。八大国刹利八帝释女等。当护汝等得利早还。若取妇施者。不应作是说

  枯河无有水　　国空王无护
  女有兄弟十　　亦名无覆护
  应作是咒愿
  女人信持戒　　夫主亦复然
  由有信心故　　能行修布施
  二人俱持戒　　修习正见行
  欢喜共作福　　诸天常随喜
  此业之果报　　如行不赍粮

若出家人布施者。不得作是说

  使子孙繁炽　　奴婢及钱财
  牛羊诸六畜　　一切皆滋多

应作是咒愿

  持钵家家乞　　值嗔或遇喜
  将适护其意　　出家布施难

僧上座应如是知。若不如是者越威仪法

佛住舍卫城。时檀越饭僧难陀为上座先坐。优波难陀及余比丘不时集。上座嫌言。世尊独制我。不制余人耶。乃至佛言。从今日后。应一切齐集食。上座应如上说。此中但以第二上座。及一切为异。乃至当留比坐坐处。若行食人过者。不得默然而看。比坐应语。与是不得得食便先食。要待遍已然后食。若时逼者随下随食无罪。上座应咒愿。若不能者。第二上座咒愿。若复不能者。下过乃至能者应咒愿。如是一切食上座应知。若不如是知者越威仪法。佛住舍卫城。时优波难陀度人出家受具足。受具足已不教诫。如天牛天羊威仪不具足。不知承事和上阿阇梨长老比丘法。又不知入聚落阿练若法。入众着衣持钵法。诸比丘以是因缘往白世尊。佛言。呼优波难陀来。来已佛问比丘。汝实尔不。答言实尔。佛言。从今日后。和上应如是教共行弟子。云何教。受具足已应教诵二部比尼。若不能者教诵一部。复不能者教广诵五篇戒。复不能者教诵四三二下至四事。日三教。晨起日中向冥。教法者。若阿毗昙。若比尼。阿毗昙者九部经。比尼者波罗提木叉。略广。若不能者应教知罪轻重。知线经义。知比尼义。知阴界入义。知因缘义。教威仪非威仪应遮受经时共诵时坐禅时。即名教。若不受经共诵坐禅者。下至应教莫放逸。和上不如是教共行弟子者。越威仪法

复次佛住舍卫城。时优波难陀共行弟子。不数至和上所。优波难陀嫌言。世尊独制我不制弟子。弟子来我当教。不来我教谁。诸比丘以是因缘往白世尊。佛言。呼是比丘来。来已佛问比丘。汝实尔不。答言实尔。佛言。从今日后。共行弟子应如是事和上云何事。共行弟子法应晨起先右脚入和上户。入已头面礼足问安眠不。若受经若问事已应出。小行器唾壶着常处。先以水洒地然后扫。巨摩涂地。洗手已授水齿木竟。持钵与迎粥食。粥已洗器举着常处。若有请处者应往迎食。欲入村时授入聚落衣。卷叠院中衣着常处。入聚落时应从师后行。若欲乞食时当白和上。和上应语如法莫放逸。若先还者应与和上敷坐床取净水办草叶待和上。和上还已应授与院中衣。取入聚落衣抖擞叠着常处。若热时应与水洗浴。寒时应然炉火已。若得好食者应授与和上。和上看已应问。汝何处得是好食。若言某甲淫女家寡妇家大童女家不能男家恶名比丘尼边恶名沙弥尼边得。和上应语。此非行处不应取彼食。若言为说法故得。应语不得邪命取人食。食时应授水洗手授食。若是热时与冷水以扇扇之。食已收钵取草叶洗钵举着常处。和上若欲入林坐禅时。应取尼师檀着肩。上持澡罐随后。到已若受经问义。得已应在一处修习。若欲共他并诵时白和上。和上应问与谁共诵。答言。与某甲共诵。和上观前人。持律缓者应语莫去。此人不可与作往反。若持律好者。应语诵。还时应取尼师檀着肩上持澡罐随还。和上欲礼塔时。应与水洗手授华。礼塔已与敷坐床与洗脚与油涂足。欲眠时应拂拭床褥安枕。应与然灯。内唾壶小行器。和上安隐已然后受经问义。分房当次得时先问和上然后取。二人共得房者。和上应问汝共谁得房舍。答言共某甲。应观前人。持戒缓者应语莫取。生人过患。若贤善者语取。后更有上座来出去时亦当白。若共行弟子于和上所应如是作。若不作者越威仪法。若弟子众多。下至一拂拭床。是名事

佛住舍卫城。时难陀优波难陀受人依止不教诫。如天牛天羊。一一如上和上中广说。但以阿阇梨为异耳

佛住舍卫城。尔时难陀优波难陀受人依止弟子不来。师嫌言。世尊独制我不制弟子。弟子不来我当教谁。如上共行弟子中广说。但此中以依止弟子为异耳

  上座布萨事　　第二一切然
  上座食上法　　第二一切然
  和上所教示　　共行应随顺
  依止顺法教　　弟子应奉行

初跋渠竟

佛住舍卫城祇洹精舍。如来五日一行诸比丘房。见床处处侧地。风飘日曝雨露其上。虫食乌鸟粪上佛知而故问。比丘。此是谁床。处处侧地乌鸟粪上。乃至佛告诸比丘。从今日床褥应如是知。云何知。不得见床处处侧地虫啖日曝雨露风飘乌鸟粪上而置。若处处者应收检着一处。侧者当正。日曝风雨飘者应着房内。虫啖者当支脚。乌鸟粪上当抖擞内着房中。不得看房舍漏坏不治。若草覆者当草补。瓦覆还用瓦补。石灰覆者还用石灰补。泥覆者还泥补。壁破者当泥治巨摩涂地。众僧床褥不得趣尔受用。以单故布覆上。应以两重尼师檀覆上。若卧具。眠时应以物厕里不得令近身。褥氍毹厚者。不得屈敷破坏僧物。褥枕拘执。若垢腻者应浣。破者应补已还成。若僧床褥卧具应如是举持。若不尔者越威仪法

佛住舍卫城祇洹精舍。尔时诸比丘。春末月不修治房舍。如来五事利益故。五日一行诸比丘房。何等五。一者我声闻弟子中不贪著有为事不。二不着世俗言论不。三不着眠睡不。四为看病比丘故。五有信心年少比丘见如来威仪庠序发欢喜故。是名五事行房。见房舍破坏不治。佛知而故问比丘。是何等房破坏不治。诸比丘答言。安居比丘自当治事。佛言。从今日后。安居时房舍应如是治。云何治。若安居时欲至。不得看房舍破坏不治而言安居人自当治。若草房者当草覆。乃至泥房者应泥补。壁孔应泥治。当塞鼠孔泥治地。房中受用物应聚着一处。五法成就应拜作分房人。何等五。不随爱。不随嗔。不随怖。不随痴。得不得。应知。是名五。羯磨者应作是说。大德僧听。某甲比丘五法成就。若僧时到。僧拜某甲作分房人。如是白。白一羯磨。乃至僧忍默然故。是事如是持。是比丘得羯磨已。应修房温室食堂讲堂浴室井屋厕屋门屋经行处树下疏记多少。若阿练若住处离余住处远者。四月十二日十三日应分房舍。若不受者应余处去。若多近住处者。十四日十五日分房。应僧中读疏。大德僧听。某甲精舍有尔所房尔所床褥尔许食尔许斋日饮食。有尔所安居衣。上座应语分房舍共一施。应分房从上座乃至无岁比丘。不得与沙弥房。若和上阿阇梨言但与我当治事应与。若房长者一人应与两房。若言我不须二得一便足。应语言不为受用故与。为治事故与。若房少者二人三人共一房。如是复不受者。五人六人共。若复不受。有大堂者一切尽共入大堂。若复不受者。上座敷大床。下座敷小床。若复不受者。上座小床。下坐草褥。若复不受者。上座草褥下坐应加趺坐。若复不受者。上座加趺坐。下坐应立。若出树下。冬时分房。治事故与。受用故与。上座来唤起便应去。春时分房亦复如是。夏时分房。治事故与。受用故与。上座来唤起去不应去。若比丘春末月应如是治房。若不如是者越威仪法

佛住舍卫城祇洹精舍。尔时世尊五事利益故。五日一行诸比丘房。见房舍漏坏不治事雨潦弥满水渎不通门户虫啖床褥[璊-王+酉]青。佛知而故问。比丘。是何等房。不治漏坏如是。乃至佛言。从今日后。夏安居中应如是治房舍床褥。云何如是治。不得见房舍漏坏及以床褥而不治事。若草覆者应草补。乃至泥覆者泥补通水渎及长流。若卧床褥坐床[璊-王+酉]生者。应日中晒令干。若房内湿者。应令离壁支脚勿使虫食。应扫屋间炱煤虫网。半月应以巨摩涂地。若乾者应以水洽涂地。若湿者淳用巨摩涂。若房内湿者。不得洗手洗足洗钵。不得闭户。当时时开户使风得入。不得以烟熏之。若比丘夏安居房舍当如是治。若不如是越威仪法

佛住舍卫城。尔时比丘阿练若处安居竟。不嘱便去。后野火来烧房舍。诸比丘以是因缘往白世尊。佛言。比丘安居竟。房舍应如是治。云何治。若比丘在阿练若处安居竟。至冬时欲移就暖处者。不得尽去。当求两人三人堪能者令住。应与饮食勿令乏短。若言不能我何故住此空野中为。若都无住者。若有床枕褥拘执铜铁器物。一切应寄聚落中精舍。卧床坐床当离壁以物支足。勿令虫食。安居竟不得见房舍漏坏不治事而去。若草覆者应草补。乃至泥覆者泥补。泥治房舍作白色壁。周匝鲜火当嘱托放牧人。汝时时与我看视。聚落中住处亦应如是治事。若温室讲堂食堂自污洒治事。若精舍檀越在者。应语令治。若差人治。若无主复不差人者。一切僧应治。当共分人得一肘二肘三肘令周遍。卧床坐床缓坏者应更织令坚。若褥枕拘执卧具腻应浣令净。若破者应补。房中受用诸物。应聚着一处。若比丘安居竟。房舍床褥应如是治。若不如是治越威仪法

佛住舍卫城。尔时世尊五事利益故。五日一行诸比丘房。见卧床坐床处处狼藉侧地。佛知而故问。是何等床狼藉不举答言世尊。是旧比丘所安。我是客。佛言。从今日后。客比丘应如是知。云何知。乃至不得见卧床坐床狼藉虫啖而置。若狼藉者应收置一处。若侧者应正以物支足勿使虫啖。客比丘来至不得便持物着屋中。当放物一处觅旧比丘。得房舍已若地不平者应平。若有鼠孔者应塞泥治。若有炱煤虫网应扫。卧床坐床若缓者应织令急。褥枕拘执应抖擞屋中。应以水洒净扫涂地。若木衣架者。当以物拭令净。若是竹滑者以手拭之。应看壮坚者以钵悬上。若半夜住者。亦应如是治竟去。客比丘。若不如是治越威仪法

佛住舍卫城祇洹精舍。尔时如来五事利益故。五日一行诸比丘房。乃至言世尊。是客比丘敷置。非我旧。比丘。佛言。从今已后旧比丘应如是知。云何知。旧比丘不得令床。敷处处弃捐令虫啖食而置。若处处星散者。应聚一处。若虫啖者当以物支足。旧比丘法不得自住好房。床褥枕留弊坏垢腻者待客比丘来。自当治当修治好者待客比丘。旧比丘应如是知。若不如是越威仪法

佛住舍卫城只桓精舍。如来五事利益故。五日一行诸比丘房。乃至佛见已知而故问。比丘。是谁床敷。答言世尊。是旧比丘敷。我方始住。佛言。从今已后。床敷一切比丘应如是知。云何知。一切比丘不得令床褥处处雨露日炙虫啖。若见散在地者。应聚着一处。若雨露日炙者应安覆处。若虫啖者当支足。若房舍漏坏者应覆。草覆者草补。乃至泥覆者泥补。壁穿坏者当补治泥地。若床褥枕拘执垢腻破坏者。不得看置。应浣染补治。内毳当擘还。[槎-工+目]床绳缓者当织令坚致。打揵椎治床褥时。不得徐徐来。应疾往集。集已应当共治。有应作绳者。有应织者。当共作。若分者各自持去。若如是打揵椎治床褥时。不得言我是阿练若我乞食我大德我是上座不能治此中受用者。自当治一切尽集共治。有绳线者。有缝者。有上色者。比丘应如是一切治。若不如是越威仪法

佛住舍卫城。尔时诸比丘处处大便。为世人所嫌。云何沙门释子似如牛驴。便右无常处。诸比丘以是因缘往白世尊。佛言。从今已后应作厕屋。厕屋不得在东在北。应在南在西开风道。作法者。若作坑。若依高岸。若坑底有水出者。当使净人先起止中。然后比丘行。若临岸上底有流水者应安板。令先堕板上后堕水中。应作两孔三孔。孔广一不舒手。长一肘半。屋中应安隔。使两不相见。边安厕篦。屋下应安衣架。尔时有比丘先在厕上。后有比丘急行入厕便。欲在先比丘上行。彼比丘言。长老莫污我。比丘以是因缘往白世尊。佛言。从今日后。上厕法应如是知。云何如是知。不得临急已然后上厕。应当如觉欲行便往。往时不得默然入应弹指。若内有人亦应逆弹指。若大急者。应背蹲先人应相容处。不得未至便高举衣来。当随下随褰。不得着僧卧具上厕。不得厕上嚼齿木覆头覆右肩。应当偏袒。不得在中诵经禅定不净观及以睡眠令妨余人。起时不得高举衣起去。应随下随起。复次尔时诸比丘用竹作筹草伤破身。诸比丘以是因缘往白世尊。佛言。从今已后。不听竹片[竺-二+韋]片木札及骨。应用滑物圆物。不得用已放厕中。应土毗夜置一处。若是深坑高岸放中无罪。大小行及涕唾。当使正堕孔中。不得污两边。若前人污者。当以木篦除令净。不得大小行已不用水而受用僧坐具床褥。应安水瓶。若是坑者不得就中用水。若临岸者得用。当用木石瓦作瓶盖。年少比丘次第益水。时时当洗瓶。若木盖者不得日中晒勿令破。若是瓦石者得着日中晒。厕边应着灰土巨摩。若水器有虫者。不得言此中有虫。当持草横上令知有虫相。不得多用。水应裁量用。若瓶水尽者。当语知水家使人益若自益。下至一澡罐水令得一人用。若下部痔脱病不得洗者。当用软物拭。若布若树叶。若无厕屋者应在房后。若壁不便右。不得并嚼杨枝及覆头覆肩。应偏袒。若夜患下者。应以瓦器盛弃之。若无器者当在水渎边。明当洗去。若温室讲堂中卒下者当出。若大急不得去者当在一处。不得如牛随行随放。晓当除却水洗处。持油涂之下至巨摩。若绕塔时。腹痛下者应当去。若大急者应在一处。不得如牛污脚而去。竟已当除去水洗香泥涂之。若阿练若处无香者。当持油涂之。若欲入聚落。当先便右已而去。入聚落中若大行者。应往丈夫厕上。不得入女人厕。若无者应问人求随所安处。问时不得问年少妇女闻已当笑。应问长宿。若复无者当入空舍。入时不得在浅露处。不得深处使人谓呼是贼。若复无者。应在道边墙下。若有伴者令背向障。若共贾客行时大便者应下道。勿在上风熏人。应在下风。若宿时欲便右者。不得默然去。当语贾客勿呼是贼。亦当在下风。不得在上风。若随贾客船上行时若大便者。当到大行处。应用木板着下。令先堕木上然后堕水。若无木者。乃至一厕草承。若无厕草。当用瓦器盛已弃之。若塔院僧院内见不净者应除去。若二人共行见者下坐应除。若下坐持戒缓者当自除。若被毒。医言应服大便汁。若自己许不须复受。若他许者当受。若比丘在厕上应如是。若不如是越威仪法

佛住舍卫城。尔时诸比丘处处小行。为世人所嫌。云何沙门释子如牛驴处处小行。此坏败人何道之有。乃至佛言。从今已后。应作小行处。作法者。不得在北在东。应在南在西开风道。时有比丘小行。复有比丘来于上欲小便。先比丘言。长老莫污我。诸比丘以是因缘往白世尊。佛言。从今已后。小便法应如是知。云何知。不得临急然后去。如觉欲行当去。应先弹指。若先有人者亦逆弹指。若急者应背先人。先人应容处。不得覆头覆肩并嚼齿木。应偏袒右肩当上行。不得在上禅定眠睡诵经及不净观以妨后人。竟当时去。若无小便处者。应以罂盛。罂上当安穿底瓯。别一瓯中行以泻中。若无瓯者当用木杓泻中。不得大行涕唾中。年少比丘次第弃之。弃时当着屏处。不得弃塔院上流中。泻已当水洗覆地。若无者应人人求器。若是瓦者洗已覆地。若木者洗已着阴中。勿令破当施弦。夜当内着床下。若无器者。水渎边小便。不得在塔上流若温室讲堂上。欲小便时应出。若急失者不得行失小便当住一处。讫然后以水洗油涂乃至巨摩。若绕塔欲小便者应去若急者不得并行应住一处。讫以水洗之香涂。若阿练若处无香者。当用油涂。若欲入聚落。当先小便已而去。若聚落中欲小便者。当在屏处。若急不得至屏处者当向墙。若有伴应背向障。若共贾客道行欲小便者。当在下风不得上风。若夜宿时小便者。当在下风。起时当语人令知。勿令人呼是贼。若船行者当至小便处。若无者当小便器中已泻弃。比丘病。医言当服小便者。不得取初后应取中。若自己许承取即名受。若在地及他许当受。小便法应如是。若不如是越威仪法

佛住舍卫城。尔时六群比丘嚼未断治齿木。为世人所嫌。云何沙门释子如凶恶人合枝条嚼齿木。诸比丘以是因缘往白世尊。佛言。从今日后。不听用齿木。复次佛住舍卫城尔时世尊大会说法。时比丘口臭。在下风而住。佛知而故问。是何比丘独在一处如嫌恨人。比丘答言。世尊制戒不听嚼齿木。口臭恐熏诸梵行人。故在下风。佛言。听用齿木应量用。极长者长十六指。复次尔时有檀越在阿练若处种树。比丘拔取作齿木用。主见已心生不悦。即往佛所以是因缘而白世尊。佛为随顺说法。发喜心已礼佛而退。佛言。呼是比丘来。比丘来已佛问。汝实尔不。答言实尔。佛言。汝云何取华果树作齿木。从今已后。不听用花果树作齿木。嚼时不得在温室讲堂食屋及僧前和上阿阇梨前塔前像前。不得覆头覆肩。应偏袒右肩在屏处。若僧房内者。应以器盛嚼。残余不得着器中。不得着塔院中僧院中常行处。刮舌时不得如淫欲人法。刮已当洗着一处。若齿木难得者。当截所嚼处弃之。洗已残者明日更用。复次尔时有比丘嚼齿木欲尽。见世尊来。以恭敬故咽之。细木着咽喉不乐。诸比丘以是因缘往白世尊。佛言。从今已后。不听嚼尽。极长者十六指。极短者四指已上。嚼时当在屏处。先净洗手齿木嚼已水洗弃之。用时不得如淫欲人。当以除口臭秽故。嚼时不得咽汁若误咽者无罪。比丘病。若医言嚼齿木咽之当差。应受已嚼咽。若无齿木者。当用灰卤土塼礓石草木洗口已食。若塔院僧院。中见所嚼齿木。当取弃之。若二人共见。小者应弃。若下坐持戒缓者。当自取弃之。齿木法应如是。若不如是越威仪法

  床敷春末月　　安居坐已竟
  客比丘并旧　　一切亦复然
  厕屋大小便　　齿木二跋渠

佛住舍卫城。如来五事利益故。五日一行诸比丘房。见比丘敷衣地补。佛言。从今日应作席。作法应用竹[竺-二+韋]长十肘广六肘。欲缝衣时应在讲堂上若温室禅坊中。敷席已张衣上缝。当洗脚坐上。若不洗当背坐上勿令脚近不得在上晒谷晒衣染衣。不得使日炙雨露鸟兽污上。缝衣竟当内着覆处。若无席者应在床上作。若复无者温室讲堂上巨摩涂地缝。缝衣时应如是。若不如是越威仪法

佛住舍卫城。尔时比丘坐禅还。持冷脚熨他。彼比丘心惊不安。诸比丘以是因缘往白世尊。佛言。从今已后当作障隔。作法者。应用[竺-二+韋]竹若旃。竖四角施帘绳系。坐禅还时开。入中还闭。不得昼闭应举。夜当下。障隔法应如是。若不如是越威仪法

佛住舍卫城。尔时世尊五事利益故。五日一行诸比丘房。见房舍漏坏不治。佛知而故问。是何房舍漏坏乃尔。从今日后。房舍应如是知。云何如是知。不听见房舍漏坏不治。若草覆者草补。乃至泥覆者泥补。应时时扫屋间虫网尘埃。地高下者应平治。塞鼠孔泥治。半月当一巨摩涂地。若地燥者当水和涂。若湿者淳用。若是上屋地作绀青色者。当以物裹床足。不得在中然灯经行及着革屣。不得唾地。当用唾壶。若是中屋者。得洗足洗手面荡钵。下屋者。得然灯经行洗手足面荡钵。房舍应如是。若不如是越威仪法

佛住舍卫城。尔时世尊五日一行诸比丘房。见房舍讲堂壁上涕唾淋落垂地。佛知而故问。是何涕唾不净乃尔。佛言。从今日后。涕唾法应如是知。云何如是知。壁泥已不泥尽不得唾。若地不泥者当唾一处。以脚磨之。不得处处污。若作地者应用唾壶。底当安沙若灰礓石。当数弃之。勿令臭秽生虫清水。净洗覆干。不得在中嚼齿木。若禅坊中欲唾者。应唾革屣底拭地。若地有覆者当用唾壶。若在食上欲唾者。不得大喀着地。使比坐比丘恶心。应唾两足中间以脚磨之。若大多出不止者。当出外唾已还坐。若和上阿阇梨前欲唾者。当至屏处。若聚落中欲唾者应唾足边。以脚磨之若是末吐无罪。若塔院中僧院中见涕唾者。应以足磨之。若二人共见。小者应磨。若小者持戒缓者当自磨。比丘唾时应如是。若不如是越威仪法

佛住舍卫城。尔时比丘举钵着向孔中。旋风来吹堕地即破。闻食粥揵椎声欲取钵。正见一聚碎瓦。诸比丘以是因缘往白世尊。佛言。呼是比丘来。来已佛问比丘。汝实尔不。答言实尔。佛言。从今日后。钵应如是知。云何知。不得举着向孔中岸边危处。不得着开户扇处及行来处。不得用灰洗令脱色。当用树叶汁无沙巨磨洗。洗时不得在岸边危处石上塼上。不得在多罗树下迦毗陀树下那梨树下。洗钵应踞坐。若胡跪离地一搩手。应先洗和上阿阇梨钵然后自洗。不得持自钵中残水泻和上阿阇梨钵中。当持和上阿阇梨钵中残水洗己钵。干时亦先收和上阿阇梨钵。盛时应先盛。和上阿阇梨钵。盛时当踞坐持钵囊带串臂着膝上盛之。若着卧床上若坐床上。钵囊当用两重三重作。欲悬钵时。当先摇捎橛坚不。然后安之。若无悬处者当着床上。若向中有笼蔬遮者得安。若有钵龛者得安。勿令相[打-丁+棠]钵龛当作缘。不得闇中取钵不得不净手取。应净洗手。若以叶捻取。取钵时一手捉两。一手捉一。不得捉四。授钵时不得卒放。应问言捉未。若言捉已乃放。不得持钵盛不净物。亦不得用盛水剃发洗手足面浴室中用及洗小便处用。护钵如护眼应当如是。若不如是越威仪法

佛住舍卫城。尔时六群比丘呰毁粥。若见薄者作是言。此非粥。此是遥浮那河。若见粥强者便言。此非粥。是饭折人齿。诸比丘以是因缘往白世尊。佛言。呼是比丘来。来已佛问比丘。汝实尔不。答言实尔。佛言。从今已后。粥应如是知。云何知。若闻打食粥揵椎声时。当知此是二部僧粥。为是一部僧。为是师徒眷属。知已应去。到已不得形相厚薄。随得应取。不得越次取。取时不得覆头覆肩着革屣。应脱革屣偏袒右肩取。若行粥人去駃者。下至脱革屣根。若不及脱者待还。时取。若倩人取。若坐者次第取。若薄者不得言太清如遥浮那河见月影。若强者不得言此是饭折人齿。随得应取。粥法应如是。若不如是越威仪法

佛住王舍城迦兰陀竹园。尔时比丘在帝释石室山边坐禅。时有比丘在前立住。坐禅比丘心不得定。诸比丘以是因缘往白世尊。佛言。呼是比丘来。来已佛问言。汝实尔不。答言实尔。佛言。从今日后。当如是住。云何如是住。不得在坐禅比丘前立。不得在僧中当前立。不得当徒众坐前立。不得当和上阿阇梨前立。及长老比丘前立。不得着革屣叉腰覆头放两手在边。若病者无罪。不得在淫女前住。樗蒱儿前沽酒家前屠儿前狱囚前杀人前住。不得在深邃处立住。住法应如是。若不如是越威仪法

摩诃僧祇律卷第三十四摩诃僧祇律卷第三十五

        东晋天竺三藏佛陀跋陀罗共法显译

    明威仪法之二

佛住王舍城迦兰陀竹园。尔时有比丘。着多罗屐在坐禅比丘前经行。比丘心不得定。诸比丘以是因缘往白世尊。佛言。呼是比丘来。来已佛问言。汝实尔不。答言实尔。佛言。从今已后。应如是经行。云何如是。不得在坐禅比丘前经行众僧前徒众前和上阿阇梨前长老比丘前经行。若病服酥服吐下药。得在前经行。行时不得背回。应面向右回。若共和上阿阇梨经行时。不得在前不得共并。当随后行。回时不得先回。应在后面向右回。不得在淫女前经行摴蒱儿前估酒前屠肆前狱卒前杀人前。不得深邃处经行。当在不深不浅处经行。经行法应如是。若不如是越威仪法

佛住舍卫城。尔时六群比丘在禅房。中作骆驼坐。诸比丘以是因缘往白世尊。佛言。呼六群比丘来。来已问言。汝实尔不。答言实尔。佛言。从今日后。不得作骆驼坐。应加趺坐。若坐久寄极者。当互舒一脚。不得顿舒两脚。若起经行。不得覆头禅坊中坐。若老病得覆半头一耳。若屏处树下覆头无罪。和上阿阇梨上座前长老比丘若坐若立。不得坐。不得在淫女前乃至深邃处坐。当在不深不浅处坐比丘应如是坐。若不如是越威仪法

佛住舍卫城。尔时六群比丘伏卧仰卧左胁卧。诸比丘以是因缘往白世尊。佛言。呼是比丘来。来已问言。汝实尔不。答言实尔。佛言。从今已后。当如是卧。云何卧。不听饿鬼卧。不听阿修罗卧。不听贪欲人卧。若仰向者阿修罗卧。覆地者饿鬼卧。左胁卧者贪欲人卧。比丘应如师子兽王顾身卧。敷时不听左敷应右敷。头向衣架。不得以脚向和上阿阇梨长老比丘。不得初夜便唱言嘘极而卧。当正思惟自业。至中夜乃卧。以右胁着下如师子王卧。累两脚合口舌柱上龂。枕右手舒左手顺身上。不舍念慧思惟起想。不得眠至日出。至后夜当起正坐思惟已业。若夜恶眠不自觉转者无罪。若老病若右胁有痈疮无罪比丘卧法应如是。若不如是越威仪法也

  衣带帘障隔　　房舍及涕唾
  钵龛粥行住　　坐卧三跋渠

佛住舍卫城尔时六群比丘闭僧坊门共坐言谈。客比丘来打门唤不闻。即便踰墙入。旧比丘问言。长老从何处入。答言踰墙入。旧比丘言。汝何故踰墙入。客比丘言。汝何故闭门唤而不应。如是共诤往白世尊。佛言。从今已后。不得闭门语话。亦不得踰墙而入。从今已后。客比丘应如是。旧比丘应如是。云何如是。客比丘行时。应持户钩漉水囊针筒。行伴一人有者一切无罪。乃至都无者。举众有罪。道路若有病者。当代担衣钵。不得在前远去。应扶持而去。若不能行者。当借索乘致之。若道中有露湿者。年少当在前。若畏贼虎狼时。老者应在中央。若欲使贼起慈心者。应老者在前。若经聚落路边见有支提者。当按常道行。不得下道左旋右旋。暮欲宿时。当先遣二年少比丘在前求宿处。索非时浆及涂足油前食后食。去者当着衣钩纽。白非时入聚落。得已应还报言。已得住处。若有池水井水。当澡浴着衣纽。展转相白而入。若欲饮石蜜浆者当在外饮。勿使人生疑呼出家人非时食。不得担荷而入。当分衣物徐持共入。若得唱言随所安者。后人不白入者无罪。不得余道去。若道上有覆无罪。若聚落中有精舍者应往。若阿练若处者。边有池水井水亦应当澡洗而入。不得担荷。当共分张衣物脱革屣杖贯。若有支提者当右旋。不得高大语大声入。见旧比丘。不得唱咄咄汝故在此也。汝此中生还此中死。不离此野干食。旧比丘不得言。咄咄如囚脱枷锁。已四五年不可得见。客比丘不得言。汝几岁我应得此房。不得问明日谁作前食后食有好食不。旧比丘不得闭门语话。若欲舍后泥作及作余事者。当使园民若沙弥维那守门。若闭门者客比丘不得踰墙而入。应持门钩开入。若唤开门入已。旧比丘应问汝几岁。应答言。我尔许岁。旧比丘言。若尔许岁者。得如是床褥。当问大小行处。不得临时方问。次应问众僧制限。旧比丘应语僧一切制限。某甲家覆钵羯磨莫往。某甲家狗恶。某甲家不信。客比丘早起不得便乞食去。应问是住处。有前食后食不。旧比丘应语。长老莫乞食。乞食疲苦或不如意。此中有前食后食。若行伴已去者。不得语言。长老贾客已去故可及。应语。长老可小停息正尔复有伴耳。若有急事必欲去者。应给粮食嘱累行伴。如是客比丘旧比丘法当如是。若不如是越威仪法

佛住舍卫城。尔时六群比丘洗脚而并俗话弄水。诸比丘以是因缘往白世尊。佛言。从今日后。洗脚应当如舍利弗法也

佛住王舍城迦兰陀竹园。时舍利弗着入聚落衣。持钵入城次行乞食。威仪庠审来去视瞻。屈伸俯仰着衣持钵。守摄诸根心不外乱。似得妙法润泽之相婆罗门见已作是念。是沙门释子在于人间现持威仪。至屏处已必无法则。我当逐看。若见放恣当以手拍头。即便寻后。于是舍利弗在聚落中及阿练若处威仪不改。到住处已持钵置一处。抖擞僧伽梨襞亵置常处。敷坐床。持洗脚板及罂水自近而坐复取革屣抖擞放地。次取巾拭膞。还取革屣以底相搭。合捉以巾拂之。次以水渍巾。拭一只革屣鼻及纲纽。次拭根。次拭第二者亦如是。还复拭初捉者脚指处。次拭脚跟处。还拭第二者亦尔。次浣巾捩已晒之。次洗手。洗手已以右手泻水。左手洗左膞。次洗右膞次洗脚。婆罗门见已发欢喜心言。尊者净洁如是。此残水亦当可饮。我婆罗门事净水法不及是净。时舍利弗因婆罗门发欢喜心而为说法。得法眼净。诸比丘白佛言。世尊。甚善婆罗门。见舍利弗洗脚威仪净故发欢喜心乃至如是。佛言非但今日欢喜。过去世时已曾如是。如生经中广说。尔时长者子舍利弗是。尔时贼者今婆罗门是。时诸天见已而说偈言

  净洁好威仪　　因是得善利
  如水净影现　　学威仪最胜
  来时怀恶心　　既见反欢喜
  不学善威仪　　必为贼所害

若比丘聚落中还时。应脱入聚落衣抖擞襞亵着常处。着园中衣。敷坐床。聚洗脚板盛水罂自近。以巾拂脚尘土。次捉革屣以底相搭。持巾拂之。次渍巾拭一只鼻纲纽。次拭根。次拭第二只亦如是。还复取初捉者。先拭脚指间。次拭脚跟处。次拭第二者亦尔。次浣巾绞捩晒之。莫使尘生虫食。然后洗手。若水器在右边。应先洗左膞次洗右膞然后洗脚。不得以捉水手揩脚。应一手泻水一手摩。若二人者。一人浇一人洗。不得太多用水弃。当筹量用。不得覆头覆右肩。当偏袒坐。不得洗脚时坐禅睡眠不净观及诵经。竟当避去勿妨余人。若最在后洗者。得诵经无罪。若水尽者。不得默然置之。当语知水家令益。若不能者。乃至自益一澡罐水。使得一人用直。洗脚法应如是。若不如是越威仪法也

佛住舍卫城。尔时六群比丘洗脚。湿脚着革屣。革屣染色。脱着脚污僧床褥。诸比丘以是因缘往白世尊。佛言呼六群比丘来。来已佛问比丘。汝实尔不。答言。实尔世尊。佛言。从今日已后。洗脚时应如是。当竖革屣耳令脚干已乃着革屣若多人待者。当以手捋水以巾拭之然后着革屣。不得以湿脚蹈僧净好作地。当令燥已乃入。若是一人洗处者不应拭当待燥已着革屣应护尘土。若急欲坐禅诵经经行者。乃至手拭巾拂尘土而去。洗脚法应如是。若不如是越威仪法

佛住舍卫城。尔时僧净水。蔓荼罗。诸比丘取水洗脚洗手面洗钵。用已缭系瓮头印封户。而入聚落乞食。后有客比丘来嗔嫌言。何故闭净水屋印封而去。时诸比丘以是因缘往白世尊。乃至佛言。从今已后。春月当如是安水。若大瓮小瓮若瓶当以净物覆口以绳缭系之。若瓦若石若木作盖覆上。内应置[戀-心+廾]水器水中应着波多梨华瞻婆华须摩那华。如是比令水香美。有名水。如巴连弗邑有输奴水。王舍城有温泉水。波罗奈城有佛游行池水。瞻婆国有恒水。舍卫城有石蜜水。沙只国有悬注水。僧伽施国有石蜜水。摩偷罗国有。遥扶那水。如是比水不听洗脚手面及钵。若病须水应与满钵。若食上欲行水者。当先净水洗手洗器然后行水。受水人当护左手令净受水。若手污者当浇。若以叶承取亦用叶拭腻口。饮时不得没唇。不得使器缘着额。当拄唇而饮。饮时不得尽饮。当留少许。掏荡已从口处弃之。行水人当好护净器。若见没唇着额者。当放置一处。以草作识令人知不净。若能以水洗者可更行。若非时行饮者。行饮人先净洗手洗器而行。受饮人亦应净洗手受。若不洗者当以叶若净衣承器底受如上。乃至口处弃。若浴室中行饮者。当以叶承器底拄唇而饮。余如上说。若禅坊中行饮时。地有覆者应持器承。若坐相离者。一人行器一人行水。余如上说。如是名好水。不得用洗脚手面荡钵。亦不得作余用弃之。若有作衣钵事须者。可权贷用还偿。若水自恣用者随意取无罪。水应如是用。若不如是越威仪法也

佛住王舍城耆域童子庵婆罗园。尔时耆域童子往至佛所。头面礼足却住一面白佛言。世尊。愿听诸比丘温室浴。能除冷阴得安乐住。佛言。听温室浴。复次佛住舍卫城。尔时世尊听温室浴。时六群比丘闻打洗浴揵椎时。便先入浴室。顿着薪炭已闭户取汗而住。外比丘索开户。不肯与开而言。诸长老且住待火然。便多用薪炭屑水都尽。方开户而唤言。诸长老可入。诸比丘既入。复于外闭户。诸比丘热闷唤索开户。答言。长老。且住取汗能愈疥癣。而复于外用水屑都尽。以器覆地然后开户言。长老可出。出已热闷求水。复语言。长老。稍用如世尊所说。乃至水亦当节量用。诸比丘以是因缘往白世尊。乃至佛言。浴室应如是作。浴法应如是浴。室应方作若圆作。当安户作向。向法内宽外小。若一若二安开向物通烟道。屋内应以塼石。砌底作窖令底广上狭。去地半肘通烟道边安火朼。若窖在右边。左边安户扇。若在左边。右边安户扇。短作户扂令易开闭。前应作衣屋安龙牙撅悬衣处。若欲浴时。使园民先扫屋间尘埃虫网。以水洒地净扫。应办薪炭釜镬盆瓮。先安薪炭然后打揵椎。不得太早。着火令然尽乃打揵椎。打揵椎时。应知为浴一切僧为浴徒众。为别屋随事应去若一切浴者应次第去。应各自以腰带系衣作识安衣架上。入时不得掉两臂而入。一手遮前而入。一人入一人出。有后入者先人应与处。不得越器物及长老比丘上过。当徐徐入。若和上阿阇梨在内者不得在外待言何时出。应当脱衣入与揩洗。若欲与人揩者。当白和上阿阇梨。若先白者无罪。若火炽者年少当近火。若火弱者长老应近。当徐徐用水。不得污溅边人。若弟子揩时不得一时举两手。当先令揩一臂。一手覆前竟已次揩一臂。内水已闭户而坐令身汗。当行油。若以盏子。若以手等行。屑末亦尔。若檀越言自恣与。当筹量用水。若罂量分用者。当齐所得器。不得长用余分。若言各自办水者。有水者得入。无者不得入。若有弟子言和上阿阇梨但入我当与水。亦当筹量用。若优婆塞园民言但入我当与水。虽尔亦应节用。若近池水得自恣用无罪。不听露地裸浴。若水齐腰腋得用无罪。若坐水中至脐亦得出已。自取衣着他衣正理而去。洗浴已若直欲去。应语园民应举浴器物若比丘后来言长老但去我自举者。应去。后者摒挡举物覆火。浴法应如是。若不如是越威仪法也

佛住舍卫城。尔时世尊五日一行诸比丘房。见净厨器物处处狼藉。佛知而故问。是何器物狼藉乃尔。乃至佛言。从今日后。不得令器物纵横如是。若摩摩帝若直月。当使园民若沙弥摒挡。若摩摩帝若直月不用意见者。便应使净人摒挡。若铜铁釜镬铫器。应使净人净洗以泥涂上覆着净厨屋内。若瓦釜铫镬亦尔。覆地以塼瓦。镇之。木瓮木杓亦应洗净举之。若簟席当应日晒悬举竹箧。簸箕漉米箕亦应悬举勿使虫啖。饭箧饭朼净洗悬举。囊襆及漉水囊亦应悬举勿令虫食。捣药杵臼不得用已放地。当净洗覆着常处。食厨净屋不得视穿漏不治。若草覆草补乃至泥覆者当泥补。穿坏者当塞。当数扫除。若内燋薪时当摒挡着一处。煮染器及盛染盆不得用已舍去。当净洗治覆置常处。浣衣木盆用已。亦当净洗举置常处。晒衣绳亦不得用已缭乱放地。当綪卷置常处。釿斧锯凿锹钁梯橙。此是四方僧物。用已当摒挡着常处。后人须者取易得不致疲苦。若须用者当与。若二人一时索者当先与上座。若上座用久。年少小用者。当先与年少。若二人俱小用者。当先与上座。器物法应如是。若不如是越威仪法也

佛住舍卫城。尔时众多比丘共一房住。时有比丘衣架上自取衣。拽他衣堕地余比丘夜出大小行。脚蹈衣上。衣主求衣不见。乃至于地得之。诸比丘以是因缘往白世尊。佛言。从今已后。衣应如是。若众多人共一房住者。衣应各自襞亵以叶着内。若他衣架上。以腰绳系之。复不得持和上衣阿阇梨衣裹己衣。当持己衣覆和上阿阇梨衣。若春时多尘土者。当持己衣覆上若夏地湿者。当持己衣着下。不得使房中有尘土。当数数水洒之巨摩涂地。不得持衣捻捉唾壶大小便器捉革屣。不得盛粪扫拾巨摩若有垢腻当数浣染缝。视衣当如皮想。衣法应如是。若不如是越威仪法

  客比丘并旧　　洗足并拭足
  净水及饮法　　温室亦洗浴
  净厨并衣法　　第四跋渠竟

佛住舍卫城。尔时聚落比丘阿练若比丘共一施。时阿练若比丘常以时来。聚落比丘忽早打揵椎而食。阿练若比丘日时欲至。方到问言。打揵椎未。答言已食竟。时阿练若还去。明便早来尽持食去。聚落比丘来索食。净人言。阿练若比丘已尽持去。聚落比丘言。长老何故早起来尽持食去。阿练若言。汝何故早起打揵椎食不待我耶。二人共诤。往至佛所以是因缘具白世尊。佛言。从今日后阿练若比丘应如是。聚落比丘应如是云何如是。若阿练若比丘聚落比丘共一施者。聚落中。比丘不得早起打揵椎前食后食及差请食。应待阿练若。阿练若比丘不得言我徐徐往自当待我应先往。若倩人请分。若嘱留坐处。聚落比丘应问阿练若比丘来未。若倩人迎食。若嘱留坐处。应示处。若优婆塞请僧者。聚落比丘应语阿练若比丘言。长老明日早来。某甲请前食后食。莫余乞食。阿练若比丘闻已当早来。来已若食未熟者不得守住。应礼塔诵经问法。聚落比丘应先釜中着水然火待至然后着米。阿练若比丘或有鬼难水火贼难不得来者。而弃米若饮食已熟者。檀越欲打揵椎。当语。长寿。日故尚早。可待阿练若至。若日时逼者应打揵椎。阿练若应以树若墙壁影作准则知日早晚应来设未来者当留坐处。若阿练若处作食者亦应如是。阿练若比丘不应轻聚落中比丘言。汝必利舌头少味而在此住。应赞汝聚落中住说法教化。为法作护覆荫我等。聚落比丘不应轻阿练若言。汝在阿练若处住希望名利。獐鹿禽兽亦在阿练若处住。汝在阿练若处从朝竟日正可数岁数月耳。应赞言汝远聚落在阿练若处。闲静思惟上业所崇。此是难行之处。能于此住而息心意。阿练若应如是。聚落比丘应如是。若不如是越威仪法也

佛住舍卫城尔时旧比丘共诤口。有客比丘来接足而礼。后日客比丘来复礼问言。汝来几日。答言。四五日。旧比丘言。汝来尔许日。何以不见我。答言。我已见礼竟。长老共诤口故不见我耳。旧比丘言。汝何以见。我共诤而向我礼。答言。汝何以共诤不视我礼耶。二人便共诤往至佛所。乃至佛言。从今日后。应如是礼。应如是相问讯。云何如是礼如是问讯。前人共诤共语时不得礼。当低头小敬前人若止应作礼。若屋作泥作时不应礼。如是一切作熏钵浣衣煮染染衣缝衣澡浴油涂身洗足洗手面洗钵礼塔食时。含咽着眼药读经诵经写经经行下阁上阁时。上厕时。不着衣时着一泥洹僧时。尽不应礼。闇中不应礼授经时不应礼。着泥洹僧时着衣时若疾行时不应礼。不得覆头覆右肩着革屣作礼。不得礼膝礼脚礼胫。当接足礼。若前人脚上有疮。当护勿[打-丁+棠]触。受礼人不得如哑羊不语。当相问讯。问讯时不得作如是语。何处有多美饮食。应问少病少恼安乐不。道路不疲苦耶。客比丘应问。何者是僧上座。第二第三上座应礼足。旧比丘应问。长老几岁。若客比丘小者。应与座令坐。若有者应与前食后食涂足油。非时浆。客比丘旧比丘应如是。若不如是越威仪法也

佛住舍卫城。尔时六群比丘展转作俗人相唤。阿翁阿母阿兄阿弟。诸比丘以是因缘往白世尊。佛问六群比丘。汝实尔不。答言。实尔。佛言。从今日后。应如是共语问讯共翁语时不得唤言阿翁阿爷摩诃罗。应言婆路醯多。共母语时不得言阿母阿婆应言婆路醯帝。共兄语时不得言阿兄。当言婆路醯多。共姊语时不得言婆鞞。应言婆路醯帝。共和上语时不得言跋檀帝。当言优波上。若共阿阇梨语时不得言跋檀帝。当言阿阇梨。若有众多阿阇梨者。当言某甲阿阇梨共下坐语时得唤字唤巨帝唤岁。共上座语时应唤跋檀帝若慧命若阿阇梨。若有人唤时不得应言何道何物。若和上唤时应言诺。若阿阇梨唤时应言诺。若上座唤时亦应言诺。若年少唤时应言何故唤。若母人男子唤时应言何故唤。有人问汝和上阿阇梨字何等。不得直道和上阿阇梨字应言义。因缘故字某甲。语法应如是。若不如是越威仪法也

佛住舍卫城。尔时刹利众集欲有所论。时难陀优波难陀先到而坐。时诸人嫌言。我等今集欲有所论。而此沙门妨。我议论事。诸比丘以是因缘往白世尊。乃至佛言。从今日后。当如是入刹利众。云何如是入刹利众。若有事缘应往。当先语其中大者道来情事。若言可来应往。不得持伞盖着革屣。入时应脱着一处。不得言男子乐不。若示坐处应坐。不得毁誉军阵斗法。若见好射不得称赞。应言刹利种是上姓。如来应供正遍知常在二家生。刹利婆罗门家。有二种轮。法轮力轮。诸出家人赖力轮护故得以自安。欲有论事说已当去。入刹利众应如是。若不如是越威仪法也

佛住舍卫城。尔时婆罗门众集。难陀优波难陀先至而坐。诸婆罗门嫌言。我等欲有所论。而此沙门妨废我等事。乃至佛言。从今日后。应如是入婆罗门众。若有事缘欲至往时当先语其中大者道其事情。若听者应往。未至时当屏伞盖脱革屣。不得见已方却。又不得借盖革屣往。不得言乐不男子不得毁誉天祠。不得形相。婆罗门多我慢故当生六趣若鸡若猪若狗若野干驼驴地狱中应。言如来应供正遍知二种姓家生若刹利家若婆罗门家欲。有所论当说已而去。入婆罗门众法应如是。若不如是越威仪法

佛住舍卫城。乃至佛言。从今日后。入居士众。若有缘应往乃至示坐处而坐。不得言汝净洗手脚坐于店肆用轻称小斗欺诳于人甚于盗贼。应言有二种轮法轮食轮。得食轮已乃转法轮。如世尊说告诸比丘。婆罗门居士供给衣食卧具疾病汤药。饶益甚多是难为事。我依汝等。在如来法中修梵行度生死流。皆是汝等信心之恩。若有所论言已而去。入居士众应如是。若不如是越威仪法也

佛住舍卫城。乃至佛言。入外道众应如是。云何如是。乃至示坐处已应坐。不得毁誉彼见。又不得形呰言汝等邪见不信无惭无愧。应誉其实事。汝等能出家解。系缚舍于俗服冥心空闲。甚是难事。如是得称一切实事。不得说其过若欲论事言已便去。入外道众法应如是。若不如是越威仪法也

佛住舍卫城。乃至佛言。从今日后。应如是入众。云何入众。若欲众僧中有所论事。当于外断令决了。不得便入僧中断。若事难了应语其和上阿阇梨。若是事不须僧断者。应语令止。若事必须。彻僧。举事人复是可信。应为说和合如法如律事。和上阿阇梨听已当往僧上座前言。我欲有所说听不。上座应观察前人语。乃至入众时不得着革屣覆头覆右肩。当脱革屣偏袒入众。入众法应如是。若不如是越威仪法也

  阿练若聚落　　礼足相问讯
  相唤刹利种　　婆罗门居士
  外道贤圣众　　第五跋渠竟

佛住舍卫城。尔时六群比丘脱园中内衣已。露身求入聚落内衣。从聚落出已脱入聚落内衣。露身求园中内衣。诸比丘以是因缘往白世尊。乃至佛言。应如是着衣。云何如是着衣。欲入聚落时。不得脱园中内衣露身求入聚落内衣。不得脱入聚落内衣露身求园中内衣。欲入聚落时。当先取入聚落内衣自近。不得着聚落衣已于下挽园中内衣出。应随一边着一边脱。出聚落时脱入聚落内衣着园中内衣亦尔。着内衣法应如是。若不如是越威仪法也

佛住舍卫城。尔时六群比丘欲入聚落。脱园中衣着一内衣求入聚落衣。出聚落还脱入聚落衣着一内衣求园中衣。诸比丘以是因缘往白世尊。乃至佛言。从今日后。应如是着衣。不得脱园中衣着一内衣求入聚落衣。应先取入聚落衣自近。脱园中衣襞亵举着常处。然后着入聚落衣。从聚落出已。应取园中衣自近已。抖擞入聚落衣着常处着园中衣着衣法应如是。若不如是越威仪法也

佛住舍卫城。尔时优波难陀入聚落中。曳衣行泥土污色。值钩处挽裂。值刺处便穿。狭迮巷中唐突而过。弟子嫌言。我等勤苦浣染缝治而不爱护。诸比丘以是因缘往白世尊。乃至佛言。从今日后。入聚落时应如是着衣。云何如是。乃至不得聚落中曳衣使穿破。若春时离聚落远者。当襞亵着肩上持去。近聚落已若有池水汪水。洗手脚已着衣安纽而入若无水者。树叶若草拭脚尘土。然后着入。若冬时应着衣去。若逢奔驰象马车乘。当在上风。勿令尘土泥涂坌污。若钩刺棘不得挽裂而去。道巷迮者不得揩揬而过。若门狭小当侧身而过。若下者当曲身而过。入聚落着衣法当如是。若不如是越威仪法

佛住舍卫城。尔时难陀优波难陀不敷坐具而坐。以衣盛烂果腻饼而污衣。弟子嫌言。我勤苦浣染治而不爱护。诸比丘以是因缘往白世尊。乃至佛言。从今日入白衣家内衣应如是。云何如是。若床有尘土不净。不敷物不得坐。若见亲旧应语言令敷。若彼言此沙门憍恣难事者。当自拂拭敷坐具洗手而坐。不得以衣承取一切饼果湿华碎末拭口。白衣家内坐护衣应如是。若不如是越威仪法也

佛住舍卫城。尔时优波难陀语难陀共行弟子言。我欲共汝入聚落乞食。我于彼若作非威仪者。莫向人说。我是汝叔父。答言。设使我父及祖父作非威仪者我亦当道。如上广说。乃至答言。实尔世尊。佛言。从今日后。前沙门应如是。后沙门应如是云何前后沙门应如是。前沙门若能得食者当共食。若不能得者当早遣令还索食。后行沙门不得去前者太远使不相见。不得大逼相蹑脚跟。当相去一舒手以外。前有恶象马牛。当言和上阿阇梨前有恶物当避一处。若前行沙门羸老者。当在前与遮。若前有礼者。当语某甲礼。若有人请食。后沙门应忆还住处已应语向某甲家请。若前沙门不能咒愿。语令能咒愿者咒愿。不得言汝在前坐前取水前食而使我咒愿应当咒愿。前沙门后沙门应如是。若不如是越威仪法

佛住舍卫城。尔时比丘倩地迎食。与钵已而舍去。彼迎食比丘。持食来求觅而不知处。置钵禅堂上而便舍去。至明日比丘语言。可还我钵不。答言。我置钵禅堂上。复言。汝何以持我钵放空禅堂中。彼言。汝何故使我迎食已而舍我去。二人共诤。往至佛所即以上事具白世尊。佛言。从今日后。倩人迎食应如是。与人迎食应如是云何倩人迎食。与人迎食应如是。不得倩人迎食已舍去。又不得与人迎食已置钵空禅堂上而舍去。与他迎食者。当先语。长老我今取食莫余行严办待我。迎食人应知时。若逼时者应先持来。若时早者当依次坐次第取。取时不得合和各令异处。自食已持来。若日逼者不得于彼食。当持二分食来。来时当相望日足。及时至者应来。若不及者便于彼食。勿使二人俱失食。倩迎食者不得言我已倩得而舍去当先嚼齿木办水敷坐床洗手而待。当数看日。若日时欲逼者。当持澡罐水往迎。若道中逢者共食若故早者当待至已食。若有长者当与取食人。不得与余人。若不须者可与余人。迎食法应如是。若不如是越威仪法

佛住舍卫城。尔时六群比丘入城乞食。低头直进入白衣家唐突前人。为世人所嫌。言沙门释子犹如羯羊。直前触人。诸比丘以是因缘往白世尊佛言。从今日后。乞食法应如是。云何如是。不得如羯羊直头径前。不得复大远离在于不见处。当在现处住。不得言与我食当得大福。应默然而立。不得左顾右视。使人生疑谓是贼细作。当摄六情观于无常。亦不得大久住。若其家妇女有舂捣作事。未视之顷可小停住。若彼见已复舂作者当去。若见妇人纺线缠已复纺者此无与心应去。若女人见已入舍空出者应去。若是富家处处多有宝物者不得便去。呼语见已应去。乞食法应如是。若不如是越威仪法

佛住舍卫城。尔时优波难陀与共行弟子入聚落乞食。优波难陀持食出还觅弟子不见。嫌言。我持食来舍我而去。诸比丘以是因缘往白世尊。佛言。从今日后。乞食时后沙门应如是。云何如是。前沙门乞食时。不得大离远。不得大近边看。令主人生念。言不能乞食望得他残耳。当在现处住若请食者应食。若不请者当乞食。若井若池水边食已洗钵而去无罪。食时相待应如是。若不如是越威仪法也

  内衣聚落衣　　入聚落着衣
  白衣家护衣　　前沙门及后
  倩迎并与取　　乞食与相待
  第六跋渠竟

佛住舍卫城。尔时诸比丘闇中入禅坊倒地。诸比丘以是因缘往白世尊。佛言。从今日听然灯。时六群比丘当直然灯。以口吹灭以手扇灭以衣扇灭。复放下风扰乱诸坐禅比丘。比丘以是因缘往白世尊。佛言。从今已后然灯法应如是。云何如是。应从最下次第当直当直人应预办木钻牛屎于食屋中宿火不得顿然灯。当置火一边渐次然之然灯时当先然照舍利及形像前灯。礼拜已当出灭之。次然厕屋中。若坐禅时至者。应然禅坊中。应唱言。诸大德咒愿灯随喜。次然道经行处次然阁道头。若多油者厕屋中当竟夜然若油少者人行断当灭。灭已次灭道经行处。次灭阁道头。次灭禅坊中灯。灭禅坊中灯时不得卒灭。当言诸大德敷褥欲灭灯。便以手遮唱言。灯欲灭灯欲灭。不听用口吹灭手扇灭及衣扇灭当[敲-高+(立/(可-一))]折头燋去。至后夜时当复起先然厕屋。次然道经行处。次然阁道头。次然禅坊中。然禅坊中时不得卒入然。当唱言。诸大德灯欲入灯欲入。次唱说偈晓欲灭时。当先灭阁道头。次灭行处。次灭厕屋中。次灭禅坊中灯。然灯法应如是。若不如是越威仪法也

佛住舍卫城。尔时诸比丘禅坊中坐禅低仰而睡。诸比丘以是因缘往白世尊。佛言。从今已后。应行禅杖。六群比丘行禅杖时。捣比丘胁肋。彼即惊唤杀我长老诸比丘以是因缘往白世尊乃至佛言。从今日后。应如是行禅杖。作禅杖法应用竹若[竺-二+韋]长八肘物。裹两头。下坐应行。行时不得覆头覆右肩着革屣。当偏袒右肩。若有睡者不得卒急唤起。不得捣胁。当并边以杖拄前三摇复不觉者。若在左边当拄右膝。若在右边当拄左膝。觉已当起取杖而行。亦不得覆头覆右肩。当偏袒而行。若睡者众多。不得如牛一时并起应两人三人起。年少应行杖。若和上阿阇梨睡。亦应令起。恭敬法故。应起取杖。弟子不得与杖当自行。行杖人不得随嗔爱而求其过。当摄六情一心思惟。若有睡眠者应与彼取杖人不得嫌恨。当作是念。彼今与我除阴盖。益我不少。念已应起行。若有睡者应与。行禅杖法应如是。若不如是越威仪法也

佛住舍卫城。尔时比丘行禅杖。天寒手战。诸比丘以是因缘往白世尊。佛言。从今日后应作丸。六群比丘行丸时。掷胸掷面。比丘惊言杀我诸比丘以是因缘往白世尊。佛言。从今日后。作丸法掷丸法应如是。云何如是。作丸法应用若线若毛若[疊*毛]作。不得令太坚。不得太软。行法当先与中央人。若有睡者不得趣掷头面。当掷前前人。恭敬法故应起取。取已还坐。若和上阿阇梨睡者不得置亦应与丸。彼恭敬法故应起。弟子应代行丸。彼应还坐不得侠恨求过。得丸者当作是念。彼今与我除阴覆饶益不少。行丸法应如是。若不如是越威仪法

佛住舍卫城。尔时六群比丘禅坊户前脱革屣。以底相拍。如提干鱼而入。乱坐禅比丘。诸比丘以是因缘往白世尊。乃至佛言。从今已后。禅坊中脱革屣应如是。云何如是。不听禅坊户前拍革屣。若地有覆者。当脱持入。不得如提干鱼。当以底相搭。衣覆而入。当着右边尼师檀下。若地无覆者。当徐徐着入。脱已而坐。禅坊内革屣应如是。若不如是越威仪法

佛住舍卫城。尔时六群比丘禅坊内立。抖擞尼师檀作声。乱诸比丘。诸比丘以是因缘往白世尊。佛言。从今已后。禅坊中尼师檀应如是。云何如是。不得禅坊中抖擞尼师檀。当中襞亵置左肩上而去。到已中屈叠敷而坐来时亦当襞亵着肩上而还。若欲置常处者当中掩之。还时当徐舒而坐。禅坊中尼师檀应如是。若不如是越威仪法

佛住舍卫城。尔时六群比丘禅坊中故大謦欬作声。乱诸比丘。诸比丘以是因缘往白世尊。乃至佛言。从今已后。禅坊中謦欬应如是。云何如是。若欲謦欬时不得放恣故大作声。当掩口徐徐作声。若大不可制当起出。出已欬竟还入。若犹故不止者。当语知事人已去。謦欬法应如是。若不如是越威仪法

佛住舍卫城。尔时六群比丘以草根以缕以屑。散着鼻中连啑作声。乱坐禅比丘。诸比丘以是因缘往白世尊。佛言。从今已后。啑应如是。云何如是。禅坊中啑者不得放恣大啑。若啑来时当忍以手掩鼻。若不可忍者。应手遮鼻而啑。勿使涕唾污溅比坐。若有啑者不得言语。若上座啑者应言和南。下坐者默然。啑法应如是。若不如是越威仪法

佛住舍卫城。尔时六群比丘禅坊中欠呿。张口舒臂频申骨节作声。乱诸比丘。诸比丘以是因缘往白世尊。乃至佛言。从今已后。频申欠呿法应如是。云何如是。若坐禅坊内坐欠呿欲来时。不得放恣大欠呿频申作声。应当自制。若不可忍者。当手覆口徐徐欠。不得乱比坐。频申时当先举一手下已次举一手。欠呿频申法应如是。若不如是越威仪法

佛住舍卫城。尔时六群比丘禅房中坐。把搔擖擖作声。乱诸比丘。诸比丘以是因缘往白世尊。乃至佛言。从今已后。应如是把搔。云何如是。不得大把搔令擖擖作声。不得用指甲及木把搔。若大痒者当以手摩若指头刮。把搔法应如是。若不如是越威仪法

佛住舍卫城尔时六群比丘餐糗啖豆多饮酪浆。在禅坊中四角头坐。迭互放气粗细作声而言。长老。此声调和甚好不。以手把气而拄他鼻言。长老香不。诸比丘以是因缘往白世尊。乃至佛言。从今已后。下风事应如是。云何如是。不得故食多气物用作调戏。禅房中若急下风来者当制。若不可忍者。当向下坐。若下坐处有僧上座者。应还向上座。放气时不得令大作声扰乱比坐。若食上下风来者亦向下坐。勿令扰乱比坐。若和上阿阇梨长老比丘前者。当出去在下风勿令臭熏。若共贾客道行。不得在前纵气。若气来不可忍者当下道在下风放之。放下风法应如是。若不如是越威仪法

  然灯行禅杖　　掷丸持革屣
  尼师檀謦欬　　啑及频申欠
  把搔及下风　　第七跋渠竟

云何是威仪非威仪。威仪者二部比尼随顺行。是名威仪。不随顺行是名非威仪。威仪众学越恶心无心触女人一切心悔越比尼威仪竟

摩诃僧祇律卷第三十五摩诃僧祇律卷第三十六

        东晋天竺三藏佛陀跋陀罗共法显译

    明八波罗夷法初

婆伽婆三藐三佛陀。从本发意所修习者皆悉成就。住迦维罗卫释氏精舍。为诸天世人恭敬供养。广说如上。尔时大爱道瞿昙弥。与阐陀夷阐陀波罗陀婆阐陀阐陀母如是等五百释女。往诣佛所头面作礼却住一面。时大爱道白佛言。世尊。佛兴难值得闻法难。今遭如来出世演说甘露妙法。令诸众生成就寂灭妙证。如大爱道出家线经中广说。乃至佛言。从今日后。大爱道比丘尼僧上座如是持。尔时大爱道瞿昙弥白佛言。世尊。以为诸比丘制四堕重法。我等得广闻不。佛言得。瞿昙弥。若信心善女人欲得五事利益者。当尽受持此比尼。何等五。若信心善女人欲建立佛法者。当尽受持此比尼。欲令正法久住者。当尽受持此比尼。不欲有疑悔请问于他人者。当尽受持此比尼。诸有比丘尼犯罪恐怖为作依怙者。当尽受持此比尼。欲游化诸方而无挂碍者。当尽受持此比尼。是名笃信善女人受持此比尼五事利益。余如上比丘初五缘中广说。若比丘尼不还戒戒羸不出。受淫法乃至共畜生。是比丘尼犯波罗夷。不应共住。比丘尼者。受具足善受具足。一白三羯磨无遮法。和合二部众。如法非不如法。和合非不和合。满二十非不满二十。是名比丘尼不还戒戒羸不出者。如上比丘中广说。受者欲心受。淫者非梵行。若比丘尼与人男眠觉死。如是非人男畜生男眠觉死。人非人畜生不能男眠觉死。三疮门。若口若小行道大行道。若一一受乐者。是比丘尼波罗夷不应共住。波罗夷者。谓于法智退没堕落无道果分。是名波罗夷。如是乃至尽智无生智。于彼诸智退没堕落无道果分。是名波罗夷。又复波罗夷者。于涅槃退没堕落无道果分。是名波罗夷。又复波罗夷者。于梵行退没堕落。是名波罗夷波罗夷者所可犯罪。不可发露悔过。故名波罗夷。若比丘尼染污心欲看男子。越比尼心悔。若眼见若闻声。越比尼罪。裸身相向偷兰罪。乃至入如胡麻波罗夷。若比丘尼不说还戒不说不还戒。戒羸便作俗人。随其所犯得。罪若作外道亦如是。若裹不覆若覆不裹。亦覆亦裹不覆不裹。乃至入如胡麻。皆波罗夷。若比丘尼不还戒戒羸不出。便作俗人形服而犯者。随其犯得罪。若比丘尼于比丘边强行淫者。比丘尼波罗夷。比丘受乐者亦波罗夷。若比丘比丘尼共行淫者。俱波罗夷。比丘尼共沙弥行淫者。比丘尼波罗夷。沙弥驱出。俗人亦如是。若比丘尼共三种行淫。人非人畜生。复有三种上中下道。复有三种若觉若眠若死皆波罗夷。比丘尼若眠心狂入定。有人就上行淫。比丘尼觉。若初中后受乐者波罗夷。比丘尼若眠心狂入定。人就上行淫。觉已初不受乐。中后受乐者亦波罗夷。比丘尼若眠心狂入定。人就上行淫。觉已初中不受乐。后受乐者亦波罗夷。比丘尼若眠心狂若入定。人就上行淫。觉已初中后不受乐无罪。云何受乐。云何不受乐。受乐者。譬如人饥得种种美食彼以食为乐。又如渴人得种种好饮彼以饮为乐。受欲乐者亦复如是。不受乐者。譬如好净之人以种种死尸系其颈。又如破痈热铁烙身。不受乐者亦复如是。若比丘尼受淫。若买得若雇得。若恩义得若知识得。调戏得试弄得未更事得。如是一切得而受淫者。皆波罗夷。若心狂不觉者无罪。是故说。若比丘尼不还戒戒羸不出。受淫法乃至共畜生。是比丘尼犯波罗夷不应共住。第二第三第四如比丘戒中广说。若比丘尼于聚落空地。不与取随盗。物主或捉或杀或缚或摈出。咄女人汝贼汝痴耶。比丘尼如是不与取波罗夷。不应共住。若比丘尼自手夺人命。求持刀与杀者。教死叹死。咄人用恶活。为死胜生。作如是意如是想。方便叹誉死快。因是死非余者。是比丘尼波罗夷。不应共住。若比丘尼未知未了。自称得过人法。圣知见殊胜如是知如是见。彼于后时若捡挍若不捡挍犯罪。欲求清净故便作是言。阿梨耶我不知言知不见言见空诳不实语除增上慢。是名比丘尼波罗夷不应共住

佛住迦维罗卫国尼拘类树释氏精舍。尔时世尊制戒不听比丘尼阿练若处住。时赖吒比丘尼聚落中未有精舍。寄释种家住。授释种年少经。赖吒比丘尼身色端正而未离欲。年少亦复端正俱未离欲。一日之中三来受经。时比丘尼数数见已欲心耽着。遂至成病颜色萎黄。诸比丘尼问讯言。阿梨耶何所患苦。须何等药。若须酥油蜜石蜜当相给与。答言不须。自当差耳。优婆塞优婆夷问讯亦如是。时释种年少问言。阿梨耶何所患苦。须何等药。当相给与。家中有者与。若无者当余处求索与。答言长寿。非如是等药能差。复问。阿梨耶。是病非是身病故。当知心病耳。答言。如汝所说。复问。此病云何当差。比丘尼言。汝欲使我差不。答言欲使差。又复语言。当须何物今求相与。比丘尼言。共作是事来。年少答言不敢。余出家人被袈裟者。我尚不生此心。而况是师我所尊重。复言。若不能者。但抱我呜。捉我上下扪摸我。答言但须尔者我能为之。即便抱呜捻捉两乳上下摩扪。得适意已后数数如是。如世尊说。念色不忘染污心起。如女人忆男男忆女人。从是已后数数。不止。余比丘尼语言。阿梨耶莫作是事。此不得尔答言。我作此事便得悦乐。比丘尼即以此事语大爱道。大爱道闻已往白世尊。佛言。呼赖吒比丘尼来。来已问言汝实漏心。漏心男子边肩以下膝以上摩触受乐耶。答言。实尔世尊。佛言。赖吒。此是恶事。汝常不闻我无量方便呵责淫欲。欲为迷醉。欲如大火烧人善根。欲为大患。我常种种方便称赞离欲断欲度欲。汝今云何能作此恶事。此非法非律。不可以是长养善法。佛语大爱道瞿昙弥。依止迦维罗卫住比丘尼皆悉令集。集已尔时世尊以是因缘。向诸比丘尼广说过患事起。种种因缘呵责过患事起已。为诸比丘尼随顺说法。有十事利益。如来应供正遍知。为诸弟子制戒立说波罗提木叉法。何等十。一者摄僧故。二者极摄僧故。三令僧安乐故。四折伏无羞人故。五有惭愧人得安隐住故。六不信者令得信故。七已信者增益信故。八于现法中得漏尽故。九未生诸漏令不生故。十正法得久住故。为诸天世人开甘露门故。是为十。以是十事。如来应供正遍知为诸弟子制戒立说波罗提木叉法。乃至未闻者当闻。已闻者当重闻。若比丘尼漏心。漏心男子边肩以下膝以上摩触受乐者。是比丘尼波罗夷不应共住。比丘尼者如上说。漏心男子者。欲心。肩以下者。乳房以下。膝以上者。大髀上至脐。摩触者。移手摩扪。受乐者。觉快乐。染著者。是比丘尼波罗夷波罗夷者如上说。不共住者。不得共比丘尼住。法食味食。如前后亦如是。如后前亦如是。波罗夷罪不应共住。若比丘尼漏心。漏心男子肩以下膝以上摩触受乐者波罗夷。不应共住。如是不能男及女人偷兰遮罪。比丘尼漏心男子不漏心。亦波罗夷。不能男及女人偷兰遮罪。比丘尼无漏心男子有漏心。偷兰遮。不能男及女人越比尼罪。比丘尼无漏心男子无漏心。越比尼罪不能男子女人。越比尼心悔

若比丘尼使男子剃发时。两女人痛。按令觉女人不觉男子。如是刺头出血刺臂刺脚时。当使女人急捉。令觉女人不觉男子。肩以上膝以下若有痈疮。使女人捉男子破无罪。隐处不得。隐处者。肩以下膝以上。若是处有病者。当使女人治。是故说

佛住毗舍离。诸天世人恭敬供养。广说如上。尔时赖吒波罗比丘尼。授离车童子经。乃至说。余出家人着袈裟者。我尚不生此心。而况是师所尊重者。比丘尼言。若不尔者。近我住共语。捉我手捉我衣。来欢喜请坐。曲身就共期行。彼答言。但如是者可尔。如是适意已数数不止。如世尊说。念色不忘染污心起。如女忆男男忆女。诸比丘尼语大爱道。大爱道以是因缘往白世尊。佛言。呼赖吒波罗比丘尼来。来已佛具问上事。汝实尔作是事不。答言实尔。佛言。此是恶事。汝云何漏心。漏心男子边申手内住乃至共期。从今已后。不听漏心漏心男子边申手内住乃至共期。佛告大爱道瞿昙弥。依止毗舍离比丘尼皆悉令集。以十利故与诸比丘尼制戒。乃至已闻者当重闻。若比丘尼漏心。与漏心男子申手内住共语。受捉手捉衣。来欢喜请坐。曲身就共期去。是比丘尼波罗夷。不应共住。比丘尼者如上说。比丘尼漏心漏心男子者。二俱欲心。申手内住者。舒手所及处。语者共耳语受捉手者。若捉手若捉腕若大指若小指。若捉衣者。僧伽梨郁多罗僧安陀会僧祇支雨衣。来欢喜者。善来欣悦常数数来。请坐者。我已敷床褥可坐。曲身者。亚身往就。期去者。若店肆前园泽中若常行来处。是比丘尼。波罗夷不应共住。波罗夷者如上说。若比丘尼漏心。漏心男子申手内共语。受捉手捉衣。来欢喜请坐曲身共期去。是比丘尼波罗夷不应共住。如是不能男及女人偷兰遮。比丘尼漏心男子不漏心亦波罗夷。不能男及女人偷兰遮。比丘尼无漏心男子漏心偷兰遮。不能男及女人越毗尼罪。俱无漏心越比尼罪。不能男及女人越比尼心悔。若比丘尼漏心漏心男子申手内住乃至共期去波罗夷。若一一次第犯八事波罗夷。若间犯满者亦波罗夷。若犯一即悔偷兰遮。悔已复犯。乃至第七偷兰遮满八者。波罗夷。是故说佛住毗舍离。广说如上。尔时离车初生二男。次生一女以为不吉。心自念言。今此不祥之女谁当取者。有人语言。汝欲安处此女不。答言欲得。若尔者可持。与迦梨比丘尼。当与汝养育。即便唤迦梨来。白言阿梨耶。我今生此不吉之女无人取者。与我长养度令出家。我自给衣食。比丘尼即取养育便与出家。家中日日送食年年与衣。长大与学戒。次受具足女人之法淫欲偏多。年遂转大欲情亦炽。不能自制。即白师言。我结使起不乐出家。今欲还俗。师言怪哉。俗中犹如火坑。何由可乐。从是以后。渐与俗人及诸外道交通遂便有娠。比丘尼即便驱出。语其师言。汝不知弟子与俗人外道私通耶。答言。我亦早知。但其家日日送食年年得衣。若当白僧便当驱出。我利此二事是故不说。比丘尼即语大爱道。大爱道即以是事往白世尊佛言。唤迦梨来。来已问言。汝实尔不。答言。实尔世尊。佛言。此是恶事。迦梨汝云何知比丘尼犯重罪。覆藏此非法非律不可以是长养善法。佛语大爱道。依止毗舍离比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼知比丘尼犯重罪不向人说。是比丘尼若离处若死若罢道。后作是言。我先知是比丘尼犯重罪。不向人说。不欲令他知。是比丘尼波罗夷不应共住。比丘尼者如上说。知者。若自知若从他闻。重罪者。八波罗夷中若犯一一。不向人说者。不向一人若众多若僧中不说。离处者若驱出。死者无常。罢道者离此法律作俗人外道。已后便言。我先知其犯罪但不欲令人知。是比丘尼波罗夷不应共住。波罗夷者如上说。若比丘尼明相出时。见比丘尼犯重罪。不作覆藏心。至日出时作覆藏心至明相出时。是比丘尼犯波罗夷。是名二时。如是乃至八时。如比丘覆藏中广说。若比丘尼见比丘尼犯重罪。应向人说。若见共住弟子依止弟子犯重罪。便作是念。我若向人说者。比丘尼便当驱出。以爱念故覆藏其罪。得波罗夷。是比丘尼闻是语已。语知识比丘尼言。某甲犯重罪。若我语人者比丘尼僧当驱出。是以我覆藏。彼比丘尼闻已复作是念。我若说者是二人俱驱出即便覆藏。俱得波罗夷。如是一切展转覆藏。皆波罗夷。若比丘尼见他犯重罪。语余比丘尼言。我见某甲犯重罪。此比丘尼即呵言。汝今作恶何故语我莫复说。得偷兰遮。若比丘尼见比丘尼。犯重罪。应向人说。若犯罪人凶恶可畏有势力恐夺其命伤梵行者。当作是念。行业罪报彼自应知。喻如失火烧屋。但当自救焉知他事。得舍心相应者无罪。是故说

佛住拘睒弥瞿师罗园。尔时阐陀。五众罪中犯若一若二。诸比丘言。长老阐陀。汝见是罪不。答言。汝用问我见不见为我不见。诸比丘以是因缘往白世尊。佛语比丘。是阐陀于五众罪中若犯一一而言不见者。僧应与作不见罪举羯磨。僧与作不见罪举羯磨已。往诣比丘尼精舍言。婆路醯谛。僧与我作举羯磨。不共法食味食。即言怪哉。今我共汝法食味食。即便随顺。比丘尼谏言。阐陀母。是阐陀僧和合如法作举羯磨。未作如法莫随顺。答言。我是其母是我所生。我不随顺谁当随顺。比丘尼即语大爱道。大爱道即以是事往白世尊。佛言是阐陀母比丘尼僧如法作举羯磨而随顺者。汝应屏处三谏。众多人中三谏。僧中三谏。令舍此事。屏处谏者。应问言。汝实知阐陀僧如法作举羯磨而随顺耶。答言实尔。应谏言。阐陀母。僧如法作举羯磨。未作如法莫随顺。我今慈心谏汝。欲饶益故。一谏已过二谏在。舍此事不。如是第二第三谏亦如是。众多人中三谏亦如是。若不舍者。僧中应作求听羯磨。应作是说。阿梨耶僧听。僧与阐陀如法作举羯磨。未作如法。阐陀母与随顺。已屏处三谏多人中三谏令舍此事而不舍。若僧时到。僧今亦当三谏令舍此事。僧中应问阐陀母。汝实知和合僧如法与阐陀作举羯磨。未作如法而汝随顺。已屏处三谏。众多人中三谏。令舍此事而不舍耶。答言实尔。即应谏言。僧和合如法与阐陀作举羯磨。汝莫随顺。僧欲饶益故谏汝。汝当随顺僧语。一谏已过二谏在。汝舍不。答言不舍。如是第二第三谏犹言不舍。比丘尼以是因缘往白世尊。佛言唤来。来已问言。汝实尔不。答言实尔。佛言。此是恶事。汝常不闻我无量方便毁呰佷戾难谏称誉易谏也。此非法非律非如佛教。不可以是长养善法。汝云何被举比丘而随顺。从今日后。不听随顺被举比丘。佛语瞿昙弥。依止拘睒弥比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼知僧和合如法比尼与比丘作举羯磨。未作如法而随顺。诸比丘尼应谏是比丘尼。阿梨耶。是比丘僧和合如法比尼作举羯磨。未作如法莫随顺是比丘。诸比丘尼谏时作是语。我不随顺谁当随顺。诸比丘尼如是第二第三谏舍是事好。若不舍者是比丘尼波罗夷不应共住。比丘尼者如上说。知者。若自知若从他闻和合者。非别众。如法比尼者。不见罪不作罪。三见不舍。三者。谤契经邪见边见。被举者。不共住。未作如法者。未随顺僧。未解随顺者。共法食味食。诸比丘尼谏是比丘尼作是语。阿梨耶。是比丘僧如法比尼作举羯磨。未作如法莫随顺法食味食。谏时便作是语。我不随顺谁当随顺。应重谏乃至三谏。舍者善。若不舍者是比丘尼波罗夷。波罗夷者如上说。屏处三谏舍者善。若不舍者谏。谏越比尼罪。众多人中亦如是僧中初谏时越比尼罪。谏竟偷兰遮。第二初谏时越比尼谏竟偷兰遮。第三初谏时偷兰遮。谏竟波罗夷。若屏处众多人中僧中一切越比尼。一切偷兰遮。成一重罪名波罗夷。若中间舍者随事治

  淫盗断人命　　不实称过人
  肩以下膝上　　漏心八事满
  覆重并随举　　八波罗夷竟

    明十九僧残法之一

受使行如比丘中广说。是故世尊说。若比丘尼受使行。和合男女若取妇若私通。乃至须臾顷。是法初罪僧伽婆尸沙。二无根如比丘中广说。是故世尊说。若比丘尼嗔恨不喜故。于清净无罪比丘尼。以无根波罗夷法谤。欲破彼比丘尼净行。彼于后时若捡挍若不捡挍。便作是言。是事无根。我住嗔恨故作是语。是法初罪。是故世尊说。若比丘尼嗔恨不喜故。以异分事中小小事。非波罗夷比丘尼。以波罗夷法谤。欲破彼梵行。彼于后时若捡挍若不捡挍。以异分中小小事。是比丘尼住嗔恨故说。是法初罪。佛住舍卫城。比丘尼僧伽蓝。外道尼住处。中隔墙崩。尔时偷兰难陀比丘尼语。外道尼言。汝当补治。汝等无羞人徒众来往裸形出入。我此众善好有惭羞。见汝等结使增长。彼答言。今是雨时不可得作。须雨时过当作。比丘尼言。今当驶作不得待后。彼言。我不能作。比丘尼嗔言。短寿。啖酒糟驴。汝敢不作。无惭无愧邪见不信。汝速治去。外道尼骂言。众多人子大腹沙门尼。汝便杀我。终不与汝作。比丘尼即往断事官所。具说上事。长寿为我敕彼作隔墙。时断事官信于佛法。即录外道尼来。来已语言。弊恶短寿啖酒糟驴邪见外道。何不作墙隔。汝等无羞裸形出入。是阿梨耶梵行人。设见汝等增长结使。汝急作去。若不作者当加汝罪。外道尼即作。昼成已夜雨便坏。如是夏三月作不能使成。于是外道嫌责语诸优婆塞言。看汝福田。倚恃官力驱我泥作三月。诸优婆塞妇女闻已语比丘尼。比丘尼闻已向大爱道说。大爱道即以是事具白世尊。佛言。唤比丘尼来。来已佛问。偷兰难陀汝实尔不。答言实尔。佛言。此是恶事。汝云何共斗相言。此非法非律不如佛教不可以是长养善法。佛告大爱道。依止舍卫城住比丘尼。皆悉令集。以十利故与诸比丘尼制戒。乃至已闻者当重闻。若比丘尼诤讼相言。若俗人若出家人昼日须臾。乃至与园民沙弥共斗相言。是法初罪僧伽婆尸沙。比丘尼者如上说。诤讼者口诤讼。俗人者在家人。出家者。外道出家乃至阇致罗。昼日者。齐日没。须臾者。乃至须臾顷。下至沙弥园民。初罪者。不待三谏。僧伽者。谓八波罗夷婆尸沙者。是罪有余僧应羯磨治故。说僧伽婆尸沙。复次是事僧中发露悔过故。亦名僧伽婆尸沙。若比丘尼至王家断事官所相言者。僧伽婆尸沙。道说偷兰遮。若至优婆塞家信心家道说越比尼罪。心嫌者越比尼心悔。若比丘尼至王家相言越比尼罪。嫌说者越比尼心悔。是故世尊说。佛住舍卫城。尔时赖吒比丘尼妹。嫁适异村得病。遣信唤赖吒言。及我未死早来看我。可得相见。即便往看。未得至间而妹命终。到已其妹婿语赖吒言。汝妹命过。谁当料理家内看视儿子。唯愿赖吒。为我料理以代妹处。比丘尼便作是念。此人出是恶声。或能强见侵掠。即怀怖惧佯如出外。便还舍卫城语诸比丘尼言。异哉其当坏我梵行。诸比丘尼问言。以何事故。便具说上事。诸比丘尼闻已语大爱道。大爱道即以是事具白世尊。佛言。唤是比丘尼来。来已问言。汝实尔不。答言实尔世尊。佛言。汝云何道路独行从今日后不听独行。复次诸比丘尼道路行。有一年少比丘尼。下道便利。在后诸贾客来见比丘尼端正。即便遮问。汝年少端正正应受欲。何以出家请说其故。比丘尼言。我出家何用问为。复言不尔。会当有意语我。答亦如初。如是戏弄已须臾放去。到聚落已心生疑悔语大爱道。大爱道即以是事具白世尊。佛言。不欲无罪。复次诸比丘尼共道行。有比丘尼病不及伴。独在后来已心生。疑悔语大爱道。大爱道即以是事具白世尊。佛言。病无罪。佛语大爱道。依止舍卫城比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼无比丘尼伴行。不得出聚落界。除余时。余时者不欲病。是名余时。是法初罪僧伽婆尸沙。比丘尼者如上说。无比丘尼伴者。独一人道行如上广说。除余时者。不欲病世尊说无罪。僧伽婆尸沙者如上说。若比丘尼着道行时未出界无罪。若到聚落城邑界时当相去在申手内。若相离申手外。一足过偷兰遮。二足过僧伽婆尸沙。一人界中间住偷兰遮。如是余人过偷兰遮。是故世尊说

佛住王舍城。王舍城中有人名羯暮子。取得羯暮女为妇。端正少双。持食与夫。世尊到时着入聚落衣。持钵入城次行乞食到其家。时妇作是念。若我夫见佛者。必当起看妨废饮食当户而立。于佛有缘。世尊即放光明照其舍内。其夫窥看。见佛便语妇言。汝大不善但欲减损于我。其妇言。我非欲相损。我畏见世尊已妨废食耳。其夫嗔言。女人情浅。欲少饶益而伤损不少。妇语夫言。大家郎听我出家。夫语妇言。欲何道出家。妇言。佛法出家。夫言相听。即往优钵罗比丘尼所求出家。即度出家受具足。初夜后夜精勤不懈。至八日得尽有漏。自知作证三明六通心得自在依树下坐。时释提桓因往到其所。即说颂曰

  帝释天营从　　来下稽首足
  观是羯暮女　　出家始八日
  优钵善比丘　　漏尽证六通
  所作已成办　　德力心自在
  折伏诸情根　　闭目树下坐
  是故今稽首　　世间良福田

此比丘尼有好清声。善能赞呗。有优婆塞请去。呗已心大欢喜。即施与大张好[疊*毛]。时诸天于虚空中。而说颂曰

  今汝得善利　　福德甚巍巍
  一切染着尽　　清净奉施衣
  今王舍城中　　清信诸士女
  何不来劝请　　微妙善法音
  亲近能离苦　　不请则不说
  闻已如修习　　则致胜妙处

是时诸人家家请呗。闻欢喜已大得利养。诸比丘尼各生嫉心。便作是言。此妖艳歌颂惑乱众心。诸比丘尼以是因缘往白世尊。佛言。唤是比丘尼来。来已问言。汝实作世间歌颂耶。答言。我不知世间歌颂。佛言。是比丘尼非世间歌颂。过去世时有波罗奈城王名吉利。有七女。一名沙门。二名沙门友。三名比丘尼。四名比丘尼婢。五名达摩支。六名须达摩七名僧婢。于迦叶佛前发愿。如七女经中广说。时比丘尼人复将去离众独宿。有比丘尼语大爱道。大爱道即以是事往白世尊。佛言。唤是比丘尼来。来已问言。汝实离众独宿不。答言实尔。佛言。从今日不听离众独宿。复次流离王罚迦维罗卫国。应广说。尔时诸比丘尼城外独宿。乃至除王难。复次尔时诸比丘尼着道行。老病不及伴独宿。心生疑悔问大爱道。大爱道即以是事往白世尊。佛言。不欲无罪。佛语大爱道瞿昙弥。依止舍卫城住比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼离比丘尼一夜宿除余时。余时者。若病时贼乱围城时。是名余时。是法初罪。比丘尼者如上说。一夜宿者。日未没至明相出。除余时者。不欲离宿老羸病贼乱围城。若城内不得出。城外不得入。是名余时。是法初罪僧伽婆尸沙。僧伽婆尸沙者如上说。若比丘尼离比丘尼宿。日未没至明相出。僧伽婆尸沙。日没以离至明相出。偷兰遮。若比丘尼僧伽蓝中共房宿。当相去一申手内。一夜中当三以手相寻看。不得一时顿三。当初夜一中夜一后夜一。初夜不寻看越比尼罪。中夜不寻看亦越比尼罪。后夜不寻看亦越比尼罪。一切时看无罪。若上阁下阁异宿者。一夜当三过往。如是僧伽蓝中宿偷兰遮。是故世尊说

佛住舍卫城。王舍城中有长者名曰须提那。有妇年少端正。其夫无常。妇不乐男子。叔欲摄取。即语余妇人言。我不乐男子。而叔欲取我为妇。女人语言。汝欲得离不。答言。我欲离。即语言。汝往舍卫城。就迦梨比丘尼所。当度汝出家。此妇人似如出行。便诣舍卫城问人言。何者是比丘尼僧伽蓝。即示处。入已问言。何者是迦梨比丘尼房。即示房处入已问言。阿梨耶是迦梨非。答言是。为何故问。答言。我欲出家。即度出家受具足。其叔于后求不知处。有人语言。舍卫城迦梨比丘尼已度出家。便往舍卫城问人言。何者是比丘尼僧伽蓝。即示处。入已问言。何者是迦梨比丘尼房。即示处。入已问言。阿梨耶是迦梨耶。答言是。何故问。便言。我不放妇。何故度我妇出家。尼言长寿。汝何处来。答言。王舍城来。比丘尼骂言。短寿物汝是贼。王舍城人恒来喜作细作。伺国长短。即语弟子。取我僧伽梨来。系此短寿闭着狱中。其人即恐便作是念。此人眼目可畏。或能必尔。眼并眄之渐渐却行。出外已嗔恚言。此比丘尼盗度我妇。反欲系我。诸比丘尼闻已语大爱道。大爱道即以是事往白世尊。佛言。呼比丘尼来。来已佛问。汝实尔不。答言实尔。佛告迦梨。此是恶事。汝云何主不听而度人。从今日不听主不放而度。即语大爱道。依止舍卫城比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼其主不听而度。是法初罪僧伽婆尸沙。比丘尼者如上说。不听者。未嫁女。当问父母。已出嫁当问婿姑妐及叔。不听者度出家受具足者。僧伽婆尸沙。僧伽婆尸沙者如上说。是法初罪。若比丘尼主不听而度者越比尼罪。与学戒者偷兰遮。受具足者僧伽婆尸沙。是故世尊说

佛住舍卫城。尔时阿摩罗邑力士妇。年少端正与人私通。其夫语言。汝莫复作。若作者我当如是如是治汝。其妇故作不止。其夫即伺。合男子捉取。便送与断事官言。我妇与是人通。愿官与我如法治罪。如法治罪者言。若女人共他私通者。应七日二众前集。集会七日已于二家众前中裂其身。官便语妇言。汝且还归。若家有者。可往办具布施饮食。若无者随意。满七日已当于二众前中裂汝身。即便还家具办饮食施于二众。此妇于屏处啼泣。诸母人问言。汝何故啼耶。答言。我那得不啼。满七日已当于二众前中裂我身。母人言。汝欲得活不。答言尔。便语言。汝往舍卫城迦梨比丘尼所。求索出家可得活。众人酒醉。于是女人似如小出。即诣舍卫城问人言。比丘尼僧伽蓝在何处。示处。入问人言。何者是迦梨比丘尼房。即示其处入已白言阿梨耶。我欲出家。问言。主听汝未。答言。云何听。比丘尼言。若未出嫁父母听已。嫁者姑妐夫主叔听。是则听。答言。若尔者已自是听。诸宗亲都欲中裂我身弃舍竟。比丘尼言。若尔者已好放汝。即度出家受具足。其人求觅欲治罪不见。闻舍卫城比丘尼已度出家。即诣舍卫城问人言。何者是比丘尼精舍。人即示处。入已问言。何者是迦梨比丘尼房。示言此是。入已问言。阿梨耶。是迦梨比丘尼耶。答言。何以故问彼言。我不放妇。何以度出家。长寿。汝家在何处。答言在阿摩勒邑。便语言。短寿汝是贼。汝不知耶。阿摩勒人恒喜来此。伺求国便欲为细作。便语弟子。取我衣来。我当告王系此短寿。其人闻已念言。此比丘尼眼目角张。或能作恶。渐渐却行。出外嗔恚骂詈。此沙门尼。盗度我妇反欲系我。诸比丘尼闻已语大爱道。大爱道即以是事具白世尊。佛言。唤比丘尼来。来已佛言。迦梨此是恶事。汝云何知人犯罪众亲欲治罪而度出家。此非法非律非如佛教。从今日后。不听犯罪女人众欲治罪而度出家。复次释迦揵提邑有女人。如上说。乃至语比丘尼言。度我出家。比丘尼言。先已有比如此犯罪不听出家。复向余比丘尼。都无度者。便向外道求出家。其人欲取治罪而不知处。闻在舍卫城外道已度出家。其夫念言。此妇本是优婆塞女。而今堕外道邪见即是治罪。便不复寻求。诸外道法饮米泔汁及荡釜水裸形无耻。而复妻掠无度。其妇厌患言。此非出家之法。即舍向比丘尼精舍。白言。我堕深坑崩岸当堕泥犁。唯愿牵我出家。诸比丘尼无敢度者。便诣大爱道白言。阿梨耶。是我亲里释家女今堕深坑。愿度我出家。大爱道即以是事往白世尊。佛言得。若先外道度后听出家。佛告大爱道。依止舍卫城比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼知犯罪女众亲欲治而度除余时。余时者。先外道度。是名余时。是法初罪。比丘尼者如上说。知者。若自知若从他闻。众者。二众集父母众。夫家众亲者。婆罗门宗姓。刹利宗姓。毗舍宗姓。首陀罗宗姓。治罪者。或以薄裹而烧。或沙囊系颈沉着水中或火烧头。或截耳截鼻。或烧热铁烙小便道。或中裂其身。如是国法种种不同。除先在外道出家者。世尊说无罪外道者。尼揵帝梨檀迟伽。如是比外道。是法初罪僧伽婆尸沙者如上广说。若比丘尼知犯罪女应治度出家越比尼罪。与学法者偷兰遮受具足僧伽婆尸沙。是故世尊说

佛住舍卫城。尔时众多女人在阿耆罗河彼岸。此岸比丘尼僧集。时偷兰难陀比丘尼。脱衣放地截流浮渡。诸女人共相谓言。看是偷兰难陀比丘尼浮渡而来。来已于露处坐已。须臾复还渡。诸女人嫌言。云何是偷兰难陀比丘尼如凶恶人渡已复还。诸比丘尼闻已语大爱道。大爱道即以是事往白世尊。佛言。唤偷兰难陀比丘尼来。来已佛言。此是恶事。汝云何于船渡处而独浮渡。从今日后不听于船渡处而独浮渡。佛告大爱道。依止舍卫城。比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼于船渡处独渡河者。是法初罪僧伽婆尸沙比丘尼者如上说。独渡者出界到彼岸僧伽婆尸沙

佛住舍卫城。尔时迦梨比丘尼于聚落中游行。去后有依止弟子。僧与作举羯磨。师还弟子白言。僧与我作举羯磨。不共法食味食。即呵言汝且默然。但使僧集即便集僧。诸比丘尼各作是念。是比丘尼行还集僧。常喜有施物。我等今日当得何物。皆喜速集。集已即作是唱阿梨耶僧听。某甲比丘尼僧作举羯磨。若僧时到。僧与某甲比丘尼舍举羯磨。如是白。阿梨耶僧听某甲比丘尼僧与作举羯磨。僧今与某甲比丘尼舍举羯磨。阿梨耶僧忍与某甲比丘尼舍举羯磨者默然。若不忍者便说。是第一羯磨如是三羯磨。诸比丘尼见此比丘尼眼目可畏。无敢遮者。诸比丘尼展转相谓。此是何语。皆言我亦不知此语。诸比丘尼白大爱道。大爱道以是因缘往白世尊。佛言。唤是比丘尼来。来已佛问。汝实尔不。答言实尔。佛言。此是恶事。汝云何知比丘尼僧如法比尼作举羯磨未行随顺未作如法先不语僧自舍羯磨。从今日后不听。佛告大爱道。依止舍卫城比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼知比丘尼僧和合如法比尼作举羯磨。未作如法先不语僧自与舍。是法初罪僧伽婆尸沙。比丘尼者如上说。知者。若自知若从他闻。和合者。非别众。如法比尼者。不见罪不作三见。不舍举羯磨者。不共住。未作如法者。未行随顺心未调伏。僧未与舍先不语者。僧中未作求听羯磨而自僧中舍。是法初罪僧伽婆尸沙。僧伽婆尸沙者如上说。若弟子僧和合作举羯磨者。若和上尼阿阇梨尼。应至长老比丘尼所作是言。谁无愚痴恒无有过。慧心常存不知故尔。更不复作。如是遍语诸人已令心柔软。然后于僧中作求听羯磨。当作是说。阿梨耶僧听。某甲比丘尼有是事故僧作举羯磨彼行随顺心柔软舍。若僧时到。僧某甲欲从僧乞舍举羯磨。诸阿梨耶听。某甲欲从僧乞舍举羯磨。僧忍默然故。是事如是持。然后应乞。若有人遮者。和上应软语令止。若比丘尼知僧和合如法比尼作举羯磨。而自舍者。得越比尼罪

佛住王舍城。尔时有一长者。欲心请树提比丘尼。与衣钵饮食疾病汤药。作是言。阿梨耶。知我以何故与。比丘尼言知。复问。云何知。答言。以福德故。复言。如是然后兼为欲故。时树提是离欲人。闻是语其心游然不持经怀。然复不遮。诸比丘尼即以是事语大爱道。大爱道即以是事往白世尊。佛言。呼树提来。来已具问上事。汝实尔不。答言。实尔。世尊。佛言。此是恶事。汝不为后世人作轨则耶。此非法非律不如佛教。不可以是长养善法。佛语大爱道。依止王舍城比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼无漏心。漏心男子边取衣钵饮食病疾汤药者。是法初罪僧伽婆尸沙。比丘尼者如树提比丘尼。无漏心者。无欲心。钵者。上中下。衣者。僧伽梨郁多罗僧安陀会僧祇支雨浴衣。饮食者。佉陀尼食蒲阇尼食。药者蜜石蜜生酥及脂。是法初罪。若人与比丘尼衣钵饮食疾病汤药作是言。我为是故与不应受。应言我不须余家自得。若受者僧伽婆尸沙。若不语动手足瞬眼振手弹指画地作字。如是相者。知有欲心于我。此不应受。受者偷兰遮。若信心清净诸情审谛受者无罪。若女人欲心与比丘。若动手足瞬眼与者。当知有欲心不应受。受者越比尼罪。若信心清净诸根审谛受者无罪。是故世尊说

摩诃僧祇律卷第三十六摩诃僧祇律卷第三十七

        东晋天竺三藏佛陀跋陀罗共法显译

    明十九僧残法之余

佛住王舍城。尔时世尊制戒。不听漏心男子边取衣钵饮食疾病汤药。时树提比丘尼不取长者施衣。时偷兰难陀比丘尼语树提言。何不取此男子施。男子漏心不漏心何预人事。但使汝无漏心取已随因缘用。诸比丘尼谏是比丘尼。莫作是语。男子漏心不漏心何预人事。但使汝无漏心可取此施随因缘用。如是二谏三谏不止。诸比丘尼以是事语大爱道。大爱道即以是事往白世尊。佛言。唤比丘尼来。来已佛问。汝实尔不。答言实尔。佛言。此是恶事。汝云何劝彼。取漏心人施。此非法非律不如佛教。不可以是长养善法。佛语大爱道。依止王舍城住比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼语比丘尼作是语。可取此男子施。漏心不漏心何预汝事。但汝莫漏心。可取施已随因缘用。诸比丘尼应谏是比丘尼。莫作是语。应取是施。男子漏心不漏心何预人事。但使汝无漏心可取。施已随因缘用。如是应第二第三谏。舍是事好。若不舍者。是法初罪僧伽婆尸沙。作是语比丘尼者。如偷兰难陀比丘尼。取施者。如树提比丘尼。诸比丘尼谏是比丘尼令舍是事。如不舍者是法乃至三谏。僧伽婆尸沙。是故世尊说。佛住王舍城。破僧相助如比丘中广说。是故世尊说。若比丘尼欲破和合僧。故勤方便执持破僧事共诤。诸比丘尼应语是比丘尼。阿梨耶。莫破和合僧。勤方便执持破僧事共诤。当与僧同事。何以故。僧和合欢喜不诤。共一学如水乳合。如法说安乐住。是比丘尼。诸比丘尼谏时。坚持不舍者。应第二第三谏。舍者善。若不舍者是法乃至三谏。僧伽婆尸沙。诸比丘尼同意相助。若一若二若众多同语同见。欲破和合僧。是比丘尼。诸比丘尼谏时。是同意比丘尼言。阿梨耶。莫说是比丘尼好恶事。何以故。是法语比丘尼。律语比丘尼。是比丘尼所说。皆是我等心所欲。是比丘尼所见欲忍可事。我等亦欲忍可。是比丘尼知说非不知说。诸比丘尼应谏是同意比丘尼。阿梨耶。莫作是语。法语比丘尼律语比丘尼。何以故。此非法语比丘尼律语比丘尼。阿梨耶。莫助破僧事。当乐助和合僧。何以故。僧和合欢喜不诤。共一学如水乳合。如法说安乐住。是比丘尼诸比丘尼谏时。若坚持不舍者。应第二第三谏。舍是事善。若不舍是法乃至三谏。僧伽娑尸沙

佛住舍卫城。尔时偷兰难陀比丘尼有斗诤事。僧如法比尼。与作羯磨。羯磨竟嗔恚以非理谤僧。而作是言。阿梨耶僧。随爱随嗔随怖随痴。僧依爱依嗔依怖依痴。是故呵责此非法断事。是比丘尼。诸比丘尼谏言。阿梨耶。莫作非理谤僧。僧不随爱不随嗔不随怖不随痴。僧不依爱嗔怖痴非法断事。如是第二第三谏不止。诸比丘尼以是因缘语大爱道。大爱道以是事往白世尊。佛言。汝去应屏处三谏多人中三谏僧中三谏。令舍此事。屏处谏者。屏处应问。汝实嗔恚非理谤僧。僧随爱随嗔随怖随痴。僧依爱依嗔依怖依痴耶。答言实尔。屏处应谏言。汝莫嗔恚非理谤僧。僧不随爱随嗔随怖随痴。僧不依爱嗔怖痴非理断事。我今慈心谏汝。欲饶益故。一谏已过二谏在。舍是事不。答言不舍。如是第二第三谏。多人中亦如是。僧中应作求听羯磨。阿梨耶僧听。偷兰难陀比丘尼嗔恚非理谤僧。随爱随嗔随怖随痴。僧依爱嗔怖痴。已屏处三谏已多人中三谏。令舍此事而不舍。若僧时到。僧今亦应三谏。僧中应问。汝实嗔恚非理谤僧随爱随嗔随怖随痴乃至非法断事。已屏处三谏多人中三谏而不舍耶。答言实尔。僧中应谏言。汝莫嗔恚非理谤僧。僧不随爱不随嗔不随怖不随痴。乃至非理断事。僧今慈心谏汝。欲饶益故。当取僧语。一谏已过二谏在。舍是事不。答言不舍。第二第三谏犹故不舍。诸比丘尼以是因缘往白世尊。佛言。唤是比丘尼来。来已佛具问上事。汝实尔不。答言实尔。佛语偷兰难陀。此是恶事。汝常不闻我无量方便呵责佷戾称叹软语耶。汝云何佷戾。此非法非律非如佛教。不可以是长养善法。佛告大爱道。依止舍卫城住比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼嗔恚非理谤僧作是言。僧随爱随嗔随怖随痴。僧依爱嗔怖痴。是故呵责。是比丘尼。诸比丘尼应谏作是言。阿梨耶。莫作是语。僧随爱随嗔随怖随痴僧依爱嗔怖痴。何以故。僧不随爱嗔怖痴。汝莫嗔恚非理谤僧。是比丘尼。诸比丘尼谏时。坚持不舍者。应第二第三谏。舍是事善。若不舍是法乃至三谏。僧伽婆尸沙。比丘尼者如偷兰难陀比丘尼。嗔恚非理谤僧。屏处三谏不舍者。谏谏越比尼罪。多人中亦尔。僧中初谏时亦越比尼罪。谏竟偷兰遮。第二初谏时亦越比尼罪。谏竟偷兰遮。第三初谏时偷兰遮。谏竟僧伽婆尸沙。成僧伽婆尸沙已。屏处多人中僧中。一切越比尼罪偷兰遮。除八谤僧偷兰遮。余一切合成一僧伽婆尸沙罪治。若中间止者。随止处治罪。是故世尊说

佛住拘睒弥。阐陀母比丘尼。诸比丘尼共法中。如法如比尼教。当学莫犯自身作不可共语。如阐陀戾语中广说。乃至若比丘尼自用戾语。诸比丘尼共法中。如法如律教。便自用意作是言。汝莫语我若好若恶。我亦不语汝若好若恶。诸比丘尼应谏彼比丘尼言。阿梨耶。诸比丘尼共法中如法如律教汝莫自用。诸比丘尼教汝。汝当信受。汝亦应如法如律教诸比丘尼。何以故。如来弟子中展转相教展转相谏。共罪中出故。善法得增长故。是比丘尼。诸比丘尼谏时。坚持不舍者。应第二第三谏。舍是事善。若不舍是法乃至三谏。僧伽婆尸沙。如比丘戒中广说。是故说

佛住舍卫城。尔时有二比丘尼。一名真檀。是释家女。二名郁多罗。身习近住。口习近住。身口习近住。迭相覆过。身习近者。共床眠共床坐同器食。迭互着衣共出共入。口习近者。染污心语迭相覆罪。此犯彼覆彼犯此覆。身口习近者。二事俱。比丘尼谏言。阿梨耶。莫身习近住口习近住。莫身口习近住。莫迭相覆过。何以故。不生善法。一谏二谏三谏不止。诸比丘尼语大爱道。大爱道即以是因缘往白世尊。佛言。呼是比丘尼来。来已佛问言。汝实尔不。答言实尔。佛言。此是恶事。汝云何身口习近住迭相覆过。此非法非律非如佛教。不可以是长养善法。佛告大爱道。依止舍卫城住比丘尼皆悉令集。乃至已闻者当重闻。若二比丘尼习近住迭相覆过。诸比丘尼应谏是比丘尼言。阿梨耶。莫习近住迭相覆过。习近住不生善法。是比丘尼。诸比丘尼谏时。坚持不舍。应第二第三谏。舍是事善。若不舍是法乃至三谏。僧伽婆尸沙。佛住舍卫城。尔时世尊制戒。不听习近住。时真檀释家女。郁多罗比丘尼。各自别住。偷兰难陀比丘尼言。阿梨耶。但习近住互相藏过莫相远住。不妨生善法。余人亦有如是相近住。僧不能遮。轻易汝故共相禁制耳。诸比丘尼谏是比丘尼阿梨耶。莫作是语。但习近住互相藏过莫相远住不妨生长善法。乃至轻易汝故共相禁制。如是一谏不止。二谏三谏不止。诸比丘尼语大爱道。大爱道即以是事往白世尊。佛言。是真檀释家女郁多罗比丘尼相远住。偷兰难陀比丘尼劝令习近共住不妨生善法者。当屏处三谏多人中三谏僧中三谏令舍此事。屏处谏者。应作是言。偷兰难陀。汝实语真檀比丘尼郁多罗比丘尼言。但习近住互相藏过莫相远住不妨生善法。余人亦有如是相近住者。僧不能遮。轻易汝故共相禁制耶。答言实尔。应谏言。汝莫作是语。相习近住互相藏过莫相远住。不妨生善法。余人亦有如是相习近住者。僧不能遮。轻易汝故共相禁制。我今慈心饶益故谏汝。一谏已过二谏在。汝舍不。答言不舍。如是第二第三。多人中亦如是谏。若不舍者。僧中应作求听羯磨。唱言。阿梨耶僧听。偷兰难陀比丘尼。劝真檀释家女郁多罗比丘尼。相习近住互相藏过不妨生善法。已屏处三谏多人中三谏不止。若僧时到。僧今亦应三谏令舍此事。僧中应问偷兰难陀。汝实劝相习近住。乃至僧今慈心谏汝。欲利益故。一谏已过二谏在。汝舍不。答言不舍。第二第三谏故不舍。诸比丘尼以是因缘往白世尊。佛言。唤是比丘尼来。来已佛问言。汝实尔不。答言实尔。佛言。此是恶事。乃至佛告大爱道。依止舍卫城住比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼见相远住。便劝作是言。当习近住迭相藏过莫相离住不妨生长善法。余人亦有如是相习近住者。僧不能遮。轻易汝故相禁制耳。诸比丘尼应谏是比丘尼言。阿梨耶。某甲某甲相远住。莫劝习近住递相覆过习近住不妨生善法。莫作是语。余人亦有习近住僧不能遮轻易汝故相禁制耳。是比丘尼。诸比丘尼谏时。坚持不舍。应第二第三谏。舍者善。若不舍者。是法乃至三谏。僧伽婆尸沙。相远住者。如真檀释家女郁多罗比丘尼。劝者。如偷兰难陀比丘尼。习近住者。身相习近口相习近身口相习近覆者。身口过。此身口过彼覆藏彼身口过此覆藏是比丘尼者。如偷兰难陀比丘尼。诸比丘尼者。僧多人一人。三谏者屏处三谏多人中三谏僧中三谏。屏处谏者。屏处应问。汝实劝某甲某甲比丘尼莫相远离住。乃至答言。实尔。屏处应谏作是语莫尔。阿梨耶。某甲某甲相远住。作是教言相习近住。乃至一谏不止。二谏三谏不止。多人中亦尔。僧中三谏不止。是法乃至三谏不舍。僧伽婆尸沙。僧伽婆尸沙者如上说。若比丘尼屏处三谏。谏谏越比尼罪。多人中三谏。谏谏越比尼罪。僧中初谏越比尼罪。谏竟偷兰遮。第二初谏越比尼罪谏竟偷兰遮。第三初谏偷兰遮。谏竟僧伽婆尸沙。成僧伽婆尸沙已屏处多人中僧中。一切越比尼罪偷兰遮合成一僧伽婆尸沙罪治。若中间止。随止处治罪。是故说

佛住迦维罗卫尼拘律树释氏精舍。时释种女母子出家。母在外道中出家。语女言。我今母子如何生离。汝可来此共住。其女白言。我不得无故而来。当待有所因而来。于是女还与比丘尼共斗嗔言。我今舍佛舍法舍僧。舍说舍共住共食舍经论。我非比丘尼非释种。诸外道亦有胜法修梵行处。我用是沙门尼释种为。我当于彼而修梵行。诸比丘尼谏是比丘尼言。阿梨耶。莫舍佛舍法舍僧。乃至莫舍释种。舍佛者不善。乃至舍释种者不善。一谏不止。二谏乃至三谏亦不止。诸比丘尼语大爱道。大爱道即以是事具白世尊。佛言。汝去先屏处三谏多人中三谏僧中三谏令舍此事。屏处谏者。屏处应问言。汝实嗔恚言我舍戒我舍佛。乃至用沙门尼释种为。当于余胜处修梵行耶。答言实尔。屏处应谏。汝莫舍戒舍佛。舍法舍僧。乃至舍沙门尼释种。舍佛者不善。乃至舍沙门尼释种不善。我今慈心。欲利益汝故谏汝。一谏已过二谏在。舍是事不。答言不舍。第二第三亦如是。多人中三谏亦尔。若不舍者。僧中应作求听羯磨。问如屏处中说。犹故不止。诸比丘尼以是因缘往白世尊。佛言。呼比丘尼来。来已佛具问上事。汝实尔不。答言实尔。佛言。此是恶事乃至非法非律不如佛教。不可以是长养善法。佛告大爱道。依止迦维罗卫住比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼嗔恚欲舍戒作是言。我舍佛舍法舍僧。舍说舍共住舍共食舍经论。舍沙门尼释种。用是沙门尼释种为。余更有胜处。我于彼中修梵行。诸比丘尼应谏是比丘尼言。阿梨耶。莫嗔恚舍戒作是言。我舍佛乃至舍沙门尼释种。舍佛者不善诸比丘尼如是谏时。故坚持不舍应第二第三谏。舍是事好。若不舍是法乃至三谏。僧伽婆尸沙。比丘尼者。如释种女欲舍戒舍佛乃至舍沙门尼。诸比丘尼者。若僧多人及一人。三谏者。屏处三谏多人中三谏僧中三谏舍者善。若不舍者是法乃至三谏。僧伽婆尸沙。僧伽婆尸沙者如上说。屏处谏时舍者善。若不舍者谏谏越比尼罪。多人中亦尔。僧中初谏越比尼。谏竟偷兰遮。第二初谏亦越比尼。谏竟偷兰遮。第三初谏偷兰遮。谏竟僧伽婆尸沙。僧伽婆尸沙罪起已屏处多人中僧中成一重罪。作僧伽婆尸沙治。若中间止随止处治。是故世尊说。阿梨耶僧听已说十九僧伽婆尸沙法。十二是初罪。七乃至三谏。若比丘尼犯一一罪。半月二部众中行摩那埵。次到阿浮呵那。二十僧二部众中应出罪称可众人意。二十人中若少一人。此比丘尼不名出罪。诸比丘比丘尼应呵责。是名时。是中清净不。第二第三亦问。是中清净不。是中清净默然故。是事如是持

  使行二无根　　相言独行宿
  不听犯罪女　　渡河并自舍
  受漏心人施　　劝彼令取施
  十二是初罪　　破僧并相助
  嗔恚而谤僧　　戾语习近住
  劝住嗔还戒　　第二篇说竟

    三十事初

  十日离衣宿　　非时捉金银
  卖买并乞衣　　听乞得取二
  办衣二居士　　王臣次第十

如比丘中广说初跋渠竟

佛住舍卫城。尔时偷兰难陀比丘尼在聚落中住。为僧劝化索床褥。语妇人言。优婆夷。汝当施僧床褥枕拘执。时妇人信心欢喜。即与床褥枕拘执直。得已持作衣钵饮食汤药。时比丘尼次行乞食到其家。诸妇人问言。阿梨耶。我与偷兰难陀比丘尼床褥拘执枕直。为作未。比丘尼言。那得作。但自买衣钵饮食汤药。诸比丘尼闻已语大爱道。大爱道即以是事往白世尊。佛言。唤偷兰难陀比丘尼来。来已佛问言。汝实索床褥拘执而作余用耶。答言实尔。佛言。此是恶事。汝常不闻我无量方便毁訾多欲称叹少欲。汝云何作恶不善法。此非法非律非如佛教。不可以是长养善法。从今日后。不听为床褥乞转作余用。佛告大爱道瞿昙弥。依止舍卫城比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼为床褥乞。而自作衣钵饮食疾病汤药者。尼萨耆波夜提。比丘尼者如上说。床褥枕拘执。如上比丘中广说。乞者。劝化求索。后自用作衣钵饮食汤药者。尼萨耆波夜提。尼萨耆波夜提者。此物应僧中舍。波夜提悔过。不舍而悔越比尼罪。波夜提者如比丘中广说。若比丘尼为床褥乞。而自用作衣钵饮食汤药时。尼萨耆波夜提。若为此索不得作彼用。若为床索作褥。为褥索作枕。为枕索作拘执。越比尼罪。若劝化乞多得床褥枕直。当一一示人记识。此是床直。此是褥直。此是枕直。此是拘执直。若不尔者。一一越比尼罪。得贷用治房舍及釜镬如法贷用。若比丘为床褥乞。而余用者越比尼罪得如法贷用。是故说

佛住舍卫城。尔时偷兰难陀比丘尼着垢腻穿穴弊衣而行乞食。妇人见已语言。阿梨耶。我施衣直知衣。复有人言。我施钵直知钵。得已但作饮食用尽。不作衣钵。有比丘尼乞食。妇人问言。偷兰难陀我先与衣钵直作未。报言。但作饮食。那得作衣钵。比丘尼闻已语大爱道。大爱道以是因缘往白世尊。佛言。唤是比丘尼来。来已佛问言。汝实尔不。答言实尔。世尊。佛言。此是恶事。汝不闻我无量方便赞叹少欲毁呰多欲耶。汝云何得衣钵直。而作余用。从今日后不听。佛语大爱道。依止舍卫城住比丘尼皆悉令集乃至已闻者当重闻。若比丘尼人为作是与。而作彼用者。尼萨耆波夜提。比丘尼者如上说为是与者。为衣为钵直与作余用者。作饮食汤药。尼萨耆波夜提。此物僧中舍波夜提悔过。若比丘尼人与衣直钵直酥油直直衣直。应知衣钵直。应知钵酥直。应知酥油直。应知油。若作异用者尼萨耆波夜提。若檀越言随意用无罪。若无所适为随作无罪。若比丘人与衣直钵直酥直油直衣直。应作衣乃至酥直知酥。若作异用者越比尼罪。若随意用者无罪。无所适为者无罪。是故世尊说

佛住舍卫城。尔时偷兰难陀比丘尼劝化作食。语妇人言。优婆夷。我欲与僧作食诸优婆夷信心欢喜与食直。作是言阿梨耶。至作食日语我我当来行食。比丘尼得已自作食及买衣钵。余残作粗食。至其日自来行食。见已问言。阿梨耶我前与食直多。何故食粗乃尔。诸比丘尼言。何处得好食。但自作衣钵食啖。诸比丘尼闻已语大爱道。大爱道即以上事往白世尊。佛言。唤是比丘尼来。来已佛问言。汝实尔不。答言实尔。佛言。此是恶事。乃至佛告大爱道瞿昙弥。依止舍卫城住比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼为食乞。作衣钵饮食汤药受用者。尼萨耆波夜提。比丘尼者如上说。为食者为僧作食。乞者劝化求索。异用者衣钵自饮食。尼萨耆波夜提。尼萨耆波夜提者如上说。若比丘尼为僧索作食。而自买衣钵饮食者。尼萨耆波夜提。随本所欲作应用作者。若回前食作后食。回后食作前食者。越比尼罪。若回食直作床褥。若春夏冬衣分若食分随先所向应用。而不称施主本心与。越比尼罪。若比丘尼为僧劝化得食应尽作。若有长饮食酥油。应示檀越。檀越若持去者当默然。若言我与阿梨耶。应言与僧。复言我以自与僧竟。此与阿梨耶。如是取者无罪。是故说

佛住舍卫城。尔时有客比丘尼来。次第应得房。先住下坐比丘尼言。阿梨耶。待我移钵。乃至明日问言。移钵竟未。答言。我移钵未竟。客比丘尼言。汝欲持是钵居瓦肆去耶。用尔许钵为。诸比丘尼闻已语大爱道。大爱道往白世尊。佛言。呼是比丘尼来。来已佛问言。汝实尔不。答言实尔。佛言。汝云何畜长钵。从今日后。不听畜长钵。佛告大爱道瞿昙弥。依止舍卫城比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼畜长钵尼萨耆波夜提。比丘尼者如上说。畜长钵钵者。名嵩婆钵乌婆嵩婆钵忧鸠吒夜钵婆耆夜钵。如是铁瓦等。是名钵。有钵名上中下过钵减钵随钵。畜者尼萨耆波夜提。比丘尼得畜十六枚钵。一受持。三作净施。四过钵。四减钵。四随钵。若过畜者尼萨耆波夜提。尼萨耆夜提者如上说。比丘尼畜长钵有齐限。比丘多畜净施用无罪。是故世尊说

佛住舍卫城如上广说。乃至语言。汝欲居衣肆店耶。诸比丘尼闻已语大爱道。大爱道即以是事往白世尊。佛言。唤是。比丘尼来。来已佛问言。汝实尔不。答言实尔。佛言。汝云何畜长衣。从今日后。不听畜长衣。佛告大爱道瞿昙弥。依止舍卫城住比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼畜长衣尼萨耆波夜提。比丘尼者如上说。衣者。钦婆罗衣[疊*毛]衣憍奢耶衣刍摩衣舍那衣麻衣驱牟提衣。畜者。过限畜尼萨耆波夜提。尼萨耆波夜提者如上说。比丘尼听畜二十衣。五衣受持。十五衣净施已受用。若过是畜尼萨耆波夜提。比丘无限齐净施受用无罪。是故世尊说

佛住舍卫城。尔时偷兰难陀比丘尼僧伽梨破。不浣染补治。掷弃墙下作是言。若欲取者便取。时树提比丘尼着破衣。余比丘尼言。阿梨耶。可取持此衣浣染补治受用。即取补治浣染而着。偷兰难陀比丘尼言。还我衣来。语诸比丘尼言。异事试看。是衣物都不得放地须臾舍去。汝屋中得满未。即夺取僧伽梨。诸比丘尼语大爱道。大爱道即以是事往白世尊。佛言。呼是比丘尼来。来已佛问言。汝实尔不。答言实尔世尊。佛言。此是恶事。乃至佛告大爱道瞿昙弥。依止舍卫城住比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼于住止处。弃故僧伽梨唱言。有欲取者取。后还夺者尼萨耆波夜提。比丘尼者如上说。住处者精舍内。弃者放舍在地。人取已后还夺者尼萨耆波夜提。尼萨耆波夜提者如上说。若比丘尼弃物已。有人取用不得还夺。若无人取后须用而取者无罪。若比丘精舍内。弃衣钵革屣及余小小物。人取已后还夺者越比尼罪。若无人取后还取者无罪。是故世尊说

佛住舍卫城尔时有比丘尼。有垢污僧迦梨。擿已于日中晒。风起吹去。诸比丘尼语大爱道。大爱道即以是事往白世尊。佛言。呼是比丘尼来。来已佛问言。汝实尔不。答言实尔世尊。佛言。汝云何擿故僧伽梨已。不自缝不使人缝。从今日后。不听擿衣浣。复次尔时有释种女摩罗女。本是乐人。浣僧伽梨僧伽梨厚重难浣。语大爱道。大爱道往白世尊。佛言。从今日后。听至五六日。佛告大爱道瞿昙弥。依止舍卫城住比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼故僧伽梨若自擿若使人擿。过五六日不自缝不使人缝。除病尼萨耆波夜提。比丘尼者如上说。故僧伽梨者。欲浣若自擿若使人擿五六日者。限齐六日。不还自缝不使人缝尼萨耆波夜提。尼萨耆波夜提者如上说。若比丘尼浣故僧伽梨。若轻而薄者不听擿。若厚而重者听擿擿已当浣浣已应舒置箔上。若席上以石镇四角。干竟当唤共行弟子依止弟子。同和上阿阇梨诸知识比丘尼速疾共成。若老病无人佐者无罪。是故世尊说

佛住舍卫城。尔时学戒尼语偷兰难陀言。阿梨耶。与我受具足。偷兰难陀言。汝与我衣当与汝受具足。即便与衣。后不与受具足。学戒尼言。与我受具足。如是经久。诸比丘尼语大爱道。大爱道即以是事往白世尊。佛言。唤是比丘尼来。来已佛问言。汝实尔不。答言实尔。佛言。此是恶事。乃至佛告大爱道。依止舍卫城住比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼语式叉摩尼言。汝与我衣当与汝受具足。取衣已不与受具足者尼萨耆波夜提。比丘尼者如上说。式叉摩尼者。受学戒。衣者七种衣如上说。复有衣名僧伽梨乃至雨浴衣。许受具足者。后自不与受。不使人受。尼萨耆波夜提。尼萨耆波夜提者如上说。若比丘尼取式叉摩尼衣。许与受具足。后应与受。若老病无力不能受者。应语余人。汝取是衣与受具足。若前人不欲受还索衣者当还。若比丘许沙弥。不与受具足越比尼罪。是故世尊说

佛住毗舍离。尔时有北方商人。持贵价好钦婆罗而行卖之。人问此索几许。答言百千。时国王王子大臣及余大商人主皆嫌贵不买。在店上愁忧而坐。人问言。汝何故而有愁色。答言。我卖此钦婆罗。大有价直输税亦多。而今卖不可售。是以不乐。人言。汝欲令售不。答言欲令售。即语。汝可持诣跋陀罗沙门尼所。彼当买之。即持往问人言。何者是比丘尼精舍。人示处已。问言。何者是跋陀罗比丘尼房。人示处已。问言。何者是跋陀罗跋陀罗比丘尼。答言。何故问耶。答言。欲买是钦婆罗不。问言。索几许。答言百千。亦不与高下。即语弟子言。汝去语婆路醯肆上。取百千与之。有人问言。汝卖钦婆罗售未。答言已售。问言谁取。答言沙门尼跋陀罗。其人即嫌言。出家人有此爱好之欲。诸比丘尼闻已语大爱道。大爱道即以是事往白世尊。佛言。唤是比丘尼来。来已佛问。汝实尔不。答言实尔。佛告比丘尼。汝不为后世人作轨则耶。从今日后。不听出四羯利沙槃买重衣。佛告大爱道瞿昙弥。依止比舍离城住比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼过四羯利沙槃市重衣尼萨耆波夜提。比丘尼者如上说。四羯利沙槃者四四十九故钱。重衣者钦婆罗衣。市者知取也。若过十九故钱取者尼萨耆波夜提。尼萨耆波夜提者如上说。若比丘尼不得过十九故钱市重衣若不乞自与虽贵价无罪。比丘尼有限比丘无限。虽贵价知取受用无罪。是故世尊说

佛住毗舍离。尔时南方有商人。持细鹅相纹[疊*毛]来有人问言。此衣索几许。答言百千。以价贵故王家不买。及诸大臣诸商人主都无买者。以不售故于店肆上愁忧而坐。有人问言。汝何故忧色。答言。我贵买此衣输税亦多。而今卖不可售。问言。汝欲令售不。答言。欲令售。语言汝可持诣跋陀罗沙门尼所。当与汝买。即往问人。何者是比丘尼住处。知已入问。何者是跋陀罗沙门尼房。人即示处。到已言。和南阿梨耶。是跋陀罗不。答言是何以问答言。我有此鹅相纹[疊*毛]能买不。问言。汝索几许。答言。我索百千。比丘尼亦不求减。即语弟子言。汝往白婆路醯店上。取百千与。有人问言。汝得售耶。答言已售。问言谁取。答言。跋陀罗沙门尼取。有人嫌言。出家之人何乃爱好如是。比丘尼闻已语大爱道。乃至佛语跋陀罗比丘尼。汝不为后世人作轨则耶。从今日后。不听过两羯利沙槃半市细轻衣。佛告大爱道瞿昙弥。依止舍卫城住比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼。过两羯利沙槃半市细轻衣者。尼萨耆波夜提。比丘尼者如上说。两羯利沙槃半者四十六故钱。市者知取。若过者尼萨耆波夜提。尼萨耆波夜提者如上说。若比丘尼市细轻衣者。应以两羯利沙槃半知取不得过。若不乞自与。设得贵价细衣受用无罪。比丘贵价市衣受用无罪

  床褥乞自用　　衣钵直异用
  为众减自用　　畜钵并畜衣
  弃衣后还取　　擿衣受具足
  重衣及细轻　　第二跋渠竟

佛住舍卫城。尔时有载薪人驾车于店肆前过。商人问言。此卖索几许。答言。一羯利沙槃。商人语言。汝载此薪诣我家写之。还过此当与汝价。卖薪人即乘车经比丘尼精舍前过时。偷兰难陀比丘尼问言。长寿。汝薪有主买未。答言已有得几。答言一羯利沙槃。即语言我与汝两羯利沙槃主贪利故即以与之。其人下薪已还经店肆前过。商人语言。汝持直去。答言。我已卖与余人。问言。卖得几许。答言。得两羯利沙槃。问言谁取。答言。偷兰难陀比丘尼。商人嫌呵言。此沙门尼何能饶钱如是。比丘尼闻已语大爱道。大爱道即以此事往白世尊。佛言。唤是比丘尼来。来已问言。汝实知他买已而益价取耶。答言实尔佛言。此是恶事。汝云何知他市得而抄买耶。此非法非律非如佛教。不可以是长养善法。佛告大爱道瞿昙弥。依止舍卫城住比丘尼皆悉令集乃至已闻者当重闻。若比丘尼知他市得而抄买者尼萨耆波夜提。比丘尼者如上说。知者若自知若从他闻。市得者如店上商人。若比丘尼欲市物。知他已市不得横抄。应待前人不取得取。亦应问前人。汝故取不。若言故欲取。为欲坚之。此不应取。若言不复取。取者无罪。若比丘尼买衣钵还自相抄者越比尼罪。若僧中上价取者。除和上阿阇梨无罪。若比丘市物抄截他市者越比尼罪。是故说

  长钵减五缀　　七日嗔夺衣
  卖金并乞缕　　致织及急施
  抄市回僧物　　第三跋渠竟

从比丘尼取衣及浣染。淳黑三分白憍舍耶。六年尼师檀。三由旬擘羊毛。雨浴衣。阿练若处。此十一事应出不说。更有十一事。应内旃跋渠残从初跋渠。初跋渠中出。取比丘尼衣。捉金银补出。浣故衣以卖买补。后跋渠中出。雨浴衣以卖金补出。阿练若处以抄市补处一跋渠二跋渠数不减尼萨耆者。世尊说比丘尼三十事竟

    明一百四十一波夜提法之一

  妄语及种类　　两舌更发起
  脱命说句法　　自称过人法
  未足说粗罪　　与遮轻呵戒
  初跋渠说竟　　斫种异语恼
  嫌责露地敷　　覆处强牵出
  先敷尖脚床　　虫水浇草泥
  疑悔使不乐　　第二跋渠竟
  一食及处处　　与衣不舍用
  不作残食劝　　不受非时食
  停食两三钵　　藏物别众食
  第三跋渠竟

  然火过三宿　　与欲后嗔恚
  入聚落遣还　　障道见不舍
  沙弥三坏色　　取宝恐怖他
  第四跋渠竟

  饮虫水外道　　淫处坐屏处
  观军过三宿　　牙旗及相打
  掌刀水中戏　　第五跋渠竟
  指相指贼伴　　掘地四月请
  不从学饮酒　　轻他默然听
  断事不摄耳　　第六跋渠竟
  离同食王宫　　针筒过八指
  兜罗及坐具　　覆疮效如来
  僧残谤回向　　第七跋渠竟

同比丘戒中广说

佛住毗舍离。尔时跋陀罗伽毗比丘尼。不语依止弟子。辄着僧伽梨入聚落。有比丘尼呼言。某甲乞食去来。答言。阿梨耶。待我取僧伽梨。即求衣不见正见师衣作是念。师必着我衣去。即生念。师可得着我衣。我不得着师衣语言汝去。我不得去。何故耶。答言。我无衣。即语着汝师衣来。答言。我所尊重不敢着。汝自去一日失食。诸比丘尼语大爱道。大爱道即以是事往白世尊。佛言。唤是比丘尼来。来已佛问言。汝实尔不。答言实尔世尊。佛言。此是恶事。汝云何不语着他衣。从今已后不听。佛告大爱道。依止比舍离住比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼不语主而着他衣。波夜提。比丘尼者如上说。不听不语他而着弟子僧伽梨。若欲着时应语。我着汝衣。汝若行者可着我僧伽梨。如是一切衣。若欲浣衣染衣缝衣。有事缘着弟子衣者。当语言。汝住当与汝持食来。若比丘着他衣。不语者越比尼罪。是故世尊说

摩诃僧祇律卷第三十七摩诃僧祇律卷第三十八

        东晋天竺三藏佛陀跋陀罗共法显译

    明一百四十一波夜提法之二

佛住舍卫城。尔时有人名竭住。在外道中出家。父母在佛法中出家。时竭住。盛寒时无衣。往至母所禽兽而住。母即慈念。有新浣染作净郁多罗僧。便脱与之。得已即着入酒店中坐。为世人所嫌。言此邪见啖酒糟驴。而着圣人幖帜。诸比丘尼闻已语大爱道。大爱道即以是事往白世尊。佛言。呼是比丘尼来。来已问言。汝实尔不。答言实尔。佛言。此是恶事。汝云何持衣与出家外道。从今已后。不听自手与外道衣。佛告大爱道瞿昙弥。依止舍卫城比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼自手与俗人外道沙门衣波夜提。比丘尼者如上说。俗人者在家人。外道者外道出家。自手与者手与手受。沙门衣者贤圣幖帜。波夜提者如上说。不得自手与俗人外道沙门衣。若比丘尼有戒德。妇女小儿欲乞破衣段以禳灾者不得自手与。应遣净人女与。若比丘自手与俗人外道沙门衣者越毗尼罪。若有戒德比丘。人索破袈裟段。欲以禳灾者。应使净人与。不得与大段当与小者。是故世尊说

佛住舍卫城。尔时有比丘尼。如女人着衣。为世人所嫌。云何比丘尼着长衣曳缕而行。如世间女人。此坏败人何道之有。比丘尼闻已语大爱道。大爱道即以是事具白世尊。佛言。呼比丘尼来。来已问言。汝实尔不。答言实尔。佛言。从今已后。不听合缕作衣。当应量作。佛告大爱道瞿昙弥。依止舍卫城比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼作安陀会应量作。长四修伽陀搩手。广二搩手。若过作截已波夜提。比丘尼者如上说。安陀会者世尊所听。作者若自作若使人作。应量者长四修伽陀搩手。修伽陀者善逝广二搩手。若过量作截已波夜提悔过。波夜提者如上说。若比丘尼长应量广过量作。成波夜提。受用越比尼罪。如是广应量长过量。如是边应量中过量。中应量边过量。如是屈量皱量。水洒量干已欲令长广。波夜提。受用越比尼罪。是故世尊说

佛住舍卫城。尔时有比丘尼年少端正。着衣道行。时两乳现出。男子见已笑之。诸比丘尼闻已语大爱道。大爱道即以是事往白世尊。乃至佛言。从今已后。比丘尼应作僧祇支。复次尔时有比丘尼。留缕作僧祇支长广。乃至佛言。从今日后。截缕应量作。佛告大爱道瞿昙弥。依止舍卫城比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼僧祇支应量作。长四修伽陀搩手。广两搩手。若过作截已波夜提。波夜提如上安陀会中广说

佛住比舍离。尔时跋陀罗比丘尼于苏河浴。尔时有五离车童子。于河上看。见已生欲心。比丘尼言。长寿汝去。答言我不去。欲看阿梨耶形体。比丘尼言。汝用看是臭烂身九孔门为。复言不尔。我甚欲见。良久不去。比丘尼作是念。此凡夫愚浅。即以手掩前后而出。其人见已迷闷倒地。血从口出。诸比丘尼语大爱道。大爱道即以是事往白世尊。乃至诸比丘尼问佛。云何是五离车童子。有欲心迷闷倒地乃尔。佛言。非但今日有此欲心。过去世时已曾如是。诸比丘尼白佛言。愿欲闻之。佛言。过去久远。尔时有一天女端正殊特。时有五天子。一名释迦罗。二名摩多梨。三名僧阇耶帝。四名鞞阇耶帝。五名摩吒。见已各生欲心便作是念。此非可共物。欲心重者当以与之。各言可尔。于是释迦罗即说颂曰

  我忆淫欲时　　坐卧不自安
  乃至睡眠时　　欲退始得安

摩多梨复说颂曰

  释迦汝眠时　　犹故有暂泰
  我忆淫欲时　　如阵战鼓音

僧阇耶帝复说颂曰

  摩多鼓音喻　　犹故尚有间
  我心染欲时　　如駃流漂木

鞞阇耶帝复说颂曰

  汝喻漂浮木　　或时有稽留
  我忆欲念时　　如虻虫不瞬

于是摩吒复说颂曰

  汝等诸所说　　全是安乐想
  我耽淫欲时　　不觉死与生

于是诸天子言。汝最重者即并与之。佛告诸比丘尼。尔时五天子者今五离车是。诸比丘尼白佛言。是比丘尼有何行业端正如是。在大姓家生。以信出家得证无漏。佛告诸比丘尼。过去世时有城名波罗奈。有长者家初取新妇。常有一梳头人给与饮食。时有辟支佛名宣絺。诣门乞食。其妇见之不大端严无恭敬心。既不与食复不语去。梳头人见已语言。新妇可施与食。答言。丑陋不好。我不能与。即语可赐我食分。我欲与之。答言随意。亦可弃着水中。其人得食即施辟支佛。于是受食乘空而逝。见其飞腾心大欢喜即发誓言。愿我后身生大姓家身体端正。见佛闻法得尽有漏。于是命终即生天上。于百千天女。五事最胜。寿命色力名称辩才。天上命终生波罗奈城婆罗门家。值迦叶佛出世时。父母出行游观。时女在家。迦叶佛入城乞食次到其家。宿殖德故见大欢喜。净洗铜盘盛种种好食及憍舍耶衣奉上世尊。即说颂曰

  今奉食与衣　　众施中最胜
  今供牟尼尊　　结习尽得证
  如是漏尽证　　愿我亦复然

此女后嫁适婆罗门家。姑妐严恶难事。乃至我用此活为。不如自杀。即持璎珞及涂身香。并自绞绳。欲行自杀。过见迦叶佛塔。即持严身之具供养佛塔。然后自绞。命终之后即生婆罗门家。乃至自说颂曰

  璎珞衣香花　　信供迦叶塔
  缘此福报故　　今礼世尊足

佛言。从今日后。应作浴衣。乃至已闻者当重闻。若比丘尼作雨浴衣。应量作。长四修伽陀搩手。广二搩手。若过作截已波夜提。如上僧祇支中广说

佛住舍卫城。尔时比丘尼僧语偷兰难陀言。汝能为僧乞迦絺那衣不。答言能。即往无信家语言。大福德。汝能施僧迦絺那衣不。答言能。僧自恣已语偷兰难陀言。得迦絺那衣未。答言我知。即到其家语言。长寿。迦絺那衣办未。答言我知。寻复往索。比丘尼复言我知。如是衣时已过。诸比丘尼语大爱道。大爱道即以是事往白世尊。佛言。呼比丘尼来。来已佛问。汝实尔不。答言实尔。佛言。汝云何至不能办衣家。为僧索迦絺那衣。从今已后不听。佛告大爱道瞿昙弥。依止舍卫城住比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼诣不能办衣家。为僧乞迦絺那衣。波夜提。比丘尼者如上说。不信者。无力与希望处弱。衣者钦婆罗衣[疊*毛]衣乃至驱牟提衣。乞者为僧求迦絺那衣。衣时过不得者波夜提。波夜提者如上说。若比丘尼能为僧求迦絺那衣者。应好着意求。不得至不信家求。当至有信家眷属多者乞。若前人言我自知。当复语言汝定与不。勿令过衣时。亦当相望其人。必不能办者。当更余处求。亦应自筹量。不能办者不应与僧求。若已许僧求衣。不自勤求不使人求。又不自语僧。令衣时过者波夜提波夜提者如上说。若比丘往诣不信家。为僧求迦絺那衣者越比尼罪。是故世尊说

佛住舍卫城。尔时比丘尼着上下衣。来礼世尊足。后失火烧衣。诸比丘尼语大爱道。大爱道即以是事往白世尊。佛言。唤是比丘尼来。来已问言。汝实尔不。答言实尔。佛言。汝云何所受持衣而不随身。从今日后。不听所受持衣而不随身

复次尔时有比丘尼释种女摩罗女。先是乐人。出家僧伽梨重不能胜。甚以为苦。乃至佛言。从今已后听病时。佛告大爱道瞿昙弥。依止舍卫城比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼不病。所受衣不随身者波夜提。比丘尼者如上说。所受衣者僧伽梨郁多罗僧安陀会。僧祇支雨浴衣。病者世尊说无罪。不随身者波夜提。波夜提者如上说。若比丘尼不病。所受持衣不持者。波夜提。若礼塔若经行。若昼日坐禅处界内无罪。是故世尊说

佛住比舍离。尔时跋陀罗比丘尼家中常与送食。得已更煎更熬更调和。其兄弟伯叔来见已言我欲食。答言可尔。即取而食。觉气味异常。问言何处得此好食。答言故是家中所送耳。即便恚言。我家从来作食徒弃钱财初不得好食。即还家鞭打奴婢骂言。虚弃钱物而不可食。其使人嗔恚言。坐此比丘尼。得苦恼如是。诸比丘尼闻已语大爱道。大爱道即以是事往白世尊佛言。呼跋陀罗比丘尼来。来已问言。汝实尔不。答言实尔。佛言。此是恶事。从今日后。不听自煮熬煎

复次佛住舍卫城。尔时有比丘尼。是释种女摩罗女。行乞食得宿饭宿羹宿菜。食已吐逆。诸比丘尼语大爱道。大爱道往白世尊。得听我等温食不。佛言得。佛告大爱道瞿昙弥。依止比舍离比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼得佉陀尼食蒲阇尼食。更煮使人煮。更熬使人熬。更煎使人煎。不病比丘尼食者波夜提。佉陀尼者五佉陀尼食。蒲阇尼者五蒲阇尼食。更煮者若自煮使人煮。熬者若自熬若使人熬。煎者若自煎若使人煎。病者世尊说无罪。云何病。老病羸瘦食冷吐逆不乐。不病比丘尼煮食食者波夜提。波夜提者如上说不听为美食故更熬更煎。若冷得温。不听铫釜中煮。若用铜盂。若钩钵键镃中温。若比丘为美故自更煮更熬更煎越比尼罪。若使净人知者无罪。若乞食时食冷更温无罪。是故世尊说

佛住舍卫城。尔时有夫妇二人。释种中出家。时夫摩诃罗食。比丘尼在边行水以扇扇之。摩诃罗说往时事。比丘尼嗔。即以水洒面。以扇拍头。呵言。汝不知恩义故。说往时之事。不应说者而便说之。比丘尼见已语言。阿梨耶。此上尊众不得如是。复言。是摩诃罗不善不知恩义。不应说者而今说之。诸比丘尼语大爱道。大爱道即以是事往白世尊。佛言。呼是比丘尼来。来已问言。汝实尔不。答言实尔。佛言。此是恶事。汝云何比丘食以水扇供给。此非法非律非如佛教。不可以是长养善法。从今已后不听。佛告大爱道瞿昙弥。依止舍卫城住者皆悉令集。乃至已闻者当重闻。若比丘尼。比丘食以水扇供给波夜提。比丘尼者如上说。比丘食者五正食五杂正食。水扇者持水瓶行水以扇扇之波夜提。波夜提者如上说。若比丘尼持水瓶不持扇者越比尼罪。持扇不持水者亦越比尼罪。二俱持者波夜提二俱不持无罪。是罪一比丘一比丘尼。若众多比丘行水扇者无罪。若众中有父兄者以扇扇无罪。是故世尊说

佛住舍卫城。尔时有半耆蒜商人。请比丘尼僧与蒜。时六群比丘尼就园啖蒜。践蹈狼藉。时商人来行蒜。见此狼藉即问园民。何故乃尔。答言。前请比丘尼与蒜或就中食或持去。践蹈如是。商人嫌言。我请与蒜但当食之。何故持去践蹈如是。诸比丘尼闻已语大爱道。大爱道即以是事具白世尊。乃至答言实尔。佛语比丘尼。此是恶事。从今已后不听食蒜。乃至已闻者当重闻。若比丘尼食蒜者波夜提。比丘尼者如上说。蒜者种蒜山蒜。如是比一切蒜不听食。熟不听生亦不听。重煮亦不听。烧作灰亦不听。若身有疮听涂。涂已当在屏处。疮差净洗已听入。是故世尊说

  他衣外道衣　　只支安陀会
  浴衣迦絺那　　持衣不随身
  更煮捉水扇　　食蒜八跋渠

佛住舍卫城尔时赖吒波罗姊无常。乞种种饮食与姊子。为世人所嫌云何沙门尼受他信施施与俗人。比丘尼闻已语大爱道。大爱道即以是事具白世尊。佛言。呼比丘尼来。来已问言。汝实尔不。答言实尔。佛言。从今已后。不听自手与俗人食

复次佛住舍卫城。尔时竭住外道到母边。其母见来。以种种饮食满钵而与。其子得已即持至酒店上自食。复与人食。有人问言。汝何处得此好食。语言汝默。世人以沙门尼为福田。沙门尼复以我为福田。为世人所嫌。云何沙门尼用人信施与不增长福处。诸比丘尼闻已语大爱道。大爱道即以是事往白世尊。佛言。呼是比丘尼来。来已问言。汝实尔不。答言实尔。佛言。此是恶事。汝云何自手与外道食从今已后。不听自手与外道食。佛告大爱道瞿昙弥。依止舍卫城住比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼俗人外道。自手与食波夜提。比丘尼者如上说。俗人者在家人。外道者出家外道。自手者手与手受器与器受。食者佉陀尼食蒲阇尼食波夜提者如上说。若比丘尼有亲里来欲与食者。不听自手与。当使净女人与。若无净女人者。应语此中自手取食。若畏多取者。应语取尔许来受取。余者置。受得已放地令自取。若外道来者不听自手与。当使净女人与。若无净女人者。应语此中自取食。若畏取多者。应语取尔许来。余者举置。手中者放地与之。若亲里嫌恨言。汝作旃陀罗相遇耶。应语汝出家处不好。世尊制戒不得与。得使外道作食。语言。汝授与我。余者自食。是故世尊说

佛住拘睒弥。尔时阐陀母比丘尼善知治病。持根药叶药果药。入王家大臣家居士家。治诸母人胎病眼病。吐下熏咽灌鼻用针刀。然后持此诸药涂之。由治病故大得供养。诸比丘尼呵言。此非出家法此是医师耳。诸比丘尼语大爱道。大爱道以是因缘往白世尊。佛言。唤是比丘尼来。来已问言。汝实尔不。答言实尔。佛言。此是恶事。从今日后。不听作医师活命。佛告大爱道瞿昙弥。依止拘睒弥比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼作医师活命波夜提。比丘尼者如上说。医者持根药叶药果药治病。复有医咒毒咒蛇乃至咒火咒星宿日月。以此活命如阐陀母者波夜提。波夜提者如上说。比丘尼不得作医师活命。若有病者得教语治法。比丘作医师活命者越毗尼罪。是故世尊说

佛住拘睒弥。尔时世尊制戒不得作医师活命。有人呼阐陀母治病。比丘尼言。世尊制戒不听。复言。若不听者授我医方。即授与俗人外道医方。诸比丘尼言。但诵医方此非出家法。诸比丘尼语大爱道。大爱道即以是事具白世尊。佛言。呼比丘尼来。来已问言。汝实尔不。答言实尔。佛言。从今日后。不听授俗人外道医方。佛告大爱道瞿昙弥。依止拘睒弥比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼授俗人外道医方者波夜提。比丘尼者如上说。俗人者在家人。外道者出家外道。授医方者咒蛇咒毒乃至咒火咒星宿日月波夜提波夜提者如上说。比丘尼不得授俗人外道医方。不得教语。若比丘授俗人外道医方者越比尼罪。是故世尊说

佛住舍卫城。尔时比舍佉鹿母请二部僧。时比丘尼晨朝往到其家语优婆夷言。汝今日请二部僧。我等当以何报之。鹿母言。阿梨耶。但诵经行道。便是报恩。答言实尔。然复更以余事薄报。即共上阁取其劫贝。中有擘者。有纷者。中有纺者。成缕丸已而与之言。我欲报者今以作竟。优婆夷言此事非是报。欲报者食已坐禅受经诵经。是乃为报。诸比丘尼闻已语大爱道。大爱道以是事具白世尊。佛言。呼是比丘尼来。来已问言。汝实尔不。答言实尔。佛言。此是恶事。从今日后。不听于白衣家作世俗作。佛告大爱道瞿昙弥。依止舍卫城比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼为俗人作者波夜提。比丘尼者如上说。俗人者白衣家。为俗人作者擘劫贝纷劫贝及纺。若舂若磨若浣衣。如是比俗人家作者波夜提。波夜提者如上说。比丘尼不得为俗人作。若檀越欲供养佛故言。阿梨耶。佐我作供养具者。尔时得佐结华鬘。得佐研香。若比丘佐俗人作者越毗尼罪。是故世尊说

佛住舍卫城。尔时有夫妇二人。日中时自于屋内无人想处。欲行淫事。尔时偷兰难陀比丘尼先不语。卒尔便入。其夫见之忿恚。妨我行欲。身生犹起不息。即逐欲捉比丘尼。比丘尼畏之急走来还住处。语诸比丘尼言。今日殆坏我梵行。诸比丘尼语大爱道。大爱道即以是事往白世尊。佛言。唤是比丘尼来。来已佛问言。汝实尔不。答言实尔。佛言。此是恶事。汝云何知食家不先语而入。从今已后不听。佛告大爱道瞿昙弥。依止舍卫城比丘尼皆悉令集乃至已闻者当重闻。若比丘尼知食家先不语而入者波夜提。比丘尼者如上说。知者若自知若从他闻。食者女人是丈夫食。丈夫是女人食。家者刹利家。婆罗门家。毗舍家。首陀罗家。如是比先不语者先不语而入波夜提。波夜提者如上说。若比丘尼先不语不得入。若欲入者应语守门者。我欲入。若守门者白已言入乃入。若守门者不还不得入。若闻房中语声。当弹指动脚作声。若彼默然者不得入。若来出迎得入。若比丘先不语而入者越毗尼罪。是故世尊说

佛住舍卫城。尔时迦梨比丘尼度梨车第三生女出家与俗人外道习近住。诸比丘尼语大爱道。大爱道即以是事具白世尊。佛言。呼比丘尼来。来已佛问比丘尼。汝实尔不。答言。实尔。世尊。佛言。此是恶事。从今日后。不听习近住。佛告大爱道瞿昙弥。依止舍卫城比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼与俗人外道习近住。若竟日若须臾。下至园民沙弥波夜提。比丘尼者如上说。俗人者在家人。外道者出家外道。昼日者齐日没。乃至须臾者须臾间。习近住者身习近住。口习近住。身口习近住。下至园民沙弥者波夜提。波夜提者如上说。若比丘尼习近住者波夜提。若比丘尼习近住展转相乐住者。和上尼阿阇梨尼应离别送着异方。若比丘习近住者越比尼罪。是故世尊说

佛住舍卫城。尔时偷兰难陀比丘尼共余比丘尼诤斗。便相咒誓言。南无佛指佛誓。指阿阇梨誓袈裟边誓。若我作是者。我不在袈裟中死。不得断苦边。得杀父母罪得背恩罪。得谤贤圣罪。入泥犁堕饿鬼堕畜生。我若尔者当入是诸趣。汝若尔者亦当入是诸趣中。诸比丘尼闻已语大爱道。大爱道即以是事往白世尊。佛言。呼是比丘尼来。来已问言。汝实尔不。答言实尔。佛言。此是恶事。汝云何出家人作是咒誓。此非法非律非如佛教。不可以是长养善法。乃至已闻者当重闻。若比丘尼自咒誓咒他者波夜提。比丘尼者如上说。自咒誓者。南无佛指佛誓。指阿阇梨誓。我若尔者。当得如提婆达多罪。得妄语罪。得背恩罪。得两舌罪。若我尔者。梵行不成就。不在袈裟中死。入泥梨堕畜生饿鬼。若汝谤我者。亦当得是罪。作是誓者波夜提。若比丘作是誓越比尼罪。是故世尊说

佛住舍卫城。尔时偷兰难陀共诸比丘尼斗诤已。嗔恚自打自抓大啼哭泪出。诸比丘尼闻已语大爱道。大爱道即以是事往白世尊。佛言。唤是比丘尼来。来已问言。汝实尔不。答言实尔。佛言。汝云何嗔恚自打而啼哭泪出。此非法非律不如佛教。不可以是长养善法。佛告大爱道瞿昙弥。依止舍卫城住比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼自打而啼泣泪者波夜提。比丘尼者如上说。自打者若手搏若拳敲若杖若土块若鞭。如是比丘尼自打而啼者波夜提。波夜提者如上说。若比丘尼自打不啼者越比尼罪。啼而不打者亦越比尼罪。自打而啼者波夜提。不打不啼者无罪。若比丘自打而啼越比尼罪。是故世尊说

佛住舍卫城。尔时偷兰难陀比丘尼到俗人家舍。称说树提比丘尼。贤善持戒精进。乃至威仪庠序左顾右视。着衣持钵审谛安详省于言语。天人供养。檀越见已生恭敬心。给施衣钵饮食疾病汤药。偷兰难陀威仪不具足。着穿破垢衣。大腹乳胁露现。举止卒暴多于言语。生不敬心不请与衣钵饮食疾病汤药。便作是言。我至檀越家称叹树提故得此供养。而树提但道说我不好事故我不得供养。树提言。阿梨耶。我不道说何故说汝恶事。诸比丘尼闻已语大爱道。大爱道即以是事往白世尊。佛言。呼是比丘尼来。来已问言。汝实尔不。答言实尔。佛言。此是恶事。汝云何不审谛而便嫌责。此非法非律非如佛教。不可以是长养善法。佛言。从今已后。不得不审谛闻而嫌责他。佛告大爱道瞿昙弥。依止舍卫城住比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼语比丘尼作是言。阿梨耶。共往某甲家。彼于后不忍。某甲比丘尼无因缘不审谛闻而呵责者。波夜提。比丘尼者如偷兰难陀比丘尼。家者刹利家。婆罗门家。毗舍家。首陀家。后不忍者如树提比丘尼。不忍事者九恼非处起嗔第十。无因缘者。不审谛闻后嫌责者波夜提。波夜提者如上说。若比丘尼不审谛闻而嫌责者波夜提。若比丘不审谛而呵责者越比尼罪。是故世尊说

佛住舍卫城。尔时偷兰难陀比丘尼。时到着衣持钵。诣大家门前立。有比丘来乞食。作如是言。上尊众可入此家。为尊者作食。与食已然后自食。若比丘尼来复言。阿梨耶入去。檀越为汝作食。施食已然后自食。或语言余家亦有食。何必共在此。如是一切外道乞食皆如是悭嫉心护他家。诸比丘尼闻已语大爱道。乃至答言。实尔世尊。佛言。此是恶事。汝云何悭嫉心护他家。从今日已后不听。佛告大爱道。依止舍卫城住比丘尼皆悉令集乃至已闻者当重闻。若比丘尼悭嫉心护他家者波夜提。比丘尼者如上说。家者四种姓家。悭嫉心者如偷兰难陀比丘尼。波夜提者如上说。比丘尼不得悭嫉心护他家。若比丘比丘尼问者当语实。若外道问时若恐染着外道邪见而呵责者无罪。若比丘悭嫉心惜他家者越毗尼罪。是故世尊说

  手与食医师　　授方佐俗作
  不语入习近　　自咒自打啼
  呵责护他家　　第九跋渠竟

佛住舍卫城。尔时有夫妇出家。时夫摩诃罗来与食。在边而立。其夫说先时女人恶事。闻已不喜便作是言。短寿摩诃罗不识恩义。不应说者而说之。诸比丘尼呵言。阿梨耶。此上尊众不得作此骂詈。即语比丘尼言。此短寿摩诃罗不知恩义。不应说者而说之。诸比丘尼语大爱道。大爱道即以是事往白世尊。佛言。呼来。来已问言。汝实尔不。答言实尔。佛言。此是恶事。从今日后不听。比丘尼对面呵骂比丘。佛告大爱道。依止舍卫城住比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼对面呵骂比丘者波夜提。比丘尼者如上说。对面者四目相对。呵骂者言。短寿摩诃罗不善不识恩义波夜提。波夜提者如上说。比丘尼不得对面呵骂比丘。若兄弟亲里出家。其人不持戒行。亦不得呵骂。应当软语教诲。若是年少者。应语沙路醯多。莫作此事。汝今不学何时当学耶。汝后弟子亦当学汝作不善。若老者。应语沙路醯多。汝今不学者待至老死时乃学耶。比丘亦不得对面呵骂。比丘尼言。剃发妇女淫劮妇女。乃至言摩呵梨汝不善不知恩义。可得软语教如上说。若比丘对面呵骂比丘尼越比尼罪。是故世尊说

佛住舍卫城。尔时比丘尼一岁二岁三岁便畜弟子。不知教诫。如天羊天牛而自放恣。净戒不具足。威仪不具足。不知恭奉和上尼阿阇梨。不知供奉长老比丘尼。不知入聚落法阿练若法。不知入僧中法。不知着衣持钵。诸比丘尼以是因缘往白世尊。佛言。呼是比丘尼来。来已问言。汝实尔不。答言实尔。佛言。从今已后。不听减十二雨畜弟子。佛告大爱道瞿昙弥。依止舍卫城比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼减十二雨畜弟子者波夜提。比丘尼者如上说。减十二雨者减十二年。是名减十二雨。比丘尼减十二雨满十二年。亦名减十二雨。比丘尼减十二雨过十二年。亦名减十二雨。比丘尼冬时受具足。数冬为十二未经自恣。是名减十二雨。若春时受具足。数春为十二。未经自恣。是名减十二雨。初安居时受具足。未经初安居时受自恣。是名减十二雨。后安居时受具足。未经后安居受自恣。是名减十二雨。比丘尼满十二雨减十二年。是名满十二雨。比丘尼满十二雨满十二年。如是过十二年。是名满十二雨。比丘尼冬时受具足。经安居竟受自恣。是名满十二雨。若春时受具足。经安居竟受自恣。如是初安居受具足已。经初安居竟受自恣。后安居受具足。经后安居受自恣。是名满十二雨。比丘尼畜受具足者波夜提。波夜提者如上说。若比丘尼减十二雨度人者越比尼罪。受具足者波夜提。若比丘减十二雨度人受具足者越比尼罪。是故世尊说

佛住舍卫城。尔时世尊制戒。不得减十二雨畜弟子。时六群比丘尼及余比丘尼。满十二雨十法不满。畜弟子不教诫犹如天牛天羊。乃至不知着衣持钵。诸比丘尼以是因缘语大爱道。乃至答言。实尔世尊。佛言。从今已后。不听十法不具足而畜弟子。佛告大爱道瞿昙弥。依止舍卫城住比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼满十二雨。十法不具足而畜弟子者波夜提。比丘尼者如上说。满十二雨者如上说。十法不具足者十法不成就。何等十。一持戒。二多闻阿毗昙。三比尼。四学戒。五学定。六学慧。七能自出罪。能使人出罪。八弟子亲里欲罢道。能自送若使人送至他方。九能看弟子病若使人看。十满十二雨若过。是名十法。若十法不满度弟子越比尼罪。受具足波夜提。若比丘十法不具足度人越比尼罪。是故世尊说

佛住舍卫城。尔时世尊制戒。满十二雨十法具足得畜弟子。尔时比丘尼满十二雨十法具足畜弟子。诸比丘尼嫌言。汝满十二雨十法具足。谁能知汝。诸比丘尼闻已语大爱道。大爱道即以是事往白世尊。乃至答言。实尔世尊。佛言。从今日后。畜弟子应作求听羯磨。然后得乞畜弟子羯磨。羯磨者应作是说。阿梨耶僧听。某甲比丘尼成就十法。若僧时到。僧某甲比丘尼。欲从僧乞畜弟子羯磨。阿梨耶僧听。某甲比丘尼十法成就。欲从僧乞畜弟子羯磨。僧忍默然故。是事如是持。此比丘尼应从僧乞。胡跪合掌作是言。阿梨耶僧听。我某甲满十二雨十法成就。今从僧乞畜弟子羯磨。唯愿僧与我畜弟子羯磨。如是三乞。羯磨者应作是说。阿梨耶僧听。某甲比丘尼满十二雨十法成就。已从僧乞畜弟子羯磨。若僧时到。僧某甲比丘尼十法成就。与畜弟子羯磨。如是白。阿梨耶僧听。某甲比丘尼满十二雨十法成就。已从僧乞畜弟子羯磨。僧今与某甲比丘尼畜弟子羯磨。阿梨耶僧忍。与某甲比丘尼畜弟子羯磨。忍者僧默然。若不忍者便说。是初羯磨。第二第三亦如是说。僧已与某甲比丘尼畜弟子羯磨竟。僧忍默然故。是事如是持。佛告大爱道瞿昙弥。依止舍卫城住比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼十法具足。不羯磨而畜弟子者波夜提。比丘尼者如上说。十法具足者亦如上说。不羯磨者不僧中作羯磨。名不羯磨。十法不具足者亦名不羯磨。虽作羯磨。若白不成就。众不成就羯磨不成就。亦名不羯磨。畜弟子者受具足不羯磨与受具足者波夜提。是故世尊说

佛住毗舍离。尔时迦梨比丘尼度梨车第三生女。与受学法已。捉户钩开他房户。共俗人外道住。比丘尼嫌呵言。此人犯戒捉户钩开他房户。共男子住。云何与受具足。诸比丘尼语大爱道。大爱道即以是事具白世尊。佛言。唤迦梨来。来已问汝实尔不。答言实尔。佛言。此是恶事。汝云何知犯戒。捉户钩开他房户。与外道共住。而与受具足。从今已后不听犯戒而与受具足。佛告大爱道。依止比舍离比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼知他犯戒。捉户钩开他房户。共男子住。与受具足者。波夜提。比丘尼者如上说。犯戒者戒不具足越戒。捉户钩开房者开他房户。男子者俗人若外道出家人。共住者习近住。与受具足者波夜提。波夜提者如上说。若共俗人外道习近住者。不听与受具足。若能使此人梵行全者。当先离别然后与受具足。若比丘知沙弥犯戒与女人习近住。不更与出家而与受具足者。越比尼罪。是故世尊说

佛住舍卫城。尔时比丘尼度十岁十二岁童女出家与受具足。时女软弱不堪苦事。净不具足。威仪不具足。不知奉事和上尼阿阇梨尼。不知入聚落。不知阿练若。不知入众。不知着衣持钵。诸比丘尼语大爱道。大爱道乃至佛言。呼是比丘尼来。来已问言。汝实尔不。答言实尔。佛言。从今日后。不听不满二十童女与受具足。佛告大爱道瞿昙弥。依止舍卫城住比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼与减二十雨童女受具足者波夜提。比丘尼者如上说。减二十雨者减二十年。是名减二十雨。童女减二十雨满二十年。亦名减二十雨。童女减二十雨出二十年。亦名减二十雨。冬时生通数冬二十未经自恣。是名减二十雨。童女春时生亦尔。前安居时生数前安居二十未经自恣。后安居时生数后安居二十未经自恣。是亦名减二十雨。童女若减二十雨。童女一切作减二十想与受具足。一切波夜提罪。此人不名受具足。若减二十雨。半减想半满想。与受具足。减想者波夜提。满想者无罪。此人名受具足。减二十雨童女。一切满想与受具足。一切无罪。是人名受具足。满二十雨减二十年。是名满二十雨。童女满二十雨满二十年。满二十雨过二十年。是名满二十雨。童女冬时生经安居自恣已满二十与受具足。春时亦如是。前安居生经前安居竟自恣已。后安居生后安居竟自恣已。满二十雨童女。半减想半满想。减想者越比尼罪。满想者无罪。此人名受具足。满二十雨童女。一切谓不满想与受具足。一切越比尼罪。此人不名受具足。一切满想一切无罪。此人名善受具足。童女者未坏梵行与受具足者波夜提。若童女欲于如来法中受具足者。应问汝何时生。若不知者应看生年板。若无者当问父母亲里若复不知当问何王时大丰时大俭时。若复不知者不可相形。若是乐人家女。年小而形大。当相其手足骨节。是故世尊说

佛住舍卫城。尔时世尊制戒。不听减二十雨童女受具足。时诸比丘尼。满二十雨童女与受具足。诸比丘尼嫌言。汝满二十雨不满二十雨。谁得知者。诸比丘尼语大爱道。大爱道即以是事往白世尊。乃至佛言。从今日已后。十八童女欲于如来法中受具足者。应从僧乞二年学戒。先作求听羯磨已。然后得乞。羯磨人应作是说。阿梨耶僧听。某甲十八岁童女。欲于如来法律中受具足。若僧时到。僧某甲欲从僧乞二年学戒。阿梨耶僧听。某甲十八岁童女。欲从僧乞二年学戒。僧忍默然故。是事如是持。此女人应从僧乞。作是言。阿梨耶僧听。我某甲十八岁童女。欲于如来法律中受具足。今从僧乞二年学戒。唯愿僧哀愍故与我二年学戒。如是至三。羯磨人应作是说。阿梨耶僧听。某甲十八岁童女。欲于如来法律中受具足。已从僧乞二年学戒。若僧时到。僧与某甲二年学戒羯磨。白如是。阿梨耶僧听。某甲十八岁童女。欲于如来法律中受具足。已从僧乞二年学戒。僧今与某甲二年学戒。阿梨耶僧忍僧与某甲二年学戒。忍者僧默然。若不忍者便说。是第一羯磨。第二第三亦如是说。僧已与某甲二年学戒竟。僧忍默然故。是事如是持。佛告大爱道瞿昙弥。依止舍卫城比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼。满二十岁童女不与学戒。而与具足者波夜提。满二十岁者满二十雨。满二十雨减二十年。亦名满二十雨。乃至后安居时生。后安居受自恣。数满二十。是名满。不与学戒者不与羯磨与学戒。是名不与。十法不具足亦名不与学戒。虽羯磨众不成就。白不成就。羯磨不成就。若一一不成就。而与受具足者波夜提。是故世尊说

佛住舍卫城。尔时比丘尼与受学戒不满学。与受具足。乃至已闻者当重闻。若比丘尼受学戒不满学。与受具足者。波夜提。受学戒者与受学戒。十法满。众成就。白成就。羯磨成就。若一一成就。是名与受学戒。不满学戒者与受学戒已。二岁应随顺学十八事。何等十八。一切比丘尼下一切沙弥尼上饮食。于其不净比丘尼净于比丘尼不净于其亦不净。得与比丘尼同室三宿。与沙弥尼亦齐三宿。得与比丘尼授食。除火净五生种已。从沙弥尼受食。不得向说波罗提木叉。从波罗夷乃至越比尼罪得语言。不得淫。不得盗不得杀人。如是比得教。不得听布萨自恣。至布萨自恣日。至上座前头面礼僧足作是言。我某甲清净忆念持。如是三说已。却行而去。后四波罗夷。若一一犯者。即日应更受学法。若十九僧伽婆尸沙已下。一切作突吉罗悔。若破五戒。何等五。非时食。停食食。受金银及钱。饮酒。着香华随其犯日。从始学戒满减者减二雨学。是名不满学。不满学与受具足者波夜提。是故世尊说

佛住舍卫城。尔时世尊制戒。不听不满学与受具足。尔时比丘尼十八雨童女学戒满。二十雨与受具足。诸比丘尼嫌言。汝学戒满不满谁得知者。诸比丘尼以是因缘语大爱道。乃至佛言。从今已后。学戒满二十雨童女。欲于如来法律中受具足作比丘尼者。先作求听羯磨。应然后从僧乞学戒满受具足羯磨。羯磨者应作是说。阿梨耶僧听。某甲二十岁童女学戒满。欲于如来法律中受具足。若僧时到。僧某甲欲从僧乞学满受具足。阿梨耶僧听。某甲二十岁童女学戒满。欲从僧乞学满受具足。僧忍默然故。是事如是持。应从僧乞胡跪合掌作是言。阿梨耶僧听。我某甲二十岁童女学戒满。欲于如来法律中受具足。今从僧乞学满受具足。唯愿僧哀愍故与我学戒满受具足。如是三乞。羯磨者应作是说。阿梨耶僧听。某甲满二十雨童女学戒满。欲于如来法律中受具足作比丘尼已从僧乞学满受具足。若僧时到僧与某甲学满受具足羯磨。白如是。阿梨耶僧听。某甲满二十雨童女学戒满。欲于如来法律中受具足作比丘尼。已从僧乞学满受具足。僧今与某甲学满受具足。阿梨耶僧忍与某甲学满受具足者默然。若不忍者便说。是第一羯磨。第二第三亦如是说。僧已与某甲学满羯磨竟。僧忍默然故。是事如是持。佛告大爱道瞿昙弥。依止舍卫城比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼学戒满。不羯磨与受具足者波夜提。学戒满者二雨中随顺行十八事。不羯磨者不作羯磨。与受具足者波夜提。波夜提者如上说。是故世尊说

摩诃僧祇律卷第三十八摩诃僧祇律卷第三十九

        东晋天竺三藏佛陀跋陀罗共法显译

    明一百四十一波夜提法之三

佛住舍卫城。尔时释种女拘梨女摩罗女梨车女先已嫁出家。曾任苦事故而有黠慧。大爱道瞿昙弥问佛世尊。已嫁女减二十雨得与受具足不。佛言得。尔时比丘尼与曾嫁八岁九岁女受具足。太小软弱不堪苦事。诸比丘尼语大爱道。大爱道即以是事往白世尊。乃至已闻者当重闻。若比丘尼适他妇减十二雨与受具足者波夜提。减十二雨者如减二十雨中广说。适他妇者坏梵行。与受具足者波夜提。波夜提者如上说。若适他妇欲于如来法律中受具足者。应先问乃至看手足骨节。是故世尊说

佛住舍卫城。尔时世尊制戒。不听减十二雨适他妇受具足。尔时比丘尼适他家。妇满十二雨与受具足。诸比丘尼嫌言。汝满十二雨适他妇。满与不满谁知者。诸比丘尼语大爱道。大爱道往白世尊。乃至佛言。从今已后。满十二雨适他妇。应与二年学戒。佛告大爱道。依止舍卫城比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼适他妇满十二雨。不与学戒受具足者。波夜提。如上童女不学戒中说

  面骂不满度　　十法不具足
  不羯磨畜众　　犯戒减二十
  不学不满学　　满学不羯磨
  减十二不学　　第十跋渠竟

佛住舍卫城。尔时迦梨比丘尼度王臣须提那妇。出家与受学戒。本在家有娠。转转腹大。诸比丘尼嫌言。已受学戒而有娠体应驱出。答言。我出家已来不知是法。诸比丘尼语大爱道。大爱道以是因缘往白世尊。佛言。此出家已来不知是法。此在家时事。若有如是比者。未应与受具足待娩身已。若生女者出草蓐已与受具足。若生男者待儿能离乳。然后与受具足。若亲里姊妹言。取是小儿来我自养活。如是者应与受具足。佛告大爱道瞿昙弥。依止舍卫城比丘尼皆悉令集乃至已闻者当重闻。若比丘尼已适他妇受学戒。不满学与受具足者波夜提。如上童女学戒不满中广说

佛住舍卫城。尔时世尊制戒。不听满十二雨适他妇二年学戒不满与受具足。尔时比丘尼与适他妇二年学戒满与受具足。诸比丘尼嫌言。汝学戒满与不满谁能知者。诸比丘尼语大爱道。大爱道以是事往白世尊。乃至佛告大爱道瞿昙弥。依止舍卫城住比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼已适他妇学戒满。不羯磨与受具足者波夜提。如上童女不羯磨中广说

佛住舍卫城。尔时比丘尼多畜弟子不教诫。如天牛天羊。净不具足。威仪不具足。不知承事和上阿阇梨。不知承事长老比丘尼。不知入聚落法阿练若法。不知着衣持钵法。比丘尼语大爱道。大爱道即以是事往白世尊。佛言。呼是比丘尼来。来已佛问。汝实尔不。答言。实尔。世尊。佛言。此是恶事。汝云何度人而不教诫。从今已后。应二年教诫。佛告大爱道瞿昙弥。依止舍卫城住比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼与弟子受具足已。应二年教诫。若不教者波夜提。比丘尼者如上说。弟子者共住弟子。二年者二雨时。教诫者若阿毗昙。若毗尼。阿毗昙者九部修多罗。毗尼者波罗提木叉广略。威仪应教。非威仪应遮。若不教诫者波夜提。若弟子不可教不欲学者应驱出。若比丘共住弟子不教敕越毗尼罪。是故世尊说

佛住舍卫城。尔时比丘尼度弟子。弟子受具足已弃余处去。时和上尼嫌言。世尊制戒应教诫弟子。弟子舍我去。我当教诫谁。诸比丘尼语大爱道。大爱道即以是事具白世尊。佛言。呼是比丘尼来。来已问言。汝实尔不。答言实尔。佛言。此是恶事。汝云何受具足已而余处去。应二年事和上尼。佛告大爱道瞿昙弥。依止舍卫城比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼受具足已。应二年供给随逐和上尼。若不供给随逐波夜提。受具足者共住弟子。二年者二雨时。供给者供给和上尼。应随逐者不远离。不供给随逐者波夜提。若和上尼不善持戒不欲学。弟子作是念。我和上尼但非威仪处行。我若随逐或伤我梵行。欲全梵行故舍去无罪。若比丘。不供给和上随侍越毗尼罪。是故世尊说

佛住舍卫城。尔时比丘尼年年度弟子受具足。心生疑惑。为得为不得。即问大爱道。大爱道往白世尊。佛言。唤是比丘尼来。来已问言。汝实尔不。答言实尔。佛言。从今日后不听年年度人受具足。当作间。佛告大爱道。依止舍卫城比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼年年畜弟子波夜提。年年者雨雨时。畜弟子者受具足。波夜提者如上说。不听年年畜弟子。应作一雨时间。若比丘尼有福德。一年与学戒弟子。二年与受具足。虽年年无罪。是故世尊说

佛住王舍城。尔时树提比丘尼欲与弟子受具足。语偷兰难陀比丘尼言。阿梨耶。为我请僧与弟子受具足。后比丘尼僧与受具足。偷兰难陀比丘尼请得六群比丘。树提问言。为我请得僧未。答言已得。得谁答言。得六群比丘。语言。我不用。至明日更请善比丘受具足。诸比丘尼语大爱道。大爱道即以是事往白世尊。佛言。唤是比丘尼来。来已问言。汝实尔不。答言实尔。佛言树提。此是恶事。汝云何一众清净。已停宿受具足而复轻众。从今日后。不听一众清净停宿受具足。亦不听轻众。佛告大爱道瞿昙弥。依止王舍城比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼一众清净停宿受具足波夜提。比丘尼者如上说。一众清净者。比丘尼众中受具足。停宿者至明日。比丘众中受具足波夜提。波夜提者如上说。不听一众清净停宿受具足。复不听轻众。复不得请恶比丘众与受具足。应当先求善比丘。若不可得当求半。若过半许而作羯磨。若王贼难。不得者停宿无罪。比丘亦不得轻众。应得半。若过半而作羯磨。轻众者得越毗尼罪。是故世尊说

佛住毗舍离。尔时迦梨比丘尼度梨车第三生女出家。与俗人外道习近住。诸比丘尼语迦梨比丘尼。汝知是弟子与俗人外道习近住。汝何故不别离送于异方。诸比丘尼语大爱道。大爱道即以是事往白世尊。佛言。呼是比丘尼来。来已问言。汝实尔不。答言实尔。佛言。此是恶事。汝云何知弟子共俗人外道习近住而不离别。从今已后不听。佛告大爱道。依止毗舍离住比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼度弟子有事。不自送不使人送。下至五六由旬波夜提。比丘尼者如上说。度人者和上尼。弟子者共行弟子。有事者弟子欲罢道。若父母亲里欲罢道。若婿若叔欲罢道。送者若不自送不使人送。下至五六由旬者极齐六。若弟子习近住者应送游行。若身老病不能去者应嘱人。当教诫汝可游方多有功德。礼诸塔寺见好徒众多所见闻我若不老者亦复欲去。若比丘共住弟子有事。不自送不使人送者得越毗尼罪。是故世尊说

佛住舍卫城。尔时偷兰难陀比丘尼十法不满。度弟子不教诫。如天牛天羊。乃至比丘尼语言。阿梨耶。汝十法不具足。度弟子何不教诫使如法。偷兰难陀言。汝妒我度弟子而责数我。诸比丘尼语大爱道。大爱道即以是事往白世尊。佛言。呼是比丘尼来。来已问言。汝实尔不。答言实尔。佛言。此是恶事。乃至汝云何十法不具度弟子不教诫而嫌责他。从今已后不听嫌他。佛告大爱道瞿昙弥。依止舍卫城比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼语比丘尼作是语。阿梨耶。十法不具足度弟子应教诫。而反嫌责者波夜提。比丘尼者若僧若众多人若一人。是比丘尼者如偷兰难陀比丘尼。十法不具者十法不成就。度弟子者受具足作是谏时。而嫌责者波夜提。波夜提者如上说。比丘如是者越毗尼罪。是故世尊说

佛住舍卫城。尔时有学戒尼。语偷兰难陀言。阿梨耶。我学戒满。与我受具足。答言可尔。后学戒尼言。阿梨耶。我学戒满与我受具足。闻是语已。自不与受不使人受。又不发遣。诸比丘尼言。汝先许与受具足。何以不与。闻此语犹故不与。诸比丘尼语大爱道。大爱道即以是事具白世尊。佛言。呼是比丘尼来。来已问言。汝实尔不。答言实尔。佛言。此是恶事。汝云何许他受具足而不与受。从今已后不听。佛告大爱道。依止舍卫城比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼语式叉摩尼言。学戒满当与汝受具足。后不与受不使人受。又不遣去者波夜提比丘尼者如上说。式叉摩尼者随顺行十八事二岁学。作是语者。如偷兰难陀比丘尼许与受具足后不与受不使人受波夜提。波夜提者如上说。若比丘尼语式叉摩尼。当与汝受具足。若后无力者当使人受。若不自受不使人受者。应语令去更余处受具足。若比丘尼许式叉摩尼受具足。后不与受者波夜提。若比丘许沙弥受具足。后不与受者得越毗尼罪。是故世尊说

佛住毗舍离。尔时跋陀罗伽毗梨比丘尼载好上乘到亲里家。为世人所嫌。云何沙门尼出家。故如俗人载好上乘多欲如是。诸比丘尼闻已语大爱道。大爱道即以是事具白世尊。佛言呼是比丘尼来。来已问言汝实尔不。答言实尔。佛言。此是恶事从今已后不听。复次尔时释种女。比丘尼道路行羸。老病不及伴后被贼。乃至佛告大爱道。依止舍卫城比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼不病载乘者波夜提。比丘尼者如上说。病者若老羸病若乐人不能行。世尊说无罪。乘者八种。乃至船乘是名八种。载者波夜提。不听不病比丘尼载乘。病者不得载特牛乘。得载牸牛车及雌马骆驼。若病不觉雌雄无罪。若乘船直度无罪。若上水若下水作因缘受持得去。若比丘不病载乘者。越毗尼罪。是故世尊说

  不满不羯磨　　和上不教诫
  弟子不随逐　　年年畜弟子
  停宿受具足　　有事不遣送
  嫌责许具足　　载乘最在后
  十一跋渠竟

佛住毗舍离。尔时跋陀罗伽比梨比丘尼持伞盖着革屣。往亲里家。为世人所嫌。云何沙门尼似如俗人如是多欲。诸比丘尼语大爱道。大爱道即以是事往白世尊。佛言。呼是比丘尼来。来已问言。汝实尔不。答言实尔。佛言。从今已后。不听持伞盖革屣。复次佛住舍卫城。释种女摩罗女先是乐人。出家道路行。时天极热甚大疲苦。诸比丘尼语大爱道。大爱道即以是事。往白世尊。佛言。从今日后听病时。佛告大爱道。依止舍卫城比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼不病。持伞盖着革屣者波夜提。比丘尼者如上说。病者老羸病尪弱。世尊说无罪。伞盖者树皮盖。多梨盖。竹盖。摩楼盖。树叶盖。[疊*毛]伞盖。如是比余盖等。革屣者一重两重。持者受用波夜提。波夜提者如上说。持盖不持革屣越毗尼罪。持革屣不持伞盖。亦越毗尼罪。二俱持者波夜提。二俱不持者无罪。若比丘持庄严伞盖两重革屣者越毗尼罪。是故世尊说

佛住毗舍离。尔时跋陀罗伽比梨比丘尼往至亲里家。敷高脚佉啁罗床褥两三重登上。为世人外道所嫌。云何沙门尼出家。犹如俗人多欲如是。诸比丘尼语大爱道。大爱道即以是事往白世尊。佛言。呼是比丘尼来。来已问言。汝实尔不。答言实尔。佛言。汝云何过量佉啁罗床上坐。从今已后不听。佛告大爱道瞿昙弥。依止毗舍离比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼过量佉啁罗床褥上若坐若卧波夜提。比丘尼者如上说。过量者过八指。佉啁罗床褥者佉啁罗十四种。乃至崩求罗。佉啁崩求罗床。若坐若卧波夜提。波夜提者如上说。若竟日坐一波夜提。若起已更坐随坐得波夜提。若过量床得埋脚坐。若比丘坐过量佉啁罗床上越毗尼罪。是故世尊说

佛住舍卫城。尔时六群比丘尼共一床一敷眠。枕褥破裂床复折坏。诸比丘尼以是因缘语大爱道。大爱道乃至佛言。呼是比丘尼来。来已佛言。汝实尔不。答言实尔。佛言。此是恶事。乃至佛告大爱道。依止舍卫城比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼同敷床褥卧波夜提。敷者同一敷一覆一床。床者十四种。乃至脂兰床波夜提。波夜提者如上说。不得同床卧。一床一人卧。三坐床得二人卧。展脚不得过膝。若方褥三褥得二人卧。展脚不得过膝。若地敷者不得多取。地当相去一不舒手。自敷坐具而卧。若寒时得上通覆于下人。各自别覆无罪。若比丘共床卧越毗尼罪。是故世尊说

佛住舍卫城。尔时伽梨比丘尼受僧房已闭户而去。后客比丘尼上座来次第与房。见户闭即嫌言。此僧房舍何以闭户而去。诸比丘尼语大爱道。乃至佛言呼是比丘尼来。来已问言。汝实尔不。答言实尔。佛言。此是恶事。乃至汝云何僧房舍不舍闭户而行。从今已后不听。佛告大爱道。依止舍卫城比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼僧房床褥不舍而去波夜提。比丘尼者如上说。僧床褥者坐床卧床枕褥拘执。不舍者不还不白。余处去者波夜提。波夜提者如上说。若比丘尼欲行去。当舍床褥。与知床褥人已而去。若不舍而去者波夜提。若房不空。寻有人住者越毗尼罪。是故世尊说

佛住舍卫城。尔时竭住母比丘尼。先不语卒尔而入竭住父比丘房。而摩其背。即反顾视之。见已言。咄咄远我。比丘尼言。我先常与洗浴。今摩触何苦。语言。本是俗人今日出家不得如先。诸比丘尼语大爱道。大爱道即以是事往白世尊。佛言。呼是比丘尼来。来已问言。汝实尔不。答言实尔。佛言。此是恶事。乃至汝云何先不白入比丘精舍。从今已后不听。乃至已闻者当重闻。若比丘尼先不白入比丘僧伽蓝者波夜提。比丘尼者如上说。比丘僧伽蓝者下至一比丘住处。先不白者先不语不呼。入者如竭住母比丘尼波夜提。波夜提者如上说。若比丘尼欲入比丘住处者。当到门屋应先白和南比丘尼。白入愿听。比丘当筹量。若比丘尼贤善。自无事着衣服者听入。若有事或泥作或裸露当语言。姊妹小住。应唱言。诸长老。比丘尼欲入各自着衣。若比丘尼不善无威仪者。应语莫入有事。若先不语最初入者波夜提。后来者无罪。不白而入者举一足越毗尼罪。两足波夜提。若还去者越毗尼罪。若比丘先不语而入比丘尼住处者越毗尼罪。应住门屋下遣净人女语。是故世尊说

佛住舍卫城。尔时比丘尼在道行。暮至村中欲求宿处。至一家语妇人言。借我宿处。妇人言。我夫行去暮或能还。比丘尼复重借。言故当不来可寄一宿。即与宿处。夫主暮还为结所使与妇共行欲事。比丘尼未离欲。闻声不悦还已语诸比丘尼。比丘尼语大爱道。乃至佛言。呼是比丘尼来。来已问言。汝实尔不。答言实尔。佛言。汝云何知食家淫处宿。从今已后不听。复次佛住舍卫城。尔时诸比丘尼道路行。至暮于聚落中。遍求无丈夫家而不能得。便在巷陌边宿。于夜暴风雨起。有诸年少来相侵触伤于梵行。诸比丘尼以是因缘语大爱道。乃至佛言。从今日后除余时乃至已闻者当重闻。若比丘尼知食家淫处宿。除余时波夜提。余时者风时雨时夺命时伤梵行时。是名余时。比丘尼者如上说。知者若自知若从他闻。食者女人是丈夫食。丈夫是女人食。家者四种姓家。淫处者夫妇宿处。除余时波夜提。余时世尊说无罪。风时雨时失命时疑男子伤梵行时。是名余时。不得知食家淫处宿。若疑是聚落中有放荡男子。畏宿者无罪。是故世尊说

佛住舍卫城。尔时毗舍离比丘尼安居竟。欲向舍卫城礼拜世尊。到比丘精舍中。和南。我闻尊者欲诣舍卫城礼拜世尊审尔不。答言。何故问。我欲随去。比丘言。世尊制戒。不得与比丘尼共道行又问。何时当发答言。某日。即记识其日。预持衣钵于路侧而待。比丘至其日食已而去。见比丘尼并相谓言。此比丘尼欲随我等去。当急脚行。诸年少比丘尼奔走而逐。诸老病乐人不能得及。于后为贼所剥。诸比丘尼语大爱道。大爱道以是因缘往白世尊。乃至呼是比丘尼来。来已佛问。汝实尔不。答言实尔。佛言。汝云何无商人伴。于空迥处向余国行。从今已后不听。佛告大爱道。依止舍卫城比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼无商人伴向异国行波夜提。比丘尼者如上说。无伴者无商人伴。余国者异王境界。去者波夜提。若比丘尼欲行时。当先求商人伴。若前人言。阿梨耶但来。我当料理使令得去。当相望其人。若语大善视瞻不好者。不应随去。更求善人将女妇者共去。若去时卒不得善察。至迥处方觉者不得便舍去。当待近聚落已方便舍去。若问言欲那去。当语言。我乞食耳。若比丘尼无商人伴行者得越毗尼罪。至所在波夜提。若比丘于空迥无商人伴行者得越毗尼罪。是故世尊说

佛住舍卫城。尔时比丘尼共女人。共到园池处看。诸女人在水边饮食。比丘尼往故村舍中看。时有诸年少从林中出扰乱比丘尼。比丘尼语大爱道。乃至已闻者当重闻。若比丘尼自境界内。观园林故墟波夜提。比丘尼者如上说。境界内者自王境内。园者庵婆罗园。乃至阿提目多园。林者种种林树。故墟者空屋宅中。观看去者波夜提。波夜提者如上说。若比丘尼往园林墟宅中看去时越毗尼罪。到彼波夜提。若檀越妇女请共去者无罪。若比丘往丘墟园林观看为乐者越毗尼罪。是故世尊说

佛住毗舍离。尔时须阇提比丘尼。是优陀夷本二。语优陀夷言。尊者。我明日当守房可来看。时比丘尼尽入聚落乞食。时优陀夷着衣持钵入比丘尼精舍。二人共在房后。各出身坐蹲踞相向欲心相视。时有老病比丘尼出欲便利。见已羞惭却行而去。以是因缘语大爱道。乃至佛言。呼是比丘尼来。来已佛言。此是恶事。乃至已闻者当重闻。若比丘尼共一比丘空静处坐波夜提。一者共一比丘更无人。设有人眠醉狂痴心乱苦痛婴儿非人畜生。故名为一。空静者避隈无人处。坐者共坐波夜提。波夜提者如上说。若比丘尼共比丘竟日坐一波夜提。若中间起还坐随坐一一波夜提。若比丘尼独在房中坐。卒有比丘来入坐者。比丘尼当速起。欲起时当先语。勿使比丘怪。若言何故起。当语。世尊制戒我不得共比丘独坐。若减七岁男亦犯齐几时名坐。如取食乞出家人顷。若有净人。作事行来出入。不断无罪。若房户向道。有行人。不断者无罪。若行人断者波夜提。若净人眠时当弹指令觉。若在阁上下人见。若在阁下上人见。三人展转。相见无罪。或见非闻。或闻非见。或亦见亦闻。或非见非闻。见非闻者。遥见比丘比丘尼坐不闻语声。闻非见者。闻语声而不见。如是广说见而不闻越毗尼罪。闻而不见亦越毗尼罪。见闻无罪。非见非闻波夜提。是罪亦聚落亦阿练若。亦昼亦是夜。亦时亦非时。是覆处非露处。是一人非众多。是近处非远处是故世尊说

佛住毗舍离。尔时跋陀罗比丘尼到亲里家共兄弟姊妹儿于屏处坐。比丘尼嫌言。云何出家人。与俗人隐处坐。犹如俗人。以是因缘语大爱道。乃至佛言。从今已后。不听共男子屏处坐乃至已闻者当重闻若比丘尼与丈夫屏处坐波夜提。波夜提者如上比丘中广说。是故世尊说

  持伞佉啁床　　同敷床不舍
  不白淫处宿　　无伴故墟看
  比丘静处坐　　男子亦复然
  十二跋渠竟

佛住毗舍离。尔时跋陀罗比丘尼到亲里家。与兄弟姊妹儿。申手内住共耳语。奴婢嫌言。此出家人耳语。正当说我等过。诸比丘尼闻已。语大爱道瞿昙弥乃至已闻者当重闻。若比丘尼与男子申手内住若耳语波夜提。比丘尼者如上说。申手内者共申手内住。耳语者耳边共语波夜提。比丘尼不得与男子申手内住共语若耳语。若欲共语者。当在申手外。若欲论密事。当隔篱隔壁隔树隔缦。比丘尼波夜提。比丘与女人申手内住共耳语越毗尼罪。是故世尊说

佛住毗舍离。尔时跋陀罗比丘尼到亲里家。与兄弟姊妹儿在闇处无灯。先不语卒尔而入。尔时亲里羞惭。诸比丘尼语大爱道。乃至答言。实尔。佛言。汝云何知男子在闇中无灯而入。从今已后不听。乃至已闻者当重闻。若比丘尼知闇中有男子坐无灯而入波夜提。比丘尼者如上说。男子坐者常眠卧处。闇处者不相见处。无灯者无油灯及余种种灯。入者波夜提。波夜提者如上说。不得入闇地男子坐处。若有因缘事须入者。若闻内人高声大声当入。若不闻语者应先遣人语若弹指若作灯明现相。有人呼入者当入。若不语不弹指不作灯明而入者波夜提。若比丘不语而入者越毗尼罪。是故世尊说

佛住王舍城。尔时六群比丘尼先到作伎乐处。占顾坐处伎儿戏时高声大笑。众人效笑。人笑时便复默然似如坐禅人。笑适止。还复拍手大笑。于是众人舍伎儿而观比丘尼。时伎儿不得雇直。嗔恚嫌责。坐是沙门尼。令我失雇直。诸比丘尼语大爱道。乃至答言。实尔佛言。此是恶事。汝云何观伎乐。从今已后。不听观伎乐。乃至已闻者当重闻。若比丘尼观伎乐行波夜提。比丘尼者如上说。伎乐者舞伎歌伎铙盘打鼓如是一切。下至四人共戏。观看者波夜提。波夜提者如上说。不得观伎乐。若比丘尼乞食值王王夫人。若天像出有伎乐者遇见无罪。若下处就高作意窥望逐看波夜提若檀越欲供养佛。作众伎乐研香结鬘。语比丘尼言阿梨耶。佐我安施供养具。尔时得助作。若于彼间闻乐。有欲着心者当舍去。若比丘观伎乐者越毗尼罪。是故世尊说

佛住舍卫城。尔时比丘尼诤斗不和合住。时大爱道瞿昙弥众主。僧诤事已起者不能灭。未起者不能令不起。诸比丘尼以是因缘往白世尊。佛言。呼大爱道瞿昙弥来。来已佛语瞿昙弥。汝实尔不。答言实尔。佛言。汝云何诤事起而不断灭。未起者不能方便令不起。从今日后。诤事起当断灭。佛告大爱道。依止舍卫城比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼斗诤不和合住。众主不料理断灭者波夜提。比丘尼者如上说。诤者口诤。斗者展转取胜不和合住。是法非法。是毗尼非毗尼。是罪非罪。是轻是重。是可治是不可治。有残无残。如法羯磨非法羯磨。和合羯磨不和合羯磨。应羯磨不应羯磨。是处羯磨非处羯磨。众主者众之标望得自从意。不料理断灭者不自灭不使人灭波夜提。波夜提者如上说。若比丘尼斗诤不和合住。不得视置。当料理断灭使展转悔过。若复不止事。须羯磨者当集僧料理。若自不能者。当余众请有德比丘尼。若比丘。若优婆塞优婆夷令灭。若诤事难断当作是念。众生业行待时待熟自当灭。如是者无罪。若比丘斗诤。众主不料理灭者越毗尼。罪是故世尊说

佛住毗舍离。尔时有跋陀罗比丘尼。到亲里家观看洗浴。诸妇人言。我与阿梨耶揩身体使我得功德。此比丘尼端正。诸女人欲看其身体故。便听使揩。即用种种香油涂身。诸比丘尼嫌言。出家人犹故多欲。诸比丘尼语大爱道。乃至答言。实尔世尊。佛言。汝云何使俗人家妇女揩摩身体。从今日已后不听。乃至已闻者当重闻。若比丘尼使俗人妇女涂香油揩摩洗浴。除病时波夜提。比丘尼者如上说。俗人妇女者四种家女。揩摩洗浴者以种种香油揩摩洗浴。若老病者无罪。若不病揩摩洗浴波夜提。波夜提者如上说。若身体有疮疥。得持药揩摩洗浴。若热病得摩耶披屑涂。若风病得以小麦屑涂。若杂病者以杂药涂无罪。涂已不得在众人中住。当在边房。病差洗已当入。若比丘不病。使俗人揩摩越毗尼罪。是故世尊说

佛住毗舍离。尔时世尊制戒。不听俗人妇女揩摩洗浴。时跋陀罗比丘尼使比丘尼揩摩。诸比丘尼以是因缘往白世尊。乃至已闻者当重闻。若比丘尼不病。使比丘尼揩摩洗浴者波夜提。若揩而不摩越毗尼罪。摩而不揩亦越毗尼罪。二俱者波夜提。若比丘不病。令比丘揩摩者越毗尼罪。是故世尊说

沙弥尼亦如是。乃至已闻者当重闻。若比丘尼不病。令沙弥尼揩摩者波夜提。沙弥尼者随佛出家受十戒使揩摩者如比丘尼中说。式叉摩尼亦如是。乃至已闻者当重闻。若比丘尼不病。令式叉摩尼揩摩者波夜提式叉摩尼者随顺行十八事。二年学戒。使揩摩者如上比丘尼中说。俗人妇女亦如是。乃至已闻者当重闻。若比丘尼不病。令俗人妇女揩摩者波夜提。俗人妇女者四种姓家女人。揩摩如比丘尼中说

佛住王舍城。尔时比丘尼僧集欲作布萨羯磨。时树提比丘尼不来。僧遣信唤言。阿梨耶。比丘尼僧集欲作布萨可来。树提言。世尊制戒。世间清净者得布萨。我即清净不能去。大爱道以是因缘具白世尊。乃至答言。实尔。佛言。此是恶事。乃至汝不恭敬布萨。谁当恭敬。乃至已闻者当重闻。若比丘尼半月清净布萨。不恭敬者波夜提。清净布萨者十四日十五日。不病比丘尼不来恭敬布萨者波夜提。病者老羸病服药刺头出血服酥。应与清净欲。若不病不来。设病不与清净欲波夜提。若比丘尼不来布萨。病不与清净欲波夜提。若比丘不来布萨。病不与欲越毗尼罪。是故世尊说

  申手内无灯　　伎乐主不灭
  香油比丘尼　　沙弥尼学戒
  女妇不布萨　　十三跋渠竟

佛住舍卫城。尔时长老比丘教诫比丘尼。尔时六群比丘不得教诫。次便作是言。我等教诫去又言。世尊制戒。不听不差而教诫。我等当出界外。展转相拜而去。即出界外展转相拜已。晨朝着衣往到比丘尼住处。语比丘尼言。姊妹尽集。我当教诫。时六群比丘尼即便速集。善比丘尼不来。而作是言。我不能非毗尼人边受教诫。时六群比丘共六群比丘尼作世俗语已。须臾间而去。尔时长老难陀着衣持钵。来到精舍言。姊妹集僧我欲教诫。于是善比丘尼尽集。六群比丘尼不来。长老问言。比丘尼僧集未。答言不集。谁不集。答言。六群比丘尼。即遣信唤。姊妹来我欲教诫答言。我不去。已六群阿阇梨边受教诫竟。时长老言尼僧不和合。即起而去。佛知而故问。汝教诫何以速。答言世尊。我至时着衣往欲教诫。善比丘尼皆集。唯六群比丘尼不来。比丘尼僧不和合故不得教诫。佛言。呼六群比丘尼来。来已问言。汝实尔不。答言实尔。乃至已闻者当重闻。若比丘尼半月僧教诫。而不恭敬不来波夜提。比丘尼者如上说。半月者十四日十五日僧教诫者教诫比丘尼。不恭敬不来者波夜提。波夜提者如上说。若老羸病服药刺头出血服酥。应与欲作是言。我某甲与教诫欲。如是三说。若不病不去。病不与欲波夜提。若至布萨日。应差比丘尼持欲诣僧。作如是言。比丘尼僧和合。头面礼比丘僧足。问布萨请教诫。如是三说。比丘僧中有教诫尼者。应语。姊妹当住。若有比丘成就十二法者。应羯磨教诫。若无者当语言。无教诫比丘尼人莫放逸。是故世尊说也

佛住王舍城。尔时树提比丘尼隐处生痈。诸比丘尼入聚落乞食。后有治痈师来。比丘尼言。长寿。与我破痈。答言可尔。即与破痈疮。着涂药已而去。诸比丘尼乞食还。见地脓血问言。此是何等脓血。答言。我破痈疮。诸比丘尼嫌言。汝云何隐处有痈。不白善比丘尼而破。诸比丘尼语大爱道。乃至答言。实尔世尊。佛言。汝云何膝以上肩以下有痈疮。先不白听而破痈。从今已后不听。乃至已闻者当重闻若比丘尼。膝以上肩以下隐处有痈疮。先不白听男子破洗者波夜提。比丘尼者如上说。膝已上者髀已上。肩已下者乳房已下。先不白者不白善比丘尼。听者不僧中作求听羯磨。隐处有痈欲破痈者。应先僧中作求听羯磨。羯磨者应作是说。阿梨耶僧听。某甲比丘尼隐处有痈。若僧时到僧某甲比丘尼。欲从僧乞破痈羯磨。阿梨耶僧听。某甲比丘尼。欲从僧乞破痈羯磨。僧忍默然故。是事如是持。若隐处有痈者。当令可信人若依止弟子若同和上阿阇梨以锥若指甲破之以药涂。若使男子破痈波夜提。波夜提者如上说。若肩已上膝已下有痈疮。若欲刺头出血。若欲刺臂。当使妇女人急按男子破无罪。是故世尊说

摩诃僧祇律卷第三十九摩诃僧祇律卷第四十

        东晋天竺三藏佛陀跋陀罗共法显译

    明一百四十一波夜提法之余

佛住舍卫城。尔时迦梨比丘尼。安居中受僧床褥已而舍游行。诸比丘尼以是因缘语大爱道瞿昙弥。乃至答言。实尔。佛言。汝云何安居中游行。从今已后不听。乃至已闻者当重闻。若比丘尼。安居中游行者波夜提。安居者。前安居。后安居。行者。下至聚落宿波夜提。波夜提者如上说。若比丘尼。安居中离界一宿波夜提。若王难余方贼来。若恐夺命。若畏失梵行者去无罪。比丘尼安居中。无有求听羯磨法为塔僧事而游行。是故世尊说

佛住舍卫城。尔时比丘尼。舍卫城安居竟。来诣比舍离。往到跋陀罗比丘尼亲里家。其家人问何处安居。答言。舍卫城。问。舍卫城何似好不。比丘尼言。祇洹树林华果茂盛池水清凉。精舍如是。世尊住处如是。尊者舍利弗大目连如是。须达居士如是。檀越言。此是真出家。今我跋陀罗此处生此处长。如无手足人。初不肯出。诸比丘尼以是因缘往白世尊。乃至答言。实尔。佛言。汝云何安居竟而不游行。从今已后不听。乃至已闻者当重闻。若比丘尼。安居竟不游行者波夜提。安居竟者。三月竟。不游行者。乃至不出聚落行波夜提。波夜提者如上说。安居竟乃至不离界一宿行波夜提。若羸老病不能行无罪。是故世尊说

佛住舍卫城。尔时偷兰难陀语树提言。此间安居。即往檀越家叹誉。树提比丘尼贤善持戒汝当供养。于是树提威仪庠序。举动视瞻不失仪法。见已生欢喜心。乃至后嫌诃恼触。诸比丘尼以是因缘往白世尊。乃至答言。实尔。佛言。此是恶事。乃至已闻者当重闻。若比丘尼语比丘尼作是语。阿梨耶。此处安居。后嫌诃恼触波夜提。若比丘尼语是中安居安居中恼触。恼触者。若自身口若使人身口恼触。波夜提。若前人不持戒。畏作非法虽驱遣无罪。若式叉摩尼沙弥尼越比尼罪。乃至俗人越比尼心悔。是故世尊说

佛住舍卫城。尔时迦梨比丘尼。到欲安居时余行去。受安居已还。房舍已分竟。方来索言。是我房舍还我。住者言我已受不可得。于是斗诤。有善比丘尼呼言。阿梨耶。可就此房住。入已持巨摩柴草积聚房中。先住者言。阿梨耶。此不用物不须安。即言贤善。汝买得此房耶。答言。我当次得此僧房。若是僧房者我何以不安。于是以身口扰乱。诸比丘尼以是因缘往白世尊。乃至答言。实尔。佛言。此是恶事。汝云何知他先安居已后来扰乱。从今已后不听。乃至已闻者当重闻。若比丘尼。知比丘尼先安居已后来。若自扰乱。若使人扰乱波夜提。知先安居者。前安居后安居。扰乱者。若自身口。若使他身口扰乱波夜提。若扰乱比丘尼波夜提。式叉摩尼沙弥尼越比尼罪。乃至俗人越比尼心悔。是故世尊说

佛住舍卫城。尔时有比丘尼。不先看墙外。掷弃大小便。时有婆罗门。新洗浴着新净衣巷中行。正堕头上。婆罗门嗔骂言。众多人子沙门尼。污我如是。诸比丘尼往白佛。乃至答言。实尔世尊。佛言。此是恶事。汝云何不审谛观而弃不净。从今已后不听。乃至已闻者当重闻。若比丘尼。隔墙不观掷弃不净波夜提。隔墙者。隔篱墙。掷不净者。大小便洟唾粪扫及洗手足水发指甲。不观者。不先看而掷。若欲掷弃物时当先谛视。若多人行者。当待断乃掷。若行人希者。当弹指乃掷。若不视不弹指而掷者波夜提若比丘不视而掷者越比尼罪。是故世尊说

佛住舍卫城。尔时波斯匿王东园池。不禁比丘比丘尼入。尔时六群比丘尼往彼园中作世俗语话。大小便洟唾生草上。复以藕叶裹不净放池水中。明旦波斯匿王与后宫夫人。共诣园池游观。时后宫人闭在深宫不出来久。始得一出游戏熙怡喜勇竞。各占顾生草。此是我许而往捉之污泥其手。诣水欲洗。复见水上有裹。便作是念。诸年少等闻我等出。必裹众香以待我等。即往捉取而污其手。即往白王。此是何物不净如是。王即呼守园人问。谁污此园。白言更无余人。昨日六群比丘尼在中作浴人言戏而去。诸比丘尼以是因缘往白。乃至佛言。此是恶事。乃至已闻者当重闻。若比丘尼。生草上大小便波夜提。若比丘尼。水中大小便波夜提。比丘尼者如上说。草者一切草。大小便洟唾波夜提。若雨时生草覆地者。当在无草处行。若无空处者。当在瓦塼上干草木牛马屎上人行处。若复无者。下至一木枝。令先堕木枝后堕草上。若经行处有草者。当于经行头安唾壶。是故世尊说。比丘尼如上说。水者有十种如上说。若水中大小便洟唾波夜提。若雨时水漫溢者当于高处。大小便。若无是者。当于瓦石干草木上牛马屎上。若复无者。当以草木枝承令先堕木枝后堕水中。若掘厕下有水出者。不得先于中大小便。先令净人行。然后比丘尼行。若厕下有流水者。当安板木。令先堕板上后堕水中。若船上行时有厕处者。当安板木承。令堕板上后堕水中。若无板者。以木枝承令先堕木枝上后堕水中。是故世尊说

佛住舍卫城。尔时六群比丘尼游行劝化。语女人言。与我物。欲为诸比丘作食。女人即与作是言。至作食日语我。我当行食。时请尊者舍利弗大目连离波多劫宾那尊者罗睺罗。复请六群比丘。敷二坐。一与长老比丘。一与六群比丘。尔时长老比丘。时到着衣持钵到舍次第而坐。与尊者舍利弗白米饭蒙巨羹酥乳酪。如是转与粗食。尊者目连与粗米饭摩沙羹油乳。余比丘与赤米饭摩沙羹。或有得饭不得羹。有得羹不得饭。乃至尊者罗云与赤米饭麻籸菜羹。时诸女人复持种种好食来。问言与谁。比丘尼便以身障长老比丘。示六群比丘。与白米饭好羹酥乳酪。自恣与。诸比丘食已而去。佛知而故问。舍利弗。得好食满足不。答言已食。世尊。如是三问。答亦如是。如是一一问诸长老比丘。答皆如是。乃至问罗云。何故色力不足。得好食饱不。答言世尊。食油得力食酥有色。食麻籸菜无色无力问六群比丘得好食不。答言世尊。我得白米饭好羹酥酪种种好食。皆是姊妹信心恩力。佛言。上座是谁。答言。尊者舍利弗。佛问舍利弗。汝实尔不。答言。实尔。世尊。佛言。此非法食。汝云何看是扰乱比丘僧而入舍心。舍利弗言。若世尊言。是非法食者。若一劫若过一劫不可得消。于是即取鸟翮擿而吐之。佛言。呼六群比丘尼来。来已问言汝实尔不。答言实尔。佛言。此是恶事。汝云何知众利回与一众。从今已后不听。乃至。已闻者当重闻。若比丘尼。知众利回与一众波夜提。比丘尼者如上说。知者。若自知若从他闻。众者。比丘众比丘尼众。利者。八种时药夜分药七日药终身药随身物重物不净物净不净物回者。选物向处。已定而回与余众。波夜提。波夜提者如上说。若人来问。我欲布施当施何处。应言随汝心所乐处施。若言何处功德大。当言施僧。若问何处有好持戒僧。当言都无犯戒僧。若言何处有比丘比丘尼自守少事坐禅诵经不大游行恒使我得见此物。得语言与某甲。若比丘尼。知物向僧回向已。尼萨耆波夜提。若回向余人波夜提。众回向余众波夜提。眷属回向眷属亦波夜提。一人物回向一人越毗尼罪。比丘回众物与余众越比尼罪。是故世尊说

  教诫隐处痈　　离宿不游行
  安居后嫌责　　安居已后来
  隔墙弃不净　　草水回向僧
  十四跋渠竟

比丘同戒七十。不同戒七十一。百四十一波夜提修多罗说竟

明八提舍尼法初

佛住舍卫城。尔时佛告大爱道。如来一时在舍卫城。时六群比丘尼。酥市乞酥。油市乞油。蜜市乞蜜。石蜜市乞石蜜。肉市乞肉。鱼市乞鱼。乳市乞乳。酪市乞酪。而食为世人所讥。云何沙门瞿昙称叹少欲毁呰多欲。如比丘缘中广说。瞿昙弥比丘尼亦应如是学。瞿昙弥。我一时住迦维罗卫释氏精舍。听病比丘尼索好食。佛告大爱道瞿昙弥。依止舍卫城比丘尼皆悉令集。乃至已闻者当重闻。若比丘尼不病为身白衣家乞酥。若使人乞。若啖若食。是比丘尼应向余比丘尼悔过。如是言。阿梨耶。我堕可诃法。此法悔过。是波罗提提舍尼法。如是二油三蜜四石蜜五乳六酪七鱼八肉。为身者。自为向身。病者世尊说无罪。云何病。老羸病服吐下药刺头出血如是比病。家者。四种姓家。酥者。牛酥水牛酥羊酥。乞者若自乞若使人乞。若啖若食者。是比丘尼应向余比丘尼悔过言。阿梨耶。我堕可诃法。此法悔过。前人应问。汝见此罪不。答言见。汝莫更作我顶戴持。波罗提提舍尼者。此罪应发露。是名悔过。若比丘尼热病。须酥者得乞。不得到不信家乞。当至有信家。若乞食时见量酥人言。长寿无病。答言。阿梨耶欲得何物。答言乞食。主人言。我无食正有酥。须酥者与。得取满钵。亦得劝与余人。量油亦得如是。若风病起亦得乞油。不得从压油家索。应从有信家索。若乞食见量油人。当言无病长寿。言阿梨耶。欲须何物。答言乞食。我无食正有油。须者当与。得取满钵无罪。当时亦得劝与伴如是蜜。若水病时得乞蜜。不得至采蜜家索。当到有信家乞。乃至得劝与伴如是石蜜。若病。医言应服石蜜。得乞石蜜。不得至石蜜家乞。当到有信家。若乞食时。见称石蜜人。乃至得劝与伴。若病。医言当服乳。得乞乳。若乞食时见放牛家[穀-禾+牛]乳。应言长寿无病。言阿梨耶。欲得何物。言我乞食。答言我无食正有乳。须者得取。若索酪浆。言无有酪浆正有乳得取。若病。医言当须酪得乞酪。若乞食时见量酪人语言。长寿无病。问言阿梨耶。欲得何物。答言我乞食。若言我无食正有酪得取。亦得劝与伴。若乞酪下清汁。与酪者得取。若比丘尼服吐下药。医言当须鱼汁得乞。若乞食时乞酪浆得鱼者得取。若刺头出血。医言须肉得乞。不得至屠儿家乞。当诣有信家乞。若乞食时得索菜汁。若言无菜汁正有肉汁。须者得取。若自知我某时常病发。尔时药必难得。得预乞无罪。若不病时乞病时食越比尼罪。病时乞不病时食无罪。病时乞病时食无罪。不病时乞不病时食波罗提提舍尼。不随病煮随病食无罪。随病煮不随病食越比尼罪。随病煮随病食无罪。不随病煮不随病食。出家人仰他活命无罪。是故世尊说。酥油蜜石蜜乳酪肉鱼是名八。比丘尼波罗提提舍尼法竟。众学法广说如比丘中。唯除六群比丘尼生草上水中大小便。余者尽同。七灭诤法。现前比尼。忆念比尼。不痴比尼。自言比尼。觅罪相比尼。多觅比尼。布草比尼。法随顺法如上比丘中广说。比丘尼波罗提木叉分别竟

明杂跋渠初　坐法者

佛住舍卫城。尔时比丘尼初夜后夜加趺而坐。时有蛇来入疮门中。诸比丘尼语大爱道。大爱道以是因缘往白世尊。佛言。应与某甲药。蛇不死而还出。即与药而出。佛言。汝云何加趺而坐。从今已后不听。坐法者当屈一脚以一脚跟掩疮门。若比丘尼加趺坐越比尼罪

簟席法者。佛住舍卫城。尔时比丘尼敷簟席缝衣。竹篾伤小便道血出。诸比丘尼以是因缘往白世尊。佛言。从今日后不听比丘尼坐竹席。若缝衣时。若在讲堂温室。巨摩涂地已缝衣。若无者当敷着床上若膝上缝。若于竹簟席上坐越比尼罪。是名席法

佛住舍卫城。尔时偷兰难陀与众多女人。到阿耆罗河脱衣洗浴。比丘尼先出。取女人庄严腰物缠腰已。语女人言看我好不。诸女人言。我食欲人缠腰使细。欲令夫主爱念。阿梨耶。用是何为。比丘尼闻已以。是事具白大爱道。乃至答言实尔。世尊。佛言。此是恶事。从今已后。不听比丘尼缠腰。若用女人缠腰物缠腰越比尼罪。若有痈疮缠腰无罪

佛住舍卫城。尔时偷兰难陀比丘尼共众多女人。到阿耆罗河边。脱衣放一处入水洗浴。先出岸上着女人袯衣。语诸女人言。看我宜着不。女人言。我是俗人着此已。欲令夫主爱念。汝用着是为。诸比丘尼以是因缘往白世尊。乃至答言实尔。佛言。从今日后。不听着袯衣。袯衣者。珂贝琉璃真珠玉金银摩尼如是比。庄严阴衣不听着。下至结缕作阴衣相。越比尼罪。若阴上有痈疮裹者无罪。是名袯衣。佛住舍卫城。乃至洗浴。先出着女人庄严服。诸比丘尼以是因缘往白世尊乃至答言实尔。佛言。从今日后。不听着女人庄饰服。女人服者。头上光鍱额耳镮铃璎珞指镮臂钏脚钏如是比。一切女人严饰服不听着。若著者越比尼罪。若身有痈疮。以药涂缠无罪。是名女人严饰服

佛住舍卫城。尔时比丘尼度释种女摩罗女梨车女大富家女。合严饰服而度出家。时诸贫家有女出门。及节会日行来皆从借赁。为世人所讥。此赁衣人非出家法。诸比丘尼以是因缘往白世尊。乃至答言实尔。佛言从今日后。不听合女人严饰服度出家。当令舍已而度。舍者若女人来欲出家者。应令舍俗人严身具。若作是念。某时或谷贵乞食难得。或老病当须汤药。女人少能得物。当置人家。若女人持俗严饰服来。合度出家者越比尼罪。是名合严饰服出家

佛住舍卫城。尔时释种女摩罗女梨车女贵人女。将使人出家。使人端正。令与外人交通以自活命。为世人所讥。此非出家人。是淫女耳。诸比丘尼以是因缘往白世尊。乃至答言实尔。佛言。汝云何畜。淫女以自活命。从今日后。不听畜淫女活命。若畜者越比尼罪。是名淫女。佛住舍卫城。尔时世尊制戒。不听畜淫女。尔时比丘尼便私畜园民女。于外淫荡以自活命。为世人所讥。此非出家法。是淫女耳。比丘尼以是因缘往白世尊。乃至答言实尔。佛言。从今日后。不听私畜园民女。使人女作淫女以自活命。若畜者越比尼罪。是名园民女。佛住舍卫城。尔时有年少比丘尼。端正乳出。人见皆笑。诸比丘尼以是因缘往白佛。乃至答言实尔。佛言。从今日后。当作僧祇支。作法者如上说。应先着覆乳衣然后着余衣。若不畜僧祇支越比尼罪。有而不着亦越比尼罪。是名僧祇支法

佛住毗舍离。如跋陀罗比丘尼缘中广说。佛言。不听裸身浴。当用浴衣。不听裸形入河若池水中浴。当着雨衣。若裸浴越比尼罪。若避隐处无人处裸浴无罪。是名浴衣法

  坐法并竹席　　缠腰覆袯衣
  着俗严饰具　　合严饰具度
  使人园民女　　僧祇支浴衣
  杂跋渠初竟

佛住舍卫城。尔时比丘尼住处。与俗人隔壁。比丘尼欲心起自手拍阴。时丈夫闻声。即语妇人言。此是何声。答言。不知何故作此声耶。其丈夫言。此出家人修梵行欲心起不能自制拍阴声耳。诸比丘尼闻已以是因缘往白。乃至佛言。汝实尔不。答言实尔。佛言。从今已后。不听拍阴。拍者。手拍若拘钵拍若键镃拍。以歇欲心者越比尼罪。是名手拍

佛住舍卫城。尔时比丘尼欲心起。作胡胶身生缚着。床脚后失火。恐烧床褥故出之。时俗人看火起。何处被烧何处不被烧。见已嫌诃。云何出家人作此恶事。诸比丘尼以是因缘往白。乃至答言实尔。佛言。从今日后。不听作胡胶形。胡胶形者。若胡胶作若铜铅锡白镴若牙若蜡蜜。如是比作身生。以歇欲心者。偷兰遮。是名胡胶形

佛住舍卫城。尔时大爱道往至佛所。头面礼足却住一面。时大爱道白佛言。世尊女人形臭得听洗不。佛言得洗。时比丘尼洗外内犹故臭。以是因缘往白。乃至言得洗内不。佛言得洗。洗法者得齐一指节。不得令过。若过洗以。歇欲心者偷兰遮是名洗法

佛住舍卫城。尔时比丘尼有月期污床褥。大爱道往诣佛所白佛言。世尊。得作月期不净衣不。佛言得。当持故布作。不得坚物作。又不得深内作淫欲想。当软物障小便道。若用坚物深内。以歇欲心者。偷兰遮。是名月期衣法

佛住舍卫城。尔时比丘尼往女人洗浴处浣月期衣。女人嫌言。是沙门尼污此水赤乃如是。诸比丘尼以是因缘往白。乃至佛言。从今日后。不听女人洗浴处浣月期衣。若浣者越比尼罪。是名女人浣月期衣法

佛住舍卫城。尔时世尊制戒。不听女人洗处浣月期衣。便往男子洗处浣。乃至若比丘尼往男子洗处浣者越比尼罪。是名男子法。佛住舍卫城。尔时世尊制戒不听男子洗浴处浣月期衣。时比丘尼到客浣衣处浣。乃至不听客浣衣处浣月期衣。当取盆余瓦器中于屏处浣。浣时不得持水洒地。当着水渎中无人见处。衣当晒令干。后须时当用。若比丘尼。于客浣衣处浣月期衣者越比尼罪。是名客浣衣处

佛住舍卫城。尔时比丘尼欲心起。以小便道承悬注水。即失不净心生疑悔。诸比丘尼语大爱道。大爱道往白世尊。佛言。从今日后。不听以小便道承悬注。悬注者水悬注下。若比丘尼于悬注水中浴时。当持衣物遮。若以小便道承悬注水屋檐漏水。以歇欲心者偷兰遮。若于悬注水屋檐漏浴者。不得以身向水当背上。若以身向水以歇欲心者偷兰遮。是名悬注水

佛住舍卫城。尔时比丘尼于急流水中浴。欲心生逆水而行失不净。诸比丘尼以是因缘往白。乃至从今日后。不听于急流水中逆水触小便道。流水者。若山水若急流水。若向流逆水以歇欲心者偷兰遮。若于急流水洗时。不得向流当背。若向流者越比尼罪。是名流水。佛住舍卫城。尔时比丘尼种种触身出精。或芜菁根葱根。种种诸根内小便道中出精。比丘尼以是因缘往白。乃至从今已后不听若比丘尼用芜菁根葱根内小便道中出精。以歇欲心者偷兰遮。是名根

  拍阴胡胶形　　齐节月期衣
  女人洗处浣　　男处浣亦然
  客浣衣处浣　　悬注及急流
  种种根出精　　第二跋渠竟

佛住舍卫城。尔时诸比丘集。不知作举羯磨。令比丘尼作已。比丘尼心生疑悔。语大爱道。大爱道即以是事往白世尊。佛言。此上尊众汝云何与作举羯磨。从今已后不听与比丘作举羯磨。若比丘中都无能者。得授使诵。作羯磨时若不得者遥授无罪。若比丘尼。与比丘作羯磨者越比尼罪。比丘得与比丘尼作羯磨无罪。是名羯磨

佛住比舍离。尔时跋陀罗比丘尼。着憍奢耶衣到亲里家。道路值暴雨。如视水精举见身体。众人围绕欲看。于是蹲地。依止弟子在边而障。诸比丘尼以是因缘往白。乃至答言。实尔世尊。佛言。从今已后。比丘尼不听着憍舍耶衣。憍奢耶者有二种。一者生二者作。生者细丝。作者纺丝。着细丝憍奢耶越比尼。着纺丝越比尼心悔。比丘着无罪

佛住舍卫城。尔时偷兰难陀比丘尼大乳。着一僧祇支于阁上经行。俗人遥见自相谓言。看是似如水上浮瓠。诸比丘尼以是因缘往白。乃至佛言。从今日后。当作覆肩衣。覆肩衣者。襞叠拖覆肩上。若不作不着越比尼罪。不听比丘尼高处着一重僧祇支经行。若屏处着一重僧祇支无罪。是名僧祇支

佛住舍卫城。尔时释种女摩罗女梨车女贵胜家女出家善知庄严。有嫁女娶妇。皆借倩庄严。得好饮食。为世人所讥。此非出家人。是客庄严人耳。诸比丘尼以是因缘往白。乃至佛言。从今已后。不听庄严女人。庄严者。梳头庄眼粉面朱唇。着严饰服以自活命者越比尼罪。若有头痛眼痛得磨着药无罪。是名庄严法

佛住舍卫城。尔时释种女摩罗女大姓家女出家。种优钵罗华取而卖之。为世人之所讥。此非出家人。此是卖华女耳。诸比丘尼以是因缘往白世尊。乃至答言实尔。佛言。从今已后。不听种华卖以自活命。若比丘尼种优钵罗华以自活命者越比尼罪。为塔为供养佛故无罪。是名优钵罗华

佛住舍卫城。尔时比丘尼种须曼那华。乃至为塔供养佛故无罪

佛住舍卫城。尔时世尊制戒。不听种华树。尔时释种女摩罗女出家。结华鬘卖以自活命。为世人所讥。此非出家人。此是卖华鬘女耳。诸比丘尼以是因缘往白。乃至佛言。从今日后。不听结华鬘。鬘者。优钵罗华摩梨华须曼那华。结作鬘卖活命者越比尼罪。若佛生时大会菩提大会转法轮大会阿难大会罗睺罗大会五年大会。檀越言阿梨耶佐我结鬘尔时得结种种鬘无罪。是名结鬘法

佛住舍卫城。尔时释种女摩罗女梨车女出家。纺缕而卖为世人所嫌。此非出家人。此是卖缕人也。诸比丘尼以是因缘往白。乃至佛言。从今已后。不听纺缕。纺缕者。劫贝缕刍摩缕憍舍耶缕舍那麻缕纺缕。卖活命者越比尼罪。若欲作漉水囊腰带纺者无罪。是名纺缕法

佛住舍卫城。尔时须提那死妇出家。其叔常欲使罢道。时比丘尼入聚落乞食。叔遇见之即欲捉取。便走入一大家内。语妇人言。异事几当坏我梵行。问何故。答言。叔欲罢我道。妇人言。莫恐我当相护。比丘尼言。我欲向和上边去。妇人言。汝欲去者当着俗服假异摽相。乃可得脱。即着臂钏耳镮俗人服饰。又将四五人侍从而去。其叔于外见之念言。此非比丘尼。是俗人耳。到住处已诸比丘尼呵言。汝何故着此。答言。我叔欲取我。方便自护故假着此耳。诸比丘尼语大爱道。大爱道即以是事具白世尊。佛言。呼比丘尼来。来已佛问汝实尔不。答言实尔。佛言。汝云何坏威仪。从今已后。不听坏威仪。若决定坏威仪者非比丘尼。若方便自护故坏威仪越比尼罪。故名比丘尼。若比丘尼决定坏威仪者偷兰遮。若方便自护无罪

  羯磨憍舍耶　　僧祇支客严
  种花须曼那　　结鬘并纺缕
  坏威仪最后　　第三跋渠竟

佛住舍卫城。尔时偷兰难陀比丘尼乞食诣一大家。时有妇人堕胎。语言。为我弃之。答言不能。又请我当顾尔许物。即取以钵盛之而去。时大迦叶乞食恒作此念。最初得食。当施与若比丘比丘尼。见此比丘尼已语言。取钵来。即覆不示。又复更呼。亦复不示。大迦叶性有威风。厉声而唤。即战怖而示。见已言。咄汝何故作此恶法。时大迦叶语诸比丘尼。诸比丘尼。以是因缘往白世尊。乃至答言实尔。佛言。此是恶事非法。汝云何覆钵。从今日后不听覆钵。复不听露捉。得食已当覆。若见比丘时当举覆示之。若露持钵越比尼罪。见比丘不示亦越比尼罪。是名钵事

佛住舍卫城。尔时有大臣犯王法。其家财物尽应没官。王即遣人守护。时偷兰难陀比丘尼乞食次到其家。妇人语言。阿梨耶。我家有事犯王罪应至死。财物入官。我欲寄少宝物严饰之具。若我得脱当相顾直。我若死者即持相施。时比丘尼即与钵盛杂宝。覆已而去。时守门人见之问言。钵中何物而不示之。又复叱唤畏而示之。比丘尼闻已往白。乃至答言实尔。佛言。从今日后。不听覆钵宝物。若有犯官事未被收录。又未籍其财。尔时寄者得取。若王收摄又籍其财。应语言。世尊制戒不得受是。若言我与塔与僧施汝得取。得已不得覆上而去。当露持去。若有问者当言。塔物僧物我物。若听去者善。若不听者当还。是名覆钵法

佛住舍卫城。尔时比丘尼作厕。以物覆上。诸女人持死胎放中。后有贱人旃陀罗抒厕。见已言。是沙门尼自堕胎掷中。诸比丘尼以是因缘往白。乃至佛言。从今日后不听覆厕。当开口作。若闭口作者越比尼罪。是名厕法

佛住舍卫城。尔时释种女摩罗女于浴室中浴。时有年少入中坏其梵行。诸比丘尼语大爱道。乃至从今日后不听入浴室。若病者得房内然火油涂而揩。若比丘尼入浴室浴者。越比尼罪。是名浴室法

佛住舍卫城。尔时未制戒。比丘尼阿练若处聚落中未有住处。时五百比丘尼。大爱道为上首。于王园中住。诸释种女摩罗女年少端正。有诸年少初夜伺便欲捉比丘尼。见已乘空而去。中夜复来亦复如是。后夜复来。中有钝根。不时入定及睡眠者。不得即去。为所侵掠。大爱道以是事往白世尊。佛言。从今日后。不听比丘尼在阿练若处住。若四众集竟夜说法者得住。尔时不得在屏处。若比丘尼阿练若处住者越比尼罪。是名阿练若处。比丘受迦絺那衣非比丘尼。比丘尼受迦絺那衣非比丘。比丘舍非比丘尼。比丘尼舍非比丘。比丘阿提呵鲁阿那提诃鲁非比丘尼。比丘尼阿提诃鲁阿那提诃鲁非比丘

  覆钵并宝钵　　开厕入浴室
  阿练若处住　　比丘受迦絺
  非是比丘尼　　比丘舍迦絺
  非是比丘尼　　第四跋渠竟

食于比丘不净比丘尼净。比丘尼不净比丘净。比丘得使比丘尼授食。除金银及钱五生种火净。比丘尼得从比丘受食。除金银及钱火净五生种。有三因缘非比丘。何等三。心决定舍戒。有实事僧驱出。形转为女。是名三非比丘。应遣诣比丘尼精舍。不得共比丘尼同覆障应别。若后还得男根者。当还比丘僧中。故名具足。亦复本岁有三因缘非比丘尼。何等三。心决定坏威仪。有实事僧驱出。转形为男。如比丘中说。比丘尼无有作残食法。一坐足自恣食

佛住舍卫城阿耆罗河彼岸。请二部僧食。比丘比丘尼俱欲渡。比丘言。世尊制戒。不得共船载。比丘二人三人轻船而渡。渡尽比丘尼渡。渡已问岁数。日时已过。时大爱道失食饥羸。到世尊所头面作礼却住一面。佛知而故问。何故饥色。即以是事具白世尊。佛言。从今日后。上座八人。当次第如法。余者随到而坐。若五年大会多人集。比丘尼上座八人当次第坐。余者随意坐。若八人不随次第坐。越比尼罪。是故世尊说

  二众净不同　　三非比丘僧
  三非比丘尼　　无残八上座
  第五跋渠竟

比丘杂跋渠中。别住蒜伞盖。乘刀治革屣同床卧坐伎乐九事应出不说。余十三跋渠残比丘尼别。五杂跋渠威仪中。阿练若浴室厕屋缝衣簟应出不说。余尽同比丘尼。二部修多罗及学五百戒。世尊分别说戒序。八波罗夷。十九僧伽婆尸沙。三十尼萨耆波夜提。百四十一波夜提。八波罗提提舍尼。六十四众学。七止诤法。法随顺法偈在后。比丘尼比尼竟

摩诃僧祇律私记

中天竺昔时。暂有恶王御世。诸沙门避之四奔。三藏比丘星离。恶王既死更有善王。还请诸沙门还国供养。时巴连弗邑有五百僧。欲断事而无律师。又无律文无所承案。即遣人到祇洹精舍。写得律本于今传赏。法显于摩竭提国巴连弗邑阿育王塔南天王精舍。写得梵本还杨州。以晋义熙十二年岁在丙辰十一月。于斗场寺出之。至十四年二月末都讫。共禅师译梵本为秦焉。故记之。佛泥洹后。大迦叶集律藏为大师宗。具持八万法藏。大迦叶灭后。次尊者阿难亦具持八万法藏。次尊者末田地亦具持八万法藏。次尊者舍那婆斯亦具持八万法藏。次尊者优波崛多世尊记无相佛。如降魔因缘中说。而亦能具持八万法藏。于是遂有五部名生。初昙摩崛多别为一部。次弥沙塞别为一部。次迦叶维复为一部。次萨婆多。萨婆多者。晋言说一切有。所以名一切有者。自上诸部义宗各异。萨婆多者。言过去未来现在中阴各自有性。故名一切有。于是五部并立纷然竞起。各以自义为是。时阿育王言。我今何以测其是非。于是问僧佛法断事云何。皆言法应从多。王言若尔者。当行筹知何众多。于是行筹取本众筹者甚多。以众多故。故名摩诃僧祇。摩诃僧祇者大众名也佛说犯戒罪报轻重经

如是我闻。一时佛住王舍城迦兰陀竹园。尔时尊者目连。晡时从禅定觉。往至世尊所。头面礼足却住一面。时尊者大目连白佛言。世尊。意有所疑今欲请问。唯愿听许。佛告目连。听汝所问。当为汝说。目连即白佛言。世尊。若比丘比丘尼。无惭愧心轻慢佛语犯众学戒。如是犯波罗提提舍尼波夜提偷兰遮僧伽婆尸沙波罗夷。得几不饶益罪。唯愿解说。佛告目连。谛听谛听当为汝说。若比丘比丘尼。无惭无愧轻慢佛语犯众学戒。如四天王寿五百岁堕埿梨中。于人间数九百千岁。佛告目连。若无惭无愧轻慢佛语犯波罗提提舍尼。如三十三天寿千岁堕埿梨中。于人间数三亿六十千岁。佛告目连。无惭无愧轻慢佛语犯波夜提。如夜摩天寿二千岁堕埿梨中。于人间数二十亿四十千岁。佛告目连。无惭无愧轻慢佛语犯偷兰遮。如兜率天寿四千岁堕埿梨中。于人间数五十亿六十千岁。佛告目连。无惭无愧轻慢佛语犯僧伽婆尸沙。如不憍乐天寿八千岁堕埿梨中。于人间数二百三十亿四十千岁。佛告目连。无惭无愧轻慢佛语犯波罗夷。如他化自在天寿十六千岁堕埿梨中。于人间数九百二十一亿六十千岁。时尊者目连闻佛所说。欢喜奉行

尔时目连即说偈言

  因缘轻慢故　　命终堕恶道
  因缘修善者　　于此生天上
  缘斯修福业　　离恶得解脱
  不善观因缘　　身坏入恶道

摩诃僧祇律卷第四十


摩诃僧祇律大比丘戒本

    No. 1426 [cf. No. 1425]

摩诃僧祇律大比丘戒本

        东晋天竺三藏佛陀跋陀罗译

六念法

一者。当知日数月。一日二日。乃至十四日十五日。月大月小悉应知

二者。清旦当作施食法。今日得食施某甲某甲。于我不计意我当食。(如是三说)

三者。日日自忆若干腊数

四者。当忆念受持衣及净施者

五者。当念不别众食

六者。当念病不病

摩诃僧祇律波罗提木叉大比丘戒本。

大德僧听。冬时一月过。少一夜余有一夜三月在。老死至近佛法欲灭。诸大德。为得道故一心勤精进。所以者何。诸佛一心勤精进故得阿耨多罗三藐三菩提。何况余助道法。未受具戒者已出。僧今和合先作何事。(一人答言布萨说戒)诸大德不来。诸比丘说欲及清净。谁与比丘尼取欲

  合十指爪掌　　供养释师子
  我今欲说戒　　僧当一心听
  乃至小罪中　　心应大怖畏
  有罪一心悔　　后更莫复犯
  心马驰恶道　　放逸难禁制
  佛说切戒行　　亦如利辔勒
  佛口说教诫　　善者能信受
  是人马调顺　　能破烦恼军
  若不受教敕　　亦不爱乐戒
  是人马不调　　没在烦恼军
  若人守护戒　　如[犛-未+牙]牛爱尾
  系心不放逸　　亦如猴着锁
  日夜常精进　　求实智慧故
  是人佛法中　　能得清净命

大德僧听。今十五日布萨说波罗提木叉。若僧时到。僧忍听僧一心共作布萨说波罗提木叉。如是白

诸大德今布萨说波罗提木叉。僧一心善听。有罪者应发露无罪者默然。默然故当知诸大德清净。如一一比丘问答。是比丘众中三唱。若比丘如是比丘众中三唱。忆有罪应发露。不发露得故妄语罪诸大德。故妄语罪。佛说障道法。是故比丘欲求清净故。忆有罪应发露。发露则安隐不发露罪益深

诸大德。已说波罗提木叉序。今问诸大德。是中清净不。是中清净不。是中清净不。诸大德。是中清净默然故。是事如是持

诸大德。是四波罗夷法。半月半月次说波罗提木叉

若比丘。于和合僧中受具足戒。不还戒戒羸不出。相行淫法乃至共畜生。是比丘波罗夷不共住

佛在毗舍离城。成佛五年冬分第五半月十二日。食后东向坐一人半影。为长老耶奢伽兰陀子制此戒。已制当随顺行。是名随顺法

若比丘。于聚落中若空地。不与取随盗物。王或捉或杀或缚或摈出。咄男子。汝是贼汝愚痴。比丘如是不与取。是比丘波罗夷不共住

佛在王舍城。成佛六年冬分第二半月十日。食后东向坐。两人半影。为瓦师子长老达腻伽因洴沙王及粪扫衣比丘制此戒。已制当随顺行。是名随顺法

若比丘。自手夺人命。求持刀与杀者。教死叹死。咄人用恶活为死胜生。作是意作是想。方便叹誉死快。因是死非余者。是比丘波罗夷不共住

佛在毗舍离城。成佛六年冬分第三半月九日。食前北向坐。一人半影。为众多看病比丘因鹿杖外道制此戒。已制当随顺行。是名随顺法

若比丘。未知未见。自称得过人圣法知见殊胜。我如是知如是见。彼于后时若检校若不检校犯罪。欲求清净故作是言。长老。我不知言知不见言见。虚诳不实语除增上慢。是比丘波罗夷不共住

佛在舍卫国。成佛六年冬分第四半月十三日。食后东向坐。三人半影。为聚落中众多比丘及增上慢比丘制此戒。已制当随顺行。是名随顺法

诸大德。已说四波罗夷法。今问诸大德。是中清净不。是中清净不。是中清净不

诸大德。是中清净默然故。是事如是持(四事竟)

诸大德。是十三僧伽婆尸沙法半月半月次说波罗提木叉

若比丘。故出精。除梦中僧伽婆尸沙

若比丘。淫欲变心。与女人身身相摩触。若捉手若捉发及余身分。摩触受乐者。僧伽婆尸沙

若比丘。淫欲变心。与女人说作丑恶语。随顺淫欲法。如年少男女。僧伽婆尸沙

若比丘。淫欲变心。于女人前叹自供养己身。姊妹如我沙门持净戒行善法修梵行。以淫欲法供养第一。僧伽婆尸沙

若比丘。受使行和合男女。若娶妇若私通。乃至须臾。僧伽婆尸沙

若比丘。自乞作房无主为身。应量作。长十二修伽陀磔手内。广七磔手。应将诸比丘示作房处无难处非妨处。若难处妨处自乞作房无主为身。亦不将诸比丘示作房处。而过量作。僧伽婆尸沙

若比丘。作大房有主为身。应将诸比丘指授处无难处非妨处。若难处妨处有主为身。亦不将诸比丘指授处者。僧伽婆尸沙

若比丘。嗔恨不喜故。于清净无罪比丘。以无根波罗夷法谤。欲破彼比丘净行。此于后时若检校若不检校。便言是事无根。我住嗔恨故说。僧伽婆尸沙

若比丘。嗔恨不喜故。于异分中小小事非波罗夷。以波罗夷法谤。欲坏彼比丘梵行。此于后时若检校若不检校。便言我以异分中小小事。住嗔恨故说。僧伽婆尸沙

若比丘。为破和合僧故。勤方便执破僧事故共诤。诸比丘应谏言。长老。莫为破和合僧故勤方便执破僧事故共诤。当与僧同事。何以故。僧和合欢喜不诤。共一学如水乳合。如法说法照明安乐住。如是谏时舍者善。若不舍应第二第三谏。舍是事善。若不舍僧伽婆尸沙

若比丘。同意相助。若一若二若众多。同语同见欲破和合僧。诸比丘谏时。是同意比丘言。长老。莫说是比丘好恶事。何以故。是法语比丘律语比丘。是比丘所说所见。欲忍可事。我等亦欲忍可。是比丘知说。非不知说。诸比丘应谏言。长老。莫作是语。是法语比丘律语比丘。何以故。此非法语比丘律语比丘。诸长老。莫助破僧事。当乐助和合僧。何以故。僧和合欢喜不诤。共一学如水乳合。如法说法照明安乐住。如是谏时。舍者善。若不舍应第二第三谏。舍是事善。若不舍僧伽婆尸沙

若比丘自用戾语。诸比丘共法中如法如律教时。便自用意言。长老。汝莫语我好恶事。我亦不语汝好恶事诸比丘应谏言。长老。诸比丘共法中如法如律教。时汝莫不受。汝亦应如法如律教诸比丘。何以故。如来弟子众展转相教展转相谏。共罪中出故善法得增长。如是谏时舍者善。若不舍应第二第三谏。舍是事善。若不舍僧伽婆尸沙

若比丘。依城邑聚落中住。污他家行恶行。污他家亦见亦闻。行恶行亦见亦闻。诸比丘应谏言长老。汝等污他家行恶行。污他家亦见亦闻。行恶行亦见亦闻。汝等出去不应此中住。是比丘言。僧随爱随嗔随怖随痴。何以故。有如是同罪比丘。有驱者有不驱者。诸比丘应谏言。长老。如是莫言。僧随爱随嗔随怖随痴。有同罪比丘有驱者有不驱者。何以故。僧不随爱不随嗔不随怖不随痴。长老。汝等污他家行恶行。污他家亦见亦闻。行恶行亦见亦闻汝等出去莫此中住。如是谏时舍者善。若不舍应第二第三谏。舍是事善。若不舍僧伽婆尸沙

诸大德。以说十三僧伽婆尸沙法。九初罪四乃至三谏。若比丘犯一一罪。随知覆藏时应与波利婆沙。波利婆沙已应僧中六日六夜行摩那埵。行摩那埵已应二十僧中出罪。若少一人不满二十。是比丘不得出罪。诸比丘应被诃。是事法尔。今问诸大德。是中清净不。是中清净不。是中清净不。诸大德。是中清净默然故。是事如是持(十三事竟)

诸大德。是二不定法。半月半月次说波罗提木叉

若比丘。与女人独屏覆处可淫处坐。可信优婆夷。于三法中一一如法说。若波罗夷。若僧伽婆尸沙。若波夜提。比丘自言。我坐是处于三法中一一如法治。若波罗夷。若僧伽婆尸沙。若波夜提。应随可信优婆夷所说法治。彼比丘是初不定法

若比丘。与女人独露现处不可淫处坐。可信优婆夷。于二法中一一如法说。若僧伽婆尸沙。若波夜提。比丘自言。我坐是处于二法中一一如法治。若僧伽婆尸沙。若波夜提。应随可信优婆夷所说法治。彼比丘是二不定法。诸大德。已说二不定法。今问诸大德。是中清净不。是中清净不。是中清净不

诸大德。是中清净默然故。是事如是持。(二不定竟)

诸大德。是三十尼萨耆波夜提法半月。半月次说波罗提木叉

若比丘。衣竟。迦絺那衣已舍。若得长衣十日畜。若过者尼萨耆波夜提

若比丘。衣竟。迦絺那衣已舍。三衣中若离一一衣余处宿。除僧羯磨。尼萨耆波夜提

若比丘。衣竟。迦絺那衣已舍。若得非时衣。比丘若须应取疾作衣受。若不足有望处。为满故听一月畜。若过者足不足尼萨耆波夜提

若比丘。取非亲里比丘尼衣。除贸易尼萨耆波夜提

若比丘。使非亲里比丘尼浣故衣。若染若打尼萨耆波夜提

若比丘。从非亲里居士居士妇乞衣。除余时尼萨耆波夜提。余时者失衣时

若比丘。失衣时。得从非亲里居士居士妇乞衣。若自恣与得取上下衣。若过受尼萨耆波夜提

若居士居士妇。为比丘办衣价言。我办如是衣价。买如是衣与某甲比丘。是比丘先不请。为好故便往劝言。善哉居士。如是衣价。买如是色衣与我。若得衣尼萨耆波夜提

若比丘。居士居士妇。各办如是衣价言。我等办如是衣价。买如是衣与某甲比丘。是比丘先不请为好故便往劝言。善哉居士。各办如是衣价。共作一如是色衣与我。若得衣尼萨耆波夜提

为比丘故若王大臣遣使送衣直与是比丘。使到言。如是衣直若王大臣送尊者应受。比丘言。我不得受是衣直。送净衣来者应受。使言尊者有执事人不。比丘若须衣。应示使若园民若优婆塞言。是人能为比丘执事。使到劝言。善哉执事。如是衣价买如是净衣与某甲比丘。是比丘来取衣时与。使劝喻已还到比丘所言。尊者所示执事人。我已劝作已。须衣时往取。比丘若须衣。应到执事所言。我须衣我须衣。第二第三亦如是说。若得衣者好。若不得应第四第五第六在执事人前默然立。得衣者善。若不得过是求。若得衣尼萨耆波夜提。若不得随衣直来处。若自去若遣使言。汝为某甲比丘送衣直。是比丘于汝衣直竟不得用。汝自知莫令失。是事法尔(十事)

若比丘。纯黑羺羊毛作新敷具。尼萨耆波夜提。

若比丘。作新敷具。应用二分纯黑羺羊毛。三分白四分下。若过分尼萨耆波夜提

若比丘。憍奢耶杂纯黑羺羊毛作新敷具。尼萨耆波夜提

若比丘。作新敷具。应至六年持若减六年故。敷具若舍若不舍作新敷具。除僧羯磨。尼萨耆波夜提

若比丘。作新敷具毡尼师坛。应着故敷具毡方一修伽陀磔手。为坏色故。若不著作新敷具毡尼师坛。尼萨耆波夜提

若比丘。道行得羊毛。若须得取至三由旬。若过者尼萨耆波夜提。若比丘。使非亲里比丘尼浣染擘羊毛。尼萨耆波夜提

若比丘。自手捉生色似色。若使人捉举染著者。尼萨耆波夜提

若比丘。种种卖买。尼萨耆波夜提

若比丘。种种贩卖生色似色。尼萨耆波夜提(二十竟)

若比丘。长钵得十日畜。若过者尼萨耆波夜提

若比丘。所用钵减五缀。更乞新钵为好故。尼萨耆波夜提。是钵应众中舍。众中最下钵应与。作是言。长老。是钵受持破乃止。是事法尔

若比丘。病应服酥油蜜石蜜生酥及脂。一受七日服。若过七日。有残不舍而服。尼萨耆波夜提

若比丘。与比丘衣已。后嗔恨不喜。若自夺若使人夺得衣者。尼萨耆波夜提

若比丘。春残一月在。当求雨浴衣。半月在当作成受用。若未至求雨浴衣。作成受用者。尼萨耆波夜提

若比丘。自行乞缕。使非亲里织作衣。尼萨耆波夜提

若居士居士妇使织师为比丘织作衣。是比丘先不请。为好故便往劝织师言。善哉居士。此衣为我作。汝当好织令致长广。当与汝钱直若食直。如是劝得衣者。尼萨耆波夜提

若比丘。十日未至自恣得急施衣。须者得取畜至衣时。若过时畜尼萨耆波夜提

夏三月未至。夏末月比丘在阿练若处住。有疑恐怖有因缘事。三衣中若一一衣得寄家内离六宿。若过者除僧羯磨。尼萨耆波夜提

若比丘。知物向僧自回向已。尼萨耆波夜提(三十事竟)

诸大德。已说三十尼萨耆波夜提法。今问诸大德。是中清净不。是中清净不。是中清净不。诸大德。是中清净默然故。是事如是持

诸大德。是九十二波夜提法。半月半月次说波罗提木叉

若比丘。知而故妄语波夜提

若比丘。种类形相语波夜提

若比丘。两舌语波夜提

若比丘。知僧如法如律灭诤已。更发起言。此羯磨不了当更作。作是因缘不异波夜提

若比丘。为女人说法过五六语。除有智男子。波夜提

若比丘。教未受具戒人说句法。波夜提

若比丘。自称向未受具戒人说得过人法。我如是知如是见。说实者波夜提

若比丘。知比丘粗罪。向未受具戒人说。除僧羯磨波夜提

若比丘。僧应分物。先听与而后遮言。长老。汝亲厚意回僧物与人。波夜提

若比丘僧。半月诵波罗提木叉经时作是言。长老。用诵是杂碎戒为使诸比丘生疑悔作是轻呵戒因缘不异。波夜提(十事竟)

若比丘。坏种子破鬼村波夜提

若比丘。异语恼他波夜提

若比丘。嫌责语波夜提

若比丘。僧住处露地敷卧床坐床褥枕。若自敷若使人敷。去时不自举不使人举。波夜提

若比丘。僧房内敷床褥。若自敷若使人敷。去时不自举不使人举。波夜提

若比丘。嗔恨不喜。僧房内牵比丘出。若自牵若使人牵。下至言汝出去。波夜提

若比丘。知僧房内比丘先敷床褥。后来敷欲扰乱令去。作是因缘不异。波夜提

若比丘。僧房阁屋上敷尖脚床。若坐若卧。波夜提

若比丘。知水有虫浇草泥。若使人浇。波夜提

若比丘。经营作大房施户牖。齐再三覆。当于少草地中住教。若过者。波夜提(二十竟)

若比丘。僧不差而教诫比丘尼。波夜提

若比丘。僧差教诫比丘尼。从日没乃至明相未出。波夜提

若比丘。往尼住处教诫。不白善比丘。除余时波夜提。余时者病时

若比丘语比丘言。长老。为食故教诫比丘尼。波夜提

若比丘。共一比丘尼空静处坐。波夜提

若比丘。与比丘尼期共道行。下至聚落间。除疑怖畏估客伴时波夜提

若比丘。与比丘尼期共载船。上水下水。除直渡波夜提

若比丘。与非亲里比丘尼衣。除贸易波夜提

若比丘。与非亲里比丘尼作衣。波夜提

若比丘。知比丘尼赞叹食。除旧檀越波夜提(三十事竟)

若比丘。施一食处。不病比丘过一食波夜提

若比丘。处处食。除病时衣时波夜提

若比丘。食已足离坐处。不作残食法。食者波夜提

若比丘。知彼比丘食已足离坐处不作残食法。欲恼故劝言。长老食此食。食者波夜提

若比丘。不与不受着口中。除水及杨枝波夜提

若比丘。非时食波夜提

若比丘。停食食波夜提

若比丘。往白衣家自恣与饼糗。得受两三钵出外共不病比丘食。若过受不共食波夜提

若比丘。不病为身乞酥油蜜石蜜乳酪鱼肉。如是乞美食食者波夜提

若比丘。别众食。除余时波夜提。余时者。病时衣时行时船上时大众会时外道施食时(四十事竟)

若比丘。无病自为身然草木牛屎。若自然若使人然。除因缘波夜提

若比丘。与未受具戒人同屋。过三宿波夜提

若比丘。与羯磨欲已。后嗔恨不喜作是言。我不与欲不好与。此羯磨不成就我不与此欲。波夜提

若比丘语比丘言。长老。共汝入聚落。到彼当与汝食。若自与若使人与。后欲驱故便言。汝去我共汝住不乐。我独住乐。作是因缘不异波夜提

若比丘作是语长老。我知世尊说障道法。习此法不能障道诸比丘应谏言。长老。汝莫谤世尊。谤世尊者不善。世尊不作是语世尊说障道法实障道。汝舍此恶事。如是谏时。若坚持不舍。应第二第三谏。舍者善。若不舍。僧应作举羯磨。是比丘波夜提

若比丘。知比丘恶见不舍。僧如法如律作举羯磨。未作如法如律。共食共同屋住波夜提

若沙弥作是言。如来说淫欲是障道法。我知习淫欲不能障道。诸比丘应谏言。汝沙弥莫谤世尊。谤世尊者不善。世尊不作是语。世尊说淫欲实障道法汝舍此恶见。如是谏时。若坚持不舍。应第二第三谏。舍者善。若不舍应驱出言。汝从今已后。不应言佛是我师。亦不得共比丘三宿。汝去不得此中住若比丘知沙弥恶见不舍驱出。未作如法。诱唤畜养共食共住波夜提

若比丘。得新衣当三种坏色。若一一坏色青黑木兰。若不坏色受用者。波夜提

若比丘。僧住处内宝若名宝。若自取若使人取。除内取为主来求者与。波夜提

若比丘减半月浴。除余时波夜提。余时者。春后一月半。夏初一月。此二月半。是热时病时风时雨时作时行时(五十事竟)

若比丘。知水有虫饮者波夜提

若比丘。自手与无衣出家男女食波夜提

若比丘。知食家淫处坐波夜提

若比丘。知食家屏处坐波夜提

若比丘。看军发行波夜提

若比丘。有因缘事得到军中三宿若过者波夜提

若比丘。有因缘事得到军中三宿。若看军发行牙旗斗势波夜提

若比丘。嗔恨不喜打比丘波夜提

若比丘。嗔恨不喜掌刀拟比丘波夜提

若比丘。知比丘粗罪覆藏者波夜提(六十事竟)

若比丘。故夺畜生命波夜提

若比丘。故令他比丘起疑悔须臾不乐。作是因缘不异波夜提

若比丘。净施五众衣。后不舍而受用者波夜提

若比丘。戏笑藏比丘衣钵尼师坛针筒。若使人藏波夜提

若比丘。恐怖比丘波夜提

若比丘。水中戏波夜提

若比丘。以指相指波夜提

若比丘。与女人期共道行。下至聚落中波夜提

若比丘。与女人同屋宿波夜提

若比丘。与女人独屏处坐波夜提(七十事竟)

若比丘。知人不满二十。与受具足戒。是人不名受具足。诸比丘应被呵。波夜提

若比丘。知贼众期共道行。下至聚落中波夜提

若比丘。自手掘地若使人掘。若指授语掘是地。波夜提

若比丘。四月别请应受。过受波夜提。除更请长请

若比丘语比丘言。长老。当学莫犯五众罪。是比丘言。我不随汝语。若见余长老寂根多闻持法深解。我当从咨问。彼有所说我当受行。除余时波夜提。余时者。比丘欲得法利应学。亦应问余比丘

若比丘。饮酒咽咽波夜提

若比丘。轻他比丘波夜提

若比丘。诸比丘诤讼时默然立听。彼有所说我当忆持。作是因缘不异波夜提

若比丘。僧断事不与欲。出去不白。波夜提

若比丘。阿兰若处住。非时入聚落。不白善比丘。除急事波夜提(八十事竟)

若比丘同食处。食前食后不白善比丘。行至余处。除衣时波夜提

若比丘入王宫。夫人未藏宝。下至过门限。波夜提

若比丘。骨牙角作针筒。破已波夜提

若比丘。作床脚应高佛八指。除入梐。若过截已波夜提

若比丘。兜罗绵[袖-由+宁]褥。若坐若卧出已波夜提

若比丘。作尼师坛应量作。长二修伽陀磔手。广一磔手半。更益一磔手。若过截已波夜提

若比丘。作覆疮衣应长四修伽陀磔手广二磔手若过截已波夜提

若比丘。作雨浴衣应长六修伽陀磔手广二磔手半。若过截已波夜提

若比丘。与如来衣量等作衣。若过截已波夜提。如来衣。长九修伽陀磔手。广六磔手

若比丘。嗔恨不喜。以无根僧伽婆尸沙法谤。波夜提

若比丘。知物向僧回与余人。波夜提

若比丘。僧半月说波罗提木叉经时作是言。长老。我今始知是法入修多罗半月波罗提木叉中说。诸比丘知彼比丘本若二若三。说波罗提木叉经中坐。况复多。彼比丘不以不知故无罪。随所犯罪一一如法治。应呵责言。长老。汝失善利。半月说波罗提木叉经时。汝不尊重。不一心念。不摄耳听法。呵已波夜提(九十二事竟)

诸大德。已说九十二波夜提法。今问诸大德。是中清净不。是中清净不。是中清净不

诸大德。是中清净默然故。是事如是持

诸大德。是四波罗提提舍尼法。半月半月次说波罗提木叉

若比丘。阿练若处住。先不语不病。外不受于内受。若啖若食应向余比丘悔过言。长老。我堕可呵法。此法悔过

若比丘。不病在白衣家内。从非亲里比丘尼边受食。若啖若食应向余比丘悔过言。长老。我堕可呵法。此法悔过

若比丘。受白衣家请食。比丘尼在前立。指示言。与是比丘饭。与是比丘羹。若鱼若肉。诸比丘应语是比丘尼言。姊妹小住。待诸比丘食竟。若无一比丘呵者。是诸比丘应向余比丘悔过言。长老。我堕可呵法。此法悔过

有学家僧作学家羯磨。比丘先不请而往自手受食。若啖若食。是比丘应向余比丘悔过言。长老。我堕可呵法。此法悔过

诸大德。已说四波罗提提舍尼法。今问诸大德。是中清净不。是中清净不。是中清净不

诸大德。是中清净默然故。是事如是持

诸大德。是众学法。半月半月次说波罗提木叉

齐整着内衣应当学

齐整被衣应当学

好覆身入家内应当学

谛视入家内应当学

小声入家内应当学

不笑入家内应当学

不覆头入家内应当学

不反抄衣入家内应当学

不脚指行入家内应当学

不叉腰入家内应当学(十事)

不摇身入家内应当学

不摇头入家内应当学

不掉臂入家内应当学

好覆身家内坐应当学

谛视家内坐应当学

小声家内坐应当学

不笑家内坐应当学

不覆头家内坐应当学

不反抄衣家内坐应当学

不抱膝家内坐应当学(二十事)

不交脚家内坐应当学

不叉腰家内坐应当学

不动手足家内坐应当学

一心受食应当学

羹饭等食应当学

不偏刳食应当学

不口中颊食食应当学

不吐舌食应当学

不大团饭食应当学

不张口待食应当学(三十事)

不挑团食应当学

不啮半食应当学

不含食语应当学

不指抆针食应当学

不舐手食应当学

不[口*束]指食应当学

不[口*專][口*集]作声食应当学

不吸食食应当学

不全吞食应当学

不落饭食应当学(四十事)

不振手食应当学

不嫌心看比坐钵食应当学

端心视钵食应当学

不病不得为己索食应当学

不以饭覆羹上更望得应当学

不以腻手受饭器应当学

不以钵中残食弃地应当学

已立不为坐人说法除病应当学

已坐不为卧人说法除病应当学

已在下不为高床上人说法除病应当学(五十事)

不为着革屣人说法除病应当学

不为着屐人说法除病应当学

不为覆头人说法除病应当学

不为缠头人说法除病应当学

不为抱膝蹲人说法除病应当学

不为翘脚人说法除病应当学

不为捉刀人说法除病应当学

不为捉弓箭人说法除病应当学

不为捉杖人说法除病应当学

不为捉盖人说法除病应当学(六十事)

在后不为在前人说法除病应当学

不为骑乘人说法除病应当学

在道外不为道中人说法除病应当学

不生草上大小便涕唾除病应当学

不水中大小便涕唾除病应当学

不立大小便除病应当学

(众学六十六事竟)

诸大德。已说众学法。今问诸大德。是中清净不。是中清净不。是中清净不。诸大德。是中清净默然故。是事如是持

诸大德。是七灭诤法。半月半月次说波罗提木叉

若随事随顺人。应与现前比尼人。与现前比尼

应与忆念比尼人。与忆念比尼

应与不痴比尼人。与不痴比尼

应与自言治比尼人。与自言治比尼

应与觅罪相比尼人。与觅罪相比尼

应与多觅罪相比尼人。与多觅罪相比尼

应与如草敷地比尼人。与如草敷地比尼

诸大德。已说七灭诤法。今问诸大德。是中清净不。是中清净不。是中清净不。诸大德。是中清净默然故。是事如是持(七灭诤竟)

诸大德。是随顺法。半月半月次说波罗提木叉。二部比尼随顺者。随顺行此法

诸大德。已说随顺法。今问诸大德。是中清净不。是中清净不。是中清净不

诸大德。是中清净默然故。是事如是持。

诸大德。已说戒经序法。已说四波罗夷法。已说十三僧伽婆尸沙法。已说二不定法。已说三十尼萨耆波夜提法。已说九十二波夜提法。已说四波罗提提舍尼法。已说众学法。已说七灭诤法。已说法随顺法。是名如来应供正遍知法比尼法。入波罗提木叉经中。是法随顺法。一切学莫犯

佛言。毗婆尸佛如来应供正遍知。为寂静僧。略说波罗提木叉

  忍辱第一道　　涅槃佛称最
  出家恼他人　　不名为沙门

尸弃佛如来应供正遍知。为寂静僧。略说波罗提木叉

  譬如明眼人　　能避崄恶道
  世有聪明人　　能远离诸恶

毗叶婆佛如来应供正遍知。为寂静僧。略说波罗提木叉

  不恼不说过　　如戒所说行
  饭食知节量　　常乐在闲处
  心净乐精进　　是名诸佛教

拘留孙佛如来应供正遍知。为寂静僧。略说波罗提木叉

  譬如蜂采华　　不坏色与香
  但取其味去　　比丘入聚落
  不破坏他事　　不观作不作
  但自观身行　　谛视善不善

拘那含牟尼佛如来应供正遍知。为寂静僧。略说波罗提木叉

  欲得好心莫放逸　　圣人善法当勤学
  若有智寂一心人　　尔乃无复忧愁患

迦叶佛如来应供正遍知。为寂静僧。略说波罗提木叉

  一切恶莫作　　当具足善法
  自净其志意　　是则诸佛教

释迦牟尼佛如来应供正遍知。为寂静僧。略说波罗提木叉

  护身为善哉　　能护口亦善
  护意为善哉　　护一切亦善
  比丘护一切　　便得离众苦
  比丘守口意　　身不犯诸恶
  是三业道净　　得圣所得道
  若人打骂不还报　　于嫌恨人心不恨
  于嗔人中心常净　　见人为恶自不作
  七佛为世尊　　能救护世间
  所可说戒经　　我已广说竟
  诸佛及弟子　　恭敬是戒经
  恭敬戒经已　　各各相恭敬
  惭愧得具足　　能得无为道

已说波罗提木叉经竟。僧一心得布萨摩诃僧祇戒

  持戒净身口　　摄心正忆念
  多闻生实智　　斯由戒为本
  戒为妙宝藏　　亦为七财宝
  戒为大船师　　能渡生死海
  戒为清凉池　　澡浴诸烦恼
  戒为无畏术　　消伏邪毒害
  戒为究竟伴　　能过崄恶道
  戒为甘露门　　众圣之所由
  持戒心不动　　专精不放逸
  不毁正戒相　　亦无邪命心
  是名清净戒　　诸佛之所赞
  是故欢喜持　　清净之戒身

摩诃僧祇律大比丘戒本


毗尼母经

    No. 1463

毗尼母经卷第一

        失译人名今附秦录

  母义今当说　　汝等善听之
  是中文虽略　　广摄毗尼义
  依初事演说　　智慧者当知
  一切经要藏　　皆总在此中
  律藏外诸义　　母经中可得
  律义入此经　　如众流入海
  毗尼外诸义　　如母经中得
  一切诸经义　　随意皆能解
  律能灭疑惑　　如众经定说
  佛所制诸戒　　皆在此经中

问曰。何故名母经。智者说曰。此经能灭憍慢解烦恼缚。能使众生尽诸苦际毕竟涅槃。故名母经。毗尼者。名灭灭诸恶法。故名毗尼。今当说母经义。母经义者。能决了定义不违诸经所说。名为母经。此中解二种经。一比丘经。二比丘尼经。一切诸聚后当广说。初十人制戒因缘增一中义。皆入此经中。因初因缘。得知初事断人疑心。众经中义不复惑也。若比丘欲善持毗尼母经中定解。能速除生死亦胜犯戒贼。受具足义今当说。何故名受具足。智慧人受具足已不犯。所求成就故言受具。能成就义名为受具。以是义故。成就众善名为受具。复次能专心持戒。故言受具。能使成沙门义。故名受具。能使人成就意净法故。名为受具。能成就寂灭法故名受具。又成就比丘法故名受具。于此律中知见达解触证得知。名为受具。有能成就比丘五种受具。名为受具。何者五。一者善来比丘即得受具。二者三语即得受具。三者白四羯磨受戒名为受具。四者佛敕听受具即得受具。五者上受具。何故名为上受具。佛在世时不受戒。直在佛边听法得阿罗汉。名上受具。是名比丘五种受具。比丘尼亦有五种受具。一者随师教而行名为受具。二者白四羯磨而得受具。三者遣使现前而得受具。四者善来而得受具。五者上受具。能成就不作一切诸恶。是名受具。又于毗尼藏中选择是非能信行故。名为受具。又能成就断五盖法。名为受具。有能除觉。观亦名受具。能舍爱着禅心亦名受具。苦乐忧喜以能舍故。名为受具。能过四空定故亦为受具。能知诸相灭亦名受具。又受三归五戒亦名受具。又受八斋法亦名受具。又受沙弥十戒亦名受具。又分受戒名为受具。又能白业观者亦名受具。成就种性地故名为受具。云何名种性地。有人在佛边听法。身心不懈念念成就。因此心故。豁然自悟得须陀洹。须陀洹者善法之种性也。四果四向第八地见谛地薄地离欲地已作地乃至无师独觉。皆名受具。成就六度亦名受具。善语亦名受具。从智慧受具乃至善语受具。皆名受具。复欲广说。何等人应得受具。若有善男子善女人。无障清净皆得受具。夫障有三种。业障报障烦恼障。清净人者。听其出家剃除须发着法服受三自归十戒乃至白四羯磨受具。当使出家者知四堕法不可犯也。依四依止尽形寿受行。乃至梵行营事得出家法。得法证果受乐。大功德成就。是余众事应问和上阿阇梨。和上阿阇梨应教毗尼中所应作不应作。又复劝与诸同学同业同行一切善法莫相违反。何故与受具者。欲使得五通乐见苦不怖少欲知足得大人觉。云何名为得于大觉。如佛所受行于毗尼。故名为觉

云何名欲。如佛翘勤不惓。故名为欲。又复明欲系念在前。如佛觉无异。以是义故名为欲也。何故名触。得定故名触。得善得恶亦名为触。云何名证。不放逸故名为证。证言知义如佛觉也。此中何者是善来比丘受具。如尊者阿若憍陈如。当尔之时世尊游波罗奈。尊者阿若憍陈如。见法得法证法深解法性。即从座起整衣服偏袒右肩右膝着地合掌作礼白佛言。世尊。唯愿如来听我出家修于梵行。世尊告曰。善来比丘。听汝于我法中修于梵行尽于苦际。此阿若憍陈如即得出家即得具足。如来言已。身上所著婆罗门服。乃至须发即皆堕落。沙门法服自然在身。威仪庠序手执应器。如二十年学法者也。尊者阿钵只婆犯跋提伽摩诃男等。亦如阿若憍陈如也。耶修陀同侣四人。毗摩罗修婆侯富那伽憍梵跋提耶奢童子同侣有五十人。弥低同侣亦五十人。那罗陀摩那婆跋陀跋期同侣五十人。优楼频蠡迦叶那提迦叶伽耶迦叶此等徒众千人。优波提舍驹律陀而为上首。徒众二百五十人

如此等皆豪贵巨富本是外道出家。佛已出世受悟时至。皆来诣佛求欲出家。最后须跋陀罗如此人等。皆是善来比丘也。其所得果皆是无学后边身者。何以故。如来自神口所说故尔。余人边不能得也。问曰。世尊何以不与神力加波罗伽至婆梨伽富迦罗婆利伽使善来出家。答意如此。婆醯有障道业。是故不得善来出家。富伽罗婆利伽者。此人现身无学因缘故。不得善来出家。以是义故。虽俱在佛边。不得一切善来出家也。三语受具者。尔时世尊告诸比丘。吾于人天罗网皆得解脱。汝等于此网中皆得解脱。尔时恶魔闻佛此言。即语佛言。汝于人天罗网不得解脱诸比丘亦不得解脱。佛即说偈答曰

  世人于五欲　　第六意识受
  吾已离诸欲　　恶魔汝自堕

恶魔闻此言已。知佛达其未离欲故。惭愧忧愁不乐。忽自灭去。佛告诸比丘。汝各各二人共诣诸方教化。莫独去也。诸比丘即去。彼土诸人闻比丘说法。皆来诣佛。于其中路有生悔心者。即还归家。以是因缘诸比丘来白世尊。佛即教使就彼三语受戒。语诸比丘。汝等各各还去。彼方若有求出家者。当为剃除须发教着法服与三语受戒。归依佛归依法归依僧。如来应正觉是我师。此即三语受戒法也。尔时诸比丘生疑。云何三语即是出家即是具足。佛为说曰。归依佛归依法归依僧即是出家。第二归依佛竟归依法竟归依僧竟即是受具。以是义故出家受具成就也。有人复更生疑。何故优婆塞受三自归。及以沙弥乃至八戒皆受三语。何故不名受具也。佛说曰。此二义各异。优婆塞者。不止在三归。更加五戒。始得名为优婆塞也。沙弥乃至八戒亦复如是。三语受具者。与此为足更无所加。故言受具。所以无所加者。三归有二种。一者为受五戒十戒八斋故受三归。乃至为受二百五十戒故受三归。二者直受三归。所以尔者。当尔之时。佛未制二百五十戒乃至八斋。以是义故。直说三归得受具也。佛制不听。三语受戒已后。虽有三语不成就也。佛所以后断三语受戒者。因一病比丘。是故断也。于时阿若憍陈如。即从座起整衣服偏袒右肩。右膝着地合掌向佛。白佛言。世尊。我等云何得知三归三语受具。佛告憍陈如。若人求出家者。当剃除须发。教作如是言。我今尽形寿归依佛法僧。乃至说。我今依佛出家。婆伽婆是我师也。佛告憍陈如。三语受戒如我所说解也。尊者憍陈如。闻佛所说三语受戒。心开意解。即退坐礼佛而去。尊者阿若憍陈如。游行到毗利耆国。展转复到毗舍离。毗舍离中有毗梨耆人。二国族姓子合在一处。一名羯羯带遮。二名羯伦伽。三名毗斤带遮。四名羯迟遮。五名遮赖遮。六名毗陀跋遮。七名跋陀。八名修跋陀遮。九名(本阙)十名耶奢。十一名移须多罗。十二名阿梨耶。此诸人等皆生念言。阿若憍陈如。于大沙门法。中出家行于梵行。此是大智见者。乃能随学必有妙法。我等何为不就其出家学妙法也。彼所修行我等亦共修行。尔时族姓子共论议已。即便相将诣憍陈如所。头面礼足却住一面。白尊者言。惟愿大德。听我等于如来法中出家修于梵行。阿若憍陈如。即受其言听其出家。为说三语受戒。受戒已。即共相随诣于佛所。头面礼足却住一面。尊者憍陈如。即白佛言。此诸族姓子等求欲出家。为其三语受戒为得戒不。佛告憍陈如。此诸人等三语受戒。具足成就善得具戒。何以故。过去诸佛亦曾与此三语受戒。未来诸佛亦当与此三语受戒。我今现在亦同彼也。是故得有三语受戒。白四羯磨者。何以要现前白四羯磨而受具者。解云。当于尔时。佛住王舍城。优楼频螺迦叶等师徒已出家竟。有一病比丘无供养者。病困笃已即便命终。诸比丘等见此比丘病笃命终。一无看病者。二无弟子。二俱无故苦恼如是。往白世尊。佛即集诸比丘僧。从今已去。断三语羯磨。于十僧中白四羯磨听使受具。如是一一受戒皆如上广说。应当知。尔时有一恶比丘度人出家。出家者即于师边生疑。往白世尊。世尊问言。汝先未受戒时生疑不。答言。不也。佛言。汝已得具足戒也。复有一人求师出家受具足戒。得受具已心中生疑。疑师不清净为得戒不。往白世尊。世尊问言。汝先知师不清净不。受戒者言。不知也。又复问言。汝先知不清净师边受戒不得戒不。答言。不知。佛言。汝便是得具足戒也。复有一人求师出家。师即为受具足。后心生疑往白世尊。世尊问言。汝先知汝师破戒不。答言。知也。又复问言。汝先知不清净师边受戒不得戒不。答言。知也。复更问言。汝先知汝师受戒时得戒不。答言。不知也。佛言。汝便得具足戒也。又复一人求师出家。师即与受具足。后心生疑往白世尊。世尊问言。汝先知不清净师边受戒不得戒不。答言。先知。复更问言。汝先知汝师师边受戒不得戒不。答言。知也。佛言。三事皆知。受戒不得也以是义故。名为白四羯磨。云何名为敕听受具。当于尔时。佛在舍卫国比舍佉鹿母园中堂上。问苏陀耶沙弥义。沙弥解义。如佛所解称如来意。佛即告言。汝从今已往。若有疑惑恣汝来问。亦即与戒即得具足。故名敕听受具。云何上受具。如有一人尽一切漏。未满二十已受具足。即于比丘法中自生疑心。同住诸比丘知其生疑。往白世尊。世尊语此漏尽比丘。汝数胎中年乃至闰月皆数满不。答言。不满。佛即问诸比丘。此比丘得阿罗汉耶。诸比丘白佛。得阿罗汉。佛言。此是上受具也。又复告言。后受戒者听数胎中年。云何比丘尼五种受具随师教而行。名为师法受具。当于尔时。佛住释种园中。时摩诃波阇波提憍昙弥。与五百释种女来诣佛所。到已头面着地礼佛足。白佛言。世尊。我等女人于佛法中得出家不。佛言。吾不欲听女人出家。闻此语已低头泣泪而去。世尊后时。从释种园向舍卫国只桓精舍。憍昙弥五百女等。闻佛向只桓精舍。心怀悲恼自慨其身。不在佛法之次。各自剃头着法服。随佛后而去。到只桓精舍在外而立。见尊者阿难。阿难即问母及诸女言。优婆夷等何为剃发自着法衣颜色憔悴而不悦乎。母及诸女即答言。所以不悦者。但世尊不听女人出家。是故忧色也。阿难言。且止。当为白世尊。阿难寻入即启世尊。是优婆夷等求欲出家。愿世尊听许。佛告阿难。吾所以不听女人出家者。如世人家男少女多家业必坏。出家法中若有女人必坏正法不得久住。阿难重白佛言。女人于佛法中修梵行得四果不。佛告阿难。能修梵行其志不退亦可得耳。阿难复白佛言惟愿世尊。听女人在佛法之次。佛告阿难。女人能行八敬法者听其出家。若不能者不听在道。所以为女人制八敬者。如人欲渡水先造桥船。后时虽有大水必能得渡。八敬法亦如是。怖后时坏正法故为其制耳。佛告阿难。汝今为女人求出家。后当减吾五百世正法。阿难闻此之言忧愁不乐。即出外问诸优婆夷等。佛说八敬之法能奉行不。诸女闻此语已内怀欢喜。即请阿难。还白世尊。我等今日蒙世尊施法。当奉行之。譬如有人沐浴香汤庄饰已竟。更有人来以华鬘庄其顶上。我等今日亦复如是。阿难以此之言即启世尊。世尊言。此等已得受具。是名师法受具。白四羯磨受具者。如上病比丘经中所说。遣使受具者。亦如比丘尼经中所说。云何名善来比丘尼受具。当于尔时。世尊在舍卫国。摩登只女来到佛所。头面着地礼世尊足退坐一面。佛即为说法深悟法性。得须陀洹果。求佛出家。世尊告曰。听汝于我法中善修梵行尽诸苦际。佛言已讫。头发自落法服应器忽然在身。威仪庠序如久服法者。是故名为善来受具

上受具者。尽诸有漏成阿罗汉。如上沙弥。虽未满二十得阿罗汉故。名为上受具。此比丘尼亦复如是。是名上受具。比丘尼五种受具竟。立善法上受具者。尔时王舍城中有婆罗门。名尼驹陀。钱财珍宝巨亿无量。此婆罗门家生一子。字毕波罗延。父母种姓清净。诸婆罗门所有经书无不悉达。乃至大人之相亦能达之。此毕波罗延童子父命终后。家中有碎金九十六斛。钱有八十亿勒沙十万一勒沙也。奴婢仆使有千聚落。其妇字跋陀。颜貌殊特世之无类。故能割爱断贪舍之而去。默生此念。世间若有应真罗汉者就之出家。诣彼苦行仙人林中修于梵行。作是念已。故能割爱断贪舍之而去。诣彼苦行仙人林中。十二年茹菜食果饮清流泉修于梵行。得诸禅心成就五通。世尊尔时现出于世。在鹿野苑初转法轮。僧已成就。与大比丘众千人俱。如此人等。皆是耆旧长宿。国之所重。诸根寂静皆是漏尽解脱者也。世尊与诸比丘展转游行。到摩竭提国。入若致林中。在尼驹树王下住。尔时世尊。以佛眼观于世间。何等众生生于世间。少诸烦恼有大神力。能堪听受吾所说法。如来见毕波罗延童子在优吒林中。见已即生此念。是人堪受吾之正法。尔时世尊。欲度毕波罗延童子故。与千比丘俱。从摩竭提国向多子塔。到已在树下止住。一日于此林中。佛神力故。光明照曜林树焰赫而皆大明。譬如秋月无云翳日。如来光明亦复如是。此童子十二年已。自然生心欲向多子塔。经涉崄难山谷林薮到多子塔。到已见此林中光明殊特与世超绝。默自生念。此中或有诸天释梵大力神仙师子王等。是故此林有异瑞相。毕波罗延童子渐渐前行。见如来足迹有千辐相轮具足分明。即寻迹前行。遥见如来诸根明净颜貌殊特众相具足俨然而坐。童子即时衣毛皆竖生于信心。内自默念。本出家时心中所期今此是也。诸天即复唱告语言。不须疑也。此童子复见诸比丘系念坐禅。即生念言。本所求者今乃得见。直前诣佛。到已头面着地。以两手摩佛足。口复鸣之自云。我姓迦叶字毕波罗延童子。如是三称尔时世尊告诸比丘。若有烦恼结漏未尽。非一切智亦非人师。受成就善法人礼者。头破作七分。吾今实是烦恼结漏尽者。为一切人作福田者。慈愍众生者。亦是一切智者。是故受此童子礼也。尔时世尊告童子言。汝今已具足供养信心成就可退坐一面。童子即受告敕。礼佛足已退坐一面。尔时世尊。为彼童子种种因缘巧说诸法示教利喜。童子即悟法得道获须陀洹果。即从座起合掌作礼前白佛言。世尊是我师。我是声闻弟子。佛即为童子说如是言。当于四念处亲近修行。广演乃至八圣道亦如是。佛告童子言。汝入诸族姓子聚落心莫染着。犹如月照世间无所染着。汝入诸聚落心无染着亦复如是。如蜂采花入诸聚落亦应如是。童子。如真陀罗童子喻。当舍恃姓财德之心。应当谦下入于聚落。如牛群中大牛自恃角峰慢于余者当时刖角慢心都息。汝入聚落心无染着亦应如是。佛告童子。内六入莫取想封着系缚心也。外六入乃至中六识亦如是色阴亦不应封着取想。乃至识阴亦如是。眼耳鼻舌身意及外六尘。得觉观意观亦应如是不取想也。譬如空中水渧。渧渧相寻无有滞碍。观十八界十二入五阴等不取着心无挂碍亦复如是。善男子。汝如此应学。童子白佛言。奉世尊教。尔时童子闻佛世尊引诸譬喻种种说法。即悟取解。童子受法已。即从座起绕佛三匝礼佛而去。到一树下端身系念佛所说法七日七夜。至八日朝诸漏已尽三明六通具八解脱证阿罗汉果得阿罗汉果已。往至佛所头面着地礼佛已却坐一面。白佛言。世尊。我先闻如来所说法七日七夜。至八日朝诸漏已尽心得解脱。得三明六通获阿罗汉果。譬如有人说言。有一大象高于七肘。复有一树高六肘半。说言。此树能荫象者无有是处。若有得罗汉果三明六通具八解脱。能过我者无有是处。佛告迦叶。善哉善哉。迦叶。如汝所说。汝于我所说法中种种诸喻。深悟无生得阿罗汉果。即是受具足戒也

尔时世尊。因是事故集诸比丘告言。我先为迦叶说如此法。汝等今日皆修行之。佛复告诸比丘。从今已去。听汝等立善根上受具。佛告诸比丘。过去诸佛未来诸佛皆立善根上受具。我今亦复如是。是名立善根上受具也

尔时尊者迦叶。即从座起偏袒右肩右膝着地合掌礼佛白佛言。世尊。我等于如来法中。住何等法修何等法。行法之人有何差别。佛言。善哉善哉。迦叶。汝之所问甚善。如泉涌出不可穷尽。所问住修乃至差别。言辞义理所问无滞。佛告迦叶。四圣种是住处。十二头陀名为行处。尽诸有漏名为差别

迦叶白佛言。四圣种十二头陀乃至漏尽解脱。当顶戴奉行若长者若长者子。沐浴香汤以上衣服而自庄饰。更有人来以好花鬘系其顶上。我等亦复如是。顶戴如来所告敕法。佛告迦叶。汝云何复住四圣种中。迦叶白佛。一者随前所得粪扫衣以为足想。二者见前人所著粪扫衣亦赞叹之。三者自见所著粪扫衣不自恃讥彼。四者得饮食乃至病瘦汤药随所得以为足想。又复不自恃讥彼。又于他人不生此念。彼人胜我彼人不如我。复不念言。彼人似我此人不似我。复不生心。此人卑我彼人不卑我。复不念言。彼人妙我彼人不妙我。世人皆与上相违。而我如上也。佛告迦叶。四圣种住应如是学。迦叶。云何复欲行十二头陀。迦叶白佛言。一者常自行空闲静处亦当赞彼闲静之处。二者乞食。三者粪扫衣。四者若有嗔心止不食灭已乃食。五者一坐食。六者一时受取。七者常冢间行。八者露地坐。九者树下坐。十者常坐不卧。十一者随得敷具。十二者齐三衣。如此等法皆应赞叹。亦不自恃讥彼。乃至少欲众具知足。众具广示于人。佛告迦叶。善哉善哉。如汝所言。行十二头陀正应如是。佛复告迦叶汝可随吾按行林薮。迦叶答言。奉世尊告。佛起而去。迦叶即捉坐具着肩头随世尊后。迦叶随佛如师子子随大师子。尔时世尊。随道而行到一树下。告迦叶言。汝可为吾于此树下敷座。迦叶即奉告。揲僧伽梨四揲敷座。如来就坐。迦叶礼佛足。世尊以右手按坐。告迦叶言。此坐甚柔软。迦叶言。世尊。此坐实柔软。此衣是弟子初出家时衣。此衣新时价直迦尸一国今价已退可直半国。唯愿如来纳受此衣。佛告迦叶。吾怜愍汝故受此衣。汝受持何等。即白佛言。我当取迦尸迦草粪扫衣中最下者求觅受持。佛告迦叶。善哉善哉。汝受持迦尸迦草粪扫衣者。多所利益多所安隐。尔时世尊。与大比丘僧千二百五十人俱。次复游行摩竭提国。在林中善立摩拘陀树王下坐。尔时六群比丘于静房中共谈。迦叶不如阿若憍陈如等善来受具。亦不如毗舍离拔只子比丘三语受具。亦不如婆卢波斯那比丘白四羯磨受具。此非受具者也

云何与诸比丘同共布萨羯磨。世尊尔时。在树下以天耳闻诸比丘在屏处论。佛告迦叶。为吾取水。迦叶即持钵向池取水。六群比丘见迦叶来到。六群即逆语言。汝非如五人憍陈如等善来受具亦不如毗舍离子三语受具。亦不如婆卢波斯那白四羯磨受具。汝非受具。云何与诸比丘同共布萨羯磨。迦叶即答诸比丘言。世尊为我在多子塔建立善法上受具竟。说此言已。即持水来到佛所奉佛钵水。佛饮已余残持与迦叶。迦叶取水已。整衣服偏袒右肩头面着地礼佛足合掌白佛言。六群比丘见向说言。汝非善来受具。复非三语受具亦非羯磨受具。云何同僧法事。弟子答诸比丘。世尊为我在多子塔建立善法上受具。汝等当诣佛咨启取足。得与不得。随佛所说当受行之。尔时世尊。为欲断未来诸比丘谤毁心故。告阿难言。汝往到王舍城。此城中若有诸比丘。尽集在大僧坊中。阿难即受教而去。至彼即集诸比丘在大僧坊。众僧集已即来白佛。僧已集竟。世尊自当知时。尔时世尊。即诣僧坊安庠就座右胁而卧。如象王观谛视迦叶。尔时迦叶从座而起。右膝着地头面礼佛。胡跪合掌白世尊言。本在家时父终亡后。粟金有九十六[百*斗]金钱有八十亿勒沙自妻颜容瑰玮世之无匹。内自思惟。若有真阿罗汉者当受之出家。思惟已。即舍爱断贪出家求道世间若有弟子师者唯佛是也。云何六群谤言不受具也。又复更言。世间若有奇色妙宝。不出已有。非贪财视色久已舍之。云何方被谤。从出家已。来在彼林中十二年。得四禅心乃至五通。未有一念乱心在前。何以故。见此生死诸行。可怖畏故复次言。家父在时。用二十亿金钱娉妻。一日三时随时易服。未曾有乏。乃至病瘦医药。及离世八法。恃姓豪贵不曾经心。虽娉其妻各修梵行未曾有毁。迦叶白佛言。世尊。我过去世缘以食施辟支佛故。从是以来常乐出家求涅槃解脱。佛自证知。何以故。心中常自怖畏流转五道受于生死。世尊。我初至多子塔林中。见如来即生此念。此即是本出家时所求师也。何以故。我于过去诸佛生于信心。今见世尊生于信心。等无有异。尔时世尊告诸比丘。若有烦恼结漏未尽。非一切智复非人师。受此成就大士礼者。头破作七分。吾实是烦恼惑累无明闇障皆已永断。知一切法为人作师。是故受此人礼。尔时迦叶即白佛言。诸比丘虽如此谤亦无忧恼。世尊今时。虽复种种赞叹之德亦不欣悦。何以故。我观能赞所赞是二皆空。所以者何。我得一切无我无人诸法空观故。从尔时世尊在多子塔。为我说月光喻水渧喻已来。心心相续常念此法更无余想。所以尔者。常系心在于善法不随余念。世尊。我未见佛时。十二年中常观地水火风及与三界皆作空想。况于今日遇世尊说法有余心想。亦复无有三世见闻觉知。岂于六群生异念乎。世尊为我说四圣种已来。我亦不取味触之想。见此阴身如四毒蛇。行四威仪心不与俱。何以故尔。久知此是过患之本。观此五阴念念生灭。亦如五拔刀贼。观色集色灭受想行识识集识灭。观六入空聚落中五拔刀贼。观于无我。世尊。我观此身。如器盛不净流出于外。身随身观。世尊。我观此心。无常迅速如野马疾风。心随心观。我观受苦。生灭代谢如水流灯焰。受随受观。我观法无我。属诸因缘。法随法观。世尊。我于如来所说法中无有错谬。当顶戴奉行。世尊。我于尔时王舍城千二百五十僧中。众僧行筹唱言。谁是应真可捉此筹。我于尔时。即拔此筹。若不遇如来出世。应得辟支佛而入涅槃。所以尔者。曾于诸佛久种善根。我于尔时。在毕波罗。石窟中卒遇小患。世尊故来问疾。但窟小身大。我即以手举此石窟令大。世尊。即入为我说苦空法也

尔时我在毕波罗窟中入火光三昧。是时帝释梵王来礼我足。复有一人捉刀欲害我。从定出观此二人平等无异。复言我在大众及与私房威仪无异。佛告诸比丘。威仪进止当如迦叶。我虽闻此言不以喜悦。迦叶复言。我夜经行及中时乞食。意中生念。夜短中逼。举目上看日月。皆住不行。诸天变为人身。前后围绕供养于我。我于尔时。于此事中都无喜欢奇特之心。我于王舍城中。与千二百五十比丘俱集一处。行筹唱言。如来灭后谁能持佛法。我于尔时即拔此筹。所以尔者。于论中辩才无制御者。是故拔筹。若有正问。于五欲中谁不重染。应说我是。何以故。于三有中善得解脱故。若有人问。于根力觉道谁能成就。我于此中能师子吼。何以故。于一切苦集灭出离。知味知过如实见之。欲如火坑乃至喻于牟戟。欲之过患亦复如是。我无爱贪永已绝矣。心缘解脱涅槃。速疾如山顶水。舍于有漏如弃涕唾。我以广修四念处乃至八圣道。于八解脱定自在出入。我于神通自在无碍。世尊。我于众生有漏无漏种种诸心皆能悉达。我知众生过去无量宿命。世尊。我以天眼过于人眼。见众生生彼死此皆悉见之。我尽诸有漏心得解脱慧得解脱。迦叶言。诸比丘及余六群大德。莫谓我自叹其德。所有功德皆已舍之。况复其余虚假之名。所以说者。为欲利益长夜诸众生故。佛告迦叶。善哉善哉。迦叶。汝所利益事。除吾一人。其余声闻无能及者。汝可为诸六群愍其痴故。当与忏悔

尔时优波离。即从座起偏袒右肩右膝着地合掌礼佛。问世尊言。一切诸佛皆建立善法上受具不。佛告优波离。非一切诸佛皆建立之。所以立者。为五浊众生建立之耳。五浊者。所谓劫浊命浊众生浊业浊烦恼浊。过去未来诸佛亦复如是。我今五浊恶世。是故制之。优波离。问佛。几处得建立善法上受具满足。佛告优波离。五处满足。何等为五。一者最后边身。二者婆醯破罗伽至婆勒伽。先得须陀洹果者是。三者随顺苏陀夷诸漏已尽心得解脱。四者难陀放牛儿。五者今迦叶如来受具戒。非余声闻。优波离。此五处建立善法上受具而得满足。世尊。有几处白四羯磨受具而得满足。佛言。有五处而得满足。一者和上如法二者二阿阇梨如法三者七僧清净四者羯磨成就五者众僧和合与欲。优波离。此五处不成就。不名满足。此中有四种受具。从善来乃至白四是也

比丘尼亦有四种受具。一者如摩登只女是。二者师法是。三者遣使现前是。四者白四羯磨是。敕听受具上受具。此二皆作建立善法上受具。名说比丘尼上受具。亦建立善法上受具名说。是名受具。不受具者。异于上受具。名不受具。若声闻用善来语授人戒者。不成受具。用三语授人戒亦不得受具。白四羯磨唱不成就者。亦不得受具。非法僧亦不得受具。何者名非法僧。不就戒场先羯磨后白。又复更作余羯磨。皆名非法僧。离佛离法离毗尼受具亦不得具。年不满二十不得受具。若受亦不得具。若无和上若二和上若三乃至众多作和上亦不得受具

若受戒者若和上。隐身不现亦不得受具。十数众僧虽满。若一隐不现。若受戒者不现。亦不得受具外更不结大界。直结小界亦不得受具。若和上众僧受戒人互在界内外。亦不得受具。有十三种人。不得作和上受具。若在家受优婆塞戒若毁破一。有受八斋毁一。若受沙弥十戒毁一。如此人者。后出家亦不得戒。亦不得作和上。二者若出家在家破比丘尼净行。亦不得作和上。三者为衣食故。自剃头着袈裟诈入僧中与僧同法事。此亦不得作和上。四者若有外道人。于佛法中出家。后时厌道。不舍戒而去。从外道中还来欲在法中。佛不听此人在于僧中。亦不得作和上。五者黄门不得作和上。六者杀父。七者杀母。八者出佛身血。九者杀真人罗汉。十者破和合僧。十一者若非人变形为人者名为非人。十二者若畜生道变形为人者。十三者二根人。如是十三种。不任作和上。何以故。是人无戒故

毗尼母经卷第一毗尼母经卷第二

        失译人名今附秦录

尼遣使受戒中。佛在世时唯有一女得。所以得者。但此女颜容挺特世所无比。若往者恐恶人抄略。是故佛听。今时若有如是比者。可得遣使受戒。其余一切要现前得具。不现前不得。师法受具中。除憍昙弥五百诸女。其余一切不得师法受具。上受具中。除尊者摩诃迦叶苏陀耶。其余一切不得建立善法上受具。若男子女人其性调善。慧亦明了无有诸难。得受具足。复有三人不得受具。一不自称字。二不称和上字。三不乞戒。此三种人不得受具。与此相违得受具足。复有五人可受具足。一成就丈夫。二不负债。三不是人奴。四年满二十。五父母放出家。是五种人得受具足。复有五处。白四羯磨受戒满足何者五。一者和上二者阿阇梨。三众僧具足。四性调顺。五诸根具足无诸障碍。是名五处受戒满足。与五人相违不得受具。复有二人不听受具。一者有业障。二者龙变为人。若先不知与受戒。后时知应摈出众。先知不应与受戒。如上十三比类应广知。复有一人不应受具。此身上忽生白色生已复灭。若先知不应与受具。若不知已受具竟。后时虽知不应驱出众

云何为业。思业行业可思业。故思业非可思业。可受业不可受业。少受业多受业。已受业未受业。色业非色业。可见业不可见业。有对业无对业。圣业世间业。现身受业生受业。后受业趣恶业。趣天业趣涅槃业。有三业一切诸业摄在其中。白业。白第二业。白第四业。复有四业。非法作业。法作业。群共作业。业齐集作业。复有四种业。有比丘群业。共作非法羯磨齐集业。共作非法羯磨群共业。作法羯磨齐集业。作法羯磨此中。非法业群共业。诸比丘不应作。非法业齐集业。此二业不应作。法业群品业亦不应作。法业齐集业。此二业应作。吾所听之。此中有三种应当知。一者白业。二者摈罚业。三非白非摈罚业。云何名为白业。白已剃发受沙弥戒。乃至大比丘戒亦先白后受。若不听不得受比丘法。一切皆如是。若有所作。要白众僧。听得不听不得作。是故名为白业羯磨。云何名为摈罚羯磨。若有比丘不顺佛语。或自白僧或他白僧。僧集随其罪轻重。众诃责摈出。或有人摈罚。罪负未讫更重作之。众僧亦更重诃责。如此之类皆名摈罚业也。云何名为不白不摈罚。若有比丘。僧差营房舍。此业非白亦非摈罚。又复此人。僧初与羯磨立作营房人。是亦非白非摈罚。是业名为非白非摈罚。又复解羯磨非一。如羯磨亡比丘物。此羯磨非白非摈罚。是故有异。受功德衣羯磨亦如是。如结大界羯磨净地羯磨。如此等不在白摈罚羯磨也。复有二种羯磨。一为人二为法。何等为法羯磨。如白已说波罗提木叉戒自恣。如平僧坊地差营事人差分衣钵人。如为受迦絺那衣舍迦絺那衣结界舍界离衣宿先布萨却安居者。诸比丘檀越请安居。安居日满比丘尼为饮食美故不去。檀越心生疲厌。诸比丘即往白佛。佛即制。安居竟比丘尼若过一日波逸提。若大比丘突吉罗。齐集自恣。问法答法。问毗尼答毗尼。问法者迦叶是。答法者阿难是。问毗尼者迦叶是。答毗尼者优波离是。俱名依法羯磨。云何名依人羯磨。如度沙弥法先白后剃发受戒。如行波利婆沙日未满更犯还行本事行摩那埵行阿浮诃那与现前毗尼忆念毗尼。因闼婆摩罗子被谤故。佛制忆念毗尼。因难提伽比丘本清净心受戒。失心所作违于毗尼。后还得本心。诸比丘谤言犯罪。此比丘自言。我本失心时所作不觉不知。佛言。痴狂心所作不犯。是故此比丘。从众僧乞不痴毗尼。云何名自知比丘。佛在世时常自说戒。忽至说戒日。说戒时至。初夜中夜诸比丘请佛说戒。佛默然不说。目连以天眼观此众中。谁不清净。佛不说也。见一比丘不清净。目连即起捉臂牵出。佛即告目连言。何以不审悉问之。诸比丘应自知。所以初夜中夜佛不言者。外有恶贼故尔。尔时舍卫国诸比丘斗讼。此应灭之云何得灭。众中三藏比丘。当取其语和合灭之。有比丘字诃德。有风热乱心故。与诸外道论义。言辞错乱前后不定。为外道所笑。诸比丘白佛。佛呼此比丘在前。语言。汝莫乱心故与人论议。言应定实。现前诃责现前灭之

尔时舍卫国诸比丘诤讼。佛告诸比丘。各各相向五体投地。如草敷地灭所诤讼。犯事后当忏悔除灭。从诃责羯磨乃至知种种杂物人羯磨。此是依人羯磨。有羯磨成事不成。有事成羯磨不成。有俱成有俱不成。羯磨者法也。事者人也。云何名事成羯磨不成者。此人清净一切无诸障碍。是名事成。羯磨不成者。或言语不具亦前后不次第说不明了。是名羯磨不成。何者名为羯磨成事不成。羯磨成者。言语具足前后次第说亦明了。是名羯磨成。事不成者。有人诸根不具及余障碍。是名事不成。又俱成者。羯磨及人此二皆具。故言俱成。俱不成者。羯磨及人二俱不足。是名俱不成。应止羯磨者。诸比丘皆集。但所作不如法。应羯磨作法不羯磨作。应白作法不白作。众中有持毗尼行清净者。说言。此非法非律。是不应作。即止不作。是名止羯磨。不应止羯磨者。众僧齐集。所作亦皆如法。众中无讥慊者。是名不应止羯磨。此二章。卑犍度中广说章。卑者国名也。摈出有二种羯磨。一永摈二为调伏故摈。调伏者。未忏悔中间。及饮食坐起言语。一切僧法事皆不得同。是名摈出调伏羯磨。此人若刚强永无改悔。尽此一身不复得同僧事。尊者优波离。即从座起整衣服合掌礼佛白佛言。世尊。若有比丘于僧事无缺。而强摈者此事云何。佛言摈有二种。一者善摈二者恶摈。如摈十三种人者名为善摈。与此相违名为恶摈。是名摈出羯磨。复有众僧。听忏悔入僧次第羯磨。若比丘为调伏故摈出者。此人后时改悔求僧除罪。僧有所教敕皆顺僧意不敢违逆。能使众僧齐心欢喜。僧即聚集解摈羯磨更作。听入僧羯磨。是名听入僧羯磨。优波离问佛。摈出忏悔此事云何。佛言。为调伏者听使忏悔。永摈者不听忏悔。何者名为诃责羯磨。有人僧中健斗强诤。于僧法事中皆不如法。现前种种诃责乃至摈出。此诃责事。诃责犍度中广说。有诃责者。若比丘作种种不如法事。众僧语言。长老汝犯不如法事。此人即答僧言。我不知不见犯何等事。僧应种种苦责摈出。是名呵责羯磨。谏法应三处谏。见闻疑破戒破见破行。谏者。有五事因缘。一知时二利于前人三实心四调和语五不粗恶语。复有内立五种因缘故应谏。一利益二安乐三慈心四悲心五于犯罪中欲使速离。是名谏法缘事。云何名为缘事。若因若缘此中从何初起。如拔陀波罗比丘经中。应当广知。尔时世尊。在舍卫国一坐而食佛告诸比丘。吾一食已来身体调适无诸患苦。汝等亦应一食。诸比丘闻告欢喜奉行。拔陀波罗比丘不顺佛告。不能一食。何以故。我常数数食以此为法。佛复告言。汝能多食者中前多乞一坐而食。复言不能。佛复欲游诸国邑。阿难为佛缝衣。此比丘到阿难所问言。汝何所作。阿难答言。世尊欲游诸国邑。是故为佛缝衣。汝住此或无利益。闻此语已即到佛所。五体投地白佛言。世尊。当为弟子忏悔。佛言。忏悔无益。一切沙门婆罗门皆知汝行非法。若顺吾言者。四禅四空定诸通解脱皆可得耳。不用吾言者。于此诸善不可得也。复更殷勤三请世尊。世尊然后受其忏悔。复为说法。若人造恶能改悔者。于佛法中多所利益。如是广说。此拔陀波罗比丘数数犯罪。诸比丘见已谏之。闻谏之言不以经怀。便以余言而答。佛向拔陀波罗比丘言。有一比丘犯种种罪。诸比丘见已如法谏之。此比丘更以异言而答。复生嗔恚。佛言。此比丘虽不受谏亦应谏之。所以尔者。欲使诸沙门婆罗门一切广闻。亦欲使其现身长夜受苦。佛说曰。调伏法有三种。一呵责二别住宿三当令依止有智慧者乃至驱出。是人因是事调伏。心意柔软顺僧法而行。能使大众欢悦。是名调伏法。舍摩陀者(秦言名灭)何等比丘事应灭。若有比丘随善法能除四受。一者欲受二者见受三者戒取受四者我取受。能除此四受。随顺行出离法。善者念念增进。恶者舍之。是名为灭。又复灭者。从现前毗尼乃至敷草毗尼。灭此七诤亦名为灭也。不应灭者。若比丘成就五法起斗诤事。一者常乐在家。二者常乐依国王大臣。三者不乐依僧。四者亦不依法。五者众僧所行事皆不顺之。若比丘成就此五种事。所有诤事不应灭之。复有比丘成就五法。有诤事起应当灭之。何等为五。五者与上五事相违。即是五也。成此五法。所有诤事应当灭之。又复灭者。随僧行法能随顺之。所有善法日日增进。其所行事常为解说。若有事能令僧喜行之不惓。是名灭法。舍戒法。若比丘愁忧不乐不乐梵行。欲归家不乐比丘法。于此法中生惭愧心。意欲成就在家之法。出家法于我无益。在家法益我甚好。意欲舍比丘法还家。作如是语。我舍佛法僧和上阿阇梨梵行毗尼波罗提木叉戒。如是广说。应当知是为舍戒。不舍戒者。若痴狂心乱乃至口噤不能言者。不名舍戒。如是广说。应当知。戒羸者。比丘生念。不乐梵行乐在外道乃至作僧祇人。是名戒羸。戒羸事如上文中所说。说戒法。应如法集僧。僧集已应当一白羯磨。不应二三四白羯磨也。僧作法事如法取欲皆应默然。不应遮也。僧若不满足者不应说戒。僧若满足应广说戒。时不中略说也。时者。无留难名为时。尔时世尊。于静房中心念。我为诸比丘制戒。说波罗提木叉。乃至能使人得四沙门果。波罗提木叉者。戒律行住处。是名波罗提木叉义。尔时诸比丘用歌音诵戒。佛言。不应当以高声了了诵戒。歌音诵戒有五事过。一心染着此音。二为世人所嫌。三与世人无异。四妨废行道。五妨入定。是名五事过也

佛在世时。诸比丘日日说戒。众僧皆生厌心。佛闻即制十五日一说戒。尔时于一住处说戒。僧坊既大。诸比丘远者不闻。是以如来为诸比丘制法。僧众若多僧房亦大者。应当正中敷座。说戒者在此座上。当高声了了说使得闻之。尔时诸比丘在一住处。僧众虽大无诵戒者。法事不成。世尊闻已告诸比丘。从今已后。有出家者至五腊要诵戒使利。若根钝者乃至百腊亦应诵之。若故不诵。若先诵后时废忘。若复钝根不能得者。此等三人有四种过。一不得畜弟子。二不得离依止。三不得作和上。四不得作阿阇梨。是名不诵戒者罪。有八种难得略说戒。一者王难二者贼难三者水难四者火难五者病难六者人难七者非人难八者毒蛇难。有此八种得略说戒。略有五种。一者说戒序已。称名说言。四波罗夷。汝等数数闻。乃至众学亦如是说。第二略者。从戒序说四事竟。后亦称名如前也。第三略者。从戒序说至十三事。后者称名亦如前二。第四略者。从戒序说至二不定。余者称名亦如前三。第五略者。从戒序说乃至尼萨耆波逸提。后者称名亦如前四。尔时有众多比丘。在一处皆根钝无所知。有贼难不得就余寺说戒。法事不成。佛闻已教诸比丘。汝等当略说戒。诸恶莫作诸善奉行自净其意是诸佛教。是名略说戒。不成说戒有四种。非法群共说戒不名说戒。非法齐集此亦不名说戒。群共此亦不成说。应一白处二白。此亦不成说戒。若有比丘于说戒时。三四别共私论起贡高心。因说戒论义生于诤讼。如此说戒不成说戒。不成有二种。一斗讼故说戒不成。二恶心故增长烦恼。是二皆不成说戒。此事布萨犍度中应当广知。是处应说。何者若比丘未犯罪心中生念。云何不犯众恶而得生善。即诣持法持毗尼持摩得勒伽藏者问之。尊者。何者是法。何者非法。何者可说。何者不可说。彼师闻此语。即次第为说法。如法说不如法。不如法说如毗尼。如毗尼说非毗尼。如非毗尼说轻。如轻说重。如重说粗恶语。如粗恶语说非粗恶语。如非粗恶语说犯。如犯说不犯。如不犯说残。如残说不残。如不残说应。如应说不应。如不应说制。如制说不如制。如不如制说所说。如所说不如所说。如不如所说齐量。如齐量说不齐量。如不齐量说分别。如分别说不分别。如不分别说比丘法。食在界内无净厨不得食。何以故。佛游诸聚落。见诸比丘共诤。佛问比丘诤何等事。比丘白佛。昨日食已有余残食。是故诤之。佛言。从今已去。宿食及在大界内食。无净厨者一切不得食。众僧住处初立寺时。众僧齐集。应先羯磨作净厨处。后羯磨众僧房舍处。若当时忘误不羯磨作净厨处者。后若忆还解大界后解小界。先羯磨净厨处。结界法。先结小界后结大界。共宿食残宿食。众僧小界内所作食。僧自手作食。若僧值世饥馑得食。余时不得食。受食已檀越来请。彼中食即足。应以此食转施余僧。彼僧得已应作残食法而食。复有诸大师。为国主所重请食。彼中食足。余残将来施同住处僧。僧怖不食。佛言。听汝作残食法食之无过。有比丘外得果来即与净施主。施主值世饥馑不还本主。佛因而制戒。从今已去。若饥馑世得自畜而食。池中果一切果亦如是。畜钵法。除铁钵瓦钵。余一切钵皆不得畜。色中上色衣不应畜。何者锦纹鬘花如此等衣不中畜。应说者。有比丘生念。云何修诸善法。往诣诸智者所。问言。云何名犯。云何不犯。云何忏悔。因何事而犯。彼师随顺毗尼为说犯不犯。如是广应当知。问者闻师说已。心中无复忧苦。随顺师教如毗尼而行。心得清净随顺善法。更无余念。是名应说。又复应说者。比丘生念。厌患生死。云何出离修道而得涅槃。生此念已。即到智者边问之。尊者大德。云何修四禅乃至四果。彼师次第为说。乃至阿罗汉果。是名应说。云何名为非法说。彼师为问者说。法说非法非法说法。乃至所说名非所说。不所说名所说。限量作非限量。非限量作限量。分别名不分别。不分别名分别。从食钵乃至饮皆亦如是。又不应说者。有比丘问智者。云何得初禅乃至四果。智者为说。汝之所问得过人法。汝犯波罗夷。是名不应说。往时有比丘。字难提伽。失性。于众僧布萨日。或忆或不忆。忆时来不忆不来。诸比丘往白世尊。佛告言。但与此比丘作失性白二羯磨。虽不来法事成就。此布萨犍度中广明。此比丘还得本心。心中生疑。本失性羯磨为舍不舍。往白世尊。佛言。得心者可舍之。诸比丘复疑。后还失心此复云何。佛言。还作失性羯磨。后得本心还舍。比丘受人施不如法。为施所堕。堕有二种。一者食他人施不如法修道。放心纵逸无善可记。二者与施转施施不如法。因此二处当堕三途。若无三途受报。此身即腹坏食出。所著衣服即应离身。应施者。若父母贫苦。应先授三归五戒十善然后施与。若不贫虽受三归五戒不中施与。复有施处。一者治塔人。二者奉僧人。三者治僧房人。四者病苦人。五者婴儿。六者怀妊女人。七者牢狱系人。八者来诣僧房乞人。如此等人或中与或不中与。治塔奉僧治僧房人。计其功劳当偿作价。若过分与为施所堕。施病者食。当作慈心随病者所宜而施与之。若设病错误与食。为施所堕。婴儿牢狱系人怀妊者。如此人等当以慈心施之。勿望出入得报。当为佛法不作留难。如此等心施之如法。若不尔为施所堕。诣僧房乞。若自有粮不须施之。施者为施所堕。若无粮食施之无过。若比丘不坐禅不诵经。不营佛法僧事。受人施为施所堕。若有三业受施无过。若前人无三业。知而转施与者。受施能施。二皆为施所堕。若比丘食檀越施以知足为限。若饱强饮食者为施所堕。若比丘作憍慢意自饮食者为施所堕。何以故。世尊。于长夜中常赞叹限食。最后乃至施持戒者。能受施能消施也。如佛说曰。施持戒者果报益大。施破戒者得果报甚少。如佛说偈。宁吞铁丸而死。不以无戒食人信施。若食足已更强食者。不加色力但增其患。是故不应无度食也。羯磨者。有四因缘羯磨得成。一如法二僧齐集。三如法白一处白一。乃至白四处白四。白四处不三二一。白四者众僧不来者与欲。众中无说难者。此四法成就。是名如法羯磨。此事章卑犍度中当广知。非羯磨者。四事不成不名羯磨。毗尼者。有种种毗尼。有犯毗尼。有斗诤毗尼。有烦恼毗尼。比丘毗尼。比丘尼毗尼。少分毗尼。一切处毗尼。从犯毗尼。出罪毗尼。又毗尼能灭不善根。能灭障法。能灭五盖恶行。名为毗尼。复有毗尼。能发露随顺修行舍恶从善。名为毗尼。云何名为发露。所犯不隐尽向人说。名为发露。此事灭罪犍度中广说。随顺者。随顺和上所说。随顺阿阇梨所说。乃至众僧所说皆不违逆。是名随顺。云何名为灭。能灭斗诤故名为灭。云何名为断。如断烦恼名为断。烦恼毗尼。断烦恼毗尼中应当广知。又比丘说言如我所知见者。欲不能障道。余比丘谏言。莫作是语。欲者是障道之本。所以知之。世尊种种为欲作喻。欲如火坑乃至刀喻等。云何言不障当舍此见。诸比丘谏时。受谏者好。若不受诸比丘当为作白四羯磨忆之。是名弃舍恶见比丘过语。诸比丘集作法事。不如法众中。有见众僧作法事不成。此人若有三四五伴。可得谏之。若独一不须谏也。何以故。大众力大或能摈出。于法无益自得苦恼。以是义故。应默然不言。若入僧中应立五德一者常起慈心如扫叉喻。好恶平等皆欲令得善。二者于诸上座常起恭敬谦下之心无得慢也。三者于诸下座勿得谈论而共交由。四者若僧集作法事时。大众应请一知法者说法。五者若众不请。应语众令请知法说。舍利弗亦成就上五种入僧法。云何名白。迦叶。随比丘说言众皆听许默然故。名为白。白一处是。如初度沙弥。受大戒时白僧。白僧已差教授师。将出家者屏猥处。问其遮法。为欲说波罗提木叉。若自恣若钵破更受。有一比丘字阐陀。始欲犯戒。诸比丘知已谏之。此比丘语诸比丘言。汝等何所说。共谁言谁有犯者。云何名犯。作如此异语。诸比丘白佛。佛言。与此比丘作异语别住羯磨。阐陀比丘后时复更轻弄诸比丘。诸比丘语。莫坐便坐。莫起便起。莫语便语莫来便来。诸比丘白佛。佛言。为作调弄白一羯磨。如此等及余未列名者。皆名白一羯磨。云何名为白二羯磨。白者。大德僧听某甲房舍隤毁。若僧时到僧忍听。僧与某甲房舍与某檀越修治及与营事比丘。白如是。大德僧听。某房舍某房舍无檀越隤毁。僧今与某房舍与某檀越令修治及营事比丘。若僧忍者持某房舍与某檀越令修治及营事比丘。僧忍者默然不忍者便说。僧已忍。持某房舍与某檀越及营事比丘竟。僧忍默然故是事如是持。营僧事人分亡比丘衣钵。受迦絺那衣舍迦絺那衣。一切结界不离衣宿法。先结大界后结不失衣界。先舍不失衣界后舍大界。教授比丘尼自恣。如是等众多。皆白二羯磨。白四羯磨者。白已三羯磨。是名白四羯磨。一者呵责。二者有比丘共白。衣斗。众僧劝令与檀越忏悔。摈出灭摈别住还行本事行摩那埵行阿浮呵那乃至七灭诤。有比丘大德。为巨富信心檀越所重。请其多年。随其所须供给与之。傍人说曰。此长者巨富。由比丘故大损其财。痴失性比丘尼受戒已。来僧中乞戒。犯戒事覆钵默摈。如是等及余未列者。皆白四羯磨。别住有二种。若有外道来入佛法中求出家者。僧应与四月别住白四羯磨。又复别住者。十三种种性。于僧残中若犯一一。不发露覆藏。后时发露。僧与白四羯磨别住。以何义故名为别住。别在一房不得与僧同处。一切大僧下坐不得连草食。又复一切众僧苦役。扫塔及僧房。乃至僧大小行来处。皆料理之。又复虽入僧中。不得与僧谈论。若有问者亦不得答。以是义故名为别住。行本事者。别住时未竟。又复更犯。复从众僧乞别住。僧还与本所覆藏日作白四羯磨。故名本事。云何名为摩那埵。摩那埵者。别住苦役与前住无异。但与日限少有异耳。若犯时即发露者。亦六日六夜行之。摩那埵者(秦言意喜)前唯自意欢喜。亦生惭愧。亦使众僧欢喜。由前喜故与其少日。因少日故始得喜名。众僧喜者。观此人所行法不复还犯。众僧叹者言。此人因此改悔。更不起烦恼成清净人也。是故喜耳。阿浮呵那者。清净戒生得净解脱。于此戒中清净无犯。善持起去。是名阿浮呵那义。有犯不犯。犯者三种人犯。一不痴狂。二不散乱心。三不为苦痛所逼。是名为犯。复有犯者。一切所犯轻重。随彼佛所制处广应当知。不犯者亦如是。随何篇所明。彼中广应当知。决了犯不犯义。一切当毗尼中推之。从初法非法不知。乃至忏悔不忏悔不知。此二十二种与人受具。皆名为犯。欲决断一切不犯者。应当毗尼中推之。有能成就二十二法者。应与人受具。是名不犯。有比丘犯非比丘尼犯。又比丘尼犯非比丘犯。又比丘比丘尼犯。非式叉摩尼犯。又比丘比丘尼犯。非沙弥沙弥尼犯。或有出家五众犯。非优婆塞优婆夷犯。复有七众皆犯。何等名为比丘犯非比丘尼犯。如阿练若住处所行法。比丘尼不行。比丘犯非比丘尼犯。有一比丘在阿练若处住。懈怠不能瓶中盛水。亦复无食。后时有贼来。从索水索食皆不得。嗔恚即打此比丘。如来知已后与制戒。阿练若处住者。皆应瓶盛水残食少多留之。贼来索可与耳。如是等皆比丘法。非比丘尼所行法。何者比丘尼犯非比丘犯。若比丘尼独渡水独行入村。离众独宿或独随道行。或独使男子剃发。或独比丘经行处行或结加趺坐。如是等所犯。比丘尼犯非比丘犯。何者名比丘比丘尼犯非式叉摩尼犯。若比丘比丘尼不受食而食。比丘比丘尼犯。非式叉摩尼犯。何等三众犯。非沙弥沙弥尼犯。除沙弥沙弥尼戒已。犯余戒者是三众犯。非沙弥沙弥尼犯。何者五众犯。非优婆塞优婆夷犯。除五戒已。犯余戒者是五众犯。非二众也。何者名七众都犯。七众皆持五戒。七众若犯此五戒。皆同犯也。有犯冬有非春夏有。有犯春有非夏冬有。有犯夏有非冬春有。何者冬有非春夏有。冬四月已满。应舍功德衣。若不舍过一日犯突吉罗。此犯冬有非春夏也。何者春犯非夏冬有。春一月残。应乞雨浴衣。若过一月乞。若乞过长得。得已不十五日用。此三事皆犯尼萨耆波逸提。何者夏有非冬春有。比丘法应夏安居。安居有二种。前后若不安居。复不自恣。此犯夏有非冬春有。是故此三所犯。各当时而有。是名犯不犯。何者轻。犯波罗提提舍尼。此罪轻。或向一人说。若自心念。皆能灭也。自种性者。若比丘畜人皮革屣食人肉。若畜食者偷兰遮。种性者。肉及皮即是人身故言种性。突吉罗者。不摄身威仪得突吉罗。恶口者。说言汝是工师技儿诸根不具。如此说者得波逸提。是名恶口轻犯也

重者。波罗夷僧伽婆尸沙。此二边所得偷兰遮重也。或有所犯。于比丘重比丘尼轻。或有所犯。于比丘尼重比丘轻。比丘重者。故出精比丘得僧伽婆尸沙。比丘尼得波逸提

比丘尼重者。比丘尼淫欲心盛。手摩男子屏处。男子亦摩比丘尼屏处。俱着触乐。比丘尼犯波罗夷。若比丘尼。知比丘尼犯重。覆藏不向一比丘尼说。亦得波罗夷。若比丘不随顺僧法。僧与呵责羯磨。又比丘尼言。此比丘随顺僧法。种种言说与比丘同心。诸比丘尼谏言。不须往反言语相助。不受尼谏。往返言语相助不绝。尼僧与作白四羯磨。此尼得波罗夷。比丘尼复有八事。犯波罗夷。一者尼与男子互相捉手。二者便更互捉衣。三者共男子静屏处并坐。四者屏处共语。五者屏处身相触。六者尼共男子独道行。七者道中露身相触。八者至共期行不净处。若尼具前七事时。犯偷兰遮。满八事犯波罗夷。此是比丘尼重比丘轻或有犯重报轻。或有犯轻报重。或有犯重报亦重。或有犯轻报亦轻。有犯重报轻者。有比丘作使和合男女。若和合者得僧残。不和合得偷兰遮。若比丘私作房。不白众僧乞羯磨。未成犯偷兰遮。成已犯僧残。是名犯重报轻。犯轻报重者。若比丘嗔恚心打阿罗汉。或复欲心摩触阿罗汉起于染着。乃至打佛于佛上起染欲心。或有恶口骂阿罗汉及佛。毁呰形残诸根不具。此得波逸提。是名犯轻报重。犯重报重者。波罗夷及二无根谤圣及凡。得僧残罪。二无根者。一比丘嗔心遣妹尼弥勒。往谤阿罗汉陀骠摩罗子。语言。大德共我行欲。此谤他比丘。随路行见二羊共行欲。心中生念。前谤既虚。今以母羊为弥勒尼。翁羊为陀骠摩罗子。生此念已。来到寺中向众僧说。前时不实今日实见。诸比丘即谏言。此阿罗汉莫以恶言谤之。答言实尔听我所说。诸比丘听之。说言。我向者路中行。见二羊共行欲。翁羊为陀骠摩罗子。母羊即是弥勒尼。诸比丘闻此言。即共论议。此二皆无根。是名二无根谤。一污他家。二坏法轮僧方便。三随坏法轮僧徒众。四恶性不受人谏。得僧残罪。此是犯重报亦重。犯轻报亦轻者若比丘入聚落不忆念摄身四威仪及口四过。忘误犯者。一人前忏悔波逸提突吉罗。若比丘尼犯罪。先忘不发露。布萨时始忆。若欲发露恐乱僧听戒心中默念。说戒已当忏悔。如此等皆犯轻报亦轻。有三种犯。一者事重心轻。二者事轻心重。三者事心俱重。事重心轻者。若比丘在尼寺中为尼说法。日已没心中生疑。谓日未没说法。此是事重心轻事轻心重者。比丘在尼寺说法。日未没意谓日已没说法。此是事轻心重。心事俱重者。比丘在尼寺说法。日已没心作没想。此是心事俱重。心轻事重心重事轻。是二俱得突吉罗。心事俱重得波逸提。波罗夷者。犯名虽同。果报有异。所以者何如淫处非一畜生及人。人中有出家有不出家。又不出家中有二种。有持戒不持戒。出家中有五种。亦有持戒不持戒乃至圣人。有如是差别。犯名虽同果报有异。第二波罗夷者所盗处非一。有出家在家。在家人中盗取他物亦有差别。出家人中盗亦有差别。是三宝中盗亦有差别。是故波罗夷名虽同果报有异。第三波罗夷者。天及人乃至圣人如此人等。若断命根得波罗夷。断名虽同果报亦异。第四波罗夷者。亦有差别。向在家人说得过人法重。向出家人说得过人法轻。是故得罪名虽同。果报不同也

毗尼母经卷第二毗尼母经卷第三

        失译人名今附秦录

云何名残。罪可除。是以故名残也云何无残。四波罗夷。罪不可除。是故名无残。云何名粗恶犯。如人欲作四波罗夷事。身所作及口所说无有惭愧。因此二处必成波罗夷事。是名粗恶。又复一处浊重。僧伽婆尸沙边成婆尸沙方便是也。是二偷兰名浊重犯。何者非粗浊重。波逸提波罗提提舍尼自性偷兰遮突吉罗。如此等亦是不善身口所作。但非大事方便。以是义故。非粗恶浊重也。沙弥沙弥尼犯波罗夷。得突吉罗不可忏也。有犯须羯磨有不须羯磨。有犯须羯磨者。如十三僧残乃至恶口。此犯须羯磨得除。不须羯磨者。三波罗夷是。一波罗夷须羯磨得除。何者如难提伽比丘。常空静处坐禅。有天魔变为女形在难提前。难提欲心炽盛随逐此女。魔即隐形。见一死马共行不净。行已即悔。脱袈裟怀抱。垂泪举手呼天大唤。我非沙门非释子。到世尊所。如其所犯向世尊说。佛知此比丘发露心重后更不犯。即集诸比丘为作白四得戒羯磨。所以得戒者。一此人见佛。二发露心重。是以得戒。虽还得戒。一切大道人下坐。僧作法事尽不得同。是名有须不须也

尊者萨婆多说曰。若比丘得世俗定从四禅起。天魔作女形惑乱其心。此比丘即共行不净。行已即悔无覆藏心。念念相续无一念隐。亦心中不乐舍法服。如此人者。应当从僧乞灭除波罗夷羯磨。僧与此人白四除波罗夷罪羯磨。此人得戒已。如僧告敕尽形奉行。不得作和尚阿阇梨。不得作教授尼师。僧集时不得说戒。一切法事得听。在大僧下坐。不得与僧连草食。如尊者婆奢说曰。若比丘得世俗定。从定起已。或痴狂心乱。或为方道。乃至鬼所惑。因此行不净行。行已即悔。发露无覆藏心。复不欲舍法服。应僧中乞除波罗夷罪羯磨。奉僧所敕。尽形寿不得作和尚阿阇梨。不得作教授尼师。大众集时不得说戒。亦不得为人作羯磨。一切大僧下沙弥上坐。不得与僧连草食。有一比丘字禅那陀。在空闲处禅定。诸檀越日日送食。中间无男子。有一女人常为送食。常来不已。便生染心共行不净。行已即悔。脱三衣着肩上露身而走唱言贼贼。边人问之。有何等贼。答言。为烦恼贼所劫尽。向诸檀越及众僧发露无覆藏心。僧中智者语言。有尊者波奢善持毗尼。能除汝罪。此比丘即到波奢所。如其所犯向波奢说。波奢语言。汝欲除罪能用我语不。答曰无违。波奢遣人作大火坑满中炎火。语言。汝欲除罪者可投此坑中。波奢先共余比丘论。若比丘直入坑者汝等捉之。此比丘用波奢语直欲入坑。边人捉之。波奢知此比丘心实。即为作白四羯磨除此波罗夷。此比丘从今得羯磨已。名为清净持戒者。但此一身不得超生离死证于四果。亦不得无漏功德。然障不入地狱耳。喻如树叶落已还生树上无有是处。若犯初篇得证四果获无漏功德亦无是处。此人虽与僧同在一处。但僧与其万途隔也。如上所说。犯戒有七种。一波罗夷。二僧伽婆尸沙。三尼萨耆波逸提。四波逸提。五偷兰遮。六波罗提提舍尼。七突吉罗。波罗夷者。不生善根。永不可忏。亦无羯磨可得除罪。有偷兰遮。不可羯磨除罪何者。如提婆达多出佛身血是。此偷兰遮永不生无漏善根。亦无羯磨可除罪也。有波逸提。不生善根亦无羯磨可得除罪也。何者如比丘嗔心欲断佛命打佛。得波夜提不可忏也。有突吉罗。不生善根亦无除罪羯磨。何者沙弥沙弥尼式叉摩尼。四波罗夷中若犯一。此罪不可忏也。是故有犯须羯磨有犯不须。如上说也。羯磨已复羯磨者。僧残是也。羯磨已更不羯磨者。尼萨耆波夜提九十二波夜提等是也。欲发露者要具五法。一整衣服。二脱革屣。三胡跪。四合掌。五说所犯事。如是应忏悔。若不尔不名忏悔。有五种犯易除。一者有罪。应一比丘前除。若无比丘。心中立誓亦可得除。二者犯突吉罗。若恶口向一人说得灭。三者如波夜提自性偷兰。一人前悔亦得除灭。四者僧残边偷兰波罗夷边偷兰。四人已上众中羯磨除之。僧残如上说。五者从地至地。羯磨受戒犍度中。当知有总名说。何者是从波罗夷乃至七灭诤。若有所破皆名为犯。是故名集犯。谏法者。若有比丘犯罪。余比丘或见闻疑。应先白上座及僧。上座僧若听。复应问犯罪者。今欲谏汝为听不。若上座及僧犯事者与欲得谏。若二俱不听。若一听一不听。皆不得谏。谏者要内立五德然后谏之。一者知时而谏。二者实心非虚伪心。三者为利益故。不为不利益故谏。四者柔软言辞非粗恶语谏。五者慈心故谏。非不见过故谏。谏者。众僧集已次第坐竟。有事者别一处坐。谏者从座起。诣彼犯罪人所。如其所见闻疑事。事有三处。一者波罗夷僧残及偷兰。此名为戒二者破正见住邪见中。三者从波逸提乃至恶口。名之为行。见闻疑于此三处起。谏者或屏处或众中。语言。汝当忆念本所犯。不得同僧作法事。应出去。如法除罪已。后还当入僧。是名为谏忆念也。有谏法不成者。众僧集已。犯罪者别处坐。谏者问有罪者听谏不。答言听。有事者听已即起去。此不成谏。谏他者问已即去。六群比丘是。若问犯罪者。问已即去。不成谏也。何时名谏时。众僧齐集与欲。犯罪者现前与欲。谏者现前。如此等俱名为谏。时尊者萨婆多说曰。谏者语犯罪者言。我念汝语汝谏汝。犯罪者答言。汝念我语我谏我善哉。受谏者。不应受五种人谏。一者无惭无愧。二者不广学。三者常觅人过。四者喜斗诤。五者欲舍服还俗。如此等五人。不应受其谏。是名不受谏。佛语诸比丘。谏者。于犯罪人边取欲竟。不应舍去。去者得突吉罗罪。自今已去。谏者与犯罪人。共期一处僧伽蓝中。若集饮甜浆若食粥。及布萨自恣。一切法事集处。应僧前谏已舍去。若无大众。一二知见三藏比丘前。谏之舍去。尊者弥沙塞说曰。止语羯磨者。若有比丘。一破戒二破见三破行。此人众僧应立五德故谏。若性不受人语。兼恃聪明多智徒众甚大。复恃国王大臣之力。不受谏者。众僧应当与作不语羯磨。是名止语。止不说戒者。佛告诸比丘。众中若有不清净者。止不应说戒。六群比丘闻佛语已。即遍诸寺唱言。佛止不听说戒。世尊告曰。吾不止清净比丘说戒。若七聚中乃至恶语。僧集时众中。有犯者止。无犯者便说。是名止说戒止自恣者。佛告诸比丘。众中若有不清净止不应自恣。当作止自恣羯磨。应检校不清净者。若重驱出。轻者令其忏悔。然后自恣。若此不清净者。自恃聪明多智。亦恃徒众国王大臣力。不可驱出者。当至后自恣。后自恣时到。犹不出者。众僧可别自恣得清净耳。云何名波罗提木叉。波罗提木叉者。名最胜义。以何义故名为最胜。诸善之本以戒为根。众善得生故言胜义。复次戒有二种。一出世二世间。此世间者。能与出世作因故言最胜。复次戒有二种。一者依身口二者依心。由依身口戒得依心戒。故名为首。是波罗提木叉布萨犍度中当广说。复有五种广略说戒。说戒序四事竟。余戒皆言汝等数数闻。第二说戒序四事十三事竟。余戒皆言汝等数数闻。第三说戒序四事十三事二不定竟。余戒皆言汝等数数闻。第四说戒序乃至三十事竟。余戒皆言汝等数数闻。第五如上广说。比丘法要诵波罗提木叉。若不诵者。有诵毗尼处。三时就彼处住。何以故。若所犯所疑忏悔解疑得除罪也。是故佛制。比丘要诵波罗提木叉。何故名布萨。断名布萨。能断所犯。能断烦恼。断一切不善法。名布萨义。清净名布萨。云何名布萨羯磨。众僧欲布萨时。众中最小者。应扫堂敷坐具取香水洒地燃灯如此诸事皆名布萨羯磨。云何名自恣。比丘夏坐已讫。于智慧清净比丘前。乞见闻疑罪。所以乞者。夏九十日中欲明持戒律及与余善皆无毁失。是故安居竟始得自恣名。何故佛教作自恣。一各各相课。二各各相忆念。三互相教授。四各各相恭敬。五语皆相随。六皆有依非无依。是故名自恣。自恣羯磨者。众中最下座。应扫堂敷敷具燃灯取香火。如此事皆名羯磨。若界里不羯磨净。厨处宿食沙门皆不得食。当于尔时。佛游于跋利耆国。展转游行到毗离国。闻诸比丘声高。佛问阿难。此众僧诤何等事。阿难即往看。见比丘积聚食甚多。来白佛言。世尊。旧住比丘沙弥及净人。欲办食与客比丘。是以声高。佛即告阿难言。汝往语诸比丘。从今以往。非僧集羯磨净厨界内宿食皆不得食。复于一时。世尊在波罗奈。时世饥馑。众僧皆积聚谷米界外安止。人皆盗持去。诸比丘展转相语。往白世尊。佛言。俭年听谷米在界里。乃至药草亦如是

复于一时。世俭谷贵人无礼义。诸比丘在界外熟食。有力者皆抟撮持去。诸比丘白佛。佛言。听汝等界里熟食界内食。复为沙弥净人分减持去。复白世尊。佛言。听诸比丘手自熟食

尔时世尊。在舍卫国。有一病比丘常食粥。檀越为日日送。值一日中城门闭。不得来比丘失食。佛即为此病比丘。界里白二羯磨结净厨处。听此净处煮粥食之。时诸比丘生疑。谓此比丘食共宿食界里熟饭食手自作食。佛言。非宿食非界里熟食非手自作。乃至药草亦如是

尔时世尊。在波罗奈国。时世饥荒。诸比丘随路而行。见熟果皆落在地。不得自取待净人顷。后有白衣来至即取持去。比丘白佛。佛言。听汝草覆头待净人。草覆头待净人顷。复有白衣来披草见之即取持去。复白世尊。佛言。听汝手自取之持去至净人所著地还如法受食之。诸比丘白佛。齐谷贵已来。愿世尊。听诸比丘食残宿食手自作食自得取果。佛言齐谷贵已来可尔若比丘中前得食。更至余处得食已足。还来以此食施施主。时世饥俭施主即食。比丘往白佛。昨日有残食。与施主望后日得食。施主即自食。佛言荒年听无施主得自举食。时有大德众僧。为国王大臣所重。诸檀越请入聚落食。食已余残持来到寺。与余比丘欲食者。若世俭时不作残食得食至丰时与施主作残食法然后得食。若于后时谷贵人民饥馑。诸比丘食后得果欲食者不作残食法亦得食。后丰已不得。俭时若比丘。得种种草根及药根可食者。无施主得自举食。后丰时不得。云何名受迦絺那衣如法。众僧齐集现前无留难。檀越施新如法衣应受。如法者。非锦衣非上色衣。是名如法衣。界内众僧病者营三宝事者与欲。然后白二羯磨。是名如法。云何不名受。非法群品界外众僧。是名不受。舍迦絺那衣法。五月已满。众僧齐集。现前无留难者。界内众僧如法与欲。白二羯磨不作余羯磨。是名如法舍。有八种舍迦絺那衣。一者受衣已后出园是名去后舍。二若比丘受功德衣已。出寺游行求索在外。闻僧已舍衣竟。作是念。我当更求余衣。是名尽时舍。三受功德衣已。出外游行讫。闻寺上已舍衣竟。作是念。我今更不求衣。是名究竟舍。四若比丘受衣已出外求衣。得衣已贼即盗衣。闻寺上已舍竟。是名失时舍。五若比丘受衣已。出外乞索望得衣。乞不得。闻寺上已舍迦絺那衣。是名希望断时舍。六若比丘受衣已出外求索。闻寺上已舍。作是念。我当更求三衣。是名闻时舍。七若比丘受衣已。出界外行望得。即还经多日回在界外。闻寺上已舍衣。是名在界外舍。八若比丘受衣已出外求衣。若得不得即来还寺及僧舍衣。是名如法舍。除此八种已非法群品。皆不名受亦不名舍

分亡比丘物。衣钵坐具针毡綖囊拘执衣毛深三指伞盖剃刀。是名可分众具。尊者迦叶惟说曰。分亡比丘物法。先将亡者去藏已。众僧还来到寺。现前僧应集。集已取亡比丘物着众僧前。遣一人分处可分不可分物。各别着一处。三衣与看病者。余物现前僧应分。若有奴婢应放令去。若不放应使作僧祇净人。象驼马牛驴与寺中常住僧运致。此亡比丘。若有生息物在外。应遣寺中僧祇净人推觅取之。得已入此寺常住僧。瓦铁所作应可分物。铁杓铁镯[金*(亡/(睪-幸+(月*奼)))]斤斧五尺刀户钩针筒刀子剪刀铁杖香炉火炉槃伞盖盖茎香筒。如是等广知。大铜盂小铜盂镯[金*(亡/(睪-幸+(月*奼)))]铜杖。如是等名数皆如铁也。何故名重衣。重有二种。一者价重。二者能遮寒。故名为重。衣者要净受持。不净不得。净有二种。一染已着色名为净。二者着色已安三点。亦名为净。若衣作已浣染三点。诸檀越见知是沙门服非外道衣。是故名为重衣。尔时尊者毕陵伽婆蹉。眼痛随路而行。两脚相跋东行西倒不能进路。佛遥见之问诸比丘。何以故。尔时诸比丘白佛。眼痛不见道故。尔时佛言。听着革屣。尊者毕陵伽婆蹉。为国人所重。或用罗网而施者。或与象马骆驼车乘。及作一小寺施者。如此等施。佛皆听受之。尊者眼痛故。檀越为作琉璃[槎-工+目]诸比丘白佛言。唯愿世尊。听毕陵伽婆蹉畜此[槎-工+目]治眼痛。佛言。此物价重。为病痛故听畜。复有诸檀越。持种种铜铁瓦瓶铜盆铜盔如是等重物施。佛听畜之。若有人施柔软极价好衣。听作净施畜之。复次师所有重物弟子不得自取。僧与得取。弟子不持此物着僧前。僧不得自取羯磨分之。何以故。此物属四方僧故。何故复名重物者。前明重物就衣得名。今明重物就物得称。不应分者。若私有寺及寺中所有田业果树及象马骆驼牛驴乃至床榻盆瓶养生之具。皆亦如是属四方僧。若四方地外起大堂小房。此中所有物。现前僧不得分。亦属四方僧也。此事衣犍度中应广知。若粪扫衣在四方墙内者。比丘不应取也衣若篱上及在城堑中亦不应取。若穿墙作孔出死人处墙外衣不应取也。佛所以制者。时世大疫。死者无数。不能得远着冢间。穿墙外安之。王家有制。不听墙外安尸。禁防者即告令言。谁持此死人衣去。当使负死人着冢间。诸人答曰。昨来沙门取之。禁防即敕沙门。负死人着冢间弃之。佛以是因缘制比丘不听取也。冢间死尸未坏者。此尸上衣不应取也。死尸上起塔。塔上所悬衣不应取。如是等粪扫衣皆不应取。有一比丘独别处住得病命终。此比丘所有衣钵资生之具。应属现前僧。有一看病比丘不知法。持此衣物往诣世尊。佛即教言。汝持此衣物诣僧从僧乞。从上座一一应问。得几许分当施我。一一乞乞已。众僧当为作白二羯磨施之。所以佛听乞者。此人有看病之功。是故佛听乞耳。复有所不应分物。何者存在时所有经律。应分处与能读诵者。若不及分处。现前僧应与能读诵者。此物不应分卖也。若比丘独在聚落中白衣舍命终。后有比丘比丘尼式叉摩尼沙弥沙弥尼随。何者先来檀越。应用此物与之。若无来者。随何寺近应施近寺众僧。何者名养生之具。人所须是。何者非养生之具。非人所用。名非养生。乃至畜生所须。名为养生。非畜生所须。名非养生。若比丘取他养生物。要语他。他与得取。不与不得取。畜生养生具。除解语者一不得取。解语者当问。与得取不与不得取。比丘正应所畜物。钵三衣坐具钵针綖囊及瓶盆是。所不畜者。女人金银一切宝物一切斗战之具酒盛酒器。如此等物不应受畜。难陀比丘淫欲炽盛。有女为其作礼。即失不净女人头上难陀及女二皆惭愧。即往白佛。佛教作囊盛之。佛听畜刀子。一用割皮。二用剪甲。三用破疮。四用截衣五用割衣上毛缕。六用净果。乃至食时种种须故。是以听畜。剃发法。但除头上毛及须。余处毛一切不听却也。所以剃发者。为除憍慢自恃心故。若发长不得用剪刀甲。应用剃刀除之。佛所制剪刀者。六群比丘用剪刀剃发。诸比丘白佛。佛因六群制不得用剪刀。若比丘头上有疮。用剪刀绕疮甲之涂药。比丘不听作利木刀刮汗却毛也。若断一毛一突吉罗。除头上毛。若断一一偷兰遮。是名剪发法。又复剃发者。如罗睺罗童子。佛尔时从尼拘陀树下来向迦维罗卫城乞食。时瞿夷共罗睺罗在高楼上。见佛来入城。瞿夷指佛语罗睺罗言。此是汝父。罗睺罗即下楼诣佛作礼。佛手摩罗睺罗头已为极乐。佛问罗睺。汝乐出家不。罗睺答言。乐欲出家。即将罗睺至尼拘陀精舍。告舍利弗。与罗睺作和尚。舍利弗白佛。云何教出家。佛告舍利弗。先与剃发着袈裟。教胡跪合掌。然后授三归五戒沙弥十戒。此是初剃发着袈裟受三归五戒十戒之始。尔时白净王。闻罗睺罗出家。即来到佛所。礼佛足退坐一面。低头泣泪白佛。世尊。兄弟已共出家。望罗睺罗继后使宗庙不绝。云何度罗睺罗出家。佛即为父王说出家种种功德大利。因此为后出家者作制。若欲出家先白父母。父母不听不得出家。是名度沙弥法。出家求父母如法之初始也

佛在俱睒弥国。五师子意欲出家。不白父母辄来到寺求欲出家。僧即为剃发度出家。父母后时不知子所在。遍聚落求觅都不知处。复诣寺问诸沙门。皆言不见。入寺中房房求之。忽见其子已剃发出家。父母即慊说言。沙门释子云何妄语。实度人子皆言不见。诸比丘即白世尊。佛言。从今已去。若出家者白父母。父母听许。欲度沙弥者。要白僧剃发受三归五戒乃至沙弥戒。若僧不听。不得度沙弥。出家度沙弥因缘毗尼中广说。诸比丘初出家后时发生已长。往白世尊。佛言。听数数剃之。此是初数数剃发因缘。尔时佛在王舍城。佛发已长。诸比丘中恭敬心故。无剃发者。有优波离童子。共父母来到佛所。见佛已即生此念。欲为如来剃发。生此念已。长跪叉手白世尊言。今欲为佛剃发。愿大慈听许。佛即令其剃发。父母在边白世尊言。剃发善不。佛言剃发。甚善但身近来逼。童子小却身。举头父母复问言。剃发善不。佛言善但举头。大高小复下头父母。复问佛。剃发善不。佛言善。但出息大粗。此童子即不出息入第四禅。佛告阿难。此童子入第四禅。汝可取其手中剃刀阿难即取。此童子所以敢剃如来发者。有三因缘。一者愚痴故剃。二者如来神力欲令得第四禅故剃。三者欲令后代众生知剃发有大功德故剃。佛当欲剃发时。告语诸人。此发不可故衣故器盛之。当用新物。当剃发时。瞿波罗王子来到佛所。从世尊乞发持还国供养。佛即许之。王子即复咨启世尊。此发应以何等器盛之供养。佛言。应用七宝作器盛之供养。即如佛教。造七宝瓶而用盛之。复问世尊。若去时象马车乘人肩头上。于尔许处应乘何处去。佛言皆得。但去时应作种种伎乐将去。王子如佛教。去路上闻有别国贼来。即路中作一大塔供养佛发。此塔名为佛发塔也。尊者迦叶惟说曰。夫剃发法上座应先剃。复有一说。发长者应先剃。复有一义。先洗头者应先剃。复有一义。有事因缘欲行者应先剃。是名如法剃发

复次比丘法。不应故杀众生食。食有三处。一见二闻三疑。如此等三处不应食也。若有檀越欲祀天时作意。其有来者皆应与食。无分别心所杀众生。俟一切来者。比丘若得如此处肉不应食也

又于一时。佛在毗舍离。谷贵世荒乞食难得。比丘中有神力者。乘其通力至外道国乞食。诸外道人见比丘来乞。慊其不净。以食着地舍之而去。诸比丘白佛。食难得故。乘神通力至外道国乞食。外道见之污贱。以食着地舍之而去。此当云何。佛言。虽手不受。将来着前。已是与竟。汝等但受之。此即是受食。是名故作受用。不与毗尼合者法名非法非法名法。乃至说名非说非说名说。是名不与毗尼合。又复不合者。比丘语诸比丘言。我不能学此法。何用微细事为。大德我亦知此法入毗尼入修妒路。如是广应知。是名不合毗尼。合毗尼者。如佛所说。此应作此不应作。此犯此非犯。如是不违佛所说。是名合毗尼义。云何名为人养生具。众僧净人是。非人养生具。象驼马驴牛。能与僧远致者。名为非人养生具。云何名为食果。尔时王舍城有大长者。此长者大有果树长者遣人。持果供养众僧语使人言。汝到寺当觅跋难陀释子示果行与众僧。当于尔时。跋难陀出外食比来顷。日已过中。诸比丘竟不得果食。尔时世尊。游蜜蜂林中。有一比丘病。须服呵梨勒。诸比丘白佛。佛即听服三果呵梨勒毗醯勒阿摩勒。随病因缘若不差尽形服之。又于一时。毗舍佉鹿母外大得果来。此果甜美不敢自食。即请佛及僧设食。兼欲与果供养佛及僧。佛众僧食已起去。毗舍佉鹿母事多匆务忘不行果。去后乃忆。内自思惟。本所以请佛及僧者。缘有此果欲用供养。云何忘去。即遣人担果诣佛及僧。僧心中生疑不敢辄受。即便白佛。佛言。当作残食法食之无咎。僧净地中忽生果树。此树长大。有枝曲向不净地中。佛语诸比丘。遣净人绳击牵向净地。后诸比丘心疑。此果本在不净处。今牵在净处。为得食不。佛言。若果落不净地者不得食。不落者得食。复有果生不净地中。但枝及蔓皆向净地。若落净地者得食。不落者不得食。又于一时。诸比丘大得种种果。但人少果多食不可尽。残者不知何处用。白佛。佛言。听捺破取汁至初夜得饮。若不至初夜。汁味有异成苦酒者。不得饮也。何以故。此酒两已成故。有比丘不净果而食。外道讥慊言。诸比丘无慈心此果有命云何食生命也。为世慊故佛即制。诸比丘果要净而食。不净不得食。净有五种。一火净二刀净三鸟净四果上自有坏处净五却子净。复有七种净。一却皮净二破净三烂净四萎净五刨刮净六水所漂净七尘土坌净。此是净法

尔时世尊。在波槃国拘尸那竭城。娑罗双树间入涅槃。诸离车力士五百人等来到佛所。以种种香汤沐浴佛身。先用劫波缠如来身。复用五百张细软白叠缠之。以酥油香油着铁棺中。然后安如来身。复取种种香木聚积成[卄/積]。复捣种种末香着于[卄/積]上。有一力士捉炬火欲然之。诸天即灭不令得然。阿那律语诸力士。汝等不须疲苦。诸天不欲令然。力士即问阿那律言。诸天何故不欲令然。阿那律言。诸天欲令摩诃迦叶见如来身。当于尔时。天雨曼陀罗花供养如来。有一时阿跋外道从如来边得一曼陀罗花。持此花向波婆国。至波婆国道中。见摩诃迦叶与五百徒众随道而行。迦叶问言。从何处来。答言。从拘尸那竭城来。复问言。见吾大师如来不。答言。汝师入涅槃已经七日。诸天雨花供养如来。此花是也

摩诃迦叶悲惨不乐。诸弟子等皆惋转于地。如失水鱼头着尘土。各各而言。我等从今永失荫覆。如是种种说辞非一。跋难陀释子谏诸比丘。不须愁恼。世尊在时禁制非一。今入涅槃。我等自由欲作不作。各任其性何须恼也。摩诃迦叶。闻此之言倍生悲惨。而复说言。如来者是论中师子。所说法轮无能坏者。复能降伏一切外道。于一切法悉得自在。法王法主如来应供正遍知。虽入涅槃其日未久。云何恶人于大众中无惭愧心发如此言。摩诃迦叶作此惋叹已。与五百比丘向如来所。到已语阿难言。我今欲见如来之身。阿难答言。如来身者。诸力士等。用劫贝及与白叠。缠如来身安置棺中。种种香木积聚成[卄/積]。云何可见。作是言已。如来神力故双足出现。迦叶看如来足见有垢着。问阿难言。如来足上何故得尔。阿难言。有诸女人。如来临涅槃时悲感恋慕。以顶礼如来足。是故垢着。佛现足令迦叶见已即还不现。迦叶绕如来七匝说偈赞叹。火即自燃焚已供养如来竟。迦叶于王舍城耆阇崛山竹林精舍。集五百大阿罗汉语言。我在波婆国道中。闻如来已入涅槃语五百比丘。皆悲感懊恼。跋难陀释子忽作是言。如来在世法律切急。如来灭后各任其性何须懊恼。诸外道等若闻此语。当作是言。诸释子。世尊在世奉教修行。如来灭后皆已废舍。我等应当聚集结集经藏使法不绝。诸罗汉答言。我等集于经藏须于阿难。迦叶答言。阿难结漏未尽。云何得在此众。诸罗汉言。所废忘处应当问之。迦叶言。若尔者当作求听羯磨使入僧中。五百僧坐已。取五部经集为三藏。诸经中有说比丘戒律处。集为比丘经。诸经中有说戒律与尼戒相应者。集为尼经。诸经中乃至与迦絺那相应者。集为迦絺那犍度。诸犍度母经。增一比丘经。比丘尼经。总为毗尼藏。诸经中所说。与长阿含相应者。总为长阿含。诸经中所说。与中阿含相应者。集为中阿含。一二三四乃至十一数增者。集为增一阿含。与比丘相应。与比丘尼相应。与帝释相应。与诸天相应。与梵王相应。如是诸经。总为杂阿含。若法句若说义若波罗延如来所说。从修妒路乃至优波提舍。如是诸经与杂藏相应者。总为杂藏。如是五种名为修妒路藏。有问分别无问分别。相摄相应处所此五种。名为阿毗昙藏。此十五种经集为三藏

阿难偏袒右肩胡跪合掌。白摩诃迦叶言。亲从如来边闻如是说。吾灭度后应集众僧舍微细戒。迦叶还问阿难。汝亲从如来闻如是语。微细戒者何者是。阿难答言。当尔之时为忧苦恼所逼。迷塞遂不及问。迦叶即诃阿难。汝所语非时。先何不问世尊。今乃言不问

尔时迦叶。问诸比丘。我等宜共思惟此义。何等是微细戒。有一比丘说言。除四事余者名微细戒。一一说乃至除九十事。余名微细戒。迦叶说言。汝等所说皆未与微细戒合。随佛所说当奉行之。佛不说者此莫说也。若舍微细戒者。诸外道辈当生谤言。如来灭后微细戒诸比丘皆已舍竟。瞿昙沙门法如火烟焰忽生已灭。若舍微细戒者。但持四重余者皆舍。若持四重何名沙门。以是义故。尊者迦叶责阿难七事。因阿难为女人求出家中。彼有九事讁阿难。一者若女人不出家者。诸檀越等常应各各器盛食在道侧胡跪授与沙门。二者若女人不出家者。诸檀越等常应与衣服卧具逆于道中求沙门受用。三者若女人不出家者。诸檀越等常应乘象马车乘在于道侧以五体投地求沙门蹈而过。四者若女人不出家者。诸檀越辈常应在于路中以发布地求沙门蹈而过。五者若女人不出家者。诸檀越辈常应恭敬心请诸沙门至舍供养。六者若女人不出家者。诸檀越辈见诸沙门常应恭敬心净扫其地脱体上衣布地令沙门坐。七者若女人不出家者。诸檀越辈常应脱体上衣拂比丘足上尘。八者若女人不出家者。诸檀越辈常应舒发扫比丘足上尘。九者若女人不出家者。沙门威德过于日月。况诸外道岂能正视于沙门乎。十者若女人不出家者。佛之正法应住千年。今减五百年。一百年中得坚固解脱。一百年中得坚固定。一百年中得坚固持戒。一百年中得坚固多闻。一百年中得坚固布施。初百岁中有解脱坚固法

  安住于此中　　悉能达解义
  第二百岁中　　复有坚固定
  第三百岁中　　持戒亦不毁
  第四百岁中　　有能多闻者
  第五百岁中　　复有能布施
  从是如来法　　念念中渐减
  如车轮转已　　随转时有尽
  正法所以隐　　阿难之愆咎
  为女人出家　　劝请调御师
  正法应住世　　满足于千年
  五百已损减　　余者悉如本
  是故五百岁　　五法兴于世
  解脱定持戒　　多闻及布施

毗尼母经卷第三毗尼母经卷第四

        失译人名今附秦录

诸比丘欲集法藏。时摩诃迦叶以手拍地。声震之响喻如铜钟。尔时王舍城中旧住五百罗汉师子阿兰那。闻此之音共相告言。集法藏时至。尊者富兰那。与其徒众五百罗汉。即共相随向王舍城耆阇崛山竹林精舍中。至摩诃迦叶所。到已语摩诃迦叶言。我等闻摩诃迦叶五百罗汉于王舍城竹林精舍中欲集法藏。我等亦欲得闻。摩诃迦叶即向富兰那等。出集法藏因缘。富兰那语尊者摩诃迦叶言。大德。所集法藏缘已得闻竟。甚善不可言。但于八法中我所不解。从界里宿食乃至池边种种草根等。如此八法亲从佛边闻。如来听畜。复言。不听者是处不解。迦叶答言。实如汝语。佛为饥馑谷贵乞食难得。怜愍众生故听畜。世丰谷贱乞食易得。是故如来还不听也。富兰那言。迦叶。如来是一切知见者。畜时欲使人知畜时。舍时欲使人知舍时。迦叶答言。以是义故。佛知时而说。是时中应畜。是时中不应畜。富兰那。是故我等应随如来。制时随制听时随听。如来应供成就八种善法。一者善得金刚智。二者悉断一切烦恼破无明闇。三者于一切法无诸障碍。四于一切处而得自在。五能善降伏外道异论。六善示众生利不利。七能与众生如法分别。八善能巧制犯不犯自在无碍。成此八法名法王法主。尔时摩诃迦叶。问阿难言。此事复云何。阿难答摩诃迦叶曰。如我佛边所闻。如迦叶答富兰那也。若人如佛语而行者。此人能炽然佛法。是故应如法行之。尊者富兰那徒众。闻此语已如法而行。即是炽然佛法者。此是雪山中五百比丘所集法藏。七百比丘集法藏今当说。如来涅槃后一百年。毗舍离毗利只子诸比丘等。如佛所说行于十法。随顺行者炽然佛法。一应用。二指抄饭食。二入聚落得食。说言饱已不言不足。后得食时不作残食法得食。三界里群品作法事亦得。四赞叹群品作法事善。五前人作法后人复作所作皆善。六酥油蜂蜜石蜜。以酪和之得食。七昨日受盐今日得和饭食。八得饮奢留伽酒。九坐具不剪须得敷。十金银七宝得自手捉亦得畜之。以是因缘故。迦兰陀子耶舍。欲除灭此过患。于毗舍离集七百罗汉。众僧集已。迦兰陀子耶舍。问尊者离婆多言。比丘入聚落中食。得两指抄饭食不。尊者离婆多答曰。不得两指抄饭食。耶舍问曰。何处制此不得两指抄饭食也。离婆多答曰。舍卫国制残食处制之。耶舍复问尊者离婆多言。若比丘食足已不作残食法得食不。答言不得。耶舍复问尊者。界里作法事得不。尊者即问。界里作何等法事。答曰群品作法事。尊者答曰不得。问何处制。答曰。王舍城中布萨犍度中制。耶舍复问。界里群品作法事。说言好得。作如是语不。答言不得。此亦王舍城中布萨干度中制。耶舍复问尊者。前所作事更得重作不。尊者答曰。云何名为重作。耶舍说曰。此事今作曾作。尊者答曰。若此事以阿毗昙毗尼修妒路不合者。已作不应作。未作不应作。今作不应作。若此事与三藏合者。已作应作。未作应作。今作应作。耶舍复问尊者。得食美食不。答曰何者美食。耶舍说曰。酥油蜜石蜜与酪和之。是为美食。尊者答曰。不得食也。何处制也。舍卫国中制。残食处制耳。耶舍复问尊者。所受盐得食不。尊者答曰。何者所受盐。耶舍说曰。昨所受盐今日得和饭食不。尊者答曰不得食也。何处制也。舍卫国药草犍度中制。复问尊者。得饮奢留伽酒不。答言不得。何处制。拘睒弥国因莎提比丘制。耶舍复问尊者言。得畜不剪须敷具不。答言不得。何处制之。舍卫国因六群比丘制。复问尊者。得畜金银宝器不。答言不得。何处制之。王舍城因跋难陀释子制。以何义故。更集法藏欲使比丘舍恶修善。若四人住处乃至众多人住处。欲使知法如法修行佛法炽然。若和尚阿阇梨若知法人。如此人等皆能如法者。可佛法增长。有二种法不可违。一佛法不可违。二转轮圣王法不可违。以是义故。更集七百僧集法藏也。所以言毗尼经者。诸经中与毗尼相应者。总为比丘比丘尼经。诸经中与迦絺那衣相应者。总为迦絺那犍度。比丘经。比丘尼经。一切犍度。摩得勒伽。毗尼增一。此五种总为毗尼藏。是故名毗尼经。所言大广说者。所说事多故名广说。我今教授大法故名为大。我今说大法大毗尼。是故名大广说。大人所说法名之为大。何者大人诸佛世尊。名为大人此大人说故名为大人。又言广者。有大德比丘略说经。若众多比丘前。若四三二一比丘前。说其所解经。我亲从佛边闻如此说。上座有德知见者。应取其所说思惟此理。若与三藏相应者应语言。大德所说甚善。若有后学者应以此法教之。若不与三藏相应者语言。大德莫行此法。亦莫教人行此法也。是故名为广说。说大调伏现前。故名广说

若有一人聪哲高才。自备此德捉其所解。与如来所说法竞。如人捉伪金与真金并。若真伪难别者。以火烧之真伪自现。若以伪法言是如来说者。与三藏经并之。知其真伪也。如世有真医。有人实非医。妄称是医人。不别者就其治病。虚丧身命。犹如世人不识真法。随行邪伪法者。能灭善心身命也。不灭正法者。佛所说毗尼。如佛所说行。是人能使正法炽然于世。何以故。此人知此是佛说。知此非佛说。是故能典正法。是名广说。尊者萨婆多说曰。有四白广说。有四黑广说。以何义故名为广说。以此经故。知此是佛语此非佛语。若有才辩了了能识是非为人说者。此言应受。黑广说亦应如白广知。四者。若众多若三若二若一。是名为四。又比丘作如是言。世尊在浮弥城告诸比丘。汝等若村若落我亲从佛边闻说受持。此是法此是毗尼此是师教。此比丘所说非可非不可。若以增一阿含中阿含长阿含杂阿含比丘经比丘尼经诸犍度摩得勒伽与法理合者。应语言。大德此法可自勤行亦教人勤行。若不合法理者语言。大德此法不应自行亦不应教人行。此是初广说。第二第三乃至第四亦如是说。第一大众前。第二四人前。第三二人前。第四一人前。是名广说

佛告诸比丘。吾教汝一句一偈。若多若少。若应行者如语行之。不应行者如语莫行。若后世比丘所说。与三藏相应者亦应行之。若吾所说或多或少。不应行者亦莫行之。后代比丘所说。不应行者亦莫行之此法增一经中广明。有广说者。如来临涅槃时告阿难言。吾灭度后汝等言。我等无依。莫作此说。吾所制波罗提木叉。即是汝依即是汝师。是故阿难。吾去世后。当依波罗提木叉而行行法。应当各各谦卑行之。汝等应当除去憍慢安心净法。阿难。从今已去。下者应称上座尊者。上座应称下座慧命。阿难。若人见十二因缘。是为见法亦得见我。如来临涅槃时。欲为利益众生故。说是四广。以是义故。名为广说。佛复告言。有物和合故应畜。有物不和合故不应畜。云何名为和合。如舍利弗外得上色纳。以此纳缝着条衣上。佛即听畜之。故名和合。不和合者。上色锦上色白虽和合不应畜。故名不和合。犹如酒若和药得饮。不和不得饮。上色与下色合得畜。不合不得畜。和合有二种。一色和合。二衣和合。色和合者。先用根染后用弱染。复有先用上色染后用下色染。此二名色和合应畜。何者名为上色。五正色名为上色。萨婆多说曰。上色者。纯青纯赤纯黄纯黑纯白。是名五种上色。大色和合者。先用青染后用余色染。先用余色染后用青色染。五种亦如是。是色应得畜。衣和合者。若衣作净纳未作净。缝纳着衣上。若衣未净纳已净者。缝纳着衣上。此二皆名净衣。若衣未满十日未作净施。纳已作净施。缝纳着衣上得畜。若纳十日未满未作净施。缝纳着衣上得畜。故名衣和合。净施法。一日得一日作净施。若过十日不作净施。犯尼萨耆。若复放逸故不说净者。以心恶故。不满十日皆犯舍堕。何者不和合应畜和合不应畜。不和合应畜者。山涉子识其留草阎婆伽毗钵优勒伽蜜苦酒阎陀林斤提力姜。如是等药不合应畜。何以故。此药一一别中投食。合不中投食。如煮乳令沸熟已写置一器中。时节小久乳水各别。此乳着盐不中食。不和盐中食。上所列药草和合投合。不中一一中投食。亦如乳盐合不中食。别食甚好。是名不和合用。当于尔时。佛为病比丘听饮苏毗勒浆着盐得饮不着亦得。是名和合用

尽形受药者。姜椒荜茇诃梨勒盐菖蒱。如是等皆名尽形受药。药草犍度中广说。寺中应可作者。从羯磨一切法事。乃至饮食卧起。及露着泥洹僧竭支皆中。复有中者。若寺中地见金银。知主不知主。皆应取举之。知主者后来当还。若不知主者。应当众僧中唱。我昨日僧地中得金银。是谁物也。有人来言是我物者。应问。此物头数多少及与斤两。裹持系缚用何等物。若言一一相应者可还之。不相应者不应与也。复有寺中可中作者。若比丘比丘尼。用木叶作盖。用木皮作盖。或织草作盖。如此等皆寺中得用。复有比丘。寺中得用物富罗上。重着革皮落缩。若出聚落雨雪得着。无雨雪不得也。所著革屣四重三重乃至一单。寺里皆应得着。入聚落时雨雪得着。无时不得也。病时亦得着。革屣犍度中广说

寺中应畜铁钥木钥瓢杖浴室中床。是名寺中应畜物。比丘僧差入林者。应与七日。若七日不得来者。应与十五日。若十五日不得来者。应与一月。是名应入林

若比丘身上生疮。比丘用粗涩散洗疮。佛言听。诸比丘用细末柔软散洗疮。举散法。着瓶中塞口乃至着橛上。药草犍度中应广知

若比丘有白癞病自裂脓血流出。诸比丘用粗涩散涂洗。佛言。当用细末柔软散涂洗。杂犍度中应广知

若比丘新生疮病痛不坏者。当用坏药傅之。后时当畜种种愈疮药治之令差

若比丘下分中有痔病者。当作裹疮衣。莫令脓血流出污衣。随医师分处作衣听畜之

若诸比丘头上生疮。若面上生疮。若唇上生疮。若肩头生疮。若腋下生疮。若胁上生疮。若脐上生疮。若坐处生疮。若膝头生疮。若[跳-兆+專]上生疮。若头上有疮者。听裹头覆头入白衣舍。若面上有疮者。听钵水中自照。或壁上自照见疮。得自涂药。唇上有疮者。得听两唇不相到嚼食。若舌上有疮者。听着口中不嚼吞之。若肩头有疮者。听以手捉疮以衣覆上入白衣舍。复听肩头疮上衣不覆得入白衣舍。若腋下有疮者。听手叉腰入白衣舍。若胁上有疮者。听反抄衣入白衣舍。若脐上有疮者。听下系泥洹僧。若坐处有疮者。听入白衣舍蹲坐。若膝上有疮。听褰衣过膝入白衣舍。若[跳-兆+尃]上有疮者。听高着泥洹僧入白衣舍。是故名有疮听也。若众僧寺里有三四人别作大堂。住止处应绕四边掘深堑遮水。堑里应作大小行处。此事敷具犍度中广说。佛告阿难。汝捉钥可房房语诸比丘。吾欲南行按行诸国。谁能随吾去者。可自料理衣钵。阿难即受告敕。房房语之。诸长老比丘白阿难言。若师去者得随佛去。若师不去自亦不得去。何以故。至彼中更须觅依止师故。尔时世尊即共堪能去者。相随向南路上。佛见诸比丘少。告阿难言。汝不房房语也。比丘何故少。阿难即具以上事白世尊。佛告阿难。从今已后。若比丘满十腊知法者。应受十腊乃至百腊不知法者依止。依止法。受具犍度中广说。此房房中所作事。应二指作法。若钵破作五段。缀此钵法。应相去二指安一缀。若上厕时洗大便道。应用二指头洗之。若衣破着纳者。孔外荫二指。若比丘畜发法。极长不过二指应剃。是名法。略说共作法。若比丘性行调柔持戒亦具威仪可观。如此人者。僧应与共同一切法事。乃至饮食卧起皆应共同。是名略说共作法。若比丘行来到他寺上。应问此寺中一比丘结大界处。复问离衣宿处。兼问众僧净厨处。亦问布萨说戒处。如是等处皆问一人。故名略问。问已若有同伴亦应语之。又复应问。所饮水中有虫不。清净不。此水属谁。又问。果菜净未。一人问。余人皆得净。故名略。若旧住比丘请客比丘。客比丘到寺。一人问净不净。如是可问处皆问。是余比丘皆得清净。尊者萨婆多说曰。有利养生人贪着。佛不听取。然不制所犯。应如前所制法行

世尊说曰。若人所作不善。知惭愧者不为障道。若比丘无惭愧心亦无所知。如是所说不应受用。又复有人无惭愧心有所知解。其所说法亦不应受。复次有人虽知惭愧然无所知。若有所说亦不应受。若复有人有惭愧心能达法相。如此说者应受用之。尊者迦叶惟说曰。有诸人智慧等所见亦同。其性柔雅戒行清净无有瑕秽。是名和雅所说应受。有应作处。何者是。尼师坛有破穿处。应用弊纳补四边荫一寸。如是广知。若有疮处应治。若众僧食处应扫。若和尚阿阇梨食处应扫。是名处所。若比丘病。佛听煮粥食之。无净地。众僧当与作白二羯磨作净处所。如是等皆名处所

佛在世时。常在王舍城中说戒。至十五日月尽。诸比丘远近不避疲劳。诣王舍城听佛说戒。佛知诸比丘疲苦。即问诸比丘方所。随其方所住处说戒。是名为方。东方塔名罗多跋陀罗。乃至北方有山。名无之罗毗罗。是名为方。如是等边方。有律师五人得受具足。阿练若比丘应善知方所。亦应知处及时。尔时诸比丘北方受安居。安居已竟。各执衣钵往到佛所。世尊问言。从何方来。皆说所从来处。故名为方。佛听何等国土应五人受具。阿畔提国有毗尼师。听五人受具。有一比丘字数虏奴。少小信道欲得受具。国土无僧。尊者迦旃延有缘到彼国。此比丘求迦旃延欲受具。十二年中集僧乃得受具。迦旃延为受具已来到佛所。佛问言。迦旃延汝何故迟。迦旃延即以受戒因缘具白世尊。佛即立制。从今已去。听边地无众僧处有律师五人受具。有国大热处听日日洗。荆棘多处听着厚革屣。作革屣法随土地所有厚皮听作。有诸比丘在雪山中夏安居。手脚头耳皆冻坏。安居已讫。各执衣持钵来诣佛所。头面礼足退立一面。佛知而故问。汝等何故身体皆坏。比丘白佛。雪山中寒冻故是以皆坏。佛问言。应着何等不令身坏。诸比丘白佛。若脚着皮革靴上着复衣应当不坏。佛即听着富罗。复听着罗目伽上听着驹执。复听着复衣若用羊毛骆驼毛。乃至绵纻之听着。有二婆罗门比丘。一字乌嗟呵。二字散摩陀。往到佛所白世尊言。佛弟子中。有种种性种种国土人种种郡县人。言音不同语既不正。皆坏佛正义。唯愿世尊。听我等依阐陀至持论。撰集佛经次比文句。使言音辩了义亦得显。佛告比丘。吾佛法中不与美言为是。但使义理不失。是吾意也。随诸众生应与何音而得受悟应为说之。是故名为随国应作。毗舍离饥馑如上文说。佛听畜迦絺那衣。有五种利。一得中前数数食。二得有檀越来请得别众食。三得畜长财不说净。四得离衣宿。五不白得出界。是名受迦絺那衣利。作浆法。先研米与水和滤着一器中。后炊饭[攸/食]饙取饭汁着一处经一宿。中食时如法受饮之。萨婆多迦叶惟说曰。此浆中后乃至初夜得饮。初一分竟。诸比丘夏安居法。若有破坏房舍。应受取任力所能修补治之。自恣法者。若有大众。应如法白二羯磨自恣。若阿练若比丘。或一或二乃至三四。应胡跪合掌展转相向言。今日众僧自恣我亦自恣。如是三说。若独一人。应心念口言。今日众僧自恣我亦自恣。如是三说。云何与自恣欲。尔时世尊告诸比丘。今日自恣。有一比丘白佛言。世尊。病比丘不堪来者。为看病不得来者。为佛法僧不得来者。此事云何。佛告比丘。如此等皆应与欲。说言。今日众僧自恣。我不得往自恣。与众僧清净如法自恣欲。如是三说。是名与自恣法。有五种与自恣法。一今日僧自恣我与僧自恣。二我白自恣。三为我故自恣。四若口不能言者。手作说相亦得与自恣。五语虽不了亦是与自恣。是名五种自恣。若前人身口不能。后复更问之。身口无相貌者。命根未断耳闻人语。众僧就其前羯磨自恣。取自恣人若将自恣来。道中命终。或为淫欲所迷。或失性。或出界外。或舍道还俗。如此等皆不成取欲。应更遣人取欲。若取欲者。为贼为水为虎狼所遮不得来者。此取欲成就。如此等难事非一。但取欲者。欲来而力不能。皆取欲成就。波罗提木叉法者

尔时世尊在净房中作是念。我今为诸比丘制说波罗提木叉戒。何以故。后学比丘欲行法者。不知何者佛制何者非佛制。乃至阿罗汉果乐。佛告诸比丘。我今说波罗提木叉。汝等当善受行之。若有所犯即应忏悔。若无所犯应系念思惟。吾说戒时若默然者。当知皆是清净之人。汝等屏处发露无隐。吾大众中问无隐等无有异。第二第三亦如是问。若故作不妄语者。佛说障道。障者。障于四禅四空乃至障四果四向。若后能改悔。四禅四空四向四果皆可得取。是故名波罗提木叉法也。说波罗提木叉。有五种如上说也。布萨取欲。如上自恣取欲无异。田舍园。前所施后所施处。不应转易更施余处。若五钱转施皆是恶作。复有十八种分别。复有八种阿练若处所。有若比丘尼外来所施。若有所作为人所叹。有作为人呵摈。如是等皆名为物。云何名呵责摈出。呵责摈出者。要示彼摈者罪相貌然后摈出。不得直驱

尔时自恣前。有一比丘犯罪。见者欲谏。语言。我欲谏汝。听不。犯罪者可。当欲谏时。犯罪者无。是名事在人无。若后时欲谏者。还犯罪人边取欲得谏。不取不得也

尔时世尊从迦尸国与五百比丘。向幽兰精舍。此寺中有旧住五人。一名阿犯只。二名富那婆苏。三名半持陀路醯尼。四名伽路罗。五名帝奢。此比丘等闻世尊来。即共分此寺中房舍园田花果敷具及养生具。唯留佛一房。所以分者。恐佛共舍利弗目连诸大比丘等来。必夺我房舍及田业。是故急分。生此念已。房舍作一分。园田作一分。一切敷具作一分。一切养生具作一分。一切花果作一分。分已。世尊来到。到已告舍利弗目连言。汝语旧住比丘。客僧来到。可房房料理敷具。如佛告敕即往语之

旧住者即答舍利弗目连言。第一房为佛拔竟。唯愿如来安乐住止。余物一切五分分竟。目连闻此语已。即传此言具白世尊。世尊即遣目连复重语之。诸比丘答亦如前。佛即唤旧住比丘。种种因缘呵责。为说世有五贼。第一贼者。有恶比丘不持禁戒多将徒众游诸国邑食人信施者是。二若有比丘实不清净自言清净此亦是贼。三若有比丘自恃聪明多智起于憍慢诃骂比丘言无节度此亦是贼。四若有比丘为衣食故自言得过人法此复是贼也。五若有比丘用僧祇物以自资命此亦是贼。是故一切属四方僧物不应独用。诸比丘白佛。若有物诸比丘因此生诤讼者。此物云何。佛言。比丘若共忏悔。此物得分。不和合不得分也。分法。要作白二羯磨。此事拘睒弥犍度中广明。提婆达多破僧有五法。一者尽形寿乞食。二者粪扫衣。三者不食酥盐。四者不食肉鱼。五者露坐。以此五法僧中行筹。可者受筹。尔时座中有百比丘受筹。阿难即众中脱僧伽梨掷地唱言。此是非法。有五十大上座亦脱僧伽梨掷地。诸比丘以此因缘具白世尊。佛言。此便是地狱人。当入阿鼻地狱一劫。不可救也。此破僧犍度中广明。上提婆达多五法不违佛说。但欲依此法坏佛法也

尔时世尊在王舍城。诸比丘在冢间树下。或在水边大泽中。处处敷草露宿。有大长者晨朝出行。见诸比丘为作礼问言。昨暮何处宿。诸比丘答曰。家间树下处处皆敷草卧。长者问言。若有檀越为作房舍得不。诸比丘答曰。佛未听作。比丘以是因缘即往白佛。佛告诸比丘。若有檀越信心能为僧造房者听作之。长者闻佛告已。即造六十口房施设饮食。请佛及僧供养已。捉金瓶行水竟。胡跪合掌白佛言。今为佛及僧作六十口房。愿世尊及比丘僧。为弟子受用。佛因长者施房为说施房利益。一者能遮风雨。二者能遮寒热。三者能遮恶兽毒虫。如是种种利益尽为说之。因此房故令诸比丘得善寂安乐住。此敷具犍度中广说

佛在阿吒毗国。听诸比丘私作房。诸比丘各各私作大房。所索甚多。诸檀越遥见沙门入村。皆避之不欲相见。有比丘字阿吒毗。为私作房故自伐林木。林中有神以林为舍。此鬼内自思惟。正欲打此道人。恐畏有咎。若默然者无住止处。即往白佛。佛告言。若打持戒者其罪极重。汝渡河有大树。此树神昨已命终。汝可依彼大树住。因此制戒。不听私起大房

尔时世尊在拘睒弥国。有比丘字阐陀。与国主优填王极善。自往语之。今欲私起房乏材木。王即语言。国中所有材木随意取之此比丘官路中有一大树。枝条荫覆五百乘车。国中诸人皆以此树有命之想。阐陀比丘伐此树。檀越慊之。比丘往白世尊。佛即因而制戒。自今已去。若有神树。路中诸人所贵重树不听伐也。若伐者得波逸提。或言偷兰遮。从此以来不听过量私作大房

尔时闼婆摩罗子出家。翘勤行道得阿罗汉果。内自思惟。于此身上更修何业。思惟既定。当为僧劝化中食及造敷具。于一日中有比丘。逼夜来向寺不知寺处。闼婆摩罗子即入火光三昧。举手照明令知寺处。此比丘到已示房舍敷具大小行处。澡手水涂足油一切示处。若有客僧来到寺者。随其所须皆供给之。心无爱憎。佛即赞叹。一切饮食敷具平等无过。闼婆摩罗子无根谤缘。因此广知

尔时提婆达多共阿阇世论议。汝可杀父我亦杀佛。新王新佛共治天下。世皆大平人民安乐不亦快乎。阿阇世问提婆达多。须几兵众可得除佛。提婆达言。得六十兵可得除之。与六十兵。得兵已先遣二人往杀佛。杀佛已从余道回莫着本路。复遣四人杀前二人从余道回。如是展转皆欲令相杀尽。所以尔者。不欲令此恶名流布于外。二人往见佛。自然不起恶心。即向佛说本来之意。佛为说法得须陀洹果。佛即语之。汝等回去莫随余道得到提婆达多所。提婆达多闻不得杀佛。即生嗔恚自到佛所。以大石打佛。诸天即接此石掷着他山。有小石破来伤佛足。诸比丘等皆来捉杖围绕世尊房。佛语诸比丘。假使有人捉须弥山欲压吾者犹不能害。况提婆达多。汝等各自随所修业安乐行之。佛未制戒前。比丘一不得与沙弥同房宿。罗睺罗无别房。诸比丘驱出。罗睺在厕上宿。厕中有大毒蛇。佛知有此毒蛇恐伤罗睺故来到厕。知而故问。汝是谁耶。罗睺答言。是沙弥罗睺。佛问。汝何故此中住。答言。更无别房。诸比丘不听共宿。佛即将入房。后日集诸比丘告曰。出家人法常应慈心。从今以后。沙弥听共大比丘二宿。至三夜若无去处。比丘不应睡卧。当结加趺坐至明相现。若第四日复无去处。明相欲现时应遣沙弥出房外。若沙弥恐怖不能出者。大比丘应自出去。有客比丘来到寺上。旧住比丘拔房舍卧具供给之。后去时不白旧住者。经多日已。主人入房始知客比丘去敷具虫鼠啮坏。以是因缘比丘具白世尊。佛因而制戒。若客比丘寄寺中宿者。去时应擗揲敷具及料理坐床。当白旧住比丘去。若不尔出界外。得波逸提

有于一时六群比丘共十七群比丘俱作客寄宿。六群是上座。十七群是下座。十七群语六群言。大德可简取上房。六群答言。谁问好恶。十七群自取房敷坐具竟。六群即夺房取驱令出外。十七群嗔恚高声唱叫。主人闻已。十七群为何等事。十七群如上因缘答主人。诸比丘往白世尊。佛因而制戒。从今以后。下座推上房与上座。上座不取。下座敷敷具竟。上座不得强力夺取驱出。若下座先至不知上座来。上座既至。下座应避出去。上下皆不得恃力驱出。若恃力者得波逸提。时有六群比丘。在重阁上住。意不审悉。不看阁地厚薄放身而坐。床脚陷过。伤下住比丘头。佛因而制戒。从今以去。阁上住者。要审悉厚薄。不得直放身坐。若坐者得波逸提

有于一时阐陀比丘。作房用有虫水和泥。诸檀越见慊言。云何比丘无慈心。佛因而制戒。从今已去。比丘不得用杂虫水和泥作房。若用得波逸提。房舍竟

尔时佛在波罗奈国。阿若憍陈如等五比丘。往到佛所白世尊言。听诸比丘何等处住敷何等敷具。佛告憍陈如。听比丘阿练若处树下冢间河边山谷间空闲处住敷草木叶以为坐具。此敷具犍度中广明。住处总明有二。一者聚落中。二者空静处

尔时有客比丘。寄他寺中安居。不自看房舍卧具。得下房下卧具。心中不悦修道有废。嗔旧住比丘。有生谤之言。比丘心有爱嗔痴怖。佛闻此言告诸比丘。从今以去。夏安居时。要自看房舍卧具。然后受之。若依上座次第得房。不看无咎。若分房者语。汝自看房。懈怠不看者得突吉罗。如来所以教诸比丘护敷具者。见五种过。一不欲令风吹。二不令日曝。三不令得天雨。四不令尘土坌之。五不令虫鸟敷具上放不净。比丘夏安居法。差分房分敷具人。令房房看之。何等房敷具多何处无。若多处分着无处。若遍有长敷具。从上座次第赋之。是名敷具处所。营事有二种。一者作。二者覆。作者。有檀越欲为众僧起房。僧差营事人白二羯磨令料理。若此营事人。意欲成此房己尽形受用者。僧当令其十二年住。后众僧随意分处。若营事人二三年中不能成房。僧当观其力能。若堪办者听使作竟。若不能者更差余人。是名作者。云何名为覆者。若作者作墙壁已不能覆。后僧更差堪能者令覆。若覆者意欲尽形住。僧当听六年住。后随僧分处。是名覆处者。比丘相恭敬法。当起迎作礼执手问讯。随其所须供给。莫违其志

诸比丘白佛。上座于下座有所犯罪。现前应立几法发露。佛言。当立四法。一者偏袒右肩。二者脱革屣。三者合掌。四者当说所犯罪。下座向上座悔过。所犯者现前应立五法。一偏袒右肩。二脱革屣。三胡跪。四合掌。五说所犯罪

若客比丘到他寺中见上座。应立五法恭敬。一偏袒右肩。二脱革屣。三胡跪。四两手捉上座足。五和南。若旧住比丘小者。亦应立五法恭敬。是法持戒犍度中广明。治风病法。当用苏毗勒浆。此浆作法。先遣净人捣大麦器中盛之。着水经二三日。小酢已净滤饮之。若和尚病。弟子应作此浆养病。弟子若病。和尚亦应如此

有比丘尼持苏毗勒浆随道行。道中见一人截手足而卧。比丘尼以苏毗勒浆灌疮上。此人即死。佛言。从今已去。不听持苏毗勒浆灌疮上。有比丘持苏毗勒浆到尸陀林。见一病人卧地。从比丘索苏毗勒浆饮。比丘慈悲心故施之。此人即死。诸比丘生疑。无有所犯也。佛言。怜愍心故无犯。是名苏毗勒浆。佛为病比丘故。听服六种散。一离畔散。二破罗私散。三怖罗罗散。四阿犯却罗散。五波却罗散。六阿半陀散。如是等散众多不一。若比丘病。随医分处服之

尔时离车子有宝钵。满中盛细末旃檀。持用奉佛。佛言。吾佛法中不听受宝器。离车子言。若不受宝。愿世尊。可受旃檀香。佛即为受。有比丘用粗澡豆洗钵坏钵色。佛言。应当熟捣细物筛之然后得用。有一女人夫主已丧。淫欲炽盛。与外人交通。遂成有胎。恐事发露。语交通者求药堕胎。此人于比丘比丘尼中求得药即堕其胎。佛闻而制戒。不听出家者与人堕胎药。比丘法不得用杂香澡豆洗身。乃至病亦不得用

毗尼母经卷第四毗尼母经卷第五

        失译人名今附秦录

尔时佛在波罗奈。五比丘往白世尊。听诸比丘畜何等药。佛言。听诸比丘畜陈弃药。乃至流离亦听畜。治病药有四种。中前服药不得中后七日终身服也。中后药中前亦得服之。不得终身畜也。中后药有得七日畜有不得者。终身药中。中前中后乃至七日皆得服也。药犍度中当广明。有婆罗门子尸罗。持八种浆施佛。一庵罗浆。二瞻婆浆。三枣浆。四坏味浆。五多浆。六沙林毗浆。七破留沙浆。八甘浆。如此浆等。佛听比丘得服。佛制酒者。因莎提比丘饮酒醉。是故制之不听饮也。尊者弥沙塞说曰。莎提比丘小小因酒长养身命。后出家已不得饮四大不调。诸比丘白佛。佛言。病者听瓮上嗅之。若差不听嗅。若嗅不差者听用酒洗身。若复不差听用酒和面作酒饼食之。若复不差听酒中自渍。尊者迦叶惟说曰。有浆初中饮后不中饮。有浆初中饮中后亦中饮。有浆初不中后亦不中。有浆初不中饮中后中饮。如佛毗舍离所制。麴不食苦酢酒不中饮。尊者迦叶惟曰。有八种酒不得饮。与麴和合作酒不得饮。若面和合作酒。虽着种种药亦不得饮。有酒酢能使人醉者亦不得饮。有酒虽甜能使人醉者亦不得饮。清酒不得饮。小酢酒亦不得饮。细末饭酒亦不得饮。有书陀酒不得饮。如是等酒甚多皆不得饮。尊者萨婆多说曰。用蒱桃谷和作酒不得饮。用蜜作酒不得饮。破谷作酒不得饮。种种果杂作酒不得饮。如是等一切酒不得饮。是名不中饮酒。着屐人不应为说法。如耶奢童子。渡波罗河脱金屐舍去。已见此屐。即知耶奢诣佛求出家

尔时佛在舍卫国。有六群比丘着高屐入禅坊。屐声高大。坐禅比丘闻此。谓是贼军马来到。生大惶怖。佛闻之因而制戒。从今已去。比丘一切不得着屐。除病者上厕。是名屐因缘。尔时有长者字流卢奴。其初生时父欢喜故。施子二十万亿金钱。即以二十亿为名。此人豪贵巨富生年已来足不蹈地。后求佛出家。精勤修学得阿罗汉果。行道苦故足皆流血。佛知其小小已来。富乐足不蹈地。听着一重革屣。流卢奴即白世尊。弟子能舍豪富如此家业。岂复贪着一革屣也。若世尊听一切比丘著者。弟子当着。佛因此故听一切比丘。着革屣者不得听法。病者得着听法。有比丘着革屣入塔。佛即制戒。不听着革屣入塔绕塔。乃至富罗亦不得着入塔。所以尔者。彼土诸人着革屣富罗者。皆起憍慢心。是故佛不听着也。是名著革屣因缘。阿盘提国寒故听畜皮。除五种皮。一师子皮。二熊皮。三罴皮。四龙皮。五人皮。如是等皮皆不得畜非所应也。所应畜者。象皮马皮驼皮牛皮驴皮。如是应畜者众多是。出家人法。不畜盛酒大瓮中盛酒大铜瓶斛。如是等生人慊疑。不应畜也

尔时毗舍佉鹿母。施僧六种物。一者刻漏好床。二者铜盔。三者烛竖。四者扇。五者扫帚。六者大铜器。诸比丘等生疑问佛。佛言。大铜器不应受。余五应受。有一瓦师。大作瓦器持布施僧。僧生疑问佛。佛言。除大器余者皆受。尔时有二贾客。去只桓精舍不远。一者信道一不信道。不信者言。沙门释子为贪心故多畜大器。信者言。沙门释子无贪心也。不畜大器。两人相敢货金钱五百。共到只桓见诸檀越多将大器布施众僧。信者不如偿五百金钱。佛闻此已即制比丘。从今已去。不听畜盛酒大器。二贾复于余时更共诤理。不信者言。沙门今者贪心多故犹畜大器。信者言。沙门今者不畜大器。二人共诤更货千钱。不信者多将大器往施沙门。诸比丘皆不受。不信者负还偿千钱。是名不应畜器。尔时婆难陀释子。杖头系羊毛荷负而行。檀越见嗤笑佯问毛卖之。难陀答言。不卖也。如是展转彻世尊耳。世尊即制。从今已去。不听比丘杖头系羊毛肩上担行

不听为捉杖人说法。杖头若铁若鹿角皆应着也。何以故。恐杖尽故。诸比丘煮染草法。作三尺杖。杖头系草。沸溢出时以杖搅之。若不知染草生熟者。一器中着水。取杖刺染草汁中。漉着水器中。染草若熟。染汁直沉水下。若不熟散浮水上。熟竟净漉染衣。染竟欲晒衣时着平地。当四角莫令绻缩。欲叠衣时当缠着轴上。莫令不平。跋难陀释子。结络囊盛钵系杖头倚头而行。诸大臣遥见谓王擎幢来到。皆远避之。到已始知是沙门。诸臣皆嫌之。佛闻即制。不听比丘杖头系钵络倚头而行

六群比丘畜筒杖。俗人见之皆嫌言。沙门与国王大臣无异。佛闻之即制。不听畜也

若病比丘有缘入聚落须杖。应求僧乞白二羯磨。僧为作羯磨者。得持钵络系杖头而行。不羯磨不得

尔时世尊在王舍城。有比丘尼檀林中夜闇行。心生怖畏。毒蛇虫螫诸恶兽等。因此白佛。佛言。听诸比丘夜怖畏处。动锡杖作声。令诸恶毒虫远去。如是广知

有讁罚杖者。呵责羯磨。摈出灭摈羯磨。依止羯磨。忏悔羯磨。僧不见犯事者羯磨。未受忏悔羯磨。不舍恶见羯磨。如是等作白四羯磨。与别住行六日摩那埵异语违返覆钵不语。五白四羯磨。二白一羯磨。是名摈罚

云何名为络囊。乞食时至应安钵中置络囊中。诸檀越施羹饭。手捉络令泻钵中。羹饭虽溢出钵污络无患。但莫使热来触手。若有弟子乞食时至。应盛钵授与和尚阿阇梨

尔时王舍城中有大长者。大得栴檀香木雇匠作栴檀钵。用宝作络。庭中立高幢。挂络幢头。唱言。若王舍城中沙门婆罗门有神德者。能飞取申手取。取者得之。外道富兰那迦叶。来到长者所语言。吾是真大阿罗汉现神力取之。诸六师等各各现神力不能得取。当于尔时。目连在大磐石上经行。宾头卢语目连言。大德。佛弟子中神通第一。能师子吼可现神力取是钵也。目连答言。不复乐现神通不能取也。世尊亦说。大德。是大阿罗汉神通第一。能师子吼今可取之。宾头卢即现神力立大石上。乘空而行绕王舍城。见者莫不惊怖。此石若下无有免者。长者尔时在高楼上。见宾头卢现神足已。叉手合掌向宾头卢礼白言。弟子已施尊者钵竟。愿取此钵。宾头卢取已。长者请入家内。取钵盛种种美食供养宾头卢。诸比丘以是因缘具白世尊。佛唤宾头卢问言。汝实为此钵现神力也。宾头卢答世尊言。实尔。佛种种呵责宾头卢。云何为此木钵与诸白衣现神力耶。譬如淫女为半钱故示人形体。汝亦如是。从今已去。不听畜栴檀钵。亦不得为木钵故现神力也。若为降伏诸外道故可得现耳。所以令畜络者。沙弥净人共外行得果。好者自食恶者与师。佛闻此已。教诸比丘令得作络囊。得果着中坚系口自持之。至寺内洗手如法受食。尊者萨婆多说曰。有一比丘共净人乞食。此净人捉食不用心。外道着毒药不觉。比丘到住处食即命终。佛因此敕诸比丘。从今已去。各各作络囊盛钵好自持之。以诸因缘听畜络也。若有老病比丘随路行须杖。或道中有种种毒虫之难。佛听捉杖行。杖头或铁或铜或角应着之。蒜者。比丘除病。一切皆不得食

尔时世尊在只桓精舍。大众中说法。有比丘食蒜。远佛在大众外坐。佛问阿难言。此比丘何故独远别坐。阿难白佛。此比丘食蒜。是以别坐。佛告阿难。如来善说法中。为此小事不闻法也。佛告阿难。自今已去。除病皆不得食蒜。有一时中。舍利弗得风病。医分处服蒜。即往白佛。佛言。病者听服

尔时世尊在毗舍离。城外有一檀越大种蒜。偷罗难陀比丘尼数数过此蒜园边行。檀越善心为福德故。问言。尊者须蒜食不。尼答言。素自不能食。得蒜下食甚善。檀越即施之。日许与众僧五颗蒜。偷罗难陀即白尼众。某檀越日许僧五颗蒜。僧若须者遣沙弥尼往取。有一尼须蒜。遣式叉摩尼沙弥尼往取。正值蒜主持蒜入城市易。有一净人守蒜园。沙弥尼问。蒜主何处去。净人答言。入城市易。沙弥尼从彼索蒜。净人答言。我不知也。但知守蒜。沙弥尼怒曰大家见与。汝岂得护。手自掘之。此是和尚分。此是阿阇梨分。此是今日分。此是明日分。如是分处恣意持去。蒜主回还见之。问守园人言。此蒜谁持去。守园者以上因缘具白大家。蒜主即大嫌责诸比丘尼。如是展转世尊闻之。唤诸比丘尼种种呵责。告言。从今已去。比丘尼不得食蒜。食者波夜提

诸比丘问佛。剃发法应用何等刀。佛言。若铜若铁用作刀剃发。既作刀已无安置处。复问世尊。佛言。若铜若铁若角若骨若竹若苇用作。安置刀处藏法。若木皮若牛羊皮裹之安置藏处。是名安置剃发刀法。杂犍度中广说。比丘尼剃发法。应各各展转相剃。若男子为剃发者。应二比丘尼抱令剃。若比丘尼于剃发男子有欲心。男子于尼亦有欲心者。不应令剃。乘有四种。一者象乘。二者马乘。三者车乘。四者舆乘。尔时拘睒弥城外有大树。名尼拘陀。此树下有种种乘憩驾止息。是名为乘若为法来。不下乘者。不应为说法。除病。应如瓶沙王乘八万四千象马诣夜置林到佛听法。当尔时亦有迦叶兄弟徒众千人在佛边听法。当尔时世尊。从毗梨只国游行到毗舍离。庵罗女并离车子等。皆乘种种上妙御乘来至佛所而听法。闻法已劝请世尊。至庵罗园中宿。明日受弟子微供。如是诸人所乘皆名为乘

尔时六群比丘乘种种御乘。诸人遥见。谓是国王大臣。到已始知是沙门。诸人皆嫌之。佛闻已制戒。除老病比丘。皆不得乘乘。不得象马乘也。病者皆得乘之

尔时摩竭提国瓶沙王。有五种庄饰之具。一者金绳刀。二者七宝乘。三者七宝冠。四者杂七宝罗网扇。五者杂宝革屣。舍此五种严身之具。跣足到于佛前。头面着地礼如来足退坐一面。尔时摩竭提国。从王来者八万四千人。见优楼频蠡迦叶兄弟皆在于坐。心中生疑。为优楼频蠡迦叶就大沙门出家。为大沙门就迦叶出家。佛知诸人心中生疑。即说偈问迦叶

  于汝所行法　　见于何等过
  弃舍求出家　　欲求何等利
  本习事火法　　云何息不奉
  更见异胜法　　不睹而舍之

迦叶即说偈。答佛

  饮食味为最　　过患之甚大
  女色味之上　　其患过于彼
  本所事火法　　未免于彼苦
  出家所求法　　永绝诸苦难

尔时世尊说偈。重问迦叶

  为味所系缚　　习久以成性
  于天上人中　　见何利解脱

迦叶还重说偈。答佛

  见三有生死　　空寂无所有
  诸法念念灭　　是故舍不着

尔时摩竭提国瓶沙王诸从来者。疑犹未解。佛与迦叶各说二偈。为是谁胜。佛知此念。即告迦叶。汝持扇扇吾。迦叶即起捉扇扇佛。扇已即空中作神通。还下佛前顶礼佛足。口复呜足说言。世尊是师我是弟子。诸人见已。始知佛是大师度迦叶也。佛知时坐心疑已解。便为说法示教利喜。王等八万四千人。皆得须陀洹果。十亿那由他诸天。亦远尘离垢得法眼净

尔时天帝释四天王等。变身为婆罗门形。捉金扇扇佛。如是应广知

尔时六群比丘。捉珠拂自拂伤损众生。诸檀越嫌之。云何出家人畜此拂。为庄饰故伤损众生。佛因而制戒。从今已去。不得捉坚[革*卬]拂伤损众生

又比丘捉拂欲拂如来塔。佛即可之。尔时有八人在边捉拂拂佛。一者迦叶。二者优陀夷。三者莎伽陀。四者弥卑喻。五者那迦婆罗。六者均陀。七者修那刹逻。八者阿难。如此等比丘所捉拂拂佛。名之为拂

尔时诸比丘齐集一处。时景盛热。佛听诸比丘畜扇。若破坏听补治。作扇法。若布若[疊*毛]若竹若[竺-二+韋]若纸皆得作也。尔时有夫妇二人年老出家。后此道人乞食到尼寺。此老尼食上持扇扇之。比丘语言不须扇也。此尼忿恚用扇打比丘直舍入房。佛闻之因而制曰。从今已去。不听尼捉扇扇比丘也。若时热众僧大集。听和上共行弟子扇之。阿阇梨听共宿弟子扇之。大众差下座比丘扇之。如迦叶等八人捉扇扇佛。名之为扇

尔时六群比丘。捉伞盖着革屣随路而行。诸檀越嫌之。云何比丘自恣捉伞盖着革屣随路而行。佛因而制曰。从今已去。不听捉伞盖着革屣而行。若在寺中听着革屣。木皮或草作盖听之。入聚落除老病。余者一皆不听。尔时诸离车子诣佛来时。乘马乘车及与衣服。一切严身之具皆作青色。佛告诸比丘。汝欲知忉利诸天出游观时相貌。如今离车子等无有异。尔时跋难陀。手捉奇妙宝盖随路而行。诸人遥见。谓是大国王。至已知是比丘。诸人嫌言。云何出家之人捉如此妙盖随路而行。佛闻已即制。不听比丘捉盖行除老病者。是名为盖

云何名为镜。能令身体现处名之为镜。若病比丘面上有疮欲涂药者。当唤比丘令涂。若无比丘。或水或钵或壁。于面可现处照见自涂。铁镜中一不得照有比丘眼痛。往白世尊。佛教作三种眼药。一者羊胆。二者其兰禅。三者苏毗兰禅。石上细磨之用涂眼。若有宝入眼药者。佛亦听之。举药法。当筒盛。不听用宝作。如是应广知

复有比丘。眼冥无所见。佛听用人血涂。亦听若人骨人发烧令作灰细磨。亦得着眼中。如是应广知

天竺土地常用药涂眼当为严饰。六群比丘如俗人法。日用药涂治眼当为庄严。佛闻之。不听用此药日涂眼也。若病者听用三种药治眼

尔时六群比丘尼为女人庄饰。佛闻之。唤比丘尼呵责。从今已去。不听尼与妇女庄饰

比丘法自不得舞。亦不得教人舞。佛所不听。阿犯只富那婆苏六群比丘等。自歌舞作伎也。佛闻之制。一切比丘不得歌舞作伎也

有六群比丘。如狗槃走法走。佛不听也。舞法。是童蒙小儿所作。歌者似哭音。此法比丘皆不应作。露齿笑者。狂人相貌亦不听也

六群比丘作歌音诵经叹佛。佛不听也。作者有五种过。一者于此音中自生染着。二者生人染着。三者诸天不乐。四者言音不正。五者语义不了。是名音乐。花鬘璎珞自不得着。亦不得作花鬘璎珞与俗人着。比丘若为佛供养若为佛塔声闻塔供养故作伎不犯。何者是作鬘璎珞花。一优钵罗花。二婆师迦花。三瞻卜迦花。四阿提目多迦花。五打金作花。六打银作花。七白镴花。八铅锡花。九作木花。十作衣花。十一作带花。是名花鬘花。尊者迦叶惟说曰。若为佛不为。余众生得作。不犯

尔时六群比丘。用跋那香涂身。诸白衣嫌之。佛不听。六群比丘复用香捣香涂身。而为俗人所讥。如是等众多皆不听也

若比丘得种种好香。涂佛塔声闻塔。为供养塔故。作种种形像。皆得为之。佛于一时。不听诸比丘着死尸衣入塔。比丘言。我等皆着粪扫衣。云何入塔礼拜。佛闻之告诸比丘。汝等得粪扫衣。水中久渍。用纯灰浣令净。用奚墨伽香涂上。然后得着入塔。诸比丘所住房内。若有臭气不得住者。听烧种种好香熏之。是名为香

天竺土法。贵胜男女皆和种种好香用涂其身上着妙服。六群比丘如俗人法用香涂身。诸檀越嫌之。云何比丘如俗人法。世尊闻已制。一切比丘不听用香涂身。若有病者须香涂差随宜得不犯。云何名为坐。坐者。众僧集会敛容整服加趺而坐。用可观名之为坐。又复坐者。佛游行到一树下加趺而坐。观者无厌名之为坐。如坐禅人一坐经劫身不动摇皆名为坐。出家人不应与女人屏覆处坐。俗人所以。共屏覆处坐者。男以女欲为食。女以男欲为食。比丘既舍。此法。不应同屏处坐。波斯匿王遣军马出路边。有一小寺客僧来多。为避军故尽入房里。房小人多狭膝而坐。亦名为坐。尊者离跋多。来到萨婆钳边。萨婆钳见离婆多来处悬远身体疲懈。自狭坐令离婆多宽坐。离婆多内自思惟。尊者萨婆钳。阎浮提中第一上座。云何于其前懈怠宽纵。即敛身端坐系念思惟。如此二人坐。名之为坐。云何名为不应卧。不得与女人同房卧。被摈沙弥亦不得同房卧

敷具者。床绳床草敷木叶敷及道人所有敷具。皆名敷具

有比丘尼。游行入聚落乞食。主人不在。尼辄入舍坐。舍主从外来。见尼坐问内人。汝等谁安此尼住此。内人答曰。尼自来无人安也。家主嫌言。云何比丘尼不语直坐。佛闻此已制。比丘尼到檀越舍。不问不得坐也

尔时比丘尼问佛。出家人入聚落中。若僧多房舍迮狭。人应得几许地。佛告诸比丘。尼随房宽狭筹量分之

若人无病自大卧地。不应为说法。病者卧欲闻法。应为说

尔时亿耳比丘。阿槃提国迦旃延子边出家。持戒修道翘勤不懈得阿罗汉。得果已。从阿槃提国向瞻婆国到如来所。佛见其远来兼得阿罗汉果。以此因缘告阿难言。汝为吾敷敷具。亦为此比丘吾房内敷敷具。此比丘佛房里卧法。面向佛不得背佛卧

尔时复有诸比丘。贪着睡眠乐故废舍三业。金刚力士默作此念。如来三阿僧祇劫种种苦行乃得成佛。今诸比丘贪着睡卧乐故。不复行道。云何得尔心念口言。诸比丘闻已。具以上事往白佛世尊。佛告诸比丘。食人信施不应懈怠。夜三时中。二时应坐禅诵经经行。一时中以自消息。是名卧具。有诸比丘露地而坐。上座长宿皆患背痛。如是展转乃彻世尊。佛告诸比丘。露地坐背痛者。除锦上色白皮革。余一切得用作禅带坐。时当用带自束。作带法。广一磔手。长短随身量作。是名禅带

尔时比丘初出家。时佛未听用绳系着泥洹僧法。用两头接腰间。后时到檀越舍众中忽脱落地。诸人皆笑。比丘惭愧。以是因缘往白世尊。佛言。从今以去。听编长短使得再匝缠腰。余有二尺长。若作绳令三匝直用缠腰头。各使有一尺余。是名带因缘。共行弟子共宿弟子。和尚阿阇梨欲出行时。应看此绳。无虫鼠啮处不。审悉看已然后过授。若阿练若处比丘无弟子者。下座应如是审悉看已授与上座。若比丘头痛者。应用腰绳急系。若比丘腰绳头有须者。不应得畜。六群比丘畜如是绳。佛即制也

有比丘为戏笑故藏他绳。过时不与令主忧恼。佛亦不听

尔时舍利弗入白衣舍。值飘风急疾吹体上。袈裟落地露身而立。佛因而制曰。从今已去。比丘袈裟上皆应着纽。一边安钩钩纽中。莫令衣堕。是名衣安纽钩法

尔时六群比丘。抄泥洹僧背上。负重低头而行。身体露现。为白衣所嫌。佛闻之因而作制。从今已去。不听比丘负重襞抄。若有因缘。为三宝事须襞抄者。好自料理莫令身现。是名襞抄法。比丘应畜稚弩。何以故。若有贼时。应望空放弩令贼怖去。有法。名同用异。如稚弩甘蔗。皆名忆初。有贼索忆初。知索稚弩。食时索忆初。知索甘蔗。是同名用异。有比丘经行处应敷毡[疊*毛]不得敷皮革。寒处得也。和尚阿阇梨经行处。弟子不得在中经行。可在边行。有老道人。如和尚阿阇梨腊数年相似者。经行处年少比丘不得在中经行

和尚阿阇梨若经行时。弟子有所咨问。应合掌曲躬低头而问。有重阁。上屋欲崩向不净地。诸比丘心疑。往白世尊。佛言。但使不坏。未落不净处者。名为净房。众僧住处未有净厨。若众集羯磨第一好房作净厨者。佛所不听。应用第二房作净厨。若先作羯磨者。应还解羯磨第二房以为净厨。所以锦不听敷经行处者。有檀越持国土所贵重锦。持来施僧。僧得已用敷经行地。檀越后来见之嫌言。云何比丘无爱惜心。如此贵物云何敷经行地。而践蹈之。如此展转世尊闻之。告诸比丘。从今已去。檀越所施好贵重物。不应敷经行地

有二种比丘。不得与僧同宿。一者行事别住比丘。二者有比丘不如法。智者谏之不用其言。辄自出寺。是二人等各不得共宿。有檀越施僧地。佛听受用。是名为地

有五种树。比丘不得斫伐。一菩提树。二鬼神树。三阎浮树。四阿私陀树。五尼屈陀树

有诸释子出家。优波离是其家剃发人。唤来语言。汝奉事吾已久。今欲别去。无可余馈汝。唯有身上所著好宝衣璎珞环玔及七宝严刀。尽舍与汝。优波离得已内自思惟。此人性高体贵。尚能舍去求道。况我微贱守宝受苦。即用三叠裹悬着树上。谁须有须者随意持去。即随释子诣佛出家。若比丘为三宝种三种树。一者果树。二者花树。三者叶树。此但有福无过。有比丘乐空静处树下安居者。往白世尊。得树下安居不。佛言。可得安居。心中生疑。复更问佛。大小树下。复得安居耶。佛言。大者益好若无。极小者高于人。枝叶四布稠致极厚。雨雪不漏日光不彻。如此树下可得安居。有比丘树上安居。缚木作床。即不下树放便利树下。此树有大鬼。忿嗔打此比丘杀。佛言。从今已去。不听比丘树上安居树下便利。佛未制戒前。比丘尼皆冢间树下空闲处坐禅经行。花色比丘尼得无著果。行坐威仪善有法式。贼主行来会遇见之。即生信心。去余处食已。有余长肉。以叠裹之悬着树上。作是愿言。若有阿罗汉得道者。中前或来至此。可得中食。花色尼六通具足。遥闻此言。明日遣沙弥尼往取。尔时世尊随路而行。到一树下敷座而坐。值遇毗赖吒子散只耶。六十乘车载黑石蜜供佛及僧。树因缘如是广知

有比丘共一女人独树下坐。俗人见之嫌言。云何沙门与女人独树下坐。诸比丘闻已往白世尊。佛言。从今已后。不听比丘独共女人树下坐

若众僧地中有树木枯者。不得独取燃火。何以故。此是属四方僧故。若僧地中有好树。众和合得用作佛塔僧房。不和不得。若大众中三四人别作大房共住。作房地中先有树。众僧分处与得用。若僧不分处与不得用也。若作房者。此地中自种树得用。若本作房者无后僧住。此树不须白僧得用。若所住房处有空地处。房主为此房故种树。得用治房。若种树者不在。有余僧住。此树不须白僧亦得用也。花树果树。除众僧和合用治塔作房。私不得斫

有五种树不得斫。一菩提树。二神树。三路中大树。四尸陀林中树。五尼拘陀树。除因缘。因缘者。若佛塔坏。若僧伽蓝坏为水火烧。得斫四种。除菩提树。有五种树应得受用。一者火烧。二者龙火烧。三者自干。四者风吹来。五者水漂。如是等树得受用。云何名为斗诤。言讼斗者。二人共竞名之为斗。徒党相助是名为诤。往彻僧者名之为言。各说其理是名为讼

复有四种诤。一言语诤。二不受谏诤。三所犯诤。四所作诤。是名为诤。云何名为破。破有二种。一破法轮。二破僧。法轮者。八正道不行。邪法流布。以智为邪。用愚为正。智障邪显。是名坏法。轮破僧者。一僧伽蓝中一人布萨。乃至五人布萨。或一人为二人羯磨。乃至为大众羯磨。大众为大众羯磨。是名破僧

共提婆达多相随者。皆得偷兰遮。还来僧中忏悔者得除。不来者助成破僧。不得破僧罪。唯提婆达多一人得破僧罪。复有一说。无有破僧法轮。不行即是破僧

复有二种破。一朋党破。二见破。如拘睒弥比丘。朋党共诤不依阿毗昙修多罗毗尼。以非为是。此是愚痴故尔。此拘睒弥犍度中广明。见破者。如提婆达多破僧。是名破见。破僧犍度中广明。如上所说十八种破

尔时有一比丘独处安居。闻有一比丘欲行破僧法。此比丘心生疑。若往谏恐破安居。若不往恐恶法流行。佛闻已告此比丘。言若为法事不破安居。比丘尼亦如是。为法不破安居也。所以谏者。畏其堕地狱受报慈心谏。复有比丘闻彼中已破僧竟。欲往和合之。恐失安居。心中疑念。佛知而告曰。若为和合破僧法者。不失安居。比丘尼亦如是。用四句法破僧。法言非法。非法言法。非毗尼言毗尼。是毗尼言非毗尼。非犯言犯。犯言非犯。轻者言重。重者言轻。以此四句或比丘心。一僧伽蓝中别有徒众。乃至布萨羯磨十八种法。皆自别作。不与僧同。比丘经比丘尼经中应广知。是名为破。云何为和合。为破僧者说。法如法说。非法如非法说。犯如犯说。不犯如不犯说。毗尼如毗尼说。非毗尼如非毗尼说。重如重说。轻如轻说。乃至布萨羯磨皆与僧同。不复别作。是名和合。复有五种和合。一者见法和合。二者见初和合。三者与欲和合。四者信和合。五者默然和合。以此五法能令僧和合。如是广知。优波离问世尊。和合破僧者得何等利

佛说曰。和合破僧者生天受一劫报。比丘白佛言。僧诤事起未忏悔名和合不。佛言。不忏悔不名和合。如法悔已乃名和合

毗尼母经卷第五毗尼母经卷第六

        失译人名今附秦录

若有比丘欲舍房余行。应先扫除房内涂治令净。擗叠敷具。以床远壁。安敷具床上。好者着下恶者覆上。二种敷具如上应广知。去时应白和尚阿阇梨。若听应去。不听当住。若过十腊有胜法事必能利益者。和尚阿阇梨虽不听去自往无过。若去时出寺外应望去处方所。复应筹量行伴。中同行不中同行。若欲过国逻被破取税物而去者不中共伴。若盗贼人不中同伴。若有不信邪见亦不中共伴。如是众多今总说二三。复应思惟。同寺共结伴至道中。若有病痛能相料理不。若先知心必应好者可共去。若未相知可待后好伴。复更思惟。此同行伴。如我心中欲有所作共同不。复应思惟。其人威仪常能摄不。非是懈怠人不。此人于我为利为衰为可信不。可信若共行时为苦为乐。复应思惟。从本已来为有病也为无病也为健不健。或至道中不相舍不。如是筹量进路。是名去者。寺中上座去时。所住房内先自料理。然后应嘱年少比丘。后时当料理此房如我在时。复次上座嘱法。从布萨说戒乃至一切分处是也。如是嘱已。然后出寺去至寺外。复问同行比丘。汝等衣钵乃至一切自随之物无所忘不。复兼诫敕。诸比丘今当共行。汝等时言少语守摄诸根。路中处处若有见者。皆令欢喜发其善心。诸同行下座。闻上座所说诫敕。皆叉手合掌胡跪对曰。如所教敕欢喜奉行。此诸比丘随路行时。下座常应恭敬赞叹上座前后围绕而行。处处若有住止发时。上座应遍看无遗落物不。若有者应语令取。又复上座道中行法。下座在前上座在后。复语诸下座。各自摄心莫令散乱。若道中下座得病。上座应为说法令善心相续。虽有急难因缘不得舍去。道中行时。下座若有难事。上座应助料理。一父母难。二兄弟姊妹难。三六亲难。四国王大臣难。五盗贼难。六野兽难。上座尽其筋力令得脱难。若自力不能者。应到聚落郡县城邑有僧伽蓝处国人所重有德比丘所。乃至笃信婆罗门诸檀越大臣所语令料理。若得脱者善。若不脱应躬自诣国王门前。营理使得解脱。莫使受苦。若比丘非时入聚落。应白和尚阿阇梨语比坐而入。是名入聚落法。非时集会者。除食时食粥时饮甜浆时。是余一切作法事时。如法如毗尼如佛教。是名非时集。若非时诸比丘集。此中有上座。上座应问诸大德。何故僧非时集。诸比丘答曰。有如此等法事。应当作故集。上座应作羯磨。若白一若白二若白四。是名非时上座集法。复有二种聚会。一众竟夜说经论议。二众默然端坐禅思。复有五日一会法。会时有上中下三众尽集。集已皆敛容整服端身静坐。兼复各相恭敬。威仪法则观者无厌。能生人善心。此是五日聚会法。听者摄心在法更无余缘。若说法者脱有忘误。听众应各自忆之。若无忘误。不中嫌呵言丰义滞。于法及说法者。皆应恭敬如奉帝释。不应自轻及轻法师。于智慧人所说法中不应散乱。定心而听。念念相续莫令有间。听法时内心应立五德。一未曾闻法今始得闻。二已曾闻法还令通利。三断我疑心。四正我所见。五增长净心。是为内五德。此事增一阿含中应广知。闻法有九利益。一生信心。二因信心欢喜。三欢喜爱乐。四舍贪求利养听法无疑。五正见成就。六断无明智慧心生。七断心上缠缚。八于四圣谛中得法眼净。九于五阴中得苦空无常无我观。得此观已内心踊跃。信心转深不可俎坏。得离烦恼证涅槃道受解脱乐。以是义故应至心听法

法会座中若有上座。应先须臾静坐。静坐竟当自为大众略说少法。说已观此众中。有七能者。上座当自请为大众说法。上座复应观。此法师所说法次第义味及与才辩。此文句不前后颠倒不。义相应不。文及义次第相续不断绝不。并才了了不。所说与三藏合不。复观法师说法称众情不。若所说文句及义不合三藏。乃至言说不了了者。不得讥嫌。上座应当语说法者。可略说法。众中法师众多。皆欲令说。若法师所说文句次第义理亦善。乃至所说才辩了了合三藏经称大众心。上座先应劳谢法师称赞微妙。大众亦应同共赞叹随喜。此座中有笃信檀越。上座应当广为说听法因缘所得利益。令增进善心转固不退。于此座中有比丘。欲为四众说法者。不得直尔而说。先语比坐。比坐比丘复当向上座说。上座不得辄听说法。要先观其所知德行。若必能者上座应当于大众前请其说法。若知才不任默然置之。若有外道来至会中欲坏正法者。上座应当与往返论议而降伏之。如法如毗尼如佛教示其义趣。有如此之德。名会中上座。若说法者。持波罗提木叉。自摄身口意善行三业。奉和尚阿阇梨奉上座。如上文中所说。此人当成就四念处法。于微罪中。生大怖想。应善学如是随顺行法。若我所说戒行。必令前人而信受之。受法以耳听者心缘不散如闻而行。是名为受。我若说慧若说定。若说涅槃应听受之。善摄耳根莫着余音。若我所说必欲令解

复次说法比丘。先自行阿练若行。复赞叹阿练若行。若我说阿练若行。当摄耳根而善听采。敢有所说必欲令解。乞食乃至三衣说法。说者应自行之。复应赞叹乞食乃至三衣。复教人行亦教人赞叹。若我有所说乞食乃至三衣。应善摄耳而听受用。我今所说必欲令解。复次说法比丘。应当筹量大众。应说何法而得受解。众若应闻深法当为说深法。应闻浅者为说浅法。不益前人名为恶说。何故不益前人。闻此浅法不欲听闻不求取解。何者名为深法。论持戒论定论慧论解脱论解脱知见论十二因缘乃至论涅槃。是名深法。应闻深者说如是法。乐欲听闻思求取解。是名为益。若乐浅者应为说浅。何者是浅法。论持戒论布施论生天论。若众乐浅。为说深不乐听闻。不求受解。不益前人。是名恶说。浅者为说浅法利益故。名为善说。复次若说法比丘。应知义文句男女之音。复能善巧方便说法。如其所知令前人解。复应善知文句义味次第前后不相间杂。若巧说者乃至微法。能令前人而趣向之。乃至最后行者。所以言最后行者。最后有二种。一者说法最后。名为最后。二者所说法最浅。名为最后。复就人名义。有二种最后。一者如须跋陀罗。最后得道。名为最后。二者如比丘比丘尼。此报身上得阿罗汉。此身亦名最后。复次说法者。欲说法时。应当先观四众比丘比丘尼优婆塞优婆夷众。若比丘比丘尼。应为说持戒定慧涅槃。若优婆塞优婆夷。应为说持戒布施生天乃至清净法。复次若说法者。应除贪心不染心不恶心不愚痴心不自轻心不轻大众心。应慈心喜心利益心堪忍心不动心无惑心。立如此等心应当说法。复次说法者。不应用余缘说法。应故说法。以法重难闻。此法是宝是药能利益人。是以故说。说者应慈心悲心为人说法。乃至一四句能使前人如实解者。于长夜中利益安乐。复作此念。用此次第满足句义。令听众平等得解。复次说法比丘。不应眼见利养而生贪心为人说法。不应怖心为人说法。何以故。若怖心为人说法。令身疲顿兼复所说言不比次音不辩了。若说法不妙义亦难解。若庠序安心为人说法。乃至义味皆亦明了。复次说法比丘。应当次第随顺说法。复应为众说厌患法远离法。当令前人心生欢喜求于解脱速得涅槃。若说法比丘。复应常念观身苦空无常无我不净。莫使有绝。何以故。当得十二念成圣法故。何者十二念。一念成就己身。二念成就他人。三念愿得人身。四念生种姓家。五念于佛法中得信心。六念所生处不加其功而得悟法。七念所生处诸根完具。八念值佛世尊出现于世。九念所生处常得说正法。十念愿所说法常得久住。十一念愿法久住得随顺修行。十二念常得怜愍诸众生心故。得此十二念具足。必得圣法。是名故说法。从难得法乃至观身不断绝。说法者所说法也

若说法众中有上座。观说法者乃至不称众情。上座应语说法者。长老不应作如是说。何以故。有五事因缘。为正法作留难。法不得久住隐没不现。何者为五。一者所诵经文不具足。所习学法不能究尽。所教弟子文不具足。师及弟子。所说不了义亦不尽。二者若学习者尽知三藏。文义皆具所说明了。若不教四部众弟子者。其身灭已法亦随灭。三者若僧中上座为众导首者。不修三业乐营世俗生死中业。其边所习学徒众弟子。不修三业乐营世事。如此徒众能灭正法。四者若有比丘。性戾喜嗔不随人语。闻善闻恶皆生嗔恚。若有国土所重知见比丘。皆舍避去不复往返是灭法之本。五者若有比丘。常喜斗讼朋党相助。共诤形势利养。如此五事能速灭正法。若说法者。语言辩了殊音亦正。所习文句及义皆悉具足。复称众情。如此说者。一切大众皆应称叹随喜。复有五法因缘。能令正法不速隐没。一者所诵习经文句具足。前后次第所有义味悉能究尽。复教徒众弟子同己所知。如此人者。能令佛法久住于世。二者广知三藏文义具足。复能为四部之众如所解教之。其身虽灭令后代正法相续不绝。如此人者。能使正法不坠于地。三者僧中若有大德上座。为四部所重者。能勤修三业舍营世事。其徒众弟子递代相续皆亦如是。此亦复令正法久住。四者若有比丘。其性柔和言无违逆。闻善从之闻恶远避。若有高才智德者训诲。其言奉而修行。是亦能令佛法久住。五者若比丘共相和顺。不为形势利养朋党相助共诤是非。如此五事能令正法流传不绝。是名说法中上座。尔时瓶沙王在楼上。见诸白衣皆相随而去。王问边人。此等诸众欲诣何处。诸臣答曰。外道有说法处到彼听法。王心中自念。彼此俱听。何不诣佛听法。尔时佛在王舍城。王即到佛所。头面礼足却坐一面。白佛言。世尊。外道日日说法。诸白衣辈日日大设供养。弟子意中愿。世尊。月六斋日聚集沙门讲说论议。弟子当作种种供养饭佛及僧兼得闻法。外道自言我法真正。佛若不说法。世人不识正法皆入邪道。如来以是因缘即集诸比丘。比丘集已默然而坐。诸檀越皆来集已。意欲听法语诸比丘。比丘闻已即白世尊。佛告诸比丘。听汝等呗。呗者言说之辞佛虽听。言说未知说何等法。诸比丘复咨问世尊。佛言。从修多罗乃至优波提舍随意所说。诸比丘佛既听说十二部经。欲示现此义复有疑心。若欲次第说文。众大文多恐生疲厌。若略撰集好辞直示现义。不知如何。以是因缘具白世尊。佛即听诸比丘引经中要言妙辞直显其义。尔时佛听说法。时有二比丘。同一坐中并共说一法。如来闻之即制不听。尔时会中复有一比丘。去佛不远立高声作歌音诵经。佛闻即制不听。用此音诵经。有五事过如上文说。用外道歌音说法。复有五种过患。一者不名自持。二不称听众。三诸天不悦。四语不正难解。五语不巧故义亦难解。是名五种过患。尔时瓶沙王笃信三宝。若佛及僧有所须者与欲随意。乃至浴池皆亦如是。瓶沙王晨朝大将人众诣池欲洗。遥闻池中言语诵经音声极高。即问边人。此是何人。从者白王。此是六群比丘。王即止所将侍从不听更前。恐惊动沙门。王住极久。比丘浴犹未讫。王不得洗即回驾还宫。如是展转世尊闻之。即制诸比丘。从今已去听十五日一浴。浴时不听高声大语。是名语法也

尔时诸比丘聚集一处。意欲系念思惟不乐言说。佛知诸比丘意。即告言。听汝等默然若系念思惟。若默然经行不言定心思义皆亦听之。是名不语法也。养徒众法。应教授以二事因缘当摄徒众。一法事摄。二依食摄。随力所能摄徒众多少也。比丘养徒众。主常应方便教授眷属。莫令多求。摄令坐禅诵经修福。于此三业中应教作种种方便。一教多求法。二教莫舍。三教勤作方便而修习学。复应观其徒众。不乐多言不。贪着多言不。于多言中不勤作方便不。复不乐多眠不。不贪着眠不。于眠中不勤求眠缘不。复观徒众。不多爱乐在家不。不贪着在家不。不勤求方便多作在家缘不。复应观徒众。不多乐聚集调戏欢乐不。于调戏中不贪着不。复不勤方便作调戏缘不。复应观其徒。众中谁行如法谁行不如法。若如法者。应加衣食乃至法味数数教授。若不如法者。应语令去。后时脱有改悔心者。还听在众。供给衣食教其法味。是名养徒众法。比丘众主入大众法。应敛容整服端身直视谦言下身恭敬前人。威仪庠序诸根寂静观者无厌。入僧之法应修如此德行。众者四众是。四众中有如法众有不如法众及自己众。如己所行入大众法。皆应教徒众。如此入大众也。是名入大众法。比丘作众主法在众中应观此众。于坐禅经行默念思惟言辞往返论说经义。乐何等法。若乐言辞论说者。随习何经。共论其所习莫违逆之。是名众主法。众中上座应观时人。当乐何法。为乐施论。为乐持戒论。为乐生天论。为乐涅槃论。随众乐何等论应为说之。复应观大众。于空无相无愿法中。当乐何等法。随众中所宜而为说之。是名众中说法上座法。尔时世尊在静房中思惟。当为比丘制戒。因缘如上文中所说。五种说戒亦如上文。比丘至五腊。要诵波罗提木叉使利。比丘说戒因缘如上文广说。一人布萨。二人三人布萨。如上文说。布萨中所作事。皆名羯磨。如上文所说。受安居法。亦如上文安居法。客比丘先语旧住者。若有难缘不听安居。更余处求觅不得强力而住。若安居处好。无檀越可语者。当自立心结安居法。比丘夏安居处。若僧伽蓝中。若别波演中。若树下。应先往看之。有敷具不。此住处无音声恼乱不。无师子虎狼贼蚊虫水等难不。此中可得安隐安居竟不。有石窟石篱不。若有者。彼中有草木。皆应料理除却之。此石窟中复应涂治。如是广应知。比丘夏安居时。应自思惟。此处安居饮食如意不。若病患时随病医药可得不。复观共住者。相随如意得好共事不。同住者可信不。共住得安隐行道不。若共行住坐卧时。不为我作留难不。若病时不弃舍去不。如是筹量众事和合已。然后安居。复观大众中。夏安居时此众中。无有健斗诤者不。不生我恶心恶语不。不能为我作留难不。复更思惟。如世尊说。夏安居要依波罗提木叉。此众中有知法解毗尼解摩得勒伽藏不。莫使我夏安居中脱有所犯欲除灭之无所趣向。又如世尊说。愚痴无所解者。尽形寿不离依止。复更思惟。此众中有僧如父母教训子者不。有名德高远道俗所敬重者。若我犯罪当诣彼生大惭愧求于忏悔。彼上座为怜愍心故。时时当教授令我不生放逸。如世尊说。破僧大恶。如坚涩苦辛无有乐者。此住处众中。无有健斗诤。夏安居中不起破僧因缘事不。当不为我作留难不。如是筹量无留难已。然后受安居。是名欲受安居时筹量法。诸比丘受安居法。先受安居法竟。然后受房舍敷具。房中应当修补涂治。及所坐床皆应一一料理。夏安居中若无因缘不得余行。若为因缘者。若为佛为法为僧为病者。应受七日法出界外。还来此中安居。为饮食利养不得出界外。为钵为衣为药为针毡。得受七日法出界外。尔时钵住王子。于佛法中出家。其父王为塔故大设供养。即遣信唤其子。可来共供养塔。夏安居中不得出行。以是因缘具白世尊。佛言。为塔故诸比丘听受七日法。七日满还此中安居。诸比丘夏安居法受七日。七日满不中过。七日及夜不来到安居处。比丘夏安居法即失。前衣钵乃至针毡因缘应勤方便。未解者令解。未得者令得。未证者令证。是名受安居法。安居众中上座。应当问大界标相处所。复问失衣不失衣处所。复应问净处所。问布萨处所。说戒说法。差说法人咒愿。差营事人。慰喻营事人。差行筹人。差僧净人。诸比丘出界外。七日十五日乃至一月。白二羯磨教授年少比丘。应当自教语劝人教语。如此等事皆应夏安居中上座所作。复应巡房看敷具。谁如法受用。谁不如法受用。如法受用者。示教利喜赞其所行。不如法者。应谏令忆念语言。长老应如法受用。不如法受用有五事过患。如来制戒应忆念此事。安居中上座法。若中食时食粥时及饮甜浆时。众中上座应唱言。尔许时已过。余有尔许时在。若众中上座。行如此等行者。是名僧父母。亦名僧师。是名安居中上座法。安居比丘自恣时得作一事。一者自恣时说见闻疑罪是也自恣后得作四事。一解大界。二还结大界。解界有二种因缘。一为大水漂标相坏不知处所。二为贼难故诸比丘皆出界外。有此二因缘故须解须结也。三受迦絺那衣。四安居竟受敷具。是事自恣后因缘。众者有四众。比丘众。比丘尼众。优婆塞众。优婆夷众。复有四众僧。一凡夫僧。二圣人僧。三惭愧僧。四无惭愧僧。比丘僧者。一二三不成僧。四人成僧。乃至二十人成僧。四人僧者。得作白一白二羯磨。不得自恣。不得受具。不得作阿浮呵那。除此三已。余一切法事皆得作。五人僧者。得自恣布萨。边地有律师得受具。中国不得。中国边地不得作阿浮呵那。二十人僧者。一切法事皆得。十人僧。除阿浮呵那。余一切法事得作。若四人作法事。少一人。法事不成。名为非法作法事。五人作法事处。少一人。法事不成。名为非法作法事。十人作法事处。少一人。法事不成。名为非法作法事。二十人作法事处。少一人。法事不成。名为非法作法事。是名僧事。入僧法。从敛容乃至生人善心。如上文中所说。入僧时用心法。如扫帚扫地。不见是非普起慈心。应如是心入僧。是名入僧法

入僧中坐法。入僧中时应恭敬上座。自知坐处所。复不得宽纵多。取坐处。若僧中见作非法事欲谏者。恐僧不用其言。可忆识默然而坐。若比丘入僧中时。应筹量僧所作法事。为如法为不如法。与毗尼相应不相应。若相应者善。若不相应者。有同心如法行毗尼者可共谏之。若无默然而坐。是名入僧中事

若僧集时。众中上座。应观中座下座。威仪坐起如法不。不裸露不。若坐不如法。兼有裸露者。上座应当弹指令中下座知。若犹不觉者。应遣使语之。僧中事上座皆应料理。中座比丘众中坐时。应观上座下座。坐如法不。衣服自覆形体不。若不如法者。应弹指令知。若犹不觉。应语知法人使往语。上座自知时。语下座言。长老自知时。于上座边应供养恭敬尊重赞叹。是名中座法

下座众中坐法。众坐已定。应看上座中座。坐及衣服如法不。若不如法。应弹指令知。若复不知。亦遣知法人往语。大德自知时。于上中座复应供养恭敬尊重赞叹。下座僧中应取水洒地及涂扫令净。僧浴室中应燃火。佛制下座僧中所应作法。皆应作之。是名下座法。从无腊乃至九腊。是名下座。从十腊至十九腊。是名中座。从二十腊至四十九腊。是名上座。过五十腊已上。国王长者出家人所重。是名耆旧长宿。一切僧所行法应学。学净持戒。净持戒者。一切佛所制戒皆能受持。无微毫之失。故名持戒得净戒净。心戒者。禅戒是也。持心不散得与定合。故名得心戒也。净慧戒者。守持此慧不令散乱得见四谛。名净慧戒。一切人若有信心持戒者。应当作心生如是念。若犯微细戒生于怖心与重戒无异。作如是持戒者梵行清净。所受持波罗提木叉戒亦清净。一切应修身业口业意业令成就善行。乃至能防身口意不作十恶。是名一切人所行法

尔时世尊在毗舍离。诸离车子等设食请僧。有种种美食。僧食过多皆患不乐。耆婆医王观病处药。若得浴室此病可差。复欲令只桓精舍中浴室得立。以是因缘比丘往白世尊。佛听诸比丘作浴室。浴室法。应垒泥作。若土不可得处。用木作之。当以泥涂。此浴室中。一壁下燃火令热。余壁下敷床洗浴。入浴室洗法。随上座须热当闭户须冷当开。下座不得违上座。入浴室洗时。上座应先入取好床洗浴。此入浴室中洗法。因六群比丘佛制也。又一时比丘。共俗人入浴室洗。佛闻之不听。比丘不得与白衣一时浴室中共洗。若有笃信檀越听之。后一时诸比丘。皆裸身入浴室中共洗。各各相视皆生惭愧。因此展转乃彻世尊。佛言。从今已去不听裸身共入浴室洗。复不得相洗。若一有衣一无衣。有衣得与无衣者淋水。亦得洗之。无衣者不得灌水洗他。若浴室去水远者。听浴室中安池水。亦得凿井。入浴室洗法如是应广知。入浴室洗僧中上座。若见浴室中大热小开户令暂冷。复应为入浴室众僧说洗因缘。洗者不为严身净洁故洗。当为说厌患身法。复为说调伏心法。当生慈心。为令得少欲知足而为说法。复更为说。此澡浴者不为余缘。但欲令除身中风冷病。得安隐行道故洗。是名浴室中上座所作法用。共行弟子共宿弟子奉事和尚阿阇梨。和尚阿阇梨畜弟子法。此皆如上文所说。沙弥法。沙弥得除草净地取杨枝取花果。取来已应白和尚。和尚阿阇梨应当受取受用。沙弥法应知惭愧。应善住奉事师。法中不应懈怠放恣。应当自慎身口卑已敬人。应常乐持戒。莫乐调戏。亦不应自恃才力。复莫轻躁。应知惭耻。复不应说无定乱言。敢有言说应庠序合理。常应自知净不净法。常应随逐和尚阿阇梨读诵经法。一切僧中有所作皆不得违逆。如是广知。共伴行时前行比丘法。在前应回顾看后者。所著衣齐整不。不参差不。不骞缩不。不摄心不。作不威仪行不。若入他家于妙色上不起染心不。若见珍琦异宝不起盗心不。有比丘僧遣比丘到檀越边忏悔。受使比丘到檀越舍在前入。应作如是语语檀越言。此比丘众僧已讁罚竟。可受此比丘忏悔。是名前行比丘法。所以言前行者。受僧使往先入檀越舍语。名为前行。又复同道来时。僧遣此比丘引道在前到檀越处。亦名在前

后行比丘应成就五法。一行时不应在前而去。二不得远在后。要次后而行。三前比丘若是和尚阿阇梨若是上座。其所言说不得违逆。若问行道诵经所修之业。皆应实答不得藏隐。除得禅得圣果。若前有所说善法。胜者应随喜赞叹。四若有不达忘误处。应语此处所说不合佛意。夫欲语不是处者要屏猥语。五若得如法财。及投钵中所得。皆应为取料理。是名后比丘五德。若比丘为在家人作师。教化作福田者。有五事不得。一不应依此檀越舍止住。二不应系心贪其利养。三不应为檀越总说法示教利喜。应别教转修余法。余法者。布施持戒受八斋法。如是一一说之四不得与在家人戏乐共相娱乐。五不得系心常欲相见。复有五事不得。一若檀越未亲旧处。不得强作旧意而往。二复不得求其形势料理檀越家业。三不得私共檀越窃言。四不中语檀越良时吉日祠祀鬼神。五不得于亲旧檀越处过度所求。比丘应成就五法。当为檀越尊重恭敬。何者为五。一者非亲旧处不应往返。二不自求形势料理檀越家业。三不共檀越窃言令他家中生疑。四不教檀越良时吉日祠祀鬼神。五不过度所求

比丘入檀越家。应成就五法。一入时小语。二敛身口意业。三摄心卑恭而行。四收摄诸根。五威仪庠序发人善心。是名入檀越舍五法用。比丘有九事一知檀越心不应坐说法。若比丘入他舍时。檀越虽为礼拜。知不实生恭敬心者不应坐。二虽往迎逆。心不殷重亦不应坐。三虽让令坐。知心不实。亦不应坐。四虽请令坐。安不恭敬处。复不应坐。五设有所说。法言及非法言。心不采录亦不应坐。六虽闻有德不信受之。亦不应坐。七若有所求索知有甚多。而少与者亦不应坐。八到其舍时。设有美食不施设之。而办粗食亦不应坐。九虽供给所须。如市易法与。亦不应坐。复有九事。知檀越心应坐说法。一者知有敬心而礼。二知敬心迎逆。三知敬心故请入。四知重心故敷坐处高。五知心受教故。法言及非法言。皆摄受用。六知闻其德生信。七知少难得而更得多。八知先有粗食而更为办细美之食。九知有所欲好心施与。用此九事因缘。知檀越心者。应坐为说法

比丘若入白衣舍时。如月光喻摄心。若入聚落行时。应卑恭惭愧而行。不应高心放逸无有惭愧散乱而行。摄心之法。譬如人足蹈高山悬岩绝崄方寸之处。念念生怖更无余念。亦如有人于峻极之处临于深渊。但生怖心更无余念。入聚落时摄心不散亦应如此。诸比丘汝等摄心入聚落时。如迦叶入聚落行也。佛问比丘。汝等入聚落。如月徐行不。有惭愧不。汝自忆念心中所念行不。如高岩深渊喻生怖心不。摄身口意不。令放逸不。汝不如深毛羊入荆棘中随着而住不。为六尘利养所牵住不。入聚落时如怖畏牢狱枷锁不。汝入聚落时不生着心。如着弶鹿得脱不。忆念本处不。是故比丘入聚落时。如上种种喻应行。入聚落时如蜂采华不损色香而饵其味。入聚落时。不着色声香味触法。但为其善而行聚落。如世尊说。若有比丘欲入聚落时。生如是念。檀越所有尽施于我。莫与余人。愿多与我莫与我少。愿施好者莫与我恶。心恭敬故施莫不恭敬而与。作是念已入聚落中。所求种种皆不如愿。于所求处皆生退心。愁忧惭愧苦恼不乐。若有比丘。欲入聚落乞时。不作如此念。檀越所有尽施于我莫与余人。愿多与我莫与我少。愿施好者莫与我恶。乃至不恭敬而与。不作此念入聚落时。所得多少好恶如此等。不生愁忧惭愧苦恼之心。诸比丘。迦叶入聚落时。终不生如此等念。不生此念故。于好恶多少一切事中。不生退心。乃至不生苦恼不乐之心

  汝行时恒常　　如蜂采花木
  所获好恶中　　或迟或疾得
  如蜂取花味　　不坏其色香
  仙人行世间　　修善亦如是
  彼此不相违　　正观其过患
  应自观其身　　好恶作不作
  汝敷具有不　　家系缚脱未
  犹座而自缠　　如蚕虫处茧

是故如蜂喻入聚落而行。于六尘不取其味。如空中手无有碍处。入聚落时心无所碍亦应如此。如世尊说告诸比丘。汝等意谓行何等行。比丘堪为檀越家作师范耶。比丘即答佛言。世尊。是诸法根本。亦知诸法次第。亦是大医。唯愿世尊。为我等解说。诸比丘闻已然后得解。世尊即时动手于空。告诸比丘言。此手今空中回转无碍无系缚。诸比丘行世心无碍无系缚亦应如此。若人求财者作心制身然后乃得。若欲求福系心苦身后乃得报。若有比丘。于好于恶心生平等。见他得利如已所得。心生随喜。如此比丘堪为世人作师。诸比丘。迦叶入聚落时。不碍不缚不取。欲得利者求利欲得福者求福。如自已得利欢喜。见他得利欢喜亦复同之。如手空中转无碍无系缚

  若善入聚落　　衰利心平等
  同梵共入聚　　不生嫉妒心
  汝所亲识舍　　无别亲旧处
  是名师行法

比丘入檀越家内所行法。不应调戏。不应自恃憍慢。不应轻躁。不应无忌难所说。不应杂乱无端绪语。不应坐处远故低身就他共语。复不应相逼坐共谈。不应偏蹲危坐。不中大笑而坐。虽执威仪不应示现有德相貌而坐。不应累髀而坐。不应累膝而坐。不应累脚而坐。不应用手左右捞摸而坐。不应动脚不住而坐。不中大瓮器上而坐。不中与比丘尼独静房内而坐。不中与女人独房内坐。不得下处坐为高坐人说法。比丘应一切衰利中常应忍辱。是名入家中比丘坐法。入家中上座比丘法。上座应知时知齐量知己。身知大众知人德行高下。应教诸比丘威仪。应为诸白衣如法而说。教令听法教令读诵。如是应广种种教诸善法。咒愿时到复应咒愿。是名家中上座法

尔时世尊在舍卫国。憍娑罗国有一住处。众多比丘欲夏安居。诸比丘共相议言。我等夏安居中。云何得安隐安乐行道。复共议言。欲得安隐行道者。当共作制。不听有所言说。欲有所须。当用手作相貌索。夏安居竟。诸比丘相随。到世尊所礼拜问讯。佛见已知而故间。夏中得安隐欢乐行道不。诸比丘答世尊言。得安隐行道。佛复问言。汝等共作制限。答言。共作不语法限。佛言。此作冤家法限共住。乃至是苦云何言乐。从今已后不听诸比丘作不语制

是众上座布萨时。若有檀越来。应为说法慰喻。于一座中有比丘。字优波斯那。其性闇钝不习学三藏。兼言辞讷钝。僧聚集时有檀越来。不能为说法不能慰劳答谢。檀越心疑。不知众僧为何缘见慊无所言说。如是展转世尊闻之。告诸比丘。从今已去众集时白衣来者。上座应当为说法慰喻。上座若不能者。当语第二上座。上座若不语得罪。若语第二上座。不用其言。亦自得罪

比丘行道中。若见同出家人及见白衣。应当问来方所语言。善安隐来不。是名言语法一时有众多比丘在路而行。身体疲极意欲止息。心疑不敢。后时往白世尊佛言。听诸比丘远行之时路边止息

若和尚阿阇梨有所犯。众僧羯磨驱出。羯磨成已弟子即失依止。若弟子犯事。众僧羯磨成已亦失依止。若弟子和尚阿阇梨语言。从今已去不须我边住。心决定者。尔时即失依止。若明相未现。与和尚阿阇梨别亦失依止。若比丘僧中有所犯事。僧与讁罚。若此比丘求乞一日。假至后日者。上座应听呵责羯磨驱出羯磨发起善心羯磨实示现羯磨覆钵羯磨不语羯磨。如此羯磨忏悔已。后众僧与作舍羯磨。是名放舍法。经行处经行。不得余处经行。坐禅处坐禅。不得余处。行时不中生疲厌心。不中生散乱心而行。若经行处地不平者。应当平之莫令高下。尔时世尊在波罗只国。告侍者那伽波罗。取吾洗浴衣来。得已着衣经行。佛经行时。帝释化作金舍。前礼佛足白世尊言。愿受此金舍经行。尔时佛在毗舍离经行。六群比丘着革屣随佛经行。佛言。弟子法。和尚阿阇梨前着革屣经行。乃至经行处亦不得经行。况吾前着革屣。吾经行处经行耶。如是广应知。有行摩那埵比丘。众僧经行处经行。佛见之即制。不听有罪比丘清净比丘经行处经行。有比丘露地经行。值天大雨污湿衣尽愁忧不乐。佛闻已告诸比丘。听比丘作经行舍。比丘在耆阇崛山中露地经行。值天卒风暴雨兼复日热所逼。佛闻此因缘。听诸比丘作经行舍。复于一时比丘尼住处。下座比丘尼在上座尼前经行。憍慢自大无恭敬心。六群比丘尼。见诸下座尼恼上座亦学。故来上座前经行。以是因缘世尊闻之。不听下座比丘尼上座前经行。上座尼经行处。下座尼不得在中经行。有比丘体上生疮。医教治法。用唾涂疮上。烧热瓦熨之。令加脱疮得差。医如此分处。佛即听之。有一时诸比丘。在僧房中新涂治彩画。为寒故燃火。烟熏彩色皆坏。佛闻之不听。若寒者教露地燃火自炙。诸比丘后时白世尊。露地燃火自炙。炙前后寒炙后前寒。不能令温。佛闻之。听房中燃火自炙。但使无烟。诸比丘住处房前巷间。处处小便污地臭气皆不可行。佛闻之告诸比丘。从今已去不听诸比丘僧伽蓝中处处小行。当聚一屏猥处。若瓦瓶若木筒埋地中就中小行。小行已以物盖头。莫令有臭。有诸比丘。寒时露洗足。寒切极苦。佛闻之。听用或铜或瓦或木作器着舍内就中洗足。诸比丘所用钵生穿破。破处饮食在中臭不可用。佛听作熏钵炉。若麻子若胡麻子捣破用涂钵。炉上安钵在中熏之。此炉熏钵已竟。好举莫令见雨

若比丘用神通力在空中住。欲受戒者师及众僧在地。不得受戒。若师在空中。受戒者及众僧在地。亦不得受戒。若僧在空中。师及受戒者在地。不得受戒。师及弟子及众僧皆在空中。亦不得受戒。何以故。空中无齐限可结界故。若比丘夜中着三衣肩上。乘神通向余处去。不失衣也。若衣在地。比丘乘神通在空中。若明相未现。还下足蹈衣边地。不失衣。若明相现。足不蹈衣边地。失衣。何以故。空是界外故。有诸比丘。乘神通空中思欲饮水。佛听饮之。虽听饮水。未知何方而得饮水。若持衣入水恐落水中。若着岸上复恐失衣。佛教令取水时一脚入水一脚在岸上得取水。是名虚空法。气有二种。一者上气。二者下气。出时莫当人张口令出。要回面向无人处张口令出。若下气欲出时。不听众中出。要作方便出外。至无人处令出。然后回来入众。莫使众讥嫌污贱。入塔中时。不应放下气令出。塔舍中安塔树下大众中。皆不得令出气。师前大德上座前。亦不得放下风出声。若腹中有病。急者应出外莫令人生污贱心。扫地法。不中众在下。不得在上风扫地。食粥法。不得张口哈作声。粥冷已徐徐密哈之。是名食粥法

尔时世尊在王舍城。有一比丘。婆罗门种姓。净多污。上厕时以筹草刮下道。刮不已便伤破之。破已颜色不悦。诸比丘问言。汝何以颜色憔悴为何患苦。即答言。我上厕时恶此不净。用筹重刮即自伤体。是故不乐。诸比丘以上因缘具白世尊。佛唤此比丘问。汝实尔不。比丘白佛。实尔世尊。佛言。汝犹尚自污其身。况复余人。佛种种呵责此比丘已语言。应当自拥护身。若欲便利时。不得恣意用力放令出声。应当徐徐渐渐令出。上厕去时。应先取筹草至户前三弹指作声。若人非人令得觉知。户前安衣处脱衣着上。若值天雨无藏衣处。持衣好自缠身。开户看厕内。无诸毒虫不。看已欲便利时。应徐徐次第抄衣而上。不得忽褰令露身体。坐起法。不中倚侧当中而坐。莫令污厕两边。欲起时衣。次第渐渐而下。不得忽放。上厕法。一一三摩兜犍度中广明。诸比丘上厕时。坐起处危疲寄。佛闻此已。听行来处安好板。莫令高下不平。起止已竟。用筹净刮令净。若无筹不得壁上拭令净。不得厕板梁栿上拭令净。不得用石。不得用青草。不听诸比丘土块软木皮软叶奇木。皆不得用。所应用者。木竹苇作筹。度量法。极长者一磔。短者四指。已用者不得振令污净者。不得着净筹中。是名上厕用厕筹法。尊者迦叶惟说曰。得用石用瓦。昙无德不听也

上厕有二处。一者起止处。二者用水处。用水处坐起褰衣。一切如起止处无异。厕户前着净瓶水。复应着一小瓶。若自有瓶者当自用。若无瓶者用厕边小瓶。不得直用僧大瓶水令污。是名上厕用水法。嚼杨枝法。尔时诸比丘不嚼杨枝。口气臭可恶。不嚼杨枝有五过患。一口气臭。二咽喉中不净。三痰癊宿食风冷不消。四不思饮食。五增人眼病。嚼杨枝有五种功德。一口气香洁。二咽喉清净。三除痰癊宿食。四思食。五眼无病。有诸比丘。嚼杨枝时。或就僧坊内。或就众僧净地。或在经行处。或就师前。或大德上座前。佛闻之皆制不听。复有诸比丘。木皮作杨枝。复有诸比丘。嚼短杨枝。即入咽喉中作患。佛亦制不听。杨枝法度。长者一磔手短者四指。弟子法。应晨朝取杨枝授与和尚阿阇梨。迦叶惟说曰。嚼杨枝法。短者四指嚼两指。塔前众僧前和尚阿阇梨前。不得张口大涕唾着地。若欲涕唾当屏猥处。莫令人恶贱。是名[口*弟]唾法

诸比丘食后须摘齿者。当用铜铁骨竹木苇作。不得令头太尖伤破。若摘齿竟应洗净。莫令有陈宿食使他污贱。是名摘齿法

诸比丘耳中尘垢满。时佛听用铜铁骨角竹木苇作却耳中垢

晨起嚼杨枝竟。须刮舌者。佛听用铜铁木竹[竺-二+韋]作刮。是名刮舌法

小便法。欲觉知时即应起去。不得耐久住。是名小便法。小便处应安木屐。欲小行时。当着屐屐上。莫令[口*弟]唾小便污上。诸比丘住处。若有老病不堪远上厕者。听私屏处若大瓮若木筒埋地中作起止处。好覆上莫令人见。此行来处上应安好板莫令不净污之。云何名为不行。受具足者名之为行。不受具足名为不行

云何名为行法人。受具足者名行法人。不受具足名不行法人。是名行法。又行者。佛所听者行。名为行。佛所不听者。虽行名为不行

云何复名为行。法言是法。非法言非法。轻言是轻。重言是重。是名为行。非行者。法言非法。非法言法。轻言是重。重言是轻。是名非行法

又复行者。身三业乃至十善业是。不行者。身三业乃至十不善业是。又复行者。八正道是行。八邪道非行。又复行佛所制戒随顺行者。名之为行。不随顺行者。名为非行。是行非行法。第三事竟。略名一切章句。如是应广知

毗尼母经卷第六毗尼母经卷第七

        失译人名今附秦录

犯罪凡有三种。一者初犯罪缘。二者因犯故制。三者重制。云何名缘

尔时世尊在修赖吒国游行。迦兰陀子修提那。为续种继后故作欲心。与其本二行欲。因此初犯。佛集诸比丘。是名为缘。云何名为制。若比丘行非梵行。乃至畜生。犯波罗夷不共住。是名为制。云何名为重制

尔时世尊在毗梨只国。有一毗梨只子出家。后不乐道常思念欲事。归家即共其本二行欲。行欲已讫即生悔心。制本住寺。向诸比丘说所犯事。诸比丘闻已往白世尊。佛告诸比丘。初入犯波罗夷。如毗舍离林中乞食比丘。此是重制

尔时尊者优波离。即从座起整衣服顶礼佛足胡跪合掌。白佛言。世尊。若有人于畜生边行淫。此为犯不。佛告优波离。初入亦犯。优波离复问。非道行淫为犯不。佛言初入亦犯。初入犯因缘。如律中广解

重制有二种因缘。一者急二者缓。急者。乃至畜生与人同犯。是名为急。云何名缓。若有比丘欲舍道还俗行淫者。听舍戒还家。若后时还乐在道者。听出家与受具足。是名为缓。如难提伽比丘犯重。听忏悔在大僧下沙弥上。此亦是缓。譬如国王有犯罪者一者急二者缓。重制中亦如是。一缓一急。是故三处得决所犯事

复有三处决了非犯。一者缘。二者制。三者重制。缘者。佛未制戒时初犯者此是缘。制者。初犯者制不犯戒。是名为制。重制者。若比丘比丘尼不得自在。为强力所逼强。共行欲不受乐者不犯。是名重制。是名三处决断不犯。复有三处决断所犯。一缘二制三重制。缘者。尔时世尊在王舍城。陀腻加比丘不与取。瓶沙王所护材木。如来欲令后比丘更不作过患。以此事故集诸比丘。是名为缘。若比丘若空地若聚落不与取犯波罗夷。是名为制。若自取若为他外逻教取若遣人取。是三处不与取犯波罗夷。是名重制。若他所有不作他想取犯突吉罗。此亦重制。一切所犯。如此三处决了应广知

重制复有二种。一者急二者缓。急者。乃至草木小叶他物不与不得取。是名为急。缓者。若他物不作他想取。是名为缓。是名三处决断犯

复有三处决断不犯。一缘二制三重制。缘如上说。制者。初未结戒时不犯。是名为制。重制者。他物他想不取。乃至不起盗心。是名重制

尔时世尊在毗舍离。有比丘住跋裘河边。起不净想厌患此身。以衣钵雇比丘相杀。如来欲断如此恶因缘故。集诸比丘。是名为缘。制者。若比丘断人命。得波罗夷。不应共住。是名为制。重制者。从受母胎乃至老时断人命者。皆得波罗夷。是名重制

复有重制。若人病求欲自杀。比丘若自与刀。若教人与刀。若自与药。若教人与药。如是等众多方便。皆名重制。重制有二因缘。一者急二者缓。急者。一切不得杀乃至蚁子。是名为急。缓者。若人作非人想杀者不犯。是名为缓。此是三处决断所犯。复有三处决断不犯。一缘二制三重制。缘者如上说。制者。初未制戒时作不犯。是名为制。重制者。于一切众生上不起杀心。是名重制。以是义故。名三处决断不犯

复有三处决断。一缘二制三重制。缘者。尔时世尊在毗舍离跋裘河摩帝寺。诸比丘为乞食故。故妄语。如来断此因缘。集诸比丘。是名为缘。制者。若比丘自称得过人法。是比丘得波罗夷。不应共住。是名为制。重制者。自称得身念处。乃至自称言得果。是名重制。重制复有二种。一急二缓。急者。一切不得妄语乃至戏笑。是名为急。缓者。若欲故作妄语。语不成令人不解者得偷兰遮。是名为缓。是名三处决断所犯

有三处决断不犯。一缘二制三重制。缘者即如上说。制者。初未制戒时所作不犯。是名为制。重制者。如增上慢比丘。实未得道。闻边人说其得道。意谓实得。后翘勤不已。得阿罗汉果。知其本谓得者不实。心疑问佛。佛言不犯。是名重制。此是决断三处不犯。如是乃至众学。皆以此三法推可知

复次应推缘。一钵二衣三尼师檀四针筒五道行人六人七房。钵缘者

尔时世尊在王舍城。王舍城有一长者。其家中有大栴檀木作钵。乃至集诸比丘。是名为缘。制者。不应畜栴檀钵。是名为制。重制者。不应为诸白衣现神通力。是名重制。复有重制。比丘不应畜木钵石钵金钵银钵宝钵珠钵。不应架上安钵。不应泥团上安钵。乃至不应湿钵置钵囊中。此杂犍度中广明。是名三处决断犯。不应坐钵上。不应卧钵上。不应钵中盛水洗手足。一切处不应用。除病。不应用钵除粪。不应不爱护钵。敬之如目。除病。是名三处决断犯

复有三处。应决断不犯。一缘二制三重制。缘者

尔时世尊在波罗奈。诸比丘白佛。我等应当畜何等钵。是名为缘。制者。听诸比丘畜笼口钵更竖钵。是名为制。重制者。听诸比丘畜铁钵苏摩钵乃至赤钵。皆应畜之。是名重制。复有重制。若钵挂肩腋下使破者。听作筐盛之。若苏摩钵破者。劫波缕麻缕缀之。乃至用落沙胶之。若铁钵生穿破。应打铁令薄补熏受用。长钵不应过十日畜。钵破未过五缀。不应舍更求余钵。比丘尼得钵。即日作净施。不应过夜。此亦是重制

衣缘者。一缘二制三重制

尔时世尊在舍卫国。六群比丘畜上色衣。佛集诸比丘。是名为缘。制者。不听畜上色衣。是名为制。重制者。不得畜锦衣白衣。不听畜有须衣罗网衣。是名重制。又复不听裹头行。又复不听畜革行缠除因缘。不得用僧伽梨裹木新面牛屎草土。不得脚蹑僧伽梨。不得揲僧伽梨敷坐。不得衬身着僧伽梨。不得不爱护僧伽梨。如自护其皮。是名重制。此是三处决断所犯。复有三处决断不犯。一缘二制三重制。缘者

尔时世尊在波罗奈。有诸比丘。白佛。我等应当畜何等衣。是名为缘。制者。听诸比丘畜粪扫衣。是名为制。重制者。听畜十种乃至粪扫衣。又复比丘畜长衣不过十日。若有水火盗贼失衣者。有檀越大持衣来施。得受三衣不得过取。比丘得新衣。应作三点净。若比丘衣破听着衲。是名三处决断不犯。尼师坛。有三处决断所犯。一缘二制三重制。缘者

尔时世尊在舍卫国。时六群比丘畜尼师坛。长广过度。佛因是集诸比丘。是名为缘。制者。若诸比丘畜尼师坛过量。是名为犯。齐量者。长二修伽陀搩手半。广一修伽陀搩手半。重制者。不应畜上色尼师坛锦尼师坛帛尼师坛革尼师坛。不得用尼师坛裹木柿奈乃至裹土。护尼师坛法如护身皮。是名重制。此三处决断所犯

复有三处决断不犯。一缘二制三重制。缘者如上说。制者。如佛齐量作。是名为制。重制者如佛度量作十种袈裟。衣财中染作袈裟色亦得作。是名重制。此三处决断不犯

针筒。有三处决断。一缘二制三重制。缘者

尔时世尊在王舍城。有针筒工师。信心三宝请众僧。常施针筒。常施不已。贫不自活。佛闻已集诸比丘。是名为缘。制者。不听比丘畜骨牙角针筒。是名为制。重制者。有诸比丘用上色作针毡。锦帛革作针毡。佛不听用上色乃至革作针毡。是名重制。此针毡筒。应好秘密藏之。不听与白衣持行。何以故。有一比丘。共贾客同路而行。尔时比丘语贾客言。我有因缘须下道行。可为我持此针筒去。须臾相及。道人去后。持直百千两价金珠着针筒中。道人来还。与针筒不语令知。至税处过已。还唤来捡挍。税主针筒中得此宝珠。种种呵责道人。极受苦恼。佛闻之制曰。从今已去不听与白衣持针筒行。是名重制。此是三处决断所犯。复有三处决断不犯。一缘二制三重制。云何名缘。缘者如上说。制者。如初未制戒不犯。是名为制。重制者。用铜铁铅锡竹苇木泥石作针筒听畜。复听比丘用十种衣裁作针毡受用。是名重制。此是决断三处不犯

复有三处决断所犯。一缘二制三重制。缘者。尔时六群比丘常行诸国。夏时或值天雨水涨漂失衣钵。或伤众生乃至践蹋生草。诸檀越慊言。外道持戒者。畏伤杀众生。夏犹不行。况佛弟子慈心者冬夏所求无有厌足。鸟依林树。野兽依山。皆有住时。云何比丘无暂时息。以是因缘世尊闻之。集诸比丘。是名为缘。制者。不听比丘夏安居中行。是名为制。重制者。有一比丘。夏安居时。结安居已无缘而出。夫安居法。结安居竟。不得无缘而出。如婆难陀释子杖头挂毛毳而行。皆不听也

又如六群比丘。共比丘尼同路而行。复不中共盗贼同路而行。乃至不得如婆难陀释子擎宝盖着道而行。复不得挂钵络幢头而行。一切行路中所不应作。如是应广知。是名重制。此是三处决断所犯

复有三处决断不犯。一缘二制三重制。缘者如上说。制者。若不及前安居。及后安居者。此亦不犯。复非无缘出行。此亦不犯。复有比丘。受七日法出到家中。知日尽欲来。母不听之。过七日已作失安居想。往白世尊。佛言。若心决断欲来。母不听者不失安居。若比丘夏安居竟。应移余处住。若有缘。不得去者不犯。若无缘。安居竟出外一宿还来亦不犯。是名重制。此是三处决断不犯。复有三处决断所犯。一缘二制三重制。缘者

尔时世尊在王舍城。中有童子十七群。最大者年十七。下者十二。上富者。有八十亿万钱下贫者。有八十万钱。此童子中。一者父母所爱。字优波离父母生念。我唯有此一子。我百年后。云何得令此子长命老寿无苦常得安乐。意欲令学书诵经。恐复眼劳受苦。若欲教画。恐立久脚疼。若教天文算计。恐劳身心。又复思念。沙门释子常处闲静志求无为。此乃是大乐。可安着沙门中。复有十七群童子。是其伴侣。数数来唤相随出家。于是父母放令出家。师即为受具足戒。但年小昼二时食。夜未晓复啼索食。佛以天耳闻其啼声。即集诸比丘。是名为缘。制者。年满二十听受具足。是名为制重制者。年未满二十而不得受戒。复有十三种人受戒不听。于十三种中。若受一人戒。知不应与受戒。而与受戒者。受戒师亦有所犯。是名重制。此三处决断所犯

复有三处决断不犯。一缘二制三重制。缘者如上说。制者。如未制戒前不犯。是名为制。重制者。年满二十与受戒不犯。若不知年未满二十。受戒者亦不自知。与受戒不犯。有一沙弥。年未满二十受具。心中生疑。为得戒不。往白世尊。佛言。听汝数胎中年。若不满者听数闰月。若复不满者。听数十四日布萨。数十四日布萨复不满。佛问诸比丘。此人得阿罗汉果未。诸比丘白佛言。实得阿罗汉果。佛语诸比丘。此是上受具。若如此者。虽未满二十得具足。不犯。如耶输陀善男子等受戒得戒不犯。乃至珊阇耶伽优婆提舍拘律陀等。二百五十人及余人等受戒得戒。是名重制。此是三处决断不犯

复有三处决断所犯。一缘二制三重制。缘者。尔时世尊在王舍城。听阿罗毗比丘作私房。此阿罗毗比丘作房广长。所须甚多求索非一。此比丘住处村舍诸人。遥见比丘皆避入舍不欲相见。佛闻此因缘集诸比丘。是名为缘。制者。比丘无主私乞作房。应量作若过犯僧残。是名为制。重制者。如尊者阐陀私作房。从王索材。王言自恣听取。即伐路中一切人所贵重树。世人慊言。云何比丘无慈心断树生命。佛因是制戒。私作房不得伐路中大树。是名重制

复于一时。世尊在拘睒弥国。阐陀比丘私作房。用有虫水和泥作房。作房竟有余长泥。尽取[卄/積]在房上。房即崩坏。佛因此制戒。不听私作房伐路中大树。不听用有虫水和泥。不听[卄/積]泥着屋上。是名重制

尔时尊者罗睺罗。在那罗伽波宁。有一檀越笃信三宝。于尊者罗睺罗边生恭敬心。为罗睺罗私起房。作房竟即请罗睺罗受用。罗睺罗数时受用。舍向余方教化。房主复用此房施多人。罗睺罗后时来到。闻已以此因缘具白世尊。佛教罗睺罗。汝到檀越边问之。檀越见我身口意有何等过。檀越答言。不见有过。罗睺罗还到佛所。具说檀越之言。佛因此即集诸比丘。或有施如法施如法受如法用。或有施不如法施不如法受不如法用。若有檀越。自出意作房施一人。若后时转施与众多人。是名不如法施不如法受不如法用。若有人自意作房施与一人。后时转施与众僧。是名不如法施不如法受不如法用。若有出意自作房施众中一人。此众后时分作二部。若回此房与一部。是名不如法施不如法受不如法用。若有檀越自出意作房施众多人。后时转施一人若转施大众。此皆不如法施不如法受不如法用。如法者。若施一人一人受用。施众多人众多人受用。施众僧众僧受用。若僧分作二部。施一边一边受用。是名如法受用。是名重制。此三处决断所犯

复有三处决断不犯。一缘二制三重制。缘者即如上说。制者。如初未制戒时所作不犯。是名为制。重制者。若众僧示作房处。所作齐量无诸妨难。若复作塔为僧作房舍不犯。是名重制。王舍城中有檀越。为僧起六十口房。皆不犯。是名重制。此三处决断不犯。一切不犯者。顺佛教而行是也。犯者。违佛教行是也。比丘法。佛所听者应作。佛所不听不应作。如初中后亦如是。云何名毗尼。毗尼者。凡有五义。一忏悔二随顺三灭四断五舍。云何名为忏悔。如七篇中所犯。应忏悔除。忏悔能灭。名为毗尼。云何名为随顺。随顺者。七部众随如来所制所教。受用而行无有违逆。名为随顺毗尼。云何名灭。能灭七诤。名灭毗尼。云何名断。能令烦恼灭除不起。名断毗尼。云何名舍。舍有二种。一者舍所作。二者舍见事。舍作者。十三僧残是也。就十三中。九事作即成不得谏。四事三谏不受。僧为作白四羯磨。罪成。成已若白三羯磨悔事不成。如此十三名舍作法。见者。如阿梨吒比丘说言。我亲从佛闻。行欲不能障道。舍是见故名为舍也。此二种名舍毗尼。总有二种。一可发露。二不可发露。可发露者。比丘十三僧残。比丘尼十九僧残。六三谏此有羯磨可除罪。名可发露。不可发露中。尼有一事可三谏。如比丘犯罪。僧羯磨摈出。有比丘尼。常来佐助言语比丘尼。比丘尼谏言。此不须佐助。乃至三谏不止。僧为作白四羯磨。至三羯磨时悔者罪犹可除。至第四羯磨。事成。不复可除。是名不可发露。如是比丘四。比丘尼七。皆无谏也。是名舍毗尼。此五总名毗尼义。云何为犯。犯有二种。一者犯重。二者犯轻。犯重者。欲作恶时烦恼火盛。能烧善心令灭恶事得成。名为烧义。成恶事已后改悔时。心生苦恼善心炽盛。能灭恶心。亦名烧义。犯轻者。起烦恼心微。随犯微罪灭微善心。不得自存名为炙义。后改悔时。起微善心炙小恶心。亦名炙义

云何名犯。能使众生轮回三有。名为犯义。云何复名犯。所不听作而作。名之为犯

云何名犯。犯所持戒。所犯受果。不可贪乐。故名为犯

云何复名为犯。过患苦恼触逼切身。皆名犯义。能断善法。名为犯义。又言犯者。人及六欲天四禅四空三界中所作不善。皆名为犯。又言犯者。嗔心现前。名为犯。又烦恼染心。亦名为犯。又复犯者。烦恼在道中增长。名为犯义。又烦恼满足。亦名犯义

云何烦恼名为犯义。如器中着水然火。溢出烦恼火。能令身口放逸。作不善业。是名为犯。又复犯者。七聚法中所不应作。作者皆名为犯。何故名波罗夷。波罗夷者破坏离散名波罗夷。又波罗夷者。为他刀槊所伤。绝灭命根。名波罗夷。佛法中波罗夷者。与烦恼共诤。为恶所害。名波罗夷。又复波罗夷者。为三十七住道法所弃。为四沙门果所弃。为戒定慧解脱解脱知见一切善法所弃者。名波罗夷

又波罗夷者。于毗尼中正法中比丘法中。断灭不复更生。名波罗夷。世尊说言。有涅槃彼岸。不能度到彼岸故名波罗夷。波罗夷者。如人为他斫头更不还活。为恶所灭不成比丘。名波罗夷。尊者迦叶惟说曰犯最重恶。于比丘法中更无所成。名波罗夷。又波罗夷者如人犯罪施其死罚更无生路。犯波罗夷永无忏悔之路。于比丘法中更不可修。名波罗夷。如人欲到彼岸。愚痴故中道为他所诳而失彼岸。于佛教中。为烦恼所诳。失涅槃彼岸。是名为堕

  恶中淫欲最　　不与取为最
  断人命为最　　过人法亦最
  于善中翘勤　　最能方便断
  背舍诸功德　　是名波罗夷
  虽假着法服　　入僧次而坐
  与梵者超隔　　故名波罗夷
  受他施济命　　行非功德器
  能劫国土贼　　是名波罗夷

云何名僧残。僧残者。所犯僧中应忏悔。不应一人边。乃至二三人边不得忏悔。众中忏悔名为僧残。一切比丘所忏悔事。皆应僧中。僧为作是名僧残。又言僧残者。残有少在不灭。名为僧残。又复残者。如人为他所斫残有咽喉。名之为残如二人共入阵斗。一为他所害命绝。二为他所害少在不断。不断者若得好医良药可得除差。若无者不可差也。犯僧残者亦复如是。有少可忏悔之理。若得清净大众为如法。说忏悔除罪之法。此罪可除。若无清净大众不可除灭。是名僧残除灭罪法。教令别住。行六日行摩那埵行阿浮呵那。行阿浮呵那得清净竟。于所犯处得解脱。得解脱起已更不复犯。是名僧残

云何名为波逸提。波逸提者。所犯罪微故。名波逸提。又复波逸提者。非断灭善根罪枝条罪。名波逸提。又复波逸提者。如被斫者少伤其皮不至损命。波逸提罪亦复如是。此罪伤善处少。名波逸提

云何名为波罗提提舍尼。波罗提提舍尼者。犯即忏悔。数犯数悔故。名波罗提提舍尼。又复名波罗提提舍尼者。忘误作非故心作故。名波罗提提舍尼

云何名为偷兰遮。偷兰遮者。于粗恶罪边生故。名偷兰遮。又复偷兰遮者。欲起大事不成。名为偷兰遮。又复偷兰遮者。于突吉罗恶语重故。名为偷兰。一食人肉偷兰。二畜人皮偷兰。三剃阴上毛腋下毛偷兰。四用药灌大便道偷兰。五畜人发钦畔罗偷兰。六裸形行偷兰。七畜石钵偷兰。八嗔恚破衣偷兰。九嗔恚破房偷兰。十嗔恚破塔偷兰。是名自性偷兰。突吉罗者。名为恶作。犯身口律仪名为恶作。恶语二种。一者妄语二者非时语。非时语者。释摩男释子作平等心持药布施众僧。六群比丘谤言。好者与上座恶者与我等。施主答言。我当市上更买好药与尊者。六群比丘谤他故名恶语。所说不当时。名非时语

应初夜受用者。一甘蔗浆。二水和甘蔗浆。复有八种浆。一庵罗果浆。二瞻波浆。三拘罗浆。四咒提浆。五元提浆。六舍林毗浆。七破楼尸浆。八蒲桃浆。如此等浆气味未变。至初夜得饮。变不得饮。二日二夜相应者。受具足人。与未受具足者共宿。至第三夜。具足者明相未现时应起坐。复有二夜相应者。若犯罪者应发露别。住别住处有畏难不得住者。听二夜覆藏。复有二时相应法。初夜时后夜时。应翘勤坐禅经行。何故不劝三时。行者中夜一时以自消息。是故不得教竟夜行。所以劝初夜后夜者。欲令行道不懈。是名二时相应

夜应作者。夜中露地得卧昼日不得。欲晓时还入房中眠卧。若夜中经行时。为热故不得具着衣者。直被袈裟得经行。若竭支大者。不着泥洹僧袈裟亦得。着革屣取水与人若池边取水。夜得昼不得。中前所应者。从明相现至中。此时中应食无犯。有中所应食。五种正食是。非余不正食也。不正食中前得数数食。中前入聚落食法。若无檀越请。不语比座得入聚落乞食无过。若受请者。不语比座去有过。何以故。如拔难陀释子。处受请不语比座。晨朝向一受请处去。后更余处请檀越来至。唤拔难陀兼唤余比丘。比丘待拔难陀。日时已过不得中食。以是因缘佛制。比丘有请处。应语比座令知。中前病比丘得食粥。复有中前应入聚落。不应语比座。为佛为法为四方僧为塔为病得入聚落

共行弟子一切入聚落。皆应白和尚。若有比丘。入聚落见檀越者应语比座令知

后食者。食已竟后更得食。日时未过作残食法食。是名后食。病者。后食得数数食无过。看病者。作残不作残皆得食后食。若有檀越请应语比座。若无檀越请不语无过。若比丘昼相应夜不相应者。教授比丘尼时。昼日应教夜不应教

若比丘尼受教诫法。十五日语教诫师。若即得白僧者。十五日暮尼得布萨。若昼日僧不集不得白僧者。至暮布萨时当白僧。得教诫已至十六日。比丘尼教诫师边取教诫。取教诫已即得布萨。若十五日比丘尼就大僧中受教诫。僧集时即乞教诫。更不须后时来乞。若比丘尼。比丘尼僧中受具足竟。即昼日大僧中受具足。不应夜来也

若比丘尼得长钵。即日施人及作净施。至明相未现不犯

若比丘尼得所用器听畜。十六种器中各畜一。若长者亦即日施人及作净施。至明相未现已来不犯。复有昼日相应者。若比丘贪乐坐禅。坐处无有依止师。依止师住处但使一日得往还。遥依止不失。若两寺相去一日得往还。若有守僧伽蓝者。亦得遥依止不失。若比丘同布萨结大界处。极远听一日往还结大界。是名昼相应法也。昼夜所应作法。受具布萨自恣与欲与清净欲自恣欲受安居受功德衣受三衣不离宿。是名昼夜相应法也。复有二日二夜相应法。受具足人与未受具人。二日二夜同宿第三夜受具者。明相未现时应起坐。若客比丘到他寺上。请房舍卧具受已。不语旧住者出外再宿。至第三夜明相未现时。若自来若遣人来。语旧住者善。若不语至明相现得罪

若比丘在军中再宿。至第三夜明相未现时。若有时。可与相识者别。若无时。直去出军外明相现不犯。若与相识者辞知不放者。可直去不须辞也。是名二日二夜相应法也

三夜相应法者。受具足者。与未受具足者。三夜同房。至第四夜明相未现时。未受具足者应出界外。若不能出。受具足者应出界外。是名三夜相应法也。复有五日五夜相应法。若比丘有盗贼难军贼难。不得持三衣自随者。应持三衣寄知旧白衣舍五日。至六日明相未现。应来看衣手自捉之。若过六日至明相现。尼萨耆波逸提。若比丘作亲意。不语取他衣着。过五日至六日明相现突吉罗

若比丘自三衣。至五日应捡挍。无虫鼠伤坏不。若过五日至六日明相现。得突吉罗。是名五夜相应法

六夜相应法者。若比丘离衣宿。至六日明相现失衣。复有六夜所行法。六夜行摩那埵是也。是名六夜相应法。七夜相应法者。酥油生酥蜜黑石蜜。为病者七日应畜。明相现至八日不应畜。若比丘夏安居中。若为佛法僧塔病。如是等众多受七夜法。尊者萨婆多说曰。若比丘受依止竟。乞七日法出界外。七日满还来到寺不失依止。是名七夜相应法

毗尼母经卷第七毗尼母经卷第八

        失译人名今附秦录

十夜相应法者。若比丘畜长衣。不作净施不过十日。畜长钵不作净施。亦不过十日。是名十夜相应法。半月相应法者。夏安居前一月求浴衣。得衣已要半月着。至夏安居中半月一用浴。若比丘尼犯僧残。二部僧集半月行摩那埵。比丘尼半月中从僧乞教诫法。二部众半月应洗。半月应布萨。比丘夏安居中有缘出界外。远者应受十五日法。为持戒令清净故。名半月相应法。一月相应法者。比丘三衣中若少一衣。求衣财得已。一月中要割截染治缝竟受持。若过一月尼萨耆波逸提。自恣后一月离衣宿。春一月残应求浴衣。浴衣法。长六肘广二肘半。夏安居中所为事。七日十五日竟应求一月。受迦絺那衣法。七月十六日应受。若事缘不及乃至八月十五日故得受。过是不得受。是名一月相应法

二月相应法者。不剃发极迟。得满二月不得过。是名二月相应法。三月相应法者。三月夏安居竟。应一宿出外。是名三月相应法。四月相应法者。夏四月中用雨浴衣。若檀越施僧四月药令服者。僧即应受用。不得过四月。若外道诣诸僧求出家。应四月令别住观其行迹。不觅僧过故来也。不伪心求出家不。心意调和不。知其行已然后剃发度令出家

复有四月相应者。四月是冬。四月是春。四月是夏。是名四月相应法。五月相应法者。自恣后满五月。舍迦絺那衣。是名五月相应法。十二月相应法者。受大道人具足戒已。十二月中教授。一切大道人所作法竟。然后更有受具足者当为受。未满十二月不得受也。沙弥受大戒已。后更得受一沙弥。沙弥尼受戒式叉摩尼戒二年。不得度沙弥尼。式叉摩尼受具足已得度沙弥尼。比丘尼亦如大僧十二月中教其所应作法竟。后若有式叉摩尼欲受具足。听与受具足。是名十二月相应法。依止法亦十二月竟。得受人依止。不得一时并受二人依止。一岁相应法。即上十二月相应法是。二岁相应法者。若度童女年十八者。受沙弥尼戒。即得受式叉摩尼二年学戒。若女人十岁已有夫主者。度令出家受沙弥戒。满二年后。得与受式叉摩尼戒。复满二年后。得受具足戒。是名二岁相应法。三岁相应法者。一腊比丘得与五腊者同床坐简三岁。是名三岁相应法。五岁相应法者。比丘满五腊。要诵戒令利。诵白一白二白四三羯磨皆令使利。未满五腊比丘不离依止。五种失依止如上说。是名五岁相应法。六岁相应法者。尼师坛满六年应畜。若过不满破应用施人。若着衲得自畜。若不破亦应自畜。若房先已有四边墙上未覆。僧羯磨差人令覆竟。满六年在中住应还僧。不得过也。是名六年相应法。十岁相应法者。比丘满十腊。得为人作和上受具足。得受人依止。得受沙弥。十岁女人有夫主者。受沙弥十戒二年。得受式叉摩尼戒。是名十岁相应法。十二岁相应法者。若比丘有檀越主。欲为僧作房。僧差比丘令营房。房成已十二年在中住。后还僧不得过也。是名十二年相应法。十八岁相应法。度沙弥尼年满十八。受式叉摩尼戒。是名十八岁相应法。二十岁相应法者。童女受沙弥戒。二岁学戒年满。二十得受具足。是名二十岁相应法。一人相应法者。胡床唯得一人坐。故名一人相应法也。二人相应法者。绳床唯受二人。是名二人相应法。三人相应法者。大床唯容三人。是名三人相应法。四人相应法者。若极大床得安四人。是名四人相应法。五相应法者。五正食是。七相应法者。夜中离衣七七四十九弓地一弓四肘。是名七相应法。八相应法者。作床法。一切床脚。除上入梐。下八指。是名八相应法。十相应法者。听用十种衣财作衣。是名十相应法。二十相应法者。二十众作阿浮阿那。是名二十相应法。一相应法者。受具足时惟一和上。是名一相应法。二相应法者。受具足时唯二阿阇梨。是名二相应法。三相应法者。受具足时先办三衣。若少不得受具。是名三相应法。四相应法者。白四羯磨而得受具。是名四相应法。五相应法者。无五种遮得受具足。是名五相应法。七相应法者。取欲者语一人。如是展转语第七人。皆得取欲清净。是名七相应法。八相应法者。若有长财。广佛四指长八指。应作净施。是名八相应法。十相应法者。受具时有十人得受具。是名十相应法。二十相应法者。年满二十而得受具。是名二十相应法

一相应法者比丘尼织绳一匝。是名一相应法。二相应法者。不织绳一匝织绳一匝。是名二相应法。三相应法者。织绳一匝不织绳二匝。是名三相应法。四相应法者。四迦罗沙畔是也。天竺国十六铜钱。是一迦罗沙畔。冬天遮寒极重价衣。用四迦罗沙畔作不过。是名四相应法。五相应法者。比丘尼五衣具足得受具足。是名五相应法。七相应法者。七种饭是。是名七种相应法。八相应法者。有檀越请比丘尼食。比丘尼去时晚至。彼中尼多问腊次第。日已逼中食不得足。世尊闻已因而制戒。从今已去比丘尼大众集时。听上座八人问次第余者随意而坐。十相应法者。比丘成就十法。僧羯磨差令作教诫比丘尼师。何者十。一成就波罗提木叉戒。二多闻。多闻者。诵三藏文义皆利。是为多闻。三诵比丘比丘尼经。四口中常说微妙好语。心中起悲语了了可解。五诸根完具相貌殊特人所爱敬。六族姓子若刹利居士婆罗门。七有好才辩为尼说法示教利喜。八为比丘尼所贵重。九于比丘尼三业无失。十若二十腊若过二十腊。是名十相应法。二十相应法者。二十腊是

一相应者。阿练若比丘独在一处。僧布萨日心念口言。众僧今日布萨我亦布萨。二相应法者。二比丘共展转言。长老。今日众僧清净布萨。我亦布萨清净。是名二相应法。三相应法者。三人亦展转相语。是名三相应法。四相应法者。一人白已然后布萨。是名四相应法。五相应法者。边地无僧。通律师五人得受具。是名五相应法。七相应法者。七灭诤是。是名七相应法。八相应法者。比丘尼八敬法是。是名八相应法。十相应法者。比丘成就十法得正说戒。是名十相应法。二十相应法者。如上童女说。一相应法者。一比丘自恣是。二相应法者。二比丘展转自恣法是。三相应法四相应法。皆展转自恣是。五相应法者。五人羯磨差一人作自恣者是。是名五相应法。七相应法者。成就七法。是名七相应法。八相应法者。在家白衣笃信三宝成就八非法。僧为作覆钵羯磨。舍八非法已。僧还为舍覆钵羯磨。是名八相应法。十相应法者。不成就十法。不得与人受具。是名十相应法。二十相应法者。若比丘三衣不具尽力求索满二十日作办割截缝受持。若不办至三十日得办者割截缝受持。若过三十日不办应作净施。若不净施犯舍堕。一相应法者。二比丘共住。一者命过。在者作是念。此亡比丘物应属我。此人即得。后来者不得。是名一相应法。二相应法者。三人共住。一人命过。二人应展转相语。大德忆念。此物应属我等。二人如是展转。是名二相应法。三相应法者。四人共住一人终亡。三人展转如上所说。是名三相应法。四相应法者。五人共住一人终亡。四人作羯磨分之。是名四相应法。五相应法者。五人羯磨分亡比丘物。四人羯磨施一人。一人还施众。然后得共分之。是名五相应法。七相应法者。恭敬七法。是名七相应法。八相应法者。比丘成就八法。僧应差令发檀越信心忏悔。是名八相应法。十相应法者。有说十人作法事得如法。若说九人十一人不如法。是名十相应法。二十相应法者。二十人拔筹。是名二十相应法。一相应法者。若比丘独住。自知有所犯。无忏悔处。应作心忆持。后见一比丘即忏悔。是名一相应法。二相应法者。比丘犯罪已向一人发露。若不除后至众中更忏悔。是名二相应法。三相应法者。比丘犯罪已向二比丘发露。若不除后至僧中更忏悔。是名三相应法。四相应法者。若比丘犯罪。向四人忏悔作羯磨得除。是名四相应法。五相应法者。五种忏悔法是。是名五相应法。七相应法者。比丘成就七法得止说戒。八相应法者。如来见八种过患。是名八相应法。十相应法者。听畜十种粪扫衣。是名十相应法。二十相应法者。若比丘欲作新敷具。应用二十两羊毛作。是名二十相应法。中前相应者。五正食九种似食。及余中前相应者是。是名中前相应法。初夜相应者。如蒲桃浆乃至水解浆等。是名初夜相应法。七日相应者。五种药及余药。是名七日相应法。尽形寿相应法者。一山涉子。二识留三留草。四善善。五卢破罗。六胡椒。七姜。八毗钵。九尸罗折勒。十真浮留。十一填力。十二伽伦拘卢喜。如此等众多。是名尽形相应法。养生众具相应者。三衣钵敷具针毡筒盆瓶箧。如是等比丘所须物。名为养生具相应法。钵与人相应者。铁钵苏摩钵如是等众多。是名与人相应法。衣与人相应者。十种衣财如法染治割截得受持。是名与人相应法。敷具相应者。如齐量作。是名与人相应法。针毡筒与人相应者。如上文说。是名与人相应法。乞食相应者。乞食时得食与钵平不得多受。乞衣时檀越虽大有所施。少三衣者取不得过取。是名乞衣相应法。尔时世尊。乞食已还住处。执衣擗揲着一处。是名衣相应法。敷具相应者。如敷具揵度中广明。是名敷具相应法。齐量者。泥洹僧。长四肘广一肘半。是名齐量。钵衣敷具针毡筒行道人房。如是等一切物。如佛说者名为齐量。不如佛语名不齐量。染色相应者。诸比丘衣色脱。佛听染用十种色。十种色者。一泥。二陀婆树皮。三婆陀树皮。四非草。五乾陀。六胡桃根。七阿摩勒果。八佉陀树皮。九施设婆树皮。十种种杂和用染。如是等所应染者。此十种色。是衣三点作净法。一用泥二用青三用不均色。用此三种三点净衣。威仪相应者。所著衣服齐整。乃至不应立大小便。是名威仪相应法。所应差人者。白二白四羯磨差人。先结不净地。次结众僧房舍。后结十界。结大界已当问众僧。何处作净厨。僧所可处结作净厨。后结布萨处。最后结不失衣界。解界时。先解不失衣界。后解布萨界。复解众僧净厨界。次解大界。次解僧房舍界。次解不净地界安杂物处。教授比丘尼。自恣行筹僧使。为四方僧营事。从檀越信心分粥分前食。乃至寺中净人。不听笃信檀越家乞食。作制狂乱失性为尼受大戒。如是等及余未列名者。差人作羯磨。是皆名差人相应法。处所相应者。若塔若衣坏破穿。皆应修补涂治。是名处所相应。和尚住处。阿阇梨住处。众僧住处。僧布萨处。尔时世尊。为病比丘羯磨净地作食处。若客比丘来到。寺主人应语。不净处。僧房处。结大界处。净厨处。布萨处。不失衣界处。饮水处。是名处所相应法。方相应者。若和上众僧。随师僧向何方。是名方所。又复方者。佛在王舍城中。月尽十五日说戒时众僧皆来集。佛问。汝等从何处来。诸比丘说其方所是名为方。东方有罗睺跋陀塔。南方有处所名多奴。西方有处所。名书毗陀楼陀。北方有处所。名无至罗毗阇。此四处最是边方。通律师得五人受戒。是名方所相应法。国土相应法者。阿槃提国通律师五人得受具足。阿犯干提热得数数洗。亦听两三重皮作革屣着。尔时诸比丘雪山中夏安居。身体剥坏来到佛所佛闻已如此国土。听着富罗复衣。有二比丘。一名乌嗟罗。二名三摩跎。来到佛所白言。诸比丘有种种性种种国土人出家。用不正音坏佛经义。愿世尊听我用阐提之论正佛经义。佛言。我法中不贵浮华之言语。虽质朴不失其义。令人受解为要尔时世尊在毗舍离。世俭谷贵乞食难得。诸比丘乘神通力至岂伽国乞食。彼国人恶贱道人。持食着地不过手中。有诸比丘往白世尊。佛言。虽非手受施心已竟可取食之。是名国土相应法。自恣相应法者。一人心念口言。二人三人四人皆展转相语。五人羯磨自恣。是名自恣相应法。自恣与欲相应法者。有五种与欲。一我与自恣。二我自恣。三为我故作自恣。四手作相貌自恣。五口作相貌自恣。若此五种不成。不名与自恣欲。是名自恣相应法。自恣取欲相应法者。僧差人令取欲。取欲者。若父母病难非梵行难。如是众多难。当与余人令持欲去。与欲法。语持欲去者言。大德忆念我某甲。今日众僧自恣我亦自恣。与众僧清净欲。是名与欲相应法。取欲比丘若未得还。忽大水来及师子虎狼难不得往自恣。出界外自恣者亦得清净。去者亦得清净。是名取欲人自恣相应法

波罗提木叉相应者。尔时世尊。在静房中作是思惟。今为诸比丘制听集一处说波罗提木叉戒。我若不为制者。新学比丘欲学波罗提木叉者。云何得闻何所修集。尔时世尊从静房起告诸比丘。从今已去汝等当集一处说波罗提木叉戒。欲说戒时先白。大德僧听。若僧时到僧忍听。僧今集一处说波罗提木叉戒。白如是。名波罗提木叉戒相应法。说波罗提木叉相应者。有五种略说波罗提木叉。文如上说。复有说波罗提木叉相应者。文如上母经中说。是名说戒相应法。布萨相应者。乃至三人展转语布萨。如法布萨者。四人已上一白然后布萨。布萨处下座比丘应扫洒地。是名布萨相应法。欲相应者。尔时世尊告诸比丘。当唱净。唱净已今日众僧布萨。有病比丘不来者听与欲遣人取之。是名欲相应法。若有缘与欲无缘应去。与欲有五种。如上文说。取欲人相应者。若取欲有众难不得来取欲者。清净众僧清净。是名取欲人相应。清净相应者。若病不得来自说清净。是名清净相应布萨。自恣中得言与清净欲余欲直言与欲。不言清净。是名与欲清净。取欲者。有难不得去。名清净取欲。是名取欲人清净相应法。上来所说种种制者。比丘经。比丘尼经。摩得勒伽经。增一经。诸干度经。如此等经中推求之。若与五经义合者。应受持莫舍。若不与合者。置而莫行。复应推法。一缘二制三重制。总略犯不犯。要与五种经相应。五经中缘制重制。对而求之。云何名为总。比丘即名一切比丘。是名为总。云何名为略说。初中后说但令义显。是名为略。广说者。若有比丘向比丘说其所解。我从佛边闻如是说。闻此者即不得非其所说。亦不得即取持。此所解与五部经对之。若与经相应者。应语言。长老所说甚善。好自受持莫令废舍。常应为人如是广说。若不与五经相应者应谏之。长老所说不应受持。亦莫广为人说。更求胜解。是名第一广。第二广者。自云。从众僧边闻。亦向他人说其所解。闻者亦如上。不非不受取。五经验之。是名第二广。第三广者。若有比丘自云。从三人边闻。亦向余比丘说其所解。此闻者受不受亦推五部经中验之。是名第三广。第四广者。复有比丘自称。我从二大德比丘边闻如是说。亦向余人说其所解。彼闻比丘受不受亦应如上验之。是名第四广。广有二种。一者广文。二者广义。是名为四广。复更略明应不应义。应者铁钵瓦钵。优伽国钵。优伽奢国钵。毗舍离国黑钵。舍卫国赤钵。钵虽有六种。其实铁瓦二也。是名钵相应钵。不相应钵者。栴檀钵尸舍婆木钵。石钵金钵银钵。琉璃钵玉钵七宝钵。是名不相应。是故言相应不相应也。彼人应此人不应。应者。比丘畜长钵得满十日。不应者。比丘尼畜长钵不得过一日。是名不应。此是彼人应此人不应。尔所人应尔所不应者。若钵破过五缀更求新钵受持者。要四人中白二羯磨受持。三人已下不得。是名尔许人应尔许人不应。齐量应不齐量不应。应者。升半已上至二升半。是名应。不应者。不满升半过二升半。是名不应。以是义故。言齐量相应不相应也。是色应是色不应者。受熏色应。不受熏色不应。是名色相应不相应

或时应或时不应。应者。若为贼劫水[漂*寸]若堕地破若失。如是人者应语父母亲里眷属索。是名应。若不为水[漂*寸]贼劫堕地破失。语父母亲里眷属索者。是名不应。是名人应不应。衣相应不相应。应者。十种衣财应。不应者。上色衣锦衣白色衣着须衣。如是等众多皆不相应。是名衣不应。三衣独受持一衣亦不应。乃至头有须钦婆罗衣亦不应。有时中应有时中不应。若为贼急水[漂*寸]火烧若忘失。如是时中应语父母兄弟亲里。若不如此不应语求索也。是名是时应是时不应。僧竭支相应者。极短过系腰下一搩手作。法令覆两乳柱腋下。是名相应。不相应者。过限短作不相应。衬身衣者。暮卧时齐咽覆脚。但使莫污外净衣。是为齐量。覆疮衣长四肘广二肘。雨浴衣长二搩手半。净体巾长一搩手广一搩手。净面巾长结卷一肘广亦结卷一肘。净眼巾纵广皆自一搩手。是名此应此不应。尔所人应尔所人不应。应者。四人三人。二人不应。是名尔所人应尔所人不应。或时应或时不应。应者。从自恣后一月中得受迦絺那衣。过是不得受。是名或时应或时不应。有色应有色不应。佛所听者应。佛所不听者不应。是名有色应有色不应。有齐量应有齐量不应。应者。泥洹僧踝上三指应。过是长不应。是故名应不应。行路法。前安居后安居。随向何处好应行向安居处。安居处后有缘乞七日法是亦应行。安居前后一月是亦应行。不应行者。夏中无缘不应乞七日。冬中无缘不应行。是名应行不应行。人应不应者。过度长过度短。有诸难师僧不具。是名不应。应者。不长不短年满二十。无诸难师僧清净具足。是名应。是故名人应不应。房应不应。应者。僧如法施地。地处无诸难。作应齐量。是名应。不应者。僧不如法与地。地处有诸难。作过量所求甚多。令檀越讥嫌。是名不应。此是房应不应。犯毗尼者。七聚犯干度。是此七聚法应一一推其所犯缘。复应推此罪。当云何忏悔而得灭除。复应知起此罪时。初夜竟夜何时中起。复是二夜中起耶。复应更推前食后食昼日犯。所起犯。为因人为因法。初夜所犯者。不应受用而受用是也。夜犯者。比丘为比丘尼说法犯也。二夜犯者。共未受具人过二夜。明相未现不起不出。是名为犯。中前犯者。中前洗足以油涂足入聚落除病犯也。后食犯者。先受人请中食。后更余处受请。不语比座去。是名犯也。昼日犯者。若比丘昼日露处胁着地卧。是名为犯。复有昼日犯者。不着泥洹僧僧竭支。单着袈裟经行。又复弟子与和上阿阇梨。过食取食不中着革屣。是名昼日犯。从法所起犯者。得过人法。不得向白衣说。若同出家人知旧言不相违者可向说。不应向余者说。复有因法犯者。若授前人经若并诵。授经者授前句。受者接后句诵。如此人者不应授经。不并诵者。上座诵前句竟。下座次应诵上座所诵句。若同时诵不得。不得为女人说法过五六语。不得为覆肩覆头。如是等众多不得为说法。是名因法所犯。因人所犯者。长短过度不满二十。有遮法师僧不具亦不清净。非法群品受戒。虚空中受戒。界外受戒。若授十三种非法人戒。受戒不得戒者。一切皆名因人犯也。所犯因六处起。应推六处忏悔。有犯因身起非心口。有犯因口非身心。有犯因心非身口。有犯因身心起。有犯因心口起。有犯因身口心起。有犯因贪欲起。有犯因嗔恚起。有犯因愚痴起。有犯是身口愚痴所害。有犯是身口嗔恚所害。有犯是身口贪欲所害。有犯因身非心口者。初波罗夷故弄阴出精。有犯是不善。有犯是无记。离三衣宿若故以杖手打人等。比丘皆名身犯。从口所起犯者。第四波罗夷。若共女人淫欲心粗浊语若嗔恚心语。若自称叹己身以淫欲供养我。若以二无根谤。若毁呰他种姓形貌。妄语两舌。如是等及余口业所犯者。是名口业所起犯。从身口所起犯者。第二波罗夷。为人行媒。若为房事。此等及余。是名身口所犯。因心所起犯者。如三十事中。金银施主所与。手虽不捉心作己有。语净人持着某处。不语净人言任汝所为。如比丘见他所犯。覆藏不向人发露。是为心犯。身心所起犯者。如上身心所犯是也。从身口心所起犯者。如上身口心所犯是也。从贪欲所起犯者。初波罗夷。故弄阴出精。身触口赞叹己身。如是等是也。从嗔恚所起犯者。第三波罗夷二无根谤是也。从愚痴所起犯者。若比丘恶性不受人谏。如是比皆因愚痴所起犯也。身贪者。初波罗夷身触故弄阴出精。及余身贪所起者是也。口贪者。粗浊语为淫欲故赞叹己身乃至及余。如此比皆名口贪也。身口贪者。如有母子二人出家。子常来供养母。母子各生贪心。母语子言。此是汝本所出处。今还看之有何咎也。子用母言即行不净。是名身口所贪也。如此比众多略说之耳。从身嗔生者。手自断他命。及杖打他。复有比丘共白衣诤。决他谷田中水。令谷得死。如是等嗔。是名从身嗔所生。从口嗔所生者。若比丘语人言。为我断某甲命若遣书。如是等非一。是名从口嗔所生

从身口嗔所生者。乘嗔心若身若口害他恼他。是名从身口嗔所生从身愚痴所生者。若比丘取床敷卧具。露地敷坐。去时不自举。是名从身愚痴所生。从口愚痴所生者。若客比丘受众僧房舍卧具。去再宿不自来语不教人来语。是名从口愚痴所生。从身口愚痴所生者。若受众僧房舍床敷。去时不教人举不自举。是名从身口愚痴所生

从身贪所害者。有一比丘名能加僧提。僧差令守寺。后有一小女来至寺中。即捉共行不净。此女年小根坏而死。诸比丘心疑。杀淫于此二处何中犯罪。往问世尊。佛言。淫边得罪也。是名身贪所害犯也。从口贪所害犯者。尔时白衣疾病而卧。其人有妻颜貌端正。有一比丘往到问疾。语彼妻言。可共行欲事。女人答言。我有夫主不得自从。比丘即为病者说法语言。若作罪行久住于世。后世受罪甚久。若有福德命终即受天乐。何用此恶活为。此病者即因此厌身方便取死。诸比丘白佛。佛言。此人犯波罗夷。是名从口所贪犯也。从身口所染害者。即身口贪是也。尔时有优婆夷苏毗耶。语比丘言。若共我行欲者。不净欲出时应舍起去不犯。比丘即用其言共行欲。谓为不犯。如是展转世尊闻之。佛言。此是身口所贪犯也。又复身口所贪犯者。有一比丘为弟子受戒。白四羯磨受戒已。不为说戒相。直舍来向寺。弟子在后见其本二。问言君何所作。答言。师将此中受大戒。妇即语言。持戒日长。今因便相见可共行欲。夫即用妇言共行不净。此人所以行不净者。不识戒相故尔。佛闻已制戒。从今已去受戒已。即为受戒者说戒相令知。是名身口所贪犯也。身嗔恚所害者。乘嗔心手自断他命。是名身嗔心害犯也。口嗔害犯者。遣使杀人。是名口嗔害犯也。身口嗔恚所害者。身自杀口语人杀。是名身口嗔所害犯也。身愚痴所害者。若属他木。若果若树。不语主辄取。是名身愚痴所害犯也。口愚痴所犯者。若有比丘。见比丘所作不是。语言。长老此所作不如法。不须重作。答谏者言。我不用大德语。当更问有智慧者。此名口愚痴所犯也。复有口愚痴所犯者。众僧说戒时语言。何用说此微细戒为。此亦是口愚痴所犯也

复有人僧说戒时作如此语。汝等所说我等数数闻。他何须重说也。此是口愚痴所犯

身口愚痴所犯者。若二三人教一人令杀。去者言可尔即往杀之。是名身口愚痴所犯也。不善犯者。是凡夫人故作所犯。及学人故作所犯是。何者犯是无记。凡夫人非故心作忘误作。学人及阿罗汉忘误作。名为无记有犯。忆念忏悔者。若知而故作者重。若愚痴不解作者轻。重者若一人前若众僧前忏悔得除。轻者心念口言除也。此是犯突吉罗恶口罪也。一切不善无非突吉罗

突吉罗者。皆名恶作也。死人未坏尸上取粪扫衣。穿墙壁出死尸置外尸上取粪扫衣篱上有衣谓粪扫衣取。皆轻。心念忏悔即除。是身所犯。若有所犯。说戒时至不得忏悔。当自忆持说戒竟然后忏悔。有忘误犯者。心念自责灭也。心念自责灭者。众学中不故作者是。故作下者。一人前忏悔者。是名轻也。故作中者。自性偷兰。波逸提。波罗提提舍尼。是名中犯。一人前悔也。重者。十三僧残。僧残边偷兰。波罗夷边偷兰。此是忏悔中重者。不可悔者。四重突吉罗波逸提偷兰。此罪不可悔也。若比丘共诤欲除罪者。先共斗者忏悔。如草敷泥上令人过不污。共和合忏悔。覆恶上得生善。然后悔所犯也。阿浮呵那忏悔。如上文所说灭斗诤言讼毗尼者。相打恶骂。是名为斗。诤者。朋党相助。是名为诤。言者。彻断事官。故名为言。讼者。各说事理是非。名为讼也。斗有三种。善不善无记。复应推诤缘因何而起。云何忏悔而得灭也。此诤为初夜起中夜起后夜起。为前食起后食起中后起。为二夜起。为因法起。为因人起也。因初夜起者。此初夜浆。或言过初夜中饮。或言不中乃至长短非法群品受具。或言得或言不得。因是起斗。如是一切皆如上犯毗尼文中说。此诤缘根本有六分别十八。何者为六。一者嗔恚。二者恼害。三者幻伪。四者悭嫉。五者见取。六者边邪二见。嗔者。面色变异令人可怖。恼害者。能害他令恼。幻伪者。心不真实诈作虚事。是名幻伪。悭嫉者。贪前物不欲与人。名之为悭。嫉者。见他所得生恼。是名为嫉。见取者。取已所见为是。他见为非。是名见取。边见者。见续为常见灭为断。邪见者。谤无因果。是名六处所起。何者十八种分别。上起从法非法乃至说非说。十八种上起斗。是名诤根本聚也。此斗聚有二因缘灭。一者人现前。二者推求所起处。如六群比丘住舍卫城。向阿梨跋提河上浴。脱衣着岸上。后迦留陀比丘来。脱衣着六群衣上。出来不审谛。着六群比丘衣去。六群谤迦留陀盗衣。即屏处为作羯磨。迦留心疑往白世尊。佛言。汝取衣时作何等心取。迦留言作已想取。佛言。若如是者不犯盗也。因此即制。从今已去要具二缘。一推其缘。二人现前。然后作灭毗尼。是名灭诤毗尼。断烦恼毗尼者。此毗尼断欲界色界无色界见谛修道使缠。是名灭烦恼毗尼。使者。随逐行人不令修善。是使义。久来所习难舍。是使义。能使人沉没恶道。是使义。系缚行人在生死中。是使义。能使人受身相续不绝。是使义。不断烦恼是使义。怨家是使义。方便不舍是使义。作恶不断是使义。十使者。见使疑使戒取使欲染使恚使色染使无色染使无明使慢使掉使。缠者。无明缠嗔恚缠懈怠缠睡缠掉缠悔缠疑缠自贪己物缠复贪他物缠。从是生斗诤竞讼。因此后生害心。缠缚行人不令解脱。是名缠义。又复缠者。我见缠疑缠戒取缠欲缠恚缠悭缠嫉缠无明缠慢缠掉缠。此十缠即是十结。是故名缠。欲界所摄十二居止。色界二十二居止。无色界四居止。见谛所断。身见戒取疑。何者修道所断。薄欲界贪欲嗔恚无明。得斯陀含果断欲界贪欲嗔恚无明尽。得阿那含果。断色无色界贪欲无明尽。得阿罗汉果。此所起烦恼应推求。何处起何处灭。起处者。于结使起处。生贪着染心。能生一切烦恼。何者结使起处。眼见身色生爱着心。计以为常亦计我。乃至意法亦如是。外六尘中六识内六触。六受六爱六觉六观。乃至五阴十二入四大识眷属。观此以为我以为常。因此五阴十二入十八界上起我起常故。能生结使一切烦恼。凡有五百故言一切也。是名所起处聚。灭聚者。于烦恼起处法中。生过患想。眼见身色乃至意法。作无常无我观。识眷属。作无常苦病痈毒箭在身空无我观。作此观已。能断一切烦恼。是名灭聚处也。欲断烦恼要作五种观行。无常行苦行无我行寂灭法。空行。无常行者。念念不住病坏所加。是名无常。苦者。如痈如病如箭入心如物坏生苦。是名苦行。空者。观我我所皆如幻化无有实法。是名为空。无我行者。观一切诸法皆无有我。无常苦二行总观一切有漏法。空无我二行。通观有漏无漏法寂灭义。无有生死变易。故名寂灭法也。是故行者。常应系心在五行观也。所观境界者。五阴十二入十八界十二因缘。乃至作六念处观。及寂灭法身念处。安般念处乃至四无量心念处。食不净想乃至断想。杂阿含中应广知。若作骨想坏想。从足至顶作不净观乃至散灭想。此是心所缘境界。若住三空中。随用何门观而断结使。是名住三解脱门。若行人住地中时。应观六地。一者白骨观地。二者性地。三者八人地。四者薄地。五者离欲地。六者已作地。是名住地。见谛中所应断者。有六。一身见。二疑。三戒取。四向恶道欲。五向恶道恚。六向恶道痴。修道所应断。一欲染。二恚。三色染。四无色染。五无明。六慢。七调。断如此七烦恼。便得证果。断三结得须陀洹。欲染恚薄故得斯陀含。欲染恚断故得阿那含。一切结尽故名阿罗汉。是故言。此等断故得果。以果分别于人。得须陀洹果故名须陀洹。得斯陀含果故名斯陀含。得阿那含果故名阿那含。得阿罗汉果故名阿罗汉。是名断聚集处。比丘毗尼受具足者。或应或不应乃至齐量。或应或不应或听或不听。应齐量听不应不听。有犯不犯。如法者不犯。不如法者犯。如此次第应推。钵乃至房。应不应如上文所说。一切受具足人相应者。钵囊革屣针筒禅带袈裟钩纽绳腰绳盛眼药筒药[木*著]药器头上帽水漉。如是等物有应不应。是名比丘毗尼。比丘尼毗尼者。受具足比丘尼或应或不应若齐量者不犯。不齐量者犯。亦应次第推钵乃至房。若诸比丘尼得钵。即日受持一。余者若作净施若遣与人。若泥洹僧僧竭支如上说。覆疮巾如上说。浴衣如上说。衣乃至房。如比丘经中说。式叉摩尼得自取食。今日取明日得食。余者皆如大比丘尼法学。是名比丘尼毗尼。少分毗尼者。比丘有二百五十法。比丘尼有五百法。式叉摩尼如大比丘尼法。但除自取食食取已至明日故得食。沙弥尼优婆塞优婆夷。各自有戒。皆是其人毗尼。是名少分毗尼。一切处毗尼者。一切净持戒净心戒净慧戒应当学。一切微细戒尽应如重持之。乃至究竟令梵行。波罗提木叉戒使得清净。一切身善行口善行意善行。应随顺行正见乃至正定。优婆塞优婆夷。应当除其邪淫。乃至远离杀生邪见。是名俗人戒也

推求所犯轻重聚。及起处缘可灭不可灭经

毗尼母经卷第八


菩萨藏经

    No. 1491

菩萨藏经

        梁扶南三藏僧伽婆罗译

如是我闻。一时佛住舍卫国祇树给孤独园。与大比丘众一千二百五十人及七万二千菩萨。是时长老舍利弗承佛神力。即从坐起。偏袒右肩右膝着地。合掌礼佛白佛言。世尊。云何善男子善女人忏悔灭罪。速得三藐三菩提。佛告舍利弗言。人欲学三藐三菩提。或声闻乘人。或缘觉乘人。或大乘人。或余众生。应诵十方十世界十佛名号。然十千灯若酥若油。香及磨香亦随灯数。种种花种种果种种叶。作大供养行大布施。盛十频伽水盛十坩水。沐浴清净以香熏身着新净衣更洗手足。两手各持十枚莲华应当菜食。给使仆人皆令净洁。于十方面各施佛座(上方佛座宜须小高)忏悔之人于十方面随便设座。即于坐处礼十方佛。口自发露忏悔从来所作行业。亦悔无始生死以来所造众恶。改往修来誓不复作。佛言。舍利弗。东方名阿输歌世界(此谓无忧)于彼有佛名月胜吉。南方难陀世界(此谓欢喜)于彼有佛名旃檀吉。西方跋陀罗世界(此谓贤)于彼有佛名无边光明。北方饶益眼世界。于彼有佛名幢吉。东南方月光世界。于彼有佛名无忧吉。西南方有幢世界。于彼有佛名宝刹。西北方有鸣世界。于彼有佛名花德。东北方安隐世界。于彼有佛名三勇猛。上方有月世界。于彼有佛名大功德吉。下方大名世界。于彼有佛名光明吉。一日一夜六时行道礼拜。偏袒右肩右膝着地。合掌向佛而说此言。我礼一切诸佛如来。彼现在十方诸佛。已得阿耨多罗三藐三菩提。现转法轮。现光明法轮。现取法轮。现雨法雨。现系法鼓。现吹法螺。现建法幢。现然法炬。现以法施充足众生。随一切众生所乐皆悉为说。能多利益安隐众生。为慈悲世间。为饶益诸天人众。我今顶礼彼诸如来。彼诸如来彼佛尊重应当供养。诸佛是大智慧是世间眼。能为世间作证。主领世间现知现见。我以身口意敬礼彼佛。我从无始生死以来所造恶业。为一切众生障碍。或起贪或起嗔或起痴。不识佛法僧。不识善不善法。或以恶身口意出佛身血。或诽谤正法。或破和合僧。或杀真人罗汉。或杀父母。或备起十不善道。或已作今作当作。或见他作赞叹随喜。或以身三口四意三业行造作众恶。恶口骂詈诽谤他人。或斗秤欺诳于人。或生六道恼乱父母。或取塔寺物。或用僧物。或用四方僧物。或破佛所制戒。或不随和上阿阇梨语。或嗔或骂。或诽谤声闻缘觉大乘。或因悭嫉造诸恶业。或恶骂如来。或法说非法。或非法说法。如是一切诸恶。我今于十方诸佛发露忏悔。彼诸如来现见现知现证。我于佛前一心发露不敢覆藏。发露已后誓不敢作。是诸罪业应入地狱饿鬼畜生阿修罗道。或经八难。愿此诸罪现前消灭未来不生。我今日在诸佛前。发露忏悔不敢覆藏。发露之后誓不敢作。如过去诸菩萨为修行菩提。如彼所忏悔。我今亦复如是忏业障碍。发露之后不敢复作。如未来诸菩萨摩诃萨当忏悔。我亦如是忏悔发露。发露之后誓不更作。如现在十方菩萨摩诃萨。为修行菩提今现忏悔。我亦如是忏悔发露誓不更作。如过去未来现在三世诸菩萨摩诃萨为修行菩提。已忏悔当忏悔现忏悔。我亦如是忏悔誓不敢作。舍利弗。若善男子善女人当如是忏悔。是故舍利弗。若善男子善女人欲得于一切诸法清净无有障碍。应当如是忏悔诸恶业障。既发露已誓不更作。若乐生刹利富贵种姓。多饶财宝种种具足形貌端正。欲得大乘者。当如是忏悔。若欲得四天王处。当如是忏悔。若欲得三十三天炎摩天兜率陀天化乐天他化自在天。应如是忏悔。若欲得梵身天梵富楼天大梵天少光无量光光曜少净无量净遍净受福无挂碍天果实天无想天不烦不热善见善现色究竟。当如是忏悔。若乐生无色界空处识处不用处非想非非想处。当如是忏悔。若欲得须陀洹斯陀含阿那含阿罗汉果。当如是忏悔。若欲得声闻三明六通神力自在听明利智。若欲得缘觉菩提。当如是忏悔。若欲得一切智清净智不可思议智无等等智正遍智。如是当忏悔。舍利弗。何以故。一切诸法由因缘生。如来所说有法从缘生。有法从缘灭。以因缘展转。于彼法过去彼已灭已转。彼业无障碍。彼诸法未生亦无障碍。舍利弗。何以故。一切诸法如来所说。皆悉空寂。无众生无寿命无人不生不灭。舍利弗。一切诸法自身所造。自身者亦是有。舍利弗。若善男子善女人欲入此法慧。所谓无真实众生。此谓说灭一切业障。忏悔品竟。尔时舍利弗白佛言。世尊。善男子善女人欲得阿耨多罗三藐三菩提。欲得声闻乘缘觉乘大乘。或有余人修功德。云何当生随喜善根。尔时佛告舍利弗。善男子善女人若欲随喜。昼夜六时偏袒右肩右膝着地。恭敬合掌如是当说此言。若有众生于十方已作功德事。若布施若持戒若修行。我于彼一切随喜。以第一随喜胜随喜最上随喜无上随喜无等随喜无等等随喜。我悉如是随喜。若有众生于十方当作功德。若布施若持戒若修行。我于彼一切随喜。以第一随喜胜随喜最上随喜无上随喜无等随喜无等等随喜。我悉如是随喜。若有众生于十方今现作功德。若布施若持戒若修行。我于彼一切随喜。以第一随喜胜随喜最上随喜无上随喜无等随喜无等等随喜。我悉如是随喜。若彼诸菩萨初发菩提心功德。若彼菩萨已于百劫修行功德聚。若彼菩萨已得无生法忍功德聚。若彼菩萨已得不退地功德聚。若菩萨从一地次第至十地功德。我于彼一切随喜。以第一随喜胜随喜乃至无等等随喜。若菩萨先已修行六波罗蜜相应功德善根。我悉随喜以第一随喜乃至无等等随喜。若未来菩萨当修行六波罗蜜相应功德善根。我悉随喜。以第一随喜乃至无等等随喜。若现在诸菩萨今修行六波罗蜜相应功德。我悉随喜以第一随喜乃至无等等随喜以过去如来应供正遍知。已得阿耨多罗三藐三菩提。已转法轮。为饶益众生。为安隐众生。为慈悲众生。为以义饶益众生。及诸天人声闻缘觉菩萨所造功德。我悉随喜。未来如来当得阿耨三菩提。当转法轮为饶益众生。为安隐众生为慈悲众生。为以义饶益众生。及诸天人声闻缘觉菩萨所造功德。我悉随喜现在十方诸佛现得阿耨多罗三藐三菩提。现转法轮。现燃法炬。现击法鼓。现吹法蠡现建法幢。现以法施充足众生饶益众生安隐众生慈悲世间。以义饶益一切人天。若彼声闻缘觉大乘所造功德。我悉随喜。以第一随喜乃至无等等随喜。舍利弗。此谓随喜功德聚。以此随喜功德聚。若善男子善女人行此功德。此功德果报不可数不可量。舍利弗。若三千大千世界所有众生。乃至恒河沙等世界众生。悉皆漏尽成阿罗汉。若有善男子善女人以四事尽寿供养。若善男子善女人如是随喜功德。胜此功德无量无边。是故舍利弗。若善男子善女人乐得阿耨多罗三藐三菩提当随喜。若女人欲得男子当随喜

尔时舍利弗白佛言。世尊已说随喜。为现在未来菩萨光明云何劝请。佛告舍利弗。若善男子善女人欲得阿耨多罗三藐三菩提若声闻乘若缘觉乘。若大乘若余众生。昼夜六时偏袒右肩右膝着地。恭敬合掌说如是言。我礼一切诸佛世尊。今现在十方诸佛。已得阿耨多罗三藐三菩提。现转法轮。我已礼彼佛。我今劝请转于法轮。愿诸佛世尊转法轮。愿燃法灯。愿开法眼。愿燃法炬。愿兴法云。愿吹法蠡。愿击法鼓。愿建法幢。为饶益众生安隐众生。为慈悲世间以义饶益一切天人。舍利弗。昼夜六时偏袒右肩右膝着地。恭敬合掌说如是言。我礼一切诸佛世尊。若十方诸佛欲入涅槃。我当劝请彼佛愿久住世。为饶益众生安隐众生。慈悲世间以义饶益一切天人。我为阿耨多罗三藐三菩提行此劝请。舍利弗。此谓劝请聚。此劝请聚。善男子善女人所得功德不可数量。舍利弗。若善男子善女人三千大千世界布满七宝布施如来。若善男子善女人前劝请功德胜此功德无量无边。舍利弗。若恒河沙等世界布满七宝布施诸佛。若善男子善女人前劝请功德胜此功德无量无边。如是劝请阿耨多罗三藐三菩提。如是我劝请。舍利弗。此谓劝请聚。以此劝请聚。若善男子善女人现劝请。彼功德不可思量。何以故。舍利弗。我先修行菩提行。我已如是劝请诸佛为转法轮。以此功德我得阿耨多罗三藐三菩提。帝释诸天娑婆世界主梵天王等。亦劝请我转于法轮。为多所饶益安隐世间。乃至以义饶益一切天人。舍利弗。我先劝请诸如来为法久住。我以此功德根故。得十力四无畏十八不共法。得四无碍辩。得大慈大悲。我已入泥洹。我法当久住

尔时舍利弗白佛言。世尊。云何善男子善女人欲得阿耨多罗三藐三菩提。若声闻乘若缘觉乘。若大乘若余众生。当行回向善根为一切智。尔时佛告舍利弗。若善男子善女人欲得阿耨多罗三藐三菩提。若声闻乘若缘觉乘。若大乘若余众生。昼夜六时偏袒右肩右膝着地。恭敬合掌作如是言。我于无始生死所作功德善根。或于佛或于法或于僧。或一人乃至施与畜生一抟食。或忏悔或劝请或随喜。或归依三宝受戒功德。一切和合。回施与一切众生。如诸佛世尊现智无著智回施与一切众生。我亦如是。回施一切众生。如手捉宝珠施与一切。如云降雨润益无尽无减。为众生富贵无减。为功德无减法无减智慧无减乐说无减。为阿耨多罗三藐三菩提。为得一切智。我以此功德施与众生。一切和合回向阿耨多罗三藐三菩提。以此善根愿令一切众生亦得阿耨多罗三藐三菩提。得一切智。如先诸菩萨。为菩提修行善根修行回向为一切智。我亦如是。回向为一切智。以此善根我当得阿耨多罗三藐三菩提得一切智。如未来诸菩萨。当修行回向善根为一切智。我亦如是。以回向善根为一切智。如现在诸菩萨。修善根为一切智。我亦如是。回向善根为一切智。以此善根愿一切众生得阿耨多罗三藐三菩提得一切智。如先释迦牟尼佛。坐菩提树下。住不可思议无垢定降伏恶魔。所有诸法可知可见可觉。于夜后分明星出时。以一念相应慧行灭苦道得证醍醐。我亦如是。一切众生学阿耨多罗三藐三菩提。如无量光明如来。胜光明如来。清净光明如来。功德光明如来。师子如来。百光如来。高明如来。网光如来。珠光如来。火光如来。光王如来。庄严如来。宝幢如来。法幢如来。身胜如来等应供正遍知。如余诸佛世尊。已得阿耨多罗三藐三菩提。已转法轮。为饶益多众生。为安隐诸众生。为慈悲世间乃至以义饶益一切天人。我亦如是。为一切众生得阿耨多罗三藐三菩提。当转法轮。为饶益众多众生。为安隐众生。为慈悲世间乃至以义饶益一切天人。舍利弗。此谓回向功德聚。此功德聚。胜前布施功德聚。百分千万亿分。乃至算数譬喻所不能及

舍利弗。若善男子善女人受持此经为他广说。所得功德无数无量。舍利弗若有人能令三千大千世界杂类众生。于一念顷俱得人身已。复能令得缘觉菩提。常以四事供养。施与一一缘觉七宝如须弥山。如是日日乃至入涅槃。入涅槃已起七宝塔。花香幡盖种种供养。舍利弗。于汝意云何是善男子善女人。所得功德宁为多不舍利弗言。甚多世尊。甚多善逝。是故舍利弗。若善男子善女人受持此经。所得功德复多于彼。愿此功德为阿耨多罗三藐三菩提。此功德比先功德。百分千万亿分。乃至算数譬喻所不能及。何以故。舍利弗。善男子善女人信此经劝请十方诸佛为转法轮。如我所说法施胜于财施。尔时四众一万人俱从坐起。皆偏袒右肩右膝着地。合掌向佛而说此言。世尊。我等当受持此经。为人广说当信。何以故。世尊我等欲得阿耨多罗三藐三菩提。我当成就如是善根如是善法。是时帝释天王散以天花。供养世尊及此经法。而说此言。世尊。此经有大功德为增长诸菩萨善根。为灭业障。是时佛告帝释。如是如是。憍尸迦。何以故。天王我念过去阿僧祇劫。是时有大光聚如来应供正遍知出现于世天王。大光聚如来应供正遍知。寿六十八亿岁。初始说法有百千万亿弟子。彼一切皆阿罗汉尽诸有漏。第二说法有九十九千亿弟子。亦皆漏尽得阿罗汉。第三说法有九十八亿百千弟子。诸漏已尽得阿罗汉。天王。彼大光明聚如来应供正遍知。为一切世间诸天梵王沙门婆罗门故。住经六十八亿岁。是时帝释天王及四众。从光明聚如来受持此经。为多利益一切世间。为成阿耨多罗三藐三菩提。复有一天女名竭伽陀。受持此经。发阿耨多罗三藐三菩提心。厌离女人得丈夫身。常生人天之中不经恶趣。八万四千世作转轮王。憍尸迦。于汝意云何。至此彼竭伽陀女人岂异人乎。即我身是。我昔于亿百千世界值无数佛同名光明聚如来。于彼佛所悉闻此经。若善男子善女人闻此如来名。必定当得大般涅槃。若有女人闻此光明聚如来名者当转女身。寿命终时无有疑乱。不更受女身。憍尸迦此经大功德恩。能摄受诸菩萨摩诃萨善根。能灭诸业障碍。是时帝释白佛言。世尊。当何名此经。云何受持。是时佛告帝释。憍尸迦。此经名灭业障碍。汝当受持。亦名菩萨藏。汝当受持。亦名断一切疑。如是受持。佛说经已。帝释天王及长老舍利弗比丘众。及诸菩萨天人阿修罗乾闼婆。一切世间闻佛所说。欢喜奉行

菩萨藏经


菩萨戒本(出瑜伽论本事分中菩萨地)

    No. 1501

菩萨戒本(出瑜伽论本事分中菩萨地)

        弥勒菩萨说

        沙门玄奘奉　诏译

若诸菩萨。已受菩萨所受净戒。应自数数专谛思惟。此是菩萨正所应作。此非菩萨正所应作。既思惟已然后为成。正所作业当勤修学。又应专励听闻菩萨素呾缆藏。及以菩萨摩呾理迦。随其所闻当勤修学

若诸菩萨住戒律仪。有其四种他胜处法。何等为四。若诸菩萨为欲贪求利养恭敬。自赞毁他是名第一他胜处法。若诸菩萨现有资财性悭财故。有苦有贫无依无怙。正求财者来现在前。不起哀怜而修惠舍。正求法者来现在前。性悭法故虽现有法而不舍施。是名第二他胜处法。若诸菩萨长养如是种类忿缠。由是因缘不唯发起粗言便息。由忿蔽故加以手足块石刀杖。埵打伤害损恼有情。内怀猛利忿恨意乐。有所违犯。他来谏谢不受不忍不舍怨结。是名第三他胜处法。若诸菩萨谤菩萨藏爱乐宣说。开示建立像似正法。于像似法。或自信解。或随他转。是名第四他胜处法。菩萨于四他胜处法。随犯一种况犯一切。不复堪能于现法中增长摄受。菩萨广大菩提资粮。不复堪能于现法中意乐清净。是即名为相似菩萨非真菩萨。菩萨若用软中品缠。毁犯四种他胜处法不舍菩萨净戒律仪。上品缠犯即名为舍。若诸菩萨毁犯四种他胜处法。数数现行。都无惭愧。深生爱乐。见是功德。当知说名上品缠犯。非诸菩萨。暂一现行他胜处法。便舍菩萨净戒律仪。如诸苾刍犯他胜法。即便弃舍别解脱戒若诸菩萨。由此毁犯弃舍菩萨净戒律仪。于现法中堪任更受非不堪任。如苾刍住别解脱戒犯他胜法。于现法中不任更受。如是菩萨安住菩萨净戒律仪。于有违犯及无违犯。是染非染软中上品。应当了知

若诸菩萨安住菩萨净戒律仪于日日中。若于如来或为如来造制多所。若于正法。或为正法造经卷所。谓诸菩萨素呾缆藏摩呾理迦。若于僧伽。谓十方界已入大地诸菩萨众。若不以其或少或多。诸供养具而为供养。下至以身一拜礼敬。下至以语一四句颂。赞佛法僧真实功德。下至以心一清净信。随念三宝真实功德。空度日夜。是名有犯有所违越。若不恭敬懒堕懈怠而违犯者。是染违犯。若误失念而违犯者。非染违犯。无违犯者。谓心狂乱。若已证入净意乐地。常无违犯。由得清净意乐菩萨。譬如已得证净苾刍恒时法尔。于佛法僧以胜供具承事供养

若诸菩萨。安住菩萨净戒律仪。有其大欲而无喜足。于诸利养及以恭敬。生着不舍。是名有犯有所违越。是染违犯。无违犯者。谓为断彼生起乐欲。发勤精进摄彼对治。虽勤遮遏。而为猛利性惑所蔽。数起现行

若诸菩萨。安住菩萨净戒律仪。见诸耆长有德可敬同法者来。憍慢所制。怀嫌恨心怀恚恼心。不起承迎不推胜座。若有他来语言谈论庆慰请问。憍慢所制。怀嫌恨心怀恚恼心。不称正理发言酬对。是名有犯有所违越。是染违犯。非憍慢制无嫌恨心无恚恼心。但由懒堕懈怠忘念无记之心。是名有犯有所违越。非染违犯。无违犯者。谓遭重病。或心狂乱。或自睡眠。他生觉想而来亲附。语言谈论庆慰请问。或自为他宣说诸法论义决择。或复与余谈论庆慰或他说法论义决择属耳而听。或有违犯说正法者。为欲将护说法者心。或欲方便调彼伏彼。出不善处安立善处。或护僧制。或为将护多有情心。而不酬对。皆无违犯

若诸菩萨安住菩萨净戒律仪。他来延请。或往居家。或往余寺。奉施饮食及衣服等诸资生具。憍慢所制怀嫌恨心怀恚恼心。不至其所不受所请。是名有犯有所违越。是染违犯。若由懒堕懈怠忘念无记之心。不至其所不受所请。是名有犯有所违越。非染违犯。无违犯者。或有疾病。或无气力。或心狂乱。或处悬远。或道有怖。或欲方便调彼伏彼。出不善处安立善处。或余先请。或为无间修诸善法。欲护善品令无暂废。或为引摄未曾有义。或为所闻法义无退。如为所闻法义无退论义决择。当知亦尔。或复知彼怀损恼心诈来延请。或为护他多嫌恨心。或护僧制。不至其所不受所请。皆无违犯

若诸菩萨。安住菩萨净戒律仪。他持种种生色可染。末尼真珠琉璃等宝。及持种种众多上妙财利供具。殷勤奉施。由嫌恨心或恚恼心违拒不受。是名有犯有所违越。是染违犯。舍有情故。若有懒堕懈怠忘念无记之心违拒不受。是名有犯有所违越。非染违犯。无违犯者。或心狂乱。或观受已心生染着。或观后时彼定追悔。或复知彼于施迷乱。或知施主随舍随受。由是因缘定当贫匮。或知此物是僧伽物窣堵波物。或知此物劫盗他得。或知此物由是因缘多生过患。或杀或缚或罚或黜或嫌或责。违拒不受皆无违犯

若诸菩萨。安住菩萨净戒律仪。他来求法。怀嫌恨心怀恚恼心。嫉妒变异不施其法。是名有犯有所违越。是染违犯。若由懒堕懈怠忘念无记之心。不施其法。是名有犯有所违越。非染违犯。无违犯着。谓诸外道伺求过短。或有重病。或心狂乱或欲方便调彼伏彼。出不善处安立善处。或于是法未善通利。或复见彼不生恭敬无有羞愧。以恶威仪而来听受。或复知彼是钝根性。于广法教得法究竟。深生怖畏。当生邪见增长邪执衰损恼坏或复知彼法至其手转布非人。而不施与。皆无违犯

若诸菩萨。安住菩萨净戒律仪。于诸暴恶犯戒有情。怀嫌恨心怀恚恼心。由彼暴恶犯戒为缘。方便弃舍不作饶益。是名有犯有所违越。是染违犯。若由懒堕懈怠弃舍。由忘念故不作饶益。是名有犯有所违越。非染违犯。何以故。非诸菩萨于净持戒。身语意业寂静现行。诸有情所起怜愍心欲作饶益。如于暴恶犯戒有情。于诸苦因而现转者。无违犯者。谓心狂乱。或欲方便调彼伏彼。广说如前。或为将护多有情心或护僧制。方便弃舍不作饶益。皆无违犯。若诸菩萨。安住菩萨净戒律仪如薄伽梵于别解说毗奈耶中将护他故。建立遮罪制诸声闻令不造作。诸有情类未净信者令生净信。已净信者令倍增长。于中菩萨与诸声闻应等修学无有差别。何以故。以诸声闻自利为胜。尚不弃舍将护他行。为令有情未信者信。信者增长学所学处何况菩萨利他为胜

若诸菩萨。安住菩萨净戒律仪如薄伽梵于别解脱毗奈耶中。为令声闻少事少业少希望住。建立遮罪制诸声闻令不造作。于中菩萨与诸声闻不应等学。何以故。以诸声闻自利为胜不顾利他。于利他中少事少业少希望住。可名为妙。非诸菩萨利他为胜不顾自利。于利他中少事少业少希望住。得名为妙。如是菩萨为利他故。从非亲里长者居士婆罗门等。及恣施家。应求百千种种衣服。观彼有情有力无力。随其所施如应而受。如说求衣求钵亦尔。如求衣钵如是自求。种种丝缕令非亲里为织作衣为利他故应蓄种种憍奢耶衣诸坐卧具。事各至百。生色可染百千拘胝。复过是数亦应取积。如是等中少事少业少希望住。制止遮罪菩萨。不与声闻共学安住。净戒律仪菩萨于利他中。怀嫌恨心怀恚恼心。少事少业少希望住。是名有犯有所违越。是染违犯。若由懒堕懈怠忘念无记之心。少事少业少希望住。是名有犯有所违越。非染违犯

若诸菩萨。安住菩萨净戒律仪。善权方便为利他故。于诸性罪少分现行。由是因缘于菩萨戒无所违犯。生多功德。谓如菩萨见恶劫贼。为贪财故欲杀多生。或复欲害大德声闻独觉菩萨。或复欲造多无间业。见是事已发心思惟我若断彼恶众生命。堕那落迦。如其不断。无间业成。当受大苦。我宁杀彼堕那落迦。终不令其受无间苦。如是菩萨意乐思惟。于彼众生或以善心或无记心。知此事已。为当来故深生惭愧。以怜愍心而断彼命。由是因缘于菩萨戒无所违犯。生多功德

又如菩萨见有增上。增上宰官上品暴恶。于诸有情无有慈愍专行逼恼。菩萨见已起怜愍心。发生利益安乐意乐。随力所能若废若黜增上等位。由是因缘于菩萨戒无所违犯。生多功德

又如菩萨见劫盗贼夺他财物。若僧伽物窣堵波物。取多物已执为己有纵情受用。菩萨见已起怜愍心。于彼有情发生利益安乐意乐。随力所能逼而夺取勿令受用。如是财故当受长夜无义无利由此因缘所夺财宝。若僧伽物还复僧伽。窣堵波物还窣堵波。若有情物还复有情。又见众生或园林主。取僧伽物窣堵波物。言是己有纵情受用。菩萨见已思择彼恶起怜愍心。勿令因此邪受用业。当受长夜无义无利。随力所能废其所主。菩萨如是虽不与取而无违犯。生多功德

又如菩萨处在居家。见有女色现无系属习淫欲法继心菩萨求非梵行。菩萨见已作意思惟。勿令心恚多生非福。若随其欲便得自在。方便安处令种善根。亦当令其舍不善业。住慈愍心行非梵行。虽习如是秽染之法。而无所犯多生功德。出家菩萨为护声闻圣所教诫。令不坏灭一切不应行非梵行

又如菩萨为多有情解脱命难。囹圄缚难刖手足难。劓鼻刵耳剜眼等难。虽诸菩萨为自命难。亦不正知说于妄语。然为救脱彼有情故。知而思择故说妄语。以要言之。菩萨唯观有情义利非无义利。自无染心唯为饶益诸有情故。覆想正知而说异语。说是语时于菩萨戒无所违犯。生多功德

又如菩萨见诸有情。为恶友朋之所摄受。亲爱不舍。菩萨见已起怜愍心。发生利益安乐意乐。随能随力说离间语。令离恶友舍相亲爱。勿令有情由近恶友当受长夜无义无利。菩萨如是以饶益心说离间语。乖离他爱无所违犯。生多功德

又如菩萨见诸有情。为行越路非理而行。出粗恶语猛利诃摈。方便令其出不善处安立善处。菩萨如是以饶益心。于诸有情出粗恶语无所违犯。生多功德

又如菩萨见诸有情。信乐倡伎吟咏歌讽。或有信乐王贼饮食。淫荡街衢无义之论。菩萨于中皆悉善巧。于彼有情起怜愍心。发生利益安乐意乐。现前为作绮语相应。种种倡伎吟咏歌讽。王贼饮食淫衢等论。令彼有情欢喜引摄自在随属。方便奖导出不善处安立善处。菩萨如是现行绮语无所违犯。生多功德。若诸菩萨。安住菩萨净戒律仪。生起诡诈虚谈现相。方便研求假利求利。味邪命法无有羞耻。坚持不舍。是名有犯有所违越。是染违犯。无违犯者。若为除遣生起乐欲发勤精进。烦恼炽盛蔽抑其心时时现起

若诸菩萨。安住菩萨净戒律仪。为掉所动心不寂静不乐寂静。高声嬉戏諠哗纷聒。轻躁腾跃望他欢笑。如此诸缘是名有犯有所违越。是染违犯若忘念起非染违犯。无违犯者若为除遣生起欲乐。广说如前。若欲方便解他所生嫌恨令息。若欲遣他所生愁恼。若他性好如上诸事。方便摄受敬顺将护随彼而转。若他有情猜阻菩萨。内怀嫌恨恶谋憎背。外现欢颜表内清净。如是一切皆无违犯。若诸菩萨。安住菩萨净戒律仪。起如是见立如是论。菩萨不应欣乐涅槃。应于涅槃而生厌背。于诸烦恼及随烦恼。不应怖畏而求断灭。不应一向心生厌离。以诸菩萨三无数劫。流转生死求大菩提。若作此说。是名有犯有所违越。是染违犯。何以故。如诸声闻于其涅槃忻乐亲近。于诸烦恼及随烦恼深心厌离。如是菩萨于大涅槃忻乐亲近。于诸烦恼及随烦恼深心厌离。其倍过彼百千俱胝。以诸声闻唯为一身。证得义利勤修正行。菩萨普为一切有情。证得义利勤修正行。是故菩萨当勤修集无杂染心。于有漏事随顺而行。成就胜出诸阿罗汉无杂染法。若诸菩萨。安住菩萨净戒律仪。于自能发不信重言。所谓恶声恶称恶誉不护不雪。其事若实而不避护。是名有犯有所违越。是染违犯若事不实而不清雪。是名有犯有所违越。非染违犯。无违犯者。若他外道若他憎嫉。若自出家因行乞行因修善行。谤声流布。若忿蔽者若心倒者。谤声流布。皆无违犯。若诸菩萨。安住菩萨净戒律仪。见诸有情应以种种辛楚加行猛利加行。而得义利。护其忧恼而不现行。是名有犯有所违越。非染违犯。无违犯者观由此缘于现法中。少得义利多生忧恼。若诸菩萨。安住菩萨净戒律仪。他骂报骂他嗔报嗔。他打报打他弄报弄。是名有犯有所违越。是染违犯

若诸菩萨。安住菩萨净戒律仪。于他有情有所侵犯。或自不为彼疑侵犯。由嫌嫉心由慢所执。不如理谢而生轻舍。是名有犯有所违越。是染违犯。若由懒堕懈怠放逸不谢轻舍。是名有犯有所违越。非染违犯。无违犯者。若欲方便调彼伏彼。出不善处安立善处。若是外道若彼希望。要因现行非法有罪。方受悔谢。若彼有情性好斗诤。因悔谢时倍增愤怒。若复知彼为性堪忍体无嫌恨。若必了他因谢侵犯。深生羞耻而不悔谢。皆无违犯

若诸菩萨。安住菩萨净戒律仪。他所侵犯彼还如法平等悔谢。怀嫌恨心欲损恼彼不受其谢。是名有犯有所违越。是染违犯。虽复于彼无嫌恨心不欲损恼。然由禀性不能堪忍故不受谢。亦名有犯有所违越。是染违犯。无违犯者。若欲方便调彼伏彼。广说一切如前应知。若不如法不平等谢。不受彼谢亦无违犯

若诸菩萨。安住菩萨净戒律仪。于他怀忿相续坚持。生已不舍。是名有犯有所违越。是染违犯。无违犯者。为断彼故生起乐欲。广说如前

若诸菩萨。安住菩萨净戒律仪。贪着供事增上力故。以爱染心管御徒众。是名有犯有所违越。是染违犯。无违犯者。不贪供侍无爱染心。管御徒众

若诸菩萨。安住菩萨净戒律仪。懒堕懈怠耽睡眠乐。卧乐倚乐非时非量。是名有犯有所违越。是染违犯。无违犯者。若遭疾病。若无气力。行路疲弊。若为断彼生起乐欲。广说一切如前应知

若诸菩萨。安住菩萨净戒律仪。怀爱染心谈说世事虚弃时日。是名有犯有所违越。是染违犯。若由忘念虚弃时日。是名有犯有所违越。非染违犯。无违犯者。见他谈说护彼意故。安住正念须臾而听。若事希奇。或暂问他。或答他问无所违犯

若诸菩萨。安住菩萨净戒律仪。为令心住欲定其心。心怀嫌恨憍慢所持。不诣师所求请教授。是名有犯有所违越。是染违犯。懒堕懈怠而不请者。非染违犯。无违犯者。若遇疾病。若无气力。若知其师颠倒教授。若自多闻自有智力。能令心定。若先已得所应教授。而不请者。无所违犯

若诸菩萨。安住菩萨净戒律仪。起贪欲盖忍受不舍。是名有犯有所违越。是染违犯。无违犯者。若为断彼生起乐欲。发勤精进烦恼猛利。蔽抑心故时时现行。如贪欲盖。如是嗔恚惛沉睡眠掉举恶作及与疑盖。当知亦尔

若诸菩萨。安住菩萨净戒律仪。贪味静虑于味静虑见为功德。是名有犯有所违越。是染违犯。无违犯者。若为断彼生起乐欲。广说如前

若诸菩萨。安住菩萨净戒律仪。起如是见立如是论。菩萨不应听声闻乘相应法教。不应受持不应修学。菩萨何用于声闻乘相应法教。听闻受持精勤修学。是名有犯有所违越。是染违犯。何以故。菩萨尚于外道书论精勤研究。况于佛语。无违犯者。为令一向习小法者舍彼欲故。作如是说

若诸菩萨。安住菩萨净戒律仪。于菩萨藏未精研究。于菩萨藏一切弃舍。于声闻藏一向修学。是名有犯有所违越。非染违犯

若诸菩萨。安住菩萨净戒律仪。现有佛教于佛教中未精研究。于异道论及诸外论精勤修学。是名有犯有所违越。是染违犯。无违犯者。若上聪敏。若能速受。若经久时能不忘失。若于其义能思能达。若于佛教如理观察。成就俱行无动觉者。于日日中常以二分修学佛语。一分学外则无违犯

若诸菩萨。安住菩萨净戒律仪。越菩萨法于异道论及诸外论研求善巧。深心宝玩爱乐耽味。非如辛药而习近之。是名有犯有所违越。是染违犯

若诸菩萨。安住菩萨净戒律仪。闻菩萨藏于甚深处最胜甚深真实法义。诸佛菩萨难思神力。不生信解憎背毁谤。不能引义不能引法。非如来说不能利益安乐有情。是名有犯有所违越。是染违犯。如是毁谤。或由自内非理作意。或随顺他而作是说

若诸菩萨。安住菩萨净戒律仪。若闻甚深最甚深处心不信解。菩萨尔时应强信受应无谄曲。应如是学。我为非善盲无慧目。于如来眼随所宣说。于诸如来密意语言。而生诽谤。菩萨如是自处无知仰推如来。于诸佛法无不现知等随观见。如是正行无所违犯。虽无信解然不诽谤

若诸菩萨。安住菩萨净戒律仪。于他人所有染爱心。有嗔恚心自赞毁他。是名有犯有所违越。是染违犯。无违犯者。若为摧伏诸恶外道。若为住持如来圣教。若为方便调彼伏彼。广说如前。或欲令其未净信者发生净信。已净信者倍复增长

若诸菩萨。安住菩萨净戒律仪。闻说正法论义决择。憍慢所制。怀嫌恨心怀恚恼心。而不往听。是名有犯有所违越。是染违犯。若为懒堕懈怠所蔽。而不往听。非染违犯。无违犯者。若不觉知。若有疾病。若无气力。若知倒说。若为护彼说法者心。若正了知彼所说义。是数所闻所持所了。若已多闻具足闻持。其闻积集。若欲无间于境住心。若勤引发菩萨胜定。若自了知上品愚钝。其慧钝浊于所闻法难受难持。难于所缘摄心令定。不往听者。皆无违犯

若诸菩萨。安住菩萨净戒律仪。于说法师故思轻毁。不深恭敬嗤笑调弄。但依于文不依于义。是名有犯有所违越。是染违犯

若诸菩萨。安住菩萨净戒律仪。于诸有情所应作事。怀嫌恨心怀恚恼心不为助伴。谓于能办所应作事。或于道路若往若来。或于正说事业加行。或于掌护所有财宝。或于和好乖离诤讼。或于吉会或于福业不为助伴。是名有犯有所违越。是染违犯。若为懒堕懈怠所蔽不为助伴。非染违犯。无违犯者。若有疹疾。若无气力。若了知彼自能成办。若知求者自有依怙。若知所作能引非义能引非法。若欲方便调彼伏彼。广说如前。若先许余为作助伴。若转请他有力者助。若于善品正勤修习不欲暂废。若性愚钝于所闻法难受难持。如前广说。若为将护多有情意。若护僧制不为助伴。皆无违犯

若诸菩萨。安住菩萨净戒律仪。见诸有情遭重疾病。怀嫌恨心怀恚恼心不往供事。是名有犯有所违越。是染违犯。若为懒堕懈怠所蔽不往供事。非染违犯。无违犯者。若自有病。若无气力。若转请他有力随顺令往供事。若知病者有依有怙。若知病者自有势力能自供事。若了知彼长病所触堪自支持。若为勤修广大无上殊胜善品。若欲护持所修善品令无间缺。若自了知上品愚钝。其慧钝浊于所闻法难受难持。难于所缘摄心令定。若先许余为作供事。如于病者于有苦者。为作助伴欲除其苦。当知亦尔

若诸菩萨。安住菩萨净戒律仪。见诸有情为求现法。后法事故广行非理。怀嫌恨心怀恚恼心。不为宣说如实正理。是名有犯有所违越。是染违犯。若由懒堕懈怠所蔽不为宣说。非染违犯。无违犯者。若自无知。若无气力。若转请他有力者说。若即彼人自有智力。若彼有余善友摄受。若欲方便调彼伏彼。广说如前。若知为说如实正理。起嫌恨心。若发恶言。若颠倒受。若无爱敬。若复知彼性弊[怡-台+龍]戾不为宣说。皆无违犯

若诸菩萨。安住菩萨净戒律仪。于先有恩诸有情所。不知恩惠不了恩惠。怀嫌恨心不欲现前如应酬报。是名有犯有所违越。是染违犯若为懒堕懈怠所蔽不现酬报。非染违犯。无违犯者。勤加功用无力无能不获酬报。若欲方便调彼伏彼。广说如前。若欲报恩而彼不受。皆无违犯

若诸菩萨。安住菩萨净戒律仪。见诸有情堕在丧失财宝眷属禄位难处。多生愁恼。怀嫌恨心不往开解。是名有犯有所违越。是染违犯。若为懒堕懈怠所蔽不往开解。非染违犯。无违犯者。应知如前。于他事业不为助伴

若诸菩萨。安住菩萨净戒律仪。有饮食等资生众具。见有求者正来悕求饮食等事。怀嫌恨心怀恚恼心而不给施。是名有犯有所违越。是染违犯。若由懒堕懈怠放逸不能施与。非染违犯。无违犯者。若现无有可施财物。若彼希求不如法物所不宜物。若欲方便调彼伏彼。广说如前。若来求者王所不宜将护王意。若护僧制而不惠施。皆无违犯

若诸菩萨。安住菩萨净戒律仪。摄受徒众。怀嫌恨心。而不随时无倒教授无倒教诫。知众匮乏而不为彼。从清净信长者居士婆罗门等。如法追求衣服饮食诸坐卧具病缘医药资身什物随时供给。是名有犯有所违越。是染违犯。若由懒堕懈怠放逸。不往教授不往教诫。不为追求如法众具。非染违犯。无违犯者。若欲方便调彼伏彼。广说如前。若护僧制。若有疹疾。若无气力不任加行。若转请余有势力者。若知徒众世所共知。有大福德各自有力。求衣服等资身众具。若随所应教授教诫。皆已无倒教授教诫。若知众内有本外道。为窃法故来入众中。无所堪能不可调伏。皆无违犯

若诸菩萨。安住菩萨净戒律仪。怀嫌恨心于他有情不随心转。是名有犯有所违越。是染违犯。若由懒堕懈怠放逸不随其转。非染违犯。无违犯者。若彼所爱非彼所宜。若有疾病。若无气力不任加行。若护僧制。若彼所爱虽彼所宜。而于众多非宜非爱。若为降伏诸恶外道。若欲方便调彼伏彼。广说如前。不随心转。皆无违犯

若诸菩萨。安住菩萨净戒律仪。怀嫌恨心他实有德不欲显扬。他实有誉不欲称美。他实妙说不赞善哉。是名有犯有所违越。是染违犯。若由懒堕懈怠放逸不显扬等。非染违犯无违犯者。若知其人性好少欲将护彼意。若有疾病。若无气力。若欲方便调彼伏彼。广说如前。若护僧制。若知由此显扬等缘。起彼杂染憍举无义。为遮此过。若知彼德虽似功德而非实德。若知彼誉虽似善誉而非实誉。若知彼说虽似妙说而实非妙。若为降伏诸恶外道。若为侍他言论究竟不显扬等。皆无违犯

若诸菩萨。安住菩萨净戒律仪。见诸有情应可诃责应可治罚应可驱摈。怀染污心而不诃责。或虽诃责而不治罚如法教诫。或虽治罚如法教诫。而不驱摈。是名有犯有所违越。是染违犯。若由懒堕懈怠放逸而不诃责乃至驱摈。非染违犯。无违犯者。若了知彼不可疗治。不可与语喜出粗言。多生嫌恨故应弃舍。若观待时。若观因此斗讼诤竞。若观因此令增諠杂。令僧破坏。知彼有情不坏谄曲。成就增上猛利惭愧疾疾还净。而不诃责乃至驱摈。皆无违犯

若诸菩萨。安住菩萨净戒律仪。具足成就种种神通变现威力。于诸有情应恐怖者能恐怖之。应引摄者能引摄之。避信施故不现神通恐怖引摄。是名有犯有所违越。非染违犯。无违犯者。若知此中诸有情类多着僻执。是恶外道诽谤贤圣成就邪见。不现神通恐怖引摄。无有违犯

又一切处无违犯者。谓若彼心增上狂乱。若重苦受之所逼切。若未曾受净戒律仪。当知一切皆无违犯

若诸菩萨。从他正受戒律仪已。由善清净求学意乐菩提意乐。饶益一切有情意乐。生起最极尊重恭敬。从初专精不应违犯。设有违犯。即应如法疾疾悔除令得还净

如是菩萨一切违犯。当知皆是恶作所摄。应向有力于语表义能觉能受小乘大乘补特伽罗。发露悔灭。若诸菩萨。以上品缠违犯如上他胜处法。失戒律仪。应当更受。若中品缠违犯如上他胜处法。应对于三补特伽罗。或过是数。应如发露除恶作法。先当称述所犯事名。应作是说。长老专志。或言大德。我如是名。违越菩萨毗奈耶法。如所称事犯恶作罪。余如苾刍发露悔灭恶作罪法。应如是说。若下品缠违犯如上他胜处法。及余违犯。应对于一补特伽罗发露悔法。当知如前。若无随顺补特伽罗。可对发露悔除所犯。尔时菩萨以净意乐起自誓心。我当决定防护当来终不重犯。如是于犯还出还净

复次如是所犯诸事。菩萨学处。佛于彼彼素呾缆中随机散说。谓依律仪戒。摄善法戒。饶益有情戒。今于此菩萨藏摩呾理迦。综集而说。菩萨于中应起尊重。住极恭敬专精修学

菩萨戒本一卷


菩萨戒本一卷(出地持戒品中)

    No. 1500

菩萨戒本一卷(出地持戒品中)

        慈氏菩萨说

        北凉天竺三藏昙无谶于姑臧译

  归命卢舍那　　十方金刚佛
  亦礼前论主　　当觉慈氏尊
  今说三聚戒　　菩萨咸共听
  戒如大明灯　　能消长夜闇
  戒如真宝镜　　照法尽无遗
  戒如摩尼珠　　雨物济贫穷
  离世速成佛　　唯此法为最
  是故诸菩萨　　应当勤护持

诸大士。此四波罗夷法。是菩萨摩得勒伽和合说

若菩萨为贪利故。自叹己德毁呰他人。是名第一波罗夷处法

若菩萨。自有财物性悭惜故。贫苦众生无所依怙。来求索者不起悲心给施所求。有欲闻法吝惜不说。是名第二波罗夷处法

若菩萨。嗔恚出粗恶言意犹不息。复以手打或加杖石。残害恐怖嗔恨增上。犯者求悔不受其忏。结恨不舍。是名第三波罗夷处法

若菩萨。谤菩萨藏说相似法。炽然建立于相似法。若心自解或从他受。是名第四波罗夷处法

诸大士。已说四波罗夷法。若菩萨起增上烦恼。犯一一犯失菩萨戒。应当更受。今问诸大士。是中清净不(三说)

诸大士。是中清净默然故。是事如是持

诸大士。此菩萨众多突吉罗法。是菩萨摩得勒伽和合说

若菩萨。住律仪戒。于一日一夜中。若佛在世若佛塔庙。若法若经卷。若菩萨修多罗藏。若菩萨摩得勒伽藏。若比丘僧。若十方世界大菩萨众。若不少多供养乃至一礼。乃至不以一偈赞叹三宝功德。乃至不能一念净心者。是名为犯众多犯。若不恭敬若懒堕若懈怠犯。是犯染污起。若忘误犯非染污起不犯者。入净心地菩萨。如得不坏净比丘。常法供养佛法僧宝

若菩萨多欲不知足贪着财物。是名为犯众多犯。是犯染污起。不犯者。为断彼故。起欲方便摄受对治。性利烦恼更数数起

若菩萨。见上座有德应敬。同法者憍慢嗔恨。不起恭敬不让其座。问讯请法悉不酬答。是名为犯众多犯。是犯染污起。若懒堕懈怠若无记心。若忘误犯非染污起。不犯者。若重病若乱心。若眠作觉想。问讯请法悉不答者。是名不犯。若上座说法。及决定论时。若自说法若听法。若自决定论时。若说法众中。若决定论众中。不礼不犯。若护说者心。若以方便令彼调伏。舍离不善修习善法。若护僧制。若护多人意

若菩萨。檀越来请。若至自舍。若至寺内。若至余家。若施衣食种种众具。菩萨以嗔慢心。不受不往。是名为犯众多犯。是犯染污起。不犯者。若病若无力。若狂若远处。若道路恐怖难。若知不受。令彼调伏舍恶住善。若先受请。若修善法不欲暂废。为欲得闻未曾有法。饶益之义及决定论。若知请者为欺恼故。若护多人嫌恨心故。若护僧制

若菩萨。有坛越以金银真珠摩尼琉璃种种宝物。奉施菩萨。菩萨以嗔慢心违逆不受。是名为犯众多犯。是犯染污起。舍众生故。若懒堕懈怠。犯非染污起。不犯者。若狂若知受已必生贪着。若知受已施主生悔。若知受已施主生惑。若知受已施主贫恼。若知是物是三宝许若知是物是劫盗得。若知受已多得苦恼。所谓杀缚讁罚夺财呵责

若菩萨。众生往至其所欲得闻法。若菩萨嗔恨性嫉不为说者。是名为犯众多犯。是犯染污起。若懒堕懈怠。犯非染污起。不犯者。若外道求短。若重病若狂。若知不说令彼调伏。若所修法未善通利。若知前人不能敬顺威仪不整。若彼钝根闻深妙法生怖畏心。若知闻已增长邪见。若知闻已毁呰退没。若彼闻已向恶人说

若菩萨。于凶恶犯戒众生。以嗔恨心若自舍若遮他令舍。不教化者。是名为犯众多犯。是犯染污起。若懒堕懈怠。若忘遮地。犯非染污起。何以故。菩萨于恶人所起慈悲心深于善人。不犯者。若狂若知不说。令彼调伏如前说。若护他心若护僧制

若菩萨。于如来波罗提木叉中。毗尼建立遮罪护众生故。令不信者信。信者增广同声闻学。何以故。声闻者乃至自度。乃至不离护他。令不信者信。信者增广学戒。何况菩萨第一义度。又复遮罪住少利少作少方便。世尊。为声闻建立者。菩萨不同学此戒。何以故。声闻自度舍他。应住少利少作少方便。非菩萨自度度他。应住少利少作少方便。菩萨为众生故。从非亲里婆罗门居士所求。百千衣及自恣与。当观施主堪与不堪。随施应受。如衣钵亦如是。如衣钵如是自乞缕。令非亲里织师织。为众生故。应蓄积憍奢耶卧具坐具乃至百千。乃至金银百千亦应受之。如是等住少利少作少方便声闻遮罪。菩萨不共学住。菩萨律仪戒为诸众生。若嫌恨心住少利少作少方便者。是名为犯众多犯。是犯染污起。若懒堕懈怠住少利少作少方便。犯非染污起若菩萨。身口谄曲若现相若毁呰。若因利求利住邪命法。无惭愧心不能舍离。是名为犯众多犯。是犯染污起。不犯者若断彼故起欲方便。烦恼增上更数数起

若菩萨。掉动心不乐静。高声嬉戏令他喜乐作是因缘。是名为犯众多犯。是犯染污起。若忘误犯非染污起。不犯者。为断彼故起欲方便。如前说。又不犯者。他起慊恨欲令止故。若他愁忧欲令息故。若他性好戏为摄彼故。欲断彼故为将护故。若他疑菩萨慊恨违背。和颜戏笑现心净故

若菩萨。作如是见如是说言。菩萨不应乐涅槃。应背涅槃。不应怖畏烦恼。不应一向厌离。何以故。菩萨应于三阿僧祇劫。久受生死求大菩提。作如是说者。是名为犯众多犯。是犯染污起。何以故。声闻深乐涅槃畏厌烦恼。百千万倍。不及菩萨深乐涅槃畏厌烦恼。谓诸声闻但为自利。菩萨不尔普为众生。彼习不染污心胜阿罗汉。成就有漏离诸烦恼

若菩萨。不护不信之言。不护讥毁亦不除灭。若实有过恶不除灭者。是名为犯众多犯。是犯染污起。实无过恶而不除灭。非染污起。不犯者。若外道诽谤及余恶人。若出家乞食。修善因缘生他讥毁。若前人若嗔若狂。而生讥毁。若菩萨观众生。应以苦切之言方便利益。恐其忧恼而不为者。是名为犯众多犯。是犯非染污起。不犯者观彼现在少所利益多起忧恼

若菩萨。骂者报骂嗔者报嗔。打者报打毁者报毁。是名为犯众多犯。是犯染污起

若菩萨。侵犯他人。或虽不犯令他疑者。即应忏谢。嫌恨轻慢。不如法忏谢。是名为犯众多犯。是犯染污起。犯懒堕懈怠犯非染污起。不犯者。若以方便令彼调伏。若彼欲令作不净业。然后受者不谢无罪。若知彼人性好斗讼。若悔谢者增其嗔怒。若知彼和忍无嫌恨心。恐彼惭耻不谢无罪

若菩萨。他人来犯如法悔谢。以嫌恨心欲恼彼故。不受其忏。是名为犯众多犯。是犯染污起。若不嫌恨性不受忏。是犯非染污起。不犯者。若以方便令彼调伏。如前说。若彼不如法悔。其心不平。不受其忏无罪

若菩萨。于他起嫌恨心执持不舍。是名为犯众多犯。是犯染污起。不犯者为断彼故起欲方便。如前说

若菩萨。为贪奉事畜养眷属者。是名为犯众多犯。是犯染污起。不犯者无贪心畜若菩萨。懒堕懈怠耽乐睡眠。若非时不知量。是名为犯众多犯。是犯染污起。不犯者若病若无力。若远行疲极。若为断彼故起欲方便。如前说

若菩萨。以染污心论说世事经时者。是名为犯众多犯。是犯染污起。若忘误经时犯非染污起。不犯者见他聚话。护彼意故须臾暂听。若暂答他问未曾闻事

若菩萨。欲求定心。嫌恨憍慢不受师教。是名为犯众多犯。是犯染污起。若懒堕懈怠犯非染污起。不犯者。若病若无力。若知彼人作颠倒说。若自多闻有力。若先已受法

若菩萨。起五盖心不开觉者。是名为犯众多犯。是起染污起。不犯者为断彼故起欲方便。如前说

若菩萨。见味禅以为功德。是名为犯众多犯。是犯染污起。不犯者为断彼故起欲方便。如前说

若菩萨。如是见如是说言。菩萨不应听声闻经法。不应受不应学。菩萨何用声闻法为。是名为犯众多犯。是犯染污起。何以故。菩萨尚听外道异论。况复佛语。不犯者专学菩萨藏未能周及

若菩萨。于菩萨藏不作方便。弃舍不学。一向修习声闻经法。是名为犯众多犯。是犯非染污起

若菩萨。于佛所说弃舍不学。反习外道邪论世俗经典。是名为犯众多犯。是犯染污起。不犯者若上聪明能速受学。若久学不忘。若思惟知义。若于佛法具足观察得不动智。若于日日常以二分受学佛经。一分外典。是名不犯。如是菩萨善于世。典外道邪论。爱乐不舍不作毒想。是名为犯众多犯。是犯染污起

若菩萨。闻菩萨法藏甚深义真实义。诸佛菩萨无量神力。诽谤不受。言非利益非如来说。是亦不能安乐众生。是名为犯众多犯。是犯染污起。或自心不正思惟故谤。或随顺他故谤。是菩萨闻第一甚深义不生解心。是菩萨应起信心不谄曲心作是学。我大不是盲无慧目如来慧眼。如是随顺说如来有余说。云何起谤。是菩萨自处无知处。如是如来现知见法正观正向不犯。非不解谤

若菩萨。以贪恚心自叹己德毁呰他人。是名为犯众多犯。是犯染污起。不犯者若轻毁外道称扬佛法。若以方便令彼调伏。如前说。又不犯者令不信者信。信者增广

若菩萨。闻说法处若决定论处。以憍慢心嗔恨心不往听者。是名为犯众多犯。是犯染污起。若懒堕懈怠犯非染污起。不犯者若不解若病若无力。若彼颠倒说法。若护说者心。若数数闻已受持已知义。若多闻若闻持。若如说行。若修禅定不欲暂废。若钝根难悟难受难持。不往者皆不犯

若菩萨。轻说法者。不生恭敬嗤笑毁呰。但著文字不依实义。是名为犯众多犯。是犯染污起。若菩萨。住律仪戒见众生所作。以嗔恨心不与同事。所谓思量诸事。若行路若如法兴利。若田业若牧牛。若和诤若吉会。若福业不与同者。是名为犯众多犯。是犯染污起。若懒堕懈怠犯非染污起。不犯者若病若无力。若彼自能办。若彼自有多伴。若彼所作事非法非义。若以方便令彼调伏。如前说。若先许他若彼有怨。若自修善业不欲暂废。若性闇钝。若护多人意。若护僧制不与同者。皆不犯

若菩萨。见羸病人。以嗔恨心不往瞻视。是名为犯众多犯。是犯染污起。若懒堕懈怠犯非染污起。不犯者。若自病若无力。若教有力随顺病者。若知彼人自有眷属。若彼有力自能经理。若病数发若长病。若修胜业不欲暂废。若闇钝难悟难受难持。难缘中住。若先看他病。如病穷苦亦尔

若菩萨。见众生造今世后世恶业。以嫌恨心不为正说。是名为犯众多犯。是犯染污起。不犯者。若自无智若无力。若使有力者说。若彼自有力若彼自有善知识。若以方便令彼调伏。如前说。若为正说于我憎恨。若出恶言。若颠倒受。若无爱敬。若复彼人性弊[怡-台+龍]戾

若菩萨。受他恩惠。以嫌恨心不以答谢。若等若增酬报彼者。是名为犯众多犯。是犯染污起。若懒堕懈怠犯非染污起。不犯者。若作方便而无力。若以方便令彼调伏。如前说。若欲报恩而彼不受

若菩萨。见诸众生有亲属难财物难以嫌恨心不为开解除其忧恼。是名为犯众多犯。是犯染污起。若懒堕懈怠犯非染污起。不犯者。如前不同事中说

若菩萨。有求饮食衣服。以嗔恨心不能给施。是名为犯众多犯。是犯染污起。若懒堕懈怠犯非染污起。不犯者。若自无。若求非法物。若不益彼物。若以方便令彼调伏。如前说。若彼犯王法护王意故。若护僧制

若菩萨。摄受徒众。以嗔恨心不如法教授。不能随时从婆罗门居士所。求衣食卧具医药房舍随时供给。是名为犯众多犯。是犯染污起。若懒堕懈怠放逸。犯非染污起。不犯者。若以方便令彼调伏。如前说。若护僧制。若病若无力。若使有力者说。若彼有力多知识大德自求众具。若曾受教自已知法。若外道窃法不能调伏

若菩萨。以嫌恨心不随他者。是名为犯众多犯。是犯染污起。若懒堕懈怠犯非染污起。不犯者。若彼欲为不如法事。若病若无力若护僧制。若彼虽如法。能令多人起非法事。若伏外道故。若以方便令彼调伏

若菩萨。知他众生有实功德。以嫌恨心不向人说。亦不赞叹。有赞叹者不唱善哉。是名为犯众多犯。是犯染污起。若懒堕懈怠放逸。犯非染污起。不犯者。知彼少欲护彼意故。若病若无力若以方便令彼调伏。若护僧制。若令彼人起烦恼。起溢喜起慢起非义。除此诸患故。若实功德似非功德。若实善说似非实说。若为摧伏外道邪见。若待说竟

若菩萨。见有众生应呵责者。应折伏者。应罚黜者。以染污心不呵责。若呵责不折伏。若折伏不罚黜。是名为犯众多犯。是犯染污起。若懒堕懈怠放逸犯非染污起。不犯者。彼不可治不可与语。难可教诲多起慊恨。若观时。若恐因彼起斗诤相违。若相言讼。若僧诤若坏僧。若彼不谄曲有惭愧心。渐自改悔

若菩萨。成就种种神力。应恐怖者而恐怖之。应引接者而引接之。欲令众生消信施故。不以神力恐怖引接者。是名为犯众多犯。是犯非染污起。不犯者。若彼众生更起染着。外道谤圣成就邪见。一切不犯。若彼发狂若增苦。受诸大士已说众多突吉罗法。若菩萨犯一一法。应作突吉罗忏。若不忏者障菩萨戒。今问诸大士。是中清净不(三说)

诸大士。是中清净默然故。是事如是持

诸大士。我已说菩萨四波罗夷法。众多突吉罗法。此是弥勒世尊摩得勒伽和合说。律仪戒。摄善法戒。摄众生戒。此诸戒法。能起菩萨行。能成菩萨道。诸大士。欲发心求阿耨多罗三藐三菩提者。当善护持。若护持者不起像法法灭尽想。能令像法实义炽然。能令正法永不灭尽。心得正住自成佛法。教化众生常无劳倦。善业毕竟速成佛道

菩萨戒本


菩萨戒羯磨文(出瑜伽论本地分中菩萨地)

    No. 1499

菩萨戒羯磨文(出瑜伽论本地分中菩萨地)

        弥勒菩萨说

        沙门玄奘奉　诏译

    受戒羯磨第一

若诸菩萨欲学菩萨三聚净戒。或是在家或是出家。先于无上正等菩提发弘愿已。当审访求同法菩萨。已发大愿有智有力。于语表义能授能开。于如是等功德具足。胜菩萨所先礼双足。偏袒右肩膝轮据地。合掌恭敬如是请言

大德忆念我如是名。于大德所乞受一切菩萨净戒。唯愿须臾不辞劳倦。哀愍听授(第二第三亦如是说)既作如是无倒请已。偏袒右肩恭敬礼拜。供养十方三世诸佛世尊。已入大地得大智慧得大神通。诸菩萨众。现前专念彼诸功德生殷净心

若诸菩萨。欲授菩萨菩萨戒时。先应为说菩萨法藏摩呾理迦。菩萨学处及犯处相。令其听受。以慧观察自所意乐。堪能思择受菩萨戒。非唯他劝非为胜他。当知是名坚固菩萨。堪受菩萨净戒律仪。以受戒法如应正授。其受戒菩萨复于彼有智有力。胜菩萨所。谦下恭敬膝轮据地。对佛像前合掌请言。唯愿大德。哀愍授我菩萨净戒。如是请已。专念一境长养净心。我今不久当得无尽无量无上大功德藏。即随思惟如是事义。默然而住

尔时有智有力菩萨于彼能行正行菩萨。以无乱心若坐若立。而作是言。汝如是名善男子。听汝。是菩萨不。彼应答言是。发菩提愿未。应答言已发。自此已后应作是言。汝如是名善男子。听汝等。今者欲于我所受诸菩萨一切学处。受诸菩萨一切净戒。谓律仪戒。摄善法戒。饶益有情戒。如是学处如是净戒过去一切菩萨已具。未来一切菩萨当具。普于十方现在一切菩萨今具。于是学处于是净戒。过去一切菩萨已学。未来一切菩萨当学。现在一切菩萨今学。汝能受不。答言能受。能授菩萨第二第三亦如是说。能受菩萨第二第三亦如是答。如是受已。能受菩萨不起于座。能授菩萨对佛像前。普于十方现住诸佛及诸菩萨。恭敬供养顶礼双足。作是白言。仰启十方无边无际。诸世界中诸佛菩萨。今于此中现有某名菩萨。于我某菩萨所。乃至三说受菩萨戒。我为作证。唯愿十方无边无际诸世界中诸佛菩萨。第一真圣于现不现一切时处。一切有情皆现觉者。于此某名受戒菩萨亦为作证。第二第三亦如是说。如是受戒羯磨毕竟。从此无间。普于十方无边无际诸世界中现住诸佛。已入大地诸菩萨前。法尔相现由此表示。如是菩萨已受菩萨所受净戒。尔时十方诸佛菩萨。睹是菩萨法尔之相生起忆念。由忆念故正智见转。由正智见如实觉知。某世界中某名菩萨某菩萨所。正受菩萨所受净戒。一切于此受戒菩萨。如子如弟生亲善意眷念怜愍。由佛菩萨眷念怜愍。令是菩萨希求善法。倍复增长无有退减。如是名为受菩萨戒启白请证。若诸菩萨住戒律仪。有其四种他胜处法。何等为四。若诸菩萨为欲贪求利养恭敬。自赞毁他。是名第一他胜处法。若诸菩萨现有资财性悭财故。有苦有贫无依无怙。正求财者来现在前。不起哀怜而修惠舍。正求法者来现在前。性悭法故。虽现有法而不给施。是名第二他胜处法。若诸菩萨长养如是种类忿缠。由是因缘。不唯发起粗言便息。由忿蔽故加以手足块石刀杖。捶打伤害损恼有情。内怀猛利忿恨意乐。有所违犯他来谏谢。不受不忍不舍怨结。是名第三他胜处法。若诸菩萨谤菩萨藏爱乐宣说。开示建立像似正法。于像似法或自信解或随他转。是名第四他胜处法。如是名为菩萨四种他胜处法。菩萨于四他胜处法。随犯一种况犯一切。不复堪能于现法中增长摄受。菩萨广大菩提资粮。不复堪能于现法中意乐清净。是即名为相似菩萨非真菩萨。菩萨若用软中品缠。毁犯四种他胜处法。不舍菩萨净戒律仪。上品缠犯即名为舍。若诸菩萨毁犯四种他胜处法。数数现行。都无惭愧。深生爱乐。见是功德。当知说名上品缠犯。非诸菩萨。暂一现行他胜处法。便舍菩萨净戒律仪。如诸苾刍犯他胜法。即便弃舍别解脱戒。若诸菩萨由此毁犯。弃舍菩萨净戒律仪。于现法中堪任更受。非不堪任。如苾刍住别解脱戒犯他胜法。于现法中不任更受

如是菩萨所受净戒。于余一切所受净戒。最胜无上无量无边。大功德藏之所随逐。第一最上善心意乐之所发起。普能除灭于一切有情一切种恶行。一切别解脱律仪。于此菩萨律仪戒。百分不及一。千分不及一。数分计分算分喻分。乃至邬波尼杀昙分亦不及一。摄受一切大功德故

如是已作受菩萨戒羯磨等事。授受菩萨俱起供养。普于十方无边无际诸世界中诸佛菩萨。顶礼双足恭敬而退

又诸菩萨。不从一切诸聪慧者。求受菩萨所受净戒。无净信者不应从受。谓于如是所受净戒。初无信解不能趣入。不善思惟有悭贪者。悭贪蔽者。有大欲者。无喜足者。不应从受。毁净戒者。于诸学处无恭敬者。于戒律仪有慢缓者。不应从受。有忿恨者多不忍者。于他违犯不堪耐者。不应从受。有懒惰者有懈怠者。多分耽着日夜睡眠。乐倚乐卧乐好合徒侣。乐嬉谈者。不应从受。心散乱者下至。不能[(殼-一)/牛]牛乳项善心一缘住修习者。不应从受。有闇昧者。愚痴类者。极劣心者。诽谤菩萨素呾缆藏及摩呾理迦者不应从受。又诸菩萨。于受菩萨戒律仪法。虽已具足受持究竟。而于谤毁菩萨藏者。无信有情。终不率尔宣示开悟。所以者何。为其闻已不能信解。大无知障之所覆蔽便生诽谤。由诽谤故。如住菩萨净戒律仪。成就无量大功德藏。彼诽谤者。亦为无量大罪业藏之所随逐。乃至一切恶言恶见及恶思惟。未永弃舍终不免离

若诸菩萨欲受菩萨净戒律仪。若不会遇具足功德补特伽罗。尔时应对如来像前。自受菩萨净戒律仪。应如是受。偏袒右肩右膝着地。作如是言。我如是名。仰启十方一切如来。已入大地诸菩萨众。我今欲于十方世界佛菩萨所。誓受一切菩萨学处。誓受一切菩萨净戒。谓律仪戒摄善法戒。饶益有情戒。如是学处如是净戒。过去一切菩萨已具。未来一切菩萨当具。普于十方现在一切菩萨今具。于是学处于是净戒。过去一切菩萨已学。未来一切菩萨当学。普于十方现在一切菩萨今学。第二第三亦如是说。说已应起。所余一切如前应知

    忏罪羯磨第二

若诸菩萨从他正受戒律仪已。由善清净求学意乐。菩提意乐。饶益一切有情意乐。生起最极尊重恭敬。从初专精不应违犯。设有违犯。即应如法疾疾悔除。令得还净

如是菩萨一切违犯。当知皆是恶作所摄。应向有力于语表义。能觉能受。小乘大乘补特伽罗。发露悔灭。若诸菩萨。以上品缠违犯如上他胜处法。失戒律仪。应当更受。若中品缠违犯如上他胜处法。应对于三补特伽罗。或过是数。应如发露除恶作法。先当称述所犯事名。应作是说。长老专志或言大德。我如是名。违越菩萨毗奈耶法。如所称事犯恶作罪。余如苾刍发露悔灭恶作罪法。应如是说。若下品缠违犯。如上他胜处法及余违犯。应对于一补特伽罗发露悔法。当知如前。若无随顺补特伽罗。可对发露悔除所犯。尔时菩萨以净意乐起自誓心。我当决定防护当来。终不重犯。如是于犯还出还净

    得舍差别第三

略由二缘。舍诸菩萨净戒律仪。一者弃舍无上正等菩提大愿。二者现行上品缠犯他胜处法

若诸菩萨。虽复转身遍十方界。在在生处不舍菩萨净戒律仪。由是菩萨不舍无上菩提大愿。亦不现行上品缠犯他胜处法

若诸菩萨转受余生。忘失本念值遇善友。为欲觉悟菩萨戒念。虽数重受而非新受。亦不新得

菩萨戒羯磨文

    菩萨戒羯磨序

        沙门静迈制

夫瀛溟冲廓。总川逝而朝宗。法性惟玄。统品物而都会。是知无说显道崇毗耶之息言。绝听雨花。宗摩竭之掩室。自非德本宏邈。孰能究其弘致者哉。有三藏法师。是称玄奘。弱龄轶俗。凝神气于白云。壮志游真。晰智晖于玄妙。漱其源者随迎而不如。涮其流者游泳而不测。大龟启灭之岁。捐觿鞢而整花田。须陀问道之年。镜戒珠而嬉行地。爰以炎隋季祀三聚创膺。深惟蹄旨。悟有余说。悼灵章之紊译。怆神理之纰传。故能出玉门而遐往。戾金河而殉妙。爰有大正法藏。寔号戒贤。道格四依。称流五印。凡厥藏海取质若人。故以所旌戒标洪誉。遂于摩揭陀国。钦承函杖。见所未见。闻所未闻。虽萨陀之遇昙无。蔑以加也。因固请受菩萨律仪。一稔三祈肇允殷望。法师以菩萨净戒。谅一乘之彝伦。授受宏规。信十地之洪范。特所吟味。匪替喉衿。以大唐贞观二十有三年。皇上御天下之始月魄日。于大慈恩寺奉诏译周羯磨戒本。爰开两轴。盖菩萨正地之流澌也。迈以不敏猥厕译僚。亲禀洪规。证斯传焰。动衷形说。式赞大猷。聊纪译辰。以备攸忘。其证义。证文。正字。笔受。义业。沙门明琰等。二十许人。各司其务同资教旨菩萨戒羯磨文


菩萨受斋经

    No. 1502

菩萨受斋经

        西晋居士聂道真译

菩萨受斋法言。某自归佛自归法自归比丘僧。某身所行恶。口所言恶。意所念恶。今已除弃。某若干日若干夜。受菩萨斋自归菩萨。如前六万菩萨皆持是斋。我是菩萨。如先行菩萨文殊师利。洹那鸠楼阿芜陀昙无迦弥勒阿惟楼尸利沙门陀楼檀那罗首楞。及陀宿命菩萨所持斋。我是菩萨。持菩萨斋。若我分檀布施当得檀波罗蜜。如我受莂当得惟逮波罗蜜。一心坐禅当得禅波罗蜜。如我说经当得般若波罗蜜。是为沤和拘舍罗。从是得摩诃般若波罗蜜。如念泥犁中人薜荔中人畜生中人。令得解脱出生为人。从是分檀布施。当到须摩提拘楼檀阿弥陀佛前。受得三昧禅。是为菩萨受斋法

佛告须菩提。菩萨有十念当护之。何等十念。当念过去佛。是菩萨法。当念未来佛。是菩萨法。当念一切十方现在佛。是菩萨法。当念尸波罗蜜持戒。是菩萨法。当念禅波罗蜜。是菩萨法。当念沤和拘舍罗。是菩萨法。当念般若波罗蜜。是菩萨法。当念禅三昧六万菩萨在阿弥陀佛所。是菩萨法。当念过去当来今现和上阿阇梨。是菩萨法。是为十念。若有发意求菩萨道者禅。日当思惟是为十事。不念为污行。菩萨斋日有十戒。第一菩萨斋日。不得着脂粉花香。第二菩萨斋日。不得歌舞捶鼓伎乐庄饰。第三菩萨斋日。不得卧高床上。第四菩萨斋日。过中以后不得复食。第五菩萨斋日。不得持钱刀金银珍宝。第六菩萨斋日。不乘车牛马。第七菩萨斋日。不得捶儿子奴婢畜生。第八菩萨皆持是斋。从分檀布施得福。我是菩萨。如我念在泥梨中人薜荔中人畜生中人。令得解脱出生为人。从是分檀布施。当至须诃摩持拘楼檀阿弥陀佛前。受得三昧禅。是为菩萨解斋法

菩萨斋日去卧时。于佛前叉手言。今日一切十方其有持斋戒者。某助安无量。今日其有持戒者。某助安无量。今日其有忍辱者。念天下人民者。某助安无量。今日其有精进者。某助安无量。今日其有智慧说经者。某助安无量。持是代劝助欢喜福施。与归流十方一切人非人。萨和萨所在勤苦厄难之处。皆令得福。解脱忧苦出生为人。安隐富乐无极。是菩萨斋日。不得见扫除。第九菩萨斋日。不得饮食尽器中。第十菩萨斋日。不得与女人相形笑共坐席。女人亦尔。是为十戒。不得犯不得教人犯。亦不得劝勉人犯。菩萨解斋法言。南无佛南无法南无比丘僧。某若干日若干夜。持菩萨斋。从分檀布施当得檀波罗蜜。如我持戒当得尸波罗蜜。如我念十方天下人令得安隐。当得羼提波罗蜜。如我受莂当得惟逮波罗蜜。如我坐禅当得禅波罗蜜。是为沤和拘舍罗。如摩诃般若波罗蜜。如诸菩萨六万菩萨法斋。日夜一分禅一分读经一分卧。是为菩萨斋日法。正月十四日受十七日解。四月八日受十五日解。七月一日受十六日解。九月十四日受十六日解

右斋日数

归命西方阿弥陀三耶三佛檀。廅楼亘摩诃那钵菩萨。三毒消除往生尊刹

  清净尊神国　　安隐在西方
  愿得自归命　　奉事无上王
  神通圣智达　　照见我心情
  自归诸大护　　百劫不动倾

菩萨受斋经


菩萨五法忏悔文

    No. 1504

菩萨五法忏悔文

        失译人名今附梁录

十方三世佛。五眼照世间。三大无不知。明见罪福相。弟子某甲等。从无数劫来。不遇善知识。造作一切罪。破戒犯四重。六重及八重。谤法断善根。具足一阐提。幸遇诸如来。经法贤圣众。能除众罪者。弟子头面礼。愿诸恶云消。令发无上慧。忏悔竟五体作礼

十方诸佛始登道场。观树经行未转法轮。无明老死长衰可悲。愿设法药救诸疾苦。法雨流布枯槁众生。得道明了。十方现在佛。已度有缘者。众生多懈怠。方便现泥洹。弟子诚心礼。请佛令久住。一切诸菩萨。已发无上意。愿勤加精进。于无佛世界。现成等正觉。普度诸群生。慈哀无过佛。是故至心请。请佛已竟头面作礼

历世怀妒嫉。我慢及恚痴。见人得利如箭射心。闻人得乐如钉入眼。坐此诸罪障。堕落三恶道。常不遇诸佛。今日一心悟。发大随喜心。十方三世佛。及彼弟子众。其数无有量。从初发一念。乃至坐道场。四等大布施。清净持禁戒。定慧及解脱。无量诸知见。弟子悉随喜。慧心朗然明。愚痴暗障灭。一念发随喜。功德满十方。智慧如诸佛。随喜已竟五体作礼

往返生死中。从生故至死。从贵故还贱。惟未得泥洹。法身常清净。波若妙解脱。今当求此利。所可有福业。一切皆和合。回以施众生。共成无上道。广大如虚空。无相如真智。究竟尽法界。金刚空慧常现在前。无行神通有感必应。回向已竟头面作礼

诚心发大愿。行道如誓愿。慧心如猛风。定力如金刚。于此回向后。念念转慈悲。舍离爱着想。欢喜度一切。舍去身命时。佛放光明灭除一切难障。化生兜率天。面睹慈氏尊。修相尽具足。六根普聪彻。闻佛说妙法。即悟无生忍。皆住不退地。乘大神通力周游十方国。供养一切佛。无量妙音声。赞叹佛功德。二十五有中。无时不现身。如日照世界。光明朗十方。一切幽闇处。皆为作灯明。虽得佛道转法轮现泥洹。众生不尽成佛不舍。普贤文殊愿。发愿已竟洗心作礼

菩萨五法忏悔文


菩萨璎珞本业经

    No. 1485

菩萨璎珞本业经卷上

        姚秦凉州沙门竺佛念译

    集众品第一

如是我闻。一时佛重游于洴沙王国道场树下成正觉处。复坐如故。昔始得佛光影甚明。今复放四十二光。光光皆有百万阿僧祇功德光为璎珞。严好佛身弥满法界。湛若虚空凝神照寂。乐常住性穷化体神。大用无方法王法主。于一切众生而作父母。自然百千宝莲华师子之座。古昔诸佛所坐皆尔。道德威仪相好如一。身意清净福行普具。光明所彻金刚宝藏。出化无极照人刹土。去来现在无复障碍。化及一切度法与人三世悉等。圆明独达一切佛等

尔时大会菩萨尽一生补处。神通妙达周遍十方。法身无极导利众生。开佛法藏示现佛性妙果。寂灭无为要教都入人根。以宿命智训化。以渐心入无际。解内外要始终无极。等诸佛土无所分别。以大悲口赞扬佛名不可胜极。六道之事靡不贯达。所化之处至皆叹言。佛念吾等建立大志。乃悉现我诸佛世界所有好恶殊胜之土。佛所游居阐隆导化。光明神足教诲我等开示我意。佛本业璎珞十住十行十向十地无垢地妙觉地。为我说要断我瑕疵及诸疑妄。悉为我现佛土佛身佛神佛力佛定。无量变化四等无畏无罪三业三六不共。一切功德无上道法众事敷教。流入十方一切国土。东去无极有香林刹。佛名入精进。菩萨字敬首。南去无极有乐林刹。佛名不舍乐。菩萨字觉首。西去无极有花林刹。佛名习精进。菩萨字宝首。北去无极有道林刹。佛名行精进。菩萨字慧首。东北无极有青莲刹。佛名悲精进。菩萨字德首。东南无极有金林刹。佛名尽精进。菩萨字目首。西南无极有宝林刹。佛名上精进。菩萨字名首。西北无极有金刚刹。佛名一乘度。菩萨字法首。下方无极有水精刹。佛名大精进。菩萨字智首。上方无极有欲林刹。佛名至精进菩萨字贤首。如是一切法光流入靡不周遍。尔时牟尼佛叹十方诸菩萨等。皆彼国第一。各与无数上人俱来入此大会。顶礼佛足坐千宝莲华座。时彼土众中第一菩萨。名曰敬首。以佛圣力叹言。快集此会观其所止。佛国清净至于法服。如来德式修行妙善。四十二贤圣之因。演说经法得佛变通。随刹清浊度人无极。分流道化靡不周匝。于是他方佛国亦说璎珞本业无二无别。所开道法与今释迦所说无异。是时敬首菩萨入十方刹诸佛神力大师子吼。发问一切佛一切菩萨无量大宝藏海金刚璎珞法门

尔时释迦牟尼佛初至树下。观视十方法界众生根缘现故。放大光明悉照佛界上至四空一时来下入法会中。十八天六天四天皆悉集会。无量国土。其一国者一须弥山日月围绕照四天下。东弗于逮南阎浮提西句耶尼北郁单越。大海铁垣围绕国界。上有二十八天。如此者为一小国。周匝十方合有百亿国土。是时佛光悉现其中。及四天王忉利天焰天兜术天不憍乐天化应声天。梵天梵众天梵辅天大梵天。水行天水微天水无量天水音天约净天无相天遍净天净光明天守妙天微妙天极妙天福果天果胜天大静天空住天识住天无所有住天非想非无想住天。如是诸天皆有大池水莲华中生。故名水天。四非色众生皆以化生下至五轮际。是为一佛刹。名为大忍法界。释迦文佛分身百亿悉遍其中。为彼国说贤圣本业璎珞之行。时诸大众天人。视彼小国佛及菩萨。若近相见皆来集此金刚寂灭道场树会

    菩萨璎珞本业经贤圣名字品第二

尔时他方敬首菩萨以佛神力故。复以大众皆是龙王师子王。二十八天王众皆大根大行。受佛神通力故发小问问佛。大师。本何修行成佛圣道。身口意净金刚不坏。一切众生不得其过。内性明照常住不灭。过一切菩萨之上。出生端正色相无比。圆极自然无为清净。二种常身度人无量。现六道中常为释梵所敬。除闇昧如烛火。明天地如日月。度天人如船师。竖过三界为妙觉尊。欲成斯道当如何行。一切贤圣名字何等

尔时释迦牟尼佛。以金刚口告敬首菩萨言。佛子。谛听谛听善思念之如法修行。我先天上人中广开一切菩萨无量行愿。是法亦是十方三世诸佛快说。决定了义璎珞佛所行道。今当为此大众十四那由他一切人根。开璎珞本业。汝心可念。志愿高远极大悲化。慈及十方一切众生。佛言。佛子。欲成斯道当先正三业。习三宝教信向因果。然即所问悉可得入一切佛教。为菩萨者得佛不久。必谛受学四十二贤圣名门决定了义。十方三世一切诸佛皆共同说一而无二

佛子。所谓留伽度(秦言发心住)留谛迦度(秦言治地住)留罗伽(秦言修行住)留摩阿(秦言生贵住)安婆沙(秦言方便具足住)毗跋致(秦言正心住)阿毗跋致(秦言不退住)必叉伽(秦言童真住)必阿罗(秦言法王子住)流止迦(秦言灌顶住)度伽阿(秦言欢喜行)度安尔(秦言饶益行)度只罗(秦言无嗔恨行)度和差(秦言无尽行)度利他(秦言离痴乱行)度生婆谛(秦言善现行)度沙必(秦言无著行)度阿诃(秦言尊重行)度佛何(秦言善法行)度叉一婆(秦言真实行)罗谛流沙(秦言救护一切众生回向)罗昙沙(秦言不坏回向)必白伽(秦言等一切佛回向)法必他(秦言至一切处回向)佛度陀(秦言无尽功德藏回向)罗叉必(秦言随顺平等善根回向)师罗叉伽(秦言随顺等观一切众生回向)波诃谛(秦言如相回向)波罗提弗陀(秦言无缚解脱回向)达摩边伽(秦言法界无量回向)鸠摩罗伽(秦言逆流欢喜地)须阿伽一波(秦言道琉璃离垢地)须那迦(秦言流照明地)须陀洹(秦言观明炎地)斯陀含(秦言度障难胜地)阿那含(秦言薄流现前地)阿罗汉(秦言过三有远行地)阿尼罗汉(秦言变化生不动地)阿那诃(秦言慧光妙善地)阿诃罗弗(秦言明行足法云地)摩诃一和沙(秦言无相无垢地)娑伽婆伽婆佛陀(秦言妙觉者无上地)

佛子。是故名门摄一切功德行。佛及菩萨无不入此名门。一切神通一切因果一切境界亦入此名门。佛子。是名门十方诸佛所说道同。不增不减决定师子吼说。当以誓自誓受持读诵解释义味。愿一切众生同入我法同我等佛。应如是修学

佛告敬首菩萨。佛子。吾今略说名门中一贤名门。所谓初发心住。未上住前有十顺名字。菩萨常行十心。所谓信心念心精进心慧心定心不退心回向心护心戒心愿心。佛子。修行是心。若经一劫二劫三劫。乃得入初住位中。住是位中增修百法明门。所谓十信心。心心有十。故修行百法明门。常发无量有行无行大愿。得人习种性中广行一切愿

  发住贤人　　发广大愿　　今生至佛
  一切愿入　　在我愿中　　无不成就
  自致得佛　　已愿为本　　我今行施
  当愿众生　　舍贪欲意　　入空道位
  法戒常行　　当愿众生　　摄行不破
  得正解脱　　六忍常奉　　当愿众生
  得无诤心　　寂法忍住　　大精进力
  当愿众生　　常行不住　　入自觉果
  住禅定心　　当愿众生　　具足神通
  无为自安　　修正法智　　当愿众生
  入慧海流　　绍菩萨位　　行无相愿
  当愿众生　　一切愿满　　流入佛海
  大慧方便　　当愿众生　　法河无碍
  到二谛际　　大力神通　　当愿众生
  变化在我　　得无所畏　　边际智满
  当愿众生　　金刚智成　　登道场果
  入无垢地　　当愿众生　　坐佛道树
  教化一切　　我今已觉　　当愿众生
  解相续假　　灭计断心　　觉照法化
  当愿众生　　悟法缘成　　灭计常心
  我得满体　　当愿众生　　悟相待法
  灭计我心　　无缘大悲　　当愿众生
  解假因生　　灭见盗心　　第一灭度
  当愿众生　　悟实法缘　　灭戒盗心
  得十力果　　当愿众生　　悟二谛照
  灭邪见心　　以金刚力　　当愿众生
  悟十二缘　　灭疑见心　　独照无方
  当愿众生　　识法无常　　灭贪悭心
  五眼三达　　当愿众生　　修三明觉
  灭痴闇心　　无碍和合　　当愿众生
  绍三宝解　　灭嗔诤心　　得大明慧
  当愿众生　　入一切空　　灭无明藏
  三十二相　　当愿众生　　相相严好
  灭依报果　　得应身用　　当愿众生
  乘大法船　　入佛法海　　我因果愿
  悉已具足　　一切行愿　　摄在其中
  二十四愿　　摄无量行　　信愿始门
  终大慧本　　今于诸佛　　前受大愿
  愿今已满　　修进余行　　其中功德
  行百千劫　　我愿乃舍　　入无量界
  一切菩萨　　若入是愿　　无不得入
  萨婆若海

佛子。住是位中发大愿已。过外一切凡夫行十信者。今复修行无量功德。所谓十波罗蜜三空无相无作有无空空观成就。即除我人主者众生渐舍诸见。常乐我净三界系缚无明渐破。伏断一切业习故。厚集一切善法八万四千般若波罗蜜。一切诸法门摄我心中念念不去心

佛子。有十不可悔戒。应受应持。一不杀人乃至二十八天诸佛菩萨。二不盗乃至草叶。三不淫乃至非人。四不妄语乃至非人。五不说出家在家菩萨罪过。六不沽酒。七不自赞毁他。八不悭。九不嗔乃至非人。十不谤三宝。若破十戒不可悔过入波罗夷。十劫中一日受罪八万四千。灭八万四千生故不可破。是故佛子。失发心住乃至二住三位十地一切皆失。是故此戒是一切佛一切菩萨行之根本。若一切佛一切菩萨。不由此十戒法门得贤圣果者。无有是处。是初住相习种性中第一人。如是下九人法行渐渐增广。乃至九住十行十向十地无垢地。亦渐增广不可思议行。佛子。吾今略说如海一渧

    菩萨璎珞本业经贤圣学观品第三

尔时敬首菩萨白佛言。云何菩萨学观名字义相。及心所行法复当云何。佛言。佛子。汝之所问。同十方佛土中一切佛皆坐道场时能问者。皆名敬首所问无异。谛听谛听思念正观如法修行。佛子。一切诸佛皆说六明焰三三昧门。我亦如是说。六种性者。是一切菩萨功德璎珞。严持菩萨二种法身。菩萨所著百万阿僧祇功德行为璎珞。若一切菩萨不入璎珞功德门。得入正位者。无有是处

佛子。性者。所谓习种性性种性道种性圣种性等觉性妙觉性。复名六坚。亦名坚信亦名坚法亦名坚修亦名坚德亦名坚顶亦名坚觉。复名六忍。信忍法忍修忍正忍无垢忍一切智忍。复名六慧。闻慧思慧修慧无相慧照寂慧寂照慧。复名六定。习相定性定道慧定道种慧定大慧定正观定。复名六观。住观行观向观地观无相观一切种智观。佛子。一切菩萨及佛。无不入此六种明观决定了义实相法门

佛子。汝先言名字者。所谓铜宝璎珞。菩萨字者。所谓习性种中有十人。其名发心住菩萨治地菩萨修行菩萨生贵菩萨方便具足菩萨正心菩萨不退菩萨童真菩萨法王子菩萨灌顶菩萨

佛子。银宝璎珞。菩萨字者。性种性中有十人。其名欢喜菩萨饶益菩萨无嗔恨菩萨无尽菩萨离痴乱菩萨善现菩萨无著菩萨尊重菩萨善法菩萨真实菩萨

佛子。金宝璎珞。菩萨字者。道种性中有十人。其名救护一切众生离众生相菩萨不坏菩萨等一切佛菩萨至一切处菩萨无尽功德藏菩萨平等善根菩萨顺观众生菩萨如相菩萨无缚解脱菩萨法界无量菩萨

佛子。琉璃宝璎珞。菩萨字者。圣种性中有十人。其名欢喜菩萨离垢菩萨明慧菩萨焰光菩萨难胜菩萨现前菩萨远行菩萨不动菩萨慧光菩萨。法云菩萨

佛子。如是百万阿僧祇功德璎珞。严持菩萨二种法身。是四十人名为学行。入法流水中以自灌注

佛子。摩尼宝璎珞。菩萨字者。等觉性中一人。其名金刚慧幢菩萨。住顶寂定。以大愿力住寿百劫。修千三昧已入金刚三昧。同一切法性二谛一谛一合相。复住寿千劫学佛威仪。象王视观师子游步。复修佛无量不可思议神通化导之法。是故一切佛法皆现在前。入佛行处坐佛道场超度三魔。复住寿万劫化现成佛。入大寂定等觉诸佛二谛界外。非有非无无心无色因果二习无有遗余。现同古佛但有应名。现诸色心教化众生。现同古昔诸佛常行中道。大乐无为而生灭为异。而实非佛现佛神通常住本境。佛子。水精璎珞内外明彻。妙觉常性湛然明净。名一切智地。常处中道一切法上超过四魔。非有非无一切相尽。顿解大觉穷化体神。二身常住为化有缘。是故佛子。吾今略说贤圣名字。汝等受持现行化人

佛子。汝先言云何心所行法者。所谓十心。一发心住。二治地心住。三修行心住。四生贵心住。五方便心住。六正心住。七不退心住。八童真心住。九法王子心住。十灌顶心住

复次即十观心所观法者。一厚集一切善根。所谓四弘誓。未度苦谛令度苦谛。未解集谛令解集谛。未安道谛令安道谛。未得涅槃令得涅槃

佛子。二修习无量善行。所谓四念处观。身受心法。若四皆空四倒则无不坏。假名一切法故。皆如幻化者。五阴色识受想行六大识空。四大一切法。无自相无他相如虚空故

佛子。三善习佛道法。所谓观十一切入。四大四色空处识处。皆如宝相故。佛子。四一切佛前受法而行。所谓八胜处。内实五阴中广相略相二胜处。外假众生法中广相略相二胜处。四大法广略四胜处。如是观一切法空无相故

佛子。五修诸清白法。所谓八大人觉。少欲知足寂静精进正念正定正慧不诤论。顺一切法故

佛子。六为诸佛所护。所谓八解脱观。闻慧得内假外假二相不可得故。一解脱思慧。内五法外一切法不可得故。二解脱修慧。六观具足色界五阴空。三解脱四空五阴及灭定观皆不可得故。五解脱如相故

佛子。七广正法。所谓六和敬。三业同戒同见同行。同入此法和。毕竟空故。住不退位故

佛子。八信喜大法。所谓三空。一切因空故无作。一切果空故无相。因空果空复空故空空。如是法如虚空故

佛子。九心住四等法。所谓化众生教四谛法。三界非乐为苦。无明习因受生无穷。三空道品无为寂灭。四谛无二一合相故

佛子。十好求佛功德。所谓六念。佛法僧戒舍天。得一切佛功德。念念入不幻三昧。常所习现前修故。佛子。吾先忉利天说十观名。初十住凡夫行。若一切菩萨无不入此门向萨婆若海

佛子十行心者。一欢喜心行。二饶益心行。三无嗔恨心行。四无尽心行。五离痴乱心行。六善现心行。七无著心行。八尊重心行。九善法心行。十真实心行

复次即十观心所观法者。一为自得一切种智故。所谓四正法。善法未生方便令生。善法已生方便令增广。恶法未生方便令不生。恶法已生方便令断。菩萨尔时为求佛果故

佛子。二为得自身有大力故。所谓四如意足。念守境。精进驰求。定检摄。慧照境。得法无生自在法故

佛子。三愿无畏具足故。所谓五根。信念精进定慧。皆无相故

佛子。四求具足三宝故。所谓五分法身。戒除形非。定无心乱。慧悟想虚。解脱无累。无累知见一切众生无缚。为知见解脱故。诸法虚空无二故

佛子。五为化一切众生故。所谓八正道。从师生慧名正知见。得法生思名正思惟。策励不倦名正精进。出家受道得三道分。名正语正业正命。入法性空名正定正慧。于无生无二观一合相故

佛子。六得大慈悲故。所谓七观择法念法精进法护法喜法定法慧法是名观门入一相故。佛子。七为得四无碍故。所谓五善根。正观暖观顶观忍观三界空第一观。能生十地无相大明慧故。圣人胎未变故。第一空平等故。佛子。八入一切佛国中行故。所谓四化法。法辩议辩语辩乐说辩。是四名慧性。照一切法无生。入第一义谛中行故

佛子。九为于一念中照一切法故。所谓三世十二因缘。过去二无明诸行。现在识名色六处触受爱取有。未来生灭。皆假合会成。性实不可得故

佛子。十为自在转大法轮故。所谓菩萨三宝。菩萨尔时于第一义中道。智为觉宝。一切法无生动与。则用为法宝。常行六道与六道众生和合。故名僧宝。转一切众生流入佛海故

佛子。吾于焰天。为诸天说凡夫十行。今于此众略说法要汝等受持。一切佛亦同是说

佛子。十回向心者。一救护一切众生离相回向心。二不坏回向心。三等一切佛回向心。四至一切处回向心。五无尽功德藏回向心。六随顺平等善根回向心。七随顺等观一切众生回向心。八如相回向心。九无缚解脱回向心。十法界无量回向心

复次十观心所观法者。一二谛正直。所谓学习第一义谛。观一切法相如不可得故。以慈悲喜舍教授六天人。剃头被三宝衣。出家菩萨共一切僧佛法无二故。第一清净故

佛子。二深第一义智。所谓五神通。是慧性差别用故天名神心。是以天身通。天眼见三世中一切法。见微细色等。天耳得闻十方声等。天他心智知一切人心故。天宿命智知三世六道命分故。以无生智见一切法故

佛子。三淳至。所谓于无生慧中四不坏净。于佛法僧戒中。信不坏故

佛子。四量同佛力。所谓三相。诸法本无假名生。已有还无假名灭。不空有法假名住。是故一切通达空而不二。名世谛相空。空一谛相故

佛子。五善计量众生力。所谓五阴色者。异空色集。成大色分故。色相空。刹那刹那成心故。心相空。受想行识无集无散。一相无相故

佛子。六佛教化力。所谓十二入。外六境到内六根。为识所入处。故名为入。其慧观者。不在内不在外不在中间。一切法无自无他故

佛子。七趣向无碍智。所谓十八界。六境六根六识一合相。一切法亦一合相故

佛子。八随顺自然智。所谓因果。善恶名因。苦乐名果。所由为因。所起为果。由起相待通为因果故。因果二空无生无灭。皆一合相故

佛子。九能受佛法僧故。所谓二谛空。因缘集故谓之有非。曰有是有。因缘散故谓之无非。曰有是无。故有无无。无般若解脱无二相故。佛子。十以自在慧化一切众生。所谓中道第一义谛。般若处中而观达一切法而无二。其观慧转转入圣地。故名相似第一义谛观。而非真中道第一义谛观。其正观者。初地已上有三观心入一切地。三观者。从假名入空二谛观。从空入假名平等观。是二观方便道。因是二空观。得入中道第一义谛观。双照二谛心心寂灭。进入初地法流水中。名摩诃萨圣种性。无相法中行于中道而无二故

佛子。是三十心入一乘信。一乘因法非近行可得。广行大心三阿僧祇劫行伏道忍方始满足

佛子。若退若进者。十住以前一切凡夫法中发三菩提心。有恒河沙众生。学行佛法信想心中行者。是退分善根。诸善男子。若一劫二劫乃至十劫。修行十信得入十住。是人尔时从初一住至第六住中。若修第六般若波罗蜜。正观现在前。复值诸佛菩萨知识所护故。出到第七住常住不退。自此七住以前名为退分

佛子。若不退者。入第六般若修行。于空无我人主者。毕竟无生必入定位。佛子。若不值善知识者。若一劫二劫乃至十劫。退菩提心。如我初会众中有八万人退。如净目天子法才王子舍利弗等。欲入第七住。其中值恶因缘故。退入凡夫不善恶中。不名习种性人。退入外道。若一劫若十劫乃至千劫。作大邪见及五逆无恶不造。是为退相。佛子。吾先第四天中广开此凡夫十向法。今在此树下略说法要。汝诸人等善自受行

佛子。十地心者。一四无量心。二十善心。三明光心。四焰慧心。五大胜心。六现前心。七无生心。八不思议心。九慧光心。十受位心

复次十观心所观法者。一欢喜地住中道第一议谛慧。所谓二十欢喜心。十无尽愿。现法身入十方佛土。作五神通入如幻三昧。现作佛化无量功德。不受三界凡夫时果。常入一乘位一心四谛集苦道灭。二种法身变易受生。三观现前常修其心入百法明门。所谓十信一信十故。百法明门十三故。烦恼毕竟不受。心心寂灭法流水中。自然流入萨婆若海

佛子。二金刚海藏法宝。所谓自行十善。教人行十善。赞叹行十善者。赞叹十善法。现千佛土教化一切众生。无相达观皆成就故

佛子。三入如幻三昧。所谓十二门禅。初觉观喜乐一心五支为因。第六默然心为定体。喜乐倚一心四支为因。第五默然心为定体。乐护念智一心五支为因。第六默然心为定体。不苦不乐护念一心四支为因。因名方便。第五默然心为定体。禅名支林。定名捡摄。经劫不散故名为定。四空定同有五支。体用相似故方便道同。支者想护正观一心五支为因。第六默然心为定体。从定生四无量心。名四无量定。圣人现同凡夫法故。以自在力。复过是法入无量定。百千佛土教化一切众生故

佛子。四遍行法宝藏。所谓身受心法正进如意足根力八正七觉。是菩萨大行。现亿法身化一切众生故

佛子。五入法界智观。所谓十六谛。有谛无谛中道第一议谛。苦谛集谛灭谛道谛。相谛差别谛视成谛。说谛事谛生起谛。尽无生谛入道谛如来智谛。五明论一切法。尽在一念心中一时行。现无量身一切佛土。受佛法化故。佛子。六达有法缘故起智。所谓十十二因缘十种照。一我见十二缘。二心为十二缘。三无明十二缘。四相缘由十二缘。五助成十二缘。六三业十二缘。七三世十二缘。八三苦十二缘。九性空十二缘。十缚生十二缘。逆顺观故现无量身。入一切佛土化一切众生故

佛子。七尽果报无障无碍智。所谓以三空智观三界二习。色心果报灭无遗余。一切行功德功用造作以竟。一切变通所为所作不一不二。无不满足修行开发。一切功德行功用开发。乃至上地一切功德行已修竟。开发功用亦悉具足一切行根本已。十度为本。施戒忍进定慧愿方便通力无相慧。十度行法功用已竟无为无作法流水中心心寂灭。自然流入萨婆若海故

佛子。八不思议无功用观。所谓无相大慧方便大用。无有色习无明亦尽。百万劫事无量佛土事。已一念心一时行。现如佛形一切众生形。一念心中一时行已。无功用故

佛子。九入法际智。所谓四十辩才一切功德行皆成就。心习已灭无明亦除。一切佛藏一切变通藏。已一心中一时行。无量大千世界中。作佛形作众生形。教化无量众生法故

佛子。十无碍智观。所谓无量法云雨澍及一切众生。二习无明今已尽灭受大职位。神变无量不可具说。现同如佛无相用故

佛子。如是一切贤人。同入此门修行成觉

佛子。吾先第六天说十地导化天人。今故略开。汝等受行

佛子。第四十一地心者。名入法界心。复次心所行法者。所谓勇伏定入法光三昧。入此定中修行十法。一学佛不思议变通。二集菩萨眷属。三重修先所行法门。四顺一切佛国问讯一切佛。五与无明父母别。六入重玄门。七现同如佛现一切形相八二种法身具足。九无有二习。十登中道第一义谛山顶。是故无垢菩萨从发心住来。至此一地经无量劫。修四十心无量功德法门。复从喜地修行二种法身无量功德。经百千劫法藏始满。入相尽三昧成就一切智位。常行佛行故。佛子。吾先于第三禅中集八禅众。说一生补处菩萨入佛华三昧定百万亿偈。今以略说一偈之义。开众生心。汝等受持

佛子。第四十二地名寂灭心妙觉地常住一相。第一无极湛若虚空。一切种智照达无生有谛始终。唯佛穷尽众生根本有始有终。佛亦照尽乃至一切烦恼一切众生果报。佛一心念称量尽原。一切佛国一切佛因果。一切佛菩萨神变。亦一念一时知住不可思议二谛之外独在无二

佛子。吾先在此树下说法界海时。有八万无垢菩萨现身得佛故。今为此大众略开佛果行处。汝应顶受

敬首菩萨白佛言。世尊。从初地至后一地。有果报神变二种法身。一法性身。二应化法身。为何色相为何心相。佛言

佛子。出世间果者从初地至佛地。各有二种法身。于第一义谛法流水中。从实性生智故。实智为法身。法名自体集藏为身。一切众生善根。感此实智法身故。法身能现应无量法身。所谓一切界国土身。一切众生身。一切佛身。一切菩萨身。皆悉能现不可思议身。国土亦然

佛子。土名一切贤圣所居之处。是故一切众生贤圣。各自居果报之土。若凡夫众生住五阴中为正报之土。山林大地共有名依报之土。初地圣人亦有二土。一实智土前智住后智为土。二变化净秽经劫数量应现之土。乃至无垢地土亦如是。一切众生乃至无垢地。尽非净土住果报故。唯佛居中道第一法性之土。是故我昔于普光堂上。广为一切众生说净土之门

佛子。初地一念无相法身智身。成就百万阿僧祇功德法。双照二谛心心寂灭法流水中。不可以凡夫心识思量二种法身。何况二地三地乃至妙觉地。但就应化道中。可以初地有百身千身万身乃至无量身。有缚有解。其法身处心心寂灭法流水中。上不见一切佛法一切果报可求。下不见无明诸见可断众生可化。但以世谛应化法中。见佛可求诸见可断众生可化。佛子。亦可得言修三坚法入圣人位。但法流水中心心寂灭。自然流入妙觉大海。佛子。乃至三贤十地之名。亦无名无相。但以应化故。古佛道法有十地之名。佛子。汝应受持一切佛法等无有异

佛子。世间果报者。所谓十住。铜宝璎珞铜轮王。百福子为眷属。生一佛土受佛学行教二天下。银宝璎珞银轮王。五百福子为眷属。生二佛国中受佛教行化三天下。金刚宝璎珞金轮王。千福子为眷属。入十方佛国中化一切众生。处四天下

欢喜地。百宝璎珞七宝相轮四天王。万子为眷属百法身为百佛国中化十方天下。千宝璎珞八宝相轮忉利王。二万子为眷属。万宝璎珞九宝相轮焰天王。眷属亦然不可称数。亿宝璎珞十宝相轮兜率陀天王。眷属亦然不可称数。天光宝璎珞十一宝相轮化乐天王。眷属亦然。摩尼宝光璎珞十二宝相轮他化天王。眷属亦然。千色龙宝光慧璎珞十三宝相轮梵天王。眷属亦然。梵师子宝光璎珞大应宝相轮光音天王。眷属亦然。不可思议宝光璎珞白云光宝相轮净天王。眷属亦然。百万神通宝光璎珞无畏珠宝相轮静居天王。眷属亦然。千万天色宝光璎珞觉德宝光相轮三界王。一切菩萨为眷属。无量功德藏宝光璎珞千福相轮法界王。一生补处菩萨为眷属。佛子。是上璎珞相轮。一切佛及菩萨。动止俱游常随其身。亦化一切众生。故有如是果报之名数法。佛子。三贤菩萨。伏三界烦恼粗业道粗相续果。亦不起粗。是见道喜忍伏三道业道。离忍伏人中业道。明忍伏六天业道。焰忍伏诸见业道。胜忍伏疑见业道。现忍伏因业道。无生忍伏果业道。不动忍伏色因业道。光忍伏心因业道。寂灭忍伏心色二习业道。无垢忍伏习果道。习前已除而果不败亡。是故佛子。三贤名为伏断喜忍。以上亦伏亦断。一切烦恼觉忍现时。法界中一切无明顿断无余

佛子。无明者。名不了一切法。迷法界而起三界业果。是故我言。从无明藏起十三烦恼。所谓。邪见我见常见断见戒盗见果盗见疑见。七见。见一切处求故说见。从见复起六着心。贪爱嗔痴欲慢。于法界中一切时起

佛子。一切烦恼以十三为本。无明与十三作本。是以就法界中别为三界报。佛子。见着二业。迷法界中一切色欲心。所起报故。分为欲界报

佛子。见着。二业迷法界中一切色心故。色心所起报。分为色界报

佛子。见着二业迷法界中一切定心故。定心所起报分为无色界报

是故于一法界中。有三界报。一切有为法。若凡若圣若见着若因果法不出法界。唯佛一人在法界外。然后为复来入法界藏中。为无明众生。示一切善恶道果报差别无量

佛子。前三贤伏三界无明。而用粗业。何以故。当受生时。善为缘子爱为润业故。受未来果故名息用而不断爱用。又十一人亦伏法界中三界业果故。初地乃至七地。三界业果俱伏尽无余。八地乃尽故。从此以上示现作佛。王宫受生。出家得道。转法轮灭度。亦现一切佛界。故无子爱三界之报。唯有无明习在。以大愿力故变化生。是以我昔天中。说生不生义业生变生。佛子。圣位中二种业。一慧业。无相无生智。心心缘法性而生无照。是名慧业。二功德业。实智出有谛中。有为无漏集百万阿僧祇功德。故名为功德业从初圣以上而现受生。以变易故毕故不造新。以愿力故住寿百劫千劫变化生一切

菩萨璎珞本业经卷上菩萨璎珞本业经卷下

        姚秦凉州沙门竺佛念译

    释义品第四

佛告敬首菩萨。汝先言义相云何者。所谓十住十行十向十地无垢地妙觉地义相今当说。佛子。是金刚海藏璎珞经中。释贤圣相义。义出体。体者菩萨体。义名功德如是二法。一切菩萨为体为义。故名体义

佛子。发心住者。是人从始具缚凡夫。未识三宝圣人。未识好恶因之以果。一切不识不解不知。佛子。从不识始凡夫地。值佛菩萨教法中起一念信便发菩提心。是人尔时住前。名信想菩萨。亦名假名菩萨。亦名名字菩萨。其人略行十心。所谓信心进心念心慧心定心戒心回向心护法心舍心愿心。复行十心。所谓十善法五戒八戒十戒六波罗蜜戒。是人复行十善。若一劫二劫三劫修十信。受六天果报。上善有三品。上品铁轮王化一天下。中品粟散王。下品人中王。具足一切烦恼

集无量善业亦退亦出。若值善知识学佛法。若一劫二劫方入住位。若不尔者常没不出。住退分善根如上说。佛子。发心住者。是上进分善根人。若一劫二劫一恒二恒三恒佛所。行十信心信三宝。常住八万四千般若波罗蜜。一切行一切法门皆习受行。常起信心。不作邪见十重五逆八倒。不生难处常值佛法。广多闻慧多求方便。始入空界住空性位。故名为住。空理智心习古佛法。一切功德不自造。心生一切功德故。不名为地但得名住。佛子。治地住者。常随空心净八万四千法门。清净白故。名治地住。佛子。长养一切行故。名修行住。佛子。生在佛家种性清净故。名生贵住。佛子。多习无量善根故。名方便具足住。佛子。成就第六般若故。名正心住。佛子。入无生毕竟空界。心心常行空无相愿故。名不退住。佛子。从发心不生倒。不起邪魔破菩提心故。名童真住。佛子。从佛王教中生解。当绍佛位故。名法王子住。佛子。从上九观空。得无生心最上故。名灌顶住

是故佛子。从灌顶心进入五阴法性空位。亦行八万四千般若波罗蜜。故名中十行佛子。就中始入法空。不为外道邪论所倒入正位故。名欢喜行。佛子。得常化一切众生皆法利众生故。名饶益行。佛子。法实得法忍心无我无我所故。名无嗔恨行。佛子。常住功德现化众生故。名无尽行。佛子。命终之时无明鬼不乱不浊不失正念故。名离痴乱行。佛子。生生常在佛国中生故。名善现行。佛子。于我无我乃至一切法空故。名无著行。佛子。三世佛法中常敬顺故。名尊重行。佛子。说法授人动成物则故。名善法行。佛子。二谛非如非相非非相故。名真实行

是故佛子。从真实心。入众生空无我空。二空平等无别。一观相一合相。学习百万亿般若波罗蜜空观故。回易前后心心。观唯明明寂灭。长养上地明观法故。回因向果。复以无量心不舍不受故。十向法如是。佛子。常以无相心中。常行六道而入果报。不受而受诸受。回易转化故。名救护一切众生离众生相回向。佛子。观一切法但有受但有用但有名。念念不住故。名不坏回向。佛子。三世诸佛法。一切时行故。名等一切佛回向。佛子。以大愿力入一切佛国中。供养一切佛故名至一切处回向。佛子。以常住三宝授与前人故。名无尽功德藏回向。佛子。习行相善无漏善而不二故。名随顺平等善根回向。佛子。以观善恶父母无二。一相一合相故。名随顺等观一切众生回向。佛子。常照有无二谛一切法一合相故。名如相回向。佛子。以诸法无二般若无生二谛平等。过去一合相现在一合相未来一合相故。名无缚解脱回向。佛子。觉一切法第一义谛中道无相一切法皆一照相故。名法界无量回向。佛子是三十心义释无量无边。非一切凡智所能思量。十方诸佛一切菩萨之所游路

佛子。汝先言云何名地。佛子。地名持。持一切百万阿僧祇功德。亦名生。成一切因果故名地。佛子。舍凡夫行生在佛家。绍菩萨位入圣众中。四魔不到。有无二边平等双照大信始满。习学无生中道第一义谛观。上至二地三地乃至十一地。明观法门心心寂灭法流水中。一相无相二身无方通同佛土故。名欢喜地。佛子。以正无相善入众生空。现万佛世界六通变化空同无为故。名离垢地。佛子。光慧信忍。修习古佛道。所谓十二部经。修多罗。祇夜。毗伽罗那。伽陀。忧陀那。尼陀那。阿波陀那。伊帝目多伽。阇陀伽。毗佛略。阿浮陀达摩。忧波提舍。以此法度众生。光光变通故名明地。佛子。大顺无生起忍。观一切法二谛相。上观佛功德。下观六道众生。大慈观故说法授乐。大悲观救三苦众生。大喜观喜前人受乐。大舍观一切众生。皆入平等入七观法。故名焰地。佛子。顺忍修道。三界无明疑见。一切无不皆空。八辩功德入五明论。所谓四辩因果内道外道辩。五论者内外方道因果鬼师无不通达。故名难胜地。佛子。上顺诸法。观过去一切法一合相。现在一切法一合相。未来一切法一合相。法界因缘寂灭无二。故名现前地

佛子。无生忍诸法。观非有烦恼非无烦恼。一生一灭一果。三界最后一身一入一出。集无量功德。常向上地念念寂灭。故名远行地。佛子。是故菩萨无生观。舍三界报变易果。用入中忍无相慧。出有入无化现无常。自见己身当果。诸佛摩顶说法。身心别行不可思议。故名不动地。佛子。复入上观光光佛化无生忍道。现一切佛身。故名妙慧地

佛子。菩萨尔时入中道第一义谛。大寂忍下品中行。行佛行处。坐千宝相莲华。受佛记位学佛化功。二习伏断大信成就。同真际等法界。二谛一相。具一切功德入众生根。无量璎珞功德。一时等现一切形相。故名法云地

佛子。菩萨尔时住大寂门中品忍观。功行满足登大山台。入百千三昧。集佛仪用唯有累果。无常生灭心心无为。行过十地解与佛同坐佛坐处。其智见二常无常一切法境。当知如佛名为学佛。下地一切菩萨。于此菩萨不能别知。于佛名菩萨。于下菩萨名佛。所以者何。是菩萨以大变力。住寿百劫万劫现作佛化。初生得道转法轮。入无余灭度。说八法轮。似佛非佛。一切佛等故。威仪进止一切法同。住是百千三昧中。如是佛行。故入金刚三昧。一相无相寂灭无为。故名无垢地。佛子。妙观上忍大寂无相。唯以一切众生缘生善法。亦自持一切功德。故名佛藏而寂照一切法。自佛以下一切菩萨照寂。是故佛子。吾昔第四禅中为八亿梵天王。说寂照如来无心。无色而寂照一切法。佛子。吾今略说义句。为此大众开善法行

    菩萨璎珞本业经佛母品第五

尔时敬首菩萨白佛言。佛及菩萨二。初照智从何而生。寂照寂照之义复云何。二谛法性为一为二。为有为无。第一义谛复当云何。佛言。佛子。所谓有谛无谛。中道第一义谛。是一切诸佛菩萨智母。乃至一切法。亦是诸佛菩萨智母。所以者何。诸佛菩萨从法生故。佛子。二谛者。世谛有故不空。无谛空故不有。二谛常尔故不一。圣照空故不二。有佛无佛法界不变故不空。第一无二故不有。无佛有佛法界二相故不一。诸法常清净故不二。诸佛还为凡夫故不空。无无故不有。空实故不一。本际不生故不二。不坏假名诸法相故不空。诸法即非诸法故不有。法非法故不二。非非法故不一。佛子。二谛义者。不一亦不二。不常亦不断。不来亦不去。不生亦不灭。而二相即圣智无二。无二故是诸佛菩萨智母。佛子。十方无极刹土诸佛。皆亦如是说。吾今为是大众略说明月璎珞经中二谛要义

尔时敬首菩萨白佛言。诸佛菩萨大方便平等慧照诸法界。为顿等觉。为渐渐云何。无明藏与心。为一为异。劫量久近复当云何。佛言。佛子。汝于过去七佛法中一一已问。非为不知。直为此大众十四亿人。于此法中便欲令得决了故问。佛子。吾今为十四亿大众。以金刚口说决定了义。佛子。我昔会有一亿八千无垢大士。即坐达法性原。顿觉无二一切法一合相。从法会出各各坐十方界。说菩萨璎珞大藏。时坐大众见一亿八千世尊。名顿觉如来。各坐百宝师子吼座。时无量大众亦坐一处。听等觉如来说璎珞法藏。是故无渐觉世尊。唯有顿觉如来。三世诸佛所说无异。今我亦然

佛子。汝先言。无明心一者。是事不然。苦解与无明诸见一相者。应无缚解凡佛非二。所以者何。烦恼同一体相故。何以故。而共一心生灭一时。不别不异故。佛子。若缚解一相者。四大可为一。六味应不异。而大异而味异故。缚解亦如是。佛子。一切菩萨为凡夫时具足一切结。而断时粗分先去细分后除。若一心烦恼一者。不应明闇有二。佛子。复以近况远。凡夫善心中尚无不善。何况无相心中而有无明。佛子。而言善恶一心者。是洴沙王国中外道安陀师偈。明闇一相善恶一心

佛子。我法正义。而可得言善恶同一行者。有缚有解有凡有佛。相续百劫同一行者。而不得善恶同一心。古佛常说。无相智火灭无明闇。而善恶二别。而言同一果者。亦无是处。一切善受佛果。无明受有为生灭之果。是故善果从善因生。是故恶果从恶因生。故名善不受生灭之果。唯受常佛之果。佛子。若凡夫圣人一切善。皆名无漏不受漏果。而言受漏果者。佛化众生行善背恶故。缘因而发有为果报。非为无漏。因者无明业受果故。是名三受三苦。苦苦行苦坏苦。苦受乐受舍受。二受善缘因果。苦受恶因果。一切皆苦无明为本。佛子。汝先言。一切菩萨行道劫数久近者。譬如一里二里乃至十里石。方广亦然。以天衣重三铢。人中日月岁数。三年一拂此石乃尽。名一小劫。若一里二里乃至四十里。亦名小劫。又八十里石方广亦然。以梵天衣重三铢。即梵天中百宝光明珠为日月岁数。三年一拂此石乃尽。名为中劫。又八百里石方广亦然。以净居天衣重三铢。即净居天千宝光明镜为日月岁数。三年一拂此石乃尽。故名一大阿僧祇劫。佛子。劫数者。所谓一里二里乃至十里石尽。名一里劫二里劫。五十里石尽。名五十里劫。百里石尽名百里劫。千里石尽名为千里劫。万里石尽名为万里劫。佛子。一切贤圣入是数量。修一切法门。时节久近得佛果。其数百劫乃得等觉。若一切众生入是数者得佛不久。若不入者不名菩萨。佛子。法门者。所谓十信心。是一切行本。是故十信心中。一信心有十品信心。为百法明门。复从是百法明心中。一心有百心故。为千法明门。复从千法明心中一心有千心。为万法明门。如是增进至无量明。转胜进上上法故。为明明法门。百万阿僧祇功德。一切行尽入此明门

    菩萨璎珞本业经因果品第六

敬首菩萨白佛言。贤圣正法已说具足。因果二相复当云何。佛言。佛子。三世诸佛所行之因。所谓十般若波罗蜜是百万阿僧祇功德本。佛及菩萨亦摄在中。是故十法为金刚智慧海藏。出一切光明功德之行

佛子。十般若波罗蜜者。从行施有三缘。一财。二法。三施众生无畏。戒有三缘。一自性戒。二受善法戒。三利益众生戒。忍有三缘。一忍苦行。二忍外恶。三第一义谛忍。精进有三缘。一起大誓之心。二方便进趣。三勤化众生。禅有三缘。一定乱相不起。二定生一切功德。三定利众生。慧有三缘。一照有谛。二无谛。三中道第一义谛。愿有三缘。一自行愿。二神通愿。三外化愿。方便有三缘。一进趣向果。二巧会有无。三一切法不舍不受。通力有三缘。一报通。二修定通。三变化通。无垢慧有三缘。一无相智。二一切种智。三变化智。佛子。从十智生一切功德行。七财。信施戒闻慧惭愧。资用成佛故说财。四摄。利益濡语施法同事。法辩义辩语辩乐说辩。于此四辩法中无障无碍。故名无碍。从无碍智生智名依故。依了经不依不了经。依法不须人。依义不须语。依智不须识。从智生十力四无畏六通三明百万亿阿僧祇功德。次第生智。能缘八世谛一切法四谛二谛十二缘。诸法缘成。假法无我。有法相待。一切相虚。相续名一。空不可得。因生集起。即法非缘。实实集有名生成法。法假造法。受名起用名聚法。是故八有为法。一切法本智所照处。复从是智能除五盖贪嗔睡掉疑。四食触识思段食。四生卵生胎生湿生化生。十恶五逆。八倒三障。八难十三烦恼。六道三界。六十二见。四流四缚四取。九烦恼七识住四结。一切所除皆名不善。佛子。十智境所除一切功德。皆名佛因。汝应受应行。佛子。汝先言果者。是五贤菩萨修诸道法。证一大果为法性体。其体者。非有非无非大非小。非身非心非相非三世。非天非人非名字。非常乐我净。非六道非六识入。非数量法过一切法相。非福田非鬼神。非动静非生灭。非第一非五色。非六大非土田。非法界非三界。非缚解非明闇非得法。寂然无为一切法外。心行处灭其处难量。就有谛中修劫量行而有果报。佛子。有二法身。一果极法身。二应化法身。其应化法身如影随形。以果身常故应身亦常。佛子。古昔诸佛二身道同。佛子。一切菩萨二身俱是无常身。佛子。一切凡夫亦有二身。一报身二方便身。报身不共有。方便身共一切众生有。佛子。一切菩萨一切众生皆有二身。一切诸如来常作如是说。故名决定了义。佛子。佛义功德身者。诸佛道同果法不异。所谓十号。一如来二应供三正遍知四明行足五善逝六世间解七无上士八调御丈夫九天人师十佛陀。具向十德故。为一切众生所供养。复次十八不共法。所谓身无失。念无失。口无失。无异想。无不定心。无不知已舍。心念无减。欲无减。精进无减。智慧无减。解脱无减。解脱知见无减。身业随智慧行。口业随智慧行。意业随智慧行。智知过去未来现在无碍无障。复有十力。是处非处力业力定力根力欲力性力果力天眼力宿命力结尽力。慈悲喜舍我是一切智人。我漏已尽无漏。出烦恼道烦恼障道。天身天眼天耳漏尽宿命他心。五眼五分法身。无罪三业佛宝法僧。灭谛解脱灵智一乘。金刚宝藏法身藏自性清妙藏。三达三无为三明。一谛一道独法大乐无为。佛子。一切圣果无量功德藏中。不可说不可说果。是果一道。佛子。果体圆满无德不备理无不周。居中道第一义谛清净国土。无极无名无相。非一切法可得。非有体非无体。其一照相一合相一体相一觉相。净明无二。佛子。是果独法圆满常住。一果体相有无量义。义有无量德。德有无量名。义果者。所谓灭谛常乐我净。十八不共一切功德。皆名义果。故名果果。佛子。义德名是三。皆教化故。有如是三句之义。若贤人一切众生。有解是三句者。是人已为三世诸佛受佛职位。佛子。其果不可说不可知。而就名相法中说名相法。是故一果名体。义名果果。是义果者。出圆果故。名果果。佛子。吾说此因果。百千劫说不可尽。汝诸大众。善自受持

    菩萨璎珞本业经大众受学品第七

尔时敬首菩萨敬礼于诸佛。奉承大众教。略问于要义七会之所说。信顺三宝藏。为法法不绝。不为世名利。愿令法久住。白佛言。世尊。佛上已说若因若果若贤若圣一切功德藏。今此大众有十四那由他人。谁能不起此坐受学修道。从始至终一一具行次第。入菩萨位者。时释迦牟尼佛顶髻。放一切佛光一切菩萨光。复集十方各百亿佛土其中佛及菩萨。一切皆集已。即于是众中告文殊师利菩萨。普贤菩萨。法慧菩萨。功德林菩萨。金刚幢菩萨。金刚藏菩萨。善才童子菩萨言。汝见是大众中敬首菩萨。能问三观法界诸佛自性清净道。一切菩萨所修明观法门。汝等七菩萨。各领百万大众。应受观学如是法门。佛子。我今更重说如是明观法。所谓六入次第道。谛听善思修诸智慧。戒敕于众受用伏行。佛子。若一切众生初入三宝海以信为本。住在佛家以戒为本。佛子。始行菩萨若信男若信女中。诸根不具黄门淫男淫女奴婢变化人受得戒。皆有心向故。初发心出家欲绍菩萨位者。当先受正法戒。戒者是一切行功德藏根本。正向佛果道一切行本。是戒能除一切大恶。所谓七见六着。正法明镜。佛子。今为诸菩萨结一切戒根本。所谓三受门。摄善法戒。所谓八万四千法门。摄众生戒。所谓慈悲喜舍化及一切众生皆得安乐。摄律仪戒。所谓十波罗夷

佛子。受戒有三种受。一者诸佛菩萨现在前受。得真实上品戒。二者诸佛菩萨灭度后。千里内有先受戒菩萨者。请为法师教授我戒。我先礼足应如是语。请大尊者。为师授与我戒。其弟子得正法戒。是中品戒。三佛灭度后千里内无法师之时。应在诸佛菩萨形像前。胡跪合掌自誓受戒。应如是言。我某甲白十方佛及大地菩萨等。我学一切菩萨戒者。是下品戒。第二第三亦如是说。佛子。是三摄受三种受戒。过去佛已说。未来佛当说。现在佛今说

过去诸菩萨已学。未来诸菩萨当学。现在诸菩萨今学。是诸佛正法戒。若一切佛一切菩萨不入此法戒门。得无上道果虚空平等地者。无有是处。佛告诸佛子。今正说正戒。善男子善女人当受戒时。先礼过去世尽过去际一切佛。礼未来世尽未来际一切佛。礼现在世尽现在际一切佛。如是三礼已。法僧亦然。佛子。复敬受四不坏信。依止四依法。从今时尽未来际身。归依佛归依法归依贤圣僧归依法戒。如是三说已。佛子。次当教悔过三世罪。若现在身口意十恶罪。愿毕竟不起尽未来际。若未来身口意十恶罪。愿毕竟不起尽未来际。若过去身口意十恶罪。愿毕竟不起尽未来际。如是悔过已。三业清净如净琉璃内外明照。即与授十无尽戒。汝等善听。佛告佛子。从今身至佛身尽未来际。于其中间不得故杀生。若有犯非菩萨行。失四十二贤圣法。不得犯。能持不。其受者答言能。佛子。从今身至佛身尽未来际。于其中间不得故妄语。若有犯非菩萨行。失四十二贤圣法。不得犯。能持不。其受者答言能。佛子。从今身至佛身尽未来际。于其中间不得故淫。若有犯非菩萨行。失四十二贤圣法。不得犯。能持不。其受者答言能。佛子。从今身至佛身尽未来际。于其中间不得故盗。若有犯非菩萨行。失四十二贤圣法。不得犯。能持不。其受者答言能。佛子。从今身至佛身尽未来际。于其中间不得沽酒。若有犯非菩萨行。失四十二贤圣法。不得犯。能持不。其受者答言能。佛子。从今身至佛身尽未来际。于其中间不得故说在家出家菩萨罪过。若有犯非菩萨行。失四十二贤圣法。不得犯。能持不。其受者答言能。佛子。从今身至佛身尽未来际。于其中间不得故悭。若有犯非菩萨行。失四十二贤圣法。不得犯。能持不。其受者答言能。佛子。从今身至佛身尽未来际。于其中间不得故嗔。若有犯非菩萨行。失四十二贤圣法。不得犯。能持不。其受者答言能。佛子。从今身至佛身尽未来际。于其中间不得故自赞毁他。若有犯非菩萨行。失四十二贤圣法。不得犯。能持不。其受者答言能。佛子。从今身至佛身尽未来际。于其中间不得故谤三宝藏。若有犯非菩萨行。失四十二贤圣法。不得犯。能持不。其受者答言能

佛子。受十无尽戒已。其受者过度四魔越三界苦。从生至生不失此戒。常随行人乃至成佛。佛子。若过去未来现在一切众生。不受是菩萨戒者。不名有情识者。畜生无异。不名为人。常离三宝海。非菩萨非男非女非鬼非人。名为畜生名为邪见。名为外道不近人情。故知菩萨戒有受法而无舍法。有犯不失尽未来际。若有人欲来受者。菩萨法师先为解说读诵。使其人心开意解生乐着心。然后为受。又复法师能于一切国土中。教化一人出家受菩萨戒者。是法师其福胜造八万四千塔。况复二人三人乃至百千。福果不可称量其师者。夫妇六亲得互为师授。其受戒者。入诸佛界菩萨数中。超过三劫生死之苦。是故应受。有而犯者胜无不犯。有犯名菩萨。无犯名外道。以是故。有受一分戒名一分菩萨。乃至二分三分四分。十分名具足受戒。是故菩萨十重八万威仪戒。十重有犯无悔。得使重受戒。八万威仪戒尽名轻。有犯得使悔过对首悔灭。一切菩萨凡圣戒尽心为体是故心亦尽戒亦尽。心无尽故戒亦无尽六道众生受得戒。但解语得戒不失。佛子。三世劫中一切佛常作是说。我今在此树下为十四亿人说。住前信想菩萨初受戒法。佛子。是信想菩萨。于十千劫行十戒法。当入十住心。佛子。当先为诸大众受菩萨戒。然后为说璎珞经同见同行。尔时众中有百亿人。即从坐起受持佛戒。其名梵陀首王共无数天子修十戒满足。入初住位

佛子。复从是住修行百法观门所谓十信十进十发趣十乘十金刚十随喜十戒十愿十护十回向。以是百法观达三界空假名皆空。一切法无我无人无受无因皆无定性。即灭十三缚。所谓七见六着。如实相入初行位。佛子。复从是行观修千法明门。所谓十信乃至十向。转转入法。法无我法集法起法道法灭皆无人受法法如虚空如幻如城如焰。一切法无相百千生灭皆不可得。入初回向位。佛子。复从是向明明转照。照智学相似平等观。观名无得。无得假得。喻如然灯有炷。非初焰者非初焰有时中有烧。非离初焰者非初焰无。时中有烧。后亦如之。直以有为诸法二谛皆迭迁。假号故烧故知始焰非今。今燋非始。今燋非始故。于今方有。始焰非今故。于今无烧。无烧于今今烧假烧得平等观亦复如是。非初心有中有得。亦非初心无中有得。后心亦然。是故始心非今心。今起非始起。今起非始起故。于今方有。始心非今心故。于今无得。无得于今。今得假得。中道第一义谛心。念念寂灭入万法明门。从十信乃至十向。自然流入平等道。无得一相真实观。一照相入初地道

佛子。复从是地正观一照智中。入百万阿僧祇功德门。于一相观中一时行。乃至第十地。心心寂灭自然流入无垢地。佛子。复从是地以一照智。了一切业因业果法界无不一观。以智知一切众生识始起一相住于缘。顺第一义谛起名善背第一义谛起名惑。以此二为住地故。名生得善生得惑。因此二善惑为本。起后一切善惑。从一切法缘生善惑名。作以得善作以得惑。而心非善惑。从二得名故善惑二心。起欲界惑名欲界住地。起色界惑名色界住地。起心惑故名无色界住地。以此四住地。起一切烦恼故。为始起四住地。其四住地前更无法起故。故名无始无明住地。金刚智知此始起一相有终。而不知其始前有法无法云何。而得知生得一住地作得三住地。唯佛知始知终。是无垢菩萨一切智齐知自地。常住第一义谛中。自然流入妙觉海地。佛子。住是妙觉地中。唯现化可名。有无量义有无量名其出一体所谓妙果常住清净至若虚空。不可思议不可说不可名数。不可名入界分可得

佛子。我说菩萨次第六入法门无量功德如是六入法门一切菩萨无不入者。我今此座有十四亿人。不离本座入此六入法门。佛子。我本初得道时。在此树间说十世界海法门。有九十亿人亦入此六入明门。复至普光堂说十佛国土。有百万亿人入此六入明门。复至帝释堂说十。住有五百万人入此六入明门。复至焰宝堂说十。行有千万人入此六入明。门复至第四天法光堂说十回。向有十河沙人入此六入明门。复至第六摩尼堂说十地。有百万河沙人入此六入明门。复至祇洹林说入法界品。有十二河沙人入此六入明门。今复至此第八会座。为十方无极大众敬首菩萨一切众。说六入明门一切大众受持若一无二无别

    菩萨璎珞本业经集散品第八

佛告敬首菩萨及此会十四亿那由他人大众。汝闻上四十二贤圣因果明观法门。一切大众皆应发三菩提心。如是三告佛子。应受应持应发心时诸大众中有百千天子。闻是法门发初住心。舍凡夫法修行伏忍。得入十住明观法。复有十千信男信女。入清净十行法门。复有八万大梵天王。得初地明观法。复有八部阿须轮王。各舍本形入十信心行十善行。复有八万第十地人现成正觉。佛子。尔时十方无极佛刹一切大众。闻佛说璎珞中六入法门所谓十住十行十向十地无垢地妙觉地。各各发无上菩提心还归本国。复有色界无色界。各各还修神通归本所住处。转宣菩萨璎珞法门化授天人。复有六欲天人还归本天。广为诸天人说本行无量。时诸大众各各受持读诵解其义味。还本土说菩萨之本行诸佛之本业受持已竟

尔时佛告文殊师利慧海金刚藏道华等八千菩萨。皆为十方诸佛国中第一弟子。汝应为十方无明众生。受持读诵解其义味。为过去未来现在一切众生。开空慧道入法明门。尔时有五十万大菩萨皆一生补处。从座而起受持佛语经劫不灭。复有万梵天王亦即从座起受持佛语。复有无量天女从座而起受持佛语。尔时他方无极刹菩萨此国菩萨。已变化神通入如幻三昧。踊在虚空欢喜无量。得闻受持璎珞功德经。心心受行成佛不舍众贤圣门。时佛复现百万变化神通无量光无量清净身。重嘱此金刚藏海璎珞经。汝诸大众。受持受此经法。是经是过去无量百千佛心中所行法。汝等受持供养。是时一切大众。一时从座放千光明照三千大千世界。欢喜受持菩萨不可思议璎珞经。顶受供养礼佛而退。复有六欲天子十千国王闻佛法座离散。一时号泣涕出流恸声满三千。无不悲泣从座而去。复有八十亿大菩萨。皆以四无量心有无一等无为无相受持佛语。各入无尽法化三昧欢喜而退。复有十千始行贤者。入九观定四禅四空定尽灭定七净十戒心入定见道度疑。正道行知见行断知见。得入法故礼佛而退

尔时座中有八千菩萨各从座起。一金刚华菩萨白佛言。世尊。未来世中说经菩萨法轮下。其听法者受化奉行法用。复当云何。佛言。佛子。快发斯问。佛子。先当为听法者与授菩萨法戒。然后为说菩萨之本行六入法门。佛子。次第为授四归法。归佛归法归僧归戒。得四不坏信心故。然后为授十戒。不杀不盗不妄语不淫不沽酒不说在家出家菩萨罪过不悭不嗔不自赞毁他不谤三宝。是十波罗夷不可悔法。佛子。受十戒已。复为听者教供养法师。常以天上无量华香。百千灯明百千天衣璎珞。百千妓乐百味饮食屋宅经书。一切所须之物皆悉给与。弘通法师。当如敬佛如事父母。如事火婆罗门法。佛子。如事帝释父母师僧。日日三时礼敬为法舍身没命。乃是佛子。如是求法之人。乃可为说菩萨之本行。百千万佛转授璎珞法门。时十亿大众叹言。未来世中无法无三宝无贤人。时劫从恶世起故。其说法者其听法者甚难甚难。复从坐起各各悲泣。号声大恸地转海波。三千倒覆。二十八宿日月不现。是时大众还摄神力佥然而敬。受持读诵解说义句。十劫不灭无穷无尽。各各欢喜奉行。作礼而退

菩萨璎珞本业经卷下


清净毗尼方广经

    No. 1489 [No. 1490]

清净毗尼方广经

        后秦龟兹国三藏鸠摩罗什译

如是我闻。一时佛住王舍城只阇崛山。与大比丘僧八千人俱。菩萨摩诃萨万二千人及欲色界天净居天子。尔时世尊与诸无量百千大众。恭敬围绕而演说法。时有天子名寂调伏音。来在会坐。是时寂调伏音天子从坐而起。偏袒右肩右膝着地。合掌向佛。白世尊言。是文殊师利为住何处今此大众渴仰欲见。是善丈夫从其闻法。如是问已时佛告彼寂调伏音。天子东方过此十千佛土彼有佛国名曰宝主是中有佛号曰宝相如来应正遍觉现在说法文殊师利住在彼土。为诸菩萨摩诃萨而转说法。时彼天子白世尊言唯愿现相令文殊师利来诣此土。何以故。世尊。若从一切声闻缘觉有所闻法。不如从于文殊师利所闻法也唯除如来。其余说法无有胜者文殊师利若演说法。一切魔宫皆悉闇蔽。一切众魔悉能摧伏去增上慢。灭增上慢。若有未发菩提心者发菩提心。已发心者住不退转可摄者摄可舍者舍。顺如来欲令正法久住。尔时世尊知寂调伏音天子心已放白毫藏光普遍照此佛世界已东方过于十千佛土。普照遍彼宝主世界。时宝主世界菩萨摩诃萨见此光已白宝相佛言世尊。是何光相有此光明遍照此界。如是问已。宝相佛告诸菩萨言。善男子。西方去此十千佛土有国名娑婆。其中有佛号释迦牟尼如来应供正遍觉。现在说法。彼如来放毫藏一光。是光通彻。十千佛土来照此界。是诸菩萨白世尊言。以何因缘故。彼释迦牟尼如来应正遍觉。放毫藏一光。时佛报言。彼释迦牟尼如来国。有无量千亿菩萨皆悉集会。及释梵护世一切四众。欲见文殊师利童子从其闻法。以是缘故。请彼释迦牟尼如来放毫藏一光。时宝相佛告文殊师利。汝今可往娑婆世界。释迦如来应正遍觉喜欲见汝。及诸大众欲见闻法。文殊师利。白彼世尊。我今亦知如是光瑞。时文殊师利法王之子。与十千菩萨俱。头面敬礼宝相佛足。譬如壮士屈申臂顷。与十千菩萨没宝主界到娑婆界。住虚空中而不现形。雨种种花以供如来普及大众。积至于膝。杂色妙好色香适意。一切大众见雨此华。白世尊言。是何先相大雨此花。佛言。诸善男子。是文殊师利法王之子。与十千菩萨俱。来到此娑婆世界。住虚空中而不现形。雨花供我。时诸大众俱共同声白世尊言。我等欲见文殊师利法王之子。及诸菩萨摩诃萨睹其形容。时文殊师利及十千菩萨从空而下。顶礼佛足右绕已毕。各以神力化作座已却坐一面。时寂调伏音天子白世尊言。愿问文殊师利法王之子。建立言论众所欲闻。佛告天子。汝今自问文殊师利法王之子。随汝所疑。时寂调伏音天子问文殊师利。彼宝相佛土。云何说法汝乐于彼。文殊师利报言。天子。不生贪欲不灭贪欲。不生嗔恚不灭嗔恚。不生愚痴不灭愚痴。不生烦恼不灭烦恼。何以故。无生之法终无有灭。天子问言。云何文殊师利。彼土众生不生贪嗔愚痴烦恼又不灭耶。答言。不也天子。天子问言。彼佛说法为何所断。答言。为不生不灭而演说法。何以故。彼佛刹土不知断不修证。彼诸众生重第一义谛。非重世谛。天子问言。文殊师利。云何名为第一义谛。文殊师利言。天子。彼不住生又不住灭。无有处相非无处相。非相非无相。非相非虚空。色相非可相。非不可相。非尽可尽。无尽无有能尽。如是说名第一义谛。天子。义者非心非心相续。非言说句。无此无彼亦无中间。如是说名第一义谛。天子。又复义者。而不可得无文字行。是名第一义谛。何以故。佛说一切所有音声皆是虚妄。天子言。文殊师利如来所说可虚妄耶。天子。如来所说无实无虚妄。何以故。如来无二相。无住心无言说。非有为法非无为法。非说实非说虚。无二相。天子。于意云何。如来化人若有所说。为实为虚妄。答言。非实非虚妄。何以故。如来化人无有实故。文殊师利言。如是如是。天子。一切诸法无成就者。如来所说无实无虚妄。故名无二。天子言。文殊师利。云何如来说第一义谛。文殊师利言。天子。无有能说第一义谛者。何以故。是无言说无能说者。说是法时。五百比丘不受诸法漏尽心得解脱。二百天子逮得法忍。尔时寂调伏音天子问文殊师利。第一义谛甚为难解。文殊师利言。如是如是。天子。第一义谛实为难解。不正修行者实为难解。天子问言。文殊师利。云何菩萨名正修行。文殊师利言。若不说言。知是断是修是证是。何以故。若有相者。是贪是着是戏论。若有说言。是应知应断应修应证。是不名为正修行也。天子问言。文殊师利。云何菩萨正修行也。天子。如如等法界等五逆等。如法界等诸见亦等。如凡夫法等。学法亦等。无学法等。如声闻法等。缘觉法等。菩萨法等。佛法亦等。如生死法等。涅槃法等。烦恼亦等。诤讼亦等。天子问言。文殊师利。云何诤讼等烦恼亦等。文殊师利言。空故等。无相故等。无愿故等。何以故。空无分异故。天子。如宝器空泥器空。其中空界等无有异。无有种种以无二故。如是天子。如烦恼空及诤讼空。无有别异等无有二。天子言。文殊师利。菩萨颇修于圣谛不。文殊师利言。天子。若其菩萨不修圣谛。云何能为声闻说法。又复天子。菩萨修圣谛有观。声闻修圣谛无观。菩萨修圣谛有闲。声闻修圣谛无闲。菩萨修圣谛有缘。声闻修圣谛无缘。菩萨修圣谛。而正观之不证实际。菩萨修圣谛有善方便。不背生死向于涅槃。菩萨修圣谛观一切佛法。天子。譬如有人舍大伴主。独一无侣欲过旷路。心甚惊怖不敢复还。如是天子声闻亦尔。怖畏生死不还世间。舍一切众生不还生死。不观佛法无善方便。独一无二修行圣谛。天子。如大伴主多诸眷属多诸财产。资粮丰饶大获生利欲过旷路。天子。菩萨如是为大伴主。多诸眷属成大法利。多法资粮具足六波罗蜜成四摄法。普悉观缘一切众生。观生死回流正观佛法。从于佛土至于佛土。具善方便修于圣谛。天子。如疏薄物。若以瞻婆须曼婆师花所熏之香。香气速出。如是天子。声闻修谛速疾如是。不满所愿中入涅槃。彼亦不出于佛戒闻定慧解脱解脱知见功德之香。又亦不能断烦恼习。天子。如迦尸衣若以天宝沉水香熏。经百千年清净美香人天敬重。如是天子。菩萨百千万亿劫中常修圣谛。不中入涅槃欲满本愿。出佛戒闻定慧解脱解脱知见功德之香。能断结习。为诸人天阿修罗乾闼婆等之所敬重。寂调伏音天子。又问文殊师利。彼宝相如来应正遍觉。是佛国土诸声闻众为何如也。如乐于彼。文殊师利言。天子。彼土声闻不住于信。不教他信不护法界。非八人出过八邪。非须陀洹出过恶道。非斯陀含往来教化一切众生。非阿那含一切诸法无去来故。非阿罗汉受于一切三千界供。亦非声闻能持一切佛所说法。不断于欲不为欲热。不断于嗔不为嗔热。不断于痴不为痴热。于一切法离诸暗障。不断烦恼勤行精进。断于一切众生烦恼永无有生。过一切生随心欲生。无有我人众生之相。而教化众生无取无与。一切众生清净福田。无思无念而修正念。不生不灭而修正断。远离身心而出生神足。知于一切众生诸根到于彼岸。而修行根。摧一切结而修于力。遍知一切而修于觉。得于无为不证于道。到于实际而修于定。至于法界而修于慧。尽于无明而生于明。无有二行而证解脱。肉眼悉见一切众生一切佛国一切诸佛。天眼悉见一切众生死此生彼。慧眼观见一切众生生死无来无去。法眼见于诸法平等。佛眼明见一切佛界。天耳悉闻一切佛法。能受能持。一心能知一切众生所有心行。悉知宿命过去际劫。百千万亿神通能过无量佛刹。烦恼悉尽不证解脱。虽复可见然非色身。虽有言说无有文字。虽有思念而心无动。形色尊妙众相庄严。功德璎珞威德难当。名闻高远净戒涂香。世法不污烦恼不染。无粗恶言游戏神通。多闻增广辩才震吼善知变化。调伏闇冥大慧明照。所说无滞总持究竟。常为诸佛之所护念。声闻所念常恒专念。菩提之道其念如海。定如须弥忍如大地。勇健降魔犹如帝释。无能轻者寂静如梵。无有等等犹如虚空遍入一切。天子。彼宝相佛土声闻如是。所有功德复过于此。说是法时。于是会中五百比丘五百比丘尼。五百优婆塞五百优婆夷。五千天子向声闻智。说如是言。世尊。我等愿为彼宝相如来作声闻众。文殊师利言。善男子。非声闻心能生彼土。汝等可发无上道心得生彼土。诸生彼者皆是发阿耨多罗三藐三菩提心。尔时是等即发无上正真道心。如来悉记当生彼土。时寂调伏音天子。问文殊师利。云何名为菩萨毗尼。云何名为声闻毗尼。文殊师利言。天子。怖畏三界毗尼。是声闻毗尼。受无量生死欲化一切诸众生等生于三界毗尼。是菩萨毗尼。轻毁功德庄严毗尼。是声闻毗尼。自集功德庄严毗尼。是菩萨毗尼。自断一切诸烦恼结。是声闻毗尼。欲断一切众生烦恼。是菩萨毗尼。不念成熟一切众生一切佛法。是声闻毗尼。念欲成熟一切众生一切佛法。是菩萨毗尼。非为一切诸天所识。是声闻毗尼。一切三千大千世界诸天识知。是菩萨毗尼。一切魔舍是声闻毗尼。一切三千大千世界诸魔[口*睪]哭。一切众魔生于怨憎生摧伏想。是菩萨毗尼。唯独照明是声闻毗尼。普欲照明一切世间。欲照明成就一切佛法。是菩萨毗尼。自观之心是声闻毗尼。观一切佛法是菩萨毗尼。渐次毗尼是声闻毗尼。一念悉知是菩萨毗尼。断三宝种是声闻毗尼。持三宝种是菩萨毗尼。如破瓦器不可修补。是声闻毗尼。如金银器破还可修治。是菩萨毗尼。无善方便是声闻毗尼。成就方便是菩萨毗尼。无有十力四无所畏。是声闻毗尼。成就十力四无所畏。是菩萨毗尼。少水果树是声闻毗尼。园林堂阁法乐可乐。是菩萨毗尼。无六波罗蜜无四摄法。是声闻毗尼有六波罗蜜具四摄法。是菩萨毗尼。不断一切习是声闻毗尼。灭一切习是菩萨毗尼。又复天子。略说有限所摄。有少法功德有少戒闻定慧解脱解脱知见。是声闻毗尼。无量无量所摄。无量功德。无量戒闻定慧解脱解脱知见。是菩萨毗尼

尔时世尊赞文殊师利。善哉善哉。文殊师利。汝快说此菩萨毗尼。文殊师利。听我少说成满汝义。文殊师利。譬如二人。一赞大海二叹牛迹。文殊师利。于意云何。是人能赞是牛迹中几所功德。文殊师利白言。世尊。大海无量。牛迹甚少。当何所赞。佛言如是知声闻毗尼犹如牛迹小无功德无可赞叹。声闻乘人亦复如是。文殊师利。于意云何。彼第二人能赞大海功德不也。文殊师利言。世尊。而是大海有无量功德无量可叹。佛言。当知菩萨毗尼亦复如是。譬如大海无量功德无量可叹。当知大乘亦复如是。说是法时。万二千天子发阿耨多罗三藐三菩提心。而说是言。世尊。我等亦当修学如此菩萨毗尼。调伏无量一切众生。时寂调伏音天子问文殊师利。汝今修学何等毗尼。声闻毗尼。缘觉毗尼。菩萨毗尼。文殊师利言。天子。于意云何。颇有大海不纳众水。天子答言。文殊师利。无有大海不纳众水。文殊师利言。如是天子。菩萨毗尼犹如大海。所有毗尼无不纳受。所谓声闻毗尼。缘觉毗尼。菩萨毗尼。一切毗尼。天子言。文殊师利。所言毗尼。毗尼者为何等义。文殊师利言。天子。毗尼毗尼者。调伏烦恼。为知烦恼故名毗尼。天子言。文殊师利。云何当修调伏烦恼。云何知烦恼。文殊师利言。若自妄想。若他妄想。自他妄想不正忆念。自想他想颠倒不实。诸见所缚无明为首。如是则能发生烦恼。若不自妄想。不他妄想。不自他妄想。专正忆念不自想他想。断于颠倒不住诸见。除去无明不行二行。如是则便不起烦恼。烦恼不起是毕竟毗尼。天子。是名毕竟毗尼。若以圣智知于烦恼。虚妄诈伪是无所有。无主无我无所系属。无来处去处。无方非无方。非内非外非中可得。无聚无积无形无色。如是名为知于烦恼。天子。如人知于毒蛇种性。能寂彼毒。如是若知结使种性。能寂烦恼。天子问言。云何名为烦恼种性。文殊师利言。妄想是烦恼种。若不妄想则便不起。若其不起则非烦恼。若无烦恼则无窟宅。若无窟宅则无所烧。亦无所住。若无所住名毕竟毗尼。如是名为知烦恼种性。天子问言。云何文殊师利。是调伏烦恼。为实为不实。文殊师利言。天子。如人梦为毒蛇所螫。以苦痛故服于毒药。蛇毒消除苦痛便差。天子。于意云何。如彼人者为蛇所螫。为实不实。天子答言。文殊师利。此是不实。无有实故。当除何毒。文殊师利言。毒蛇不实除亦不实。应如是知。诸圣毗尼亦复如是。天子。汝作是言云何是调伏烦恼。为实为不实。天子。若我无我烦恼无烦恼。若我实者烦恼亦实。是中若我无我。烦恼无烦恼。都不可得。若如是者当何调伏。何以故。天子。一切法寂以无生故。一切法寂不可取故。一切法寂无形相故。一切法尽无所有故。一切法无尽以无生故。一切法无生无所有故。一切法无灭无有坚实故。一切法无作无作者故。一切法无作无有我故。一切法无我以无主故。一切法无主如虚空故。一切法无来以无体故。一切法无去以无际故。一切法无住无住处故。一切法无住无生灭故。一切法无为以无漏故。天子。一切法无与毕竟调伏故。寂调伏音天子复问文殊师利。一切诸法以何为门。文殊师利言。不正修门增生死故。正修行门获涅槃故。正修行门得自在故。不正修门不得自在故。疑惑门闇障碍故。达解门无暗障故。妄想门增烦恼故。无妄想门无烦恼故。识门有结使故。无识门无结使故。觉门多事务故。寂门一切寂静故。见门增憍慢故。空门灭憍慢故。恶知识门生诸恶法故。善知识门生诸善法故。邪见门生诸苦本故。正见门生诸善本故。悭惜门贫穷故。布施门大财封故。毁戒门诸恶道故。持戒门诸善处故。诤讼门障诸法故。忍辱门增胜法故。懈怠门令心垢故。精进门心无垢故。觉观门多乱闹故。禅定门心一处故。无智慧门如痴羊故。智慧门三十七助道分故。慈门不障智故。悲门质直无虚伪故。喜门集法宝故。舍门离爱憎故。正念门不失本善根故。断门修正行故。神足门身心轻故。根门信为首故。力门摧伏一切诸烦恼故。觉门顺觉诸法故。八圣道门出过一切诸非道故。复次天子。菩提心门一切佛法故。摄一切法门于一切法得自在故。摄众生门演说法故。善方便门处非处故。慧度门到于一切众生心行之彼岸故。六波罗蜜门大乘故。六神通门慧光明故。法施忍门不随他智故。天子又问。文殊师利。何等为法界门。文殊师利言。天子。普遍门是法界门。天子言。何界是法界。文殊师利言。一切众生界是法界。天子言。文殊师利。法界有边际不。答言。天子。于意云何。虚空有边际不。不也。文殊师利。天子。犹如虚空无有边际。法界亦尔无有边际。天子言。文殊师利。汝知法界耶。答言。天子。法界不知法界。天子言。文殊师利。汝知何法有如是辩。答言。天子于意云何。响知何法而出音声。天子言。响无所知而出音声。以因缘故而有音声。如是天子。菩萨缘众生故。而有所说。天子言。汝住何处能有所说。答言。天子。犹如如来化人所住。而有所说。我住亦尔。天子言。如来化人无有住处。答言。天子。如来子人无所住而有所说。一切诸法亦无所住。而有所说。天子言。文殊师利。若一切法无住。汝住何处成无上道。文殊师利言。天子我住无间。成无上道。天子言。无间为住何处。答言。无间住无根本。天子言。文殊师利。住无间者必堕地狱答言。天子如是如是如来所说造五无间必堕地狱。天子。我今亦住于五无间。天子。菩萨住五无间成无上道何等为五菩萨摩诃萨从初发心求无上道。中间不堕声闻缘觉地。是初无间。我应救济一切众生中间无懈。是二无间。舍一切物中间无悭。是三无间。知诸法无生。中间不与诸见共住。是四无间。若知若见若断平等正觉。以一念相应慧而觉知之。中间不起必成正觉。是五无间。若菩萨住是五无间。成阿耨多罗三藐三菩提。天子言。文殊师利。颇有凡夫住五无间堕于地狱。菩萨亦住此五无间。成于无上正真道耶。答言有。天子言。以何因缘故。答言。天子。一切法空。解于空故名得菩提。一切诸法。无相无愿非有为。无生无起因缘生。觉是因缘故名觉菩提

天子言。文殊师利。谁信此法。答言。天子。若佛如来尚不生信。况复声闻。天子又问。谁解是法。答言。不行我相者。又问谁信是法。答言。不住此彼岸者。天子言。若不住此彼。谁想是法。答言。于一切法无忆想者。又问谁持。答言。不持一切结使者持。天子又问。此经当至何等人手。答言。至与一切众生法者之手。又问。彼何形色。答言。天子。彼有法色。非阴界入色。又问。彼有何行。答言。彼有空行无相行无愿行。又问。彼趣何处。答言。天子。彼当趣向一切至处。到于一切众生心行。至无所至。天子问言。文殊师利。菩萨退不。答言。天子若菩萨退阿耨多罗三藐三菩提。无有是处。天子言。谁为退者。答言。一切诸烦恼退。一切声闻缘觉地退又问。谁是不退。答言。三昧等者是无有退。天子言。文殊师利。何等为三昧。答言。无二无别异。天子言。文殊师利。若一切法无有别异。谁为别异。答言。天子。不知一切法平等者。分别为二。彼行二行堕于二行。若知平等不行别异。若知平等彼趣平等。天子又问。文殊师利。颇有菩萨具于烦恼成菩提耶。答言有。天子又问是谁。答言。天子。若菩萨断结使是声闻。若菩萨知一切众生烦恼结使。大悲增盛发于无上正真道心。是有菩提。天子问言。颇有悭吝成檀波罗蜜耶。答言有。问言是谁。答言。天子。若菩萨不舍菩提之心。摄护众生。如是悭吝是檀波罗蜜。天子又问。颇有毁戒名尸波罗蜜耶。答言有。问言是谁。答言。天子。若菩萨多益一切众生不自观戒。如是毁戒名尸波罗蜜。文殊师利。颇有菩萨舍于堪忍名忍波罗蜜耶。答言有。问言。是谁。答言。天子。若菩萨舍外道禁戒坚住佛戒。是名羼提波罗蜜。文殊师利。颇有懈怠成精进波罗蜜耶。答言有。问言是谁。答言。天子。若菩萨于声闻缘觉地生于懈怠。勤加修习无上正道。是名毗梨耶波罗蜜。文殊师利。颇有不定心名禅波罗蜜耶。答言有。问言是谁。答言。天子。菩萨梦中不生声闻缘觉地心。是菩萨不定心。是名禅波罗蜜。文殊师利。颇有无慧名菩萨般若波罗蜜耶。答言有。问言是谁。答言。天子。谓无慧者而是菩萨。不作一切世间蛊道诸恶咒术厌镇颠狂。苦于一切众生法慧。是菩萨成就具一切智。是名般若波罗蜜。是时世尊赞文殊师利。善哉善哉。文殊师利。善说菩萨应作不应作。汝如是说。文殊师利。听吾少说。文殊师利。如人饥羸宁忍饥苦。终不服于杂毒之食。菩萨如是。宁悭贪毁戒嗔诤懈怠。乱心妄念愚无智慧。不住声闻缘觉地中。正念施戒忍进禅慧。何以故。菩萨于中应生怖畏。天子问佛。菩萨不怖畏结使耶。佛言。应怖。天子。但菩萨于声闻地中倍应生怖。天子。于意云何。如人护命。为畏斩头畏斩手足。天子白佛。彼畏斩头不畏手足。何以故。世尊。人斩手足能修福业。以是因缘得生天上。世尊。若人斩头失于寿命。不修德行。佛言。如是。天子。菩萨宁当毁犯禁戒。终不舍于一切智心。宁为菩萨具诸烦恼。终不作于漏尽罗汉。天子叹曰。希有世尊。是菩萨所行胜余世间。世尊。诸声闻持戒勤加精进。即是菩萨毁禁懈怠。佛言。如是如是。如汝所说。天子。如贫人食是转轮王毒。如是天子。声闻勤进断诸烦恼。尚不安乐阎浮众生。况复一切诸众生也。天子。如大商主多财封邑。大舍勤进多所利安多所养育。菩萨如是行大慈悲。于一切众生兴起大悲修行。精进养育无量一切众生。令得世间出世间乐。是时长老大迦叶白世尊言。诸声闻人证无为法。菩萨唯得有为之法。云何有为菩萨。胜无为声闻。佛言。迦叶。我今为喻。诸有智者因是得解。迦叶。譬如有人破析一毛以为百分。是人复以此一分毛。点满四大海中之酥。迦叶。于意云何。是人毛分取四海酥。能作是念。我所取多非海中者。迦叶白言。不也世尊。佛言。迦叶。汝意云何。于此二分。何者为胜。何者为大。何者为多。何者大价。迦叶白言。假使令取千亿由旬。余者犹胜犹大犹多有于大价。况以毛分唯取一渧。佛言。迦叶。如毛百分以一分毛取一点酥。声闻所有无为智慧。亦复如是。佛智所知。迦叶。如满四大海中之酥。菩萨有为善根功德。亦复如是。用以回向无为智故。迦叶。譬如蚁子含持一粒。犹如秋月成熟谷满大地。迦叶。于意云何。何者为胜。世尊。秋月成熟谷满大地。有无量谷。救济养育无量众生以为资粮。世尊。蚁持一粒无所利安。迦叶。蚁持一粒。如诸声闻解脱之果亦复如是。如秋谷成熟满于大地。当知菩萨六波罗蜜四摄之法。善根功德亦复如是。成熟养活无量众生。安置世乐出世间乐及涅槃乐。迦叶。如有百千水精珠担而来入城。若一无价琉璃宝珠置之船上。若其安隐达阎浮提。救护一切贫穷困苦。迦叶。于意云何。是百千担水精入城。是无价宝一琉璃珠可为比不。不也世尊。迦叶。是百千担诸水精珠来入城者。喻于声闻无为功德。亦复如是。如一无价宝琉璃珠船上安隐。至阎浮提多所安乐。菩萨如是不断三宝种。发于一切智宝之心多所安乐。时大迦叶白世尊言。未曾有也。如来善说。诸菩萨等发于一切智宝之心。出过一切声闻缘觉。尔时宝主世界菩萨诸与文殊师利来者。闻说是已白世尊言。一切言说皆是戏论。是差别说呵责结使说。世尊。宝相佛土无有是说。纯明菩萨不退转说。无差别说。世尊难有。释迦牟尼如来应正遍觉能忍是苦。得一切法无有差别无上中下。一味法性安置三乘。是诸菩萨即以天花散供佛上。语文殊师利。我等可还宝主世界。文殊师利言。汝等可去宜知是时。诸菩萨言。汝不去耶。文殊师利言。善男子。一切世界皆悉平等。一切佛等一切法等一切众生等。我住于彼。何所为作。诸菩萨言。以何事故。一切世界等一切佛等一切法等一切众生等。文殊师利言。诸善男子。一切刹土如虚空故等。诸佛法界不思议故等一切诸法虚伪故等。一切众生无我故等。以是义故我如是说。一切世界等乃至一切诸众生等。时文殊师利现神通力。以神力故令娑婆界。如宝主界等无差别。令世尊释迦牟尼。如宝相如来等无差别。彼诸菩萨各作是念。我等已到宝主世界。于释迦牟尼佛生宝相佛想。即白佛言。谁使我等来至此土。佛言。谁将汝去。诸菩萨言。文殊师利童子将我等去。佛言。彼将汝来。尔时文殊师利语诸菩萨。善男子。汝等各各入定观之。谁将汝来。谁将汝去。时诸菩萨各入定观各作念言。我等不动娑婆世界去。我等自谓至宝主界。世尊。未曾有也。文殊师利以神通力三昧之力。使我等谓到宝主界。犹故不动是娑婆界。世尊。愿令一切众生。悉得如是神力如文殊师利。尔时佛告宝主世界诸来菩萨。善男子等。如金器银器颇梨器琉璃器水精器铁器金刚器栴檀器宝器瓦器木器。其中空界。器虽种种其空无异。如是一法性一如一实际。然诸众生种种形相各取生处。彼自体变百千亿种形色别异。谓地狱色畜生色饿鬼色。天色人色。声闻色缘觉色菩萨色佛色。以平等故色等如。如等故色等如。空等故色等。善男子。文殊师利以是事故说。一切世界等乃至一切众生等。是故说言我今不往。是时世尊以如是法。示教利喜诸菩萨已。头面礼足绕佛三匝出众不远。没娑婆界往宝主界。是时佛告阿难。汝受此经持读诵说。于大众中为人广说。大德阿难白世尊言。我已受持。世尊。当何名斯经。云何受持。佛告阿难。此经名寂调伏音天子所问。亦名清净毗尼。亦名一切佛法。佛说是经已。大德阿难。寂调伏音天子。文殊师利等一切菩萨。大迦叶等一切声闻。闻佛所说。皆大欢喜

清净毗尼方广经


萨婆多部毗尼摩得勒伽

    No. 1441

萨婆多部毗尼摩得勒伽卷第一

        宋元嘉年僧伽跋摩译

    初毗尼众事分　问波罗夷戒

  前顶礼世尊　　法王圣种生
  降伏诸恶行　　善调诸弟子
  毗尼为最胜　　我今说少分
  如树根为本　　枝叶依彼增
  一切善法聚　　毗尼为根本
  大觉之所说　　如堤塘防水
  大驶流不坏　　如是毗尼堤
  防诸恶戒水　　佛及诸菩萨
  最为人中尊　　辟支佛清净
  牟尼诸弟子　　应供阿罗汉
  亦说毗尼因　　以离诸有缚
  今离及当离　　皆住毗尼中
  离是无解脱　　是故精勤学
  圣众和合住　　诸佛秘密藏
  在世常不灭　　法灯照世间
  离则不寂灭

问犯毗尼罪作无作耶。答犯罪。作无作色非色耶。答是。色可见不可见耶。答或可见或不可见。云何可见。谓身作。云何不可见。谓身无作及口作无作有对无对耶。答若作是有对无作是无对。有漏无漏耶。答有漏。有为无为耶。答有为。世间法出世间法耶。答世间法。阴摄不摄耶。答阴摄。界摄不摄耶。答界摄

问罪受不受耶。答不受(此受如不离根受之也)从受生非受生耶。答从受生(此受四受之受也)四大造非四大造耶。答四大造。从结生非结生耶。答从结生。记无记耶。答或记或无记。云何记佛所结戒故犯。云何无记佛所结戒不故犯。隐没不隐没耶。答或隐没或不隐没。云何隐没佛所结戒故犯。云何不隐没佛所结戒不故犯。如隐没不隐没。秽污不秽污亦如是。染污不染污耶。答染污。依家不依家耶。答依家

问罪有诤无诤耶。答有诤。有缘无缘耶。答无缘。心非心耶。答非心。心数非心数耶。答非心数。有报无报耶。答或有报或无报。云何有报有记犯。云何无报无记犯。业非业耶。答是业。内入外入耶。答外入。过去未来现在耶。答或过去或未来或现在。云何过去。若犯罪竟已忏悔是过去。云何未来。若未犯罪必当犯是未来。云何现在。若犯罪不发露悔过是现在。问罪为善不善无记耶。答或不善无记。云何不善佛所结戒故犯。云何无记佛所结戒不故犯。记无记前已说。为欲界色界无色界摄耶。答欲界摄。为学无学非学非无学耶。答非学非无学。见断修断无断耶。答修断。为身为口为意罪耶。答或身或口。云何身。若比丘故夺众生命。偷盗。作淫摩触。身故出精。杀草木自手掘地。非时食饮酒等。此是身罪。云何口罪。若比丘空无所有说过人法。共女人粗恶语无净人。为女说法等。是口罪。无独心犯罪。问颇有行此事犯罪即行此事不犯耶。答或有犯或不犯。云何犯。如比丘不受迦絺那衣。受畜长衣。别众食处处食。不白入聚落等。随其事犯罪。云何不犯。若比丘受迦絺那衣。随意畜衣。别众食处处食。不白入聚落。随其事不犯。是故即行此事犯不犯。问颇有作此羯磨犯即作此羯磨不犯耶。答有如比丘不见摈。恶邪不除摈。向诸比丘。下意调伏随顺。诸比丘界外为出罪。随其事犯。云何不犯。如比丘作不见摈。恶邪不除摈。是比丘向诸比丘。下意调伏随顺。诸比丘界内为出罪不犯。是故行此羯磨犯不犯。问颇有说羯磨犯。即说此羯磨不犯耶。答有。云何说羯磨犯。如比丘不见摈。恶邪不除摈。是比丘向诸比丘。下意调伏随顺。诸比丘界外与出罪已。共食共住共宿。诸比丘问是比丘言。汝长老。是比丘不见摈。恶邪不除摈。汝等莫与是比丘共食共住共宿。彼答言。是长老比丘下意调伏随顺。我等已界外与出罪。随其事犯。云何不犯。诸比丘摈不见摈。恶邪不除摈。比丘是比丘向诸比丘。下意调伏随顺。诸比丘界内与出罪已。共食共住共宿。诸比丘语是比丘言。此长老比丘不见摈。如上说。诸比丘答言。此长老比丘下意调伏随顺已与出罪。诸比丘问言何处。答言。界内出。界内出罪不犯。是故即说此羯磨犯不犯

问颇有说犯。说不说亦犯耶。答有。云何说犯若比丘于五篇戒。一一犯已自说犯。是名说犯。云何说不说犯。若比丘于五篇戒。一一犯已。或说或不说亦故犯。是故说不说犯

问颇有犯自说犯。他说犯耶。答有。云何自说犯。若比丘于五篇戒中。若一一犯已向他说。是名自说犯。云何他说犯。如诸比丘信可信优婆夷语。如法治比丘。是名他说犯

问颇有忆犯不忆亦犯耶。答有。云何忆犯。若比丘于五篇戒中。一一犯已或都忆或少忆。是名忆犯。云何不忆犯。若比丘于五篇戒。一一犯已都不忆或少不忆是名不忆犯

问颇有现前犯不现前犯耶。答有。云何现前犯。若现在前犯罪。云何不现前犯。谓现前不犯罪

问颇有犯恶邪见罪不共住。即以此事种种不共住耶。答有。如不见摈恶邪不除

问颇有作此羯磨不共住。即作此羯磨种种不共住耶。答有。如前说

问颇有说羯磨不共住。即说此羯磨种种不共住耶。答有。如上广说

问颇有自言不共住。自言种种不共住耶。答有。此事应广说

问颇有犯事僧作羯磨。即以此事众多比丘若二若一得作羯磨耶。答有。云何比丘犯罪僧作羯磨。若比丘尼僧与比丘作。不礼拜羯磨不共语羯磨。不供养羯磨。是名僧作羯磨。众多二一比丘亦如是

问颇有即以此事作苦切羯磨。即以此事作驱出羯磨。即以此事作摈羯磨。折伏羯磨耶。答有。义说得彼三句五句。如修多罗说。不成作苦切异驱出异。摈异折伏异。余三作句亦如是

问颇有犯此事。波罗夷。即犯此事。僧伽婆尸沙耶。答有。若比丘尼摩触身。波罗夷。比丘摩触僧伽婆尸沙

问颇有犯是事。波罗夷。即犯此事。波夜提耶。答有。比丘尼覆藏粗罪。波罗夷。比丘覆藏粗罪。波夜提

问颇有犯是事。得波罗夷。即犯此事。突吉罗耶。答有。若比丘尼随顺摈比丘。得波罗夷。比丘随顺摈比丘。突吉罗

问颇有行此事。犯僧伽婆尸沙。即行此事。犯波夜提耶。答有。若比丘故出精。僧伽婆尸沙。比丘尼故出精。波夜提

问颇有行此事。犯僧伽婆尸沙。即行此事。犯突吉罗耶。答有。若比丘尼劝比丘尼染污心。男子边受衣食等。僧伽婆尸沙。比丘劝犯突吉罗

问颇有行此事。犯波夜提。即行此事。犯波罗提提舍尼耶。答有。若比丘尼索美食。犯波罗提提舍尼。比丘。犯波夜提

问颇有行此事。犯波夜提。即行此事。犯突吉罗耶。答有。若比丘尼净生草上大小便。波夜提。比丘突吉罗

问颇有行此事。污染比丘尼。不得出家。不得受具足戒。即行此事。污染比丘尼。得与出家。得与受具足戒耶。答有。非梵行污染比丘尼。此人不得与出家。不得与受具足戒。身摩触污染比丘尼者。此人得与出家。得与受具足戒

问贼住人不得与出家受具足戒。颇有行此事。得与出家受具足戒耶。答有。若经二三布萨羯磨者。此人不得与出家受具足戒。若经一布萨或不经者。此人应与出家受具足戒

问破僧人不得与出家受具足戒。颇有即行此事。得与出家受具足戒耶。答有。非法想破僧者。不得与出家受具足戒法想破僧者。得与出家受具足戒

问若人杀母不得与出家受具足戒。即行此事。得与出家受具足戒耶。答有。若作母想杀者。不得与出家受具足戒。若作余想杀者。得与出家受具足戒。如杀母杀父阿罗汉亦如是

优波离问佛言。世尊。有善心杀母不善无记心杀母耶。佛语优波离。有善心杀母不善心无记心杀母。云何善心杀母。若母重病莫令久受苦恼故夺命。是名善心杀母。云何不善心杀母。若为财物若为妻子故。故夺母命。是名不善心杀母。云何无记心杀母。或斫树斫壁斫地而误杀母。是名无记心杀母

又复问佛言。善心杀母。得波罗夷得逆罪耶。又复善心杀母。不犯波罗夷不得逆罪耶。佛言有。云何善心杀母。得波罗夷。得逆罪。若母重病如前说。是名善心杀母。得波罗夷。随得逆罪。云何善心杀母。不得波罗夷。不得逆罪。若母病使母服药时。药等因是命终。不犯波罗夷。不得逆罪

又复问佛言。不善心杀母。犯波罗夷。得逆罪。不善心杀母。不得波罗夷不得逆罪耶。佛言有。云何不善心杀母。得波罗夷。得逆罪。若为财物等故如前说。云何不善心杀母。不得波罗夷。不得逆罪。若杀他母羊母鹿母等。是不善心杀母。不得波罗夷。不得逆罪

又复问佛言。无记心杀母。犯波罗夷。得逆罪。无记心杀母。不得波罗夷不得逆罪耶。佛言有。云何无记心杀母。得波罗夷。得逆罪。先作杀母方便眠后母死。得波罗夷。得逆罪。是无记心杀母。得波罗夷。得逆罪。云何无记心杀母。不得波罗夷。不得逆罪。若斫树等如前说。是无记心杀母。不得波罗夷。不得逆罪

又复问佛言。共住净行比丘在界内不和合。僧作羯磨成作羯磨不犯耶。佛言有。如来阿罗呵三藐三佛驮

又问。颇有比丘五种说波罗提木叉。一一说波罗提木叉。作布萨成作布萨耶。答有。谓三语布萨

又问。如佛所说。白衣在僧中僧作布萨。说波罗提木叉。成说波罗提木叉不犯戒耶。答有。瓶沙王因缘此中应广说

问颇有善心犯戒。不善心犯戒。无记心犯戒耶。答有。云何善心犯戒。如新出家比丘未知戒相。自手净地拔生草。若经行处采花髻鬘。此善心犯戒。云何不善心犯戒。佛所结戒故犯。云何无记心犯戒。佛所结戒不故犯

问阿罗汉善心犯戒。不善无记心犯戒耶。答有。若阿罗汉犯戒一切皆无记心犯。云何无记心犯戒。若阿罗汉眠已有人举着高床上。或女人盗入房宿。与未受具戒人二夜宿已后。复盗入宿。是名无记心犯戒

问若破僧一切皆一劫寿耶。若寿一劫皆悉破僧耶。作四句。或破僧非一劫寿。或一劫寿非破僧。或破僧亦一劫寿。或非破僧非一劫寿。云何破僧非一劫寿。若法想破僧。云何一劫寿非破僧。伊罗龙王。善建立龙王。摩那斯龙王。今婆罗龙王。郁多罗龙王。提梨咤龙王。迦罗龙王。难陀龙王。鏂钵难陀龙王。及梵富婆天。此一劫寿非破僧。云何一劫寿亦破僧谓调达。云何非破僧亦非一劫寿。除是句。问破僧不生一劫罪。或生一劫罪。非破僧耶。答有。云何破僧不生一劫罪法想。破僧是法想。破僧不生一劫罪。云何寿一劫罪。非破僧。伊罗龙王等。除梵富楼天。云何破僧亦生一劫罪。谓调达。云何非破僧不生一劫罪。除是句

问若破僧一切皆邪定耶。作四句。云何破僧非邪定法想破僧。云何邪定非破僧。谓杀母杀父阿罗汉。恶心出如来血。是邪定非破僧。云何邪定亦破僧。谓调达。云何非邪定非破僧。除是句

问一切破僧明无明耶。作四句。云何非明非无明法想破僧。云何无明非明非破僧。谓六师等。云何破僧亦明亦无明。谓调达。云何非破僧非明非无明。除是句

又问佛言。世尊。唯比丘破僧非比丘尼式叉摩那沙弥沙弥尼耶。佛语优波离。比丘破僧非比丘尼。非式叉摩那。非沙弥沙弥尼。唯助破僧耳

问唯比丘尼破比丘尼。僧非比丘式叉摩那等。如前说

问破僧成就为罪成就耶。优波离。破僧成就破僧者。成就罪。破僧犯何等罪。谓偷罗遮。破僧已忏悔何等罪。谓僧伽婆尸沙

问若一切受法皆不共住耶。作四句。云何受法非不共住。谓若受五法是受法非不共住。云何不共住非受法。若犯。一一波罗夷罪。不受五法是非受法是不共住。云何受法亦不共住。谓受五法。犯一一波罗夷罪。云何非受法亦非不共住。除是句

问若一切受法皆种种不共住耶。作四句。答有。云何种种不共住非受法。谓不见摈恶邪不除摈

问颇有不共住。即一切种种不共住耶。作四句。种种不共住非不共住。如恶邪不除

问颇有摈羯磨。即堕羯磨耶。答有。摈羯磨即堕羯磨。云何羯磨。云何羯磨事。所起罪是羯磨。忏悔是羯磨事

云何迦絺那。云何受迦絺那。云何舍迦絺那。谓衣是迦絺那。发起九种心。是受迦絺那。八事是舍迦絺那

问颇有取三钱犯波罗夷耶。答有。若迦梨仙直十二钱。问颇有取十钱或取五钱犯波罗夷耶。答有。若迦梨仙直四十钱。或直二十钱

问颇有减与犯减与不犯耶。答有。下白减与犯波夜提。黑减不犯

问颇有增益犯增益不犯耶。答增黑犯波夜提。增白不犯

问颇有等量犯等量不犯耶。答有佛衣等量犯波夜提。身等量不犯

问颇有不作犯作不犯耶。答有。得新衣不三坏色犯波夜提。坏色不犯

问颇有比丘入初禅时。犯偷罗遮。入已犯僧伽婆尸沙耶。答有。若比丘语余比丘言。与我作房。作是语已。入初禅入已房成。犯僧伽婆尸沙。入第二第三第四禅亦如是。或非比丘时。犯比丘时净。或比丘时犯非比丘时净。云何非比丘时犯比丘时净。若比丘尼时犯不共僧伽婆尸沙。彼转根作比丘得净。是非比丘时。犯比丘时净。云何比丘时犯非比丘时净。若比丘犯不共僧伽婆尸沙。彼转根作比丘尼得净

问颇有不知时犯知时净。知时犯不知时净耶。答有。云何不知时犯知时净。若比丘眠熟有人举着高床上。如前说。彼觉已如法除灭。是名不知时犯知时净。云何知时犯不知时净。若比丘犯僧伽婆尸沙。阿浮呵那时闻白已睡眠。眠中羯磨竟。是名知时犯不知时净

问颇有一方便中犯三波罗夷耶。答有。若比丘语彼人言。汝知我说过人法。杀某人盗某重物。是名一方便犯三波罗夷

问颇有比丘尼一方便犯四波罗夷耶。答有。如比丘尼共期。汝见我随顺摈比丘时。杀某人盗某重物。汝知我得罗汉。是名比丘尼一方便犯四波罗夷

问颇有比丘一坐处犯一切五篇戒耶。答有。若比丘学家中自手受佉陀尼蒲阇尼。犯波罗提提舍尼。偏刳食。犯突吉罗。无净人为女说法过五六语。犯波夜提。向女人说粗恶语。犯僧伽婆尸沙。空无所有说过人法。犯波罗夷

问颇有比丘作一方便犯百千罪耶。答有。若比丘嗔恚若沙若豆散掷诸比丘随所著。犯波夜提

问颇有比丘盗取重物离本处不犯波罗夷耶。答有。若取非人重物

问颇有比丘亦未曾犯戒乃至突吉罗是非比丘耶。答有。谓失根者

问颇有比丘尼未曾犯戒乃至突吉罗是非比丘尼耶。答有。谓失根者

问颇有比丘独在房中。犯四波罗夷耶。答有。若比丘男根长自下部作淫。先作盗方便杀生。方便妄语方便我是阿罗汉

问颇有比丘在房中于彼失衣破安居耶。答有。若比丘结坐已。未自恣衣着床上不受七夜在空中明相出时。破安居失衣

问颇有比丘杀比丘尼非母非阿罗汉。犯波罗夷得逆罪耶。答有。若父出家受具足戒。转根作比丘尼

问颇有比丘尼杀比丘非父非阿罗汉。得波罗夷得逆罪耶。答有。母出家受具足戒。转根作比丘

问颇有比丘作非梵行。犯波罗夷。作非梵行不犯波罗夷耶。答有。若生女人女根不坏作淫。犯波罗夷。若坏。不犯波罗夷

问颇有盗犯波罗夷。盗不犯波罗夷耶。答有。若取人重物。犯波罗夷。若取非人重物。不犯波罗夷

问颇有杀人犯波罗夷。杀人不犯波罗夷耶。答有。是人作人想杀。犯波罗夷。若异想杀不犯。欲杀非人而杀人。不犯波罗夷

问颇有比丘说过人法。犯波罗夷。说过人法不犯波罗夷耶。答有。若不异想说过人法。犯波罗夷。若增上慢说。不犯波罗夷

问颇有犯此事得波罗夷。即犯此事不犯波罗夷耶。答有。若比丘尼摩触身。犯波罗夷。比丘摩触。不犯波罗夷。比丘尼随顺摈比丘。波罗夷。比丘随顺。不犯波罗夷。比丘尼覆藏粗罪。波罗夷。比丘覆藏。不犯波罗夷

问颇有犯此事。僧伽婆尸沙。即犯此事。不犯僧伽婆尸沙耶。答有。若比丘故出精。犯僧伽婆尸沙。比丘尼出精。不犯僧伽婆尸沙。比丘摩触身。僧伽婆尸沙。比丘尼不犯僧伽婆尸沙。比丘尼染污心男子边受食等。犯僧伽婆尸沙。比丘不犯僧伽婆尸沙

问颇有犯此事。得波夜提。即犯此事。不犯波夜提耶。答有。若比丘覆藏粗罪。犯波夜提。比丘尼不犯波夜提。若比丘不病索美食。犯波夜提。比丘尼不犯波夜提。若比丘尼于净生草上大小便。犯波夜提。比丘不犯波夜提

问颇有犯此事。犯波罗提提舍尼。而犯此事。不犯波罗提提舍尼耶答有。若比丘尼索美食。犯波罗提提舍尼。比丘不犯波罗提提舍尼

问颇有行此事。犯突吉罗。即行此事。不犯突吉罗耶。答有。比丘净生草上大小便。犯突吉罗。比丘尼不犯突吉罗。比丘尼齐下着衣。犯突吉罗。比丘不犯突吉罗

问颇有比丘犯戒时净净时犯耶。答有。若比丘于女人前说粗恶语转根。是名犯时净。云何净时犯。若比丘犯僧伽婆尸沙。阿浮呵那时舍合掌覆头。身不齐整画地断草。是净时犯

问颇有舍异界得自然界耶。答有。舍羯磨界得聚落界

问颇有余人语余人。得波罗夷。余人语余人。得僧伽婆尸沙耶。答有。若比丘作破僧方便污他家。乃至三谏不舍得僧伽婆尸沙

问颇有余人语余人得波夜提耶。答有若比丘恶邪见乃至三谏不止。犯波夜提

问颇有余人语余人。犯波罗提提舍尼耶。答有。比丘尼为比丘索食。犯波罗提提舍尼

问颇有余人作语余人。犯突吉罗耶。答有。如佛所说。若比丘半月半月说波罗提木叉时忆有罪不发露。得突吉罗

问如佛所说无有比丘尼舍戒。更得出家受具足戒。颇有比丘尼舍戒。更得出家受具足戒耶。答有。若比丘尼。舍戒已转根作男子。更与出家受具足戒。成出家得具足戒

如佛所说。犯边罪人不得与出家。不得与受具足戒。颇有犯边罪得与出家。得与受具足戒。成出家得具足戒耶。答有。若比丘尼犯不共波罗夷罪。彼舍戒转根成男子。得与出家受具足戒。成出家得具足戒。优波离问佛言。世尊。有几种羯磨。佛语优波离。有百一种羯磨。又问。几白羯磨。几白二羯磨。几白四羯磨。答二十四白羯磨。四十七白二羯磨。三十白四羯磨。又问。此百一羯磨。几有欲几无欲。答除结界羯磨。余者皆有与欲

又问。几羯磨摄一切羯磨耶。答三羯磨摄一切羯磨。谓白羯磨白二白四羯磨

又问。余人不语亦不作身方便。而犯波罗夷耶。答有。比丘尼见比丘尼犯粗罪覆藏不发露。得波罗夷

问颇有犯四篇戒不发露忏悔而得清净耶。答有。若比丘犯不共四篇戒。彼转根作比丘尼。即得清净

又问。颇有比丘尼犯五篇戒。不发露忏悔而得清净耶。答有。若比丘尼犯不共五篇戒。彼转根作比丘。即得清净

又问。颇有比丘杀人不犯波罗夷耶。答有。二人共一处欲杀此人而杀彼人

又问。颇有余人作淫余人。得波罗夷耶。答有。若比丘尼见比丘尼作淫覆藏不发露。明相出得波罗夷

问颇有比丘行时犯五篇戒耶。答有。若比丘到学家中自手受食。犯波罗提提舍尼。偏刳食犯。突吉罗。无净人为女说法过五六语。犯波夜提。于女人前粗恶语。犯僧伽婆尸沙。空无所有说过人法。犯波罗夷

又问。若有人非律说律者何处求。戒相。答二波罗提木叉中十七事。毗尼事中。增一中目多伽。因缘中共不共。毗尼中结。戒中结。地中空。行中转。根中求

问颇有不离一切趣趣所系不。于胜法中出家。复不尽漏而取无余般涅槃耶。答有。谓化人杀彼。得何罪。答偷罗遮。佛所说毗尼众分事竟

    问四波罗夷初

佛住舍卫国祇树给孤独园。尔时优波离问佛言。世尊。有比丘以咒术仙药化作畜生。已共作淫。得何罪。答若自知比丘想。我是比丘作不可事者。犯波罗夷。若不自知比丘想。犯偷罗遮。又问。若比丘咒术仙药。化作畜生女已共作淫。犯何罪。答若自知比丘想。犯波罗夷。若不自知比丘想偷罗遮。二比丘咒术仙药化作畜生共作淫。得何罪。答若自知比丘想犯波罗夷。不自知比丘想。偷罗遮。非人女亦如是。云何非人女边作淫。犯波罗夷。谓举身可捉畜生女亦如是。若不可捉共作淫。若精出。犯僧伽婆尸沙。不出犯偷罗遮。云何口中作淫。犯波罗夷。答若过节犯波罗夷。不过偷罗遮。若中破裂三疮门不坏。犯波罗夷。若头断从咽喉处入。偷罗遮。若精出。犯僧伽婆尸沙

云何疮门坏。答若疮门周匝坏于彼作淫。偷罗遮。精出僧伽婆尸沙。云何大便道作淫。犯波罗夷耶。答为过皮至节。小便道亦如是。不触三疮门边入。偷罗遮。云何女人疮门坏。答若一切坏半坏入。偷罗遮。精出僧伽婆尸沙。女人中截虫不啖不烧三疮门不坏入。犯波罗夷。若多虫啖若烧入。偷罗遮。精出僧伽婆尸沙。生女亦如是。生女女根半坏入。波罗夷。无毛熟母猪边作淫入。偷罗遮。精出僧伽婆尸沙。颇有比丘独在房中。犯波罗夷耶。答有。男根长自口及大便道作淫。若蚊幮为拈作淫。波罗夷

问颇有比丘小便中作淫。不犯波罗夷耶。答有。截已作淫或截女根已作淫。或俱截作淫。偷罗遮

问颇有比丘于小便道小便道入不犯耶。答入小便器中

问颇有比丘俱有拈作淫。不犯波罗夷耶。答有。鼻中作淫。又以厚衣缠之。或以筒盛作淫。偷罗遮。精出僧伽婆尸沙

问颇有比丘于女人边作淫。不犯波罗夷耶。答有。初作者于二根边作淫。波罗夷。石女边作淫根小不入。偷罗遮。精出僧伽婆尸沙

云何受乐受乐有何义。答若身心得乐是受乐义。本犯戒人作淫。得突吉罗问初波罗夷事竟

佛住王舍城。尔时尊者优波离问佛言。世尊。若比丘自作二四十人数取分。云何如法云何非法。答前者如法后者非法。得何罪。答若事办物满五钱。波罗夷。不满偷罗遮。自当二八十人数亦如是

问颇有比丘余人作语移物着处处。犯波罗夷耶。答有。谓移棋子着余处。犯波罗夷。若商客语比丘汝等不输税当度我输税物。若比丘度税物过税处事满。波罗夷。未过税处。偷罗遮。若使诸商人余道去。彼诸商人不从税道去过税处。偷罗遮。若比丘先不知余比丘。于针囊中盗着税物过囊主不犯。著者事满。波罗夷。不满偷罗遮。若比丘语无腊比丘言。担是物去。犯偷罗遮。过税处。满波罗夷。无腊比丘不问突吉罗。空中度税物从税处度。偷罗遮。余处度不犯。若比丘持不可量物度税处。满波罗夷。若自度己物过税处满。波罗夷。若未受具戒时作方便。未受具戒时取突吉罗。未受具戒时作方便。受具戒时取突吉罗。未受具戒时作方便。受具戒已取偷罗遮。九句亦如是广说。若比丘取衣架满五钱。犯波罗夷。不满偷罗遮

颇有比丘偷金鬘。不犯波罗夷耶。答有。若取天龙鬼神鬘。若比丘欲取衣架。合衣持去。当数衣架。满波罗夷。不满偷罗遮。若衣离架若满波罗夷。不满偷罗遮。若比丘使比丘为余人故取物。彼起盗心取。俱得波罗夷。若比丘他不使盗而为他盗取。偷罗遮。若比丘欲取劫贝衣。而取刍麻衣。偷罗遮。展转取亦如是。若比丘语比丘于七种衣中。使取一一衣。彼起盗心而自取。波罗夷。示彼而取。偷罗遮。疑心取。偷罗遮。如佛所说。若取五钱。犯波罗夷。取何等五钱。犯波罗夷耶。答二十钱。云何钱。谓迦呵那一迦梨仙直四迦呵那。云何满。谓相言诤

问颇有比丘取物不离本处。而犯波罗夷耶。答有。谓田宅等若比丘取树上果。满波罗夷。不满偷罗遮。若取瞿耶尼物得何罪。答若用此间迦梨仙。满波罗夷。不用此间迦梨仙者。偷罗遮。问颇有比丘偷铜钱。犯波罗夷耶。答有。若迦梨仙直二十铜钱。若有比丘破仓取谷。当取初方便。若满波罗夷。不满偷罗遮。若比丘取众多物。波罗夷

问颇有比丘取金像。不犯波罗夷耶答有。若不直五钱。偷罗遮。金鬘亦如是。问颇有比丘取水器。犯波罗夷耶。答有若直五钱。若比丘取金金未坏相当数直。若满波罗夷。不满偷罗遮。若比丘贷物言不贷故妄语。波夜提。不还偷罗遮。若比丘受他寄索时言不受故妄语。波夜提。物离本处。满波罗夷。若主听。偷罗遮。若比丘取迦梨仙。若满犯波罗夷。不满偷罗遮。若比丘取减五钱物。偷罗遮。贼住偷盗。犯突吉罗。若经羯磨白二白四羯磨者。犯本犯戒人偷盗。突吉罗。学戒人偷盗。突吉罗。本不和合人偷盗。犯突吉罗。云何离处若物在本处移着余处。问颇有比丘。白四羯磨受具足戒。四波罗夷中一一不犯而非比丘耶。答生二根。问第二波罗夷事竟

问若比丘咒术仙药咒他作畜生而杀犯波罗夷颇有比丘杀母。不犯波罗夷不得逆罪耶。答有。欲杀余人而杀母。犯偷罗遮。欲杀母。而杀他。偷罗遮。二人没水中欲杀此人而杀彼人。犯偷罗遮。欲杀凡夫而杀阿罗汉。偷罗遮。不得逆罪。欲杀阿罗汉而杀凡夫。偷罗遮。欲杀阿罗汉而杀阿罗汉。犯波罗夷。得逆罪。若比丘堕胎得波罗夷。问余母人堕胎。余母人取饮。后生儿余女人养杀何等母。得波罗夷得逆罪耶。答堕胎者欲出家时。当问何者谓养者

问颇有比丘堕畜生胎。犯波罗夷耶。答有。谓畜生怀人胎者

问若比丘堕人胎。不犯波罗夷耶。答有。谓人怀畜生胎者。若使人高处掷下入水火等。当得安隐。彼即自掷入水火等死者。得波罗夷。欲杀母而杀父。偷罗遮。不得逆罪。欲杀父而杀母。得偷罗遮。第三波罗夷

若比丘言。我于四沙门果退。波罗夷。我已得复失不说沙门果。偷罗遮。若言得四沙门果而失。犯波罗夷。若言我是学人意在工巧。偷罗遮。若三沙门果中说一一果。犯波罗夷。若言我无所有无贪欲嗔恚。犯波罗夷。于今是最后生。犯波罗夷。如我相似余人。问言。有何相似。答言。得圣法。犯波罗夷。若比丘到居士家言。谁语汝我是阿罗汉不实语故。偷罗遮。比丘到居士家言。汝得大利。我出入汝家。彼问言。长老。有何等利。答自说圣法。得波罗夷。若比丘语施主。受用汝房者。是阿罗汉。我非阿罗汉。犯偷罗遮。如是衣钵荐席卧具等。偷罗遮。若比丘言。某处敷种种卧具者。彼比丘是须陀洹。乃至阿罗汉。我亦在彼波罗夷。若比丘言。我不堕地狱饿鬼畜生。偷罗遮。若说四沙门果。犯波罗夷。若比丘言我已离结使烦恼。波罗夷。比丘言于声闻所得我已得。波罗夷。我修五根。波罗夷。五力七觉八道亦如是。我于初禅退。波罗夷。乃至次第逆顺修禅亦如是。某卧处起初禅不与觉道支相应。偷罗遮。欲作经语而说圣法。偷罗遮。我于施无所有。偷罗遮。我是佛。偷罗遮。我是天人师。偷罗遮。我是毗婆尸佛弟子。波罗夷。我得果波罗夷。于聋所说过人法。偷罗遮。哑人所聋哑人所入定人所说。偷罗遮。先犯戒人说过人法。突吉罗。学戒人贼住本不和合人等。说过人法亦如是。我修慈悲喜舍故妄语。波罗夷。手印标相。偷罗遮。说四波罗夷竟

萨婆多部毗尼摩得勒伽卷第一萨婆多部毗尼摩得勒伽卷第二

        宋元嘉年僧伽跋摩译

    问十三僧伽婆尸沙初

眠中作方便眠中精出不犯。觉时作方便眠中出。偷罗遮。作方便已舍置。偷罗遮。甲坐舍方便。偷罗遮。未受具戒时作方便受具戒竟精出。偷罗遮。受具戒时作方便。受具戒时精出。僧伽婆尸沙。受具戒时作方便。白衣时出。偷罗遮。从何处与别住。从初根本所犯。云何出精。谓出至节。云何知作心次第精出。是名知。或比丘时犯非比丘时净。或非比丘时犯。比丘时净。或比丘时犯比丘时净。或非比丘时犯非比丘时净。云何比丘时犯非比丘时净。谓转根是比丘时犯非比丘时净。云何非比丘时犯比丘时净。谓转根。云何比丘时犯比丘时净若比丘犯僧伽婆尸沙。如法除灭。是名比丘时犯比丘时净。云何非比丘时犯非比丘时净。谓比丘尼。犯僧伽婆尸沙。如法除灭。是非比丘时犯非比丘时净。眠中作方便觉时精出。若知偷罗遮。不知不犯。若男根起逆水行。偷罗遮。若出节精。偷罗遮。握搦捋弄精不出。偷罗遮。与药不出。偷罗遮。疑触女人。偷罗遮。触于齿。偷罗遮。触无肉淳骨。偷罗遮。于余女人染污心触余女人。偷罗遮。触二根人意在女想者。僧伽婆尸沙。意在男想。偷罗遮。共女人相摩触。僧伽婆尸沙。共黄门相摩触。偷罗遮。共男子相摩触身。偷罗遮。为细滑暖等因缘故摩触女人身。偷罗遮。摩触母身爱母故不犯。为细滑等摩触。偷罗遮。姊妹亦如是

为他故粗恶语。偷罗遮。遣使语。偷罗遮。不犯二十一句亦如是。自赞叹身亦如是

若法非过去现在未来而颠倒。此法以十利故。制彼法。云何答曰。谓媒嫁持自在语。至非自在所。偷罗遮。云何自在。若于眠食戏笑。自在于彼行媒嫁。偷罗遮。买是女作妇。偷罗遮。胎中媒嫁。偷罗遮。斗诤中夺女人。偷罗遮。无子所媒嫁。偷罗遮。黄门所媒嫁。偷罗遮。自媒嫁。偷罗遮。如是人男非人男于彼媒嫁。偷罗遮。人男非人女。偷罗遮。俱非人。偷罗遮。媒嫁梵行人。偷罗遮。媒嫁处男子转根成女人。女人转根成男子。偷罗遮。本犯戒人。偷罗遮。学戒人偷罗遮

乞房已不作。偷罗遮。问颇有比丘自作房。不从僧乞不犯耶。答有。谓蚊蟵。问颇有比丘自乞作房不犯耶。答有。谓他房他作为成。偷罗遮

二人共作。偷罗遮。十人共乞作一房十人。各犯僧伽婆尸沙。物不现前而作房。偷罗遮不舍房而作。偷罗遮。远处作房。偷罗遮。云何自乞房若得物。若未有直作大房亦如是。云何乞房众僧和合作羯磨。自物作房。偷罗遮。手印谤比丘。偷罗遮。遣使亦如是。谤本犯戒人。偷罗遮。谤学戒人。偷罗遮。谤沙弥。突吉罗

若比丘僧中作不定语。比丘作淫。偷五钱杀人说过人法。而不说其名。偷罗遮。手印相亦如是。若比丘从坐起而作是言。我无所因而说。于一切众僧边得突吉罗。若比丘以是事谤比丘尼。偷罗遮。比丘尼以是事谤比丘。偷罗遮。何以故。共戒故谤式叉摩那沙弥沙弥尼。突吉罗。非比丘非沙门。非释子不精进恶沙门。乃至少因缘。皆犯偷罗遮。即以此事比丘谤比丘。偷罗遮。谤式叉摩那沙弥沙弥尼。突吉罗。展转如轮谤亦如是。难事谤比丘。突吉罗。谤比丘比丘尼。式叉摩那。沙弥沙弥尼。展转如轮除四波罗夷。以余者谤。突吉罗。少片亦如是。不乞听摈。比丘成摈不答不成摈。诸比丘犯突吉罗

颇有比丘不乞听。而摈比丘成摈耶。答有。众僧一时共摈。颇有比丘不乞听。而众僧中摈比丘成摈耶。答有。先已听不白。以不解人作羯磨。成羯磨不。答成。诸比丘犯突吉罗。不语彼而摈比丘。成摈不。答成摈。诸比丘犯突吉罗。不使忆念亦如是。不作白羯磨。摈比丘。成摈不。答成。诸比丘犯突吉罗。不现前亦如是。不受法比丘摈不受法比丘。成摈不。答成摈。诸比丘犯突吉罗。受法比丘摈不受法比丘不受法比丘摈受法比丘。亦如是。若比丘语诸比丘。我是受法比丘而摈是比丘成摈不。答非法自言不成摈。受法比丘自言得成摈。问颇有比丘为四人作羯磨而不犯耶。答有。若坐大床小床与五人受大戒。若十五人亦如是。如佛所说。众不得羯磨。众颇有得羯磨众耶。答有。若坐大床小床如前说。在空中地人作羯磨。成羯磨不。答不成。诸比丘得呵罪。人在地空中作羯磨。亦如是。界内界外亦如是。余四乃至恶性随事分别。云何不清净清净相。若比丘犯波罗夷。而威仪清净。是不清净清净相。云何清净不清净相。持戒不犯威仪不清净。云何清净清净相。而不犯戒威仪清净。云何不清净不清净相。若比丘犯波罗夷。僧伽婆尸沙。威仪不清净。僧伽婆尸沙竟

    问二不定法

如世尊所说。信可信优婆夷语。治比丘为信一切可信优婆夷语治比丘耶。答应问可信优婆夷言。姊妹。此比丘在彼不。答言在。彼应用可信优婆夷语治是比丘。可信优婆夷言。我见非时食。比丘言。我食酥蜜。应用可信优婆夷语治是比丘。亦应令是比丘自言。可信优婆夷言。我见是比丘饮酒。比丘言。我饮蜜浆酥毗罗浆。应用是可信优婆夷语治。亦应令是比丘自言。可信优婆夷言。我见某甲比丘作淫比丘言。我髀中作淫。应用是可信优婆夷语治。亦应令是比丘自言。可信优婆夷言。我见某甲比丘共畜生作淫。比丘答言。实作身外分作。应用是可信优婆夷语治。亦应令是比丘自言。龙女天女人女夜叉女亦如是。可信优婆夷言。我见是比丘共某甲女人作淫。比丘言。我以余因缘故到彼。不应用是可信优婆夷语。可信优婆夷言。我见某甲比丘共某甲女人作淫。女人立比丘坐。不应用是优婆夷语治是比丘。四威仪中亦如是。第二戒如摩触身戒。若比丘于是一一事中不说。不应用是优婆夷语治是比丘

    问三十事初

问颇有比丘过十夜衣不犯尼萨耆耶。答有。若烧若失

问颇有比丘过十夜衣不犯尼萨耆耶。答有。用水衣作衣。毛衣不净衣亦如是

颇有比丘尽寿畜长衣不犯尼萨耆耶。答有。十夜内无常

颇有比丘二十年畜长衣不净施不犯耶。答有。若狂若心散乱。若苦病痴騃者

问颇有比丘过十夜衣即此衣一夜离宿耶。答有。过十夜已作衣受出界外明相出

颇有比丘即日得衣即日尼萨耆耶。答有。频日得衣。先尼萨耆罪。未忏悔离衣宿已。不受三衣。过十夜。尼萨耆。尼师檀离宿不犯尼萨耆耶。答三衣佛所说不得离宿。尼师檀或得离宿。或不得。尼师檀非一夜离宿衣

如世尊所说。瞻病衣过十夜。尼萨耆。手巾漉水囊卧具褥受持不犯。若不受持者。舍已更受随意用

云何打衣。若新衣未经四月受用。是不得打衣。云何得打衣。时衣四月为时以经四月受用。是名得打衣。三衣不得同意取。取者恶取。犯突吉罗

众僧界外道界共一界内一门离衣宿。若在门下宿。不犯

颇有比丘外道处着衣僧界内宿不犯耶。答有。外道共同一界。树界亦如是

颇有比丘四处着衣余处宿不犯耶。答有。若着卧床坐床上。随其事亦如是。若不持三衣行。应更受余衣

如佛所说一月衣云何受。一月衣谓三衣不足。若三衣满足。不得畜一月衣。若不满三衣。悕望一月。必得者应畜。若不得者。即应裁割受持。得以不裁截受持。尼萨耆波夜提。如频日得衣

问颇有比丘使非亲里比丘尼浣衣不犯耶。答有。谓浣新衣

颇有比丘非母亲非父亲使比丘尼浣衣不犯耶。答有。谓母也。已浣更使浣。突吉罗。遣使展转手印。浣浣尼萨耆。衣众僧衣不净衣使贼住浣。本不和合。本犯戒。式叉摩那沙弥尼皆不犯尼萨耆。犯突吉罗

问颇有比丘于非母亲比丘尼所受衣不犯耶。答有。谓母贼住人边受衣。不犯尼萨耆。犯突吉罗。若比丘尼放地言。寄大德。我听随意用。我当得功德。比丘受用不犯。使人取。突吉罗。遣使手印取衣。一切皆突吉罗。若比丘尼以衣着地默然去。比丘同意受用。不犯。又言。受用与我直不犯。暂时借用不犯。式叉摩那沙弥尼亦如是。若言某聚落中有衣。与大德往取。犯突吉罗。若默然心受。后同意取用不犯。若比丘言。我等不得取非亲里比丘尼衣。彼默然着地而去。后同意用。不犯

颇有比丘取母衣犯尼萨耆耶。答有。若取异物

问颇有比丘着衣入白衣舍衣不离身即尼萨耆耶。答有。若泥土所污比丘尼拂拭去。若比丘使非亲里比丘尼浣尼师檀。尼萨耆波夜提。浣褥。突吉罗。浣枕等。突吉罗。云何浣。乃至三入水

问颇有比丘从非亲里居士居士妇乞衣不犯耶。答有。若为僧乞二根边乞。不犯

颇有比丘居士居士妇边乞衣不犯耶。答有。谓父母也。乞房衣雨衣不犯。学戒人乞。突吉罗。乞不净衣。突吉罗。乞劫贝头沙。突吉罗。受具戒时乞。受具戒时得。作四句。若居士转根作女人不犯。居士妇比丘转根作比丘尼。亦如是。遣使乞。突吉罗。手印相亦如是。从非人畜生天边乞衣不犯。为沙弥作衣。比丘往乞。突吉罗。为众多比丘作衣。一比丘往乞。突吉罗。居士时为作衣出家已往索突吉罗。受具戒时为作衣。受具戒已索。得突吉罗。是衣应舍。若夜叉边索。天龙所一切外道所索不犯。遣使手印索。突吉罗

非人与直。非人为使。非人为檀越。不犯。非人与直。非人为使。人为檀越。不犯。非人与直。人为使。人为檀越。不犯。人与直。人为使。人为檀越。不犯。从龙索物。不犯

颇有比丘新憍舍耶作尼师檀不犯尼萨耆耶。答有。若瞿那杂作。突吉罗。若劫贝杂作。突吉罗。头鸠罗杂作。突吉罗(头鸠罗者纻也)若发若毛杂作。突吉罗。佛衣作尼师檀。突吉罗。遣使手印作。突吉罗

颇有比丘新憍舍耶杂作敷具不犯尼萨耆耶。答有。不自作纯黑作者。自作亦如是。云何犯罪。若成已敷眠

颇有比丘作敷具犯四波夜提耶。答有。若等修伽陀量不满六年。非亲里比丘尼浣过十夜。减与白及不净。突吉罗

颇有比丘不满六年作敷具不犯耶答有。六年内罢道还复受戒。狂痴亦如是

颇有比丘六年内作敷具不犯耶。答有。六年内转根为女人者

颇有比丘六年内作敷具不犯耶。答有。谓僧羯磨憍舍耶亦如是(亦如是者前新憍舍耶敷具僧羯磨作不犯)为他作。突吉罗

颇有比丘取僧伽梨犯突吉罗耶。答有。若杂金缕作银缕金宝缕作亦如是。若着前地不受用。若受金想。尼萨耆。若在远处使人取。突吉罗

颇有母边取物尼萨耆耶。答有。若贸易余物

颇有比丘种种贩卖不犯耶。答有。使未受具戒人是也。卖买一切亦如是。若未受具戒人卖买。不犯。若不如法卖买。突吉罗。共非人贩卖。突吉罗。共天龙夜叉乾闼婆一切非人卖买。突吉罗。共亲里卖买。突吉罗。狂心散乱心苦痛心卖买。突吉罗。本犯戒。本不和合。贼住黄门。污染比丘尼所贩卖。皆突吉罗。学戒人卖买。突吉罗。未受具戒时用银卖物。未受具戒时。得突吉罗。如是作七句。狂心散乱心者。不犯

颇有比丘畜过十夜钵不犯耶。答有。十夜内狂若心散乱

颇有比丘终身畜长钵不犯耶。答有。以僧中舍已悔过

颇有比丘有一钵即此一钵尼萨耆耶。答有。谓不受持

颇有比丘有钵更乞余钵终身不净施不犯耶。答有。谓小钵

问颇有乞得钵舍时不犯尼萨耆耶。答有。与欲人满众舍小钵。犯突吉罗。此钵不成舍使他行小钵突吉罗。遣使手印。突吉罗

颇有比丘频日乞钵不犯耶。答有。若易得十夜内

颇有比丘减五缀钵更乞新钵不犯耶。答有。二人乞一钵。三人乞一钵。不犯尼萨耆。犯突吉罗

颇有比丘终身畜长钵不犯耶。答有。谓已僧中舍钵

颇有比丘自乞缕使织不犯尼萨耆波夜提耶。答有。乞不净缕使织作衣。犯突吉罗。狂心乞缕。突吉罗。为僧乞不犯。手印遣使乞。突吉罗。若四若五乃至乞一缕遣使手印乞。突吉罗

为比丘织衣。比丘往不语。突吉罗。若语若不净缕杂织。突吉罗。为比丘作。比丘不语。不犯。黄门织衣。比丘语彼。突吉罗。二根亦如是

颇有比丘嗔恚心夺比丘衣不犯耶。答有。谓夺不净衣。夺本犯戒学戒贼住本不和合沙弥。突吉罗。遣使手印夺。突吉罗。夺减量衣。突吉罗。若夺衣人转根作女人。突吉罗。与衣者转根亦如是

问颇有比丘过六夜离衣宿不受持余衣不犯耶。答有。八难中一一难起。若无余衣三衣中安居。后一月得离衣宿。过是离宿尼。萨耆

不净衣作雨衣。突吉罗。劫波涂沙作雨衣。突吉罗。若比丘自恣已至余住处。彼处未自恣。随彼畜雨衣。波夜提。若比丘畜长衣不舍。尼萨耆波夜提耶。答有。若比丘自恣已至余住处。彼处未自恣。随彼畜。雨衣波夜提。不从初受作雨衣。尼萨耆波夜提

颇有比丘从母边取衣尼萨耆波夜提耶。答有。僧衣回向已。尼萨耆。时药七日药亦如是

颇有比丘与僧衣回向已不犯耶。答有。若界外犯。突吉罗。与第二第三人亦如是。若僧界内不和合分衣。突吉罗

颇有比丘时药作非时药七日药终身药耶。答有。甘蔗时药汁。作非时药。作糖七日药。烧作灰终身药。胡麻亦如是。肉是时药煎取膏。七日乐烧作灰。终身药若七日药在不净地。不经宿不受持。得七日。受不答得受。终身药亦如是。若净膏漉已合油煎。得七日服。若比丘舍七日药。还作七日食。广说随其事。余比丘亦得七日食。随其事不犯。若灌鼻若灌耳。若摩足受持。不犯

    问九十事初

居士问比丘言。汝是谁耶。比丘答言。我是外道。舍戒不。答不舍戒。故妄语。波夜提

居士问比丘言。汝是谁耶。答是居士。舍戒不。答不舍戒。故妄语。波夜提

指余人为和上舍戒不。答不舍戒。故妄语。波夜提

比丘语比丘言。汝是剃师。故妄语波夜提。有比丘颠倒说与和上某甲阿阇梨某甲。乞彼随语与物。故妄语波夜提。数数称名乞。波夜提不闻言闻。波夜提。闻言不闻。波夜提。手印相。皆突吉罗。手作相口不语。突吉罗。语人言眼瞎彼实不瞎。得二波夜提。故妄语毁呰语波夜提。聋盲喑哑亦如是。汝发创彼非发创。故妄语。波夜提。一切工巧亦如是。共期不去。故妄语。波夜提。比丘言。汝是婆罗门出家而作剃师耶。故妄语波夜提。刹利出家亦如是

若比丘行时以天眼出比丘罪。成出罪不。答不成出罪。天眼非事故坐亦如是。若比丘僧中出比丘罪。成出罪不。答不成出罪。比丘犯突吉罗。不先语故毁呰贼住人突吉罗。先不和合学戒污染比丘尼亦如是。毁呰式叉摩那沙弥沙弥尼。皆突吉罗。遣使手印。突吉罗。比丘语比丘。汝是婆罗门种。比丘尼语比丘。汝作下贱业作剃师。得二波夜提。故妄语毁呰语。刹利种亦如是。传他毁呰语。突吉罗。用天耳闻两舌。突吉罗。僧中乞作两舌。波夜提。贼住本不和合遣使手印。突吉罗。比丘两舌。波夜提。比丘尼式叉摩那沙弥沙弥尼边两舌。突吉罗。比丘尼比丘边两舌。突吉罗。式叉摩那沙弥沙弥尼边两舌。突吉罗

已灭贼住人罪。更发起本不和合本犯戒。突吉罗。遣使手印发起。突吉罗。灭比丘尼罪已更发起。突吉罗。灭式叉摩那沙弥沙弥尼罪已更发起。突吉罗

为眠母人说法。突吉罗。净人眠说法。突吉罗。郁单越人为净人。痴人为净人。聋人为净人。哑人为净人。边地人为净人说法。突吉罗。为黄门说法。突吉罗。为二根说法。突吉罗。遣使手印。突吉罗。若有不净人为净人。得为女人说法不。答不得。何以故。佛说言净人故为说咒愿不犯。盲人为净人为女说法。众多哑人为净人。为女说法。突吉罗。五众为净人说法不犯。不狂为净人不犯。无净人得与受八支斋戒不犯。授经不犯。问答诵经。皆不犯。颇有比丘共未受具戒人并诵偈句法不犯波夜提耶。答有。共畜生天龙鬼神等。突吉罗。共沙弥沙弥尼等。突吉罗。遣使手印。突吉罗

问。何以故。波罗夷僧伽婆尸沙罪。向未受具戒人说波夜提耶。答此二戒聚摄粗恶罪。以是故。向他说波夜提

颇有向未受具戒人说过人法不犯波夜提耶答有。若向式叉摩那沙弥沙弥尼说。突吉罗。手印。突吉罗。向见谛人说正见人说。不犯。向狂人散乱心人重病人说。突吉罗。不犯有二十一句。五众展转相向说。突吉罗。向贼住人本不和合学戒人说。遣使手印说。突吉罗。若比丘回僧物与比丘尼僧。突吉罗。手印回向。突吉罗

比丘尼言。何用半月半月说是杂碎戒。突吉罗

问颇有比丘呵说杂碎戒不犯耶。答无也。除二十一句。不犯

颇有比丘断草不犯波夜提耶。答有。谓剃发。若比丘以灰土覆生草。若沙及余方便。突吉罗。若语人取。是果我欲食。突吉罗。若生果未净全咽。突吉罗。取木耳。突吉罗。本不和合学戒人取。突吉罗

若比丘为他骂。突吉罗。骂畜生。突吉罗。传骂。突吉罗

问余事说余事。突吉罗。默然恼他。突吉罗。闻言不忆。突吉罗

颇有比丘坐卧床着露地不自举不使人举不犯耶。答有。谓宝床

颇有比丘露地敷卧具去时不自举不使人举不犯耶。答有。若不净物杂作。突吉罗。若在覆处。若白衣所摄。去时不举不犯。先取者应举。若贼住比丘敷卧具。去时不自举。不使人举。突吉罗。本不和合学戒人不举。突吉罗。若比丘自卧具不自举。不使人举。突吉罗。五众亦如是

颇有比丘僧卧具不自举不使人举不犯耶。答有。若白衣舍坐不举。或人所夺不犯。近经行不犯。暂时坐起去不自举。不使人举。突吉罗。众僧卧具力势者所夺。随意坐不犯。除卧床坐床。余长木长板等随意坐。不犯。若比丘不嘱卧具。出行中道见比丘语言。与我举坐床卧床。彼受嘱已不举。突吉罗。若比丘卧具欲内房中。户闭者当云何。答应着壁下墙下树下。雨所不坏处

房舍内敷卧具戒亦如是

颇有比丘驱出比丘不犯波夜提耶。答有。若一切众僧驱一比丘。突吉罗。彼何等人耶。谓贼住驱本犯戒。本不和合学戒人沙弥等出。突吉罗。遣使手印及私房驱出。突吉罗。若露地驱出。突吉罗。驱出饿鬼等。突吉罗

颇有比丘知先比丘敷卧具竟后来强以卧具自敷使人敷不犯波夜提耶。答有。谓贼住本犯戒本不和合学戒沙弥突吉罗

颇有比丘不楔床脚于上坐卧不犯波夜提耶。答有。贼住寺中本犯戒。本不和合寺中比丘尼。寺中除比丘寺。余四众寺。突吉罗。外道寺中。突吉罗

颇有比丘以有虫水浇草土不犯波夜提耶。答有。若遣使手印。突吉罗。以乳酥酪浇草土中虫。突吉罗

颇有比丘过二三覆屋不犯波夜提耶。答有。若手印遣使。突吉罗。使黄门覆。突吉罗

云何大房。谓私房是名大房。或有主名大房。云何教诫比丘尼。答若说八重法。是名教诫比丘尼。受法比丘教诫不受法比丘尼。突吉罗。与上相违亦如是。教诫贼住比丘尼。突吉罗。本犯戒本不和合学戒比丘尼。突吉罗。教诫比丘尼比丘余处亦得教诫。为更作羯磨耶。不作耶。佛言。先已作竟。但应教诫。不须更作。若僧不差。比丘教诫比丘尼。不犯耶。答有。先已差。若有一比丘处。比丘尼应往求教诫不。答应求教诫。二三亦如是

颇有比丘日没时教诫比丘尼不犯波夜提耶。答有。若比丘尼寺中聚落中近聚落寺中白衣家不犯。聚落外犯

颇有比丘施非母亲衣不犯耶。答有。谓母作二十一句。施本犯戒比丘尼衣。突吉罗。贼住本不和合学戒比丘尼。突吉罗

如佛所说。若比丘言诸比丘。为供养利故。教化比丘尼。得波夜提

颇有比丘作如是语不犯波夜提耶。答有。非人出家作比丘尼。突吉罗。非人者。天龙夜叉乾闼婆阿修罗紧那罗摩睺罗伽人非人毗舍遮鸠槃茶等。出家作比丘尼是也

有比丘共比丘尼期空中行。突吉罗。隐身共行。突吉罗。未受具戒时期。受具戒已去。突吉罗。受具戒时期。白衣时去。突吉罗。比丘空中行。比丘尼地行。突吉罗

有比丘共天女屏覆处坐。若彼可捉者。突吉罗

共比丘尼独屏覆处坐亦如是

颇有比丘比丘尼赞叹得食不犯耶。答有。若为余者赞叹。余者食不犯

有比丘先受居士请。后比丘尼赞叹言。请某甲。某甲比丘。檀越答言。已请食者。不犯。净施比丘尼食者。不犯。净施式叉摩那沙弥沙弥尼食者。不犯。不知比丘尼赞叹食者。不犯

颇有比丘处处受请食不犯耶。答有。先为他作净施受。若病食者。不犯。处处受亲里食。不犯。若比丘受请食。即于坐处。余处与食。作意不受食者。不犯。若比丘受请。有人言。大德。更当有食。我不请大德食者。不犯。比丘受二种请。谓佉陀尼。蒲阇尼。而不净施。食者不犯。比丘先受请已。有人言。大德。忆念我有食。我不请大德食者。不犯比丘。先受请已。有人言。大德。我有随病食。我不请大德食者。不犯

颇有比丘受二处请不净施不犯耶。答有。若非正食。有比丘受请已。有人言。大德。来到我舍。我不请大德食者。不犯。坐中谓彼先未受请食者。不犯。一坐处更有余人请食者。不犯。常请食者。不犯。慈愍故受食者。不犯。长食食者。不犯(长食者谓白衣舍早起作食熟未食先留出家人分名为长食食此食者不犯)二人食一人并取合行食者。不犯。不净食手印受。突吉罗。或狂人来请。疑故更受余请。不犯。狂比丘受请食净施。受法比丘食者。不犯。作二十一句。居士语比丘言。长老受我请。彼比丘不净施食者。突吉罗

颇有一处受二家请食不犯耶。答有。谓龙宫食天祠食外道食

颇有比丘受二三钵食不犯耶。答有。外道家天祠夜叉祠不犯。手印相受。突吉罗。除饼等受余食。不犯。若过取二三钵已。使余人持去。突吉罗

颇有比丘食已自恣不受残食法更食不犯耶。答有。若病酥蜜亦如是。食不净食已。自恣更受残食法不名为受食者波夜提。云何不净食。谓正食也

颇有比丘食已自恣不受残食法食不犯波夜提耶。答有。若贼住若学戒。本不和合本犯戒。突吉罗

颇有比丘别众食不犯波夜提耶。答有。行过半由延。不犯。如佛所说。别众食除因缘。不犯。为一切因缘现在前为一一因缘现在前耶。答一一因缘现在前食。不犯

颇有比丘别众食不犯耶。答有。若出界食空中食。不犯

颇有比丘非时食佉陀尼蒲阇尼不犯耶。答有。若住北郁单越。用彼时食。不犯

问颇有比丘一坐食犯四罪耶。答有。若不受食。若不净食。若非时食。若残宿食随入。口口犯四波夜提

问北郁单越宿食。得食不。答得食。余方亦如是。三种人宿食。比丘不得食。何等三。谓贼住。本不和合。学戒

颇有比丘食宿食不犯耶。答有。若比丘尼宿食。比丘得食。比丘宿食。比丘尼得食。若钵口缺食余着器极用意。三洗故腻用食者。不犯。与沙弥已。沙弥还与。比丘用食不犯。宿食与他。他还与。食者突吉罗

若自不受食者。不犯

若用北郁单越法不受食食。不犯。余方不得。若比丘食时。净人以佉陀尼蒲阇尼着器中。成受不。若可却者却。不可却者得食。不犯者。谓浊水碱水灰水

颇有自为求美食不犯耶。答有。若从龙索。夜叉索。一切非人所索。不犯

颇有比丘索美食不犯耶。答有。从亲里索。有虫水应漉

若共黄门屏处坐。突吉罗。共黄门屋中坐。突吉罗。非自在屋中共坐。突吉罗屏处坐。突吉罗。云何非自在屋。若父母亲里等家中自在于中坐。不犯。多有儿息未分财物。名不自在屋。若已分财物已。取妇于中坐。波夜提。若寺舍主所夺于中坐。外道寺中共坐。突吉罗

颇有比丘共坐不犯耶。答有。若虚空中共坐

颇有比丘共屏处坐不犯耶。答有。若大众中彼坐无屏处

颇有比丘屏处食得波罗夷耶。答有。谓食欲

颇有比丘屏处坐波夜提耶。答有。强迫坐者。若屏处食酥油蜜糖食虫水。波夜提

颇有比丘用虫水不犯耶。答有。若大虫于中洗浴。突吉罗。遣使手印。突吉罗

颇有比丘自手与外道食不犯耶。答有。若亲里若病若欲出家者手印与食。突吉罗

颇有比丘军发行往观不犯波夜提耶。答有。天龙夜叉阿修罗等军发行往观。突吉罗。若四兵围绕。若王所唤。若八难中有一一难。不犯。若家内若寺中。一切不犯

过二宿观军发行亦如是

若比丘打三种人。突吉罗。谓贼住。本不和合。本犯戒。若以物掷众多比丘。随所著随得尔所波夜提。若不著者。突吉罗

问颇有比丘一方便得百千波夜提耶。答有。若比丘把沙把豆散掷诸比丘。随所著不着。如前说

若比丘举手刀向众多比丘。得众多波夜提。向四种人。突吉罗。谓贼住。本不和合。本犯戒。学戒

非比丘边覆藏粗罪成覆藏耶。答不成覆藏。于贼住所本不和合所本犯戒所。不名覆藏。若比丘见比丘犯。粗罪彼言我不犯不向人说。不名覆藏。若比丘覆藏比丘粗罪。波夜提。比丘覆藏比丘尼式叉摩那沙弥沙弥尼粗罪。突吉罗。狂痴乱心人覆藏粗罪。不犯。五众展转如轮亦如是。问向狂人忏悔成忏不。答不成忏。僧中覆藏粗罪。波夜提。摈沙弥应舍不应舍。答应舍。若沙弥向僧忏悔。布萨忏悔应摄取

若比丘布萨时作心发露罪。不名覆藏

若比丘驱比丘尼。突吉罗。外道家中驱比丘。突吉罗。驱式叉摩那沙弥沙弥尼。突吉罗。遣使外道家驱沙弥。突吉罗。驱式叉摩那沙弥沙弥尼。突吉罗

若比丘酥油蜜着火中。突吉罗。若烧骨烧诸故衣物等。突吉罗。前火中薪等。突吉罗

颇有比丘共未受具戒人宿过二夜不犯耶。答有。若篱下墙下树下不犯

颇有比丘共未受具戒。人过二夜宿已得二波夜提耶。答有。二夜共沙弥宿已。第三夜共女人宿

若比丘于摈比丘所出罪共食。得波夜提。狂者所散乱心所出罪。突吉罗。摈比丘所出罪。突吉罗

沙弥言。我知佛所说。欲不障道。众僧和合已。彼若忏悔还者当摄受

若比丘与不受法比丘欲已呵责。突吉罗。与上相违亦如是。为贼住人作羯磨。与欲已呵责。突吉罗。与学戒本不和合本犯戒式叉摩那沙弥沙弥尼羯磨已。呵责。突吉罗

颇有比丘着不坏色衣不犯波夜提耶。答有。着不净衣。谓劫波头沙。突吉罗。若不净衣坏色。作净衣著者。突吉罗。若比丘坏色衣。比丘尼得着。乃至沙弥尼亦得着。沙弥尼净衣。比丘得着。乃至沙弥亦得着。拭足衣手巾漉水囊钵囊腰绳等。皆应作净

若比丘衣国王长者所夺。后还得者。更应作净耶。答不作。先已净故

颇有比丘若取宝若似宝等不犯波夜提耶。答有。若取天龙鬼神等宝。突吉罗。若遣信取某处宝。突吉罗

颇有比丘取摩尼宝不犯耶。答有。若取水精摩尼。突吉罗。若作念为他取主还当还主。不犯

颇有比丘坐卧金宝床不犯耶。答有。若天龙鬼神等一切处。不犯。若比丘得刀应坏刀相已然后受用。若比丘金银团上坐。突吉罗。若比丘摩触金银。突吉罗

萨婆多部毗尼摩得勒伽卷第二萨婆多部毗尼摩得勒伽卷第三

        宋元嘉年僧伽跋摩译

颇有比丘半月内浴除因缘不犯耶。答有。着雨衣浴。若比丘迷闷时浴不犯。入水举木因浴不犯。或水中有少因缘因浴不犯。若比丘渡水学浮时浴不犯。若结安居已一月数数浴不犯。过一月已半月应浴。若有闰中安居。当数日满

颇有比丘一方便得十波夜提耶。答有。若杀微细虫。随杀得波夜提。欲斫藤误斫蛇不犯。欲斫蛇而斫藤。突吉罗。欲杀此虫而杀彼虫突吉罗。欲斫虫而斫地。突吉罗。欲搦虫而搦土。突吉罗。手印遣使杀虫。突吉罗。若令贼住。本犯戒。本不和合学戒疑悔者。突吉罗。除比丘比丘尼。令余人疑悔。突吉罗。比丘令比丘尼疑悔。波夜提。比丘尼令比丘疑悔。波夜提。比丘尼令式叉摩那乃至沙弥尼疑悔。突吉罗

颇有比丘指挃比丘身根不犯波夜提耶。答有。若身根坏指挃。突吉罗

若比丘以一瓶水浇诸比丘随所著得尔所波夜提。不著者突吉罗。若比丘坐以水渧地。突吉罗。若比丘尼自出乳汁。波夜提。若比丘水中浴戏拍水出没波夜提。浴时以酥油糖蜜。灌身戏。突吉罗

颇有比丘共女人宿不犯波夜提耶。答有。谓墙壁树下大空屋中。突吉罗。共何等女人宿耶。谓身可捉者。若一房舍相连食。堂中共一门。于中共宿。波夜提。若不知未受具戒人入宿。不犯

颇有比丘恐怖比丘不犯波夜提耶。答有。谓贼住。本犯戒。本不和合学戒式叉摩那沙弥沙弥尼。突吉罗

颇有比丘藏比丘衣钵等物不犯波夜提耶。答有。谓藏金银钵。突吉罗。不净衣不净尼师檀钵囊等。突吉罗

净施五种人衣云何犯。过十夜明相出。波夜提

若比丘言。我见某甲共某甲女人共坐卧波夜提。谤式叉摩那沙弥沙弥尼突吉罗

若比丘知是贼众。知是女人义共道行。波夜提。中道还。突吉罗

颇有比丘共贼道行不犯波夜提耶。答有。谓为贼所将去。若崄难道。若夺人精气夜叉等共行不犯

若四月请若众若私若衣食等应受。过受波夜提。数数请不犯。若比丘檀越请言。若所须者但来取。作是语已。彼比丘罢道更受具足戒已。还到本檀越舍。须更请不。答须更请。若居士无常有余子等。须更请为用前法耶。答须更请。居士先请比丘。比丘为作覆钵羯磨。得受不。答不得受。受者突吉罗。居士言。若不受者。我当生大不敬信。为得受不。答不得。令彼忏悔使得清净已然后得受

年不满二十年。疑与受具足戒。得具足不。答不得。僧犯突吉罗。受具戒人自知不满二十。受具戒时言满二十共行事不犯。后知此人不满二十。众僧不得共行事。初始不得戒故。四种受戒随其事四种者本不和合。如分别毗尼中说。更作羯磨不成就。云何不自知未满二十。后知不满二十。经僧布萨羯磨。作十二人。是名贼住。从何处数年岁。从母胎数取一切闰月。若掘死地坏地离自性不犯。云何生地。经夏四月。是名生地。遣使手印掘地突吉罗

作白时从坐起去。突吉罗。作白已未作羯磨起去。波夜提。作非法羯磨起去。突吉罗。与贼住。本犯戒。本不和合学戒。式叉摩那沙弥沙弥尼作羯磨起去。突吉罗。遣无腊人作使。俱得突吉罗。彼还反。得波夜提突吉罗。咒术使木人。突吉罗

若比丘为他听诤讼。突吉罗

若以酒煮时药非时药七日药得服不。若无酒性得服。若一切果饭得食不。答得食

若比丘教比丘尼修多罗毗尼阿毗达摩。作是言。我不能学。更余比丘边去。除修多罗毗尼阿毗达摩。不学余者。突吉罗

若比丘若僧事若私事入聚落三处不白不犯。白衣舍阿练若处近聚落边无比丘时不白不犯。种种人共住不白入聚落不犯。若自在地白空中人成白不。答成白。相违亦如是作。要以不去。突吉罗。若四衢道中见比丘时应白。不者发心已应去。若一界内出界入余处。若无比丘应白比丘尼。乃至沙弥尼。亦如是

受一请已。复受一不净施食已。自恣不受残食法入聚落。犯二波夜提。不受残食。不白入聚落

颇有比丘明相未出王未藏宝入王家不犯耶。答有。若天王家龙王夜叉王。及一切非人王等家。若有急因缘。若藏宝已入不犯

若说波罗提木叉时。比丘尼言。我始知此罪。犯突吉罗。除毗尼说余法时作是言。我始知是法半月中说。突吉罗

颇有比丘作床足过八指不犯波夜提耶。答有。若以宝作床金银琉璃颇梨作。突吉罗。若为他作过八指。突吉罗

颇有比丘以褥缝着坐床卧床不犯耶。答有。除木绵褥余褥缝着。突吉罗。为他缝突吉罗。手印遣使。突吉罗。缝不净褥。突吉罗。尼师檀覆疮衣。随其事应当知

以不净衣作雨衣。突吉罗

以不净衣修伽陀衣量等作突吉罗

问九十波夜提竟

    问四波罗提提舍尼

若白衣舍三种人边受食。突吉罗。谓贼住。本不和合。学戒。若比丘在空中受比丘尼食。突吉罗

颇有比丘从非亲里比丘尼边受食不犯耶。答有。比丘在寺比丘尼在白衣舍。颇有比丘非母亲比丘尼边受食不犯耶。答有。谓母于非亲里比丘尼边同意白衣舍受不犯。手印不犯

若比丘到白衣家乞食。是中有比丘尼言。与是比丘食。是比丘得食。犯突吉罗。异家一门于中受食。或为他受。突吉罗

颇有非亲里比丘尼边受食犯四篇戒耶。答有。若以衣裹食取衣取食。女人前粗恶语。摩触内身遣使手印言。与羹与饭。比丘不遮。犯突吉罗。若门限边受食不犯。及亲里边受不犯

若阿练若怖畏处不病内受食。突吉罗。不犯者病也。应语彼居士言。此中有难或王问比丘。此中有贼无贼耶答言无。而此中有贼受食不犯。若出界外受食不犯。若中道见居士送食语言莫入。而彼自入不犯。比丘若狂不犯

颇有比丘从学家中自手受食不犯耶。答有。谓先请若病

波罗提提舍尼竟

    七灭诤

若比丘狂犯戒后忆有罪。应如法除灭。若不忆不犯。若欲举诤者应先令是比丘自言。然后举先应乞。听求闼赖吒。闼赖吒者。于二部朋党无有彼此。若彼不同者不应举。若举者不名闼赖吒。闼赖吒应两边知受筹。若作已复言不作得故妄语罪。如不痴多觅罪。现前毗尼。自言毗尼。忆念毗尼。觅罪布草随其义当知

优波离问分别波罗提木叉竟

    问受戒事

问不作白四羯磨受具足戒。为得具足戒。为不得耶。答不得。若受具戒时舍和上。为得具足戒。为不得耶。答不得。受具戒时作者不称三种名。谓和上众僧受戒者。名为得戒。不得戒耶。答不得戒。若作白已减作羯磨。为得戒。不得戒耶。答不得。受具戒时不乞和上。为得戒。不得戒耶。答得戒。众僧犯突吉罗。受具戒时不问遮道法。便与受戒。为得戒不。答得戒。诸比丘犯突吉罗。与愚痴人受具戒。为得戒不。答得戒诸比丘犯突吉罗。二人共一羯磨二处受戒。为得戒不。答得戒。谓二界中间作羯磨

颇有比丘与四处人受戒作羯磨为得戒不。答得戒。谓坐床卧床上坐四向作羯磨

颇有比丘与五处人受具戒作羯磨为得戒不。答得戒。谓坐床卧床上坐为五处人作羯磨。八人十二人十五人十八人亦如是

若比丘界内不和合与人受具足戒。为得戒不。答不得

云何污染比丘尼。答谓非梵行是名污染比丘尼。一人以八事污染比丘尼。成污染不。答成污染。八人各以一事污染比丘尼。是污染比丘尼不。答不成污染比丘尼

云何贼住。人答若不以白四羯磨受具足。戒经白二白四羯磨。布萨自恣。又在十二人数。是名贼住

受戒人不知和上是贼住。依彼出家受具戒。为得戒不。答得戒。诸比丘犯突吉罗。本犯戒本不和合亦如是

若白衣为和上。与白衣受具戒。为得戒不。答得戒。诸比丘犯突吉罗。非出家人为和上。与人受具足。为得戒不。答得戒

云何是越济人。答谓舍沙门衣服舍戒。诣外道所。着彼衣服。乐彼所见。是越济人

杀母人与出家受具足戒。得受具足戒不。答或得。或不得。云何得受具戒。或欲杀余母而杀自母。此得与出家受具足戒。若故夺母命。不得与出家受具足戒。杀父杀阿罗汉亦如是

恶心出佛血。或得与出家受具足戒。或不得云何得与出家受具足戒。答非故恶心出佛血。此得与出家受。具足戒。云何不得。恶心出血

破僧人。或得与出家受具足戒。或不得。若法想受筹。因彼受筹僧破得与受具戒。作非法想不得与受具足戒

与钝性人受具戒。为得戒不。答得戒。诸比丘犯突吉罗。不净人亦如是

与聋人受具戒。为得戒不。答若闻羯磨者得戒。不闻者不得。聋人狂人。满众散乱心人。重病人。亦如是。不受法人受戒受法人。满数不得戒。受法人受戒。不受法人满数不得戒。不见摈比丘与不见摈人受戒。为得戒不。答彼言见罪得戒。恶邪不除摈亦如是。众数比丘若闻羯磨已。转根得戒。受具戒人转根得具戒耶。答得戒。如佛所说。比丘尼从比丘乞受戒故和上转根得具戒不。闻羯磨已转根得具足戒。受戒人在地空中作羯磨。为得戒不。答不得与上相违亦如是。云何得具足戒。若白四羯磨是名得戒

问受戒事竟

    问布萨事

结聚落界除聚落及聚落界应结。不离衣界聚落。聚落界非衣界故。众在地坐空中结界不成结界。与上相违亦如是。若在阿练若处。面应一拘卢舍为界。于中一布萨。若面一拘卢舍。内有比丘而不见。云何作布萨。若眼所及处。共彼作布萨。亦应发心

佛住舍卫国。长老优波离问佛言。世尊。若比丘在地与欲人在空中。与清净欲。成与清净欲不。答不成与。若受清净欲已。出界外即失清净欲

颇有比丘二处说波罗提木叉。成说不。答成说。谓二界中间

颇有比丘三处与清净欲。三处布萨成与清净欲不。答得成。谓在界中间狂人说戒。成就说戒不。答成就说戒。常住比丘布萨时摈比丘。客比丘来得与同羯磨不。答若如法作羯磨得与同。云何起离众。若一比丘起大小行。不舍闻处不名离众。若舍闻处。是名起离众。若聋人满众说戒。得成就。说戒边地人痴钝人等亦如是。布萨时僧破诸比丘。云何作布萨。答各各自朋党说戒

颇有比丘四处坐作说戒。成就戒不。答成说戒。谓若坐床卧床

问布萨事竟

    问自恣法

在地共空中人自恣不成自恣。与此相违亦如是

颇有比丘二处自恣成自恣不。答有。谓在二界中间。四处自恣亦如是。如佛所说。清净同见所出罪。云何清净同见于一事。同见谓波罗提木叉。如所说。除水火难有余难起。得一语自恣不。答若有一一难起。尽得一语自恣。如佛所说。除是事已余事自恣。谓除人已余事自恣。云何事云何人。若彼人所犯罪。即除此人也。如佛所说。自恣时出比丘罪。或有说犯波罗提提舍尼。或有说犯心悔。或有说犯波夜提。或有说犯突吉罗。云何事。谓波罗提提舍尼。若旧住僧十五日自恣。客僧来多十四日自恣。旧比丘应出界外自恣

如佛所说。应出界外自恣。为一切比丘出界外。为一一出界耶。答一切出界外自恣。自恣已摈比丘得共住不。答不得。云何起离众。如前说。聋人满众。自恣痴人满众。边地人满众。受法比丘满众。数不成自恣。自恣人转根不成自恣

问自恣事竟

    问安居法

若比丘安居中摈比丘得共住不。答三月中得共住。若比丘安居中空中住。明相出失安居不。答失安居。若聚落中众僧安居已。出界去。余比丘更结界。此中檀越施众僧衣。此衣应属谁。答属先聚落众僧。如佛所说。此是界功德利。若安居中僧破。此施衣应属何僧。答属多者有四依。谓依夏依时依食依自恣

颇有比丘得四处安居四处自恣耶。答有。若坐卧床上

问安居法竟

    问药法

终身药在不净地经宿得食不。答不得。得食人乳不。答不得。得涂余身分。若不净膏杂盐煮得食不。答得。谓病非不病肉亦如是。火在不净地。人在净地作净得食不。答得食。火在不净地肉近火边。无人为作净成净不得食不。答成净得食

如佛所说。不得啖虫膏得余用不。答不得。食得余用。火在不净地。净人在净地。净酥油得食不。答得食。除八种浆余物作浆。得饮不。答若澄清得饮

问药事竟

    问衣法

安居中摈比丘不得夏房衣。颇有比丘非亲里居士居士妇边乞衣不犯耶。答有。若乞房衣若为僧乞。若学戒人乞遣使乞衣。突吉罗。云何得衣。若在膝上手中。若在肩上。是名得衣。若从非亲里居士居士妇乞衣不得。突吉罗。若比丘四处取衣不犯耶。答有。若坐卧床上

问衣事竟

    问受迦絺那衣法

余处自恣已至余处。得受迦絺那衣不。答得受。不得住处利减量衣。作迦絺那衣受成受不。答不成受

如佛所说。受迦絺那衣比丘所听行事为舍戒。为开通耶。答开通非舍戒。若比丘安居中放牛处。结为内界。自恣已舍。彼中檀越施衣。为属谁。答属先安居者。如佛所说。此安居利。

颇有比丘一衣受作迦絺那衣。即此不成受耶。答有。谓依闰不依闰。彼安居依闰自恣九日得衣即受。作迦絺那衣不依闰。成受迦絺那衣依闰者不成受。王作闰月。数安居日满自恣已。受迦絺那衣成受。布萨时舍迦絺那衣。若安居中僧破如法者。应受迦絺那衣。若俱受迦絺那衣如法者。得住处利

受迦絺那衣时。云何随喜。若现前随喜。云何闻舍迦絺那衣。若出界外从他闻舍迦絺那衣。云何失衣。谓失所作衣。云何成衣。若所作衣成。如是广说。若性住比丘受迦絺那衣。谁应随喜。谓性住比丘及摈比丘。若摈比丘随喜。亦成受迦絺那衣

问迦絺那衣事竟

    问俱舍弥事

若摈比丘作羯磨所摈者。睡眠成摈不。答若闻白已成摈。若满众比丘睡眠成摈不。若闻白已成摈。若与摈比丘作羯磨时。众多比丘两人闻成摈不。答乃至一人闻得成摈。若俱舍弥比丘各成二部。为是破僧非破僧耶。答非破僧。何以故。非作破僧想羯磨故。毗舍离比丘起十事。诸上座比丘不助此不助彼。名闼赖吒比丘

问俱舍弥事竟

    问羯磨事

聋人满数作羯磨。成作羯磨不。答若闻成作羯磨。痴钝人边地人亦如是。受法比丘羯磨不受法比丘满数不成羯磨。人在地空中作羯磨不成作。相违亦如是

颇有二处作羯磨成作不。答成作。谓界中间颇有四处。与四人作羯磨成作不。答成作。谓若坐床卧床如为比丘作。苦切羯磨。驱出羯磨。折伏羯磨。如是为沙弥作者。不成作。沙弥在地空中为作羯磨不成羯磨。相违亦如是。颇有一羯磨摈四沙弥。成摈不。答有。谓在界中间

颇有四处摈四沙弥成摈不。答有。谓坐床卧床

问羯磨事竟

    问覆藏僧残事

颇有比丘犯十三事终身不发露不犯耶。答有。谓若昼日有比丘处。夜在无比丘处。不成覆藏。于聋人所发露成发露。犯突吉罗。愚痴人所边地人所亦如是。受法人不受法人所发露。不受法人受法人所发露。皆成发露。谁边覆藏成覆藏耶。答若性住比丘边不发露。从是名覆藏。聋人所覆藏不名覆藏。痴人所边地人所覆藏。不名覆藏。人在地空中覆藏不名覆藏。与上相违亦如是

颇有比丘二处发露。成发露耶。答有。谓二界中间。受法比丘于不受法比丘边覆藏。不成覆藏。与上相违亦如是。于摈比丘所覆藏。别住所别住竟所。摩那埵摩那埵竟所。狂所散乱所。苦病所白衣所覆藏。皆不名覆藏

颇有比丘得四处。四比丘得作阿浮呵那耶。答有。谓坐卧床上从何处与别住。谓界内有比丘处

颇有比丘终身覆藏僧残不发露不犯耶。答有。谓本犯波罗夷也

问覆藏事竟

    问遮布萨事

如佛所说。遮比丘布萨何时遮耶。谓布萨时非不布萨时。用天眼遮布萨不成遮。犯突吉罗。用天耳闻已遮布萨。聋人遮布萨不成遮。痴人边地人。受法人不受法人。在地在空一切皆不成遮。犯突吉罗

颇有比丘二处说戒成说戒不。答成说戒。谓二界中间

颇有比丘四处四比丘四处得一语一布萨耶。答有。若坐床卧床上遮。自恣亦如是广说

问遮布萨事竟

    问卧具事

若二比丘乞卧具。上座应先受用。用竟与第二比丘。地敷褥得共未受具戒人坐不。答得共坐

如佛所说。客来比丘当应如法行事。应礼上座比丘。若彼有别住人。应礼不。答不得礼。客来比丘不应礼二种人。谓别住人及下坐

问卧具事竟

    问灭诤事

若比丘诤事比丘尼不得灭。比丘诤事比丘灭。比丘尼诤事乃至沙弥尼诤事比丘灭。如别住。别住竟者行摩那埵。行摩那埵竟者应在比丘下坐。卧具亦应与下者不。答不然。应次第与。先应与无腊人卧具已。然后与非法者。被摈人若有长卧具应与。云何灭诤。若僧如法受筹灭诤。若不现前受筹灭。不名灭诤

问灭诤事竟

    问破僧事

如佛所说。以二因缘故破僧。谓闻及受筹。无有第三因缘破僧。摈人为第九人。不名破僧。贼住人二根人亦如是

问破僧事竟

    问覆钵事

居士二法成就应作覆钵羯磨。云何二。谓骂比丘及无根。波罗夷。谤清净比丘

颇有比丘二处为居士覆钵。成覆钵耶。答有。谓二界中间受法比丘。于不受法比丘檀越家覆钵不成覆钵。摈比丘于性住比丘檀越家。作覆钵不成覆钵。贼住人亦如是

颇有比丘四处为四居士作覆钵。成覆钵耶。答成。谓坐床卧床。于本犯戒人所忏悔。犯突吉罗。于贼住人。本不和合人。学戒人沙弥等所忏悔。犯突吉罗。于摈比丘所亦如是

优波离问事竟

    毗尼摩得勒伽杂事

佛住毗耶离猿猴池堂。为迦兰陀子须提那制戒。尔时须提那愁忧疑悔。便作是念。佛言。除前犯戒者无罪。我未制戒时。作众多淫。不知何者先作不犯。诸比丘向佛广说。佛语诸比丘。汝等当知。我未制戒时。须提那犯罪。一切时不犯。跋耆子比丘不舍戒。戒羸不出。便变服作淫。作淫已作是语。我当问诸比丘。我若更得出家者。我当出家。不得出家者。便住向诸比丘。广说上事。诸比丘向佛广说。佛语诸比丘。若比丘舍戒出戒羸。已变服作淫。此人更得出家受具足戒。从今是戒应如是说。若有比丘不舍戒。戒羸不出。作淫法。是比丘得波罗夷。不共住

有一比丘在阿练若处住。去彼不远。母象生一女象子。母象出行食。女象子来近比丘。比丘与草食与水饮。象女蹲食女根开现。比丘见已生贪着心。便共作淫。即生惭愧疑悔。我犯波罗夷。向诸比丘广说。诸比丘向佛广说。佛言。彼不触边故不犯波罗夷。犯偷罗遮。彼女象渐渐长大根复开现。此比丘复生贪着心。以手擗象女根欲作淫。女象以脚踏比丘。彼即生惭愧怖畏。心生疑悔我犯波罗夷。以是事故。向诸比丘广说。诸比丘向佛广说。佛语诸比丘。有怖畏惭愧心。不犯波罗夷。犯偷罗遮

如佛所说。狂者不犯。云何为狂。答有五因缘。名为狂。谓失亲。失财。四大不调。为非人所恼。宿业报。是名五种狂也。若彼作犯戒事。自知是比丘者随事犯。不知者不犯

如佛所说。散乱心者。不犯。云何散乱心耶。答散乱心有五因缘。谓见非人怖。散乱心。非人打非人夺精气。四大不调。宿业报。是名五因缘散乱心也。犯戒如前说

如佛所说。苦痛人不犯。云何苦痛耶。答有五因缘。名为苦痛。谓风发冷发热发和合发时发。是名五因缘苦痛也。犯事如前说

又复比丘。道非道想作淫。即生疑悔。我犯波罗夷。向诸比丘广说。诸比丘向佛广说。佛言。道作道想。犯波罗夷。道作非道想。波罗夷。非道道想。偷罗遮。三道谓大便道小便道口道。若比丘大便道过皮。波罗夷。小便道过节。波罗夷。口道过齿。波罗夷

猿猴师子獾孔雀鸡自根长。广说如毗尼。皆悉犯波罗夷。难提比丘学戒。如毗尼中广说

若比丘在空中裸身浴。四比丘为揩摩身。彼身相摩触起染污心。取比丘男根。着口中即还吐出。寻生疑悔。我犯波罗夷耶。向佛广说。佛言。不犯波罗夷。不得露地浴。受揩摩身坐卧亦如是。若比丘淫欲炽盛。往语所爱比丘言。我淫欲炽盛。彼答作淫去。彼即往作淫。彼比丘即生疑悔。我使比丘作淫。我得波罗夷耶。佛言。不犯波罗夷。犯偷罗遮

尊者优波离问佛言。世尊。云何忏悔偷罗遮罪。佛语优波离。有四偷罗遮。谓波罗夷边重偷罗遮。波罗夷边轻偷罗遮。僧伽婆尸沙边重偷罗遮。僧伽婆尸沙边轻偷罗遮。波罗夷边重者。界内一功大众中忏悔。轻者出界外四人忏悔。僧伽婆尸沙边重偷罗遮。出界外四人忏悔。轻者一人忏悔

有比丘欠时不遮口。有一比丘淫欲炽盛。以男根刺口中。彼寻吐出。即生疑悔。我得波罗夷。乃至佛言。不犯波罗夷。从今以去欠时当遮口。不遮者。犯突吉罗。有比丘男根常起作是念。入女根不犯。便着女根中。即生疑悔。我犯波罗夷。乃至佛言。入即犯波罗夷

有一比丘于母所起染污心。语母言。我欲得作淫。母语子言。汝所出处。随汝意作。便欲作淫欲。至女根时。即生惭愧。彼生悔心。我犯波罗夷。乃至佛言。惭愧时不起淫心。不犯波罗夷。犯偷罗遮

有比丘于旷野中观死尸。彼见女尸衣服严好。生染污心。手捉女根欲入内里生满中虫。即生疑悔。我犯波罗夷。乃至佛言。有二种坏。谓内坏外坏。不犯波罗夷。犯偷罗遮

有优婆夷名善光。日欲没时命终。彼亲族即庄严已。弃旷野中有比丘在彼观死尸。见已生染污心。捉女根欲入尸。即起坐。比丘生怖畏疑悔心。我犯波罗夷。乃至佛言。畏时无贪。不犯波罗夷。犯偷罗遮

有优婆夷名善生。有一比丘出入其家。语彼优婆夷言。我淫欲所缠。彼答言。下作方便上出。上作方便下出。我辈于中不受乐耶。比丘即呵责骂詈。汝历鹿妄语。作是语已。便共行事。乃至佛言。入即犯波罗夷

有一居士妇。比丘出入其家。语彼妇言。我淫欲所缠。妇答言。作方便如前说。乃至佛言。入即波罗夷

孙陀罗难陀比丘因缘如毗尼中广说。彼独住阿练若处住。去婆罗门田不远。彼婆罗门数至田看见。此比丘生欢喜心。彼即请食。比丘受请。婆罗门办诸饮食已。遣裸形小女。往至比丘所。唤比丘。比丘见彼女根生染污心。便共作淫。女根破裂。即生疑悔。乃至佛言。若受乐犯波罗夷。若不受乐。偷罗遮

有比丘男根常不起。便作是念。起者作淫。犯波罗夷。不起者作不犯彼即作淫。乃至佛言。不犯波罗夷。犯偷罗遮

有比丘眠。女人来就作淫。便生疑悔。乃至佛言。若手捉手若脚踏脚。若髀触髀。波罗夷不触。偷罗遮。如眠狂痴亦如是。女人四句。于男非男亦如是。有比丘眠中女人就作淫。彼比丘生疑悔。乃至佛言。语比丘。汝知不。答言不知。我觉动。觉动不犯波罗夷。犯偷罗遮

比丘眠中女人就作淫。即生疑悔。乃至佛言。比丘汝知不受乐不。答言不受乐。不受乐不犯

有比丘眠中女人就作淫。即生疑悔。乃至佛言。汝知不受乐不。答言不知。不受乐而觉动。佛言。犯偷罗遮。如比丘比丘尼式叉摩那沙弥沙弥尼亦如是

有恶沙弥语女人言。入一切道中不犯。彼即用一切道作已。即生疑悔。乃至佛言。入即波罗夷。如女人男子亦如是。有比丘眠中女人就作淫。彼生疑悔。乃至佛言。汝知不。答言不知。不知不犯。如女人男子非男亦如是

恶比丘语式叉摩那言。汝未受具足戒。共我作淫。不犯。彼即许。许已生悔。比丘强捉作淫。彼生疑悔。我非式叉摩那耶。乃至佛言。失式叉摩那。更应与受。犯突吉罗

恶阿练若比丘语沙弥言。汝未受具足戒。共我作淫。无罪。广说如前。沙弥犯突吉罗。沙弥尼亦如是

恶阿练若比丘语新受戒比丘。汝始受戒共我作淫。无罪。彼寻听许。许已生悔。彼强捉作淫。即生疑悔。我犯波罗夷。乃至佛言。不受乐不犯波罗夷。犯偷罗遮

有比丘眠熟。比丘来共作淫。若初中后不知不犯。作淫者灭摈。广说如毗尼中

有比丘见木女像端正可爱。生贪着心。即捉彼女根欲作淫。女根即开。寻生怖畏疑悔。乃至佛言。若举身受乐。犯波罗夷。若女根不开。犯偷罗遮。如木女金银七宝石女胶漆布女。乃至泥土女亦如是

龙女至比丘所。语比丘言。共我作淫来。比丘即许。欲作淫。见形长大生恐怖心。寻生疑悔。乃至佛言。若恐怖心。不犯波罗夷犯偷罗遮。夜叉女亦应如是广说。彼即忽然不见。乃至佛言。不现。犯偷罗遮。天女乾闼婆女亦如是。阿修罗女来至比丘所。语比丘言。共我作淫来。比丘即许。彼女根广大。比丘以脚内女根中。乃至佛言。不犯波罗夷。犯偷罗遮。天女亦如是

有比丘独在阿练若处。有非人来。至比丘所。语比丘言。共我作淫来。彼比丘精进净行答言。我不作淫耶。彼人言。若不作者当与汝作大罪。比丘故不肯作比丘眠已。彼非人合衣掷着王夫人背后。王见已语比丘言。汝何以来此。比丘答言。我独在阿练若处如前说。王言。汝何以独在阿练若处住止即出。是比丘去。乃至佛言。不犯。如是阿练若处不应住。毗舍阇女因缘亦如是

佛住舍卫国。尔时花色比丘尼晨朝着衣持钵入城乞食。食已洗足入房坐禅。不闭户热时眠熟。恶人见其眠熟。即就作淫已去。彼觉已即生疑悔。乃至佛言。不犯。眠时应闭户。若不闭户眠。犯突吉罗

有比丘入舍卫城乞食。入长者家。彼家中系一母猪。母猪展转挽绳欲去。比丘见已悲愍心故。即便解放。居士见之。比丘自念言。我偷我是恶沙门。便解他猪放。我住共此母猪作淫去。即共作淫作已。便作是念。我当问诸比丘。若得出家者。当更出家。不得者便住。以是事向诸比丘广说。诸比丘向佛广说。佛言。初不犯后犯。鸡亦如是

萨婆多部毗尼摩得勒伽卷第三萨婆多部毗尼摩得勒伽卷第四

        宋元嘉年僧伽跋摩译

有居士担肉行为乌所夺。比丘乞食。彼肉堕比丘钵中。居士见钵中有肉。语比丘言。汝是恶比丘恶沙门。我肉乌所夺。今在汝钵中。比丘自念。我是恶比丘恶沙门。我当往作淫去。彼即作淫作已生悔。乃至佛言。前不犯后犯。有比丘母狗前小便。彼母狗即来含比丘男根。比丘寻急拔出。即生疑悔。乃至佛言。不犯波罗夷。不得母狗前小便。若欲小便。应驱令去。若不驱者。当更余处去

有比丘经行野干女来亲近比丘。比丘知是母野干。意起染污心。即以衣裹取母野干。以口啮之。即生恐怖疑悔心。乃至佛言。不犯波罗夷。犯偷罗遮

有比丘独住阿练若处。紧那罗女来捉比丘。掷着深山中已便去。比丘心闷失。相还得稣已离是处去。彼生疑悔。乃至佛言。如是恐怖处比丘不应住

比丘裸形渡水。鱼含男根。即便拔出。寻生疑悔。乃至佛言。比丘不得裸形渡水

有女人裸形障内小便。比丘视见女根起染污心。即以男根刺障内。与女根相近。即生疑悔。乃至佛言。不犯波罗夷。犯偷罗遮

佛住舍卫国。有一比丘食已房前经行。彼经行已。敷尼师檀。一处结加趺坐坐禅。天时大热睡眠。眠中涅槃僧脱去。男根起有女人取薪。展转至比丘所。见比丘如是眠。见已生染污心。即就作淫。作淫已去。比丘觉已彼母人语比丘言。阿阇梨当知。我家在某处。若更欲得者。来至我家。比丘即生疑悔。乃至佛言。汝比丘受乐不。答言不受乐。自今以去不得独在空处睡眠。眠者突吉罗

佛住婆耆陀国波罗给林树。尔时有一比丘。在阿练若处住如前说。女人取草因缘如前说。有五因缘男根起。一谓淫。二谓风。三谓大便。四谓小便。五谓虫螫。凡夫及未离欲具五离欲具四

佛住王舍城。有一比丘。患淫病。彼闻耆婆所说使母人口含男根。便得差。即作是念。佛言。听病服药。比丘即使女人口含男根。病即得差。寻生疑悔。乃至佛言。入则波罗夷

婆楼国淫女家有一贼。常恼乱人众。王民语王某处淫女家藏贼。王即唤淫女问汝家实有贼无贼耶。答言无贼。王言。若汝家得贼者。与汝大罪。司者于淫女家。即捉得贼。王即嗔淫女。王语使者。捉是淫女。拔脚跟筋。拔已弃着旷野中。使人如王教作。乃至着旷野中。比丘往至彼处。见是女人。即起染污心。欲共作淫。彼即起坐语比丘言。与我水饮。比丘即取水与。女人饮水已。作是言。此是不净身。何足为贪。过此夜已。女亲属等来看此女。比丘见诸人来起立一面。彼女向诸亲等。说我不死者。由是比丘力故。诸人即语是比丘言。有所须者来取。比丘寻生疑悔。乃至佛言。不犯波罗夷。犯偷罗遮

有比丘行牛群中。有大恶牛。来触比丘。倒女人上寻生疑悔。乃至佛言。不犯。行时当自防护

有比丘堕井。女人先落井中。女人抱比丘颈。井上人以绳牵比丘出。见女人抱比丘颈。诸人问言。此母人何处来。比丘答言。先落井中抱我颈出。即生疑悔。乃至佛言。不犯。当好作意已看井

比丘行乞食。入小巷中。比丘入女人出根处相触。即生疑悔。乃至佛言。不犯。先应作意。入聚落乞食

有比丘共女人乘船渡水。船便翻没。女人抱比丘颈。渡水至岸。寻生疑悔。乃至佛言。不犯。先当思量。然后当渡

有一男子作女人威仪。诣比丘尼所。阿梨耶度我出家。诸比丘尼不观察筹量。便与出家。此男子夜时摩触诸比丘尼。诸比丘尼即生疑悔。乃至佛言。不犯当好观察思量。然后度人

偷罗难陀。弃胎因缘。此中应广说。乃至佛言。比丘尼不得弃胎弃胎者。犯偷罗遮

拔陀罗比丘尼。此中应广说。乃至佛言。汝拔陀罗受乐不。答言。世尊不受乐。如炽然利剑。乃至佛言。汝宿业果报。得是身根少分强捉者不犯

修阇多比丘尼为弊恶人所捉。掩覆其口。将入旷野中。污已舍去。此比丘尼还所住处。诸比丘尼驱出不容。彼答言。我不受乐。诸人问言。云何不受乐弊恶人将汝至旷野中污汝。已便去。以是因缘。诸比丘尼向诸比丘说。诸比丘向佛广说。佛问。汝受乐不。答言不受乐。展转身掉手掉臂不能得脱。佛言。诸比丘当知。此是宿业报。报得女身。身根少分展转者力捉。掉臂者力捉。力捉者不犯

檀尼比丘尼入舍卫城乞食如前说。乃至佛言。汝受乐不。答言不受乐。我以啼哭大唤。复言。莫捉我。乃至佛言。力捉者不犯

罗咤比丘尼入舍卫城乞食广说如前。诸比丘语是比丘尼。汝受乐不。答言不受乐。汝往问阿梨难陀去。尊者难陀广问是事。此尼敬彼故。不说。难陀呵责此比丘尼。是比丘尼自念。何用如是受生。我当以瓶系颈没水取死。即便作绳系瓶连颈没深水中。绳不坚断出没水中。弊恶人见入水挽出。倒悬去水。还得稣息。即共作淫。诸比丘尼求觅到彼。见彼作淫。诸比丘尼语此尼言。汝本不受乐。今复不受乐耶。乃至佛言。汝受乐不。答言不受乐。我展转如前说。乃至力捉者不犯(一竟)

盗事

佛住王舍城。尔时达腻迦陶家子忧愁疑悔。作是念未制戒时。初作罪不犯。我盗取众多木。不知何者为初。佛语诸比丘。我未制戒时。达腻迦作罪。一切不犯

有比丘阿练若处。他所摄物不摄想取。便生疑悔。乃至佛言他摄他摄想取犯波罗夷。疑取波罗夷。他所摄不摄想取。偷罗遮。不摄不摄想取不犯

有比丘乞饭取余物。乃至佛言。不犯波罗夷。犯偷罗遮。如乞饭乞糗。乞鸠楼摩。乞鱼乞肉乞佉陀尼取余物。一切皆犯偷罗遮

有比丘先不请受食。即生疑悔。乃至佛言。不犯波罗夷犯突吉罗

俱萨罗国众僧分食共住。比丘入聚落彼有二共行弟子。弟子各为师请食。得食已出自相谓言。汝亦取我亦取。不知谁是不与取。我等犯波罗夷耶。佛言。不犯。请食时应相语

俱萨罗国众僧分食比丘入聚落。彼所爱伴为其取食。彼还已语言。我为汝取食。彼答言。我不使汝请食。寻生疑悔。乃至佛言。他不语不应为取食

俱萨罗国众僧分食有比丘病。看病比丘为病比丘请食。得食已。比丘命终。此食当云何。佛言。若先命终后取食者。应还本处。若先取已后命终者。如余财物

有比丘语比丘言。长老。共作偷去来。即便共去。至道中。自生惭愧。我作不可耶。于正法中出家而作此事。即便退还。彼生疑悔。乃至佛言。不犯波罗夷。犯突吉罗

有比丘语比丘。长老。共作偷去来。即便共去。半道悔还乃至佛言。不犯波罗夷。犯突吉罗。有比丘语比丘言。作偷去来。乃至生悔。便作是念。我若不去者。当夺我命。我当共去。不偷不受。彼即共往。不偷不受。乃至佛言。不犯

有比丘语比丘。共汝作偷去来。即便共去。半守道半作事。守道者便作是念。我等不取不犯耶。以是因缘。向诸比丘说。诸比丘闻已。向佛广说。佛言。若满事。波罗夷。不满者偷罗遮

有比丘语比丘言。共作偷去来。即便共去。得便自取。彼或有得者或不得者。若不得者。即生疑悔。乃至佛言。不犯波罗夷。犯偷罗遮。有诸贼施比丘衣。比丘疑故不敢取。乃至佛言。作施主意取

有比丘共行弟子贼所捉。彼盗将来便生疑悔。乃至佛言。若属彼已将来事满波罗夷。不满偷罗遮。界内亦如是

有比丘为贼所捉。而自逃走。便生疑悔。乃至佛言。自逃走不犯

比丘有物欲度关税处。便作是念。我若度税物者。当犯波罗夷。我此物施与母施与父。施与兄弟姊妹等。施与和上阿阇梨。施与支提施与众僧。度税处者。犯偷罗遮空中度不犯

有比丘借坐床后发心。不欲还。便生疑悔。乃至佛言。不犯波罗夷。犯偷罗遮

有比丘借经。广说如前。有比丘偷衣。开发衣时衣中有无价物。即生疑悔。乃至佛言。当数衣价犯

有贼偷酒持至阿练若处。中有已饮者。未饮者藏着阿练若处已去。有比丘到彼坐禅。见是酒已。语余人言。持是酒去。着寺中用作苦酒。即持着寺中。诸贼渴乏还觅酒不得。问诸比丘言。汝等不取我酒耶。比丘答言取。诸贼语比丘言。汝等是贼中之贼也。偷我等酒。比丘寻生疑悔。乃至佛言。不犯。当好观察。已取希望心净故不犯。肉亦如是。诸贼破城邑已逃走。恐怖入寺舍中。是诸贼等以衣施诸比丘。诸居士等围绕寺舍。即便入内。见诸比丘。捉衣居士言。此是我等衣。比丘答言。此衣贼施与我。寻生疑悔乃至佛言。不犯。贼边受衣时。当好观察。若斗战时得衣施者应受。当以刀割截坏色已受持。若已割截坏色索者。亦应与染衣人。染衣已忘。不举入聚落。比丘至彼求觅粪扫衣。至彼见衣持去。彼已还见语比丘言。此是我衣莫取。比丘答言。我粪扫中得。即生疑悔。乃至佛言。不犯。以不摄受想故。当善观察已取

居士以衣着厕外。入厕中大小便。比丘觅粪扫衣。到彼处见已持去。居士出见语言。此是我衣。乃至佛言。不犯当好观察已取

比丘去只桓不远。有田夫作田。脱衣着地已作。比丘觅粪扫衣。至彼见已持去。田夫见比丘取衣语言。此是我衣莫持去。比丘不闻为持去。田夫急追夺取。语比丘言。汝不与取。比丘答言。我粪扫衣取。便生疑悔。乃至佛言。不犯。当好观察已取

有居士闻诸沙门释子衣堕地者便取去。是长者以八迦梨仙。着衣中裹埋粪扫中。出少许令现已去。比丘求粪扫衣。至彼处见已便取。长者语比丘言。大德。莫取我衣。比丘言。我粪扫中得。长者答比丘言。我闻释子衣堕地者便取。以是故。我着彼处耳。即生疑悔。乃至佛言。不犯。当善观察已取

有诸童子脱衣着地已共戏。戏已忘不取衣。各各还家。比丘求粪扫衣。至彼见此衣已。便取去。有一女来觅此衣见比丘持去。语比丘言。大德。莫取是衣去。比丘答言。我粪扫中得。女人答言。此是我儿衣。儿出外戏忘不持去。比丘答言。若是汝衣者便持去。寻生疑悔。乃至佛言。当善观察已取

有比丘藏粪扫衣已。入舍卫城乞食。有一比丘。求粪扫衣。至彼处见已。便取持去。就水浣之。彼比丘乞食已出。至本衣处。见比丘浣已粪扫衣。即语言。长老。汝犯波罗夷。即答言。何因犯波罗夷耶。此比丘言。汝偷我粪扫衣。彼比丘言。我不作摄受想取。乃至佛言。善观察已取

有比丘畜不净粪扫衣。诸天呵责。及金刚力士亦呵责。佛语比丘。不得畜不净所污粪扫衣。畜者犯突吉罗。若得粪扫衣当好浣治。令净好缝好染已受持

有比丘取守墓中粪扫衣为旃陀罗呵责。我等欲取此衣。彼已持去。乃至佛言。有守墓中衣不得取。取者犯偷罗遮

去冢间不远。有天祠。祠中有祀祠人。衣风飘堕落冢间。比丘求粪扫衣。至彼见已持去。祠中人出见已。语比丘言。此是我等衣。莫持去。我等衣风飘来堕此处。比丘言。是汝衣者取去。乃至当善观察已取

有居士请佛及僧于舍食。比丘僧往佛住请食分。尔时给孤独长者子只桓中戏。贼来入寺捉儿将去。有比丘闻已。便作是念。我当以咒术力。化作四种兵众。追逐彼贼。贼见怖畏。放置儿去。诸比丘闻已。语是比丘言。汝犯波罗夷。即生悔念。乃至佛言。汝云何救是小儿。比丘答言。我作咒术。佛言。不犯

俱裟罗国众僧分衣。是中有比丘入聚落。此比丘有二近住弟子。俱取衣分。取已出外。自相谓言。汝与和上取分耶。答言取。二俱不知谁是分谁是非分。谁犯波罗夷。谁不犯波罗夷。乃至佛言。不犯。取时应当相语

俱萨罗国众僧分衣中有比丘入聚落。彼有同伴为取衣分。行比丘还已语言。我为汝取衣分。行比丘言。我不使汝取衣分。即生疑悔。乃至佛言。不犯波罗夷。若不语不应取。分取者突吉罗

俱萨罗国众僧分衣中有比丘病。看病比丘为取衣分。病比丘命终。不知当云何。乃至佛言。若先命终后取者。还与本处。若先取后命终者。如余衣物

有居士犁比丘田。比丘往到彼。语居士言。与我分。若不与我分者莫犁。居士逆比丘意犁不止。比丘自身掷犁上。居士放犁已。呵责毁訾。云何沙门释子而作是事。寻生疑悔。乃至佛言。不犯。比丘不应如是自苦身

有比丘语比丘言。长老。共偷支提物去来。当不得罪。乃至佛言。若有护支提者。数直满波罗夷

旧住比丘为众僧故。使人犁田。比畔有居士田。比丘亦使人犁此田。居士见比丘犁此田。语比丘言。莫犁此田。此非众僧田。比丘言。谁证知。居士答言。非人证知。当使非人自言。此居士祠祀鬼神已。自誓地中自然证出。比丘寻弃犁具。居士便即还去。比丘取证埋藏已更犁。居士还见比丘犁。语比丘。何以故犁。汝得波罗夷罪。即生疑悔。乃至佛言。若满直波罗夷

有比丘不与取居士果木。乃至佛言。满波罗夷。果亦如是

有比丘经行处生树。乌鹊树上作巢。比丘取用作薪。乌作声。精舍闹乱。乃至佛问阿难。阿难广说上事。乃至佛言。不应取乌鹊巢。取者突吉罗。若取用煮染因缘亦如是

佛住舍卫国。一居士有萝卜园。比丘往彼索。与我萝卜根。居士答言。与我直。比丘言无直。云何与。居士言。若不与我直者。我当云何活。比丘言。不与少许耶。答言不与。比丘即以咒术枯杀萝卜。寻即生悔。乃至佛言。不犯波罗夷。犯偷罗遮

如萝卜园香园叶园花园果园亦如是。马啖草。比丘手把草在马前行。马便随逐去。比丘动身欲盗心。寻即生悔。乃至佛言。不犯波罗夷。犯偷罗遮

有比丘共商客来至俱娑罗国。至崄难处。商客乘马。比丘步行。商客语比丘。此崄难处当乘马。速出此难。比丘即骑马。骑马已发心欲盗。便即生悔。乃至佛言。不犯波罗夷。犯偷罗遮

有比丘乘船渡水。船中有金发心欲盗。寻即生悔。乃至佛言。不犯波罗夷。犯偷罗遮

有商客船中载金渡水。船即覆没金箧逐水流去。诸比丘下流洗浴。见是箧流来。便取是箧。诸商人言。莫取此箧。是我等物。比丘答言。我水中得。商客言。我等乘船渡水。船即覆没箧随流去。比丘寻即生悔。乃至佛言。不犯

共住比丘盗心取四方僧物。度与余寺。寻便生悔。乃至佛言。不犯波罗夷犯突吉罗

诸贼偷牛入阿练若处。系置便去。诸比丘往至彼处。见已即解放。便即生悔。乃至佛言。不犯波罗夷。犯突吉罗

舍卫国诸居士从天祠乞愿。愿即称意。以白[疊*毛]施与彼祠。迦罗难陀因往到彼。即取此衣。诸比丘言。汝是偷。答言。云何偷。汝不与取。便即生悔。乃至佛言。不犯波罗夷。犯偷罗遮。毗耶离祠祀亦如前说。彼以金鬘系天额已去。迦罗难陀取。因缘如前说

有众多女人渡水。衣服璎珞着此岸上。渡物至彼还来取物。或有水中浴者猕猴见已。下树取此璎珞去。诸女人还不见璎珞。猕猴树上便掷放地。诸比丘去是不远。经行见是璎珞。便取持来还诸女人。诸女人言。我等璎珞汝等所取诸比丘答言。我等不取。猕猴因缘如前说。乃至佛言。不犯

有众多比丘在一寺中住。有鼠从穴出。取诸食果。藏着穴中。诸比丘见是鼠从穴出便作是念。此鼠取我等食着穴中。比丘即破此穴。取诸食等。示诸比丘。此鼠偷我等食。置此穴中。诸比丘语是比丘。汝得波罗夷。乃至佛言不犯比丘不应取鼠穴中食等

有鼠取诸饮食。着比丘床下。比丘晨朝嚼杨枝已取此食啖。诸比丘语是比丘。汝亦不乞食。何处得是食啖。比丘答言鼠取食因缘如前说。诸比丘言。汝不与取犯波罗夷。乃至佛言。此鼠是比丘父。爱子故取食与子。不犯

猎者逐鹿。鹿走入寺。猎者言。还我鹿来。比丘答言。已入寺中。那得还汝。彼即舍去。诸比丘即生疑悔。乃至佛言。不犯

猎者射鹿因缘如前说。复有猎者。以毒箭射鹿。鹿走入寺。猎者言。此鹿已中毒箭。当更射杀。汝等避箭。诸比丘不避箭。彼等呵责已去。后鹿命终诸比丘不知当云何。乃至佛言。应还猎主

诸比丘坏诸猎网。犯偷罗遮。悲愍心坏。突吉罗。鸟网亦如是。坏狱亦如是

有比丘取狂人衣。彼见已语言。莫担去。比丘答言。后当还汝。寻生疑悔。乃至佛言。不犯波罗夷。犯偷罗遮

有比丘多贷店肆物。后主索发心不欲还。寻即生悔。乃至佛言。不犯波罗夷。犯偷罗遮

有病比丘欲饮浆。亦欲施僧。语弟子言。办浆施僧及自饮。病比丘与诸弟子直。诸人言。我等不用浆。但独与病者饮物者当分。便即行事。寻即生悔。乃至佛言。不犯波罗夷。犯偷罗遮。苏毗罗浆亦如是

有比丘病多有不净物。语诸弟子。我命终后。僧当分我物。语诸弟子言。与我饼食。彼荒惧合饼与食。食已身重。即便令终。众僧殡送已。语是弟子言。担是物来。众僧当分弟子求觅不得。众僧索物不得已。便各起去。无常比丘后野干破腹食之。不净物出现。有比丘至彼处观尸。见不净物担来与僧。寻即生悔。乃至佛言。不犯

又复病比丘多有田宅。语诸弟子。唤诸比丘来。当以此物布施众僧。及支提人别布施。彼看病比丘便作是念。当施僧支提人别施者。我等不得。便不唤僧及诸比丘。病比丘即便命终。寻生悔心。乃至佛言。不犯。看病人不应违。病人意如病人。使应当随意。或有病人。亦随看病人意。复有比丘病。诸弟子唤诸比丘。亦如前说

舍卫国商客乘船入海。海龙捉船。于中或有称天者称树神等者。中有优婆塞。语诸人等。当称目犍连。目犍连念我等者。安隐得渡。彼即忆念目犍连。目犍连即入禅定。化作金翅鸟王。在船头立。龙见已怖畏放去。商人安隐得至舍卫国。在诸比丘前。赞叹目犍连。我等安隐至此。皆是目犍连力。诸比丘问言。何因力耶。商人广说前事。诸比丘语目犍连。汝犯波罗夷。目犍连言。以何事犯波罗夷。诸比丘言。汝夺龙船。寻生疑悔。乃至佛问。汝以何心救。答言。神足力。神足力故不犯

舍卫国商客步道至他国。到险难处贼所围绕中有称天等者。中有优婆塞。是目犍连檀越即称目犍连名。目犍连入禅定。化作四种兵在前。诸贼恐怖舍去。诸商客安隐至舍卫国。因缘如前说

鱼因缘广说。亦如是

鏂钵难陀释子自恣已游行诸寺。诸比丘何处自恣僧得几许物。诸比丘见来。即迎接彼以软语问讯。诸比丘已坐。问诸比丘言。僧得物布施不。答言得。担来放前。诸比丘即前持来着前。着前已分上座。得分捉立。彼语上座。未可去

鏂钵难陀能种种说法。即为上座随宜说法。上座即以衣施。第二第三上座亦如是。彼得众多衣已。担入只桓中。语诸比丘。我今多得衣施。诸比丘问。何处得。因缘如前说。诸比丘言。此是未曾起因缘。乃至佛言。若比丘余处安居。余处取衣分。突吉罗

长老阿难有一共行弟子。精进持行。有一檀越。有二子居士病。阿难弟子往彼问讯。阿难弟子取居士户钥与一子。第二者无所得。不得者往语尊者阿难。阿难即嗔弟子。阿难弟子使五百弟子忏悔和上。诸弟子言。云何忏悔。答言。汝等将诸童子童女。往至和上所。和上当与汝等说法。说法已置诸童子便去。童子必当啼唤。和上必当言。将诸童子去。汝等当答。若听弟子某甲忏悔者。我当将去。彼即如教敕。便为说法。说法已置诸童子去。阿难言。将诸童子去。即答言。若听弟子忏悔者我当将去。阿难即受忏悔。教弟子作突吉罗忏悔

有比丘有大威德商客所请。若有所须者来取。彼比丘有弟子。作是念。商客数数来请和上。我当往试之。为实为虚。即往彼言。和上须酥即出酥与。商客复作是语。须羹者来取。答言善。比丘即持酥去。以少许着羹中与和上食。或着豆中。如是种种用。后商客至比丘所白言。大德。先遣信来取酥。今何以不更来取耶。师问弟子言。汝从商客取酥不。彼答言取。师言。汝犯波罗夷。弟子言。商客请和上。我以试彼故往取。还与和上食。即生疑悔。乃至佛言。应白和上已取(二竟)

佛住跋耆国娑罗双树间婆求河边。诸比丘作念言。佛未结戒。先作罪不犯。我等杀众多人。不知何者为先。乃至佛言。婆求河边未结戒时。一切不犯

有比丘人作非人想杀。寻生疑悔。乃至佛言。人非人想杀。波罗夷。疑波罗夷。非人人想杀。偷罗遮。非人非人想杀。偷罗遮。疑杀。偷罗遮

有比丘长病。何用是生活。即往至同行比丘所语言。借我刀来。彼问言用作何等。答言。但与我来。即便与之。即持入房内。闭户上床坐。即自截头手捉刀而死。二三日不见出。借刀比丘开户看见。自截头捉刀而死。寻即生悔。此比丘命终由我与刀。若不与刀便即不死。乃至佛言。不犯。不得不思量与病人刀

有比丘往至檀越家。主人妇语比丘言。共我作淫来。比丘答言。汝夫妒恶。妇答言。我能使不妒恶。即便药杀。后比丘复往其家。妇言。共我作淫来。比丘言。姊妹莫作是语共作淫耶。我等修梵行人。彼答言。方作是语。我修梵行耶。我已杀夫。比丘言。我教汝杀耶。母人言。我闻汝言汝夫妒恶。我便已杀。寻即生悔。乃至佛言。不犯

有比丘杀意打他命终。波罗夷。不死。偷罗遮。若骨折若腰曲。偷罗遮

有比丘母人怀妊作方便欲杀母。母死波罗夷。儿死偷罗遮。俱欲杀俱死。俱波罗夷。俱不死。俱偷罗遮

有比丘堕胎方便。胎死波罗夷。母死偷罗遮。俱死俱不死如前说

人死已咒术力更生杀。偷罗遮

有比丘为众僧作苏毗罗浆。众多比丘饮已命终。寻即生悔。乃至佛言不犯。二比丘共作伴一人得病。语伴言。与我作苏毗罗浆。饮已当差。广说如毗尼

有婆罗门疽病。往至比丘所言。大德我得苏毗罗浆饮已当差比丘答言。汝婆罗门邪见人。云何饮苏毗罗浆。彼答言。我先病得苏毗罗浆饮已得差。比丘寻与苏毗罗浆。饮已命终寻即生悔。乃至佛言。不犯

有比丘到旷野中观死尸。见一人以木从下道入竖着地。彼语比丘言。大德。与我苏毗罗浆饮当得差。比丘即与苏毗罗浆饮。饮已命终。寻即生悔。乃至佛言。不犯。比丘尼与五百贼苏毗罗浆饮。诸贼饮已命终。广说如毗尼

有比丘旷野中作僧坊。比丘手中塼落打比丘命终。寻即生悔。乃至佛言。不犯。当好用意捉塼

有旷野中众僧作房。垒壁上斫塼。如前说

有旷野中作浴室。如前说。作阶道亦如是旷野中作浴室。诸比丘各以囊襆担土落比丘上命终。寻即生悔。乃至佛言。不犯。当好用意

佛住王舍城。比丘山下坐禅。山上有比丘。推石堕比丘上。便即命终。寻生疑悔。乃至佛言。不犯。当好用意

有比丘牛群中行。有一特牛。逐比丘。比丘走倒小儿上。小儿即死。寻生疑悔。乃至佛言。不犯。当好用意牛群中行

有比丘长病患腰脊曲厌生投坑自杀。下有野干食死尸。比丘堕上野干即死。比丘腰脊得直。寻即生悔。乃至佛言。不犯。比丘不应作是

有比丘坐床上。弟子言起。彼答言。长老。莫使我起。强使令起。起便命终。寻即生悔。乃至佛言。不犯波罗夷。犯偷罗遮

有比丘欲舍狂人命故打死者。波罗夷。不死偷罗遮

有比丘长病。看病人厌语病比丘。我不复看汝。作是念不看当速死。不看故命终。寻即生悔。乃至佛言。不犯波罗夷。犯偷罗遮

有比丘多有财物得重病。看病人作是念。我不看者当速死。此物众僧共分。比丘不看故。即便命终。寻生疑悔。乃至佛言。不犯波罗夷。犯偷罗遮

有比丘食不消腹胀卷眠。看病者言。舒身。病比丘言。莫舒我身。舒身当死。强使舒身。即便命终。寻即生悔。乃至佛言。不犯波罗夷。犯偷罗遮。痈未熟便破。即命终。犯偷罗遮。破熟痈不犯。比丘尼亦如是

有比丘病。应须随病食。看病人不与随病食。即便命终。犯偷罗遮。与随病食命终不犯。有比丘看病不与随病药。如前说

有比丘病语看病人。出我着房外。洗浴我已。还内我。即如其教。出便命终。一切不犯

有比丘床上坐睡。有比丘见已触彼。彼即命终。乃至佛言。不犯

有一时刀风起。禅镇水浇广说如毗尼

有一居士新熟物。先施僧已。然后自食。有一阿练若比丘。到彼居士舍。居士作是言。我不复与僧。当与是阿练若比丘。有比丘语诸比丘彼居士常先施僧新熟已自食。今不来施者。与是阿练若去。众僧言。唤彼阿练若比丘来。即便唤来。诸比丘语言。某居士常先施僧新熟已。自食。汝何以断截耶。答言。大德。我不断截。诸比丘语是比丘。将阿练若比丘着坑中。彼即命终。乃至佛言。不犯波罗夷。犯偷罗遮

有居士欲布施比丘自恣衣。有阿练若比丘。入出其舍。如前说。乃至诸比丘言。以木押踝便即命终。乃至佛言。犯偷罗遮

有比丘乞食。在门阃上立。边有一木倚着壁。比丘衣触倒地。押小儿上即死。乃至佛言。不犯当好作意乞食

有一婆罗门晨朝祀祠中庭坐。比丘入乞食。婆罗门嗔然灯已走去。即倒地命终。比丘作念。此命终由我故。乃至佛言。不犯。比丘使比丘至险难处。至彼命终。乃至佛言。犯波罗夷不死。犯偷罗遮

佛住毗耶离。诸比丘大林中坐禅。尔时有比丘杀猕猴。诸比丘言。汝犯波罗夷。比丘言。何因缘故。答言。汝杀似人。寻即生悔。乃至佛言。犯波夜提

舍卫国有一居士。生儿已渐得长大出家学道。有少因缘故入聚落。有一居士母。抱儿入屋。比丘亦入。彼母人作念。此比丘弄我以杖打比丘。比丘避杖堕小儿上。小儿即死寻即生悔。乃至佛言。不犯。比丘不应如是行。当应一心行

有一良师出家。有一比丘病。往师比丘所。欲破额出血拔刀向彼病人。病人见刀即怖死。寻便生悔。乃至佛言。不犯。比丘不应习破额

有比丘长病。便作是念。何用如是生活。我当自杀。语看病者言。与我绳来。彼即与绳。便自绞死。乃至佛言。不应与病人绳

有比丘有小因缘故。入聚落。将治病差。比丘为伴中道畏贼。语病比丘使行。病比丘言。不能。不病者言。若不使行为贼所劫。病者强力使行至聚落即死。不病者言。病比丘死由我故。我若不将来不死。寻即生悔。乃至佛言。不犯。不应将病比丘作伴行(第三竟)

第四

佛住跋耆国竹林聚落婆求河边。诸比丘作是念。未制戒前不犯。不知何者为前。乃至佛言。我未制戒前。一切不犯

有比丘于人所非人想。说过人法。寻即生悔。乃至佛言。于人人想。波罗夷。人非人想。波罗夷。疑波罗夷。非人非人想。偷罗遮。非人人想。偷罗遮。疑偷罗遮

有比丘于居士所说过人法。居士不忆念。居士问言。大德。何所道。比丘答言。欲食。寻即生悔。乃至佛言。犯偷罗遮。有居士语比丘。若阿罗汉者受四事供养。默然受。犯偷罗遮

复有居士语比丘言。若是婆罗门离恶法者。受我供养。若默然受。偷罗遮。居士语比丘。若是阿罗汉者。受我食默然受。偷罗遮

有比丘晨朝着衣持钵入白衣舍。居士言。大德。若是阿罗汉者入舍。若默然入。偷罗遮。又复若阿罗汉者坐受水。受食受佉陀尼等。若非者出去。若默然受者。偷罗遮

有比丘着衣持钵。入居士舍。居士言。大德。若是阿罗汉者。入坐受食等。如前说。比丘答言。我非阿罗汉。与我者当受。诸居士语比丘言。诸根寂静善护调伏。默然受者。偷罗遮。习学调伏语者不犯

萨婆多部毗尼摩得勒伽卷第四萨婆多部毗尼摩得勒伽卷第五

        宋元嘉年僧伽跋摩译

佛住舍卫国祇树给孤独园。尔时优陀夷作是念。前作者不犯。未制戒时。众多出精不知何者为前。乃至佛言。未制戒前。优陀夷出精。一切不犯。有比丘出茎中精。偷罗遮。空中动搦押作方便已舍不出。偷罗遮。有比丘行时精出。寻即生悔。乃至佛言。犯偷罗遮。有女人礼比丘足。比丘精出。寻生疑悔。乃至佛言。不犯。如毗舍佉鹿子母。一一头面礼比丘足。至长老难陀足。难陀即失不净。堕鹿子母头上。鹿子母起已。两手摩头而说偈言

  我今得大利　　如是同梵行
  烦恼极炽盛　　于世尊法中
  忍修涅槃道

尔时优陀夷寻生疑悔。乃至佛言。不犯。应着小衣

有比丘搔男根不净出。乃至佛言。不犯。有比丘浴时揩摩身不净出。乃至佛言。不犯。有比丘从一处至一处不净出。乃至佛言。犯偷罗遮。恶念思惟亦如是

有比丘母抱捉姊妹本二共食。不净出。寻生疑悔。乃至佛言。不犯

有比丘火难中水难中坑堑难中。及师子虎狼非人等难中出。女人不净出。寻生疑悔。乃至佛言不犯

有比丘女人捉足[跳-兆+專]膝髀指时不净出。寻生疑悔。乃至佛言。不犯

有比丘于青瘀膖胀烂坏血涂骨散骨白骨等所。出不净。一切僧伽婆尸沙

有比丘把搔时风时洗足时不净出。乃至佛言。不犯

有比丘治身时不净出。乃至佛言。犯偷罗遮

有比丘乞食。有寡女语比丘言。共作淫来。比丘即以脚指刺女根中。乃至佛言。犯偷罗遮

有比丘急流水中洗浴男根逆水住不净出。乃至佛言。犯偷罗遮

有比丘头上耳中出不净。犯僧伽婆尸沙

有比丘胁脊胸腋下。臂肘脾中两脚中。两[跳-兆+專]中手中等出不净。僧伽婆尸沙。不出偷罗遮

若有比丘于绳床坐。卧床毡褥枕瓶箧石像土像木像户限等。所出不净。犯偷罗遮

优陀夷便作是念。佛言。前作者不犯。未制戒时。共众多女人摩触身。何者为前。乃至佛言。未制戒前。一切不犯

有比丘人女非人女想摩触。寻生疑悔。乃至佛言。人女人女想摩触。僧伽婆尸沙。人女非人女想摩触。僧伽婆尸沙。疑摩触。僧伽婆尸沙。非人女三句亦如是

有比丘触女人脚。突吉罗。女人触比丘脚。不犯。触女人肩。突吉罗。女人触比丘肩。不犯。有比丘抱母。寻即生悔。乃至佛言。不犯。女人捉比丘指。寻即生悔。乃至佛言。不犯。比丘火中出女人。水中坑中刀中堑中非人等中出女人。寻即生悔。乃至佛言。不犯。有女人捉比丘两臂两膝两手等寻即生悔。乃至佛言。不犯。若比丘摩触青瘀膖胀烂坏虫啖血涂离散白骨等。皆犯偷罗遮。女人倒地比丘扶起突吉罗。比丘倒地女人扶起。不犯

有比丘欲行与女别。女坐膝上。寻生疑悔。乃至佛言。不犯

有比丘夜闇中出小便。比丘尼逆来。比丘尼倒比丘上。寻生疑悔。乃至佛言。不犯

有比丘入聚落乞食。一女人蹻脚坐语比丘言。共作淫来比丘取石取土取木。着女根中。悉犯偷罗遮

有比丘为女人说法。彼女人脚触比丘膝髀胁脊臂肩颈等。皆犯突吉罗

优陀夷复作是念。佛言。前作者不犯。未制戒时。我于女人所。众多粗恶语不知。何者为前。向诸比丘说。诸比丘向佛广说。佛言。我未制戒时。作一切不犯。若有比丘。于人女作非人女想粗恶语。寻生疑悔。乃至佛言。若人女人女想。僧伽婆尸沙。人女非人女想。僧伽婆尸沙

疑僧伽婆尸沙。使化人作粗恶语。偷罗遮。自语。僧伽婆尸沙。比丘语女人言。姊妹所有者与我。女问言。阿阇梨。何所有与。比丘答言。汝自知。女人解意。即答言。已办。寻生疑悔。乃至佛言。犯偷罗遮

有比丘入聚落乞食。见女人蹻脚而坐。语比丘言。阿阇梨。共作淫来。比丘答言。汝根如是好。可作如是如是事。寻生疑悔。乃至佛言。犯偷罗遮

有比丘性粗恶语。于女人所作粗恶语。寻生疑悔。乃至佛言。犯偷罗遮

有比丘尼晨朝洗浴已。着服安禅那摩头着新衣。入舍卫城乞食。比丘亦入城乞食。语彼比丘尼言。姊妹。何以如是行乞男子耶。寻生疑悔。乃至佛言。犯偷罗遮

有比丘父欲与女别。彼是恶行女。比丘语女言。莫作恶行。女问言。我当作何等行。比丘言。莫作如是如是事寻即生悔。乃至佛言。犯偷罗遮

有比丘晨朝着衣到居士舍。语居士母言。与我。彼问言何所与。答言。与我是。彼即解意。答比丘言。已办。乃至佛言。犯偷罗遮

有比丘语女人言。我所见者与我。女问言。何所见。比丘言。我所见者与我。女即解意语比丘言。已办。乃至佛言。犯偷罗遮

有比丘语女人言。姊妹。前者与我。女问言。何者。比丘答言。是汝前。女即解意。答言。大德已办。乃至佛言。犯偷罗遮

有比丘晨朝着衣到居士舍。语居士母言。乐喜者与我。女人问言。何者大德所喜。答言。我所喜者与我。乃至大德已办。乃至佛言。犯偷罗遮

有比丘入居士家。语居士妇言。所爱者与我。乃至大德已办。乃至佛言。犯偷罗遮

有比丘晨朝着衣到居士舍。语居士妇言。姊妹。与我水饮。彼答言。且止当为取。比丘言汝即是水女人言。已办。乃至佛言。犯偷罗遮

有比丘语女人言。与我佉陀尼。女人言。且止当为作之。比丘言。汝即是佉陀尼。答言。已办。乃至佛言。犯偷罗遮

有比丘语女人言与我粥啖。女人言。且止当为作。比丘言。汝即是粥。彼言。已办。乃至佛言。犯偷罗遮

有比丘晨朝着衣到居士舍。语居士妇言。与我蒲阇尼。彼答言。且止当为作。比丘言。汝即是蒲阇尼。女人言。已办。乃至佛言。犯偷罗遮

有比丘于女人所粗恶语。女人不忆念。问比丘言。何所道。比丘止不语。乃至佛言。犯偷罗遮(三竟)

佛住舍卫国祇树给孤独园。尔时鹿子比丘便作是念。佛言。前作不犯。我众多作媒嫁。不知何者为前。以是因缘故。向诸比丘说。诸比丘向佛广说。佛言。未制戒前。一切不犯

有比丘到居士舍。居士言。大德。能为我到某甲女人所。作如是语不。答言能。我当往不还报。居士言。我当云何知。比丘言。我当使比丘至某处。比丘即往到彼家已。出见一比丘语比丘言。且止。彼比丘念言。当为何事。即便住居士。出见是比丘言。善哉善哉。我事已办比丘问言。何事办居士言。共期。寻生疑悔乃至佛言不犯

有比丘到居士舍。居士言。大德。能到某甲女人边。如是语不。答言能。比丘到女人所道居士意。女言。我不用。寻生疑悔。乃至佛言。犯偷罗遮

有比丘到居士舍。居士共妇斗诤。居士鞭妇驱出。比丘和合。和合已。寻生疑悔。乃至佛言。意已断驱出。宣令言。非我妇。于彼媒嫁。犯偷罗遮

有比丘到居士舍。居士语比丘言。能为我至淫女所。作如是语不。答言能。比丘即往到淫女所。作如是语。淫女言。已办。还报。居士他已了。居士眠未觉。乃至佛言。犯偷罗遮

有比丘到居士舍。居士言。汝能唤某甲淫女来不。答言能。即到彼唤淫女。淫女中道他将去。乃至佛言。犯偷罗遮

有比丘到居士舍。居士言。能至某甲女人所唤来不。答言能。即往到彼。女人眠未觉。如前说。乃至佛言。犯偷罗遮

有比丘到居士舍。居士语比丘言。能唤某甲女人来不。答言能。即往唤女人。女人庄严时。夫主还彼事不成。乃至佛言。犯偷罗遮

有二居士为知识。各作是言。汝若取妇时生男。我生女与汝儿作妇。我生男汝生女者与我儿作妇。后一居士生男。第二者生女。生男者居士无常。彼居士不复与女。居士子闻已。语比丘言。能为我到某甲居士所索女不。语彼女言。我等未生时。已以汝与我。我父亡后财物丧失。汝当莫舍我。比丘答言能。即往语彼女人。如上广说。彼女闻已。即舍父母走。至彼男子所。寻生疑悔。乃至佛言。犯偷罗遮

有居士语女人言。与我时节。女人答言。我无闲时。居士言。我何时当知汝闲。女人答言。有比丘数来至我所。我当使往到汝所。以拳打汝背。当知有闲。后比丘到女人舍。女人语比丘言。汝能往到某甲居士所。以拳打背上不。答言能。即往以拳打居士背。居士言。善哉大德。我事已办。比丘言。何事。居士言。共期。乃至佛言。犯突吉罗

有比丘到居士家。女人语比丘。能往唤某甲居士来不。答言能。若为众僧作食者。我当去。女人即送食。与众僧比丘。供养僧已。即往唤彼男子。男子逐比丘来。即共作淫。乃至佛言。犯偷罗遮

复有居士新迎妇端正色好。有一男子欲得彼妇。即数数遣信至彼妇人所。妇人不肯。此妇夫命终。此妇于先欲得男子。所有小过。即收系缚。母语女言。以何方便离此难处。女答母言。有一方便。此居士先数数遣信来至我所。我不从彼。母言。汝当从此此是恶人。令彼得安乐。女言。今当遣谁往。时有比丘。到彼中。即语比丘言。汝能往到某居士所。语居士言。某甲居士妇唤汝。当作如是如是事。比丘言能。即往语居士。居士来共作淫。寻生疑悔。乃至佛言。犯偷罗遮

有居士母。为众僧作精舍。四事供给。居士母命终。后无人料理。废四事供养。诸比丘到居士舍。语居士言。作如是精舍。居士母在时四事供给。居士答言。此母是福德人。复语比丘言。汝能往某甲居士妇所言。与我送食。比丘答言能。即往到彼语言。汝能为某甲居士送食不。答言。不能。我家多事。比丘复言。汝当往为我等精舍故。妇言。为精舍故当往。往便即共作淫。比丘寻生疑悔。乃至佛言。不犯。居士即复以四事供给众僧。料理精舍

有比丘到居士家。居士语比丘言。能往语彼某甲女人来不。答言能。即往语女人。女人病居士亦得病。二人俱病。事不得成。乃至佛言。犯偷罗遮

有比丘到居士舍。女人语比丘。能往唤某甲居士来不。答言能。即往语居士。居士病女人亦病。乃至佛言。犯偷罗遮

有比丘晨朝着衣持钵到居士舍。居士语比丘言。能到某甲居士所言。与我女姊妹等不。比丘答言能。即往语彼。此居士儿命终。若女命终。若狂若痴。若先与他处。犯突吉罗

复有比丘到居士舍。如前说儿病女病俱病。俱狂痴。若与余处。犯偷罗遮

受具戒应与。受具戒不应与。受具戒得具戒。不得具戒羯磨。羯磨事羯磨处。非羯磨处。摈羯磨。舍羯磨。苦切羯磨。出罪羯磨。事非给摩。他事给摩。他事所作事。学非舍戒舍戒。戒羸戒非羸。非舍戒诤。摄诤事诤。事不灭诤。已灭事说不说。受为狂人羯磨。为非狂人羯磨。堕信施不现前羯磨羯磨忏罪白白羯磨。白二羯磨。白四羯磨。苦切羯磨。驱出羯磨。折伏羯磨。不见摈羯磨。舍摈羯磨。恶邪不除摈羯磨。别住羯磨。本日羯磨。摩那埵羯磨。阿浮呵那羯磨。别住有何利。何以故。本日治本日治。有何利何因缘故。出阿浮呵那觅罪相羯磨。戒聚犯聚。不犯聚。轻罪重罪。有余无余。边罪粗罪。罪聚出罪。忆罪斗诤。止斗诤。求出罪遮。说波罗提木叉遮。自恣内宿内熟自熟。捉食受食恶捉。受不受不舍。水食舍。受迦絺那舍。迦絺那不舍。迦絺那重物。轻物。可分物。不可分物。人物非人物。摄物不摄物。不从他受得。取死人物。成衣粪扫灌鼻灌下部刀剃毛剃发。啖净食。作衣果食。非人食。五百集毗尼。七百集灭毗尼。因缘摩诃鏂波提舍。迦卢鏂波提舍等。因时杂园林中净。山林中净。堂净边方净。方净国土净。衣净酢浆净。自恣与自恣。欲取自恣。欲说自恣。欲布萨布萨与欲。受欲。说欲清净。与清净。受清净。说清净。欲清净。与欲清净。受欲清净。说欲清净偷婆偷婆物。偷婆舍偷婆无尽。功德尽供养。偷婆庄严。偷婆偷婆香华璎珞。有食粥佉陀尼舍消。蒲阇尼钵衣。尼师檀针。针筒依止。受依止。与依止。舍依止。和上弟子法供养。和上阿阇梨。近住弟子。和上阿阇梨共行弟子。近住弟子。沙弥筹量卧具。营知事次第礼拜。苏毗罗浆屑药浆。皮革屣揩脚物杖络囊蒜。剃刀剃刀。房户钥户。锁扇柄伞乘。扇拂镜歌舞。香花璎珞。安禅那安禅那物。眠坐卧经行。禅带纽腰绳弹。反抄着衣。地树地物。林树诤诤。坏恭敬下意种种。不共住闼赖咤。实觅罪。波罗夷学戒僧上座山林树堂。房卧具户橝。旷野空房。钵衣尼师檀。针针房粥。水瓶澡罐瓶。盖水饮水器。食蒲阇尼食。时食受食。乞食请食。阿练若比丘阿练若上座。聚落聚落中上座。客比丘客比丘上座。行行上座。洗足洗足上座。集集上座。说法说法上座。非时非时僧。集非时僧集上座。呗不呗。求安居。安居安居上座。安居竟从众至众。安居中安居中上座。布萨说戒。说戒者说戒。上座。上座中座下座。浴室洗浴上座。和上共行弟子。阿阇梨近住沙弥。方便后行比丘。到家入家。入家坐家上座。先语消息空中。迦絺那经行。漉囊下风。入厕厕边。厕跂厕上座。洗大便已。洗手洗处跂小便。小便处小便跂。小便上座。筹草处唾器。杨枝擿齿刮舌挑耳。威仪不威仪。三聚云何受具戒。受戒者受羯磨。共羯磨住故。故名受具戒。彼有十种受具戒。一无师得。谓如来阿罗呵三藐三佛驮。二见谛得。谓五比丘。三问答得。谓须陀夷。四三归得。五自誓得。谓摩诃迦叶及三说。六边地律师等五众得。七中国十众得。八八重得。谓摩诃波阇波提等。九遣使得。谓法与十二部僧得。若制白四羯磨已三语三归受具足戒者。不得具足戒。若未制白四羯磨。三语三归受戒。善得具足戒。善来者若前若后。受戒善得具足戒。何故善来比丘。我与受具戒者。是最后身。比丘终不作学人无常。是故善得具足戒

比丘尼受具足戒有三种受。一受八敬法。二遣使。三二部僧。现前白四羯磨。受具足戒。受八敬法者。摩诃波阇波提比丘尼等。是事应广说。遣使受戒者。达摩提那。或有相似者。若有难不得出。尔时为彼作羯磨。得羯磨者。持去向彼说已。语言。姊妹。善得具足戒。从是后二部僧现在前白四羯磨。受具足戒。得具足戒。八敬遣使受者不得。是名受具足戒

问何以故。名受具足戒。答至诚受羯磨得触证。是名具足戒。与上相违。名非具足戒

云何应与受具足戒。人男人女离障碍事。云何不应与受具足戒。谓杀母。杀父。杀阿罗汉。破僧。出佛身血。无和上无衣钵行。别住未竟。外道越济。非男污染。比丘尼贼住。未满二十。自言非比丘。已灭摈可灭摈。一切非人等。是名不应与受具足戒。若与受具足戒。僧悉有罪。彼人名污众人。云何得具戒。与人受具足戒时。称其名。如法众僧和合问遮罪已。如法白四羯磨。不动不转受具足戒。是名得具足戒人。与上相违。非得具足戒人。云何不得具足戒人。不得不触不证。是名不得具足戒人。十三人一向不得具足戒。一切五逆越济非男。污染比丘尼。贼住不共住。本不和合人。不满二十人。自言非比丘化人等。一向不得具足戒

云何羯磨。谓白羯磨。白二羯磨。白四羯磨。何以故名羯磨。有二因缘折伏羯磨。忏罪羯磨。又复能得清白法故。名为羯磨。云何折伏羯磨。忏罪羯磨。谓折伏驱出摈忏罪。别住本日治。与摩那埵本日治。作是事已。名折伏忏罪羯磨。云何清白羯磨。谓受具足戒。布萨自恣。阿浮呵那等。及余如法羯磨。是名清白羯磨。云何羯磨事。谓所因事缘作羯磨故。故名羯磨事。云何羯磨处。白羯磨成就。闻成就如法众僧和合。作羯磨。不可转动故。名处羯磨

云何非处羯磨。白羯磨不成就。闻不成就。非法僧不和合。可动转。是名非处羯磨

云何摈羯磨。谓比丘有罪摈。比丘不得共作羯磨布萨。不得共住共食。是名摈羯磨

云何舍羯磨。谓如法忏悔。共僧同住同食。是名舍羯磨

云何苦切羯磨。若比丘斗诤相言。众僧与作苦切羯磨已。敕言。后更作者当更苦治汝。是名苦切羯磨

云何出罪羯磨事。若见若闻。若疑犯罪。彼必真实不虚。时非不时义。饶益非不饶益。软语非粗言。慈心非嗔恚。是名出罪羯磨事

云何非给摩他事。谓苦切羯磨。驱出羯磨。折伏羯磨。摈羯磨。不见摈恶邪不除摈。别住本日摩那埵。是名不止羯磨

云何止羯磨。有罪忏悔发露。下意调伏。是名止羯磨

云何所作事。因是因缘故作事

云何学。学有三种。增上戒学。增上心学。增上慧学。复有三种学。威仪学。毗尼学。波罗提木叉学

云何非舍戒。若狂屏处自说。沙弥所。外道所。白衣所。不于性住比丘所说。不名舍戒

云何舍戒。作如是语。出家辛苦作沙门甚难。不乐作比丘。忆父母等送我。至父母所。送我至白衣家。与我觅作具。复作如是语。我舍佛等。乃至不与长老等共法。以清净心说我不乐作。比丘惭愧比丘事。厌离比丘事。口作是说。是名舍戒

云何戒羸。若比丘忆念家中。不乐作比丘。如前说。是名戒羸

云何戒羸非舍戒。以前事向众说。何以故名戒羸。不乐所作比丘事。是名戒羸非舍戒

云何诤。诤有四种相。言诤。斗诤。犯罪诤。常所行诤。何故名诤。因是生诤故。故名诤

云何摄诤。谓七灭现前毗尼等广说。何以故。名摄诤。彼四诤以七灭灭调伏寂静。是名灭诤

云何诤事不灭。若五法成就诤不得灭。何等五。一不白僧。二非佛教。三不白二众。四犯罪比丘未受语。五众犯罪未忏悔。具此五事。诤不得灭

云何诤灭事。有五种成就诤得灭。何等五。一已白僧顺佛教。白二众如法自见罪。诸比丘罪已忏悔。此五事成就诤得灭。是名诤已灭事

云何说。说有五种。谓戒序。四波罗夷。十三僧残。二不定。广说。是名说

云何不说。若众说戒时。说戒者不利。利者应次第说。复不利者。更使利者次第说。乃至下尽应次第说。各说少分。故名不说

云何受。若比丘独住。至布萨时。应扫偷婆房舍堂前布萨处。次第敷座。若有比丘来。未布萨者共布萨。若不来者应在高处望。若见比丘来者。应作是言。疾疾来。今日作布萨。若无来者至冥还来坐处次第坐。心念口言。今日作布萨。我今亦作布萨。若得和合僧。广作布萨。是名受

云何为狂人羯磨。若比丘狂心散乱。当为彼作白二羯磨。广说如长老娑伽陀因缘。云何非狂羯磨。除狂羯磨。诸不狂羯磨

云何堕信施。施与持戒人。回施不持戒人。与正见人。回施邪见人。堕信施如所食如所取。若乃至长取一抟堕信施。是名堕信施

云何不现前羯磨。十种不现前。作羯磨。谓覆钵羯磨。舍覆钵羯磨。学家羯磨。舍学家羯磨。作房羯磨。沙弥羯磨。狂羯磨。不礼拜羯磨。不共语羯磨。不供养羯磨。是名不现前羯磨

云何羯磨。若减四人作羯磨。不成作羯磨。五人羯磨应五人作。十人羯磨应十人作。二十人羯磨应二十人作。四十人羯磨应四十人作

云何忏罪五法五非法。云何五法。非别住所。非不共住所。非未受具戒人所。众中尽发露。是名五如法。与上相违。名非法

云何白。谓白不作羯磨。僧为狂人作白。是名白。云何白羯磨。羯磨白僧。谓布萨自恣。阿浮呵那。舍小钵布草。如是一切名白羯磨。云何白二羯磨。作白已。复作一羯磨

云何白四羯磨。作白已三羯磨。白羯磨不作白作羯磨。不成白。白二作羯磨。不作白。不成白二白四羯磨。不作白作羯磨。不成白四众多羯磨。不作白。不成众多作白二羯磨。不作白。不成作多作羯磨。不犯减作不成作白。时众中有少因缘起去不舍。闻处忆白。若舍闻处。不忆白。还应语僧。更作白。白未竟。复有起去。若舍闻处。更应作白

云何苦切羯磨。若比丘斗诤。僧与作白四羯磨。是名苦切羯磨

云何驱出羯磨。污染他家与作驱出白四羯磨。云何折伏羯磨。若比丘毁訾檀越使忏悔。彼故白四羯磨。云何不见摈羯磨。若比丘犯罪已问言。不见罪与作不见摈白四羯磨

云何舍摈羯磨。比丘犯罪如法忏悔。作白四羯磨。解摈

云何恶邪不除摈。若比丘起恶邪见不肯舍。为作不舍白四羯磨

云何别住。若有外道。欲于正法中出家受具足戒。尔时应四月在和上所住。与作白四羯磨。又复别住。十三事中犯一一事已覆藏。随覆藏与别住。作白四羯磨。是名别住

云何本日治。若比丘别住中。复犯僧残。与本日治。作白四羯磨

云何摩那埵。若比丘已别住竟。与摩那埵。作白四羯磨。不动转。于一切比丘所。下意故。名摩那埵

云何阿浮呵那。于不善处举着善处。是名阿浮呵那。覆藏罪别住。有何利。本日治摩那埵。有何利。何以故作阿浮呵那。答覆藏者与别住摩那埵。是别住功德利。本日治调伏故。阿浮呵那。是摩那埵功德利。阿浮呵那清净故。何以故。摩那埵是别住功德利耶。比丘别住下意调伏。是故摩那埵别住功德利。何以故。本日治调伏。调伏者。使诸比丘知是长老。如是炽盛烦恼犯罪惭愧。更不作故。是名本日治调伏。何以故。阿浮呵那是摩那埵功德利。已调伏求清净。自求出罪。诸比丘言。是比丘求清净求出罪。是贤善比丘。我等当与作阿浮呵那。是故阿浮呵那是摩那埵功德利。何以故。阿浮呵那是清净已起得清净。无罪。如世尊所说。二种比丘得清净。一谓不犯罪。二谓犯罪。如法忏悔。是故阿浮呵那。是清净。云何觅罪。若比丘犯戒。犯戒已自说。后不说与觅罪。白四羯磨。是名觅罪

云何戒聚。戒身即戒聚。云何犯聚。犯波罗夷。僧残。波夜提。波罗提。提舍尼。突吉罗。是名犯聚。云何不犯聚。不作若犯。如法忏悔。通是不犯聚

云何轻罪。谓可忏悔。云何重罪。谓不可忏悔

云何有余罪。后四篇。谓僧残。波夜提。波罗提。提舍尼。突吉罗

云何无余罪。谓初篇。云何边罪。谓四波罗夷

云何粗罪。四波罗夷。僧伽婆尸沙

云何罪聚。谓一切罪不善所摄

云何出罪。汝长老犯如是。如是罪当发露忏悔。莫覆藏。是名出罪

云何忆罪。长老汝犯如是。如是罪当忆念

云何斗诤。若见闻疑罪不共语。是名斗诤

云何止斗诤。以五因缘。何等五。我语汝我说汝。我出汝罪。我令汝忆。汝听我。是名止斗诤

云何求出罪。如前说。是名求出罪

云何遮布萨。十种遮布萨。广说如毗尼

云何遮自恣。有四非法四如法。非法者。无根戒。不净人。恶威仪人。邪命人。与上相违。名如法遮自恣

云何内宿食。若界内不结净地食。在界内比丘不得食。是名内宿。若结净地食。在净地得食

云何内熟。若比丘界内不结净地。界内熟食。比丘不得食。是名内熟

云何自熟。尔时毗耶离饥俭诸居士。欲与诸比丘作食。便作是言。我等若使人作者。当多有人食。此食及亲里等来索。见诸比丘道业不就。语诸比丘言。此米使净人作食竟。食诸比丘不好看捡。诸客比丘来者当相分。与诸比丘食少身体羸瘦。乃至佛言。听诸比丘界内结净地已作食。诸比丘结已。使净人作食。净人沙弥自食已。少与诸比丘。诸比丘食少故。身体羸瘦。乃至佛言。如是饥俭时。听诸比丘自作食。舍二处内宿内熟。乃至俭时未过自作食

云何捉食。比丘无惭愧故。捉食

云何受食。若比丘从男女黄门二根等受

云何恶捉。自手捉食已。复从他受

云何受。诸比丘食已。自恣受残食法而食

云何不受。食已未自恣。听诸比丘持食出。如饥俭时。食已不自恣。不受残食法。得食不受残食法。听食果。谓胡桃等

云何不舍毗耶离。饥俭时听

云何水食。长老舍利弗血病。良师言。食藕者得差

尔时尊者大目犍连曼陀罗池中取藕来。与尊者舍利弗。舍利弗食少许已。与诸比丘。诸比丘不食。我等已自恣竟。诸比丘向佛广说。乃至佛言。饥俭时食已自恣。不受残食法。听食藕

云何舍饥俭已过。世尊从毗耶离游行诸国。渐至舍卫国。尔时世尊问阿难。我毗耶离听诸比丘八事者。内熟乃至藕等。诸比丘故行是事耶。阿难白佛言。世尊。或有行者有不行者。尔时世尊集诸比丘僧。集僧已。语诸比丘。我先毗耶离听八事。尔时饥俭故。听非丰时。自今已去不听食者得罪。是名舍

云何受迦絺那。若此住处受迦絺那。界内一切众僧应集。同戒同见清净故。又复余处比丘闻某处受迦絺那衣。发随喜受

云何不受迦絺那衣。与上相违。名不受

云何舍迦絺那。有八种。广说如毗尼

云何不舍迦絺那衣。与上相违。名不舍

云何重物。谓木床乃至阿珊提等。木竹及余物。作者荐席机褥瓦器等物。是名重物

云何轻物。谓金银铜铁床等。金银铜铁器钵衣物等。是名轻物

云何可分物。谓死比丘三衣持与看病人。除重物。余一切轻物可分。谓铁器钵络囊铜器户钩刀针镊剪爪刀香炉香匙香器斧凿等。如是物可分。不可分者重物。重物不可分。谓木床乃至瓦器等不得分。持作四方僧物。若染汁四方僧来者。共染衣。除五大妙色金床。转易物已共分。铜床亦如是。木床等四方僧共用。又复五事比丘不得卖。不得与人。不得分破。何者是谓园林寺舍卧具园寺舍地

云何人物。世尊听诸比丘为僧故。受园林。非为一人

云何非人物。谓象马骆驼秦牛水牛。世尊为塔为僧故听受

云何摄物。若他所摄。若聚落阿练若处。男女非人所摄。是名摄物

云何不摄物。若聚落阿练若处他不摄。若男女非男二根不摄。是不摄物

云何比丘不从他受而得受用。除一切可食物。除水杨枝。是不从他受

云何死比丘衣。死比丘衣五。众得分受用

云何成衣。若作五年大会得衣

云何粪扫衣。有五种。比丘得取火烧牛嚼鼠啮水衣产衣

云何灌鼻。佛听病比丘灌鼻。如尊者毕陵伽婆蹉。是事应广说

云何灌下部。比丘不得灌下部。灌者偷罗遮。不犯者灌便病差

云何刀。比丘不得用刀治病。若治者。偷罗遮。

不犯者。余药不治刀治得差

云何剃毛。除须发剃余身分毛。突吉罗

云何剃发。比丘应次第剃发。下座剃发已。下刀上座不得使起。起者。突吉罗。云何啖。谓五种种子

云何净。谓五种净

云何食五种净已食。及八种浆清净不浊

云何作衣。十种衣三种坏色用

云何果食。毗耶离中众多果。诸比丘私取食。乃至佛言。不得私取食当等分。分果时一人受二人三人分。高声大声。乃至佛言。不得分。若有净人作五沙门净已。从彼受食

云何非人食。听诸比丘天上金银琉璃地阶道行坐卧听器中食。是名非人食

云何五百集毗尼。佛般涅槃不久。五百比丘集王舍城已。撰集一切修多罗。毗尼阿毗昙

云何七百集灭。佛般涅槃后一百一十年。毗耶离诸比丘十恶事起非法。非毗尼非佛教。离佛法与毗尼阿毗昙法相相违。以是为净。何等为十。谓盐净。二指净。聚落净。[酉*(替-曰+貝)]酪净。如是净。随喜净。生酒净。习净。缕尼师檀净。受金银净

云何盐净。以自尽寿受持盐杂食得食。佛言。食者犯突吉罗。佛在舍卫国。药法中制是罪。二指净者。食自恣已得二指挑食。佛言。食者犯波夜提。佛在毗耶离。食法中制是罪。聚落净者。一聚落请食已自恣。复得至余聚落食。佛言。食者波夜提。佛在毗耶离。食法中制是罪。[酉*(替-曰+貝)]酪净者。食自恣竟。复得[酉*(替-曰+貝)]酪已得饮。佛言。饮者波夜提佛在毗耶离。食法中制是罪。如是净者。界外成众羯磨界内随喜。佛言。犯突吉罗。瞻婆国羯磨事中制是罪

随喜净者。界外先不语作羯磨。作已来语随喜。佛言。犯突吉罗。亦瞻婆制是罪。生酒净者。谷作酒未熟得饮。佛言。饮者波夜提。枝提国因娑伽陀比丘制此戒。修习净者。修习杀生不修习杀生。杀生无罪。佛言。随事犯。缕尼师檀净者。尼师檀头不接缕。佛言。不接缕者。犯波夜提。迦留陀因缘制此罪。金银净者。毗耶离诸比丘自手受金银。佛言。受者波夜提。王舍城制此罪。毗耶离诸比丘行是十事。七百比丘集灭是罪

云何毗尼因缘。谓二波罗提木叉。毗崩伽十七毗尼事。七法八法善诵。增一散毗尼。共戒不共戒

萨婆多部毗尼摩得勒伽卷第五萨婆多部毗尼摩得勒伽卷第六

        宋元嘉年僧伽跋摩译

云何摩诃鏂波提舍。有四摩诃鏂波提舍。若有一比丘来所说言。是修多罗毗尼阿毗昙。我从佛口受是法。诸比丘当取是语。不得是非。当修多罗毗尼阿毗昙中觅。若与彼相应者。当称叹其人。善哉长老。善受持。若不相应者。当语彼言。此非佛语。非修多罗毗尼阿毗昙。汝不善解。二人三人大众来所说亦如是。何以故。名摩诃鏂波提舍。答大清白说圣人。圣人所说依法故。不违法相故。弟子无畏故。断伏非法故。摄受正法故。名摩诃鏂波提舍。与上相违。名迦卢鏂波提舍。何以故。说迦卢鏂波提舍。为诸弟子善解无畏故。持正法故。为后世末法中诸恶比丘增故。此是佛语。彼非佛语故。故名迦卢鏂波提舍

云何等因。谓药若根茎叶花果药等。与病因相应故。故名等因

云何时杂。即日受时药。即日受非时药。七日药终身药时杂应时服时药摄故

云何园林中净。若比丘园林中有金银。作是念。有主者来取

云何山中净。山者。树也。树者。枝叶相接花果相接。面一拘卢舍。三衣随处着。过明相出。云何堂净。若僧伽蓝中上座次第坐

云何国土净。若在郁单越。用阎浮提时食。若阎浮提时郁单越中夜。一切余方亦用阎浮提时食

云何边方净。俱只国不知受食。诸神通比丘到彼所乞食。彼人取食着地不肯授与。诸比丘不知云何。乃至白佛。佛言。听诸比丘。五种受法。谓手从手受。器从器受。衣从衣受。余身分从余身分受。放地受。是名边方净

云何方净。雪寒处听诸比丘着靴履[輻-車+革][革*羅]。余国不听。亦听诸比丘着复衣。余处不听。阿槃提国听诸比丘用皮常洗浴。余方不听。亦听律师等五人受具足戒。余处不听

云何衣净。世尊听诸比丘十种衣。谓羊毛衣。纻麻。刍摩。头鸠罗。劫贝。俱絁炎波兜那剑。俱耽波剑。俱脂罗剑。阿婆罗哆剑。此十种衣三坏色已受持

云何酢浆净。诸比丘病问诸医师。医师言。饮浆可得差。乃至佛言。应作酢浆。作法者取米汁温水和之。放一处酢已。须者受用。若浆清澄无浊。以囊漉清净如水。从地了受已。至日没得饮。非初夜。初夜受初夜饮。乃至后夜受。后夜饮

云何自恣。若比丘自恣日集在一处。僧中三处自恣。谓见闻疑。何以故。佛令诸比丘自恣。欲使诸比丘不孤独故。使各各忆罪故。忆罪已发露悔过故。以苦言调伏故。而得清净无病安隐故。自意喜悦故。我清净无罪故

云何与自恣欲。若比丘病不到自恣处。若不病不去。犯突吉罗。若有恐怖若命难梵行难。若八难九难。一一难起不得往自恣处。应与自恣欲。如何难起。亦当与自恣欲

云何取自恣欲。若以人到比丘所取自恣欲。应如是取界内。非界外取欲已。若界内有大怖难命难梵行难等。八因缘中一一难起。尔时出界外不失欲

云何说自恣欲。到众中为彼比丘说自恣欲。若说者善。不说者。犯突吉罗

云何布萨半月半月诸比丘各各自观身。从前半月至今月半中间。不犯戒耶。若忆犯者。于同意比丘所。发露忏悔。若不得同意作念。若得同意当发露忏悔除是罪。余清净共僧同作布萨。是名布萨。何以故。名布萨舍诸恶不善法。舍烦恼有爱。证得清净白法。究竟梵行事故。名布萨

云何布萨与欲。谓病比丘布萨时。不能到僧中。应与欲若不病与欲。犯突吉罗

云何受欲。广说如前说。欲亦如前。何以故。名欲。欲者。所作事乐随喜。共同如法僧事

云何与欲。病比丘不能到僧中。应与欲。若不病与欲。犯突吉罗。若有十难因缘。应与欲。如何难起。亦应与欲。与欲者。与欲成与欲。比丘与欲。答言尔成与欲。与我说欲。成与欲。当与汝欲。成与欲。身动成与欲。口动成与欲。若身口不动。将到僧中。若不堪动。一切僧应就。不应别作僧事。若别作僧事者。随事犯受欲说欲。如前自恣说

云何清净。清净者。无罪。云何与清净。广说如前。与欲受清净说清净。亦如自恣说

云何欲清净。若僧布萨羯磨时。欲及清净。云何与欲清净。布萨时比丘病不能到僧中。当与欲清净。若不病与欲清净。犯突吉罗。若命难梵行难及八因缘难起。当与欲清净。如何难起亦应与欲清净。与欲清净者。与欲清净比丘与欲清净。答言。尔与我说欲清净。当与汝欲清净。身动口动彼一一成与欲清净。若身口不动。应将到僧中。若不堪动。一切僧应就。不应别作布萨羯磨

云何受欲清净。若比丘从比丘边受欲清净。受欲清净者。应如是取界内非界外。若命难梵行难。乃至八难中。一一难起持。至界外不失欲清净

云何说欲清净。受欲清净。比丘到僧中。为彼比丘故。说欲清净。若说者善。不说者。犯突吉罗。不恭敬和合故

云何偷婆。佛听发瓜作偷婆。如给孤独长者因缘毗尼中广说。是名偷婆。云何偷婆物。谓偷婆田宅彼处建立偷婆

云何偷婆舍。谓殿舍楼阁。若木鋀石白镴铅锡等

云何偷婆无尽功德。毗耶离诸商客为世尊起偷婆。起偷婆已。复为偷婆故。多施诸物。诸比丘不受是无尽物。即以白佛。佛听受使优婆塞净人知。若彼得利用。治偷婆或作偷婆。云何供养偷婆。土抟白灰朱砂

云何庄严偷婆。庄严偷婆者。缯彩安牧迦。头鸠罗俱给耶。俱脂跛剑幡幢。金银琉璃。珂石珊瑚。虎魄马瑙。真珠摩尼。赤珠玫瑰。沉水栴檀。末香涂香灯花。如是等及诸妙物庄严

云何供养偷婆。伎乐香花。末香涂香烧香。礼拜为塔故。比丘得结鬘

云何有食。若比丘住寺中得食

云何粥。世尊听诸比丘啖粥。不得吮粥作声

云何佉陀尼。佛听诸比丘啖九种佉陀尼。叶佉陀尼。花佉陀尼。果佉陀尼。胡麻佉陀尼。油佉陀尼。面佉陀尼糖佉陀尼。根佉陀尼。石蜜佉陀尼。食此九种佉陀尼时。不得拍拍作声

云何含消。含消有五种。世尊听诸比丘服。谓酥油蜜糖醍醐。服含消药时。治病想服药想。粪尿想髓脑想

云何蒲阇尼有五种。世尊听诸比丘啖乌陀那贵摩沙曼陀。若鱼肉等。是名蒲阇尼。食蒲阇尼时。治病想服药想粪屎想

云何钵。世尊听诸比丘畜二种钵铁钵瓦钵。八种钵不听畜

云何衣。世尊听诸比丘畜七种衣。不听净施。谓僧伽梨郁多罗。僧伽安旦婆娑。雨衣覆疮衣。尼师檀。养命衣。是名衣

云何尼师檀。世尊听诸比丘畜。诸比丘畜尼师檀。护僧卧具故。无尼师檀不得坐僧卧具

云何针。世尊听诸比丘畜二种针。铁针铜针。是名针

云何针筒。世尊听诸比丘畜针筒。为举针故。不应与无惭愧人。不得与沙弥

云何依止。世尊所说。客来比丘不应先洗足消息。先当求依止。尔时有一客比丘来。闻佛制戒。客来比丘不得先洗足消息。先求依止。此比丘体力疲极。求觅依止。迷闷倒地。即便命终。诸比丘向佛广说。佛言。听诸比丘脱衣钵拭足尘。洗足已二三日。然后求依止。尔时诸比丘趣得便依止。彼于善法退转。佛言。不得趣尔依止。当好筹量。能增长善法者。然后依止。依止时当问余比丘。此比丘何似有戒德不。能教诫不。眷属复何似。无有诤讼不。能相教诫不。如是问已。从求依止。与依止者。亦如是

云何受依止。当偏袒右肩。两手捉两足已。当如是语。我某甲从大德求依止。大德与我依止。我依止大德住。第二第三亦如是说。彼应答言。好善哉

云何与依止。不满十腊。不得与依止。假使满十腊。愚无所知。不得与依止。若五法成就。得与依止。何等五。知犯不犯。知轻知重。广诵波罗提木叉。已与人说。广说如毗尼

云何舍依止。有五因缘。失依止还依止。去舍戒。从众至众。见本和上

云何和上。诸比丘无和上出家受具足戒。心意不调伏。威仪不齐整。病痛无人看。诸比丘向佛说。佛言。自今听依和上出家。和上教诫弟子。心得调伏。病时相看。后诸比丘弟子病时不看。佛言。应看不看者。犯突吉罗

云何弟子。诸比丘依和上出家受具足戒。不来亲近和上。诸比丘向佛说。佛云。应亲近和上承事问讯。随逐行作事时。应白和上。和上所作事。应代作除。四种。谓大小行嚼杨枝界内礼枝提

云何供养和上。应承事供养问讯礼拜和上所应作事应疾疾作之。不应懈怠。惭愧和上。恭敬和上。下意求善法不求过。和上有过应谏。和上病应看。自事不应废

云何阿阇梨。诸比丘无阿阇梨出家。心不调伏。威仪不齐整。病无人看。诸比丘白佛。佛言。听诸比丘。作阿阇梨。当教诫看病诸比丘不肯与受具足戒。佛言。应与受具足戒

云何近住弟子近住弟子。不亲近阿阇梨。诸比丘向佛广说。佛言。近住当亲近阿阇梨问讯随逐。所作事白阿阇梨。除大小行。如前说

云何和上阿阇梨共行弟子。近住弟子共行弟子。近住弟子于和上阿阇梨所。如父母想。和上阿阇梨于弟子所。如儿子想

云何沙弥。世尊听畜沙弥不太小。小者七岁。若作罪者。当使忏悔。若裸形与着衣

云何筹量。若始作住处起寺舍时。先当筹量。行处成就不永成就。不经行处成就。不非妨处。难处不少闹乱声。不如是观察。已起立寺舍。若不筹量营事得罪

云何卧具。世尊听诸比丘畜毡褥毾[毯-炎+登]。若僧有若自有

云何营知事。世尊住阿茶毗寺舍。房舍崩坏。见已问阿难言。此房舍何以崩坏。阿难白言。世尊。六群比丘知事不修治故。佛语阿难。更使余人知事。若小小治乃至扫地便止。不修治者。不听知事。好修治者使终身知事。烟熏雨漏房舍。与知事人住。佛言。不得终身知事。不得与烟熏雨漏房舍住。与十二年房故名新。若知事新作房舍。新作卧具者。十二年中僧不使。或十一年。或十年九年。八年七年。六年五年。四年三年。二年一年。不使泥不使治。云何次第。佛听诸比丘次第上中下。礼拜问讯。起迎合掌

云何苏毗罗浆。佛听病比丘饮苏毗罗浆。如尊者舍利弗病因缘。是中应广说。取根茎花果叶药着一器中。渍酢已。清澄无浊。朝受乃至初夜饮。后夜亦如前说

云何屑。佛听诸病比丘畜豆屑赤豆屑摩修罗屑等。不得杂香。不以色好故畜。若病得合余香

云何药。谓根茎叶花果时药。七日药。终身药。世尊听诸病比丘畜服。若众若自

云何浆。谓世尊听诸病比丘饮八种浆。净漉水净已饮

云何皮。比丘不得畜皮。不得受不得用。坐卧除革屣。若至白衣舍。得坐不得卧

云何革屣。世尊听诸比丘畜二种革屣。谓一重皮革屣。芒屣不得杂色作

云何揩脚物。比丘不得畜浮石。云何杖。王舍城尸陀林中多有毒虫。诸比丘为毒虫所害。佛言。白羯磨已。听畜杖

云何杖络囊。世尊听病比丘从僧乞白二羯磨已畜

云何蒜。世尊听病比丘服蒜。如长老舍利弗不病不得食。若病食者。当如法行

云何剃刀。世尊听诸比丘畜剃刀。为剃发故。是名剃刀

云何剃刀房。世尊听诸比丘畜剃刀房。为举刀故

云何户钥。世尊听诸比丘畜户钥。为护卧具故。若众若自。为安隐僧故

云何户锁。如户钥

云何扇柄。摩尼扇柄。比丘不得畜。若得者。取当供养佛枝提声闻枝提

云何伞。世尊听诸比丘畜伞。防雨热故

云何乘。世尊听老病比丘乘乘。广说如毗尼

云何扇。世尊听诸比丘畜扇。若众若自

云何拂。世尊听诸比丘畜拂

云何镜。世尊不听诸比丘照镜。乃至水中除面眼有病

云何歌舞倡伎。比丘不得自作。亦不得教人作

云何香花璎珞。佛言。比丘不得着香花璎珞。若得者取当供养佛枝提声闻枝提

云何眼安禅那。世尊听病比丘畜安禅那。不得为好故着。眼药为病故。听着

云何着安禅那物二种。着安禅那物。谓铜铁

云何卧。比丘不病不得昼日卧。不得灯中卧。若疲极者应起去。不得恼第二人

云何眠。世尊听比丘昼日经行坐除睡盖。初夜过四叠郁多罗僧。敷卷叠僧伽梨为枕。右胁卧脚脚相累。不得散手脚。不得散乱心。不得散乱衣。作明相正念起想思惟。然后眠至后夜疾疾起。经行坐除去睡盖

云何禅带。世尊听病比丘畜禅带。谓腰背痛。如尊者舍利弗因缘。此中应广说

云何纽。佛听诸比丘安衣纽。为风故。为摄衣故

云何腰绳。世尊听诸比丘畜三种腰绳。谓编绳圆织绳綖绳

云何弹。世尊听诸比丘畜弹。怖贼故。无有因缘得打

云何反抄着衣。比丘不得反抄着衣。除高处作

云何地。地有二种。经行地。精舍地

云何树。耆阇崛山道边无树。佛言。听诸比丘种树。为荫故。为花故。应次第种

云何地物。谓田地。听诸比丘取田地。为园故。为精舍故

云何林树。比丘应次第取

云何诤相言斗诤行两舌。各各相斗。不和合不如一水乳。各自分住。非时不作。无义无作。非法不作。无朋党不作。自恼恼他不作俱恼不作。如是诤不应作

云何诤坏。僧作二僧坏轮坏

云何僧坏非轮坏。若行十四坏僧事。取一一坏事。如法如律。非法非律。乃至界内各作布萨。是名僧坏非轮坏

云何轮坏非僧坏。八圣道名轮。舍八圣道说余道。是名轮坏非僧坏。轮坏及前僧坏。俱名坏

云何恭敬。恭敬和上阿阇梨上中下座。如是一切善恭敬

云何下意。被摈比丘应行事。不得度人。不得与人受具戒。不得与人依止。不得畜沙弥。不得教诫比丘尼。若僧差作不应受。不得犯余戒。不得违众僧羯磨。不得遮众僧布萨自恣。不得出清净比丘罪。不得遮羯磨(一十)不得教诫性住比丘。不得道说性住比丘。不得使性住比丘忆念罪。不得共性住比丘共坐。常当下意恭敬。当示摈想。众僧一切羯磨不得受。广说十二人(十七)

云何种种不共住。有二种法及食所行事。如摈比丘差别者。一切众僧羯磨不得受。众僧差作亦不得受。广说十二人。若于同梵行所有过罪者。僧应如是语。汝莫不止。僧当治汝系汝罚汝。二犯罪。此僧中忏悔不得出界外。唯此僧能舍汝罪。非界外。如是治不止者。更加其罪。如调恶马以辔制之

云何闼赖吒二十二法成就。名闼赖吒比丘

云何二十二法。精进根本成就惭愧。威仪具足。乐持戒善解毗尼。闻持多闻。通利阿含。善解诤事。善解诤本。善解诤相。善解灭诤。善解灭诤已更不起。善解事辩才无恐畏。身口善能使能受能行。受羯磨不随爱。不随嗔。不随怖。不助二边。受法食财食。是名闼赖吒二十二法

云何实觅罪。先犯罪已发露。后覆藏当与实觅罪。作白四羯磨。所行事如前说

云何波罗夷学戒。若作淫已。乃至刹那不覆藏。诸比丘当与学戒。作白四羯磨。广说如难提学戒。当行学戒法。在比丘下坐授食与比丘。自从净人受食。得共比丘二夜宿。自共未受具戒。不得过二夜宿。若无能作羯磨人。觅不可得者。听学戒人。作二种羯磨。谓布萨自恣羯磨。不得满众作布萨自恣僧羯磨等。云何众僧上座。上座入界内。当教诫年少比丘。慰劳说经授经坐禅。使善法增长。恒使有食。有分食时等分使众得利。作方便求索。当劝化比丘使利益众。应看病比丘。当为病者乞药。当差人看病。当与病人说法。不得舍病者。如是等界内一切事。上座皆悉应知

云何床上座。床名僧伽蓝上座法。若食佉陀尼蒲阇尼。打揵稚时上座应前行前坐。当看诸年少比丘威仪。谁正谁不正。若有不正。当作相使知。若作相不知。语比坐令语知。若比坐不语者。上座起往语。齐整威仪。行食时上座言一切平等。与使唱僧跋。若白衣来当使与食。若无食若彼自不食。上座当为说法。我等正有此食

云何树界枝叶花果相接。乃至一拘卢舍。随意着衣。得至明相出

云何堂前。僧伽蓝有众多比丘。应次第分。若自恼恼他。若两恼应避去。若堂前破坏应治

云何房。若住房中。当以水洒净扫。瞿摩耶涂地。拂拭床卧具有垢者应浣

云何卧具。若比丘露地敷卧具已。出寺门外。五十寻过不得去。若去。突吉罗。若有二比丘。一人取床。一人取卧具

云何户掸。比丘不得闭户作声。开户时先当挠户。当徐徐入。使脚迹不作声。户若有两扇者。不得相振作声

云何户掸。若上下掸者。当俱下已去。使房舍坚牢故防自身故。防卧具故

云何空坊。若空坊无比丘者。当水洒扫地。瞿摩耶涂地。若有器者当净洗揩拭。若有净人当使净草。若有白衣来者。当为说法

云何钵。钵不得着石上土埵上。不得近坑边。食时口中嚼物吐出滓。不得着钵中。不得钵中洗手面。不得着不净地。不得用合沙物洗。不得湿盛。不得极燥。徐徐受用令得久用。因坏更乞难

云何衣。观衣如自皮。不得着僧伽梨担草木。瞿摩耶土水洒地。扫地分粪。瞿摩耶涂地。不得坐僧伽梨上。不得覆身。僧伽梨当作僧伽梨用。郁多罗僧作郁多罗僧用。安陀会僧作安陀会僧用。不得以衣着不净处。着衣不得担。担僧伽梨应割截。成郁多罗僧。安旦婆僧。不必割截。若比丘无新衣。有故衣者。若有长衣。应唱令。若五条七条。九条十一条。十三条。十五条。不得妙色染。若妙色染当坏。以干大皮树皮染。染已受持

云何尼师檀。世尊听诸比丘畜尼师檀。不得用少片物作尼师檀。受持不得离宿

云何针。有二种针。世尊听畜。谓铜铁。好举不得因生。坏更求难

云何针房。为护针故

云何粥。世尊听诸比丘饮粥。饮粥有五种功德。断饥。断渴。断风。消宿食。未熟令熟。歠粥不得作声

云何水瓶佛听诸比丘畜水瓶。令清净。不得用盛食器用作水瓶

云何澡罐。世尊听诸比丘畜燥罐。使令清净

云何瓶盖。世尊听诸比丘以物覆瓶口

云何水。比丘使令水清净。好用意漉水。好看水勿有虫。净洗手着净衣漉水。不得不净衣手漉水

云何饮水器。世尊听诸比丘畜饮水器。令净洁

云何食蒲阇尼。有五种。若食一一蒲阇尼时。当观食。此食从何处来。从仓中出。仓复何因。仓从地出。地复何因。以粪尿和合种子得生。今复还养粪身。举抟时作粪想。正念在前。不以散乱心啖食。当作逆食想。从他得想。病想。因缘得想。然后食。当复观不别众食。复应观自恣不自恣

云何食时。若食五正食时。打犍捶时。当齐整衣服。威仪严政。入众时不得作语声

云何食。不长取与他。除与父母兄弟。客来至寺。病者怀胎母人。正念已当与食。应与畜生一抟。欲出家者。于众有益者与

云何受食。当一心受食。不得散乱心。正念受食。如所食。如所取

云何乞食。广说如毗尼

云何请食。比丘请食不得杂好覆。勿以不净污。当知时

云何阿练若比丘。阿练若比丘常当美语含笑。在前不皱眉。畜净水瓶盛满水。畜火珠月珠

云何阿练若上座。阿练若上座当教诫年少比丘说法。以阿练若法教诫。使阿练若法增长

云何聚落。聚落中比丘如前说。白衣来当为说法。随力所能

云何聚落中上座。聚落中上座如前说

云何客比丘。若客比丘来。当在现处默然立。齐整威仪如前说

云何客上座。客上座当观伴比丘。遣使白旧比丘。求房卧具

云何行。明日欲行。当白和上阿阇梨。我向某方某国去。若听去者去。不听者不得去。所住房当洒扫涂治卧具。当拂拭已去

云何行上座。行上座比丘当观年少比丘。使年少比丘先去上座后去。于中勿有所忘。教诫年少比丘。勿令掉戏。当求觅商伴。当观方国。当观住处。当观卧具。当观比丘伴。为同不同。莫中道病痛相弃。不观察而去。随事犯罪

云何洗足。若比丘洗足已。水器空当着水

云何洗足上座。若年少比丘先洗已。与水上座。不得使起。已灌脚故

云何集。若八日十四日十五日。不病应集一处说法

云何集上座。若打揵稚上座前行前坐。须臾默然已。当自说法。若自不能。当使余比丘说。若白衣来。当为说法。若外道来。为说法摄取至心说。不以自大自高

云何说法。若比丘说法者。当敬众爱众。下意至诚为说。义味具足不心意散乱。慈悲愍念欢喜为说。不为饮食。次第为说。当敬法为法说法。不为财利

云何说法上座。当观说法人。为说法说非法。说非法者当谏。误者为正。若说法当称誉赞叹

云何非时。若欲行时。当白和上阿阇梨。我欲行至某处某聚落。白已便去

云何非时僧集。除八日十四日十五日。诸余集时僧所作事。若有所分打揵椎时。速集速坐

云何非时集。上座打揵椎时。上座在前行在前坐。当如法。如毗尼。如佛教行

云何呗。王舍城诸外道八日十四日十五日。集一处呗诵多得利养。眷属增长。尔时瓶沙王信佛法僧。往诣佛所。白佛言。世尊。诸外道八日十四日十五日。集一处呗诵多得利养。眷属增长。愿世尊。听诸比丘八日十四日十五日集一处说法呗诵。当得利养。眷属增长。诸檀越得福。诸比丘辩捷摄佛法故。正法久住故。佛言。听诸比丘八日十四日十五日集一处呗诵说法。诸比丘以凡声呗诵不适众意。众言。佛听诸比丘好声呗诵者好。乃至佛言。听诸比丘好声呗诵。诸比丘复以下声呗诵。诸众不闻。众言。佛听立呗诵者好。乃至佛言。听诸比丘立呗。诸比丘长诵修多罗竟。众言。佛听诸比丘略诵要者好。乃至佛言。听诸比丘略诵要义。诸比丘略诵心生疑悔。我等莫退失修多罗去。乃至佛言。当于中取要义者。说余修多罗。持莫忘失。诸比丘半呗。佛言。不得半呗。半呗者。突吉罗。诸比丘两人共呗恼众。佛言。不得两人共呗。共呗者。突吉罗。诸比丘各将众去。佛言。不得将众去。将去随事犯。不犯者。自去。不为法故去。又复诸比丘说法中自活。佛言。不得说法中自活。若众中无能诵呗。当次第差。若都无者。各诵一偈

云何不呗。于中有能者请说。请而不说。犯偷罗遮

云何求安居。欲安居时。当好筹量已安居。此住处得同意不。安乐住不。共语共坐不。复有随病饮食易得不。病时医药可得不。有看病人不。有持修多罗。毗尼。摩得勒伽阿毗昙不。比丘无有斗诤相言不。众僧不破不。如是筹量已安居

云何安居。安居中无事。不得出界一宿。若有事当受七日法。或为偷婆。或为和上阿阇梨病。或为法。如是等因缘听出

云何安居上座。安居上座当知僧坊禅窟破坏者。当使修治劝化料理

云何过安居竟。过安居竟。有三业。谓衣器迦絺那衣。安居中得不得。用作迦絺那衣

云何众。比丘当观众。谁善威仪。谁恶威仪。有恶威仪者当折伏。刹利众乃至居士众

云何入众。如是入刹利众。如是入婆罗门众。如是入沙门众。如是入居士众。如是行如是住。如是坐如是语。如是默然

云何安居中。安居中比丘不得种种世间语论。谓国事大臣斗战胜负。畜生饿鬼。男女淫欲饮食等事

云何安居中上座。安居中上座当观众安乐不。安乐者默然。不安乐者。随顺说法

云何布萨。布萨有五种。说不说。与清净。自恣。布萨事。广说如布萨

云何说戒。说戒有五种。广说如前

云何说戒者。说戒比丘当使利次第说。莫使文句脱失。当自观身。从前十五日来犯戒。不犯戒者。得同意即忏悔。不得同意心念。得同意当悔。如波罗从木叉修行

云何说戒上座。若打揵椎时。自观身不犯戒耶。若犯戒。如前说

云何上座。上座比丘当观年少比丘。年少比丘在大小行处。当看莫令作犯戒事。若打揵椎时。在众上座

云何中座。中座比丘随上座入聚落。若上座大小行未竟。小远当待。若不出而远去者待来

云何下座。下座比丘食时应出食。若行水时观早晚待上座。应扫地瞿摩耶涂。敷卧具与水食。食旦钵那时。复行水应请食。应浴室中然火取水。应取樵着浴室中。取油瞿摩耶土屑。水受揩身为揩身。当弃除粪。一切重事悉应作

云何浴室下声。入浴室整威仪

云何洗浴。世尊听比丘洗浴。洗浴有五种功德。如契经说。复有五种功德。谓除风除冷除热除垢起厌患。浴时白和上阿阇梨。浴时在上座后坐。不得在前。向火令水调适。若冷热应语他。不白和上阿阇梨。不得为他揩身。身亦不得受揩。若和上阿阇梨相嫌处。不得亲近。浴室中坐物瓮器应举置本处。广说如毗尼

云何浴室上座。浴室上座下座比丘先浴已汗出。不得使起。云何和上。和上当教诫弟子诵经。教义摄。教令坐禅。教离恶知识。使亲近善知识。复与衣钵卧具医药。摄取犯戒。教使悔过

云何弟子。弟子应惭愧和上。应承事看视。所作应白。应在和上前现相处立。行时随逐。当为和上求衣钵等。如前为弟子说。若善法不增长者应语和上。与我某甲比丘和上。应观是比丘。此比丘行云何眷属。云何能教诫。不如是筹量已使去。若彼复不增长。复应去

云何阿阇梨。广说如前

云何近住弟子。广说如共行弟子

云何沙弥。亦如共行弟子。差别者。沙弥应净花果杨枝草已使令作净

云何治罪。若比丘犯罪当作方便。问令彼自说。若不自说者。不得即出罪。先当觅伴。若王若王子。若王臣有大力者。得伴已。然后出彼罪。云何后行比丘。后行比丘不得在前行。不得前坐。不白上座。不得语。问时当语上座。语时中间不得作乱语。上座说非法时当谏。说法者随喜。得如法利养当取

云何入家。比丘入白衣家。不得调戏。不得举眼视

云何入白衣舍。比丘失念入白衣舍。有五种失。不白入坐。食家中坐。屏覆处坐。别众食无净人。为女说法。正念者无此过

云何入家坐。入家坐比丘不得说畜生国土饮食等。当为说法。令入正见。行布施。调伏诸根。修梵行。布萨受戒三归

云何白衣家上座。白衣家上座当教诫年少比丘。勿使调戏

云何共语旧住比丘。客比丘来先意问讯。善来善来。软语爱语。含笑现前。不皱眉见。客比丘来当欢喜。问道路不疲耶。饮食不失时耶。不大疲极耶。当问几腊。若是上座起作礼。取衣钵敷座。为洗足取水。随力所能供养。与好卧具

云何消息。若客比丘至寺不应便求房舍卧具。且坐一处默然。齐整威仪

云何空中。空中一切羯磨不得作。比丘不得空中行。除明相出。安居中除受七夜

云何迦絺那。若比丘受迦絺那有七利。随意畜衣。不着僧伽梨入聚落。别众食。数数食。不白入聚落。迦絺那功德利。着缦衣入聚落

云何经行。比丘经行时有上座在前者当白。不得摇身行。不得大驶驶。不得大低头缩。摄诸根心不外缘。当正直行。行不能直者安绳

云何漉水囊。无漉水囊不得远行。除江水净除涌泉净。除半由延内。若半由延内寺寺相接。不持漉水囊。不犯

云何下风。下风出时不得作声

云何入厕。比丘入厕时。先弹指作相。使内人觉知。当正念入。好摄衣好正。当中安身。欲出者令出。不肯出者勿强出

云何厕边。比丘不得厕边浣衣割截衣缝染衣。不得捉经。不得诵经。不得作白。不得经行。一切事不得作。除厕相连

云何厕屐。比丘当徐徐蹋上。不得污屐

云何厕。上坐年少比丘先入。不得使出

云何洗。若比丘不洗大小便。不得礼拜受礼。不得坐卧僧卧具上。除无水处。若为非人所嗔。水神嗔。或服药

云何大行已洗手处。洗手处边不得浣衣等。如前说

云何洗处。洗处屐徐徐洗。不得污湿屐

云何小便。比丘不得处处小便。应在一处作坑

云何小便处。近小便处。不得浣衣等。如前说

云何小便屐。比丘徐徐小便。不得污湿屐

云何小便上座。下座比丘已小便。不得使起

云何筹草。不得利刮。不得用草拭。用细软滑物。若用石木

云何唾。唾不得作声。不得在上座前唾。不得唾净地。不得在食前唾。若不可忍起避去。莫令余人得恼

云何器。世尊听诸比丘畜二种器。熏钵器。唾器。当好守护。勿令破坏。妨废更求难

云何齿木。齿木不得太大太小。不得太长太短。上者十二指。下者六指。不得上座前嚼齿木。有三事应屏处。谓大小便嚼齿木。不得在净处树下墙边嚼齿木

云何扬齿。不得太利。不得疾疾刺齿。间应徐徐挑。勿使伤肉

云何刮舌。不得用利物刮。不得疾疾刮。当徐徐勿使伤舌

云何挑耳。不得用利物挑。不得疾疾挑。勿令伤肉

云何威仪。一切沙门所生功德是威仪。与上相违。名不威仪

云何三聚。谓受戒聚。相应聚。威仪聚

佛说摩得勒伽善诵竟

萨婆多部毗尼摩得勒伽卷第六萨婆多部毗尼摩得勒伽卷第七

        宋元嘉年僧伽跋摩译

如佛所说。边地律师五人受具戒。若有十人律师五人受戒。得戒不。佛言。得具戒。诸比丘得呵罪。如佛所说。过十夜衣。尼萨耆。云何得长衣。谓若入手若在膝上肩上作想。此是我衣。比丘得眠上座卧不。佛言。应敷卧具已坐卧故者。不犯。如世尊所说。不得捉牛尾渡。得捉余尾渡不。佛言。除虎尾象马师子尾。捉余尾渡。不犯

糖浆得七日受不。答得饮。几时饮乃至未舍自性。以不净药合煮得啖不。答不得。得涂身涂疮灌鼻。以不净脂合盐煮得啖不。答不得。若当猪脂用不犯

若比丘五种种子自手作净。若刀若爪成净不。答成净。得食不。得食。除火净。若火净杀草。得波夜提。树在不净地。果落净地得食不。不经宿得食。树在净地果落不净地。得食不。答不得。净人在不净地。不净地作净成净不。答成净。得食不。得食。除火净

净人在不净地。净地作净。成净不。成净。得食不。得食。除火净。得食鳝肉不。不得。得饮人乳不。不得。得着眼中苏毗罗浆。非时得饮不。病者得饮。一切不净肉不得食。得食人肉不。不得食。食者得何罪。犯偷罗遮。除人肉。余不净肉得食不。不得食

云何不净肉。谓鳝蛇虾蟆乌鹊白鹭。如是等肉不得食。食者突吉罗。即日受时药七日药终身药。各各相杂得服不。不得服。时药时服。乃至终身药终身服

时药得作非时七日终身药耶。广说如前。若药不手受不说受不病得服不。不得服。时药非时药七日药终身药。不手受不说受。经宿得服不。不得服。已手受说受内宿得服不。不得服。手受说受病者得服

云何养病除性罪。余者养病。世尊听饮八种浆。几时饮。乃至未舍自性得饮

狂人边得取衣不。或得或不得。云何得。不知父母所在兄弟姊妹。自持物施比丘得取

云何不可取。父母等可知。不自手与。不可取

狂人边说。受持衣成受不。不舍自性成受。若比丘独住。有人施现前僧。可分衣。无余比丘。此衣当云何。彼比丘得衣时。心念口言。我此住处得是衣。现前僧应分。此中无僧。此衣属我入我。我当受是衣。当割截缝染。我当受持。如是作羯磨已。若有比丘来不应与。若未作羯磨时来者应与。不与者。犯突吉罗

若有比丘得衣与众僧。界外自取。突吉罗。若恣心取随事犯。二人众多亦如是。长者儿被驱布施。得取不。不得取

有衣与自恣僧。自恣僧应分。若施现前僧。现前僧应分。安居中为僧故。出界外者得物应分。破安居人得衣分不。或得或不得。若前后安居已破者应得。前后不安居者不得。看病人出界去。后病者死。应与衣不。有应与不应与。为病者去应与。为自去者不应与。白衣看病应与不应与。应与少许比丘尼。式叉摩尼。沙弥沙弥尼。亦如是。余处安居余处看病。病者死应与衣。不应与沙弥。看病应尽与。为少与。应尽与。或等与。若无看病人僧尽应看。若不看。犯突吉罗。若差看不看。犯突吉罗。病人不用看病人语。突吉罗。看病人不用病人语。突吉罗。若人施不净物作是言。我等不得用不净物。作是念已。施某甲净人。得净者当受

有比丘四处安居。成安居不。若以床木四界安居。何处应得安居。衣分共与一分。减量作雨衣受持。突吉罗。覆疮衣亦如是。畜三种外道衣。谓皮衣毛衣发衣。偷罗遮。除此三种。畜外道余衣。突吉罗

如世尊所说。故衣不得受作迦絺那衣。云何故衣。谓先已受作迦絺那衣

世尊所说。新衣受作迦絺那衣。云何新衣。初受作迦絺那衣。名新衣。如世尊所说。发三心受作迦絺那衣。云何三心。谓乃至最后发三心。谓浣时截时染时。不发此三心成受迦絺那衣。不成受。犯突吉罗。成已复应发二心。此衣当为僧受作迦絺那衣。我已受是迦絺那衣。不发二心。成受不成受。犯突吉罗

如佛所说。经宿衣受迦絺那衣。不成受。云何经宿。谓过十夜。或经一夜

如世尊所说。不净衣受迦絺那。不成受。云何不净衣。谓频日得衣

如世尊所说。故衣受作迦絺那衣。不成受。云何故。比丘受用三衣。如世尊所说。被打衣成受迦絺那衣。云何打衣。谓新衣。如所说打净

衣成受迦絺那。云何打净。谓坏色衣未受迦絺那时。僧坏为二众。一众受。一众不受。二众成受不。受者成受。不受者不成。受已受迦絺那衣。僧坏为二部。一众舍。一众不舍。成舍不。舍者成舍。不舍者不成舍。若僧破时。谁应受。谓如法者。应受未成衣受作迦絺那衣。不成受。成者受成受

受迦絺那住处有十利。广说如毗尼。着僧伽梨入聚落有五功德。雨衣亦如是

如世尊所说。住处利。云何住处利。谓得衣利。名住处利。如世尊所说。急施衣得受作迦絺那衣

云何急施衣。谓十日未至。自恣得衣。是急施衣。用是作迦絺那衣受成受。如世尊所说。三月得衣。得受作迦絺那衣

云何三月衣。旧僧十五日自恣。客比丘来多同见同住。彼十四日自恣。若旧僧随客比丘自恣。此日得衣。名三月得衣。用是衣作迦絺那衣。受成受。如佛所说。时衣得受作迦絺那衣

云何时衣。自恣竟后一月得衣。是名时衣

如佛所说。不净衣不得受作迦絺那衣。云何不净衣。谓死比丘衣。五种人受迦絺那衣。不名受

云何五。谓无腊人。破安居人。后安居人。余处安居人。摈人。八种舍迦絺那衣。几共几不共。除后二种。余者不共。问有即日受迦絺那衣。即日舍不作白羯磨耶。旧比丘十六日受迦絺那衣。客比丘来多相向说舍

云何破僧。得无间堕阿鼻地狱。非法非法想。破僧或破僧一切受法耶。或受法一切破僧耶。答或破僧非受法作四句

云何破僧非受法。若破僧不受十四事。云何受法非破僧。谓受十四事。俱者亦受十四事亦破僧。非受十四法非破僧。除是句。僧坏时舍界成舍。不法语者舍成舍。僧坏时比丘尼得作布萨不。得作布萨

僧破时闼赖吒比丘当云何。当在如法众。不得遣信。至第二众僧坏时。教诫比丘尼。不如法语者应教诫。无法语者不应教闼赖吒。应出界外教诫。若比丘随顺摈比丘。犯突吉罗。被摈人为独为有伴耶。独无伴侣。被摈人不得共食。若不知被摈共食共住。不犯。受法比丘共不受法比丘共食不犯。不受法比丘共受法比丘共食。犯突吉罗。四人随顺破僧。是名破僧。如佛所说。如是比丘不得摈。云何如是比丘。若比丘有大威德。持修多罗。毗尼。摩得勒伽。多闻多知识多眷属。摈如是人。犯偷罗遮。有信乐比丘。应出罪。云何信乐。若闻若信语。使忏悔。若不忏悔。犯突吉罗。若僧坏谁应舍迦絺那衣。法语者应舍

被摈人下意随顺调伏。应舍羯磨。不应舍羯磨。同意比丘应与卧具。云何同意。寂静不相恼。名同意。毗耶离俱舍弥。比丘集一处。闼赖吒当云何闼赖吒应出界外作布萨

俱舍弥毗耶离比丘共布萨。成布萨不。不成布萨。若闼赖吒比丘共毗耶离比丘共布萨。成布萨不。成布萨

若比丘应与比丘尼求教诫欲。云何与教诫欲。语言姊妹等和合作布萨。若作布萨。僧破建立为二部。应与比丘尼教诫不。应与。应何处教诫。应出界外教诫。如佛所说。非法不和合。非法和合。如法不和合。如法和合

云何非法不和合。应与苦切羯磨。与摈羯磨。僧复不和合。云何非法和合。应与苦切而与摈羯磨。众僧和合。云何如法和合。先作白。后作羯磨。僧和合与上相违。名法不和合。一比丘摈一人。众多摈四人。犯突吉罗。四人摈四人。犯偷罗遮。摈比丘时眠成摈不。若闻白已眠成摈。先眠后白。不成摈。应余羯磨。出比丘罪。余羯磨摈比丘。犯偷罗遮

若摈比丘时不来者。应取欲。云何到羯磨。四比丘清净共住。乃至二十人亦如是。若沙弥欲与受具戒时。莫与我受戒。为得戒不。得戒。式叉摩那沙弥尼亦如是。受具足戒时。别住时。本日时。摩那埵时。阿浮呵那时。十二人时。亦如是。僧摈眠人成摈不。若闻白成摈。不闻不成摈。入灭尽定人亦如是。僧破各各相摈。不成摈。若非法羯磨。一切不和合羯磨耶。若不和合羯磨。一切非法羯磨耶

云何和合非法羯磨。谓不现前摈比丘不出己罪。不使自言。不在界内而一切集不来者与欲。是和合非法羯磨

云何如法羯磨非和合人现前。如前说。众不和合。是如法羯磨非和合。或僧中三唱。忆有罪不发露。一切犯罪耶。若三唱忆有罪不发露。一切犯罪。若有僧中三问。自言非比丘。是自言非比丘波罗夷。亦如是。别住人摈比丘。成摈不。成摈。唯除受戒羯磨。余羯磨尽得作。先白众僧摈比丘。成摈不。成摈。若一若僧不知而摈比丘。犯偷罗遮。彼罚比丘下意调伏应舍不。应舍。一语与二人受戒。得戒不。不得戒。一语与四人受戒。得戒不。不得戒。受欲满四人摈比丘。成摈不。不成摈。贼住满众亦如是

应作苦切羯磨而作驱出羯磨。成作不。成作。舍苦切羯磨。即舍驱出羯磨。苦切羯磨。摈比丘成摈不。成摈。驱出羯磨有何义。谓比丘常犯戒。不止不与依止。苦切羯磨有何义。若比丘斗诤不止。众僧语言。若不止者。更加汝重罪。摈羯磨有何义。若比丘污他家不得住。发喜忏罪有何义。若比丘失檀越意。众僧语言。若不忏悔。檀越更加汝罪。有一事摄一切毗尼。谓律仪。有一事不摄一切毗尼。谓非律仪。有一事摄一切犯戒罪。谓非律仪。有一事不摄一切犯戒罪。谓律仪。有犯一事得大罪。谓破僧。复有一事得大罪。谓恶心出佛身血。复有一事得大罪。谓诽谤贤圣。复有一事得大罪。谓随顺破僧

复有一事得大罪。谓诽谤如来贤圣众。有一非法遮说戒。谓无根。有一杀生得大罪。谓杀辟支佛。复有一事得大罪。谓盗僧物。复有一事得大罪。谓淫阿罗汉比丘尼。又复妄语得大罪。谓空无说过人法。有二犯罪。谓不善无记。复有二犯罪。谓有余无余。复有二种口犯罪。谓不善无记。又复二种犯罪。谓身不善无记。复有二种犯。有余罪。谓不善无记。复有二种犯无余罪。谓不善无记

复有二种犯罪。谓隐没无记。不隐没无记。复有二种犯罪。谓障碍不障碍。复有二种犯罪。谓共不共。复有二种犯罪。谓比丘共比丘尼。比丘尼共比丘。复有二种犯罪。谓比丘共式叉摩那。式叉摩那共比丘。沙弥沙弥尼亦如是。复有二种犯罪。谓比丘共优婆塞。优婆塞共比丘。优婆夷亦如是。有二一切时犯罪。谓佛在世灭度后。有二犯罪。谓国土摄方摄。有二犯罪。谓轻重。有二犯罪。谓应出不应出。有二犯罪。谓出家入家。有二犯罪。谓可忏不可忏。有二犯罪。谓制开。有二犯罪。起不起。有二犯罪。谓终身暂时。有二犯罪。谓坏不坏。有二犯罪。谓轻重。有二犯罪。谓有余无余

有二犯罪重。有余无余。有二犯罪。谓偷罗遮悔。白衣有二犯罪。忏悔心悔。有二犯罪。谓有报无报。有二犯罪。谓入众一人。有二犯罪。谓巧方便不犯罪。不巧方便犯罪

有二惭愧。谓所望无所望。有二僧断事。谓作羯磨不作羯磨。有二断事。谓僧差不差

有二僧断事。谓软语粗语。有二断事。谓说者听者。有二断事。谓时时说。非时非时说。有二僧断事。分明不分明。如是决断不决断。有二断事。有恩无恩。有二断事。谓有慧无慧。有二断事。谓羺羊恶口。非羺羊恶口。有二断事。谓多闻不多闻。有二断事。谓利阿含。不利阿含。有二断事。谓善解不善解。有二断事。谓如法不如法。如是时非时。知量不知量。有二诽谤如来。谓非法说法。法说非法。有二犯罪。谓作无作。有二调伏。谓摈毁呰。有二诽谤如来。谓有信恶解。无信嗔恚。相违则白法。有二罪。谓恶戒恶见。有二苦切。谓众罚私罚。有二驱出。谓罚僧和合。有二别住。谓犯戒别住。外道别住。有二本日。谓罚令戒具满

有二摩那埵。谓罚调伏。有二扫地。谓罚善心。有二清净。谓作清净无作清净。有二诤比丘。比丘尼诤比丘。乃至沙弥尼亦如是。有三犯罪。谓贪生嗔生痴生。有三身犯罪。谓贪生嗔生痴生。有三口犯罪。谓贪生嗔生痴生。有三非比尼。谓贪生嗔生痴生。有三比尼。谓贪比尼嗔比尼。痴比尼。有三法摄一切罪。谓因缘制分别。有三羯磨摄一切羯磨。谓白羯磨。白二羯磨。白四羯磨。有三羯磨。谓僧羯磨。闼赖吒羯磨。布萨羯磨。有三学。谓增上戒。增上定。增上慧。复有三学。谓威仪比尼波罗提木叉。有三犯罪。谓身口意。有三诤。谓善不善无记。有三业。谓法非法似法。有三因缘僧破。谓闻取筹建立二部。有三应灭。谓犯罪自言自言犯罪。有三供养。谓如来阿罗诃三藐三佛驮上座同梵行。有三受供养。谓如来上座同梵行

有三应起迎。谓如来上座同梵行。有三人应礼不礼犯罪。谓和上阿阇梨众。别住法语者不礼三人无罪。谓不共住人别住人下座。有三使。谓僧使。私使。波罗提木叉使。复有三使。谓僧使。五部使。王使。复有三使。谓和上使。阿阇梨使。优婆塞使。又复三使谓和上使。阿阇梨使。上座使。有三自恣。谓请自恣。数数自恣。常自恣

又复三自恣。谓与欲自恣。清净自恣。心自恣。有三自恣。谓衣自恣。食自恣。药自恣

有三制。谓因缘起制罪。教诫制罪。摄受制罪

有三羯磨。谓僧羯磨。施主羯磨。财物羯磨

有三建立。财利建立。人建立。界建立

有四知。谓知犯。知不犯。知清净。知不清净。复有四种清净。见清净。忏悔清净。教诫清净。出罪清净。复有四不止。贪不止。恚不止。痴不止。贪恚痴不止。复有四止。贪止。恚止。痴止。贪恚痴止。复有四众。谓除须发众。秽浊众。智慧众。斗诤众。复有四因缘故。世尊听诸比丘服药。缘事故。随国土故。时故。人故。复有四种药。谓不净净用。净不净用。不净不净用。净净用

复有四事。如来制伏弟子言。莫作制伏求罪。为法久住故。复有如来四境界。谓智境界。法境界。人境界。神足境界。此四境界中如来制戒。谓智法人神足境界如是制毗尼。制波罗提木叉。修多罗。阿毗昙。咒术究竟。毗尼集。毗尼发露罪。忆念罪。讥嫌罪。国土罪。清净与清净受。清净说清净自恣。自恣人自恣羯磨。与自恣。受自恣。说自恣。遮自恣。苦切羯磨。驱出羯磨。摈羯磨。忏悔羯磨。与受具足。不与受具足。得具足不得具足。依止与依止说。依止受依止。依止清净。非法羯磨。如法羯磨。似法羯磨。毗尼羯磨。非毗尼羯磨。和合羯磨。不和合羯磨。可转羯磨。不可转羯磨。和上阿阇梨弟子礼拜。同意忍辱。忏悔使忏悔。正顺舍一切羯磨。如是等亦在是四境界时。谓智法人神足境界时。有五因缘。受羯磨。谓自作羯磨。余作羯磨。现前随喜。与欲出罪。复有五苦切事。谓我当此僧中说汝罪。余僧中说汝罪。我当说汝某甲罪。我当牵汝至僧中。我当必定举汝罪。如是种种呵责已去

复有五法成就举罪。谓真实不虚。时非不时。慈心非嗔恚。软语非粗言。利益非不利益。复有五种。谓苦切驱出牵忏悔不见摈

复有五种。成就比丘不生优婆塞敬信。谓毁呰佛法。僧无威仪。不学比丘戒。余亦如是

复有五事持律比丘受诤者。先当内观五法。善思量已。然后受诤。何等五。我精进不。我不犯戒不。清净不。多闻不。善解毗尼不。不与恶徒众相染不。得伴不。如毗尼如佛所说不。如是思量。已应受诤

复有五持律比丘。不应僧中灭诤。谓恐怖恼他语。久重语。语不可众意。与是相违应受诤

复有五事。持律比丘不应僧中灭诤。谓受恶比丘语。受误语。不三问恶比丘。与是相违应受诤。复有五事。持律比丘不应僧中灭诤。谓不解自语。不解他语。不乐他语。不乐自语。不多闻。与是相违应受诤

复有五事。持律比丘不应受诤。谓不求请。专执不善解诤事。不知诤。不知诤灭。与是相违应受诤。复有五事。持律比丘不应受诤。谓不求请上座。痴无解。不多闻。不知毗尼。无眷属。不恭敬僧。上中下座。及闼赖吒

复有五事。持律者能灭诤。谓上座或是中下座。待谓。不恭敬比丘能驱出。能齐整僧众

复有五事。成就闼赖吒比丘。应摈应驱出毁呰。令生忧恼制伏。何等五。谓若闼赖吒比丘。持恶戒。犯戒邪见。不多闻。不知毗尼。无惭愧。无知众为眷属。助恶比丘众

复有五事。比丘应断事。敬众慈心软语。知坐处能坐。断事时知自坐处。当自为说法。若自不说。当请能者为说。善说者应赞

复有五事。比丘当行。谓心如扫彗。僧中心平等。不憍慢。不僧中说国土。及诸恶语

复次如法僧中随顺。有罪应悔。无罪默然。莫与僧作异众

复有五种大贼。谓百人百众围绕。第一大贼。用四方僧物持与他。第二大贼。自言我是阿罗汉。第三大贼。如来所说甚深空义。而言我说。第四大贼。比丘犯戒。不精进行恶法。脓血内流空形蠡声。非沙门自言沙门。非梵行自言梵行。若将百众二百乃至五百人围绕。游行城邑聚落。受诸供养。是第五大贼

复有五种劫。谓强夺取。软语取。苦切取。受寄取。施已还取

复有五种不应开通。无惭愧。不软语。不多闻。欲举他罪。不求清净

复有五种。不应施于中作福想。谓施女人。施斗牛。施酒。施画男子像。施伎乐声

复有五因缘。不得至布萨前。谓王难贼难火难水难腹行虫难。复有比丘到白衣舍五种失念。谓不白入聚落。不看坐处坐。共女人屏处坐。无净人为说法过五六语。不手按而坐

复有五种过。谓见女人。见已共语。共语已亲近。亲近已起恶念。起恶念已于重戒中随犯。不知犯前后戒。不乐修梵行

复有五法成就。使弟子忏悔和上谓不亲近和上。无惭愧。不念和上。共和上诤。不恭敬。不以法摄和上。财摄和上。若忏悔者善。不悔者随事犯。与上相违应受悔。若不受随事犯。阿阇梨近住弟子亦如是

复有五种差别。佛差别。法僧差别。羯磨差别。道差别。相违不差别。复有五种差别。佛差别。和上差别。阿阇梨差别。羯磨差别。法差别

复有五因缘摩触身犯僧伽婆尸沙。谓人女有淫心。修习衣内摩触。有六诤本。如增一中说。有六种使命。谓僧使。诸部使。和上阿阇梨使。上座使。王使

复有六事。优婆塞不应作。谓压油。猩猩。血染。沽酒。卖肉。卖刀杖

复有六种自恣。谓比丘等自恣。比丘尼等自恣。二部僧自恣。食自恣。清净自恣。自恣第六

复有六种坏。谓自坏。他坏。戒坏。见坏。威仪坏。命坏。与上相违名六成

复有六爱敬。谓身业慈。口业慈。意业慈。贤圣共戒。贤圣同见。如法所得衣钵之余施同梵行

复有六种劫。五种如前说。劫法第六

复有六法现前。名得具戒。谓佛现前。法僧现前。和上阿阇梨现前。受戒人现前

复有六种法。于法中难满足。谓多欲。难满。难养。不知足。不孝顺。多疑。不求究竟。与上相违名易满足。有七财。谓信财。戒财。施财。闻财。慧财。惭财。愧财

复有七力。谓信力。戒力。施力。慧力。惭力。愧力

复有七法。谓色苦如实知。色习如实知。色灭如实知。色道如实知。色爱如实知。色过如实知。色离如实知。受想行识亦如是

复有七方便。谓不净观。安般念。四念处。暖法。顶法。忍法。世间第一法

复有七宝。谓金轮宝。象宝。马宝。女宝。摩尼宝。主藏宝。主兵宝

复有七觉宝。谓念觉宝。择法觉宝。精进觉宝。喜觉宝。猗觉宝。定觉宝。舍觉宝

复有七灭诤法。谓现前毗尼。忆念毗尼。不痴毗尼。自言毗尼。觅罪毗尼。多觅毗尼。布草毗尼

复有七种衣。谓旃衣。麻衣。纻衣。俱脂衣。俱舍耶衣。劫贝衣。刍麻衣

复有七种退法。谓不敬佛法僧戒放逸不敬禅定

复有七种增进法。谓敬佛敬法敬僧敬戒不放逸敬禅定

复有七种制伏。谓某处不应往。莫亲近某人。莫依某处。莫至某聚落。莫行某道中。莫至某家。莫共某甲人语

复有七种不信。如契经说

复有持律比丘。有七种功德。谓比丘所敬。比丘尼所敬。不随顺使随顺。持佛密藏称扬佛法。善解法相善能教诫。以持律故。一切沙门婆罗门顶戴供养。复有七种持律。谓毗婆尸。式弃。毗湿婆。迦罗鸠孙陀。迦那迦牟尼。迦叶。释迦牟尼

有八种功德。谓界功德。事功德。依止功德。僧制功德。僧施功德。安居功德。施四方僧功德。第八指示功德

复有八种舍迦絺那衣。如毗尼说

复有八种屐不得着。谓草屐。芒屐。迦尼迦屐。綖屐。木屐。竹屐。叶屐。藤屐

复有三十八法。如修多罗说

问云何破僧。破僧有十四事。谓法非法。广说如毗尼。非一比丘破僧。或乃至八人九人破僧。有二因缘僧破。谓说同受筹

复有八法无根波罗夷法谤僧伽婆尸沙。谓嗔忿恨不乐欲。使成非比丘欲灭已沙门法。自不清净。疑彼虚事。当观彼人。知法举是罪。必生斗诤。相言成异众别离。非解脱因。与上相违应作

复有八法灭贪嗔痴。谓八圣道。如修多罗广说

复有八垢。谓内垢衣垢。财垢食垢。净垢不净垢。摄受垢不摄受垢

复有八法无根遮说戒。谓犯无根波罗夷。广说如毗尼

有九依。谓依佛依法依僧。依和上依阿阇梨依种族。依住处依人依具戒

复有九法灭嗔恚。如修多罗说。无学漏尽阿罗汉比丘。所作已办梵行已立者。不犯事。谓不随欲。不随嗔。不随怖。不随痴。不故夺命。不偷盗。不淫。不故妄语

杀生有十过。如修多罗说。十不善业道。如修多罗说。善业迹道亦如是

复有十摄受。谓衣摄食摄卧具摄药摄。修多罗摄阿毗昙摄毗尼摄。犯罪摄。清净摄。出罪摄。相违则非摄。持律比丘有十利。即此前功德

复有十种障受具足。谓非人。不乞。不作白。减作羯磨。年不满二十。害母。害父。杀阿罗汉。破僧。恶心出佛血。与是相违则非障

复有十种障受具足。谓本犯戒。贼住。非男二根。越济。本不和合。杀父母。阿罗汉。破僧。出佛血

复有十种。谓王难。贼难。水难。火难。腹行虫难。人难。非人难。命难。梵行难

复有十种毗尼。谓比丘毗尼。比丘尼毗尼。具毗尼。少分处毗尼。一切处毗尼。灭贪嗔痴毗尼。灭罪毗尼。灭诤毗尼

复有十种具足出他罪得多功德。谓实不虚。时非不时。软语非粗言。慈心非嗔恚。饶益非不饶益。精进。多闻。持戒。正念。智慧

复有十法成就多得功德。谓意欢喜。尊重。修敬。供养。赞叹无学。戒成就。定慧。解脱。解脱知见成就

复有十法具足多生功德。谓无学正见。乃至解脱解脱知见

复有具足十法。应与出家。广说如增一

复有十种利。谓衣利。法利。僧利。和上利。阿阇梨利。戒定慧解脱解脱知见利

复有十种一味。谓学戒身定慧解脱解脱知见。无学戒定慧解脱解脱知见

若有檀越为僧作房。后回与一人。是非法施。非法受非法用。广说如增一

复有十利。世尊制戒谓摄僧故。极摄故。制伏高心人故。已调伏者摄受故。不信者生信故。已信者增进故。为法久住故。广显梵行故。遮今世恼漏故。后世漏不生故

复有律师利。谓知有罪无罪。应修不修。知作不作。知净不净。心意常明了。四众所供养。不从他受教诫。所以然者。以持律故。护最胜秘密藏故。内外一切沙门婆罗门顶戴供养故。利益多众生故。种无量众生善根故。法得久住故。复有十法。如来制波罗提木叉。如前说

一切毗尼几处所摄。略说三处摄。谓白羯磨。白二羯磨。白四羯磨

问百一羯磨。几白羯磨。几白二羯磨。几白四羯磨。答二十四白羯磨。四十七白二羯磨。三十白四羯磨

云何二十四白羯磨。谓威仪阿阇梨白羯磨。问遮道法白羯磨。布萨时白羯磨。布萨时一切僧犯罪白羯磨。布萨时一切僧疑罪白羯磨。欲自恣时白羯磨。自恣僧犯罪白羯磨。自恣一切僧疑罪白羯磨。自恣时僧中犯罪白羯磨。斗诤时白羯磨。自恣时罪相未定白羯磨。安居时白羯磨。独受死比丘衣白羯磨。分死比丘物白羯磨。舍迦絺那白羯磨。说粗罪白羯磨。尊者陀骠比丘分衣白羯磨。现前毁呰白羯磨。默然恼他白羯磨。羯磨学家白羯磨。舍学家白羯磨。覆钵白羯磨。仰钵白羯磨。是为二十四白羯磨

云何四十七白二羯磨。现前布萨白二羯磨。结大界白二羯磨。结衣界白二羯磨。结小界白二羯磨。狂痴白二羯磨。羯磨自恣人白二羯磨。分卧具白二羯磨。结净地白二羯磨。迦絺那衣白二羯磨。受迦絺那白二羯磨。守迦絺那白二羯磨。忏悔白衣白二羯磨。略说十二种人白二羯磨。闼赖吒白二羯磨。毗由茶白二羯磨。灭诤白二羯磨。行法舍罗白二羯磨。乞房白二羯磨。大房白二羯磨。举罪比丘白二羯磨。上座白二羯磨。舍钵白二羯磨。令白衣不生信白二羯磨。教诫比丘尼人白二羯磨。新波梨卑白二羯磨。不礼拜白二羯磨。不共语白二羯磨。毁众白二羯磨。畜杖白二羯磨。畜络囊白二羯磨。五年得利白二羯磨。遮布萨白二羯磨。式叉摩那二岁学六法白二羯磨。本事白二羯磨。比丘尼生子共房宿白二羯磨。连房白二羯磨。三十九夜白二羯磨。是名四十七白二羯磨

或有说者。一切所作羯磨。尽应用白二羯磨

复有说言。除受具足及阿浮诃那。余一切尽应白二羯磨

云何三十白四羯磨。谓受具戒白四羯磨。与外道四月别住白四羯磨。舍三种界白四羯磨。众僧和合布萨白四羯磨。苦切白四羯磨。依止白四羯磨。驱出白四羯磨。不见摈白四羯磨。恶邪不除摈白四羯磨。别住白四羯磨。服日白四羯磨。摩那埵白四羯磨。服日白四羯磨。阿浮诃那白四羯磨。忆念毗尼白四羯磨。不痴白四羯磨。实觅白四羯磨。破僧白四羯磨。助破僧白四羯磨。游行白四羯磨。随爱随嗔随怖随痴白四羯磨。恶口白四羯磨恶邪白四羯磨。灭沙弥白四羯磨。比丘尼随顺摈比丘白四羯磨。比丘尼染污住白四羯磨。与学戒白四羯磨。是名三十白四羯磨。或有说一切羯磨。皆应白四

此百一羯磨。几与欲。除结界余尽与欲。此百一羯磨。几四人作。几五人作。几十人作。几二十人作。几四十人作。谓除自恣五人。受具戒十人。阿浮诃那二十人。比丘尼阿浮诃那二部僧四十人。余一切四人作

羯磨有何义。谓依事所作故名羯磨。此说何义。所因事名事。随说名羯磨

苦切有何义。谓比丘斗诤。作苦切羯磨。依止有何义。若比丘常犯戒。使依止作羯磨。驱出有何义。若比丘污他家。作驱出羯磨。余羯磨随其义应当知

萨婆多部毗尼摩得勒伽卷第七萨婆多部毗尼摩得勒伽卷第八

        宋元嘉年僧伽跋摩译

    优波离问波罗夷

优波离问佛言。若比丘自咒术力药力。自变作人女共畜生作淫。得何罪。佛言。若自知我是比丘作不可事。犯波罗夷。不自知比丘想。偷罗遮

又问。比丘自咒术力药力。作畜生男共人女作淫。得何罪。佛言。若自知比丘想作不可事。波罗夷。不自知比丘想。偷罗遮

又问。二比丘咒术力药力。作畜生身共作淫。得何罪。如前说

共何等女人作淫。得波罗夷。若一切身可捉共作淫。犯波罗夷。不可捉。偷罗遮

问云何口中作淫。波罗夷。答节过齿。波罗夷

问云何谷道作淫。波罗夷。答过皮节入。波罗夷

问云何女根中作淫。波罗夷。答过皮节入。波罗夷

问女身中破还合共作淫。得何罪。答若入大小便。波罗夷。口中作淫。偷罗遮

问女人头断共作淫。得何罪。答大小便处作淫。波罗夷。口中偷罗遮。穿身分作孔作淫。偷罗遮。烂身作淫。偷罗遮。三疮门烂坏作淫。偷罗遮

问如佛所说。三疮门一一处作淫。波罗夷。颇有一一处作淫不犯波罗夷耶。答有。两边坏入。偷罗遮。屈入。偷罗遮

问如佛所说。共活女疮门不坏作淫。波罗夷

云何活女疮门不坏。答若两边等不坏。是名不坏。云何活女疮门坏。若疮门两边坏或烂堕。如生女。死女亦如是。如人女。非人女亦如是。共男子黄门作淫。亦如是。共畜生女男黄门作淫。亦如是

有比丘共熟猪母作淫。偷罗遮

问颇有比丘独在一房作淫得波罗夷耶。答有。谓根长

问有比丘。女身中破合已作淫。得何罪耶。答若合处际现。偷罗遮。合处不现。波罗夷

问颇有比丘。女根截已作淫。得何罪。答得偷罗遮。男根触女根。突吉罗

问如佛所说。有间有间作淫。波罗夷。颇有比丘有间有间作淫不犯耶。答有。多以衣裹皮囊竹筒作淫。偷罗遮

问颇有比丘共女人作淫不犯波罗夷耶。答有。本犯戒。本不和合。贼住。污染比丘尼。犯突吉罗

问若比丘眠中共作淫犯何罪。答若知比丘想。波罗夷。若不知比丘想。偷罗遮

问若比丘二八十人中取分得何罪。答偷罗遮。彼作妄语。波夜提。若分物已满。波罗夷。不满。偷罗遮

问如佛所说。取重物离本处。波罗夷。颇有比丘取重物离本处不犯耶。答有。谓轻物

问若商客。语比丘言。大德。汝等出家人不输税。为我度税物。得何罪。答若许未度。偷罗遮。若作方便。突吉罗。若商客未至税处。示余道随语去。偷罗遮。商客未至税处。语比丘言。与我度税物。若许未度税处。突吉罗。度税处满。偷罗遮。商客未至税处。语比丘言。与我度税物。与汝半税直。比丘为度满。偷罗遮。商客语比丘。与我度税物。税直都与汝。比丘为度满。偷罗遮

商客到税处语言。与我度税物。比丘为度物直五钱。波罗夷

商客到税界语比丘言。与我度物。税直半与汝。比丘为度满。波罗夷。商客语比丘。为我度税物。税直尽与汝。比丘为度满。波罗夷

问如佛所说。取重物离本处。波罗夷。颇有取重物离本处不犯波罗夷耶。答有。商客以税物盗着比丘钵囊中若衣囊针囊中。比丘不知度税处。突吉罗。若比丘口中度税物满。偷罗遮。若比丘度不可称量物。波罗夷。度可称量物。偷罗遮。不可称量物。谓物少价直不可量。若余处度。偷罗遮

问如佛所说。五种劫。谓偷取。软语取。苦切取。寄取。偷法。此五种偷何者犯波罗夷耶。答除偷法。余犯波罗夷取。佛舍利有主。若为自活偷满。波罗夷。不满。偷罗遮。若增恶取。彼我俱无。偷罗遮。若为供养故。佛是我师。我应供养。满五钱。突吉罗

问若比丘偷经物。得何罪。答满。波罗夷。不满。偷罗遮。若为书经故取不犯。若偷经满。波罗夷。不满。偷罗遮。若读诵书写。不犯

问若人庙中物支提物。若白衣家中庄严具。若比丘偷心取。得何罪耶。答若有主守护。满。波罗夷。不满。偷罗遮。若取非人物庙等亦如是。满。偷罗遮。不满。突吉罗

问若比丘至白衣家语居士妇言。居士与我某甲物。得已犯何罪耶。答若物满。偷罗遮。不满。突吉罗。至居士所亦如是

问若闇夜中有衣。四比丘共偷取。得何罪。答物未分。偷罗遮。分已各满。波罗夷。不满。偷罗遮

问若人物着衣架上。比丘偷心取。得何罪。答选择时。偷罗遮。选择已满。波罗夷。不满。偷罗遮。合架取。偷罗遮。物离架满。波罗夷。不满。偷罗遮。衣囊亦如是。余物随其义应当知

问为他偷。得何罪。答偷罗遮

问如佛所说。比丘取五钱。波罗夷。颇有比丘取五钱不犯波罗夷耶。答有。若迦梨仙贱

问颇有比丘偷衣不犯耶。答有。衣减五钱

问如佛所说。比丘取重物移着处处。犯波罗夷。颇有比丘移重物着处处不犯波罗夷耶。答有。若共行弟子近住弟子。作偷意取和上阿阇梨物。转上着下。转下着上。偷罗遮

问比丘疑物。彼人物非彼人物。实是彼人物。取得何罪。答偷罗遮。非彼人物。亦偷罗遮

问如佛所说。若取五钱。波罗夷

云何五钱。答四迦呵那。一迦梨仙。迦梨仙直二十钱。取五钱。波罗夷

未受具戒时。作方便。未受具戒时。得突吉罗。未受具戒时作方便。受具戒时得突吉罗。未受具戒时作方便。受具戒已得偷罗遮。受具戒时作方便。受具戒得突吉罗

受具戒时作方便。受具戒已离处。偷罗遮。受具戒时作方便。受具戒时。得偷罗遮

问若比丘盗寺舍地。几事犯波罗夷。答二事斗诤相言斗诤取。偷罗遮。得胜。波罗夷。相言。偷罗遮。若胜满。波罗夷。如寺舍地田宅店肆亦如是。偷树果破仓若一方便满。波罗夷。不满。偷罗遮。若多方便一一方便满。偷罗遮。弗于逮方便取。偷罗遮。满波罗夷。用此迦梨仙者不满。偷罗遮。俱耶尼亦如是。郁单越不犯。无摄受故

问或有比丘偷铜钱犯波罗夷耶。答当计直满。犯波罗夷

问如佛所说。若比丘取五钱。波罗夷。颇有比丘取减五钱犯波罗夷耶。答有。若迦梨仙贵

问如佛所说。若比丘取五钱。波罗夷。颇有取五钱不犯波罗夷耶。答有。若迦梨仙贱

问若比丘先作偷心欲取衣。取时已有想。得何罪。答偷罗遮。后不犯。或前已有想。后作偷想。取架上衣。前不犯。后波罗夷

问如佛所说。若取五钱。波罗夷。颇有比丘取众多钱不犯耶。答有。若取大众共物。偷罗遮。或多人共取。偷罗遮

问如佛所说。偷木器满。波罗夷。颇有比丘偷木器满五钱不犯波罗夷耶。答有。若为他取。问如佛所说

若比丘偷金鬘满。波罗夷

颇有偷金鬘满不犯波罗夷耶。答有。若取非人金鬘。偷罗遮

问若有比丘偷水。得何罪。答当量水满。波罗夷。不满。偷罗遮

问若有比丘偷坡塘水。得何罪。计功水满。波罗夷。不满。偷罗遮

问如佛所说。取五钱。波罗夷。颇有比丘取百千迦梨仙不犯耶。答有。自己想取。同意取。暂时取。语他取。无主想取。无盗心取

问如佛所说。若比丘取五钱波罗夷。颇有比丘取百千迦梨仙不犯耶。答有。取四钱数数取。一一偷罗遮。若比丘偷心取。自己想举。前偷罗遮。后不犯。若自想取。偷心举。前不犯。后心若满五钱。波罗夷。不满。偷罗遮

问若人藏宝若似宝。着地中。比丘取弃。犯何罪。答偷罗遮

问若地宝涌出。比丘作己物取。得何罪。答偷罗遮。若他物想取。满。波罗夷。不满。偷罗遮。若手印取满。波罗夷。不满。偷罗遮

问取不用迦梨仙。得何罪。答量价满。波罗夷。不满。偷罗遮

问如佛所说。比丘移重物着处处。波罗夷。颇有比丘移重物着处处不犯耶。答有。一比丘担着远处。第二比丘移着处处。偷罗遮

问若比丘居士衣同意取。得何罪答偷罗遮。若居士言。我此衣与大德。若比丘施意想受用。偷罗遮。若綖若华果亦如是

问若比丘变金作铜度税处。得何罪。答偷罗遮

问若比丘取宝取金银坏色已取。犯何罪。答量价满。波罗夷。不满偷罗遮

问若比丘受寄已不还取。得何罪。答满。波罗夷。不满。偷罗遮

若比丘取迦梨仙矿。偷罗遮

问若比丘举他物。后不还。偷罗遮。事竟满。波罗夷。不满。偷罗遮。若比丘前决定不还。后离本处。无盗心。偷罗遮。若先离本处。后决定不还满。波罗夷。不满。偷罗遮

问若取似迦梨仙。犯何罪答量价。若比丘偷陶器。得何罪。答量其价。若减取五钱。犯何罪。犯偷罗遮。未受具戒作方便未受具戒时。得突吉罗。未受具戒时。作方便。受具戒时。得突吉罗。未受具戒时作方便。受具戒已。得偷罗遮。受具戒时作方便。受具戒已。得偷罗遮。受具戒已作方便。受具戒已。得满波罗夷

问若比丘取象马骆驼牛羊。犯何罪。答若自为满。波罗夷。不满。偷罗遮。若憎嫉彼故。偷罗遮。杀取肉亦如是。若解放使彼生恼。偷罗遮

问若比丘时作方便。转根作比丘尼时。离本处。得何罪。答满。波罗夷。不满。偷罗遮。比丘尼时作方便。转根作比丘时。离本处满。波罗夷。不满。偷罗遮

问如佛所说。比丘偷盗。波罗夷。颇有偷盗不犯波罗夷耶。答有。若本犯戒。本不和合。贼住。污染比丘尼。犯突吉罗

问颇有未受具戒人偷犯波罗夷耶。答有。谓学戒人

问颇有比丘变人作畜生杀。得何罪。自变作畜生杀人。得何罪。答若自知我是比丘。波罗夷。不自知比丘。偷罗遮

问如佛所说。杀母。犯波罗夷。得逆罪。颇有比丘杀母不得波罗夷不得逆罪耶。答有。若比丘杀爱慢母

若比丘欲杀余人而杀母。偷罗遮。若比丘欲斫树而斫母死。不犯。如母。父阿罗汉亦如是

二人共坐。欲杀彼人而杀此人。偷罗遮。欲杀阿罗汉而杀非阿罗汉。偷罗遮。不得逆罪。欲杀非阿罗汉而杀阿罗汉。偷罗遮。作阿罗汉想杀而非阿罗汉。偷罗遮

若一女生子一女取养后杀。何者得波罗夷。得逆罪耶。答杀生母。得波罗夷。并得逆罪。出家时问何者问养母畜生人想断命。偷罗遮。人作畜生想杀。突吉罗

问如佛所说。若比丘堕胎。波罗夷。颇有比丘堕胎不犯耶。答有。堕人怀畜生胎。偷罗遮。堕畜生怀人胎。波罗夷

问若比丘高处推母着下处母死。波罗夷。得逆罪。颇有比丘高处推母着下处母死不犯耶。答有。若己先堕死后母死。偷罗遮。不得逆罪。如杀母。父阿罗汉亦如是。若先作杀母方便已。而自杀。母先死。波罗夷。得逆罪。自先死后母死。偷罗遮。杀父阿罗汉亦如是

若比丘疑人非人而杀人。偷罗遮。若比丘疑母非母耶。而杀母。偷罗遮。不得逆罪。如母。父阿罗汉亦如是

问若比丘疑此人是此人非而是此人杀。得何罪。答偷罗遮

问若比丘见将贼杀去。贼于彼手中走去。诸人逐贼问比丘言。大德。见贼去不。答言见。便作是念。此是恶人。有杀心示语处所。是人因是事死。波罗夷。不死。偷罗遮。无心说彼人死。突吉罗。不死亦突吉罗。众多贼亦如是

问颇有比丘杀父母不得波罗夷不得逆罪耶。答有。若父母得重病扶起扶行。因是死。不得波罗夷。不得逆罪

问若比丘母非母想杀。犯偷罗遮。非母母想杀。偷罗遮。非人想杀。偷罗遮

问若比丘人人想杀。犯波罗夷。颇有比丘人人想杀不犯波罗夷耶。答有。自杀。偷罗遮。欲杀他而自杀。偷罗遮

问若比丘戏笑打父。因是死。犯何罪。答突吉罗。未受具戒时作方便。未受具戒时死。突吉罗。未受具戒时作方便。受具戒时死。突吉罗。受具戒时作方便。受具戒已死。偷罗遮。受具戒已作方便。受具戒已死。波罗夷

问如佛所说。若比丘人人想杀。波罗夷。颇有比丘人人想杀不犯波罗夷耶。答有。谓本犯戒人。贼住人。本不和合人。污染比丘尼人。犯突吉罗

问颇有未受具足人杀人波罗夷耶答有。谓学戒人

问若比丘如是语。我于四沙门果退。犯何罪。答偷罗遮

问若比丘言。我得四沙门果。得何罪。答不得言得。波罗夷罪

问我失阿罗汉果。阿那含果。斯陀含果。得何罪耶。答不犯(退有二种得退未得退今言失者意在未得退是故不犯)

实不得退言得退。波罗夷。实者不犯

问若比丘言我是学人。得何罪耶。答若言我学波罗提木叉。偷罗遮。若空无所有言学圣法。波罗夷。学修多罗毗尼阿毗昙亦如是。若比丘言。我是最后生。犯何罪耶。答若说过去法已灭。偷罗遮。若说实生尽。波罗夷

问若比丘作如是语。我当说汝是须陀洹斯陀含阿那含阿罗汉。而自说我须陀洹斯陀含阿那含阿罗汉。得何罪。答偷罗遮

问若有比丘语白衣言。谁语汝。我是须陀洹非斯陀含非阿那含非阿罗汉。复作是语。我非须陀洹乃至阿罗汉。波罗夷

问若比丘欲说须陀洹果。而说斯陀含阿那含阿罗汉果。犯何罪。答偷罗遮

问若比丘言。我耆梨山中。得须陀洹果。七叶山中得斯陀含。竹林精舍得阿那含。耆阇崛山得阿罗汉。犯何罪。答若在彼处诵修多罗。我不作懈怠。偷罗遮。若故妄语。波罗夷

问若有比丘。人问得果不。答言得。而示手中果花叶。犯何罪耶。答若意在花果。偷罗遮。若故说沙门果。波罗夷

问若比丘言。某甲家乞食比丘须陀洹斯陀含阿那含阿罗汉。我非须陀洹乃至阿罗汉。得何罪耶。答偷罗遮

问有比丘言。受用某甲居士衣食卧具医药者。是须陀洹乃至阿罗汉。我亦受用。我非阿罗汉。犯何罪。答偷罗遮

问若比丘言。某甲居士请众多比丘。敷种种众多褥。皆是须陀洹。乃至是阿罗汉。无凡夫。我亦受请。亦为我敷座。得何罪耶。答偷罗遮

问若人问比丘。大德何处得衣食。乃至汤药。比丘答言。某甲居士请众多比丘。语比丘言。若是须陀洹。乃至阿罗汉者。受我四事供养随意取。我亦于中取。而我非须陀洹乃至阿罗汉。得何罪。答偷罗遮

若比丘言。我不畏不活畏。不畏大众畏死畏恶道畏。犯何罪。答若因此身说此身过去变坏。偷罗遮。若故妄语说圣法。波罗夷。乃至恶道畏亦如是

问若比丘言。我于一切结使系缚烦恼解脱。得何罪耶。答若言于过去烦恼灭。偷罗遮。若故说结使系缚解脱。波罗夷

问若比丘言。诸贤圣所知。我亦得。得何罪。答若言我得修多罗者。偷罗遮。若故说圣法。波罗夷

问若比丘言我修诸根力觉道。得何罪耶。答若诵得修多罗。偷罗遮。若故妄语修根力觉道。波罗夷

问若比丘言。我当说须陀洹果。而我非须陀洹。得何罪耶。答偷罗遮。乃至阿罗汉亦如是

问若比丘言。我入世俗禅。不得世俗智。得何罪耶。答偷罗遮

问若比丘言我是世尊。得何罪耶。答若意在说法教诫。偷罗遮。若故妄语世尊。波罗夷

问若比丘言我是佛。得何罪耶。答若言我觉恶不善法。偷罗遮。若故妄语波罗夷

问若比丘言。我是毗婆尸佛弟子。得何罪耶。答归依释迦牟尼。便归依七佛。若说宿命通。波罗夷

问若比丘言。得须陀洹不得我非须陀洹。得何罪耶。答偷罗遮

问若有比丘言我得果。问言得何果。示庵婆罗果阎浮果波那娑果。得何罪耶。答偷罗遮。若故妄语说沙门果。波罗夷

问若比丘自作书。某甲比丘得须陀洹果。得何罪耶。答偷罗遮。乃至阿罗汉亦如是

问若比丘说过人法。不犯波罗夷耶。答有。本犯戒。本不和合。贼住。污染比丘尼人。突吉罗

问颇有非受具戒人说过人法犯波罗夷耶。答有。谓学戒人

问若比丘独入房。得四波罗夷耶。答有。先作偷盗方便杀生方便。知我入房时。阿罗汉自根长。问四波罗夷竟

    问十三僧伽婆尸沙

问若比丘行时精出。得何罪。答不犯。觉时方便。眠时精出。偷罗遮。觉时方便。觉时出于中起想。僧伽婆尸沙。不异。偷罗遮。方便受乐出。偷罗遮。顿出不犯。若握搦不出。偷罗遮。未受具戒时作方便。未受具戒时出。突吉罗。若未受具戒时作方便。受具戒时出。偷罗遮。受具戒时作方便。受具戒时出。偷罗遮。如是应作九句

问若比丘犯僧残罪已。不知时日。何处与别住耶。答从初受戒日

问若比丘按摩受乐。偷罗遮。若比丘以手摩捉。偷罗遮。自出中受乐。偷罗遮。男根触受乐。偷罗遮。出节中精。偷罗遮。空中动出。偷罗遮。行中动出。偷罗遮

问如佛所说。出节中精。偷罗遮。云何节精。答精离本处在节作方便出。偷罗遮

问颇有比丘时犯。非比丘时净。非比丘时犯。比丘时净。比丘时犯比丘时净。非比丘时犯非比丘时净耶。答有。云何比丘时犯非比丘时净。若比丘犯不共。僧伽婆尸沙。转根作比丘尼得净。云何非比丘时犯比丘时净。若比丘尼犯不共。僧伽婆尸沙。转根作比丘即得净。云何比丘时犯比丘时净。比丘犯戒如法忏悔

云何非比丘时犯非比丘时净。若比丘尼犯戒如法忏悔

问颇有比丘眠时犯。觉时净。觉时犯。眠时净耶。答有。云何眠时犯觉时净。若比丘眠时举着高床上。女人入宿觉已。知如法忏悔。云何觉时犯眠时净。若比丘犯僧伽婆尸沙。阿浮呵那时。闻白已眠。即眠中羯磨竟

问如世尊所说。若比丘故出精。除梦中。僧伽婆尸沙

颇有比丘故出精不犯耶。答有。前者

又问。颇非前者故出精不犯耶。答有。出他精。偷罗遮

又问。颇有比丘故出精。不犯耶。答有。为他作境界

又问。颇有比丘故出精不犯耶。答有。本犯戒。本不和合。贼住。污染比丘尼。突吉罗

问颇有未受具戒人故出精犯僧伽婆尸沙耶。答有。谓学戒

问如世尊所说。比丘摩触女人。僧伽婆尸沙。颇有比丘摩触不犯耶。答有。若女人身根坏。偷罗遮。若病癣疥痒摩触。偷罗遮。比丘身根坏等亦如是。俱身根坏等。突吉罗。若比丘疑为是女人非女人摩触。偷罗遮。若染着余女人摩触余女人。偷罗遮。若摩触齿爪毛。偷罗遮。摩触骨。偷罗遮。女人来摩触比丘齿爪毛。突吉罗。摩触离身齿爪毛发骨。突吉罗。爪齿毛发骨爪齿毛发骨摩触。突吉罗

比丘比丘相摩触。偷罗遮。比丘摩触女黄门。偷罗遮。女黄门摩触比丘。突吉罗。比丘摩触男子。偷罗遮。若比丘摩触女身时比丘转根作比丘尼。偷罗遮。比丘摩触男子。男子转根作女人。僧伽婆尸沙。若比丘摩触男子时。比丘转根作比丘尼。波罗夷。若比丘摩触男子俱转根。偷罗遮

若比丘尼摩触男子。男子转根作女人。偷罗遮。比丘尼摩触男子。比丘尼转根作比丘。偷罗遮。比丘尼摩触女人俱转根。偷罗遮

比丘尼摩触比丘转根作比丘。偷罗遮。比丘摩触比丘尼转根作比丘尼。偷罗遮。为温暖细软故不犯。比丘摩触黄门二根不男。偷罗遮。摩触入灭尽定比丘尼。偷罗遮。无污染心摩触女人。突吉罗。母想姊妹想女想不犯。本二不染污心摩触。突吉罗。若火中水中师子虎狼非人。及余诸难中捉出。不犯

问若比丘于女人所粗语。僧伽婆尸沙。颇有粗语不犯耶。答有。为他粗语。偷罗遮。遣书疏汝根断汝根恶。汝与我分共我眠。皆犯偷罗遮。黄门二根边粗恶语。偷罗遮。入灭尽定比丘尼所粗恶语。偷罗遮。赞叹己身亦如是

问若法有非过去非未来非现在耶。答有。谓媒嫁受语去。偷罗遮。还报忏悔何罪。谓僧伽婆尸沙。人男人女先以期比丘言。姊妹合耶。突吉罗。自在不自在亦如是。云何自在。多有财有息国王长者所信。云何不自在。无有财息。国王长者所不信持。不自在语至自在所。偷罗遮。若比丘言买女人。突吉罗。买某甲女人。偷罗遮。于买女人所媒嫁。偷罗遮。一女怀男一女怀女。于中媒嫁。偷罗遮。若空媒嫁。偷罗遮。若比丘持去持来。僧伽婆尸沙。后去来。偷罗遮。媒嫁黄门二根。偷罗遮。若比丘狂人边受语。至狂人所。偷罗遮。狂人边受语。至非狂人所偷罗遮。非狂人边受语。至狂人所偷罗遮。散乱人边受语。至散乱人所。偷罗遮。散乱人所受语。至非散乱人所。偷罗遮。不散乱人所受语。至非散乱人所说已还报。僧伽婆尸沙。居士语比丘僧。大德。能为我至某甲居士所言。我有女姊妹与汝儿。汝有女姊妹与我儿。众僧受语。语彼还报。一切僧得僧伽婆尸沙。若众僧同意遣一比丘往语。彼还报。一切僧得僧伽婆尸沙。若比丘自以己意。僧不使语彼还报。自得僧伽婆尸沙。众僧不犯。媒嫁童女。偷罗遮。比丘受使已转根。偷罗遮

还报转根。偷罗遮。受语时转根作比丘尼还报。偷罗遮。未受具戒时受使。未受具戒时还报。突吉罗。未受具戒时受使。受具戒时报。突吉罗。未受具戒时受使。受具戒已还报。偷罗遮。受具戒时受使。具戒已报。偷罗遮。受具戒已受使。未受具戒时报。偷罗遮。受具戒已受使。受具戒时报。偷罗遮

问如佛所说。比丘媒嫁。僧伽婆尸沙。颇有比丘媒嫁不犯耶。答有。本犯戒。本不和合。贼住。污染比丘尼。突吉罗

问颇有非受具戒人媒嫁犯僧伽婆尸沙耶。答有。谓学戒媒嫁人。男非人女。偷罗遮。人女非人男。偷罗遮。俱非人。偷罗遮。男女先已期

问比丘言。见某甲女人不。答言见。在某处所。偷罗遮

问颇有比丘行别住。即行别住竟耶。行摩那埵。即行摩那埵竟耶。答有。若比丘犯僧伽婆尸沙。不覆藏。往诣僧所。乞行摩那埵。僧与摩那埵。彼行摩那埵竟。复犯二僧伽婆尸沙。一一夜覆藏。二二夜覆藏。僧与别住。一夜覆藏别住竟。二夜者未竟。第三夜与摩那埵。行摩那埵竟

若比丘自乞作房。不从僧乞。僧伽婆尸沙。乞物作房不作。偷罗遮。从僧乞已不作。偷罗遮。已作不成。偷罗遮。成他房自住。偷罗遮。未覆为覆。偷罗遮。作未成自杀。若自言我沙弥黄门二根。广说如舍戒。皆犯偷罗遮。大房亦如是

问如佛所说。无根波罗夷谤。僧伽婆尸沙

颇有比丘无根波罗夷谤不犯耶。答有。若手印遣使从他闻谤。皆偷罗遮

问若比丘自书言。某甲比丘犯波罗夷。得何罪。答偷罗遮。若狂痴散乱心。苦痛心。聋盲喑哑。眠入正受。皆犯偷罗遮。何以故。不住自性心故。谤黄门。偷罗遮

问颇有比丘无根波罗夷谤不犯耶。答有。本犯戒。本不和合。贼住。突吉罗颇有比丘非具戒人谤犯僧伽婆尸沙耶。答有。谓学戒人

问若比丘自言。我作非梵行。以无根教人谤比丘。犯何罪。答僧伽婆尸沙。展转如轮

如佛所说。若比丘无根波罗夷谤比丘。僧伽婆尸沙。若比丘无根波罗夷。谤比丘尼。犯何罪。答僧伽婆尸沙。手印遣信谤。皆偷罗遮

问若比丘尼无根波罗夷。谤比丘尼。僧伽婆尸沙。八事覆藏粗罪。随顺摈比丘摩触身谤。僧伽婆尸沙。若比丘谤式叉摩那。偷罗遮。谤沙弥沙弥尼。偷罗遮。比丘尼谤比丘。僧伽婆尸沙。比丘尼谤式叉摩那沙弥沙弥尼。偷罗遮。式叉摩那谤比丘比丘尼。突吉罗

如世尊所说。比丘无根波罗夷谤比丘。僧伽婆尸沙。无根逆罪谤比丘。得何罪。答僧伽婆尸沙。又说犯僧伽婆尸沙。突吉罗。云何僧伽婆尸沙。谓以杀母父阿罗汉谤。僧伽婆尸沙。破僧出佛身血谤。突吉罗。如是说者。一切犯僧伽婆尸沙。何以故。一切无间罪非比丘故。除无间罪。以余法谤。偷罗遮。突吉罗。遣使手印展转无根五逆谤。偷罗遮。比丘自作书某甲比丘杀母父阿罗汉。破僧恶心出佛身血。偷罗遮

问颇有比丘无根谤不犯耶。答有。谓狂散乱重病。聋盲喑哑。眠入定谤。皆偷罗遮。何以故。心不住自性故

问颇有比丘无根波罗夷谤不犯耶。答有。本犯戒。本不和合。贼住。污染比丘尼。突吉罗。比丘自言。我杀母杀父谤。僧伽婆尸沙。乃至出佛身血谤。僧伽婆尸沙。展转亦如是。比丘尼亦如是。比丘尼谤比丘亦如是。比丘谤式叉摩那乃至沙弥尼。突吉罗。比丘尼亦如是。式叉摩那谤比丘比丘尼。突吉罗

萨婆多部毗尼摩得勒伽卷第八萨婆多部毗尼摩得勒伽卷第九

        宋元嘉年僧伽跋摩译

问若可信优婆夷语诸比丘。我见某甲比丘犯四波罗夷。得用是语治比丘不。答得治。问若可信优婆夷语诸比丘。我见某甲比丘身分中作淫。用是语治不。答言。不得

问可信优婆夷语诸比丘。某甲比丘共刹利女作淫。用是语治比丘不。答不得。何以故。不用是语治耶。答比丘不自言故。若二人共见者。当问二人。若二人语同比丘自言。可用是语治。如刹利女。婆罗门女毗舍女首陀罗女亦如是。若可信优婆夷语诸比丘。我见某甲去时小便道作淫。当用是语治不。答若有二人当问同者。应治。口中亦如是。大便道作淫。亦如是

若可信优婆夷言。我见某甲比丘非时食怛钵那。应问是比丘。比丘言我食糖。当用是语治。糖浆蜜酒亦如是

若有比丘非时食糖。可信优婆夷言。我见非时食肉。亦应令是比丘自言已用是语治。啖酥啖食亦如是

比丘齿外出不净。可信优婆夷见已。语诸比丘。我见某甲比丘口中作淫。亦应令是比丘自言用是语治。髀中出精亦如是。大小便处亦如是

二可信优婆夷共道行。见二比丘共道行。一优婆夷见一比丘出精。一优婆夷见一比丘摩触身。亦应令是比丘自言。应用是语治二人。见众多亦如是。坐卧亦如是。优婆夷了了见罪已。可用是语治

可信优婆夷语诸比丘。我见某甲比丘犯后四篇罪。亦应令是比丘自言。用是语治

又复优婆夷见比丘犯十三僧伽婆尸沙。亦应令是比丘自言用是语治。后三篇亦如是

    问三十事

问若有比丘得少片衣。不受持。应舍不。答不应舍。应受持不。答不应受持。若比丘失尼萨耆衣。云何忏悔。答尼萨耆悔

问如佛所说。过十夜衣。尼萨耆波夜提。颇有畜过十夜衣不犯耶。答有。若比丘不净物杂作衣。谓骆驼毛牛毛。犯突吉罗。若比丘得衣已。五日中狂。至何时犯耶。答得本心时

问如佛所说。过十夜衣。尼萨耆波夜提。颇有终身畜不犯耶。答有。十夜内命终。或以不净物杂。如前说。过十夜衣一夜离宿耶。答有。若比丘离衣宿。或频日得衣

问得用众僧衣受作三衣不。答得受。若受持已离宿应舍不。答不得舍。唯作波夜提悔

问若比丘界内着衣出界外。界外着衣入界内。明相出离衣宿不。答离衣宿。衣着地。空中明相出。空中着衣在地。明相出亦如是。奇界不离衣宿。无界处住去衣。远近名离衣宿耶。答随众僧篱墙大小。或坑堑。比丘于是内着衣。随意明相出。学戒人三衣。比丘尼五衣。学戒尼五衣亦如是

问如佛所说。畜一月衣。颇有畜过一月衣不犯尼萨耆波夜提耶。答有。不净衣。如前说。过一月畜。突吉罗。畜减量衣过一月。突吉罗

问如佛所说。畜一月衣。何等衣。答谓净衣。云何净衣。佛所不遮衣是

问如佛所说。若使非亲里比丘尼浣故衣染打。尼萨耆波夜提。颇有比丘使非亲里比丘尼浣染打不犯尼萨耆波夜提耶。答有。已浣更使浣。突吉罗。手印遣信展转使浣。皆突吉罗。使浣未应浣衣。使浣众僧衣。尼萨耆衣。净施衣。频日衣。皆突吉罗。染打亦如是

问颇有比丘着净衣入聚落衣不离身尼萨耆波夜提耶。答有。若比丘入白衣舍。着衣大小行泥土污。非亲里比丘尼为除去。尼萨耆波夜提。使浣不净衣。突吉罗。使比丘尼浣衣时。比丘尼转根。突吉罗。染打亦如是。自转根亦如是。使本犯戒比丘尼浣染打。突吉罗。使贼住不共住本不和合污染比丘尼人浣。皆突吉罗

如佛所说。若比丘非亲里居士居士妇边乞衣。尼萨耆波夜提。颇有从非亲里居士居士妇乞衣不犯耶。答有。身动索得衣。突吉罗。从黄门乞衣。突吉罗。俱黄门。突吉罗。俱二根。突吉罗。本犯戒。突吉罗。本不和合。贼住。别住。污染比丘尼亦如是。非亲里亲里想乞。突吉罗。疑乞。突吉罗。亲里非亲里想乞。突吉罗。疑乞。突吉罗。遣使手印展转乞。皆突吉罗未受具戒时乞未受具戒时得。突吉罗。未受具戒时乞。受具戒时得。突吉罗。未受具戒时乞。受具戒已得。突吉罗。余句亦如是。乞时比丘转根作比丘尼。突吉罗。比丘尼乞时转根作比丘。突吉罗

若为他作往索得。突吉罗。为比丘尼式叉摩那沙弥沙弥尼作。比丘往索得。突吉罗。为得多比丘作一人索得。突吉罗。为二人作索得。突吉罗。为比丘作比丘尼式叉摩那沙弥沙弥尼索得。突吉罗

未受具戒时。为作衣。未受具戒时得。突吉罗。如是应广说。黄门等亦如前说

为非人作衣索得。突吉罗。为天龙夜叉乾闼婆紧那罗饿鬼鸠槃茶毗舍遮富单那作衣往索得。皆突吉罗。本犯戒人亦如是。比丘尼等亦如是

问如佛所说。四语五语六语默然索不得。尼萨耆波夜提。颇有过五六语索得不犯耶。答有。从非人索。突吉罗。或人与衣直着沙门婆罗门所过五六语索。突吉罗。非人衣直着沙门婆罗门所亦如是。沙门婆罗门衣直着非人所亦如是。本犯戒人乃至污染比丘尼人。亦如是。颇有未受具戒人过五云语索犯尼萨耆波夜提耶。答有。学戒人

问如佛所说。新俱絁耶作敷具。尼萨耆波夜提。颇有比丘新俱絁耶作敷具不犯尼萨耆波夜提耶。答有。为他作。突吉罗。他作未成为成。突吉罗。若不净物杂作。突吉罗。修伽陀衣等量作。突吉罗

问如佛所说。若比丘纯净黑羺羊毛作敷具。尼萨耆波夜提。颇有比丘纯作不犯耶。答有。如前说。未受具戒时作。未受具戒时成。突吉罗。未受具戒时作。受具戒时成。突吉罗。如是应作七句。本犯戒。本不和合。贼住。污染比丘尼人作。皆突吉罗。颇有未受具戒人作犯尼萨耆波夜提耶。答有。谓学戒人

问如佛所说。若比丘减六年更作新敷具。不犯尼萨耆波夜提耶。答有。谓狂痴不犯。为他作。他作未成。为成不净杂净杂净。皆突吉罗。作方便已罢道。更出家已成。突吉罗。作时转根作女人。复转根作男子成。突吉罗。本犯戒人。乃至污染比丘尼人。突吉罗

问颇有未受具戒人作犯尼萨耆波夜提耶。答有。谓学戒未受具戒人作方便。未受具戒时成。突吉罗。如是应作七句

空中持羊毛去。突吉罗与化人持去。突吉罗。本犯戒人乃至污染比丘尼人。皆突吉罗。颇有非具戒人持去犯尼萨耆波夜提耶。答有。谓学戒人

问如佛所说。使非亲里比丘尼擘羺羊毛。犯尼萨耆波夜提。颇有比丘使非亲里比丘尼擘羺羊毛不犯耶。答有。已浣擘更使浣擘。突吉罗。遣使手印展转使浣。皆突吉罗。使他浣。突吉罗。使浣僧物。突吉罗。使浣尼萨耆物。突吉罗。骆驼毛杂。突吉罗。牛毛鹿毛羖羊毛杂者使浣。突吉罗。染擘亦如是。本犯戒乃至污染比丘尼人亦如是

问颇未受具戒人浣染擘。犯尼萨耆波夜提耶。答有。谓学戒人

问如佛所说。若比丘自手取金银。若使人取。若教人取。尼萨耆波夜提。颇有比丘自取使人取教人取不犯尼萨耆波夜提耶。答有。谓不中用碎者大团。突吉罗。断坏。突吉罗。似金银。突吉罗。国土所讥。突吉罗。未坏相。突吉罗。国土不讥不犯。本犯戒乃至污染比丘尼。皆突吉罗

问颇有非具戒人取金银尼萨耆波夜提耶。答有。谓学戒人

问如佛所说。比丘以种种银买物。尼萨耆波夜提。颇有比丘以种种银买物不犯尼萨耆波夜提耶。答有。谓用似银买物。突吉罗。非人天龙夜叉乾闼婆紧那罗摩睺罗伽饿鬼毗舍遮鸠槃茶富单那买物。突吉罗。共亲里狂散乱苦痛。乃至污染比丘尼人买。皆突吉罗。学戒人买。尼萨耆波夜提。比丘买银时转根作比丘尼。突吉罗。比丘尼以银买物转根作比丘亦如是。未受具戒时买银。未受具戒时。得突吉罗。如是应作七句

种种贩卖戒亦如是

问如佛所说。畜长钵过十夜。尼萨耆波夜提。颇有过十夜不犯尼萨耆波夜提耶。答有。本犯戒。本不和合。贼住。污染比丘尼。突吉罗。学戒人畜长钵过十夜。尼萨耆波夜提。畜坏钵。突吉罗。畜未熏钵。突吉罗

问颇有比丘终身畜长钵不犯尼萨耆波夜提耶。答有。得钵已十夜内命终。若比丘狂心散乱心过十夜。不犯

问颇有比丘久畜长钵不犯耶。答有。若比丘寄钵未至。或为他畜

问颇有比丘一夜畜钵犯尼萨耆波夜提耶。答有。比丘转根作比丘尼

问如佛所说。比丘尼一夜畜长钵。尼萨耆波夜提。颇有十夜畜不犯耶。答有。谓转根作比丘十夜畜。不犯

问如佛所说。若比丘有钵更乞。尼萨耆波夜提。是钵应众中舍。若有比丘乞得众多钵。尽应僧中舍不。答不尽舍应舍一。余者应与同意。一切钵应行耶。答不应。应行一。何者应行。意所贪乐者。二人共得一钵。突吉罗。遣使手印乞。突吉罗。各相为乞。突吉罗。自物贸钵。突吉罗。知足物贸钵。突吉罗。从外道乞钵。突吉罗。从沙门婆罗门乞。突吉罗。本犯戒。乃至污比丘尼人乞。皆突吉罗。学戒人乞。尼萨耆波夜提。未受具戒时乞。未受具戒时。得突吉罗。如是应作七句

问如佛所说。若比丘与比丘衣已还夺。尼萨耆波夜提。颇有比丘还夺衣不犯耶。答有。谓受法比丘与不受法比丘衣已还夺。突吉罗。夺本犯戒人。本不和合。贼住。污染比丘尼人。突吉罗。夺减量衣。突吉罗。施已转根作比丘尼夺衣。突吉罗。受者转根作比丘尼夺衣。突吉罗。比丘尼与衣已转根作比丘夺衣。突吉罗。受者转根作比丘夺衣。突吉罗

问若阿练若比丘怖畏处。三衣中一一衣着。白衣家内有因缘。出界外作意当还。还时诸难起。不得至衣所。离衣宿不。答不离衣宿

问颇有比丘离六夜衣宿不犯尼萨耆耶。答有。谓不净衣。突吉罗。如是应作十句。若僧伽梨作羯磨已。离宿不犯

问如佛所说。余一月在乞雨衣。半月中应作雨衣畜。颇有比丘减一月乞过半月畜不犯尼萨耆耶。答有。谓不净衣。突吉罗。乞减量雨衣。突吉罗。未至一月二人共乞雨衣。突吉罗

问自恣已王作闰。得急施衣。当云何。答随数。安居月过十日。尼萨耆波夜提。急施衣不得作非时衣

问如佛所说。急施衣过十日。尼萨耆波夜提。颇有过十日不犯耶。答有。若不净衣。突吉罗。畜不净缕织衣。突吉罗。畜减量衣。突吉罗。本犯戒畜急施衣过十夜。突吉罗。乃至污染比丘尼人过十夜。突吉罗。学戒人畜过十夜。尼萨耆波夜提

如佛所说。施僧衣已。自回向己。尼萨耆波夜提。颇有比丘回向己不犯耶。答有。谓父母衣施僧已回向己。突吉罗。未至界内回向己。突吉罗。施三人二人回向己亦如是

问若比丘非时受甘蔗。非时压非时漉。非时煮非时受。得食不。答不得。八种浆五种脂亦如是。乳油肉等亦如是

问时药非时药。七日药终身药。不手受不说受得服不。答不得。手受不说受得服不。答不经宿。病者得服。不病不得服。即此药共诸药杂得服不。不得服时药乃至共终身药。杂非时得服不。答不得服。时药力故。七日药七日服。过七日不得服。终身药杂七日药七日服。时药时服。非时药非时药服。七日药七日药服。终身药终身药服施合施应分别

三十事竟

问若比丘作外道服式舍戒不。答不舍戒。犯偷罗遮。若人问汝是谁。答是外道。故妄语。波夜提

问若比丘作居士形舍戒不。答不舍戒。犯突吉罗。若人问汝是谁。答是居士。故妄语。波夜提。余事随其义说

比丘语比丘言。汝刹利种出家。乃至首陀罗出家。汝是剃师。故妄语。波夜提

若比丘天眼举他罪。突吉罗。天耳亦如是。若比丘唱言。僧中有犯戒人。故妄语波夜提。汝是缺戒人。漏戒人。羸戒人。污戒人。故妄语。波夜提。教诫语不犯。语婆罗门出家比丘言。汝是剃师。突吉罗。问言。汝是谁。答言。我是比丘尼。故妄语。波夜提

问比丘言。汝是谁耶。答我是沙弥。舍戒不。答不舍戒。故妄语。波夜提。我是沙弥尼白衣外道。外道出家。夜叉乾闼婆紧那罗摩睺罗伽鸠槃茶等亦如是。更以余事随其义。应当知

问如佛所说。比丘毁呰语。波夜提。颇有毁呰语不犯耶。答有。谓本犯戒。乃至污染比丘尼毁呰语。突吉罗。非人出家毁呰语。突吉罗。天龙夜叉乾闼婆紧那罗摩睺罗伽。毗舍阇鸠槃茶等出家毁呰语。突吉罗。毁呰如是等出家人。突吉罗。毁呰狂人散乱心苦病人聋哑。中国人毁呰边地人不解故。突吉罗。边地人毁呰中国人不解。突吉罗。手印遣使。突吉罗。比丘毁呰性住比丘。波夜提。比丘毁呰比丘尼。突吉罗。比丘毁呰式叉摩那沙弥沙弥尼。突吉罗。比丘尼毁呰比丘尼。波夜提。比丘尼毁呰比丘。突吉罗。比丘尼毁呰式叉摩那沙弥沙弥尼。突吉罗。式叉摩那毁呰比丘比丘尼。突吉罗。沙弥毁呰比丘比丘尼式叉摩那沙弥沙弥尼。突吉罗。沙弥尼亦如是

比丘于性住比丘所。行两舌。波夜提。比丘尼于比丘所。行两舌。式叉摩那沙弥沙弥尼所。行两舌。皆突吉罗。比丘于比丘尼所。行两舌。式叉摩那沙弥沙弥尼所。行两舌。皆突吉罗。五众如轮亦如是。本犯戒。乃至污染比丘尼人。聋盲喑哑所。行两舌。皆突吉罗。本犯戒人行两舌。突吉罗。本犯戒比丘尼。乃至污染比丘比丘尼。行两舌。突吉罗。聋盲喑哑人。行两舌。突吉罗。天龙夜叉乃至富单那出家作比丘。行两舌。突吉罗。如是人所。行两舌。突吉罗。在地向空中人。行两舌。波夜提。在空中向地人。行两舌。波夜提。在界内向界外人两舌。波夜提。在界外向界内。行两舌。波夜提。中国人向边地人。行两舌不解。突吉罗。边地人向中国人。行两舌不解。突吉罗。学戒人向性住比丘。行两舌波夜提。遣使手印两舌。突吉罗

问如佛所说。僧如法和合灭诤已更发起。波夜提。颇有比丘发起不犯耶。答有。谓本犯戒。本不和合。乃至污染比丘尼人。更发起。突吉罗。发起学戒诤。波夜提。本犯戒人等发起诤。突吉罗。比丘发起狂心散乱心苦病心诤。突吉罗。发起聋盲喑哑诤。突吉罗。发起非人出家诤犯。突吉罗。云何非人天龙夜叉。乃至富单那。中国人发起边地人罪不解故。突吉罗。边地人发起亦如是。手印遣使展转发。突吉罗。比丘语学戒人言。汝非学戒人。突吉罗。比丘发起比丘尼诤。突吉罗。发起式叉摩那沙弥沙弥尼诤。突吉罗。比丘尼发起比丘诤。突吉罗。发起式叉摩那乃至沙弥尼诤。突吉罗。式叉摩那发起沙弥沙弥尼。乃至比丘尼展转如轮亦如是

问如佛所说。无净人为女人说法。云何非净人。若谓痴狂边地人眠醉放逸。入定人不解不闻故。非净人以此等为净人说法。突吉罗。手印遣使。突吉罗。女人净净人不净为说法。突吉罗。女人不净净人净为说法。突吉罗。无净人为黄门说法。突吉罗。聋盲喑哑狂散乱心重病。天龙夜叉。乃至富单那等为净人为女说法。突吉罗。本犯戒。乃至污染比丘尼人。为女说法。突吉罗。学戒人无净人为女说法。波夜提

问如佛所说。若比丘共未受具戒人诵经。波夜提。颇有共未受具戒人诵不犯波夜提耶。答有。共畜生诵。突吉罗。狂心散乱心重病人。天龙夜叉。乃至富单那等比丘共诵。突吉罗。本犯戒乃至污染比丘尼人共诵。突吉罗。学戒人共诵。波夜提。共聋盲喑哑人诵。突吉罗。比丘共比丘诵。突吉罗。比丘共比丘尼。乃至共沙弥尼诵。突吉罗。比丘尼亦如是。式叉摩那沙弥沙弥尼亦如是

问如佛所说。比丘未受具戒人前说粗恶罪。波夜提。颇有说粗恶罪不犯耶。答有。未受具戒人前自说己粗恶罪。突吉罗比丘尼前说。突吉罗。式叉摩那乃至沙弥尼前。说粗恶罪。突吉罗。比丘未受具戒人前。说比丘尼粗恶罪。突吉罗。比丘尼乃至沙弥尼作句亦如是。天龙等出家作比丘说己粗恶罪。突吉罗。天龙等出家说比丘粗罪。亦如是。说本犯戒乃至污染比丘尼人罪。突吉罗。彼人等出家说比丘粗罪。突吉罗。说学戒人粗罪。突吉罗。在地向未受具戒人。说空中比丘粗罪。波夜提。在空中说地人粗罪亦如是。界内界外亦如是。中国人向边地人。边地人向中国人说不解。突吉罗。遣使手印。突吉罗

问如佛所说。向未受具戒人。说实过人法。波夜提。颇有比丘向未受具戒人说不犯耶。答有。谓向天龙乃至富单那等说。突吉罗。向狂心散乱心重病人聋盲喑哑乃至污染比丘尼说实过人法。突吉罗。中国人向边地人说。边地人向中国人说不解。突吉罗。手印遣使。皆突吉罗。比丘漏尽未受具戒人。问漏尽不手中捉果核。彼言得是不犯。如是随其义说

问如佛所说。若比丘僧施他物。回与余人。波夜提。颇有比丘回向不犯耶。答有。比丘尼僧物回向与他。突吉罗。非人出家物比丘回向与他。突吉罗。非人回向比丘乃至沙弥尼物。突吉罗。非人者。天龙乃至富单那等。狂心散乱心重病人等物回向他。突吉罗。本犯戒人。乃至污染比丘尼人物回向他。突吉罗。彼亦如是。非学戒人回向他物。波夜提。中国人回向边地人物。边地人回向中国人物。亦如是

若比丘以沙土覆生草。突吉罗。若比丘打熟果落。突吉罗。打生果落。波夜提。手印遣使斫树。突吉罗。比丘折树枝。波夜提。学戒人打熟果落。突吉罗。生果落。波夜提。比丘以神力折树枝。突吉罗。手作相使折。突吉罗。比丘言。汝某甲来折如是如是。突吉罗。若比丘以暖汤浇草草死。波夜提。不死。突吉罗。若比丘杀五种种。五波夜提。以风吹日曝五种子。五突吉罗。火炙五种种不死。五突吉罗。死五波夜提。本犯戒乃至污染比丘尼人杀。突吉罗。水渍火烧舂捣。皆突吉罗。学戒人杀草木。波夜提。断须。突吉罗。掷物杀草木。突吉罗

问如佛所说。嫌骂。波夜提。颇有比丘嫌骂不犯耶。答有。谓非人出家嫌骂性住比丘。突吉罗。性住比丘嫌骂非人出家。突吉罗。非人者。天龙乃至富单那等

颇有比丘骂人比丘不犯波夜提耶。答有。谓本犯戒乃至污染比丘尼人。突吉罗。本犯戒乃至污染比丘尼人骂他。突吉罗。比丘骂聋盲喑哑狂痴散乱心重病人。突吉罗。聋盲等骂性住比丘。突吉罗。学戒人嫌骂。波夜提。中国人骂边地人。边地人骂中国人不解。波夜提。独非独想非独独想独独想骂。突吉罗。骂性住比丘不闻。突吉罗

问如佛所说。比丘恼他。波夜提。颇有恼他不犯耶。答有。除罪事以余事恼比丘。突吉罗。狂心散乱心重病聋盲喑哑等恼他。皆突吉罗。非人出家恼他。突吉罗。非人者。乃至富单那。本犯戒。乃至污染比丘尼恼他。突吉罗。恼如是人。突吉罗。学戒恼他。波夜提。中国人恼边地人。边地人恼中国人。突吉罗。除比丘恼余人。突吉罗。遣使手印恼他。突吉罗

问如佛所说。比丘用僧卧具露地自敷使人敷。不自举不使人举。波夜提。颇有比丘不自举不使人举不犯波夜提耶。答有。不净者。不自举不使举。突吉罗。骆驼毛牛毛。羖羊毛鹿毛。杂作不自举不使举。突吉罗。卧具量乃至长八指。若过坐卧已。不自举不使举。突吉罗。本犯戒乃至污染比丘尼。寺舍中比丘敷卧具不自举不使举。突吉罗。本犯戒乃至污染比丘尼等。至比丘寺中亦如是。比丘敷白衣卧具不举。突吉罗。敷自卧具不举。突吉罗。比丘比丘尼寺中敷。卧具去时不举。突吉罗。如是异沙门婆罗门寺中敷卧具不举。突吉罗

萨婆多部毗尼摩得勒伽卷第九萨婆多部毗尼摩得勒伽卷第十

        宋元嘉年僧伽跋摩译

问如佛所说。若比丘比丘房舍中敷草若树叶。去时不自举不使举。波夜提。颇有不自举不使举不犯耶。答有。本犯戒乃至污染比丘尼。房中敷不自举不使举。突吉罗。本犯戒乃至污染比丘尼。至比丘房中亦如是。比丘尼寺房中亦如是。外道房中亦如是

问如佛所说。若比丘知僧寺中先有比丘。往到彼逼坐令恼。波夜提。颇有比丘逼坐不犯耶。答有。逼本犯戒乃至污染比丘尼。突吉罗。本犯戒等恼性住比丘。突吉罗。非人出家逼恼性住比丘。突吉罗。性住比丘逼恼非人等出家。突吉罗。比丘比丘尼寺中逼恼比丘比丘尼。突吉罗。除如来弟子僧房舍内。余寺内逼恼。突吉罗。私房逼恼。突吉罗

问如佛所说。比丘嗔恚。寺内自挽出使人挽出。波夜提。颇有自挽出使人挽出不犯耶。答有。谓挽出非人作比丘乃至污染比丘尼。突吉罗。乃至污染比丘尼比丘挽出性住比丘。突吉罗。狂心散乱心聋盲喑哑挽出比丘。突吉罗。性住比丘挽出彼人。波夜提。挽出恶比丘衣钵。突吉罗。比丘尼僧中挽出比丘比丘尼。突吉罗。除如来弟子寺舍。余寺舍中挽出。突吉罗

比丘有虫水浇草土瞿摩耶。波夜提。土草中有虫亦如是

问如佛所说。比丘僧重阁上尖脚床上坐卧。波夜提。颇有比丘坐尖脚床上不犯耶。答有。谓非人出家乃至污染比丘尼人坐卧。突吉罗。学戒人坐卧。波夜提。聋盲喑哑。突吉罗。颇有比丘坐卧尖脚床不犯耶。答有。痴狂散乱心重病不犯。自重阁上坐尖脚床。突吉罗。阁下坐尖脚床不犯。除如来寺舍。余寺舍坐尖脚床。突吉罗

问颇有比丘过二三覆不犯耶。答有。谓用草覆板覆不犯

问如佛所说。僧不差教诫比丘尼。波夜提。颇有不差教诫不犯耶。答有。本犯戒乃至污染比丘尼。不差教诫。突吉罗。僧不差教诫本犯戒比丘尼乃至污染比丘尼人。突吉罗。学戒人僧不差教诫。波夜提。聋盲喑哑教诫。突吉罗。僧不差教诫聋盲喑哑比丘尼。突吉罗。教诫狂痴乃至重病比丘尼。突吉罗。非人出家比丘教诫比丘尼。突吉罗。教诫非人出家比丘尼。突吉罗。非人者。如前说

若比丘尼边地人比丘中国人。教诫不解。突吉罗。比丘边地。人比丘尼中国人。教诫不解。突吉罗。遣使手印教戒。突吉罗。日没教诫广说亦如是。有五德成就。应差教诫

问如佛所说。若比丘言。诸比丘为利养故。教诫比丘尼。波夜提。颇有比丘作是语不犯耶。答有。谓语非人出家作比丘语性住比丘。突吉罗。语本犯戒乃至污染比丘尼人。突吉罗。彼语性住比丘。亦突吉罗。语聋盲喑哑。突吉罗。彼语性住比丘亦如是。语痴狂乃至重病。突吉罗。彼语性住比丘不犯。学戒语波夜提。中国人语边地人。边地人语中国人不解。突吉罗。遣使手印。突吉罗。受法语不受法。突吉罗

问如佛所说。若比丘与非亲里比丘尼作衣。波夜提。颇有为作不犯耶。答有。谓本犯戒乃至污染比丘尼为作衣。突吉罗。为本犯戒乃至污染比丘尼人作衣。突吉罗。比丘聋哑比丘尼聋哑亦如是。狂痴乃至重病为作衣。不犯。学戒人为作衣。波夜提。非人出家为非亲里比丘尼作衣。突吉罗。为非人出家比丘尼作衣。突吉罗。非人者。如前说。受法比丘为不受法比丘尼作衣。突吉罗。相违亦如是。与衣戒亦如是广说

问如佛所说。若有比丘共比丘尼道行。除因缘。波夜提。颇有比丘共道行不犯耶。答有。非人出家作比丘共道行。突吉罗。共非人比丘尼亦如是。非人者。如前说。本犯戒乃至污染比丘尼人共道行。突吉罗。共本犯戒比丘尼乃至污染比丘尼人共道行。突吉罗。共狂痴乃至重病比丘尼共道行。突吉罗。比丘狂痴乃至重病共行。不犯。比丘聋盲喑哑。共道行。突吉罗。比丘尼聋盲亦如是。受法比丘共不受法比丘尼共道行。突吉罗。相违亦如是。学戒人共道行。波夜提。共黄门比丘尼道行。突吉罗。乘船戒亦如是。应广说

问如佛所说。若比丘共女人屏处坐。犯波夜提。颇有共坐不犯波夜提耶。答有。谓本犯戒乃至污染比丘尼。突吉罗。比丘狂痴乃至重病共屏处坐。不犯。聋盲喑哑及非人等出家共屏处坐。突吉罗。非人者。如前说。共天女坐。突吉罗。乃至富单那女坐亦如是。共黄门二根童女屏处坐。突吉罗。比丘共聋盲喑哑乃至狂痴重病屏处坐。皆突吉罗。学戒共女人屏处坐。波夜提。共比丘尼屏处坐戒亦如是。除童女

问如佛所说。若比丘比丘尼赞叹得食。波夜提。颇有比丘得赞叹食不犯耶。答有。谓本犯戒乃至污染比丘尼人得食食。突吉罗。比丘狂痴乃至重病得食食。不犯聋盲人得食食。突吉罗。学戒人得食食。波夜提。非人出家得食食。突吉罗。非人出家作比丘尼比丘于彼得食食。突吉罗。知为他作得食食。突吉罗。不知不犯。本犯戒乃至污染比丘尼人所赞叹得食食。突吉罗。受法不受法展转。亦突吉罗。遣使手印亦如是

问如佛所说。比丘处处食。除因缘。波夜提。颇有比丘二处受请不犯波夜提耶。答有。若比丘先受无衣请食。后受有衣请食。不犯二处。有衣食受请食。不犯。一得衣一觅衣。受请食不犯。语比丘言。就此食。当为汝觅衣食食。不犯。语比丘此间食余处随意食食。不犯。除五种食随意食余食。不犯

问颇有比丘二处受无衣食不犯耶。答有。谓本犯戒乃至污染比丘尼人受二请。突吉罗。聋盲喑哑乃至非人出家受一请。突吉罗。狂痴乃至重病。不犯

问如佛所说。一宿处无病比丘听一食过一食。波夜提。颇有比丘过一食不犯耶。答有。谓非人宿处无病再食。不犯。非人者。如前说。比丘作宿处过一食。不犯。余沙门婆罗门食处过一食。突吉罗。亲里食处再食。不犯。黄门二根乃至聋盲喑哑食处再食。突吉罗。痴狂乃至重病再食。不犯。学戒再食。波夜提

问如佛所说。若比丘入白衣舍乞食。诸信向婆罗门居士自恣与众多饼食。比丘应取二三钵。过取波夜提。颇有过取不犯耶。答有。谓天龙夜叉外道家过取。突吉罗。在彼坐食不犯。取二三钵已更乞。突吉罗。受法比丘到不受法比丘檀越家。取过二三钵。突吉罗。相违亦如是。乃至非人出家亦如是。本犯戒四人等亦如是。聋盲等亦如是。学戒人过取。波夜提

问如佛所说。若比丘食已自恣。不受残食法更食。波夜提。颇有比丘更食不犯耶。答有。谓病食不足酥蜜亦如是食不净食已自恣。受残食法不成受食者。波夜提。不净食者。谓五正食

问颇有比丘食已自恣。更受残食法食中数数自恣。不犯波夜提耶。答有。谓本犯戒乃至污染比丘尼。突吉罗。学戒人食中数数自恣食。波夜提

问如佛所说。若比丘别众食。波夜提。颇有比丘别众食。不犯波夜提耶。答有。谓六种因缘。一一因缘食者不犯。除五正食。食余食不犯

问如佛所说。若比丘非时食。波夜提。颇有比丘非时食不犯耶。答有。三方用阎浮提时食。不犯

问弗于逮俱耶尼宿食得食不。答不得食。郁单越宿食得食不。答得食

问几种宿食比丘不得食。答三种。谓僧比丘学戒。四种宿食得食。谓比丘尼。式叉摩那学戒。比丘尼。沙弥沙弥尼比丘尼亦如是

问若钵极腻用瞿摩耶土屑。极用意三洗腻故。不去得食不。答得食。何以故。非食腻故

问若比丘捉酥油瓶应弃。不得食不。答或得或不得。二种人有惭无惭。无惭者。捉得食。有惭者。误捉得食。若比丘取食欲与沙弥。沙弥与比丘得食不。答得食。沙弥不与得索不。答不得索。比丘举沙弥食与沙弥。沙弥与比丘。得食不。答得食。碱水应受不。答更着盐应受。不着不须受。浊水见面不须受。不见面应受。受法学戒人与不受法比丘食。得食不。答不得食。不受法学戒得与受法比丘食不。答不得食。不受法比丘与受法比丘食得食不。答不得。相违亦如是

问如佛所说。若比丘无病索美食。波夜提。颇有比丘索美食不犯耶。答有。从亲里索。不犯。若比丘饮虫水随饮杀虫随得尔所波夜提

问颇有比丘食家中坐食犯边罪耶。答有。食欲食。犯波罗夷

问颇有比丘知食家中强坐。不犯波夜提耶。答有。天龙家坐。突吉罗。乃至富单那等家中亦如是。童女黄门二根坏根。皆突吉罗。三种人不犯。聋盲等五种人及非人出家亦如是。立亦如是。除请食。不犯

如佛所说。若比丘裸形外道女自手与食。波夜提。颇有自手与食不犯耶。答有。与宿食。犯突吉罗。使他与。突吉罗。欲教化与不犯与亲里。突吉罗。放地与。突吉罗。作分已着地语言随意食。突吉罗

问如佛所说。若比丘往看军。波夜提。颇有比丘观军不犯耶。答有。若捉得多贼比丘为厌故往看。不犯。看天龙乃至富单那军。突吉罗。过再宿或看斗战戒亦如是

问如佛所说。若比丘嗔恚打比丘。波夜提。颇有比丘打不犯耶。答有。打本犯戒等四种人聋盲等。突吉罗。彼打性住比丘亦如是。打天龙亦如是。天龙等出家打比丘亦如是。性住比丘打彼比丘亦如是。颇有比丘打比丘得百千罪耶。答有。若比丘大众中嗔恚手把沙豆等掷诸比丘。随所著随得尔所波夜提。不著者。突吉罗

问如佛所说。若比丘知粗罪覆藏。波夜提。颇有覆藏不犯耶。答有。覆藏本犯戒乃至污染比丘尼人粗罪。突吉罗。彼五种人覆藏比丘粗罪亦如是。学戒人覆藏粗罪。波夜提。覆藏非人出家粗罪聋盲等粗罪。突吉罗。彼覆藏比丘粗罪亦如是

问如佛所说。语比丘汝来当与汝多美食。彼作是言。汝去。是事应广说。颇有比丘作是语不犯波夜提耶。答有。遣本犯戒等五种人非人出家等遣还突吉罗。彼等遣还亦如是。聋盲等亦如是。中国人遣边地人。边地人遣中国人亦如是。遣使手印亦如是。及余沙门婆罗门亦如是

问如佛所说。若比丘无病露地然火。波夜提。颇有比丘露地然火不犯耶。答有。本犯戒人乃至污染比丘尼。突吉罗。非人等出家然火。突吉罗。三种人等然火。不犯。聋盲等然火。突吉罗。中国人为边地人。边地人为中国人然火。突吉罗。遣使手印然火。突吉罗。烧酥油石蜜等。突吉罗。诸贼天龙乃至富单那等使然火。不犯。为众僧为性住比丘然火。不犯

问如佛所说。比丘共未受具戒人过二夜宿。波夜提。颇有比丘过二夜宿不犯耶。答有。共黄门二根过二夜宿。突吉罗。共化人过二夜宿。突吉罗。本犯戒乃至污染比丘尼人。共未受具戒人宿过二夜。突吉罗。比丘聋盲喑哑共未受具戒人宿过二夜。突吉罗。非人出家作比丘性住比丘共宿过二夜。突吉罗。相违亦如是。非人如前说。学戒人共未受具戒人宿过二夜。突吉罗

问如佛所说。若比丘如法僧事与欲竟。后言不与。波夜提。颇有与已后言不与不犯耶。答有。受法比丘与不受法比丘欲已。后言不与。突吉罗。相违亦如是。本犯戒乃至污染比丘尼聋盲喑哑及非人出家等。作比丘与欲已。后言不与。皆突吉罗。学戒人与欲已。后言不与。波夜提

若比丘于摈比丘边出罪共法食。波夜提。于狂痴乃至重病比丘所出罪。突吉罗

若有沙弥作是语。我知如来法。是事应广说诸比丘与作灭羯磨。后沙弥忏悔已。应舍不。答应舍

问如佛所说。若比丘得新衣。应三种坏色。不坏色。波夜提。颇有比丘不坏色不犯耶。答有。谓不净衣

问如佛所说。若比丘自取宝。波夜提。颇有比丘自取宝犯僧伽婆尸沙耶。答有。谓取女宝似女宝。犯僧伽婆尸沙。盗心取。波罗夷。取轮宝摩尼宝。突吉罗。捉象宝马宝不犯。非人金银坐卧具得坐卧。器得用食

问如佛所说。半月应浴。半月内浴。波夜提。颇有比丘减半月内浴。不犯耶。答有若被雨所渍因缘等。不犯

问如佛所说。若比丘故夺畜生命。波夜提。颇有故夺畜生命。不犯耶。答有。狂痴乃至重病。不犯。本犯戒人。乃至非人出家故夺畜生命。突吉罗。学戒人故夺命。波夜提。沙弥故夺命。突吉罗

问如佛所说。若比丘故令他比丘疑悔。波夜提。颇有比丘故令他疑悔。不犯耶。答有。除受具足戒以余事令疑悔。突吉罗。本犯戒人令性住比丘疑悔。突吉罗。乃至遣使手印。突吉罗。中国人令边地人。边地人令中国人疑悔。突吉罗

问如佛所说。若比丘指挃。波夜提。颇有比丘指挃不犯耶。答有。若比丘身根坏挃。突吉罗。以水渧身根。突吉罗。俱身根坏挃。突吉罗。挃未受具戒人。突吉罗。本犯戒等挃比丘。突吉罗。相违亦如是

问如佛所说。若比丘水中戏。波夜提。颇有比丘水中戏不犯耶。答有。本犯戒人乃至非人等出家水中戏。突吉罗。除水余事戏。突吉罗。学戒人戏。波夜提。戏有五种。戏笑乐掉没

问如佛所说。若比丘共女人宿。夜波提。云何女人。答身可捉者共天女宿突吉罗。龙女畜生女等共宿。突吉罗。若比丘草林树林竹林树孔中共女人宿。突吉罗。学戒人共女人宿。波夜提。本犯戒人共女人宿。突吉罗。天女紧那罗女鬼女等共宿亦如是

问如佛所说。若比丘恐怖比丘。波夜提。颇有比丘恐怖比丘不犯耶。答有。恐怖非人出家比丘。突吉罗。非人出家恐怖比丘。突吉罗。中国人怖边地人边地人怖中国人。突吉罗。遣使手印怖。突吉罗

问如佛所说。若比丘藏比丘衣钵等。波夜提。颇有比丘藏衣钵等物不犯耶。答有。藏非人出家衣钵等物。突吉罗。相违亦如是。遣使手印藏亦如是。藏尼萨耆衣钵。突吉罗。藏痴狂乃至重病人衣钵等物。突吉罗。受法比丘藏不受法比丘衣钵等物。突吉罗。藏诸余沙门婆罗门衣物等。突吉罗

受法比丘与不受法比丘衣已不语辄用。突吉罗。相违亦如是。本犯戒乃至污染比丘尼非人。乃至富单那等出家与衣已不语辄用。突吉罗。学戒与比丘衣已辄用。波夜提。性住比丘与彼衣已不语辄用。突吉罗

问几种人受持衣。答五种人净施七种人

问如佛所说。若比丘以无根僧残罪谤比丘。波夜提。颇有谤不犯耶。答有。谤非人出家非人出家谤比丘。皆突吉罗。学戒人谤。波夜提。谤学戒人。突吉罗。谤痴狂乃至中国人。中国人谤边地人。边地人谤中国人。皆突吉罗

问如佛所说。若比丘无男子共女人道行。波夜提。颇有比丘共女人道行不犯耶。答有。共化女道行。突吉罗。天女乃至富单那女共道行。突吉罗。非人等出家共女人道行。突吉罗。非人者如前说。本犯戒乃至聋盲喑哑等共女人道行。突吉罗。共童女黄门三根道行。突吉罗

问如佛所说。若比丘共贼道行。波夜提。颇有共贼道行不犯耶。答有。本犯戒乃至污染比丘尼聋盲喑哑乃至非人等贼共道行。突吉罗。非人出家共贼道行亦如是

问如佛所说。若比丘不满二十年人与受具戒。波夜提。颇有与不满二十年人受具戒不犯耶。答有。不满二十年作满想。与受具足戒共食共住。不犯。共彼人几时住。答乃至未决定时决定知已。应不令在比丘地。应更与受具戒。若不与受具戒经三布萨。若白四羯磨。是名贼住。应灭摈

问如佛所说。若比丘自手掘地使人掘。波夜提。掘何等地若不烧不坏地掘烧坏地。突吉罗。

问如佛所说。若比丘过四月受请。波夜提。颇有过四月受不犯耶。答有。受四月请。四事中一一请已。于中索余。突吉罗。过四月已余事请索余事。波夜提。安居中请食更索食。突吉罗。病索不犯

问如佛所说。若比丘是中应学。应广说。颇有比丘作是语不犯耶。答有。若使学非法不学。不犯。受法比丘使不受法比丘学五法不学。不犯。不受法比丘语受法比丘。学是法我不学。突吉罗。语非人出家。乃至中国语边地边地语中国。突吉罗。学戒人语。波夜提

问如佛所说。若比丘诸比丘斗诤默然屏处听。波夜提。颇有比丘屏处听不犯耶。答有。听比丘尼斗诤。突吉罗。乃至听沙弥尼斗诤亦如是。比丘尼亦如是。本犯戒乃至污染比丘尼听斗诤。突吉罗。学戒听。波夜提

问如佛所说。若比丘僧断事时默然起去。波夜提。颇有默然起去不犯耶。答有。若比丘未作白。起至大小行处还语已去。不犯。去时不舍闻处。不犯

问如佛所说。若比丘不恭敬上座。波夜提。颇有比丘语上座。不犯波夜提耶。答有。若上座断事时中间说非法事。年少比丘说法于中语。不犯。相违亦如是

问米苦酒澄清无腻非时得饮不。答不得饮

问根浆华茎果浆非时得饮不。答得。得几时饮。乃至未舍自性得饮。过时不得饮

问几处不白入聚落不犯耶。答三处。谓阿练若处。聚落中。神足空中。行不白入。不犯。伴不解性住比丘语不白入聚落。不犯。在地白空中入。不犯相违亦如是。界内界外白入。不犯。有比丘不白入。波夜提。不白非人出家入。不犯。乃至污染比丘尼及余沙门婆罗门等不白入。不犯

问颇有比丘受请已食前食后不白去。至二三家。不犯耶。答有。若有衣食请去。不犯。非五种食。不犯

问若比丘夜未晓未藏宝至城门。突吉罗。至四天王夜叉等城门。突吉罗

若比丘说戒时。作是言。我始知是戒。不犯耶。答有。谓不共戒共戒者。波夜提。比丘尼亦如是。若比丘以角牙齿骨作针房。波夜提。颇有作不犯耶。为他作。突吉罗。他作与。不犯

问颇有过修伽陀八指作床脚不犯波夜提耶。答有。若用牙摩尼作。突吉罗

问如佛所说。若众僧坐床卧床。自以兜罗絮缝着床解去。波夜提悔颇有不解去。不犯耶。答有。若以余物作突吉罗雨衣戒。覆疮衣戒。尼师檀戒。佛衣等量戒不净亦如是

问波夜提竟

    问波罗提提舍尼事

白衣舍从三种人边受食。突吉罗。谓贼住人。本犯戒人。本不和合人。比丘在空中受食。比丘在界内从界外比丘尼边受食。不犯。从亲里受食。不犯。非亲里同意受。不犯。遣使手印受。不犯

若比丘入白衣家乞食。比丘尼语居士言。与是比丘食比丘受食。突吉罗。为他受食。突吉罗。遣使手印受突吉罗。亲里不犯

若怖畏阿练若处不病内受食。突吉罗。如佛所说比丘语居士言。此中有怖畏。居士问比丘言。此中有贼不。有者我当语王。比丘应言无。界外受。不犯。若道中食。不犯。比丘遮居士言。莫入。自入不犯。比丘若狂。不犯

问颇有比丘学家中受食。不犯耶。答有。若先请若病。不犯。波罗提提舍尼竟

毗尼摩得勒伽略说七千偈。一偈有三十二字。七千偈便有二十二万四千言。十卷成

萨婆多部毗尼摩得勒伽卷第十


萨婆多毗尼毗婆沙

    No. 1440

萨婆多毗尼毗婆沙卷第一

        失译人名今附秦录

    总序戒法异名等

佛陀者。秦言觉。觉了一切法相故。复次一切众生长眠三界。佛道眼既开自觉觉彼。故名为觉。佛于一切法。能一切知能得一切说。问曰。佛云何一切说。为应时适会随宜说耶。为部党相从而说法耶。答曰。佛随物适时说一切法。后诸集法藏弟子以类撰之。佛或时为诸弟子制戒轻重有残无残。撰为律藏。或时说因果相生诸结诸使及以业相。集为阿毗昙藏。为诸天世人随时说法。集为增一。是劝化人所习。为利根众生说诸深义。名中阿含。是学问者所习。说种种随禅法。是杂阿含。是坐禅人所习。破诸外道。是长阿含。问曰。佛若一切说者。有经云。佛坐一树下捉一枝叶。问弟子曰。此枝叶多树上叶多。白佛言。树上叶多。佛言。我所知法如树上叶。我所说法如手中叶。云何言佛一切说耶。答曰。有别相一切总相一切。今言别相一切。有言。佛能一切说。但众生不能一切尽受。佛非不能说有言。应云一切知直云说也。不得言一切说。问曰。若佛知而能说。声闻辟支佛亦知而能说。何不称佛耶。答曰。不尔。佛知说俱尽。声闻辟支佛知说。于法有所不尽。复次佛解一切法尽能作名。二乘不能。复次佛得无边法能无边说。二乘不能。复次有共不共。声闻辟支佛所得共。佛所得不共。小乘所得三乘同知。中乘所得二乘共知。唯佛所得二乘不知独佛自知。复次函大盖亦大。法相无边。佛以无边智。知彼无边法。二乘智有边故。不称知法相。复次有根有义。根者。慧根。义者。慧所缘法。佛根义俱满。慧所缘法无所不尽。二乘根义二俱不满。复次佛得如实智名。于一切法相如实了故。二乘知法不尽深底。兼有所不周。是以不得称如实知。以是种种义故。二乘不得称佛陀。婆佉婆者。不可以音转。可以义解义。云世尊。以能知一切对治法故。复次世法言音不同。世人自不相解。佛悉知之。故云世尊。复次勒比丘。亦云凡二乘。凡夫自说得法。或乐静默或入禅定。或以余缘。或秘惜不说。佛所得法。以慈悲力故。乐为他故。复次云已破三毒故。得称世尊。问曰。二乘亦破三毒。何不名世尊耶。答曰。不尔。二乘有退。佛不退故。退有三种。果退不果退所用退。果退者。小乘三果退。下果不退。中乘二种。若百劫习行成辟支佛不退。若本是小乘三果作辟支佛。则果有退。佛果不退。不果退者。若向三乘人未得而退。若比丘修三业懈堕不进。凡所修习退而不勤。名不果退也。所用退者。凡有所得法不现前用。如佛十力小乘十智。用一余则不用。如诵十万言经。若不诵时。尽名所用退也。小乘不果退。中乘亦有不果退。佛无不果退。于一切行中无不勤故。二乘有所用退也。佛则不定。又云佛十力中用一不用九。故名退也。又云无不用退。如诵二十万言经。凡人力劣故。或一日二日诵讫。佛能即时诵讫。十力亦尔。用能即用无障碍故。无不用退。又云佛无不用退。如着泥洹僧时。不直尔着。如凡人法。皆为利众生故。凡所用法。有益则用无益则不用。非不能用故。无不用退也。虽各有所解。而云不可定也。佛意不可思议。问曰。小乘何故三果退下果不退。答曰。三果以曾得故退。下果未曾得故不退。如人饥得美食久则不忘。此义亦尔。又云。下果忍作无碍道智。作解脱道。三果智作无碍道智。作解脱道故退。又云。见谛道无退。思惟道有退。净不净想断结故。思惟道有逼迫。见谛道无逼迫。见缔结见理。思惟生故逼迫不退也。有云。见谛智力强。如大梁镇物。思惟智弱故退也。有云。见谛欲界忍智二心。能断九品。上界忍智二心。断七十二品。结尽无色界故不退也。以是义故独名世尊也。复次佛习气尽。二乘习气不尽。如牛齝比丘常作牛齝。以世世牛中来故。如一比丘。虽得漏尽而常以镜自照。以世世从淫女中来故。如一比丘常跳棚踯阁。以世世猕猴中来故。不得名世尊。凡言如是我闻者。佛在世时言我闻为是灭后。答曰。佛自说法何由言闻。是灭后也。撰法藏者言我闻。佛二十年中说法。阿难不闻何得言我闻。答曰。云诸天语阿难。有云。佛入世俗心令阿难知。有云。从诸比丘边闻。有云。阿难从佛请愿。愿佛莫与我故衣。莫令人请我食。我为求法恭敬佛故。侍佛所须不为衣食。诸比丘晨暮二时得见世尊。莫令我尔。令我欲见便见。有佛二十年中所说法。尽为我说。问曰。二十年中所说多。何由可说。答曰。善巧方便能于一句法中演无量法。能以无量法为一句。佛粗示其端绪。阿难尽得。以智速利强持力故。八万法藏者。又云。如树根须枝叶多。名为一树。佛为一众生始终说法。名为一藏。如是八万。有云。佛一坐说法。名为一藏。如是八万。有云。十六字为半偈。三十二字为一偈。如是八万。有长短偈。三十二字为一偈。如是八万。有云。如半月说戒。为一藏。如是八万。有云。佛自说六万六千偈。为一藏。如是八万。有云。佛说尘劳有八万。法药亦有八万。名八万法藏。问曰。契经阿毗昙不以佛在初。独律诵以佛在初。答曰。以胜故。秘故。佛独制故。如契经中。诸弟子说法。有时如释提桓因。自说布施为第一。何以故。我以施故。得为天王。所愿如意。佛言。如是。有时化作化佛。化佛说法。律则不尔。一切佛说。是故以佛在初。有如契经随处随决。律则不尔。若屋中有事不得即结。必当出外。若白衣边有事。必在众结。若聚落中有事。亦在众结。若于五众边有事。必当比丘比丘尼边结。是以佛在初。毗耶离者。或有国以王为名。或以地为称。或以城为号。此国以龙名目。迦兰陀聚落者。以鸟名之。有云。聚落主名。须提那者。父母求请神祇得故。名曰求得。富贵者。富有二种。一众生类。二非众生类。非众生类者。多有金银七宝仓库财帛田畴舍宅。众生类者。奴婢仆使象马牛羊村落封邑。故名富。贵者。或为村主。或有德美人所宗重。故言贵也。多财种种成就。自归三宝受三归法。问曰。三归以何为性。有论者。言三归是教无教性。受三归时。胡跪合掌口说三归。是名身口教。若淳重心有身口无教。是谓教无教也。有云。三归是三业性身口意业。有云。三归是善五阴。以众生善五阴为三归。以三宝为所归。所归以救护为义。譬如有人有罪于王。投向异国以求救护异国王言。汝求无畏者。莫出我境界。莫违我教。必相救护。众生亦尔。系属于魔有生死过罪。归向三宝以求救护。若诚心三宝更无异向。不违佛教。于魔邪恶无如之何。如昔有一鸽为鹰所追。入舍利弗影战惧不安。移入佛影泰然不怖。大海可移此鸽不动。所以尔者。佛有大慈大悲。舍利弗无大慈大悲。佛习气尽。舍利弗习气未尽。佛三阿僧祇劫修菩萨行。舍利弗六十劫中修习苦行。以是因缘鸽入舍利弗影中。犹有怖畏。入佛影中而无怖畏。问曰。若归向三宝能除罪过息怖畏者。提婆达多亦归依三宝。以信出家受具足戒。而犯三逆堕阿鼻狱。答曰。凡救护者。救可救者。提婆达多罪恶深大。兼是定业。是故叵救。问曰。若有大罪佛不能救。若无罪者不须佛救。云何三宝能有救护。答曰。提婆达多虽归三宝。心不真实。三归不满。常求利养名闻。自号一切智人。与佛共竞。以是因缘。三宝虽有大力。不能救也。如阿阇世王。虽有逆罪应入阿鼻狱。以诚心向佛故。灭阿鼻罪入黑绳地狱。如人中七日重罪即尽。是谓三宝救护力也。问曰。若调达罪不可救者。又经云。若人归依佛者。不堕三恶道。是义云何。答曰。调达以归三宝故。虽入阿鼻狱。受苦轻微。亦时得暂息。有如人在山林旷野怖畏之处。若念佛功德怖畏即灭。是故归依三宝。救护不虚也。三宝于四谛中。何谛所摄。于二十二根中。何根所摄。于十八界中。何界所摄。十二入中。何入所摄。于五阴中。何阴所摄。三宝于四谛中。二谛所摄。根中三根所摄。未知根已知根无知根。十八界中三界所摄。意界意识界法界。十二入中意入法入所摄。五阴中无漏五阴所摄。佛宝于四谛中。道谛少入。法宝于四谛中。尽谛所摄。僧宝于四谛中。道谛少入。佛宝于二十二根中。无知根所摄。法宝是尽谛无为故。非根所摄。僧宝二十二根中。三无漏根所摄。佛宝于十八界中。意界意识界法界少入。十二入中意入法入少入。五阴中无漏五阴少入。法宝于十八界中。法界少入。十二入中法入少入。法宝非五阴所摄也。阴是有为。法宝是无为故。僧宝于十八界中。意识界法界少入。十二入中意入法入少入。五阴中无漏五阴少入。问曰。归依佛者。为归依释迦文佛。为归依三世佛耶。答曰。归依三世佛。以法身同故。若归依一佛。则是归依三世诸佛。以佛无异故。又云。若归依三世诸佛者。有诸天自说。我是迦叶佛弟子。我拘留孙佛弟子。如是七佛中。各称我是某佛弟子。以是因缘。正应归依一佛。不应三世佛也。又云不应尔也。何以故。如毗沙门经说。毗沙门王归依三宝。归依过去未来现在佛。以是义故。应归依三世诸佛。问曰。若尔者如诸天各称某甲佛弟子。此义云何。答曰。诸天所说何足以定实义。有诸天各称一佛为师。亦归依三世诸佛。直以一佛为证耳。问曰。何所归依名为归佛。答曰。归依语回转。一切智无学功德。问曰。为归依色身归依法身耶。答曰。归依法身。不归依色身。不以色身为佛故也。问曰。若色身非佛者。何以出佛身血而得逆罪。答曰。以色身是法身器故。法身所依故。若害色身则得逆罪。不以色身是佛故得逆罪也。归依法者。何所归依名归依法。答曰。归依语回转。断欲无欲尽谛涅槃。是名归依法也。问曰。为归依自身尽处他身尽处。答曰。归依自身尽处。亦他身尽处。是归依法。问曰。若归依僧者。何所归依。答曰。归依语回转。良祐福田声闻学无学功德。是名归依僧。问曰。为归依俗谛僧。为归依第一义谛僧。若归依第一义谛僧者。佛与提谓波利受三自归。不应言未来有僧。汝应归依第一义谛僧。常在世间故。答曰。以俗谛僧是第一义谛僧所依。故言未来有僧汝应归依。有欲尊重俗谛僧故如是说。佛自说一切诸众中佛众为第一。譬如从乳出酪从酪出酥从酥出醍醐。醍醐于中最胜最妙。最为第一。佛弟子众亦复如是。若有众僧集会。是中必有四向四得无上福田。于一切九十六种中最尊最上。无能及者。是故言未来有僧汝应归依。不伤正义也。问曰。佛亦是法。法亦是佛。僧亦是法。正是一法。有何差别。答曰。虽是一法。以义而言有种种差别。以三宝而言无师大智及无学地一切功德。是谓佛宝。尽谛无为。是谓法宝。声闻学无学功德智慧。是谓僧宝。以法而言无师无学法。是谓佛宝。尽谛无为非学非无学法。是名法宝。声闻学无学法。是名僧宝。以根而言。佛是无知根。法宝非根法也。僧是三无漏根。以谛而言。佛是道谛少入。法宝是灭谛。僧是道谛少入。以沙门果而言佛是沙门。法宝是沙门果。僧是沙门。法宝是沙门果。以婆罗门而言。佛是婆罗门。法宝是婆罗门果。僧是婆罗门。法宝是婆罗门果。以梵行而言。佛是梵行。法宝是梵行果。僧是梵行。法宝是梵行果。以因果而言。佛是因。法宝是果。僧是因。法宝是果。以道果而言。佛是道。法宝是道果。僧是道。法宝是道果。佛以法为师。佛从法生。法是佛母。佛依法生。问曰。佛若以法为师者。于三宝中何不以法为初。答曰。法虽是佛师。而法非佛不弘。所谓道弘由人也。是以佛在初。问曰。若受三归。或时先称法宝后称佛者。成三归不。答曰。若无所晓知说不次第者。自不得罪。得成三归。若有所解故倒说者。得突吉罗。亦不成三归。问曰。若称佛及法不称僧者。成三归不。若称法僧不称佛宝。成三归不。若称佛僧不称法宝。成三归不。答曰。不成三归。问曰。若不受三归。得五戒不。若不受三归。得八斋不。若不受三归。得十戒不。若不白四羯磨。得具戒不。答曰。一切不得。若欲受五戒。先受三归。受三归竟。尔时已得五戒。所以说五戒名者。欲使前人识五戒名字故。白四羯磨竟。已得具戒。所以说四依四堕十三僧残者。但为知故说也。有言。受三归竟说不杀一戒。尔时得戒。所以说一戒得五戒者。为能持一戒五戒尽能持故。有以五戒势分相着故。兼本意誓受五戒故。有言。受五戒竟然后得戒。于诸说中。受三归已得五戒者。此是定义。如白四羯磨法。若受八戒若受十戒。如五戒说。若五戒十戒八戒。但受三归便得戒。若受具戒要白四羯磨。而得具戒。不以三归也。凡具戒者。功德深重。不以多缘多力无由致得。是故三师十僧白四羯磨而后得也。五戒八戒十戒。功德力少。是故若受三归。即便得戒。不须多缘多力。受具戒已。何以但说四波罗夷十三僧残。不说余篇耶。此二篇戒最是重者。一篇戒若犯永不起。二篇虽起难起。若波利婆沙摩那埵。二十众中而后出罪。若难持而能持者。余易持戒不须说也。是故但说二篇。不说余篇。问曰。是波罗提木叉戒。是无漏戒。是禅戒不。答曰。非无漏戒。亦非禅戒。此波罗提木叉戒。若佛在世则有此戒。佛不在世则无此戒。禅无漏戒。若佛在世若不在世。一切时有波罗提木叉戒。从教而得。禅无漏戒不从教得。波罗提木叉戒从他而得。禅无漏戒不从他得。波罗提木叉戒。不问眠与不眠善恶无记心。一切时有。禅无漏戒。必无漏心中禅心中有戒。余一切心中无也。波罗提木叉戒。但人中有。禅无漏戒人天俱有。波罗提木叉戒。但欲界中有。禅戒无漏戒。欲色界俱有。无色戒成就无漏戒。波罗提木叉戒但佛佛弟子有。禅戒外道俱有。问曰。优婆塞五戒。几是实罪。几是遮罪。答曰。四是实罪。饮酒一戒是遮罪。饮酒所以得与四罪同类结为五戒者。以饮酒是放逸之本也能犯四戒。如迦叶佛时。有优婆塞。以饮酒故。邪淫他妇盗他鸡杀。他人问言。何以故尔。答言。不作。以酒乱故。一时能破四戒。又以饮酒故。能犯四逆。唯不能破僧耳。虽非宿业有狂乱报。以饮酒故。迷惑倒乱犹若狂人。以饮酒故。废失正业坐禅诵经佐助众事。虽非实罪。以是因缘与实罪同例。问曰。优婆塞戒。但于众生上得戒。非众生上亦得戒不。但于可杀可盗可淫可妄语众生上得戒耶。若于不可杀不可淫不可盗不可欺诳众生亦得戒耶。答曰。于众生上得四戒。于非众生上得不饮酒戒。若众生可杀不可杀可盗不可盗可淫不可淫可妄语不可妄语一切得戒。下至阿鼻地狱。上至非想处及三千世界。乃至如来一切有命之类。尽得此四戒。以初受戒时一切不杀一切不盗一切不淫一切不妄语无所限齐。以是故。一切众生上无不得戒。凡受戒法。先与说法引导开解。令于一切众生上起慈愍心。既得增上心。便得增上戒。夫得戒法。于一切众生上。各得四戒。四戒差别有十二戒。于一切众生上。不杀不盗不淫不妄语。凡起四恶。有三因缘。一以贪故起。二以嗔故起。三以痴故起。于一切众生上。有十二恶。以反恶故。得十二善戒色也。一切无边众生上亦复如是。后有百万千万阿罗汉。入于涅槃。先于此阿罗汉上所得戒。始终成就不。以罗汉泥洹故。此戒亦失也。得不饮酒戒时。此一身始终三千世界内。一切所有酒上。咽咽得戒色。以受戒时一切酒尽不饮故。设酒灭尽。戒常成就而不失也。先受戒时。于一切女人上三疮门中。得不淫戒。而后取妇。犯此戒不。答曰不犯。所以尔者。本于女上。得不邪淫戒。今是自妇。以非邪淫故。不犯此戒。以此语推一切同尔。以八戒十戒众生非众生类得戒亦如是。二百五十戒。一切众生上各得七戒。以义分别有二十一戒。如一众生上起身口七恶。凡起此恶有三因缘。一以贪故起。二以嗔故起。三以痴故起。以三因缘起此七恶。三七二十一恶。反恶心得戒。一众生上。得二十一戒色。一切众生上亦复如是。有五种子。如一种子中破一粒麦一粒粟。断一根果。摘一枝叶。随所破所断。各得一罪。随所得罪处。反罪得戒得尔所戒。本受戒时不杀一切草木。一切草木上尽得戒色。如不掘地戒。一微尘上得一戒色。三千世界下至金刚地际。一一微尘上得一戒色。亦复如是。二百五十戒中。若众生非众生类上得戒多少。以义而推可以类解。得戒时一时。一一戒上得无量戒。如一不杀戒。一众生上各得三戒。凡杀法以三因缘故杀。一以贪故。二以嗔故。三以痴故杀。以反杀得三戒色。若以贪故杀一人者。于一人上。三不杀戒中。但犯一不杀戒。二不杀戒不犯。一切众生上一切不犯。而犯此一戒。得波罗夷。以罪重故。譬如穿器不受道水。不能得沙门四果故。名非沙门。初犯一戒已毁破受道器。名波罗夷。后更杀人得突吉罗。实罪虽重无波罗夷名。以更无道器可破故。而此比丘。故名破戒比丘。不名非比丘也。以此义推。可一时得无量戒。不可一时尽犯也。而得一时舍戒也。凡破戒法。若破重戒更无胜进。后还舍戒后更受者。更不得戒也。如破八戒中重戒。更受八戒若受五戒若受十戒若受具戒。兼禅无漏戒一切不得。若破五戒中重戒。若更受八戒十戒具戒。并禅无漏戒一切不得。若破五戒中重戒已。欲舍五戒更受戒者。无有是处。若舍戒已。更受五戒若受八戒十戒具戒。并禅无漏戒一切不得也。若破十戒具戒中重戒者。若欲胜进若欲舍戒还受戒者。如五戒中说。问曰。禅戒无漏戒波罗提木叉戒。于三戒中何戒为胜。答曰。禅戒无漏戒为胜。有云。波罗提木叉戒胜。所以尔者。若佛出世得有此戒。禅戒无漏戒一切时有。于一切众生非众生类。得波罗提木叉戒。禅戒无漏戒。但于众生上得。于一切众生上慈心。得波罗提木叉戒。禅戒无漏戒。不以慈心得也。夫能维持佛法。有七众在世间。三乘道果相续不断。尽以波罗提木叉为根本。禅无漏戒不尔。是故于三界中最为殊胜。初受戒时。白四羯磨已成就戒色始一念戒色。名业亦名业道。第二念已后所生戒色。但是业。非业道。所以尔者。初一念戒色。思愿满足。以思通故。名思业道。以前戒色为因故。后戒色任运自生。是故但名业。非业道。初一念戒。有教有无教。后次第生戒。但有无教。无有教也。初一念戒亦名为戒。亦名善行。亦名律仪。后次续生戒。亦有此三义。问曰。三世中何世得戒。答曰。现在一念得戒。过去未来是法。非众生故不得戒。现在一念是众生故得戒。亦有此三义。问曰。为善心中得戒。为不善心中。为无记心中。为无心中得戒耶。答曰。一切尽得。先以善心礼僧足已。受衣钵求和上问清净乞受戒。胡跪合掌白四羯磨已。相续善心戒色成就。是谓善心中得戒。若先次第法中。常生善心起诸教业。白四羯磨时。或起贪欲嗔恚等诸不善念。于此心中成就戒色。是名不善心得戒也。以本善心善教力故。而得此戒。非不善心力也。先以善心起于教业。白四羯磨时。或睡或眠或于眠心。而得戒色是名无记心中而得戒也。先以善心起于教业。白四羯磨时入灭尽定。即于尔时成就戒色。是名无心中而得戒也。问曰。若白衣不受五戒。直受十戒。得戒不。答曰。一时得二种戒。得优婆塞戒。得沙弥戒。若不受五戒十戒。直受具戒。一时得三种戒。问曰。若受具戒。一时得三种戒者。何须次第先受五戒次受十戒后受具戒耶。答曰。虽一时得三种戒。深习佛法必须次第。先受五戒以自调伏。信乐渐增次受十戒。既受十戒善心转深。次受具戒。如是次第得佛法味。好乐坚固难可退败。如游大海渐渐深入。入佛法海亦复如是。若一时受具戒者。既失次第。又破威仪。复次或有众生。应受五戒而得道果。或有众生。因受十戒而得道果。以是种种因缘。是故如来说此次第。若先受五戒。次受十戒。受十戒时亦成就二戒。五戒十戒。已学戒已。次受具戒。受具戒时成就三种戒。五戒十戒具戒。七种受戒中。唯白四羯磨戒。次第三时得。余六种受戒。但一时得。无三时次第得也。若一时得三种戒。若欲舍时。若言我是沙弥非比丘。即失具戒。二种戒在。五戒十戒。若言我是优婆塞非沙弥。即失十戒。五戒在。若言。在家出家一切尽舍。我是三归优婆塞。三种一时尽失。不失三归。若次第得三种戒。舍法次第。如一时得戒中说。若先受优婆塞五戒。后出家受十戒。舍五戒不。答曰。不舍。但失名失次第。不失戒也。失优婆塞名。得沙弥名。失白衣次第。得出家次第。若沙弥受具足戒时。失十戒五戒不。答曰。不失。但失名失次第。不失戒也。失沙弥名。得比丘名。失沙弥次第。得比丘次第。始终常是一戒。而随时受名譬如树叶。春夏则青秋时则黄冬时则白。随时异故树叶则异而始终故是一叶。戒亦如是。常是一戒。随时有异。有如乳酪酥醍醐四时差别。虽随时有异。而故是一乳也。戒亦如是。虽三时有异戒无异也问曰。凡受优婆塞戒。设不能具受五戒。若受一戒乃至四戒。受得戒不。答曰。不得。若不得者。有经说。有少分优婆塞多分优婆塞满分优婆塞。此义云何。答曰。所以作是说者。欲明持戒功德多少。不言有如是受戒法也。问曰。若受一日二日乃至十日五戒。得如是受不。答曰。不得。佛本制戒各有限齐。若受五戒必尽形受。若受八戒必一日一夜。是故不得异也。夫白四羯磨戒有上中下。五戒是下品戒。十戒是中品戒。具戒是上品戒。又五戒中亦有三品。若微品心受戒。得微品戒。若中品心受。得中品戒。若上品心受戒。得上品戒。十戒具戒亦各有三品。如五戒说。若微品心受戒。得五戒已。后以中上品心受十戒者。先得五戒更无增无胜。于五戒外。乃至不非时食等残余五戒。得增上五戒。先得五戒仍本微品也。即先微品五戒。更无增无胜。仍本五戒。自五戒外一切诸戒。以受具戒时心增上故。得增上戒。以是义推。波罗提木叉戒无有重得。以次第而言。五戒是微品。十戒是中品。具戒是上品。以义而推。亦可以上品心得五戒。是上品戒。中品心得十戒。是中品戒。下品心得具戒。是下品戒。以是义故。随心有上中下。得戒不同。无有定限也。若先请和上。受十戒时和上不现前。亦得十戒。若受十戒时和上死者。若闻知死受戒不得。若不闻死受戒得戒。若白四羯磨受具足戒。和上不现在前。不得受戒。以僧数不满故。若僧数满。设无和上亦得受戒。问曰。五戒优婆塞得贩卖不。答曰。得听贩卖。但不得作五业。一不贩卖畜生以此为业。若自有畜生直卖者听。但不得卖与屠儿。二者不得贩卖弓箭刀杖以此为业。若自有者直听卖。三者不得沽酒为业。若自有者亦听直卖。四者不得压油为业。以油多杀虫故。天竺法尔。自罽宾已来麻中一切无虫。若无虫处压油无过也。五者不得作五大色染为业。以多杀虫故。洛沙等外国染法多杀诸虫。是故不听。谓秦地染青法。亦多杀虫。堕五大染数。问曰。夫以斋法过中不食。乃有九法。何故八事得名。答曰。斋法以过中不食为体。以八事助成斋体。共相支持。名八支斋法。是故言八斋。不云九也。若受八戒人。于七众中为在何众。虽不受终身戒。以有一日一夜戒故。应名优婆塞。有云。若名优婆塞。无终身戒。若非优婆塞。有一日一夜戒。但名中间人。问曰。若七众外有波罗提木叉戒不。答曰。有八斋是。以是义推。若受八戒不在七众也。受八斋法。应言一日一夜不杀生。令言语决绝。莫使与终身戒相乱也。问曰。受八戒法。得二日三日乃至十日一时受不。答曰。佛本制一日一夜。不得过限。若有力能受。一日过已次第更受。如是随力多少。不计日数也。夫受斋法必从他受。于何人边受。五众边已受八戒。若鞭打众生斋不清净。虽即日不鞭打众生。若待明日鞭打众生。亦不清净。以要而言。若身口作不威仪事。虽不破斋斋不清净。设身口清净。若心起贪觉欲觉嗔恚觉恼害觉。亦名斋不清净。虽身口意三业清净。若不修六念。亦名斋不清净。受八戒已精修六念。是名斋清净。有经说。若作阎浮提王。于阎浮提中一切人民。金银财宝于中自在。虽有如是功德。以八斋功德分作十六分。阎浮提王功德。于十六分中不及一分。所谓最后清净八斋也。若人欲受八斋。先恣情女色。或作音乐。或贪饮啖。种种戏笑。如是等放逸事。尽心作已而后受斋。不问中前中后。尽不得斋。若本无心受斋。而作种种放逸事。后遇善知识即受斋者。不问中前中后。一切得斋。若欲受斋。而以事难自碍。不得自在。事难解已而受斋者。不问中前中后。一切得斋。问曰。若欲限受昼日斋法。不受夜斋得八斋不。若欲受夜斋。不受昼斋。得八斋不。答曰。不得。所以尔者。佛本听一日一夜斋法。以有定限不可违也。问曰。若不得者。如皮革中说。亿耳在旷野。是诸饿鬼种种受罪。或昼则受福。夜则受罪。或夜则受福。昼则受罪。所以尔者。以本人中昼受斋法夜作恶行。或夜受斋法昼作恶行。是以不同。此义云何。答曰。凡是本生因缘不可依也。此中说者。非是修多罗。非是毗尼。不可以定义也。有云。此是迦旃延欲度亿耳故。作变化感悟其心。非是实事。若受斋已欲舍斋者。不必要从五众而舍斋也。若欲食时趣语一人。斋即舍。凡得波罗提木叉戒者。以五道而言。唯人道得戒。余四道不得。如天道以着乐深重。不能得戒。如昔一时大目揵连以弟子有病。上忉利天以问耆婆。正值诸天入欢喜园。尔时目连。在路侧立。一切诸天无顾看者。耆婆后至。顾见目连向举一手。乘车直过。目连自念。此本人间是我弟子。而今受天福。以着天乐都失本心。即以神力制车令住。耆婆下车礼目连足。目连。种种因缘责其不可。耆婆答目连曰。以我人中为大德弟子。是故举手问讯。颇见诸天有尔者不。生天上着乐染心不得自在。是使尔耳。目连问耆婆曰。弟子有病当云何治。耆婆答曰。唯以断食为本。有时目连。劝释提桓因。佛世难值。何不数数相近咨受正法。帝释欲解目连意故。遣使敕一天子。令来反覆三唤。犹故不来。此一天子唯有一妇有一伎乐。以染欲情深。虽复天王命重。不能自割。后不获已而来。帝释问曰。何故尔耶。即以实而对。帝释白目连曰。此天子唯有一天女一妓乐。以自娱乐。不能自割。况作天王。种种宫观无数天女。天须陀食自然百味。百千妓乐以自娱乐。视东忘西。虽知佛世难遇正法难闻。而以染乐缠缚不得自在。知可如何。凡受戒法。以勇猛心自誓决断。然后得戒。诸天着乐心多善心力弱。何由得戒。饿鬼以饥渴苦身心焦然。地狱无量苦恼种种楚毒。心意着痛无缘得戒。畜生中以业障故。无所晓知无受戒法。虽处处经中说龙受斋法。以善心故。而受八斋。一日一夜得善心功德。不得斋也。以业障故。以四天下而言。唯三天下。阎浮提瞿耶尼弗婆提。及三天下中间海洲上人一切得戒。如瞿耶尼。佛遣宾头卢。往彼大作佛事。有四部众。东方亦有比丘。在彼而作佛事。有四部众。唯郁单越无有佛法。亦不得戒。以福报障故。并愚痴故。不受圣法。有四种。一男二女三黄门四二根。四种人中。唯男女得戒。二种人不得戒。黄门二根。如是男女中。若杀父母杀阿罗汉出佛身血破僧轮污比丘尼贼住越济人断善根。如是等人尽不得戒。大而观之。爱佛法者盖不足言。若天若龙若鬼神若郁单越若不男二根种种罪人。尽得受三归也。问曰。三世诸佛得戒等不。答曰。不等。凡得戒者。于众生非众生类上得戒。而一佛出世。度无量阿僧祇众生。入无余涅槃。而后佛出世。于此众生尽不得戒。如是诸佛先后得戒各各不等。如迦叶佛。度无数阿僧祇众生。入无余涅槃。而迦叶佛于此众生尽皆得戒。释迦文佛于此众生尽不得戒。一切诸佛有三事等。一者行等。二者法身等。三度众生等。一切诸佛尽三阿僧祇劫修菩萨行。尽具五分法身十力四无所畏十八不共法。尽度无数阿僧祇众生入于泥洹。问曰。经云。一佛出世度九十那由他众生入于泥洹。何以言无数阿僧祇众生耶。答曰。此经说一佛出世度九十那由他众生者。但云从佛得度者有尔所众生。而众生或自从佛得度。或从佛弟子。或遗法中而得度者。言九十那由他众生。直佛边得度者。统而言之。无数阿僧祇众生入无余泥洹。三世诸佛三事尽等。而得戒不等。问曰。恶律仪戒。众生类非众生类上得那。能以不能尽得戒不。答曰。但于众生上得恶律仪戒。非众生类上不得恶律仪戒。有云但于能杀众生上得恶戒。不可杀众生上不得恶戒。有云。可杀不可杀众生上。尽得恶戒。如屠儿杀羊。常怀杀心作意。杀羊无所齐限。设在人天中。今者不杀而受生展转。有堕羊中理。是故于一切众生。尽得恶戒。十二恶律仪亦如是。十二恶律仪者。一者屠羊。二者魁脍。三者养猪。四者养鸡。五者捕鱼。六者猎师。七者网鸟。八者捕蟒。九者咒龙。十者狱吏。十一者作贼。十二者王家常差捕贼人。是为十二恶律仪。养蚕皆不离恶律仪也。恶律仪戒有三时舍。死时。欲爱尽时。受律仪戒时。如受三归时。始初一说即舍恶戒。第二第三说时即得善戒。问曰。善戒人作恶戒人时。何时舍善戒得恶戒。答曰。一说言我作屠儿。即舍善戒。第二第三说我作屠儿。即得恶戒。又云。随何时舍善戒即得恶戒。若善戒人未自誓作屠儿。但以贪利养。共屠儿作杀害事。尔时名犯善戒。未舍善戒未得恶戒。必自誓作屠儿。而得恶戒。若受恶戒自誓便得。不从他受。若欲受一日二日乃至十日一年二年恶律仪戒。随誓心久近随意即得。所以尔者。以是恶法顺生死流无胜进义。是故随心即得。不同善律仪也

萨婆多毗尼毗婆沙卷第一萨婆多毗尼毗婆沙卷第二

        失译人名今附秦录

    七种得戒法

问曰。佛在世几年便听白四羯磨受戒。答曰。有言。佛初得道一年后听白四羯磨受具足戒。有言。四年后。有言。八年后。以义而推。八年者是正义也。佛以二月八日弗星现时。初成等正觉。亦以二月八日弗星出时生。以八月八日弗星出时转法轮。以八月八日弗星出时取般涅槃。佛初得道于七七日中。游诸法门及观众生。初七日八喜法门。第二七日入乐法门。第三七日入诸解脱。第四七日游入大舍。第五七日入逆顺观十二因缘。第六七日重复游历前诸法门。第七七日观诸众生应受化者。问曰。佛三阿僧祇劫习菩萨行。为成佛道度诸众生。何故四十九日游诸法门而不度耶。答曰。佛先自安身而后度彼。是故游诸法门以自娱乐。令身心调适后度众生。又为憍陈如五人根未熟故。又为佛法尊重故。详而后说。又为满梵天王本愿故。梵天王本愿。成佛道时要先请佛转于法轮。是故待梵天王请而后说法。过七七日佛即生念。令梵天王知。尔时梵王。如屈伸臂顷。于色界没来至佛所。请转法轮。佛受彼请已。然后观诸众生谁应度者。譬如大龙从大海出令密云弥布欲注大雨。观阎浮提何处国土应可雨者。佛亦如是。从无量大法海出。布慈悲云无所不遍。欲雨法雨。观诸众生谁可度者。先念阿兰迦兰待接有礼。及郁头蓝弗等异道诸师。诸人已先命终。佛即言曰。彼为长衰。甘露当开。汝何不闻。生死往来何缘得息。问曰。若彼诸人必应入道。不应命终而得闻法。若不应闻不入道者。佛何故生念欲度彼人。答曰。佛欲令众生不忘恩德。此诸人等先有小恩。佛忆欲度。而况大恩而可忘者。又此异道诸师。时人所宗咸谓得道。欲灭一切邪忆想故。明九十六种无出要法故。痛彼长衰生死不息。唯先五人应食甘露。是故诣彼鹿园欲度五人。佛与五人安居一时。或三人乞食。二人听法。或二人乞食。三人听法。问曰。何以故。二人三人各异等侣去住不同耶。答曰。三人是佛父亲。而爱多。二人是佛母亲。而见多。是故二人三人各为等侣。所以二人三人去住不同者。若二人乞食。三人听法。若三人乞食。二人听法。即得食还。佛及五人共食此食。食既得办听法不空。是故五人去住不俱。尔时五人虽未得戒。而剃发着袈裟与佛相似。六年树下给侍菩萨时。仪式已尔不适今日。安居九十日常为说法。施戒生天及阴界入种种异法以调伏之。尔时佛与五人前三月安居。过安居已至八月八日。得入见谛成须陀洹。尔时始名转于法轮授于前人。佛及五人始有六圣人在世间。次度宝称等五人。皆是善来。次度五十人。亦是善来。如是次第度人转多。佛敕诸比丘令游行世间。欲令法处处流布。尔时世人弃俗入道诣诸比丘。或三语受戒。或三归受戒。以众生宿业力故。若应三语得戒者三语则止。若应三归得戒者三归便止。以业力故。自然使尔。牛齝比丘先将七万人诣诸比丘。诸比丘各尽与三语受戒。次大迦叶来诣佛所言。佛是我师我是弟子。世尊修伽陀是我师。我是弟子。是名自誓受戒。次后优楼频螺迦叶兄弟门徒千人。舍利弗。目连等门徒二百五十人。合千二百五十人。尽是善来。所以常偏称千二百五十人者。以是诸人同是婆罗门中出家故。又以门徒师众大故。又俱是善来故。又以皆是阿罗汉故。佛遣阿难。与大爱道八法受戒。十四年后听白四羯磨受戒。凡七种受戒一者见谛受戒。二者善来得戒。三者三语得戒。四者三归受戒。五者自誓受戒。六者八法受戒。七者白四羯磨受戒。于七种中。见谛得戒唯五人得。余更无得者。善来得戒三语三归。佛在世得。灭后不得。自誓唯大迦叶一人得。更无得者。八法受戒唯大爱道一人得。更无得者。白四羯磨戒。佛在世得灭后亦得。问曰。佛与辟支佛云何得戒。答曰。无师得戒。问曰从教得戒不从。教得耶。答曰。不从教得。有言。从教得。如佛在树下结跏趺坐言。我要不解此坐而得漏尽。即身教成就。口教成就。后得漏尽。戒亦俱得。是谓身教得戒。辟支佛亦尔。若有百劫积行辟支佛。无佛法时于中出世。正得有一。不得有二。譬如犀有一角无第二角。离俗出家独处闲静。而自说偈。远离恶法当得善法。善恶俱灭然后得道。尔时亦身口教二俱成就。后得漏尽戒亦俱得。是名从教得戒。若须陀洹斯陀含阿那舍。此三道人。佛法灭后若得漏尽。是钝根辟支佛。佛法灭后。此钝根辟支佛出。不限多少。或一或二乃至众多。佛与百劫积行辟支佛。一坐漏尽无有阶差。见谛得戒。或言从教得戒。或言不从教得。言从教得者。安居一时乞食听法。身口二教亦俱成就。然后见谛戒亦俱得。是名从教得戒。佛与辟支佛及见谛得戒。是三种戒有同有异。佛与辟支佛见谛得戒。同是具戒。同障身口七恶。同无漏心中得。是名为同。云何为异。佛与辟支佛此二戒。是无师得。见谛戒是从佛得。又此二戒。大尽智现在前得。见谛戒。道未知智现在前得。又此二戒无学人得。见谛戒是学人得。是名为异。问曰。此三戒十智中。何智现前得。答曰。佛与辟支佛戒。大尽智现在前得。问曰。无漏心中云何得有漏戒。答曰。法应有尔。以业力故。无漏心中得有漏无漏二种戒。见谛戒道未知智现在前得。无漏心中得有漏无漏二种戒。亦如前说。见谛得戒。五人中憍陈如为上座。以先见谛故。善来中宝称为上座。以先来故。如是善来比丘次第为上座。三语三归亦以先至为上座。见谛得戒。善来比丘。自誓得戒。此三种得戒必从佛得。问得称佛作和上阿阇梨不。答曰。于弟子有和上阿耆利义。佛不为人作和上阿耆利。是故不得称也。从诸比丘三语三归受戒。得称和上阿耆利不。答曰。不称和上。得称阿耆利。大爱道八法受戒。亦得称阿难作阿耆利。不得作和上也

问曰。佛何以不为人作和上阿耆利。答曰。为平等故。佛等心一切令尽事以无偏。不与彼作和上。不与此作和上。又止斗诤故。若作和上阿耆利。则有亲有疏。既有亲疏则有斗诤。又为止诽谤故。若作和上。外道当言。沙门瞿昙自言慈等一切。与一作和上。不与一作和上。与凡人无异。又为成三归故。若佛作和上。则堕僧数。如受具戒三师七僧十众受戒。若作和上则入十众。若入十众即堕僧数。无有佛宝。若无佛宝不成三归。又为成四不坏净故。若作和上则无佛不坏净。又为成六念故。若作和上则无念佛。复次若作和上。弟子有病。应当看视饮食医药种种所须。岂是自在法王所应为耶。复次若作和上。弟子有病及诸苦难。则应营理供给。所乏则灭前人所有功德。如昔一时有一比丘应得罗汉。而有转轮王业障不得漏尽。佛欲除其障故。即为比丘一正富罗。转轮王福一时灭尽。即得无著。以是因缘故。若作和上有损无益。复次佛法流布有近有远。若作和上。设有弟子若欲受戒。不问近远一切尽来。则令众生多受苦恼。若不作和上阿耆利。则令诸弟子无有如是诸苦难也。复次若作和上。佛在世时理则可尔。若佛灭后谁作和上。以是种种因缘。佛不为弟子作和上阿耆利也。问曰。七种受戒几从佛得。几不从佛得。答曰。大而言之。七种受戒尽从佛得。以佛出世有是戒故。以义而推。三种戒从佛而得。一者见谛得戒。二者善来得戒。三者自誓得戒。是从佛得。余四种受戒从弟子得。一者三语。二者三归。三者八法受戒。四者白四羯磨。此四种戒从弟子得。七种受戒。几从他得。几从自得。答曰。六从他得。一须分别。见谛得戒以根本而言。以佛说法故。得证圣谛。名从他得。以义而推。自以忍智明照真谛。而得具戒。则名自得。问曰。七种戒。几白得。几不白得。答曰。六种戒不由白得。正有白四羯磨戒由白而得。问曰。七种受戒。几是业。几非是业耶。答曰。七种戒尽是业也问曰。七种戒。几是比丘。不共比丘尼。答曰。五是比丘。不共比丘尼。一者见谛戒。二者善来。三者三语。四者三归。五者自誓。问曰。七种受戒。几是比丘尼。不共比丘。答曰。一是比丘尼。不共比丘。所谓八法受戒。问曰。七种受戒。几是比丘比丘尼共。答曰。一是比丘比丘尼共。所谓白四羯磨戒也。问曰。七种戒。几通三天下。几不通三天下。答曰。一种戒通三天下。所谓白四羯磨戒也。余六种戒。但在阎浮提不通三天下。问曰。七种戒。几戒羸。几戒不羸。几戒舍。几戒不舍。几根变。几根不变。几断善根。几不断善根。答曰。一戒羸。六戒不羸。一戒舍。六戒不舍。一根变。六根不变。一断善根。六不断善根。一戒者。所谓白四羯磨戒也。以众生福德浅薄感得此戒致使不能牢固有诸灾患也。六种戒者。所谓见谛戒乃至八法受戒。以众生福德深厚。致得此戒。始终坚固无灾患也。问曰。七种戒几是增上尊重。几不尊重。答曰。大而言之。七种戒尽是尊重。以义分别则有差别也。六种得戒。众生功德力重。致得此戒。则名为胜。然不能大唯持正法。是以不胜。如见谛得戒自誓得戒八法得戒。此三种戒。正有一得无有重得。如善来得戒。极至须跋后更无得也。三语得戒三归得戒。佛成道已八年中得。八年后更无得者。白四羯磨戒。若佛在世若佛灭后一切时得。佛法始终。以白四羯磨戒为宗本。能继续三宝作无边利益。莫上于白四羯磨戒。是故于七种戒中。最胜最妙最为尊重。问曰。于七众中。几从佛得受。几不从佛得受耶。答曰。大而言之。七众尽从佛得受。以佛出世故有此七种。以事而言。七众中比丘优婆塞优婆夷三众。从佛得受。沙弥中正有二沙弥。从佛得受。一者难提。二者耶奢。余三众比丘尼式叉摩尼沙弥尼。佛不受也。为止诽谤故。佛若自受三众。外道当言。瞿昙沙门。本在王宫在婇女中。今虽出家。自度女人以自娱乐。以是因缘佛不度也。复次佛为法王。与一切众生作大师。导引众生背俗入道。先令众生信向无疑然后道教得化流天人。是故如来。舍近取远自不度也

    结淫戒因缘第一

除却须发着袈裟。问曰。不除须发得戒不。答曰。得戒。但非威仪。若无衣钵得戒不。答言。得戒。问曰。若无衣钵必得受戒者。何故必须衣钵。答曰。一为威仪故。二为生前人信敬笃心故。如猎师着袈裟鹿以服善故则无怖心。三以表异相故。内德既异外相亦异生信心者。信三宝生人天中。信邪堕三恶道。信知苦断习证灭修道。不信者。不信善恶四谛。信家非家。家者。父母兄弟妻子眷属。非家者。无常变坏不可久保故。多增贪欲嗔恚斗讼诤乱种种恶法故。非是功德善法之家。远离乡土者。夫出家者为灭垢累。家者是烦恼因缘。是故宜应极远离也。施食者。得五功德。一者得色。二者端政。三者得力。四者得辩。五者得寿。次第乞食者。一日到一家得食则食。不足即止。次第到七家得食则食。不得亦止。又云。次第从家至家。食足则止。不限多少。后日乞食。还从先次从家至家。是名次第乞食法。何故受乞食法。凡在家者多诸恼害。以众法因缘故。二以鞭打僧祇人民共相嗔恼。多诸非法因缘。食不清净。三以观他意色心不安泰。四以少欲知足修圣种故。若受檀越请者。亦有过失。以请因缘故。若食先粗更令精细。若少敕作令多。若受恶味教增众馔。又既受请心有希望。则非少欲圣种之法。五称檀上四依之教。又若受请者。常怀彼我得失之心。若乞食者。肃然无系意无增减。六以众食有尽乞食无穷。但天下有人要必有食。是以乞食无尽。佛教弟子修无尽法。佛法难成者。如人入海采宝。多没少还。入佛法海多坏少成。如以利刀自割身体。能不自伤甚为难也。受佛禁戒修净法身。内怀烦恼恶法利刀。不毁法身甚是难有。未结此者。唯说一切恶莫作。而未结五篇罪相轻重故。言未结戒也

行淫欲者。一久习烦恼故。二以须父母交会有福德子应受生故。三以余报淫不尽。如人从生至长。不行淫欲便得漏尽。有人要经淫欲而得漏尽。以宿世淫欲因缘有尽不尽故。四为结戒因缘故。若不尔者无由结戒。如是再三者。为怀妊故。其母三反三问得子便止。续种者。凡世立字各有因缘。一以宿命名字即以为名。二以星宿立字。三因缘立字。如须提那。以无子因缘故。字为续种。四因德立字。如律师因以知律名为律师。如阿毗昙师。如三藏师。是因德立字。欲想者。身口不动。但心想女人。欲觉者。心既瞢醉身体[夢-夕+登]瞢。欲热者。二身交会。集僧者。佛现不自专辄。二佛不集众共筹量轻重而后结戒。但共众和合令罪者心伏。三以如国王持国。虽得自在。凡有国事。与诸臣议之国得久住。佛法王亦尔。虽于法自在。为持佛法故。凡有法事。集众共和法得久住。四以为肃现在将来弟子。凡是僧事不问有力无力。要问众详议不得专独。五诸佛法尔不独一佛。僧者。凡有五种。一者群羊僧。二者无惭愧僧。三者别众僧。四者清净僧。五者第一义谛僧。群羊僧者。不知布萨行筹说戒自恣羯磨一切僧事尽皆不知。犹如群羊。故名群羊僧。无惭愧僧者。举众共行非法。如行淫饮酒过中食。凡是犯戒非法一切同住。名无惭愧僧。别众僧者。如羯磨死比丘物。以贪秽心。设客比丘来。不同羯磨。凡是随心别众羯磨。名为别众僧。清净僧者。一切凡夫僧持戒清净众无非法。名清净僧。第一义谛僧者。四得四向。名第一义谛僧。问曰。集僧者。五种僧中集何等僧。答曰。集二种僧。有言。三种僧虽皆非法俱是佛弟子。云何独集二种僧。义应尽集五种僧。知而故问者。一以诸佛常法。二以佛无事不知。欲令前人伏罪。顺自言治法。三以为安众生故。佛无事不知无事不见。若不问前人。自以知见说其罪过。则众生常坏怖惧不能自安。非是集众安众生法四以若逆察人心。非大人圣主仪体。知时问者。要在比丘众中问。沙弥白衣前不问。二以今是结戒时故问。有益问者。须提那常怀忧悔。今佛既问。知先作无罪得除忧悔。二以因之结戒灭将来非法。三以佛既结戒。知罪轻重有残无残可忏不可忏。决将来疑网。四以有十利功德故。有因缘问者。以结戒因缘故。是愚痴人者。佛大慈大悲兼无恶口。云何言愚痴人。答曰。佛是称实之语。非是恶口。此具缚烦恼众生。具足愚痴故。二慈悲心故。呵责折伏。如今和上阿耆利教诫弟子故。称言痴人。非是恶口。开诸漏门者。须提那于劫初来。未有男女作淫欲事。而此人于彼最初行淫。作恶法根本。今佛法清净未有非法。而须提那最初为恶。作将来非法罪过之始。故言开诸漏门。宁以身分内毒蛇口中。蛇有三事害人。有见而害人。有触而害人。有吞啮害人。女人亦尔有三种贼害人善法。若见女人心发欲想。灭人善法。若触女身犯僧残罪。灭人善法。若共交会犯波罗夷。灭人善法。若为毒蛇所害。害此一身。若为女人所害。害无数身。二者毒蛇所害。害报得无记身。女人所害。害善法身。三者毒蛇所害。害五识身。女人所害。害六识身。四者毒蛇所害。故得与众行筹说戒。得在十四人数一切羯磨。女人所害。不与僧同此众事。五者毒蛇所害。故得生天上人中值遇贤圣。女人所害。入三恶道。六者毒蛇所害。故得沙门四果。女人所害。正使八正道满于世间。犹如大海于此无益。七者毒蛇所害。人则慈念而救护之。女人所害。众共弃舍无心喜乐。天龙善神一切远离。诸贤圣人之所呵责。以如是因缘故。云宁以身分内毒蛇口中终不以此触彼女人。以十利故者。若结此戒。顺此十利功德。得此十利功德。若持一戒。将来得一戒果报。兼得十利功德果报。如是一切戒当分各尔。非一切通得十利功德也。不共住者。不共作一切羯磨同于僧事。所以不共住者。为生四部天龙鬼神信敬心故。若行恶之人与共同事。则无由信敬。二以现佛法无私无爱无憎。若清净者共住。不清净者不共住。三者为止诽谤故。若与恶人同事。外道邪见及以世人咸生诽谤。当言佛法有何可贵。不问善恶一切共事。四者以持戒者得安乐住。增上善根故。破戒者生惭愧心。折伏恶心故。有一比丘独坐林中者。以在众多事多恼妨修善法故。以二智慧偏多以在众多闻多见多语多论。虽生智慧少于禅定。宜在静处以修其心。若定多者。则宜在众广求知见。佛虽先结淫戒不得与女人行淫。未制畜生。佛必因事渐制。是以因此比丘与畜生共作恶法。随事更制。畜生于六道最是边鄙。是故乃至畜生。既下至畜生。凡可淫处一切尽结。凡犯罪有三种。一犯业道罪。二犯恶行罪。三犯戒罪。须提那。于三罪中得犯恶行罪。淫是恶法故。无业道罪。自己妻故。无犯戒罪。佛未结戒故。林中比丘得二罪。得恶行罪。淫是恶法故。得业道罪。雌猕猴属雄猕猴故。不得犯戒罪。佛未结戒故。此二比丘俱名先作。是故无犯戒罪。若比丘者。一切七种得戒比丘。尽皆在中。学学者三学。学戒增学心增学慧增。问曰。学多。何以正齐三学。答曰。三学摄一切学。如是五篇戒。防身口恶。净修身口。无法不尽。学心增者。息于心垢无法不周。学慧增者。明见法相根本除恶。学戒增者。学律藏。学心增者。学契经。学慧增者学阿毗昙。又云。学戒增者。学五篇戒。学心增者。得初禅五支二禅四支乃至四禅。名学心增。学慧增者。明见四谛。复次灭恶律仪戒。及一切威仪五篇戒清净。名学戒增。以戒清净故。得心清净。名学心增。更思寻深理增长善法。名学慧增。四复次经中修戒修心修慧故。知三学摄一切学。五又云。八正道中正语正业正命是学戒增。正定是学心增正见正志正方便正念。是学慧增

复次得五篇戒。名学戒增。得禅戒名学心增。得无漏戒名学慧增。复有三学。学威仪增。学毗尼增。学波罗提木叉增。威仪增者。一切威仪戒。毗尼者。灭一切恶法。波罗提木叉者。五篇戒。问曰何以重分别学戒增。答曰。外道亦云学戒增。是以重分别也。明外道无学戒增。外道断结至三空。而不能断非想处结。佛法断结根本都尽。是以得学戒增

复次外道断结。一切假上地断下地。而佛法不尔。亦以上地断下地。亦能以下地断上地。又云。外道亦制四重。一不淫师妇。二不盗金。三不杀婆罗门。四不饮白酒。佛法不尔。一一切不淫。二一切不盗。三一切不杀。四一切不妄语。同入学法者。如初受具足戒比丘所学。百岁比丘亦如是学。问曰。若百岁比丘。同初受戒比丘所学者。初受戒比丘扫地涂地取水种种役使。百岁比丘亦应同不。答曰。百岁比丘亦从少至长。初受戒比丘亦当从少至长。是故如初受戒比丘所学。百岁比丘亦如是学。是名同入比丘学法。此中言学者。学二百五十戒一切威仪法也。我舍佛者。此中凡有二十一事舍戒。从舍佛乃至不复与汝共作同学。二十一事中但得一事。皆名舍戒事。问曰。舍佛者。是根本弃背三宝。更得出家不。答曰。有论者言。更不得出家。以是根本恶故。又云。故得出家。以不堕百一遮故。以根本舍戒清净无所违故。先虽舍佛今还归依佛。经云。无有一法疾于心者。凡夫心轻躁或善或恶。不可以暂恶便永弃也。虽尔若根本舍佛后还得出家。然舍佛已现世则无吉祥善事。所作无吉无利灾祸归身。欲舍戒无过者。若舍具戒。当言我舍具戒。我是沙弥。若舍出家戒者。当言我舍出家戒。是优婆塞。若舍五戒者。当言归依优婆塞。如是则成舍戒。亦无过咎。又言。若已着白衣被服。有人问言。汝何故尔。答曰。我罢道。我作白衣。亦名舍戒。若舍戒时。都无出家人。若得白衣。不问佛弟子非佛弟子。但使言音相闻。解人情去就。亦得舍戒。舍戒一说便舍。不须三说。问曰。受戒时须三师七僧。舍戒何故一人便舍。答曰。求增上法故。则须多缘多力。舍戒如从高坠下。故不须多也。又云。不欲生前人恼恶心故。若须多缘者。前人当言。佛多缘多恼。受戒时可须多人。舍戒何须多也。又云。受戒如得财宝。舍戒如失财宝。如入海采宝。无数方便然后得之。及其失时。盗贼水火须臾散灭。舍戒亦尔也。舍三宝所以成舍戒者。以受戒时归向三宝得戒故。舍和上阿耆利成舍戒者。以因和上阿耆利得戒故。舍比丘乃至优婆夷。乃至不复与汝共作同学。成舍戒者。以本同归向一味一道。今若舍之。则佛法义断。以是背佛法故。戒则去也。和上者。四种和上。一有法无衣食。二有衣食无法。三有法有衣食。四无法无衣食。今舍和上者。一切舍之。阿耆利者。有五种。一受戒。二威仪。三依止四受经。五出家。舍者。一切舍之。行淫法者。或有行淫。身不相触。如比丘身弱口中行淫。有一比丘。男根长。自后道中作淫。是名犯淫身不相触。或有身相触。不犯淫戒。如淫坏根女人。是谓身相触不犯淫戒。或有身相触。亦犯淫戒。如淫不坏根女人。是名身相触亦犯淫戒。有非身相触不犯淫。如于死女人非处行淫。是名非身相触不犯淫。犯淫身相触。得波罗夷。身不相触不犯淫。偷兰遮。轻重云何。身相触亦犯淫波罗夷。不犯淫身相触偷兰遮。轻重云何。波罗夷者。名堕不如意处。如二人共斗一胜一负。比丘受戒欲出生死。与四魔共斗。若犯此戒则堕负处。问曰。犯五篇戒皆堕负处。何以独此戒得名。答曰。余四篇戒。当犯时亦堕负处。但寻悔灭。非永堕负处。不得名也。如怨家以刀割人命根不断。虽云得胜非是永胜。若断命根名决定胜。犯四篇戒如命根不断。犯此四重如命根断。名堕不如。如伐他国。若得臣下。虽小得胜未名大胜。若得国主。名根本胜。若犯余戒恶法。四魔未名得胜。若犯此戒。毕竟永弃退堕负处

复次如好田苗。若被霜雹摧折堕落不得果实。犯此戒亦尔。烧灭道苗。不得沙门四果。复次如焦谷种。虽种良田粪治溉灌。不生苗实。犯此戒亦尔。虽复勤加精进。终不能生道果苗实。如断多罗树不生不广。犯此戒亦尔。不得增广四沙门果。复次如断树根。树则枯朽。若犯此戒道树枯损。名堕不如。若犯此戒。众所弃离。天龙善神所不亲近。贤圣呵责。名堕不如。若犯此戒。不消檀越衣服饮食卧具医药种种利养。名堕负处。复次犹如死尸在人众中。无所能为无所增益。若犯此戒。虽在出家清净众中。不能成就四沙门果。名堕负处。复次如弊坏垢污衣服。人所弃舍。若犯此戒。佛法所弃。不得与众说戒羯磨布萨自恣。不入十四人数。名堕不如。乃至畜生者。与女人交会受欲具足。与畜生女交会染欲情薄。是故言下至畜生。三恶是五道之边下。故言下至畜生。若犯四重。初犯一时得波罗夷。第二犯时乃至众多。尽突吉罗。如犯淫戒初波罗夷第二犯时乃至众多。尽突吉罗。后三戒当体各尔。如淫戒分别应。当体各尔。女人三处得波罗夷。方便偷兰遮。有轻有重。重偷兰遮。大众中忏。应胡跪合掌三从众乞乞已应一白。一白已忏悔亦应三说。轻偷兰遮。界外四人忏法亦同。且轻重有异。轻偷兰遮者。欲作重淫若起还坐。轻偷兰。发足趣女未捉已还及捉已失。乃至共相呜抱。轻偷兰。男形垂入女形已来未失精。亦犯轻偷兰。若失精得重偷兰。若男形触女形。及半珠已还。不问失精不失精。尽得重偷兰。死女三处行淫。非人女三处行淫。俱得波罗夷。生女死女三处行淫。若坏堕虫食于中行淫。俱得重偷兰。生女死女非处行淫腋下股间行淫。得重偷兰。刺身作疮于中行淫。俱得重偷兰。发足向死女畜生女二根。欲作重淫。乃至男形入三疮门半珠已还。得偷兰遮。轻重如生女中说。若发足向人男非人男畜生男黄门。欲作重淫。于中得偷兰遮。轻重亦如前说。若先正为女人上出精而已。除三疮门。一切身分处精出。僧残。若先为摩捉呜抱而已。若摩若捉。尽僧残。若欲女人身上出精。手已摩捉。精未出便止。四人偷兰遮若犯五篇戒。一一得三罪。如犯波罗夷。以犯戒体波罗夷。违佛教波夜提。犯威仪突吉罗。乃至众多学法犯三罪。犯戒体突吉罗。违佛语波逸提。犯威仪突吉罗。各有三罪。若忏时但忏戒体。余二罪同灭。以戒体是根本故

    结盗戒因缘第二

佛在王舍城者。有论师言。此国于十六大国最胜故。名王舍城。复次此国本有恶龙。作种种灾害。破人民舍宅。唯王宫舍不坏故。名王舍城。复次本此人民饥馑。食狗肉蛇肉人肉种种杂肉。以是故。有诸罗刹恶鬼入国作诸变异。王问。何故有此。答曰。云人民饥馑食啖种种不清净肉有此灾异。王寻立制。不听食此诸不净肉。兼立种种礼仪法限。王法胜故。名王舍城。复次此国山中。有五百辟支佛五百仙人。一切人民常供给所须。以仙圣多故。名王舍城。复次十六大国中二国最胜。一优填王国。二摩竭国。优填王国衣冠王服为胜。摩竭国法礼义为胜。十六国中设有礼义。摩竭国王或用不用。此国法式。十六国中一切用之。是故名王舍城。复次佛在此国。于道树下坐师子座。成阿耨多罗三藐三菩提故。此国地神有大力势。常护此国主故。令此国强盛。异国归向是国。故名王舍城。众多比丘一处安居者。佛一切时前安居。唯毗罗然国后安居。以因缘故。问曰。佛从他安居自安居。答曰。有言。从他安居。有云。自安居。何以故。佛自得一切十力四无所畏故。不从他安居。又云。佛自结此法。自制此法。是故自安居。问曰。佛三语安居一语安居。答曰。佛心念安居。不以口言。以不忘故。问曰。佛布萨自恣羯磨僧事。尽同众不。答曰。佛尽不同众僧。布萨自恣一切僧事皆悉不同。亦不与欲清净。以佛无非法不入僧数故

佛十二年中常在众说戒。十二年后有恶法出。佛止不说令弟子说。问曰。佛无边智慧无边辩力。何故十二年中常说一偈。答曰。佛虽重说。而所受众生各异不同。佛若语若默皆有所化度。是故虽有无穷之辩。为众生故。更不异说更不多说。尔时与阿难者。佛凡制戒必因外事。既有因缘然后结戒。佛将欲结此盗戒。欲令从他得事作结戒因缘。是故佛与阿难按行诸房。佛敕阿难破之者。若余人破者则生诤讼。阿难破之其心则伏。佛在世时三人第一多力。一者阿难。二者拘夷。三者有一释种子。以三人力大无能过者。阿难能转四十里石。是故破之。畏故心伏。又云。余人若破瓦舍坚牢。余人卒不能破。阿难力大须臾破之。漏结因缘者。有二种。一烦恼根本。如须提那林中比丘是其事也。二比丘自作房舍。资产之业多事多恼。妨废坐禅读经比丘正业故。名漏结因缘。达尼吒默然者。佛是法王。或以非法故破之。若以我不可故破之。是故不言。佛何故必破此房。欲永断将来漏因缘故。见以惊怖者。问曰。此怖畏。为在欲界色无色界。为心相应为不相应。答曰。欲界与心相应。问曰。色界三灾所及三禅诸天。尽从下至上。此非怖耶。答曰。此是厌舍故去。非是怖也。色界有厌无怖也。唯欲界有怖。问曰。谁成就此怖。答曰。欲界凡夫四道果人。乃至辟支佛成就此怖。唯佛无怖。即往白王何故以此大材持与比丘者。问曰。既为臣下。何敢以此直言逆于王。答曰。一以义正理负故。二以卑言软语故。王初登位时者。问。此比丘先取财时。作是念耶。临急语耶。答曰。是垂急之语。问曰。此比丘谁边得罪。为是城内人民边。为是主材人边。为是王边。答曰。王边。事在王故。王自在故语诸比丘者。以是小事因缘故。不敢白佛。二以事是可耻。不敢白佛。佛语阿难者。问余三戒何以不问。独问此戒耶。答曰。此戒依王法。三戒不尔。是以不问。此戒要依国法。盗物多少得断命罪。则依而结戒。淫杀二戒。事成则罪成。不问多少。妄语国无此法。是以三戒不问问。佛知一切法相。何须问耶。答曰。为止诽谤故。佛得自在随意自制。若问而后结。佛随国成法而后结戒。则众生心伏。若信者不信者。何故尔耶。答曰。若直问信者。恐为比丘故。言盗多钱得重。若问不信者。或增妒故。言盗少得重罪。是以遍问怨亲中人。盗至几钱王与大罪。盗至五钱得重罪者。或言金钱。或言银钱。或言铜钱。或言铁钱。无有定也。盗至五钱得波罗夷者。谓阎浮提现有佛法处。及弗婆提拘耶尼三天下。唯王舍国法。以五钱为限。又言五钱成重罪者。佛依王舍国法结戒故。限至五钱得波罗夷。如是各随国法依而制罪。观律师意。欲以后义为定。而难不欲广。汝盗比丘如是不与取者。或不与取非是贼。如取有主物谓是无主。或是贼非不与取。如众僧中行三番饼。盗心取四。又如无主物作有主心取。是谓贼非不与取。一以人与故。二以无主故。或是贼亦不与取。如盗心取有主物。或非贼非不与取。如无盗心取无主物。罪者。总五篇罪。名一切是罪。五篇戒外亦有种种罪。今佛结戒示罪轻重。故云。此是波罗夷罪。此是僧残。此是波逸提。此是波罗提提舍尼。此是突吉罗。受王职者。问曰。女人五碍。何由为王。答曰。不得作转轮王身。小王无所碍也。有主物者。一切有主物。纵使空地有物。地中伏藏若是王地。尽属于王。无主物若疑心取。偷兰遮。若塔中得物。若塔外得物。若有鸟死在塔地中。现是佛物。尽供塔用。若物在僧地亦尔。若房中得物。亦供房用。若知是物是死比丘物。众僧应分。若山野中或山崩树折。热风寒风有鸟兽死。无食啖处得取。无罪。一切鸟兽食残取。突吉罗。师子残无罪。若盗佛像。为供养故。无罪。若为得钱。转卖得钱。偷兰遮盗经。不问供养不供养。计钱得罪。若盗舍利偷兰遮。物离本处有二种。一举离本处。二举离本处还着本处。即持去者。得二种罪。一得业道罪。以盗他故。二波罗夷罪。以佛结戒故。还着本处者。得一罪。先离本处。无业道罪。不损他物故。得波罗夷。五宝者。一者金。二者银。三者真珠。四者珊瑚。五者毗琉璃。五似宝者。一铜。二钱。三水银。四白镴铅锡。五合作种种庄严具。若捉五宝得突吉罗。若离地得波逸提。若捉钱离地不离地。尽突吉罗。若比丘有通。以通力飞过诸国。若所发处若所至处。应输税不与得重。其间所经诸国无过。若贩卖者而随王使。王使认名比丘无罪。若不认名计钱得重

萨婆多毗尼毗婆沙卷第二萨婆多毗尼毗婆沙卷第三

        失译人名今附秦录

    盗戒因缘第二之二

国中以王舍城优填王国。于十六大国最为第一。于阎浮提内。中国边方一切统摄。而优填王国。用王舍国法。以此义推于阎浮提一切国法礼义。以王舍城为正。阿阇世王于人王第一。佛为法王。众圣中尊故。佛在王舍城依人王制戒。王舍国法。五钱以上入重罪中。佛依此法。盗至五钱得波罗夷。如是阎浮提内现有佛法处。限五钱得罪。若国不用钱准五钱成罪。律师云言。更有一义秘不欲广。若自盗他物。欲取五钱已上。从始发足步步。轻偷兰遮。乃至选择取三钱已还。得轻偷兰。四钱成重偷兰。若取一钱乃至四钱。亦从始发足乃至取三钱。亦轻偷兰。得四钱重偷兰。若遣使取他物。当教时得轻偷兰。若取物五钱已上离本处时。此比丘得波罗夷。随教取物故。若受使比丘在彼取物时。狂心乱心病坏心取物比丘不得罪。遣使比丘得罪。若教取金乃取银。此比丘不得波罗夷。以异教故。得偷兰。以先方便故。若受使人随教不教从此至彼。受使人若是比丘。步步轻偷兰。教他比丘无罪若盗僧物五钱以上。得重偷兰。四钱以下得轻偷兰。而报罪甚深。若曳不离僧地。得轻偷兰。若入比丘所拔房。得重偷兰。若舍属一主物不异主。若不离地未出家界。步步轻偷兰。若入女姊妹奴婢房中。得波罗夷。若入兄弟儿房中。得轻偷兰。若出主地相亦波罗夷。若比丘冬夏拔房房即属此比丘。随房所得地远近。即为房界。若僧房中住而不拔此房。则是异主异房。若物在地。物是一主。地属异主。若地无异相。随物周圆边际为相。若出边际则离本处。若在褥上有异色。物在一色移在异色即离本处。无主水中有主鸟。若沈令水覆背上。名离本处。若举离水。名离本处。若移鸟令离周圆边际。名离本处。若流水中捉鸟住。令后水过前头亦名离本处。有主水中有主鸟。若举离水。名离本处。若水是一主。岸上地是异主。若曳上岸。名离本处。若地与水同是一主。纵令上岸不名异处。若未入王界。有一比丘语此比丘。彼国税重。闻重便还。若税实重。二俱无过。若税实轻。妄说言重教他比丘。得重偷兰。受教比丘无罪。若入王界语言税重。闻重即还。若税实重。二俱无咎。若税实轻。妄说言重教他比丘。得波罗夷。受教比丘无罪。若瓶中有宝。欲盗此宝。合瓶持去若近若远。得轻偷兰。若取宝举出离瓶底。得波罗夷。取非人五钱已上。重偷兰。若四钱以下轻偷兰。天与畜生尽名非人。云何名无主物。若二国界中间各自封相。其间空地。地若有物。名无主物。又如一王征破异国。所破国王若死若走。后王未统摄此国。尔时地若有物。名无主物。若无主物有主心取。轻偷兰。若有主物无主心取。突吉罗。若物有人守护。无我所心盗取。于物主边得波罗夷。田地相言得胜波罗夷。不如得轻偷兰。若牛马珍宝相言得胜。未离本处得轻偷兰。相言得物离本处波罗夷。若相言胜负未定。先牵牛马。去得轻偷兰。后相言得胜得波罗夷。以先离本处故。若比丘白衣时有田地。先出家时一切尽舍。不属比丘也。若先不舍者。故属比丘若国罚负比丘。若先失物。作心未舍还取此物。若己物外更取他物。计钱成罪若先心已舍。正使己物亦不得取。取亦计钱。若国禁物若持出王界者。入死罪中。若比丘持出。律师初言得重。后更问之似不入重。然违犯王教突吉罗。盗王民有死罪有重罚负。若盗心持去离本处得波罗夷。若王人正使出家出国。既无死罪亦无罚负。王直不听。若无盗心将出国。违王教突吉罗。拘耶尼用牛马市买卖牛得钱。钱满得罪。弗婆提用衣市买。其法亦尔三天下同。有比丘盗罪。凡是三宝物他寄物。自为衣服医药父母。除贩卖一切无过

    杀戒因缘第三

有魔天神者。魔王在第六天。一切欲界众生。皆属于魔。有内眷属外眷属。内眷属受魔教。外眷属不受魔教。此天神受魔教。即生恶邪见者。或言见盗。或言戒盗。问曰。阿难言者。问曰。佛一切智何故教诸比丘令得如是衰恼。若不知者。不名一切智。答曰。佛一切等教。尔时不但六十人受不净观。佛法教无有偏。但受得利有多有少。故无咎也。佛深知众生根业始终。必以此法因缘后得大利云。六十比丘。迦叶佛所受不净观法。不能专修多犯恶行。命终入地狱中。今佛出世罪毕得生人间。堕下贱家出家入道。以本缘故。应受此法。既命终已得生天上。于天来下从佛听法得获道迹。以是因缘佛无偏也。得大果大利者。一现漏尽结。二不堕恶道。三生天人中。四善法增长。五不堕下贱家。阿那波耶者。出息入息。始习此法系心鼻头。若观六界系意顶上。若不习不净。注心眉间。所以习不净观先在面上者修此观法。为除贪欲心。欲心生。要从面起故。先观于面。结跏趺坐者。所以结跏趺坐。为正身故。所以正身。为正心故。是正于心必先正身。又云。九十六种外道。皆不结跏趺坐。欲异外道故。为此坐法。又云。欲止睡眠故。又云。欲生前人信敬心故。如一时有异国来罚罽宾。入其界内。见诸比丘在山林树下结跏趺坐正身正意。即生信敬寻归本国。又云。佛坐道树时结跏趺坐。利根辟支佛亦结跏趺坐。以是诸缘故。结跏趺坐。得波罗夷罪者。问曰。何以但害人得波罗夷。答曰。人中有三归五戒波罗提木叉戒故。又沙门四果多在人中得。佛与辟支佛。必在人中得漏尽故也。是以害人波罗夷。余道不得波罗夷。若为杀人作刀杖弓箭突吉罗。若执刀欲杀人发足。步步轻偷兰。乃至未伤人已还。尽轻偷兰。若刀着人不问深浅。命未断以还重偷兰。若死波罗夷。若为杀人故作坑。未成时突吉罗。作竟轻偷兰。若人堕中勇健便急即能出坑。得重偷兰。若堕坑中不死。亦重偷兰。作弶作拨亦尔。若遣使杀人。当教时得轻偷兰。使若杀时。此比丘得波罗夷。遣使杀人亦三心中得波罗夷。若遣使杀人。遣使杀人比丘。若诵经礼佛。使杀。彼时遣使比丘得波罗夷。是善心中得罪。不善心中无记心中。义推可知。若遣使杀人。教彼人若来者杀。而受使者彼人去时杀者。比丘得轻偷兰。若教刀杀而用杖杀。若杀此而杀彼。凡不如本教更异方便。尽轻偷兰。若教一人杀彼人。而受使者更使异人。如是展转乃至十人。最后人杀时。尽得波罗夷。若比丘善知星历阴阳龟易解国兴衰军马形势。若以比丘语故。征统异国。有所杀害兼得财宝。皆得杀盗二波罗夷。若优婆塞。以王故。同心共征异国。若破他国。有所伤杀兼得财宝。虽手不作。以同心故。亦犯杀盗二戒。若二人相刺一时死。无犯戒罪。以受戒誓毕一形故。若以刀杖欲杀人故。或杖打刀刺。不寻手死十日应死。后更异人打。即寻杖死。打死比丘得波罗夷。先打比丘得重偷兰。若遣使杀人。使若往杀下刀。不问深浅。前人不死。遣使比丘受使比丘。俱重偷兰。若堕胎杀者。在母腹中诸根成就以来。随以种种因缘而得杀者。名堕胎杀。按腹杀者。若在腹中诸根未成。如薄酪生酥若按腹令散。若彼死者。名按腹杀。乃至腹中初得二根者。始处缘时。父母精合识处其中。得身根命根。尔时作因缘杀者。得波罗夷。此是穷下之说也。有四人不可杀。入灭尽定无想定。佛使入慈三昧

    妄语第四

若为利养名闻故。言我得不净观阿那波那乃至世间第一法。得向四沙门果四禅四无量心四无色定五神通。尽波罗夷。乃至自言持戒清净淫欲不起。若不实者偷兰遮。若自言诸天龙乃至罗刹鬼来至我所彼问我我答彼。是事不实者波罗夷。所以得罪者。自现内有胜法能感诸天龙神。又自显断恐怖故。龙神来至我所。我无恐惧可名过人法。不名过天。佛在人中结戒故。人中有波罗提木叉戒故。又人中多入圣道多修善法。胜于天故。但胜人已胜于天。又言。但胜人得波罗夷。天故无所论。若不诵四阿含。自言诵四阿含。非阿毗昙师。自言阿毗昙师。非律师自言律师。实非坐禅作阿练。若自言我是阿练若。悉偷兰遮。大而言之。无所习诵。而言我有所诵习。悉偷兰遮

    十三事初

与诸比丘结戒者。问曰。一切善法不言结。何以但言结戒。答曰。戒是万善之本。但结戒即一切结也。佛所以制此故出精戒。为令法久住故。又欲止诽谤故。若作此事。世人外道当言。沙门释子作不净行。与俗人无异。又欲生天龙善神信敬心故。若作此事。虽复私屏。天龙善神一切见之。又佛平等不问亲疏。有事则制无事则止。又诸佛法尔。淫是恶行。法应制之。僧伽婆尸沙者。秦言。僧残。是罪属僧。僧中有残。因众除灭。又云。四事无残。此虽犯有残。因僧灭罪。故曰僧残。问曰。四篇皆是有残。何以独此戒言有残。答曰。四篇虽是有残。不一切尽因僧灭。如三十事中。三事因僧灭。余则不因。九十事中。七事因僧。余则不因。十三事一切因僧。又犯此戒。行波利婆沙亦在僧中。摩那埵亦在僧中。出罪亦在僧中。余戒不尔。故名僧残。又此戒不共。如比丘犯得僧残。比丘尼犯得波逸提。问曰。何以不同。答曰。为令二众有差别故。又云。女人烦恼深重难拘难制。若与制重则罪恼众生。又云女。人要在私屏多缘多力苦乃出精。男子不尔随事能出。故不同也。若比丘作方便出精。精未出变为尼然后出。无罪。以尼无出精方便故。若比丘故出精一心即变为尼。即清净住。若比丘作六夜摩那埵未竟即变为尼。亦清净住。若行波利婆沙未竟即变为尼。亦清净住。若比丘尼变为比丘亦如是。不共戒如是。共戒云何。若比丘先作僧残。未成变为尼。然后成事。先比丘得偷兰遮。尼得僧残。以罪同故。若比丘尼变为比丘亦尔。若比丘犯僧残。一念变为尼。乃至十年五年覆藏。然后变为尼。一种十五日除罪。若比丘尼犯僧残。一念不覆藏乃至发露。行十五日法中。一日二日若变为比丘。但作六夜摩那埵。然后出罪。若先犯罪有覆藏日。即变为比丘。随本覆日。行波利婆沙。梦中出精者。有三事能发烦恼。一因缘。二方便。三境界。众生先善业故。生富贵处。但以淫欲为先。若生天上亦复如是。人天富乐是淫欲因缘也。二方便者。若见闻女色。后方便思惟。然后起欲。是名方便。三境界者。若见上妙女色即生欲心。是名境界。是比丘先富贵家子。虽得出家。以先欲因缘重故。梦中失精。复以是事因缘故。游诸聚落。或见好色。或方便思惟。以是因缘故。梦中失精。一面立者。阿难恭敬佛故不坐。问曰。舍利弗目连深恭敬佛。何以坐耶。答曰。此二人恭敬法故。阿难兼以俗亲故。是以不同。又云。阿难受他使故不坐。又云。诸佛法尔。凡侍比丘法不应坐。赞戒赞持戒者。为折伏破戒故。令持戒者增善根故。如佛赞多闻智慧勤精进。若破戒者。若愚痴者。若懈怠者。知佛语无二必有深利。作如是说。不持戒者勤加持戒。愚痴众生勤求智慧。懈怠众生勤加精进。是故赞持戒也

    第二摩捉戒

迦留陀夷持户钩在门间立。此人淫欲偏多。伺见女人共语笑抱捉。解释欲心。问曰。若欲心多者。何不作大事破戒。答曰。此人根熟应得漏尽故。又应度此舍卫城中具足千家正少一人。是故不作大事。诸女人何以来看。一以世间多事多诸匆务。出家人所住处寂静安乐故。二亲近善知识。欲闻法故。三众僧房中种种严饰。采画房舍床榻卧具。触目可乐。是故来看。何故正食后来。又言。无有定义。若食前来。复当言。何以不食后来。进退有疑耳。又云。俗人食前多事多缘。或作饮食分处奴婢。夫婿儿子各随缘已。然后共相依。随登山游泽或诣僧坊。又云。所以至僧坊者。为欲亲近善人乐闻法故。若食前来。诸比丘各乞食。随缘不在僧坊。是故食后来。诸女人何以随比丘入房舍中。答曰。谓出家之人断欲清净。信敬故随入无疑。有善者默然。问曰。何故有默有不默者。有云。欲心多者默然。欲心少者不默然。有云。若知识者默然。非知识者不默然。不相错故。有云。人性不同。有乐覆罪过者默然。有不乐藏过者不默。有云。无有父母兄弟夫婿儿女。无所畏难故默然。有父母兄弟夫婿儿女者。有畏难故不默然。诸比丘为诸女人说法者。为说佛法众僧是良祐福田可信可敬。莫以小缘故自破善根。又云。赞叹迦留陀夷种种功德智慧。当得漏尽度千家作大利益。莫见小因缘故自失敬信也。佛所以结此摩捉女人戒。一以出家之人飘然无所依止。今结此戒与之作伴。令有所依怙。二欲止斗诤故。此是诤竞根本。若捉女人则生诤乱。三息嫌疑故。若比丘设捉女人。人见不谓直捉而已。谓作大恶。是故止之。四为断大恶之源。欲是众祸之先。若摩捉女人。则开众恶门。禁微防着。五为护正念故。若亲近女人则失正念。六为增上法故。比丘出家迹绝欲秽。栖心事外为世揩轨。若摩捉女人。与恶人无别。则丧世人宗敬之心。此是不共戒。比丘犯僧残。比丘尼犯摩捉波罗夷。若比丘欲摩捉女人。根变作尼。变竟后捉无罪。以尼无方便心故。即清净住。若比丘已犯摩捉僧残根变作尼。即清净住。若尼犯摩捉波罗夷。根变作比丘。即清净住。若比丘捉女人。未着女人。即变为男子。手着时非女人。不得僧残。得先方便偷兰遮。捉已变得僧残。若尼欲捉男子。手未捉根变为女。变为女竟捉不得波罗夷。得先方便偷兰遮。未变捉。捉竟变得重

    第三恶语戒

此是不共戒。比丘恶语得僧残。比丘尼恶语偷兰遮。式叉摩尼沙弥沙弥尼突吉罗。此五篇戒各有种类。十三事中初五戒。三十事中三戒。从非亲里尼。取衣浣故衣。染羊毛。九十事中十五戒。与女人过五六语。教尼至日没时。次第后十戒。食家中前后二戒。与女人同室宿。议共道行。四悔过中第四戒。众学法中不眄视不高视。戒是淫戒种类。十三事二房舍。三十事中七戒。畜宝戒。种种用宝戒。贩卖戒。自乞缕。使织师织。还夺他比丘衣。知物向僧自回向己。九十事中三戒。藏针筒等戒。与五众衣辄还用。与贼众议共道行。四悔过中第三戒。众多学戒中。以饭覆羹净草净水。如是等戒。是盗戒种类。十三事中污他家。三十事中憍奢耶敷具。九十事中。知水有虫自浇草土若使人浇。知水有虫取用二戒。打他比丘搏他比丘二戒故夺畜生命。四悔过中初戒。众学中大塼饭净草净水。如是等戒。杀戒种类。十三事中二谤戒。破僧相助三戒。戾语戒。三十事中三戒。一二居士作衣。若王大臣遣使戒。九十事中初十戒。四悔过中第二戒。众多学一切说法戒。如是等戒。妄语戒种类。二百五十戒。以类而言。有四种类。以罪而言。罪有五差偷兰遮。十三事初房舍

佛在阿罗毗国。此是鬼神名。此国是阿罗毗所住处。故因之为名。诸比丘者。有二种。一世谛比丘。二第一义谛比丘。住波罗提木叉戒。是世谛比丘。住无漏戒。是第一义谛比丘。大迦叶者。迦叶名多故。以大辩之。一大富贵长者所生故。二能舍大富贵豪族出家故。三能行头陀少欲知足大法故。四国王帝主天龙鬼神多知多识所供养故。五舍世间大利养。少欲知足行乞食故。如大舍利弗。成就大智慧故。如大目连。成就大神通故。以成就大功德故。兼行少欲知足头陀法故。名大迦叶。与少不足。名为多欲。得一求一。名不知足。又复得内供养无厌。名为多欲。得外利养无厌。名不知足。与诸比丘结戒。一以为法久住故。二为止诽谤故。三不恼害众生令信敬增长故。四为少欲知足行善法故。此名不共戒。比丘犯僧残。比丘尼犯偷兰。下三众犯突吉罗。是舍私作。无檀越主。自乞自作。以多缘多事恼乱在家人故。制令应量。长十二搩手内广七搩手者。佛一搩手。凡人一肘半示处者。僧应示作处。集僧已能尽往示处者益善。若不往僧应差四人示处。教应量已印封作相。若僧不教应量不示难处妨处者突吉罗。难处者。蛇窟乃至鼠穴。是名难处。齐几名无难处。但使齐房四角已还。无难处得作。又云。但使出入道径无难。名无难处妨者。是舍四边一寻内。有塔地若王地。以王来入僧房内。王或欲止息眠戏。不欲在僧房内。别结此地属王。故名王地居士者。以居士作僧房。坛越数来往僧中。止息戏笑。不欲在僧房中。故别结此地属居士。外道地者。居士有亲里外道出家。来往僧中故。别结此地属外道。比丘尼地者。居士亲里女出家作尼。来往僧房中故。别结此地属尼。大石者。若近在房。行来进止作诸恼害。或破器物故。名妨处。流水者。若近流水。或水长漂没房舍。或水流食岸毁坏不少。池水者。池水浸润不得久固。大树者。飞鸟所集有诸音声。多所恼乱兼屎尿不净。并枝折落有所伤破。深坑者。颓损崩坏。令房不得久故。不问处过量难处妨处。四事不如法。若平地时封地作相。时以得偷兰遮。从二团泥未竟已还。尽轻偷兰。余一团泥在。未竟重偷兰。竟僧残。若三事不如法。一事如法。二事不如法。二事如法。一事不如法。三事如法。从平地封地作相。乃至一团泥未竟已还。尽轻偷兰。作房竟得重偷兰。作房比丘。先自看作房处。然后集僧。集僧已从僧三乞。僧应先示处次封作相竟然后羯磨。若封相风吹雨水坏灭者。应更作相。已羯磨时相坏亦成羯磨。半已相坏亦成羯磨。若羯磨已相坏亦成羯磨。若印封作相已。不得余处作房。若异比丘不得此处作房。正应此比丘作。作房已不得嫌小更大。作房不如法。随作时得偷兰。若房主比丘死。若远行者去绝不还。随意处分。若与三宝。若随亲与。若与白衣。若自卖作钱自在随心。若卖房不得卖地。若众僧不听。众僧得罪。若房主比丘不自分处者。属四方僧。众僧次第应住。若此房上。更异比丘欲作房。不须白僧。但房主比丘听作。自在得作。不听不得作此房。亦随主自在分处。若不分处。即属四方僧。如先比丘法。若比丘作房不如法。若四方僧地不得作塔。不得作别波演。若作得罪。亦不得四方僧地中为佛法自为种殖。若僧和合。听四方僧地中作塔得作。若不和合不听不得作。若僧地中有种种花。应净人取。作次第与僧随意供养。不得私取自供养三宝。若花多众僧取不能尽。若僧和合。听随意取之。若荒饿后三宝园田无有分别。先旧比丘及以白衣。一切尽无问定无处。若众僧和合。随意分处非僧地。地应属王。若比丘作房者。应以白王然后作房。不白不得作。若僧坊中内。不得起塔作像。以近人臭秽不清净。若重阁舍。若经像在下重。不得在上住。若塔地花不得供养僧。法正应供养佛。此花亦得卖取钱以供养塔用。若属塔水以供塔用。设用有残。若致功力是塔人者。应卖此水以钱属塔。不得余用。用则计钱。若塔无人致水功力。一由僧人。残水多少善好筹量。若学问坐禅比丘各有定业。若学不根本如学问法者。取学问腊。则不清净。若禅不根本心如禅法者。取坐禅腊。则不清净。后房舍

佛在俱睒弥国。长老阐那者。是佛异母弟。优填王妹儿。生大豪族出家为道。多住此国。性[仁-二+戾]自用作种种过恶。多在此国。与诸比丘结戒者。所以因缘如上说。此是不共戒。若比丘犯僧残。若比丘尼犯偷兰。下三众罪犯突吉罗。有主者。有檀越主人。为比丘出钱作僧房。以僧房故不问量。若檀越欲作大房。语主人意小作者。则应少欲法。若檀越意为福德故。欲令容受多人故。欲作大房。欲多重作房。不应违施者意若违损他福德。若主人意。欲如耆阇崛山只桓精舍广大严净者。应好示语檀越意令开解然后小作房。律师云。后房舍。有檀越主。与比丘物为众僧作房。但以众房不限量数。自余作法如前房说。若不问僧作处难处妨处三事。不如法从平地印封作相。二团泥未竟已还。尽轻偷兰。一团泥未竟重偷兰。作房舍竟僧残。若二事不如法一事如法。若一事不如法二事如法。从平地印封作相。一团泥未竟已还。轻偷兰。作房竟重偷兰。若自物与僧作房亦如是。若僧祇物一人作僧房。不问作处难处妨处。而作房处无难无妨。作房竟突吉罗。若有难处妨处。平地印封作相。乃至二团泥未竟以还。轻偷兰。一团泥未竟以还。重偷兰。作竟僧残。若自物施主物。自物作房。如初房舍法。若初房舍若后房舍。倩他作作不如法。二俱得罪。若僧房自房。作法白僧三乞。次第如初房说。优婆塞者。秦言离恶修善。亦名亲近

    第八无根谤戒

佛在王舍城者。迦维罗长养色身。摩竭提国长养法身。是故佛多在王舍城。陀骠力士子成就五法故。僧羯磨作知卧具人。问曰。五法成就者多。何以正差陀骠。答曰。以陀骠旧住王舍城瞻待客比丘故。又云。为满本愿。过去迦叶佛时。亦为众僧作知卧具人。称可僧意。尔时作愿愿我将来亦为众僧作知卧具人。及在彼世时。亦知卧具称悦时人。是以今佛还知卧具。佛所以令德行具足者使知卧具。现无吝法故。外道法。凡有所知见。尽不与弟子。恐弟子德行与己齐等。无师相承故。佛法不尔。一切无惜。随弟子优劣随事称差。又欲现长幼智德阶差。知卧具者其德如是。况受用者。又欲庄严将来弥勒佛法故。如今舍利弗智慧第一。目连神足第一。迦旃延解契经第一。富楼那四辩第一。阿难总持第一。五百弟子各为第一。陀骠知卧具第一。时人见佛弟子各称第一。皆发胜愿自誓立行。愿我于当来佛法中。亦得第一如是。佛出世庄严未来。五百佛法随所应与。阿练若阿练若共。持律持律共。说法说法共。读修妒路读修妒路共。问曰。若如是随同者。共不有所偏私耶。答曰不尔。众僧先已自唱随同业者。共以业同故。不相扰乱得安乐住。问曰。是四人其业各异。何以常不相离。答曰。阿练若。禅法有所疑滞。咨问有处。兼欲数闻说法增修。是以相近。持律者。凡欲知戒相轻重。决了罪过断解僧法。是以相近。法师者。义论说法称扬三宝。能增长善根。契经者。诵诸大经多知广见随事能答。故相亲近。若僧坊中房鲜少。若有四房。先唱与阿练若。次第唱与。若别波演有四房。亦次第唱与。若舍有四重。亦次第唱与。若无四房。随宜分处。不须灯烛者。凡光明神力要入定心。若分卧具必出定心。云何不定心中而有光明。答曰。诸佛不可思议。禅定不可思议。龙不可思议。业报不可思议。又云。此人利根。禅定亦利。当分卧具时。或入定心。或出定心。其间駃速谓但是散心。如击鼓人手自击鼓口并叫唤。击鼓心非缘叫唤心。二心各异。但以其駃疾故。谓是一心。又如浮人手捉浮瓠脚并蹋水。捉浮瓠心脚蹋水心。二心各异亦复如是。又云。先入定心手出光明。出光明已然后出定。以入定势力故。虽在不定心中。光明不灭。犹如陶师转轮作器。以一转力故。十匝五匝。势故不尽。此亦复尔。一定力故光明久住。如过去然灯佛。出现于世为众生说法。时世众生乐着世乐。懈怠慢恣不受佛法。定光如来。以神通力化作一城。庄严清净。其中人民富乐充溢五欲自恣。如是经由十二年中。定光如来亦十二年常在禅定。过是以后。大水忽至漂没此城。城中人民一切散灭。时世人民乐着富乐者。或悟无常。我不久亦当如是。定光如来即从定起。踊在虚空作种种神变。从虚空来下为众说法。时会众生。或得须陀洹乃至阿罗汉。或种辟支佛道因缘。或发阿耨多罗三藐三菩提心者。无量众生大得法利。以神通力常得停住。十二年中以定力故。光明暂住。何足为难。问曰。佛法。罪当发露功德覆藏。陀骠何故常放光明自显功德。答曰。自显功德凡有二种。一为利养名闻。二为佛法众生故。若为佛法众生。随时自在无所障碍。陀骠所以放光明者。正为止诽谤故。如佛为婆罗门女所谤故。作师子吼。自说我有十力四无所畏十八不共法。以表清净。如舍利弗目连。为瞿迦离所谤。作师子吼。我有七觉意宝。如长者家其库藏中有种种衣服种种器仗自在取用。我有七觉意宝。亦随意取用之。以表清净。目连亦作师子吼。自说我生已尽不复当生。所作已办梵行已成。以表清净。阿那律为人所谤。自说我入智慧楼观自在游戏。以表清净。如莎伽陀为人所谤言其饮酒。自言我禅定能令从阿鼻地狱上至阿迦尼吒天满其中火。以表清净。如输毗陀为人所谤。自说一念能知五百劫事。以表清净。陀骠为慈地所谤故。常放光明。以表清净。复次除轻毁心故。如学问比丘轻毁坐禅劝佐众事比丘。坐禅比丘亦轻毁二业比丘。劝佐众事比丘亦轻毁坐禅学问比丘。是故陀骠。以坐禅力常现光明。兼知卧具劝佐众事。灭相轻毁胜负心故。三为折伏山林树下比丘高慢心故。常谓城傍比丘在散乱心中多言多事行道修业无所能成。自谓静处无能过者。是故陀骠。虽在事乱得大神力。手放光明。以分卧具。伏彼高心。四为现精进果报。以精进力得此神通。以激励懈怠诸慢恣者。五为檀越施主增长善根。六为现不退法。陀骠先德行纯备。后为慈地所谤。时人疑谓其退故放光明。明实不退。七欲现众僧大威德故。分卧具比丘神德犹尔。况余大德名闻高远者。八为爱惜正业不令虚缺。常在定心兼分卧具。令僧事得办。而不废禅业。以是因缘故。常放光明。众僧羯磨作差会人。作差会人故。为慈地所谤。然后作知卧具人。以被谤故。手出光明。令诸众生灭诸恶法。以知卧具事亦胜故。移令在前。差会在后。慈地比丘所以常得粗恶食者。先业力故。又此人日夜无清净心。天龙鬼神与作因缘。令其所作事不如意。世尊知我者。以实清净故。不得言尔。以本业力故。不得言不。佛何故不说陀骠清净。一以佛平等心无亲无爱故。不即言一是一非。二以陀骠本业果熟故。过去迦叶佛时作知食人。时有一冢间比丘。是阿罗汉。仪容端政在路而行。有一女人见生染爱。随观不舍。时主食人见其如是。谓先与交通。寻作是言。是比丘必与此女人共作恶法。以谤贤圣故。堕在地狱。罪毕得出。以本善业值佛得道。残业力故。受此恶报。是弥多罗比丘尼自说作罪故。应与灭羯磨。自言罪者。比丘比丘尼式叉摩尼沙弥沙弥尼。自言作罪。若不改悔。应与灭羯磨。若不与灭羯磨。但直尔驱出。若改悔者得偷兰遮。若不改悔者突吉罗。若比丘犯戒内烂。举众共知。不须自言。直尔遣出。若与羯磨使四远同闻。折伏罪恶得作无过。凡五众自言作重罪。若一人前自说。若多人前说。尽应遣出。比丘比丘尼应现前。三众不现前。陀骠比丘与忆念毗尼。如七灭诤中。灭羯磨法者。不得众共作一切僧事百一羯磨。皆不得同众。众僧自恣腊面门腊。皆不得与。若死。众僧不得羯磨取物。应与所亲白衣。自不得从他受法。亦不得教前人法。不得受他礼拜供养。说戒及一切羯磨。不得与欲清净。有三种人。必堕地狱罪。因诽谤故。兼说二人堕地狱罪。佛不欲面称人恶。众中有此恶者。是故佛因事说过。令诸罪人摧伏恶心深心惭愧。夫人生世间。斧在口中生。此中佛自说本缘。过去不可计劫有佛出世。名阿梨罗。彼佛法中有兄弟二人。出家作比丘。兄坐禅故。得阿罗汉三明六通。弟学通三藏阐扬佛法。时世四辈宗奉二人。但兄以圣道故。利养偏胜。时檀越持一端[疊*毛]。与兄不与弟。凡饮食衣服病瘦医药。皆偏不同。其弟比丘生恼疾心。欲毁害诽谤。时檀越遣一女。至三藏比丘所。比丘语女言。汝与我谤彼比丘。女言。此是圣人。云何谤之。此比丘以种种方便诱惑其心。女人即可之。比丘言。我当索取彼[疊*毛]。持以与汝以证其罪。但言。与我行淫即索与之。女即还归家。问其意故。何以经久。即言。彼处比丘留我戏弄。是故经久。复言。与我此[疊*毛]。于时世人咸生疑惑。罗汉比丘。见此二人作大罪恶。即避异方。佛言。时弟比丘者。则我身是。女人者。孙陀利是。以我前世谤漏尽无学人故。今漏尽在无学地。还被诽谤。与诸比丘结戒者。为法久住故。为止谤毁令梵行安乐住不妨读经行道故。此是共戒。比丘犯得僧残。比丘尼犯亦得僧残。下三众犯得突吉罗。无根波罗夷者。无根谤有四种。一以无根波罗夷法谤得僧残。二以无根僧残谤得波逸提。三以无根出佛身血破僧谤得偷兰。四以无根波逸提谤得突吉罗。说他粗罪有三种。一说他波罗夷僧残。得波逸提。说他出佛身血破僧偷兰。说波逸提突吉罗。覆他粗罪有三种。一覆藏他波罗夷僧残。得波逸提。二覆藏他出佛身血破僧偷兰遮。覆波逸提突吉罗。轻呵戒唯有一种。轻呵五篇戒。尽波逸提。乃至轻呵最后一篇。亦波逸提。无根谤。说他粗罪。轻呵戒。是三事诤乱法故。覆藏他粗罪。匿藏罪恶染污佛法故。复次无根谤说他粗罪。妨废读经行道故。轻呵戒。破佛法身故。覆粗罪。令佛法不清净。长养恶法故。无根者。有三种根本。一见二闻三疑。依此三种。名为有根。不见不闻不疑。是名无根。云疑不成根。眼根者。必使清净无病。见事审谛可依可信。唯听肉眼不听天眼。以有天眼者不说人恶。复次若听天眼说过者。人谁无过。但有大小天眼。无往不见。若听说过者。则妨乱事多。耳根者。必使清净无谬审谛可信。亦不可听天耳。事同天眼。疑不可依。若说罪过为说定相。疑者。非是决定。或谓犯罪。或谓不犯或不可依。故不得为根

    第十破僧戒

破僧轮破羯磨僧。有何差别。答曰。有种种差别。破僧轮破羯磨僧。俱偷兰遮。而破僧轮。犯逆罪偷兰遮不可忏。破羯磨僧。犯非逆罪可忏。偷兰遮。复次破僧轮。入阿鼻狱受罪一劫。破羯磨僧。不堕阿鼻狱。复次破僧轮下至九人。破羯磨僧下至八人。复次破僧轮。一人自称作佛。破羯磨僧。不自称作佛。复次破僧轮。界内界外一切尽破。破羯磨僧。要在界内别作羯磨。复次破僧轮。必男子。破羯磨僧。男子女人二俱能破。复次破僧轮。破俗谛僧。破羯磨僧。俗谛僧第一义谛僧二俱能破。复次破僧轮。但破阎浮提。破羯磨僧。通三天下。调达以五法诱诸年少比丘。令生异见。破僧之要。以五法为根本。问曰。此五法佛常自赞叹。何故名为非法。答曰。佛所以赞叹者云。四圣种能得八圣道成沙门四果。今调达倒说云。八圣道趣向泥洹反更迟难。修行五法以求解脱其道甚速。是故说为非法。非法说法者。五法非法说是法。法说非法者。八圣道是法说言非法。非律说律者。五法非律。说言是律。律说非律者。八圣道是律。说言非律。非犯说犯者。佛不制心戒。而说心起三毒即是犯戒。犯说非犯者。不制剃发剪爪佛说犯戒。而言爪发有命。有不剃剪不。犯轻说重。如优钵罗龙。以摘树叶故。罪不可忏。因此便言。杀草木者。一切是重。重说轻者。见须提那达尼吒等以先作故不得重罪。便言。淫欲盗是轻。有残说无残者。下四篇戒。犯则有残。而说言无残。无残说有残者。四重犯则无残。而说有残。常所说法说非常所说法者。八圣道是常所用法。而说非是常所用法。非常所用法说是常所用法者。五法是非常所用法。而说是常所用法。四禁是轻余篇言重。此是非教。而说是教。四禁是重。余篇是轻此是正教。而说非教

萨婆多毗尼毗婆沙卷第三萨婆多毗尼毗婆沙卷第四

        失译人名今附秦录

    第十二污他家

马宿满宿。此二人二宿出时生。因宿作名。是豪族家。深着世乐不能舍心。是故犯戒放逸作恶行污他家者。作种种恶业。破乱他人信敬善心是名污他家。作恶行者。作此不清净业。秽污垢浊故又得恶果故名为恶行。又污他家者。若比丘凡有所请求。若为三宝。若自为请求。如是一切。若以种种信物。与国王大臣长者居士一切在家人。若出家人皆名污他家。何以故。凡出家人无为无欲清净自守。以修道为心。若与俗人信使往来废乱正业非出家所宜。又复若以信物赠遗白衣。则破前人平等好心。于得物者欢喜爱敬。不得物者。纵使贤圣无爱敬心。失他前人深厚福利。又复倒乱佛法。凡在家人。应饮食衣服供养出家人。而出家人反供养白衣。仰失圣心又乱正法。凡在家人。常于三宝求清净福田。割损血肉以种善根。以出家人信物赠遗因缘故。反于出家人生希望心。破他前人于三宝中清净信敬。又失一切出家人种种利养。若以少物赠遗白衣。纵使起七宝塔种种庄严。不如静坐清净持戒。即是供养如来真实法身。若以少物赠遗白衣。正使得立精舍犹如只桓。不如静坐。清净持戒即是清净供养三宝。若以少物赠遗白衣。纵令四事供满阎浮提一切圣众。不如静坐。清净持戒即清净供养一切圣众。若有强力欲破塔坏像。若以赠遗得全济者。当卖塔地花果。若塔有钱。若余缘得物随宜消息。若有强力。欲于僧祇作破乱折减。若僧祇地中随有何物。卖以作钱随缘消息。若僧常腊若面门腊。若有强力欲作折减。随此地中所有出物。以消息之。父母是福田则听供养。若僧祇人。以为僧祇役故。此则应与若施主欲与众僧作食。欲知法则此应与一切孤穷乞丐。怜愍心故应与。一切外道常于佛法作大怨敌伺求长短。是应与。若为身命衣钵随缘乞求。而以与之以免祸难。共女人一床坐者。比丘不得与女人同床坐。若坐突吉罗。不得同席同褥。皆突吉罗。长床相接。但异席异褥异毡。令中间空绝。毡褥各异得坐。女人者。一切女人。母女姊妹不问亲疏一切不听。以坏威仪故。以香涂身者。香薰衣。四众得突吉罗。比丘尼得波逸提。以女人染着深故。五众尽不得。以香水洒地。除为三宝。自贯花鬘亦使人贯者。所以不听者。以此中所作恶行。或是先作。或以制戒。妨废行道故。正为三宝亦不得作。又云。若以花香璎珞庄严之具。不得着佛身上。但散地供养。若比丘以花供养众僧。不得以散身上。若以花着浆饮上。亦不听饮。若令象斗乃至鸡斗。五众尽不听。若比丘比丘尼作杀心。令斗死者波逸提。不死者突吉罗。三众令斗突吉罗。五众尽不听走。除有急难因缘。五众尽不听啼哭。乃至父母丧亡一切不听。四众得突吉罗。比丘尼得波逸提。以爱恋心深故。一切五众不听大唤。以坏威仪故。除急难因缘。一切五众不得啸谬语。以坏威仪。尔时阿难者问曰。阿难是佛侍者。何以离佛游行。答曰。阿难随有缘众生应受化故。问曰。阿难何时得离佛游行。答曰。佛若入禅。得离游行。又佛至他方。阿难力不能去。尔时得离。又承佛使命。得离游行。阿难持空钵入还空钵出问曰。阿难是佛侍者。有大功德。兼是所生土地皆是亲里。何故乞食空出。答曰。马宿满宿于中作大非法。侵陵污辱种种恶行。得免恼害。以是大幸。何况得食。又阿难少小出家。岁月既久故。不识阿难也

    第十三戾语戒

若如是者。诸如来众得增长利益。以共语相教共出罪故。问曰。经中说但自观身行。谛视善不善而云展转相教不相违耶。答曰。佛因时制教。言乖趣合不相违背也。佛以前人心有爱憎发言有损。是以云但自观身行。若为慈心有利益者。是故应共语相教也。若钝根无智言说无利。是故说言但自观身。若聪智利根发言有益。是则应展转相教。若少闻少见出言无补。是故云但自观身行。若广闻博见有所弘益。则展转相教。又云。若为利养名闻有所言说。是故云但自观身行。若为利安众生阐扬佛法。则应展转相教。又云。为现法乐。是故言但自观身行。若欲以法化益众生使天下同己。则应展转相教。又为新出家爱恋父母兄弟妻子。是故言但自观身行。若久染佛法力能兼人。则应展转相教

    次二不定法初

时毗舍佉即到掘多舍。问曰。毗舍佉聪明利根大德重人。知比丘与女人屏处坐何故往。答曰。是人已入道迹深乐佛法。佛常自说。听法有五事利。一得闻未曾闻法。二已曾闻清净坚固。三除邪见。四得正见。五解甚深法。是以毗舍佉乐法情深。不以嫌疑自碍。佛说种种法者。在家人未入道迹。多为说布施功德。出家人已入道迹者。多为说持戒功德。与诸比丘结戒者。一为止诽谤故。二为除斗诤故。三为增上法故。比丘出家迹绝俗秽。为人天所宗。以道化物。而与女人屏处私曲鄙碎。上违圣意。下失人天宗向信敬。四为断恶业次第法故。初既屏处。渐染缠绵无所不至。是以防之。于如是人终不为身。若为他人。若为财利故者。此是成就无漏信人。终不故作妄语。正使凡夫深乐佛法。乃至失命因缘不作妄语。而况圣人。若人语言。汝若妄语不害汝命。若不妄语当害汝命。即自思惟。我不妄语。害此肉身灭此一身。若妄语者。灭无量身兼害法身誓不妄语。人复语言。汝若妄语。活汝父母兄弟姊妹一切亲族。若不妄语。一切所亲尽皆杀之。寻复思惟。我不妄语。害此一世生死亲族。我若妄语流转三恶。永失人天累世亲族眷属。又失贤圣出世眷属。是名不为他而作妄语。又复语言。汝若妄语。与汝珍宝种种财利。若不妄语。则不与汝。即便思惟。我不妄语。失此俗财我若妄语失圣法财。是名不为财利而作妄语。不定者。佛坐道场时。已决定五篇戒轻重通塞。无往不定。此所以言不定者。直以可信人不识罪相轻重亦不识罪名字。设见共女人一处坐。不知为作何事。为共行淫。为作摩触为作恶语。为过五六语。故言不定。此与女人屏处坐戒。或已结或未结。作实觅毗尼者。若比丘或初言尔。后言不尔。或言我不往不作是罪。应随可信人语与实觅毗尼。所以尔者。欲令罪人折伏恶心。又令苦恼不覆藏罪。又令梵行者得安乐住。又肃将来令恶法不起。实觅毗尼者。与人受具戒。作依止。畜新旧沙弥。皆成。但得突吉罗从不教毗尼。乃至不应相言事。皆不成亦得突吉罗。若作羯磨已若说先罪。应解羯磨随罪轻重治。若不说。尽形寿不解羯磨。第二不定法。正以处二法为异。一切尽同。与实觅毗尼亦同二不定竟

    三十事初结长衣戒因缘

六群比丘者。一难途。二跋难陀。三迦留陀夷。四阐那。五马宿。六满宿。云二人得漏尽入无余涅槃。一迦留陀夷。二阐那。二人生天上。又云。二人犯重戒。又云不犯。若犯重者不得生天也。一难途。二跋难陀。二人堕恶道生龙中。一马宿。二满宿。二人善解算数阴阳变运。一难途。二跋难陀。二人深通射道。一迦留陀夷。二阐那。二人善于音乐种种戏笑。一马宿。二满宿。二人善于说法论议。一难途。二跋难陀。二人深解何毗昙。一迦留陀夷。二阐那。二人事事皆能。亦巧说法论议。亦解阿毗昙。一马宿。二满宿。又云。此六人无往不通通达三藏十二部经。内为法之梁栋。外为佛法大护。二人多欲。一难途。二跋难陀。二人多嗔。一马宿。二满宿。二人多痴。一迦留陀夷。二阐那。又云。三人多欲。一难途。二跋难陀。三迦留陀夷。二人多嗔。一马宿。二满宿。一人多痴。阐那是也。五人是释种子王种。难途跋难陀马宿满宿阐那。一是婆罗门种。迦留陀夷。六人俱是豪族。共相影响相与为友宣通佛教。着异衣者。畜积既多故。随时异所著各异。又云。直着一衣但随时处异。又云。一日之中随所著衣。过后夜已。次日更不重着。日日不同。畜积如是种种余衣。问曰。何由得如是种种衣服。答曰。既是贵姓。又多知识多人乐与。兼复多欲。是故衣多。问曰。何以作如是畜积多衣。答曰。本是豪族。先在家时。爱着璎珞种种服饰。虽乐法出家。以本习故乐好衣钵。又世世已来性常多欲。是以今故聚积无厌。问曰。此净施者。是真实施。为是假名施。答曰。一切净施。九十六种无净施法。佛大慈大悲方便力故。教令净施。是方便施。非是真施也。令诸弟子得畜长财而不犯戒。问曰。佛何以不直令弟子得畜长财而强与结戒设此方便。答曰。佛法以少欲为本。是故结戒不畜长财。而众生根性不同。或有众生。多须畜积。而后行道得证圣法。是故如来先为结戒而后方便。于佛法无碍众生得益。如昔一时有比丘来白佛言。与我清净房舍幡幢花盖缯彩被褥。以香涂地丝竹音乐种种庄严。佛敕阿难。处处求索即与具之。比丘在中心安行道。佛随其所应而为说法。即于是处断结漏尽成阿罗汉三明六通具足圣法。以是因缘。佛法通塞众生根性。唯佛知之。不应致难。此比丘从第六天上来生人间。随本所习因而度之。是故既作净施。得畜长财。而不犯戒。问曰。净主比丘不犯长财犯耶。答曰无犯。此方便施。是他物故

三十事初。与诸比丘结戒者。一以为俗利则道利不成。又失檀越信敬净心。比丘无厌与俗无别。有违佛教四圣种法。此是共戒。比丘比丘尼俱得舍堕。式叉摩尼沙弥沙弥尼突吉罗。长物凡有五种。一重宝。二钱及似宝。三若衣若衣财应量已上。四一切不应量若衣若衣财。五一切谷米等一切钱宝比丘不得畜。若僧中次第付者。比丘即应向比丘说净若不说净重宝。应舍与同意净人。如畜宝戒中说。应僧中作波逸提悔过。若钱及似宝。除百一物数。一切亦应舍与同心净人。如畜宝戒中说作突吉罗忏钱宝说净有二种。若白衣持钱宝来与比丘。比丘但言。此不净物我不应畜。若净当受。即是净法。若白衣言。与比丘宝。比丘言。我不应畜。净人言。易净物畜。即是作净。若白衣不言易净物畜。比丘自不说净。直置地去。若有比丘。应从说净随久近畜。若无比丘不得取。取得舍堕。若得应量衣不应量衣。若即说净益善。若不说净。乃至十日无咎。至十日时应与人。若作净若受持。若不与人不作净不受持。至十一日地了时。应量衣应舍。对手作波逸提忏。不应量衣应舍。作突吉罗忏。若比丘得谷米等。即日应作净。若无白衣。四众边作净。若不作净至地了时。谷应舍。作突吉罗忏。沙弥应畜上下衣。一常着衣当安陀会。二当郁多罗僧。令清净入众僧。及行来时着。得畜。泥洹僧一竭支一富罗。随身所著物。各听畜一。自外一切尽是长财。沙弥若得钱宝。亦即时说净。若不即说钱宝应舍。作突吉罗忏。若得应量不应量衣。亦至十日。过十日长物舍。作突吉罗忏。一切谷米等亦不得过一宿。同比丘法。五种衣中三种衣。过十日舍堕。一牛嚼衣。二鼠啮衣。三火烧衣。此三粪扫衣长。过十日得舍堕。二种衣不得舍堕。一男女初交会污衣。二女人产污衣。过十日得突吉罗。十日者。佛知法相。不缓不急不增不损正制十日。初日得衣。即不见摈。不作摈。恶邪不除摈。若彼心。乱心。病坏心。若不解摈。不得本心。乃至命尽。不犯此戒。后若解摈。若得本心。还计日成罪。若初日得衣。上入天宫。北至郁单越住。彼若至命尽。不犯此戒。后归本处。计日成罪。若初日得衣。至五日。若不见摈。恶邪不除摈。若狂心乱心病坏心。上入天宫。北至郁单越。后还解摈。若得本心。若还本处。有言。从解摈日次第十日成罪。有言。取前五日数后五日。然后成罪。律师言。后是定义西拘耶尼。东弗婆提。尽有比丘戒法。亦同龙宫。物皆有主。是故三处不同天上触物自然。郁单越物皆无主。二处兼无比丘戒法。净施法者。如钱一切宝物。应先求一知法白衣净人语意令解。我比丘之法。不畜钱宝。今以檀越为净主。后得钱宝。尽施檀越得净主。已后得钱宝。尽比丘边说净。不须说净主名。说净已随久近畜。若净主死远出异国。应更求净主。除钱及宝一切长财。尽五众边作净。应求持戒多闻有德者而作施主。后设得物。于一比丘边说净主名。而说净法。若净主死远至异国。更求净主。除不见摈恶邪不除摈六罪人。一出佛身血。二破僧轮并犯四重。于六中但犯一事。亦不得作净主。得戒沙弥聋哑盲瞎狂心乱心病坏心婆利婆沙摩那埵五法人。凡净施者。欲令清净作证明故。不生斗诤。如是等人则不如法。若说净钱宝。后贸一切衣财。作三衣钵器。入百一物数。不须说净。自百一物外一切说净。若舍堕钱宝易得一切衣财作百一物。先畜钱边突吉罗对手忏。先畜宝边得舍堕罪。应僧中忏已贸衣财作百一物。不须复舍已入净故。若百一物外。作衣不作衣一切说净。若说净钱宝及以衣财。若人贷去。后时宝更还宝钱更还。钱衣财不须说净。若贷异物。后还不相似物。更须说净。以物异故。若说净一切衣财。作百一物数。更不须说净。若作净余长。应量不应量衣。若长器物。尽更说净。若先应量舍堕物。即作应量不应量衣。此衣尽舍。作波逸提忏。若先不应量舍堕物即作应量不应量衣。此衣尽舍作突吉罗忏。若先应量舍堕物。更买得衣财。即作应量不应量衣。此衣不舍。忏先波逸提罪。若先不应量舍堕物。更买得衣财。作应量不应量衣。此衣不舍。已入净故。忏先突吉罗罪。僧伽梨郁多罗僧安陀会。所以作此三名差别者。欲现未曾有法故。一切九十六种。尽无此三名。以异外道故。作此差别。又僧伽梨。下者九条。中者十一条。上者十三条。中僧伽梨。下者十五条。中者十七条。上者十九条。上僧伽梨。下者二十一条。中者二十三条。上者二十五条。下僧伽梨二长一短。中僧伽梨三长一短。上僧伽梨四长一短。若下僧伽梨三长一短。得受持得着行来。得突吉罗。中僧伽梨四长一短二长一短。得受持着行来。得突吉罗。上僧伽梨二长一短三长一短。得受持着行来。得突吉罗。正衣量三五肘。若极长六肘。广三肘半。若极下长四肘。广二肘半。若如法应量三五肘。受时应言。此衣则成受持无过。若言如是衣。则不成受持。得突吉罗。坏威仪故。若过三五肘。受时应言。如是衣则成受持无过。若言此衣不成受持。得突吉罗。坏威仪故。又缺衣故。过十日无长衣罪。若减三五肘。受时应言。此衣则成受持无过。若言如是衣不成受持。得突吉罗。坏威仪故。又缺衣故。过十日无长衣罪。三五肘若长如法受。则成受持。若比丘死。三衣应与看病人。三五肘外长随多少。应白僧令知。僧和合与者好。凡受衣法。若长应说净。若不说净。入长财中。凡百一物中。三衣钵必应受持。自外若受则可。不受无过。若比丘不受三衣过十日。无长衣罪。无离衣宿罪。有坏威仪罪。有缺衣罪。若新僧伽梨极上三重。一重新。二重故。名新衣。若纯新作衣。二重新作僧伽梨。尼师檀亦如是。若新衣作郁多罗僧安陀会。俱得一重。若故衣极多。四重僧伽梨。二重郁多罗僧。二重安陀会。四重尼师檀。三衣若破。不问孔大小。但使缘不断绝。故成受持。若衣久故失色。故不失受持。后更上色。亦不失受持。更以异物补衣。若但直缝不得成衣。若过十日则堕长财。除先说净。若反钩刺则合成衣。应着三点。不须更受。若是衣财先虽说净。后若作衣受持。则失净法。此衣后舍应更说净。若不说净则堕长衣。若比丘重缝三衣。设有因缘。摘分持行到于异处。名不离衣宿。比丘若死。又言。本界内羯磨此衣。又云。应与看病人。以本是一衣同受持故。律师云。后是定义。若有因缘。一端叠得为三衣。令色如法。若受一衣若受为二衣。随得受持。若十五肘外有长叠。应说净。若不说净。则堕长财。受三衣法。应三说。不得言第二。第三亦如是。是中犯者。若初日得衣二日舍。如是乃至九日得衣十日舍。十日得衣此衣十日。若不舍不受持不作净。至十一日地了时舍堕。舍堕者。前九日衣尽舍作净。但十日时所得一衣。以前次续因缘故。得舍堕罪。凡此中言舍者。尽是作净。以此义推。自后诸句以类可解。若初日得衣初日舍。二日得衣。以不相续故。此二日衣。次第更得十日。若初日得衣二日舍。二日更不得衣。三日得衣。此三日次第得至十日。以不相续故。此中十日衣。以日次第相续。若初日得衣二日舍。二日得衣与初日相续。同日中一舍一受故。若初日得衣初日舍。二日得衣。与初日衣不相续。以异日舍异日受故。此二日衣更次第十日。自后诸句以类推之。义可知也。若比丘有应舍衣已舍。罪已悔过。次续未断若更得衣是后衣于前衣边得舍堕。此言得次续者。非是日次续。以心多求次续不绝。是名次续。衣已舍。罪已悔过。次续心断。即日若先所求衣来。若意外衣来。不堕次续。以心断故。若即日舍衣。即日悔过。求衣心不断。乃至一月。若所求衣来。若意外来。尽是次续。此衣故于先衣边得舍堕。即得衣日得罪。不须经日。若今日舍衣。罪已悔过。即日心断。后日更生求衣因缘得衣。不堕次续。以中间心断故。地了时舍衣。罪已悔过。次续心断。向暮更求得衣。衣舍突吉罗忏。若衣已舍。次续已断。罪未悔过。正使多日得衣。衣舍突吉罗悔

    第二结离衣宿因缘

外国明相。有种种名。婆罗门名日。诸富贵人名易。诸山胡名却沙。种作人名种作时。捕鱼人名显。如是诸相尽非明相。但于明相上作是诸名。以少因缘者。大迦叶凡经营五大精舍。一者耆阇崛山精舍。二者竹林精舍。余有三精舍。时治理竹园精舍。来诣竹园。如舍利弗经营祇洹精舍。目连经理五百精舍。问曰。诸弟子漏结已尽所作已办。何故方复屡有所经营作诸福业。答曰。一为报佛恩故。二为长养佛法故。三为灭凡劣众生作小福业自贡高故。四为将来弟子折伏憍豪心故。五为发起将来众生福业故。问曰。大迦叶有大神力。何故不以神力去。而以天雨为碍。答曰。迦叶自治僧坊。自手执作泥涂垣壁。自手平治地。自手平治地已。天则大雨。以天雨故。便入禅定。自期雨止便起。天雨竟夜晓则而止。即便出定明相已举又云。尔时佛为诸比丘说枯树经。或有比丘服俗还家。或有忧恼不能自安。尔时迦叶。为诸比丘随宜说法。竟夜不息。说法已竟天时已晓。以是因缘不用神力。离僧伽梨宿。今当云何。问曰。大迦叶是大智人有深大事犹能了达此是小事何足问人。答曰。欲令将来众生不以小智小辩自信自用。常怀不及以咨。于他。为物范轨示此迹尔。赞戒赞持戒者。所以赞戒者。以心善故。又大迦叶。佛从始已来未曾呵责。如舍利弗。佛亦呵言。汝何以食不净食。如大目连。佛亦呵言。汝何以授未满二十年人具戒如难陀。佛亦呵之。汝何以教尼乃至日没时。如优陀夷。佛亦呵言。汝痴人乃与舍利弗论议诤胜。如阿难。佛亦呵言。痴人汝何以触恼上座。而大迦叶。未曾为佛所呵责。以其德行深厚无有过咎。又欲令于佛灭后维持大法。纵使若有小缺。不以致责。欲令后世众生深心尊重故。复次迦叶。常乐行道时入禅定天晓乃起。舍利弗者母名。舍利弗者。秦言身子。舍利所生故。名舍利子。又母怀妊时。梦见一人容仪端政身着钾胄手执大棒入其身内。相师占云。当生智人聪辩绝世。必能摧伏一切论师。又云。母怀妊时神智过常。自求论师与共诤胜。时人咸怪谓失本心。诸婆罗门言。此非已力。以怀智人故使尔耳。既知审尔。如常侍卫以防护之。月满便生。舍利弗病者。佛弟子中多病。无过舍利弗。常患风冷又病热血。有医言。风病应服大麦浆。又言。血病应取大麦汁服之。又言。应烧石令热着乳汁中服之。又言。应乳汁中煮蒜食之。又言。应取树叶捩取汁以涂身上。又言。着禅带。舍利弗有大功德智慧。何以有如是病耶。又言。舍利弗前世业缘故。以过去世恼乱父母及以师僧。是故有病。又云。舍利弗智慧利根。深染法味。常修智慧及论议法。又乐禅定劝作众事。精勤三业无时暂懈。卧起不时故有此病。又云。此是后边身。先世罪业一切受尽。然后泥洹。故多病也。欲一月游行者。问曰。舍利弗病。何以欲游行耶。答曰。有缘众生应受化故。如佛一日六时观众生。随应度者不失时宜。舍利弗第二转法轮师。亦一日六时常观察众生。知应度者随宜度之。又舍利弗捉持佛法。欲游诸国随可应为随宜消息。是故应行。又以风冷病故。游行自苦。病则损折故。又求行道所宜处故。又诸国土。应降伏者欲令降伏故。已降伏者令发信悟故。问曰。何以正一月游行。答曰。有缘众生一月则尽。是故一月。又云。应降伏者一月则讫。又云。求索所须衣服卧具一月则足。又云。应求病所须一月则办。僧伽梨重者。问曰。舍利弗有四如意足。能以三千世界手中回转。何以乃言僧伽梨重。答曰。舍利弗所以游行。欲化众生。而所应度者。不以神通得悟。是以不现神力。正应步行。而僧伽梨重。又云。欲往降伏未降伏者。而诸论师可以理屈。若现神力则长彼憍心。是故不现神足。若欲步行而僧伽梨重。又云。现大慈悲相故。为将来老病比丘无诸恼故。欲令如来作开通因缘。与老病比丘。作一月不离衣宿羯磨。老者。七十已上名为老。问曰。佛何以结一月不离衣法。答曰。为度众生因缘故。又为行道因缘故。不持重衣得离苦恼。随时修业无所妨故。又为求随身所须故。为求病瘦所宜故。为营精舍塔寺故。为降伏未降伏故。已降伏者生信悟故。曰得舍衣突吉罗忏

    不离衣宿第二

此戒比丘比丘尼共。式叉摩尼沙弥沙弥尼不共。无离衣宿戒。尼结大界。极大一拘屡舍。结一月衣戒同也。僧结衣界。尼则不同。尼结衣界。僧则不同。凡结大界。所以通聚落者。僧结大界。以界威力故。恶不得便。又在界内善神所护。是以为檀越故。通聚落结也。若结大界。僧应尽集不得与欲。着上下衣游行诸国者。上衣郁多罗僧。下衣安陀会。一夜者。又云。但以色阴昼夜。以明晓为昼。黑冥为夜。又云。以五阴为昼夜。日没者。若日过阎浮提界。名日没。明相者。有种种异名。有三种色。若日照阎浮提树。则有黑色。若照树叶。则有青色。若过树照阎浮提界。则有白色。于三色中白色为正。离衣宿至明相出。尼萨耆波逸提。或有舍衣不得罪。如比丘出界至他处宿。借衣受持过地了时舍衣还他。是谓舍衣无罪。或有得罪不舍衣。如比丘出界至他处宿。借衣受持过地了时。即还他衣不说舍法。还自受衣。以不舍衣更受自衣。坏威仪故。突吉罗。是谓得罪不舍衣。或有亦舍衣亦得罪。如比丘自有衣出界外宿地了时舍堕。是谓亦舍衣亦得罪。或非舍衣不得罪。如比丘自受持衣不离宿。是谓不舍衣不得罪。除僧羯磨者。僧先结大界。后结衣界。大界者。极大纵广十俱屡舍。必使此中羯磨布萨时不生疑心。设有河水大道亦得合结。但度岸取相而后结之。降此已还。随远近大小无过。若结衣界作羯磨应言。除聚落及聚落界。所以除聚落者。聚落散乱不定。衣界是定。又为除诽谤故。又为除斗诤故。又为护梵行故。又为除嫌疑故。又言。若有聚落。应言除聚落。若无聚落不须言除。又言。羯磨法尔。若有若无一切时除。所以然者。若结衣界时无聚落。结衣界已。后聚落来入界中。不须更结。已先结故。若本有聚落。结衣界已移出界去。即此空处。名不离衣界。若聚落先本小后转大。随聚落所及处。尽非衣界。若聚落先大。结衣界已聚落转小。随有空地。尽是衣界。又如王来入界内施帐幕住近左右作饮食处大小行来处。尽非衣界。有作幻人咒术人作乐人。来入界内所住止处。亦如王法。尽非衣界。复次除僧羯磨者。如舍利弗僧伽梨重。为老病比丘。结一月不离衣法。与羯磨竟病差。于此月内。即先羯磨游行。若羯磨竟病重不行。病差已复不行更得病。即先羯磨同一月内。故得游行。若化众生未尽。一月已尽。若求衣服医药所须。若为三宝有所营作。所求未办。而一月已尽。以事难故。至缘讫无罪。若比丘死。此衣应与看病人。以衣属死比丘故。若失衣更求得衣。不问轻重。应更作羯磨。若施三宝。更求得衣。亦应更作羯磨。乃至九月亦如是。以因缘故结一月。以一月因缘故结九月。问曰。何以不多不少正齐九月。答曰。比丘结三月一处安居以修所业。是故九月。问曰。为一羯磨。为九羯磨。答曰。一羯磨。若僧伽梨。郁多罗僧安陀会亦如是。以因缘故。听僧伽梨。因僧伽梨。听郁多罗僧安陀会。问曰。正听离一衣。更听离二衣。答曰。不听二衣。所以制三衣。以除寒故。一衣不能却寒。以除惭愧故。一衣不能除惭愧。又为入聚落故制三衣。一衣不中入聚落。又为生前。人欢喜心故制三衣。一衣不生人善心。为威仪清净故制三衣。一衣威仪不清净。若比丘尼欲留二衣亦不得。所以制五衣者。为威仪故。三衣不成威仪。余如前说。若着郁多罗僧安陀会。一切时得入王宫聚落。无过。若作一月羯磨。有老比丘。僧伽梨重。若实不老不病。僧伽梨重。为作羯磨。则成羯磨。僧得突吉罗。前人以不知法故无罪。若前人知法。亦得突吉罗。若实不老不病。僧伽梨不重。而言老病重。得波逸提。得成羯磨。或聚落界非家界。如二聚落各有一家。是谓聚落界非家界。或有家界非聚落界。如一大聚落更无异聚落。有众多家。是谓家界非聚落界。或有亦聚落界亦是家界。如二聚落各有多家。谓聚落界亦是家界或有非聚落界非家界。如阿练若处。是谓非聚落界非是家界。聚落有一界亦有别界。相接聚落。是名一界。不相接聚落。是名别界。家亦有一界亦有别界。若房舍住处。是名一界。若作食处。若取水处。若门处。若大小便处。是名别界。自后诸句类可解也。不相接聚落者。鸡飞所及处。箭射所及处。分别男女处。惭愧人大小行处。若聚落正有一家。置衣在一家中。在箭射所及处卧。至明相举不失衣。设衣在箭射所及处。比丘在家中卧。至明相举亦不失衣。若聚落有众多家。若衣在家中。在箭射所及处卧则失衣。以家界别故。若置衣在家界外。在箭射所及处卧不失衣。相接聚落界者。四边有聚落。以十二桄梯四向到墙上得登出入。身在梯根下卧。置衣在四边聚落。则不离衣。以梯四向相接故。若聚落正有一家。衣在家内不失衣。若聚落有多家。衣在家内则失衣。若衣在家界外不失衣。若有梯衣在四聚落不失衣。若无梯衣在四聚落则失衣。以不相接故。复有相接聚落界。如两边有聚落。中间有道容车行来。若车轴两头到聚落。以衣着一头。人在一头。设在车上俱不失衣。以车连接故。设聚落正有一家。以衣在一家内。在车上卧。亦不失衣。若无车者不成相接。必使有车则不失衣。若无车者则失衣也。若聚落有墙篱。围绕四边。容作事处。是聚落界。以有墙障故。势不及远。若聚落有堑围绕四边。掷粪扫所及处。是名聚落界。以墙篱围绕及堑围绕。此二界异前不相接。聚落界相接聚落界。族有一界有别界。若父母兄弟儿子。共一食一业。未作别异。是名为家。若父母兄弟儿子。异食异业尽皆别。虽同居一处。事各不同。是名为族。族有一界亦有别界。各有所住处。是名一界。若作食处。若门处。若取水处。若大小行处。是名别界。若衣在一族。人在异族。则失衣也。若人在一处。衣在取水处。若在作食处。则失衣也。自后车行聚落。外道舍场舍园舍。若异主异见。则失衣。若一主同见不失衣。义推可知。重阁舍者。若衣在上重。人在下重。舍属一主。不失衣。若舍是异主。衣在上重。人在下重。衣在下重。人在上重。则失衣。若衣在下重。人在中重。若衣在中重。人在下重。若衣在上重。人在中重。若衣在中重。人在上重。则不失衣。以中间相接相通故。若比丘与师持衣。前后四十九寻。律师云。亦得纵广四十九寻。若比丘二界上卧。身入二界内。衣在二界。俱不失衣。若二聚落中隔一墙。在墙上卧。衣在二聚落。俱不失衣。若比丘在二界中间死。随面向何处应取衣。又云。随所先见。则取此衣

    第三非时优波斯那因缘

我欲四月燕坐。问曰。佛三阿僧祇劫立四弘誓。欲济无边众生。今既成道。云何寂然自守。答曰。佛无时不度众生。或以寂默而作佛事。或以说法而作佛事。行住坐卧无非佛事。凡静默者。或离身乱。或离心乱。或身心俱离。佛四月燕坐。或游诸禅定。或至他方度脱众生。或入十力四无所畏十八不共法。佛所以燕坐者。以众生常见佛故。宽纵懈怠。欲令众生生渴仰心故。又不欲令外道异见长讥谤故。以常见佛驰骋诸国。谓直栖栖内无实法。是故燕默亦其不空。又欲令将来弟子作轨则故。佛功德智慧一切具足。犹禅默不废。而况凡夫而生懈怠。又佛以法为师。静默入定。游入种种无量法门。即是法供养师。四月燕坐者。佛在世时凡三燕坐。一初得道已十五日燕坐。亦制诸比丘不得见佛。中间二月燕坐亦复立制。问曰。佛何以初十五日中二月后四月。答曰。初得道时始度众生。以化众生因缘多故。正十五日中燕坐。时所化众生。以无量外缘渐少。是故二月。后泥洹时到。所化众生转以向尽。是故四月。又佛初成道时。众生为恶者少。但十五日则见过罪。又至中间众生作恶渐增。二月燕坐亦见过罪。至其后时多作非法。四月燕坐乃见过罪。往者随意。问曰。诸比丘何以不语优波斯那僧众之制。答曰。优波斯那既是大德。捉持佛法。以畏难故。不敢向说。除一送食比丘及布萨。食供养佛色身。布萨供养法身。是故听之。此是共戒。比丘比丘尼俱舍堕。三众突吉罗。非时衣者。从四月十六日至八月十五日。名为衣时。若有功德衣。至腊月十五日。名为衣时。从腊月十六日至四月十五日。名为非时。此四月中。若人自恣与衣。是名非时衣。若四月内得父母兄弟姊妹儿女本二所施衣。若五岁会若入舍会。不名非时衣。此各有常定故。若自求已乞衣。不名非时。三衣具足。不听乞故。若得不具足衣。停是衣欲令具。得至一月。过是停舍堕。此戒体得不具足衣。欲使具足故。得至一月。必使一月勤求成衣。令想念不断。得至一月。若或时断想。不至一月。若初日得衣即作是念。我此十日所望必不能得。是衣不得过十日。若过十日。若是衣乃至四肘无缝缘作。若直留此过十日者舍堕。若不应量衣者。突吉罗。此衣应舍。乃至十日。作是念。我此一日所望。恐必不能得此衣。一日内不与人不作衣不作净。至十一日亦如前说。若初日得即停衣。日不得所望。非望而得。是二种衣十日内。若不作衣不作净。不与人不受持。至十一日。是二衣下至四肘者舍堕。若不应量。此衣舍衣突吉罗忏。虽不得所望。非望所得应成衣故。若比丘得不具足衣。停更望得衣故。乃至九日不得所望。非望而得。是衣至十一日。亦如前说。若初日得不具足衣。停更望得衣。故至十日不得所望。非望而得。是衣一日内若不作衣不与人。不作净不受持。至十一日亦如前说

萨婆多毗尼毗婆沙卷第四萨婆多毗尼毗婆沙卷第五

        失译人名今附秦录

    第四结从非亲里尼取衣因缘

花色比丘尼者。容貌端政。色作优钵罗花色。此人前世久远劫时。作一婆罗门女。父母家人入海采宝。是女在后不能自活。便与诸淫女共在一处。卖色自供。此女色貌不丰。无人往来。常自咎责。何以独尔。时世有辟支佛。一切敬仰。有人语言。汝能供养辟支佛者。随心所欲世世如愿。时彼女人即随其语。办美饮食以优钵罗花覆上。奉辟支佛。即发愿言。令我世世常作女人。端政无双为人所敬。无能过此。又愿得如沙门所得功德令我得之。是故今世犹作女人。颜貌第一。以本愿故。今得漏尽。安陀林者。名昼闇林。是林广大繁茂。林下日所不照。又林主长者。名曰安陀。故因此为名。以贵价叠裹一刬肉悬着树上。问。设有人取此叠肉。谁边得罪。为贼边得。为尼边得。答曰。尼边得罪。何以衣服弊坏者。问曰。花色有大功德名闻。多人所识。何故衣服不充。答曰。世有二人无厌无足。一得已积聚。二得已施人。花色凡有所得求者皆与。是以供身所须常有所乏。盈长衣中者。此是佛入静室四月燕默。多有比丘。舍居士衣着粪扫衣。是假衣也

    从非亲里尼取衣第四

此是不共戒。比丘尼无犯。沙弥突吉罗。与诸比丘结戒者。正以男子女人。不宜交往共相染习。则致种种非法因缘。是以断之。若是亲里不致嫌疑亦无非法。是故则听取衣者。是应量衣。若是白衣。若非法色衣。亦不得取。以染应法故。取则舍堕。若多比丘取一衣。多人犯。一比丘多尼边取一衣。计尼犯。五种衣。三种不得取。火烧牛嚼鼠啮。取则舍堕。二种衣取突吉罗。取应量钵舍堕。若取一切不应量衣服键镃器物。突吉罗。若从式叉摩尼沙弥尼取衣与比丘尼同犯。除贸易者。令行道者得安乐故。又使弟子无苦恼故。若比丘得比丘尼所宜衣。比丘尼得比丘所宜衣。不贸易者。以衣因缘故。种种驰求妨废行道得诸恼害。是故听之

    使非亲里尼浣故衣第五

此是不共戒。沙弥使非亲里尼浣故衣。突吉罗。是中犯者。若自持衣与非亲里尼。若浣若染若打。三事中趣作一事。尼萨耆波逸提。若一时作三事。亦得一舍堕。若浣不好净。染不成色。打不能熟。尽突吉罗。若使书信印信突吉罗。若使浣舍堕衣突吉罗。若二人共一衣。乃至多人共衣使打染。尽突吉罗。使浣染打不净衣驼毛牛毛羖羊毛杂织衣。突吉罗。与学沙弥浣染打舍堕。破戒贼住如是等无犯。使式叉摩尼沙弥尼浣染打故衣。与比丘尼同犯。若比丘尼使比丘尼浣故衣。突吉罗。此戒应量不应量衣一切犯

    从非亲里居士乞衣第六

跋难陀说种种法者。或云。初说布施。中说持戒。后说生天福报。或云。前后说法。但说布施福报。为诸比丘结戒者。一以佛法增上故。二为止诤讼故。三为灭前人不善心故。四为众生于正法中生信乐故。此是共戒。比丘比丘尼俱舍堕。式叉摩尼沙弥沙弥尼突吉罗。是中犯者。比丘从非亲里乞衣。得衣者尼萨耆波逸提。若使书信印信突吉罗。若二人共乞一衣。突吉罗。若为他索突吉罗。若得应量衣舍堕。若得不应量衣突吉罗。不犯者。从亲里索。若亲里多财饶宝。从乞无犯。若亲里贫匮从索突吉罗。若亲里与少更索多突吉罗。若为他索突吉罗若。为法令亲里自与无过。若先请者。若非亲里先请与衣从索无犯。虽先请与衣后若贫穷。从索突吉罗。若与少更索多。亦突吉罗。若为他索亦突吉罗。若非亲里不索自与。无犯

    第七戒

尔时波罗比丘者。此是土地名。此比丘因地为名。昔儒童菩萨于然灯佛所。以发布地令佛蹈过。以此因故。得发绀色。即于尔时剃发出家。时无数人得菩萨发尊重供养。以是因缘。众多众生值过去佛。皆得漏尽入无余泥洹。余四十人于今佛得度。此波罗比丘四十人中是一人数最后度者。裸形而行者。问曰。远行难崄。有贼难毒虫难水难火难饥寒等难。佛何以令诸比丘远游行耶。答曰。众生根性好乐不同。是故大圣因而制教。或有众生。因动乱游行而生善根。是故如来赞叹游行。随时一移无所系恋。若有众生。但因静默而增善根。是故如来赞叹闲居静默自守。随有益故则无咎也。所以裸形者。一以佛结戒故。不敢乞衣。二为将来比丘多有如是诸苦难事。欲令佛作开通因缘故。夺比丘衣者。此六群比丘。有深智慧善为方便。先语波罗。汝衣满足。长者与我。波罗许可。是故无罪。与诸比丘结戒者。此是共戒比丘比丘尼俱舍堕。三众突吉罗。若比丘失一衣。是比丘僧伽梨。可摘作衣者不应乞。若乞得者舍堕。若乞不得突吉罗。若有余财中作衣者不应乞。若乞同僧伽梨得罪。若失二衣。有僧伽梨可摘作一衣者。应乞一衣。若乞得二衣者舍堕。若不得突吉罗。此中衣者。限应量衣。余不应量衣。若少若无应乞。若长乞。尽突吉罗

    第八戒

此是共戒。比丘比丘尼俱尼萨耆波逸提。三众突吉罗。尔时有一居士。为跋难陀释子办衣直。此居士常与跋难陀客主来往。跋难陀智慧福德多财饶货。常以财宝与此居士出入息利。时此居士。欲办一衣与跋难陀以求意气。欲令息利之中不计多少跋难陀知其意故。便到其所劝令好作。此戒体。非亲里居士居士妇。先为办衣直。便到其所教令加钱好作。若贵价好色大量。如语得者舍堕。不得者突吉罗。若遣使书信印信突吉罗。若不为贵价好色大量求。随其所宜等价等色等量。减价减量减色。劝令作如是衣者无犯。是中衣者。应量衣。下至四肘。上至八肘。得应量衣舍堕。得不应量衣突吉罗。不犯者。从亲里索。若亲里丰财多货从索无过。若贫穷者突吉罗。若先请者非亲里。先请有所须者索。若先请檀越丰有财物。劝令好作无过。若贫乏者突吉罗。若非亲里自与无犯

    第九戒

此是共戒。比丘比丘尼俱舍堕。三众突吉罗。此亦是应量衣。若劝得不应量衣突吉罗。前戒。一居士为比丘先办衣直。劝令于价色量中加直好作。此戒体。二居士各办衣直。各作一衣与比丘。劝令合作。使于价色量中增加好作。义同前戒。正以二居士为异。不犯者。从亲里索若先请。若不索自与。尽如前说。若遣使书信印信。尽突吉罗

    第十戒

跋难陀前在家时。善于射道兼知兵法。摩竭提国大臣将帅。遣五百人从其受法。得通射道有达兵法。即还本国。摩竭大臣寻遣使命。多持宝货来报其恩。时跋难陀。以染法服出家在舍卫国。时摩竭使到迦维罗卫。已云出家。展转求觅至舍卫城。到市肆上得共相见。即以宝付之还归本国。此是共戒。比丘比丘尼俱舍堕。六法尼沙弥沙弥尼突吉罗。此戒体。若檀越遣使送宝与比丘。比丘应言。我法不应受宝物。若须衣时得清净衣者。速作衣持。使若问比丘。有净人不。应示所在。使以衣直付净人。教令作净衣与比丘。使语比丘。须衣时往取衣。比丘应到净人所索衣作是言。我须衣。如是三反索。得衣者善。不得者。四反五反六反净人前默然立。若乃至六反默然立。得衣者善。若不得衣。过六反得衣舍堕。戒体正在三索三默无过。若七反得衣成罪。不得突吉罗

    十诵律第二诵初三十事中第十一事

佛在俱舍毗国。此是土地名也。憍奢耶者。是绵名也。此国养蚕。如秦地人法。蚕熟得绵。名憍奢耶。此国以绵作衣。凡有二种。一擗绵布贮如作毡法。二以绵作缕织以成衣。作此二衣。名作敷具。敷具者。衣名也。与诸比丘结戒者。止诽谤故长信敬故。行道安乐故。不害众生故。此是不共戒。比丘尼式叉摩尼沙弥沙弥尼突吉罗。是中犯者。乞茧乞绵乞缕作二种衣。衣成者尼萨耆波逸提。此二种衣。得作三衣中受持。若乞茧自作绵不得罪。若乞茧卖故有生虫者突吉罗。若无虫者无罪。若乞得成绵贮衣无罪。若乞得茧绢已成者无罪。若憍奢耶虫坏作敷具无罪。若合驼毛羊毛牛毛突吉罗。若合刍摩衣麻衣劫贝衣褐衣钦婆罗衣。作敷具者突吉罗。作衣下至四肘舍堕。若使他作亦舍堕。以憍奢耶贵故

    第十二事

此国以黑羊毛贵故不听也。黑羊毛作衣法亦二种。一以黑羊毛择治布贮作细毡。二作缕织成作衣。此二种衣。尽名敷具。敷具者。衣名也。此羊毛衣得作三衣。尽中受持。此是不共戒。四众突吉罗。是中犯者。羊毛有四种。生黑蓝染。黑泥染。黑木皮染。黑四种黑羊毛中随取一种。擗治布贮作敷具。成已舍堕。若得朽坏黑羊毛作敷具无犯。若得以成者。若为塔若为僧。若以驼毛羖羊毛牛毛合作突吉罗。若刍麻衣劫贝衣褐衣钦婆罗衣合作突吉罗。作衣下至四肘舍堕。若使人作亦舍堕。以黑羊毛贵故

    第十三事

此戒正以杂羊毛作敷具为异。此是不共戒。四众突吉罗。黑羊毛如前说。白羊毛背毛胁毛颈毛。下者头毛腹毛脚毛作敷具。应用二十钵罗黑毛十钵罗白毛十钵罗下毛一钵罗四两。若作敷具。用黑毛二十钵罗中乃至过一两舍堕。若取白羊毛十钵罗中过一两突吉罗。若取下羊毛十钵罗中乃至少一两舍堕。若作六十钵罗敷具。用三十钵罗黑羊毛十五钵罗白羊毛十五钵罗下羊毛。若作百钵罗敷具。用五十钵罗黑羊毛二十五钵罗白羊毛二十五钵罗下羊毛。若自索羊。毛自作成衣。亦舍堕。虽听杂作以功力多故。有所妨废。是故得罪。若倩人如法作无罪。亦下至四肘。尼萨耆波逸提

    第十四事

此戒体。若作三衣已六年内。不得从檀越乞羊毛缕种种衣具。作应量衣。则随织成已舍堕。除僧羯磨。僧羯磨已。得从檀越乞衣具作衣。此戒体。断多贪多畜。此不共戒。四众突吉罗。自与不犯。自有衣财作不犯。若买得衣财作不犯

    第十五结新作尼师檀因缘

默然受请。问。佛受请何以默然。答曰。佛贪结已尽。于食无贪无染。是故默然。声闻辟支佛。贪结虽尽习垢犹在。是故受请。故有许可。又云。为断讥谤故。若佛于食发言许可。外道异见当言。瞿昙沙门自言。超过三界而故于食有贪。又云。佛现大人相故。食是小事不以致言。譬如国王终不以小事倾移。设有大事详而后动佛亦然也。又云。佛凡有五时入空三昧。一受请时。二受食时。三说法时。四有利乐时。五讥谤时。若受请时观。请我者谁。受请者谁。若受食时。施食者谁。受食者谁。如是乃至讥谤我者谁。受谤者谁。以入空三昧故。是以默然。有经说。佛亦有时受请以言许可。问曰。佛何以有时许可有时默然。答曰。此不可思议。经云。佛不可思议。龙不可思议。世界业报不可思议。此是佛不可思议。佛欲令众生知佛心者。乃至下流钝根众生。佛欲令见即得见之。若欲令不见。正使声闻辟支佛有通眼者。不能得见。又佛放大光明。下至阿鼻狱上至有顶。有应度者令得见之。不应度者对眼不见。是故佛有时许可有时。默然。不可测也。头面礼佛足右绕而去。若外道异见但绕而去。若有信者礼足绕已而去。佛身清净喻如明镜。天神龙宫山林河海。一切器像于身中现。见者信敬心生。是故头面礼足。右绕者。顺佛法故。所以右绕。又密迹力士。若有左绕者。即以金刚杵碎之。又佛世世已来。常顺三宝父母师长。一切教诫无违无逆。今得果报无有逆者。又佛身净。众生于中各见所事。或天或神莫不见者。是以畏敬右绕而去。问曰。外道邪见何以不礼佛足。答曰。世世习憍慢故。又常怀恶邪无善心故。又云。各有所事故。何以正绕三匝。一以不恼乱佛不自乱故。二以生将来解脱因缘故。还归竟夜具诸净洁多美饮食。问曰何以正夜作食。答曰。昼日多热饮食臭秽。是故夜作。又云。夜作食晨得新食。若先作食者则食宿食。是以夜作。白佛时到。问曰。先已请佛何以重请。答曰。欲生增上功德故。先白以请。今更重请功德转增。又欲成三坚法故。又佛时到自行。何由得知。一居士在静处烧香。遥供养请佛。香来绕佛三匝。又云。密迹力士白言时到。又云。阿难时至则白。又云。佛自知时不须外缘。佛自房住者。佛以行无益故不行。又云。佛所以住者有五因缘。一以入静室。二为诸天说法。三为病比丘。四为结戒故。五为看诸房舍卧具故。从房至房者。为欲令诸比丘生畏敬故。比丘行后佛自观诸房舍。后诸比丘必自肃慎。不敢令诸房舍中有诸非法。又欲断诸比丘非法谈论。佛自入房舍。终不敢有非法言者。又欲断诸贼盗人故。佛自行房。设有恶人不起贼心。上座说法者。所以食竟与檀越说法者。一为消信施故。二为报恩故。三为说法令欢喜清净善根成就故。四在家人应行财施出家人应行法施故。尔时有居士。请佛及僧明日舍食。佛在世时。饮食衣服及余供养。常受一人分。佛灭度后。三宝分中但取一分。问曰。佛在世时何以但取一人分。灭度后取三宝一分。答曰。佛在世时供养色身。是故但取一人分。佛灭度后供养法身。以佛法身功德胜于僧宝。是以于三分中取一分也。佛若在世时。若施主言供养佛。则色身受用。若言供养佛宝。则色身不得受用。应着抓塔发塔中。施心供养法身。法身长在故。凡为施法。应令心定口定。施福既深又易分别。若施佛者定言与佛。若施法者应好分别。若施法宝口必令定。若施经书口亦令定。若施说法诵读经人。口亦使定。若施众僧亦有三种。若僧祈腊若自恣腊若面门腊。于此三种应好分别。又施众僧复有二种。一施僧宝。二但施僧。若施僧宝。凡夫僧圣人僧不得取分。以施僧宝故。若施众僧者。圣僧凡夫僧俱得取分。以言无当故。若言施三宝。应分作三分。一分与佛宝。一分与法宝。应悬着塔中。不得作经。不得与说法诵经人。一分与僧宝。众僧不得取。此物应还付施主。若无施主应着塔中。供养第一义谛僧。若直言施法。分作二分。一分与经。一分与读诵经人。不与法宝。律师言。不与法宝。如秦地寄物来与法丰僧祈。若自恣若面门随语分处。若直言与法丰僧。应分作三分。一分与僧祈。一分与自恣腊。至自恣时分。一分与面门。随取饮食。若法丰无僧。乃至有一沙弥。沙弥应分作三分。僧祈面门自恣。自恣腊时。待自恣时取。面门腊随取食。若取自恣腊时食面门腊时应打揵椎。若有比丘共食共分。无者自食自取。如法清净。若无沙弥。应入近住僧。若无近住僧。应入尼僧。尼僧应好思量。若法丰僧始终有还理。应举置一处还则与僧。若必无还期。应分作三分如前法。一分入僧祈。一分入面门。一分入自恣。待自恣时分。若远方送物与尼僧。次第如法如前僧法。更无异也。若送物与波演。分作三分。一分入波演。以无僧祈故。一分入面门。一分入自恣。待自恣时分。若远处。以罽宾佛教炽盛。送物供养者。此物正应与佛与僧。以僧顺佛教故。若与佛与僧。即是与法。以法不离佛僧故。应分作二分。一分入佛。一分入僧。若送物供养罽宾。有二种僧。一萨婆多。二昙无德。随意供养无过。若送物与五法僧。若无五法人。即入五法尼僧。若无尼僧。若始终永无五法人者。此五法物。应分作三分。僧祈自恣面门。二种得入僧祈用。不得分也。面门还置本处。不得取也。若比丘作尼师坛。应用故敷具周匝修伽陀一搩手。坏色故。尼师坛者。长佛四搩手。广佛三搩手。故敷具者。僧祈藏中有种种故弃衣服卧具尽名敷具。若作新尼师坛。应取故敷具最长者。广中取一搩手长。裂随广狭分作缘。周匝缘尼师坛。若故敷具中无大长者。随有处长者用。若无长者短者亦用。若一切都无不用无罪。若四方僧虽有故衣服。非是弃物不得取用。若有处不用舍堕

    第十六事

诸比丘持毛从后来心生嫉妒者。诸贾客欲贩羊毛。不欲令羊毛多入国故。二见诸沙门担负羊毛。非出家人法。是故呵之。此是不共戒。比丘尼式叉摩尼沙弥沙弥尼突吉罗。由旬者。四十里一由旬。若得羊毛。一比丘担去。得至三由旬。若二比丘至六由旬。如是不计人多少。是中犯者。若比丘自持羊毛过三由旬。尼萨耆波逸提。问曰。此是暂舍为根本舍。答曰。以罪言之。是根本舍。以法言之。是则暂舍。若使五众持去过三由旬突吉罗。不得车载驮负。若使净人持去过三由旬突吉罗。不犯者。三由旬内。若着耳上。若着耳中。若着咽下。若作毡。若着针筒中持去不犯。若与人持去三由旬不犯。以非比丘法故。亦自伤损

    第十七事

头面礼足一面立。问曰。瞿昙弥比丘尼众。何以不坐。答曰。女人敬难情多。是故不坐。又云。佛少为尼众说法。设为说法不广为说。又尼众一切时佛所不坐。为止诽谤故。若坐听法。外道当言。瞿昙沙门在王宫时。与诸婇女共在一处。而今出家与本无异。欲灭如是诸讥毁故。是以不坐。又女人鄙陋多致讥疑。是故不坐。与诸比丘结戒者。为增上法故。若诸尼众执作浣染。废息正业。则无威德破增上法。又为止恶法次第因缘。又为二部众各有清净故。此是不共戒。四众突吉罗。是中犯者。若比丘往语非亲里比丘尼。为我浣染擗羊毛。若比丘尼为浣为染为擗。随作一事。各得舍堕。若比丘尼更转使他浣染擗突吉罗若使式叉摩尼沙弥尼浣染擗舍堕。若遣使书信印信浣染擗突吉罗。若舍堕。羊毛未作净。使浣染擗突吉罗。若净施羊毛使浣染擗。净施主得突吉罗不。犯者亲。里尼式叉摩尼沙弥尼不犯

    第十八事

与诸比丘结戒者。为止诽谤故。为灭斗诤故。为成圣种故。此是共戒比丘比丘尼俱尼萨耆波逸提。式叉摩尼沙弥沙弥尼不得畜。畜得突吉罗。捉则无罪。是戒体。正以畜宝制戒。如戒本说。若比丘自手取宝。若使人取。此二种取尽取。自畜取有五种。以手从手取。若以衣从他衣取。若以器从他器取。若言着是中。若言与是净人。皆为畜故。以此五事当取时舍堕。莫自手捉。如法说净者不犯。宝者。重宝。金银摩尼真珠珊瑚车磲马瑙。此诸宝若作若不作若相若不相。作者。以宝作诸器物。不作者。但是宝不作器物。相者。不作器宝。或作字相。或作印相。不相者。不作器宝不作字相。不作印相。若受畜如是宝舍堕。若比丘自手取铁钱铜钱白镴钱铅锡钱树胶钱皮钱木钱。此诸钱亦以五种取。以手捉手取若以衣从衣取。若以器从器取。若言着是中。若言与是净人。为畜故当五种取时突吉罗。莫自手捉。当取时如法说净者不犯。若比丘舍堕宝若少应弃。若多设得同心净人。应语言。我以不净故不取。汝应取。净人取已语比丘言。此物与比丘。比丘言。此是不净物。若净当受。即是说净。说净已。然后入众悔过。不为畜故。若捉他宝。若捉自说净宝。但捉故得波逸提。一切钱若铜钱。乃至木钱。若他钱。若说净钱。但捉突吉罗。非是此戒体。是九十事捉宝戒。若种种钱似宝。玻[王*(黎-(暴-(日/共))+(恭-共))]琥珀水精种种伪珠。鋀石铜铁白镴铅锡。如是等名似宝钱及似宝。若畜得突吉罗。钱宝应舍与同心白衣净人。不入四方僧。若重宝不得同心净人。入四方僧。若似宝作器。入百一物数。不须作净。若不入百一物数。一切器与非器。皆应说净。百一物各得畜一。百一之外皆是长物

    第十九事

尔时六群比丘先舍堕宝作种种用者。此宝六群比丘如法说净已种种转易。此是共戒。比丘尼俱舍堕。式叉摩尼沙弥沙弥尼突吉罗。此戒体。以重宝与人求息利。当与时得舍堕。若为利故以重宝相贸。得彼宝时舍堕。以重宝为利故更买余物。得物时舍堕。以宝相贸者。如以作贸作。以作贸不作。以作贸作不作。不作亦有三句。若以相贸相。若以相贸不相。若以相贸相不相。不相亦有三句。是谓以宝贸宝。用有五种。一者取。二者持来。三者持去。四者卖。五者买取。取者。若言取此物。从此中取。取尔所。从此人取。持来持去亦如是四种。卖与买亦如是四种。若比丘用铁钱乃至木钱。与人求息利突吉罗。若为利故。以钱买物突吉罗。若余似宝若縠绢布。如是比丘若出息若以买物为利故。尽突吉罗。此戒体。正应言种种用宝。不得言卖买。此戒直一往成罪。不同贩卖戒。贩卖戒。为利故买已还卖。成罪舍堕。钱宝若少应弃。若多设得同心净人。如前说。种种用宝及后贩卖戒物。要得白衣同心净人舍。不听沙弥。沙弥亦舍。畜宝戒亦尔。若种种用钱及以似宝。舍与同心净人。不入四方僧。作突吉罗忏。立木榜治者。板上书其罪过。以示同见也

    第二十事

尔时有梵志。是外道六师门徒。六师者。一师十五种教。以授弟子。为教各异。弟子受行各成异见。如是一师出十五种异见。师别有法。与弟子不同。师与弟子通为十六种。如是六师有九十六。师所用法及其将终。必授一弟子。如是师师相传。常有六师。与诸比丘结。戒者为佛法增上故为。止斗诤故为成圣种。故为长信敬故。此是共戒。比丘比丘尼俱尼萨耆波逸提。三众突吉罗。此贩卖罪。于一切波逸提中最是重者。宁作屠儿不为贩卖。何以故。屠儿正害畜生。贩卖一切欺害。不问道俗贤愚持戒毁戒。无往不欺。又常怀恶心。设若居谷。心恒希望使天下荒饿霜雹灾疫。若居盐贮积余物。意常企望四远反乱王路隔塞。夫贩卖者。有如是恶。此贩卖物。设与众僧作食。众僧不应食。若作四方僧房。不得住中。若作塔作像。不应向礼。又云。但作佛意礼。凡作持戒比丘。不应受用此物。若此比丘死。此物众僧应羯磨分。问曰。不死时不受用此物。何以死便羯磨。答曰。此贩卖业罪过深重。若生在时。众僧用食此物者。虽复犯戒有罪。僧福田中故与受用。以受用故续作不断是故僧福田中不听受用。今世无福后得重罪。以此因缘不敢更作。比丘既死。更无贩卖因故。是故听羯磨取物。或有方便有罪。果头无罪。如为利故。籴谷居盐。后得好心。即施僧作福。是名方便得突吉罗。果头无罪。或方便无罪。果头有罪。如为福故。籴米不卖。后见利故。便卖以自入。是谓方便无罪果头有罪。得突吉罗。凡如此比可以类解。是中犯者。若比丘为利故买。买已不卖突吉罗。若为利故卖已不买买亦突吉罗。若为利故买已还卖。尼萨耆波逸提。若贩卖物作食啖。口口波逸提。若作衣着。着波逸提。若作褥敷卧上转转波逸提。凡市买法。不得下价索他物。得突吉罗。众僧衣未三唱。得益价。三唱已不应益。众僧亦不应与。衣已属他故。比丘三唱得衣。不应悔。设悔众僧莫还。是贩卖物若无同心净人。应作四方僧卧具。为止诽谤。若作入佛。外道当言。瞿昙沙门多贪利故。令弟子舍物持用自入。又除佛福田。无过四方僧福田。不问受法不受法持戒毁戒法语非法语。一切无遮。若持戒比丘。若他比丘贩卖物衣食。不应食用

    第二十一事

与诸比丘结戒者。为成圣种。为增正业故。此是不共戒。比丘过十日舍堕比丘尼过一宿舍堕。式叉摩尼沙弥沙弥尼突吉罗。若畜长白铁钵瓦钵未烧一切不应量钵突吉罗。问曰。若白衣若不如法色衣。过十一日舍堕。以染作非法色故。若白铁钵若瓦钵未烧过十日。何以不得舍堕。答曰。衣钵不同。衣染则如意成色。更无增损。钵若烧若熏。或损或坏。是故不同。铁钵瓦钵若未熏未油。得用食。不成受持。钵者。三种上中下。上者受三钵他饭一钵他羹余可食物半羹。是名上钵。下者受一钵他饭半钵他羹余可食物半羹。是名下钵。上下两间。是名中钵。若大于大钵。小于小钵。不名为钵。钵他者。律师云。诸论师有种种异说。然以一义为正。谓一钵他受十五两饭。秦称三十两饭。是天竺粳米釜饭。时人咸共议计。谓上钵受三钵他饭一钵他羹余可食者半羹。三钵他饭。可秦升二升。一钵他羹余可食物半羹。是一钵他半也。复是秦升一升。上钵受秦升三升。律师云。无余可食物。直言上钵受三钵他饭一钵他羹。留食上空处。令指不触食中下钵亦除余可食物。但食上留空处。令指不触食。下钵者。受一钵他饭半钵他羹余可食物半羹。是秦升一升一升。余可食物半羹可一升半。下钵受秦一升一升半。问曰。衣若长若减。得成受持。钵若长若减。不成受持。答曰。衣设长可减可续。钵若大若小。不可增损。是故有异。是中犯者。若比丘一日得钵。即是日狂心乱心病坏心。若不见摈恶邪不除摈。如是乃至命终无罪。后若得心若解摈。即次第数日得罪。若得钵经五日。若狂心乱心病坏心。若不见摈恶邪不除摈。随几时无罪。后若得心若解摈。数前五日。后取五日成罪。若得钵日。至天上郁单越。随几时无罪。后若还至本处。次第如前说

    第二十二事

见一肆上有好瓦钵圆正可爱。律师云。佛初出世众僧无钵。佛敕释提桓因。令天巧工作十万钵。在于世间肆上钵者。是彼天钵。非是人造。此是共戒。比丘尼更乞新钵。俱尼萨耆波逸提。三众突吉罗。若乞白铁钵未烧瓦钵。若与他乞。若遣使书信印信。若二人共乞一钵若买得若自与。皆突吉罗。一切不应量钵亦突吉罗。若乞得白铁钵未烧瓦钵。自烧熏已尼萨耆波逸提。若比丘所受钵。四缀以还未可五缀。更乞新钵舍堕。若钵可应五缀。若缀未缀乞钵无犯。钵若四缀五缀以还。食已应解缀却好荡令净手拭令干举着净处。后日食前更以新绳缀已用食。若钵未满五缀。更乞新钵。此如律文。应僧中次第行。若都不取者。还与此比丘。终身令畜。前所受持钵如法受持。后钵不受。直令常畜此二钵。若食时当持二钵。终身如是。以示多欲罪过。断后恶法因缘。此钵常好爱护。如律文说。若不护故。使令破得罪

    第二十三事

为诸比丘结戒者。为除恶法故。为止诽谤故。为成圣种故。此是共戒。比丘尼俱尼萨耆波逸提。式叉摩尼沙弥沙弥尼突吉罗。是中犯者。若比丘自乞缕突吉罗。若使非亲里织师织。尼萨耆波逸提。若遣使书信印信。皆尼萨耆波逸提。以凭贵重势力故。织师畏难事必得果。是故成罪。此戒得衣已得罪。从亲里乞缕无罪。若自织令比丘比丘尼式叉摩尼织。皆突吉罗。若为无衣故。从非亲里乞缕欲作衣。亦突吉罗。若少衣正应乞衣。不应乞缕作衣。须缕缝衣作带无罪。若不凭贵人势力。自里求之织师与织者无罪。凡一切自以意求人织绢织布无罪。此戒不问应量不应量衣。尽得罪。不犯者。使亲里织。若非亲里令织一肘衣乃至禅带无犯

    第二十四事

此是共戒。比丘尼俱尼萨耆波逸提。三众突吉罗。是戒体。若非亲里居士居士妇。使织师为比丘织作衣。比丘自往劝。令如意好广致净洁织。许与食食具食直。得好衣舍堕。不得好衣突吉罗。此衣亦不问应量不应量。尽得罪。若为织师说法令好织。不与食具食直。得好衣突吉罗。若遣使书信印信。许与食具食直。得好衣舍堕。不犯者。自有缕令织师织。无罪

    第二十五事

此是共戒。若比丘尼犯。俱尼萨耆波逸提。三众突吉罗。若比丘夺比丘衣舍堕。若夺比丘尼式叉摩尼沙弥沙弥尼衣。突吉罗。若夺得戒沙弥行波利婆沙摩那埵盲瞎聋哑不见摈恶邪不除摈。尽尼萨耆波逸提。若夺狂心乱心病坏心犯四重出佛身血坏僧轮五法人尽突吉罗。若比丘尼夺比丘尼衣舍堕。夺比丘衣突吉罗。若夺得戒沙弥尼衣行波利婆沙盲瞎聋哑比丘尼衣舍堕。不见摈恶邪不除摈亦舍堕。余如前说。此戒体。比丘先根本与他衣。后为恼故。暂还夺取舍堕。衣舍还他。波逸提忏。若先根本以与他衣。后根本夺。应计钱成罪。若先暂与他衣。后便夺取无罪。若和上为折伏弟子令离恶法故。暂夺衣取无罪。若夺衣已。二人俱出界不失衣。若夺衣比丘持衣出界。若失衣比丘自出界宿是则失衣。尼萨耆波逸提者。是衣直舍还他。不须僧中。律师云。胡本无僧中舍法。波逸提罪对手悔过。律师云。比丘尼从佛出世至今。无得戒沙弥尼。况有犯罪。一念不覆藏者。亦与学法。又云。佛在世时。时有一人与学法。佛灭度后。罽宾有一得戒沙弥。凡有二人俱得漏尽。又云。得戒沙弥众不作恶。更起异见入外道法中。亦不乐俗返戒还家。无有不见圣谛而取命终。比丘本不与他衣。以忿恚故欲令彼恼。强以力势暂夺彼衣。突吉罗

    第二十六事

此是不共戒。余四众尽无此戒

尔时长老毗呵。秦言断也。已断一切生死烦恼。故曰断也。虽一切罗汉皆得漏尽。而本立名。各有因缘。是故不同。毗呵比丘有好僧伽梨直十万钱。时有群贼欲劫其衣。到比丘房前以手指户。即问。何人。贼答。比丘。我等欲得汝僧伽梨。比丘以僧伽梨着向中入四禅。力持令不得。诸贼种种方便不能得衣。即便相谓。今既叵得。当共伺求乞食不在。必可如意。即如其计后来不在。即持衣去。以是因缘失僧伽梨。夏三月过有闰。未满八月者。前安居已过。有闰者。律师云。不应言有闰也。未满八月者。云后安居。始过七月十五日。未满八月。从七月十六日次第六夜。听阿练若安居比丘处离衣宿。所以听者。云外国贼盗有时。此六夜中间是贼发时。是故听也。此衣应寄众僧界内。若白衣舍无贼难处。至第六夜应还取衣。若往衣所。若受余衣。若不取来。若不至衣所。不受余衣。至第七日地了时。尼萨耆波逸提。阿练若处者。去聚落五百弓。名阿练若处。胡步四百步一百弓。胡步者。以一搩为一步。如是四百步一百弓。四百弓一拘屡舍。四拘屡舍一由旬。云一拘屡舍者。四百弓。摩竭国一拘屡舍。于北方半拘屡舍。中国地平。是故近也。北方山陵高下。是故远耳。又云。中国多风。远则不闻鼓声。近则闻之。是故近耳。北方少风远闻鼓声。是故远也。所以南北有远近者。以闻鼓声有远近故。云拘屡舍者。是声名也。凡言鼓声所及处是一拘屡舍。律师云。此是定义

    第二十七事

此是共戒。比丘尼俱尼萨耆波逸提。式叉摩尼沙弥沙弥尼突吉罗。十日未至自恣者。自恣余有十日在得急施衣者。若王施。若夫人施。若王子施。大官斗将施众僧。有信乐心。以物施僧。以诸贵人善心难得。又难可数见。或有余急因缘。是故名急施衣。若不受者。前人功德不成。众僧失衣。是故听受。若女欲嫁时以至婿家。不自在故。今得自在。以物施僧。若病人施。以善心故。以物施僧。令存亡有益。如是等比。尽名急施衣。众僧得衣。即随次分之。乃至衣时应畜者。从七月十六日至八月十五日。若无功德衣。齐是名衣时。此一月所以名衣时。以夏安居竟檀越多致饮食衣服供养众僧。兼诸比丘种种执作浣染衣服。以是因缘。此一月内有所放舍故。名为衣时。若有功德衣从八月十六日至腊月十五日。名衣时。是中犯者。若无功德衣。至八月十五日。是衣应舍。若作净若受持。若不舍不作净不受持。至八月十六日地了时。尼萨耆波逸提。若有功德衣。至腊月十五日。是衣应舍。若作净若受持。若不舍不作净不受持。至腊月十六日地了时舍堕。除十日急施衣。一切安居衣。必待自恣时分。若安居中分。突吉罗

萨婆多毗尼毗婆沙卷第五萨婆多毗尼毗婆沙卷第六

        失译人名今附秦录

    第二十八事

此是不共戒。比丘得畜雨衣。比丘尼得畜浴衣。不得畜雨衣。以尼弱劣担持为难。是故不听畜雨浴衣。畜雨浴衣凡有二事。天雨时以障四边于中澡浴。若天热时亦以自障于中澡浴。二以夏月多雨常裹三衣担持行来。沙弥沙弥尼式叉摩尼不听畜。春残一月应求雨衣。半月应畜者。从三月十六日至四月十五日。是春残一月。从三月十六日至三月尽。应求应作。若得成衣。从四月一日至十五日应畜。畜法者。得用浴担持行来。若不成衣乃至四月十五日听求听作。设三月十六日求衣。至十八日十九日成衣者。律师云。亦得畜用察其意制。此一月内得求得畜。而大制半月应求半月应畜。若前安居。至四月十五日应如法受持。到七月十五日。应着一处不应畜用。若畜用者突吉罗。亦不须舍至来年安居时。如前畜用不须更受。若后安居。从四月一日至五月十五日。四十五日畜。至七月十五日。应举一处不应畜用次第如前安居法。若闰三月。比丘不应前三月求作雨衣。应后三月十六日应求作雨衣。若比丘先不知有闰。前三月十六日求作雨浴衣已竟。于其中间长。一月内不得畜用。应举一处。此是百一物中一事。不须与人。不须作净。若闰四月。前四月十六日安居。即日应受持雨衣。至七月十五日。于其中间百二十日常得畜以夏有闰多雨热故。过半月畜舍堕者。律师云。诸论师谓闰三月于前三月十六日求作雨衣。至三月尽作衣已竟。至后三衣便受用。至后三月尽从受来。尼萨耆波逸提。求来作来突吉罗。是名过半月畜。是衣应舍。波逸提罪忏忏悔过已。从四月一日便畜用。至四月十五日。无过四月十六日。受持次第如前法。过半月衣从求作衣来突吉罗。于闰一月中畜一尼萨耆波逸提。设未舍衣未悔过。从四月一日至七月十五日中间。更不得罪。若无闰处。比丘求雨浴衣往有闰处安居。是人从求衣来作衣来。皆突吉罗。受持衣来舍堕。有闰者。闰三月无闰处比丘。从三月十六日求雨浴衣于有闰处是前三月。比丘于无闰处得雨浴衣已。至有闰处。始入后三月。于其中间长一月。未至求衣时。以非求衣时故。从求作来突吉罗。过半月畜故。从畜用来尼萨耆波逸提。以先有心故。比丘不畜雨浴衣无罪。雨衣至四月十六日。能受亦可不受无过

    第二十九事

此是共戒。比丘尼俱尼萨耆波逸提。三众突吉罗。此戒体。若物向僧。与前人说法令物自入舍堕。物则还僧向三二一比丘突吉罗。若比丘知是物向比丘尼僧。自求向已舍堕。向三二一突吉罗。若比丘知檀越以物施僧。回向彼塔。物即入彼塔。不须还取。以福同故。比丘作突吉罗忏。若比丘知檀越以物施此僧者。回向余僧者。物入此余僧者。不须还取。以僧者同故。比丘作突吉罗忏。若比丘知檀越以自恣腊与此众僧。回向余僧。自恣物应还与此僧。以自恣物所属异故。比丘作突吉罗忏。若不还此僧。计钱成罪。面门腊亦如是。若比丘知物向一人。回向余人。应还取。此物已归此物主。作突吉罗。忏若不还彼物。计钱成罪

    第三十事

此是共戒。比丘尼俱尼萨耆波逸提。毕陵迦婆蹉弟子。有残不净酥油蜜石蜜。残宿而食。恶捉不受内宿。佛先但制五正食似食。未制七日药。凡不受内宿等。尽是先作也此戒体。若病比丘须七日药。自无净人求倩难得。应自从净人手受。从比丘口受已。随着一处。七日内自取而食。若病重口不受亦得服。设看病比丘手受口受。亦成受法。设受已净人若触更受。若即日受。若以不受药堕中。应还更受。若受药已经二日三日。有药入中。应还更受。更从一日作始次第七日。若药众多。不知何者是受何者不受。应更手受口受然后服之。若六日七日异病比丘。不得复受药经七日。此药至七日。此药应作净若与人若服。若不作净不与人不服。至八日地了时。尼萨耆波逸提。若不病人七日药得。于净人边作净已。得共一处随时受食。若自受已经宿取食。犯残宿食戒。作波逸提忏。此四种药。日中后一切时食无过。若以时药终身药。助成七日药。作七日药服无过。以七日药势力多故。又助成七日药故。如以酥煮肉。此酥肉汁得作。七日药服。如石蜜或时药。或以终身药已成石蜜。得作七日药服。如是或以时药或七日药。以成终身药。作终身药服无过。或以终身药。或以七日药。以成时药。作时药服。随势力多故。相助成故。若分数势力等者。随名取定。如石蜜丸。虽势力等以名定作七日药服。如五石散。随石作名。作终身药服。如是若势力多者。随力作名。若力等者。随名定药。三十事竟

    九十事初戒

此是共戒。比丘尼俱波逸提。三众突吉罗。或有妄语入波罗夷。实无过人法。说有过人法故。或有妄语。入僧伽婆尸沙。以无根法。谤他比丘故。或有妄语。入偷兰遮。如说过人法不满。以无根法谤他不满。或有妄语。入波逸提。如无根僧。残谤他故。如此九十事中种种妄语。是谓妄语入波逸提。或有妄语入突吉罗。如三众妄语。或有妄语无罪。如先作如在家无师僧本破戒还作比丘。或有七事以成妄语。一先作妄语意。二发口妄语。三妄语已说是妄语。四异见。五异欲六异忍。七异知。复有四事以成妄语。一异见后三事如前或有三事以成妄语。一先作妄语意。二设言妄语。三妄语已说是妄语。若比丘不见事言见。波逸提。若见言不见。若见谓不见。语他言见。若不见谓见。语他言不见。若见已疑。为见不见。语他言不见。若不见疑。为见不见。语他言见。以是心想故。皆波逸提。闻觉知亦如是。一切随心想说无犯。见闻觉知。以眼为见。以耳为闻。鼻舌身为觉。意根为知。以三根性利力用偏多。各分为名。三根性钝。力用处少。总名为觉。复次三根能远取境界各分为名。三根近取境界。故合为名。若使妄语。若书信妄语。尽突吉罗。若先无心妄语。误乱失口妄语。尽突吉罗。若说法义论。若传人语。若凡说一切是非。莫自摄为是。常令推寄有本。则无过也。若狂心乱心病坏心无犯。或有妄语不两舌者。如旋风土鬼来至我所。自言持戒清净淫欲不起。如自称过人法。前人不闻不受。重偷兰。若欲以无根法谤他。先向同意说。某甲比丘犯如是罪。与我相助。重偷兰。如破僧相助僧残。未满者偷兰

    九十事第二

此是共戒。比丘尼俱波逸提。三众突吉罗。说本生因缘者。一以证轻毁过罪故。二息诽谤故。若不说本生。外道当言。瞿昙沙门无宿命通。三以成十二部经故。此是本生也。佛用愿智以知过去。问曰。愿智宿命智有何差别。答曰。宿命智知过去。愿智知三世。宿命智知有漏。愿智二俱兼知。宿命智知自身过去。愿智自他兼知。宿命智一身二身次第得知。愿智一念超知百劫。古时畜生所以能语。今时畜生所以不语。谓劫初时先有人天未有三恶。初有三恶。尽从人天中来。以宿习近故。是以能语。今时畜生。多从三恶道中来。是以不语。是中犯者。有八种。谓一种姓二伎三作四犯五病六想七烦恼八骂。以此八种轻比丘者。若以种伎作三事。轻毁刹利婆罗门估客子三种人者突吉罗。以此三事轻毁余人者尽波逸提。以余五事轻毁刹利乃至栴陀罗波逸提。若以八事现前轻毁波逸提。屏处轻毁突吉罗。若以八事轻毁比丘尼突吉罗。以此八事轻毁三众突吉罗。以此八事。轻毁狂心乱心病坏心在家无师僧越济人一切在家人聋人。尽突吉罗。六罪人亦突吉罗。若前人有此八事轻毁者波逸提。若无八事但为恼故轻毁突吉罗。若遣使书信突吉罗。若以八事轻毁言。汝有此八事。皆不应出家法。如是语故波逸提。若直以八事轻毁突吉罗。除此八事以余轻毁者。设言。汝多食多眠多谈语。用出家受戒为。突吉罗。此戒体。若闻者波逸提。不闻者突吉罗。凡设有先出家而后癞病者。一切僧事故得共作。若食时莫令坐众中

    九十事第三

此是共戒。比丘尼俱波逸提。三众突吉罗。是中犯者。有八种。一种二伎三作四犯五病六想七烦恼八骂。是八事皆用五事。如是名如是性如是种如是作如是相。此八事中三事种伎作。传向刹利婆罗门估客子比丘。突吉罗。以此三事传向余比丘波逸提。若以五事传向一比丘波逸提。若以八事传向四众突吉罗。传向在家无师僧。若遣使书信。狂心乱心病坏心聋越济人六罪人一切在家人。尽突吉罗。以五事者。若比丘传此比丘语向彼比丘说。乃至言。彼说汝是恶骂人用出家受戒为。即问。彼是谁耶。答言。某姓。某姓是谁。答言。某种。某种是谁。答言。某作。某作是谁。答言。某相。若彼闻者波逸提。不闻突吉罗。所以次第五种者。以同名同姓等多故。宜次第定之。或有两舌。非妄语非恶口。如一比丘传此比丘语向彼说。当实说故非妄语。软语说故非恶口。以分离心故名两舌。或有两舌。是妄语非恶口。如一比丘传此比丘语向彼比丘说。以别离心故是两舌。以妄说故是妄语。以软语说故非恶口。或两舌是恶口非妄语。如一比丘传此比丘语向彼比丘说。以别离心故是两舌。以粗语说故是恶口。当实说故非妄语。或有两舌。是妄语是恶口。如一比丘传此比丘语向彼比丘说。以别离心故是两舌。以妄说故是妄语。以恶声说故是恶口。妄语恶口作四句亦如是。如是解已更说波逸提突吉罗。解者。应言闻已更说。若闻者波逸提。不闻突吉罗。二种骂突吉罗。在家人骂者。说俗中种种不清净。出家人骂者。直说出家中不如法事除此八事更以余事者。云汝是多眠多食人戏笑人。用出家受戒为。突吉罗。若言汝欺诳人多情诈人。如是传向比丘者。闻则突吉罗。不闻亦突吉罗。若不传彼此语。但二边说令离散者突吉罗

    九十事第四

此是共戒。比丘尼俱波逸提。三众突吉罗。是人有五种。一者旧人。二者客人。三者受欲人。四者说羯磨人。五者见羯磨人。是中犯者。若旧比丘。于相言诤中相言诤想。如法灭已如法灭想。还更发起波逸提。相言诤中相助诤想。如法灭已如法灭想。还更发起波逸提。相言诤中犯罪诤想常所行诤想亦如是。如相言诤有四句。相助诤犯罪诤常所行诤亦各有四句。凡十六句。此诸句中各得波逸提。如旧比丘于四诤中作十六句。客人受欲人说羯磨人见羯磨人。亦于四诤中各有十六句。凡五人八十句。一一句中各得波逸提。若旧比丘。于相言诤中如法灭已如法灭想。还更发起波逸提。如法灭中不如法灭想。还更发起波逸提。如法灭。中生疑。还更发起波逸提。如相言诤有三句。句句中得波逸提。相助诤犯罪诤常所行诤。亦各有三句。有十二句。如旧比丘。客比丘受欲。比丘说羯磨比丘见羯磨比丘。亦各十二句。凡六十句。一一句中波逸提。若旧比丘。于相言诤法不如法灭想。还更发起突吉罗。如法灭诤中生疑。还更发起突吉罗。如相言诤有二句。余三诤亦各有二句。凡八句。余四人亦有八句。凡四十句。一一句中突吉罗。若旧比丘。于相言诤法。不如法灭中不如法灭想。还更发起不犯。如相言诤作一句。余三诤亦各有一句。如旧比丘于四诤中各作四句。余四比丘亦各有四句。凡二十句。一一句中不犯。此戒体。不问羯磨不羯磨。但僧和合如法作已。后还发起。不问众中屏处。尽波逸提。若是僧制不入佛法。还更发起突吉罗。若非佛法非僧法。人和合作已。作非法心。还更发起无罪。除五种人。外来与欲比丘尽同

    九十事第五

此是不共戒。比丘尼与男子说法。过五六语。突吉罗。二男子不犯。式叉摩尼沙弥尼亦突吉罗。沙弥与女人说法过五六语。亦突吉罗。女者。能受淫欲者。若石女若小女未堪任作淫欲者突吉罗。五六语者。五种语名。色阴无常受想行识无常。此五语无犯。若过五语波逸提。六语名。眼无常耳鼻身意无常。是名五六语。若过五六语波逸提。有智男子者。谓解人情语言意趣向。可作证明者。要是相解语言。若方类不同者一切不听。男子必是白衣。一切出家人亦不得。以事同故。正使众僧集会。若有女人若多若少。无有智男子。不得为说。得为尼说法。一切尼众。以教诫法故无过。若比丘以为女人说法过五六语波逸提。即先坐处无有智男子。更有异女人来复为说法。先女人亦在中坐二俱闻法。设说法已从坐起去。道中更为异女人说法。先女人亦俱闻法。若为女人说法过五六语已。入余处更为女人说法。先女人亦在壁立听。若在余屏处听。二俱闻法。此三处说法。皆于先女人边得罪。先女人已过五六语。后为余女人说法。亦同闻法。以先因缘故。若初语时。语语波逸提。若不知前女人在中者不犯。若经说。事事波逸提。若偈说。偈偈波逸提。偈者。三十二字。或三十字。或二十字。若转经者。亦事事波逸提。不犯者。若说布施福报咒愿。若问而答。若受五戒八戒。若呗若说世间常事突吉罗

    九十事第六

此是共戒。比丘尼俱波逸提。三众突吉罗。为诸比丘结戒者。为异外道故。为师与弟子差别故。为分别言语令分了故。为依实义不贵音声故。未受具戒人者。除比丘比丘尼余一切人。是此戒体。以句法教未受具戒人得罪。句法有二种。一足句。二不足句。足句者。律师云。同句。若师诵长句。弟子亦诵长句。是名同句。是中犯者。若师随声高下诵长句授弟子。弟子与师齐声诵长句者。得波逸提。若诵短句齐声同诵波逸提。若师诵长句弟子诵短句。若齐声者突吉罗。若师诵短句弟子诵长句。齐声诵者突吉罗。不犯者。若师诵已弟子后诵。不令声合。不问同与不同句。一切不犯。义正在同句齐声。得波逸提。若句不同齐声者突吉罗。但令声有前后。一切无犯。若二人俱经利并诵无犯。不得合呗。若比丘无处受诵。乃至得从沙弥尼受法。但求好持戒重德人。作伴证明耳。亦得从白衣受法。但不得称阿阇梨。如是展转皆得受法。但消息令不失威仪。足味不足味足字不足字亦如是。若以同句教具戒人突吉罗。若师诵长句弟子误受短句突吉罗

    九十事第七

此是共戒。比丘尼俱波逸提。三众突吉罗。若为利养故向具戒人说者亦波逸提。与比丘结戒者。为大人法故。若称德行覆藏过罪。是小人法为平等法故若自称圣德则贤愚各异前人于众僧无平等心。颇有向未受具戒人说过人法无犯耶。答曰有。若向知识同心无外。不为名利而为说者无犯。若遇贼难畏失夭命故语言。汝若杀我得大重罪若为病故。无人看视得语前人若看我者得大福德。如是等因缘说则无罪以人身难得故。是故无过。未受大戒人者。除比丘比丘尼余一切人。是实有者。实有过人法。若比丘实得四向四果。向未受具戒人说者波逸提。若实得四禅四无量心四无色定五神通不净观阿那波那。向他人说波逸提。问曰。不净观阿那波那。是近小法。何以名过人法。答曰。此是入甘露初门。一切贤圣莫不由之。是故名过人法。乃至为名利故。言我清净持戒。突吉罗。若说天龙鬼神来至我所。为名利故波逸提。若言旋风土鬼来至我所。为名利故突吉罗。若实诵三藏。为名利故向人说者突吉罗随所诵经随所解义随能问答。为名利故。向人说者突吉罗

    九十事第八

此是共戒。比丘尼俱波逸提。三众不犯。与诸比丘结戒者。为大护佛法故。若向白衣说比丘罪恶。则前人于佛法中无信敬心。宁破塔坏像。不向未受具戒人说比丘过恶。若说过罪则破法身故。除僧羯磨者。凡羯磨者二种。如律文说。若向未受具戒人。说比丘粗罪者。波罗夷僧残。向未受具戒人。说二篇罪名。波逸提。说罪事突吉罗。若说下三篇罪名突吉罗。说罪事亦突吉罗。不问前比丘有罪无罪。向未受具戒人说其粗罪。尽波逸提。若说四众罪突吉罗。若遣使书信印信亦突吉罗。若说出佛身血坏僧轮。对首偷兰遮。若说四事边十三事边。一切偷兰遮突吉罗。若说四众粗罪突吉罗。若比丘见余比丘犯波罗夷者。见比丘与女人说过人法。谓为波罗夷。云何波罗夷谓僧残邪。见比丘与女人说过人法。谓与女人作恶语。是名于波罗夷谓僧残。云何谓波逸提。见比丘与女人说过人法。谓与女人过五六语。云何谓波罗提提舍尼。见比丘与女人说过人法。谓从女人精舍内受饮食。云何谓突吉罗。见比丘与女人说过人法。谓语女人汝盲汝瞎。若比丘见余比丘与女人恶口语。是名僧残。云何于僧残谓波逸提。见比丘与女人恶口语。谓过五六语。是谓于僧残谓波逸提。云何谓波罗提提舍尼。见比丘与女人恶口语。谓从女人精舍内受饮食。云何谓突吉罗。见比丘与女人恶口语。谓语女人汝盲汝瞎。云何谓波罗夷。见比丘与女人恶口语。谓说过人法。若比丘见比丘与女人过五六语。是谓波逸提。云何谓波罗提提舍尼。若见比丘与女人过五六语。谓从女人精舍内受饮食。云何谓突吉罗若比丘与女人过五六语。谓语女人此黑此白。云何谓波罗夷。若与女人过五六语。谓说过人法。云何谓僧残。若见比丘与女人过五六语。谓与女人恶口语。若见比丘从女人精舍内受饮食。是名波罗提提舍尼。云何谓突吉罗。见比丘从女人精舍内受饮食。谓语女人此盲此瞎。云何谓波罗夷。见比丘从女人精舍内受饮食。谓说过人法。云何谓僧残。见比丘从女人精舍内受饮食。谓与女人作恶口语。云何谓波逸提。见比丘从女人精舍内受饮食。谓与女人过五六语。若见比丘语女人此白此黑。是谓突吉罗。云何谓波罗夷。见比丘语女人此盲此瞎。谓说过人法。云何谓僧残见比丘语女人此盲此瞎。谓与女人作恶语。云何谓波逸提。见比丘语女人此盲此瞎。谓与女人过五六语。云何谓波罗提提舍尼。见比丘语女人此盲此瞎。谓从女人精舍内受饮食。若比丘见余比丘犯波罗夷生疑。为波罗夷为非波罗夷。如见比丘共女人作淫。谓为故出精。谓为石女。后便断疑。于波罗夷中定生波罗夷想。问曰。何由断疑。答曰。遇善知识故断疑。遇善知识。能断不善法。能灭邪法。能断不定法。若见比丘犯僧残生疑。见与女人赤体相抱。疑为赤体为合衣。为石女为非石女。若比丘犯与女人过五六语。疑为过五六语为不过。为石女为非石女。若比丘见比丘学家中取食。疑为作羯磨。若未作羯磨。若比丘见余比丘语女人此盲此瞎生疑。为言此盲此瞎。为说余事

    九十事第九

与诸比丘结戒者。为灭斗诤故。为灭苦恼故。为得安乐行道故。此是共戒。比丘尼俱波逸提。三众突吉罗。此戒体。若僧和合作羯磨不作羯磨。与知事执劳苦人。若僧祈物若自恣物。和合与已后便呵言。随亲厚与波逸提。凡众僧中。若为僧执劳苦人。若大德及贫匮者。若僧和合与。尽得与之。若与欲和合后呵者波逸提。若在外来呵者突吉罗。此戒不必言随亲厚与。但言不应与尽犯

    九十事第十

此是共戒。三众不犯。阐那者。是佛异母弟。优填王妹儿。俱舍毗国是阐那所生处。白净王安处宫室也。拘舍弥国安一宫室也。阐那母常在此中。有一姝亦适此国。以是因缘阐那多住此国。又以此中利益众生多故。多住此国。与诸比丘结戒者。为尊重波罗提木叉故。为长养戒故。为灭恶法故。阐那以十二年前佛常说一偈。今说五篇名为杂碎。是中犯者。若说四波罗夷呵者。若说一戒呵言。何用说是淫戒为。得一波逸提。若呵事者四波逸提。若四通呵者一波逸提。若说戒序时呵者得一波逸提。问曰。戒序非戒何以得罪耶。答曰。戒序说二百五十戒义。若呵戒序即是呵一切戒。是故得罪。如是次第十三事二不定三十事九十事四悔过众学法有百八事。若一一呵百八波逸提。若通呵一波逸提。七灭诤亦尔。若说随律经呵者亦波逸提。若凡经中有随律经时说呵者。尽波逸提。除随律经。说余经时随多随少呵者。尽突吉罗。问曰何以说呵戒。随律经等罪重。余经罪轻。答曰。戒是佛法之平地万善由之生。又戒一切佛弟子皆依而往。若无戒者则无所依。一切众生由戒而有。又戒入佛法之初门。若无戒者则无由入泥洹城也。又戒是佛法之璎珞。庄严佛法。是故罪重

    九十事第十一

此戒二缘合结一戒。初缘拔寺中草。第二缘斫大卑跋罗树破鬼神村。是树神后夜时。往诣佛所头面礼佛足一面立。问曰。鬼神何以夜至佛所。答曰。佛在世时。夜时多为天龙鬼神说法。昼多为人说法。所以尔者。人若见诸鬼神则生怖畏。是以昼夜各异。一面立者。诸神于佛爱敬心重故有所请求故。有为诸神多乐清净。地不净故。以是种种因缘。所以不坐。冬八夜时寒风破竹。炎天竺冬末八夜春初八夜。是盛冬时。所以尔者。寒势将尽必先盛后衰。又云。以日下近地故。热势微少。是故寒甚。所以独言破竹者。以竹最坚尚破。况余木耶。又云。竹性法热冬夏常青。寒甚故破。何况余木。与诸比丘结戒者。为不恼众生故。为止诽谤故。为大护佛法故。凡有三戒。大利益佛法在余诵。一不得担。二不杀草木。三不掘地。若不制三戒。一切国王当使比丘种种作役。有此三戒。帝主国王一切息心。此是共戒。比丘尼俱波逸提。三众是净人故不犯。有五种子。根种子。茎种子。节种子。自落种子。实种子。根种子者。谓故萝卜芜菁根。如是等根生者。茎种子者。谓安石榴葡萄杨柳。如是等茎生者。节种子者。甘蔗粗竹细竹。如是等节生者。自落种子者。谓蓼蓝罗勒胡荽橘梨。如是等自落生者。实种子者。稻麻麦大豆小豆粟[序-予+禾]等此。皆是实种子。若比丘五种子中。自断教断自破教破自烧教烧。皆波逸提。教他者。教比丘比丘尼得波逸提。若教三众突吉罗。若一时烧五种子者。一波逸提。若一一烧随所多少。一一波逸提。若摘树叶若一一摘。一一波逸提。若一下断树。一波逸提。如是等比。以类可解。凡净生果生菜。若合子食。是五种子者一切火净。若不合子食。设果菜非五种子。但刀爪净一切得食。律师云。一切果若合子食应火净。若不合子食。一切时得食。不须刀爪净而食。佛自说。生果菜不问有种子无种子。要须净而食。不净果若合子吞咽突吉罗。若啮破波逸提

    九十事第十二

此是共戒。比丘尼俱波逸提。三众突吉罗。此戒体。僧先差十四人。嗔讥是人者波逸提。凡差十四人。若羯磨若不羯磨。二俱无过。若十四人未舍羯磨。嗔讥是人者波逸提。若舍羯磨嗔讥是人突吉罗。乃至别房乃同事差作知食人。嗔讥是人突吉罗。遥嗔讥十四人。若闻者波逸提。不闻者突吉罗。遥嗔讥者。不在面前言音足相关了。若遣使书信突吉罗

    九十事第十三

此是共戒。此戒有二忆识羯磨。不随问答恼他。作忆识羯磨。作忆识羯磨已。不随问答恼他波逸提。未作羯磨不随问答恼他突吉罗。二默然恼他故作忆识羯磨。作忆识羯磨已默然恼他波逸提。未作羯磨默然恼他突吉罗。五篇戒中有三戒。二结已合作一戒。如四事中淫戒。一以共人行淫结戒。二以共畜生行淫结戒。此九十事中有二戒。二结合作一戒。如前嗔讥戒。初以嗔讥陀骠差会故。是一结也。后不现前嗔讥。便遥嗔讥。复更结戒。是二结也。虽前后二结。故是一嗔讥戒。此不随问答戒亦二结也。初以不随问答。因以结戒。是一也。二以默然恼他。是二结也。虽是二结。故是一不随问答恼他戒也。忆识法者。一切五众尽与忆识。问曰。此忆识者。是现前不现前。答曰。比丘比丘尼现前。三众不现前。要在界内。如学家羯磨亦在界内。覆钵羯磨不现前。三众亦尔不现前。作羯磨已。若舍戒沙弥即先羯磨。若返戒还俗后作比丘。即本羯磨。若根变作尼即本羯磨。若尼根变亦如是。亦得作布萨自恣。百一羯磨一切尽得作。僧祈自恣面门腊一切尽同。得授他经法。亦得从他受经法。尽无碍也。不得作和上依止畜沙弥。不舍羯磨得受具戒。不随问答戒体。必是比丘共说波罗提木叉。为恼故不随问答波逸提。若尼三众问戒中事。不随问答突吉罗。若问余经法事。不随问答突吉罗。若出所犯罪。得解羯磨。六法尼根变作沙弥。沙弥尼根变作沙弥

    九十事第十四

此是共戒。比丘尼俱波逸提。三众突吉罗。与诸比丘结戒。为行道安乐故。为长养信敬。为令檀越善根成就故。僧卧具者。粗细绳床木床种种被褥枕。露地者。无覆障处。是中犯者。凡有二时。一地了时。二日没时。若比丘初夜初分。露地敷僧卧具。在中若坐若卧。去时不自举不教人举。至地了时波夜提。乃至地了时敷僧卧具。不自举不教人举。至地了竟波逸提。地了时若露地敷僧卧具。在中若坐若卧。去入室休息。至日没时波逸提。若日没时露地敷僧卧具。入室休息。至日没竟波逸提。若露地数僧卧具已。出寺过四十九步地了波逸提。若露地敷僧卧具已。不嘱人游行诸房突吉罗。若自卧具者不随时举突吉罗。若敷露地所以时举者。一畏雨湿。二畏日曝。三畏风吹。以守护故应举覆处。若露地敷僧卧具。不问出寺不出寺。至地了时波逸提。若虽有覆障。而日雨所及皆波逸提。若敷僧卧具出寺外不问远近。至地未了日未没突吉罗

    九十事第十五

此是共戒。比丘尼俱波逸提。三众突吉罗。是中犯者。若客比丘房中敷僧卧具出界去波逸提。若旧比丘房中敷僧卧具出界去。作是念。即当还。有急因缘不得即还。出界至地了时突吉罗。卧具者。粗细绳床木床被褥毡。敷者。若房内敷僧卧具。出寺若近若远皆应付嘱。若不付嘱。应自卷亵举之。付嘱次第法尽在律文。好持戒大沙弥亦得付嘱之。若客比丘房内敷卧具出界。期还至地了时突吉罗。若不期还。出界至地了时波逸提。若旧比丘敷卧具竟出界。不期还。至地了时波逸提

    九十事第十六

此是共戒。三众突吉罗。与诸比丘结戒者。为不苦恼众生故。为灭斗诤故。是中犯者。若比丘嗔不喜。手自牵出从床上至地。波逸提。乃至从土埵上至地。亦波逸提。要必力能牵者波逸提。力不能者突吉罗。若使他牵者。比丘比丘尼式叉摩尼沙弥沙弥尼。乃至白衣牵比丘者波逸提。若使比丘能牵者。二俱波逸提。不能者二俱突吉罗。教余能牵者波逸提。若不能突吉罗。若牵比丘尼三众突吉罗。若牵聋盲瞎哑得戒沙弥波利婆沙摩那埵波逸提。在家无师僧本破戒比丘还出家受戒越济人六罪人五法人突吉罗。白衣无罪。除因缘者。若房坏诸难房中牵出。不犯波罗夷。先作杀心强牵出死者波罗夷。不死者偷兰遮。若牵比丘尼淫乱心牵摩捉者僧残。若嗔恨心牵比丘尼能者波逸提。不能突吉罗。若尼牵比丘波逸提。若比丘在僧祈房中。若在尼房中牵尼突吉罗。若尼在僧祈房中牵比丘者波逸提。若尼房中牵比丘突吉罗

    九十事第十七

此是共戒。比丘尼俱波逸提。三众突吉罗。是中犯者。若比丘知比丘房中先敷卧具竟。后来于坐床前若卧床前。若房内房外行处高处土埵前。如是一一处。若自敷若使人敷。能敷者波逸提不能敷者突吉罗。此戒体。正戒不得强违前人意有所为作。若为恼他故。闭户开户闭向开向。然火灭火然灯灭灯。若呗咒愿读经说法问难。随他所不乐事作。一一波逸提。必以恼他心故成罪

    九十事第十八

此是共戒。比丘尼俱波逸提。三众突吉罗。是中犯者。若卧床若坐禅床。若一脚尖三脚不尖。若二脚尖二脚不尖。若三脚尖一脚不尖。若四脚尖。在重阁上随用力坐卧。一一波逸提。若用一切软物搘床脚不犯。若用塼石瓦等物。能伤人者用。以搘床脚波逸提。若重阁上安床处牢厚不穿漏者不犯。若床脚不尖者不犯。设尖不用力坐卧不犯。此戒体。必是重阁尖脚坐床。安床处底薄用力坐卧波逸提。凡比丘坐卧法。一切审详。不审详必有所伤。兼坏威仪突吉罗

    九十事第十九

此是共戒。比丘尼俱波逸提。三众突吉罗。凡杀生有三种。有贪毛角皮肉而杀众生。有怨憎恚害而杀众生。有无所贪利有无嗔害而杀众生。是名愚痴而杀众生。如阐那用有虫水。是谓痴杀众生。此杀生戒凡有四戒。于四戒中。此戒最是先结。既结不得用有虫水浇草土和泥。便取有虫水饮。既不得用一切有虫水。便故夺畜生命。既制不得夺畜生命。便夺人命。凡夺物命有四结戒。以事异故尽名先作。是中犯者。若比丘取有虫水浇草上和泥。随用水多少。用用波逸提。若欲作住止处。法先应看水。用上细叠一肘作漉水囊。令持戒审悉者漉水竟。着器中向日谛看。若故有虫者。应二重作漉水囊。若三重作漉水囊。故有虫者。此处不应住

萨婆多毗尼毗婆沙卷第六萨婆多毗尼毗婆沙卷第七

        失译人名今附秦录

    九十事第二十

此是不共戒。尼突吉罗。三众突吉罗。阐那作房。即日成即崩倒。作此大房。用三十万钱。功用甚大。诸比丘为檀越说法。房虽崩倒功德成就。房未坏时。佛已到此房中。即是受用。佛是无上福田。佛既受用。功德深广不可测量。又云。房始成时。有一新受戒年少比丘。戒德清净。入此房中以杨枝猗房。以此一持戒比丘。已毕檀越信施之德。若起亿数种种房阁种种庄严。下至金刚地际高广严饰。犹若须弥。设有一净戒比丘。暂时受用。已毕施恩。何以故。佛于无量劫中修菩萨行。今得成佛道。始体解波罗提木叉。以授众生。波罗提木叉非世间法。是背离世俗向泥洹门。凡房舍卧具饮食汤药。是世间法。非是离世难得之法。是故一净戒比丘。若暂受用已毕施恩。若作僧新房舍及以塔像。旷路作井及作桥梁。此人功德一切时生。除三因缘。一前时事毁坏。二此人若死。三若起恶邪。无此三因缘者。福德常生。佛先已入此房中。上下重往返经行。令檀越施功德不空。佛以神力。感诸弟子与檀越次第说法凡作房法。有三品上中下。覆房法。各自有限。若下房以中上房覆法者。以珍重故。兼顿成故。若用草覆。草草波逸提。若中房以上房覆法者。亦以珍重故。若用草覆。草草波逸提。若随上中下覆法者。以顿成故。房成已一波逸提。若不顿垒墙成无罪

    九十事第二十一

僧不差教比丘尼戒初缘。尔时佛告诸比丘。我教化四众疲极。问曰。佛得那罗延身。身无疲极。得十力四无所畏大慈大悲。心无疲极何以言疲极耶。答曰。佛无疲极。随世俗法故。如父知子。堪理家事。虽自有力以儿堪任故。欲以事业委付儿故。云我气衰耄家事汝一切知之。佛亦如是。虽不疲极。欲以教法以授弟子。随世法故说言疲极。所以令诸弟子教诫尼者。一以现无吝法故。二师与弟子知见同故。三欲现槃特比丘功德智慧故。四为诸比丘于尼众各有因缘。应受教化故

    九十事第二十二

难陀者。更有难陀。非佛弟难陀。往昔维卫佛出现于世。为众生说法。彼佛灭后有王。起牛头栴檀塔。种种庄严。此王有五百夫人供养此塔。各发愿言。愿我等将来从此王边而得解脱。尔时王者。今难陀是。尔时五百夫人者。今五百尼是。以是本愿因缘故。应从难陀而得解脱

此中次第三戒已舍。羯磨教尼人故。三戒亦舍。设为尼说法时至日没者。以坏威仪突吉罗。若呵与尼说法人。以坏威仪故亦突吉罗。拘摩罗偈者。有堂名拘摩罗。以堂主名拘摩罗故。堂名拘摩罗。佛在拘摩罗堂上。为拘摩罗天说此偈。得入见谛。以是因缘。名拘摩罗(九十事第二十三诸本皆阙)

    九十事第二十四

若不期而偶共同道。当使相去语言不相闻处。若相闻已还突吉罗。若尼与比丘期。比丘不许。若比丘与尼共期。尼不许。若相闻语声突吉罗。水道亦如是。水者。中涉行。尼与比丘期行突吉罗。此戒不共三众突吉罗。是中犯者。若比丘与尼共期。陆道行从一聚落至一聚落波逸提。若中道还突吉罗。向空地无聚落处。乃至一拘卢舍(五百弓也)波逸提。若中道还突吉罗。水道亦如是。若与式叉摩尼沙弥尼议共道行。同尼也。大众前去者。以佛在男子中得阿耨多罗三藐三菩提故。又以比丘于四众中最上首故。以此因缘故名大众。除因缘者。若多伴所行道有疑怖畏。多伴者。若有二三白衣若议行者突吉罗。若百千伴亦尔。有白衣不议无罪。水道亦如是。此戒。若多尼共期行止一波逸提。不犯者。不期去。若有王夫人共行不犯。设有夫人若共期。亦突吉罗

    九十事第二十五

此是比丘尼不共戒。尼与比丘议载船突吉罗。三众突吉罗。是中犯者。若一比丘与一尼共期载一船。一波逸提。若比丘一乃至与四比丘尼共在一船。四波逸提。随尼多少。随得尔所波逸提。若四比丘与一尼共载一船。各得一波逸提。亦随尼多少。得尔所波逸提。与式叉摩尼沙弥尼共期载船。同尼。是中犯者。若比丘与比丘尼共期载一船。上水从一聚落至一聚落波逸提。道中还突吉罗。若无聚落空地乃至狗卢舍波逸提。中道还突吉罗。下水亦如是。不犯者。若不共期。若直渡。若欲直渡为水所漂去。若直渡前岸端崩堕。若失行具。若行船人不知捉船。如是比丘本欲直渡。以此诸难或上或下不犯。若尼与比丘各在异船共期。无白衣伴波逸提。若不期必使语声不相闻。若相闻突吉罗。若陆道行恐怖。水行无恐怖。共期无罪。若船有多白衣。期无罪

    九十事第二十六

此是不共戒。比丘与尼应量衣钵波逸提。沙弥与非亲里尼衣突吉罗。比丘尼式叉摩尼沙弥尼。与非亲里比丘衣突吉罗。若比丘与式叉摩尼沙弥尼。同尼波逸提。若遣使与突吉罗。若与五种粪扫衣。三种波逸提。牛嚼衣鼠啮衣火烧衣。二种衣突吉罗。男女初交会所污衣。女人产所污衣。若与应量白衣波逸提。以染应法故。若与不如法色衣。亦波逸提。亦以染应法故。若二比丘共与一尼衣。若以一衣与二尼突吉罗。若不应量衣钵。键[金*慈]匙[木*著]一切器物。衣纽乃至一尺一寸一缕。一钵食中乃至一饼一果。皆突吉罗。除打揵椎。众中次第与食不犯。是中犯者。若非亲里尼谓是亲里。谓是亲里者。如有姊妹别离既久。后见他人谓是亲里。又如更娶异母。或以私通而生男女。或先怀妊今生男女。以是因缘谓是亲里。如是诸比丘以类可解。若与衣者波逸提。若非亲里尼谓是亲里比丘尼式叉摩尼沙弥尼与波逸提。若非亲里尼生疑。是亲里非亲里。乃至是出家尼非出家尼与衣。波逸提。若比丘有亲里尼。生非亲里想者。谓若姊妹别离既久。后设相见谓非亲里。如父外通设生男女。又如异母怀妊后适他家而生男女。又如父与自家婢使共通而生男女。是谓亲里非亲里想。若与衣者突吉罗。若亲里尼谓非亲里。乃至谓是出家。若生疑。是亲里非亲里。乃至是出家尼非出家尼。若非亲里尼。若谓若不谓。若疑若不疑。与不净衣驼毛衣牛毛衣羖羊毛衣杂毛织衣与。突吉罗

    九十事第二十七

若比丘尼与非亲里比丘作衣突吉罗。三众亦突吉罗。是中犯者。若比丘为非亲里比丘尼作衣。随一一事中波逸提。若割截篸突吉罗。若刺针针波逸提。若直缝针针突吉罗。若绳缀时突吉罗。若篸缘突吉罗。若与亲里尼作不犯。此中作衣尽是应量衣。若作白衣若作非法色衣。尽波逸提。若作五种粪扫衣。三种波逸提。如前。二种突吉罗。亦如前说。若尼遣使持衣财来与作衣突吉罗。若使人与作突吉罗。若二人共作一衣突吉罗。若与式叉摩尼作衣波逸提。若与作一切不应量衣突吉罗。若浣随一一事突吉罗。若染一一洒波逸提。若作驼毛牛毛羖羊毛等衣。亦波逸提

    九十事第二十八

此是共戒。尼俱波逸提。三众突吉罗。若与式叉摩尼沙弥尼屏覆处坐。尽波逸提。屏覆者。无惭愧处。可作媱欲处。独与一尼者。更无第三人。是中犯者。若比丘独与比丘尼屏覆处坐波逸提。起已还坐波逸提。随起还坐。随得尔所波逸提

    九十事第二十九

此是共戒。尼俱波逸提。三众突吉罗。若石女小女未堪任作淫欲者突吉罗。前屏处戒。此露处戒。后二食家中戒。与未受具戒人同房宿过二宿戒。与女人同室宿戒。此六戒讥嫌事同。而义有异。屏处露处二食家戒。此四戒。正二人更无第三人成罪。后过再宿戒。与女人同室宿戒此二戒。设有多人亦得成罪。又前四戒昼日犯。后二戒夜犯。此二戒如是差别。是中犯者。若比丘独与一女人露处共坐波逸提。起已还坐波逸提。随起还坐。随得尔所波逸提。相去一寻坐波逸提。相去一寻半坐突吉罗。不犯者。若相去二寻坐。若过二寻坐不犯

    九十事第三十

此是不共戒。沙弥突吉罗。此戒体。比丘尼向檀越。偏赞比丘功德智慧。而后得食波逸提。若式叉摩尼沙弥尼作因缘食。亦波逸提。请大迦叶舍利弗大目连阿那律。凡有五事。能与众生作现世福田。一入见谛道。二大尽智。三灭尽定。四四无量。五无诤三昧。出见谛道。所以令人得现世福。已从无始已来。为邪见所恼。今证见谛。尽一切五邪。皆悉无余。不坏信见今始成就。以此因缘。令人现世得福。大尽智生。所以令人得现世福者。众生从无始来。为痴爱慢所恼。今得尽智三垢永尽。以此因缘令人得现世福。若出灭尽定。亦令众生得现世福。又言。从灭尽定出。正似从泥洹中来。以此因缘故得现世福。又言。若入灭尽定。必次第从初禅乃至非想处。然后入尽定。若出定时。必从非想次第入无所有处。乃至初禅入散乱心。以心游遍诸禅功力深重。是故令众生得现世福。四无量者。以心缘无边众生拔苦与乐益物深广。以此因缘故。令众生得现世福。无诤三昧。此是世俗三昧。非无漏也。诤有三种。一烦恼诤。二五阴诤。三斗诤。一切罗汉二种诤尽。烦恼诤斗诤。此二诤尽。五阴是有余故未尽。有此五阴能发人诤。唯有无诤三昧。能灭此诤。一切罗汉虽自无诤。不能令前人于身上不起诤心。无诤罗汉。能令彼此无诤。一切灭故。能令众生现世得福。比丘尼语居士妇言。请比丘为请谁耶。答言。请某比丘。尼语居士妇言。尔为办粳米饭酥豆羹鸡肉鵽肉鹑肉。比丘食者波逸提。乃至教以少姜着食中。比丘食者突吉罗。此戒体。但偏赞其德。不问凡圣。尽食者波逸提。若比丘尼言请比丘。居士妇言。为请谁耶。答言。请某。居士妇言。我已先请。问办何食。答言。粗食为办粳米饭乃至鵽鹑肉等。比丘食者突吉罗。若不曲赞功德。但说布施沙门功德。其福甚大。如是凡说布施之福。比丘食者无罪

    九十事第三十一

此是不共戒。比丘尼三众不犯。尔时有一比丘。秋月冷热病盛不能饮食。天竺冬末月八日春初月八日。此十六日寒势猛甚。多发冷病。以冬春气交诤故。又日在下道行光照处少。是故寒甚。春末月八日夏初月八日。此十六日热势极盛。多发热病。以日正在上故。所照处广。是故大热。夏末月八日冬初月八日。此十六日不寒不热。以日所行道不高不下故。以寒热俱。有发冷热病。利益比丘故。听三种具足食。应食。谓食好色香味。病比丘应受一请。不应受二请。若受一请不能饱。听受第二请。不应受第三请。若受第二请不能饱。听受第三请。不应受第四请。若受第三请不能饱。应受已渐渐食乃至日中。若比丘数数食波逸提。除时者。谓病时。若病以食消息。病则折损。听数数食。又除施衣时。是名时。是中犯者。若比丘有衣食请。彼有衣食来受请及食不犯若比丘有衣食请。彼无衣食来受请不犯。食者波逸提。有衣食请。彼有衣无食来受请不犯。食者波逸提。若无衣食请。彼无衣食来受请突吉罗。食者波逸提。若无衣食请。彼有衣食请。彼有衣食来受请突吉罗。食者无犯。若无衣食请。彼有衣无食来受请突吉罗。食者堕。若有衣无衣食请。彼有衣无衣食来受请突吉罗。食者堕。若有衣无衣食请。彼有衣食来受请突吉罗。食者犯。若有衣无衣食请。彼无衣食来受请突吉罗。食者波逸提。不犯者。得多衣有食请。一切有衣食来不犯。从今听诸比丘节日数数食。彼与他竟受彼中食。何者与他谓相食。相者吉凶相也。故作食。作食者。为大德比丘故作也。斋日食月一日十六日众僧别房众僧请独请。皆应与他。若五众请不应与他。若有衣食请。彼有衣无衣食来受请无犯。若至外有檀越请言。比丘来食与汝衣。受请无犯。食亦无犯。有衣食请无衣食请者。若衣食请受请无犯。食亦无犯。若无衣食请。受请突吉罗。食者波逸提。凡两有必一得一失。若只句必应。若有衣食请。受请无犯。食亦无犯。彼无衣食来出外。若檀越言与食。无衣受请突吉罗。食者波逸提。以此类之义可解也

    九十事第三十二

此戒共。尼俱波逸提。三众突吉罗。是中犯者。若比丘福德舍过一食堕。若过一夜宿不食者突吉罗。若余处宿是中食者堕。若不病是中过一食堕。病者。乃至从一聚落来身伤破。乃至竹叶所伤。皆名为病。不犯者。一夜宿受一食。若病若福德舍主是亲里若先请。若待伴欲入崄道。若福德舍多次第住。若知福德舍人请住。皆不犯。福德舍者。根本为佛弟子一切出家人。欲使福深广故。然宿一切出家。在家沙门婆罗门悉皆不听。遮食而食多为出家人。在家人不定或与不与

    九十事第三十三

凡众生起烦恼发狂者。皆由先深爱乐失所重故。佛以神通力化令见之。如此长者失女夫故。恚恼成狂。佛以神力化作女夫。共在一处。以此因缘恚心即灭。佛以慈力彼嗔即灭者。有众生应于佛得利益者。设起烦恼。必先以慈心神通力故。令烦恼心灭。然后说法。如此比类有十三因缘。一睐眼女父怀嗔诣佛所。佛以慈心神通力故。彼嗔即除而后说法。二舍卫国有一长者。有一子爱之甚重。而少死。又多谷麦雹霜坏败荡尽。以此狂乱。佛以神力狂迷即除。听法见谛。三有一婆罗门生六子。皆容貌端政一时尽死。猖狂而行。佛以慈心神力。化作六子尽在佛前。即惭愧欢喜狂乱寻除。佛为说法入见谛道。四阿阇世王饮醉象欲来蹈佛。佛以慈心神力化作火坑。五指作师子王。象畏怖屈膝礼佛。佛以手摩头命尽生天。五优波斯那怀嗔向佛。佛以慈心神力。化大毒蛇在道两边。令悟以恚毒心故堕此蛇中。怖畏心故恚害即灭。六琉璃王罚舍夷国。得诸释子埋身地中。不令动摇。佛以神力化作园林浴池。以欢其心。琉璃王与诸释女。在堂五欲自娱。诸女问王。何以欢喜种种娱乐。王答女言。得胜怨家是故尔耳。女言。以诸释种尽是贤圣不与物诤故。王得胜耳。若不尔者。但令一人与王共斗。王不能胜。琉璃即恚。刖其手足掷置堑中。佛以慈心神力。令得手足闻法见谛。七佛在树下。尔时魔王与无数兵众来欲害佛。佛以神力降伏魔敌。随前类像化而伏之。为师子之像以伏其虎。金翅鸟像以伏其龙。其夜叉者现毗沙门王。如是比。八舍利弗目连以不忍见佛泥洹。便先泥洹以其先泥洹故。七万阿罗汉同时泥洹。当于尔时。四辈弟子莫不荒乱。于时如来以神通力化作二大弟子在佛左右。以此缘故。众生欢喜忧恼即除。佛为说法各得利益。九有一居士。佛记七日当取命终入于地狱。阿难往语诚如佛语无二。而以世乐染心。不以在意犹作乐自娱。阿难以日垂尽兼有大力。强牵至佛所。以手摩之兼令出家。随宜说法得阿罗汉道。十有一长者。唯有一子甚爱。象所蹈杀。父即荒迷狂行东西。佛以神力化作其儿使令见之。荒心即除。佛为说法。发辟支佛因缘。十一有龙女往至佛所。其夫嗔恚。佛感令嗔灭。寻为说法受三自归。十二鸽入佛影中不移转。十三病比丘佛自洗浴。然后说法得阿罗汉。如是有十三因缘。以慈心神力除灭恶心后授法利。外国法。白衣舍晨起作食。常分食分与乞食比丘。置一处来者与之。外国僧法。若乞食时各分处。某甲比丘至某处。某甲比丘至彼处。各当衰利。若檀越先分一升。当取一升。不得长索。若长索更得一小钵者波逸提。不得者突吉罗。若主人先办大钵一钵尽与比丘。不得更索。若更索得者波逸提。已得食已无出外与比丘法。此食若能自食尽则止。若不能尽随意分处。若欲如法者。主人舍先三钵尽与比丘。若量腹取者好。余长者外见乞食比丘应示处。若不示处突吉罗。钵量数大钵一钵。是中钵二钵。下钵三钵。中钵二钵。是下钵三钵。若檀越舍先留上钵一钵尽与比丘。比丘更索突吉罗。得小钵一钵波逸提。若主人先留小钵一钵尽与比丘。比丘更索突吉罗。索乃至更得小钵二钵。亦突吉罗。以本制戒限小钵三钵故。若更索得小钵三钵者波逸提。若主人先留中钵二钵尽与比丘。比丘更索突吉罗。索更得小钵一钵堕。若主人先不留食。随檀越与多少无过。更索突吉罗。若先与小钵一钵。若更索乃至得小钵二钵突吉罗。若得小钵三钵堕。如是随与多少后更索突吉罗。得三小钵外更索一小钵堕。以类推之尽可解也。若檀越自恣请不问多少也。此是共戒。比丘尼俱堕。三众突吉罗。五道中从人取食过限者堕。四道突吉罗。是中犯者。若比丘以上钵取者。应取一钵。不应过若取二钵堕若以中钵取。极多取二钵。若取三钵堕。若以下钵取。极多取三钵。若取四钵波逸提

    九十事第三十四

此戒不共。三众不犯。是中犯者。若比丘食竟从坐起去。不受残食法若啖根食波逸提。此十五种中随啖何食。已从坐起去不受残食法。十五种中随啖何食堕。若一时和合啖十五种。一波逸提。若异时各各异啖。十五波逸提。受残食法者。随所能食。多少尽着钵中。知诸比丘一食未竟来从坐起。从是人边偏袒胡跪擎钵言。长老忆念。我受残食法。若前比丘不少多取者。不名受残食法。若以钵食着地。若着膝上。不名受残食法。若以此为受残食法者堕。若相去手不相及者。不名为受。若以不净食。若以不净肉受。不名受残食法。不净食者。残宿食恶捉食共宿食。不净肉者。狗肉恶鸟肉等也。若欲食五种佉陀尼。而以五种菩阇尼受者。不名为受。如是展转欲食此而受彼悉不成受。诸不成受而食者。皆波逸提。大比丘边得受残食法也。四众边不得。若上座边。应偏袒胡跪事事如法。若下坐边。唯除胡跪余法悉同。优波离问佛。比丘有几处行时自恣几住几坐几卧。所以问者。若义不问佛。义相不显。问已理相分明。行者无碍。优波离问佛。印封已后。诸弟子顶戴奉行。如得王封随至四关无敢遮者。此亦如是。又如佛于三千世界于法自在无能过者。优波离于阎浮提内。解律自在无能过者。又云。优波离三千世界无能及者。是人问佛。佛自答之。理无不尽。佛告优波离。有五处比丘行时自恣五处住坐卧。行有五者。知行知供养知应食知种种食坏威仪。住坐卧亦如是。若比丘行洗口时。有檀越与五种食。比丘应食。应行受残食法。不应住坐卧。若住坐卧当知坏威仪不名受。若以此为受食者。皆波逸提。不犯者。若比丘言小住。若日时早。若啜粥。若一切可啖者嘱。不犯。一切五众及一切解法白衣边尽得嘱。若一人受残食法。余人食不成。若行食应行时嘱受残食法不必行也。知行者。知是行时。知供养者。知前人与食。知应者。知应受不应受。知种种食者。知分别食。坏威仪者。知行食时如是坏威仪如是不坏威仪

    九十事第三十五

此是不共戒。三众不犯。此戒体。若比丘不嘱食不受残食法。以嗔心欲令恼故。强劝令食。食者波逸提。不食者突吉罗。是中犯者。若比丘见余比丘食竟不嘱食。自恣请啖十五种食。随食何食皆波逸提。一切麦粟稻麻[序-予+禾]。未作糗饭[麩-夫+(糒-米)]。尽名似食。若变成糗饭[麩-夫+(糒-米)]。尽名正食别众食

    九十事第三十六

此戒尼共。三众不犯。若僧祈食时应作四种相。一打揵椎。二吹贝。三打鼓。四唱令令界内闻知。此四种相必使有常限。不得或时打揵椎或复打鼓或复吹贝令事相乱。无有定则不成僧法。若不作四相而食僧祈食者不清净。名为盗食僧祈不问界内有比丘无比丘。若多若少若遮若不遮。若知有比丘。若知无比丘。尽名不如法食。亦名盗僧祈。不名别众罪。若作四相食僧祈食者。设使界内有比丘无比丘若多若少。若知有比丘无比丘若来不来。但使不遮一切无咎。若使有遮。虽打揵椎食不清净。名盗僧祈。若大界内有二处三处。各有始终僧祈同一布萨。若食时但各打揵椎。一切莫遮清净无过。若有檀越。或作一月或作九十日长食者。若能一切无遮大善。若不能无遮。初作食日应打揵椎唱言。六十腊者入。若有六十腊者若多若少。但令一人入。即是清净。若无六十腊者。次唱五十九腊者。若无次第唱乃至沙弥。沙弥一人入亦是清净。若都无者亦名清净。若初日不唱。应日日唱如初日法。若初日唱者。乃至长竟若遮不遮一切无过。若初日不唱。应日日唱。乃至一人入已。余遮不遮亦复无咎。若不作此二种法。若食时有遮。界内乃至有一比丘。以遮故不得食者。此中一切僧得别众食罪。设界内无比丘故有遮。食不清净。若作九十日长食。初日如法唱。九十日竟。若檀越续有一月半月食。即前唱法为清净。不须更唱。唯僧房卧具九十日竟。应日日唱。若不日日唱即不清净。若有檀越请四人已上。在僧布萨界内食。应布萨处请僧次一人若送一分食。若不请一人不送一分食者波逸提。若二处三处亦如是。若各至布萨处僧中取一人若送一分食。则清净自处。不须展转取人送食也。随何处不请僧中一人不送一分食者波逸提。设请一人送一分食。外有异处比丘来。若遮乃至不与一人食者波逸提。若聚落界内虽无僧界。设二檀越请四人已上于二处食。应打揵椎二处互请一人若送食一分。若更有异比丘。应如法入。乃至一人若不互请及送食分。食者堕。若遮不与一人食。亦波逸提。若聚落界内先无众僧。有檀越请四人已上。应打揵椎。若不打揵椎。设知此中乃至有一比丘不来食者。得别众食罪。若疑有比丘而便食者突吉罗。若都无疑心。若打揵椎。不问有无一切无罪。僧祈食法。随处有人多少。应令食有常限。计僧祈食调一日食。几许得周一年。若日食一斛得周一年。应常以一斛为限。若减一斛名盗僧祈。若增出一斛亦名盗僧祈。若减一斛食。僧应得者失此食故。若出一斛。则令僧祈断绝不续故。既有常限。随多少一切无遮。若僧多时随共食之。若僧少时亦共食之。设有余长。留至明日次第行之。如是法者一切无过。留至明日所未许也。若行路时檀越请食四人已上。若伴中乃至有一比丘别食者。此诸比丘得别众食罪。以远游行时。随所住处纵广有一拘屡舍。此界内不得别食不得别布萨。虽非衣界。若人各赍食虽四人一处共食无过。若檀越食三人已下。各异处食亦无过。若一切共一处食大善。若食僧食若檀越食时。有异檀越。别与四比丘食。四比丘在僧中次第并坐受此食。食得别众罪。若四人先取僧中次第食。后得益者无罪。若僧食时自在维那。以僧祈物别作肥。好已四人共食。四人虽在一处无别众食罪。但食不净。若比丘或食僧食若檀越食。各取食分。虽四人已上于别处食。不犯别众。若四人已上虽在界内。各自有物共作食。不犯别众。若四人各自乞食于一处食亦无罪。若四人中一人出食三人无食。共一处食波逸提。若别房波演檀越。别与小食四人已上。非足食故无罪。设续与后食。应僧中请一人若送一分食。若各别食。食不成众。不犯不尔者波逸提。若僧食竟。有客比丘来。檀越与食四人已上。无罪。若客比丘游行。入有僧界内。受檀越食。四人已上一处食者波逸提。若先自赍粮。设本是檀越。与共食无罪。若同行四人一人有食。于僧界内在一处。与三人共食波逸提。若在旷远无僧界处。有多比丘共伴。一比丘别请三比丘。共一处食波逸提。以随住处有自然拘屡舍界故。若有行粮共一处食无过。若客比丘众多。共伴入聚落界。虽无僧界。若比丘若白衣为檀越。别请四人已上。于一处食波逸提。若同伴四人已上。在聚落界内受一檀越食。先虽无僧。但知有一比丘在中。不请共食者波逸提。若生疑心不问有无食者突吉罗。若欲如法者。应好隐悉聚落有比丘无比丘。不生疑心食者无过。若不尔应打揵椎。若远不闻。若闻不来。则清净如法。复次若僧界若自然界若聚落界。有檀越食僧食竟。有客比丘来。檀越与食四人以上无罪。若比丘僧于比丘尼僧无别众过。凡是别众食。尽是檀越食。若僧祈食一切尽无别众罪。但不如法食僧祈食者。食不清净。多得盗僧祈罪。若僧界内有檀越别食。应请僧中一人若遣一分食。若不尔者。三人已下各异处食无过。若僧界内有檀越食。先作意请僧中一人。而忘不请食已在前。应作一分食置上座头送与众僧。若僧远者。应取此食次第行之。凡檀越食法。必先请比丘。若檀越在僧界内。应语檀越。请此界内僧中一人。设请余界僧。不免罪也。若此僧结十拘屡舍界。去僧道远。复不先请。即日请者。亦应作一分食置上座头。若能得送与僧者善。若不能得送与者。应次第行之。若三比丘一比丘尼不犯。若三比丘尼一比丘不犯。乃至三比丘一沙弥尼不犯。若三比丘在界外。一比丘在界内不犯。若三比丘在界内。一比丘在界外不犯。若三比丘在地中。一比丘在空中不犯。若三比丘在空中。一比丘在地不犯。除病时作衣时。作衣者。不问应量不应量衣。一切尽听。若作衣时食难得者。听别众食。食若易得不听别众食。除行时者。极至半由旬若往若来。是中犯者。若比丘昨日来今日食堕。明日行今日食波夜提。若即日行即日道中食。若到所至处食无犯。船亦尔。大众集时者。或以法事或以余缘众僧集会。极少旧比丘四人客比丘四人。名为大众。虽大众集。食不难得者。不听别众食。食者波逸提。沙门请食时者。是外道沙门。除佛五众。一切外道出家皆名沙门。是中犯者。若沙门请。请已服俗作白衣。持食与比丘。比丘食者波逸提。受请不犯。若白衣请比丘。请已外道出家作沙门。手持食与比丘。比丘食者波逸提。若沙门请比丘。沙门持食与比丘。受请及食不犯。若有檀越作长食。或一月或九十日。先随意请人。各使令定至作食初日一切令集。清晨打揵椎。众僧集已。劝化主比丘。应立一处举声大唱。六十腊者入先。被请众僧各住一处。不被请中有六十腊者应入。若无者次应唱五十九腊者入。次第无者应唱沙弥入。若无沙弥亦得清净。若檀越僧界内作食堂舍不容。次第出在异处食无过。若僧食时。若是僧食若檀越食。各取食分在外。四人共一处食无犯。若檀越舍内请四人已上食。虽打揵椎。若檀越遮者。知有一比丘不得食者。尽得波逸提。若大界内有二处僧祈。一日中二处俱有檀越食。布萨处无过。不布萨处。若不请布萨处一人。若不送一分食者。此处僧尽得波逸提。若狂心乱心病坏心灭摈人。若三比丘一狂心三狂心一比丘。设界内四比丘四狂心。各檀越与食。尽无过。乱心病坏心灭摈人亦如是。凡别众食必在界内。界有种种众僧结界。有聚落界。有家界。有旷野处自然一拘屡舍界。此界内不得别食。不得别布萨。但非衣界。如是比丘是界内者不得别食。又必是檀越。四人已上共一处。设界内有众僧。不如法食者波逸提。若但知有一人。不如法食者波逸提

    九十事第三十七

此是共戒。比丘尼俱波逸提。三众突吉罗。是中犯者。若比丘非时啖食波逸提。若食五种佉陀尼五种菩阇尼五种似食。若十五种一时食。一波逸提若一一食。一一波逸提。若比丘非时中非时想食波逸提。非时中时想食波逸提。非时中疑食波逸提。若时中非时想食突吉罗。时中疑食突吉罗。时中时想食不犯。若非时食咽咽波逸提。非时者。从日中至后夜后分。名为非时。从晨至日中名时。何以故。以日初出乃至日中明转盛中则满足。故名为时。从中至后夜后分。明转减没。故名非时。又从晨至日中。世人营务事业作饮食。是故名为时。从中至后夜后分。燕会嬉戏自娱乐时。比丘游行有所触恼。故名非时。又从晨至日中。俗人种种事务淫恼不发。故名为时。从中至后夜后分。事务休息淫戏言笑。若比丘出入游行。或时被诽谤受诸恼害。名为非时。又比丘从晨至中。是乞食时。应入聚落往来游行。故名为时。从中至后夜后分。应静拱端坐诵经坐禅各当所业。非是行来入聚落时。故名非时

    九十事第三十八

此戒比丘尼共。三众不犯。是中犯者。若比丘啖举残宿食波逸提。若一时啖十五种食。一波逸提。若一一啖。一一波逸提。此戒体咽咽波逸提。共食宿有三种。若受食已作己有想。若共宿若不共宿。经宿突吉罗。食则波逸提。若自捉食名恶捉。捉时突吉罗。作己有想经宿亦突吉罗。食亦尔。若食不受不捉。作己有想经宿突吉罗。食亦突吉罗。不问共宿不共宿。但作己有想名内宿。若他比丘食共宿无过。触捉白衣食已。白衣还自收摄。后与比丘得食。若旷野中得多饮食。食已弃去后来故在。若无鸟兽食处。得取而食。若多人共粟麦手触。各各分已即清净也。若食是佛腊面门腊自恣腊。虽先受捉后买得食。以无己想故无罪

萨婆多毗尼毗婆沙卷第七萨婆多毗尼毗婆沙卷第八

        失译人名今附秦录

    九十事第三十九

此戒比丘比丘尼共。三众不共。是中犯者。若比丘不受饮食着口中波夜提。随所多少着口中。咽咽波逸提。有四人得从受食。男女黄门二根。一切非人畜生亦成受食。凡受食者。一为断窃盗因缘故。二为作证明故。从非人受食。得成受食。不成证明。所以听非人边受食者。旷绝之处无人受食。是故听之。若在人中。非人畜生及无智小儿。一切不听也。又为止诽谤故。为少欲知足故。生他信敬心故。如昔有一比丘与外道共行。止一树下树上有果。外道语比丘。上树取果。比丘言。我比丘法。树过人不应上。又言。摇树取果。比丘言。我法不得摇树落果。外道上树取果掷地与之。语取果食。比丘言。我法不得不受而食。外道生信敬心。知佛法清净。即随比丘于佛法中出家。寻得漏尽。若受果树叶大朴成受食。不大槃小槃圆槃机案。但一人受无过。手不净受食。得突吉罗

    九十事第四十

此戒不共。比丘波夜提。比丘尼四悔过。三众突吉罗。所以名美食者。以价贵故。以难得故。以愈病故。或有美食非美药。以乳酪酥等是。或有美药非美食。生酥油是。亦是美食亦美药。酥肉鱼脯是。或非美食亦非美药。呵梨勒等是。是中犯者。若比丘无病。为身索乳酪生酥熟酥油鱼肉脯。得波逸提。不得者突吉罗。若比丘无病。为身索饭羹菜等。得者突吉罗。不得者亦突吉罗。不犯者。病若亲里若先请不索自与不犯。若比丘乞食时。至檀越门弹指摇杖。若问者随所须语。意令知得者善。若不得者不得强索。得者突吉罗。此中制食。无病索酥油等波逸提。后过四月中制药。过四月请已。索酥油者波逸提

    第三诵九十事第四十一

此是共戒。比丘尼俱波逸提。三众突吉罗。前制有虫水浇草土和泥。此制一切不得用虫水者。若眼所见若漉水囊所得。一时舍利弗。以净天眼见空中虫。如水边沙如器中粟。无边无量见已断食。经二三日。佛敕令食。凡制有虫水。齐肉眼所见漉水囊所得耳。不制天眼见也。凡用水法。应取上好细叠纵广一肘作漉水囊。令一比丘持戒多闻深信罪福安详审悉肉眼清净者。令其知水。如法漉水置一器中足一日用。明日更看。若有虫者。应更好漉以净器盛水向日谛视。若故有虫。应作二重漉水囊。若二重故有虫者。应三重作。若故有虫。不应此处住。应急移去。是中犯者。若比丘知水有虫用者。随所有虫死。一一波逸提。若比丘用有虫水煮饭羹汤浣染洗口身手足一切用者。随尔所虫死。一一波逸提。若有虫水无虫想用波逸提。若有虫水有虫想有虫水疑用波逸提。若无虫水有虫想无虫水疑用突吉罗。若无虫水无虫想用无罪

    九十事第四十二

此是共戒。比丘尼俱波逸提。三众突吉罗。此戒于五道中。人道中得波逸提。余道突吉罗。以趣异故。食家女人名男子食。家者。白衣房舍也。此戒体。若白衣舍是行淫欲处。更无异人。此处强坐。令他夫妇所欲不得随意。得波逸提。是中犯者。若比丘食家中强坐波逸提。若起还坐。随起还坐。得尔所波逸提。不犯者。断淫欲家。若受斋家。若有所尊重人在座。和上阿阇梨父母。如是此名尊重人也若此舍多人出入处不犯。此戒与夫妇一处。后戒独一女人为异

    九十事第四十三

此是共戒。比丘尼俱波逸提。三众突吉罗。于五道中。人道得波逸提。余道突吉罗。以趣异故。食家中者。义如前说。此戒体。比丘独与一女人。深屏处坐波逸提。独者独与一女人。更无第三人。是中犯者。若比丘有食家。独与一女人共坐。三事起一波逸提。一者有食家。二者独与一女人。三者深邃处坐。若从坐起还坐。随得尔所波逸提。更得三事起。一波逸提。随起还坐。随得尔所波逸提。若闭户向外无净人者波逸提。若开户向外有净人者突吉罗。若开户向内有净人不犯。此前后二戒。若是童女石女小女未堪作淫欲者若根坏。尽突吉罗。与女屏处坐戒。凡有二种。一与夫妇同处。二与女人独处坐。与女人露处坐。正有一种。更无第三人。与尼亦有屏处坐戒如前戒。不与尼屏处坐戒。是亦有与尼露处坐戒。此九十事无在尼戒因尼有缘故制同戒

    九十事第四十四

此戒共。三众突吉罗。毗罗然国。近雪山故。名毗罗然。是外道沙门志所乐处。阿耆达者。以供养火故。名阿耆达。问颇有沙门为大众师多人所敬者不。佛将受宿报故。令发是念。端政者。身端政衣服端政威仪端政法端政。诸根寂静者。六根不乱故。身有圆光如真金聚。设以阎浮檀金置于佛前。佛出一臂即如土石。无复光色。即还自国。为佛及僧办夏四月多美饮食。所以办四月者。以夏一时有四月故。又彼国安居常以四月故也。断外人客。女乐自娱。外事好恶一不得白。问曰。佛是豪族。加是法王举世所宗。不畏毁失远近听望。何故尔也。答曰。此婆罗门王。从无始来为痴闇所盲。不顾好恶。是故尔耳。又此婆罗门长夜恶邪。是法怨贼。虽复请佛无信敬心。是故不以为意。又佛欲现受宿报故使尔耳。又云。阿耆达本无恶心。直为外人所误。是使尔耳。王夜梦见自身倒地佛即挽起。觉已请诸婆罗门师以占此梦。诸婆罗门以怀嫉心诳言。此梦是大不祥。阿耆达言。何以却之。婆罗门言。王当四月断外人客女乐自娱。可灭此也。即随其语如法行之。无上道者。道凡三种。一声闻究竟道。二辟支佛究竟道。三佛究竟道。此三道究竟入泥洹门故名道也。佛究竟道。于三道中最为无上道。剃除须发着袈裟。问曰。佛常剃除不。答曰。不尔。佛发常如剃发后一七日状。问曰。佛初得道时着袈裟不。答曰。无有白衣得佛者。要有三十二相。出家着法衣。威仪具足舍离烦恼。而复一切种智入其身内。如王女喻也。若凡夫若声闻若缘觉。一切种智终不入其身也。佛苦行三阿僧祇劫。缘觉百劫。声闻二三身亦可得也。佛与大众止此林中。所以然者。以称本要四圣种法。又欲折伏将来弟子憍慢心故。若有弟子得诸禅定。又有多闻通经藏者。谓应常处僧坊堂阁不处林薮。而三界法王尚处林野。况余人也。又为将来弟子作轨则故。佛既受处山泽。后诸弟子甘心受行。又欲为天龙善神说法故。一切天龙多乐闲静。是故如来处林树下。是时舍利弗独住不空道山中。受天王释夫人阿修罗女请四月安居。问曰。人云何能消天食耶。答曰。得禅定人不可思议。不足致疑也。又诸天食多人虽得。食不得。如天食法少食则消。昔维卫佛时高行梵志因缘应此中说。凡马食麦二斗。一斗与马一斗与比丘。中有良马。食麦四斗。二斗与马二斗与佛。问曰佛法平等。何以一多一少。答曰。僧祈物者法应平等。此檀越麦随施主意。又佛身大比丘身小。各量腹食。不失平等义也。阿难。取佛分麦并取自分。入聚落中。一女人前赞佛功德。赞佛色身及法身梵音声。菩萨修行时。于口四业多修二业。一不恶口得梵音声。二修不非时语。得凡所言说人皆信受。若作饭者。应弥勒佛时作转轮圣王玉女宝。自作饭者此福无量。以此因缘故。必至阿耨多罗三藐三菩提。凡发菩提心有二种。一见佛发心。二闻法发心。此女人亦见佛亦闻法。先闻阿难说佛功德。后取麦时。以心福深重故。一切林障廓然开辟。遥见世尊。阿难以指示之。此是佛也。女人见佛光相殊特。内心喜勇发菩提心。佛言。除佛五众。余残出家人皆名外道。食者十五种食皆名为食。是中犯者。若比丘一时与外道十五种食。一波逸提若一一与。一一波逸提。不犯者。若外道外道女病若亲里若求出家时与不犯。出家时者。四月试时化食。若化主欲令人食饱满。即得饱满。若不欲者即不得也。若盗化物。得对首偷兰遮。食化食无残宿食罪。若五众劝檀越作食一切无过。但比丘食三种所劝食波逸提食比丘沙弥所劝食无罪也。若自手与一切九十六种异见人食。不问在家出家裸形有衣悉波逸提。若教人与突吉罗与一切无见人食无咎。若众僧与外道食亦无过。正不得自手与

    九十事第四十五

此是共戒。比丘尼俱波逸提。三众突吉罗。与诸比丘结戒者。为佛法尊重故。为灭诽谤故。为息诸恶法增长善法故。是中犯者。若比丘故往看军发行。得见波逸提。不见突吉罗。军有四兵。象兵马兵车兵步兵。或四兵为一军。或三二一兵为一军。若故往观乃至一兵军。从高至下从下向高。得见波逸提。不得见突吉罗。若不故往以行来因缘道由中过不犯。若住立看坏威仪突吉罗。若左右反顾看突吉罗除因缘。因缘者。若王王夫人太子大臣大官诸将。如是等遣使唤往者不犯。凡人亦尔。止诽谤故。若唤不往。当言。比丘有所求时。不唤自来。无所求时故唤不来。为沙门果故。若往说法。或得须陀洹。或得斯陀含。或得阿那含。又长信敬善根故。又以道俗相须长养佛法故。是以听往。以欢喜心故。得沙门果也

    九十事第四十六

此是共戒。比丘尼俱波逸提。三众突吉罗。是中犯者。若比丘往军中过二夜宿。当至第三夜地了时波逸提。若军中病。若狂心乱心病坏心。不犯

    九十事第四十七

此是共戒。比丘尼俱波逸提。三众突吉罗。是中犯者。若比丘往看军阵看器仗。得见波逸提。不见突吉罗。若从下向高从高向下。得见者波逸提。不得见突吉罗。四兵乃至一军亦如是。若观牙旗幢幡两阵合战波逸提。不犯者。不故往有因缘道由中过不犯。此戒体。比丘在军中二宿时。故往看军阵。看器仗牙旗幢幡两阵合战。波逸提。设不在军二宿。住时故往看。乃至军阵合战。亦波夜提。若坐不见故。立看者突吉罗。乃至见军幢幡波逸提

    九十事第四十八

此是共戒。比丘尼俱波逸提。三众突吉罗。是中犯者。若比丘以嗔心故。若以手打若肘若膝若脚若杖打。皆波逸提。若余身分打皆突吉罗若为咒故。若食噎打拍不犯。若比丘打比丘尼突吉罗。若打三众突吉罗。若打得戒沙弥盲瞎聋哑波利婆沙摩那埵比丘。悉波逸提。戏笑打他突吉罗。六罪人五法人越济人贼住人。本破戒舍戒还俗更作比丘。在家无师僧污比丘尼。杀阿罗汉不能男不见摈。不作摈恶邪不除摈打者皆突吉罗。若打他或波罗夷。或僧残。或偷兰遮。或突吉罗或波逸提。若杀心打他死者波罗夷。不死偷兰遮。若淫乱心打比丘尼式叉摩尼沙弥尼白衣女人。悉僧残。若无杀意但嗔心打比丘。波逸提。打不满及打余人。皆突吉罗

    九十事第四十九

此是共戒。尼俱波逸提。三众突吉罗。此与前戒打拟为异。余义尽同前戒。若打波逸提。举拟欲打便止突吉罗。以打不满故。此戒本意不规打。直欲掌拟令其恼怖。但拟波夜提。如本意欲女人上出精。若遂意僧残。若不精出。直摩捉便止。偷兰遮。若本心直规摩捉。乐意僧残。此二戒亦尔。是中犯者。若比丘举手掌脚掌。举肘举膝杖。拟向比丘波逸提。拟向比丘尼式叉摩尼沙弥尼突吉罗。若拟向得戒沙弥盲瞎聋哑波利婆沙摩那埵苦切驱出等羯磨人。皆波逸提。六罪人五法人越济人贼住人。本破戒舍戒还俗更作比丘。在家无师僧污比丘尼。杀阿罗汉不见摈不作摈。恶邪不除摈不能男。尽突吉罗。或有拟向。波罗夷偷兰遮波逸提突吉罗。若杀心拟向他死者波罗夷。不死者偷兰遮。不作杀心但嗔心拟向比丘波逸提。余身分拟向突吉罗。拟向余人突吉罗。不犯者。若比丘举掌。遮恶兽若遮恶人。如是等为救护恐难。不犯

    九十事第五十

此是共戒。少分不共。尼覆藏七波罗夷。波逸提。覆藏行淫波罗夷。此不共戒。三众突吉罗。无根诽谤他有四种。以无根波罗夷谤他僧残。以无根出佛身血无根破僧轮。谤他四人偷兰遮。以无根僧残谤他波逸提。以无根波逸提波罗提提舍尼突吉罗。谤他突吉罗。是名四种。向未受具戒人说他粗罪有三种。一波罗夷僧残。得波逸提。二说他出佛身血破僧轮。得对首偷兰遮。三说他波逸提波罗提提舍尼突吉罗。得突吉罗。覆藏粗罪有三种。覆藏波罗夷僧残。得波逸提。覆藏出佛身血坏僧轮得对首偷兰遮。下三篇。得突吉罗

    九十事第五十一

此是共戒。比丘尼俱波逸提。三众突吉罗。此戒体。若比丘为恼故令失食。将向白衣舍恼使令还。是中犯者。若比丘语余比丘言。汝来共到他家。若未来入城门。令还者突吉罗。若入城门令还者亦突吉罗。若未来入外门中门内门。令还者突吉罗。若入内门未至闻处。令还者亦突吉罗。若至闻处令还者波逸提。如跋难陀语达摩令还时。檀越闻处。是名闻处。若檀越偶出见其还去。唤使令住。若闻而不住突吉罗。若不闻者波逸提

    九十事第五十二

此是共戒。比丘尼俱波逸提。三众突吉罗。此戒体。无病无余因缘。露地然火向得罪。冷热风病随何病须火消息。是名病可然火物。凡有五种。一草二木三牛屎四木皮五粪扫。此五种物。若自然若使人然波逸提。必在无覆障处然向物五事中若一时以五种着火中。一波逸提。若一一着火中。一一波逸提。若他先然火。后随何事着火中。各得波逸提。若与他前已然薪突吉罗。若手把火东西房无罪。若以一茎小薪若一把草着火中波逸提。若露地火灰炭着火中突吉罗。不犯者。若病若煮饭煮羹煮粥煮肉煮汤煮染熏钵治杖治户钩。如是等因缘不犯。若行路盛寒不犯

    九十事第五十三

此是共戒。比丘尼俱波逸提。三众不犯。羯磨跋难陀者。或言驱出羯磨。或言依止羯磨。或言不见摈羯磨。或言恶邪不除摈羯磨。佐助六群比丘者。或言六群中一人。或言六群门徒甚多。是门徒中一人僧事者。若白羯磨白二白四。若布萨说戒自恣。若差十四人。是中犯者。若比丘如法僧事与欲竟后悔言。我不应与波逸提。随心悔言。一一波逸提。除僧羯磨事。僧凡所断事。和合作已后悔讥呵突吉罗。若僧如法作一切羯磨事已。后呵言不可波逸提。若僧作一切羯磨事。作不如法。当时力不能有所转易故。默然而不呵。后言不可无罪。除僧羯磨。一切非羯磨事。众僧和合共断决之。后更呵者。若顺法顺毗尼者波逸提。若虽是王制。不顺毗尼突吉罗

    九十事第五十四

此是共戒。比丘尼俱波逸提。三众无犯。边小房者。或言。诸房舍最是边外故言边。又言。房舍卑陋少诸卧具所须。于三品中最是下者。故名为边。与诸比丘结戒者。为佛法尊重故。为息诽谤故。与未受大戒一房过二宿波逸提。所以听二宿者。以若都不听。或有失命因缘。又若不听二宿。必有种种恼事因缘。以怜愍故。得共二宿。以护佛法故。不听三宿。未受大戒者。除比丘比丘尼。余一切人是。舍有四种。一者一切覆一切障。二者一切障不一切覆。三者一切覆半障。四者一切覆少障。是中犯者。若比丘与未受大戒人。四种舍中宿过二夜波逸提。起已还卧。得尔所波夜提。若通夜坐不犯。若共宿过二夜已。第三夜更共异人宿波逸提。以前人相续故。若共宿二夜已。移在余处。过一宿已还共同宿无过。若直有覆无障突吉罗。若但有障无覆突吉罗。若却入内闭户无犯。若大篱墙内无过。若黄门二根共宿一夜突吉罗。过二宿波逸提若一切覆三边障一边不障。突吉罗

    九十事第五十五

此是共戒。比丘尼俱波逸提。三众突吉罗。阿利吒比丘先是外道弟子。外道邪师遣入佛法中。倒乱佛法。其人聪明利根。不经少时通达三藏。即便倒说云。行障道法不能障道。尽其智辩不能令成。此戒体。先三软语约敕不止。次僧中白四羯磨约敕。若如法如律如佛教三谏不止波逸提。三众恶邪不除。亦三教不止。尽灭摈

    九十事第五十六

此是共戒比丘尼俱波夜提。三众不犯。与诸比丘结戒者。为灭恶法故为佛法清净故。此戒体。若比丘知比丘如法作恶邪不除摈。便与共住同室宿波逸提。共事者。有二种事。一法事二财物事。共住者。共是人住。作白白二白四羯磨布萨说戒自恣差十四人羯磨。是中犯者。若比丘共摈人作法事。若教经法若羯磨波逸提。若经说。事事波逸提。若别句说。句句波逸提。若从摈人问义受经亦如是。共财者。若比丘与摈人衣钵乃至与终身药。皆波逸提。若从摈人取衣钵。乃至取终身药。皆波逸提。若四种舍中共卧取者波逸提。起已还卧。随起还卧。一一波逸提。若通夜坐不卧。突吉罗

    九十事第五十七

此是共戒。比丘尼俱波逸提。三众无犯。此戒体。若比丘知是灭摈沙弥。便畜营恤共事共宿波逸提。是中犯者。若比丘教摈沙弥经法若偈说。偈偈波逸提。若经说事事波夜提。若别句说。句句波逸提。若从摈沙弥受经读诵亦如是。若与衣钵乃至终身药。皆波逸提。若从取钵取衣乃至终身药。皆波逸提。若四种房中共宿波逸提。若起已还卧。随起还卧。随得尔所波逸提。若通夜坐不卧亦波逸提。若沙弥恶邪不除三教不止。与灭摈羯磨。若服俗作白衣。后还作沙弥。即先羯磨。若受具戒亦即先羯磨。若根变作沙弥尼。亦即先羯磨。三众共恶邪不除摈。共宿共事共住。突吉罗。共灭摈三众共宿共事。亦突吉罗

    九十事第五十八

此是共戒。比丘尼俱波逸提。三众不犯。若宝者。金银车磲马瑙琉璃真珠若金薄金像凡是宝器。捉者一切波逸提。若金像自捉举波逸提。若净人共举无犯。一切似宝若捉若举无犯。若以似宝作女人庄严具。捉者突吉罗。若以作男子庄严具。除矛槊弓箭刀杖。作鞍勒鞭带。一切捉者无犯。若捉铠一切乐器突吉罗。若自捉钱突吉罗。若比丘捉重宝波逸提。若使三众白衣捉无犯。除僧坊内若住处内若有人忘宝。应如是立心取。有主来索当还。是应尔。僧坊内者。墙堑篱障内。住处内者。随白衣舍安止比丘住处。是名住处内。此二处有人忘宝在中。若有净人教取看弆。若无净人应自取举。若有主来应问相。相应然后与。若不相应不应与。若僧篱墙外复白衣住处不应取。次第法如律文说

    九十事第五十九

此是共戒。尼波逸提。三众突吉罗。新衣者。不问新故。自以初得故名为新。色有五大色。黄赤青黑白。黄者。郁金根黄蓝染。赤者。羊草落沙染。青者。或言蓝黛。是或言其流。非即是也。是亦禁。余未识其本。凡此五大色。若自染突吉罗。若作衣不成受。若作应量衣不应量衣。一切不得着。若先得五大色衣。后更改作如法色。则成受持。若先作如法色。后以五大色后坏者。不成受持。虽不成受。若作三点净者。得一切处着。若绀黑青作衣不成受持。除三衣。余一切衣但作三点净着无过。若皂木兰作衣。一切得作亦成受持。若非纯青浅青及碧。作点净得作衣里。舍勒外若不现得着。若作现处衣尽不得着。赤黄白色。色不纯大者亦如是。除富罗革屣。余一切衣卧具物乃至腰带。尽应三点净。若不点净着用者。皆波逸提。一切不如法色衣不成受持。一切如法色衣则成受持。一切如法色衣不如法色衣。不作净著者。皆波逸提。若衣故点灭犹是净衣。不须更点净。若先点净衣。更以新物段补。设十处五处。但一处作一点净。不须一一净也。以皆却刺补故。若但直缝者应各各作点净。若却刺补衣若直缝补衣。设不作点净著者突吉罗。凡净法有三种。一者如法三点净衣。一切浆须作净者。比丘得自作。二者若果菜五种子。应沙弥白衣作净。三者若得二重以上革屣若得新靴。应令白衣着行五六七步。即是作净。如畜宝用种种宝贩卖物。此三种物尽白衣边作净。复有二种净。一故作净。如界采五种子淳浆。若火若刀若爪甲若水故作净。是名故作净。二者不故作净。如果菜五种子。若刀火自堕上。即名作净。鹦鹉亦尔。若雨堕浆中。即名为净。是名不故作净。凡坏色作点净三种。一青二皂三木兰。若如法色衣。以五大色作点著者突吉罗除五大色。有纯色黄蓝郁金落沙青黛及一切青。名纯色亦不得着。若黄赤白衣虽三点净着。突吉罗。若先衣财时作点净。后染作色成已。若更不点净无咎。以先净故。五纯色衣不成受持。若作三点净着。得突吉罗。若先纯色后以如法色坏。则成受持。紫草奈皮[卄/(阿-可+辛)/木]皮地黄红绯染色黄栌木。尽皆是不如法色。以如法色更染覆上。则成受持。若先如法色。后以不如法色。更染作点净得着。不成受持

    九十事第六十

此是共戒。比丘尼俱波逸提。三众突吉罗。是中犯者。若比丘未满十五日浴者波逸提。若满十五日若过不犯。除热时者。春残一月半夏初一月。是二月半名热时。律师云。天竺早热。是名天竺热时。如是随处热时早晚。数取二月半。于中浴无犯。病者。冷热风病洗浴得差名病时。风时。必有尘坌污身体。是名风时。雨时者。必使雨水湿衣污染身体。是名雨时。作时者。乃至扫僧坊地五六尺。名为作时。行路时者。乃至半由旬若来若去。是中犯者。若比丘昨日来今日浴波逸提。若明日去今日浴波逸提。若即日来去经半由旬浴者无犯。若无诸因缘。减半月浴者波逸提。若有因缘。不语余比丘辄浴者。突吉罗

    九十事第六十一

此是共戒。比丘尼俱波逸提。三众突吉罗。与诸比丘结戒者。为怜愍故。为断罪恶故。为长敬信心故。是中犯者。有一种夺畜生命波逸提。自夺教夺遣使。凡三事以成杀罪。一众生想。二杀众生意。三断命波逸提。自杀者。欲令死故。若手拳若以头脚若杖木瓦石刀槊弓箭等能杀众生物。以此打掷。若死者波逸提。若不即死后因是死波逸提。若不即死后不因是死突吉罗。若以毒药着眼中。若着身处分中。若着食中若着行处卧处。若死不死义如前说。若作弶机拨按腹堕胎。乃至母腹中初得二根。念欲令死不死义。如前说。若教杀若遣使杀。教使杀此乃杀彼突吉罗。教令来杀乃去时杀突吉罗。如是种种杀义。如波罗夷中说。正以人与畜生为异耳

    九十事第六十二

此是共戒。比丘尼俱波夜提。三众突吉罗。是中犯者。有六因缘。一生。二受具戒。三犯。四问。五物。六法。生者有二种。一问余比丘。汝何时生。问汝腋下何时毛生。口边何时生须。咽喉何时现。受具戒有四种。若比丘问余比丘。汝何时受具戒。二谁是汝和上阿阇梨。谁是汝教授师。三问汝于十众受具戒五众中受耶。四问汝于界外受具戒为界内受耶。犯者。有四种。一言犯僧残。二犯波逸提。三犯波罗提提舍尼。四犯突吉罗。问者。问他比丘。汝某聚落行某巷行。到某家坐。某处共某女人语。是恶名女人也。到某尼坊共某尼语耶。恶名尼也。是名问。物者。若比丘语余比丘。汝谁同心用钵乃至终身药。法者。若比丘语他比丘。莫多畜衣。莫数数食。莫别众食。莫他不请入他家。莫非时入聚落。莫不着僧伽梨入村邑。于前六事中。生者或得波逸提。或得突吉罗或无罪。若推其生时。年岁及三相久近。未应受具戒而受具戒。前人实不得戒。为慈愍好心语者无罪。若故欲令其疑悔突吉罗。若前人有戒欲恼令疑悔波逸提。若以后五事。欲令疑悔故语者。不问前比丘疑悔不疑悔。尽波逸提。除此六事。更以余事欲令疑悔故语者突吉罗。所谓语比丘言。汝多眠多食多语言等。是人非比丘非沙门非释子。若以此六事。令余人疑悔者突吉罗。所谓若比丘尼三众。在家无师僧本破戒。还俗后作比丘。越济人贼住灭摈人。六罪人五法人。狂心乱心病坏心。杀阿罗汉污比丘尼本不能男。尽突吉罗。若得戒沙弥盲瞎聋哑。不见摈不作摈恶邪不除摈。波利婆沙摩那埵依止等四羯磨人。尽波逸提。若以此六事。遣使教人突吉罗

    九十事第六十三

此是共戒。比丘尼俱波逸提。三众突吉罗。是中犯者。若比丘以一指击擽他比丘波逸提。若以二三乃至九指一一击擽。一一波逸提。若十指一时击擽。一波逸提若击擽比丘尼三众。六罪人五法人。狂心乱心病坏心。在家无师僧。如是等人尽突吉罗。盲瞎聋哑波利婆沙摩那埵得戒沙弥。不作不见恶邪不除依止等四羯磨人。尽波逸提。若以木击擽突吉罗。若教人击擽突吉罗。十七群击擽死者。是年少小比丘也

    九十事第六十四

此是共戒。比丘尼俱波逸提。三众突吉罗。与诸比丘结戒者。为佛法尊重故。为长敬信故。不废正业故。为修正念故。是中犯者。有八种。一者作喜。二者作乐。三者作笑。四者戏。五者弄水。六者令他喜。七者令他乐。八者令他笑。若比丘于八事中趣为一事。若拍水若倒没。若如鱼宛转。若一臂浮若两臂浮。若身涌若仰浮。如是等种种非威仪事。一一波逸提。乃至槃上有水。若坐床上以指画之突吉罗。不犯者。若为学浮若直渡者。不犯

    九十事第六十五

此是共戒。比丘尼俱波逸提。三众突吉罗。舍有四种。一切覆一切障。一切障不一切覆。一切覆不一切障。一切覆少障。是中犯者。若比丘是四种舍中。共女人畜生女宿波逸提。若起还卧。随起还卧。得尔所波逸提。不犯者。通夜不卧。乃至异舍有女人宿。孔容狸子入处。是舍中宿波逸提。若房中有一女人。一波逸提。有十女人。十波逸提。此戒亦身教成罪。亦人上成罪。一卧一波逸提。十卧十波逸提。是名身教成罪。若一卧有一女人一堕。若一卧时有十女人十堕。是名人上得罪。若舍一切覆无障突吉罗。若一切覆三边有障。一边无障。若乃至一边有障三边无障突吉罗。若四边有障不一切覆突吉罗。若一切覆一切障。不问大小。尽波逸提。若作都堂招提舍。同覆同障。设使堂舍中有诸小房。虽房房各异。以堂同故。是一房。必使堂四边有障。上覆亦同。若比丘在堂内小房中自闭房户。女人复在一小房中。以堂一覆故波逸提。若白衣舍内房舍各异。若比丘在一房中。女人在余房。若比丘不闭房户突吉罗。闭户无犯。若是房墙障相连。上复同覆而并户。出入处异。虽相连同覆。但比丘闭户无罪。若树下突吉罗。若女人是畜生女堪作淫欲者波逸提。若不堪任作淫欲者。如石女根坏鬼神女天女鸽雀等。突吉罗

    九十事第六十六

此是共戒。比丘尼俱波逸提。三众突吉罗。是中犯者。有六种色声香味触法。色者。若比丘作象色马色羊色水牛色。如是等可畏色。问此是常所见事。何以怖畏。答以非时故令人怖也。若能令人怖若不能。皆波逸提。是名色。声香味亦如是。以非时故令人怖也。味者。若比丘问他比丘。汝今日用何物啖食。答言。用酪鱼。又言。若用酪鱼啖饭者。是人得癞癣病。若众令怖若不怖皆波逸提。如是等名味。触者。若他先敷坚物用坐。欲令怖故去坚敷软。事相忽异。令惊怖也。去软着坚亦尔。如是等以种种异触怖他。名触也。法者。若比丘语余比丘。汝莫于生菜中大小便。当堕地狱饿鬼畜生。若能令怖若不能。皆波逸提。若比丘自以六事怖。若教他怖余比丘。若能令怖若不能。皆波逸提。除此六事。更以余事怖比丘者突吉罗。所谓若以多眠多食多言语。当堕地狱饿鬼畜生。如是比丘怖他者突吉罗。若怖比丘尼三众。六罪人五法人。狂心乱心病坏心。在家无师僧越济人。杀阿罗汉污比丘尼。本不能男一切外道出家人。一切在家人。尽突吉罗。得戒沙弥盲瞎聋哑。波利婆沙摩那埵。不见不作恶邪不除摈。依止等四羯磨人。尽波逸提

    九十事第六十七

此是共戒。比丘尼俱波逸提。三众突吉罗。是中犯者。若比丘藏他比丘衣钵户钩革屣。若觅不得波逸提。若觅得突吉罗。若藏石钵金钵银钵琉璃钵。如是一切诸宝钵。若觅得不得。尽突吉罗。若藏五大色衣驼毛牛毛羖羊毛杂羊毛衣尽突吉罗。若藏得戒沙弥波利婆沙摩那埵盲瞎聋哑依止等人不见不作恶邪不除摈人衣钵。尽波逸提。若藏六罪人五法人在家无师僧本比丘更出家越济人贼住人杀阿罗汉污比丘尼本不能男比丘尼三众如是等人衣钵。皆突吉罗。一切百一物藏。尽波逸提。若钵未熏亦波夜提。若钩钵键[金*咨]一切长衣钵作净畜者。乃至针筒藏者波逸提。若针筒有针波逸提。无针突吉罗

    九十事第六十八

此是共戒。比丘尼俱波逸提。三众突吉罗。此戒体。本与他衣作诳心与。欲使役故。令他作已有想。作已便夺波逸提。所以不与重者。不根本与故。是中犯者。若比丘与比丘比丘尼式叉摩尼沙弥沙弥尼衣。他不还便夺取者。波逸提

萨婆多毗尼毗婆沙卷第八

    续萨婆多毗尼毗婆沙序

        西京东禅定沙门智首撰

世雄息化。律藏枝分。遂使天竺圣人。随部别释。自佛教东流。年代绵久。西土律论。颇传此方。然此萨婆多即解其十诵。智首宿缘积善。早预缁门。始进戒品。即为毗尼藏学。至于诸律诸论每备披寻。常慨斯论要妙。而文义阙少。乃至江左淮右。爰及关西。诸有藏经。皆亲检阅。悉同雕落。罕有具者。虽复求之弥恳。而缘由莫测。每恨残缺。滞于译人。静言思此。恒深悲叹。比奉诏旨。来居禅定。幸逢西蜀宝玄律师。共谈此论。阙义玄言本乡备有。非意闻之。不胜庆跃。于是殷勤三覆。问其所由。方知此典译在于蜀。若依本翻。有其九卷。往因魏世道武。殄灭法门。乃令兹妙旨。首末零落。遂使四方皆传阙本。其真言圆备。尚蕴成都。智首乃托邛僰行人。井络良信。经涉三周。所愿方果。以皇隋之驭天下二十六载大业二年岁次丙寅冬十二月。躬获此本。传之京邑。智首深愿流兹觉水。散此慧灯。悟彼学徒。补其法宝。已有一本。附齐州神通寺僧沙禅师。令于海岱之间。诸藏传写。犹恨晋魏燕赵。未获流布。相州静洪律师毗尼匠主。复是智首生年躬蒙训导。今谨附一本。屈传之河朔。故具述由序。标之卷初。愿寻览诸贤。无猜惑也萨婆多毗尼毗婆沙卷第九

        失译人名今附秦录

    九十事第六十九

谤人犯重偷兰遮。犯突吉罗。向一人谤。亦犯

    九十事第七十

女人同道行者。上制尼。此制白衣女也。义如上尼中无异也。若共多女。犯多也

    九十事第七十一

贼共行者。袈裟秦言染也结爱等亦名染。着此服者。在兽不令其畏。是故猎师喜假服之。后令兽远见比丘便生畏心远而避之。与贼行亦尔。是以人见比丘共贼行。便生不信。是故佛制

    九十事第七十二

不满二十年中人。若不满二十自想不满不得戒者。真实不满乃至无十九故。所以不得戒也。胡本十九得戒者。不如秦也。要数日满为年下不满得戒者。以母胎足故也。共事者。说戒羯磨等。共住得罪者。以过二宿也。若岁满日少亦得也。若人满二十。自想满二十。僧中问云不满者有二种。一误若忘此人得戒。二意不欲受。师强与故说不满。此人不得戒。年六十不得受大戒。设师僧强授亦不得。以其人不任堪苦行道。又心智钝弱。唯听为沙弥。七岁以下亦不听度。度受戒俱突吉罗。僧祇家有观相貌义。年未满二十不听者。以其轻躁不耐寒苦。若受大戒人多呵责。若是沙弥人则不呵故也。尼十二得者。为夫家所使。任忍众苦。加厌本事也

    九十事第七十三

掘地中生地者。胡本云实地。不生者云不实地。四月及八月此是雨时。地相连着润势相淹。能生草木故。义名生地。余无雨时。日炙干燥风吹土起。而不生草故。义名不生地也。若触此上干土犯突吉罗。下侵湿地犯堕。墙根齐筑处不犯。以异于地故。地虽筑治若湿相淹发犯堕。凡欲取菜草土。当遥言某处有好者净来。若到边指示犯也。蚁封雨时犯突吉罗。以非根本实地故。若中生草触草犯堕。封土犯突吉罗。所以犯突者。有少相连分故。泥下地犯堕。屋上墙上生草如蚁封通覆处地若土起犯突及下地犯堕

    九十事第七十四

四月请中。佛遮非时非亲里乞。六群以释摩男是亲故。四月竟已从乞。以非时非法呵责强索故制之。以数数请者。或请主官事匆懅。不如所请后更请。或二月已尽。后有财更请二月。或多财人数数请故。事不一同。三时之中随请。若夏初请夏中受。若夏半来请不尽四月。则并入冬分。受余时亦尔。别请者。私请大德人不犯也

    九十事第七十五

结同戒者。若二部同戒。必于大僧中结。后令大比丘告尼。以女人贱当从大僧受故。若独结尼戒。就二部中也。或因尼起同。或因比丘起同。或俱因起不同。修多罗者。四阿含及二百五十戒。毗尼者。言折伏。以能折伏贪恚痴故。诸律是也。摩多勒伽者。善择诸法相义。有似阿毗昙也。毗婆沙者。云阿毗昙及戒僧一。是以明义相论色非色教非教等故也。及入毗尼经者。余经中诸说戒处是云。若以此经中戒。向未受大戒说犯突要。心口轻其人不来听戒。犯。若有余事不来无苦

    九十事第七十六

往听斗诤犯者。以能破佛法令僧为二部。是故制诤。后听者。犯所以在高下处听犯者。以诤事重故。故不同说戒布萨羯磨等也。此中诤人及余不诤人。来听及向人说不说。皆犯

    九十事第七十七

僧断事时默然起去中。若但明白白二白四羯磨者。以百一羯磨入此三中故。轻事白羯磨。中事白二。重事白四说。此三羯磨时。若起去犯堕。余非羯磨事起去。犯突

    九十事第七十八

不恭敬者。胡云恼他也。凡四事恼他。与记识已。师及于已是上座。语令莫作是事。初顺言不作。后作一也。二逆言当作犯堕。恼下坐犯突。未与记时有二事唯犯突也

    九十事第七十九

饮酒中凡有酒香酒味醉。此三中若饮一。犯堕也。啖麴犯者。云此麴以麦及药草以酒和卧之。后干持行和水饮之。能令人醉者也。余麴无犯也。若过是罪者。此酒极重。饮之者能作四逆。除破僧逆。以破僧要当自称为佛故。亦能破一切戒。及余众恶也

    九十事第八十

非时入聚落中。明在阿练若处者。有檀越。近聚落外作住处学问处及阿练若处。有远阿练若住畏贼故。近聚落作僧藏也。若寺在聚落外。不白出寺至城门。犯突。又云。入聚落内时。若总白入聚落。后到随意所至也。若别相白。若先不白。随见异寺比丘白。无犯

    九十事第八十一

食前后者。此为檀越家比丘结也。缘跋难陀出百两金钱百两贮畜百两饮食。此施主所以请佛及僧。欲在僧中从其乞生。然知其欲乞故先至已余行晚来。因制戒也。檀越道人设食日晨白僧往不犯。不白往者犯堕。若白往于道中。至余家索食。食得正食堕。助食突。若与僧一时去不白。先入者堕。主人明日当作食。今日自往者堕。除主人唤食。后主人不留辄自住者堕。作经劳主人。僧先至而方后到者堕。食后未嚫去者堕。余道人欲私行。直报同学。得犯与不犯。与上同。虽大界内近寺。白衣家不白亦犯堕也。入城突。若白而还晚。令僧恼者突

    九十事第八十二

门者。王宫外门也。门阃者。宫门前一限木也。过此木犯。未藏宝者。王已出外夫人未起。其进御时。所著宝衣轻明照彻内身外现。以发欲意未藏此衣。名未藏宝。又女为男宝。夫人未以余衣覆身。亦名未藏宝。夜未晓者。胡本有二义。一未晓。二夫人未起。王及夫人未出宝衣未藏入限木内犯。已出已藏入限不犯。及王夫人大臣太子势力强将入不犯。或未藏宝夫人无突。有夫人无宝突。入天龙鬼神宫门突。入空宫门不犯。王者。取聚落主已上也

    九十事第八十三

我今始知是法者。云经心听乱心听戒故犯。云初至众学犯突。说竟犯堕。实先知言始知。犯妄语堕。此中正结不专心听罪也

    九十事第八十四

针筒者。以是小物故。所以不入三十事故。又应破故。若还主主不受。若与他则主恼。施僧则非法。唯毁弃。骨者。象马龙骨。牙者。象及猪牙。齿者。象马猪齿。角者。牛羊鹿角也。贪好故不净故犯也。现余钵支等亦尔也

    九十事第八十五

高广床者。以生憍慢故。木床高大。悉犯俗人八戒。同是也。八指者。一指二寸也。随得者。明用时随坐卧得罪。所以不入舍堕者。以截断故。截使应量入僧中悔若下湿处听八寸支过悉犯

    九十事第八十六

兜罗者。草木华绵之总称也。以是贵人所畜故。又人所慊故。喜生虫故。又若卧软暖上。后得寒及粗[革*卬]时。不堪忍故乞时犯突。随贮至成犯堕。凡施佛即得其福。无从用生。今佛不用故。僧则常用。福则常生故。应护作卧具也

    九十事第八十七

覆疮衣者。先未听畜涅槃僧。有一比丘。病痈脓血流出。污安多卫。佛见听畜覆疮衣。乃至疮差。后十日内畜不犯。既听涅槃僧。患疮时涅槃僧内着之。量如涅槃僧

    九十事第八十八

尼师檀者。本佛在时不卧故小作。后因难陀听益缕际从织边唯于一头。更益一搩手。凡长六尺广三尺。令比丘卧故。僧卧具量四八尺也。今若欲作尼师檀量故。如本作也。云以此先制故。所以在此中也。后以结三十舍堕。则入舍堕。今作不如法。便入舍堕也

    九十事第八十九

雨浴衣中求愿。佛不与过愿者。云过愿如王大人法。有从求愿所索礼必不违。若求妻妾奴婢田宅悉与。佛以过此不如法与故。云不与过愿。唯与如法愿也。云今凡比丘浴。若露覆室。要不共白衣。及覆上身。要当着竭支。一当有羞愧。二喜生他欲想故。昔有罗汉比丘浴。有一比丘。见其身体鲜净细软。便欲心生后不久男根堕落即有女根。则休道为俗生子。后还遇见即便识之。知本所因即归情求。及罗汉教令悔过。用心纯至还得男根。故宜不露形也。云淫持戒大比丘及沙弥罪。同破七宝塔。劝人令出家精进。斯福同塔也

    九十事第九十

云佛衣量。佛身丈六常人半之。衣量广长皆应半也。佛弟难陀短佛四指。衣应减长中一尺广中四寸。难陀先着上衣。佛着中衣。今不听过等。听着下衣。常人则下中下也。佛衣色如金诘施。[疊*毛]色亦尔。故难陀衣宜当覆沙。覆沙者秦言坏色也令同比丘衣也

    四悔过第一

此是不共戒。比丘尼式叉摩尼沙弥尼无犯。沙弥突吉罗。此戒体无罪名。一人边一说悔过。是中犯者。若比丘不病入聚落中。非亲比丘尼边自手取根食。得波罗提提舍尼罪。若一时取十五种食。一波罗提提舍尼。若一一取。十五波罗提提舍尼。不犯者。若病若亲里比丘尼。若天祠中多人聚中与。若沙门住处与。聚落外若比丘尼坊舍中与。不犯

    第二事

此是不共戒。比丘尼式叉摩尼沙弥尼无犯。沙弥突吉罗。是中犯者。若比丘受比丘尼所教与食。得波罗提提舍尼罪。随受得尔所波罗提提舍尼。若二部僧共坐。一部僧中若有一人语是比丘尼者。第二部僧亦名为语。若别入别坐别食别出者。是中入檀越门比丘应问出比丘。何比丘尼是中教檀越与比丘食。答言某。应问。约敕未。答言。已约敕是入比丘亦名约敕。有诸比丘出城门时。有比丘入者。应问出者。若出未约敕。入者应约敕。若出约敕。入者亦名约敕

    第三事

此戒与比丘尼共。三众不共。是中犯者。若比丘学家中。僧作学家羯磨已。先不请后来自手取根食。得波罗提提舍尼。若一时取十五种食得一罪。若异时各各取。得十五波罗提提舍尼

    第四事

此是不共戒。四众无犯。是中犯者。若比丘僧未差。是人不僧坊外自手取根食。僧坊内取。得波罗提提舍尼罪。若比丘受僧羯磨已。是比丘知是中有贼入。应将净人是中立。若是中见人有似贼者。应取是食语诸持食人。汝莫来入。是中有人似贼。若是持食人强来者不犯。律师云。所羯磨人必使勇健多力能却贼者。若不能却。一切僧尽应至有贼处。若复不能。应语聚落檀越令多人防护也

众学初

此是共戒。诸比丘极高着泥洹僧者。非是五比丘。非是优为迦叶等。亦非舍利弗目揵连等。又非善来比丘。多是白四羯磨受具戒者。如释种千人同时出家者。此诸人等多坏威仪。如释种比丘本出豪族。以先习故。下着泥洹僧。诸婆罗门外道。在佛法中出家。高着泥洹僧。诸六群比丘参差着泥洹僧。问曰。五篇戒中佛何以正制着泥洹僧着三衣。观去来现佛及净居天耶。答曰。佛结五篇戒。皆应观三世诸佛及净居天。但年岁久远文字漏落。余篇尽无此中独有。复次结五篇戒。此最在初。结后集藏者铨次在后。以此篇贯初故。余篇不说。复次此戒于余篇是轻者。将来弟子不生重心。是故如来以佛眼观去来诸佛及净居天也而后结也。使来世众生不生慢罪。复次三世诸佛结戒有同不同。于五篇戒中不必尽同。此着泥洹僧袈裟。三世诸佛一切尽同。是故此戒观诸佛及净居天。余篇不观也。问曰。此众学戒结既在初而在后耶。答曰。佛在初结。后集法藏者铨次在后。何以故。罪名虽一而轻重有五。以重戒在先轻戒在后。此戒于五篇中最轻是故在后。又以一是实罪二是遮罪。以实在初遮罪在后。又以一是无残二是有残。又以如焦败种。又以如多罗叶。是故重者在初。轻者在后。问曰。余篇戒不言应当学。而此戒独尔。答曰。余戒易持而罪重。犯则成罪。或众中悔或对首悔。此戒难持而罪轻。脱尔有犯心悔念学。罪即灭也。以戒难持易犯故。常慎心念学不结罪名。直言应当学也。高下着内衣者。踝上一搩手上下过名高下。若比丘沙弥远行来时。听踝上二搩手上至膝下。比丘尼式叉摩尼沙弥尼。一切时踝上一搩手。正使行来不得高也。三不参差。四不如釿头。五不如多罗叶。六不如象鼻。七不如糗揣。八不细襵。九不着茸。十不并襵两边。十一不着细缕内衣。十二周齐着三衣。有四事高下者。在泥洹僧上四指。三不参差。四周齐也

入白衣舍有四十一事。受食有二十七事。一一心受饭。二一心受羹。三不溢钵受羹饭。四羹饭等食。五不拘饭食。六不构饭食。七不大揣饭食。八不手捉食。九不豫张口待食。十不含食语。十一不啮半食。十二不吸食作声。十三不嚼食作声。十四不味咽食。十五不吐舌食。十六不缩鼻食。十七不舐手食。十八不指抆钵食。十九不振手食。二十不弃箸半饭。二十一不腻手捉饮器。二十二不病不得自为索羹饭。二十三不饭覆羹更望得。二十四不相看比坐钵。二十五端视钵。二十六次第啖食尽。二十七洗钵水有饭。不问主人不应弃舍内。为人说法有十九事。大小便唾涕有三事。上树有一事

    七灭诤第一

自言灭诤法。五众有事。及五篇犯有犯不犯事。尽自言灭诤法灭也。自言灭诤。有十种非法十种如法。十非法者。若比丘犯波罗夷罪。自言不犯。众僧问言。汝自说犯不。自言不犯。是名非法。又比丘犯僧残波逸提波罗提提舍尼突吉罗。自言不犯。众僧问言。汝自说犯不。自言不犯。是名五非法也。又比丘不犯波罗夷罪。自言我犯。众僧问言。汝自说犯不。自言我犯。是名非法。有比丘不犯僧残波夜提波罗提提舍尼突吉罗。自言我犯。众僧问言。汝自说犯不。自言我犯。是名十非法。十如法者。有比丘犯波罗夷。自言我犯。众僧问言。汝自说犯不。自言我犯。是名如法。有比丘犯僧残波夜提波罗提提舍尼突吉罗。自言我犯。众僧问言。汝自说犯不。自言我犯。是名五如法。又比丘不犯波罗夷僧残波夜提波罗提提舍尼突吉罗。自言不犯众僧问言。汝自说犯不。自言不犯。是名十如法

    第二事

现前灭诤。有二种非法二种如法。二非法者。有非法僧。约敕非法僧令折伏。与现前灭诤。有非法僧。约敕非法三人二人一人令折伏。与现前毗尼。乃至不如法一人。约敕不如法一人僧三人二人令折伏。与现前毗尼。是名一非法现前毗尼。有不如法僧。约敕如法僧令折伏。与现前毗尼。有不如法僧。约敕如法三人二人一人令折伏。与现前毗尼。乃至不如法一人。约敕如法一人僧三人二人令折伏。与现前毗尼。是名二非法现前毗尼。二种如法现前毗尼者。有如法僧。约敕如法僧令折伏。与现前毗尼。又如法僧。约敕如法三人二人一人令折伏。与现前毗尼。乃至如法一人。约敕如法一人僧三人二人令折伏。与现前毗尼。是名一如法现前毗尼。又如法僧。约敕不如法僧令折伏。与现前毗尼。又如法僧。约敕不如法三人二人一人令折伏。与现前毗尼。乃至如法一人。约敕不如法一人僧三人二人令折伏。与现前毗尼。是名二种如法现前毗尼

    第三事

此是守护毗尼。三众尽与忆念毗尼。五篇戒尽与忆念毗尼。与忆念毗尼。必白四羯磨与。或现前或不现前。比丘比丘尼现前。三众不现前。若比丘得忆念已。若下戒作沙弥。即先忆念。若反戒还俗后更出家。若作沙弥若受具戒。即先忆念。若根变作比丘尼。即先忆念。若沙弥得忆念已。若受具戒即先忆念。若返戒还俗后更出家。若作沙弥若受具戒。即先忆念。若根变作沙弥尼亦即先忆念。若比丘尼式叉摩尼沙弥尼得忆念已。展转次第如比丘沙弥法。有三种非法忆念毗尼。有三种如法忆念毗尼。三种非法者。有比丘犯无残罪。自言犯有残罪。是比丘从僧乞忆念毗尼。若僧与是比丘忆念毗尼。是名非法。何以故。是人应灭摈故。又如施越比丘。狂痴心故。多作不清净非法不随顺道非沙门法。是人还得本心。先所作罪若僧三人二人一人常说是事。是人从僧乞忆念毗尼。若僧与是人忆念毗尼。是名非法。何以故。是人应与不痴毗尼故。又如呵多比丘。无惭无愧破戒见闻疑罪。是人自言我有是罪。后言我无是罪。若僧与是人忆念毗尼。是名非法。何以故。是人应与实觅毗尼故。是名三非法忆念毗尼。三如法者。又如陀骠比丘。为慈地比丘尼无根波罗夷谤故。若僧三人二人一人常说是事。是比丘从僧乞忆念毗尼。若僧与是人忆念毗尼。是名如法。何以故。是人应与忆念毗尼故。又如一比丘犯罪。是罪发露如法悔过除灭。若僧三人二人一人犹说是事。是比丘从僧乞忆念毗尼。若僧与忆念毗尼。是名如法。何以故。是人应与忆念毗尼故。又如比丘未犯是罪。将必当犯。以是事故。若僧三人二人一人说是犯罪。是比丘从僧乞忆念毗尼。若僧与是人忆念毗尼。是名如法何以故。是人应与忆念毗尼故。是名三如法忆念毗尼。忆念毗尼行法者。余比丘不应出其罪过。不应令忆念。不应乞听。亦不应受余比丘乞听。若彼从乞听突吉罗。若受他乞听亦突吉罗。若彼不听若出过罪若令忆念。得波夜提

    第四事

此是守护毗尼。五众尽与不痴毗尼。与不痴毗尼。必白四羯磨或与现前或不现前。比丘比丘尼现前三众不现前。若比丘得不痴毗尼已。若下戒作沙弥。即先不痴毗尼。若反戒还俗后更出家。若作沙弥若受具戒。即先不痴毗尼。若根变作比丘尼。即先不痴毗尼。若沙弥得不痴毗尼已。若受具戒即先不痴毗尼。若反戒还俗后更出家。若作沙弥若受具戒。即先不痴毗尼。若根变作沙弥尼。亦即先不痴毗尼。若比丘尼式叉摩尼沙弥尼得不痴毗尼已。展转次第如比丘沙弥法。不痴毗尼有四种非法四种如法。四种非法者。有比丘不痴狂现狂痴相貌。诸比丘僧中问。汝狂痴时所作今忆念不。答言。长老。我忆念痴故作。他人教我使作二忆。梦中作三忆。裸形东西走立大小便四也。是人从僧乞不痴毗尼。若僧与是人不痴毗尼。是名四非法。四如法者。有比丘实狂痴心颠倒现狂痴相貌。诸比丘问。汝忆念狂痴时所作不。答言不忆念。他不教我作。不忆念梦中作。不忆裸形东西走。不忆立大小便。是人从僧乞不痴比尼。若僧与是人不痴毗尼。是名四如法不痴毗尼。得不痴毗尼行法者。余比丘不应出其过罪。不应令忆念。不应从乞听。亦不应受他比丘乞听。若从彼乞听得突吉罗。若受他乞听亦得突吉罗。若彼不听便出过罪若令忆念。得波夜提罪

    第五事

此是折伏毗尼。一切五篇戒尽与实觅毗尼。一切五众尽与此毗尼。比丘比丘尼现前三众不现前。白四羯磨与实觅毗尼。有五种非法五种如法。五种非法者。有比丘犯波罗夷罪。先言不犯后言犯。若僧与是人实觅毗尼。是名非法。何以故。是人应与灭摈故。有比丘犯僧残波夜提波罗提提舍尼突吉罗。先言不犯后言犯。若僧与是人实觅毗尼。是名非法。何以故。是人随所犯应治故。五如法者。有比丘犯波罗夷。先言犯后言不犯。若僧与是人实觅毗尼。是名如法。何以故。是人应与实觅故。若比丘犯僧残波夜提波罗提提舍尼突吉罗。先言犯后言不犯。若僧与是比丘实觅毗尼。是名如法。何以故。是人应与实觅毗尼故。实觅毗尼行法者。是比丘不应与他受大戒。不得受他依止。不应畜新旧沙弥。不得教比丘尼法。若僧羯磨教化比丘尼不应受。僧所与作实觅毗尼。罪更不应犯。若似是罪及过是罪。亦不应作。不应呵僧羯磨。亦不应呵作羯磨人。不应从他乞听。不应遮说戒。不应遮受戒。不应遮自恣。不应出无罪比丘过罪。不应共同事。应调伏心行随顺比丘僧意。若不如是行法者。尽形不得离是羯磨

    第六事

多觅毗尼者。多求因缘断多处未断。从多人断故。名多觅毗尼。行筹时断事时。一切僧集不得取欲。何以故。或多比丘说非法故。是名一切行筹。此中一切比丘不应取欲。如行钵法也。若不能断。乃至彼处僧坊中。若有三人二人一人比丘持三藏四众所重者。应到彼处应语彼一比丘。如前次第事具足向说。是大德比丘应作是语。不可二人相言俱得胜也。是中必一胜一负。如是语者。是名如法说。若不如是语者。是名非法说。是诸相言比丘。若如法断事已。还更发起波逸提。若但诃责言。是断事不如法犯突吉罗。闼赖吒利者。闼赖名地。吒利名住。智胜自在于正法不动。如人住地无倾覆也。应灭期者。恐事缠难断。当云受语有偏故。亦恐前人求及于己故也。应舍付僧者。以从僧中来既不能灭。宜还付本故也。僧现前者。明僧既集。中有能遮者。而不遮则僧和合。名现前也。乌回鸠罗者。乌回名二。鸠罗名平等。心无二其平如秤。今必以二人有五法。五法者。不随爱故舍有罪。不随嗔故罚无过。不畏彼故而违法。不痴故不畏罪。非法轻断事也。知断不断故。名乌回鸠罗。与欲以小远去者。恐僧中有相佐助事。必叵断故也。所以取欲者。令有相助者后更无言故。更立乌回鸠罗者。诤事逐增。恐有破僧之由妨行道故。故更差多方能善断事者。不必具五法也。遣使近处僧者。若就他处事必增多难断故遣使也。彼既来已。若彼中能者云七日尽已破安居者。以未开三十九夜故也。开某处乃至持摩多勒伽者。佛法有二柱能持佛法。谓坐禅学问。故求此人辈。亦中有大德人。令诤事羞难故也。传事人断者。恐至他处难灭。亦望其人向他处。僧有愧受谏故。又坐禅道远之劳故。亦恶事得灭为善故。作期者。以事起从夏故。除夏三月取余九月明事。若叵断其当作方宜令断。莫令还至夏分也。若能者付以传事便还。所以界外令满众者。明差四人使界外灭。若事可断。必令后不起故。以重故也。为五事故。立行筹人也。疾灭也。强者。有三。一其人身有力。二倚有力人。三有钱力往来。从一住处至一住处者。明事久既经多处不断事缠坚结。其人无惭无愧心转奸巧故。所以行筹者事既难断。若说一是一非。必增其恶心故。行筹于众人前。好恶自伏理亦无偏藏。行筹者。行筹人心为非法人故。望取非法者多。若在明处助非法者。着取非法筹故也。期行者。要共相。亲者。作要也。一切僧取筹者。以此事重故。一切悉集说戒自恣。虽要犹有不来。此将欲令相助者后无语故。亦恐受欲人多取非法筹故。四众所尊重者。以上取二种筹停等叵断故。就有德人。众所归伏无不用语。故有不随者。羞亦为诸人所笑。必受语传事人多说事不说人。大德比丘亦直说事。是非不说人。有事二人各自内知。而伏则胜负相现也。还发起波逸提者。以二罪印之。令彼此后更无言故结罪也

    第七事

何以名布草毗尼。或有一住处。诸比丘喜斗诤相言。是诸比丘应和合一处已应作是念。诸长老。我等大失非得大衰非利大恶不善。我等以信故。佛法中出家求道。然今喜斗诤相言。若我等求是事根本者。僧中或未起事便起。已起事不可灭。作是念故白僧。若僧时到僧忍是事。以布草毗尼灭。是名白。诸比丘应分作二部。是中若有上座大长老。应语此一部言。我等大失非得大衰非利大恶非善。我等信故佛法中出家求道。然今喜斗诤相言。若我当自屈意。我等所作罪。除偷兰罪。除白衣相应罪。是汝等现前发露悔过不覆藏。是中若无一比丘遮是事者。应到第二部众所。是中若有长老上座应语言。我等大失非得大衰非利大恶非善。我等信故佛法中出家求道。今喜斗诤相言。若我等求是事根本者。僧中或有未起事便起。已起事不可灭。今汝等当自屈意。我等所作罪。除偷兰遮。除白衣相应罪。今自为及为彼故。当现前发露悔过不覆藏。诸比丘言。汝自见罪不。答言见罪。如法悔过莫复更起。第二部众亦如是说。是名如布草毗尼法

一切斗诤诽谤犯罪和合事。现前毗尼所摄。唯有下四事。用上七毗尼灭无余也

一切善不善无记。及十四破僧六诤本生。通名诤事(在人名诤在僧名事)用三毗尼灭(现前多觅布草)从见闻疑根生。作不作俱言犯。通名出事(在人名出在僧名事)用四毗尼灭(现前忆念不痴实觅)从身作口作身心作口作生。通名犯事(方便名犯事成名破不悔名越)用二毗尼灭(现前自言)从白白二白四布萨自恣差十四人。从僧至僧为事本。通名作事用一毗尼(现前)

萨婆多毗尼毗婆沙卷第九


沙弥尼戒经

    No. 1474

沙弥尼戒经

        在后汉录

沙弥尼初戒。不得杀生。慈愍群生如父母念子。加哀蠕动犹如赤子。何谓不杀。护身口意。身不杀人物蚑行喘息之类。而不手为亦不教人。见杀不食。闻杀不食疑杀不食。为我杀不食。口不说言当杀当害报怨。亦不得言死快杀快。某肥某瘦。某肉多好。某肉少也。意亦不念当有所贼杀。于某快乎。某畜肥某瘦。哀诸众生如己骨髓。如父如母如子如身。等无差特。普等一心常志大乘。是为沙弥尼始学戒也

沙弥尼戒。不得盗窃。一钱以上草叶毛米。不得取也。主不手与不得取。口不言取。心不念取。目不爱色。耳不爱声。鼻不盗香。舌不偷味。身不贪衣。心不窃欲。六情无著。常立权慧。则曰不盗。是为沙弥尼戒也

沙弥尼戒。不得淫泆。何谓不得。一心清洁身不淫泆。口不说淫。心不念淫。执己鲜明。如虚空风无所倚着。身不行淫。目不淫视。耳不淫听。鼻不淫香。口不淫言。心不存欲。观身四大本无所有。计地水火风无我无人无寿无命。何所淫泆。何所著乎。志空无相愿。是为沙弥尼戒也

沙弥尼戒。不得两舌恶言。言语安详。不见莫言见。不闻莫言闻。见恶不传。闻恶不宣。恶言直避常行四等。无有非言。言辄说道。不得论说俗事。不讲王者臣吏贼事。常叹经法菩萨正戒。志于大乘不为小学。行四等心。是为沙弥尼戒也

沙弥尼戒。不得饮酒。不得嗜酒。不得尝酒。酒有三十六失。失道破家危身丧命。皆悉由之。牵东引西。持南着北。不能讽经不敬三尊。轻易师友不孝父母。心闭意塞世世愚痴。不值大道其心无识。故不饮酒。欲离五阴五欲五盖。得五神通得度五道。是为沙弥尼戒也

沙弥尼戒。不得持香华自熏饰衣被履缕。不得五色。不得以众宝自璎珞。不得着锦绣绫罗绮縠。不得绮视。当着粗服青黑木兰及泥洹里衣低头而行。欲除六衰。以戒为香。求诵深法以为真宝。三十二相以为璎珞。得殖众好以为被服。愿六神通无碍。六度导人。是为沙弥尼戒也

沙弥尼戒。不得坐金银高床绮绣锦被宝綩綖。不得念之。不得教求索好床榻席五色画扇上好[肖*毛]拂。不得着臂钏指镮。直信戒惭愧施。博闻智慧一心精专。常求三昧以为床榻。心不动摇。众慧自然以为坐具。七觉不转志于道心。是为沙弥尼戒也

沙弥尼戒。不得听歌舞音乐声拍手鼓节。不得自为亦不教人。常自修身顺行正法。不为邪行。一心归佛诵经行正。以为法乐。不为俗乐。听经思惟深入大义。自不有疾。不得乘车马象。当念轻举八不思议神通之达。以为车乘度脱八难。是为沙弥尼戒也

沙弥尼戒。不得积聚珍宝。不得手取。不得教人。常自专精以道为宝。以经为上。以义为妙。解空无相无愿为本。至于三脱不求贪欲。欲离九恼。住道甚久无穷无极。无有边际亦无所住。是为沙弥尼戒也

沙弥尼戒食不失时。常以时食不得失度。过日中后不得复食。虽有甘美无极之味。终不复食。亦不教人犯。心亦不念。假使无上自然食来。亦不得食也。若长者国王过日中后。亦不服食。终死不犯。常思禅定。一切饮食虽有所食。裁自支命。欲令一切解深达愿。得十种力以为饮食。是为沙弥尼戒也

沙弥尼已受十戒。原道思纯。能行是十事。五百戒自然具足。譬如人头手足眼耳鼻口身意腹背不毁。诸根具足肠胃肺肝五藏诸节筋脉悉具。譬如树根安隐具足不枯腐朽。茎节枝叶华实自然弘茂。沙弥尼如是。能备十戒之本。其五百戒皆悉周满可逮神通无所不达。譬如好田种不腐败。风雨时节五谷丰熟。人民得治。沙弥尼如是能尊十戒。五百戒则为举矣。譬如国君风化普平万民安宁。沙弥尼如是。若能具十戒者。五百之戒自然普备。若父母慈和。子孙眷属奴客婢使自然率从

又沙弥尼常尊三宝敬师和上。过于父母百千万倍。父母一世。和上度无极无限。念报反复不造反逆。常厌秽身如人闭狱堕坠溷厕。不贪女身不烧色欲。如于大火。譬若处贼。心念一切。如父如母如子如身。常惭本行怀态不快。乃获斯身。当解本无。犹如幻化。无男无女从行得之。本无五道。况男女乎。求大乘者。了一切空如幻化梦影响野马芭蕉深山之响缘对而生。本无所有。信色如影。痛痒如芭蕉。思想如野马。生死如泡。识如幻非我。因缘合成无缘则无。独来独去。无一随者。欲为道者。权慧为父母乐法为兄弟。不离深义以为和上。慈悲喜护谛住正法。以为男女。六度无极以为伴党。神通之慧以为车乘。不违经戒思惟空义。以为屋宅。又沙弥尼不得独行。同类为伴。二人若三人。若无沙弥尼。当与清信女俱行。若婢使不得与大沙弥男子同床座坐。不妄语。又不得比寺居止。自不疾病。不得数往反檀越。请读经乃说。不得自用。等辈相教随年恭顺。不得慢恣转相导说。若有过失屏处相谏。莫于众中说闻善见善乃可宣扬。闻恶见恶不得传说。唯可白和上。不得语余人。常自克责。见善思及。见恶自察。悲哀彼人意不及故。若作沙弥尼求和上者。当得好聪明智慧奉顺法者。世世能度人。譬若有船完具牢坚在所能度至于彼岸。若师不聪明。行不应法。非是大师。持作和上。譬如坏船乘欲度海中路而没。既溺众人。师亦并命无有遗余。其初持法授人经戒。正则为师。闻大师欲以为和上。本作沙弥尼。不得彼者。遥称名礼之以为师。未必面见。心近则近。心远则远。身虽相近心乖不同。相去亿里沙弥尼行路。不得与男子共行同道相随。不得与男子沙门比房同寺。各各别异法之大节焉

沙弥尼戒经一卷


沙弥尼离戒文(沙弥尼戒经)

    No. 1475

沙弥尼离戒文(沙弥尼戒经)

        东晋失译

善女人字某言。某所受秽恶之身。充弊人流不堪下行。克己自悔。愿为弟子。受持正戒终身奉行

用何等故。作沙弥离。用归命佛归命法归命比丘僧故。用剃头被袈裟故。几戒沙弥离。有十戒

一尽形寿不得杀生。不得教人杀生

二尽形寿不得盗。不得教人盗

三尽形寿不得淫。不得教人淫

四尽形寿不得嫁。不得教人嫁

五尽形寿不得妄语。不得教人妄语。六尽形寿不得歌舞。不得教人歌舞。不得弹筝吹笛

七尽形寿不得着香华脂粉。不得教人着脂粉

八尽形寿不得于高好刻镂床上卧。不得教人作好床卧

九尽形寿不得饮酒。不得教人饮酒

十尽形寿过日中不得复食。不得教人食

威仪七十事

  不得着缯彩衣　　不得作彩衣与人
  不得恶口相调　　不得教人作不急语

不得与优婆夷相看形体大笑

不得于避处裸形自弄身体

不得照镜摩抆面目画眉

不得嗔恨羞惭恚语

不得思念与男子共交会问优婆夷何如

不得坐毛绵上。不得着靴履。不应作履

不得贪家钱财强索人物

不得坐。他妇女床上开器视衣言是好彼丑十六以上应作沙弥离。素无瑕秽贞良完具。无所毁辱。父母见听乃得为道。素不贞良不应为道。石人匿病不应为道

不得与比丘僧同室宿。不得共坐。不得相形笑。不得卧沙弥离衣被中。不得错法衣共器误着僧衣。不得手授男子物。设欲与物。当置着地却使取之。不得与优婆夷露浴。不得独至僧房问义。不得说浴事。不得笑经语。不得左右顾视。不得手据机上

受经有五事。当与长老尼共行。去坐六尺。长跪。但得问义。当识句逗

省师病有四事有亲应得省。三人共行。去床六尺。长跪问讯语讫应去不得论事

夜卧有五事。当头输佛。当伛卧不得申脚。不得仰向频申。不得袒裸自露。不得手近不净处

至檀越家有五事。当先到精舍礼佛。次礼师僧优婆夷请乃应入。当报师僧。直视六尺当独坐床

止檀越家。有五事不应法。不得至妇女房中语戏。不得至窖下坐食。不得与婢共私语。不得独至舍后。不得与人共上厕。不得上男子厕上

入浴室有五事。不得与优婆夷共洗。不得与婢使共洗。不得与小儿共洗。不得取他成事水。不得自视形体隐处

烧香有五事。不得左右远视。不得独与优婆塞共烧香。不得独与婢使。不掣脚。不得背像。朝起有五事。先当清净却着法衣。先礼经像。却礼师僧。去六尺问讯。却行出户。师与语有五事。问经戒义不知当请。若见责当即自悔过。不得覆藏。不得自理。不得恶眼视师

浣衣有四事。当于屏处当长跪。当弃恶水于屏处。不得于人道径中。当待燥燥应收。不得令堕地

行道有五事。当与三人共行。当与大尼共行。若当与优婆夷共行。当视前六尺。当着法衣。师云。女人受性大出杂态姿。则喜好淫泆无礼。故为女人。今以自觉。得蒙释迦文佛大恩。普三界开视道地得值法。其有自识本行。归念佛者少

佛言。观见人间。上至二十八天。下至十八地狱。皆苦无乐。故结戒以训后生。佛告诸弟子。为道至难。鲜能去家断绝六情。受佛重戒捐弃爱欲。有其然者少

佛告诸弟子。汝慎莫妄度沙弥离。女人姿态难保悦。在须臾以复更生恶意。譬如水泡一起一灭。无有常定。能见人根观其大行。见其宿罪。今以尽度。便得道者急当度之。自非菩萨阿罗汉。不可度尼

除觐说戒节度

维那先具舍罗筹香火戒文。净扫除精舍。却鸣揵槌。烧香礼佛呗咒愿意。咒愿鬼子母。各便就坐。整法服叉手静默。维那便行香火人。各说一偈。维那在户里三唱。白衣出除觐布萨竟。三弹指令白衣远去。莫令闻说戒音声讫。开户维那唱言。静坐除觐默今布萨。亦三过唱讫。便维那捉筹。上座尼前长跪。布萨人与一筹。亦自取讫。便还敛筹。别着一处。还取未布筹。手捉从上座尼前问。谁脱不受筹。未得者便当言未。已得者当默讫竟。维那数筹有几人。数知少多。维那唱言。除觐等若干人。随年号月。十五便言十五日。月尽便言三十日。于某州某郡某县某檀越精舍中说戒。愿持说戒功德归流。大檀越眷属一切安隐。命过者生天人中增益功德。十方厄难普使解脱。各咒愿讫。维那长跪上座尼前。请能说戒人令说戒。复请一人三呗读经。读经竟呗。呗讫。上座普咒愿。下座尼皆长跪受咒愿。维那唱。皆共礼佛礼般若讫。下坐尼皆礼大尼讫。便维那长跪唱言。随所安

请说戒读经人。共别坐一床上

沙弥尼离戒文按此戒名。国本宋本及开元录。皆云沙弥尼离戒文。丹本即云沙弥尼杂戒文。今捡正文。诸本皆非。何则。按此译之离字。与他译之尼字。但梵音楚夏耳。曾不是沙弥尼之离戒文。亦不是沙弥尼之杂戒文。并乖正文。故今可直云沙弥离戒文。乃正耳。然无所据。不敢即正。直书其意。以待好古雅正君子焉


沙弥十戒法并威仪

    No. 1471

    沙弥十戒法并威仪序

夫乾坤覆载。以人为贵。立身处世。以礼仪之。本君臣父子非礼不立。防邪止奸非礼不禁。和国崇婚非礼不定。逊悌乡邑。非礼不通。师徒朋友非礼不敬。吊丧问疾非礼不行。昔先贤垂范。永以为轨则。丧祭之仪世务之急。是以信行之机旦夕之要。今世浮游。或轻或重。或深或浅。不谐法则。以致讥论

沙弥十戒法并威仪一卷

        失译附东晋录

佛语舍利弗。汝去度罗睺罗出家。舍利弗言。我当云何度。佛教言。我罗睺罗。归依佛归依法归依僧(如是三说)我某甲。归依佛竟归依法竟归依僧竟(如是三说)尽形寿不杀生。尽形寿不盗。尽形寿不邪淫。尽形寿不妄语。尽形寿不饮酒佛婆伽婆出家。我某甲因和上某甲。随佛出家(如是三说)佛婆伽婆出家。舍俗服着袈裟。我某甲。因和上某甲。随佛出家。舍俗服着袈裟

尽形寿不杀生持沙弥戒

尽形寿不盗持沙弥戒

尽形寿不淫持沙弥戒

尽形寿不妄语持沙弥戒

尽形寿不饮酒持沙弥戒

尽形寿不着香华鬘不香涂身持沙弥戒

尽形寿不歌舞倡妓不往观听持沙弥戒

尽形寿不坐高广大床持沙弥戒

尽形寿不非时食持沙弥戒

尽形寿不捉持生像金银宝物持沙弥戒

汝今已受沙弥十戒竟。当尽形寿顶戴奉持。终身不得犯。应供养三宝。和上阿阇梨一切如法教。不得违逆。上中下坐心常恭敬。勤求方便坐禅诵经学问劝助作福。闭三恶道开涅槃门。于比丘法中增长正业。得四道果沙弥之戒。尽形寿不得残杀伤害人物。当念所生及师友恩。精进行道欲度父母。慎无愠讼。推直于人。引曲向己。蠉飞蠕动蚑行之类。无所克伤。施恩济乏使其得安。心念为人。言无及杀。见杀不食。闻声不食。疑杀不食。若见杀时当起慈心。誓吾得道国无杀者。草木不用慎无毁伤。有犯斯戒非沙弥也

沙弥之戒。尽形寿不得偷盗。圭合铢两一无欺人。心存于义口不教取。贩卖仆使奴婢。借赁僮客。或有惠施一不得取。无服饰珍玩高床帏帐。衣趣蔽形无以文彩。食趣支命不得嗜味。无得贮畜谷粮。藏积秽宝人与不受。受则不留转济穷乏。常为人说不贪之德。宁就断手不取非财。有犯斯戒非沙弥也

沙弥之戒。尽形寿不得取妇畜养继嗣。防远女色禁闭六情。莫睹美色。目不瞻眄。心无念淫。口无言调。华香脂粉无以近身。好声邪色一无视听。宁破骨碎心焚烧身体不得为淫。虽淫劮而生垢秽。不如贞洁而死。有犯斯戒非沙弥也

沙弥之戒。尽形寿诚信为本。不得两舌恶骂妄言绮语。前誉后毁证人入罪。徐言持政无宣人短。为人说法思合议理。见有诤者两说和善。夫士处世斧在口中。所以斩身由其恶言。不慎言者非沙弥也

沙弥之戒。尽形寿不得饮酒。无得尝酒。无得嗅酒。亦无粥酒。无以酒饮人。无饮药酒。无止酒舍。酒为毒水众失之原。残贤毁圣招致祸殃。四等枯朽去福就罪。靡不由之。宁饮洋铜。慎无犯酒。有犯斯戒非沙弥也

沙弥之戒。尽形寿。不得习弄兵仗手执利器。畜养六畜笼系飞鸟。车舆骑乘快心恣意。驰骋游猎弹射禽兽。无得放火焚烧山林伤害众生。无得破决湖池堰塞泒渎。钩钓鱼网残害水性。有犯斯戒非沙弥也

沙弥之戒。尽形寿不得习弄棋局摴蒲博塞。诤于胜负弄舞调戏。吟咏歌音手执乐器。琴瑟箜篌筝笛竽笙。以乱道意。无得垦掘山泽耕犁田亩。修治园圃种殖五谷。船车贾作于市贩买。与百姓诤利。有犯斯戒非沙弥也

沙弥之戒。尽形寿。不得学习奇技巫医蛊道。时日卜筮占相吉凶。仰观历数推步盈虚。日月薄蚀星宿变怪。山崩地动风雨旱涝。岁熟不熟有疫无疫。一不得知不得论说。国家政事平量优劣。出军行师攻伐胜负。有犯斯戒非沙弥也

沙弥之戒。尽形寿。男女有别居。不同寺迹不相寻。无同船车俱载。逢无道谈。若持异物无察视之。远嫌避疑。无书疏往来。假借裁割浣濯衣服及所乞求。彼若惠己亦不宜受。若欲往时必须耆年。慎无独行。无止坐宿。有犯斯戒非沙弥也

沙弥之戒。尽形寿。非贤不友。非圣不宗。不孝之子。屠儿猎者。偷盗嗜酒之徒。志趣邪僻。履行凶崄。不得交游往来之艺浊亏损道行。法服应器常与身俱。非时不食。非法不言。食则无语卧则无谈。精勤思义温故知新。坐则禅思。起则讽诵。戒行如是真佛弟子(说戒已竟次说威仪)

已受沙弥十戒。为贤者道人。次教之当用。渐渐稍从小起。当知威仪施行所应。当知和上几岁三师名字。当教识知初受戒时岁日月数。当知事和上有几事。亦当知随事阿阇梨有几事。亦当知给杨枝澡水有几事。亦当知授袈裟摄袈裟及持钵有几事亦当知捉锡杖持履有几事。与和上阿阇梨俱应请时。若至国王家时。若至迦罗越家时。若至婆罗门家时。若连坐饭时。若别坐饭时。若俱入城乞食时。若俱还时。至故处时。若日晚时。若止水边饭时。若道边时。若树下饭时。若自先去住相待时。若合钵食时。若转贸钵时。若俱共对饭时。若前后饭时。若饭已澡漱时。若澡钵去时。各当具知有几事。当知给众僧作直日时。各当知有几事。年满二十欲受具足戒时。皆悉当知设为贤者。比丘所问不具对者。不应与受具足戒。何以故。作沙弥乃不知沙弥事所应施行。沙门事大难作甚微妙。贤者沙弥。卿且去熟学当悉闻知。乃应授与具足戒。所以卿不知沙弥法者。但未谛知身苦故。不伏意耳。而反欲受具足戒。今授卿具足戒者。人谓佛法易行沙门易作。不知佛道至妙。罪福运行法律交互。以是数日之中相之。是故当先问。设能具对能如法者。三师易得耳师教沙弥有五事。一者当敬大沙门。二者不得呼大沙门名字。三者大沙门说戒经时不得盗听。四者不得求大沙门长短。五者大沙门误失时。不得转行说。是为沙弥威仪

又教沙弥有五事。一者不得屏处骂大沙门。二者不得轻易大沙门于前戏笑。效其语言形相行步。三者见大沙门过。即当起住若读诵经。若饭时若作众事。不应得起。四者行与大沙门相逢。当下道止住避之。五者若调戏时。若见大沙门即当止谢言不及。是为施行所应尔

沙弥事和上有十事。一者当早起。二者欲入户当先三弹指。三者具杨枝澡水。四者当授袈裟却授履。五者当扫地益澡水。六者当襞被[木*尤]拂拭床席。七者师出未还不得舍房中去。师还当逆取袈裟内襞之。八者若有过和上阿阇梨教诫。不得还逆语。九者当低头受师语去。当思念行之。十者出户当还牵户闭之。是为事和上法。教沙弥事阿阇梨有五事。一者视阿阇梨。一切当如视我。二者不得调戏。三者设呵骂汝。不得还语。四者若使汝出不净器。不得唾恶怒。五者暮当按摩之。是为事阿阇梨法也

事阿阇梨法。沙弥事师。当早起具杨枝澡水。有六事。一者断杨枝当随度数。二者当破头。三者当洗使令净。四者当易故宿水。五者当净澡军持。六者当满中水。持入不得使有污湔有声。是为具杨枝澡水法

授袈裟有四事。一者当徐徐一手排一手捉下授之。二者当次视上下。三者当止住持师衣已。四者当上着师肩上。是为授袈裟法

摄袈裟有四事。一者当视上下。二者不得使着地。三者当着安常处。四者覆上。是为摄袈裟法

持钵有四事。一者当洗令净。二者拭令燥。三者带令坚。四者不得使有声。是为持钵法

持锡杖有四事。一者取拭去生垢。二者不得着地使有声。三者师出户乃当授。四者师出还当受取。若俱行若入众若礼佛。亦当取持。是为持锡杖法

持履有四事。一者当先抖擞之。二者当视次比之。三者当澡手。不得便持袈裟。四者师坐当取次比之。是为持履法

若俱应请连坐饭时。有四事。一者坐当离师六尺。二者当视师达嚫竟乃应授钵。三者不得先师食饭。四者师饭已当起取钵自近。是为连坐饭时法也

别坐饭时有四事。一者当立住师边。二者师教食去乃当坐去。三者头面着地作礼。四者食饭不得倨坐。上戏饭已当至师边住。师教还坐乃应坐。是为别坐饭时法也

入城乞食时有四事。一者当持师钵。二者当随师后。不得以足蹈师影。三者于城外当取钵授师。四者入城欲别行当报师。是为行乞食时法

俱行还至故处有四事。一者当先徐开户出坐具敷之。二者澡师手已乃却自澡。三者当授师钵自却叉手住。四者当豫具澡豆手巾等。是为还归饭时法

过水边饭时有四事。一者当求净地。二者当求草作坐。三者当取水澡师手已还自洗手。已乃却授师钵。四者师教使饭。当作礼却坐。是为水边饭时法

止阴树下饭时法。有四事。一者当持钵挂着树上采取叶作坐。二者取水澡师手。设不得水。取净草授与师。三者还取钵授师四者当豫具净草澡师钵已。却以草熟拭钵乃去。是为树下饭时法

道中相待有三事。一者持钵着净地作礼如事说。二者当视日早晚。可疾还归若道止。三者当取师钵。并持随师后去。是为道中相待时法

合钵饭时有二事。一者若师钵中无酪酥浆。当自取所得钵饭授师。若师不取。旦当却住。二者徐取师钵中半饭。出着净地树叶上。却自取钵中半饭。着师钵中却住。是为合钵饭时法

转贸钵饭时有三事。一者若师钵中得美膳者。自得不如者便当授师。二者师欲贸钵当让不受。三者师坚呼贸钵当取再餐。便当拭钵还授师。是为贸钵饭时法

对饭时有三事。一者当授师钵乃却坐饭。二者当数视师所欲得。即当起取与。三者食不得大疾亦不得后竟以起。当复问欲得何等。师言持去乃当取去。是为对饭时法

前后饭时有三事。一者授师钵具已。当却至屏处住。听师呼声即当应之。二者当豫取澡水着一边。三者师饭毕当澡师手却住。师教去饭。乃当作礼去饭。是为前后饭时法

饭已澡钵有三事。一者澡漱已。当先取师钵澡。令净已着树叶上。二者却自澡钵已。亦着树叶上。先取师钵已手摩令净。燥内着囊中付师。三者还自取钵拭令燥。亦内着囊中带之止住。是为燥钵时法

澡钵去时法有三事。一者师言我今欲过某许贤者某自先归。二者头面着地作礼便去。三者独还去。不得过余聚落中戏笑。直归故处诵经。是为澡钵去时法

沙弥入众有五事。一者当明学。二者当习事。三者当给众。四者当授大沙门物。五者欲受大戒时。三师易得耳

复有五事。一者当礼佛。二者当礼比丘僧。三者当问讯上下坐。四者当留上座坐处。五者不得诤坐处

复有五事。一者不得于坐上遥相呼语笑。二者不得数起出。三者若众中呼沙弥某甲。即当起应。四者当随众僧命。五者摩摩帝呼有所作。当还白师。是名入众时法用

沙弥作直日有五事。一者当惜众僧物。二者不得当道作事。三者作事未讫。不得中起舍去。四者若和上阿阇梨呼不得便往。应当报摩摩帝。五者当随摩摩帝教令不得违戾。是为作直日法

择菜有五事。一者当却根。二者当齐头。三者不得使有青黄合。四者洗菜。当三易水令净。已当三振去水。五者作事毕竟。当扫处令净

复有五事。一者不得私取众僧物。二者若有所欲取。当报摩摩帝。三者尽力作众僧事。四者当扫除食堂中。乃却布席空案。五者当朝暮扫除舍后。益水弃灰土

汲水有十事。一者手不净。不得便用汲水。当先澡手。二者不得大投罐井中使有声。三者当徐徐下罐。不得大挑击左右着使有声。四者不得使绳头还入井中使有声。五者不得持履覆井栏上。六者不得持罐水着入釜中。七者不得持罐置地。八者当洗澡器令净。九者举水入当徐徐行。十者着屏处不得妨人道中

澡釜有五事。一者当澡釜缘口上。二者当澡釜缘里三者当洗腰腹。四者澡里底。五者当三易水

吹窖有五事。一者不得蹲吹火。二者不得然生薪。三者不得倒然湿薪。四者不得然腐薪。五者不得以热汤浇火灭

扫地有五事。一者当顺行。二者洒地不得有厚薄三者不得有污湔四壁。四者不得蹈湿地坏。五者扫已即当自撮草粪弃之

比丘僧饭时沙弥扫地。有五事。一者常却行。二者不得挑手持。三者过六人土作聚。四者悉扫令遍为善。五者即当自手扫除持出弃之

持水澡罐泻水。有五事。一者一手持上。一手持下。不得转易二者当近左面坚持直视前。三者当视人手浇下水。不得多不得少。正当投人手中。四者下水当去人手四寸。不得高不得下。当相视水多少。设水少不足一人。当益水不得住人手。五者以澡手还着袈裟如法

持当盘有五事。一者不得曳盘使有声。二者当两手坚持左面。三者当随人手高下。不得左右顾视。四者澡盘中水满当出弃之。不得浇人前地。五者已当过澡手还着袈裟如法

持手巾有五事。一者当左手持下头右手持上头授人。二者去坐二尺。不得倚人膝。三者持手巾。不得随障人口。四者人拭手未放巾不得引去。以下竟当持付主若着故处。五者已当澡手还着袈裟如法

布履有五事。一者当先抖擞去中所有。二者当从上座起。三者当从澡盘后示主令自识。四者不得持左着右。皆当下意沙弥。五者已竟当还澡手着袈裟如法

沙弥澡钵有七事。一者钵中有余饭。不得便取弃之。二者欲弃中饭当着净地。三者当用澡豆若草叶。四者澡钵不得于净地当人道中。五者澡钵当使下有枝。六者当更益净水。不得远弃污湔人。七者欲弃钵中水。当去地四寸。不得使有高下

拭钵有五事。一者当更澡手拭令燥。二者当持净手巾着膝上。三者当拭里使燥。四者手已拭表。不复得拭里。五者钵已燥。即当持净手巾并覆。着囊中安常处

行会饭时教沙弥持钵。有五事。一者不得置地。二者不得累使有声。三者不得持杨枝着钵中。四者人来授案。不得持钵榰着人案上。五者不得从人后授钵。当正从前亦不行众中。视师饭已当起取钵还坐。是为持钵法

为师遣行答谢人。有七事。一者当直往二者当直还。三者当识师所语。亦当识人报语。四者不得妄有所过。五者若所索不得止留宿。六者不得调譺。七者出行当有法则

沙弥给比丘僧使未竟。不得妄入大沙门户。有三事得入。一者若和上阿阇梨暂使往。二者若倩有所取。三者欲往问经应得入

欲入门户有七事。一者当三弹指乃得入。二者不得当人道住坐若障火光。三者不得妄语他事。四者当叉手如法说。五者若教坐不得交脚。六者不得调譺。七者不得障人先。欲出户当向户出。回面向户却行而出。不得背去

独使沙弥远出行当教上头。有三事。一者彼人问卿和上名何等。便报言字某甲。二者复问卿和上作沙门来几岁。便报言若干岁。三者复问卿和上是何许人。便报言某郡县人。设复问卿阿阇梨名何等人。便报言字某甲。复问卿阿阇梨年几许。便报言年若干。复问卿阿阇梨是何许人。便报言是某国县人。若复问贤者名何等字。便报言字某甲。复问卿作沙弥已来几时。便报言若干岁若干月若干日若干时。是为知和上阿阇梨亦自知时名字岁日月数

入浴室有五事。一者低头入。二者入当避上座处。三者上座读经时不得狂语。四者不得以水互相浇。五者不得以水浇火灭

复有五事。一者不得调譺。二者不得破中盆[央/瓦]。三者用水不得大费。四者不得潘中澡豆麻油。五者当疾出去不得止中浣衣

沙弥至舍后行有十事。一者欲大小便即当行。二者行不得左右顾视。三者至当三弹指。四者不得迫促中人使出。五者已至上复三弹指。六者不得大咽。七者不得低头视阴。八者不得弄上灰土。九者不得持水浇壁。十者已还当澡手。未澡手不应持物

复有五事。一者不得正唾前壁。二者不得左右顾视望。三者不得持草画壁地。四者不得持火[火*曹]画地及壁。五者不得久固圊厕上。当自下去。设当逢人不得为作礼。当避道去

说沙弥威仪式竟

沙弥七十二威仪。总有十四事

师与语有二事。一者不得报语。二者不得自理

沙弥为师作礼有十事。一者师头前有盘不应作礼。二者师坐禅不应作礼。三者师经行不应作礼。四者师食不应作礼。五者师说经不应作礼。六者与师相逢左面不应作礼。七者师梳齿不应作礼。八者欲入户。作礼应弹指三返。师不应应去。九者不得离师七步。十者师户开应作礼。早起入户有五事。一者整理衣被。二者出瓯。三者扫地。四者问经五者与物。襞三衣有五事。一者不得当前。二者当于左面。三者当识衣表里。四者不得倒襞。五者当置常处。随师行有五事。一者不得过历人家。二者不得止住道与人共语。三者不得左右顾视。四者当低头随师后。五者到檀越家。当住一面师教应坐

给师所须有五事。一者当得杨枝。二者当得澡豆。三者不得宿水。四者当更汲。五者手巾用应浣净。沙弥洗有五事。一者不得向塔。二者不得向和上。三者不得向阿阇梨。四者当于屏处。五者当自取水。不得取他人成事水。暮入户有五事。一者当扫除床。二者当理衣被。三者当内瓯。四者当然灯。五者教卧应去出者当背向。牵户闭。沙弥从师受经。有五事。一者整衣服。二者当叉手作礼。三者不得前却。四者两足当齐。五者当小偻。沙弥授师三衣。有五事。一者当洗手。二者当与安陀卫。三者当与忧多罗僧。四者当与僧伽梨。五者当与手巾。沙弥洗钵有五事。一者当得牛粪灰。二者当得澡豆。三者去地七寸。四者不得有声三易水欲捐水不得洒地。五者当令燥。沙弥扫地有五事。一者不得背师。二者不得逆扫。三者当令净。四者不得有迹。五者当即时弃却。沙弥随师至檀越家。有五事。一者当持钵。二者当持手巾。三者当搏户。四者到檀越家索净水洗钵。五者师坐捉手巾钵授与师。乃应还自坐。沙弥入浴室。有五事。一者不得先师入。二者不得在坐前。三者师未获水不得动。四者设欲揩背先当拟之。五者浴已当先取可着衣。沙弥礼节威仪又朝晡。问讯礼敬。有十三事。一者当早起澡漱。二者当整顿衣服。三者问讯起居。四者师若在内欲进之法。当先脱头上所著物及足所著物。五者不得蹑迹。六者当住外立三弹指呼前乃进入。七者当头面着地稽首为礼。八者若命令坐三让乃坐。九者坐必端严。十者有问即对应声分明。十一者无云即默。十二者事必宜退稽首如初。十三者欲出户时。当回身还向去。沙弥又持师澡罐。有十五事。一者净洗澡瓶。二者当有常处。三者当令净水满器。四者不得宿水。五者豫具杨枝。六者治杨枝当令如法。七者澡瓶去膝一尺。八者执澡瓶。当左手持上右手捧下。九者泻水调适当得其多少。十者不得令有声。十一者手巾必有常处。十二者持巾左执其手巾右以授师。十三者弃不净水当有常处。十四者无令浇灒净地。十五者用巾已当复常处。又洒扫拂拭床有八事。一者常向于尊。二者不得背。三者洒地当轻手裁水多少。四者用粪箕当以自向。五者弃粪当有常处。六者扫拭床席。七者襞衣被[木*尤]。八者扫拭床不令有声。又持师食有十四事。一者当具净巾。二者所欲进食皆当两手捧下。三者当直进。四者跪以授师。五者不得道中与人言笑。六者进食不得有声。七者凡所进饮食当适其寒温。八者匙[木*著]当令净洁。九者若有所益必令调均。十者住必有常处。十一者宜端严。十二者食毕敛器务令徐徐。十三者随次所举。十四者扫洒澡器一如常法。又取法衣及履。有十事。一者当左执其上右执其下。二者当跪以授师。三者当襞袈裟。不得以口衔之。四者不得振令有声。五者还复其常处。六者以巾覆上。七者取履当先抖擞之。八者不得使有大声。九者着地当令端正。十者还当复其常处。若取应器及澡瓶。有八事。一者先摩拭令净。二者当两手捧其下。三者跪取师钵。四者洗当用皂荚豆末。五者毕令于手中澡。六者有急事当行宜着日中。七者若向火令其燥。八者毕令复其常处。若取锡杖有七事。一者当扫拭令净。二者不得下拄地。三者不得以有所指拟。四者无使有声。五者当两手捧之。六者当跪以授师。七者毕还复常处。又侍师沐浴剃头朝当着法衣。有十二事。一者务当恭敬执所宜作。二者随时寒温。三者拂除浴室。四者具净汤水。五者当先具皂荚澡豆及麻油。六者豫取净手巾。七者寒具炉火。八者当端住于外无令人入。九者若去发必令有常处。十者若曝法衣当待干燥。十一者急事行当有所付。不得使忘去。十二者执事必宜复其常处。又持香赋花有七事。一者当净拭香炉。二者当舍去宿花。三者当裁火多少。四者赋香花从上座始。五者赋香时手相离五寸。六者执香炉无以自薰。七者毕竟当着常处。又然灯有八事。一者去故炷。二者梳洗灯炉令净。三者当调适盛油。四者求净炷。五者不令欲尽数往益之。六者朝当早起视护。七者油未尽当扶出余炷聚着倚处别然令尽。八者毕竟徐还着本处。若行采花及取杨枝。有九事。一者有主问其主。二者无主当咒愿山泽树神。三者取花及杨枝。不得拔其根株。四者于道路当直往还。五者不得慢惰语戏。六者设为人所犯。慎无与人交通。七者低头内自克责。勿令有恨心。八者若欲赋花当于上座始。九者当去萎花。凡所施行不得自用。有十八事。一者出入行来当先白师。二者若欲宿行当先白师。三者若作新法衣当先白师。四者若欲着新法衣。当先白师从受。五者若欲浣法衣裳当先白师。六者若欲剃头先当白师。七者若疾病服药当先白师。八者若作众僧事当先白师去。九者若欲私有具纸笔之辈当先白师。十者若讽起经呗当先白师。十一者若人以物惠施。先白师已受取。十二者己物惠施人。当先白师。师听然后与。十三者人从己假借。一一当先白师。师听然后有与。十四者己欲从人假借。皆当白师。师听得去。十五者欲白之仪先整衣服稽首为礼。十六者若其听或不听。皆当恭敬稽首作礼。十七者陈所欲知。十八者不得有恨意有所应辞报。又从师行先后还。有十六事。一者当整衣服。二者识所言趣常报应答。随持锡杖手巾之辈。三者寻师后。四者无蹑其影。五者无锡杖戏其前。六者不得道中与人语。七者不得恶师有过。八者师若遣还有所取当寻其来道。九者即当如其教行。十者慎无淹留。十一者师若使住为檀越说经。即当稽首承受节度。十二者暮当早还。十三者慎无留宿。十四者还到请礼问事先整衣服。十五者当五体投地稽首作礼。十六者礼师自如常法。若独行送死问疾。有九事。一者当主人门。当相进退之仪。有异座当坐。设无异座不宜杂坐。二者当视其座席无犯宜忌端坐。三者人若欲问经当宜知时。四者慎无为非时之说。五者主人设食。虽非时法会之食。无令失其仪轨。六者宜还及日。七者无犯夜行。八者若逼暮疾风雨临时制宜。九者还毕如旧。若于道路与师相逢。有六事。一者当先整衣服。二者当脱革屣。三者礼师当稽首足下。四者身寻师后。五者师若自别去当稽首承受节度。六者虽不与师相随。所行礼节必令如常。若众僧食饭时。十六事。一者闻揵稚声即当整衣服。二者当务脱革往住塔下。三者住必端严。四者若从师后到便位住。慎勿言笑有所及。五者若上人说经咒愿。皆当恭敬慎无失仪。六者欲食之初。当先瞻望上下。七者食无众人前食止无后众。八者无诃食好恶。九者不得大餐小餐。十者慎无大咽。十一者不得大挠刮钵中。十二者不得[木*著]叩案上。十三者不得求益。十四者不得以食私所与若摘与狗。十五者有来益食不得言不用。十六者说已饱当以手让却之。又众僧说经。有十三事。若法会说经在温室及清凉室若浴室。一者当整理衣服。二者当平视直进。三者无得道中与人语笑。四者以次礼所尊。五者却入偶坐席。六者上座说经及位便坐。七者坐必端严。八者慎无乱语。九者无大欬唾。十者无唾净地违礼律。十一者若次应说经即当说。十二者为众人所差上高座。当先审所举措慎莫失仪。十三者若坐中有失义。当遏恶扬善。慎无苟且现之过。又众僧说经十三事。若番次直日朝晡行礼。一者闻揵稚声豫具香火。二者赋香如旧。三者整所宜次四者净拂床席。五者扫洒如法。六者若法会出所领分明付授檀越诸宜用。七者事毕领受毕令如初。八者门钥相付。早关晚开一以为常。九者若有异宾当师边听所须当付。十者若有宾宿皆当整衣服住其常位。十一者有即对应声分明。十二者住必端严无令失仪。十三者若欲暂出辄者。令人自代无令处空重呼。又直日所领知后十事。若为直日宜轨所修。其有众事功夫。一者起塔。二者讲堂设僧诸事。三者若作佛像常早起忧识事。四者当选所宜。用错斧锯必使常处。五者若所画朱彩胶墨豫具所得。无令临时有乏。六者毕宜选录复有常处(经本元少七者)八者数所领受。分明付授无令差趺。九者居有所市求。皆问于摩摩帝。十者出用令余宣陈列令有本末。又独行分卫十六事。若行分卫。一者务与人俱。二者若无人俱当知所可行处。三者应器常在左胁。四者带应器之宜出时当以外向。五者以食来还当以内向。六者到人门户宜审举措。七者家无男子慎无入门。八者若欲坐当先瞻视座席。九者设座有刀兵不应坐。十者设有宝物不应坐。十一者若设有妇女衣被严具之辈不应坐。都无此者然有及坐。十二者主人设食。十三所食者便当咒愿。十四者不得问食好丑。十五者不先食说经。十六者虽欲说经。当知所应说时不宜说时。又市所求有九事。一者当低头直往直还。二者若睹异物慎无察视。三者无诤贵贱。四者无坐女肆。五者若为人所犯方便避之。勿从求直。六者卖买若于诚谛送直。无言来取致及反覆。七者已许某甲物。虽复更贱。无舍彼取此令主有恨。八者若见四辈人有卖买贱直。不令己任如当言法不得尔。九者慎无保任致愆负。又到比丘尼寺中有九事。若师使到比丘尼寺中。一者当与俱。二者绕塔作礼一如常法。三者若有异座讫无异座不得坐。四者疾病欲问经。当说所宜说。五者不得为非时之说。六者不得反人之非。七者若坐以珍异衣服巾履施惠一不得受。八者若还不得说其好丑。九者余人不得言但用供养某。又讲经诵法有八事。一者必令详审所见不同。或左右各有所习。二者慎无专知据言此是彼非。三者同学变诤务令和解无令颇。四者众事役劳。慎无自代显己之功。五者大沙门说戒慎无瞩之。六者知己有过犯于众人。即当言悔与共和解。七者师若问言。某说卿有过。即当如事道之。八者无得隐蔽以成愆负。有论语有十事。常昼夜三时诵经行道。一者整衣服。二者若经行必令有常处。三者当于中。四者讲堂中。五者或于塔下。六者亦饭堂中。七者不得蹑革屣。八者不得木履。九者不得持杖。十者慎无卧诵经。又诵经行有十事。房室中常法。一者寝息各异不相涉入。二者受经句读。三者论经义。四者问讯疾病。五者或为便往。六者不得说不急之事。七者不得示人之非。八者不得转相评论。九者借取与必分明。十者无违期约以失道信

沙弥十戒法并威仪一卷五德者。一者发心离俗。怀佩道故。二者毁其形好。应法服故。三者永割亲爱。无适莫故。四者委弃身命。遵崇道故。五者志求大乘。为度人故。十数者。一者一切众生皆依饮食而存。二者名色。三者三受。四者四谛。五者五阴。六者六入。七者七觉分。八者八正道。九者九众生居。十者十一切入。


沙弥威仪

    No. 1472

沙弥威仪

        宋罽宾三藏求那跋摩译

已受沙弥十戒。为贤者道人。次教之当用。渐积从小起。当知威仪施行。应当知和上几岁三师名字。当教识知初受戒时岁日月数。当知事和上有几事。亦当知随事阿阇梨有几事。亦当知给杨枝澡水有几事。亦当知授袈裟摄持钵有几事。亦当知捉锡杖持履有几事。与和上阿阇梨俱应请时。若至国王家时。若至迦夷罗越家时。若至婆罗门家时。若连坐饭时。若别坐饭时。若俱入城乞食时。若俱还至故处时。若日晚过止水边饭时。若共于树下饭时。若自先去往相待时。若合钵食时。转贸钵时。若其对饭时。若前后饭时。若饭已澡漱时。若澡钵去时。若当具知给众僧作直日时。有当知有几事。年满二十欲受戒时。习悉当知之。设为贤者。比丘所问不具对者。不应与具足戒。何以故。作沙弥乃不知沙弥所施行。沙门事大难作甚微妙。贤者沙弥卿且去。熟学当悉闻知。乃应授具足。所以卿不知沙弥事悉者。俱来谛知身善故。不知不伏意耳。而返欲返受具足戒。今授卿具足戒人。谓佛法易行沙门易作。不知佛道致深罪福运行法律交互。以是日中数相之。是故当先问。设其主具对能如法者。三师易得。师教沙弥有五事。一者当敬大沙门。二者不得唤大沙门字。三者大沙门说戒经不得盗听。四者不得求大比丘长短。五者大比丘误时不得转行说。是为威仪法当教行五事。一者不得于屏处骂大比丘。二者不得轻易大比丘于前戏笑。效其语言形相行步。三者见大比丘过。则当起住若读经。若饭时者作众事不应起。四者行与大比丘相逢。当止住下道避之。五者若调戏。若见大比丘。即当止谢言不及。是为施行所应尔。沙弥事和上有十事。一者当早起。二者欲入户当先三弹指。三者具杨枝澡水。四者当授袈裟却授履。五者扫地更益澡水。六者当辟扫拭床席。七者师出未还不得中舍户去。师还逆取袈裟内襞之。八者若有过。和上阿阇梨教诫之。不得还逆语。九者当低头受师语去。当思惟念行之。十者出户当还牵户闭之。是为事和上法。沙弥事阿阇梨有五事。一者视阿阇梨一切当如视我。二者不得调戏。三者设呵骂汝不得还语。四者若使出不净器不唾不得怒恶恚。五者暮宿当按摩之。是为事阿阇梨法也。沙弥事师当早起具杨枝澡水有六事。一者断折杨枝当随度。二者当破头。三者当澡使净。四者当易故宿水。五者当净澡罐。六者当满中水持入。不得使有声。是为给杨枝澡水法。授袈裟有四事。一者当徐徐一手捉下授之。二者当次视上下。三者当正住持师衣已。四者当上着肩上。是为袈裟法。亵袈裟有四事。一者当视上下。二者不得使着地。三者当着常处。四者覆上。是为亵袈裟法

持钵有四事。一者当洗令净。二者拭令澡。三者带令坚。四者不得有声。是为持钵法

持履有四事。一者先抖擞之。二者当视次比之。三者当澡手不得便持袈裟。四者师坐当取次比之。是为持履法

持锡杖有四事。一者当取拭去生垢。二者当取不得着地使有声。三者师出户乃当授。四者师出还当逆取。若俱行若入众若礼佛当取持。是为持锡杖法

俱应请连坐饭时有四事。一者若坐当离师六尺。二者视师大嚫竟乃授钵。三者不得先师食。四者食已当起取钵自近。是为连坐饭时法

别坐饭时法有四事。一者当立住师边。二者教饭乃当坐去。三者头面着地作礼。四者去饭不得倨坐上戏。饭已竟当至师边住。师教还坐乃应坐。是为别坐饭时法

入城乞食时有四事。一者当持师钵。二者当随不得以足蹈师影。三者于城外当取钵授师。四者入城欲别行当报师。是为行乞食法俱还至故处饭时有四事。一者当先徐徐开户出布坐具。二者澡师手已乃却自澡。三者授师钵却自叉手住。四者当预具澡豆手巾。是为还归饭时法

还水边饭时有四事。一者当求净处。二者当求草作座。三者当取水澡师手乃却授钵。四者师教使饭当作礼却坐。是为水边饭时法

止于树下饭时有四事。一者持钵着树枝取叶作座。二者取水还当澡师手。设不得水求取净草授师。三者还取师钵授师。四者当预具净草。净师钵已。却熟拭钵乃去。是为树下饭时法

住于道中相待有三事。一者持钵着净地作礼如事说。二者当视日早晚。可自还归若道上。三者当取师钵并持随后去。是为道中相待法

合钵食时有三事。一者若师钵中无酪酥浆。当自取所得钵授师。不受且当却住。二者徐取钵中半饭出着树叶上。三者却自取钵中半饭着师钵中却住。是为合钵食时法

转贸钵时有三事。一者师钵中得善自取不如者便当授师。二者师欲贸钵当让不受。三者师坚呼贸钵当取一再食。便当拭钵还授师。是为贸钵时法。对饭时有三事。一者当授师钵乃却自饭。二者数视师所欲得即当起取与。三者食不得大疾。亦不得后已起。当复问欲得何等。师言持去乃当持去。是为对饭时法

前后饭时有三事。一者持师钵具已当却至屏处住。听师呼声即当应之。二者当预取澡水着一边。三者师饭毕。当澡师手却住师教去饭。乃当作礼去饭。是为前后饭时法

饭已澡漱有三事。一者澡漱已当先取师钵澡令清净已着树叶上。二者却自澡钵已。亦着树叶上。先取师钵以手摩令澡。内着囊中付师。三者还自取钵拭令燥。内着囊中带之止住。是为澡钵时法

澡钵去时有三事。一者言我今欲过某许贤者某甲。二者头面着地作礼便去。三者独还去不得过余聚落中戏笑。直归故处读经。是为澡钵去时法

沙弥入众有五事。一者当明学。二者当习诸事。三者当给众。四者当授大沙门物。五者欲受大戒时三师易得耳

复有五事。一者当礼佛。二者当礼比丘僧。三者当问讯上座。四者当留上座处。五者不得诤坐处

复有五事。一者不得于坐上遥相呼语笑。二者不得数起出。三者若众僧唤沙弥某甲即当起应四者当随众僧教令。五者若摩摩谛唤。有所作当还白师。是为入众法

沙弥作直日有五事。一者当惜众僧物。二者不得当道作事。三者事未竟已不得中起舍去。四者若和上阿阇梨唤。不得便往。应当报摩摩谛。五者当随摩摩谛教令。不得违戾。是为作直日法。择菜有五事。一者当却根二者当齐头。三者不得使有青黄合。四者洗菜当三易水令净已。当三振去水。五者作事毕竟。当还扫除使净

复有五事。一者不得私取众僧物。二者若有所欲取。当报摩摩谛。三者尽力作众僧事。四者当扫除食堂中。乃却布空案。五者当朝暮扫除舍后益水

汲水有十事。一者手不净。不得便用汲水。当先澡手。二者不得大投罐井中使有声。三者当徐徐下罐。不得大挑击左右着使有声。四者不得使绳头还入井中。五者不得持履伏井栏上。六者不得持罐水入着釜中。七者不得持罐置地。八者当洗澡器令净。九者举水入当徐徐行。十者着屏处。不得妨人道中

澡釜有五事。一者当先澡釜缘上。二者当洗釜里。三者当澡中腰腹。四者当澡里底。五者皆当三易水

吹窖有五事一者不得。蹲吹火。二者不得燃生薪。三者不得倒吹湿薪。四者不得然腐薪。五者不得热汤浇火灭

扫地有五事一者顺行。二者洒地不得有厚薄。三者不得污溅四壁。四者不得蹈湿上坏地。五者扫已即当自择草分弃之

比丘僧饭食沙弥扫地有五事。一者却行。二者不得掉臂手。三者过六人止作一聚。四者悉扫遍为善。五者即当自手除持出弃之

持水澡罐泻水。有五事。一者一手持上一手持下不得转易二者当近左面坚持直视前。三者当视人手浇下水。不得多亦不得少。正当投人手中。四者下水当去人手四寸。不得高不得下。当相视水多少。设水少不能足。一人当益不得住人手。五者已澡手还着袈裟

持澡盘有五事。一者不得使盘有声。二者当两手坚持当倚右面。三者当随人手高下。不得左右顾视。四者澡盘中满当出弃之。不得浇人前地。五者已当过澡手还着袈裟

手巾有五事。一者当右手持上左手持下一头授人。二者当去坐二尺。不得前倚人膝。三者当持巾不得随障人口。四者人拭未放巾。不得引去。已下竟当报主若着故处。五者已当澡手还着袈裟

授履有五事。一者当先抖擞去中所有。二者当从上座起。三者当随澡钵后示主令自识。四者不得持左着右。皆当下竟沙弥。五者已竟当还澡手还着袈裟

沙弥钵有七事。一者钵中有余饭。不得便取弃之。二者欲弃饭当着净地。三者当用澡豆若草叶。四者澡钵不得于净地当人道中。五者澡钵当使下有榰。六者当更益净水。水不远弃污溅人地。七者欲倒弃钵中水。当去地四寸不得高下

拭钵有五事。一者当澡手拭使燥。二者当持净手巾着膝上。三者当拭里使燥。即当持净巾并覆着囊中着常处

行会饭时教沙弥持钵有五事。一者不得置地。二者不得累使有声。三者倩下着地。四者人未授钵。不得持钵置案上。五者不得从人后授钵。当正从前。亦不得众中。视师饭已。当起取钵还坐

沙弥为师持书行答谢人有七事。一者当直往。二者当直还。三者当识师所语。亦当识人报语。四者不得妾有所过。五者若有所借。不得止留宿。六者不得调譺。七者行出当有法则

沙弥给众僧使未竟。不得妄入。大沙门户有三事得入。一者和上阿阇梨暂使往。二者若倩有所取。三者自往问经应得入

欲入户有七事。一者当三弹指乃得入。二者不得当人道作。三者不得妄说他事。四者当叉手如法说。五者教倨不得交脚。六者不得调譺。七者不得障人先欲出。当还向牵户

独使沙弥远出行当教上头有三事。一者彼人问卿和上名何等。便报言和上字某甲。二者复问言卿和上作沙门几岁。便报言若干岁。三者复问卿和上何许人。便报言某郡县人。设复问阿阇梨名何等。便报言字某甲。复问卿阿阇梨年几何。便报言年若干。复问阿阇梨是何许人。便报言某郡国人。若复问贤者何许人。便报言某郡县人。复问贤者名何等。便报言字某甲。复问卿作沙弥已来几何时。便报言已若干岁若干日月若干时节。是为知和上阿阇梨。亦自知时字岁日月数

入浴室有五事一者当低头入。二者当避上座处。三者上座读经不得狂语。四者不得以水更相洗。五者不得持水浇火灭

复有五事。一者不得调譺。二者不得破中盆瓮。三者用水不得大费。四者不得浊中澡豆麻油。五者自出去不得止浣衣

至舍后有十事。一者欲大小便即当行。二者行不得左右视。三者至当三弹指。四者不得迫促中人使出。五者已至复当三弹指。六者不得大咽。七者不得低头视阴。八者不得弄上灰土。九者不得持水浇壁。十者已当还澡手未澡不得持物。复有五事一者不得正唾前壁。二者不得左右顾视。三者不得持草画地。四者不得持火炷画地及壁。五者不得久固。上已当疾下去。设逢人不得为作礼。下道避之

沙弥十数。一者一切众生皆因饮食而存。二者二谛。三者三受。四者四谛。五者五阴。六者六入。七者七觉分。八者八圣道。九者九众生居。十者十一切入。是名十数

沙弥。一者发心离俗。怀[佩-一]佩道故。二者毁其形好。应法服故。三者永割亲爱。无滴莫故。四者委弃身命。遵崇道故。五者志求大乘。为度人故

敬白四坐大德众僧。沙弥某甲。合有尔许人等。稽首和南。盖闻道。太阳垂晕。则仓生蒙朗。真尊演教有怀开悟。崇和时众照阳圣化。洪法之遵博晕像运。皆僧集堂布萨说戒。戒能灭恶。为万善之基。因生妙行解脱之本。沙弥闻之踊跃欢喜。意欲布施。为无财宝。且持杨枝五百净筹一千。仰奉清众。表心单诚。除癊去秽。幸烦德僧。慈纳咒愿

沙弥威仪


善恭敬经

    No. 1495

善恭敬经

        隋天竺三藏阇那崛多译

如是我闻。一时婆伽婆。住在如来本所行处宝庄严殿。尔时世尊与大比丘及诸菩萨摩诃萨等。并余无量百千万亿四部大众。左右围绕共会说法。尔时长老阿难从坐而起。整理衣服右膝着地。以十指爪合掌向佛。身心恭敬而白佛言。世尊。如来常说有多闻者有大功德。若复教他立多闻处。世尊。彼善男子。得几所功德。作是语已默然而住

尔时世尊告长老阿难言。阿难。汝既问我以是义故。我当为汝譬喻解释。所以者何。智者于义譬喻得解。阿难。譬如三千大千世界。所有树木百卉药草若小若大。乃至似于如横一指。从地生者彼等树木。并着枝叶花果子实皆悉备具。阿难。而彼所有树木之中。如横一指最小之者。所生花果多少之数如一恒沙。如向一指所生花叶果实枝等。如横二指所生草木。还有若干花果子实。多少之数。如二恒沙。如是次第乃至从地更有出生。如横三指还有若干枝叶花果。多少之数如三恒沙。阿难。于意云何。颇复有人能数彼树多少以不。阿难言。不也世尊

尔时佛复告阿难言。彼之一指以上所有花果子实。有人尚能数知多少。而彼善男子善女人。教他乃至一四句偈。为他显示不求果报。发慈哀心怜愍之心。乃至教他令得阿罗汉果。复作是念。以何方便令多众生。以此法施因缘力故令得须陀洹果。乃至令得阿罗汉果。乃至令发菩提之心。以慈愍故教他乃至一四句偈。为他解释分别显示。以此功德。欲比于前譬喻功德多少之数。于此功德百分不及一。千分不及一。百千分不及一。亿千分不及一。歌罗数分不及一。譬喻分不及一。优婆尼沙陀分不及一彼等福德不可称量。阿难。彼之男女多得善根。乃至令他住多闻中。复能向他乃至宣说一四句偈

尔时世尊作是语已。长老阿难复白佛言。希有。世尊世尊。乃能作如是说。希有。婆伽婆如来。乃能作如是说。世尊。彼之受法善男子善女人。于是法中及法师所。应作何等恭敬之心。作是语已

佛告阿难言。阿难。汝莫问我如是之事。何以故。今者众生无敬法心。阿难复更重白佛言。善哉世尊。我渴仰法。于是法中深生敬心。如法学法。我作世尊侍者已来。未曾闻此如是之法。世尊。我从今已当作如是恭敬之心。如世尊敕不违圣教

尔时阿难复白佛言。世尊。于后末世有善男子善女人等。于诸法中或有渴仰敬重心相。惟有口言。为衣食故为利养故。从贫贱中剃发出家。而作是言我能为法。虽复彼等求诸佛法。世尊。然彼众生无行法心示下贱相。是人还起下贱之心。世尊。我为自身故发是问。我等云何应住。云何应行。作是语已

尔时佛告长老阿难作如是言。阿难。若有善男子善女人乐于法者。欲得读诵。彼等众生欲向和上阿阇梨所。至已应问诸佛法言。随心所乐所堪说处。应说依止。彼或十腊或十二腊。为重法故应乞依止。何以故。如来往昔虽复说言五夏比丘不须依止。而彼学者于前敬心乃能为法。以是义故应当依止。何以故。彼人欲学于佛法故

阿难。而彼和上阿阇梨等。为彼应作如是依止。当如是耶。我许汝耶。汝得利耶。我教汝耶。汝当谨顺莫放逸耶。应练行耶。如是与耶。若有比丘得具足法。彼则堪能与他依止。若能如是分别法句。与他依止名依止师

若有比丘虽复百夏。不能闲解如是法句。彼亦应当从他依止。所以者何。自尚不解况欲与他作依止师。假令耆旧百夏比丘。而不能解沙门释种秘密之事。彼人为法应说依止。虽有百夏上座比丘。不解律法。彼等亦应说于依止

若有比丘从他受法。彼等比丘于彼师边。应起尊贵敬重之心。欲受法时。当在师前不得轻笑。不得露齿。不得交足。不得视足。不得动足。不得踔脚。足踝齐整勿令高下。于彼师前勿升高座。师不发问不得辄言。凡有所使勿得违命。勿视师面。离师三肘命坐即坐。勿得违教。安坐已讫。于彼师所应起慈心。若有弟子欲受法时。长跪师前先诵所得。诵已有疑先应咨白。若见听许然后请决。是时学者既受法已。右膝着地两手捧足。一心顶礼师所住处。地若平正即应设敬。若地偏隘即还却立。乃至师过至彼平所即便请法。若至平处礼师足已。却缩而行至十肘地。遥礼师已随意归还。又复弟子应作是念。师在我后观我是非不应放逸。我若即来寻至师前。请决所疑是即为善。傥不得来应当知时。一日三时应参进止。若三时间不参进止。是师应当如法治之

又复弟子若参师时。至彼师所若不见师。应持土块或木或草以为记验。若当见师在房室内。是时学者应起至心绕房三匝。向师顶礼尔乃方还。若不见师众务皆止不得为也。除大小便

又复弟子于其师所不得粗言。师所呵责不应反报。师坐卧床应先敷拭。令无尘污虫蚁之属。若师坐卧乃至师起。应修诵业。时彼学者至日东方便到师所。善知时已数往师边。咨问所须我作何事。当白师言。入聚落不。若师欲得入聚落时。师所袈裟当须前奉先应洗手。若洗手讫应持己衣。还拭己手至彼师所身心安住。两手捧衣长跪而授。如法敬奉处所安住。然后奉水令洗手面。先奉内衣着身体者。尔乃更当奉余衣服常所用者。向于师所应作如是恭敬之心

又复弟子在于师前不得涕唾。若行寺内恭敬师故。勿以袈裟覆于肩[骨*專]。不得笼头。师经行处应常扫拭。天时若热。日别三时以扇扇师。三度授水授令洗浴。又复三时应献冷饮。应当知时为师乞食师所营事。应尽身力而营助之。取师应器洗治令净。若师与洗先洗师器乃及己钵。若与应洗。如不与者不应再索。何以故。有因缘故。阿难。有诸比丘当作是念。如来往昔钵无人洗。彼等学佛应当自役。虽然如来许彼。天若热时应具冷水。天若寒者应备暖水。凡所须者皆应尽备。亲在师前勿嚼杨枝。于他人处勿说师过。若遥见师寻起迎接

阿难。凡有师者。随在谁边学四句偈或听或读。或问或咨一四句等。是即为师。时彼学者于其师所。常起恭敬尊重之心。若不如是名不敬者。亦不名住正行之者。若于他边说师过者。彼人不得取我为师。何以故

阿难。彼无敬心不爱佛故。彼无行人况爱法者。彼无敬人当不爱法。彼大恶人亦不爱僧不入僧数。何以故。彼愚痴人不行正行。阿难。佛所言说皆为行者

尔时长老阿难闻佛说已。悲泣流泪以手扪拭。作是白言。世尊。于将来世少有众生住是行者。世尊。我等当行如是之行。我今当住如是之行。世尊。若有比丘。于彼师所或和上边。不生敬心道说长短。于将来世得何等报。佛告阿难。若将来世有诸比丘。或于师所或和上边。不起恭敬说于师僧长短之者。彼人则非是须陀洹。亦非凡夫。彼愚痴人应如是治。何以故。阿难。师实有过尚不得说。况当无也

阿难。若有比丘于其师边不恭敬者。我说别有一小地狱名为椎扑。当堕是中。堕彼处已。一身四头身体俱然。状如火聚出大猛炎。炽然不息然已复然。于彼狱处复有诸虫。名曰钩[此/束]。彼诸毒虫常啖舌根。时彼痴人从彼舍身。生畜生中受野兽形。或野干身或受狼身。彼诸人等见者大唤。或唱言狼或唱野干。阿难。彼痴人辈。皆由往昔骂辱于师及与和上。是故见者皆悉不喜。以彼往昔舌根过故。恒食屎尿。舍彼身已虽生人间常生边地。生边地已舍于一切功德之事。具足恶法离众善法。虽得人身皮不似人。不能具足人之形色。不似父母。父母憎恶。得人身已常被轻贱诽谤陵辱。离佛世尊恒无智慧。从彼死已还速坠堕地狱之中。何以故

阿难。若有人等。于教授师所。施自在师所。教法行师所。教真行师所。起不恭敬。受是重殃。阿难。彼痴人辈。自余更得无量无边苦患之法。阿难。若从他闻一四句偈。或抄或写书之竹帛。所有名字。于若干劫取彼和上阿阇梨等荷檐肩上。或时背负或以顶戴常负行者。复将一切音乐之具。供养是师

阿难。作如是事。尚自不能具报师恩。亦复不名深敬于师。况敬法耶。作是敬者是名敬师

阿难。若有无量无边供养之具。尔乃堪能供养师耶

阿难。当来之世多诸比丘得是经已。于师和上起不敬心无有正行。于师和上恒说于过。阿难。我说彼等愚痴人辈极受多苦。于当来世必堕恶道。阿难。我向汝说我向语汝。如来在世于汝等边已为说讫。此是正道此非正道。于当来世彼诸比丘随行何行。还生是处得是果报。是故阿难。我教汝等常行恭敬

阿难。若有善男子善女人。能生恭敬尊重之心。当得如是胜上之法。所谓爱敬诸佛世尊敬重经法。深爱敬僧当入是次。佛说是经已。长老阿难等及诸大众。闻佛所说欢喜奉行

善恭敬经


善见律毗婆沙

    No. 1462

善见律毗婆沙

    序品第一

        箫齐外国三藏僧伽跋陀罗译

南无诸佛

  若人百亿劫　　不可思议时
  为一切众生　　往至疲倦处
  正为世间故　　南无大慈悲
  由法难知故　　从生生世间
  稽首头顶礼　　甚深微妙法
  破裂坏消尽　　无明烦恼网
  若戒定智慧　　解脱具足行
  勤修功德者　　众僧良福田
  我今一心归　　头面稽首礼
  归命三宝竟　　至演毗尼义
  令正法久住　　利益饶众生
  以此功德愿　　消除诸恶患
  若乐持戒者　　持戒离众苦

说曰。律本初说。尔时佛在毗兰若。优波离为说之首。时集五百大比丘众。何以故。如来初成道。于鹿野苑转四谛法轮最后说法度须跋陀罗。所应作者已讫。于俱尸那末罗王林娑罗双树间。二月十五日平旦时入无余涅槃。七日后迦叶从叶波国来。与五百比丘僧。往俱尸那国。问讯世尊。路逢一道士。迦叶问曰。见我师不。道士答言。汝师瞿昙沙门。命过已经七日。瞿昙涅槃诸人天供养。我从彼得此天曼陀罗华。迦叶与大比丘闻佛已涅槃。宛转涕哭闷绝躄地。时有比丘。名须跋陀罗摩诃罗。言止止。何足啼哭。大沙门在时。是净是不净。是应作是不应作。今适我等意。欲作而作。不作而止。时迦叶默然而忆此语。便自思惟。恶法未兴宜集法藏。若正法住世利益众生。迦叶复念。佛在世时语阿难。我涅槃后所说法戒即汝大师。是故我今当演此法。迦叶惟念。如来在世时以袈裟纳衣施我。又念。往昔佛语比丘。我入第一禅定。迦叶亦入定。如来如是赞叹我。圣利满足与佛无异。此是如来威德加我。譬如大王脱身上铠。施与其子使护其种姓。如来当知。我灭度后迦叶当护正法。是故如来施衣与我。迦叶即集比丘僧。语诸比丘。我于一时。闻须跋陀罗摩诃罗言。大沙门在时。是净是不净。是应作是不应作。今适我等意。欲作而作不作而止。诸长老。我等辈宜出法藏及毗尼藏。诸比丘白大德迦叶。大德。当选择诸比丘。大德迦叶。佛法九关一切悉通。一切学人须陀洹斯陀含爱尽比丘。非一百亦非一千。通知三藏者得至四辩。有大神力得三达智。佛所赞叹。又爱尽比丘五百少一。是大德摩诃迦叶。所以选择五百而少一者。为长老阿难故。若无阿难。无人出法。阿难所以不得入者。正在学地。大德迦叶。为欲断诸诽谤故。不取阿难。诸比丘言。阿难虽在学地。而亲从佛前受修多罗祇夜。于法有恩。复是耆老。释迦种族如来亲叔之子。又无偏党三毒。大德迦叶。应取阿难足五百数。此是众圣意也。诸大德比丘作是思惟。在何处集法藏。唯王舍城众事具足。我等宜往王舍城中。安居三月出毗尼藏。莫令余比丘在此安居。所以者何。恐余比丘不顺从故。是以遣出。于是大德迦叶白二羯磨。于僧耆品中广明。于是从如来涅槃。后七日大会。复七日中供养舍利。过半月已。余夏一月半在。迦叶已知安居已近。迦叶语诸长老。我等去时已至。往王舍城。大德迦叶。将二百五十比丘逐一路去。大德阿[少/兔]楼驮。将二百五十比丘。复逐一路去。贤者阿难。取如来袈裟。比丘僧围绕。往舍卫国至如来故住处。舍卫城人见阿难已。懊恼悲泣问阿难言。如来今在何所而独来耶。诸人号哭。犹如如来初涅槃时。贤者阿难。以无常法教化诸人。既教化已入祇树园。即开佛房取佛床座出外拂拭入房扫洒。扫洒已取房中故供养花出外弃之。还取床座复安如本。贤者阿难种种供养。如佛在时无异。于是阿难。从佛涅槃后。坐倚既久四大沉重。欲自疗治。一日已至三日中服乳。取利而于寺坐。时有修婆那婆罗门来请阿难。阿难答曰。今日服药不得应命。明日当赴。至日将一长老比丘。到修婆那家。修婆那即问修多罗义。是故阿鋡第十品中。名修婆那修多罗经。于是阿难。于祇树园中种种修护已。欲入安居向王舍城。大德迦叶。与阿[少/兔]楼驮一切比丘众。至王舍城。尔时见十八大寺一时颓毁。如来灭后诸比丘。衣[笐-几+儿]诸物纵横弃散而去。是故狼藉。五百大德比丘顺佛教故。修护房舍。若不修护。外道当作此言。瞿昙沙门在世时修治房舍。既涅槃后弃舍而去。为息此讥嫌故。宜应料理。迦叶言。佛在世时赞叹安居先事。修护房舍作计校已。往至阿阇世王所。告求所须。王见比丘头面礼足即问。大德何所须求。迦叶答曰。十八大寺颓毁败坏。今欲修护。王自知之。王答善哉。即给作人。夏初一月日迦叶等修治修治寺中已。复往王所而白王曰。所修护寺今悉毕竟。我等今者便演出法藏及毗尼藏。王答大善。所愿成就。王复言曰。我今当转王威法轮。诸大德当演无上法轮。王白众僧。我今政听诸大德使令。众僧答曰。先立讲堂王问何处起戴。答曰。可于先底槃那波罗山边禅室门边造。此中闲静。王答甚善。于是阿阇世王威力。犹如第二忉利天毗舍技巧。须臾之顷即立。成办栋梁椽柱障壁阶道。皆悉刻镂种种异妙。于讲堂上。以珍玩妙宝而庄严之。悬众杂花缤纷罗列。地下亦复如是。种种殊妙犹如梵天宫殿无异。[毯-炎+瞿]氀茵褥荐席五百。敷置床上悉北向坐。又高座以众宝庄饰。选高座中最精妙者。拟以说法高座东向。众僧语阿难曰。明日集众出毗尼藏。汝犹须陀洹道。云何得入。汝勿懈怠。于是阿难自思惟。明日众圣集法。我云何以初学地入中。阿难从初夜观身已。过中夜未有所得。阿难思惟。世尊往昔有如是言。汝已修功德。若入禅定速得罗汉。佛言无虚。当由我心精勤太过。今当畴量取其中适。于是阿难从经行处下至洗脚处。洗脚已入房却坐床上。欲少时消息倚身欲卧。脚已离地头未至枕。于此中间便得罗汉。若有人问于佛法中离行住坐卧而得道者。阿难是也于是大德迦叶至中月二日(六月十七日)中食已竟。料理衣钵集入法堂。贤者阿难欲现证所得令大众知。不随众僧入。众僧入已次第而坐。留阿难坐处。下坐众僧从上和南。次及空处而问。留此处拟谁。答曰拟阿难。又问。阿难今在何处。阿难知众心故现神足。故于此处没。当坐处踊出现身。于是众僧坐竟。大德迦叶语诸长老。为初说法藏毗尼藏耶。诸比丘答曰。大德。毗尼藏者是佛法寿。毗尼藏住佛法亦住。是故我等先出毗尼藏。谁为法师。长老优波离众有问曰。阿难不得为法师耶。答曰。不得为法师。何以故。佛在世时常所赞叹。我声闻弟子中持律第一优波离也。众曰。今正应问优波离出毗尼藏。于是摩诃迦叶。作白羯磨问优波离。长老僧听。若僧时到僧忍听。我问优波离毗尼法中。白如是。优波离作白羯磨。大德僧听。若僧时到僧忍听。我今答大德迦叶毗尼法。白如是。如是优波离。白羯磨已整身衣服。向大德比丘头面作礼。作礼已上高座而坐。取象牙装扇。迦叶还坐已问优波离。长老。第一波罗夷。何处说因谁起耶。答曰毗舍离结。因迦兰陀子须提那起。问曰犯何罪也。答曰犯不净罪。迦叶问优波离罪．因缘．人身．结戒．随结戒。有罪亦问无罪亦问。如第一波罗夷。如是第二第三第四因缘本起。大迦叶悉问优波离。随问尽答。是故名四波罗夷品。复次问僧伽婆尸沙。复次问二不定。次问三十尼萨耆波夜提。次问九十二波夜提。次问四波罗提提舍尼。次问七十五众学。次问七灭诤法。如是大波罗提木叉作已。次问比丘尼八波罗夷。名波罗夷品。复次问十七僧伽婆尸沙。次问三十尼萨耆波夜提。次问六十六波夜提。次问八波罗提提舍尼。次问七十五众学。次问七灭诤法。如是已作比丘尼波罗提木叉竟。次问蹇陀(汉言杂事)次问波利婆罗(汉言三摈四羯磨也)如是律藏作已。大德迦叶一切问优波离。优波离答已。是故名五百罗汉集律藏竟。于是长老优波离放扇从高座下。向诸大德比丘作礼。作礼已还复本座。摩诃迦叶言。毗尼集竟问法藏。谁为法师应出法藏。诸比丘言。长老阿难。于是大德迦叶作白羯磨。长老僧听。若僧时到僧忍听。我问长老阿难法藏。白如是。阿难复作白羯磨。大德僧听。若僧时到僧忍听。我今答大德迦叶法藏。白如是。于是阿难从坐起。偏袒右肩礼。大德僧已即登高座。登高座已手捉象牙装扇。大德迦叶问阿难。法藏中梵网经。何处说耶。阿难答曰。王舍城那兰驮二国中间王庵罗絺屋中说。因谁而起。因修悲夜波利婆阇迦婆罗门揵多。因二人起。大德迦叶问阿难梵网经因缘本起。次问沙门果经何处说耶。阿难答曰。于王舍城耆婆林中说。为谁说耶。为阿阇世王梵弃子等。如是沙门果经因缘本起。以是方便问五部经。何谓为五部。答曰。长阿鋡经。中阿鋡经。僧述多经。殃堀多罗经。屈陀迦经。问曰。何谓屈陀迦经。答曰。除四阿鋡。余者一切佛法。悉名堀陀迦经。四阿鋡中一切杂经。阿难所出唯除律藏。佛语一味分别有二用。初中后说其味有三。三藏亦复如是。戒定慧藏。若是部党五部经也。若一二分别有九部经。如是聚集有八万法藏。问曰。何以名为一味。世尊得阿耨多罗三藐三菩提。乃至涅槃时。于一中间四十五年。为天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。是为一味。若一解脱性复为一味。何谓为二。法藏毗尼藏。何以初中后说。佛初中后说。是谓为三。而说偈言

  流转非一生　　走去无厌足
  正觅屋住处　　更生生辛苦
  今已见汝屋　　不复更作屋
  一切脊肋骨　　碎折不复生
  心已离烦恼　　爱尽至涅槃

复有法师。解优陀那偈。此是如来初说。月生三日中得一切智慧。踊跃观看因缘。说是偈言

  时法生成就　　蹇陀迦中说

如来临涅槃时敕诸比丘。汝于我法中慎莫懈怠。此是最后说。于两中间。是名中说。问曰。何谓三藏。答曰。毗尼藏修多罗藏阿毗昙藏。是名三藏。问曰。何谓毗尼藏。二波罗提木叉．二十三蹇陀．波利婆罗。是名毗尼藏。问曰。何谓修多罗藏。答曰。梵网经为初。四十四修多罗。悉入长阿鋡。初根牟罗波利耶二百五十二修多罗。悉入中阿鋡。乌伽多罗阿婆陀那为初。七千七百六十二修多罗。悉入僧述多。折多波利耶陀那修多罗为初。九千五百五十七修多罗。悉入鸯掘多罗。法句喻躯陀那伊谛佛多伽尼波多毗摩那卑多涕罗涕利伽陀本生尼涕婆波致参毗陀佛种性经若用藏者。破作十四分。悉入屈陀迦。此是名修多罗藏。问曰。何谓阿毗昙藏。答曰。法僧伽毗崩伽陀兜迦他耶摩迦钵叉逼伽罗坋那只迦他跋偷。此是阿毗昙藏问曰。何谓毗尼义耶。说偈答曰

  将好非一种　　调伏身口业
  知毗尼义者　　说是毗尼义

问曰。何谓种种五篇波罗提木叉。波罗夷为初。五篇七聚罪。是谓为种种戒母。将成坚行宽方便。随结从身口不善作。此是将身口业。是故名毗尼耶。问曰。何谓修多罗。以偈答曰

  种种义开发　　善语如秀出
  经纬与涌泉　　绳墨綖贯穿
  是谓修多罗　　甚深微妙义

问曰。何谓发义。答曰。自发义能发他义。问曰。何谓善语。答曰。先观人心然后善语。问曰。何谓秀出。答曰。譬如禾稻秀出结实。问曰。何谓经纬。答曰。以綖织成。问曰。何谓涌泉。答曰。如泉取者众多而无穷尽。问曰。何谓绳墨。答曰。如直绳能去曲木。问曰。何谓为綖。答曰。譬如散花以綖贯穿风吹不散。修多罗者亦复如是。贯诸法相亦不分散。问曰。何谓阿毗昙。以偈答曰

  有人意识法　　赞叹断截说
  长法是故说　　是为阿毗昙

此是阿毗偈也。意识赞叹断截长。此入阿毗义也。问曰。何谓为意。答曰。修多罗句云。有人言极剧意云何。是阿毗意义也。何谓为识。答曰。修多罗句画夜阿毗。此是阿毗识义也。何谓赞叹。答曰。王阿毗王。此是阿毗赞叹义也。何谓断截。答曰。足力阿毗。此是阿毗断截义也。何谓为长。答曰。阿毗于多(汉言长也)此是阿毗长义也。又曰生色界慈心遍观一方毗呵罗(汉言意义)识者。色声乃至触。是识义也。赞叹者。学法无学法世间无上法。此是赞叹义也。断截者。触法成学。是断截义也。长者。大法不可度量阿耨多罗法。是长义也。此义应当知之。又曰昙者法也。何谓为藏以偈答曰

  智藏藏义味　　从义学器者
  我今合一说　　藏义汝自知
  此是藏义也

问曰。何谓为藏。答曰。藏者学。此是法藏也。又修多罗句云。如人执揽与鋘呋而来。此是器义也。今已总说三藏。应当知是二义也。已略说毗尼藏。智藏亦言义器。修多罗亦如是。又曰。阿毗昙者则是藏也。如是已知。复于三藏中。种种因缘指示佛法。语言分别随所薄着。学除甚深相学破合离者。次第文句至义自出。今次第现此三藏。阿毗说曰。阿毗者。意义识义赞叹义断截义出过广义大义无上义。何谓为意。忆持也。识者分别也。赞叹者。常为圣人之所赞叹也。断截者。分别偈也。出过者。过于余法也广者。于诸法中最为广也。大者诸法之最大也。无上者。诸法无能胜也。昙者。举义承义护义。何谓为举。举者。举置众生于善道也。承者。承受众生不令入三恶道也。护者。拥护众生令得种种快乐也。藏者器也。何谓为器。器者。能聚集众义也。问曰。藏与阿毗昙。为同为异。答曰同。又问曰。若同者。但云阿毗昙自足。何须复言藏也。答曰。圣人说法欲使文句具足故。更安藏字也。如是三藏义亦尔。又为指示故。为教授故。为分别故。为系故。为舍故。为甚深相故。为离合故。若比丘随所至处。显现如是一切诸义。此是三藏。如是次第威德显现正义。随罪过随比类随教法。随覆见缠名色差别。若人依毗尼为行则得入定。得定便具三达智。此是戒为行本。因三昧故便具六通。若人修学阿毗昙。能生实智慧。实慧既生便具四辩。若人随顺律语得世间乐。何谓为世间乐。净戒之人人天赞善。常受世间四事供养。此世间乐除欲乐。如修多罗说。佛所说我已知之。不宜在家出家学道而得道果。得道果者。戒定慧力也。随逐恶者。皆由无智。无智故佛教妄解。妄解故诽谤如来。作诸恶业自破其身。从此因缘广生邪见。于阿毗昙僻学者。捉心过急。则心发逸所不应思。如修多罗。告诸比丘。有四法。不应思而思。心则发狂。法师曰。如是次第破戒邪见乱心善不善说已。而说偈言

  具足不具足　　随行而得之
  比丘乐学者　　当爱重此法

如是藏义知一切佛语。应当知。何谓为阿含。法师曰。有五阿含。何谓为五。一者长阿含。二者中阿含。三者僧育多阿含。四者鸯堀多罗阿含。五者屈陀伽阿含。问曰。何谓为长阿含。三品中梵网经为初。四十四修多罗悉入三品中。是名长阿含。法师问。云何名之为长。聚众法最多故名为长。又问曰。何谓为阿含。答曰。容受聚集义名阿含。如修多罗说。佛告诸比丘。我于三界中不见一阿含。如畜生阿含。纯是众生聚集处也。以是义故。中阿含亦应知。不长不短故名为中。于十五品。根学修多罗为初。一百五十二修多罗。是名中阿含。七月日出法竟。大德迦叶。修理成就十力法已。于是大地如人欢喜。叹言。善哉善哉。乃彻黄泉六种震动。又种种奇异妙相出现。此是五百大众罗汉初集名也。而说偈言

  世间中五百　　罗汉出是法
  故名五百出　　诸贤咸共知

是时大众说。大德迦叶问优波离。波罗夷何处结耶。亦问犯处亦问因缘亦问人身。此问大德自知。答曰。时因人结戒。是故结戒一切次第我今当说。尔时佛在毗兰若处。问曰何时说耶。答集五百大众说。如是种种义出已。问曰何以优波离说。答曰为大德迦叶。问是戒本已现今谁持者。持者何处住。我当说根本。今说章句义。尔时佛住毗兰若。此根本律藏初如是说。长老优波离佛前持。佛未涅槃时。六通罗汉无数千万。从优波离受。世尊涅槃后。大德迦叶为初。诸大悲众集阎浮利地中。谁能持。优波离为初。诸律师次第持。乃至第三大众诸大德持。令次第说师名字。优波离。大象拘。苏那拘。悉伽符。目揵连子帝须。五人得胜烦恼。次第阎浮利地中持律亦不断。乃至第三一切诸律师。皆从优波离出。此是连续优波离。何以故。优波离从金口所闻。聚于心中开施与人。人知已有学人。须陀洹斯陀含阿那含不可计数。爱尽比丘一千。大象拘是优波离弟子。从优波离口悉闻。自解至深极理。学人初受不可计数。爱尽比丘一千。苏那拘此是大象拘弟子。苏那拘从师口受取律已。读诵性自知律。学人初受不可计数。爱尽比丘一千。悉伽符是苏那拘弟子。从师口受律已。于一千阿罗汉中。最胜性自知律。学人初受学不可计数。爱尽比丘非百千不可度量。尔时阎浮利地无数比丘集。目揵连子帝须神力。第三大众欲现如是。毗尼藏阎浮利地中。诸法师次第乃至第三大众持。应当知。问曰。何谓为第三大众。答曰。此是次第时已出竟。光明妙法用智慧故。而说是赞曰

  寿命住世间　　五百智慧明
  五百中大德　　迦叶最为初
  譬如灯油尽　　涅槃无著处

    跋阇子品第二集法藏

于是众圣。日夜中次第而去。世尊涅槃已一百岁时。毗舍离跋阇子比丘。毗舍离中十非法起。何谓为十。一者盐净。二者二指净。三者聚落间净。四者住处净。五者随意净。六者久住净。七者生和合净。八者水净。九者不益缕尼师坛净。十者金银净。此是十非法。于毗舍离现此十非法。诸跋阇子修那伽子名阿须。阿须尔时作王。党跋阇子等。尔时长老耶须拘迦。是迦乾陀子。于跋阇中彷徉而行。毗舍离跋阇子比丘。毗舍离中现十非法。闻已我不应隐住坏十力法。若为方便灭此恶法。即往至毗舍离到已。尔时长老耶须拘迦乾陀子。于毗舍离大林鸠咤伽罗沙罗中住。尔时跋阇子比丘说戒时。取水满钵置比丘僧中。尔时毗舍离诸优婆塞来诣跋阇子比丘。作如是言。语诸优婆塞。应与众僧钱。随意与半钱若一钱。使众僧得衣服。一切应说。此是集毗尼义。七百比丘不减不长。是名七百比丘集毗尼义。于集众中二万比丘集。长老耶斯那比丘发起此事。于跋阇子比丘众中。长老离婆多问萨婆迦。萨婆迦比丘答。律藏中断十非法。及消灭诤法。大德。我等辈今应出法及毗尼。择取通三藏者。至三达智比丘择取已。于毗舍离婆利迦园中。众已聚集。如迦叶初集法藏无异。一切佛法中垢洗除已。依藏更问依阿含问。依枝叶问依诸法聚问。一切法及毗尼藏尽出。此是大众。于八月日得集竟。说偈赞曰

  世间中七百　　是为七百名
  依如前所说　　汝等自当知

是时萨婆迦眉苏寐离婆多．屈阇须毗多．耶须婆那参复多。此是大德阿难弟子。修摩[少/兔]婆娑伽眉。此二人是阿[少/兔]留驮弟子。已曾见佛。而说偈言

  第二好集众　　大法一切出
  已至重法处　　应作已作竟
  爱尽比丘者　　是名第二集

    阿育王品第三集法藏

诸大德自作念言。当来世我等师法。如是浊垢起有无耶。大德即见当来世非法垢起。从此以后百岁。又十八年中。波咤利弗国阿育王已生世。生已一切阎浮利地靡不降伏。于佛法中甚笃信极大供养。于是诸外道梵志。见阿育王如此信佛法。外道梵志贪供养故。入佛法中而作沙门。犹事外道如旧。以外道法教化诸人。如是佛法极大浊垢。浊垢欲成。于是诸大德作是念。我等辈及当来世见垢不。各自观寿命不及。复作是念。谁为当来宣传。诸大德观一切人民及欲界中。都无一人。复观诸梵天。有一天人短寿。曾观法相。诸大德作如是念。我等当往请此梵天人下生世间。于目揵连婆罗门家中受胎。然后我等教化令其出家。得出家已。一切佛法通达无碍三达智已。破坏外道判诸诤法。整持佛法。于是诸大德往至梵天。梵天人名帝须。诸大德至语帝须。从此百年后十八年中。如来法极大垢起。我等观一切世间及欲界。不见一人能护佛法。乃至梵天见汝一人。善哉善人。若汝生世间。以十力法汝当整持。诸大德作是言已。大梵帝须闻诸大德佛法中垢起我当洗除。闻已欢喜踊跃答曰。善哉对已。与诸大德立誓于梵天应作已罢。从梵天下。尔时有大德和伽婆栴陀跋阇。二人于众少年。通持三藏得三达智爱尽阿罗汉。是二人不及灭诤。诸大德语二长老。汝二人不及灭诤。众僧今依事罚汝。当来有梵天人名帝须。当托生目揵连婆罗门家。汝二人可一人往迎取度出家。一人教学佛法。于是诸大德阿罗汉。随寿长短各入涅槃而说偈言

  第二七百众　　和合灭非法
  当来法因缘　　已作令久住
  爱尽得自在　　善通三达智
  神通得自在　　犹不免无常
  我今说名字　　传流于将来
  如是生无常　　已知生难得
  若欲得常住　　当勤加精进

此第二僧说。摩呵梵魔帝须。从梵天下。托生目揵连婆罗门家。于是和伽婆观见帝须。已入婆罗门家受胎。知受胎已。和伽婆日日往其家乞食乃至七年。何以故。为度因缘故。于是七年乞饭不得。乞水亦不得。过七年已复往乞食。其家人应曰。食已竟。大德。更往余家。和伽婆念言。今得语已还。于是婆罗门从余处还。于路见和伽婆。咄出家人。从我家来耶。有所得不。答曰得。婆罗门还至家中。而问家人。比丘乞食有与不耶。家人答曰。都不与之。婆罗门言。比丘妄语。若明日来者我当诘问。明日门外坐。大德和伽婆明日来。婆罗门问曰。大德。昨言乞有所得。定无所得。何以妄语。比丘法得妄语不。大德和伽婆答曰。我往汝家七年。都无所得。昨始得家人语我更往余家。是故言得。婆罗门自思念言。此比丘正得语。而言有所得。善哉。是知足人也。若得饮食者。便应大欢喜。婆罗门即回已饮食分。施与和伽婆。而作是言。从今已去日日于此取食。于是和伽婆。日日恒往取食。婆罗门见和伽婆威仪具足。发大欢喜心。欢喜心已。复更请曰。大德。自今以后莫余家乞。长来此食。和伽婆默然受请。日日食已渐示佛法。示已而去。尔时婆罗门子年始十六。已学婆罗门法三围陀书。婆罗门子初从梵天下。犹好净洁。床席先提悉不与人杂。若欲往师所。以床席先提。以白洁裹。悬置屋间而去。去后大德和伽婆至。而作是念。时今至矣。来往多年此婆罗门子都不共语。以何方便而化度之。即以神力。令家中床座隐蔽不见。唯见婆罗门子所举先提。尔时婆罗门见和伽婆来。遍求坐床了不能得唯见其子所举先提。即取与和伽婆坐婆罗门子还。见和伽婆坐其先提。见已心生忿怒。即问家人。谁持我先提与沙门坐。大德和伽婆食竟。婆罗门子嗔心已息。大德和伽婆语婆罗门子。汝何所知婆罗门子。咄沙门我无所知。谁应知也婆罗门子问和伽婆。沙门知围陀法不。问已此沙门必知。大德和伽婆。于三围陀中通达。及干昼(汉言一切物名)揩昼．伊底呵写．文字一切分别．婆罗门子。于狐疑法不能通达。所以尔者。由师不解。婆罗门子问和伽婆。于难解中问问尽答。和伽婆语婆罗门子。汝问已多。我今次问汝一事。汝应当答。婆罗门子言。善哉沙门。我当分别答耶。和伽婆于双心中。问婆罗门子。若人心起而不灭。若人心灭而不起。若人心灭而灭。若人心起而起。于是婆罗门子。仰头向虚空下头视地。不知所以。反咨沙门。咄沙门。此是何义。和伽婆答。此是佛围陀。婆罗门子语。大德得与我不。答曰得。复问。云何可得。答曰。汝若出家然后可得。于是婆罗门子心大欢喜。来到父母所而白言。此沙门知佛围陀。我欲就学。用白衣服沙门不与。令我出家然后当得。父母作是念已善哉。若汝出家学围陀竟。当速还家。婆罗门子心念言。我就此沙门。学佛围陀竟者当还。临欲去时父母教敕。汝能勤学当听汝去。答曰。无暇教敕。于是婆罗门子往诣和伽婆所。到已和伽婆。即取婆罗门子度为沙弥。以三十二禅定法教其思惟。婆罗门子须臾之顷。得须陀洹道。和伽婆思念。此婆罗门子已得道迹。不乐还家。譬如燋谷不复更生。此沙弥亦复如是。和伽婆复言。若我与禅定深法。其得罗汉者恬静而住。于佛法中不复更学。我今遣其往诣栴陀跋阇所。教学佛法并宣我意。和伽婆言。善来沙弥。汝可往彼大德栴陀跋阇所学佛法耶。汝到彼已当作是言。大德。我师遣来此教学佛法。栴陀跋阇答。善哉沙弥。明日当教帝须一切佛法及义。唯除律藏。教学已竟受具足戒。未满一岁即通律藏。于三藏中悉具足知。和尚阿阇梨。以一切佛法付帝须已。随寿命长短入于涅槃。尔时帝须深修禅定。即得阿罗汉。以佛法教导一切人民。尔时宾头沙罗王生儿一百。宾头沙罗王命终。阿育王四年中杀诸兄弟。唯置同母弟一人。过四年已然后阿育王。自拜为王。从此佛涅槃已一百一十八年。后阿育王即统领阎浮利地。一切诸王无不降伏。王之威神。统领虚空及地下。各一由旬。阿耨达池诸鬼神。恒日日献水。八担合十六器。以供王用。尔时阿育王已信佛法。以水八器施比丘僧。二器施通三藏者。二器供王夫人。余四器自供。又雪山鬼神。日日献杨枝木。名罗多。柔软香美。王及夫人宫中妓女。合一万六千人。寺中比丘有六万众。常以杨枝。恒日日供比丘僧。及王夫人宫中妓女。悉令备足。复有雪山鬼神献药果。名阿摩勒呵罗勒。此果色如黄金。香味希有。复有鬼神献熟庵罗果。复有鬼神。日日献五种衣服。悉黄金色及手巾。又日日献贤圣蜜浆。又献涂香及阇提花。海龙王又献名眼药。阿耨达池边。有自然粳米香美。鼠剥去皮取完全者。鹦鹉日日赍九十担献王。又巧作堂屋。中蜜蜂结房。作蜜以供王。迦陵频伽之鸟来至王所。作种种妙音以娱乐王。王有如是神力。又于一日王作金锁遣锁海龙王将来。此海龙王寿命一劫。曾见过去四佛。龙王到已赐坐。师子座以白伞覆上。种种香花供养。阿育王。脱己所著璎珞。璎珞海龙王身。以一万六千妓女围绕供养。阿育王语海龙王言。我闻如来相好殊妙。我欲见之。汝可现之。于是海龙王受教。即现神力。自变己身为如来形像。种种功德庄严微妙。有三十二大人之相八十种好。譬如莲花郁波罗花开敷庄严水上。亦如星宿庄严虚空青黄赤白种种光色。去身一寻以自庄严。譬如青虹亦如电光围绕而去。譬如金山众宝光明而围绕之。一切众生视之无厌。诸梵天龙夜叉乾闼婆等。于七日之中瞻仰目不暂舍阿育王见之欢喜。自从登位三年唯事外道。至四年中信心佛法。王所以事外道者。时阿育王父宾头沙罗王。本事外道。日日供施婆罗门六万人。王与夫人宫内悉事外道。是故相承事之。有一日阿育王。供设诸婆罗门。王于殿上坐见诸婆罗门。左右顾视都无法用。王见如此而作是念。我且更选试。必有法则者。我当供养。作是念已向诸臣言。卿等。若有事沙门婆罗门者。可请来我宫中。我当供施。诸臣答曰。善哉。答已各去。于是诸臣。依其所事事尼揵陀等诸外道。各将至王宫。到已而白王言。此是我等罗汉。是时阿育王。即敷施床座。高下精粗各各不同。王语诸外道。随力所堪各各当座而坐。诸外道闻王此言。仍各自量而坐。或坐先提者。或坐木段者。王观察如此。自作念曰。此诸外道等定无法用。王即知已而作是言。外道如此不足供施。食讫即令出。又复一日。王于殿上在窗牖中。见一沙弥。名泥瞿陀。从殿前过。行步平正威仪具足。王问。此谁沙弥耶。左右答曰。泥瞿陀沙弥。是先王长子修摩那之子也。法师曰。我今依次第说因缘。尔时宾头沙罗王病困。阿育王。从所封郁支国来还父王国。即杀修摩那太子。仍自把王国事。阿育王杀太子修摩那已。捡挍宫内。修摩那妃。先已怀胎满十月。仍假服逃出。去城不远至栴陀罗村。村边有树名泥瞿陀。有一天人作此树神。树神见修摩那妃语言。善来。妃闻树神唤。即往至树所。树神神力化作一屋。语妃曰。汝可住此屋。妃闻语已即便入屋。其夜而生一男儿。母为作字名泥瞿陀。于是旃陀罗主敬心供给。如奴见大家无异。时王女妃住树神屋中七年。泥瞿陀年已七岁。尔时有阿罗汉比丘。名婆留那。以神通观泥瞿陀。因缘应度。作是念今时至矣。欲度为沙弥。即往诣妃所。求度为沙弥。妃即与令度。婆留那即度为沙弥。发未落地即得罗汉。又一日沙弥料理装束已。往诣师所供养已。取钵盂袈裟往至母所。从城南入过殿前行出城东门。尔时阿育王。在殿上向东经行。王见泥瞿陀沙弥于殿前过。威仪具足视地七尺而行。心中清净。此因缘已前说。今当广说。于是阿育王而作是念。彼沙弥者。屈身俯仰威仪庠序。当有圣利法也。王见沙弥已信心欢喜。即发慈哀心。何以故。过去世时此沙弥。是阿育王兄。曾共修功德。而作偈说

  往昔因缘故　　今生复欢喜
  譬如郁钵花　　得水鲜开敷

于是阿育王。生慈悲已不能自止。即遣三臣往唤沙弥。诸臣极久未时得还。复遣三臣。三臣到已语沙弥言。沙弥速去。于是沙弥。执持威仪安庠而来。到已王语沙弥。当自观察随意坐也。于是沙弥。观看众中都无比丘。沙弥知已。仍欲就白伞高座。而作方便令王受钵。王见沙弥作方便已。心自念言。此沙弥者必为家主。沙弥即以钵授王已。即就王座。王以己所食施与沙弥。沙弥自量取足而受。沙弥食竟。于是王问沙弥。沙弥师教沙弥悉知不。答曰。我知少分。王言。善哉。为我说之。善哉大王。我当为说。沙弥而作是念。量王所堪。即为说法咒愿。便说半偈

  不懈怠者是涅槃　　若懈怠者是生死

王闻已向沙弥言。我知已但说令尽。沙弥咒愿已竟。王向沙弥言。日供养八分。沙弥答。善哉。我当回与师。王问。沙弥师是谁耶。答言。无罪见罪呵责。是名我师。王言。更与八分。沙弥答。善哉。我当与阿阇梨。王复问言。阇梨是谁。答。共于善法中教授令知。是我阇梨。王复答言。善哉。我更与八分。沙弥答。此八分与比丘僧。王复问言。比丘僧是谁。答言。我师我阇梨我是依止。故得具足戒。王闻是已倍增欢喜。王语沙弥。若尔我更与八分。沙弥答言。善哉受。受已而去。明日沙弥。与比丘僧三十二人来至王宫。到已中食竟。王问沙弥。更有比丘无。沙弥答言有。若有者更将三十二人来。如是渐增乃至六万。是时外道六万徒众失供养分。大德泥瞿陀。即授王及宫内夫人诸臣。悉受三归五戒。是时王及诸人。信心倍增无有退转。王为诸众僧。起立大寺安处众僧。乃至六万日日供养。王所统领八万四千国王。敕诸国起八万四千大寺。起塔八万四千。王敕诸国造立塔寺。各受王命欢喜而造。复有一日于阿育僧伽蓝作大布施。布施已。王于六万比丘僧中坐。而作是言。我有四种供给。汤药饮食衣服卧具。自恣与僧。语已而作是问。诸大德。佛所统领有几种法耶。比丘答言。支法有九。法聚有八万四千。王闻已至心于法。王作是念。我当立八万四千寺。以供养八万四千法聚。即日出银钱九十六亿。而唤大臣。臣到已王语臣言。我所领八万四千国。遣人宣令。国起一寺。阿育王自作阿育王僧伽蓝。众僧见阿育王欲起大寺。见已有一比丘。名因陀掘多。有大神力漏尽罗汉。众僧即差因陀掘多。统知寺事。是时因陀掘多见寺有所阙短处。自以神力修治令办。王出银钱。罗汉神力三年乃成。诸国起寺来启答王。一日俱到白统臣言。造塔寺已成。统臣入白王言。八万四千国。起八万四千寺塔。皆悉已成。王答言。善哉。王语一大臣。可打鼓宣令。寺塔已成。七日之后当大供养布施。国中一切内外人民。悉受八戒身心清净。过七日已庄严拟赴王命。如天帝释诸天围绕。阿育王国土亦复如是。庄严竟人民游观无有厌足。人民悉入寺舍。尔时集众。有八亿比丘僧九十六万比丘尼。于集众中罗汉一万。诸比丘僧。心作是念。我当以神通力令王得见己所造功德。见此已然后佛法大盛。诸比丘以神通力。王所统领阎浮利地。纵广四万乃至海际。其中所起塔寺。一切供养布施种种功德。使王一时睹见。王得见已心中欢喜。而白众僧言。如我今者。供养如来作大布施。心中欢喜有如我不。于是众僧。推目揵连子帝须令答王。帝须答王言。佛在世时诸人供养。不及于王。唯王一人无能过者。王闻帝须此语。心中欢喜不断。而作念言。于佛法中作大布施。无与我等。我当受持佛法如子爱父。则无有狐疑。于是大王问比丘僧。我于佛法中得受持不。尔时帝须闻王语已。又见王边王子。名摩哂陀。因缘具足。便作念。若是王子得出家者。佛法极大兴隆。念已而白王言。大王。如此功德犹未入佛法。譬如有人从地积七宝上至梵天。以用布施。于佛法中亦未得入。况王布施而望得入。王复问言。云何得入法分。帝须答言。若贫若富。身自生子。令子出家得入佛法。作是言已。王自念。我如此布施。犹未入佛法。我今当求得入因缘。王观看左右见摩哂陀。而作是念。我弟帝须已自出家。即立摩哂陀为大子。王复筹量立为太子好。令出家好。即语摩哂陀。汝乐出家不。摩哂陀见叔帝须出家。后心愿出家。闻王此言心大欢喜。即答。实乐出家。若我出家。王于佛法得入法分。尔时王女名僧伽蜜多。立近兄边其婿先已与帝须俱出家。王问僧伽蜜多。汝乐出家不。答言。实乐。王答。若汝出家大善。王知其心。心中欢喜向比丘言。大德。我此二子众僧为度。令我得入佛法

善见律毗婆沙卷第一善见律毗婆沙卷第二

        萧齐外国三藏僧伽跋陀罗译

众僧已受。即推目揵连子帝须为和尚。摩呵提婆为阿阇梨。授十戒。大德末阐提为阿阇梨。与具足戒。是时摩哂陀年满二十。即受具足戒。于戒坛中得三达智。具六神通漏尽罗汉。僧伽蜜多阿阇梨。名阿由波罗。和尚名昙摩波罗。是时僧伽蜜多年十八岁。度令出家。于戒坛中即与六法。王登位以来。已经六年二子出家。于是摩哂陀。于师受经及毗尼藏。摩哂陀于三藏中。一切佛法皆悉总持。同学一千摩哂陀最大。尔时阿育王登位九年。有比丘拘多子。名帝须。病困剧。持钵乞药得酥一撮。其病增长命将欲断。向诸比丘言。三界中慎勿懈怠。语已飞腾虚空。于虚空中而坐。即化作火自焚烧身。入于涅盘。是时阿育王。闻人宣传为作供养。王念言。我国中比丘。求药而不能得。王于四城门边起作药藏。付药满藏中。时波咤利弗国四方城门边。有四千客堂。堂日得钱五千。以供王用。尔时王。以钱一千供大德泥瞿陀。一千供养塔像华香直。取一千供给法堂。一千供诸律师。一万供众僧。四城门边药藏。日一万以用买药直。尔时佛法兴隆。诸外道等衰殄失供养利。周遍乞食都无所得。为饥渴所逼。托入佛法而作沙门。犹自执本法教化人民。此是律此是法。既不用佛法律威仪进止。悉不得法来入寺住。至布萨日来入僧中。诸善比丘不与其同。尔时目揵连子帝须。自念言。诤法起已不久当盛。我若住僧众。诤法不灭。即以弟子付摩哂陀已。目揵连子帝须。入阿烋河山中隐静独住。诸外道比丘。欲以己典杂乱佛法。遂成垢浊。外道犹行己法。或事火者。或五热炙身。或大寒入水。或破坏佛法者。是故诸善比丘。不与同布萨自恣及诸僧事。如是展转乃至七年不得说戒。阿育王知已。遣一大臣。来入阿育僧伽蓝。白众僧。教灭斗诤和合说戒。大臣受王敕已入寺。以王命白众僧。都无应对者。臣便还更咨傍臣。王有敕令。众僧灭诤而不顺从。卿意云何。傍臣答言。我见大王往伏诸国。有不顺从王即斩杀。此法亦应如此。傍臣语已。使臣往至寺中。白上座言。王有敕令。众僧和合说戒。而不顺从。上座答言。诸善比丘。不与外道比丘共布萨。非不顺从。于是臣。从上座次第斩杀。次及王弟帝须而止。帝须见杀诸比丘。即自念言。此臣受取王敕。辟故杀诸众僧也。问曰。帝须是谁。答曰。是王弟同生。尔时阿育王登位。立弟为太子。太子一日入林游戏。见诸群鹿阴阳和合。太子作是念。此诸群鹿啖草饮水。尚复如此。岂况比丘在寺房舍。床褥细软饮食适口。当无是事。太子游还到王所。白王言。我向出游。见诸群鹿阴阳和合。畜生啖草饮水。尚有此事。诸比丘僧。在寺房舍供养备足。岂无此事。王闻语已。即自念言。非狐疑处而生狐疑。一日太子帝须。触忤王意。王忿而语太子帝须。我今以王位别汝。七日作王讫已。我当杀汝。是时太子帝须。虽受王位七日之中日夜妓乐饮食种种供养。心不染着。形体羸瘦忧恼转剧。所以尔者。犹畏死故。七日已满。王唤帝须问。何意羸瘦。饮食妓乐不称意耶。帝须答言。死法逼迫心不甘乐。王闻语已语帝须言。汝已知命七日当死。犹尚惶怖。况诸比丘出息入息恒惧无常。心有何染着。王语已。帝须于佛法中即生信心。又复一日。太子帝须出游行猎。渐渐前行至阿练若处。见一比丘坐。名昙无德。有一象。折取木枝遥拂比丘。太子见已心发欢喜。而作愿言。我何时得如彼比丘。昙无德比丘。自逆知帝须心愿。比丘即以神力飞腾虚空。于虚空中而坐。令帝须得见。从虚空飞往阿育僧伽蓝大池中。于水上而坐立。脱僧伽梨郁多罗僧置虚空中。入池洗浴。是时太子帝须。见大德有如是神力。心大欢喜而言。今日我当出家。即还宫中白王言。我欲出家。王必哀念听。我出家。王闻帝须求出家。心大惊怪。答言。宫中妓女百味肴膳娱乐快乐。何以出家。王种种方便令其心止。志意坚固永不肯住。而答王言。宫中婇女欢乐暂有。会当别离。大王叹言。善哉。即遣诸臣。使平治道路扫洒清净竖立幢幡种种庄严。庄严竟已。臣白王言。装束已办。王取太子公服天冠璎珞庄严太子千乘万骑围绕奉送往至寺中。众僧见太子帝须出家。心大欢喜。有办僧伽梨者。郁多罗僧者。安陀会者。钵盂者。拟待太子即出家已。是时太子往到禅房。至昙无德比丘所求欲出家。国中豪贵诸长者儿一千童子。随太子出家国中人民见太子出家。各自念言。太子如此尊贵。尚舍王位出家修道。我等贫穷何所恋慕。念已无数人众悉随出家。阿育王登位四年太子出家。复有王外甥阿嗜婆罗门。是僧伽蜜多知已。有一男儿阿嗜。闻太子出家。心中惊喜往至王所。即白王言。我今欲随太子出家。愿王听许。王答。善哉。即与太子俱日出家。如是于佛法中。多有刹利出家。佛法兴隆。时帝须言。当知此臣僻取王意杀诸比丘。臣杀未已。帝须比丘便前遮护。臣不得杀。臣即置刀。往白王言。我受王敕。令诸比丘和合说戒。而不顺从。我已依罪次第斩杀。杀犹未尽。帝须比丘即便遮护。不能得杀。臣白王言。帝须比丘为杀以不。王闻臣言杀诸比丘。即大惊愕。心中懊恼闷绝躄地。以冷水洒面良久乃稣。即语臣言。咄咄我遣汝入寺。欲令众僧和合说戒。何以专辄而杀众僧。王往寺中白诸众僧。我前遣一臣教令和合说戒。不使杀诸比丘。此臣专辄枉杀众僧。不审此事谁获罪耶。有比丘答言。由王故杀。此是王罪。或有比丘言。两俱得罪。有一比丘即问王言。王心云何。有杀心不。王答言。我本以功德意遣。无杀心也。若王如此王自无罪。杀者得罪。王闻如是言已。心生狐疑问诸比丘。有能断我狐疑者不。若能断我狐疑心者。我当更竖立佛法。诸比丘答言。有目揵连子帝须。能断狐疑竖立佛法。于是即遣法师四人。人各有比丘一千侍从而去。复遣大臣四人。人各有一千人将从。往迎大德目揵连子帝须。须得而归。是时二部众。往至阿烋河山中。迎取目揵连子帝须。到已而言。王唤帝须。帝须不去。王复更遣法师八人。人各有比丘一千侍从。大臣八人。人各一千侍从。到已复言。王唤帝须。帝须不去。王迟望二使。经久未反。王心狐疑。王复问诸大德。大德。我已遣二使。往迎目揵连子帝须。使已经久而不见至。众僧答言。恐迎者僻宣王意言唤帝须。是故不来。王复问言。云何作请语而得来耶。众僧答王。当作是言。佛法已没。愿屈大德来更共竖立。乃可得来。王闻是言。更遣法师十六人。人各比丘一千侍从。大臣十六人。人各将一千人。王复问。彼法师为老为少。众僧答言老。若其老者。当用舆迎。众僧答言。不得乘舆。王复问言。彼大德者住在何处。答言。阿烋河山中。若尔当遣舫乘往迎。敕使者言。汝若到已。当请大德住大舫中。可使四边带仗防护。是时大众使者发去。到阿烋河山中。即以王命白大德言。今佛法已没。仰屈大德来共竖立。于是大德。闻使语已言。我出家正为佛法。今时至矣。即取坐具而起。帝须自念言。明当至波咤利弗国。是时阿育王。夜梦见如是相貌。有一白象而来。以鼻摩娑王头捉王右手。明旦王召相师曰。我夜梦如是相貌。为吉为凶。有一相师。即答王言。捉王手者是沙门像也。大王闻相师语已。即得信来。白王。大德帝须今日已至。王闻至已。即出往迎。王自入水至膝。大德帝须欲上。王以右手捧接大德。大德帝须便捉王手。左右拔剑欲斫大德帝须。何以故。阿育王法。若人捉王头及手。即便斫头。是故拔剑欲斫。尔时王见水中拔剑影。王回顾言。咄咄。我昔敕臣。往至寺中令众僧和合说戒。而僻取我意杀诸比丘。而汝今者复欲杀耶。止止。莫作我罪。法师问曰。比丘不得捉白衣手。云何得捉。答曰。王为欲闻法故往请来。王即是大德弟子故得捉手。于是王将大德往园林中住。三重防卫。王自为大德洗脚以油磨之。磨竟于一边而坐。王自念言。此大德能断我疑不。若能断我疑者。亦能断诤法。然后佛法竖立。王念。我且当试大德。我欲见大德神通力。愿为示现。帝须答言。汝今乐见何等神力。王言。我欲见大地震动。帝须问曰。为欲使一边动一切动耶。王复问言。于此二种何者为难。帝须答言。譬如铜盘盛满中水。有人动盘水悉动难。半动半不动难。王言。半动半不动甚难。帝须答言。如是大王。王言。欲见半动半不动。帝须语王。周回四方四由旬。弹绳作界。东方安车。南方安马。西方安人。北方安铜盘水。使各骑界上一脚在内一脚在外。铜盘水当安界上。半入界内半在界外。王即随教作已。于是帝须即入第四禅。从禅定起。而向王言。善见大王。大德帝须即以神力。能使四方四由旬外悉大震动。界内不动。车马及人外脚悉动。内脚不动。水半动半不动。于是大王。见大德神力如此。即大欢喜。我先所疑今得断也。于佛法中恶法得灭。王即问大德帝须。我先遣一臣到寺。令僧和合说戒。而臣专辄杀诸比丘。此罪谁得耶。帝须答言。大王。有杀心不。王即答言。我无杀心。若无杀心王无罪也。即便为王说本生经。佛语诸比丘。先筹量心然后作业。一切作业皆由心也。帝须欲演本生经。大王。往昔有一鹧鸪鸟。为人笼系在地。愁怖便大鸣唤。同类云集为人所杀。鹧鸪问道士。我有罪不。道士答言。汝鸣声时有杀心不。鹧鸪鸟言。我鸣伴来。无杀心也。道士即答。若无杀心汝无罪也。而说偈言

  不因业而触　　必因心而起
  善人摄心住　　罪不横加汝

如是大德帝须。方便令王知已。七日在园林中。帝须教王。是律是非律。是法是非法。是佛说是非佛说。七日竟。王敕。以步障作隔。所见同者集一隔中。不同见者各集异隔。处处隔中出一比丘。王自问言。大德。佛法云何。有比丘答言。常或言断。或言非想。或言非想非非想。或言世间涅槃。王闻诸比丘言已。此非比丘。即是外道也。王既知已。王即以白衣服与诸外道。驱令罢道。其余隔中六万比丘。王复更问。大德。佛法云何。答言。佛分别说也。诸比丘如是说已。王更问大德帝须。佛分别说不。答言。如是大王。知佛法净已。王白诸大德。愿大德布萨说戒。王遣人防卫众僧。王还入城。王去之后。众僧即集众六万比丘。于集众中。目揵连子帝须为上座。能破外道邪见徒众。众中选择知三藏得三达智者一千比丘如昔第一大德迦叶集众。亦如第二须那拘集众出毗尼藏无异。一切佛法中清净无垢。第三集法藏九月日竟。大地六种震动。所以一千比丘说。名为第三集也。法师问曰。三集众谁为律师。于阎浮利地。我当次第说名字。第一优波离。第二驮写拘。第三须那拘。第四悉伽婆。第五目揵连子帝须。此五法师于阎浮利地。以律藏次第相付不令断绝。乃至第三集律藏。从第三之后。目揵连子帝须临涅槃。付弟子摩哂陀。摩哂陀是阿育王儿也。持律藏至师子国。摩哂陀临涅槃。付弟子阿栗咤。从尔已来。更相传授至于今日。应当知之。我今说往昔师名。从阎浮利地五人持律藏至师子国。第一名摩哂陀。第二名一地臾。第三名郁帝臾。第四名参婆楼。第五名拔陀沙。此五法师智慧无比。神通无碍得三达智。于师子国各教授弟子。摩哂陀临涅槃。付弟子阿栗咤。阿栗咤付弟子帝须达多。帝须达多付弟子伽罗须末那。伽罗须末那付弟子地伽那。地伽那付须末那。须末那付伽罗须末那。伽罗须末那付昙无德。昙无德付帝须。帝须付提婆。提婆付须末那。须末那付专那伽。专那伽付昙无婆离。昙无婆离付企摩。企摩付优波帝须。优波帝须付法叵。法叵付阿婆耶。阿婆耶付提婆。提婆付私婆。如此诸律师智慧第一。神通无碍得三达智爱尽罗汉。如是师师相承至今不绝。法师曰。我今更说根本因缘。尔时于波咤利弗国。集第三毗尼藏竟。往昔目揵连子帝须。作如是念。当来佛法何处久住。即以神通力观看阎浮利地。当于边地中兴。于是目揵连子帝须。集诸众僧语诸长老。汝等各持佛法。至边地中竖立。诸比丘答言。善哉。即遣大德末阐提。汝至罽宾揵陀罗咤国中。摩呵提婆。至摩醯婆末陀罗国。勒弃多。至婆那婆私国。昙无德。至阿波兰多迦国。摩诃昙无德。至摩诃勒咤国摩呵勒弃多。至臾那世界国(是汉地也)末示摩。至雪山边国。须那迦郁多罗。至金地国。摩哂陀郁帝夜参婆楼拔陀。至师子国。各竖立佛法。于是诸大德各各眷属五人。而往诸国竖立佛法。尔时罽宾国中有龙王。名阿罗婆楼。国中种禾稻。始欲结秀。而龙王注大洪雨。禾稻没死流入海中。尔时大德末阐提比丘等五人。从波咤利弗国飞腾虚空。至雪山边阿罗婆楼池中下。即于水上行住坐卧。龙王眷属童子入白龙王言。不知何人。身着赤衣居在水上。侵犯我等。龙王闻已即大嗔忿。从宫中出。见大德末阐提。龙王忿心转更增盛。于虚空中作诸神力。种种非一。令末阐提比丘恐怖。复作暴风疾雨雷电霹雳。山岩崩倒树木摧折。犹如虚空崩败。龙王眷属童子。复集一切诸龙童子。身出烟竟。起大猛火雨大砾石。欲令大德末阐提恐怖。既不恐怖。而便骂言。秃头人君为是谁。身着赤衣。如是骂詈。大德颜色不异。龙王复更作是骂言。捉取打杀。语已更唤兵众。现种种神变。犹不能伏。大德末阐提。以神通力蔽龙王神力。向龙王说。若汝能令诸天世人一切悉来恐怖。我者一毛不动。汝今更取须弥山王及诸小山掷置我上。亦不能至。大德作是语已。龙王思念。我作神力便已疲倦。无所至到。心含忿怒而便停住。是时大德知龙王心。以甘露法味教化示之。令其欢喜归伏龙王受甘露法已。即受三归五戒。与其眷属八万四千俱受五戒。复有雪山鬼夜叉揵挞婆鸠盘茶鬼等。闻大德末阐提说法已。即受三归五戒。复有夜叉五人。与眷属俱。呵梨帝耶夜叉尼有五百子。得须陀洹道于是大德末阐提。唤一切夜叉及龙王。从今以后莫生嗔恚。莫残害人民禾稻。于诸众生生慈悲心令得安乐。一切诸龙鬼等答言。善哉。如大德教即当顺从。即日龙王作大供养。龙王遣取己七宝床。与末阐提。末阐提坐于床上。龙王立近末阐提边。以扇扇末阐提。是时罽宾揵陀勒叉国人民。常以节日集。往祠会龙王。到已见大德末阐提。各相谓言。此比丘神力乃胜龙王。于是人民悉礼末阐提。礼已而坐。末阐提。为诸人民说读譬喻经。说已八万众生即得道果。千人出家。法师言。从昔至今罽宾国。皆着袈裟光饰其境。而说偈言

  罽宾揵陀国　　尔时末阐提
  嗔恚大龙王　　教化令受法
  复有余大众　　从系缚得解
  八万得天眼　　出家一千众

大德摩诃提婆。往至摩醯娑慢陀罗国。至已为说天使经。说竟四万人得道果。皆悉随出家。而说偈言

  摩诃提婆　　有大神力　　得三达智
  到摩醯娑
  为说天使经　　度脱诸众生
  四万得天眼　　皆悉随出家

大德勒弃多。往婆那婆私国。于虚空中而坐。坐已为说无始经。说已六万人得天眼。七千人出家。即起五百寺。而说偈言

  大德勒弃多　　有大神通力
  到婆那婆私　　于虚空中坐
  为说无始经　　众生得天眼
  出家七千人　　五百僧伽蓝

大德昙无德。往阿波兰多国。到已为诸人民说火聚譬经。说已令人欢喜。三万人得天眼。令服甘露法。从刹利种男女。各一千人出家。如是佛法流布。而说偈言

  大德昙无德　　有大神通力
  往阿婆兰多　　说火聚经法
  令服甘露法　　众生得天眼
  一千比丘僧　　比丘尼如是

大德摩诃昙无德。往至摩诃勒咤国。到已为说摩诃那罗陀迦叶本生经。说已八万四千人得道。三千人出家。如是佛法流通。而说偈言

  大德摩诃昙　　有大神通力
  往摩诃勒咤　　说迦叶本经
  众生得道果　　出家三千人

大德摩诃勒弃多。往臾那世界国。到已为说迦罗罗摩经。说已臾那世界国。七万三千人得道果。千人出家。臾那世界佛法通流。而说偈言

  摩诃勒弃多　　有大神通力
  往臾那世界　　说摩迦罗经
  众生得道果　　出家一千人

大德末示摩。大德迦叶。大德提婆纯毗帝须。复大德提婆。往雪山边。到已说初转法轮经。说法已。八亿人得道。大德五人。各到一国教化。五千人出家。如是佛法流通雪山边。而说偈言

  大德末示摩　　有大神通力
  往到雪山边　　说初法轮经
  众生得道果　　出家五千人

大德须那迦那郁多罗。往至金地国。到已。于金地中。有一夜叉尼。从海中出。往到王宫中。夫人若生儿已。夜叉即夺取而食。尔时王夫人生一男儿。见大德须那迦来即大恐怖。而作念言。此是夜叉尼伴也。即取器仗往欲杀须那迦。须那迦问言。何以持器仗而来。诸人答言。王宫中生儿。而夜叉尼伴夺取而食。君将非其伴耶。须那迦答言。我非夜叉尼伴。我等名为沙门。断杀生法。护持十善勇猛精进。我有善法。是时夜叉尼闻王宫生儿。相与围绕从海中出。作如是言。今王生儿。我当往取食。王宫中国人。见夜叉众来。皆大惊怖。往白大德。是时须那迦。即化作夜叉大众。倍于彼众而围绕之。夜叉尼等见化夜叉。而作念言。彼夜叉者当已得国。今将欲来害食我等。作是念已。即各走去不得回顾。于是化夜叉众。随后而逐不见而止。大德须那迦。即诵咒防护国土。使诸夜叉断不得入。即为国人民说梵网经。说已六万人皆得道果。复有受三归五戒者。三千五百人为比丘僧。一千五百人为比丘尼。于是佛法流通。法师言。从昔至今。王若生儿悉皆取名名须郁多罗。而说偈言

  大德须那迦　　郁多罗比丘
  有大神通力　　往到金地国
  为说梵网经　　众生得道果
  三千五百僧　　一千五百尼

大德目揵连子帝须。与众僧遣摩哂陀往师子洲。摩哂陀即作是念。此时可去以不。摩哂陀即入定观。师子阿[少/兔]罗陀国王。名闻茶私婆。年已老耄。不堪受化。若往化者。佛法亦不久住。我今且止。去时未至。若王命终。太子代位。我当共往建立佛法。我今且往外家。欲问讯母。复更自念。到母国已当还此不。仍往师子洲也。摩哂陀往师所。头面礼足及比丘僧。从阿育王僧伽蓝出。摩哂陀为上座。僧伽蜜多儿沙弥。须末那等六人。及一优婆塞。名盘头迦。与共俱去。过王舍城至南山村。从此次第而去至母国也。法师曰。何以故。昔阿育王封郁支国。初往至国次第而去。即到南山。山下有村。名卑提写。大富长者以女与阿育王为妇。到国而生一男儿。名摩哂陀。摩哂陀年已十四。后阿育王便登王位。留妇置郁支国。在卑提写村住。是以经文注言。摩哂陀经六月日而至母所。尔时摩哂陀。次第到母国已。母出头面作礼。作礼已竟。为设中食。即立大寺。名卑地写。时摩哂陀少时住寺。而作是念。此间所作已讫。时可去不。摩哂陀复自思念。我今且当待阿育王遣使往师子洲。授太子天爱帝须为王竟。然后我往。使彼太子若登位者。得阿育王拜授为王。并闻如来功德。必大欢喜。我伺其出游眉沙迦山。是时我与相见。过一月已当往到彼。四月十五日众僧集布萨时。便共筹量。于是众僧各各答言。时可去矣。法师曰。往昔说偈赞言

  上座摩哂陀　　大德郁地臾
  大德郁帝臾　　大德跋陀多
  大德参婆楼　　沙弥修摩那
  皆得三达智　　婆塞槃头迦
  已得见道迹　　此诸大士等

尔时天帝释。知闻茶私婆王便已终没。即下白摩哂陀言。师子阿[少/兔]罗陀国王命已寿终。今太子天爱帝须已登为王。我念往昔佛在世时。已记摩哂陀比丘当在师子土中兴隆佛法。是故大德。今应当去。我亦侍从俱往至彼。天帝释即作是言。尔时佛在菩提树下。以天眼遍观世间。即见师子洲中佛法兴盛。敕语我言。可与大德摩哂陀。俱往师子洲中竖立佛法。是故我今作如是言。大德摩哂陀。已受天帝释语已。即从卑地象山。与大众俱飞腾虚空。到师子阿[少/兔]罗陀国。往至东方眉沙迦山下。是故从古至今。名为象山。法师曰。今说往昔偈言

  住卑地写村　　已经三十日
  时至宜应去　　往到师子洲
  从阎浮利地　　次第飞腾往
  譬如虚空雁　　罗列不失次
  如是诸大德　　根本因缘起
  国东眉沙山　　叆叇如黑云
  即到山顶上　　徘徊而来下

尔时诸大德。到师子洲中已。摩哂陀为上座。于时佛涅槃已。二百三十六岁。佛法通流至师子洲中。应当知之。尔时阿阇世王。登王位八年佛涅槃。此年师子童子。而于彼洲初立作王。又有童子。名毗阇耶。往师子洲中。安立人民住止处竟尔时阎浮地王。名郁陀耶跋陀罗。登王位已十四年。此毗阇耶。于师子洲中命终。郁陀耶跋陀罗已十五年。半头婆修提婆。于师子洲登王位。尔时阎浮利地。若那迦逐写迦。登王位二十年。半头婆修提婆王。于彼命终。阿婆耶即代为王。阎浮利地王。名修修佛那迦。作王十七年。阿婆耶王二十年。有波君茶迦婆耶。起兵伐阿婆耶王得。仍即立代为王。阎浮利地王。名迦罗育。在位已十六年。波君茶迦婆耶已十八年。阎浮利地王。名栴陀掘多。作已十四年。波君茶迦婆耶命终。闻茶私婆。代阎浮利地王。名阿育。已在位十七年。闻茶私婆命终。天爱帝须代。尔时佛涅槃后。阿[少/兔]楼陀王闵蹰王。在位各八年。那迦逮婆迦作王十四年。修修佛那迦作王十八年。其儿代名阿育。作王二十八年。阿育王有十儿。并登为王二十二年。次玫难陀代作王二十二年。复有栴陀掘多。作王二十四年。宾头沙罗王代在位二十八年。阿育王代位已十八年。摩哂陀到师子洲中。即是王种。次第应当知。是时天爱帝须王。有星宿恶。忌避出。使臣打鼓宣令。王当出。使臣打鼓宣令。王当出避。与四万众围绕出城。到眉沙迦山。王欲行猎。尔时山中有一树神。欲令王得见大德摩哂陀。树神化作一鹿。去王不远。示现啖草而便徐行。王见化鹿。即张弓捻箭引弓欲射。王复念言。我当谛射此鹿。鹿仍回向阇婆陀罗路而走。王即逐后。到阇婆陀罗。化鹿知去摩哂陀不远而灭。于是摩哂陀见王已近。而作是念。今以神力。令王正见我一人不见余人。大德摩哂陀。即唤帝须。帝须。汝当善来。王闻唤已。而便念言。今此国中谁敢唤我名者。此何等人。着赤衣服割截而成。唤我名字生狐疑心。此是何等。为是人乎。为是神鬼耶。于是大德摩哂陀。即答言。我等沙门释种法王之子。为哀愍大王。从阎浮利地故来到此。尔时天爱帝须王。与阿育王以有书信。遥作知识。是时天爱帝须王。功德瑞相。有山名车多迦。山边生一竹林。林中有三竹。大如辕。一名藤杖。二名华杖。三名鸟杖。藤杖者。其色白如银。金藤绕缠华杖者。黄碧绛黑白华。种种杂华璎珞华杖。鸟杖者。鹰鹞耆婆鸟。耆毗迦鸟。如是种种众鸟。复有四足众生。如生气无异。法师曰。今说往昔偈赞

  车多迦山边　　忽生一竹林
  林中有三竹　　其色白如银
  黄白绛碧黑　　金藤围绕缠
  众鸟及四足　　种种杂华照

海中复出珊瑚真珠摩尼金银种种杂宝。复有八种真珠马珠象珠车珠婆罗迦珠婆罗耶珠缠指珠迦鸠陀婆罗珠世间珠如是天爱帝须王。遣信赍上三竹及众宝物并八真珠。献阿育王。到已阿育王见大欢喜。即答饷。以五种服饰伞拂剑天冠七宝革屣及众宝物不可计数。何谓为众物檀陀迦蝝。及常满河水。腾沙迦华。频伽色发衣一双。手巾青栴檀。有土如平旦时色。阿罗勒果。阿摩勒果王女。法师曰。今说往昔偈言

  天冠拂伞剑　　七宝装革屣
  频伽檀陀蝝　　色发衣一双
  金钵仪一具　　阿耨达池水
  鲜白贵手巾　　无价青栴檀
  平旦色白土　　龙王名眼药
  庵摩阿梨勒　　无上甘露药
  鹦鹉所献米　　其数五百担
  此诸众妙物　　阿育王功德

如是诸妙物。是世间饷也。复有三宝饷。阿育王言。我已归依佛归依法归依僧。作优婆塞。此是释种子法。于三宝中。汝当至心信受佛法。阿育王遣信。答天爱帝须王饷。并授王位。天爱帝须王。以三月十五日受拜王位。经一月日。摩哂陀等来到。复闻摩哂陀说我是释种子。天爱帝须王。于猎场中即复思忆。阿育王书言有释种子。即投弓放箭却坐一面。各相问讯。法师曰。今说往昔偈赞言

  投弓放箭　　却坐一面　　大王坐已
  问讯大德　　句次有义　　时四万人
  往到王所　　各自围绕

是时军众到已。大德摩哂陀。即现六人。王时见已而问。大德。此六人者何时来也。答言。与我俱来。王复问于阎浮利地。有余如此沙门不。答言。彼国土者沙门众多。袈裟之服晃曜国内。皆三达智神通无碍。悬知人心漏尽罗汉。佛弟子声闻众多。王复问言。诸大德等乘何来此。答言。我等不用水陆而来。王自念言。当从虚空来也。摩哂陀复作是念。王有智慧无智慧耶。我当试之。有一庵罗树。王坐近树。摩哂陀因树而问。大王。此是庵罗树耶。王即答言。是庵罗树。置此庵罗树。更有树无。答言。更有。复置此树。更有树无。答言。更有。复置此树。更有余树无。即答言有。复问。置余树更有树无。答此是庵罗树耶。摩哂陀答善哉大王。有大智慧。摩哂陀言。王有宗亲无。答甚多。大德。置王宗亲。余人有宗亲无。答言。极多置王宗亲。置余人宗亲。更有余人无。王便答言。我即是也。摩哂陀答。善哉善哉。大王聪明。自知己身非亲非余人亲。于是大德摩哂陀言。此王智慧能竖立佛法。即为说咒罗诃象譬经说已。王与四万大众。一时俱受三归。是时王听法已。遣信还国欲取饮食。王复念言即今非时。非沙门食也。饮食到已王自欲独食意复疑而问诸大德。大德食不。答言。此非我等沙门食时。王问。何时得净也。答曰。从旦至中得应净法。王曰。诸大德。今可共还国。答言不随我等住此。若诸大德住此。请童子随去。答言。此童子者已得道果通知佛法。今欲出家。王言。若尔者。我明当遣车来奉迎。语已即头顶礼足而便还去。王去不久。摩哂陀唤沙弥修摩那。今应说法。时汝可唱转法轮。修摩那白师言。我今唱令声至何处。答言。使声满师子国。修摩那答言。善哉大德。即入第四禅已。从禅定起。自敕心已。令师子国一切人民俱闻我声。仍便三唱三唱已竟。王闻此声。即遣人往到诸大德所。问有何等触犯诸大德。令声惊大乃至如是。大德答言。无所惊动。此是唱声欲演佛法。是时地神闻沙弥声。即大叫欢喜。声彻虚空中。虚空诸神展转相承。声至于梵天。梵天闻已一切来集。是时摩哂陀。即说平等心经。说已诸天无数皆得道迹。摩睺罗伽迦楼罗等。皆受三归。如昔大德舍利弗说平等经无数人得道。摩哂陀。今说亦复如是。过夜至明旦。王遣车来迎。到已使者白诸大德。今车已至。愿屈而去。答使者言。我等不乘车也。汝但先还。今当随后作是答已。即飞腾虚空。往阿[少/兔]罗国城东而住。是往昔诸佛住处而下。摩哂陀等既初下此处。即名初住处。王遣使者迎诸大德。即召诸臣共料理屋舍。诸臣闻王语已。心中欢喜。王复念言。昨所说法。沙门法者。不得高广大床。王筹量未竟。迎使者还已到城门。使者见诸大德。已先在城东衣服俨然。心大惊喜。入白王言。大德已至。王问使者。诸大德为乘车不。使者答言。不肯乘车。使者复言。我在前还。诸大德在后来。今已先至住在城门。王闻使者语已。敕言。不须安高广床。王教诸臣。令敷地敷上安茵褥。教已。王即出迎诸大德。诸臣即取[毯-炎+瞿]氀重敷褥上。国中相师见王以席敷地。而自念。此诸沙门便令此地永不移转。王迎诸大德。到已头顶礼足。以种种供养迎入国内。于是大德摩哂陀等。见席敷地。各自念言。我等辈法。于此地中不复移转。而各就坐。王以肴膳饮食种种甘味。自手斟酌供设备足。王遣信唤宫中大夫人。名阿[少/兔]罗。与五百夫人。使各赍华香供养王。仍却坐一面。于是大德摩哂陀。即为大众雨大法雨。说饿鬼本生经宫殿本经。开演四谛。说已五百夫人皆得道果。国中人民。先随王到眉沙迦山中者。各相宣传。称叹诸大德巍巍功德。一切国中远近悉来到。国众数填塞。不得看诸大德。作大叫声。王问何物叫声。答言。国中民人。不得见诸大德比丘。故大叫耳。王自念言。此中迮狭不得悉入。王语诸臣。可更料理大象屋中。以白沙覆地。五色华散上。悬施帐幔。诸大德等在象王处坐。诸臣敷施已竟。入白王言。于是诸比丘。往象屋中。到已各坐。为说天使经。说已千人得道。于象屋中人众转多。复移于城南门外。园林名难陀。于中敷施荐席。诸大德比丘往到。为众说读譬经。千人得道。从初日到第三日说法。二千五百人皆得道迹。诸大德住难陀园。国中长者妇女来到。到已作礼问讯。从旦至冥。诸比丘即从坐而起。诸臣惊怪而问。诸大德。今欲何去。答言。我等欲还所住。臣即白大王。诸法师欲去。大王许不。王即白言。大德。今日已冥。云何得去。且停住此时诸比丘答言。不住。王复请言。我父王有园。名曰眉伽。去此不远不近。可在中住。往来便易。于是诸大德随王请住。明旦大王。复往问讯。到已作礼而便白言。夜来得安眠不。起居何如。此园可住以不。诸大德答言。可住。仍说修多罗偈。佛言。我听诸比丘园林中住。王闻说已心大欢喜。即以金瓶水授摩哂陀。手水下着手。是时国土地大震动。王即惊怖。白大德言。大德。何以如此地皆大动。摩哂陀答。大王。勿有恐惧。此国土者十力法兴。欲造大寺在此园地。是故地为先瑞。故现此耳。王闻语已倍增踊跃。于是摩哂陀。明日与众俱。往王宫中食。食讫还住难陀园中

善见律毗婆沙卷第二善见律毗婆沙卷第三

        萧齐外国三藏僧伽跋陀罗译

为诸人民说无始界经。复一日为众说火聚经。如是展转乃至七日。八千五百人皆得道果。佛法于此园中光明流布。以是即名为光明园也。七日已后。诸大德往王宫。说不懈怠经已。往支帝耶山。是时大王。与诸臣共论。此诸比丘教化我等。极令坚固。诸大德为已去未。诸臣答王。诸众僧自来今去。亦当不白大王。于是王与二夫人共乘宝车。千乘万骑围绕驰奔。逐诸众僧。到于支帝耶山。到已置诸从众。王自往到诸大德所。王大疲劳气力嘘吸。摩哂陀。问大王。何以如此喘息。王即答言。诸大德已教授我等。悉令坚固。我欲知诸大德去时。答言。我等不去。为欲前三月夏安居。王问。三月夏安居为是何等。答言。沙门法应三月安居。王当自知。我等无住处。又期日在近。时有大臣。名阿栗抽。兄弟五十五人立在王边。即白大王。我等欲随诸大德出家。王答。善哉。听汝等出家。听已往到摩哂陀所。即度为沙门。发未落地即得罗汉。王于迦那迦庭前。造作六十八房。语已王即还国。摩哂陀。复教化王兄弟十人。极令坚固信心佛法。诸比丘于支帝耶山迦那迦房中三月夏坐。尔时便有六十六人得罗汉。于是诸比丘。夏三月后。到七月十五日自恣。白王夏讫。住此已久。旷绝师久。今欲还阎浮地问讯我师。王即答言。我用四事。供养法师。复有余人。因依法师得三归五戒。今诸大德何故愁忧。大德答言。先依师目下住。朝夕供养礼拜。今此间无师。以是愁忧。王言。诸大德。先云佛已涅槃。今故言有师。诸大德答言。佛虽入涅槃。舍利犹在。王言。我已知诸大德意欲令我起塔。若如是者。愿诸大德。为度量好处。王复念言。地处可得。舍利云何得也。摩哂陀答言。王自与沙弥修摩那共度量之。王答言。善哉。于是大王。即到沙弥修摩那所问言。大德。我今云何得如来舍利也。修摩那答言。善哉大王。但当净治道路扫洒清净。竖诸幢幡散华烧香。种种庄严。王与眷属俱受八戒。以一切妓乐及王所乘象。以璎珞庄严。上张白伞。象正向摩诃那伽园林山中。可得如来舍利。王即答言。善哉善哉。即受教敕。诸大德即往至支帝耶山。到已摩哂陀语沙弥言。修摩那善来。修摩那。汝今往至阎浮利地。向汝祖父阿育王。具宣我意作如是语。大王知识。师子国王天爱帝须。已信心佛法。今欲起塔。大王有舍利。愿时赐与。得大王舍利已。汝可更往忉利天宫向帝释言。帝释有二舍利。一者右牙。留帝释供养。二者右缺盆骨。必付汝来。复问帝释。先言侍从俱往师子国。而今云何晏然不来。修摩那答言。善哉。受敕已。即取袈裟执持钵器飞腾虚空。须臾往到阎浮利地波咤利弗国城门而下。往至王所而白王言。摩哂陀故遣我来。王闻是已欢喜踊跃。王即受取沙弥钵已。以涂香涂钵。即开七宝函。自取舍利满钵。白光犹如真珠。以授与沙弥。沙弥取已。复往天帝释宫。帝释见沙弥已白言。大德修摩那。何因缘故而来至此。沙弥答言。天王先已遣诸大德至师子国。而天王至今不去。帝释答言。我去何所作耶。沙弥问帝释。帝释有二舍利。一者右牙留此。二者右缺盆骨。与我供养。帝释答言。善哉善哉。即取户钥开七宝塔。塔纵广一由旬。即取舍利授与修摩那。修摩那受已。下到支帝耶山。其名曰摩哂陀郁地臾郁帝臾跋陀沙参婆楼等。即取阿育王舍利。置支帝耶山。余缺盆骨。晡时赍往摩诃那园林。沙弥先所敕令。平治道路等。诸事悉已备办。王即乘象。手捉白伞覆舍利上。到支帝耶山。王自念言。此是如来舍利。象自伏地。白伞自下。令如来舍利住我头上。王念未竟。象自伏地白伞自下时舍利函即上顶上。王作语时。王举体怡悦。如得甘露味。即问大德。大德。舍利在我顶上。今当云何。大德答言。置象头上。于是大王。即以舍利函置象顶上。象得舍利发欢喜心。即以音声供养舍利。是时虚空兴云澍雨。随应众生。大地震动乃至水际。天龙鬼神。见佛舍利已至边地。心中欢喜。而说偈言

  如来真舍利　　从忉利天下
  犹如盛满月　　来化于边地
  正住象顶上　　以音乐供养

是时作众伎乐。围绕大象供养殊胜。非可具宣。象面向西而缩行至东。到城门即入城内。城内人民供养恭敬。从南门出。绕取塔园西边。到波醯阇已回取塔园。于塔园中。往昔三佛舍利。皆在塔园。往昔师子国。名塸阇洲。国名无畏。王亦名无畏。支帝耶山。名提婆鸠咤。是时塔园。名波利耶园。尔时鸠留孙佛出于世间。鸠留孙佛声闻。名摩诃提婆。与千比丘俱。到提婆鸠咤而住。亦如摩哂陀住支帝耶山。尔时塸阇洲中众生。染着苦恼。鸠留孙佛。以天眼观看众生。如此苦恼。佛即与七万比丘俱。行到塸阇洲。灭诸疾病。疾病灭已。如来为国人说法。八万四千人皆得道果。如来即以漉水瓶置与国中。于时如来回还本国。人民起塔。以漉水瓶安置塔里。名为波利耶园摩诃提婆。散华供养。于是人民住在国中。拘那含牟尼佛时。师子洲名婆罗洲。国名跋阇摩。王名沙灭地。支帝耶山。名金顶山。是时婆罗国大荒。一切饥俭生大苦恼。拘那含牟尼佛。以天眼观看世间。而见婆罗洲。如来即与比丘千人俱到洲中。以佛神通使天降雨。以时五谷丰熟。佛为国中人民说法。八万四千人皆得道果。佛留一比丘。名须摩那。与千比丘众围绕而住。复留腰绳。尔时如来。与诸大众而共还国。人民起塔。以绳置塔里供养。迦叶佛时。师子洲名慢陀。国名毗沙罗。王名支衍多。支帝耶山。名修婆鸠咤。尔时慢陀洲生大斗诤。又多众生。染着苦恼。如来以天眼观看世间。见慢陀洲有大苦恼。如来与二万比丘俱到此洲。以佛神力灭除斗诤。佛为国中一切人民说微妙法。八万四千人皆得道迹。佛置一比丘。名萨婆难陀。与千比丘俱。佛留洗浴衣。国王人民即起大塔。以佛浴衣置塔里供养。如是塔园展转名字。往昔三佛。皆以所用留与起塔。如是三界无常。止余空地。天人于故塔基处。悉种棘刺。何以故。断于秽恶故。是时大象戴舍利。自然往至故塔园基处。王与人民。即斫伐棘刺。平治如掌。象到故塔基北。于菩提树处。向塔而住。王欲下舍利。象不与。王复问摩哂陀。大德云何得下。摩哂陀答言。不可得下。王当先起基与象顶等。乃可得下。于是大众匆匆共辇土壁。三四日中。象犹顶戴舍利而立。王作基已。复白大德。塔形云何。摩哂陀答言。犹如积稻聚。王答。善哉。于塔基上起一小塔。王作种种供养欲下舍利。举国人民。华香妓乐来观舍利。尔时大众集已。舍利即从象顶上升虚空。高七多罗树。现种种神变。五色玄黄。或时出水。或时出火。或复俱出。犹如世尊在世于揵咤庵罗树神力无异。此非摩哂陀及天人神力。何以故。往昔如来在世之时。遗敕舍利。若我灭度后。往师子国到塔园时。作种种神力。如来已敕。今故现耳。法师言。今说往昔偈言

  佛不可思议　　法亦不思议
  若有信心者　　功德不可思

于此师子洲。释迦如来已三到往。第一往者。教化夜叉已。即便敕言。若我涅槃后。我舍利留住于此。第二往者。教化舅妹子生龙王。此前二到如来独往。第三往者。有百比丘围绕。到已。摩诃支帝耶处。塔园处。菩提处。至东伽那地伽婆毗根那罗尼处。如来而入三昧。如来涅槃后。舍利最后第四往时。作神力出水。于国土中一切人民。悉被水洒除人饥渴。是时舍利。从虚空中下。大众即见下王顶上而便停住。王得舍利下已。而自念言。我今得人身者。有诚实也。即大供养仍取舍利安置塔中。大地六种震动。是时王弟。名曰无畏。即与千人俱共出家。国中五百童子复共出家。国内五百五人童子。又复出家。如是增益。乃至三万人出家。尔时建立塔竟。大王夫人乃与王妹。天龙夜叉乾闼婆。各各供养。供养已竟。摩哂陀即还摩伽园。到已。是时阿[少/兔]罗欲出家。即白王言。王闻已心中怅然。白大德。阿[少/兔]罗夫人今欲出家。愿大德为度。摩哂陀答言。我等沙门。不得度女人我今有妹。名僧伽蜜多。在波咤利弗国。可往迎来。往昔三佛菩提树。皆来种此国。今我等师菩提树。亦应种此间。是故大王。当遣使者到阿育王所。请比丘尼僧伽蜜多。求菩提树来此间种。王答。善哉。受教敕已。即唤诸臣共议。王唤外甥。汝能往阎浮利地波咤利弗国。请僧伽蜜多及取菩提树不。即答言能。于是外甥。与王先要。若王听我出家者。我今当去。不者不去。王答言。善哉。若得僧伽蜜多比丘尼及菩提树来者。当听汝出家。于是外甥。先受摩哂陀教。及受王命。受已。摩哂陀以神通力。令王外甥阿摽叉一日到阎浮俱罗渚。到已即乘舶渡海。到波咤利弗国。是时阿[少/兔]罗夫人。与童女五百人及王宫女五百人。悉受十戒被袈裟衣出在城外。别于城边起立房舍住止。阿摽叉到已白王言。大王儿。名摩哂陀。敕我来此。作如是言。大王知识。天爱帝须王夫人。名阿[少/兔]罗。欲求出家。无人为度。愿王。赐遣僧伽蜜多比丘尼及菩提树。于是使者。宣摩哂陀敕已。往到比丘尼所白言。大德。大德兄摩哂陀。遣我来此。教作是言。师子国王天爱帝须夫人阿[少/兔]罗。与诸童女五百人及王宫女五百眷属俱欲出家。今请大德为师。愿大德时来。比丘尼闻兄信已。即匆匆而起。往到王所。而白王言。大王。我兄信至。天爱王夫人及诸女人。求出家为道。请我为师。今正待我。我今欲去。白王令知。王即答言。我儿摩哂陀。孙子修摩那。自去之后。我常如人断手足无异。我久不见二人。日夜忧恼不离于心。我见汝面得适我心。汝今复去。我必死矣。汝止莫去。僧伽蜜多答言。大王。我兄信至重。不可得违。刹利夫人阿[少/兔]罗。复欲出家。今正待我。是故我今应当往彼。王即答言。若汝兄信如此。可去并菩提树。僧伽蜜多白王。菩提树在何处。大王答言。在阿兰若处。王先有心。欲取菩提树。不可以刀斧断。云何得取。王罔然无计。而问大臣提婆。提婆答言。诸大德比丘应知。王答。善哉。为设中食。众僧食竟。王白诸比丘。如来菩提树。可往师子国不。众僧推目揵连子帝须。为知此事。于是目揵连子帝须答言。菩提树可往师子国。何以故。尔时如来在世。已有五敕。何谓为五。佛已卧床临欲涅槃时。而作是语。当来阿育王。取菩提树与师子国者。使菩提树南边枝去。不用刀斧自然而断。断已来入金盆。此是一敕。若我菩提树。是时树即于盆中。上升虚空而入云住。此第二敕。若入云已停住七日竟。自然而下入金盆已。即便茂盛布叶结实。其叶色玄黄种种示现。不可具陈。此第三敕也。若往师子国可种。初欲种时作种种神变。此第四敕。若我舍利一斗。到师子国即现。如我在世相貌形状。三十二大人相八十种好。光明赫烈倍于日月。此第五敕。大王闻有五敕。心大欢喜。从波咤利弗国。步至菩提树所。多将紫磨金。是时天帝释巧匠。名毗舍。知王心已。作锻师立在王边。王即唤言。锻师。可取此金锻用作盆。锻师白王。广大云何。王即答言。此是汝业。汝自知之。锻师答言。善哉。我今当作。即便取金。以神通两手徘徊。即成金盆。围绕九肘。可高五肘厚八寸许。盆口团圆如象王鼻。于是阿育王部伍大众。千乘万骑竖诸幢幡。种种珍宝华香璎珞妓乐庄严。广三由旬长七由旬。出国围绕而去。又将诸比丘僧。俱到菩提树所围绕而住。阿育大王。与诸小国王千人。迎菩提树。阿育王在中央住。诸小王等于外围绕。于是阿育王等。仰看大树及南面枝。是时树作神力故。令树隐蔽不现。唯余一枝形长四肘。大王见树神力不现。即发欢喜心。今以阎浮地一切土地。及取王公服璎珞香华种种供养。周回八方向树头顶作礼。以阎浮利地王位。拜树为王。拜已白诸众僧而作誓言。许我取树与师子国者。令树悉现及南面一枝。王即以七宝作师子座。以金盆上置高座上。阿育王即上高座。自执画笔磨雄黄石。王复作誓言。若菩提树必许往师子国者。复以我有信心者。摩诃菩提。自然落金盆中。是时王作誓已。树即复如本。是时以涂香为泥。满金盆中。以笔画树枝曲处作十画。九画生根一画处断。根长四寸又生细根。交撗抽叉犹如罗网。大枝长十肘。复有五枝。枝各长四肘。五枝各生一子。复有千小枝。大王见菩提树神变如此。心大欢喜合党向树。发大叫声。众僧唱萨。于是诸小王。及侍从者一切大众。悉大叫唤。是时地神惊怪。复大叫声。声彻虚空。如是展转。声至于梵天。是时树枝自然从本而断。落金盆中。即有百根。直下至盆底。复有十根穿度盆下。九十细根围绕而生。如是次第日夜增长。是时大地六种震动。于虚空中。诸天作众妓乐。诸山树木皆悉大动。如人舞状。天人拍掌。夜叉鬼神皆大熙笑。阿修罗王歌呗赞咏。梵王欣悦。于虚空中雷电霹雳。四足众生驰走鸣唤。诸鸟飞翔出种种音。阿育王及诸小王。共作妓乐。如是众声。上彻梵天。是时菩提树子。出六色光。光明遍照满娑婆世界。上至梵天。时菩提树上升虚空停住七日。七日竟。大众唯见光明。不见金盆亦不见树。王即从七宝师子座下。七日作供养菩提树。七日竟。树复放光明。照娑婆世界。上至梵天摄光还复。于虚空中云皆清明。菩提树布叶结实。璎珞树身。从虚空而下入金盆。大王见树入金盆已。即大欢喜。复更以阎浮利地。供养小菩提树以阎浮利地七日供养。八月十五日自恣日。晡时菩提树入金盆中。七日从金盆出。上升虚空停住七日。从虚空下入金盆中。王以阎浮利地。拜菩提树七日为王。九月十五日众僧布萨日。菩提树从其所生处一日发来。到婆咤利弗国城东。置娑罗树下。菩提树即生郁茂。王见已生大欢喜。又以阎浮利地。更拜为王。供养已。白僧伽蜜多。时可去矣。答言。善哉大王。即与八部鬼神护菩提树。八种大臣。有八种婆罗门。有八种居士。有八具波伽人。有八鹿罗车人。有八迦陵伽人。王舁八金瓮八银瓮辇。水灌菩提树。受王教已依事而作。王俱与大众。围绕菩提树。次第而送于路上。天人夜叉乾闼婆阿修罗日夜供养。到多摩摽渚。王自担菩提树入水。齐颈即上舶上。与僧伽蜜多。王唤阿摽叉。阿摽叉菩提树在我国。我以阎浮利地。三拜为王。我自戴菩提树入水。至颈送置舶上。便敕阿摽叉。若菩提树往到彼国。汝可语。汝王身自下水没颈。迎菩提树顶戴担上。如我于此种种供养无异。作是敕已。舶即发去。是时海中当舶住处。纵广一由旬无有波浪。王自念言。佛菩提树今从我国去。作是念时。流泪悲噎。舶去之后。王遥望见。种种杂华从海水出。随从舶后以供养之。又虚空中散种种华妓乐供养。水神又以种种华香供养菩提树。如是展转供养。乃彻龙王宫。龙王即出欲夺取菩提树。于是僧伽蜜多比丘尼。化作金翅鸟王。龙王见比丘尼神力如是。即头顶礼足白言。今我欲请菩提树及大德。还我宫中供养七日。于是菩提树及大众。悉入龙王宫中。龙王以位拜菩提树为王。七日供养。过七日已。龙王以十月生一日。自送菩提树一日。到阎浮俱那卫渚。阿育王遥望。不复见菩提树。啼哭而还。是时天爱王。辄如须摩那沙弥先敕。平治道路扫洒清净。竖立幢幡。种种供养。从北城门到俱那卫渚。地平如掌。待菩提树至。僧伽蜜多以神通力。令王于城内遥见菩提树来。王即从城出。将五色华处处散。乃至阎浮俱那卫渚。一日即到。作种种妓乐入水齐颈。王自念言。佛菩提树今到我国。发念未竟。于是菩提树放六色光。王见已心大欢喜。即以顶戴上。国有耆旧十六大姓。与王共迎菩提树。到岸上已三日。以师子洲供养菩提树。十六大姓知王国事。三日竟至四日。担菩提树次第到阿[少/兔]罗陀国。到已举国人民欢喜礼拜供养。十月十四日过中。菩提树从北城门入。当城中央。而复更从城南门出。从城南门去五百弓。此处如来已曾入三昧。非是释迦牟尼一佛。过去诸佛亦皆于中而入三昧。俱那卫佛菩提树。树名摩诃沙利婆。俱那含佛菩提树树名忧昙钵。迦叶佛菩提树。树名尼俱陀。于弥伽园中。沙弥修摩那。敕执作基墌都围度量布置门屋。及菩提树所住之处。皆令整理于王门屋处置。是时十六大姓人。悉着王公服。围绕菩提树已。便于王门屋地种。始放树。树即上升虚空。高八十肘。即出六色光。照师子国皆悉周遍。上至梵天。尔时众人。见树种种变化。心大欢喜。众中万人同时发心念佛。次第得阿罗汉。即共出家。日光未没树犹在虚空。日没后从虚空。似娄彗星宿。而下至地。地皆大动。是时摩哂陀。与僧伽蜜多王及国人民。来集于菩提树。时众人见北枝有一子而熟。即从枝堕落。以奉摩哂陀摩哂陀以核与王令栽。王即受于金盆中。以肥土壅。又以涂香覆上。须臾之间即生八株。各长四肘。王见如此惊叹。以白伞覆上。拜小树为王。王取一株种于阎浮拘罗卫渚。取一株薄拘罗婆门村中种。取一株种收椒门中。一株种塔园中。一株种摩醯首罗寺。一株种支帝耶山中央。一株种楼醯那村。一株种往罗村。余四子在树上。次第熟落。合生三十二株。悉取于由旬园种。如是展转增生。满师子国中。以菩提树故。国土安隐无有灾害。于是阿[少/兔]罗夫人。与千女俱。往僧伽蜜多所。僧伽蜜多即度为比丘尼。从度之后。次第得阿罗汉。王外甥阿摽叉。与五百人出家。出家之后。次第得阿罗汉。又一日王与摩哂陀。往礼菩提树。到铁殿处。人民献华于王。王以华奉摩哂陀法师。法师受已。以供养铁殿。华堕地。地即震动。王见地动即问。大德。此地何忽动也。答言。大王。当来此殿众僧说戒。是故地现此瑞也。次第而去。到庵罗处。有人以庵罗子香味具足献王。王以奉摩哂陀。摩哂陀啖。取核语王言。可种此核。王即种以水洒地。地皆震动。王问。何故地动。大德言。当来世众僧集处故。现瑞相也。王即散华八过作礼而去。到支帝耶处。有人以薝卜华献王。以奉摩哂陀处作礼。礼竟地动。王问。何以地动。大德答言。当来此处。起如来大塔故现瑞。王言。我今当立塔。摩哂陀答言。不须王立。王多诸造作。当来世有王孙子王名木叉伽摩尼阿婆耶。当起大塔。王问大德。是我孙子起塔功德。我获其福不。大德答言。不得获也。王又作方便。令入功德。即取一石柱高十二丈。而刻石柱记。我孙子名木叉伽摩尼阿婆耶。当来此中起大塔。王复问大德。大德。佛法今根株着师子国未。摩哂陀答言未。王问。何时着。大德言。若师子国人中出家。其父母悉是师子国人。不杂他国人。若出家已。便取法藏及毗尼藏。是时然后。佛法根株着师子国也。王复问大德。大德答言。王外甥阿摽叉。此比丘是也。于佛法极大勇猛。王更问。我今竟何所作。大德答言。当作众僧集堂。王答。善哉。于时大王有大臣。名弥伽槃茶。弥伽槃茶住处。于其中起作集堂屋。如阿阇世王殿无异。用王威德作已。一切种种妓乐。各各自然分布处所。王自念言。我今往看佛法根株下。数百千人围绕大王。往到塔园也

善见律毗婆沙卷第三善见律毗婆沙卷第四

        萧齐外国三藏僧伽跋陀罗译

尔时塔园中摩哂陀。与比丘一千人俱。敷摩哂陀坐具南向坐。又敷大德阿摽叉北向坐。大德摩哂陀。请阿摽叉为法师。阿摽叉仍依往昔大德优波离无异。摩哂陀。与大僧六十八人围绕法座。王弟比丘。名末多婆耶。与五百比丘俱欲学律藏。悉围绕阿摽叉高座。余诸比丘。与王各次第而坐。于是大德阿摽叉。即便为说。尔时佛住毗兰若那邻罗宾洲曼陀罗树下说律叙。说已于虚空中天大叫称。善哉善哉。非时而雷电霹雳。地即大动种种神变。于是大德阿摽叉及摩哂陀。与爱尽六十人俱。复有六万比丘围绕。于塔园寺中说如来功德。如来哀愍众生三业不善。是故说毗尼藏。以制伏身口意业。如来在世为声闻弟子说律藏竟。然后入无余涅槃。尔时众中。而说偈言

  一切别众住　　大德六十八
  共知律藏事　　法王声闻众
  爱尽得自在　　神通三达智
  以无上智慧　　教化师子王
  光照师子国　　周遍无不睹
  譬如大火聚　　薪尽入涅槃

诸大德涅槃后。诸弟子眷属。名帝须达多迦罗须末那毗伽修摩那。此是大德阿摽叉弟子。如是师师相承展转至今。是故第三集众。众中而问。谁将律藏至师子国。答是摩哂陀。摩哂陀之后阿摽叉。阿摽叉弟子。如是次第受持。譬如白琉璃器盛水。内外明彻水无漏落。诸大德持律藏。亦复如是乃至于今。若人有信心恒生惭愧好学戒律者。佛法得久住。是故人欲得佛法久住。先学毗尼藏。何以故。有饶益行者故。何谓饶益。若善男子好心出家。律藏即是父母。何以故。与其出家令得具足教学威仪。依止律藏自身持戒。能断他疑。若入僧中无所畏惧。若有犯罪依律结判。令法久住。诸法师言。佛语比丘。若受持此律。有五事利。何谓为五。一者自能持戒。二者能断他疑。三者入僧无畏。四者建立佛法。五者令法久住佛说持律人即是功德根。因根故摄领诸法。法师曰。佛说戒律。为欲止恶因。止恶故生不悔心。因不悔心故。得生欢喜。因欢喜故。得生安乐。因安乐故。得生三昧。因三昧故。得生慧眼。因生慧眼故。而生厌污。因厌污故。而得离欲。因离欲故。而生度脱。因度脱故。得度脱智。因度脱智。次第得入涅槃。为欲言故。为欲说故。为依止故。为欲闻故。如是次第心得度脱智。是故殷勤当学毗尼。此是毗尼处说根本法师曰。而说偈言

  若人时何故受持　　若人将耶若处住

已说此次第今说

此是偈义。今当说律外序也

尔时为初义非一种。我今当演毗尼义。是故律中说。尔时佛住毗兰若。初义者。尔时尊者舍利弗从三昧起请佛结戒。是时佛住毗兰若。尔时者。发起义。是时者。即说其事。何以故。如律所说。尔时须提那与故二作不净故。是时佛因须提那故。为声闻结戒。此是初义。尔时檀尼咤比丘偷王材。是时佛于王舍城结戒亦如是。尔时者。亦是发起义。亦是因义。佛婆伽婆后当解。住者。行立坐卧。毗兰若者。是国名也。那邻罗者。即夜叉名。因夜叉鬼依此树故而号之。宾洲曼陀罗者。此是练木树也。树下者。日当中阴所覆处是也。又言。无风时叶落堕地处是。问曰。如来何以在此树下住。答曰。此树郁茂林中第一。去城不远往来便易。问曰。如来住毗兰若。复言住在树下。如来不应二处住。答言。勿作此难。毗兰若者。往来处也。树下者。即是住处。问曰。优波离何以说毗兰若。答曰。哀愍白衣故。问曰。何以树下住。答曰。为诸弟子顺出家法除贪欲故。问曰。何以依近于国。答曰。为四大故。问曰。前句者。为说法故。后句者。如来欲入静故。前句者。慈悲所牵。后句者。从苦入乐故。前句者。为安乐众生故后句者。自安乐身故。前句者。布施法与众生故。后句者。自除圣利满足。前句者。为众生作桥梁故。后句。为诸天人故。前句者。同众生故。后句者。不与众生同故。前句者。唯佛一人三界独尊。众生因佛故。得大安乐。是谓为一。后句者。因佛生在林中乐树下故。法师曰。此义甚广我今略说。与大比丘僧俱者。大者。因小有大故。所以比丘僧功德极大名为大。复有大义。最小者得须陀洹道故。复有大义。五百大众集故。僧者。等戒等见等智等众。是为僧也。俱者。共在一处。五百比丘者。五百数也。毗兰若婆罗门者。生于毗兰若国。因国号之。婆罗门者净行也。又复婆罗者。知外道围陀书。门者闻也。佛经言婆罗门者。能除烦恼。门者听也。声彻于耳。因他语故而知法。沙门瞿昙者。灭恶法也。瞿昙者。婆罗门以姓唤故。释迦种子者。释迦种者。指示大姓。离释种出家。此是演发心信乐出家也。或有负债出家。或有失国出家。或有贫穷出家。或有避王使出家。如来不如此出家。如是好名闻者。如是足句也。好者。与众善会复言最上。名闻者。赞叹受名。又言令他知之。婆伽者。此是初如来十号。令众生信心于佛。是故法师演出如来功德。阿罗者。是三界车辐。汉者。打坏三界车辐。所以如来打坏三界车辐。故名阿罗汉也。又言。阿罗者杀贼。所以如来杀烦恼贼。故名阿罗汉。又言。阿罗者。一切恶业。汉者。远住三界为车。无明爱缘行者为辐。老死者为辋。受生者为毂。诸烦恼者为轴。无始世界流转不住。佛于菩提树下。以戒为平地。以精进为脚足至心为手。智慧为斧。斫断三界车辐。又言。无始世界者为车。无明为毂。老死为辋。十恶为辐。何以故。不知苦法。若生欲界。因无明故造作三业。若生色界。造作色界业。若生无色界。造作无色界业。于欲界中。缘无明故受识。色界中亦尔。于无色界中。无明缘也。又于欲界中名色。欲界中六入缘无明。欲界中名色。色界中三入。缘于无色界中无明。色界中一入。缘于欲界中六入。欲界中六触。缘于色界中三入。色界中三触。缘于无色界中一入。无色界中一受。缘于欲界中六触。欲界六乐。缘于色界中三触。色界中三乐。缘于无色中一触。无色中一乐。缘于欲界中六乐。欲界六乐者。生六爱。缘于色界中三乐。色界中三爱。缘于无色界中一乐。无色界中一爱。缘处处爱。生于生中。若人于五欲中。我欲行欲自受欲故。身口意不善行具足者。即入地狱。于地狱中。因业故。受生受生。此是业生也。因业生五阴。次五阴老。老者熟。坏五阴者。谓之死也。于三界中我欲。于天上行欲。起立善行。或忍辱因善行故。得生天上。此是因善业故。而复生。有一人。我欲受梵天乐。因乐受故。忆念四法。何谓为四。慈悲喜舍心。忆已具足。得生梵天。于梵天中。生因业故。此是业生。复有一人。我欲生无色界。我次生非想非非想天。恒自入禅思惟。即生此处。此是因业得生。余者次第汝自当知。过去当来二世。皆从无明缘行。我今略说。余汝自广说。无明缘行。此是一品。六识名色六入六触六乐。此是一品。爱取生。此是一品。有老死。此是一品。前品者。过去世也。中二品者。现在世。后品者老死。此是当来世也。取无明缘行者。连得爱受。此不得相离。此五法过去世也。中品六入为初。此是果报。若取爱受者。连得无明。此五法今业生也。有老死者。一切五法。余者六识。为初后悉入。此是当来世生。若分别说者。有二十四种。缘行六识。此二者中间为一品。受爱于二中间为一品。生有者于二中间为一品。合有三品四段。因品故。生二十种本起因缘。如来已见观度。真实知故。以真实智。名为实知。见者。何谓为见。见者达故。名为见也。观者何谓为观。遍知一切。故名为观。以知观见度。如来真实知已。生厌患想。便生离心欲得度脱。先坏三界车轴故。名为阿罗汉。又罗汉名者是应供。问曰。何谓名为应供。受人天供养故。名为应供。昔有梵王。以宝大如须弥供养如来。是故名为应供。尔时世间大王。瓶沙王拘沙罗王等。复种种供养。是名应供。佛涅槃后阎浮利大王。名阿育。复以金钱九十六亿。起八万四千宝塔。复大种种布施。是名应供。余诸大众供养者不可称计。又言。阿罗汉者。罗汉者覆藏义。阿者无也。名无覆藏。何谓无覆藏。譬如世人作罪恒自覆藏。如来于中永无故。名无覆藏。三藐三佛陀者善知一切法故。名三藐三佛陀。言佛陀者。法应知而知。法应弃者而弃。应出者而出。是名佛陀。又言。佛陀复有别义。何者。以慧眼若见苦谛集谛灭谛道谛。次第明见。是佛陀也。色声香味触法。眼识耳识鼻识舌识身识意识。眼触耳触鼻触舌触身触意触。眼记耳记鼻记舌记身记意记。眼念耳念鼻念舌念身念意念。眼爱耳爱鼻爱舌爱身爱意爱。眼思耳思鼻思舌思身思意思。五阴十观法十思十念。胮胀为初。如是有十段为初。有三十二十二入十八界。欲生为初。九四禅为初。慈为初。复有四无色禅。有四无色三昧。有四十二因缘。逆观老死忧悲乃至无明。次第观乃至老病死苦恼。老病者苦谛。有者集谛。从二者出。名灭谛。知方便灭。名为道谛。如来一一善知一切。是名三藐三佛陀。知者三知。亦有八知。于三界经中说有八知。汝自当知。复次庵罗树经。三昧知神通知六通。合为八知。行足者。或覆藏六识饮食知足省于睡眠七正法四禅。此是十五法。自当知。如来以法行。是故名明行足。如来以此法行至涅槃。是名明行足。不但如来。声闻亦然。如来以知行而足。故名明行足。以知相故。如来得一切智。以行故。名为大慈悲。一切众生惟集苦恼。如来悉知。以大慈悲故。知众生苦恼。而能善说。令舍苦就乐故。故名善逝。是故声闻善逝而行善逝。非恶善逝。又言。行至善处。是名善逝。又行步平正威仪具足无缺。亦名善逝。又往常住不复更还。名为善逝。以阿罗汉道不及。名为善逝。自从锭光佛受记。哀愍众生令得安乐。乃至菩提树下善行如此。是名善逝。不从断见不从常见。身离疲苦不从断常。名为善逝。为一切众生说法无不应时。名为善逝。众生不乐而不说。乐者而说。是名善逝。所说者。皆是真实义。非虚妄义。又一切众生闻之。悉令欢喜。是名善逝。又不说无义语。所说者。皆是有义利益。是名善逝。世间解者。知一切世间法。名为世间解以集谛故。以灭谛故。以灭谛方便故。解世间故。是名世间解。如经所说。亦不生不老不死不堕不住处。我不用行至世间彼岸是名世间解。佛语诸比丘。我未至世间极。我不说苦尽。佛语诸比丘。此身一寻称为沙门。世间集谛。世间灭谛。世间苦谛方便我不用行。而至未至从苦而出。无有是处。又世间者。有三。何谓为三。一者行世间。二者众生世间。三者处世间。问曰。何谓行世间。答曰。一切众生从饮食生。是为行世间。何谓众生世间。答曰。常世间无常世间。是为众生世间。何谓处世间。以偈答曰

  日月飞腾　　照于世间　　光明无比
  无所障碍

此是处世间。又言。一世间二世间三世间四世间五世间六世间七世间八世间九世间十世间如是乃至十八世间。问曰。何谓为一世间。答曰。一切众生以饮食得生。是名一世间。何谓为二世间。答名色是为二世间。何谓三世间。答曰。苦乐不苦不乐。是为三世间。何谓四世间。答曰。四食是为四世间。何谓五世间。答曰。五阴。何谓六世间。答曰。六入。何谓七世间。答曰。七识。何谓八世间。答曰。八世间法。何谓九世间。答曰。九众生居。何谓十世间。答曰。有十入。何谓十二世间。答曰。十二入。何谓十八世间。答曰。十八界。此是行世间。如来以一一知。名为世间解。众生烦恼。如来亦解。行亦解。意亦解。小烦恼大烦恼亦解。利识亦解。钝识亦解。善缘亦解。恶缘亦解。应令知亦解。不应令知亦解。生不生亦解。是名众生世间靡所不知。是为世间解。处世间者。问曰。何谓处世间答曰。铁围山纵广二万三千四百五十由旬。周回三十七万三百五十由旬。地厚四那由他二万由旬。在水上水厚八那由他四万由旬。在风上风厚六十九万由旬。是处世间界。又须弥山根。入海八万四千由旬须弥山王高亦如是。以七宝缠。有七山围绕之。而说偈言

  由揵陀罗　　伊沙陀罗　　迦罗毗拘
  须陀苏那　　尼民陀罗　　毗那多迦
  阿沙千那　　是七大山　　围绕须弥
  四天王住　　天夜叉住　　高百由旬
  雪聚大山　　广千由旬　　纵广正等
  顶有八万　　复有四千　　以严饰之
  有阎浮树　　高二千里　　围二百里
  枝布方圆　　覆百由旬　　因此树故
  号阎浮地　　大铁围山　　根入大海
  深下八万　　二千由旬　　高亦如是
  常住不坏　　都绕世间　　月众星王
  方圆四十　　有九由旬　　日王方圆
  五十由旬

又天帝释宫。纵广万由旬。阿修罗宫亦复如是。阿鼻地狱亦如是。阎浮利地亦尔。西拘耶尼。纵广七千由旬。东弗于逮亦复如是。北郁单越。纵广八千由旬。一一洲。各有五百小洲围绕。此是铁围山之内。铁围之外中间。悉是地狱铁围无量。世界亦无量。所以佛以无量慧眼。遍知一切。故名为世间解。无上士者。自以功德过于人天故。名无上士。以戒定慧解脱解脱知见具足故。名无上士。是故无上与无上等。佛语诸比丘。我不见梵魔沙门婆罗门世间戒定慧解有能及佛者。又无我师故。名无上。调御丈夫者。有应调者辄而调之。何以故。譬如象马[怡-台+龍]悷加之杖捶然后调伏。如来亦复如是。能调伏一切众生。故名调御。昔佛降伏畜生。龙王丈夫。名阿波罗留又。象丈夫。又名纯杵魔朽陀陋阿耆死驱偷魔死驱死驱陀那。如是诸丈夫。佛以善法调伏。令入正法。授三归五戒。人丈夫。名尼揵陀子阇跋。又婆罗门十轲罗娑鸯掘魔罗等。如是无数。复有夜叉丈夫。名阿罗婆迦修至满魔轲罗。诸夜叉丈夫。释提桓因等如是无数天人。以正法调伏之。于修多罗说。佛语寄须。汉言牧象人我调御丈夫。以柔法教一切众生。若其不受者。当以强法教之。若不受者。复当以刚柔教之。若不受者。便不与和合。法师曰。此修多罗当如法广说。故名无上调御丈夫天人师。师者。亦如估客有一宗主善知崄难。问曰。何谓为难。一者贼难。二者虎狼师子难。三者饥俭难。四者无水难。宗主于诸难中。皆令得度到安乐处。故名为师。如来亦复如是。何以故。如来能度众生。令过崄难。何谓为崄难。一者生难。二者病难。三者老难。四者死难。如是诸难。如来能度脱。令得安乐处。故名为师。问曰。佛何以独为天人师。不为畜生师耶。昔如来在世亦为畜生说法。何以独称为天人师。修多罗经说。尔时佛在瞻婆国。于迦罗池边。为瞻婆人说法。是时池中有一蛤。闻佛说法声欢喜。即从池出入草根下。是时有一牧牛人。见大众围绕听佛说法。即往到佛所。欲闻法故以杖刺地。误着蛤头。蛤即命终生忉利天。为忉利天王。以其福报故。宫殿纵广正十二由旬。于是蛤天人。霍然而悟。见诸妓女娱乐音声。悟已寻即思惟。我先为畜生。何因缘故生此天宫。即以天眼观。先于池边听佛说法。以此功德得此果报。蛤天人即乘宫殿。往至佛所头顶礼足。佛知故问。汝是何人忽礼我足。神通光明相好无比。照彻此间。蛤天人以偈而答

  往昔为蛤身　　于水中觅食
  闻佛说法声　　出至草根下
  有一牧牛人　　持杖来听法
  杖搀刺我头　　命终生天上

佛以蛤天人所说偈。为四众说法。是时众中八万四千人。皆得道迹。蛤天人得须陀洹果。于是蛤天人得道果已。欢喜含笑而去。故称为天人师。佛婆伽婆者。佛者。名自觉亦能觉他。是名为佛。又言知。何谓为知。知谛故。故名为佛。又言觉悟世间。是名为佛。于三达智经自应当知。婆伽婆者。一义利益。二者无上。三者恭敬。四者尊重。何以名恭敬尊重为世间应恭敬尊重。世间有四名。一者随。二者志。三者因。四者号。问曰。何谓为随名。答曰。如世间人唤牛小即犊子。次而丁牛大者唤老牛。此名不定随时而唤。问曰。何谓为志名。答曰。如人持伞持杖。即唤为有伞人有杖人。是为志名。问曰。何谓为因。答曰。譬如贫人因奴得宝故。字奴为多宝。是为因名。婆伽婆者。号名。何以故。非白净饭王作名。非八万眷属作名。非天帝。亦非兜率天梵魔此等作名。何以故。佛语舍利弗。我名号者。非父母作。非八万眷属作。非天帝。非兜率天梵魔天作名。次第解说。于菩提树下。等一切智。真实观见唯婆伽婆。是故佛自作号。无敢为佛作名号者。何以故。佛自观身威德智慧故。现令众生知而立名号。婆伽婆者。婆伽者过。婆者有也。过有故名婆伽婆。又言。贪嗔恚痴颠倒心。不羞不畏优婆那诃(汉言嗔盛)不喜。他好嫉妒虚心曲心[夢-夕+登]瞢心。贡高极贡高醉懈怠。爱无明恶根不善作垢不净。不等记思四颠倒。流结没受五支斗(汉言触为初也)五盖念六斗诤本爱聚众生烦恼。八邪见九爱本十恶法道。六十二见百八烦恼。渴疲极万烦恼。略说五烦恼聚。天人魔梵。如此等众不能毁坏如来。是名婆伽婆。又言。如来能坏毁欲嗔恚诸愚痴烦恼流恶法等。是名婆伽婆。又言。如来有三十二大人相。八十种好。相好无比离诸烦恼。天人世间恒欲往生。到已。佛观众生心随所乐。即便为说。是故名婆伽婆。世间伽婆有六种。一者领。二者法。三者名。四者微妙。五者欲。六者念。问曰。何谓为领。答曰。自领心故。何谓为法。答曰。如来法身一切具足故。何谓为名。答。佛名清净。无所不遍故。何谓微妙。答曰。佛身具足一切微妙。观之无厌故。何谓为欲。答曰。佛欲有所至应心即到。佛欲自为又欲为他故。何谓念。答曰。一切众生皆以念心供养故。故名婆伽婆。又言。婆伽婆者。分别义。问曰。何谓分别。答曰。功德为初分别诸法。五阴十二入十八界四谛六识十二因缘。一一分别关知。苦谛逼迫不定。是为苦谛。着不舍聚。是为集谛。灭苦受。是为灭谛。因缘得出。是名道谛。如是分别故。故名婆伽婆。又婆伽婆者。婆伽者三界。婆者吐。吐三界烦恼故。名婆伽婆。世间有天人梵魔沙门婆罗门。是名世间。天人者。六欲天人。魔者六天。梵者富楼天。沙门婆罗门者。佛法怨家。又天人者。世间诸王亦入天人。又天人者。含取欲界天人。魔者。含取天魔界。梵者。无色梵天界。沙门婆罗门者。含取世间四部众故。所以尔者。收取上下悉入如来功德。悉能通达如此诸处。自以知说法者。自用方便而知。故名自知者。自用慧眼而知。是名为知。又言。知者。知无障碍故。名知。说者。觉令知。是名为说。又言。开一切法故。名说。问曰。佛何以为众生说。答曰。于一切众生生大慈悲故。度无上安乐。为众生说法。或一句或一偈或多或少。是名为说。初善中善后善。其义巧妙纯一无杂一切具足。皆是一味。复言。初品者初善。中品者中善。后品者后善。又言。戒者初善。三昧得道者中善。涅槃者后善。又言。戒者三昧初善。禅定与道者中善。果与涅槃者后善。佛者善觉。名为初善。法者善法。名为中善。僧者善随。名为后善。问曰。何以众僧名为后善。答曰。若闻已不动不摇得圣利故。是名后善。佛菩提者。名为初善。辟支菩提者。名为中善。声闻菩提者。为后善。初说者。闻已即离五盖于一切诸善。是名初善。闻已而随。名为中善。随已渐渐得道。是名后善。如是如来。或多或少而为说法。于多少中亦有初中后善善。义善文字。何以故。如来说法。梵行法梵行道。以种种方便。开示令知。此说有义是名义善。又言善义者句。亦言开示。亦言分别。亦言不覆藏。连句相续不断。是名善义。善字者。能持深义指示深义。是名善字。法辩义辩辞辩乐说辩。唯聪明人能知此理。非愚夫能解。其义深邃唯智者能别。是名善字。美满具足者。义既美满。具足者。义既美满不假卑足。故名具足。开示梵行。问曰。何谓为梵行。答曰。梵天人所行此法。故名梵行。何以故。开示梵行初善。有因缘故中善。义不颠倒后善。闻者欢喜而随。是名开示梵行。问曰。何以名美满。答曰。戒为初五法聚。是名为美满。义之不杂。是故名净。如来为众生说法不贪供养。是名净梵行者。佛辟支佛声闻所行者。是名梵行。善哉如是行相可往问讯。问曰。何谓为善哉。答曰。将众万善故名善哉。亦言。将安乐故。是名善哉。如是者。以足句。行相者。行者所行过人相者相貌具足。可往问讯者。可往观佛。问曰。何谓为观。以两眼视。谓之为观。于是毗兰若婆罗门作是思惟已。往到佛所共相劳问。婆罗门问佛。四大堪忍不。声闻弟子少病少恼四大轻利不。安乐住不。是名劳问。身与婆罗门。共相问答义味次第。心中欢喜忆持不忘。问讯已却坐一面。却者。犹如日转。坐者。身体布地。一面者。在于一边。智慧之人往到宿德所。坐避六法然后可坐。何谓六法。一者极远。二者极近。三者止风。四者高处。五者当眼前。六者在后。问曰。远坐何过。答曰。若欲共语言声不及。大近何过。答曰。触忤宿德。上风何过。答曰身气臭故。高处何过。不恭敬故。当前何过。视瞻难故。后坐何过。答曰。宿德共语回顾难故。婆罗门离此六法而坐。是故律中说却坐一面。沙门者。伏烦恼。又言却烦恼。又言息心。婆罗门者。世间真婆罗门父母不杂。长者者。身体长大亦年纪长大。又言。有威德。是名长者。财富者亦名长者大老者。头发堕落。又言生又子孙展转相生。是名老。朽迈者。皮肤燋皱言语错谬。是名朽迈。年过者。生来已经二三王代职。犹故生存。是名年过。延寿者。年过百岁。是名延寿。至年者。是最后年。是名至年。咄瞿昙沙门何以作。此是婆罗门语。婆罗门到佛所。见佛不起不为作礼不施床座。故作此言。如我所闻。今正见于如来。欲自称身而下余人。佛以慈悲心而答婆罗门。我不见佛于林中生时。堕地向北行七步。自观百亿万天人梵魔沙门婆罗门。无堪受我礼者。观看已而自唱言。天上天下唯我为尊。梵天闻菩萨唱已。即叉手而言。菩萨三界独尊无有过者。菩萨闻已作师子吼。唯我独尊。佛语婆罗门。尔时我未得道时三界已自独尊。何况于今众善功德拜我为佛。云何为汝作礼耶。若人受我礼者。头即堕地。是故汝勿于佛处希望礼拜。是婆罗门瞳蒙无知。向佛而作是语。婆罗门言。若如是者色无味。何以故。有色而已实无味。佛欲调伏婆罗门故。答言。汝言无味。实无味。何以故。如世间人色声香味触。以此为味。如来于此已断。譬如断多罗树永不复生。婆罗门言。若如是者便为贡高。佛答言。因汝语故。即有贡高。何谓我贡高。过去三世诸佛。不为世人作礼。我种如是。是故贡高。婆罗门言。若如此者便无所作。佛答言。如汝所语。我实不作。何谓不作。我不作偷盗妄语欺诳淫欲诸恶业等身口意业。我悉不为。故名不作。婆罗门言。此人便自断其种耶。佛答言。实尔。何以故。三界中一切种种诸烦恼。我皆以断故名断种。婆罗门罔然。不知以何答。更改语。此人可薄不净。佛答曰。如我意者实有不净。有人纵心口为恶者。此是可薄不净。婆罗门便恚言。此人亦闻我语随事而灭之。佛又答曰。三界诸烦恼中我实已灭。婆罗门又言。此人可念不堪共语。佛答曰。实有如此我亦又念。诸愚痴人甚可怜愍。恒为恶业不念修善。婆罗门便生嗔恚骂言。此人当是日夜不眠。思求文章穷世间人。佛答曰。实有如此。何以故。我不入胎眠故。亦不入天上眠故。故名不眠。于是婆罗门以八事讥佛已。如来法王以怜愍心故。视婆罗门眼。欲令服甘露法味而为说法。是时婆罗门心中清净。譬如虚空无诸云翳。亦如日月照诸闇冥。如来以种种方便教化令知。如来自称。我已得无上智慧常住涅槃。向婆罗门言。汝老死至近。来到我所。于汝实有所获。何以故。譬如鸡卵或八或十或十二。问曰。何以三种分别数。答曰。此是足句。亦令文字美满。鸡母伏卵随时回转。伏者。以两翅覆至欲生时。眼见光明以嘴啄[穀-禾+卵]。出已鼓翅呜唤。前出为大为小。婆罗门答前者为大。佛言。我亦如是。何以故。无明[穀-禾+卵]里覆障三界。我以智慧嘴啄无明[穀-禾+卵]。前出三界。此谁大谁小。答言。瞿昙即大。余后句无义。自当知。世间中一。一者无二。三藐三菩提者。无上菩提。问曰。何谓为无上菩提。答曰。若人在须陀洹道。问须陀洹果即为说之。乃至在阿罗汉道。问阿罗汉果。即为说之。如声闻辟支佛佛道。随问而答。故名无上菩提。是故我最大。鸡母伏卵随时回转。佛在菩提树下。观四谛法。苦空无常。佛语婆罗门。我正勤精进。而得无上最大。非懈怠放逸心。我以勇猛正勤精进。于菩提树下以四精进。何谓为四。一者正。二者不急。三者不宽。四者不置。以法而得无上道。不柔者不住。起心者于所观处行。不退者不疲劳。三昧心者一心。又言。善置心为三昧故。即成一心不过不逸。此是初善法。以此法故。得初禅定。从初禅定次第至三达智为极。佛为欲出无上法故。律中说。佛言。婆罗门。我于欲中清净恶亦复清净。问曰。何谓为欲。答曰。贪欲欲。欲贪欲。欲思欲。此是欲名。何谓诸恶法者。答曰。欲狐疑。此是名恶法。如来于此二处而得寂静。又问曰。何谓欲中清净。答曰。离欲亦言弃欲。何以故。初入第一禅定者。无明是欲傥。欲是禅定怨家。已弃欲故而得禅定。是谓为怨家。欲与恶离者禅定而来。欲恶灭已禅定即起。如是二句义自当知。又有三静。身静心静覆静。是为三静。此三静者。亦入前二句静。问曰。何谓为欲。答曰。欲有二。一者处欲。二者烦恼欲。问曰。何谓处欲。何谓烦恼欲。答曰。处欲者。心着色处。烦恼欲者。令人至欲所。此后二句者。正着所解。前句者。为弃乐欲。后句者。从烦恼出。如是欲处烦恼欲。于其二中心极清净。又言。前句除欲处。后句者。除烦恼欲。前句者。除因缘动摇。后句者除痴相。前句者着净。后句止欲。如是次第自当知之。问曰。贪欲者。贪即是欲。贪别欲别。答曰。归一。何以故。一切诸恶法理归一。然分别各异。又律中说。贪者烦恼。欲者欲处。亦如三昧贪欲怨家。欢喜者。是嗔恚怨家。思者。是睡怨家。安乐者。是动疑怨家。度量者。是狐疑怨家。亦如初禅者贪欲怨家。贪欲者含入五盖。诸恶法者含取诸盖。何谓为诸盖。答曰。三毒根五欲五尘邪贪。后句。着处分别诸尘嗔恚痴流法。前句者。欲流欲着欲泉欲受杀心结欲。后句者。诸流泉受着。前句者诸爱等。后句者无明等。前句者贪等八心受。后句者四不善心起。如是欲中清净恶亦清净。念思者何谓为念。答曰。动转。何以动转。于观处初置心。是名念。问曰。何谓为思。答曰。诸禅人以心置观处。中心徘徊观处。又言。思者。研心着心连心。譬如钟声初大后微。初大声者如念。后微者如思。如鸟翔初动后定。动者如念。定者如思。如蜂采华。初至如念。后选择如思。初禅有五支。何谓为五支。一者念。二者思。三者喜。四者乐。五者定。是为五支。犹如大树有华有实。亦如初禅有念有思从静起。问曰。何谓为静。答曰。离五盖是为静。喜乐者喜者满。何谓为满。身心喜满怡悦边味是喜。乐者。弃除二苦身苦心苦。是名为乐。乐者着其想味。又问曰。何谓为喜。答曰。心肥壮其想希好。是名为喜。乐者得而受之。又言。两法不得相离。若有喜者则有乐。乐则有喜。喜者含入行阴。乐者含入受阴。如人涉道渴乏无水。闻有水处即发喜心。是名为喜。到已饮水洗浴。是名为乐。初禅定者。初者第一禅。定者善烧。亦言禅师所观法。何谓为善烧。答曰。极能烧覆盖。又言断烦恼。亦言见。何谓为见。答曰。观见法相。接取威仪八三昧法。何以故。迦师那阿揽摩那(汉言三十八禅定)相。观迦师那阿揽摩那故。名为禅定。此是见道果。何以故。为观相故。何谓为观相。观无常故。以观故成道。以果观灭谛。是故名禅定为观相。律中所说。问曰。何谓为初禅。答曰。有念有思有喜有乐有定。是名初禅。如人有物。如人有眷属。置物已。置眷属已。有余名无。答曰。无余名。禅定亦如是。置念置思置喜置乐置定。更无余名。即是禅定。譬如军阵有人兵象马攻具。名之为军。人兵象马攻具散去。即无军名。禅亦如是。置上句五法。即无禅定名。入者。至亦言成就。住者。于菩提树下以禅定而住。佛于菩提树下坐观何等。观出息入息。问曰。有余禅无。答曰。亦有。法师曰。禅定法。于静道经中。我若广说。其义深远则为纷纭。于阿毗昙毗婆沙汝自当知。今所说者正论毗尼毗婆沙。余者稍略说。是禅定第一品

念思灭者。念思此二法过。入第二禅定。第二禅起。此二法即灭。何以故。为过二大支故。名为第二禅定。又言。第二禅定中。无初禅定法。有余法。初禅定中触法为初。此中二大支已过。即得第二禅定法。是故律中说。念思灭入第二禅定。内法者现。问曰。何谓为现。答曰。现者从身生。清者无垢也。禅亦名清。何以故。如青衣。因有青色故。名青衣。禅亦如是。因有清法故。谓之清禅。问曰。何以名定清。答曰。念思是动之根也。念思已灭。名即清净。一相者一法起。问曰。何谓一法起。答曰。为不顾念思故。是名一法相。亦言无上。又言一相者。念思已离。亦言无双。是名一相。问曰。一法相者。何以名为一法相。答曰。三昧是也。问曰。何谓为三昧。答曰。一心无二。亦言定亦言不动。是故第二禅一相。何以故为名故。问曰。何谓为名。非我亦非生气是名名也。问曰。初禅无清耶。答曰有。若尔者初禅亦名一相。何以止名第二禅名一相。答曰。念思动水动浪起不见面像。亦如第一禅。有念思心不清故。是名非一相。何以故。三昧不明故。问曰。第二禅三昧。何以独明了。答曰。为心净故。从三昧生喜乐者。此是从初禅定三昧生喜乐也。此是第二禅定。第二者数也。如初禅定有五支。第二禅定有四支。何谓为四。一者清。二者喜。三者乐。四者一心。若广说有四。略说有三。如经文所说。何时三支起喜乐一心耶。法师曰。我今证一句。余自当知。此是第二禅定品竟。离喜者。问曰。何谓为离喜。答曰。薄喜亦言过喜亦言灭喜。是时念思灭已喜又更起。问曰。第二禅中以论念念思灭已喜。何故更重而说耶。答曰。欲赞第三禅故。所以说之。何以故。譬如第三道邪见不灭。于初须陀洹道以灭。今于第三道中又说。何谓为赞。第三道故。此中亦复如是。舍而住者。何谓为舍。答曰。舍者。是平等见不偏见不党见恒大健舍。是第三禅。又曰。舍有十种。问曰。何谓为十。一者沙浪求舍。二者梵魔求舍。三者菩提等舍。四者毗梨求舍。五者行求舍。六者触求舍。七者观求舍。八者末阇求舍。九者智求舍。十者清净求舍也。此十种舍善。处处地人心观因一相。以略说故。于沙利耶中昙摩僧伽诃尼耶中净道道中三处中。已广说自当知。我若于此毗尼中广说者。即为乱多。问曰。十舍者。取何舍耶。答曰。取末阇求舍。问曰。何谓末阇求舍。答曰。不知他事因喜而生。问曰。初禅第二禅。此二处无末阇求舍耶。正三禅有也。答曰。初与第二禅亦有。然犹微不现。何以故。念思喜蔽故。第三禅中念思喜已离故得现耳。正思知者。问曰。何谓为思。答曰。心多生想故谓之思也。知者。问曰。何谓为知。答曰。洞达知也。问曰。何谓为正思。答曰。正思者。不忘亦言识。又言起相知者。问曰。何谓为知。答曰。择也。亦言聚又言广。此略说。末阇中自当知之。问曰。初禅定无思知。答曰有。何以故。若无思知者。从何往者初法也。问曰。初禅中何不现思知也。答曰。犹大钝故。譬如磨刀初钝后利。思知亦复如是。初观禅中犹大钝是故不现。亦如人[(殼-一)/牛]乳驱犊不远时时复来。亦如第三禅定乐离喜不远。若无思知守者。即与喜合。思知守之。数强者即离。乐者无上乐极乐。何以故。思知守故。义文如此。自当知之。以身知乐者。问曰。何谓为身。答曰。名色身。以名色身故知乐。何以故。乐与名色身合。两理相合极为美味。以知以美味相着故知起觉之。是故以身知乐者。善人言舍有思住乐。问曰。何谓为善人言。答曰。佛辟支佛声闻。为第三禅人说第三禅因缘。是名善人言。何谓为言。答曰。开视为说为分别亦言赞叹。问曰。何谓舍思住乐。答曰。为欲入第三禅定故。云何入。为极乐故。以极乐美满故。于第三禅定而舍之。令喜止不起。是名有思。何以故。为善人所念所入乐。乐纯无杂是善人所赞叹。是义本说舍思住乐。善人赞叹如是。入第三禅者。如入第一第二。第三禅亦如是。所异者。第一有五支。第二有四支。第三有二支。如经本所说。问曰。何时二支出于第三禅定中答曰。乐一心。此第三禅品竟

善见律毗婆沙卷第四善见律毗婆沙卷第五

        箫齐外国三藏僧伽跋陀罗译

弃乐弃苦者。问曰。何谓弃乐弃苦。答曰。于四禅定中弃乐心苦心。又言。弃名乐名苦也。问曰。乐心苦心于第四禅言何时得弃。答曰。于第四禅定门中弃也。问曰。何处身苦灭尽。答曰。如经所说。佛语诸比丘。离欲清净已。即入第一禅。苦于此灭。问曰。苦心乐心于何处灭无余。答曰。于修满中。佛语诸比丘。于第四禅定灭尽无余苦乐喜悉于禅定门灭无余也。何以故。初禅定念思未离故心苦。念思灭者苦亦灭。亦如第二第三第四禅定。念为初次第而灭。喜者。于第四禅定门灭尽。乐到第四禅定。入乐住舍起不过乐也。是故苦于第四禅中灭尽无余。是谓不苦不乐。此法极细不可以意取也。何以故。譬如恶牛牧者捉之不得。乃立作栏驱群内栏。一一牵出次第而至。至恶牛已此即是然后捉得。佛亦如是。先取乐故入一切法。入已次第而出。此是不苦不乐。不苦心不乐心。此是不苦不乐受。问曰。此不苦不乐可得捉不。答曰。不可得捉。又问曰。上句何以云得捉。答曰。以名知其相故。犹如捉得。语相如此自当知之。如经文所说有四缘。长老以不苦不乐以名解脱。以三昧故弃除苦乐。即入第四禅定。长老。此是四缘不苦不乐。以名解脱。以三昧故。如第三道邪见。为诸法初灭。此赞叹第三道。此中亦复如是。问曰。何谓为诸法。答曰。嗔恚愚痴为初。如是自当知。亦如第四禅定。苦乐心为初。因乐起生欲。因苦起故生嗔恚。嗔恚起故灭乐心。是故于第四禅定极远。是名不苦不乐。问曰。不苦不乐。其相云何。答曰。舍乐舍不乐。问曰。其味云何。答曰。舍苦舍乐味。亦言不偿味。舍识净者。问曰。何谓舍识识净。答曰。舍者令识得净洁。此是第四禅定识净洁。识净洁已即生三识。悉是舍所作非余法作。是故律本说舍识净洁譬如月光有云覆之其光不明。云除去已月即光明净洁。此中思乐亦如是。思乐离者识即净洁。问曰。前三禅定有无。答曰有。问曰。何不出识。答曰。为思为初覆是故不出。又第四禅定舍。即是夜识即是月满。理合者然后显月光明。如第一禅有五支。亦如第四禅有三支舍识一心。广说有三略说有二。如经中所说。何时起二支。是第四禅定中起二支。禅定第四品竟

此是四禅定者。有欲作观地有欲一心。又欲作通地。有欲灭谛地。有欲入生。爱尽人者求一心也。何以入禅定得一心。我住乐一日。即作迦私那已。起八三昧学。凡人从三昧起已一心谛谛。我观是名观地也。复有人成八三昧已。入通禅地已。从三昧起已。而作神通。或一身作千万身。如是次第自当知。是故以禅为通地。又有作八三昧已。入灭谛三昧已。七日入灭尽定。此世间涅槃。我念取七日乐。此是灭谛地。有人入八三昧。从禅定不乐。我欲生梵天。此是入生地。佛入第四禅定。于菩提树下从三昧起。如来观地禅亦言通地。亦入灭谛地。二入一切法世间法圣利法。法师曰。今略说取如是。第四禅定次第自当知。以此法故。入第四禅定。以三昧一心谛。是故言净。如律本所说已舍识净。问曰。何谓为净。答曰。白而不黑亦言光明。因乐故。离欲离诸烦恼已离竟。心即清白随用能堪。何以故。已教授令柔故至极处。如经文所说。若心已柔随用所堪。譬如生金。次第锻成柔已随用所堪。若欲作种种璎珞打之不碎。心亦如是所遣而随。如经文所说。佛语诸比丘。我不见一法如心者。调伏非一过柔辱。堪可施用极净而住。已住故名为不动。为精进故非懈怠。不可动一心。摄已非掉心。可动智慧。摄已非无明。可蔽为识所摄。非妄可辱光明所摄。非烦恼闇所障。此六法所摄非可动转。如是心入八支已。随所堪任分别诸法。以第四禅定三昧故。而得一心已。一心故。诸盖远离。心无垢浊念思已过。心得清净得智慧故。一切诸盖不得覆蔽。以无念故即至不动。去烦恼已名亦不动。此句是修多罗中说。自当知之。宿命智者。从通地生。宿者。过去世阴。住者。生此家生彼家。此家死彼家死。更堕彼家此家。离此家往生彼家。自用智慧一一悉分别知。如是自识宿命过去。如律本所说。识宿命智。以识故。知前身所住处。受生皆悉识。或一生二生如是展转。心知而识之。如佛到波罗蜜。已不复有调伏。心心下而识。初学之人作已然后识。我今略说。于净道毗婆沙自当知之。此中随律本说。一生者。问曰。何谓为一生。答曰。一过入胎乃至死。是名一生。如是次第乃至无数生。三拔劫者汉言劫灭。问曰。何谓为无数三拔劫。答曰。次第而灭。是为三拔劫。毗拔夷劫者汉言劫成。问曰。何谓为毗拔咤夷劫。答曰。次第而生。是名毗拔咤夷劫。取三拔劫者。含入三拔叉夷劫。是叉夷根。若取毗拔劫者。即入毗拔叉夷。是劫心下而识。如经文所说。佛语诸比丘。有四阿僧祇劫。何谓为四。三拔咤三拔叉夷毗拔咤毗拔叉夷。何谓三拔咤。有三三拔咤。何谓为三。火三拔咤。水三拔咤。风三拔咤。有三三拔咤处。阿婆沙罗天。修婆紧那天。卑胁破罗天。若火三拔咤起时。从阿婆沙罗天下火烧尽。若水三拔咤起时。从修婆紧那天下洪水没尽。若风三拔咤起时。从卑胁破罗天下飘尽。广一佛境界。法师问曰。佛境界云何。答曰。生境界灭境界知境界。问曰。何谓为生境界。答曰。十千世界。若佛生者。十千世界皆悉震动。佛威德百亿世界。若佛说宝咒聚咒他阇咒阿咤咒无罗咒。闻不从者。即出风飘落百亿世界外。知境界者。不可度量佛三境界。灭境界与生境界。皆悉崩坏。若兴盛者亦俱成立。我今略说。于净道毗婆沙自当知。如是佛于菩提树下得一切智。非一劫二劫。如是三拔咤劫皆悉知之。若处生者。问曰。何谓若处生者。若处坏劫时。或生天上或入人间。或化生胎生或湿生。如是次第悉知。此是我姓。此是我父母名。我名或迦叶。姓或婆罗门。种或刹利种。苦乐色如是。或白或黑。饮食如是粳米麦粟。树木甘果美香之味。身口意业作如是行。寿命长短如是。从世间上至第一天乃至梵天。受生如是展转。后生兜率天一生补处。于兜率与天人同姓。名斯多揩多(汉名白旗天人)身黄金色。饮食甘露受天之乐。寿命五十七亿六万世间岁。从天宫下托生白净饭王家。于摩耶夫人受胎。知过去世一切生处种姓受形好丑贫富贵贱相貌。如是皆悉知之。法师问曰。佛一人知余人亦知。答曰。余人亦知。辟支佛声闻外道梵志各为分别。外道梵志知四十劫。此外不知。智慧狭劣故不得远知。正知受生而已。余一切悉不能知。何以故。为狭劣故。大阿罗汉有八十人。知十千劫。有二上阿罗汉。知一阿僧祇劫又十千劫。辟支佛亦知一阿僧祇劫又十千余劫。此是随所行而得知。佛所知非可穷尽。外道梵志次第得知。若欲悬略知者不能自辨。譬如盲人行须次第而得。若不次第无有是处。声闻知者两头合得。辟支佛亦如是。诸佛知者随意而得。从无数劫中上下反覆悉得知。此是我知婆罗门。佛语婆罗门。我于菩提树下得无上智慧。即知过去无央数劫。我今无明闇灭得慧光明。从何而得。皆从精勤不惜身命得之。譬如鸡子以嘴破[穀-禾+卵]。佛语婆罗门。我宿命智为嘴无明覆前身宿命为[穀-禾+卵]。我今以嘴破[穀-禾+卵]于[穀-禾+卵]前出。是故我名无上智也。宿命智品他生随知。以慧知众生堕生。是故名生堕知。以天眼观看众生。如来已满波罗蜜故。始观即知。余人皆须修行而知。今我略说。净道毗婆沙自当知之。圣者。问曰。何为圣。答曰。以肉眼如圣眼无异。天人所行诸善得成此眼。离诸肉眼。离诸尘垢能远照故。是故律本所说。以圣眼观慧眼者。以精勤而得。亦如圣眼无异。何以故。已住于圣然后而得。是故名慧眼为圣眼。何以故。以身依止圣故。得圣光明。心摄光故。而得远观。彻通石壁如真明无异。是故以清净慧眼。观众生生堕落受生。是故外道梵志。见堕不见生故生断见。又有外道。见生不见堕故生常见九众生居。佛常见亦观断见亦观。是故律本所说。以慧眼见众生堕生。极净者。如来离十一烦恼。是故名极净。如经文所说。佛语阿[少/兔]楼陀。狐疑是心烦恼。智已而弃之。不摄心者。是烦恼。睡心眠心亦是烦恼。惊喜施心大心。过精勤心极柔心。极多言心。不分别心。极观色心。如是诸烦恼心。阿[少/兔]楼陀。此十一烦恼。如来极精勤故。离此烦恼。若我见色不见光。见光不见色。如是为初。如来已过十一烦恼。亦过人眼。是故律本所说。以圣眼净过世间肉眼观者。众生如肉眼无异。众生堕落受生亦见。法师曰。佛见众生初生堕不。答曰。初生堕落见。于中间不见。是故律本所说亦如是。贱者。问曰。何谓为贱。答曰。以愚痴行行恶法。是名为贱。又生贫穷亦是贱人所恶贱。贵者。问曰。何谓为贵。答曰。以慧心受生。是故名贵。好色者从不嗔中来。恶色从嗔恚中来。善道者生至善道。或言。多金银珍宝亦名善道。恶道者。从悭贪而生贫穷下贱。亦名恶道。下贱者。饮食难得朝暮不供。随业所行如来悉知。复观看众生。于地狱中受诸楚毒。如来见已而作是念。此诸众生种何罪根而受是苦日夜不休。如来观已。此诸众生当作恶业故乃受此报。复观天上见诸天人。于离陀园林眉沙园林。于波留沙迦园林。诸天人观看游戏。如来见已而作念言。此诸众生种何福业。来生此处受天福位。种诸善业得如是报。此是行业所知。当来知亦如是。如来以圣眼知得大神通。身作恶业者。问曰。何谓身作恶。答曰。恶者杂秽不净。以身作恶业如是。如来悉知口作恶业意作恶业。悉如前句说无异。毁谤善人者。问曰。何谓为善人。答曰。佛辟支佛声闻乃至白衣须陀洹道亦名善人。问曰。何谓毁谤。答曰。灭诸善法骂詈。此是毁谤言。复有余言。佛辟支佛声闻悉是恶法非正法。无有禅定法无涅槃法无道果法。如是谤作如是谤。或知者毁谤。或不知亦毁谤。悉入毁谤善人。如此人等造作重业。以重业故。天上门闭开地狱门。法师曰。我今说证。有一聚落有二比丘。一老一少。二人入聚落。初至一家得热糜一稀。老比丘得糜已而作是念。我腹中有风。此糜复热。若服此糜当除腹里风。是时有人持木一段欲作门限掷置一边。于是老比丘即坐木上歠糜。年少比丘见老比丘歠糜已而薄。摩呵罗作我羞耻也。老比丘歠糜竟。而还到寺已。老比丘问年少比丘。长老。于佛法中有所得无。答言。有。得须陀洹道。老比丘言。若如是者。不须更进求余道。何以故。为汝诽谤爱尽比丘。于是年少比丘闻已即作悔过。大德。我于大德作不善法。愿得悔过。即受欢喜而去。法师曰。若人骂詈圣人。若大比丘作如是言。长老。我今于长老忏悔。愿长老受。若少者头面礼足叉手作如是言。大德。此是我过。于大德中我今忏悔。大德受。若不受者。即去余方若至余寺。来至比丘所若老者。头面礼足叉手而言。大德。此是我过。愿大德受。若少者而言。长老。此是我过。我今忏悔。愿长老受。若入涅槃者。于涅槃处作忏悔。作忏悔已。如是天道涅槃道门不闭。即如前无异。邪见者。问曰。何谓为邪见。答曰。颠倒见此是邪见。已受邪见形更教余人。以口恶故。诽谤圣人。意恶业亦如是。已取邪见。一切诸恶业含入邪见。邪见者。是大罪业作之逆罪。如经文所说。佛语舍利弗。比丘持戒具足。三昧智慧具足。自身正见。转教余人如是。舍利弗。邪见亦如是。不离身口意。如人以土丸掷不离于土。邪见恶业不离地狱。何以故。为大罪故。如经文所说。佛语诸比丘。我见恶业无过邪见极最大罪。若身死者。问曰。何谓为死。答曰。死者罪堕地狱无脱时。又言四大坏散。亦言更受生。法师曰。若取地狱者。即塞天道解脱门。又言。若取恶道者。饿鬼畜生阿修罗悉含入。又言地狱者。阿鼻为初白黑自知。又言善道者。人间亦是善道。问曰。天何义耶。答曰。色声香味最胜。是名天。知者是眼知。余者自当知。我今略说圣眼品竟。如无明覆过去宿命。宿命嘴啄故。无明覆[穀-禾+卵]。亦如现在堕落知。漏尽智者。于阿罗汉道漏灭尽智。是名漏尽智。过下置心者。是观心也。观心能知苦。于此灭不过一切苦谛相貌味。皆悉洞达知。又观苦谛。从何而起。从集起。此即集谛。又观苦灭。此是灭谛。将至灭谛者。即是道观。四谛已相貌如是。正实无异洞达悉知。是故佛言。我知四谛如是见如是知。欲漏者。从欲漏出。此是指示果。于果中说我今脱已。又有覆知心。观已而知。我不复更生。是故律本所说。佛语婆罗门。我不更生。法师问曰。为是过去不生现在不生当来不生。若言过去生。过去生已灭。若言现在生。现在生已生。若言当来生。当来生未至。有何更生。答曰。断因故。是名不生。住者。于梵行而住。梵行者。凡善人与七学等共住。此是佛指示出家人。所作已作者。于四谛四道所作已竟。是故佛语婆罗门。我所作已竟不复还。问曰。何谓不还。答曰。诸烦恼漏不还至我所。是故不还更无精勤。如来已观知如此。是名漏尽智。何以故。如来欲开示婆罗门。佛已得三达智过去现在当来智。法师曰。如此语者不应自称。何故。如来而自誉耶。答曰。佛为欲哀愍世间及婆罗门等故。作是语。我圣人。我最长无上尊。一切知。我不为人作礼。婆罗门闻佛种种说发心欢喜。即于佛前悔过言。瞿昙沙门有如是圣利满足。我实不知瞿昙沙门。即是前生功德具足。婆罗门便自克责。克责已闻说法即赞言善哉善哉。瞿昙沙门。为指示法味。法师问曰。何故二赞善哉。复以偈颂曰

  嗔灭急赞叹　　殷勤极惊笑
  信心愁足美　　句句当重说

此中赞叹。何以故。婆罗门闻佛说法心欢喜。无以谢答。为自歌咏。法师曰。婆罗门心当有是思惟。佛所说法。其义深远其语美味。善入人心生大慈悲。甚为悦乐。婆罗门向佛说言。我如覆钵。佛今说法令我得闻。如钵已仰得受甘露。如人以草木覆藏珍宝有人指示令知。如人迷路有人捉手指示善道。如在大闇处有人施与灯烛令得见道。我亦如是。法师曰。婆罗门何以作是言者。我今更演此义。婆罗门心如覆钵不得受甘露味。佛今开示令受甘露。何以故。如草木覆藏。自迦叶佛后邪见为草木。覆藏正法无人指示。今佛指示令知。迷路者。外道邪见为路。于妙道中迷惑不见善道。佛以法为手。指道令得度脱。如愚痴闇不见三界。佛以法为灯烛。施与令得光明。毗兰若婆罗门。作赞叹已心极清净。白世尊言。我今归依瞿昙沙门。归依者。言随从。又言依止。知佛杀烦恼。次归依法归依僧。归依法者。如来积行得此法。不更堕落。若人随法法即受。不堕地狱饿鬼畜生。法者义受。又言圣道涅槃。道者是法。如经所说。佛语诸比丘。法不作有八支道众法之上。法师曰。我今略说。复有婆罗门。名车多摩那婆。歌咏赞佛。而作颂曰

  欲离欲不动　　愁忧法不作
  不逆流美味　　极好分别知
  于众法最上　　应当受归依
  布施四向人　　若分别有八
  于僧中最上　　获得大果报
  于此自归依　　名真优婆塞

如是婆罗门言。愿佛知我已受三归。法师曰。若于此解三归者。即成纷多。若欲知者。可于阿毗昙毗婆沙自当知。愿瞿昙沙门。知我已作优婆塞。愿佛名我是佛优婆塞。问曰。何谓为优婆塞。谁为优婆塞。谁不为优婆塞。云何有戒为优婆塞。有心为优婆塞。云何名为优婆塞。云何不名为优婆塞。法师曰。此义甚多。此中不可说。于修陀尼毗婆沙。自当知之。从今以去者。从今至命终不受余师。愿佛知之。若有人以刀斫断我头。使我言非佛非法非比丘僧。我头宁当落地。不作是言。婆罗门以身命奉托如来欲自供养。作如是言。愿世尊当受我请。于毗兰若国。前夏三月与比丘僧。婆罗门言。我今已作优婆塞。愿如来怜愍我。当受我请。于毗兰若国。如来默然受请。法师问曰。佛何不答婆罗门请。答曰。已应世间人以身口答。世尊用忍心而答。为怜愍婆罗门。知佛受请者。问曰。何谓为受请。答曰。若不受请者。当以口身而答。世尊默然颜色怡悦。是故知佛受请。婆罗门即从坐起。绕佛三匝四方作礼而去。合十指爪掌叉手放顶上却行。绝不见如来。更复作礼回前而去。是时毗兰若国极大饥俭。是时者。佛受毗兰若婆罗门前夏三月。饥俭者。饮食难得。若人不清净至心。正有饮食不与。亦名饥俭。毗兰若国不尔。以五谷不结实故。二疑者。问曰。何谓为二疑。答曰。二者二种心疑。何谓二种心疑。答曰。心疑。于此夏三月乞食。或疑得或疑不得。或疑可得生活。或疑不可得生活。是为二种心疑。白骨者。贫穷下贱人乞食不得。饿死弃尸骨旷野狼藉。是名白骨。又言。五谷不秀实白如骨。亦名白骨。如筹者。禾始结秀而遭大旱。根株直竖如筹。是名如筹。又言不尔。饥俭时以筹市井。是名如筹。何以故。临市时。强者得入羸者不得。于外大叫。粜米人见诸羸人。生怜愍发平等心。开门令入次第坐。先受取直然后与米。随其多少用筹计数。诸比丘自念言。此间饥俭皆悉用筹计挍。时诸比丘入经七八聚落。或得少许或不得者。尔时估客从北方。驱马五百匹。向南贩货。或得二三倍利。以求利故。遍历诸国次第至毗兰若国。住夏四月。问曰。贩马人何故不去而住四月。答曰。雨水多故。不通马行。即于城外立马厩。并自立屋舍篱障都围。于是诸比丘往到估客处乞食。人得马麦各五升。问曰。为信故为不信故。而以麦与诸比丘。答曰信。贩马人入聚落。日日见诸比丘乞食空钵而归。见已估客还向诸同侣说如上事。各作是念。诸比丘乞食极大疲苦都无所得。宜共计挍。我等估客若日日供。其朝中恐不周立。我等当减取马分。各五升与诸比丘。比丘得此马麦便不疲倦。于我等马不甚为损。作是筹量已。诸估客往到诸比丘所作礼而白言。诸大德。可受我等麦。日日人各五升及杂食随意所作饮食。是故律本所说。日施比丘麦。着衣服已朝行乞食。问曰。何谓为朝。答曰。从旦至中是名朝。着衣服者。以袈裟裹身。分卫者。毗兰若聚落乞食不得。遍历聚落都无一人出应对者。持麦还寺者。行乞处处得麦而还。取麦捣舂而食者。老比丘无净人。复无为作者。躬自作糜作饭。或八或十共作竟。当分而食。贤者阿难取如来分手自磨。阿难智慧具足。作食极美味。诸天复内甘露作竟。佛受而食即入三昧。从此以后不复乞食。问曰。是时大德阿难侍佛不。答曰侍。如来从菩提树下起。二十年中侍佛者皆不专一。或时大德那伽。或大德那耆多。或大德弥耆耶。或大德优伽婆。或大德沙伽多。或大德须那诃多。如是诸大德随意乐侍。而来不乐而去或悉去。时大德阿难来侍。问曰。国中饥俭。云何无一人作功德分割少饭供诸众僧。又有婆罗门请世尊前夏三月复不供养。何以故。为天魔波旬蔽一由旬内。悉令一切人民心志都无供养者。蔽已而去。问曰。如来心宁不知。善哉。因欲制戒说法故。佛语阿难。汝辈善人已胜。未来比丘当觅稻禾肉。法师曰。我未解此义。如来当作如是语。阿难汝等辈善人。于饥俭时乞食难得。已知足故护持正法。是故为胜。于饥俭时能伏贪心。是故为胜。余聚落中禾米丰饶甘果异味甚多。而无往者。于众中都无一人思者嗔者怨言者。何以住此。世尊何不往到彼丰饶聚落饮食易得。都无此言亦不怨恨。毗兰若婆罗门何以请我等来此。夏坐而不供养。复无异心思欲行求利养者。亦无更相赞叹。是人得道令人得知。希望供养如是之言。各缄口默然。但一心依止如来住耳。是故为胜。问曰。知魔蔽耶。答曰知。又问。如来何不往舍卫王舍城及余国结安居。而来此国耶。答曰。若置舍卫王舍城国。政使往到郁单越。或上忉利天。魔王亦当来蔽。不可得隐避。何以故。此年魔王大忿。如来已自遍观。唯有毗兰若国贩马人可依安居。问曰。魔王既能蔽余人。何意不蔽贩马人。使佛及众僧不得食。答曰。亦能蔽。何以故。魔王已去后。贩马人后至。是以不得蔽。问曰。魔王何不更为蔽贩马人。答曰。不得都蔽。法师曰。有四种魔不能蔽。何谓为四。一者朝中供养。二者汤药不乏。三者如来寿命。四者如来光明。日月梵王至如来所。光明隐蔽不现。是故魔王种种方便而不能蔽。一时佛闻舂臼声者。诸比丘得马麦还舂捣。是故有声。知而故问。知而不问。知故问者。佛知有因缘利益众生。是故问。知而不问者。无利益是故不问。时而问者。若问正时而问。是故时而问。不问者。如来知非时而不问。有义而问。无义不问。有二因缘问。一者为欲说法。二者为声闻弟子制戒因缘或轻或重。是故问。阿难此声何物声耶。阿难答言。此是诸比丘舂麦声。佛言。善哉善哉。阿难。何以佛叹言。未来比丘住在寺中饮食易得。而生憍心言。饭粗谷或言大熟。或言大强或言粒碎或言酢碱。如是之言。即是觅禾稻肉义。佛语阿难。汝等善人。当为后世比丘作善法因缘。以汝等法。未来比丘若得饮食。于好于恶不生增减。往昔法王在世诸大罗汉犹食马麦。况我等辈于此饮食而有嫌薄

    摩诃目揵连品

尔时大目揵连。大者。于声闻神力智慧最大。是故名大。目揵连者姓。白佛言者向世尊言。问曰。何以向世尊言。答曰。大德目揵连出家七日即得声闻波罗蜜。如来复赞叹神通第一目揵连。所以目揵连有神通力。而作是念。毗兰若国大俭。诸比丘僧乞食难得极为疲劳。我今当反地取地肥供与众僧。复自思惟。若我反地。不白世尊者。便是与如来并神力则乖我法。作是思已而白佛言。世尊。地初成时地肥。譬如生酥亦如蜜味。善哉世尊。我欲反地取地下肥供诸众僧。反者。取下还上。何以故。为众僧故。佛不欲许。令目揵连作师子吼。佛而问目揵连。一切众生城邑聚落悉依止。此地复不得悬置虚空。汝云何作。目揵连答曰。世尊。我今以一手化作地受取城邑聚落一切众生与地无异。以一手度众生等依止地。佛答。止目揵连。问曰。何以世尊不听目揵连反地。答曰。为哀愍众生颠倒住故。或言是或言非。我住处若城邑聚落更相惊怪。此非我城邑聚落田园池林。法师曰。唯有神力人能作。非无神力者。非一时俭未来亦俭。若遭俭时谁得如目揵连。当来声闻弟子少有神力。若入聚落乞食。诸人见已而作是言。世尊在世声闻弟子。持戒具足故。得神通力。即于俭时回反大地而取地味以供众僧。今者众僧持戒不具。若具足者如前无异。复无少少分施。余人以倒见故。轻慢圣人。以轻慢故。死堕地狱。是故世尊语目揵连。勿乐反地。目揵连就佛乞求反地不得。复作余乞。善哉世尊言且止。法师曰。从善哉文句。如前所说。汝自当知。法师曰。有小异。何者。目揵连复欲牵郁单越地还令连阎浮利地。问曰。海云何。答曰。海如牛迹一步而度。令诸比丘食如诸聚落

    舍利弗品

优波离欲证律藏根本。于是舍利弗从静处起。而作是念。问曰。何谓为静。答曰。寂静无声。亦言一心寂静。云何佛法久住。从毗婆尸佛而答。余者义自当知。问曰。舍利弗何不自以神力观看可知而来白佛。答曰不得。舍利弗若以神力观看。正可知诸佛久住不久住。若分别诸佛因缘不能通了。大德大莲华言能。何以故。所以上罗汉十六种智。如此之理不足为难。依止如来欲显世尊为上。是故来白佛而问。佛答舍利弗。余者律句次第自当知。云何因缘者。此义易知。佛语舍利弗毗婆尸佛者。语为初。诸佛非是懈怠。或为一人二三人如是增上乃至一切三千大千世界众生说法有生异心。此众少应略说。此众大应广说。亦不作高下说法。悉皆平等一种说法。譬如师子王七日一起觅食。临捉众生无大小先吼而捉。何以故。若师子捉众生时不先大吼用轻心故。或得脱者。是故皆吼令众生怖伏而捉。佛亦如是。于一切众生无大小。皆以殷勤说之。若有略说众生或不勤心修习。何以故。如来为尊重法故。今我世尊说法。譬如大海水同一味。过去诸佛亦复如是。然众生心易教授。今说一偈义令入四谛。是故过去诸佛。不广说法修登偈耶。法师曰。前句已说故不重说。不为声闻结戒者。问曰。过去诸佛何不为声闻弟子结戒。答曰。诸声闻弟子不犯非故。亦不结威德波罗提木叉。亦不半月半月说戒乃至六年。六年止说教授波罗提木叉。此说如来自说。不令声闻说。尔时阎浮利地槃头摩底王舍城翘摩鹿野苑。是毗婆尸佛所住处。一切比丘僧悉集。佛布萨众僧布萨。三人布萨二人布萨一人布萨。往昔阎浮利地有八万四千寺。寺或有十万二十万比丘。亦不喧闹皆寂静而住。是时诸天人心思欲闻佛说戒。恒计年岁。应到六年即集大众。往佛所待佛说戒。是时诸比丘。若有神力者来。无神力者诸天来白时可去即取衣钵。诸比丘承天人神力。到布萨堂往至头顶礼足。时毗婆尸佛知众集。即说教授波罗提木叉

  忍辱第一道　　涅槃佛胜最
  出家恼他人　　不名为沙门
  一切恶莫作　　当具足善法
  自净其志意　　是即诸佛教
  不恼不说过　　不破坏他事
  如戒所说行　　饭食知节量
  一切知止足　　常乐在闲处
  是名诸佛教

以如是方便。一切过去诸佛以此偈教授波罗提木叉。此是诸佛寿命长短。是故如是说短寿。诸佛从菩提树下。为声闻弟子结戒。此是威德波罗提木叉。非如来说。诸声闻弟子说。是故我等释迦牟尼佛。从菩提树下二十年中。皆说教授波罗提木叉。复一时于富婆僧伽蓝。于眉伽罗母殿中。诸比丘坐已。佛语诸比丘。我从今以后。我不作布萨。我不说教授波罗提木叉。汝辈自说。何以故。如来不得于不清净众布萨说波罗提木叉。从此至今。声闻弟子说威德波罗提木叉。是故律中说。佛语舍利弗。过去诸佛不说威德波罗提木叉。说教授波罗提木叉。毗婆尸三佛不说波罗提木叉。三佛已入涅槃。声闻弟子复入涅槃。最后声闻弟子。姓非一种。名非一种。或姓瞿昙。或姓目揵连。或名佛无德。或名昙无德。从非一种。或婆罗门种。或居士种。或刹利种。又非一种家。或富家。或贫穷家。或下贱家。从如此种种非一家。非一姓等出家。而作梵行。为非一种姓名入正法故。而各自用其志意处。当佛法不相承受。所以佛法不久住世。为此等故。问曰。诸比丘何不勤修精进。而使正法速颓灭耶。答曰。先诸大德犹为不善。况我等辈各不护法藏。故令佛正法而速灭耶。不用綖贯穿者。风吹即散。贯者言缚。譬如种种花不以綖贯之风吹即散。佛法亦如是。为不结戒故。以心先观然后教授声闻。问曰其义云何。答曰。过去诸佛先观声闻心然后教授。缘诸声闻易悟理故。佛亦不为广说。怖畏林者。此林若有入者即生怖畏。如是汝等思惟者。有三思惟。出家为初。汝等当勤心思惟。汝等莫作是思惟者。有三恶法。思欲为初。汝等慎莫思如是。汝等当忆持在心。观无常苦空无我。心恒忆持莫如是。汝等莫思忆者。无常莫思常理。不净莫思言净。汝等勿作是思。此是汝等应弃者。诸恶法应弃。此应起而住者。善法汝等应起。若已得者令增长。从不起烦恼心得脱者。心不取烦恼故而脱。亦言以灭不起灭而灭。是故律本所说。从不起烦恼心得脱。一切皆是阿罗汉。譬如莲华日光始出即便开敷。舍利弗往昔恐怖林中者。若人未离欲入此林。林有威相故。皆悉毛竖。舍利弗此是因缘者。法师曰。次第句义易自当知。不久住者。毗婆尸佛寿命八万岁。诸声闻众亦复如是。从佛在世乃至最后声闻。佛法住世百千六万岁。尸弃佛寿命七万岁。声闻弟子寿命亦尔。惟卫佛寿命六万岁。声闻寿命亦如是。二佛寿命到最后。声闻佛法住世。百千四十二十万岁。次第而数。是故佛法不久住。于是舍利弗。闻三佛佛法不久。闻已意欲更问佛久住。而白佛言。世尊。以何因缘。佛法久住诸佛寿命。拘那卫佛寿命四万岁。拘那含牟尼佛寿命三万岁。迦叶佛寿命二万岁。释迦牟尼佛寿命百岁。诸声闻弟子寿命亦如是。是故佛法久住。我今世尊。应取迦叶半寿一万岁。是时应出世。观看众生根无熟者。五千岁应出。次第五百岁应出。又复无根熟众生。乃至百岁。然后有众生可度。是故佛出世短寿。声闻弟子亦如是。佛法久住如前。三佛法与寿命俱灭。是故名不久住。后三佛者。佛虽灭度。佛法犹在世。是名久住。于是舍利弗闻佛说已。欲令佛法久住。而白佛言。唯愿世尊。为诸声闻弟子结戒。如律本所说。舍利弗从三昧起。余者后句次第自当知。佛告舍利弗。止止时未至矣。舍利弗重白佛言。世尊。唯愿为诸弟子结戒。佛告舍利弗。止止。此法非声闻缘觉所知。唯佛与佛乃能知耳。未垢起故。问曰。何谓为垢。答曰。垢处者。于今世后世过如来法。是名为垢。未为声闻结戒者。问曰。何以不为声闻结戒。答曰。未有漏者如来结戒。众生生诽谤想。云何瞿昙沙门。如诸声闻弟子。悉是贵姓。或是王位。舍其财物宫殿妻子眷属。不惜身命。皆是知足。于世间无所希求。云何瞿昙。反以波罗提木叉而系之。是瞿昙未善别世人。故言如此。若我结戒者。世人而亦不生敬重之心。譬如医师未善治病。见人始欲生痈。虽有痈性未大成就。辄为破之。破已血出狼藉。受大苦痛。以药涂之疮即还复。医师谓曰。我为汝治病。当与我直。病人答曰。此痴医师。若是我病可为我治。我本无病。强为破肉令血流出生大苦痛。反责我直。讵非狂耶。声闻弟子亦复如是。若先结戒而生诽谤。我自无罪强为结戒。是故如来不先结戒。若漏起者。问曰。何谓为漏起。答曰。若漏于僧中已起者。是时如来当为诸弟子结戒。指示波罗提木叉。譬如良医应病设药令得除愈。大获赏赐又被赞叹。此好医王善治我患。如来亦复如是。随犯而制。欢喜受持无有怨言。是以律本云。止止舍利弗。若有漏法生。然后世尊当为结戒。法师曰。余句自当知之。于佛法中谁先出家。崩揵多儿。名忧波斯那。因忧波斯那制戒。未满十腊而与弟子授具足戒。忧波斯那二腊。弟子一腊。如是次第从此。已佛为制戒。告诸比丘。自今以后若未满十腊。而与弟子授具足戒者。犯突吉罗罪。佛已结戒竟。复有比丘。虽满十腊若过十腊。痴无智慧。而与弟子授具足戒。佛又制戒。告诸比丘。若人无智慧。与人授具足者。得突吉罗罪。佛听有智慧人者。十腊若过十腊。善能教授。听与弟子授具足戒。未多者。众僧中老少未多。戾舍亦未大。若众僧多者。当有犯漏法者。是时如来然后结戒。若比丘与未受具足戒共宿。过二三宿者。是比丘得波夜提罪。若比丘年年度弟子者。是比丘得波夜提罪。若比丘尼年年度弟子。是比丘尼得波夜提罪。已说如是。汝自当知。大利养者。若众僧得大供养者。便生有漏法。是时如来当结戒。若比丘受裸形外道若男若女自手与饮食等。是比丘得波夜提罪。未多闻者。若众僧中未有多闻。若比丘僧中多闻。便生漏法。若一阿含若五阿含读诵通利。以不正心而说颠倒义。非律言是律。非法言是法。是故佛结戒若比丘作是语。佛所说法我已知。作是言者。是比丘得波夜提罪。次如沙弥语无异。所以如来因有漏法。我云何为诸弟子结戒。云何漏者。答曰。劫贼云何为劫贼。答曰。于佛法犯戒即是劫贼。云何名为劫贼。答曰。非沙门者。自言我是沙门。劫四辈物。是故律中所说。未有漏法未有劫人。亦言未有犯戒人无罪者。言无烦恼亦言无患。无犯戒不染黑法者。黑法言破戒。亦言众僧不破。极净者。言极光明住。真实地者。戒三昧智慧解脱。是真实地而住。法师曰。我当说次第。于毗兰若国前夏三月。五百比丘最小得须陀洹道。问曰。何谓为须陀洹道。答曰。须陀洹言流。问曰。云何为流。答曰。道若人入此流道。名须陀洹道。如经文所说。佛问舍利弗。须陀洹云何名须陀洹。舍利弗答。此是世尊善贯八道。何谓为八。一者正见。二者正思。三者正口。四者正行。五者正生。六者正勤。七者正识。八者正三昧。复问。何谓为须陀洹。答曰。若人以八贯故。来至善道。是名须陀洹。如是名如是姓。因道而名果。是故名须陀洹。汝自当知。不堕落法者。不言无须陀洹人。无堕落于地狱饿鬼畜生。何以故。断烦恼故。以道故。便回向菩提者。回向前三道必当至。何以故。为道故。如是大智舍利弗答如来已。于毗兰若夏三月大自恣竟。尔时佛告阿难者。告者。语又言。觉佛法久有此法。过去诸佛告。受人别请竟得去。声闻弟子。别与不别随意而去。佛怜愍众生。欲遍行诸国。佛行诸国者。佛行有三境界。一者大境界。二者中境界。三者小境界。三境界随意而行。问曰。何谓大境界。答曰。九百由旬。何谓中境界。答曰。六百由旬。小境界云何。答曰。一百由旬。若佛欲大境界行时。大安居竟。九月一日与比丘僧围绕而去。次第到聚落教化说法。受诸饮食。应可度者即为度之。未得度者令获福利。九月日游行。于夏三月中。多诸比丘行三昧法未竟。如来不大自恣。待小自恣到。九月十五日竟而去。中境界行时。八月日游行。小境界者。先观众生根熟而住。次根熟而去。到十一月一日。与比丘僧围绕而去。七月日游行。此三境界中处处众生。令离烦恼得四道果。为教化故。譬如采华人遍行山中。见诸杂华有开荣者。便摘持去。如来亦复如是。又有佛法。于清旦时入禅定乐从三昧起。以大慈悲观看十方世界。应可度者如来即往度之。又有诸佛法。有新从余国来者。如来便相劳问说法。因缘今欲发起。结禁戒故。此是诸佛无上道法。问曰。何谓为声闻法。佛在世时二过集众。何谓为二。一过初入夏坐欲取禅定。第二过夏坐竟现有所得。此是声闻法故。如律本所说。佛语阿难宜可共往。往者。别诸婆罗门。别者。白婆罗门言。安居以竟。我今便欲游行余国。尔时世尊即着袈裟整衣服晨朝而去。阿难侍从往到城门。到已而入。放大光明遍照城内巷陌舍宅。皆如金聚。玄黄五色犹如电光。即向毗兰若婆罗门家。到门下立。使人忽见佛光明。入白婆罗门言。瞿昙沙门今在门外。婆罗门闻佛来声。霍然而悟。即起取氍氀毾[登*毛]敷置床座。躬自出迎白世尊言。可从此路而入。于是佛入已而坐。时毗兰若婆罗门。本心欲坐近世尊边。无因得坐故。于座边叉手而立。法师曰。次第后句自当知之。婆罗门白言。世尊。应与未与。法师曰。此是婆罗门欲发起先所许供养如来者。婆罗门言。我先请如来三月夏坐。应日日赍饭食糜粥甘果水浆供养世尊。而便痴忘。未有一毫。非为不与。未得奉设。缘我白衣多诸事务。嗔恚愚痴逼迫迷乱。我心而忘。是故不与。法师曰。何以婆罗门作此语。不知魔王所迷。而自克责。为白衣业故。遂忘世尊。于是婆罗门自念。我请佛三月供养。都未施设。我今以三月供限并一日施。唯愿世尊哀愍纳受明日者。婆罗门供如来明日即办。佛观婆罗门心极大欢喜。佛为哀愍故自念。若我不受请者。此婆罗门当生恶心作如是言。瞿昙沙门于三月请未得供养。今者怨恨不受我请。当复有言。瞿昙沙门非一切智。不能暂忍。或当作如是言轻贱如来获大罪报。是故我今应当受请

善见律毗婆沙卷第五善见律毗婆沙卷第六

        萧齐外国三藏僧伽跋陀罗译

默然者已受请。佛告婆罗门。汝勿系心家业。佛已语竟。复观看随其所堪而为说法。说今世后世悉现令知。于功德中。复已受持精勤修已。如来即雨法雨。雨法雨已。佛即从座而起还向本处。是时婆罗门即集儿子孙息。咄汝等辈。我先请佛三月安居。不得一日供设。我今以三月供限。并设明日语竟。即馔办饮食。昼夜料理。至旦扫洒家内清净。即以涂香烧香华鬘璎珞。悬缯旛盖。施敷床席。皆悉精丽种种供养。备具办已。来到佛所白佛言。世尊。饮食已办时今至矣。尔时如来与比丘僧围绕而去。是故律本所说。佛往至婆罗门家。到已与诸比丘共坐。是时婆罗门供设佛及比丘僧。比丘僧中佛为上座。极美者无上味以手者自手与食令饱。饱者言满足。亦言快意。却者言止。止有三种。何谓为三。一者以手。二者以眼。三者以口。食欲竟此亦易解。婆罗门以三衣施佛。三袈裟直金钱三千。又施五百众僧白[疊*毛]各一双。合直金钱五十万。婆罗门虽作如是施已。心犹未止。复更施绛钦婆罗一张。又钵兜那波咤(汉言绢也)佛与比丘截断钦婆罗。各作禅带及钵囊襻。又断裂钵兜那波咤。作腰绳漉水囊二种。复有百煎药膏。满一器直金钱一千。以供众僧涂身。法师曰。布施沙门者。法止四种。不与世人同。今已备足。律本所说。布施三衣不及四种。我今故演耳。于是婆罗门作此施已。与眷属俱头面礼佛及比丘僧却坐一面。尔时世尊作是念言。此婆罗门及其眷属。请我夏坐。三月之中为魔所娆未闻法要。我今以其三月未听法故。并为一日敷演解说甘露法味。令其眷属各得饱满。佛为婆罗门说法竟。即起出门欲向余国。于是婆罗门及其眷属。各各头面着地为佛作礼流泪而言。唯愿世尊。哀愍我等时复一来。与我相见使不恨耳。尔时世尊于兰若中。停三日入佛境界。观诸比丘九十日中日食马麦。身体羸瘦不堪远涉。直路而去到须离国。从须离去取波夜伽处。到已即渡大江。渡已便向婆罗那私国。到已从此而去到毗舍离城。是时世尊。便于摩呵句咤罗精舍而住。法师曰。律毗婆沙。名善具足毗兰若因缘竟

迦兰陀品

此毗婆沙义味具足。不杂他法分别戒相。于律中因缘根本所说甚为难解。此毗婆沙善能分别一切律藏。无有障碍。故名具足

  世间中尊王　　哀愍众生故
  今说毗尼藏　　令众生调伏
  亦将众善行　　灭除诸恶法

尔时毗舍离城。如是次第易可解耳。若有深奥不可解者。我当为说。迦兰陀者。是山鼠名。时毗舍离王将诸妓女入山游戏。王时疲倦眠一树下。妓女左右四散走戏。时树下窟中有大毒蛇。闻王酒气出欲螫王。树上有鼠。从上来下鸣唤觉王。蛇则还缩。王觉已复眠。蛇又更出而欲螫王。鼠复鸣唤下来觉王。王起已见树下窟中大毒蛇即生惊怖。四顾求诸妓女。又复不见。王自念言。我今复活由鼠之恩。王便思惟欲报鼠恩。时山边有村。王即命村中。自今以后我之禄限。悉回供鼠。因此鼠故。即号此村。名为迦兰陀村。迦兰陀子者。是时村中有一长者。有金钱四十亿。王即赐长者位。因村名故。号迦兰陀长者。法师问曰。长者独名迦兰陀。余人亦尔。答曰。悉名迦兰陀。律本所说。须提那者。是迦兰陀长者子多知识。知识者。苦乐共同。时有因缘往毗舍离。因缘者。寻觅负债人。复有法师言。九月九日国人大集游戏。以是之故。须提那往观看。尔时世尊九月前十五日至毗舍离见者。问何谓为见。答曰。须提那清旦食竟。见诸人偏袒右肩赍持种种华香往至佛所欲供养听法从城门出。须提那见已而问。咄善人何处去耶。答言。今往佛所供养听法。须提那曰。善哉。我亦随去。尔时世尊四众围绕。以梵音声为众说法。须提那到已。见佛为大众说法故。律本名为见。法师曰。此是须提那往昔福因令其发悟。须提那。心自念言。云何因缘得入听法。何以故。四众围绕至心听法。不可移动难得入故。是时迦兰陀子须提那渐近众边。问曰。何不入众。答曰。为后到故。是以近众边坐。律本所说。迦兰陀子须提那。往到众所坐一处已。迦兰陀子须提那而作是念。问曰。坐已作是念。为闻法已作是念。答曰。闻佛赞叹戒定慧已作是念。问曰。念何等。答曰。当作是念。佛一一分别说法。我已知反覆思惟。戒定慧中义理一味。作是念。我在家修戒定慧梵行。一日得过者其事甚难。不宜在家。如磨琢者。问曰。何谓磨琢。答曰。如人磨琢极能白净。在家修如琢者亦甚难得。我今云何得剃除须发。披袈裟衣而修梵行。我得出有为家入无为家。问曰。何谓有为家无为家。答曰。有为家者。耕田种植贩货种种事业。无为家者。无诸事业寂然无欲。是名出有为家入无为家。众起未久往到佛所者。须提那众未起时。往到佛所不求出家。何以故。若求出家者。兄弟眷属在坐听法。当作留难而作是言。父母唯汝一子。若求出家谁当侍养。作是语已必捉将还。则作我出家艰难。须提那与众俱退。行至数步方便而还。往到佛所便求出家。是故律本说。众起未久。须提那往到佛所。唯愿世尊。从罗睺出家之后。父母不听出家佛不得度。是故佛问须提那。汝父母听汝出家不。法师曰。此句次第易解。自当知。应作已讫者。须提那心乐出家。于游戏处心不染着。于诸债主得与不得匆匆而还。次第易解。阿摩多多者(汉言阿摩是母多多者言父也)汝者易解。一子者。唯汝一子无兄弟。法师曰。父母何以作是言。为念故。住在欢乐者。从小至大不经辛苦。自初生时乳母抱养遂及长大。百味饮食恒相给恤。车马出入脚不践地。是名住在欢乐。父告须提那。汝小苦亦不知。不知苦者。一苦破作十分。于一分苦汝亦未经知。我至死不与汝别离者。父母言。我生世若汝死亦不弃舍。况今生别无有此理。即于此中卧地上者。言无毡席而卧地上。供养者。问曰。云何为供养。答曰。男女妓乐琴瑟箫笛箜篌琵琶种种音声。与诸知识而娱乐之。诸知识人方便慰喻令其心退。于五欲中食。问曰。何谓为食。答曰。食者。自己身与妇于五欲中共相娱乐。复作功德者。言供佛法僧。得种种布施修治善道者作功德。默然而住者。父母种种教化令其心息。如是父母反覆至三。执志不转。父母唤须提那知识。而言曰。此卿等知识。今卧在地上。我已三请永不肯起。卿等为我令止出家。于是诸知识往至须提那所。三过作如是言。知识卿父母唯卿一子。若必出家。父母年老谁当供养。卿出家者。愁忧憔悴致死无疑。于卿何益。卿豪贵出家者。捉瓦器乞食。或粗或恶或得或不得。日复一食而复独眠。若修习梵行此法甚难。如是种种方便永无退心。诸知识议言。今当听其出家。即往须提那父母所劝。放出家听已。是故律本说。迦兰陀子须提那知识。往至父母所。知识向须提那言。卿父母已听卿出家。须提那即从地而起欢喜踊跃。须提那七日不食身体羸瘦。父母以香汤洗浴。以油涂身洗梳头发。作种种饮食肴膳。三四日中体力平复。于是须提那礼父母。于是流泪与别。往到佛所。唯愿世尊度我出家者。问曰。为是如来度。为众僧度。答曰。比丘度。是时世尊边有一乞食比丘。佛告乞食比丘。汝可度须提那出家与具足戒。比丘答。善哉世尊。即取须提那度为沙门。即字尊与比丘与具足戒。是故律本说。是时须提那。于佛所得出家。已受具足戒。受头陀法。头陀者。汉言抖擞烦恼尘垢。受者言行。阿兰若者。弃舍聚落房舍。住阿兰若处乞食。乞食者。不受长利养。弃舍十四食。受粪扫衣者。不受檀越衣。次第乞食者。不越次。拔阇村者。拔阇王村财宝无量。财者。朝冥受用。宝者。恒覆藏不令人见。无量者过数。饮食丰饶者。日日恒有盈长饮食。料理房舍者。摒挡床席卷叠覆蔽。赍六十大银盘者。一盘堪十人食。合供六百众僧饮食。食者取也。问曰。何谓为取。答曰。取四大力。回与者。舍与众僧心不恋慕。自入乞食。家中婢将经宿残饭不中食出外掷弃。经宿或一二夜饭醋臭。问曰。为是粳米为是粟米。答曰。粟饭也。大姊者。出家人不得唤为婢。故唤姊掷我钵中。问曰。出家人得作是语不。答曰得。何以故。主人弃薄故。如此弃掷之物。亦可得言将与我内置我钵。法师曰。有一比丘乞食。见人担残宿饭欲掷弃。比丘言。若必弃者置与我钵。是比丘佛所赞叹。问曰。唯饭一种得余物亦得。答曰。一切掷弃之物皆得索取。勿生狐疑。手足者。乞食下钵受食露手至腕。足者。从踝上四指。音声者。须提那唤时得闻声。忆识者。识其三相。佛成道十二年后须提那出家。须提那在他国八年。学道八年后还迦兰陀村。佛成道已二十年。须提那别家已经八年。婢是故不识。入白大家言者。问曰。何不即问而入白大家。答曰。婢见畏难故。不敢辄问。是故匆匆入白。若审尔者谛墙边而食者。尔时村中家家。各于墙边作小屋贮水浆。拟乞食人止息所须随意。是故律本说。出门外于墙边而食何物人者。父问须提那。何物人于墙边食此残宿饭。出家人不应如此食此宿饭。父向须提那言。汝在家时。肴膳饮食于中嫌呵。或言粗恶冷热不调。汝今食此残宿饭。如食甘露无有怨言。法师曰。须提那父应作是语。但父心中逼切。不得申如此语。师师相承作如是解。捉手俱共还家者。问曰。何以与白衣捉手还家

答曰。须提那为人至孝。父既捉手不违父命。俱共还家受请默然而住者。问曰。须提那受上乞食法。何以受父请。答曰。须提那当作是念。离家既久。若不受檀越请者檀越当生恶心。以哀愍故。为受一请。受者令知。金银聚者。问曰。为铤为碎。答曰钱。人者。亦不长不短。于后施幔者。疑静处绕四周安幔。晨朝着衣钵者。应请也。问曰。何不待檀越来赴而自往耶。答曰已报。律中不说。母者。能生他为义。母物者。从外家随母来是。朝冥洗浴用直余。我先娉汝母物限复未出我物未出。汝祖父母物亦未出。未出者。言财物无量。汝可还俗者。父语须提那。汝可舍弃出家衣服。还俗着好衣服受五欲乐。汝出家非是畏王使故出家。非负债出家不能复俗者。须提那语檀越。我极乐梵行。我于复俗心无贪着。愿檀越勿有所怪。须提那语檀越。我有所白愿勿嗔责。父答善哉善哉者。父闻须提那作是语。心中欢喜故赞善哉。取麻布作大囊。以金银内里。坚缚囊口十余车。载至大江中深处弃之。为此因缘者。须提那语辞用宝何为。缘此宝故能起诸烦恼。水火盗贼悉从斯生。毛竖者。或有国王。见宝物多便来求索。或有盗贼而来劫夺。或为水火之焚漂。深思惟此已。举身震栗毛为之竖。日夜守护者。未瞑时便处分前后。布置人力持时卓逻。关闭门户极令坚密。勿使劫盗得入怨家所伺故名守护。唤新妇者。须提那父种种方便。令须提那还俗。了无从意故。唤新妇言。唯汝先相爱念。能令其心回。何以故。一切财宝犹不能坏。唯有女人能令人回转。天上玉女端正若为者。此是新妇问须提那辞。新妇所以见诸刹利及诸贵姓舍诸财宝及宫殿妻子眷属。意谓诸种姓悉皆为求天玉女故而修梵行。不为天女者。不求天女。新妇闻须提那以妹相答。自谓先夫妇共床寝息。今唤为妹。即是共父母生之义。故生大苦恼闷绝躃地。勿触恼者。莫以财宝及女欲触或我心。可留续种者。父母语须提那。愿汝恒修梵行。于虚空中而入涅槃。愿汝留一子以续种姓。勿令财宝空失无有主领。我等死亡。必入梨车毗王库藏故。请求续种耳。须提那答。此事甚易我能为之。问曰。何以须提那作是言。须提那心生念言。若我不与种者。终不置我日夜恼我。我若与子令其心息。不复娆我。我因此故。得安住道门修习梵行。月华者。月生水华。此是血名。女人法。欲怀胎时。于儿胞处生一血聚。七日自破从此血出。若血出不断者。男精不住即共流出。若尽出者。以男精还复其处。然后成胎。譬如田家耕治调熟。然大过水以谷下中。谷浮水上流出四面。何以故。水大谷不着泥故。不成根株。女人亦复如是。若血尽已男精得住。即便有胎。捉妇臂者。此是抱将。入深处共为欲事。尔时佛从菩提树下。二十年中未为诸弟子结戒。诸弟子既新涉学故。佛未为制戒。须提那不知罪相。谓之无罪。若须提那以知罪相者。乃可没命何敢有犯。三行不净者。三过捉妇共作不净。行不净故而便有胎。法师曰。有与无。答曰有。何谓有。一者身相触。二者取衣。三者下精。四者手摩脐下。五者见。六者声。七者香。以此七事女人怀胎。问曰。何谓为摩细滑。有女人月水生时嬉乐男子。若男子以身触其一一身分。即生贪着而便怀胎。此是相触怀胎。问曰。何谓取衣。答曰。如优陀夷比丘。与妇俱共出家。分别久。优陀夷往到比丘尼所。两情欲爱不止。各相发开。欲精出污优陀夷衣。以衣与比丘尼。比丘尼得已便舐之。复取内女根中。即便怀胎。有女人华水生时触男子衣。是名取衣。问曰。何谓为下精。答曰。如鹿子道士母。往昔有一鹿母行。次第至一道士处。道士小便有精气俱下。鹿母时正华水生。嗅看小便汁。欲心着而欲饮。遂怀胎。生鹿子道士。是名下精。摩脐下者。如睒菩萨父母欲盲。天帝释逆知。下来至其所而言。宜合阴阳当生儿。夫妇既悉出家为道。答言。我等已出家。法不得如此。帝释复言。若不合阴阳。可以手摩脐下。即随言便怀胎而生睒。是名手摩脐下。闵陀婆耶。与栴陀钵殊多。二人亦如是生。问曰。何谓为见。答曰。有一女人。月华成不得男子合。欲情极盛唯视男子为志。譬如王宫婇女亦复如是。即便怀胎。是名见。问曰。何谓为声。答曰。譬如白鹭鸟悉是雌无雄。到春时阳气始布雷鸣。雌但一心闻声便怀胎。鸡亦有时如此。但闻雄声亦怀胎。是名声。问曰。何谓为香。答曰。如秦牛母。但嗅特气而怀子。是名香。须提那不如此。实行不净法。男女欲色俱合便托生。三事悉合然后生子。须提那如是。是时地神见须提那行不净法。即大叫唤。一切作诸恶法无人不知。初作者。护身神见。次知他心天人知。如此之人天神俱见。是故大叫唤。展转相承传至于梵天者。置无色界。余者悉闻知。时子渐渐长大与母俱共出家者。续种年八岁。与续种母出家。母依比丘尼。续种依比丘僧。各得善知识。是故律本说。即共出家次第得阿罗汉果。即生悔心者。前既作不净行故。恒日夜生悔心。于利我不得利者。于佛法中修习梵行得三达智。我不得此利。是名于利。我不得此利。我得恶利者。余人出家得善利。我不得善利得恶利。梵行者。总持戒定慧藏。而我不得总持。羸瘦者。为自悔所行饮食不通。是故血肉燋小。形体色变者。如树叶萎黄欲落。筋脉悉现者。为无肉血故筋脉悉现。心亦蔽塞者。心孔悉闭也。羞耻低头者。于清净行自观不善而生羞耻。时诸比丘各出房前游戏。见须提那羸瘦而问。先面貌休满者。身体美满手足平正肥壮。今何以羸瘦。诸比丘语须提那。汝于梵行中何所忧恨。为不乐出家耶。须提那答。诸长老。我于梵行非不乐。于清净法勤心修治。为我已作恶法故。已作恶者。已得恶法。恒在眼前见。诸比丘语须提那言。汝所作足可狐疑。问曰。何谓狐疑。答曰。于清净法中为不净行故。而生狐疑。不得修梵行。于是诸比丘作方便。释须提那意而作是言。不尔长老。佛以种种方便说法离欲者。所以佛为一切众生。于三界中说五欲法。皆令离欲不使得合。语异而义同。说法令爱尽者。令至涅槃不住三界。是故不令爱。佛已如是说欲。令分别不共。汝今而合者。佛说离不净行。而汝与故二作不净行。此义易解。佛种种说法令离迷惑者。佛所以为众生说法。令除迷惑断渴爱者。所以一切众生渴于五欲。佛说法令众生断除渴爱故。断种者。佛说法令断三界种爱尽涅槃。爱者。三界爱欲众生所以不得出。为爱欲所缠缚。尽者。灭为爱尽。而得涅槃者。三界中四生五道七识。住九众生居。从此至彼从彼还此。犹如綖绣衣孔更相贯穿缠缚。不解爱即缠缚。尽即灭也。爱尽者即涅槃也。又涅槃者。涅者言不。槃者言织。谓不织义。佛说除欲者。五尘欲烦恼欲。皆悉令除。知欲者。一切诸欲应一一知已而调伏之。是名为知。渴欲者。于诸欲中极求欲。思欲者。有所思与欲共思。烦闷欲者。于五欲中思未得。而生烦闷。此说皆道谛所说。前句说世间法。后句说出世间法。长老是不信人不信令信者为作恶法故。未信心人不得令信。长老信心者。更回转其心。回转心者。于法中信心而生悔恨。若人以道信心。譬如须弥山四方风摇不能转动。此信心者亦复如是。是故律本所说。有人如此无人如此时诸比丘以事白世尊。诸比丘以须提那所作恶法。而白佛令知。心不希佛独誉已。亦不令佛贱薄。遣须提那。出于清净法中。又不以此恶法斗乱故。但依实理而言。诸比丘各自念言。垢法已起。白世尊言。今垢法已起。愿为声闻弟子结戒。以此因缘集比丘僧者。以须提那所行恶过圣人法。是故集比丘僧。佛即贱薄须提那者。若人作恶法应薄贱。如来即薄贱。有人能持戒精进者。应赞叹如来即赞叹。如此善恶行者。佛不覆藏。如须提那者应薄贱。是故律本所说。应薄贱如来以慈悲心薄贱。佛言。汝痴人空无所有。痴者。应作而不作。不应作而作。不顺从作即不净。以不净故。即非沙门法。佛问。以何因缘作如此事。佛言。我说离欲。一一如前说。佛见须提那已作恶法。以慈悲之心而言痴人。譬如慈父母见子作恶。亦呵骂其子。痴人何以作如此事。是故律本所说。痴人汝可以男根内毒蛇口。勿内女根中。毒蛇口者。若人触毒蛇口。肉即烂坏。此死为善。若人以男根内女根中者。死入地狱无有出期。宁可以男根内蝮蛇口亦复如是。一人即烂。为此命终不堕地狱。若内女根中轮转地狱。宁以男根置大火聚中不内女根。何以故。痴人若火聚置者。或死或不死。若死者现身暂小受苦。不为此因缘堕地狱受大苦痛。不善诸法者。恶人法。山野人法者。于山野中人法。大罪者。大烦恼。末水法者。作非法竟然后用水。故名末水。于静处者。唯有二人。可作不净行。一切恶法为初。问曰。佛何以作是言。答曰。于清净法中。而须提那作垢故。名须提那于净法中最初犯垢。如来以种种方便者。种种薄贱。此人难养者。于覆藏法。自不能护其身。是名难养。不知足者。为住于覆藏处故。名不知足。若得珍宝如须弥山。亦不称意故。名不知足。说身聚集一处者。共集一处而相赞叹或烦恼赞叹。懒堕者。有八所作悉具足。如来方便赞叹少欲知足易养易长。少欲者。无悭贪心。若于一供养随其所得。若持易养者。能制六情不随六尘。是名易养。易长者。于四供养知量知足。是名易长。若粗若细趣得而受。为少欲故。即是知足。净者。为少欲知足。是名净。已净故。不染尘垢。即是抖擞。因抖擞尘垢。是名端正。又言三业俱净弃除三不善业无人毁呰。是名端正。不聚者。身覆藏烦恼。令开发使分散。是名不聚。以不聚故。即勇猛精进。佛为诸比丘制戒。善者能信受随应比丘。何以故。若少欲知足人者。即能受持。是故佛为说戒本。如五色华次第贯穿。亦如七宝珠贯之次第。今世后世说令恐怖。若人乐学者住学地。而得阿罗汉。或得斯陀含阿那含须陀洹。若无因缘者亦得生天。若佛说长阿含短阿含。善者能信受。戒者学地。何谓为学地。答曰。禅定三昧法。何谓为学地。因十法。因十法故。而为结戒。令众僧安隐。安隐者。不倾危。若人能受如来所说禁戒者。当来世极大安乐。是名安隐。佛言。若人受我语者。我为结戒。若人不受我语。我不说戒。但说根本因缘。亦不强伏。是故律本所说。因十法故。令众僧安乐。此作不得罪。此作得罪。此时应作。此时不应作。为乐学故。莫令狐疑。是故律本所说。惭愧比丘不言。制不惭愧比丘。以此法故。令惭愧得安乐。何以故。不惭愧比丘。不得入众集僧布萨自恣。惭愧比丘得安乐。何以故。得闻禅定三昧。不惭愧比丘不得触娆故。故律本说。惭愧比丘得安乐。断今世恼漏故。今世恼漏者。为不覆五情。即于今身作不净行。或人捉或打或杀或自悔过。如是种种苦恼。断令得度脱。制不惭愧比丘。不惭愧者。破戒。又言。已作不善法故。而不羞耻。如此人佛制之。若如来制已。作恶法反问他人。见我何所作何所闻我得何罪。如是恼乱众僧。若结戒者。众僧以毗尼法。呵责破戒比丘。不得动转。是故律本说。制不惭愧比丘。惭愧者。得安乐住。若有惭愧比丘乐学法戒。此应作此不应作。断灭未来漏者。为不断五情故。而行恶法。后身堕地狱中。受诸种种苦毒。非直一受而已。轮转在中无央数劫。如来为此说戒断此因缘。未信心者令信。如来所以结戒。若善比丘随顺戒律威仪具足。若未信心见之即生信心。而作是言。此沙门释家种子。勤心精进难作能作所作极重。见如是作已而生信心。若外道见毗尼藏而作是言。佛诸比丘亦有围陀。如我无异。而生敬心。是故律本所说。未信令信。已信者令增长。若有信心出家。随禁戒所说。人见所行甚为恭敬。又言。云何尽形寿。日止一食而修梵行。护持禁戒。见如是已信心增长。是故律本所说。已信者令增长。令正法久住者。正法有三种。何谓为三。一者学正法久住。二者信受正法久住。三者得道正法久住。问曰。何谓学正法久住。答曰。学三藏一切久住佛所说。是名正法。于三藏中十二头陀．十四威仪．八十二大威仪戒．禅定三昧。是名信受正法久住。四沙门道果及涅槃者。是名得道正法久住。如来结戒故。令比丘随顺。若随顺者。具足而得圣利。是故学为初正法久住。为爱重律者。有结戒故。覆藏毗尼。弃舍毗尼。调直毗尼。结戒毗尼。此四毗尼极为爱重。是故律本所说。爱重毗尼藏。法师曰。以一切语句。若初中后句。汝自当知。于戒中罪福。比丘应学。是故律本说。佛语诸比丘。汝当说戒。问曰。此语云何。佛语比丘。我已结戒。汝当说当持当学当教余人。作如是说。若比丘行淫欲法。得波罗夷罪不得共住。如是断根法。坚固作已。初结波罗夷。为欲随结猕猴。今说其根本。如是佛以为声闻弟子结戒。是故律本所说。为诸比丘结戒。初结品竟

法师曰。若句义难解者。我今当说。尔时有一比丘。此句义易解。以饮食诱猕猴者。是时大林中多诸比丘行慈悲心。为慈悲故。多畜生无所畏。獐鹿猕猴孔雀翡翠雁雉诸杂禽兽。于禅房前经行游戏。是时有一比丘。于猕猴群有一雌猕猴。形状肥壮可爱。此比丘以饮食诱。共行不净法。是比丘行不净法。游行观看房舍者。诸比丘从余国来问讯世尊。因而往到此。是时比丘早朝得阿揵多食(汉言客比丘食)食竟而作是念。我等宜往观诸比丘房舍。是故律本言。往观房舍。往至诸比丘所。是猕猴先与一比丘作不净行。猕猴见诸比丘来。意谓诸比丘悉如先比丘无异。即往到诸比丘所。而以欲心行调。如先所共行淫比丘无异。到已便以欲根向诸比丘。现其淫相。举尾现示待。恐诸比丘皆有淫意。于久不见。便自作其淫形状。示诸比丘。诸比丘知猕猴欲为淫事。诸比丘言。我等可在屏处伺乞食道人还。当见其所行。定是长老。定者实不虚。如劫盗人具收其藏不敢隐蔽。实为长老不作如此耶。女人欲根畜生女根不异。佛所结戒皆为此事。人女见者。若见若捉若摩。所为不净行者。畜生女亦如是。一切作悉是恶法。汝长老。汝以此方便而作。乃至共畜生。得波罗夷罪不应共住。若共畜生女以作不净行。亦言成波罗夷罪。法师曰。随结令得坚固。戒有二法。一者世间自然罪。二者违圣人语得罪。若心崇于恶法者。即是世间自然罪法。余者如来所结戒罪。于世法随制。以断结令坚固。唯除梦中。于梦中不犯。制中随结无性罪。展转食别众食。无性罪随结。不犯如是世间法。如是如来。以为诸比丘随结戒已。猕猴品竟

今起余法。悉是因拔阇子而起。如调达得拔阇子都党而破和合僧。此是拔阇子起。又佛涅槃后一百岁。而作非法非毗尼非佛教。皆是拔阇子起。如律本所说。佛已结戒竟。拔阇子恣食恣眠已而生欲意。又不舍戒行淫欲法。而后眷属坏败。坏败者。各迸散为王所罚。或死亡别离。是名眷属坏败。或病苦逼迫病者。身体羸损。以羸损故。而生大苦。大德阿难。我等非毁谤如来者。不说如来罪。不诽谤法。不毁众僧。我辈自毁身。无福德无威风。今当修持正法者。三十八观法。我等辈次第而观菩提法者。此是阿罗汉道。慧因修集者。令增长我等而住者。弃舍白衣所住。住清净处无所余作。阿难答言。善哉。是时阿难不知他心。但闻发大誓言。若得如是极为大善。是故阿难答言。善哉。无有是处。此语断。若应果者。即言有处。以无果故。而无是处。是故佛答阿难。无有是处。如来已观拔阇子等无有因缘。若佛与拔阇子等具足戒者。此等已得波罗夷罪不应共住。是故律本所说。无有是处。若至莫与具足戒。若众僧与具足戒者。非清净法不成沙门。于沙弥地而住。若住沙弥地者。尊重正法所修而得。佛以怜愍此等故。不与具足戒。亦与具足戒。何以故。为不破戒故。于清净法中恭敬尊重。此有因不久得道。是故律本说。若出家者。与具足戒。不与具足戒。此三法已具。如来为欲结戒。告诸比丘。汝当如是说戒。若比丘不应共住。法师曰。此律本已具。我今当分别说。若者总名。不属一人。法师曰。于戒句中于戒本中于问难中。若欲知者有四毗尼。应当知。诸大德有神通者。抄出令人知。尔时集众时。问曰。何谓为四。一者本。二者随本。三者法师语。四者自意。问曰。何谓为本。一切律藏是名本。何谓随本。四大处名为随本。佛告诸比丘。我说不净而不制。然此随入不净。于净不入。是名不净。佛告诸比丘。我说不净而不制。然此随入净。是名净。佛告诸比丘。我说听净。然此随入不净。于净不入。此于汝辈不净。佛告诸比丘。我说听净。然此随入净。于汝辈净。是名四大处。问曰。何谓法师语。答曰。集众五百阿罗汉时。佛先说本。五百阿罗汉广分别流通。是名法师语。问曰。何谓自意。答曰。置本置随置法师语。以意度用方便度。以修多罗广说。以阿毗昙广说。以毗尼广说。以法师语者。是名自意。又问。此义云何。莫辄取而行。应先观根本已次观句义。一一分别共相度量。后观法师语。若与文句等者而取。若观不等莫取。是名自意。从自意者。法师语坚强。法师语应观。随本文句俱等应当取。若文句不等勿取。从法师语。随本坚强。若观随本文义等者应当取。若不等莫取。从随本本皆强坚。不可动摇。如众僧羯磨。亦如佛在世无异。法师曰。若观随本不能自了者。应观修多罗本义疏。俱等者取。法师曰。有二比丘共相诘问。一比丘言净。第二比丘言不净。更观本及随本。若本与随本。言净者善。若言不净莫取。若一比丘观本已净。又文义证多。第二比丘文义寡少。应从第一比丘语。法师曰。若二比丘文义俱等者。应反覆思惟筹量义本。应可取不可取。此是学四种毗尼人。若律师者。有三法者然后成就。问曰。何谓为三。答曰。一者。于本讽诵通利句。义辩习文字不忘。此是一法。第二者。于律本中坚持不杂。三者。从师次第受持不令忘失。问曰。何谓为本。答曰。一切毗尼藏。是名为本讽诵通利者。若有人不以次第句问。不假思虑随问能答。句义辩习者。律本句义善能分别。义及义疏皆悉能解。坚持不杂者。有惭愧意。是名坚持。若无惭愧人。虽多文解义敬重供养。不依法律。是法中蕀刺。何以故。亦能破和合僧。亦能恼僧。有惭愧者。于戒中恒生惭愧。乃可没命不为供养而破正法。缘有惭愧者。而有戒律。不杂者。于文句中不相杂乱。若有人问者次第而答。若颠倒律本义及义疏而答。譬如人行刺蕀中难可得度。若有人以此理问者。乃以彼语而答。若能辩者有所问难。随问而答无所脱落。如以金碗请师子膏。不得漏失。故名不杂。次第从师受持不忘者优波离从如来受。陀写俱从优波离受。须提那俱从陀写俱受。悉伽婆从须那俱受。目揵连子帝须从悉伽婆受。又栴陀跋受。如是师师相承乃至于今。若知如是者。是名坚固受持。若不能得次第尽知师名者。须当知一二名字也。若能具足善三法者。是名律师。若是律师。众僧集判诸诤事。律师于中先观六事。安详而答。问曰。何谓为六。答曰。一者观处。二者观本。三者观文句。四者观三叚。五者观中间罪。六者观无罪。问曰。何谓为观处。答曰。若草若树叶应覆身而来。若不覆身裸形入寺者。得突吉罗。如是观罪相已。即取律本为证。而灭诤法。是名观处。观本者。问曰。何谓为观本。答曰。若故妄语得波夜提罪。如是五篇罪。于五篇中。可一一观罪性。即取本为证。而灭诤法。是名观本。何谓观文句。身未坏者得偷兰遮。如是七聚罪相。可一一观罪性。即取本为证。而灭诤法。是名各观文句。何谓三。僧伽婆尸沙有三叚。波夜提有三叚。于三叚中观。即取本为证。而灭诤法。何谓为观中间罪。答曰。举火榛得突吉罗罪。如是戒本中。观中间罪取本为证。而灭诤法。是名为观中间罪。何谓无罪。不受乐。无盗心。无杀心。无妄语意。无出心。不故作不知。如是一一无罪相观。以本为证。而灭诤法。若比丘知四毗尼法。又善三法观六事已成灭法。若比丘灭法不俱回转。如佛在世无异。若比丘犯制戒。即往律师自有狐疑。而便问言。此事云何。律师先善观。若有罪答言有罪。无罪者应答言无罪。可忏悔者语令忏悔。应与阿浮呵那者答言与。若不与当言不与。见波罗夷罪相。莫道言汝得波罗夷。何以故。初波罗夷淫欲虚诳妄语其相易现。杀盗二戒其相难知。因细而得从细而解。是故莫向狐疑人道。汝得波罗夷罪。若有师者答言。汝今可往咨问汝师。即便遣去。仍往到律师所。而问言。此罪云何。若此律师观其罪相可治。此比丘得律师语已。即还报律师言可治。律师言。善哉。随语而作。若无师者。教问同学。同学若答言可治。还报律师。律师答言。善哉。若无同学教问弟子。弟子又答言可治。还报律师。律师言。善哉。随语而作。若弟子见有罪相。莫作是言。汝得波罗夷罪。何以故。法师曰。佛出世难得。出家亦难得。受具足戒甚难。语已律师即净扫洒房舍。令狐疑比丘尽日坐。坐已即与三十禅法。令其自观。若戒无病。观者禅法即现。威仪贯通心便入定。坐在定中。若过一日亦不觉知。到瞑律师往至其所。而问言。长老。心意云何。答言。大德。我心意唯有定耳。律师又言。长老。出家人甚难。于沙门法慎勿懈怠。皆应修学。若破戒者。入禅心即不定。如坐棘刺。何以故。为悔过火所烧。亦如坐热石上。不得安定。而复起去。若律师往到其所而言。长老。心意云何。为定与不。答言。不定。律师言。人于世间为罪行。不可覆藏。初作时。护身善神先应观知。又沙门婆罗门略知人心。长老。汝可随宜觅安止处。四种毗尼及律师三法品竟

善见律毗婆沙卷第六善见律毗婆沙卷第七

        萧齐外国三藏僧伽跋陀罗译

法师曰。今当为解律中文句。如律本所说名者。不独一随人而结。人身修习生名姓戒寺行年纪。当以一一而知。我今分别解说。人身者。随得一人。或长或短。或赤或黑或白。或肥或瘦。修习者。或修禅定。或修僧事。或修学问。是名修习。生者。或生刹利家。或婆罗门家。或毗舍家。或修陀家。故名为生。名者。或名佛陀勒诘多。或名昙无勒诘多。或名僧伽勒诘多。是为名。姓者。或姓迦旃延。或姓婆私叉。或姓拘私夜。是名为姓。戒者。随其所持禁戒。故名为戒。寺者。随其所住寺舍。是名为寺。行者。随业而行。故名行。年纪者。或五或十或二十或三十。故名年纪。是名律中文句。若有比丘行。是比丘得。比丘者。是乞士。或得或不得。亦名乞士。此皆是善人之行。佛辟支佛声闻悉行乞食。或贫或富舍家学道。弃舍牛犊田业及治生俗务。而行乞食资生有无。皆依四海以为家居。是名比丘。着割截衣者。衣价直千万。比丘得已。便割截而着。坏衣价直。以针綖刺纳。毁其细软。遂成粗恶。衣先鲜白。而以树皮坏其本色。便是故衣。名为比丘。是故律本所说能着割截衣者。是名比丘。沙弥者。亦名比丘。如有檀越来请比丘。沙弥虽未受具足。亦入比丘数。是名字比丘。长老。我亦名比丘。此是假名比丘。法师曰。云何名假名比丘。如长老阿难夜行见一犯戒比丘而问。咄此为是谁。犯戒比丘应言。我是比丘。此是假名无坚实也。善来比丘者。有白衣来诣佛所欲求出家。如来即观其根因缘具足应可度者。便唤言善来比丘。须发自堕而成比丘。唤者。如来于纳衣里出右手。手黄金色。以梵音声唤善来。可修梵行令尽苦源。佛语未竟。便成比丘得具足戒。三衣及瓦钵贯着左肩上。钵色如青郁波罗华。袈裟鲜明如赤莲华。针．綖．斧子．漉水囊。皆悉备具。此八种物是出家人之所常用。自然而有威仪具足。世尊即为和尚。亦是戒师。来至佛所头顶礼足退坐一面。法师曰。如来从初得道乃至涅槃。善来比丘其数有几。答曰。如此比丘其数有一千三百四十一人。问曰。名字何等。其名曰阿若憍陈如等五人。次名耶输长者子。其诸知识五十四人。拔群有三十人。阇致罗一千人。此二大声闻二百五十人。鸯掘摩罗一人。是故律以赞一千三百四十一人

  一千三百　　四十一人　　有大信心
  皆来诣佛　　如来慈悲　　举金色手
  以梵音唤　　应时得度　　衣钵自降
  皆悉善来

有大智慧皆悉是善来比丘名。非但此等比丘善来。复有诸善来比丘。斯楼婆罗门与三百人俱。复有摩诃劫宾那。与一千人俱。迦维罗卫国。复与一万人俱。又有一万六千人。与波夜罗尼婆罗门俱共出家。悉是善来比丘。此是修多罗中说。于毗尼藏不说其名。以三归得具足戒者。如是三过说三归。即得具足戒。如律所说。善来比丘得具足戒。三归得具足戒。受教得具足戒。答问得具足戒。受重法得具足戒。遣使得具足戒。以八语得具足戒。白羯磨得具足戒。法师曰。善来三归得具足戒已说。问曰。何谓为受教授。佛告迦叶。汝应如是学言。我于上中下坐发惭愧心。佛告迦叶。汝今应听一切善法入骨置于心中。我今摄心侧耳听法。佛告迦叶。汝应如是学念身而不弃舍。汝迦叶应当学。大德迦叶。以教授即得具足戒。迦叶具足戒者。皆是佛神力得。答问得具足戒者。须波迦佛听受具足戒。尔时世尊。于富婆罗弥寺经行。问须波迦沙弥。或问膖胀名。或问色名。此二法者。为是同一为是各异。因十不净而问须波迦即随问而答。佛即叹言。善哉。又问。汝年几。须波迦答。我年七岁。世尊语须波迦。汝与一切智人。并善能答问正心。我当听汝受具足戒。是名答问得具足戒。受重法得具足戒者。摩诃波阇波提比丘尼。是受八重法。即得具足戒。遣使受具足戒者。半迦尸尼遣使。八语得具足戒者。从比丘尼得白四羯磨。比丘僧复白四羯磨。是名八语得具足戒。白四羯磨得具足戒者。此是今世比丘常用八语得具足戒。法师曰。我取本为证。佛告诸比丘。我听汝等三归竟得受具足戒。如是佛听诸比丘受具足戒。善者无恶。今世凡人修善乃至阿罗汉。悉名善人。何谓为善。善戒．定．慧．解脱．解脱知见。与五分合。是名善人。真者。戒为最真。是名为真。譬如白[疊*毛]以青色染之。既成色已。便唤为青[疊*毛]。真比丘亦尔因戒故。名为真比丘。去烦恼内漏尽罗汉。亦名为真。学者。凡夫人与七学人学于三学。是名学比丘。无学者。学地已过住于上果。从此无复余学诸漏已尽。是名无学。集僧比丘者。最少集僧五人。多者随集多少。应取欲者。取欲现前。僧既和合。无有呵者。便作和合羯磨。白四羯磨者。一白三羯磨。应羯磨者。以法而作羯磨。不恶者。人身无难白羯磨。心善众不可坏者。无有薄故名不恶。善者。行法亦善。行如来教亦善。足者。得上相亦言至。问曰。何谓为上相。答曰。比丘相是名上相。以白四羯磨得至上相。是名具足戒白四羯磨。我今于中说白四羯磨。余者后当广说。阿波娄加(汉言小小白众也)白羯磨白二羯磨白四羯磨。如是次第从骞陀迦到波利婆罗。以羯磨本若至句。我当广说。若于中说者。于初波罗夷中而便乱杂。是以至句次说者令人易解。此中僧已集众竟。白四羯磨比丘。若是比丘行不净。得波罗夷罪。余诸比丘悉是同名比丘。若比丘共诸比丘。尽形寿入戒法中。戒者应学。学有三学。有上戒．上心．上慧。是名三学。问曰。何谓为上戒。上者。言无等也。戒者。学亦名无等学。上心者。是果心。上慧者。作业以知果。问曰。何谓为学。何谓为上学。何谓为心。何谓为上心。何谓为慧。何谓为上慧。答曰。五戒十戒是学。若佛出世若不出世。于世间中此戒常有。佛出世时。佛声闻教授余人。若未出世时。辟支佛．业道沙门．婆罗门．转轮圣王．诸大菩萨。教授余人。身自智慧教授沙门婆罗门。若其能学此功德者。死得生天或生人间。受诸欢乐。是名学波罗提木叉者。名无等学。于诸光明日光为王。于诸山中须弥为最。一切世间学波罗提木叉为最。如来出世便有此法。若无佛出世。无有众生能竖立此法。身口意行诸恶业。佛以无等学而制。又言。若入此同入道果。是名上学。心者。六欲有八功德心。世间有八心三昧。是名上心。过一切世间心。唯佛出世乃有此心。是名上心。此是道果心。若有此心。便无行不净法慧者。有因有果。业为因报为果。以慧而知。是名慧。佛出世不出世。便有此法。佛声闻教授余人。若不出世时。业道沙门婆罗门转轮圣王诸大菩萨亦教授余人。如阿拘罗十千岁作大布施。如毗罗摩婆罗门。如脾陀罗及诸大智慧人。作大布施功德满具。上生天上受诸快乐。转轮三相者。苦空无我。是名上慧。上学上心此二法者。智慧最胜。是名上慧。上慧者。唯佛出世乃有此法。道果慧亦名上慧。是故比丘入于三学中。行不净行得波罗夷罪。此三学中波罗提木叉学。若入其中。是名尽形寿。又言。诸比丘非一种。各异国土乡居不同。非一姓非一名。同一住处共一学。亦名共生。于波罗提木叉学不犯。是名尽形寿。戒羸不出者。不舍戒戒羸相不向人说。若戒羸向人说而不舍戒。戒亦不出。法师曰。何不言舍戒。而云戒羸。如戒本所说。不过二三宿共宿。而得罪。言语便易。所以佛说。此戒羸亦如是。是故律本所说。言语亦善而为说法。不舍戒义已足。何须言羸。譬如大王无人侍从。复无天冠璎珞。亦不庄严。人见不以为好。是以先云戒羸。后言不出。二句既合。是名为善。有戒羸而不出。戒不羸而出。于学中心厌不持。是名戒羸。愁忧者。于佛法中厌恶不乐。或言。今日我去明日我去。或从此路去彼路去。而出气长叹心散乱不专。是名愁忧。欲舍沙门法者。欲舍比丘相。厌恶者。以比丘相极为羞辱。见比丘相如见粪秽。乐白衣相。法师曰。次第律中易解。我今舍佛。善哉。我当舍佛。发言令人解。如是戒羸而不舍戒。法师曰。更有余戒羸我舍佛舍法舍僧。舍学舍毗尼。舍波罗提木叉。舍和尚舍阿阇梨。舍同学舍弟子。舍阇梨弟子。舍共和尚同学。舍共阿阇梨和尚同学。此十四句皆是戒羸之初。我今作白衣作优婆塞。作净人作沙弥。作外道作外道优婆塞。我非沙门我非释种子。此八句悉是戒羸因。从此二十句。合有一百一十句。名戒羸。从此以后。我忆母为初。有十七句。田者。稻田为初。处者。从此出甘果菜茹若叶。是名为处。技巧者。或能作瓦器或能受使。如是为初。犹恋家者。我有父母今还供养。此为初有九句。从此依止。我有母应还养母。母视养我。如是为初十六句从此作。梵行人一食一眠甚为难行为初有八句。我不能我不忍我不乐。如是为初五十句。又一百一十句。又复一百六十句。法师曰。次第戒羸已说。汝自当知。次舍戒句云何。比丘者。法师曰。此句次第易解。我舍佛舍法舍僧。舍毗尼舍波罗提木叉舍同学。舍和尚弟子阿阇梨弟子。舍同和尚弟子。舍同阿阇梨弟子。舍同学。此十四句与舍语相等。而说令人解。此是欲从法下。欲从比丘僧下。而说令人解。若此人欲说佛我舍。临发口而言。我舍佛非天竺正语。随得一语而说。我佛舍我法舍。如是次第乃至同学。如律本所说。于圣利满足。我欲入第一禅定。临发口误言。我入第二禅定。若如是语。此人欲舍比丘相。是故作如是言。此语若知者。即成舍戒。如帝释如梵魔堕无异。亦如此人从如来法堕还白衣。若是说。我已舍佛我欲舍佛我应舍佛。此过去现在当来语。若遣使若书若作手印向人说。此不成舍戒。若空诳妄语。以手现相而得重罪。此中不尔。若人舍者向人而舍。以心发言已然后说成舍戒。若发言向一人说。若此人解者。即成舍戒。若此人不解者。边有人解者。亦不成舍戒。若向两人说。一人解一人不解成舍戒。若悉解者成舍戒。若向百千人说。解者成舍戒。若比丘为淫欲所恼。欲向同学说者。复自忌畏。因在屏处作大声而言。我今舍佛。随有解者。忽有边人解。此比丘欲舍戒。舍于如来法堕落。即成舍戒。不前不后解此比丘语。如世间语无异。若此比丘语已未即时解。久久方思然后解欲舍戒者。不成舍戒。如空说如粗恶语供养。身口嗔故虚语。如此等语与此间无异。若置心而解便即得。若有狐疑久久方解。而不得罪。佛告诸比丘。如是戒羸者而成舍戒。若言白衣受我。我欲成白衣。我今成白衣。我已成白衣。而说者不成舍戒。若言今日令白衣受我。今知而置心中而说。以天竺中国语。或非天竺语。若人解此语者。便即舍戒。法师曰。如是次第优婆塞为初。从此七句八句十四句二十二句。我不用此何为。佛于我无益。我已说此四句。汝自当知。文句虽多义理归一。法师曰。我不能尽解。次第律本汝自知。法师曰。优波离言。佛有一百名。法名亦如是。余诸句亦如是。我今略说。我今舍佛失戒。我舍三藐三佛陀。我舍无量意。舍无譬意。我舍菩提智。舍无愚痴。舍通达一切。如是随号皆成舍戒。又言舍法。此名非号。即成舍戒。舍善分别。舍现身报。舍不异。舍来见。舍能济出。舍智慧真实知。复言。我舍无作法。舍离欲。舍灭。舍甘露法。舍长阿含。舍短阿含。舍梵网。舍初本经。舍僧述多。舍鸯掘经。舍本生经。舍阿毗昙。舍功德法。舍非功德亦非功德。舍识处。舍善置。舍神通地。舍摄领。舍勇猛。舍菩提。舍道。舍果。舍涅槃。我舍八万四千法聚。以如此号悉成舍戒。我舍僧。此说非号。舍善从僧。舍正随。舍以理随。舍集僧。舍四双僧。舍八辈僧。舍应供。舍叉手供养。舍无上福田。号名僧。亦成舍戒。我今舍戒。此说非号。成舍戒。舍比丘戒。舍比丘尼戒。舍上学上心。舍上慧。以号舍即成舍戒。舍比丘毗尼比丘尼毗尼。舍初波罗夷第二第三第四波罗夷。舍僧伽婆尸沙。舍偷兰遮。舍波逸提。舍波罗提提舍尼。舍突吉罗。舍头婆和多(汉言微细罪也)如是戒号。亦成舍戒。我舍波罗提木叉。此名非号。便成舍戒。舍比丘波罗提木叉。舍比丘尼波罗提木叉。此是号。亦成舍戒。我舍学而成舍戒。舍比丘学比丘尼学第一第二乃至波罗提木叉学。舍三藐三佛陀学无量意学。舍智慧学舍离学。如是次第我今当舍。和尚人度我出家。及与具足戒。于某处。我得出家。于某处我得具足戒。此人我舍。如是说舍和尚。以号名舍和尚。戒亦得舍。我今舍阿阇梨。此语非号。戒即得舍。若人度我。若人教我依止某处而问而学。此人我当舍。如是以阿阇梨号而说。便得舍戒。我舍弟子。此语非号。戒即得舍。若人我度。我与具足戒。于我处得出家已。得具足戒已。此人我今舍。如是舍弟子。以名号故。即成舍戒。我今舍阿阇梨弟子。即成舍戒。若人我出家。若教授咨问我者。此人我舍。以此名号。即成舍戒。我今舍同学戒。即得舍戒。若人我师度与具足戒。于我师处得具足戒。此人我舍。以同学名号。即得成舍。我今舍同学阿阇梨。戒即得舍。若人我阿阇梨度与具足戒。于阿阇梨处咨问。我阿阇梨教授令知。此人我舍。如是以阿阇梨同学名号。即成舍戒。我今舍一切同学。即得舍戒。若人与我共一学心共一学慧。此人我舍。如是以一切同学名号。即成舍戒。我今作白衣。即成舍戒。我还复如故。我作估客。我今耕田养牛畜五欲。如是以白衣名号。即成舍戒。我今作优婆塞。便成舍戒。我今作优婆塞二语。作优婆塞三语。我持五戒或持十戒。我今作优婆塞。如是以优婆塞名号。戒即成舍。我今作净人。戒即成舍。我为众僧驱使。我今分粥分米果木果。如是以净人名号。即成舍戒。我作沙弥。即成舍戒。作年少沙弥。作小沙弥。如以沙弥名号。即成舍戒。我今作外道。即成舍戒。作尼乾陀．阿寅婆迦。作多波须。作波利婆阇。作畔郎具。如是以外道名号。即成舍戒。我作外道优婆塞。即成舍戒。作尼干优婆塞。作阿寅优婆塞迦优婆塞作多婆须优婆塞。作波利波阇优婆塞。作畔郎具优婆塞。如是以外道名号。即成舍戒。我非沙门。即成舍戒。我作破戒行恶法。作臭秽净行覆法。非沙门而言沙门。非梵行而言梵行。中盛臭秽。如是以非沙门名号。即成舍戒。我非释迦种子。即成舍戒。我非三藐三佛陀子。非无量意子。非无譬意子。非菩提智子。非勇猛子。非无愚痴子。非通达无碍子非胜胜子。如是以释迦种子名号。即成舍戒。以此因故。以此表故。以此方便故。以佛名号故。如是说已。悉是舍戒因。置佛为初。更有余语舍戒。无有是处。法师曰。如是舍戒相。我已现耳。于不舍戒者。莫令狐疑。我今广说舍戒。因人为初。或因人成舍戒。或因人不成舍戒。法师曰。律本所说。佛告诸比丘。云何不成舍戒。初句说颠者。或夜叉颠狂瞻颠狂。余者随颠倒心。若其舍戒。不成舍戒。若于颠狂人舍戒。意甚乐舍戒。而颠狂人不解戒。不成舍戒。失心者。如夜叉颠狂无异。法师曰。夜叉颠狂与瞻颠狂。此无罪。后当说。如是失心舍戒。而不成舍。为苦逼迫者。苦刀已触以心闷故。而言舍戒。戒不成舍。或向受苦者说。以苦闷故。不解此说。不成舍戒。向天神者。地神为初。乃至阿咤贰杈天神。若向此诸神舍戒。戒不成舍。向畜生者。摩睺罗伽．迦楼罗．紧那罗．象．猕猴。及诸畜生。向此辈舍戒。戒不成舍。颠狂人向颠狂人。为不知故。戒不成舍。法师曰。向诸神舍戒其速知。何以故。为其大功德故。三因受胎所以速知。若此人转心我欲舍戒。诸天神已自知。佛护人心易动勿令失戒。是故佛断。勿向天神舍戒。于人中不断。若共者若不共。若等例者不等例者。若向白衣若向出家。向解人舍戒。皆即成舍。若此人不解。皆不成舍。法师曰。我已说此义。善语者。何谓为善语。所以善人所行。是摩竭国语。若边地安陀罗弥国语。而不解摩竭国语。或有余国语。展转相语皆悉不解。而教之。汝作如是言。若不知者。先教授令知。戏论言语。速急误言。我舍佛痴疙。如是诸舍戒。戒不舍。智慧人速急或误语。而不成舍戒。不欲舍而言舍。如人读律无异。如人闻律如人诵律无异。教授无异。如此诸语不成舍戒。欲向说而不说。已有戒羸相。我今舍戒。不作是言。此是欲说而不说。向痴人说者。向老耄人说。向土像木像人说。或向野中小儿。或至不向说。如此语悉不成舍戒。法师曰。我今断言。以一切随方便。我今舍佛为初。即成舍戒。余者不成舍戒。法师曰。今行不净法为初。我今分别说义。如律本所说。行不净法者。问曰。云何不净法。答曰。非好法非善人法。野人法愚痴人法。如律本说。大罪乃至捉水于静处二人。此恶法从句义。捉触历沙。悉成大罪。以水为端。是名为不净行。于覆藏处者。静处无人而行不净行二人可尔。是名不净行。问曰。何谓行不净行。答曰。二人俱欲俱乐。亦言二人俱受欲。是名行不净行。如律本所说。以男表置女表。以女表置男表。以男根内女根。若入一胡麻。风不至处湿处。若入如此处。得波罗夷罪。女根中四面当中央此五处。四边及中央皆犯罪。男根亦有四边当头屈入。此六事若一一入。犯波罗夷罪。屈者。如屈指如称头。高低俱犯。若男根生疣死。不受乐突吉罗。觉乐者得波罗夷。以男根毛。手指头若入者。得突吉罗。法师曰。此是行不净法。何以故。此恶不善语。若诸长老。闻说此不净行。慎勿惊怪。是沙门惭愧心。应至心于佛。何以故。如来为慈悲我等。佛如此世间中王。离诸爱欲得清净处。为怜愍我等辈。为结戒故。说此恶言。若人如是观看如来功德。便无嫌心。若佛不说此事。我等云何知得波罗夷罪偷兰遮突吉罗。若法师为人讲。听者说者。以扇遮面。慎勿露齿笑。若有笑驱出。何以故。三藐三佛陀怜愍众生金口所说。汝等应生惭愧心而听。何以笑。驱出。乃至共畜生者。此是下极语。共畜生亦得波罗夷罪。岂况女人。法师曰。我次第而解。有足无足畜生。无足者蛇。有足者二足。下至鸡上至金翅鸟。四足者。下至猫上至犬者。取蛇者。蚺蛇一切长者。其中三处。一一入如胡麻。得波罗夷。余不堪者突吉罗。鱼者。一切鱼龟鼍鳖蛤等。亦如前说三处得罪。此中有小异。蛤口极大。若以男根内蛤口。而不足如内疮无异。得偷兰遮。若取鸡乌鸟雉鸠鸟一切诸鸟于三处。应得波罗夷者得。应得突吉罗者得。若取猫者。狐狸狗猘亦如前三处得罪。波罗夷者。退堕不如。此是比丘罪。如律本所说。佛语阿难。佛为拔阇子结波罗夷戒已。成就如是。汝比丘得波罗夷罪。是名波罗夷。法师曰。若人犯此戒。名为波罗夷。是故于波利婆品偈言

  我说波罗夷　　汝当一心听
  堕落是不如　　违背正法故
  不同一住处　　是名波罗夷

此是犯波罗夷重罪。此人名为堕。亦言从如来法中堕非释迦种子。于比丘法中不如。是名波罗夷。不共住者。不共行为初。法师曰。我当次第说罪。僧有四行。于戒坛中作四法事和合。是名一行。亦言五行波罗提木叉。应一处说波罗提木叉。无惭愧人不得入。于一众僧事不得同入。驱出在外。是名不共住。是故律本说。不共布萨及诸羯磨。是比丘得波罗夷罪不应共住。律本说竟

如是已说次第戒句。若处处犯者。欲知分别。是故如来结此文句已。根入根不但人女。一切女亦如是。金银女。此女非处若处。得罪者。我今当说。三女者。于三女根中。人女有三道。黄门有三。各有三根。有三男子波罗夷。十二处人男女。此易可解。二根黄门后自解说。人女有三根。畜生女亦三根。人女有三根。非人女有三根。畜生女有三根。二根黄门人非人畜生合九。人黄门非人黄门畜生黄门有二合六。人男子非人男子畜生男子合六。都合三十。若二处乃至入如胡麻子。行不净行。得波罗夷。非欲心不成。是故律本中说。比丘不起心。如是初说。比丘者。此是行欲比丘。谷道者。是粪道。若比丘行淫。于粪道中入如胡麻。得波罗夷罪。非但己作。亦教人作。若行时已自受乐。罪亦不免。此皆用心。非余事得罪。善人出家。若人捉令作不净行。此比丘不乐一心护戒。此不得罪。后受乐得波罗夷罪。有怨家将女人至比丘所欲坏比丘。或以饮食诱。知识眷属至比丘所。而作是言。大德。此是我等事。愿大德为作。夜半将一女人。捉比丘推眠。或有捉比丘手捉头捉脚者。而以女根谷道逼内比丘根。若此比丘三时受乐。得波罗夷罪。若精出亦犯不出亦犯。莫作是言。此我怨家捉而不得罪。心受乐便犯。若具四事。何谓为四。一者初入。二者停住。三者出。四者受乐。若初入不受乐。停住出时乐。得波罗夷。初入不乐停住不乐。出时乐亦得波罗夷。四时无乐不犯。不受乐者。如内毒蛇口。如内火聚中。是故律本说。出入不受乐。不得波罗夷罪。是故比丘坐禅。观苦空无我不计身命。女人围绕如火绕无异。于五欲中。如五拔刀贼伤害无异。若如此者即无罪。初四事竟

如是四事已现。诸怨家将人女至比丘所。不但谷道得重罪。小便道口亦得罪。又时怨家将人女。或将竟夜不眠。或将醉女颠狂女或将死女。又怨家将女死尸野兽未食。法师曰。未食何等。未食女根。又将女死尸。女根多分在或少在。不但女根。谷道及口。或多分在少分在。不但人女。畜生女亦如是。于三处多分在少分在。二根男子二根黄门。或多分在少分在。此有四种如是无异。法师曰。人女有三道。于三道中三四。不眠女有三四。醉女有三四。颠女有三四。狂女有三四。死女多分在有三四。死女少分在有三四。死女余少分在有三四。有二十七。非人女畜生女亦如是。合诸女八十一。二根黄门亦如诸女人无异。合八十一。黄门男子二三道。合五十四。非人男畜生男各有二。合五十四。女如此都合二百七十处。此义易可解。多分在少分在。我当分别广说。于师子国有二律师。此二律师共一阿阇梨。一名大德优波帝写。第二名大德写写提婆。此二法师如恐怖处护律藏无异。优波帝写有弟子极智慧。一名大德摩诃波头摩。二名大德摩诃须摩。摩诃须摩已曾九遍听律。摩诃波头摩。与摩诃须摩俱共九遍听受。复自覆九遍。是故最胜。大德摩诃须摩。九倒听律已。舍阿阇梨渡江别住。大德摩诃波头摩。闻摩诃须摩已渡江住。而作是念。此律师极大勇猛。其师犹在而舍师去往住处。是名最勇猛。若师犹在。应听律藏及广义疏。年年应受。非一过也。讽诵通利。是名律师恭敬于律。又一日。大德优波帝写大德摩诃波头摩为初。五百弟子。于初波罗夷中。说此文句而坐。是时弟子问师。大德。多分在得波罗夷罪。余少分在得偷兰遮。半分在云何。得何等罪。师答言。长老。如来所以结波罗夷。尽结不余。若波罗夷处。结波罗夷罪。此皆是世间罪。非结罪。若是半分在成波罗夷罪。佛便应结。不见波罗夷影。唯见偷兰遮影。若死尸中。佛结波罗夷。多分在得波罗夷罪。少分在得偷兰遮。从偷兰遮不见有罪。少分者。于死尸中。应知非生。若肉如指爪根皮或筋犹在根中。得波罗夷。若坏烂肉皮无有。犹有形摸。用入男根者得重罪。若形摸尽坏烂平如疮无异。得偷兰遮。从此狗啖离尸肉。若肉中行淫得突吉罗。若于死尸中一切尽啖。唯余三道中行淫得重罪。若半分在少分在得偷兰遮。若生身中眼鼻耳。又男根头皮及伤疮。若有欲心入一胡麻子。得偷兰遮。余身掖者得突吉罗。此是淫心。若死尸犹湿处。若于波罗夷处偷兰遮。偷兰遮处突吉罗。突吉罗处若有犯者。而随犯得罪。若此尸膖胀烂臭诸蝇围绕。从九孔脓出。若欲往而不堪。若于波罗夷处偷兰遮。偷兰遮处突吉罗。突吉罗处有行淫者。悉得突吉罗。畜生象马[牛*秦]牛驴骆驼水牛。于鼻中行不净。得偷兰遮。一切眼耳疮。得突吉罗。余处者突吉罗。若死犹湿。于波罗夷处偷兰遮。突吉罗处有犯者。随其轻重得罪。若死尸膖胀如前说。得突吉罗。男子根头皮中。或乐细滑。或乐行淫心。两男根相拄。得突吉罗。若淫心与女根相拄。得偷兰遮。此大义疏出。若比丘欲心。与女根相拄或口中。得偷兰遮。为谁起。答曰。因六群比丘。尔时六群比丘。于阿寅罗波帝夜江边。诸[牛*秦]牛度江泅。遂捉得角而行淫于角间。或行耳颈尾下背上。欲意而触。不分别说。佛告诸比丘。若欲意相触者。得偷兰遮。此一切相畴量而取。不失此义。云何不失此义。若欲心以口与口。此不成淫相。得突吉罗罪。本无淫心。乐受细滑。以口与口。僧伽婆尸沙。以男根触女根外分。亦僧伽婆尸沙。畜生女根以男根触外分。得偷兰遮。乐受细滑得突吉罗。都合二百六十九。四种说竟。如是世尊。为护顺从者。说二百七十四种。如来为欲遮将来恶比丘故。莫作是言。以物裹男根行淫言无罪。故作此事以遮正法。勿使当来成就于二百七十四种。取一四隔分别而现。有怨家将女人。欲坏比丘净行。或以谷道水道口。以此二事而坏比丘。有隔无隔。有隔无隔者。以女三道。无隔者比丘根。法师曰。此事我当分别善说。有隔者。于女三道中。以物隔女根。或以树叶。或衣或熟皮。或蜡或铅锡。是名为隔。法师曰。随得物而用隔。有无隔而入。无隔有隔。无隔无隔。有隔有隔。有淫心作。得波罗夷罪。若犯波罗夷得波罗夷罪。若犯偷兰遮得偷兰遮罪。犯突吉罗得突吉罗罪。若以物塞女根。于物上行淫。得突吉罗罪。若以物缠男根。以物头内女根中。得突吉罗罪。两物相触。得突吉罗罪。若以竹籚筒内女根。于筒行淫。若入触肉者。得波罗夷罪。若破筒两边触肉。亦得波罗夷罪。若以竹节遮男根头。四边着肉。亦得波罗夷。若于竹筒不触者。得突吉罗。如是一切罪相。汝自当知。隔四种竟。如是隔四分别说已。不但怨家将女人至比丘所。怨家将比丘至女人所。有隔无隔如前说。怨家四事说竟。何以故。比丘怨家故。而作如是。或国王为初怨家。我今当说。此诸怨家。将女人至比丘所。或贼或多欲男子。以欲事为乐。或乐走放逸人。或乾陀贼。此贼常取人心以祠鬼神。何以故。不以耕田种植供给妻子。唯破村人估客取物。以此为业。诸乾陀贼求觅村人估客。劳自防卫。不能得故。比丘在阿练若处。无人防卫。易可得故。捉得而作是念。若杀比丘应得大罪。欲破比丘戒。而将女人至比丘所。令其破戒。法师曰。如前说无异。说四种竟。前说人女三道行淫。初说如是。今当演说断诸迷惑。以道道者。问曰。何谓以道道者。答曰。女人有三道。于一一道中。以男根内。或二道合成一道。水道入从谷道出。以谷道入以水道出。从道非道出者。从水道入。水道边有疮。从疮而出。以非道者。以疮入水道出。以非道入从非道出。波罗夷偷兰遮。二疮道合成一道。从第一疮入。第二疮道出。得偷兰遮。次说无罪不知不受乐者。此二我当演说。眠比丘者。若知受乐莫言我眠。而言不知不觉。言得脱二人俱驱还俗。应问眠者。汝受乐不。若受乐者犯波罗夷。故作者。不须问。如是有罪悉现。今次至无罪不觉者。此比丘若眠不觉。如人入定。都无所知。是故无罪。如律本所说。白世尊。我不觉此事。佛语比丘。若不觉不知即不犯罪。觉不受者。觉已即起不受乐便无罪。如律本所说。白世尊。我觉已不受乐。佛语比丘。若觉已不受乐。便无罪。颠狂者有二。一者内瞻颠狂。二者外瞻颠狂。外瞻如血遍身。若病起时体生疥癞。合身振动。若以药治即便得差。若内瞻起者。而生狂乱不知轻重。若以药治都无除差。如此颠狂不犯。失心者。夜叉反心有二种。一者或夜叉现形人见可畏。是故失心。二者夜叉以手内人口中反人五藏。于是失心。如此二者。便无罪也。若此二颠狂。失本心故。见火而捉如金无异。见屎而捉如栴檀无异。如是颠狂犯戒无罪。又时失心。又时得本心。若得本心作。狂病者。随病至处者不犯。初者。于行中之初。如须提那作。不犯波罗夷。余者犯。猕猴比丘跋阇子波罗夷罪。解律本竟

善见律毗婆沙卷第七善见律毗婆沙卷第八

        箫齐外国三藏僧伽跋陀罗译

戒句中欲分别令知。此是总说。汝等当知。起作识有心世间罪功德业受起者。总一切戒本。有六戒句起。法师曰。后当解。今当略说耳。后戒因六种戒而起。有戒因四种起。有戒因三种起。有戒因迦絺那起。有戒因羊毛起。有戒因舍心起。于此中因作而起。因不作而起。因作因不作而起。或因作起。或因不作起。或因作不作起。于其中有识得脱。有识不得脱。于戒中以心得脱。此是以识得脱。余者非识得脱。更有戒无心。有戒有心。问曰。何谓有戒有心。答曰。有心作而得罪。问曰。何谓无心。答曰。与心相离而得罪。此一切世间罪。制戒罪有二。诸罪相以说。行善受者。有戒身业。有戒口业。问曰。何谓为身业。答曰。因身行故。从此得罪。故曰身业。因口行故。故名口业得罪。复有戒善。复有戒不善。复有不善非不善三十二心起罪。欲界八善心。十二不善心。欲界有十无记心。从善心从无记心。有二知心。于诸心中。以善心得罪。名为善罪。余者次第亦如是说曰。有戒三受。有戒二受。有戒一受。于三受中。因三受得罪。名为三受。或因乐受。或因舍受得罪。名为二受。或因苦受得罪。名为一受。如是因无记想有心性罪行善受。汝等知此杂已。于诸起中。此波罗夷因何物起。便因一种起。以支者。有二支。何谓为二。因身心起。是名为二支。行以得罪。是名因行。想者。欲想。若无欲想。便得脱。无罪者。不知不觉不受不乐。有心者。有欲心行。然后得罪。性罪者。自然罪。若身心共作。然后得罪。以贪作。是名不善。或乐或舍。以此二法而得罪。是名二受。法师曰。一切罪相。于广说中汝等应知

  猕猴拔阇子　　老出家及鹿

此偈名为忧陀那。世尊自判忧波离。为未来世律师。易忆识故。说此偈颂。汝等应当善观罪相。猕猴拔阇子此事随制。白衣者。着白衣服行淫。草衣者。外道人结茅草为衣。木皮衣者。剥木皮以为衣。木板衣者。以木板遮前后以为衣。发钦婆罗者。织人发以为衣。毛钦婆罗。以牦牛毛织为衣。角鸱翅衣者。连角鸱翅以为衣。鹿皮衣者。取完全合毛四脚被以为衣。问曰。杀人何故不得波罗夷罪。答曰。本为细滑无杀心故。得僧伽婆尸沙罪。郁波罗华比丘尼者。本是舍卫国长者女。此比丘尼。于过去世百千劫积众善行。是故端正微妙。色如优钵罗华内。此比丘尼离诸烦恼。更增好色。故名优钵罗华比丘尼。染著者。从白衣以来。为男子之所染着。眠卧床上者。此比丘尼从外乞还食。开户入户。闇故不觉男子在内。便脱衣而眠。此婆罗门便从床下出。犯比丘尼。犯者。坏比丘尼。此比丘尼爱尽无欲。如热铁入身。是故不犯。此男子行欲竟去。此地能载须弥诸山王。而不载七尺恶人。是故地为之开。即入阿鼻地狱。火如罗网。世尊闻已语诸比丘。此比丘尼不乐故。故名无罪。佛因比丘尼。而说偈言

  如莲华在水　　芥子投针锋
  若于欲不染　　我名婆罗门

第十四句成女根者。于夜半中眠熟。男子相貌牙须失已。而成女相貌。和上具足戒。我听即依先。不须更请师及具足戒。腊数者。从初受戒。我听往比丘尼僧中。依先腊数而住。不同者。故出精为初。此罪转根即失。若更复为男子者亦无罪。法师曰。此是依文句次第解已。今更广解。此二根中男根最上女根下。何以故。男子若多罪者。而失男根变为女根。女人若多功德。而变为男子。如是二根以多罪故而失。以多功德故而成男子。若有二比丘。同住共咨禀讲说讽诵经典。而一比丘夜半转根成女。二人悉得共眠罪。若觉知者。而烦冤哭泣向同房说。同住应作是言。卿勿忧恼。如是三界罪。佛已开门。或比丘或比丘尼。都不闭塞善门。如是慰喻已。而作是言。卿可往比丘尼僧中住。若转根比丘尼问。大德。有知识比丘尼不。若有者答有。若无答无。若转根比丘尼更作是言。大德。可将我往比丘尼所。同住比丘。可将转根比丘尼付知识比丘尼。若无知识者。将至比丘尼寺若去时不得两人而往。若得四五比丘乃可共往。明把炬火捉杖行。我等哀愍往至尼寺。寺若远在聚落外。度江若置众者。此无罪也。若至比丘尼所而作是言。即说比丘名问比丘尼知不。若比丘尼知而答知。此比丘今转成女根。诸比丘尼应当怜愍此比丘尼。答言善哉。诸比丘尼应作是言。我等当与此比丘尼共讽诵经典听法。诸比丘送付比丘尼已。还归本寺。转根比丘尼随顺尼僧。意勿有违失。若诸比丘尼无惭愧心。又无同意料理。得移余尼寺。应觅依止师读诵经法随顺比丘尼法律。转根比丘尼得度弟子受依止。诸比丘尼不得讥嫌生彼此心。若先比丘时沙弥。付嘱余比丘。比丘时三衣钵。失受持法。至比丘尼所。应更受五衣钵。若受持外先有长衣钵者。依比丘尼法。应更说净畜。若比丘时所受七日药。失受法。应更受。若比丘时受七日药。满七日而转根。得更受持七日。先比丘时施主。于今比丘尼不失。即为施主。又比丘时一切布施共物。得依先分取。如律本所说。酥油蜜石蜜。若有人受七日药未满。有因缘事而食得罪。汝智慧人可思此理。此欲为转根人问故。受者。若为失若为不失。转根或死罢道还俗施人贼所劫抄。如是舍心。是名失受。若一呵梨勒果受已转根。即失此受。若在比丘时所有资生什物。悉得随身。乃至私房舍悉得随身。若先僧中所供给物悉还僧。若先于僧有恩。欲与好房舍卧具未与。而转根为比丘尼。比丘僧有应与若与比丘同。僧残者。应半月摩那埵出罪。若比丘时行摩那埵未竟。转根为比丘尼。尼应行半月摩那埵出罪。若行摩那埵竟。转根为比丘尼。应与出罪。若行半月摩那埵未竟。复转根为比丘。应与六夜摩那埵出罪。若行摩那埵竟复转根。比丘僧应与出罪。比丘转根因缘以说竟。若比丘尼时行媒嫁法覆藏不出。转根为比丘。不须覆藏六夜摩那埵出罪。若比丘尼正行半月摩那埵。转根为比丘。不须行摩那埵。直与出罪。若行摩那埵竟。转根为比丘。应与出罪羯磨。若复转根为比丘尼者。应与半月摩那埵出罪。法师曰。从此次第易可知耳。弱者。此比丘先是妓儿。是故脊弱。长根者。此比丘身根最长。泥画女像捻泥女像。画女像者。画为女像。木女者。刻木为女像。金银铜锡铁牙蜡木女。悉突吉罗罪。若欲作出精意。精出即得僧伽婆尸沙。若精不出偷兰遮。摩触木女人。悉突吉罗。端正微妙者。此比丘王舍城人。信心出家相貌端正。是故号为端正。此比丘在王路行。有女见此比丘形貌端正。即生欲心。以口衔比丘男根。此比丘是阿那含。不生乐想。次句诸比丘愚痴人随诸女人语。法师曰。此三偈易可解耳。口开张者。风所开也。若比丘口中行欲者。着四边波罗夷。不着四边及头突吉罗。若节过齿波罗夷。若齿外皮里亦波罗夷。若齿外无皮偷兰遮。若舌出外就舌行欲偷兰遮。生人出舌就舌行欲亦偷兰遮。以舌舐男根亦偷兰遮。若死人头断就颈行淫及口波罗夷罪。若颈中行欲偷兰遮。白骨者。若比丘初发心往。即得突吉罗。若舍取连合贪细滑者。行淫心若着精出不出。悉突吉罗。若作出精意僧伽婆尸沙。若不出者偷兰遮。龙女者。龙女化为人女形。或紧那罗女。比丘共作淫。悉得波罗夷。夜叉者。一切鬼神悉入夜叉数。饿鬼者。一切饿鬼。有饿鬼。半月受罪半月不受罪。与天无异。若现身身若可捉得。波罗夷罪。不现而可捉得。亦波罗夷。不现不可捉得无罪。若此鬼神。以神力得比丘。比丘无罪。法师曰。次第文句易可解耳。若男根病者。男根长肉生。名为疣。与此女人共行淫。觉不觉悉得波罗夷。至女根者。此比丘与女人共行淫法安男根不入女根而生悔心。是故得突吉罗罪。淫初法。若捉手若一一身分未入女根。悉得突吉罗若入女根得重罪。若比丘初欲眠先闭户。是故律本中说。佛告诸比丘。眠不闭户者。此是白日入定也。若比丘白日入定。先闭户入定。法师曰。律本说。不闭户不说有罪。开户而眠。于乾陀迦说。佛告诸比丘。若白日入定。应闭户然后入定若不闭户者。得突吉罗罪。优波离及诸比丘。已知佛意。是故于广说中而说。此句有罪白日得。于夜半不得。以此文句属着前句。法师曰。若户可闭。若户不可闭。答曰。树枝竹枝笄作。若如是为初。余者随作户扇。若扇下有臼上有纵容。若转户扇者。应闭牛栏户。横安二三木郭门。门扇安车用牵。或以板作扇。或用竹作。如店户并扇。或竹作帘。又用布作幔。若手捉钵闭户扇。唯除户布幔无罪。余者悉得突吉罗罪。若比丘白日入定。转户可闭。不闭得罪。余者不闭入定及眠不得罪。法师曰。可闭者。有臼及纵容关掸。此户可闭。不闭得罪。若闭者。安掸成闭若不安关掸。直闭着户刺者。亦成闭。头余少许不至。亦成闭极小不容人头入。如是亦善。若多有人在外。比丘沙弥长老。汝可看。作是言已入定无罪。或于外经行执作。此比丘应得看户作是念已眠无罪。于鸠沦陀者。广说也。向优婆塞语看户亦善。而不得向比丘尼及女人。若户扇臼纵容破或无。或于户前执作妨不得闭。作是念已眠无罪。若无户扇者无罪。若门屋应举梯入定无罪。若不举梯闭下户而眠无罪。若于房中眠应闭户。若大房后有小房闭大户小房眠无罪。若后小房眠闭后户。不闭大房户无罪。若一房有二户。悉闭然后眠无罪。若三重阁屋。下重上座住。中及上重比丘眠。而作是念。上座已在下重我眠无罪。若有守门人而语汝看户。作是言已眠无罪。若无上座及守门人。而向诸比丘沙弥及白衣语已眠无罪。若二人乞食前还者作是念。后还应闭户。法师曰。有户扇臼纵容者。不闭得罪。余者无罪。虽有臼纵容。屋无覆不闭无罪。若夜半眠开户无罪。至晓起者无罪。已起更眠得罪。若比丘眠时作念。我至晓当起亦得罪。有比丘远涉道路。或夜半得眠。足犹在地而眠。熟不觉则无罪。若举足上床眠不觉有罪。若比丘坐睡不闭户无罪。若房中经行睡熟。于地眠不闭。户无罪。若觉已睡眠得罪。有夜叉捉比丘强伏令眠亦得罪。于鸠沦陀广说。非本心者无罪。法师曰。大德波头摩言。觉不觉悉得罪。婆[少/兔]迦车迦比丘言。不是优波离逆取佛意判定无罪。判已后复问佛。佛叹言。善哉。法师曰。次第文句易可知解。离车童子者。离车是其种姓也。因姓而立名。此诸童子淫色。捉比丘令行淫。因此行非法故。败坏门户。老出家往看故二。此比丘晚暮出家。为哀愍故往。此故二向老比丘言。大德。儿子极多无人养育。大德可还俗。老比丘不答。故二知老比丘不还俗。即荡倒地。老比丘羸弱无力。摆拨不能得脱。故二即就上行淫。适其意而下。此比丘是阿那含人。断三界结。是故不受乐。鹿子句易可解耳。一切善见。初波罗夷品广说竟

  善见一切相　　律本无覆藏
  初中后亦善　　是名一切善
  如来化众生　　毗尼最为上
  为怜愍众生　　故说毗尼藏

  第二无二佛所说　　退堕不如波罗夷
  广说今至令人知　　离先初说成不杂

尔时佛住王舍城耆阇崛山中。王舍城者国名也。问曰。以何因故。名为王舍。答曰。初劫慢他多王瞿贫陀王。如是圣王为初。于此地立舍宅。故名王舍。又有别解。此国若佛出世时。及转轮圣王。此地立成国土。若无圣人出世者。此地夜叉为主。此是现行来处。又言耆阇崛山中。此是现如来住处。耆阇者鹫鸟。崛者顶也。耆阇鸟食竟还就山顶迻。是故名之耆阇崛山。又有法师解。山顶石形如似鹫鸟。是故名耆阇崛山。众者。如律文说。三人名众。从此以上名为僧。若以修多罗文句。三名为众。今用修多罗文句。知识者。不堪亲友住处相知。名为知识。耆旧者。亲厚知识同衣食也。伊私耆梨山边者。问曰。何谓为伊私耆梨。答曰。伊私者出家人。耆梨吞也。所以尔者。时有五百辟支佛。往至迦私俱娑罗国。到已乞食。得已还入此山。集众入定。是时人民见辟支佛入山边。而不见出。时人作是言。此山恒吞出家人。从此以后。号为伊私耆梨山。于山边作诸草屋者。悉用草。入夏坐有五百比丘。各各自作草屋。多罗叶为初。何以故。为如来已制戒故。佛告诸比丘。若欲入夏坐者。先修治房舍。若无房舍者。得突吉罗。是故夏坐。得现房舍者善。若无应倩人作。不得无房舍而夏坐。何以故。过去诸佛皆受房舍。诸比丘作房舍已。三月入夏坐。于三学中日夜勤学。是故大德檀尼迦。第二波罗夷为初。檀尼迦者名也。陶家者。此作瓦器业也。檀尼迦比丘在闲静处作一草屋。夏坐已竟者。已大自恣黑月初。坼坏草屋者。悉以次第坼解。不令有损。缚束悬着树枝不散。何以故。若有更乐住者。以此现草而作屋。临去时作是言。若有寺用及余比丘作屋者。随须而取。何以故作此言。正为阿兰若比丘作屋草木难得故。是以缚束若举置。若阿兰若比丘住竟去者。亦更坏取缚束悬举。勿使虫蛀。与当来同学用故。诸比丘行法作已而去。游行诸国随所乐。长老檀尼迦陶师子。即于此住。乃至三过者。取柴人谓言空屋坼破将去。自有技艺。于陶家所作无所不备。檀尼迦比丘和泥作屋。窗牖户扇悉是泥作。唯户扇是木。取柴薪牛屎及草。以赤土汁涂外。烧之熟已。色赤如火。打之鸣唤。状如铃声。风吹窗牖。犹如乐音。佛问诸比丘。此是何等赤色。佛知而故问。何以故问。为制戒因缘故。答世尊者。诸比丘向世尊言。此是檀尼迦陶师子屋。色赤如火。以无数方便呵责此比丘。云何痴人。于众生中无慈悲。而残害众生。无慈者。悲之前护义也。悲者。因彼苦故而心动。是名悲。不残害者。不毁伤众生命。因痴故。掘土蹋泥取火。烧多诸众生。因此死故。是故律本说。汝痴人者。当来众生而作是言。佛在世时比丘。已作如是残害众生。要当无罪。勿令众生生如是心。如来呵责檀尼迦已。佛告诸比丘。从今以后不得纯泥作屋。若有作者得突吉罗罪。因此瓦屋便成结戒。檀尼迦比丘若初不犯罪。余者有过佛语作。得突吉罗罪。若住者亦得突吉罗罪。若以茅和泥者善。纯泥作屋得罪。诸比丘答言。善哉。汝等可打破此屋者。诸比丘受佛语已。即往至屋所。以木石打破坏之。于是长老檀尼迦比丘为初说。法师曰。我今次第分别说之。是时檀尼迦。于屋一边白日入定。闻诸比丘打破瓦屋声。即问言。咄咄汝等。何以打破我屋。诸比丘答言。世尊使令打破。檀尼迦闻已即受教敕。若佛使破者善。法师曰。檀尼迦比丘作屋。自用物作屋。成佛何故而打破。答曰。所以破者。此屋不净故。是外道法用。复有余义。无慈悲众生作此瓦屋。若比丘多闻知律者。见余比丘所用不得法。即取打破无罪。物主不得作是言。大德已破我物。应还我物直。若有比丘。以多罗叶作伞。内外俱五种色。以綖贯连极令精好。此伞不善。若赤若黄二色。以綖贯连内外具等。此伞伞柄以糸缠。不以为华。贪取坚牢此善。若刻镂作禽兽种种形状者。此不善。有若作半月形不得作罂铫形及竹节。如此不善。听刻柄作镮以绳缚。坚牢故善。若作袈裟法者。不得缝作蜈蚣脚。若作袈裟。不得绣作文章。不得作锁形缝。可却刺缝。若安钩纽。纽绳得作四帘。不得十六帘。作钩者。不得槌及伽耶形。不得作蟹眼形。袈裟角法作。可安纽绳。勿令粗现。不得用米糊汁渍袈裟。若初作者。得用为却尘土故。若染时不得与香汁木胶油及已染袈裟。不得以蠡及摩尼珠种种物摩使光泽。若染不得以脚蹋。染时不得用手摩及以袈裟打盆里。不得手拳打。可以掌徐徐拍。若以绳安袈裟角。拟悬晒者。染竟截除。律本所说。佛告诸比丘。我听用袈裟角绳。法师曰。何但角缘边亦善。为浣染故。若取此为精不善。但割截而用。若钵法及半钵法。不得内外刻镂。若先有可去令漫。若熏钵不得作摩尼色。可作如油色。钵曼陀不得刻镂。可得作牙齿者善。若水法者。伞下口及腹。不得刻作异形。伞及下口。可刻作系缚处善。若腰绳法者。织作或一道二道。复合者得用鱼口。不得如蟹眼及两头安缕。又如频伽及摩竭鱼口。不得作鼍头种种精好织作文华。唯除鱼骨及珂树罗花或缦织头。不得留多缕耳。若极多可四缕。若用完绳者。止一缚及宛转。若有完绳两三股缠相着善。不得作八相绳。绳头听安二结。如瓶形。若作药筒法者。不得刻作男女及四足二足众生倒巨华及榛牛屎形。如是形不应作。若得如是筒。磨削去善。若用綖缠。拟坚牢故得用。或圆或方或八帘十六廉者。若筒底及口盖。得作两三镮。拟缚故。药杵法者。不得作好色。囊者亦尔。户钥法者。及囊不得作好色。可纯一色善。不得刻镂作禽兽形。刀子法者。不得刻镂作禽兽形模。听安口带。剔爪凿法者。中央如钻形。火钻朽法及承掌。悉不得作华种种刻镂。惟除镮。作针法者。先安鉆。钳竟然后炉。勿使落失。亦不得作刻镂种种形状。截杨枝[金*斧]。不得刻镂。纯铁作。斧柯法者。得作四廉及八廉。锡杖法者。不得作好色枝。纯得作三四镮缠。以坚牢故。头圆形。油筒法者。用角竹胡芦贞木。不得作男女形状作状．隐囊．覆地．脚巾．经行．机囊．扫帚．粪箕．染盆．漉水器．磨脚．瓦石澡洗．板钵支．三杖钵支．钵盖．多罗叶．扇。如是诸物。得作倒巨刻镂诸变。房及房户扇窗牖。得用七宝作。水精亦得。一切房中施案。无所禁阂。唯除难房。问曰。何谓为难房。答曰。有势力王。于他戒场立作故。名难房。应向住者言。莫于此作房。若苟执不从。重向言。莫于此作。我等作布萨自恣时即妨碍。纵使竖者。房亦不得安立。如是故作不止语至三。犹不应。若众多比丘有惭愧者。剔坏此房。唯置佛殿及菩提树坏已勿用。次第举置。遣送与住比丘。余草使取。若取者善。不取草烂坏。或为恶人所烧。坏者无罪。住比丘不得责草直。如是已破檀尼迦屋。檀尼迦复念欲更作。往至守材人者。檀尼迦觅材周遍不得。是故往到城守材人所。主材者言。此是王物。修护国者。城里有所坏败。急难防豫。或为火烧。或敌国来攻。或应拟以作诸战具。种种资用修储。是故藏举此材。段段余者。檀尼迦自用。便斫断段段恣意用。或头或尾。婆娑迦罗者。是婆罗门名也。摩竭国臣者。于国统领国事财富无量。经历者。此大臣从国出按行城中诸材木。婆那者。是大臣豪贵。唤小者。为婆那。令人缚者。此婆罗门往白王。审实有与檀尼迦材不。将至王所。王答不与。是故大臣而缚。是时檀尼迦。见守材人已被缚。见已生狐疑心。彼人当为我取材故。而被王缚。我当自往救其令脱。是以日夜参承。何以故。守材人遣信。至檀尼迦所。大德及未杀我。愿速来分解。若杀已方来。于我无益。初拜为王。而作是言。若沙门婆罗门。草木及水随意取用。此是王自语。王忆识不。尔时王初登位打鼓宣令。若沙门婆罗门草木及水随意取用。是故我取王材。王答。我先语为诸沙门婆罗门有惭愧语。不为如汝无惭愧者。如此语者。令取阿兰若处无主物。不说有主物。为毛得脱者。所以出家着袈裟如毛也。何以故。譬如世有智慧人。欲多啖羊肉。无方从得。而作方便买取。好大有毛羊系门外。而题羊头令杀之。众人见已。贪其毛故。而倍易之。羊遂得活。檀尼迦比丘亦复如是。有袈裟故。得脱罪也。诸人呵责于王前。呵责檀尼迦比丘。呵责者。言汝非沙门。恶眼视之。说其所作赞叹。令人知非沙门法。非释种子。作梵行者无上行也。四句已下。有一旧臣。知王旧法出家为道。于是世尊。即问旧臣比丘。法师问曰。佛是一切智。过去未来诸佛结戒。罪相轻重世尊悉知。何以故。方问旧臣比丘。所以佛问旧臣比丘者。若不与旧臣比丘共论已一钱结波罗夷罪。为世人讥嫌。比丘持戒功德无量。犹如虚空。亦如大地。不可度量。云何佛已一钱故。而结重罪也。佛以智慧筹量。令禁戒久住。令人信受。是故宜与旧臣筹量。白衣法者。若偷一分。若杀若缚若摈出。佛云何不毁出家。出家人乃至草叶不得取。所以佛用智慧筹量。而制禁戒。不生讥嫌。是故佛与旧臣比丘。依因世法而结禁戒。观众者。见旧臣比丘去佛不远。而问此比丘。瓶沙王法。盗至几直而缚摈杀。摩竭国者。国名也。斯尼喻者。人象车马悉具。谓名斯尼喻也。瓶沙者。王名。摈者。徙置余国。法师曰。次句易解。五摩娑迦一分者。尔时王舍城二十摩娑迦。成一迦利沙槃分。迦利沙槃为四分。一分是五摩裟迦。汝等自当知。此迦利沙槃者。乃是古时法。迦利沙槃非今时。留陀罗王为初。迦利沙槃。过去诸佛亦以一分结波罗夷。当来诸佛亦以一分结波罗夷。一切诸佛波罗夷罪无异结。四波罗夷不增不减。是故佛呵责檀尼迦比丘。以一分故。结第二波罗夷。如律本所说。不与取名盗为初。以断根本故。结第二波罗夷竟。次随结浣濯。更起已说根本。如是佛为诸比丘已结戒竟。此第二随结。亦如前结无异。汝等自当知。若今重说文句成烦。若难者至当解说。至浣濯处者。浣白[疊*毛]已曝晒此处故。名浣濯处。浣濯衣人者。是浣濯人白[疊*毛]。诸浣濯人晡时。缚束白[疊*毛]欲还入城。匆匆乱闹不见。是时六群比丘因闹故。以盗心取一束。聚落者。或聚落或阿兰若处。律中已说。我今更分别演说。聚落者。一家一屋如摩罗村。此是一屋亦名聚落。以此汝自当知。无人者。夜叉所住处。或人暂避因缘后更还住。有篱者。塼为初。乃至下以草木作。依[牛*秦]牛住者。随牛处处住。或一屋或二三屋。亦名聚落。估客住者。步担估客车行估客。亦名聚落。城邑及村。亦名聚落。聚落界者。为欲明阿兰若界。门闑住者。若聚落如阿[少/兔]罗陀国有二门闑。于内门闑以外悉是阿兰若处。若无门闑可当门闑处。亦名为门闑。此是阿毗昙阿兰若法。中人者。不健不羸。掷石者。尽力掷也。至石所落处。不取石势转处。若聚落无篱者。住屋檐水所落处掷石也。又法师解。老妪在户里。掷粪箕及舂杵所及处立。在此掷石所及处。又法师解。若屋无篱。于屋两头作栏。当栏中央。掷石所及处以还。是名屋界。问曰。若本聚落广大。今则狭小。齐何以为界。答曰。取有人住屋漏所落处。中人掷石所及处以还。是聚落界。阿兰若界者。从门闑以外五百弓。名为下品阿兰若。法师曰。此义我已分别说竟。屋界聚落聚落界。为断恶比丘故。说此五种。于此五处有主物。盗心取一分。波罗夷。不与取者。他物若衣若食。他不以身口与。而自取一分。或从手取。或从处取。不舍者。主心不舍。若空地亦名不舍。取此物者。是名盗也。盗者。是诸罪也。法师曰。我以法中不取文字。但取其义。言盗者。夺将举断步离本处相要。问曰。何谓为夺。若比丘夺人园林。共诤时得突吉罗。令园主狐疑。得偷兰遮罪。若园主作决定失心。比丘得波罗夷罪。问曰。何谓为将。若比丘将人物以头戴之。以偷心摩触。得突吉罗。若以手摇动。得偷兰遮罪。若下置肩上。得波罗夷罪。问曰。何谓为举。答曰。若比丘受人寄物举置藏。其主还就比丘取。比丘答言。我不受汝寄。作是言已。得突吉罗罪。令物主狐疑。得偷兰遮罪。物主言。我不得此物。比丘得波罗夷。问曰。何谓为断步。答曰。若比丘欲偷物。及人将物去。初举一步。得偷兰遮罪。第二步得波罗夷罪。问曰。何谓离本处。答曰。若人举物在地上。此比丘以盗心摩触。得突吉罗。动摇者得偷兰遮。若离本处。得波罗夷罪。问曰。何谓为要。答曰。若比丘自要言。我至某处某处。我便将此物去。若至某处取物。一脚在界内。一脚在界外。偷兰遮。若两脚俱出界外。波罗夷。若关税处。将物过不输税。若过税处一脚在税内偷兰遮。若两脚俱出税外波罗夷。法师曰。此是论杂物也。若以一物论者。若奴有主或畜生。如是为初。若夺若将举。若断步。若离本处。若要处过。此是一种物。以此六句若分别说。成五五二十五句。汝当应知。如是说第二波罗夷。极为善说。何以故。为难知故。如律本初说。以五法偷。然后得波罗夷。物以有主为初。是为五种。法师曰。如是说枝叶已。汝当取一事。有五种亦有六种。若尔者不成五五。答曰。不然。何以故。若处一句取人物有五种。汝自当知。诸旧法师说。此第二波罗夷事相难解。是故不得不曲碎解释。是故我今说此二十五句。汝当善观察。问曰。何谓为五。一者种种物五。二者一种物五。三者自手五。四者初方便五。五者盗取五。问曰。种种五及一种五。此二法亦得夺将举离本处。此初已说。汝自当知要处足之。是名为六也。要处掷处此法俱等。是故第三句。五中亦得种种物五。一种物五已说。何谓自手五。答曰。自手取有五种。一者自手取。二者教。三者掷。四者能取。五者舍心。问曰。何谓自手取。他物以手自偷取。是名自手。教者。若比丘教他人。汝取某甲物。是名教也。掷者。若住在关税内。而掷出外。重物者得波罗夷罪。以此句故。与要处俱等。能取者。教人若某甲物汝能取者取。不能得且止。此人即随教而去。若偷得此物。教者遣去。得波罗夷罪。若去者随时而取。是名能取。舍心者。于物处置心舍。此心是名舍心。何谓初方便五。一者初方便。二者随方便。三者结方便。四者要作。五者记识。教人故。是初方便。汝等自当知。因离本处故。是名随方便。余三者。依律本所说。何谓为盗取五种。一者盗取。二者略取。三者要取。四者覆藏取。五者下筹取。是名为五。有一比丘。为众僧分袈裟。盗心转易他筹而取袈裟。于转筹处我当自说。是名盗取五种。如是五五。合已成二十五。汝等自知。于五五中。智慧律师。若诤事起。莫速判此事。先观五处然后判断。如往昔偈言

  若说往昔事　　时宜用为五
  于五处观已　　智慧应当知

处者。若我欲取此物。语已已得罪。应观此物有主与无主。应观若有主舍心不舍物。主应自善见。若未舍心者而偷。应且计律罪。若已舍心得波罗夷。更还物主。此是法用。法师曰。我今出根本。往昔婆帝耶王时。供养大塔。有比丘从南方来。此比丘有七肘黄衣。置在肩上。此比丘入寺作礼。是时王与大众入寺。驱逐诸人。诸人众多摒叠一边。大众乱闹更相荡突。遂失衣不见而出。比丘作是念。大众乱错如此。我衣失不可得也。作舍心已。后有比丘来。见此衣作盗心取。取已而生悔心。我非沙门失我戒也。我今还俗往至律师所。问已然后我知。是时律师。名周罗须摩那。善解律相。诸律师中最为第一。犯罪比丘往至律师所。头顶礼足以事具白。我今云何得罪与不。律师知已大众法后比丘取衣。律师知此比丘罪可救。向罪比丘言。汝能得物主来不。若能得物主。我当安置汝。罪比丘答言。我今云何能得。律师言。汝但去处处唤问。罪比丘入五大寺寻觅不得。更还问律师。律师复言。何方有多众比丘来此。答言。南方来多。汝先取衣度量长大。目色度量竟。汝更去次第寺寺入而问。罪比丘受教已依敕而去。逢见物主。将至律师所。律师即问物主比丘。长老。此是汝衣不。答言是。大德。问何处失。比丘依事答。律师问。汝舍心不。答言。已作舍心。又问罪比丘。汝何处取。答言。我某时某处取。律师言。若汝无盗心取者便无罪。汝恶心作取得突吉罗。汝先当忏悔。然后无罪。语物主比丘。汝以舍心。以衣与此比丘。答言善。罪比丘闻律师语已。如人得甘露味。身心欢喜。法师曰。如是名为观处。时者。取时。此衣有时轻有时重。若取轻即以轻时价直得罪。若重时即以重时价应得罪。法师曰。此语难解。我今取人为证。于海中间有一比丘。得椰子槃端正具足。得已而刻。刻作如蠡槃无异。令人心恋。此比丘常以饮水。以椰子槃置海中间寺。比丘往支帝耶山。是时有一比丘。往海中间。到已入寺。即住寺而见椰壳槃。以盗心取已。复往支帝耶山。到已用槃食粥。椰子槃主比丘见而问。咄长老。从何处得此椰子槃也。此比丘而答。我从海中间得。物主比丘而言。此非汝物。是我许。汝偷取也。即捉到僧前具判此事。无人能判。复往至大寺。于大寺即鸣鼓。近塔集众已。诸律师共判此事未竟。是时众中有一阿毗昙师比丘。名瞿檀多。极知方便。大德瞿檀多而作是言。此比丘于何处取椰子壳槃。答云。我于海中间取。彼价直几。答言。彼土啖此椰子。余壳弃破。或然作薪。都无价直。问物主比丘。手执作此椰子堪几直。答曰。此椰子人已啖肉饮汁弃皮。比丘拾取削治作器。此堪一摩娑迦。大德瞿檀多言。若如是者。不满五摩娑迦。不犯重罪。是时众中闻此语。即叹言。善哉。殊能判此事。是时婆帝耶王。欲入寺礼拜。从城门出闻诸比丘叹言善哉。王闻已问傍臣。此是何声。臣即次第而答。王闻已便大欢喜。王即打鼓宣令。自今以后一切出家人。于事有疑。悉就瞿檀多判。此大德判事不违戒律。法师曰。如是观看随处结直。有物新贵后贱。问曰。何谓新贵后贱。答曰。如新铁钵。完净无穿初贵。后穿破便贱。是故随时评直。所用物者。随身用之。如刀斧。初贵后贱。法师曰。若比丘偷他人斧。应问斧主。君买斧几直。大德。我用一分买。又问。汝买来已用未。斧主答曰。我始用一日破杨枝。或言。破樵烧钵已曾经用。便成故物。如眼药杵。亦如户钥。以稻糠。一烧再烧。或以瓦屑磨。亦名为故。又如浴衣。或一过入水。或叠肩上。或用裹头。或用裹沙。亦名为故。酥油或易器。或虫蚁落中亦名为故。或石蜜初强后软乃至手爪掏入。亦名为故。若比丘凡是偷他物。应问物主。若未用贵。已用者贱。汝等应知。此是五处。律师善观然后判事。随罪轻重而以罪之。夺取品竟

善见律毗婆沙卷第八若以一物论者奴有主。或畜生。如此为初。若夺。若将举。若断步。若离本处。若要处过。此是一种物。以此六句若分别说。成五五二十五句。汝当应知。如是说第二波罗夷。极为善说。何以故。为难知故。如律本初说。以五法偷。然后得波罗夷罪。物以有主为初。是为五种。法师曰。如是说枝叶已。汝当取一事。有五种亦有六种。若尔者不成五五。答曰。不然。何以故。若处一句取人物有五种。汝自当知。诸旧法师说此第二波罗夷事相难解。是故不得不曲碎解释。是故我今说此二十五句。汝当善观察。问曰。何谓为五。一者种种物五。二者一种物五。三者自手五。四者初方便五。五者盗取五。问曰。种种五及一种五。此二法亦得夺将举离本处。此初已说。汝自当知。要处足之是名为六也。要处掷处此法俱等。是故第三句五中亦得种种物五。一种物五已说。何谓自手五。答曰。自手取有五种。一者自手取。二者教。三者掷。四者能取。五者舍心。问曰。何谓自手取。他物以手自偷取。是名自手。教者若比丘教他人。汝取某甲物。是名教也。掷者若住在关税内。而掷出外重物者。得波罗夷罪。以此句故。与要处俱等。能取者教人若某甲物。汝能取者取。不能得且止。此人即随教而去。若偷得此物教者遣去得波罗夷罪。若去者随时而取。是名能取。舍心者于物处置心舍。此心是名舍心。何谓初方便五。一者初方便。二者随方便。三者结方便。四者要作。五者记识。教人故是初方便。汝等自当知。因离本处故。是名随方便。余三者依律本所说。何者尽力掷也。至右所落处。不取石势转处。若聚落无篱者。住屋栏水所落处掷石也。又法师解。老妪在户里掷粪箕及舂杵所及处立在此掷石所及处。又法师解。若屋无篱。于屋两头作栏。当栏中央掷石所及处以还。是名屋界。问曰。若本聚落广大今则狭小。齐何以为界。答曰。聚有人住屋漏所落处中人掷石所及处以还。是聚落界。阿兰若界者。从门闑以外五百弓。名为下品阿兰若。法师曰。此义我以分别说竟。屋界聚落聚落界为断恶比丘故说此五种。于此五处有主物。盗心取一分波罗夷。不与取者。他物若衣若食。他不以身口与而自取一分。或从手取。或从处取。不舍者。主心不舍若空地。亦名不舍。取此物者是名盗也。盗者是朱罗也。法师曰。我以法中不取文字。但取其义。言盗者。夺将举断步离本处相要。问曰。何谓为夺。若比丘夺人园林共诤时。得突吉罗罪。令园主狐疑。得偷兰遮罪。若园主作决定失心。比丘得波罗夷罪。问曰。何谓为将。若比丘将人物以头戴之。以偷心摩触。得突吉罗罪。若以手摇动。得偷兰遮罪。若下置肩上。得波罗夷罪。问曰。何为举。答曰。若比丘受人寄物举置藏。其主还就比丘取。比丘答言。我不受汝寄。作是言已。得突吉罗罪。令物主狐疑。得偷兰遮罪。物主言我不得此物。比丘得波罗夷罪。问曰。何谓无断步。答曰。若比丘欲偷物。及人将物去。初举一步得偷兰遮罪。第二步得波罗夷罪。问曰。何谓离本处。答曰。若人举物在地上。此比丘以盗心摩触。得突吉罗罪。动摇者得偷兰遮罪。若离本处。得波罗夷罪。问曰。何谓为要。答曰。若比丘自要言。我至某处某处。我便将此物去。若至某处取物。一脚在界内一脚在界外。偷兰遮。若两脚俱出界外。波罗夷。若关税处将物过不输税。若过税处一脚在税内。偷兰遮。若两脚俱出税外。波罗夷。法师曰。此是论杂物者教。三者掷。四者能取。五者舍心。问曰。何谓自手取。他物以手自偷取。是名自手。教者若比丘教他人汝取某甲物。是名教也。掷者若住在关税内。而掷出外重物者。得波罗夷罪。以此句故与要处俱等。能取者。教人若某甲物汝能取者。取不能得且止。此人即随教而去。若偷得此物。教者遣去得波罗夷。不舍者主心不舍若空地。亦名不舍。取此物者是名盗也。盗者是朱罗也。法师曰。我以法中不取文字但取其义。言盗者夺将举断步离本处相要。问曰。何谓为夺。若比丘夺人园林共诤时。得突吉罗罪。令园主狐疑得偷兰遮罪。若园主作决定失心。比丘得波罗夷罪。问曰。何谓为将。若比丘将人物以头戴之。以偷心摩触。得突吉罗罪。若以手摇动。得偷兰遮罪。若下置肩上。得波罗夷罪。问曰。何谓为举。答曰。若比丘受人寄物举置藏。其主还就比丘取。比丘答言我不受汝寄。作是言已。得突吉罗罪。令物主狐疑。得偷兰遮罪。物主言我不得此物。比丘得波罗夷罪。问曰。何谓为断步。答曰。若比丘欲偷物及人将物去。初举一步得偷兰遮罪。第二步得波罗夷罪。问曰。何谓离本处。答曰。若人举物在地上。此比丘以盗心摩触。得突吉罗罪。动摇者得偷兰遮罪。若离本处得波罗夷罪。问曰。何谓为要。答曰。若比丘自要言。我至某处某处我便将此物去。若至某处取物。一脚在界内一脚在界外。偷兰遮。若两脚俱出界外。波罗夷。若关税处将物过不输税。若过税处一脚在税内。偷兰遮。若两脚俱出税外。波罗夷。法师曰。此是论杂物善见律毗婆沙卷第九

        箫齐外国三藏僧伽跋陀罗译

过要处者。攀诸文句随其形相。于盗戒中次第分别。随色名色者。随其处所也。名者。随其名号。或一分或直一分或过一分。如是为名。何以故。一讫利沙盘分为四分。此是现不净物。一分直者。此是现净物也。过一分者。或净物过一分。或不净物过一分。此是应足第二波罗夷。地主者。主四天下如转轮圣王。或一天下如阿育王。亦如师子王。一处有如瓶沙王波斯匿王。一边者。一边地王。中间者。领一村二村。亦名为王。典法者。典知王法随罪轻重。若杀若截鼻若截手足。或大臣若太子或边地王。悉皆得治。是名为王。杀者。断命也。或鞭杖。摈者。遣出余国。贼者。偷人物或少或多。皆名为贼。如是为初得罪。法师曰。后次第句易可解耳。夺取为初。有六句此说竟。若一分若直一分若过一分。现其所取。问曰。取一分已犯罪。何须云一分直若过一分。答曰。为遮未来世恶比丘故。作此广解。地中地上物者。地中物者。藏置地中。此是律本中解也。法师曰。此文句难解。今欲广说之。藏者。掘地以土而覆上。或石草木。如是为初。是名地藏。若比丘言。我欲偷地中藏物去时。一切方便。悉得突吉罗。问曰。云何方便。答曰。临欲去时。着衣运动至中路。作是念。此物巨大。我不能独取。我今更觅伴。如是进止皆突吉罗。若至伴所语言。某处有宝藏。我今共长老取。答善即起。得突吉罗。说言。某处有大堈珍宝。今与长老共偷取。若得共营功德用。因此故。我与长老无所乏少。如是悉得突吉罗。得伴已而求利钁。若自有利钁往取用。若无利钁。或至他比丘处。或至白衣家借。主问。持钁何所用。答言。小小用。得突吉罗。若故妄语须钁还寺用掘地。得波夜提。又一家解。不然悉得突吉罗。何以故。是偷方便故。法师曰。故妄语得波夜提。此解善。若钁无柄。为求柄故。斫死木突吉罗。斫生树得波夜提罪。又一家解。斫生树得突吉罗。何以故。为偷方便故。若欲借钁。恐他人知。欲自作钁掘地。觅铁伤地杀草。悉波夜提突吉罗。又一解。悉得突吉罗。何以故。是偷方便故。若无篮入林斫竹及藤作篮。得波夜提。如前所说。或作得想。以此物供养三宝斋讲设会。如是言去时无罪。若作偷心去时得突吉罗。若欲至藏处。更斫草木为路。得波夜提罪。若斫死木突吉罗。于中生者。问曰。何谓为于中生。答曰。藏物既久上生草木。名于中生。若斫伐此草木得突吉罗。法师曰。有八种突吉罗罪。问曰。何谓为八。一者方便突吉罗。二者共相突吉罗。三者重物突吉罗。四者非钱突吉罗。五者毗尼突吉罗。六者知突吉罗。七者白突吉罗。八者闻突吉罗。问曰。何谓为方便突吉罗。答曰。如偷人觅伴及刀斧钁随其方便。是名方便突吉罗。若波夜提处得波夜提罪。若突吉罗处得突吉罗。共相突吉罗者。若草木于宝藏上生。以刀斧伐之。是名共相突吉罗。此中波夜提突吉罗。波夜提罪悉成突吉罗。何以故。方便偷故。不应捉物者。十种宝七种谷种种器仗。若捉者得突吉罗。是名不应捉物。得突吉罗。非钱者。一切甘果甘蕉子椰子为初。若捉者得突吉罗。是名非钱突吉罗。毗尼者。若比丘入聚落乞食。坌尘入钵中。不更受而受饮食。受者得突吉罗。是名毗尼突吉罗。知突吉罗者。闻人唱已。知而不出罪。得突吉罗。是名知突吉罗。白者。若于十白中。以一白得突吉罗。是名白突吉罗。闻者。佛语诸比丘。前亦未现灭。得突吉罗。是名闻突吉罗。此闻共相突吉罗。何以故。如律本所说。若草木于宝藏上生若斫伐者得突吉罗。若正斫伐草木时。而生悔心。即还复本心。因斫伐故得突吉罗。能忏悔者得脱。若无惭愧心。能尽力掘土觅宝藏处。亦得突吉罗。一边聚者。死土并聚一边。得突吉罗。前突吉罗灭。若以手磨宝未动。悉得突吉罗。前聚土突吉罗灭摇者得偷兰遮。法师曰。突吉罗偷兰遮。此罪其义云何。突吉罗者。不用佛语。突者恶。吉罗者。作恶作义也。于比丘行中不善。亦名突吉罗。律本中偈

  突吉罗罪者　　其义汝善听
  亦名是过失　　又名为蹉跎
  如世人作恶　　或隐或现前
  说是突吉罗　　汝等自当知

偷兰遮者。偷兰者大。遮者。言障善道后堕恶道。于一人前忏悔。诸罪中此罪最大。如律本中偈

  说偷兰遮罪　　其义汝谛听
  于一人前悔　　受忏者亦一

悔于一人前。此罪最为大。若摇动竟后更生悔心。而作偷兰遮忏悔得脱。问曰。十白突吉罗中。云何而得突吉罗。答曰。未羯磨前白竟不舍。得突吉罗。一白羯磨竟不舍。初羯磨竟不舍。随羯磨不舍。得偷兰。取离本处者。此比丘以盗心。移转余处乃至一发。得波罗夷罪。若偏举堈一边未犯都离者得波罗夷罪。若堈边竖三柱以绳悬缚。然后凿土四面及下土。尽得偷兰遮。若拔一柱二柱。亦偷兰遮。三柱俱去堈落地者。得波罗夷罪。以绳系堈着树。然后凿土担堈出。随绳长短未犯。若解绳离树。得波罗夷。若不解绳斫树断者。亦得波罗夷。堈上种树作志。根生缠裹堈。比丘掘土断树根。波夜提突吉罗。如前说。树根断堈随树起未犯。从树根挑取堈。离树如毛发许。得波罗夷。树倒堈出尘转离本处未犯。从彼离处波罗夷。堈上有石发石开堈。未犯重。得突吉罗。内器者。堈大不可移转。将器来取宝得一分。得波罗夷。若堈中有珠冠及金锁牵头出后未离堈。得偷兰遮。若截取一分得波罗夷。若满堈宝。以手搦取手未离处。指迸中一分出。还落堈中偷兰遮若出离堈得波罗夷。有法师解。堈坻取宝已。离堈坻未出堈口。得波罗夷。法师曰。于戒律中宜应从急。一饮得波罗夷者。一饮直一分得波罗夷。又一解分别各异。有大堈重脱不得举。以口就中饮。口未离堈得偷兰遮。若离者得波罗夷。若持竹筒饮入过颈一分。得波罗夷。若口含筒嗽取。口筒俱满便举。以手塞筒一头。以得离堈者。得波罗夷。若以衣掷堈中。吸取堈里酥油。衣以离手得波罗夷。又法师解不然。若以衣掷已。而生悔心未举。得偷兰遮。若心不悔者。举离堈得波罗夷。若掷已主觉责直。若还直得偷兰遮。若不还得波罗夷。若比丘自有空堈。外人来以酥油置堈里。比丘以嗔心。捉掷出余处不犯。若不嗔以盗心。取掷移余处。得波罗夷。若不移余处。便钻穿堈坻。令酥油一分漏出。得波罗夷。若钻酥油堈。当钻时酥油凝强不出。后得日炙。自然融出一分。得波罗夷。若钻孔大。酥油如胶出。相续不断出过一分。见已而生悔心。便更取还复堈里。得偷兰遮。若断一分在外波罗夷。若移堈置木石欲倒落处者。得波罗夷。主人若以空堈置平正处。未与酥油。拟与酥油。比丘知故。便以大木石支置堈。拟作破想。主人见比丘为此事故。若破时便责备直。若还好若不还得波罗夷。若比丘不作破想。而以种种死尸及大小便内堈里。初未着堈得突吉罗。若以着得偷兰遮。若着已主人见责备堈直。不还得波罗夷。若不作盗心。但以嗔恚心故。或打破或火烧或以水浇。种种方便令主人不得作生活者。得突吉罗。应还主直。若不还得波罗夷。若以沙土石与堈里。以水浇盈满出外者。堈不复堪用。应还主直。若不还得如前罪。法师曰。地下物今以广说竟。地上物今当说地上置物者。于地中或于殿上或山顶上。如是为初。若置是诸处不藏者。是名地上置物。或聚或散以器盛。法师曰。前已广明。此义今当总说。或以手搦取。汝自当知。酥油蜜乳酪如水流无异。汝自当知。物之轻重金锁珠贯及长白[疊*毛]。若移离本处如毛发。得波罗夷。此是地上品竟。虚空物者。孔雀为初。于孔雀中有六种处。何谓为六。一者孔雀口。二者尾。三者两翅。四者脚。五者背。六者冠。若比丘我欲盗取虚空中孔雀。孔雀欲飞。比丘当前立住。孔雀既见比丘不能得飞。舒翅而住。比丘得突吉罗。举手触之亦得突吉罗。若摇动孔雀者。亦得偷兰遮。若捉牵尾离头处。得波罗夷。傍牵左翅过右翅。得波罗夷。上下亦尔。若孔雀于空中下就比丘一一身分住。若在右手。比丘以盗心。回还左手离本处。得波罗夷。若自飞度不犯。以盗心将去初举一步。得偷兰遮。第二步竟得波罗夷。若孔雀在地。比丘盗心取他人孔雀。若捧孔雀一一身分。未离地得偷兰遮。若尽举身分悉离地者。得波罗夷罪。若孔雀在笼。若盗心偷孔雀。而合笼将去。随分多少得罪。若孔雀在园中食。以盗心驱出孔雀过门。得重罪。盗心捉孔雀掷园外。得波罗夷罪。若孔雀在聚落中。盗心驱出聚落界得波罗夷。若孔雀自游行。或至寺中或至空地。比丘以盗心。或持杖或捉石木掷孔雀。若孔雀惊怖飞向林中。或在屋上或还本处。未得罪。若盗心故驱。若离地一发。得波罗夷罪。如是一切诸鸟犯不犯。与孔雀无异。衣者。回风所吹上虚空中。比丘以盗心。捉一一衣分。得突吉罗。若捉衣动偷兰遮。离本处波罗夷。此衣与孔雀无异。若衣从虚空落地。比丘手捉取。得突吉罗。离本处犯重罪。堕落物者。诸人以宝物庄严其身。宝物堕落不自觉知。比丘遥见此物从虚空下。以盗心捉取此宝。离地一发得波罗夷。若袈裟堕落如前说无异。虚空中物广说竟。若床上置种种诸物。有可捉有不可捉。此事如地上诸物说无异。若合床将去离本处。汝自当知。若袈裟在衣架者。若比丘盗心。取架上袈裟。离本处得重罪。不关两头离本处亦得罪。荡至两头亦犯罪。合架将去得重罪。若袈裟结着衣架。荡着两头偷兰遮。解结将去波罗夷。若比丘以袈裟系四角作承尘。比丘盗心解一角乃至三角。悉得偷兰遮。若解四角波罗夷。若袈裟置架上。一头在架上。一头着地一头离架。未离地偷兰遮。一头离地未离架。亦偷兰遮。若离架离地波罗夷。若比丘以衣囊及诸杂物。悬置钩上。若比丘盗心。捧囊未离钩偷兰遮。出钩外得波罗夷罪。若比丘以衣囊置橛上。比丘盗心取离橛。未离壁偷兰遮。离壁未离橛亦偷兰遮。若离橛离壁波罗夷。又以衣囊及诸杂物置橛上。比丘盗心欲举取脱落肩上。若心悔还安橛上偷兰遮。若重起盗心将去波罗夷。若从橛举物重不能胜落地偷兰遮。若就地取将去波罗夷。问曰。以何为橛。答曰。长一肘锁头钉着壁。曲橛象牙橛一切诸橛亦复如是。若衣物在树上。比丘以盗心取。轻重如橛上广说。若衣在果树上。比丘盗心摇树取衣衣未落。比丘见果起盗心。若摇果落。直一分波罗夷。若衣果并不落偷兰遮。悬物品竟

水处者。安置水中。畏官为初。藏置水中物。于水中不败。铜器为初。水处者。池为初。若物置不流水中。物亦停住。若比丘以盗心水中觅物。于浅处觅。去时步步得突吉罗。若深处随作方便。得突吉罗。入水者。没头为初。若未至物处。或见毒蛇大鱼及鳄种种恶兽。见已怖走失无罪。法师曰。捉物为初。如前说无异。汝自当知。处者。捉物六处。四边及上下。是为六处。若池中者。莲华为初。若比丘以盗心取华。随直多少结罪。若折华时藕糸未断。亦波罗夷。若盗心取藕掘地。罪轻重如前说。若水上置种种杂物。比丘以盗心要期牵物。至某处某处当取。牵未离处偷兰遮。若举离水处一发波罗夷。若华束在水中渍。若盗心解束。偷兰遮。离束波罗夷。六处境界如前说。若盗心拔华。根未断尽偷兰遮。根断尽波罗夷。若池干无水。掘华四边断根偷兰遮。离本处随直多少结罪。若池中有鱼。鱼有主。一池水中是其处。若比丘以盗心钩取。或网取或安鱼笱。鱼未入突吉罗。鱼入者偷兰遮。若举鱼离水波罗夷。若鱼跳出网上岸偷兰遮。从岸上取离处。随直多少结罪。龟鳖亦如是。若比丘盗心欲取鱼。池大捉不能得。掘作小池引鱼令入。若鱼入小池突吉罗。若从小池取鱼捉不得。鱼还入大池偷兰遮。若鱼未至小池。亦偷兰遮。若从渎中及小池中取离处。随直多少结罪。若池水涸欲尽。鱼并聚一处。他与药鱼死。比丘不知。作粪扫取不犯。若知有主盗心取。随直多少结罪。若鱼主责直应还。不还犯罪。若鱼主取鱼竟无守护心。比丘以盗心取偷兰遮。法师曰。此罪轻重如前说。汝自当知。水品竟

船者。凡用渡江乃至用绳。此中凡能载物。尽名为船。于船中有人无人及诸杂物如前说。若比丘以盗心欲偷船覆。自念言。我欲取船无伴。我今觅伴去。捉摇如前说。解绳者。若解绳绳未离处突吉罗。绳离处偷兰遮波罗夷。法师曰。我今广说。若系船在急水。若断绳船未离处偷兰遮。若船离处波罗夷。若不流水中先离处后断绳。绳断波罗夷。若船在陆地离处波罗夷。若以两木支船。盗心去一木偷兰遮。去两木船落地波罗夷。若船在陆地。比丘以盗心。长索绞车牵离处偷兰遮。离处解绳波罗夷。若船在水不系。比丘以盗心上。意欲向东风吹向西偷兰遮。若起盗心随所至处取波罗夷。若悔心。为风所吹。更还本处。主索应还。若不还主波罗夷。船品竟

乘者。车为初。车贮杂物。有识无识如前说。若车贮谷。比丘以盗心用器碗取。器未离处偷兰遮。器离处者波罗夷。若车重不能牵。觅牛欲牵。初觅牛突吉罗。得牛牵车。牛举一脚偷兰遮。牛举四脚波罗夷。若意欲向南。牛向东西偷兰遮。若复还本路波罗夷。若悬车在壁。盗心取犯不犯。如悬钵囊无异。乘品竟

戴物者。以头戴之。法师曰。我欲释此义。头者。从咽喉后发际以上。是名为头。若诸杂物在上。悉名头戴。从咽喉发际以下。名之为肩。若腋以下腹以上。是名荷捉突吉罗。余如前受寄头戴物说。余肩腹境界亦如是。此次第句义。易可解耳。戴物品竟

园者。华园果园生诸香草。比丘以盗心掘取。随直多少结罪。若园中树皮盗心剥取。随直多少结罪。华果亦如是。若诤园林者。他园林比丘强诤夺。初欲诤时突吉罗。令园主狐疑偷兰遮。若园主作舍心。比丘波罗夷。若园主未作舍心。比丘取园。作决定得想。波罗夷。若言官行货诤园得胜。园主作失想。比丘波罗夷。若僧中判事。僧知故违理判者。判主得波罗夷。若僧中详依理判。诤者不如偷兰遮园品竟

寺中者。于寺中置诸杂物。有四处举物。如前所说。若房舍施与四方众僧。或大或小。若比丘欲诤取此房不成诤。无的主故不犯重罪。若檀越施一众乃至一人。若盗心取此房。主作失心。盗者作决定得想。犯不犯如前所说。寺品略说竟

田中者。有二种田何谓为二。一者富槃那田。二者阿波兰若田。问何谓为富槃那田。有七种谷粳米为初。何谓为阿波兰若田。豆为初。乃至甘蔗。若比丘盗心取谷。满一分犯重罪。若谷未收。比丘以盗心。觅镰觅担觅篮。种种方便得突吉罗。若以手揽捉得偷兰遮。若刈断与余生者相连着。未离本处得偷兰遮。若解脱相离。随直多少结罪。若盗心取稻作米前运动方便突吉罗。若刈稻打稻舂。随一一作得偷兰遮。若成米内器离地波罗夷。若比丘与他诤田。如前所说。若比丘偷他田地。乃至一发。大作决定盗心。得波罗夷。何以故。地深无贾故。若此比丘来问众僧。今取此地。僧答同者。皆得重罪。若有二标。若比丘举一标得偷兰遮。举二标波罗夷。若地有三标。若举一标突吉罗。举二标偷兰遮。若举三标得波罗夷。若地有多标举一标得突吉罗。乃至二标皆突吉罗。余后二标举一偷兰遮。举二波罗夷。若盗心以绳弹取他地。初一绳置一头偷兰遮。置绳两头波罗夷。若书地作名字。初书一头偷兰遮。书地两头波罗夷。若盗心唱言。齐是我地。田主闻已生狐疑心恐失我田。是比丘得偷兰遮罪。若田主作决定失想。得波罗夷。说田品竟

地者。宅地园地。有树无树有篱无篱。如华园品说亦如田品说。略说地品竟

聚落者。律中已广说竟。阿兰若者。是地有主。法师曰。亦有无主。云何有主无主。答曰。若草木在林中。无直不得取。是名有主。若草木在林。随意斫伐无人呵问是名无主。若比丘有主阿兰若物。随直多少结罪。有主阿兰若处。掷去不堪用物。取者无罪。若有主阿兰若。木柱及诸杂物。久久在中无人收拾。比丘借取用。后主来求相还。取者无罪。若比丘赍直。至有主阿兰若林中。语守林人。汝听我且取材木。取竟便还汝直。若守林人答言。若尔随意取。比丘便使人入林随意而取。取者无罪。若林主语守林人言。有比丘取者。汝莫取直。而守林人从索直。比丘应与。若守林人眠不觉。或余处行不在。比丘便入林中取木。后守林人还见从索直。比丘应与。若比丘入林取木竟。为贼虎所逐。恐怖未得还直。后应还直。若不还。随物多少结罪。若比丘入林中。不问守林人。以盗心辄取他物若过境界。随直多少结罪。阿兰若品竟

水者盛置在器及乏水时。是诸家中各各盛置大器。比丘以盗心。钻器觅钻及微少钻着。得突吉罗。若钻未彻得偷兰遮。钻彻得水随直多少结罪。若器小者。比丘倾器取。随直多少结罪。若器口大。以小器内中取者。如前偷油品所说。若他池水。比丘以盗心掘地决取。若水流出过一分。比丘得波罗夷罪。若比丘以方便。盗心掘他池边。垂彻而置。欲使他因此处破。及小儿破或牛践破。若水因此处出。比丘得波罗夷。若池中有大树。比丘为求水故。便斫树堕池中。树带浪起池边崩穴。水便流出。随多少直结罪。若比丘有二池。一池有水一池无水。各在他池两边。他池多水。比丘以盗心便掘穴已。有水池边通注他池。令水流溢。灌入己无水池。若损他池水随直多少结罪。若比丘田近他无水池。以方便心掘池通田。天雨水从池入田。池主来索水直。比丘应还。若不还随直多少结罪。若众家共有一池。分水注田。比丘以盗心。断取他水令注己田。若禾未死偷兰遮。若禾死。随直多少结罪。水品竟

杨枝者。如前园中所说。法师曰。若众僧雇人取杨枝。未还众僧。杨枝犹在某处。犹是雇者物。比丘以盗心前选择取。随直多少结罪。若众僧雇人典赏物。比丘先不白众僧以盗心取随物多少结罪。若众僧差沙弥次第十五日。为众僧取杨枝。沙弥择好者与师僧未及得分。比丘以盗心择取。随多少结罪。若杨枝已在僧常用处。取者无罪。取杨枝法。汝等应知。问曰。云何可知。答曰。若众僧日取三杨枝。亦随僧取三杨枝。若入禅室及听讲。并取五六杨枝。若尽已更取亦得。何以不并多取。而取五六。为人讥嫌故。杨枝品竟

树者。若阎浮庵罗树及胡椒藤。若以盗心以刀斫树及藤。树断皮犹相连偷兰遮断者波罗夷。藤断而犹在树波罗夷。若以盗心斫树过半而置。若树因此而折者。应计多少还直。不还犯罪。若以毒骨刺树杀亦如是。树品竟

展转偷者。若偷人取物。比丘以偷心夺取。物离偷人身分。若此人健。又于比丘夺得物还者。比丘虽不得物。亦得波罗夷罪。何以故。以决定得偷心离本处故。若此物主不置。比丘强牵取。未离手得偷兰遮。离手犯重。若以盗心脱人手钏镮。出手者波罗夷。犹在手者偷兰遮。脚亦如是。若盗剥取他衣。初捉衣突吉罗。牵衣动偷兰遮。离身波罗夷。若牵衣断随直多少结罪。若盗心偷人及身上衣若将去。初举一脚偷兰遮。举二脚波罗夷。若盗心又偷身及衣。人走突吉罗。人掷衣置地。比丘手捉亦突吉罗。若动衣偷兰遮。离本处波罗夷。若盗心偷身及衣。人走逐不及。比丘言。汝脱衣掷地置汝身若人以手初解衣突吉罗。衣解偷兰遮。衣离身分波罗夷若比丘盗心偷人及衣。人走解衣置地。比丘犹逐人不置。不及而反还。取衣离地波罗夷。若盗心偷人。人走荒怖脱衣掷去。比丘逐犹不置。不得人而还。见衣在地。比丘言。此人掷去衣。我当拾取不犯。偷人不得突吉罗。若人回头遥语比丘。莫取我衣。比丘若取衣离地波罗夷。若人以舍心掷衣走。比丘逐人既不得而还。见衣在地言。此衣我力所得。即便拾取突吉罗。又有一师解言。不得突吉罗。何以故。衣主以舍心故。展转偷品竟

受寄者。若人寄物在比丘处。物主来求比丘言。我不受汝寄。妄语应得波夜提。为是偷方便故。得突吉罗。若比丘念言。此人寄我物无人知。我今为还为不还得偷兰遮。若比丘决定心得。物主作失心。得波罗夷。若比丘言我恼之。彼若强诤者我还衣。不诤者我当取。物主以失心与比丘。取此衣者波罗夷。若受人寄物。物主来求。口还而心决定不还。物主作狐疑心。比丘得波罗夷。若受寄以盗心。移物置别处突吉罗。若以物易食尽。物主来问犹突吉罗。若物主还问不还物者波罗夷罪。若借用者无罪。若见他钵精好。合众钵并与上座处。若以盗心取已。粗钵与上座处。欲易取他好钵。以方便诱彼比丘。令过夜失眠。窃起至上座处言。我欲远行。取他钵相言。我钵钵囊如是相如是形。上座与钵。钵离本处。彼比丘得波罗夷。若上座已取钵竟。欲付盗比丘。上座言。汝是谁非时取钵。盗比丘闻上座语。惊怖而走。亦得波罗夷。上座以好心取钵无罪。若上座生心言。此比丘已走我盗取。此亦得波罗夷。若上座夜闇。自误取己钵与盗比丘。盗比丘得突吉罗。若上座误取盗比丘钵。还与盗比丘。盗比丘得突吉罗。上座无罪。复一比丘盗心礼上座言。我是病比丘与我钵来。上座言。此房无病比丘。汝当是偷。上座又先与同房比丘共诤。上座盗心。取共诤比丘钵与贼比丘。上座及盗比丘。俱得波罗夷。若上座以盗心取诤比丘钵。不得诤比丘钵。还得贼比丘钵。与贼比丘。上座得波罗夷。若上座以盗心。取共诤比丘钵。不得诤比丘钵。上座自还得己钵与贼比丘。上座及偷比丘。俱得突吉罗。若上座将物与年少捉言。我将汝至某处。年少比丘怀盗心。捉物逐上座至所在。年少比丘默舍。上座将物走。先一步得偷兰遮。二步得波罗夷。若上座将年少比丘。捉物入聚落乞食。年少比丘怀盗心言。捉物逐上座入聚落。念言。我至聚落。当去。未至聚落。步步突吉罗。一脚界外一脚界内偷兰遮。两脚入界波罗夷。若从聚落中起盗心出。犯亦如是。若上座使年少比丘。汝将此衣往彼聚落浣染。年少比丘起盗心将物去。步步回转物皆突吉罗。若过所期处波罗夷。若至聚落以衣易食或卖。未犯重。若还衣主问。衣在何处。比丘答。已易食尽。主责衣直应还。若不还波罗夷。若比丘以盗心强为上座浣衣。若上座授衣与盗比丘。衣离上座手。盗比丘得波罗夷。若盗比丘生心念言。将此物至聚落我当取。犯亦如是。若上座衣不净。以衣现相欲使人浣。年少比丘以盗心问。上座言。此衣欲浣。年少问言。何处浣。上座言。随长老所至处浣。若年少随所至处突吉罗。若用物者偷兰遮。若上座求衣不还者波罗夷。若上座以[疊*毛]寄檀越。年少比丘以盗心。诈往上座檀越家诳言。上座教我来取[疊*毛]。若寄夫夫与。寄夫妇与。寄妇夫与。随[疊*毛]入比丘手。一一波罗夷。若檀越语上座言。我欲请上座食并施白[疊*毛]一张。年少比丘知。往至檀越家语檀越。上座教我来且前请[疊*毛]食。至日当受。檀越即以[疊*毛]与之上座后知。从年少索[疊*毛]。若不还[疊*毛]波罗夷。若檀越请二比丘夏坐。夏坐竟施白[疊*毛]二张。一粗一细不现前与。后上座遣年少比丘。就檀越请[疊*毛]。檀越以[疊*毛]付年少比丘言。细者与上座。粗者与年少。年少将[疊*毛]还置一处。上座问言。何者与我。年少以盗心答言。上座粗者是。若上座取粗[疊*毛]。年少比丘得偷兰遮。年少取细[疊*毛]离本处波罗夷。若年少比丘以盗心书[疊*毛]作字。细者自作己名。后上座依名取[疊*毛]。年少比丘得偷兰遮。年少取[疊*毛]得波罗夷。若客比丘入寺。见旧比丘作袈裟。客比丘心念。此旧比丘故。当为我看此钵默置而去。后遂失此钵。客比丘不得责钵。何以故。不付嘱故。若付嘱旧比丘。不解客比丘语。客比丘谓旧比丘已受付嘱。后遂失此钵。客比丘亦不得责。何以故。由不了语故。若付嘱钵。旧比丘答言。善哉。若后失钵应责偿。何以故。为付嘱故。若知典钵库比丘。若出入诸比丘钵。忘不闭户。失诸比丘钵。应偿。若人穿壁偷不偿。若诸比丘语典钵比丘长老。晨朝出钵置外。我等遣人守护。守护人眠睡失钵。典钵比丘不须偿。若典钵比丘诸比丘付钵。懒开库而以钵置己私房。若失钵责偿。若典钵库比丘开钵库户。未得闭忽得卒病。不展转付嘱。失钵不偿。若典库比丘闭库而眠。有贼来唤开户。比丘不开。贼云。我得户开我杀汝。比丘亦不开。贼而以斧斫户。比丘念言。我若不开。复死复失钵。于是开户。贼悉将钵去。比丘不得责。若知钵库比丘。以钥匙与客比丘。客比丘遂开库。偷将钵去。知库比丘应偿钵。若上座向知钵库比丘言。我欲寄钵库主。共长老看钵。若开户不开失钵。二人共偿。若上座将人入库。知钵库比丘言。莫将人入。上座言。无所苦失钵。上座自偿。若知僧库藏比丘。众僧作大会出内杂物。一人不瞻若有所失。知库比丘不偿。若外利养入。知库比丘得受两分。若头陀比丘虽住寺中。不住僧房。不食众檀越。自为起房。众僧不得差作维那及知事使。若比丘若于读诵教化说法。能得利养利众僧。众僧不得差知僧事。有房舍衣钵。应先以好者与之。饮食果木得加分与。若比丘受用僧房舍衣钵。若慢藏失僧物。悉应偿。得差看佛供养具不得辞。有所失悉偿。失官税者。应输税者不输。以偷过官税。若初捉突吉罗。隐藏偷兰遮。不输过官税处波罗夷。若盗心掷落税外波罗夷落税内偷兰遮。若掷税外物还展转入税内波罗夷。又法师说偷兰遮。若有大木作桥。一头税界内。一头税界外。若以盗心将物从木上过。未度木偷兰遮。过木波罗夷。若二人共税。一人税界外。一人在税界内偷兰遮。二人悉出税界外波罗夷。若将牛马负物过官税处。比丘语受税人。随汝税取估直。受税人忘。牛遂自出税界外。比丘不犯。何以故。已语受税人故。若比丘将至官税处。一人欲税一人言置。比丘不输度不犯。若比丘物至官税处欲输税。受税人言。小小不须税比丘将物度无罪。若比丘将物至受税人处。受税人正蒱博戏。比丘三唤不应。比丘委去无罪。若比丘将物至官税处。卒有水火贼难。各惊走四出不受税。比丘委去不犯税界者。亦掷石所及处。若比丘将物不至税界过者不犯。法师曰。我欲现偷人无罪。云何无罪。答曰。无主人故无罪。若人儿落度。父母以水灌顶遣去。或父母死亡。比丘取如是人无罪。若负他人责。比丘将去无罪。家生或买得或破得。云何家生。家中奴婢生。云何买得。以物买得。云何破得。兴军破得。律本中说。若偷如是人得罪。初从捉突吉罗。若抱举一脚离地偷兰遮。若两脚离地波罗夷。若恐怖驱去初方便小罪。若举一脚偷兰遮。举两脚波罗夷。若他人奴。比丘语言。汝在此辛苦。何不叛去。若至他处可得适意。若奴闻比丘语已初发心欲去突吉罗。若初举一脚偷兰遮。举两脚波罗夷。若奴叛。有众多比丘语其道。催令驶去。随语比丘得重罪。若奴使走。比丘语言。汝如是走可脱。比丘无罪。若奴安徐去。比丘语言。汝如是宽行郎主当捉得汝。奴闻比丘语。即便驶去。比丘犯重罪。若奴叛走已至他国。比丘语言。汝可更余处去。汝主求逐汝。奴闻比丘语即叛去。比丘犯重罪。若比丘语言。汝此处辛苦某处极乐。奴闻比丘语即便叛去。比丘不教去无罪。有比丘作是言。某方极乐道路处处丰饶饮食。谁能逐去者。奴闻此语便自随比丘去。比丘即驱使此人。比丘无罪。若至半路虎狼贼难。比丘唤走无罪。偷人品竟

无足者蛇虺有主世人已蛇为技。若有观看。或与一钱乃至半钱。此人置蛇睡眠。比丘盗心将去随直多少结罪。蛇在函中。比丘盗心以虾蟆饵之。或手牵出离函。随直多少结罪。无足品竟

二足者。鬼人为初。唯鬼不可偷。三种鸟。一者毛翅。二者皮翅。三者骨翅。毛翅者。孔雀鸡为初。皮翅者。蝙蝠为初。骨翅者。蜂为初。比丘盗心。随直少多结罪。如前说无异。四足者。一切畜生象为初。若盗心大力能抱象离地波罗夷。若象在厩。或系腹或系颈或系四足。若解缚离本处。若不系驱出屋外。若在外驱出门。若在聚落驱出聚落界。若在阿兰若处。驱行离四足处。若眠驱起。随一一离处波罗夷。牛马驴骆驼一切四足亦如是。若半在栏以栏为界。解缚驱出如前所说若以草诱去随离处犯罪。若唤牛名。解语随出犯罪亦如前。若牛眠地杀。牛主责应还直。若不还犯重罪。四足品竟

多足众生者。百足蜈蚣蚰蜒。若一举脚九十九。偷兰遮。若举最后一脚。随直多少结罪。多足品竟

若为贼往他人家看物处所篱壁穿破处。还来语贼。贼闻比丘说。依事往取。随物离处。若众多比丘遣一比丘往。一切犯罪。若教一比丘看物处所。有比丘言。不须遣其去我自往看。此比丘犯罪。教者被教者无罪。众多比丘强将一比丘共偷得物。便驱此比丘守视。诸伴便觅物去。此守物比丘起盗心。物中好者便偷将举。随直多少结罪。众多比丘者。众多比丘作是言。我等共往某乡某处相与共偷。诸伴悉同而去。一人入取物。物离本处。悉得波罗夷。于问难中四人共偷。三人得罪一人得脱。我今问汝。汝当善思。答曰。有四比丘。一是师三是弟子。欲偷六摩娑迦。师语弟子言。汝人各偷一摩娑迦我偷三。第一弟子言。和尚偷三我偷一。汝二人各偷一。余二人展转相教亦如是。师自偷三钱偷兰遮。教三弟子偷亦偷兰遮。何以故。自偷异教人偷异。是故二偷兰。三人云何得重罪。为教他偷五摩娑迦故。是故得重罪。汝当善思者。于盗戒中。义理分别当善思。云何善思。一种物置一处。复一种多处多种置多处。此事汝当善识。云何一种物置一处。有一人以五摩娑迦置店肆中。众多比丘见。遣一比丘往取离本处。众多比丘悉得波罗夷。有一人五店。店安一摩娑迦。众多比丘遣一比丘往五处取。最后处得波罗夷。种种物置一处。诸杂物置一处。或直五摩娑迦。或直过五摩娑迦置一处。众多比丘遣一比丘取。此比丘举物离地。众多比丘得重罪种种物置多处。有五人各有一店。众多比丘遣一比丘取。最后离本处。众多比丘犯重罪。教品竟

相要者某时共去。或中前中后或夜。或今日或明日。或今年或明年。相要不绝时克不违。犯不犯如前所说。若不从教。教中前取而中后取。教初夜取而后夜取。教白月取而黑月取。教此年取而后年取。教者犯小罪。取者犯波罗夷。若时克相应。俱得罪。相要品竟。

善见律毗婆沙卷第九善见律毗婆沙卷第十

        箫齐外国三藏僧伽跋陀罗译

现相教取五者。眼现相为初。或眼现相。或手现相。或脚现相。或遥头现相。或动身现相。如是种种现相教偷。犯不犯如前所说教取此物而得此物。俱犯重。教取此物而得彼物。教者小罪。取者犯重。教语此人者。有众多比丘。一是师三是弟子。第一弟子名佛陀勒弃多。二名昙摩勒弃多。三名僧伽勒弃多。师行见他物起盗心。唤佛陀勒弃多语言。汝教昙摩勒弃多。教僧伽勒弃多。往取彼物。师教第一弟子时。师得突吉罗。昙摩勒弃多语。僧伽勒弃多受语时。师得偷兰遮。若往取物离本处。师及三弟子俱犯重。法师曰。非但四人犯罪。若百千人展转相教。罪亦如是。教他者。师教佛陀勒弃多。汝往语昙摩勒弃多。教昙摩勒弃多。语僧伽勒弃多。汝往取物。佛陀勒弃多。见昙摩勒弃多。不语或不见。自往语僧伽勒弃多。汝往取物。若物离本处。师得突吉罗。昙摩勒弃多无罪。第一第三犯重。已去还者。僧伽勒弃多。见人守视不得取。还报师。师语言。随便取莫置。师得突吉罗。后若得物。师及弟子俱犯重。若师教弟子取物决定得。如掷物虚空必定落地。师教竟得波罗夷。若师盗心教弟子已。或一年或二年或三年乃至六年。师或死或罢道。师不犯重。偷者得罪。教已乃至三年。弟子未得偷。弟子患耳聋。师不知聋。师生悔心语弟子言罢。弟子聋不闻语故。承先教往取离本处。师及聋弟子俱犯重。若弟子不聋。答言。善哉不取。师及弟子不犯重。得突吉罗。教取品竟

今当现盗戒有五事。是故律本所说。五事者。何谓为五。一者他物。二者他物想。三者重物。四者盗心。五者离本处。若一事二事不犯重。若具二事。偷兰遮突吉罗。六事者。非自想非亲厚想。非暂用想重物。盗心离本处。非他主者。非他守护。此物粪扫想无主想。自己想暂用想。非盗心无罪己想。于他物中生自己想。取离本处无罪。若物主责应还。若不还者犯重罪。亲厚想者。如律本所说。佛告诸比丘。有五事得取亲厚物。何谓为五。一者知识。二者同食。三者善语。四者生。五者取已欢喜。何谓为知识。一见而欢喜。是名知识。同食者极亲厚无所吝惜。是名亲厚。善语者。若我物。随汝意取不须复问。是名善语。生者。从今若未死。同用此物。取已欢喜。我取此物。物主闻之必当欢喜。是名五事。应知可取。亲厚取复有三事。一者生知识。取已欢喜。二者生同食。取已欢喜。三者语。取已欢喜。若亲厚生。取已欢喜。成亲厚取。若在家若出家。前取欢喜。后因事生悔心。虽悔不得夺取。复有知识。心不乐与。口不言与不与。取已物主后有所嫌。不得夺取。又有知识言。若汝有所须取食用。我若有所须就汝取。后因事相嫌。得夺取。借用者。用已当还主。如是用者。是名借用。若物主言。不须还。仍布施善。若不布施应还其物。众物僧物亦如是。饿鬼物者。四天王为初亦入其中。若比丘取诸鬼神物无罪。若天帝释若帝释立店贩卖。比丘天眼观知是帝释而取物。帝释吝惜还不还无罪。所以无罪。此是应化物故。若世间人以物系树。无人守护取者无罪。畜生物者。龙王迦楼罗为初。若其化作人形。如帝释所说无异。若师子若虎杀鹿及牛而食。比丘不得夺取。何以故。虎狼嗔心恐杀比丘。若食竟比丘驱去然后取。若得令净人炙食无罪。粪扫者。此是掷弃之物。作是念已取之无罪。若此物有主来求。比丘应还。若不还者犯重。颠狂者。律本广说。最初未制戒不犯。颠狂不犯。后者。六群比丘为初尽犯。法师曰。盗戒究竟发起从心。作世间罪恶业。不善者三受。汝等应当知。发起者。从身业意业发起。此是自取。教人取者。从意口业发起。自取教人。从身口意业。作者。以身作得。世间罪者。性罪。不善者。恶心作。受者。有三受苦乐不苦不乐。法师曰。悉前波罗夷已说。随结者。六群比丘为初。若易解者。律本中已说。句次难解者我当广说。凡人心恒缘于欲。未曾舍离。圣人若舍身口。以心结罪。无有得脱者。是以圣人制戒。要因身心。是故律本中说无罪者。起心不动身口。是名无罪。若起盗心。当自克责还复好心。触摇离本处。此易解耳。谁偷取。答言。我偷取。佛言比丘汝心云何。比丘答言。逐口语实无盗心。若尔无罪。鬼入者。此饿鬼见死尸有好衣。起贪心即入尸中。不受语者。此比丘闻饿鬼语。比丘莫取我好衣。比丘闻言亦不受语。起者。此饿鬼见比丘将衣去。起而追逐。闭户者。比丘寺近尸陀林。比丘性强不畏鬼神。是故入房反闭户倒地。此饿鬼见比丘闭户已言。我不得此衣。掷置死尸而去。是故律本所说。倒地未烂坏者。此是新死尸也。未烂坏死尸不听取衣。若取者突吉罗。若烂坏者取无罪。问曰。云何烂坏。答曰。鹫鸟为初。或脚瓜疮或口疮乃至小疮。如针头刺取者无罪。若皮未断者亦不听取。若此尸生时被疮或炙疮。随一一疮可取。若此尸膖胀烂臭可取。若此尸完全。比丘故取衣。语守护尸陀林人为我取。若无守护尸陀林人。语余人汝为我取善。若都无人者。比丘或以刀子刺作疮可取。若如此尸比丘得取。易筹者。众僧掷筹分衣。比丘以盗心易他好筹。犯不犯如前所说。若闇夜及昼日不见主盗取。此是小贼。若欺诳心治不中用物为好。或以假色易取人物对面欺人。此是大贼。若人自有力。王为初。若自有力。若依强势逼人取物。重秤大斗如前种种。皆入偷罪。誓者。有二。一者物誓。二者处誓。云何物誓。有比丘欲偷衣入房。若得此衣当取余物不取。是名誓物。云何誓处。若比丘取他物将去。自誓言。我至某处当取。是名誓处。易筹竟。法师曰。文句次解我不须广说。若寺舍空废无人。比丘来去见树有果。应打揵锤。若无揵锤下至三拍手。然后取食无罪。若不如是食犯盗。若聚落外有寺。贼难恶兽难。比丘走入聚落。有客比丘来入寺。见饮食及果。以盗心而食。随直多少结罪。次第句易解。取猪被系者。于阿兰若处。张罥绳取野猪。比丘以盗心解放他猪。随直多少结犯重。若以慈心解放无罪。应还直。若比丘有慈心。先以物准直系着绳。然后解放无罪。若此猪见比丘来。辄自突走绳断去无罪。若猪未至绳。比丘遥驱去无罪。若他狗啮野猪。比丘以慈心驱打狗放猪无罪。若主责直应还。若不还犯罪。野猪被罥三四日不得食。体羸不能动。比丘盗心以饮食与之。食罢体健。比丘作大叫声。猪闻之惊怖。牵罥突走。比丘犯重罪。若慈心作不犯。应还主直。比丘见野猪着罥。盗心割绳留少许不断。比丘作大叫声。猪闻惊怖突罥走去。如前所说。比丘见猪着罥起盗心。或安刀剑近绳。或绳边燃火。欲使猪牵绳突刀。或火烧猪脱走去。犯不犯如前所说。若人故掘地作坑。拟取猪鹿麈獐等众兽。若比丘盗心。坏坑及诸张具物过不得。比丘犯重。若众生不过无罪。若人近寺边安罥捕诸众生。比丘语此人。莫近寺安罥取猪鹿。若此人不从。比丘向地主言。若地主教坏不犯。若人作田为獐鹿所食。张罥防护。捕鹿得鹿便食肉。若守护竟主舍心。后坏若解不犯。法师曰。句次易解。若人安鱼笱捕鱼。若盗心开放。随直多少结罪。若先穿鱼笱作孔。打水惊鱼令出者犯。若不出者不犯如前。又盗心合鱼笱将去离水。随直多少犯。又饮食于笱外饵鱼。鱼见饮食突出。若主责应还直。若空鱼笱。比丘盗心若开若破。鱼从中往还。主责直应还。若比丘取鱼笱移掷他处。犯不犯亦如前说。偷阎浮子及酥油器。如前所说。若比丘盗心取酥未满一分。然后生悔心。后我不更作。至明更偷心。取不满一分。复悔心后誓不作。如是展转偷尽一器。不犯重。得突吉罗偷兰遮。又有比丘如是偷酥。日日止取一匙。而不舍心取满一分。便犯重。相要偷者。食堂有二种残食。次阎浮子如前所说。分庵罗果者。旧比丘见客比丘来。而不分果。客比丘语净人言。我等为得分与不。作是言已。客比丘便自打磬取果。便自分与旧比丘。及客俱得共食。是故律本所说。佛告诸比丘。自今已后若有饮食应分。分食无罪。自言。己寺旧比丘。若有果有客比丘来。应共分食无罪。若客比丘去后。旧比丘然后分食。是名朱罗。是故客比丘来。旧比丘应唱鸣磬。共客比丘食果。若不打磬。客比丘打磬食无罪。若旧比丘。有众僧园林有果树。拟四种用。客比丘不得辄打磬而食。亦不得取将去。若旧比丘有众僧园林。不肯守护。为偷人所取。若众僧俱共立制。不听僧食。此制不成。若能守护。此制则成。若檀越施众僧果树。或拟衣服或拟汤药。众僧不得分食。若檀越以果树为四事布施。比丘以盗心回分食。随直多少结罪。若檀越为作房舍施众僧。回食得偷兰遮。应还直。若为袈裟施。应当作袈裟。若饥俭时。众僧作白羯磨。为饮食难得。众僧三衣已足。今且回以食用。令众僧得安乐。若众僧和合食用无罪。若檀越为三衣施。若众僧无房舍。作白羯磨回以作房舍。众僧和合用无罪。若檀越布施重物作房舍。应作房舍。若饥俭时。众僧饮食难得。或病或值国土荒乱。比丘舍寺余方。寺舍果树无人主领。若如此者。重物得作食用。为护住处故。又寺中房舍多。无人修治败坏。应留好者。余粗败得坏卖为食用。为护住处故。若有檀越以四事布施。不得回以余用。若以此直雇人守护园林。令住园中然后得用。若比丘行来过此园。见椰子多罗树子。守者得自与众僧食。何以故。已令其守护故。又守护人众僧限分果与。应依限数取食。不得过长。若守者为众僧。贩货果蓏得净衣物与众僧者得。益与守视人果食者善。若檀越布施园。为华香灯供养塔像及修治僧房。得取少直赁人守园。若无果直者。得用佛物回赁人。若佛无物。得用众僧物赁令守住园中。若守者于园中贩货果蓏。如前所说。熟庵罗果者。佛语诸比丘。得受守护园人布施。法师曰。若守护善。若不守护不善。大德修摩那言。若守园人众僧日得供果。自有限应依限与者善。若过限不善。大德波头摩言。赁守园无券疏者。亦得任意与。众僧果多少得食。又言。若聚落童子为众僧守园。若童子与果者众僧得食。若童子便自取者。不得食众僧果或佛果。有人先下少直贉市园果。而即守护园若以果与众僧者得食。若众僧以果雇人守园者。守园人以己果分。得与众僧食。非己分不得与。又众僧众多果树。指以一树雇守园人。是其树限果者。得与比丘。不得取众僧果。与材木者。借用无罪。众僧材木。拟作说戒堂。或作食堂者。先白众僧然后借用得。若众僧材具露。无覆烂败。或雨湿曝露。得用作房。若后有众僧。责直及材具者。应依数还。又无直及材具备者。当作是言。众僧物随众僧取用。若作房阙无窗牖。借用众僧材木。足者此应备还。余材具亦如是。水者。若乏水时。有众僧自取水。若去半由旬一由旬二由旬。如是水贵时。又以偷心取水。随直多少结罪若取一器二器。以灌菩提树及澡洗。或作染汁者得。若众僧立制不听人取。又以盗心取或不得取。而以土掷内水中。随直多少结罪。若旧比丘制极重。不听余人浣濯煮染。旧比丘伺不见。余人自盗心用。客比丘若见旧比丘已用。即逐其用无罪。众僧有三池。僧立制不听杂用。一者饮池。二者浴池。三者杂用池。若如是者客比丘来。一一随顺旧比丘制。不得乱用。若不立制者随用。若处乏土。众僧运取土。若以盗心取一分。便犯重罪。若白众僧然后得用土。治护佛及众僧房竟。有须者先白众僧然后得用。若不白贷用亦得。石灰亦如是。茅草者。若人烧草茅不离本处。烧者得突吉罗。应还本直。若草茅田众僧守护。以覆房舍用。若众僧无人守护。有余比丘欲守护得。用茅草田故。是众僧田。又此比丘舍去。田被烧者。众僧亦不责。问曰。若此比丘就众僧乞分者与分。若已与分遣其守护。若此比丘求增直。众僧应与倍直。若众僧不用者。余人任意得用。何以故。为不用故。若众僧与茅草与根株。若众僧欲用语守者。不须复看众僧自看。床者为初。有七事易可解。石柱木柱一一柱。若比丘以盗心取。随直多少结罪者。禅房为初。众僧无人守护。墙壁崩倒。若有盗心取柱种种材具。盗心取柱种种材具。随直多少结罪。何以故。众僧物。或时有众僧。或时无众僧。若于深野中有贼起。众僧舍寺避去。亦如前说。若借用无罪。此比丘复移去。若死亡者应还众僧。寺中小小用事易解。若比丘借众僧床席毾[毯-炎+登]。若见客上座来应与。若此物失或坏败不偿。若有余处去还付众僧。若自用不与上座。失者应偿。若此比丘借余寺床席毾[毯-炎+登]者。欲去有比丘回借此用。当作是语。我今欲还彼寺床席。比丘言但置。我自送还。若失代借者偿。瞻波国中者。三新粥者。麻豆米粥。或与酥乳酪沙糖蜜。王舍城中者。糜豆瞿罗(汉言美羹)法师曰。次第易解耳。蔼寿迦者。易可解。波罗奈国贼所夺将去。此比丘以神通力观檀越家。见檀越儿为贼将去。比丘以神通力往取不犯。云何神通力。比丘以神力令小儿自见己屋而来入中。贼不见小儿及化屋。小儿得脱。法师曰。此二事易可解耳。律第二波罗夷广说竟。名为善见

  第三三净说　　诸佛善分别
  名为波罗夷　　今正当广说
  我等善心听

尔时佛住毗舍离大林中。于高阁讲堂中。毗舍离者。此是国名也。因女人相立为名。此城人民众多三过开广。法师曰。我今广说毗舍离根本因缘。往昔波罗奈国王王夫人怀妊。此夫人自知怀妊而白王言。王即供给侍养。皆使调适。期月已满即入产堂。若有福德之人。平旦时生。此夫人平旦时。生出肉一段。赤如木槿华。又余夫人生儿。色如金色。此夫人见傍夫人生儿端正微妙。而生羞耻心。而作是念。若王见诸夫人儿端正。而我生子唯一段肉。无有手足。王设见者必生恶贱。作是念。即取盛贮器中。打金作薄以朱砂书题。是波罗奈国王夫人所生。盖覆器头以王印印之。以金薄书置器外。送放江中使人弃已。诸鬼神营护。使无风浪漂没。尔时有一道士。依止牧牛人住于江边。此道士清朝往江边澡洗。遥见此器而念言。我当拾取。此器近已而取。又见金薄书字。复见有王印印之。便开器看。唯见有肉一段。而作是念。若是死肉久应烂臭。必有异相。即取将归住处。善举一处。过半月已而成二片。道士见如是瑞相。安置好处。自尔之后复经半月。二片各生五胞。又却后半月。一片成男一片成女。男色如黄金。女色如白银。道士见如是相已。心生爱重。如自子无异。以慈心力故。两手拇指自然出乳。一指饮男一指饮女。乳入子腹。譬如清水入摩尼珠。内外明彻。道士号儿。名为离车子(汉言皮薄亦言同皮)道士养此二子。极为辛苦。日入聚落乞食。兼为二子觅诸饮食。日晏方还。是时牧牛人。见道士为此二子辛苦如是。来白言。大德。出家人正应行道。何以为此二子妨废道业。可持乞我。我等为养活。道士言。善哉。于是牧牛人各还到。明日与诸同伴平治道路。竖立幢旛散杂色华。鸣鼓来迎二子到道士处。白道士言。今此二子时将去矣。道士答言善。道士复更付嘱。此二子者。有大福德不可度量。汝等善好料理。当以乳酪生熟酥五种而供养之。若此二子长大。还自共匹对。觅好平博处所安立住止。可拜男为王女为夫人。牧牛人等受教敕已。即将还本住处。二子渐渐长大。共诸牧牛人儿子出门游戏。此二子便以脚蹋牧牛儿。牧牛儿涕泣还向父母说。此无父母子蹋打我等。父母答言。汝等各自避去。因此戏处。名为跋阇(跋闇者汉言避也)二子年至十六。牧牛人见子已长。又见平博地处纵广一百由旬。即于中央起立宅舍。牧牛人以女嫁与男。立为夫妇。即拜男为王女为夫人。后怀妊一产二儿。一男一女。如是十六倒生儿。诸牧牛人见王子渐多。复各更为开立舍宅造诸园池。合三十二人宅舍。如是展转乃至三倒开广故。名为毗舍离。此是根本因缘也。大林中于高阁讲堂者。此林无人种自然而生。从迦惟罗卫国连至雪山。故名大林。高阁讲堂者。于大林作堂。堂形如雁子。一切具足。为佛作此堂也。种种方便赞叹不净观者。以种种因缘观身不净。云何不净。从头至足。头发指爪筋肉脓血屎尿[口*弟]唾。从七孔流出不净。此略说汝自当知。佛告诸比丘。此身一寻汝当善观。于一一身分中。无有真珠珊瑚摩尼等宝及牛头栴檀等香。唯有臭秽不净。发毛为初。观发有五种。一者色。二者形。三者气。四者长。五者住处。毛亦如是法师曰。我今略说已。在屈陀迦广说。如是于一一身分。悉有五种观。说不净者。如来以种种方便说不净。膖胀为初内外俱观。内者。自己身。外者。他身。如思念自利益故。是故如来赞叹有五种。失得有五种。有三善具足十相。名为得第一禅。因第一禅故。调心柔忍。而起毗婆毗婆舍那(汉言观苦空无我)因此观故。断诸烦恼得阿罗汉果。何因何缘为具足十相。一者心离烦恼怨家。二者入中三昧。三者心不摇动极清而放。四者已入静放。五者一心不越等法。六者合成一味。七者五根怡悦。八者精勤执境不置。九者增进。十者成就堪受。是故禅从中说。初禅何者为中何者为后。初入第一禅。极净为初。满舍为中。怡悦为后。又问。初禅极净者为初。净有几相。答曰。净有三相。何谓为三。一者从怨家得离心净。二者因净故而入。三者已入三昧而住。此是初禅极净三相。初禅满舍为中。中者有几相。答曰。中复有三相。一者心净而放。二者入静而住。三者一处而住。此是初禅满舍。为中三相。是后禅本中说中善。何谓为初禅怡悦。为断。断中几相。答曰。断有四相。一者不越同生法。二者合成一味五根怡悦。三者应足精勤生怡悦心。更足精勤怡悦。四者增进。此是初禅怡悦。为后四相。是故禅经中说后善。如是心至真。以三相十相具足。以思观喜乐具足。以志心至心忆念三昧智慧具足。指示赞叹入不净三昧者。如是更重思量分别不乱。是故如来殷勤赞叹说利者。所以赞其所利。云何为利。佛告诸比丘。若比丘数观不净。因观不净故。心得离淫欲舍淫欲憎淫欲。比丘。譬如鸡毛与筋近火燋缩不能得伸。比丘亦数观不净。见欲秽污心不乐近。佛语诸比丘。我乐入静半月独住。勿令余人来至我所。唯听一人送食。乐修福德者少于语言。如是比丘。乃听来往送食。余一切比丘及白衣。悉断不得入。何以故。如来作如是敕。以天眼观往昔。有五百猎师。共入阿兰若处杀诸群鹿。以此为业。五百猎师堕三恶道。于三恶道。受诸苦恼。经久得出。昔有微福得生人间。出家为道受具足戒。五百比丘宿殃未尽。于半月中更相杀害。复教他杀。如来见已此恶业至。诸佛所不能救。是故如来。因此半月入静室。于五百中。有凡人及须陀洹斯陀含阿那含阿罗汉道。此诸圣众生死有际。余凡人轮转无际。是故如来。为诸凡人说不净观。因不净观故。厌离爱欲。若其命终得生天上。若不离爱欲。死不生善处。佛自念。此五百比丘随我出家。因我故得生善处。是故我今当慈悲此等。为说不净观令生善处。本不教死。为诸比丘说已。复作是念。若比丘日日有死者。来白我言。今日有一比丘死。今日二比丘死。今日三比丘死。今日四比丘死。今日五比丘死。日日如此。乃至十比丘死。非可以我神力救护。彼我无益。是故我舍入静处。是故律本所说。佛告诸比丘。我乐入静处。是以不听余人入。唯听一人送食。如来欲息诸讥谤。勿使诸人作如是言。佛是一切智。而不能断诸声闻弟子相杀。岂能制余人。其中有人答言。佛入定。无人得往说如此事。是故不知。若佛知者。必当制断。不听相杀。羞者。观身秽污不净。而自羞耻贱薄。厌恶此身。如年少男女。年至十六性好净洁。庄严其身者。以香汤沐浴竟。复以香涂身。着上妙细[疊*毛]衣服。而以死蛇死狗。以系其颈。见此秽污不净。厌恶欲速弃舍之。比丘厌恶其身亦复如是。取刀自相杀者。各各相语。长老。卿为度我。答言。我为度汝。如是次第而共相杀。鹿杖沙门。鹿杖者。其名也。沙门者。作如沙门形。剃头留少周罗发。着坏色衣。一以覆身。一以置肩上。入寺依止比丘。拾取残食以自生活。诸比丘往至鹿杖沙门所。而作是言。善哉。殷勤汝为度我。如此语者。是凡人也。非圣人语。血流出者。血出污手足及刀。往婆裘摩河者。世间有人言。此河能洗除人罪。鹿杖沙门念言。我当往婆裘河洗除我罪。多狐疑者。诸比丘死已。皆悉右胁而卧。身亦不动无所言说。见如是已。心生大狐疑。悔过克责。我无善利而得恶利。无善利者。于我无安乐行。而长叹息无利无利。造作恶业者。鹿杖沙门自念言。人身难得。而我杀诸持戒具足比丘。于我极恶。有一魔神者。此是邪见地神。是魔王伴傥。而自念言。我作此言必合魔王意。以璎珞庄严其身。现变神通力。履水而行。往至鹿杖沙门所。而作是言。鹿杖沙门。汝所作大善。未度汝度者。于三界中。未度汝为度之。此是愚痴地神。作如是言。死者得度。鹿杖沙门极大懊恼。忽闻地神作如是言。而念。此神有大神力。作此语者。于我必当有利。作此念已。更洗刀入寺。房房唤觅。谁未度者我为度之。未得道者闻此语。而毛自竖惊怖心中震动。已得道者。观身无常苦空无我。而无惶怖。一日杀一比丘。有日或杀二三四五。如是增至杀五百比丘尽。从禅定起者。佛知五百比丘死已。而从禅定起。佛知而故问。如人不知。何以故。欲为说法故。而问阿难。先诸比丘极多。今何以减少。诸比丘日常三时问讯咨受问法。今者都无。余国去耶。时阿难不知五百比丘宿业果报。唯见观不净故各自杀身如是。时尊者阿难答已。而作是言。善哉世尊。愿易余观令得罗汉。譬如大海多诸川流。佛法亦尔。多诸方便。十念十极四大梵观。如是为初令入涅槃。惟愿世尊。以此方便教诸比丘。是时世尊。欲为诸比丘更说余观。而唤阿难。如是为初。依止毗舍离者。诸比丘于毗舍离中住。或一伽浮陀。或半由旬。或一由旬。令一切比丘皆悉来集讲堂。阿难若近处即自往唤。若远处者。遣年少比丘往唤。须臾之间悉集讲堂。阿难往白佛。时可为诸比丘教授说法。佛知已。于是佛告诸比丘。我前所说观不净者。令得罗汉。今以余方便更为汝等说。是故律本所说。阿那波那念者。佛为比丘说无上禅法。次第文句我今当说。无有漏失。汝当勤心谛听受之。今此比丘者。佛告诸比丘。不但观不净行得除烦恼。今阿那波那亦得除烦恼。法师曰。今广说次第。阿那波那者。入息出息。如经文所说。入息相非出息相。出息相非入息相。念入息念出息念出入息故。便得定心。阿那波那念则是三昧。如是义汝自当知。数观者。将养令大。更作者。已思更思。极静好者。此二法其义云何。答曰。此阿那波那不同不净。其心不乱。不净观者其心恒乱。何以故。为厌故。律本所说。极静妙不假更足安乐不止。从初发心无有恼乱。是故如来赞为静好极。有气味时身心怡悦。易可入耳。起者。不住不覆。恶法须臾消灭。于四道果随其所能。譬如春中半月不雨。象马人牛践蹋尘起满虚空中。夏初五月疾风暴雨。尘灭消除无复遗余。阿那波那除烦恼。如雨淹尘。佛告诸比丘。阿那波那念三昧者。云何思云何念云何作。知之阿那波那念。诸比丘。若人善出家为道。若在空闲树下山林。此是出静处。问曰。何以出静处。答曰。离諠闹故。譬如牧牛人有一犊子。从出生饮母乳至于长大。欲取乳时。以绳系犊着柱。犊子念乳牵绳跳踉。无时暂停。绳坚牢故。不能得脱倚柱而息。比丘譬如牧牛人。牛母为聚落。心为犊子。乳为五欲。柱为阿兰若。绳为阿那波那念。一切禅定念阿那波那。诸佛缘觉阿罗汉之所尊重。若不舍城邑聚落。难入阿那波那。若禅比丘取此定已。阿那波那第四禅定。作已。而取为地。复观苦空无我观已。得阿罗汉果。是故佛为诸禅人。现阿兰若住处。佛如知相地师。若欲立国邑。善能分别地相吉凶。即语王言。此地善可立国。若立国邑。王得大利益。王随语已即立国邑。如相师占便即赏之。佛亦如是。能分别禅处。即向禅人说此处善可入禅。诸禅人即随佛教。次第得阿罗汉果。赞叹佛亦如王供养相师。诸禅人。如师子王依住此林。隐蔽其身伺禽兽。若近其处而起。捉取得便食之。比丘亦尔住在阿兰若。伺候须陀洹斯陀含阿那含阿罗汉。次第得者即便取之。往昔偈言

  譬如师子王　　隐住山林中
  伺诸禽兽近　　即便捉取食
  佛子亦如是　　隐住阿兰若
  伺取无上道　　获得沙门果

树下者。于树下若坐若行。静室者。除树下阿兰若处。余一切住。皆名静室。时节及四大和适时。所宜阿那波那念。是故律本中说。加趺而坐。此是现阿那波那念。易可解耳。结加趺坐者。易解。正身者。十八背骨骨相累筋脉皮宽舒。若急坐者须臾疲劳。从禅定退。安念前者。念禅定法安置其前。出入息者。比丘结加趺坐念禅定已。念出入息云何。念喘息长念喘息短。因长短故。而心得定。无有动摇。因不动摇念即起成。以念及智慧。然后知喘息长短。譬如儿在胎中。初从胎出。先出息长短可知。云何可知。譬如水随器长短而流。亦如象蛇其身长故息亦随长。虾蟆。身短息亦随短。坐禅比丘亦复如是。以此譬喻知息长短。以正念故。心已生乐。因乐故。极细长出息入息。心转乐已。因出息入息。心转乐已。出入息转细长。因转乐已生怡悦。因怡悦故。知息转成微细。因此怡悦复增怡悦。怡悦故。倍息增微细难得分别。已生舍心。以此九法汝自当知。我出息知一切身。入息亦知一切身者。知一切身出息入息。身长短初中后。一切知现前。知知与心合。知息初后。又禅比丘见出息如散尘。此现前见初出。见中后不得见。欲见中后心不能及。又出息止见中。不见初后。又见后出息。不见初中。又有比丘悉见初中后。何以故。心无疲倦故。若得如是。即为善出入息。于禅学者。不休息不住。恒观出入息。若如是者。护身口意业。名为学戒定慧。若三昧心。名为学定。若能分别戒定者。名为慧。此是三学。于观处中。以念正心已学系心中。已作恒使不绝。从此以后。于彼若殷勤当学灭出息入息者。粗出息入息而灭。灭者住也。云何为粗。比丘初入禅定身心疲极。是故出息入息粗。鼻孔盈满复从口。出入息从粗。身心不疲极。渐渐细微。于出入息中。比丘而生狐疑。我出入息为有为无。譬如有人登上高山。身心疲劳气息粗大。又从山下至平地下。有池水及大树。入池洗浴竟。还于树下稣息。或眠或坐身心清凉。渐渐气息微细。比丘初入定亦复如是。初未录身心出入息粗。何以故。为无念故。何以渐细念。录身心故。而说偈言

  身心极疲劳　　出入息亦粗

第一禅粗。第二禅细。第三禅转细。第四禅定。第三禅为粗。第四禅名为细。此极处出入。若不捉息出入息粗。若捉出入息细者。不捉者。放息。捉者。于第四禅初而捉心。至第四禅而灭出息入息此是舍摩陀法。毗婆舍那法者。不捉出息入息大粗。若观四大即细。又观优波陀那色细。四大成粗。复观一切色细。优波陀那色成粗。又观无色细。一切色成粗。又观色无色细。无色成粗。又观因缘细。色无色成粗。又观因及名色细。因缘成粗。又观观相毗婆舍那细。因及名色成粗。观小毗婆舍那细。观相毗婆舍那成粗。观大毗婆舍那细。小毗婆舍那成粗。此次第前。次第前者细。后后者粗。粗细波萨提者(汉言寂静无有疲极)于三跋陀中说。云何学灭出息入息。云何出息。云何入息。答曰。身有入息念。学灭出息入息。如是身心不倾不危不动不摇。寂静极微细如无。是名学灭出息入息。如是风住。如未成阿那波那念。亦未成就观未成就智慧人。不入此三昧。不从此起。若学灭出息入息。如是成就风住不起。即名善开智慧人。入如是法亦从此起。云何知之。譬如打铜器声初大后微。大声已自忆识。后渐复善忆识。微声善忆置心中。微声已灭。犹思忆不离心中。出息入息亦复如是。初粗后细忆识粗者。渐以至细。细者已灭。犹忆识心中。自此忆识故心定住。如是得风息。心定住关炼成就出息入息亦成就。阿那波那三昧亦成就。如是智慧人入此禅定。亦从此起。是故律本中说。灭出息入息已。随念。更起。故名随观。知出息入息非随念随念非出息入息。因此二法故。有知起观看此身。如是次第得阿罗汉果。如是初学禅人。云何学之。善心比丘应净四戒。净者有三。何谓为三。一者不犯。二者犯已忏悔。三者诸烦恼不坏。如是净戒已。然后成念。应作佛房跋多菩提树地前跋多和尚阿阇梨浴室说戒堂八十二揵陀迦跋多。有四种摩诃跋多。如是作已名为善行戒也。若比丘乐学此戒。应当满持。若比丘言。我持戒具足无有缺漏。而不自念言。我应当死。作如是念。舍诸营作善行戒。此比丘戒满者。无有是处。若比丘作善行戒者。此比丘戒具足美满。因美满故得受取三昧。何以故。如修多罗中说。佛告诸比丘。若人不习学善行戒。此人戒难得具足。而说偈言

  住处寂利养　　众业足为五
  远亲及诸病　　读诵长为十

此十恋慕法。若人能舍者。然后入禅定。禅定法者。有二种。一者一切观。二者摄亲。问曰。何谓为一切观。答曰。于比丘僧为初。作大慈心及念死观不净也。若比丘慈心。云何初作慈心观。比丘初观作界心观。先观比丘僧。次观天人。次观大富长者。次观常人。次观一切众生。何以先观比丘僧者。为同住故。若慈心遍覆。比丘僧中安乐而住。何以观天人。为护持故。若慈心遍覆天人者。天人柔心而行善法。何以观大富长者。为行善法故。何以观常人。为同法行故。莫自相害。何以观一切众生。为无艰难故。何以念死者。觅增长悲叹无懈怠故。观不净此圣观也。若观不净便得离欲。一切诸恶。欲为根本。是故应敬重不净观。能立一切诸善。是名一切观。三十八观随意能修。修习不离。是名摄观。此是阿那波那念入摄观。法师曰。我今略说。若欲知。于阿毗昙婆沙广说。如是净戒已离诸缘事。而入阿那波那定。因阿那波那定。即入第四禅定。入已观苦空无常。观已往问阿罗汉。若无阿罗汉至阿那含。若无阿那含往至斯陀含。若无斯陀含至须陀洹。若无须陀洹往至得禅人。何以寻觅如此人。其已得禅易指示故。譬如象行脚迹易寻不迷正路。得道得禅亦复如是。何以故。易指示故。法师曰。我欲说初行。此比丘装束轻身无余长物。威仪具足往至师所。到已而作跋多。以下承师意。师渐以爱念应取五品。问曰。何谓为五品。一者取。二者问。三者起。四者着。五者相。问曰。何谓为取。答曰。取禅定法。何谓为问问其次第。何谓为起。起禅定法。何谓为着。着禅定法。何谓为相。分别禅定相貌。是名五品。何故前取五品。为身莫劳亦莫恼师故。是故先取五品。为易忆识易从习故。若取五品已。若于师处善者住。若不善可移住。无智慧者去师一由旬。有智慧者过此亦得住。应远离十八住处善。有五种应当取。取已断灭小小缘事。中食已少时消息。息已先念三宝。令心欢喜。随如师教勿有忘失。此阿那波那念善置心中。法师曰。我今略说已。于阿毗昙广说。汝自当知。忆识心中者。云何忆识。数随触安置观还净历观。数者。一二为初。随者。随息出入。触息所触处安置者。道也。净者果。历观者。法相。若初学者。先数安置心中。数法者下数。从一至五置更始。不得三四。上数者。从一至十置更始。不得八九

善见律毗婆沙卷第十善见律毗婆沙卷第十一

        萧齐外国三藏僧伽跋陀罗译

问曰。若数至三四置者。有何不善。答曰。出入息逼促。因逼促故。心难调伏。譬如牛栏内牛极多。在栏里迮切。会当破栏出。若足十者。身中宽容如大栏。宽容牛故。易可守养。若至八九有何不善。答曰。勿使乱错。而生狐疑心。或言。我得禅味。起迷惑心故。如是之过汝自舍离。若数息者。安徐数也。如人量谷。先满覆竟。然后数为一。复更取量。若有尘草。选拾弃之。覆竟唱二。如是次第乃至十。坐禅比丘。数出息入息亦复如是。若駃者。如牧牛人数牛。云何数牛。黠了牧牛人。手执杖门柱上坐。驱牛出时打牛駃出。以完而数。一二三四五。如是至十。何以故。作如是数。有时四大不和。气息駃出入。时随出入而数。一二三四五。一二三四五。数牛时当门关而数。不数内外。因駃数故。而心得定。何以故。譬如人乘船上湍。一二三四五篙。更互剌住船然后定。出息入息亦复如是。何以心者如船。出入息者如篙。心流五欲。而出息入息制其令定。若息入心随入。如肪膏入身美满。若息出心随出。于观中最大。因其大故。心亦难调。除此二法。于触处住至而数之。然后即成三昧。是故律本中说。莫数内外息。数何时可止者。若心不乱如息出入。便止不数如是已便作随念。何谓名为随念。知出入息。不假数而知随念有三种。何谓为三。答曰。齐为初。心为中。鼻头为后。是名三种。若出息者。齐为初心为中。鼻头为后。若入息。鼻头为初。心为中。齐为后。若心随出息。心即不定。因心不定。身即动摇。是故律本。若心随出息入息。而内不定。而外动摇内动摇。因动摇故。不成三昧。若随入随出亦复如是。是故莫随息中后出入。但安置鼻头住正心。而住待息出入。若断数心忆识自定。譬如跛脚人守养小儿。以篮贮悬系屋间。坐住揽至而荡一处。手不移动。比丘坐禅亦复如是。又曰。譬如守门人。人出入不先遥问。临到门限然后问之。亦不问所从来及所持杂物。但知其出入而已。比丘坐禅亦复如是。不先逆取知出入息。汝自当知。佛言。若知三法心即定。何谓为三。一者乐入。二者方便。三者得上。是名为三。譬如大木善置地上。有人欲解木。先观木际然后用锯解之。心恒注看锯齿。令其正直不观往还。出息入息亦复如是。现思禅法办立方便。如大木在地。善观木际如心善思。禅法如锯往还。出入息亦尔。心注看锯齿。如注鼻头。比丘坐禅应知此譬。亦现禅定。亦立方便。亦至上处。问曰。何谓为禅定。答曰。身心精进调柔成就。此是名为禅定。问曰。何谓办立方便。答曰。以勇猛精进消除烦恼及灭断思。是名办立方便。问曰。何谓至上处。答曰。以勇猛精进。消除结使。是名至上处。此三法非一心观成。非不知三法。心亦不动现禅定法。办立方便往至上处。得如是者。然后按阿那波那念。名为成就。若比丘入阿那波那念者。此比丘光彻世间。如月从云得出光明照于世间。此禅定中有人初作。而现瑞相。有人用数息而现瑞相。其瑞云何。此比丘或坐地或坐床上。无有敷具。其坐处柔濡。犹如木绵华无异。何以故。已数息故。其身轻利。如是次第粗出入息灭。身心无极故。犹处虚空。出息转细如有如无。如人打磬初粗后细。坐禅比丘数息亦复如是。是故律本中说先大后小。法师曰。此数息禅定。与余禅定有异。余禅定先细后粗。若此比丘入禅。禅相不现。莫从坐起安心正坐更自思惟。云何思惟。以知禅相不现。而言。此出息入息。何处有何处无。谁有谁无。而言。人在母腹中。无出入息。于水中无出入息。长寿天无出入息。死尸无出入息。入第四禅定无出入息。色无色界无出入息。灭尽三昧无出入息。作是念已。自呵责身。汝智慧人。非在母腹中。亦非在水。亦非在色无色天。亦非在灭尽三昧。亦非在长寿天。亦非在死尸。亦非入第四禅定。有出息入息极细微。而不能自知。但更正心。若长鼻者。安心鼻弗咤(汉言鼻两边)若鼻短者。安心置唇上。是故勤守此处。如修多罗中说。佛告诸比丘。若人好忘不安心在前。不得入阿那波那禅定。非但阿那波那禅定。余一切禅定亦如是。若思念之禅定即现。此阿那波那禅定极重。诸佛辟支佛大阿罗汉。悉用阿那波那念为地。然后得随道念极静。是故于此定中忆念为上及慧。譬如绢练用针綖极细。针者如忆念。綖如智慧。连勿使断。因二法故。不失出息入息。譬如耕田人。牛已疲极。其人亦复疲极。解牛而放。放已牛即入林中。其人苏息已。起追逐牛而不逐牛迹。入林直先往牛饮水处止。或坐或卧待牛饮水竟。取绳穿鼻以杖驱去。更还耕田比丘禅定亦复如是。若出息入息悉疲极。暂时放之令苏息。不还出入。但先住鼻端。听息出入而数。忆念如绳。智慧如杖。加之令出息入息若得如是。不久而现禅相。身体怡悦。如木绵触身柔弱。有人见如古贝华。有人见如猛风起。有人见如星宿。有人见如连珠。有人见如散白珠。有人见如古贝华核。有人见如绳。有人所触悉强。有人见如火焰。有人见如猕猴。有人见如云起。有人见如莲华。有人见如车轮。有人见如月圆。何以故。如修多罗说。诸比丘集众诵经。而各各有所见异瑞。有人见如山如江如树。如是为初。问曰。如是山江树者。从何生也。答曰。从心想有。而生人忆想各异。是故想亦尔。有人观息出。有人观息入。有人观禅相。若不观如是亦不起阿那波那。亦不成初禅法。若有此三法者。成就禅定。若坐禅比丘现如是相。应往白师。我见如是相。师答言。是见相。不言是禅相。不言非禅相。作是答已更语。长老汝更进心。法师曰。师何不向语是禅相是非禅相也。答曰。若向其分别说者。是禅相即懈怠非禅相。而心生退。是故不说。但殷勤教之。禅相自现。而说往昔偈言

  置心于观后　　现相非一种
  若有智慧人　　正心而数之
  于出息入息　　精勤不错乱

如是从禅相现已。诸盖寂然而住。诸烦恼寂然自止。用此二法正心安置。即成三昧。或得初地。或得除烦恼地。或因现禅支。或得初地者。此现得初三昧地。问曰。着三昧与初三昧。有异为同。答曰。有异。初三昧心善行已。入婆傍伽心(汉言心羸弱心眠)着三昧心境界。一日恒入善行。不随婆傍伽。此二法。是名有异。若禅相现已。或观色或观相貌。将养令长。如转轮王在胎。父母爱重护之。令冷热调适及诸饮食。若善守护得成其果。比丘护禅相亦复如是。不护即失。云何护之。一者善住处。二者善行处。三者亲近善人。四者饮食调适。五者和调四时。六者善经行立坐卧。七者离诸愦闹及饮食为初。是名为七。以此七法以用护之。若护如是禅相。坚固而住。次第增长现之已。具诸根极清净调伏柔弱。若欲捉心即得。若欲放之即去。若欲起之即起。若欲调之即调。若欲欢喜即欢喜。若欲舍之即成舍。离非禅人亲近禅人。至心于禅知禅相。此是十法。善安置心中。莫作懈怠。精勤修习当作是念。今着三昧舍婆傍伽心。而起谛心。住刹那而灭。复起四五阇婆那(汉言分别心)此五心。初心作心。第二学心。第三随心。第四中间心。第五着心。若合五为四。初作学心。第二随心。第三中间心。第四着心。此第四亦名为四。亦名为五。无六无七。初者。欲界心。着心色界心。以此心故。灭五支起五支。具足十相及三善。得第一禅已。即于观中思念灭已。得第二禅。如是相灭。得第三四。如是教心乃至上。法师曰。此略说也。若广说于净道经。汝自当知。如是比丘得第四禅定。善记识之。令其增长。若欲进至真处。此第四禅五事善。一者安置心。二者入。三者敕。四者起。五者反观。以此五事而至真处。此比丘已作流利。或观色为初。或观无色为初色无色观已。更增毗婆舍那。云何增。此比丘从第四禅定起已。而取禅支。取已此禅支依止心中。心依倚四大观四大身。从此禅支。言非色处为初。是色非色等法而见识。从此四大为初。色共诸色等。法识非色也。若从三昧起。出息入息。身心即是其因。见如是已。譬如锻师有皮囊筒因人鼓动风得出入。出息入息亦复如是。因身心故。息得出入。此比丘见出息入息见身。见色心等与诸法此非色。如是名色已。复观其因缘见已。于三世中连续名色不断。因续名色而生狐疑。断狐疑已。而观三相。观三相已。复观起灭。因观起灭故。先见光明。离十毗婆舍那烦恼。离已而起道智慧。起已舍起法见。生灭法已。念念相灭。若二法起已。于三界中而生厌患。如是次第得四道已。至阿罗汉果。有十九覆观智。知至极已。于三界中梵摩沙门婆罗门中。成无上福田。此是阿那波那念数。第一四广说竟。余三四中。与余禅法不异。是故我今当分别说之。觉者现离喜也。我今出息入息而现喜。以二事觉喜。何谓为二。一者用观。二者用不迷。云何用观而觉喜。入二禅有喜。正入时欲得智慧。以观自然觉喜。是故用观觉喜。云何不迷而觉喜。二禅有喜。入已从禅定起。智与喜等而观。消灭于毗婆舍那。贯度其相而不迷。以不迷故。而成觉喜。于波致三毗陀经说。以喘息入息而成一心。心不散乱而知生识。因识已知便即觉喜。以长出息用短入息。觉一切身灭身。出息入息成一心已知识。以此二法而成觉起。以安心故。而用觉喜。以知故。以观故。反覆观以整心。至心而取精进。而用起识。正心安置以慧知之。应知以知。应舍而舍。应观而观。应现而现。即成觉喜。如是觉喜已。余句次仪亦如是。此三禅定。便有异有觉乐。若以四禅定而觉心增诃罗。问曰。何谓为心增诃罗。答曰。受二阴为初。是名心增诃罗。觉乐。此是毗婆舍那地。乐者。有二乐。一者身乐。二者心乐。于三毗陀中说。灭心增诃罗者。粗粗心增诃罗而灭。亦言定止若广说者。于身增诃罗。汝自当知。于喜文句中受亦入。若取乐者。受即覆现二。心增诃罗句中想受支多私迦。此诸法与心不离。若取心增诃罗。想与受等共入。如是观受已。此是说四事。汝自当知。于三四中四禅定觉心。云何觉心。觉心欢喜善欢喜心极欢喜。我今觉出息入息故。有二种欢喜。何谓为二种欢喜。一者以三昧。二者以毗婆舍那。云何以三昧而觉喜入二禅定。有喜正入。一刹那心与喜等。心中怡悦喜极喜。云何毗婆舍那入二禅定。有喜从禅定起已。以消灭法而触禅喜。如是于毗婆舍那刹那。作禅喜为观而心喜如是。随心即怡悦。我今觉出息入息善安置心者。以第一禅定。于观处中善安置心。入禅定已从定起。以灭灭法而观禅心。于毗婆舍那中。现观度想一刹那心定。如是起刹那心定。为一心定故。于观处心即善住。我觉如是解脱心者。从烦恼处即得解脱。从第二禅定离思念。从第三禅定离喜。从第四禅定离苦乐。如是从次第得脱。从定起已。见灭灭法。于毗婆舍那。时见无常而舍常法。复见苦复舍乐想。复见无我复舍乐想。心不乐着。因不乐着故。而观离欲。从欲而观灭想。从起想而观弃舍。从取心即解脱。是故律本说。出息入息心即解脱。如是观心。此是说四。汝自当知。于第四四中观无常者。无常想。应当知观无常。应当知恒观无常。问曰。何谓无常。五阴无常。云何五阴无常。答曰。为生灭法。云何生灭。变相法。以变相故。而生无相法。刹那刹那汝自当知。是名观无常。其色为初。观无常者。此恒观无常也。因观故。如是四大出息入息而灭法。是名观无常。观离欲者。有二离欲。云何二离欲。一者消离欲。二者无余离欲。问曰。何谓消离欲。一切法相刹那而灭。云何无余离欲。观离欲是涅槃支因二法故。而至道处因。至已见寂灭法。见已观舍。以毗婆舍那。舍除烦恼。转即入涅槃。如是阿那念。而至极处。阿那波那品竟

是时世尊者。此略说也。尔时世尊。以阿那波那念教诸比丘。因诸比丘观不净。而自共相杀。因此故。集诸众僧。集已世尊诃责众僧。汝等比丘。何以自共相杀。赁鹿杖沙门。复杀诸比丘。如来诃责已而为诸比丘结第三波罗夷。若比丘故断人命。如是为初。为声闻弟子凡圣杂故。不得骂诸比丘言痴人。空人者。如是断根已。次至随结。赞死教死为初。法师曰我今说其根本。如是佛制戒已欲缚者欲来缚心。赞叹死者言汝在世间多诸苦恼。汝作诸功德死得生天已作善者如是为初。汝已作善业。无所狐疑。死必生天。不作恶业者汝不杀生妄语。一切恶业汝皆悉不作。汝病极苦用活何为何以故。汝已作善业故。若汝从此死已。得生天上受五欲乐。恶业者令駃死。病人闻比丘语。因语故。而自取死。是名断也。知者此是众生。我欲令其死。决定无疑也。众生受人身者。从胎为初至老。是人身初心者。初受生心。此语现五欲界是故说初心。心与三无色阴共成。迦罗罗色者。此初立人身。名为迦罗罗。于迦罗罗色。若男女身相。合成三十色。若黄门身相二十。问曰。何男女迦罗罗色。初成迦罗罗时。如真羺羊色点取澄清油酥。而说偈言

  如油酥微渧　　澄清无垢浊
  迦罗罗初生　　色泽亦如是

如是极微细以此为初。过去世人寿二千岁。迦罗罗次第长大乃至老死。此名为人身断命者。从迦罗罗时。或热手搏之。或以手摩之。或以药服之。如是种种方便断使勿生。是名断命。二生者。一者色生。二者无色生。于诸色中。无不可断。色生可断断色已。无色亦死。何以故。为无色依止色故。问曰。断色者。为过去色现在色当来色也。而说偈言

  过去世生非今生　　当来世生非今生
  现在世生是生生　　离过未来取现在
  断现在生成断生

问曰。何谓为现在。答曰。一刹那相续不灭。是名现在生。问曰。云何为刹那。答曰。起生老灭。法师曰。若如是者则不成杀。何以故。为自生自灭。不假断之。云何知之。答曰。现在相续过去未灭。譬如人从外值热而来。入室安坐已。热气已灭。冷气而来相续不断。心亦如是。过去生相续现在不绝。若断之即成杀生。此是当来生因。法师曰。应知众生。应知断众生命。应知方便。问曰。何谓应知众生。答曰。世人唤假名为众生。论其实者生气也。云何应知断众生命。答曰。断生气勿令生也。云何应知方便。答曰。有六方便。一者自。二者教。三者掷。四者安。五者咒。六者神力。问曰。云何为自。答曰。自杀。云何教。教余人杀。如是汝杀。掷者。弓箭为初。随种种方便令断命。安者。箛蔟塪及毒药等。安置一处。触之即死。咒者。有二种。一者阿塔婆尼耶。二者数。问曰。何谓为阿塔婆尼耶。答曰。或敌国或贼咒之。令头腹痛种种疾病。令其死。数者。依文句咒。或十二十如是至百数。是名数也。神力者。以神通如龙王迦留罗夜叉天人人王龙王杀众生。以眼视或啮或吐毒即死。迦留罗者。能啄杀三十寻围。龙夜叉天人人王者。随其种种方便。令众生得死。与器杖者。种种器仗乃至刀子。如此之物与令其自断命。而唱言。汝用此生何为不如死。而取铁锤石木绳毒药种种死具。而近其身赞言。汝在世已作诸功德。死必生天。于难陀园中。与天人玉女娱乐。何以生世受此苦病。或教使投岩。岩者。山破为二段深谷中。或教入地狱。法师曰。若教人如是自杀者。得波罗夷罪。此杀人身。若余众生得波夜提罪。何以世尊广制此戒。为未来世恶比丘故。余后句次第易解。若毒药或刺斫。种种死具不即死。后因此死者。是比丘得波罗夷罪。我今现羺羊四。云何为羺羊四。有一比丘。见羺羊眠一处。而作忆识。我夜当杀此羺羊。移眠余处。于羺羊处。或父或母或阿罗汉来。补以衣覆体而眠。此比丘往至。夜闇不别是人。言是羺羊。取刀而斫杀。或得父死。或得母死。或得阿罗汉死。得波罗夷逆罪。何以故。初作杀羊心。临下刀时生心言。不期是羊不期是人。我正断此命。是故得波罗夷逆罪。有一比丘来补羊处而眠。杀者言。此是即杀得波罗夷罪。不得逆罪。夜叉鬼神来补羊处。杀者而言。此是即杀得偷兰遮罪。不得五逆罪。若羊得波夜提罪。若心期杀父母阿罗汉。次第而得得波罗夷逆罪。知父在军中。望军而射。着父死得波罗夷逆罪。若非父波罗夷罪。教杀长人得短人。教杀绛衣人。而杀白衣人。教者得脱重罪。杀者得波罗夷。若教言随得而杀。随死俱得罪。教人今日杀。受教者明日杀。若教明日杀。而即今日杀。教中前杀中后杀。杀者得波罗夷罪。教者脱重罪。若教随时杀。若杀俱得重罪。教言。若有人来至此处。汝当杀所期人。未来教者往补。受教者不别而杀。杀者得波罗夷罪。死者初教时得突吉罗罪。若比丘教比丘。受教者心生念。我当先杀伴。下刀还得所期人。杀者教者俱得重罪。若展转教杀。犯不犯亦如前。时非时亦如前。若比丘教比丘杀比丘。教时未得道。临杀时此比丘已得罗汉。教者杀者俱得波罗夷逆罪。不静谓静者。不静眼不见。谓言是静。若供养时。于怨家比丘中。与诸比丘共来。于前而坐。为闇所蔽而不知来。而作是言。此某甲名字。贼何不杀之。毒蛇何不啮之。人何不毒药之。我意极乐此人死。如是之语。是名不静而言静。静而言不静者。此比丘来至供养处而坐。向者咒比丘知此比丘来。来比丘去已。不觉谓言在。如前所说咒。是名静而言不静。如前后所说咒令死。悉突吉罗罪。法师曰。今当演说赞叹死。以身作赞叹者。随其知或与刀杖。或与毒药或与绳。或令投身山岩。如此之死。死已必当得物。或复得人身财富无量。或得生天。此是以身教之。或摇手或摇足或摄眼。唱言者。开口出声随意所赞教其令死。此人知其赞叹时。得突吉罗罪。随其赞取死苦痛而不死。得偷兰遮罪。若死波罗夷罪。若此人不解其赞。余人解而言。我死必得生天即取死。赞者无罪。若为二人赞者。随死得波罗夷罪。若心无所的属曼赞死。若有死者得波罗夷罪。若遣使赞叹使某甲死。初语得突吉罗罪。往至说竟受苦痛偷兰遮。若死得波罗夷罪。使者闻赞叹死得生天。而不向彼人说。还自向亲友眷属说。若有死者。使者得波罗夷。教者得突吉罗罪。若使者闻语生天而自取死。教者得突吉罗罪。若作书遣使赍书。使者不知书语若死。遣者得波罗夷。使者无罪。若作书不指的。随得人与令死若得其父。父死者得波罗夷逆罪。若有杀心。自假造经书种种赞死。有人读此经书。见经赞死生天。随经语种种死者。得波罗夷罪。若父母死得波罗夷逆罪。若后生悔心烧经。得初作经突吉罗罪。若众多比丘共作赞死经。若有读经有死者。众多比丘悉得波罗夷。若随得其父母死。得波罗夷逆罪。若造作赞死经。有人偷取读。因此有死者。造作比丘得波罗夷罪。若遭浛或遗落去失。有人拾得依经取死。造经比丘得波罗夷罪。法师曰。今当说断命初事。若比丘有杀心。掘地作坑令某甲堕中死。初掘出地得突吉罗罪。若堕坑受苦得偷兰遮罪。若死者得波罗夷罪。若余人堕死者。比丘无罪。若为一切作坑。人堕死得波罗夷。若父母堕死得波罗夷逆罪。若坑深。有人担食粮。落坑中不即死。后啖食尽必定死。无有出期。初落坑。作坑者已得波罗夷罪。若作坑本拟杀人。人不来而自误落坑死。初作坑时得突吉罗罪。复有人落坑。手脚折不即死。又得出坑已。后因此而死。作坑者得波罗夷罪。若因余因缘死不犯。法师曰。教人作坑犯不犯如前所说。若作坑取鬼神。初作坑时及鬼神落中受苦。得突吉罗罪。若死者偷兰遮。人与畜生落死不犯。若后有悔心。自填塞坑。又余缘败坏不犯。若作种种杀具使人死。犯不犯如前说。不故作者。或余事作坑有落者不犯。或说苦空无常不净观。人闻此而自取死不犯。广说律本竟。今说杀戒因缘。或从身心起得罪。或口心作得罪。或用身心口得罪。此是性罪。身业口业害心苦受。慈悲者。有一比丘病极困。诸比丘见此比丘病重。以慈悲心而唱言。长老。长老持戒具足。因畏死故。而受今苦。长老若死何必不生天。病比丘闻语已而念言。诸比丘皆赞我持戒具足。死必生天而不食取死。赞者得波罗夷罪。是故有智慧比丘。往看病比丘。慎勿赞死。正可说言。长老持戒具足。莫恋着住处及诸衣物知识朋友。但存念三宝及念身不净。三界中慎莫懈怠。随寿命长短。若此病比丘因语而死。如是因说法死无罪。诸比丘欲坐先手按座而坐。法师曰。何座先按而坐。何座不按而坐答曰。若单施席者不须按。若有[毯-炎+瞿]氀毡被者。先按然后得坐。若比丘先到。后檀越敷[毯-炎+瞿]氀毡被。不须按而坐。若檀越言。法师此中可坐。乃坐不须按。若前已有比丘。后来比丘亦不须更按可即坐。桩杵句者。于桩杵句中。不故作者。无杀心。桩臼句义可解。不须说。老出家句者。有三句。初句子向父言。莫令众僧待。为令速到故。推父倒地即死。是故无罪。第二句者。何以乐父死为。于众僧前众僧问。谁儿。此是摩诃罗儿。此摩诃罗儿。闻此语已生羞耻心。而故荡父令死。是故得重罪。第三句者。正得偷兰遮罪。从此复有三句。易可解不须解。于分卫食有三句。此乞食比丘以法为重。所以得食先与同学。无有杀心。是故无罪。从上座至下座一切皆死。余句易可解耳。第二句。若乞食从外道家得食。极精食者莫受。若已受者。勿与他人及自食。可藏弃之。亦勿与畜生。试句者得偷兰遮罪。何以故。为欲试故。若知决定应死者得重罪。从此传三句。此易可解耳。淫欲乱心句中者此比丘日夜思欲制其心。而不能制欲还复自念言。我持戒具足。何以舍戒还俗。我宁可取死。是故上耆阇崛山顶投岩取死。而岩下有斫伐人。比丘堕时堆杀伐人。无杀心无罪。佛告诸比丘。莫自杀身。杀身者。乃至不食。亦得突吉罗罪。若比丘病极。若见众僧及看病比丘料理辛苦。而自念言。此等政为我故。辛苦乃尔。自观寿命不得久活。而不食不服药善。又有比丘我病极苦。我寿命亦尽。我道迹如在手掌。若见如此不食死无罪。若比丘入禅见欲得道。而不入聚落乞食。遂不得食亦善。石句中者。比丘不得拼石。不但石乃至草木土。若起塔寺垒石掷打破亦得。乃至料理房舍亦得。若中食后掷饭虚空与众鸟亦得。若有恶兽来逼。用石土掷惊勿取着亦得。于烝句者。次第义可解。作奸坏胎者。此女夫婿远行去。妇与人私通而生胎。胎长大。就比丘乞药令胎堕落。并妇句者。易可解。按句中女人向比丘言。云何得堕胎。比丘答言。汝可按杀儿自堕。比丘教按。女人以热气熨之。比丘无罪。若比丘教自按杀。女人唤余人为按杀。比丘无罪。若但教按即死。随其自按。若余人按死者。比丘得重罪。无儿女句者。一切女人无不受胎者。何以唤为无儿。若欲受胎时。一切女人受胎。若有罪业众生入胎一弹指之顷即灭。是故无儿。或女人四大不和。风吹而灭。或儿处有虫。亦生虫啖而灭。是故名为无儿。此比丘不解。作药令儿得住。与药而死。比丘得突吉罗罪。是故当来比丘勿作医师。若作医师者。得突吉罗罪。若为出家比丘比丘尼式叉摩尼沙弥沙弥尼合药者无罪。若诸同学自有药者为合。若无药自有亦与。若自无者。亦可为往自恣请檀越家。求药不得复往余家。复有五种得与药。何谓为五。一者父。二者母。三者人侍养父母。四者自净人。五者畔头波罗沙。问曰。何谓畔头波罗沙。善男子欲求出家未得衣钵。欲依寺中住者。若父母财富自有良药。医师不须复作。若父母犹居王位。有病不得不为合药。若父母贫贱。病时有时将入寺看。洗浴母者。慎勿触体。饮食得手与食父者如沙弥无异。洗手足油涂身。悉得用手与。供养令得差愈。净人者。雇其得入林斫伐樵薪。若得病未至家。比丘与药。若已至家。比丘不得与药。若有善男子。依止比丘随驱使。若病比丘得与药。复有十种得与药。一者兄。二者弟。三者姊。四者妹。五者叔姨。六者伯姨。七者叔父。八者伯父。九者叔舅。十者伯舅。此等自有药者为合。若无可借用。若后还者善。若不还勿责。如是展转乃至七世。得从其乞药合药不犯污他家。若弟妇若姊婿有病者。可得以药与姊与弟。令自与婿妇。若无弟无姊。云何得与药。可与外甥与弟子。汝自与汝父母。若和上父母在寺有病疾。弟子亦得为和上父母合药治病。若和上无父母自有药善。若无弟子父母有药善。若无弟子父母有药自与得。和上看弟子亦如是。若余人有病。或贼或军人。被创来投入寺。比丘若有眷属。就眷属乞药得与。若无眷属。有善优婆塞。就乞亦得与。若有檀越供养众僧不异父母。若檀越有疾病。众僧不得为合药。亦不得与药。又檀越但问。大德某甲病。云何救治。云何合药。答言。此药得差。若作是言善。若檀越又问比丘。大德我母病。愿大德为处方。比丘不得处方。作方便问。傍大德某甲比丘病。以何药救治。答言。长老用此药。此药得差。檀越闻二比丘语已。还为父母合汤药。若比丘作如是语无罪。尔时大德摩诃波头摩。婆娑婆王夫人得病。夫人遣宫中一女往问。大德波头摩默然不答。乃与傍比丘共语。此女人闻二比丘语已。还为夫人合药即得差。夫人病得愈已。作三衣及三百迦利沙槃。又汤药一正瞿多者。是贮衣物遣饷。而置大德前。问讯言。夫人今以此药。乃与大德香花之费。波头摩自念言。此香是医师得分。用净取而作供养。法师曰。如是智慧人能利益众生。于己亦无罪。如是作善。若白衣言。大德请为某甲作咒。比丘不得作。若言。大德为诵咒。得为诵也当作是念。此白衣不知佛法。若我不为作咒者。当生恶念。是以为诵咒。取水洒绳而与。若自作绳水与者。得突吉罗罪。若国王及聚落大檀越有病者。遣人至寺请比丘为说咒。比丘为说阿咤那咤。或往到病所为说法。为与戒故得往。若檀越作是言。今某国王某檀越丧今葬。请比丘送丧。不得去。若比丘自念言。我往看彼葬观无常。因此故我或得诸道果。如此去无罪。分卫食者。若可与。若不可与。父母可与。不得与余人。如一迦利沙槃。得与人供养父母。得与净人得与槃头婆罗沙。如此人等须与。若有贼若劫人来乞者得与。问曰。何人可与相劳问。何人不可与问。若有人来至寺。不问贵贱劫贼。一切悉得劳问。若有唤求所须。自物者得与。若众僧物。先白众僧和合者得与。若有强力恶人来乞者。守物人为护住处故。得随意与。与竟后众僧不得诃问守物者言。是汝自领而辄与恶人。何以故。为护住处故。法师曰。我今说取其证。尔时于师子洲国。名阿[少/兔]罗陀。于中有贼。名阿婆耶。有五百贼。侍从围绕一处中顿住。立作垒栅。去垒四面各一由旬。而往劫夺。于隔历句者。易可解耳。得罪者。于屈陀迦汝自当知。或举或抑者。十七群比丘有十七人。见六群比丘有一人。十七群比丘一人取其钵盂。六人举之令倒地。展转如无异。各坐其上。于是老六群比丘而死。结罪已。于律中说。治鬼句者。杀夜叉鬼。此夜叉能捉人。比丘作诵咒令其置而不肯置。比丘语言。若汝不置我能杀汝。夜叉犹不置。于是比丘。或以米粉或以土泥。捻作夜叉鬼形。而诵咒断其手足。手足即断。断其颈。颈亦即断而死。是故得偷兰遮罪。不但杀夜叉。杀天帝释亦得偷兰遮罪。恶夜叉句者。有一寺恶夜叉住中。此比丘不知房中有恶夜叉。而教一比丘来入房中。令其安乐住止。是故无罪。若有杀心令入死者犯重罪。不死犯偷兰遮罪。不但恶夜叉。或有毒蛇虎狼等。悉入恶夜叉。犯不犯如前说。崄难句者。于崄难处多有贼。教者不知无罪。知者死犯重罪。不死犯偷兰遮罪。杀即是者。如是初句。有一比丘与一比丘怨家。此比丘欲杀怨家比丘。自念言。我若白日杀者。人即觉知。伺夜当杀之。而先观住处知已而还。至夜往怨家比丘所。而多有伴。此比丘闇中摸索。疑是怨家。即杀已是怨家犯重罪。有一比丘疑此而杀彼者。此怨家比丘住处。多伴共眠。于闇中摸索言是怨家。而误杀彼。有一比丘言彼是而杀此者。言是彼杀即得彼者。如此杀者。悉得重罪。非人句者。初言令此鬼出。而与病比丘杖打之遂死。是故无罪。问曰。若欲令鬼出者。云何得出。答曰。以多罗树叶。或以綖缚病者手足而与杖。诵罗多那说咒竟。而言汝莫触娆持戒人。汝可去为说法者法师曰。此句易可解耳。法师曰。斫木句者。小小有异义。若此木倒时笮比丘而不犯。此比丘手中有刀斧鋘呋。比丘宁守死。不得以此刀斧等斫木掘土以脱其命。何以故。若掘土斫木得波夜提罪。因得波夜提罪故。名为过圣人教。是故智慧人宁守戒而死。不犯戒而生。若有余人为掘土斫木。救出者善。若有方便得。云何方便有死木者。余比丘以抄举之善。若比丘堕坑窟。余比丘得以绳下钓上。慎莫自斫木。得语诸白衣沙弥为斫。放火句者。有异义。若人放烧火来近寺。为护住处故。比丘得铲草掘土以断火不犯。放烧句者。复有义。若自念言。我今烧一切众生。中随有众生死随得罪。五逆波罗夷偷兰遮波夜提罪。若言。我今正烧草。得波夜提。教人烧得突吉罗。唯除护住处得烧。何以故。佛所听故。酪汁句者。生酪汁冷酪汁热酪汁。汝自当知。何谓为稣毗罗浆。答曰。先取阿摩罗诃罗勒鞞醯勒。谷者。七谷。取粳米为初作余甘蕉子一切木果一切笋鱼肉蜜沙糖石盐三蒜。如此之物悉合和为一。或内[岡*瓦]或内小器血头盖泥置。三四年中待其熟。熟时色如蜜色。以此治病。风[口*束]癞如是病为初。若服此药饮食时。皆须肥味。一切诸药无过此药。最为第一。若比丘服此药时。过中亦得服。若无病者以水和得服。第三波罗夷品竟

  世尊知四谛　　善说第四重
  今分别解说　　名为波罗夷

尔时佛住毗舍离国者。此义已在前。不复重演。其未说者今我当说。为白衣驱使者。或为白衣耕田及作园林。一切所作我等当作。此是亦不应作。为教授白衣。于律中已说。使者。为白衣作使。行圣利法者。于人中名为无上法也。亦言过人法。亦言梵法。亦言入涅槃法。此法佛辟支佛罗汉法。此比丘得第一禅。如是为初。诸比丘自共筹量已。然后向诸白衣说。有比丘。名佛陀勒弃多。得第一禅定。昙无勒弃多。得第二禅定。僧伽勒弃多。得第三禅定。如是向白衣说。次第乃至第四禅定。阿罗汉漏尽三达智。白衣或问或不问。诸比丘如是更相赞叹。诸白衣供养。颜色光泽和悦气力充足。何以故。此诸比丘得供养已。饮食美味恣意游戏。亦不坐禅。是故颜色光泽和悦。婆裘河边者。此诸比丘于婆裘河边安居故。名婆裘河比丘。佛问比丘。汝等住止和合安乐者。语诸比丘。汝等四体九孔悉安乐不。不以为劳也。世尊慰喻已。而诃责婆裘河诸比丘。汝等作如此行。便是大贼。佛故欲因断。当来诸比丘勿作此行。是故律本说。佛告诸比丘。今世有五种大贼。何谓为五。一者聚集众多。或一百二百。如是乃至五百人主。劫城聚落穿踰墙壁。是世间大贼。如是为初。比丘亦复如是。犯突吉罗罪波夜提。如是展转乃至犯波罗夷罪。受他供养尊重赞叹叉手礼拜。如是为初。今世有此恶比丘。舍师及同学。而营觅利养。得利养得利养已恣意饮食。身体肥壮气力充足。共相调戏。或说饮食美味。或说淫欲。或说国土富乐聚落。或说园林甘美膳种种思忆言说谈道粗恶。放纵心意不能自制。遂成破戒。受诸信心檀越布施衣服饮食汤药卧具房舍床席。实非释种子。而称释种子。非梵行自称是梵行。受此诸施。是名第一大贼

善见律毗婆沙卷第十一善见律毗婆沙卷第十二

        萧齐外国三藏僧伽跋陀罗译

有善比丘。或知修多罗藏或解阿毗昙藏。或解毗尼藏。不希饮食趣得支命。持戒清净。或为人说法。威仪具足。令人欢喜。从邑至邑。从国至国。为人敬重佛法兴隆。如是比丘光扬佛法。有恶比丘。从善比丘闻受法已。为他讲说言辞柔和音声清彻。人所乐闻众共赞誉。大德善说妙法。从谁禀受。答言。我自知之。不从他学。如是自称。如来积四阿僧祇劫百千劫。具足诸波罗蜜。勤苦如是得此妙法。而恶比丘因偷此法。求觅利养。是名第二大贼。复有大贼。精进比丘持戒具足。或得须陀洹斯陀含阿那含乃至阿罗汉。或凡夫比丘持戒清净。以波罗夷法谤之。憎嫉他行。自称己是清净人。如是谤诸贤圣。偷窃圣法。是名第三大贼。重物者。如盗戒无异。乃至五摩沙迦盗取。是名重物。佛告诸比丘。有五种重物。不应与人。僧亦不得与。众亦不得与。一人亦不得与。若与者得偷兰遮罪。何谓为五。一者园。二者地。三者铁物。四者木物。五者土物。以此诸重物。不得妄与人。佛告诸比丘。五种不得分。僧众一人园为初。若分得偷兰遮罪。法师曰。分不可分。于蹇陀迦当广说。今此略说。以取者。以此重物而取白衣意。希望白衣不可与人。而偷取以饷致白衣。佞取其意。此是第四大贼也。以此重物饷致白衣者。名污他家。因污他家得突吉罗罪。应驱出众。复有比丘。取僧物如己物无异。行用与人得偷兰遮罪。若以偷心取者。随宜多少结罪。此是名为第五大贼。贼无过此贼。圣利法者。此法极细微。若金银珍宝亦可偷取。此法不可偷取。是故律本说。圣利法者。而自说有。于身中无圣利法。自言圣利法已在我身。问曰。此无离本处。云何名为贼。答曰。不能得名为贼。何以故。为因空诳妄语。而得大利养故。以方便取之。是故律本说。佛告诸比丘。盗取人饮食者。此亦名大贼。何以故。以无实故。假名有实言。我是阿罗汉。圣法在他。而假偷在己。譬如猎师欲杀群鹿。若以人形往者。鹿见必走。以方便故。以草木缠身。身非草木。而现示是草木形。诸群鹿见者谓之草木。而来就之。即杀取。比丘亦复如是。非阿罗汉。假示是阿罗汉。现阿罗汉相。信心檀越谓是真实。以肴膳饮食而供养之。亦如猎师假形谋鹿。如此比丘假形谋取诸檀越饮食是故律本中偈赞

  外袈裟绕颈　　内行不净法
  已行恶法故　　死即堕地狱
  铁丸热光炎　　宁可吞取死
  若有破戒者　　不应吞信施

外袈裟绕颈者以袈裟缠置肩上。此是外取圣表式。内空无所有。譬如画器内盛臭物。如此之虚假。定无一可取。恶比丘亦复如是。第二偈者。何以如来作如是说。宁吞铁火丸。而不吞檀越供养施食。何以故。吞铁火丸肝肠烂死。不以此因缘堕于地狱。是故作如是说。诃责婆裘比丘已告诸比丘。说戒时作如是言。若比丘空诳妄语为初。佛结第四波罗夷坚已。复次随结。除增上慢者。如是佛已为比丘说随结已。于随结中。不见谓为已见者。以慧眼不见阿罗汉想。而谓已见。如是未至谓至。未得谓得。未得句者。以道谛未得。作真实者。以慧眼覆见真实。增上慢者。作是言。我已得圣利法。于中生慢。或言过慢。或言增慢。自念言。我于阿罗汉法。我已作之。云何慢。以舍摩陀毗婆舍那力故。烦恼暂住。是名为慢。若后见欲境。烦恼便起。唯此人不犯。问曰。何人起慢。何人不起慢。声闻罗汉不起慢。既得道果。一切诸烦恼灭故。以慧眼覆观。无有未得谓得狐疑。云何狐疑。我得须陀洹斯陀含阿那含为初。如是于四道果慢不起复不起慢。于破戒人。云何不起。于圣利法无有分故。如禅人好眠为事。此人不起。起慢人者。先持戒具足而入禅定。得禅定已。未分别名色。始入毗婆舍那。三想具足心绝勇猛。或得舍摩陀。或二十年或三十年中不起。因勇猛行毗婆舍那力故。自念言。我得须陀洹道斯陀含阿那含。增上慢如是。若能善持舍摩陀。非但二十三十年。乃至八十年百年烦恼不起。是以生增上慢言。我得阿罗汉。是故如来除增上慢。不入空诳妄语圣利法。答曰。言禅定解脱三昧入空慧眼。如是禅定为初。一切诸法。是名为圣利法。恶比丘以此法为己有。或以己身现为法。有圣利满足见者。世间过世间。用慧知诸法。如肉眼见无异。慧眼者。三知也。问曰。慧与眼为一为异。答曰。一也。慧即眼眼即慧。问曰。若尔者。何不直言慧。何须言眼。亦不须言慧。答曰。不然。所以如眼不异。故名慧眼。过人法向男女说者。此是指示说处也。非天梵魔。亦非夜叉饿鬼畜生。我如是知如是见者。此说其因缘。知如是见如是禅定为初。如是见如是我知。若捡挍若不捡挍者。此令人知已得罪也。当时说已得波罗夷罪。已得竟。或有捡挍或不捡挍。自向他说。是故律本说。或捡校或不捡校。云何捡校。问长老。何时得禅定解脱三昧三道耶。如是方便问已或问。长老得三想苦空无我。或以三昧得之。或非三昧或毗婆舍那得也。或以色或以无色。或以内色或以外色。何时得也。为朝得为中得为暮得。复问处。何处得也。为树下为阿兰若。为空闲得耶。问已复问。若烦恼已灭。去几余有几。以何道灭之以须陀洹道。为斯陀含道。于一一道中。汝得何法。若有比丘得过人法。而一一答言。若不得者。问已迷乱不能自答。若人得者。现法如在手掌无异。日时处所皆一一答之。或白日或夜。若答已复问。四道果中汝已何道。杀几烦恼。答者一一悉著者。复问。汝得何法。为得须陀洹斯陀含。若答悉著者。若有小小异者。即不信。何以故。若有智慧聪明比丘。从师禀受一一句义。不得谬乱。复作余问

初入云何。若答不着。即圣利满足汝不得也而驱出。若答言。入圣道着。久于戒定慧中。无有懈怠精勤不退。于四供养心无染着。譬如虚空。若如此比丘说而同合。如大河水与盐牟那水相合无异。是故佛为声闻弟子说涅槃道。于一一说中无有谬错。是故以种种问难怖之。若不怖者。是爱尽比丘。如霹雳着身。亦无恐怖。若有恐怖。则非阿罗汉。若不恐怖。一毛不竖。如师子王。此比丘若说圣利法善者。王及诸大臣有供养者。皆悉堪受。恶比丘者破戒也。比丘有戒者善比丘也。令人知我者。以恶心而假现圣利。无有实想。得波罗夷。已乐自令净者。自念言。我已得波罗夷罪。我今云何得净也。如来所以结戒。比丘犯波罗夷罪。于天禅定解脱智慧住乐道者。皆悉障碍不复得。如律本中说半偈

  沙门不持戒　　死必入地狱

若于比丘中戒不具足。还作白衣优婆塞沙弥戒持五戒清信士。如此于涅槃道无有障碍。是故于白衣相净。是故破戒比丘乐净者。还作沙弥及白衣清信士。是故律本中说乐欲得净。我不知言知不见言见。我空诳妄语。空诳妄语者。此无义语也。依止前三波罗夷。若人得此罪。名为波罗夷。法师曰。此句易可解耳。我乐静者。此是略说现圣利法。以不广说而增其罪。又有异义。以方便令人得知。入禅定者入第一禅定第二第三第四禅定。慈悲禅定不净观禅定阿那波那禅定圣人禅凡夫禅悉入。是故律本中说。入禅定为初。若如是说。得波罗夷。言我已离烦恼离欲断不复生。得罪如前所说。若言我入三昧得道。发语知者。已得波罗夷罪。或言我得智慧。或言得三达智。或言得三十七菩提党法。得初力得善作。得八圣道法。如是皆得波罗夷罪。我离欲如是为初。此是须陀洹道。以第三道离嗔恚欲。以第四道离愚痴。是故律本中说。我已离欲。若如是说。得波罗夷罪。或言六通中我一一已得亦得波罗夷罪。若言我前世已得六通我今欲得。如此不得重罪。或言我得四辩犯重。或言我入灭尽三昧不犯重。何以故。灭尽三昧。非圣人定非凡人定。若有人疑。是阿那含阿罗汉。令人知我如是。令人知人即知。又言我已从迦叶佛时得须陀洹道。不犯重罪。何以故。如来以今世结戒。不为过去世。又言过去世入三昧亦如是。法师曰。空诳妄语罪相已结定。今至有三转。取第一禅为初。乃至离五盖一。此是第一转。第二转取第二定为初。第三转取第三定为初。我如是入如是定。如是起如是作。已如是通达无碍。有如是说。悉得重罪。法师曰。妄语有三种。何谓为三。一者自念言。我今欲妄语。二者开口成妄语。三者妄语已自念言。我已妄语。是名三种妄语。复有妄语。初念言。我今妄语。临发言而实语。不成妄语。如此不得重罪。复有妄语。我欲禅发言而禅。我欲入定。如此不犯重。复有妄语。初发思妄语。发口言妄语。语已妄语。如此三相具足。是妄语是为真实妄语。法师曰。若如此不成妄语。何以故。心心起灭如一刹那。前心非后心。后心非前心。是故一心不具足三相。答曰。不尔。所以如来结戒。心心相续如一无异。是故犯重。问曰。三相何者为正。答曰。初发为正。法师曰。我今断说。何者得罪。言我今正得者即得罪。若言曾得欲得不犯重。此三转品竟。欲说者。我欲说第一禅定。后发语我入第二禅定。此是语误。第三第四禅定亦如是误。悉犯重罪。何以故。为其地故。如言我欲舍僧。而误舍法。我欲舍法。误言舍佛。戒亦即失。今空诳妄语小小有异。问曰。何谓为异。答曰。舍戒虽现身相。戒亦不去。要须发语而失。若向人说我得道人。未即解语。良久方解。不即知故不犯。不犯重得偷兰遮罪。又有比丘向人说。此人亦不知禅想。亦未曾得禅。不解禅义。随世间语禅定而已。若比丘说。此人闻已言。此比丘已得禅定已入禅定。若如是知者。即犯重罪。欲说品竟。次方便转者。随律文句解说。而向白衣说者。言若人受檀越饮食衣服房舍汤药者得阿罗汉。以方便不自说名字故。犯偷兰遮罪。若檀越不解语犯突吉罗罪。法师曰。如是种种方便。欲令人解。罪相轻重。汝自当知。我今说无罪者。除增上慢者无罪。不欲向人说误说无罪。实得向同意说不犯。最初未制戒婆裘河比丘不犯。颠狂心乱不犯。此因缘本起从身心口。此是性罪。受者。乐受。法师曰。此是律本所说。今次随结。法师曰。次第至随结。若有难解者。我今当解说。增上慢句者。前已说。次第二人令人疑句。我今阿练若处住。人当疑我得阿罗汉。或疑我得斯陀含乃至须陀洹。以此疑故。当大得利养。若初作如是心时。得突吉罗罪。从寺往阿练若处。步步得突吉罗罪。至阿练若处起作。皆得突吉罗罪。后有人疑无人疑。得利养及不得利养。皆突吉罗罪。又有比丘受头陀法。我不宜在聚落。宜在阿练若处。此是清净处。若清净我当得一一道果。及阿练若处若入已。不得阿罗汉果我终不出。又自念言。如来赞叹阿练若住处。若我在阿练若处。诸同学见我。亦乐入阿练若处。若如是住者便无罪。第三句者。我欲入聚落乞食。着衣持钵现圣利想乃至食竟。悉突吉罗罪。若得利养若不得利养。悉突吉罗罪。又自念言。我欲入聚落乞食学圣人法。为今世后世。诸同学见我持钵乞食。赞叹言善。此是真如来法。若我等不行此法。实有惭愧。若生如是心乞食无罪。第四句者。向檀越言。若人住在檀越寺。为不说名字故。不得波罗夷罪。令人疑者。此句易可解耳。言烦恼。若向白衣说烦恼尽。随语得波罗夷罪。若空静处说言。我得阿罗汉。得突吉罗罪。若檀越所供养比丘。此比丘是阿罗汉。此句易可解耳。不须广说。病句者。非人所能堪忍。唯我能忍此苦。此文句者无罪。若言非凡人所能堪忍。唯我一人能忍此苦。若作如是语者。得偷兰遮罪。婆罗门句者。此婆罗门信心于法。是故言善来罗汉。如是饮食供养。一一皆唤为罗汉。为信心故。唤为罗汉。受如此供养供给。一一悉不犯。佛告比丘。如此赞叹之言。应生惭愧心而受。受已当勤行道以求罗汉。次还俗句者。如我等辈于俗法已断。此非贡高语。是故无罪。障碍句者。于白衣法已障亦言已离。于律本罪想已说。从寺出者。若人先从此寺出。此比丘得阿罗汉。法师曰。此是略说耳。今当广说。云何广说。若言从寺出。或从房出。或从戒坛出。或言渡江。如是众多僧已有制。若比丘前出者。此比丘是罗汉。若欲令人知前出犯波罗夷。若有因缘师僧遣去。及父母急难因缘出去不犯。若因此事出欲现罗汉想亦不犯。若乘车及以神力出不犯。律本中说。若步出犯若立制已。即日出不犯。若阿练若比丘立制。若坐此树下者得阿罗汉。若在此经行处。此比丘亦得阿罗汉。我等应以香华供养。若有恶比丘。乐欲得此供养。树下坐者及往经行处。得波罗夷罪。若有白衣作寺。若比丘入我寺者。是阿罗汉。若有恶比丘入此寺者。犯波罗夷罪。若众僧立制。于夏三月中。莫语莫眠莫出莫受檀越供养。若如是非法制不从不犯。长老勒佉[少/兔]者。身相具足。如梵王身故。名勒佉[少/兔]。问曰。此勒佉[少/兔]何时出家。答曰。与千梵志同善来出家得具足戒。又问曰。此勒佉[少/兔]。因闻何法而得阿罗汉。答曰。因闻光明经即得阿罗汉。目连从出家七日便即得道。发含笑者。是小笑也。因何而笑。已在律本不须重说。骨骨相连者。此是饿鬼形也。非肉眼所见。唯圣眼能察。问目连既见如此众生。何不生慈悲心而发含笑。答曰。所以目连自思惟言。以佛慧眼自念己身。如此细微众生我今得见。念已生欢喜心。故发含笑。复自念言。如此饿鬼之苦。我今得脱。我得善利。如修多罗中说。佛告诸比丘。因缘果报不可思议。若思议者则成颠狂。是故如此因缘不可思议。如律本中说。勒佉[少/兔]问目连。以何因缘而发含笑。目连答言。若欲问者。于佛前而问。骨骨相连者。其骨形长一由旬。无筋肉也。众鸟飞逐者。为是真鸟为化鸟。此是夜叉鬼。鬼口纯铁为嘴。发大叫声者。此是号哭大苦恼声也。此骨若有人来触者。如新破痈疮。苦痛如是。咄哉者。叹其苦也。法师曰。大句次易可解耳。比丘呵责者。诸比丘言。目连空诳妄语。是故呵责。佛言。目连是慧眼也。是故律本中说。目连已成天眼得见如是。佛告诸比丘。我已曾见如是众生。我于菩提树下得一切智。我见无量无边不可思议世界众生住处。犹如手掌中见阿摩勒果。杀牛人者。杀牛为业。杀已剔肉卖。余骨相连悬置钩上。以此果报久在地狱。良久得出。余业未尽。今受此形。肉段句者。此人屠牛杀已。割肉作脯悬置钩上。余骨弃掷。恒以此为业。因此果报死入地狱。受果报已从地狱出。受身形如脯段。众鸟逐。如前句说无异。第二句者。此是捕鸟人得鸟。先斩头斩翅斩足剥皮。悬置钩上。恒以此为业死入地狱。一一如前句说无异。无皮句者。此人恒杀羊。如斩鸟句一一无异。刀毛句者。此是屠猪人。恒用刀杀猪。恒以此为业。死入地狱。如前所说一一无异。槊毛句者。此人恒捕猎众鹿。以槊刺杀。因此果报死入地狱。如前句所说一一无异。箭毛句者。此人先作国主。若人有众罪。以种种治之。或刺或割鞭杖捶挞无道。如是为初。以此果报死入地狱。如前所说一一无异。锥毛句者。此人生时作军士。恒以铁锥刺马。因此果报死入地狱。从地狱出今受此形。锥恒自刺身。针毛句者。此人生时两舌恶口。死入地狱。从地狱出受此形。恒受针刺阴囊[岡*瓦]句者。此人是村中官长。不善判事。以此果报死入地狱。从地狱出。受身阴大如[岡*瓦]。何以故。若人有罪。辄受人财货。覆藏其咎。若无物者。开露其罪。故受此形。法师曰。若有智慧人作官长者。慎勿曲理。受罪果报如此。奸淫句者。此人生时好作奸淫。人所爱惜细滑。而辄与人私通。死入地狱。从地狱出受饿鬼形。恒入屎坑。要婆罗门句者。此易可解耳。无皮女句者。女人皮细滑非己有。是丈夫许。而偷与余人。因此果报死入地狱。先触乐后触苦。今受如此果报。丑臭句者。律本已说浓烂句者。此女人以火炭泥余女人。以此果报。一一如前所说。杀贼句者。此易可解耳。比丘句者。此恶比丘受他信心供养。不护身口意业。以此果报。一佛中间在地狱。从地狱出受饿鬼形。恶比丘尼式叉摩尼沙弥尼。不护身口意业。受罪亦如是河句者。法师曰。此河从何处来。从毗婆罗山出。去一由旬。龙王宫殿在此河下。纵广一由旬。其城郭如忉利天宫无异。因龙王福德因缘故。所以清冷香美莲华。大如车轮。水从此流出。经三地狱中间上过。所以热沸。此是镬汤地狱余热气上烝。是故水沸。斗句者。目连向诸比丘言。长老檀越洴沙王。与离车子共斗。长老檀越不如退走诸比丘心念。惜檀越故。语目连。汝空诳妄语。群象句者。叶毗尼江边。叶毗尼者。江名也。安阇三昧者。问曰。身心不动。此是第四。禅定。何以群象渡江而叫声。答曰。有二种叫声。一者小象欲泅渡江。见水深而畏故叫。二者大象得水而生欢喜故大叫声。未成就者。此禅未成。亦言垢浊不净。是故得闻象声。严好比丘忆过去五百劫者。此是一生相续忆识。不识化生也。法师曰。云何忆识五百劫生也。此是从外道第四禅定出。定寿终生无色界。寿尽从无色界下生人间。入佛法中得三达智。是故忆五百劫。于二中间不忆。如修多罗中说

佛告诸比丘。我声闻弟子忆过去事。严好比丘第一。诸大德已说四波罗夷竟。法师曰。波罗夷有几。答曰。我今总说一切二十四波罗夷。汝自当知。问曰。何谓为二十四波罗夷。答曰。比丘有四。比丘尼不同波罗夷有四。十一人不得。何谓十一人不得。答曰。一者黄门。二者畜生。三者二根人。此三者受生无缘故。名波罗夷。然此三人不障天道。于四道果中有障碍。是故名为波罗夷。此三人不听出家。四者贼住。五者破内外道。六者杀母。七者杀父。八者杀阿罗汉。九者坏比丘尼。十者出佛身血。十一者破和合僧。此十一人。为所作故。不得道果故。名为波罗夷。贼住破内外道坏比丘尼。此三人不障天道。于四道果障碍。杀父杀母杀阿罗汉出佛身血破和合僧。此五重罪。此是五逆罪。天道道果悉障。法师曰。波罗夷有八合十九。复有比丘尼乐着白衣衣服。计成合为二十。此比丘尼亦不破戒。复有弱脊长根。含他人根。坐他人根。此是四。都合成二十四。最后四是随结。法师曰。何以含他人根。名为淫法。此以欲意故名为淫。不得与比丘同住者。不得与布萨说戒自恣羯磨一切僧事。悉不得共。我今问长老。于一一波罗夷中谁清净者。第二第三亦问如是。谁清净者。法师曰。余文句者。易可解耳。一切善见律毗婆沙四事竟

  波罗夷品竟　　次至十三事
  今演十三义　　汝等应当知

尔时世尊游舍卫城。尔时者。为声闻弟子结戒时。非世间时也。游者。有四。何谓为四。一者行。二者住。三者坐。四者卧。以此四法。是名游。譬如世人言王出游。若到戏处或行住坐卧佛游舍卫亦复如是。舍卫者。是道士名也。昔有道士居住此地。往古有王见此地好。就道士乞为立国。以道士名号为舍卫。如王舍城。昔有转轮王。更相代谢止住此城。以其名故。号为王舍城。舍卫亦复如是。舍卫又名多有。何谓多有。诸国珍宝及杂异物。皆来归聚此国。故名多有

  舍卫甚微妙　　观者无厌足
  以十音乐声　　音中唤饮食
  丰饶多珍宝　　犹如帝释宫

迦留陀者。是比丘名也。欲意炽盛者。为欲火所烧故。颜色燋悴身体损瘦。法师曰。次第文句易可解耳。不须广说。若有难处。我今当说。乱意睡眠者。以不定意以此睡眠也。若白日眠。先念某时某时当起。如修多罗中说。佛告诸比丘。若汝洗浴竟欲眠。当作是念。我发未燥当起。如是眠若夜亦应知。时月至某处当起。若无月星至某处当起。当念佛为初。于十善法中。一一法中随心所念然后眠。此痴比丘不作是念而眠。色欲所缠。是故弄出不净。除梦中者。法师曰。律本说。唯除梦中。弄与梦俱出不净。何以除梦。答曰。佛结戒制身业。不制意业。是以梦中无罪。如律本中说。佛告诸比丘。汝当作如是说戒。若比丘故弄出精僧伽婆尸沙。出精者。故出知精出。以为适乐。无惭愧心。精者。律中七种。毗婆沙广解有十。何谓为十。青黄赤白木皮色油色乳色酪色酥色。精离本处。本处以腰为处。又言不然。举体有精。唯除发爪及燥皮无精。若精离本处。至道不至道及出。乃至饱一蝇。得僧伽婆尸沙罪。若有热作行来运动。及病疾自出不犯。梦有四种。一者四大不和。二者先见。三者天人。四者想梦。问曰。云何四大不和梦。答曰。四大不和梦者。眠时梦见山崩。或飞腾虚空。或见虎狼师子贼逐。此是四大不和梦。虚不实。先见而梦者。或昼日见或白或黑。或男或女。夜梦见。是名先见。此梦虚不实。天人梦者。有善知识天人。有恶知识天人。若善知识天人现善梦。令人得善恶。知识者。令人得恶想现恶梦。此梦真实。想梦者。此人前身。或有福德或有罪。若福德者现善梦。罪者现恶梦。如菩萨母梦菩萨。初欲入母胎时。梦见白象从忉利天下入其右胁。此是想梦也。若梦礼佛诵经持戒。或布施种种功德。此亦想梦。法师曰。此梦梦中能识不为想也。答曰。亦不眠亦不觉。若言眠见梦者。于阿毗昙有违。若言觉见梦见欲事。与律有违。问曰。有何违。答曰。梦见欲事。无人得脱罪。又律中说。唯除梦中无罪。若如此者梦即虚也。答曰。不虚。何以故。如猕猴眠。修多罗中说。佛告大王世间人梦。如猕猴眠。是故有梦。问曰。梦善耶为无记耶。答曰。亦有善有不善者亦有无记。若梦礼佛听法说法。此是善功德。若梦杀生偷盗奸淫。此是不善。若梦见赤白青黄色。此是无记梦也。问曰。若尔者应受果报答曰。不受果报。何以故。以心业羸弱故。不能感果报。是故律中说。唯除梦中。僧伽婆尸沙者。僧伽者。僧也。婆者。初也。尸沙者。残也。问曰。云何僧为初。答曰。此比丘已得罪。乐欲清净往到僧所。僧与波利婆沙。是名初。与波利婆沙竟。次与六夜行摩那埵。为中。残者。与阿浮呵那。是名僧伽婆尸沙也。法师曰。但取义味。不须究其文字。此罪唯僧能治。非一二三人故。名僧伽婆尸沙。若得故出精罪。应知方便时想。应知方便者。我今出内色。欲出外色。俱出内外。虚空中动。如是方便故。名方便也。起时有五种。一者欲时起。二者大便起。三者小便。四者风动。五者虫触。是名五种。若欲时起男根便强堪用。过此时不起。余四亦如是。复有朝中晡夜。亦名为时。为除病者

如是有十句。青色为初。亦有十故。于律本中说。户孔为初。内色与外色触。即成堪用。虚空中动。亦无内亦无外色。自动故得罪。虫者。此虫身有毛。若触痒而起即成堪用。若作药或布施。或祠祀或试。或以生天或作栽种。若作如是者。皆悉得罪。若故出精离本处。得僧伽婆尸沙罪。若故出精而不出不得罪。若自流出非故出者亦无罪。法师曰。次句易解。若比丘得罪。往至毗尼师所。毗尼师次第问。先敕。勿覆藏语。先敕。我如医师汝如病者。而实头痛而假言脚痛。医师设药病亦不差。即呵责言。师无验不解设药。是故汝可一一向我说。若重结重。若轻结轻。毗尼师先观十一欲十一方便。问曰。何谓为十一欲。答曰。一者乐出乐。二者正出乐。三者已出乐。四者欲乐。五者触乐。六者痒乐。七者见乐。八者坐乐。九者语乐。十者乐家乐。十一者折林也。乐出乐者。若比丘欲时起心乐。欲乐故出精。精出故得僧伽婆尸沙。若故出乐精不出。得偷兰遮罪。若比丘心想而眠。先作方便以脚挟。或以手握根。作想而眠。方梦精出。得僧伽婆尸沙罪。若欲起观不净。以观不净而灭之。心净无垢而眠。若梦精出无罪。是名乐出乐。正出乐者。若比丘眠而梦作欲事。正出而觉而不动根。精出无罪。若正出而动者得罪。若正出自念言。勿污衣席不乐出。而以手捉塞。将出外洗无罪。若有乐心得罪。是名正乐。已复不触无罪。若贪乐更弄出得罪。是名已出乐。欲乐者。比丘欲起而捉女人精出无罪。何以故。为淫事故。得突吉罗罪。若至境界得波罗夷罪。若捉已贪细滑。不入波罗夷境界。精出得僧残罪。是名欲乐。触乐者。或内触或外触。内者。或以手试为强为软。因触故精出不犯。若有出心贪乐得罪。是名内触。外触者。比丘欲心触女身。或抱或摩触细滑精出不犯。以摩触故。得僧残罪。若乐触乐乐出精俱得罪。痒乐者。或癣或疥虫触男根起。痒以手抓之精出者无罪。若根起因势动出犯罪。见乐者。若比丘或见女根。根起而熟视精出。不犯僧残罪。得突吉罗罪。若见已动根精出。得僧伽婆尸沙罪。是名见乐。坐乐者。比丘与女人于静处坐。共语而精出无罪。因静处坐得余罪。若坐欲心起因动腰。得僧残罪。是名坐乐。语乐者。与女人于静处语。女根云何。为黑为白为肥为瘦。作如是语精出无罪。因粗恶语得僧残罪。若语乐有出心动犯僧残。是名语乐。乐家者。比丘还檀越家。以念故。或母或姊妹。以手摩挲或抱。精出不犯。因触故得突吉罗罪。若摩挲故出精犯罪。是名乐家。折林者。男子与女结誓。或以香华槟榔。更相往还饷致言。以此结亲。何以故。香华槟榔者。皆从林出故。名折林。若女人答饷善。大德饷极香美。我今答后饷。令此大德念我。比丘闻此已欲起精出不犯。若因便故出犯罪。又因不出得偷兰遮罪。法师曰。是名为十一。毗尼师善观已。有罪无罪若轻若重。轻者言轻。重者说重。如律本所治者。若如是作善。譬如医师善观诸病随病投药。病者得愈医师得赏。故出不净者。如是为初。心乐出而不弄不动。若精出不犯。若触若痒无出心无罪。有出心有罪。除梦中者。若比丘梦与女人共作淫事。或梦共抱共眠。如是欲法次第汝自当知。若精出无罪。若正出而觉。因此乐出。或以手捉。或两髀挟。犯罪。是故有智慧比丘。若眠梦慎莫动善。若精出恐污衣席。以手捉往至洗处不犯若根有疮病以油涂之。或种种药磨不乐精出无罪。若癫狂人精出无罪。最初未制戒不犯。第一僧伽婆尸沙说竟

尔时佛住舍卫国祇树给孤独园精舍。法师曰。此义前已解。此摩触戒文句者。若有难解者我今解说。于阿兰若处住者。非真阿兰若处。所以非真阿兰若处。所以作非真。在给孤独园精舍后林中故。名阿兰若。此比丘房四面周围当中住处善庄严者。其中巧妙种种玩饰。治欲谋人不思善法。一窗开者。若开一窗余处悉闇。若闭此窗开余窗。此处复闇。如是语已婆罗门尼自念言。此婆罗门意欲乐出家。应覆藏而发露者。所以发露者。欲遮婆罗门出家心故。何处高德作如是恶事。高德者。姓贵德高。亦言大富贵姓。女者。有夫女人。或无夫女。或无子女。淫乱变心者。淫欲入身。如夜叉鬼入心无异。亦如老象溺泥不能自出。淫乱变心随处而着。无有惭愧。或心变欲或欲变心。是故律本中说。淫乱变心心即染着。亦言恋着。以身摩触缚着也。始生者。是即时生也。其儿身犹湿未燥。若触其身者。亦名犯僧残。若过其境界波罗夷罪。若与俱在一静处犯波夜提。如此始生亦如是。何况长大。捉手为初。摩触细滑。此是恶行也。是故律本中说。若捉手。法师曰。今当广说。手者。肘为初。乃至爪。是名手也。又言。从臂至爪。亦名为手。发者。纯发无杂结者。束发也。杂丝者。是杂五色。丝也。发杂华者。瞻卜华为初。杂金银者。或金银钱。或金华或银华。及种种珍宝装严。亦名杂金银。若比丘捉如是发者。皆得僧残。若比丘言。我捉杂发。罪无得脱。若比丘或捉一发亦僧残。除发及手。余处摩触悉名细滑。若比丘捉一一身分悉僧残。此摩滑戒。若捉手若捉发若摩触细滑。分别有十二种。我今当现。捉触为初。律本中说。捉者。不摩触者。不捉不摩。是名触也。捉者。捻置一处。是名捉。余句易可解耳。此诸文句今正广说。若女作女想。比丘欲心以身相触。律中已说。若捉能得僧残。若捉置更捉。随捉多少悉僧残。若比丘以一手摩触乃至一日僧残。何以故。为不动手故。触亦如是。下触者。从头至脚底捉不置亦得一僧残。若放已更捉。随捉多少。一一僧残。上触者。从脚至头亦如是。低触者。先捉女发低头行嗅。随其所作不置。得一僧残。牵者。牵就其身。荡者。荡离其身。捉将者。捉女人去一由旬不动手。得一僧残。若置更捉。随一一捉得僧残。若隔衣捉若隔璎珞捉偷兰遮。若衣穿着肉僧残。人女作人女想僧残。人女疑偷兰遮。人女作黄门想偷兰遮。人女作男子想偷兰遮。人女作畜生想偷兰遮。黄门作黄门想偷兰遮。黄门疑突吉罗。男子畜生作黄门想突吉罗。男子作男子想突吉罗。男子疑突吉罗。男子作人女想作畜生想突吉罗。畜生作畜生想突吉罗。二女者。如是为初。若捉二人二僧残。若捉众多女众多僧残。若众多女聚在一处若总捉。计女多少。一一僧残。若中央女不着衣偷兰遮。比丘以衣绕缚众多女牵去偷兰遮中央女不着衣突吉罗。比丘以绳缚女人衣突吉罗。若女人次第坐膝膝相着。比丘捉着上头第一女僧残。余女突吉罗。若合捉衣第一女偷兰遮。第二女突吉罗。第三女以下无罪。若摩触女人粗厚衣偷兰遮。若女人细薄衣手出摩触僧伽婆尸沙。若比丘与女人。发发相着。毛毛相着。爪爪相着。偷兰遮。何以故。无觉触故。法师曰。以发相系。为得一罪。为得众多罪。如赤身坐卧众僧床。随毛着一一突吉罗。此女不然。一偷兰遮。不得多罪。今说往昔罗汉偈

  处想及触欲　　真实无狐疑
  如律本中说　　重罪汝当知

处者。女也。想者。是女想。欲者。摩触细滑欲。触者。知触女人身。具如此事得僧残。余者偷兰遮。若有欲心摩触女身得僧残。若无欲心触突吉罗。有女人以青衣覆身而眠。比丘欲摩触衣。误得女人身僧残。次至掩句者。无女想以手掩女人身。悉突吉罗。若女人共比丘一处坐。女人淫欲变心。来摩触捉比丘。比丘有欲心动身僧残。法师曰。如是次第黄门男子畜生。罪有轻重汝自当知。若女人掩比丘。比丘以欲心受乐不动突吉罗。若女人或打拍比丘。比丘以欲心喜受。悉突吉罗。若比丘以形相欲心。或摄目或动身动手动足。种种淫想形相变心。悉突吉罗。若女人摩触比丘身。比丘有欲心身不动无罪。求脱者。若比丘有梵行难。比丘推荡牵挽分解得脱一切不犯。若女人年少力壮卒抱比丘。比丘力羸不得转动。随其所作。若临行淫时。比丘觅方便求走得脱无罪。不故者。是不故触女身。或女人度钵。或度种种饮食。相触无罪。无想者。比丘于女人无想。比丘或缘余事。行来相触非故触。如是无罪。不知者。若女人作男子装束。比丘不知捉者无罪。不受者。若众多女人共捉比丘比丘不受乐无罪。最初未制戒颠狂心乱无罪。第二僧伽婆尸沙广说竟

今次随结摩触戒。从身心起二受。乐不苦乐。是名二受。念母者。以念故。触母身突吉罗。女姊妹亦如是。何以故。女人是出家人怨家。若母没溺水中。不得以手捞取若有智慧比丘以船接取。若用竹木绳杖接取得。若无竹木绳杖。脱袈裟郁多罗僧接亦得。若母捉袈裟已。比丘以相牵袈裟而已。若至岸母怖畏未已。比丘向母言。檀越莫畏。一切无常今已得活。何足追怖。若母因此溺势遂死。比丘得以手捉殡殓无罪。不得弃掷。若母于泥井中没亦如是。女人所用衣服悉一切不得捉若捉突吉罗。唯除布施得取。若泥木画女像。一切不得捉。若捉突吉罗。若人布施随处用。一切谷不得捉唯除米。若路游谷田不犯。真珠摩尼车磲马瑙珊瑚虎珀金银琉璃珂贝。此十种宝悉不得捉。若真珠着肉未洗得捉比丘若一切病人施比丘作药。若服涂疮得取。若珊瑚珂贝未磨洗得捉。若金银人合作药得捉。若以金银合和铜锡无金银色得捉。若人以宝作堂。以琉璃为柱。以银为角子。以金缠。如此悉是真宝作堂。比丘欲说法。得上坐住无罪。若一切器仗。比丘悉不得捉。朴未成者得捉。若人施器仗与众僧不得捉卖。唯得打坏随处用。若比丘往战斗处见。此是粪扫器仗。先打坏然后拾取。若得楯破作板杂用。一切乐器不得捉。若未成器者犹是朴得捉。若人布施者。得随意卖。夜叉尼句者。乃至他化自在天夫人亦不得捉。若捉偷兰遮。法师曰。次第文句易可解耳

善见律毗婆沙卷第十二善见律毗婆沙卷第十三

        萧齐外国三藏僧伽跋陀罗译

畜生女句者。龙女迦留罗女。一切畜生女。悉不得捉。捉者突吉罗。度桥句者。或板或竹或木一切桥。比丘与女人共度桥。比丘以欲心动桥。桥动不动突吉罗。树句者。若女人上树或大小树。比丘以欲心动树突吉罗。船句亦如是。绳句者。若比丘捉绳头。女人捉绳尾。比丘以欲心牵绳动偷兰遮。不动突吉罗。或共捉杖竹木。一切犯不犯亦如是。触钵句者。易可解耳。礼拜句者亦如是。第二僧伽婆尸沙广说竟

尔时佛住舍卫国祇树给孤独园精舍。时优陀夷。粗恶语教授。若赞叹亦如是。法师曰。后当说。无惭愧者。女人无惭愧心。心乐者便笑其所作。答言。善哉大德。作种种方便。令比丘生欲心。便语或言。大德非是男子。或言恐是黄门。女人作如是戏笑语。不顾戒者。比丘以欲心。不思虑好恶。便说粗恶语。粗恶者。非法语也。如年少男女者。赞叹二道。得僧伽婆尸沙。二道者。谷道水道。赞叹者。汝有好相或言汝无相未犯。若言谷道水道如此。真是着女想。作是说已得罪。若毁呰言二道。或言二道合。或言长或言短或言偏。如是为初。悉得罪。或乞或求亦得罪。或言愿汝父母何时持汝与我。或言我何时当得汝。作如是语。悉得罪。问句者。汝与汝夫云何作。自答言。汝当如是作。亦得罪。答问句者。我当与我夫眠。云何好夫当念我。比丘答言。如是如是眠不犯。若言汝作淫事得罪。教授句者。亦如是。毁呰句者。汝根相恶有孔无形。或言有形无孔。无血句者。汝水道燥无血。恒出者。是女人水道血恒自流出。塞句者。恒以衣塞水道。不令血出。长崛句者。汝根长崛。出两边者。女根中肉长出有毛。两道合汝二根。此十一句中。长崛共合两根。此三句得僧伽婆尸沙。初句谷道水道与淫法。为初六句。得僧伽婆尸沙。余无形若以淫法相对得罪。法师曰。余文句轻重汝自当知。女作女想。于第一僧伽婆尸沙已说境。颈以下者。从颈下至膝。上者。从脚膝至颈。从膝以下突吉罗。若赞叹衣服镮钏璎珞说法论义为讲无罪。若比丘为比丘尼说法。因说法中便生欲心。作粗恶语僧伽婆尸沙。不犯者。最初未制戒痴狂心乱痛恼所缠不犯。律文句广说竟

今次随结此粗恶语。因身心口起淫性罪身心业。若比丘以欲心方便。欲乐此事假说傍事。若女人解此语突吉罗。若言钦婆罗毛长。或言短或言赤或言黑突吉罗。一切因事而言。若女人解突吉罗。若不解无罪。法师曰。次第文句易可解耳。不须广说。粗恶语竟

尔时佛住舍卫国。时优陀夷。于舍卫国多诸知识者。恒往至知识家。为四供养故。饮食衣服汤药房舍。恶者。最恶恒流出外血出。唾者。便唾女根。作是言。谁用此不净臭处。女言。我有何处不净。何处不好。为衣裳不净。为颜貌丑陋。有何物不如余人。律本中说。已至女边倚看竟。然后而唾。赞叹供养者。以淫欲法赞叹供养己身。或赞其所须淫事。此第一供养。如我等出家。余供养易可得耳。此淫欲供养难得故。名第一供养。得僧伽婆尸沙。又言。我亦刹利汝亦刹利。若共和合。正好无过此也。若如是语无罪。若言我亦刹利。汝可以欲事与我共通。作如是语。僧伽婆尸沙。法师曰。余文句如前说无异。最初未制戒痴狂心乱痛恼所缠不犯。今次随结。文句次第易可解耳。第四僧伽婆尸沙竟

尔时佛住舍卫国。行媒戒。智慧者。大有智慧聪明。了了能疗理家事。不懈怠有惭愧心。语童女者。此男子好。汝可取为夫。复向男子言。此童女极好作。又忠信真实无虚邪心。汝可取为妇。檀越答。大德。我等不甚体悉此人。未知好恶。是谁家儿子。定是何姓何名。那得辄以女相与。若大德教我与。我当遣嫁。若不教与不敢专辄。如此婚姻事大。时克吉凶发遣进止。后日好恶悉委大德。自知故二众者。此女其夫生时。是村众主。其夫死已。故号为故二众。村后者。是村外村后边住也。诸人共相推论。知优陀夷先后贯练嫁娶婚姻。善解进止。悉是其知养。看儿妇者。初至看视依儿妇无异。后便增薄犹如婢使。初至一月悉付嘱家事。过一月已种种驱使。作田取水苦者。是贫穷也。于是优陀夷语檀越。莫苦人女。如此猥使甚不可。檀越答言。我等不与大德共论此事。我是白衣知白衣事。大德是出家知出家法。各不相关。若知白衣家者。此人非沙门。作如是语已仍息。优陀夷便即遣出。汝去汝去。汝莫住此处。装严者。一切金银珍宝。头多者。汉言多色欲人也。能供养者。若女人以音声色触香味。如是一切妙法悉持供养其夫。是名能供养。共赌者。若我等能得此女。汝当偿我。若不能得者。我即偿汝。如律中所说。比丘不得戏赌。暂时者。乃至一刹那。汉言弹指顷。是名暂时。得行媒法则。何以故。随人驱使行媒法故。男女者。女饷男子。比丘传言。此女人念汝。男子答饷。比丘复往女处言。如是如是此男子念汝。女语比丘言。我欲共某男子私通。比丘受语向男子说。还来报女乃至一交会。僧伽婆尸沙。女有十护。父护者。父禁制不听出入。恐虑他事。母护亦如是。父母护检看视。不与余处游戏。亦不听行来出入。兄护姊护宗亲护姓护法护罚护。法护者。是同法人护也。罚护者。若寡女欲与余人私通。先向官说。若许者便通。若不许者不得专辄。犯者罚金输官。故名罚护。物买者。持物赎取。是名为买也。乐住者。是乐同住也。雇住者。以物雇之。家事悉以委付。衣物住者。因得衣裳承住为妇。此是贫穷女也。水得者。因共洗浴以水相灌。共作要誓为夫妇。是名水得。镮得者。以镮安置头上。恒以戴物取镮掷去。汝来住我屋常作我妇。是名镮得。婢取者。自己婢还取为妇。执作者。以直雇赁充家中执作。取以为己妇。是名执作。举旗妇者。竖旗立军往破他国。得他女取为己妇。若白衣遣比丘往他处。某方护女。求此女为我妇。比丘答言善。即往至女所。向女说如是事。女意善。或应或不应。比丘受如是使还报男子信。僧伽婆尸沙。若男子语比丘教语比丘。比丘仍语父母兄弟姊妹。如此使偷兰遮。又法师言。不然。何以故。如律本中说。意欲舍佛。误言舍僧。意欲舍僧。误言舍佛。于戒亦不失。比丘虽语父母兄弟姊妹。亦得僧伽婆尸沙。法师曰。后文句如前无异。故不更说。若众多女遣一比丘传语。语众多男子。比丘受语往说还报女。众多僧伽婆尸沙。不犯者。最初未制戒。若僧使。若因此使往语女言。某甲男子意。欲索汝为己妇。不犯。何以故。由不受说语故。痴狂心乱痛恼所缠不犯。具六事僧伽婆尸沙。一者摇头。二者手印。三者口受。四者摇身。五者受书。六者具此五事。是名为六事。若父母斗诤。父遣母还本家。父后生悔心。语比丘言。我年老旦夕无人侍养。汝可向汝母语还看我。比丘受如是使。语母还报父。悉僧伽婆尸沙。此戒不问知已不知。但受语往说还报。悉僧伽婆尸沙。此是制罪。非性罪具三受。今次随结文句易可解耳。不须广说。五僧伽婆尸沙竟

尔时佛住王舍城竹林迦兰陀林中。此房舍戒。阿罗毗迦者。是聚落名也。此比丘阿罗毗迦聚落中生。故名阿罗毗迦比丘。自乞求者。是自乞求种种材具。欲营造作大房。教作者。教余人作或自作。此比丘舍坐禅诵经恒修下业。无主者。无檀越主。但自东西乞求。自为者。自为己身不为众僧。大房者。此房极大无有齐限。乞求绝多。或乞人或借人。或乞作器或借作器。如是种种或乞或借。除借乞得罪。不得借猎肉捕鱼。二师悉断。余借一切皆净。此比丘所营造作房舍既大。鱼肉难得。恐其因借倩承遣捕猎。所以断。若立房得作田。借犁牛及余耕具无罪。若寺中有拾取残食人。食竟共聚种种戏笑。如是人驱使无罪。若比丘欲作殿。往至凿石家。借作石手为作殿。若得善。若得石柱。比丘问檀越言。此柱云何得竖。若檀越自为竖善。若檀越更与余柱亦得。若檀越答言。无人。或言。自有事。比丘教余处借。比丘复言。我无余知识。若檀越无人。有直与直亦好。若得直将至木师所。若须塼瓦。往至瓦师所。若须刻画。往至刻画师所。若有余直可作床席衣服房舍所须若拾残食人作息正得与食。若无食可入聚落乞来与善。不得与钱直。为房舍非时入聚落乞油。以手覆钵。若到檀越家。檀越问比丘。欲何所须。比丘答言。为房舍作乞油充与作人。食米亦如是说。若得油还付知寺事人。若比丘为折或伤或失或死。比丘悉应还直。若檀越承回施比丘。比丘不得受。若布施寺得受。比丘不得自取。唤净人付之。若借车及房舍所须种种杂物。亦如牛句无异。若比丘病乞药善。白衣见比丘来。即共念言。此比丘已复来乞。各走隐避。或见比丘乞食。各自闭户。应量作者。云何应量作。应量中人三磔手。当佛一磔手。作房内量。长十二佛磔手。内广七佛磔手。若长中减一磔手。广中益一磔手。亦不得。若减广益长亦不得。何况长广俱过量。未竟乃至一抟泥亦犯。若房长六磔手广四磔手。作如是房者无主亦不犯。何以故。以非房故。若瓦房内外上下悉泥犯。若草房不犯。法师曰。定何时犯。为初作犯。为后作犯。为房成毕犯。答曰。初作乃至二抟泥已还。悉突吉罗。最后第一抟泥偷兰遮。第二抟得竟僧伽婆尸沙。泥者。有二种。一者土泥。二者石灰泥。处者。窗牖柱梁栋桁火烟孔处。此是非泥处。比丘应将比丘指示作房处。房主应将比丘为示作房处。房主先当治地平正。犹如鼓面。然后往至僧所。请僧安处房处。第二第三亦如是请。若僧往指示善。若僧不得往。僧差智慧比丘。往看无难处非妨处。此比丘往看已好。如房主所治地善。难处者。虎狼师子下极蚁子。若蚁有窟是中住不得作。若蚁子游行觅食驱逐得作。何以故。为如来慈愍众生及比丘故。妨处者。或人田园。或是道路处。或是怨家处。或是贼处。或是尸陀林处。或是王志护处。如是一切妨处。悉不得作。绕屋四周使得回十二桄梯。桄间一拳肘若回草车。余文句已在律本。不须复说。若比丘自起作大房。无主为身不处分过量。随作房有所造作营理。一一悉突吉罗。若以塼垒壁。随塼多少。一一突吉罗。最后二塼第一塼偷兰遮。第二塼僧伽婆尸沙。屋成泥治竟已结罪污。洒不犯。若作屋余塼泥留置。我后当成偷兰遮。若决定罢心僧伽婆尸沙。若周匝垒壁上不至屋留取明不犯。若作屋留。一抟泥处后当成。有缘事行不作。有客比丘来住。见不成为成彼此无罪。若难处妨处二突吉罗。僧不处分过量。二僧伽婆尸沙。若作屋未成。若施僧乃至一人。若打坏若掷置不犯。若自作自成教他成。教他作教他成。悉僧伽婆尸沙。若二三人共作屋。若一比丘一沙弥悉不犯。何以故。人无一屋分故。若段段分人得一屋分。僧伽婆尸沙。若垒塼作窟。垒石垒土垒木。若草屋乃至过量不处分。亦不犯。有房有难处妨处。僧不指示过量。不得僧伽婆尸沙。有智慧者应解此义。若自为身。作说戒堂温室食堂。如此作不为自己住无罪。若兼为自己住僧伽婆尸沙无罪者。最初未制戒阿罗毗迦比丘无罪。具六事。一者自作。二者教人作。三者不指示。四者过量。五者难处。六者妨处。此戒具三业三受。房舍广说竟

尔时佛住俱参毗瞿私多园中。此房戒中。俱参毗者。此是园名也。瞿私多园者。此是长者子名也。孱那者。此是供养菩萨人也。令大德示房处者。有檀越语孱那比丘言。愿大德示我作房处我为大德作。神庙树者。此是国邑人民朝夕供养。是鬼神住处。生树者。作众生想也。摩呵罗者。有主为身作大房。此房有主。为身得过量作。有主为身作大房。僧不指示有难有妨处。僧伽婆尸沙。余文句如前房无异

尔时佛住王舍城。于竹林园中。时沓婆摩罗子。竹林园者。种竹围绕。竹高十八肘四角有楼兼好门屋。遥望叆叇犹如黑云。故名竹林园。亦名迦兰陀。迦兰陀因缘如前说。故不重出。沓婆是比丘名。摩罗子是王名。此王子出家故。名沓婆摩罗子。此大德年七岁出家。剃发落地即成罗汉。得三达智具六神通四无碍辩。一切声闻所知无不通达。罗汉之中已是第一。入静处者。是处寂静无有喧闹。故名寂静处。从三昧起者。自言。我所修善法今已悉讫。我当为众僧分布房舍及诸饮食。法师曰。大德何以作如是言。此最后身所修已极。当取涅槃。譬如然灯置于风处。不久当灭。此身亦复如是。我当为众僧分布房舍及诸饮食。所以为众僧分布房舍及诸饮食者。见善男子比丘。从远方来问讯世尊。房舍迮狭无有住处。我当以神力化作房舍床席[毯-炎+瞿]氀毾[毯-炎+登]毡褥等物。又一日见诸小比丘恭敬宿德上座让不受前请。以此因缘饮食不时遂成疲劳。我今当令众僧住止安乐。各得所宜。不以饮食为苦。是故分布令其平等。法师曰。大德沓婆摩罗子。于三业之中。何以独修下业。答曰。此是前身宿愿所牵。故有是念。问曰。此沓婆摩罗子。何时发此愿也。答曰。过去有佛。号波头勿多罗。此沓婆摩罗子生一居士家。是时国邑人民。共作大会请佛入国。有六万八千比丘围绕。大会供养七日布施。时有一罗汉比丘。于大众中以神通力。分布床席及诸饮食。是时沓婆摩罗子。见此罗汉比丘。以神通如此。心大欢喜往至佛所。头面作礼却坐一面。而白佛言。愿我后身当来佛时。出家学道速成罗汉。为诸众僧分布房舍床席及诸饮食。如今罗汉神力无异。是时世尊见当来世。此善男子所愿果得成遂不。世尊观来世已。语沓婆摩罗子言。汝从此百千劫已。有佛号释迦牟尼。汝年七岁得出家。剃发落地即成罗汉。名沓婆摩罗子。汝具六神通必得此愿。沓婆摩罗子从此以后。布施持戒得生天上。天上命终下生人间。如是展转乃至释迦出世。从天上下生人间。出家得道。从禅定起。而作是念。作是念已。往至佛所头面礼足。而白佛言。今从世尊乞二种愿。一者为诸众僧分布房舍。二者差会分布饮食。于是世尊答言。善哉。汝贪嗔既尽。堪为此事。汝当为众僧分布床席及诸饮食。此沓婆摩罗子。何以故。从世尊乞如是愿。答曰。为止未来诸诽谤故。于是沓婆摩罗子。受世尊敕已。还所住处。世尊见未来。慈地比丘。因沓婆摩罗子差会分房。必生诽谤。为止诽谤故。语诸比丘。汝当请沓婆摩罗子为众僧差会分房。请竟应作白二羯磨差。同学者。同一法事也。亦言同一法学。若比丘共学修多罗者。为敷床座同在一处。若学阿毗昙者毗昙者共。若学毗尼毗尼者共。若说法者说法者共。若坐禅者坐禅者共。何以故。为避諠闹故。无业无记语者共。无记语者。不修三业食已而眠。眠起洗浴共论世间无记之语。令身体肥壮。问曰。沓婆摩罗子。何以使无业好语者共在一处耶。答曰。使其得住安心道故。因乐道故。得生天上。入火光三昧者。此是第四禅定。从禅定起已。放右手第二指。以为光明。须臾名闻满阎浮利地。诸比丘从远方来欲看神力。至已语沓婆摩罗子言。长老。为我等安止住处敷施床座。沓婆摩罗子问诸大德。乐何处住耶。诸比丘各各答言。我乐耆阇崛山住。又言。我乐雪山边住。又言。我乐天道士山住。又言。我乐郁单越住。如是众多。沓婆摩罗子自随一比丘。为安止住处敷施床座。为余比丘安止住处。悉是化身。如真身无异。安止诸比丘已自还竹林寺住。慈地比丘者。是六群比丘中是第一。恶食者。不得好食。不但恶食。房舍卧具皆悉得恶。问曰。慈地比丘何以恒得恶房恶食。坐其前身无福德故。复于众中最小。是故得恶房恶食。善饮食檀越者。此檀越恒为众僧作肴膳饮食。又一日善檀越入寺。至沓婆摩罗子所问。大德。明日次谁受弟子请。沓婆答言。次慈地比丘受请。檀越闻已心不欢喜。还至家中语其婢言。汝明日为慈地比丘作食。我不知事。莫如前后食。又语其婢言。若慈地比丘来至。于外敷施床席供设而已。勿使其入。昨日者。慈地比丘与同伴集在一处共论言。我等今日应得好食。昨日此檀越来至沓婆所。当是沓婆教语檀越。于外敷施床席及粗饮食。无风风起者。极密处而大风起。水中火者。本是水能灭火。今火从水中出。佛语沓婆。汝忆有作是事不。今慈地比丘有如是言。沓婆答言。唯世尊知我。世尊是一切智。我是漏尽罗汉。何须我言耶。佛复语沓婆言。汝不得作如此语也。若汝有如此事者。于众中言有。若无者于众中答言无。法师曰。世尊何以不直言沓婆无罪。此是慈地比丘尼妄语。答曰。世尊为怜愍众生故。世尊言作我知比丘犯波罗夷。世尊亦言我知汝犯波罗夷。若有比丘犯波罗夷者。必谤世尊。何以故。为世尊随嗔爱。爱沓婆故。不道其罪。嗔我故。今道我罪。世尊定非一切智。因诽谤故。死堕地狱。又为当来无惭愧比丘。实有罪而言无罪。佛不在世。谁知我罪者。是故佛语沓婆言。汝若有作答言有作。若不作答言不作。沓婆答言。实不作乃至梦中亦不为此事。灭摈比丘尼者。灭摈有三。一者灭身。二者灭不同住。三者灭罚。是名三灭摈。云何灭身。答曰。灭作者。是灭身也。云何灭不同住。若犯罪不出。复不舍邪见。名灭不同住。云何灭罚。汝但作罪自然灭。此是灭罚也。此慈地比丘尼。于三灭中自得灭身也。佛语诸比丘。汝等灭摈慈地比丘尼。法师曰。此慈地比丘尼身清净。为人所教作如此谤。教者应灭摈。何以世尊。教灭摈慈地比丘尼。为以其谤故摈。为以其犯罪故摈。若以其有罪摈者。沓婆摩罗子亦应有罪。以其谤故摈者。沓婆无罪。于律本中说。若比丘以无根波罗夷法谤比丘。得僧伽婆尸沙。若比丘以无根波罗夷。谤比丘尼突吉罗。比丘尼谤比丘亦如是。若尔慈地比丘尼得突吉罗。妄语故波夜提。法师曰。以无根波罗夷谤比丘。得僧伽婆尸沙。无波夜提罪。慈地比丘尼犯突吉罗。亦无波夜提罪。所以摈遣慈地比丘尼。以其自言犯罪故。于是世尊从坐起入房。诸比丘即教慈地比丘尼脱法服。觅白衣服与着。驱其令出。慈地比丘。见摈慈地比丘尼语众僧言。我嗔嗔故。教比丘尼谤。此是我罪。莫摈慈地比丘尼。嗔者。转善心也。不喜者。因嗔故失喜心。是不喜亦言心垢。无根波罗夷法者。此无实波罗夷。谤者。于此处不见不闻不疑。不见者。不自以肉眼见。亦不自以天眼见。不闻者。不从人闻。不疑者。不以心疑。有见疑者。有比丘于村外入草中。便曲有女人亦入草中。比丘先从草出。女人复从此草出。比丘女人各不相知。有傍比丘见已。即便生疑心。自念言。此两人岂无非法意耶。是名见疑。闻疑者。闻比丘与女人闇中语声。因此生疑。是名闻疑。疑疑者。有男子女人。将饮食入寺。观看游戏去已。余残饮食处所狼藉不净。未得扫除。明日朝旦有客比丘。来入寺中见此处所。即生疑心。复至旧比丘身有香气。更复疑言。当是昨夜。此比丘与女人饮食。共作非法淫欲也。是名疑疑。慈地比丘不见不闻不疑。而生诽谤。是名无根波罗夷法谤。谤者。欲使彼比丘于清净法退堕。若言汝得波罗夷罪。得僧伽婆尸沙。若教人谤。语语悉僧伽婆尸沙。若遣书如此使书无罪。谤者。有四种。一者戒谤。二者威仪谤。三者邪见谤。四者恶活谤。问曰。何谓戒谤。答曰。四波罗夷法十三僧伽婆尸沙。若以一一谤。是名戒谤。余二不定尼萨耆九十众学。悉是威仪谤。邪见谤者。汝言是身有吾有我。是名邪见谤。恶活谤者。汝以因持戒觅利养。是名恶活谤。复有四种谤。一者现处。二者现罪。三者不同住。四者不共法事。现处者。汝与女人共行淫事。是名现处。现罪者。汝得重罪。是名现罪。不同住者。我不与汝共住一处。是名不同住。不共法事者。布萨说戒自恣一切羯磨不同。是名不共法事。若言汝犯重罪。非沙门非释种子。如是之语得罪。若被谤者言。汝何不礼我。答言。汝非沙门非释种子。若如是答者僧伽婆尸沙。若言法师自知。何假我言。如是语未犯罪。法师曰。谤者被谤者后当广说。谤者共至僧前白僧言。愿诸大德。为我等欢喜判此事。我等亦欢喜奉行。众僧应为判此事。若言众僧为我判此事莫停。若是者我当受持。若不是者我不受。若作如是语者。众僧语谤者言。汝且礼佛为其说法。后当为汝判此事。若迁延至冥。罪人语众僧言。日既冥。我且还所住。众僧答言善。得稣息已。明朝复来僧中求判此事。众僧答言。且还去。如是至三。如是满三已。心软折伏。僧应取此事为判。虽满三请。心犹刚强言语粗强。众僧语言。此处少律师。不得为汝判此事。汝可往余寺求判。众僧问言。汝已求僧未。答言。已求僧教我来此。众僧言。若如是者。此处亦无律师。可余寺更觅。如是次第求觅不得。心软折伏还归本处。白众僧言。我等诸处觅求僧。无人判。愿大德。为我等判此事。我等欢喜奉行。众僧应依法为判。众僧问被谤者言。汝有此事不。众僧应作白羯磨和合灭此斗诤事。若无惭愧者谤有惭愧者。被谤者有智慧。谤者无智慧。若来僧。撤应穷诘此事。此比丘痴顽答对谬僻。僧语言。汝无知不解。何以谤人。汝应共和合还去。莫举此事。若谤者有智慧。以见闻疑罪于僧前能答。众僧应问被谤者。若有罪者众僧应为治。若无罪者僧应答言。汝各自还去。若有惭愧者谤无惭愧者。谤者痴。若来撤僧。僧应方便问谤者言。汝以何谤。以戒谤以威仪谤。法师曰。何以有惭愧者教。无惭愧者不教。众僧便随爱嗔怖痴。答曰。不然。何以故。为欲折伏无惭愧人故。有惭愧者得安乐住故。若教无惭愧人。得势力增长恶法故。有惭愧者无势力。不得安乐住故。是故僧不教无惭愧人。若谤者被谤者。俱有惭愧。众僧应懦软为说法教化言。汝若有相触犯更相忏谢。汝等各还和合共住。若相谤事。众僧乃至满三。教化和合。犹不肯罢。众僧应依法为判。法师问曰。谤法若为初中后。答曰。先作求听。是为初。若撤僧。是为中。若有罪无罪僧为灭。是为后。问曰。谤法有几根有几地。答曰。谤有二根三处五地。何谓二根。有根法谤无根法谤。是名二根。何谓三处。见闻疑。是名三处。何谓五地。一者时。二者真实不虚。三者无嗔以怜愍心。四者有义。五者不随爱怖。是名五地。若问若不问者。以无根波罗夷法谤已。若众僧问。若二三人乃至一人。若于僧前自说成罪。得僧伽婆尸沙。法师曰。诤有四诤。相言为初。诤有何义。证罪为诤此事。是名为诤。此相言诤。为善为不善为无记耶。答曰。亦善亦不善亦无记。云何善云何不善。善者用法论。是名善。用非法论者。是名不善。不以法不以非法论者。是名无记。法师曰。余三诤后当解说。若言汝沙弥汝优婆塞。汝外道汝尼揵陀。汝黄门汝二根人。汝畜生。汝杀父汝杀母。汝杀阿罗汉。汝破和合僧。汝出佛身血。如是为初。得僧伽婆尸沙。狐疑者。于见闻狐疑。疑者二心也。亦言忘前事某时某日。法师曰。余文句易可解耳。若比丘以无根波罗夷法谤。僧伽婆尸沙。僧伽婆尸沙法谤。波夜提。以威仪法谤。突吉罗。若以嗔故不现前谤。波夜提。若以威仪法不现前谤。突吉罗。无罪者。最初未制戒颠狂心乱痛恼所缠不犯。此戒从身心中起。是故律本中说。身业口意业性罪。谤戒广说竟

尔时佛住王舍城。于竹林迦兰陀园中。慈地比丘从耆阇崛山下。见一羊行淫。慈地比丘语诸伴言。我等取羖羊名沓婆摩罗子。取母羊为慈地比丘尼。诸比丘答言。善哉。我今以此法谤沓婆摩罗子。无不为此败。欢喜共去往到僧所。而白僧言。我等见沓婆摩罗子。与慈地比丘尼共作淫事。众僧闻慈地比丘语已。即集众僧共判此事。众僧问慈地比丘。汝定何处。见沓婆摩罗子与慈地比丘尼共作淫事。答言。我等从耆阇崛山下。入聚落乞食。道中逢见沓婆摩罗子与慈地比丘尼共语调戏。众僧问沓婆摩罗子言。此时汝在何处。沓婆答言。在竹林精舍。汝何所作。答众僧言。为众僧分布饮食。谁知见汝。答言。众僧知见。问者。作白羯磨问众僧。某时某时。定见沓婆为众僧分布饮食不。众僧答言。实见为僧分食。众僧复问慈地比丘。汝语不相应。当是方便非真实也。众僧如是三问已。慈地比丘答言。如是实是方便。众僧诃责慈地比丘言。云何以余分事与沓婆。问曰。云何余分。答言。余分者。沓婆是人。羊是非人。以羊当沓婆处。是名余分。以母羊当慈地比丘尼。亦名余分。何以故。以事相似故。是故律本中说。若片若似片。次第文句易可解耳。不须广说。是名余分。同种姓者。有一比丘。同刹利种出家。见彼刹利行淫。谤此刹利比丘言。汝犯波罗夷。众僧问言。汝实见此刹利行淫不。答言。实见。语语僧伽婆尸沙。相名房舍见彼而谤此。犯不犯如前所说。无罪者。若实见犯。最初未制戒。颠狂心乱痛恼所缠不犯。第二谤句广说竟

尔时佛住王舍城竹林精舍。此破和合僧戒中。于是提婆达多。往至拘迦利迦一吒无迦利骞陀毗耶子娑勿陀达多所。至已语诸长老言。我等共破和合僧及如来威德。破和合僧因缘。后骞陀迦中当说。善哉大德者。此是乞语也。愿一切比丘。尽形受在阿兰若处住。此是受头陀法。若比丘还聚落中住犯罪。愿佛为诸比丘如是结戒。余四法亦如是。我等令人知者。佛不随我等制。我等自行此法令人知。我等少欲知足。于是发大善心。佛闻调达乞五法欲破和合僧。佛念言。此人为利养故。必堕地狱。佛念言。我若许调达五法者。多有善男子出家。若受持此法。则于道有难。是故律本中说。止止调达。勿建此法。若善男子。或在阿兰若处或在聚落。随心所乐各不障道。头陀乞食舍粪扫衣半月树下不食鱼肉佛言。除三疑不食。云何三疑。一者见。二者闻。三者疑。云何见见檀越为比丘杀。云何闻。闻檀越为比丘杀。云何疑。疑为比丘杀。若见疑者。云何见疑。比丘从阿兰若处。入聚落乞食。道逢见诸白衣入山行猎。明日聚落作大会。诸比丘于会得肉。心自念言。昨日见诸檀越行猎疑此肉。当是为猎得也。是名见疑。不得食。若檀越言。我本为王及自为行猎。不为比丘。大德但食。若如是者食无罪。闻疑者。比丘在阿兰若处。闻聚落行猎设会。檀越请比丘食。比丘疑心若食得罪。若檀越言。我自为行猎。不为比丘。若如是者食无罪。是名闻疑。若不见不闻不疑。为比丘杀。如是食无罪。有见得食。云何有见得食。若见人屠杀。不为比丘。后若得肉食无罪。是名有见杀得食无罪闻者。比丘自闻杀声。不为比丘。比丘若得此肉。比丘得食无罪。是名闻。疑得食无罪。疑者。比丘入聚落乞食。见新肉疑不敢受。若檀越言不为比丘杀。得食无罪。是名疑得食。若檀越为比丘杀。若不见不闻不疑。得食无罪。若檀越请二人与食。下座心自念言。此当为上座杀。不为我我食无罪。上座复自念言。此当为下座杀。本不为我。我食无罪。若如此者。两各自疑为彼。上下座疑俱食无罪。若人为比丘杀。比丘不知食竟方知。如此者无罪。若比丘得肉食。应问然后食。何以故。为欲分别净不净得食故。熊猪肉相似故。不但熊猪。更有相似者。是故应问。欢喜踊跃者。调达乞五法。世尊不与。调达欢喜自念言。我今定得破和合僧。拘迦利闻语已。心大懊恼。如服毒药无异。调达教化同伴。作如是言。汝何以懊恼。出家求道宜应精进。瞿昙沙门亦有此法。不尽形寿。我今尽形寿受持此法。何以懊恼。同伴闻已欢喜随从。法师曰。调达痴人。已向阿鼻地狱不觉不知。欢喜礼佛而去。还向拘迦利等言。我共汝等。当行此五法令人知。我等少欲知足。多欲无厌足者。衣服饮食受不节量。是名多欲无厌足也。调达语同伴言。瞿昙沙门恒自思念。我声闻弟子云何得衣服饮食不以为劳。此是多欲无厌足人。佛语调达。汝勿乐此法破和合僧。是重罪也。若众僧和合。如水乳合安乐行。若破如是僧者。一劫在阿鼻地狱受诸苦痛。若僧破能令更和合者。一劫在天上欢喜。受梵天福也。诸比丘为调达种种方便说法。诸善比丘见调达破和合僧。以种种方便教化。令其开解。心同身同与僧和合。如水乳合。心同者。心同法。身同者。身同共一和合布萨。云何不同身。虽共一处。心行外法。是名形同心不同。坚持不舍者。执破僧事不置。是名坚持诸比丘谏是比丘者。诸有惭愧比丘谏诸比丘。莫破和合僧。令与僧同住。诸比丘应三谏舍者善。若不舍。第一谏不舍突吉罗罪。第二谏不舍偷兰遮。第三谏不舍僧伽婆尸沙罪。外谏者。诸比丘闻欲破和合僧。往到其所谏言。长老。莫破和合僧。若破僧者甚重。若舍者善。若不舍。捉手牵至僧中语言。汝莫破和合僧。如是三谏。外软语三谏。将至僧中软语三谏不舍。悉犯突吉罗罪。若舍者善。不舍者。应作白四羯磨谏。若初白羯磨不舍。犯突吉罗罪。若作第一羯磨不舍。犯偷兰遮罪。第二羯磨亦偷兰遮罪。第三羯磨不舍僧伽婆尸沙。问曰。第三羯磨。为初得僧伽婆尸沙。为中得。为后得。答曰。最后得。最初犯者。调达是也。问曰。余戒最初不犯。调达亦应不犯。答曰。以其僧三谏不舍故。所以犯罪。法师曰。次第文句易可解耳。不须广说。此戒具三事身心曰意业苦受破和合僧说竟

尔时佛住王舍城于竹林精舍。第二破和合戒中。助破僧者。心乐随从受持其法。别众者。不同布萨说戒自恣。为助破和合僧。令僧不增长。是名别众。我等可忍知者。若其所说我等皆忍皆知。诸长老。莫助破和合僧。当助和合僧。僧和合欢喜不诤。如水乳合。余文句易可解耳。余文句。如前破僧无异。第二破僧竟

尔时佛住拘参毗耶于瞿私多园中。恶性难语戒中。不善行者。种种身业口业。行不善行。长老。何以向我作如是言。此是贡高语也。法师曰。我今解释其义。此恶性比丘。不受诸比丘教语言。汝等不应教我。我应教汝等。何以故。佛是我家佛。何以故。我与揵陟将佛入山学道。不见诸长老一人侍从佛者。佛得道已而转法轮。是故佛是我家佛。法亦是我家法。是故我应教诸长老。长老不应反教我。法师曰。阐那比丘。何以不言僧是我家僧。为与众僧斗诤故。不得言僧是我家僧。诸长老。譬如秋天树叶落地。风吹聚集共在一处。又如水上浮蓱。风吹并在一处。诸长老种种出家。入佛法中亦复如是。是故诸长老。不应教我。我应教诸长老。自身作不可共语者。诸同学比丘。以波罗提木叉教。以贡高故。不受其语。应可共语者。于波罗提木叉中。共说共罪中出故。是以佛法中得增长。次第文句易可解耳。恶性戒广说竟

善见律毗婆沙卷第十三善见律毗婆沙卷第十四

        萧齐外国三藏僧伽跋陀罗译

尔时佛住舍卫国给孤独园精舍。污他家者。有二比丘。一名马师。二名满宿。于鸡咤山住。此是聚落名。此二比丘。恒于此聚落寺中料理寺舍。因营理故。与诸白衣言语来往。无有惭愧。污他家比丘者。此是马师满宿。于六群比丘中最是上座。马师满宿本是田夫。同作田辛苦。二人共论言。我等作田辛苦。可共出家。于佛法中衣食自然。同伴答言。善哉可尔。更共筹量。我等今者就谁出家。当就舍利弗目犍连出家。筹量已。往到舍利弗目犍连所求欲出家。舍利弗目犍连。即为出家与具足戒。诵波罗提木叉竟。满五腊更得二伴。一名黄赤比丘。二名慈地比丘。四人共论言。此舍卫国有时丰熟有时饥俭。我等不宜聚住一处。宜应分张余国。三人语黄赤比丘言。长老汝乐何处住。黄赤比丘答言。我乐舍卫国住。此国邑内人民。有五十七万户。邑外属舍卫国者。有八万聚落。国土纵广一百由旬。汝于此国住处。多种华果树。名庵罗树波那沙树椰子树。如是众多树。瞻卜华树阇提华末利华。如是众多华。以华果诱恤诸居士居士女。诸居士若有乐出家者。汝当度令出家。使眷属增长复问慈地比丘言。汝乐住何处。答言。我乐住王舍城。王舍城国邑人民。有八亿万户。邑外属王舍城者。有八万聚落。国土纵广三百由旬。汝于此国多种华果树。及度人出家如前说无异。次问马师言。汝何处住。马师答言。我乐住黑山聚落。此聚落饮食丰饶一年三熟。次问满宿言。汝乐住何处。满宿答言。我乐与马师共住。汝二人当好料理住处。多种华果树。以诱恤诸居士居士女。此四比丘共相处分已。各还所住。料理住处度人出家。三住处眷属弟子。各有五百人。合有一千五百比丘。黄赤比丘眷属弟子。悉持戒具足。将诸弟子眷属。从佛游行诸国。佛所结戒护持不犯。未结戒犯。三人随所住处。无有惭愧。佛已结戒及未结戒犯。此恶比丘。不应作而作。不应行而行。是故律本中说。种华者。自种或教人种。或一种华或众多华。或自溉灌或教人溉灌。自掘地作池。或教人掘以用贮水。或用洗浴或用灌华。皆悉不善。若为僧作池。若自作不得。教言掘。唯作净语不犯。若为僧作园。及自作园若种树。为荫凉故。皆用净语。若种种华果。诱恤白衣男女。自种教人种。悉突吉罗。若为佛僧种不犯。唯除不得掘地伤种。若为僧种果得食无罪。若无虫水得自灌教人灌无罪。又法师曰。作净语教人种得。云何净语。汝使此树活莫令死。净人随时料理。灌水不得。为白衣贯结华鬘。乃至散华束相着。亦不得除供养三宝。不得舞者。动身下至举手不得。不犯者。或白衣使比丘礼佛赞经咒愿。或使比丘鸣磬集众。布施种种法事。为白衣驱使不犯。余文句在律中。易可解耳。若比丘疾病无汤药。以华果及余饮食饷人。求易汤药不犯。若为白衣驱使初去时。步步得突吉罗罪。若得饮食。咽咽突吉罗罪。下至为白衣传语随问答。悉突吉罗罪。除为五众出家人驱使不犯。若父母疾病。若众僧净人疾病。为觅汤药驱使不犯。污他家广说竟。行波利婆沙已。次与六夜摩那埵。行摩那埵者。汉言折伏贡高。亦言下意。下意者。承事众僧。二十僧中行阿浮呵那。阿浮呵那者。汉言唤入。亦言拔罪。云何唤入拔罪。与同布萨说戒自恣法事。共同故。名唤入拔罪。法师曰。十三僧伽婆尸沙广说竟

次至二不定法。尔时佛住舍卫国祇树给孤独园精舍。时问者。见无人时问优婆夷。汝不愁忧疲倦饥渴也。夫主念汝不。如是作白衣语悉问。见时说法者。见人时便为说法。说法者。或说五戒。或说八戒。或说去还食。或说舍罗食。或说半月食。如是种种为其说法。多子者。此优婆夷生儿。有十男十女。是名多子。多孙者。此优婆夷男女儿。各有二十儿。儿孙合有四百二十人。国中人民。见毗舍佉母多儿孙男女如此。皆共评论言。其是好。若有嫁娶各来迎取。以为法则。此处堪行淫法。坐屏处者。或比丘共女人坐。或女人眠比丘坐。或比丘眠女人坐。或二人俱眠或俱坐。是故律本中说。眼屏耳屏云何眼屏。对无目人前云何耳屏。对聋人前或对聋盲人前。或对眠人前。或对女人前可信语者。此优婆夷声闻弟子。是故律本中说。得果人也。是名可信优婆夷若比丘言。我与优婆夷共坐。若一一罪随比丘语治。不得随优婆夷语治。何以故。见闻或不审谛故。法师曰。我今欲说其事。于摩罗园精舍中。有一爱尽比丘一日往檀越家入屋中坐。优婆夷对比丘。别倚床而立。外有凡夫比丘。入檀越家乞食。遥见比丘与优婆夷相对。谓言。共同床坐谛视不已。爱尽比丘自念言。此比丘当言。我与女人共床坐也。各还所住。乞食比丘欲举其罪。往至爱尽比丘房求听打户欲入。爱尽比丘逆知其心。即以神力从屋栋出。在虚空中坐此比丘入已。遍求觅不得。见在虚空中坐。语爱尽比丘言。大德。有神力如此。何以入白衣家。独与女人共床坐也。爱尽比丘答言。长老。此是独入白衣家罪。长老护我善。法师曰。此见而不谛。是故独入白衣家罪。是故见而不可信。若比丘欲入聚落乐与女人坐屏处。着衣持钵时突吉罗罪若发去时。步步悉突吉罗罪。若至檀越家入屏处坐。波夜提罪。若出已更还坐。一一波夜提罪。若众多女人共坐。众多波夜提罪。若比丘先在屏处。女人来入礼拜问讯不犯。从身心起。第一不定法广说竟

尔时佛住舍卫国祇树给孤独园精舍。露屏处者。非覆藏处。一比丘一女人者。此处无男子。可作粗恶语。除有知男子。余文句如初不定法说无异。无罪者。最初未制戒痴狂心乱痛恼所缠不犯。此戒性罪从身心起。乐受不苦不乐受所摄。二不定广说竟

次至三十尼萨耆。尔时佛住毗舍离国。于瞿昙庙中。听诸比丘受持三衣。何谓为三。一者安陀会。二者郁多罗僧。三者僧伽梨。是名三衣。法师曰。解说三衣。于骞陀迦耆婆品当广说。用余衣入聚落者。入房着异衣。入聚落着异衣。如是乃至九种衣。佛已听我等畜三衣。因此语故。三衣各畜三。便成九衣。欲与长老舍利弗者。时长老阿难言。除佛世尊。余声闻弟子。悉无及舍利弗者。是故阿难。若得袈裟染治帖净。好者奉舍利弗。若得时食。有好者先奉舍利弗。若得非时浆七日药尽形寿药。于中好者亦奉舍利弗。若有诸长者子欲出家。来求阿难。阿难教往舍利弗所。求作和上或作阿阇梨。夫为长者子应供养父母。是故我今应供养世尊。阿难悉作。我今得无为而住。是故舍利弗。恒敬重阿难。若得衣服饮食。于中好者先奉阿难。是故律本中说。欲奉舍利弗。佛问阿难。舍利弗何时当还。阿难答言。或九日还或十日还。问曰。长老阿难。何由知舍利弗九日十日当还。答曰。所以知者。舍利弗欲游行诸国时。来至阿难所。语阿难言。我欲行某国某国。某时某日当还。长老当好供养世尊。慎莫懈怠。若世尊为四部众及天龙说法。时长老好忆持。我还长老当为我说。若世尊觅我时。长老当遣人来报我。舍利弗在诸国。或遣信来问讯世尊。问讯世尊已。往至阿难所。语阿难言。舍利弗令问讯大德。少病少恼安乐住不。问讯阿难已。语阿难言。我某日当还。是故阿难。知舍利弗九日十日当还。是故律本中说。佛告诸比丘。若十日听畜长衣。法师言。若阿难言舍利弗一月半月当还。如来亦应因此结戒。阿难言十日当还。是故如来听十日内畜长衣不犯。问曰。如来何故随阿难语仍结戒。答曰。此是制罪非性罪。是故随阿难语而结。衣竟者。随因缘得衣竟。或望衣竟或望断作者。割截簪缝。是故名作。竟者。众事已讫。是名竟。失衣者。若夺若失若烧若漂若败坏若望断若迦提月过若出功德衣。如是众因缘亦名竟。佛告诸比丘。有八事舍迦絺那衣。何谓为八。一者去。二者竟。三者尽。四者失。五者闻。六者望断。七者出界外。八者共出。是为八。法师曰。此八事骞陀迦别当说。共僧舍者。作白羯磨舍。十日者。时克也。此衣十日内听畜。不得过十日。六种衣中若一一衣者。何谓为六。一者驱磨。二者古贝。三者句赊耶。四者钦婆罗。五者娑那。六者婆兴伽。是名六衣。若一一衣十日内应说净者。若长二磔手广一磔手应说净。若不说过十日犯舍堕。是故律本中说。我听诸比丘说净。衣长八指。是修伽陀指。广四指。此是最下衣。尼萨耆者。汉言舍。此是律法。波夜提罪应忏悔。法师曰。何时尼萨耆。阿留那出时。汉言明相。得罪。若多衣缚束一处。过十日得一罪。若散衣不缚束。计衣多少随得罪。舍已然后忏悔。法师曰。云何舍。如律本中说。佛语诸比丘。汝当如是舍。整衣服偏袒右肩来至僧中。先礼上座长跪叉手。作如是言。大德僧忆念。我比丘某甲。故畜长衣过十日。犯舍堕。今舍与僧。若一衣言一。若二衣言二。若三衣若众多。道言众多。众中了了解法比丘。应作白羯磨受彼比丘忏悔。大德僧听。比丘某甲。故畜长衣过十日犯舍堕。今见罪僧中发露忏悔。若僧时到僧忍听。我受某甲比丘忏悔白如是。羯磨已问彼比丘言。汝见罪不。答言见。汝当来罪莫犯。答言善。然后受忏悔。若舍与一人。舍二人舍三人中。作是言。大德忆念。我比丘某甲。畜长财过十日犯舍堕。今舍与诸大德。波夜提罪今忏悔。三人中一人应白二人言。诸长老忆念。我受某甲比丘忏悔。当忆持。受忏悔者问彼比丘。答对如僧中无异。僧中一人应三唱还彼比丘衣。作是言。此尼萨耆衣。僧今舍与长老。如是三唱。此为作法故舍。众僧下至一人。应还彼比丘衣善。若不还者。犯突吉罗罪。若犯舍堕。衣不舍不忏悔。随着一一突吉罗罪。若一着不脱乃至破。一突吉罗罪。若犯尼萨耆。衣无罪者。于十日内若说净若失。是名无罪。诸比丘自作是念。如来听畜三衣。我今长雨衣尼师檀覆疮衣敷具手巾朱罗波利迦罗衣。不知当云何。为说净为受持。作如是念已往白世尊。佛告诸比丘。三衣受持不须说净。雨衣四月受持。过四月已说净。尼师檀受持不须说净。覆疮衣不须说净。疮差已说净。敷具受持不须说净。朱罗波利迦罗衣受持不须说净。手巾受持不须说净。问曰。三衣云何受持。答曰。作竟染帖净量足然后受持。云何量。僧伽梨郁多罗僧量者。上者减修伽陀衣。下者长四肘一拳肘。广二肘一拳肘。安陀会量者。长四肘一拳肘广二肘。若长广减量作。朱罗波利迦罗衣。汉言杂碎衣。受持三衣者。云何受持。若先受持僧伽梨。舍已受持新者。以身口对大德比丘说。若无大比丘。以手捉僧伽梨自说。若手不捉不成说。应道其名字。法师问曰。所舍三衣。作朱罗波利迦罗衣受持。不须说净。答曰。应说净。尼师檀受持一不得二。敷具青黄赤色有缕毛。多少随得畜。覆疮衣畜一不得过。手巾畜二。朱罗波利迦罗衣。随有多少说受持不犯。床褥荐席隐囊[毯-炎+瞿]氀。悉属房物不须说净。受持三衣云何失。若施人若人若贼夺。若失若罢道。若还作沙弥。若死若转根。若舍若穿若离宿。问曰。云何穿。答曰。穿大如指甲。问曰。云何指甲。最小指甲。若当穿中有一横缕不失。若僧伽梨郁多罗僧。广边八指内穿不失。长边一磔手内穿不失。安陀会。广边四指内穿不失。长边一磔手内穿不失。长广外穿如小指甲大失。若失已过十日犯舍堕。补竟受持。尼师檀覆疮衣雨衣敷具手巾。若受持穿不失。若衣欲破未有穿。或一条或二条。先以物补。然后割却故者。不失受持。若三衣有二重。一重穿一重不穿不失。问曰。袈裟背处欲破。欲转中着两边。云何转而不失。答曰。先取两边合刺连相着。然后以刀破背处开。然后刺缘不失受持。若袈裟大减不失受持。若袈裟小以物裨不失受持。问曰。若浣袈裟色脱失受持不。答曰。不失。若最下量物。长一尺六寸广八寸。此以物补应须说净。若以小物补不须说净。说净有二种法。一者对面净。二者展转净。云何对面净。并缚相着。将至一比丘所。胡跪作如是言。我有此长衣。为净故。我今施与长老。正得赏护不得用。云何得用。若施主语言。此是我衣随长老用。若作是语得用无罪。是名对面真实净。云何展转净。于五众中随得一人作施主。将长衣至比丘所说言。我比丘某甲。有此长衣未作净。为展转净故。施与长老。彼受施者言。大德有此长衣未作净。为展转净故。施与我。我今受。施主是谁。答言。某甲比丘。更说言。大德有此长衣。为净故。施与我。我已受。此是某甲比丘物。大德为某甲比丘护持。用时随意不须问主。是名展转净施。法师曰。若受施已答言善。不知为说不成说净。应更觅知法人就说与前人。云何成就。云何不成就。若言施与大德。若言舍与大德。此是真实净成舍。云何展转净施成舍。若言为展转净故施与长老。若言为展转净故舍与长老。若言为展转净故与长老。随用一说成舍。云何不成舍。若言愿大德受此衣。愿成就大德衣。是名真实展转净施。不成真实净舍。云何成受不成受。若言我取。若言我受。是名真实净成受。云何不成受。若言我当取。若言我欲取。若言作我物。若言成我物是真实净不成受。若请为施主不得不受。若不受者非律行也。法师曰。次第文句易可解耳。若受已不得不还。若不还得突吉罗罪。若受已知非己物。因施方便承匿此物。随直多少得罪。此戒从身心口起。长衣不受持不净施。过十日得罪。不以想脱。知过十日得罪。不知过十日亦得罪。此戒三受所摄长衣戒广说竟

持郁多罗僧安陀会游行诸国者此僧伽梨置既久。而生抚坏。于是长老阿难。按行诸房见抚衣。法师曰。阿难云何见此衣。阿难按行而见此衣。答曰。所以长老阿难按行诸房。若见有败坏者及不净。便自补治扫除。若见有疾病比丘。便随时供养料理。是故阿难按行诸房。与不离宿羯磨者。虽离衣宿而不犯尼萨耆罪。问曰。得几时离宿。答曰。随病未差得离宿。若病比丘。僧为羯磨离衣宿已往余方。若病差欲还。道路崄难不得还。恒作还意。虽病差不失衣。若决定作不还意失衣。若过十日犯长衣罪。若往余方病差。还来至衣所病复发。更欲往余方。承先羯磨不须更羯磨。聚落一界者。此聚落一族饮食共同置衣此聚落。身在阿兰若处。若明相未出入聚落界。不失衣。聚落别界者。住止别。衣在此家。身在彼家宿。失衣。不离肘者。衣在十五肘内不失。若衣在地。身以神力在虚空。失衣。别聚落者。多主。如毗舍离拘私罗那国。此是别聚落。若衣在客舍身在外。若来离衣十五肘内。不失衣。法师曰。次第文句易可解耳。重阁者。或五重或七重。各一界有别界。云何一界。若上下重悉属一主。衣在此重阁。不失衣。是名一界。云何别界。此重阁多人共住。若住处各异。衣在上重。比丘在下重。比丘应往衣所。若不往衣所失衣。是名别界。车界者。若比丘置衣车上。比丘应随逐车行。不得远。若明相未出时。离车十五肘内。不失衣。若出十五肘外。失衣是名车界。若寄衣置车。车若翻倒或败坏。车上物分张多聚。衣随聚处。比丘应往衣边。不得离。树界者。日正中时影所覆处。若树枝叶蔬荫不相连接。衣在日中。比丘在树下失衣。若树枝偏长。衣在枝荫下。比丘在树根。不失。阿兰若界者。如毗梨吒毗林无异。汉言大树。亦如海洲。人所不及处。林界者。若衣在林中。衣在十四肘内。不失衣。海洲亦如是。方十四肘内不失衣。此林若有人来往。无十四肘界。衣应随身。若不随失衣。比丘在阿兰若处。竟夜坐禅。天欲晓患眼睡。脱衣置岸上。入池洗浴。洗浴未竟明相出。此衣便成离宿。犯尼萨耆罪。若未舍未忏悔若着。突吉罗罪。若露身上岸。复犯突吉罗罪。问曰。云何得脱。答曰。若无比丘未得忏悔得着无罪。若见比丘。不舍忏悔随着。一一突吉罗罪。若比丘有舍堕衣。欲将至比丘所舍忏悔。道路值贼夺衣。但忏悔波夜提罪。若遣沙弥或白衣。为比丘持衣行。或避路或眠熟。至明相出失衣应舍。若沙弥或白。衣持衣在前。入不失衣界。比丘亦入不知。谓言界外。明相出。衣实在界内。谓失不失。依止亦如是。若弟子未满五腊。为师持衣随和上行。道路值人说法。因贪闻法故。至明相出。不犯离师罪。何以故。心无决定住故。和上犯离衣宿罪。此戒衣已受持。离宿故得罪。余文句如前无异。离衣宿戒广说竟

尔时有一比丘得非时衣。此比丘欲作衣不足。以水洒日曝牵挽欲令长。世尊按行房舍。见已问言。比丘汝作何等。比丘答言。此衣短欲牵挽使长。非时衣者。夏末一月冬四月是时。余七月是非时。非时施者。僧次得众次。得或独得。僧者一切众僧。众者。或学律众。或学阿毗昙众。或学修多罗众。若不足者。小小不足。得置一月望得者。或于僧中望得。或于众中望得。或于亲友望得。或于知识望得。或于粪扫处望得。或自物望得。是名望得。若有望处。一月内得畜。若过畜犯尼萨耆罪。若二十九日得所望衣细先衣粗。先衣说净。新得衣复得一月。为望同故。若望得衣粗。复得停一月。如是展转随意所乐。为欲同故。莫过一月。法师曰。次第文句易可解耳。若二十九日得所望衣。即日应受持若说净。若不受持不说净。至明相出时。尼萨耆。如是展转乃至十日。得所望衣。即日应受持说净。若不受持不说净。至十一日明相出时。尼萨耆。此戒因缘本起。如第一尼萨耆无异。广说竟

尔时佛住舍卫国祇树给孤独园精舍。时长老优陀夷。遣故二浣故衣。父母亲七世者。父祖高祖曾祖。如是乃至七世。母七世亦如是。父亲者。伯叔兄弟乃至儿孙。母亲者。舅姨乃至儿孙七世。悉是母亲。若女乃至孙。悉是亲也。得使出家。女乃至孙儿染。不得使出家。妇儿染。何以故。非亲故。比丘尼者。从二部僧中白四羯磨受具足戒。是名比丘尼。故衣者。下至经身。是名故衣。浣尼萨耆者。若比丘教比丘尼浣。若作窖暖水觅[卄/燋]钻火。随所作一一。比丘得突吉罗罪。若浣竟尼萨耆。若浣竟欲还比丘。比丘尼自言未净。更为重浣。比丘得突吉罗罪。染亦如是。若染竟使打。随一一比丘得突吉罗罪。若非亲非亲想使浣染尼萨耆。无罪者。若比丘尼自取浣不犯。若使式叉摩尼沙弥尼沙弥优婆塞优婆夷浣染不犯。若使优婆夷浣染。未得浣染。后出家受具足戒已。方为浣染。还比丘。得尼萨耆。若使沙弥尼式叉摩尼浣染。未得浣染。后受具足戒竟为浣染。比丘得尼萨耆罪。若使优婆塞沙弥浣染。未得浣染。后出家受具足戒已。转根成比丘尼为浣染。比丘犯尼萨耆罪。使比丘浣染。转根亦如是。若使比丘尼浣染。浣染已比丘自言未净。重为浣。比丘犯尼萨耆罪突吉罗罪。若使众多非亲里比丘尼浣。众多尼萨耆。若比丘尼。从比丘尼僧得具足戒不从大德得具足戒。如五百诸释女。使此比丘尼浣。突吉罗罪。无罪者。若浣革屣囊钵囊隐囊带腰绳。浣如是物无罪。法师曰。次第文句易可解耳。此戒具足六事得罪。何谓为六。一者身。二者口。三者身口。四者身心口。五者作。六者不以想脱。此戒具三受。浣衣戒广说竟

尔时佛在王舍城于竹林精舍。时郁波罗华比丘尼。住舍卫国。于是郁波罗华。清朝着衣持钵。入舍卫国乞食。乞食已还入安陀迦林白日入定。问曰。比丘尼无独行法。郁波罗华云何独入安陀迦林。答曰。如来未制独行戒。是以郁波罗华得独入。已行者。已行贼法。云何行贼法。穿踰墙壁劫夺人物。以此为业。是名为贼。贼主者。统领诸贼。此贼主先与比丘尼。郁波罗华相识。前行者。贼主盗前而行。见郁波罗华比丘尼畏诸贼侵犯。语诸伴言。汝等可于此路去。诸贼即随贼主而去。从三昧起者。比丘尼初入禅时自誓言。我某时当起。从三昧起已诸贼唱如是言。若沙门婆罗门须者当与。比丘尼心自念言。此林更无余人。唯我一人必当与我。是故比丘尼得取。在寺者。是优陀夷。问曰。何以优陀夷独自在寺。答曰。诸比丘悉随如来入聚落乞食。留优陀夷守护住处。若汝欲与我者当与我。安陀会细[糸*遲]故。法师曰。优陀夷于安陀会少有贪。但欲见比丘尼身故。是以乞安陀会。与已去者。优陀夷三乞已。比丘尼即脱衣与已还所住处。交易者。律本中说。佛告诸比丘。五众同法得共相交易。云何同法。同师戒见共同。是名同法。初欲受突吉罗罪。入手尼萨耆。唯除亲里比丘尼不犯。非亲里式叉摩尼沙弥尼优婆私不犯。不犯者。若比丘为四众说法。欢喜布施无罪。若非亲里。比丘尼掷去。粪扫取不犯。从一部众受具足戒非亲里比丘尼受。突吉罗罪。从二部众受具足戒非亲里比丘尼受。尼萨耆波夜提罪。若以少物交易得多不犯。余文句易可解耳。不须广说。此戒具六事。制罪具三受。如前受衣戒广说

尔时佛住舍卫国祇树给孤独园精舍。忧波难陀释迦子者。释种出家有八万人。忧波难陀最为轻薄。而性聪明音声绝妙。涉远路者。众多比丘从娑翅多往舍卫国。于中路遇贼劫夺衣物。捡问者。汝裸形外道乃有好心。答曰。我是释种沙门。非外道也。诸比丘闻言是沙门。往白优波离。大德。可往捡问。优波离即往捡问。汝几腊。何时受戒。师僧是谁。云何受持三衣。问已知是比丘。得从非亲友檀越乞衣。若无乞处。以草障身入寺。不得裸形入寺。法师曰。我今次第说。若比丘道路行见贼。持衣钵与年少令走避。若贼逐年少失衣。上座若下座。随得一人。折取草及树叶。付与余人。使得遮身向寺。白衣见比丘遭贼裸身。持白衣衣与。或与五大色衣。得着无罪。是故律本中说。有比丘着白色衣。或着上色衣。或着不割缕衣。得着无罪。此是何人。若有智慧当思此义。答曰。此是遭贼失衣比丘。若有比丘遭贼失衣。得着外道衣。外道衣者。若鸟毛衣或木板衣。得着无罪。然不得转见受邪见法。若失衣比丘入寺。若有僧衣者与僧衣。若属房衣比丘入房住。若不入房住。得以此衣与。若无衣得以敷具隐囊坼与比丘着。若破坏不须偿。若檀越施衣。应还僧衣。失衣比丘入寺。若无僧衣。得从非亲里居士乞。失衣比丘得自乞。为他乞不犯。唯不得乞金银。法师曰。余次第文句易可解耳。不须广说。此戒从身心起。具三受。从非亲里乞衣戒广说竟

善见律毗婆沙卷第十四善见律毗婆沙卷第十五

        萧齐外国三藏僧伽跋陀罗译

尔时佛住舍卫国祇树给孤独园精舍。多将衣者。檀越闻比丘失衣。人人与衣。自恣请者。檀越语比丘言。若有所须随意取是。名自恣请。上下衣者。安陀会郁多罗僧受僧伽梨。是故律本中说。若比丘失三衣。得受上下衣。余一衣余处乞。若失二衣。得受一衣。若失一衣不得受。若比丘尼失五衣。得受二衣。若失四衣。得受一衣。若失三衣不得受。若亲友。若自恣请檀越。若自己物。随意受。此戒具六事。非想得脱。此是制戒。身业口业具三受。上下衣广说竟

尔时佛住舍卫国祇树给孤独园精舍。衣直者。金银钱。若檀越檀越妇。欲持直为比丘买衣。比丘知已即往劝言。若为我作衣者。当使细致长广。教益直者。下至十六分之一。教致织者。下至增一綖。若得此衣尼萨耆罪。若檀越欲作大。劝使小。欲多直买。劝令少直。若随檀越作。如是得衣无罪。若亲里。若自恣请檀越。如是劝作不犯。若为他劝益不犯。法师曰。次第文句易可解耳。不须广说。第二非亲里居士。为比丘办衣价。多居士为异。余文句如前戒说

尔时佛住舍卫国祇树给孤独园精舍。语居士言。汝可持此衣直买衣与某甲比丘。如是语已。五十伐者。伐五十迦梨娑槃直待大德者。大德。我今日有事。愿大德待过今日。明日当与。王臣者。食王俸禄。是名王臣。遣使者。遣人送也。将者将至比丘所。取净者。若得净物我当受也。净物者。衣服汤药。是名净物。若守僧房者。为僧驱使人也。已令知者。我已语守房人。若大德须衣。往其所当与大德衣。居士我须衣者。告令知也。随解语知也。第二第三亦如是索。若得者善。若不得者。第一第二第三。乃至第六在前默然。云何默然者。口不语立不坐。若檀越唤教坐。不得坐。若与饮食。亦不得受。乃至饮亦尔。若请说法咒愿。悉不得为说。若檀越问言。以何因缘来至此。答言。居士自当知。若得者善。若不口语索。得十二默然求。若一语索。破二默然。二语索。破四默然。若三语索。破六默然。乃至六语索。破十二默然。若更往索。得衣者尼萨耆。若一日一往一索。如是得六日往。若一日一往六语索。后不得更往索。亦不得默然。若不得衣。随衣价来处。往语言。我于汝财竟不得用。汝自知莫使失。若不得衣。应自往报衣主。不得使人往报。若使人报犯突吉罗罪。法师曰。执事人有二种。一者指示。二者不指示。指示有二种。何者二种。一者比丘指示。二者使者指示。不指示者。复有二种。一者自不现前。二者他不现前。是名四执事人。法师曰。云何使者指示。答曰。若有居士为比丘买衣。使者往至比丘所。使者到已语比丘言。大德。某居士遣我送衣价。愿大德受。比丘答言。此是不净物。比丘不得受。使者复言。大德。有执事人不。比丘答言无。使者自觅执事人。得已将至比丘所。语比丘言。此人能为大德作执事人。即持直付执事人。使者对比丘前语执事人。汝可持此直买衣与比丘。若有执事人。比丘语使者言。执事人在某村某处。名某甲。使者往至执事人所。语执事人言。汝可持此直买衣与某甲比丘。付已还至比丘所。语言。大德所示执事人。我已付衣直。大德须衣往取。使者付衣直已。若不自来报比丘。遣人来报语比丘言。大德所示执事人。已付衣直。大德须衣往取。当与大德衣。是名四种执事人。是故律本中说。比丘若有执事人。信心敬法。可以直付之。若汝等须衣。当往取。当取净物。不受金银。以此因缘方便。可得受金银。除此无受金银法。若使者语执事人。可持此直买衣与某甲比丘。比丘付执事人衣直已。不报比丘。比丘不得就执事人求衣。若求得衣突吉罗罪。若有居士。持金银往比丘所。语比丘言。持此金银与众僧。愿大德受。为作僧伽蓝。作食堂若园田。比丘不得受。若受得突吉罗罪。教令付净人。后得为处分料理。若使人不解。比丘得教净人为受。后得随处处用。若居士持金银布施众僧。教作饮食衣服汤药卧具。不得自受。若众僧受金银。后得饮食衣服受用。得突吉罗罪。若众僧不受。居士不解将还。知律比丘路见语言。汝与众僧何以将归。居士闻已解。即还付与净人。若居士布施随处用。比丘不得回换。若回换余用者。突吉罗罪。若施作房舍住处无食。众僧各欲散去。无人守护。得减房直籴食。以供守房舍人食。若如此回换用者无罪。若四方众僧房舍物。若住处无食。众僧欲散去。得减房物以供食用得。何以故。为守护住处故。虽尔不得尽用。若居士布施田池。比丘不得受。云何不得受。比丘语居士言。比丘法不得受田池。居士语比丘言。此田池中能生四种净物。用供养众僧。若如是者得受。若居士言。以池布施众僧。使洗浴浣濯。及一切众生饮随意用。若如是施池得受。若居士不解语。但言施池。比丘答言。出家人法不听受池。若布施净水当受。居士答言。善哉大德。本施水。如此言得受。若居士犹不解语。但言布施而已。于后命过。比丘不得受用。若居士有儿孙。比丘应教儿孙布施。若断种无儿孙。可向聚落老宿言。此居士不解布施。命已过。比丘不得受用。长者自知。长者语比丘言。弟子以水布施众僧。若如是布施者。比丘得受用无罪。不得受金银钱。若居士持米布施。及甘果衣服饮食。一切得受。若居士自施净食得受。不得自为身教居士及请人作饮食。若得亦不得食。法师曰。往昔有一比丘。在质多罗山住。欲得[麩-夫+并]食。出庭前见诸居士。以水泥地现为[麩-夫+并]相。发口言。云何得如是[麩-夫+并]明日供众僧。居士即解已。便还家中作如是[麩-夫+并]。明朝持来供养众僧。上座知不受。诸下座见上座不受。亦各不受。往昔知足比丘。现相如是。犹不得食。况今为身求而得食也。布施园不得受。如前说无异。若布施阿兰若处及林得受。后人破林为田。得米甘果饮食得受。若不与不得强责。若前破林为田人罢。后人来作。应责直。何以故。为己成田故。若有人欲赁田。不得受金银。净物得受。若赁田人不知处所问比丘。若有知畔齐。应示处所。若不知勿妄示也。若有人布施众僧奴。不得受。若言施净人或言执事人得受。若众僧净人。若朝为众僧作食。中后自营觅。中前得与食。中后不得与食。衣一切不得与。若半月为众僧驱使。得与衣食。半月自作。众僧不得与衣食。若都不为众僧执作驱使。自为己营觅。后得直与众僧得受。若不与不得就责也。若施牛羊不得受。若言施乳酪等五味得受。余一切畜生亦尔。法师曰。次第文句易解耳。王臣戒因缘本起。身心口业三受。此是制罪。不以不知故得脱

尔时佛住阿罗毗城。憍赊耶敷具者。平地布置。以酢浆洒杂者。乃至杂憍赊耶一毛尼萨耆。憍赊耶毛者。糸中微细者是也。此敷具是毡作。非织物也。法师曰。次第文句易解耳

尔时佛在毗舍离城于高阁讲堂。纯黑羺羊毛者。不杂余毛。次第文句易可解耳。不须广说。纯黑羺羊毛竟

尔时佛住舍卫国祇树给孤独园精舍。安边者。以少白毛置边也。律中已解。不须广说

尔时佛住舍卫国祇树给孤独园。除病比丘者。若病比丘欲往余处。嫌卧具重不能将行。众僧为羯磨。得作新卧具。若病未差得随意作。若病差已更发。不须更羯磨。得用先羯磨。法师曰。次第文句易可解。不须广说

尔时佛住舍卫国祇树给孤独园精舍。尼师檀戒中。诸比丘我欲入静处三月日。法师曰。世尊何以入静处三月日。世尊遍观众生。于三月中无得道者。是以入静处三月。我入后当有如是事。比丘既闻我语已。必立非法制。优波斯那朋健陀子。当破此制入至我处。我见已当得赞叹。因优波斯那朋健陀子。多比丘受头陀法。来得见我。我静处三月竟。将诸比丘按行诸房。见尼师檀处处狼藉。因尼师檀。我当为比丘结戒。世尊作是念已。即静处三月日。于是优波斯那朋健陀子佛至往所者。长老优波斯那。与弟子年未满二十受具足戒。得突吉罗罪。于骞陀迦中呵责言。汝痴人。汝未满十腊。云何而辄与未满二十年人受具足戒。复不解教授。乃遣余人教授。优波斯那。得呵责已。礼佛而去。心自念言。我是善男子出家。非恶心出家。云何为弟子故。而得呵责。我当去十由旬住。教授弟子令威仪齐整。如我无异。然后往问讯世尊。因弟子威仪如法故。而得赞叹。是故律本中说。佛问比丘。汝心乐着纳衣不。比丘答言实不乐着。为随师故着。佛即赞言。善哉善哉优波斯那。善能教授弟子威仪具足。佛告诸比丘者。佛见尼师檀处处狼藉。佛告诸比丘。信心布施使得受用。莫令损失。佛已种种方便者。佛已无数方便为诸比丘说法。故尼师檀者。下至一经坐。是名故也。取少许者。四边随取一边。或方或圆取帖新者上。若不能帖。细擘杂新者作亦得。法师曰。余次第文句在律中。不须广说。因缘本起如前。尼师檀戒竟

尔时佛住舍卫国祇树给孤独精舍。担羊毛戒。弄者。居士道路逢见比丘担羊毛。问言。大德。担此羊毛何处去。何处贩卖也。卖堪几直。比丘闻诸居士戏笑弄已。比丘行至寺已嗔恚掷地。诸比丘问言。大德。何处将此羊毛来。而嗔恚掷地。比丘答言。我为此羊毛故。为诸居士之所调弄。是以嗔恚掷地。自担者。以郁多罗僧裹而自担也。过三由旬者。自担过三由旬。无人代也。随毛多少。一一犯尼萨耆罪。至三由旬已放地。若以杖拨。或以脚转。过三由旬。皆尼萨耆罪。至三由旬。若虎狼贼难担出三由旬。悉尼萨耆罪。若三由旬内为贼劫夺。劫夺已后还比丘。比丘复得担三由旬不犯。无罪者。钦婆罗尼师檀已成毡不犯。三由旬内不犯。至三由旬已。有人代担过三由旬不犯。担羊毛者。下至塞耳过三由旬犯罪。法师曰。余次第文句易可解耳。不须广说。此戒从身心起。不以不知故得脱。羊毛戒广说竟

尔时佛在释翅瘦迦维罗卫尼拘律园。浣羊毛戒者。妨废坐禅诵经者。比丘尼由为六群比丘浣染擘羊毛故。是以妨废。余文句易可解耳。浣染擘羊毛戒竟

尔时佛在罗阅城耆阇崛山中。金银戒者。金者。珂琉璃珊瑚一切诸宝及贩卖之物。是金银种类。是故律本中说。下至树胶钱国土所用。皆不得捉。亦不得教人捉。悉犯。若为身捉。尼萨耆。若为僧若为众乃至一人若为像捉。悉突吉罗罪。无罪者。不自受不教人受。若居士持金银布施比丘。比丘答言。不得受。居士复言。大德。我舍心布施已定。不得将还。放地而去。比丘见居士去已。比丘留守看。又有居士见比丘住此。往问言。大德。何以住此。比丘答言。有居士布施此金银。比丘法不得受此。居士向比丘言。大德。大德既不得受。布施弟子。比丘默然。居士承取持去。后居士以此金银。易饮食衣服净物与比丘。比丘得受。若无解法人。金银在屋中闭户莫使失。若有卖衣钵人。比丘唤来示金银。语卖衣钵人言。贫道须此衣钵。有此金银。居士自知。若无卖衣钵人。有卖非时浆七日药尽形寿药。将来至金银所。语言。有此金银。众僧须此药。居士自知。得药已众僧得食用。金银主比丘不得食用。余白衣净人乃至畜生。悉不得食。何以故。为众僧物故。若不得药。金银主置而去。更无方便得受。若见优婆塞。唤来教掷去。优婆塞言。此金银何以掷去。我当拾取。比丘答言。随意。若优婆塞解法。持易衣钵来与众僧得受。若无优婆塞可教掷去。众僧应白二羯磨。一比丘知五法者。将此金银使闭目掷去。莫记处所。若记处所突吉罗罪。受施用有四种法。云何为四。一者盗用。二者负债用。三者亲友用。四者主用。问曰。云何盗用。答曰。若比丘无戒。依僧次受施饮食。是名盗用。云何负债用。若比丘受人饮食衣服。应先作念。若不先作念而受衣食。是名负债用。若有聪明智慧信心出家比丘。至受食时。口口作念。若钝根者。未食时先作一念。若钝根比丘受用衣时。应朝先作一念。利根者着著作念。房舍床席卧具一切受用信施。应先作念。若不先作念。是名负债用者。若不为障寒障热及障惭耻而用衣。若不为饥渴疾病而受饮食汤药。亦名负债。若受饮食衣服。不先作念突吉罗。云何亲友用。七学人受用施物如子受父物无异。是名亲友用。云何主用。真人罗汉受用施物。法师曰。于四种受用中。盗用最恶。复有四种受用。云何为四。一者有惭愧用。二者无惭愧用。三者有法用。四者无法用。云何有惭愧用。无惭愧人亲近有惭愧人受用无罪。是名有惭愧用。云何无惭愧用。有惭愧人亲近无惭愧人受用得罪。是名无惭愧用。有惭愧人亲近无惭愧人。后必当随其作恶。故名无惭愧人。无惭愧人亲近有惭愧人。后必当改恶修善。是名有惭愧人。云何有法用。若有惭愧人用法而得。是名有法用。云何无法用。无惭愧人不用法而得。若得此物。如得毒药无异。是名无法用。法师曰。余次第文句已在律中。不须广说。此是制罪。身口心业三受。受宝戒广说竟。贩卖宝戒者。非一种作者。或已成器或未成器。头物者。华钗一切头所用。悉是头物。镮钏钳锁种种身所装束。是名成器。已成器易未成器。以未成器易已成器。以突吉罗易尼萨耆波夜提。以尼萨耆波夜提易突吉罗。问曰。云何以突吉罗易尼萨耆波夜提。答曰。以铜钱易金钱。亦得尼萨耆波夜提。是名突吉罗易尼萨耆波夜提。以金钱易铜钱。是名尼萨耆波夜提易突吉罗。若以宝易铁。以此铁作钵作斧。随作一一作器。悉不得用。若用突吉罗罪。法师曰。余次第文句易可解耳。因缘本起如前戒无异种种贩卖戒。律中已解。更无异义。不复重出。若畜长钵过十日。尼萨耆波夜提。尼萨耆钵。不舍不忏悔。若用突吉罗罪。无罪者。未满十日若说净若受持。法师曰。新钵几薰堪受持。答曰。若铁钵五薰堪用。若土钵二薰堪用。若买他钵。未还直不得受持。若钵主言。但用然后还直。钵主虽作此语。亦不得受持。还直然后受持。若买钵已度直竟。钵主为薰竟报比丘。比丘不往取。过十日犯舍堕。若钵主薰竟。人知薰竟。传向比丘道。比丘虽闻语过十日不犯。要听钵主报。后过十日对人说受。若无人得独说受。若失受持者。罢道死转根舍穿。是名失受持破穿如栗米大。失受持。若以铁屑补得受持。因缘本起如前无异。长钵戒广说竟。舍卫国五种药者。生酥熟酥油蜜石蜜。酥者。一切净肉乳亦可饮。酥亦中作药。问曰。七日药蝇蚁落中。得服不。答曰。漉去得服。若今日受酪说。酪中酥为七日药不。即欑酥至第七日欑得酥。此第七日得服。若至第八日尼萨耆。油石蜜亦如是。若非时受酪非时欑。若非时受酥。不得服。油石蜜亦如是。若鬼病须生肉生血得差听服。唯除人血不得服。若得酥已说内置器中。此器已盛酥。器中有酥出。与新酥共合。应更说。若酥至第七日若失。若与白衣沙弥。若还与酥。若沙弥布施。得食无罪。未满七日布施沙弥。至第八日若有急须用。得就沙弥乞食无罪。法师曰。余文句已在律中。不须广说。此七日药戒广说竟。此是制罪非性罪。从身心起。舍卫国佛听雨浴衣者。于骞陀迦。因毗舍佉母故。听受雨衣。余一月未至夏者。应作雨浴衣浣染缝治。四月十六日雨浴衣浣染裁缝。不须说净亦不得用。五月一日受持用竟。雨时四月合春末十五日。一百三十五日用。若春末月不得雨浴衣。又夏方得即受持用。非求雨浴衣时者。从九月半至四月半以还。此非求雨浴衣时。若求尼萨耆。若有雨浴衣不用。裸形洗浴突吉罗罪。四月十六日求雨浴衣。不足。若有望得处得停置。为足故。若得足者应受持。若不足得停置。乃至九月半不须说净。若受迦絺那衣。得停至正月半。不须说净。若三衣不足。回用作袈裟。若少不足。有望得处。得停至一月。若足者作衣。若不足。应说净若受持。若不说净不受持。至三十一日尼萨耆。无罪者。若少者从亲里乞。若自恣请檀越乞不犯。法师曰。余次第文句。律中当广解。不须重说。恐怖戒者。住阿兰若处有二种。一者长在阿兰若处。二者三月在阿兰若处。比丘阿兰若处住。衣服败坏。得还聚落僧房住。为治护衣故。若治护竟。还复阿兰若处住得。迦提月贼者。迦提月无雨秋贼起。见诸贼杀人夺物。比丘恐怖者。畏失三衣。三衣中随一一衣寄聚落中。恐怖者。若自见贼若闻人道。是名恐怖。若阿兰若处众多房舍坚密。不须寄衣聚落。寄衣已六夜一往看。见衣已还阿兰若处。除僧羯磨。法师曰。余次第文句。律中已说。不须广解。回施者。檀越饭佛及僧欲施衣。比丘自回向已。初教回向已突吉罗罪。得物入手尼萨耆波夜提罪。若回施与他乃至畜生。欲与此畜生。回与彼畜生。得突吉罗罪。欲供养此像。回与彼像。悉突吉罗罪。无罪者。若不知与僧。法师曰。三十事广说。究竟无遗余。次至九十事。汝等一心听。妄语戒中诃多者。此是大德名也。释种出家有八万人。诃多亦在其中。性好谈论。与外道论义时自知理屈。便违反前语。若外道好语时。便回为己语。自知理僻言是外道语。若克时与外道论议。语外道言。中后当论议。自中前来。语诸檀越言。即时论议自上高座语诸檀越言。外道那得不来。必当畏我。是故不来。自下高座而去。中后外道来。觅比丘不得。便呵责言。沙门释子言知正法。云何故妄语。妄语者。口与心相违。亦名空语也。不犯者。欲说此误说彼。妄语戒广说竟。此是性罪。毁訾语者。欲令彼羞也。无罪者。唯除教授。此是性罪。毁訾语广说竟

两舌者。若两舌斗乱比丘比丘尼波夜提。余三众突吉罗。白衣亦突吉罗。此是性罪。两舌广说竟。同诵句者。有四种。何者为四。一者句。二者随句。三者随字。四者随味。何者为句。偈中句一句。是名一句。何者随句。次第二句。是名随句。何者随字。随文字而说是名随文字。何者随味。同字异义。是名随味有字义味。是名为句。若教未受具戒人诸恶莫作。未受具足戒人同声而诵。波夜提。若师言诸恶莫作。未受具足人抄前。而诵诸善奉行。同声而诵。师得罪。师言诸行无常。弟子言无常。亦得波夜提。若长行同者。随字得罪。佛语者。一切律藏阿毗昙藏修多罗。此是佛语。声闻语者。阿能伽那正见经。阿[少/兔]摩那经。周罗卑陀罗。摩诃卑陀罗。是名声闻语。梵志语者。一切外道梵志一品。是名梵志语。天人语者。魔王梵王帝释一切天人所语。是名天人语。同诵不犯。法师曰。若佛涅槃后迦叶为上座。五百罗汉所集三藏。若共未受具戒人同诵此法者。得波夜提罪

若法师所撰文字共同诵者不犯。法师曰。同诵戒广说竟。不前作念者。临欲眠时。应先念佛念法念僧念戒念天念无常。于六念中随一一念。若不如是念。是名不前念。露身者。临眠不先作念。心即散乱。是故露身种种音声。或如鸟声或如牛马声。诸优婆塞闻已皆生讥嫌。云何出家人。作如是眠。佛因是事。为诸比丘结戒。自今以后。不得与未受具足戒人同房宿。时罗睺罗闻佛结戒。护持不犯。是故罗睺罗入佛厕。以袈裟敷地而眠。罗睺罗所以入佛厕屋者。以净洁多人以香华供养。是故入中而眠。明相未出。如来上厕先謦欬作声。罗睺罗在内亦謦欬作声。佛知而故问。汝是谁。答言。我是罗睺罗。佛因罗睺罗故。念诸沙弥开得二宿。法师曰。云何房不得共宿。一切覆一切障。乃至以衣幔作屋亦犯。壁者。乃至高一肘半。亦名为壁。共宿犯。若多房共一户亦犯。除别有户不犯。第三明相未出避去。若不避者全三宿亦不犯。第四宿初夜不得。若胁着床波夜提罪。若屋少覆多障不犯。多覆少障亦不犯。若四周屋各向里开户。共一大户出入亦犯。若别有户不犯。若过三宿比丘眠。未受具戒人眠。得波夜提罪。若未受具戒人眠已起更眠。随眠多少得波夜提罪。若未受具戒人过三宿。未受具戒人眠比丘眠。俱波夜提罪。若比丘起已更眠。随眠多少。众多婆夜提罪。若屋相连接大。乃至一由旬。同一户出入亦犯。屋若有龟鳝窟。止穿外边里边不通。不犯。若屋多覆半障突吉罗罪。多障半覆亦突吉罗罪。法师曰。余次第文句易解。不须广说。同宿戒广说竟。共女人同屋宿戒者。作福德舍。拟去来人止宿也。共女人同屋宿戒已在律中。不须广说。为说法者。或说三归五戒。或说天堂地狱。除有知男子者。是人男非鬼畜生。若有知男子过五六语亦不犯。五六语者。若比丘为说五六语无罪。五六语者。一偈一句若声相连不断。一波夜提。若句句断。句句波夜提。一句经文五句义疏合成六句不犯。若过波夜提。有众多女人。为一女人说法竟。复为第二第三女人说。第一女人复来听。虽过五六语不犯。答问者。若女人问长阿含中事。比丘随问而答。乃至尽阿含亦不犯。法师曰。余次第文句易可解耳。不须广说。因缘本起如前戒。为女人说法广说竟。此圣制戒前。第四波罗夷已广说竟。此中不异。实得过人法。向未受具戒人说故。得波夜提。过人法向未受具戒人说竟。粗罪者。四重十三。是名粗罪。除比丘比丘尼。向未受具戒人说。波夜提。除僧羯磨者。羯磨在某处某处说。若非所羯磨处说。波夜提。除四重十三。若说余篇罪突吉罗。法师曰。余次第文句已在律中。不须广说。粗罪戒竟。掘地戒者。真地非真地今当分别。真地者。无有沙石瓦砾。纯土。是名真地。非真地者。多有沙石瓦砾沙土。是名非真地。若地被烧。亦名非真地。若地有沙石。云何知可得掘。应取少土以水淘看。若四分石一分土可得掘。若石上土厚四寸燥得取。若雨已经四月不得取。若比丘掘生地。掘掘波夜提。若比丘语净人言。汝为众僧掘地及斫木不犯。若指示教掘是斫是波夜提。若画地或作字波夜提。若把火烧手掷地不犯。余文句在律中。不须广说。掘地戒广说竟。此是制罪。从身心起。不受语。是旷野比丘不受鬼神语。因斫树故。伤鬼子臂。鬼作是念。不应专辄杀出家人。当往白佛。佛闻此事当为比丘制戒。往至佛所具白此事。世尊闻已即说偈言

  若人嗔心起　　譬如车奔逸
  车士能制止　　不足以为难
  人能制嗔心　　此事最为难

佛说偈已。此树神即得须陀洹道。佛知树神无住处。以天眼观见树无主者。语树神言。汝可依此树住。问曰。此树在何处。答曰。此树在给孤独园。树神得住止处。心自念言。世尊大慈赐我宫殿。自今以后供养世尊。尔时佛为天人说法。若有大天人后来。前小天人次第退坐。乃至海际。尔时得道树神退。依树而住听佛说法。佛昼日为四部众说法。初夜为比丘说法。中夜为天人说法。后夜为龙王说法。云何知之。中夜天人来打户扇上头。后夜龙王来打户扇下头。是故天龙之异。树者。生树也。村者。此树八微合成。名之为村。树有五种。阿梨陀者。黄姜也。忧尸罗者。香[卄/(ㄙ*ㄙ)/ㄆ]也。贸他致吒者。是雀头香。卢揵者。黄连也。陀卢者。外国草名也。舍摩者。是菩提树也。婆罗醯者。贝多树也。此二种。树唯见交广。有余方不见。稣摩那华者。其华香气。与末利相似。末利华者。广州有其华腾生也。稣罗婆者。不得此草名也。菩醯那。是外国草名也。树有二种。一者水生。二者陆生。优钵罗花莲华浮蓱水生。若水中翻覆得突吉罗。若离水波夜提。若须华果。得攀树枝下使净人取。不犯。不得令枝折。若树高净人不及。比丘得抱净人取。不犯。若树压比丘。得斫树掘地以救其命。不犯。伤草木戒广说竟。此是制罪。从身心起。余语戒者。以作恶行者不应作以作。身口得罪。覆者。不欲令人知。谁得罪者。法师曰。今当释其义。若有余比丘问。长老得罪。将至僧前共判此事。于僧前答言。谁得罪。余比丘语言。长老得罪。答言。我得何罪。比丘言。或言波夜提。或言突吉罗。问我何时得罪。语言。汝某时某时得罪。我作何事得罪。汝作某事得罪。答言。汝道何事。如是不随问答。是名余语。若比丘见阐那捉银钱。比丘语言。何以捉银钱。答言。我捉锡钱非银钱。或见饮酒。语言。汝何以饮酒。答言。我水。语言。汝何以与女人独坐屏处。答言。有智男子。是名余语。或时默然不答。若知是非法作余语答僧。得波夜提。若狐疑是法非法作余语答僧。得波夜提。若实知答僧言我不知。得波夜提。畏成斗僧默然不犯。余文句易可解。不须广说。此是性罪。从身心口业起。不随问答广说竟。若讥嫌被僧差人波夜提。若讥嫌余人突吉罗。此是性罪。身口业起。讥嫌戒竟。若露地敷僧卧具戒。冬时者。霜雪时也。已曝身者。寒月取众僧床席逐日曝身。知时者。若净人唤不举众僧卧具。不教他举犯。法师曰。冬日时有四月。热时有四月。若不雨时。得敷众僧卧具。若雨时不得敷。树下者。若树叶厚密。上无众鸟聚集。得敷众僧卧具。不犯。若比丘受上头陀法。若在树下若在空地。乃至不得袈裟为屋。不得将众僧卧具在外受用。若能赏护乃至袈裟覆莫令湿。得受用。若受中头陀法。无雨时露地。雨时屋下若入屋下。得受僧卧具。若檀越见比丘露住。为作众僧卧具。比丘受已。若有比丘应付嘱。若无比丘付嘱。与近住处。若无近住。若空屋举置。若无空屋。若厚密树下。可缚举已去。若不举若去时先作念。我入聚落不久当还。如此去者无罪。若入聚落已。有八难因缘不得来。付嘱无罪。若实雨言不雨而去突吉罗。床有四种。何谓为四。一者波摩遮罗伽脚。二者文蹄脚。三者句利罗脚。四者阿遏遮脚。波摩遮罗床者。梐入脚。文蹄脚床者。梐与脚相连成也。句利罗床者。或作马蹄脚。或作羊蹄脚虎狼师子。如是是名句利罗脚。阿遏遮脚者。脚入梐。如是床在露地敷已。离中人掷石外。波夜提。若上座嘱下座教敷床已。若上座置衣着床上。下座得去。若不置一物。下座应为并譡若不并挡。嘱上座已去无罪。若敷已未坐。更有比丘坐语已去无罪。若为法师敷高座。若法师未来敷者应守护。若法师坐已得去无罪。若先提坐蹬下至木椯。去时不自举不教人举突吉罗。若众僧染盆水觚洒绳。去时应举置常处而去若不举而去突吉罗。若他人私物不举亦突吉罗。自己物去时不举亦突吉罗。若有八难因缘。去时不举不犯。法师曰。余文句易可解。不须广说。此戒是制罪。从身心口起。房内敷僧卧具。或比次者。若皮作比次。比次者。是枕囊或坐囊。若荐席下至草敷。去时自不举。不教人举。若无篱障。去离一掷石外还。突吉罗。二掷石外还波夜提。若有篱出篱外便犯。僧房内敷僧卧具戒广说竟。知他比丘敷卧具竟。后来恼他比丘波夜提。若不知若疑亦波夜提。若八难因缘不犯。恼他戒广说竟。是性罪。重阁者。下至倚立不着头无罪。无罪者。非重阁者不犯。重阁戒广说竟。若重泥者。若户两边及上头。得二肘半重泥。若户高下有壁。亦得重泥。窗四面亦得重泥。何以故。为开闭窗户故。覆者。覆有二种。一者圆覆。二者纵覆。若一教罢不犯。若瓦覆过三节。得波夜提。若过三节。随用瓦多少。一一波夜提。若石灰覆过三节。随用搏抟得波夜提。若草覆过三节。随用草。把把得波夜提。若覆不好坏更覆不犯。无罪者。语已去不犯。若空处作屋过三节覆突吉罗。此是制罪。知水有虫者。随因缘知也。若自浇若教他浇。自浇者。随息一一得波夜提。若教他浇。随语语得波夜提。此是性罪。从身心口起。用虫水戒广说竟

教诫比丘尼者大得供养者。诸大德。为教诫比丘尼故。大得利养。非比丘尼与。亦非比丘尼教与。此诸比丘尼。有是国王女大臣女。或是大富长者女。各自还家。父母问言。谁为教授比丘尼。答言。诸大德教授我等。父母闻已发欢喜心。即以四事饮食衣服汤药卧具。供养诸大德。有比丘尼还家。说诸大德持戒精进学问忍辱贵姓。父母闻已增加供养。以三种因缘。诸大德大得利养。六群比丘。见诸大德大得利养。便语比丘尼言。我等亦能教授比丘尼。比丘尼闻已。往六群比丘所求教授。六群比丘。为比丘尼说少法已便多说世间国土治化饥俭丰熟城邑聚落。此等皆是三恶道语。是故律本中说。若比丘有八法堪教诫比丘尼。何者为八。一者持戒。二者守护波罗提木叉。三者威仪具足。四者见小罪生怖畏心。五者坚持。六者多闻。七者多闻坚固。八者分别说法初中后善。纯一清白梵行具足。正见无邪诵二部波罗提木叉。义字分明音声流利为比丘尼恭敬贵重。善能随顺说法。是名八法。持戒者。或言戒在身。或言持戒不犯。是名持戒。护持者。身口意业不犯。或言行无上法。或言受具足波罗提木叉法。是名守护持。威仪具足者。不邪命自活。不往五处。一者淫女。二者寡妇。三者比丘尼寺。四者大童女家。五者黄门。亦不往信心优婆夷家。是名威仪具足。见小罪生怖畏者。若见小罪如见大毒蛇无异。是名怖畏。坚持不犯者于持戒中不生退心。是名坚持。多闻者。解一阿含或言二阿含。是名多闻。坚固者。所解阿含坚固不失。是名多闻坚固。初中后善者。法师曰。于毗兰若婆罗门品以说。义字分明者。为人解说无疑乱。音声流利者。言辞辩了亦不謇吃。反复流利者。诵二部波罗提木叉。无有滞碍。半月半月尽布萨。悉知六斋日。能为人说法。若诵一阿含二阿含亦知无碍。知沙门禅定法。乃至阿罗汉果悉知无碍。若满二十岁。能为人受具足戒。法师曰。何以不言知阿毗昙。答曰。若能知阿毗昙最善。若下根者。知律及修多罗。亦得教授。音声流利女人乐闻。何以言音声流利教授比丘尼。答曰。女人多贪着音声。然后听法。为比丘尼敬重者。此比丘有道德故。为比丘尼所贵重。不污三众。何以言污三众不得教授。若教授者。此尼见者不生敬重心。满二十岁者。若满二十岁。持法坚固少有退败。年少轻躁易可退败。是故制。满二十腊。堪教诫比丘尼。扫洒房舍洒水者。所以扫洒办水者。比丘既从远来。宜应供给床席水浆。若无荐席下至草敷。若为尼说法。应须一伴。不得房中说。若比丘尼于路见比丘。远则合掌近应和南。乃至王难路湿。亦应问讯夏安居。去比丘寺半由旬得安居。过半由旬不得。若檀越请比丘尼夏坐。无比丘依。安居比丘尼欲去。檀越语言。但住。弟子为请比丘来。若请未得。至后安居。有比丘得住。若为请不得应去。若道路有命难有梵行难。无比丘得安居不犯。若初安居有比丘。结安居竟。若比丘有因缘去。若罢道若病。比丘尼不知后知。以结安居不得移住。无罪。若安居竟。不得无比丘自恣。应觅。半月半月应往大僧中请二法。何者二法。一者问布萨日。二者请教诫。法师曰。如来何故殷勤嘱授比丘尼。为比丘尼女人钝根故。是时比丘尼僧。尽往比丘所受教诫。诸人讥嫌比丘尼。往白比丘。比丘往白佛。佛因此制。自今以去。不得多比丘尼往请教诫。听五人往。由致讥嫌。佛言。听二三人往。比丘尼僧。应羯磨差二三人。往大僧中请教诫乃至阿兰若比丘。亦应教诫比丘尼。云何教诫。应作期。若树下若客舍中。比丘尼期往不往。得突吉罗。若比丘不至期处待。亦得突吉罗比丘尼十四日自恣。比丘僧十五日自恣。若比丘尼请说。若不说八敬先说余法。突吉罗。若说八敬已后说余法。不犯。除答问不犯。除为他说尼听不犯。为式叉摩尼沙弥尼说不犯。法师曰。余文句易可解。不须广说。此是制罪。从心口起三受若比丘僧不差。若往比丘尼寺教诫。波夜提

善见律毗婆沙卷第十五善见律毗婆沙卷第十六

        萧齐外国三藏僧伽跋陀罗译

今当说般陀根本因缘。般陀者。汉言路边生也。何以故。般陀母本是大富长者女。长者唯有此一女。作七层楼安置此女。遣一奴子供给所须。奴子长大。此女便与私通。即共奴筹量。我今共汝叛往余国。如是三问奴子。奴子言。不能去。女语奴言。汝若不去。我父母知必当杀汝。奴答言。我若往他方。贫无钱宝。云何生活。女语奴言。汝随我去。我当偷取珍宝共汝将去。奴答言。若如是者我共去。此女日日偷取珍宝。与奴将出在外藏。举计得二人重以遣奴。前出在外共期。此女便假着婢服反钥户而出。共奴相随远到他国。安处住止。一二年中即怀胎。临欲产时。心自念言。我今在此。若产时无人料理。思念忆母欲得还家。共婿筹量。我若产时唯有我母能料理。我今欲去。君去以不。奴婿答言。不能去。我等叛来。云何得归。大家必当杀我等。妇语婿言。女人法虽嗔不能杀子。是以欲去。婿答言。若不杀汝必当杀我不能去也。婿入山斫樵不在。于后闭户而去。婿还不见其妇。即问比邻。见我妇不。答言。汝妇已去。其夫闻已即随后逐。至半路便及其妇。已生一男。夫语妇言。汝为欲产故去。汝今已产。何须去也。妇闻此语。惭愧父母故。即俱还家料理生活。其后未久以复怀胎。临欲产时。思忆母故。复叛还家。至半路复生一男。其婿追逐半路共还。其二儿于路边生故。字为般陀。般陀兄弟。与诸同类共戏。二儿力大打诸同类。同类骂言。汝无六亲眷属。孤单在此。何敢打我。儿闻此呵责已。还家啼泣问母。他人皆有六亲眷属。我等何以独无其母默然不答。其儿啼哭不肯饮食母见不食啼哭如是。其母慈念二儿故。便语其实。我是某国大富长者女。汝父是长者家奴。遣供给我。我便与其通不能相离。我与其逃避在此生汝。二人闻母语已。语母言。可送我还外家。不能住此生活。其母不许。二儿啼泣不已。母即共婿筹量。此儿啼哭不肯住此。我等云何可共送还其外家。婿言。可尔。即共往送到已。父母及儿俱住门外。见家人出语言。汝可还向长者道。长者女将儿婿今在门外。父母闻已答言。可使二儿入。汝不须相见。长者即遣人迎二儿入。儿入已即以香汤洗浴。以香涂身着衣璎珞。长者抱取二儿置两膝上。问言汝母在他方云何生活。不甚贫乏也。二儿答言。我父母在他方贫穷。以卖樵自活。母闻是语心生慈念。即开库藏以囊盛金。遣人送与女语言。汝留二儿我自养活。汝将此金还先所住处。好自生活。不须与我相见。二儿年已长大。为其娶妇。父母年老临欲终时。以家业悉付二儿。其父母命终。尔时佛为四众说法。尔时摩诃般陀。即往佛所听说法。既闻法已心乐出家。还家共弟筹量。我今欲出家。以家事付汝。弟闻兄语心中懊恼。白兄言。我今孤露无所依凭。兄今舍我出家。我云何得活。其弟如是三请。兄心坚固无有退转。以家事付弟即便出家。出家不久即得罗汉。其弟久后心自念言。我兄舍家业与我。如人呕吐无异。我云何受而生贪着。以厌世故。即往兄所求欲出家。兄即度令出家。教其一偈。四月不得忘前失后。兄摩诃般陀心自念言。此人于佛法无缘。当遣还家。即语周罗般陀言。汝今钝根即牵袈裟驱令出门。于门外啼哭不欲还家

尔时世尊。以天眼观看众生。见周罗般陀应可度因缘。世尊往至其所。问周罗般陀言。何以啼哭在此。答佛言。我既钝根。诵一偈四月不得。兄摩诃般陀。以我钝根故。驱我出寺。佛言汝止。莫懊恼。我当教汝。法师曰。摩诃般陀。可不见其得道因缘。何以牵其出也。答言。周罗般陀非声闻能度。唯佛能度。是以牵出。世尊安慰其心。即以少许白叠与周罗般陀。汝捉此叠向日而帑。当作是念言。取垢取垢。佛教已入聚落。受毗舍佉母请。佛临中观周罗般陀将得道。即说偈言

  入寂者欢喜　　见法得安乐
  世无恚最乐　　不害于众生
  世间无欲乐　　出离于爱欲
  若调伏我慢　　是为第一乐

周罗般陀遥闻此偈。即得阿罗汉果。问曰。有比丘往比丘尼寺说八敬。得三波夜提不。答曰有。一者僧不差。二者往比丘尼寺。三者至日没。是三波夜提。往比丘尼寺说余法。得一波夜提二突吉罗。何者是。一者僧不差。二者往比丘尼寺。此二突吉罗。至日没。一波夜提。提婆达多三文陀达多骞驮达多俱伽利伽迦留提舍赞叹者。显其名字也。别众食者。别众食有二种。一者请。二者乞。云何成别众食。有一优婆塞。往至四比丘所。以政食请比丘。愿大德受之。是名请成别众食。一时受请。或明日或后日一时受一处食。成别众食。四人俱得罪。一时受请已。各去至檀越家。以一时受食还各处食。得罪如故。法师曰。何以故。为一时受食故。一时受请。各去各受各食。不得罪。别请别去。至檀越家一时受。得罪。是名受请得罪。云何从乞得罪者。有四乞食比丘。或坐或立见优婆塞。语优婆塞言。与我等四人饭。或一一人乞言。与我饭亦如是。或俱去或各去。一时受食得。是名从乞得罪。病者。脚破沙土入中。不能行故。得受别众食。是名病。作衣时者。若得衣裁。或先割截作衣。是名作衣时。乃至衣上安钩纽。行者。下至半由旬。船行亦如是。饥俭时乃至食不足四人食。名大饥俭时。沙门施食者。或同法沙门外道沙门。有七因缘得别众食不犯。不请足四。第二乞食足四。第三未受具戒足四。第四钵盂足四。第五病人足四。此五四今当广说。云何不请足四。有檀越请四人。一人知已。不去至檀越家。檀越问。上座来不。三比丘答言。不来。檀越临欲中。见一比丘。即唤入与食。四人俱食不犯。是名不请足四。何以不犯罪。一者非请故。云何乞食足四。三人受请。一人乞食不受请。是故不得罪。沙弥足四。请三道人一沙弥不犯。钵盂足四。云何钵盂足四。请三道人一钵请食不犯病。人足四者请。三道人一病比丘足成四人不犯请。四人有一解律比丘。欲俱食。畏犯罪。即作方便。檀越行食时。覆钵不受。檀越问言。何以不受。答言。但与三人食。我欲咒愿。三比丘食竟。后便受食不犯若请与饭至家与肉亦犯。请与饭至家与粥不犯。若有檀越欲饭僧。遣人往寺。请僧。受我等饭。僧中有解律比丘。自念言。此僧中多有行头陀法。使者不解法。故作是请。解律比丘答言。明日当知。使者复来。故如前不解语请僧。知法比丘答言。明日当知。如是展转乃至半月。若犹不解。知法比丘语言。若檀越如是请僧者。但得沙弥不得大僧。使者言。诸大德亦受余家请。今者何以不受我请。答言。非不受请。犹汝不知法故。但言请僧。莫言与饭糗鱼肉等。但言请僧。比丘得受不犯。若如是教示。使者犹不解语。畏人讥嫌。语言。汝但去。众僧明日入聚落乞食。往至所请檀越家受食不犯。别众食戒广说竟。此是制罪。从身心起。展转食者。若比丘受请已。檀越未来。比丘畏日晚。恐檀越不来。便入聚落乞食。乞食还见所请檀越来。比丘不食。请主问言。大德何以不食。比丘答言。以受檀越请故不得食。檀越语言。但食。若如是语者食不犯。若众多檀越同一时请。如是食不犯。展转食戒竟。此制罪。从身心起。归妇贾客道路粮。若取一钵出。随意自食若施人。若取二钵。一钵自食。一钵与比丘僧。若取三钵。一钵自食。二钵与比丘僧。不得与知识白衣若亲里或自恣请檀越。亦不得取过三钵。法师曰。余文句易可解。此是制罪。从身心起。不以不知故得脱。归妇道路粮戒竟。五正食者。粳米饭穄米饭粟米饭赤粳米饭麦饭。此五种米作粥。初出釜画成字不得食。若米合菜作粥亦如是。若少饭和多水食。以离威仪。应作残食法。米杂肉及鱼作粥肉。若现如芥子大。应作残食法。肉烂与水无别。不须作残食法。一切草根及树木子作饭。不须作残食法。干饭者。若粟作干饭。或粳米作或麦作。干饭者。日曝令燥。若以豆及树木子作干饭。不须作残食法。糗者。粳米糗粟米糗麦糗。食竟应作残食法。糗有二种。一者散糗。二者以糖蜜抟令相着糗。米不碎故。是米不须作残食法。若糗谷米出食。不须作残食法。若受五政食者。钵中手中有食。人行食。在申手内遮离威仪。应作残食法。申手外遮不成遮。在申手内口中咽食尽遮不成遮。若口中有饭申手内遮成遮。若不净肉二切不中食者遮不成遮。何以故。不净不中啖若啖不净肉。申手内遮不成遮。若遮与他不成遮。何以故。未罢食想。若正食遮与他不成遮。申手内者。去身二肘半内遮成遮。二肘半外遮不成遮。若持食来置地。一申手内不授与比丘。若遮不成遮。若净人手捉食遮成遮。若与他比丘食谓与己。若遮不成遮。遮有二种。一者身遮。二者口遮。云何身遮。若手遮或摇头。或以手覆钵口。遮者言罢不受。若以菜杂鱼肉作羹。若言受菜羹遮不成遮。若言受肉羹遮成遮。若正不正杂为粥。若说正名成遮。说不正名不成遮。行威仪者。唯除船车乘不犯。病人残食者。或食残或未食亦成。残食戒广说竟。此是制罪。从身口起。一切树木及草不任为食。根茎花果得尽形受服。有树草木举体时食。有树果心时食。余者尽形受药。有树举体尽形受药。非时食戒广说竟。若乞美食乳酪鱼及肉。得波夜提。乞余食突吉罗。除为病人乞不犯。乞美食戒竟

除水及杨枝者。若天人授食。或鬼神授食。畜生及飞鸟授食。皆成受。若头戴食若肩担食。授与比丘。教比丘自取。不成受。若低身流落比丘手中成受。若担长乃至二十寻。两头安食。净人合担授与比丘。受得一头。一头亦成受。若乞食值风雨。尘土落钵中。比丘作念。当为沙弥乞食。得食还语沙弥言。我今乞食。值风雨尘土落钵中。不成受。为汝乞食。今时与汝。沙弥受已语比丘言。此是沙弥食。今施与大德。如是施者得食不犯。若比丘手捉钵。食时眠睡。人持食置钵中。比丘不觉。不成受。若临受食时睡。人持食着钵中。成受。何以故。作受食意故。若尘大可除去食不犯。若尘细落不可除。应使人度。若二人并食。若行食余食。迸落比丘钵中。成受。若食时额头汗流落钵中。应更受。若臂中汗流入手。不须受。摇掷从地转来。落比丘手上。成受。若净人在树上。以绳系果授与比丘。不成受。若人长手。乃至十由旬。度食与比丘。成受。若比丘病。沙弥若净人。抱比丘行见果。比丘从净人乞。净人取果已。回手就身上。度与比丘。成受。若比丘患热。捉果树枝行。以为遮日。后见枝中有果莫动。教沙弥擿果。授与比丘。得受。若船或车载饮食。比丘篙船牵车。动饭食得食无罪。若众多比丘共行。唯有一小沙弥。比丘各自担粮至食时各自分分。沙弥得分已。语比丘言。今持沙弥分与大德易。得易已复持与第二上座易。得第二上座食已。复与第三上座易。如是展转乃至众多。如是食皆无罪。若沙弥不解法。比丘自持食分与沙弥易。第一上座得易已。第二上座复与沙弥易。第二上座得易已。第三上座复求易。如是展转众多。皆得换易食不犯。共宿恶触。若比丘担米行。沙弥小不能作食。比丘得自作。唯除不得然火。教沙弥然火。食熟已分。如前展转与沙弥换易食不犯。自作食若食沸涌出。比丘不得用气吹持物搅。皆犯突吉罗罪。若食吐未出咽喉。还咽不犯。若出咽喉入口还咽。犯波夜提。若受生姜后生芽。不失受。若火净以后生芽。生芽处应更净。非生芽得食无罪。先受盐。盐变成水。不失受。若急病因缘。大小便及灰土。得自取服。若无灰。得破树然火作灰。云何病得毒若蛇啮。法师曰。余文句易可解。此是制罪。从身口起。此二食家中坐戒。二不定法已解。与女人独露处坐者。若二人共坐床语。彼此相解。申手内以还。得波夜提。言语不相解。申手内以还。犯突吉罗罪。释摩男者。是佛叔之子。大佛一月日。得斯陀含道也。若檀越施药。应作药用。不得作食用。与油乞酥。犯突吉罗。象军者。象上有四人。下有八人。是名象军。马军者。一人在马上。二人在下。是名马军。车军者。四人逐车。是名车军。步军者。四人相逐。是名步军。若酒煮食煮药。故有酒香味。犯突吉罗。无酒香味得食。水深没脚背水中戏。得波夜提。若摇船弄水得突吉罗。青色者。或铜青或蓝青。或木兰色。木兰色者。泥点也。以此三种色点净。下如麻子大。若不点净得波夜提。若比丘知水有虫饮用。随息咽咽波夜提罪。知水有虫以火热汤浇亦如是。虫水戒说竟。若比丘知他比丘粗罪已覆藏。第二比丘复覆藏。如是百千人共覆藏。皆犯波夜提。此是性罪。因身心起。覆藏他罪戒竟。若年不满二十。欲受具足戒。听数胎月闰月数。十四日布萨。足满二十得受戒。与贼众议共道行者。此是制罪。与比丘尼议共道行者。此是制罪。律中已说。阿栗挓邪见者。摩着细滑。不遮天道。不遮解脱道。阿栗咤所以生此邪见者。言须陀洹斯陀含有妇儿亦不障道。牵此自比言摩着细滑不能障道。若言细滑能障道者。一切毡褥及隐囊亦细滑。那独言女人细滑能障道耶。阿栗咤邪见戒广说竟。若学比尼者。有五德有六德。有七德有八德。有九德有十德。有十一德。何谓为五德。一者身自护戒。二者能断他疑。三者入众无畏。四者能伏怨家。五者令正法久住。云何身自护戒。持戒清净无有缺漏。是名护戒。律师以六法不得罪。一者不无趣。二者无知。三者不狐疑。四者不净言净。五者净言不净六者不迷惛。云何不无趣。知而故作。是名无趣。如律本中说。知而故作得罪。以知而覆藏。往不应行处。是名无趣。云何无知此人不知戒相欲作而作。是名无知得罪。云何狐疑得罪。欲作心生狐疑而作。是名狐疑得罪。云何不净言净。是熊肉不净言是猪肉而啖。是名不净言净。虎肉言是鹿肉。非时食言是时食。是名不净言净。云何净言不净。实是鹿肉。作虎肉想啖。如是乃至时言非时而食。是名净言不净。云何迷惛。与未受具足戒人。过二宿不知。是名迷惛得罪有迷惛不知时与非时。离衣宿亦复不知。是名迷惛。云何能断他疑。有比丘犯罪。狐疑不能决判。若来咨问依律为判。是名能断他疑。云何入众无畏。以知律故。随事能作。是名入众无畏。云何能伏怨家。如离车子起十非法。能依律除灭。是名能伏怨家。云何令正法久住。一者身自随法。二者能令他得法。因得法故。正心持律。因持律故。得入禅定因禅定故。而得道果。是名令正法久住。如律本中说佛语阿难。若我灭度后。毗尼即是汝大师也。是名令正法久住。下至五比丘解律在世能令正法久住。若中天竺佛法灭。若边地有五人受戒。满十人往中天竺。得与人具足戒。是名令正法久住。如是乃至二十人得出罪。是名令正法久住。因律师故。令正法久住。是名持律五德。云何持律六德。一者守领波罗提木叉。二者知布萨。三者知自恣。四者知授人具足戒法。五者受人依止。六者得畜沙弥。是名六德。云何守领波罗提木叉。知十四日布萨。十五日布萨。和合布萨。僧布萨。众布萨一人布萨。说波罗提木叉布萨。净布萨。敕布萨。是名九布萨。此是律师所知。有九自恣。一者十四日。二者十五日自恣。三者和合自恣。四者僧自恣。五者众自恣。六者一人自恣。七者三语自恣。八者二语自恣。九者等岁自恣。此是律师所知。众僧有四法。一者白僧。二者白羯磨。三者白二羯磨。四者白四羯磨。此四法是律师所知。非修多罗师阿毗昙师所知。若不解律。但知修多罗阿毗昙。不得度沙弥受人依止。有五德六德。僧成律师十一德。以律师持律故。佛法住世五千岁。是故多诸比丘。就优波离学律。云何学律读诵解义。是名学律杂碎者。从二不定乃至众学。是名杂碎。若向大比丘毁呰戒。得波夜提。向未受具戒毁呰戒。得突吉罗罪。余文句易可解。不须广说。毁呰戒竟。此是性罪。从身口起。打者。六群比丘恒驱使十七群比丘以不从语故便打之。若嗔心打乃至死。得波夜提罪。嗔心打者。乃至头破手脚折。波夜提罪。若打未受具戒下至畜生。得突吉罗若欲心打女人得僧残。若虎狼师子乃至梵行难。以手打求脱不犯。手搏者。手不着身手搏也。手搏戒竟屏处听者或壁障或荫处往去。步步得突吉罗罪。往至闻处得波夜提罪。为欲自改往听不犯。此是性罪。若比丘与欲竟后悔戒无解。(七十六)若僧断事未竟默起去戒无解。若比丘先欢喜听。后如是说。诸比丘随亲友回僧物与戒无解。佛语阿难。入王宫有十过失。何谓为十。一者若王与夫人共坐一处。夫人见比丘而笑。比丘见夫人亦笑。王见已生疑。是比丘当与夫人共通。是名第一过失。佛语阿难。入王宫复有过失。若王与宫中婇女共交会而忘后生儿。王言。我不近此婇女。云何有儿。当是比丘所为。是第二过失。佛语阿难。复有过失。若宫中失宝物求觅不得。王言。更无余人。当是比丘取。是名第三过失。佛语阿难。复有过失。若王宫中私语。已声彻于外。王念言。当是比丘传出于外。是名第四过失。佛语阿难。复有过失。若王退大为小迁小为大。无人得入王宫。当是比丘教王所为。是名第五过失。佛语阿难入王宫复有过失。若王退长者位遣儿代。诸人讥嫌。当是比丘出入王宫。教王所为。是名第七过失。佛语阿难。比丘入王宫复有过失若王非时遣军诸人讥嫌。当是比丘教王所为。是名第八过失。佛语阿难。入王宫复有过失。若王非时遣军中路退还。诸人讥嫌言。当是比丘教王所为。是名第九过失。佛语阿难。入王宫复有过失。若王调象马车以宝严饰。诸人讥嫌。当是比丘教王所为。是名第十过失。入王宫戒广说竟若为佛僧捉宝举。得突吉罗罪。若僧坊内若住处内。得遗落宝。为掌护故。若去时应付与知法畏罪者。付嘱言。有主来索当还。若久久无主来索。得为房舍用若池井用。不得为己身用。若久后有主来索。应将示僧房若池井。此是檀越物。若弃布施善。若不布施。欲还得本物者。比丘应入聚落向信心檀越道。某月某日寺中得遗落宝。掌护久无人来索。以用作僧房池井。主今来索欲还本直。檀越能以物赎布施众僧不。若能赎布施善。若无人能赎。比丘应广教化求索觅直还。捉宝戒广说竟。此是制罪。从身业起。非时入聚落戒无解高床戒无解。兜罗纻坐褥戒无解。针筒戒无解。尼师檀毡。作长二磔手广一磔手半。益缕者。益一磔手。长六尺破头。一磔手作三破。名为缕修伽陀磔手。尼师檀戒竟。覆疮衣戒无解。雨浴衣戒无解。第一波罗提提舍尼不解。若夫妇俱得须陀洹道。若有百千两金布施。亦尽由得道故。于财无有悭惜。布施太过居家贫穷。是以佛制不得受食。尸沙者。学也。迦罗尼者。应学作或脚大或股小得下着。洗钵水弃白衣家内者。若饭粒撩与众生。余水弃不犯。或碎令与水合弃不犯。不得净用水大小便。不犯者。若水人所不用。或海水不犯。水虽中用。旷远无人用不犯。佛塔中止宿及藏物。此二戒梵本无有。所以无者。佛在世未有塔。此戒佛在世制。是故无著革屣入佛塔。手捉革屣入佛塔。着腹罗入佛塔。手捉腹罗入佛塔。佛塔下食担死尸。塔下烧死尸。向塔烧死尸。绕塔四边烧死尸。不得担死人衣及床从塔下过。佛塔下大小便。向佛塔大小便绕佛塔大小便。不得持佛像至大小便处。不得佛塔下嚼杨枝。不得向佛塔嚼杨枝。不得绕佛塔四边嚼杨枝。不得佛塔下涕唾。不得向佛塔涕唾。不得绕佛塔四边涕唾。向佛塔舒脚。安佛置下房。此上二十戒。梵本无有。如来在世塔无佛故

尔时佛呵责六群比丘。何以自在下人在高而为说法。佛语比丘。往昔于波罗奈国。有一居士。名曰车波加。其妇怀妊。思庵罗果。语其婿言。我思庵罗果。君为我觅。其夫答言。此非庵罗果时。我云何得。妇语夫言。君若不得庵罗果。我必当死矣。夫闻妇语。心自念言。唯王园中。有非时庵罗果。我当往偷取。作是念已。即夜入王园偷庵罗果。取果未得时明相已出。不得出园。于是树上藏住。时王与婆罗门入园。欲食庵罗果。婆罗门在下。王在高座。婆罗门为王说法。偷果人在树上。心自念言。我今偷果事应合死。因王听婆罗门说法故。我今得脱。我无法王亦无法。婆罗门亦无法。何以故。我为女人故。而偷王果。王犹憍慢故。师在下自在高座而听法。婆罗门为贪利养故。自在下坐为王说法。我与王婆罗门相与无法。我今得脱。作是念已。即便下树往至王前。而说偈言

  二人不知法　　二人不见法
  教者不依法　　听者不解法
  为食粳米饭　　及余诸肴膳
  为是饮食故　　我言是无法
  为以名利故　　毁碎汝家法

我为凡人时。见人在上说法者在下。言其非法。何况我今汝诸弟子。为在高人自在下而为说法。时偷果人者。我身是也。众学戒广说竟。七灭诤法。后骞陀迦中当广说。次说比丘尼戒。摩触者。缺瓮骨以下。至肘膝以上。摩触波罗夷。若比丘尼摩触比丘。比丘受乐不动身。比丘不得罪。若比丘来摩触比丘尼。比丘尼身不动受乐。随处得罪。后四波罗夷竟。若比丘尼言人共往官所。若比丘尼语居士言。汝先说理。若居士说理时。比丘尼得突吉罗。居士说已。比丘尼复向官说。比丘尼得偷兰遮罪。若居士复说。比丘尼得理。犯僧残。不得理亦犯僧残。若居士言比丘尼。官唤比丘尼来。来已语比丘尼言。但还去官自判。得理不得理比丘尼不犯。若比丘尼至官前言人。若官问何物人。不得道名字。若教官罚物。随直多少犯罪。应偿。若官问不道名字不犯。若官后自寻访知主。官自罚不犯。若人偷比丘尼衣。不得言是贼。但言此人取贫道衣去。若人当劫夺比丘尼。得就王乞护身。不得称名字。若道名字犯。如前说。王闻比丘尼乞护身已。王打鼓宣令。若有犯比丘尼者。依法治罪。后有人犯比丘尼。王自依法治罪。比丘尼不犯。若人入比丘尼寺斫伐树木。不得夺刀斧及打坏。若打坏应还直。不还计直多少犯罪。余文句易可解。言人戒广说竟。度贼女戒不解(第五)辄出界外为解羯磨戒无解(第六)若比丘尼独船渡水亦僧残(第七)十七僧残竟。三十事无解。蒜者。唯大蒜。食咽咽波夜提。余细蒜葱不犯。亦得以大蒜与食中作调和不犯。若洗小便处。两指齐一节。不得过。若一指洗。得入两节。不得过。不得用二指洗。入便犯罪。若乞谷麦波夜提。乞豆及苽菜不犯。为造房舍乞谷麦不犯。一切不得在生菜果树及禾谷上大小便。得波夜提罪。一切余果木及谷子未出芽大小便上突吉罗。往观看伎乐者。下至猕猴孔雀共戏。往看波夜提。若寺中作伎往看不犯。若夏安居竟。应去寺六由旬。若不去波夜提罪。八波罗提提舍尼无解。比丘尼戒竟。骞陀伽(汉言杂揵度)尔时佛过七日已从禅定起。天帝释奉呵罗勒果。如来受食已便利。天帝释复授杨枝净水。时贾客兄弟二人。从优加罗村来。车载财物欲往中国。至菩提树边。车自然而住。不肯前进。兄弟二人见车不进。以为不祥。即设饮食祠祀鬼神。时树神即现半身。语贾人言。汝车不去。是我留耳贾人当知。白净王子出家学道。今在菩提树下得一切智。于七日中未有所食。汝可以糗蜜奉上如来。令汝等长夜得利益安隐快乐。时兄弟二人闻树神语。即以糗蜜奉上佛。此次第文句律中已说。最初受三归者。献佛糗蜜二贾人。是兄弟。受归依已欲还。白佛言。我等二人云何得供养佛。佛以手自摩头。发即随手落。语贾人言。汝可供养此发以为汝大师。问曰。先受乳糜钵。今何所在。今复受四天王献钵。答曰。佛前受乳糜钵。度尼连禅河。于时钵没在水中。海龙王将供养。是故更受四天王献钵。钵色如玉。若人求欲出家。父母已听离诸疾病。无有障碍。来至僧中。若众集应白僧。若不集人人语令知。白僧已先为洗浴。洗浴已和上应生儿想。不得生污贱心。何以故。若如是好心料理。弟子于和上阿阇梨。便生父想。临剃发和上应为说五法。何者为五。一者发。二者毛三者爪。四者齿。五者皮。所以说此五法者。有人前身曾观此五法。今为剃发落地。即发先业。便得罗汉。是故先教五法。然后为剃发。如罗睺罗。发落未竟便成罗汉。如痈熟须人为刺然后得破。亦如莲花须待日出而得开敷。此欲出家人亦复如是。因说五法便得悟道。为剃发时。当顶留五三发置。以香汤洗浴。除白衣气。来至和上前胡跪。和上问言。今为汝去顶发许不。答言尔。和上自为剃去顶发。剃顶发已。在和上前胡跪。和上授与袈裟。得以顶戴受。受已还和上。如是第二第三受。顶戴受已。和上为着不得自取自着袈裟。要须和上授。次第礼诸比丘。往阿阇梨所。礼足胡跪合掌。阿阇梨教言。汝当随我语。教汝受三归。答言尔。与三归竟。次与十戒。云何与三归。答曰。受三归有二种。一者别受。二者总受。云何别受。别受者。归依佛归依佛归依佛竟。归依法归依法归依法竟。归依僧归依僧归依僧竟。是名别受。总受者。归依佛归依法归依僧。归依佛竟归依法竟归依僧竟。如是三说。是名总受。不得先归依僧后归依法佛。亦不得杂说。若师教言归依佛。弟子语不政。言归依佛。亦成受。若师教言归依佛。弟子言归依佛。亦成受三归。若师与弟子。语俱不正。言归依佛。不成受三归。若师教归依佛。弟子答言尔。或语不出口。或逐语不具足。皆不成受三归。受三归竟。次与授十戒。受十戒有二种。一者别受。二者总受。云何别受。我受不杀我受不杀我受不杀竟。如是次第亦如是说。是名别受。云何总受。我受一不杀生。二不偷盗。三不淫。四不妄语。五不饮酒。六不过中食。七不歌舞作唱严饰乐器。亦不故往观听。乃至斗诤悉不得看。八不着香花璎珞以香涂身。九不高广大床上坐卧。十不得捉持生像。生像者。此是金与银。及一切宝。皆不得捉。若言音不同者。如伧吴不相解。应教其义。如是不解。弟子答言能持。亦成受戒。若钝根者。不知着衣。不知捉钵。食亦不知。行住坐卧皆悉不知。不得离和上。一一应随和上学。和上看弟子如儿想。度沙弥法竟。弟子法者。明相出早起。嚼杨枝洗手面。脱革屣。往至和上所。师起已。与师三种杨枝大中小。一时授与师三种杨枝。若师日日恒取大者。置中小恒与大者。若师取中置大小。若师取小置大中。若有时取大。有时取中。有时取小。三种随意与。应授水。水有二种。一者冷二者温水。若师恒用冷水。置温水。若师恒用温水。置冷水。若师有时用冷有时用温。二种水随意授与。供给水已。若和上入圊。便转应往和上房扫除。料理床席卷牒衣裳。授僧伽梨者。先安僧伽梨衬已。度与和上。若和上将去。着衣持钵随和上后。不得近不得远。去和上七尺而行。师应教弟子持戒。若有犯罪。应教忏悔。有长衣钵。弟子若无应与。若弟子疾病应料理。若和上多有弟子。一人供给。余者随意读诵。尔时婆罗门欲求出家。比丘不许。婆罗门便啼哭懊恼。时佛见婆罗门形体羸瘦。问诸比丘。此婆罗门何以羸瘦。比丘答言。此婆罗门求欲出家。诸比丘不许。是故羸瘦。佛问诸比丘。此婆罗门与谁有恩。舍利弗答言。此婆罗门在王舍城。曾施我食。是故我识。佛语舍利弗。汝当度此婆罗门。时舍利弗白佛言。云何度此婆罗门。佛告舍利弗。汝当为白四羯磨授此婆罗门。尔时佛集诸比丘为说法已。语诸比丘。自今以去断三语受戒。众中有了了智慧比丘。为作白四羯磨受戒。受戒已。多作诸恶不按威仪。有少欲知足比丘。呵责言。汝等云何作诸恶行不按威仪。比丘答言。谁请大德与我戒。谁请大德为作和上。时有少欲比丘。白佛言。诸比丘。不请作和上。不乞戒。与受具足戒。佛因此制戒。人不请不作和上不乞戒。不得授具足戒。若与受得突吉罗。请和上乞戒。在律中。尔时诸比丘或二人或三人白四羯磨。为人受具足戒。中有少欲知足比丘。呵责已往白佛。佛以此因缘集比丘僧。自今以去应制十僧授人具足戒。若减十人授具足。得突吉罗。或一岁或二岁。为人受具戒。不知教授。弟子不按威仪。将诸弟子往至佛所。头面礼足却坐一面。尔时佛劳问。汝等四大调和不。乞食易得不。答佛言。四大调和乞食易得。于是佛知而故问。此诸比丘。谁弟子也。答言。我弟子。问言。汝几岁。答言。二岁。汝弟子几岁。答言。一岁。佛即呵责言。汝自未断乳。云何度人。呵责已集诸比丘。自今以去不满十岁。不得度人受具戒。若受戒得罪。虽满十腊。愚痴无智慧。不得受人具戒与受戒竟。法师曰。今明失依止不失依止法。弟子与依止师共行。遥见和上失依止。若见和上作非和上想。不失依止。若和上来入界内或入屋中。弟子不知失依止。若和上来入界内或屋中。或聚落乞食。闻声不见形。皆失依止。若闻声作非和上想。不失依止。若外道初入佛法中。应与波利婆沙。得波利婆沙已。若好往五不应行处。懈怠不肯学佛法。若闻毁佛法生欢喜心。若闻毁僧生欢喜心。不得与具戒行。波利婆沙外道。修得四禅乃至能飞腾虚空。亦不得与具戒。要满四月。若佛法中修得须陀洹道。即日为受具戒。不须与波利婆沙。若在外道。或闻说法得须陀洹道。来至僧中求欲出家。即与出家与具戒。不须与波利婆沙。若波利婆沙垂满四月。闻毁佛法生欢喜心。闻毁外道嗔恚。好往五不应行处。应更与四月。若结发外道事火外道。不须波利婆沙。何以故。此二外道有业信因果。过去诸佛为菩萨时。出家波罗蜜皆于此道学。外道波利婆沙竟。癞者。有数癞有白癞。有黑癞疥癣。皆入癞。亦不得出家。癞癣下至如指甲大。亦不得出家。如指甲大若在露处。增长不增长。悉不得出家。若屏处不现增长。不得出家。若不增长得出家。若瘤病在露处。增长不增长。不得出家。若屏处不增长得出家。若小时有疣病大便失。得度出家。此非瘤病。是故得出家。若身体细起。犹如棘刺。皆入癞数。不得出家度王人者。时诸比丘度斗将出家。后有贼起。王觅诸斗将。欲使破贼。遣人求觅至僧坊中。见诸比丘已度出家。使人来白王言。诸比丘已度出家。王闻已集诸臣共论。王问臣言。度官人者其罪云何。臣答王言。若和上应斫头。羯磨师应截舌。余临坛人应打肋折。时王得须陀洹道。闻诸臣语已。往至佛所白佛言。自今以后愿莫度王人。未来世王。若不信三宝者。诸比丘若度王人。便依法治罪。若王人大臣人。下至食王俸禄者。皆是王人。若父食王禄儿不食王禄。父不得出家。儿得出家。若食禄有期限未尽。不得出家。食禄尽然后得出家。若必欲出家。转禄与兄弟儿子。后得出家。若食禄白王。王听亦得出家。贼者。抄劫窃盗断道杀人知姓字。不得度出家。若图国贼。若舍恶心欲出家。得度出家。为国除患。王闻出家亦大欢喜。若舍恶业降出投王。王许得度出家。不得度患鞭杖疮人。若疮差得度。若犯罪人以铁烙为字。不得度出家。若治护得差得出家。负债者。若自负债。若祖负债。若父负债。若儿负债。若债由己。不得出家。有人为偿债。得出家。奴者。有四种奴。一者家生。二者买得。三者破得。四者自成奴。自成奴者。为衣食故自求为奴。是名自成奴。若奴主放奴出家。语诸比丘言。奴有道心者放。若无道心还复为奴。若如是语者。不得度出家。时有一居士家。有疫病起。初杀蝇蜈蚣百足。次杀鸡猪。次杀牛羊。次及婢奴。后及好人。此疫病起时。不得从户中出。应破壁出直去。不得反顾。若反顾即死。若不即死。至他方亦死。时父子三人破壁得出。直去不反顾。是故得活。既至他方。贫穷不能自立。往至比丘所求欲出家。比丘即度为出家。得出家已。将二儿乞食

善见律毗婆沙卷第十六善见律毗婆沙卷第十七

        萧齐外国三藏僧伽跋陀罗译

尔时佛从摩竭国往迦维罗国者。法师曰。我今次第说根本因缘。尔时输头檀那大王。心自念言。我子初出家日。自唱言。我若成佛。当还此国。王忆此语。心自念言。我子成佛已来。王恒侧耳听。闻子苦行竟。往菩提树下得道。已往波罗奈国。转四谛法轮。度阿若憍陈如等五人出家。今住摩竭国。我今年老及今生存。宜见我子。作是念已。即唤一臣语言。我闻人言。我子已成佛。今住摩竭国。汝可将千人往迎。汝至彼语我子言。我今年老欲得相见。臣受王语已。即将千人前后围绕。往摩竭国。到已往至佛所。头面礼足却坐一面。是时世尊观千人心已。即为说法。时千人得闻法已。即得罗汉。佛唤善来比丘。即得具足戒。此千比丘得罗汉已。入果三昧受解脱乐。即于此住不复欲还。王遣信已迟望不还。又无消息。王复遣臣往。如是次第遣八臣往。一臣各将千人至佛所。皆悉出家得罗汉果。无有一人还报王者。王自念言。我遣八臣去。无有一人还报我者。王自筹量。我今更遣谁去耶。时有一臣。名曰迦留陀夷。与菩萨同日生。王即遣迦留陀夷往迎佛。如前遣八臣语无异。迦留陀夷先与王要。若王许我出家者。我当往迎。王答言善。迦留陀夷受王语已复将千人往彼。佛为说法即得罗汉。佛唤善来比丘。得具足戒。时迦留陀夷。见禾稻结莠草木水陆花出敷荣时节和适。已六十偈赞叹道路。佛知而故问迦留陀夷。汝为何事而赞叹道路。迦留陀夷答佛言。输头檀那大王。遣我来者欲有所白。佛言。听汝所说。白佛言。父王言。我今年老及今生存。欲见佛故。遣我来奉迎佛。唯愿哀愍大王故。时可去矣。佛语迦留陀夷。汝可宣令语诸比丘。佛欲游行。各自料理庄严。随佛游行。是时央伽摩竭国。有十千比丘。从迦维罗卫国来。迎佛者有十千比丘。都合二万比丘。皆得阿罗汉。从摩竭国前后围绕。随佛出城。摩竭国去舍卫国六十由旬世尊渐渐游行。经六十日至舍卫国。时佛日日朝中恒食父王供。所以得食父王供者。时迦留陀夷。时到着衣持钵飞腾虚空。往至舍卫国白父王言。佛已至某处。时王为迦留陀夷设食。以盛满钵饭。授与迦留陀夷。愿大德。可以此钵饭奉上佛。如是日日恒为世尊迎食。迦留陀夷食父王食已。向父王及诸释子。赞叹如来功德。诸释子闻赞叹佛功德。倍增信心。诸释子即聚集。自共筹量。佛不乐愦闹。我等当为佛求觅静处造立精舍。时弥瞿陀释子有一园。不近不远可立精舍。时诸释子人人各各共出财物。为佛起立精舍。精舍成已。父王将诸释子。人人各赍持香花奉迎佛。到已父王及释子中。有大佛者。不为佛作礼。若有小佛者。为作礼。尔时佛见父王及诸释子中。有不为佛作礼者。佛知诸释子意。即上升虚空作十八变。如降伏外道作神力无异。王及诸释子。见佛神力如此。自然为佛作礼。输头檀那王礼已。白佛言。我今第三礼佛足。何谓第三礼佛足。一者佛初生时阿夷相言。若在家者。应作转轮圣王。若出家学道。必得成佛。是时地为振动。我见神力如是。即为作礼。第二者我出游戏耕田。菩萨在阎浮树下。日时已晡。树影停住不移。覆菩萨身。我见神力如是。即为作礼。今者见佛神力如是。是名第三礼如来足。输头檀王礼如来足时。一切诸释子皆随作礼。无有一人立住者。佛从虚空下坐师子座。王及诸释子一时俱坐。时众已定。天降雨。其色红赤。以淹尘土。时众意乐湿便湿。若不乐湿。雨虽着而不湿。时众见雨神力如是。倍增欢喜。尔时佛为诸时众说法。王及诸释子。得闻法已。有得须陀洹者斯陀含者。各起礼佛绕三匝而去。王及诸释。无有一人请佛中食者。明日时到。佛及二万比丘。着衣持钵前后围绕。次第而去。入迦维罗卫国。到城门已。佛心自念。过去诸佛。入眷属村云何乞食。应次第乞为选择也。即观过去诸佛皆次第乞食。无有选择。又为未来声闻弟子依我法故。应次第乞食。时城中诸释妇女。闻佛将徒众入城乞食。各开窗户看佛乞食。时罗睺罗母在楼殿上闻佛入城乞食。心自念言。本在家时。着天冠璎珞。乘七宝辇舆。千乘万骑。前后围绕出入。今者剃除须发着袈裟。持钵乞食。我今观看为好以不。作是念已。即开窗看。遥见佛放五色光。其光照地。犹若融金。耶输陀罗见已。即入白王言。王儿今者入城乞食。王闻已即匆匆而出。往至佛所白言。大德乞食令我等羞。大德徒众我能供给。用乞何为。佛答言。我种如是。王复白佛。我刹利种无有乞食。何以言我种如是。佛答言。过去诸佛是我种。非今刹利种也。佛即为大王。而说偈言

  起已不懈怠　　善法恒自行
  行法得安眠　　今世若后世

王闻说已。即得须陀洹道

尔时世尊。复为大王。而说偈言

  行法则善行　　不行于恶法
  行法得安眠　　今世若后世

王闻第二偈已。复得斯陀含道。复为王说昙摩波罗本生经。王闻已得阿那含道。王临命终佛为说法。于白伞下。得罗汉果。即入涅槃。时大王从如来请钵。请佛及僧。王自导前俱共上殿。王即施设种种肴膳。佛食已竟。宫中婇女闻佛食竟。语罗睺罗母言。我等今者应往礼拜问讯世尊。罗睺罗母语诸婇女。佛若慈愍我者。自来看我。不能去也诸婇女等各赍香花往礼拜佛。诸婇女去后。罗睺罗母心自念言。若佛来者。我当头面礼足。佛食已授钵与王。佛将二神足罗汉弟子。往至罗睺罗母所。敕弟子言。若罗睺罗母礼拜供养。当随其意。莫作障碍。答言善哉佛。是时佛即入罗睺罗母房。敷座而坐。罗睺罗母见佛坐已。疾以手捧佛足。以头摩而作礼。王见罗睺罗母礼佛已。王白佛言。世尊。罗睺罗母于佛极生尊重心。佛答王言。罗睺罗母于我生尊重。非适今也。王问佛于何时生尊重。佛即为说紧那罗本生经。即日以五法。欲拜王子难陀为王。何者五法。一者披发。二者结衣。三者庄严殿。四者娶妇。五者竖伞。是名五法。佛以钵授与难陀。难陀意不乐去。为尊重佛故。俯仰随去。随佛至寺已。意不乐出家。如来观其宿缘应得罗汉。是故强令出家。佛至迦维罗卫国。二日已方度难陀。七日已度罗睺罗。法师问曰。云何得度罗睺罗。答曰。佛入城乞食。罗睺母将罗睺在阁上。罗睺母于窗牖遥见佛。语罗睺言。此是汝父。即以璎珞与罗睺着。语言。往汝父所乞珍宝。汝父在家时大有宝藏今不知所在。汝可往乞。白多多言。我欲竖伞作转轮王。多多可赐我珍宝。罗睺受母语已。往至佛所入佛影中。白佛。沙门影极清凉乐。佛食已讫还本处。罗睺即随佛后。从佛乞珍宝。佛不应答。如是渐渐遂逐至寺。佛敷座坐已。语罗睺言。我于菩提树下得此珍宝。此财宝于一切宝中最胜第一。汝欲乐得不。罗睺答世尊言。甚乐沙门。佛即唤舍利弗。舍利弗来已。佛语舍利弗言。汝可度罗睺出家。舍利弗答言。善哉世尊。舍利弗即度罗睺出家。输头檀那王。闻罗睺罗出家。心大懊恼。即便匆匆往至佛所。白佛言。若有出家者。应先白父母。听者可度出家。若父母不听。愿佛莫度。是故律本中说。父母不听不得出家。若父母听出家已还俗。若后更欲出家。应白父母。父母不听不得出家。若有人求欲出家。比丘问言。汝父母听出家不。答言。不听。若不听者。不得出家。语比丘言。若不度我者。我当焚烧寺舍。若有如是难事度出家不犯。若有余方余国度出家。不须问父母。罗睺罗出家因缘竟沙弥有十恶。应灭摈。何者为十。杀盗淫欺饮酒毁佛法僧邪见坏比丘尼。是名十恶法。唯坏比丘尼净行。永摈不得出家。余九戒若能改悔。不更作得出家。此十三难人。为人作师。受具足戒。亦不得戒。教授师。若自羯磨。若他羯磨。出家有三种偷。一者偷形。二者偷和合。三者亦偷形亦偷和合。云何偷形。无师自出家。不依比丘腊。不依次第受礼。不入僧法事。一切利养不受。是名偷形。云何偷和合。有师出家受十戒。未受具足戒。往他方或言十腊。或言二十腊。次第受人礼。入僧布萨及一切羯磨。依次第受人信施。是名偷和合。云何亦偷形亦偷和合。无师自出家。依次第受腊。入一切羯磨。受人信施礼拜。是名偷形亦偷和合。偷形者。不经法事。不受信施。不受礼拜。若欲更出家受具足戒得。若有避难出家饥俭出家。不入一切法事。过难过饥俭已。若欲出家受具足戒得。若比丘实一腊。妄言二腊。依二腊次受利养。计钱犯重。若比丘水中脱衣洗浴。自言裸形好。若欲往外道处。步步突吉罗。中路悔还。忏悔突吉罗。得住若往外道处闻外道说法。不入其意悔还。忏悔突吉罗。得住。若入外道闻说法。心便好乐。受外道法。下至拔一发。患痛悔还。应灭摈。不得更出家。度外道竟。不得度龙者。何以故。龙不得禅定道果故。龙有五事。不得离龙身。何者五。一者行淫时。若与龙共行淫。得复龙身。若与人共行淫。不得复龙身。二者受生不离龙身。三者脱皮时。四者眠。五者死时。是为五事。不得离龙身。迦楼罗乃至释提桓因。不得出家。不得与具足戒。龙品竟。不得度杀父母人。杀父母。于出家法如来不听。若杀畜生父母。得出家。实是父作非父想杀。亦不得出家。不得度杀罗汉人。若有白衣得罗汉。若杀不得出家。若杀下三果人。不障出家。若畜生想杀罗汉不犯。业障重不得度人。坏比丘尼者。于三处行淫。皆名坏比丘尼。若摩触比丘尼。不障出家。若以白衣服。强与比丘尼着就行淫。亦名坏比丘尼。不得出家。若比丘尼乐着白衣服。就行淫者不障出家。若初坏者不得出家。第二坏者不障。若坏式叉摩尼沙弥尼。不障出家。破僧人不得度出家。云何破僧。若执十八事。三谏不舍。二根有三种。一者自受胎能令他受胎。二者自受胎不能令他受胎。三者不能自受胎能令他受胎。此三种人悉不得出家受具足戒若已受具足戒。应灭摈。若无和上。不得与受具足戒。若与受具足戒。得突吉罗。是人得戒。若黄门作和上。为人受戒得戒。师僧得罪。无衣钵受具足戒。得戒。师僧得罪。得二三人一时受具足戒。一一同等腊等。时不得相礼。同一和上一羯磨师。一时为三人受具足戒。一时得戒腊。同无大小。和上者。外国语。汉言知罪知无罪。是名和上。受戒已应步影。步影者。正立住取住脚为初。随身影长短步影。步影竟。教其时。其时者。或冬时或春时或夏时竟。教日月日月时。次教受戒时众数多少。次与四依已。次说四重受戒已。令新受戒者在前出。受戒犍度竟

尔时佛住罗阅城王舍城摩竭国。此三义一名异。汉言王舍城。罗阅城是外国音。罗者言王。阅者言舍。故言罗阅城也。摩竭者。此是外国音也。摩竭者。是初国名耳。界相者。若山界相。大者如须弥山。小者如象大。是为山相。石界相者。大者如牛。小者三十称。若漫石不得作界相。应别安石作界相。林界相者。若草林若竹林。不得作界相。何故尔。草竹体空不坚实。是以不得作界。林相者。大林相乃至百由旬。小林者下至四树连接。亦名为林树界相者。不得以枯树为相。大树者阎浮树。大小者高八寸。形如针大得作界相。若无自生树。种树亦得作界相。路界者。入田路。向井取水路。向河取水路。穷路。皆不得作界相。大路或车步路。路短者乃至经三四村。皆得作界相。蚁封界相者。大如山。小者高八寸。皆得作界相。江界相者。若好王治化五日一雨。此雨江水不得作界相。若四月日不雨。常流不断水深二尺。得作界相。水界相者。若自然池水。得作界相。若通水入田。或堈盛水。悉不得作界相。此是八种界相。结界相有五种。一方。二圆。三鼓形。四者半月形。五者三角。若依相结界已。后若失相。界亦不失。若人掘地乃至水际。皆不失界相。若结小界。不得说欲。结布萨界。得说欲。结界场。极小容二十一人。作界场已。后起屋覆。界不失。若结小界已。于中起三层楼。从地至最上层同一界。若有石山。上广下小。于上结界。若有比丘。在下不妨。若结界已。水荡成坑有水流。知其处所。竖柱为阁。于上作法事得。若结界已。水穿地为孔。不坏界相。神通比丘在窟里空中住。或在地下不得别作法事。若界场上。有大树枝叶出界外。若作法事时。比丘不得在树上妨作法事。应唤下。若神通比丘在露地虚空住。不妨作法事。若衣角柱地妨。应唤下结布萨界。极广得三由旬。不得过。若过不成界。得罪。除村村外界者。中人掷石以还。若比丘结界已。于比丘尼非界。比丘尼界上得更结界。比丘尼界亦不失。比丘尼于比丘界上亦得结。比丘界亦不失。阿兰若界者。极小方圆七盘陀罗。一盘陀罗二十八肘。若不同意者。二十八肘外。得作法事。一切江河水不得结界。水中自然界者。若掷水若掷沙已外。若有比丘不妨取水。常流处深浅。皆得作自然界。潮水不得。若在船上布萨。应下磸若下栋。不得系着岸。若崩岸。有大树根在水中。不得系着树根。若掷水水内有树根。应斫去。若不斫去。与陆地界相连。若水中大石或树或浮木。悉是水界所摄。第一句非法别众者。云何非法别众。同一住处有四比丘。一人受欲。三人说波罗提木叉。或三人。一人受欲。二人说波罗提木叉。是名非法。亦名别众。是名非法别众。第二句非法和合众者。同一住处有四比丘。四人应广说波罗提木叉。不广说。作三人法。人人对首说。是名非法和合众。第三句云何法别众。同一住处有四比丘或三人。一人受欲。三人对首说。或三人。一人受欲。二人对首说。是名法别众。第四句者。同一住处有四比丘。和合说波罗提木叉。或三比丘和合布萨三语说。是名法和合众。十六日布萨者。此是和合布萨。梵本律。五月十六日为前安居。六月十六日后安居。若安居中有因缘移去无罪。不成安居。不得在露地。不得伞下安居。脚下生毛者。其毛绀色。犹如空青。因业所报故得如是。问曰。何业所报。答曰。过去世时此守笼那。与八万人俱。于八万人中最为长大。共诸长者子。为辟支佛起一草屋。请辟支佛三月夏坐。时守笼那。以一羊毛钦婆罗敷草屋前。与辟支佛。恒用拭脚。以此果报。脚下生毛。此八万长者子。共供养辟支佛故。今生复为亲友。守笼那往至王所。何以与八万人俱。王若独唤守笼那者。畏其惊怖。是以敕诸长者子八万人俱往至王所。五象王者。一父象有六母象。名为象王。如是有五象王。加那腹罗革屣者。此是曼根革屣。鹿角革屣者。克皮作鹿角形。阿罗梨革屣者。以象毛安革屣边。腹罗跋陀罗革屣者。以木绵及诸杂物。与皮合缝。使中央起。真誓梨革屣者。以编草作。编边革屣者。以孔雀尾编边。多带革屣无解。似孔雀毛革屣者。其形似孔雀毛时王舍城有一童女。字婆罗跋提。端正无比。时瓶沙王举为淫女。王出百千金钱。诸臣长者出二百千钱。共庄束此淫女。为作屋宅。衣服车乘园林浴池种种伎乐。耆婆者。外国音。汉言活童子。何以名之活童子。时无畏王子。晨朝乘车欲往见王。路见小儿。问傍人言。此儿为死活。傍人答言活。是故言活童子。王子问曰。其母生已。何以掷置路上。答曰。此淫女法。若生女教习为淫女种。若生男则掷弃。是故生弃路上。王子无畏。抱取养育渐渐长大。即立为儿问曰。耆婆童子何不学余技术。答曰。往昔有佛。名曰莲花。时有一医师。恒供养莲花如来。耆婆见已心自念言。云何我未来世。得如此医供养如来。作是念已。即于七日中供养如来。往至佛所头面礼足。白佛言。愿我未来世作大医师供养佛。如今者医师供养佛无异。作是愿已礼佛而退。耆婆命终即生天上。天上福尽下生人间。如是展转乃至释迦出世。宿愿所牵不学余技。但学医方。问曰。耆婆所以善学医道者。耆婆就师学时。天帝释观见此人。医道若成必当供养佛。是故帝释化入耆婆师身中。以教耆婆。于七月中得师法尽。过七月已。帝释所教如是。满七年医道成就。耆婆还国。何以中路治病。其师心自念言。此是王子。不乏财宝。若还至本国不识我恩。作念已。即与耆婆弊故之衣。不与粮食。耆婆辞师还去。于其中路。为饥渴故。过一聚落。借问村人。谁家有病。村人答言。某长者家有病。即为治之。大获珍宝。耆婆自念。我治一人病。得如是珍宝。若治多人病者。当获无量珍宝。我今所获皆由师恩。受施有十五处。一者戒场界。二者境界界。三者同布萨界。四者不失衣界五者罗婆界。六者聚落界。七者村界。八者国土界。九者阿槃陀罗界。十者掷水界。十一者乡居界。十二者罗那界。十三者阿罗阇界。十四者洲界。十五者铁围山界。此是十五界。汝今当知。戒场界者。前已说。境界界者。或在讲堂。或在食堂分衣。健人二掷石已还。随界大小。皆有掷石界。比丘入皆得分。是名境界界。同布萨界者。若入布萨界者。皆应得分。是名布萨界。不失衣界者。入不失衣界内。皆应得分。是名不失衣界。罗婆界者。若王或大臣。为比丘作住止竟。或十由旬。若竖立柱若作标相。齐此标内。若有布施皆属我等。是名罗婆界。聚落界者。有市故。名聚落界。村界者。无市名为村界。国土界者。有城邑。名为国土界。阿槃陀罗界者。是阿兰若处界也。掷水界者。是船界。乡居界者。随城东西。名乡居界。罗那界者。是国土界也。阿罗阇界者。一王所领。是名阿罗阇界。洲界者。海中一洲。是名洲界。铁围界者。是一铁围山界。若人言布施界场众僧。属界场众僧。布萨界不得。若人言布施境界者。及掷石界得。若人言布施布萨界者。同利养界亦得。若人言布施不失衣界。布萨界利养界俱得。唯除布萨界中有聚落界。不得。若人言布施聚落界者。聚落界中有布萨界。大小皆得。若人言布施村界者。村中有布萨界及诸小界。皆得。若人言布施国土界者。一国土界尽得。若人言布施阿兰若处界者。阿兰若处得。余界不得。若人言布施掷水界者。入掷水界内得。余不得。若人言布施乡居界者。乡居中有界在乡居界中亦得。若人言布施罗那。一国土界亦得。若人言布施阿罗阇界者。一王所领一国土众僧皆得。若人言布施师子洲阎浮利地洲布施二洲众僧。随有众僧。多少应中半分。若阎浮利地五人。师子洲百千人。亦应中半分。若人言布施界内众僧。比丘应问。界有多种。施何物界。答言。不知。但言施界内众僧。随界内众僧多少皆得。别住处同利养。随住处得物应共分。僧得施者。若人言布施僧。鸣磬集众来及者得。若檀越担一衣。施僧与一比丘。比丘受已言我应受。此恶受。云何善受。应受已鸣磬集僧。集僧已。以黄物画作分数。不得破。从上座示此分。是上座分。上座取不。上座答言。此分我不取。布施长老。如是第二第三。上座皆言不取布施长老。乃至下座亦如是。此比丘得取。是名善受。若住处有一比丘。檀越将衣布施一比丘。此比丘应鸣磬集僧。若有比丘来共分。若无比丘来得。心念口言独受。若檀越布施僧。受粪扫衣比丘不得受。若人入住处布施僧。鸣磬集众。外比丘来相连臂入。乃至百由旬。前者入界内最后者亦得分。何以故。以相连不断。是故得分。若人布施二部僧。随人多少应中半分。若有百比丘尼。有一比丘。亦应中半分。若有百比丘。有一比丘尼。亦应得半。若人施僧钵囊革屣囊漉囊针刀子杖扇受粪扫衣比丘得受。若檀越担物布施一人。复言施僧。依僧次取一分。不得别取。若人施佛施比丘比丘尼。云何分。破作二分。一分与佛。一分与比丘比丘尼共等分。若人施众多比丘。施法师一人。施佛。云何分。佛一比丘众多比丘平等分。若人将余食施佛及僧。以钵置佛前次第行。佛饭谁得食。若有侍佛比丘得食。若无侍佛比丘。有白衣侍佛亦得食。若檀越布施安居竟僧。后安居者不得。破安居人亦不得。若人冬分中檀越言布施安居竟僧。前后安居僧悉得。唯除破安居人不得。若人言布施某寺某房。随檀越言得。若人言布施安居僧。前后安居破安居人皆得。若檀越布施迦提月后安居人。后安居人得。前安居人不得。若人于春分中布施安居僧。应问。为布施安居竟僧当来安居僧。答言。布施当来安居僧。当来安居僧得。比丘语檀越言。当来恐有贼难。不能掌护。檀越教分。随施主得分。若檀越言食我食布施衣。不食者不得受。我施药者亦如是。指示施者。随指示处得衣。犍度竟

药犍度

拘跋陀罗饭者。此是穄米饭也。修步者。此是青豆羹。吉罗者。此是竹笋也。那[少/兔]者。此是外国药无解。呿阇尼者。一切果。是名呿阇尼。呵罗勒者。如大枣大。其味酢苦。服便利。鞞醯勒者其形如桃子。其味甜。服能治嗽。阿摩勒者。此是余甘子也。广州土地有。其形如[卄/(麩-夫+壬)]子大。质多罗药。是外国药名。加婆药者。是外国药名。婆利婆婆者。是芥子。[貝*貳]渠者。外国药。能治毒。汉地无有。陀婆阇者。是烟药。耆罗阇那耆者。此是赤石也。眼药者。陀婆阇陀婆。阇那者。陆地生。耆罗阇那者。水中生也。龙者。长身无足。师子象马龙狗肉不得食。皮毛不得用。得一切肉应问。若得不问。得突吉罗罪。失守摩罗者。鳄鱼也。广州土境有黑石蜜者。是甘蔗糖。坚强如石。是名石蜜。伽尼者。此是蜜也。乌婆陀颇尼。颇尼者。薄甘蔗糖。边房云何结作净屋。若初竖柱时。先作坑以柱近坑。比丘围绕捧柱而说。为僧众作净屋。如是三说。说亦竟柱亦竖。第二第三第四柱亦如是说。若说一柱亦成净屋。若以成屋云何作净。应唤屋主来语言。此屋未净。汝为众僧作净。檀越作是言。此净屋布施众僧。随意受用。即成净屋。若先作屋无屋主。云何作净。若聚落有老宿。应唤来。此屋未作净。请为净主。若檀越不解说。比丘应教作是言。此是净屋布施众僧。随意受用。即得作净屋。受用随意。安置饮食。无内宿无内煮罪。阎浮子者。其形如沈苽大。紫色酢甜。舍楼伽者。此是忧钵罗拘物头花根舂取汁澄使清。是名舍楼伽浆。波漏师者。此似庵罗果。一切木果。得作非时浆。唯除七种谷不得。一切诸叶得非时服。唯除芋不得。一切诸花得作非时服。唯除摩头花汁。一切果中唯除罗多树果椰子果波罗奈子甜瓠子冬苽甜苽。此六种果不得非时服。一切豆不得非时服。盛水器者。木瓦铁。余者不得用。若自有种子众僧地。应半与众僧。若自有地众僧种子。应半与众僧。药揵度竟

善见律毗婆沙卷第十七善见律毗婆沙卷第十八

        萧齐外国三藏僧伽跋陀罗译

迦絺那衣犍度问曰。几人得受迦絺那衣。下至五人前安居人。得受迦絺那衣。破安居人后安居人不得。异住处不得。若住处不满五人得唤余寺众僧足数受得足数。客比丘不得受。若住处有四比丘。一沙弥安居欲竟。为沙弥受大戒。得足成五人受迦絺那衣。新受戒者亦成受。一比丘四沙弥受戒亦如是。若住处有五比丘若过五。不解受迦絺那衣。得余处请一知法比丘。使羯磨受迦絺那衣。得为羯磨。自不受亦不得衣分。法师问曰。何人得与众僧迦絺那衣。答曰七众衣天人衣。得受作迦絺那衣。若人不解作迦絺那衣来问。比丘应教。若僧伽梨郁多罗僧安陀会。随一一衣。得受作迦絺那衣。十六日明相出。将迦絺那衣裁来与众僧。比丘应语衣主。须针綖染色作衣比丘多少。檀越闻已应供养作衣比丘饮食。为僧受迦絺那衣。应知受衣法用。若衣裁者。应先浣与众多比丘共割裁簪缝治。即日染成点净已应受。若多有人送迦絺那衣。应受一衣。余应分。应羯磨受。僧持迦絺那衣与谁。应与衣坏者。若衣败比丘多败衣比丘中老者与。若无老者。腊数大者与。不得与悭。贪者。佛告诸比丘。当如是持迦絺那衣羯磨法。律中以说。若衣未成。应唤一切比丘共成。不得说道德作留难。唯除病者。法师曰。何以于迦絺那衣。如是殷勤。为诸佛所赞故。往昔有佛。名无莲花。有声闻弟子。名须阇多。作迦絺那衣未成。莲花佛与一万六千比丘围绕。共作迦絺那衣。成已。持衣比丘者。舍己所受持僧伽梨。迦絺那衣我今持。如是三说。三说已即持置体上。偏袒右肩往至上座前。合掌向僧而说。大德。我以法持僧迦絺那衣。愿僧随喜。上座从坐起。偏袒右肩合掌向僧。作如是说。长老。以法持僧迦絺那衣。我随喜。乃至下座亦如是说。非僧受持迦絺那衣。非众受持迦絺那衣。一人持迦絺那衣。僧随喜众随喜。然后成持迦絺那衣。若人持三衣与众僧。持作迦絺那衣。作是言。若持迦絺那衣者。三衣悉属。随施主语悉与受衣人。余众僧不得受。迦絺那衣已摄僧得施。受迦絺那衣者。轻物得分。重物属四方僧。若同布萨界有多住处。不得别受迦絺那衣。应和合一处受一迦絺那衣法。不得缝作。应却刺作。持所有衣者。未作持出界外。界外者。是余寺也。法师曰。受迦絺那衣已。何以出界外。为安乐住故。作不还意者比丘出界外已。见此住处有好房舍。或有知识。作不还意。先失住处。后失功德衣。余文句于律中已说。我亦不作衣。亦不还者。作念已住处及功德衣俱失。作衣时失。所作衣者。住处先失。后失功德衣闻失者。先失功德衣。后失住处。断望者。先失住处后望后望断得所望非望而得者。此文句前后转易。现多文句。无有深义。于律广说。迦絺那衣犍度竟。若行别住人。若有人请。或与人受戒。得停行法事罢还续行。舍行法时当如是言。我今舍波利婆沙。如是三说。若别住摩那埵。当行法时。比丘去都无人。但作意言。若比丘来我当白。六日中都无比丘可白。亦得出罪。若寺中多有比丘来去难白。昼日得舍行法。明相未出。应得四五比丘出界。二掷石外。还受行法白僧。我行摩那埵。若干日以过。余若干日在。若界内有比丘。出至其处应白。若不白失夜。若比丘送。受行法竟。若还者应留一人待明相出为舍行法。共还入寺如前法。满六夜已得出罪。出罪法。于律本已说。故不出。尔时拘睒弥有一住处。有二比丘。一是律师。一修多罗师。时修多罗师。入厕用洗盆竟。不去水覆盆。律师入厕。见洗盆不去水。问修多罗师言。谁入厕不去水覆瓮。修多罗师答言。是我。律师言。汝知罪相不。修多罗师言。我实不知罪相。律师言。汝得突吉罗罪。修多罗师言。若犯突吉罗罪。我应忏悔。律师言。汝故作与不。修多罗师言。不故作。律师言。若不故作者无罪。修多罗师闻律师言无罪。律师还房语弟子言。修多罗师不知犯不知不犯。弟子闻师语已。语修多罗师弟子言。汝师不知犯不犯。弟子闻语已。向师说如是事。修多罗师闻弟子语。语弟子言。此律师先言我无罪。今言我有罪。律师妄语。修多罗师弟子闻师语已。语律师弟子言。汝师犯妄语罪。律师弟子闻语已向师说。如是展转成大斗诤。律师后得修多罗师便。集众举修多罗师罪。为作举罪羯磨。是故律本中说。和合举罪。问曰。佛何以从坐起。以神通力不语诸比丘往舍卫国。答言。佛在众中若为判者。得理者欢喜。不得理者便言。佛朋傥彼部。诽谤佛言随爱嗔。因谤佛故死入地狱。是故佛从坐起去。不为其判。拘睒弥揵度竟。瞻婆揵度无解。相言诤用二毗尼灭。现前毗尼多觅毗尼。忆念毗尼者。为爱尽比丘。下至阿那含人。不为凡夫多觅毗尼者。处处多觅知法比丘判故。名多觅毗尼。摩夷者。是二部波罗提木叉。若行舍罗。非法舍罗多者。收取唱言。明日更行舍罗。于其中间。更觅如法伴党。若上座捉非法舍罗者。行筹者耳语。语言。上座年老。何以捉非法筹。当捉如法筹。七灭诤法竟。比丘尼犍度。何以佛不听女人出家。为敬法故。若度女人出家。正法只得五百岁住。由佛制比丘尼八敬。正法还得千年。法师曰。千年已佛法为都尽也。答曰。不都尽。于千年中得三达智。复千年中得爱尽罗汉。无三达智。复千年中得阿那含。复千年中得斯陀含。复千年中得须陀洹学法。复得五千岁。于五千岁得道。后五千年学而不得道。万岁后经书文字灭尽。但现剃头有袈裟法服而已。比丘尼犍度竟。重物不得分。众僧田园池井。不得卖取余物。唯除换易众僧床席器物。不得分不得卖。唯除换易。眼药筒挑耳篦针綖小刀子户钩钥锡杖小桓铁器杖得分。余作器不得分。唯除斫杨枝斧。除刀子革屣伞具得分。若人布施竹草及土。不得分。若人布施药得分。箱箧不得分。若人布施僧房中所用器物。一切不得分。唯除盛油筒。法犍度竟

    大德舍利弗问优波离律污出品

舍利弗问优波离　　几罪以身得　　几罪以口得　　覆藏得几罪　　相触复有几

优波离以偈答舍利弗　　以身得六罪　　口业复有六　　覆藏得三罪　　相触得五罪

第二问　　明相出几罪　　三唱复有几　　于此几八事　　一切聚有几

答曰　　明相出三罪　　三唱有二种　　于此一八事　　一切聚有一

第三问　　如来分别结　　毗尼有几相　　毗尼重有几　　复有几粗覆

答曰　　如来分别说　　毗尼有二相　　毗尼重有二　　覆粗亦有二

第四问　　聚落间几罪　　渡江复有几　　啖肉几偷兰　　啖肉几突吉

答曰　　聚落间有四　　渡江亦有四　　一肉偷兰遮　　九肉突吉罗

第五问　　夜语几得罪　　昼日复有几　　布施得几罪　　受施得几罪

答曰　　夜语有二罪　　昼日亦有二　　布施得三罪　　受施得四罪

第六问　　几罪对首悔　　几罪须羯磨　　作已不可悔　　如来分别结

答曰　　五罪可忏悔　　第六须羯磨　　一罪不可忏　　如来分别结

第七问　　毗尼重有几　　佛说身口业　　非时几谷味　　几白四羯磨

答曰　　毗尼有二重　　身口亦如是　　非时谷一味　　一白四羯磨

第八问　　波罗夷有几　　几同和合地　　复有几失夜　　结二指有几

答曰　　波罗夷有二　　和合地有二　　失夜亦有二　　结二指有二

第九问　　打身有几种　　几种众僧破　　作初罪有几　　作白复有几

答曰　　打身有二种　　因二破众僧　　作初有二罪　　作白亦有二

第十问　　杀生有几罪　　重语有几种　　骂詈有几种　　行媒有几种

答曰　　杀生有三罪　　重语有三罪　　骂詈亦有三　　行媒有三罪

第十一问　　几人受具戒　　聚作有几罪　　灭摈复有几　　一语复有几

答曰　　三人不得受　　聚作复有三　　灭摈亦有三　　一语亦有二

第十二问　　盗戒有几罪　　淫戒复有几　　正断复有几　　因弃掷有几

答曰　　盗戒有三罪　　淫戒有四罪　　正断亦有三　　因弃掷有三

第十三问　　教比丘尼戒　　几波夜突吉　　于中几有新　　衣有几种衣

答曰　　教尼戒品中　　波夜突吉罗　　有四信佛说　　与衣二种罪

第十四问　　佛说尼有几　　波罗提有几　　食生谷有几　　波夜突吉罗

答曰　　佛说比丘尼　　波罗提有八　　波夜提突吉　　因乞生谷故

第十五问　　行时有几罪　　立时有几罪　　坐时有几罪　　眠时有几罪

答曰　　行时有四罪　　立时有四罪　　坐时有四罪　　眠时有四罪

第十六问　　波夜提有几　　一切非一种　　非前亦非后　　同一时而得

答曰　　波夜提有五　　其类非一种　　非前亦非后　　一时俱得罪

第十七问　　有几波夜提　　一切非一种　　非前亦非后　　同一时而得

答曰　　有九波夜提　　其类非一种　　非前亦非后　　一时俱得罪

第十八问　　有几波夜提　　其类非一种　　以身口忏悔　　如来分别说

答曰　　有五波夜提　　其类非一种　　以口业忏悔　　如来分别说

第十九问　　有几波夜提　　其类非一种　　几以口业忏　　如来分别说

答曰　　有九波夜提　　其类非一种　　一以口业忏　　如来分别说

第二十问　　有几波夜提　　其类非一种　　口语成忏悔　　如来分别说

答曰　　有五波夜提　　其类非一种　　发语名字忏　　如来分别说

第二十一问　　有几波夜提　　其类非一种　　聚性成忏悔　　如来分别说

答曰　　有九波夜提　　其类非一种　　聚性成忏悔　　如来分别说

第二十二问　　第三罪有几　　因食复有几　　食时得几罪　　因食得几罪

答曰　　第三得三罪　　因食有六罪　　食时得三罪　　因五食得罪

第二十三问　　一切第三过　　至处复有几　　复问罪有几　　诤事复有几

答曰　　一切第三过　　罪至有五处　　善答罪有五　　诤事亦有五

第二十四问　　论事复有几　　以几法用灭　　有几不得罪　　有几处成善

答曰　　论事复有五　　以五法用灭　　清净有五种　　三处中成善

第二十五问　　身业夜几罪　　身业昼几罪　　见时得几罪　　乞食得几罪

答曰　　身业夜二罪　　身业昼二罪　　见时得一罪　　乞食得一罪

第二十六问　　见恩有几种　　依人成忏悔　　驱出复有几　　善行复有几

答曰　　见恩有八种　　依人成忏悔　　驱出说有三　　善行四十三

第二十七问　　妄语有几处　　七日复有几　　波罗提舍几　　发忏悔有几

答曰　　妄语有五处　　七日法有二　　十二提舍尼　　忏悔复有四

第二十八问　　妄语有几观　　布萨有几观　　使者有几观　　外道有几法

答曰　　妄语有八观　　布萨复有八　　使者亦有八　　外道有八法

第二十九问　　受戒有几语　　复有几起敬　　几人应豫座　　教诫尼有几

答曰　　八语受具戒　　起敬亦有八　　豫座复有八　　八法教诫尼

第三十问　　几人不应礼　　不为作叉手　　有几突吉罗　　用衣复有几

答曰　　十人不应礼　　不为作叉手　　有十突吉罗　　用衣复有十

第三十一问　　有几作不善　　如来分别说　　于瞻婆律中　　一切不善作

答曰　　十二作不善　　如来分别说　　于瞻婆律中　　一切不善作

第三十二问　　随大德所问　　我亦随意答　　问问中即答　　无有一狐疑

一者身得。二者口得。三者身口得。四者身心得。五者心口得。六者身口心得

身业得六罪者。淫怒为初。口业得六罪者。虚诳妄语为初

覆藏得三罪者。一者比丘尼覆藏重罪。得波罗夷。二者比丘覆藏他重罪。得波夜提。三者比丘自覆藏重罪。得突吉罗。是名覆藏得三罪

相触得五罪者。一者比丘尼摩触波罗夷二者比丘摩触僧残。三者比丘以身触女人衣得偷兰遮。四者比丘以衣触女人衣。得突吉罗。五者比丘指挃他比丘波夜提。是名五罪

明相出得三罪者。一夜六夜七夜十夜过一月明相出。尼萨耆波夜提。比丘尼独宿明相出僧残。比丘自覆罪明相出突吉罗。是名明相出得三罪。三唱二种。一者比丘。二者比丘尼。当说戒时三唱。有罪不发露。得突吉罗。是名三唱二罪。于律中具八事成罪者。比丘尼波罗夷。是一切聚有一者。戒序中说。忆有罪应发露。发露者。五篇戒也。故言聚有一。如来分别说者。分别戒相轻重。毗尼有二重者。身口是。毗尼重有二者。波罗夷僧残是也。覆粗亦有二者。一波罗夷。一僧残

聚落间有四者。一比丘与比丘尼共期行。比丘初去时突吉罗。至聚落境界。比丘得波夜提罪。一脚在内一脚在外。比丘尼得偷兰遮。二脚尽入僧残。是名聚落间四罪。度江有四罪者。比丘与比丘尼共期船行。初去时比丘得突吉罗。上船比丘得波夜提。比丘尼一脚上岸。得偷兰遮。二脚俱上得僧残。是名度江四罪。一肉偷兰遮者。即是人肉九肉突吉罗。象马狗等肉。夜语有二罪者。若比丘尼。共男子入闇室屏处耳语。得波夜提。若比丘尼。共男子一处去二肘外。得突吉罗。是名夜语二罪

昼日亦有二者。比丘尼共男子屏处。若二肘半内得波夜提。二肘半外。得突吉罗。是名昼日二罪。布施得三罪者。比丘有杀心。布施毒药杀人。得波罗夷罪。杀非人得偷兰遮罪。杀畜生得波夜提罪。是名布施三罪。受施得四罪者。女人以手施与。比丘捉得僧残。女人以淫欲施比丘。得波罗夷。非亲里比丘尼施衣。得尼萨耆波夜提。若比丘尼染污心。知染心男子受食。得偷兰遮。是名受施得四罪。五罪可忏悔者。僧残偷兰遮。波夜提。波罗提提舍尼。突吉罗恶说。是名五罪可忏悔。第六须羯磨者。僧伽婆尸沙。一罪不可忏者。波罗夷是也。毗尼有二重者。一波罗夷。二僧残。身口亦如是者。结戒不过身口。非时谷一味者。稣毗盐以谷作。得非时服。是名谷一味。一白四羯磨者。差教诫比丘尼是。波罗夷有二者。一比丘二比丘尼是也。和合地有二者。一身和合。二法和合。失夜亦有二者。一行波利婆沙。二行摩那埵是也。结二指有二者。一比丘尼洗净。二头发长。不得过二指。打身得二罪者。比丘尼打身得突吉罗。啼得波夜提是。因二破众僧有。一羯磨。二捉舍罗是。初作有二罪者。一比丘作初罪。二比丘尼作初罪是。作白亦有二者。一白羯磨二单白。杀生有三罪者。人得波罗夷。非人偷兰遮。畜生波夜提。语重有三罪者。教偷教死向人说得圣利法。是名语有三重。骂詈亦有三者。若欲心骂女根谷道二僧残。骂余身分。得突吉罗。是名三罪。行媒有三罪者。受语时得突吉罗。往说偷兰遮。还报得僧残。是名三罪。三人不得受者。一远不闻。二身分不具足。三根不具足。衣钵不具足。身分所摄。十三难人。是根不具足所摄。聚作复有三者。一别众。二白不成就。三羯磨不成就。是名三。灭摈亦有三者。一比丘尼以身谤人。如慈地比丘尼。二沙弥坏沙弥。就他谷道行淫。三言行淫欲法不障道者。是名灭摈三罪。一语亦有三者。一羯磨三人一时得戒。是名三。盗戒有三罪者。五钱波罗夷。四钱偷兰遮。三钱乃至一钱突吉罗。是名盗三罪。淫戒有四罪者。一女根波罗夷。死女半坏偷兰遮。不触四边突吉罗。比丘尼以物作根自内根中。得波夜提。是名四罪。正断亦有三者。一断人命波罗夷。二断草木波夜提。三自截男根偷兰遮。是名三因。弃掷有三者。有杀心弃掷毒药。若人得死波罗夷。非人死偷兰遮。畜生死得波夜提。是名三弃掷。复有三。比丘弃掷精僧残弃掷大小便生草上。得波夜提。水中净地。得突吉罗。涕唾亦如是。是名弃掷三。波夜提突吉罗者。教诫比丘尼至日没。得波夜提先说法后说八敬。得突吉罗。有四信佛说者。一房舍。二戒。三如法作。四不如法作。是名四。与衣二种罪者。与非亲里具足比丘尼衣。得波夜提。与不具足戒比丘尼衣。得突吉罗。不具足戒者从比丘尼白四羯磨未从大僧白四羯磨。是名与衣二。波罗提有八者。比丘尼波罗提提舍尼是。波夜提突吉罗者。比丘尼乞生谷。得波夜提。食时突吉罗。行时有四罪者。比丘与女人共期。初去时得突吉罗。至村得波夜提。比丘尼独行去时。得偷兰遮。至村得僧残立时有四罪者。比丘尼共男子立在屏处。得波夜提。申手外得突吉罗。若比丘尼。明相欲出不随伴去。住离申手内偷兰遮。申手外得僧残。坐眠亦如是。波夜提有五者。酥油蜜石蜜脂。五器各受过七日服。得五波夜提罪。其类非一种者酥蜜等也。非前亦非后者。取聚置一处。并服一时。俱得罪。有九波夜提者。乞九种美食。一乳。二酪。三生酥。四熟酥。五油六蜜七石蜜。八肉。九鱼。是名九种。其类非一种各异也。非前亦非后者。因食时俱得罪。一时食也。有五波夜提者。其五波夜提。其类非一种。以口业忏悔。一时忏悔得灭。有九波夜提者。乞九种美食。得九波夜提罪。其类非一种者。酥油鱼肉相异。一以口业忏者。九波夜提罪。一语忏便得灭也。有五波夜提者。发语名字忏者列罪名而忏悔。有九波夜提者。取姓成忏悔者列罪名而忏。第三得三罪者。随举比丘尼三谏不舍波罗夷。比丘被僧三谏不舍僧残。比丘比丘尼恶见。三谏不舍波夜提。因食得六罪者。云何得六罪。一为饮食故。自称得过人法。二为饮食故行媒。三为饮食故言。若人住此寺者得道果。不自道名字故。得偷兰遮。四为饮食故。无病乞食。五为饮食故。比丘尼无病乞食。犯波罗提提舍尼。六为饮食故。比丘无病乞饭。得突吉罗罪。是名因食得六罪。食时得三罪者。比丘食人肉偷兰遮。象马龙狗等肉突吉罗罪。比丘尼食蒜得波夜提罪。是名食时三罪。因五食得罪者。比丘尼知男子染污心。从乞得人肉得蒜。得美食象马肉。受染污心男子食僧残。啖人肉偷兰遮。啖蒜波夜提。乞美食波罗提提舍尼。象马等肉突吉罗。是名因五食得罪。一切第三过者。比丘尼随举。初谏不舍突吉罗。一羯磨不舍偷兰遮。三羯磨不舍波罗夷。是名三谏三罪。罪至有五处者。比丘随举白不舍突吉罗。一羯磨不舍偷兰遮。三羯磨不舍波罗夷。若欲破僧三谏不舍僧残。恶见三谏不舍波夜提。是名五罪。善答罪有五者。比丘比丘尼式叉摩尼沙弥沙弥尼。五众具有三谏不舍罪。诤事亦有五者。五众俱有四诤。论事复有五者。论五众诤事。以五法用灭者。五众灭五众诤事。清净有五种者。五众犯罪忏悔得清净。三处中成善者。僧处众处白衣三处无诤。是名善也。身业夜二罪者。比丘尼与男子共业夜入屋。申手内波夜提。申手外突吉罗。身业昼二罪者。比丘尼昼日与男子共屏处。申手内波夜提。申手外突吉罗。见时得一罪者。比丘故看女根。得突吉罗罪。乞食得一罪者。比丘无病。不得为身乞食。得突吉罗。见恩有八种者。于拘睒弥犍度已说。依人成忏悔者。五众悔罪。要因人得悔。驱出说有三者。一覆藏。二未忏悔。三恶见。善行四十三者。摈人行四十三法得入众。不行此法不得入众。妄语有五处者。波罗夷僧残偷兰遮波夜提突吉罗。七日法有二者。七日药受七日法出界外。是名二。十二提舍尼者。比丘尼八波罗提提舍尼。比丘四波罗提提舍尼。合十二。忏悔复有四者。提婆达多遣人害佛。供养阿[少/兔]留陀。优婆夷离车子。众僧为作覆钵羯磨。沙婆伽比丘此四种人就佛忏悔。妄语有八观者。发心欲妄发口成妄语。妄语竟知是妄语。隐藏所知妄道余事。前人知解邪心。是名观也。布萨复有八者。八戒也。使者亦有八者。调达以非法欲破僧。僧差具八德人往说。调达所作。非佛法僧。是调达所作也。外道有八法者。外道欲出家。行波利婆沙八法者。不往五不应行处。闻赞佛法僧欢喜。八语受具戒者。比丘尼白四羯磨。比丘白四羯磨。起敬亦有八者。比丘尼八敬法也。豫座复有八者。大众集时。上座八人次第坐。余者随坐。八法教诫尼者。比丘有八德。堪教诫比丘尼。十人不应礼。比丘尼。式叉摩那尼。沙弥。沙弥尼。优婆塞。优婆夷犯戒人。眠人。食人。大小便嚼杨枝人。十人不为作者如前。十种人不得作叉手。有十突吉罗者。若为上十种人。作礼及叉手。得突吉罗。用衣复有十者。十种衣听着。十二作不善者。白不善。非法别众。非法和合众。法别众。白羯磨中有四非法。白二羯磨中有四非法。白四羯磨中有四非法三四合十二非法

善见律毗婆沙卷第十八


舍利弗问经

    No. 1465

舍利弗问经

        附东晋录

如是我闻。一时佛住罗阅只音乐树下。与大比丘众一千二百五十人俱。名闻十方结尽解脱。八部鬼神等愿闻法要

舍利弗从座而起。前白佛言。世尊。佛是法王。随众生欲散说法教。令诸天人恭敬奉持。或闻传闻。或行不行。云何名行法者。云何名不行法者。佛言。善哉善哉。汝能为诸众生。作如是问谛听谛听。吾为汝说。夫行法者。有闻而持。有传闻而持。皆名曰僧。如宝事比丘。闻佛所说诸行无常。即观生灭断诸有漏。真吾弟子是行法者。其传闻者。如观身比丘闻汝说。迦留陀夷说。饮酒者开放逸门。于行道者作大留难。即入无诤三昧。得见道断集。行我法者不行非法。行非法者是名不行是非法人。非吾弟子。入邪见稠林。舍利弗白佛言。云何世尊。为诸比丘所说戒律。或开或闭。如为忽起长者设供。断诸比丘不听朝食。如为社人请。复听食饭[米*(犮-乂+又)]鱼肉。如为频富村人请。复不听食饭但食薄粥。如为频婆娑罗王请。复听饱食饭食。如为阐陀师利请。复听多家数数食。皆不得饱。诸如此语。后世比丘比丘尼优婆塞优婆夷。云何奉持。佛言。如我言者。是名随时。在此时中应行此语。在彼时中应行彼语。以利行故皆应奉持。我寻泥洹。大迦叶等当共分别。为比丘比丘尼作大依止。如我不异。迦叶传付阿难。阿难复付末田地。末田地复付舍那婆私。舍那婆私传付优波笈多。优婆笈多后。有孔雀输柯王。世弘经律。其孙名曰弗沙蜜多罗。嗣正王位顾问群臣。云何令我名事不灭。时有臣言。唯有二事。何等为二。犹如先王造八万四千塔。舍倾国物供养三宝。此其一也。若其不尔。便应反之。毁塔灭法。残害息心四众。此其二也。名虽好恶俱不朽也。王曰。我无威德以及先王。当建次业以成名行。即御四兵攻鸡雀寺。寺有二石师子。哮吼动地王大惊怖退走入城人民看者嗟泣盈路。王益忿怒。自不敢入驱逼兵将乍行死害。督令勤与呼摄七众。比丘比丘尼沙弥沙弥尼式叉摩尼出家出家尼一切集会。问曰。坏塔好不。坏房好不。佥曰。愿皆勿坏。如不得已。坏房可耳。王大忿厉曰。云何不可。因遂害之无问少长。血流成川。坏诸寺塔八百余所。诸清信士。举声号叫悲哭懊恼。王取囚系加其鞭罚。五百罗汉登南山获免。山谷隐险军甲不能至。故王恐不洗赏慕诸国。若得一首即偿金钱三千君徒钵叹阿罗汉。及佛所嘱累流通人。化作无量人。捉无量比丘比丘尼头。处处受金王诸库藏一切空竭。王益忿怒。君徒钵叹现身入灭尽定。王自加害。定力所持初无伤损。次烧经台。火始就然飙炎及经。弥勒菩萨以神通力。接我经律上兜率天。次至牙齿塔。塔神曰。有虫行神。先索我女。我薄不与。今誓令护法。以女与之使至心伏。虫行神喜。手捧大山用以压王及四兵众一时皆死。王家子孙于斯都尽。其后有王。性甚良善。弥勒菩萨化作三百童子。下于人间以求佛道。从五百罗汉咨受法教。国土男女复共出家。如是比丘比丘尼还复滋繁。罗汉上天。接取经律还于人间。时有比丘名曰总闻。咨诸罗汉及与国王。分我经律多立台馆。为求学来难

时有一长老比丘。好于名闻亟立诤论。抄治我律开张增广。迦叶所结名曰大众律。外采综所遗诳诸始学。别为群党互言是非。时有比丘。求王判决。王集二部行黑白筹。宣令众曰。若乐旧律可取黑筹。若乐新律可取白筹。时取黑者乃有万数。时取白者只有百数。王以皆为佛说。好乐不同不得共处。学旧者多从以为名为摩诃僧祇也。学新者少而是上座。从上座为名。为他俾罗也。他俾罗部。我去世时三百年中。因于诤故。复起萨婆多部及犊子部。于犊子部。复生昙摩尉多别迦部。跋陀罗耶尼部。沙摩帝部。沙那利迦部。其萨婆多部。复生弥沙塞部。目揵罗优婆提舍。起昙无屈多迦部。苏婆利师部。他俾罗部。复生迦叶维部。修多兰婆提那部。四百年中。更生僧伽兰提迦部。摩诃僧祇部。我灭度时二百年中。因于异论生。起鞞婆诃罗部。卢迦尉多罗部。拘拘罗部。婆收娄多柯部。钵蜡若帝婆耶那部。三百年中。因诸异学。于此五部。复生摩诃提婆部。质多罗部。末多利部。如是众多久后流传。若是若非。唯余五部各举所长。名其服色。摩诃僧祇部。勤学众经宣讲真义。以处本居中。应着黄衣。昙无屈多迦部。通达理味开导利益。表发殊胜。应着赤衣萨婆多部。博通敏达以导法化。应着皂衣迦叶维部。精勤勇猛摄护众生。应着木兰衣。弥沙塞部。禅思入微究畅幽密。应着青衣。是故罗旬喻比丘分卫。不能得食。后以五种律衣更互而着。便大得食。何以故。是其前世执性多悭。见沙门来急闭门户云。大人不在。见他布施欢喜摄念。发心愿作沙门。是故今身虽得出家穷弊如此。我法出家。纯服弊帛及死人衣。因罗旬踰故。受种种衣也。舍利弗言。如来正法。云何少时分散如是。既失本味云何奉持。佛言。摩诃僧祇其味纯正。其余部中如被添甘露。诸天饮之。但饮甘露弃于水去。人间饮之水露俱进。或时消疾或时结病。其读诵者亦复如是。多智慧人能取能舍。诸愚痴人不能分别。舍利弗言。如来先云。若寒国土。听诸比丘身着俗服及覆头首。迦那比丘行大林聚落。值天大寒鸟兽死尽。村人与其俗衣。世尊令其忏悔何耶。佛言。听着染色置在衣里耳。舍利弗言。云何世尊常言。诸比丘不得以钵布地。当擎以净物。若无净物。当以草叶木叶。君输柯比丘。与其眷属受日难王请。行净板擎钵。云何世尊。而骂之言。是恶魔行非行法者。我言以清净物不受染。若净无者。乃用草木之叶。一用即弃。不得用木皮木肉。以其体中本有胶故。若胶若漆。以受尘故若已枯燥。本是有故。湿热更流故。舍利弗白佛言。世尊。云何听诸比丘受施主请食及僧家常食。云何兰若提比丘。受无畏长者。请食如来骂云。是土木人。不应食人食也。佛言。以破坏威仪行食之。时但以眼视不以手受。外道梵志尚知受取。况我弟子而不受食。何况于食。一切诸物不得不受。唯除生宝及施女人。若作法者。犹应授与体上之衣。若贮金器受则判施。舍利弗白佛言。云何世尊。说遮道法不得饮酒。如葶苈子。是名破戒开放逸门。云何迦兰陀竹园精舍。有一比丘疾病。经年危笃将死。时优波离问言。汝须何药。我为汝觅。天上人间乃至十方。是所应用我皆为取。答曰。我所须药是违毗尼故。我不觅以至于此。宁尽身命无容犯律。优波离言。汝药是何。答曰。师言须酒五升。优波离曰。若为病开如来所许。为乞得酒。服已消差。差已怀惭。犹谓犯律。往至佛所殷勤悔过。佛为说法。闻已欢喜得罗汉道。佛言。酒有多失开放逸门。饮如葶苈子。犯罪已积。若消病若非先所断。舍利弗又白佛言。云何如来常言。不得杀众生乃至蚁子。而以腊月八日。于舍卫国长水河边。与输丽外道捔术。先逼以神通力令堕负处。其生惭羞投水自尽。眼视沉没而不拯救。不亦杀乎。方复告众言。输丽持此恶法惑乱众生。前世善熟灭此恶身转生善见不亦快乎。我诸弟子。当于此日设清净浴洗。浣身垢念除倒见身。若清净心亦清净。似结使人无有慈悲。佛言。大智。汝能为诸未通达者。问斯诚要。输丽外道。于无量世中积习邪见。誓障正法。往昔灯明佛时。我行菩萨道。遇一村落。人多疠病。死者纵横。我采众药随宜救济皆得除愈。其中一人名曰不戴(吴音)是梵志学自负多能。不肯信服。临欲终时方复求我。我语之云。汝先可治与药不取。今将气尽方复有求。如汝即时非药能治。不戴曰。我今不能复判优劣。愿未来世共决胜负。我若负者当杀身。求生为汝弟子。汝若不如为我走使。时我报云。善哉善哉。故今生此土与我相值。临终善熟共契所会。发言失据耻其眷属。投水自害。身虽死亡。心发善故。生我法中。有胜进故我不救也。舍利弗言。云何于训戒中。令弟子偏袒右肩。又为迦叶村人说城喻经云。我诸弟子当正被袈裟。俱覆两肩勿露肌肉。使上下齐平现福田相行步庠序。又言。勿现胸臆。于此二言云何奉持。佛言。修供养时。应须偏袒。以便作事。作福田时。应覆两肩。现田文相。云何修供养。如见佛时问讯师僧时。应随事相。若拂床。若扫地。若卷衣裳。若周正荐席。若泥地作华。若揵高足下。若洒若移种种供养。云何作福田时国王请食。入里乞食。坐禅诵经巡行树下。人见端严有可观也。舍利弗复白佛言。世尊。八部鬼神。以何因缘生于恶道。而常闻正法。佛言。以二种业。一以恶故生于恶道。二以善故多受快乐。又问。善恶二异可得同耶。佛言。亦可得耳。是以八部鬼神。皆曰人非人也。天神者。其之先身。以车舆舍宅饮食。供养三宝父母贤胜之人。犹怀悭俭谄嫉妒者故。受天神身。如普光净胜天神等。虚空龙神者。修建德本。广行檀波罗蜜。不依正念。急性好嗔故。受人非人身。如摩尼光龙王等。夜叉神者。好大布施。或先损害。后加饶益。随功胜负。故在天上空中地下。乾闼婆者。前生亦少嗔恚。常好布施。以青莲自严。作众伎乐。今为此神。常为诸天奏诸伎乐。阿修罗神者。志强。不随善友所作净福。好逐幻伪之人。作诸邪福。傍于邪师。甚好布施。又乐观他斗讼。故受今身。迦娄罗神者。先修大舍。常有高心。以倰于物故受今身。紧那罗神者。昔好劝人发菩提心。未正其志逐诸邪行。故得今身。摩睺罗伽神者。布施护法性好嗔恚。故受今身。人非人等。皆由依附邪师行谄恶道。以邪乱正俱谓是道。以自建立。夫出世道者。不杂魔邪谄悦之语。谄悦之语非出生死。是入恶道。谄悦邪人所可言说。大观似道细则睒铄。当依正法及行正法者。当得佛法僧力解脱无为。若依相似法。依行邪导师。系缚生死永沦恶趣。是无知人非求出世。入邪见网。邪导师者。虽读众经。以邪事业矫制邪科。出邪谄法诳惑凡人。以求敬仰非人所知。说云我知。非人所得。说云我得。或人难曰。那知那得。答曰。空界天神幽中知识。密以语我。或云。某年某月有利有害。逆相开示应防应救。此灭彼兴我得汝失。如是欺诳薄俗之人。不能深思德本。随逐邪末失其正见。兴造邪业生顾钱帛。死入恶道。拔舌吞铜百千万岁。后作畜生亦无量岁。复生为鬼。或在山林旷野河海舍宅。益怀谄诳无有休息。或迷谤行人使失道径。或示语邪巫言。先亡形服恐动百端。甚可恶贱求人饮食。无有终极。值我弟子心怀正直不失正念者。闻即呵叱终敢复为。若我弟子。心怀怯弱易失心者。从其求免踰得其便。千端万绪求索无厌。如是之人无丈夫相。为邪所动。死堕恶趣。甚可悲念。舍利弗复白佛言。八部鬼神。依空为空神。依地为地神耶。佛言别有地神。如净华光等。过去世时好修布施。多嗔难满嗜酒喜歌舞。故作此神。着纯白之衣。洁净无垢。舍利弗。复白佛言。云何如来。告天帝释及四天大王云我不久灭度。汝等各于方土护持我法。我去世后。摩诃迦叶。宾头卢君徒般叹。罗睺罗。四大比丘住不泥洹。流通我法。佛言。但像教之时信根微薄。虽发信心不能坚固。不能感致诸佛弟子。虽专到累年。不如佛在世时一念之善。其极慊至无复二向。汝为证信。随事厚薄为现佛像僧像。若空中言。若作光明。乃至梦想。令其坚固。弥勒下生听汝泥洹。舍利弗复白佛言。如来现世二十年前。度诸弟子无有常施随有便施。自二十年后。施多定物。是义云何。佛言。有长者子。名曰分若多罗。宿有善根。生婆罗门家。乐欲舍家修无上道随大目犍连。于巴连弗邑天王精舍。求受具戒。目连语云。汝可七日七夜悔汝先罪皆使清净。无诸妨障者。我当为汝从僧中乞。分若多罗言。云何得知妨障已灭。云何得知我受得戒。仰愿诸佛。加我威神。令我罪灭得见得戒之相。佛言。汝但勤诚。诚至自见。分若白佛。谨奉尊教。恳恻日夜到第五夕。于其室中雨种种物。若巾若帊若拂若帚若刀若斧若锥若铲次第分别堕其目前。分若多罗。生欢喜心。生得果心。满七日已。具白目连。目连问我。我语之曰。是离尘相拂割之物也。当以嚫师。师其缘也。夫受戒者。随其力办可以为施。不限于此不必备此。舍利弗复白佛言。世尊。有诸檀越。造僧伽蓝厚置资给供。来世僧有似出家僧。非时就典食僧。索食而食。与者食者得何等罪。其本檀越得何等福。佛言。非时食者。是破戒人。是犯盗人。非时与者。亦破戒人。亦犯盗人。盗檀越物是不与取。非施主意施主无福。以失物故。犹有发心置立之善。舍利弗言。时受时食。食不尽者非时复食。或有时受至非时食。复得福不。佛言。时食净者。是即福田。是即出家是即僧伽。是即天人良友。是即天人导师。其不净者。犹为破戒。是大劫盗。是即饿鬼。为罪窟宅。非时索者。以时非时非时辄与。是典食者。是名退道。是名恶魔。是名三恶道。是名破器。是癞病人。坏善果故。偷乞自活。是故诸婆罗门。不非时食。外道梵志亦不邪食况我弟子知法行法。而当尔耶。凡如此者非我弟子。是盗我法利。着无法人。盗名盗食。非法之人。盗与盗受。一团一撮片盐片酢。死堕燋肠地狱。吞热铁丸。从地狱出生猪狗中。食诸不净。又生恶鸟。人怪其声。后生饿鬼。还伽蓝中处。都圊内啖食粪秽。并百千万岁。更生人中贫穷下贱。人所弃恶。所可言说人不信用。不如盗一人物其罪尚轻。割夺多人故。良福田故断绝出世道故。舍利弗复白佛言。如来宗亲多有出家。为自发心。为佛神力耶。佛言。诸释憍慢着乐。何能愿乐。特是父王宣勒。宗室生二子者。一人随我。阿那律久积善根深乐正法。携率释子跋提难提金毗罗难陀跋难陀阿难陀提婆达多优波离。澡浴清净来至我所。欲求出家。时有上座名毗罗茶。别度阿难阿难陀。次一上座名婆修罗。别度提婆达多跋难陀。唯阿难修不忘禅。宿习总持。于少时中得佛觉三昧。积百万川水。揽以为雨。雨水奔流入于大海。阿难手从海中取以分别色味。不杂。还置本源。无有漏失。文殊师利。白佛言。世尊。舍利弗者。如来常言。其于声闻中智慧第一。不谓小心能问要义。佛言。其久种明悟。发扬我法。以诸慧利利众生故。云何如来。说父母恩大不可不报。又言。师僧之恩不可称量其谁为最。佛言。夫在家者。孝事父母在于膝下。莫以报生长与之等。以生育恩深故言大也。若从师学开发知见。次恩大也。夫出家者。舍其父母生死之家。入法门中受微妙法。师之力也。生长法身。出功德财。养智慧命。功莫大也。追其所生乃次之耳。又言。当何名斯经。佛言。当名菩萨问喻。以广大故。又名舍利弗问。尔时四众闻说是已。五十新学比丘。信根成立法眼清净。旧德天人八部等。皆大欢喜。作礼而去

舍利弗问经


十诵比丘波罗提木叉戒本

    No. 1436

十诵比丘波罗提木叉戒本

        姚秦三藏鸠摩罗什译

大德僧听。冬时一月过少一夜。余有一夜三月在。老死至近。佛法欲灭。诸大德。为得道故。一心勤精进。所以者何。诸佛一心勤精进故。得阿耨多罗三藐三菩提。何况余善道法。未受具戒者已出。僧今和合。先作何事(一人应言布萨说戒)诸大德。不来诸比丘。说欲及清净

  合十指爪掌　　供养释师子
  我今欲说戒　　僧当一心听
  乃至小罪中　　心应大怖畏
  有罪一心悔　　后更莫复犯
  心马驰恶道　　放逸难禁制
  佛说切戒行　　亦如利辔勒
  佛口说教诫　　善者能信受
  是人马调顺　　能破烦恼军
  若不受教敕　　亦不爱乐戒
  是人马不调　　没在烦恼军
  若人守护戒　　如牦牛爱尾
  系心不放逸　　亦如猴着锁
  日夜常精进　　求实智慧故
  是人佛法中　　能得清净命

大德僧听。今十五日布萨说波罗提木叉。若僧时到僧忍听。僧一心作布萨说波罗提木叉。白如是

诸大德。今共作布萨说波罗提木叉。僧一心善听。有罪者发露。无罪者默然。默然故。当知诸大德清净。如一一比丘问答。是比丘众中三唱亦如是。若有比丘。如是比丘众中第三唱。忆有罪不发露。得故妄语罪。诸大德。故妄语罪。佛说遮道法。比丘于此中欲求清净。忆有罪应发露。发露则安隐。不发露罪益深。诸大德已说波罗提木叉序。今问诸大德。是中清净不。第二第三亦如是问。是中清净不

诸大德。是中清净。默然故。是事如是持

诸大德。是四波罗夷法。半月半月波罗提木叉中说

若比丘。共诸比丘入戒法中。不还戒戒羸不出。行淫法乃至共畜生。是比丘得波罗夷罪。不应共事

若比丘。若聚落中若空地。不与取。名盗物。如不与物取故。若王若王等。若捉若杀。若缚若摈。若输金罪。若如是言。咄汝小儿。汝痴汝贼。如是相。比丘不与物取。是比丘得波罗夷罪。不应共事

若比丘。若人若似人。故自手夺命。若自持刀与。若教人持与。若教死若赞死。若如是语。咄人用恶活为死胜生。随彼心乐死。种种因缘教死赞死。是人因是事死。是比丘得波罗夷罪。不应共事

若比丘。空无所有。不知不见过人法圣利满足。若知若见作是语。我如是知如是见。是比丘后时若问若不问。为出罪求清净故。作是言。我不知言知。不见言见。空诳妄语。是比丘得波罗夷罪。不应共事。除增上慢

诸大德。已说四波罗夷法。若比丘犯一一法。是比丘不得共住。不得共事如前后亦如是。是比丘得波罗夷罪。不应共事。今问诸大德。是中清净不第二第三亦如是问。是中清净不。诸大德。是中清净。默然故。是事如是持

诸大德。是十三僧伽婆尸沙法。半月半月波罗提木叉中说

若比丘故出精。是比丘僧伽婆尸沙。除梦中

若比丘。淫乱变心。与女人身共合。若捉手。若捉臂。若捉发。若捉一一身分。若上若下摩着细滑。僧伽婆尸沙

若比丘。淫乱变心。淫欲粗恶不善语。呼女人如年少男女相。僧伽婆尸沙

若比丘。淫乱变心。于女人前赞自供养己身。语姊妹。如我等比丘持戒。断淫欲行善法。姊妹淫欲法。供养是第一。供养僧伽婆尸沙

若比丘行媒法。持男意至女边。持女意至男边。若为妇事。若私通事。乃至一交会时。僧伽婆尸沙

若比丘。无主为身自乞欲作房。应量作。是房量。长十二佛磔手。内广七磔手。是比丘应将诸比丘示作房处无难处非妨处。诸比丘应示作房处无难处非妨处。若比丘。难处妨处自乞作房。无主为身。亦不将诸比丘示作房处。亦过量。僧伽婆尸沙

若比丘。有主自为欲作大房。是比丘。应将诸比丘示作房处无难处非妨处。诸比丘应示作房处无难处非妨处。若难处妨处有主为身作大房。亦不将诸比丘示作房处。僧伽婆尸沙

若比丘。嗔嗔故。不喜清净无罪比丘。以无根波罗夷法谤。欲破彼比丘净行。是比丘后时。若捡校若不捡校。知是事无根。无根故。是比丘住嗔法。语诸比丘言。我嗔故如是语。僧伽婆尸沙

若比丘。嗔嗔故不喜。异分异分事中取片若似片法。非波罗夷比丘。以波罗夷法谤。欲破彼比丘净行。是比丘后时。若捡校若不捡校。知是异分异分事中取片若似片法。是比丘住嗔法。语诸比丘言。我嗔故如是语。僧伽婆尸沙

若比丘。为破和合僧故勤方便。若受破缘事故共诤。诸比丘应谏是比丘。大德。莫为破和合僧故勤方便。亦莫受破缘事故共诤。大德。当与僧同事。何以故。僧和合欢喜不诤。一心一学如水乳合。安乐行。大德舍是破僧因缘事。诸比丘如是谏时。若坚持是事不舍。诸比丘应第二第三谏。舍是事好。若不舍者。僧伽婆尸沙

是为破和合僧故勤方便。是比丘有余比丘。亲厚同意别异语。若一若二若众多。是同意比丘语诸比丘。大德。是事中莫谏是比丘。何以故。是法语比丘善语比丘。是比丘说法不说非法。说善不说不善

是比丘知说非不知说。是比丘所说。皆是我等心所欲

是比丘欲忍可事。我等亦欲忍可。诸比丘应如是谏是同意比丘大德莫作是语。是法语比丘善语比丘。是比丘说法不说非法。说善不说不善

是比丘知说非不知说。是比丘所说。皆是我等心所欲。是比丘欲忍可事。我等亦欲忍可。大德。莫乐助破僧事。当乐助和合僧。何以故。僧和合欢喜不诤。一心一学如水乳合。安乐行。诸大德。当舍破僧同意别异语。是同意比丘。诸比丘如是谏时。若坚持是事不舍。诸比丘应第二第三谏。舍是事好。若不舍僧伽婆尸沙

若比丘。依止城若聚落住。是诸比丘行恶行污他家。皆见闻知。诸比丘应如是谏是诸比丘。大德。汝等行恶行污他家。皆见闻知。诸大德。汝等出去。不应是中住。是比丘语诸比丘言。诸大德。诸比丘随爱嗔怖痴。何以故。有如是同罪比丘。有驱者有不驱者。诸比丘应语是比丘。诸大德。莫作是语。诸比丘随爱嗔怖痴。有如是同罪比丘。有驱者有不驱者。何以故。诸比丘不随爱嗔怖痴。诸大德。汝等行恶行污他家皆见闻知。诸大德舍是爱嗔怖痴语。汝等出去。不应是中住。是同意比丘。诸比丘如是谏时。若坚持是事不舍。诸比丘应第二第三谏。舍是事好。若不舍僧伽婆尸沙

有一比丘。恶性难共语。诸比丘应如法如善说所犯波罗提木叉中事。自身作不可共语。如是言。诸大德汝等莫语我若好若丑。我亦不语诸大德若好若丑。诸大德不须谏我。诸比丘应谏彼比丘。大德。诸比丘如法如善说所犯波罗提木叉中事。汝莫自身作不可共语。汝身当作可共语大德。当为诸比丘说如法如善。诸比丘亦当为大德说如法如善。何以故。诸如来众得如是增长。所谓共说共谏共罪中出故。大德。舍是自身作不可共语业。诸比丘如是谏时。若坚持是事不舍。诸比丘应第二第三谏。舍是事好。若不舍僧伽婆尸沙

诸大德。已说十三僧伽婆尸沙法。九初犯罪四乃至三谏诸罪中。若比丘犯一一罪。知故覆藏随几时。应强令行波利婆沙。行波利婆沙已。是比丘应僧中六日六夜行摩那埵。行摩那埵已。次到阿浮诃那。如法作已。诸比丘心喜。二十比丘僧中应出罪。若少一人不满二十众。欲出是比丘罪。是比丘罪不得出。诸比丘亦可诃。是法应尔。今问诸大德。是中清净不(第二第三亦如是问)诸大德是中清净默然故是事如是持

诸大德。是二不定法。半月半月波罗提木叉中说

若比丘。共一女人。独屏覆处可淫处坐。可信优婆夷。是比丘应三法中。若一一法说。若波罗夷。若僧伽婆尸沙。若波夜提。若比丘自言。我坐是处。应三法中随所说法治。若波罗夷。若僧伽婆尸沙。若波夜提。随可信优婆夷所说。种种余法治是比丘。是初不定法

若比丘。共一女人。非屏覆处不可淫处坐。是比丘与女人。说粗恶淫欲语。可信优婆夷。二法中一一法说。若僧伽婆尸沙。若波夜提。若比丘自言。我坐是处。应二法中随所说法治。若僧伽婆尸沙。若波夜提。随可信优婆夷所说。种种余法治是比丘。是二不定法。诸大德。已说二不定法。今问诸大德。是中清净不(第二第三亦如是问)诸大德。是中清净。默然故。是事如是持

诸大德。是三十尼萨耆波夜提法。半月半月波罗提木叉中说

若比丘。三衣具足讫。迦絺那衣时。长衣乃至十日应畜。若过畜。尼萨耆波夜提

若比丘。三衣具足讫。迦絺那衣时。三衣中若离一一衣余处宿。尼萨耆波夜提。除僧羯磨。

若比丘。三衣具足讫。迦絺那衣时。若得非时衣。是比丘若须衣得自手取物。应疾作比丘衣畜。若得足者好。若不足若知更有得处。若为满故。是比丘是衣乃至一月应畜。若过一月畜。尼萨耆波夜提

若比丘。从非亲里比丘尼边取衣。尼萨耆波夜提。除贸易

若比丘。使非亲里比丘尼浣故衣。若染若打。尼萨耆波夜提

若比丘。从非亲里居士若居士妇乞衣得者。尼萨耆波夜提

除因缘。因缘者。夺衣失衣烧衣濡衣。是名因缘

若比丘。夺衣失衣烧衣漂衣。从非亲里居士若居士妇乞衣。若非亲里居士若居士妇。自恣多与衣。是比丘若欲取。乃至上下衣应受。若过受。尼萨耆波夜提

若比丘。非亲里居士若居士妇。为办衣价。念言。我如是如是衣价。买如是如是衣。与某甲比丘。是比丘先不自恣。为好衣故少作因缘。便到非亲里居士若居士妇所。作如是言。汝等善哉。办如是如是衣价。买如是如是衣与我。为好故。若得是衣。尼萨耆波夜提

若比丘。非亲里居士若居士妇。各各办衣价。念言。我如是如是衣价。买如是如是衣。与某甲比丘。是比丘先不自恣请。为好衣故少作因缘。便到非亲里居士若居士妇所。作如是言。汝等善哉。办如是如是衣价。买合作一衣与我。为好故。若得是衣。尼萨耆波夜提

若比丘。若王若王臣。若婆罗门若居士。遣使送衣价。是使到是比丘所。语是比丘言。大德知不。是衣价。若王若王臣。若婆罗门若居士。所送。大德受是衣价。是比丘应语使如是言。诸比丘法。不应受衣价。我曹须衣时得清净衣。应自手取物疾作衣畜。使语比丘言。大德。有执事人。常能为诸比丘执事不。须衣比丘应示使执事人。若守僧房人。若优婆塞。应语言。是人等常能为诸比丘执事。使向执事人所。语执事人言。善哉执事。如是如是衣价。买作如是如是衣。与某甲比丘。是比丘须衣时至。当来当与衣。使若自劝喻。若使人劝喻已。还到比丘所。到已白言。大德所示执事人。我劝喻作已。大德。须衣时往取。当与大德衣。须衣比丘应到执事所索衣。作是言。我须衣我须衣。第二第三亦如是索。若得衣者好。若不得第四第五极至第六。在执事前默然立。若第四第五极至第六。在执事前立。得衣者好。若不得。为得衣故。过是求。若得是衣。尼萨耆波夜提

若不得衣。随衣价来处。若自去若遣使。应如是言。汝为某甲比丘送衣价。是比丘于汝衣价竟不得用。汝自知财莫使失。是事法尔

若比丘。新憍奢耶作敷具。尼萨耆波夜提

若比丘。纯黑羺羊毛。作新敷具。尼萨耆波夜提

若比丘。欲作新敷具。应用二分纯黑羺羊毛。第三分白。第四分下。若比丘。不用二分纯黑羺羊毛第三分白第四分下作新敷具。尼萨耆波夜提

若比丘。欲作新敷具。故敷具必应满六年畜。若比丘六年内故敷具

若舍若不舍。更作新敷具。尼萨耆波夜提。除僧羯磨

若比丘。欲作新尼师坛。故尼师坛四边。各取一修伽陀磔手。为坏好色故。若比丘不取故尼师坛四边各一修伽陀磔手坏色。为好故。尼萨耆波夜提

若比丘。行道中得羺羊毛欲受。是比丘应自手取。乃至三由旬。若无代过担者。尼萨耆波夜提

若比丘。使非亲里比丘尼浣染擘羺羊毛。尼萨耆波夜提

若比丘。自手取金银。若使人取。若教他取。尼萨耆波夜提

若比丘。以金银买种种物。尼萨耆波夜提

若比丘。种种贩卖。尼萨耆波夜提

若比丘。畜长钵得至十日若过畜。尼萨耆波夜提

若比丘。所用钵不满五缀。更乞新钵。为好故。尼萨耆波夜提

是比丘是钵。应比丘众中舍。是比丘众中最下钵应与。应如是教。汝比丘受是钵乃至破。是事法尔

若比丘。自乞缕。使非亲里织师织。尼萨耆波夜提

若比丘。非亲里居士若居士妇。使织师为比丘织作衣。是比丘先不自恣请。为好衣故。少作因缘。往到织师所语织师言。汝知不。此衣为我作。汝好织令致广。我或当与汝少物。是比丘若自劝喻。若使人劝喻已。后时与少物。乃至一食。若一食具。若一食直。为得衣故。若得是衣。尼萨耆波夜提

若比丘。与他比丘衣。后嗔恚忿心不喜。若自夺若使人夺。作是言。汝比丘还我衣来。不与汝。尼萨耆波夜提。是比丘应诸比丘前舍是衣

若比丘。十日未至自恣。得急施衣。是比丘若须衣。得自手取物。乃至衣时应畜。若过畜。尼萨耆波夜提

若比丘。夏三月过有闰。未满八月。若阿兰若比丘。在阿兰若处住。意有疑恐怖畏难。若是比丘欲三衣中若一一衣着舍内

若有因缘出界故离衣宿。极至六夜。若过宿。尼萨耆波夜提

若比丘。春残一月。比丘应求雨浴衣。半月应畜。若比丘春残一月内求雨浴衣。过半月畜。尼萨耆波夜提

若比丘。知檀越欲与僧物。自回向己。尼萨耆波夜提

若比丘。佛听诸病比丘。服四种含消药。酥油蜜石蜜。是药病比丘残共宿。极至七日应服。若过七日。尼萨耆波夜提

诸大德。已说三十尼萨耆波夜提法。今问。诸大德。是中清净不。(第二第三亦如是问)诸大德。是中清净。默然故。是事如是持

诸大德。是九十波夜提法。半月半月波罗提木叉中说

若比丘。故妄语波夜提

若比丘。毁訾语波夜提

若比丘。两舌斗他比丘者。波夜提

若比丘。知僧如法断事竟。还更发起。波夜提

若比丘。为女人说法若过五六语。波夜提。除有智男子

若比丘。以阐陀偈句。教未受具戒人者。波夜提

若比丘未受具戒人前。自为身说过人法。若知若见。自称言。我如是知如是见。乃至实。波夜提

若比丘。知他比丘粗罪。向未受具戒人说。波夜提。除僧羯磨

若比丘。先欢喜听。后如是言。诸比丘随亲厚。回僧物与。波夜提

若比丘。说戒时作是言。何用说是杂碎戒为。半月半月波罗提木叉中说。说是戒故。诸比丘心悔心坏心恼心热。忧愁不乐生反戒心。作是轻呵戒者。波夜提

若比丘。杀众草木波夜提

若比丘嫌骂波夜提

若比丘。不随问答恼他。波夜提

若比丘。僧卧具若坐床。若卧床若钩絷。若坐卧具。露地若自敷若使人敷。是中若坐若卧。去时不自举不教人举。波夜提

若比丘。比丘房舍。中敷卧具。若自敷若使人敷。是中若坐若卧。去时不自举不教人举。波夜提

若比丘。比丘房舍中。嗔恚忿心不喜。若自挽出。若使人挽出。如是言。出去灭去。汝不应是中住。是因缘故不异。波夜提

若比丘。比丘房舍中。知诸比丘先安住敷卧具竟。后来强以卧具。若自敷若使人敷。作是念。若不乐者自当出去。是因缘故不异。波夜提

若比丘。比丘重阁上。若尖脚坐床若卧床。用力若坐若卧。波夜提

若比丘。知水有虫。若自浇草土。若使人浇。波夜提

若比丘。欲作大房舍。从户牖平地边渐次。若二若三垒令坚牢。若过垒。波夜提

若比丘僧。不差教诫比丘尼。波夜提

若比丘。僧虽差教诫比丘尼。是比丘乃至日没时。波夜提

若比丘。如是语。为供养利故。诸比丘教化比丘尼。波夜提

若比丘。与比丘尼议共道行。乃至到一聚落。波夜提。除因缘。因缘者。若多伴所行道。有疑怖畏。是名因缘

若比丘。与比丘尼议共载船。若上水若下水。波夜提。除直度

若比丘。与非亲里比丘尼衣。波夜提

若比丘。与非亲里比丘尼作衣。波夜提

若比丘。共比丘尼。独屏覆处坐。波夜提

若比丘。共女人独露处坐。波夜提

若比丘。知比丘尼赞因缘得食食。波夜提。除先白衣时善因缘

若比丘。数数食波夜提。除因缘。因缘者。病时布施衣时。是名因缘

若比丘。施一食处。无病比丘应一食。若过一食。波夜提

若比丘。到白衣家自恣多与。若饼若糗。诸比丘若须。若二若三钵应受。若过是取。波夜提。二三钵受已出外。应与余善比丘。是事法尔

若比丘。食竟不受残食法。若食波夜提

若比丘。知他比丘食竟不受残食法。强劝自恣多与饮食。如是言。比丘食。为恼故作是念。令是比丘乃至少许时得恼。是因缘故不异。波夜提

若比丘。别众食波夜提。除因缘。因缘者。病时。作衣时。欲道行时。欲船上行时。大会时。外道沙门施食时。是名因缘

若比丘。非时食波夜提

若比丘。残宿食食波夜提

若比丘。不受饮食着口中。波夜提。除水及杨枝

若比丘。诸家中如是美食。乳酪生酥熟酥油鱼肉脯。若比丘无病。如是美食为身索。波夜提

若比丘。知水有虫取用。波夜提

若比丘。食家中卧处坐。波夜提

若比丘。食家中独与一女人卧处强坐。波夜提

若比丘。裸形外道。若出家男。若出家女。自手与食。波夜提

若比丘。军发行往观。波夜提。除因缘

若比丘。有因缘到军中。乃至二宿应住。若过宿。波夜提

若比丘。乃至二宿军中住。观军发行主将幢麾军阵合战。波夜提

若比丘。嗔他比丘。恚忿不喜手打。波夜提

若比丘。嗔他比丘。恚忿不喜手搏。波夜提

若比丘。知他比丘粗罪。覆藏乃至一宿。波夜提

若比丘。语彼比丘。大德来至诸家。使与汝多美饮食。是比丘。不使与彼比丘食。如是言。汝去。共汝若坐若语不乐。我独坐独语乐。欲令恼故作是念。令是比丘乃至少时得恼。是因缘故不异。波夜提

若比丘。无病欲露地自炙。若草木牛屎粪扫。若自烧若使人烧。波夜提

若比丘。如法僧事与欲竟。后更呵。波夜提

若比丘。未受具戒人。共一房宿过二夜。波夜提

若比丘。作是言。我如是知佛法义。行障道法不能障道。是比丘。诸比丘应如是谏。汝大德。莫作是语。我如是知佛法义。行障道法不能障道。汝莫谤佛。莫诬佛。谤佛不善。佛不作是语。佛种种因缘说行障道法实障道。汝大德。舍是恶邪见。是比丘。诸比丘如是谏时。若坚持是事不舍

诸比丘应第二第三谏。舍是事好。若不舍波夜提

若比丘。知是人如是语不如法悔。不舍恶邪见故摈。若畜使共事若语共宿。波夜提

若有沙弥作是言。我如是知佛法义。行诸欲不能障道。是沙弥。诸比丘应如是教。汝沙弥。莫作是语。我如是知佛法义。行诸欲不能障道。汝莫谤佛莫诬佛。谤佛不善。佛不作是语。佛种种因缘说行诸欲能障道。汝沙弥。舍是恶邪见。是沙弥。诸比丘如是教时。若坚持不舍

诸比丘应第二第三教。舍是事好。若不舍者。诸比丘应如是语。汝沙弥。从今日不应言佛是我师。亦不应随诸比丘后行。诸余沙弥。得共比丘乃至一宿两宿。汝亦无是事。痴人出去灭去。莫此中住。若比丘。知是摈沙弥。若畜使一房舍宿。波夜提

若比丘。若宝若名宝。若自取若语取是物。波夜提。除僧房内。若住处内。若宝若名宝。僧房内住处内。如是生心。是谁有是主取去。是事法尔

若比丘。得新衣应三种坏色。一一坏色。若青若泥若木兰

若比丘三种坏色中不一一坏色。若青若泥若木兰作新衣。波夜提

若比丘。半月内浴。波夜提。除因缘。因缘者。春残一月半。夏初一月。是二月半。名热时。除病时风时雨时作时行路时。是名因缘

若比丘。故夺畜生命。波夜提

若比丘。故令他比丘心疑。作是念。令是比丘乃至少时得恼。是因缘故不异。波夜提

若比丘指痛挃波夜提

若比丘水中戏波夜提

若比丘。共女人一房舍宿。波夜提

若比丘。自恐怖他比丘。若使人恐怖。乃至戏笑。波夜提

若比丘。他比丘若钵若衣若户钩钥若革屣若针筒。如是一一生活具。若自藏若使人藏。乃至戏笑。波夜提

若比丘。与比丘比丘尼式叉摩那沙弥沙弥尼衣。辄还用。波夜提

若比丘。无根僧伽婆尸沙法。谤他比丘。波夜提

若比丘。与女人议共道行。乃至到一聚落。波夜提

若比丘。与贼众议共道行。乃至到一聚落。波夜提(七十)

若比丘。不满二十岁人与受具足戒。波夜提。是人不得戒。诸比丘亦可呵。是事法尔

若比丘。自手掘地。若使人掘。若指示言掘是。波夜提

若比丘。受四月自恣请。过是受者。波夜提。除常自恣请。除数数自恣请。除独自恣请

若比丘。说戒时如是言。我今未学是戒。先当问诸比丘诵修多罗毗尼阿毗昙者。波夜提

若比丘。欲得法利。是波罗提木叉中应学。亦应问诸比丘诵修多罗毗尼阿毗昙者。应如是言。诸大德。是语有何义。是事法尔

若比丘共诸比丘斗乱诤讼时。屏处默然立听作是念。诸比丘。所说我当忆持。波夜提

若比丘。僧断事时默然起去。波夜提

若比丘。轻他比丘。波夜提

若比丘饮酒。波夜提

若比丘。非时入聚落。不白善比丘。波夜提。除因缘

若比丘。请食食前食后行至余家。波夜提

若比丘。刹帝利王水浇顶。夜未晓未藏宝。若门艺门艺边过。波夜提。除大因缘

若比丘。说戒时如是言。我今始知是法半月半月入戒经中说。诸比丘知是比丘乃至若二若三说戒中坐。何况多。是比丘不以不知故得脱。随所犯罪如法治。应呵令厌。汝大德。汝失无利。汝不善。汝说戒时不敬说戒。不作是念。实有是事。不贵重。不着心中。不一心念。不摄耳听法从彼事。波夜提

若比丘。若骨若齿若角作针筒。波夜提

若比丘。欲作坐床若卧床。足应高八指。除入梐。若过作。波夜提

若比丘。自以兜罗绵贮褥。若使人贮。波夜提

若比丘。欲作雨浴衣。应料量。是中量。长六修伽陀磔手。广二修伽陀磔手半。若过作。波夜提

若比丘。欲作覆身衣。应料量。是中量。长四修伽陀磔手。广二修伽陀磔手半。若过作。波夜提

若比丘。欲作尼师坛。应料量。是中量。长二修伽陀磔手。广一修伽陀磔手半。若益一磔手缕。若过作。波夜提

若比丘。佛衣等量作衣。若过佛衣量。波夜提。是中佛衣量。长九修伽陀磔手。广六修伽陀磔手。是名佛衣量

诸大德。已说九十波夜提法。今问。诸大德。是中清净不。(第二第三亦如是问)诸大德。是中清净。默然故。是事如是持

诸大德。是四波罗提提舍尼法。半月半月波罗提木叉中说

若比丘无病。白衣家内非亲里比丘尼边。自手受食。是比丘。应诸比丘边出罪如是言。诸大德。我堕可呵法所不应作。是可出法我今出。是第一波罗提提舍尼法

有诸比丘。白衣家请食。是中一比丘尼立指示。与是比丘饭。与是比丘羹。诸比丘应语是比丘尼。小住姊妹。待诸比丘食竟。若诸比丘中。乃至无一比丘能语是比丘尼。姊妹小住待诸比丘食竟。是比丘应余比丘边出罪如是言。诸大德。我堕可呵法所不应作。是可出法我今出。是第二波罗提提舍尼法

有诸学家中。僧作学家羯磨。若比丘知是学家中僧作学家羯磨。先不请后来自手受饭食。是比丘应余比丘边出罪如是言大德。我堕可呵法所不应作。是可出法我今出。是第三波罗提提舍尼法

有僧阿兰若处住。有疑怖畏。若比丘先知如是阿兰若住处有疑怖畏。僧亦不作羯磨。不精舍外受饮食。精舍内受饮食。是比丘应余比丘边出罪。如是言。大德。我堕可呵法所不应作。是可出法我今出。是第四波罗提提舍尼法

诸大德。已说四波罗提提舍尼法。今问。诸大德。是中清净不。(第二第三赤如是问)诸大德。是中清净。默然故是事如是持

诸大德。是众学法。半月半月波罗提木叉中说

不高着内衣。应当学

不下着内衣。应当学

不参差着内衣。应当学

不如釿头着内衣应当学

不如多罗叶着内衣。应当学

不如象鼻着内衣。应当学

不如糗团着内衣。应当学

不细襵着内衣。应当学

不如两耳着内衣。应当学

不生起着内衣。应当学

不细生疏着内衣。应当学

周齐着内衣。应当学

不高被衣。应当学

不下被衣。应当学

不参差被衣。应当学

齐整被衣。应当学

好覆身入白衣舍。应当学

好覆身白衣舍坐。应当学

善好入白衣舍。应当学

善好白衣舍坐。应当学

不眄视入白衣舍。应当学

不眄视白衣舍坐。应当学

不嗅入白衣舍。应当学

不嗅白衣舍坐。应当学

不自大入白衣舍。应当学

不自大白衣舍坐。应当学

小声入白衣舍。应当学

小声白衣舍坐。应当学

不胡跪入白衣舍。应当学

不胡跪白衣舍坐。应当学

不覆头入白衣舍。应当学

不覆头白衣舍坐。应当学

不襆头入白衣舍。应当学

不襆头白衣舍坐。应当学

不叉腰入白衣舍。应当学

不叉腰白衣舍坐。应当学

不现胸入白衣舍。应当学

不现胸白衣舍坐。应当学

不现胁入白衣舍。应当学(四十)

不现胁白衣舍坐。应当学

不反抄衣入白衣舍。应当学

不反抄衣白衣舍坐。应当学

不左右抄衣入白衣舍。应当学

不左右抄衣白衣舍坐。应当学

不放衣掉入白衣舍。应当学

不放衣掉白衣舍坐。应当学

不掉臂入白衣舍。应当学

不掉臂白衣舍坐。应当学

不摇肩入白衣舍。应当学(五十)

不摇肩白衣舍坐。应当学

不摇头入白衣舍。应当学

不摇头白衣舍坐。应当学

不摇身入白衣舍。应当学

不摇身白衣舍坐。应当学

不携手入白衣舍。应当学

不携手白衣舍坐。应当学

不躄行入白衣舍。应当学

不躄行白衣舍坐。应当学

不累脚入白衣舍。应当学

不累脚白衣舍坐。应当学

不掌扶颊白衣舍坐。为白衣笑故。应当学

一心受饭。应当学

一心受羹。应当学

不溢钵受饭食。应当学

羹饭等食。应当学

不偏刳食。应当学

不钵中择好饭食。应当学

不大抟饭食。应当学

抟饭可口食。应当学

不张口待饭食。应当学

不含食语。应当学

不啮半食。应当学

不嚼食作声食。应当学

不全吞食食。应当学

不味咽食食。应当学

不吐舌食。应当学

不嗅食食。应当学

不舐手食。应当学

不指抆钵食。应当学

不弃饭食。应当学

不振手食。应当学

不污手受食器。应当学

不得以饭覆羹更望得。应当学

不病不得为身索羹饭。应当学

不得嫉心看比坐钵中。应当学

一心观钵食。应当学

次第食。应当学

不应洗钵水弃白衣舍内。除语檀越。应当学

人骑马不应为说法。除病。应当学

人在前比丘在后。不应为说法。除病。应当学

人在道中比丘在道外。不应为说法。除病。应当学

人在高比丘在下。不应为说法。除病。应当学

人坐比丘立。不应为说法。除病。应当学

人卧比丘坐。不应为说法。除病。应当学

人覆头。不应为说法。除病。应当学

人襆头。不应为说法。除病。应当学

人叉腰。不应为说法。除病。应当学

人现胸。不应为说法。除病。应当学

人现胁。不应为说法。除病。应当学(一百)

人反抄衣。不应为说法。除病。应当学

人左右反抄衣。不应为说法。除病。应当学

人放衣掉。不应为说法。除病。应当学

人着屐。不应为说法。除病。应当学

人着革屣。不应为说法。除病。应当学

人捉杖。不应为说法。除病。应当学

人捉盖。不应为说法。除病。应当学

人捉五尺刀。不应为说法。除病。应当学

人捉小刀。不应为说法。除病。应当学

人捉弓箭种种器杖。不应为说法。除病。应当学

不应生草上大小便涕唾。除病。应当学

不应净用水中大小便涕唾。除病。应当学

不应立大小便。除病。应当学

树过人不应上。除大因缘。应当学

诸大德。已说众学法。今问。诸大德。是中清净不(第二第三亦如是问)诸大德。是中清净。默然故。是事如是持

诸大德。是七灭诤法。半月半月波罗提木叉中说

应与现前毗尼人。当与现前毗尼

应与忆念毗尼人。当与忆念毗尼

应与不痴毗尼人。当与不痴毗尼

应与自言治人。当与自言治

应与觅罪相人。当与觅罪相

应与多觅罪相人。当与多觅罪相

种种僧中诤事起。如草布地除灭。应当学

诸大德。已说七灭诤法。今问诸大德。是中清净不。(第二第三亦如是问)诸大德。是中清净默然故是事如是持

诸大德已说戒序。已说四波罗夷法。已说十三僧伽婆尸沙法。已说二不定法。已说三十尼萨耆波夜提法。已说九十波夜提法。已说四波罗提提舍尼法。已说众学法。已说七灭诤法。是事入佛戒经中半月半月波罗提木叉中说。及余随道戒法中。是中诸大德。一心欢喜不诤。如水乳合安乐行。应当学

毗婆尸佛如来无所著等正觉。为六百二十万比丘前后围绕。说是戒经

  忍辱第一道　　涅槃佛称最
  出家恼他人　　不名为沙门

尸弃佛如来无所著等正觉。为八十万比丘前后围绕。说是戒经

  譬如明眼人　　能避险恶道
  世有聪明人　　能远离诸恶

毗钵施佛如来无所著等正觉。为十万比丘前后围绕。说是戒经

  不恼不说过　　如戒所说行
  饭食知节量　　常乐在闲处
  心净乐精进　　是名诸佛教

拘留孙佛如来无所著等正觉。为四万比丘前后围绕。说是戒经

  譬如蜂采花　　不坏色与香
  但取其味去　　比丘入聚落
  不破坏他事　　不观作不作
  但自观身行　　谛视善不善

拘那含佛如来无所著等正觉。为三万比丘前后围绕。说是戒经

  欲得好心莫放逸　　圣人善法当勤学
  若有知寂一心人　　乃能无复忧愁患

迦叶佛如来无所著等正觉。为二万比丘前后围绕。说是戒经

  一切恶莫作　　当具足善法
  自净其志意　　是名诸佛教

我释迦牟尼佛如来无所著等正觉。为千二百五十未曾有僧前后围绕。说是戒经

  护身为善哉　　能护口亦善
  护意为善哉　　护一切亦善
  比丘护一切　　便得离众恶
  比丘守口意　　身不犯众恶
  是三业道净　　得圣所得道

  若人挝骂不还报　　于嫌恨人心不恨
  于嗔人中心常净　　见人为恶自不作

  七佛为世尊　　能救护世间
  所可说戒经　　我已广说竟
  诸佛及弟子　　恭敬是戒经
  恭敬戒经已　　各各相恭敬
  惭愧得具足　　能得无为道
  已说戒经竟　　僧一心布萨

十诵比丘波罗提木叉戒本


十诵比丘尼波罗提木叉戒本

    No. 1437

十诵比丘尼波罗提木叉戒本一卷

        宋长干寺沙门释法显集出

    说法章

大德尼僧听。冬时一月过少一夜。余有一夜三月在。老死至近。佛法欲灭

    第二教戒章

诸大德。为得道故。一心勤精进。所以者何。诸佛一心勤精进故。得阿耨多罗三藐三菩提。何况余善道法

    第三会坐章

未受具足者已出。僧今和合。先作何事(一人答布萨说波罗提木叉)诸大德。不来诸比丘尼。说欲及清净

    第四供养章

  合十指爪掌　　供养释师子
  我今欲说戒　　僧当一心听
  乃至小罪中　　心应大怖畏
  有罪一心悔　　后更莫复犯
  心马驰恶道　　放逸难禁制
  佛说切戒行　　亦如利辔勒
  佛口说教诫　　善者能信受
  是人马调顺　　能破烦恼军
  若不受教敕　　亦不爱乐戒
  是人马不调　　没在烦恼军
  若人守护戒　　如牦牛爱尾
  系心不放逸　　亦如猴着锁
  日夜常精进　　求实智慧故
  是人佛法中　　能得清净命

    第五和众章

大德尼僧听。今十五日布萨说波罗提木叉。若僧时到僧忍听。僧一心作布萨说波罗提木叉。如是白

    第六净众章

诸大德。今共作布萨说波罗提木叉。僧一心善听。有罪者发露。无罪者默然。默然故。当知诸大德清净。如一一比丘尼问答。是比丘尼众中三唱亦如是。若有比丘尼。如是比丘尼众中第三唱。忆有罪不发露。得故妄语罪。诸大德。故妄语罪。佛说遮道法。比丘尼于此中欲求清净。忆有罪应发露。发露则安隐。不发露罪益深

诸大德。已说波罗提木叉序。今问诸大德。是中清净不。第二第三亦如是问。是中清净不。诸大德。是中清净。默然故。是事如是持

诸大德。是八波罗夷法。半月半月波罗提木叉中说

若比丘尼。同入比丘尼学法。不舍戒戒羸不出。行淫法乃至共畜生。是比丘尼犯波罗夷。不应共住

若比丘尼。若聚落若空地。不与取。名盗物。如不与物取故。若王若王等。若捉若杀。若缚若摈。若输金罪。若言。汝小儿汝贼汝痴。如是相。不与物取。是比丘尼犯波罗夷。不应共住

若比丘尼。若人若似人。故自手夺命。若持刀与。若教死若赞死。作是言。人用恶活为。死胜生。随彼心乐死。种种因缘教死赞死。是人因是事死。是比丘尼犯波罗夷。不应共住

若比丘尼。不知不见。空无过人法。自言。我如是知如是见。是比丘尼后时若问若不问。贪利养故。不知言知。不见言见。空诳妄语。除增上慢。是比丘尼犯波罗夷。不应共住

若比丘尼。有漏心听漏心男子。发际已下至膝腕已上。却衣顺摩逆摩。牵推按掏抱上抱下。是比丘尼犯波罗夷。不应共住

若比丘尼。有漏心听漏心男子。捉手捉衣共立共语。共期入屏覆处。待男子来。与身如白衣女。以此八事示贪着相。是比丘尼犯波罗夷。不应共住

若比丘尼。知比丘尼犯重罪。覆藏乃至一夜。是比丘尼。知彼比丘尼若退若住若灭若去。后作是言。我亦先知是比丘尼犯如是如是罪。但不欲自举。不欲向僧说。或有人言。云何妹自污其姊。是比丘尼犯波罗夷。不应共住

若比丘尼。知是比丘。一心和合僧。如法作不见摈。独一无二。无伴无侣。不休不息。便往随顺。诸比丘尼。应如是谏是比丘尼。是比丘。一心和合僧。如法作不见摈。独一无二。无伴无侣。不休不息。汝莫随顺是比丘。诸比丘尼如是谏时。坚持是事不舍者。诸比丘尼应第二第三谏。令舍是事故。第二第三谏时。若舍是事善。若不舍者。是比丘尼犯波罗夷。不应共住

诸大德。已说八波罗夷法。若比丘尼犯一一法。是比丘尼不得共住。不得共事。如前后亦如是。是比丘尼犯波罗夷。不应共住。今问诸大德。是中清净不。第二第三亦如是问。是中清净不。诸大德。是中清净。默然故。是事如是持

诸大德。是十七僧伽婆尸沙法。半月半月波罗提木叉中说

若比丘尼行媒法。若持男意语女。持女意语男。若为妇事若私通事。乃至一会时。是法初犯僧伽婆尸沙可悔过

若比丘尼恶嗔故。以无根波罗夷法。谤无波罗夷比丘尼。欲破彼梵行。是比丘尼后时若问若不问。知是事无根。是比丘尼住嗔故。作是语者。是法初犯僧伽婆尸沙可悔过

若比丘尼恶嗔故。异分中取片若似片事。以波罗夷法谤。欲破彼比丘尼梵行。是比丘尼后时。若问若不问。知是片似片事。是比丘尼住嗔故。作是语者。是法初犯僧伽婆尸沙可悔过

若比丘尼有漏心。从漏心男子自手取食。是法初犯僧伽婆尸沙可悔过

若比丘尼语比丘尼言。若汝无漏心。从漏心男子自手取食啖。若随意用。于汝何所能。是法初犯僧伽婆尸沙可悔过

若比丘尼。若夜若昼。若异聚落若异界。若度水彼岸一身独宿。是法初犯僧伽婆尸沙可悔过

若比丘尼。恃势言人者。是法初犯僧伽婆尸沙可悔过

若比丘尼。知贼女决断应死。众人皆知王及主不听。便作弟子。是法初犯僧伽婆尸沙可悔过

若比丘尼。知比丘尼和合僧如法作不见摈。不问比丘尼僧亦不取欲。便出界外与解摈者。是法初犯僧伽婆尸沙可悔过

若比丘尼。欲破和合僧。勤方便受持破僧事。诸比丘尼应如是谏。汝莫破和合僧勤方便受持破僧事。当与僧和合。僧和合者欢喜无诤。一心一学如水乳合。得安乐住。汝当舍是求破僧事。诸比丘尼如是谏时。坚持是事不舍者。当再三谏令舍是事。再三谏时舍者善。不舍者是法至三。犯僧伽婆尸沙可悔过

若比丘尼。求破和合僧。有余同意相助比丘尼。若一若二若多。语诸比丘尼言。汝是事中莫说是比丘尼。何以故。是比丘尼说法说律。不说非法。不说非律。是比丘尼所说。皆是我等所欲。是知说非不知说。是比丘尼所说。皆是我等所欲乐忍。诸比丘尼应如是谏是相助比丘尼。汝莫作是语。是比丘尼说法说律。不说非法不说非律。是比丘尼所说。皆是我等所欲。是知说非不知说。是比丘尼所说。皆是我等所欲乐忍。汝莫相助求破僧事。当助和合僧。僧和合者欢喜无诤。一心一学如水乳合。得安乐住。诸比丘尼如是谏时。坚持是事不舍者。诸比丘尼当再三谏。令舍是事故。再三谏时舍者善。不舍者是法至三。犯僧伽婆尸沙可悔过

若比丘尼。随所依止聚落。作恶行污他家。皆见皆闻皆知。诸比丘尼应如是言。汝等作恶行污他家。皆见皆闻皆知。汝等出去。不应住此。是比丘尼语诸比丘尼言。诸比丘尼。随爱随嗔随怖随痴行。何以故。有如是同罪比丘尼。有驱者有不驱者。诸比丘尼语是比丘尼。汝莫作是语。诸比丘尼随爱随嗔随怖随痴行。何以故。诸比丘尼不随爱嗔怖痴行。汝等作恶行污他家。皆见闻知。汝当舍是随爱嗔怖痴语。汝等出去。不应住此。如是谏时不舍是事者。当再三谏。令舍是事故。再三谏时舍者善。不舍者。僧伽婆尸沙可悔过

有比丘尼恶性戾语。诸比丘尼。说如法如律如戒经中事。是比丘尼戾语不受。语诸比丘尼言。汝莫语我好恶。我亦不语汝好恶。诸比丘尼应如是言。诸比丘尼。说如法如律如戒经中事。汝莫戾语当随顺语。诸比丘尼。当为汝说如法如律。汝亦当为诸比丘尼说如法如律。何以故。如是者。诸如来众得增长利益。以共语相教共罪中出故。汝当舍是戾语事。诸比丘尼如是谏时。坚持是事不舍者。诸比丘尼当再三谏。令舍是事故再三谏时舍者善。不舍者僧伽婆尸沙可悔过

若比丘尼。共比丘尼斗诤时。作是言。我舍佛舍法舍僧舍戒。非但沙门释子知道。更有余沙门婆罗门。有惭愧善好乐持戒者。我当从彼修梵行。诸比丘尼应谏是比丘尼言。汝莫共诸比丘尼斗诤时作是言。我舍佛舍法舍僧舍戒。非但沙门释子知道。更有余沙门婆罗门。有惭愧善好乐持戒者。我当从彼修梵行。汝应佛法中乐修梵行。当舍离自不乐心。诸比丘尼如是谏时。坚持是事不舍者。当再三谏。令舍是事故。再三谏时舍者善。不舍者僧伽婆尸沙可悔过

若比丘尼。共比丘尼斗诤时。作是言。比丘尼僧。随爱行随嗔行随怖行随痴行。诸比丘尼应如是谏。汝莫共诸比丘尼斗诤时作是言。比丘尼僧。随爱行随嗔行随怖行随痴行。何以故。比丘尼僧。不随爱嗔怖痴行。汝当舍是随爱嗔怖痴语。诸比丘尼如是谏时。坚持是事不舍者。诸比丘尼应再三谏。令舍是事故。再三谏时舍者善。不舍者僧伽婆尸沙可悔过

若二比丘尼同心共作恶业。有恶名声。恼比丘尼僧。互相覆罪。诸比丘尼应如是谏。汝等莫同心共作恶业有恶名声。恼比丘尼僧。互相覆罪。汝等各别离行。别离行者增长佛法。汝等舍是随顺恶行。诸比丘尼如是谏时。坚持是事不舍者。应再三谏。令舍是事故。再三谏时舍者善。不舍者僧伽婆尸沙可悔过

若比丘尼。教二比丘尼言。汝莫别离行。当同心行。别离行者不得增长。若同心行者便得增长。比丘尼僧中。亦有如汝等者。僧以嗔故。教汝别离行。诸比丘尼应如是谏。汝莫教二比丘尼作是言。汝等莫别离行。当同心行。别离行者不得增长佛法。同心行者便得增长。众中亦有如汝等者。僧以嗔故。教汝别离行。汝当舍是劝邪行事。诸比丘尼如是谏时。坚持是事不舍者。当再三谏。令舍是事故。再三谏时舍者善。不舍者僧伽婆尸沙可悔过

诸大德。已说十七僧伽婆尸沙法。九初罪八乃至三谏。若比丘尼随犯一一罪。应二部僧中半月行摩那埵。可二部僧意。二部僧各二十众。应出是比丘尼罪。若二部众中若少一人。是比丘尼罪不名为出。二部僧可呵。是法应尔。今问诸大德。是中清净不。第二第三亦如是问。是中清净不。诸大德。是中清净。默然故。是事如是持

诸大德。是三十尼萨耆波夜提法。半月半月波罗提木叉中说

若比丘尼。衣竟已舍迦絺那衣。畜长衣得至十日。过是畜者。尼萨耆波夜提

若比丘尼。衣竟已舍迦絺那衣。五衣中若离一一衣。乃至一宿。尼萨耆波夜提。除僧羯磨

若比丘尼。衣竟已舍迦絺那衣。若得非时衣。是比丘尼须者当自手取。速作受持。若足者善。若不足者。更望得衣令具足故。停是衣乃至一月。过是停者。尼萨耆波夜提

若比丘尼。从非亲里居士居士妇乞衣。得衣者。尼萨耆波夜提。除因缘。因缘者。夺衣失衣烧衣漂衣。是名因缘

若比丘尼。夺衣失衣烧衣漂衣时。从非亲里居士居士妇乞衣。自恣多与衣。是比丘尼应取上下衣。过是取者。尼萨耆波夜提

若为比丘尼故。非亲里居士居士妇办衣直作是言。我以是衣直。买如是衣。与某比丘尼。是比丘尼。先不自恣请。便往居士居士妇所。作同意言。汝为我办如是衣直。买如是如是衣与我。为好故。若得衣者。尼萨耆波夜提

若为比丘尼。二非亲里居士居士妇。各办衣直作是言。我以是衣直。各买如是衣。与某比丘尼。是比丘尼。先不自恣请。便往居士居士妇所。作同意言。汝等各办衣直。合作一衣与我。为好故。若得衣者。尼萨耆波夜提

若为比丘尼故。若王王臣若婆罗门居士。遣使送衣直。是使到比丘尼所言。大德。某送此衣直。汝当受取。比丘尼应言。我比丘尼法。不应受衣直。若须衣时得净衣者。当自手受速作衣持使语比丘尼言。大德。有执事人。能为比丘尼执事不。是比丘尼应示执事人。若僧园民若优婆塞。此人能为比丘尼执事。是使往执事人所言。汝取是衣直。作如是衣。与某比丘尼。是比丘尼须衣时来。汝当与衣。是使语已还报比丘尼。我已语竟。大德。须衣时便往取。当与汝衣。是比丘尼往执事所索衣。作是言。我须衣。至再三反亦如是索。得衣者善。不得者四反乃至六反。往执事人前默然立。若四反乃至六反默然立。得衣者善。若不得衣。过是求得衣者。尼萨耆波夜提。若不得衣。随送衣直来处。若自往若遣使语。汝所送衣直。我不得。汝自知物莫使失。是事应尔

若比丘尼。自手取宝。若使人取。尼萨耆波夜提

若比丘尼。种种用宝者。尼萨耆波夜提

若比丘尼。种种贩卖者。尼萨耆波夜提

若比丘尼所用钵破减五缀。更乞新钵。为好故。尼萨耆波夜提。是钵应比丘尼僧中舍。众中最下钵。应与是比丘尼。如是教言。汝比丘尼畜是钵。乃至破。是事应尔

若比丘尼自乞缕。使非亲里织师织。尼萨耆波夜提

若为比丘尼故。非亲里居士居士妇。使织师为织衣。是比丘尼先不请。便往语织师言。汝知不。是衣为我故织。汝好织极好织广织净洁织。我当多少益汝。是比丘尼。若自语若使人语。后时若与食。若与食直。为好故。得衣者。尼萨耆波夜提

若比丘尼。与比丘尼衣。后嗔恚嫌恨。若自夺若使人夺。还我衣来不与汝。得衣者。尼萨耆波夜提

若比丘尼。十日未至自恣。有急施衣应受。比丘尼须是衣者。当自手取乃至衣时畜。过是畜者。尼萨耆波夜提

若比丘尼知物向僧。自求向己者。尼萨耆波夜提

若比丘尼病。听服四种含消药。酥油蜜石蜜。共宿至七日得服。过是服者。尼萨耆波夜提

若比丘尼。畜长钵乃至一夜。过是畜者。尼萨耆波夜提

若比丘尼。时衣作非时衣分者。尼萨耆波夜提

若比丘尼。非时衣作时衣分者。尼萨耆波夜提

若比丘尼。共比丘尼贸衣。后到比丘尼所。作是言。我还汝衣。汝还我衣。得衣者。尼萨耆波夜提

若为比丘尼故。众多非亲里居士居士妇。各各办衣直作是言。我等以是衣直。各买如是衣。与某比丘尼。是比丘尼先不请。后到众多居士居士妇所。作是言。汝等以是衣直。共买如是一衣与我。为好故。得是衣者。尼萨耆波夜提

若比丘尼。自为乞金银。尼萨耆波夜提

若比丘尼乞是已。更索余者。尼萨耆波夜提

若比丘尼为僧是事乞。作余事用。尼萨耆波夜提

若比丘尼。自为是事乞。作余事用。尼萨耆波夜提

若比丘尼。为多人是事乞。作余事用。尼萨耆波夜提

若比丘尼。乞重衣。应乞四钱直衣。过是乞尼萨耆波夜提

若比丘尼。乞轻衣。应乞二钱半直衣。过是乞。尼萨耆波夜提

诸大德。已说三十尼萨耆波夜提法。今问诸大德。是中清净不。第二第三亦如是问。是中清净不。诸大德。是中清净。默然故。是事如是持

诸大德是百七十八波夜提法。半月半月波罗提木叉中说

若比丘尼。故妄语波夜提

若比丘尼形相比丘尼波夜提

若比丘尼两舌者。波夜提

若比丘尼。僧如法断诤竟。还更发起。波夜提

若比丘尼。以句法教未受具戒人者。波夜提

若比丘尼。实有过人法。向未受具戒人说。波夜提

若比丘尼。知比丘尼有恶罪。向未受具戒人说波夜提。除僧羯磨

若比丘尼先自劝与。后作是言。诸比丘尼。随亲厚回僧物与。波夜提

若比丘尼说戒时。作是言。何用是杂碎戒为。半月说时。令诸比丘尼疑悔恼热愁忧不乐生反戒心。作是轻呵戒者。波夜提

若比丘尼。斫伐鬼村种子村。波夜提(一十)

若比丘尼。嗔讥僧所差人。波夜提

若比丘尼。用异事默然恼他。波夜提

若比丘尼。露地敷僧卧具。粗细绳床被褥若使人敷是中坐卧。去时不自举不教人举。波夜提

若比丘尼。比丘尼房中敷僧卧具。若使人敷。是中坐卧。去时不自举不教人举。波夜提

若比丘尼。比丘尼房中嗔恨不喜。便自牵出。若使人牵。痴人远去。不应住此。波夜提。除因缘

若比丘尼。比丘尼房中知他先敷卧具。后来强敷若使人敷。不乐者自当出去。波夜提。除因缘

若比丘尼。比丘尼房阁中。尖脚坐床若卧床。用力坐卧。波夜提

若比丘尼。知水有虫。自用浇草和泥。若使人用。波夜提

若比丘尼。独与一比丘屏覆处坐。波夜提

若比丘尼。不病住福德舍。过一食者。波夜提(二十)

若比丘尼往白衣家。自恣请多与饼糗。诸比丘尼须者。应二三钵取。过是取者。波夜提。二三钵取已出外。与余比丘尼共分。是法应尔

若比丘尼别众食。波夜提。除因缘。因缘者。病时作衣时道行时船行时大众集时沙门请时

若比丘尼非时啖食。波夜提

若比丘尼。举残宿食食者。波夜提

若比丘尼。不受食着口中。波夜提。除水及杨枝

若比丘尼知水有虫取用。波夜提

若比丘尼。有食家中强坐。波夜提

若比丘尼。食家中独与一男子舍内强坐。波夜提

若比丘尼裸形外道。若出家男出家女。自手与食。波夜提

若比丘尼。故往看军发行。波夜提除因缘(三十)

若比丘尼。有因缘往军中宿。过二夜波夜提

若比丘尼。二夜军中宿时。往看军阵器仗牙旗幡幢两阵合战。波夜提

若比丘尼。嗔打比丘尼。波夜提

若比丘尼。嗔举手向比丘尼。波夜提

若比丘尼。知比丘尼犯僧残罪。覆藏乃至一夜。波夜提

若比丘尼。语余比丘尼。来共到诸家。是比丘尼不教与食。便作是言。汝去。与汝共坐共语不乐。我独坐独语乐。欲恼彼故。以是因缘无异。波夜提

若比丘尼。无病露地燃火。若草木牛粪木皮粪扫。若自燃若使人燃。波夜提

若比丘尼。如法僧事与欲竟。后悔言。我不应与。波夜提

若比丘尼。与未受具戒人同室宿。过二夜。波夜提

若比丘尼作是语。我如是知佛法义。行障道法不能障道。诸比丘尼应如是谏。汝莫作是语。我知佛法义。行障道法不能障道。汝莫谤佛。谤佛者不善。佛不作是语。佛种种因缘说障道法能障道。汝当舍是恶邪见。诸比丘尼如是谏时。坚持不舍者。当再三谏令舍是事。再三谏时舍者善。不舍者波夜提(四十)

若比丘尼。知比丘尼作如是语。不如法悔不舍恶邪如法摈出。便与共事共住共同室宿波夜提

若有沙弥尼作是语。我知佛法义。行淫欲不能障道。诸比丘尼应如是教言。汝莫作是语。我知佛法义。行淫欲不能障道。汝莫谤佛。谤佛者不善。佛不作是语。佛种种因缘说淫欲能障道法。汝当舍是恶邪见。诸比丘尼如是教时。坚持是事不舍者。当再三教令舍是事。再三教时舍者善。不舍者。诸比丘尼应如是语。汝沙弥尼。从今不应言佛是我师。亦不应随诸比丘尼后行。余沙弥尼。得共比丘尼同房再宿。汝今不得。痴人灭去。不应住此。若比丘尼。知是灭摈沙弥尼。便畜经恤共事共宿。波夜提

若比丘尼。若宝似宝。自捉教人捉。波夜提。除因缘。因缘者。若宝似宝。在僧坊内若住处内如是心取。主来当还。是事应尔

若比丘尼得新衣。应三种色中随用一一种。坏是衣色。若青若泥若木兰。若比丘尼。不以三种坏色着新衣。波夜提

若比丘尼减半月浴。波夜提。除因缘。因缘者。春残一月半。夏初一月。是二月半。大热时病时风时雨时作时行时。是名因缘

若比丘尼。故夺畜生命。波夜提

若比丘尼。故令比丘尼疑悔。使须臾时心不安隐。以是因缘无异。波夜提

若比丘尼。以指击擽他。波夜提

若比丘尼水中戏。波夜提

若比丘尼与男子同室宿。波夜提(五十)

若比丘尼。自恐怖比丘尼。若使他恐怖。乃至戏笑。波夜提

若比丘尼。自藏比丘尼衣钵户钩革屣针筒。种种随法物。若使他藏。乃至戏笑。波夜提

若比丘尼。与比丘比丘尼式叉摩尼沙弥沙弥尼衣。他不还便强脱取。波夜提

若比丘尼。以无根僧伽婆尸沙法。谤比丘尼。波夜提

若比丘尼。与男子共期同道行。至一聚落。波夜提

若比丘尼。与贼共期同道行。乃至一聚落。波夜提

若比丘尼。自手掘地。若教他掘。作是言。汝掘是处。波夜提

若比丘尼。受四月自恣请。过是受者。波夜提。除常请数数请别请

若比丘尼。说戒时作是言。我不受学是戒。先当问余比丘持修多罗持毗尼持摩多罗伽者。波夜提

若比丘尼欲知是法者。应从此戒中学。当问余比丘。持修多罗持毗尼持摩多罗伽者。应如是问。是语云何。是事应尔

若比丘尼。共比丘尼斗诤已。盗往立听。彼比丘尼所说我当忆持。波夜提(六十)

若比丘尼。僧断事时默然起去。波夜提

若比丘尼不恭敬者。波夜提

若比丘尼饮酒者。波夜提

若比丘尼非时入聚落。不白余比丘尼。波夜提。除急因缘

若比丘尼许他请僧。中前中后行至余家。波夜提

若比丘尼。入灌顶刹利王家。夜未过未藏宝。若过门闑及闑处。波夜提。除急因缘

若比丘尼。说戒时作是言。我今始知是事入戒经中半月次来所说。诸比丘尼知是比丘尼先曾再三闻说此戒。何况复过。是比丘尼非以不知故得脱。随所犯事应令如法悔过。应呵令厌汝失无利是恶不善。汝说戒时不尊重戒不一心听。以是事故。波夜提

若比丘尼。用骨牙齿角作针筒。波夜提

若比丘尼。欲作床者。当应量作。足高八指。除入梐。过是作者。波夜提

若比丘尼。自以兜罗贮卧具。若使人贮。波夜提(七十)

若比丘尼。如佛衣量作衣。若过作。波夜提。佛衣量者。长佛九磔手。广六磔手。是佛衣量

若比丘尼啖生熟蒜。波夜提

若比丘尼剃大小便处毛。波夜提

若比丘尼洗时以指刺女根中。过二指节。波夜提

若比丘尼以掌拍女根者。波夜提

若比丘尼煮生物作食。波夜提

若比丘尼。比丘食时在前立待。波夜提

若比丘尼。以屎尿掷墙外。波夜提

若比丘尼。弃屎尿着生草上。波夜提

若比丘尼。独与一比丘屏处共立共语。波夜提(八十)

若比丘尼。独与一比丘露地共立共语。波夜提

若比丘尼。独与一白衣男子屏处共立共语。波夜提

若比丘尼。独与一白衣男子露地共立共语。波夜提

若比丘尼。闇中无灯与男子共立共坐。波夜提

若比丘尼。作男根着女根中。波夜提

若比丘尼。语比丘尼言。善女来。共我房住。后嗔不喜。若自牵出。若使人牵出。作是言。汝远灭去。莫此中住。以是因缘无异。波夜提

若二比丘尼共一床卧。波夜提

若二比丘尼共一敷具卧。波夜提

若二比丘尼共一衣覆卧。波夜提

若比丘尼入白衣舍。独与一比丘共立共语窃语。遣共行比丘尼求闲便故。波夜提(九十)

若比丘尼入白衣舍。独与一白衣男子共立共语窃语。遣共行比丘尼。欲独语。波夜提

若比丘尼。共比丘尼斗诤相嗔。自打身啼者。波夜提

若比丘尼。共比丘尼斗诤时。作法咒泥梨咒。波夜提

若比丘尼。不审谛看物便嫌恨。波夜提

若比丘尼。夏中无因缘游行他国。波夜提

若比丘尼。自恣竟不游行余处一宿。波夜提

若比丘尼。国内疑处畏处游行。波夜提

若比丘尼。国外疑处畏处游行。波夜提

若比丘尼。故往看画舍。波夜提

若比丘尼。先住恼后住者。波夜提(一百)

若比丘尼。后住恼先住者。波夜提

若比丘尼。共活比丘尼病不供给。波夜提

若比丘尼。见比丘来不起。波夜提

若比丘尼。不问比丘辄坐者。波夜提

若比丘尼。不问主人便敷卧具。若使人敷。波夜提

若比丘尼。不满十二岁畜众者。波夜提

若比丘尼。满十二岁。未作畜众羯磨。畜众者。波夜提

若比丘尼。畜未满十二岁已嫁女为众。波夜提。

若比丘尼。满十二岁已嫁女。不作属和上尼羯磨。畜为众。波夜提

若比丘尼。僧与止羯磨复畜众者。波夜提(一百一十)

若比丘尼。弟子不二岁学六法。畜为众者。波夜提

若比丘尼。弟子二岁学六法。未作属和上尼羯磨。畜为众。波夜提

若比丘尼。受大戒已不二岁随和上尼。波夜提

若比丘尼。畜弟子不与财法。波夜提

若比丘尼。畜淫女为众。不远本处五六由旬。波夜提

若比丘尼。畜未满二十岁童女为众。波夜提

若比丘尼。满二十岁童女。未作属和上尼羯磨畜为众。波夜提

若比丘尼。畜孝女为众。波夜提

若比丘尼。畜将男女自随女人为众。波夜提(四十即不共中第四十)

若比丘尼。畜恶性女人为众。波夜提(一百二十)

若比丘尼。满二十岁童女。不二岁学六法。畜为众。波夜提

若比丘尼。满二十岁童女。二岁学六法。不作属和上尼羯磨。畜为众。波夜提

若比丘尼作是言。汝与我衣钵户钩。时药时分药七日药尽形药。我当度汝。波夜提

若比丘尼。女人夫主不听。畜为众。波夜提

若比丘尼语他言。汝二岁学六法。后当畜汝。若不畜者。波夜提

若比丘尼。岁岁度弟子者。波夜提

若比丘尼。宿作乞属和上尼羯磨。畜为众者。波夜提

若比丘尼。作浴衣者当应量作。量者。长五修伽陀磔手。广二磔手半。过是作者。波夜提(五十)

若比丘尼。数数易衣服。波夜提

若比丘尼。作衣极久乃至五夜。过是成者。波夜提(一百三十)

若比丘尼。五夜不看五衣。波夜提

若比丘尼。以衣与白衣。波夜提

若比丘尼。月病休止。浣病衣已净不起去。波夜提

若比丘尼。遮与僧衣。波夜提

若比丘尼。所望得衣弱。而受迦絺那衣。波夜提

若比丘尼。僧舍迦絺那衣时不随者。波夜提

若比丘尼。僧分衣时不随者。波夜提

若比丘尼。僧断事时不随顺者。波夜提(六十)

若比丘尼。不以房舍嘱他。至聚落中。波夜提

若比丘尼。读诵种种咒术。波夜提(一百四十)

若比丘尼。教白衣读诵种种咒术。波夜提

若比丘尼。与白衣作。波夜提

若比丘尼。坐白衣床。不还付主便去。波夜提

若比丘尼。不问主人坐他床上。波夜提

若比丘尼无病乘乘。波夜提

若比丘尼纺绩。波夜提

若比丘尼着腰络。波夜提

若比丘尼捉盖入白衣舍。波夜提

若比丘尼。离有比丘住处安居。波夜提

若比丘尼安居竟。不二部僧中求三事自恣说见闻疑。波夜提(一百五十)

若比丘尼。半月不往僧中求教诫。波夜提

若比丘尼无病。不往受教诫。波夜提

若比丘尼。有比丘住处外门。不问便入。波夜提

若比丘尼。喑嗌向比丘。波夜提

若比丘尼。共比丘尼斗诤恶口。恐怖他言。

某王大臣斗将。是我知识。当以彼力治汝波夜提

若比丘尼护惜他家。波夜提

若比丘尼受请都不食者。波夜提

若比丘尼。比丘不听。便问经律阿毗昙。波夜提

若比丘尼裸形露地洗浴。波夜提

若比丘尼着白衣严身具。波夜提(一百六十)

若比丘尼。故往观听歌舞伎乐庄严妓儿。波夜提

若比丘尼有疮。使男子解系。波夜提

若比丘尼。与男子共行说俗事。波夜提

若比丘尼。以涂香胡麻滓屑揩身。波夜提

若比丘尼。使他以涂香胡麻滓屑揩身。波夜提

若比丘尼着头光。波夜提

若比丘尼。不语余比丘尼出远门去。波夜提

若比丘尼以刷刷头。波夜提

若比丘尼使他刷头。波夜提

若比丘尼以梳梳头。波夜提(一百七十)

若比丘尼使他梳头。波夜提

若比丘尼编头。波夜提

若比丘尼使他编头。波夜提

若比丘尼生草上大小便。波夜提

若比丘尼故出精。除梦中。波夜提

若比丘尼饮精。波夜提

若比丘尼男子洗处浴。波夜提

若比丘尼在门中立。波夜提(一百七十八)

诸大德。已说百七十八波夜提法。今问诸大德。是中清净不。第二第三亦如是问。诸大德是中清净。默然故。是事如是持

诸大德。是八波罗提提舍尼法。半月半月波罗提木叉中说

若比丘尼无病。自为索乳。是比丘尼应向余比丘尼说罪。我堕可呵法不是。是说罪法。我今说罪悔过。是初波罗提提舍尼法

若比丘尼无病。自为索酪生酥熟酥油鱼肉脯。是比丘尼应向余比丘尼说罪。我堕可呵法不是。是说罪法。我今说罪悔过。是名八波罗提提舍尼法

诸大德。已说八波罗提提舍尼法。今问诸大德。是中清净不。第二第三亦如是问。是中清净不。诸大德。是中清净。默然故。是事如是持

诸大德。是众学法。半月半月波罗提木叉中说

不高着泥洹僧。应当学

不下着泥洹僧。应当学

不参差着泥洹僧。应当学

不如钉头着泥洹僧。应当学

不如象鼻着泥洹僧。应当学

不如多罗叶着泥洹僧。应当学

不如糗团着泥洹僧。应当学

不细襵着泥洹僧。应当学

不着耳泥洹僧。应当学

不并襵两边着泥洹僧。应当学

不着细缕泥洹僧。应当学

周齐着泥洹僧。应当学

不高披衣。应当学

不下披衣。应当学

不参差披衣。应当学

周齐披衣。应当学

好覆身入白衣舍。应当学

好覆身白衣舍坐。应当学

善摄身入白衣舍。应当学

善摄身白衣舍坐。应当学

不高视入白衣舍。应当学

不高视白衣舍坐。应当学

不呵供养入白衣舍。应当学

不呵供养白衣舍坐。应当学

静默入白衣舍。应当学

静默白衣舍坐。应当学

不蹲行入白衣舍。应当学

不蹲行白衣舍坐。应当学

不覆头入白衣舍。应当学

不覆头白衣舍坐。应当学

不襆头入白衣舍。应当学

不襆头白衣舍坐。应当学

不肘隐人肩入白衣舍。应当学

不肘隐人肩白衣舍坐。应当学

不叉腰入白衣舍。应当学

不叉腰白衣舍坐。应当学

不左右反抄衣入白衣舍。应当学

不左右反抄衣白衣舍坐。应当学

不偏抄衣入白衣舍。应当学

不偏抄衣白衣舍坐。应当学

不以衣覆右肩全举左肩上入白衣舍。应当学

不以衣覆右肩全举左肩上白衣舍坐。应当学

不掉臂入白衣舍。应当学

不掉臂白衣舍坐。应当学

不摇肩入白衣舍。应当学

不摇肩白衣舍坐。应当学

不摇头入白衣舍。应当学

不摇头白衣舍坐。应当学

不摇身入白衣舍。应当学

不摇身白衣舍坐。应当学

不携手入白衣舍。应当学

不携手白衣舍坐。应当学

不翘一脚入白衣舍。应当学

不翘一脚白衣舍坐。应当学

不累脚入白衣舍。应当学

不累脚白衣舍坐。应当学

不掌扶颊白衣舍坐为白衣笑故。应当学

一心受饭。应当学

一心受羹。应当学

不溢钵受饭食。应当学

羹饭等食。应当学

不刳饭如井食应当学

不抟饭食。应当学

不大抟饭食。应当学

不手把食。应当学

不张口待饭食。应当学

不含食语。应当学

不啮半食。应当学

不吸食作声食。应当学

不嚼食作声食。应当学

不味咽食食。应当学

不吐舌食。应当学

不缩鼻食。应当学

不舐手食。应当学

不腻手受食器。应当学

不振手食。应当学

不指扪钵食。应当学

不病不得为身索若饭若羹。应当学

不得以饭覆羹更望得。应当学

不呵相看比坐钵。应当学

端视钵食。应当学

次第食尽。应当学

不应洗食钵水弃白衣舍内除语檀越。应当学

骑乘人不应为说法。除病。应当学

人在前比丘尼在后不应为说法。除病。应当学

人在道中。比丘尼在道外。不应为说法。除病。应当学

人坐比丘尼立。不应为说法。除病。应当学

人在高。处比丘尼在下。处不应为。说法。除病。应当学

人卧比丘尼。坐不应为。说法。除病。应当学

人覆头不应为说法。除病。应当学

人襆头不应为说法。除病。应当学

肘隐人不应为说法。除病。应当学

人叉腰不应为说法。除病。应当学

人左右反抄衣不应为说法。除病。应当学

人偏抄衣不应为说法。除病。应当学

以衣覆右肩全举左肩上不应为说法。除病。应当学

人着革屣不应为说法。除病。应当学

人着屐不应为说法。除病。应当学

人捉杖不应为说法。除病。应当学

人捉盖不应为说法。除病。应当学

人捉刀不应为说法。除病。应当学

人捉弓箭种种器仗。不应为说法。除病。应当学

不应生草上涕唾。除病。应当学

不应净用水中大小便涕唾。除病。应当学

不应立大小便。除病。应当学

树过人不应上。除大因缘。应当学

诸大德。已说众学法。今问诸大德。是中清净不。第二第三亦如是问。是中清净不。诸大德。是中清净。默然故。是事如是持

诸大德。是七灭诤法。半月半月波罗提木叉中说

应与现前毗尼人。当与现前毗尼

应与忆念毗尼人。当与忆念毗尼

应与不痴毗尼人。当与不痴毗尼

应与自言治人。当与自言治

应与觅罪相人。当与觅罪相

应与多觅罪人。当与多觅罪

种种僧中诤事生。如草布地除灭。应当学

诸大德。已说七灭诤法。今问诸大德。是中清净不。第二第三亦如是问。是中清净不。诸大德。是中清净。默然故。是事如是持

诸大德。已说戒序。已说八波罗夷法。已说十七僧伽婆尸沙法。已说三十尼萨耆波夜提法。已说百七十八波夜提法。已说八波罗提提舍尼法。已说众学法。已说七灭诤法。是事入佛经中半月半月戒经中。说及余随道戒法是中诸大德。一心欢喜不诤。一学一道和合。如水乳合安乐行。如是应当学

毗婆尸佛如来无所著等正觉。为六百二十万比丘前后围绕。说是戒经

  忍辱第一道　　涅槃佛称最
  出家恼他人　　不名为沙门

式佛如来无所著等正觉。为八十万比丘前后围绕。说是戒经

  譬如明眼人　　能避崄恶道
  世有聪明人　　能远离诸恶

随叶佛如来无所著等正觉。为十万比丘前后围绕。说是戒经

  不恼不说过　　如戒所说行
  饭食知节量　　常乐在闲处
  心净乐精进　　是名诸佛教

拘楼孙佛如来无所著等正觉。为四万比丘前后围绕。说是戒经

  譬如蜂采花　　不坏色与香
  但取其味去　　比丘入聚然
  不破坏他事　　不观作不作
  但自观身行　　谛视善不善

拘那含佛如来无所著等正觉。为三万比丘前后围绕。说是戒经

  欲得好心莫放逸　　圣人善法当勤学
  若有知寂一心人　　乃能无复忧愁患

迦叶佛如来无所著等正觉。为二万比丘前后围绕。说是戒经

  一切恶莫作　　当具足善法
  自净其志意　　是则诸佛教

释迦牟尼佛如来无所著等正觉。为千二百五十未曾有僧前后围绕。说是戒经

  护身为善哉　　能护口亦善
  护意为善哉　　护一切亦善
  比丘护一切　　便得离众苦
  比丘守口意　　身不犯众恶
  是三业道净　　得圣所得道

  若人挝骂不还报　　于嫌恨人心不恨
  于嗔人中心常净　　见人为恶自不作

  七佛为世尊　　能救护世间
  所可说戒经　　我已广说竟
  诸佛及弟子　　恭敬是戒经
  恭敬戒经已　　各各相恭敬
  惭愧得具足　　能得无为道

诸大德。已说波罗提木叉意。僧一心得布萨

十诵比丘尼波罗提木叉戒本一卷


十诵羯磨比丘要用一卷

    No. 1439

十诵羯磨比丘要用一卷

        宋沙门释僧璩于杨都中兴寺依律撰出

(羯磨随事乃有众多且依成文略出要用苦余不尽在于大本凡在大众内欲作羯磨作羯磨者集唱僧今和集欲作何事僧中一人应随答作某羯磨)又唱不来诸比丘说欲(说已唱白羯磨若在戒场上但唱也)

僧今和集欲作何事

    受三归五戒文第一(受三归五戒法白衣初来欲受三归五戒教礼佛法僧胡跪合掌忏悔三业然后受之戒师应教云)

我某甲。从今尽寿。归依佛两足尊。归依法无欲尊。归依僧众中尊(如是三说)

我某甲。归依佛竟。归依法竟。归依僧竟。于释迦牟尼佛法中。乐受五戒为优婆塞。当证知(如是三说)

汝某甲听。是佛婆伽婆。释迦牟尼多陀阿伽度阿罗诃三藐三佛陀。为优婆塞说五戒。凡是优婆塞。当尽寿护持。何等为五。尽寿离杀生是优婆塞戒。是中尽寿离杀生。是事能持不(答能)

尽寿离不与取。是优婆塞戒。是中尽寿离不与取。是事能持不(答能)

尽寿离邪淫。是优婆塞戒。是中尽寿离邪淫。是事能持不(答能)

尽寿离妄语。是优婆塞戒。是中尽寿离妄语。是事能持不(答能)

尽寿离饮酒是优婆塞戒。是中尽寿离饮酒。谷酒甘蔗酒蒲萄酒。一切能放逸酒。是事能持不(答能)

    受八戒文第二(有人来欲受八戒先教礼三宝然后教胡跪合掌戒师应教如是说)

我某甲。从今至明旦。归依佛两足尊。归依法无欲尊。归依僧众中尊(如是三说)

我某甲。从今至明旦。归依佛竟。归依法竟。归依僧竟(如是三说)

我某甲。已受三归竟。从无始生死已来至于今日。身业不善杀盗淫。口业不善妄言绮语恶口两舌。意业不善贪欲恚嗔愚痴邪见。如此众罪。今向十方诸佛诸尊菩萨得道贤圣现在师僧前。求哀忏悔。我某甲已忏悔竟。身业清净口业清净意业清净。是名清净住。从今至明旦习学诸佛。不杀不盗不淫不妄语不饮酒。不坐卧高广大床。不着香华缨络香油涂身。不作唱技乐故往观听。过中不食(如是三说)

我某甲。已受八戒竟。以此功德。不求转轮圣王释梵诸王人天之乐。愿尽诸烦恼。明知一切法。果成佛道(优婆夷受文亦如是)

    乞畜众羯磨文第三(比丘尼受戒满十二岁欲畜众集僧胡跪合掌应如是乞)

大德尼僧听。我比丘尼某甲。受大戒来满十二岁欲畜众。我某甲。已从僧乞畜众羯磨。愿僧。与我某甲作畜众羯磨。慈愍故(如是三说)

僧与畜众羯磨文

大德尼僧听。比丘尼某甲。受大戒来满十二岁欲畜众。某甲已从僧乞畜众羯磨。若僧时到僧忍听。僧当与某甲畜众羯磨。如是白

大德尼僧听。比丘尼某甲。受大戒来满十二岁欲畜众。某甲已从僧乞畜众羯磨。僧今与某甲畜众羯磨。谁诸长老忍。与某甲畜众羯磨者。是长老默然。谁不忍者便说。是初羯磨成就不(如是三说)

僧已忍与某甲畜众羯磨竟。僧忍默然故。是事如是持

    受沙弥十戒文第四(佛语诸比丘从今欲求出家人有二事应白僧一出家剃头若已剃发来一事应白僧僧若集应言)

大德僧听。某甲求出家剃发。僧忆持(若僧不集应别房白应言)诸长老。某甲求出家。忆持(若有袈裟应着若无和上应与教胡跪合掌先教求和上应言)

大德忆念。我某甲。求大德为沙弥和上。愿大德。为我某甲作十戒和上。我某甲依大德和上故。出家受十戒(如是三说戒师应教)

我某甲。归依佛归依法归依僧出家。是佛婆伽婆释迦牟尼多陀阿伽度阿罗诃三藐三佛陀出家。我亦随佛出家。和上某甲(如是三说)

我某甲。归依佛竟归依法竟归依僧竟出家。是佛婆伽婆释迦牟尼多陀阿伽度阿罗诃三藐三佛陀出家。我亦随佛出家竟。和上某甲(戒师应言)汝某甲听。是佛婆伽婆释迦牟尼多陀阿伽度阿罗诃三藐三佛陀。为沙弥说十戒。何等为十

尽寿离杀生。是沙弥戒。是中尽寿离杀生。汝能持不(答能)

尽寿离不与取。是沙弥戒。是中尽寿离不与取。汝能持不(答能)

尽寿离非梵行。是沙弥戒。是中尽寿离非梵行。汝能持不(答能)

尽寿离妄语。是沙弥戒。是中尽寿离妄语。汝能持不(答能)

尽寿离饮酒。是沙弥戒。是中尽寿离饮酒。谷酒甘蔗酒蒲萄酒。一切能放逸酒。汝能持不(答能)

尽寿离坐卧高广大床。是沙弥戒。是中尽寿离坐卧高广大床。汝能持不(答能)

尽寿离着香华璎珞香油涂身。是沙弥戒。是中尽寿离着华香璎珞香油涂身。汝能持不(答能)

尽寿离作唱技乐故往观听。是沙弥戒。是中尽寿离作唱技乐故往观听。汝能持不(答能)

尽寿离受畜金银钱宝。是沙弥戒。是中尽寿离受畜金银钱宝。汝能持不(答能)

尽寿离非时食。是沙弥戒。是中尽寿离非时食。汝能持不(答能)

如是沙弥十戒。尽寿不应犯。当勤供养三宝佛宝法宝比丘僧宝。当供养和上。阿阇梨。一切如法教不得违逆。勤求方便学问坐禅诵经。于佛法中。当得须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道。乃至得阿耨多罗三藐三菩提。令出家不虚果报不绝。汝所未解。和上阿阇梨当广为汝说(优婆夷三归五戒八戒沙弥尼三归十戒受文尽与上沙弥出家十戒文同此中但以称沙弥尼为异耳)

    受六法坛文第五(若沙弥尼初来应教次第头面礼僧足已次第应求和上尼戒师教言)

大德。忆念。我沙弥尼某甲。求尊为和上尼。愿尊。为我某甲作和上尼。我某甲。因和上尼故。僧与我某甲二岁学戒(如是三说)一比丘尼应问和上尼。能为某甲作和上不(答能即应将至戒场上着见处离闻处尔时应问)

僧和合不。僧一心和合当作僧事。和上尼某甲。沙弥尼某甲。僧当与二岁学戒。(如是三说若僧一心和合者应叹沙弥尼来教头面一一礼僧足已次应教令从僧乞二岁学戒作如是说)大德尼僧听。我沙弥尼某甲。因和上尼某甲。从僧乞二岁学戒。和上尼某甲。僧当与我某甲二岁学戒。和上尼某甲。慈愍故。(如是三乞即时戒师应僧中唱)

大德尼僧听。沙弥尼某甲。因和上尼某甲。从僧乞二岁学戒。和上尼某甲。若僧时到僧忍听。僧当与某甲二岁学戒。和上尼某甲。如是白

大德尼僧听。沙弥尼某甲。从和上尼某甲。从僧乞二岁学戒。和上尼某甲。僧今与某甲二岁学戒。和上尼某甲。谁诸长老忍。与某甲二岁学戒。和上尼某甲。忍者是长老默然。谁不忍者便说。是初羯磨成就不(如是三说)

僧已忍。与某甲二岁学戒竟。和上尼某甲。僧忍默然故。是事如是持(即时为式叉摩尼说六法也)

汝某甲听。佛世尊多陀阿伽度阿罗诃三藐三佛陀知者见者。说戒式叉摩尼六法。汝式叉摩尼。尽寿受持

佛种种因缘呵欲欲想欲欲觉欲欲热。赞叹断欲除欲想灭欲热。若式叉摩尼同入学法中。不舍戒戒羸不出相。随心想受淫欲乃至共畜生。是非式叉摩尼。非沙门尼非释女。失灭式叉摩尼法。是事尽寿不应犯。汝能持不(答能)

佛种种因缘呵责偷夺法。赞叹不偷夺法。乃至一条线一寸纳一渧油分齐。尚不应犯。是中佛制极少乃至五钱若五钱直。若式叉摩尼随所偷夺事。若王捉若杀若打若缚。若摈出若输金罪。若作是言。汝贼汝小儿汝痴汝堕官罪。若式叉摩尼。如是偷夺者是非式叉摩尼。非沙门尼非释女。失灭式叉摩尼法。是事尽寿不应犯。汝能持不(答能)

佛种种因缘呵责杀生。赞叹不杀乃至蚁子尚不应杀。何况于人。若式叉摩尼。故夺人命。若持刀与。若教死叹死。作如是言。咄人用恶活为死胜生。随彼心乐死。种种因缘教死叹死。若作忧多杀。若头多杀。作弶作网作拨。若作毗陀罗杀。若似毗陀罗杀。若断气杀。若堕胎杀。若按腹杀。若推着火中水中。若从高推下。若遣使道中死。乃至母腹中初得二根。身根命根歌罗罗中生。恶心方便令夺其命。从是因缘死者。是非式叉摩尼。非沙门尼非释女。失灭式叉摩尼法。是事尽寿不应犯。汝能持不。(答能)

佛种种因缘呵责妄语。赞叹不妄语。乃至戏笑尚不应妄语。何况故妄语。若式叉摩尼。不知不见空无过人法。自言我如是知如是见。我得须陀洹果乃至阿罗汉果。我得初禅二禅三禅。我得慈悲喜舍无量空处识处无所有处非想非非想处定。我得不净观阿那般那念。诸天来至我所。诸龙夜叉薜荔伽毗舍阇鸠槃茶罗刹等来至我所。彼问我答我问彼答。若式叉摩尼如是妄语者。是非式叉摩尼。非沙门尼非释女。失灭式叉摩尼法。是事尽寿不应犯。汝能持不(答能)

佛种种因缘呵欲欲想欲欲觉欲欲热。赞叹断欲除欲想灭欲热。若式叉摩尼。有漏心听漏心男子。发际至腕膝已上却衣。顺摩逆摩抱捉牵推。举上举下若按若掐。是非式叉摩尼。非沙门尼非释女。失灭式叉摩尼法。若犯者可更受。是事尽寿不应犯。汝能持不(答能)

佛种种因缘呵欲欲想欲欲觉欲欲热。赞叹断欲除欲想灭欲热。若式叉摩尼有漏心。听漏心男子。捉手捉衣共立共语。共期入屏覆处。待男子来自身往就。如白衣女人。此八事示贪着相。是非式叉摩尼。非沙门尼非释女。失灭式叉摩尼法。若犯更受。是事尽寿不应犯。汝能持不(答能)

汝某甲听。僧已与汝二岁学法。式叉摩尼受持六法。名式叉摩尼。汝得具满和上阿阇梨具满比丘尼僧。得好国土。得好行处。转轮圣王所愿尚不能满。汝今已具满。当恭敬三宝佛宝法宝比丘僧宝。当供养和上阿阇梨恭敬上中下坐。当勤三学善戒学善心学善慧学。当修三脱门空无相无作。当勤三业坐禅诵经劝作众事。汝行是法当开甘露门。得须陀洹果斯陀含果阿那含果阿罗汉果。如莲华在水日夜增长。法诸善根亦复如是。于佛法中日夜增长。余残诸戒。和上阿阇梨。当渐渐为汝广说

  释师子法中　　已获难得戒
  无难时难得　　已得勿使空
  头面礼僧足　　右绕欢喜去

    大比丘尼坛文第六(式叉摩尼初来入尼僧中头面一一礼僧足礼僧足已尼戒师应教受衣钵应问此五衣钵是汝有不答言是应教效我语)

我某甲。是衣僧伽梨若干条受割截成。我某甲不离宿受持(如是三说)

我某甲。是衣郁多罗僧七条受。两长一短割截成。我某甲不离宿受持(如是三说)

我某甲。是衣安陀会五条受。一长一短割截成。我某甲不离宿受持(如是三说)

若僧伽梨缦。应言。是缦衣僧伽梨受持。余二衣亦尔

我某甲。是覆肩衣受。长四肘广二肘半。是覆肩衣。我某甲不离宿受持(如是三说)

我某甲。是衣厥修罗受。长四肘广二肘半。是厥修罗。我某甲不离宿受持(如是三说)

我某甲。是钵多罗应量受持。常用故(如是三说次教令求和上尼)

大德忆念。我式叉摩尼某甲。求尊为和上尼。愿尊。为我某甲作和上尼。我某甲。因和上尼故。僧当与我某甲作乞属和上尼羯磨。慈愍故(如是三说戒师应问)能为某甲作和上尼不(和上尼答言能应教着见处离闻处尼戒师应僧中作如是唱)谁能为某甲作教授师(一比丘尼言我能佛言如是比丘尼若成就五法应差作教师何等五不随爱教嗔教悕教痴教知教不教应知教师即时唱)

大德尼僧听。式叉摩尼某甲。从和上尼某甲求受具足戒某甲能作教师。为教某甲故。若僧时到僧忍听。某甲作教师。为教某甲。如是白

大德尼僧听。式叉摩尼某甲。从和上尼某甲。求受具足戒。某甲能作教师教某甲。谁诸尼僧忍。立某甲为教师为教某甲。忍者是长老默然。谁不忍者便说。僧已忍。立某甲为教师教某甲竟。僧忍默然故。是事如是持(已被羯磨者应往式叉摩尼所教正衣服右膝着地合掌而问)

汝某甲听。今是至诚时实语时。我今问汝。实当言实。不实当言不实。汝是女不。是人不。非是非人不。非畜生不。非是不能女不。女根上有毛不。不枯坏不。不带下病不。非偏不。不二道合不。女根不小不。非是不能产不。非是无乳不。非是一乳不。非是恒月水不。非无月忌不。非婢不。非客作不。非买得不。非破得不。非兵妇不。非吏妇不。非犯官事不。不负他物不。女人有如是等病。癞病痈疽病销尽病癫狂病长病热病。无如是等病不。父母夫主在不。若言在。父母夫主听出家不。五衣钵具不。汝字何等。和上尼字谁。答言。我字某甲。和上尼名某甲(尼教师问竟应白僧是式叉摩尼某甲我已问竟尼羯师磨应言清净者将来次教乞属和上尼羯磨应言)

大德尼僧听。我某甲。因和上尼某甲。求受具足戒。我某甲。今从僧乞属和上尼羯磨。和上尼某甲。僧当与我某甲作属和上尼羯磨。和上尼某甲。慈愍故(如是三说尼戒师应僧中作如是唱)

大德尼僧听。某甲。因和上尼某甲。求受具足戒。某甲。今从众僧乞属和上尼羯磨。和上尼某甲。若僧时到僧忍听。我今僧中问某甲无遮道法。如是白(戒师僧中问遮法与上教师问遮法中同止以空静处此以众中以为异耳)

大德尼僧听。颇有未问者不。若未问者当更问。已问者默然(是中尼戒师即时应僧中唱)

大德尼僧听。式叉摩尼某甲。从和上尼某甲。求受具足戒。某甲已从僧乞属和上尼羯磨。和上尼某甲。某甲自说清净无诸难事。年岁已满衣钵具足。某甲和上尼某甲。若僧时到僧忍听。僧当与某甲作属和上尼羯磨。和上尼某甲。如是白

大德尼僧听。式叉摩尼某甲。从和上尼某甲。求受具足戒。某甲已从众僧乞属和上尼羯磨。和上尼某甲。某甲自说清净无诸难事。年岁已满衣钵具足。某甲和上尼某甲。僧今与某甲作属和上尼羯磨。和上尼某甲。诸尼僧忍。与某甲作属和上尼羯磨。和上尼某甲。忍者是长老默然。谁不忍者便说。是初羯磨成就不(如是三说)僧已忍。为某甲作属和上尼羯磨。和上尼某甲竟。僧忍默然故。是事如是持

(比丘尼众应在尼寺中作如是羯磨竟即日将至大僧中和合与受具足戒也)

    入大僧中受具足坛文第七(将至大僧中头面一一礼僧足礼僧足已应教从和上尼乞受具足戒应言)

大德忆念。我某甲。求尊为和上尼。愿尊。为我某甲作和上尼。我某甲。依和上尼故。僧当与我某甲受具足戒。慈愍故(如是三说故次教从僧乞受具足戒应言)

大德僧听。我某甲。从和上尼某甲。求受具足戒。我某甲。今从众僧乞受具足戒。和上尼某甲。僧当济度我与我某甲受具足戒。慈愍故(如是三乞一比丘应僧中唱)

大德僧听。某甲。从和上尼某甲。求受具足戒。某甲已从众僧乞受具足戒。和上尼某甲。若僧时到僧忍听。我当僧中问某甲六法。如是白。(应语彼言)汝某甲听。今是至诚时实语时。我今僧中问汝。实当言实。不实当言不实。汝本来清净不。汝从出家来。顺行出家法不。二岁学六法不。比丘尼僧作本事不。尼僧已和合作乞属和上尼羯磨未。五衣钵具不。汝字何等。和上尼字谁。答言。我名某甲。和上尼名某甲

大德僧听。颇未问者不。若未问者当更问。已问者默然

大德僧听。某甲。从和上尼某甲。求受具足戒。某甲已从众僧乞受具足戒。和上尼某甲。某甲自说清净无诸难事。年岁已满。从出家来顺行出家法。已二岁学六法。比丘尼僧已作本事。已作属和上尼羯磨。五衣钵具。某甲和上尼某甲。若僧时到僧忍听。僧当与某甲受具足戒。和上尼某甲。如是白

大德僧听。某甲。从和上尼某甲。求受具足戒。某甲已从众僧乞受具足戒。和上尼某甲。某甲自说清净无诸难事。年岁已满。从出家来顺行出家法。已二岁学六法。比丘尼僧已作本事。已作属和上尼羯磨。五衣钵具。某甲和上尼某甲。僧今与某甲受具足戒。和上尼某甲。谁诸长老忍。与某甲受具足戒。和上尼某甲。忍者是长老默然。谁不忍者便说。是初羯磨成就不(如是三说)

僧已忍。与某甲受具足戒。和上尼某甲竟。僧忍默然故。是事如是持(应教言若人问汝几岁应答言无岁何时节随时应答若春若夏若冬某月某日某时有闰无闰皆应随实答是事汝尽寿应为忆念持即应为说三依止法)

汝某甲听。佛世尊多陀阿伽度阿罗呵三藐三佛陀知者见者。为受大戒比丘尼。说三依止法。比丘尼依是出家。受戒行比丘尼法。何等三

依粪扫衣。比丘尼依是。得出家受戒行比丘尼法。若长得赤麻衣白麻衣刍麻衣翅夷罗衣缯衣钦婆罗衣劫贝衣。如是等清净衣。皆是盈长得。是中尽寿依粪扫衣。汝能持不(答能)

依乞食。比丘尼依是。得出家受戒行比丘尼法。若长得相食故作食。六斋日食。月一日食。十六日食。众僧食。别房食请食。若僧若别请。如是等清净食。皆是盈长得。是中尽寿依乞食。汝能持不(答能)

依陈弃药。比丘尼依是。得出家受戒行比丘尼法。若长得四种含销药(酥油蜜石蜜)四种净脂(驴脂猪脂熊脂鳣脂)五种根药(舍利姜赤附子波提鞮沙菖蒱根)五种果药(诃梨勒阿摩勒鞞醯勒胡椒毕钵罗也)五种盐(紫盐白盐黑盐赤盐楼盐)五种汤(花汤叶汤根汤茎汤果汤)五种树胶药(兴渠萨阇罗谛夜谛夜婆提谛夜波那)如是余清净药。皆是盈长得。是中尽寿依陈弃药。汝能持不(答能次应说八堕法)

汝某甲听。佛世尊多陀阿伽度阿罗诃三藐三佛陀知者见者。为受具足戒比丘尼。说八堕法。若比丘尼。于八堕法中。堕所犯一一法。是非比丘尼。非沙门尼非释女。失灭比丘尼法

佛种种因缘呵欲欲想欲欲觉欲欲热。赞叹断欲除欲想灭欲热。若比丘尼。共诸比丘尼入戒法中。不舍戒戒羸不出相。随心想受淫欲乃至共畜生。是非比丘尼。非沙门尼非释女。失灭比丘尼法。是事尽寿不应犯。汝能持不(答能)

佛种种因缘呵责偷夺法。赞叹不偷夺法。乃至一条线一寸纳一渧油分齐。尚不应偷夺。是中佛制极少乃至五钱若五钱直。若比丘尼随所偷事。若王捉若杀若打若缚。若摈出若输金罪。作是言。汝贼汝小儿汝痴汝堕官罪。若比丘尼如是偷夺者。是比丘尼。非沙门尼。非释女。失灭比丘尼法。是事尽寿不应犯。汝能持不(答能)

佛种种因缘呵责杀生。赞叹不杀生。乃至蚁子尚不应杀。何况于人。若比丘尼自手夺人命。若持刀与若教死赞死。作是言。咄人用恶活为死胜生。随彼心乐死。种种因缘教死赞死。若作忧多杀。若头多杀。若作弶作网作拨。若作毗陀罗杀。若似毗罗杀。若断气杀。若堕胎杀。若按腹杀。若推着火中水中。若从高推下。若遣使道中死。乃至母腹中初得二根。身根命根歌罗罗中生。恶心方便令夺其命。从是因缘死者。是非比丘尼。非沙门尼。非释女。失灭比丘尼法。是事尽寿不应犯。汝能持不(答能)

佛种种因缘呵责妄语。赞叹不妄语。乃至戏笑尚不应妄语。何况故妄语。若比丘尼不知不见空无过人法。自言我如是知如是见。我得四果四向。乃至我得初禅二禅三禅四禅。我得慈悲喜舍无量空处识处无所有处非想非非想处定。我得不净观阿那般那念。诸天来至我所。诸龙夜叉薜荔伽毗舍阇鸠槃荼罗刹等来至我所。彼问我答我问彼答。若比丘尼如是妄语者。是非比丘尼。非沙门尼。非释女。失灭比丘尼法。是事尽寿不应犯。汝能持不(答能)

佛种种因缘呵欲欲想欲欲觉欲欲热。赞叹断欲除欲想灭欲热。若比丘尼有漏心。听漏心男子发际至腕膝已上却衣。顺摩逆摩抱捉牵推。举上举下按掐者。是非比丘尼。非沙门尼。非释女。失灭比丘尼法。是事尽寿不应犯。汝能持不(答能)

佛种种因缘呵欲欲想欲欲觉欲欲热。赞叹断欲除欲想灭欲热。若比丘尼有漏心。听漏心男子捉手捉衣共立共语。共期入屏覆处。待男子来自身往就。如白衣女人。此八事示贪着相。是非比丘尼。非沙门尼。非释女。失灭比丘尼法。是事尽寿不应犯。汝能持不(答能)

佛种种因缘呵责恶知识恶伴党。赞叹善知识善伴党。若比丘尼。知他比丘尼犯重罪。覆藏乃至一夜。是比丘尼。知彼比丘尼若退若住若失若远去往。作是言。我先知是比丘尼有如是事。不欲自向人说。不欲向僧说。不欲令人作是言。云何姝自污姊。是非比丘尼。非沙门尼。非释女。失灭比丘尼法。是事尽寿不应犯。汝能持不(答能)

佛种种因缘呵责恶知识恶伴党。赞叹善知识善伴党。若比丘尼。知比丘僧一心和合作不见摈。是比丘独一无二无伴无侣不休不息。随顺相助。诸比丘尼应语是比丘尼言。僧一心和合作不见摈。是比丘独一无二无伴无侣不休不息。汝莫随顺。若是比丘尼。诸比丘尼如是谏时。坚持是事不舍者。诸比丘尼应第二第三谏。令舍是事故。第二第三谏时舍者善。若不舍者。是非比丘尼。非沙门尼非释女。失灭比丘尼法。是事尽寿不应犯。汝能持不(答能)汝某甲听。僧已与汝受具足戒竟。善受教化随顺师教。汝已得好和上阿阇梨。得好众僧。得好行道处。如转轮圣王所愿尚不能得满。汝今已具满。当恭敬三宝佛宝法宝比丘僧宝。当勤三学善戒学善心学善慧学。勤修三脱门空无相无作。当勤三业坐禅诵经劝作众事。汝行是法当开甘露门。得须陀洹果斯陀含果阿那含果阿罗汉果辟支佛佛道。如莲华在水日夜增长。汝诸善根亦复如是。于佛法中日夜增长。余残诸戒。和上阿阇梨当渐渐为汝广说。即为说偈

  释师子法中　　一切妙善集
  深大无涯际　　功德之宝海
  是愿转轮王　　天王善妙王
  常求作沙门　　不遂汝已得
  精勤行三业　　佛法无量种
  汝常忆念法　　逮诸无碍智
  如莲花在水　　渐渐日增长
  汝亦如是信　　戒闻定慧增
  余戒佛所说　　和上师当教
  众中礼绕竟　　喜各从所乐

    受大戒坛文第八(佛语诸比丘受具足法有三事现前得受具足何等三一有僧二有人欲受具足三有羯磨是为三欲受具足人初来应教次第头面礼僧足礼僧足已教受衣应问此衣是汝有不答言是应教汝效我语)

我某甲。此衣僧伽梨若干条受。若割截若未割截。是衣受持不离宿(如是三说)

(次问此衣是汝有不答言是)我某甲。此衣忧多罗僧七条受。若割截若未割截。是衣受持不离宿(如是三说)

(次问此衣是汝有不答言是)我某甲。此衣安陀会五条受。割截若未割截。是衣受持不离宿(如是三说)

(次问此钵多罗是汝有不答言是)我某甲。此钵多罗应量受。长用故(如是三说受衣钵已应求和上应言)大德忆念。我某甲。请大德为和上。愿大德。为我某甲作大戒和上。我某甲。依大德和上故。得受具足戒。愿大德。与我某甲受具足戒。慈愍故。(如是三说戒师应问)谁能为某甲作和上(和上答言我某甲能即时舍闻处着见处戒师应唱众僧和集)谁能为某甲。作教授师(若僧中有比丘言我能若有五法不应立作教师爱教嗔教怖教痴教教不教不知五法成就应立作教师不爱教不嗔教不怖教不痴教教不教知)

大德僧听。某甲。从和上某甲求受具足戒。某甲。能为某甲作教师。若僧时到僧忍听。僧某甲当作教师。为教某甲。如是白

大德僧听。某甲。从和上某甲求受具足戒。某甲。能为某甲作教师。教某甲故。谁诸长老忍某甲作教师教某甲者。是长老默然。谁不忍者便说。僧已忍某甲作教师教某甲竟。僧忍默然故。是事如是持(即时教师往弟子所教偏袒着衣胡跪合掌)

汝某甲听。今是至诚时实语时。后僧中亦如是问。汝实当言实。不实当言不实。我今问汝。汝丈夫不。年满二十不。非奴不。不与人客作不。不买得不。不破得不。非官人不。不犯官事不。不阴谋王家不。不负人债不。丈夫有如是病。若癞痈漏瘭疽痟疾癫病。汝有父母在不。若言在。父母听汝出家不。先不作比丘不。若言作。清净持戒不。舍戒时一心如法还戒不。三衣钵具不。汝字何等。和上字谁。答我名某甲。和上名某甲。教师问竟。应白僧。我问某甲竟(戒师语若清净者将来教礼僧足礼僧足已从僧乞受具足戒耳)

大德僧听。我某甲。从和上某甲。求受具足戒。我某甲。今从众僧乞受具足戒。和上某甲愿僧济度我。与我某甲受具足戒。慈愍故(如是三说即时一比丘唱)

大德僧听。某甲。从和上某甲求受具足戒。某甲已从众僧乞受具足戒。某甲和上某甲。若僧时到僧忍听。我今僧中问某甲无遮道法。如是白(戒师问遮法文与上教师问遮法文同上以空静此以众中以为异耳)

大德僧听。颇有未问者不。若未问者当更问。已问者默(戒师应唱)大德僧听。某甲。从和上某甲求受具足戒。某甲已从众僧乞受具足戒。和上。某甲某甲自说清净无诸难事。年岁已满衣钵具足。某甲和上某甲。若僧时到僧忍听。僧当与某甲受具足戒。和上某甲。如是白

大德僧听。某甲。从和上某甲。求受具足戒。某甲已从众僧乞受具足戒。和上某甲。某甲自说清净无诸难事。年岁已满衣钵具足。某甲和上某甲。僧今与某甲受具足戒。和上某甲。谁诸长老忍。与某甲受具足戒。和上某甲。忍者是长老默然。谁不忍者便说。是初羯磨成就不(如是三说)僧已忍与某甲受具足戒竟。和上某甲。僧忍默然故。是事如是持(若人问汝几岁应言未有岁何时若冬若春若夏有闰无闰是时节汝尽寿应忆念即时应说四依)

汝某甲听。是佛婆伽婆释迦牟尼多陀阿伽度阿罗诃三藐三佛陀。为受具足人说四依法。依是得出家受具足戒作比丘。何等四

依粪扫衣。比丘依是得出家受具足戒成比丘法。若更得白麻衣赤麻衣羯耶衣憍施耶衣翅夷罗衣钦跋罗衣劫贝衣。如是等余清净衣。皆是盈长得。是中依粪扫衣。能尽寿受持不(答能)

依乞食比丘。依是得出家受具足戒成比丘法。若更得为作食。因生六斋日食。月一日食。十六日食。众僧食。别房食。请食。若僧若私。如是等余清净食。皆是盈长得。是中依乞食。能尽寿受用不(答能)

依树下住。比丘依是得出家受具足戒。成比丘法。若得温室讲堂殿楼一重舍。阁屋平覆屋地窟山窟。漂头勒迦卧具曼头勒迦卧具。禅头勒迦卧具。下至草敷叶。如是等余清净房舍卧具。皆是盈长得。是中依树下住。能尽寿受用不(答能)

依陈弃药。比丘依是得出家受具足戒。成比丘法。若更得四种含销药(酥油蜜石蜜)四种净脂(熊脂驴脂猪脂鳣脂)五种根药(舍利姜赤附子波提鞮沙菖蒲根)五种果药(呵梨勒鞞醯勒阿摩勒胡椒跋钵罗)五种净盐(黑盐白盐紫盐赤盐鲁出盐)五种汤(根汤茎汤叶汤花汤果汤)五种树胶药(兴渠萨阇罗谛掖谛掖婆提谛掖婆那)如是等余清净药。皆是盈长得。是中依陈弃药。能尽寿受用不(答能)

汝某甲听。是佛婆伽婆释迦牟尼多陀阿伽度阿罗呵三藐三佛陀。为受具足比丘说四堕法。若比丘于是四堕法。若作一一法。是非比丘。非沙门非释子。失灭比丘法。如截多罗树断更不生不青不长不广。比丘亦如是。于四堕法。若犯一一法。非比丘非沙门非释子。失灭比丘法

佛种种因缘呵责欲欲想欲欲觉欲欲热。赞叹断欲除欲想灭欲热。若比丘。共诸比丘入戒法中。不舍戒戒羸不出相。随心想受淫欲乃至共畜生。是非比丘非沙门非释子。失灭比丘法。是事尽寿不应犯。汝能持不(答能)

佛种种因缘呵责偷夺法。赞叹不偷夺法。乃至一条线一寸纳一渧油分齐。尚不应偷夺。是中佛制极少乃至五钱若五钱直。若比丘随所偷夺事。若王捉若杀若打若缚。若摈出若输金罪。作是言。汝贼汝小儿汝痴汝堕官罪。若比丘如是偷夺者。是非比丘。非沙门非释子。失灭比丘法。是事尽寿不应犯。汝能持不(答能)

佛种种因缘呵责杀生。赞叹不杀生。乃至蚁子尚不应杀。何况于人。若比丘自手夺人命。若持刀与。若教死赞死。作是言。咄人用恶活为死胜生。随彼心乐死。种种因缘教死赞死。若作忧多杀。若头多杀。若作弶作网作拨。若作毗陀罗杀。若似毗陀罗杀。若断气杀。若堕胎杀。若按腹杀。若推着火中水中。若从高推下。若遣使道中死。乃至母腹中初得二根。身根命根歌罗罗中生。恶心方便令夺其命。从是因缘死者。是非比丘。非沙门非释子。失灭比丘法。是事尽寿不应犯。汝能持不(答能)

佛种种因缘呵责妄语。赞叹不妄语。是中乃至戏笑尚不应妄语。何况故妄语。若比丘不知不见空无过人法。自言我如是知如是见。我得须陀洹果乃至阿罗汉果。我得初禅二禅三禅四禅。我得慈悲喜舍无量空处识处无所有处非想非非想处定。我得不净观阿那般那念。诸天来至我所。诸天龙夜叉薜荔毗舍阇鸠槃茶罗刹等来至我所。彼问我答我问彼答。若比丘如是妄语者。是非比丘。非沙门非释子。失灭比丘法。是事尽寿不应犯。汝能持不(答能)

汝某甲听初篇罪不可起。第二篇罪虽可起。几时覆藏。随覆藏时。应行波利婆沙。行波利婆沙已。应行六夜摩那埵。行摩那埵已二十比丘众中出罪。是众中可耻为人所轻。是中汝不得故弄阴出不净。如是事能不作不(答能)

不得故触女人身。不得向。女人恶口语。不得女人前自赞供养身。不得媒嫁女人。不得自起房。佛听应作。不听不应作不得起大房。佛听应作。不听不应作。无根罪不得谤他人。少许罪因缘不得谤言大。不得勤破僧。不得佐破僧人。不毁辱他家。不得性戾难教。如是事能不作不(答能)

汝某甲听。僧已与汝受具足戒竟。善受教化随顺师教。汝已得好和上阿阇梨。得好众僧。得好国土好行道处。如转轮圣王所愿尚不能得满。汝今已具满。当恭敬三宝佛宝法宝比丘僧宝。当勤三学善戒学善心学善慧学。勤修三脱门空无相无作。当勤三业坐禅诵经劝作众事。汝行是法当开甘露门。得须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道。如莲华在水日夜增长。汝诸善根亦复如是。于佛法中日夜增长。余残诸戒。和上阿阇梨当渐渐为汝广说。即为说偈

  释师子法中　　一切妙善集
  深大无涯际　　功德之宝海
  是愿转轮王　　天王善法王
  常求作沙门　　不遂汝已得
  精勤行三业　　佛法无量种
  汝常忆念法　　逮诸无碍智
  如莲华在水　　渐渐日增长
  汝亦如是信　　戒闻定慧增
  余戒佛所说　　和上师当教
  众中礼绕竟　　喜各从所乐

    结小界文第九(先结空地界然后结界场先一比丘唱四方小界相作畔齐已作白二羯磨在众中作如是白)

大德僧听。比丘某甲。唱四方小界相。僧今结小界作戒场。若僧时到僧忍听。僧于此四方相内。结小界作戒场。如是白

大德僧听。比丘某甲。唱四方小界相。僧今于此四方相内。结小界作戒场。谁诸长老忍僧于此四方相内结小界作戒场者。是长老默然。谁不忍者便说。僧已忍于此四方相内结小界作戒场竟。僧忍默然故。是事如是持

    结大界文第十(先令一比丘唱四方大界相作畔齐已作白二羯磨在众中作如是白)

大德僧听。比丘某甲。唱四方大界相。是诸相内是界内。若僧时到僧忍听是中一布萨共住结界。如是白

大德僧听。比丘某甲。唱四方大界相。是诸相内是界内。是中一布萨共住结界。谁诸长老忍。是中一布萨共住结界者默然。谁不忍者便说。僧已忍一布萨共住结界竟。僧忍默然故。是事如是持

    结不离衣界文第十一

大德僧听。一布萨共住。随几许结界内。是中除聚落及聚落界。取空地及住处。若僧时到僧忍听。是中一布萨共住结界内。作不离衣宿羯磨。如是白

大德僧听。一布萨共住。随几许结界内。是中除聚落及聚落界。取空地及住处。是中一布萨共住结界内。作不离衣宿羯磨。谁诸长老忍。是中一布萨共住结界内。作不离衣宿羯磨者。是长老默然。谁不忍者便说。僧已忍一布萨共住结界内作不离衣宿羯磨竟。僧忍默然故。是事如是持

    解大界文第十二(解小界亦依此文正言小界为异耳)

大德僧听。是中一布萨共住和合解界舍界。若僧时到僧忍听。一布萨共住解界舍界。如是白

大德僧听。是中一布萨共住处解界舍界。谁诸长老忍一布萨共住处解界舍界者默然。谁不忍者便说。僧已忍一布萨共住处解界舍界竟。僧忍默然故。是事如是持(所以无别解衣界文者欲更广促界者亦应解衣界后解大界若直解大界衣界亦并自去故不烦文也)

尼结界舍戒文亦同

    差监为僧执事第十三(执事人有十四种五法成不随爱不随嗔不随怖不随痴知得不一比丘僧中唱)

大德僧听。比丘某甲。能为僧作知食人。若僧时到僧忍听。立某甲作知食人。如是白

大德僧听。比丘某甲。能为僧作知食人。谁诸长老忍立某甲作知食人者。是长老默然。谁不忍者便说。僧已忍立某甲作知食人竟。僧忍默然故。是事如是持(余十三种人亦应羯磨差尼家十二种文亦同)

    受安居文第十四(佛言五众应安居何等五人者一比丘二比丘尼三式叉摩尼四沙弥五沙弥尼云何应受安居佛言若上座欲安居应从坐起偏袒着衣胡跪合掌应如是言)

长老忆念。我比丘某甲。是住处夏安居前三月。依某甲可行处聚落某甲僧坊久破。为治故(如是三说)

下座应言莫放逸上座言受持(若下座受安居如上座法唯除捉两足为异耳后三月受持亦尔)

    受七日文第十五

长老忆念。我比丘某甲。是住处夏安居。受七日出界外。为缘事故(如是三说)

    受三十九夜文第十六(乞三十九夜出界文若僧众受遣不须乞若私营三宝事须乞乞法者)

大德僧听。我比丘某甲。为僧事故。今从众僧乞三十九夜出界外。还是中安居。是中自恣(如是三说)

大德僧听。比丘某甲。是处夏安居。受三十九夜出界外。为僧事故。若僧时到僧忍听。僧某甲是处夏安居。为僧事故。受三十九夜出界外。如是白

大德僧听。比丘某甲。是处夏安居。为僧事故。受三十九夜出界外。谁诸长老忍某甲是处夏安居为僧事故受三十九夜出界外者是长老默然。谁不忍者便说。僧已忍与某甲三十九夜出界外竟。僧忍默然故。是事如是持

    一人心念口言布萨文第十七

今僧布萨。若十四日若十五日。我今日亦布萨(如是三说)

    三人二人三语布萨文第十八(受法上下仪法如上故不烦文)

长老忆念。今日僧布萨。若十四日若十五日。长老。知我清净忆持无遮道法。戒众满故(如是三说)

    四人以上广布萨时与清净文第十九

长老忆念。今日若十四日若十五日。僧作布萨。我比丘某甲。有缘事故。与僧清净布萨欲。长老。为我说并取筹(如是三说)

    至僧中说清净文第二十

长老忆念。今日僧作布萨。比丘某甲。有缘事故。与僧清净欲为取筹(如是三说)

十诵羯磨比丘要用一卷


十诵律

    No. 1435

十诵律卷第一(初诵之一)

        后秦北印度三藏弗若多罗共罗什译

    明四波罗夷法之一

佛在毗耶离国。去城不远有一聚落。是中有长者子。名须提那加兰陀子。富贵多财种种成就。自归三宝为佛弟子。厌世出家剃除须发被着法服而作比丘。远离乡土到憍萨罗国一处安居。时世饥馑乞食难得。诸人民妻子尚乏饮食。何况能与诸乞求人。时须提那作是念。此大饥馑乞求难得。我等诸亲里多饶财富。当因我故布施作福。今正是时。作是念已。夏安居过三月自恣竟作衣毕。着衣持钵还毗耶离。经游诸国至本聚落。晨朝时到着衣持钵入村乞食至亲里舍。为诸比丘各各劝与种种饮食。自行头陀受乞食法。次乞食已还到自舍。而作是言。先许当还我今来归。作是语已便駃出去。其家小婢见其駃去。即驰往白须提那母。向须提那入门便去。其母念言。须提那入门即去。或能愁忧欲还舍戒不乐梵行。我今当往教令还家自恣五欲布施作福。作是念已。往到其所语须提那。汝若愁忧不乐梵行欲舍戒者。便来还家受五欲乐布施作福。即答母言。我无愁忧不欲舍戒不厌梵行。亦不欲舍沙门之法心乐梵行。其母自念。我虽口言不回其心。当语其妇言。汝净洁时到则来报我。便往语之。妇言如是受其母教。净洁时到。往报母言。今何所作。时母教言。本须提那所喜衣服严饰之具悉皆着来。受教还房。着其所喜衣服严具。母即将到须提那所。便作是言。汝若愁忧不乐梵行欲舍戒者。当自还家受五欲乐布施作福。佛法难成出家勤苦。即答母言。我不愁忧心不动转自乐修梵行不乐五欲。母言。善哉须提那。汝乐梵行不欲舍戒者。今妇时到当留续种。若家无嗣。所有财物悉当入官。尔时世尊未结此戒。是须提那即便心动答母。言尔。母即避去。便将其妇屏处行淫。如是再三。寻时怀妊。有福德子月满而生。名曰续种。至年长大信乐佛法。出家学道勤行精进。逮得漏尽成阿罗汉。时须提那既行淫已。心生疑悔。愁忧色变无有威德。默然低头垂肩迷闷不乐言说。时知识比丘来相问讯在一面坐。问须提那。汝先有威德颜色和悦乐修梵行。今何以故。愁忧色变默然低头迷闷不乐。汝身为病为私屏处作恶业耶。须提那言。我身无病。私屏作恶业故心有愁忧。时诸比丘渐渐急问。便自广说如上因缘。诸比丘闻已。种种因缘呵须提那言。汝应愁苦忧悔。乃作如是私屏恶业。汝所作事非沙门法。不随顺道无欲乐心。作不净行。出家之人所不应作。汝不知佛世尊以种种因缘呵欲欲想欲欲欲觉欲热。以种种因缘称赞断欲舍欲想灭欲热。佛常说法教人离欲。汝尚不应生心。何况乃作起欲恚痴结缚根本不净恶业。时诸比丘种种呵已。向佛广说。佛以是事集比丘僧。诸佛常法。知而故问。或有知而不问。有知时问。有知时不问。有益事问。无益事不问。有因缘问。佛世尊知彼时。以正念安慧问须提那。汝实作是事不。答言实作世尊。佛以种种因缘呵责须提那言。汝所作事非沙门法。不随顺道无欲乐心作不净行。出家之人所不应作。汝愚痴人不知我以种种因缘呵欲欲想欲欲欲觉欲热。种种因缘称赞断欲舍欲想灭欲热。我常说法教人离欲。汝尚不应生心。何况乃作起欲恚痴结缚根本不净恶业。语诸比丘。是愚痴人开诸漏门。宁以身分内毒蛇口中。终不以此触彼女身。佛如是种种因缘呵已语诸比丘。以十利故为诸比丘结戒。摄僧故。极好摄故。僧安乐住故。折伏高心人故。有惭愧者得安乐故。不信者得净信故。已信者增长信故。遮今世恼漏故。断后世恶故。梵行久住故。从今是戒应如是说。若比丘同入比丘学法。不舍戒行淫法。是比丘得波罗夷不共住

佛在舍卫国。有一比丘名跋耆子。不舍戒戒羸不出还家作淫。后欲出家自作是念。我当先往问诸比丘。得出家不。不得则止。作是念已问诸比丘。诸比丘疑以此白佛。佛言。有人不舍戒戒羸不出还家作淫。可得出家更作比丘。从今是戒。应如是说。若比丘同入比丘戒法。不舍戒戒羸不出作淫法。是比丘得波罗夷不应共住

佛在舍卫国。尔时憍萨罗国有一比丘独住林中。有雌猕猴常数来往此比丘所。比丘即与饮食诱之。猕猴心软便共行淫。是比丘多有知识。来相问讯在一面坐。时猕猴来欲行淫。一一看诸比丘面。次到所爱比丘前住谛视其面。时此比丘心耻不视猕猴。猕猴寻嗔攫其耳鼻伤破便去。时诸比丘急问其故。便自广说如上因缘。诸比丘以种种因缘呵责。汝所作事非沙门法。不随顺道无欲乐心作不净行。出家之人所不应作。汝不知佛以种种因缘呵欲欲想欲欲欲觉欲热。以种种因缘称赞断欲舍欲想灭欲热。佛常说法教人离欲。汝尚不应生心。何况乃作起欲恚痴结缚根本不净恶业。时诸比丘种种因缘呵责已。往诣佛所向佛广说。尔时世尊以是因缘集比丘僧。知而故问是比丘。汝实作是事不。答言实作世尊。佛以种种因缘呵责。汝所作事非沙门法。不随顺道无欲乐心作不净行。出家之人所不应作。汝愚痴人。不知我以种种因缘呵欲欲想欲欲欲觉欲热。种种因缘称赞断欲舍欲想灭欲热。我常说法教人离欲。汝尚不应生心。何况乃作起欲恚痴结缚根本不净恶业。如是种种因缘呵已语诸比丘。我先已结此戒。今复随结。从今是戒应如是说。若比丘同入比丘学法。不舍戒戒羸不出行淫法。乃至共畜生者。是比丘得波罗夷不应共住。若比丘者有四种。一者名字比丘。二者自言比丘。三者为乞比丘。四者破烦恼比丘。名字比丘者。以名为称。自言比丘者。用白四羯磨受具足戒。又复贼住比丘。剃除须发被着袈裟。自言我是比丘。是名自言比丘。为乞比丘者。从他乞食故。如婆罗门从他乞时。亦言我是比丘。是名为乞比丘。破烦恼比丘者。诸漏结缚烦恼众生。能受后身生热苦报。生死往来相续因缘。若能知见断如是漏拔尽根本。如断多罗树头毕竟不生。是名破烦恼比丘。云何比丘具足戒。云何具足戒比丘。若僧和合说白四羯磨。是人信受随行不违不逆不破。是名比丘具足戒。是名具足戒比丘。学者有三学。善戒学善心学善慧学。复有三学。善学威仪善学毗尼善学波罗提木叉。同入学法者。如百岁受戒比丘所学。初受戒人亦如是学。如初受戒人所学。百岁比丘亦如是学。是中一心一戒一说一波罗提木叉。同心同戒同说同波罗提木叉。故名同入比丘学法。不舍戒者。若比丘狂时舍戒。不名舍戒。若心乱时。病坏心时。若向狂人。向乱心人。向病坏心人。若独舍戒。若独不独想。不独独想。若中国语向边地人不相解者。若边地语向中国人不相解者。若向哑人。若向聋人。向哑聋人。向无所知人。若向非人。向睡眠人。向入定人。若隔障。若自嗔。若向嗔人。若梦中。若自不定心。若向不定心人。如是舍戒皆不名舍戒。或有舍戒非戒羸。或有戒羸非舍戒。或有戒羸亦舍戒。舍戒非戒羸者。若比丘言。我舍佛即名舍戒。若言。舍法舍僧舍戒。舍和上舍阿闇梨。舍同和上同阿阇梨。舍比丘比丘尼。舍式叉摩尼。舍沙弥沙弥尼。舍优婆塞舍优婆夷。皆名舍戒。若言。汝等当知我是白衣若是沙弥。非比丘非沙门非释子。乃至不复与汝等共作同学。是名舍戒非戒羸。戒羸非舍戒者。若比丘愁忧不乐。欲舍戒厌比丘法。欲弃圣服取白衣服。须白衣法不须比丘法求在家事。复作是言。我念父母兄弟姊妹我念儿女。当駃教我生活伎术。安我好处嘱我以善知识。说如是语。是名戒羸非舍戒。戒羸亦舍戒者。若比丘愁忧不乐欲舍戒。厌比丘法欲弃圣服。取白衣服须白衣法。不须比丘法求在家事。复作是言。我念父母兄弟姊妹我念儿女。当駃教我生活伎术。安我好处嘱我以善知识。说如是语已复作是言。我舍佛舍法乃至舍优婆塞优婆夷。是名戒羸亦舍戒。行淫法者。淫名非梵行。非梵行者二身交会。波罗夷者名堕不如。是罪极恶深重。作是罪者。即堕不如。不名比丘。非沙门非释子。失比丘法。不共住者。不得共作比丘法。所谓白羯磨白二羯磨白四羯磨布萨自恣。不得入十四人数。是名波罗夷不共住。是中犯者有四种。男女黄门二根。女者。人女非人女畜生女。男者人男非人男畜生男。黄门二根者。亦人非人畜生。比丘与人女行淫。三处犯波罗夷。大便处小便处口中。非人女畜生女二根亦如是。共人男行淫。二处犯波罗夷。大便处口中。非人男畜生男黄门亦如是。复有共畜生女行淫。二处犯波罗夷。谓鸡若似鸡是

佛在舍卫国。有一乞食比丘。名曰难提。晨朝时到着衣持钵入城乞食食已持尼师坛着左肩上入安桓林。在一树下敷尼师坛端身正坐。有魔天神。欲破是比丘三昧故。化作端政女身在其前立。比丘从三昧起。见此女身即生着心。世俗禅定不能坚固。寻时退失欲摩女身。女人即却渐渐远去。便起随逐欲捉其身。时彼林中有一死马。女到马所则身不现。是比丘淫欲烧身故。便共死马行淫。既行淫已欲热小止。即生悔言。我已退堕。非是比丘非释种子。今诸比丘必舍远我不复共住。我不应以不清净身着此法衣。即脱袈裟摄着囊中以置肩上往诣佛所。尔时佛与百千万众恭敬围绕而为说法。佛遥见来即作是念。若我不以软语劳问者。其心必破沸血当从面孔出。是比丘来到佛所。佛言。善哉难提。汝更欲学比丘所学耶。闻佛所言善哉难提。心大欢欣便作是念。我当得共诸比丘住必不摈我。如是思惟已答言。世尊。我更欲学比丘学法。尔时佛语诸比丘。汝等还与难提比丘学法。若有如难提比丘者亦与学法。应一心和合僧难提比丘偏袒右肩脱革屣胡跪合掌作如是言。大德僧听。我难提比丘。不舍戒戒不羸不出作淫法。我今从僧还乞学法。僧怜愍我故。还与我学法。第二第三亦如是说。是中一比丘于僧中唱。大德僧听难提比丘不还戒戒不羸作淫法。是难提比丘从僧乞还学法。今僧怜愍故还与学法。若僧时到僧忍听。还与难提比丘学法。白如是。如是用白四羯磨还与难提比丘学法竟。僧忍默然故是事如是持。与学沙弥行法者。佛所结一切戒尽应受行。在诸比丘下坐。应授与大比丘饮食汤药。自从沙弥白衣受饮食。不得与大比丘同室过再宿。自不得与白衣沙弥过二宿。得与具戒比丘作布萨自恣二羯磨。与学沙弥不得足数作布萨自恣羯磨。一切羯磨不得作(淫事竟)

佛在王舍城。尔时众多比丘共一处安居。少于房舍。时诸比丘随所知识乞索草木。各各自作庵舍止住。是诸比丘入城乞食。有取薪人。坏其庵舍持材木去。乞食还见即生忧愁。作如是言。我等辛苦暂行乞食。诸年少辈便坏我舍持材木去。当复更从知识乞索草木作庵舍住。是时众中有一比丘。名达尼迦。是陶家子。自以巧便即作泥舍泥户泥向。梁椽牛头象牙衣架皆用泥作。集诸草木以火烧成。色赤严好。作是舍已嘱诸比丘。二月游行乞索。欲作入舍饮食。尔时佛与阿难按行诸房。遥见其舍色赤严好。佛知而故问阿难。是何等物色赤严好。阿难答言。今王舍城众多比丘一处安居。其房舍少。是诸比丘随所知识乞索草木作庵舍住。入城乞食时。取薪人便坏庵舍持材木去。乞食还见生愁忧言我等辛苦暂行乞食。诸年少辈便坏我舍持材木去。是中有比丘名达尼迦。陶家子。自以巧便作是泥舍。集诸草木以火烧成。严好如是。佛告阿难。汝破是达尼迦比丘赤色泥舍。莫使外道讥嫌呵责。佛现在世出如是漏结因缘法。阿难受教。即往破之。达尼迦比丘二月游行。还见舍破坏。问所嘱比丘。谁坏我舍。比丘答言。是佛大师教令破之。达尼迦心念。法王教破不得有言。今王舍城诸材木师。是我知识。可作木舍。过夜时到着衣持钵入城乞食。乞食已到木师所。汝今知不。摩竭国主韦提希子阿阇世王。与我材木。木师答言。若王与者随意取之。是中有大重材中守护城难持出入不应乞人者。即取斩截藏着一处。时知城统。见大重材中守护城斩截覆藏。见已惊怖毛竖生念。得无怨贼将欲来耶。若已得入往问木师。是大材木用守护城。谁取斩截藏着一处。答言。有达尼迦比丘。来作是言。阿阇世王与我材木。我时答言。若王与者随意取之。即便自取大材木斩截藏着一处。城统心念。王今云何乃以大材与此比丘。即到王所言。大王更有余材。云何乃以守城大材持与比丘。王言不与。城统言。王今已与。谁言我与。答言。木师言与。王曰。将木师来。即受教去将木师来。时木师中道见达尼迦比丘语言。以汝因缘故我今有事。比丘言。且去我随后往。时城统即将木师到王所言。大王。此是木师。时达尼迦比丘随后来。王遥见之便言。放木师去将比丘来。城统即放木师将达尼迦比丘前到王所。王言。汝比丘法云何不与而取。答言。大王。我非不与取。王先与我。王言。我不忆与。比丘答言。今令王忆。王言云何。答言。王当自念初登位时。作如是言。若我国内草木及水。随诸持戒沙门婆罗门取用。王言。我谓无主草木故作是说。王言。汝今堕大罪中。比丘答言。我出家人寄住王国。云何杀我。王言。比丘去。勿复更取如是大材。时众人唱言。希有此比丘。决定应死。呵责便放。是比丘从大罪中得出。到众僧中食。后语诸比丘。我今日垂为王所杀。广说上事诸比丘以种种因缘呵责。汝所作事非沙门法。不随顺道无欲乐心作不清净行。出家之人所不应作。汝不知佛世尊以种种因缘呵责偷夺法。种种因缘称赞不偷夺法。汝尚不应生心。亦不应说。何况能取。以种种因缘呵已向佛广说。佛以是事集比丘僧。知而故问。汝达尼迦比丘。实作是事不。答言。实作世尊。佛以种种因缘呵责。汝所作事非沙门法。不随顺道无欲乐心作不清净行。出家之人所不应作。佛言。汝痴人。不知我以种种因缘呵责偷夺法。种种因缘称赞不偷夺法。汝尚不应生心。口亦不应说。何况乃取。种种因缘呵已语阿难。将一下坐比丘入王舍城。街巷市里多人众处。以问众人。若信不信者。若贤者非贤者。若大臣大官将帅官属。盗至几许。摩竭国主阿阇世王与其大罪。阿难受教。将一下坐比丘入王舍城。街巷市里多人众处。以问众人。盗至几许。摩竭国主阿阇世王便与大罪。众人答言。大德阿难。盗至五钱若五钱直。便与大罪。阿难闻已。还诣佛所作礼却住向佛具说。盗至五钱若五钱直。阿阇世王便与大罪。佛即语诸比丘。以十利故与诸比丘结戒。从今是戒应如是说。若比丘若聚落中若空地。物不与偷取。以所偷物。若王王臣。若捉系缚若杀若摈若输金罪。若作是言。汝小儿汝痴汝贼。比丘如是不与取者。得波罗夷不应共住。不与取者。他人不与是物。若男若女若黄门若二根人不与盗取。是名不与取。王者刹利种身受王职吉水灌顶。是名为王。亦名国主。亦名灌顶。若婆罗门居士若女人身受王职。亦名为王国主灌顶。杀者名为夺命。系者。若着杻械枷锁在狱。皆名为系。摈者。驱出国界。输金者。输金等物赎罪。贼者有二种。若劫若盗。汝小儿者。未知法故。痴者。无所知故。波罗夷者名堕不如。是罪极恶深重。作是罪者。不名比丘。非沙门非释子。失比丘法不共住者。不共作比丘法。所谓白羯磨白二羯磨白四羯磨说戒自恣。不得入十四人数。是名波罗夷不共住。是中犯者有三种。取人重物犯波罗夷。一者自取。二者教他人。三者遣使。自取者。手自取自手举离本处波罗夷。教他者。若比丘教人盗他物。是人随语即偷夺取离本处。是时。比丘得波罗夷。遣使者。若比丘语人言。汝知某甲重物处不。若言知处遣往盗取。是人随语即偷夺。取离本处时。比丘得波罗夷。复有三种。取人重物波罗夷。一者用心。二者用身。三者离本处。用心者。发心思惟欲偷夺取。用身者。若手若脚若头若余身分取他人物。离本处者。随物所在处举着余处。复有三种。取人重物波罗夷。一者他不与。二者重物。三者离本处。他不与者。若男若女若黄门若二根人不与。重物者。物直五钱若过五钱。离本处者。随物所在处举着余处。复有三种。取人重物波罗夷。一者盗心。二者重物。三者离本处。盗心者。他不与自盗心取。重物离本处亦如上说。复有三种。取人重物波罗夷。一者是物属他。二者重物。三者离本处。属他者。是物有主。若男若女若黄门若二根人。重物离本处如上说。复有三种。取人重物波罗夷。一者属他想。二者重物。三者离本处。属他想者。知是物有主人。重物离本处如上说。若男若女黄门二根人。重物离本处如上说复有四种。取人重物波罗夷。一者他不与二者偷夺心取。三者重物。四者离本处。皆如上说。复有四种。取人重物波罗夷。是物属他偷夺心取。重物离本处波罗夷。知物属他偷夺心取。重物离本处。皆如上说。复有四种。取人重物波罗夷。一者有守护。二者有主。三者重物。四者离本处。有守护者。如人有象马牛羊妻子奴婢。若在自国若在他国有人守护。有我所心谁为我所心随谁物。复有田甘蔗田稻田麦田麻田豆田葡萄田有人守护。有我所心谁为我所心随谁物。复有象厩马厩门间食厨。有人藏物在中。是名守护。有我所心谁为我所心随谁物。重物离本处如上说。复有四种。取人重物波罗夷。是物无守护有我所心重物离本处。无守护者。如人有象有马妻子。若在自国若在他国。是物无人守护。有我所心谁为我所心随谁物。复有田地。场上有谷。是物无人守护。有我所心谁为我所心随谁物。复有五宝若似五宝。藏着地中无人守护。但有我所心。谁有我所心。谓随所属主有我所心。是名有主无人守护。重物离本处如上说。复有四种。取他重物波罗夷。是物有守护无我所心重物离本处。有守护无我所心者。如群贼破他城邑多得财物。若以王力若聚落力还破是贼。贼舍物走。是物主不守护无我所心。已失故。贼亦不守护无我所心。已夺故。有守护无我所心。谁守护无我所心。夺得者。又如比丘失诸衣钵。有知识比丘在余处见。便即夺取。是失衣钵比丘不守护无我所心。已失故。贼不守护无我所心。已夺故。有守护无我所心。谁守护无我所心。夺得者。重物离本处如上说。处者。地处上处虚空处。乘处车处船处。水中田地僧坊处。身上处关税处共期处。无足二足四足多足。地处者。如人有五宝若似五宝在地。比丘以偷夺心取离本处波罗夷。若选择时偷兰遮。选择已取五钱直波罗夷。若以木瓦石举取。虽堕本处波罗夷。若拽取未出界偷兰遮。又如铁瓶铜瓶铁瓮铜瓮。以五宝若似五宝着此器中。比丘以偷夺心取离本处波罗夷。若选择时偷兰遮。选择已取五钱直波罗夷。若取瓶底物转出近口波罗夷。近瓶口物转着瓶底亦波罗夷。若穿瓶取五钱直波罗夷。若比丘偷夺心。在器不在物。若心在物不在器。或心两在。取五钱直波罗夷。是名地处。上处者。若细陛绳床粗陛绳床。蓐囊蓐薄蓐厚蓐蓐覆杂色蓐杂色绶缘。薄被厚被表[革*茸]被表里[革*茸]被缘[革*茸]被。地敷具树上处屋上处。细陛绳床处者。谓脚处足处环处床陛处上绳床足处上头处。若以绳织异绳名异处。若皮若衣覆。一色名一处。异色名异处。如是诸处有五宝若似五宝。比丘以偷夺心取五钱直波罗夷。若选择时偷兰遮。选择已取五钱直波罗夷。粗梐绳床处者。若一板名一处。若皮若绳若衣覆。异绳名异处。余如上说。蓐者一种毛一种名一处。表处里处一色名一处。异色名异处。是诸处有五宝若似五宝。比丘以偷夺心取五钱直波罗夷。若选择时偷兰遮。选择已取五钱直波罗夷。囊蓐薄蓐厚蓐蓐覆杂色蓐杂色绶缘薄被厚被表[革*茸]被表里[革*茸]被缘[革*茸]被地敷具处者。一种毛名一处。一色名一处。异色名异处。余如上说。树处者。根处茎处枝处叶处华处果处乃至根须处。是诸处有五宝若似五宝。比丘以偷夺心取五钱直波罗夷。若选择时偷兰遮。选择已取五钱直波罗夷。屋上处者。谓门间处向处门关处户橝处牛头象牙衣架梁椽重阁梯梐处。一桄名一处。栏楯处一钩名一处。若未泥舍一墼名一处。若草覆舍一重名一处。若木覆舍一木名一处。若仰泥舍一画色名一处。是诸处有五宝若似五宝。比丘以偷夺心取五钱直波罗夷。若选择时偷兰遮。选择已取五钱直波罗夷。是名上处。虚空处者。如人房舍殿堂诸栏楯上。有贵价衣波头摩衣头求罗衣鸠罗阇衣悬是诸处。风吹在空衣未堕地。比丘以偷夺心接取波罗夷。又如比丘和上阿阇梨衣。从下至上从上堕下衣未至地。比丘以偷夺心接取波罗夷。又如人门中向中阁上檐下楼观处屋间阁上。以内外庄严身具在是诸处。有有主鸟鹅雁孔雀鹦鹉猩猩衔是物去。比丘以偷夺心夺是鸟取波罗夷。若待鸟时偷兰遮。鸟随比丘所欲至处波罗夷。若至余处偷兰遮。若有野鸟谓诸鹰鹫衔是物去。比丘以偷夺心夺是鸟取偷兰遮。若待鸟时突吉罗。鸟随比丘所欲至处偷兰遮。若至余处突吉罗。又诸野鸟持是物去。诸有主鸟夺野鸟取。比丘以偷夺心夺是有主鸟波罗夷。若待鸟时偷兰遮。鸟随比丘所欲至处波罗夷。若至余处偷兰遮。诸有主鸟持是物去为野鸟所夺。比丘以偷夺心夺野鸟取偷兰遮。若待鸟时突吉罗。鸟随比丘所欲至处偷兰遮。若至余处突吉罗。是名虚空处。乘处者。象乘马乘。象乘处者。谓脚处膝处髀处胯处肋处脊处胸处颈处头处耳处鼻处口处牙处尾处。如是诸处有五宝若似五宝。比丘以偷夺心取波罗夷。若选择时偷兰遮。选择已取五钱直波罗夷。马乘处者。谓脚处膝处髀处胯处肋处脊处胸处颈处头处耳处鼻处口处鬃毛处尾处。余如上说。车处者。犊车鹿车獐车步挽车辇车。犊车处者。谓辐辋辕毂箱处栏楯处。是诸处有五宝若似五宝。比丘以偷夺心取波罗夷。若选择时偷兰遮。选择已取五钱直波罗夷。鹿车獐车步挽车亦如是。辇车处者。脚处脚重环处坐处板橙处柱处覆处。若绳索覆若衣覆。一色名一处。异色名异处。是诸处有五宝若似五宝。比丘以偷夺心取波罗夷。若选择时偷兰遮。选择已取五钱直波罗夷。是名乘处。船处者。单槽船舫船舍船瓶船浮囊船板船木筏草筏。单槽船处者。两舷处两头处底处两箱处竖桅处柁楼处。是诸处有五宝若似五宝。比丘以偷夺心取波罗夷。选择时偷兰遮。选择已取五钱直波罗夷。舫船处者。谓横梁处绳缚处。余如上说。舍船处者。谓板壁处瓶处瓮处安瓶瓮盖处柱处梁处。若以草覆。一重草名一处。若木枝覆若板覆。一覆名一处。异色名异处。是诸处有五宝若似五宝。比丘以偷夺心取波罗夷。瓶船处者。一切瓶一切绳缚处一切皮缚处。浮囊船处者。一切囊处一切缚处。板船者。一切板处。木筏者。一切木处。草筏处者。一切草处一切缚处。是诸处有五宝。若似五宝。比丘以偷夺心取波罗夷。若选择时偷兰遮。选择已取五钱直波罗夷。是名船处。水处者。如人为舍故车故薪故水中浮物来下。比丘以偷夺心取波罗夷。若选择时偷兰遮。选择已取五钱直离本处波罗夷。若从捉留住后水到前波罗夷。若沉着水底波罗夷。若举离水亦波罗夷。复次有主池中诸有主鸟。比丘以偷夺心取是诸鸟波罗夷。若选择时偷兰遮。选择已取五钱直波罗夷。若沉着水底偷兰遮。若举离水波罗夷。复有无主池中诸有主鸟。比丘以偷夺心取波罗夷。若选择时偷兰遮。选择已取五钱直波罗夷。若沉着水底波罗夷。若举离水亦波罗夷。是名水处。田处者。有二因缘夺他田地。一者相言。二者作相。比丘为地故言他得胜者波罗夷。不如者偷兰遮。若作异相过分得胜。地直五钱波罗夷。僧坊舍亦如是。是名田处。身上处者。如比丘与和上阿阇梨持衣行。是比丘身上诸处。谓脚处[跳-兆+尃]处膝处髀处胯处臗处肋处脊处腹处胸处手处肘处臂处肩处颈处头处。比丘以偷夺心取是衣囊。从此处移着彼处波罗夷。是名身上处。关税处者。比丘度关应输税物而不输税直五钱波罗夷。复有贾客至关税处语比丘言。与我过是物。比丘与过税直五钱波罗夷。复有贾客至关税处语比丘言。与我过是物与汝半税。比丘与过得税物直五钱波罗夷。复有贾客至关税处语比丘言。与我过是物尽与汝税。比丘与过若税物直五钱波罗夷。复有贾客来至关税处。比丘示异道过失所税物。物直五钱波罗夷。复有贾客未至税处。比丘示异道过失所税物。五钱直偷兰遮。若税处有贼若恶兽若饥饿故。比丘示异道不犯。是名关税处。共期处者。比丘与贼共期。破诸村落得物与比丘分。得五钱直波罗夷。是名共期处。无足众生者。蛭虫千头罗虫有人取之举着器中。比丘以偷夺心取波罗夷。若选择时偷兰遮。选择已取五钱直波罗夷。若穿器取虫直五钱波罗夷。若比丘偷心在器不在虫。若心在虫不在器。若心两在。以偷夺心取得五钱直波罗夷。是名无足处。二足处者。如鹅雁孔雀鹦鹉舍利鸟拘耆罗鸟狌狌及人。有人取是物举着笼中。比丘以偷夺心取得波罗夷。若选择时偷兰遮。选择已取五钱直波罗夷。若穿笼取鸟直五钱波罗夷。若比丘偷心在笼不在鸟。若心在鸟不在笼。若心两在。以偷夺心取得五钱直波罗夷。偷人有二种。一者担去。二者共要。若比丘以人着脊上过二踔波罗夷。若共期处行过二踔波罗夷。是名二足处。四足处者。象马牛羊驴骡。有人以绳系在一处。比丘以偷夺心解绳牵去过四踔波罗夷。若在墙壁篱障内。比丘以偷夺心驱出过四踔波罗夷。有诸四足共一处卧。比丘以偷夺心驱一令起出过四踔波罗夷。若在外放。比丘心念。是放牧人入村去时我当盗取偷兰遮。若杀者波夜提。杀已取肉直五钱波罗夷。是名四足处。多足处者。蜈蚣百足蛣蜣。有人举着器中。比丘偷夺心取波罗夷。若选择时偷兰遮。选择已取五钱直波罗夷。若穿器取虫直五钱波罗夷。若偷心在器不在虫。若心在虫不在器。若心两在。以偷心取直五钱波罗夷。是名多足处。又有七种。取人重物波罗夷。一非己想。二不同意。三不暂用。四知有主。五不狂。六不心乱。七不病坏心。又七种取人重物无犯。一者己想。二者同意。三者暂用。四者谓无主。五者狂。六者心乱。七者病坏心。又七种取非人重物偷兰遮。一非己想。二不同意想。三不暂用。四知有主。五不狂。六不心乱。七不病坏心。又七种取非人重物无犯己想同意取暂用谓无主狂心乱心病坏心。又有七种取人轻物偷兰遮。非己想不同意不暂用知有主不狂不心乱不病坏心。又有七种取人轻物无犯。己想同意取暂用谓无主狂心乱心病坏心。又有七种取非人轻物突吉罗。非己想不同意不暂用知有主不狂心不心乱不病坏心。又有七种取非人轻物无犯。己想同意取暂用谓无主狂心乱心病坏心。有比丘尼名施越。多知识谓有福德人。喜供养与油酥蜜石。蜜有一贾客见是比丘尼。信敬心喜作如是言。善女所须酥油蜜石蜜至我舍取。答言如是。时有比丘尼闻是语。过后数日便往到其舍言。施越比丘尼须胡麻油五升。贾客问言。用作何等。答言。我持是至比丘尼寺中。贾客即与。是比丘尼持至寺中便自服。过之后数日。贾客见施越比丘尼言。善女何以但索麻油不索余物。比丘尼言。何以说是。答言。有一比丘尼来言。汝须胡麻油。我即与之。施越言善。若索余物汝亦当与。施越即往语彼比丘尼言。汝是弊恶比丘尼下贱比丘尼。汝得波罗夷。彼比丘尼言。何以尔。施越言。贾客不与。诈取他油。彼比丘尼言。我非不与取。我以汝名字故取。即自生疑。我将无得波罗夷耶。是事白佛。佛知故问。汝以何心取。答言。我以施越名字取。佛言。不得波罗夷。但故妄语得波夜提。从今日不得诈称他名取。若取犯罪。复有东方比丘尼。与波利比丘尼共一道行。时波利比丘尼在前遗失衣去东方比丘尼在后得之。共会一处时。东方比丘尼唱言。谁失是衣我今地得。波利比丘尼言。汝取是衣耶。答言我取。波利言。汝得波罗夷罪。问言何故。答言。汝以盗心取故。是比丘尼心疑。我将无得波罗夷耶。是事白佛。佛言无犯。有一居士近只桓耕地放衣一面。时有比丘求粪扫衣。见是地衣四顾无人便取持去。耕人遥见语比丘言。莫取我衣。比丘不闻。耕人即往捉比丘言。汝比丘法不与取耶。比丘答言。我谓粪扫无主故取。耕人言。此是我衣。比丘言。是汝衣者便自持去。比丘心疑。我将无得波罗夷耶。是事白佛。佛知故问。汝以何心取。比丘言。我谓无主故取。佛言无犯。从今取衣当善筹量。此是他衣物。虽无人守。必自有主(盗竟)

十诵律卷第一十诵律卷第二(初诵之二)

        后秦北印度三藏弗若多罗译

    明四波罗夷法之二

佛在跋耆国跋求摩河上。是时佛语诸比丘。修习不净观得大果大利。诸比丘作是念。世尊教我等。修习不净观得大果大利。我等当勤修习。诸比丘作是念已。勤修习不净观。深怀厌恶惭愧是身。譬如年少自喜严饰洗浴身体剪爪治须发着好衣服以香涂身。若以死蛇若以死狗。或以死人臭烂青瘀鸟兽所食脓血虫出以系其颈厌恶。臭尸深怀惭愧。是诸比丘深修不净观故惭愧厌恶亦复如是。尔时或有比丘发心。欲死叹死求刀自杀。或服毒药。或有自系。或投高崖。或有比丘转相害命。有一比丘勤修不净观。深得厌恶惭愧臭身。便往鹿杖梵志所赞言。善人。汝能杀我与汝衣钵。时彼梵志即以利刀而断其命。有血污刀。持至跋求摩河上洗之。有魔天神。从水中出住水上赞梵志言。善人汝得大福德。是沙门释子未度者度未脱者脱兼得衣钵。时彼梵志生恶邪见自谓审尔。便挟刀去从房至房从经行处至经行处唱言。谁未度者我当度之。谁未脱者我当脱之。时诸比丘勤修不净观故厌恶臭身。从住处出至梵志所赞言。善人可断我命。时彼梵志寻断其命如是二三乃至六十。以是因缘僧遂减少。月十五日说戒时至众僧减少。佛知故问阿难言。今说戒日众僧都集。何故减少。阿难白言。世尊一时教诸比丘。深修习不净观得大果大利。是诸比丘即勤修不净观。厌恶臭身。譬如年少自喜严饰。洗浴身体剪爪。治须发着好衣服以香涂身。若以死蛇若以死狗。或以死人臭烂青瘀鸟兽所食脓血虫出以系其颈。是人厌恶深怀惭愧。是诸比丘修不净观厌恶惭愧亦复如是。尔时或有发心欲死叹死求刀自杀。或服毒药或有自系。或投高崖或有比丘转相害命。有一比丘。勤修不净观故。深得厌恶惭愧臭身。便往鹿杖梵志所赞言。善人。汝能杀我。与汝衣钵。时彼梵志寻以利刀断是比丘命。有血污刀。持至跋求摩河上洗之。有魔天神。从水中出住水上赞梵志言。汝得大福德。是持戒沙门释子未度者度未脱者脱兼得衣钵。时彼梵志即生恶邪见自谓审尔。便挟刀去从房至房从经行处至经行处即大唱言。谁未度者我当度之谁未脱者我当脱之。时诸比丘勤修不净观故深得厌恶惭愧臭身。从住处出至梵志所赞言。善人可断我命。时彼梵志寻断其命。如是二三乃至六十。故僧减少。唯愿世尊。为诸比丘说余善道。安乐住法无有厌恶。诸恶法生即能除灭。佛语阿难。更有善道。安乐行法无有厌恶。诸恶法生即能除灭。世尊。云何善道。安乐住法无有厌恶。诸恶法生即能灭除。佛告阿难。有阿那般那念。名为善道安乐住法。所以者何。诸恶法生即能除灭。无厌恶故。世尊。云何修习阿那般那念。名为善道安乐住法。诸恶法生即能除灭。无有厌恶。佛语阿难。若有比丘随其所依城邑聚落止住。晨朝时到着衣持钵摄身诸根系念一心入村乞食。食已若在空处若在树下若在空舍。敷尼师坛正坐端身系念在前。除世贪嫉。于他财物远离贪着。如是行者则能舍离嗔恚睡眠调戏疑悔。是诸阴盖能烦恼心使慧力羸不至涅槃。是故当除。若息入时当一心知入。若息出时当一心知出。若长若短。若息入遍身。当一心知从一切身入。若息出遍身。当一心知从一切身出。除身行时。当一其心念出入息。受喜时受乐时受心行时除心行时。当一其心念出入息。觉心时令心喜时令心摄时令心解脱时当一其心念出入息。观无常观变坏观离欲观灭尽观舍离。当一其心念出入息。阿难。是名善道安乐行法。诸恶法生即能除灭。无有厌恶。尔时佛语诸比丘。当勤修习阿那般那念得大果大利。时诸比丘各作是念。世尊为我等赞叹修习阿那般那念。得大果大利。我等当勤修习。作是念已。即勤修习阿那般那念。便得无量种种知见作证。佛知多有比丘得漏尽道成阿罗汉。以是因缘集比丘僧种种呵责。云何名比丘。求刀自杀叹死教死。种种呵已语诸比丘。以十利故与诸比丘结戒。从今是戒应如是说。若比丘。若人若人类。故自夺命。若持刀与教死叹死。作如是言。人用恶活为。宁死胜生。随彼心乐死。种种因缘教死叹死。死者是比丘波罗夷不应共住。夺命者。自夺若教他夺。是中云何犯罪。比丘有三种夺人命波罗夷。一者自。二者教。三者遣使。自者。自身作自身夺他命。教者。教语他言。捉是人系缚夺命。遣使者语他人言。汝识某甲不。汝捉是人系缚夺命。是使随语夺彼命时。比丘得波罗夷。复有三种夺人命。一者用内色。二者用非内色。三者用内非内色。内色者。比丘用手打他。若足若头若余身分。作如是念。令彼因死。彼因死者是比丘波罗夷。若不即死后因是死亦波罗夷。若不即死后不因死得偷兰遮。用不内色者。若比丘以木瓦石刀槊弓箭。若木段白镴段铅锡段遥掷彼人。作如是念。令彼因死。彼因死者波罗夷。若不即死。后因是死亦波罗夷。若不即死。后不因死偷兰遮。用内非内色者。若比丘以手捉木瓦石刀槊弓箭。若木段白镴段铅锡段打他。作如是念。令彼因死。彼因死者波罗夷。若不即死后因是死亦波罗夷。若不即死后不因死偷兰遮。复有比丘。不以内色。不以非内色。亦不以内非内色。为杀人故合诸毒药。若着眼中耳中鼻中口中。若着男女根中身上若着疮中。若着饼肉中羹饭粥中若被褥中大车小车卧具辇舆步挽车中。作如是念。令彼因死。彼因死者波罗夷。若不即死后因是死亦波罗夷。若不即死后不因是死偷兰遮。复有比丘。不以内色。不以非内色。亦不以内非内色。亦不以毒药。为杀人故。作忧多杀。头多杀。作弶。作罥。作拨。作毗陀罗杀。半毗陀罗杀。断命杀。堕胎杀。按腹杀。推着火中。推着水中。推着坑中。若遣令去就道中死。乃至胎中初受二根身根命根。于中起方便杀。忧多者。有比丘。知是人从此道来。于中先作无烟火坑。以沙土覆上。若心念若口说。以是人从此道来故。我作是坑。是名成忧多。若是人因是死者。比丘得波罗夷。若不即死后因是死亦波罗夷。若不即死后不因死偷兰遮。若比丘为人作坑。人死者波罗夷。非人死者偷兰遮。畜生死者亦偷兰遮。若为非人作坑。非人死者偷兰遮。人死者突吉罗。畜生堕死亦突吉罗。若比丘为畜生作坑。畜生堕死波夜提。若人堕死突吉罗。非人堕死亦突吉罗。若比丘不定为一事作。诸有来者皆令堕死。人死者波罗夷。非人死者偷兰遮。畜生死者波夜提。都无死者偷兰遮突吉罗。是名忧多。头多者有二种。一者地。二者木。地头多者。若比丘作坑。埋人脚踝。若埋膝若腰。若脐若腋至颈。如是埋已。令象蹴蹋。令马骆驼牛驴蹴蹋。若令毒蛇蜈蚣往啮。作如是念。令彼因死。彼因死者比丘得波罗夷。若不即死后因是死亦波罗夷。若不即死后不因是死偷兰遮。是名地头多。木头多者。有比丘穿木作孔。若桁人脚杻手枷颈。如是系已。令象马骆驼牛驴蹴蹋。若令毒蛇蜈蚣往啮。作如是念。令彼因死。彼因死者波罗夷。若不即死后因是死亦波罗夷。若不即死后不因死偷兰遮。是名木头多。弶者。有比丘知是人从此道来。于中依树依柱依石依壁。若依木段白腊段铅锡段。是中施弶。若心念若口说。为是人从此道来故作弶。令彼因死者比丘得波罗夷。若不即死后因是死亦波罗夷。若不即死后不因死偷兰遮。若为人作弶。人死者波罗夷。非人及畜生死者偷兰遮。若为非人作弶。非人死者偷兰遮。人及畜生死者突吉罗。若为畜生作弶。畜生死者波逸提。人及非人死者突吉罗。若不定为一事作。诸有来者皆令堕死。若人死者波罗夷。非人死者偷兰遮。畜生死者波夜提。都不死者偷兰遮突吉罗。是名为弶。罥者。有比丘知是人从此道来。若依树依柱依石依撅依壁。依木段白镴段铅锡段。是中施罥。若心念若口说。为是人从此道来故作罥是罥事成。彼因死者比丘得波罗夷若不即死后因是死亦波罗夷。若不即死后不因死偷兰遮。若比丘为人故作罥。人死者波罗夷。非人死者偷兰遮。畜生死者亦偷兰遮。为非人作罥。非人死者偷兰遮。人及畜生死者突吉罗。为畜生作罥。畜生堕死波夜提。人及非人死者突吉罗。若比丘不定为一事作罥。诸有来者皆令堕死者。若人死者波罗夷。非人死者偷兰遮。畜生死者波夜提。都无死者偷兰遮突吉罗。是名为罥杀拨者。若比丘知是人从此道来。若依树依柱依橛依石依壁。依木段白镴段铅锡段。是中施机拨。若心念若口说。为是人从此道来故作拨。是拨事成。彼因死者比丘得波罗夷。若不即死后因是死亦波罗夷。若不即死后不因死偷兰遮。若比丘为人故作拨。人死者波罗夷。非人及畜生死者皆偷兰遮。为非人作拨。非人死者偷兰遮。人及畜生死者突吉罗。为畜生作拨。畜生死者波夜提。人及非人死者突吉罗。若比丘不定为一事作拨。诸有来者皆令堕死。若人死者波罗夷。非人死者偷兰遮。畜生死者波夜提。都无死者偷兰遮突吉罗。是名为拨。毗陀罗者。有比丘以二十九日。求全身死人召鬼咒尸令起。水洗着衣着刀手中。若心念若口说。我为某故作毗陀罗。即读咒术。是名毗陀罗成。若所欲杀人。或入禅定。或入灭尽定。或入慈心三昧若有大力咒师护念救解。若有大力天神守护。则不能害。是作咒比丘。先办一羊。若得芭蕉树。若不得杀前人者。当杀是羊若杀是树。如是作者善。若不尔者还杀是比丘。是名毗陀罗。半毗陀罗者。有比丘二十九日作铁车。作铁车已作铁人。作铁人已召鬼。咒铁人令起。水洗着衣系刀着铁人手中。若心念若口说。我为某故。作是半毗陀罗读是咒术。是名半毗陀罗成。若所欲杀人。入禅定入灭尽定入慈心三昧。若有大力咒师护念救解。若有大力天神守护。则不能害。是作咒比丘。先办一羊若得芭蕉树。若不得杀前人者。当杀是羊若杀是树。如是作者善。若不尔者还杀是比丘。是名半毗陀罗。断命者。若比丘以其二十九日。牛屎涂地酒食着中。然火已寻着水中。心念口说读咒术言。如火水中灭。某甲人命亦如是灭。若火灭时彼命随灭。又如比丘二十九日。牛屎涂地酒食着中。画作所欲杀人形像。作是像已寻还拨灭。心念口说读咒术言。如是像灭彼命亦灭。若像灭时彼命随灭。有如比丘二十九日。牛屎涂地酒食着中。以针刺衣角头寻还拔出。心念口说读咒术言。如是针出彼命随出。是针出时彼命随出。是名断命。堕胎者。有比丘。与有胎女人吐下药灌鼻药。灌大小便处药。若针血脉。若出眼泪。若消血药。作是念。以是因缘令女人死。死者波罗夷。若不即死后因是死亦波罗夷。若不即死后不因是死偷兰遮。若是比丘为杀彼母故令堕胎。若母死者波罗夷。若胎死者偷兰遮。若俱死者波罗夷。俱不死者偷兰遮。若比丘为杀胎故作堕胎法。若胎死者波罗夷。母死者偷兰遮。俱死者波罗夷。俱不死者偷兰遮。是名堕胎。按腹者。有比丘。使怀妊女人重作或担重物。教使在车前走。若令上峻岸。作是念。以此因缘令女人死。死者波罗夷。若不即死后因是死亦波罗夷。若不即死后不因是死偷兰遮。若比丘为母故按腹。母死者波罗夷。胎死者偷兰遮。俱死者波罗夷。俱不死者偷兰遮。若为胎故按腹。胎死者波罗夷。母死者偷兰遮。俱死者波罗夷。俱不死者偷兰遮。是名按腹。推堕火中者。推木火中草火中牛屎火中[麩-夫+孚]糠火中。作如是心念。令彼因是死。彼因是死者波罗夷。若不即死后因是死者波罗夷。若不即死后不因死偷兰遮。是名堕火。推堕水中者。推大池中大海中深泉中陂水中大深井中深河渠中乃至面没水中。作如是念。令彼因是死。死者波罗夷。若不即死后因是死波罗夷若不即死后不因死偷兰遮。是名堕水。高上推堕下者。高山高岸殿舍墙壁深坑。作如是念。令彼因是死。死者波罗夷若不即死后因是死波罗夷。若不即死后不因死偷兰遮。遣令道中死者。有比丘知是道中有恶贼恶兽饥饿。遣令往至此恶道中。作如是念。令彼恶道中死。死者波罗夷。若不即死后因是死波罗夷。若不即死后不因死偷兰遮。是名遣令道中死。乃至胎中初得二根者。谓身根命根迦罗罗时。以杀心起方便欲令死。死者波罗夷。若不即死后因是死波罗夷。若不即死后不因死偷兰遮。佛语诸比丘。求刀有二种。一者自求。二者教人求。赞叹有三种。一者恶戒人。二者善戒人。三者病人。恶戒人者。杀牛杀羊养鸡养猪放鹰捕鱼猎师围兔偷贼魁脍咒龙守狱有比丘到恶戒人所。作如是言。汝等恶戒人。何以久作罪。不如早死。是人因是死者。比丘得波罗夷。若不即死者偷兰遮。若恶戒人作如是言。我不用是比丘语。不因死者比丘得偷兰遮若比丘赞叹是人令死。便心悔作是念言。我何以教是人死。还到语言。汝等恶人。或以善知识因缘故。亲近善人得听善法。能正思惟得离恶罪。汝勿自杀。若是人受比丘语。不因死者比丘得偷兰遮。善戒者。比丘比丘尼优婆塞优婆夷。有比丘到诸善人所。作如是言。汝持善戒。有福德人若死便受天福。汝等何不自夺命。是人因是自夺命者。比丘得波罗夷。若不自夺命偷兰遮。若善戒人作是念。我何以受是比丘语自夺命。不因死者偷兰遮。若比丘教他死已。心生悔言。我不是何以教此善人死。还往语言。汝善戒人。随寿命住福德益多。福德多故受福亦多。莫自夺命。不因死者偷兰遮。病者。四大增减受诸苦恼。比丘语是人言。汝云何能久忍是苦恼。何不自夺命。因是死者比丘得波罗夷。若不死者偷兰遮。若是病人作是念。我何缘受是比丘语自夺命。不因死者偷兰遮。若比丘心悔。我不是。何以教此病人自杀。还往语言。汝等病人。或得良药善看病人随病饮食。病可得差莫自夺命。病人不因死者偷兰遮。是名三种赞死。迦留陀夷恒出入一居士舍。晨朝时到着衣持钵往至其舍。是家妇有未断乳儿。持着床上以叠覆之舍去。迦留陀夷门下弹指。妇人出看言。大德入坐此床上。迦留陀夷不看。便坐儿上肠出大唤。妇言。此有小儿。比丘身重小儿即死。作是事已还到寺中。语诸比丘。我今日作如是事。诸比丘以是事白佛。佛知而故问。汝以何心作。答言。我不先看床上便坐。佛言无犯。从今当先看床榻坐处。然后可坐。若不先看者得突吉罗罪。又父子比丘共行憍萨罗国向舍卫城。至崄道中。儿语父言。疾行过此。父随儿语疾走乏死。儿即生疑。我将无犯波罗夷得逆罪耶。是事白佛。佛知故问。汝以何心语。儿比丘言。我见日暮恐不过崄道。以爱重心语令疾行。遂使乏死。佛言无犯。复有父子比丘共行憍萨罗国向舍卫城。至一聚落无有僧坊。儿问父言。今何处宿。父言聚落中宿。儿言。聚落中宿白衣何异。父即语儿。当何处宿。儿言。空地宿。父言。此有虎狼可畏。我眠汝觉。儿言尔。即便卧。父便鼾眠。虎闻鼾声。便来啮父头破大唤。儿即起看头破寻死。儿即生疑。我将无犯波罗夷得逆罪耶。是事白佛。佛言不犯。应大唤燃火怖之。有一比丘。日暮入崄道值贼。贼欲取比丘。比丘舍走。堕岸下织衣师上。织师即死。比丘心疑。我将无犯波罗夷。是事白佛。佛言。不犯波罗夷。从今日莫作如是身行。阿罗毗国僧坊中坏故。房舍比丘在屋上作。手中失墼堕木师上。木师即死。比丘心疑我将无犯波罗夷。是事白佛。佛言不犯。从今日当一心执作。复次阿罗毗国。比丘僧房中坏故。房舍比丘作时。见墼中有蝎。怖畏跳下堕木师上。木师即死。比丘心疑。我将无犯波罗夷。是事白佛。佛言不犯。从今莫起如是身行(杀事竟)

佛在维耶离国。夏安居时。与大比丘众俱。时世饥馑乞食难得。诸人妻子尚乏饮食。何况与乞人。佛以是因缘故集诸比丘。而告之曰。汝等当知。此间饥饿乞食难得。诸人妻子尚乏饮食遭诸苦恼。何况与人。汝等比丘。随所知识随诸亲里随所信人。往彼安居。莫在此间以饮食故受诸苦恼。时诸比丘随所知识各往安居。有诸比丘。往憍萨罗国一处安居。复有比丘。到婆求摩河边聚落安居。是聚落中多诸贵人。奴婢财宝谷米丰饶种种成就。时河上安居比丘作是念。今世饥饿乞食难得。诸人妻子尚乏饮食。况与乞人。是聚落中多富贵家。谷米丰饶种种成就。我等当到是诸家共相赞叹作是言。居士当知。汝等得大善利。诸大比丘僧依汝聚落中安居故。今此众中某是阿罗汉。某是向阿罗汉。某是阿那含。某是向阿那含。某是斯陀含。某是向斯陀含。某是须陀洹。某是向须陀洹。某得初禅二禅三禅四禅。某得无量慈心无量悲心无量喜心无量舍心。某得无量空处识处无所有处非有想非无想处。某得不净观。某得阿那般那念。诸比丘作是念已。即入聚落到富贵家共相赞叹。汝等当知得大善利。福田众僧依汝聚落安居。今此众中。某是阿罗汉。我亦是阿罗汉。某向阿罗汉。我亦向阿罗汉。某是阿那含。我亦是阿那含。某向阿那含。我亦向阿那含。某得斯陀含。我亦得斯陀含。某向斯陀含。我亦向斯陀含。某得须陀洹。我亦得须陀洹。某向须陀洹。我亦向须陀洹。某得初禅二禅三禅四禅无量慈心悲心喜心舍心空处识处无所有处非有想非无想处不净观阿那般那念。我亦得初禅乃至阿那般那念。彼诸居士即生清净信心。作如是念。我等得大善利。有大福田众僧。依我等聚落安居。某得阿罗汉。某向阿罗汉。某得阿那含。某向阿那含。某得斯陀含。某向斯陀含。某得须陀洹。某向须陀洹。某得初禅二禅三禅四禅无量慈心悲喜舍心空处识处无所有处非有想非无想处不净观阿那般那念。是居士得是信心已。今饥俭时乞食难得。乃能如先丰乐易得时。与众僧作前食后食怛钵那。时婆求摩河边安居比丘。啖是饮食身体充满。得色得力肥盛润泽。诸佛在世法。岁二时大会。春末后月夏末后月。春末月者。诸方国土处处诸比丘来作是念。佛所说法我等当安居时修习得安乐住。是名初大会。夏末月者。诸比丘处处夏三月安居竟。作衣毕持衣钵诣佛所作是念。我等久不见佛久不见世尊。是第二大会

尔时憍萨罗国安居比丘。过夏三月作衣毕。持衣钵游行到维耶离国。诸佛常法。有共佛安居比丘。有客比丘来。当共往迎一心问讯。与担衣钵开房舍示卧具处。作是言。此是汝等房舍。粗陛绳床细陛绳床被褥枕席随上座次第住。尔时维耶离比丘。遥见憍萨罗比丘来。便共出迎一心问讯。与担衣钵开房舍示卧具处。作如是言。此是汝等房舍。粗陛绳床细陛绳床被褥枕席随上座次第住问讯言。汝等忍足安乐住乞食不乏道路不疲耶。憍萨罗比丘答言。我等忍足安乐住道路不疲。但乞食难得。维耶离比丘言。汝实忍足安乐住道路不疲。乞食难得故。汝等羸瘦颜色憔悴。尔时婆求摩河上比丘安居竟。作衣毕游行到维耶离。时维耶离比丘。遥见婆求摩河比丘来。皆共出迎一心问讯。与担衣钵开房舍示卧具处。作如是言。此是汝等房舍。粗陛绳床细陛绳床被褥枕席随上座次第住问讯言。汝等忍足安乐住乞食不乏道路不疲耶。婆求摩河上比丘答言。我等忍足安乐住乞食不乏。但道路疲极。维耶离比丘言。汝实忍足安乐住道路疲极乞食不乏。何以故汝等肥盛颜色和悦。时维耶离比丘渐渐急问。汝等长老今世饥俭乞食难得。诸人妻子尚乏饮食。况能与人。汝等何因缘故。安居时气力肥盛颜色和悦乞食不难。时婆求摩河比丘广说如上因缘。维耶离比丘问。诸长老。汝等所可赞叹。实有是功德不。答言实无。维耶离比丘。以种种因缘呵责婆求摩河比丘。汝所作事。非沙门法不随顺道。无欲乐心作不净行。出家之人所不应作。汝不知佛世尊以种种因缘呵责妄语。种种因缘赞叹不妄语。佛常说法教人离妄语。汝等尚不应生心作妄语想。何况为饮食故。空无过人圣法。自说言得。如是种种因缘呵已。向佛广说。佛以是事集比丘僧。知而故问婆求摩河比丘。汝等实作是事不。答言。实作世尊。佛以种种因缘呵责婆求摩河比丘。汝等所作事。非沙门法不随顺道。无欲乐心作不净行。出家之人所不应作。汝痴人不知。我以种种因缘呵责妄语。种种因缘赞叹不妄语。我常说法教人离妄语。汝尚不应生心作妄语想。何况为饮食故。空无过人法。自说言得。佛如是种种因缘呵已。语诸比丘。世间有三种大贼。一者作百人主故在百人前百人恭敬围绕。二百三百四百五百人主故在五百人前五百人恭敬围绕。入城聚落穿踰墙壁断道偷夺破城杀人是名初世间大贼。二者有比丘。用四方众僧园林中竹木根茎枝叶花果财物饮食。卖以自活若与知识白衣。是名第二世间大贼。三者有比丘。为饮食供养故。空无过人圣法。故作妄语自说言得。若与百人恭敬围绕。至五百人恭敬围绕。入城聚落受他供养前食后食怛钵那。是名第三世间大贼。是中百人贼主。在百人前恭敬围绕。二百三百四百五百人主。在五百人前恭敬围绕。入城聚落穿踰墙壁断道偷夺破城杀人。此名小贼。若有比丘。用四方众僧园林中竹木根茎枝叶花果财物饮食。卖以自活若与知识白衣。是亦小贼。佛言。是第三贼。于天人世间魔界梵世沙门婆罗门天人众中。最是大贼。谓为饮食故。空无过人法。故作妄语自说言得。若与百人至五百人恭敬围绕。入城聚落受他供养前食后食怛钵那。是名大贼。佛说偈言

  比丘未得道　　自说言得道
  天人中大贼　　极恶破戒人
  是痴人身坏　　当堕地狱中

佛种种因缘呵责已语诸比丘。以十利故与诸比丘结戒。从今是戒应如是说。若比丘不知不见空无过人法。自言我得如是知如是见。是比丘后时若问若不问。贪着利养故。不知言知不见言见。空诳妄语。是比丘波罗夷不共住

佛在舍卫国。时憍萨罗国有空闲处。诸比丘住其中。诸比丘因别相观得定故。贪欲嗔恚不起。便作是念。我已得道所作已办。是诸比丘到佛所自言。我是阿罗汉。生分已尽更不受身。作是语已。后近聚落僧坊中住。数见女人故。贪欲嗔恚便起。是诸比丘作是言。我曹辛苦痛恼。本在空闲处时。因别相观得定故。贪欲嗔恚不起。便作是念。我已得道所作已办。即到佛所自言。我是阿罗汉。我生已尽更不受身。今近聚落住。数见女人故贪欲嗔恚便生。我曹失比丘法烧比丘法。我曹空无过人法自说言得。是诸比丘语余比丘。余比丘闻已向佛广说。佛以是事因缘故集比丘僧。以种种因缘赞戒赞持戒。赞戒赞持戒已。语诸比丘。从今是戒应如是说。若比丘不知不见空无过人法。自言我得如是知如是见。后时或问或不问。欲出罪故便言。我不知言知不见言见空诳妄语。除增上慢。是比丘波罗夷不共住。不知者。过人法不知不得不见不触不证。不见者。不见苦谛不见集谛灭谛道谛。是中犯者。若比丘说我阿罗汉。若不实。犯波罗夷向阿罗汉不实犯波罗夷。若阿那含不实犯波罗夷。向阿那含不实犯波罗夷。若斯陀含不实犯波罗夷。若向斯陀含不实犯波罗夷。若须陀洹不实犯波罗夷。若向须陀洹不实犯波罗夷。若比丘言。我得初禅二禅三禅四禅。得无量慈心悲心喜心舍心空处识处无所有处非有想非无想处不净观。得阿那般那念。不实犯波罗夷。乃至说我善持戒人淫欲不起。若不实者偷兰遮。若比丘作是言。诸天来至我所。龙夜叉毗陀罗鬼饿鬼鸠槃茶鬼毗舍遮鬼罗刹鬼来至我所。彼问我答我问彼答。若是事不实者。比丘犯波罗夷。乃至旋风土鬼来至我所。若不实者偷兰遮。一时长老大目揵连。在耆阇崛山入无所有空定。善取入定相。不善取出定相。从三昧起。闻阿修罗城中伎乐音声已。还疾入定。作如是念。我在定中闻阿修罗城中伎乐音声。从三昧起语诸比丘。我在耆阇崛山入无所有处无色定。闻阿修罗城中伎乐音声。诸比丘语目连。何有是处。入无色定当见色闻声。何以故。若入无色定。破坏色相舍离声相。汝空无过人法故作妄语。汝目连应摈治驱遣。是事白佛。佛语诸比丘。汝等莫说目连犯罪。何以故。目连但见前事不见后事。如来亦见前亦见后。是目连在耆阇崛山。入无所有处无色定。善取入定相。不善取出定相。从定起闻阿修罗城中伎乐音声。闻已还疾入定。便自谓。我入定闻声。若入无色定。若见色若闻声无有是处。何以故。是人破坏色相舍离声相故。若目连空无过人法故妄语者亦无是处。是目连随心想说无罪。有一时诸比丘问长老目连。多浮陀河水从何处来。目连答言。此水从阿耨达池中来。诸比丘言。阿耨达池其水甘美有八功德。此水沸热碱苦何有此事。汝目连。汝空无过人法故作妄语。汝目连应摈治驱遣。是事白佛。佛语诸比丘。汝等莫说目连是事犯罪。何以故。阿耨达池去此极远。是水本有八功德甘美。经历五百小地狱上来。是故碱热。汝等若问目连是水何故碱热。能随想答。目连实语无犯。有一时大目揵连入定。见跋耆诸夜叉与摩竭陀夜叉共斗。破摩竭陀夜叉。从定起已语诸比丘。跋耆人当破摩竭陀人。后阿阇世王。善将兵众破跋耆人。诸比丘语大目揵连。汝先言跋耆人当破摩竭陀人。今摩竭陀人破跋耆人。汝空无过人法故作妄语。汝目连应摈治驱遣。是事白佛。佛语诸比丘。莫说目连是事犯罪。何以故。目连见前不见后。如来见前亦见后。是跋耆夜叉与摩竭陀夜叉共斗得胜。时跋耆人亦破摩竭陀人。后阿阇世王更集兵众共战得胜。是目连随心想说无犯。目连又后入定。见摩竭陀夜叉。与跋耆夜叉共斗得胜。目连从三昧起。语诸比丘。摩竭陀人当破跋耆人。后共斗时跋耆人得胜。诸比丘语目连。汝先言摩竭陀人当破跋耆人。今跋耆人更破摩竭陀人。汝空无过人法故作妄语。汝目连应摈治驱遣。是事问佛。佛语诸比丘。莫说目连是事犯罪。何以故。目连见前不见后。如来见前亦见后。是摩竭陀夜叉与跋耆夜叉共斗得胜。时摩竭陀人亦胜跋耆人。后跋耆人更集兵众共斗得胜。目连随心想说无犯。有一时目连。晨朝时到着衣持钵入居士舍。与敷座处共相问讯。居士言。大德目连。是妊身妇人为生男女。目连答言。生男。语已便去。复有一梵志来入舍。居士问言。此妊身妇人为生男女。答言。生女。后实生女。诸比丘语目连。汝先说居士妇生男。今乃生女。汝空无过人法故作妄语。汝目连应摈治驱遣。是事白佛。佛语诸比丘。莫说目连是事犯罪。何以故。目连见前不见后。如来见前亦见后。是时此女是男。后转为女。目连随心想说无犯。后复相他生女亦如是。尔时大旱。目连入定见。却后七日天当大雨沟坑满溢。诸城邑人皆闻是语。咸大欢喜。国中人民皆舍众务覆屋盖藏。各各屈指捉筹数日。到第七日尚无雨气。何况大雨。诸比丘语目连。汝言七日大雨沟坑满溢。今无雨气何况有雨。汝空无过人法故作妄语。汝目连应摈治驱遣。是事白佛。佛语诸比丘。莫说目连是事犯罪。何以故。目连见前不见后。如来亦见前亦见后。是七日时实有大雨。有罗睺阿修罗王。以手接去置大海中。目连随心想说无犯。又一时长老莎伽陀语诸比丘。我入禅定。能令阿鼻地狱上至阿迦腻吒天满其中火。诸比丘言。何有是处。声闻弟子能作大火从阿鼻地狱极至梵世。汝空无过人法故作妄语。汝莎伽陀应摈治驱遣。是事白佛。佛语诸比丘。莫说莎伽陀是事犯罪。何以故。若比丘依初禅修如意足得神通力。从阿鼻地狱上至阿迦腻吒天自在能满中火。若依初禅二禅三禅四禅亦如是。是莎伽陀依止四禅。善修如意足得大神通。若念从阿鼻地狱上至阿迦腻吒天自在随意能满中火。是莎伽陀实语无犯。又一时长老输毗陀语诸比丘。我一念中能识宿命五百劫事。诸比丘言。何有是处。声闻弟子在一念中极多能知一世汝空无过人法故作妄语。汝输毗陀应摈治驱遣。是事白佛。佛语诸比丘。莫说输毗陀是事犯罪。何以故。是人前身从无想天命终来生此间。无想天上受五百劫。是故自说。我一念中能知五百劫事。是输毗陀随心想说无犯(四波罗夷竟)

十诵律卷第二十诵律卷第三(初诵之三)

        后秦北印度三藏弗若多罗译

    明十三僧残法之初

佛在舍卫国。尔时长老迦留陀夷。有别房舍。别房舍中有好床榻。被褥敷好独坐床。扫洒内外皆悉净洁。以净水瓶盛满冷水。常用水瓶盛满冷水。是迦留陀夷。淫欲发时便自出精。离急热故得安快住。后时迦留陀夷知识比丘来。共相问讯在一面坐。语迦留陀夷。汝忍不足不。安乐住不。不乏不。答言。忍足安乐住不乏。问曰。云何忍足安乐住不乏。答言。诸长老。我有别房好床被褥。净水瓶常用水瓶。皆满冷水。扫洒内外皆悉净洁。敷好独坐床。淫欲发时便自出精。离急热故得安快住。诸长老。以是因缘故。忍足安乐住不乏。诸比丘言。汝非忍非足。实苦恼行以为安乐。汝所作事非沙门法。不随顺道不清净行。出家之人所不应作。汝不知佛世尊以种种因缘呵欲欲想。种种因缘赞叹离欲除灭欲热。佛常说法教人离欲。汝尚不应生心。何况乃作起欲恚痴结缚根本不净恶业。诸比丘种种呵已向佛广说。佛以是事集比丘僧。知而故问迦留陀夷。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。汝所作事非沙门法。不随顺道不清净行。出家之人所不应作。汝痴人。汝不知我以种种因缘呵欲欲想。种种因缘赞叹离欲除灭欲热。我常说法教人离欲。汝尚不应生心。何况乃作起欲恚痴结缚根本不净恶业。汝痴人。以此手受他信施供养。云何复以此手作不净行。佛如是种种呵已语诸比丘。以十利故与诸比丘结戒。从今是戒应如是说。若比丘故出精僧伽婆尸沙。佛结是戒已。诸比丘梦中精出心生疑悔。往阿难所头面礼足一面坐已语阿难言。世尊结戒出精者僧伽婆尸沙。今诸比丘梦中。出精。生心疑悔。愿为我等问佛是事。阿难默然受比丘语。诸比丘知阿难默然受已。从坐起头面礼足还去。不久阿难往诣佛所。头面礼足在一面立。白佛言。世尊。世尊为诸比丘结戒。出精者僧伽婆尸沙。佛虽如是结戒。今诸比丘梦中出精。心生疑悔。阿难问佛。梦中有心想不。佛言。有心想而不作。佛以是事集比丘僧。种种因缘赞戒赞持戒。赞戒赞持戒已语诸比丘。从今是戒应如是说。若比丘故出精除梦中。僧伽婆尸沙。僧伽婆尸沙者。是罪属僧。僧中有残。因众僧前悔过得灭。是名僧伽婆尸沙。是中犯者有三种。一者发心欲出。二者身动。三者精出。复有三种。一者为受乐。二者治病。三者为自试。比丘以内受色。为受乐故。发心身动精出。僧伽婆尸沙。为治病故。为试看故。以内受色。发心身动精出。僧伽婆尸沙。比丘以外不受色。为受乐故。为治病故。为试看故。发心身动精出。僧伽婆尸沙。复有四种。一者虚空中动。二者发心。三者身动。四者精出。比丘以内受色。为受乐故虚空中动。发心身动精出。僧伽婆尸沙。为治病故。为试看故。虚空中动发心身动精出僧伽婆尸沙。复有五种。若比丘搔小便处。捺小便处。发心身动精出僧伽婆尸沙。比丘以内受色。为受乐故。为治病故。为试看故。搔捺小便处。发心身动精出僧伽婆尸沙。若比丘以外不受色。为受乐故。为治病故。为试看故。搔捺小便处。发心身动精出僧伽婆尸沙。是中精有五种。一者青。二者黄。三者赤。四者白。五者薄。青者。转轮王及转轮王受职太子。黄者。转轮王其余诸子。赤者。转轮王最上大臣。白者。年已成人。薄者。年未成人。若人青精出者。不出黄赤白薄。但能出青。若人精出黄者。不出赤白薄青。但能出黄。若人赤精出者。不出白薄青黄。但能出赤。若人出白精者。不出薄青黄赤。但能出白。若人出薄精者。不出青黄赤白。但能出薄。若比丘为出青精故。搔捺小便处。发心身动精出僧伽婆尸沙。若比丘为出黄赤白薄精故。搔捺小便处。发心身动精出僧伽婆尸沙。若一人一时。出五种精者。无有是事。或有人。多行淫故。有种种精出。或担重故。远骑乘故。筋节断解故。有种种精出。若比丘起欲想欲欲欲觉欲热。不发心欲出身不动。精自出者无犯。若比丘男根上。有疮疱癣疥痒。为治是病故。搔捺精出无犯。若比丘向火炙男根。痒摩触精出无犯。若比丘行时两髀摩触。或衣触。或骑乘。或载车。身动精出不犯。若比丘见好色故精出不犯。若不见形忆想故精出不犯(一事竟)

佛在舍卫国。尔时长老迦留陀夷。晨朝时到着衣持钵入城乞食。食已还房。持户钩在门间立。作如是念。若有女人欲来入僧坊中看房舍者。我当示诸房处。时迦留陀夷遥见众女人。便言。姊妹来。我当示汝诸房舍处。少多示已。将至自房摩触其身。是众女中有喜者默然。有不喜者。即出房外语诸比丘。大德法应尔耶。此安隐处更有恐怖诸比丘言。云何安隐处更有恐怖。众女人广说上事。诸比丘言。如汝所说。安隐处更有恐怖。时诸比丘种种因缘为众女人说法示教利喜。头面礼足还去。不久诸比丘诣佛所。头面礼足在一面坐。向佛广说。佛以是事集比丘僧。知而故问迦留陀夷。汝实作是事不。答言。实作世尊。佛以种种因缘呵责迦留陀夷。汝所作事非沙门法。不随顺道不清净行。出家之人所不应作。汝痴人不知。我以种种因缘呵欲欲想。种种因缘称赞离欲除灭欲想。我常说法教人离欲。汝尚不应生心。何况乃作起欲恚痴结缚根本不净恶业。佛种种因缘呵已语诸比丘。以十利故与诸比丘结戒。从今是戒应如是说。若比丘欲盛变心故触女身。若捉手臂头发。一一身分上下摩触。僧伽婆尸沙。欲盛者。即名变心。亦名贪心染心系心。或有变心。非欲盛心。亦非贪心染心系心。如狂痴人乱心人病坏心人。是名变心。非欲盛心染心系心。女人者。有大有中有小。童女非童女堪作淫欲。触身者。共在一处。手者。从腕及指。臂者。从腕至肩。发者。头发若劫贝毳纳头髾。一一身分者。眼耳鼻等。是中犯者有九种。上摩下摩若抱若捉若牵若推若举若下若摩大小便处。若比丘欲盛变心上下摩触无衣女人头僧伽婆尸沙。若摩面咽胸腹肋脊脐腰大小便处髀膝[跳-兆+專]僧伽婆尸沙。如是抱捉牵推举下摩触大小便处亦如是。若比丘从地。举无衣女人。着土埵上。土埵上着踞床上。踞床上着独坐床上。独坐床上着大床上。大床上着舆上。舆上着车上。车上着马上。马上着象上。象上着堂上。堂上乃至从小下处着小高处。僧伽婆尸沙。若比丘欲盛变心。从堂上举无衣女人着象上。象上着马上。马上着车上。车上着舆上。舆上着大床上。大床上着独坐床上。独坐床上着踞床上。踞床上着土埵上。土埵上着地。乃至小高处着小下处。僧伽婆尸沙。若比丘欲盛变心。上下摩触有衣女人头偷兰遮。若摩面咽胸肩腹肋脊脐腰大小便处髀膝[跳-兆+專]偷兰遮。如是抱捉牵推举下摩大小便处偷兰遮。若比丘欲盛变心。从地举有衣女人着土埵上。乃至小高处举着小下处偷兰遮。若女人欲盛变心。上下摩触无衣比丘头。比丘有欲心。身动受细滑。僧伽婆尸沙。若摩面咽胸腹肋脊脐腰大小便处髀膝[跳-兆+專]。比丘有欲心身动受细滑。僧伽婆尸沙如是抱捉牵推举下摩大小便处。比丘有欲心身动受细滑。僧伽婆尸沙。若女人欲盛变心。从地举无衣比丘着土埵上。乃至小下处举着小高处。比丘有欲心身动受是细滑。僧伽婆尸沙。若女人淫欲盛变心。从堂上举无衣比丘着象上。乃至小高处举着小下处。比丘有欲心身动受细滑。僧伽婆尸沙。若女人欲盛变心。上下摩触有衣比丘头。比丘有欲心身动受细滑偷兰遮。若摩面咽胸脊腹肋脐腰大小便处髀膝[跳-兆+專]。比丘有欲心身动受细滑偷兰遮。如是抱捉牵推举下摩大小便处。比丘有欲心身动受细滑偷兰遮。若女人欲盛变心。从地举有衣比丘着土埵上。乃至小下处举着小高处。比丘有欲心身动受细滑偷兰遮。若女人欲盛变心。从堂上举有衣比丘着象上乃至小高处着小下处。比丘有欲心身动受细滑偷兰遮。若一比丘摩一女人。僧伽婆尸沙。若一比丘摩二三四女。僧伽婆尸沙。若二比丘摩二三四一女人。僧伽婆尸沙。若三比丘。摩三四一二女人。僧伽婆尸沙。若四比丘。摩四一二三女人。僧伽婆尸沙。女人所。女人想摩。僧伽婆尸沙。女人所。男想黄门想二根想摩。僧伽婆尸沙。男所。男想黄门想二根想女人想摩。偷兰遮。黄门所。黄门想二根想女想男想摩。偷兰遮。二根所。二根想女想男想黄门想摩。偷兰遮。若是事人女边。僧伽婆尸沙。即是事非人女边偷兰遮。若是事人女边偷兰遮。即是事非人女边突吉罗。若母想姊妹想女想摩触女身不犯。若救火难水难刀难。若堕高处恶虫难恶鬼难不犯。若无染心触不犯(二事竟)

佛在舍卫国。尔时长老迦留陀夷。晨朝时到着衣持钵入城乞食。食已还房。取户钩在门间立。作如是念。若有女人欲来看者。我当示诸房处。尔时迦留陀夷遥见诸女。便言。姊妹来。我当示汝诸房舍处。少多示已。将至自房作不净恶语是诸女中有喜者默然。不喜者出外语诸比丘。大德法应尔耶。此安隐处更有恐怖。诸比丘言。云何安隐处更有恐怖。诸女广说上事。诸比丘言。如汝所说。时诸比丘以种种因缘。为众女说法示教利喜。头面礼足还去。不久诸比丘以是因缘向佛广说。佛以是事集比丘僧。知而故问迦留陀夷。汝实作是事不。答言。实作世尊。佛以种种因缘呵责迦留陀夷。汝所作事非沙门法。不随顺道不清净行。出家之人所不应作。汝痴人不知。我以种种因缘呵责诸欲欲想。种种因缘称赞离欲除灭欲热。我常说法教人离欲。汝尚不应生心。何况乃至起欲恚痴结缚根本不净恶业。佛种种因缘呵已语诸比丘。以十利故与诸比丘结戒。从今是戒应如是说。若比丘欲盛变心在女人前。作不净恶语随淫欲法说者。僧伽婆尸沙。不净恶语者。随波罗夷随僧伽婆尸沙事。虽一切罪皆名为恶。但此是重罪因缘故。名为恶语。随淫欲法者。二身共会。说者。如年少男女。淫欲盛故。具说恶语。是中犯者有九种。赞毁乞愿问反问办教骂。赞者。比丘在女人前赞叹三疮门。形色端正不大不小不粗不细乃至百语。一一语中僧伽婆尸沙。毁者。比丘在女人前毁呰三疮门。形色不好或大或小或粗或细乃至百语。一一语中僧伽婆尸沙。乞者。比丘在女人前乞言。汝三疮门中随意与我。我于三疮门中随汝意作。乃至百语。一一语中僧伽婆尸沙。愿者。比丘在女人前愿言。若人得汝三疮门者。是福德乐人。汝能三疮门中随汝意作。乃至百语。一一语中僧伽婆尸沙。问者。比丘问女人言。汝夫三疮门中几种作几时作。乃至百语。一一语中僧伽婆尸沙。反问者。比丘问女人言。汝夫于三疮门中不如是作耶。乃至百语。一一语中僧伽婆尸沙。办者。比丘在女人前言。我办酒食槃案华香璎珞末香涂香敷好床褥。汝若来者。我于三疮门中随汝意作。乃至百语。一一语中僧伽婆尸沙。教者。比丘教女人言。汝三疮门中随意与男子者。则为男子所爱。乃至百语。一一语中僧伽婆尸沙。骂者。比丘骂女人有二种。粗骂细骂乃至百语。一一语中僧伽婆尸沙。若女人在比丘前赞三疮门。形色端正乃至百语。是中比丘随顺其心少多语出。一一语中僧伽婆尸沙。若女人在比丘前毁呰三疮门。形色不好乃至百语。是中比丘随顺其心少多语出。一一语中僧伽婆尸沙。若女人在比丘前乞。三疮门中随我意作。我随汝意与。乃至百语。是中比丘随顺其心。少多语出。一一语中僧伽婆尸沙。若女人在比丘前愿言。若人得我三疮门者。是福德乐人。我能随意与乃至百语。是中比丘随顺其心少多语出。一一语中僧伽婆尸沙。若女人在比丘前问言。汝于三疮门中。能几种作几时作。乃至百语。是中比丘随顺其心少多语出。一一语中僧伽婆尸沙。若女人在比丘前反问言。汝于三疮门中不如是作耶。乃至百语。是中比丘随顺其心少多语出。一一语中僧伽婆尸沙。若女人在比丘前言。我办酒食盘案香华璎珞末香涂香敷好床褥。汝能来者。三疮门中随汝意与。乃至百语。是中比丘随顺其心少多语出。一一语中僧伽婆尸沙。若女人在比丘前教言。汝能三疮门中随意作者。则为女人所爱。乃至百语。是中比丘随顺其心少多语出。一一语中僧伽婆尸沙。若女人在比丘前骂是比丘。粗骂细骂乃至百语。是中比丘随顺其心少多语出。一一语中僧伽婆尸沙。若一比丘向一女人。不净恶语一僧伽婆尸沙。若一比丘向二三四女人。不净恶语僧伽婆尸沙。若二比丘向二三四一女人。不净恶语僧伽婆尸沙。若三比丘向三四一二女人。不净恶语僧伽婆尸沙。若四比丘向四一二三女人。不净恶语僧伽婆尸沙。若比丘女人所女人想。不净恶语僧伽婆尸沙。女人所。男想黄门想二根想。不净恶语僧伽婆尸沙。男所男想黄门想二根想女想。不净恶语偷兰遮。黄门所。黄门想二根想女想男想不净恶语偷兰遮。二根所男想女想黄门想二根想不净恶语偷兰遮。若是事人女边僧伽婆尸沙。即是事非人女边偷兰遮。若是事人女边偷兰遮。即是事非人女边突吉罗(三事竟)

佛在舍卫国。尔时长老迦留陀夷。晨朝时到着衣持钵入城乞食。食已还自房。持户钩在门间立。作如是念。若有女人欲来僧坊看房舍者。我当示诸房处。尔时迦留陀夷遥见众女来。便言。姊妹我当示汝诸房舍处。少多示已。将至自房。向女人赞叹淫欲以身供养。是众女中有喜者默然。不喜者出外语诸比丘。大德法应尔耶。此安隐处更有恐怖。诸比丘言。云何安隐处更有恐怖。诸女人广说上事。诸比丘言如汝所说。时诸比丘以种种因缘。与众女说法示教利喜。头面礼足还去。不久诸比丘以是因缘向佛广说。佛以是事集比丘僧。知而故问迦留陀夷。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。汝所作事非沙门法。不随顺道不清净行。出家之人所不应作。汝痴人不知。我以种种因缘呵欲欲想。种种因缘赞叹离欲除灭欲热。我常说法教人离欲。汝尚不应生心。何况乃作起欲恚痴结缚根本不净恶业。佛种种因缘呵已语诸比丘。以十利故与诸比丘结戒。从今是戒应如是说。若比丘欲盛变心在女人前赞叹以身供养作如是言。汝能以身供养我等持戒行善梵行人者。诸供养中第一供养。僧伽婆尸沙。以身供养者。比丘语女言。汝能以身作淫欲供养者。诸供养中第一供养。持戒者。大戒律法尽能受持。行善者。正见忍辱故。梵行者。二身不共会故。是中犯者有九种。谓上大胜巧善妙福好快。上者。若比丘语女人言。汝能以身作淫欲供养我等持戒人者。诸供养中是上供养。僧伽婆尸沙。若语女人言。汝能以身作淫欲供养行善人者。是上供养。僧伽婆尸沙。若语女人言。汝能以身作淫欲供养梵行人者。是上供养。僧伽婆尸沙。若语女人言。汝能以身供养持戒行善人。持戒梵行人。行善梵行人。持戒行善梵行人者。是上供养僧伽婆尸沙。若比丘语女人言。汝能以身作淫欲供养不大持戒人者。是上供养僧伽婆尸沙。若语女人言。汝能以身作淫欲供养不大行善人者。是上供养僧伽婆尸沙。若语女人言。汝能以身作淫欲供养不大修梵行人。是上供养僧伽婆尸沙。若比丘语女人言。汝能以身作淫欲供养不大持戒行善人。不大持戒梵行人。不大行善梵行人。不大持戒行善梵行人者。是上供养僧伽婆尸沙。若比丘语女人言。不以自身作淫欲供养我等持戒人者。是上供养偷兰遮。若语女人言。不以自身作淫欲供养行善人者。是上供养偷兰遮。若语女人言。不以自身作淫欲供养梵行人者。是上供养偷兰遮。若语女人言。不以自身作淫欲供养持戒行善人。持戒梵行人。行善梵行人。持戒行善梵行人者。是上供养偷兰遮。若语女人言。不以自身作淫欲供养不大持戒人者。是上供养偷兰遮。若比丘语女人言。不以自身作淫欲供养不大行善人者。是上供养偷兰遮。若语女人言。不以自身作淫欲供养不大修梵行人者。是上供养偷兰遮。若比丘语女人言。不以自身作淫欲供养不大持戒行善人。不大持戒梵行人。不大行善梵行人。不大持戒行善梵行人者。是上供养偷兰遮。如是大胜巧善妙福好快供养亦如是。若比丘语女人言。汝能以身作淫欲供养持戒人者。是上大供养僧伽婆尸沙。若言上胜上巧上善上妙上福上好上快供养。僧伽婆尸沙。若言大胜大巧大善大妙大福大好大快供养僧伽婆尸沙。若言胜巧胜善胜妙胜福胜好胜快供养。僧伽婆尸沙。若言巧善巧妙巧福巧好巧快供养。僧伽婆尸沙。若言善妙善福善好善快供养。僧伽婆尸沙。若言妙福妙好妙快供养。僧伽婆尸沙。若言福好福快供养僧伽婆尸沙。若言好快供养。僧伽婆尸沙。若言上大胜上大巧上大善上大妙上大福上大好上大快供养僧伽婆尸沙。若言大胜巧大胜善大胜妙大胜福大胜好大胜快供养。僧伽婆尸沙。若言胜巧善胜巧妙胜巧福胜巧好胜巧快供养。僧伽婆尸沙。若言巧善妙巧善福巧善好巧善快供养。僧伽婆尸沙。若言善妙福善妙好善妙快供。僧伽婆尸沙。若言妙福好妙福快供养养僧伽婆尸沙。若言福好快供养。僧伽婆尸沙。若言上大胜巧上大胜善上大胜妙上大胜福上大胜好上大胜快供养。僧伽婆尸沙。若言上大胜巧善上大胜巧妙上大胜巧福上大胜巧好上大胜巧快供养。僧伽婆尸沙。若言上大胜巧善妙上大胜巧善福上大胜巧善好上大胜巧善快供养。僧伽婆尸沙。若言上大胜巧善妙福上大胜巧善妙好上大胜巧善妙快供养。僧伽婆尸沙。若言上大胜巧善妙福好上大胜巧善妙福快供养。僧伽婆尸沙。若比丘语女人言。若以饮食衣被卧具华香璎珞。持用供养是上供养。能以身供养者过是上中上。僧伽婆尸沙。如是大胜巧善妙福好快亦如是。若比丘语女人言。以饮食衣被卧具华香璎珞。持用供养是上中上。能以身供养者过是上中上。僧伽婆尸沙。如是大胜巧善妙福好快亦如是。若一比丘向一女人。赞叹以身供养一比丘僧伽婆尸沙。若一比丘向二三四女人。赞叹以身供养。僧伽婆尸沙。若二比丘向二三四一女人。赞叹以身供养。僧伽婆尸沙。若三比丘向三四一二女人。赞叹以身供养。僧伽婆尸沙。若四比丘向四一二三女人。赞叹以身供养。僧伽婆尸沙。若比丘女人所。女想赞叹。僧伽婆尸沙。女人所。男想黄门想二根想赞叹。僧伽婆尸沙。男所。男想黄门想二根想女想赞叹。偷兰遮。黄门所。黄门想二根想女想男想赞叹。偷兰遮。二根所。二根想女想男想黄门想赞叹。偷兰遮。若是事人女边。僧伽婆尸沙。即是事非人女边。偷兰遮。若是事人女边。偷兰遮。即是事非人女边。突吉罗(四事竟)

佛在舍卫国。尔时有鹿子长者儿。名曰迦罗。聪智利根。众人所问常为断疑。他事匆务。若人有女姊妹。有来求者。往问迦罗。某求我女若姊妹。是人为好不好。应与不应与。能与妇儿衣食不。若迦罗言。不好不能与妇儿衣食。汝莫与女。即便不与。若迦罗言。好能与妇儿衣食。汝当与女。即随语与。若人自为求妇。若为儿求。往问迦罗。我求某女。是女好不。能成家事。我为可取不。若迦罗言。不好不能成家事。汝莫取之。即随语不取。若迦罗言。好能成家事。汝可取之。即随语取。若诸人女姊妹。堕贫穷勤苦重作恶处。衣食不充。便作是言。如我女姊妹所受苦恼。诸问迦罗信受语者。所受苦恼当复剧是。由我等信受迦罗语故。令女姊妹堕是恶处。贫穷勤苦衣食不充。若诸人女姊妹。堕好处富乐衣食充足。便作是念。如我女姊妹所受富乐。诸问迦罗信受语者。所受富乐当复胜是。我等信受迦罗语故。令女姊妹得好处。衣食充足。尔时迦罗。或得称誉。或得毁呰。是人后时以信出家。剃除须发被着袈裟。作比丘已。犹如本法他事匆务。若人有女姊妹。有来求者。往问迦罗比丘。某求我女姊妹。是人为好不好。应与不应与。若迦罗言。是人不好。即便不与。若迦罗言好。即随语与。若人或为己为儿求妇。往问迦罗。我求某女。若姊妹好不好。能办家事不。若迦罗言好。便随语取。若言不好。即便不取。若诸人女姊妹。有堕贫穷恶处勤苦重作衣食不充。便作是念。诸问迦罗信受语者。所受勤苦当复剧是。若得富乐好处。便作如是念。诸问迦罗信受语者。所受富乐当复胜是。我以信受迦罗语故。令女姊妹得是乐处。如是迦罗比丘。或得赞叹。或得毁呰。是迦罗比丘。数出入诸檀越舍。有人问迦罗言。大德。汝至某家不。汝能语某。与我儿女若与姊妹。迦罗言能。如是作媒人往来。有比丘少欲知足行头陀。闻是事心不喜惭愧。种种因缘呵责迦罗。云何名比丘。作媒人行。如是呵已向佛广说。佛以是事集比丘僧。佛知而故问迦罗。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。汝所作事非沙门法。不随顺道不清净行。出家之人所不应作。汝痴人不知。我以种种因缘呵欲欲想。种种因缘赞叹离欲除灭欲热。我常说法教人离欲。汝尚不应生心。何况乃作起欲恚痴结缚根本不净恶业。汝痴人。我尚不赞叹少有欲心。何况汝作媒嫁事。佛种种呵已语诸比丘。以十利故与诸比丘结戒。从今是戒应如是说。若比丘行媒嫁法。持女意语男。持男意语女。若为成妇事。若为私通事。乃至一会时。僧伽婆尸沙。媒法者。受他语往来。女者。有十四种护。父所护。母所护。父母所护。兄弟所护。姊妹所护。舅护。姑护。舅姑护。亲里护。姓护。自护。法护。夫主护。持女意语男者。有女人语比丘言。汝能持是语语彼男子不。我为汝作妇。若共私通。汝能为我作夫。若共私通。若我与汝女。若与姊妹。汝能作我女夫。若姊妹夫。是名持女意语男。持男意语女者。有男语比丘言。汝能持是语语彼女人不。汝与我作妇。若共私通。我与汝作夫。若共私通。若与我女。与我姊妹。我与汝作女夫。为姊妹夫。是名持男意语女。乃至一会时者。一时共交会故。丈夫有七种妇。索得。水得。破得。自来得。以衣食得。合生得。须臾得。索得者。以少多财物索得作妇。是名索得。水得者。若人捉手以水灌掌与女作妇。是名水得。破得者。若破他国夺得作妇。复有自国反叛诛罚得者。是名破得。自来得者。若女人自一心贪着爱乐故。来供给作妇。是名自来得。衣食得者。若女人不能自活。为衣食故。来供给作妇。是名衣食得。合生得者。若女人语男子言。汝有财物我有财物。若生男女当供养我等。是名合生得。须臾得者。共一交会。故名须臾得。是中犯者。若比丘自受主人语。自语彼。自报主人者。僧伽婆尸沙。若自受主人语。自语彼。使报主人者。僧伽婆尸沙。若自受主人语。自语彼使。使报主人者。僧伽婆尸沙。若比丘自受主人语。使语彼。使报主人者。僧伽婆尸沙。若自受主人语。使语彼使。使报主人者。僧伽婆尸沙。若自受主人语。使语彼。自报主人者僧伽婆尸沙若比丘自受主人语。使使语彼。使使报主人者。僧伽婆尸沙。若自受主人语。使使语彼。自报主人者。僧伽婆尸沙。若自受主人语。使使语彼。使报主人者。僧伽婆尸沙。若比丘从使受主人语。使语彼。使报主人者僧伽婆尸沙。若从使受主人语。使语彼使。使报主人者。僧伽婆尸沙。若从使受主人语。使语彼。自报主人者。僧伽婆尸沙。若比丘从使受主人语。使使语彼。使使报主人者。僧伽婆尸沙。若比丘从使受主人语。使使语彼。自报主人者。僧伽婆尸沙。若从使受主人语。使使语彼。使报主人者。僧伽婆尸沙。若比丘从使受主人语。自语彼。自报主人者。僧伽婆尸沙。若从彼使受主人语。自语彼。使报主人者。僧伽婆尸沙。若从使受主人语。自语彼使使报主人者。僧伽婆尸沙。若比丘从使使受主人语。使使语彼。使使报主人者。僧伽婆尸沙。若从使使受主人语。使使语彼。自报主人者。僧伽婆尸沙。若从使使受主人语。使使语彼。使报主人者。僧伽婆尸沙。若比丘从使使受主人语。自语彼。自报主人者。僧伽婆尸沙。若从使使受主人语。自语彼。使报主人者。僧伽婆尸沙。若从使使受主人语。自语彼使。使报主人者。僧伽婆尸沙。若比丘从使使受主人语。使语彼。使报主人者。僧伽婆尸沙。若从使使受主人语。使语彼使。使报主人者。僧伽婆尸沙。若从使使受主人语。使语彼。自报主人者。僧伽婆尸沙。有二比丘。受主人语出外。一比丘言。汝并说我意。若语彼。还报主人者。俱僧伽婆尸沙。若不报者俱偷兰遮。有二比丘。受主人语出外。一比丘语一比丘。莫说我意。若语彼。还报主人者。一比丘僧伽婆尸沙。若不报者偷兰遮。诸比丘入他舍。主人问前行比丘。汝等出入某甲家不。能语某甲。与我儿若女姊妹。前行比丘言。我等不得作媒人。后行比丘闻是语。便往语彼居士言。汝能与某甲儿若女姊妹耶。还报者僧伽婆尸沙。不报者偷兰遮。主人问后行比丘。汝出入是诸家不。能语某甲。与我儿若女姊妹。后行比丘言。我等不得作媒人。前行比丘闻是语。便往语彼居士言。汝能与某甲儿若女姊妹。比丘受语。语彼还报者。僧伽婆尸沙。不报者偷兰遮。又一比丘行道中。一女人语比丘言。汝能语某甲。与我儿若女姊妹。比丘受语。语彼还报者。僧伽尸婆沙。不报者偷兰遮。二三四女人亦如是。二三四比丘亦如是。一比丘行道中。一男子语比丘言。汝能语某甲。与我儿若女姊妹。比丘受语。语彼还报者。僧伽婆尸沙。不报者偷兰遮。二三四男子亦如是。二三四比丘亦如是。黄门二根亦如是。一比丘行道中。一女一男语比丘言。汝能语某甲。与我儿若女姊妹。比丘受语。语彼还报者。僧伽婆尸沙。不报者偷兰遮。二三四女人男子亦如是。二三四比丘亦如是。一比丘行道中。一女人一黄门语比丘言。汝能语某甲。与我儿若女姊妹。比丘受语。语彼还报者。僧伽婆尸沙。不报者偷兰遮。二三四女人黄门亦如是。二三四比丘亦如是。一比丘行道中。一女人一二根人语比丘言。汝能语某甲。与我儿若女姊妹。比丘受语。语彼还报者。僧伽婆尸沙。不报者偷兰遮。二三四女人二根亦如是。二三四比丘亦如是。一比丘行道中。一男一黄门语比丘言。汝能语某甲。与我儿若女姊妹。比丘受语。语彼还报者。僧伽婆尸沙。不报者偷兰遮。二三四男子黄门亦如是。二三四比丘亦如是。一比丘行道中。一男子一二根语比丘言。汝能语某甲。与我儿若女姊妹。比丘受语。语彼还报者。僧伽婆尸沙。不报者偷兰遮。二三四男子二根亦如是。二三四比丘亦如是。一比丘行道中。一黄门一二根语比丘言。汝能语某。与我儿若女姊妹。比丘受语。语彼还报者。僧伽婆尸沙。不报者偷兰遮。二三四黄门二根亦如是。二三四比丘亦如是。一比丘行道中。一女一男一黄门一二根语比丘言。汝能语某。与我儿若女姊妹。比丘受语。语彼还报者。僧伽婆尸沙。不报者偷兰遮。二三四女人男子黄门二根亦如是。二三四比丘亦如是。有居士夫妇相嗔不和。时一比丘常出入是家。晨朝时到着衣持钵入舍坐已。共相问讯。教二人令和合。比丘生疑。我将无犯僧伽婆尸沙耶。是事白佛。佛言。有三种妇。一财索得。二水得。三破贼得。三种妇若作券言非我妇。礼法未断犹故出入。未唱言非我妇。教是和合者偷兰遮。若作券言非我妇。礼法已断不复出入。而未唱言非我妇。教是和合偷兰遮。若作券言非我妇。礼法已断不复出入。唱言非我妇。和合是者。僧伽婆尸沙。受他语有三种。还报有六种。三种者。一威仪二相三期。威仪者。比丘语主人言。若见我来往坐立。当知得不得。相者。比丘语主人言。主人若见我新剃发。若着絁僧伽梨。若捉瓦钵。当知得不得。期者。比丘语主人言。若见我在众中大语时。若挑衣时。当知得不得。是名三种受语。六种报者。一口二书三手印四威仪五相六期。若比丘口受使语。口语彼。口还报者。僧伽婆尸沙。若书手印威仪相期还报者。僧伽婆尸沙。比丘受使口语。书语彼。书还报者。僧伽婆尸沙。若书手印威仪相期口还报者。僧伽婆尸沙。比丘受使口语。手印语彼。手印还报者。僧伽婆尸沙。若手印威仪相期口书还报者。僧伽婆尸沙。若比丘受使书语。书语彼。书还报者。僧伽婆尸沙。若书手印威仪相期口还报者。僧伽婆尸沙。若比丘受使书。手印语彼。手印还报者。僧伽婆尸沙。若比丘手印威仪相期口书还报者。僧伽婆尸沙。比丘受使书语。口语彼。口还报者。僧伽婆尸沙。若比丘书手印威仪相期还报者。僧伽婆尸沙。若比丘受使手印。手印语语彼。手印还报者。僧伽婆尸沙。手印威仪相期口书还报者。僧伽婆尸沙。比丘受使手印语。口语彼。口还报者。僧伽婆尸沙。书手印威仪相期还报者。僧伽婆尸沙。比丘受使手印语。书语彼。书还报者。僧伽婆尸沙。手印威仪相期口还报者。僧伽婆尸沙。若受富贵人语。语富贵人。还报富贵人者。僧伽婆尸沙。若受贫贱人语。语富贵人。还报贫贱人者。偷兰遮。若比丘受他语。解意旨。僧伽婆尸沙。若受意旨。不受语。偷兰遮。若但受语。不解意旨。不犯(五事竟)

佛在阿罗毗国。尔时诸阿罗毗比丘。自乞作广长高大舍。久故难治。诸比丘数从居士乞言。我须墼须塼鏒钁斧凿釜盆槃盂瓶瓮麻绳种种草木皮绳土囊作人车鹿车。诸比丘以是因缘。心常匆遽乐著作事。妨废读经坐禅行道。尔时长老大迦叶。晨朝时到着衣持钵入城乞食。诸居士遥见大迦叶来。即呵责言。诸沙门释子自言。修善功德。今自乞物。作广长高大舍。久故难治。数来求索种种所须。以是因缘妨废读经坐禅行道。我等失利。供养如是难满难养无厌足人。大迦叶闻是事心不喜。乞食已往诣佛所。头面礼足在一面坐。白佛言。世尊。我晨朝时到着衣持钵。入阿罗毗城乞食。诸居士遥见我来呵责言。诸沙门释子自言。修善功德。今自乞物。作广长高大舍。久故难治。数从我等索墼索塼鏒钁斧凿釜盆瓶瓮草木皮绳索。常著作事。以是因缘。妨废读经坐禅行道。我等失利。供养如是难满难养多欲无厌足人。唯愿世尊。与诸比丘作舍限量。佛默然受。大迦叶知佛默然受语已。将护旧比丘心故作礼而去。去不久。佛以是事集比丘僧。知而故问诸比丘。汝实作是事不。答言。实作世尊。佛以种种因缘呵责诸比丘言。云何名比丘。自乞作广长高大舍。久故难治。数从诸居士种种求索乐著作事。以是因缘。妨废读经坐禅行道。佛如是种种因缘呵已。语诸比丘。以十利故与诸比丘结戒。从今是戒应如是说。若比丘自乞作舍。无主自为。当应量作。是中量者。长十二修伽陀搩手。内广七搩手。是比丘应问诸比丘。诸比丘当示无难无妨处。若比丘自乞作舍。无主自为。不问诸比丘。过量作者。僧伽婆尸沙。若自乞者。比丘从诸人乞。若得百钱五十乃至一钱。舍者。温室凉室殿堂楼阁一柱舍重舍。无主者。是舍无檀越主。若男女黄门二根。自为者。不为众僧故专为己名自为。量者。佛言。用我手量。长十二搩手。内广七搩手。问者。应问僧。示处者。僧应示作处。难处者。是中有蛇窟蜈蚣百足毒虫乃至鼠穴。无难者。是中无蛇窟蜈蚣百足毒虫乃至鼠穴。妨处者。是舍四边一寻地内。有塔地若官地居士地外道地比丘尼地。若有大石流水池水大树深坑。如是有妨处。僧不应示。无妨处者。是舍四边一寻地内。无塔地官地居士地外道地比丘尼地大石流水池水大树深坑。如是无妨处。僧应示。是比丘应从僧乞示作处。乞示作处法者。僧一心和合时。是比丘从坐起。偏袒右肩脱革屣胡跪合掌。应作是言。诸长老一心念。我某甲比丘。为是自乞作舍。无主自为。无难无妨处作故。从僧乞示作处。僧怜愍故。示我作处。第二第三亦如是乞。是中僧应筹量可示不可示。若是比丘言无难。而实有难。不应示。若言无妨。而实有妨。亦不应示。若言无难无妨。而实有难有妨。不应示。若言无难。实无难应示。若言无妨。实无妨应示。若言无难无妨。实无难无妨应示。示法者。僧一心和合。一比丘僧中唱言。大德僧听。是某甲比丘。欲自乞作舍。无主自为。无难无妨处作故。从僧乞示作处。若僧时到僧忍听。僧当示某甲比丘作处。白如是。大德僧听。是某甲比丘自乞作舍。无主自为。无难无妨处作故。从僧乞示作处。僧怜愍故。当示作处。谁诸长老忍。僧示某甲自乞。作舍无主自为无难无妨处作者默然。若不忍者说。僧示某甲比丘自乞作舍无主自为无难无妨处作竟。僧忍默然故。是事如是持。是中犯者。若比丘自乞作舍。无主自为。不如法作者犯。过量作犯。不问处犯。有难处犯。有妨处犯。过量不问处犯。过量难处犯。若过量妨处犯。若不问难处犯。不问妨处犯。若难处妨处犯。若过量不问难处犯。若过量不问妨处犯。若过量不问难处妨处犯。若比丘语余比丘。为我作舍。语已便去。后为作竟。是舍不如法作者犯。若过量作犯。不问处犯。有难处犯。妨处犯。过量不问处犯。过量难处犯过量妨处犯。不问难处犯。不问妨处犯。难处妨处犯。过量不问难处犯。过量不问妨处犯。过量不问难处妨处犯。若比丘语余比丘。为我作舍。语已便去。后作未成。行还自成。是舍不如法作犯。过量作犯。不问处犯。难处犯。妨处犯。过量不问犯。过量难处犯。过量妨处犯。不问难处犯。不问妨处犯。难处妨处犯。过量不问难处犯。过量不问妨处犯。过量不问难处妨处犯。若为佛为僧无犯。若得先成舍。无犯(六事竟)

十诵律卷第三十诵律卷第四(初诵之四)

        后秦北印度三藏弗若多罗译

    十三僧残法之余(并二不定法)

佛在拘睒弥国。尔时长老阐那。多有知识。国王夫人王子大臣将帅官属。以多知识故。伐他神树作大房舍。是树多人所识。多人所用。诸居士嫌恨呵责。诸沙门释子自言。修善功德。以国王夫人王子大臣将帅官属所知识故。伐是多人所识多人所用神树。作大房舍。我等失利供养如是难满难养多欲无厌足人。有比丘。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集比丘僧。知而故问阐那。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘。以国王夫人王子大臣将帅官属所知识故。伐是多人所识用神树。作大房舍。佛种种因缘呵已。语诸比丘。以十利故与诸比丘结戒。从今是戒应如是说。若比丘作大房舍。有主自为作。是比丘应问诸比丘。诸比丘当示无难无妨处。若比丘作大房舍。有主自为。不问诸比丘难处妨处。作者僧伽婆尸沙。大舍者。温室凉室殿堂楼阁一柱舍重舍。乃至容四威仪行立坐卧。有主者。是舍有檀越主。若男若女黄门二根。自为者。不为僧故专为己故。名为自为。问者。应问僧。示处者僧应示处。难处妨处者。如上说。是比丘应从僧乞示作处。乞法者。僧一心和合。是比丘从坐起。偏袒右肩脱革屣。胡跪合掌应作是言。诸长老一心念。我某甲比丘欲作大房舍。有主自为。无难无妨处作。我某。甲比丘为是有主自为。无难无妨处作故。从僧乞示作处。僧怜愍故示我作处。第二第三亦如是乞。是中僧应筹量可示不可示。若言无难。而实有难。若言无妨。而实有妨。若言无难无妨。而实有难有妨。皆不应示。无妨实无妨。无难实无难。应示。示法者。僧一心和合一比丘唱言。大德僧听。是某甲比丘欲作大舍。有主自为无难无妨处作。是比丘为作大舍故。从僧乞示作处。若僧时到僧忍听。僧当示某甲比丘作处。白如是。大德僧听。是某甲比丘欲作大舍。有主自为无难无妨处作故。从僧乞示作处。僧怜愍故当示作处。谁诸长老忍。某甲比丘作大舍有主自为无难处无妨处作者默然若不忍者说。如是白四羯磨僧示竟。某甲比丘作大舍。有主自为无难无妨处。僧忍默然故。是事如是持。是中犯者。若比丘有主自为。过量作大舍犯。不问处犯。有难处犯。有妨处犯。不问有难处犯。不问有妨处犯。难处妨处犯。不问难处妨处犯。若比丘语余比丘。为我作舍。语已便去。后为作竟。是舍过量作犯。不问处犯。有难处犯。有妨处犯。不问有难处犯。不问有妨处犯。有难有妨处犯。不问有难有妨处犯。若比丘语余比丘。为我作舍。语已便去。后作未成。行还自成。是舍过量作犯。不问处犯。有难处犯。有妨处犯。不问有难处犯。不问有妨处犯。有难有妨处犯。不问有难有妨处犯。若先成舍。无犯(七事竟)

佛在王舍城。尔时长老陀骠力士子。成就五法故。僧羯磨作知卧具人。不随爱。不随嗔。不随怖。不随痴。知得不得。是人随所应与。若阿练儿阿练儿共。持律持律共。说法说法共。读修妒路读修妒路共。如是同事者共。是人作是念。我如是与者。若语若默安乐得住。是陀骠分布卧具时。不须灯烛。左手出光。右手持与。有比丘故待闇来。欲见陀骠神通之力。时佛故在王舍城。是力士子陀骠。成就五法故。众僧教作差会人。是人差次会时。不随爱嗔怖痴知次第不越次。尔时弥多罗浮摩比丘次会。值得粗食。如是再三食粗食。时作如是念。我深苦恼。是陀骠力士子。故以是粗食恼我。当以何报令彼得恼。复作是念。我当谤以无根波罗夷法。是比丘有妹比丘尼。名弥多罗。时此比丘尼。到弥多罗浮摩比丘所。头面礼足在一面立。时弥多罗浮摩比丘。不共语亦不看不教坐。是比丘尼作是念。我作何恶何所触犯。使此兄不共我语。作是念已便言。我于兄有何过故。不共我语不教我坐。是比丘言。陀骠比丘故以粗食恼我。乃至再三。汝不助我。比丘尼言。欲令我以何事相助。是比丘言。妹汝到佛所作如是言。世尊。云何有是法。陀骠比丘共我作淫。堕波罗夷事。比丘尼言。是清净无罪比丘。云何谤以无根波罗夷法。是比丘言。妹汝不作是谤者。我不共汝语。不唤汝坐。是比丘尼敬爱兄故。即作是念。若我不随语者。兄不共我语。不教我坐。如是念已。即语兄言。当随汝语。是比丘言。妹小住。我当先往佛所。汝随后来。我当证之。即往佛所头面礼足在一面立。是比丘尼便从后来。头面礼足在一面立。白佛言。世尊。云何有是法。陀骠比丘共我作淫。堕波罗夷事。时弥多罗浮摩比丘即作是言。世尊。是事实尔。我亦先知。如是比丘尼所说。尔时陀骠在佛后扇佛。佛顾视陀骠言。汝今云何。是弥多罗比丘尼在我前言。世尊。云何有是法。陀骠比丘共我作淫。堕波罗夷事。弥多罗浮摩比丘亦作是言。世尊。是事实尔。我先亦知。如是比丘尼所说。陀骠比丘白佛言。世尊。世尊知我。修伽陀知我。佛语陀骠。汝今不得作如是语。世尊知我。修伽陀知我。汝忆念者。便说忆念。若不忆念者。说不忆念。我不忆念世尊。不忆念修伽陀。尔时长老罗睺罗亦在会中。偏袒右肩合掌白佛言。世尊。是陀骠比丘为何所说。是弥多罗比丘尼今在佛前作如是语。世尊。云何有是法。陀骠比丘共我作淫。堕波罗夷事。弥多罗浮摩比丘。亦作是言。世尊。是事实尔。我先亦知。如是比丘尼所说。佛语罗睺罗。我今问汝。随汝意答。于意云何。若是比丘尼来语我言。世尊。云何有是法。罗睺罗共我作淫。堕波罗夷事。弥多罗浮摩比丘亦作是说。是事实尔。我亦先知。如比丘尼所说。汝当云何。时罗睺罗言。世尊知我。修伽陀知我。佛言。痴人。汝尚能言。世尊知我。修伽陀知我。何况陀骠比丘。持戒清净善修梵行。云何不言世尊知我修伽陀知我。尔时佛语诸比丘。汝等当记。陀骠比丘说不忆念。是弥多罗比丘尼自说作罪故。应与灭羯磨。佛如是教已。起入禅室。时诸比丘审谛急问弥多罗浮摩比丘言。汝云何见。何处见。见犯何事。汝以何事故往见。是诸比丘审谛急问已。答言。陀骠比丘实梵行清净。我以欲故嗔故怖故痴故。作是语谤。诸比丘言。云何陀骠比丘梵行清净。以欲故嗔故怖故痴故。作是语谤。答言。陀骠比丘成就五法故。王舍城众僧教作差会人。不随爱嗔怖痴次第不越次。我时次会。值粗恶食。如是再三啖食。时心中苦恼。便作是念。陀骠比丘。故以粗食恼我。当以何报。复作是念。我当谤以无根波罗夷法。以是因缘故。我以欲嗔怖痴故。作是语谤。是中有比丘。少欲知足行头陀。闻是事心不喜。呵责言。云何名比丘。以无根波罗夷法。谤清净梵行比丘。诸比丘种种因缘呵已。向佛广说。佛时即从禅室出。集比丘僧。知而故问弥多罗浮摩比丘。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘。以无根波罗夷法。诽谤清净梵行比丘。佛以种种呵已。语诸比丘。有三种人必堕地狱。何等三。若人以无根波罗夷法。谤清净梵行比丘。是初人堕地狱。复有人如是邪见。便作是言。淫欲中无罪。以是故。是人深作放逸自恣五欲。是为第二人堕地狱。复有人犯戒恶法臭烂。非沙门自言沙门。非梵行自言梵行。是为第三人堕地狱。尔时世尊。欲明了此事。而说偈言

  妄语堕地狱　　作之言不作
  是二俱相似　　后皆受罪报
  夫人处世间　　斧在口中生
  以是自斩身　　斯由作恶言
  应呵而赞叹　　应赞而呵骂
  口过故得衰　　衰故不受乐
  如奄失财利　　是衰为鲜少
  恶心向善人　　是衰重于彼
  尼罗浮地狱　　其数有十万
  阿浮陀地狱　　三千六及五
  恶心作恶口　　轻毁圣人故
  寿终必当堕　　如是地狱中

佛种种因缘呵已。语诸比丘。以十利故与诸比丘结戒。从今是戒应如是说。若比丘住恶嗔故。以无根波罗夷法。谤无波罗夷比丘。欲破彼梵行。是比丘后时。或问或不问。知是无根事。比丘住恶嗔故。作是语者。僧伽婆尸沙。恶嗔者。以贪着故起。恶嗔增盛。不见是人功德。但求过恶。无波罗夷比丘者。是比丘四波罗夷中一切不犯。无根者。有三种根本。若见若闻若疑。谤者。是比丘不犯。强以罪加。破梵行者。破彼比丘法欲令退堕。知是无根事者。事有四种。诤讼事。相助事。犯罪事。常所行事。是中犯者。若比丘以无根波罗夷法。谤不清净比丘。十一种犯。五种不犯。十一种者。是事不见不闻不疑。若见妄若闻妄若疑妄。若闻信闻。若闻不信闻。闻已言疑。疑已言见。疑已言闻。是名十一种犯。五种不犯者。是事若见若闻若疑。见已不妄。闻已不妄。是名五种不犯。如不清净比丘似清净比丘亦如是。若比丘以无根波罗夷法。谤清净比丘。十种犯四种不犯。十种者。不见不闻不疑。若闻妄疑妄。若闻信闻。闻不信闻。闻已言疑。疑已言见。疑已言闻。四种不犯者。若疑若闻。若闻不妄。若疑不妄。如清净比丘。似不清净亦如是(八事竟)

佛在王舍城。尔时力士子陀骠比丘。独在山下与二比丘尼共立一处。时弥多罗浮摩比丘。亦在彼山坐石上治衣。遥见陀骠比丘独与二比丘尼共立一处。见已作是念。我先以无根波罗夷法诽谤不成。今有小事。当以波罗夷法谤之。作是念已。便语诸比丘。今陀骠比丘是犯淫人。我见是事不随他语。尔时诸比丘审谛急问。汝云何见。何处见。见犯何事。汝以何事往见。如是诸比丘审谛问已。便云。我随爱随嗔随怖随痴故说。是陀骠比丘实梵行清净。诸比丘问。云何言。我随爱嗔怖痴故说。是陀骠比丘梵行清净。答言。我在彼山坐石上治衣。遥见陀骠比丘独与二比丘尼共立一处。见已便作是念。我先以无根波罗夷法诽谤不成。今有小事。当以波罗夷法谤之。以是故言。我随爱嗔怖痴故说。陀骠比丘实自清净。是中有比丘。少欲知足行头陀。闻是事心不喜。呵责言。云何名比丘。持小片事。以波罗夷法谤清净比丘。诸比丘种种因缘呵已。向佛广说。佛以是事集比丘僧。知而故问弥多罗浮摩比丘。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘。持小片事。以波罗夷法谤清净比丘。佛以种种因缘呵已。语诸比丘。以十利故与诸比丘结戒。从今是戒应如是说。若比丘恶嗔故。异分中取片。若似片事。以波罗夷法谤无波罗夷比丘。欲破彼梵行。是比丘后时。或问或不问。知是片似片事。比丘住恶嗔故作是语者。僧伽婆尸沙。异分者。四波罗夷是。何以故。是四波罗夷中。若犯一一事。非沙门非释子。失比丘法。故名异分。不异分者。十三事。二不定法。三十舍堕法。九十堕法。四波罗提提舍尼法。众多学法。七止诤法。是名不异分。何以故。若犯是事。故名比丘。故名释子。不失比丘法。是名不异分。片须臾片者。诸威仪中事。是名为片。亦名须臾片。诤者。诤有四种。斗讼诤。相助诤。犯罪诤。常所行事诤。是中犯者。若比丘地了时。见余比丘犯僧伽婆尸沙。是比丘僧伽婆尸沙中。定生僧伽婆尸沙想。不见他犯波罗夷言。我见犯一一语中僧伽婆尸沙。日出时日出已。中前日中中后。晡时日没日没已。初夜初分初夜中分初夜后分。中夜初分中夜中分中夜后分。后夜初分后夜中分后夜后分亦如是。有比丘地了时。见余比丘犯罪。若波逸提。若波罗提提舍尼。若突吉罗。是比丘突吉罗罪中。定生突吉罗想。不见他犯波罗夷言。我见犯一一语中僧伽婆尸沙。乃至后夜后分亦如是。有比丘地了时。见余比丘犯僧伽婆尸沙。谓是僧伽婆尸沙。谓波夜提。谓波罗提提舍尼。谓突吉罗。是比丘僧伽婆尸沙中。定生突吉罗想。不见他犯波罗夷言。我见犯一一语中僧伽婆尸沙。乃至后夜后分亦如是。复有比丘地了时。见余比丘犯罪。若波夜提。若波罗提提舍尼。若突吉罗。是人谓是突吉罗。谓僧伽婆尸沙。谓波夜提。谓波罗提提舍尼。是人突吉罗罪中。定生波罗提提舍尼想。不见他犯波罗夷言。我见犯一一语中僧伽婆尸沙乃至后夜后分亦如是

复有比丘地了时。见余比丘犯僧伽婆尸沙。是中生疑。为是僧伽婆尸沙。为非僧伽婆尸沙。后除疑心。定生僧伽婆尸沙想。不见他犯波罗夷言。我见犯一一语中僧伽婆尸沙。乃至后夜后分亦如是。复有比丘地了时。见余比丘犯罪。若波夜提。若波罗提提舍尼。若突吉罗。是中生疑。为突吉罗。为非突吉罗。后除疑心。突吉罗罪中。定生突吉罗想。不见他犯波罗夷言我见犯一一语中。僧伽婆尸沙。乃至后夜后分亦如是

复有比丘地了时。见余比丘犯僧伽婆尸沙。是中生疑。是罪为僧伽婆尸沙。为波夜提。为僧伽婆尸沙。为波罗提提舍尼。为僧伽婆尸沙。为突吉罗。后除疑心。僧伽婆尸沙中。定生僧伽婆尸沙想。不见他犯波罗夷言。我见犯一一语中僧伽婆尸沙。乃至后夜后分亦如是。复有比丘地了时。见他犯罪若波夜提。若波罗提提舍尼。若突吉罗。是中生疑。是罪为突吉罗。为僧伽婆尸沙。为突吉罗。为波夜提。为突吉罗。为波罗提提舍尼。后除疑心。突吉罗罪中。定生突吉罗想。不见他犯波罗夷言。我见犯一一语中僧伽婆尸沙。乃至后夜后分亦如是。复有比丘地了时。见他犯僧伽婆尸沙。是中生疑。为是僧伽婆尸沙。为是波夜提。为是波罗提提舍尼。为是突吉罗。后除疑心。僧伽婆尸沙中。定生突吉罗想。不见他犯波罗夷言。我见犯一一语中僧伽婆尸沙。乃至后夜后分亦如是。复有比丘地了时。见他比丘犯罪。若波夜提。若波罗提提舍尼。若突吉罗。是中生疑。是罪为是突吉罗。为僧伽婆尸沙。为波夜提。为波罗提提舍尼。后除疑心。突吉罗罪中。定生波罗提提舍尼想。不见他犯波罗夷言。我见犯一一语中僧伽婆尸沙。乃至后夜后分亦如是(九事竟)

佛在王舍城。尔时提婆达多。求破和合僧。受持破僧事。是人有嫉妒心。方便作是念。我独不能得破沙门瞿昙和合僧坏转法轮。是提婆达多有四同党。一名俱伽梨。二名骞陀陀骠。三名迦留陀提舍。四名三文达多。提婆达多到是四人边已作是言。汝当共破沙门瞿昙和合僧坏转法轮。时彼四人语提婆达多言。沙门瞿昙诸弟子。有大智慧大神通。得天眼知他心念。是人知见我等欲破和合僧坏转法轮。我等云何能破沙门瞿昙和合僧坏转法轮。提婆达多语四人言。沙门瞿昙年少弟子。新入彼法出家不久。我等到边用五法诱取。语诸比丘言。汝尽形寿受着纳衣。尽形寿受乞食法。尽形寿受一食法。尽形寿受露地坐法。尽形寿受断肉法。若比丘受是五法。疾得涅槃。若有长老上座比丘多知多识久习梵行得佛法味者。当语之言。佛已老耄年在衰末。自乐闲静受现法乐。汝等所须事我当相与。我等以是方便能破沙门瞿昙和合僧坏转法轮。四比丘言。如是提婆达多受提婆达多语。提婆达多后时到诸年少比丘所。以五法诱之。语诸比丘。汝尽形寿受着衲衣。尽形寿受乞食法。尽形寿受一食法。尽形寿受露地坐法。尽形寿受断肉法。汝等行是五法。疾得涅槃。复语诸长老上座比丘。佛已老耄年在衰末。自乐闲静受现法乐。汝所须事我当相与。尔时提婆达多。非法说法。法说非法。非律说律。律说非律。非犯说犯。犯说非犯。轻说重。重说轻。有残说无残。无残说有残。常所用法说非常法。非常所用法说是常法。非教说教。教说非教。时诸比丘见提婆达多欲破和合僧坏转法轮。见已往诣佛所。头面礼足在一面坐。坐已。白佛言世尊。是提婆达多。欲破和合僧。受持破僧因缘事。是人非法说法。法说非法。非律说律。律说非律。犯说非犯。非犯说犯。轻说重。重说轻。有残说无残。无残说有残。常所用法说非常法。非常所用法说是常法。教说非教。非教说教。佛语诸比丘。汝等当呵提婆达多令舍是破僧因缘事。是比丘受佛语已。到提婆达多所言。汝莫求破和合僧。莫受持破僧事。当与僧和合。僧和合者。欢喜无诤。一心一学如水乳合。得安乐住。汝当舍是破僧因缘事。时提婆达多不舍是事

尔时提婆达多四同党。呵诸比丘言。汝等莫说提婆达多是事。何以故。是人说法说律。是人所说皆是我等所欲。是人知说。非不知说。是人所说皆是我等所乐忍。如是诸比丘。再三教提婆达多。不能令舍恶邪便从坐起往诣佛所。头面礼足一面坐。坐已。白佛言。世尊我等已约敕提婆达多。而不舍恶邪。有四同党复作是言汝等莫说提婆达多是事。何以故。是人说法说律。是人所说。皆是我等所欲。是人知说。非不知说。是人所说。皆是我等所乐忍。诸比丘再三约敕。不舍是事

尔时佛作是念。如提婆达多痴人及四同党。或能破我和合僧坏转法轮。我当自约敕提婆达多令舍是事。佛作是念已。即自约敕提婆达多。汝莫求破和合僧。莫受持破僧因缘事。汝当与僧和合。僧和合者欢喜无诤。一心一学如水乳合。得安乐住。汝莫非法说法法说非法。非律说律。律说非律。非犯说犯。犯说非犯。轻说重。重说轻。有残说无残。无残说有残。常所用法说非常法。非常所用法说是常法。非教说教。教说非教。汝当舍是破僧因缘事。尔时提婆达多。闻佛口教暂舍是事。佛以是事集比丘僧以种种因缘呵责。云何名比丘求破和合僧受持破僧事。佛如是种种因缘呵已。语诸比丘。以十利故与诸比丘结戒。从今是戒应如是说。若比丘欲破和合僧。勤求方便受持破僧事。诸比丘应如是呵言。汝莫破和合僧。莫求方便受持破僧事。当与僧和合。僧和合者欢喜无诤。一心一学如水乳合。得安乐住。汝当舍是求破僧事。诸比丘如是教时。不舍是事者。当再三教令舍是事。再三教已舍者善。不舍者僧伽婆尸沙。是中犯者。比丘是事中。有十四种。犯非法说法偷兰遮。法说非法偷兰遮。非律说律偷兰遮。律说非律偷兰遮。非犯说犯偷兰遮。犯说非犯偷兰遮。轻说重偷兰遮。重说轻偷兰遮。有残说无残偷兰遮。无残说有残偷兰遮。常所用法说非常法偷兰遮。非常所用法说是常法偷兰遮。非教说教偷兰遮。教说非教偷兰遮。先应软语约敕。已舍者。令作十四偷兰遮悔过出罪。若不舍者。应作白四羯磨约敕。约敕法者。众僧一心和合。一比丘僧中唱言。大德僧听。是某甲比丘。求破和合僧受持破僧事已软语约敕不舍是事。若僧时到僧忍听。僧当约敕某甲比丘。汝莫破和合僧。莫受持破僧事。当与僧和合。僧和合者欢喜无诤。一心一学如水乳合。得安乐住。汝当舍是求破僧事。白如是如是白四羯磨。僧约敕某甲比丘。汝莫破和合僧莫受持破僧事竟。僧忍默然故是事如是持。如佛先说。是比丘应约敕。乃至三教令舍是破僧事者。是名约敕。是名为教。是名约敕教。若软语约敕不舍者未犯。初说说未竟说竟。第二说说未竟说竟。第三说说未竟。非法别众。非法和合众。似法别众。似法和合众。如法别众。异法异律异佛教。若约敕不舍者未犯。若如法如律如佛教。三约敕竟不舍者。犯僧伽婆尸沙。是比丘若以十四事约敕皆成约敕若以是约敕。若以余约敕。此十四事一向约敕不舍者。一向成僧伽婆尸沙。后复约敕不舍者。复得僧伽婆尸沙。随所约敕不舍者。随得尔所僧伽婆尸沙。是比丘应即时入僧中自唱言。诸长老。我某甲比丘。得僧伽婆尸沙罪。若即说者善。若不即说者。从是时来。名覆藏日数(十事竟)

佛在王舍城。佛以是助破僧比丘因缘故。集比丘僧。种种因缘呵责助破僧比丘。云何名比丘。知是比丘求破和合僧作别朋党共相佐助。若一若二若众多。佛如是种种因缘呵已。语诸比丘。以十利故与诸比丘结戒。从今是戒应如是说。若比丘求破和合僧。有余同意相助比丘。若一若二若众多。语诸比丘言。汝是事中莫说是比丘。何以故。是比丘说法说律。不说非法不说非律。是比丘所说。皆是我等所欲。是知说非不知说。是比丘所说。皆是我等所乐忍。诸比丘应如是教是相助比丘。汝莫作是语。是比丘说法说律。不说非法不说非律。是比丘所说皆是我等所欲是知说非不知说。是比丘所说。皆是我等所乐忍。汝莫相助求破僧事。当乐助和合僧。僧和合者欢喜无诤。一心一学如水乳合。得安乐住。诸比丘如是教时。坚持是事不舍者。诸比丘当再三教令舍是事。再三教已舍者善。不舍者僧伽婆尸沙。是中犯者。若助破僧比丘语诸比丘言。汝是事中。莫说是比丘得突吉罗。若言是比丘说法者得偷兰遮。是说律者偷兰遮。若言是比丘所说皆是我等所欲突吉罗。若言知说非不知说偷兰遮。若言是比丘所说皆是我等所乐忍偷兰遮。先应软语约敕。已舍者。令作四偷兰遮二突吉罗悔过出罪。若不舍者。应作白四羯磨约敕。约敕法者。僧一心和合。一比丘僧中唱言。大德僧听。是某甲比丘。助某甲比丘求破僧。作别朋党若一若二若众多。已软语约敕不舍是事。若僧时到僧忍听。僧当约敕某甲比丘。汝等莫助某甲比丘求破僧事。莫作别朋党。莫作是言。是比丘说法说律。是比丘所说皆是我等所欲。是知说非不知说。是所说皆是我等所乐忍。如是白。如是白四羯磨约敕某比丘汝莫助破和合僧竟。僧忍默然故。是事如是持。如佛所说。是比丘应约敕。乃至三教令舍助破僧事者。是名约敕。是名为教。是名约敕教。若软语约敕不舍者不犯。若初说说未竟说竟。第二说说未竟说竟。第三说说未竟。非法别众。非法和合众。似法别众。似法和合众。如法别众。异法异律异佛教。不舍者不犯。若如法如比尼如佛教。三约敕不舍者。犯僧伽婆尸沙。是比丘若以四事约敕。皆成约敕。若以是约敕。若余约敕。此四事一向约敕。不舍者。一向成僧伽婆尸沙。若后复约敕不舍者。复得僧伽婆尸沙。随所约敕不舍者。随得尔所僧伽婆尸沙。是比丘应即时入僧中自唱言。诸长老。我某甲比丘。得僧伽婆尸沙罪。若即说者善。若不即说者。从是时来。名覆藏日数(十一事竟)

佛在舍卫国。尔时黑山土地。有二比丘。名马宿满宿。在此处住。作恶行污他家。皆见皆闻皆知。是比丘共女人一床坐共一盘食。共器饮酒。中后食。共食宿。啖宿食。不受而食。不受残食。弹鼓簧。捻唇作音乐声。齿作伎乐。弹铜盂。弹多罗树叶。作余种种伎乐歌舞。着鬘璎珞。以香涂身。着香熏衣。以水相洒。自手采华。亦使人采。自贯华鬘。亦使人贯。头上着华自着耳环。亦使人着。自将他妇女去。若使人将去。若令象马斗。车斗步斗。羊斗水牛斗。狗斗鸡斗。男斗女斗。亦自共斗。手打脚踏。四向驰走。变易服饰。驰行跳踯。水中浮没。斫截树木。打臂拍髀。啼哭大唤。或啸谬语诸异国语。踯绝反行如婉转鱼。踯物空中还自接取。与女人共大船上载令作伎乐。或骑象马乘车辇舆。与多人众吹贝导道。入园林中。作如是等种种恶不净事。尔时阿难。从迦尸国来。向舍卫城。到黑山邑宿。晨朝时到着衣持钵入城乞食。阿难持空钵入城。还空钵出。出城不远多人众集。有少因缘。阿难到彼问众人言。汝此土地丰乐多诸人众。今我乞食。持空钵入还空钵出。无有沙门释子在此多少作恶事耶。尔时有贤者。名忧楼伽。在彼众中。从坐起偏袒合掌语阿难言。大德知不。此有马宿满宿比丘。作诸恶行如上广说大德阿难。是二比丘住此作恶。悉污诸家皆见闻知。时忧楼伽贤者。即以两手抱阿难身。将入自舍敷座令坐。自手与水与多美饮食。自恣饱满已。洗手摄钵。贤者取小床坐。欲听法故。阿难以种种因缘说法示教利喜已。从座起去。向自房舍。随所受卧具。还付旧比丘。持衣钵游行。向舍卫国渐到佛所。头面礼足在一面立。诸佛常法。有客比丘来。以如是语问讯。忍不足不。安乐住不。道路不疲。乞食不乏。佛以如是语问讯阿难。忍不足不。安乐住不。道路不乏耶。乞食不难耶。阿难答言。世尊。忍足安乐住。道路不乏。乞食不难。以是因缘向佛广说。佛以是事集比丘僧。以种种因缘。呵责马宿满宿比丘。云何名比丘。作恶行污他家皆见闻知。佛如是种种因缘呵已。语阿难。汝往黑山。与马宿满宿比丘驱出羯磨。若更有如是比丘。亦应如是驱出羯磨。羯磨法者。一心和合僧。是马宿满宿比丘。着见处不闻处。一比丘僧中作是言。谁能说马宿满宿比丘如是罪事。而自不犯毁呰波夜提。何以故。僧差作故。若有比丘僧中言。我能作者。即唤马宿满宿比丘来。是比丘应问。汝忆念。与女人共一床坐。共一盘食。共一器饮酒。中后食。共食宿。啖宿食。不受食。不受残食法。广问如上种种恶不净事。汝忆作不。若马宿满宿比丘。是诸罪中趣说一事。即应语。汝默然。今僧与汝作驱出羯磨。时一比丘。僧中唱言。大德僧听。是马宿满宿比丘。作恶行污他家皆见闻知。共女人一床坐。共一盘食。共器饮酒。中后食。共食宿。啖宿食。不受食。不受残食法。乃至诸异国语。若僧时到僧忍听。僧与马宿满宿比丘驱出羯磨。若马宿满宿比丘。共女人一床坐。一盘食。共一器饮酒。中后食。共食宿。啖宿食。不受食。不受残食法。乃至诸异国语。僧与作驱出羯磨。白如是。如是白四羯磨。僧与马宿满宿比丘作驱出羯磨竟。僧忍默然故。是事如是持。是比丘。如法僧与驱出羯磨已。作是言。僧阿难。随欲行嗔行怖痴行。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘呵责。云何名比丘。众僧和合如法作驱出羯磨。乃复说。僧阿难。随欲行嗔行怖行痴行。诸比丘种种因缘呵已。向佛广说。佛以种种因缘。呵责马宿满宿比丘。云何名比丘。一心和合僧如法作驱出羯磨。说僧阿难随欲行嗔行怖行痴行。佛种种因缘呵已。语诸比丘。以十利故。与诸比丘结戒。从今是戒应如是说。若比丘随所依止聚落作恶行污他家皆见皆闻皆知。诸比丘应如是言。汝等作恶行污他家皆见皆闻皆知。汝等出去。不应住此。是比丘语诸比丘言。诸比丘随欲行嗔行怖行痴行。何以故。有如是同罪比丘。有驱者有不驱者。诸比丘语是比丘。汝莫作是语。诸比丘随欲行嗔行怖行痴行。何以故。诸比丘不随欲嗔怖痴行。汝等作恶行污他家。皆见闻知。汝当舍是随欲嗔怖痴语。汝等出去。不应住此。如是教时。不舍是事者。当再三教令舍是事。再三教时舍者善。不舍者僧伽婆尸沙。是中犯者。若比丘言。诸比丘随欲行。偷兰遮。随嗔行偷兰遮。随怖行偷兰遮。随痴行偷兰遮。若言同犯罪比丘有驱者有不驱者。呵骂僧故。得波夜提。先应软语约敕。若舍者。令作四偷兰遮一波夜提悔过出罪。若不舍者。应作白四羯磨约敕。约敕法者。僧一心和合。一比丘。僧中唱言。大德僧听。是马宿满宿比丘。众僧如法作驱出羯磨。说僧阿难随欲行嗔行怖行痴行若僧时到僧忍听。僧当约敕是比丘。众僧如法作驱出羯磨。汝莫说僧阿难随欲行。莫言随嗔行。莫言随怖行。莫言随痴行。汝当舍是随欲嗔怖痴语。白如是。如是作白四羯磨。僧约敕马宿满宿比丘竟。僧忍默然故。是事如是持如佛先说。是比丘应约敕。乃至三教。是名约敕。是名为教。是名约敕教。若软语约敕不舍者不犯。若初说说未竟说竟。第二说说未竟说竟。第三说说未竟。非法别众。非法和合众。似法别众。似法和合众。法别众。异法异律异佛教。约敕不舍者不犯。若如法如律如佛教。三约敕不舍者。犯僧伽婆尸沙。是比丘若以四事约敕皆成约敕。若以是约敕。若以余约敕。以此四事。一向约敕。不舍者。一向成僧伽婆尸沙。若后复约敕。不舍者。复得僧伽婆尸沙。随所约敕不舍者。随得尔所僧伽婆尸沙。是比丘应即时入僧中自唱言。诸长老。我某甲比丘。得僧伽婆尸沙罪。若即说者善。若不即说。从是时来。名覆藏日数(十二事竟)

佛在拘睒弥国。尔时长老阐那。犯小悔过罪。诸比丘欲利益怜愍安隐故。教忆是罪。语阐那言。汝作某可悔过罪。汝应发露悔过。莫覆藏。阐那答言。汝等莫语我好恶。我亦不语汝等好恶。何以故。我大人子得佛法故。汝等种种杂姓。种种国土。种种家。信佛法故。剃除须发着法服随佛出家。如秋叶落风吹一处。汝等亦尔。种种杂姓种种国土种种家。信佛法故。剃除须发着法服随佛出家。以是故。汝等不应语我好恶。我亦不应语汝好恶。我大人子得佛法故。是中有比丘少欲知足行头陀。闻是事心不喜。种种因缘呵责。云何名比丘。如戒经中说事。诸比丘如法如律。以利益怜愍故说。自身作戾语事。诸比丘种种因缘呵已。向佛广说。佛以是事集比丘僧知而故问阐那言。汝实作是事不。答言。实作世尊。佛以种种因缘呵责阐那。云何名比丘自身作戾语。佛种种因缘呵已语诸比丘。以十利故。与诸比丘结戒。从今是戒应如是说。若比丘恶性戾语。诸比丘说如法如律如戒经中事。是比丘戾语不受。语诸比丘言。汝莫语我好恶。我亦不语汝好恶。诸比丘应如是言。诸比丘说如法如律如戒经中事。汝莫戾语。汝当随顺语。诸比丘当为汝说如法如律。汝亦当为诸比丘说如法如律。何以故。如是者。诸如来众得增长利益。以共语相教共出罪故。汝当舍是戾语事。诸比丘如是教时。不舍是事者。当再三教令舍是事。再三教已舍者善。不舍者僧伽婆尸沙。是中犯者。若比丘言。汝莫语我突吉罗。莫语好偷兰遮。莫语恶偷兰遮。我亦不语汝突吉罗。不语汝好偷兰遮。不语汝恶偷兰遮。若言舍是教我法。嫌骂众故得波夜提。先应软语约敕。软语约敕已。舍是事者。作令四偷兰遮二突吉罗一波夜提悔过出罪。若不舍者应作白四羯磨。约敕。约敕法者。僧一心和合。一比丘僧中唱言。大德僧听。是阐那比丘自身作戾语事。已软语约敕不舍是事。若僧时到僧忍听。僧当约敕阐那比丘。莫作戾语事。莫言汝莫语我好恶。我亦不语汝好恶。诸比丘说如法如律如戒经中事。汝莫戾语。当作随顺语。诸比丘当为汝说如法如律。汝当为诸比丘说如法如律。如是者。诸如来众得增长利益。以共语相教共出罪故。汝当舍是戾语事。白如是。如是作白四羯磨约敕阐那比丘竟。僧忍默然故。是事如是持如佛先说。是比丘应约敕。乃至三教。是名约敕。是名为教。是名约敕教。若软语约敕不舍者未犯。若初说说未竟说竟。第二说说未竟说竟。第三说说未竟。非法别众。非法和合众。似法别众。似法和合众。法别众。异法异律异佛教。三约敕不舍者未犯。若如法如律如佛教。三约敕竟不舍者。犯僧伽婆尸沙。是比丘。若以四事约敕。皆成约敕。若以是约敕。若以余约敕。以此四事一向约敕。不舍者。一向成僧伽婆尸沙若后复约敕不舍者。复得僧伽婆尸沙。随所约敕不舍者。随得尔所僧伽婆尸沙。是比丘应即入僧中自唱言。诸长老。我某甲比丘。犯僧伽婆尸沙。若即说者善。若不即说者。从是时来。名覆藏日数(十三事竟)

    明二不定法

佛在舍卫国。尔时迦留陀夷比丘。与掘多忧婆夷旧相知识。共事共语。时迦留陀夷到掘多舍已。独屏覆处坐说法。时有毗舍佉鹿子母。小因缘故。到掘多比舍。遥闻迦留陀夷说法声。作是念。必当是迦留陀夷在掘多舍说法。我当往听。时毗舍佉鹿子母。即到掘多舍。见迦留陀夷。独与掘多屏覆处坐。见已作是念。是坐处恶。比丘不应是中坐。若有长者。见是坐处。必当知。是比丘作恶事竟。若欲作恶。我今当往白佛。时毗舍佉鹿子母。即到佛所。头面礼足一面坐已。以是因缘向佛广说。佛与毗舍佉鹿子母。说种种法示教利喜已默然住。毗舍佉鹿子母见佛默然已。从坐起作礼而去。去不久。佛以是事集比丘僧。知而故问迦留陀夷。汝实作是事不。答言。实作世尊。佛以种种因缘呵责迦留陀夷。汝所作事。非沙门法不随顺道。无欲乐心作不清净行。出家之人所不应作。汝痴人。我以种种因缘。呵欲欲想欲欲欲觉欲热。种种因缘称赞断欲除欲想灭欲热。我常说法教人离欲。汝尚不应生心。何况乃作起欲恚痴结缚根本不净恶业。佛如是种种因缘呵已。语诸比丘。以十利故。与诸比丘结戒。从今是戒应如是说。若比丘独共女人坐屏覆内可行淫处。若可信优婆夷说。是比丘三法中一一法。若波罗夷。若僧伽婆尸沙。若波夜提。若是比丘自言。我坐是处。应三法中随所说治。若波罗夷。若僧伽婆尸沙。若波夜提。若随可信优婆夷所说法治。是初不定法。女人者。女人名有命人。若大若小中作淫欲。独者。一比丘一女人。更无第三人。屏处者。是处有壁。有篱席障薄障衣幔障。如是等种种余障。是名屏覆处。行淫处者。是中无所羞耻。可作淫欲。可信优婆夷者。归依佛归依法归依比丘僧得道得果。是人终不为身若为他人若以小因缘若为财利故故作妄语。三法中波罗夷者。四波罗夷中趣说一事。僧伽婆尸沙者。十三僧伽婆尸沙中趣说一事。波夜提者。九十波夜提中趣说一事。不定者。云何名不定。可信优婆夷。不知犯。不知何处起。不知犯名字。但言我见女人是处来去坐立。亦见比丘来去坐立。不见若作淫欲。若作偷夺。若夺人命。若触女人身。若杀草木。若过中食。若饮酒。如是事中不决定故。是名不定。随优婆夷所说事。应善急问是比丘。善急问已。自说我有是罪而不往。随比丘语应治。若言我往不犯是罪。如比丘语应治。若言我不往无有是罪。随可信优婆夷语故。应与是比丘作实觅法。实觅法者。众僧一心和合。一比丘僧中唱言。大德僧听。是某甲比丘。以可信优婆夷语。善急问已。不自说到彼处。不自说有是罪。若僧时到僧忍听。僧与某甲比丘随可信优婆夷语作实觅。白如是。如是白四羯磨。僧与某甲比丘随可信优婆夷语作实觅竟。僧忍默然故。是事如是持。得实觅比丘行法者。是人不应与他受大戒。不应受他依止。不应畜沙弥。不应教化比丘尼。若僧差作不应受。不应重作实觅罪。不应作相似罪。亦不应作重于先罪。不应呵羯磨。不应呵作羯磨人。不应出清净比丘罪。不得求听欲出他罪。不应遮说戒。不应遮自恣。不应遮僧羯磨教诫比丘尼人。不应举清净比丘罪。不应教令忆念。不应相言。恒自谦卑折伏心意。随顺清净比丘心。行常恭敬礼拜。若不如是法行者。尽形寿不得出是羯磨(初不定竟)

佛在舍卫国。尔时尸利比丘。与修阇多居士妇旧相知识。共事共语。时尸利比丘。晨朝时到着衣持钵至修阇多舍。独二人露处坐说法。时有布萨陀居士妇。小因缘故。到修阇多比舍。闻尸利比丘说法语声。作是念。必是尸利比丘为修阇多说法。我当往听。即往到舍。见尸利比丘独与修阇多妇露处共坐。见已作是念。是坐处恶。比丘不应是中坐。若其夫若其子若奴若子弟若典计人。见是处坐。必当知。是比丘作恶事竟若欲作恶。我今当往白佛。时布萨陀往到佛所。头面礼足一面坐已。以是因缘向佛广说。佛与布作陀说种种法。示教利喜已默然。布萨陀见佛默然已。从座起作礼而去。去不久。佛以是事集比丘僧。佛知而故问尸利比丘。汝实作是事不。答言。实作世尊。佛以种种因缘呵责尸利比丘。汝所作事。非沙门法不随顺道。无欲乐心作不清净行。出家之人所不应作。汝痴人不知。我以种种因缘呵欲欲想欲欲欲觉欲热。种种因缘称赞断欲想灭欲热。我常说法教人离欲。汝尚不应生心。何况乃作起欲恚痴结缚根本不净恶业。佛如是种种因缘呵已。语诸比丘。以十利故。与诸比丘结戒。从今是戒应如是说。若比丘独共一女人露地坐不可行淫处。若可信优婆夷说。是比丘二法中一一法。若僧伽婆尸沙。若波夜提。若是比丘自言。我坐是处。应随所说治。若僧伽婆尸沙。若波夜提。若随可信优婆夷所说治。是二不定法。露地处者。无壁障无篱无薄席障无衣幔障。是名露地。不可行淫处者。是中有所羞耻。不得作淫。可信优婆夷者。归佛归法归僧得道得果。是人终不为身若为他人若以小因缘若为财利故故作妄语。说二法中一一法者。僧伽婆尸沙者。十三僧伽婆尸沙中趣说一事。波夜提者。九十波夜提中趣说一事。不定者。可信优婆夷。不知犯何处起。不知犯名字。但说我见女人是处来去坐立。亦见比丘是处来去坐立。不见出精若触女身。若杀草木若过中食若饮酒。如是事中不决定故名为不定。随可信优婆夷所说应善急问。善急问已。若是比丘自言。我有是罪而不往。如比丘语应治。若言我往无有是罪。如比丘语应治。若言我不往无有是罪。如可信优婆夷语。应与实觅。实觅法者。僧一心和合。一比丘僧中唱。大德僧听。是某甲比丘。以可信优婆夷语。善急问已。不自说到彼处。不自说有是罪。若僧时到僧忍听。与某甲比丘随可信优婆夷语作实觅。白如是。如是白四羯磨。与某甲比丘随可信优婆夷作实觅竟。僧忍默然故。是事如是持。得实觅比丘行法者。是人不应与他受大戒。不应受他依止。不应畜沙弥。不应教诫比丘尼。若僧差作不应受。不应重作实觅罪。不应作相似罪。不应作重于先罪。不应呵羯磨。不应呵作羯磨人。不应出清净比丘罪。不得求听欲出他罪。不应遮说戒。不应遮自恣。不应遮僧羯磨教诫比丘尼人。不应举清净比丘罪。不应教令忆念。不应相言。恒自谦卑折伏心意。随顺清净比丘心。行常恭敬礼拜。若不如是法行者。尽形寿不得出是羯磨(二不定讫)

十诵律卷第四十诵律卷第五(初诵之五)

        后秦北印度三藏弗若多罗译

    明三十尼萨耆法之一

佛在王舍城。尔时六群比丘多畜衣服。入聚落着异衣。出聚落着异衣。食时着异衣。食竟着异衣。怛钵那时着异衣。怛钵那竟着异衣。食前着异衣。食后着异衣。初夜着异衣。中夜着异衣。后夜着异衣。入厕着异衣。出厕着异衣。洗大便时着异衣。洗大便竟着异衣。小便时着异衣。小便竟着异衣。入浴室着异衣。出浴室着异衣。畜积如是种种余衣。朽烂虫坏不用。是中有比丘。少欲知足行头陀。闻见是事心不喜。种种因缘呵啧六群比丘。云何名比丘多畜衣服。入聚落着异衣。出聚落着异衣。食时着异衣。食竟着异衣。怛钵那时着异衣。怛钵那竟着异衣。食前着异衣。食后着异衣。初夜着异衣。中夜着异衣。后夜着异衣。入厕着异衣。出厕着异衣。洗大便时着异衣。洗大便竟着异衣。小便时着异衣。小便竟着异衣。入浴室着异衣。出浴室着异衣。畜积如是种种余衣。朽烂虫坏不用。种种因缘呵已。向佛广说。佛以是事集比丘僧。知而故问六群比丘。汝实作是事不。答言。实作世尊。佛以种种因缘呵责六群比丘。云何名比丘多畜衣服。入聚落着异衣。出聚落着异衣。食时着异衣。食竟着异衣。怛钵那时着异衣。怛钵那竟着异衣。食前着异衣。食后着异衣。初夜着异衣。中夜着异衣。后夜着异衣。入厕着异衣。出厕着异衣。洗大便时着异衣。洗大便竟着异衣。小便时着异衣。小便竟着异衣。入浴室着异衣。出浴室着异衣。畜积如是种种余衣。朽烂虫坏不用。佛如是种种因缘呵已。语诸比丘。以十利故。与诸比丘结戒。从今是戒应如是说。若比丘衣竟。已舍迦絺那衣。畜长衣得至十日。若过是畜者。尼萨耆波夜提。是中或有衣竟。非舍迦絺那衣。或舍迦絺那衣。非衣竟。或衣竟。亦舍迦絺那衣。或非衣竟。亦非舍迦絺那衣。衣竟非舍迦絺那衣者。若比丘衣竟。未舍迦絺那衣。是名衣竟非舍迦絺那衣。舍迦絺那衣非衣竟者。若比丘舍迦絺那衣。衣不竟。是名舍迦絺那衣非衣竟。衣竟亦舍迦絺那衣者。若比丘衣竟。舍迦絺那衣。是名衣竟亦舍迦絺那衣。非衣竟亦非舍迦絺那衣者。若比丘衣不竟。非舍迦絺那衣。是名非衣竟亦非舍迦絺那衣。长衣者。除僧伽梨郁多罗僧安陀卫。余残衣名为长衣。尼萨耆波夜提者。是衣应舍。波夜提罪应悔过。是中犯者。若比丘。初一日得衣畜二日舍二日得衣三日舍。三日得衣四日舍。四日得衣五日舍。五日得衣六日舍。六日得衣七日舍。七日得衣八日舍。八日得衣九日舍。九日得衣十日舍。十日得衣十日时。比丘是衣。应与人若作净若受持。若不与人不作净不受持。至十一日地了时。尼萨耆波夜提。若比丘。一日得衣二日更得。畜一舍一。二日得衣三日更得。畜一舍一。三日得衣四日更得。畜一舍一。四日得衣五日更得。畜一舍一。五日得衣六日更得。畜一舍一。六日得衣七日更得。畜一舍一。七日得衣八日更得。畜一舍一。八日得衣九日更得。畜一舍一。九日得衣十日更得。畜一舍一。十日时比丘是衣。应与人若作净若受持。若不与人不作净不受持。至十一日地了时。尼萨耆波夜提。若比丘。一日得衣二日更得。舍前畜后。二日得衣三日更得。舍前畜后。三日得衣四日更得。舍前畜后。四日得衣五日更得。舍前畜后。五日得衣六日更得。舍前畜后。六日得衣七日更得。舍前畜后。七日得衣八日更得。舍前畜后。八日得衣九日更得。舍前畜后。九日得衣十日更得。舍前畜后。十日时比丘是衣。应与人若作净若受持。若不与人不作净不受持。至十一日地了时。尼萨耆波逸提。若比丘一日得衣二日更得。畜前舍后。二日得衣三日更得。畜前舍后。三日得衣四日更得。畜前舍后。四日得衣五日更得。畜前舍后。五日得衣六日更得。畜前舍后。六日得衣七日更得。畜前舍后。七日得衣八日更得。畜前舍后。八日得衣九日更得。畜前舍后。九日得衣十日更得。畜前舍后。十日时比丘是衣。应与人若作净若受持。若不与人不作净不受持。至十一日地了时。尼萨耆波逸提。若比丘。一日得衣畜。二日不得。三四五六七八九十日不得。十日时比丘是衣。应与人若作净若受持。若不与人不作净不受持。至十一日地了时。尼萨耆波逸提。若比丘。一日得衣畜。二日得衣畜。三四五六七八九十日得衣畜。十日时比丘是衣。皆应与人若作净若受持。若不与人不作净不受持。至十一日地了时。尼萨耆波逸提。若比丘。初日得衣。用作僧伽梨最下九条。成分别若干长若干短。总说九条。作衣竟日。即应受持作是言。我是最下僧伽梨九条作持。余残物及先僧伽梨。应与人若作净若受持。若比丘初日得衣。用作郁多罗僧七条。成分别若干长若干短。总说七条。作衣竟日。即应受持作是言。我是郁多罗僧七条作持。余残物及先郁多罗僧。应与人若作净若受持。若比丘初日得衣。用作安陀卫五条。成分别若干长若干短。总说五条。作衣竟日。即应受持作是言。我是安陀卫五条作持。余残物及先安陀卫。应与人若作净若受持。若比丘得新衣。二重作僧伽梨。一重作郁多罗僧。一重作安陀卫。二重作尼师坛。若欲三重作僧伽梨。三重作尼师坛。若更以新衣重缝。是比丘重缝衣故。突吉罗。若过十日。尼萨耆波夜提。若比丘得故衣。作四重僧伽梨。二重郁多罗僧。二重安陀卫。四重尼师坛。若更以新衣重缝。是比丘重缝衣故。突吉罗。若过十日。尼萨耆波逸提。若比丘得新衣。二重作僧伽梨。二重尼师坛。若三重僧伽梨。三重尼师坛。若还摘却作是念。是衣若与人若作净若受持。还摘衣突吉罗。若过十日。尼萨耆波夜提。若比丘得故衣。四重作僧伽梨。二重郁多罗僧。二重安陀卫。四重尼师坛。若还摘却作是念。若与人若作净若受持。还摘衣故。突吉罗。若过十日。尼萨耆波夜提。若比丘得新衣。二重作僧伽梨。二重尼师坛。若三重僧伽梨。三重尼师坛。若还摘却作是念。若浣若染。若转易表里。还摘衣故。突吉罗。若过十日。无犯。若比丘得故衣。四重作僧伽梨。二重郁多罗僧。二重安陀卫。四重尼师坛。若还摘却作是念。若浣若染。若转易表里。还摘衣故。突吉罗。若过十日。无犯。若比丘有舍堕衣。未舍罪未悔过。次续未断。若更得衣。是后衣本衣因缘故。得尼萨耆波夜提。复次比丘有舍堕衣。已舍罪未悔过。次续未断。若更得衣。是后衣本衣因缘故。得尼萨耆波逸提。复次比丘有舍堕衣。已舍罪已悔过。次续未断。若更得衣。是后衣本衣因缘故。得尼萨耆波夜提。若比丘有舍堕衣。已舍罪已悔过。次续已断。若更得衣。无犯(一事竟)

佛在王舍城。尔时六群比丘。处处留衣。着上下衣游行诸国。趣着弊衣无有威仪。诸受寄旧比丘。与六群比丘。架上取衣舒晒抖擞卷牒着衣囊中系举。以是因缘妨废读经坐禅行道。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘呵责六群比丘。云何名比丘。处处留衣。着上下衣游行诸国。趣着弊衣无有威仪。诸受寄旧比丘与汝。架上取衣舒晒抖擞。卷牒着衣囊中系举。以是因缘妨废读经坐禅行道。诸比丘如是呵已。向佛广说。佛以是事集比丘僧。佛知而故问六群比丘。汝实作是事不。答言。实作世尊。佛以种种因缘呵责六群比丘。云何名比丘。处处留衣。着上下衣游行诸国。趣着弊衣无有威仪。诸受寄旧比丘与汝。架上取衣舒晒抖擞。卷牒着衣囊中系举。以是因缘妨废读经坐禅行道。佛以是事种种因缘呵已。语诸比丘。以十利故。与诸比丘结戒。从今是戒应如是说。若比丘衣竟舍迦絺那衣已三衣中若离一衣。乃至一夜宿。尼萨耆波逸提。除僧羯磨。一夜者。从日没至明相未出。三衣中若离一衣者。若离僧伽梨。若离郁多罗僧。若离安陀卫。除僧羯磨者。僧羯磨名如大迦叶。以因缘故。留僧伽梨耆阇崛山中。着上下衣来入竹园。时遇天雨。不得还上耆阇崛山。离僧伽梨宿。是大迦叶语诸比丘。我以因缘故。留僧伽梨耆阇崛山中。今遇天雨不得还山。离僧伽梨宿。今当云何。诸比丘以是事白佛。佛以是事集比丘僧。佛知而故问大迦叶。汝实留僧伽梨山中。着上下衣来入竹园。时天雨不得还山。是事问诸比丘。我留僧伽梨耆阇崛山中。着上下衣来入竹园。今遇天雨不得还山。今当云何。汝实尔不。答言。实尔世尊。佛以种种因缘赞戒赞持戒。赞戒赞持戒已。语诸比丘。从今日听一布萨共住处结不离衣羯磨。不离衣羯磨法者。一心和合僧。一比丘应僧中唱。大德僧听。是一布萨共住处。僧先所结共布萨界是中除聚落及聚落界。取空地及住处。若僧时到僧忍听。僧一布萨共住处。作不离衣羯磨。白如是。大德僧听。是一布萨共住处。僧先所结共布萨界。是中除聚落及聚落界。取空地及住处。作不离衣羯磨。谁诸长老忍是一布萨共住处作不离衣羯磨者默然。谁不忍者是长老说。僧已结一布萨共住处作不离衣羯磨竟。僧忍默然故。是事如是持。是名除僧羯磨。复有僧羯磨。如长老舍利弗病。欲一月游行诸国。僧伽梨重。时舍利弗语诸比丘。我欲一月游行。我今有病。僧伽梨重。今当云何。诸比丘以是事白佛。佛以是因缘集比丘僧。知而故问舍利弗。汝实语诸比丘。我欲一月游行。今我有病。僧伽梨重。今当云何。汝实。尔不答言。实尔世尊佛以种种。因缘赞戒赞持戒赞戒。赞持戒已。语诸比丘。从今听老比丘病比丘。作一月不离僧伽梨宿羯磨。乞羯磨法者。是老病比丘。僧和合时。偏袒右肩脱革屣胡跪合掌言。诸长老忆念。我某甲比丘老病。欲一月游行僧伽梨重。今从僧乞一月不离僧伽梨宿羯磨。僧怜愍故。与我一月不离僧伽梨宿羯磨。如是三说。是中僧应筹量。若是比丘言我老病。而实不老不病。不应与。若实老实病。应与。若言僧伽梨重。而实不重。不应与。若实重应与。与法者。僧一心和合。一比丘僧中。唱大德僧听。是某甲比丘老病。欲一月游行僧伽梨重。若僧时到僧忍听。僧与某甲比丘老病一月不离僧伽梨宿羯磨。白如是。如是白二羯磨。僧已与某甲比丘老病一月不离僧伽梨宿羯磨竟。僧忍默然故。是事如是持。乃至九月亦尔。如僧伽梨若郁多罗僧安陀卫亦如是。是中若未结不离衣法。比丘在聚落。衣亦在聚落。比丘应至衣所。若比丘在聚落。衣在阿练若处。比丘应至衣所。若比丘在阿兰若处。衣在聚落。比丘应至衣所。若比丘在阿兰若处。衣亦在阿兰若处。比丘应至衣所。若已结不离衣法。若比丘在聚落。衣亦在聚落。比丘应至衣所。若比丘在聚落。衣在阿兰若处。比丘应出聚落界。若比丘在阿兰若处。衣在聚落。比丘应至衣所。若比丘在阿兰若处。衣亦在阿兰若处。不犯。聚落者。若一家二家众多家。有居士共妻子奴婢人民共住。是名聚落。聚落有一界亦有别界。一家中亦有一界有别界。不相接聚落界者。若鸡飞所及处。若弃粪扫所及处。若有惭愧人所大便处。若箭射所及处。若比丘在一聚落。衣在余聚落。比丘应取衣来。若至衣所。若受余衣。若不取衣来。不至衣所。不受余衣。至地了时。尼萨耆波逸提。相接聚落界者。若容十桄梯。若十二桄梯。若容载梁车回转。若聚落有墙壁篱围绕外至几许名为界。是中界者。谓墙外容作事处。若聚落有堑围绕。外至几许名为界。是中界者。谓掷粪扫所及处。若比丘在一聚落。衣在余聚落。比丘应取衣来。若至衣所。若受余衣。若不取衣来。不至衣所。不受余衣。至地了时。尼萨耆波逸提。同族有一界亦有别界。是中同族别界者。谓门屋食堂中庭厕处取水处。若比丘在一族。衣在余族。比丘应取衣来。若至衣所。若受余衣。若不取衣来。不至衣所。不受余衣。至地了时。尼萨耆波逸提。家有一界亦有别界。是中别界者。谓户处食处中庭厕处取水处。若比丘在一家。衣在余家。应取衣来。若至衣所。若受余衣。若不取衣来。不至衣所。不受余衣。至地了时。尼萨耆波逸提。重阁舍有一界有别界。是中界者。谓中重下重。是上重界。一户入故。中重上重是下重界。一户入故。下重是中重界。一户入故。若比丘在异重。衣在异重。比丘应取衣来。若至衣所。若受余衣。若不取衣来。不至衣所。不受余衣。至地了时。尼萨耆波逸提。若是重阁属一人者。无犯。外道人舍有一界亦有别界。外道名阿视毗尼揵子老弟子梵志等。除佛五众。余残出家人皆名外道。是外道舍界者。谓门屋食堂中庭厕处取水处。若比丘在一外道舍。衣在余外道舍。应取衣来。若至衣所。若受余衣。若不取衣来。不至衣所。不受余衣。至地了时。尼萨耆波逸提。若诸外道同见同论。无犯。轮行人处有一界有别界。轮行人若伎人。歌舞人。踯绝人。相打人。相扑人。俳笑人。以粗轮载财物。细轮载妻子。游行诸国营轮住宿。是中界者。谓门处食处中[這-言+(序-予+手)]厕处取水处。若比丘在一家。衣在余家。应取衣来。若至衣所。若受余衣。若不取衣来。不至衣所。不受余衣。至地了时。尼萨耆波逸提。若是轮行人属一人者。无犯。场处有一界有别界。是中界者。谓门处食处中庭厕处取水处。若比丘在一场。衣在余场。应取衣来。若至衣所。若受余衣。若不取衣来。不至衣所。不受余衣。至地了时。尼萨耆波逸提。场舍有一界有别界。是中界者。谓门处食处中庭厕处取水处。若比丘在一场舍。应在余场舍。应取衣来。若至衣所。若受余衣。若不取衣来。不至衣所。不受余衣。至地了时。尼萨耆波夜提。园有一界有别界。是中界者。谓门处食处中庭厕处取水处。若比丘在一园中。衣在余园。应取衣来。若至衣所。若受余衣。若不取衣来。不至衣所。不受余衣。至地了时。尼萨耆波夜提。园舍有一界有别界。是中界者。谓门处食处中庭厕处取水处。若比丘在一园舍。衣在余园舍。应取衣来。若至衣所。若受余衣。若不取衣来。不至衣所。不受余衣。至地了时。尼萨耆波夜提。车行有一界有别界。是中前车界者。谓向中车杖所及处。中车界者。谓向前车后车杖所及处。后车界者。谓向中车杖所及处。若比丘在一车界。衣在余车界。应取衣来。若至衣所。若受余衣。若不取衣来。不至衣所。不受余衣。至地了时。尼萨耆波逸提。单船有一界有别界。是中单船界者。谓船所系处。若柱若橛若板处。若比丘在一船。衣在余船。应取衣来。若至衣所。若受余衣。若不取衣来。不至衣所。不受余衣。至地了时。尼萨耆波逸提。舫船界亦如是。树有一界有别界。是中不相接树界者。若日中时影所阴处。若雨堕时水不及着枝叶处。若比丘在一树下。衣在余树下。应取衣来。若至衣所。若受余衣。若不取衣来。不至衣所。不受余衣。至地了时。尼萨耆波逸提。相接树界者。若是诸树枝叶相接。乃至一拘卢舍。是中随所著衣至地了时。无犯。四十九寻衣角。如比丘与和上阿阇梨担衣道中行。若在前若在后。四十九寻内不离。若过四十九寻。至地了时。尼萨耆波夜提。有诸比丘。持衣钵着一处。在衣四边卧。是中一比丘若起去。离可得还取处。至地了时。尼萨耆波夜提。有比丘二界中卧衣离身乃至半寸堕他界中得突吉罗罪。若衣一角在身上。无犯(二事竟)

佛在王舍城。尔时六群比丘。得非时衣畜。作是念。是不相似留置。若得相似者当作成衣。是六群比丘。若先得青衣后得黄衣。作是念。不相似留置。若先得黄衣。后得赤衣白衣麻衣野麻衣刍摩衣憍奢耶衣翅夷罗衣钦婆罗衣劫贝衣。得已作是念。不相似留置。若得相似者当作成衣。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘呵责六群比丘。云何名比丘。得非时衣畜。以不相似故留置。若得相似者当作成衣。先得青衣后得黄衣。作是念。不相似留置。若先得黄衣。后得赤衣白衣麻衣野麻衣刍摩衣憍奢耶衣翅夷罗衣钦婆罗衣劫贝衣。得已作是念。不相似留置。若得相似者当作成衣。如是诸比丘种种因缘呵责已。是事白佛。佛以是事集比丘僧。知而故问六群比丘。汝实作是事不。答言。实作世尊。佛以种种因缘呵责六群比丘。云何名比丘。得非时衣畜。以不相似故留置。若得相似者当作成衣。若先得青衣后得黄衣。作是念。不相似留置。若先得黄衣。后得赤衣白衣麻衣野麻衣刍摩衣奢施耶衣翅夷罗衣钦婆罗衣劫贝衣。得已作是念。不相似留置。若得相似者当作成衣。佛如是种种因缘呵已。语诸比丘。以十利故。与诸比丘结戒。从今是戒应如是说。若比丘衣竟。已舍迦絺那衣。若得非时衣。比丘须者当自手取速作衣持。若足者善。若不足者。更望得衣令具足故。停是衣乃至一月。过是停者。尼萨耆波夜提。非时者。谓除别房衣家中施衣除安居衣。余残衣名非时衣。自手取速作受持者。是衣若作僧伽梨。若作郁多罗僧。若作安陀卫。更望得衣者。此比丘作是念。若母与我。若父若兄弟。姊妹儿女。本第二。若有般阇婆瑟会(五岁会也)若有沙婆婆瑟会。(六岁会也)若二月会。若入舍会。我此一月中。会当能集成是衣。不足令足者。若僧伽梨少。若郁多罗僧少。若安陀卫少。作令具足。是中犯者。若比丘得不具足衣。停更望得衣故。是比丘随得衣日。即作是念。我十日所望必不能得。是衣十日应作衣。若与人。若作净。若受持。若不作衣。不与人。不作净。不受持。至十一日地了时。尼萨耆波逸提。又比丘得不具足衣。停更望得衣故。至二日作是念。我九日所望必不能得。是衣九日应作衣。若与人。若作净。若受持。若不作衣。不与人。不作净。不受持。至十一日地了时。尼萨耆波逸提。又比丘得不具足衣。停更望得衣故。至三日作是念。我八日所望必不能得。是衣八日内。应作衣若与人若作净若受持。若不作衣不与人不作净不受持。至十一日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至四日作是念。我七日所望必不能得。是衣七日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十一日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至五日作是念。我六日所望必不能得。是衣六日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十一日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至六日作是念。我五日所望必不能得。是衣五日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十一日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至七日作是念。我四日所望必不能得。是衣四日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十一日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至八日作是念。我三日所望必不能得。是衣三日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十一日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至九日作是念。我二日所望必不能得。是衣二日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十一日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十日作是念。我一日所望必不能得。是衣一日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十一日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十一日。作是念。我此十一日所望必不能得。是衣十一日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十二日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十二日。作是念。我此十二日所望必不能得。是衣十二日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十三日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十三日。作是念。我此十三日所望必不能得。是衣十三日应即作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十四日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十四日。作是念。我此十四日所望必不能得。是衣十四日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十五日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十五日。作是念。我此十五日所望必不能得。是衣十五日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十六日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十六日。作是念。我此十六日所望必不能得。是衣十六日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十七日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十七日。作是念。我此十七日所望必不能得。是衣十七日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十八日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十八日。作是念。我此十八日所望必不能得。是衣十八日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十九日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十九日。作是念。我此十九日所望必不能得。是衣十九日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十日。作是念。我此二十日所望必不能得。是衣二十日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十一日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十一日。作是念。我此二十一日所望必不能得。是衣二十一日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十二日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十二日。作是念。我此二十二日所望必不能得。是衣二十二日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十三日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十三日。作是念。我此二十三日所望必不能得。是衣二十三日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十四日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十四日。作是念。我此二十四日所望必不能得是衣二十四日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十五日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十五日。作是念。我此二十五日所望必不能得。是衣二十五日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十六日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十六日。作是念。我此二十六日所望必不能得。是衣二十六日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十七日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十七日。作是念。我此二十七日所望必不能得。是衣二十七日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十八日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十八日。作是念。我此二十八日所望必不能得。是衣二十八日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十九日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十九日。作是念。我此二十九日所望必不能得。是衣二十九日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至三十日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至三十日。作是念。我此三十日所望必不能得。是衣三十日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至三十一日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。即停衣日不得所望。非望而得。是衣十日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十一日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二日不得所望。非望而得。是衣九日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十一日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。乃至九日不得所望。非望而得。是衣二日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十一日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。乃至十日不得所望。非望而得。是衣一日应即作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十一日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十一日不得所望。非望而得。是衣十一日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十二日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十二日不得所望。非望而得。是衣十二日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十三日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十三日不得所望。非望而得。是衣十三日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十四日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十四日不得所望。非望而得。是衣十四日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十五日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十五日不得所望。非望而得。是衣十五日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十六日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十六日不得所望。非望而得。是衣十六日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十七日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十七日不得所望。非望而得。是衣十七日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十八日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十八日不得所望。非望而得。是衣十八日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十九日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十九日不得所望。非望而得。是衣十九日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十日不得所望。非望而得。是衣二十日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十一日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十一日不得所望。非望而得。是衣二十一日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十二日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十二日不得所望。非望而得。是衣二十二日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十三日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十三日不得所望。非望而得。是衣二十三日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十四日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十四日不得所望。非望而得。是衣二十四日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十五日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十五日不得所望。非望而得。是衣二十五日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十六日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十六日不得所望。非望而得。是衣二十六日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十七日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十七日不得所望。非望而得。是衣二十七日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十八日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十八日不得所望。非望而得。是衣二十八日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十九日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十九日不得所望。非望而得。是衣二十九日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至三十日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至三十日不得所望。非望而得。是衣三十日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至三十一日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。即得衣日断所望得。非望而得。是衣十日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十一日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二日断所望得。非望而得。是衣九日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十一日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至三日断所望得。非望而得。是衣八日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十一日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。乃至九日断所望得。非望而得。是衣二日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十一日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十日断所望得。非望而得。是衣十日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十一日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十一日断所望得。非望而得。是衣十一日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十二日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十二日断所望得。非望而得。是衣十二日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十三日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十三日断所望得。非望而得。是衣十三日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十四日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十四日断所望得。非望而得。是衣十四日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十五日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十五日断所望得。非望而得。是衣十五日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十六日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十六日断所望得。非望而得。是衣十六日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十七日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十七日断所望得。非望而得。是衣十七日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十八日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十八日断所望得。非望而得。是衣十八日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十九日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十九日断所望得。非望而得。是衣十九日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十日断所望得。非望而得。是衣二十日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十一日地了时。尼萨耆波夜提。又比丘得不具足衣停更望得衣故。至二十一日断所望得。非望而得。是衣二十一日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十二日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十二日断所望得。非望而得。是衣二十二日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十三日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十三日断所望得。非望而得。是衣二十三日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十四日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十四日断所望得。非望而得。是衣二十四日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十五日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十五日断所望得。非望而得。是衣二十五日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十六日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十六日断所望得。非望而得。是衣二十六日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十七日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十七日断所望得。非望而得。是衣二十七日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十八日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十八日断所望得。非望而得。是衣二十八日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十九日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十九日断所望得。非望而得。是衣二十九日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至三十日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至三十日断所望得。非望而得。是衣三十日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至三十一日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。即得衣日不得所望。不断所望。非望而得。是衣十日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十一日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二日不得所望。不断所望。非望而得。是衣九日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十一日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至三日不得所望。不断所望。非望而得。是衣八日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十一日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。乃至九日不得所望。不断所望。非望而得。是衣二日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十一日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十日不得所望。不断所望。非望而得。是衣一日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十一日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十一日不得所望。不断所望。非望而得。是衣十一日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十二日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十二日不得所望。不断所望。非望而得。是衣十二日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十三日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十三日不得所望。不断所望。非望而得。是衣十三日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十四日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十四日不得所望。不断所望。非望而得。是衣十四日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十五日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十五日不得所望。不断所望。非望而得。是衣十五日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十六日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十六日不得所望。不断所望。非望而得。是衣十六日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十七日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十七日不得所望。不断所望。非望而得。是衣十七日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十八日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十八日不得所望。不断所望。非望而得。是衣十八日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十九日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得持故。至十九日不得所望。不断所望。非望而得。是衣十九日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十日不得所望。不断所望。非望而得。是衣二十日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十一日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十一日不得所望。不断所望。非望而得。是衣二十一日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十二日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十二日不得所望。不断所望。非望而得。是衣二十二日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十三日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十三日不得所望。不断所望。非望而得。是衣二十三日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十四日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十四日不得所望。不断所望。非望而得。是衣二十四日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十五日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十五日不得所望。不断所望。非望而得。是衣二十五日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十六日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十六日不得所望。不断所望。非望而得。是衣二十六日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十七日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十七日不得所望。不断所望。非望而得。是衣二十七日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十八日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十八日不得所望。不断所望。非望而得。是衣二十八日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十九日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十九日不得所望。不断所望。非望而得。是衣二十九日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至三十日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至三十日不得所望。不断所望。非望而得。是衣三十日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至三十一日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。即得衣日作是念。我此三十日所望必不能得。是衣十日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十一日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二日作是念。我此二十九日所望必不能得。是衣九日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十一日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至三日作是念。我二十八日所望必不能得。是衣八日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十一日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。乃至九日作是念。我二十二日所望必不能得。是衣二日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十一日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十日作是念。我二十一日所望必不能得。是衣一日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十一日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十一日作是念。我二十日所望必不能得。是衣十一日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十二日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。十二日作是念。我十九日所望必不能得。是衣十二日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十三日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十三日作是念。我十八日所望必不能得。是衣十三日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十四日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十四日作是念。我十七日所望必不能得。是衣十四日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十五日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十五日作是念。我十六日所望必不能得。是衣十五日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十六日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十六日作是念。我十五日所望必不能得。是衣十六日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十七日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十七日作是念。我十四日所望必不能得。是衣十七日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十八日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至十八日作是念。我十三日所望必不能得。是衣十八日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至十九日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得得故。至十九日作是念。我十二日所望必不能得。是衣十九日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十日作是念。我十一日所望必不能得。是衣二十日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十一日地了时。尼萨耆波夜提又比丘得不具足衣。停更望得衣故。至二十一日作是念。我十日所望必不能得。是衣二十一日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十二日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十二日作是念。我九日所望必不能得。是衣二十二日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十三日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十三日作是念。我八日所望必不能得。是衣二十三日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十四日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十四日作是念。我七日所望必不能得。是衣二十四日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十五日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十五日作是念。我六日所望必不能得。是衣二十五日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十六日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十六日作是念。我五日所望必不能得。是衣二十六日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十七日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十七日作是念。我四日所望必不能得。是衣二十七日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十八日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十八日作是念。我三日所望必不能得。是衣二十八日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至二十九日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至二十九日作是念。我二日所望必不能得。是衣二十九日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至三十日地了时。尼萨耆波夜提。又比丘得不具足衣。停更望得衣故。至三十日作是念。我一日所望必不能得。是衣三十日应作衣。若与人若作净若受持。若不作衣不与人不作净不受持。至三十一日地了时尼萨耆波夜提。又比丘得不具足衣。停更望多衣故。即得衣日不得所望。亦不断望。非望而许。复勤求所望。是望亦断。非望更得。是衣十日应作衣。若足者善。若不足者留。又比丘得不具足衣。停更望多衣故。至二日不得所望。亦不断望。非望而许。复勤求所望。是望亦断。非望更得。是衣九日应作衣。若足者善。不足者留。又比丘得不具足衣。停更望多衣故。乃至九日不得所望。亦不断望。非望而许。复勤求所望。是望亦断。非望更得。是衣二日应作衣。若足者善。不足者留。又比丘得不具足衣。停更望多衣故。至十日不得所望。亦不断望。非望而许。复勤求所望。是望亦断。非望更得。是衣十日应作衣。若足者善。不足者留。又比丘得不具足衣。停更望多衣故。至十一日不得所望。亦不断望。非望而许。复勤求所望。是望亦断。非望更得。是衣十一日应作衣。若足者善。不足者留。又比丘得不具足衣。停更望多衣故。至十二日不得所望。亦不断望。非望而许。复勤求所望。是望亦断。非望更得。是衣十二日即应作衣。若足者善。不足者留。又比丘得不具足衣。停更望多衣故。至十三日不得所望。亦不断望。非望而许。复勤求所望。是望亦断。非望更得。是衣十三日应作衣。若足者善。不足者留。又比丘得不具足衣。停更望多衣故。至十四日不得所望。亦不断望。非望而许。复勤求所望。是望亦断。非望更得。是衣十四日应作衣。若足者善。不足者留。又比丘得不具足衣。停更望多衣故。至十五日不得所望。亦不断望。非望而许。复勤求所望。是望亦断。非望更得。是衣十五日应作衣。若足者善。不足者留。又比丘得不具足衣。停更望多衣故。至十六日不得所望。亦不断望。非望而许。复勤求所望。是望亦断。非望更得。是衣十六日应作衣。若足者善。不足者留。又比丘得不具足衣。停更望多衣故。至十七日不得所望。亦不断望。非望而许。复勤求所望。是望亦断。非望更得。是衣十七日应作衣。若足者善。不足者留。又比丘得不具足衣。停更望多衣故。至十八日不得所望。亦不断望。非望而许。复勤求所望。是望亦断。非望更得。是衣十八日应作衣。若足者善。不足者留。又比丘得不具足衣。停更望多衣故。至十九日不得所望。亦不断望。非望而许。复勤求所望。是望亦断。非望更得。是衣十九日应作衣。若足者善。不足者留。又比丘得不具足衣。停更望多衣故。至二十日不得所望。亦不断望。非望而许。复勤求所望。是望亦断。非望更得。是衣二十日应作衣。若足者善。不足者留。又比丘得不具足衣。停更望多衣故。至二十一日不得所望。亦不断望。非望而许。复勤求所望。是望亦断。非望更得。是衣二十一日应作衣。若足者善。不足者留。又比丘得不具足衣。停更望多衣故。至二十二日不得所望。亦不断望。非望而许。复勤求所望。是望亦断。非望更得。是衣二十二日应作衣。若足者善。不足者留。又比丘得不具足衣。停更望多衣故。至二十三日不得所望。亦不断望。非望而许。复勤求所望。是望亦断。非望更得。是衣二十三日应作衣。若足者善。不足者留。又比丘得不具足衣。停更望多衣故。至二十四日不得所望。亦不断望。非望而许。复勤求所望。是望亦断。非望更得。是衣二十四日应作衣。若足者善。不足者留。又比丘得不具足衣。停更望多衣故。至二十五日不得所望。亦不断望。非望而许。复勤求所望。是望亦断。非望更得。是衣二十五日应作衣。若足者善。不足者留。又比丘得不具足衣。停更望多衣故。至二十六日不得所望。亦不断望。非望而许。复勤求所望。是望亦断。非望更得。是衣二十六日应作衣。若足者善。不足者留。又比丘得不具足衣。停更望多衣故。至二十七日不得所望。亦不断望。非望而许。复勤求所望。是望亦断。非望更得。是衣二十七日应作衣。若足者善。不足者留。又比丘得不具足衣。停更望多衣故。至二十八日不得所望。亦不断望。非望而许。复勤求所望。是望亦断。非望更得。是衣二十八日应作衣。若足者善。不足者留。又比丘得不具足衣。停更望多衣故。至二十九日不得所望。亦不断望。非望而许。复勤求所望。是望亦断。非望更得。是衣二十九日应作衣。若足者善。不足者留。又比丘得不具足衣。停更望多衣故。至三十日不得所望。亦不断望。非望而许。复勤求所望。是望亦断。非望更得。是衣三十日应作衣。若足者善。不足者留。若比丘有舍堕衣。未舍罪未悔过。次续不断更得衣。尼萨耆波夜提。本衣因缘故。又比丘有舍堕衣。已舍罪未悔过。次续不断更得衣。尼萨耆波夜提。本衣因缘故。又比丘有舍堕衣。已舍罪已悔过。次续不断更得衣。尼萨耆波夜提。本衣因缘故。又比丘有舍堕衣。已舍罪已悔过。次续已断更得衣。不犯。佛在舍卫国。与大比丘众安居。尔时诸比丘多得布施衣畜。佛欲制诸比丘多畜衣故。语安居比丘。我欲制诸比丘多畜衣故。语安居比丘。我欲四月燕坐。令诸比丘不得来至我所。除一送食比丘及布萨。诸安居比丘受佛教。还众中立如是制。若比丘非一送食及布萨至佛所者。得波夜提罪。立是制已。白佛。佛默然可之。尔时长老优波斯那。与多比丘众五百人俱。皆阿练儿。着纳衣一食乞食空地坐。来去坐卧。视瞻进止威仪清净。持僧伽梨执钵安庠。从憍萨罗游行到舍卫国。时多比丘只桓门间经行。长老优波斯那问诸比丘。佛今所在。诸比丘言。佛在彼东向大房。一板为户内。若欲往者随意。时长老忧波斯那。往大房所。到已謦欬以指扣户。佛与开户。长老优波斯那。即入大房舍内到佛所。头面礼足一面坐。佛知故问言。汝徒众清净善好。汝众何因缘故清净威仪。答言。世尊。若比丘来至我所。求读诵经求依止者。我语是比丘。汝能尽形作阿练儿。着粪扫衣乞食一食空地坐。我当教汝读经与汝依止。若比丘能行是头陀法者。我教读经与依止。以是故。世尊。我徒众威仪清净。佛问优波斯那。旧比丘立制。汝知不。答言。不知世尊。旧比丘云何立制。佛语优波斯那。我欲四月燕坐。语诸比丘。汝诸比丘不得来至我所。除一送食及布萨。诸比丘受我语。还众中立制。若比丘非一送食及布萨往佛所。得波夜提罪。诸比丘立制已来语我。我即默然可之。优波斯那言。世尊。旧比丘知此意不。佛言。何以不知。佛言。我从今听阿练儿着粪扫衣头陀比丘。若送食不送食。若布萨不布萨。随意来至我所。旧比丘闻长老优波斯那非送食非布萨欲见佛故便到佛所。闻已集比丘僧。集已。唤优波斯那来。众僧已集。尔时长老优波斯那。即到僧中头面礼上坐足。随次坐已。旧比丘问优波斯那。汝知旧比丘立制不。答言。不知。问上坐言。旧比丘立制云何。答言。优波斯那。佛语安居比丘。我欲四月燕坐。诸比丘不得来至我所。除一送食及布萨。我等受佛教立制。若比丘非一送食非布萨。往佛所者。得波夜提罪。佛即默然可之。汝优波斯那。非一送食非布萨。往到佛所。得波夜提罪。汝应如法悔过。汝当发露。是罪莫覆藏。优波斯那言。上座知不。我到佛所头面礼足一面坐已。佛知故问我言。优波斯那。汝徒众何因缘故威仪清净。我言。世尊。若有比丘来至我所。求读诵经若求依止。我语是比丘。汝能尽形作阿练儿。着粪扫衣乞食一食空地坐。我当教汝读经与汝依止。若比丘能行是头陀法者。我教读经与依止。以是故。世尊。我徒众威仪清净。佛问我言。旧比丘立制。汝知不。答言。不知世尊。云何立制。佛言。优波斯那。我欲四月燕坐。语诸比丘。令诸比丘不得来至我所。除一送食及布萨。诸比丘受我语。还众立制。若比丘非一送食非布萨往佛所者。犯波夜提。我即可之。我言。世尊。彼旧比丘知此意不。佛言。何以不知。佛言。我从今听阿练儿着纳衣头陀比丘。若一送食非送食。若布萨非布萨。随意来至我所。尔时诸比丘作是念。我等何不舍居士衣着纳衣耶。即时诸比丘舍居士衣。皆着粪扫衣(三事竟)

十诵律卷第五

此卷第二十六张第二行夜提(之下)乃至三十日皆如上说者。丹本无此中九字。而有又比丘得不具足衣(乃至)至三十日地了时尼萨耆波夜提等凡九十一行文。国本宋本并无者。今依丹本遆而足之

同卷二十七张第十三行。即今正本第三十一张第十三行。尼萨耆波夜提(之下)十二日乃至三十日亦如上说者。丹本无此中十二字。而有又比丘得不具足衣停更望得(乃至)至三十日地了时尼萨耆波夜提(等凡)九十二行文。国本宋本并无者。今依丹本遆而足之

同卷第二十九张第四行。即今正本第三十七张第四行。尼萨耆波夜提(之下)十二日乃至三十日皆如上说者。丹本无此中十二字。而有又比丘得不具足衣(乃至)尼萨耆波夜提(等凡)九十七行文。国本宋本所无者。今依丹本遆而足之十诵律卷第六(初诵之六)

        后秦北印度三藏弗若多罗译

    明三十尼萨耆法之二

佛在舍卫国。尔时华色比丘尼。晨朝时到着衣持钵入城乞食。食已入安和林中。在树下端身政。坐威仪清净。时有五百群贼。先入林中。是贼主信佛法。见华色比丘尼端身政坐威仪清净。见已生清净信心。我何不以一丳肉与是比丘尼令啖。是贼中更有少知法者言。此比丘尼是时食人。不非时食。贼主闻已信心转深。是比丘尼端身政坐威仪清净。时食不非时食。我何不以一丳肉令明日食。少知法者言。是比丘尼随得而食。不留余宿食食。时贼主于比丘尼倍生信心。是比丘尼端身政坐威仪清净。时食不非时食。随得而食。不留余宿食食。我何不以一贵价[疊*毛]裹一丳肉悬着树上为是比丘尼故。作是念。若有沙门婆罗门。取者即以施与。作是念已。即以贵价[疊*毛]裹肉悬着树上。作是言。诸沙门婆罗门。须者即以施与。时夜过已。华色比丘尼作是言。贼因我故。以[疊*毛]裹肉悬着树上。作是言。若沙门婆罗门须者以施与。我不应啖此肉。当持与僧。[疊*毛]当自取。即持是肉至只桓中。问作食人处。以肉与已。出只桓去。时六群比丘。见华色比丘尼持好[疊*毛]出。见已生贪心。语言。汝[疊*毛]细好。比丘尼答言。细好比丘尼答言细好已。六群比丘言。好何不施与好人。比丘尼作是念。是决定索。云何不与。即以[疊*毛]与六群比丘。是比丘尼深言敬佛。作是念。我不应不见佛便还入城。作是念已。即向佛所。尔时世尊。与诸大众围绕说法。佛遥见华色比丘尼来衣服弊坏。佛知而故问阿难。是华色比丘尼何以衣弊坏。不能得布施衣耶。阿难言。适得贵价[疊*毛]。佛言。今在何处。何难言。六群比丘索去。佛知故问阿难。比丘实从非亲里比丘尼取衣耶。答言。实取世尊。佛即语阿难。盈长衣中取五衣与是比丘尼。阿难言尔。即盈长衣中取五衣与之。比丘尼即着是衣。来诣佛所。头面礼足在一面立。佛与说法示教利喜。示教利喜已默然。华色比丘尼。闻佛说法示教利喜。头面礼足绕佛而去。去不久。佛以是事集比丘僧。佛知而问六群比丘。汝实作是事不。答言。实作世尊。佛以种种因缘呵责六群比丘。云何名比丘。从非亲里比丘尼取衣。非亲里人。不能问衣足不足为长不长。趣得便取。若亲里者。当问衣足不足为长不长。亲里人尚自持衣与。何况不足而取。佛如是种种因缘呵已。语诸比丘以十利故。与比丘结戒。从今是戒应如是说。若比丘从非亲里比丘尼取衣。尼萨耆波逸提。非亲里者。亲里。名母姊妹若女乃至七世因缘。衣者。麻衣赤麻衣白麻衣刍麻衣翅夷罗衣钦婆罗衣劫贝衣。是中犯者。若一比丘。从一非亲里比丘尼取衣。一尼萨耆波逸提。若一比丘。从二三四非亲里比丘尼取衣。随得尔所尼萨耆波逸提。若二比丘。从二三四一非亲里比丘尼取衣。随得尔所尼萨耆波逸提。若三比丘。从三四一二非亲里比丘尼取衣。随得尔所尼萨耆波逸提。若四比丘。从四非亲里比丘尼取衣。得四尼萨耆波逸提。若四比丘。从一二三非亲里比丘尼取衣。随得尔所尼萨耆波逸提

佛在舍卫国。尔时憍萨罗国。有二部僧多得衣。分作二分。比丘得比丘尼所宜衣。比丘尼得比丘所宜衣。比丘得时诸比丘尼语比丘言。诸大德衣与我等。我等所得衣与诸大德。比丘答言。佛结戒不得从非亲里比丘尼取衣。诸比丘不知云何。是事白佛。佛以是事集比丘僧。种种因缘赞戒赞持戒。赞戒赞持戒已。语诸比丘。从今是戒应如是说。若比丘从非亲里比丘尼取衣。除贸易。尼萨耆波逸提。是中犯者。若比丘有非亲里比丘尼。谓是亲里。从取衣者。尼萨耆波逸提。若谓是比丘式叉摩尼沙弥沙弥尼出家出家尼。从取衣者。尼萨耆波逸提。若非亲里比丘尼。比丘生疑。为亲里非亲里。从取衣者。尼萨耆波逸提。若疑。是比丘尼非比丘尼。是式叉摩尼非式叉摩尼。是沙弥非沙弥。是沙弥尼非沙弥尼。是出家非出家。是出家尼非出家尼。从取衣者。尼萨耆波逸提。若比丘有亲里比丘尼。谓非亲里。从取衣者。突吉罗。若谓是比丘尼式叉摩尼沙弥沙弥尼出家出家尼。从取衣者。突吉罗。若比丘有亲里比丘尼。比丘生疑。为亲里非亲里。从取衣者。突吉罗。若疑。是比丘非比丘。是式叉摩尼非式叉摩尼。是沙弥非沙弥。是沙弥尼非沙弥尼。是出家非出家。是出家尼非出家尼。从取衣者。突吉罗。取亲里非亲里。若谓若疑。以不净衣。谓骆驼毛牛毛羖羊毛杂织。突吉罗。不犯者。若亲里。若先请。若别房中住故与。若为说法故与。不犯(四事竟)

佛在舍卫国。尔时长老迦留陀夷。与掘多比丘尼旧相识。共语来往。时迦留陀夷二月游行他国。掘多比丘尼。闻长老迦留陀夷二月游行。掘多比丘尼。闻迦留陀夷二月游行竟还到舍卫国。掘多比丘尼。闻迦留陀夷二月游行还舍卫国已。洗身体庄严面目。香油涂发着轻染衣。到迦留陀夷所。头面礼足在前而坐。时迦留陀夷生染着心。谛视其面。比丘尼亦生染心。视比丘面。比丘尼作是念。此视我面必生染着。我何不在前起行。时迦留陀夷单着泥洹僧。共行来往欲心动发。畏犯戒故不敢相触。谛相视面便失不净。离急热已即还本坐。掘多比丘尼作是念。长老迦留陀夷还坐本处。必失不净。掘多比丘尼还着上衣已。来近迦留陀夷。语迦留陀夷。持是衣来。我当与浣。迦留陀夷更着余衣。脱此衣与比丘尼。比丘尼持是衣小却一面。捩衣取汁着小便处。即时有福德子。来受母胎。腹渐长大。诸比丘尼驱出寺言。是弊恶比丘尼。贼比丘尼。汝新外来耶。旧出家人云何得娠。是比丘尼言。我不作淫欲。如是因缘向诸比丘尼说。诸比丘尼不知云何。是事白佛。佛言。汝等莫呵责此比丘尼。是不破梵行。不犯淫欲。如是因缘故得娠。尔时佛以是事集比丘僧。知而故问迦留陀夷。汝实作是事不。答言。实作世尊。佛种种因缘呵责迦留陀夷。云何名比丘。使非亲里比丘尼浣故衣。佛如是种种因缘呵已。语诸比丘。以十利故。与诸比丘结戒。从今是戒应如是说。若比丘使非亲里比丘尼浣故衣。若染若打。尼萨耆波逸提。非亲里者。亲里。名母姊妹若女乃至七世因缘。故衣者。乃至一经身着。皆名故衣。是中犯者。若比丘语非亲里比丘尼。为我浣是故衣。若染若打。若比丘尼为浣是衣。比丘得尼萨耆波逸提。若染。尼萨耆波逸提。若打。尼萨耆波逸提。若浣染若浣打。若染打若浣染打。皆尼萨耆波逸提。又比丘语非亲里比丘尼。为我浣打是衣。莫染。若比丘尼为浣。比丘得。尼萨耆波逸提。若打若染。若浣染若浣打。若染打若浣染打。皆尼萨耆波逸提。又比丘语非亲里比丘尼。为我浣染是衣。莫打。若为浣。尼萨耆波逸提。若染若打。若浣染若浣打。若染打若浣染打。皆尼萨耆波逸提。又比丘语非亲里比丘尼。为我染打是衣。莫浣。若为染。尼萨耆波逸提。若打。尼萨耆波逸提。若浣若浣染。若浣打若染打。若浣染打。皆尼萨耆波逸提。有比丘语非亲里比丘尼。为我浣打是衣。如染。若为浣。尼萨耆波逸提。若打。尼萨耆波逸提。若染若浣染。若浣打若染打。若浣染打。皆尼萨耆波逸提。有比丘语非亲里比丘尼。为我浣染是衣。如打。若为浣。尼萨耆波逸提。若染若打。尼萨耆波逸提。若浣染若浣打。若染打若浣染打。皆尼萨耆波逸提。有比丘语非亲里比丘尼。为我染打是衣。若浣。若为染。尼萨耆波逸提。若打。尼萨耆波逸提。若浣若浣染。若浣打若染打。若浣染打。皆尼萨耆波逸提。又比丘语非亲里比丘尼。为我浣是衣。莫染莫打。若为浣。尼萨耆波逸提。若染。尼萨耆波逸提。若打若浣染。若浣打若染打。若浣染打。皆尼萨耆波逸提。又比丘语非亲里比丘尼。为我染是衣。莫浣莫打。若为染。尼萨耆波逸提。若浣若打。若浣染若浣打。若染打若浣染打。皆尼萨耆波逸提。又比丘语非亲里比丘尼。为我打是衣。莫浣莫染。若为打。尼萨耆波逸提。若浣若染。若浣染若浣打。若染打若浣染打。皆尼萨耆波逸提。若比丘有非亲里比丘尼。谓是亲里。作是言。为我浣染打是衣。若为浣染打。比丘得尼萨耆波逸提。若谓是比丘是式叉摩尼沙弥沙弥尼出家出家尼。作是言。为我浣染打是衣。若为浣染打。比丘得尼萨耆波逸提。若比丘有非亲里比丘尼。疑为亲里非亲里。语言。为我浣染打是衣。若为浣染打。尼萨耆波逸提。若疑是比丘非比丘式叉摩尼非式叉摩尼沙弥非沙弥沙弥尼非沙弥尼出家非出家出家尼非出家尼。语言。为我浣染打是衣。若为浣染打。尼萨耆波逸提。若比丘有亲里比丘尼。谓非亲里。语言。为我浣染打是衣。若为浣染打。比丘得突吉罗。若谓是比丘式叉摩尼沙弥沙弥尼出家出家尼。语言。为我浣染打是衣。若为浣染打。是比丘得突吉罗。若比丘有亲里比丘尼。生疑是亲里非亲里。语言。为我浣染打是衣。若为浣染打。突吉罗。若疑是比丘非比丘式叉摩尼非式叉摩尼沙弥非沙弥沙弥尼非沙弥尼出家非出家出家尼非出家尼。语言。为我浣染打是衣。若为浣染打。突吉罗。若比丘有亲里非亲里。若谓若疑。以不净衣。谓骆驼毛牛毛羖羊毛杂织衣。使浣者。比丘皆得突吉罗。若亲里不犯(五事竟)

佛在舍卫国。尔时有一居士。着上下衣来到只桓。是跋难陀旧相识。共语共事。跋难陀遥见居士来。着上下衣生贪着心。居士渐至跋难陀所。头面礼足在前坐。跋难陀为说种种法。示教利喜已。作是言。居士。汝是上下衣好。中作比丘僧伽梨郁多罗僧安陀卫。若汝与我者。我能取畜。是居士不闻。或闻不欲与。时跋难陀更种种说异法。示教利喜已。复言汝着上下衣好。中作比丘僧伽梨郁多罗僧安陀卫。汝若与我我能取畜。是居士不闻是语。或闻不欲与。跋难陀更说种种异法。示教利喜已。复语居士言。汝与我一衣来。我等法从居士得衣。居士作是念。此比丘作是决定索。云何不与。即脱一衣卷叠授与。是居士与衣已。心悔嗔恚不忍。作是念言。我不应到沙门释子僧伽蓝中。若居士到中。则强夺衣取。如崄道无异。以是故。不应到沙门释子所。是居士入舍卫城时。守门者见而问言。汝出时着上下衣。今一衣所在。居士即以是因缘向说。说是语时。倍生悔心嗔恨不忍。作是言。不应到沙门释子僧伽蓝中。若到则强夺人衣。如崄道无异。如是一人语二人。二人语三人。展转相语。沙门释子强夺人衣。恶名流布满舍卫城。是中有比丘。少欲知足行头陀。闻是事心不喜。是事白佛。佛以是事集比丘僧。知而故问跋难陀释子。汝实作是事不。答言。实作世尊。佛以种种因缘呵责跋难陀。云何名比丘。非亲里人所。作同意索。佛种种因缘呵责已。语诸比丘。以十利故与诸比丘结戒。从今是戒应如是说。若比丘从非亲里居士居士妇乞衣者。尼萨耆波逸提。非亲里者。亲里名若父母兄弟姊妹儿女乃至七世因缘。除是名非亲里。居士者。名为男子。居士妇者。名为女人。衣者。白麻衣赤麻衣翅夷罗衣钦婆罗衣刍麻衣劫贝衣。是中犯者。有三种。谓价色量价者。若比丘语居士。与我好价衣。若得衣者。尼萨耆波逸提。若不得衣。突吉罗。乃至直二百三百钱价衣与我。若得衣者尼罗耆波逸提。若不得衣突吉罗。是名价。色者。若比丘语居士。与我青衣。若得衣者。尼萨耆波逸提。若不得衣突吉罗。黄赤白黑衣白麻衣赤麻衣翅夷罗衣钦婆罗衣刍麻衣劫贝等衣亦如是。是名色。量者。若比丘语居士。与我四肘衣。若得衣者。尼萨耆波逸提。若不得衣突吉罗。若五肘六肘乃至十八肘衣亦如是。是名量。索此得彼者。突吉罗。若索青得黄衣。突吉罗。若索青得赤白黑亦如是。若比丘索白麻衣。得赤麻衣。突吉罗。乃至索钦婆罗衣。得劫贝衣。突吉罗。不犯者。从亲里索。若先请。若不索自与。无犯

佛在舍卫国。尔时波罗比丘。从憍萨罗国游行。向舍卫国。道中遇贼夺衣。裸形而行。时作是念。佛结戒。不得从非亲里乞衣。我亲里远。今当裸形到舍卫国。即便来入只桓礼旧比丘。旧比丘问。汝何人。答言。我是沙门。何沙门。答言。释子沙门。何故裸形。答言。我道中遇贼夺衣。裸形而来。时作是念。佛结戒。不听从非亲里乞。我亲里远。当裸形到舍卫国。是故我今裸形。次礼到六群比丘所。六群比丘问言。汝何人。答言。沙门。何沙门。答言。释子沙门。何以故裸形。答言。我道中遇贼夺衣。时作是念。佛结戒。不听从非亲里乞。我亲里远。当裸形到舍卫国。是故裸形。六群比丘作是念。以是因缘佛必当听从非亲里乞。我等当亲近是人。六群比丘语言。汝云何裸形到佛所。我当借汝衣到佛所。汝得衣已当还我。答言尔。六群比丘即借衣着。向佛所头面礼足一面坐。诸佛常法。客比丘至。如是劳问。语诸比丘。忍不足不。安乐住不。乞食不乏不。道路不疲极耶。即时佛以是语劳问波罗比丘。忍不足不。安乐住不。乞食不乏不。道路不疲极耶。诸比丘答言。世尊。忍足安乐住乞食不难。但道中疲极。以是事向佛广说。佛以是事集比丘僧。以种种因缘。赞戒赞持戒。赞戒赞持戒已。语诸比丘。从今是戒应如是说。若比丘从非亲里居士居士妇乞衣者。尼萨耆波逸提。除余时。余时者。夺衣失衣烧衣漂衣。是为时。夺衣者。若官夺若贼若怨家若怨党夺。失者。若失不知何所在。若朽烂若虫啮。烧者。若为火烧若日炙。漂衣者。若水漂风飘。是名时(六事竟)

尔时六群比丘闻。佛以是因缘。听比丘从非亲里居士乞。闻已语波罗比丘言。汝等少知少识故无衣。我等多知多识亦少衣。我今为汝故乞。若汝三衣满足者。余残衣尽用与我。波罗比丘言。如是。时六群比丘。即入舍卫城到富贵人舍。赞叹波罗比丘善好。是佛亲里。崄道中遇贼夺衣。汝等当与。即时信者与种种衣。若[疊*毛]俱执钦婆罗。如是展转从一家至一家。多得衣服。裹着肩上持还。六群比丘自取好者。持不好者与波罗比丘。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘呵责六群比丘。云何名比丘。故夺波罗比丘衣。诸比丘种种因缘呵责已。向佛广说。佛以是事集比丘僧。知而故问六群比丘。汝实作是事不。答言。实作世尊。佛以种种因缘呵责六群比丘。云何名比丘。故夺波罗比丘衣。种种因缘呵已语诸比丘。以十利故与诸比丘结戒。从今是戒应如是说。若比丘夺衣失衣烧衣[漂*寸]衣时。从非亲里居士居士妇乞。自恣多与衣。是比丘应取上下衣。若过是取者。尼萨耆波逸提。上下衣者。有二种。有白衣上下衣。有比丘上下衣。白衣上下衣者。一上衣一下衣。比丘上下衣者。所用三衣。若得白衣上下衣。若少应更乞。若多应还主。若得比丘上下衣。若少不应更乞。若多不应还主。是中犯者。若比丘三衣具足不应乞。若乞得者。尼萨耆波逸提。若乞不得。突吉罗。若比丘失一衣。是比丘僧伽梨。可擿作衣者。擿作不应乞。若乞得者。尼萨耆波逸提。若乞不得。突吉罗。若比丘失二衣。是僧伽梨可擿作衣者。应乞一衣。不应乞二衣。若乞得二衣者。尼萨耆波逸提。若乞不得。突吉罗。若比丘失三衣。应从五众所暂借衣着入聚落乞衣。若无是事。是中若有四方僧物。若毡若拘执若褥若班縍若枕。擿作衣着。着是衣已。而乞衣。若乞得衣者。应着新衣当浣先衣綟晒打治还成着本处。若此寺空无人住者。应随着近有僧住处。若先寺还有人住。应取是物还着本处(七事竟)

佛在舍卫国。尔时有一居士。为跋难陀释子办衣直。作是念言。我以是衣直。买如是衣。与跋难陀释子。时跋难陀释子闻已。往到居士所。问言。汝实为我办衣直。作是念言。我以是衣直。买如是衣。与跋难陀释子耶。居士答言。实尔。云何为我作衣。答言。作如是衣。跋难陀释子言好。我等。比丘出家人。少衣服乞求难得。汝等居士不能常有布施因缘。若欲为我作衣者。当为我作如是如是衣。居士言尔。是居士即随先衣直。更办再三倍价衣。与跋难陀释子。后心生悔呵骂言。沙门释子不知时。不知厌足不知筹量。若施者不知量。受者应知量。我本所办衣直更出再三倍。此是我等过罪衰恼无利。何故布施供养如是难满难养无厌足人。是中有比丘。少欲知足行头陀。闻是事心不喜。诸比丘以是事白佛。佛以是事集比丘僧。知而故问跋难陀释子。汝实作是事不。答言。实作世尊。佛以种种因缘呵责跋难陀释子。云何名比丘。非亲里人所。作同意索。种种因缘呵已语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若为比丘故非亲里居士居士妇办衣直。作是念言。我以是衣直买如是衣。与某比丘。是中比丘。先不自恣请。便往居士居士妇所。作同意言。汝为我办如是衣直。买如是如是衣与我。为好故。若得衣者。尼萨耆波逸提。为比丘者。为跋难陀释子故。衣者。白麻衣赤麻衣翅夷罗衣钦婆罗衣刍麻衣憍奢耶衣劫贝衣。衣直者。金银车磲玛瑙钱乃至米谷。办者。以此直物别着一处。如是衣者。如是价如是色如是量。与某比丘者。与跋难陀释子故。先不自恣请者。居士先不语比丘所须来取。作同意者。信是居士随我索多少不嗔。为好者。难满难养无厌足故。是中犯者。有三种。谓价色量。价者。若比丘语居士。与我好衣。若得衣者。尼萨耆波逸提。若不得衣。突吉罗。乃至与我二三百钱价衣。若得衣者。尼萨耆波逸提。若不得衣。突吉罗。是名价。色者。比丘语居士言。与我青衣。若得衣者。尼萨耆波逸提。若不得衣。突吉罗。若言与我黄赤白黑衣白麻衣赤麻衣翅夷罗衣钦婆罗衣刍麻衣憍奢耶衣劫贝衣。若得者。尼萨耆波逸提。若不得衣。突吉罗。是名色。量者。若比丘语居士言。与我四肘衣五肘六肘乃至十八肘衣。若得者。尼萨耆波逸提。若不得衣。突吉罗。是名量。若索此得彼。突吉罗。若索青得黄。突吉罗。若索青得赤白黑亦如是。若索白麻衣得赤麻衣。乃至索钦婆罗衣得劫贝衣亦如是。不犯者。从亲里索。若先请。若不索自与。无犯(八事竟)

佛在舍卫国。尔时跋难陀释子。有二非亲里居士居士妇。为跋难陀。释子办衣直。作是念言。我以是衣直。各各买如是如是衣。与跋难陀释子。跋难陀释子闻已。便往居士居士妇所言。汝等实为我故办衣直。作是念言。我等以是衣直。各各买如是衣。与跋难陀释子不。答言实尔。云何作衣。居士答言。作如是衣。跋难陀释子言善。我等比丘出家人。少衣服乞求难得。汝等不能常有布施因缘。汝今以有好心。为我作如是如是衣。若不能各作者。二人共作一衣与我。答言尔。诸居士居士妇。随所办衣直。更出再三倍作衣。与跋难陀释子。后起悔心呵责。沙门释子难满难养无有厌足。我等衰恼失利。云何布施供养是人。是中有比丘。少欲知足行头陀。闻是事心不喜。诸比丘以是事白佛。佛以是事集比丘僧。知而故问跋难陀。汝实作是事不。答言。实作世尊。佛以是事种种因缘呵责。云何名比丘。非亲里人作同意索。种种因缘呵已。语诸比丘。以十利故与诸比丘结戒。从今是戒应如是说。若比丘二非亲里居士居士妇。各办衣直。作是念言。我以是衣直。各买如是衣与某甲比丘。是中比丘。先不请。便往居士居士妇所。作同意言。汝等各办衣直。合作一衣与我。为好故。若得衣者。尼萨耆波逸提。为比丘者。为跋难陀释子故。衣直为办先不请。如上说。是中犯者。有三种。价色量。价者。若比丘语居士言。与我好衣。二人共作一衣。若得者。尼萨耆波逸提。若说与我好衣。若言二共合。若言二作一衣。若不得衣。突吉罗。乃至与我二三百钱价衣者。尼萨耆波逸提。若不得衣突吉罗。是名价。色者。比丘语居士言。与我青衣若黄赤白黑衣白麻衣赤麻衣翅夷罗衣刍麻衣钦婆罗衣劫贝衣。若得者。尼萨耆波逸提。若言与我好衣。若言二共合。若言作一衣。若不得衣。突吉罗。是名色。量者。比丘语居士言。与我四肘衣五肘衣乃至十八肘衣。得者。尼萨耆波逸提。若言与我好衣。若言二共合。若言作一衣。若不得衣。突吉罗。是名量。若索此得彼。突吉罗。若索青衣得黄衣。突吉罗。若索青得赤白黑。突吉罗。若索白麻衣得赤麻衣。乃至索钦婆罗衣。得劫具衣。突吉罗。不犯者。从亲里索。若先请。若不索自与。无犯(九事竟)

佛在舍卫国。尔时有一居士。遣使送衣直。与跋难陀释子。使持是物来。见跋难陀释子共估客子在市肆中床上坐。使到作是言。大德。某甲居士遣我送是衣直。大德受取。时跋难陀释子闻已。语估客子。汝受是衣直。数取举置。若我得净人。当来取去。估客子即数取举。尔时舍卫国。众人共要聚集一处。若不及者罚钱五十。是估客子应往赴集。时估客子系物着一处。关闭肆户庄严欲去。时跋难陀释子将净人来。语估客子。与我衣直来。答言。是舍卫城。众人有聚集事。我必应往。若不及者罚钱五十。小待我还当与。跋难陀言。不得尔。汝白衣在家常自求利。先与我便去。不得小住。是估客子。开肆户出是衣直。看数付与还归。闻众人聚集已散。即罚钱五十。众人来责。估客子。心生愁恼。呵骂沙门释子。不知时不筹量。若小住者。汝事不废。我不被罚。我坐是沙门释子故失是物。一人语二人二人语三人。如是展转。沙门释子恶名流布。遍舍卫城。是中有比丘。少欲知足行头陀。闻是事心不喜。诸比丘以是事白佛。佛以是事集比丘僧。知而故问跋难陀释子。汝实作是事不。答言。实作世尊。佛以种种因缘。呵责跋难陀释子。汝不知时不知量。何不小住待。汝事不废。居士无所失。佛如是种种呵责已。语诸比丘。以十利故与诸比丘结戒。从今是戒应如是说。若为比丘故。若王王臣若婆罗门居士。遣使送衣直。是使到比丘所言。大德。若某王王臣若婆罗门居士。送是衣直。汝当受取。比丘应言。我比丘法。不应受衣直。若须衣时。得净衣者。当自手受。速作衣持。是使语比丘言。大德。有执事人。能为比丘执事不。是比丘应示执事人。若僧园民若优婆塞。此人能为比丘执事。是使往执事人所言。善哉执事。汝取是衣直。作如是如是衣。与某比丘是比丘须衣时来。汝当与衣。是使语已还报比丘。我已语竟。大德须衣时。便往取。当与汝衣。是比丘到执事所索衣作。是言。我须衣。至再三反亦如是。索得衣者善。不得者。四反五反乃至六反。往执事前默然立。若四反五反六反默然立。得衣者善。若不得衣。过是求得衣者。尼萨耆波逸提。若不得衣。随送衣直来处。若自往若遣使语。汝所送衣直。我不得。汝自知物莫使失。是事应尔。为比丘者。为跋难陀释子故。王者。若刹利种。受王职亦名王。亦名国主。亦名水浇顶。若婆罗门若居士乃至女人。受王职亦名王。亦名国主。亦名水浇顶。王臣者。食官俸禄。婆罗门者。婆罗门种。居士者。除王王臣及婆罗门。种余在家白衣。是名居士使者。若男女黄门。二根。衣者。白麻衣赤麻衣翅夷罗衣刍麻衣憍奢耶衣钦婆罗衣劫贝衣。直者。金银车磲马瑙钱。使到已语比丘者。是使语跋难陀释子言。大德。是某王王臣若婆罗门若居士。送是衣直与大德。今当受取。比丘语使言。我比丘法。不应受衣直。若得净衣者。当自手受。速作衣持者。若作僧伽梨郁多罗僧安陀卫。是使语执事。以是衣直。作如是如是衣者。谓如是价如是色如是量。我已语执事者。若自口语若遣人语。比丘须衣时往到索衣。作是言者。至再三反。往应言我须衣。若三反往语。得衣者善。若不得衣。乃至六反往执事前默然立者。当在面前立。谓巧作处。自住处。产业处。市肆处。巧作处者。锻作处木作处。陶作处。若执事人在是处。比丘应在其面前默然立。自住处者。自在其家房舍处。产业处者。耕种处。贩卖处。出息物处。算计处。市肆处者。金肆银肆。客作肆。银肆珠肆。若执事人在是处者。比丘四反五反乃至六反。默然在面前立。不得衣者。应语衣主。若自往若遣使。汝所送衣直。我不得用。汝自知物。是比丘语衣主已。有余因缘往到是处。若执事人问比丘。汝何故来。比丘答言。我有余事故来。若执事言。汝持是衣直去。是比丘言。我已语衣主。汝自往共分了。若执事言。汝但持是衣直去。我自当往解语衣主。若比丘尔时受衣直持去者。无犯(十事竟)

十诵律卷第六十诵律卷第七(二诵之一)

        后秦北印度三藏弗若多罗译

    明三十尼萨耆法之三

佛在拘睒弥国。尔时拘睒弥比丘。作新憍施耶敷具。此国绵贵缕贵衣贵茧贵。多杀蚕故。比丘数数乞。语居士言。比丘须绵须缕须衣须茧。擘治引贮多事多务。妨废读经坐禅行道。诸居士厌患呵责言。诸沙门释子自言善好有德。而作新憍施耶敷具。此国绵贵缕贵衣贵茧贵。多杀蚕故。诸比丘乞绵乞缕乞衣乞茧。擘治引贮多事多务。妨废读经坐禅行道。是中我等失利供养。是难满难养无厌足人。有比丘少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集比丘僧。知而故问拘睒弥比丘。汝等实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘。作新憍施耶敷具。此国绵贵缕贵衣贵茧贵。多杀蚕故。佛如是种种因缘呵已。语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘以新憍施耶作敷具者。尼萨耆波夜提。尼萨耆波夜提者。是敷具应舍。波夜提罪应悔过。是中犯者。若比丘取绵。擘治作新敷具者。尼萨耆波夜提。若以缕若以衣若以茧。擘治作敷具者。尼萨耆波夜提。不犯者。若得已成敷具。不犯(十一事竟)

佛在王舍城。尔时六群比丘。以纯黑羺羊毛作敷具。此国黑。羊毛贵。黑羊毛缕贵。黑羊毛毡贵。诸比丘数数乞。语居士言。比丘须黑羊毛。须黑缕黑毡。诸居士厌患呵责言。诸沙门释子自言善好有德。而以纯黑羺羊毛作新敷具。此国黑羊毛贵。缕贵毡贵。比丘取是黑羊毛。择擘布贮多事多务。妨废读经坐禅行道。是中有比丘。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集比丘僧。知而故问六群比丘。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘。以纯黑羊毛作新敷具。此国黑羊毛贵缕贵毡贵。择擘布贮多事多务。妨废坐禅读经行道。佛种种因缘呵已语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘以纯黑羺羊毛作新敷具者。尼萨耆波夜提。黑羺羊毛者。有四种。谓生黑。蓝染黑。泥染黑。木皮染黑。是名四种黑。尼萨耆波夜提者。是敷具应舍。波夜提罪应悔过。是中犯者。若比丘以生黑羺羊毛。择擘布贮作敷具者。尼萨耆波夜提。若以蓝染泥染木皮染。择擘布贮。作敷具者。皆尼萨耆波夜提。若比丘以黑羺羊毛黑羺羊毛缕。黑羺羊毛毡。择擘布贮作敷具者。皆尼萨耆波夜提。不犯者。若为塔作。为僧作若得已成者不犯(十二事竟)

佛在王舍城。尔时六群比丘作是念。佛结戒。不听纯黑羺羊毛作敷具。我今当以少白羺羊毛杂黑羺羊毛作敷具。是中有比丘。少欲知足行头陀。闻是事心不喜。种种呵责。云何名比丘。佛不听纯黑羺羊毛作敷具。便以少白羺羊毛杂作敷具种种因缘呵已。向佛广说。佛以是事集比丘僧。知而故问六群比丘。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘。作是念。佛不听纯黑羺羊毛作敷具。便以少白羺羊毛杂作敷具。佛种种因缘呵已语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘作敷具。应用二分黑第三分白第四分下。若比丘不用二分黑第三分白第四分下。作敷具者。尼萨耆波夜提。黑者。有四种。生黑。蓝染黑。泥染黑。木皮染黑。白者。谓脊毛胁毛项毛。下者谓头毛腹毛脚毛。若作四十波罗敷具者。应用二十波罗纯黑羺羊毛十波罗白羺羊毛十波罗下羊毛。尼萨耆波夜提者。是敷具应舍。波夜提罪应悔过。是中犯者。若比丘取黑羺羊毛。过二十波罗。乃至一两作敷具。得尼萨耆波夜提。若取白羺羊毛。过十波罗。乃至一两作敷具。得突吉罗。若取下羊毛减十波罗。乃至一两作敷具。得尼萨耆波夜提。不犯者。若取下羊毛多。若纯用下羊毛者。不犯(一波罗者此四两也十三事竟)

佛在王舍城。尔时六群比丘。多作敷具畜言。此敷具太厚此敷具太薄。此太轻此太重此太大此太小。此穿坏此缘破。此敷具举畜朽坏不用。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘呵责。云何名比丘。多作敷具畜言。此太厚此太薄。此太轻此太重。此太大此太小。此穿坏此缘破。此敷具举畜。腐坏不用。种种呵已向佛广说。佛以是事集比丘僧。知而故问六群比丘。汝实作是事不。答言。实作世尊。佛以种种因缘呵责六群比丘。云何名比丘。多作敷具畜言。此太厚此太薄。此太轻此太重。此太大此太小。此穿坏此缘破。此敷具举畜。腐坏不用。佛种种因缘呵已。语诸比丘以十利故。与诸比丘结戒。从今是戒应如是说。若比丘欲作新敷具。故敷具必令满六年畜。若比丘减六年。若舍故敷具若不舍。更作敷具。除僧羯磨者。尼萨耆波夜提。僧羯磨者。若比丘故敷具。若太厚若太薄。若太轻若太重。若太大若太小。若穿坏若缘破。欲作新敷具者。是比丘。一心和合僧。从坐起偏袒右肩。脱革屣胡跪合掌。作是言。我某甲比丘。故敷具若太厚若太薄。若太轻若太重。若太大若太小。若穿坏若缘破。欲作新敷具。我从僧乞作新敷具。第二第三亦如是乞。尔时僧应筹量。若言太厚而实不厚。不应羯磨。若言太薄而实不薄。若言太重而实不重。若言太轻而实不轻。若言太大而实不大。若言太小而实不小。若言穿坏而实不穿坏。若言缘破而实不破。不应作羯磨。若穿坏可还割补者。不应作羯磨。若缘破可还襵缝者。亦不应作羯磨。若言太厚实厚。应作羯磨。若言太薄实薄。若言大重实重。若言大轻实轻。若言太大实大。若言太小实小。若言穿坏而实穿坏。若言不可割补。而实不可割补。若言缘破实破。不可襵缝者。应作羯磨。是中一比丘。应僧中唱言。大德僧听。是某甲比丘敷具。若太厚若太薄。若太轻若太重。若太大若太小。若穿坏不可割补。若缘破不可襵缝。今从僧乞作新敷具羯磨。若僧时到僧忍听。与某甲比丘作新敷具羯磨。白如是。如是白二羯磨。僧与某甲比丘作新敷具羯磨竟。僧忍默然故。是事如是持。是名僧羯磨。是中犯者。若比丘随何岁作敷具。即是岁更作新敷具。若作突吉罗。作竟尼萨耆波夜提。若随何岁作敷具。若至二岁三四五六岁。更作新敷具。若作突吉罗。作竟尼萨耆波夜提。若比丘随何岁作敷具。即是岁舍故敷具。更作新敷具。若作突吉罗。作竟尼萨耆波夜提。若随何岁作敷具。若至二三四五六岁。舍故敷具。更作新敷具。若作突吉罗。作竟尼萨耆波夜提。若比丘随何岁作新敷具。即是岁不舍故敷具。更作新敷具。若作突吉罗。作竟尼萨耆波夜提。若随何岁作新敷具。若至二三四五六岁。不舍故敷具。更作新敷具。若作突吉罗。作竟尼萨耆波夜提。若比丘随何岁作敷具。即是岁若舍故敷具。若不舍。更作新敷具。若作突吉罗。作竟尼萨耆波夜提。若随何岁作敷具。若至二岁三四五六岁。若舍故敷具。若不舍。更作新敷具。若作突吉罗。作竟尼萨耆波夜提。若比丘随何岁作敷具。即是岁更欲作新敷具时。得突吉罗。作竟尼萨耆波逸提。若随何岁作敷具。若至二三四五六岁。若欲作新敷具时。皆突吉罗。作竟尼萨耆波逸提。若比丘随何岁作敷具。即是岁更作新敷具。未成而置。至第二岁当作竟。是比丘初作敷具时。得突吉罗。作竟尼萨耆波夜提。若随何岁作敷具。若至二岁三四五六岁。更作新敷具。未成而置。至第七岁当作竟。初作时突吉罗。作竟无犯

若比丘如先所作敷具。应与人若作净。若比丘六岁内。故敷具若舍若不舍。更作新敷具。尼萨耆波夜提(十四事竟)

佛在舍卫国。尔时有一居士。请佛及僧明日食。佛默然受请。居士知佛受已。从坐起头面礼佛足右绕而去。还归竟夜具诸净洁多美饮食。办已晨朝敷坐。具遣使白佛。时到食具已办。唯佛知时。诸比丘僧往居士舍。佛自房住迎食分。诸佛常法。若众僧受请去。佛持户钥从房至房。观诸房舍。是时诸比丘入居士舍已。佛持户钥从房至房遍观诸房。开一房户见有舍敷具满是房中衣架垂曲。见已作是念。多有是舍敷具不复用。诸婆罗门居士。干竭血肉布施作福。若比丘少取者善。以何因缘。使诸比丘用是故敷具。令诸施主布施得福。复作是念。我今听诸比丘。作新坐具敷具。用是故敷具。作周匝一修伽陀磔手。坏色故。以是因缘。得用故敷具。诸施主得福。佛作是念已。闭户下橝。还自房坐本处。尔时居士见众僧坐竟。自手行水。以净洁多美饮食自恣饱满已。居士知僧洗手摄钵竟。取一小床在僧前坐。欲听说法。上座说法已起去。余比丘随次第去。还诣佛所头面礼足一面坐。诸佛常法。比丘僧食还。如是劳问。诸比丘饮食多美僧满足不。即以如是问讯。诸比丘满足不。诸比丘言。世尊。饮食多美众僧满足。佛语诸比丘。汝等众僧入居士舍已。我持户钥遍观诸房。开一房户见有舍敷具满是房中衣架垂曲。见已作是念。多有是舍敷具不复用。诸施主干竭血肉布施作福。若比丘少取者善。云何使诸比丘用是故敷具。令诸施主布施得福。复作是念。我当听诸比丘。作新敷具坐具用故敷具。周匝一修伽陀磔手。为坏色故。以是因缘。得用故敷具。施主得福。佛以是事集比丘僧。语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘作新敷具坐具。应用故敷具周匝一修伽陀磔手。坏色故。若比丘作新敷具坐具。不用故敷具周匝一修伽陀磔手坏色。为好故。尼萨耆波夜提尼萨耆波夜提者是敷具坐具应舍。波夜提罪应悔过。是中犯者。若比丘欲作新敷具坐具。应取故敷具周匝一修伽陀磔手。坏色故。若取作者善。若不取作。尼萨耆波夜提。若减取作乃至半寸。突吉罗。若取过一修伽陀磔手作不犯。若以故敷具。遍着新敷具坐具上。不犯(十五事竟)

佛在舍卫国。尔时诸比丘。共估客游行。憍萨罗国向舍卫国。诸估客。满车载羺羊毛。到崄道中。一估客。车轴折牛脚伤破。是估客语诸伴言。汝等各各。为我少多载是羊毛。勿令都失。诸估客言。我等车各自满重。若为汝载者。亦当俱失。诸估客悉皆舍去。是估客在一面立。愁忧守是车物。诸比丘随后来。以二因缘故。一者为尘坌身。二者不喜闻车声。是估客遥见诸比丘来。心喜作是念。是羊毛必当不失。当以布施是比丘僧。作是念已语诸比丘。共集一处。我以是羊毛布施众僧。僧即时集。居士布施已去。诸比丘各各作分。有比丘肩上担去。有比丘脊上负去。有比丘手持去。经大聚落中过。诸前行估客。见诸比丘持羊毛来。心生嫉妒。作是呵责言。汝等何处买是毛来。欲何处贩去。何处坐肆。是为得利。为不得利。是中有比丘。少欲知足行头陀。闻是估客呵责心不喜。向佛广说。佛以是事集比丘僧。知而故问诸比丘。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘。自担羊毛过三由延。佛如是种种因缘呵已。语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘行道中得施羊毛。比丘须者自取持去。乃至三由延。若无人代过是担者。尼萨耆波夜提。若二比丘得羊毛持去。得至六由延。若三比丘得至九由延。若四比丘得至十二由延。若五比丘得至十五由延。如是随人多少。一人得至三由延。尼萨耆波夜提者。是羊毛应舍。波夜提罪应悔过。是中犯者。若比丘自持羺羊毛去。过三由延。尼萨耆波夜提。若令比丘比丘尼式叉摩尼沙弥沙弥尼持去。过三由延。突吉罗。若比丘持羺羊毛。着耳上去。若着耳中。若着咽下。若作毡。若着针线囊中持去。不犯(十六事竟)

佛在舍卫国。尔时迦留陀夷。得先羊毛分。持诣王园比丘尼精舍。到已令诸比丘尼集一处。作是言。能与我擘治浣染是羊毛不。迦留陀夷。有大名闻威德力势。诸比丘尼以敬畏故。不能违逆。作是言。大德。但放地去。迦留陀夷即留而去。诸比丘尼取羊毛擘治浣染已。染色着手。尔时摩诃波阇波提瞿昙弥比丘尼。与众多比丘尼五百人俱。出王园精舍往诣佛所。头面礼足一面立。是五百比丘尼亦头面作礼一面立。佛见诸比丘尼手有染色佛知故问瞿昙弥比丘尼言。何故诸比丘尼手有染色。瞿昙弥答言。世尊。我等所求异所作异。佛言。瞿昙弥。云何所求异所作异。瞿昙弥以是事向佛广说。佛言。汝等实所求异所作异。佛尔时与瞿昙弥比丘尼众说种种法。示教利喜已默然住。时瞿昙弥比丘尼众。知佛说法已。头面礼足右绕而去。诸比丘尼去不久。佛以是事集比丘僧。知而故问迦留陀夷。汝实作是事不。答言。实作世尊。佛以种种因缘呵责迦留陀夷。云何名比丘。使非亲里比丘尼浣染擘羊毛。如是种种呵已语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘使非亲里比丘尼浣染擘羊毛者。尼萨耆波夜提。非亲里者。亲里名母姊妹女乃至七世因缘。除是名非亲里。尼萨耆波夜提者。是羊毛应舍。波夜提罪应悔过。是中犯者。若比丘往语非亲里比丘尼。为我浣染擘羊毛。若比丘尼为浣。比丘得尼萨耆波夜提。若染尼萨耆波夜提。若擘尼萨耆波夜提。若浣染若浣擘。若染擘。若浣染擘。皆尼萨耆波夜提。若比丘往语非亲里比丘尼。为我浣染如擘。若为浣。尼萨耆波夜提。若染尼萨耆波夜提。若擘若浣染。若浣擘若染擘。若浣染擘。皆尼萨耆波夜提。若比丘往语非亲里比丘尼。为我浣擘如染若为浣。尼萨耆波夜提。若擘尼萨耆波夜提。若浣染若浣擘。若染擘若浣染擘。皆尼萨耆波夜提。若比丘往语非亲里比丘尼。为我染擘如浣。若为浣尼萨耆波夜提。若擘尼萨耆波夜提。若染尼萨耆波夜提。若浣擘。若浣染。若染擘。若浣染擘。皆尼萨耆波夜提。若比丘往语非亲里比丘尼。为我浣染莫擘。若为浣尼萨耆波夜提。若染尼萨耆波夜提。若擘尼萨耆波逸提。若浣染若浣擘若染擘。若浣染擘皆尼萨耆波夜提。若比丘往语非亲里比丘尼。为我浣擘莫染。若为浣尼萨耆波夜提。若擘尼萨耆波夜提。若染尼萨耆波夜提。若浣染若浣擘。若染擘。若浣染擘。皆尼萨耆波夜提。若比丘往语非亲里比丘尼。为我染擘莫浣。若比丘尼为染。尼萨耆波夜提。若擘尼萨耆波夜提。若浣尼萨耆波夜提。若浣染若浣擘若染擘若浣染擘。皆尼萨耆波逸提。若比丘往语非亲里比丘尼。为我浣。莫染莫擘。若为浣。尼萨耆波夜提。若染若擘若浣染若浣擘。若染擘若浣染擘。皆尼萨耆波夜提。若比丘往语非亲里比丘尼。为我染。莫浣莫擘。若为染。尼萨耆波夜提。若浣若擘。若浣染若浣擘。若染擘若浣染擘。皆尼萨耆波夜提。若比丘往语非亲里比丘尼。为我擘。莫浣莫染。若为擘。尼萨耆波夜提。若浣若染。若浣染若浣擘若染擘。若浣染擘。皆尼萨耆波夜提。若比丘有非亲里比丘尼。谓是亲里语。使浣染擘羊毛。若比丘尼为浣若染若擘。尼萨耆波夜提。若有非亲里比丘尼。谓是比丘式叉摩尼沙弥沙弥尼出家出家尼。语使浣染擘。若为浣染擘。尼萨耆波夜提。若比丘有非亲里比丘尼。疑是亲里非亲里。语使浣染擘。若浣染擘。尼萨耆波夜提。若疑是比丘非比丘式叉摩尼非式叉摩尼沙弥非沙弥沙弥尼非沙弥尼出家非出家出家尼非出家尼。语使浣染擘。若为浣染擘。尼萨耆波夜提。若比丘有亲里比丘尼。谓非亲里。语使浣染擘。若为浣染擘。突吉罗。若谓是比丘式叉摩尼沙弥沙弥尼出家出家尼。语使浣染擘。若为浣染擘。皆突吉罗。若比丘有亲里比丘尼。疑是亲里非亲里。语使浣染擘。若为浣染擘。突吉罗。若疑是比丘非比丘式叉摩尼非式叉摩尼沙弥非沙弥沙弥尼非沙弥尼出家非出家出家尼非出家尼。语使浣染擘。若为浣染擘。皆突吉罗。若比丘有亲里非亲里比丘尼。若谓若疑。语使浣染擘不净毛。谓骆驼毛羖羊毛杂毛。突吉罗。不犯者亲里(十七事竟)

佛在王舍城。尔时六群比丘自手取宝。诸居士呵责言。沙门释子自言善好有德。云何自手取宝。如王如大臣。是中有比丘。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集比丘僧。知而故问六群比丘。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘。自手取宝。佛如是种种因缘呵已。语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘自手取宝。若使他取。尼萨耆波夜提。宝者。名为金银。是二种。若作若不作。若相若不相。取者。有五种以手从他手取。若以衣裓从他衣裓取。若以器从他器取。若言着是中。若言与是净人。尼萨耆波夜提。尼萨耆波夜提者。是物应舍。波夜提罪应悔过。是中犯者。若比丘手从手取。衣从衣取。器从器取。若言着是中。若言与是净人。皆尼萨耆波夜提。若作若不作。若相若不相。从他取者。皆尼萨耆波夜提。若比丘自手取铁钱。突吉罗。若取铜钱白镴钱铅锡钱树胶钱皮钱木钱。皆突吉罗。佛言。若比丘自手取宝。若少应弃。若多。设得同心净人者。应语是人言。我以不净故。不应取是宝。汝应取。净人取是宝已。语比丘言。此物与比丘。比丘言。此是不净物。若净当受。若不得同心净人。应用作四方僧卧具。是比丘应入僧中言。诸大德。我自手取宝得波夜提罪。我今发露不覆藏悔过。僧应问是比丘。汝舍是宝不。答言已舍。僧应问。汝见罪不。答言见罪。僧应语言。汝是罪发露悔过。后莫复作。若言未舍。僧应约敕令舍。若僧不约敕一切僧得突吉罗。若僧约敕不舍。是比丘得突吉罗。若筹量未决。不犯(十八事竟)

佛在王舍城。尔时六群比丘。先所舍宝作种种用。令起房舍作金肆客作肆锻铜肆治珠肆。畜象群。马群骆驼群牛群驴群羊群奴婢子弟人民。是中有人。强夺诸人民田业。卖与比丘。诸失居业者嗔恚呵责。作是言。沙门释子自言。善好有德。种种用宝作肆卖买。如王如大臣无异。是中有比丘。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集比丘僧。知而故问六群比丘。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘。种种用宝。佛种种呵已。语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘种种用宝者。尼萨耆波夜提。种种者若用作易作。若用作易不作。若用作易作不作。若用不作易不作。若用不作易作。若用不作易作不作。若用相易相。若用相易不相。若用相易相不相。若用不相易不相。若用不相易相。若用不相易相不相。是名种种。用者。有五种。若言取此物。从此中取。取尔所。从此人取。持来持去。卖买亦如是。复有五种。取彼物从彼中取。取尔所。从彼人取。持来持去。卖买亦如是。此物者。若金若银。从此中取者。若取刍麻。若取憍施耶。取尔所者。若取五十。若取一百。从此人取者。若从男女黄门二根人取。持来持去卖买亦如是。取彼物者。若金若银。从彼中取者。若取刍麻。若取憍施耶。取尔所者。若取五十。若取一百。从彼人取者。若从男女黄门二根人取。持来持去卖买亦如是。尼萨耆波夜提者。是物应舍。波夜提罪应悔过。是中犯者。若比丘用作易作。尼萨耆波夜提。用作易不作。用作易作不作。用不作易不作。用不作易作。用不作易作不作。皆尼萨耆波夜提。若用相易相。若用相易不相。若用相易相不相。若用不相易不相。若用不相易相。若用不相易相不相。皆尼萨耆波夜提。若言取此。尼萨耆波夜提。若从此中取。尼萨耆波夜提。若取尔所。尼萨耆波夜提。从此人取。尼萨耆波夜提。若持来持去卖买亦如是。若言取彼。尼萨耆波夜提。若言从彼中取。若取尔所。从彼人取。皆尼萨耆波夜提。持来持去卖买亦如是。若比丘用铁钱种种用。得突吉罗。用铜钱白镴钱铅锡钱树胶钱皮钱木钱种种用。皆突吉罗。若比丘种种用宝。若少应弃。若多。设得同心净人者。应语是人言。我以不净故不应取汝应取。净人取是物已。语比丘言。是物与比丘。比丘言。此是不净物。若净当受。若不得同心净人。应用作四方僧卧具。是比丘应入僧中言。诸大德。我种种用物得波夜提罪。我今发露不覆藏悔过。僧应问。汝舍是物不。答言已舍。应问。汝见罪不。答言见罪。僧应语。汝是罪发露悔过后莫复作。若言未舍。僧应约敕令舍。若僧不约敕。一切僧得突吉罗。若僧约敕不舍。是比丘得突吉罗。若筹量未决不犯(十九事竟)

佛在舍卫国。尔时有一梵志。着翅弥楼染钦婆罗。是跋难陀释子旧知识共事。时跋难陀遥见梵志着翅弥楼染钦婆罗衣来。见是衣已生贪着心。梵志到跋难陀所。共相问讯乐不在一面坐。跋难陀语梵志言。汝钦婆罗好可爱。答言实好。跋难陀言。可与我。我持此常钦婆罗与汝。梵志言。我自须用。跋难陀复言。汝梵志法裸形无德。何用好衣为。梵志言我须用卧。跋难陀又言。汝本与我白衣时。善知识深相爱念。我本时无有好物不与汝者。汝亦无有好物不与我者。汝今出家已。意怀生悭贪心。不如本耶。时跋难陀苦责数已。梵志即脱翅弥楼染钦婆罗与跋难陀。跋难陀还与常钦婆罗。梵志着常钦婆罗。到梵志精舍。诸梵志见已语言。汝翅弥楼染钦婆罗那去。答言。与他贸去。共谁贸耶。答言。与跋难陀。跋难陀与。汝有何因缘故共贸。答言。我本白衣时善知识深相爱念故共贸。诸梵志言。跋难陀释子调欺汝。是梵志言。若欺若调我已共贸。诸梵志复言。是翅弥楼染钦婆罗大有价。非是常钦婆罗比。是梵志言。虽贵价我已与贸。诸梵志复言。汝驶往取是翅弥楼染钦婆罗来。莫令我等立木榜治汝。是梵志即时怖畏。作是念。同学或能立木榜治我。便到跋难陀释子所。作是言。跋难陀。还我翅弥楼染钦婆罗。此钦婆罗还汝。跋难陀言。已共贸竟。梵志言。汝欺我调我。跋难陀言。设使欺调贸已决了。梵志又言。翅弥楼染钦婆罗大价。非是汝常钦婆罗比。答言。价大不大贸已决了。又言。跋难陀。我诸同学言。若不还得翅弥楼染钦婆罗者。当立木榜治汝。汝当还我来。莫使诸同学立木榜治我。跋难陀言。若立木榜治汝。若更余治。何豫我事。贸已决了终不与汝。是梵志急索不得。诸有不信佛法人。闻说是事。以妒心故呵责。作是言。沙门释子自言。善好有德。云何名出家人。故欺调余出家人。诸有信人亦复呵责。云何名比丘。作种种卖买事。是中有比丘。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集比丘僧。知而故问跋难陀。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘。作种种卖买事。佛如是呵已。语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘种种卖买者。尼萨耆波夜提。种种者。若以相似买相似。若以不相似买不相似。相似者。钵与钵相似。衣与衣相似。澡盥澡盥相似。户钩户钩相似。时药时药相似。夜分药夜分药相似。七日药七日药相似。终身药终身药相似。是名用相似买相似。不相似者。钵与衣不相似。钵与澡盥。户钩时药夜分药七日药终身药不相似。衣与澡盥不相似。户钩时药夜分七日终身药及钵不相似。澡盥与户钩不相似。与时药夜分七日终身药钵衣不相似。户钩与时药不相似。夜分药七日终身药钵衣澡盥不相似。时药与夜分药乃至户钩不相似。夜分药与七日药不相似。乃至时药不相似。七日药与终身药不相似。乃至夜分药不相似。终身药与钵不相似。乃至七日药不相似。是故说用不相似买不相似。尼萨耆波夜提。尼萨耆波夜提者。是物应舍。波夜提罪应悔过。是中犯者。若比丘为利故买已不卖。突吉罗。若为利故卖不买。亦突吉罗。若为利故买已还卖。尼萨耆波夜提。若比丘是可舍物。若用金买银。用银买钱。用钱籴毂。用毂买物。是物若可啖口。口得突吉罗罪。是物若可作衣着。随着得波夜提。佛言。从今日听。若共贸物。前人心悔。应还。自取本物。时六群比丘闻佛听共贸物心悔应还自取本物。闻已故半月一月着他衣坏失色。然后索悔。索悔时他不与。因是斗诤相言相骂相打。种种事起。诸比丘以是事白佛。佛言。七日内悔者应还。若过七日不应还。有卖衣人持衣行卖。六群比丘。以少价求他贵衣。卖衣人言。汝何为故。以少价索我贵价衣。若不知衣价人。则轻贱我衣。减我衣价。佛言。不应减价索他贵衣。若减价索他贵衣。突吉罗。若实须是物。审思量言。我以尔所物买。若彼不与。更应再语。若复不与。又应三语。若三索不与。比丘急须是物者。应觅净人使买是物。若净人不知市价。比丘当先教。以尔所物买是物。应教此物索几许。汝好思量看。佛言。从今日听众僧中卖衣。未三唱应益价。益价时比丘心悔。我将无夺彼衣耶。佛言。三唱未竟益价不犯。若比丘为利故。以铁钱种种卖买尼萨耆波夜提。若比丘为利故。用铜钱白镴钱铅锡钱树胶钱皮钱木钱种种买卖。皆尼萨耆波夜提。是比丘种种买卖物。若少应弃。若多。设得同心净人者。应语净人言。我以如是如是因缘不应取。是物汝应取。净人语比丘。是物与比丘。比丘言。此是不净物。若净当受。若不得同心净人。应用作四方僧卧具。是比丘应入僧中言。诸大德。我种种卖买。得波夜提罪。我今发露不覆藏悔过。僧应问。汝舍是物不。答言已舍。僧应问。汝见罪不。答言见罪。僧应语。汝今发露不覆藏悔过。后莫复作。若言未舍。僧应约敕令舍。若僧不约敕。一切僧得突吉罗。若僧约敕不舍。是比丘得突吉罗。若此贱彼贵卖。虽有利不犯。本不为利故(二十事竟)

佛在王舍城。尔时六群比丘。多畜钵积聚生垢。破坏不用。故是中有比丘。少欲知足行头陀。闻是事心不喜。呵责六群比丘。云何名比丘。多畜钵积聚生垢破坏不用。如是呵已向佛广说。佛以是事集比丘僧。知而故问六群比丘。实作是事不。答言。实作世尊。佛种种因缘呵责。云何名比丘。多畜钵积聚生垢破坏不用故。种种呵已语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘畜长钵得至十日。过是畜者。尼萨耆波夜提钵者。有三种。上中下。上钵者。受三钵他饭。一钵他羹。余可食物半羹。是名上钵。下钵者。受一钵他饭。半钵他羹。余可食物半羹。是名下钵。若余者名中钵。若大于大若小于小。钵不名为钵。尼萨耆波夜提者。是钵应舍。波夜提罪应悔过。是中犯者。若比丘。一日得钵畜二日舍。二日得畜三日舍。三日得畜四日舍。四日得畜五日舍。五日得畜六日舍。六日得畜七日舍。七日得畜八日舍。八日得畜九日舍。九日得畜十日舍。十日得畜。十日时是钵应与人。若作净若受持。若不与人不作净不受持。至十一日地。了时。尼萨耆波夜提。又比丘一日得钵。二日更得。畜一舍一。二日得三日更得。畜一舍一。三日得四日更得。畜一舍一四日得五日更得。畜一舍一。五日得六日更得。畜一舍一。六日得七日更得。畜一舍一。七日得八日更得。畜一舍一。八日得九日更得。畜一舍一。九日得十日更得。是钵十日时皆应与人。若作净若受持。若不与人不作净不受持。至十一日地了时。尼萨耆波夜提。又比丘一日得钵。二日更得。畜后舍前。二日得三日更得。畜后舍前。三日得四日更得。畜后舍前。四日得五日更得。畜后舍前。五日得六日更得。畜后舍前。六日得七日更得。畜后舍前。七日得八日更得。畜后舍前。八日得九日更得。畜后舍前。九日得十日更得。十日时是钵皆应与人。若作净若受持。若不与人不作净不受持。至十一日地了时。尼萨耆波夜提。又比丘一日得钵。二日更得。畜前舍后。二日得三日更得。畜前舍后。三日得四日更得。畜前舍后。四日得五日更得。畜前舍后。五日得六日更得。畜前舍后。六日得七日更得。畜前舍后。七日得八日更得。畜前舍后。八日得九日更得。畜前舍后。九日得十日更得。是钵十日时应与人。若作净若受持。若不与人不作净不受持。至十一日地了时。尼萨耆波夜提。又比丘一日得钵畜。二日不得。三四五六七八九十日不得。是钵十日时应与人。若作净若受持。若不与人不作净不受持。至十一日地了时。尼萨耆波夜提。又比丘一日得钵畜。二日更得三四五六七八九十日更得畜。是钵十日时皆应与人。若作净若受持。若不与人不作净不受持。至十一日地了时。尼萨耆波夜提。若比丘有钵。应舍未舍。罪未悔过。次续未断。更得钵。是后钵。得尼萨耆波夜提。本钵因缘故。又比丘应舍钵已舍。罪未悔过。次续未断。更得钵。是后钵。尼萨耆波夜提。本钵因缘故。又比丘有应舍钵已舍。罪已悔过。次续未断更得钵。是后钵尼萨耆波夜提。本钵因缘故。又比丘有应舍钵已舍。罪已悔过。次续已断。更得异钵者。不犯(二十一事竟)

十诵律卷第七十诵律卷第八(二诵之二)

        后秦北印度三藏弗若多罗译

    明三十尼萨耆法之四

佛在舍婆提。尔时跋难陀释子。共一估客子市巷中行。见一肆上有好瓦钵圆正可爱。见已贪着。语估客子。汝看是瓦钵圆正可爱。答言实尔。估客子言。汝须是不。答言欲得。即便买与。跋难陀释子得是钵已。出舍卫城入祇洹中。示诸比丘言。诸长老。汝等看是瓦钵圆正可爱。诸比丘言。实好。汝何从得。跋难陀向诸比丘广说是事。诸比丘问。汝先有所用钵不。答言先有。又言。用此钵为。答言。先有今有有何患。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘呵责。云何名比丘。先有所用钵。更乞新钵。种种呵已向佛广说。佛以是事集比丘僧。知而故问跋难陀释子。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘。先有所用钵更乞新钵。种种呵已语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘所用钵破。减五缀。更乞新钵。为好故。尼萨耆波夜提。是钵应比丘僧中舍。此众中最下钵。应与是比丘。如是教言。汝比丘畜是钵乃至破。是事应尔。所用钵者。先所受用食钵。钵者。有三种。上中下。上者。受三钵他饭。一钵他羹。余可食物半羹。是名上钵。下钵者。受一钵他饭。半钵他羹。余可食物半羹。是名下钵。余者。名中钵。大于大小于小。不名为钵。减五缀者。四缀三缀二缀一缀。为好者。是比丘难满难养不知足不少欲故。是钵应比丘众中舍者。是钵应盛满中水僧中行之。应作是唱言。诸长老集。今欲作满水钵。诸比丘应即时各自持先所受用钵来集一处。是时诸比丘不得更受余钵。若诸比丘于是时。更受余钵者。得突吉罗罪。僧和合已。先应作行满水钵人羯磨。一比丘应僧中唱言。诸长老。谁能行是满水钵者。若比丘言。我能。是比丘若成就五恶法。不应令作行钵人。何等五恶。随欲行。随嗔行。随怖行。随痴行。不知行不行。若成就五善法者。应令作行钵入。不随欲嗔怖痴知行不行。是比丘应令作行钵人。是中一比丘即时唱言。大德僧听。某甲比丘能作行满水钵人。若僧时到僧忍听。某甲比丘作行满水钵人。如是白。如是作白二羯磨。僧今听。某甲比丘作行满水钵人竟。僧忍默然故。是事如是持。若是比丘作行满水钵人。应满钵盛水。初应先至第一上座比丘所问言。上座须是钵不。若上座言须。应与上座。是人应取上座钵行之次到第二上座所。问言。须是钵不。若言须应与。又应取第二上座钵次问第三上座。问第三上座时。若第一上座心悔还自索钵者。佛言不应与。若上座强取应还夺。教上座作突吉罗悔过。若是钵第一上座不取者。应次第行遍。若是满水钵。都无人取者。乃应还与彼比丘。若有人取是钵者。应取是人钵次遍行之。若无取是钵者。乃以与彼比丘。如是教言。汝畜是钵。乃至破是钵。莫着地。莫着石上。莫着高处。莫着屋漏处。莫着土埵上。不应持至大小便处。不应持入浴室。不应以杂沙牛屎洗。若钵湿不应便举。不应令太干。不应故打破。不应用澡洗手面。好守护莫以是破因缘故求觅。妨废坐禅读经行道。尼萨耆波夜提者。是钵应舍。波夜提罪应悔过。是中犯者。若比丘钵未破。不应更乞新钵。若乞得者尼萨耆波夜提。不得者突吉罗。若比丘钵破可一缀。若缀若未缀。不应更乞。若乞得者。尼萨耆波夜提。不得者突吉罗。若比丘钵破。可两缀三缀四缀。若缀未缀。不应更乞。若乞得者。尼萨耆波夜提。不得者突吉罗。若比丘钵破可五缀。若缀未缀。更乞新钵。若得不得不犯(二十二事竟)

佛在王舍城。尔时六群比丘自乞缕。持到富贵人舍。作是言。诸聚落主。令织师为我织衣。是诸贵人即语织师。与是比丘织衣。我与汝价。是织师依此贵人舍住。敬畏故不能违逆。但织衣时嗔恚呵责言。沙门释子自言。善好有德。依恃贵人使我虚作。无食无价亦无福德恩分。是我等衰恼失利。值遇是难满难养不少欲不知足人。是中有比丘。少欲知足行头陀。闻是呵责心不喜。向佛广说。佛以是事集比丘僧。知而故问六群比丘。汝实作是事不。答言。实作世尊。佛以种种因缘呵责六群比丘。云何名比丘。自乞缕使非亲里织师织衣。种种因缘呵已。语诸比丘。以十利故。与比丘结戒。从今是戒应如是说。若比丘自行乞缕。使非亲里织师织者。尼萨耆波夜提。自乞者。或得五十波罗。或得百波罗。乃至得一两。缕者。麻缕毛缕刍摩缕劫贝缕。非亲里者。亲里。名父母兄弟姊妹儿女乃至七世因缘。异是名非亲里。织师者。若男女黄门二根。尼萨耆波夜提者。是物应舍。波夜提罪应悔过。是中犯者。若比丘从亲里乞缕。若令亲里织。若自织。若令比丘比丘尼式叉摩尼沙弥沙弥尼织。是中从亲里乞不犯。令亲里织亦不犯。自织得突吉罗。令比丘比丘尼式叉摩尼沙弥沙弥尼织。皆突吉罗。若比丘从亲里乞缕。令非亲里织。若自织。若令比丘比丘尼式叉摩尼沙弥沙弥尼织。是中从亲里乞不犯。令非亲里织师织。尼萨耆波夜提。若自织。令比丘比丘尼式叉摩尼沙弥沙弥尼织。皆突吉罗。若比丘从亲里乞缕。令亲里非亲里织。若自织。若令比丘比丘尼式叉摩尼沙弥沙弥尼织。是中从亲里乞不犯。令亲里织亦不犯。令非亲里织。尼萨耆波夜提。自织令比丘比丘尼式叉摩尼沙弥沙弥尼织。皆突吉罗。若比丘从非亲里乞缕。令非亲里织。若自织。若令比丘比丘尼式叉摩尼沙弥沙弥尼织。是中从非亲里乞缕。突吉罗。令非亲里织。尼萨耆波夜提。自织。令比丘比丘尼式叉摩尼沙弥沙弥尼织。皆突吉罗。若比丘从非亲里乞缕。令亲里织。若自织。若令比丘比丘尼式叉摩尼沙弥沙弥尼织。是中从非亲里乞缕。突吉罗。令亲里织无犯。自织。令比丘比丘尼式叉摩尼沙弥沙弥尼织。皆突吉罗。若比丘从非亲里乞缕。令亲里非亲里织。若自织。若令比丘比丘尼式叉摩尼沙弥沙弥尼织。是中从非亲里乞缕。突吉罗。令非亲里织。尼萨耆波夜提。令亲里织不犯。自织。令比丘比丘尼织式叉摩尼沙弥沙弥尼织。皆突吉罗。若比丘从亲里非亲里乞缕。令亲里非亲里织。若自织。若令比丘比丘尼式叉摩尼沙弥沙弥尼织。是中从亲里乞不犯。从非亲里乞。突吉罗。令亲里织不犯。令非亲里织。尼萨耆波夜提。自织。令比丘比丘尼织式叉摩尼沙弥沙弥尼织。皆突吉罗。若比丘从亲里非亲里乞缕。令亲里织。若自织。若令比丘比丘尼式叉摩尼沙弥沙弥尼织。是中从亲里乞不犯。从非亲里乞突吉罗。令亲里织不犯。自织。令比丘比丘尼式叉摩尼沙弥沙弥尼织。皆突吉罗。若比丘从亲里非亲里乞缕。令非亲里织。若自织。若令比丘比丘尼式叉摩尼沙弥沙弥尼织。是中从亲里乞。不犯。从非亲里乞。突吉罗。令非亲里织。尼萨耆波夜提。自织。令比丘比丘尼式叉摩尼沙弥沙弥尼织。皆突吉罗。不犯者。织一波梨。若织禅带腰带。若一杼两杼不犯(二十三事竟)

佛在舍卫国。尔时有一居士。为跋难陀释子故。令织师织衣。跋难陀闻是事。往语织师言。汝知不。是衣为我织。汝好织广织极好织净洁织。我当少多利益汝。若食若似食若食直。织师言。大德。我等学是者。欲得利故。若与我少多利者。当为汝好织广织极好织净洁织。跋难陀言善。时织师便为好织广织极好织净洁织。多费经纬。居士觉已语织师言。何以用经纬多。织师答言。我不减不偷。织竟自共称看今是衣好织广织极好织净洁织故。多费经纬。居士言。谁约敕汝令如是织。织师言。跋难陀释子。居士言。但好织是。居士先所办缕。更再三倍用。乃得成衣。与跋难陀释子已嗔恚呵责。诸沙门释子自言。善好有功德。何以乃能不知时不知量。若施者不知量。受者应知量。我先所办缕再三倍用。乃得成衣。此是我等衰恼失利。何以供养是难满难养不知猒足不少欲人。是中有比丘。少欲知足行头陀。闻是居士呵责心不喜。向佛广说。佛以是事集比丘僧。知而故问跋难陀。汝实作是事不。答言。实作世尊。佛以种种因缘呵责跋难陀。云何名比丘。非亲里人作同意。种种因缘呵已语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若为比丘故。非亲里居士居士妇。使织师织衣。是比丘先不请。便往语织师言。汝知不。是衣为我故织。汝好织。极好织广织净洁织。我当多少益汝。是比丘若自语若使人语。后时若与食若与食直。为好故。尼萨耆波夜提。为比丘者。为跋难陀释子。非亲里者。亲里。名父母兄弟姊妹男女乃至七世因缘异是名非亲里。居士居士妇者。白衣男子名居士。白衣女人名居士妇。织师者。男女黄门二根。衣者。白麻衣赤麻衣翅夷罗衣刍摩衣憍奢耶衣钦婆罗衣劫贝衣。先不请者。是居士先不语。有所须来取。作同意者。信是居士随我所须不嗔。语织师好织者。使稍稍织。广织者。使极广织。极好织者。使好致织。净洁织者。使好净洁织。与食若似食。食者五种。谓饭糗[麩-夫+并]鱼肉。似食者。亦有五种。谓糜食粟食[麩-夫+廣]麦食莠子食迦师食。食直者。可买食物。尼萨耆波夜提者。是衣应舍。波夜提罪应悔过是。中犯者。若比丘往织师所言。是衣为我故织。汝好织我当少多利益汝。尼萨耆波夜提。若言广织当多少益汝。尼萨耆波夜提。若言极好织当多少益汝。尼萨耆波夜提。若言净洁织当少多益汝。尼萨耆波夜提。若言好织广织当少多益汝。尼萨耆波夜提。若言好织极好织。若言好织净织。若言广织极好织。若言广织净织。若言极好织净织当少多益汝。皆尼萨耆波夜提。若言好织广织极好织。若言好织广织净洁织。若言广织极好织净洁织当多少益汝。皆尼萨耆波夜提。若言好织广织极好织净洁织我当多少益汝。皆尼萨耆波夜提。又比丘往语织师。汝知不。是衣为我织。汝莫好织。我或多少益汝。是比丘得尼萨耆波夜提。若比丘往语织师言。是衣为我织。汝莫广织。或多少益汝。尼萨耆波夜提。若言莫极好织或多少益汝。尼萨耆波夜提。若言莫净织或少多益汝。尼萨耆波夜提。若言莫好织莫广织。若言莫好织莫极好织。若言莫好织莫净织。若言莫广织莫极好织。若言莫广织莫净织。若言莫极好织莫净织或少多益汝。皆尼萨耆波夜提。若言莫好织莫广织莫极好织。若言莫好织莫广织莫净织。若言莫广织莫极好织莫净洁织或少多益汝。皆尼萨耆波夜提。若言莫好织莫广织莫极好织莫净织或少多益汝。皆尼萨耆波夜提。又比丘往语织师。汝知不。是衣为我织。汝好织我不益汝。是比丘得突吉罗。若言广织。若言极好织。若言净织不利益汝。皆突吉罗。若言好织广织。若言好织极好织。若言好织净织。若言广织极好织。若言广织净洁织。若言极好织净织不益利汝。皆突吉罗。若言好织广织极好织。若言好织广织净洁织。若言广织极好织净洁织不利益汝。皆突吉罗。若言好织广织极好织净洁织不利益汝。皆突吉罗。若比丘往语织师言。汝知不。是衣为我织。汝莫好织我不益汝。突吉罗。若言莫广织。若言莫极好织。若言莫净洁织我不益汝。皆突吉罗。若言莫好织莫广织。若言莫好织莫极好织。若言莫好织莫净洁织。若言莫广织莫极好织。若言莫广织莫净洁织。若言莫极好织莫净织。若言莫好织莫广织莫极好织。若言莫好织莫广织莫净织。若言莫广织莫极好织莫净织。若言莫好织莫广织莫极好织莫净织不利益汝。皆突吉罗。若比丘自有物。令织师织不犯(二十四事竟)

佛在舍卫国。尔时跋难陀释子。有共行弟子。名达摩。善好有德。时跋难陀暂与割截衣着。尔时佛自恣竟夏末月。欲二月游行他国。跋难陀释子。闻佛夏末月欲二月游行他国闻已语弟子达摩。佛夏末月欲二月游行他国。今我共汝在佛前游行他国。我等当多得衣食诸卧具不阙。达摩言不能去。何以故。我欲从佛游行他国。得数见佛数见大德比丘。因他故得闻法。跋难陀言。汝不欲共我去耶。答言不去。跋难陀言。不去者还我衣来。弟子言。和上衣已与我。跋难陀言。我不以他事故与汝。与汝者为我事故。汝实不欲去耶。答言。实不欲去。跋难陀即还夺衣取。是弟子在只陀槃那门间立啼。佛入只陀槃那见达摩。佛知而故问。达摩。汝何故啼耶。即向佛广说上事。佛以是事集比丘僧。知而故问跋难陀释子。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘。与他比丘衣。后嗔恚嫌恨。便还夺取。种种呵已语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘与他比丘衣后嗔恚嫌恨。若自夺若使人夺。还我衣来不与汝。得是衣者。尼萨耆波夜提。自夺者。自身夺。使人夺者。令他人夺。尼萨耆波夜提者。是衣应舍。波夜提罪应悔过。是中犯者。若比丘与他比丘衣。后嗔恚嫌恨便夺。若能夺得者。尼萨耆波夜提。若不能得者。突吉罗。使人夺得者。尼萨耆波夜提。不得者突吉罗。自以力斗诤夺得者。尼萨耆波夜提。不得者突吉罗。使他出力斗诤。夺得者尼萨耆波夜提。不得者突吉罗。若欲折伏彼故。暂夺不犯(二十五事竟)

佛在舍卫国。尔时长老毗诃比丘。留僧伽梨安陀林中。着上下衣入城乞食。后失僧伽梨。还觅不得。向诸比丘说。我留僧伽梨安陀林中入城乞食。后便失。还觅不得。我当云何。诸比丘以是事白佛。佛以是事集比丘僧。知而故问毗诃。汝实留僧伽梨安陀林中。着上下衣入城乞食。后失僧伽梨。还觅不得。向诸比丘说。诸长老。我留僧伽梨安陀林中。着上下衣入城乞食。后失僧伽梨。还觅不得。我当云何。答言。实尔世尊。佛种种因缘赞叹随所往处与衣钵俱。作如是言。若比丘少欲知足。衣趣蔽形食趣活命。随所往处与衣钵俱。常安乐住。譬如鸟飞随所往处毛翅共俱。比丘亦尔。随所往处与衣钵俱。常安乐住。佛以种种因缘赞叹与衣钵俱已。语诸比丘。以十利故。与诸比丘结戒。从今是戒应如是说。若比丘三月过。未至八月未满岁。若阿练儿比丘。在阿练儿处住。有疑怖畏。是比丘欲三衣中随一一衣着界外家中。此比丘有因缘出界外。离衣宿齐六宿。过是宿者。尼萨耆波夜提。未满岁者。后安居。阿练儿处者。去聚落五百弓。于摩伽陀国是一拘卢舍。于北方国则半拘卢舍。有疑处者。疑是中失物。乃至失一水器。有畏者。是中有怖畏。乃至畏恶比丘。若是比丘欲三衣中随以一一衣着界外家中。衣名三衣若僧伽梨若郁多罗僧若安陀会。六夜离衣不犯者。若离僧伽梨。若离郁多罗僧。若离安陀会。尼萨耆波夜提者。是衣应舍。波夜提罪应悔过。是中犯者。比丘第六夜。应还取衣。若至衣所。若受余衣。若比丘不取衣来。不往衣所。不受余衣。至第七夜地了时。尼萨耆波夜提三月过者。谓夏有四月三月虽过。而后安居人日犹未满故。言未满八月也(二十六事竟)

佛在舍卫国。尔时舍卫估客游诸聚落。为市利故。道中见一僧坊闲静远离。估客入中见比丘僧少。问比丘言。此中比丘何以少。比丘答言。汝不知耶。估客言云何比丘言。是处无檀越供给衣食汤药。是故比丘僧少。估客言。我等欲修治是处供给衣食汤药。是诸估客即时留衣食汤药直已便去。游行诸处。诸比丘夏初月。分是物去。余处安居。是估客得利行还。见是僧坊。作是念。此是我等所供养处。当入中看。有几人安居。或有所乏衣食汤药。当更供给。即入已见比丘转少。问言。此中比丘何以转少。比丘言。汝不知乎。是中无檀越供给衣食汤药直。是故减少。估客言。我等先所供给衣食汤药直。是物那去。比丘答言。是夏初月诸比丘分是物去余处安居。估客言。我等不为分故与使余处安居。我为住此处故与令受供养。是中有比丘少欲知足行头陀。闻是事心不喜。向佛广说佛以是事集比丘僧。佛以种种因缘呵责。云何名比丘。夏初月分安居物。佛尔时但呵责未结戒

佛又在舍卫国。尔时波斯匿王有斗将千人五百人作一营皆着弊坏垢衣无色无德。自房舍中无好床榻卧具。诸斗将妇亦无好衣服环钏璎珞华鬘庄严身具。正使得官供给廪食。又不充足是人喜饮食人客嗜酒斗诤。或时啼哭。或时戏笑跳踯大唤。有达摩提那比丘尼。近是处住。以是大音声闹乱故。妨是比丘尼坐禅读经。时达摩提那比丘尼。往斗将妇所问言。汝等夫。何以着弊坏垢衣。无色无德。自房舍中。无好床榻卧具。汝等亦无好衣服环钏璎珞华鬘严具。设使得官供给又不充足。汝夫。喜饮食人客嗜酒喜斗诤。或啼哭戏笑。或跳踯大唤。妨我坐禅读经汝何不遮。答言。何能制之。设使遮者。先所得饮食之余。更不复得。善人若当呵者。或能受用。达摩提那比丘尼。闻语已去乞觅饮食。时时请诸斗将中大力势者。与食诱之知有信心能信受语。即便语言。诸聚落主。汝等归依佛归依法归依僧。是信受语故即归依佛法僧。归依佛法僧故。不复喜饮酒。亦不喜延致酒客。不喜斗诤。不复喜啼哭戏笑跳踯大唤。自房舍中。有好床榻衣服卧具。诸妇皆有好衣服环钏璎珞华鬘庄严身具。官所给廪皆得充足。以是因缘故。诸斗将渐渐大富。多饶金银财宝奴婢人民种种成就。波斯匿王以是富人围绕故。王有威德众所敬仰。尔时波斯匿王。有小国反叛。语诸斗将。汝等往彼折伏便还。是诸将中有深敬佛者。弓头着漉水囊。作是念。若值水有虫者。当漉饮之。是中有不信佛法者。生嫉妒心。往到波斯匿王所言。是中某甲诸斗将。弓头着漉水囊。作是念。值有虫水者。当漉饮之。是等诳王。王言。云何是等于小虫中有如是怜愍心。何况于人。王言唤来。即往唤之。王言。汝等实以漉水囊系弓头。作是念。值水有虫者。当漉饮之耶。答言实尔。王言。汝等诳我。斗将言。云何诳王。王言。汝于小虫尚有怜愍心。何况于人。斗将言。虫有何过。于王若有过者。当知我等为王治之。王作是念。或有人喜净洁故。何必畏杀虫。王言。将至阵前。即将至阵前。是诸斗将。或有得慈心三昧。入慈心力故。破是贼阵即时折伏。王闻破贼心大欢喜。尔时诸斗将破贼已。还到王所长跪而言。大王常胜。作是语已在王前立。王即时偿赐财物聚落田宅人民。更倍供给。尔时诸斗将富贵转增。多饶金银财宝奴婢人民种种增益。王以是人围绕故。威德转胜众倍敬仰。诸斗将作是念。我等富贵具足者。皆因达摩提那比丘尼故。我等何不请是比丘尼来。是舍卫国三月夏安居。是诸斗将到比丘尼所言。大德。到我舍卫国夏安居来。比丘尼答言。不能。何以故。答言。随佛安居处。我等当往安居。是中数得见佛。数得见大德比丘。因他故得闻法。汝等若欲令我是中安居者。可先请佛此舍卫国夏安居。是斗将即往佛所。头面礼足在一面坐。佛见坐已种种因缘说法示教利喜。示教利喜已默然。是诸斗将。闻佛说法种种因缘示教利喜已。白佛言。世尊。受我等请舍卫国夏安居。怜愍故佛默然受之。诸斗将知佛默然受请已。头面礼足右绕而去。还到自舍各相约敕。随力所办。若一日食二日食三日食。如是次第办三月食。为众僧作别房衣。作家中衣作夏安居衣。尔时余十日在。未到自恣。波斯匿王复有小国反叛。即复遣先斗将往。以前破贼。是故今复使汝等往。是诸斗将闻已愁忧。何苦乃尔。先斗因缘殆而得脱。今复往者或能失命。我等已请佛三月办衣食汤药。我等若不以布施者。众僧失布施。我等失福德。我等先欲施物。今布施何苦。我等常令施法不绝。僧福田中恒作福德。僧得施物。我等得福。即出前许布施物。多持衣襆。到只陀林中打揵槌。诸比丘言。何以打耶。斗将答言。诸大德集。我以此衣布施众僧诸比丘言。佛不听我等未自恣夏月内分安居衣。诸斗将言。我等官人属他不得自在。先斗因缘殆而得脱。今往不知云何。或能失命。众僧集聚当受是衣物。诸比丘不知云何。是事白佛。佛知故问阿难。自恣有几日在。阿难答言。世尊。有十日在。佛语阿难。虽十日未至自恣。恐失布施衣应受。佛及僧集坐一处诸斗将分诸衣与众僧已。在佛前坐听说法故。佛见坐已。说种种法示教利喜。示教利喜已默然。是诸斗将闻佛说法已。头面礼足右绕而去。去不久。佛以先因缘及是事故。集比丘僧。佛以种种因缘。赞戒赞持戒。赞戒赞持戒已。语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘十日未至自恣。有急施衣应受。比丘须是衣者。当自手取。乃至衣时畜。过是畜者。尼萨耆波夜提。十日未至自恣者。若知自恣有十日在急施衣者。若王施若夫人施若王子施。若大臣大官斗将内官。若女欲嫁时。若病人。若欲杀贼时。如是等人施衣。若知十日未至自恣应受。衣时者。若有住处。不受迦絺那衣夏末一月。若受迦絺那衣住处夏末一月及冬四月。尼萨耆波夜提者。是衣应舍。波夜提罪应悔过。是中犯者。若是处不受迦絺那衣。诸比丘。夏末月末后日。是衣应舍。若作净若受持。若不舍不作净不受持。至冬初月初日地了时。尼萨耆波夜提。若是住处受迦絺那衣。是诸比丘冬末后月末后日。是衣应舍应作净若受持若不舍不作净不受持。至春初月初日地了时。尼萨耆波夜提(二十七事竟)

佛在王舍城。尔时六群比丘作是言。佛听我等畜雨浴衣。便春冬一切时畜。是中有比丘。少欲知足行头陀。闻是事心不喜种种因缘呵责。云何名比丘。佛听畜雨浴衣。故便冬春一切时畜。佛听畜三衣。雨浴衣乃是第四衣。是诸比丘种种呵已。是事白佛。佛以是事集比丘僧。知而故问六群比丘。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘。我听畜雨浴衣。便冬春一切时畜。种种因缘呵已。语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘春残一月。应求作雨浴衣。半月应受持。若比丘未至春残一月求作。过半月受持者。尼萨耆波夜提。是中云何求。云何作。云何持。求者。从他乞。是衣作者。若浣染割截[打-丁+替]。缝持者若是衣受用。尼萨耆波夜提者。是衣应舍。波夜提罪应悔过。是中犯者。若比丘有闰月处求雨浴衣。往无闰月处安居。是中从外求来作来。皆突吉罗。从受持来。尼萨耆波夜提。若有闰处比丘遣使往。语无闰处比丘言。诸大德。小待共自恣。若无闰处比丘受是语待者。是无闰处比丘从求来作皆突吉罗。从受持来。尼萨耆波夜提。若比丘有闰处求雨浴衣。有闰处安居。不犯。持竟。夏前三月便舍之。无闰处者。已入八月。热时已过故犯。有闰者。谓此国晚热。谓闰春末月。则闰月内求之。若求得者。三月末便应受持。不能得者。四月十六日应受持。即得不应停过十五日(二十八事竟)

佛在舍卫国。尔时有一居士。发心欲与佛及僧饮食复与僧衣。时世饥俭乞食难得。是居士财物不多。夏时已过心中忧愁作是言。今何痛恼苦急乃尔。我本心欲与佛及僧饮食复与僧衣。时世饥俭乞求难得我财物少。夏时已过心中忧愁。苦急不满我愿。我今当从僧中少多。请比丘与食与僧衣。令我福德不空。作是念已便入祇洹打揵槌。有比丘问居士。何因缘故打揵捶。居士答言。我欲从僧请尔所比丘到我舍食。时知会人即差尔所比丘去。次到六群比丘。六群比丘先时有次请。便持衣钵先至请家。办饮食时教如是如是作。是时六群比丘晨朝持衣钵。到是居士舍共相问讯在一面坐。居士作礼在前坐。自向六群比丘软语。我本心欲与佛及僧饮食复与僧衣。今世饥俭乞求难得。我财物少。夏时已过心中忧恼苦急作是念。我今何不从僧中请少多比丘。与食便与僧衣。令我不失福德。以是因缘故食与汝等衣当与僧。时六群比丘闻衣名心动。语居士言。是衣何似持来示我。居士言善。即出衣示之。六群比丘见衣倍生贪心。语居士言。汝意欲令是衣有用耶。欲令举置耶。居士言。所以施者欲令用之。汝若欲令不用者当与僧。何以故。僧多有衣举在一处朽坏虫啖。若令用者当与我等。我等衣少得施当用。居士言。汝等知与僧不用。若汝等能用者便当相与。居士与食已持是衣与六群比丘。六群比丘食已持是衣入祇洹。示诸比丘是衣何似细好不。诸比丘言。实好汝何从而得。六群比丘广说是事。是中有比丘少欲知足。行头陀闻是事心不喜。种种因缘呵责。云何名比丘知物向僧自求向己。种种因缘呵已向佛广说。佛以是事集比丘僧。知而故问六群比丘。汝实作是事不。答言。实作世尊。佛以种种因缘呵责六群比丘云何名比丘。知物向僧自求向己。种种因缘呵已语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘知物向僧自求向己。尼萨耆波夜提。知者若自知若从他闻。若檀越语。物者谓施僧物。若衣钵户钩澡灌时药夜分药七日药终身药。向僧者发心欲施僧未与。尼萨耆波夜提者。是衣应舍波夜提罪应悔过。是中犯者。若比丘知是物向比丘僧自求向己。尼萨耆波夜提。若向三二一。突吉罗。若比尼萨耆波夜提。若向三二一。突吉罗。若比丘知是物向此三比丘。求向余三比丘。突吉罗。若比丘知是物向三比丘求向二比丘一比丘。比丘尼僧三比丘尼二比丘尼一比丘尼。三式叉摩尼二式叉摩尼一式叉摩尼。三沙弥二沙弥一沙弥。三沙弥尼二沙弥尼一沙弥尼。比丘僧。皆突吉罗。若比丘知是物向此二比丘。求向余二比丘。突吉罗若知是物向二比丘。求向一比丘比丘尼僧。三比丘尼二比丘尼一比丘尼。三式叉摩尼二式叉摩尼一式叉摩尼。三二一沙弥。三二一沙弥尼。比丘僧三二一比丘。皆突吉罗。若比丘知是物向此一比丘。求向余一比丘。突吉罗。若知是物向一比丘。求向比丘尼僧。三二一比丘尼三二一式叉摩尼。三沙弥二一沙弥。三二一沙弥尼。比丘僧三二一比丘皆突吉罗。若比丘知是物向此三比丘尼。求向余三比丘尼。突吉罗。若比丘知是物向三比丘尼。求向二比丘尼一比丘尼。三二一式叉摩尼。三二一沙弥。三二一沙弥尼。比丘僧三比丘二一比丘。比丘尼僧。皆突吉罗。若比丘知是物。向此二比丘尼。求向余二比丘尼。突吉罗。若比丘知是物向二比丘尼。求向一比丘尼三二一式叉摩尼三二一沙弥三二一沙弥尼比丘僧三二一比丘比丘尼僧。三二一比丘尼。皆突吉罗。若比丘知是物向此一比丘尼。求向余一比丘尼。突吉罗。若比丘知是物向一比丘尼。求向三二一式叉摩尼。三沙弥二一沙弥。三二一沙弥尼。比丘僧三二一比丘。比丘尼僧三比丘尼二一比丘尼。皆突吉罗。若比丘知是物向此三式叉摩尼。求向余三式叉摩尼。突吉罗。若比丘知是物向三式叉摩尼。求向二一式叉摩尼。三二一沙弥。三二一沙弥尼。比丘僧三二一比丘比丘尼僧。三二一比丘尼。皆突吉罗。若比丘知是物向此二式叉摩尼。求向余二式叉摩尼。突吉罗。若比丘知是物向二式叉摩尼。求向一式叉摩尼。三二一沙弥。三二一沙弥尼。比丘僧三比丘二一比丘比丘尼僧。三比丘尼二一比丘尼。三式叉摩尼。皆突吉罗。若比丘知是物向此一式叉摩尼。求向余一式叉摩尼。突吉罗。若知是物向一式叉摩尼。求向三沙弥。二一沙弥。三沙弥尼。二一沙弥尼。比丘僧三比丘二一比丘。比丘尼僧三比丘尼。二一比丘尼。三式叉摩尼。二一式叉摩尼。皆突吉罗。若比丘知是物向此三沙弥。求向余三沙弥。突吉罗。若比丘知是物向三沙弥。求向二沙弥一沙弥。三沙弥尼二一沙弥尼。比丘僧三比丘二一比丘。比丘尼僧三比丘尼二一比丘尼。三式叉摩尼二一式叉摩尼。皆突吉罗。若比丘知是物向此二沙弥。求向余二沙弥。突吉罗。若比丘知是物向二沙弥。求向一沙弥。三沙弥尼二一沙弥尼。比丘僧三比丘二一比丘。比丘尼僧三比丘尼二一比丘尼。三二一式叉摩尼。三二一沙弥三二一沙弥尼。皆突吉罗。若比丘知是物向此一沙弥。求向余一沙弥。突吉罗。若比丘知是物向此一沙弥。求向三沙弥尼。二一沙弥尼。比丘僧三比丘二一比丘。比丘尼僧三比丘尼二一比丘尼。三式叉摩尼二一式叉摩尼。三沙弥二一沙弥。皆突吉罗。若比丘知是物向此三沙弥尼。求向余三沙弥尼。突吉罗。若比丘知是物向此三沙弥尼。求向余二一沙弥尼。比丘僧三二一比丘。比丘尼僧三比丘尼。二一比丘尼。三二一式叉摩尼。三二一沙弥。皆突吉罗。若比丘知是物向二沙弥尼。求向余二沙弥尼。突吉罗。若比丘知是物向二沙弥尼。求向一沙弥尼。比丘僧三二一比丘。比丘尼僧三比丘尼二一比丘尼。三二一式叉摩尼。三二一沙弥。三二一沙弥尼。皆突吉罗。若比丘知是物向此一沙弥尼。求向余一沙弥尼突吉罗。若比丘知是物向一沙弥尼。求向比丘僧。三比丘二一比丘比丘尼僧三比丘尼二一比丘尼。三二一式叉摩尼。三二一沙弥。三二一沙弥尼。皆突吉罗。若比丘知是物向此多畜生。求向余多畜生。突吉罗。若比丘知是物向多畜生。求向二畜生一畜生突吉罗。若比丘知是物向此二畜生。求向余二畜生。突吉罗。若比丘知是物向二畜生。求向一畜生多畜生突吉罗。若比丘知是物向此一畜生。求向余一畜生。突吉罗。若比丘知是物向一畜生。求向多畜生二畜生。突吉罗。若比丘知是物向比丘僧。求向比丘尼僧。突吉罗。若比丘知是物向比丘尼僧。求向比丘僧突吉罗。若比丘僧破为二部比丘。知是物向此一部。求向余一部。突吉罗。若比丘向中生向想。得尼萨耆波夜提。若向中生不向想。亦得尼萨耆波夜提。若向中生疑尼萨耆波夜提。若不向中生向想得突吉罗。若不向中生疑得突吉罗。若不向中生不向想不犯(二十九事竟)

佛在舍卫国。与大比丘僧安居。尔时长老毕陵伽婆蹉。王舍城安居。多有知识。大德酥油蜜石蜜。是长老多得故一钵半钵。拘钵多罗。半拘钵多罗。大揵镃小揵镃。或络囊盛。悬象牙杙上。从中取时翻弃污壁。卧具烂坏污墁房舍。房舍臭处。是长老毕陵伽婆蹉弟子。举宿而食。恶捉不受内宿诸佛在世法。岁二时大会。春末后月夏末后月。春末月者。诸方国土处处诸比丘来诣佛所。作是念。佛所说法。我等当安居时修习得安乐住。是初大会。夏末月者。诸比丘夏三月安居竟作衣毕。持衣钵诣佛所。作是念。我等久不见佛。久不见世尊。是第二大会。尔时有一比丘。王舍城安居竟作衣毕。持衣钵游行到舍卫国。往诣佛所。头面礼足在一面立。诸佛常法。若客比丘来。以如是语劳问诸比丘。忍不足不。安乐住不。乞食不乏。道路不疲耶。尔时佛以如是语劳问是比丘。忍不足不。安乐住不。乞食不乏。道路不疲耶。比丘答言。世尊。忍足安乐住。乞食不乏。道路不疲。以上事向佛广说。佛以是事集比丘僧。种种因缘呵责。我怜愍利益病比丘故。听服四种含消药酥油蜜石蜜。云何是比丘。举宿而食。恶捉不受内宿。种种因缘呵已。语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘病。听服四种含消药酥油蜜石蜜。共宿至七日得服。过是服是。尼萨耆波夜提。病者。若风发热发冷发。服是四种药可差者。是名病。不病者。异是因缘名为不病。尼萨耆波夜提者。是药应舍。波夜提罪应悔过。是中犯者。若比丘一日得酥畜二日舍。二日得畜三日舍。三日得畜四日舍。四日得畜五日舍。五日得畜六日舍。六日得畜七日舍。七日得七日时。比丘是酥应与人。若作净若服。若比丘不与人不作净不服。至第八日地了时。尼萨耆波夜提。若比丘一日得酥二日更得。畜一舍一。二日得酥三日更得。畜一舍一。三日得酥四日更得。畜一舍一。四日得酥五日更得。畜一舍一。五日得酥六日更得。畜一舍一。六日得酥七日更得。七日时比丘是酥应与人。若作净若服。若不与人不作净不服。至第八日地了时。尼萨耆波夜提。若比丘一日得酥畜二日。更得畜后舍前。二日得酥三日更得。畜后舍前。三日得酥四日更得。畜后舍前。四日得酥五日更得。畜后舍前。五日得酥六日更得。畜后舍前。六日得酥七日更得。七日时比丘是酥应与人。若作净若服。若不与人不作净不服。至第八日地了时。尼萨耆波夜提。若比丘一日得酥二日更得。畜前舍后。二日得酥三日更得。畜前舍后。三日得酥四日更得。畜前舍后。四日得酥五日更得。畜前舍后。五日得酥六日更得。畜前舍后。六日得酥七日更得。七日时比丘是酥应与人。若作净若服。若不与人不作净不服。至第八日地了时。尼萨耆波夜提。若比丘一日得酥畜。二日不得。三四五六七日不得。七日时比丘是酥应与人。若作净若服。若不与人不作净不服。至第八日地了时。尼萨耆波夜提。若比丘一日得酥畜。二日更得。三四五六七日更得。七日时比丘是酥皆应与人。若作净若服。若不与人不作净不服。至第八日地了时。尼萨耆波夜提。若比丘有应舍酥。未舍罪未悔过。次续未断更得酥。是后酥得尼萨耆波夜提。本酥因缘故。又比丘应舍酥已舍罪未悔过次续未断。更得酥。是后酥得尼萨耆波逸提。本酥因缘故。又比丘应舍酥已舍。罪已悔过。次续未断。更得酥。是后酥得尼萨耆波夜提。本酥因缘故。又比丘应舍酥已舍。罪已悔过。次续已断更得酥。不犯。油蜜石蜜亦如是。若重病不犯(三十事竟)

十诵律卷第八佛在舍卫国。尔时有一居士。发心欲与佛及僧饮食。复与僧衣。时世饥俭乞食难得。是居士财物不多。夏时已过。心中忧愁作是言。今何痛恼苦急乃尔。我本心欲与佛及僧饮食。复与僧衣。时世饥俭乞求难得。我财物少夏时已过。心中忧愁苦急不满我愿。我今当从僧中少多。请比丘与食与僧衣。令我福德不空。作是念已。便入祇洹打揵椎。有比丘问居士。何因缘故打椎。居士答言。我欲从僧中请尔所比丘到我舍。时知会人。即差尔所比丘去。次到六群比丘。六群比丘先时有次请。便持衣钵先到。请家办饮食时。教如是如是作。是时六群比丘。晨朝持衣钵到是居士舍。共相问讯在一面坐。居士作礼已在前坐。自向六群比丘软语。我本心欲与佛及僧饮食复与僧衣。今世饥俭乞求难得。我财物少夏时已过。心中忧愁苦急作是念。我今当从僧中请少多比丘与食。便与众僧衣。令我不失福德。以是因缘故。食与汝等衣当与僧。时六群比丘闻衣名心动。语居士言。是衣何似。持来示我。居士言善。即出衣示之。六群比丘见衣倍生贪心。语居士言。汝意欲令是衣有用耶。欲令举置耶。居士言。所以施者欲令用之。汝若欲令不用者当与僧。何以故。僧多有衣举在一处。朽坏虫啖。若令用者当与我等。我等少衣得布施我等当用。居士言。汝等知与僧不用。若汝等能用者便当相与。居士与食食已。持是衣与六群比丘。食已持是衣去入祇洹示诸比丘。是衣何似细好不。诸比丘言实好。汝何从得。六群比丘广说是事。是中有比丘少欲知足行头陀。闻是事心不喜。种种因缘呵责。云何名比丘。知物向僧自求向己。种种因缘呵已向佛广说。佛以是事集比丘僧。知而故问六群比丘。汝实作是事不。答言。实作世尊。佛以种种因缘呵责六群比丘。云何名比丘。知物向僧自求向己。佛以种种因缘呵已语诸比丘。以十利故与诸比丘结戒。从今是戒应如是说。若比丘知物向僧自求向己。尼萨耆波逸提。知者若自知若从他闻若檀越语。物者谓施僧物。若衣钵户钩澡灌时药时分药七日药终身药。向僧者。发心欲与僧未定与。尼萨耆波逸提者。是衣应舍。波逸提罪应悔过。是中犯者。若比丘知是物向比丘僧。自求向己。尼萨耆波逸提。若向三二一突吉罗。若比丘尼知是物向比丘尼僧自求向己。尼萨耆波逸提。若向三二一突吉罗。若比丘知是物向此三比丘。求向余三比丘。突吉罗。若比丘知是物向三比丘。求向二比丘一比丘。比丘尼僧。三比丘尼二比丘尼一比丘尼。三式叉摩尼二式叉摩尼一式叉摩尼。三沙弥二沙弥一沙弥。三沙弥尼二沙弥尼一沙弥尼。比丘僧。皆突吉罗。若比丘知是物向此二比丘。求向余二比丘。突吉罗。若知是物向二比丘。求向一比丘。比丘尼僧。三比丘尼二比丘尼一比丘尼。三式叉摩尼二式叉摩尼一式叉摩尼。三沙弥二沙弥一沙弥三沙弥尼二沙弥尼一沙弥尼。比丘僧三二一比丘。皆突吉罗。若比丘知是物向此一比丘。求向余一比丘。突吉罗。若知是物向一比丘。求向比丘尼僧。三比丘尼二比丘尼一比丘尼三式叉摩尼二式叉摩尼一式叉摩尼。三沙弥二一沙弥。三沙弥尼二一沙弥尼。比丘僧三比丘二比丘一比丘。皆突吉罗。若比丘知物向此三比丘尼。求向余三比丘尼。突吉罗。若比丘知是物向三比丘尼。求向二比丘尼一比丘尼。三式叉摩尼二一式叉摩尼。三沙弥二一沙弥。三沙弥尼二一沙弥尼。比丘僧三比丘二一比丘。比丘尼僧。皆突吉罗。若比丘知是物向此二比丘尼。求向余二比丘尼。突吉罗。若比丘知是物向二比丘尼。求向一比丘尼三式叉摩尼。二一式叉摩尼。三沙弥。二一沙弥三沙弥尼。二一沙弥尼比丘僧。三比丘二一比丘比丘尼僧。三二一比丘尼。皆突吉罗。若比丘知是物向此一比丘尼。求向余一比丘尼。突吉罗。若比丘知是物向一比丘尼。求向三式叉摩尼二式叉摩尼一式叉摩尼。三沙弥二一沙弥三沙弥尼。二一沙弥尼。比丘僧三比丘二一比丘比丘尼僧三比丘尼。二一比丘尼皆突吉罗。若比丘知是物向此三式叉摩尼。求向余三式叉摩尼。突吉罗。若比丘知是物向三式叉摩尼。求向二式叉摩尼。一式叉摩尼三沙弥二一沙弥。三沙弥尼二一沙弥尼。比丘僧。三比丘二一比丘。比丘尼僧。三比丘尼二比丘尼一比丘尼。皆突吉罗。若比丘知是物向此一式叉摩尼。求向余二式叉摩尼。突吉罗。若比丘知是物向二式叉摩尼。求向一式叉摩尼。三沙弥二一沙弥。三沙弥尼二一沙弥尼。比丘僧。三比丘二一比丘。比丘尼僧。三比丘尼二一比丘尼。三式叉摩尼。皆突吉罗。若比丘知是物向此一式叉摩尼。求向余一式叉摩尼。突吉罗。若知是物向一式叉摩尼。求向三沙弥二一沙弥。三沙弥尼二一沙弥尼。比丘僧。三比丘二一比丘。比丘尼僧。三比丘尼二一比丘尼。三式叉摩尼二式叉摩尼。皆突吉罗。若比丘知是物向此三沙弥。求向余三沙弥。突吉罗。若比丘知是物向三沙弥。求向二沙弥一沙弥。三沙弥尼二一沙弥尼。比丘僧。三比丘二一比丘。比丘尼僧。三比丘尼二一比丘尼。三式叉摩尼二一式叉摩尼。皆突吉罗。若比丘知是物向此二沙弥。求向余二沙弥。突吉罗。若比丘知是物向二沙弥。求向一沙弥。三沙弥尼二一沙弥尼。比丘僧。三比丘二一比丘。比丘尼僧。三比丘尼二一比丘尼。三式叉摩尼二一式叉摩尼。三沙弥。皆突吉罗。若比丘知是物向此一沙弥。求向余一沙弥。突吉罗。若比丘知是物向此一沙弥。求向三沙弥尼二一沙弥尼。比丘僧。三比丘二一比丘。比丘尼僧。三比丘尼二一比丘尼。三式叉摩尼二一式叉摩尼。三沙弥二一沙弥。皆突吉罗。若比丘知是物向此三沙弥尼。求向余三沙弥尼。突吉罗。若比丘知是物向此三沙弥尼。求向余二沙弥尼一沙弥尼。比丘僧。三比丘二一比丘。比丘尼僧。三比丘尼二一比丘尼。三式叉摩尼二一式叉摩尼。三沙弥二一沙弥。皆突吉罗。若比丘知是物向此二沙弥尼。求向余二沙弥尼。突吉罗。若比丘知是物向二沙弥尼。求向一沙弥尼。比丘僧。三比丘二一比丘。比丘尼僧。三比丘尼二一比丘尼。三式叉摩尼二一式叉摩尼。三沙弥二一沙弥。三二一沙弥尼。皆突吉罗。若比丘知是物向此一沙弥尼。求向余一沙弥尼。突吉罗。若比丘知是物向一沙弥尼。求向比丘僧。三比丘二一比丘。比丘尼僧。三比丘尼二一比丘尼。三式叉摩尼二一式叉摩尼。三沙弥二一沙弥。三沙弥尼二一沙弥尼。皆突吉罗。若比丘知是物向此多畜生。求向余多畜生。突吉罗。若比丘知是物向多畜生。求向二畜生一畜生。突吉罗。若比丘知是物向此二畜生。求向余二畜生。突吉罗。若比丘知是物向二畜生。求向一畜生多畜生。突吉罗。若比丘知是物向此一畜生。求向余一畜生。突吉罗。若比丘知是物向此一畜生。求向多畜生二畜生。突吉罗。若比丘知是物向比丘僧。求向比丘尼僧。突吉罗。若比丘知是物向比丘尼僧。求向比丘僧。突吉罗。若比丘僧破为二部。比丘知是物向此一部。求向余一部。突吉罗。若比丘向中生向想。得尼萨耆波逸提。若向中生不向想。亦尼萨耆波逸提。若向中生疑。尼萨耆波逸提。若不向中生向想。得突吉罗。若不向中生疑。得突吉罗。若不向中生不向想。不犯(二十九事竟)十诵律卷第九(二诵之三)

        后秦北印度三藏弗若多罗译

    明九十波夜提法之一

佛在舍卫国。尔时南天竺有论议师。以铜鍱鍱腹头上然火来入舍卫国。时人问言。汝何因缘尔。答言。我智慧多。恐腹裂故。汝头上何以着火。欲照闇故。语言。痴婆罗门。日照天下。何以言闇。答言。汝等不知。闇有二种。一者无日月火烛。二者愚痴无智慧明。诸人言。汝未见诃哆释子比丘。故敢作是语。若见共语者。日出则闇。夜则日出。时城内人民。即唤诃哆释子比丘。欲令共论。时诃哆闻之心愁。不得已而来入城道中。见二羝羊共斗。即因取相作是念。一羊是婆罗门。一羊是我。是我者斗则不如。见已转更愁忧。前行又见二牛共斗。复作是念。一牛是婆罗门。一牛是我。是我者即复不如。又前行复见二人相扑。作是念。一是婆罗门。一是我。我者即复不如。欲入论处。见一女人持满。瓶水水瓶即破。复作是念。我见诸不吉相。将无不如。不得已。便前入舍。见是论师婆罗门眼口相貌。自知不如愁忧更甚。适坐须臾。诸人便言可共论议。答言。我今小不安隐。须待明日。作是语已便还宿处。至后夜时即向王舍城。明旦城中人集。久待不来。知时已过。自到只桓推寻求之。余比丘言。诃哆释子即后夜时持衣钵去。诸城内人闻已种种呵责。云何名比丘。故妄语。一人语二人。二人语三人。如是展转恶名流布满舍卫城。是中有比丘。少欲知足行头陀。着衣持钵入城乞食。闻是事心不喜。食已向佛广说。佛以是事集比丘僧。以种种因缘呵责。云何名比丘。故妄语。种种呵已语诸比丘。以十利故与诸比丘结戒。从今是戒应如是说。若比丘故妄语者。波夜提。故妄语者。知是事不尔。诳他故异说。波夜提者。是罪名烧煮覆障。若不悔过。能障阂道。是中犯者。有五种。有妄语入突吉罗。有入波夜提。有入偷兰遮。有入僧伽婆尸沙。有入波罗夷。有入波罗夷者。自知无圣法。语人言。我有圣法。是名入波罗夷。入僧伽婆尸沙者。以无根四波罗夷法。谤他比丘故。入偷兰遮者。不具足波罗夷妄语。亦不具足僧伽婆尸沙妄语故。入波夜提者。若比丘以无根僧伽婆尸沙。谤他比丘故。入突吉罗者。除四种妄语。余妄语犯突吉罗。若比丘不见事言见。波夜提。若见言不见。波夜提。若见谓不见。语他言见。波夜提。若不见谓见。语他言不见。波夜提。若见已疑。为见不见。语他言不见。波夜提。若不见疑。为见不见。语他言见。波夜提。闻觉知亦如是。若随心想说不犯(一事竟)

佛在王舍城。尔时六群比丘。喜斗诤相骂。是六群比丘与诸比丘共斗诤已。便出他过形相轻唤。下贱种姓下贱名字技术作业。是时有未诤者便诤。已诤者不欲止。未出事便出。已出事不可灭。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘呵责。云何名比丘。喜斗诤相骂。共他诤已。便出其过形相轻唤。下贱种姓名字技术。是时有未诤者便诤。已诤者不欲止。未出事便出。已出事不可灭。种种因缘呵已向佛广说。佛以是事集比丘僧。知而故问六群比丘。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘。喜斗诤相骂。共他诤已。便出其过形相轻唤。下贱种姓名字技术。是时有未诤者便诤。已诤者不欲止。未出事便出。已出事不可灭。佛种种因缘呵已。说本生因缘。佛语诸比丘。过去有人有一黑牛。复有一人亦有一牛。为财物故唱言。谁牛力胜我牛者。我输尔所物。若不如者输我尔所物。时黑牛主闻是唱声。答言可尔。时载重物系牛车左。形相轻唤谓黑曲角。以杖击之牵是车去。时牛闻是形相骂故。即失色力。不能挽重上阪。时黑牛主大输财物。是得物人后复更唱。谁牛力胜。我输尔所物。是时黑牛闻是唱声。便语主言。是人何故复唱斯言。时主答曰。贪财物故复作是唱。黑牛语主。可答言尔。主言不能。所以然者。以汝弊恶牛故。大输我物。今复作者输我物尽。牛语主言。先在众人前形相轻我。以下贱名唤谓黑曲角。闻恶名故即失色力。是故不能挽重上阪。今授主语。莫出恶言。在他前时便语我言。汝犊子时刺入脚中。自看是刺欲得出故。角入地中故曲。汝是好黑大牛。生来良吉角广且直。主受牛语。即便洗刷麻油涂角。着好华鬘系车右边。柔软爱语。大吉黑牛广角大力。牵是车去。是牛闻是柔软爱语故。即得色力牵重上阪。时黑牛主。先所失物更再三倍得。是牛主得大利已。心甚欢喜。即说偈言

  载重入深辙　　随我语能去
  是故应软语　　不应出恶言
  软语有色力　　是牛能牵重
  我获大财物　　身心得喜乐

佛语诸比丘。畜生闻形相语尚失色力。何况于人。时佛以种种因缘呵已语诸比丘。以十利故与诸比丘结戒。从今是戒应如是说。若比丘形相他者。波夜提。波夜提者。煮烧覆障。若不悔过能障阂道。是中犯者。有八种。谓种技作犯病相烦恼骂种者。若比丘往语刹利子比丘言。汝刹利种。用出家受戒为。轻毁心故。一一语突吉罗。又比丘往语婆罗门子比丘言。汝婆罗门种。用出家受戒为。轻毁心故。一一语突吉罗。又比丘往语估客子比丘言。汝估客种。用出家受戒为。轻毁心故。一一语中突吉罗。又比丘往语锻师子比丘言。汝锻师种。用出家受戒为。轻毁心故。一一语波夜提。又比丘往语木师子比丘言。汝木师种。用出家受戒为。轻毁心故。一一语波夜提。又比丘往语陶师子比丘言。汝陶师种。用出家受戒为。轻毁心故。一一语波夜提。若比丘往语皮师子比丘言。汝皮师种。用出家受戒为。轻毁心故。一一语波夜提。又比丘往语竹师子比丘言。汝竹师种。用出家受戒为。轻毁心故。一一语波夜提。又比丘往语剃毛发师子比丘言。汝剃毛发师种。用出家受戒为。轻毁心故。一一语波夜提。又比丘往语旃陀罗子比丘言。汝旃陀罗种。用出家受戒为。轻毁心故。一一语波夜提。是名为种。技者。若比丘往语刹利子比丘言。汝刹利种。用出家受戒为。汝应学乘象马乘车辇舆。学捉刀楯弓箭。学捉铁钩。学掷网罗。学入阵出阵。如是种种刹利技术汝应学。轻毁心故。一一语突吉罗罪。又比丘往语婆罗门子比丘言。汝婆罗门种。用出家受戒为。汝应学围陀经亦教他学。自作天祠亦教他作。学饮食咒蛇咒疾行咒劬罗咒揵陀罗咒。如是种种婆罗门技术汝应学。轻毁心故。一一语突吉罗。又比丘往语估客子比丘言。汝估客种。用出家受戒为。汝应学书算数印相。学知金银相丝绵缯彩。学坐金肆银肆客作肆铜肆珠肆。如是种种估客技术汝应学。轻毁心故。一一语突吉罗。又比丘往语锻师子比丘言。汝锻师种。用出家受戒为。汝应学作钏鉡锁鼎。[金*敖]铧锹钁。斧槊大刀小刀。钵拘钵多罗。半拘钵多罗。大揵镃小犍镃。剃刀针钩锁钥。如是种种锻师技术汝应学。轻毁心故。一一语波夜提。又比丘往语木师子比丘言。汝木师种。用出家受戒为。汝应学作机关木人若男若女。学作盆盂耧犁车乘辇舆。如是种种木师技术汝应学。轻毁心故。一一语波夜提。又比丘往语陶师子比丘言。汝陶师种。用出家受戒为。汝应学知土相取土调泥着水多少。学转轮作盆瓶釜盖。大钵拘钵多罗。半拘钵多罗。大揵镃小揵镃。如是种种陶师技术汝应学。轻毁心故。一一语波夜提。又比丘往语皮师子比丘言。汝皮师种。用出家受戒为。汝应学知皮相渍皮坚软裁割缝连作富罗革屣。学治浸皮摩刬皮知皮表里。学作鞍勒鞭[革*必]。如是种种皮师技术汝应学。轻毁心故。一一语波夜提。又比丘往语竹师子比丘言。汝竹师种。用出家受戒为。汝应学知竹苇相浸竹坚软。学破学屈学作槊箭扇盖箱箪。如是种种竹师技术汝应学。轻毁心故。一一语波夜提。又比丘往语剃毛师子比丘言。汝剃毛师种。用出家受戒为。汝应学知留顶上周罗发。学剃须剃腋下毛剪爪甲镊鼻毛。如是种种剃毛师技术汝应学。轻毁心故。一一语波夜提。又比丘往语旃陀罗子比丘言。汝旃陀罗种。用出家受戒为。汝应学截人手足耳鼻头持着木上。学担死人出烧。如是种种旃陀罗技术汝应学。轻毁心故。一一语波夜提。是名为技。作者。若比丘往语刹利子比丘言。汝刹利种。用出家受戒为。汝应学乘象马辇舆捉刀楯弓箭掷钩网罗入阵出阵。如是种种刹利事汝应作。轻毁心故。一一语突吉罗。又比丘往语婆罗门子比丘言。汝婆罗门种。用出家受戒为。汝应读围陀经亦应教他人读。自作天祠亦教他作。读饮食咒蛇咒疾行咒劬罗咒揵陀罗咒。如是种种婆罗门事汝应作。轻毁心故。一一语突吉罗。又比丘往语估客子比丘言。汝估客种。用出家受戒为。汝应坐金肆银肆铜肆客作肆珠肆。如是种种估客事汝应作。轻毁心故。一一语突吉罗。又比丘往语锻师子比丘言。汝锻师种。用出家受戒为。汝应作钏鉡锁鼎。[金*敖]铧锹钁斧槊大刀小刀。钵拘钵多罗半拘钵多罗。大揵镃小揵镃剃刀针钩锁钥。如是种种锻师事汝应作。轻毁心故。一一语波夜提。又比丘往语木师子比丘言。汝木师种。用出家受戒为。汝应作机关木人盆盂耧犁车乘辇舆。如是种种木师事汝应作。轻毁心故。一一语波夜提。又比丘往语陶师子比丘言。汝陶师种。用出家受戒为。汝应取土调泥。转轮作盆瓶瓮釜盖。大钵拘钵多罗。半拘钵多罗。大揵镃小揵镃。如是种种陶师事汝应作。轻毁心故。一一语波夜提。又比丘往语皮师子比丘言。汝皮师种。用出家受戒为。汝应取皮浸治割截连缝。作富罗革屣鞍勒鞭[革*必]。如是种种皮师事汝应作。轻毁心故。一一语波夜提。又比丘往语竹师子比丘言。汝竹师种。用出家受戒为。汝应破竹苇作槊作箭扇盖箱箪。如是种种竹师事汝应作。轻毁心故。一一语波夜提。又比丘往语剃毛师子比丘言。汝剃毛师种。用出家受戒为。汝应剃毛须发。剃腋下毛。剪爪甲镊鼻毛。如是种种剃毛师事汝应作。轻毁心故。一一语波夜提。又比丘往语旃陀罗子比丘言。汝旃陀罗种。用出家受戒为。汝应断人手足耳鼻头。持着木上担死人出烧。如是种种旃陀罗事汝应作。轻毁心故。一一语波夜提。是名为作。犯者。若比丘往语余比丘言。汝犯罪人。用出家受戒为。汝犯僧伽婆尸沙。犯波夜提。犯波罗提提舍尼突吉罗。轻毁心故。一一语波夜提。是名为犯。病者。若比丘语余比丘言。汝恶疾病人。用出家受戒为。汝有癞病痈病白癞病干病痟病鬼病。轻毁心故。一一语波夜提。是名为病。相者。若比丘往语余比丘言。汝恶相人。用出家受戒为。汝卷手兀手瘿癖左作臂似鸟翅。轻毁心故。一一语波夜提。是名为相。烦恼者。若比丘往语余比丘言。汝重烦恼人用出家受戒为。汝多欲多嗔多痴喜忧恼轻毁心故。一一语波夜提。是名烦恼。骂者。若比丘往语余比丘言。汝喜骂人。用出家受戒为。汝作二种骂骂他。一者白衣骂。二者出家骂。令心苦恼。轻毁心故。一一语波夜提。是名为骂。若比丘以是八种语语余比丘。轻毁心故。波夜提。除是八种。若以余事轻毁比丘者。突吉罗。若除比丘以八种轻毁余人者。突吉罗(二事竟)

佛在王舍城。尔时六群比丘喜斗诤相言六。群比丘与余比丘共斗诤故。诸比丘僧分为二部。是六群比丘往语一部言。汝等知不。彼部说。汝等用出家受戒为。汝等某名某姓某种某作某相。复还语一部言。汝等知不。彼部说。汝等用出家受戒为。汝等某名某姓某种某作某相。是时有未破者便破。已破者不和合。未出事便出。已出事不可灭。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘呵责。云何名比丘。喜斗诤令比丘僧破为二部。便语一部言。彼诸比丘说。汝等用出家受戒为。汝等某名某姓某种某作某相。复还语一部言。汝等知不。彼诸比丘说。汝等用出家受戒为。汝等某名某姓某种某作某相。是时有未破者便破。已破者不和合。未出事便出。已出事不可灭。种种因缘呵已向佛广说。佛以是事集比丘僧。知而故问六群比丘。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘。斗诤令比丘僧破为二部。便往语一部言。彼诸比丘说。汝等用出家受戒为。汝等某名某姓某种某作某相。复语一部言。彼诸比丘说。汝等用出家受戒为。汝等某名某姓某种某作某相。是时有未破者便破。已破者不可和合。未出事便出。已出事不可灭。佛种种因缘呵已。即说本生因缘。语诸比丘。过去世雪山下有二兽。一名好毛师子。二名好牙虎。共为善知识。相亲爱念相问讯。时闭目相舐毛。是二兽恒得软好肉啖。去是不远。有两舌野干。野干作是念。是好毛师子好牙虎共作善知识。相亲爱念相问讯。时闭目相舐毛。恒得好软肉啖。我当至是二兽边作第三伴。作是念已。到虎师子所。作是言。我与汝作第三伴。汝听我入不。师子虎言。随意。两舌野干。得二兽残肉啖故。身体肥大。肥已作是念。是好毛师子好牙虎。共为善知识。相亲爱念相问讯。时闭目相舐毛。恒得好肉啖。或时不得必当啖我。我何不先作方便令心别离。别离已皆从我受恩。作是念已。往语师子言。汝知不。好牙虎有恶心于汝。作是言。好毛师子有所食啖。皆是我力。说是偈言

  虽有好毛色　　剿疾人所畏
  好毛不胜我　　好牙作是说

好毛师子言。云何得知。两舌野干答言。好牙虎明日见汝时。闭目舐汝毛者。当知恶相。作是语已往语虎言。汝知不。好毛师子于汝有恶心。作是言。好牙有所食啖。皆是我力。说是偈言

  虽有好牙色　　剿疾人所畏
  好牙不胜我　　好毛作是说

云何得知。答言。好毛明日见汝时。闭目舐汝毛者。当知恶相。是二知识中。虎生畏想。是故先往师子所言。汝于我生恶心。作如是言。好牙有所食啖。皆是我力。复说偈言

  虽有好牙色　　剿疾人所畏
  好牙不胜我　　汝作是说耶

师子言。谁作是语。答言。两舌野干。好毛复问言。汝于我生恶心。作如是言。好毛有所食啖。皆是我力。复说偈言

  虽有好毛色　　剿疾人所畏
  好毛不胜我　　汝作是说耶

虎言不也。虎语师子言。汝若有是恶语者。不得共作善知识。好毛言。是两舌野干有如此言。于意云何。不喜共我住耶。即说偈言

  若信是恶人　　则速别离去
  常怀其愁忧　　嗔恨不离心
  凡为善知识　　不以他语离
  不信欲除者　　常觅其方便
  若信他别离　　则为其所食
  不信两舌者　　还共作和合
  所怀相向说　　心净言柔软
  应作善知识　　和合如水乳
  今此弊小虫　　生来性自恶
  一头而两舌　　杀之则和合

尔时虎与师子。验事实已。共捉野干破作二分。佛言。畜生尚以两舌因缘故得不安乐何况于人。佛以是因缘呵已。语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘两舌者。波夜提。波夜提者。名烧煮覆障。若不悔过。能障碍道。是中犯者有八种。谓种伎作犯病相烦恼骂。是八事中皆用五事。如是名如是姓如是种如是作如是相。如是名者。某甲某甲比丘名。姓者。婆蹉姓俱磋姓伤提罗姓婆罗堕姓阿支罗姓。是名姓。种者。刹利种婆罗门种毗舍种。首陀罗种作者。作卖金肆卖银肆客作肆珠肆。相者。卷手兀手瘿癖左作臂似鸟翅。是名相。种者。若比丘往语刹利子比丘言。彼说汝刹利种。用出家受戒为。彼是谁耶。答曰名某。某名是谁。答曰某姓。某姓是谁。答曰某种。某种是谁。答曰某作。某作是谁。答曰某相。若彼解者突吉罗。不解者亦突吉罗。解已更说亦突吉罗。若比丘往语婆罗门子比丘言。彼说汝婆罗门种。用出家受戒为。彼是谁耶。答曰名某。某名是谁。答曰某姓。某姓是谁。答曰某种。某种是谁。答曰某作。某作是谁。答曰某相。若彼解者突吉罗。不解者亦突吉罗。解已更说亦突吉罗。若比丘往语估客子比丘言。彼说汝估客种。用出家受戒为。彼是谁耶。答曰名某。某名是谁。答曰某姓。某姓是谁。答曰某种。某种是谁。答曰某作。某作是谁。答曰某相。若彼解者突吉罗。不解者亦突吉罗。解已更说亦突吉罗。又比丘往语锻师子比丘言。彼说汝锻师种。用出家受戒为。彼是谁耶。答曰名某。某名是谁。答曰某姓。某姓是谁。答曰某种。某种是谁。答曰某作。某作是谁。答曰某相。若彼解者波夜提。不解者突吉罗。解已更说得波夜提突吉罗。又比丘往语木师子比丘。言彼说汝木师。种用出家受戒为。彼是谁耶。答曰名某。某名是谁。答曰某姓。某姓是谁。答曰某种。某种是谁。答曰某作。某作是谁。答曰某相。若彼解者波夜提。不解者突吉罗。解已更说者波夜提突吉罗。又比丘往语陶师子比丘言。彼说汝陶师种。用出家受戒为。彼是谁耶。答曰名某。某名是谁。答曰某姓。某姓是谁。答曰某种。某种是谁。答曰某作。某作是谁。答曰某相。若彼解者波夜提。不解者突吉罗。解已更说波夜提突吉罗。又比丘往语皮师子比丘言。彼说汝皮师种。用出家受戒为。彼是谁耶。答曰名某。某名是谁。答曰某姓。某姓是谁。答曰某种。某种是谁。答曰某作。某作是谁。答曰某相。若彼解者波夜提。不解者突吉罗。解已更说波夜提突吉罗。又比丘往语竹师子比丘言。彼说汝竹师种。用出家受戒为。彼是谁耶。答曰名某。某名是谁。答曰某姓。某姓是谁。答曰某种。某种是谁。答曰某作。某作是谁。答曰某相。若彼解者波夜提。不解者突吉罗。解已更说波夜提突吉罗。又比丘往语剃毛发师子比丘言。彼说汝剃毛师种。用出家受戒为。彼是谁耶。答曰名某。某名是谁。答曰某姓。某姓是谁。答曰某种。某种是谁。答曰某作。某作是谁。答曰某相。若彼解者波夜提。不解者突吉罗。解已更说波夜提突吉罗。又比丘往语旃陀罗子比丘言。彼说汝旃陀罗种。用出家受戒为。彼是谁耶。答曰名某。某名是谁。答曰某姓。某姓是谁。答曰某种。某种是谁。答曰某作。某作是谁。答曰某相。若彼解者波夜提。若不解者突吉罗。解已更说波夜提突吉罗。是名为种。伎者。若比丘往语刹利子比丘言。彼说汝刹利种。应学乘象马车舆。捉刀楯弓箭。掷钩掷网罗。入阵出阵。如是种种刹利伎术汝应学。用出家受戒为。彼是谁耶。答曰名某。某名是谁。答曰某姓。某姓是谁。答曰某种。某种是谁。答曰某作。某作是谁。答曰某相。若彼解者突吉罗。不解者亦突吉罗。解已更说亦突吉罗。又比丘往语婆罗门子比丘言。彼说汝婆罗门种。应学围陀经亦教他学。自作天祠亦教他作。读饮食咒蛇咒疾行咒劬罗咒乾陀罗咒。如是种种婆罗门伎术汝应学。用出家受戒为。彼是谁耶。答曰名某。某名是谁。答曰某姓。某姓是谁。答曰某种。某种是谁。答曰某作。某作是谁。答曰某相。若彼解者突吉罗。不解者亦突吉罗。解已更说亦突吉罗。又比丘往语估客子比丘言。彼说汝估客种。应学算书数印相。学知金银相丝绵缯彩。应坐金肆银肆客作肆铜肆珠肆。如是种种估客伎术汝应学。用出家受戒为。彼是谁耶。答曰名某。某名是谁。答曰某姓。某姓是谁。答曰某种。某种是谁。答曰某作。某作是谁。答曰某相。若彼解者突吉罗。不解者亦突吉罗。解已更说亦突吉罗。又比丘往语锻师子比丘言。彼说汝锻师种。应学作钏鉡锁鼎[金*敖]铧锹钁斧槊大刀小刀。钵钩钵多罗半钩钵多罗。大揵镃小揵镃剃刀针钩锁钥。如是种种锻师伎术汝应学。用出家受戒为。彼是谁耶。答曰名某。某名是谁。答曰某姓。某姓是谁。答曰某种。某种是谁。答曰某作。某作是谁。答曰某相。若彼解者波夜提。不解者突吉罗。解已更说波夜提突吉罗。又比丘往语木师子比丘言。彼说汝木师种。应学作机关木人。盆盂耧犁车乘辇舆。如是种种木师伎术汝应学。用出家受戒为。彼是谁耶。答曰名某。某名是谁。答曰某姓。某姓是谁。答曰某种。某种是谁。答曰某作。某作是谁。答曰某相。若彼解者波夜提。不解者突吉罗解已更说波夜提突吉罗。又比丘往语陶师子比丘言。彼说汝陶师种。应学知土相取土调泥学转轮作盆瓶釜盖。钵拘钵多罗半拘钵多罗。大揵镃小揵镃。如是种种陶师伎术汝应学。用出家受戒为。彼是谁耶。答曰名某。某名是谁。答曰某姓。某姓是谁。答曰某种。某种是谁。答曰某作。某作是谁。答曰某相。若彼解者波夜提。不解者突吉罗。解已更说波夜提突吉罗。又比丘往语皮师子比丘言。彼说汝皮师种。应学知皮相浸皮坚软。割截裁缝作靴富罗革屣。学治粗皮摩刬皮鞍勒鞭[革*必]。如是种种皮师伎术汝应学。用出家受戒为。彼是谁耶。答曰名某。某名是谁。答曰某姓。某姓是谁。答曰某种。某种是谁。答曰某作。某作是谁。答曰某相。若彼解者波夜提。不解者突吉罗。解已更说波夜提突吉罗。又比丘往语竹师子比丘言。彼说汝竹师种。应学知竹苇相浸竹坚软。学破学屈作扇盖箱箪。如是种种竹师伎术汝应学。用出家受戒为。彼是谁耶。答曰名某。某名是谁。答曰某姓。某姓是谁。答曰某种。某种是谁。答曰某作。某作是谁。答曰某相。若彼解者波夜提。不解者突吉罗。解已更说波夜提突吉罗。又比丘往语剃毛师子比丘言。彼说汝剃毛师种。应学知留顶上周罗发。学剃发剃须剃腋下毛。剪爪甲镊鼻毛。如是种种剃毛师伎术汝应学。用出家受戒为。彼是谁耶。答曰名某。某名是谁。答曰某姓。某姓是谁。答曰某种。某种是谁。答曰某作。某作是谁。答曰某相。若彼解者波夜提。不解者突吉罗。解已更说波夜提突吉罗。又比丘往语旃陀罗子比丘言。彼说汝旃陀罗种。应学断人手足耳鼻头。持着木上担死人出城烧。如是种种旃陀罗伎术汝应学。用出家受戒为。彼是谁耶。答曰名某。某名是谁。答曰某姓。某姓是谁。答曰某种。某种是谁。答曰某作。某作是谁。答曰某相。若彼解者波夜提。不解者突吉罗。解已更说波夜提突吉罗。是名为伎。作者。若比丘往语刹利子比丘言。彼说汝刹利种。应乘象马车舆。捉刀楯弓箭。掷钩网罗。入阵出阵。如是种种刹利种事汝应作。用出家受戒为。彼是谁耶。答曰名某。某名是谁。答曰某姓。某姓是谁。答曰某种。某种是谁。答曰某作。某作是谁。答曰某相。若彼解者突吉罗。不解者亦突吉罗。解已更说亦突吉罗。又比丘往语婆罗门子比丘言。彼说汝婆罗门种。应读围陀经亦教他读。自作天祠亦教他作。读饮食咒蛇咒疾行咒劬罗咒乾陀罗咒。如是种种婆罗门事汝应作。用出家受戒为。彼是谁耶。答曰名某。某名是谁。答曰某姓。某姓是谁。答曰某种。某种是谁。答曰某作。某作是谁。答曰某相。若彼解者突吉罗。不解者亦突吉罗。若解已更说亦突吉罗。又比丘往语估客子比丘言。彼说汝估客种。应坐金肆银肆客作肆铜肆珠肆。如是种种估客事汝应学。用出家受戒为。彼是谁耶。答曰名某。某名是谁。答曰某姓。某姓是谁。答曰某种。某种是谁。答曰某作。某作是谁。答曰某相。若彼解者突吉罗。不解者亦突吉罗。解已更说亦突吉罗。又比丘往语锻师子比丘言。彼说汝锻师种。应作钏鉡锁鼎。[金*敖]铧锹镬斧槊大刀小刀。钵拘钵多罗半拘钵多罗。大揵镃小揵镃。剃刀针钩钵钩锁钥。如是种种锻师事汝应作。用出家受戒为。彼是谁耶。答曰名某。某名是谁。答曰某姓。某姓是谁。答曰某种。某种是谁。答曰某作。某作是谁。答曰某相。若彼解者波夜提。不解者突吉罗。解已更说波夜提突吉罗。又比丘往语木师子比丘言。彼说汝木师种应作机关木人车舆耧犁。如是种种木师事汝应作用出家受戒为。彼是谁耶。答曰名某。某名是谁。答曰某姓。某姓是谁。答曰某种。某种是谁。答曰某作。某作是谁。答曰某相。若彼解者波夜提。不解者突吉罗。解已更说波夜提突吉罗。又比丘往语陶师子比丘言。彼说汝陶师种。应取土调泥。转轮作盆瓶瓮釜盖。钵拘钵多罗。半拘钵多罗大揵镃小揵镃。如是种种陶师事汝应作。用出家受戒为。彼是谁耶。答曰名某。某名是谁。答曰某姓。某姓是谁。答曰某种。某种是谁。答曰某作。某作是谁。答曰某相。若彼解者波夜提。不解者突吉罗。解已更说波夜提突吉罗。又比丘往语皮师子比丘言。彼说汝皮师种。应取皮浸治割截连缝。作靴富罗革屣鞍勒鞭[革*必]。如是种种皮师事汝应作。用出家受戒为。彼是谁耶。答曰名某。某名是谁。答曰某姓。某姓是谁。答曰某种。某种是谁。答曰某作。某作是谁。答曰某相。若彼解者波夜提。不解者突吉罗。解已更说波夜提突吉罗。又比丘往语竹师子比丘言。彼说汝竹师种。应学破竹苇作槊作箭扇盖箱簟。如是种种竹师事汝应学作。用出家受戒为。彼是谁耶。答曰名某。某名是谁。答曰某姓。某姓是谁。答曰某种。某种是谁。答曰某作。某作是谁。答曰某相。若彼解者波夜提。不解者突吉罗。解已更说波夜提突吉罗。又比丘往语剃毛师子比丘言。彼说汝剃毛师种。应学知留顶上周罗发。学剃发剃须剃腋下毛。剪爪甲镊鼻毛。如是种种剃毛师技术汝应学。用出家受戒为。彼是谁耶。答曰名某。某名是谁。答曰某姓。某姓是谁。答曰某种。某种是谁。答曰某作。某作是谁。答曰某相。若彼解者波夜提。不解者突吉罗。解已更说波夜提突吉罗。又比丘往语旃陀罗子比丘言。彼说汝旃陀罗种。应作断人手足耳鼻头。持着木上担死人出烧。如是种种旃陀罗事汝应作。用出家受戒为。彼是谁那。答曰名某。某名是谁。答曰某姓。某姓是谁。答曰某种。某种是谁。答曰某作。某作是谁。答曰某相。若彼解者波夜提。不解者突吉罗。解已更说波夜提突吉罗。是名为作。犯者。若比丘往语余比丘言。彼说汝犯罪人。用出家受戒为。汝犯僧伽婆尸沙。汝犯波夜提。汝犯波罗提提舍尼。汝犯突吉罗。彼是谁耶。答曰名某。某名是谁。答曰某姓。某姓是谁。答曰某种。某种是谁。答曰某作。某作是谁。答曰某相。若彼解者波夜提。不解者突吉罗。解已更说波夜提突吉罗。是名为犯。病者。若比丘往语余比丘言。彼说。汝恶病人。用出家受戒为。汝癞病痈病干病痟病鬼病。彼是谁耶。答曰名某。某名是谁。答曰某姓。某姓是谁。答曰某种。某种是谁。答曰某作。某作是谁。答曰某相。若彼解者波夜提。不解者突吉罗。解已更说波夜提突吉罗。是名为病。相者。若比丘往语余比丘言。彼说汝恶相人。用出家受戒为。汝卷手兀手。瘿癖左作。臂似鸟翅。彼是谁耶。答曰名某。某名是谁。答曰某姓。某姓是谁。答曰某种。某种是谁。答曰某作。某作是谁。答曰某相。若彼解者波夜提。不解者突吉罗。解已更说波夜提突吉罗。是名为相。烦恼者。若比丘往语余比丘言。彼说汝重烦恼人。用出家受戒为。汝多欲多嗔多痴喜忧恼。彼是谁耶。答曰名某。某名是谁。答曰某姓。某姓是谁。答曰某种。某种是谁。答曰某作。某作是谁。答曰某相。若彼解者波夜提。不解者突吉罗。解已更说波夜提突吉罗。是名为烦恼。骂者。若比丘往语余比丘言。彼说汝喜骂人。用出家受戒为。汝以二种骂骂他。白衣骂出家骂。彼是谁耶。答曰名某。某名是谁。答曰某姓。某姓是谁。答曰某种。某种是谁。答曰某作。某作是谁。答曰某相。若彼解者波夜提。不解者突吉罗。解已更说波夜提突吉罗。是名为骂。若比丘以是八种。语余比丘。别离心故。波夜提突吉罗。异是八种。若以余事。别离比丘者。突吉罗。除比丘。若以八种别离余人者。突吉罗(三事竟)

佛在王舍城。尔时六群比丘。喜斗诤相言相骂。是六群比丘。共余比丘斗诤相言相骂。僧如法断诤竟。六群比丘知如法断已。还更发起作是言。诸长老。是事非作恶作。应更作非断恶断。更断非停恶停。更停非灭。恶灭更灭。是中有未破比丘便破。已破者不可和合。未诤者便诤。已诤者不可灭。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘呵责六群比丘言。云何名比丘。僧如法断诤竟。还更发起。作是言。诸长老。是事非作恶作。更作非断恶断。更断非停恶停。更停非灭。恶灭更灭。是中有未破比丘便破。已破者不可和合。未诤者便诤。已诤者不可灭。种种呵已向佛广说。佛以是事集比丘僧。知而故问六群比丘。汝实作是事不。答言。实作世尊。佛以种种因缘呵责六群比丘。云何名比丘。僧如法断诤竟。还更发起。作是言诸长老。是事非作恶作。更作非断恶断。更断非停恶停。更停非灭。恶灭更灭。中有未破比丘便破。已破者不可和合。未诤者便诤。已诤者不可灭。佛种种呵已语诸比丘。以十利故。与诸比丘结戒。从今是戒应如是说。若比丘僧如法断诤竟。还更发起者。波夜提。如法断者。如法如律如比尼如佛教说。诤者有四种。相言诤无事诤犯罪诤常所行诤。还更发起者。作如是言。诸长老。是事非作恶作。应更作非断恶断。更断非停恶停。更停非灭。恶灭更灭。是人有五种。一者旧人。二者客人。三者受欲人。四者说羯磨人。五者见羯磨人。波夜提者。名煮烧覆障。若不悔过。能障阂道。是中犯者。若旧比丘。于相言诤中。相言诤想。如法灭已。如法灭想。还更发起。作如是言。诸长老。是事非作恶作。更作非断恶断。更断非停恶停。更停非灭。恶灭更灭。波夜提。相言诤中。无根诤想。犯罪诤想。常所行诤想。如法灭已。如法灭想。还更发起言。诸长老。是事非作恶作。更作非断恶断。更断非停恶停。更停非灭。恶灭更灭。波夜提。若旧比丘无事诤中。无事诤想。如法灭已。如法灭想。还更发起言。诸长老。是事非作恶作。应更作非断恶断。更断非停恶停。更停非灭。恶灭更灭。波夜提。无事诤中。犯罪诤想。常所行诤想。相言诤想。如法灭已。如法灭想。还更发起言。诸长老。是事非作恶作。更作非断恶断。更断非停恶停。更停非灭。恶灭更灭。波夜提。旧比丘犯罪诤中。犯罪诤想。如法灭已。如法灭想。还更发起言。诸长老。是事非作恶作。更作非断恶断。更断非停恶停。更停非灭。恶灭更灭。波夜提。犯罪诤中。常所行诤想。相言诤想。无事诤想。如法灭已。如法灭想。还更发起言。诸长老。是事非作恶作。更作非断恶断。更断非停恶停。更停非灭。恶灭更灭。波夜提。旧比丘常所行诤中。常所行诤想。如法灭已。如法灭想。还更发起言。诸长老。是事非作恶作。更作非断恶断。更断非停恶停。更停非灭。恶灭更灭。波夜提。常所行诤中。相言诤想。无事诤想。犯罪诤想。如法灭已。如法灭想。还更发起言。诸长老。是事非作恶作。更作非断恶断。更断非停恶停。更停非灭。恶灭更灭。波夜提。客比丘。受欲比丘。作羯磨比丘。见羯磨比丘亦如是。若比丘如法灭诤中。如法灭想。还更发起。波夜提。如法灭诤中。不如法灭想。还更发起。波夜提。如法灭诤中。生疑还更发起。波夜提。不如法灭诤中。如法灭想。还更发起。突吉罗。不如法灭诤中。生疑还更发起。突吉罗。不如法灭诤中。不如法灭想。还更发起不犯(四事竟)

佛在舍卫国。尔时迦留陀夷。中前着衣持钵入舍卫城乞食。食已还至自房。收衣钵持户钩在门间立。作是念。若有女人来此看者。我当示诸房舍。尔时多有女人来入寺看。迦留陀夷遥见女人来。作是言。诸姊妹来。我当示诸房舍处。以是因缘故。诸女人集。说两可羞事。以他母事向女说言。汝母隐处有如是如是相。尔时女作是念。如是比丘所说。必当与我母通。又以女事向母说。汝女隐处有如是如是相。母作是念。如是比丘所说。必当与我女通。又以子妇事向姑说。汝子妇隐处有如是如是相。姑作是念。如是比丘所说。必当与我子妇通。又以姑事向子妇说。汝姑隐处有如是如是相。子妇作是念。如是比丘所说。必当与我姑通。迦留陀夷作是语时。为他身自身作疑。是诸妇女展转相疑。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘呵责。云何名比丘。女人前说两可羞事。种种因缘呵已。向佛广说。佛以是事集比丘僧。知而故问迦留陀夷。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘。女人前说两可羞事。佛种种因缘呵已。语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘与女人说法过五六语波夜提。除有知男子。女人者。女人能受淫欲。过五六语者。五语。名色阴无常受想行识阴无常。六语。名眼无常耳鼻舌身意无常。法者。名佛所说。弟子所说。天所说。仙人所说。化人所说。显示布施持戒生天涅槃。有智男子者。知名能分别言语好丑。波夜提者。烧煮覆障。若不悔过。能障碍道。是中犯者。若比丘无解语男子。为女人说法过五六语。若偈说。偈偈波夜提。若轻说。事事波夜提。若别句说。句句波夜提。若比丘即先坐处坐。无解语男子。更有异女人来。复为说法过五六语。先女人亦在中坐。二俱闻法。若偈说。偈偈波夜提。若经说。事事波夜提。若别句说。句句波夜提。若比丘为女人说法。无解语男子。过五六语。已从坐起去。更有女人道中逆来。复为说法。无有解语男子。过五六语。先女人复从后来。二俱闻法。若偈说。偈偈波夜提。若经说。事事波夜提。若别句说。句句波夜提。若比丘无解语男子。为女人说法过五六语已。次入余家。更为余女人说法过五六语。无解语男子。先女人亦来在壁边立。若在障边。若在篱边。若在堑边。亦复闻法。若偈说。偈偈波夜提。若经说。事事波夜提。若别句说。句句波夜提。不犯者。若比丘呗。若达嚫若说。所施功德。若与受戒。若女人问而答不犯(五事竟)

佛在阿罗毗国。尔时阿罗毗国比丘。于寺内以句法教未受具戒人。或足句不足句。足味不足味。足字不足字。以是因缘故。寺内出大音声高声。多人众声。似学算人声。似婆罗门读围陀经时。如捕鱼师失鱼时声。是寺内以句法教未受具戒人者声亦如是。佛闻是大高音声。知而故问阿难。是寺内何以故。有是多人众声。阿难答言。世尊。是阿罗毗国比丘。于寺内以句法教未受具戒人。或足句不足句。足味不足味。足字不足字。以是因缘故。有大高声多人众声。佛以是事集比丘僧。知而故问阿难毗比丘。汝实作是事不。答言。实作世尊。佛以是种种因缘呵责阿罗毗比丘。云何名比丘。以句法教未受具戒人。种种因缘呵已。语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘以句法。教未受具戒人者。波夜提。未受具戒人者。除比丘比丘尼。余一切人是。句法者。足句不足句足字不足字足味不足味。足句者。具足说句。不足句者。不具足说句。足味者。具足说味。不足味者。不具足说味。足字者。具足说字。不足字者。不具足说字。若足句。即是足味足字。非不足句不足味不足字。若不足句。即是不足味不足字。非足句足味足字。法者。佛所说。弟子所说。天所说。仙人所说。化人所说。显示布施持戒生天泥洹。波夜提者。名煮烧覆障。若不悔过。能障阂道。是中犯者。若比丘以足句法。教未受具戒人。若偈说。偈偈波夜提。若经说。事事波夜提。若别句说。句句波夜提。足味足字亦如是。若比丘以不足句法。教未受具戒人。若偈说。偈偈波夜提。若别句说。句句波夜提。若经说。事事波夜提。不足味不足字亦如是。不犯者。说竟说。不犯者。郁提舍事问答并诵。彼中自已郁提舍者。授经余诵者诵竟(六事竟)

十诵律卷第九十诵律卷第十(二诵之四)

        后秦北印度三藏弗若多罗译

    明九十波逸提法之二

佛在维耶离国。夏安居时。与大比丘僧俱。时世饥俭乞食难得。诸人妻子自乏饮食。况与乞人。佛以是因缘故集比丘僧。语诸比丘。汝等知不。此间饥俭乞食难得。诸人妻子自乏饮食。况与乞人。汝等比丘随所知识。随诸亲里。随所信人。往彼安居。莫以饮食因缘故受诸苦恼。诸比丘受教已。头面礼足随知识去。有往憍萨罗国安居。有比丘往婆求摩河边。依止一聚落安居。是聚落中有富贵家。多饶财宝谷米丰盈。多诸产业田地人民奴婢作使。种种成就。尔时婆求摩比丘作是念。今世饥俭乞食难得。诸人妻子自乏饮食。况与乞人。是聚落中有富贵家。多饶财宝谷米丰盈。多诸产业田地人民奴婢作使种种成就。我等何不往到其舍共相叹言。聚落主知不。汝等得大善利。有大福田。众僧依汝聚落安居。此众中某是阿罗汉。某向阿罗汉。某阿那含。某向阿那含。某斯陀含。某向斯陀含。某须陀洹。某向须陀洹。某得初禅二禅三禅四禅。某得无量慈悲喜舍。某得空处识处无所有处非有想非无想处。某得不净观。某得阿那般那念。诸比丘作是念已。即入聚落至富贵舍。共相叹言。居士知不。汝等得大善利。有大福田。众僧依汝聚落安居。某是阿罗汉。某向阿罗汉。某阿那含。某向阿那含。某斯陀含。某向斯陀含。某须陀洹。某向须陀洹。某得初禅二禅三禅四禅。某得无量慈悲喜舍。某得空处识处无所有处非想非非想处。某得不净观。某得阿那般那念。诸居士闻已得信心忍。作是念。我等实得善利。有大福田众僧。依我聚落安居。某是阿罗汉。某向阿罗汉。乃至某阿那般那念。乃至如丰乐时。与僧小食中食怛钵那于饥俭时亦如是作。诸婆求摩河安居比丘。啖是饮食大得色力。肥盛润泽。佛在世时法。岁二时大会。春末月夏末月。春末月者。诸方国土处处诸比丘。作是念。佛所说法。我等夏安居时。修习得安乐住。是初大会。夏末月者。诸比丘夏三月安居竟作衣毕。持衣钵诣佛所。作是念我等久不见佛。久不见世尊。是第二大会。尔时憍萨罗国安居比丘。过夏三月作衣毕。持衣钵游行到维耶离。诸佛常法。有共佛安居比丘。有客比丘来。当共往迎一心问讯开房舍示卧具处。作如是言。此是汝等房舍。床榻踞床独坐床被褥枕席。随次第住。尔时维耶离比丘。遥见憍萨罗比丘来。便共出迎一心问讯。与担衣钵开房舍示卧具处。作如是言。此是汝等房舍。卧具床榻随次第住问讯言。汝等道路不疲。气力轻健。乞食不难耶。答言。我等道路不疲。气力轻健。但乞食难得。维耶离比丘言。汝等实道路不疲。气力轻健。乞食难得。汝等羸瘦颜色憔悴。尔时婆求摩河边安居比丘。三月竟作衣毕。持衣钵游行到维耶离。共佛安居比丘。遥见婆求摩河比丘来。皆共出迎一心问讯。与担衣钵开房舍示卧具处。作如是言。此是汝等房舍。床榻卧具随次第住。问讯言。汝等道路不疲。气力轻健乞食不难耶。答言。我等气力轻健乞食不难。但道路疲极。住维耶离比丘言。汝等实道路疲极。乞食不难。何以故。汝等肥盛颜色和悦。时维耶离比丘渐渐急问。诸长老。今世饥俭乞食难得。诸人妻子自乏饮食。况与乞人。汝等何因缘故。安居时气力肥盛颜色和悦乞食不难。时婆求摩河比丘。即向广说如上因缘。诸比丘问曰。汝等所可赞叹。实有是功德不。答言实有。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘呵责。云何名比丘但为饮食故。实有过人法。向未受具戒人说。种种因缘呵责已。向佛广说。佛以是事集比丘僧。知而故问婆求摩河比丘。汝等实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘。以饮食故。实有过人法。向未受大戒人说。佛种种因缘呵已。语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘实有过人法。向未受大戒人说者。波夜提。未受大戒人者。除比丘比丘尼。余一切人是。实有者。得是圣法故。波夜提者。煮烧覆障。若不悔过。能障阂道。是中犯者。若比丘实是阿罗汉。向他人说。波夜提。实向阿罗汉。向他人说。波夜提。实阿那含向阿那含。实斯陀含向斯陀含。实须陀洹向须陀洹。向他人说。皆波夜提。若比丘实得初禅。向人说者波夜提。实得二禅三禅四禅慈悲喜舍空处识处无所有处非有想非无想处不净观阿那般那念。向他人说。波夜提。乃至我好持戒。向他人说。突吉罗。若比丘实见诸天来至我所。龙夜叉浮荼鬼毗舍遮鬼罗刹鬼来至我所。向他人说。波夜提。乃至实见土鬼来至我所。向他人说。突吉罗(七事竟)

佛在王舍城。尔时六群比丘。喜斗诤相言相骂。时六群比丘。共余比丘斗诤相言相骂已。向未受大戒人说其恶罪。某比丘犯波罗夷僧伽婆尸沙波夜提波罗提提舍尼突吉罗。是中比丘。未破者便破。已破者不和合。未出事便出。已出事不可灭。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘呵责六群比丘言。云何名比丘。喜斗诤相言相骂共他斗已。向未受大戒人说出其恶罪。某比丘犯波罗夷僧伽婆尸沙波夜提波罗提提舍尼突吉罗。种种因缘呵已。向佛广说。佛以是事集比丘僧。知而故问六群比丘。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘。喜斗诤相言相骂。共他诤已。向未受大戒人出其恶罪。某比丘犯波罗夷僧伽婆尸沙波夜提波罗提提舍尼。突吉罗。种种因缘呵已。语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘知他有恶罪。向未受大戒人说。除僧羯磨。波夜提。知者。若自知若从他闻若彼自说。恶罪者。若波罗夷僧伽婆尸沙一切犯罪。皆名为恶。未受大戒人者。除比丘比丘尼。余一切人是。除僧羯磨者。僧羯磨名。若比丘于白衣舍作恶若令他作是人现前僧。应与作说罪羯磨。说罪羯磨法者。先应求能说罪人。如是应作。一心和合僧中一人唱言。谁能说某比丘罪。谁能某居士前说某比丘罪。是中若有比丘言能。是比丘僧应筹量。若有五法。僧不应令作说罪人。何等五法。随爱说随嗔说随怖说随痴说不知说不说。若比丘成就五法。僧应令作说罪人。何等五。不随爱说不随嗔说不随怖说不随痴说知说不说。是中一比丘。僧中唱。大德僧听。某比丘能作说罪人。能某居士前说某比丘罪。若僧时到僧忍听。某比丘能作说罪人。能某居士前说某比丘罪。如是白。白二羯磨僧。作说罪羯磨竟。僧忍默然故。是事如是持。若比丘作说罪者。应说彼比丘罪。余比丘不应说。若余比丘说得突吉罗。若比丘作说罪人。应向是居士说。不应向余人说。若向余人说者突吉罗。随家说。若一家若多家。随行处说。若一行处若多行处。随聚落说。若一聚落若多聚落。随里巷市肆说。若一若多。是中应如是处说。若余处说突吉罗。若是罪比丘。僧作说罪羯磨已。若更勤恼僧。是时一切僧。应说是人罪。如是应作一心和合僧中。一比丘唱言。大德僧听。是某比丘。僧作说罪羯磨已。更勤恼僧。若僧时到僧忍听。一切僧随意。随时随处说某比丘罪。如是白白四羯磨僧作随意说罪羯磨竟。僧忍默然故。是事如是持。是名除僧羯磨。波夜提者。煮烧覆障。若不悔过。能障阂道。是中犯者。若比丘见余比丘犯波罗夷。生波罗夷想。见中见想。见中不见想。见中疑闻中闻想。闻中不闻想。闻中疑。若说名波夜提。若说事突吉罗。随说名说事。一一语波夜提突吉罗。又比丘见余比丘犯僧伽婆尸沙。生僧伽婆尸沙想。见中见想。见中不见想。见中疑想。闻中闻想。闻中不闻想。闻中疑。若说名波夜提。若说事突吉罗。随说名说事。一一语波夜提突吉罗。又比丘见余比丘犯波夜提波罗提提舍尼突吉罗。于突吉罗中。生突吉罗想。见中见想。见中不见想。见中疑。闻中闻想。闻中不闻想。闻中疑。若说名突吉罗。若说事亦突吉罗。随说名说事。一一语突吉罗。又比丘见余比丘犯波罗夷谓为波罗夷。谓僧伽婆尸沙。谓波夜提。谓波罗提提舍尼。谓突吉罗。是比丘于波罗夷中。生突吉罗想。见中见想。见中不见想。见中疑。闻中闻想。闻中不闻想。闻中疑。若说名波夜提。若说事突吉罗。随说名说事。一一语波夜提突吉罗。又比丘见余比丘犯僧伽婆尸沙。谓僧伽婆尸沙。谓波夜提。谓波罗提提舍尼。谓突吉罗。谓波罗夷。是比丘于僧伽婆尸沙中。生波罗夷想。见中见想。见中不见想。见中疑。闻中闻想。闻中不闻想。闻中疑。若说名波夜提。若说事突吉罗。随说名说事。一一语波夜提突吉罗。又比丘见余比丘犯波夜提波罗提提舍尼突吉罗。于突吉罗中。谓突吉罗。谓波罗夷。谓僧伽婆尸沙。谓波夜提。谓波罗提提舍尼。是比丘于突吉罗中。生波罗提提舍尼想。见中见想。见中不见想。见中疑。闻中闻想。闻中不闻想。闻中疑。若说名突吉罗。若说事突吉罗。随说名说事。一一语突吉罗。若比丘见余比丘犯波罗夷生疑。为波罗夷非波罗夷。是比丘后便断疑。于波罗夷中生波罗夷想。见中见想。见中不见想。见中疑。闻中闻想。闻中不闻想。闻中疑。若说名波夜提。若说事突吉罗。随说名说事。一一语波夜提突吉罗。又比丘见余比丘犯僧伽婆尸沙生疑。为僧伽婆尸沙非僧伽婆尸沙。是比丘后便断疑于僧伽婆尸沙中生僧伽婆尸沙想。见中见想。见中不见想。见中疑。闻中闻想。闻中不闻想。闻中疑。若说名波夜提。若说事突吉罗。随说名说事。一一语波夜提突吉罗。又比丘见余比丘犯波夜提波罗提提舍尼突吉罗。是比丘突吉罗中生疑。为突吉罗非突吉罗。是比丘后便断疑于突吉罗中生突吉罗想。见中见想。见中不见想。见中疑。闻中闻想。闻中不闻想。闻中疑。若说名突吉罗。若说事亦突吉罗。随说名说事。一一语突吉罗。若比丘见余比丘犯波罗夷。于波罗夷中生疑。为波罗夷为僧伽婆尸沙。为波罗夷为波夜提。为波罗夷为波罗提提舍尼为波罗夷为突吉罗。是人断疑。于波罗夷中生波罗夷想。见中见想。见中不见想。见中疑。闻中闻想。闻中不闻想。闻中疑。若说名波夜提。若说事突吉罗。随说名说事一一语波夜提。突吉罗。又比丘见余比丘犯僧伽婆尸沙生疑。是罪为僧伽婆尸沙为波夜提。为僧伽婆尸沙为波罗提提舍尼。为僧伽婆尸沙为突吉罗。为僧伽婆尸沙为波罗夷。是人断疑。于僧伽婆尸沙中生僧伽婆尸沙想。见中见想。见中不见想。见中疑。闻中闻想。闻中不闻想。闻中疑。若说名波夜提。若说事突吉罗。随说名说事。一一语波夜提突吉罗。又比丘见余比丘犯波夜提。波罗提提舍尼突吉罗。于突吉罗中生疑。为突吉罗为波罗夷。为突吉罗为僧伽婆尸沙。为突吉罗为波夜提。为突吉罗为波罗提提舍尼。是人断疑。于突吉罗中生突吉罗想。见中见想。见中不见想。见中疑。闻中闻想。闻中不闻想。闻中疑。若说名突吉罗。若说事突吉罗。随说名说事。一一语突吉罗。若比丘见余比丘犯波罗夷生疑。是罪为波罗夷。为僧伽婆尸沙。为波夜提为波罗提提舍尼。为突吉罗。是人于波罗夷中。定生突吉罗想。见中见想。见中不见想。见中疑。闻中闻想。闻中不闻想。闻中疑。若说名波夜提。若说事突吉罗。随说名说事。一一语波夜提突吉罗。又比丘见余比丘犯僧伽婆尸沙生疑。是罪为僧伽婆尸沙。为波夜提。为波罗提提舍尼。为突吉罗。为波罗夷。是人于僧伽婆尸沙中。定生波罗夷想。见中见想。见中不见想。见中疑。闻中闻想。闻中不闻想。闻中疑。若说名波夜提。若说事突吉罗。随说名说事。一一语波夜提突吉罗。又比丘见余比丘犯波夜提波罗提提舍尼突吉罗。是人于突吉罗中生疑。为突吉罗。为波罗夷。为僧伽婆尸沙。为波夜提。为波罗提提舍尼。是人突吉罗中。定生波罗提提舍尼想。见中见想。见中不见想。见中疑。闻中闻想。闻中不闻想。闻中疑。若说名突吉罗。若说事突吉罗。随说名说事。一一语突吉罗(八事竟)

佛在王舍城。尔时长老陀骠力士子。多知多识。能致供养饮食衣服卧具医药资生之具。时陀骠比丘衣服故坏。诸居士因陀骠比丘故。多与众僧饮食衣服。现前僧应分物。时弥多罗浮摩比丘。作是念。因是陀骠比丘故。众僧多得供养饮食衣服卧具汤药。是陀骠比丘衣服故坏。今众僧得现前僧应分物。当于众前作羯磨与陀骠比丘。作是念已。即众僧中作羯磨与陀骠比丘。是弥多罗浮摩比丘先自劝与已。后作是言。诸比丘随所亲厚。回僧物与。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘呵责。云何名比丘。先自劝与。后作是言。诸比丘随所亲厚。回僧物与。种种因缘呵已。向佛广说。佛以是事集比丘僧。知而故问弥多罗浮摩比丘。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘。先自劝与。后作是言。诸比丘随所亲厚。回僧物与。佛种种因缘呵已。语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘先自劝与。后作是言。诸比丘随所亲厚。回僧物与。波夜提。先劝与者。先与僧欲。后作是言。随亲厚者。随和上阿阇梨。随同和上同阿阇梨。随善知识。随所爱念。随同事。随国土。随聚落。随家随伴。僧物者。若得布施物衣钵户钩时药夜分药七日药终身药。波夜提者。煮烧覆障。若不悔过。能障阂道。是中犯者。若比丘先劝与欲竟。后作是言。诸比丘随所亲厚。回僧物与。得波夜提。若作是言。随和上随阿阇梨。随同和上同阿阇梨。随善知识。随所爱念。随所同事。随国土随聚落。随家随伴。皆波夜提(九事竟)

佛在拘睒弥国。尔时长老阐那犯可悔过罪。时诸比丘慈心怜愍欲利益故。教令悔过言。阐那。汝犯某可悔过罪。汝应发露莫覆藏。阐那言。用是杂碎戒为。半月说戒时。令诸比丘疑悔恼热。忧愁不乐生舍戒心。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘呵责。云何名比丘。作是言。用是杂碎戒为。半月说时。令诸比丘疑悔恼热。忧愁不乐生舍戒心。种种因缘呵已。向佛广说。佛以是事集比丘僧。知而故问阐那。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘。毁呰已所学。以种种因缘呵已。语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘。说戒时。作是言。何用是杂碎戒为。半月说时。令诸比丘疑悔恼热。忧愁不乐生舍戒心。作是轻呵戒者。波夜提。波夜提者。煮烧覆障。若不悔过。能障阂道。是中犯者。若比丘说四波罗夷时。作是言。用是四波罗夷为。半月说时。令诸比丘疑悔恼热。忧愁不乐生舍戒心。波夜提。若比丘说十三僧伽婆尸沙时。二不定法时。三十尼萨耆波夜提法时。九十波夜提时。四波罗提提舍尼时。众多学法时。七止诤法时。及说随律经时。若作是言。用是随律经为。半月说时。令诸比丘疑悔恼热忧愁不乐生舍戒心。作是语者。皆波夜提。除随律经。说余经时。用说是经为。令诸比丘疑悔恼热。忧愁不乐生舍戒心。作是语者。突吉罗。随所说处。一一语得波夜提突吉罗(十事竟)

佛在阿罗毗国。尔时阿罗毗诸比丘。自手拔寺中草经行处草经行两头处草。自手采花。是时有居士。于草木中生有命想见以妒嫉心言。沙门释子是夺命人。杀一切众生。是中有比丘。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集比丘僧。知而故问阿罗毗比丘。汝等实作是事不。答言。实作世尊。佛以种种因缘呵责阿罗毗比丘。云何名比丘。自手拔寺内草经行处草经行两头处草。自手采花。佛但呵责而未结戒。佛在舍卫国。尔时有一摩诃卢比丘。是木师种。斫大毕拨树起大房舍。是树神后夜时。担负小儿。手复牵抱男女。围绕往诣佛所。头面礼足一面立已。白佛言。世尊。云何有是法。我所住所止所依所归所趣房舍。有一摩诃卢比丘。斫我树取作大房舍。我儿子幼小众多。冬八夜时。寒风破竹冰冻寒甚。我当于何安隐儿子。佛尔时敕余鬼言。汝当安止与是住处。诸鬼以佛语故。即与住处。是夜过已。佛以是事集比丘僧。语诸比丘。昨夜有一鬼。担负小儿。手复牵抱男女。围绕来至我所。头面作礼一面立言。云何有是法。我所住所止所依所归所趣房舍。有一摩诃卢比丘。斫我树取作大房舍。我儿子幼小众多。冬八夜时。寒风破竹冰冻寒甚。我当于何安隐儿子。佛语诸比丘。是事非法不是不应尔。居士天神皆嫌呵责。云何名比丘。自手拔寺内草经行处草经行处两头草。自手采花。种种因缘呵已。语诸比丘。以十利故。与诸比丘结戒。从今是戒应如是说。若比丘斫拔鬼村种子。波夜提。鬼村者。谓生草木众生依住。众生者。谓树神泉神河神舍神交道神市神都道神蚊虻蛣蜣蛱蝶啖麻虫蝎虫蚁子。是众生以草木为舍。亦以为村聚落城邑。生者。谓根含润泽。若自断若教人断。自破教破。自烧教烧。是名为斫。草木有五种子。根种子茎种子节种子自落种子实种子。根种子者。谓藕罗卜芜菁舍楼楼偷楼楼。如是比种根生物。茎种子者。谓石榴葡萄杨柳沙勒。如是比种茎生物。节种子者。谓甘蔗粗竹细竹。如是比种节生物。自落种子者。谓蓼阿修卢波修卢修伽罗菩提那。如是比自零落生物。实种子者。谓稻麻麦大豆小豆褊豆。如是比种子生物。波夜提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘根种子中。根种子想。生中生想。若自断教断。自破教破。自烧教烧。波夜提。又比丘根种子中。茎种子想。枝种子想。自落种子想。实种子想。生中生想。若自断教断。自破教破。自烧教烧。波夜提。若比丘茎种子中。茎种子想。生中生想。自断教断。自破教破。自烧教烧。波夜提。又比丘茎种子中。枝种子想。自落种子想。实种子想。根种子想。生中生想。自断教断。自破教破。自烧教烧。波夜提。若比丘枝种子中。枝种子想。生中生想。自断教断。自破教破。自烧教烧。波夜提。又比丘枝种子中。自落种子想。实种子想。根种子想。茎种子想。生中生想。自断教断。自破教破。自烧教烧。波夜提。若比丘自落种子中。自落种子想。生中生想。自断教断。自破教破。自烧教烧。波夜提。又比丘自落种子中。实种子想。根种子想。茎种子想。枝种子想。生中生想。自断教断。自破教破。自烧教烧。波夜提。若比丘实种子中。实种子想。生中生想。自断教断。自破教破。自烧教烧。波夜提。又比丘实种子中。根种子想。茎种子想。枝种子想。自落种子想。生中生想。自断教断。自破教破。自烧教烧。波夜提。若比丘一时烧五种子。一时犯五波夜提。一一烧一一波夜提。随所烧得尔所波夜提。若比丘自断树若教断。波夜提。随所断树。得尔所波夜提。若比丘自断草教断。波夜提。随所断草。得尔所波夜提。生中生想。自断教断。波夜提。生中干想。自断教断波夜提。生中疑为干为生。自断教断波夜提。若干中生想。自断教断突吉罗。干中疑为干为生。自断教断突吉罗。干中干想。自断教断不犯(十一事竟)

佛在王舍城。尔时陀骠比丘力士子。成就五法。僧羯磨作差会人。差诸比丘会时。不随欲不随嗔不随怖不随痴知次第。随上下坐不越次。尔时弥多罗浮摩比丘。得粗恶不美饮食处。啖不美食时。作是念言。是陀骠比丘。随欲差会。随嗔怖痴不知次第。越次不随上下坐。我等当共灭摈是人。更立差会人。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘呵责。云何名比丘。僧如法羯磨差会人。便嗔讥言。是随欲嗔怖痴不知次第。越次不随上下坐。种种因缘呵已。向佛广说。佛以是事集比丘僧。知而故问弥多罗浮摩比丘。汝实作是事不。答言。实作世尊。佛以是事种种因缘呵责。云何名比丘。僧如法羯磨差会人。便讥嗔。佛以种种因缘呵已。语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘嗔讥差会人者。波夜提。波夜提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘僧如法羯磨差会人。嗔讥是人者。波夜提。若僧如法羯磨差十四人。嗔讥是人者。波夜提。若十二人未舍羯磨。嗔讥是人者。波夜提。若舍羯磨已。嗔讥是人者。突吉罗。于十四人中二人。若舍羯磨未舍羯磨。嗔讥是二人者。波夜提突吉罗。乃至别房及同事差会。嗔讥是人者。突吉罗。佛结戒已。诸比丘不复面前嗔讥。便遥嗔讥陀骠比丘。随欲差会。随嗔怖痴不知次第。越次不随上下坐。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘呵责。云何名比丘。佛结戒故。不面前嗔讥。便遥嗔讥。种种因缘呵已。向佛广说。佛以是事集比丘僧。知而故问弥多罗浮摩比丘。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘。僧如法作差会人。便遥嗔讥。种种因缘呵已。语诸比丘。从今是戒应如是说。若比丘面前嗔讥僧所差人。若遥讥者。波夜提。是中犯者。若比丘僧如法羯磨差会人。若嗔讥是人闻者。波夜提。不闻者突吉罗。若僧如法羯磨作十四人。若遥嗔讥。是人闻者波夜提。不闻者突吉罗。若比丘十二人未舍羯磨。若遥嗔讥。是人闻者波夜提。若不闻者突吉罗。若舍羯磨已。遥嗔讥。闻者突吉罗。不闻者亦突吉罗。十四人中二人。若舍羯磨不舍羯磨。若遥嗔讥。是人闻者波夜提。不闻者突吉罗。乃至别房及同事差会。若遥嗔讥。是人闻者突吉罗。不闻者亦突吉罗。二人者。教诫尼人及四悔中第四差羯磨使迎食人(十二事竟)

佛在拘睒弥。尔时阐那比丘犯可悔过罪。诸比丘慈心怜愍欲利益故。语阐那言。汝犯可悔过罪。当发露莫覆藏。阐那语诸比丘言。汝等能谓我作是事耶。我不谓汝等能说我犯是事。诸比丘言阐那。汝若有罪便言有。无便言无。何以用异事。依止异事。阐那言。我何豫汝等事。我畏汝等耶。更用异事依止异事。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘呵责。云何名比丘。犯罪已用异事依止异事。种种因缘呵已。向佛广说。佛以是事集比丘僧。知而故问阐那。汝实作是事不。答言。实作世尊。佛以种种因缘呵责阐那。云何名比丘。犯罪已用异事依止异事。种种因缘呵已。语诸比丘。汝等当忆识阐那比丘用异事。若更有如阐那比丘者。亦应当忆识彼用异事。忆识法者。一心和合僧。一比丘僧中唱言。大德僧听。是阐那比丘犯罪用异事。若僧时到僧忍听。忆识阐那比丘用异事。汝阐那。随所用异事众僧随忆识。如是白如是白二羯磨僧忆识竟。僧忍默然故是事如是持。佛语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘用异事恼他。波夜提。波夜提者。煮烧覆障。若不悔过。能障阂道。是中犯者。若比丘僧未忆识用异事依止异事。尔时用异事。突吉罗。若僧忆识已尔时用异事依止异事。波夜提。佛在拘睒弥。即阐那比丘作可悔过罪。诸比丘慈心怜愍欲利益故。语阐那言。汝犯可悔过罪。当发露莫覆藏。阐那作是念。若我用异事者。众僧当作忆识羯磨。我当默然阐那即时默然。诸比丘语阐那言。若汝有罪便言有。无便言无。何故默然恼我等。阐那言。我是汝等何物。我不畏汝等。作是语已还复默然。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘呵责。云何名比丘。犯罪已默然恼他。种种因缘呵已。向佛广说。佛以是事集比丘僧。知而故问阐那。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘。犯罪已默然恼他。种种因缘呵已。语诸比丘。汝等当忆识阐那比丘默然恼他事。忆识法者。一心和合众僧。一比丘僧中唱言。大德僧听。是阐那比丘。犯罪默然恼他。若僧时到僧忍听。忆识阐那比丘默然恼他。汝阐那。随汝默然恼他事。众僧随忆识。如是白。白二羯磨僧忆识竟。僧忍默然故。是事如是持。从今是戒应如是说。若比丘用异事默然恼他。波夜提。是中犯者。若僧未忆识时。默然恼他突吉罗。若僧忆识已。默然恼他波夜提若比丘口病唇病齿病舌病咽病心病面气满若出血。如是不语不犯。恭敬佛故不语。恭敬和上阿阇梨。恭敬上座。尊重故不语。不犯。若不能语故不语。不犯(十三事竟)

佛在舍卫国。尔时有一居士。请佛及僧明日食。佛默然受。是居士知佛默然受已。头面礼足右绕而去。还到自舍。是夜办种种多美饮食。时诸比丘露地敷僧卧具。持衣钵在中待食时到。有比丘经行。有比丘坐。时居士早起敷坐处已。遣使白佛言。世尊。食具已办唯圣知时。即时诸比丘舍僧卧具。自持衣钵往居士舍。佛自住房迎食分。诸比丘往居士舍已。天雨湿僧卧具。诸佛常法。诸比丘往居士舍时。佛自持户钩。从房至房看诸房舍。开一房门。见僧卧具在露地雨湿烂坏。即取捩晒卷叠举着覆处。便闭房门下掸。还自房舍。独坐床上结加趺坐。尔时居士知僧坐已。自手行水。自与多美饮食自恣饱满。尔时居士知僧满足已摄钵竟。自手与水。取小床坐众僧前。欲听说法。上坐说法已从坐起去。诸比丘随次第出。还诣佛所。诸佛常法。诸比丘食后还时。以如是语劳问诸比丘。饮食多美。僧饱满不。诸比丘言。世尊。饮食多美。众僧饱满。佛言。今日汝等入居士舍已。我于后持户钩。从房至房看诸房舍。开一房门。见僧卧具露地雨湿烂坏语诸比丘。是事不是非法不应尔。一切众僧卧具。云何趣用践蹋不知护惜。诸居士血肉干竭。为福德故。布施供养。汝等应少用。守护者善。佛如是种种因缘呵已。语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘露地敷僧卧具。细绳床粗绳床褥被。若使人敷。是中坐卧。去时不自举。不教人举者。波夜提。细绳床有五种。阿珊蹄脚。簸郎劬脚。羖羊角脚尖脚曲脚。粗绳床有五种。阿珊蹄脚。簸郎劬脚。羝羊角脚。尖脚曲脚。褥被褥者。甘蔗滓贮褥。瓠茎贮褥。长瓜茎贮褥。毳贮褥。刍摩贮褥。劫贝贮褥。文阇草贮褥。麻贮褥。水衣贮褥。被者。俱执被。刍摩被。毳被。劫贝被。露地者。无土壁。无草木壁。无簟席壁。无衣幔覆障。如是比无物覆障处。自敷者。自手敷。使敷者。教他人敷。坐者坐上。卧者身着床。不举者。不自手举。不教举者。不教他举。波夜提者。煮烧覆障。若不悔过。能障阂道。是中犯者。若比丘地了时。露地敷众僧卧具已。便入室坐息。至地了竟。乃举着覆处。波夜提。地了竟时中前时日中时晡时日没时。露地敷僧卧具已。便入室坐息。至日没竟时乃举着覆处。波夜提。若比丘露地敷僧卧具已。出寺门过四十九步。波夜提。又比丘露地敷僧卧具已。出寺门过墙篱少许。至地了时。突吉罗。又比丘露地敷僧卧具已。不嘱人游行诸坊。突吉罗。有二比丘露地敷僧卧具已。俱从坐起去。后去者应举。又二比丘露地敷僧卧具已。持衣钵在中。一比丘先取衣钵去。后取衣钵去者应举。不举者犯。有一时众僧露地会食。诸比丘食竟。舍僧卧具在露地去。有恶风雨土污湿。以是事白佛。佛言。应举着覆处。佛作是语已。诸比丘食竟。有诸白衣即坐僧卧具床上。是事白佛。佛言应待。诸比丘久待热闷吐逆。佛言。若有病者应去。随见者应举。若二比丘见。一人应举大床小床。一人应举大褥小褥。若聚落边寺中持卧具至空闲处。空闲处持来至聚落边寺中。值雨不犯。若失户钩户钥无举处。若八难中一一难起。不举不犯(十四事竟)

十诵律卷第十十诵律卷第十一(第二诵之五)

        后秦北印度三藏弗若多罗译

    九十波逸提法之三

佛在舍卫国。尔时有二客比丘向暮来。次第得一房共住。一人得床一人得草敷。二人夜宿已。不举便去。时草敷中生虫。啖是草。啖床脚床梐床档床绳。啖被褥枕。啖已入壁中住。尔时有一居士。请佛及僧明日食。佛默然受。居士知佛默然受已即从座起头面礼足右绕而去。还到自舍。是夜办种种多美饮食。早起敷坐处已遣使白佛。食具已办。唯圣知时。诸比丘往居士舍。佛自住房迎食分。诸佛常法。诸比丘往居士舍。尔时佛自持户钩。从一房至一房看诸房舍。佛即持户钩从一房至一房。开一房户。见是草敷虫生啖草啖床脚床梐床档床绳被褥枕。佛见已入是舍内。徐徐举被褥枕。安徐举床。渐渐举敷草却虫已。扫洒埿涂竟。抖擞被褥枕。打床却虫还着本处。敷卧具已闭户下扂。还在房舍。独坐床上结加趺坐。是时居士见僧坐已。自手行水。自与多美饮食自恣饱满。尔时居士。知僧饱满已摄钵竟。自手与水。取小床坐众僧前欲听说法。上座说法已从座起去。诸比丘随次第出。还诣佛所。诸佛常法。诸比丘食后还时。以如是语劳问诸比丘。饮食多美。僧饱满不。佛即问诸比丘。饮食多美。僧饱满不。诸比丘言。饮食多美众僧饱满。佛语诸比丘。汝等入居士舍已。我持户钩游行诸房。开一房户。见草敷中生虫。虫啖是草。啖床脚床梐床档床绳。啖被褥枕。啖已入壁中住欲啮人。是事不是非法不应尔。云何僧卧具。取用践蹋不知护惜。诸居士血肉干竭。为福德故。布施供养。汝等应少用守护者善。佛语诸比丘。谁是中宿。诸比丘言。世尊。有二客比丘来。次第是中共住。一人得床一人得草敷。夜宿已地了便去。佛种种因缘诃责。云何名比丘。用僧卧具无所付嘱便去。种种因缘诃已。语诸比丘。以十利故。与诸比丘结戒。从今是戒应如是说。若比丘。比丘房中敷僧卧具。若自敷若使人敷。是中坐卧。去时不举不教举者。波逸提。比丘房者。或属众僧。或属一人。极小乃至容四威仪行立坐卧。自敷者自手敷。使敷者教他敷。坐者坐上。卧者身卧上。不举者不自手举。不教举者不教他举。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若客比丘。比丘房中敷僧卧具出界去。波逸提。若旧比丘。比丘房中敷僧卧具出界去。作是念。即日当还。有急因缘不得即还。出界至地了时突吉罗。佛言。从今日听付嘱僧卧具已便行。嘱者。有三种言。此是户钥。此是房舍。此是卧具。若说此是户钥此是房舍此是卧具。应付嘱谁耶。应付嘱敷卧具者。若无敷卧具者。应付嘱典房者。若无典房者。应嘱修治房舍人。若无是人。应付嘱是中旧比丘善好有功德持戒者。若无是人。是僧坊中。若有善好贤者。若守僧坊民。应付嘱。不应付嘱无惭愧破戒比丘。亦不应嘱小沙弥。若不能得好人若有衣架象牙我。应持被褥枕着上便去。若无衣架象牙我。是中有两床者。持被褥枕着一床上。以一床覆上。去壁四寸便去。不犯者。是房中留物去。乃至留盛富罗囊(十五事竟)

佛在舍卫国。尔时长老耶舍。与五百眷属俱。来向舍卫国欲安居。时诸比丘皆作安居先事。谓塞壁孔罅。塞土堕孔罅。补缺坏。解治绳床。抖擞被枕。尔时六群比丘懈惰不作。遥见他作便生是念。我等上座。须彼作竟受卧具已。当于后入随上座驱起。作是念已。诸比丘作竟受卧具已。六群比丘便随后入。诸比丘问六群比丘。汝共我等来作先事不。答言。不作。诸比丘言。汝等共我等来不作先事。我等作先事竟。我不起。六群比丘言。如佛所说。随上座次第受房。不说不作先事者不与。我是上座。云何不起。六群比丘大力剿健。不大谨慎。即强牵出。是比丘柔软乐人。头手伤坏钵破衣裂。是中有比丘。少欲知足行头陀。闻是事已心不喜。种种因缘诃责。云何名比丘。比丘房中嗔恨不喜。便强牵出。种种因缘诃已。向佛广说。佛以是事集比丘僧。知而故问六群比丘。汝等实作是事不。答言。实作世尊。佛以种种因缘诃责。云何名比丘。比丘房中嗔恨不喜。便强牵出。种种因缘诃已。语诸比丘。以十利故。与诸比丘结戒。从今是戒应如是说。若比丘。比丘房中嗔恨不喜。便自牵出若使人牵。出痴人远去不应住此。除彼因缘波逸提。比丘房者。或属僧或属一人。极小乃至容四威仪行立坐卧。嗔恨者。不随意故。不喜者。嗔不喜见故。自牵者。自手牵出。使牵者。教他牵。若从床上至地。从房内至户。从户至行来处。从高上至下处。从土埵上至地。波逸提。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘嗔恨不喜牵捉比丘。能牵者波逸提。不能牵突吉罗。若使他牵。能者波逸提。不能者突吉罗。若从坐床上。能牵者波逸提。不能者突吉罗。若从卧床上房内户外行处高上土埵上。若能牵者波逸提。不能者突吉罗。随自牵随教牵。皆波逸提突吉罗。若房舍欲破故牵出。不犯(十六竟)

佛在舍卫国。尔时长老迦留陀夷。恶眠不一心眠。鼾眠齘齿[穴/(爿*臬)]语频申。拍手动足作大音声。诸比丘闻是声。不得眠故食不消。食不消故身体患痒。恼闷吐逆不乐。诸比丘各各共相近敷卧具。作是念。莫令迦留陀夷入中卧。时迦留陀夷。强来入中敷卧具。诸比丘言。迦留陀夷。汝莫强入中卧。何以故。汝恶眠不一心眠。鼾眠齘齿[穴/(爿*臬)]语频申。拍手动足作大音声。诸比丘闻是声。不得眠故食不消。食不消故身体患痒。恼闷吐逆不乐。迦留陀夷言。我自安乐。汝不乐者便自出去。作是语已强敷卧具。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘诃责。云何名比丘。知比丘房中先敷卧具。后来强敷。种种因缘诃已。向佛广说。佛以是事集比丘僧。知而故问迦留陀夷。汝实作是事不。答言。实作世尊。佛以种种因缘诃责迦留陀夷。云何名比丘。知比丘房中先敷卧具。后来强敷。种种因缘诃已。语诸比丘。以十利故。与诸比丘结戒。从今是戒应如是说。若比丘知比丘房中先敷卧具。后来强敷。若使人敷。不乐者自当出去。除彼因缘。波逸提。知者。若自知。若从他闻。若彼人语。强敷者。不随他意自强敷故。使敷者教人敷。若敷坐床前。若敷卧床前。若敷房内。若户外行处。若高处。若土埵前敷者。波逸提。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘。知比丘在比丘房中先敷卧具竟。后来于坐床前强敷卧具。若能敷者波逸提。不能敷者突吉罗。若卧床前。若房内户外行处高处土埵前。若自敷。若使人敷。能敷者波逸提。不能者突吉罗。如是处随自敷教敷。一一波逸提突吉罗。若比丘为恼他故。闭户开户闭向开向。然火灭火然灯灭灯。若呗咒愿读经说法问难。随他所不喜乐事作。一一波逸提(十七竟)

佛在舍卫国。尔时有二客比丘向暮来。是二客比丘次得一房。一人得阁上。一人得阁下。得阁下者是坐禅人。寂静早入房中。敷床褥结加趺坐。乐默然故。在阁上者多喜调戏。经呗咒愿问难大声戏笑。作种种无益语言。然后入房。用力坐尖脚床上。以苇栈故。床脚及支陷下。伤比丘头垂死。是比丘从房出语诸比丘。汝看是比丘。不一心坐卧故。床脚陷下伤我头垂死。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘诃责。云何名比丘。不一心坐卧。用力坐故。令床脚陷下。伤比丘头垂死。种种因缘诃已。向佛广说。佛以是事集比丘僧。知而故问是比丘。汝实作是事不。答言。实作世尊。佛以种种因缘诃责。云何名比丘。不一心坐卧。令床脚陷下。伤比丘头垂死。种种因缘诃责已。语诸比丘。以十利故。与诸比丘结戒。从今是戒应如是说。若比丘。比丘房阁中。尖脚床用力坐卧。波逸提。比丘房者。或属僧。或属一人。极小乃至容四威仪行立坐卧。阁者。一重已上皆名为阁。床者卧床。卧床者五种。阿珊蹄脚。波郎劬脚。羝羊角脚。尖脚。曲脚。坐禅床亦有五种。阿珊蹄脚。波郎劬脚。羝羊角脚。尖脚。曲脚。坐者身坐上。卧者身卧上。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘卧床。一脚尖三脚阿珊蹄。若二脚尖二脚阿珊蹄。若三脚尖一脚阿珊蹄。若四脚尖。是中随用力坐卧。一一波逸提。若卧床一脚尖三脚波郎劬。若二脚尖二脚波郎劬。若三脚尖一脚波郎劬。若四脚尖。是中随用力坐卧。一一波逸提。若是卧床。一脚尖三脚羝羊角。若二脚尖二脚羝羊角。若三脚尖一脚羝羊角。若四脚尖。是中随用力坐卧。一一波逸提。若是卧床。一脚尖三脚曲。若二脚尖二脚曲。若三脚尖一脚曲。若四脚尖。是中随用力坐卧。一一波逸提。坐禅床亦如是。若以石支尖脚床。波逸提。若以甎支。若以木支。若以白镴支。若铅锡支。一一波逸提。若以材栈板栈棹子栈若厚泥。若是床脚支木朽腐。若草团支。若衣团支。若纳团支。不犯(木支朽则软不能伤人故言不犯十八竟)

佛在俱舍弥国。尔时长老阐那。用有虫水浇草和泥。诸比丘语阐那言。汝莫用有虫水浇草和泥杀诸小虫。阐那答言。我用水和泥不用虫。诸比丘言。汝知是水有虫。云何用和泥。汝于畜生中无怜愍心。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘诃责。云何名比丘。知水有虫用浇草和泥。种种因缘诃已。向佛广说。佛以是事集比丘僧。知而故问阐那。汝实作是事不。答言。实作世尊。佛以种种因缘诃责。云何名比丘。知水有虫用浇草和泥。种种因缘诃已。语诸比丘。以十利故。与诸比丘结戒。从今是戒应如是说。若比丘知水有虫。自用浇草和泥。若使人用。波逸提。知者。若自知若从他闻。虫者。若眼所见。若漉水囊所漉。浇草者自手浇。使浇者教他浇。和泥者自手和。使和者教他和。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘知水有虫用浇草。随虫死。一一波逸提。若使他浇草。随虫死。一一波逸提。若比丘知水有虫用和泥。随虫死。一一波逸提。若使他和泥。随虫死。一一波逸提。牛屎干土乃至以竹芦叶著有虫水中。随虫死。一一波逸提。若比丘有虫水中有虫想用者。波逸提。有虫水中无虫想用。波逸提。有虫水疑用。波逸提。无虫水中有虫想用。突吉罗。无虫水生疑用。突吉罗。无虫水中无虫想用不犯(十九竟)

佛在俱舍弥国。尔时长老阐那。欲起大房阁是人性懈堕。作是念。谁能日日看视。即一日掘地筑基累壁竟。安户向成第二重。安施户向泥壁涂治架椽覆讫。即日作竟即日崩倒。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘诃责。云何名比丘。起大房阁大用草木泥土。即日作成即日崩倒。种种因缘诃已。向佛广说。佛以是事集比丘僧。知而故问。阐那。汝实作是事不。答言。实作世尊。佛以种种因缘诃责阐那云何名比丘。起大房阁大用草木泥土。即日作成即日崩倒。种种因缘诃已。语诸比丘。以十利故。与诸比丘结戒。从今是戒应如是说。若比丘欲起大房。当垒壁安梁户向治地。应再三覆。过是覆者。波逸提。大房者。温室讲堂合霤堂高楼重阁狭长屋。壁者。四壁若木若土。梁者。栋所依处。户者。安扇处。向者。窗向通明处。治地者。泥地粗泥糠泥。用赤白黑垩洒。涂治彩画黑画青画白画赤画。再三覆者。应若二若三覆。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘自知覆者。应自覆一分竟。第二分应发头。第三分应约敕言。当如是覆。约敕已便去。是比丘若在中。即竟第三覆者。是舍若用草覆。随所用草。一一波逸提。若用木箦覆。随用木箦。一一箦波逸提。若以瓦覆。随所用瓦。一一波逸提。不犯者。若用板覆。若用鸟翅覆。若用优尸罗草根覆不犯(二十事竟)

佛在舍卫国。尔时佛告诸比丘。我教化四众疲极。令诸比丘当教诫比丘尼。尔时诸比丘受佛教已。次第教诫比丘尼。上座比丘次第教诫竟。次至长老般特。时阿难往语般特言。汝知不。汝明日次应教诫比丘尼。般特语阿难言。我钝根不多闻。未有所知。我夏四月乃能诵得一拘摩罗偈。智者身口意不作一切恶。常系念现前舍离于诸欲。亦不受世间无益之苦行。阿难得过是次者善。阿难再三语般特言。诸上座已教诫竟。今次到汝。般特比丘亦再三报阿难言。我钝根不多闻。未有所知。夏四月乃能诵得拘摩罗一偈。得过次者善。阿难复言。汝明日次教诫比丘尼。即受阿难语。夜过已。中前着衣持钵。入舍卫城次第乞食。食后还自房舍。空地敷坐床已入室坐禅。尔时诸比丘尼闻。今日般特比丘次教诫比丘尼。皆生轻心。是不多闻诵读经少。夏四月过诵得一拘摩罗偈。智者身口意不作一切恶。常系念现前舍离于诸欲。亦不受世间无益之苦行。我等所未闻法云何得闻。我等所未知法云何得知。所诵拘摩罗偈。我等先已诵。诸有比丘尼。先不入只陀林听法者。时皆共来。有五百比丘尼。出王园比丘尼精舍。往只桓听法。诣长老般特房前立。謦欬作声扣户言。大德般特出来长老般特。即从禅起出房。至独坐床上端身大坐。诸比丘尼头面礼竟。皆在前坐。时长老般特以柔软语言。诸姊妹。当知我钝根少所读诵。夏四月过诵得一偈。智者身口意。不作一切恶。常系念现前舍离于诸欲。亦不受世间无益之苦行。虽然我当随所知说。汝等当一心行不放逸法。何以故。乃至诸佛。皆从一心不放逸行。得阿耨多罗三藐三菩提。所有助道善法。皆以不放逸为本。作是语已。用神通力于座上没。在于东方虚空之中。现四威仪行立坐卧。入火光三昧身出光焰。青黄赤白种种色光。身下出火身上出水。身下出水身上出火。南西北方四维上下亦复如是。种种现神力已还坐本处。诸比丘尼见长老般特如是神力已。轻心灭尽。生信敬心故尊重净心。折伏憍慢。即随比丘尼所喜乐法所应解法。而为演说。众中有得须陀洹果斯陀含果阿那含果阿罗汉果。有种声闻道因缘有种辟支佛道因缘。有发阿耨多罗三藐三菩提因者。尔时众中。得如是种种大利益。是戒初因缘

佛在王舍城。尔时六群比丘。次教诫比丘尼。时置教诫事。置教诲事。置说法语。作二种恶说粗恶说。尔时有下座年少比丘尼不深乐持戒。共六群比丘调戏。轻语大笑更相字名种种不清净事。是中有上座长老比丘尼。深乐持戒在余处经行。或立住待欲闻说法。又一时摩诃波阇波提比丘尼。与大比丘尼众五百人俱。出王园精舍往诣佛所。头面礼足在一面立。五百比丘尼亦头面礼佛足在一面立。瞿昙弥比丘尼一面立已。白佛言。世尊。佛为利益故。听教诫比丘尼。我等不得是利。佛问瞿昙弥。云何我为利益故。听教诫比丘尼。不得是利。瞿昙弥比丘尼。向佛广说是事。佛言实尔。我为利益故。听教诫比丘尼。汝等实不得是利。时佛为瞿昙弥及五百比丘尼。说种种法示教利喜已默然。时瞿昙弥五百比丘尼。知佛示教利喜已。头面礼佛足右绕而去。时瞿昙弥五百比丘尼去不久。佛以是事集比丘僧。知而故问六群比丘。汝实作是事不。答言。实作世尊。佛以种种因缘诃责六群比丘。云何名比丘。僧不差便教诫比丘尼。佛种种因缘诃已。语诸比丘。以十利故。与诸比丘结戒。从今是戒应如是说。若比丘。僧不差教诫比丘尼。教诫比丘尼者。波逸提。僧不差者。僧未一心和合差令教诫。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若一比丘。僧未差教诫一比丘尼者。一波逸提。若一比丘。教诫二三四比丘尼者。四波逸提。若二比丘。教诫二比丘尼者。二波逸提。若教诫三四一比丘尼者。一波逸提。若三比丘。教诫三比丘尼者。三波逸提。若教诫四一二比丘尼者。二波逸提。若四比丘。教诫四比丘尼者。四波逸提。若教诫一二三比丘尼者。三波逸提

佛在王舍城。尔时六群比丘。知僧不差教诫比丘尼。便出界外自相差次教诫比丘尼。然后入界。诸比丘尼来时。便语诸比丘尼言。僧差我教诫比丘尼。汝来我当说教法。以是因缘集比丘尼众已。置教诫事置教诲事置说法语。作二种恶。是中有年少比丘尼不深乐持戒共六群比丘调戏。轻语大笑更相字名种种不清净事。是中有上座长老比丘尼。深乐持戒在余处经行。或立住待。是时比丘尼僧共和合相近。佛遥见比丘尼僧共和合相近。佛知故问阿难。何以故。比丘尼僧共和合相近。阿难答言。世尊。是六群比丘。知僧不羯磨令教诫比丘尼。便出界外自相羯磨教诫比丘尼。然后入界。见诸比丘尼来。便作是言。僧一心羯磨。我教诫比丘尼。汝等来我当说教法。以是因缘故集比丘尼。置教诫事置教诲事置说法语。作二种恶。是中有年少下座比丘尼不深乐持戒。共六群比丘调戏轻语更相字名。是中有上座长老比丘尼。深乐持戒在余处经行立待。世尊。以是因缘故。比丘尼僧共和合相近。佛以是因缘集比丘僧。语诸比丘。从今日比丘有五法。不应差令教诫比丘尼。何等五。一者未满二十岁未过二十岁。二者不能持戒。三者不能多闻。四者不能正语说法。五者犯十三事处处污三众。未满二十岁者。从受具戒来未满二十岁。不能持戒者。破佛所结戒。不随具戒中教。不知威仪。不知应行处不应行处。乃至破小戒无怖畏心。不能次第学持戒。不多闻者。二部具戒不合义读诵。不能正语说法者。不能善知世间正语上好言辞。犯十三事者。若十三事中。处处污式叉摩尼沙弥沙弥尼。是三众边犯罪。虽悔过亦不得教诫比丘尼。若比丘有是五法者。不得差教诫比丘尼。若比丘成就五法。应差教诫比丘尼。何等五。满二十岁若过二十岁。能持戒。能多闻。能正语说法。不犯十三事不污三众。满二十岁者。受具戒来满二十岁若过。持戒者。不犯佛所结戒。随大戒教。知威仪。知应行处不应行处乃至破小戒生大怖畏。知次第学。持戒。多闻者。二部大戒合义诵读。能正语说法者。善知世间正语上好言辞。不犯十三事者。十三事中不处处污。三众者。式叉摩尼沙弥沙弥尼。若比丘成就此五法者。僧应差教诫比丘尼。若比丘。不满二十岁。不能持戒。不能多闻。不能正语说法。犯十三事处处污三众。若僧差是人教诫比丘尼者不成差。若是人教诫比丘尼者。波逸提。若满二十岁若过不能持戒。不能多闻。不能正语说法。犯十三事污三众。若僧差是人者不成差。若差是人教诫比丘尼者。波逸提。若满二十岁若过。能持戒。不能多闻。不能正语说法。犯十三事污三众。若僧差是人者不成差。是人教诫比丘尼者。波逸提。若满二十岁若过。能持戒。能多闻。不能正语说法。犯十三事污三众。若僧差是人者不成差。是人教诫比丘尼者。波逸提。若满二十岁若过。能持戒。能多闻。能正语说法。犯十三事污三众若僧差是人者不成差。是人教诫比丘尼者。波逸提。若满二十岁若过。能持戒。能多闻。能正语说法。不犯十三事不污三众。若僧未差便教诫比丘尼者。波逸提。成就五法已差。未僧中差。便教诫者波逸提。成就五法已差。已僧中差。未语便教诫者。突吉罗。成就五法已差。已僧中差。已语。未僧中语。便教诫者突吉罗。成就五法已差。已僧中差。已语。已僧中语。不问来者言诸妹一切皆来集不。便教诫者突吉罗。成就五法已差。已僧中差。已语。已僧中语。已问诸妹一切皆来集不未说八敬法。便语后比丘者突吉罗。成就五法已差。已僧中差。已语。已僧中语。已问诸妹一切皆来集不。已说八敬法。次语后比丘者不犯(二十一竟)

佛在舍卫国。尔时佛告难陀言。汝当教诫比丘尼。当教诲比丘尼。当为比丘尼说法。何以故。若汝教诫比丘尼与我无异。即时长老难陀默然受教。佛即时告诸比丘。汝等差难陀教诫比丘尼。若更有如是比丘。亦当差令教诫比丘尼。应如是作。一心和合僧。一比丘唱言。大德僧听。是难陀比丘。僧差令教诫比丘尼。若僧时到僧忍听。僧差难陀教诫比丘尼。白如是。作白二羯磨。僧差难陀比丘教诫比丘尼竟。僧忍默然故。是事如是持。是夜过已。难陀比丘。中前着衣持钵入城乞食。食后还房。空地敷独坐床。入室坐禅。时诸比丘尼。闻难陀教诫比丘尼。先未来听法者。皆来集听。五百比丘尼俱出王园精舍。入只陀林诣难陀房前。立謦欬作声扣户言。大德难陀。为我等说法教诫来。时难陀。从禅起开户出至独坐床上端身大坐。时诸比丘尼头面礼难陀足皆在前坐。难陀即时说种种法示教利喜。示教利喜已默然。时诸比丘尼得善法味。深爱乐故不欲起去。难陀作是念。是诸比丘尼得法味故。犹欲闻法。即更为说种种法示教利喜。乃至日没。语诸比丘尼言。日没可去。诸比丘尼即起。头面礼足右绕而去。出只陀林欲入城。城门已闭。即住城下堑边宿者。或在树下或在井边。或在屏处障处宿。晨朝开门。诸比丘尼即便先入。时守门人问诸比丘尼。诸善女。今从何来。答言。我从只陀林听法。日没来还城门已闭。不及得入。问曰何处宿。各随宿处答。有城下宿者答言城下。树下宿者答言树下。井边宿者答言井边。屏障处宿者答言屏障处。守门人言。何有此法。诸沙门释子破梵行。至夜共作恶早起放来。如贼得淫女共宿早起放来门下。诸释子比丘亦如是。暮共宿已早起放来。如是一人语二人。二人语三人。如是展转恶名流布满舍卫城。是中有比丘。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集比丘僧。知而故问难陀。汝实作是事不。答言。实作世尊。佛以种种因缘诃责难陀。汝不知时不知量。乐说法乃至日没。语诸比丘。以十利故。与诸比丘结戒。从今是戒应如是说。若比丘。僧差教诫比丘尼。至日没者。波逸提。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘地了时教诫比丘尼。乃至日没竟时波逸提。若比丘。地了竟时。中前时。日中时。晡时。下晡时。日没时教诫比丘尼。至日没竟时。波逸提。若日没竟时。生日没竟想教诫。波逸提。若日没竟时。生不没竟想教诫。波逸提。若日没竟时。生疑教诫。波逸提。若日未没。生没竟想教诫。突吉罗。若日未没。生疑教诫。突吉罗。若日未没。生未没想教诫不犯(二十二竟)

佛在王舍城。尔时六群比丘。自知不复得教诫比丘尼。妒嗔作是言。诸比丘为利养故教诫比丘尼。谓衣钵户钩时药夜分药七日药终身药。以是利故。诸比丘教诫比丘尼。不为善好法。是中有比丘。少欲知足行头陀闻是事心不喜。种种因缘诃责。云何名比丘。作是言。诸比丘为财利故教诫比丘尼。种种因缘诃已。向佛广说。佛以是事集比丘僧。知而故问六群比丘。汝实作是事不。答言。实作世尊。佛以种种因缘诃责。云何名比丘。作是言。诸比丘为财利故。教诫比丘尼。种种因缘诃已。语诸比丘。以十利故。与诸比丘结戒。从今是戒应如是说。若比丘作是言。诸比丘为财利故。教诫比丘尼。波逸提。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘言。诸比丘为钵故教诫比丘尼者。波逸提若为衣户钩时药夜分药七日药终身药故。教诫比丘尼。皆波逸提。随所说随得尔所波逸提(二十三竟)

佛在王舍城。尔时六群比丘。与助提婆达多比丘尼。共期同道行调戏大笑。作粗恶语种种不净业。是中有居士逆道来者。有随后来者。见已共相谓言。汝等看是。为是妇耶。为是私通。必共作淫欲事。是中有比丘。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集比丘僧。知而故问六群比丘。汝实作是事不。答言。实作世尊。佛以种种因缘诃责。云何名比丘。与比丘尼共期同道行从一聚落至一聚落。佛种种因缘诃已。语诸比丘。以十利故。与诸比丘结戒。从今是戒应如是说。若比丘与比丘尼共期同道行。从一聚落至一聚落。波逸提。期者。若比丘作期。若比丘尼作期。道者。有二种。陆道水道。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘与比丘尼。共期陆道行。从一聚落至一聚落波逸提。若中道还突吉罗。若向空地无聚落处乃至一拘卢舍(五百弓量)波逸提。若中道还突吉罗。水道亦如是。佛在舍卫国。尔时诸比丘尼。从憍萨罗国游行向舍卫国。到险道中待多伴。时有诸比丘。亦从憍萨罗游行向舍卫国。诸比丘尼遥见诸比丘。作是念。我等共诸比丘去者。安隐得过。诸比丘来渐近。比丘尼问言。诸大德。欲何所去。诸比丘答言。向舍卫国。比丘尼言。我等当共诸大德去。诸比丘答言。佛结戒。诸比丘不得与比丘尼共期同道行。云何共去。诸比丘尼言。若然者大德前去。时诸比丘众多。安隐得过险道。贼不敢发。诸比丘尼随后缓来。贼见女人众少。寻出夺衣悉皆裸形放去。诸比丘游行。渐到舍卫国诣佛所。头面礼足一面坐。诸佛常法。有客比丘来。以如是语劳问言诸比丘。忍不足不。安乐住。不乞食易。不道路不极耶。诸比丘答言。世尊。忍足安乐住。乞食易得道路不极。即以是事向佛广说。佛以是事集比丘僧。种种因缘赞戒赞持戒。赞戒赞持戒已。语诸比丘。从今是戒应如是说。若比丘与比丘尼共期同道行。从一聚落至一聚落。除因缘。波逸提。因缘者。若是道中要须多伴。所行道有疑怖畏。是名因缘。疑者有二种。一疑失衣钵。二疑失粮食。若疑失粮食者。比丘尼饮食。比丘应取持去。若疑失衣钵。者比丘尼衣钵。比丘应取持去。若至安隐丰乐处。尔时应还比丘尼衣食。应语言。姊妹。汝等随意不得共行。若尔时即共同道行。至一聚落。波逸提。若中道还突吉罗。若从聚落向空地。乃至一拘卢舍波逸提。中道还突吉罗。水道亦如是。不犯者。不期去。若有王夫人共行不犯(二十四竟)

十诵律卷第十一十诵律卷第十二(第二诵之六)

        后秦北印度三藏弗若多罗译

    九十波逸提之四

佛在王舍城。尔时六群比丘。与助提婆达多比丘尼。共载一船调戏大笑。作粗恶语种种不清净业。是中有白衣在两岸上。见已共相谓言。汝等看是。为是妇耶。为是私通。必共作淫欲事。是中有比丘。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集比丘僧。知而故问六群比丘。汝实作是事不。答言。实作世尊。佛以种种因缘诃责。云何名比丘。与比丘尼共载一船。种种因缘诃已。语诸比丘。以十利故。与诸比丘结戒。从今是戒应如是说。若比丘与比丘尼共期载一船。波逸提。期者。有二种。若比丘作期。若比丘尼作期。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若一比丘与一比丘尼共期载一船。一波逸提。若一比丘与二三四比丘尼共期载一船。四波逸提。若二比丘与二比丘尼共期载一船。二波逸提。若与三四一比丘尼共期载一船。一波逸提。若三比丘与三比丘尼共期载一船。三波逸提。若与四一二比丘尼共期载一船。二波逸提。若四比丘与四比丘尼共期载一船。四波逸提。若与一二三比丘尼。共期载一船三波逸提

佛在舍卫国。尔时诸比丘尼。从憍萨罗国游行向舍卫城。至河岸上住待船。尔时有诸比丘。亦从憍萨罗国游行向舍卫城。到河岸上待船。船至。比丘便疾上船。诸比丘尼复来欲上船。诸比丘言。汝莫上。何以故。佛结戒。比丘不得与比丘尼共载一船。诸比丘尼言。若然者大德先渡。是船即去。更不复还。诸比丘尼即于岸上宿。夜有贼采悉夺衣裸形放去。诸比丘游行。到舍卫国诣佛所。头面礼佛足一面立。诸佛常法。有客比丘来。以如是语劳问。忍不足不。安乐住不。乞食易得。道路不疲耶。佛即时以是语问讯。诸比丘忍不足不。乞食不乏道路不疲耶。诸比丘答言。世尊。忍足安乐住。乞食易得道路不疲。即以是事向佛广说。佛以是事集比丘僧。种种因缘赞戒赞持戒。赞戒赞持戒已。语诸比丘。从今是戒应如是说。若比丘与比丘尼。共期载一船上水下水。波逸提。除直渡。上水者逆流。下水者顺流。直渡者直到彼岸。是中犯者。若比丘与一比丘尼。共载一船上水。从一聚落至一聚落。波逸提。中道还者突吉罗。若无聚落。空地乃至一拘卢舍。波逸提中道还者突吉罗。下水亦如是。不犯者若不共期。若直渡。若欲直渡为水漂去。若直渡前岸崩堕。若漂失行具。船上下不犯(二十五竟)

佛在舍卫国。尔时诸比丘在屏处分衣。有一比丘。是偷兰难陀比丘尼知旧相识。数数共语亲善狎习。是比丘从分衣处出。偷兰难陀比丘尼见已问言。大德。从何处来。答言。从某处分衣来。汝所得衣分何似。答言好。比丘尼看已言实好问言。汝须是衣耶。比丘尼言。正使须者。我是女人薄福当何从得。时是比丘作是念是比丘尼作如是决定索。云何不与。即以衣与偷兰难陀比丘尼。时佛夏末月游行诸国。诸比丘皆着新衣。是比丘独着故衣。佛见已知而故问。汝何以独着故衣。比丘以是事向佛广说。佛知故问阿难。是比丘今与非亲里比丘尼衣耶。答言。实与世尊。佛以是事集比丘僧。种种因缘诃责。云何名比丘。与非亲里比丘尼衣。何以故。非亲里人不能问衣足不足。为更有无有得便直取。若亲里者。能问足不足。为更有无有。若无能自与。何况从索。佛种种因缘诃已。语诸比丘。以十利故。与诸比丘结戒。从今是戒应如是说。若比丘与非亲里比丘尼衣。波逸提。非亲里者。亲里。名母姊妹若女乃至七世因缘。异是名非亲里。衣者麻衣白麻衣赤麻衣刍摩衣翅夷罗衣憍施耶衣劫贝衣。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘有非亲里比丘尼谓是亲里与衣。波逸提。若非亲里比丘尼。谓是比丘式叉摩尼沙弥沙弥尼出家出家尼与衣。波逸提。若比丘。有非亲里比丘尼。生疑。是亲里非亲里与衣。波逸提。若比丘。有非亲里比丘尼。生疑。是比丘非比丘。是式叉摩尼非式叉摩尼。是沙弥非沙弥。是沙弥尼非沙弥尼。是出家非出家。是出家尼非出家尼与衣。皆波逸提。若比丘有亲里比丘尼。生非亲里想与衣。突吉罗。若亲里比丘尼。生比丘想式叉摩尼沙弥沙弥尼出家出家尼想与衣。突吉罗。若比丘。有亲里比丘尼。生疑。是亲里非亲里与衣。突吉罗。若亲里比丘尼。生疑。是比丘非比丘。是式叉摩尼非式叉摩尼。是沙弥非沙弥。是沙弥尼非沙弥尼。是出家非出家。是出家尼非出家尼与衣。突吉罗。若比丘。有亲里比丘尼。若谓若疑。有非亲里比丘尼。若谓若不谓。若疑若不疑。与不净衣。谓驼毛衣牛毛衣羖羊毛衣杂毛织衣与。突吉罗(二十六竟)

佛在舍卫国。尔时迦留陀夷。与掘多比丘尼旧相识。数数共语亲善狎习。是掘多比丘尼有衣应割截作。是比丘尼语迦留陀夷。大德。能为我割截作是衣不。答言留置。即留便去。迦留陀夷即取舒展割截簪刺。当衣脊中。作男女和合像缝已卷叠着本处。掘多比丘尼来问。大德。与我割截作衣竟未。答言已作。此是汝衣。持去。莫此间舒。还比丘尼寺中可舒。即取持去。于诸比丘尼前言。看我师与我作是衣好不。诸比丘尼言好。谁为汝作。答言。大德迦留陀夷。可舒看。即为舒看。当中条有男女和合像。中有年少比丘尼喜调戏笑者。见已语言。是衣好。自非迦留陀夷。谁能为汝作如是衣。时有长老比丘尼乐持戒者。作是言。云何名比丘。故污比丘尼衣。是中有比丘。少欲知足行头陀。闻是事心不喜。以是事向佛广说。佛以是事集比丘僧。知而故问迦留陀夷。汝实作是事不。答言。实作世尊。佛以种种因缘诃责。云何名比丘。故污比丘尼衣。种种因缘诃已语诸比丘。以十利故。与比丘结戒。从今是戒应如是说。若比丘与非亲里比丘尼作衣波逸提。非亲里者。亲里名母姊妹若女乃至七世因缘。异是名非亲里。衣者。麻衣白麻衣赤麻衣刍麻衣翅夷罗衣憍施耶衣劫贝衣。波逸提者。煮烧覆障。若不悔过能障碍道。是中犯者。若比丘为非亲里比丘尼作衣。随一一事中。波逸提。若浣随一一事波逸提。若染一一晒波逸提。若割截簪缝。若刺针针。波逸提。若直缝针针突吉罗。若绳絣时突吉罗。若簪缘突吉罗。若与亲里比丘尼作衣不犯(二十七竟)

佛在舍卫国。尔时迦留陀夷。与掘多比丘尼旧相识。数数共语亲善狎习。迦留陀夷往掘多比丘尼房所。屏覆处独与掘多比丘尼共坐。是中有比丘。少欲知足行头陀。闻已呵责言。云何名比丘。独与一比丘尼屏覆处共坐。种种因缘诃已。向佛广说。佛以是事集比丘僧。知而故问迦留陀夷。汝实作是事不。答言。实作世尊。佛以种种因缘诃责。云何名比丘独与一比丘尼屏覆处共坐。种种因缘诃已语诸比丘。以十利故与诸比丘结戒。从今是戒应如是说。若比丘独与一比丘尼屏覆处共坐波逸提。独与一比丘尼者。正有二人更无第三人。屏处者。若壁障衣幔障席障。如是等物覆障。是名屏处。波逸提者。煮烧覆障。若不悔过能障碍道。是中犯者。若比丘独与一比丘尼屏处坐。波逸提。起已还坐波逸提随起还坐。随得尔所波逸提(二十八竟)

佛在舍卫国。尔时迦留陀夷。与掘多居士妇旧相识。数数共语亲善狎习。时迦留陀夷往居士妇舍。独与此妇露地共坐。诸白衣见已作是言。汝等看是为比丘妇为私通耶。是比丘必当共作淫事。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘诃责。云何名比丘。独与一女人露地共坐。种种因缘诃已向佛广说。佛以是事集比丘僧。知而故问迦留陀夷。汝实作是事不。答言。实作世尊。佛以种种因缘诃责。云何名比丘。独与一女人露地共坐。佛种种因缘诃已语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘独与一女人露地共坐波逸提。女人者名有命若大若小若嫁未嫁堪作淫事。独与一女人者。正有二人更无第三人。露地者。无壁障无衣幔障无席障。波逸提者。煮烧覆障。若不悔过能障碍道。是中犯者。若比丘独与一女人露地共坐波逸提。起已还坐波逸提。随起还坐。随得尔所波逸提。若相去半寻坐波逸提。相去一寻坐波逸提。相去一寻半坐突吉罗。不犯者若相去二寻。若过二寻坐不犯(二十九竟)

佛在舍卫国。尔时有一居士。请佛四大弟子大迦叶舍利弗目揵连阿那律明日食。皆默然受。居士知诸比丘默然受已。从坐起头面作礼右绕而去。即还自舍。通夜办种种多美饮食。是夜办多美饮食已。晨朝敷杂色坐具。自往白四大比丘言时到。偷兰难陀比丘尼先在是家出入。是比丘尼早起着衣入是居士舍。见办多美饮食敷杂色坐具。时比丘尼问居士妇。办多美饮食敷杂色坐具请比丘耶。答言请。请谁耶。答言。请大迦叶舍利弗目揵连阿那律。是比丘尼语居士妇言。请是小小比丘。若问我者。当请大龙比丘。居士妇言。何者是大龙。答言。大德提婆达多俱伽离骞陀达多三文达多迦留卢提舍是。比丘尼共居士妇语时。大迦叶在前行。闻是语作是念。我等若不即入者。是比丘尼当作大罪。即作声。比丘尼闻声即默然。回面即见便语居士妇言。汝请是大龙。居士妇言。谁是大龙。答言。大迦叶舍利弗目揵连阿那律是。时居士随后来至。闻比丘尼作二种语。语偷兰难陀比丘尼言。汝弊恶贼比丘尼一头两舌。适言小小比丘。复言大龙。若更入我舍者。当如贼法治汝。复语其妇言。汝若更前是比丘尼者。我当唱言。汝非我妇当弃汝去。尔时居士令诸比丘坐杂色坐具。自行水。自与多美饮食。与多美饮食自恣饱满已。居士行水。诸比丘摄钵已。取小卑床在诸比丘前坐。欲听说法。大迦叶说法已。与诸比丘俱从坐起去。往诣佛所头面礼足一面立笑。佛知故问大迦叶。汝何因缘笑。答言世尊。我等今日为偷兰难陀比丘尼所见字名。谓为小小比丘。复言大龙。佛言。何因缘故尔。大迦叶向佛广说如上因缘。佛知故问阿难。有诸比丘食比丘尼作因缘食耶。答言实尔。佛以是事集比丘僧。种种因缘诃责。云何名比丘。知比丘尼作因缘得食便食。种种因缘诃已。语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘知比丘尼赞叹因缘得食食者。波逸提知者。若自知若从他知。若比丘尼自说赞叹者。比丘尼赞叹。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘尼往语居士妇。当请比丘。为请谁耶。答言请某。居士妇言尔。比丘尼言。为办粳米饭。是比丘食者波逸提。有比丘尼。往语居士妇言。当请比丘为请谁耶。答言请某。居士妇言尔。比丘尼言。与办酥豆羹。比丘食者波逸提又比丘尼往语居士妇言。当请比丘。为请谁耶。答言请某。居士妇言尔。比丘尼言。为办雉肉鵽肉鹑肉。比丘食者波逸提。乃至教办少姜着食中。比丘食者突吉罗。又比丘尼往语居士妇言。当请比丘。为请谁耶。答言请某。居士妇言。我已先请。问饭何似。答言粗饭。比丘尼言。与办粳米饭。比丘食者波逸提。又比丘尼往语居士妇言。当请比丘。为请谁耶。答言请某。居士妇言。我已先请。问羹何似。答言。为作浮陵伽豆羹。比丘尼言。为办酥豆羹。比丘食者波逸提。有比丘尼往语居士妇言。当请比丘。为请谁耶。答言请某。居士妇言。我已先请。问作何食。答言牛肉。莫与牛肉。为办雉肉鵽肉鹑肉。比丘食者波逸提。乃至教以少姜着食。中比丘食者突吉罗。佛在舍卫国。尔时有居士。先有心欲请佛及僧设会。时世饥俭饮食难得。是居士既不大富。少于田宅人民作使。夏月欲末。是居士忧愁言。奈何辛苦。我先有心欲请佛及僧设会。今世饥俭饮食难得。我不大富。少于田宅人民作使。夏月欲末。莫令我于福德空过。若不能都请僧。当于僧中请少多比丘。作是念已。往诣只桓打揵捶。诸比丘问居士。汝何因缘故打揵捶。答言。我欲僧中请尔所比丘明日到我舍食。诸比丘言尔。是居士请僧已。尔时更有急因缘事。须出城行。便约敕妇言。我有急事须自行去。汝当请尔所比丘能办如是如是饮食不。时妇信乐福德故答言。我能如教。即办种种多美饮食。敷杂色坐具。无人可遣请比丘。时有一比丘尼。先出入是家。是比丘尼早起着衣往其舍。见办多美饮食敷杂色坐具。见已问言。请比丘耶。答言欲请。如夫所教我尽办已。无人可往请比丘。汝能往请比丘来者。并在此食。答言能请。时诸比丘置衣钵。空地经行立待请至。时比丘尼出城。见诸比丘各已庄严。语诸比丘言。受某居士请者。饮食已办自知时到。诸比丘作是念。佛结戒。若比丘尼作因缘食不应啖。今比丘尼使来。是比丘尼必作食因缘。诸比丘不往。失是请故是日断食。时居士行还问妇言。汝请诸比丘。好供养耶。妇言。如夫所教。我办多美饮食。敷杂色坐具。遣比丘尼往唤诸比丘。不来。当何所供养。居士闻已嗔恚言。若诸比丘不饮食者。何以受我请。诸比丘不知。今世饥俭饮食难得。诸人妻子尚乏饮食。况与乞人。是居士不能忍嗔故。入只桓诣佛所言。诸比丘。是居士欲入只桓时。见所请比丘谓言。汝等若不饮食者。何以受我请。汝宁不知。今世饥俭饮食难得。诸人妻子尚乏饮食。况与乞人。诸比丘言。居士莫愁忧。佛为我等结戒。不得食比丘尼作因缘食。今日比丘尼作使来故。我等谓是比丘尼因缘饮食。是以不往。朝来我等断食。是居士闻比丘断食故。嗔即除灭。语诸比丘言。我先有心欲请佛及僧设食。今世饥俭饮食难得。我不大富。少于田宅人民作使。夏月欲末。我不欲于福德中空过。若不能都请者。当于僧中请少多比丘明日食。汝等当知我自发心。非比丘尼作因缘。汝等明日来食啖冷食。诸比丘不知云何。以是事白佛。佛以是事集比丘僧。种种因缘赞戒赞持戒。赞戒赞持戒已。语诸比丘。从今是戒应如是说。若比丘知比丘尼赞叹得食食。波逸提。除檀越先请。先请者。檀越先自发心思惟。欲请比丘僧。是中不犯者。若比丘尼往语居士妇言。当请比丘。为请谁耶。答言请某。居士妇言。我已先请。比丘尼言。为办粳米饭。若为家属作。比丘食者不犯。又比丘尼往语居士妇言。当请比丘。为请谁耶。答言请某。居士妇言。我先已请。比丘尼言。为办酥豆羹。若为家属作。比丘食者不犯。又比丘尼往语居士妇言。当请比丘。为请谁耶。答言请某。居士妇言。我已先请。比丘尼言。为办雉肉鵽肉鹑肉。若为家属作。比丘食者不犯。乃至教以少姜着食中。若为家属作。比丘食者不犯。若比丘尼往语居士妇言。当请比丘。为请谁耶。答言请某。居士妇言。我已先请。比丘尼言。为办粳米饭。若先为比丘作。比丘食者不犯。又比丘尼往语居士妇言。当请比丘。为请谁耶。答言请某。居士妇言。我已先请。比丘尼言。为办酥豆羹若先为比丘作。比丘食者不犯。又比丘尼往语居士妇言。当请比丘。为请谁耶。答言请某。居士妇言。我已先请。比丘尼言。为办雉肉鵽肉鹑肉。若先为比丘作。比丘食者不犯。乃至教以少姜着食中。若先为比丘作。比丘食者不犯(三十竟)

佛在舍卫国。尔时有一居士。以无常因缘故。亡失田宅家人死尽。但有一儿在是中。闻说饭佛及僧者生忉利天。即发是愿。我若饭佛及僧者。善作是愿已复念。我今无所有。当行客作。尔时舍卫国有一富贵居士。多有田宅人民金银财物。种种福德威相成就。时小儿往到其舍。语居士言。我为汝客作。居士问言。汝何所能。答言。我能书能读书能算数。能相金银钱相毛。相丝绵绢相珠相能坐金肆银肆珠肆铜肆客作肆。居士言。汝一岁作索几许物。答言千金钱。居士言。汝小儿不知。今世饥俭食尚难得。何况索价。是小儿言。我多技能如是。上中下相共决断。定雇金钱五百。小儿言。我应多得价直。我急故今与汝作。当共言要。岁尽一时偿我价。居士闻已作是念。自有作人作便索价。语是小儿言。汝莫忧愁。岁竟当一时与汝。居士安着肆上。时是小儿好看市肆。是居士先不得大利。今得再三倍。是居士过一月已。检校肆中。得三倍利。居士自念。若以是物我自在坐肆。不得是利。此客作人多有福德。今得是利皆由小儿。即将去着田上。于田中了了勤作。好看守护。先仓不满今皆倍满。岁竟看仓。先不满者今三倍满。居士复念。即以是田作处。我自在中不得是利。是小儿多有福德。我仓藏满皆是小儿力。岁竟小儿到居士所。一时索价。居士小避去作是念。是儿若得价者。便舍我去。是以小避非不欲与。是小儿数来索价。居士言。汝急索价欲作何物。答言居士。我闻人说饭佛及僧生忉利天。以是故。我一岁客作。欲饭佛及僧生忉利天。居士闻是语即生信心。是儿为他故。能一岁受勤苦。居士言。欲何处作。答言。欲只桓中作。是居士方便欲令好人入其舍。作是念已。语小儿言。只桓中少釜镬盆器薪草作人。不如我家多有釜镬盆器薪草作人种种具足。正使乏少我当相助。汝请佛及僧来就我舍。小儿即出居士舍。向只陀林去。尔时世尊晡时与无数大众围绕说法。时小儿遥见佛在树林中。善摄诸根成就第一寂灭。身出光焰如真金聚端正殊特令人心净。见已往到佛所。头面礼足在一面坐。佛为小儿种种因缘说法。示教利喜已默然。是小儿从坐起合掌白佛言。愿世尊。明日及僧受我请。佛默然受。是儿知佛默然受已。头面礼足右绕而去。还居士舍。通夜办种种多美饮食。尔时舍卫国节日早起。白衣多持猪肉干糒与众僧。诸比丘受取尝看。渐渐多啖饱满。是小儿通夜办多美饮食已。早起敷坐处。往白佛言。食具已办佛自知时。诸比丘往居士舍。佛自房住迎食分。是小儿见僧坐已。自手行水。持食欲着上座钵中。上座言少着。第二上座言莫多着。第三上座言着半。如是展转少与。莫多与与半。一切僧皆悉作是语。小儿往看饭处犹不大减。次看羹处亦不大减。看盆器中皆满不减。尔时小儿至上座前言。为慈愍我故不食耶。为以世俭故。为以我一岁客作勤苦故。为食不熟不香不美故上座直性言。我不以慈愍。不以世俭。不以客作勤苦。不以不熟不香不美故。今日舍卫城节日。早起大得猪肉干糒。初欲少尝渐渐饱满。是故食少。小儿闻已愁忧心悔。我作食不具足。或不得生忉利天上。是小儿出居士舍。啼哭诣佛所。说诸比丘食少。尔时世尊。与大众恭敬围绕而为说法。佛遥见小儿啼哭而来。佛问小儿。何以啼耶。即以是事向佛广说。佛语小儿。汝疾还去。随诸比丘能啖者与。汝必得生忉利天。小儿闻已大欢喜作是念。佛无异记。我当生忉利天无疑。时小儿持食至上座所言。是食香美。少多取。复以一种与言。是复大好。少多取。第二第三皆如是劝。小儿自手与多美饮食。诸比丘自恣饱满已。知僧摄钵。自手行水。取小床坐众僧前。欲听说法。上座说法已从坐起去。诸比丘随次起去。时舍卫城晡时。有大海诸估客至。置宝物城外各相谓言。当入城买饮食。即遣人求。以二因缘故。求不能得。一以世俭。二以时热食不留残。时买食人还语估客。至城中买食都不可得。估客主言。我于大海险难初不乏食。今至大城而不能得。汝等更往审谛遍求。随以何物方便令得。是小儿先啼向佛时。多人见知。是人语估客言。某舍今日多办饮食。而所用少。汝往彼舍求食必得。估客往居士舍。语守门者。语汝家主。有大海估客。今在门下。时守门者即入白主。主言便入。即入与坐。共相问讯乐不乐。居士小默然。便问。汝何故来。答言。须食故来。居士言。此是小儿饮食。非我有也。估客语小儿言。我等须饮食。小儿言可得。不须道价。今汝估客为有几许人。答言。有五百人。尽唤来入。是人即往语估客主有饮食可得。而不须价。估客主言。我等饥乏若以贵价买尚取。何况直得皆当共去。留人守物。余人皆往入居士舍。小儿令坐。自手行水。与多美饮食。自恣饱满。与多美饮食。自恣饱满已。是小儿知食竟。摄器行水在一面坐。时近小儿边。有憍萨罗国大铜盂。时估客主语小儿言。持此盂来。小儿言何以故。但取来。即持来着估客主前。时估客主语诸估客言。随何舍得如是好供养者。应当以好物报偿。汝若能者着此盂中。时估客主衣角头有珠。直十万金钱。解着盂中。第二估客有珠。直九万金钱。如是有直八万七万六万五万四万三万二万一万者。着铜盂中。溢满一盂持与小儿。以是相与汝随意用。小儿言。我直与食不卖求价。诸估客言。我亦直与不以买食。我等所食几许。是一一珠多有所直。小儿复疑。我若取物。或不得生忉利天上。语估客主言。小住。待我问佛还。估客言随意。小儿出城往诣佛所。头面礼足在一面立。以是事向佛广说。佛言但取。必得生忉利天上。今是华报。果报在后。闻是语已念言。佛无异语。与我受记。必得生忉利天。即还到估客所取是宝物。是小儿忽然大富贵故。即名为忽然居士。所可客作居士家大富贵。种种福德威相成就事事具足。但无儿子。惟有一女。端正姝妙。是居士作是念。是小儿姓不减我。但贫乏财。今日所得财物我舍不及。今当与女作妇。即自语妇。妇言随意。是居士即以女与。如偈所说

  有者皆尽　　高者亦堕　　合会有离
  生者有死

以是因缘故。是居士死。波斯匿王闻已问言。是居士有儿不。答言无儿。有兄弟不。答言无有。谁料理是家。答言。有一女婿。善好有功德。料理其家。王言。其家财物即与是人。复与舍卫城内大居士职位。作是教已。即用作大居士职。是诸比丘。食后出城往诣佛所。头面礼足在一面坐。诸佛常法。诸比丘食还。以如是语劳问比丘。饮食多美众僧饱满不。佛以是语问诸比丘饮食多美众僧饱满不。诸比丘答言。饮食多美众僧饱满。以是事向佛广说。佛以是事集比丘僧。以种种因缘诃责比丘。云何名比丘。数数食。佛但诃责而未结戒。佛在维耶离。尔时维耶离有一大力大臣。往诣佛所头面礼足一面坐已。佛以种种因缘说法示教利喜。示教利喜已默然。是大力大臣知佛种种示教利喜已。从坐起合掌白佛言。世尊。愿佛及僧受我明日食。佛默然受。大臣知佛受已。即礼佛足右绕而去。还到自舍。通夜办种种净洁多美饮食。尔时维耶离节日。众僧多得猪肉干糒。诸比丘受已。欲少尝看渐渐饱满。是人办种种净洁多美饮食已。早起敷座遣使白佛。食具已办佛自知时。诸比丘往大臣舍。佛自房住迎食分。是大臣见僧坐已。自手行水。自持饭与上座。上座言莫多着。第二上座言少着。第三上座言与半。如是展转莫多与少与与半。一切皆尔。时是大臣往看饭处。饭不大减。看羹处羹不大减。看盆盂器中皆满不减。尔时大臣往上座所言。何故不食。为慈愍我故。为世俭故。为食不熟不香不美。上座直实言。我不以慈愍故。不以世俭。不以不熟不香不美故。今是节日。早起多得猪肉干糒。初欲少尝渐渐饱满。是故食少。大臣闻说是事。即发恚言。收是好食去。持猪肉干糒来与。尔时使人即收好食。持猪肉干糒满钵与。大臣言食。汝谓我家无是食耶。诸比丘即时惭愧不食不语。大臣见已作是念。好食尚不能啖。况啖粗食。还使收去。时大臣至上座前言。汝等好食尚不能啖。何况粗食。猪肉干糒世间宜法。若受他请应待其食。大臣自手捉好食言。是食香美。可少多啖。复捉余食言。是食香美。胜于前者。可受食。如是劝已一切僧皆饱满。尔时大臣。以净洁多美饭食。自恣饱满已自手行水。知僧摄钵竟。取小床坐僧前。欲听说法。上座说法已从坐起去。诸比丘随次第起去。还诣佛所头面礼足。诸佛常法。比丘食还如是劳问。饮食多美僧饱满不。佛以是语问诸比丘。饮食多美僧饱满不。诸比丘言。饮食多美众僧饱满。以是事向佛广说。佛以是事及先因缘集比丘僧。种种因缘诃责诸比丘。云何名比丘。数数食。种种因缘诃已。语诸比丘。以十利故。与比丘结戒。从今是戒应如是说。若比丘数数食。波逸提数数者。食已更食。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘数数食波逸提。不犯者。不数数食

佛在王舍城。尔时有一比丘。于秋月时冷热病盛。不能饮食羸瘦无色。佛见比丘羸瘦无色。知而故问阿难。何故比丘羸瘦无色。阿难答言。世尊。是比丘秋月冷热病盛。不能饮食。是故羸瘦无色。佛以是因缘故集比丘僧。语诸比丘。从今日怜愍利益病比丘故。听三种具足食应食谓好色香味。病比丘应受一请。不应受二请。若一请处不能饱。应受第二请。不应受第三请。第二请处不能饱满应受第三请。不应受第四请。若第三请处不能饱应受已渐渐食。乃至日中。从今是戒应如是说。若比丘数数食波逸提。除时。时者谓病时。是名时。若人冷盛热盛风盛。得食则止。是中犯者。若比丘无病数数食。波逸提。若实病不犯。佛在舍卫国。尔时诸比丘入舍卫城乞食。时得有衣请食。请主言。受我食者当以衣施。诸比丘言。佛未听我等为衣故数数食。诸比丘不知云何。是事白佛。佛以是事集比丘僧。种种因缘赞戒赞持戒。赞戒赞持戒已。语诸比丘。从今衣因缘故。听诸比丘数数食从今是戒应如是说。若比丘数数食波逸提。除时。时者病时施衣时。是名时。是中犯者。若比丘有衣食请。彼有衣食来。受请不犯。食者亦不犯。又比丘有衣食请。彼无衣食来。受请不犯。食者波逸提。又比丘有衣食请。彼有衣食无衣食来。受请不犯。食者波逸提。若比丘无衣食请。彼无衣食来。受请突吉罗。食者波逸提。又比丘无衣食请。彼有衣食来。受请突吉罗。食者不犯。又比丘无衣食请。彼有衣食无衣食来。受请突吉罗。食者波逸提。若比丘有衣食无衣食请。彼有衣食无衣食来。受请突吉罗。食者波逸提。又比丘有衣食无衣食请。彼有衣食来。受请突吉罗。食者不犯。又比丘有衣食无衣食请。彼无衣食来。受请突吉罗。食者波逸提。不犯者。得多有衣食请。一切有衣食来不犯

佛在舍卫国。尔时舍卫城节日多有饮食。诸居士作种种饮食。持诣园中便入只桓打揵捶。诸比丘问。居士。何因缘故打犍捶。诸居士言。我于众中请尔所比丘饮食。诸比丘言。佛未听节日在白衣会中数数食居士言。我等白衣法。若嫁娶。节日集会宴诸亲族知识。我等贵重诸比丘。更无天神胜沙门释子。汝等必当受我会食。诸比丘不知云何。是事白佛。佛以是事集比丘僧。种种因缘赞戒赞持戒。赞戒赞持戒已。语诸比丘。从今听诸比丘节日数数食。彼与他竟受彼中。何者与他谓相食故作食。斋日食月一日食。十五日食。众僧食别房食。众僧请独请。皆应与他。若五众请食。不应与他(相者吉凶相也故作者大德比丘人为之供养也五众者比丘尼六法尼沙弥沙弥尼也三十一竟)

佛在舍卫国。尔时憍萨罗国诸居士作福德舍。若有沙门婆罗门来是中宿者。诸居士往迎问讯礼拜。汤水洗脚苏油涂足。给好床榻卧具毡褥被枕。明日与香美前食后食怛钵那。恭敬供养。尔时六群比丘。从憍萨罗国游行。向舍卫城到福德舍。诸居士即时出迎问讯礼拜。汤水洗脚苏油涂足。给好床榻卧具毡褥被枕。明日与香美前食后食怛钵那恭敬供养。尔时六群比丘共相谓言。今时恶世饮食难得。当小住此受乐。作是念已即住不去。是中更有沙门婆罗门来欲宿者。不相容受。是后来沙门婆罗门语主人言。我等得此宿不。主人言好。便入至六群比丘所欲宿。六群比丘言不得。何以故。我已先住。六群比丘素健多力。客来不能共语。诸居士嗔诃责言。诸沙门释子自言。善好有德。云何强住福德舍。如王如大臣。是中有比丘。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集比丘僧。知而故问六群比丘。汝实作是事不。答言。实作世尊。佛以种种因缘诃责。云何名比丘。福德舍过一食佛种种因缘诃已语诸比丘。以十利故与比丘结戒从今是戒应如是说。若比丘福德舍过一食波逸提。福德舍法者。是中应一夜宿应一食。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘福德舍过一食。波逸提。若过一夜宿不食者。突吉罗。若余处宿是中食者。波逸提。若一夜宿一食。不犯(福德舍应言一宿处)

佛在舍卫国。尔时长老舍利弗。从憍萨罗国游行。向舍卫国到福德舍。时风病发。作是念。我若住中过一宿不食。得突吉罗。我宁当去。去已道中病更增剧。渐渐游行到舍卫国诣佛所。头面礼足一面坐。诸佛常法。有客比丘来。以如是语问诸比丘。忍不足不。安乐住不。乞食不难。道路不疲耶。佛以是语问舍利弗。忍不足不。安乐住不。乞食不难。道路不疲耶。舍利弗言。世尊。乞食易得。但不可忍道路疲极。以是事向佛广说。佛以是事集比丘僧。种种因缘赞戒赞持戒。赞戒赞持戒已。语诸比丘。从今是戒应如是说。若比丘不病。福德舍过一食。波逸提。病者。乃至从一聚落至一聚落。身伤破乃至竹叶所伤。皆名为病。是中犯者。若比丘无病。住福德舍过一食。波逸提。若过一宿不食者。突吉罗。若余处宿是中食。波逸提。不犯者。一夜宿一食。若病。若福德舍是亲里作。若先请。若住福德舍待伴欲入险道。若多有福德舍。若知福德舍人留住。皆不犯(三十二竟)

十诵律卷第十二十诵律卷第十三(第二诵之七)

        后秦北印度三藏弗若多罗译

    九十波逸提之五

佛在舍卫国。尔时有一婆罗门。有女睐眼。即名睐眼。夫家遣使来迎。时女父母婆罗门言。小待。作煎饼竟送。时世饥俭。是婆罗门勤苦求煎饼具作饼。跋难陀释子常出入其家。语其大众言。随我所入舍汝等皆随我入。若我得食汝等亦次第得。时跋难陀释子。中前着衣持钵入婆罗门舍。与坐处共相问讯乐不乐。坐已是婆罗门一心恭敬问讯跋难陀。跋难陀是大法师。有乐说辩才。为说种种妙法。主人得法味故作是言。大德无有羹饭。能啖是饼不。答言。汝等尚啖。我何以不能。即与饼持出。第二第三比丘亦如是。时饼器皆空。夫家复更遣使唤睐眼女。婆罗门还遣使答言。小待。作饼竟送。更求煎饼具。时跋难陀复共徒众来。为说种种法已。复持饼去。夫家第三复遣使来唤睐眼女。是婆罗门复答言。小待。作煎饼竟送。时夫疑嗔言。是或不复来。彼更娶妇。遣使语言。我已娶妇。汝莫复来。婆罗门闻是语。愁忧嗔言。沙门释子乃尔不知厌足。施者不知量。受者应知量。我女婿先相爱念。以是因缘今便弃去。是人嗔恨不能自忍。到只桓向佛所欲说跋难陀事。尔时佛与百千万众围绕说法。渐渐近佛。佛以慈心力故。彼嗔即除。到佛所作是言。世尊。无有是法。女人所贵重物。我女已失。佛为种种因缘说法示教利喜。示教利喜已默然。婆罗门闻佛种种因缘说法示教利喜已。头面礼佛足右绕而去。去不久。佛以是事集比丘僧。知而故问跋难陀。汝实作是事不。答言。实作世尊。佛种种因缘诃责。云何名比丘。不知时不知量不知法。若施者不知量。受者应知量。佛但诃责而未结戒。时佛故在舍卫国。尔时舍卫城中有估客众。用沸星吉日欲出行他国。有一估客。是跋难陀释子相识。跋难陀常出入其舍。时跋难陀。中前着衣持钵到其舍。与坐处共相问讯乐不乐。坐已估客一心恭敬问讯跋难陀。跋难陀是大法师。有乐说辩才。为说妙法。是人得法味故言。大德。无有羹饭。但有道中行粮糗。能啖不。答言。汝等尚能啖。我何以不能。即与糗持出。第二第三比丘亦如是。估客糗器皆空。是估客往语估客主言。我所有行粮。沙门释子悉持去尽。小待。我更作粮食。估客主言。诸估客欲沸星吉日去。云何得住。汝但办粮徐徐后来。诸估客在前去者。众多故贼不敢发。是一估客办粮已。与少伴共入险道。贼发夺物杀是估客。如是恶声流布诸国。作是言。释种比丘食他行粮。是估客险道为贼所杀。一人语二人。二人语三人。如是展转相语。诸沙门释子比丘。恶名流布满舍卫城。是中有比丘。少欲知足行头陀。闻是事心不喜。向佛广说佛以是事集比丘僧。知而故问跋难陀。汝实作是事不。答言。实作世尊。佛以种种因缘诃责。云何名比丘。不知时不知量不知法。若施者不知量。受者应知量。云何令是估客险道中为贼所杀。种种因缘诃责已语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘往白衣家。自恣请多与饼糗。诸比丘须者。应二三钵取。过是取者波逸提。二三钵取已出外。语余比丘共分。是事应尔。家者白衣。家请多与者。数数与饼者。小麦面作。大麦面作。粳米面作。大重华饼。小重华。饼如是比诸清净。饼糗者。稻糗麦糗钵者。有三。种上中下。上钵者。受三钵他饭一钵他羹余可食物半羹。下钵者。受一钵他饭半钵他羹余可食物半羹。若上下中间。是名中钵。出外语余比丘共分者。谓眼所见。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘以上钵取者。应取一钵。不应取二钵。取二钵波逸提。若以中钵取者。极多取二钵。不应取三。若取三者波逸提。若以下钵取者。极多取三钵。不应取四。若取四者波逸提。出外见比丘共分者善。不共分者突吉罗(三十三竟)

佛在舍卫国。尔时长老迦留陀夷。于夜闇时有小雨堕雷声电光中。入白衣舍乞食。时是家中。有一洗器女人出于电光中。遥见迦留陀夷身黑。见已惊怖身毛皆竖。即大唤言。鬼来鬼来。以怖畏故即便堕胎。迦留陀夷言。姊妹。我是比丘非鬼也。乞食故来。时女人嗔。以恶语粗语不净语苦语语比丘言。使汝父死母死种姓皆死。使是沙门腹破秃沙门断种人着黑弊衣。何不以利牛舌刀自破汝腹。乃于是夜闇黑雷电中乞食。汝沙门乃作尔许恶。我儿堕死令我身坏。迦留陀夷。于是家起如是过罪故。即便出去。以是事向诸比丘说。诸比丘以是事向佛广说。佛以是事集比丘僧。知而故问迦留陀夷。汝实作是事不。答言。实作世尊。佛以种种因缘诃责。云何名比丘。非时入白衣家乞食。佛言。若比丘非时入白衣家。何但得如是过罪。当复更得过于是罪。从今诸比丘应一食。尔时诸比丘以一食故。羸瘦无色无力。佛见诸比丘羸瘦无色无力。知而故问阿难。诸比丘何故羸瘦无色无力。阿难答言。世尊结戒。诸比丘应一食。一食故。诸比丘羸瘦无色无力。佛以是事集比丘僧。种种因缘赞戒赞持戒。赞戒赞持戒已。语诸比丘。从今听啖五种佉陀尼自恣食。五种者。谓根茎叶磨果。尔时诸比丘入王舍城乞食。时有白衣。以芦卜叶胡荽叶罗勒叶杂食与诸比丘。诸比丘不食故。不得饱满。复更羸瘦无色无力。佛知故问阿难。何以故。诸比丘羸瘦无色无力。阿难答言。世尊。听诸比丘啖五种佉陀尼食自恣受。诸比丘入王舍城乞食。时有白衣。以芦卜叶胡荽叶罗勒叶杂食与诸比丘。诸比丘不食不得饱满故。羸瘦无色无力。佛闻已语诸比丘。从今听食五种蒲阇尼食。谓饭糗糒鱼肉。五种食自恣受。是诸比丘入王舍城乞食。时诸白衣以芦卜叶胡荽叶罗勒叶杂食与诸比丘。诸比丘不食复不饱故。羸瘦无色无力。佛见诸比丘羸瘦无色无力。知而故问阿难。何故诸比丘羸瘦无色无力。阿难答言。世尊。听食五种食。诸比丘入城乞食时。得芦卜叶胡荽叶罗。勒叶杂食与诸比丘。诸比丘不食复不饱满故。羸瘦无色无力。佛言。从今听食五种似食自恣随所杂。谓糜粟穬麦莠子迦师饭

佛在维耶离。尔时有一居士。到佛所头面礼足一面坐。佛见居士一面坐已。与说种种法示教利喜。示教利喜已默然。是居士闻佛种种因缘示教利喜已。从坐起合掌言。愿佛及僧受我明日食。佛默然受。居士知佛默然受已。即礼佛足右绕而去。还归自舍。通夜办种种多美饮食。晨起敷座处。遣使白佛。食具已办佛自知时。诸比丘僧往居士舍。佛自住房迎食分。居士知众僧坐已。自手行水。自与种种多美饭食。自恣饱满。尔时维耶离诸比丘多病。有看病比丘。先于僧中食竟。迎病比丘食分去。诸病比丘。有食者。有不食者。有少食者。是看病比丘先已食。从坐处起更不得食。诸病比丘多有残食。弃僧坊内是时多有乌鸟。来啖是食作大音声。佛闻寺内多乌鸟声。知而故问阿难。何故僧坊内多有乌鸟声。阿难答言。世尊。是维耶离诸比丘多病。有看病比丘。先于僧中食竟。迎病比丘食分来。诸病比丘。有食者。有不食者。有少食者。是看病比丘先已食。从坐处起更不得食。诸病比丘多有残食。弃僧坊内。有乌鸟来啖是食故作大音声。佛以是事集比丘僧。种种因缘赞戒赞持戒。赞戒赞持戒已。语诸比丘。从今以二利故。听受残食法。一者看病比丘因缘故。二者比丘有因缘食不足故。以十利故与比丘结戒。从今是戒应如是说。若比丘食竟有从坐处起去。不受残食法若啖食者。波逸提。啖者五种佉陀尼。食者五种蒲阇尼五种似食。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘食竟从坐起去。不受残食法。若啖根食波逸提。若啖茎叶磨果。皆波逸提。若比丘食竟起去。不受残食法。若食饭者波逸提。若食糗糒鱼肉。皆波逸提。若比丘食竟从坐起去。不受残食法。若食糜饭粟饭穬麦饭莠子饭迦师饭。皆波逸提。从今听受残食法者。诸比丘不知云何受。佛语诸比丘。欲受残食法者。随所能食多少。尽着钵中。知余比丘食未竟未起者。从是人边偏袒胡跪捉钵言。长老忆念。与我作残食法。若前比丘不少多取是食者。不名作残食法。若用是受残食法。若啖若食波逸提。若持钵着地受残食法者。不名为受残食法。若用是受残食法。若啖若食波逸提。若以钵着膝上受残食法者。不名为受。若用是受残食法者。若啖若食波逸提。若相去远手不相及受残食法者。不名为受残食法。若用是受残食法者。若啖若食波逸提。若以不净食受残食法者。不名为受残食法。若用是受残食法。若啖若食波逸提。若以不净肉受残食法者。不名为受。若用是受残食法者。若啖若食波逸提。若比丘欲啖五种佉陀尼时。用五种蒲阇尼受残食法者。不名为受。若用是受残食法者。若啖若食波逸提。若欲食五种蒲阇尼时。用五种佉陀尼受残食法者。不名为受。若用是受残食法。若啖若食波逸提。若欲食五种似食时。用五种蒲阇尼受残食法者。不名为受。若用是受残食法。若啖若食波逸提。若比丘受残食法。坐食余五种食来。若啖一一突吉罗。长老优波离问佛言。世尊。比丘有几处行时自恣几住几坐几卧。佛告优波离。五处比丘行时自恣。五处立五处坐五处卧。行有五处者。知行知供养知遮食知种种食坏威仪。立有五者。知立知供养知遮食知种种食坏威仪。坐有五种。知坐知供养知遮食知种种食坏威仪。卧有五者。知卧知供养知遮食知种种食坏威仪。佛语优波离。若比丘行洗口。时有檀越与五种食。比丘应啖应食。应行受残食法。不应立不应坐不应卧。若立坐卧。当知坏威仪。不应受残食法。若受者不名为受。若用是受残食法。若啖若食皆波逸提。若比丘彼行洗口已。有檀越与五种食。比丘应啖应食。应行受残食法。不应立不应坐不应卧。若立坐卧。当知坏威仪。不应受残食法。若受者不名为受。若用是受残食法。若啖若食波逸提。若比丘彼行食时。有檀越与五种食。比丘应啖应食。应行受残食法。不应立不应坐不应卧。若立坐卧。当知坏威仪。不应受残食法。若受者不名为受。若用是受残食法。若啖若食波逸提。若比丘彼行食已。有檀越与五种食。比丘应啖应食。应行受残食法。不应立不应坐不应卧。若立坐卧。当知坏威仪。不应受残食法。若受者不名为受。若用是受残食法。若啖若食皆波逸提。若立坐卧亦如是。不犯者。若比丘言。小住。若言日时早。若歠粥若饮。若一切先嘱食。不犯(三十四事竟)

佛在舍卫国。尔时憍萨罗国。一住处有二比丘。是一比丘破戒缺漏。无有惭愧不护细戒。第二比丘清净持戒乃至小罪生大怖畏。是清净比丘见彼犯罪。常语彼言。汝今犯如是如是罪。破戒比丘作是念。我当何时见是犯罪我当出之。破戒比丘一时。见持戒比丘食已无自恣请故从坐起。便持蒲阇尼佉陀尼唤来共啖食。持戒比丘不忆。不嘱食便共啖食。破戒比丘言。长老。汝得波逸提罪。问言。何等波逸提。答言。汝食已无自恣请便啖食。持戒比丘言。汝知我食已无自恣请者。何故唤我食。答言。汝常数数出我罪。时我作自念。何时见汝犯罪当即出之。是故见汝食已无自恣请。欲相恼故劝汝令食。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘诃责。云何名比丘。知他食已无自恣请。欲相恼故劝令食。种种因缘诃已。向佛广说。佛以是事集比丘僧。知而故问是比丘。汝实作是事不。答言。实作世尊。佛以种种因缘诃责。云何名比丘。知他食已无自恣请。欲相恼故劝令食。佛种种诃已语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘知比丘食已无自恣请。欲相恼故。劝令食蒲阇尼佉陀尼。以是因缘无异者。波逸提。知者。若比丘自知若从他知若彼比丘自说。啖者。五种佉陀尼五种蒲阇尼五似食。劝令食者。殷勤令食。恼者以嗔恚心出其过罪。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘见余比丘食竟无自恣请。教啖根食茎叶磨食果食若教食五种蒲阇尼饭糗糒鱼肉。若教食五似食糜粟穬麦莠子迦师小麦饭者。皆波逸提。复有比丘。教余比丘非时啖食。若彼啖者俱波逸提。有比丘。教余比丘非时食。若彼食者俱波逸提。有比丘。教余比丘偷夺他物。若偷夺者。随物俱得罪。有比丘。教余比丘夺人命。若夺命者。俱波罗夷。若比丘。教余比丘杀生草木。若杀者俱波逸提。若比丘教余比丘拽他出房。若拽出者俱波逸提。若比丘教余比丘强敷卧具。若敷者俱得波逸提若比丘教余比丘。用有虫水洒草洒泥。若用者俱波逸提。若比丘。教余比丘取有虫水饮。若取饮者俱波逸提。若比丘教余比丘。与裸形外道男女饮食。若与者俱波逸提。若比丘教余比丘空地燃火。若燃者俱波逸提。若比丘教余比丘自手取金银。若取者俱波逸提。若比丘教余比丘夺畜生命。若夺者俱波逸提。若比丘教余比丘。藏是比丘衣钵。若藏者俱波逸提。若比丘教余比丘自手掘地。若掘者俱波逸提。若比丘教余比丘啖残宿食。若彼啖者俱波逸提(云大比丘未手受食而共食宿者名曰内宿啖此食者突吉罗已手受举共宿者名残宿食啖此食者波逸提三十五事竟)

佛在王舍城。尔时阿阇世王诸大臣将帅。信提婆达。是诸人民为助提婆达比丘。作供养前食后食怛钵那。诸有年少比丘出家不久者。提婆达以钵钩钵多罗大揵瓷小揵瓷衣钩禅镇绳带匙筋钵支扇盖革屣。随比丘所须物皆诳诱之。提婆达自共百比丘或二百三百四百五百比丘恭敬围绕。入王舍城别受好供养。前食后食怛钵那。诸有上座长老比丘得佛法味久修梵行。是诸比丘入城乞食。得宿冷饭或不得。或得臭糗或不得。如是粗食或饱不饱。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘诃责。云何名比丘。自共百人二百三百四百五百比丘恭敬围绕。别受供养前食后食怛钵那。诸有上座长老比丘得佛法味久修梵行。是诸比丘入城乞食。得宿冷饭或不得。或得臭糗或不得。如是粗食或饱不饱。种种因缘诃已。向佛广说。佛以是事集比丘僧。佛以种种因缘诃责。云何名比丘。自共百人二百三百四百五百比丘恭敬围绕。别受供养前食后食怛钵那。诸上座长老比丘得佛法味久修梵行。是诸比丘入城乞食。得宿冷饭或不得。或得臭糗或不得。如是粗食或饱不饱。种种因缘诃已语诸比丘。从今以二利因缘故。遮别众食。听三人共食。一利者随护檀越以怜愍故。二利者破诸恶欲比丘力势故。莫令恶欲人别作众别作法与僧共诤。以十利故与比丘结戒。从今是戒应如是说。若比丘别众食波逸提。别众食者。极少乃至四比丘共一处食。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若四比丘别众食波逸提。若三比丘别共一处食。第四人取食分不犯

佛在王舍城。尔时诸病比丘。以乞食因缘故。苦恼疲悴。城中有居士。见已问言。汝等苦恼耶。答言苦恼。何因缘故。答言。我等有病。以乞食因缘故苦恼。诸居士言。汝等病者。我今请汝。诸有病者来我舍食。诸比丘言。佛未听病因缘故别众食。诸比丘不知云何。是事白佛。佛以是事集比丘僧。种种因缘赞戒赞持戒。赞戒赞持戒已。语诸比丘。从今听诸病比丘别众食。从今是戒应如是说。若比丘别众食波逸提。除因缘。因缘者。病时。病者。若比丘风冷热盛。是名为病。是中犯者。若比丘无病别众食波逸提。病者不犯

佛在舍卫国。尔时诸比丘作衣时到。是诸比丘早起。求染衣具薪草煮染漉出扬冷出所染衣。如是中间食时转近。行乞食不得。因是苦恼。城中有居士。见已问言。汝等苦恼耶。答言苦恼。何因缘故。我等作衣时到。早起求索染衣具。薪草煮染漉出扬冷出所染衣。如是中间食时转近。乞食不得。以是因缘故苦恼。诸居士言。我今请汝。诸作衣者来我舍食。诸比丘言。佛未听我为作衣故别众食。诸比丘不知云何。是事白佛。佛以是事集比丘僧。种种因缘赞戒赞持戒。赞戒赞持戒已语诸比丘。从今听比丘作衣时到诸作衣者别众食。从今是戒应如是说。若比丘别众食波逸提。除因缘。因缘者。病时作衣时。是中犯者。若比丘作衣时未到。别众食波逸提。作衣时到别众食不犯

佛在舍卫国。尔时诸比丘。从憍萨罗国游行向舍卫城。彼国地平诸聚落远。遥看似近。诸比丘欲从前聚落乞食。至聚落时日已中到。当乞食时日已过。诸比丘断食故苦恼。是聚落中诸居士。见已问比丘言。汝等苦恼耶。答言苦恼。何因缘故。我从憍萨罗国向舍卫城。遥看聚落谓近。欲至乞食。时日便过中。不得食故苦恼。诸居士言。我今请汝等。诸欲行者来我舍食。诸比丘言。佛未听行因缘故别众食。诸比丘不知云何。以是事白佛。佛以是事集比丘僧。种种因缘赞戒赞持戒。赞戒赞持戒已语诸比丘。从今听诸行比丘别众食。从今是戒应如是说。若比丘别众食波逸提。除因缘。因缘者。病时作衣时行时。行者。极近至半由延。若往若来。是中犯者。若比丘昨日来。今日食者波逸提。明日行今日食。波逸提。即日行极少半由延。若往若来。若别众食不犯

佛在舍卫国。尔时诸比丘。后憍萨罗国载船向舍卫国。是船行近聚落。时诸比丘语船师言。回船向岸我欲乞食。即回船向岸。诸比丘出船入聚落。家家求食已出聚落食。食已洗手洗口洗钵。卷衣着囊中。如是中间船去已远。诸比丘即从步道行逐船。值师子难虎狼难熊罴难。从非道去。有棘刺竹刺刈草刺。走逐船时脚痛苦恼。是岸上有居士见已问比丘言。汝苦恼耶。答言苦恼。何因缘故。我等先载船向舍卫国。船近聚落。我等语船师言。回船向岸我欲乞食。即时向岸。我等出船入聚落。家家求食已出聚落食。食已洗手洗口洗钵。卷衣着囊中。尔时船去已远。即从道行逐船。值师子难虎狼难熊罴难。若从非道行。有棘刺竹刺刈草刺。走逐船脚痛苦恼。诸居士言。我今请汝。诸船行者来我舍食。诸比丘言。佛未听船行因缘故别众食。诸比丘不知云何。以是事白佛。佛以是事集比丘僧。种种因缘赞戒赞持戒。赞戒赞持戒已语诸比丘。从今听诸船行比丘别众食。从今是戒应如是说。若比丘别众食波逸提。除因缘。因缘者。病时作衣时道行时船行时。船行者。极近至半由延。若往若来。是中犯者。若比丘昨日来今日食者。波逸提。明日行今日食者。波逸提。即日行极少半由延。若往若来。别众食不犯

佛在王舍城。尔时王舍城内有大众集。佛与千二百五十比丘俱。是中诸比丘入城乞食。诸居士但能与二三比丘食。更不能与。即闭门言。极多谁能为与。后来乞食比丘不得故苦恼。有居士见已问比丘言。汝等苦恼耶。答言苦恼。何因缘故。诸比丘言。是王舍城有大众集故。诸比丘前乞食者二三人得。诸居士即闭门言。是极多谁能为与。我等后来乞食不得。是故苦恼。诸居士言。我今请汝诸有大众集因缘者。来我舍食。诸比丘言。佛未听大众集因缘故别众食。诸比丘不知云何。是事白佛。佛以是事集比丘僧。种种因缘赞戒赞持戒。赞戒赞持戒已语诸比丘。从今听诸比丘有大众集因缘者别众食。从今是戒应如是说。若比丘别众食波逸提。除因缘。因缘者。病时作衣时道行时船上行时大众集时。大众集者。极少乃至八人。四旧比丘四客比丘共集。以是因缘故。令聚落中诸居士。不能供给。诸比丘饮食。是中犯者。若比丘减八人集时别众食。波逸提。若八人若过八人集时不犯

佛在王舍城。尔时瓶沙王舅。于阿耆维外道中出家。是舅作是念。我外甥瓶沙王。深敬佛及弟子。我为是王故。当请佛及弟子作一食。是外道便入王舍城。求米面胡麻小豆。诸居士问言。欲作何等。答言。我外甥深敬佛。我欲令欢喜故。欲请佛及弟子作一食。诸居士信佛法故。故多与米面。得已出城见一比丘。即便语言。汝能为我请佛及尔所弟子。明日至我舍食不。比丘答言。佛未听我等受沙门别众食。彼言。俱是出家人。何故不听。有何不可。我亦不敬汝等。但为外甥敬佛。欲令欢喜故。为汝等作食。时外道作是念。我当办具饮食。若佛与弟子来者当与。若不来者当用作酒自饮。是比丘不知云何。以是事白佛。佛以是事集比丘僧种种因缘赞戒赞持戒。赞戒赞持戒已语诸比丘。从今听沙门因缘故别众食。从今是戒应如是说。若比丘别众食波逸提。除因缘。因缘者。病时作衣时道行时船行时大众集时沙门请时。沙门者。名阿耆维尼揵子老弟子。略说除佛五众。余出家人皆名沙门。是中犯者。若沙门请比丘。白衣手持食与。是比丘受请不犯。食者波逸提。若白衣请比丘。沙门手持食与。是比丘受请故突吉罗。食者不犯。若白衣请比丘。白衣手持食与。受请故突吉罗。食者波逸提。不犯者。若沙门请沙门。手持食与若受请若食不犯(三十六竟)

佛在舍卫国。尔时节日至。诸居士办种种好饮食。出城入园林中。尔时十七群比丘。自相谓言。可共到彼园中看去。皆言可尔。即自洗浴庄严面目香油涂发着新净衣。到园林中一处立看。是十七群比丘端正姝好多人敬爱。诸居士见共相谓言。看是诸出家年少端正姝好。皆言实尔。诸居士欢喜故。持种种好酒食与言。汝能啖不。答言。汝等尚能。我何以不能。是十七群比丘。多得饮食已醉乱迷闷。食后摇头掉臂向只桓。作是言。我等今日极好快乐。有福德无有衰恼。尔时诸比丘。在只桓门间空地经行。闻是音声。诸比丘问言。汝今何故言。我等今日极快乐。有福德无衰恼。时十七群比丘即广说上事。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘诃责。云何名比丘非时饮食。种种因缘诃已。向佛广说。佛以是事集比丘僧。知而故问十七群比丘。汝实作是事不。答言实作世尊。佛种种因缘诃责十七群比丘言。云何名比丘。非时饮食。种种因缘诃已语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘非时啖食。波逸提。非时者。过日中至地未了。是中间名非时。啖者。五种佉陀尼。食者五蒲阇尼若五似食。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘非时啖根食。波逸提。若啖茎叶磨果。皆波逸提。若比丘非时食饭糗糒鱼肉。皆波逸提。若比丘非时食五似食糜粟穬麦莠子迦师。皆波逸提。若比丘非时中非时想食。波逸提。非时中时想食。波逸提。非时中疑食。波逸提。若时中非时想食突吉罗。时中疑食突吉罗。时中时想食不犯(三十七竟)

佛在舍卫国。尔时有比丘。名曰上胜。受乞食法。是人日日乞二分食。一分即啖。一分持还。至自房舍着石上晒。明日洗手从净人受啖。尔时佛共阿难游行诸比丘房。到是上胜比丘房所。见石上晒饭。佛知故问阿难是石上阿谁晒饭。阿难答言。世尊。是房中有比丘。名上胜。受乞食法。乞二分食。一分即啖。一分持来着石上晒。明日洗手从净人受啖。是故晒饭。佛问阿难。诸比丘啖举宿残食耶。答言实啖。佛以是事集比丘僧。知而故问上胜比丘。汝实作是事不。答言。实作世尊。佛以种种因缘诃责。云何名比丘。啖举宿残食。种种因缘诃已语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘举残宿佉陀尼蒲阇尼啖者。波逸提。举残宿食者。若大比丘。今日手所受食。举至明日。名举残宿食。食者。五种佉陀尼五种蒲阇尼五似食。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘啖举宿根食波逸提。若啖茎叶磨果。皆波逸提。若食举宿饭糗糒鱼肉。皆波逸提。若食举宿麋粟穬麦莠子迦师饭。皆波逸提。若比丘树生净地。垂在不净地。若果堕不净地。若比丘内宿啖是果者突吉罗。若树生不净地。垂在净地。若果堕净地。若比丘以草竹叶以瓦取是果。举宿明日啖者波逸提。若比丘树生净不净地。若果堕竹上。若堕维多罗枝上摩留多枝上。取果内宿啖者。突吉罗(净地法佛在时已舍三十八竟)

佛在舍卫国。尔时长老摩诃迦罗。受一切粪扫物法。是人持粪扫僧伽梨郁多罗僧安陀卫粪扫钵粪扫杖粪扫革屣粪扫食。云何持粪扫僧伽梨。若巷中若死人处粪扫中。有段弊衣。取持水上净浣治。作僧伽梨郁多罗僧安陀卫亦如是。粪扫钵者。若巷中死人处粪扫中。有弃弊器。取持水上洗治受用。粪扫杖者。若巷中死人处粪扫中弃杖。取持水上洗治畜用。粪扫革屣者。若巷中死人处粪扫中。有弃革屣。取持水上净洗缝治畜用。粪扫食者。若巷中死人处粪扫中。有弃罗卜叶胡荽叶罗勒叶若臭糒。自手取持至水上净洗治已便食。是名粪扫食。是长老受死人处住法。乐住死人处。若国中有疫病死时。便不入城求食。但啖死人所弃饮食。若无疫病死时。则入城求食。是比丘身体肥大多脂血肉强壮多力。是比丘一时入城求食。守门人见作是念言。是比丘有疫病死时不来入城求食。无疫病时便来入城。是比丘身体肥大多脂血肉强壮多力。此人必啖人肉。一人语二人。二人语三人。如是展转恶名流布满舍卫城言。沙门释子啖人肉。是中有比丘。少欲知足行头陀闻是事心不喜。向佛广说。佛以是事集比丘僧。以种种因缘诃责。云何名比丘。不从他受饮食着口中。佛但诃责而未结戒。是长老摩诃迦罗。得世俗禅定。受死人处住法。乐住死人处。尔时舍卫国有一居士。亲里死送向死人住处。诸居士见是比丘言。此是啖人比丘。我等今日送是死人。亲里去后必当为比丘所啖。弃死人已。诸居士屏处立看。是比丘作是念。是中所有菜叶干糒。莫令乌鸟来污。即起往守诸居士言。是比丘起已去已近已取已食已。诸居士定谓沙门释子啖人肉。一人语二人。二人语三人。如是展转恶名流布满舍卫城。沙门释子实啖人肉。是中有比丘。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集比丘僧。种种因缘诃责。云何名比丘。不受食着口中。种种因缘诃已。语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘不受食着口中波逸提。不受食者。不从男女黄门二根人受。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘不受饮食着口中。波逸提。随尔所著口中。口口波逸提

尔时诸比丘闻佛结戒。欲洗口须水杨枝。求净人受。不时得辛苦。诸比丘不知云何。以是事白佛。佛以是事集比丘僧。赞戒赞持戒。赞戒赞持戒已语诸比丘。从今是戒应如是说。若比丘不受食着口中波逸提。除水及杨枝。是中犯者。有五种。若是非时不与不受不作净不净。非时者。过日中后至地未了。是名非时不与者。若男女黄门二根人不与。是名不与。不受者。不从他受。若男女黄门二根人。是故名不受。不作净者。不作火净刀净爪净鹦鹉嘴净。是名不作净。不净者。是饮食不净。若与不净食和合。若比丘非时不与不受不作净不净。啖此食者五种罪。若时不与不受不作净不净。啖此食者四罪。若时与不受不作净不净。啖此食者三罪。若时与受不作净不净。啖此食者二罪。若时与受作净不净。啖此食者一罪。若时与受作净净。啖此食者不犯不净食中。啖举残宿不净食波逸提。人肉不净偷兰遮。大比丘手触不净啖者。突吉罗(三十九竟)

佛在迦维罗卫国。尔时摩诃男释。往诣佛所头面礼佛足一面坐。佛以种种因缘示教利喜。示教利喜已默然。摩诃男闻佛种种因缘示教利喜已。从坐起合掌白佛言。愿佛及僧受我明日请。佛默然受。知佛受已。礼佛足右绕而去。还自舍通夜办种种多美饮食。煮药草乳汁。办已早起敷坐处。遣使白佛。食具已办唯圣知时。佛及众僧往入其舍就座而坐。摩诃男见佛坐已。自手行水。自手与粳米饭香药乳汁。尔时六群比丘。以药乳汁浇粳米饭。盛满钵置在前更望得。摩诃男作是念。谁食不食谁少不少。作是念已便看。见六群比丘盛满钵香药乳汁浇饭在前不食。问言何故不食。答言。有生乳不。摩诃男言。是药草乳汁香美并食。有生乳者当更相与。又问有酪不。有熟酥有生酥有油鱼肉脯不。答言。是乳香美用好药草煮并可用食。有酪熟酥生酥油鱼肉脯者当与。诸六群比丘嗔。语摩诃男言汝欺佛诳佛及僧。汝不能办好饮食者。何以请佛及僧。若余人请者。当随意与多美饮食。如此熟乳何处不得。是摩诃男性善不嗔不惊。诸行食人嫉妒嗔恚。沙门释子自言。善好有德。是释摩诃男深敬佛及僧。云何现前诃骂。佛见诸比丘作是恶事为诸白衣所诃。见已默然。尔时摩诃男以多美饮食与众僧。自恣饱满。见举钵已。自手行水。取小床坐佛前。欲听说法。佛以种种因缘说法示教利喜。示教利喜已从坐起去。尔时佛食后。以是事集比丘僧。以种种因缘诃责六群比丘。云何名比丘。是摩诃男深敬佛法众僧。现前以粗语诃骂。种种因缘诃已语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘不病。白衣家中有如是美食。乳酪生酥熟酥油鱼肉脯。自为索如是食者波逸提。家者。白衣舍名家。美饮食者。乳酪生酥熟酥油鱼肉脯。病者。风发冷发热发。若啖此食者病差。除是因缘。名曰不病。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘不病。自为索乳。得者波逸提。不得突吉罗。不病自为索酪生酥熟酥油。鱼肉脯。得者波逸提。不得突吉罗。不病自为索饭羹菜。得者突吉罗。不得者亦突吉罗。若索酪汁酪浆酪滓。得者突吉罗。不得者亦突吉罗。不犯者。若病。若亲里。若先请。若不索自与不犯(四十竟第二诵竟)

十诵律卷第十三十诵律卷第十四(第三诵之一)

        后秦北印度三藏弗若多罗译

    九十波逸提之六

佛在拘睒弥国。尔时长老阐那用有虫水。诸比丘语阐那言。莫用有虫水。多少虫死。阐那言。我用水不用虫。诸比丘言。汝知水有虫不。答言知。若知者何以用。答言。我自用水不用虫。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘诃责。云何名比丘。于众生中无怜愍心。种种因缘诃已。向佛广说。佛以是事集比丘僧。知而故问阐那。汝实作是事不。答言。实作世尊佛以种种因缘诃责阐那。云何名比丘。知水有虫故自取用。于众生中无怜愍心。种种因缘诃已语诸比丘。以十利故与诸比丘结戒。从今是戒应如是说。若比丘知水有虫。用者波逸提。知者。若自知若从他闻。虫者。若眼所见若漉水囊所得。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘知水有虫用者。随所有虫死。一一波逸提。若比丘用有虫水煮饭羹粥汤染。随尔所虫死。一一波逸提。若用有虫水洗手洗脚洗口面目洗身。随尔所虫死。一一波逸提。若有虫水中有虫想用波逸提。有虫水中无虫想用波逸提。有虫水中疑用波逸提。无虫水中有虫想用突吉罗。无虫水中疑用突吉罗。无虫水中无虫想用不犯(四十一竟)

佛在舍卫国。尔时跋难陀释子。常出入一家。时跋难陀。中前着衣持钵到是家。坐已问讯乐不乐。是居士娶妇未久欲手摩触。妇言。莫尔比丘在此。居士自念。若我住者比丘终不时去。居士语妇。与比丘食。答言尔。居士即出。妇语比丘言。受是饭糗。跋难陀言。日早小住。时到当受。居士意谓比丘已去。入欲近妇。见比丘故在。居士作是念。若我在者比丘不去。语妇言。与比丘食。答言尔。居士即出。妇复持饭糗与语比丘受。跋难陀言。小住日时早。时到当受。居士复念。比丘必去。入已故见。即发嗔言。用是比丘为。我于家中自所欲作不得自在。跋难陀如是恼居士已。便出去。食后向诸比丘说。我今日故恼是居士。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘诃责。云何名比丘。有食家中强坐。种种因缘诃已向佛广说。佛以是事集比丘僧知而故问跋难陀。汝实作是事不。答言。实作世尊。佛以种种因缘诃责。云何名比丘。有食家中强坐。种种因缘诃已语诸比丘。以十利故与诸比丘结戒。从今是戒应如是说。若比丘有食家中强坐者波逸提。有食者。女人名男子食。家者白衣房舍。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘有食家中强坐。波逸提。若起还坐。随得尔所波逸提。不犯者。若断淫欲家。若受斋家。若更有所尊重人在座。若是舍多人出入不犯(四十二竟)

佛在舍卫国。尔时跋难陀释子常出入一家。中前着衣持钵往到其舍。闭门户向。独与一女舍内相近坐。时有一乞食比丘。早起着衣持钵入城乞食。次到是家门前立弹指。时跋难陀释子见乞食比丘。是乞食比丘不见跋难陀。跋难陀语居士妇。与是比丘食。女人作是念。必是跋难陀相识。即取钵与满粳米饭。以好羹浇上。乞食比丘得已持去。女人还入。跋难陀问言。与比丘食耶。答言已与。跋难陀言善。此好比丘。跋难陀。食后还只桓。见乞食比丘作是念。莫使我空作恩分。语彼比丘言。汝今日至某家乞食不。答言到。得好食不。答言得。汝知不。我教与汝。比丘问言。汝尔时在何处。答言在房内乞食比丘以是事向诸比丘说。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘诃责云何名比丘。有食家独与一女人强坐舍内种种因缘诃已。向佛广说。佛以是事集比丘僧。知而故问跋难陀。汝实作是事不。答言。实作世尊。佛以种种因缘诃责。云何名比丘。有食家中独与女人强坐舍内。如是诃已为说本生因缘。佛语诸比丘。过去世时有狗。舍自家至他家乞食。入他家时身在门内尾在门外。时主人居士打不与食。狗诣众官言。是居士我至其家乞食。不与我食反更打我。我不破狗法。众官问言。狗有何法。答言。我在自家随意坐卧。到他家时。身入门内尾在门外。众官言唤居士来。时即将来。问言。汝实打是狗不与食耶。答言实尔。众官言。如是因缘者由来未有。即问狗言。此人应云何治。狗言。与此舍卫城内大居士职位。何以故。答言。我昔在此舍卫城中作大居士。以身口作恶故。受是弊狗身。是人恶甚于我。若令是人有力势者。极当作恶。令入地狱极受苦恼。更以何事治能剧于是。佛言。畜生尚知入他家法有齐限。何况于人而不知法。种种因缘诃已语诸比丘。以十利故与诸比丘结戒从今是戒应如是说。若比丘食家中独与一女人舍内强坐。波逸提。有食家者。女人名男子食。独者。即一比丘一女人。更无第三人。深处坐者。深入乞食比丘所不见处。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘有食家中。独与一女人共坐。三事起一波逸提。一者有食家。二者独共一女人。三者深处坐。若从坐起还坐。更得三事起。一波逸提。随起还坐。随得尔所波逸提。若闭户向。外有作净人者。波逸提。若开户向。外有作净人者。突吉罗。若开户向内有作净人者。不犯(四十三竟)

佛在舍卫国。尔时毗罗然国。有婆罗门王。名阿耆达。以因缘故。向舍卫国宿一居士舍。问是居士言。是舍卫城颇有沙门婆罗门。为大众师多人所敬。皆言好人耶。我当时时往见亲近。或令我心清净欢喜。居士言有。沙门瞿昙出释种中以信出家剃除须发着袈裟。得阿耨多罗三藐三菩提。汝当时时往见亲近。或令汝心清净欢喜。问言。瞿昙沙门今在何处。我当往见。答言。瞿昙沙门在舍卫城只桓精舍。闻已出居士舍。往诣只桓。尔时佛与无量百千万众围绕说法。阿耆达王。遥见佛在林间。端正殊特诸根寂灭。身出无量光焰如真金聚。至小道口下乘步进。前诣佛所问讯毕一面坐。佛见坐已。种种因缘说法示教利喜。示教利喜已默然。时阿耆达。闻佛说法示教利喜已白佛言。世尊。愿佛及僧受我毗罗然国夏安居一时。佛作是念。我先世果报必应当受。作是念已默然受请。是婆罗门知佛默然受已。即从坐起右绕而去。是婆罗门所有因缘事竟。还毗罗然国到自舍。为佛及僧。办夏四月多美饮食。尔时阿耆达王语守门者。我欲夏四月断外人客安乐自娱。外事好丑一不得白时守门者受敕如教佛知安居时到以是因缘集比丘僧告诸比丘今当往诣毗罗然国安居。诸比丘言受教。于是世尊。与五百比丘俱入其国。其国信邪先无精舍。城北有胜叶树林。其树茂好地甚平博。佛与大众止此林中。彼邑狭小人众少信。乞食难得。佛夜过已会僧。会僧已敕诸比丘。汝等当知。此邑狭小人众少信。乞食难得。若欲此安居者住。不者随意。是时舍利弗独往不空道山中。受天王释夫人阿须轮女舍脂请。夏四月安居天食供养。时佛与五百比丘。少一人在毗罗然国安居。彼诸居士及婆罗门。以少信心。供养佛及僧至五六日便止。诸比丘行乞食时。极苦难得。长老大目揵连白佛言。世尊。有树名阎浮因此树故地名阎浮提。欲取此果与大众食。近阎浮树有诃梨勒林。有阿摩勒果。郁单曰有自然粳米。忉利天上有食名修陀皆欲取来以供大众。有甘地味。我以一手擎诸众生。一手反地。令诸比丘取地味啖。愿皆听许。佛语目连。汝虽有大神力。诸比丘恶行报熟。不可移转。皆不听许。是国清凉水草丰茂。时有波罗奈国诸牧马人。随逐水草来到此国。诸牧马人信佛心净。见诸比丘行乞食时极苦难得。语诸长老言。极辛苦耶。答言极苦。皆言。我等知汝极苦乞食难得。今粮食尽正有马麦。汝能啖不。诸比丘言。佛未听我等食马麦。诸比丘不知云何。以是事白佛。佛言。马属看马人。若诸看马人。能以好草碱水食马令肥。此麦自在应受。是马有五百匹。比丘有五百少一人。一马食麦二斗。一斗与比丘。一斗与马。中有良马食麦四斗。二斗与佛。二斗与良马阿难取佛麦分并自分。入聚落中到一女人前赞佛功德。佛有如是念定智慧解脱知见大慈大悲。有一切智三十二相八十种好。身真金色项有圆光。有梵音声。视之无厌。若不出家应作转轮圣王。我与汝等一切皆属。今出家得阿耨多罗三藐三菩提。未度者度。未解者解。未灭者灭。未度生老病死忧悲苦恼者度。以小因缘在此安居。汝持此麦为佛作饭。女即答言。我家多事不能得作。时有一女。闻佛功德即生敬心。如是人者世未曾有。语阿难言。我与作饭及作汝分。更有善德持戒比丘。若有力者亦当与作。女即作饭持与阿难。阿难深心敬佛。如是思惟。佛为王种常御肴膳。今此粗恶何能益身。作是念已。行水授饭。见佛食之悲哽情塞。佛知其意。而欲释之曰。汝能啖此饭不。答言能啖。受而食之滋味非常。实是诸天以味加之。欣悦无量悲塞即除。佛食已讫。阿难行水浇手摄衣钵。白佛言。世尊。今倩一女作饭不肯。傍有一女不倩自作。佛语阿难。不作饭者所应。当得则不能得。若作饭者。应作转轮王第一夫人。自作饭者此福无量。若使不作余福。此德广大乃至解脱。是时世尊宿行未除。一时之中无有知佛及僧于毗罗然国啖马麦者。尔时魔王化作诸比丘。饭食盈长赍向诸国。道路逢者问言。汝从何来。答言。毗罗然国来。诸居士言。佛在彼住有供养不。答言。彼常有大会肴膳盈长。我所持者是彼遣余

尔时世尊宿行已毕。十六大国咸闻世尊与五百比丘毗罗然国三月食马麦。诸国贵人长者居士大富商人。备众供具种种肴膳车驮充满。来迎世尊如亲远至。时有七日未至自恣。佛知故问阿难。自恣余有几日。阿难答言。余有七日。佛告阿难。汝行入城语阿耆达佛言。我于汝国安居已竟。欲游行诸国。诸比丘言。世尊。是婆罗门于佛众僧有何恩德。在此安居穷乏困极。而与之别。佛言。此婆罗门虽无恩德。宾主之法宜应与别。阿难受教与一比丘俱到门下。语守门人可白汝王。阿难在外时守门者思惟念言。阿难名吉。清旦闻之。不白王者。是为不祥时阿耆达。早起沐头着白净衣独坐中堂守门者白。阿难在外。婆罗门相法。名吉则喜。即语令前。谁遮阿难。即入与坐。相问讯已问阿难言。汝何故来。答言。佛遣我来语汝我夏三月住汝国界。安居已竟当游行余国。阿耆达惊言。阿难。瞿昙沙门在毗罗然国夏住耶。阿难言然。婆罗门言。云何得住谁所供给。阿难答言。穷乏困极。佛及众僧三月食马麦。时阿耆达始自觉悟。忆前请佛及僧夏四月住。供具已备。云何令佛及僧三月食马麦。如是恶声流布诸国。当言。阿耆达长夜恶邪。憎嫉佛法。令佛及僧极受苦困。即语阿难。沙门瞿昙可得悔过留不。阿难言不得。时阿耆达惭愧忧恼热闷躄地。时宗亲以水洒面扶起乃醒。亲里喻言。汝莫愁忧。我当与汝忏谢瞿昙强请留住。若不肯住。当赍饮食随后逐送。若有乏时当以供养。时阿耆达即与宗亲共诣佛所忏悔请住。佛自思惟。若我不受者。当吐热血死。佛怜愍故受请七日。时阿耆达作是思惟。此四月供具云何七日能尽。佛自恣竟欲越只国二月游行。越只国人闻佛当来。各设供具。我今日汝明日。如是次第竟于二月。佛自恣已向越只去。阿耆达赍诸供具随送佛去。若乏少时当以供养。诸越只人闻已共作要令。若佛来者。各自当日办具小食时食中后含消浆饮。勿令乏少。莫使异人间错其间。阿耆达知佛宿处。先往施设言我今日供若明日供。诸越只人不听使作。语阿耆达汝长夜恶邪。是佛怨家。故恼佛及僧。今欲悦他意故。便作是语。我今日供。若明日供。汝有何事。尔许时令佛及僧三月食马麦。今求供日。阿耆达闻是语已。惭愧愁忧在一面立。看众僧为少何物我当与之。值时无粥。即作种种粥。酥粥胡麻粥油粥乳粥小豆粥摩沙豆粥麻子粥清粥办已奉佛佛言与众僧众僧不受佛未听我等食八种粥。以是事白佛。佛言。从今日听食八种粥。粥有五事益身。一者除饥。二者除渴。三者下气。四者除脐下冷。五者消宿食。时阿耆达自思惟我夏四月安乐自娱。若复二月逐沙门瞿昙者。以我一人废诸国事。今此供具多不可尽。且当布地令佛及僧以足蹈上。即是受用。即便白佛。愿时受用。佛告阿耆达。不得如汝所言。此是食物应口受用。佛欲遣阿耆达故。说偈咒愿

  一切天祠中　　供养火为最
  婆罗门书中　　萨毗帝为最
  一切诸人中　　帝王尊为最
  一切诸江河　　大海深为最
  一切星宿中　　月明第一最
  一切照明中　　日光为上最
  十方天人中　　佛福田为最

尔时佛与阿耆达咒愿竟游行跋耆向舍卫国。尔时有一裸形外道。随逐佛后是外道身体肥大多肉复有一外道从前逆来。问裸形外道言。汝于此行为何所得。答言。得如是如是食。问何因缘得答言。因是秃居士得。彼即骂言。汝弊罪人。因他得如是饮食。云何作恶不善语。若人随所得好食安隐处而诃骂者。不名为人。若瞿昙沙门闻是语者。必当结戒。不听弟子与外道食。是中有比丘。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集比丘僧。语诸比丘。是诸外道长夜邪见。是法怨贼求觅罪过。若为他人刀杖所打。若得毒药。若有杀者。必当言沙门释子所为。尔时佛但诃责而未结戒。佛次第游行到舍卫国。尔时众人闻佛三月啖马麦。故犹多供养未息。有卖饼女人。为佛及僧办于饮食。时阿难于中知饮食事。诸佛常法。不尽得食不从坐起。何以故。若食不足佛力令足。尔时佛犹坐未起。有二外道出家女人。从阿难乞饼。阿难不忆念。佛语。各与一饼。时有二饼相着故。一人得一。一人得二。得已小远共相问言。汝得几饼。答言得一。汝复得几。答言得二。时得一者言。与我半饼。若不与者我当相辱。答言。各随所得何以与汝。第二更言。与我半饼。若不与者我当相辱。答言。各随所得我不与汝。得一者言阿难必是汝夫。若共私通若非夫非私通者与汝一应与我一。如与汝二应与我二。即便相嗔按头大唤。佛知故问阿难。谁故大唤。答言。外道女。何故大唤。阿难向佛广说是事。时佛食后。以此因缘及先因缘故。集比丘僧语诸比丘。汝等当知。是诸外道长夜邪见。是法怨贼求觅罪过。若为他人刀杖所打。若得毒药。若有杀者。必当言。是沙门释子所作。语诸比丘。以十利故与诸比丘结戒。从今是戒应如是说。若比丘裸形外道外道女。自手与饮食。波逸提。裸形者。名阿耆维道尼揵子道。尼揵外道者老子老弟子。佛言。略说除佛五众。余残出家人。皆名外道。食者。五佉陀尼五蒲阇尼五似食。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘以根食自手与裸形外道外道女。波逸提。茎叶磨果饭糗糒鱼肉糜粟穬麦莠子加师。自手与裸形外道外道女。波逸提。若裸形外道乞果者。应言。我等不遮汝果。若乞水者。亦言不遮汝水。不犯者。若裸形外道外道女病若亲里。若求出家时。(出家时者四月试时)与不犯(四十四竟)

佛在舍卫国。尔时波斯匿王。有小国反起四种兵。象兵马兵车兵步兵。集四兵已。王自往看。铠仗好不。兵人乐不。尔所军众能破敌不。六群比丘共相谓言。今军欲发共看去耶。皆言随意。即往军所一处立看诸国王眼常喜远视王。遥见比丘。遣人问言。何因缘来。六群比丘即答言。我欲见王。王作是念。语大臣言。我于余时难见耶。诸比丘今乃军中见我。佛闻是事必当结戒。不听比丘看军发行。王唤比丘来。即诣王所。王言。何因缘来。答言来欲见王。王言。我余时难得见耶。乃来军中见。佛闻是事必当结戒。不听比丘看军发行。是中有比丘。少欲知足行头陀闻是事心不喜。种种因缘诃责。云何名比丘。看军发行。种种因缘诃已。向佛广说。佛以是事集比丘僧。知而故问六群比丘。汝实作是事不。答言。实作世尊。佛以种种因缘诃责六群比丘。云何名比丘往看军发行。种种因缘诃已语诸比丘。以十利故与诸比丘结戒。从今是戒应如是说。若比丘故往看军发行。波逸提。军发行者。为斗破贼故。集诸兵人。军者。一兵军二三四兵军。一兵者。但象兵但马兵但车兵但步兵。是名一兵。二兵者。象兵马兵。象兵车兵。象兵步兵。马兵车兵。马兵步兵车兵步兵。是名二兵。三兵者。象兵马兵车兵。象兵马兵步兵。马兵车兵步兵。是名三兵。四兵者象兵马兵车兵步兵。是名四兵。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘故往看军发行。得见者波逸提。不见者突吉罗。从下向高。得见者波逸提。不见者突吉罗。从高向下。得见者波逸提。不见者突吉罗。一兵军二兵三兵四兵军亦如是。不犯者。若不故去。若有因缘道由中过。不犯。尔时军去至彼久。未破贼时。波斯匿王有二大臣。一名尼师达多。二名富罗那。先在彼军。有亲里比丘别久忧。念欲见比丘。此二大臣遣使往唤。欲军中见比丘。比丘遣使报言。佛结戒。不得看军。汝莫忧愁。以是因缘我不得往。诸比丘不知云何。以是事白佛。佛以是事集比丘僧。种种因缘赞戒赞持戒。赞戒赞持戒已。语诸比丘。从今是戒应如是说。若比丘故往看军发行。除因缘波逸提。因缘者。若王遣使唤。若王夫人王子大臣大官诸将。如是人遣使唤。往者不犯(四十五竟)

尔时佛听诸比丘。有因缘得至军中。诸比丘亲里多。此今日请。彼明日请。如是展转军中久住。军中有不信者。嫉妒嗔言。我等为聚落官职人民廪食故在此。是比丘弊恶不吉。何因缘复来在此。是比丘久住此者。或作细作。我等或因是比丘故。破失退堕。是中有比丘。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集比丘僧。种种因缘诃责诸比丘。云何名比丘。往军中宿过二夜种种因缘诃已语诸比丘。以十利故与诸比丘结戒。从今是戒应如是说。若比丘有因缘往军中宿过二夜波逸提。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘往军中。过二夜宿波逸提。若在军中至三夜地了时。波逸提(四十六竟)

佛在王舍城。尔时六群比丘二夜军中宿。时往看军阵看着器仗牙旗幢幡两阵合战。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘诃责。云何名比丘。军中二夜宿。时往看军阵。看着器仗牙旗幢幡两阵合战。种种因缘诃已向佛广说。佛以是事集比丘僧。知而故问六群比丘。汝实作是事不。答言。实作世尊。佛以种种因缘诃责。云何名比丘。军中二夜宿时往看军阵。看着器仗牙旗幡幢两阵合战。种种因缘诃已语诸比丘。以十利故与诸比丘结戒。从今是戒应如是说。若比丘二夜军中宿。时往看军阵。看着器仗牙旗幢幡两阵合战。波逸提。着器仗者。庄严欲斗。军者。象军马军车军步军。阵者。作阵如弓。有如半月。有阵如日。有如锋头。两阵对时看者。波逸提。波逸提者煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘往看军阵。着器仗时得见者波逸提。不见者突吉罗。若从下向高得见者波逸提。不见者突吉罗。若从高向下得见者波逸提。不见者突吉罗。一军二军三军四军皆如是。若看幢幡两阵斗时亦尔不犯者。不故往。有因缘。道由中见。不犯(四十七竟)

佛在王舍城。尔时六群比丘。与十七群比丘共斗诤。嗔恚发不喜心。打十七群比丘。十七群比丘啼泣。诸比丘问。何故啼耶。答言。六群比丘打我。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘诃责。云何名比丘。共余比丘斗诤。嗔恚发不喜心。打余比丘。种种因缘诃已向佛广说。佛以是事集比丘僧。知而故问六群比丘。汝实作是事不。答言。实作世尊。佛以种种因缘诃责。云何名比丘。共余比丘斗诤。嗔恚发不喜心。打余比丘。种种因缘诃已语诸比丘。以十利故与诸比丘结戒。从今是戒应如是说。若比丘嗔恚发不喜心。打余比丘。波逸提。打者。有二种。若手若脚。波逸提者。煮烧覆障。若不悔过能障碍道。是中犯者若以手打波逸提。若以脚打波逸提。若以余身分打突吉罗。若为咒故。若食噎故。打拍不犯(四十八竟)

佛在王舍城。尔时六群比丘。与十七群比丘共斗诤。嗔恚发不喜心。六群比丘举掌向十七群比丘。十七群比丘作是念。六群比丘壮健多力。若掌着我我等便死。即便啼唤。诸比丘问。何故啼唤。答言。六群比丘壮健多力。举掌向我。怖故啼唤。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘诃责言。云何名比丘。共比丘斗诤。嗔恚发不喜心。举掌向他种种因缘诃已向佛广说。佛以是事集比丘僧。知而故问六群比丘。汝实作是事不。答言。实作世尊。佛以种种因缘诃责。云何名比丘。共余比丘斗诤。嗔恚发不喜心。举掌向他。种种因缘诃已语诸比丘。以十利故与比丘结戒从今是戒应如是说。若比丘嗔恚发不喜心。举掌向他波逸提。举掌者。有二种。手掌脚掌。波逸提者煮烧覆障。若不悔过能障碍道。是中犯者。若比丘举手掌波逸提。若举脚掌波逸提。除手脚。举余身分向他。突吉罗。不犯者。若比丘举掌遮恶兽。若遮恶人不犯(四十九竟)

佛在舍卫国。尔时跋难陀释子。有兄比丘。名曰难徒。跋难陀有弟子。名达摩亦善持戒。是弟子不随师行。难徒作是念。此是我弟弟子。不随我行。又不随我弟行。应当治之令随我等。尔时难徒以女人着一房中。往语达摩言。汝到某处来。达摩言。往何所作。答言但来。达摩作是念。此是我师兄。云何不随语即便随往。难徒知立此处得见女人。即教此中立待我。难徒即往女人所。除却三疮抱捺余身和合相触。作如是已语达摩言。汝见不。答言见。汝莫语余人。答言。我不能覆藏。必以是事白佛。当向比丘比丘尼说。难徒言。我亦见汝和上作如是事。复见剧是。尚不语人。汝何以语人。答言。汝意自欲不语。我不能覆藏。必当白佛。向比丘比丘尼说。时达摩即以是事向诸比丘说。是中有比丘。少欲知足行头陀。闻是事心不喜种种因缘诃责。云何名比丘。知比丘有重罪。故覆藏不说。种种因缘诃已。向佛广说。佛以是事集比丘僧知而故问难徒。汝实作是事不。答言。实作世尊。佛以种种因缘诃责。云何名比丘。知比丘有重罪故覆藏。种种因缘诃已。语诸比丘。以十利故与比丘结戒从今是戒应如是说。若比丘知他比丘有重罪覆藏乃至一夜波逸提。知者。若自知若从他闻若彼比丘自说。重罪者。波罗夷僧伽婆尸沙。一夜者。从日没至地未了时。波逸提者煮烧覆障。若不悔过能障碍道是中犯者。若比丘地了时。见余比丘犯波罗夷。是比丘波罗夷中生波罗夷想。竟日覆藏至地了时波逸提。若是比丘僧与作不见摈不作摈恶邪不除摈狂心乱心病坏心不犯。若僧解摈若苦痛止。是时覆藏他罪。至地了时波逸提地了已。日出时。日出已中前日中日昳。晡时日没日没已。初夜初分。初夜中分。初夜后分。中夜初分。中夜中分。中夜后分。后夜初分。后夜中分。后夜后分。覆藏他罪。至地了时波逸提。有比丘见余比丘地了时犯僧伽婆尸沙。僧伽婆尸沙中生僧伽婆尸沙想。竟日覆藏至地了时波逸提。若是比丘僧与作不见摈不作摈恶邪不除摈狂心乱心病坏心不犯。若僧解摈若苦痛止。是时覆藏他罪。至地了时波逸提。地了已日出时日出已。中前日中日昳。晡时日没时日没已。初夜初分初夜中分初夜后分中夜初分中夜中分中夜后分。后夜初分后夜中分后夜后分。覆藏他罪至地了时波逸提。有比丘见余比丘地了时犯波逸提波罗提提舍尼突吉罗。是比丘突吉罗中生突吉罗想。竟日覆藏至地了时突吉罗。是比丘若僧与作不见摈不作摈恶邪不除摈狂心乱心病坏心不犯。若僧解摈若苦痛止。覆藏他罪至地了时突吉罗。地了已日出时日出已。中前日中日昳晡时日没时日没已。初夜初分初夜中分初夜后分。中夜初分中夜中分中夜后分。后夜初分后夜中分后夜后分。覆藏他罪至地了时突吉罗。若比丘见余比丘地了时犯波罗夷。谓僧伽婆尸沙。谓波逸提谓波逸提提舍尼。谓突吉罗。是比丘。波罗夷中生突吉罗想。竟日覆藏至地了时波逸提。若是比丘僧与作不见摈不作摈恶邪不除摈狂心乱心病坏心不犯。若僧解摈若苦痛止。覆藏他罪至地了时波逸提。日出时乃至后夜后分。覆藏他罪至地了时皆波逸提。又比丘见余比丘地了时犯僧伽婆尸沙。是僧伽婆尸沙中。谓波逸提波罗提提舍尼突吉罗波罗夷。是比丘于僧伽婆尸沙中。生波罗夷想若突吉罗想。竟日覆藏至地了时。皆波逸提。若僧与作不见摈不作摈恶邪不除摈狂心乱心病坏心不犯。若僧解摈若苦痛止。覆藏他罪至地了时波逸提。日出时乃至后夜后分。覆藏他罪至地了时波逸提。又比丘见余比丘地了时犯波逸提波罗提提舍尼突吉罗。是比丘突吉罗中。谓波罗夷。谓僧伽婆尸沙波逸提波罗提提舍尼。是比丘突吉罗中。生波罗提提舍尼想若波罗夷想。竟日覆藏至地了时。皆突吉罗。若僧与作不见摈不作摈恶邪不除摈狂心乱心病坏心不犯。若僧解摈若苦痛止。覆藏他罪至地了时。突吉罗。从日出时乃至后夜后分。覆藏他罪至地了时突吉罗

若比丘见余比丘地了时犯波罗夷是比丘于波罗夷中生疑。是波罗夷非波罗夷。后时断疑。于波罗夷中生波罗夷想。竟日覆藏至地了时波逸提。若是比丘僧与作不见摈不作摈恶邪不除摈若狂心乱心病坏心不犯

若僧解摈。若苦痛止。覆藏他罪至地了时波逸提。日出时乃至后夜后分。覆藏他罪至地了时波逸提。又比丘见余比丘地了时犯僧伽婆尸沙生疑。是僧伽婆尸沙非僧伽婆尸沙。后时断疑。于僧伽婆尸沙中生僧伽婆尸沙想。竟日覆藏至地了时波逸提。若是比丘僧与作不见摈不作摈恶邪不除摈若狂心乱心病坏心不犯。若僧解摈若苦痛止。覆藏他罪至地了时波逸提。日出时乃至后夜后分覆藏他罪至地了时波逸提。又比丘见余比丘地了时犯波逸提波罗提提舍尼突吉罗。是比丘于突吉罗中生疑。是突吉罗非突吉罗。后时断疑。于突吉罗中生突吉罗想。竟日覆藏至地了时突吉罗。若是比丘僧与作不见摈不作摈恶邪不除摈若狂心乱心病坏心不犯。若僧解摈若苦痛止。覆藏他罪至地了时突吉罗。日出时乃至后夜后分。覆藏他罪至地了时突吉罗。又比丘见余比丘地了时犯波罗夷生疑。为波罗夷为僧伽婆尸沙。为波罗夷为波逸提。为波罗夷为波罗提提舍尼。为波罗夷为突吉罗。是比丘后时断疑于波罗夷中生突吉罗想。竟日覆藏至地了时波逸提。若是比丘僧与作不见摈不作摈恶邪不除摈若狂心乱心病坏心不犯。若僧解摈若苦痛止。竟日覆藏他罪至地了时波逸提。从日出时乃至后夜后分。覆藏他罪至地了时波逸提。又比丘见余比丘地了时犯僧伽婆尸沙。生疑。为僧伽婆尸沙为波逸提。为僧伽婆尸沙为波罗提提舍尼。为僧伽婆尸沙为突吉罗。为僧伽婆尸沙为波罗夷。是比丘后时断疑。于僧伽婆尸沙中生波罗夷想。竟日覆藏至地了时波逸提。若是比丘僧与作不见摈不作摈恶邪不除摈若狂心乱心病坏心不犯。若僧解摈若苦痛止。覆藏他罪至地了时波逸提。日出时乃至后夜后分。覆藏他罪至地了时波逸提。又比丘见余比丘地了时犯波逸提波罗提提舍尼突吉罗。是比丘突吉罗中生疑。为突吉罗为波罗夷。为突吉罗为僧伽婆尸沙。为突吉罗为波逸提。为突吉罗为波罗提提舍尼。是比丘后时断疑。于突吉罗中生波罗提提舍尼想若波罗夷想。竟日覆藏至地了时。皆突吉罗。若是比丘僧与作不见摈不作摈恶邪不除摈若狂心乱心病坏心不犯。若僧解摈若苦痛止。覆藏他罪至地了时突吉罗。日出时乃至后夜后分覆藏他罪至地了时。突吉罗(见他罪向一人说便止若疑不须说五十竟)

十诵律卷第十四十诵律卷第十五(第三诵之二)

        后秦北印度三藏弗若多罗译

    九十波逸提之七

佛在舍卫国。尔时跋难陀释子作是念。是达摩弟子毁辱我兄。应当报之。尔时唤言。共到某聚落去问何以故。答言但来。达摩念言。是我和上云何不随语。从只桓出。尔时只桓门间有诸比丘经行。诸比丘语达摩言。汝今日必当得多美饮食。何以故。随逐多知识比丘故。达摩言。多以不多今日当知。是跋难陀释子随所入家皆请与食。跋难陀言。小住日早时到当取。达摩作是念。我和上今日必当受好请处。是故处处不受食。第二第三家亦请与食。跋难陀言。小住日早时到当取。尔时跋难陀出白衣舍。看日已中。设入聚落乞食者不及时。若还只桓亦复不及时。即语达摩言。汝还去。我与汝共坐共语不乐。我独坐独语乐。达摩复自看日已中。设入聚落乞食不及时。若还只桓复不及时。达摩又念。今当何去。即还只桓。诸比丘问言。汝今日得多美好食耶。答言。莫共我语今日断食。问何以故。即以是事向诸比丘广说。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘诃责。云何名比丘。故断比丘食。种种因缘诃已向佛广说。佛以是事集比丘僧。知而故问跋难陀。汝实作是事不。答言。实作世尊。佛以种种因缘诃责跋难陀释子。云何名比丘。故断比丘食。种种因缘诃已语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘语余比丘。来共到诸家。到诸家已是比丘不教与食。便作是言。汝去。与汝共坐共语不乐。我独坐独语乐。欲恼彼故以是因缘无异波逸提。家者白衣家。驱出者。自驱若教人驱。波逸提者煮烧覆障。若不悔过能障碍道。是中犯者。若比丘语余比丘言。汝来。共到他家。若未入城门令还者突吉罗。若入城门令还者。亦突吉罗。若未入白衣家外门令还者突吉罗。若入外门令还者亦突吉罗。入中门亦如是。若未入内门令还者突吉罗。若入内门未至闻处令还者突吉罗。若至闻处令还者波逸提(五十一竟)

佛在憍萨罗国。与大比丘众游行。时有五百估客众随逐佛行。作是念。我等随佛行。当得丰乐安隐。佛游行到一林中欲宿。时估客各随向火。拾薪草共燃火向。诸比丘亦随所知识。共拾草木用燃火向。有一异摩诃卢比丘。拽空中木持着火中。木中有毒蛇得热便出比丘见之惊怖大唤。估客惊怪谓有贼来。共相谓言。各自捉槊刀盾弓箭聚集财物。诸估客即起捉诸器仗聚集财物。共相问言。贼在何处。比丘言。无贼但有毒蛇。诸估客言。若知是蛇何故大唤。以大唤故。诸估客众或有相杀。我等几相伤害。佛闻是事及诸估客诃责比丘。过是夜已佛以是因缘集比丘僧。以种种因缘诃责摩诃卢比丘。云何名比丘。露地燃火。种种因缘诃已。语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘无病露地燃火向。若燃草木牛屎木皮粪扫。若自燃若使人燃。波逸提。病者。冷盛热盛风盛若向火得差。是名病除。是因缘。名不病。露地者。无壁覆障。无席覆。无衣覆。如是等无覆处。名露地。自著者自手着。使著者教他着。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘以草着草火中波逸提。若以薪牛屎木皮粪扫。着草火中波逸提。若比丘以木着木火中波逸提。若以牛屎木皮粪扫草着木火中波逸提。若比丘以牛屎着牛屎火中波逸提。若以木皮粪扫草木。着牛屎火中波逸提。若比丘以木皮着木皮火中波逸提。若以粪扫草木牛屎。着木皮火中波逸提。若比丘以粪扫着粪扫火中波逸提。若以草木牛屎木皮。着粪扫火中波逸提。教着亦如是。乃至露地以火樵着火中突吉罗。不犯者。若病若煮饭若煮羹。煮粥煮肉煮汤煮染。熏钵治杖治钩不犯(五十二竟)

佛在舍卫国。尔时诸比丘欲羯磨摈跋难陀。时六群比丘在众中遮不得成羯磨。异时六群比丘余处行去。诸比丘言。我等今当与跋难陀作摈羯磨。有比丘言。六群比丘当来更遮。诸比丘言。六群比丘今远去至余聚落。多事未还。有比丘佐助六群比丘。时住不去。诸六群比丘懈怠懒惰。说戒自恣僧羯磨时不来。但与欲清净。诸比丘念。莫令佐助六群比丘来众中作遮。但取欲来。即打揵椎集比丘僧遣人到彼比丘所索欲来。彼问言。欲作何事。答言有僧事。彼比丘即与欲尔时僧一心和合。与跋难陀作摈羯磨。后日大唱言。僧已与跋难陀作摈羯磨。彼比丘言。是羯磨不应如是作。不可我意故。诸比丘言。汝已与欲。彼比丘言。我不知僧与跋难陀释子作摈羯磨故。若知者不与欲。自言。我不是有过不应与欲。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘诃责。云何名比丘。如法僧事中与欲。后悔种种因缘诃已。向佛广说。佛以是事集比丘僧。知而故问是比丘。汝实作是事不。答言。实作世尊。佛以种种因缘诃责。云何名比丘。与欲已后悔。种种因缘诃已语诸比丘。以十利故与诸比丘结戒。从今是戒应如是说。若比丘如法僧事与欲竟后悔言。我不应与波逸提。僧事者。所有僧事。若白羯磨。白二羯磨。白四羯磨。若布萨自恣。若羯磨十四人。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘如法僧事与欲竟。后悔言。我不应与波逸提若比丘僧如法事。若白羯磨。白二羯磨。白四羯磨。布萨自恣。十四人羯磨。与欲竟后悔言。我不应与欲。波逸提。随心悔言。一一波逸提(五十三竟)

佛在阿罗毗国。尔时诸贤者。随斋日至寺中受斋法。通夜燃灯加趺而坐。为听法故。时诸上座比丘初夜大坐。至中夜时各各入房。诸年少比丘及诸沙弥。在说法堂中宿不一心卧鼾眠[穴/(爿*臬)]语大唤掉臂诸贤者言看是尊众不一心眠卧。是中有比丘。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集比丘僧。知而故问阿罗毗比丘。汝实作是事不。答言。实作世尊。佛以种种因缘诃责。云何名比丘。共未受具戒人宿。佛尔时但诃责未结此戒。佛在舍卫国。尔时沙弥罗睺罗。诸比丘驱出房不共宿。罗睺罗即去到边小房中住。时有客比丘来。作是念。大房中必上座满。我当向边小房中。作是念已即向边小房中。到已謦欬打门问言。此中有谁。答言。我是罗睺罗。比丘言出去。即便出去。到第二房中。复更驱去。到第三房中。复更驱去。罗睺罗作是念。我所至房舍皆驱出者。今当往至佛厕屋中。即往厕屋中枕厕板卧。板下有蛇。先出不在。后夜大风雨堕。蛇得苦恼即还向窟。时佛忆罗睺罗卧。若我不觉者。正尔当为蛇所害。佛即入三昧。自房内没于厕边住。即以神力作龙声。罗睺罗便觉。佛知而故问。汝是谁耶。答言。我罗睺罗。何故在此。答言卧。问何故此中卧。答言。余无宿处。佛言。汝出。即便出来。佛以右手摩罗睺罗头。说是偈言

  汝不为贫穷　　亦不失富贵
  但为求道故　　出家应忍苦

说是偈已。佛即捉臂将至自房。时佛独坐床上大座。佛竟夜入禅。用圣默然到地了已。以是因缘集比丘僧。语诸比丘。是沙弥可怜愍。无父母若不慈愍。何缘得活。若值恶兽得大苦恼。是亲里必嗔言。诸沙门释子但能畜沙弥。而不能守护。佛种种因缘诃已。语诸比丘。从今为二事利故。听未受大戒人二夜共宿。一者为怜愍沙弥故。二者为有白衣来至寺中应与房宿故。以十利故与比丘结戒。从今是戒应如是说。若比丘与未受大戒人共舍宿。过二夜波逸提。未受大戒人者。除比丘比丘尼。余一切人是。舍有四种。一者一切覆一切障。二者一切障不覆。三者一切覆半障。四者一切覆少障。波逸提者煮烧覆障。若不悔过能障碍道。是中犯者。若比丘与未受大戒人。四种舍中宿。过二夜波逸提。起已还卧。随起还卧。一一波逸提。若通夜坐不犯。时有比丘病。使沙弥供给看病。是比丘至第三夜驱沙弥去。是病比丘无人看故垂死。诸比丘以是事白佛。佛以是事集比丘僧。语诸比丘。应唤沙弥在病比丘所立莫令卧。有病比丘沙弥小久立倒地便卧。佛言。病比丘不犯。是中有不病比丘不应卧(五十四竟)

佛在舍卫国。尔时阿利吒比丘。生恶邪见言。我如是知佛法义。作障道法不能障道。诸比丘闻是事。向佛广说。佛以是事集比丘僧。语诸比丘。汝当约敕阿利吒比丘言。汝莫作是语。我知佛法义。作障道法不能障道。莫谤佛。谤佛者不善。佛不作是语。佛种种因缘。说障道法能障道。汝舍是恶邪见。当三教令舍是事。诸比丘言。如是世尊。即往约敕阿利吒比丘言。汝莫作是语。我知佛法义。作障道法不能障道。汝莫谤佛。谤佛者不善。佛不作是语。佛种种因缘说障道法能障道。汝舍是恶邪见。作是教令舍此事。第二第三亦如是教。诸比丘再三教已。不能令舍。即便起去。往诣佛所头面礼足一面坐。白佛言。世尊。我等教阿利吒比丘。令舍是恶邪见。不能令舍。我等便即起来。佛言。汝等应作羯磨摈。阿利吒比丘不舍恶邪见故。若有余比丘。不舍恶邪见者亦如是治。作不舍恶邪见摈羯磨法者。一心和合僧中。一比丘僧中唱言。大德僧听。是阿利吒比丘生如是恶邪见言。我知佛法义。作障道法不能障道。僧已约敕令舍恶邪见。而不肯舍。若僧时到僧忍听。与阿利吒比丘不舍恶邪见羯磨。随汝几许时不舍恶邪见。僧随尔所时与作摈羯磨。是名白。如是白四羯磨。僧与阿利吒比丘不舍恶邪见摈羯磨竟。僧忍默然故是事如是持。语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘作是言。我如是知佛法义。作障道法不能障道。诸比丘应如是教彼比丘。汝莫作是言。我如是知佛法义。作障道法不能障道。汝莫谤佛谤佛者不善。佛不作是语。佛种种因缘说障道法能障道。汝当舍是恶邪见。诸比丘如是教时。坚持不舍。诸比丘当再三教令舍此事。再三教时舍者善不舍者波逸提。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。是比丘初应软语约敕。若软语约敕舍者。令作突吉罗悔过。若不舍者。应作白四羯磨约敕。约敕法者。一心和合僧中。一比丘唱言。大德僧听。是阿利吒比丘生恶邪见。作如是言。我知佛法义。作障道法不能障道。若僧时到僧忍听。僧约敕阿利吒比丘。令舍恶邪见。是名白。如是白四羯磨。僧约敕阿利吒比丘舍恶邪见竟。僧忍默然故是事如是持。是中佛说是比丘应第二第三约敕令舍是事者。是名约敕。是名为教。是名约敕教。若软语约敕不舍者未犯。若初说说未竟说竟。第二说说未竟说竟。第三说说未竟。非法别众。非法和合众。似法别众。似法和合众。如法别众。异法异律异佛教。约敕不舍者未犯。若如法如律如毗尼如佛教。三约敕竟不舍者。波逸提(五十五竟)

佛在王舍城。尔时六群比丘。知是人作如是语。不如法除罪。不舍恶邪见。如法摈出。便与共事共住共同室宿。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘诃责六群比丘。云何名比丘。知是人作如是语不如法除罪不舍恶邪见如法摈出。便与共事共住共同室宿。种种因缘诃已向佛广说。佛以是事集比丘僧。知而故间六群比丘。汝实作是事不。答言。实作世尊。佛以种种因缘诃责六群比丘。云何名比丘。知是人作如是语不如法悔不舍恶邪见如法摈出。便与共事共住共同室宿。种种因缘诃已语诸比丘以十利故与比丘结戒。从今是戒应如是说。若比丘知比丘作如是语不如法悔不舍恶邪见如法摈出。便与共事共住共同室宿波逸提。知者。若自知若从他闻若彼自说。如是语者。如所见说。不如法悔者。未折伏心未破憍慢不舍恶邪见者。是恶邪见未离心故。如法摈出者。如佛法僧中摈出。共事者。有二种事。法事财物事。共住者。共是人住。作白羯磨白二白四羯磨布萨自恣。若作十四人羯磨共舍宿者。舍有四种。一者一切覆一切障。二者一切障不覆。三者一切覆半障。四者一切覆少障。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘共摈人作法事。若教经法。若偈说。偈偈波逸提。若经说。章章波逸提。若别句说句句波逸提。若从摈人问诵受学亦如是。共财事者。若比丘与摈人钵波逸提。与衣户钩时药夜分药七日药尽形药。皆波逸提。若从摈人取衣钵波逸提。乃至取尽形药。皆波逸提。若四种舍中共宿卧者波逸提。起已还卧随起还卧。一一波逸提。若通夜坐不卧。突吉罗(五十六竟)

佛在舍卫国。尔时有沙弥名摩伽。生如是恶邪见。我知佛法义。作淫欲不能障道。诸比丘闻是事。向佛广说。佛以是事集比丘僧。汝等当约敕摩伽沙弥。汝莫作是语。我知佛法义。作淫欲不能障道。汝莫谤佛。谤佛者不善。佛不作是语。佛种种因缘说淫欲能障道。汝当舍是恶邪见。诸比丘言。如是世尊。即往诃沙弥言。汝莫作是语。我知佛法义。作淫欲不能障道。莫谤佛。谤佛者不善。佛不作是语。佛种种因缘说淫欲能障道。汝舍是恶邪见。诸比丘再三教已。不能令舍。即从坐起来诣佛所。头面礼足白佛言。世尊。我等约敕摩伽沙弥。令舍恶邪见。不能令舍。从坐起来。佛言。汝等应与摩伽沙弥灭摈羯磨。不舍恶邪见故。若更有如是沙弥。亦应如是治。灭摈羯磨法者。一心和合僧中。一比丘唱言。大德僧听。是摩伽沙弥生恶邪见。僧已约敕令舍恶邪见。而不肯舍。若僧时到僧忍听。与摩伽沙弥灭摈羯磨。是名曰。如是白四羯磨。僧与摩伽沙弥灭摈羯磨竟。僧忍默然故。是事如是持

佛在王舍城。尔时六群比丘。知是沙弥灭摈已。便畜经恤共事共宿是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘诃责。云何名比丘。知是灭摈沙弥。便畜经恤共事共宿。种种因缘诃已。向佛广说。佛以是事集比丘僧。知而故问六群比丘。汝实作是事不。答言实作世尊。佛以种种因缘诃责六群比丘。云何名比丘。知灭摈沙弥。便畜经恤共事共宿。种种因缘诃已。语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若沙弥作是语。我知佛法义。行淫欲不能障道。诸比丘应如是教沙弥言。汝莫作是语。我知佛法义。行淫欲不能障道。莫谤佛。谤佛者不善。佛不作是语。汝当知。佛种种因缘诃责。淫欲能障碍道。汝当舍是恶邪见。若是沙弥诸比丘如是诃时。坚持不舍者。诸比丘应再三教令舍是事。再三教时若舍者善。不舍者诸比丘应如是语沙弥。汝从今不应言佛是我师。亦不应随诸比丘后行。诸余沙弥得共比丘同房二宿。汝今不得。痴人灭去。不应住此。若比丘知是灭摈沙弥。便畜经恤共事共宿波逸提。知者。自知若从他闻若沙弥自说灭摈者如佛法。一心和合僧。作灭摈羯磨。畜者。持作弟子自作和上若阿阇梨。经恤者。若与衣钵户钩时药夜分药七日药终身药。共事者。有二种事。法事财事。共宿者。四种舍内共宿。舍者。若一切覆一切障。一切障不覆。一切覆半障。一切覆少障。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘教灭摈沙弥法。若偈说。偈偈波逸提。若经说。章章波逸提。若别句说。句句波逸提。若从灭摈沙弥受经读诵亦如是。若与灭摈沙弥钵波逸提。若与衣户钩时药夜分药七日药尽形药。皆波逸提。若从灭摈沙弥取衣钵户钩时药夜分七日尽形药。一一皆波逸提。四种舍中共宿波逸提。起已还卧随起还卧。一一波逸提。通夜坐不卧。亦波逸提(五十七竟)

佛在王舍城。尔时世尊。为乞食故。早起着衣持钵。阿难从后入王舍城。时天大雨水突伏藏出多有宝物。尔时世尊乞食。食已还耆阇崛山。佛见是藏多有宝物。佛在前行。阿难随后一寻徐行。阿难自念。我若近佛。口气脚声或恼佛故。佛见是藏语阿难言。毒蛇阿难。作是语已即便直过。不往物所。阿难见已白言。恶毒蛇世尊。作是语已即便直过。不往物所。是山下有一贫人刈麦。闻是二种语。作是念。我未曾见沙门释子毒蛇恶毒蛇。今当往看。即往见藏为水突出。见已欢喜言。沙门释子毒蛇皆是好物。即以车舆衣囊。及日取着家内。以是宝物现富贵相。谓作大舍金肆银肆客作肆铜肆珠肆象群马群牛羊群车乘辇舆人民奴婢。是人先有不相可者。作大舍时妨其生业。是人妒嫉。便白王言。是中先有贫穷贱人。卒见富相。起大堂舍金肆银肆客作肆铜肆珠肆象群马群牛羊群人民奴婢。是人必当得大宝藏。不欲语王。王即唤问。汝得宝藏耶。答言不得。王念。此人不被拷治。云何说实。即敕有司。尽夺财物缚着标头。若得宝藏不语王者。皆如是治。作是教已。即夺财物缚着标头。谁得宝藏不语王者。皆如是治。是人作是言。毒蛇阿难。恶毒蛇世尊。诸人语曰。汝莫作是语。毒蛇阿难。恶毒蛇世尊。汝应作是言。谁得宝藏。不语王者皆有此分。是人一心念佛作是言。毒蛇阿难。恶毒蛇世尊。时人白王是人标头作如是语。毒蛇阿难。恶毒蛇世尊。王即唤问。缚汝标头实作是语毒蛇阿难恶毒蛇世尊不。是人答言。大王。施我无畏者我当说实。答言。与汝无畏。即言。有是宝藏。我先贫贱。山下刈麦。有二比丘共来上山。一在前行。一在后行。前行比丘见是藏时。作是言。毒蛇阿难。语已直去不到物所。亦不取物。后行比丘亦见。复作是言。恶毒蛇世尊。语已直去不到物所。亦不取物。我闻是二语。即作是念。我未曾见沙门释子毒蛇恶毒蛇。寻便往看。见是宝藏为水所突。见已欢喜。即以车舆衣囊取着家中。现富贵相。起大堂舍金肆银肆客作肆铜肆珠肆象马群牛羊群车乘辇舆人民奴婢。今我堕罪便忆是语。此恶毒蛇今于我身能作何等。必啖我命。为是宝故。王尽夺我所有财物。垂当夺命。王作是念。必当是佛与阿难。王言汝去。于命无畏赏汝金钱五百。于是急中。说于佛语及阿难所言故。从死得脱。时是众中大臣大官大声唱言甚希有事。忆佛语故便得脱死。诸比丘闻是事。向佛广说。佛言。取重物得如是罪。及过是罪。皆由取宝物故。佛但诃责而未结戒

佛在维耶离尔时诸童子等。出城诣园林中学射。射门扇孔仰射空中筈筈相拄。尔时跋难陀释子。早起着衣持钵欲入城乞食。诸童子遥见共相谓言。此跋难陀释子喜作恶罪。若见罪闻罪疑罪无惭愧无厌足。我等今当试看。即以宝物价直一千。放着道中舍远遥看。时跋难陀释子到是宝物所。四顾无人取着腋下。诸童子见即往围绕捉言。汝比丘法。他物不与便偷取耶。答言不偷。何故取耶。答言。我谓粪扫物故取。诸童子言。云何宝物作粪扫取。诸童子念。此恶人当将诣众官。作是念已。将诣众官。众官问言。汝实偷不。答言不偷。作粪扫想取。众官又言。无有宝物得作粪扫取者。众官是佛弟子。信乐佛故作是语。比丘云何作偷。诸童子辈必当虚妄。即言汝去。后莫复尔诸露地不与宝莫取。时跋难陀作是恶事已。还向诸比丘广说是事。诸比丘以是事白佛。佛以是事集比丘僧。语诸比丘。如是罪恶及过是罪。皆由取金银宝物故。种种因缘诃已。语诸比丘。以十利故与比丘结戒。从今是戒应如是说若比丘若宝若似宝。自取教取波逸提。宝者。钱金银砗磲玛瑙琉璃真珠。似宝者。铜铁白镴铅锡伪珠自取者自手取。教取者教他取。波逸提者煮烧覆障。若不悔过能障碍道。是中犯者。若比丘捉举他钱金银波逸提。捉举他砗磲玛瑙琉璃真珠波逸提。若比丘有似宝物。作男子庄严具女人庄严具器仗斗具。捉举是物波逸提。捉举伪珠突吉罗

佛在舍卫国。尔时舍卫城节日到。诸白衣办种种饮食出园林中。时毗舍佉鹿子母着五百金钱直庄严身具。出城游戏。还欲入城。是鹿子母信乐佛及众僧。作是念。我今出城不应不见佛而还入城。又我不应着如是庄严具往诣佛所。即脱严具裹着衣中。与一小婢。与已诣佛所。头面礼足一面坐。佛以种种说法示教利喜。示教利喜已默然。鹿子母闻佛说法已。从坐起头面礼足右绕而去。佛善说法。小婢闻佛法味故。即忘庄严具去。佛见是衣裹语阿难。汝看是中。有何物取举。阿难语净人开看还令裹举。佛以是事集比丘僧种种因缘赞戒赞持戒。赞戒赞持戒已语诸比丘。从今是戒应如是说。若比丘若宝若似宝。自捉举教人捉举波逸提。除因缘因缘者。若宝若似宝在僧坊内若住处内。以如是心取。有主来者当还。是事应尔。僧坊内者。物在僧坊壁内篱内堑内障内。住处内者随白衣所请住处。是中云何不犯。若物在僧坊内。若得净人。教取看举。若不得净人。应自取看举。若有来索者。应问。汝物有何相。若说相。是者应还。若不是者。应答。无如是物。若主未来。是比丘有因缘欲行者。是中有旧住善好比丘。应语言。我得他所忘物。汝取看举。有来索者。问相。是者应还。若不是者。应答。无如是物。若过五六岁。无主来索应施四方僧物中用。若后有主来索者。应取四方僧物偿。是物在住处者。若得净人。教取看举。若不得净人。自取看举。若有来索者。应问相。是者应还。不是者。应答无如是物。若是比丘有因缘欲去。是中若有舍主善好男女应语言。我此中得他是物。汝取看举。若有索者。问相。是者应还。不是者应答。无如是物。若过五六岁无来取者。是住处若少坐床大床床板应用作。若后有来索者。应取是床座用还。是事应尔(五十八竟)

佛在王舍城。尔时王舍城人。以龙雹因缘故。作一月会。最后日设会。伎儿作伎。应多与价直。尔时六群比丘共相谓言。往看去来。皆言随意。即便俱往在一面立。遣人语伎人言。是中有所得物。与我等分。若不与者我坏汝会。便即往语。汝所得物与我等分。若不与者当坏汝会。问谁作是语。答言沙门。问何沙门。答言。释子沙门。伎人共相谓言。我等今牵观者心伎乐已调。若有大乐师尚不能坏。何况释子沙门。不与汝分。使即还报。不肯与汝分。闻不与已。即张异衣作幔。异衣作障。异衣作敷。是中着白衣服结加趺坐。辩才庄严赞佛赞法赞僧圣戒。是中有人。从大众中起。试往看之。如是第二第三。会处皆空。来就比丘闻法得味不复还去。是中即空。尔时伎人应大得价。即不复得。共相问言。彼中是谁。答言。沙门释子。即诃责言。是失沙门法。烧沙门法。尽夺我等所得财物。是中有比丘。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集比丘僧。知而故问六群比丘。汝实作是事不。答言。实作世尊。佛以种种因缘诃责六群比丘。云何名比丘。不作净染衣着。佛但诃责而未结戒。佛在舍卫国。尔时诸比丘。从憍萨罗国游行向舍卫国。与估客众俱欲度险道。时有贼来劫估客物。裸形放去。诸比丘亦失衣服。复有余出家人。亦在此中俱失衣服。时贼收衣聚在一处。是贼爱佛法故。语诸比丘。汝等各各还自取衣。余出家人亦有染衣。诸比丘疑惑。谓是他衣。竟不敢取。次第到舍卫国。往诣佛所头面作礼一面坐。诸佛常法。有客比丘来。如是语劳问。可忍不足不。乞食不难。道路不疲耶。佛以是语劳问诸比丘。可忍不足不。乞食不难。道路不疲耶。诸比丘言。忍足乞食不难道路不疲。以是事向佛广说。佛以是事集比丘僧。种种因缘赞戒赞持戒。赞戒赞持戒已。语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘得新衣者。应三种色中。随一一种。坏是衣色。若青若泥若茜。若比丘不以三种坏衣色着新衣者波逸提。新衣者。若比丘得他故衣。初得故。亦名新衣。三种坏色者。若青若泥若茜。若比丘得青衣者。应二种净。若泥若茜。若得泥衣者。亦二种净。若青若茜。若得茜衣者。亦二种净。若青若泥。若得黄衣者。应三种净。青泥茜。得赤衣者。应三种净。青泥茜。得白衣者。亦三种净。青泥茜。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘着不作净衣波逸提。若作敷具波逸提。若作枕波逸提。乃至少时试着突吉罗。若比丘得作净竟衣。以不净段物补。却刺缝一点作净。若直缝各各作净。若比丘得净染衣。却刺缝即是净。不净物补摘不净物。还与僧净染者。如法坏色染也。不净段物者。非如法色。一尺二尺故。言不净段。以此衣坏故。以段补之。皆应却刺。若直缝者。衣主命终。应摘此直缝与僧。乃以此衣与看病人。一点三点以净。此不净色故。净而却刺。是佛所许如法畜用。直缝所以不得者。以是世人衣法故。以却刺异俗(五十九竟)

十诵律卷第十五十诵律卷第十六(第三诵之三)

        后秦北印度三藏弗若多罗译

    九十波逸提之八

佛在王舍城。尔时瓶沙王。有三种池水。第一池中王及夫人洗。第二池中王子大臣洗。第三池中余人民洗。是王得道深心信佛。问诸大臣。上人洗不。答言亦洗。王言。上人应我池中洗。尔时诸比丘。常初夜中夜后夜数数洗。一时瓶沙王欲洗。语守池人。除人令净。我欲往洗。即时除却余人。但比丘在。知池人作是念。王敬比丘。若遣除者王或当嗔。便白王言。已除诸人但比丘在。王言大善。令上人先洗。初夜中夜后夜比丘洗竟便去。知池人白王言。比丘已去。王即往洗。王法洗迟。王洗竟时便即地了。王浴竟作是念。我不应出城不见佛。直还入城即诣佛所。头面礼足却坐一面。佛知而故问。大王。晨朝何来。时王以是事向佛广说。佛尔时为王说种种法示教利喜。示教利喜已默然。王闻佛说法已。从坐起头面礼足右绕而去。王去不久。佛以是事集比丘僧。种种因缘诃责诸比丘。云何名比丘。常初夜中夜后夜数数洗。令灌顶刹利大王自池中不得洗。种种因缘诃已。语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘减半月浴波逸提。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘未满半月浴波逸提。若满半月浴若过不犯

尔时春残一月半夏初一月。是二月半大热时。诸比丘不得浴故。身体垢痒烦闷吐逆。是事白佛。愿世尊。如是大热时。听诸比丘洗浴。佛言听浴。从今是戒应如是说。若比丘减半月浴波逸提。除因缘。因缘者。春残一月半夏初一月。是二月半名大热时。是中犯者。若比丘未至大热时浴波逸提。若大热时浴不犯。佛在王舍城。尔时诸比丘病。以酥油涂身。不得浴故。患痒烦闷吐逆。诸比丘白佛。愿听病因缘故浴。佛言。从今日听病因缘故浴。益利病人如食无异。从今是戒应如是说。若比丘减半月浴波逸提。除因缘。因缘者。春残一月半夏初一月。是二月半大热时。除病时。病者。若冷发风发热发。若洗浴得差。是名病。是中犯者。若比丘无病减半月浴波逸提。若病不犯。佛在王舍城。尔时诸比丘中前着衣持钵入城乞食。时恶风起。吹衣离体尘土坌身。不得浴故烦闷吐逆。是事白佛愿世尊。听风因缘故浴。佛言。从今听风因缘故浴。从今是戒应如是说。若比丘减半月浴除因缘波逸提因缘者。春残一月半夏初一月。是二月半大热时。除病时风时。是中犯者。若无风因缘浴波逸提。若有风因缘浴不犯

佛在王舍城。尔时诸比丘着新染衣入城乞食。值雨衣湿染汗着身生疥疱。不得浴故痒闷吐逆。诸比丘白佛。愿世尊。听雨因缘故浴。佛言。听雨因缘故浴。从今是戒应如是说。若比丘减半月浴除因缘波逸提。因缘者。春残一月半夏初一月。是二月半大热时。除病时风时雨时。是中犯者。若无雨因缘浴波逸提。有雨因缘浴不犯。佛在阿罗毗国。尔时诸比丘作新佛图。担土持泥墼塼草等。粗泥细泥黑白泥治。不得浴故。痒闷吐逆疲极不除。是事白佛。愿世尊。听作因缘故浴。佛言。听作因缘故浴。从今是戒应如是说。若比丘减半月浴除因缘波逸提。因缘者。春残一月半夏初一月。是二月半大热时。除病时风时雨时作时。作者。乃至扫五扫帚僧坊地。亦名为作。是中犯者。若比丘无作因缘浴波逸提。若作因缘者不犯

佛在舍卫国。尔时诸比丘从憍萨罗游行向舍卫国。是土地多土尘。行时尘士坌身。不得浴故。身体痒闷吐逆。是事白佛。愿世尊。听行因缘故浴。佛言。听行因缘故浴。从今是戒应如是说。若比丘。减半月浴除因缘波逸提。因缘者。春残一月半夏初一月是二月半大热时。除病时风时雨时作时行时。行者。乃至半由旬若来若去。是中犯者。若比丘昨日来今日浴波逸提。明日欲去今日浴波逸提。若至半由旬来去浴者不犯。若比丘无是六因缘。灭半月浴波逸提若有因缘。不语余比丘辄浴者。突吉罗(六十竟)

佛在维耶离国尔时维耶离国诸王子。出园林中学射。门扇孔仰射空中。筈筈相拄。尔时迦留陀夷。中前着衣持钵入城乞食。遥见诸王子作如是射。见已便笑。诸王子言。何以故笑。我等射不好耶。答言不好。问言汝能不。答言能。若能便射。迦留陀夷言。我等法不应捉弓箭。诸王子言。此有木弓可用。即与木弓。张时有飞鸟空中回旋。迦留陀夷放箭。围绕不令得出。诸王子言。何故不着。答言。射着何足为难。诸王子言。不尔。若能著者。便应令着。莫但虚语。即憍慢言。汝等欲令射着何处。王子言。欲令着右眼。即着右眼。是鸟即死。尔时诸王子皆惭愧妒嗔恨言。沙门释子能故夺畜生命。是中有比丘。少欲知足行头陀闻是事心不喜。种种因缘诃责。云何名比丘。故夺畜生命。种种因缘诃已。向佛广说。佛以是事集比丘僧。知而故问。迦留陀夷。汝实作是事不。答言。实作世尊。佛以种种因缘诃责。云何名比丘。故夺畜生命。种种诃已。语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘故夺畜生命波逸提。夺命者。若自夺若教他夺。波逸提者。煮烧覆障。若不悔过能障碍道。是中犯者。有三种。夺畜生命得波逸提。自教遣使。自者。若比丘自作自夺畜生命。教者。语他言。是畜生捉缚打杀。若他受教杀者。是比丘得波逸提。遣使者。若比丘语人言。汝识某畜生不。答言识。汝往捉缚打杀。使往捉缚打杀者。比丘得波逸提。又比丘有三种。夺畜生命得波逸提。一者用受色。二者用不受色。三者用受不受色。受色者。若比丘以手打畜生。若足若头若余身分。念欲令死。死者波逸提。若不即死。后因死者波逸提。若不即死后不因死突吉罗。不受色者。若比丘以木瓦石刀槊弓箭若木段白镴段铅锡段遥掷畜生。念欲令死。死者波逸提。若不即死。后因是死亦波逸提。若不即死后不因死突吉罗。受不受色者。若以手捉木瓦石刀槊弓箭木段白镴段铅锡段就打。念欲令死。死者波逸提。若不即死。后因是死波逸提。若不即死后不因死突吉罗。若比丘不以受色不受色受不受色。为杀故。以毒药着畜生眼中耳中鼻中口中身上疮中。着饮食中卧处行处。念欲令死。死者波逸提。若不即死后因是死亦波逸提。若不即死后不因死突吉罗。若比丘不以受色不受色受不受色。不以毒药。为杀故。作忧多杀头多杀。作弶网拨毗陀罗杀。似毗陀罗杀。断命杀堕胎杀按腹杀。推着水火中杀。推着坑中杀。遣令道中死。乃至母胎中初受二根。身根命根。于中起方便。念欲令死。死者波逸提。若不即死后因是死波逸提。若不即死后不因死。突吉罗(六十一竟)

佛在王舍城。尔时六群比丘共十七群比丘。斗诤相骂心不和合。时六群比丘共十七群比丘斗诤相骂已。六群比丘。欲令十七群比丘疑悔故。作是言。汝等不满二十岁受具足戒。若人不满二十岁受具足戒者。不名得具足戒。若不得具足戒。非比丘非沙门非释子。是人得是语已。愁忧疑悔啼泣。诸比丘问。何故啼耶。答言。六群比丘令我疑悔云。我等不满二十受具足戒。若不满二十受具足戒者。不名得具戒。若不得具足戒。非比丘非沙门非释子。我等闻是语。疑悔故啼。是中有比丘。少欲知足行头陀。闻是事种种因缘诃责。云何名比丘。故令他疑悔。种种因缘诃已向佛广说。佛以是事集比丘僧。知而故问六群比丘。汝实作是事不。答言。实作世尊。佛以种种因缘呵责六群比丘。云何名比丘。故令他比丘疑悔。种种因缘呵已语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘故令余比丘疑悔。使须臾时心不安隐。以是因缘无异波逸提。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。有六事。一者生。二者受具戒。三者犯。四者问。五者物。六者法。生者。若比丘问余比丘。汝何时生。答言。某王时生。某大臣时生。某丰乐时。某饥俭时。某安隐时。某疾病时生。即复言。若人某王时生。某大臣时。若丰乐饥俭安隐疫病时生者。是人不满二十岁。若人不满二十。不得受具足戒。若不得受具足戒。非比丘非沙门非释子。若他比丘起疑悔若不起。皆波逸提。又比丘问他比丘言。汝掖下何时生毛。口边何时生须。咽喉何时现。若言某王时某大臣时若丰乐饥俭安隐疫病时生。即复言。若人某王时某大臣时若丰乐饥俭安隐疫病时。生毛生须咽喉现者。是人不满二十。若人不满二十受具足戒。不名得具足戒。若不得具足戒。非比丘非沙门非释子。若起疑悔若不起。皆波逸提。是名生受具足戒者。若比丘问他比丘言。汝何时受具足戒。答言。某王时某大臣时若丰乐饥俭安隐疫病时受具足戒。即复言。若人某王时某大臣时若丰乐饥俭安隐疫病时受具足戒者。是人不得具足戒。不得具足戒者。非比丘非沙门非释子。若起疑悔若不起。皆波逸提。又比丘问他比丘。谁是汝具足戒和上。谁作阿阇梨。谁作教师。答言。某作和上。某作阿阇梨。某作教师。即复言。若某作和上。某作阿阇梨。某作教师。是人不名得具足戒。若不得具足戒。非比丘非沙门非释子。若起疑悔若不起。皆波逸提。又比丘问他比丘言。汝于十众中受具足戒。于五众中受具戒耶。答言。十众中。即复言。若如是十众中受具戒。是人不得具足戒。若不得具戒者。非比丘非沙门非释子。若起疑悔若不起。皆波逸提。又比丘问他比丘。汝于界内受具戒界外受。答言。界内受。即复言。若界内受。是人不得具足戒。若不得具足戒者。非比丘非沙门非释子。若起疑悔若不起。皆波逸提。是名受具足戒。犯者。若比丘语他比丘言。汝犯僧伽婆尸沙罪犯波逸提波罗提提舍尼突吉罗。若比丘犯僧伽婆尸沙波逸提波罗提提舍尼突吉罗者。是人非比丘非沙门非释子。若起疑悔若不起。皆波逸提。是名犯。问者。若比丘问他比丘。汝入某聚落。行某巷。至某家。坐某处。共某女人语。到某比丘尼坊。共某比丘尼语耶。答言。我入某聚落。行某巷。到某家。坐某处。共某女人语。到某比丘尼坊。共某比丘尼语。即复言。若比丘入某聚落行某巷到某家坐某处共某女人语到某比丘尼坊共某比丘尼语者。是人非比丘非沙门非释子。若起疑悔若不起。皆波逸提。是名问。物者。若比丘语余比丘。汝谁同心用钵。谁同心用衣。用户钩时药夜分药七日药终身药。答言。与某同心用钵衣户钩时药夜分药七日药终身药。即复言。若比丘与某同心用衣钵户钩时药夜分药七日药终身药者。是人非比丘非沙门非释子。若起疑悔若不起。皆波逸提。是名物。法者。若比丘语他比丘。莫多畜衣。莫数数食。莫别众食。莫他不请入其舍。莫非时入聚落。莫不着僧伽梨入村邑。若比丘答言。我受迦絺那衣。即复言。若比丘随意多畜衣。数数食别众食。他不请入其舍。非时入聚落。不着僧伽梨入村邑者。是人非比丘非沙门非释子。若起疑悔若不起。皆波逸提。是名法。若比丘以是六事。令他比丘疑悔。皆波逸提。除是六事。以余事令他比丘疑悔。突吉罗。若除比丘以是六事。以余因缘令余人疑悔。皆突吉罗(六十二竟)

佛在王舍城。尔时十七群比丘中。有一白衣小儿。喜笑。时十七群比丘以喜笑故。用指击擽。小儿多笑乃至气绝。不能动手足。便死。时十七群比丘生疑。我等将无得波罗夷。是事白佛。佛知故问十七群比丘。汝以何心作。答言。我以戏笑故。佛言。若尔者不犯杀。语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘以指击擽他者波逸提。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘以一指击擽他。一波逸提。二三四五六七八九十指。十波逸提。若以木石击擽他。突吉罗(六十三竟)

佛在舍卫国。尔时波斯匿王。有洗浴池。处处作堰。时十七群比丘共相谓言。至阿脂罗河上洗浴去来。十七群比丘中。有一比丘。得禅定故。实不乐往。为护余人意故去。诸比丘皆到阿脂罗河岸上。脱衣入河中作种种戏。或手拍水。或倒没。或如鱼转。或掉臂。或两手把水。或一手。或仰浮。是洗浴处。王殿上悉得遥见。时王与末利夫人。于殿上受五欲乐。女妓自娱。时王遥见十七群比丘在水中种种戏。语末利夫人。此是汝所尊重者。于水中作如是种种粗戏。夫人答言。王何以言看。此是年少耳。王何不言看摩诃迦叶舍利弗目揵连阿那律。尔时是中得禅定者。不洗在别处坐禅闻是二语。王语夫人语。闻已语余比丘言。汝洗己足勿复更洗。当上岸着衣皆盛满澡罐水着前结加趺坐。如是教已。即皆上岸着衣盛满瓶水着前结加趺坐。时得定者。以神通力令瓶水各各在前空中去。令诸比丘大坐闭眼随后而去。时末利夫人见已语王言。此是我所尊重者也。作如是行。乃至王所不见处。时夫人即遣使诣佛所。白佛言。是王常喜出比丘过罪。以此水中洗戏故。愿令诸比丘莫复此中洗。佛以是事集比丘僧。知而故问十七群比丘。汝实作是事不。答言。实作世尊。佛以种种因缘诃责十七群比丘。云何名比丘。水中作种种戏。以手拍水倒没。或如鱼转。或两手把水。或一手。或仰浮。种种诃已语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘水中戏波逸提。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者有八种。一者作喜。二者作乐。三者作笑。四者作戏。五者弄水。六者令他喜。七者令他乐。八者令他笑。若比丘欲作喜故。以手拍水波逸提。若于水中倒没或转如鱼。或一臂两臂浮。或身踊。或仰浮。皆波逸提。若比丘欲作乐作笑作戏弄水。令他喜令他乐令他笑故。作是种种浮戏。皆波逸提。乃至盘上有水若坐床上有水。以指画之突吉罗。不犯者。若学浮若直渡。不犯(六十四竟)

佛在舍卫国。尔时长老阿那律。从憍萨罗游行向舍卫国。到一聚落无僧坊处欲宿。是阿那律本国王子。性贵故不喜问小小事又不知何人可问不可问。见聚落中诸立年少。即往问言。是聚落中谁能与出家人宿处。时聚落中有一淫女。是诸年少欲戏弄比丘故。答言。某处可宿。即往到女门前立弹指。时女人出看。见阿那律端正有威德颜色可爱。见已淫欲心发。女人问言。汝何所索。答言寄宿。女言可得。即入与坐处。共相问讯。然后乃坐。女敕家人。办种种饮食种种庄严供养是客。即敷大床好褥被枕。即此床边更着一床。自为身故。是女人初夜请比丘作不净事。我当为汝供给捺脚。比丘答言。我是断淫欲人。莫说是事。女人意念。此必有欲。但以初至疲极故。至中夜更语。犹故不从。至后夜复语。亦故不从。至地了时女语比丘言。国王大臣有持百金钱来。我不肯从。二百三百四百五百我亦不从。我于今夜三自相请。而汝不肯。汝于比丘所应得法。必当得之。若不欲尔者。为愍我故受我施食。阿那律念言。我道中行必。当复须食。作是念已即默然受。知默然受已。即时办饮食。自手行水。自与多美饮食饱满已。知洗手摄钵竟。取小床在前坐听说法。时阿那律。观女人心本末因缘。为说次第法。即于座上远尘离垢得法眼净。是女人见法闻法知法入法。度疑悔不随他。于佛法中得自在心无所畏。从坐处起。头面礼阿那律足言。我从今日。归依佛归依法归依僧。我尽形作佛优婆夷。时阿那律更为说种种法示教利喜。示教利喜已从坐起去。从是已来此家常供给沙门释子衣服饮食。是淫女少多送阿那律已便还。尔时阿那律渐到舍卫国。脱衣钵着一处。往诣佛所。头面作礼在一面坐。诸佛常法。有客比丘来。以如是语劳问。忍不足不。乞食不难。道路不疲极耶。佛即以如是语劳问阿那律。忍不足不。乞食不难。道路不疲极耶。阿那律答言。世尊。忍足乞食不难。道路不疲。以是事向佛广说。佛以是事集比丘僧。语诸比丘。阿那律虽离欲得阿罗汉。不应与女人共宿。如熟饮食人之所欲。女人于男亦复如是。种种因缘诃责。不应与女人共宿。以十利故与比丘结戒。从今是戒应如是说。若比丘与女人同舍宿波逸提。女者。人女非人女畜生女是。人女若卧若坐名为宿。象若倚若立亦名宿。驼马牛羊若卧若立亦名宿。鹅雁孔雀鸡若一脚立若持头置项上亦名宿。舍者有四种。一切覆一切障。一切障不覆。一切覆不障。一切覆少障。是中犯者。若比丘是四种舍中。共女人宿。皆波逸提。若起还卧。更得波逸提。随起还卧。一一波逸提。不犯者。通夜坐不卧。乃至他舍有女人宿。孔容猫子入处。是中宿波逸提(六十五竟)

佛在维耶离国摩俱罗山中。尔时与侍者象守比丘俱。诸佛侍者法。佛未入房不得先入。时佛初夜露地经行。尔时小雨堕。释提桓因作是念。佛今在露地经行小雨堕。我何不变作琉璃窟令佛在中经行。即变化作。佛在中经行。帝释随后。佛经行久。是象守比丘风雨所恼。作是念。当以何方便令佛入舍。我当得入。尔时摩俱罗山中所有人民。小儿啼时则以婆俱罗夜叉。怖之令止。时象守反被俱执。在经行道头立。以两手覆两耳语佛言。婆俱罗夜叉来。时释提桓因白佛言。世尊。云何佛法中乃有是痴人。佛言。憍尸迦。我家广大。此人现身亦当得漏尽。所作已办更不复受后有。佛种种因缘示教利喜。示教利喜已默然。释提桓因闻佛示教利喜已。头面礼佛足右绕而去。释去不久。佛入自房敷坐床坐。是夜过已。以是因缘集比丘僧。种种因缘诃责象守比丘言。痴人。云何能恐怖如来佛世尊。汝痴人。佛者。无怖畏衣毛不竖。尔时佛说偈言

  佛于自法中　　通达无碍智
  有人可以此　　婆俱夜叉恐
  佛于自法中　　通达无碍智
  是故能过度　　生老病死苦
  佛于自法中　　通达无碍智
  是故能除灭　　诸结使烦恼

佛种种因缘诃责象守比丘已。语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘自恐怖他比丘。若教他恐怖。乃至戏笑波逸提。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。有六种。色声香味触法。色者。若比丘作象色。若作马色羝羊色水牛色。作如是等可畏色恐怖比丘。若能令怖若不能。皆波逸提。是名色。声者。若比丘作象声马声车声步声羝羊声水牛声。作如是等可畏声恐怖他比丘。若能令恐怖若不能。皆波逸提。是名声。香者。若比丘作好香。若作臭若等分香若作希有香。作如是等香恐怖他比丘。若能令恐怖若不能。皆波逸提。是名香。味者。若比丘问他比丘。汝今日用何物啖饭。答言。用酪酥。又言。若用酪酥啖饭者。是人得癞癣病。若能令恐怖若不能。皆波逸提。若比丘复问他比丘。汝今日以何物啖饭。答言。用酪酥毗罗浆。又言。若人用酪酥毗罗浆啖饭者。是人得癞癣病。若能令恐怖若不能。皆波逸提。又比丘问余比丘。汝今日以何物啖饭。答言。以酥猪肉。又言。若人用酥猪肉啖饭者。是人得癞癣病。若能令恐怖若不能。皆波逸提。是名味。触者。若比丘持身令坚。若粗若软若细滑若涩。令身皆异。以触他比丘。若能令恐怖若不能。皆波逸提。是名触。法者。若比丘语余比丘。汝莫于生草中大小便。当堕地狱饿鬼畜生。是比丘答言。我自知是法。又言。若比丘生草中大小便者。是比丘便堕地狱饿鬼畜生。若能令恐怖若不能。皆波逸提。是名法。若比丘以是六事恐怖比丘波逸提。除是六事。以余事恐怖比丘突吉罗。若以六事及余事。恐怖余人突吉罗(六十六竟)

佛在舍卫国。有一居士。请佛及僧明日食。佛默然受。是居士知佛默然受已。从坐起头面礼佛足右绕而去。还家通夜办种种多美饮食敷坐处。尔时诸比丘。早起持衣钵着露地待时到。尔时六群比丘。与十七群比丘共斗诤不相喜。时六群比丘。取十七群比丘衣钵藏着异处。时十七群比丘来求衣钵。久觅不得。十七群比丘法。有所作事皆共相语。时失衣者语余者言。我不知衣钵处。相助求觅。于是中间。居士敷坐处已。遣使白佛时到。饮食已办。佛自知时。诸比丘僧往居士舍。佛自房住迎食分。居士见僧坐已。自手行水。自与多美饮食自恣饱满。自恣饱满已。知僧摄钵自行水竟。取小床在僧前坐。欲听说法。上座说法已。及余比丘各从坐起。出居士舍。十七群比丘尔许时觅衣始得来入。众僧出时见已问言。何故在后。答言。六群比丘藏我衣钵。久觅始得。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘诃责六群比丘。云何名比丘。藏他比丘衣钵。求觅时间垂当断食。种种因缘诃已向佛广说。佛以是事集比丘僧。知而故问六群比丘。汝实作是事不。答言。实作世尊。佛种种因缘诃责。云何名比丘。藏他比丘衣钵。求觅时间垂当断食。佛种种因缘呵已语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘藏他比丘钵若衣户钩革屣针筒。如是随法所须物。若自藏。若教他藏。乃至戏笑波逸提。自藏者自手藏。教藏者教他藏。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘藏他比丘钵。彼比丘若觅不得。是比丘得波逸提。若觅得突吉罗。若衣户钩革屣针筒。若觅不得波逸提。若觅得突吉罗。若藏空针筒。彼比丘若觅不得突吉罗。若得亦突吉罗(六十七竟)

佛在王舍城。尔时六群比丘性懒惰。不喜自浣染衣割截篸缝。若有衣可浣染割截篸缝者。便持是衣与比丘若比丘尼式叉摩尼若沙弥沙弥尼。诸人生自衣想。浣染割截篸缝作衣竟。尔时六群比丘知衣已成。便往索言。此衣何以久不还我。软语不得。即强夺取。尔时诸比丘。不见六群比丘浣染割截篸缝衣时。但见着新衣。诸比丘问六群比丘言。不见汝浣染割截篸缝衣时。但见着新衣。六群比丘言。我等有可浣染割截篸缝衣。持与比丘比丘尼式叉摩尼沙弥沙弥尼。诸人是衣中生自衣想。浣染作衣竟。我便往索。此衣何以久不还我。软语不得。即强夺取着。以是因缘故。汝等不见我浣染割截篸缝衣时。但见我着新衣。是中有比丘。少欲知足行头陀。闻是事种种因缘诃责六群比丘。云何名比丘。与比丘比丘尼式叉摩尼沙弥沙弥尼衣。他不还。便强夺取着。诸比丘种种因缘诃已。向佛广说。佛以是事集比丘僧。知而故问六群比丘。汝实作是事不。答言。实作世尊。佛种种因缘诃责六群比丘。云何名比丘。与比丘比丘尼式叉摩尼沙弥沙弥尼衣。他不还。便强夺取着。种种因缘诃已语诸比丘。以十利故与诸比丘结戒。从今是戒应如是说。若比丘与他比丘比丘尼式叉摩尼沙弥沙弥尼衣。他不还。便强夺取着。波逸提。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘。与比丘比丘尼式叉摩尼沙弥沙弥尼衣。他不还。便夺取着波逸提

尔时诸比丘不知长衣当云何畜。是事白佛。佛言。应作净畜。有比丘。现前作净。与他衣已。他不肯还。即生斗诤。是事白佛。佛言。不应现前与。尔时有比丘与二三人衣。作是言。我所有衣钵皆与某甲。某甲二三人如是散乱不应净法。是事白佛。佛言。不应与二三人。应好思惟筹量与一好人应作是言。我衣钵皆与某甲一人。从今日比丘。有应常用衣。不应与他。若遣与若作净若受持。比丘有衣应与他者。与六群比丘中一人。是人受衣已便不肯还。余比丘亦得懊恼。不能得好同心比丘故。又一时夏末月。佛游行诸国。余比丘皆着新染衣。是一比丘着故弊衣。佛见是比丘。知而故问。汝何故着弊故衣。比丘答言。世尊。我有衣应净故。与六群比丘中一人。受我衣钵已便不肯还。余比丘亦得懊恼。不得好同心比丘故。佛言。是施不名真实。为清净因缘故与。即时是比丘应还。索取若得者好。若不得者应强夺取。应教彼作突吉罗罪悔过。从今日比丘。所有常用衣随意不应与他。若作净若受持若施人不犯(六十八竟)

佛在维耶离国。尔时有弥多罗浮摩比丘。作是念。我以无根波罗夷法。谤陀骠比丘力士子。不能得成。是事无根故。又以小因缘作波罗夷谤。亦不得成。无小因缘故。我今当以无根僧伽婆尸沙法。谤陀骠比丘力士子。作是念已。即以无根僧伽婆尸沙法。谤陀骠比丘。是中有比丘。少欲知足行头陀。闻是事种种因缘诃责弥多罗浮摩比丘。云何名比丘。以无根僧伽婆尸沙法。谤清净梵行比丘。诸比丘种种因缘诃责弥多罗浮摩比丘已。向佛广说。佛以是事集比丘僧。知而故问弥多罗浮摩比丘。汝实作是事不。答言。实作世尊。佛以种种因缘诃责。云何名比丘。以无根僧伽婆尸沙法。谤清净梵行比丘。种种因缘诃已语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘以无根僧伽婆尸沙法。谤他比丘。波逸提。无根者根有三种。若见若闻若疑僧伽婆尸沙者。十三僧伽婆尸沙中随彼所说。谤者。他所不作强言作罪。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘以无根僧伽婆尸沙法。谤不清净比丘。十一种犯五种不犯。十一种犯者。若不见不闻不疑若见忘若闻忘若疑忘。若闻信闻若闻不信闻。闻已言我疑。疑已言我见。疑已言我闻。是名十一种犯。五种不犯者。是事若见若闻若疑。见已不忘闻已不忘。是名五种不犯。不清净比丘似清净比丘亦如是。若比丘以无根僧伽婆尸沙法。谤清净比丘。十种犯四种不犯。十种犯者。不见不闻不疑。若闻忘疑忘。若闻信闻。若闻不信闻。闻已言疑。疑已言见。疑已言闻。是名十种。犯四种不犯者。若闻若疑。若闻不忘。若疑不忘。清净比丘似不清净亦如是(六十九竟)

佛在维耶离。去维耶离城不远。有织师聚落。是中一织师妇。有小事不随夫言。夫以手脚痛打驱出舍。是女父母家。在维耶离城中。妇作是念。我当还归。作是念时。有迦留罗提舍比丘。从跋耆国游行向维耶离。是妇出外见是比丘。问言。善人那去。答言。向维耶离。妇言俱去。即便俱发。尔时以染心相看调戏大语掉手臂行。作种种不净事。时织师还作是念。我妇或当走去。即出舍求妇不得。诸织师法。有事皆相佐助。即语余织师言。我妇走去。诸织师即于要道中觅。是夫作是念。是妇生在维耶离。必当还归。即自向维耶离道中。见妇与向比丘俱行。即往捉比丘以衣系项言。汝比丘法。应将我妇去耶。答言。我不将去。我自向维耶离。汝妇自随我来。夫言。云何肯直首。即以手脚打比丘。妇见打比丘故。语夫言。何以打他。此比丘不将我来。我自向维耶离。夫语妇言。小婢。汝必共作不净事。复更以手脚打比丘已放去。是迦留罗提舍比丘。起如是恶事便去。到维耶离向诸比丘说。诸比丘以是事向佛广说。佛以是事集比丘僧。语诸比丘。如是罪及余过罪。皆由与女人共期道行故。以十利故与比丘结戒。从今是戒应如是说。若比丘与女人共期道行。乃至一聚落波逸提。女人者。有命女人堪作淫欲。期者有二种。若比丘作期。若女人作期。道者有二种。水道陆道。波逸提者。煮烧覆障。若不悔过。能障碍道。是中犯者。若比丘与女人共期陆道行。从一聚落至一聚落波逸提。若中道还突吉罗。若无聚落空地行。乃至一拘卢舍波逸提。中道还突吉罗。水道亦如是。不犯者。若比丘不共期行。若与国王夫人共道行。不犯(七十竟)

佛在维耶离。尔时诸比丘。从跋耆国游行向维耶离。是道多草木。诸比丘失道。入萨罗树林中。尔时有贼。作恶事竟先在林中。诸贼见比丘作是言。比丘那去。答言。向维耶离。贼言。此非维耶离道。诸比丘言。我等亦知非向维耶离道。我等失道故。诸比丘问贼。汝等那去。答言。向维耶离。诸比丘言。我曹与汝等共去。诸贼言。不知我等是贼耶。我等或随道行。或不随道行。或从济渡恒河。或不从济渡。或由门入。或不由门入。若共我等去者。或得衰恼事。诸比丘言。我等以失道有事无事为当共去。答言。随意。即与贼俱去。不由济渡恒河时。为逻人所捉。逻人问诸比丘。汝等亦是贼耶。答言。我等非贼。以失道故。逻人即看无异财物。逻人言。汝肯直首耶。当将诣官治。众官问言。汝等亦是贼耶。答言。我等非贼。以失道故。众官即看无异财物。时断事人信佛法故。作是言。沙门释子不作是恶事。必是失道。语比丘言。今放汝去。后莫复与恶人共道行。诸比丘起如是大恶事已便去。以是事向诸比丘说。诸比丘以是事向佛广说。佛以是事集比丘僧。语诸比丘。如是罪及过是罪。以与贼众共道行故。以十利故与比丘结戒。从今是戒应如是说。若比丘与贼共期同道行。乃至一聚落波逸提。贼者。偷象马牛羊。到小聚落抄夺他物。期者有二种。若比丘作期。若贼作期。道者有二种。水道陆道。波逸提者。煮烧覆障。若不悔过能障碍道。是中犯者。若比丘陆道与贼共期。从一聚落至一聚落波逸提。若中道还突吉罗。若无聚落空地。乃至一拘卢舍波逸提。若中道还突吉罗。水道行亦如是。不犯者。若不期不犯。若险难处贼送度者不犯(七十一竟)

佛在王舍城。尔时王舍城中。十七群年少富贵家子。柔软乐人和提等。未满二十岁。长老目揵连与受具戒。是人晡时饥急故。于僧坊内发大音声。作小儿啼。佛闻僧坊内小儿啼声。知而故问阿难。何故僧坊内有小儿啼声。阿难答言。世尊。是王舍城中。有十七群年少富贵家子。柔软乐人未满二十岁。长老目揵连与受具戒。晡时饥急。是故僧坊内发大音声作小儿啼。佛以是事集比丘僧。知而故问大目揵连。汝实作是事不。答言。实作世尊。佛种种因缘诃责目揵连。汝不知时不知量。趣得便与受具足戒。汝云何不满二十岁人与受具戒。何以故。不满二十岁人。不能堪忍寒热饥渴。蚊虻风雨蛇毒所螫。他人恶口苦急夺命重病。皆不能堪忍。是不满二十岁人未成就故。佛言。满二十岁人。能堪忍寒热饥渴。蚊虻风雨蛇毒所螫。他人恶口苦急夺命重病。皆能堪忍。以成就故。佛种种因缘诃已语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘未满二十岁人。与受具足戒波逸提。是人不得具足戒。诸比丘亦可诃。是事应尔。波逸提者。煮烧覆障。若不悔过能障碍道。是中犯者。若人不满二十岁。自想不满。僧中问。汝满二十不。答言。不满。若僧与受具足戒。是人不得戒。诸比丘得罪。共事共住者亦得罪又人不满二十岁。自想不满。僧中问。汝满二十不。答言满。若僧与受具足戒。是人得戒。共事共住无犯。诸比丘得罪。又人不满二十岁。自想不满。僧中问。汝满二十不。答言。不知不忆疑。若僧不审谛问。便与受具足戒。是人得戒。共事共住无罪。诸比丘得罪。若人不满二十岁。忘不知不满。僧中问。汝满二十不。答言。不满。若僧与受具足戒。是人不得戒。诸比丘得罪。共事共住亦得罪。又人不满二十岁。忘不知不满。僧中问汝满二十不。答言满。若僧与受具戒。是人得戒。共事共住无罪。诸比丘得罪。又人不满二十岁。忘不知不满。僧中问。汝满二十不。答言。不知不忆疑。若僧不审谛问。便与受具戒。是人得戒。共事共住无罪。诸比丘得罪。若人不满二十岁。不自知不满。僧中问。汝满二十不。答言。不满。若僧与受具足戒。是人不得戒。诸比丘得罪。共事共住者亦得罪。又人不满二十岁。不自知不满。僧中问。汝满二十不。答言满。若僧与受具足戒。是人得戒。共事共住无罪。诸比丘得罪。又人不满二十岁。不自知不满。僧中问。汝满二十不。答言。不知不忆疑。若僧不审谛问。便与受具足戒。是人得戒。共事共住无罪。诸比丘得罪

若人不满二十岁。自疑为满不满。僧中问。汝满二十不。答言。不满。若僧与受具足戒。是人不得戒。诸比丘得罪。共事共住者亦得罪。又人不满二十岁。自疑为满不满。僧中问。汝满二十不。答言满。若僧与受具足戒。是人得戒。共事共住者无罪。诸比丘得罪。又人不满二十岁。自疑为满不满。僧中问。汝满二十不。答言。我不知不忆疑。若僧不审谛问。便与受具足戒。是人得戒。共事共住者无罪。诸比丘得罪。若人满二十岁。自想满二十。僧中问。汝满二十不。答言满。若僧与受具足戒。是人得戒。诸比丘无罪。共事共住者亦无罪。又人满二十岁。自想满二十。僧中问。汝满二十不。答言。不满。若僧与受具戒。是人不得戒。诸比丘得罪。共事共住者亦得罪。又人满二十。自想满二十。僧中问。汝满二十不。答言。不知不忆疑。若僧不审谛问。便与受具戒。是人得戒。共事共住无罪。诸比丘得罪。若人满二十岁。忘不自知满。僧中问。汝满二十不。答言满。若僧与受具戒。是人得戒。诸比丘无罪。共事共住亦无罪。又人满二十。忘不自知满。僧中问。汝满二十不。答言。不满。若僧与受具戒。是人不得戒。共事共住得罪。诸比丘亦得罪。又人满二十。忘不自知满。僧中问。汝满二十不。答言。不知不忆疑。若僧不审谛问。便与受具戒。是人得戒。共事共住无罪。诸比丘得罪

若人满二十岁。不自知满。僧中问。汝满二十不。答言满。若僧与受具戒。是人得戒。诸比丘无罪。共事共住亦无罪。又人满二十岁。不自知满。僧中问。汝满二十不。答言。不满若僧与受具戒。是人不得戒。共事共住得罪。诸比丘亦得罪。又人满二十岁。不自知满。僧中问。汝满二十不。答言。不知不忆疑。若僧不审谛问。便与受具戒。是人得戒共事共住无罪。诸比丘得罪。若人满二十岁。自疑为满不满。僧中问。汝满二十不。答言满。若僧与受具戒。是人得戒。诸比丘无罪。共事共住亦无罪。又人满二十岁。自疑为满不满。僧中问。汝满二十不。答言。不满。若僧与受具戒。是人不得戒。诸比丘得罪。共事共住亦得罪。又人满二十岁。自疑为满不满。僧中问。汝满二十不。答言。我不知不忆疑。若僧不审谛问。便与受具戒。是人得戒。共事共住无罪。诸比丘得罪(七十二竟)

佛在阿罗毗国。尔时阿罗毗比丘。自手掘地。作墙基。掘渠池井。掘泥处。有居士。是外道弟子。说地中有命根。是人以嫉心故。诃责言。沙门释子自言。善好有功德。而夺一根众生命。是中有比丘。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集比丘僧。知而故问阿罗毗比丘言。汝实作是事不。答言。实作世尊。佛以种种因缘诃责。云何名比丘。自手掘地。掘作墙基。掘渠池井。掘泥处。种种因缘诃已语诸比丘。以十利故与诸比丘结戒。从今是戒应如是说。若比丘自手掘地。若教他掘。作是言。汝掘是处波逸提。地者。有二种。生地不生地。颓墙土石底蚁封土聚。生地者。若多雨国土八月地生。若少雨国土四月地生。是名生地。除是名不生地。自掘者。手自掘。教他掘者。教他人掘。波逸提者。煮烧覆障。若不悔过能障碍道。是中犯者。若比丘掘不生地。随一一掘突吉罗。若颓墙土石底蚁封土聚。若掘者随一一掘突吉罗。若比丘掘生地。随一一掘波逸提。若掘作墙基。若掘渠池井。随一一掘波逸提。若掘泥处。乃至没膝处掘取。随一一掘突吉罗。若手画地。乃至没芥子。一一画突吉罗。若比丘作师匠。欲新起佛图僧坊。画地作模像处所。不犯余比丘画者犯罪。若生金银砗磲玛瑙朱砂矿处。若掘是处不犯。若生铁矿处。铜白镴铅锡矿处。若雌黄赭土白墡处。若生石处生黑石处。沙处盐地。掘者不犯(七十三竟)

十诵律卷第十六十诵律卷第十七(第三诵之四)

        后秦北印度三藏弗若多罗译

    九十波逸提之九

佛在释氏国。尔时摩诃男释。四月请佛及僧。所须药一切自恣皆从我取。尔时六群比丘过夏四月不病。到摩诃男释所言。我等须酥。答言。先所有酥僧中用[歹*斯]。但有余药诃梨勒阿摩勒毗醯勒波株罗药比牧蔓陀药多耶摩那药迦楼伽卢醯尼药。有如是等若须者便取。六群比丘又问。汝有油蜜石蜜姜胡椒荜茇黑盐不。我等须之。答言。先有僧中用尽。但有余药诃梨勒等。若须者便取。六群比丘便嗔恚言。汝诳佛及僧。力不能与者。何故请佛及僧四月自恣多与药。若有余人请者。必当自恣与多美好药。此辛苦草药何处不有。尔时摩诃男释。善好大人。如是诃时。心不忧愁。时有余居士随从摩诃男释者。以嫉嗔心诃责言。是沙门释子自言。善好有德。是摩诃男释。善好供给众僧如事大家。云何现前诃骂出其过罪。是中有比丘。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集比丘僧。知而故问六群比丘。汝实作是事不。答言。实作世尊。佛以种种因缘诃责。云何名比丘。摩诃男释善好供给众僧如事大家。而现前诃骂。种种因缘诃已语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘受四月自恣请过。除常请。除数数请。除别请。复更索者波逸提。四月请者。随何家中请僧四月一切药随意所须。常请者。随何家中常请僧一切药随意所须。数数请者。随何家中过一月已复请四月。过二月已复请四月。过三月已复请四月。过四月已复请四月。别请者。私请也。波逸提者。煮烧覆障。若不悔过能障碍道。是中犯者。若比丘随何家中四月请僧与一切药。是比丘过四月已。若复索酥。得者波逸提。不得者突吉罗。索油蜜石蜜胡椒荜茇姜黑盐。得者波逸提。不得者突吉罗。若索诃梨勒阿摩勒毗醯勒波株罗毗牧蔓陀多耶摩那伽楼伽卢醯尼等苦药。得者突吉罗。不得者亦突吉罗。若常请者。随何家中请僧与一切药若请主死。若有儿若有兄弟妇。作是言。如本家主在时请。我今亦如是常请。是中有比丘。应常请处取。若数数请者。随何家中数数请与一切药。是中一月过已更请四月。是中比丘应夏中三月受冬中一月受。若二月过已更请四月。应夏中二月冬中二月受。若三月过已更请四月。应夏一月冬三月受。若四月过已更请四月。应冬四月受。比丘冬四月过不病。更往索酥。得者波逸提。不得者突吉罗。若索油蜜石蜜胡椒荜茇姜黑盐。若得者波逸提。不得突吉罗。若索呵梨勒阿摩勒毗醯勒波株罗毗牧蔓陀多耶摩那迦楼伽卢醯尼等苦药。若得者突吉罗。不得者亦突吉罗。不犯者。若病索。若从亲里索。若先请。若不索自与。不犯(七十四竟)

佛在舍卫国。尔时佛不在比丘尼僧前结同戒。时佛在比丘僧前结同戒。语诸比丘。汝等以是戒向比丘尼说。作是语已入室坐禅。尔时诸比丘作是念。佛今为我等结同戒言。汝等向比丘尼唱说。作是语已入室坐禅。是中谁能往王园比丘尼精舍。向比丘尼僧说。复作是念。是长老跋提比丘。有大功德名闻。多知多识。此人堪往王园向比丘尼僧说。作是念已共相谓言。当共往语长老跋提比丘。即时诸比丘往诣长老跋提所。头面礼足一面坐已。语长老跋提言。汝知不。佛为我等结同戒。语我等言。汝等向比丘尼说。作是语已入室坐禅。我等作是念。是中谁能往王园比丘尼精舍向比丘尼说。我等复作是念。是长老跋提比丘有大功德名闻。多知多识。此人堪任往王园向比丘尼说。汝今往诣王园精舍。向比丘尼唱说者善。长老跋提默然受诸比丘语。尔时诸比丘知跋提默然受已。从坐起头面礼足右绕而去。是长老跋提过是夜已。晨朝着衣持钵共一后行比丘。入舍卫城次第乞食。食已向王园比丘尼精舍。诸比丘尼遥见长老跋提故。有为敷床者。有为办洗足水者。时长老跋提洗足已就座处坐。语诸比丘尼令集一处。语比丘尼言。佛为我等结同戒。我及汝等应共受持。尔时有长老比丘尼善比丘尼。皆言。善好受持是语。尔时偷兰难陀比丘尼在众中。语长老跋提言。汝愚痴不了不决定知。我等可以汝语故持不持耶。我等当问余比丘持修多罗比尼摩多罗迦者。若应持者当持。不应持者不持。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责偷兰难陀比丘尼。云何名比丘尼佛。结同戒违逆不受。复语长老跋提言。汝愚痴不了不决定知。如是种种因缘诃已。向佛广说。佛以是事集比丘僧。佛以种种因缘诃责偷兰难陀比丘尼。云何名比丘尼。我结同戒违逆不受。复诃责善男子跋提。愚痴不了不决定知。佛如是种种因缘诃已。语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘说戒时作是言。我不受学是戒。先当问余比丘持修多罗持比尼持摩多罗迦者。波逸提。若比丘欲知法者。应从此戒学。已当问余比丘持修多罗持比尼持摩多罗迦者。应如是问。是语云何。是事应尔。波逸提者。煮烧覆障。若不悔过能障碍道。是中犯者。若比丘说四波罗夷时。作是言。我不学是戒。先当问余比丘持修多罗持比尼持摩多罗迦者。波逸提。若比丘说十三僧伽婆尸沙法二不定法三十尼萨耆波逸提法九十波逸提法四波罗提提舍尼法众多学法七灭诤法及余入比尼经说时。作是言。我不受学是戒。先当问余比丘持修多罗持比尼持摩多罗迦者。波逸提。若除入比尼经。说余经时作是言。我不受学是经。先当问余比丘持修多罗持比尼持摩多罗迦者。突吉罗(七十五竟)

佛在王舍城。尔时六群比丘。与十七群比丘。常共斗诤相骂相詈。时十七群共六群斗诤相骂已。各自别去。谓六群比丘不闻其声。屏处相谓言。六群凶恶健斗。我等共同心者。六群比丘不能得便。时六群比丘盗往立听。十七群比丘谓无人闻。说已默然。时六群言。汝可以骂我等。答言。谁骂汝等。六群言。汝等适不言。六群比丘凶恶健斗诤。我等共同心者。六群比丘不能得便。十七群比丘言。谁作是言。从谁所闻。六群比丘言。我在屏处立闻。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘诃责六群比丘。云何名比丘。共他斗诤相骂已。盗往立听。种种因缘诃已向佛广说。佛以是事集比丘僧。知而故问六群比丘。汝实作是事不。答言。实作世尊。佛种种因缘诃责六群比丘。云何名比丘。共他比丘斗诤相骂。盗往立听。种种因缘诃已语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘共余比丘斗诤已。盗往立听。彼比丘所说我当忆持。波逸提。盗往听者。若在细梐绳床下。若粗梐绳床下。若独坐床下。若户边。若道边。若高上。若墙边。若别房内。若壁边障外。若闇中。若月明中。波逸提者。煮烧覆障。若不悔过能障碍道。是中犯者。若比丘共他比丘斗诤相骂已盗往听他语。若在细梐绳床下。能得闻者波逸提。不得闻突吉罗。若在粗梐绳床下。若独坐床下。若户边若道边。若高上若墙边。若别房内若壁边若障外。若黑闇中若月明中。得闻者波逸提。不闻者突吉罗。不犯者。若为和合往听不犯(七十六竟)

佛在舍卫国。尔时诸比丘。欲与跋难陀释子作摈羯磨。白时六群比丘于僧中遮。不得成羯磨。一时六群比丘有因缘余处去。有一比丘助六群者不去。诸比丘共相谓言。我等今与六群比丘作摈羯磨。有比丘言。六群比丘或当在中间遮。有比丘言。六群比丘已余处去。无有遮者。即打揵椎集比丘僧。欲与跋难陀作摈羯磨。称跋难陀名欲唱白时。助六群比丘者默然从坐起去。作是念。今诸比丘欲与跋难陀释子作摈羯磨。后白诸比丘唱言已。与跋难陀作摈羯磨。是助六群比丘者言。是羯磨不如法。别我作故。诸比丘言。汝在是中。答言。我虽在此中。汝等欲唱白时。我从坐起去。以摈跋难陀释子故。是中有比丘。少欲知足行头陀。闻是事心不喜。种种诃责助六群比丘。云何名比丘。僧断事时默然起去。种种因缘诃已向佛广说。佛以是事集比丘僧。知而故问助六群比丘。汝实作是事不。答言。实作世尊。佛种种因缘诃责助六群比丘。云何名比丘。众僧断事时默然起去。种种因缘诃已语诸比丘以十利故与比丘结戒。从今是戒应如是说。若比丘僧断事时默然起去波逸提。僧断事者。若僧所作事。谓白一白二白四羯磨布萨自恣。若作十四人羯磨。波逸提者。煮烧覆障。若不悔过能障碍道。是中犯者。若比丘僧断事唱白时。默然起去波逸提。若白一白二白四羯磨布萨自恣作十四人羯磨时。默然从坐起去者波逸提。不犯者。若去大小便。若去不离闻处。不犯(七十七竟)

佛在俱舍弥国。时阐那比丘。诸上座所说是法是律是佛教。不待说竟。中间作异语答难上座。无敬畏心。诸比丘语阐那。汝莫尔。诸上座所说是法是律是佛教。汝莫中间作异语。不待说竟答难上座。无敬畏心。阐那言。我答难上座无敬畏心。何预汝事。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘诃责阐那。云何名比丘。诸上座所说是法是律是佛教。不待说竟中间作异语。答难上座无敬畏心。种种因缘诃已向佛广说。佛以是事集比丘僧。知而故问阐那。汝实作是事不。答言。实作世尊。佛种种因缘诃责阐那。云何名比丘。诸上座所说是法是律是佛教。不待说竟中间作异语。答难上座无敬畏心。种种因缘诃已语诸比丘。汝等记阐那比丘不恭敬事。若有余比丘作是事者。亦应如是记不恭敬事。记者。僧一心和合。一比丘唱。大德僧听。是阐那比丘。上座所说是法是律是佛教。不待说竟中间作异说。答难上座无敬畏心。若僧时到僧忍听。当记阐那比丘不恭敬事。白如是。如是白四羯磨。僧记阐那比丘不恭敬事竟。僧忍默然故是事如是持。语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘不恭敬者波逸提。波逸提者。煮烧覆障。若不悔过能障碍道。是中犯者。若比丘僧未记不恭敬事。若诸比丘语汝莫作淫。答言不作而实作淫淫故波罗夷。不恭敬故突吉罗。汝莫偷夺他物。莫故夺人命。莫触女人身。莫杀草木。莫过中食。莫饮酒。汝从此房出。从床榻被褥独坐床起去。莫捉钵钩钵多罗半钩钵多罗揵镃半揵镃剃刀镊小刀。答言不作。而实作。若作随得罪。不恭敬故突吉罗。若比丘僧未记不恭敬事。诸比丘语汝莫作淫。答言当莫作。而实作淫。淫故波罗夷。不恭敬故突吉罗。汝莫偷夺他物。莫夺人命。莫触女身。莫杀草木。莫过中食。莫饮酒。汝从此房出。从床榻被褥独坐床起去。莫捉此钵钩钵多罗半钩钵多罗揵镃半揵镃剃刀镊小刀。答言当不作。而实作。若作随得罪。不恭敬故突吉罗。若比丘僧记不恭敬事已。诸比丘语汝莫作淫。答言不作。而实作淫。淫故波罗夷。不恭敬故波逸提。僧记不恭敬事已。语汝莫偷夺他物。莫故夺人命。莫触女身。莫杀草木。莫过中食。莫饮酒。汝从此房出。从床榻被褥独坐床起去。莫捉此钵钩钵多罗半钩钵多罗揵镃半揵镃剃刀镊小刀。答言不作。而实作。若作随得罪。不恭敬故波逸提。若比丘僧记不恭敬事已。诸比丘语汝莫作淫。答言当不作。而实作淫。淫故波罗夷。不恭敬故波逸提。僧记不恭敬事已。诸比丘语。汝莫偷夺他物。莫故夺人命。莫触女身。莫杀草木。莫过中食。莫饮酒。汝从此房出。从床榻被褥独坐床起去。莫捉此钵钩钵多罗半钩钵多罗揵镃半揵镃剃刀镊小刀。答言当不作。而实作。若作随得罪。不恭敬故波逸提(七十八竟)

佛在支提国跋陀罗婆提邑。是处有恶龙。名庵婆罗提他。凶暴恶害。无人能得到其住处。象马牛羊骡驴骆驼无能近者。乃至诸鸟不得过上。秋谷熟时破灭诸谷。长老莎伽陀。游行支提国。渐到跋陀罗婆提邑。过是夜已晨朝着衣持钵入村乞食。乞食时闻此邑有恶龙。名庵婆罗提他。凶暴恶害。人民鸟兽不得到其住处。秋谷熟时破灭诸谷。闻已乞食竟。到庵婆罗提他龙住处泉边树下敷坐具大坐。龙闻袈裟衣气。即发嗔恚从身出烟。长老莎伽陀即入三昧。以神通力身亦出烟。龙倍嗔恚身上出火。莎伽陀比丘。复入火光三昧。身亦出火。龙复雨雹。莎伽陀比丘即变雨雹。作释俱利饼肴饼波波罗饼。龙复放大霹雳。长老莎伽陀即变霹雳。作种种欢喜丸。龙复雨箭刀槊。莎伽陀即变作优钵罗华波头摩华俱牟陀华分陀利华。时龙复雨毒蛇蜈蚣土虺蚰蜒。莎伽陀即变作优婆罗华璎珞瞻卜华璎珞婆师华璎珞阿提目多伽华璎珞。如是等龙所有势力尽现。向长老莎伽陀。如是现威德已。不能胜故。即失威力光明。莎伽陀知龙力势已尽不能复动。即变作细身。从龙两耳入从两眼出两眼出已从两鼻入。从口中出在龙头上。往来经行不伤龙身。尔时龙见如是事已。心即大惊怖畏毛竖。合掌向长老莎伽陀言。我归依汝。莎伽陀答言。汝莫归依我。当归依我所归依。龙言。我从今归依佛归依法归依僧。当知我尽形作佛优婆塞。是龙受三自归作佛弟子已。更不复作如是凶恶事。诸人鸟兽皆得到其所住处。秋谷熟时不复伤破。如是名声流布诸国。皆言。长老莎伽陀。能降恶龙折伏令善。诸人鸟兽得到龙所。秋谷熟时不复破伤。因长老莎伽陀名声流布故。诸人为僧作供养前食后食。是中有一贫穷女人。信敬独请长老莎伽陀。莎伽陀默然受。受已是女人为办多酥乳糜。受而食之。女人思惟。是沙门啖是多酥乳糜。或当冷发。便取似水色水香水味酒持与。是莎伽陀不看即饮。饮已为说法便去。还向寺中。尔所时间酒势便发。近寺门边倒地。僧伽梨郁多罗僧安陀卫水囊钵杖油囊革屣针线囊各在一处。身在一处醉无所觉。尔时佛与阿难游行到是处。佛见是比丘。知而故问阿难。此是何人。答言。世尊。此是长老莎伽陀。佛即语阿难。是处为我敷坐床办水集比丘僧。阿难受教即敷坐床办水集比丘僧已。往白佛言。世尊。我已敷坐床办水集比丘僧。佛自知时。佛即洗足。坐阿难所敷床上。问诸比丘。汝等曾见曾闻。有龙名庵婆罗提他。凶暴恶害。先无有人到其住处。象马牛羊骡驴骆驼无能近者。乃至诸鸟无敢过上。秋谷熟时破坏诸谷。善男子莎伽陀。能折伏令善。诸人鸟兽得到泉上。是时众中有见者言见。闻者言闻。佛语诸比丘。于汝意云何。此善男子莎伽陀。今能折伏虾蟆不。答言。不能世尊。佛言。如是过罪若过是罪。皆由饮酒故。从今日若言我是佛弟子者。不得饮酒。乃至小草头一滴亦不得饮。佛种种因缘诃责饮酒已。语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘饮酒者波逸提。酒者有二种。谷酒木酒。谷酒者。用食用麴用米。或用根茎华叶果。用种种子用诸药草。杂作酒。酒色酒香酒味。饮能醉人者。是名谷酒。木酒者。不用食不用麴米。但用根茎叶华果。若用种种子作酒。酒色酒香酒味。饮能醉人。是名木酒。复有木酒。不用食不用麴米根茎叶华果。但用诸种子诸药和合作酒。酒色酒香酒味。饮能醉人。是名木酒。及前谷酒皆名为酒。若比丘取尝。咽者亦名为饮。是谓饮酒波逸提。波逸提者煮烧覆障。若不悔过能障碍道。是中犯者。若比丘饮谷酒。随咽咽波逸提。若比丘饮木酒。随咽咽波逸提。若比丘饮酢酒。随咽咽波逸提。若饮甜酒。随咽咽波逸提。若啖麴能醉者。随咽咽波逸提。若啖酒糟。随咽咽波逸提。若饮酒淀随咽咽波逸提。若饮似酒色酒香酒味能令人醉者。随咽咽波逸提。若酒色酒香酒味。若酒色酒香。若酒色酒味。若酒香酒味。饮者随咽咽波逸提。不犯者。若但作酒色。无酒香无酒味。不能醉人。饮者不犯(七十九竟)

佛在王舍城。尔时诸比丘。中前入聚落中后出。中后入聚落中后出。不知出入聚落时节。诸外道出家人嫉心诃骂言。余出家人。中前入聚落中前出。食后还自住处。皆同和合默然隐住。如鸟母中时自于巢中伏住令子暖。是沙门释子自言。善好有德。而今中前入聚落中后出。中后入聚落中后出。不知入出时节。是中有比丘。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集比丘僧。语诸比丘。云何名比丘。中前入聚落中后出。中后入聚落中后出。不知出入时节。佛尔时但诃责而未结戒。又佛在舍卫国。尔时长老迦留陀夷得阿罗汉道。心中作是念。我先在六群比丘中。于舍卫国污辱诸家。我今当还令此诸家清净。作是念已。入舍卫国俱度九百九十九家。若夫得道而妇不得。若妇得道而夫不得。则不说数。但数夫妇俱得道者。尔时舍卫城有一婆罗门家。应以声闻得度。迦留陀夷作是念。我复能度是家者。于舍卫城中满千家俱度。作是念已。过夜晨朝着衣持钵入舍卫城乞食。游行到是婆罗门舍。尔时婆罗门有小因缘不在。是婆罗门妇闭门作煎饼。迦留陀夷即入禅定。于门外没在庭前现。从禅定起弹指。妇即回顾即见。便看门犹闭。作是念。此沙门从何处入。此必贪饼故来。我终不与。若使眼脱我亦不与。即以神力两眼脱出。见已复念。出眼如碗我亦不与。即以神力变眼如碗。见已复念。倒立我前亦不能与。即以神力于前倒立。复念若死我亦不与。复以神力入灭受想定。心想皆灭无所觉知。尔时婆罗门妇见已。唤问牵挽不动。妇即惊怖作是念。是沙门大恶乃尔。此常出入波斯匿王所。末利夫人师。若闻某婆罗门家死者。我等得大衰恼。若活者我与一饼。迦留陀夷即出灭受想定。身动便起。妇即看饼。先所煎者皆好。意惜不与。当更煎之。即煎转胜。复不以与。即刮盆边取残面煎。复胜于前。复作是念。此等皆好。当以先者与之。适举一饼。余皆相着。迦留陀夷言。姊随心欲与我几许便取。即举四饼持与迦留陀夷。迦留陀夷不受言。我不须是饼。若汝欲施者可以与僧。是婆罗门妇。先世曾供养佛种善根。近正见利根。本因缘强。堪任今世得道。诸善根牵故。便作是念。是比丘实不贪饼。但愍我故来。即作是念。我所有饼尽当与僧。语言善人。我尽持筐饼施僧。答言随意。即持饼筐诣只桓中。打揵捶集比丘僧。与僧饼竟。在迦留陀夷前坐听说法。尔时迦留陀夷。即随顺观本因缘为说妙法。即于座上远尘离垢。于诸法中得法眼净。是女人闻法知法见法入法。度疑悔不随他。于佛法中得自在。心无所畏。从坐起头面礼迦留陀夷足言。我从今日归依佛归依法归依僧。知我尽形作佛优婆夷。时迦留陀夷。复为说法示教利喜。示教利喜已默然。是女人闻法示教利喜已。头面礼长老迦留陀夷足右绕而去。还到自舍。时夫于后来还。妇语夫言。汝去后我闭门作煎饼。时阿阇梨迦留陀夷来。现种种神力。我持是饼与只桓僧。阿阇梨迦留陀夷为我说法。我得须陀洹道。汝今可往。亦当为汝说法。是婆罗门。前世曾供养佛种善根。近正见利根。本因缘强。堪任今世得道。诸善根力牵故。便往诣长老迦留陀夷所。头面礼足在前而坐。迦留陀夷即随顺观本因缘为说种种妙法。即于座上远尘离垢得法眼净。是婆罗门闻法知法见法入法。度疑悔不随他。于佛法中得自在。心无所畏。从座起头面礼长老迦留陀夷足言。我从今日归依佛归依法归依僧。知我尽形作佛优婆塞。迦留陀夷。复为婆罗门说种种法示教利喜。示教利喜已默然。婆罗门闻法示教利喜已。从座起头面礼足右绕而去。还到自舍语妇言。我等无有善知识大利益我等如阿阇梨迦留陀夷者。何以故。我等因阿阇梨迦留陀夷故。破二十身见。断三恶道。无量苦恼令作有量。入正定见四谛。大德迦留陀夷所须衣被饮食卧具汤药种种生活具。我等当与。妇言。便往自恣请。婆罗门即时往诣只桓。到迦留陀夷所。头面礼足在前而坐。坐已语迦留陀夷。大德知不。我等无有善知识大利益我等如大德者。何以故。我等因大德迦留陀夷故。破二十身见。断三恶道。无量苦恼令作有量。入正定见四谛。大德。若有所须衣服饮食卧具汤药种种生活具。自恣受我请。当随意取。答言尔。是迦留陀夷。有所须衣食卧具汤药。往彼取之。是婆罗门有一儿。学婆罗门法。妇婆罗门女。父母语儿言。汝知不。我等更无好知识大利益我等如大德迦留陀夷者。何以故。我等因大德迦留陀夷故。破二十身见断三恶道。无量苦恼令作有量。入正定见四谛。如汝好供养我等。若我等死后。当如是供养大德迦留陀夷。儿答言尔。世法无常如偈所说

  常者皆尽　　高者亦堕　　合会有离
  生者有死

是儿父母死已。作孝除服洗浣竟。往诣迦留陀夷所。头面礼足在一面坐。白言。我视大德迦留陀夷。如父母无异。若有所须衣服饮食卧具汤药种种生活具。自恣受我请。当随意取。如从我父母取。答言尔。尔时迦留陀夷所须衣服饮食卧具汤药。从彼家取。尔时有五百贼。作恶事竟入舍卫城。贼主年少端正。婆罗门儿妇机上遥见。心生染着。便唤婢使语。其人来入共相娱乐。是婢即往语言。某婆罗门妇唤汝来。入共相娱乐。贼主即入。一时迦留陀夷。晨朝着衣持钵入是婆罗门舍。妇为敷座。坐已共相问讯在一面坐。婆罗门儿妇。疾为办饮食。自手行水。自与多美饮食。自恣饱满竟。行水洗手。取小床坐听法。尔时迦留陀夷。为种种因缘诃责淫欲。赞叹离淫欲。种种因缘诃责破戒。赞叹持戒。如是说法已从坐起去。时妇作是念。是比丘种种因缘诃责淫欲赞叹离欲诃责破戒赞叹持戒。是比丘必当见我二人共作恶事。是故作是语。我夫更无同心爱念如是沙门者。若以是事语我夫者。我当受大苦恼。作是念已语贼言。汝闻沙门种种因缘诃责淫欲赞叹离欲诃责破戒赞叹持戒耶。是比丘必当见我等二人共作恶事。我夫更无同心爱念如是沙门者。若以是事语我夫者。我等当受大苦恼。贼主言。余当云何。答言。当除灭去。贼主言。此有大威德力。净饭王师婆罗门子。常出入波斯匿王所。末利夫人师。云何可杀。答言。我能作因缘必令可杀。是女人中后佯病卧地。遣人往唤迦留陀夷言。来看我病。迦留陀夷中后着衣往看。即与坐处共相问讯。迦留陀夷就坐。种种因缘为说法。示教利喜已欲起去。妇言。善人莫去。随尔所时为我说法。我渐小差。苦受灭乐受生。迦留陀夷闻是语已。复为说种种法。示教利喜已欲去。又言。善人莫去。随尔所时为我说法。我便得差。苦受灭乐受生。迦留陀夷复为更说种种法示教利喜乃至日没。闇时迦留陀夷起到粪聚所。贼主以利刀断头埋着粪中。是时说戒日。只桓中行筹。长一筹。共相谓言。谁不来者。比坐皆言迦留陀夷不来。谁受欲。答言无有。诸比丘不知云何。是事白佛。佛语诸比丘。汝等作布萨说戒。迦留陀夷已入涅槃。我与善男子迦留陀夷。少一身不满五百世共伴。今则别离。佛过夜已。晨朝着衣众僧围绕恭敬。入舍卫城到粪聚所。佛神力故。死尸踊出在虚空中。诸比丘取着床上持出城。诸比丘及弟子。以大德供具烧身起塔供养。波斯匿王。闻长老迦留陀夷某婆罗门家死。即灭七世。左右十家皆夺财物。捕取五百贼悉截手足着只桓堑中。诸比丘入城乞食。闻是事已白佛。佛言。如是过罪及余过罪。皆由非时入聚落。佛言。若迦留陀夷不非时入聚落者。不于是婆罗门家为人所杀。佛种种因缘诃责非时入聚落已。语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘非时入聚落波逸提。非时者。过日中后至地未了。是中间名为非时。聚落者。白衣舍。波逸提者。煮烧覆障。若不悔过能障碍道。是中犯者。若比丘非时入聚落波逸提。随所入随一一波逸提。尔时为病比丘。欲从白衣舍索羹饭饮食粥。不得去故。看病比丘苦恼。病者增长。诸比丘不知云何。是事白佛。佛以是事集比丘僧。种种因缘赞戒赞持戒。赞戒赞持戒已语诸比丘。从今是戒应如是说。若比丘非时入聚落。不白余比丘波逸提。余比丘者。谓眼所见。是中犯者。若比丘在阿练儿处。白余比丘入聚落。从聚落还到阿练儿处。即以先白。复至聚落。波逸提。又比丘在阿练儿处。白余比丘入聚落。从聚落入聚落僧坊。即以先白。复至聚落波逸提。又比丘在阿练儿处。白余比丘入聚落。从聚落入所住处。即以先白。复入聚落波逸提。若比丘在聚落僧坊。白余比丘入聚落。从聚落还入聚落僧坊。即以先白复至聚落波逸提。又比丘在聚落僧坊。白余比丘入聚落。从聚落至所住处。即以先白复入聚落波逸提。又比丘在聚落僧坊。白余比丘入聚落。从聚落至阿练儿处。即以先白复入聚落波逸提。若比丘在所住处。白余比丘入聚落。从聚落至所住处。即以先白复入聚落波逸提。又比丘在所住处。白余比丘入聚落。从聚落至阿练儿处。即以先白复入聚落波逸提。又比丘在所住处。白余比丘入聚落。从聚落入聚落僧坊。即以先白复入聚落波逸提。若比丘非时入聚落。不白余比丘。随所经过大巷小巷。随得尔所突吉罗。随入白衣家。随一一波逸提。有一比丘。寄衣在居士舍。是比丘闻居士舍为火所烧。忘不白余比丘。从僧坊出向聚落。尔时忆念。我不白余比丘。忆已道中还至僧坊。白余比丘。尔所时间居士舍烧尽。比丘衣亦俱烧尽。居士言。汝何故后来。若先来佐我救火者。汝衣亦当不烧。是比丘不知云何。以是事白佛。佛以是事集比丘僧。种种因缘赞戒赞持戒。赞戒赞持戒已语诸比丘。从今是戒应如是说。若比丘非时入聚落。不白余比丘波逸提。除急因缘。急因缘者。若聚落失火。若八难中一一难起去者。不犯(八十竟)

佛在舍卫国。尔时有一居士。因跋难陀释子。请佛及僧明日食。佛默然受请。居士知佛默然受已。从坐起头面礼佛足右绕而去。还自舍通夜办种种多美饮食。跋难陀常出入多家。晨朝着衣持钵入诸家。时僧坊中无有人唱时到。亦无打犍捶者。佛告阿难。时到汝自知之。阿难即令唱时到打揵槌。佛及僧入是居士舍。无有人迎佛作礼敬敷坐处者。时佛语阿难。今时所应作者便作。阿难即约敕主人令敷座处。即敷座处。佛及僧坐已。佛语阿难。所应次第作事汝自当知。阿难即时语居士言。佛及僧坐久。食具已办。何不下食。居士言。小住。待跋难陀释子来。佛小默然。第二复语阿难。次第所应作事汝自当知。阿难第二复语居士。食具已办。可与佛及僧。居士言。小住。待跋难陀释子来。佛复默然。第三复语阿难。今时次第所应作事汝自当知。阿难第三复语居士。佛及僧坐久。食具已办可与佛及僧。居士复言。是会因跋难陀释子。跋难陀释子若来者当与若不来者或与或不与。若须食者当住待跋难陀。时跋难陀曰。时欲过方来。居士即自手行水。自与多美饮食。自恣饱满已。跋难陀先疾食竟便起入余家。尔时居士以多美饮食。自恣与佛及僧竟。自行水知佛洗手摄钵。取小床坐佛前听说法。佛以种种因缘说法示教利喜已。佛及僧从座起去。佛食后语阿难。为我敷坐床办水集比丘僧竟语我。阿难受教即敷坐床办水集比丘僧往白佛言。世尊。我已敷座办水集比丘僧。除一比丘跋难陀释子。佛自知时。尔时跋难陀至日暮乃来。阿难第二复到佛所。白言世尊。我已敷座办水集比丘僧。佛自知时。尔时世尊洗脚已。便坐阿难所敷床上。语诸比丘。跋难陀痴人。今日两时恼僧。中前以饮食因缘。中后以集僧因缘。佛种种因缘诃责已。语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘许他请僧。中前中后行到余家。波逸提。许请僧者。许为檀越请众僧来。中前者。从地了至日中。中后者。过日中至地未了。行诸家者。白衣舍名为家。行者。与白衣同心入出。波逸提者。煮烧覆障。若不悔过能障碍道。是中犯者。若比丘在阿练儿处。白余比丘入聚落。从聚落还阿练儿处。即以先白复至聚落。波逸提。又比丘在阿练儿处。白余比丘入聚落。从聚落入聚落僧坊。即以先白复至聚落。波逸提。又比丘在阿练儿处。白余比丘入聚落。从聚落入所住处。即以先白复入聚落。波逸提。若比丘在聚落僧坊。白余比丘入聚落。从聚落还入聚落僧坊。即以先白复至聚落。波逸提。又比丘在聚落僧坊。白余比丘入聚落。从聚落至所住处。即以先白复入聚落。波逸提。又比丘在聚落僧坊。白余比丘入聚落。从聚落至阿练儿处。即以先白复入聚落。波逸提。若比丘在所住处。白余比丘入聚落。从聚落还至所住处。即以先白复入聚落。波逸提。又比丘在所住处。白余比丘入聚落。从聚落至阿练儿处。即以先白复入聚落。波逸提。又比丘在所住处。白余比丘入聚落。从聚落入聚落僧坊。即以先白复入聚落。波逸提。若比丘为檀越家请比丘僧宿。是比丘不白诸比丘出至檀越舍界。随所经过大巷小巷。随得尔所突吉罗。随至他家。随得尔所波逸提(八十一竟)

十诵律卷第十七十诵律卷第十八(第三诵之五)

        后秦北印度三藏弗若多罗译

    九十波逸提之十

佛在舍卫国。尔时波斯匿王作是法。若佛在祇洹。我当日日自往奉见。尔时波斯匿王。闻佛在祇洹。即敕人民扫除祇洹。皆令净洁我欲见佛。受敕扫洒除却众人。唯有一人。着故弊衣在佛前坐听法。敬难佛故不敢驱去。使者白王。我已扫除祇洹净洁。唯有一人。着弊故衣近佛坐听法。我等敬难佛故不敢驱却。王言。一人着弊故衣在佛前坐。当何所能即敕御者。驾乘调车我欲见佛即严驾车。往白王言。已严驾善车。王自知时。王即上车。出舍卫城往诣祇洹。至下乘处步入祇洹。尔时大众遥见王来。皆起迎王。有一须达居士佛边听法。恭敬佛故不起迎王。王即嗔言。此是何人。着弊故衣在佛前坐见我不起。我是浇顶大王。我境界中得自在。无死罪者能杀。有死罪者能放。以敬佛故嗔不出口。直诣佛所头面礼足却坐一面。佛为种种说法示教利喜。不入王心。嗔是人故。诸佛常法。不为不一心人说法。佛即问王。何故以二心听法。王言。世尊。此是何小人。着弊故衣在佛前坐。见我来不起立迎。我于国中得自在。无死罪者能杀。有死罪者能放。须达居士言。大王不知耶。我于佛前坐听法。恭敬佛故不起迎王。无有憍慢。王时大羞小退一面。问诸大臣。此是何人。着弊故衣在佛前坐。不起迎我。诸大臣言。大王。此名须达居士。是佛弟子得阿那含道。在佛前坐听法。敬佛故不起。无憍慢心。王闻是语嗔心小息。便作是念。佛法大力。令人心大得无畏力。我今何不令诸夫人受学佛法令得大心。时王语诸夫人。使从比丘受学经法。诸比丘不欲教授。作是言。佛未听我等教诸夫人法。是事白佛。佛言。从今听比丘教授诸夫人法。时诸夫人各各自请经师。有夫人请舍利弗者。有请目连者。有请阿那律者。时末利夫人。请迦留陀夷为师。尔时诸夫人次第直宿于王。时末利夫人。下着珠网衣。上着磨贝衣。内身露现。如共王宿时。即着是衣出。在中庭床上坐。尔时迦留陀夷地晓时。着衣持钵入王宫。至门下立弹指。末利夫人看见师来。便言师入。即生惭羞。胡跪而坐不得起。迦留陀夷见已亦羞。还出到祇洹中。以是事向诸比丘说。诸比丘以是事向佛广说。佛语诸比丘。若如是过失及过是过失。皆由数入王家故。佛言。若比丘入王家有十种过失。何等十。若王与夫人共坐。比丘来入。尔时夫人见比丘或笑。比丘见夫人或笑。尔时王作是念。如夫人见比丘笑。比丘见夫人笑。此比丘必起恶业。是名第一过失。复次王共夫人宿。不自忆念。是夫人或出外住。行还有娠。时王见比丘入出。王作是念。是夫人出外。比丘数入出。必共起恶业。是名第二过失。复次王家失五宝若似五宝。王见比丘入出。是中必当起恶业。是第三过失。复次王秘密语论事。或有内鬼神。持外唱说。王作是念。如此密语外人得闻。是比丘常入出。必是比丘所传。是名第四过失。复次王欲杀王子。或时王子欲杀王。是中有不喜者。谓比丘所作。作是念。我宁莫与比丘共事。是第五第六过失。复次王欲迁小为大。或欲退大为小。是中有不喜者。谓比丘所作。作是念。我宁莫与比丘共事。是名第七第八过失。复次王大严驾幢幡鸣鼓。若乘象马辇舆出驱人远道。是中有不爱比丘者。见比丘在王边。必谓是比丘所作。作是念。我宁莫与比丘共事。是名第九过失。复次王灭敌国。敌国调伏时。应死者敕杀。又唱莫杀。是中不喜者言。我宁莫与比丘共事。是名第十过失。佛语诸比丘。诸王家多有象兵马兵车兵步兵。是家中与白衣相宜。非比丘所宜。种种因缘呵责入王家已。语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘水浇顶刹利王家。夜未过未藏宝。若过门闑及闑处。波逸提。王者。刹利种受水浇顶受王职。是名为王刹利浇顶。若婆罗门若居士乃至女人。受是浇顶王职。亦名为王刹利浇顶。夜未过者王未出故。夫人未入故。未藏宝者。未藏庄严具。未举藏故。门闑者门中相。闑处者。是门中地可安闑处。波逸提者。煮烧覆障。若不悔过能障碍道。是中犯者。王未出夫人未入未藏宝。尔时比丘入王门。得波逸提。若王虽出夫人未入未藏宝。尔时比丘入王门。得波逸提。若王出夫人入未藏宝。比丘尔时入王门。得波逸提。若王出夫人已入已藏宝物。比丘尔时入王内门不犯。佛在俱舍弥国。尔时优填王千夫人。五百人为一部。舍弥婆提为一部首。阿奴跋摩为一部首。是中舍弥婆提所领五百人。善好有功德。阿奴跋摩所领五百人。恶邪不善。尔时优填王有小国反叛。王作是念。我当留谁镇后令无恶事自往破贼。王作是念。摩揵提婆罗门利根有威德。是我妇父。我当留镇后自往破贼。我于是人无有恶事后无忧悔。王作是念已。即令婆罗门镇城。自往破贼。时诸城邑聚落名声流布。王令摩揵提婆罗门守城。后日早起百千种人。在婆罗门门下。有立赞叹者。有称吉者。有合掌恭敬礼拜者。有饷象马车乘牛羊驼驴者。有饷金银琉璃砗璖玛瑙者。摩揵提婆罗门作是念。我得如是富贵势力者。皆是我女力故。我当以何报是女。若与金银琉璃砗磲玛瑙者宫中不少。女人所有怨嫉忧毒无过对妇。若令舍弥婆提五百夫人死者。乃当报女恩。我何故不杀。今不可直杀。当作方便火烧杀之。作是念已。遣使语舍弥婆提夫人。汝如我女无异。若须苏油薪草材木树皮松明。遣人来取。即敕所典。舍弥婆提夫人遣人来。索苏油薪草两三倍与。受教言尔。女人性贪喜集财物。以易得故多取积聚。满宫房舍窗向栏楯诸楼阁间及床榻下。诸瓮瓮器皆悉盛满。摩揵提婆罗门。知火具已多。敕闭宫门放火烧之。即时人民闻王宫中失火。畏王刀力鞭杖力嗔力故。多人俱集欲破门入。摩揵提婆罗门深恶心故。作是念。若人民破门入者。或能灭火令不烧死。作是念已。语诸人民。汝等不知王心妒耶。若闻诸人破门入者。奸我宫人必当大嗔。诸人言。今当云何。答言。当缚木梯蹬入。如是集木作梯。闻舍弥波提及五百女人皆已烧死。遣人白王。宫中失火。舍弥波提夫人等五百人火所烧死。王闻是事心生忧恼。作是言。如是好福田人。今永别离。王以愁忧因缘迷闷欲死即堕床。诸臣以水洒面即便得醒。诸大臣言。王莫愁忧。更当起宫殿集诸婇女。尔时王破贼已。还至城外住。我不入城。乃至新宫殿竟。满五百女人当入城住。王以鞭杖力刀力槊力健嗔力故。宫殿速成。选取贵人女亿财主居士女。得五百人满宫中。有居士。名瞿师罗居士。有女。是舍弥波提夫人妹。名威德。是女于千夫人中最上。诸臣白王。新宫已成。诸夫人已满。王自知时。即入新宫。与新女共相娱乐。王渐渐推问因缘。后知摩揵提婆罗门为自女故作是恶事。即遣人唤婆罗门来。语言。汝出我国去。我不喜杀婆罗门。王即约敕。杀阿奴跋摩夫人。时诸新女。为王所亲信故。便白王言。是舍弥波提夫人等。长夜亲近供养佛及僧。愿听我等供养佛及僧。王时作是言。佛不听诸比丘入王宫。即时诸女。欲令王起憍慢心故。作是言。王有大威德力势。诸大事尚能办。何况此事。愿王当成我等供养事。诸女急白故。令王发憍慢心。即便听许。王问诸女。汝等实欲作供养耶。答言欲作。汝等随力办供养具。诸女有办僧伽梨者。有办郁多罗僧者。有办安陀卫者。有办钵者。有办漉水囊油囊杖针綖囊。尔时王唤巧匠问言。汝能令诸夫人不出于宫中得供养佛及僧耶。答言可得。王言云何。答言。当作行轮宫殿。即敕令速作。作已白王。轮宫已成。王自知时。王即诣佛所。头面礼足却坐一面。佛以种种因缘说法示教利喜。示教利喜已默然。王知佛种种因缘说法示教利喜已。从坐起偏袒右肩合掌。白佛言。愿佛及僧。受我明日请。佛默然受。王知佛受已。头面礼佛足右绕而去。是夜敕办多美种种饮食。晨朝敷座处。遣使白佛时到。食具已办。佛自知时。诸比丘往诣王宫。佛自房住迎食分。尔时巧匠知僧来至。即出轮宫围绕众僧。王知僧坐已。自手行水。自与多美饮食自恣饱满。即开宫门。诸女皆出问讯诸比丘。有问父母者。姊妹兄弟者。及问讯佛者。尔时长老舍利弗为上座语诸比丘。我等今日不在王宫耶。当共一心。王知僧食已。自行澡水。取小坐床坐僧前听说法。语诸夫人所欲供养者。今正是时。有夫人施僧伽梨者。施郁多罗僧者。施安陀卫者。有施钵者。有施漉水囊者。有施针綖囊者。尔时诸比丘皆得满手满钵物。相视而坐。王有方便。心念。当云何令诸比丘经宫中过。即令轮宫遮先来道。便白僧言。大德可去。诸比丘言。佛不听我等入王宫中。王言。我今教出不教入。尔时舍利弗咒愿已。及僧从座起去。还到僧坊。以是事向佛广说。佛以是事集比丘僧。种种因缘赞戒赞持戒。赞戒赞持戒已语诸比丘。从今是戒应如是说。若比丘水浇顶刹利王。夜未过未藏宝。若过门闑及门闑处。除急因缘波逸提。急因缘者。若王遣使唤比丘。若夫人王子如是等诸有力官属。唤皆不犯(八十二事)

佛在俱舍弥国。尔时长老阐那比丘有可悔过罪。诸比丘怜愍慈心求安隐故。教令悔过。阐那言。我始知是事入戒经中半月次来所说。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘呵责。云何名比丘。犯可悔罪。诸比丘怜愍教令悔过。便作是言。我今始知是事入戒经中半月次来所说。种种因缘呵已向佛广说。佛以是事集比丘僧。知而故问阐那言。汝实作是事不。答言。实作世尊。佛以种种因缘呵责阐那。云何名比丘。犯可悔过罪。诸比丘怜愍教令悔过。便作是言。我今始知是事入戒经中半月次来所说。种种因缘呵已语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘说戒时。作是言。我今始知是事入戒经中随半月次来所说。诸比丘知是比丘先曾再三闻说此戒。何况复过。是比丘非以不知故得脱。随所犯事。应令如法悔过。应更呵令折伏。汝失无利是恶不善。说戒时不尊重戒不一心听。以是事故得波逸提。波逸提者。煮烧覆障。若不悔过能障碍道。是中犯者。若比丘说四波罗夷时。作是言。我今始知是法入戒经中随半月次来所说。得波逸提。若说十三僧伽婆尸沙时。若说二不定法时。若说三十尼萨耆波逸提时。若说九十波逸提时。若说四波罗提提舍尼法时。若说众多学法时。若说七止诤法时。及说随律经时。作是言。我今始知是法入戒经中随半月次来所说。得波逸提。除随律经。说余经时作是言。我今始知是法入戒经中。突吉罗(八十三事)

佛在舍卫国。尔时舍卫城有治角师。名达摩提那。富饶财宝种种成就。是人随佛及僧所须物自恣请与。谓衣钩禅镇衣钉钵支匕针筒。如是诸比丘众多。数数往取。是人作不能供妇儿空乏。余居士嗔责呵言。沙门释子不知量不知厌足。若施者不知量。受者应知量。是达摩提那居士本富饶财。布施不知量故与。不能供妇儿空乏。是中有比丘。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集比丘僧。种种因缘呵责诸比丘。云何名比丘。不知时不知量。若施者不知量。受者应知量。是达摩提那居士。本富饶财布施不知量故与。不能供妇儿空乏。种种因缘呵已语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘骨牙齿角作针筒者波逸提。骨者。象骨马骨蛇骨。牙者。象牙马牙猪牙。齿者。象齿马齿猪齿。角者。羊角牛角水牛角鹿角。波逸提者。煮烧覆障。若不悔过能障碍道。是中犯者。若比丘骨作针筒。波逸提。若牙若齿若角。随作随得尔所波逸提。若比丘用骨牙齿角作针筒者。是比丘应破是针筒已。入僧中唱言。我用骨牙齿角作针筒。得波逸提罪。我今发露悔过不覆藏。僧应问汝破针筒未。若言已破。僧应问。汝见罪不。若言见罪。应教言。汝今发露悔过。后莫复作。若未打破。僧应约敕令破。若僧不约敕。一切僧得突吉罗罪。若僧约敕不受。是比丘得突吉罗罪(八十四事)

佛在俱舍弥国。尔时长老阐那。用高广好床。佛与阿难游行到阐那房。是阐那遥见佛来。从坐起偏袒右肩合掌白佛言。世尊。入我房舍看床。佛即入见。是床高好见已语阿难。染污烂坏。云何是痴人。用如是高广好床。佛种种因缘呵责阐那。云何名比丘。用高广好床。佛种种因缘呵已。集比丘僧语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘欲作床者。当应量作。量者。足高八指。除入梐。过是作者波逸提。床者有二种。细梐绳床粗梐绳床。粗梐绳床有五种。阿珊蹄脚。波郎劬脚。羝羊角脚。尖脚曲脚。细梐绳床亦有五种。阿珊蹄脚。波郎劬脚。羝羊角脚。尖脚曲脚。高八指者。佛言。用我八指。第三分入梐。波逸提者。煮烧覆障。若不悔过能障碍道。是中犯者。若比丘过八指作床脚者波逸提。随作随得尔所波逸提。若比丘过八指作床脚者。应截脚入。僧中白言。我过八指作床脚得波逸提罪。今僧中发露悔过不覆藏。僧应问。汝截未。若言已截。问汝见罪不。若言见罪。僧应言。汝如法悔过后莫复作。若言未截。僧应约敕令截。若僧不约敕令载者。僧得突吉罗。若僧约敕不受。是比丘得突吉罗(八十五事)

佛在王舍城。尔时六群比丘以草木兜罗绵贮卧具。诸居士嗔不喜呵骂。沙门释子自言。善好有功德。乃以兜罗绵贮卧具。如王如大臣。是中有比丘。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集比丘僧。知而故问六群比丘。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘。以兜罗绵贮卧具。种种因缘呵已语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘自以兜罗绵贮卧具。若使人贮波逸提。兜罗绵者。柳华白杨华阿鸠罗华。波鸠罗华鸠舍罗华。间阇华。波波阇华。离摩华。皆波逸提。波逸提者。煮烧覆障。若不悔过能障碍道。是中犯者。若比丘以草木兜罗绵贮卧具波逸提。随贮随得尔所波逸提。若比丘以兜罗绵贮卧具者。是比丘应摘破却兜罗绵。到僧中白言。我以兜罗绵贮卧具得波逸提罪。发露悔过不覆藏。僧应问。汝摘却未。若言已却。僧应问。汝见罪不。若言见罪。僧应约敕。汝如法悔过后莫复作。若言未摘。应约敕令摘。若不约敕。僧得突吉罗。若僧约敕不受。是比丘得突吉罗罪(八十六事)

佛在舍卫国。尔时毗舍佉鹿子母。往诣佛所头面礼足却坐一面。佛以种种因缘说法示教利喜。示教利喜已默然。知佛说法示教利喜默然已。从坐起偏袒右肩合掌白佛言。世尊。愿佛及僧受我明日请。佛默然受之。知佛默然受已。头面礼佛足右绕而去。还自舍通夜办种种多美饮食。佛是夜共阿难露地游行。佛看星宿相。语阿难言。若今有人问知星宿相者。何时当雨。彼必言七岁当雨。佛语阿难。初夜过已至中夜。是星相灭。更有异相出。若尔时有人问知相者。何时当雨。彼必言过七月当雨。又语阿难。中夜已过至后夜。是星相灭更有异相出。若尔时问知相者。何时当雨。彼必言七日当雨。是夜已过地了时。东方有云出。形如圆碗遍满空中。是云能作大雨满诸坑坎。尔时佛语阿难。语诸比丘。是碗云雨有功德。能除病。若诸比丘欲洗者。当露地立洗。阿难受教语诸比丘。是碗云雨有功德。能除病。若诸比丘欲洗者。听露地立洗。时诸比丘随意露地立洗。尔时毗舍佉鹿子母。办饮食已早起敷座处。遣婢使白佛时到。食具已办佛自知时。婢受教往诣祇洹。觅诸比丘不见。于门孔间看。见裸形露洗。见已心不喜。作是念。是中都无比丘。尽是裸形外道无惭愧人。作是念已。即还语毗舍佉鹿子母言。祇洹中无一比丘。尽是裸形外道。是毗舍佉母智慧利根。知今日雨堕。诸比丘必当露地裸形洗浴。是婢痴无所知故作是言。祇洹中无一比丘。尽是裸形外道。即便唤余婢往诣祇洹。打门作声白言。时到食具已辨。即受教去。往到祇洹打门作声白言。时到食具已办佛自知时。尔时佛与大众。着衣持钵众僧围绕俱诣其舍。佛在僧中坐。毗舍佉母自行澡水。自手与多美饮食。食已自手行水。知收钵已。持小床坐佛前听说法。白佛言。世尊。与我愿。佛言。诸多陀阿伽度阿罗呵三藐三佛陀。不得与汝过愿。毗舍佉言。与我可得愿。佛言。与汝可得愿。汝欲得何愿。毗舍佉言。一者我欲与比丘僧雨浴衣。二者与比丘尼僧浴衣。三者客比丘来我与食。四者远行比丘我与食。五者病比丘我与饮食。六者看病比丘我与饮食。七者我常与比丘僧粥。八者多知识少知识比丘。我与病缘汤药及所须物。佛言。汝见何因缘故。欲与比丘僧雨浴衣。答言。大德。我今日早起敷座已。遣婢使诣祇洹白佛时到婢至门间见诸比丘露地雨中裸形洗浴。婢还言。祇洹中无一比丘。但诸外道无惭愧人。大德。比丘裸形在佛前和上阿阇梨一切上座前。则为无羞。是故欲与比丘僧雨浴衣。着自在露地雨中洗浴。毗舍佉。汝见何因缘故。欲与比丘尼僧浴衣。答言。大德。我一时与诸居士妇共至阿耆罗河中洗浴。时诸比丘尼亦入河中裸形洗浴。诸居士妇见已心不喜。呵责言。是辈薄福德不吉粗身大腹垂乳。何用学梵行为。大德。女人裸形丑恶。是故我欲与浴衣。毗舍佉。汝见何因缘故。欲与客来比丘饮食。答言。大德。客来比丘不知何处可去不可去。道路疲极未得休息。是故我欲与饮食后。随知可去不可去处。毗舍佉。汝见何因缘故。欲与远行比丘食。答言。大德。远行比丘。若待食时怛钵那时。若行乞食则伴舍去。或夜中入崄道。或独行旷野。我与食故。不失伴不入崄道。是故我与饮食。毗舍佉。汝见何因缘故。欲与病比丘饮食。答言。大德。病比丘不得随病饮食。则病难差。是故我与随病饮食。则病易差。毗舍佉。汝见何因缘故。欲与看病比丘饮食。答言。大德。看病比丘。若待僧中食后食。若行乞食去。是病比丘瞻养事阙。若煮饭作粥作羹。煮鱼肉煮汤药。出内大小便不净器若弃唾器。是故我与看病比丘饮食。瞻养不阙。便得煮饭作粥作羹煮肉及煮汤药。出内大小便器弃唾器。毗舍佉。汝见何因缘故。欲常与比丘僧粥。答言。大德若比丘不食粥。有饥渴恼。或时腹内风起。我常与粥故则无众恼。毗舍佉。汝见何因缘故。欲与多知识少知识比丘病缘汤药及所须。物答言。病比丘必欲得汤药所须诸物。以是故我与。复次大德。我若闻某比丘彼住处死。佛记彼比丘三结断得须陀洹。不堕恶道必得涅槃极至七生天人中往返得尽众苦。大德。我当问。是长老曾来舍卫国不。若我闻是比丘曾来舍卫国。我思惟。是长老或受我雨浴衣。或受客比丘饮食。或远行饮食。或随病饮食。或看病饮食。或常与粥。或病比丘汤药诸物。大德。我以是因缘故觉意满。大德。我若闻某比丘彼住处死。佛记彼比丘三结尽三毒薄得斯陀含一来是世得尽苦际。我当问。是长老曾来舍卫国不。若我闻是比丘曾来舍卫国。大德。我如是思惟。是长老或受我雨浴衣。或受客比丘饮食。或受远行饮食。或随病饮食。或看病饮食。或常与粥。或病比丘汤药诸物。大德。我以是因缘故觉意满。大德。我若闻某比丘彼住处死。佛记彼比丘得阿那含五下结尽便于天上般涅槃不还是间。大德。我当问。是长老曾来舍卫国不。若我闻是比丘曾来。我思惟。是长老或受我雨浴衣。或受客比丘饮食。或远行饮食随病饮食。看病饮食或常与粥。病比丘汤药诸物。大德。我以是因缘故觉意满。大德。我若闻某比丘彼住处死。佛记彼比丘得阿罗汉我生已尽梵行已立所作已办自知作证。我当问。是长老曾来舍卫国不。若我闻是比丘曾来。我思惟。是长老或受我雨浴衣。或受客比丘饮食远行饮食。随病饮食看病饮食。或常与粥病比丘汤药诸物。我以是因缘故觉意满。大德。如是我财福德成就。以是因缘摄法福德。佛言。善哉善哉毗舍佉。我听汝是诸愿。汝与比丘僧雨浴衣。比丘尼僧浴衣。客比丘饮食。远行比丘饮食。随病比丘饮食。看病比丘饮食。比丘僧常与粥。多知识少知识比丘与病缘汤药诸物。毗舍佉。是财福德成就。以是因缘摄法福德。佛为毗舍佉说种种因缘示教利喜已从坐起去。佛以是事集比丘僧。语诸比丘。从今听诸比丘畜雨浴衣随意露地洗。是诸比丘。知佛听畜雨浴衣广长大作。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘呵责。云何名比丘。知佛听畜雨浴衣。便广长大作。种种因缘呵已向佛广说。佛以是事集比丘僧。知而故问诸比丘。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘。知我听畜雨浴衣。便广长大作畜。种种因缘呵已语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘欲作雨浴衣。当应量作。量者。长佛六搩手广二搩手半。过是作者波逸提。波逸提者。煮烧覆障。若不悔过能障碍道。是中犯者。若比丘过量长作雨浴衣波逸提。若过量广作波逸提。若过量广长作波逸提。若比丘过量广长作雨浴衣。是衣应截断。入僧中作是言。我过量广长作雨浴衣。得波逸提罪。今发露悔过不覆藏。僧应问。汝截断未。若言已截。僧应问。汝见罪不。若言见罪。应语言。汝如法悔过后莫复作。若言未截。僧应约敕令截。若僧不约敕。僧得突吉罗。若僧约敕不受。是比丘得突吉罗(八十七事)

佛在维耶离国。土地碱湿。诸比丘病痈疮。有一比丘疮中脓血流出。污安陀卫如水渍。佛遥见。知而故问是比丘。汝何以脓血污安陀卫。比丘答言。大德。我患痈疮。脓血流出污安陀卫。佛以是事集比丘僧。种种因缘赞戒赞持戒。赞戒赞持戒已语诸比丘。从今听畜覆疮衣着。乃至疮差后十日。若过是畜波逸提。诸比丘知佛听畜覆疮衣。便广长大作。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘呵责。云何名比丘。知佛听畜覆疮衣。便广长大作。种种因缘呵已向佛广说。佛以是事集比丘僧。知而故问诸比丘。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘。知我听畜覆疮衣。便广长大作。种种因缘呵已语诸比丘。以十利故与诸比丘结戒。从今是戒应如是说。若比丘欲作覆疮衣。当应量作。量者。长佛四搩手广二搩手。过是作者波逸提。波逸提者。煮烧覆障。若不悔过能障碍道。是中犯者。若比丘过量长作覆疮衣波逸提。若过量广作波逸提。若过量广长作波逸提。若比丘过量广长作覆疮衣。是衣应截断。入僧中作是言。我过量广长作覆疮衣得波逸提罪。今发露悔过不覆藏。僧应问。汝截断未。若言已截。僧应问。汝见罪不。若言见罪。僧应语。汝如法悔过后莫复作。若言未截者。僧应约敕令截。若不约敕。僧得突吉罗。若僧约敕不受。是比丘得突吉罗罪(八十八事)

佛在维耶离国。尔时诸比丘精污卧具。早起浣精舍门间晒。中前佛着衣持钵入城乞食。见是不净污卧具浣晒门间。佛食后以是事集比丘僧。语诸比丘。我今日中前着衣持钵入城乞食。见诸比丘精污卧具早起浣精舍门间晒。语诸比丘。此不应尔。众僧卧具多用不知量。诸居士血肉干竭。用布施作福。是中应筹量少用者善。若比丘乱念不一心眠时。有五过失。何等五。一者难睡苦。二者难觉苦。三者见恶梦。四者睡眠时善神不护。五者觉时心难入善觉观法。若比丘不乱念一心睡眠。有五善事。何等五。一者无难睡。二者易觉。三者无恶梦。四者眠时善神所护。五者睡觉心易入善觉观法。若比丘有淫怒痴。未得离欲。不乱念一心睡眠。尚不失精。何况离欲。种种因缘呵已语诸比丘。从今听诸比丘畜尼师檀。护僧卧具故。不应不敷尼师檀僧卧具上坐卧。诸比丘知佛听畜尼师檀。便广长大作。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘呵责。云何名比丘。知佛听畜尼师檀。便广长大作畜。种种因缘呵已向佛广说。佛以是事集比丘僧。知而故问诸比丘。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘。知我听畜尼师檀。便广长大作畜。种种因缘呵已语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘作尼师檀。当应量作。量者。长佛二搩手广一搩手半。过是作者波逸提。波逸提者。煮烧覆障。若不悔过能障碍道。是中犯者。若比丘过量长作尼师檀波逸提。若过量广作波逸提。若过量广长作波逸提。若比丘过量广长作尼师檀已。应截断。入僧中白言。我过量广长作尼师檀得波逸提罪。我今发露悔过不覆藏。僧应问。已截断未。若言已截。僧应问。汝见罪不。若言见罪。应教言。汝今如法悔过后莫复作。若未割截。僧应约敕令割截。若不约敕僧得突吉罗。若僧约敕不受。是比丘得突吉罗。佛在舍卫国。尔时佛。中前着衣持钵入舍卫城乞食。食已入安陀林中。一树下敷尼师檀坐。长老迦留陀夷亦入安陀林。去佛不远在一树下敷尼师檀坐。是长老身长大。两膝到地两手捉衣。作是愿言。佛何时当听我等作佛一搩手尼师檀。如是满足。佛晡时从禅起。以是事集比丘僧。语诸比丘。我今日食时着衣持钵入城乞食。食已入安陀林。一树下敷尼师檀坐。迦留陀夷乞食还。亦坐一树下作是思惟。佛今何处行道。我亦彼间行道。我时入安陀林。一树下敷尼师檀坐。迦留陀夷亦尔。是善男子身太两膝到地。作是愿言。佛何时当听作佛一搩手尼师檀。如是满足。佛语诸比丘。从今是戒应如是说。若比丘欲作尼师檀。当应量作。量者。长佛二搩手广一搩手半。及缕际益一搩手。过是作者波逸提(八十九事)

佛在迦维罗卫国。尔时长老难陀。是佛弟姨母所生。与佛身相似。有三十相。短佛四指。时难陀作衣与佛同量。诸比丘若食时会中后会。遥见难陀来。谓是佛。皆起迎。我等大师来世尊来。近乃知非。诸上座皆羞。作是思惟。此是我等下座。云何起迎。难陀亦羞言。乃令诸上座起迎我。诸比丘以是事向佛广说。佛以是事集比丘僧。知而故问难陀。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘。同佛衣量作衣。从今汝衣应减作。是袈裟应以敷晒。诸比丘。汝等以敷晒难陀衣。更有如是人。僧亦当同心以敷晒。语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘与佛衣等量作衣及过作得波逸提。佛衣量者。长佛九搩手广六搩手。是佛衣量。波逸提者。煮烧覆障。若不悔过能障碍道。是中犯者。若比丘与佛衣同量作衣波逸提。若过佛衣量作波逸提。随作随得尔所波逸提。若比丘与佛衣同量作衣是衣应截断。入僧中白言。我如佛衣量作衣得波逸提罪。今发露悔过不覆藏。僧应问。汝截断未。若言已截。应问。汝见罪不。若言见罪。僧应言。汝今如法悔过后莫复作。若言未截。僧应约敕令截。若僧不约敕。僧得突吉罗。若僧约敕不受。是比丘得突吉罗罪(九十事竟)

十诵律卷第十八十诵律卷第十九(第三诵之六)

        后秦北印度三藏弗若多罗译

    四波罗提舍尼法

佛在舍卫国。时世饥俭。华色比丘尼有德。多知多识能多得衣服饮食卧具汤药诸所须物。是比丘尼晨朝早起着衣持钵入舍卫城乞食。时见诸比丘众舍卫城乞食不得愁恼不乐。是比丘尼看诸比丘钵中。少少与少。少半与半。都无都与。是比丘尼一日乞食所得。尽以与诸比丘。如是二三日。以不得食故。于巷中迷闷倒地。一贾客见已语其妇言。华色比丘尼于巷中倒地。汝扶令起将来。妇即去扶起将来入舍。疾作粰[米*留]粥与已得醒。问言。汝何所患苦。有何疾病有何急。于巷中倒地。比丘尼言。我无病无痛无急。我不得食故。迷闷巷中倒地。又问。汝为乞食不能得耶。答言。我乞食得。以诸大众于舍卫城乞食不得愁恼不乐。我看比丘钵中。少少与少。少半与半。都无都与。如是二三日。我断食。是故迷闷巷中倒地。诸居士闻是事心不喜。呵责言。是沙门释子不知时不知量。若施者不知量。受者应知量。是华色比丘尼以断食故垂死。是中有比丘。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集比丘僧。以种种因缘呵责诸比丘。云何名比丘。不知时不知量。若施者不知量。受者应知量。是华色比丘尼以断食故垂死。种种因缘呵责已语诸比丘。以十利故与比丘结戒。从今是戒应如是说。若比丘不病入聚落中。非亲里比丘尼所自手受食。是比丘应向余比丘说是罪。长老我堕可呵法不是处。是法可悔。我今发露悔过。是名波罗提提舍尼法。病者。风盛热盛冷盛。啖是食得差。是名为病。除是因缘名为不病。非亲里者。亲里名若母若女若姊妹乃至七世因缘。是名亲里。除是名非亲里。食者。五种佉陀尼食五蒱阇尼食五似食。五佉陀尼食者。根茎叶磨果。五蒱阇尼食者。饭糗糒鱼肉。五似食者糜粟[麩-夫+黃]麦莠子迦师。是中犯者。若比丘不病入聚落中。非亲里比丘尼所自手受根食。得波罗提提舍尼罪。茎叶磨果食。饭糗糒鱼肉食。糜粟[麩-夫+黃]麦莠子迦师。皆波罗提提舍尼罪。不犯者。若病若亲里比丘尼。若天祠中多人聚中与。若沙门住处与。若聚落外比丘尼坊舍中与者不犯(一法)

佛在王舍城。尔时有一居士。请佛及二部僧明日食。佛默然受。居士知佛默然受已。头面礼足右绕而去。还自舍办种种多美饮食。晨朝敷坐处。遣使白佛时到。食具已办佛自知时。佛即与二部僧入居士舍坐。居士见佛及僧坐已。自手行水欲下食时。是中有助调达比丘尼。为六群比丘故。教檀越言。此第一上座。此第二上座。此是持律。此是法师。与是比丘饭。与是比丘羹。诸居士言。我等不知谁是第一上座。谁是第二上座。谁是持律谁是法师。此中多有饮食自当遍与。莫散乱语。若散乱语者。汝自起行食。我等当住。佛遥见比丘尼作散乱事。闻诸居士呵责。食后以是因缘集比丘僧。种种因缘呵责六群比丘。云何名比丘。啖比丘尼所教与食。种种因缘呵已语诸比丘。以十利故与比丘结戒。从今是戒应如是说。有诸比丘白衣家请食。是中有比丘尼指示言。与是比丘饭。与是比丘羹。诸比丘应语是比丘尼。小住待诸比丘食竟。若诸比丘中。无有一比丘语是比丘尼小住待。诸比丘食竟者。是一切诸比丘。应向余比丘言。长老。我等堕可呵法不是处。是法可悔。我今发露悔过。是名波罗提提舍尼法。是中犯者。若比丘受比丘尼所教与食。得波罗提提舍尼罪。随受随得尔所波罗提提舍尼罪。若二部僧共坐。一部僧中若有一人。语是比丘尼者。第二部亦名为语。若别入别坐别食别出者。是中入檀越门比丘。应问出比丘。何比丘尼是中教檀越。与比丘食。答言某。应问。约敕未。答言已约敕。是入比丘亦名约敕。有诸比丘出城门时。有比丘入者。应问出者。若出者未约敕。入者应约敕。若出者已约敕。入者亦名约敕(二法)

佛在维耶离。尔时有象师。名首罗。富贵有威德。多饶财宝。人民田宅种种成就。是人归依佛归依法归依僧。见四谛得初道。好檀越施不能筹量。是人一月得官廪千金钱。持用布施及余所有物。不能供足妇儿饥乏。诸居士嗔呵责言。沙门释子不知时不知量。若施者不知量。受者应知量。是首罗象师本富饶财物。布施不知量与不能供足妇儿饥乏甚可怜愍。是中有比丘。少欲知足行头陀。闻是事心不喜。以是事向佛广说。佛以是事集比丘僧。种种因缘。呵责诸比丘云何名比丘。不知时不知量。若施者不知量。受者应知量。是首罗象师。好檀越施不能量故与。不能供妇儿饥乏。种种因缘呵已语诸比丘。汝等与首罗象师作学家羯磨。诸比丘比丘尼式叉摩尼沙弥沙弥尼。入是家不得自手受食。若更有如是人僧亦应与作学家羯磨。学家羯磨者。僧一心和合。一比丘僧中唱言。大德僧听。首罗象师学家。诸比丘比丘尼式叉摩尼沙弥沙弥尼。入是学家不得自手受食。若僧时到僧忍听。僧与首罗居士作学家羯磨。诸比丘比丘尼式叉摩尼沙弥沙弥尼。不得入是家自手受食。白如是。如是白二羯磨。僧与首罗象师作学家羯磨竟。僧忍默然故是事如是持。是首罗象师。闻僧为作学家羯磨。诸比丘比丘尼式叉摩尼沙弥沙弥尼。不得入我舍自手受食。闻已即诣佛所。头面礼佛足却坐一面。白佛言。愿佛与我舍是学家羯磨佛语诸比丘。为首罗居士舍学家羯磨。若更有如首罗居士乞者。亦应为舍。舍法者。一心和合僧。是首罗居士。从坐起偏袒右肩脱革屣合掌白言。大德僧听。我首罗居士布施不知量与。不能供妇儿饥乏。以是因缘故。僧为我作学家羯磨。诸比丘比丘尼式叉摩尼沙弥沙弥尼。入我舍不得自手受食。我今从僧乞舍学家羯磨。如本诸比丘比丘尼式叉摩尼沙弥沙弥尼。入我舍自手受食。如是应第二第三乞。僧应筹量宜可舍不可舍。若首罗象师财损减不增长。尔时若乞不乞不应舍。若首罗居士财物增长。若乞不乞皆应与舍。若首罗象师财物不增不减。尔时若乞应舍。不乞不应舍。是中一比丘应唱言。大德僧听。是首罗象师先作檀越。布施不知量与。不能供妇儿饥乏。僧以是故。与作学家羯磨。诸比丘比丘尼式叉摩尼沙弥沙弥尼。入是舍不得自手受食。今是首罗象师。从僧乞舍学家羯磨。如本诸比丘比丘尼式叉摩尼沙弥沙弥尼。听我舍自手受食。若僧时到僧忍听。僧与首罗象师舍学家羯磨。如本听诸比丘比丘尼式叉摩尼沙弥沙弥尼。入舍自手受食。白如是。如是白四羯磨。僧与首罗居士舍学家羯磨竟。僧忍默然故是事如是持。佛语诸比丘。以十利故与比丘结戒。从今是戒应如是说。有诸学家。僧作学家羯磨竟。若比丘如是学家。先不请后来自手受食。是比丘应向余比丘说罪。作是言。长老。我堕可呵法不是处。是法可悔。我今发露悔过。是名波罗提提舍尼法。学家者得初道家。作学羯磨者。僧与是家作学羯磨先不请者。是学家先不请后来自手受食者。五佉陀尼食。五蒲阇尼食。五似食。是中犯者。若比丘学家中。先不请后来自手受食。受根食波罗提提舍尼罪。茎叶磨果饭糗糒鱼肉糜粟[麩-夫+廣]麦莠子迦师食。皆波罗提提舍尼。随自手受。随得尔所波罗提提舍尼罪(三法)

佛在迦维罗卫国。尔时诸释子向暮食时。见食好香美。作是念。我等不应独啖如是好饮食。何不当留佛及僧分。作是念已。为佛及僧故留暮食分。明日地了。诸释妇女以好宝物自庄严身。持好饮食大语大笑来行向僧坊。作是言。佛今当先食我食。彼亦复言。佛先食我食。令我长夜得利益安乐。尔时尼俱陀林中有贼。先犯事摈入是林中。持器仗着中围绕而卧。但贼主不卧。闻人声语诸贼言。诸人皆起。捉刀盾弓箭。聚财物一处。莫令王力聚落力所围绕得大忧恼。是诸人皆起。如所约敕。捉刀盾弓箭。聚财物一处。贼主言。小住。我当往看。为是何人。即立树间闻道上人声。作沙门声。问言。汝是谁耶。答言。我等是诸释妇女。以好宝物严身。持好饮食向僧坊。入尼俱陀林中。佛今者当先食我食。我等长夜当得利益安乐。贼主即还语诸贼言。今得成事。但当起取。问言云何。答言。诸释妇女以妙宝严身。持好饮食入尼俱陀林中。即时贼皆起。剥脱已裸形放去。如是名声流布城邑聚落。有恶贼剥脱诸释妇女裸形放去。即以官力聚落力围绕捕得诸贼。尔时诸女裸形住。六群比丘往语言。此食香美过与我来。此食复胜亦与我来。尔时诸妇女嗔呵言。不是都不忧念我等裸形。但念欲得是食。诸比丘以是事向佛广说。佛语阿难。取舍衣中各各与诸女一衣。阿难言尔。即取舍衣中各各与诸女一衣。诸女着已持食入僧坊中打揵捶与僧食分。在佛前坐听说法。佛见诸女坐已。种种因缘示教利喜。示教利喜已默然。诸女知佛示教利喜已。头面礼佛足右绕而去。诸女去不久。佛以是事集比丘僧。种种因缘呵责六群比丘。云何名比丘。僧未作约敕僧坊外不自手受食。而僧坊内受。种种因缘呵已语诸比丘以十利故与比丘结戒。从今是戒应如是说。有比丘僧。住阿练儿处。有疑怖畏。若比丘知是阿练儿住处有疑怖畏难。僧未作差。不僧坊外自手受食。僧坊内受。是比丘应向余比丘说罪言。长老。我堕可呵法不是处。是法可悔。我今发露悔过。是名波罗提提舍尼法。阿练儿处者。去聚落五百弓。于摩伽陀国一拘卢舍。于北方国则半拘卢舍。疑者。乃至疑失一水器。怖畏者。是中乃至畏恶比丘。僧未差者。僧未一心差是人。僧坊外者。此僧坊墙障外。若篱障外。若堑障外僧坊内者。僧坊墙障内。篱障内。堑障内。食者。五佉陀尼。五蒲阇尼。五似食。是中犯者。若比丘僧未与差是人。不僧坊外自手受根食。僧坊内受。得波罗提提舍尼。茎叶磨果饭糗糒鱼肉糜粟[麩-夫+黃]麦莠子迦师。皆波罗提提舍尼罪。随自手受。随得尔所波罗提提舍尼。从今应羯磨差参知食人。一心和合僧。一比丘问言。谁能为僧作参知食人。若有言我能。若有五法不应差作知食人。随爱随嗔随怖随痴不知有无。若成就五法。应令作参知食人。不随爱不随嗔不随怖不随痴知有无。是中一比丘。僧中唱言。大德僧听。某甲比丘。能作参知食人。若僧时到僧忍听。某甲比丘作参知食人。白如是。如是白二羯磨。某甲比丘作参知食人竟。僧忍默然故是事如是持。若比丘受僧羯磨已。是比丘知是中有贼入。应将净人是中立。若是中见有人似贼者。应取是食。语诸持食人言。汝莫来入。是中有人似贼。若是持食人。强来者不犯(四法竟)

    明一百七众学法初

佛在王舍城。尔时诸比丘。极高着泥洹僧。极下着。参差着。不周齐着。佛见已作是念。我当观过去诸佛。云何着泥洹僧。空中净居天言。世尊。过去诸佛周齐着泥洹僧。佛亦自忆知过去诸佛周齐着泥洹僧。佛复念。我当观未来诸佛。云何着泥洹僧。空中净居天言。世尊。未来诸佛周齐着泥洹僧。佛亦观知未来诸佛。亦当周齐着泥洹僧。佛复作是念。我当看净居天。云何着泥洹僧。空中天言。净居天周齐着泥洹僧。佛亦自知净居天周齐着泥洹僧。佛以是事集比丘僧。以种种因缘呵责诸比丘。云何名比丘。极高着泥洹僧。极下着泥洹僧。参差着泥洹僧。不周齐着泥洹僧。种种因缘呵已语诸比丘。以十利故与比丘结戒。从今是戒应如是说。不极高着泥洹僧。应当学。若比丘极高着。突吉罗。若不极高着不犯(一)

不极下着泥洹僧。应当学。若极下着泥洹僧。突吉罗。不极下着不犯(二)

不参差着泥洹僧。应当学。若参差着泥洹僧。突吉罗。不参差着泥洹僧不犯(三)

不如釿头着泥洹僧。应当学。如釿头着泥洹僧。突吉罗。不如釿头着。不犯(四)

不如象鼻着泥洹僧。应当学。如象鼻着泥洹僧。突吉罗。不如象鼻着不犯(五)

不如多罗叶着泥洹僧。应当学。如多罗叶着泥洹僧。突吉罗。不如多罗叶着泥洹僧。不犯(六)

不如糗抟着泥洹僧。应当学。如糗抟着泥洹僧。突吉罗。不如糗抟着不犯(七)

不细襵前着泥洹僧。应当学。如细襵前着泥洹僧。突吉罗。不细襵前着。不犯(八)

不着[革*茸]泥洹僧。应当学。着[革*茸]泥洹僧。突吉罗。不着[革*茸]衣。不犯(九)

不并襵两边着泥洹僧。应当学。若并襵两边着泥洹僧。突吉罗。不并襵两边着。不犯(十)

不着细缕泥洹僧。应当学。若着细缕泥洹僧。突吉罗。不着细缕。不犯(十一)

周齐着泥洹僧。应当学。不周齐着泥洹僧。突吉罗。周齐着不犯(十二)

佛在王舍城。尔时诸比丘。极高被衣。极下被衣。参差被衣。不周齐被衣。佛见已作是念。我当观过去诸佛。云何被衣。空中净居天言。过去诸佛周齐被衣。佛亦自忆过去诸佛周齐被衣。佛复念。我当观未来诸佛。云何被衣。空中天言。未来诸佛周齐被衣。佛亦自知未来诸佛周齐被衣。佛复念。净居诸天云何被衣。空中天言。净居诸天周齐被衣。佛亦自见净居诸天周齐被衣。佛以是事集比丘僧。种种因缘呵责诸比丘。云何名比丘。极高被衣。极下被衣。参差被衣。不周齐被衣。种种因缘呵已语诸比丘。以十利故与比丘结戒。从今不极高被衣。应当学。极高被衣突吉罗。不极高被衣不犯(十三)

不极下被衣应当学。极下被衣突吉罗。不极下被衣不犯(十四)

不参差被衣。应当学。参差被衣突吉罗。不参差被衣不犯(十五)

周齐被衣应当学。不周齐被衣突吉罗。周齐被衣不犯(十六)

佛在王舍城。尔时有一居士。请佛及僧明日食。佛默然受。居士知佛默然受已。从坐起头面礼佛足右绕而去。还自舍通夜办种种多美饮食。晨朝敷座处遣使白佛。时到食具已办。佛自知时。佛中前着衣入居士舍。尔时六群比丘。不好覆身入是家内。自看肩臂看胸。诸居士呵责言。诸沙门释子自言。善好有功德。不好覆身。入家内。自看肩臂看胸。如王如大臣。佛见六群比丘不好覆身入白衣舍。闻居士呵责如王如大臣。佛食后以是事集比丘僧。种种因缘呵责六群比丘。云何名比丘。不好覆身入家内。自看肩臂看胸。种种因缘呵已语诸比丘。以十利故与比丘结戒。从今好覆身入家内。应当学。不好覆身入家内。突吉罗。好覆身入家内。不犯(十七)

有时六群比丘。虽好覆身入家内。不好覆身坐。自看肩臂看胸。诸居士呵责言。诸沙门释子自言。善好有德。不好覆身坐家内。看肩臂看胸。如王如大臣。佛见诸比丘不好覆身坐家内。自看肩臂看胸。佛见已食后集比丘僧。种种因缘呵责诸比丘。云何名比丘。不好覆身坐家内。自看肩臂看胸。种种因缘呵已语诸比丘。以十利故与比丘结戒。从今好覆身坐家内。应当学。不好覆身坐家内。突吉罗。好覆身坐不犯(十八)

有时六群比丘。不善摄身入家内。脚蹴大车小车犊车辇舆。轮树柱壁瓶瓮倒地。诸居士呵责言。诸沙门释子自言。善好有德。不善摄身入他家。脚蹴物倒地。如盲人。佛语诸比丘。善摄身入家内。应当学。不善摄身入家内。突吉罗。善摄身入家内。不犯(十九)

又六群比丘。虽善摄身入家内。不善摄身坐。蹴大车小车犊车辇舆轮树柱壁瓶瓮床榻倒地如盲人。佛知是事语诸比丘。善摄身坐家内。应当学。不善摄身坐家内突吉罗。若善摄身坐。不犯(二十)

佛在舍卫国。尔时世尊。中前着衣与诸比丘入舍卫城。诸佛常法。若以神通力入城邑聚落时。现如是希有事。谓象申鸣马悲鸣诸牛王吼鹅雁孔雀鹦鹉舍利鸟俱均罗猩猩诸鸟。出和雅音。大鼓小鼓箜篌筝笛琵琶箫瑟筚篥铙钹。不鼓自鸣。诸贵人舍所有金器内外庄严具。若在箱箧中自然作声。盲者得视。聋者得听。哑者能言。拘躄者得伸跛蹇者得手足。睐眼得正。病瘦者得除。苦痛者得乐。毒者得消。狂者得正。杀者离杀。偷者离偷。邪淫者不邪淫。妄语者不妄语。两舌恶口无义语者。不无义语。贪者不贪。嗔者不嗔。邪见者离邪见。牢狱闭系枷锁杻械。悉得解脱。愦闹处者皆得空闲。未种善根者种。已种者增长。已增长者得解脱。诸伏藏宝物自然发出。现如是希有事。诸众生得利益。尔时佛渐渐行到城。以右足着门阃上。如是等种种希有事皆现。尔时人民于屋上堂壁楼阁上看佛及僧。是中有未曾见佛者。有曾见佛者指示言。此是佛。此是舍利弗目连阿那律难提金毗罗。此是六群比丘。六群比丘闻已。仰看作是言。某女人盲。某睐眼某赤眼。某短鼻某瘿。某背偻某跛。某白某黑。某无威德。诸女人闻已。语六群比丘言。我非汝妇。不与汝私通我等好丑何豫汝事。而字名我等。六群比丘言。我从佛及僧入城。何豫汝事。指我等言。此是六群比丘。似如过罪人。佛闻是事语诸比丘。从今不高视入家内。应当学。高视入家内。突吉罗。不高视入家内不犯(二十一)

尔时佛及僧露地坐食。诸人在堂屋上墙壁楼阁上。看佛及僧。是中有人。未曾见佛者。中有曾见佛者指示言。此是佛。此是舍利弗目连阿那律难提金毗罗。此是六群比丘。六群比丘闻已。即仰视作是言。某女人盲。某睐眼某赤眼。某短鼻某瘿。某背偻某跛。某黑某白。某无威德。诸女人闻已语六群比丘言。我等非汝妇。不与汝通。我等好丑何豫汝事。而名字我等。六群比丘言。我从佛及僧受请坐食。何豫汝等事。而指我等言。此是六群比丘。似如过罪人。佛闻是事语诸比丘。从今不高视坐家内。应当学。高视坐家内。突吉罗。不高视坐家内。不犯(二十二)

又六群比丘。嫌呵供养入家内。作是言。昨日饮食香美熟好。次第等与好敷座处。今日或当不如昨日香美熟好。或不次第等与。诸居士呵责言。诸沙门释子不善。不种不获。但能啖食出他过罪。佛闻是事语诸比丘。从今不呵供养入家内。应当学。呵供养入突吉罗。不呵供养入。不犯(二十三)

又六群比丘。入时不呵供养。坐已便呵。作是言。昨日饮食香美熟好次第等与好敷座处。今日或当不如昨日香美熟好。或不次第等与。诸居士呵言。是沙门释子不善。不种不获。但能啖食出他过罪。佛闻是事已语诸比丘。从今不呵供养坐家内。应当学。呵供养坐突吉罗。不呵供养坐。不犯(二十四)

又六群比丘。高大声入家内。诸居士呵责言。沙门释子自言。善好有德。高大声入家内。如婆罗门。佛语诸比丘。从今静默入家内应当学。若不静默入家内突吉罗。静默入不犯(二十五)

又六群比丘。虽不高声入家内。便高声坐如婆罗门诸居士呵责言。沙门释子自言。善好有德。高大声坐他家。如婆罗门。佛闻已语诸比丘。从今静默坐家内应当学。若不静默坐家内突吉罗。若静默坐不犯(二十六)

又六群比丘。蹲行入家内。诸居士呵责言。沙门释子自言。善好有功德。蹲行入家内。似如截脚。佛闻已语诸比丘。从今不蹲行入家内。应当学蹲行入家内。突吉罗。不蹲行入。不犯(二十七)

又六群比丘。虽不蹲行入家内。便蹲坐家内。诸居士呵责言。沙门释子蹲坐家内。如外道。佛语诸比丘。从今不蹲坐家内应当学。若蹲坐家内突吉罗。不蹲坐不犯(二十八)

又六群比丘。以衣覆头入家内。诸居士嗔呵责言。是诸比丘自言。善好有德。以衣覆头入家内。似如伺捕人。佛言。从今不覆头入家内。应当学。若覆头入家内。突吉罗。不覆头入不犯(二十九)

又六群比丘。虽不覆头入家内。覆头坐家内。诸居士呵责。诸比丘自言。善好有德。覆头坐家内。似如伺捕人。佛言。从今不覆头坐家内。应当学。若覆头坐突吉罗。不覆头坐不犯(三十)

又六群比丘襆头入家内。诸居士呵责言。诸沙门释子自言。善好有德。襆头入家内。如王如大臣。佛闻是事语诸比丘。从今不襆头入家内。应当学。若襆头入突吉罗。不襆头入不犯(三十一)

又六群比丘。虽不襆头入家内。而襆头坐家内。诸居士呵责。诸比丘自言。善好有德。襆头坐家内。如王如大臣。佛闻是事语诸比丘。从今不襆头坐家内应当学。若襆头坐突吉罗。不襆头坐不犯(三十二)

又六群比丘。肘隐人肩入家内。诸居士呵责言。沙门释子自言。善好有德。肘隐人肩入家内。如王如大臣。佛闻是事语诸比丘。从今不肘隐人肩入家内。应当学。肘隐人肩入家内。突吉罗。不肘隐人肩入。不犯(三十三)

又六群比丘。虽不肘隐人肩入。家内便肘隐人肩坐家内。诸居士嗔呵责言。诸沙门释子自言。善好有德。肘隐人肩坐家内。如王如大臣。佛闻是事语诸比丘。从今不肘隐人肩坐家内。应当学。肘隐人肩坐突吉罗。不肘隐人肩坐。不犯(三十四)

又六群比丘。叉腰入家内。诸居士呵责言。沙门释子自言。善好有德。叉腰入家内。如王如大臣。佛闻是事语诸比丘。从今不叉腰入家内。应当学。叉腰入突吉罗。不叉腰入不犯(三十五)

又六群比丘。虽不叉腰入家内。便叉腰坐家内。诸居士呵责言。沙门释子自言善好有德。叉腰坐家内。如王如大臣。佛闻是事语诸比丘。不叉腰坐家内应当学。叉腰坐突吉罗。不叉腰坐不犯(三十六)

又六群比丘。左右反抄衣入家内。诸居士呵责言。沙门释子自言善好有德。左右反抄衣入家内。如王如大臣。佛闻是事语诸比丘。从今不左右反抄衣入家内。应当学。左右反抄衣入家内突吉罗。不左右反抄衣入不犯(三十七)

尔时六群比丘。虽不左右反抄衣入家内。便左右反抄衣坐家内。诸居士呵责言。云何名比丘。左右反抄衣坐家内。如王如大臣。佛闻是事语诸比丘。不左右反抄衣坐家内。应当学。左右反抄衣坐突吉罗。不左右反抄衣坐不犯(三十八)

又六群比丘。偏抄衣入家内。诸居士诃责言。沙门释子自言善好有德。偏抄衣入家内。如王如大臣。佛闻是事语诸比丘。从今不偏抄衣入家内。应当学。若偏抄衣入突吉罗。不偏抄衣入不犯(三十九)

又六群比丘。虽不偏抄衣入家内便偏抄衣坐家内。诸居士呵责言。沙门释子自言善好有德。偏抄衣坐家内。如王如大臣。佛闻是事语诸比丘。不偏抄衣坐家内。应当学。若偏抄衣坐家内突吉罗。不偏抄衣坐不犯(四十)

尔时六群比丘。以衣覆右肩全举左肩上入家内。诸居士呵责言。诸沙门释子自言善好有德。以衣覆右肩全举左肩上入家内。如王如大臣。佛闻是事语诸比丘。从今不应以衣覆右肩全举左肩上入家内。应当学。若以衣覆右肩全举左肩上入家内突吉罗。不以衣覆右肩全举左肩上入不犯(四十一)

又六群比丘。虽不以衣覆右肩上全举左肩上入家内。便以衣覆右肩上全举左肩上坐家内。诸居士呵责言。沙门释子自言善好有德。以衣覆右肩全举左肩上坐家内。如王如大臣。佛闻是事语诸比丘。从今不应以衣覆右肩全举左肩上坐家内。应当学。若以衣覆右肩全举左肩上坐突吉罗。不覆右肩全举左肩上坐不犯(四十二)

尔时六群比丘。掉臂入家内。诸居士呵责言。诸沙门释子自言善好有德。掉臂入家内。似如种谷人。佛闻是事语诸比丘。从今不掉臂入家内。应当学。若掉臂入突吉罗。若不掉臂入不犯(四十三)

尔时诸比丘。虽不掉臂入家内。便掉臂坐。诸居士呵责言。沙门释子自言善好有功德。掉臂坐家内。似如种谷人。佛闻是事语诸比丘。从今不掉臂坐家内。应当学。若掉臂坐突吉罗。若不掉臂坐家内不犯(四十四)

尔时六群比丘。摇肩入家内。诸居士呵责言。沙门释子自言善好有德。摇肩入家内。如王如大臣。佛闻是事语诸比丘。从今不摇肩入家内。应当学。若摇肩入家内突吉罗。不摇肩入不犯(四十五)

尔时六群比丘。虽不摇肩入家内。便摇肩坐。诸居士呵责言。沙门释子自言善好有德。摇肩坐家内。如王如大臣。佛闻是事语诸比丘从今不摇肩坐家内。应当学。若摇肩坐突吉罗。不摇肩坐不犯(四十六)

又六群比丘。摇头入家内。诸居士呵责言。沙门释子自言善好有德。摇头入家内。似如鬼捉。佛闻是事语诸比丘。从今不摇头入家内。应当学。若摇头入家内突吉罗。不摇头入不犯(四十七)

又六群比丘。虽不摇头入家内。便摇头坐家内。诸居士呵责。沙门释子自言善好有德。摇头坐家内。似如鬼捉。佛闻是事语诸比丘。从今不摇头坐家内。应当学。若摇头坐突吉罗。不摇头坐不犯(四十八)

尔时六群比丘。摇身入家内。诸居士呵责言。沙门释子自言善好有德。摇身入家内。似如舞人。佛闻是事语诸比丘。从今不摇身入家内。应当学。若摇身入突吉罗。不摇身入不犯(四十九)

尔时六群比丘。虽不摇身入家内。便摇身坐。诸居士呵责言。沙门释子摇身坐家内。似如舞人。佛闻是事语诸比丘。从今不摇身坐家内。应当学。若摇身坐家内突吉罗。不摇身坐家内不犯(五十)

尔时六群比丘。携手入家内。蹴蹋瓶瓮器物倒地。诸居士呵责言。沙门释子自言善好有德。携手入家内。如王如大臣。佛闻是事语诸比丘。从今不携手入家内应当学。若携手入家内突吉罗。不携手入家内不犯(五十一)

又六群比丘。虽不携手入家内。便携手坐家内。诸居士言。诸长老。相近坐此请比丘多。六群比丘言。汝等更有何等事何不广敷座处。令我等相近坐耶。佛闻是事语诸比丘。从今不携手坐家内。应当学。若携手坐家内突吉罗。不携手坐不犯(五十二)

又六群比丘。翘一脚入家内。诸居士呵责言。沙门释子自言善好有德。翘一脚入家内。如王如大臣。佛闻是事语诸比丘。从今不翘一脚入家内。应当学。若翘一脚入突吉罗。不翘一脚入家内不犯(五十三)

尔时六群比丘。虽不翘一脚入家内。便翘一脚坐家内。诸居士言。诸长老。相近坐我请比丘多。六群比丘言。汝等更有何等事。何不广敷座处。令我等相近坐耶。佛闻是事语诸比丘。从今不应翘一脚坐家内。应当学。翘一脚坐家内突吉罗。不翘一脚坐不犯(五十四)

尔时六群比丘。累髀坐家内下露形体。诸居士呵责言。沙门释子自言善好有德。累髀坐家内下露形体。佛闻是事语诸比丘。从今不累髀坐家内。应当学。若累髀坐家内突吉罗。不累髀坐不犯(五十五)

尔时六群比丘累脚坐。诸居士呵责言。沙门释子自言善好有德。累脚坐家内。如王如大臣。佛闻是事语诸比丘。从今不累脚坐应当学。若累脚坐突吉罗。不累脚坐不犯(五十六)

佛在舍卫国。尔时六群比丘。早起着衣持钵入舍卫城乞食。有一居士。中门前独坐床上。以掌扶颊愁忧不乐。时六群比丘共相谓言。此人忧戚。我能令语笑。六群比丘前到是居士所。以掌扶颊愁忧而住。居士笑而问言。汝等何急共相忧愁。以掌扶颊而住。六群比丘顾语诸比丘言。我即令语笑已。诸居士呵责言。诸沙门释子自言善好有德。以掌扶颊令白衣语笑。如戏笑人。佛闻是事语诸比丘。从今不掌扶颊坐家内。为白衣笑故。应当学。若掌扶颊坐突吉罗。不掌扶颊坐不犯(五十七)

佛在王舍城。尔时有一居士。请佛及僧明日食。佛默然受已。居士知佛受已。从坐而起头面礼佛足右绕而去。还到自舍通夜办种种多美饮食。晨朝敷座处。遣使白佛时到。食具已办佛自知时。佛及僧入居士舍坐。是居士知佛及僧坐已。自手行水欲下饮食。时六群比丘。持钵置前四向顾视。居士下饭着钵中已过去。六群比丘言。此中何以不与饭。居士言已与。六群比丘言不与。居士言看钵中。看已唤居士言。授我钵来。诸居士言。汝等向者心在何处。今方唤授钵。佛言。从今一心受饭。应当学。若不一心受饭突吉罗。若一心受不犯(五十八)

又六群比丘。以饭满钵向余处看。诸居士着羹钵中已过。六群比丘言。此中何以不与羹耶。答言已与。六群比丘言不与。居士言。何不看钵中。看已语言。授我钵来。诸居士言。汝向者心在何处。今方唤授钵。佛闻是事语诸比丘。从今一心受羹应当学。若不一心受羹突吉罗。一心受羹不犯(五十九)

又六群比丘。溢钵受饮食。是中饭羹溢出。诸居士言。饭当更益。羹亦当更益。何以溢钵取弃。佛闻是事语诸比丘。从今不溢钵受食。应当学。若溢钵受食突吉罗。不溢钵受不犯(六十)

又六群比丘。以羹菜浇饭。但取羹菜处饭食诸居士呵责言。何以浇食如小儿。佛闻是事语诸比丘。从今等。羹饭和合食。应当学。若不等羹饭食突吉罗。若羹饭等食不犯(六十一)

又六群比丘。饭上若有酥酪及羹。剾中啖如井。诸居士呵责言。诸比丘食如婆罗门食。佛闻是事语诸比丘。从今不应剾中啖。如井应当学。剾中食突吉罗。不剾中食不犯(六十二)

又六群比丘抟饭食。诸居士呵责言。诸比丘抟饭如小儿。佛闻是事语诸比丘。从今不抟饭食应当学。若抟饭食突吉罗。不抟饭食不犯(六十三)

又六群比丘。大抟饭食。诸居士呵责言。诸比丘大抟饭食。似如有人欲夺驱逐。佛闻是事语诸比丘。从今不大抟食。应当学。若大抟食突吉罗。不大抟食不犯(六十四)

又六群比丘。手把饭食。诸居士呵责言。诸比丘手把饭食。如田种人。佛闻是事语诸比丘。从今不手把饭食。应当学。手把饭食突吉罗。不手把饭食不犯(六十五)

又时诸比丘。次第坐食。有一比丘。食未至便大张口。六群比丘与比坐。以戏故持土块着口中。尔时众中有如是不清净事。佛言。从今不豫张口待饭食。应当学。若食未至豫张口待食突吉罗。不豫张口待不犯(六十六)

有时六群比丘唅食语。羹饭从口流出。比坐比丘见便吐逆。佛言。从今不唅食语。应当学。若唅食语突吉罗。不唅食语不犯(六十七)

又六群比丘。啮半食。半在口中。半在手中。佛言。从今不啮半食。应当学。若啮半食突吉罗。不啮半食不犯(六十八)

佛在伽维罗卫国。尔时摩诃男释。请佛及僧明日食。佛默然受。知佛默然受已。即从坐起头面礼足右绕而去。还自舍。通夜办种种多美饮食。早起敷座处。遣使白佛言时到。食具已办佛自知时。佛着衣持钵及僧入摩诃男舍坐。摩诃男见佛坐已。自手行水。是食乳已辨。自手下饭与乳。诸比丘吸食作声。尔时有比丘。先是伎儿。闻是声即起舞。诸比丘大笑。笑时口中饭粒出。有鼻孔中出者。诸居士呵责言。诸沙门释子自言善好有德。云何令他笑如伎儿。佛见诸比丘作是事。闻诸居士呵责时佛默然。食后以是事集比丘僧。佛知故问舞比丘。汝以何心舞。答言。世尊。欲出诸比丘吸食过罪。及戏笑故。佛言。从今不吸食。应当学。若吸食作声食突吉罗。不吸食作声不犯(六十九)

又六群比丘。嚼食唼唼作声。诸居士呵责言。沙门释子自言善好有德。嚼食唼唼作声。如猪唼食。佛言。从今不嚼食作声。应当学。嚼食作声食突吉罗。不嚼食作声不犯(七十)

又六群比丘。满口着饭渐渐咽。诸居士呵责言。如猕猴食。佛言。从今不未咽食食。应当学。未咽食食突吉罗。咽已食不犯(七十一)

又六群比丘吐舌食。作是言。谁能全吞令抟不坏。诸居士呵责言。诸比丘吐舌食如小儿。佛言。从今不吐舌食。应当学。吐舌食突吉罗。不吐舌不犯(七十二)

又六群比丘缩鼻食。诸居士呵责言。应好弃涕。为寒耶。为啖蒜耶。佛言。从今不缩鼻食。应当学缩鼻食突吉罗。不缩鼻食不犯(七十三)

又六群比丘舐手食。诸居士呵责言。羹饭尽当更益何。以舐手。佛言。从今不舐手食。应当学。若舐手食突吉罗。不舐手食不犯(七十四)

又六群比丘。指抆钵食。诸居士呵责言。羹饭尽当更益。何以指抆钵食。佛言。从今不指抆钵食。应当学。若指抆钵食突吉罗。不指抆钵食不犯(七十五)

又六群比丘食着手振却。诸居士呵责言。诸比丘食如王如大臣。振手食弃。佛言。从今不振手食。应当学。振手食突吉罗。不振手食不犯(七十六)

又六群比丘弃着手饭。诸居士呵责言。是诸沙门不善。不种不获。但啖复弃。佛言。从今不弃着手饭。应当学。弃着手饭突吉罗。不弃不犯(七十七)

尔时六群比丘。腻手便捉饮器。比坐比丘见便吐逆。佛言。从今不腻手捉饮器。应当学。腻手捉饮器突吉罗。不腻手捉不犯(七十八)

又六群比丘。不病自为索饭索羹。佛言。从今不病不自为索饭索羹。应当学。不病自索羹饭突吉罗。若病索不犯(七十九)

又六群比丘。以饭覆羹。更望得故。语诸居士言。此中着羹。答言。先啖钵中饭覆者。佛言。从今不饭覆羹欲望更得。应当学。若饭覆羹更望得者突吉罗。更不望得覆者不犯(八十)

又六群比丘。呵相看比坐钵中。作是言。汝多我少。我少汝多。佛言。不诃相看比坐钵。应当学。呵相看比坐钵突吉罗。不呵相看不犯(八十一)

又一比丘僧中食时看余处。六群比丘与作比坐以戏笑故。持骨着其钵中。此比丘持手着钵中欲食。触骨惊怖。以是事故。佛言。端视钵食应当学。若不端视钵食突吉罗。端视钵食不犯(八十二)

又六群比丘多受食。不次第啖尽残在钵中。便着水汤弃。满澡盘中。收残食器皆满。诸居士呵责言。是诸沙门不善。不种不获。但能啖复弃。佛言。次第啖食尽应当学。不次第啖食尽突吉罗。次第啖尽不犯(八十三)

佛在迦毗罗国。尔时有居士。请佛及僧明日食。佛默然受。居士知佛默然受已。从坐起头面礼佛足右绕而去。还自舍通夜办种种多美饮食。早起敷坐处。遣使白佛时到。食办佛自知时。佛及僧到居士舍。新堂上水精作地。诸比丘洗钵水中有残食。舍着堂上似如吐。诸居士呵责言。是诸比丘不善。更有屏处可弃此水。何以乃弃此堂上。佛言。洗钵水有饭。不问主人不应弃舍内。应当学。若不问主人弃舍内突吉罗。问主人弃者不犯(八十四竟)

十诵律卷第十九十诵律卷第二十(第三诵之七)

        后秦北印度三藏弗若多罗译

    众学法之余

佛在舍卫国。尔时波斯匿王。立如是法。若佛在祇洹。我当日日往。时王闻佛在祇洹。即敕御者严驾。御者受教。严驾已办白言。大王。严驾已竟。王自知时。王即乘乘出城向祇洹。王在乘上。六群比丘。为王说法言。大王。色无常受想行识无常。是中有比丘。少欲知足行头陀。见是事心不喜。种种因缘呵责。云何名比丘。人在乘上。步为说法。诸比丘以是事向佛广说。佛语诸比丘。人无病乘乘。不应为说法。应当学。若不病乘乘为说法突吉罗。为病人说法不犯(八十五)

又时王在前行。六群比丘随后行。为说法言。大王。色无常受想行识无常。佛语诸比丘。人不病在前行不随后为说法。应当学。若为不病在前行人说法突吉罗。为病人说法不犯(八十六)

又时王在道中行。六群比丘在道外。为王说法言。大王。色无常受想行识无常。佛语诸比丘。若人不病在道中行。比丘在道外行不应为说法。应当学。若自在道外为道中行不病人说法突吉罗。为病人说法不犯(八十七)

诸王行法。持床榻自随。王在高床上坐。六群比丘立为说法。大王。色受想行识无常。佛语诸比丘。从今无病人坐比丘立不为说法。应当学。若自立为坐不病人说法突吉罗。为病人说法不犯(八十八)

王于六群比丘。无大恭敬心。六群比丘。或得卑小坐处。王自坐高处。六群比丘在卑下处。为王说法言。大王。色受想行识无常。佛语诸比丘。人无病在高处。自在下处不为说法。应当学。若自在下处为高处不病人说法突吉罗。为病人说法不犯(八十九)

有时王身大坐久便卧。六群比丘坐为说法言。大王。色受想行识无常。佛语诸比丘。人无病卧比丘坐不为说法。应当学。若自坐为卧不病人说法突吉罗。为病人说法不犯(九十)

有时王覆头。六群比丘为王说法言。大王。色受想行识无常。佛语诸比丘。不为覆头人说法。除病应当学。若为覆头不病人说法突吉罗。为病人说法不犯(九十一)

有时王裹头。六群比丘为说法言。大王。色受想行识无常。佛语诸比丘。不为裹头人说法。除病应当学。若为不病裹头人说法突吉罗。为病人说法不犯(九十二)

有时王肘隐人肩。六群比丘为说法言。大王。色受想行识无常。佛语诸比丘。不应为肘隐人肩者说法。除病应当学。若为肘隐人肩不病人说法突吉罗。为病人说不犯(九十三)

有时王叉腰。六群比丘为说法言。大王。色受想行识无常。佛语诸比丘。不为叉腰人说法。除病应当学。若为不病叉腰人说法突吉罗。为病人说法不犯(九十四)

有时王左右抄衣。六群比丘为说法言。大王。色受想行识无常。佛语诸比丘。不为左右抄衣人说法。除病应当学。若为左右抄衣不病者说法突吉罗。为病人说法不犯(九十五)

有时王偏抄衣。六群比丘为说法言。大王。色受想行识无常。佛语诸比丘。不为偏抄衣人说法。除病应当学。若遍抄衣不病为说法突吉罗。为病者说法不犯(九十六)

有时王以衣覆右肩全举左肩上。六群比丘为王说法言。大王。色受想行识无常。佛语诸比丘。不为以衣覆右肩全举左肩上人说法。除病应当学。若为以衣覆右肩全举左肩上不病人说法突吉罗。为病人说法不犯(九十七)

有时王着革屣。六群比丘为说法言。大王。色受想行识无常。佛语诸比丘。不为着革屣人说法除病应当学。若为着革屣不病人说法突吉罗。为病者说法不犯(九十八)

有时王着屐。六群比丘为王说法言。大王。色受想行识无常。佛语诸比丘。不为着屐人说法。除病应当学。若为着屐不病人说法突吉罗。为病人说法不犯(九十九)

有时佛与无量百千万众恭敬围绕说法。波斯匿王眷属。有捉杖者。捉盖者。捉刀者。捉盾者。捉弓箭者。六群比丘别为说法。是众中有堪得道者。以众作二段故。心散乱不得道。诸佛常法。不一心众生不为说法。佛即为王种种说法示教利喜。示教利喜已默然。王知佛种种说法示教利喜已。从坐起头面礼佛足右绕而去。王去未久。佛以是事集比丘僧。以种种因缘呵责六群比丘。云何名比丘。为捉杖不病人说法。若捉盖捉大刀小刀盾弓箭。种种器仗人说法。种种诃已语诸比丘。不为捉杖人说法。除病应当学。若为捉杖不病人说法突吉罗。为病者说法不犯(一百)

不为捉盖人说法。除病应当学。若为捉盖不病人说法突吉罗。为病人说法不犯(一百一)

不为捉刀人说法。除病应当学。若为捉刀人说法突吉罗。不为捉刀人说法不犯(一百二)

不为捉盾捉弓箭人说法。除病应当学。若为捉盾弓箭人说法突吉罗。不为捉盾弓箭人说法不犯(一百三)

佛在王舍城。尔时六群比丘。往语守菜园人言。汝与我等菜。问言。与价不。答言。我乞无价。守菜人言。索菜空与者。我等云何得活。六群比丘言。不与我耶。答言不与。六群比丘余时。大小便洟唾菜上。臭烂死坏。守菜人言。谁之所作。六群比丘往语守菜人言。汝知谁污汝菜。答言不知。六群比丘言。我等所作。随汝索菜不与。我等故作如是事。六群比丘勇健多力。不大畏罪。守菜人不能奈何。诸居士诃责言。沙门释子自言善好有德。菜上大小便洟唾。如王如大臣。佛闻是事语诸比丘。不得菜上大小便洟唾。除病应当学。若不病大小便洟唾菜上突吉罗。若病不犯(一百四)

佛在王舍城。尔时六群比丘。往语浣衣人言。与我浣衣。问言与价不。答言无价。浣衣人言。有浣衣不与价者。我等空浣衣。云何得活。六群比丘言。不与我浣耶。答言。不与汝浣。六群比丘到净水中浣衣处。大小便洟唾。诸浣衣人以先心谓水清净。浸衣着中即臭失色。浣衣人念。谁作是事。六群比丘余时往问。汝等知不。谁污是水。答言不知。六群比丘言。我等所作。以汝不与我浣衣故作是事。六群比丘勇健多力。不大畏罪。诸浣衣人不能奈何。诸居士诃责言。诸沙门释子自言善好有德。净用水中大小便洟唾。是中有比丘。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集比丘僧种种因缘诃责六群比丘。云何名比丘。净用水中大小便涕唾。佛但诃责而未结戒。又佛在舍卫国。尔时舍卫城中有一大池。名须摩那。多人所用。六群比丘共相谓言。可往须摩那池上看。皆言随意。即共往池上看。便大小便洟唾池中诸居士诃责言。是沙门释子不善。更无大小便处耶。乃到是净用水中大小便洟唾是中有比丘。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集比丘僧。种种因缘诃责言云何名比丘。净用水中大小便洟唾。佛种种因缘诃已语诸比丘。不应净用水中大小便洟唾。除病应当学。若不病净用水中大小便洟唾突吉罗。病者不犯(一百五)

佛在舍卫国。尔时六群比丘立大小便。佛闻是事语诸比丘。不得立大小便。除病应当学。若不病立大小便突吉罗。若病不犯(一百六)

佛在舍卫国。有一居士。请佛及僧明日食。佛默然受。居士知佛受已。从坐起头面礼佛足右绕而去。还自舍通夜办种种多美饮食。早起敷座处已。遣使白佛时到。食具已办佛自知时。六群比丘与十七群比丘常共相违斗诤。时十七群比丘次守僧坊。六群比丘次与迎食。六群比丘共相谓言。我等今日故断十七群比丘食。有言云何断。答言。但来当知。六群比丘到十七群比丘所。索钵言。与汝迎食分。即随佛及僧至所请家。六群比丘先食已。迎十七群比丘食分便出。出已便作余事。经过余处诸知识家。见已出城。或坐树下。或在岸上井上池上多人众处住。时十七群比丘年少饥急。共相谓言。食何故迟。又相谓言。上祇洹门外大树上。遥看见不。时有一比丘。上树看见言。在某树下井上岸下多人众中住。至日垂中。额上流汗方来唤言。汝取食分。问言。何故迟耶。答言。我等得食便出。问言。汝等不在某树下岸下多人众中住耶。而言得食便出。六群比丘言。谁道耶。十七群比丘言。我上树上见。是中有比丘。少欲知足行头陀。闻是事心不喜。诃责言。云何名比丘。佛未听上树而上。种种因缘诃已向佛广说。佛知故问十七群比丘。汝实作是事不。答言。实作世尊。佛种种因缘诃责十七群比丘。云何名比丘。我未听上树而上。种种因缘诃已语诸比丘。树过人不应上。除急因缘。应当学。若比丘上过人树。无急因缘突吉罗。若急因缘不犯(一百七众学法竟)

    七灭诤法初

佛在王舍城。尔时六群比丘劝檀越作浴。已办浴具。有客比丘。冥来脱衣着诸衣上入浴室洗。有因缘故衣服杂错。客比丘洗已出。于本处取衣。出外看是他衣。作是念此衣当还本处更觅我衣。还入衣处。六群比丘。常与善好比丘相违。见客比丘入已。语客比丘言。汝已出。何故来还。答言。我后来脱衣着诸衣上。入浴室洗。有因缘故衣服杂错。先洗浴已出取衣。出外看非我衣。作是念。此衣当还本处更觅我衣。是故来还。六群比丘言。不如汝言。汝以偷心取。取已心悔。欲着本处。汝见罪不。答言不见。六群比丘共相谓言。此云何直尔不自言罪。当与作不见摈。六群比丘即为作不见摈。摈是客比丘。客比丘作是念。六群比丘为我作不见摈。无因缘本末。我不自言罪。我今何不往舍卫国诣佛所。是比丘于王舍城随意住已。持衣钵游行向舍卫国诣佛所。诸佛常法有客比丘来。以如是语劳问。忍不足不。乞食不乏。道路不疲耶。尔时佛问客比丘。忍不足不。乞食不难。道路不疲耶客比丘言。忍足乞食不难道路不疲。即以上事向佛广说。佛知故问是比丘。六群比丘何故与汝作不见摈。比丘白佛言。世尊。无因缘本末。我不自言罪。强为我作不见摈。佛言。若六群比丘。无因缘本末。汝不自言罪。强为汝作不见摈者。汝莫愁忧。我当与汝作法伴佐助汝。佛言。从今听自言灭诤法。用是自言灭诤。众僧中种种事起应灭。自言灭诤。有十种非法十种如法。十种非法者。若比丘犯波罗夷罪。自言不犯。众僧问言。汝自说犯不。自言不犯。是名非法。又比丘犯僧伽婆尸沙波逸提波罗提提舍尼突吉罗。自言不犯。众僧问言。汝自说犯不。自言不犯。是名非法。又比丘不犯波罗夷。自言我犯。众僧问言。汝自说犯波罗夷不。自言我犯波罗夷。是名非法。又比丘不犯僧伽婆尸沙波逸提波罗提提舍尼突吉罗。自言我犯。众僧问言。汝自说犯不。自言我犯。是名十非法。十种如法者。有比丘犯波罗夷。自言我犯波罗夷。众僧问言。汝自说犯不。自言我犯。是名如法。又比丘犯僧伽婆尸沙波逸提波罗提提舍尼突吉罗。自言我犯。众僧问言。汝自说犯不。自言我犯。是名如法。又比丘不犯波罗夷。自言不犯波罗夷。众僧问言。汝自说犯不。自言不犯。是名如法。又比丘不犯僧伽婆尸沙波逸提波罗提提舍尼突吉罗。自言不犯。众僧问言。汝自说犯不。自言不犯。是名十如法自言(一法)

尔时六群比丘闻是事。我等王舍城中。作不见摈比丘。到舍卫国。诸比丘共事共住。我等当往舍卫国。六群比丘随意住王舍城已。持衣钵往舍卫国诣佛所。尔时多有比丘。祇洹门间空地经行。六群比丘见已问言。我等王舍城与不见摈比丘。来到舍卫国。汝诸比丘共事共住耶。诸比丘答言。佛以自言灭诤灭是事。六群比丘言。此事不灭恶灭。我等不现前故。尔时六群比丘佛听自言灭诤法。违逆不受。谤佛知见事。是中有比丘。少欲知足行头陀。闻是事心不喜。作是言。云何名比丘。世尊听自言灭诤法。违逆不受。谤佛知见事。种种因缘诃已向佛广说。佛以是事集比丘僧。种种因缘诃责六群比丘。云何名比丘。我听自言灭诤法。违逆不受。谤如来知见事。种种因缘诃已语诸比丘。从今听现前灭诤法。用是现前灭诤。僧中种种事起应灭。现前灭诤。有二种非法二种如法。二种非法者。有非法僧。约敕非法僧令折伏。与现前灭诤。又非法僧。约敕非法三人令折伏。与现前灭诤。又不如法僧。约敕不如法二人一人令折伏。与现前灭诤。又不如法三人。约敕不如法三人。令折伏与现前比尼又不如法三人。约敕不如法二人一人僧。令折伏与现前比尼。又不如法二人。约敕不如法二人一人僧三人。令折伏与现前比尼。又不如法一人。约敕不如法一人僧三人二人。令折伏与现前比尼。是名一非法现前比尼法。又不如法僧。约敕如法僧。令折伏与现前比尼。又不如法僧。约敕如法三人二人一人。令折伏与现前比尼。又不如法三人。约敕如法三人二人一人僧。令折伏与现前比尼。又不如法二人。约敕如法二人一人僧三人。令折伏与现前比尼。又不如法一人。约敕如法一人僧三人二人。令折伏与现前比尼。是名二非法现前比尼法。二种如法现前比尼者。有如法僧。约敕如法僧。令折伏与现前比尼。又如法僧。约敕如法三人二人一人。令折伏与现前比尼。又如法三人。约敕如法三人二人一人僧。令折伏与现前比尼。又如法二人约敕如法二人一人僧三人。令折伏与现前比尼。又如法一人。约敕如法一人僧三人二人。令折伏与现前比尼。是名一如法现前比尼法。又如法僧。约敕不如法僧。令折伏与现前比尼。又如法僧。约敕不如法三人二人一人。令折伏与现前比尼。又如法三人。约敕不如法三人二人一人僧。令折伏与现前比尼。又如法二人。约敕不如法二人一人僧三人。令折伏与现前比尼。又如法一人。约敕不如法一人僧三人二人。令折伏与现前比尼。是名二种如法现前比尼(二法)

佛在王舍城。尔时长老陀骠力士子。为弥多罗比丘尼。以无根波罗夷谤故。若僧若三人二人一人。常说是事。尔时陀骠力士子。以是事语诸比丘。弥多罗比丘尼。以无根波罗夷谤我故。若僧三人二人一人。常说是事。我当云何。诸比丘以是事白佛。佛以是事集比丘僧。佛知故问陀骠力士子。汝实为弥多罗比丘尼。以无根波罗夷谤故。若僧三人二人一人。常说是事。汝向诸比丘说。我当云何。汝实尔不。答言。实尔世尊。佛言。从今听忆念比尼法。用是忆念比尼法。僧中种种事起应灭。有三种非法忆念比尼。有三种如法忆念比尼。三种非法者。有比丘犯无残罪。自言犯有残罪。是比丘从僧乞忆念比尼。若僧与是比丘忆念比尼。是名非法。何以故。是人应与灭摈故。又如施越比丘。狂痴心颠倒故。多作不清净非法不随顺道非沙门法。是人还得本心。先所作罪。若僧三人二人一人。常说是事。是人从僧乞忆念比尼。若僧与是人忆念比尼。是名非法。何以故。是人应与不痴比尼故。又如诃多比丘。无惭无愧破戒。有见闻疑罪。是人自言我有是罪。后言我无是罪。是人从僧乞忆念比尼。若僧与是人忆念比尼。是名非法。何以故。是人应与实觅比尼故。是名三非法忆念比尼。三如法者。又比丘。如陀骠比丘。为弥多罗比丘尼。无根波罗夷谤故。若僧三人二人一人。常说是事。是比丘从僧乞忆念比尼。若僧与是人忆念比尼。是名如法。何以故。是人应与忆念比尼故。又如一比丘犯罪。是罪已发露。如法悔过除灭。若僧三人二人一人。犹说是事。是比丘从僧乞忆念比尼。若僧与是人忆念比尼。是名如法。何以故。是人应与忆念比尼故。又如比丘未犯是罪。将必当犯。以是事故。若僧三人二人一人。说犯是罪。是比丘从僧乞忆念比尼。若僧与是比丘忆念比尼。是名如法。何以故。是人应与忆念比尼故。是名三如法忆念比尼。佛如是语已语诸比丘。汝等与陀骠比丘忆念比尼。若更有如是人。亦应与忆念比尼。忆念比尼法者。是陀骠比丘。应从坐起偏袒右肩脱革屣胡跪合掌言。大德僧听。我陀骠比丘。为弥多罗比丘尼。以无根波罗夷法谤故。若僧三人二人一人。常说是事。我今从僧乞忆念比尼。若僧三人二人一人。莫复更说是事。僧怜愍故。与我忆念比尼。如是再三乞。尔时一比丘僧中唱言。大德僧听。是陀骠比丘。为弥多罗比丘尼。以无根波罗夷法谤故。僧三人二人一人常说是事。今陀骠比丘从僧乞忆念比尼。若僧三人二人一人莫复更说是事。若僧时到僧忍听。僧与陀骠比丘忆念比尼。若僧三人二人一人莫复更说是事。是名白。如是白四羯磨。僧与陀骠忆念比尼竟。僧忍默然故。是事如是持。得忆念比尼比丘行法者。余比丘不应出其过罪。不应令忆念。不应从乞听。亦不应受余比丘乞听。若彼从乞听。得突吉罗。若受他听亦得突吉罗若彼不听。若出过罪。若令忆念。得波逸提(三法)

佛在舍卫国。尔时有比丘。名施越。痴狂心颠倒故。多作不清净非法不随顺道非沙门法。是人还得本心。先所作罪。若僧三人二人一人常说是事。施越语诸比丘。我本狂痴心颠倒故。多作不清净非法不随顺道非沙门法。我今还得本心。若僧三人二人一人常说我本所作罪。我今当云何。诸比丘以是事向佛广说。佛知而故问施越。汝实狂痴心颠倒故。多作不清净非法不随顺道非沙门法。汝还得本心。若僧三人二人一人说汝本所作罪。汝向诸比丘说。我当云何。汝实尔不。答言。实尔世尊。佛言。从今听不痴比尼。用是不痴比尼。僧中有种种事起应灭。不痴比尼。有四种非法四种如法。四种非法者。有比丘不痴狂颠倒。现痴狂相貌。诸比丘僧中问。汝狂痴时所作。今忆念不。答言。长老。我忆念痴故作。他人教我使作。忆梦中作。忆裸形东西走立大小便。是人从僧乞不痴比尼。若僧与是人不痴比尼。是名四非法。四如法者。有比丘实狂痴心颠倒。现狂痴相貌。诸比丘问。汝忆念狂痴时所作不。答言。不忆念。他所教我作。不忆梦中所作。不忆裸形东西走立大小便。是人从僧乞不痴比尼。若僧与是人不痴比尼。是名四如法不痴比尼。佛言。从今听不痴比尼。用是不痴比尼。僧中种种事起应灭。尔时佛语诸比丘。汝等与施越比丘不痴比尼。若更有如是人。僧亦应与不痴比尼。与法者。是施越比丘。应从坐起偏袒右肩脱革屣胡跪合掌言。大德僧听。我施越比丘。本狂痴心颠倒。多作不清净非法不随顺道非沙门法。我今还得本心。若僧三人二人一人说我先所作罪。我今从僧乞不痴比尼。若僧三人二人一人莫复更说是事。僧怜愍故。与我不痴比尼。如是再三乞。尔时一比丘僧中唱大德僧听。是施越比丘。本狂痴心颠倒。多作不清净非法不随顺道非沙门法。今得本心。若僧三人二人一人说先所作罪。今施越比丘从僧乞不痴比尼。若僧三人二人一人莫复更说是事。若僧时到僧忍听。与施越比丘不痴比尼。若僧三人二人一人莫复更说是事。白如是。如是白四羯磨。僧与施越比丘不痴比尼竟。僧忍默然故。是事如是持。得不痴比尼行法者。余比丘不应出其过罪。不应令忆念。不应从乞听。亦不应受他比丘乞听。若从彼乞听得突吉罗。若受他乞听亦得突吉罗。若彼不听。便出过罪。若令忆念。得波逸提(四法)

佛在迦维罗卫国。尔时有比丘。名诃哆。无惭无愧恶欲。有见闻疑罪。是比丘先自言作。后言不作。诸比丘以是事向佛广说。佛以是事集比丘僧。语诸比丘。从今听实觅灭诤。用是实觅比尼。僧中种种事起应灭。实觅比尼。有五种非法五种如法。五非法者。有比丘犯波罗夷罪。先言不犯后言犯。若僧与是人实觅比尼。是名非法。何以故。是人应与灭摈故。有比丘犯僧伽婆尸沙波逸提波罗提提舍尼突吉罗。先言不犯后言犯。若僧与是人实觅比尼。是名非法。何以故。是人随所犯应治故。五如法者。有比丘犯波罗夷。先言犯后言不犯。若僧与是比丘实觅比尼。是名如法。何以故。是人应与实觅比尼故。若比丘犯僧伽婆尸沙波逸提波罗提提舍尼突吉罗。先言犯后言不犯。若僧与是比丘实觅比尼。是名如法。何以故。是人应与实觅比尼故。佛语诸比丘。汝等与诃哆比丘实觅比尼。若更有如是比丘者。僧亦应与实觅比尼。与法者。一心和合僧。一比丘僧中唱言。大德僧听。是呵哆比丘无惭无愧恶欲。有见闻疑罪。先自言犯后言不犯。以是故。僧与实觅比尼。若僧时到僧忍听。与诃哆比丘实觅比尼。白如是。如是白四羯磨。僧与诃哆比丘实觅比尼法竟。僧忍默然故。是事如是持。得实觅比尼行法者。是比丘不应与他受大戒。不得受他依止。不应畜沙弥。不应受教诫比丘尼法。若僧羯磨教诫比丘尼。不应教他。僧所与作实觅比尼罪。更不应犯。若似是罪及过是罪。亦不应作。不应诃僧羯磨。亦不应诃作羯磨人。不应举清净比丘。不应令他忆念。不应相言。不应从他乞听。欲出他罪。亦不应受他乞听。不应遮说戒。不应遮受戒。不应遮自恣。不应出清净比丘过罪恒自谦卑。应调伏心行。随顺比丘僧意。若不如是行法者。尽形不得离是羯磨(五法)

佛在俱舍弥国。尔时俱舍弥诸比丘。喜斗诤相言多少事起。作是念。若长老舍利弗作断事主者。我等当得决了。诸比丘以是事向佛广说。佛知故问阿难。有闼赖吒比丘。能受作断事主不。阿难白佛言。世尊。有能受作断事主。佛即以是事集比丘僧。语诸比丘。从今听闼赖吒比丘作断事主。受是断事法。如法如比尼如佛教现前除灭。闼赖吒有三种。有身善口不善。有口善身不善。有身善口善。身善口不善者。是闼赖吒。自不往到举事者有事者所。不自作是言。从是事若好若不好。应尔起不应尔起。若汝胜彼负。彼胜汝负。是人虽不自去语。便遣使往作是言。汝从是事。若好若不好。应尔起不应尔起。若汝胜彼负。彼胜汝负。是名身善口不善。口善身不善者。自身往到举事者有事者所已。不作是言。从是事若好若不好。应尔起不应尔起。若汝胜彼负彼胜汝负。不遣使到举事者有事者所作是言。从是事若好若不好。应尔起不应尔起。若汝胜彼负彼胜汝负。是名口善身不善。口善身善者。不自往到举事者有事者所。不作是言。从是事若好若不好。应尔起不应尔起。若汝胜彼负彼胜汝负。又不遣使往到举事者有事者所作是言。从是事若好若不好。应尔起不应尔起。若汝胜彼负彼胜汝负。是名身善口善。从今作闼赖吒者。应如是学。不应与举事者有事者同一道行。亦不得别与一人同一道行。不应共期。若先有少多因缘与期。应灭是期。期者。若中前若中后。若昼若夜。若阿练儿处。若近聚落僧坊。是闼赖吒应受是所断事。如法如比尼如佛教现前除灭。用一比尼所谓现前比尼。何等现前。现前有二种。人现前比尼现前。人现前者。谓有随助举事人及有事人共集一处。比尼现前者。如法如比尼如佛教断是事。是名比尼现前。若是闼赖吒不能如法如比尼如佛教断是事者。应舍付僧。僧应受是事。如法如比尼如佛教断是事。若僧能如法如比尼如佛教断是事者。是名为断用一比尼。所谓现前比尼。现前比尼者。僧现前人现前比尼现前。僧现前者。是中所有可中共作羯磨比丘。共同心和合一处。可受欲者持欲来。现前在比丘能遮者不遮。是名僧现前。人现前者。有随助举事人有事人共集一处。是名人现前。比尼现前者。如法如比尼如佛教断是事。是名比尼现前。若僧不能如法如比尼如佛教断是事者。尔时应僧中举乌回鸠罗。应羯磨乌回鸠罗令断是事。羯磨法者。一心和合僧。一比丘僧中问言。谁能作乌回鸠罗。如法如比尼如佛教断是事。僧中若言我能。若有五法。不应立作乌回鸠罗。何等五。随爱行随嗔行随怖行随痴行不知断不断。成就五法。应立作乌回鸠罗。不随爱行不随嗔行不随怖行不随痴行能知断不断。即时一比丘应僧中唱言。大德僧听。某甲某甲比丘。能作乌回鸠罗。如法如比尼如佛教断随僧中事。若僧时到僧忍听。某甲某甲比丘作乌回鸠罗。能如法断随僧中事。是名白。如是白二羯磨。僧立某甲某甲比丘作乌回鸠罗断随僧中事竟。僧忍默然故是事如是持。是乌回鸠罗。若是上座。诸下座比丘应与此人欲已远去。若此乌回鸠罗是下座。应从诸上座取欲已小远去。当如法如比尼如佛教断是事。若乌回鸠罗。能如法如比尼如佛教断是事者。是名为断用一比尼。所谓现前比尼。现前比尼者。僧现前人现前比尼现前。僧现前者如上说。人现前比尼现前亦如上说。若乌回鸠罗。不能如法如比尼如佛教断是事者。应更立乌回鸠罗。立法者。一心和合僧。一比丘僧中问言。谁能作乌回鸠罗断随僧中事。若言我能。一比丘僧中唱言。大德僧听。某甲某甲比丘。能作乌回鸠罗。如法断随僧中事。若僧时到僧忍听。某甲某甲比丘作乌回鸠罗。能如法断随僧中事。是名白。如是白二羯磨。僧立某甲某甲比丘作乌回鸠罗断随僧中事竟。僧忍默然故是事如是持。是乌回鸠罗若是上座。诸下座比丘应与欲已小远去。若乌回鸠罗是下座。应从诸上座取欲已小远去。当如法如比尼如佛教断是事。若乌回鸠罗能如法如比尼如佛教断是事者。是名为断用一比尼。谓现前比尼。现前比尼者。僧现前人现前比尼现前。僧现前者如上说。人现前比尼现前亦如上说。若是乌回鸠罗。不能如法断者。还付先乌回鸠罗。先乌回鸠罗。应如法如比尼如佛教断。若能如法断是事者。是名为断用一比尼。谓现前比尼。现前比尼者。僧现前人现前比尼现前。僧现前者如上说。人现前比尼现前亦如上说。若是先乌回鸠罗。复不能如法如比尼如佛教断是事者。应舍付僧。僧应受是事。如法如比尼如佛教断。若僧取是事。能如法如比尼如佛教断者。是名为断用一比尼。谓现前比尼。现前比尼者。僧现前人现前比尼现前。僧现前如上说。人现前比尼现前亦如上说。若僧不能如法如比尼如佛教断是事者。僧应遣使往近处僧所作是言。此事如是如是因缘起。闼赖吒不能断。众僧不能断。先乌回鸠罗不能断。后乌回鸠罗亦不能断。还付先乌回鸠罗。先乌回鸠罗不能断。还付众僧。汝等大德。和合来为断是事故。即时彼众应和合。若僧先安居。应受七日去。若七日尽。应破安居去。为和合故。是近处僧应受是事。如法如比尼如佛教断。若近处僧。能如法如比尼如佛教断是事者。是名为断用一比尼。谓现前比尼现前比尼者。僧现前人现前比尼现前。僧现前如上说。人现前比尼现前亦如上说。若近处僧。不能如法如比尼如佛教断是事者。尔时应僧中羯磨乌回鸠罗令断。羯磨者。一心和合僧。一比丘僧中问言。谁能作乌回鸠罗。如法如比尼如佛教断此随僧中事。是中若言我能。若有五法。不应立作乌回鸠罗。何等五。随爱随嗔随怖随痴不知断不断。若成就五法。应立作乌回鸠罗。不随爱不随嗔不随怖不随痴知断不断。即时一比丘僧中唱言。大德僧听。某甲某甲比丘。能作乌回鸠罗。能如法断随僧中事。若僧时到僧忍听。某甲某甲比丘作乌回鸠罗。如法断随僧中事。是名白如是白二羯磨。僧立某甲某甲比丘作乌回鸠罗断随僧中事竟。僧忍默然故是事如是持。是乌回鸠罗若是上座。诸下座比丘。应来与此比丘欲已远去。若是下座。应从诸上座比丘取欲已小远去。当如法如比尼如佛教断是事。是乌回鸠罗。若能如法如比尼如佛教断是事者。是名为断用一比尼。谓现前比尼。现前比尼者。僧现前人现前比尼现前。僧现前者如上说。人现前比尼现前亦如上说。若是乌回鸠罗。不能如法如比尼如佛教断是事者。应更立乌回鸠罗。立法者。一心和合僧。一比丘僧中问言。谁能作乌回鸠罗。如法断随僧中事。若言我能。一比丘僧中唱言。大德僧听。某甲某甲比丘。能作乌回鸠罗。如法断随僧中事。若僧时到僧忍听。某甲某甲比丘。作乌回鸠罗。断随僧中事。是名白。如是白二羯磨。立某甲某甲比丘作乌回鸠罗断随僧中事竟。僧忍默然故是事如是持。是乌回鸠罗若是上座。诸下座比丘应与欲已小远去。若乌回鸠罗是下座。应从诸上座取欲已小远去。应如法如比尼如佛教断是事。若乌回鸠罗。能如法如比尼如佛教断是事者。是名为断用一比尼。谓现前比尼。现前比尼者。僧现前人现前比尼现前。僧现前如上说。人现前比尼现前亦如上说。若是乌回鸠罗。不能如法如比尼如佛教断是事者。应还付先乌回鸠罗。先乌回鸠罗应受是事。如法如比尼如佛教断是事。是乌回鸠罗。若能如法如比尼如佛教断是事者。是名为断用一比尼。谓现前比尼。现前比尼者。僧现前人现前比尼现前。僧现前者如上说。人现前比尼现前亦如上说。若是先乌回鸠罗。复不能如法如比尼如佛教断者。应舍付僧。僧应受是事。如法如比尼如佛教断。若僧受是事。能如法如比尼如佛教断者。是名为断用一比尼。谓现前比尼。现前比尼者。僧现前人现前比尼现前。僧现前如上说。人现前比尼现前亦如上说。若是近处僧。不能如法如比尼如佛教断是事者。闻某住处僧。若有大众好上座知波罗提木叉。是僧中多有比丘。持修多罗者。持比尼者。持摩多罗伽者。是近处僧。应以是事遣使至某住处。僧中应先立传事人。若界外令满僧数。立法者。一心和合僧应问言。谁能作传事人。从是处持是事至某处。若道中能断者好。是中若有人言我能。若有五法。不应立作传事人。随爱随嗔随怖随痴不知灭不灭。若成就五法。应立作传事人。不随爱不随嗔不随怖不随痴知灭不灭。尔时是传事人。应持是事去。若道中能如法如比尼如佛教断者。是名为断用一比尼。谓现前比尼。现前比尼者。僧现前人现前比尼现前。僧现前如上说。人现前比尼现前亦如上说

若传事人。不能道中如法如比尼如佛教断者。应持至彼僧中。是僧中若有上座多知多识长老比丘。应语是人。是事如是如是因缘起。闼赖吒不能断。众僧不能断。先乌回鸠罗不能断。后乌回鸠罗亦不能断。还付先乌回鸠罗。先乌回鸠罗复不能断。还付僧。僧复不能断。近住处僧亦不能断。近住处乌回鸠罗不能断。后乌回鸠罗亦不能断。还付先乌回鸠罗。复不能断。还近住处僧复不能断。传事人道中不能断是事来是间。汝长老。能受是事断不。若言能断。应与作期。若不作期。不得与汝。期者。乃至九月。事有五种难断。一者坚。二者强。三者佷戾。四者往来。五者疑畏。坚者。坚执其事。强者。举事人有事人勇健强力。佷戾者。举事人有事人恶性嗔恨。往来者。此事从一住处至一住处。疑畏者。诸比丘畏断事时。破一心和合僧作两段故。先应立行筹人。如是应立。一心和合僧应问言。谁能作行筹人。是中有人言我能。有五法。不应立作行筹人。随爱随嗔随怖随痴不知行筹不行筹。若成就五法。应立作行筹人。不随爱不随嗔不随怖不随痴知行筹不行筹。是中一比丘唱言。大德僧听。某甲比丘能作行筹人。若僧时到僧忍听。某甲比丘。为僧作行筹人。是名白。如是白二羯磨。僧与某甲比丘作行筹人竟。僧忍默然故是事如是持。若比丘已作行筹人。随僧多少应作二种筹。一分长一分短。一分白一分黑。说如法者为作长筹。说非法者为作短筹。说如法者为作白筹。说非法者为作黑筹。说如法筹以右手捉。说非法筹以左手捉。说如法筹缓捉。说非法筹急捉。先行说如法筹。后行说非法筹。行筹人应作是言。此是说如法者筹。此是说非法者筹。若行筹竟。说如法者筹乃至多一。是事名断用二比尼。谓现前比尼多觅比尼。现前比尼者。是中若有随助举事人有事人。共和合一处现前。如法如比尼如佛教现前除断。是名现前比尼。多觅比尼者。是中求觅往反问如法除断。若说非法者筹乃至多一。是事亦名为断用二比尼。现前比尼多觅比尼。现前比尼者。是中若有随助。举事人及有事人。共和合在一处现前。非法非比尼非佛教除断。行筹人有四种。一者藏行筹。二者颠倒行筹。三者期行筹。四者一切行筹。藏行筹者。若有人闇中行筹。若壁障处行筹。是名覆藏行筹。颠倒行筹者。若比丘颠倒行筹。以说如法人筹。与说非法人。以说非法人筹。与说如法人。是名颠倒。期者。若诸比丘随和上阿阇梨作期。随同和上同阿阇梨。随相识随共语。随善知识随同心。随国土随聚落随家。共作期。我等取如是筹。汝等莫远我边。莫别莫异。莫不共语。共同事。是名期。一切僧取筹者。尔时一切僧。应和合一处。不得取欲。何以故。或多比丘说非法故。是名一切僧取筹。若是众僧大上座知波罗提木叉者。能断是事者。即名为断用一比尼。谓现前比尼。是中现前比尼者。僧现前人现前比尼现前。僧现前如上说。人现前比尼现前亦如上说。若是大上座知波罗提木叉比丘僧。不能断是事者。应还付传事人。传事人应取是事。于道中能如法如比尼如佛教断。若是传事人。于道中能如法如比尼如佛教断是事者。是名为断用一比尼。谓现前比尼。现前比尼者如上说。若是传事人。不能如法如比尼如佛教断是事者。是比丘道中。若闻彼处僧坊中。若有三比丘若二若一比丘。能持修多罗持比尼持摩多罗伽。四众所恭敬尊重。是传事人。应到彼住处语彼一比丘言。大德。是中事如是如是因缘起。闼赖吒不能断。僧不能断。先乌回鸠罗不能断。后乌回鸠罗不能断。还付先乌回鸠罗。复不能断。还是僧复不能断。近住处僧亦不能断。先乌回鸠罗不能断。后乌回鸠罗不能断。还先乌回鸠罗复不能断。还近住处僧复不能断。传事人道中亦不能断。大上座持律比丘僧不能断。传事人于道中不能断。三比丘二比丘不能断。大德取是事。如法如比尼如佛教断是事。是一比丘四众所恭敬尊重赞叹者。应作是言。不可二人相言俱得胜。是中必一胜一负。若作如是语者。是名如法说。若不作如是语者。是名非法说。是诸相言比丘。若如法断是事已。还更发起。犯波逸提。若但诃责言是断不如法。犯突吉罗(六法)

佛在俱舍弥国。尔时俱舍弥比丘喜斗诤相言。诸比丘以是事向佛广说。佛言。从今听布草比尼。用是布草比尼。僧中种种事起应灭。云何布草比尼。以是布草比尼法。灭僧中种种所起事。或有一住处。诸比丘喜斗诤相言。是诸比丘应和合一处已。应作是念。诸长老。我等大失非得。大衰非利。大恶不善。我等以信故。佛法中出家求道。然今喜斗诤相言。若我等求是事根本者。僧中或有未起事便起。已起事不可灭。作是念故白众僧。若僧时到僧忍听。是事以布草比尼法灭。是名白。即时是诸比丘应分作两部各在一处。是中若有事比丘。向上座大长老应作是言。我等大失非得大衰非利大恶不善。我等以信故。佛法中出家求道。然今喜斗诤相言。若我等求是事根本者。僧中或有未起事便起。已起事不可灭。今我等当自屈意。我等所作罪。除偷兰遮罪。除白衣相应罪。是事我等向长老。现前发露悔过不覆藏。是中若无一比丘遮是事者。应到第二部众所。是中若有长老上座应语言。我等大失非得大衰非利大恶不善。我等以信故。于佛法中出家求道。今喜斗诤相言。若我等求是事根本者。僧中或有未起事便起。已起事不可灭。今我等当自屈意。我等所作罪。除偷兰遮。除白衣相应罪。今自为及为彼故。当现前发露悔过不覆藏。诸比丘言。汝自见罪不。答言见罪。如法悔过莫复更起。第二部众亦如是说。是名如草布地比尼法(七法第三诵竟)

十诵律卷第二十十诵律卷第二十一(第四诵之一)

        后秦北印度三藏弗若多罗译

    七法中受具足戒法第一

佛婆伽婆王舍城外住。尔时未听比丘作和尚阿阇梨。未有白四羯磨受具足戒。时诸比丘以初未有和尚阿阇梨故。作袈裟衣不如法。着衣亦不如法。及身威仪皆不如法。又诸比丘从聚落至聚落。从城至城。从国至国。游行时行乞食时。乞饭乞羹乞佉陀尼。人请食时。索饭索羹索佉陀尼。取他残食钵残饭残羹残佉陀尼残浆。高声大声食。譬如婆罗门食。有一比丘摩诃卢患苦痛。无有等侣无人看视。外学异道。见如是事讥嫌呵责。沙门释子无善教。不被教无调顺无调御法。作袈裟衣不如法。着衣亦不如法。及身威仪皆不如法。从聚落至聚落。从城至城。从国至国。游行时行乞食时。乞饭乞羹乞佉陀尼。人请食时。索饭索羹索佉陀尼。取他残食钵残饭残羹残佉陀尼残浆。高声大声食。譬如诸婆罗门食。有诸比丘。少欲知足行头陀。闻是事心惭愧。以是事具白佛。佛以是因缘集僧。集僧竟。诸佛常法。有知而问知而不问。知时问知时不问。有益问无益不问。有因缘问。今佛知故问。佛问诸比丘。汝实尔不。答言。实尔世尊。佛种种因缘呵责。何以名比丘。无和尚阿阇梨。作袈裟衣不如法。着衣不如法。及身威仪皆不如法。从聚落至聚落。从城至城。从国至国。游行时行乞食时。乞饭乞羹乞佉陀尼。人请食时。索饭索羹索佉陀尼。取他残食钵残饭残羹残佉陀尼残浆。高声大声食。譬如诸婆罗门食。诸外学异道嫉妒讥嫌呵责言。沙门释子无善教。不被教无调顺无调御法。作袈裟衣不如法。着衣不如法。及身威仪皆不如法。从聚落至聚落。从城至城。从国至国。游行时行乞食时。乞饭乞羹乞佉陀尼。人请食时。索饭索羹索佉陀尼。取他残食钵残饭残羹残佉陀尼残浆。高声大声食。譬如诸婆罗门食。佛种种因缘诃已语诸比丘。从今听作和尚阿阇梨。听十僧现前白四羯磨受具足。云何白四羯磨受具足。众僧一心和合。一比丘僧中唱。大德僧听。是某甲。从某甲受具足戒。是从僧乞受具足戒某甲。和尚某甲。若僧时到僧忍听。僧当与某甲受具足和尚某甲。如是白。白四羯磨。从今听和尚共行弟子。若病应看欲死应救。若病应与随病饮食随病药随病供给。若弟子无财。和尚应给。若和尚无。从他索与。若少知识索不能得。乞食得好食应与。若和尚病弟子亦尔。阿阇梨看近住弟子。近住弟子看阿阇梨亦如是。从今诸有和尚阿阇梨。看共住弟子近住弟子。养畜如儿想。共住弟子近住弟子。看和尚阿阇梨如父想。汝等如是展转相依住。于我法中增长善法

佛在王舍城。是时诸比丘心念。佛已听我等作和尚阿阇梨。已听十僧现前白四羯磨受具足戒。彼年少比丘作和尚。若一岁二岁三岁四岁五岁。少长老比丘作师。是中有比丘。少欲知足行头陀。诃责诸比丘。何以名比丘。佛已听我等作和尚阿阇梨。听十僧现前白四羯磨受具足戒。年少比丘作和尚。若一岁二岁三岁四岁五岁。少长老比丘。彼诸比丘种种诃已。以是事具白佛。佛以是因缘集僧。集僧竟。佛知故问。问诸比丘。汝等实尔不。答言。实尔世尊。佛种种因缘诃诸比丘。何以名比丘。佛已听我等作和尚阿阇梨。听十僧现前白四羯磨受具足戒。年少比丘作和尚。若一岁二岁三岁四岁五岁。少长老比丘。佛虽呵责。而未结戒。佛在舍卫国。尔时长老优波斯那婆檀提子。一岁授共住弟子具足和尚一岁弟子无岁共往。憍萨罗国一处夏安居。诸佛常法。两时大会。春末月夏末月。春末月欲安居时。诸方国比丘来。听佛说法。心念。是法夏安居乐。是初大会。夏末月自恣作衣竟。持衣钵来诣佛所。如是思惟。我久不见婆伽婆。久不见修伽陀。是第二大会。是时长老优波斯那。是中住处夏安居。自恣竟作衣已持衣钵。自身二岁弟子一岁。共游行往舍卫国。到佛所头面礼佛足一面坐。诸佛常法。问讯客比丘。夏安居忍不足不。安乐住不。乞食不乏道路不疲耶。今佛亦如是问。优波斯那。夏安居忍不足不。安乐住不。乞食不乏道路不疲耶。优波斯那答言。实忍足安乐住乞食不乏道路不疲。佛知故问。优波斯那。是谁善男子。答言。是我许。佛言。是作何等。答言。是我共住弟子。佛言。汝几岁。答言二岁。是善男子几岁。答言一岁。佛以是事集僧。集僧已。佛种种因缘诃优波斯那。汝愚痴人。何故。来思惟但欲畜众。二岁比丘。畜一岁共住弟子。何以名比丘。佛听我等作和尚阿阇梨。听十僧现前白四羯磨受具足戒。是年少比丘。授共住弟子具足。一岁二岁三岁四岁五岁。少长老比丘。佛种种因缘诃竟。语诸比丘。从今不满十岁。不得授共住弟子具足。若授具足犯突吉罗

是时诸比丘心念。佛听我和尚。听阿阇梨。听十僧现前白四羯磨受具足戒。不满十岁不得授共住弟子具足。是诸比丘满十岁。皆授共住弟子具足。知法授不知法亦授。善者畜不善亦畜。住戒度不住戒亦度。是中见和尚不知法。弟子亦不知法。和尚不善弟子亦不善。和尚不住戒。弟子亦不住戒。是时诸比丘。自不知法不善不住戒。与他出家受具足。作依止师畜沙弥。有一比丘摩诃卢。不知法不善不住戒。空满十岁。与共住弟子授具足。以小事与弟子斗诤。弟子舍戒还俗。诸比丘少欲知足行头陀。诃责言。何以名比丘。佛听和尚。听阿阇梨。听十僧现前白四羯磨受具足戒。不满十岁不得授共住弟子具足。是诸比丘满十岁。皆授共住弟子具足。知法授不知法亦授。善者畜不善亦畜。住戒度不住戒亦度。是中见和尚不知法。不善不住戒。弟子亦尔。与他出家受具足。作依止师畜沙弥。彼诸比丘种种诃竟。以是事具白佛。佛以是因缘集僧。集僧已。佛知故问。问诸比丘。汝实尔不。答言。实尔世尊。佛种种因缘诃责。何以名比丘。佛听和尚。听阿阇梨。听十僧现前白四羯磨受具足戒。不满十岁不得授共住弟子具足。是诸比丘满十岁。皆授共住弟子具足。知法授不知法亦授。善者畜不善亦畜。住戒度不住戒亦度。是中见和尚不知法。不善不住戒。弟子亦尔。与他出家受具足。作依止师畜沙弥。佛种种因缘诃竟。语诸比丘。从今听五法成就满十岁。若过应授共住弟子具足。何等五。一满十岁若过。二持戒不破。三多闻。四有力能。如法除弟子忧悔。五能拔弟子恶邪。复有五法成就。满十岁应授共住弟子具足。何等五。一信成。二戒成。三闻成。四舍成。五慧成。能赞能教弟子。令善入住信戒闻舍慧。复有五法成就。满十岁应授共住弟子具足。何等五。一无学戒众。二无学定众。三无学慧众。四无学解脱众。五无学解脱知见众成就。能赞能教弟子。善入住戒定慧解脱解脱知见众。复有五法成就。满十岁应授共住弟子具足。何等五。一知犯。二知非犯。三知罪轻。四知罪重。五知诵波罗提木叉学利广说。复有五法成就。满十岁应授共住弟子具足。何等五。一知出家法。二能作教师。三能作戒师。四能知依止师法。五能知遮道法不遮道法。复有五法成就。满十岁应授共住弟子具足。何等五。一能教弟子清净戒。二能教阿毗昙。三能教比尼。四弟子在他方愁苦不乐。能致使来。若自不能因他力致来。五弟子若病能供给。若自不能。能使他供给。如是五法成就。满十岁若过。应授共住弟子具足。若上诸五法不成就。满十岁若过。授共住弟子具足。得罪

若比丘有上诸五法成就。满十岁应与他依止。云何应与。所欲求依止比丘。从座起偏袒着衣脱革屣胡跪两手捉长老两足。应如是语。我某甲比丘。从长老乞依止。长老与我依止。我依止长老住。第二第三亦如是乞。长老应言如汝语若诸五法成就满十岁。应受他依止。若无诸五法。满十岁受他依止。得罪

若比丘有上五法。满十岁应畜沙弥。云何应畜。若未剃发来。是时当与剃发。若自有袈裟应着。若无和尚应与衣着。教长跪合掌。戒师应教。我某甲。归依佛归依法归依僧。第二我某甲。归依佛归依法归依僧。第三我某甲。归依佛归依法归依僧。我某甲。已归依佛已归依法已归依僧。从今尽寿。是佛优婆塞忆持。第二我某甲。已归依佛已归依法已归依僧。从今尽寿。是佛优婆塞忆持。第三我某甲。已归依佛已归依法已归依僧。从今尽寿。是佛优婆塞忆持。汝某甲听。是佛婆伽婆知见。释迦牟尼多陀阿伽度阿罗诃三藐三佛陀说优婆塞五戒。凡是优婆塞尽寿护持。何等五。尽寿离杀生。是优婆塞戒。是中尽寿离杀生。若能持当言能。尽寿离不与取。是优婆塞戒。是中尽寿离不与取。若能持当言能。尽寿离邪淫。是优婆塞戒。是中尽寿离邪淫。若能持当言能。尽寿离妄语。是优婆塞戒。是中尽寿离妄语。若能持当言能尽寿离饮酒。是优婆塞戒。是中尽寿离饮酒。谷酒蒲萄酒甘蔗酒能放逸酒。若能持当言能。我某甲。已归依佛已归依法已归依僧出家。是佛婆伽婆释迦牟尼多陀阿伽度阿罗诃三藐三佛陀出家。我亦随佛出家。和尚某甲。第二我某甲。已归依佛已归依法已归依僧出家。是佛婆伽婆释迦牟尼多陀阿伽度阿罗诃三藐三佛陀出家。我亦随佛出家和尚某甲。第三我某甲。已归依佛已归依法已归依僧出家。是佛婆伽婆释迦牟尼多陀阿伽度阿罗诃三藐三佛陀出家。我亦随佛出家。和尚某甲。我某甲。已归依佛已归依法已归依僧已出家。是佛婆伽婆释迦牟尼多陀阿伽度阿罗诃三藐三佛陀出家。我亦随佛出家竟。和尚某甲。尔时应问。汝几岁。随年答。何时出家。冬春夏有闰无闰随问应答。此事尽寿忆持。戒师应言汝某甲听。是佛婆伽婆知见。释迦牟尼多陀阿伽度阿罗诃三藐三佛陀。为沙弥说出家十戒。凡是沙弥。当尽寿护持。何等十。尽寿离杀生。是沙弥戒。是中尽寿离杀生。若能当言尔。尽寿离不与取。是沙弥戒。是中尽寿离不与取。若能当言尔。尽寿离非梵行。是沙弥戒。是中尽寿离非梵行。若能当言尔。尽寿离妄语。是沙弥戒。是中尽寿离妄语。若能当言尔。尽寿离饮酒。是沙弥戒。是中尽寿离饮酒。谷酒蒲萄酒甘蔗酒能放逸酒。若能当言尔。尽寿离处高床大床。是沙弥戒。是中尽寿离处高床大床。若能当言尔。尽寿离着华璎珞香涂身香熏衣。是沙弥戒。是中尽寿离着华璎珞香涂身香熏衣。若能当言尔。尽寿离作伎歌舞不往观听种种乐器。是沙弥戒。是中尽寿离作伎歌舞不往观听种种庄严。若能当言尔。尽寿离受畜金银钱宝。是沙弥戒。是中尽寿离受畜金银钱宝。若能当言尔。尽寿离非时食。是沙弥戒。是中尽寿离非时食。若能当言尔。如是五法成就。满十岁应畜沙弥。若不成就五法。满十岁畜沙弥。得罪

佛在王舍城。长老大目犍连。与王舍城中和利等。十七诸年少乐人授具足戒。是诸人晡时饥极。僧坊内高声大啼。作小儿啼声。佛知故问阿难。何以僧坊内有小儿啼声。阿难答言。世尊。长老大目犍连。与王舍城中和利等。十七诸年少乐人与受具足。是诸人晡时饥极。僧坊内高声大啼作小儿啼声。是时佛以是因缘集僧。集僧已。佛知故问。问目犍连。汝实作是事不。目连答言。实尔世尊。佛种种因缘诃目犍连。汝不知时。不知量。不知限齐。汝其欲度人。未满二十人。不能忍寒热饥渴蚊虻蚤虱蛇蚖毒螫。他人恶语身中苦痛悉不能忍。满二十岁人。能忍寒热饥渴蚊虻蚤虱蛇蚖毒螫。他人恶语及身中苦痛皆悉能忍。佛种种因缘诃已。语诸比丘。从今不满二十年人。不应与受具足。若与受得波逸提罪

佛在舍卫国。佛语诸比丘。若异道人信善法欲出家。是人应四月与波利婆沙。若满四月得诸比丘意。应与出家。如是应与波利婆沙。一心集僧。是本异道。从坐起偏袒着衣脱革屣。入僧中礼僧足。胡跪合掌作如是言。诸长老忆念。我某甲本异道。今信善法欲出家。我某甲本异道。今僧中乞四月波利婆沙。僧与我某甲本异道四月波利婆沙竟。得诸比丘意。僧当与我出家受具足。第二第三亦如是乞。尔时一比丘。应僧中唱。大德僧听。是某甲本异道。信善法欲出家。今是某甲本异道。从僧乞四月波利婆沙。如是言。僧与我某甲本异道四月波利婆沙竟。得诸比丘意。僧当与我出家受具足。若僧时到僧忍听。僧某甲本异道僧当与四月波利婆沙。如是白。白四羯磨。僧与某甲本异道四月波利婆沙竟僧忍默然故是事如是持。是中云何得意。云何不得意。是本异道现前。应赞佛法僧戒呵诸异道。实若赞佛法僧戒时是本异道心不生喜乐。乃至须臾诃诸异道实时忧愁嗔诤。是名不得意。若赞佛法僧戒时。是本异道心生喜乐。诃诸异道。实时不忧愁不嗔诤。是名得意。如是应与出家受具足。与法者。一心集僧。是本异道从坐起。偏袒着衣脱革屣。入僧中礼僧足胡跪合掌。应如是言。大德僧忆念。我某甲本异道。信善法欲出家。我先已僧中乞四月波利婆沙。僧先已与我四月波利婆沙。我某甲本异道。已僧中行四月波利婆沙竟。我今从僧乞出家受具足。僧与我某甲本异道四月行波利婆沙竟。已得诸比丘意。僧当与我出家受具足。第二第三亦如是乞。是中应一比丘僧中唱。大德僧听。是某甲本异道。信善法欲出家。彼从僧乞四月波利婆沙。僧先已与四月波利婆沙。彼已僧中行四月波利婆沙。行波利婆沙竟。今从僧求出家受具足。若僧时到僧忍听。僧是某甲本异道。已僧中行四月波利婆沙竟。得诸比丘意。当与出家受具足。如是白。白四羯磨。僧是本异道某甲与出家受具足竟。僧忍默然。故是事如是持

佛在王舍城。自恣竟欲二月南山国土游行。是时佛告阿难。汝语诸比丘。佛王舍城自恣竟。欲二月南山国土游行。谁欲从佛。若欲去者集待佛。阿难言受教。即出语诸比丘。佛在王舍城。自恣竟欲二月南山国土游行。谁欲从佛。欲去者集待佛。尔时王舍城多年少比丘。一岁二岁三岁四岁五岁。少大比丘。是诸比丘如是思惟。若从佛去。处处不久住。种种供养利。数数受依止师。来还复速。我和尚阿阇梨不去。我等何以去。诸小比丘不尽从佛。尔时佛与少比丘共行。还到王舍城。佛知故问阿难。何以少比丘从佛行。阿难答言。世尊。是王舍城。多年少比丘。大比丘少。是诸比丘如是思惟。若从佛行。处处不久住。种种供养利。数数受依止师。来还复速。我和尚阿阇梨不去。我等何以去。以是事故多不从佛。佛以是因缘集僧。集僧已。佛种种因缘赞戒赞持戒。赞戒赞持戒已语诸比丘。从今听比丘有五法成就满五岁不受依止。何等五。一知犯。二知不犯。三知轻。四知重。五诵波罗提木叉利广说。虽复受戒岁多。不知五法。应尽寿依止他住长老优波离问佛。大比丘应从小比丘受依止住不。佛言应受。优波离复问。大比丘应承事供养小比丘不。佛言。除礼足余尽应作

佛在舍卫国。是时舍卫城有一居士。无常对至。财物妻子眷属奴婢一切死尽。唯有父子三人。居士自念。诸道中唯有沙门释子。得供养乐无诸忧苦。是中出家无诸不可。思惟已。将二儿到祇园中求出家。诸比丘不知其意便与出家。经数日。乞食时到着衣持钵将二儿入舍卫城乞食。诣卖食肆饼肆粰[米*留]肆煎饼肆[飢-几+(堶-土)]饼肆欢喜丸肆。是二小儿饥。见诸饼食。从父摩诃卢索言。阿父。与我食与我饼。父语儿言。但索无价。谁当与汝。二儿啼逐父行。诸居士诃骂言。沙门释子不断欲。僧坊内共比丘尼生儿。一人语二人。二人语三人。恶名流布遍舍卫城。有诸比丘。少欲知足行头陀。闻是事心惭愧。以是事具白佛。佛以是因缘集僧。集僧已。佛知故问摩诃卢比丘。汝实尔不。答言。实尔世尊。佛种种因缘呵责。何以名比丘。不满十五岁人作沙弥。佛种种因缘呵竟。语诸比丘。从今不满十五岁人。不应作沙弥。若作得突吉罗罪

佛在迦维罗卫国。是时毗琉璃愚痴人。杀迦维罗卫释子。时长老阿难亲里二小儿走诣阿难。阿难以残食养畜。佛知故问阿难。是谁小儿。答言。是我所亲。佛言。何以不出家。阿难报言。佛结戒。不满十五岁人不应作沙弥。是二小儿不满十五岁。佛问阿难。是二小儿能驱僧食上乌未。答言能。佛言。从今听能驱乌作沙弥。最下七岁

佛在舍卫国。是时跋难陀释子有二沙弥。一名卑陀。二名摩伽。僧坊内共作淫欲。诸居士来见言。沙门释子无清净行。共作淫欲。一人语二人。二人语三人。恶名流布遍舍卫城。诸比丘少欲知足行头陀。闻是事心惭愧。以是事具白佛。佛以是因缘集僧。集僧已。佛知故问跋难陀。汝实尔不。答言。实尔世尊。佛种种因缘诃。何以名比丘。畜两沙弥。佛种种因缘诃竟。语诸比丘。从今不听畜两沙弥。若畜得突吉罗罪。若畜二一沙弥。不久欲受具足。无罪

佛在王舍城。跋难陀释子。奴大家不听与出家。出家不久。乞食时至。着衣持钵入王舍城乞食。本大家见捉。是比丘高声大唤。众人大集问。何以尔。大家言。此是我奴。不放自出家。众人言。何道中出家报言沙门。何等沙门。答言。释子沙门。众人言莫尔。洴沙王有令。若奴大家不放。沙门释子中出家不得遮。何以故。沙门释子难作行苦行。舍世事向涅槃难故。诸居士嗔诃言。沙门释子是无畏处。奴大家不放。释子中出家不得说。一人语二人。二人语三人。恶名流布遍王舍城。有诸比丘。少欲知足行头陀。闻是事心惭愧。以是事具白佛。佛以是因缘集僧。集僧已。佛知而故问跋难陀。汝实尔不。报言。实尔世尊。佛种种因缘呵。何以名比丘。奴大家不放与出家。佛种种因缘呵竟。语诸比丘。从今奴大家不放。不应与出家。若与出家。得突吉罗罪

佛在王舍城。跋难陀释子。人负债。债主不放。与出家。出家数日。乞食时到。着衣持钵入王舍城乞食。是债主见捉之。高声大唤。众人来集问。何以尔。答言。是人负我债。不偿出家。众人言。是何道出家。报言沙门。何等沙门。报言。释子沙门。众人言莫尔。洴沙王有令。债主不放。释子中出家不得遮。何以故。沙门释子难作行梵行。舍世事向涅槃难故。诸居士嗔诃沙门释子是不负债处。负债人债主不放。释子中出家不得说。一人语二人。二人语三人。恶名流布遍王舍城。有诸比丘。少欲知足行头陀。闻是事心惭愧。以是事具白佛。佛以是因缘集僧。集僧已。佛知故问。问跋难陀。汝实尔不。答言。实尔世尊。佛种种因缘诃。何以名比丘。债主不放与出家。佛种种因缘呵竟。语诸比丘。从今负债人债主不放。不应与出家。若与出家。得突吉罗罪

佛在王舍城。有一锻金小儿。来入竹园僧坊。到诸比丘所言。大德。我欲出家。与我出家。诸比丘不思惟与出家。是儿父母宗亲遍觅。次到竹园诣诸比丘所问。大德。有如是如是小儿闻见不。是中有比丘。不见者言不见。不闻者言不闻。是诸亲里久觅不得便舍去。是儿作比丘不久。乞食时到。着衣持钵入王舍城乞食。宗亲见之问。汝出家耶。答言出家。何道出家。答言沙门。何等沙门。答言。释子沙门。问近远。答言。竹园中。宗亲嗔骂。沙门释子故作妄语。见言不见。闻言不闻。一人语二人二人语三人。恶名流布遍王舍城。有诸比丘。少欲知足行头陀。闻是事心惭愧。以是事具白佛。佛以是因缘集僧。集僧已。佛语诸比丘。从今求出家人。两事应白僧。一出家。二剃发。僧若集若不集。两事应白。作是语。大德僧听。是某甲。求出家剃发。以是事白僧。若已剃发来。僧若集若不集。一事应白言。大德僧听。是某甲求出家。僧忆持。若僧不集。应别房行白。应言。长老。是某甲求出家。忆持

佛在王舍城。是时耆婆药师。治二种人。一洴沙王。二佛比丘僧。何以治洴沙王。以衣食故。何以治佛比丘僧。自信自欲自爱自清净故。是时诸居士有恶重病。癞痈疽癫痟病。到耆婆所。与百金钱求治病。不肯。如是乃至五百。不肯。是居士大愁忧念言。耆婆唯治二种人。一治洴沙王。以衣食故。二治佛比丘僧。自信自欲自爱自清净故。今我等与百金钱乃至五百。不肯。是诸沙门释子福德成办人。若是中出家者。耆婆当治。我等是诸病人。至诸比丘所求出家。诸比丘即与出家受具足。诸比丘为诸病人。煮饭作羹作糜煮汤煮肉。煮药汤渍治。出大小便器及唾壶。出入多事多缘。妨废诵经坐禅。但念作事。是病人多。耆婆治不能遍。废洴沙王急事。是病人得差。平复得色力肥悦。舍戒还家。有诸比丘。少欲知足行头陀。诃责诸比丘。何以名比丘。是诸恶重病人。癞痈疽癫痟病人。与出家受具足。为煮饭作羹作粥煮汤煮肉。煮药汤渍治。出大小便器唾壶。出入多事多缘。废诵经坐禅。但念作事。是病人多。耆婆治不能遍。废洴沙王急事。是诸病人得差。色力肥悦平复。舍戒还家。种种呵竟。以是事具白佛佛以是因缘集僧。集僧已。佛知故问问诸比丘。实尔不。答言。实尔世尊。佛种种因缘呵。何以名比丘诸恶病人与出家受具足。为煮饭作羹煮汤煮肉。煮药汤渍治。出大小便器唾壶。出入多事多缘。废诵经坐禅。但念作事。是病人多。耆婆治不能遍。废洴沙王急事。是病人得差。色力肥悦平复。舍戒还家。佛种种因缘诃竟。语诸比丘。从今有如是恶重病。癞痈疽癫痟病人。不应与出家受具足。若与出家受具足。得突吉罗罪

佛在迦毗罗婆城。尔时净饭王诣佛所。头面礼佛足一面坐。合掌白佛。大德。与我愿。佛言。憍昙。佛不与汝过愿。王言。可得愿与我。佛言。可得愿当与。今求何等愿。王言。佛出家时。我心愁忧不忍不喜。难陀罗睺罗后诸子出家时。我心愁忧不忍不喜。今佛与我愿。父母不放不得与出家。何以故。父母恃子为荣。佛言。憍昙。我本心念。亦欲与诸比丘结戒。父母不放不得与出家。尔时佛与净饭王。种种说法示教利喜已默然。王闻法已。从坐起头面礼佛足绕佛而去。王去不久佛以是因缘集僧。集僧竟语诸比丘。从今父母不放不得与出家。若与出家。得突吉罗罪

佛在舍卫国。尔时诸比丘尼。从憍萨罗游行向舍卫国。萨罗林中有贼破法。劫夺比丘尼作毁辱事。诸城国邑恶名流布。若王力若聚落力。围捕尽得诸贼。唯有一贼逃走。至婆岐陀国。到比丘所。语诸比丘言。大德。与我出家。诸比丘不思与出家。诸佛常法。两时大会。春末月夏末月。春末月欲安居时。诸方国比丘来。听佛说法。心念。是法夏安居乐。是初大会。夏末月安居自恣作衣竟。持衣钵来诣佛所。如是思惟。我久不见佛。久不见修伽陀。是第二大会。诸比丘。从婆只国自恣作衣竟。持衣钵欲游行至舍卫国。小比丘言。我欲共行。诸比丘答。随汝意。即便共去。诸比丘中道见萨罗林。忆念言。是萨罗林中本有恶贼破法。劫夺比丘尼作毁辱事。小比丘言。诸长老恶贼。是我同业亲友。我亦作此恶事。诸比丘不知云何。渐渐游行。至舍卫国诣佛所。头面礼佛足却坐一面。诸佛常法。以如是语问讯客比丘忍不足不。安乐住不乞食不乏道路不疲耶。今佛亦如是。语问讯客比丘。言忍不足。不安乐住。不乞食不乏道路不疲耶。诸比丘。言实忍足安乐住乞食不乏道路不疲。诸比丘以是事具白佛。佛以是因缘集僧。集僧已。佛语诸比丘。是萨罗林中恶贼。大作罪事。劫夺比丘尼作不净事。是贼得大罪。何以故。是诸比丘尼多是阿罗汉。是人污比丘尼。不应与出家受具足。若与出家受具足。应灭摈。何以故。污比丘尼人。不生我善法比尼故

佛在舍卫国。是舍卫城中有一居士无常对至。财物家属妻子奴婢一切死尽。是居士作是念言。沙门释子福乐成办人。我当效沙门释子。作僧伽梨郁多罗僧安陀卫钵漉水囊锡杖盛酥革囊革屣针筒。如是何苦便如贼住。即效作僧伽梨郁多罗僧安陀卫钵漉水囊锡杖盛酥革囊革屣针筒。如是作已密入僧中住。诸比丘若集。若不集。徐徐问难。长老。汝几岁。汝有何时节。有闰无闰。此贼不知时节。更软语急问。彼言。我盗作如贼住。有诸比丘。少欲知足行头陀诃责。何以名比丘。得具满和尚具满阿阇梨具满教师。得微妙善法比尼。何以盗作比丘如贼住。诸比丘种种诃责竟。以是事具白佛。佛以是因缘集僧。集僧已。佛知故问。佛言。汝实尔不。答言。实尔世尊。佛种种因缘呵责言。得具满和尚具满阿阇梨具满教师。得微妙善法比尼。何以盗作比丘如贼住。佛种种因缘诃竟。语诸比丘。是名贼住。是人不应与出家受具足。若与出家受具足。便应灭摈。何以故。贼住人。不生我善法比尼故

佛在王舍城。是时跋难陀释子。与不能男出家。是人夜扪摸诸比丘。诸比丘驱出。到比丘尼边式叉摩尼沙弥沙弥尼边。皆扪摸诸比丘尼学戒尼。诸沙弥沙弥尼尽驱出。诸居士入僧坊内宿。亦扪摸诸居士。诸居士言。沙门释子中。有不能男出家与受具足。一人语二人。二人语三人。恶名流布遍王舍城。有诸比丘。少欲知足行头陀。闻是事心惭愧。以是事具白佛。佛以是因缘集僧。集僧已。佛知故问跋难陀。汝实尔不。答言。实尔世尊。佛种种因缘诃跋难陀。何以名比丘。与不能男出家。佛种种因缘诃竟。语诸比丘。从今不能男不应与出家受具足。若与出家受具足。得突吉罗罪。佛言。有五种不能男。何等五。一生不能男。二半月不能男。三妒不能男。四精不能男。五病不能男。何等生不能男。从生不能淫。是生不能男。何等半月不能男。半月能淫半月不能淫。是为半月不能男。何等妒不能男。见他行淫身分用。是妒不能男。何等精不能男。因他人淫身身分用。是精不能男。何等病不能男。若朽烂若堕若虫啖。是病不能男。是为五种不能男。生半月妒精不能男。是四种不能男。不应与出家受具足。若与出家受具足。应灭摈。何以故。不能男。不生我善法比尼故。是病不能男。先出家受具足已。若落若朽烂若虫啖若不动听住。虽不动。若舍戒。还欲出家受具足。不应与出家受具足。若与出家受具足。应灭摈。何以故。病不能男。不生我善法比尼故

佛在王舍城。有比丘与异道出家。有小因缘与师斗诤。不舍戒还本异道。诸比丘以是事具白佛。佛以是因缘集僧。集僧已。佛语诸比丘。譬如狗饥羸与美食。不肯食反食不净。是愚痴人亦如是。弃善法还本异道。佛种种因缘诃竟。语诸比丘。是越济人。不应与出家受具足。若与出家受具足。应灭摈。何以故。是越济人。不生我善法比尼故

佛在舍卫国。有一婆罗门夺母命。便自思惟。我作大罪夺母命。何处能除是恶罪。我闻沙门释子能除。即到诸比丘所言。大德。与我出家。诸比丘言。汝诸婆罗门。不信轻慢。长夜恶邪佛法怨家。何由得信欲出家。婆罗门言。大德。我本夺母命。我自思惟。作极大罪何处能除。我闻沙门释子能除大罪。是故我欲出家。诸比丘不知云何。是事白佛。佛言。是人有杀母罪。不应与出家。若与出家受具足。应灭摈。何以故。有杀母罪。不生我善法比尼故。杀父亦如是

佛在舍卫国。诸比丘从憍萨罗国游行向舍卫国。到萨罗林。林中有贼。破法劫夺断诸比丘命。诸城国邑恶名流布。王力若聚落力围捕。尽得诸贼。唯一贼走到祇洹林。诣诸比丘所言。大德。与我出家。诸比丘不思惟。便与出家。是诸贼。王敕行刑。诸比丘相语共。观世间罪报。小比丘言。我亦欲去。答言随意。即便共去。一面立看。是时诸贼断首流血。是小比丘自思惟。若我不出家亦当如是。即怖倒地。诸比丘以水洒面。稣起平复。问言。汝何所患苦。汝亦不在是中作恶业。亦不思惟是恶业耶。诸比丘软语急问。答言。萨罗林中诸贼。劫比丘杀比丘。是我同业亲友。我亦共作是恶。如是思惟。诸贼斩首流血。我不出家亦当如是。是故我怖倒地。诸比丘不知云何。共到佛所以是事白佛。佛语诸比丘。萨罗林中贼。放逸颠倒夺诸比丘命。多作恶业。彼诸比丘多是阿罗汉。此杀阿罗汉人。不应与出家受具足。若与出家受具足。应灭摈。何以故。杀阿罗汉人不生我善法比丘故

佛在舍卫国。是时有一龙。信心清净。羞厌龙身。从宫中出。变为人身诣诸比丘所言。大德。与我出家。诸比丘不思虑便与出家。是龙与一小比丘。次得一小房共宿。明日行乞食。是龙有福。乞食疾得。时复自归宫食。食讫先还房。掩户而坐。时热。龙法嗜眠。忽然倾卧。有五因缘龙身不变。一生时。二死时。三淫时。四嗔时。五眠时。是时龙眠重身满房中。同房比丘后来见之。心怖失声。龙闻是声。疾疾惊觉。还加趺坐。诸比丘大集问言。何以大唤。答言。此是蛇。诸比丘不知云何。是事白佛。佛言。非蛇是龙。佛言呼来。龙到佛所。头面礼佛足一面坐。佛与说法示教利喜。佛种种因缘说法竟。即遣去。佛语龙言。汝还本宫。是龙闻说法已。啼泣手扪泪从坐起。头面礼佛足右绕而去。龙去之后。佛以是因缘集僧。集僧已语诸比丘。从今龙不应与出家受具足。若与出家受具足。犯突吉罗罪。一切非人亦如是

佛在舍卫国瞻卜园。有一长者子出家长病。是时宗亲遣使呼之。大德。来此间治病。病人即往。是人多诸亲族。亲族各请言。我今日我明日我后日。诸人为病比丘故。大与财物。是病不可治。遂至命终。是病比丘名波罗陀。有一沙弥。于是中间受具足戒。是众中有六群比丘。六群比丘言。新受戒比丘。不应与大比丘分。应与沙弥分。师言何以故。答言。受戒羯磨不满故。师不知云何。以是事白佛。佛言。应问在羯磨中比丘。是羯磨满不满。即问诸比丘。诸比丘言。我虽在羯磨中不忆不知。以是事白佛。佛言。从今诸比丘听羯磨时。当一心听。莫余觉莫余思惟。当专心当勤当敬重。当思惟心心等同忆念。应如是听羯磨。作羯磨者。应分别言。是第一羯磨。第二羯磨。第三羯磨。若不分别说。得突吉罗罪

佛在舍卫国。佛语诸比丘。若有人恶心出佛身血。不应与出家。若与出家受具足。应灭摈。何以故。是恶心出佛身血人。不生我善法比尼故。有人非法非法想。破僧已非法见。此后得罪。非法法想。破僧已非法见。此后得罪。非法非法想。破僧已疑此后得罪。是人不应与出家受具足。若与出家受具足。应灭摈。何以故。破僧人。不生我善法比尼故。有人本出家时犯淫。乃至共畜生。是人不应与出家受具足。若与出家受具足。应灭摈。何以故。本犯戒人。不生我善法比尼故。有人本出家时犯盗。乃至五钱若直五钱物。是人不应与出家受具足。若与出家受具足。应灭摈。何以故。本犯戒人。不生我善法比尼故。有人本出家时。故自手夺人命。更无异想无异方便。是人不应与出家受具足。若与出家受具足。应灭摈。何以故本犯戒人。不生我善法比尼故。有人本出家时。空无过人法。自赞言。我有过人法。是人不应与出家受具足。若与出家受具足。应灭摈何以故。本犯戒人。不生我善法比尼故。有不见摈人。舍戒复欲还出家。到诸比丘所。大德。与我出家。出家竟我当见罪。诸比丘问佛。此人应与出家不。佛言。应与出家。出家已言。我不见是罪。大德。与我受具足。受具足已我当见是罪。应与不。佛言应与。是人受具足。受具足。已复言。不见是罪。更应摈不。佛言。若得一心和合僧。更摈。若僧不得和合。即本摈

佛在王舍城。是时诸斗将妇。婿征行久。与非人通。是诸非人形体不具。象头马头牛头猕猴头鹿头赘头平头。头七分现生子亦如是。诸母爱故。养育长大不能执作。驱弃诸子。诣天祠论议堂出家舍。是诸处觅饮食游行。次到竹园。是中六群比丘喜作罪事。好人不肯住边。若有住者余比丘轻笑。此人如是恶何以近之。是弟子亦眼见师作罪行便舍去。六群比丘见是人等。心自思惟。我若畜好弟子。余比丘轻笑。教舍我去。我等当畜是人。无有教舍我去者。设欲教者。是人丑陋。谁当喜者。如是思惟竟语言。汝何以不出家。答言。我等如是丑陋。谁当度我出家。六群比丘言。汝能代我次第守房。若为我送守房人食。能代我担衣钵。与汝出家。答言。尔时六群比丘即与出家。时有人请佛及僧。六群比丘以二因缘故。先遣弟子担衣钵去。一行迟二羞共行。是时诸居士信佛心清净。诸异道弟子辈轻笑言。此是汝等福田所供养者。前行者先食者来。诸居士闻是事羞愧。以是事具白佛。佛以是因缘集僧。集僧竟。佛知故问。问六群比丘。汝实尔不。答言。实尔世尊。佛种种因缘诃。何以名比丘。象头马头牛头猕猴头鹿头赘头平头。头七分现人与出家。佛种种因缘诃竟语诸比丘。从今象头人乃至平头人。不应与出家。若与出家受具足。犯突吉罗罪

佛语诸比丘。黄发人绿发人赤发白发似赤发猪发马发无发人。一切不应与出家。若与出家受具足。犯突吉罗罪。赤眼深眼凸眼水精眼小眼泡眼一眼无眼人亦如是。不应与出家受具足。若与出家受具足。得突吉罗罪。象耳马耳牛耳羊耳绻耳。一耳无耳。戾鼻鹦鹉嘴鼻牛鼻猕猴鼻长鼻象鼻平鼻无鼻。大唇马唇垂唇无唇。猪须牛须驴须无须。象齿马齿牛齿鱼齿狗齿无齿。长项短项曲项无项。太长人太短人。太黑人太白人。纯青纯黄纯赤纯白纯黑人。戾脚脚指残截阴一丸[病-丙+貴]不能男。截臂截脾截手截脚截指。五指不屈截唇截耳截鼻。癞病粗阴脚跛拘手曳臗。似鬼盲眼瞎瞽鸡皮体挛躄。瘿左手作羊屎短肘短喑哑聋。年太小大老[虺-虫+畏][虺-虫+妥]。不能行不能坐不能卧不能立。如是一切污染僧人。尽不应与出家受具足。若与出家受具足。犯突吉罗罪

佛语诸比丘。受具足法。有三事。现前得受具足。何等三。一有僧。二有人。欲受具足。三有羯磨。是为三。欲受具足人初来。应教次第头面一一执足礼僧。礼已教受衣。应问。此衣是汝有不。答言。是我衣。应教。汝效我语。我某甲。此衣僧伽梨若干条受。若割截若未割截。是衣持。第二我某甲。此衣僧伽梨若干条受。若割截若未割截。是衣持。第三我某甲。此衣僧伽梨若干条受。若割截若未割截。是衣持。次问。此衣是汝有不。答言是。我某甲。此衣忧多罗僧七条受。若割截若未割截。是衣持。第二我某甲。此衣忧多罗僧七条受。若割截若未割截。是衣持。第三我某甲。此衣忧多罗僧七条受。若割截若未割截。是衣持。次问。此衣是汝有不。答言是。我某甲。此衣安陀会五条受。若割截若未割截。是衣持。第二我某甲。此衣安陀会五条受。若割截若未割截。是衣持。第三我某甲。此衣安陀会五条受。若割截若未割截。是衣持。次问。此钵多罗是汝有不。答言是。我某甲。此钵多罗应量受。长用故。第二我某甲。此钵多罗应量受。长用故。第三我某甲。此钵多罗应量受。长用故。受衣钵已。应求和尚。应言。我某甲。求长老为和尚。长老。为我作和尚。依长老和尚故。我某甲得受具足。第二我某甲。求长老为和尚。长老。为我作和尚。依长老和尚故。我某甲得受具足。第三我某甲。求长老为和尚。长老。为我作和尚。依长老和尚故。我某甲得受具足戒。师应问汝。某甲能。为某甲作和尚不。若言能。即时置界场内。舍闻处着见处。戒师应唱。众僧和集。谁能为某甲作教授师。若僧中有比丘言我能。若有五法。不应立作教授师。爱教嗔教怖教愚教教不教不知。五法成就应立作教师。不爱教不嗔教不怖教不愚教教不教知。次应如是唱。大德僧听。是某甲。从和尚某甲求受具足。某甲比丘能作教授师。若僧时到僧忍听。僧某甲当作教授师。为教某甲故。如是白。大德僧听。是某甲。从和尚某甲求受具足。是某甲能教某甲。僧某甲作教授师。教某甲故。谁诸长老忍。某甲作教授师教某甲。是长老默然。谁不忍便说。僧已听某甲作教授师教某甲竟。僧忍默然故。是事如是持。即时教授师往弟子所。教偏袒着衣胡跪合掌。应如是问。汝某甲听。今是至诚时实语时。后僧中亦如是问。汝实便言实。不实便言不实。我今问汝。汝是丈夫不。年满二十不。非奴不。不与人客作不。不买得不。不破得不。非官人不。不犯官事不。不阴谋王家不。不负人债不。丈夫有如是病。若癞痈漏瘭疽痟癫病。如是病比有不。父母在不。父母听不。先作比丘不。若言作。清净持戒不。舍戒时一心如法还戒不。三衣钵具不。汝字何等。和尚字谁。应答。我名某甲。和尚某甲。教授师问竟。应还白僧。问某甲竟。戒师语。若清净将来。将来已教礼僧。礼僧已。从僧乞受具足。我某甲。从和尚某甲受具足。我今僧中乞受具足。某甲是我和尚。僧济度我。僧与我受具足。怜愍故。第二我某甲。从和尚某甲受具足。我今僧中乞受具足。某甲是我和尚。僧济度我。僧与我受具足。怜愍故。第三我某甲。从和尚某甲受具足。我今僧中乞受具足。某甲是我和尚。僧济度我。僧与我受具足。怜愍故。即时戒师。应僧中唱。大德僧听。是某甲。从和尚某甲受具足。是某甲。从僧中乞受具足。和尚某甲。若僧时到僧忍听。我今僧中问某甲遮道法。如是白。汝某甲听。今是至诚时实语时。今僧中问汝。若实当言实。不实言不实。汝丈夫不。年满二十未。非奴不。不与人客作不。不买得不。不破得不。非官人不。不犯官事不。不阴谋王家不。不负人债不。丈夫有如是病。若癞痈漏瘭疽痟癫病。如是病比有不。父母在不。父母听不。先不作比丘不。若言作清净持戒不。舍戒时一心如法还戒不。三衣钵具不。汝字何等。和尚字谁。应言。我名某甲。和尚某甲。白僧颇有未问者不。若未问者当更问。若已问者默然。戒师应唱。大德僧听。是某甲。从和尚某甲受具足。是某甲。从僧中乞受具足。和尚某甲。某甲自说清净无遮道法。三衣钵具。某甲和尚某甲。若僧时到僧忍听。僧当与某甲受具足。和尚某甲。如是白。大德僧听。是某甲。从和尚某甲受具足。是某甲。从僧中乞受具足。和尚某甲。某甲自说清净无遮道法。三衣钵具。某甲和尚某甲。僧今与某甲受具足。和尚某甲。谁诸长老忍。僧与某甲受具足。和尚某甲。是长老默然。若不忍便说。是初羯磨说竟。第二是事更说。大德僧听。是某甲。从和尚某甲受具足。是某甲从僧中乞受具足。和尚某甲。某甲自说清净无遮道法。三衣钵具。某甲和尚某甲。僧今与某甲受具足。和尚某甲。谁诸长老忍。僧与某甲受具足。和尚某甲。是长老默然。若不忍便说。是第二羯磨说竟。第三是事更说。大德僧听。是某甲。从和尚某甲受具足。是某甲。从僧中乞受具足。和尚某甲。某甲自说清净无遮道法。三衣钵具。某甲和尚某甲。僧今与某甲受具足。和尚某甲。谁诸长老忍。僧与某甲受具足和尚某甲是长老默然。若不忍便说。是第三羯磨说竟。僧与某甲受具足竟。某甲和尚某甲。僧忍默然故。是事如是持

若问汝几岁。应言未有岁。何时若冬若春若夏有闰无闰。是时节。汝尽寿应忆念。即时应说四依。汝某甲听。是佛婆伽婆知见释迦牟尼多陀阿伽度阿罗诃三藐三佛陀。为受具足人说四依。依是法比丘出家受具足。成比丘法。何等四依。依粪扫衣。比丘出家受具足成比丘法。若更得白麻衣赤麻衣褐衣憍施耶衣翅夷罗衣钦跋罗衣劫贝衣如是等余清净衣。是一切盈长得。是中依粪扫衣。能尽寿受用不。若能当言能。依乞食。比丘出家受具足。成比丘法。若更得为作食。月生食。月八日二十三日。十四日二十九日。十五日三十日。月一日十六日。众僧食别房食请食。若僧若私。如是等余清净食。是一切盈长得。是中依乞食。能尽寿受用不。若能当言能。依树下止。比丘出家受具足。成比丘法。若更得温室讲堂殿楼一重舍阁屋平覆屋地窟山窟湮头勒迦卧具。漫头勒迦卧具。禅头勒迦卧具。下至草敷叶敷。如是等余清净房舍卧具。是一切盈长得。是中依树下止。能尽寿受用不。若能当言能。依陈弃药。比丘出家受具足。成比丘法若更得四种含消药。酥油蜜石蜜。四种净脂。熊脂驴脂猪脂鳣脂五种根药。舍利姜。赤附子。波提鞞沙。昌蒲根。五种果药。诃梨勒。鞞醯勒。阿摩勒。胡椒。荜茇罗五种盐。黑盐白盐紫盐赤盐卤土盐。五种汤。根汤茎汤叶汤花汤果汤。五种树胶药。兴渠萨阇罗萨谛掖谛掖提谛掖婆那。如是等余清净药。是一切盈长得。是中依陈弃药。能尽寿受用不。若能当言能。汝某甲听。佛婆伽婆知见释迦牟尼多陀阿伽度阿罗诃三藐三佛陀。为受具足比丘说四堕法。若比丘于是四堕法。若作一一法。是非比丘非沙门非释子。失比丘法。如多罗树头断更不生不青不长不广。比丘亦如是。于四堕法若犯一一法。非比丘非沙门非释子。失比丘法。佛种种因缘呵欲。欲想欲欲欲觉欲热。赞叹断欲除欲想灭欲热。若比丘共诸比丘入戒法中。不舍戒戒羸不出。作淫法乃至共畜生。是非比丘非沙门非释子。失比丘法。汝是中尽寿不应作。是事能持不。若能当言能。佛种种因缘诃不与取。赞叹不盗。乃至一线一针一滴油分齐。五钱若五钱直。比丘若不与取。是事故。若王若王等捉若杀若系若驱出。如是语。汝小汝愚汝贼汝偷。如是比丘不与取。非比丘非沙门非释子。失比丘法。汝是中尽寿不应作。是事能持不。若能当言能。佛种种因缘诃夺他命。赞叹不夺命。乃至蚁子。不应故夺命。何况人若比丘自手故夺人命。若遣人持刀杀。若教死若赞死。若作是语。咄丈夫。用恶活为。死胜生。随心随思。种种因缘教死赞死。若坑杀若弶杀。若机拨杀若蹈杀。若比陀罗杀。若半比陀罗杀。若断命杀若堕人胎。若按腹堕胎。若排着火中。若排着水中。若在高上排着下杀。若道路遣使杀。乃至母腹中初得二根。身根命根。初在胎中嗔欲杀。从是因缘死。非比丘非沙门非释子。失比丘法。是中尽寿不应作。是事能持不。若能当言能。佛种种因缘诃妄语。赞叹不妄语。乃至戏笑不应妄语。何况故妄语。若比丘自知空无过人法。自赞我得阿罗汉果证若向阿罗汉。我得阿那含果证若向阿那含我得斯陀含果证若向斯陀含。我得须陀洹果证若向须陀洹。我得第一禅第二第三第四禅。我得慈悲喜舍空处定识处定无所有处定非有想非无想处定灭尽定不净观安那般那念。诸天来至我所。诸龙阅叉浮陀罗鬼比舍阇鬼拘盘茶鬼罗刹鬼。如是鬼辈问我。我亦问彼。彼亦答我。我亦答彼。是事空无妄语。是非比丘非沙门非释子。失比丘法。是中尽寿不应作。是事能持不。若能当言能。汝某甲听。初罪众不可起。第二罪众虽可起。几时覆藏。随时应行波利婆沙。波利婆沙竟。六夜应行摩那埵。二十比丘众中与出罪。是事众中可耻。为人所轻。是中汝不得故出精。是事能不作不。若能当言尔。不得故触女人身。是事能不作不。若能当言尔。不得向女人恶口语。是事能不作不。若能当言尔。不得女人前自叹供养身。是事能不作不。若能当言尔。不得媒嫁女人。是事能不作不。若能当言尔。不得自起房。佛听应作。不听不应作。是事能不作不。若能当言尔。不得起大房。佛听应作。不听不应作。是事能不作不。若能当言尔。无根罪不得谤他人。是事能不作不。若能当言尔。少许罪因缘不得谤言大罪。是事能不作不。若能当言尔。不得勤破僧。是事能不作不。若能当言尔。不得佐破僧人。是事能不作不。若能当言尔。不应毁辱他家。是事能不作不。若能当言尔。不得性戾难教。是事能不作不。若能当言尔。当善谦下心乐顺从教诲。汝受戒竟。得具满和尚具满阿阇梨具满比丘僧好国土好行道处。如转轮王愿。汝今已具满。当加敬三宝佛宝法宝比丘僧宝。当学三学正戒学正心学正慧学。求三脱门空无相无作当勤三业坐禅诵经劝化众事。行如是法开甘露门。得须陀洹果斯陀含果阿那含果阿罗汉果辟支佛佛道。譬如青莲华白莲华红莲华赤莲华在水中日日增长。汝亦如是。比丘法中日日增长。共余戒。和尚阿阇梨广教汝。汝已受具足竟

  释师子法中　　一切妙善集
  深入无崖际　　功德之宝海
  是愿转轮王　　天王善法王
  常求作沙门　　不遂汝已得
  精勤行三业　　佛法无量种
  汝常忆念法　　逮诸无碍智
  如莲华在水　　渐渐日增长
  汝亦如是信　　戒闻定慧增
  余戒佛所制　　和尚师当教
  众中礼绕竟　　喜各从所乐

(七法中受具足戒法第一竟)

十诵律卷第二十一十诵律卷第二十二(第四诵之二)

        后秦北印度三藏弗若多罗译

    七法中布萨法第二

佛在王舍城。是时世尊。未听诸比丘布萨。未听布萨羯磨。未听说波罗提木叉。未听会坐。尔时异道梵志问诸比丘。汝有布萨布萨羯磨说波罗提木叉会坐不。答言。不作。异道梵志嫉妒讥嫌责数言。余沙门婆罗门。尚有布萨布萨羯磨说波罗提木叉会坐。汝诸沙门释子。自称善好有德。而不作布萨布萨羯磨说波罗提木叉会坐。有诸比丘。少欲知足行头陀。闻是事心惭愧。以是事具白佛。佛以是因缘集僧。集僧已。佛语诸比丘。从今听作布萨布萨羯磨说波罗提木叉会坐。如我结戒。半月半月应说波罗提木叉

佛在王舍城。尔时长老大劫宾那。在王舍城阿练若窟中住。十五日布萨时独处坐禅。作是念。我当往布萨不往耶。当往布萨羯磨不往耶。当往说波罗提木叉不往耶。当往会坐不往耶。清净成就第一清净。佛知大劫宾那所念。佛即如其像入三昧。如三昧心忽然不现。于大劫宾那窟前住。从定起。语大劫宾那言。汝作是念。我当往布萨布萨羯磨说波罗提木叉会坐不往耶。清净成就第一清净。汝婆罗门大劫宾那。汝去布萨布萨羯磨说波罗提木叉会坐。何以故。汝是大上座。汝若不恭敬不贵重不供养布萨。谁当恭敬供养尊重布萨者。汝布萨去来。是时佛自捉大劫宾那臂将入布萨众中。佛到僧中在常处坐。佛语诸比丘。从今听二种布萨。一十四日。二十五日。一食前二食后。一昼二夜。若阿练若处若聚落边。从今我听一布萨共住和合结界。如是应作羯磨。随几许和合僧一布萨共住处羯磨结界。若一拘卢舍若二拘卢舍。乃至十拘卢舍。是中应一比丘唱四方界相。若垣若林若树若山若石若道若河若池。是时一比丘。应僧中唱。大德僧听。某甲比丘唱四方界相。是诸相内是界内。若僧时到僧忍听。僧是中一布萨共住作结界。如是白。大德僧听。某甲比丘唱四方界相。是诸相内是界内。是中僧一布萨共住作结界。谁诸长老忍。是中一布萨共住作结界者默然。谁不忍便说。僧是中一布萨共住结界竟。僧忍默然故。是事如是持

佛在王舍城。尔时长老大迦叶。留僧迦梨耆阇崛山中。着上下衣。以少因缘故。来诣竹园。值天大雨。不得还山。与僧伽梨别宿。迦叶语诸比丘言。长老。我留僧伽梨耆阇崛山中着上下衣。以少因缘故来诣竹园。值天大雨不得还山。与僧伽梨别宿。我当云何。诸比丘以是事具白佛。佛以是因缘集僧。集僧已。佛问大迦叶。汝实尔不。答言。实尔世尊。佛种种因缘赞戒赞持戒。赞戒赞持戒已。语诸比丘。从今日听是中一布萨共住结界内作不离衣宿羯磨。应如是作。一心集僧。集僧已僧中一比丘应唱。大德僧听。僧一布萨共住。随共住几许结界内。是中除聚落及聚落界。取空地及住处。若僧时到僧忍听。是中僧一布萨共住结界内。作不离衣宿羯磨。如是白。大德僧听。僧一布萨共住。随几许结界内。是中除聚落及聚落界。取空地及住处。是中僧一布萨共住结界内作不离衣宿羯磨。谁诸长老忍。是中一布萨共住结界内作不离衣宿者默然。谁诸长老不忍便说。僧是中一布萨共住结界内作不离衣宿竟。僧忍默然故。是事如是持

佛在舍卫国。尔时长老舍利弗病。欲一月游行。僧伽梨大重。不能持行。语诸比丘。诸长老。我病。欲一月游行。僧伽梨大重。不能持行。我当云何。诸比丘以是事具白佛。佛以是因缘集僧。集僧已。佛知故问舍利弗。汝实尔不。答言。实尔世尊佛种种因缘赞戒赞持戒。赞戒赞持戒已。语诸比丘从今听老病比丘欲一月游行不离僧伽梨宿羯磨。应如是作。一心集僧。是老病比丘。从坐起偏袒着衣脱革屣入僧中礼僧足胡跪合掌。应如是语。诸长老我某甲。若病若老。欲一月游行。我僧伽梨大重不能持行。我某甲。若病若老。我从僧乞一月不离僧伽梨宿羯磨。僧我某甲。若老若病。当与我一月不离僧伽梨宿羯磨。怜愍故。第二第三亦如是乞。是时僧应隐实可与不可与。是人若言我病。实不病。若言我老。实不老。若言僧伽梨大重。实不重。不应与是人。若言病老僧伽梨大重。实病老僧伽梨大重。应与。是中应一比丘唱。大德僧听。是某甲。若病若老。欲一月游行。是某甲。若病若老。从僧乞一月不离僧伽梨宿羯磨。若僧时到。僧忍听。某甲。若病若老。与一月不离僧伽梨宿羯磨。如是白。白二羯磨。僧与某甲若病若老一月不离僧伽梨宿羯磨竟僧忍默然故。是事如是持。郁多罗僧安陀会亦如是。若一月如是乃至九月亦尔

佛在舍卫国。佛语诸比丘。若僧欲促界广界。先舍本界。后界若大若小。应作如是舍。一心集僧。僧中一比丘唱。大德僧听。此中僧一布萨共住和合结界。若僧时到僧忍听。僧一布萨共住解界舍界。如是白。大德僧听。僧一布萨共住。此中僧结界。今僧一布萨共住处解界舍界。谁诸长老忍。一布萨共住处解界舍界者默然。谁不忍便说。僧一布萨共住处解界舍界竟。僧忍默然故。是事如是持

诸比丘于无僧坊聚落中。初作僧坊未结界。尔时界应几许。佛言。随聚落界是僧坊界。诸比丘无聚落空处。初作僧坊未结界。尔时界应几许。佛言。方一拘卢舍。是中诸比丘不应别作布萨及僧羯磨。若别布萨及僧羯磨。诸比丘犯罪

佛告诸比丘。说波罗提木叉有四种。何等四。一非法别众说波罗提木叉。二非法和合众。三有法别众。四有法和合众说波罗提木叉。非法别众说波罗提木叉不成说。非法和合众说波罗提木叉不成说。有法别众说波罗提木叉不成说。有法和合众说波罗提木叉。成说波罗提木叉。复有五种说波罗提木叉。云何五僧一心布萨说波罗提木叉序。余残僧先闻。已说波罗提木叉。僧和合布萨竟。僧一心布萨说波罗提木叉序说四波罗夷。余残僧先闻。已说波罗提木叉。僧和合布萨竟。僧一心布萨说波罗提木叉序说四波罗夷说十三僧伽婆尸沙。余残僧先闻。已说波罗提木叉。僧和合布萨竟。僧一心布萨说波罗提木叉序说四波罗夷说十三僧伽婆尸沙说二不定三十舍堕。余残僧先闻。已说波罗提木叉。僧和合布萨竟。第五广说

有一住处。布萨时诸比丘。小无所知不善如羺羊。云何小无所知不善如羺羊。是诸比丘。不知布萨。不知布萨羯磨不知说波罗提木叉。不知会坐。是诸比丘。是中住处布萨时。不应住。若诸比丘是住处布萨时住。一切比丘不得布萨得罪

如是小比丘。辞和尚阿阇梨欲游行。和尚阿阇梨应问。汝共谁伴去。何等比丘共游行。是诸比丘说伴字。若是伴比丘。不知布萨。不知布萨羯磨。不知说波罗提木叉。不知会坐。诸和尚阿阇梨应留。若和尚阿阇梨不留。犯突吉罗。若留故去犯突吉罗。若和尚阿阇梨留。是比丘故去。何时得罪。佛言。出界外天明时。犯突吉罗

有诸比丘。一住处安居。先念。某诸比丘诵波罗提木叉。是诸比丘初布萨时。无一比丘能诵波罗提木叉。诸比丘应遣旧比丘近住处受说波罗提木叉。若略若广。受得来者善好。若不得。是诸比丘不应是中夏安居住。若是诸比丘是处夏安居。一切比丘。一一布萨时不得布萨。得罪。是时诸比丘。若闻客比丘来清净共住同见知布萨知布萨羯磨知说波罗提木叉知会坐。旧比丘应迎软语问讯。代担衣钵示房舍卧具。长老。是汝等房舍卧具。细陛绳床粗陛床绳被褥随上座次第安住。是中旧比丘。应为办洗浴具澡豆汤水涂身苏油如供给法。应作明旦与前食后食供给供养好。若不供给供养。旧比丘一切得罪。何以故。无佛时是人补佛处。是客比丘。二部波罗提木叉能广分别。以是故。应供给供养。有一住处四比丘。布萨时是比丘。应一处和合广作布萨说波罗提木叉。有一住处三比丘。布萨时。不应说波罗提木叉。是诸比丘。应一处集三语布萨。应如是作。若上座欲作布萨。从座起偏袒着衣脱革屣胡跪合掌。应如是语。长老忆念。今僧布萨日。若十四日若十五日。长老。知我清净。忆持无遮道法清净。作布萨戒。众满故。第二长老忆念。今僧布萨日。若十四日若十五日。长老知我清净。忆持无遮道法清净。作布萨戒。众满故。第三长老忆念。今僧布萨日。若十四日若十五日。长老。知我清净。忆持无遮道法清净。作布萨戒。众满故。若下座欲作布萨。从座起偏袒着衣脱革屣胡跪。两手捉上座两足。应如是语。长老忆念。今僧布萨日。若十四日若十五日。长老。知我清净。忆持无遮道法清净。作布萨戒。众满故。第二长老忆念。今僧布萨日。若十四日若十五日。长老。知我清净。忆持无遮道法清净。作布萨戒。众满故。第三长老忆念。今僧布萨日若十四日若十五日。长老。知我清净。忆持无遮道法清净。作布萨戒。众满故

有一住处二比丘。布萨时。不应说波罗提木叉。是二比丘。应一处集三语作布萨。与上三比丘同

有一住处一比丘。布萨时是比丘。应扫塔扫布萨处扫地竟次第敷绳床。应办火灯笼灯炷灯。筋办筹。如是思惟。若诸比丘来。未作布萨。是比丘共布萨说波罗提木叉。若不来。是中有高处立望。若见有比丘。唤言疾疾来。诸长老。今日布萨。若不见。应待至暮还坐本处。如是心念口言。今日僧布萨。若十四日若十五日。我亦今日布萨。如是一比丘作布萨竟

佛在舍卫国。佛语诸比丘。是夜多过。应说波罗提木叉。是时一比丘。从坐起偏袒合掌白佛言。有诸病比丘不来。佛言。应取清净来。如是应取。应语比丘与清净来。答言与。是名得清净。若言为我僧中说清净。是名得清净。若身动与。是名得清净。若口言与是名得清净。若身不与口不与。是名不得清净。是时一切比丘。应往就病比丘若将来。莫别彼比丘作布萨说波罗提木叉。若别彼比丘作布萨说波罗提木叉。一切比丘得罪

有一住处二比丘住。布萨时。不应取清净不应与清净。是二比丘应集一处三语布萨。与上三比丘布萨同

有一住处三比丘住。布萨时。不应取清净。不应与清净。是三比丘应一处集三语布萨。与上三比丘布萨同

有一住处四比丘住。布萨时。不应取清净。不应与清净。是诸比丘一处集。广作布萨说波罗提木叉。若过四人。布萨时应和集。是中病比丘随意取清净。应如是取。若一人取一人。是名取清净。若一人取二三四人。是名取清净。随几人但忆名字。是名取清净。若取清净人不欲取。应更与他人清净。若取清净人言。我白衣我沙弥。我非比丘我外道。不见摈不作摈。恶邪不除摈不共住。种种不共住。犯重罪本白衣。不能男污比丘尼越济人。杀父母杀阿罗汉破僧。若言我恶心出佛身血。应更与他清净。若取他清净竟而不去。是名清净不到。若取他清净竟。若言我白衣我沙弥。我非比丘我外道。不见摈不作摈恶邪不除摈不共住。种种不共住。犯重罪本白衣不能男污比丘尼越济人。杀父母杀阿罗汉破僧恶心出佛身血。是名清净不到。若取他清净竟。八难中一一难起不去。是名清净不到。复次取他清净竟故不去。若放逸若懒若睡若入定。是名清净不到。是取清净人。有三因缘得罪。若故不行。若放逸若懒。二因缘无罪。若睡若入定。复次取他清净竟。到僧中不说。是名清净到。若取他清净到僧中。若言。我白衣我沙弥。我非比丘我异道。不见摈不作摈。恶邪不除摈不共住。种种不共住。犯边罪本白衣不能男污比丘尼越济人。杀父母杀阿罗汉破僧。若言我恶心出佛身血。是名清净到。复次取他清净竟到僧中。八难。若一一难起不说。是名清净到复次取他清净竟到僧中若故不说。若放逸若懒若睡若入定。是名清净到。僧中是中受清净人。有三因缘得罪。若故不说若放逸若懒二因缘无罪。若睡若入定

有一住处。布萨时比丘。若王捉若贼若怨怨党若怨党之党捉。僧应遣使诣彼所言。今日僧布萨。汝若当来。若与清净。若出界。我等不应别布萨。是比丘。若得来若与清净若出界。如是好。若都不得。诸比丘不应别布萨。若别布萨。一切比丘得罪

佛语诸比丘。僧莫起有僧事。是时应与长老施越波利婆沙。一比丘从座起偏袒着衣脱革屣合掌白佛言。大德。有诸病比丘不来。与清净竟。佛言。是比丘自身清净故与清净。今是比丘应取欲来。应如是取。语是比丘言。与欲来。若言与欲。是名得欲。若言为我向僧说欲。是名得欲。若身动与。是名得欲。若口言与是名得欲。若身不与口不与。是名不得欲。是一切比丘。应就病比丘边若将来作羯磨。诸比丘不应别作羯磨。若别作一切比丘得罪。若一人取一人欲是名得欲。若一人取二三四人。是名得欲。随几人忆名字。是名得欲。若取欲人不欲取。应更与他人若取欲人若言我白衣我沙弥。我非比丘我异道。不见摈不作摈。恶邪不除摈不共住。种种不共住。犯边罪本白衣不能男。污比丘尼越济人。杀父母杀阿罗汉破僧恶心出佛身血。应更与他欲。若取他欲竟而不去。是名欲不到。取他欲人若言我白衣我沙弥。我非比丘我异道。不见摈不作摈。恶邪不除摈不共住。种种不共住。犯边罪本白衣不能男。污比丘尼越济人。杀父母杀阿罗汉破僧。恶心出佛身血。是名欲不到。若取他欲竟。八难若一一难起故不到。是名欲不到。取他欲竟故不去。若放逸若懒若睡若入定。是名欲不到。取他欲人。有三因缘得罪。若故不去若放逸若懒。二因缘无罪。若睡若入定

复次取他欲竟到僧中不说。是名欲到。取他欲竟到僧中。若言我白衣我沙弥。我非比丘我异道。不见摈不作摈。恶邪不除摈不共住。种种不共住。犯边罪本白衣不能男。污比丘尼越济人。杀父母杀阿罗汉破僧我恶心出佛身血。是名欲到。复次取他欲竟到僧中。八难若一一难起故不说。是名欲到。复次取他欲竟到僧中。若故不说若放逸若懒若睡若入定。是名欲到。是中受欲人。有三因缘得罪。若故不说若放逸若懒。二因缘无罪。若睡若入定

有一住处。僧羯磨时。比丘。若王捉若贼若怨怨党。若怨党之党捉。僧应遣使语彼。今日僧羯磨。汝若得来若与欲若出界。我等不应别羯磨。是比丘若得来若与欲若出界。如是好。若都不得。诸比丘不应别羯磨。若别羯磨。一切比丘得罪

佛在王舍城。尔时长老施越。狂心颠倒。是长老。有时来布萨。有时不来。有时来僧羯磨。有时不来。诸比丘有疑心悔。诸比丘以是事具白佛。佛以是因缘集僧。集僧已。佛知故问施越。汝实尔不。答言。实尔世尊。佛语诸比丘。汝等集与施越作狂羯磨。若更有如是狂比丘。僧亦应与羯磨。如是应作。一心集僧。一比丘唱。大德僧听。是施越狂心颠倒。有时来布萨。有时不来。有时来僧羯磨。有时不来。诸比丘有疑心悔。若僧时到僧忍听。僧与施越狂羯磨。若有施越。若别施越。僧随意作布萨及诸羯磨。如是白。白二羯磨。僧作施越狂羯磨竟。僧忍默然故。是事如是持。若未作狂羯磨。不应别布萨及僧羯磨。若已作狂羯磨。若别若共。僧随意作布萨及僧羯磨

有一住处。布萨时一切比丘有罪。不知除是罪。有一客比丘。清净共住同见。是客比丘。知旧比丘中善好有德者。是客比丘应问。长老。若比丘作如是如是事。当得何等罪。答言。比丘作如是如是事。得如是如是罪。彼言。长老。汝自忆作如是如是事不。答言自忆。非我一人得是罪。一切僧亦得是罪。客比丘言。长老。汝说一切僧。于汝何益。汝何不是罪如法忏悔。若旧比丘受客比丘语。是罪如法忏悔。余诸比丘。见此比丘忏悔。亦应如法忏悔。若如是作好。若不作知有益。举无益莫强举

有一住处。布萨时。比丘忆有罪。是比丘应异比丘边是罪如法忏悔。如是作竟。应布萨说波罗提木叉。不应阂布萨说波罗提木叉

有一住处。布萨时有比丘一罪疑。是比丘应语余比丘。长老我一事疑。后当问是事。如是作竟。应布萨说波罗提木叉。不应破布萨

有一住处。布萨说波罗提木叉时。比丘忆念罪欲出。是比丘应自一心念。我后是罪当如法忏悔。如是作竟。应布萨说波罗提木叉。不应破布萨。若说波罗提木叉时。比丘一罪疑。是比丘应自一心念。后是罪当问。如是作竟。应布萨说波罗提木叉。不应破布萨说波罗提木叉

有一住处布萨时一切比丘僧有罪。知是罪。不能得客比丘清净共住同见是罪如法忏悔。是诸比丘应遣一比丘近住处。疾到彼间是罪如法忏悔竟来还。我等从汝边是罪如法忏悔。是比丘若能办是事好。若不能办。僧应使一比丘唱。大德僧听。我等是住处一切僧得罪知罪。不能得清净客比丘共住同见是罪如法忏悔。亦不能办遣旧比丘近住处。疾到彼间是罪如法忏悔竟来还。诸比丘于是比丘边是罪如法忏悔。若僧时到僧忍听。僧若后是罪如法忏悔。如是白。如是作竟。应布萨说波罗提木叉。不应破布萨说波罗提木叉

有一住处。布萨时一切比丘一事中疑。是中应一比丘如是唱。大德僧听。是中住处一切比丘一事中疑。若僧时到僧忍听。僧后当问是事。如是白。如是作竟。应布萨说波罗提木叉。不应破布萨

有一住处。布萨时。旧比丘若四若过。布萨处集。作布萨说波罗提木叉。有异住处比丘来。清净共住同见多。是诸比丘。应更说波罗提木叉。如是作竟。先比丘无罪。若诸比丘布萨说波罗提木叉竟。一切坐处未起未去。更有异住处诸比丘来。清净共住同见多。是诸比丘应更说。如是作竟。先比丘无罪。若诸比丘作布萨说波罗提木叉竟。有起去有未起去。更有异处住比丘来。清净共住同见多。是诸比丘应更说。如是作竟。先比丘无罪。若是诸比丘布萨说波罗提木叉竟。一切坐处起未去。更有异处住比丘来。清净共住同见多。诸比丘应更说。如是作竟。先比丘无罪等亦如是

有一住处。布萨时。旧比丘若四若过。布萨处集。欲作布萨说波罗提木叉。更有异处比丘来。清净共住同见少。是诸比丘应听次第。若布萨说波罗提木叉竟。一切坐处本起未去。更有异处比丘来。清净共住同见少。是诸比丘旧比丘边。应作三语布萨。若诸比丘作布萨说波罗提木叉竟。有起去有未起去。更有异处比丘来。清净共住同见少。是未起去比丘边。应三语布萨。若诸比丘布萨说波罗提木叉竟。一切起未去。更有异处比丘来。清净共住同见少。是诸比丘若能得同心。应更广布萨说波罗提木叉好。若不得同心。应出界三语作布萨。若旧比丘布萨说波罗提木叉时。更有旧比丘来。若多若等若少。若多若等。应更说。若少应听次第

若旧比丘说波罗提木叉时。客比丘来。若多若等若少。若多应更说。若等少应听次第。若旧比丘布萨说波罗提木叉时。更有旧比丘客比丘共来。若多若等若少若多等应更说。少应听次第

若客比丘布萨说波罗提木叉时。更有客比丘来。若多若等若少。若多应更说。等少应听次第

若客比丘布萨说波罗提木叉时。旧比丘来。若多若等若少。若多等应更说。少应听次第。若客比丘布萨说波罗提木叉时。旧比丘客比丘共来。若多若等若少。若多等应更说。少应听次第

若旧比丘客比丘共布萨说波罗提木叉时。旧比丘客比丘共来。若多若等若少。若多等应更说。少应听次第。若旧比丘客比丘共布萨说波罗提木叉时。旧比丘来。若多若等若少。若多等应更说。少应听次第。若旧比丘客比丘共布萨说波罗提木叉时。客比丘来。若多若等若少。若多应更说。等少应听次第。有一住处。布萨时。旧比丘若四若过。布萨处集。欲布萨说波罗提木叉。更有异处比丘来。清净共住同见多。彼如是念。是中旧比丘若四若过。布萨处集。欲布萨说波罗提木叉。我等应作布萨说波罗提木叉。净想比尼想别同别想。作布萨说波罗提木叉。更有异处比丘来。清净共住同见多。彼应更说。先比丘得罪。彼比丘净想比尼想别同别想。作布萨说波罗提木叉竟。若一切坐处未起未去。若有起去有未起去。若一切起未去。更有异处比丘来。清净共住同见多。彼比丘应更说。先比丘得罪

有一住处。布萨时。旧比丘若四若过。布萨处集。欲布萨说波罗提木叉。更有异处比丘来。清净共住同见多。彼作是念旧比丘若四若过。布萨处集。欲布萨说波罗提木叉。我等不应是中布萨说波罗提木叉。是诸比丘心悔别同别想。是中布萨说波罗提木叉。更有异处比丘来。清净共住同见多。彼诸比丘应更说。先比丘得罪。诸比丘心悔别同别想布萨说波罗提木叉竟。一切坐处未起未去。有起去有未起去。若一切起未去。更有异处比丘来。清净共住同见多。彼诸比丘应更说。先比丘得罪

有一住处。布萨时。诸旧比丘若四若过。布萨处集。欲布萨说波罗提木叉。更有异处比丘来。清净共住同见多。是诸比丘作是念。我等若应若不应。是中作布萨说波罗提木叉。疑净不净别同别想。作布萨说波罗提木叉。更有异处比丘来。清净共住同见多。彼诸比丘应更说。先比丘得罪。诸比丘疑净不净别同别想。作布萨说波罗提木叉竟。一切坐处未起未去。有起去有未起去。有一切起未去。更有异处比丘来。清净共住同见多。是诸比丘应更说。先比丘得罪

有一住处。布萨时。诸旧比丘若四若过。布萨处集。欲布萨说波罗提木叉。更有异处比丘来。清净共住同见多。先住比丘闻。更有异处比丘来。清净共住同见多。闻已如是念。更有异处比丘来。清净共住同见多。是灭坏除舍别异。我不须是诸比丘。为欲喜破僧。有别同别想。布萨说波罗提木叉。更有异处比丘来。清净共住同见多。是诸比丘应更说。先比丘得偷兰遮罪。近破僧故。是诸比丘欲喜破僧别同别想。作布萨说波罗提木叉竟。若一切坐处未起未去。有起去有未起去。有一切起未去。更有异处比丘来。清净共住同见多。是诸比丘应更说。先比丘得偷兰遮罪。近破僧故。若旧比丘说波罗提木叉时。旧比丘来。若多若等若少。若多等应更说。若旧比丘说波罗提木叉时客比丘来。若多若等若少。若多等应更说。若旧比丘说波罗提木叉时。旧比丘客比丘共来。若多若等若少。若多等应更说。若客比丘说波罗提木叉时客比丘来。若多若等若少。若多等应更说

客比丘说波罗提木叉时旧比丘来。若多若等若少。若多等应更说。客比丘说波罗提木叉时。旧比丘客比丘共来。若多若等若少。若多等应更说。若旧比丘客比丘共说波罗提木叉时。旧比丘客比丘共来。若多若等若少。若多等应更说

旧比丘客比丘共说波罗提木叉时旧比丘来。若多若等若少。若多等应更说

旧比丘客比丘共说波罗提木叉时客比丘来。若多若等若少。若多等应更说

旧诸比丘十四日布萨多。客比丘十五日布萨少。客比丘应随旧比丘。是日应布萨。旧比丘十四日少。客比丘十五日多。旧比丘应随客比丘。是日不应布萨。旧比丘十五日多。客比丘初日少。客比丘应随旧比丘是日更布萨。旧比丘十五日少。客比丘初日多。旧比丘应随客比丘出界作布萨。客比丘十四日多。旧比丘十五日少。旧比丘应随客比丘是日布萨。客比丘十四日少。旧比丘十五日多。客比丘应随旧比丘是日不应布萨。客比丘十五日多。旧比丘初日少。旧比丘应随客比丘是日更作布萨。客比丘十五日少。旧比丘初日多。客比丘应随旧比丘出界作布萨

有一住处。布萨时。诸旧比丘。闻客比丘相客比丘因缘。若脚声若杖声若革屣声若异人声。是诸比丘不求不觅。便布萨说波罗提木叉。旧比丘得罪。若求得不唤。布萨说波罗提木叉。旧比丘得罪。若求不能得。疑布萨说波罗提木叉。旧比丘得罪。若求不能得。无所疑。布萨说波罗提木叉。如是旧比丘无罪。若求得客比丘。一心欢喜。应布萨说波罗提木叉。如是旧比丘无罪

有一住处。布萨时。诸客比丘。闻旧比丘相旧比丘因缘。若户钥声若釿声若斧声诵经声。是诸客比丘不求不觅。便布萨说波罗提木叉。客比丘得罪。若求得不唤。布萨说波罗提木叉。客比丘得罪。若求不能得疑。布萨说波罗提木叉。客比丘得罪。若求不能得。无疑。布萨说波罗提木叉。客比丘无罪。若求觅得旧比丘。一心欢喜。应布萨说波罗提木叉。客比丘无罪

有一住处。布萨时旧比丘。见客比丘相客比丘因缘。若不识衣钵若不识杖。若盛油革囊革屣针筒。是诸比丘不求。布萨说波罗提木叉。旧比丘得罪。若求得不唤。布萨说波罗提木叉。旧比丘得罪。若求不能得疑。布萨说波罗提木叉。旧比丘得罪。若求不能得。无所疑。布萨说波罗提木叉。如是旧比丘无罪。若求得一心欢喜。应布萨说波罗提木叉。如是旧比丘无罪

有一住处。布萨时诸客比丘。见旧比丘相旧比丘因缘。若新扫洒地次第敷床。是诸客比丘不求不觅。布萨说波罗提木叉。客比丘得罪。若觅得不唤。布萨说波罗提木叉。客比丘得罪。若觅不能得。疑布萨说波罗提木叉。客比丘得罪若觅不能得。无所疑。布萨说波罗提木叉。客比丘无罪。若觅得一心欢喜。作布萨说波罗提木叉。客比丘无罪

布萨时不应往。此有比丘有住处。彼有比丘有住处。彼比丘无住处。彼比丘有住处无住处。彼间比丘不共住。布萨时不应往此有比丘有住处。彼非比丘有住处。彼非比丘无住处。彼非比丘有住处无住处。彼间比丘不共住

布萨时不应往。此有比丘无住处。彼比丘无住处。彼比丘有住处无住处。彼非比丘有住处。彼非比丘无住处。彼非比丘有住处无住处。彼比丘有住处。彼间比丘不共住

布萨时不应往。此有比丘有住处无住处。彼有比丘有住处无住处。彼非比丘有住处。彼非比丘无住处。彼非比丘有住处无住处。彼比丘有住处。彼比丘无住处。彼间比丘不共住

布萨时不应往。此有比丘非比丘有住处。彼非比丘有住处。彼非比丘无住处。彼非比丘有住处无住处。彼比丘有住处。彼比丘无住处。彼比丘有住处无住处。彼间比丘不共住

布萨时不应往。此有比丘非比丘无住处。彼非比丘无住处。彼非比丘有住处无住处。彼比丘有住处。彼比丘无住处。彼比丘有住处无住处。彼非比丘有住处。彼间比丘不共住

布萨时不应往。此有比丘非比丘有住处无住处。彼非比丘有住处无住处。彼比丘有住处。彼比丘无住处。彼比丘有住处无住处。彼非比丘有住处。彼非比丘无住处。彼间比丘不共住

布萨时不应往。此有比丘有住处。彼比丘有住处。彼比丘无住处。彼比丘有住处无住处。彼非比丘有住处。彼非比丘无住处。彼非比丘有住处无住处。彼间比丘不共住。除僧事急事。布萨时不应往。此有比丘无住处。彼比丘无住处。有比丘有住处无住处。彼非比丘有住处。彼非比丘无住处。彼非比丘有住处无住处。彼比丘有住处。彼间比丘不共住。除僧事急事。布萨时不应往。此有比丘有住处无住处。彼比丘有住处无住处。彼非比丘有住处。彼非比丘无住处。彼非比丘有住处无住处。彼比丘有住处。彼比丘无住处。彼间比丘不共住。除僧事急事

布萨时不应往。此有比丘非比丘有住处。彼非比丘有住处。彼非比丘无住处。彼非比丘有住处无住处。彼比丘有住处。彼比丘无住处。彼比丘有住处无住处。彼间比丘不共住。除僧事急事

布萨时不应往。此有比丘非比丘无住处。彼非比丘无住处。彼非比丘有住处无住处。彼比丘有住处。彼比丘无住处。彼比丘有住处无住处。彼非比丘有住处。彼间比丘不共住。除僧事急事

布萨时不应往。此有比丘非比丘有住处无住处。彼非比丘有住处无住处。彼比丘有住处。彼比丘无住处。彼比丘有住处无住处。彼非比丘有住处。彼非比丘无住处。彼间比丘不共住。除僧事急事

布萨时应往。此有比丘有住处。彼有比丘有住处。彼比丘无住处。彼比丘有住处无住处。彼比丘清净共住

布萨时应往。此有比丘有住处。彼非比丘有住处。彼非比丘无住处。彼非比丘有住处无住处。彼比丘清净共住

布萨时应往。此有比丘无住处。彼比丘无住处。彼比丘有住处无住处。彼非比丘有住处。彼非比丘无住处。彼非比丘有住处无住处。彼比丘有住处。彼比丘清净共住

布萨时应往。此有比丘有住处无住处。彼比丘有住处无住处。彼非比丘有住处。彼非比丘无住处。彼非比丘有住处无住处。彼比丘有住处。彼比丘无住处。彼比丘清净共住

布萨时应往。此有比丘非比丘有住处。彼非比丘有住处。彼非比丘无住处。彼非比丘有住处无住处。彼比丘有住处。彼比丘无住处。彼比丘有住处无住处。彼比丘清净共住

布萨时应往。此有比丘非比丘无住处。彼非比丘无住处。彼非比丘有住处无住处。彼比丘有住处。彼比丘无住处。彼比丘有住处无住处。彼非比丘有住处。彼比丘清净共住

布萨时应往。此有比丘非比丘有住处无住处。彼非比丘有住处无住处。彼比丘有住处。彼比丘无住处。彼比丘有住处无住处。彼非比丘有住处。彼非比丘无住处。彼比丘清净共住精舍法竟

佛言。不应白衣前布萨说波罗提木叉。不应沙弥前。非比丘异道。不见摈不作摈。恶邪不除摈不共住。种种不共住。犯边罪本白衣不能男。污比丘尼越济人。杀父母杀阿罗汉破僧恶心出佛身血。如是一切不应在前布萨说波罗提木叉。一切先事作已。僧应布萨说波罗提木叉。若应与现前比尼与竟。应与忆念比尼与竟。若应与不痴比尼与竟。若应与自言比尼与竟。若应与觅罪相比尼与竟。若应与多觅比尼与竟。若应与苦切羯磨与竟。若应与依止羯磨与竟。若应与驱出羯磨与竟。若应与下意羯磨与竟。若应与不见摈羯磨与竟。不作摈恶邪不除摈羯磨与竟。若应与别住羯磨与竟。若应与摩那埵本日治出罪羯磨与竟。僧应布萨说波罗提木叉。若比丘宿受清净。不应共布萨说波罗提木叉。若众僧未起如是得。布萨日未到。不应布萨说波罗提木叉。除斗僧还和合一心听布萨说波罗提木叉(七法中布萨法竟)

十诵律卷第二十二十诵律卷第二十三(第四诵之三)

        后秦北印度三藏弗若多罗译

    七法中自恣法第三

佛在舍卫国。诸比丘夏安居时。先作如是制限。长老。我等不共语言不相问讯。是诸比丘作是制已。一处夏安居。先作如是法。若有初乞食还敷独坐床。安洗足水洗足机拭足巾。净水瓶常用水瓶。若有长食。盛净器中盖着一处。食不足者食此长食。若复有乞食后来。不足者取而食之。若复有残着无草地。若无虫水中。是诸长老。盛食器净洗摩拭着一处。独坐床。洗足机拭足巾净水瓶常用水瓶着屏处。扫洒食堂。扫除竟入室坐禅。是诸长老。晡时从禅先起。见净水瓶常用水瓶洗足盆。若空无水。持至水处。若独能持来着一面。若不能持来。手招余比丘共举。持来还着本处不共语言不相问讯。诸佛常法两时大会。春末月夏末月。春末月欲安居时。诸方国比丘来听佛说法。心念。是法夏安居乐。是初大会。夏末月安居讫。自恣作衣竟。持衣钵来诣佛所。如是思惟。我久不见佛。久不见修伽陀。是第二大会。是诸比丘是中住处。夏安居自恣作衣竟。持衣钵往到佛所。头面礼毕一面坐。诸佛常法。如是语问讯客比丘。夏安居忍不足不。安乐住不。乞食不难。道路不疲耶。今佛亦如是问讯诸比丘。夏安居忍不足不。安乐住不。乞食不难。道路不疲耶。诸比丘言。忍足安乐住乞食不难道路不疲。诸比丘以是事具白佛。佛以是因缘集僧。集僧已。佛种种因缘呵诸比丘。汝愚痴人。如怨家共住。云何自言安乐住。何以名比丘。我众以法相教。而受哑法。佛种种因缘呵已语诸比丘。从今不应受哑法。若受得偷兰遮。何以故。不共语是外道法故。从今听夏安居竟诸比丘一处集。应三事求他说自恣。何等三。若见若闻若疑罪。如是应自恣一心集僧。集僧已。应差能作自恣人。应如是唱。谁能为僧作自恣人。是中若有言我能。佛言。若比丘五恶法成就。不应作自恣人。何等五。一爱自恣。二嗔自恣。三怖自恣。四愚自恣。五自恣不自恣不知。比丘成就五善法。应作自恣人。何等五。不爱自恣不嗔自恣不怖自恣不愚自恣自恣不自恣知。尔时一比丘应僧中唱言。大德僧听。是某甲某甲比丘。能为僧作自恣人。若僧时到僧忍听。僧某甲某甲比丘。当作僧自恣人。如是白。大德僧听。是某甲某甲比丘。能为僧作自恣人。僧某甲某甲比丘。为僧作自恣人。谁诸长老忍。某甲某甲比丘为僧作自恣人者。是长老默然。谁不忍便说。某甲某甲比丘。为僧作自恣人竟。僧忍默然故。是事如是持应如是作自恣羯磨。大德僧听。今日僧自恣。若僧时到僧忍听。僧一心受自恣。如是白。是时诸比丘。一切从坐起[跳-兆+互]跪地。若作自恣人是上座。应从坐起偏袒着衣曲身。应语第二上座。长老。今日自恣来。是时第二上座。从坐起偏袒着衣[跳-兆+互]跪两手捉上座足。应如是语。长老忆念。今僧自恣日。我某甲比丘长老僧自恣语。若见闻疑罪语我。怜愍故。我若见罪。当如法除。第二长老忆念。今僧自恣日。我某甲比丘长老僧自恣语。若见闻疑罪语我。怜愍故。我若见罪当如法除。第三长老忆念。今僧自恣日。我某甲比丘长老僧自恣语。若见闻疑罪语我。怜愍故。我若见罪当如法除。若下座作自恣人。应从坐起偏袒着衣[跳-兆+互]跪合掌。应如是语上座。今日自恣来。上座亦应从坐起偏袒着衣[跳-兆+互]跪合掌。应如是言。长老忆念。今僧自恣日。我某甲比丘长老僧自恣语。若见闻疑罪语我。怜愍故。我若见罪当如法除。第二长老忆念。今僧自恣日。我某甲比丘长老僧自恣语。若见闻疑罪语我。怜愍故。我若见罪当如法除。第三长老忆念。今僧自恣日。我某甲比丘长老僧自恣语。若见闻疑罪语我。怜愍故。我若见罪当如法除。如是次第一切僧自恣。若一切僧自恣竟。为僧作自恣人共作自恣。自恣竟。应至上座前唱言。僧一心自恣竟。佛语诸比丘。自恣有四种。何等四。一非法别自恣。二非法和合自恣三有法别自恣。四有法和合自恣。是中非法别自恣。佛不听。非法和合自恣。佛不听。有法别自恣。佛不听。是中有法和合自恣如是佛听。有一住处。自恣时五比丘住。是诸比丘应一处集。差为僧作自恣人。广说自恣。有一住处。自恣时四比丘住。是诸比丘。不应差为僧作自恣人。是诸比丘应一处集三语自恣。应如是自恣。上座应从坐起偏袒着衣[跳-兆+互]跪合掌如是语。长老忆念。今僧自恣日。我某甲比丘长老自恣语。若见闻疑罪语我。怜愍故。我若见罪当如法除。第二长老忆念。今僧自恣日。我某甲比丘长老自恣语。若见闻疑罪语我。怜愍故。我若见罪当如法除第三长老忆念。今僧自恣日。我某甲比丘长老自恣语。若见闻疑罪语我怜愍故。我若见罪当如法除。若下座应从坐起偏袒着衣[跳-兆+互]跪两手捉上座两足应如是语。长老忆念。今僧自恣日。我某甲比丘长老自恣语。若见闻疑罪语我。怜愍故。我若见罪当如法除。第二长老忆念。今僧自恣日。我某甲比丘长老自恣语。若见闻疑罪语我。怜愍故。我若见罪当如法除。第三长老忆念。今僧自恣日。我某甲比丘长老自恣语。若见闻疑罪语我。怜愍故。我若见罪当如法除。如是诸比丘得自恣。三比丘二比丘亦如是。有一住处一比丘。自恣时应扫塔处及自恣处。次第布床办火灯灯笼灯炷灯[木*著]办筹。如是思惟。诸比丘来未作自恣者。是比丘应共自恣。若不见来。是中有高处立望。若见有比丘。唤言。疾疾来长老。今日僧自恣。若不见。应待至暮。还坐本处。如是心念口言。今日僧自恣。我亦今日自恣。如是一比丘得自恣

佛在舍卫国。是中佛语诸比丘。是夜多过自恣时到。一比丘从坐起偏袒着衣长跪合掌白佛言。世尊。诸比丘病不来。佛言。应取自恣。如是应取。应语病比丘。与自恣。答言与。是名得自恣。若言为我僧中说自恣。是名得自恣。若身动与。是名得自恣。若口言与。是名得自恣。若身不与口不与。不得自恣。是时一切僧。应就病比丘边作自恣。若将来僧中作自恣。诸比丘不应别作自恣。若诸比丘别作自恣。一切比丘得罪。有一住处二比丘。作自恣时。是二比丘不应取自恣。是二比丘共一处三语自恣。三比丘四比丘亦如是。有一住处五比丘。自恣时。是诸比丘不应取自恣。不应与自恣。是诸比丘。应一处集差为僧自恣人。应广自恣。若过五比丘。自恣时集一处。老病比丘随意取自恣与自恣。若一人取一人。是名得自恣。若一人取二人三人四人。是名得自恣。随几许人能忆识名字。是名得自恣。若取自恣人不欲取。应更与他自恣。取自恣人若言。我白衣我沙弥我非比丘我异道。不见摈不作摈。恶邪不除摈不共住。种种不共住。犯边罪本白衣不能男。污比丘尼越济人。杀父母杀阿罗汉破僧。恶心出佛身血。应更与他自恣。若取他自恣竟不去。是名自恣不到若言。我白衣我沙弥我非比丘我异道。不见摈不作摈。恶邪不除摈不共住。种种不共住犯边罪。本白衣不能男污比丘尼越济人。杀父母杀阿罗汉破僧。恶心出佛身血。是名自恣不到。若取他自恣竟。八难中一一难起故不去。是名自恣不到。复次取他自恣竟故不去。若放逸若懒若睡若入定。是名自恣不到。是取自恣人。有三因缘得罪。若故不去若懒若放逸。二因缘无罪。若睡若入定。复次取他自恣竟。到僧中不说自恣。是名自恣到。若取他自恣竟。到僧中若言。我白衣我沙弥我非比丘我异道。不见摈不作摈。恶邪不除摈不共住。种种不共住。犯边罪本白衣不能男。污比丘尼越济人。杀父母杀阿罗汉破僧。恶心出佛身血。是名自恣到。复次取他自恣竟到僧中。八难一一难起故不说。是名自恣到。复次取他自恣竟。到僧中故不说。若放逸若懒若睡若入定。是名自恣到。是中取他自恣人。有三因缘得罪。若故不说若放逸若懒。二因缘无罪。若睡若入定。有一住处。自恣时比丘。若王捉若贼若怨家若怨党若怨党之党捉。僧中应遣使语彼言。今日僧自恣若是比丘得来。若与自恣来。若出界。我曹不应别作自恣。是比丘若得来若与自恣若出界。如是好若不得。诸比丘不应别自恣。若别自恣。一切比丘得罪

有一住处。自恣时一切比丘僧有罪。不知是罪除。有一客比丘。清净共住同见。是客比丘。知旧比丘中善好有德。是客比丘应问。长老。若比丘作如是如是事。当得何等罪。答言。若比丘作如是如是事。当得如是如是罪。彼言长老。汝自忆作如是事不。答言自忆。不独我一人得是罪。一切僧亦得是罪。客比丘言。长老。汝说一切僧。于汝何益。汝何以不如法忏悔是罪。旧比丘受客比丘语。是罪如法忏悔。余诸比丘见此比丘忏悔。亦应如法忏悔。如是作者善。若不如是作。知有益举。无益莫强举。有一住处自恣时。比丘忆罪欲出。是比丘应异比丘边是罪如法忏悔。如是作竟应作自恣。不应与自恣作碍。有一住处自恣时。比丘一罪疑。是比丘应语他比丘。长老。我一罪疑。后是事当问。如是作竟应自恣。不应与自恣作碍

有一住处自恣时。忆念罪欲出。是比丘应疾一心念。我后是罪当如法忏悔。如是作竟应自恣。不应与自恣作碍。若自恣时。比丘一罪疑。是比丘应疾一心念。后是罪当问。如是作竟应自恣。不应与自恣作碍。有一住处自恣时。一切比丘僧有罪觉。是罪不能得客比丘清净共住同见是罪如法忏悔。是诸比丘应遣一旧比丘近住处疾到彼。是罪如法忏悔竟来还。我曹从汝边是罪如法忏悔。是诸比丘若得办是事。如是好。若不能办。是僧中一比丘应唱。大德僧听。我等是住处一切僧得罪觉。是罪不能得清净。客比丘共住同见是罪如法忏悔。亦不能得办遣一旧比丘近住处疾到彼是罪如法忏悔竟来还。我等是边是罪如法忏悔。若僧时到僧忍听。僧若后是罪如法忏悔。如是白。如是作竟应作自恣。不应与自恣作碍

有一住处自恣时。一切僧一罪中疑。是中应一比丘僧中如是唱。大德僧听。是中住处一切僧一罪中疑。若僧时到僧忍听。僧后是事当问。如是白如是作竟应作自恣。不应与自恣作碍

有一住处自恣时。旧比丘若五若过。自恣处集作自恣。异住处诸比丘来。清净共住同见多。是诸比丘应更作自恣。如是作竟先比丘无罪。若诸比丘自恣竟。一切坐处未起未去。更有异住处比丘来。清净共住同见多。是诸比丘应更作自恣。如是作竟先比丘无罪。若诸比丘自恣竟。有起去有未起去。更有异住处比丘来。清净共住同见多。是诸比丘应更作自恣。如是作竟先比丘无罪。若是诸比丘自恣竟。一切坐处起未去。更有异住处比丘来。清净共住同见多。是诸比丘应更作自恣。如是作竟先比丘无罪。等亦如是。有一住处自恣时。旧比丘若五若过。自恣处集作自恣。有异住处比丘来。清净共住同见少。是诸比丘应次第自恣。若诸比丘自恣竟。一切坐处未起未去。有异住处比丘来。清净共住同见少。是诸比丘边应作三语自恣。若诸比丘自恣竟。有起去有未起去。有异住处比丘来。清净共住同见少。是未起去。诸比丘边。应三语自恣。若是诸比丘自恣竟。一切起未去。更有异住处比丘来。清净共住同见少。是诸比丘若能得和同。应广作自恣。若不得和同。应出界作三语自恣。若旧比丘自恣时。更有旧比丘来。若多若等若少。若多等应更作自恣。若少应次第作自恣。若旧比丘自恣时客比丘来。若多若等若少。若多应更作自恣。若等少应次第作自恣。若旧比丘自恣时。更有旧比丘客比丘共来。若多若等若少。若多等应更作自恣。若少应次第作自恣。若客比丘自恣时。更有客比丘来。若多若等若少。若多应更作自恣。若等少应次第作自恣。若客比丘自恣时旧比丘来。若多若等若少。若多等应更作自恣。若少应次第作自恣。若客比丘自恣时。旧比丘客比丘共来。若多若等若少。若多等应更作自恣。若少应次第作自恣。若旧比丘客比丘共自恣时。更有旧比丘来。若多若等若少。若多等应更作自恣。若少应次第作自恣。若旧比丘客比丘共自恣时。更有客比丘来。若多若等若少。若多应更作自恣。若等少应次第作自恣。若旧比丘客比丘共自恣时。更有旧比丘客比丘来。若多若等若少。若多等应更作自恣。若少应次第作自恣

有一住处自恣时。旧比丘若五若过。自恣处集欲自恣。更有异住处比丘来。清净共住同见多。彼作是念。是中旧比丘若五若过。自恣处集欲作自恣。我等应作自恣。净想比尼想别众同众想作自恣。更有异住处比丘来。清净共住同见多。彼应更作自恣。先比丘得罪。彼比丘净想比尼想别众同众想作自恣竟。若一切坐处未起未去。若有起去有未起去。若一切起未去。更有异住处比丘来。清净共住同见多。彼比丘应更作自恣。先比丘得罪。有一住处自恣时。旧比丘若五若过。自恣处集欲作自恣。更有异住处比丘来。清净共住同见多。彼作是念。旧比丘若五若过。自恣处集欲作自恣。我等不应是中作自恣。彼比丘言我作自恣。不净心悔别众同众想。是中作自恣。更有异住处比丘来。清净共住同见多。彼诸比丘应更作自恣。先比丘得罪。彼诸比丘不净心悔别众同。众想作自恣竟。一切坐处未起未去。有起去有未起去。有一切起未去。更有异住处比丘来。清净共住同见多彼。诸比丘应更作自恣。先比丘得罪

有一住处自恣时。旧比丘若五若过。自恣处集欲作自恣。更有异住处比丘来。清净共住同见多。彼诸比丘作是念。我等若应若不应。是中作自恣。疑净不净别众同众想。更有异住处比丘来。清净共住同见多。彼诸比丘应更作自恣。先比丘得罪。若疑净不净别众同众想作自恣竟。一切坐处未起未去。有起去有未起去。有一切起未去。更有异住处比丘来。清净共住同见多是诸比丘应更作自恣。先比丘得罪

有一住处自恣时诸旧比丘若五若过。自恣处集欲作自恣。更有异住处比丘来。清净共住同见多。闻已作是念。更有异住处比丘来。清净共住同见多。是灭坏除舍别异。我不须是诸比丘。为欲破僧别众同众想作自恣。更有异住处比丘来。清净共住同见多。彼诸比丘应更作自恣。先比丘得偷兰遮。近破僧故。若是诸比丘。为欲勤破僧别众同众想作自恣竟。若一切坐处未起未去。有起去有未起去。有一切起未去。更有异住处比丘来。清净共住同见多。是诸比丘应更作自恣。先比丘得偷兰遮。近破僧故。若旧比丘自恣时。更有旧比丘来。若多等应更作自恣。若旧比丘自恣时客比丘来。若多等应更作自恣。若旧比丘自恣时。旧比丘客比丘共来。若多等应更作自恣。若客比丘自恣时客比丘来。若多等应更作自恣。客比丘自恣时旧比丘来。若多等应更作自恣。客比丘自恣时。旧比丘客比丘共来。若多等应更作自恣。旧比丘客比丘共自恣时。旧比丘来。若多等应更作自恣。旧比丘客比丘共自恣时。客比丘来。若多等应更作自恣。旧比丘客比丘共自恣时。旧比丘客比丘共来。若多等应更作自恣。旧比丘十四日多。客比丘十五日少。客比丘应随旧比丘。是日应自恣。旧比丘十四日少。客比丘十五日多。旧比丘应随客比丘。是日不应自恣。旧比丘十五日多。客比丘初日少。客比丘应随旧比丘。是日更自恣。旧比丘十五日少。客比丘初日多。旧比丘应随客比丘出界作自恣。若客比丘十四日多。旧比丘十五日少。旧比丘应随客比丘。是日应自恣。客比丘十四日少。旧比丘十五日多。客比丘应随旧比丘。是日不应自恣。客比丘十五日多。旧比丘初日少。旧比丘应随客比丘。是日更自恣。客比丘十五日少。旧比丘初日多。客比丘应随旧比丘出界作自恣。有一住处自恣时。诸旧比丘闻客比丘声客比丘因缘。若脚声若杖声若革屣声若异人声。是诸旧比丘不求不觅作自恣。旧比丘得罪。若求得不唤自恣。旧比丘得罪。若求不能得疑自恣。旧比丘得罪。若求不能得无所疑自恣。如是旧比丘无罪。若求得是诸客比丘。一心欢喜应作自恣。如是旧比丘无罪。有一住处自恣时。诸客比丘。闻旧比丘声旧比丘因缘。若户钥声釿声若斧声读经声。是诸客比丘不求不觅自恣。客比丘得罪。若求得不唤自恣。客比丘得罪。若求不能得疑自恣。客比丘得罪。若求不能得无所疑自恣。客比丘无罪。若求得是诸旧比丘。一心欢喜应作自恣。如是客比丘无罪。有一住处自恣时。旧比丘见客比丘相。客比丘来因缘。若不识衣钵若不识杖。若盛油革囊革屣针筒。是诸比丘不求不觅自恣。是诸旧比丘得罪。若求得不唤自恣。旧比丘得罪。若求不能得疑自恣。旧比丘得罪。若求不能得无所疑自恣。如是旧比丘无罪。若求得是诸客比丘。一心欢喜应作自恣如是旧比丘无罪

有一住处自恣时。诸客比丘。见旧比丘相旧比丘来因缘。若新扫洒地次第敷床座。是诸客比丘不求不觅作自恣。客比丘得罪。若求得不唤作自恣。客比丘得罪。若求不得疑作自恣。客比丘得罪。若求不能得无所疑作自恣。客比丘无罪。若求得是诸旧比丘。共一心欢喜应作自恣。如是客比丘无罪

有一住处自恣时。比丘若他人举若不举。若令忆念若不令忆念。自言我有僧伽婆尸沙罪。是比丘应与别住不成与。是中应一比丘僧中唱。大德僧听。是中住处有比丘。若他人举若不举。若令忆念若不令忆念。自言有僧伽婆尸沙罪。是比丘应与别住不成与。若僧时到僧忍听僧是比丘后当与别住。如是白。如是作竟应自恣。不应与自恣作碍

有一住处自恣时。比丘若他人举若不举。若令忆念。若不令忆念自言有僧伽婆尸沙罪。是比丘若应与摩那埵。若应与本日治。若应与出罪。不成与。是中应一比丘僧中唱。大德僧听。是中住处有比丘。若他人举若不举。若令忆念若不令忆念。自言有僧伽婆尸沙罪。是比丘应与摩那埵本日治出罪。不成与。若僧时到僧忍听。僧是比丘后当与摩那埵。当与本日治当与出罪。如是白。如是作竟应自恣。不应与自恣作碍

有一住处自恣时。比丘若他人举若不举。若令忆念若不令忆念。自言有提舍迦罗尼罪。是事共诤。有比丘言。是中应出悔。有比丘言。是事应心生悔。是中一比丘应僧中唱。大德僧听。是中住处有比丘。若他人举若不举。若令忆念若不令忆念。自言有提舍迦罗尼罪。是事共诤。有比丘言。是事应出悔。有比丘言。是事应心生悔。若僧时到僧忍听。是比丘若得异比丘清净共住同见。是比丘边是罪如法忏悔。如是白。如是作竟应自恣。不应与自恣作碍

有一住处自恣时。比丘若他人举若不举。若令忆念若不令忆念。自言有提舍迦罗尼罪。是事共诤。有比丘言。是波逸提罪。有比丘言。是罪波罗提提舍尼。是中应一比丘僧中唱。大德僧听。是中住处有比丘。若他人举若不举。若令忆念若不令忆念。自言有提舍迦罗尼罪。是事共诤。有比丘言。是波逸提罪。有比丘言。是罪波罗提提舍尼若僧时到僧忍听。僧是比丘。若得异比丘清净共住同见。是比丘边是罪如法忏悔。如是白。如是作竟应自恣。不应与自恣作碍

有一住处自恣时。比丘若他人举若不举。若令忆念若不令忆念。自言有提舍迦罗尼罪。是事共诤。有比丘言。是罪残可治。有比丘言。无残不可治。是中言有残可治。是应共自恣。是中言无残不可治。是不应共自恣。彼应置自恣而去。不应斗诤相言

有一住处自恣时。有比丘说他比丘罪若见若闻若疑。诸比丘知是说他罪。人身业不净。能淫能偷。能夺人命。能自称过人法。能出精。能身身相触。能杀生草。能非时食能饮酒。不应信是比丘语治他罪。僧应语。汝长老。莫嗔莫斗莫诤莫相言。如是无羞人。僧莫数僧应自恣。不应与自恣作碍

有一住处自恣时。比丘向余比丘说他罪。若见若闻若疑。诸比丘知是长老说他罪。人口业不净。是能妄语。不知言知。知言不知。不见言见。见言不见。不疑言疑。疑言不疑。如是比丘语。不应信治他人罪。僧应语是比丘。长老。汝莫嗔莫斗莫诤莫相言。如是无羞人。僧莫数。僧应自恣。不应与自恣作碍

有一住处自恣时。一比丘向余比丘说他罪。若见若闻若疑。诸比丘知是长老说他罪。人身业不净口业不净。是能淫能偷能夺人命能自称过人法。能故出精能故触女人身。能杀生草。能非时食能饮酒。是亦能妄语不知言知。知言不知。不见言见。见言不见。不疑言疑。疑言不疑。如是比丘语。不应信治他人罪。僧应语是比丘。长老。汝莫嗔莫斗莫诤莫相言。如是无羞人。僧莫数。僧应自恣。不应与自恣作碍

有一住处自恣时。一比丘向余比丘说他罪。若见若闻若疑。诸比丘知是长老说他罪。人身业净。是长老能不淫不偷不夺人命不自称过人法。不故出精不故触女身不杀生草。不非时食不饮酒。是长老少智不决定不善知。是人亦能非法言法法言非法非善言善善言不善。如是比丘语。不应信治他人罪。僧应语是比丘。长老。汝莫嗔莫斗莫诤莫相言。如是少智人。僧莫数。僧应自恣。不应与自恣作碍

有一住处自恣时。一比丘向余比丘说他罪。若见若闻若疑。诸比丘知是长老口业净。是长老不能不知言知知言不知不见言见见言不见不疑言疑疑言不疑。是长老少智不决定不善知。是人亦能非法言法法言非法善言非善非善言善。如是比丘语。不应信治他人罪。僧应语是比丘。长老。汝莫嗔莫斗莫诤莫相言如是少智人。僧莫数。僧应自恣。不应与自恣作碍

有一住处自恣时。一比丘向余比丘说他罪。若见若闻若疑。诸比丘知是长老说他罪。人身业净口业净。是长老能不淫不偷。不故夺人命不自称过人法。不故出精不故触女身。不杀生草不非时食不饮酒。不能不知言知知言不知不见言见见言不见不疑言疑疑言不疑是长老少智不决定不善知。是人亦能非法言法法言非法善言非善非善言善。如是比丘语。不应信治他人罪。僧应语是比丘。长老。汝莫嗔莫斗莫诤莫相言。如是少智人。僧莫数。僧应作自恣。不应与自恣作碍

有一住处自恣时。一比丘向余比丘说他罪。若见若闻若疑。诸比丘知是长老说他罪。人身业净口业净。是长老能不淫不偷不故夺人命不自称过人法不故出精不故触女身不杀生草不非时食不饮酒。不能不知言知知言不知不见言见见言不见不疑言疑疑言不疑。是长老说他罪人有智人决定人善知人。是人亦不法言非法非法言法善言非善非善言善。是长老。尔时应安详窃问窃教。汝长老说他罪。为眼见耳闻心疑耶。是长老若言眼见。诸比丘应问。若眼见不应说耳闻心疑。见何等何处见。云何见见作何事。何因缘到彼。是人若言耳闻。不应说眼见心疑。闻何等何处闻。云何闻闻作何事。男边闻女边闻。不能男边闻二根人边闻。若言心疑。不应说眼见耳闻。疑何等何处疑。云何疑疑何事。若身罪中疑。口罪中疑。残罪不残罪。残不残罪中疑耶。聚落处空处何处疑。如是安详窃问窃教。是长老得实者。诸比丘应一心治是罪比丘。若罪比丘言。我是白衣。僧应语。汝出去。僧应作自恣。不应与自恣作碍

若言我沙弥非比丘异道。不见摈不作摈恶邪。不除摈不共住种种不共住。犯边罪本白衣不能男。污比丘尼越济人。杀父母杀阿罗汉破僧。恶心出佛身血人。僧应语。汝出去。诸比丘应自恣。不应与自恣作碍。一切事先作竟。僧应自恣。若应与现前毗尼。与竟应作忆念毗尼。与竟应与不痴毗尼。与竟应与自言毗尼。与竟应与实觅毗尼。与竟应与多觅毗尼。与竟是比丘若应与苦切羯磨。与竟若应与依止羯磨。与竟若应与驱出羯磨。与竟若应与下意羯磨。与竟若应与不见摈羯磨。与竟若与别住羯磨。与竟若应与摩那埵羯磨。与竟若应与本日治羯磨。与竟若应与出罪羯磨。与竟僧应自恣。

若安居比丘。闻彼住处有比丘嗔斗诤相言来。欲遮此间比丘自恣。诸比丘应二三四促作布萨。差为僧作自恣人。应广自恣。是诸比丘成办促二三四作布萨。差为僧作自恣人广自恣。如是好。若不成。诸比丘若闻彼比丘嗔斗诤相言。从彼发来为遮自恣故。是时应疾疾集。差自恣人广自恣。诸比丘若成疾疾集。差自恣人广自恣。如是好。若不成。诸比丘若闻彼比丘嗔斗诤相言。从彼来入界内。是时旧比丘。应一心软语迎问讯欢喜。为持衣钵开房舍示卧具。长老。是汝曹床坐。粗脾绳床细脾绳床被褥。汝随上座次第安住是中。应为办洗浴具。薪火澡豆汤水涂身苏油。客比丘入浴室竟。旧比丘应出界。差为僧作自恣人。广自恣。若旧比丘成办是事好。若不成旧比丘应语客比丘。长老。我等是布萨不自恣。后布萨时我等当自恣。客比丘语旧比丘言。长老。后布萨时不应自恣。若有说事今日说。为何事故。我等佛听自恣。是事不得。旧比丘应语客比丘。汝等置旧比丘。自知自恣时。若客比丘是时余处去好。若不去旧比丘应语客比丘。我等不后布萨时自恣。我等八月四月自恣。我夏末月自恣多得布施。若客比丘语旧比丘言。长老。不听汝八月四月自恣。若有说事今日说。为何事故。我等佛听自恣。是事不得。旧比丘应语客比丘。汝等置旧比丘。自知自恣时。若客比丘是时余处去好。若不去是中应不自恣而去。我等不应嗔斗诤相言故

若有病比丘。遮不病比丘自恣。僧应语是病比丘。汝长老病。莫遮不病比丘自恣。何以故。病人少安隐故。有不病比丘。遮病比丘自恣。僧应语是不病比丘。长老。汝莫遮病比丘自恣。何以故。病人少安隐故。有病比丘。遣使遮不病比丘自恣。僧应语是使。长老。莫受病人语遮不病比丘自恣。何以故。病人少安隐故。是使到病人边语。长老。僧约敕汝。病莫遮不病比丘自恣。何以故。病人少安隐故。病人言为遮。是病比丘得突吉罗罪。是使受病人语。遮不病比丘自恣。是使得突吉罗罪。不病比丘遣使。遮病比丘自恣亦如是。四种非法遮自恣。四种有法遮自恣。何等四非法遮自恣。一无根破戒遮自恣。二无根破正见。三无根破正命。四无根破威仪遮自恣。是为四非法遮自恣。何等四有法遮自恣。一有根破戒遮自恣。二有根破正见。三有根破正命。四有根破威仪遮自恣。是为四有法遮自恣

佛在舍卫国。佛语诸比丘。从今听一说自恣二说自恣。我前已听三说自恣。若一说自恣时。初说未竟若遮。是非法遮自恣。若一说竟遮是有法遮自恣。若二说自恣时。初说未竟若遮。是非法遮自恣。初说竟若遮。是非法遮自恣。二说未竟若遮。是非法遮自恣。二说竟遮。是有法遮自恣。若三说自恣时。初说未竟若遮。是非法遮自恣。初说竟若遮。是非法遮自恣。二说未竟若遮。是非法遮自恣。二说竟若遮。是非法遮自恣。三说未竟若遮。是非法遮自恣。若三说竟遮。是有法遮自恣。何处佛听应一说自恣。如一住处自恣时大会。僧中诸比丘如是思惟。是住处僧大会。若我等三说自恣。夜多过不得自恣。若僧时到僧忍听。僧当一说自恣。如是白。如是作竟应自恣。不应与自恣作碍。如是住处应一说自恣。如一住处。自恣时。王若王等。诸比丘边坐欲听法。是中诸比丘说法夜多过。诸比丘思惟。是住处王若王等。诸比丘边坐欲听法。是中诸比丘说法夜多过。若我等三说自恣。夜多过不得自恣。若僧时到僧忍听。僧当一说自恣。如是白。如是作竟应自恣。不应与自恣作碍。如是住处应一说自恣。如一住处。自恣时大得布施。是中诸比丘作分段夜多过。诸比丘思惟。是住处僧大得布施。诸比丘作分段夜多过。若我等三说自恣。夜多过不得自恣。若僧时到僧忍听。僧当一说自恣。如是白。如是作竟应自恣。不应与自恣作碍。如是住处应一说自恣。如一住处。自恣时。二法师义辩名辩辞辩应辩。是二比丘说法时夜多过。诸比丘思惟。是住处二法师义辩名辩辞辩应辩。是诸比丘说法夜多过。若我等是中三说自恣。夜多过不得自恣。若僧时到僧忍听。僧当一说自恣。如是白。如是作竟应自恣。不应与自恣作碍。如是住处应一说自恣。如一住处。自恣时。诸比丘四事。若一一事起。以是故夜多过。诸比丘思惟。是住处诸比丘四事。若一一事起。以是故夜多过。若我等是中三说自恣。是夜多过不得自恣。若僧时到僧忍听。僧当一说自恣。如是白。如是作竟应自恣。不应与自恣作碍。如是住处应一说自恣。如一住处。自恣时。多比丘病。是中诸比丘如是念。是住处诸比丘病。若我等三说自恣。有病比丘不堪[跳-兆+互]跪。若僧时到僧忍听。僧当一说自恣。如是白。如是作竟应自恣。不应与自恣作碍。如是住处应一说自恣。如一住处。自恣时。天雨覆屋薄。是中诸比丘如是念。是住处天雨覆屋薄。若我等三说自恣。屋漏污僧卧具。湿诸比丘衣。若僧时到僧忍听。僧当一说自恣。如是白。如是作竟应自恣。不应与自恣作碍。如是住处应一说自恣。如一住处自恣时。八难若一一难起。若王难若贼难若火难水难。恶兽难腹行虫难人难非人难。云何王难。若王嗔约敕。捕诸沙门释子。打杀系缚驱出。夺袈裟与白衣着。令作象兵马兵车兵步兵射兵。捉象钩捉革鞙。举舆出入军阵。若一一官杂役。是中诸比丘思惟。是住处王嗔约敕。捕诸沙门释子。杀系驱出夺袈裟与白衣着。令作象兵马兵车兵步兵射兵。捉象钩捉革鞙。举舆入出军阵。一一官杂役。若三说自恣。或夺命或破戒。若僧时到僧忍听。僧当一说自恣。如是白。如是作竟应自恣。不应与自恣作碍。如是住处应一说自恣。云何贼难。若诸贼嗔约敕。捕诸沙门释子。杀系驱出。取头血涂户耳窗向。作帜作字。门关户橝牛头象牙杙。梁栋栿衣架僧房别房。墙壁食处门间禅窟。大小便处重阁经行道头树下。皆持血作字作帜。诸比丘如是思惟。是住处贼嗔约敕。捕诸沙门释子杀系驱出。取头血涂户耳窗向。作字作帜。门关户橝牛头象牙杙梁椽栿衣架。僧房别房墙壁食处门间禅窟。大小便处重阁经行道头树下。皆持血作字作帜。若我等三说自恣。或夺命或破戒。若僧时到僧忍听。僧当一说自恣。如是白。如是作竟应自恣不应与自恣作碍。如是住处应一说自恣。云何火难。诸比丘树林中作僧坊。是中天火大火来。是火烧诸树林经行道头重阁僧坊别房垣墙食处门间大小便处居士牛羊驴马骆驼谷场使人皆烧。诸比丘思惟。是树林中作精舍。天火大火来烧树林。经行道头乃至烧居士甘蔗田稻田麦田胡麻田葡萄田牛羊驴马骆驼谷场使人皆烧。我等三说自恣。或夺命或破戒。若僧时到僧忍听。僧当一说自恣。如是白。如是作竟应自恣。莫与自恣作碍。如是住处应一说自恣。云何水难若诸比丘河曲中作僧坊。是中诸龙依止雪山住。身增长得力。入大河归大海。令河水大涨。漂诸树林经行道里重阁僧坊别房食处门间大小便处。亦复漂诸居士甘蔗田稻田乃至漂诸谷场人民。是中诸比丘思惟。是河曲僧坊。诸龙大龙依止雪山住。乃至漂人民我等三说自恣。或夺命或破戒。若僧时到僧忍听。僧当一说自恣。如是白。如是作竟应自恣。不应与自恣作碍。如是住处应一说自恣。云何恶兽难。若诸比丘恶兽处作僧坊。是中诸小比丘不知宜法。非处大小便。浣弊衣晒之。诸恶兽嗔恚。恶兽者。谓师子[坐-工+兀]虎豹豺狼熊罴。是恶兽至僧坊别房中垣墙食处禅窟门间大小便处浴室重阁经行道头树下。诸比丘思惟。是恶兽处作僧坊。是中诸小比丘不知宜法。非处大小便。浣弊衣及晒。诸恶兽嗔。来入僧坊乃至经行道头树下。我等三说自恣。或夺命或破戒。若僧时到僧忍听僧当一说自恣。如是白。如是作竟应自恣。不应与自恣作碍。如是住处应一说自恣。云何腹行虫难若诸比丘在龙处作僧坊。是中诸小比丘不知宜法。非处大小便。浣弊衣晒之。是中诸龙嗔放毒蛇蜈蚣。入诸比丘床下床上榻下榻上独坐床下户耳窗向门间户橝牛头象牙杙梁椽衣架僧房别房垣墙食处门间禅窟浴室重阁大小便处经行道头树下。是中诸比丘思惟。是龙处作僧坊。诸小比丘不知宜法。乃至树下。我等三说自恣。或夺命或破戒。若僧时到僧忍听。僧当一说自恣。如是白。如是作竟应自恣。不应与自恣作碍。如是住处应一说自恣。云何人难。若诸比丘或依城聚落住。诸比丘不知宜法。贵人妇女。若软语若骂詈。欲令伏从。是中诸人嗔约敕。捕诸沙门释子。杀系驱出。不听入城邑聚落街陌行。不听入舍。莫使坐。莫使乞食。莫与供养。是中诸比丘思惟。是诸比丘不知宜法。贵人妇女。若软语若骂詈。欲令伏从。是中诸人嗔约敕。捕杀乃至莫供养。我等三说自恣。或夺命或破戒。若僧时到僧忍听。僧当一说自恣。如是白。如是作竟应自恣。不应与自恣作碍。如是住处应一说自恣。云何非人难。有诸比丘非人住处作僧坊。是诸比丘不知宜法。非处大小便。浣弊衣晒。是中非人复嗔。恐怖诸比丘。持比丘着床上床下独坐床上独坐床下户耳窗向门间户橝牛头象牙杙梁椽衣架僧房别房垣墙食处门间禅窟浴室重阁大小便处经行道头树下。或捉比丘倒悬。是中诸比丘思惟。是诸比丘不知宜法。乃至捉比丘倒悬。我等三说自恣。或夺命或破戒。若僧时到僧忍听。僧当一说自恣。如是白。如是作竟应自恣。不应与自恣作碍。如是住处应一说自恣

有一住处自恣时。有比丘言。置罪事共人自恣。僧应语是比丘。长老。不得置罪事共人自恣。若有说事今说。为何事故。我等佛听自恣。是事不得。有比丘言。置人置罪。余人共自恣。僧应语是比丘。长老。不得置人置罪余人共自恣。若有说事今说。为何事故。我等佛听自恣。是事不得。有比丘言。置罪置人置伴党。余残人共自恣。僧应语是比丘。长老。不得置罪置人置伴党余残人共自恣。若有说事今说。为何事故。我等佛听自恣。是事不得。有一住处自恣时。识罪不识人。僧应过自恣时求说。不应自恣时求说。若自恣时求说。僧得罪。有一住处自恣时。识人不识罪。僧应过自恣求说。不应自恣时求说。若自恣时求说。僧得罪。有一住处自恣时。识罪识人。僧应自恣时求说。不应过自恣求说。若过自恣求说。僧得罪。有一住处自恣时。不识罪不识人。僧应过自恣求说。不应自恣时求说。若自恣时求说。僧得罪。有一住处自恣时诸比丘作如是制限。诸长老。我等非三月自恣。八月中四月自恣。若我等夏末月多得布施。用是自恣。摄布施故。是时有一比丘。本不要若父母遣使。若兄弟若姊妹若儿女若本第二。是中不获己强去。是比丘语诸比丘。诸长老。我本不要父母遣使。若兄弟若姊妹若儿女若本第二遣使。是中不获己强去。汝等集。我今欲自恣。欲遮自恣。欲遮一比丘自恣。僧应语是比丘。长老。不得今日自恣。亦不得遮他比丘自恣。若有说事今说。自身清净故。佛听自恣。是比丘言。汝诸长老集。今日我自恣。后来已当遮是一比丘自恣。僧应语。长老。不得今日自恣后来已遮一比丘自恣。若有说事今说。自身清净故。佛听自恣。是比丘若言。汝诸长老集。今日自恣。后来已不复遮他比丘自恣。佛言僧应和合与是比丘自恣。何以故。入自恣制限故。自恣时不应往。此有比丘有住处。彼有比丘有住处。彼有比丘无住处。彼有比丘有住处无住处。彼间比丘不共住

自恣时不应往。此有比丘有住处。彼有非比丘有住处非比丘无住处。彼有非比丘有住处无住处。彼间比丘不共住。余如布萨中广说

佛语诸比丘。不应白衣前自恣。不应沙弥前。非比丘异道。不见摈不作摈。恶邪不除摈。不共住种种不共住。犯边罪本白衣不能男。污比丘尼越济人。杀父母杀阿罗汉。破僧恶心出佛身血人。如是一切不应在前自恣。一切先事作竟。僧应自恣。若应与现前比尼与竟。应与忆念比尼与竟。应与不痴比尼与竟。应与自言比尼与竟。应与实觅比尼与竟。应与多觅比尼与竟。是比丘若应与苦切羯磨与竟。若应与依止羯磨与竟。若应与驱出羯磨与竟。若应与下意羯磨与竟。若应与不见摈羯磨与竟。若应与不作摈羯磨与竟。若应与恶邪不除摈羯磨与竟。若应与别住羯磨与竟。若应与摩那埵羯磨与竟。若应与本日治羯磨与竟。若应与出罪羯磨与竟。僧应自恣。宿受自恣。若比丘。僧不应共自恣。若僧未起如是得。自恣时未至不应自恣。除斗僧还和合一心听自恣(七法中自恣法第三竟)

十诵律卷第二十三十诵律卷第二十四(第四诵之四)

        后秦北印度三藏弗若多罗译

    七法中安居法第四

佛在王舍城。诸比丘夏中游行诸国土。践蹋生草夺诸虫命。尔时诸异道出家讥嫌责数言。诸异道沙门婆罗门。夏安居时潜处隐静。譬如鸟日中热时避暑巢窟。诸异道沙门婆罗门。夏安居时潜处隐静。沙门释子常作此心。自称有德。而夏中游行。践蹋生草残害物命。有诸比丘。少欲知足行头陀。闻是事心惭愧。以是事具白佛。佛以是事集僧。集僧已佛知故问。问诸比丘。汝实作是事不。答言。实作世尊。佛种种因缘诃诸比丘。云何名比丘。夏中游行践蹋生草夺诸虫命。佛种种因缘诃已。语诸比丘。从今应夏安居。长老优波离问佛。谁应安居。佛言。五众应安居。何等五。一者比丘。二者比丘尼。三者式叉摩尼。四者沙弥。五者沙弥尼。云何应受安居。佛言。若上座欲安居。应从坐起偏袒着衣[跳-兆+互]跪合掌。应如是语。长老忆念。我某甲比丘是住处夏安居。前三月依止某甲可行处聚落。某甲僧坊孔破治故。第二长老忆念。我某甲比丘是住处夏安居。前三月依止某甲可行处聚落。某甲僧坊孔破治故。第三长老忆念我某甲比丘是住处夏安居。前三月依止某甲可行处聚落。某甲僧坊孔破治故。下座答言莫放逸。上座言受持。若下座从上座受安居。应从坐起偏袒着衣[跳-兆+互]跪两手捉上座两足。应如是语。长老忆念。我某甲比丘是住处夏安居。前三月依止某甲可行处聚落。某甲僧坊孔破治故。第二长老忆念。我某甲比丘是住处夏安居。前三月依止某甲可行处聚落。某甲僧坊孔破治故。第三长老忆念。我某甲比丘是住处夏安居。前三月依止某甲可行处聚落。某甲僧坊孔破治故。上座言莫放逸。下座言受持。后三月亦如是。若不安居。得突吉罗罪

佛在舍卫国。尔时迦夷国土有聚落。名象力。是中有居士。字忧田。大富田业殷实宝物丰足。归依佛归依法归依僧。见谛得道果。为僧兴立僧坊。遣使言。是中多有好饮食及诸衣施。长老来受我饮食供养。僧坊卧具施四方僧。时诸比丘发遣使还报居士言。佛为比丘结戒。夏中不应游行诸国。汝莫愁恼以为忧苦。居士自念。愿不从心忧苦愁恼。我为僧故作此僧坊。僧不肯来当可如何。为当近处少多请诸常住比丘来集饮食。僧坊卧具施四方僧。诸佛常法岁两时大会。春末月夏末月。春末月。诸方国土处处比丘。往诣佛所听佛说法。夏安居乐。是初大会诸比丘往诣佛所。夏末月。比丘安居竟过三月作衣毕。与衣钵俱渐渐游行往诣佛所。久不见婆伽婆。久不见修伽陀。是第二大会诸比丘往诣佛所。有余比丘。王舍城安居竟。过三月作衣毕。与衣钵俱渐渐游行。来到佛所头面礼足一面坐。诸佛常法。有客比丘来。如是语问讯。忍不足不。安乐住不。乞食不乏。道路不疲耶。今佛亦如是语。问客比丘。忍不足不。安乐住不。乞食不乏。道路不疲耶。诸比丘言。忍足安乐住乞食不乏道路不疲。以是事向佛广说。佛以是事集僧。集僧已。种种因缘赞戒赞持戒。赞戒赞持戒已。语诸比丘。从今有事听受七夜法

长老优波离问佛。有事七夜听去。为谁故应去。佛言。为七众故应去。何等七。一比丘。二比丘尼。三式叉摩尼。四沙弥。五沙弥尼。六优婆塞。七优婆夷。云何为优婆夷故应去。如优婆夷作房舍。遣使诣比丘所白言。我作房舍。大德来。作入舍供养。有如是事听去七夜。如优婆夷作象厩马厩门屋食堂。遣使诣比丘所白言。大德。我作象厩马厩门屋食堂。大德来。作入舍供养。有如是事听去七夜。如优婆夷为僧故作房舍。若温堂凉堂合霤堂重阁一重舍平覆舍。遣使诣比丘所白言。大德。我为僧故作房舍温堂凉堂合霤堂重阁一重舍平覆舍。大德来。作入舍供养。有如是事听去七夜。如优婆夷为多比丘二一。为多比丘尼二一。为多式叉摩尼二一。为多沙弥二一。为多沙弥尼二一。为多出家二一。为多出家尼二一。若为一出家尼故。作房舍温堂凉堂合霤堂重阁一重舍平覆舍。遣使诣比丘所白言。大德来。我为一出家尼故。作房舍温堂凉堂合霤堂重阁一重舍平覆舍。大德来。作入舍供养。有如是事听去七夜。如一优婆夷王捉若贼若怨若怨党若怨党之党捉。遣使诣比丘所白言。大德。我若王若贼若怨若怨党若怨党之党捉。大德来。欲见比丘。有如是事听去七夜。为欲听法听去七夜。为欲布施听去七夜。为欲见比丘听法。欲见比丘布施欲听法布施。欲见比丘听法布施。有如是事听去七夜。如优婆夷病苦极。遣使诣比丘所白言。我病苦极。大德来。欲见比丘。有如是事听去七夜。为欲听法听去七夜。为欲布施听去七夜。欲见比丘听法。欲见比丘布施。欲听法布施。欲见比丘听法布施。有如是事听去七夜。如优婆夷病苦极。遣使诣比丘所白言。大德。我病苦极。大德来。教我随病食。有如是事听去七夜。教我随病药听去七夜。教我食具满看病人。听去七夜。为随病食随病药。为随病食具满看病人。随病药具满看病人。为随病食随病药具满看病人。有如是事听去七夜。如优婆夷为是多识多知。诸大经有波罗纱提伽(晋言清净经)波罗纱大尼(晋言一净经)般阇提利剑(晋言三昧经)摩那阇蓝(晋言化经)波罗小阇蓝(晋言梵经)阿吒那剑(晋言鬼神成经)摩诃纱摩耆剑(晋言大会经)阿罗伽度波摩(晋言蛇譬经)室唳咆那都叉耶时月提(晋言索灭解脱经)释伽罗波罗念奈(晋言释问经也)摩呵尼陀那波梨耶夜(晋言大因缘经)频波纱罗波罗时伽摩南(晋言洴沙迎经)般阇优波陀那肝提伽(晋言五受阴却经)沙陀耶多尼(晋言六情部经)尼陀那散犹乞多(晋言同界部经)波罗延(晋言过道经)阿陀波耆耶修妒路(晋言众德经)萨耆陀舍修妒路(晋言谛见经也)若未学欲学。若先学忘欲诵。遣使诣比丘所白言。大德。是多识多知诸大经。波罗纱乃至萨耆陀舍修妒路。若未学欲学。若先学忘欲诵。大德来教我受学读诵问义。有如是事听去七夜。如为优婆夷应去。优婆塞亦如是

云何为沙弥尼故应去。如沙弥尼为僧故。作房舍若温堂凉堂合霤堂重阁一重舍平覆舍遣使诣比丘所白言。我为僧故。作房舍温堂凉堂合霤堂重阁一重舍平覆舍。大德来。作入舍供养。有如是事听去七夜。若为多比丘二一。多比丘尼二一。多式叉摩尼二一。多沙弥二一。多沙弥尼二一。多出家二一。多出家尼二一。若为一出家尼故。作房舍温堂凉堂合霤堂重阁一重舍平覆舍。遣使诣比丘所白言。大德。我为一出家尼。作房舍温堂凉堂合霤堂重阁一重舍平覆舍。大德来。作入舍供养。有如是事听去七夜。如一沙弥尼若王捉若贼若怨若怨党若怨党之党捉捕治。遣使诣比丘所白言。大德。我若王捉若贼若怨若怨党若怨党之党捉捕治。大德来。欲见比丘。有如是事听去七夜。为欲听法听去七夜。为欲布施听去七夜。为欲见比丘听法。欲见比丘布施。欲听法布施。欲见比丘听法布施。有如是事听去七夜。如沙弥尼病苦极。遣使诣比丘所白言。我病苦极。大德来。欲见比丘。有如是事听去七夜。为欲听法听去七夜。为欲布施听去七夜。欲见比丘听法。欲见比丘布施。欲听法布施。欲见比丘听法布施。有如是事听去七夜。如沙弥尼病苦。遣使诣比丘所白言。我病苦。大德来。教我随病食。有如是事听去七夜。教我随病药听去七夜。教我具满看病人听去七夜。为随病食随病药。为随病食具满看病人。为随病药具满看病人为随病食随病药具满看病人。有如是事听去七夜。如沙弥尼病苦。遣使诣比丘所白言。大德。我病苦。大德来。若此间将我到彼间如法。若彼间将我到此间如法。有如是事听去七夜。如沙弥尼愁思欲舍戒。遣使诣比丘所白言。大德。我愁思欲舍戒。大德来。为我说法。有如是事听去七夜。如沙弥尼有恶邪起。遣使诣比丘所白言。我有恶邪起。大德来。为我除恶邪。有如是事听去七夜。如沙弥尼心疑悔。遣使诣比丘所白言。我心疑悔。大德来。为我如法除。有如是事听去七夜。如沙弥尼满十岁在夫家若满十八岁童女。遣使诣比丘所白言。我满十岁在夫家满十八岁童女。大德来。为我受学法。有如是事听去七夜。如沙弥尼为多识多知。诸大经名波罗纱提伽乃至萨耆陀舍修妒路。若未学欲学。若先学忘欲诵。遣使诣比丘所白言。大德。是多识多知。诸大经波罗纱提伽乃至萨耆陀舍修妒路。我若未学欲学。若学忘欲诵。大德来。教我受学问诵。有如是事听去七夜。如为沙弥尼沙弥亦如是。余随所应

云何为式叉摩尼故应去。如式叉摩尼。为僧故。作房舍温堂凉堂合霤堂重阁一重舍平覆舍。遣使诣比丘所白言。大德。我为僧故。作房舍温堂凉堂合霤堂重阁一重舍平覆舍。大德来。作入舍供养。有如是事听去七夜。若为多比丘二一。多比丘尼二一多式叉摩尼二一。多沙弥二一。多沙弥尼二一。多出家二一。多出家尼二一。若为一出家尼故。作房舍温堂凉堂合霤堂重阁一重舍平覆舍。遣使诣比丘所白言。大德。我为一出家尼故。作房舍温堂凉堂合霤堂重阁一重舍平覆舍。大德来。作入舍供养。有如是事听去七夜。如式叉摩尼。若王捉若贼若怨若怨党若怨党之党捉捕治。遣使诣比丘所白言。大德。我若王捉若贼若怨若怨党若怨党之党捉捕治我。大德来。欲见比丘。有如是事听去七夜。为欲听法听去七夜。为欲布施听去七夜。欲见比丘听法。欲见比丘布施。为听法布施。欲见比丘听法布施。有如是事听去七夜。如式叉摩尼病苦。遣使诣比丘所白言。大德。我病苦。大德来。欲见比丘有如是事听去七夜。为欲听法听去七夜。为欲布施听去七夜。为欲见比丘听法。为听法布施为欲见比丘听法布施。有如是事听去七夜。如式叉摩尼病苦。遣使诣比丘所白言。大德。我病苦。大德来教我随病食。有如是事听去七夜。教我随病药听去七夜。教我具满看病人听去七夜。为随病食随病药。为随病食具满看病人。为随病药具满看病人。为随病食随病药具满看病人。有如是事听去七夜。如式叉摩尼病苦。遣使诣比丘所白言。大德。我病苦。大德来。若此间将我到彼间如法。若彼间将我到此间如法。有如是事听去七夜。如式叉摩尼愁思欲舍戒。遣使诣比丘所白言。大德。我愁思欲舍戒。大德来为我说法。有如是事听去七夜。如式叉摩尼有恶邪起。遣使诣比丘所白言。大德。我恶邪起。大德来为我除恶邪。有如是事听去七夜。如式叉摩尼心疑悔。遣使诣比丘所白言。大德。我心疑悔。大德来为我除。有如是事听去七夜。若式叉摩尼犯后二戒。遣使诣比丘所白言。大德。我犯后二戒。大德来为我更受戒。有如是事听去七夜。若式叉摩尼已嫁满十二岁二十岁童女。遣使诣比丘所白言。大德。我已嫁满十二岁满二十岁童女。大德来与我受具足戒。有如是事听去七夜。如式叉摩尼。为是多识多知。诸大经波罗纱提伽乃至萨耆陀舍修妒路。若未学欲学。若学忘欲诵。遣使诣比丘所白言。大德。是多识多知。诸大经波罗纱提伽。乃至萨耆陀舍修妒路。我若未学欲学。若学忘欲诵。大德来教我受学诵问义。有如是事听去七夜。云何为与学沙弥尼故应去。如与学沙弥尼。为僧故作房舍温堂凉堂合霤堂重阁一重舍平覆舍。遣使诣比丘所白言。大德。我为僧故。作房舍温堂凉堂合霤堂重阁一重舍平覆舍。大德来作入舍供养。有如是事听去七夜。若为多比丘二一。多比丘尼二一。多式叉摩尼二一。多沙弥二一。多沙弥尼二一。多出家二一。多出家尼二一。若为一出家尼故。作房舍温堂凉堂合霤堂重阁一重舍平覆舍。遣使诣比丘所白言。大德。我为一出家尼故。作房舍温堂凉堂合霤堂重阁一重舍平覆舍。大德来作入舍供养。有如是事听去七夜。如与学沙弥尼。若王捉若贼若怨若怨党若怨党之党捉捕治。遣使诣比丘所白言。大德。我若王捉若贼若怨若怨党若怨党之党捉捕治。大德来。欲见比丘。有如是事听去七夜。为欲听法听去七夜。为欲布施听去七夜。为欲见比丘听法。为欲见比丘布施。为欲听法布施。为欲见比丘听法布施。有如是事听去七夜。如与学沙弥尼病苦。遣使诣比丘所白言。我病苦。大德来。欲见比丘。有如是事听去七夜。为欲听法听去七夜。为欲布施听去七夜。为欲见比丘听法。为欲见比丘布施。为欲听法布施。为欲见比丘听法布施。有如是事听去七夜。如与学沙弥尼病苦。遣使诣比丘所白言。大德。我病苦。大德来教我随病食。有如是事听去七夜。教我随病药听去七夜。教我具满看病人听去七夜。教我随病食随病药。教我随病食具满看病人。教我随病药具满看病人。教我随病食随病药具满看病人。有如是事听去七夜。如与学沙弥尼病苦。遣使诣比丘所白言。大德。我病苦。大德来。若此间将我到彼间如法。若彼间将我到此间如法。有如是事听去七夜。如与学沙弥尼愁思欲舍戒。遣使诣比丘所白言。大德。我愁思欲舍戒。大德来为我说法。有如是事听去七夜。如与学沙弥尼有恶邪起。遣使诣比丘所白言。大德。我有恶邪起。大德来为我除恶邪。有如是事听去七夜。如与学沙弥尼心疑悔。遣使诣比丘所白言。大德。我心疑悔。大德来为我如法除疑悔。有如是事听去七夜。如与学沙弥尼。僧欲作治羯磨。若苦切羯磨。若依止羯磨。若驱出羯磨。若下意羯磨。遣使诣比丘所白言。大德。僧欲为我作治羯磨。若苦切羯磨。若依止羯磨。若驱出羯磨。若下意羯磨。大德来如法助我。有如是事听去七夜。如与学沙弥尼。僧作治羯磨竟。苦切羯磨依止羯磨驱出羯磨下意羯磨竟。遣使诣比丘所白言。大德。僧与我作治羯磨竟。苦切羯磨依止羯磨驱出羯磨下意羯磨竟。大德来令轻作莫令重作。有如是事听去七夜。如与学沙弥尼。僧欲作忆念比尼不痴比尼。遣使诣比丘所白言。大德。僧欲为我作忆念比尼不痴比尼。大德来。当令与我忆念比尼不痴比尼。有如是事听去七夜。如与学沙弥尼。僧欲与作实觅羯磨。遣使诣比丘所白言。大德。僧欲为我作实觅羯磨。大德来如法助我。有如是事听去七夜。如与学沙弥尼。僧与作实觅羯磨竟。遣使诣比丘所白言。大德。僧为我作实觅羯磨竟。大德来令轻作莫令重作。有如是事听去七夜。如与学沙弥尼。僧欲作不见摈不作摈恶邪不除摈。遣使诣比丘所白言。大德。僧欲为我作不见摈不作摈恶邪不除摈。大德来我不见教见不作教作不除教除。有如是事听去七夜。如与学沙弥尼。犯僧伽婆尸沙。若应与摩那埵。若应与本日治。若应与出罪羯磨。遣使诣比丘所白言。大德。我犯僧伽婆尸沙。僧欲与我摩那埵本日治若出罪。大德来当令与我若摩那埵若本日治若出罪。有如是事听去七夜。如与学沙弥尼。二部波罗提木叉分别。若未学欲学。若学忘欲诵。遣使诣比丘所白言。大德。我二部波罗提木叉分别。若未学欲学。若学忘欲诵。大德来。教我受学诵问义。有如是事听去七夜。如与学沙弥尼。为是多识多知。诸大经波罗纱提伽乃至萨耆陀舍修妒路。若未学欲学。若学忘欲诵。遣使诣比丘所白言。大德。是多识多知。诸大经波罗纱提伽。乃至萨耆陀舍修妒路。我若未学欲学。若学忘欲诵。大德来教我受学诵问义。有如是事听去七夜。如为与学沙弥尼应去。与学沙弥亦如是。除随其所应。如为比丘应去。为比丘尼亦如是。如他事应去。自事应去亦如是。遣使应去不遣使应去亦如是。比丘比丘尼。若为自身若为他。遣使若不遣使应去。听一七夜不听二七夜。有病比丘夏安居。若不得随病食。有是事难故出去无罪

有病比丘夏安居。若不得随病药。有是事难故出去无罪

有病比丘夏安居。若不得具满看病人。有是事难故出去无罪

有病比丘夏安居。不得随病食随病药。若不得随病食具满看病人。若不得随病药具满看病人。若不得随病食随病药具满看病人。有如是事难故出去无罪

有比丘夏安居。是中女人不如法语。大德。我与汝女若姊妹。汝为我作女夫。作姊妹婿。比丘如是思惟。是中女人不如法语言。大德。我与汝女若姊妹。汝为我作女夫姊妹婿。若我是处住。或失命若失梵行。有是事难故出去无罪。有比丘夏安居。是中男子不如法语。大德。我与汝女若姊妹。汝作女婿作姊妹夫。比丘如是思惟。是中男子不如法语。大德。我与汝女若姊妹。汝作女婿姊妹夫。我若是处住。若失命若失梵行。有如是事难故出去无罪。有比丘夏安居。不正思惟取相思惟。女人若来若去若立若坐。若笑若语若啼。若歌若作妓若舞。若赤裸若多少着衣。若严饰若不严饰。比丘如是思惟。我是处住。不正思惟取相思惟。女人若去来坐立语笑。若啼歌舞作妓赤裸。若多少着衣。若严饰。若不严饰。若我是处住。或失命或失梵行。有如是难故出去无罪。有比丘夏安居。见伏藏大价珍宝。比丘如是思惟。我是中见伏藏大价珍宝。若是处住。或失命或失梵行。有是事难故出去无罪

有比丘夏安居。若父母来。兄弟姊妹儿女本第二来。比丘如是思惟。我是中若父母来。兄弟儿女姊妹本第二来。我若是处住。或失命或失梵行。有是难故出去无罪

有比丘夏安居。见破僧作二部。比丘如是思惟。是中破僧作二部。我若是中住。或生恶心或作恶口。是我长夜有折减堕恶道。有是难故出去无罪

有比丘夏安居。见僧勤欲破僧。比丘如是思惟。是中住处。僧欲勤破僧。我若是中住。或生恶心或作恶口。我长夜有折减堕恶道。有是事难故出去无罪

见多比丘二一。多比丘尼二一。多式叉摩尼二一。多沙弥二一。多沙弥尼二一。多出家二一。多出家尼二一。见一出家尼勤欲破僧。比丘如是思惟。是中出家尼勤欲破僧。我若是中住。或生恶心或作恶口。我长夜有折减堕恶道。有是事难故出去无罪

有比丘夏安居。若闻彼住处有勤欲破僧方便合会。比丘如是思惟。彼间住处有勤欲破僧方便合会。我能如是软语约敕。令彼心息还使一心和合。有是事故出去无罪

有比丘夏安居。若闻彼间住处有僧勤欲破僧。比丘如是思惟。彼间住处有僧勤欲破僧。我能如是软语约敕。令彼心息。能令不勤破僧还一心和合。有是事故出去无罪

若多比丘二一。多比丘尼二一。多式叉摩尼二一。多沙弥二一。多沙弥尼二一。多出家二一。多出家尼二一。若一出家尼勤欲破僧。比丘如是思惟。彼间有一出家尼勤欲破僧。我能如是软语约敕令和合。不勤破僧还一心和合。为是事故出去无罪

有比丘夏安居。闻彼间住处有勤欲破僧方便合会。比丘如是思惟。彼间住处有欲破僧方便合会。我不能如是约敕如是软语令彼心息还一心和合。我彼中有亲。是亲力能软语约敕。令彼破僧方便合会事息还一心和合。为是事故出去无罪

有比丘夏安居。闻彼间僧欲勤破僧方便合会。比丘如是思惟。彼间僧勤欲破僧我力不能软语约敕令彼心息还一心和合。我彼中有亲。亲力能软语约敕。令彼破僧方便合会心息还一心和合。为是事故出去无罪

如是多比丘二一。多比丘尼二一。多式叉摩尼二一。多沙弥二一。多沙弥尼二一。多出家二一。多出家尼二一。如一出家尼勤欲破僧方便合会。比丘如是思惟。彼间有出家尼。勤欲破僧方便合会。我力不能软语约敕令彼心息还一心和合。我彼中有亲。亲力能软语约敕。令彼破僧方便合会心息还一心和合。为是事故出去无罪。有比丘夏安居。时八难若一一难起。有如是事难故出去无罪。广说如自恣中

比丘发心欲彼处前三月夏安居。此间有急事起。若至彼不得已应还。是比丘作是念。我此间事未讫。而至彼间者。必当还此间。事讫然后往彼住处。是比丘不应彼间住处前三月。自违言得罪

比丘发心欲彼处夏安居。是二住处一布施别布萨。是比丘如是思惟。我若是中作布萨。得此处衣分。若彼间住处布萨。亦得此处衣分。是比丘不安居处作布萨。后还至安居处。是比丘不应彼住处前三月。自违言得罪。比丘欲往彼处住。往彼处住竟。不作布萨出界去。是比丘不应彼住处前三月。自违言得罪

比丘欲往彼住处。往彼住处竟。作布萨竟。不受床卧具出界去。是比丘不应彼住处前三月。自违言得罪。比丘欲往彼住处。往彼住处竟。作布萨受床卧具竟。无因缘出界去。是比丘不应彼住处前三月。自违言得罪。比丘欲往彼住处。往彼住处竟。作布萨受床卧具竟。不受七夜出界去。是比丘不应彼住处前三月。自违言得罪

比丘欲往彼住处。往彼住处竟。作布萨受床卧具竟。受七夜出界去。界外尽七夜而还。是比丘不应彼住处前三月。自违言得罪

比丘欲往彼住处。往彼处竟。作布萨受床卧具竟。受七夜出界去。不尽七夜而还。是比丘应彼住处前三月。不自违言无罪。后三月亦应如是广说。第七日当自恣受宿出界不犯。若六夜若五夜若四夜若三夜若二夜若一夜受宿出界外无罪(七法中安居法第四竟)

十诵律卷第二十四十诵律卷第二十五(第四诵之五)

        后秦北印度三藏弗若多罗译

    七法中皮革法第五

佛在舍卫城。尔时阿湿摩伽阿槃提国。有聚落。名王萨婆。中有大富居士。财宝丰盈种种具足。唯少一事。无有儿息。从诸神祇池神家神交道大神满贤大神高贤大神大自在天神那罗延神韦纽天神下至钵婆罗神。为有子故求请乞索。而不能得。有子时到。居士妇乃觉有娠。利根女人有四不共智。何等四。一知男爱。二知男不爱。三知妊娠时。四知所从得。妇自知有娠。语居士言。我已有娠。居士闻之。心欢喜踊跃。或当生男。好加供给洗浴净洁。以香涂身随时将息。令身安隐。若有所至。多人卫从莫令忧恼。九月已过娩身生男。耳有金环。是儿端正见者欢喜。居士闻之。心喜踊跃。集诸知相婆罗门相之问言。是儿德力何如。诸婆罗门言。居士。是儿实有福德威力。居士言。当为作字。是时国法作二种字。若随宿若随吉。诸人言。居士。是儿何时生。答言某日生。是诸婆罗门算知语言。是儿沙门宿日生。即名沙门。居士复集婆罗门及诸居士善知金宝相者。以儿耳示之。是儿耳环价直几许。诸人言。居士。是儿耳环。非世所作不易平价。意想平之。可直纯金一亿。儿字沙门。耳环直一亿。众人即字为沙门亿耳。众人当识。是居士令五种养母养视。何等五。一者治身母。二者除垢母。三者乳母。四者吉母。五者戏笑母。云何治身母。为是儿治头手足耳鼻诸指。是名治身母。云何除垢母。时时为儿洗浴浣濯。是名除垢母。云何乳母。时时饮食乳养。是名乳母。云何吉母。是儿行时执孔雀拂。持三股叉侍卫拥护。是名吉母。云何戏笑母。为儿作机关木人象马车乘弓箭种种戏具。随时娱乐之。是名戏笑母。是儿福德威力。而疾长大。便教书数算印。善知诸物价相贵贱。是王萨薄聚落。是四方商客所聚集处。时四方商客来诣聚落。问言是中阿谁善好。有德可寄可信示我利害。诸人示沙门亿耳。善好有德可寄可信善别利害。是诸商客。即诣沙门亿耳托为主人。沙门亿耳问诸商客。从何处来。答言。从某方某国来。即问。彼方国中有何好恶。商客具答好恶之事。是时复有诸商客海中来者。至王萨薄聚落。问言。是中阿谁善好。有德可寄可信示我利害。诸人示沙门亿耳。善好有德可寄可信善别利害。是诸商客即托为主人。沙门亿耳问诸商客。从何处来。答言。大海中来。问大海中有何好恶。商客具答海中诸事。大海中有波怖龟怖提迷鱼。怖提迷耆罗鱼怖失收摩罗鱼怖回波怖水覆山怖黑风怖恶龙处怖恶罗刹怖。亿耳。百千人去时一得还。若得来还。种种珍宝布施作福。七世不尽何况己身。是诸商客。见是沙门亿耳有大威力如是思惟。若作萨薄共多人入海。必安隐来出。诸人言。沙门亿耳。汝何以不入大海。答言。我入大海作何等。是中多诸恐怖。百千人去时一得还。是诸商客激厉言。何等人仰他活命。乃至淫女仰他活命。若人求作布施福德。是事善好。诸商客如是激厉。沙门亿耳信受欲去。到父母所辞欲入海。时父母说诸怖事。欲令变悔以制留之。人为财故入大海。我家中多诸宝物。汝用布施作福。七世不尽。何为入海。时不随父母语。父母语诸贵人。佐我留亿耳。时诸大官长者居士亿财主大富萨薄。如是贵人留之不随。父母知其意正。则听令去。于是乘象振铃。遍告聚落令言。沙门亿耳欲入大海。我作萨薄谁欲共去。是人福德。五百商人皆悉乐从。彼国土法。作萨薄者。要出二十万金钱。十万办舡。十万办资粮。庄严竟已。下舡着水中。以七枚绳系。日日唱言。谁能舍父母兄弟姊妹妻子阎浮提种种乐。及舍乐寿。谁欲得金银摩尼琉璃种种宝物七世随用布施作福者。共入大海。如是日日唱。日断一绳。如是断六绳。残第七绳待伊勒风(晋言好随风)既得伊勒风。断第七绳。舡疾胜箭。是萨薄福德威力。是舡疾到宝渚。敕语诸商客言。取诸宝物载使满舡。莫令大重。取宝物竟得伊勒风。是时舡去疾胜于箭。还阎浮提。向王萨薄聚落。有二道水道陆道。沙门亿耳语诸商人。何道去。诸人言陆道去。时有空泽。是中夜住。语诸商人。我曾闻贼来劫。诸商客。若前杀萨薄。则诸商客无所成办。若不杀萨薄。则以钱物力。若自身力若以他力。必能得贼。我当余处宿去。时当唤我。诸人言尔。亿耳驱驴别处宿。是诸商客夜半发去。人人相觉。竟不唤亿耳。后夜大风雨堕。亿耳觉唤诸商客。商客无人应者。亿耳如是思惟。奈何诸人弃我去耶。即逐去。是道多沙土。风雨流漫路无遗迹。仰驴嗅迹而前。亿耳饥极前行。见有一城严好净洁。如是思惟。念想得食立于城门。随念失声唱言。食食。时无数百千万饿鬼来出。皆言。何等食阿谁与。亿耳言无食。我行饥极念想得食。因出此言。我无食也。如是思惟。我当城边得食。是故唱言食耳。诸饿鬼言。此是饿鬼城。我百千万岁今日乃闻唱食声。我等以不布施悭心多故。堕饿鬼中。汝欲那去。亿耳言。欲至王萨薄聚落。鬼言。从是道去。于是前行。复见一城。如是复念。前城不得食。今或能得水。即到门立唱言。水水。时无数百千饿鬼来出。皆言。何等水阿谁与。亿耳言无水。我渴极念想得水。因出是声。我无水也。如是思惟。我当城边得水。是故唱言水耳。饿鬼言。此是饿鬼城。百千万岁今日乃闻水声。我等以不布施悭心多故。堕饿鬼中。汝欲那去。亿耳言。欲至王萨薄聚落。鬼言。从是道去。前行不久。复见树。名婆罗。夜于下宿。摇树落叶。细者自食粗者与驴。如是日暮至夜。是中即有床出。男出女出。颜貌端正着天宝冠。共相娱乐。沙门亿耳作是思惟。我不应尔看他私事。时夜过昼来。即时床灭女灭。有群狗来啖是男子肉尽骨在。亿耳念言。我悔不问是人。先作何行今得此报。夜善昼恶。我当住待问之。至夜更有好床。男出女出颜貌端正。着珠宝天冠共相娱乐。亿耳即往问男。汝作何行今得是报。夜善昼恶。男言。汝何用问为。亿耳言。意欲知之。男言。汝识阿湿摩伽阿槃地国中王萨薄聚落不。亿耳言识。男言。我是某甲屠儿。有长老迦旃延。常出入我家。我常供给饮食衣被汤药。亿耳。彼常语我言。莫作恶行后得大苦。我时答言。先世以来以此为业。今若不作那得自活。时迦旃延复语我言。汝作此恶昼多夜多。我言昼多。即语我言。汝夜受五戒可获微善。我即从受。今得此报。夜善昼恶皆由作行。悔恨何益。男问亿耳。汝欲那去。答言。至王萨薄聚落。男言。从是道去。亿耳便去。前行不久复见一树。名波罗。住下止宿。摇树落叶。细者自食粗者与驴。时夜过昼来。是处复有床出。男出女出颜貌端正。着珠宝天冠共相娱乐。亿耳即念。我不应住此观他私事。如是至暮床灭女灭。百足虫出啖是男子。肉尽骨在。亿耳念言。我悔不问。汝作何行今得此报。昼善夜恶。当住待问。夜过昼来复有床出。男出女出颜貌端正。着珠宝天冠共相娱乐。亿耳往问男子。汝作何行今获此报。昼善夜恶。男言。汝何用问为。亿耳言。意欲知之。男言。汝识阿湿摩伽阿槃地国中王萨薄聚落不。答言识。是中某甲男子淫犯他妇。有长老迦旃延。出入我家。我家常供给饮食衣被汤药。亿耳。尔时彼教我言。莫作恶行后得苦报。我答言。不能自抑当可如何。复语我言。汝于此事何时偏多。我言夜多。时迦旃延即语我言。受昼五戒可获微善。我用其言。受昼五戒故获斯报。昼善夜恶。悔恨先行无所复益。男问亿耳。汝欲那去。答言。欲至王萨薄聚落。男言。从是道去。前行复见林树池水清净。亿耳于中洗浴饮驴。是池边有堂。众宝庄严。亿耳仰视见堂。即作是念。我饥渴欲死。当何所在。即便上堂。诵佛经偈

  饥为第一病　　行为第一苦
  如是知法宝　　涅槃第一乐

上堂见女人坐象牙床。床脚系二饿鬼。是女识亿耳字。问讯沙门亿耳。道路不极不渴不饥耶。亿耳自念。是女人生不见我。乃识我字。何以得尔。女即唤亿耳坐。共相问讯。语女言。贵女乞我食。女言相与。汝但莫与是二饿鬼。亿耳言。贵女。今我饥急何能与鬼。女即与水洗手与食。是女欲令亿耳知此因缘故。小出堂外。时二饿鬼伸手语沙门亿耳。乞我一口。乞我半口。我腹中饥如火烧。沙门亿耳。先好布施怜愍众生。作是思惟。我饥急辛苦。是饿鬼那得不苦。各各与一口。是二饿鬼着食口中。是食变成脓血。少多咽还吐出。满堂臭恶。女人还入见。臭处满堂。女言。我语汝莫与。何以与之。亿耳言。姊妹。我不知是事故与。女即除吐扫洒烧香。还坐本处。亿耳语。姊妹更与我食。女言。我不惜食。设与汝者恐更与鬼。是事不可。亿耳言。姊妹我先不知故与。今不复尔。是女即以水洗手与亿耳食。是时更有一女来语。贵女与我食。女言食汝常食。作是语已。即有三锜镬爨火汤沸。是女脱衣着一面入镬中。皮肉烂尽唯有骨锁。冷风来吹。即得出镬还活。着衣啖其烂肉。啖已而去。亿耳故食。更有女来言。贵女与我食。女言食汝常食。作是语竟。女变成羖羊啖草。沙门亿耳如是思惟。自疑我或人中死生此饿鬼国耶。即语贵女是何等事。女言。何用问为。亿耳言。意欲得知。女言。汝识阿湿摩伽阿槃地国中王萨薄聚落不。亿耳言识。是一鬼系我头边床脚者。是我夫某甲居士。系我脚边床脚者。是我儿。有长老迦旃延。出入我舍。受我衣服汤药供养。是二人嗔我言。我作财辛苦。而持与他。汝空自疲劳。后世当得脓血之报。以是悭贪不喜布施堕饿鬼中。是恶口业报故。与食变为脓血。亿耳言。是女何以自啖肉。女言。是女我儿妇。以物与举。或自啖若与人。我问时如是言。我不啖不与他。若自啖若与他者。我当自啖肉。是故今自啖肉。是第二女复作何等。变作羖羊啖草。贵女言。是我婢。我使舂磨。或自啖或与他。若问时言。我不自啖不与他。若自啖若与他者。我后世当作羊啖草。以是因缘今作羊啖草。亿耳言。汝作何行。女言。我有少罪。我是中不久住。我此间死。当生四天王天中。汝能少为我不。亿耳言何等事。女言。王萨薄聚落中我有女。未知修善。汝还至彼。为我语是女某甲。我见汝父母兄兄妇婢。唯汝母独受福。余者受罪。汝母因我语汝。莫作恶事。后世多受苦报。汝若不信汝母言。是处有藏。大有钱财。取为我作福供养僧。亦供养长老迦旃延残余可以自活。作是语已问亿耳言。汝欲去耶。答言欲去。女言汝瞑眼。即如其言便瞑眼。须臾之顷。便于王萨薄聚落不远置之。是诸商客先到聚落者。诸人问之。何以不见沙门亿耳。诸商客言。大海中失。是时聚落诸人闻其失亿耳。举邑啼哭如丧父母。亿耳问之。何以如此。诸人言。沙门亿耳大海中失。以其失故啼哭相吊。亿耳即作是念。我死消息闻是聚落如是忧愦。若今见我必复扰动。何须复归。彼贵女嘱我语其女。当为至彼。亿耳渐到女舍。共相问讯语其女言。某甲知不。我见汝父母兄兄妇婢尽在饿鬼中。唯汝母独受福。余者受苦。汝母语汝。莫作恶事后受苦报。女言。咄男子。汝痴人汝狂人。我父母布施作福德。死必生天。何以故在饿鬼中。亿耳即语女言。汝母言。某处有藏。广大钱物在中。为我作福。供养僧及长老迦旃延。残余自活。是女闻已便至藏所。发取大得钱财。得以生信。如其母敕。即以供养众僧。是沙门亿耳。先世供养佛种善根利根近见谛。以是因缘力。能得今世无漏智。是人为善根力所追。便自思惟。愁忧我用归家为。当往大迦旃延所。即往到已头面礼竟一面坐。沙门亿耳心厌本事怖畏世间。长老迦旃延随顺其意而为说法。即于座上。得诸法清净无垢法眼。是人见法得法知法净法。度疑悔不信他。不随他。立道果中得无所畏。从坐起头面礼长老迦旃延足白言。大德。我归依佛归依法归依僧。我作优婆塞。忆念。我从今尽寿不杀生心信清净。大德。我欲善胜法中出家受具足戒作比丘。欲善胜法中行道。迦旃延言。沙门亿耳。父母听汝出家不。答言大德。我父母未听。迦旃延言。我曹法父母不听。不得出家受具足戒。亿耳言。大德。我自求是事。若父母听。当来出家受具足戒。迦旃延言。汝宜知是时。亿耳头面礼长老迦旃延足即便归家。见父母礼拜问讯。亿耳父母先愁苦故失明。闻亿耳从大海中安隐还归。悲喜泪出眼还得明。亿耳住过五六日已。白父母言。听我善胜法中出家。父母言。亿耳我唯有汝。本至心求愿得汝。汝不用我语入大海。得汝死消息。愁忧故眼盲。汝今大海中安隐来还。我大欢喜眼得开视。汝今便为更生。汝受我语。则为供养我曹。我曹寿命不过几时。若能毕我等寿不出家者。我死不恨。亿耳答言诺。供养满十二年。终父母寿。如偈说

  生者有死　　高者亦堕　　一切皆尽
  无有常者

亿耳澡浴。到长老迦旃延所。头面礼足一面坐。大德。我今得正法信。欲佛法中出家修梵行。长老迦旃延。即与亿耳出家。是时阿湿摩伽阿槃地国土。少比丘十众难得。是沙弥夏安居过自恣竟。长老迦旃延共住弟子近住弟子。诸方来见师问讯。尔时比丘满十众。是时与亿耳受具足戒。时诸比丘欲游行东方国。到佛所见佛供养。亿耳问诸比丘。长老那去。诸人言。欲至舍卫国见佛世尊亲近礼拜。亿耳言。我亦欲去。诸人言随意。亿耳言。小待我辞和尚。亿耳向长老迦旃延所。头面礼足一面坐如是言。大德和尚。我今安居竟。欲游行东方国土见佛世尊亲近礼拜。愿听我去。迦旃延言。欲往随意。汝当代我头面礼佛足问讯。少病少恼起居轻利安乐住不。及余比丘如是问讯。长老摩诃迦旃延是我和尚。阿湿摩伽阿槃地国土中旧比丘摩摩帝帝帝陀罗济度我。是长老头面礼佛足问讯。少病少恼起居轻利安乐住不。及余比丘亦如法问讯已。从婆伽婆乞请五事。一者阿湿摩伽阿槃地国土。少比丘受具足十众难得。愿佛听此国少比丘受具足。二者阿湿摩伽阿槃地国土。地坚多碎石土块。愿佛听此国比丘着一重革屣。三者阿湿摩伽阿槃地国人。喜洗浴以水为净。愿佛听此国诸比丘常洗浴。四者如东方国土。用如是麻褥覆毛褥覆花衣褥覆。愿佛听阿湿摩伽阿槃地国比丘皮褥覆羊韦鹿韦羖羊韦。五者有比丘遣比丘。使与他比丘衣。他不取是衣中间失。我曹当云何。亿耳。汝若去东方国土。见佛世尊亲近礼拜。代我如是问讯。以此五事具白世尊。是时亿耳。受长老迦旃延语诵利。从坐处起头面礼长老摩诃迦旃延竟。已即向自房付卧具。持衣钵游行诸国土。渐渐到舍卫国见佛。头面礼足一面坐。诸佛常法。有客比丘来。以如是语问讯。忍不足不。安乐住不。乞食不难。道路不疲耶。尔时佛以是语问亿耳。忍不足不。安乐住不。乞食不难。道路不疲耶。是比丘答言。实忍足安乐住乞食不难道路不疲。诸佛常法。共客比丘一处宿时。敕侍者为客比丘房舍内敷床卧具。是时佛敕阿难。为客比丘房内敷床卧具。阿难如是思惟。如佛所敕。为客比丘敷床卧具。佛世尊今日。必欲与客比丘同一房舍宿。即向佛房与客比丘敷床卧具竟。还白言。大德。与客比丘敷床卧具竟。佛自知时。佛从坐起向自房。到坐处敷尼师檀结加趺坐。亿耳向佛房。到已头面礼佛足。坐处敷尼师檀结加趺坐。是二人夜多坐禅默然。中夜过至后夜。佛语亿耳。汝比丘呗。亿耳发细声。诵波罗延萨遮陀舍修妒路竟。佛赞言。善哉比丘。汝善赞法。汝能以阿槃地语声赞诵。了了清净尽易解。比丘汝好学好诵。佛知故问。汝何以晚入道。亿耳言。大德。我久知欲患。有缘事不得出家。即说偈言

  已见世间过　　见法不乐漏
  圣人不乐恶　　恶人不乐善
  决定见法味　　法味息烦恼
  除热离众恶　　服法喜法味

亿耳如是思惟。是我时到。当以五事广问世尊。于是亿耳。从坐起偏袒着衣合掌白佛言。世尊。长老大迦旃延是我和尚。阿湿摩伽阿槃地国中旧住摩摩帝帝帝陀罗济度我。稽首礼佛足问讯。少病少恼起居轻利安乐住不。及余比丘亦如法问讯。以五事广问世尊。佛语亿耳。汝且止。须我问时当说。佛以是因缘会僧。会僧已告亿耳。汝所问便问。是时忆耳白佛言。大德。长老迦旃延是我和尚。阿湿摩伽阿槃地国土旧比丘摩摩帝帝帝陀罗济度我。是长老头面礼佛足问讯。少病少恼起居轻利安乐住不。余比丘亦如是问讯。五事广白世尊。何等五。一者阿湿摩伽阿槃地国土。比丘少受具足十众难得。愿佛听此国少比丘受具足。二者阿湿摩伽阿槃地国土。地坚碎石多土块多。愿佛听此国土比丘着一重革屣。三者阿湿摩伽阿槃地国土人。喜洗浴以水为净。愿佛听此国土诸比丘常洗浴。四者大德若东方国土用如是麻褥覆毛褥覆华衣褥覆。愿佛听此国土比丘皮作褥覆羊韦鹿韦羖羊韦。五者有比丘遣比丘。使与他比丘衣。他不取是衣中间失。是中我曹当云何。佛种种因缘赞戒赞持戒。赞戒赞持戒已。佛语诸比丘。从今日听边国中持律第五受具足戒。是中南方白木聚落。白木聚落外是边国也。西方有住婆罗门聚落。婆罗门聚落外是边国。北方优尸罗山。去山不远。有蒲泉萨罗树。萨罗树外是边国。东方有婆罗聚落。字伽郎。伽郎外是边国。东北方有竹河。竹河外是边国。从今日听阿湿摩伽阿槃地国土比丘作一重革屣。若穿破更补两头置中央。厚重革屣不应着。毛革屣不应着。声革屣不应着。缠革屣不应着。一切青革屣。一切黄一切赤一切白一切黑。青皮间黄皮间赤皮间白皮间黑皮间。青韦绣黄韦绣赤韦绣白韦绣黑韦绣。师子皮绣虎皮绣豹皮绣獭皮绣猫皮绣。兜罗纻屣。毳纻屣。劫贝纻。羖羊毛纻。羖羊毛缕缝屣。羖羊角革屣。广前革屣。孔雀筋缕缝。孔雀翅杂革屣。一切种种杂色庄严缕绣革屣不应着。若着犯突吉罗罪。从今日听阿湿摩伽阿槃地国中常洗浴。如东方麻褥覆毛褥覆华褥覆。我今听阿湿摩伽阿槃地国中。如是皮作褥覆。羊韦鹿韦羖羊韦。有比丘遣比丘。使与他衣。他比丘不取。是衣中间失。佛言。若得衣彼比丘十日应畜。若过十日犯舍堕

佛婆伽婆在舍婆提国住。六群比丘尔时畜大皮师子皮虎皮豹皮獭皮狸皮。佛言。五大皮不应畜。若畜犯突吉罗罪。更有五皮不应畜。象皮马皮狗皮野干皮黑鹿皮。若畜犯突吉罗罪

佛在俱睒弥国。是时长老阐那有高好床。佛与阿难诣阐那房。阐那遥见佛来。见已向佛合掌如是语。大德来入房看。佛见阐那布高好床。见已语阿难。是痴人。敷高好床内烂外流。佛种种因缘诃竟。语诸比丘。从今日高好床不应畜。若畜犯波逸提罪

佛在毗耶离国。时有一恶优婆塞。与跋难陀释子作弟子。共语恭敬更相爱念。跋难陀释子晨朝着衣持钵至其家。恶优婆塞与布坐处。命跋难陀坐。共相问讯。其家有犊子杂色斑驳。见已即生贪心。是好可用作尼师檀。跋难陀语言。汝犊子杂色斑驳。是可用作尼师檀。优婆塞言。汝须耶。语言须。即杀犊子剥皮持与。便持皮去。犊母鸣吼从后逐之。是时诸比丘。维耶离僧坊门间空地经行。遥见跋难陀来。诸比丘相语。是跋难陀释子无羞人。多有见闻疑恶。欲人牸牛吼随后来。必作恶事。若欲作若已作。渐渐到诸比丘所。问言长老。此牛何以从汝后鸣吼跋难陀向诸比丘广说。诸比丘种种因缘诃跋难陀。何以名比丘。故夺畜生命。汝无慈愍心。如是种种因缘诃已。是事白佛。佛以是因缘集僧。集僧已佛知故问跋难陀。汝实尔不。答言。实尔世尊。佛种种因缘诃。何以名比丘。故夺畜生命。无怜愍心。佛种种因缘诃已。语诸比丘。从今日白衣舍牛皮。不应受不应坐卧。比丘家中燥牛皮。应受不应坐卧

佛在舍卫国。六群比丘载女乘。种种不清净。佛言。女乘不应载。若载得突吉罗罪。六群比丘共女载。种种不清净。佛言。不应共女载。若共载得突吉罗罪。六群比丘共女有间载。种种不清净。佛言。不应共女有间载。若载得突吉罗罪

长老毕陵伽婆蹉患眼。亲里遣使两犍牛驾车来迎。长老乘车来此间治眼。答言。佛未听乘两犍牛车。以是事白佛。佛言。听载犍牛车。当使余人御。不得自御。尔时六群比丘捉牸牛尾渡河。种种不清净。佛言。不应捉牸牛尾渡河。若捉得突吉罗罪。若师子虎象马牛。雄者捉尾渡河无罪。六群比丘捉小女人手渡河。种种不清净。佛言。不应捉小女人手渡河。若捉小女人手渡河。得突吉罗罪

有诸居士妇。向阿脂罗河洗浴。脱衣岸上入水洗浴河水卒涨漂去。尔时诸比丘。在河岸边空地经行。时诸女人语诸比丘。大德。见救捉我等。诸比丘言。姊妹。佛结戒。不应故触女人身。诸女人言。大德慈悲怜愍人。何处沙门释子中我等今为水漂是非见捉。诸比丘不知云何。以是事白佛。佛言应救。诸比丘如是捉时淫心起还放。诸女言。大德小时莫放得到彼岸。诸比丘不知云何。是事白佛。佛言。虽淫心起。但捉一处莫放。到岸不应故触。若更触得罪。若绣画女木女不应故触。触得突吉罗罪

佛婆伽婆在阿罗毗国。阿罗毗诸比丘着木屐。时时到和尚阿阇梨所。受经学经问经。是时精舍内曳屐踉踉作声。有一摩呵卢比丘。蹈断长行虫。佛知故问阿难。何以故精舍内曳屐声。阿难言。世尊。是阿罗毗诸比丘。着木屐时时到和尚阿阇梨所。受经学经问经。是故曳屐作声。佛以是事集僧。集僧已。知而故问诸比丘。汝实尔不。答言。实尔世尊。佛种种因缘诃。何以名比丘。畜木屐。种种因缘诃已告诸比丘。从今不得着木屐多罗奢屐竹屐竹叶屐文若屐婆毗屐。若畜犯突吉罗罪

长老跋提。从高贵中出家。是人本白衣时。着钦婆罗屐。如本法畜钦婆罗屣。诸居士讥嫌诃责。沙门释子自称善好有德。着钦婆罗屐。如王如大臣。有诸比丘。少欲知足行头陀。闻是事心惭愧。以是事具白佛。佛以是因缘集僧集僧已。佛知故问。汝实尔不。答言。实尔世尊。佛种种因缘诃。何以名比丘。着钦婆罗屐。种种因缘诃已。语诸比丘。从今日钦婆罗屐不应着。若着犯突吉罗罪

佛在王舍城瞻卜国。中有长者子。字沙门二十亿。是人弃二十亿金。舍瞻卜城五百聚落阿尼目佉出家。徒跣空地经行。足下血出遍流经行地。经行此头彼头乌啄血。佛与阿难到是处见是事。佛知故问阿难。谁是处经行地血流漫。阿难答言。世尊。是瞻卜国中长者子。字沙门二十亿。弃二十亿金。舍阐卜城五百聚落阿尼目佉出家。徒跣经行。足下血流遍经行地。经行此头彼头乌啄血。佛以是事集僧。集僧已。佛知故问。汝实尔不。答言。实尔世尊。佛言。沙门汝能着一重经行革屣不。答言不能。佛言何以不能。答言世尊。我傥有同守戒。诸比丘当言。瞻卜国中长者子。字沙门二十亿。弃二十亿金。舍瞻卜城五百聚落阿尼目佉出家。而染着一重革屣。若佛听一切比丘着。我当着。佛种种因缘赞戒赞持戒。赞戒赞持戒已。语诸比丘。从今听着一重经行革屣。若破补两头置中央。厚重革屣不应着。毛革屣不应着。声革屣不应着。缠革屣不应着。一切青一切黄一切赤一切白一切黑革屣不应着。青皮间黄皮间赤皮间白皮间黑皮间。青皮绣黄皮绣赤皮绣白皮绣黑皮绣。师子皮绣虎皮绣豹皮绣獭皮绣猫皮绣。兜罗纻屐。毳纻屐。劫贝纻屣。羖羊毛纻屣。羖羊毛缕缝屣。羖羊角屣。广前屣。孔雀筋缝屣。孔雀翅缝屣。一切杂色革屣不应着。若着犯突吉罗罪

佛在舍卫国东园摩伽罗母堂上。晡时从禅起下堂。在露地经行。是时诸比丘着革屣随佛经行。佛顾视。见诸比丘着革屣随佛经行。语诸比丘。有外道出家师。弟子尊重恭敬师故。不着革屣从师经行。何况多陀阿伽度阿罗诃三藐三佛陀。汝曹着革屣随佛经行。佛种种因缘诃已语诸比丘。从今佛前不得着革屣。和尚阿阇梨一切上座前。佛塔中。得道塔中。温室讲堂。食厨门间禅窟。大小便处。洗大小便处。洗浴处。一切多众行处。不应着革屣若着犯突吉罗罪

佛在舍卫国。长老毕陵伽婆蹉病眼痛。徒跣入聚落。蹴石伤脚增益眼痛。以是事语诸比丘。诸比丘以是事白佛。佛以是因缘集僧。集僧已。佛知故问毕陵伽婆蹉。汝实尔不。答言。实尔世尊。佛种种因缘赞戒赞持戒。赞戒赞持戒已。语诸比丘。从今听着一重革屣入聚落。厚重革屣不应着。毛革屣不应着乃至种种杂色缕缝革屣不应着。若着犯突吉罗罪

佛在舍卫国。诸比丘露地洗脚。以脚指行脚跟行。或登树叶行。若石上跳行。入户床上坐。或时用草若衣。若弊纳拭脚住处。诸草若衣弊纳。狼藉在地。卧具垢臭。尔时有一居士。请佛及僧明日食。佛默然受。居士知佛受请。从坐起头面礼足绕佛而去。到自舍具多美饮食气味香洁办具竟。敷坐处遣人白佛时到。食具已办佛自知时。诸比丘至居士舍。佛自房住迎食分。诸佛常法。如是游观看诸比丘房。持户钩处处大房别房遍诸房看。开一房见草及衣弊纳狼籍在地卧具垢臭。佛入房。安徐举被褥出床榻。弃地草及衣弊纳。扫房中涂地竟。还内被褥床榻。闭户下橝。向自房到坐处。敷尼师檀结加趺坐。是时中间。居士见僧坐已。自行澡水。自手与种种多美饮食气味香洁。僧自恣饱满已持独坐床是中坐欲闻法。上座说法已次第而去。还到精舍头面礼佛足一面坐。诸佛常法。比丘食还。欢喜软语如是问。诸比丘美食饱满不。尔时诸比丘还。佛以如是语问。诸比丘。美食饱满不。答言饱满。佛言。我今日持户钩处处大房别房遍诸房看。开一房户。见草及衣弊纳狼藉在地卧具垢臭。是事不是。汝曹云何不爱护僧卧具。诸居士婆罗门血肉干竭布施作福诸比丘是中应少受善爱护。佛种种因缘诃已。语诸比丘。从今听一重洗脚革屣。若穿更补两头置中央。厚重革屣不应着。乃至种种杂色缕缝革屣不应着。若着犯突吉罗罪

佛在舍卫国。有一比丘失一重洗脚革屣。比丘到居士所乞言。我失一重洗脚革屣。汝与我。居士约敕皮师。汝与是比丘作一重革屣。我与汝价。是皮师以厚重革屣贵直二三钱。不肯与作一重革屣。比丘到皮师所索。皮师不与作。比丘不得。还从居士求言。居士。是皮师竟不与我作一重革屣。居士言。大德。我已约敕。不肯与我当云何。汝能着厚重革屣不。比丘如是思惟。我当坏厚重革屣作一重革屣着。是比丘持缕锥往只桓门间。欲坏厚重革屣作一重革屣。佛食后彷徉经行。往到是处。见是比丘门下坐。佛知故问比丘。汝作何等。答言世尊。我失一重洗脚革屣。我从居士乞。居士约敕皮师令作言。与是比丘作一重洗脚革屣。我与汝价。是皮师以厚重革屣贵直二三钱故。不肯与我作一重革屣。我到皮师所重索。皮师故不与我。我不得已还从居士乞。语言居士。是皮师竟不与我一重革屣。居士言。我已约敕。不肯与汝。我当云何。便语我言。汝能着厚重革屣不。我如是思惟。当坏作一重洗脚革屣。佛语比丘。莫坏厚重革屣。何以故。不坚牢故。从今听作破染着净。若有人施厚重革屣。还令主着行。下至二三步。如是得畜

佛在王舍城。六群比丘。以佛听着破染着净革屣故。求种种杂色革屣畜。有时六群比丘。到诸释子边乞革屣。若主不与。一比丘高举一比丘脱取。以是事故。释子恒不敢出。恐六群比丘脱我革屣故。诸居士讥嫌诃责。沙门释子自称善好有德。着种种杂色庄严革屣。如王如大臣。有比丘。少欲知足行头陀。闻是事心惭愧。以是事具白佛。佛以是因缘集僧。集僧已。佛知故问六群比丘。汝实尔不。答言。实尔世尊。佛以种种因缘诃。何以名比丘。着种种杂色庄严革屣。种种因缘诃已。语诸比丘。若有一重革屣。若有破染着净厚重革屣听畜。一切杂色庄严革屣不应着。若着犯突吉罗罪。佛在舍卫国。自恣竟夏末月。与大比丘众游行诸国。有一比丘。手捉革屣跛行。佛见是比丘。知而故问比丘。何以手捉革屣跛行。答言世尊。我革屣内鼻坚。足指间破痛故跛行。佛言。应用软物作(七法中皮革法第五竟)

十诵律卷第二十五十诵律卷第二十六(第四诵之六)

        后秦北印度三藏弗若多罗译

    七法中医药法第六

佛在王舍城。秋时诸比丘冷热发癖癊患动。食不能饱羸瘦少色力。佛见诸比丘羸瘦少色力佛知故问阿难。诸比丘何以羸瘦少色力。阿难白佛言。世尊。诸比丘秋时冷热发癖癊患动食不能饱。是故羸瘦少色力。尔时世尊作是念。当以何药与服令差色力还复。若食粗饭糗糒不能益身。当听服四种含消药酥油蜜石蜜。佛以是因缘故集僧。集僧已告诸比丘。从今日听诸病比丘服四种含消药酥油蜜石蜜。尔时诸比丘中前服。过中不服。犹故羸瘦少色力。佛见已复问阿难。诸比丘何以故羸瘦。答言世尊。世尊虽听病比丘服四种含消药。诸比丘中前服过中不服。是以犹故羸瘦。佛以是因缘集僧。集僧已佛种种因缘赞戒赞持戒。赞戒赞持戒已告诸比丘。从今日听四种含消药中前中后自恣服

佛在舍卫国。是时长老毕陵伽婆蹉目痛。药师语言。以罗散禅涂眼。答言。佛未听我等以罗散禅涂眼。诸比丘以是事白佛。佛言。听以罗散禅涂眼。是长老以罗散禅。盛着钵中半钵键镃小键镃。络囊悬象牙杙上。取药时。流污壁及卧具。房舍中臭秽。佛言。应用函盛。虽盛不覆。土尘堕中。用时增益眼痛。佛言。应作盖盖。直动脱。佛言。子口合作。是时诸比丘。用鸟翮鸡翮孔雀尾。着眼药眼痛更增。佛言用匕。长老优波离问佛。应用何等物作匕。佛言。若铁若铜若贝若象牙若角若木若瓦

佛在毗耶离国住。是地碱湿。诸比丘病疥。脓血流污安陀会如水渍。佛知故问。问诸比丘。何以污安陀会如水渍。诸比丘言。世尊。我曹病疥。脓血流出污安陀会。佛言。从今日听诸病疥比丘用苦药涂。长老优波离问佛。何等苦药。佛言。拘赖阇树拘波罗树拘真利他树师罗树波伽罗树波尼无只伦陀树。诸比丘不晓捣磨。佛言听石磨。石磨药堕地。佛言。听石臼杵捣。诸比丘手坏。佛言。听作木杵。作木杵不晓作。捉处手上下脱。佛言。中央令细。所捣药粗。佛言。应簁令细。以油涂疮。以药坌上

佛在舍卫国。长老施越狂病。受他语啖生肉饮血狂病当差。施越语诸比丘。我狂受他语啖生肉饮血。我今当云何。诸比丘以是事白佛。佛以是因缘集僧。集僧已。佛知故问。问施越。汝实狂受他语啖生肉饮血。语诸比丘。我今当云何。汝实作是事不。答言。实作世尊。佛种种因缘赞戒赞持戒。赞戒赞持戒已语诸比丘。从今日若有如是病。听啖生肉饮血应屏处啖莫令人见

佛在舍卫国。共大众夏安居。是时长老毕陵伽婆蹉。王舍城夏安居。是长老多知多识。多得酥油蜜石蜜。盛着大小钵大小键镃中。络结悬象牙杙上。取时流出污壁卧具房舍臭秽。有诸比丘共行弟子近住弟子。取酥油蜜石蜜。举残恶捉不受内宿合置一器中啖。诸佛常法。两时大会。春末月夏末月。春末月诸方国比丘来诣佛所。听佛说法夏安居乐。是初大会。夏末月安居竟。过三月作衣毕。持衣钵渐渐游行。来诣佛所。我久不见佛。久不见修伽陀。是第二大会。诸比丘王舍城安居讫。过三月作衣竟。与衣钵俱渐渐游行。来诣佛所。头面礼佛足。一面坐。诸佛常法。有客比丘来。如是问。忍不足不。安乐住不。乞食不难。道路不疲耶。今佛亦如是。佛问客比丘。忍不足不。安乐住不。乞食不难。道路不疲耶。诸比丘言。忍足安乐住乞食不难道路不疲。以是事向佛广说。佛以是因缘集僧。集僧已。佛种种因缘诃诸比丘。我怜愍诸病比丘。听服四种含消药酥油蜜石蜜。而举残恶捉。不从净人受内宿。种种因缘诃已。语诸比丘。从今病比丘听服四种含消药。一受已七日自恣服。若过七日。犯尼萨耆波逸提

佛在舍卫国。长老疑离越见作石蜜。若面若细糠若焦土若炱煤合煎。见已语诸比丘。诸长老。是石蜜若面若细糠若焦土若炱煤合煎。不应过中啖。诸比丘以是事白佛。佛以是因缘集僧。集僧已。佛知故问。问疑离越。汝实见作石蜜。若面若细糠若焦土若炱煤合煎。语诸比丘不应过中啖不。答曰。实尔世尊。佛种种因缘赞戒赞持戒。赞戒赞持戒已。语诸比丘。从今听作石蜜。若面若细糠若焦土若炱煤合煎。若中前应啖过中不得啖

佛在舍卫国。时长老舍利弗病风冷。药师言。应服苏提罗浆。舍利弗言。佛未听我服苏提罗浆。诸比丘以是事白佛。佛言。从今听服苏提罗浆。长老优波离问。佛用何等物作苏提罗浆。佛言。以大麦去粗皮。不破少煮。着一器中汤浸令酢。昼受昼服夜受夜服。不应过时分服

佛故在舍卫国。时长老舍利弗热血病。药师言。应服首卢浆。舍利弗言。佛未听我服首卢浆。诸比丘以是事白佛。佛言。听服首卢浆。长老优波离问佛。何等物作首卢浆。佛言。若糵若磨若捣合油。等分以水和之令酢。时应服非时不应服。佛在波罗奈国。与大众共夏安居。是中有优婆夷。字摩诃斯那。大富饶。钱谷田宅宝物丰足。种种福德成就。信佛法僧见谛得道。请佛及僧。夏四月供给病人饮食汤药自恣所须。有一比丘病服下药须肉。语诸看病人言。汝去到摩诃斯那优婆夷所。作如是语。有一比丘病。服下药须肉看病人即往摩诃斯那优婆夷所。语言。有一比丘病。服下药须肉。优婆夷即持物与婢。使买肉与看病人。婢持物遍波罗奈城中。求肉不能得。王波摩达断杀故。还语大家言。王断杀。我遍求不能得。优婆夷思惟。何以辛苦如是。我请佛及僧夏四月自恣所须。一比丘病。服下药须肉。不能得。若不得肉。或当增病。如是思惟已。捉利刀入室。自割髀肉持与婢。汝好熟煮与比丘。婢煮竟与看病人。看病人持去。以水洗病比丘手。持肉与病比丘。病比丘不知是何肉便食。病从是得差。摩诃斯那优婆夷。极患疮痛。不能出入坐起。其夫有小因缘事不在。行还不见其妇。即问。摩诃斯那优婆夷那去。家人言。病苦痛在一室中卧。不能坐起。其夫到边问。汝有何苦痛。为风热冷病耶。优婆夷广说上事。其夫闻已大嗔。不忍不信何缘尔。沙门释子不知时不筹量。若施者不知量。受者应知量。乃使我妇苦痛如是不能坐起。含嗔诣佛。佛时与大众围绕说法。遥见优婆塞来。渐近佛。以大慈力感。彼嗔恚渐息清净心生。头面礼佛足一面坐。佛为说法示教利喜。示教利喜已默然便从坐起偏袒右肩合掌白佛言世尊。受我明日请食并比丘僧。佛默然受。知佛默然受已。头面作礼绕佛而去。通夜办具多美饮食。办竟晨朝布座。遣使白佛。食具已办唯圣知时。佛着衣持钵大众围绕。往到其家在众中坐。优婆塞见大众坐竟。自行澡水。行澡水已。自手与饮食随意所须。大众食讫。澡手执钵。持一小床在佛前坐。听佛说法。佛知故问优婆塞。摩诃斯那优婆夷在何处。答言大德。摩诃斯那优婆夷病苦痛。在一室中卧不能行来。佛言优婆塞。汝去语摩诃斯那优婆夷。佛呼汝。优婆塞到优婆夷边语言。佛呼汝。是时优婆夷闻唤欢喜。疮即差平复。优婆夷言。汝看我师有如是大神力。汝语我言佛呼汝。是时我身患即差平复。夫见妇如是蒙佛神力。欢喜心生。俱诣佛所头面礼佛足一面坐。佛知二人信心欢喜。随意说法。优婆夷得斯陀含道。优婆塞得须陀洹道。佛与二人更说要法。善心即生。示教利喜已。佛从坐起而去。还到精舍。以是因缘集僧集僧已。佛知故问。问病比丘。汝实作是事不。答言。实作世尊。佛种种因缘诃责。何以名比丘。啖人肉。佛种种因缘诃已。语诸比丘。从今日不应啖人肉。人脂人血人筋。若啖犯偷兰遮。啖人骨无罪。从今小因缘不应索肉。若食时得肉应问。是何等肉若不问得突吉罗罪

佛故在波罗奈国。是时饥饿乞求难得。象大疫死。有诸贫贱人象子马子牛子客烧死人人除粪人。皆啖象肉。诸比丘时至到其家乞食。诸人言大德。我此无饭无糗糒。正有象肉。汝能啖不。答言。汝等尚啖。我何以不啖。即与象肉。诸比丘持去。余比丘问此何肉答言象肉。诸比丘种种因缘诃。何以名比丘。佛未听啖象肉而啖。诃已以是事具白佛。佛以是因缘集僧。集僧已。佛知故问。问诸比丘汝实作是事不。诸比丘言。实作世尊。佛种种因缘诃诸比丘。何以名比丘。啖象肉。若梵摩达王。闻沙门释子啖象肉。心不喜。何以故。象是官物故。佛种种因缘诃已。告诸比丘。从今不应啖象肉。象脂象血象筋。若啖得突吉罗罪。若啖象骨无罪

佛故在波罗奈国。是时饥饿乞求难得。马大疫死。有诸贫贱人象子马子牛子客烧死人人除粪人。皆啖马肉。诸比丘时至。到其家乞食。诸人言。大德。此无饭无糗糒。正有马肉。汝等能啖不。诸比丘言。汝等能啖。我何以不啖。即与马肉诸比丘持去。余比丘问。此是何肉。答言马肉。诸比丘种种因缘诃责。何以名比丘。佛未听啖马肉而啖。诃已以是事白佛。佛以是因缘集僧。集僧已。佛知故问。问诸比丘。汝实作是事不。答言。实作世尊。佛种种因缘诃诸比丘。何以名比丘。啖马肉。若梵摩达王。闻沙门释子啖马肉。心不喜。何以故。马是官物故。佛种种因缘诃已。告诸比丘。从今马肉不应啖。马脂马血马筋马骨。若啖得突吉罗罪

佛故在波罗奈国。是时饥饿乞求难得。诸贫贱人象子马子牛子客烧死人人除粪人。皆杀狗啖。诸比丘时至。到其家乞食。诸人言。大德。此无饭无糗饭糒。正有狗肉。汝能啖不。诸比丘言。汝等能啖。我何以不能啖。即与狗肉。诸比丘持去。余比丘问。此是何肉。答言狗肉。诸比丘种种因缘诃。何以名比丘。佛未听啖狗肉而啖。诃已以是事白佛。佛以是因缘集僧。集僧已。佛知故问。问诸比丘。汝实作是事不。答言。实作世尊。佛种种因缘诃诸比丘。何以名比丘。啖狗肉。汝等若至贵人边。若贵人来看汝。若闻沙门释子啖狗肉。则弃舍汝去。汝如旃陀罗。佛种种因缘诃已语诸比丘。从今不应啖狗肉。狗脂狗血狗筋狗骨。若啖得突吉罗罪

佛故在波罗奈国。时世饥饿乞求难得。有诸贫贱人象子马子牛子客烧死人人除粪人。皆杀蛇啖。诸比丘时至到其家乞食。诸人言。大德。此无饭无糗无糒。正有蛇肉。汝等能啖不。诸比丘言。汝等尚能啖。我何以不能啖。即与蛇肉。诸比丘持去。余比丘问。此是何肉。答言蛇肉。诸比丘种种因缘诃责。云何名比丘。佛未听啖蛇肉而啖。诃已以是事具白佛。佛以是因缘集僧。集僧已。佛知故问。问诸比丘。汝实作是事不。答言。实作世尊。佛种种因缘诃责。云何名比丘。啖蛇肉。若诸龙。闻沙门释子啖蛇肉。心不喜。何以故。蛇龙类故。佛种种因缘诃已语诸比丘。从今不应啖蛇肉。蛇脂蛇血蛇筋。若啖得突吉罗罪。若啖蛇骨无罪

佛在舍卫国。佛身中冷气起。药师言。应服三辛粥。佛告阿难。办三辛粥。阿难受敕。即入舍卫城。乞胡麻粳米摩沙豆小豆。合煮和三辛以粥上佛。佛知故问问阿难。谁煮此粥。答言我。佛告阿难。汝持是粥。弃着无草地无虫水中。何以故。若外道梵志见如是事。必作是语。诸沙门释子。师在时漏处法出。阿难受敕。即持粥弃着无草地无虫水中。佛以是因缘集僧。集僧已告诸比丘。从今大比丘煮食不应啖。若啖得突吉罗罪。内宿内煮内宿外煮外宿内煮自煮不应啖。若啖得突吉罗罪

佛在舍卫国。有一居士。请佛及僧明日食。佛默然受。居士知佛受已。从坐起头面礼佛足绕佛而去。还家办种种肴膳多美饮食。敷床坐褥。遣使白佛。食具已办唯圣知时。僧到其舍。佛自房住迎食分。居士见僧坐讫。自行澡水。手自下食。阿难先食迎佛食分。佛患差未久。饭不大熟。阿难思惟世尊若食傥发冷患。即持薪火。于只桓门间煮熟。时佛彷徉经行。见知而故问。阿难汝作何等。答言饭不大熟。世尊若食恐动先患。我今更煮。佛言。善哉善哉。阿难。是食如是更煮应法。从今食生听更煮。若生食听火净已得煮。云何名火净。乃至火一触

佛故在舍卫国。有一比丘痔病。药师名阿帝利瞿妒路。以刀割大行处。时近只桓门间露现处治。苦痛切身。时佛欲入只桓。药师遥见佛来。合掌请佛看是处。佛言。恶口人中。阿帝利瞿妒路此最第一。乃请如来示如是处。从今不应示语大行处。若示语犯罪。从今大行处不应听刀治。若治犯偷兰遮罪

佛故在舍卫国。毗罗然国。有婆罗门王。字阿耆达。是王有小因缘事。来到舍卫国。宿一居士舍。问居士言。是中颇有高德沙门婆罗门为大众师人所宗重者不。若有。我当时时往问讯。我心或得清净。居士言。有沙门瞿昙。释子出家信净除须发着袈裟。得阿耨多罗三藐三佛陀。汝若时时能往问讯。汝心或得清净。婆罗门言。沙门瞿昙今在何处。我欲往见。答言。今在祇树给孤独园。欲见便往。即如其言往见世尊。在林树间大众围绕说上妙法。诸根静默容貌端正如紫金山。既到问讯退坐一面。佛为说法示教利喜。示教利喜已默然。即从坐起偏袒着衣合掌白佛。愿受我请夏坐一时并比丘僧。佛念本行因缘。必应受报以是事故。默然受之。既蒙许可。即起绕佛三匝而去。还归本国。为佛及僧办诸供具种种肴膳以俟三月。敕守门人。我今一夏安乐自娱。外事好丑一不得白。守门受敕一如其教。佛已安居时到集僧。集僧已告诸比丘。今往诣毗罗然国。诸比丘言。敬如佛教。佛与五百大众俱入其国。其国信邪先无精舍。城北有林。号曰胜叶波。其林郁茂其地平博。世尊大众止顿其中。此邑狭隘边鄙最陋民穷少信乞食难得。佛便集僧。集僧已敕诸比丘。汝等当知。此邑穷隘又多不信。乞食难得。若欲于此安居者住。不者随意。众中是时舍利弗。独往阿牟迦未迦山安居。受天王释及其后阿须罗女请。夏四月天食供养。时佛与五百少一比丘。于毗罗然国安居。彼国诸居士及婆罗门。以少信心供佛及僧。满五六日便止。诸比丘乞食极苦难得

时长老大目犍连白佛。有树名阎浮提。阎浮提因以为名。我欲取此树果供养大众。有呵梨勒林阿摩勒林。郁单曰有自然粳米。忉利天食修陀味。普皆欲取以供大众。有甘地味。我以一手擎诸众生。一手反地。令诸比丘自取而啖。愿见听许。佛言。汝虽有大神力。诸比丘恶行报熟。不可移转一皆不听。是国清凉水草丰美。有波罗奈国人。逐水草放马欲令肥。丁来到此处。马子信佛心净。见诸比丘乞食极苦难得。言诸长老。汝等辛苦耶。诸比丘言极辛苦。彼言。我等知汝极饥饿。我等粮食尽。正有马麦。汝能啖不。诸比丘言。佛未听我等食马麦。诸比丘不知云何。以是事白佛。佛言。马属看马人。若是诸牧马人。能以好草盐水食马。此麦自在应受。是马有五百匹。比丘五百少一。一马食麦二斗。一比丘给一斗。一斗与马。中有良马给麦四斗。二斗给佛。二斗与良马。阿难取佛分并自取分。持入聚落于一女前赞佛言。姊妹。佛有如是念定智慧解脱解脱知见。大慈大悲。一切智人身有三十二相八十种好。紫磨金色项有圆光。大梵音声视无厌足。若不出家。当作转轮圣王。犹如日出。当有七宝及千子。我与汝等无不属者。今出家得阿耨多罗三藐三佛陀。未度者度。未解者解。未灭度者灭度。除生老病死忧悲苦恼。有小因缘在此安居。汝能持此麦为佛作干饭不。女言。大德阿难。我家中多务多事不得为作。傍有一女人。闻佛功德即生敬心。如是人者世所希有。白阿难言。可持麦来。我为作饭。从今日汝分我亦当作。更有软善智慧持戒比丘。我亦与作。女即作饭持与阿难。阿难敬佛情深。如是思惟。佛为王种常食肴膳。此饭粗恶安能益身。念已行水授饭。见佛食之悲哽交怀。佛知其意欲解释之。汝能啖此饭不。阿难言能。受以食之滋味非常。实是诸天以味加之。欣悦无量悲哽即除。佛食讫。阿难行澡水洗手摄钵。白佛言。今日有一女人。我倩作饭不肯。傍有一女不倩而作。佛言阿难。是女不肯作饭。所应得者不得。若即作者。此功德报。应作转轮王第一夫人。不倩而作者。此福无量不假余福。此福已大。是时世尊宿行未除。一时之中。无有知佛共僧毗罗然国啖马麦者。魔王化作诸比丘饭食。充满盈长赍行出向诸国。路相逢者问所从来。答言。从毗罗然国来。诸居士言。佛于彼住有四供养不。答言。彼常有大会。有肴膳盈长。我所持者。即是彼之遗余。尔时世尊宿行已毕。十六大国咸闻。世尊与五百比丘。毗罗然国三月食马麦。尔时诸国贵人长者居士大富萨薄。备众供具种种肴膳。车驮盈溢填道而来。奉饷世尊。自恣垂至七日未讫。佛知故问阿难。自恣有几日在。阿难言。余有七日。佛告阿难。汝行入城告阿耆达。佛语汝。我于汝国夏安居竟。欲余国游行诸比丘言。世尊。是人于佛众僧有何恩德。在此安居穷困理极而与之别。佛言。此婆罗门虽无恩分。宾主之宜理应与别。阿难受敕。与一比丘俱到其门下。告守门者。可白汝阿耆达婆罗门令知阿难在外。守门者思惟。阿难名吉。清旦闻之云何不白。时阿耆达。早起沐浴着白净衣独坐中堂。守门者入白王言。阿难在外。婆罗门相法。名吉则吉信名求净。即语令前。阿难前已。即唤令坐。时间小默而问阿难。阿难以何事来。答言。佛遣我来语汝。夏三月住汝国界安居。安居已竟。欲余国游行。婆罗门惊问阿难。瞿昙沙门。毗罗然国夏住耶。阿难言然。婆罗门言。云何得住阿谁供给。阿难言。穷苦理极。佛与众僧。三月食马麦。是时婆罗门始自觉悟。念前请佛并及众僧夏四月供具充备。如何令佛及僧三月食马麦。恶声丑名流布诸国。当言阿耆达长夜恶邪憎嫉佛法。恼佛及僧乃令困极。即语阿难。令沙门瞿昙可得忏悔留不。阿难言不得。是婆罗门忧愧愁恼热闷躄地。时诸宗亲以水洒面扶起乃稣。亲里喻言。汝莫愁忧。我当与汝忏谢瞿昙。当请留住。若不肯住。当赍饭食随后逐之乏少时供养。婆罗门及诸宗亲。共往诣佛忏悔请留。佛便思惟。我若不受。彼当吐热血死。佛怜愍故。受请七日。婆罗门思惟。此供具俟夏四月。云何七日能尽。佛自恣竟。欲往越只国二月游行。越只国人闻佛当来。各设供具。一日二日一施两施。令毕二月次第作竟。佛自恣竟。二月越只国游行。阿耆达赍诸供具追随佛后。若乏少时当设供养。越只诸人闻已。相率集会共作要令。若有请佛。皆当日日备具前食后食怛钵那无令乏少。莫使异人间错其中。阿耆达知佛宿处。辄赍食具器物。先往施设言。我当今日施。若明日若后日。诸越只人不听。语言。汝长夜恶邪。是佛怨家。故恼佛及僧。今欲悦他意故。作如是语。我当今日施。若明日若后日。汝有何事。尔许时令佛及僧毗罗然国三月啖马麦。而今急急欲求施日。婆罗门闻是语。惭愧交怀在一面立看。众僧少何等我当与之。值时无粥。即办种种粥。酥粥油粥胡麻粥乳粥小豆粥磨沙豆粥麻子粥清粥。办已奉佛。佛告婆罗门。与僧作分。即与比丘。比丘不受言。佛未听我食八种粥。以是事白佛。佛言。从今日听食八种粥。粥有五事利身。一者除饥。二者除渴。三者下气。四者却脐下冷。五者消宿食。婆罗门思惟。我四月安乐自娱。二月逐沙门瞿昙。以我一人废诸国事。今此供具多不可尽。且当布地令佛及僧以足蹈上。即是受用。具以所怀白佛。愿佛受用。佛告婆罗门。不可得如汝所言。此是食物。应以口受用。佛欲遣婆罗门。即为说偈

  若在天祠中　　供养火为最
  婆罗门书中　　萨鞞帝为最
  一切诸人中　　转轮王为最
  一切诸江河　　大海深为最
  于诸星宿中　　月为第一最
  一切照明中　　日光曜为最
  十方天人中　　佛福田为最

佛说偈竟。从坐起去

佛在越只国中游行。向阿那伽频头国中。有外道弟子。旧象师。名毗罗吒。大富多财谷帛充溢。田宅宝物悉皆丰足。无量福德成就。此一国人尽皆邪见。闻佛当来相率集会。至象师所向城中人。种种毁佛及僧。沙门瞿昙。难满难养多欲无厌。将千二百五十比丘千优婆塞五百乞残食人。从聚落至聚落从城至城。如霜雹蟥虫残贼人谷。所经过处破人家业。次第复欲不利我等。象师及城中人。恶心转生共作要令。沙门瞿昙来至。不听往看。佛到其国。国无精舍。城北有林。号胜叶婆。其树郁茂其地平博。世尊大众止顿其中。象师闻佛已到。其人先世供养佛。种善根近正见利根。宿因力故。能得今世无漏智。为善根力所追。便自思惟。我于此国人所宗敬。尊贵第一。若不看佛。人当谓我惜费。即告诸人。诸人先作要令。我自思惟。此要不全。诸人白言。以何事故。答言。我于此国人所宗敬。尊贵第一。若不看佛。人当谓我惜费。诸人言。今见瞿昙以何供养。答言石蜜。诸人言。沙门瞿昙。难满难养多欲无厌。若以千二百五十瓶满中石蜜尽受不让。象师大富不计重费。即将千二百五十人。负千二百五十瓶。石蜜奉佛。佛告聚落主。分与众僧。此人思惟。果如人语多受不让。即以一瓶与一比丘。诸比丘不受言。是蜜太多。我不应受。其人白佛。比丘不受。愿佛有敕。佛与钵及刀令割分之。千二百五十比丘皆得满钵。一瓶石蜜犹故未尽。白佛。佛言重与。犹故不尽。佛言。与千优婆塞及五百乞残食人。犹尚不尽。佛言重与。仍不可尽。一切皆足。瓶蜜如故。象师白佛。众已饱足。此诸瓶蜜用作何等。佛言。聚落主。我不见有人若天若魔若梵天若世间众生及沙门婆罗门食是石蜜能消助身者。除佛及僧。汝担石蜜弃着无草地无虫水中。象师言尔。即如佛教。担诸瓶蜜弃着无虫水中。是石蜜火烟出水沸声震。譬如竟日火烧热铁投着水中烟出水沸声震。象师见此二种神力。向佛意喜心信清净。知重佛德其心软伏。佛知其心随意说法。得远尘离垢。诸法眼生。见法得法知法净法度疑。不信他不随他除疑悔。住初果中得无畏。从坐起头面礼佛足白佛言。世尊。我今归依佛归依法归依僧。我是优婆塞。忆持。从今日尽形寿不杀生愿受我食后住处请。佛默然受。知佛受已。头面礼佛足绕佛三匝而去。还家摒挡大堂重阁四合舍厅舍小房舍。除去种种所有。洒扫清净悬杂色缯幡。烧众名香布种种花。敷金银颇梨绀琉璃床。各千二百五十。如是思惟。此四宝床。若不受一当受一。办千二百五十金瓶盛汤水。千二百五十使人。一比丘给一人。一切房舍地。布软[疊*毛]拘执钦婆罗杂色绫罗。处处宝瓶盛水。诸香酥灯一切办已。遣使白佛。众具已办唯圣知时。佛食后着衣。与比丘僧俱到其舍。一比丘给一人。于门外洗浴。象师自浴佛身。如一比丘浴顷。千二百五十人一时皆竟。佛及僧俱入其舍。象师以千二百五十金床奉佛。佛不受。次奉银床颇梨床绀琉璃床。尽皆不受。却四宝床更布净床。以细[疊*毛]拘执钦婆罗杂色绫绮布净床上。佛及众僧坐讫。自行澡水。奉非时浆及含消药。即于夜办具种种肴膳又办金钵银钵颇梨钵绀琉璃钵各千二百五十。如是思惟。若不受一当受一。又办金盘银盘颇梨盘绀琉璃盘各千二百五十。如是思惟。若不受一当受一。供具已办白佛。唯圣知时。佛及僧坐讫。自行澡水。以千二百五十金盘奉佛。佛不受。次奉银盘颇梨绀琉璃盘。尽皆不受。即却四宝盘。更奉木盘铜盘。佛即受之。次以千二百五十金钵奉佛。佛不受次以银钵绀琉璃钵各千二百五十奉佛。佛不受。佛告诸比丘。我先已听二种钵。若铁若瓦。八种钵不应畜。象师见佛及僧食讫。自行澡水摄钵已。持一小床在佛前坐。欲听说法。复白佛言。愿佛。受我阿那伽宾头国中尽形寿住。我为佛作千二百五十房舍千二百五十床榻被褥拘执卧具如是粳米饭。随饭羹王所食者。以供养佛及僧。佛言。聚落主。汝心信净于我已足。如汝等诸善男子。应度者众。不得独受汝请。是时佛说偈言

  若在天祠中　　供养火为最
  婆罗门书中　　萨鞞帝为最
  一切诸人中　　转轮王为最
  一切诸江河　　大海深为最
  于诸星宿中　　月为第一最
  一切照明中　　日光曜为最
  十方天人中　　佛福田为最

佛说偈竟从坐起去

佛在阿那伽宾头国中夏住已。持衣钵向毗耶离城。时诸利昌辈。闻佛越只游行欲来是毗耶离城。众人为佛及僧故具种种肴膳。佛到不久非时云起。诸饮食在露地天雨。诸利昌语阿难。我诸利昌。为佛及僧设种种饭食在露地天雨我当云何。时阿难与诸利昌俱诣佛所。头面礼足一面立。阿难白佛。是诸利昌。为佛及僧故。具种种饭食在露地天雨。诸利昌不知当云何。佛告阿难。于一房舍应作净地羯磨。云何应作。僧一心和合。一比丘唱。大德僧听。某甲房舍作净地。若僧时到僧忍听。僧某甲房作净地。如是白。白二羯磨。僧某甲房舍作净地竟。僧忍默然故。是事如是持。房中作净地竟。着饮食具舍内。煮饭作羹作饼煮肉。诸外道妒嫉讥嫌言。是秃居士舍内作饭食。诸居士内有库藏食箪食厨。诸沙门释子自言善好有德。而舍内亦有库藏食厨。与白衣何异。诸比丘少欲知足行头陀。闻是事心惭愧。以是事白佛。佛以是因缘集僧。集僧已告诸比丘。从今日僧坊外作食。僧坊外作食烟火起。露地多人见来索饭食。比丘各各分与使僧食少。以是事白佛。佛言。从今日不听作净地羯磨。若作犯突吉罗罪。先作者应舍。佛在毗耶离城中。有一大将。字师子。大富多钱谷帛田宅宝物丰足。种种福德成就。其人本是外道弟子。于佛法中始得信心。以好肥肉时时施僧。外道以嫉妒心讥嫌诃责。沙门释子正应尔耳。人故为杀而啖。何以故。师子杀肥众生。以肉时时施僧。诸比丘少欲知足行头陀。闻是事心惭愧。以是事白佛。佛以是因缘集僧。集僧已告诸比丘。三种不净肉不应啖。何等三。若见若闻若疑。云何见。自见是生为我夺命。如是见。云何闻。可信人边。闻是生故为汝杀。如是闻。云何疑有因缘故生疑。是处无屠儿无自死。是主人恶。能故为我夺命。如是疑。是三种不净肉不应啖。三种净肉听啖。何等三。若眼不见耳不闻心不疑。云何不见。自眼不见是生故为我夺命。如是不见。云何不闻可信优婆塞人边。不闻是生故为我夺命。如是不闻。云何不疑。心中无有缘生疑。是中有屠儿家有自死者。是主人善。不故为我夺命。如是不疑。是三种净肉听啖。复次有诸天祀象走所极。马走所极。乌飞所极。闪摩婆罗萨祀。尼罗伽罗祀。天祠中非天祠中。分陀利华。以彼中祀天祠肉不净。沙门释子不应啖。何以故。是诸天祠为客作故

佛故在毗耶离国。是时饥饿乞食难得。有一居士。请佛及僧明日食。佛默然受。知佛受已。从坐起头面礼佛足而归。具种种多美饮食。时国吉日。清晨众僧大得猪肉干饭。诸比丘受思惟欲啖。居士供具已办敷床座。遣人白佛时到。是时僧入其舍。佛自房住迎食分。僧坐讫。自行澡水下食。食已澡漱摄钵。持一小床坐僧前欲听说法。上座说法已次第而出。诸比丘食讫不受残食法。小食先受在精舍内。不知云何。以是事白佛。佛言。从今日听如是饥饿时。比丘若食竟小食先受。不受残食法听啖。何等受小食。诸比丘早起受而不食是也。佛故在毗耶离。是时饥饿乞食难得。有一居士。请佛及僧明日食。佛默然受。知佛受已。从坐起头面礼佛足还家。具种种肴膳办已敷床褥。遣人白佛时到。尔时僧入其舍。佛自房住迎食分。居士白众僧。大德是施早办。僧等饱食。残可持去须臾更食。诸比丘食饱。如居士言持残食去。诸比丘食竟不受残食法。所持残食不知当云何。是事白佛。佛言。从今日听饥饿时食竟持残食去。若不受残食法而食。何等是持食去。诸比丘食竟持残食去。是名持食去食。有仙人字鸡泥耶。取木果奉佛。佛言。鸡泥耶。与僧作分。彼即与诸比丘。诸比丘言。我曹食竟不受残食法。诸比丘不知云何。是事白佛。佛言。从今日饥馑时。诸比丘若食竟不受残食法听食。木果若胡桃栗枇杷。更有如是种种木果。是一切听食。长老舍利弗热血病。药师语言。应食池物。舍利弗言。佛未听我食池物。白佛。佛言。从今日听食池物。长老大目犍连。至漫陀耆尼池中取藕。大如人髀极美。如淳净白蜜。其汁如乳。以授舍利弗。舍利弗问。何处得来。目连言。至漫陀耆尼池中得来。舍利弗言。是池非人处。何谁授汝。目连言。非人授我。舍利弗言。佛未听我非人授食啖。白佛。佛言。诸比丘从今日非人授听食。是池物多得来。食残与诸比丘。诸比丘不受。诸比丘言。我食竟不受残食法。诸比丘不知云何。白佛。佛言。从今日饥饿时听。诸比丘食竟。不受残食法听敢池物。何等池物。若莲根莲子菱芡鸡头子。如是种种池物听食

佛故在毗耶离。先饥饿时怜愍诸比丘。听小食受已后食。食已持出木果池物。诸比丘丰时乞食易得。如本饥饿时净食戒比丘违。是时诸比丘少欲知足行头陀诃责。何以名比丘。佛饥饿时怜愍诸比丘。听小食时受已后食。食已持出木果池物。诸比丘丰时乞食易得。如本饥饿时净食戒比丘违。是时诸比丘种种因缘诃已。以是事白佛。佛以是因缘集僧。集僧已佛知故问。问诸比丘。汝实作是事不。诸比丘言。实作世尊。佛种种因缘诃诸比丘。云何名比丘。佛饥饿时怜愍诸比丘。听小食受已后食。食已持出木果池物。诸比丘丰时乞食易得。如本饥饿时净食戒比丘违。是时佛种种因缘诃已告诸比丘。从今日如本饥饿时。为怜愍诸比丘。听小食受已后食。食已持出木果池物。如饥饿时净不应食。若食犯波逸提

佛在毗耶离。随所住竟着衣持钵。向修摩国游行。此国有二城。一名婆提城。二名蜜城。婆提城中有六大福德人。何等六。一居士名民大。二民大妇。三民大儿。四民大儿妇。五民大奴。六民大婢。何等民大居士。大福德民大。持少金银琉璃珠宝。坐市肆中。若诸宗族五亲知识朋友。一切阎浮提人。为金银琉璃珠宝来者。是居士不起坐处。能令求者自恣所须宝物如故不尽。是为民大居士大福德。民大居士妇。有何等福德。若民大居士妇。食时若一切阎浮提人来。为饮食故。一切诸人自恣饱满。食故不尽。是民大居士妇大福德。民大居士儿。有何等大福德。其儿入仓库。宝藏中看上向。观见有孔譬如车毂。钱财宝物从上流下。宝藏即满。是民大居士儿大福德。民大居士儿妇。有何等大福德。其儿妇持华香璎珞诸杂涂香好衣上服。至中庭床上坐。欲奉舅姑及夫。坐处未起若一切阎浮提人来。为华香璎珞诸杂涂香好衣上服来者。一切自恣给与如故不尽。是民大儿妇大福德。民大居士奴。有何等大福德。民大居士奴。若持犁一出耕时七垄成就。是为民大居士奴大福德。民大居士婢。有何等大福德。民大居士婢。一切谷麦舂磨还输仓。一切阎浮提人为米面故来者。一切自恣给与米面。如故不尽。是为民大居士婢大福德。是时民大居士憍慢心生。一切阎浮提福德无人胜我。是民大居士及婆提城中人。皆是外道弟子。是诸外道闻。沙门瞿昙。苏摩国土游行来向婆提城。是外道辈。相率集会入城。至民大居士前。毁佛及僧。是人难满难养多欲无厌。是沙门瞿昙。与千二百五十比丘俱。千优婆塞五百乞残食人从一聚落至一聚落。从城至城。譬如霜雹蝗虫贼残害人民谷麦。其所至处破人家业。今来复欲残毁我辈。时民大居士即生恶心。共作要令。不听一人往见瞿昙。若往见者。输城中人五百金钱。是时民大居士问诸人言。是沙门瞿昙。人不欲与不。强索不。诸人言不强索。又问王敕与不。答言不。又问。不与是人作伤害不。诸人言不是居士言云何与。答曰。自信自欲自爱自心清净故与是居士言。若沙门瞿昙。人不欲与不强夺。不王敕与若不与不作伤害法应与是人。福德力故。令尔许众人得乐。如是人福德必胜我。是时民大居士。未见佛便憍慢心除。佛从是诸国游行到婆提城。无有精舍。城北有林。号曰胜叶。其树郁茂其地平博。世尊大众于中止顿。民大居士闻佛已到。其人先世供养佛及僧。种善根近正见。宿因力故。能得今世无漏智。为善根力所追。便自思惟。我于此国人所宗敬。富乐第一。若我不看佛者。人当谓我悭贪惜费。即告诸人。诸人先作要令。我自思惟。此要不全。我宁输五百金钱。诸人言以何事故。答言。我于此国富乐第一。若不看佛。人当谓我悭贪惜费。诸人宗重民大居士。有负其债者。有蒙供给者。虽欲输钱无敢取者。诸人言。何须破要皆当共去。一切俱行。到已头面礼佛足一面坐。佛为居士随意说法。得远尘离垢。诸法眼生。见法得法知法信净。度疑不信他。不随他除疑悔。住初果中得无所畏。从坐起头面礼佛足言。大德。我归依佛归依法归依僧。证知。我是佛弟子。从今日尽形寿归依三宝。居士即遣使唤五福德人。语言。佛大师在此。宜速时来。使到具告情事。此五人亦先世供养佛。种善根近正见利根。宿因力故。能得今世无漏智慧。善根力所追。即到佛所头面礼佛足一面坐。佛为五人随意说法。亦得远尘离垢诸法眼生。见法得法知法信净。度疑不信他。不随他除疑悔。住初果中得无所畏。从坐起头面礼佛足言。我归依佛归依法归依僧。证知。我是佛弟子。从今日尽形寿归依三宝。民大居士从坐起叉手合掌白佛言。世尊。愿佛及僧受我舍宿。佛默然许之。既蒙许可。即礼佛足还家摒挡房舍除去所有洒扫清净。悬缯幡盖杂色绫罗。烧众名香布种种花办金床银床颇梨床绀琉璃床各千二百五十。如是思惟。此四宝床。若不受一当受一。又办千二百五十金瓶盛汤水。千二百五十使人。一比丘给一人。一切办已遣使白佛。唯圣知时。佛晡时着衣持钵。与大众俱向居士舍。千二百五十沙门。居士给千二百五十使人。一比丘给一人在门外洗浴。居士自洗浴佛。一时浴讫而入其舍。居士以千二百五十金床奉佛。佛不受。次以银床颇梨绀琉璃床各千二百五十奉佛。佛尽不受。居士更布净床。以细[疊*毛]拘执钦婆罗杂色绫罗。布净床上。大众坐讫。自行澡水。奉进非时浆及含消药。即起办具种种肴膳饮食。又办金钵银钵颇梨钵绀琉璃钵各千二百五十。如是思惟。若不受一当受一。又复办金盘银盘颇梨盘绀琉璃盘各千二百五十。如是思惟。若不受一当受一。办讫白佛。时到佛及僧坐定。自行澡水。奉佛千二百五十金盘佛不受。次奉银盘颇梨盘绀琉璃盘。各千二百五十。佛尽不受。更奉木盘铜盘。即为受之。复以千二百五十金钵奉佛。佛不受。次奉银绀琉璃颇梨钵各千二百五十奉佛。佛不受。告诸比丘。我先听两种钵铁瓦。八种钵不应畜。居士供施已讫。自行澡水。食毕摄钵。持一小床在佛前坐。欲听佛说法。复白佛言。愿受我是修摩国中尽形寿供养。我当为佛作千二百五十房舍。千二百五十床榻被褥拘执。以好粳米王所食者。供养世尊及比丘僧。佛告聚落主。汝心净信于我已足。诸有如是善男子。依信法中住。我怜愍应度。不得长受汝请。佛为居士说偈咒愿

  若在天祠中　　供养火为最
  婆罗门书中　　萨鞞帝为最
  一切诸人中　　帝王尊为最
  一切江河中　　大海深为最
  于诸星宿中　　明月第一最
  一切照明中　　日光曜为最
  十方天人中　　佛福田为最

佛咒愿已从坐起去。敕诸弟子次第而出。从婆提城持衣钵。向频阇山游行。民大居士为佛故。遣五百人。以五百乳牛。五百乘车载粳米。及随饭羹王所食者。语使人言。若佛在无聚落空处宿时。汝[穀-禾+牛]五百乳牛。作粳米苏乳糜。和以黑白石蜜上佛。五百人受民大居士语。佛在无聚落处宿。五百人即[穀-禾+牛]乳作糜上佛。佛言。与僧作分。即与僧。僧不受。如是思惟。是食具以我曹故送来。已举宿不净。以是事白佛。佛言。比丘有二种请。一者即日食。二者冷食。若即日得二请。应自受一请一请与人。若得冷请。随所施随受。有净随受。有不净随受。净随受者。谓五种佉陀尼五种蒲阇尼食五似食。不净随受者。谓五宝五似宝。彼净随受受已作净。不净随受者。言此不净得净当受。佛渐渐游行到频阇山。彼频阇山中有一夜叉鬼。字优耽摩。旧在彼山中住。此鬼信佛言心净。思惟。我当何物上佛。此中唯有葡萄。即取上佛。佛言。与僧作分。彼即与比丘。比丘不受言。佛未听我曹啖葡萄。以是事白佛。佛言。从今日听啖葡萄。时大有葡萄食饱多残。诸比丘不知当云何。白佛。佛言。压汁饮。若葡萄不作净。若汁中不以水作净。不应饮。若葡萄作净。汁中不作净。若汁作净。葡萄不作净。不应饮。葡萄净汁亦净应饮。尔时佛游行集人转多。有千二百五十比丘。有千优婆塞五百乞残食人五百作人五百乳牛五百乘车。佛欲散此众即入定。譬如士夫屈伸臂顷。从频阇山没至漫陀耆尼池岸上现。岸上有结发仙人。字鸡尼耶。先在此住。见佛不起。又不问讯。亦不让坐。佛亦不与仙人语言问讯。佛即于漫陀耆尼池中洗足已。即于岸上在一树下。布尼师檀结跏趺坐。尔时微雨洒地。轻风来扫。风吹种种华。弥漫布地。鸡尼耶思惟。微雨洒地轻风吹杂华布地。皆是我力。非是沙门瞿昙力也。是夜多过。尔时四大天王。与无数百千眷属俱欲来向佛。时有四青衣鬼神。来向仙人在四边住。仙人开眼见之问。汝何人。诸鬼神言。我青衣鬼神。言何以来。言相守护。问言何以守护。鬼神言。今夜多过。四大天王当与无数百千万眷属来至佛所。此中傥有鬼神来相触扰。仙人言。不守护沙门瞿昙耶。答言不。仙人思惟。此微雨轻风杂华布地。乃是沙门瞿昙力。非我力也。即时四大天王。与无数百千眷属后夜来。见佛头面礼佛足一面立。佛以圣语说四谛法苦集尽道。二天王解得道。二天王不解。佛更为二天王。以驮婆罗语说法。吚宁(苦谛)弥宁(习谛)多咃陀譬(尽谛)陀罗辟支(道谛)佛阇陀(知也)萨婆休(一切)蠰舍摩遮(灭求)萨婆多罗(一切离)毗楼利多咃欲(远离)萨婆休(一切)鞞罗地(不作)波跋(恶也)头吃想妒(苦边尽也)涅楼遮谛(如是说也)是二天王一解一不解。佛复作弥梨车语。摩舍兜舍那舍婆萨婆多罗毗比谛伊数安兜头却婆阿地婆地。四天王尽解。示教利喜已。礼佛足而去。佛于漫陀耆尼池岸上。持衣钵游行向阿摩那国。是结发仙人旧住。此国深敬信佛。而作是念。当以何物奉上于佛。复作是念。如古昔仙人所受水净八种浆。当以奉佛。即办此众多浆。持来上佛。佛告鸡尼耶。与僧作分。即与比丘。比丘言。佛未听我饮八种浆。以是事白佛。佛言。从今日听饮八种浆。何等八。一周梨浆。二茂梨浆三拘楼浆。四舍楼浆。五说波多浆。六颇留沙浆。七梨浆。八蒲萄浆。以水作净应饮。佛从阿摩那国。随所住竟持衣钵。向阿头佉国游行。此国中有父子比丘。本作剃毛须发师。其父摩呵罗。闻佛从阿摩那国游行到阿头佉国。此中无檀越供给僧亦无供养。谁当供养佛。便语儿言。我闻佛从阿摩那国土游行欲来至此。此中无檀越供给僧亦无供养。汝可持钵入城求胡麻粳米小豆磨沙豆供养世尊。其子巧能其事。即持钵入城。大得胡麻粳米小豆摩沙豆。世尊既到。父子选择房舍。布好坐具。即办种种粥胡麻油粥乳粥二种豆粥清粥。办已奉佛及僧。诸粥太多。余残弃一房舍内地。佛食后经行。摩诃罗从佛仿佯。到是处见地粥狼藉。佛知故问摩呵罗。何许得是多粥。有檀越与耶。答言无。佛言。是众僧物耶。答言非。佛言何处得。摩诃罗以是事具白佛。佛以是因缘故集僧。集僧已。佛种种因缘诃摩诃罗。何以名比丘。教子作不净事。佛种种因缘诃已告诸比丘。从今日五众不得相教作不净事。若教得突吉罗罗。从今日前工师时种种作具不应畜。若畜得罪。若先缝衣人畜针筒不犯。先能书人畜笔筒不犯。先铜作人畜钻不犯。佛从阿头佉国持衣钵。向波婆国游行。此国中诸豪族先作要。佛来入国。一切应一由延迎佛。若不迎者。罚五百金钱。既闻佛来出迎。中有一豪族。字卢芝。第一力士。是阿难旧知识。其人于佛无信。阿难遥见其来。语言卢芝。汝来迎佛甚善。卢芝言。我非信佛而迎。我顺亲族法故。阿难言。有何法。答言。我亲族先作要法。若佛来者。应一切一由。延迎若不迎者。罚金钱五百。阿难。我不惜五百金钱。恐亲族不穆。以是故来。阿难执手牵至佛所。到已头面礼佛足一面立。阿难白佛言。是卢芝我旧知识。特相亲善于佛不信。愿佛说法令其开解。尔时世尊。以慈心感覆彼即信悟。寻为说法示教利喜。示教利喜已礼佛而出。还坐本处诸人去不久。时佛从坐起向自房。卢芝从佛如犊随母。佛入房坐。卢芝礼佛足一面坐。佛为说法示教利喜。即从坐起礼佛而去。思惟。我持何等物上佛。即以诸饼奉佛。佛言。与僧作分。彼即与比丘。比丘不受。语言。佛未听我啖饼。以是事白佛。佛言。从今日。听啖饼。何等饼。若面若大小麦饼若豆饼刻镂饼重华饼。有如是种种净饼。一切听啖。佛从波婆国随所住竟。持衣钵游行到舍卫国。诸比丘乞食。得甘美肴膳乳酪酥油鱼肉脯。诸比丘不受。思惟。乞美饮食或堕罪。以是事白佛。佛言。若不自乞檀越施应受。从今日听僧服四种药。何等四种药。一时药。二时分药。三七日药。四尽形药。时药者。五种佉陀尼五种蒲阇尼五似食。何等五种佉陀尼。一根食。二茎食。三叶食。四磨食。五果食。何等根食。芋根蔙根藕根芦卜根芜菁根。如是等种种根可食。何等茎食。芦卜茎谷梨茎罗勒茎柯蓝茎。如是等种种是茎佉陀尼。何等叶食。芦卜谷梨叶罗勒叶柯蓝叶。如是等种种叶可食。是叶佉陀尼。何等磨食。稻大麦小麦。如是等种种。是磨佉陀尼食。何等果食。庵罗果阎浮果波罗萨果镇头佉果那梨耆罗果。如是等种种。是果佉陀尼。何等五种蒲阇尼食。一饭二糗三糒四鱼五肉。如是五种蒲阇尼食。何等五种似食。糜粟穬麦莠子迦师如是等种种。是名似食。未漉浆汁。是名时药。时分药者。若净漉浆汁。是名时分药。七日药者。若酥油蜜石蜜。是名七日药。尽形药者。五种根药。何等五种。一舍利。二姜。三附子。四波提毗沙。五菖蒲根。是药尽形寿共房宿无罪。五种果药。呵梨勒。鞞醯勒。阿摩勒。胡椒。荜芺罗。尽形寿共房宿。有五种盐。黑盐紫盐赤盐卤土盐白盐。尽形寿共房舍宿。有五种树胶药。兴渠萨阇罗茶帝夜帝夜波罗帝夜槃那。尽形寿共房宿。五种汤。根汤茎汤叶汤华汤果汤。尽形寿共房宿。是四种药。时药时分药七日药尽形药。若即日受时药时分药七日药尽形药。若和合一处。此药时应服。非时不应服。时药力故。若即日受时分药七日药尽形药。是药和合一处。是药应时分服。过时分不应服。时分药力故。若即日受七日药尽形药。是药和合一处。七日应服。过七日不应服。七日药力故。尽形药随意服。若即日受时药不净。受时分药七日药尽形药。和合一处不应服。即日受时分药不净。受七日药尽形药。和合一处不应服。即日受七日药不净。受尽形药。和合一处。不应服。长老优波离问佛。是三种药。时分药七日药尽形药。是三种药。举宿得口受不。佛言。不得。是三种药。恶捉得口受不。佛言。不得。是三种药。手受口受。不病得服不。佛言。不得。是三种药。手受口受。病得服不。佛言得(七法中医药法第六竟)

十诵律卷第二十六十诵律卷第二十七(第四诵之七)

        后秦北印度三藏弗若多罗译

    七法中衣法第七之上

佛在王舍城。五比丘白佛。应着何等衣。佛言。应着槃薮衣

佛在王舍城。佛身冷湿须服下药。佛告阿难。我身冷湿。是事汝自知。阿难受教。往耆婆药师所。语耆婆言。佛身冷湿须服下药。是事汝自知。耆婆言。长老还去我随后往。耆婆思惟。佛德尊重。不宜进木药苦药如余人法。当取青莲华以下药草熏之持用上佛。即取青莲华以下药熏作已。持诣佛所头面礼足白佛言。是优钵罗华熏以下药。可以治身。愿佛受之。此药一嗅十下。二嗅二十下。三嗅三十下。佛受已默然。耆婆欲还。具教阿难侍病节度而去。佛一嗅其药十下。二嗅二十下。三嗅二十九下。耆婆明识时数复来。瞻佛问讯。世尊。不审下不。佛言。向嗅汝药二十九下。耆婆知佛身病未尽。白佛言。须饮少暖水。饮已更一下。如是随顺满三十下。耆婆还家办随病药饮食软饭粥羹。尝伽罗药奉进所须。起居轻利无复患苦。佛得瞻力。还复本色。耆婆持深摩根衣价直百千欲奉上佛。头面礼足一面立白佛言。我治王大臣皆与我愿。今日治佛。愿世尊赐我一愿。佛告耆婆。多陀阿伽度阿罗诃三藐三佛陀已过诸愿。白佛言。可得愿与我。佛告耆婆。汝索何等愿。耆婆言。大德。是深摩根衣价直百千。愿佛受着。怜愍故。佛默然受。知佛默然受。即以深摩根衣价直百千上佛。头面礼佛足而去。佛以是事集僧。集僧已告诸比丘。今日耆婆与我价直百千深摩根衣。从今日听若有施比丘如是衣者得随意取着。从今日若比丘欲着槃薮衣听着。若欲着居士施衣亦听着

佛在王舍城。是时洴沙王。乘象舆清旦出王舍城欲见佛。王信佛恭敬。时有外道梵志。从道而来。王遥见谓是沙门。便敕御者住象欲下礼拜。大臣问王。欲作何等。王言欲礼来比丘。大臣言大王。是非佛弟子。外道梵志耳。王羞愧。王问御者。今往见佛。去此几许可乘何处可下。御者具答。到已头面礼佛足一面坐白佛言。世尊。愿令僧衣与外道衣异。使可分别。佛告大王。何以故。欲令衣异。王以是事具白佛。佛为王说法示教利喜。礼佛而去。时阿难侍佛后执扇扇佛。佛顾语阿难。我欲南山国土游行。阿难受敕寻从。既到南山国土。时至乞食。食讫到一树下敷尼师檀结跏趺坐。是时近山有好稻田畦畔齐整。佛告阿难。汝见彼稻田畦畔齐整不。答言见。佛告阿难。此深摩根衣能法此田作衣不。阿难言能。即以衣与阿难。阿难受已小却。即割截簪缝中脊衣叶两向收襞展张还奉佛。佛赞善哉善哉。此衣割截如是作应法。佛从南山国土持衣钵向王舍城。到已以是因缘集僧。集僧已告诸比丘。从今日听着割截衣。不着割截衣不得入聚落。若入得突吉罗罪。佛听诸比丘着居士施衣。诸居士婆罗门有信施者。多施僧衣钦婆罗拘执杂色[疊*毛]。诸比丘畜多衣。佛知诸比丘畜多衣。多衣妨行道欲作齐限。告阿难言。吾欲向维耶离国游行。阿难受敕寻从。既到会值冬节。八夜寒风破竹。佛时着一割截衣。初夜空地经行。初夜过中夜来。佛身寒告阿难。持第二割截衣来。阿难即取衣授佛。佛取衣着。中夜空地经行。中夜过后夜来。佛身寒告阿难。持第三割截衣来。阿难即授衣。佛取衣着空地经行。佛思惟。诸比丘尔所衣足。是夜过已。佛以是因缘集僧。集僧已告诸比丘。从今听三衣。不应少不应多。苦少畜得突吉罗罪。若多畜得尼萨耆波逸提罪。有一比丘有粪扫衣。比丘闻佛结戒。不应着不割截衣入聚落。思惟。我有粪扫衣破裂。我当补帖作钩叶栏施缘。即持针缕近祇林门间补帖粪扫衣。用当割截衣。佛将侍者阿难食后经行。至彼处见之。佛知故问汝欲作何等。答言。世尊与我等结戒。不应着不割截衣入聚落。我有粪扫衣破裂。欲补帖施缘当割截衣。佛言。比丘善哉。粪扫衣补帖。应用当割截衣。从今听畜粪扫衣四种。何等四种。一冢间衣。二出来衣。三无主衣。四土衣。何等冢间衣。有衣裹死人弃冢间。是为冢间衣。何等出来衣。裹死人衣。持来施比丘。是为出来衣。何等无主衣。若聚落中若空地衣不属他。若男子若女人若黄门若二根。是为无主衣。何等为土衣。有巷陌中若冢间。若粪扫中有弃弊物。是为土衣。若比丘得冢间新衣。应两重作僧伽梨。一重郁多罗僧。一重安陀会。二重尼师檀。复次欲作三重僧伽梨三重尼师檀。若比丘得冢间故衣。应四重作僧伽梨。二重郁多罗僧。二重安陀会。四重作尼师檀。出来衣无主衣亦如是。土衣听随意作重

佛在舍卫国。有摩伽罗母。名毗舍佉。诣佛所头面礼足却坐一面。佛以种种因缘说法示教利喜已默然。知佛说法示教利喜默然已。从坐起偏袒着衣合掌白佛言。世尊。愿佛及僧受我明日请。佛默然受。知佛默然受已。头面礼佛足右绕而去。还舍通夜办种种多美饮食。佛是初夜共阿难露地经行。佛看星宿相语阿难言。若今有人问知宿星相者。何时当雨。彼必言七岁当雨。佛语阿难。初夜过已中夜至。是星相灭更有异星相出。若尔时有人问知相者。何时当雨。彼必言过七月当雨。又语阿难。中夜过已至后夜。是星相灭更有异星相出。若尔时问知相者。何时当雨。彼必言七日当雨。是夜过地了时东方有云出。形如圆碗遍满空中。是云能作大雨满诸坑坎。尔时佛告阿难。语诸比丘。是碗云雨有功德。能除病。若诸比丘欲洗浴者露地立洗。阿难受教语诸比丘。是碗云雨有功德能除病。诸比丘欲洗浴者露地立洗。时诸比丘随意露地立洗浴。尔时毗舍佉鹿子母。办饮食已早起敷坐处。遣婢白佛时到。食具已办佛自知时。婢即受教。往诣祇林请诸比丘。于门孔中看。见裸形露洗。见已心不喜。作是念。是中都无比丘。尽是裸形外道无惭愧人。作是念已。即还语大家言。只陀林中无一比丘。尽是裸形外道。是毗舍佉母智慧利根。知今日雨堕诸比丘必当露地裸形洗浴。是婢痴无所知故。作是言。祇林中无一比丘。尽是裸形外道。即更唤余婢。往诣祇林打门作声。白言时到食具已办。即受教去。往诣祇林打门作声。时到食具已办。佛自知时。尔时佛与大众着衣持钵。众僧围绕俱诣其舍。佛在僧中坐。毗舍佉母自行澡水。自手与多美饮食。食讫行水知摄钵已。持小床坐佛前。欲听说法。白佛言。世尊。请与我愿。佛言。诸多陀阿伽度阿罗诃三藐三佛陀已过诸愿。毗舍佉言。与我可得愿。佛言。与汝可得愿。欲得何愿。毗舍佉言。欲与比丘僧雨浴衣。与比丘尼僧水浴衣。客比丘来我与食。远行比丘我与食。病比丘我与食。看病比丘我与食。我常与比丘僧粥。多知识少知识比丘。我与病缘汤药及所须物。佛言。汝见何因缘故。欲与比丘僧雨浴衣。答言大德。我今日早起敷座已。遣使诣祇林白佛时到。门间见诸比丘露地雨中裸形洗浴。婢还言。祇林中无一比丘但诸外道。大德。比丘裸形在佛前和尚阿阇梨一切上座前。则为无羞。是故与比丘僧雨浴衣。自在露地雨中洗浴。毗舍佉。汝见何因缘故。欲与比丘尼僧水浴衣。答言大德。我一时与诸居士妇。共至阿耆罗河中洗浴。时诸比丘尼亦入河中裸形洗浴。诸居士妇见心不喜。诃责言。是辈薄福德。不吉粗身大腹垂乳。何用作比丘尼。大德。女人裸形丑恶。是故我欲与尼僧水浴衣。毗舍佉。汝见何因缘故。欲与客来比丘饮食。答言大德。客来比丘不知何处可去不可去。道路疲极未得休息。是故我欲与饮食。后随知可去不可去处。毗舍佉。汝见何因缘故。欲与远行比丘食。答言大德。远行比丘若待僧食时。若行乞食则伴舍去。或夜中入险道或独行旷野。我与食故。不失伴不入险道。是故我与饮食。毗舍佉。汝见何因缘故。欲与诸病比丘饮食。答言大德。病比丘不得随病饮食。则病难差。是故我与随病饮食。则病易差。毗舍佉。汝见何因缘故。欲与看病比丘饮食。答言大德。看病比丘。若待僧中食后食。若行乞食去。是病比丘瞻养事阙。若煮饭作粥作羹煮肉煮药汤。出入大小便器若弃唾器。以是故。我与看病比丘饮食。瞻养不阙。便得煮饭作粥作羹煮肉及煮药。出入大小便器弃唾器。毗舍佉。汝见何因缘故。欲常与比丘僧粥。答言大德。若比丘不食粥。有饥渴恼或时腹内风起。我常与粥故。则无众恼。毗舍佉。汝见何因缘故。欲与多知识少知识比丘病缘汤药及所须物。答言大德。病比丘必欲得汤药所须诸物。以是故我与。复次大德。我若闻某比丘彼住处死。佛记彼比丘三结断得须陀洹。不堕恶道必得涅槃。极至七生天上人中往返得尽众苦。大德。我当问。是长老曾来舍卫国不。若闻是比丘曾来舍卫国。我思惟。是长老或受我雨浴衣。或受客比丘饮食。或远行比丘饮食。或随病饮食。或看病饮食。或常与粥。或病比丘汤药诸物。大德。我以是因缘故觉意满。大德。我若闻某比丘彼住处死。佛记彼比丘三结尽三毒薄。得斯陀含一来生。是世得尽苦际。我当问。是长老曾来舍卫国不。若我闻是比丘曾来舍卫国。大德。我如是思惟。是长老或受我雨浴衣。或受客比丘饮食。或受远行饮食。或随病饮食。或看病饮食。或常与粥。或病比丘汤药诸物。大德。我以是因缘故觉意满。大德。我若闻某比丘彼住处死。佛记彼比丘得阿那含五下结尽。便于天上般涅槃不还是间。大德。我当问。是长老曾来舍卫国不。若我闻是比丘曾来。我思惟。是长老或受我雨浴衣。或客比丘饮食。或远行饮食。随病饮食。或看病饮食。或常与粥。或病比丘汤药诸物。大德。我以是因缘故觉意满。大德。我若闻某比丘彼住处死。佛记彼比丘得阿罗汉。是生已尽梵行已立。所作已办自知作证。我当问。是长老曾来舍卫国不。若闻是比丘曾来。我思惟。是长老或受我雨浴衣。或受客比丘饮食远行饮食。随病饮食看病饮食。或常与粥病比丘汤药诸物。我以是因缘故觉意满。大德。如是我财福德成就。以是因缘摄法福德。佛言。善哉善哉毗舍佉。我听汝是诸愿。听汝与比丘僧雨浴衣。比丘尼僧水浴衣。客比丘饮食。远行比丘饮食。随病比丘饮食。看病比丘饮食。比丘僧常与粥。多知识少知识比丘与病缘汤药诸物。毗舍佉。是财福德成就。以是因缘摄法福德。佛为毗舍佉说种种法示教利喜已从坐起去。佛以是事集僧。集僧已告诸比丘。从今日听诸比丘畜雨浴衣随意露地浴。是诸比丘知佛听畜雨浴衣。便广长大作畜。是中有比丘。少欲知足行头陀闻是事种种因缘诃责。云何名比丘。佛听畜雨浴衣。便广长大作畜。种种因缘诃已向佛广说。佛以是事集僧。集僧已。知而故问诸比丘。汝实作是事不。答言。实作世尊。佛种种因缘诃责。云何名比丘。知我听畜雨浴衣。便广长大作畜。诃已告诸比丘。从今日欲作雨浴衣。应量作。是中量者。长佛六搩手广二搩手半。若过量作。犯波逸提罪

佛在毗耶离国。土地卤湿。诸比丘病痈疮。有一比丘疮中脓血流出。污安陀会如水渍。佛遥见之。知而故问是比丘。汝身何以脓血流出污安陀会如水渍。比丘答言。世尊。我痈疮中脓血流出污安陀会。佛以是事集僧。集僧已告诸比丘。从今日听诸病痈疮比丘着覆疮衣。乃至疮差后十日。若过犯波逸提罪。诸比丘知佛听畜覆疮衣。便广长大作畜。有诸比丘。少欲知足行头陀。闻是事心不喜。诃责言。云何名比丘。知佛听畜覆疮衣。便广长大作畜。诸比丘种种因缘诃已具白佛。佛以是事集僧。集僧已。佛知故问诸比丘。汝实作是事不。答言。实尔世尊。佛种种因缘诃。云何名比丘。知佛听畜覆疮衣。便广长大作畜。佛种种因缘诃已告诸比丘。从今日欲作覆疮衣。先应量作。是中量长四搩手广二搩手。若过作犯波逸提罪

佛在毗离耶国。诸比丘不净污卧具浣。早起近精舍门间悬晒。食时佛着衣持钵入城乞食。见不净污卧具浣早起精舍门间悬晒。食后佛以是事集僧。集僧已告诸比丘。我今日食时着衣持钵入城乞食。见诸比丘不净污卧具晨朝浣精舍门间悬晒。汝等诸比丘。此事不是不应尔。众僧卧具多用不筹量。诸婆罗门居士。身心疲苦血肉枯竭布施作福。是中应筹量少用。乱念比丘不一心。睡眠时有五过失。何等五。一者难睡苦。二者难觉苦。三者见恶梦。四者睡眠时善神不护。五者觉时心难入诸善觉观法。不乱念比丘一心睡眠有五善事。何等五。一者无难睡苦。二者睡易觉。三者睡无恶梦。四者睡时善神来护。五者睡觉心易入善觉观法。比丘有淫怒痴未离欲。不乱念一心眠。尚不失精。何况离欲人。佛种种因缘诃已告诸比丘。从今日听畜尼师檀。覆护僧卧具故。不应不敷尼师檀僧卧具上卧。诸比丘知佛听畜尼师檀。便广长大作畜。有诸比丘。少欲知足行头陀。闻是事心不喜。诃责言。云何名比丘。知佛听畜尼师檀。便广长大作畜。种种因缘诃已具白佛。佛以是因缘集僧。集僧已。佛知故问诸比丘。汝实作是事不。答言。实作世尊。佛种种因缘诃诸比丘。何以名比丘。知佛听畜尼师檀。便广长大作畜。诃已告诸比丘。从今日作尼师檀应量作。是量长二搩手广一搩手半。若过作。犯波逸提罪

佛在舍卫国。食时着衣持钵入城乞食。食已还向安陀林中。在一树下敷尼师檀结跏趺坐。长老迦留陀夷亦复入安陀林。去佛不远在一树下敷尼师檀坐。是长老身大。两膝到地两手捉衣。愿言。佛何时当听我缕边一搩手作尼师檀。我愿满足。佛晡时从禅起。以是因缘集僧。集僧已告诸比丘。我今日食时着衣持钵入城乞食。食已还入安陀林中。一树下敷尼师檀坐。迦留陀夷乞食。还亦坐树下。作是思惟。佛今日何处行道。我亦彼间行道。我入安陀林中。一树下布尼师檀坐。迦留陀夷亦尔。是善男子身大。两膝到地两手捉衣。作是愿言。佛何时当听我缕边一搩手作尼师檀。如是满足。佛告诸比丘。从今日听尼师檀缕边一搩手作。是戒应如是说。若比丘欲作尼师檀。应量作。是量长二搩手。广一搩手半。益缕边一搩手。若过作。得波逸提罪

佛在迦毗罗婆国。长老难陀。是佛弟姨母所生。与佛身相似。三十相短四指不及佛。难陀作衣。与佛衣等量。诸比丘若食时集若中后集遥见来起迎。思惟我等大师佛来。渐近知是难陀。上座比丘羞思惟。是我等下座而起迎。难陀亦惭愧言。乃令诸上座起迎我。诸比丘具白佛。佛以是事集僧。集僧已佛知故问难陀。汝实作是事不。答言。实作世尊。佛言从今日汝衣应减作坏染净。佛告诸比丘。汝等与难陀衣作敷晒。若更有如是人。僧亦当如是同心作敷晒。从今日若比丘作衣与佛衣等若过。得波逸提罪。佛衣长九搩手广六搩手

佛在舍卫国。有一比丘。到佛所礼佛足一面立白佛。听我着刍摩衣。佛言。听汝着刍摩衣。何以故。刍摩衣不妨得道。及知足少欲知时知量。勤学少取节用。头陀静处随涅槃。有一比丘白佛。听我着憍施耶衣。佛言。听汝着憍施耶衣。何以故。憍施耶衣不妨得道。知足少欲乃至随涅槃。有一比丘白佛言。听我着沙尼衣。佛言。听汝着沙尼衣。沙尼衣不妨得道。少欲知足乃至随涅槃。有一比丘白佛。听我着野麻衣。佛言。听汝着野麻衣。野麻衣不妨得道少欲知足。羁由罗钦婆罗亦如是。有一估客。有翅弥楼钦婆罗。卖不得价。闻布施长老须菩提得今世报。即持衣施须菩提。须菩提不取言佛未听我受此衣。诸居士嗔恨言。诸沙门释子恒赞布施。今与不肯受。诸比丘以是事白佛。佛言。从今日听畜钦婆罗衣。钦婆罗衣不妨得道。少欲知足乃至随涅槃。有一比丘白佛。听我受裸形法。佛言。裸形法不应受。若受裸形犯偷兰遮罪。何以故。受裸形法。是外道相故。有一比丘白佛言。听我着发钦婆罗。佛言。发钦婆罗不应着。若着得偷兰遮罪。何以故。是外道相故。有一比丘白佛。听我着角鸱翅衣。佛言。角鸱翅衣不应着。若着得偷兰遮罪。何以故。是外道相故。有一比丘白佛。听我着粗氀衣。佛言。粗氀衣不应着。若着得突吉罗罪。有一比丘白佛。听我着皮衣。佛言。不听着皮衣。若着得突吉罗罪。有一比丘白佛。听我着一衣。佛言。不听着一衣。若着得突吉罗罪。有一比丘白佛。听我着上下衣。佛言。我先以听三衣。不应少不应多。若比丘少畜得突吉罗罪。若多畜堕尼萨耆波逸提罪。若持上下衣得突吉罗罪。有一比丘白佛。听我着打木衣。佛言。不听着打木衣。若着得突吉罗罪。有一比丘白佛。听我着阿拘草衣跋拘草衣拘赊草衣文若草衣婆婆草衣[葶-丁+呆]草衣。佛言。一切不听着。若着得突吉罗罪

六群比丘白佛。听我除身毛。佛言。不应除身毛。除身毛得突吉罗罪。六群比丘白佛。听我着真青衣。佛言。六群比丘索二种。先索除身毛。今索真青衣。佛言。真青衣及真黄真赤真白。一切毛皮衣偏袖衣复衣。一切毡衣一切贯头衣。两袖衣一切绣衣。一切衫一切裤。一切[袖-由+宁]裤一切裈。一切波罗弥利衣。一切舍勒衣一切白衣衣。比丘不应着。若着得突吉罗罪

有一比丘白佛。听我着树生衣。佛言。不听着树生衣。若着得突吉罗罪。有一比丘白佛。听我着粗毛钦跋。佛言。不听着粗毛钦跋。若着得突吉罗罪。粗毛氀钦跋有五种不可事。何等五。寒时大寒。热时大热。粗涩坚硬。令人皮粗。佛在舍卫国。长老比丘喜陀。于安陀林中留僧伽梨。着上下衣入舍卫城乞食。失僧伽梨。食后觅不得。语诸比丘。诸长老。我安陀林中留僧伽梨。着上下衣入城乞食。失僧伽梨。我当云何。诸比丘以是事白佛。佛以是因缘集僧。集僧已。佛知故问比丘喜陀。汝实作是事不。答言。实作世尊。佛种种因缘赞持一切物去。若比丘少欲住。衣趣盖形食趣充躯。是比丘所行处。共衣钵俱无所顾恋。譬如鸟飞与毛羽俱飞在空中。比丘亦如是。少欲知足。衣趣盖形食趣充躯。是比丘所行处。共衣钵俱无所顾恋。亦如鸟飞。佛种种因缘赞持一切物去已。告诸比丘。从今日不持三衣不应入俗人家。若入得突吉罗罪

佛在舍卫国。长老阿难。天雨时祇林中留僧伽梨。着上下衣入舍卫城乞食。诸比丘以是事白佛。佛以是事集僧。集僧已。佛知故问阿难。汝实天雨时祇林中留僧伽梨着上下衣入城乞食不。阿难言。实尔世尊。佛言何以故。阿难言天雨故。佛种种因缘赞戒赞持戒。赞戒赞持戒已告诸比丘。有五因缘听留僧伽梨。何等五。一有比丘住处。二若受迦絺那衣。三若天雨。四若欲雨。五若聚落外有施会。是为五因缘。复有五因缘留僧伽梨衣。何等五。一有比丘住处。二若受迦絺那衣。三若店肆施会。四市肆施会。五四衢道头。是为五因缘

佛在王舍城。是时诸外道出家。夏安居竟自恣时。诸外道居家弟子。布施衣物。诸优婆塞佛法中信心清净思惟言。是诸邪法恶师。夏安居竟自恣时。尚知布施衣。我等圣僧夏安居竟自恣时。云何不布施诸衣耶。即持衣襆诣竹园施僧。诸比丘不受言。佛未听我等受夏安居竟自恣时布施安居衣。以是事白佛。佛言。听安居竟自恣时受安居施衣。诸沙弥来索衣分。诸比丘言。佛未听我等与沙弥安居施衣分。以是事白佛。佛言听与。诸比丘如是思惟。佛言听与。不知与几许白佛。佛言。沙弥若立若坐。次第诸檀越手与布施。多少应属沙弥。若诸檀越不分别。与作四分。第四分与沙弥

佛在王舍城。是时诸外道出家。夏安居竟自恣时。诸居家弟子以诸物施。澡罐绳缨楼遮迦火炉盖扇革屣曲杖。诸优婆塞佛法中信心清净思惟。是诸邪法恶师。夏安居自恣时。尚知布施诸物。我等圣僧夏安居竟自恣时。云何不布施诸物。即随比丘法布施种种诸物。若钵若拘钵多罗。若半拘钵多罗。键镃半键镃。带镮禅镇衣鞙钵支。澡罐钵囊盖扇革屣。如是等种种比丘所须物。持诣竹园布施僧。诸比丘不受言。佛未听我等夏安居竟自恣时受随比丘所须物。以是事白佛。佛言。听夏安居起自恣时受随比丘所须物。时诸沙弥来索随比丘所须物分。诸比丘不与。语沙弥言。佛听夏安居起自恣时施衣与沙弥分。未听随比丘所须物与沙弥分。以是事白佛。佛言应与。诸比丘如是思惟。佛言应与。不知与几许白佛。佛言。诸沙弥若立若坐。若次第诸檀越手自布施。多少属沙弥。若诸檀越不分别。与作四分。第四分与沙弥

佛在舍卫国。跋难陀释子两处安居。为布施故。诸比丘不知何处与衣分白佛。佛言安居处与。诸比丘言两处安居。佛言何处住日多。答言两处日等。佛言何处自恣。答言两处自恣。佛言何处先自恣。是处与衣分

佛在舍卫国。跋难陀释子。夏后月按行诸精舍。欲知何处安居比丘多得衣物。布施多处即往。诸比丘遥见。起迎与布坐处令坐。共相问讯乐不乐。小默然语诸比丘。长老。是中住处僧得布施衣不。诸比丘言得。分未。答言未分。言持来。是间分。诸比丘持来。着跋难陀前分。分已上座取分欲去。跋难陀言。大德小待。问言有何等事。答言但小待。跋难陀能说法。杂语好语无尽语。如是好语说法。上座闻法大欢喜。爱法故语跋难陀。我衣分属汝。如是第二第三上座亦如是。一切僧衣分尽与跋难陀。如是一处两处三处多得衣。大襆持入祇林。诸比丘祇林门间空地经行。遥见来自共相语。跋难陀释子来。耐羞人多作见闻疑恶。多取衣襆来。渐近诸比丘问。是诸衣何处得。答言。与诸比丘广说法故得。诸比丘少欲知足行头陀诃责。何以名比丘。余处安居余处受衣分。诸比丘种种因缘诃已具白佛。佛以是事集僧。集僧已。佛知故问跋难陀。汝实尔不。答言实尔。佛种种因缘诃。何以名比丘。余处安居余处受衣分。尔时佛但呵。未为比丘结戒

佛在憍萨罗国。一住处与大比丘僧安居。是国中诸居士。见僧多家家与比丘僧衣。若别房衣亦后安居衣。佛后岁祇林中夏安居。是住处有两老比丘安居。诸居士思惟。我等施僧如旧令事不废。诸比丘得布施我等得福。诸居士送多衣物。如本法与住处僧。是二老比丘思惟。是诸衣多我等人少。若分知当得何等罪。心疑不分。是时跋难陀。夏后月按行诸精舍。欲知何处安居比丘多得衣物布施。跋难陀思惟。佛往年安居处。是中必有多衣施。即往彼住处。二老比丘遥见来。起迎与坐处。共相问讯乐不乐。小默然问言。是中住处僧。得布施衣物不。答言得。问分未。答未分。问言何故不分。答言。是诸衣多我等人少。若分知当得何等罪。心疑不分。跋难陀言汝不分好。若分知汝得何罪。二老比丘问。汝能分不。答言能。是中应作羯磨。即持诸衣物来置前。跋难陀分作三聚。是二比丘间着一聚。自二聚间立言。汝听作羯磨

  汝二人一聚　　如是汝有三
  两聚并及我　　如是我有三

问是羯磨好不。答言善。跋难陀大担衣去。彼言。大德上座。我等诸衣物未分。跋难陀言我与汝分。知法人应与一好衣。彼言当与。跋难陀是聚中。取一大价衣着一处。余与分作二分已。自担多衣襆入祇林。诸比丘门间空地经行。遥见来自共相语。是跋难陀无羞人。多作见闻疑恶。多取诸衣襆遂近来至。诸比丘言。跋难陀。是诸衣何处得。跋难陀具说向诸比丘。有比丘少欲知足行头陀。闻是事心惭愧诃责。何以名比丘。故夺老比丘物。诸比丘种种因缘诃已具白佛。佛以是事集僧。集僧已。佛知故问跋难陀。汝实尔不。答言实尔。佛种种因缘诃何以名比丘。故夺老比丘物。佛种种因缘诃已告诸比丘。是跋难陀。非但今世夺。前世亦夺。是事听。乃过去世一河曲中有二獭。河中得大鲤鱼不能分。是二獭一面住守之。有野干来欲饮水。见言外甥。是中作何等。獭言阿舅。是河曲中得此鲤鱼。不能分汝能分不野干言能。是中应说偈。野干分作三分。问獭汝谁喜入浅。答言是獭。谁能入深。答言是獭。野干言听我说偈

  入浅应与尾　　入深应与头
  中间身肉分　　应与知法者

野干衔鱼身。雌者来说偈问

  汝何处衔来　　满口河中得
  如是无头尾　　鲤鱼好肉食

雄野干说偈答

  人有相言击　　不知分别法
  能知分别者　　如官藏所得
  无头尾鲤鱼　　是故我得食

佛语诸比丘。时二獭者二老比丘是野干者跋难陀是。是跋难陀前世曾夺今世复夺。佛种种因缘呵跋难陀已告诸比丘。从今日是处安居。不应余处受衣分。若受得突吉罗罪

有一住处一比丘夏安居。是中诸人为夏安居僧故。布施诸衣应分物。虽诸人为夏安居僧故布施诸衣物。一比丘独夏安居应得受。二比丘三比丘四比丘亦如是。有住处无住处亦如是。无聚落阿练若亦如是。有一住处一比丘夏安居。是中诸人为客比丘故。多布施僧诸衣物应分物。虽诸人为客比丘故多布施僧诸衣。现前僧应分物。是一比丘夏安居。是衣应独受。如是二比丘三比丘四比丘亦尔。有住处无住处亦如是。无聚落阿练若处亦如是。若自恣竟僧破。应与夏安居衣分不。佛言应与。自恣竟被举比丘。应与衣分不。佛言不应与。自恣竟有比丘至彼朋党。应与安居衣分不。佛言。若至如法众中应与。自恣竟有比丘。自言我白衣。应与夏安居衣分不。佛言不应与。自恣竟有比丘自言我是沙弥。应与夏安居衣分不。佛言应与沙弥分。自恣竟有比丘自言我非比丘。应与夏安居衣分不。佛言不应与。若言我外道不见摈不作摈恶邪不除摈不共住种种不共住自言犯边罪本白衣不能男污比丘尼越济人杀父母杀阿罗汉破僧恶心出佛身血。如是人等应与夏安居衣分不。佛言不应与。自恣竟有比丘游行至他国。应与夏安居衣分不。佛言。有应与有不应与。与者知当还。不与者知不还。若嘱人取者。一切衣分应与。不嘱人取者不应与。受嘱者。一切僧使应代作

十诵律卷第二十七十诵律卷第二十八(第四诵之八)

        后秦北印度三藏弗若多罗译

    七法中衣法第七之下

佛语比丘。布施有八种。何等八。一界布施。二依止布施。三制限布施。四给得布施。五僧得布施。六现前得布施。七夏安居得布施。八指示得布施

云何名界布施。有一人言。是衣布施是中住处僧。夏后月受迦絺那衣。是衣谁应受。佛言。虽夏后月受迦絺那衣。若比丘入是界内者应受。是名界得布施

云何名依止布施。如多比丘多住处作内界。夏安居自恣竟舍本界。结僧坊垣壁作内界。是中诸人为夏安居众僧故。布施诸衣应分物。是衣谁应受。佛言。虽舍本界是诸比丘。本多住处作界内夏安居。是衣物诸比丘尽应分。是为依止得布施

云何制限布施。有一住处有二部比丘僧。夏安居有受法众。有不受法众。是众僧夏安居竟。作如是制限。此族布施我等受。彼族布施汝等受。此家布施我等受。彼家布施汝等受。是间行处布施我等受。彼间行处布施汝等受。是间聚落布施我等受。彼间聚落布施汝等受。是间去处聚落布施我等受。彼间去处聚落布施汝等受。是间街巷多人处布施我等受。彼间街巷多人处布施汝等受。是中诸人为夏安居僧故。捉上座手布施。与僧诸衣应分物。白佛言。是衣物谁应受。佛言。随何部作上座。是物应属一部。若檀越捉第一上座手第二上座手言。是物施僧。是物应属谁。答言。二上座是一部上座。应属一部。若二上座各是一部。应属二部。云何应分。答言。次第等分四分。第四分应与沙弥。是名制限得布施。云何给得布施。若为人作布施。为因缘作布施。月八日二十三日十四日二十九日十五日三十日十六日月一日。乃至布萨时一钱给某处。是诸物给处与。是为给得布施

云何僧得布施。是住处有檀越言。是衣与住处僧。是时夏后月。是住处不受迦絺那衣。白佛。是衣谁应受。佛言。夏后月是住处。虽不受迦絺那衣。诸比丘是中住处住。是衣应属。是为僧得布施

云何现前得布施。有檀越言。是住处与现前僧。是时夏后月。是住处受迦絺那衣。白佛言。是衣谁应受。佛言。虽夏后月是住处受迦絺那衣。诸比丘是中住处现在。是衣是辈应属。是为现前得布施

云何夏安居得布施。有檀越言。是衣与是住处夏安居僧。是时非夏后月。此住处迦絺那衣不受。白佛言。是衣谁应受。佛言。若非夏后月。此住处迦絺那衣不受。诸比丘是中住处夏安居竟。是衣是辈应受。是为夏安居得布施

云何示得布施。有檀越言。是衣与耆阇崛山中。若毗婆罗跋首山中。若萨波烧持迦波婆利山中。若萨多般那旧河山中。白佛。是衣谁应受。佛言。是衣何处示。示处应受。是为示得布施

佛在舍卫国。是时长老意师。夏后月与大比丘僧五百人游行诸国。以长老意师故。僧大得供养。时食怛钵那种种粥多诸衣布施。是时诸比丘如是思惟。以是长老意师故。僧大得供养。时食怛钵那多诸衣布施。诸比丘往诣意师所问言。为大德大得供养。时食怛钵那多诸衣物布施。长老。是衣物谁应受。长老意师言。诸长老。如佛毗尼中语。有一住处一比丘夏安居。诸人虽为客比丘故布施。僧诸衣应分物。是一比丘独在此夏安居。是衣应独受。二比丘三比丘四比丘亦如是。有住处无住处无聚落阿练儿处亦尔。诸长老。汝等如是比衣应受。如长老意师多亦如是。如长老耶舍。长老耶首陀亦如是

又一时众多大上座比丘大迦叶为首。波罗利弗城雍园中住。是时摩竭国一住处。独一比丘住。是中诸人为夏安居僧故。布施诸衣应分物。是比丘如是思惟。是住处诸人为僧故。布施诸衣应分物。我一人非僧。我当往问长老迦叶等诸上座比丘。是衣物谁应受。即具以是事问诸长老。诸长老言。如佛毗尼中说。有一比丘。一住处夏安居。是诸人为夏安居僧故。布施诸衣应分物。是一比丘独夏安居。是衣应受。二比丘三比丘四比丘亦如是。有住处无住处无聚落阿练儿处亦尔。如是比衣应受

佛在舍卫国。是时给孤独儿。字僧迦罗叉。顶结发故。诣祇林中多设食供养僧。诸比丘大会千二百五十人。诸居士见大众集。是中为僧故。布施诸衣现前僧应分物。旧比丘言。是夏末月是中受一日成衣。是时布施夏安居僧应分物。诸比丘不知当云何。以是白佛。佛言。虽夏末月受迦絺那衣。是名因缘衣。现前僧应分

佛在舍卫国。有阿罗汉比丘般涅槃。为是比丘故。诣祇林中多设食供养僧。诸比丘多会千二百五十人。诸居士见大众集。是中为僧故。布施诸衣。应现前僧分物。旧比丘言。夏末月是中受迦絺那衣。是衣施夏安居僧应分。诸比丘不知当云何。以是事白佛。佛言。虽夏末月住处受迦絺那衣。是因缘衣现前僧应分。沙弥来索衣分。诸比丘不与。诸比丘言。佛说夏安居衣分应与沙弥。随比丘法物应与沙弥。佛不语因缘衣应与。以是事白佛。佛言。听与。诸比丘不知与几许。以是事白佛。佛言。诸檀越布施。沙弥若立若坐。若次第自手布施。应属沙弥。若檀越不分别。与作次第分竟。四分与沙弥一分

佛在舍卫国。是时给孤独居士死故祇林破。诸比丘不知当云何白佛。佛言。比丘若可治便如法治。诸比丘治不能办转破坏白佛。佛言。给孤独居士有子。字僧迦罗叉。应语。是祇林汝父作。而今倾损。汝能治不。诸比丘到语言。僧迦罗叉。是祇林汝父所作。今日倾损。汝何以不治。答言。诸大德。我先知我父十八亿金买空地与佛及僧。今日破此非我事。僧若持祇林与我我当治。诸比丘不知当云何。以是事白佛。佛言。应与。有二人大得福德。一人新起一人补故。二人俱得无量福德。云何应与。僧迦罗叉着内界中。一比丘应僧中如是唱。大德僧听。是祇林无主。僧迦罗叉欲治。若僧时到僧忍听。僧祇林无主当与僧迦罗叉。治故。如是白。大德僧听。是祇林无主。僧迦罗叉能治。是祇林无主。当与僧迦罗叉。治故。谁诸长老忍祇林与僧迦罗叉治者。是长老默然。谁不忍便说。僧与竟。祇林无主。僧迦罗叉治。僧忍默然故。是事如是持

憍萨罗国中一住处一比丘住。春月迦絺那衣讫。是中僧得布施。现前应分物。是比丘如是思惟。是中住处僧得诸衣物。现前应分物。我一人非僧。我何以不到佛所问。是衣物谁应受。是比丘即到佛所。头面礼足却坐一面。须臾具以是事白佛。佛言。春月迦絺那衣讫

憍萨罗国中一住处一比丘住。是中僧得布施。现前僧应分物。我一人非僧。是衣物应云何受。佛言。有一比丘一住处住。诸人为僧故布施诸衣。现前僧应分物。是比丘得此衣。应心生口言。是衣物僧所得。应分物应属我。我护我受我用如是作。是名得羯磨。若余比丘来。不得强索。若不如是作。是比丘此衣不应受。若受得突吉罗罪。亦应共余比丘分。若如是不作者。出界得突吉罗罪。亦应共异比丘分。若有二比丘一住处。当云何分。应展转分自受分。云何展转分。一比丘应如是言。是衣诸人为僧故布施。诸衣僧应分物。是边尔许为我分。即此分与汝长老。是分属长老。汝护汝受汝用。第二比丘亦如是。是名展转分。云何名自受分。一比丘应如是言。是衣诸人为僧故布施。诸衣僧现前应分物。是衣物中尔许。汝应得应属汝。汝护汝受汝用。第二比丘亦如是。是名自受分。若如是作。名得羯磨。若余比丘来。不得强索。若不如是作。是比丘此衣不应受。若受得突吉罗罪。亦应共异比丘分。如是不作出界。得突吉罗罪。亦应共异比丘分。若有三比丘一住处。云何分。三比丘应展转分。若自受分若堕筹分。云何展转分。如上说。自受分亦尔。云何堕筹分。是衣作两分。应如是言。是分属上座。是分属下座。复次是分属下座。是分属上座。如是作竟。应堕一筹。异比丘见不应更堕筹。若堕者诸比丘得突吉罗罪。亦应异比丘共分。若如是不作者。出界得突吉罗罪。应异比丘共分。若有四比丘一住处。当云何分。四比丘应展转分。若自受分。若堕筹分。若僧羯磨分。展转分。自受分堕筹分亦如上说。云何僧羯磨分。是衣僧应羯磨与一比丘。一心会僧。僧中一比丘应唱。大德僧听。是衣是中住处僧。得现前应分物。若僧时到僧忍听。僧是衣僧作羯磨。与某甲比丘。如是白。白二羯磨。僧是衣僧羯磨与某甲比丘竟。僧忍默然故。是事如是持。若是比丘得僧羯磨与衣。取不肯还。如是言。实布施善与善取法善断事。皆出僧中何以还索。佛言。是比丘应如是教。是布施为清净故施。还者善。若不还。应强夺。教突吉罗罪忏悔

尔时诸沙弥来索衣分。诸比丘不与如是言。佛说安居起衣与沙弥分。随比丘所须物与沙弥分。因缘衣与沙弥分。未说非时衣与沙弥分。诸比丘不知云何。以是事白佛。佛言。应与。诸比丘不知与几许白佛。佛言。沙弥若坐若立。若次第檀越自手布施。应属沙弥。若不如是与。第四分与沙弥

佛在舍卫国。憍萨罗土地有一住处一比丘死。诸比丘不知衣钵当云何。以是事白佛。佛言。应羯磨与一比丘。羯磨者。和合僧中一比丘唱。大德僧听。某甲比丘死。是比丘所有资生轻物。若衣若非衣。现前僧应分物。僧羯磨与某甲比丘。若僧。时到僧忍听。某甲比丘死是比丘所。有资生轻物。若衣若非衣。现前僧应分物。僧羯磨与某甲比丘。如是白。大德僧听。某甲比丘死。是比丘所有资生轻物。若衣若非衣。现前僧应分物。僧某甲比丘死。是比丘所有资生轻物。若衣现前僧应分物若非衣。僧羯磨与某甲比丘。谁诸长老忍。某甲比丘死。是比丘资生轻物。若衣若非衣。现前僧应分物。僧羯磨与某甲比丘。是长老忍默然。若不忍便说。僧某甲比丘死。所有资生轻物。若衣若非衣。现前僧应分物。僧羯磨与某甲比丘竟。僧忍默然故。是事如是持

憍萨罗国一住处一比丘死。是比丘衣钵僧分竟。问诸比丘。谁看是病比丘。有比丘言。我僧言。担是死人去。比丘言。大德。我非旃陀罗。非白癞病。衣钵物僧分。我何以担死人去。是人活时恭敬爱念我。我已报竟。是死人谁欲得者便担去。是诸比丘不知云何。以是事白佛。佛言。应先与看病比丘六物。余轻物僧应分重物不应分。看病人六物云何与。一心会僧。僧中一比丘应唱。大德僧听。某甲比丘死。是比丘所有六物现前僧应分物。僧羯磨与看病人。若僧时到僧忍听。僧某甲比丘死。是比丘所有六物。现前僧应分。僧羯磨与看病人。如是白。大德僧听。某甲比丘死。是比丘所有六物。现前僧应分僧某甲比丘死。是比丘所有六物。现前僧应分。僧羯磨与看病人。谁诸长老忍。某甲比丘死。是比丘所有六物。现前僧应分。僧羯磨与看病人。忍者是长老默然。不忍是长老便说。僧已忍某甲比丘死。是比丘所有六物。现前僧应分。僧羯磨与看病人竟。僧忍默然故。是事如是持

憍萨罗国一住处一比丘死。是比丘衣物处处寄。是比丘衣物现前僧分竟。僧问是看病比丘。谁供养瞻视。答言。我等。僧言。汝等彼处处所寄处衣索取。诸瞻病人往索不得。便起斗诤相言。以是事白佛。佛言。现前六物先与看病人。余轻物僧应分。重物不应分。憍萨罗国一住处一比丘死。是比丘多衣多钵多财物不知是比丘受何等僧伽梨。何等郁多罗僧。何等安陀会。何等钵。何等漉水囊。何等尼师檀。以是事白佛。佛言。谁是根本看病人。看病人先应问病者。受何等僧伽梨。何等郁多罗僧。何等安陀会。何等钵。何等漉水囊。何等尼师檀。若如是问已。资生六物与看病人。余轻物僧应分。重物不应分。若如是不问。若不知不信。与不大好不大恶六物。余轻物僧应分。重物不应分

憍萨罗国一住处一比丘死。僧在死比丘尸前分衣钵物。是死比丘动起语诸比丘。诸大德上座莫分我衣钵物。诸比丘不知云何。以是事白佛。佛言。莫即于死尸前分若死尸已去。若僧在异处应分

憍萨罗国土地与学沙弥死。是衣钵物诸比丘不知云何。以是事白佛。佛言。当死时现前僧应分衣钵物

憍萨罗国一住处有沙弥死。诸比丘不知衣钵当云何。以是事白佛。佛言。所著内外衣应与看病人。余轻物僧应分。重物不应分。云何应与。一心会僧。僧中一比丘应唱。大德僧听。某甲沙弥死。是沙弥所有内外衣。若僧时到僧忍听。僧某甲沙弥死。内外衣现前僧应分。僧羯磨与看病人。如是白。大德僧听。某甲沙弥死。是沙弥所有内外衣。现前僧应分物。僧羯磨与看病人。谁诸长老忍。某甲沙弥死。内外衣现前僧应分物。僧羯磨与看病人者默然。不忍者便说。僧与某甲沙弥死。是沙弥所有内外衣。现前僧应分物。僧羯磨与看病人竟。僧忍默然故是事如是持

佛在舍卫国。长老忧波离问佛言。可分物不可分物。何等可分物。何等不可分物。佛言。一切田地一切房舍一切床榻卧具。一切细车一切粗车半庄车步舆车不应分

一切铁物不应分。除釜瓶受二斗已下应分。除钵小钵半钵键镃小键镃剃头刀钳镊截爪刀针刀子户钩曲户钩剃刀匣刮污篦灌鼻筒熨斗香炉熏钵钩衣钩壁上钩匕钵榰禅镇。除上尔所物。余一切铁物不应分

一切铜物不应分。除釜瓶受二斗已下应分。除水盆瓮盖刀匣刮污篦灌鼻筒熨斗香炉熏钵钩衣钩壁上钩禅镇匕钵榰。除上尔所物。一切铜物不应分

一切石物不应分。除釜瓶受二斗已下应分。水瓶水盆盖水物刮污篦灌鼻筒熨斗香炉熏钵钩禅镇。除上尔所物。一切石物不应分。一切水精物不应分。除釜熏钵钩香炉熨斗。余如上说

一切瓦物不应分。除盆受二斗已下应分。水瓶水盆盖水物钵小钵半钵键镃小键镃刀匣刮污篦灌鼻筒熨斗香炉禅镇。除上尔所物余一切瓦器不应分

一切贝物不应分。除刀匣刮污篦灌鼻筒熨斗禅镇香炉熏钵钩衣钩盛药函匕钵榰。是一切贝物应分。余一切不应分

一切牙齿物亦如是

一切角物不应分。除受半升已下应分。除刀匣衣钩壁上钩刮污篦灌鼻筒禅镇盛药函匕钵榰如是一切角物可分。余不应分

一切皮物不应分。除盛酥油囊受半升已下系革屣韦系靴韦鹿韦熟韦裹脚跟指韦应分。一切木物不应分。除杅受二升已下水瓶水盆瓮盖刀匣刮污篦衣钩钵钩壁上钩钵榰禅镇。如是一切木物可分。余一切不应分。一切竹物不应分。除盖扇箱箧席杖等应分。一切赭土不应分

一切染色若煮若未煮不应分

佛在舍卫国。是时语诸比丘。有住处一守戒比丘一被摈比丘共住。若守戒比丘死。衣物属被摈比丘。若被摈比丘死。衣物属守戒比丘。若余摈比丘来不应与

一住处一守戒比丘二被摈比丘共住。若守戒比丘死。衣物属被摈比丘。若被摈比丘死。衣物属守戒比丘。余摈比丘来不应与

一住处一守戒比丘三被摈比丘共住。若守戒比丘死。衣物属被摈比丘。若被摈比丘死。衣物属守戒比丘。若余摈比丘来不应与

有一住处一守戒比丘四被摈比丘共住。若守戒比丘死。衣物属被摈比丘。若被摈比丘死。衣物属守戒比丘。若余摈比丘来不应与

有一住处二守戒比丘一被摈比丘。二守戒比丘二被摈比丘。二守戒比丘三被摈比丘。二守戒比丘四被摈比丘亦如是

一住处有三守戒比丘一被摈比丘。三守戒比丘二被摈比丘。三守戒比丘三被摈比丘。三守戒比丘四被摈比丘亦如是

一住处四守戒比丘一被摈比丘。四守戒比丘二被摈比丘。四守戒比丘三被摈比丘。四守戒比丘四被摈比丘亦如是

一住处一摈比丘一守戒比丘共住。若摈比丘死。衣物属守戒比丘。若守戒比丘死。衣物属摈比丘。若余守戒比丘来应与。一摈比丘二守戒比丘。一摈比丘三守戒比丘。一摈比丘四守戒比丘亦如是

一住处二摈比丘一守戒比丘二摈比丘二守戒比丘。二摈比丘三守戒比丘。二摈比丘四守戒比丘亦如是。一住处三摈比丘一守戒比丘。三摈比丘二守戒比丘。三摈比丘三守戒比丘。三摈比丘四守戒比丘亦如是。一住处四摈比丘一守戒比丘。四摈比丘二守戒比丘。四摈比丘三守戒比丘。四摈比丘四守戒比丘亦如是

憍萨罗国一住处。二比丘住一比丘死。是一比丘如是思惟。佛毗尼中说。若比丘死时。现前僧中衣钵物应分。我一人非僧。我当往佛所问。是衣钵物应属谁。即诣佛所头面礼佛足一面坐。须臾退坐白佛言。大德。我等二比丘憍萨罗国住。一比丘死。我如是思惟。佛毗尼中说。若比丘死时。衣钵物现前僧应分。我一人非僧。我今问世尊。是衣钵物应属谁。佛言。有二比丘共一处住。一比丘死。即死时余一比丘应心念口言。某甲比丘死。是比丘有尔许现前资生轻物。若衣若非衣。现前僧可分物。是物属我。我护我受我用。如是作羯磨竟。若异比丘来不得强索。若不如是作。是比丘衣钵物不应受。若受犯突吉罗罪。亦应共余比丘分。如是不作出界。犯突吉罗罪。亦应共异比丘分。若有三比丘一住处。一比丘死。二比丘是衣钵物。若展转分若自受分。云何展转分。一比丘应如是念言。长老某甲比丘死。是比丘有尔所现前资生轻物。若衣若非衣。现前僧应分物。是边尔许分物属我是分与汝长老。是分汝自护自受自用。第二比丘亦如是念言。长老某甲比丘死。是比丘有尔许资生轻物。若衣若非衣。现前僧应分。是边尔许分物属我。是分与汝长老。是分汝自护自受自用。是为展转分。云何自受分。一比丘应如是言念。长老某甲比丘死。是比丘有尔许资生轻物。若衣若非衣。现前僧应分。是边尔许分物属汝。是分汝长老自护自受自用。第二比丘亦如是言念。长老某甲比丘死。是比丘有尔许资生轻物。若衣若非衣。现前僧应分物。是边尔许分物属汝。是分汝长老自护自受自用。是为自受分。如是作竟。若异比丘来不得强索。若不如是作。是比丘是衣不应受。若受犯突吉罗罪。亦应共异比丘分。如是不作者。出界犯突吉罗罪。亦应异比丘分

若四比丘一住处。一比丘死。三比丘若展转分若自受分若堕筹分。展转分自受分如上说。云何堕筹分。是衣钵物作二分。应如是言。是分属上座。是分属下座。若是分属下座。是分属上座。如是竟一筹应堕。异比丘见不应堕。若堕第二筹。诸比丘犯突吉罗罪。亦应异比丘共分。若如是不作者。出界犯突吉罗罪。亦应异比丘分。若五比丘一住处。一比丘死。余四比丘是衣钵物。若展转分若自受分若堕筹分若羯磨分。展转分自受分堕筹分如上说。云何羯磨分。是衣钵物。僧应羯磨与一比丘。一心会僧。僧中一比丘应唱。大德僧听。某甲比丘死。有尔许资生轻物。若衣若非衣。现前僧应分物。若僧时到僧忍听。僧某甲比丘。有尔许资生轻物。若衣若非衣。现前僧应分物。僧当羯磨与某甲比丘。如是白。作白二羯磨。僧已与某甲比丘羯磨。某甲比丘死。是比丘所有资生轻物。若衣若非衣。现前僧应分物。僧羯磨与某甲比丘竟。僧忍默然故。是事如是持

僧羯磨与比丘衣钵物。是比丘自受不肯还言。一切僧如法与如法取如法誓如法语竟。今何以还索。佛言。应如是语。比丘清净故施汝应还僧。若还善。若不还。应强夺。教突吉罗罪忏悔。诸沙弥来索是衣分。诸比丘不与。佛言。自恣衣分应与。随比丘法物应与。因缘衣分应与。非时衣分应与。佛未语死比丘衣分应与。以是事白佛。佛言。听与。诸比丘不知与几许。佛言。应作四分。第四分应与沙弥

佛言。诸比丘有受法比丘。不受法比丘中住。是受法比丘死。不受法诸比丘。遣使至受法比丘所言。汝等一比丘是间死。衣钵物持去。受法诸比丘若取去善。若不取。应用治四方僧房卧具

若不受法比丘。受法比丘中住。若死。受法比丘。遣使至不受法比丘所言。汝等一比丘是间死。衣钵物取去。诸不受法比丘若取去善。若不持去。应用治四方僧房卧具

有受法诸比丘。摈一比丘。到不受法比丘所言。诸大德。除我罪作清净。我当作不受法。若未除罪而死。受法诸比丘应还摄衣钵。若除罪而死。衣钵物属不受法诸比丘

有不受法诸比丘。摈一比丘。是比丘往受法诸比丘所言。大德。除我罪作清净。我当作受法。若未除罪而死。衣钵物属不受法诸比丘。若除罪而死。衣钵物应属受法诸比丘

有一比丘有衣应舍。是比丘与六群诸比丘。六群比丘取自用。不肯还归。尔时有异诸比丘苦恼。不能得清净可信比丘。佛夏后月游行诸国。诸比丘着新染衣。是比丘着弊故衣。佛见是比丘。知而故问是比丘。汝何以着故弊衣。答言。我有衣应舍。与六群诸比丘。六群比丘取自用。不肯还我。亦有异诸比丘苦恼。不能得清净可信比丘与。佛言。是清净故布施。是时比丘即应还取。若取得善。若不还应强夺。教突吉罗罪忏悔

佛在舍卫国。有一居士。请佛及僧明日食。佛默然受。知佛受已。从坐起头面礼佛足绕佛而还。其夜多办净妙种种饮食。清旦布坐处。遣人白佛。食具已办唯圣知时。佛自房住迎食分。一切僧入居士舍。阿难送佛食分。有五因缘。佛住精舍迎食分。何等五。一若欲入定。二欲为诸天说法。三欲诸房游看。四看病比丘。五若未结戒欲结。佛知诸比丘入居士舍。捉户钩遍看诸房。见一住处开门扇。一病比丘苦痛无侣。自卧大小便中。佛知故问问病比丘。汝何所患苦。独无人瞻视。自卧大小便上。是比丘忠直相实相白佛。大德。我性懒。他有事我不助。我今病。他人亦复不看我。佛如是思惟。是忠实善男子。我当以手摩其身。是时佛即以手摩之。当手摩时。比丘苦痛即除愈。身心安乐佛安徐扶起。与着衣将出房。安徐扶坐洗之。授净衣令着。不净者为浣捩晒。还入安徐却不净涕唾。除草蓐洒扫涂地。更布草蓐已。安徐扶起着衣将入房。扶令草蓐中坐。告病比丘。汝若不勤求。未得事为得故。未到事为到故。未识事为识故。汝随尔许时具受苦痛。方当复剧是。比丘亦自思惟。今佛威神力。以手摩我身。当下手时。我身苦痛即除愈。身心安乐。是比丘念佛大恩。善心生焉。得清净信立种种愿。佛功德尊重。于佛捡意一心。佛随比丘意善为说法。是比丘在草座上。一切诸法不受。得阿罗汉。佛安是比丘第一漏尽中已。从是房出闭门下橝。还本房布尼师檀结跏趺坐。居士是时见众僧坐已。从坐起自行澡水。种种饮食自恣所须。食毕澡手执钵。持一小床在僧前坐。欲听说法。时上座比丘说法。还到佛所头面礼佛足一面坐。诸佛常法。诸比丘中食还。如是问诸比丘饮食多美僧得满足不。诸比丘言大德食美饱满诸比丘食还。尔时世尊以如是问。汝等饮食美不。僧饱满不诸比丘言。大德。食美饱满

佛告诸比丘。今日我捉户钩诸房遍看。见一病比丘。苦痛病急独无人看。卧大小便中。汝诸比丘是事不是。何以不相看不相供给。入我法中。汝无父母兄弟。若不相看谁当看汝。佛种种因缘呵诸比丘已。告诸比丘。从今日应看病人。长老忧波离问佛。谁应供给瞻视病人。佛言。和尚阿阇梨。同和尚同阿阇梨。若无四种人。僧应供给。若僧不与。僧得突吉罗罪。若僧差人不肯去者。得突吉罗罪。从今日结看病比丘法。看病人法者。当随病人所须应作。随时到病人边问病因缘。问病因缘已。若问药师。若问知病比丘见病比丘。如是以何药差。若药师教应服是药。明日到厨中看僧作何食。若有随病应食。看病人则往。若无应病食。应取僧所供给供给是病人。若是事无是住处。若善好有德比丘。从是比丘索供给病人。若无是事。应从多知识大德比丘索。若无是事应留病比丘六物。余物应贸所须供给病人。若无是事。以所受重物贸轻物受持。得钱求所须供给病人若无是事。所受铁钵为贸瓦钵受持。得钱市所须供给病人。若无是事。看病人应自与。若自无。应从他乞供给病人。若无知识乞不能得。乞食美者供给病人。看病比丘。应随时到病人边为说深法。是道非道发其智慧。是病比丘如是随意说法。若是阿练若病。应现前赞阿练若法。若学修妒路经。现前赞学修妒路。若学毗尼。现前赞毗尼。若作法师。现前赞阿毗昙。若佐助众事。应赞佐助众事。若有大德多人所识。应问初地相第二第三第四地相。须陀洹果乃至阿罗汉果。若死随其功德供给供养竟。诸衣若应浣者浣。捩晒燥卷襞。徐徐担入僧中。应如是唱。某甲比丘死。是比丘僧伽梨。是忧多罗僧。是安陀会。是钵是漉水囊。是尼师檀。是余资生物。自得如是胜趣

佛言。有三种病人。有病人若得随病饮食若不得。若得随病药若不得。若得随意看病人若不得。不能差

有病人若得随病饮食若不得。若得应病药若不得。若得随意看病人若不得。能差

有病人若得随病饮食差。若不得死。若得应病药差。若不得死。若得随意看病人差。若不得死。以是病故听看病人。若上二种病人。为供养供给亦善。病人有五事难看。何等五。一恶性不可共语。二看病人教不信不受。三应病饮食不应病饮食。不知自节量。四不肯服药。五不能自忍节量。有是五法病人难看病人有五事易看。何等五。一不恶性。二看病人教能信受。三别随病应食不应食。四能自服药。五能自忍节量。有是五法病人易看。有五法。看病人不能看病。何等五。一者恶性不可共语。二者病人教不随语。三者不别知随病应食不应食。四者不能为病人他边索药。五者不能忍。有是五法不能看病人

有五法能看病人。一者不恶性可共语。二者病人教即随语。三者能知应病饮食。是应食是不应食。四者能为病人他边索药。五者能忍。有是五法能看病人

有五法病人难看。何等五。一恶性不可共语。二不知诸病起灭无常。三身中起病辛苦不乐。夺命性不能忍。四一切喜从他索。少自能作。而不作。五五受阴中起。灭不观。是色阴是色阴习。是色阴尽是痛阴是想阴是行阴是识阴是识阴习。是识阴尽。有是五法病人难看。有五法病人易看。何等五。一者不恶性可共语。二知诸痛起灭观无常。三身中起病辛苦痛急不乐。夺命性能忍。四一切不喜从他索少。自能作自作。五五受阴中起灭能观。是色阴是色阴习是色阴尽。是痛阴是想阴是行阴。是识阴是识阴习是识阴尽。有是五法病人易看

复有五法。看病人不能看病。何等五。一者恶性不可共语。二者若多恶病人屎尿。瓦瓯唾壶出入时。若弃唾时不喜。三为财物饮食不为法故。四五受阴中起灭不能观。是色阴是色阴习是色阴尽。是痛阴是想阴是行阴。是识阴是识阴习是识阴尽。五不能随时到病人边为说深妙法示是道非道。不能生其智慧。是为五法不能看病

佛告诸比丘。有比丘遣比丘。使与他比丘衣。所与比丘衣者死。彼死比丘边同意取。是恶取。死者衣受。是恶受。若本主活在与彼同意取。是好取。长衣受是好受。有比丘遣比丘。使与他比丘衣。本主死与是同意取。是恶取。死者衣受是恶受。所与比丘活在与彼同意取。是好取。长衣受是好受(七法中衣法第七竟)

十诵律卷第二十八十诵律卷第二十九(第五诵之一)

        后秦北印度三藏弗若多罗译

    八法中迦絺那衣法第一

佛在舍卫国。尔时诸比丘。于桑只陀国安居。过三月自恣竟作衣毕。持衣钵向舍卫国。道路多雨泥水。是诸比丘以多雨泥水故。甚大疲极热风所恼。往诣佛所头面礼足却坐一面。诸佛常法。有客比丘来。以如是语劳问。忍不足不。安居乐不。乞食不乏。道路不疲耶。佛以如是语劳问诸比丘。忍不足不。安居乐不。乞食不乏。道路不疲耶。诸比丘答言。世尊。忍足安居乐乞食不乏。但道路疲极。佛问诸比丘。汝等云何忍足安居乐乞食不乏。道路疲极。诸比丘答言。我等于桑只陀国安居。过三月自恣竟作衣已。持衣钵游行向舍卫国。道中值雨多泥水故。热风所恼甚大疲极。佛言。汝等比丘实忍足安居乐乞食不乏。道路疲极。从今听诸比丘。安居自恣竟。和合一处受迦絺那衣。受迦絺那衣者。先衣尚不失何况新衣。受迦絺那衣法者。一心和合僧随得衣日受。云何随得衣日。若月一日得衣即日受。若二日若三日。乃至八月十五日亦如是。一比丘应僧中唱言。大德僧听。今日僧和合受迦絺那衣。若僧时到僧忍听。僧受迦絺那衣。如是白。应先立受迦絺那衣人。应问。谁能与僧作受迦絺那衣人。是中若一比丘言能。佛言。若有五法。不应立作受迦絺那衣人。何等五。随爱随嗔随怖随痴不知受不受。若成就五法。应立作受迦絺那衣人。不随爱不随嗔不随怖不随痴知受不受。是中一比丘应僧中唱言。大德僧听。比丘某甲。能为僧作受迦絺那衣人。若僧时到僧忍听。僧立某甲比丘。作受迦絺那衣人。如是白。大德僧听。比丘某甲。能为僧作受迦絺那衣人。僧今立某甲。为僧作受迦絺那衣人。谁诸长老忍。某甲比丘。为僧作受迦絺那衣人者默然。不忍者说。僧立某甲比丘。为僧作受迦絺那衣人竟。僧忍默然故。是事如是持

尔时若僧初得施衣。安居僧应分。应以是衣羯磨与。受迦絺那衣人与法者。一心和合僧。一比丘僧中唱言。大德僧听。此住处僧得是施衣。安居僧应分。若僧时到僧忍听。僧羯磨与某甲比丘。以是衣作迦絺那衣。不离是住处受持。如是白。大德僧听。是住处僧得是施衣。安居僧应分。僧羯磨与某甲比丘。以此衣僧作迦絺那衣。不离是住处受持。谁诸长老忍。僧羯磨此衣。与某甲比丘。作迦絺那衣。不离是住处受持者默然。不忍者说。僧羯磨此衣与某甲比丘。作迦絺那衣。不离是住处受持竟。僧忍默然故。是事如是持

尔时与了了能作四。比丘浣染裁割篸刺安隐量度浣时应生心。以此衣我衣迦絺那衣受。染裁割篸刺安隐量度时作是念。我以此衣作迦絺那衣受。若生此六心。名善作迦絺那衣。若无此六心。不名善作迦絺那衣。复有三心作是念。我以是衣当作迦絺那衣受。以此衣今作迦絺那衣受。以此衣作迦絺那衣受竟。若生此三心。是名善作迦絺那衣。若无此三心不名善作迦絺那衣。复有二心作是念。我以是衣作迦絺那衣受。以此衣作迦絺那衣受竟。若生此二心。名善作迦絺那衣。若无此二心。作迦絺那衣人。得突吉罗罪

尔时长老优波离。偏袒右肩合掌问佛言。世尊。云何名受迦絺那衣法。佛言。与僧作受迦絺那衣人。应一心浣一心染一心割截一心篸一心刺一心安隐量度。作迦絺那衣人浣是衣时。应作是念。以是衣我作迦絺那衣受。染时割截时篸时刺时安隐量度时。皆作是念。以是衣我作迦絺那衣受。是比丘若生是六心。名善作迦絺那衣。若无是六心。不名善作迦絺那衣。复有三心作是念。我以此衣当作迦絺那衣受。以是衣今作迦絺那衣受。以是衣作迦絺那衣受竟。是比丘若生此三心者。名善作迦絺那衣。若无是三心。不名善作迦絺那衣。复次应生二心。作是念。我以是衣作迦絺那衣受。以是衣作迦絺那衣受竟。是比丘生此二心者。名善作迦絺那衣。若无是二心。作迦絺那衣者。得突吉罗罪。佛语优波离。不但量度。名受迦絺那衣。不但染不但缘。不但帖四角。不但出叶不但篸。故名受迦絺那衣。若用故烂衣作迦絺那衣者。不名为受。先已受作迦絺那衣。今更受者。不名为受。若用非时衣作迦絺那衣者。不名为受。若以郁金色染作迦絺那衣者。不名为受。若以经宿衣作迦絺那衣者。不名为受。若不以决定心受迦絺那衣者。不名为受。若以不净衣作迦絺那衣者。不名为受。若减量作迦絺那衣者。不名为受。若以减量。作僧伽梨若郁多罗僧若安陀卫。作迦絺那衣者。不名为受。若以不割截衣作迦絺那衣者。不名为受。若以不割截僧伽梨郁多罗僧安陀卫。作迦絺那衣者。不名为受。若作迦絺那衣未竟。不名为受。若以异比丘比丘尼式叉摩尼沙弥沙弥尼衣。作迦絺那衣者。不名为受

佛语优波离。僧如法受迦絺那衣日。有一安居比丘出还。闻已受迦絺那衣。不随喜者。是人不得受迦絺那衣。佛语优波离。如是名为受迦絺那衣。若得急施衣用作迦絺那衣者。名为善受。用时衣作迦絺那衣者。名为善受。用新衣作迦絺那衣者。名为善受。用般宿衣作迦絺那衣者。名为善受。若用净衣作迦絺那衣者。名为善受。若用作净衣作迦絺那衣者。名为善受。若用割截僧伽梨郁多罗僧安陀卫。作迦絺那衣者。名为善受。若以帖衣作迦絺那衣者。名为善受。若用比丘比丘尼式叉摩尼沙弥沙弥尼衣。作迦絺那衣者。名为善受。佛语优波离。僧如法受迦絺那衣日。有一安居比丘。出界行即日还。闻已受迦絺那衣。欢喜随顺者。是人名善受

长老优波离问佛言。世尊。云何名舍迦絺那衣。佛言。有八事名舍迦絺那衣。何等八。一者衣成时。二者衣垂成时。三者去时。四者闻时。五者失时。六者发心时。七者过齐限时。八者舍时。初六者。有人受迦絺那衣。持所有衣出界去。作是念。我不还此作衣。去时即名舍迦絺那衣。有人受迦絺那衣。持所有衣出界去。作是念。我不还此处作衣。是比丘出界已。又作是念。我不还彼处亦不作衣。去时即名舍迦絺那衣

有人受迦絺那衣。持所有衣出界去。作是念。我不还此处作衣。于界外作衣。作是念。我不还彼处。衣成时即名舍迦絺那衣。有人受迦絺那衣。持所有衣出界去。作是念。我不还此处作衣。是人于界外作衣。作衣已不好守护故失。更无物作。是人失衣时。即名舍迦絺那衣。有人受迦絺那衣。持所有衣出界去。作是念。我还此处作衣。是人即出界去。彼于界外作衣。若作若未作。作是念我还本处徐徐作。久久不成。是人过齐限时。即名舍迦絺那衣

有人受迦絺那衣。持所有衣出界外去。作是念。我还此处作衣。彼于界外闻僧已舍迦絺那衣。即作是念。迦絺那衣已舍。我不复还。是名闻舍迦絺那衣

有人受迦絺那衣。持所有衣出界去。作是念。我还此处作衣。即于界外作衣。彼衣若成若未成。作是念。我还本处未舍迦絺那衣。到已共僧舍迦絺那衣。即名为舍。是名初六

第二六者。若比丘受迦絺那衣已。作尔所毗波罗衣。持所有衣出界去。作是念。我不还此住处作衣。是比丘去时。即名舍迦絺那衣。若比丘受迦絺那衣已。作尔所毗波罗衣持衣出界去。作是念。我不还此处作衣。是比丘出界已。又作是念。我不还彼处亦不作衣。去时即名舍迦絺那衣。若比丘受迦絺那衣已。作尔所毗波罗衣。持所有衣出界去。作是念。我不还此住处作衣。于界外作衣。作是念。我不还彼处。衣成时即名舍迦絺那衣

若比丘受迦絺那衣已。作尔所毗波罗衣。持所有衣出界去。作是念。我不还此处作衣。是人于界外作衣。不好守护故失。更无物作。是人失衣时。即名舍迦絺那衣

若比丘受迦絺那衣已。作尔所毗波罗衣。持所有衣出界去。作是念。我还此处作衣。是人即出界去。彼于界外作衣。若作若未作。作是念。我还本处徐徐作。久久不成。是人过齐限时。即名舍迦絺那衣

若比丘受迦絺那衣已。作尔所毗波罗衣持所有衣出界去。作是念。我当还此处作衣。彼于界外闻僧已舍迦絺那衣。即作是念。迦絺那衣已舍。我不还本处是比丘闻时。即名舍迦絺那衣

若比丘受迦絺那衣已。作尔所毗波罗衣。持所有衣出界去。作是念。我当还此处作衣。即于界外作衣。彼衣若作若未作。作是念。我还本处未舍迦絺那衣。到已共僧舍迦絺那衣。即名为舍。是名第二六竟

复有二十舍迦絺那衣。若比丘受迦絺那衣。持所有衣出界外去。作是念。我不还此住处作衣。是比丘出界已。又作是念。我不还本住处亦不作衣。是比丘去时。即名舍迦絺那衣。

二者若比丘受迦絺那衣。持所有衣出界去。作是念。我不还此住处作衣。是比丘出界外作衣时。作是念。我不还本住处。是衣成时。即名舍迦絺那衣

三者若比丘受迦絺那衣。持所有衣出界。作是念。我不还此住处作衣。是比丘界外作衣。作衣已不好守护故失。更无物作。是人失衣时。即名舍迦絺那衣

四者若比丘受迦絺那衣。持所有衣出界去。作是念。我不还此住处作衣。是比丘界外作衣。已作尔所。尔所未作。徐徐作久久不成。又作是念。我当还本处。是比丘过齐限时。即名为舍迦絺那衣。是名初四

第二四者。若比丘受迦絺那衣。持所有衣出界去。不经理。亦不言还。亦不言不还。出界去时作是念。我不还此住处作衣。是比丘去时。即名舍迦絺那衣

二者。若比丘受迦絺那衣。持所有衣出界去。不经理。亦不言还。亦不言不还。出界作衣。作是念。我不还本处作衣。衣成时即名舍迦絺那衣

三者。若比丘受迦絺那衣。持所有衣出界去。不经理。亦不言还。亦不言不还。是比丘界外作衣。作衣已。不好守护故失。更无物作。失衣时即名舍迦絺那衣

四者。若比丘受迦絺那衣。持所有衣出界去。不经理。亦不言还。亦不言不还。出界外作是念。我不还本处。即于彼处作衣。若成若不成。徐徐作久久不成。是比丘过齐限时。即名舍迦絺那衣。是名第二四

第三四者。若比丘受迦絺那衣。持衣出界。作是念。我当还此处作衣。是比丘界外又作是念。我不还本处亦不作衣。是比丘去时。即名舍迦絺那衣。二者。若比丘受迦絺那衣。持衣出界。作是念。我当还此处作衣。是比丘界外作衣。又作是念。我不还本处作衣。衣成时。即名舍迦絺那衣

三者。若比丘受迦絺那衣。持衣出界作是念。我当还此处作衣。是比丘于界外作衣。作衣已。不好守护故失。更无物作。失衣时即名舍迦絺那衣

四者。若比丘受迦絺那衣。持衣出界作是念。我当还此处作衣。是比丘界外作衣。已作尔所。尔所未作。徐徐作。久久不成。又作是念。我当还本处。是比丘过齐限时。即名舍迦絺那衣。是名第三四

第四四者。若比丘受迦絺那衣。持衣出界去。作是念。我当还此处作衣。是比丘界外闻已舍迦絺那衣。作是念。我不还本处亦不作衣。是比丘去时。即名舍迦絺那衣

二者若比丘受迦絺那衣。持衣出界作是念。我当还此处作衣。界外闻已舍迦絺那衣。是比丘便界外作衣。又作是念。我不还本处作衣。衣成时即名舍迦絺那衣

三者若比丘受迦絺那衣。持衣出界去。作是念。我不还此处作衣。是人于界外闻已舍迦絺那衣。即于界外作衣作衣已。不好守护故失更无物作。失时即名舍迦絺那衣

四者若比丘受迦絺那衣。持衣出界作是念。我当还此处作衣。是比丘界外闻已舍迦絺那衣。界外作衣。已作尔所。尔所未作。徐徐作。久久不成。作是念。我不还本处。是比丘过齐限时。即名舍迦絺那衣。是名第四四

第五四者。若比丘受迦絺那衣。持衣出界。作是念。我当还此住处作衣。是比丘界外作衣。又作是念。我不还本处。是比丘作衣成时。即名舍迦絺那衣

二者若比丘受迦絺那衣持所有衣出界去。作是念。我当还此处作衣。是人于界外作衣。作衣已。毗波罗衣垂成留置。是人作是念。此毗波罗衣不还彼处。衣垂成时。即名舍迦絺那衣。三者若比丘受迦絺那衣。持衣出界。作是念。我当还此处作衣。是比丘界外闻已舍迦絺那衣。是比丘作是念。若僧已舍迦絺那衣。不还本处亦不作衣。以闻故。即名舍迦絺那衣

四者若比丘受迦絺那衣。持衣出界作是念。我当还此住处作衣。是比丘界外作衣。已作尔所。尔所未作。徐徐作。未舍迦絺那衣。还此住处。共僧舍迦絺那衣。即名为舍。是名第五四舍迦絺那衣

复有二十舍迦絺那衣。若比丘受迦絺那衣。持所有衣出界。望得衣故。作是念。我不还此住处作衣。是比丘界外作是念。我不还本住处亦不作衣。是比丘去时。即名舍迦絺那衣

二者若比丘受迦絺那衣。持衣出界。望得衣故作是念。我不还此住处作衣。出界外作衣。时作是念。我不还本住处。是衣成时。即名舍迦絺那衣

三者若比丘受迦絺那衣。持衣出界。望得衣故。作是念。我不还此住处作衣。是比丘界外作衣。作衣已不好守护故失。更无物作。衣失时即名舍迦絺那衣

四者若比丘受迦絺那衣。持衣出界。望得衣故。作是念。我不还此住处作衣是比丘界外作衣。已作尔所。尔所未作。徐徐作。久久不成。又作是念。我当还本处。是比丘过齐限时。即名舍迦絺那衣。是名初四。余三四。不经理。当来还。闻已舍亦如上说

第五四者。若比丘受迦絺那衣。持所有衣出界。望得衣故。作是念。我当还此住处作衣是比丘界外作衣。又作是念。我不还本处。是比丘作衣成时。即名舍迦絺那衣

二者若比丘受迦絺那衣。持所有衣出界。望得衣故。作是念。我当还此处作衣。是人于界外作衣。作衣已。毗波罗衣垂成留置。作是念。此毗波罗衣不还彼处。衣成时即名舍迦絺那衣。三者若比丘受迦絺那衣。持所有衣出界。望得衣故。作是念。我当还此处作衣是比丘界外闻已舍迦絺那衣。是比丘作是念。若僧已舍迦絺那衣。我不还本处。亦不作衣。以闻故。即名舍迦絺那衣

四者若比丘受迦絺那衣。持所有衣出界望得衣故。作是念。我当还此处作衣。是比丘界外作衣。已作尔所。尔所未作。徐徐作。未舍迦絺那衣。还此处共僧舍迦絺那衣。即名为舍。是名第五四舍迦絺那衣。是名第二五四舍迦絺那衣

复有二十舍迦絺那衣。一者若比丘受迦絺那衣。持所有衣出界。望得衣故。作是念。我不还此处作衣。不得所望。非望而得。是比丘界外作是念。我不还本处亦不作衣。是比丘去时。即名舍迦絺那衣

二者若比丘受迦絺那衣。持衣出界望得衣故。作是念。我不还此处作衣。不得所望。非望而得。是比丘出界外作衣时。作是念。我不还本处。是衣成时。即名舍迦絺那衣

三者。若比丘受迦絺那衣。持衣出界。望得衣故。作是念。我不还此处作衣。不得所望。非望而得。是比丘界外作衣。作衣已。不好守护故失。更无物作。衣失时即名舍迦絺那衣

四者若比丘受迦絺那衣。持衣出界。望得衣故。作是念。我不还此处作衣。不得所望。非望而得。是比丘界外作衣。已作尔所。尔所未作。徐徐作。久久不成。又作是念。我当还本处。是比丘过齐限时。即名舍迦絺那衣。余三四。不经理。当来还。闻已舍亦如是

第五四者。若比丘受迦絺那衣。持衣出界。望得衣故。作是念。我还此住处作衣。不得所望。非望而得。是比丘界外作衣。又作是念。我不还本处。是比丘作衣成时。即名舍迦絺那衣

二者若比丘受迦絺那衣。持所有衣出界。望得衣故。作是念。我当还此处作衣。不得所望。非望而得。是人于界外作衣。作衣已。毗波罗衣垂成留置。作是念。此毗波罗衣不还本处。衣成时即名舍迦絺那衣

三者若比丘受迦絺那衣。持所有衣出界。望得衣故。作是念。我当还此处作衣。不得所望。非望而得。是比丘界外闻已舍迦絺那衣。是比丘作是念。我若僧已舍迦絺那衣。不还本处。亦不作衣。以闻故。即名舍迦絺那衣

四者若比丘受迦絺那衣。持衣出界。望得衣故。作是念。我当还此处作衣。不得所望。非望而得。是比丘界外作衣。已作尔所。尔所未作。徐徐作。未舍迦絺那衣。还此处共僧舍迦絺那衣。即名舍。是名第五四舍迦絺那衣。是名第三五四

复有二十舍迦絺那衣。一者若比丘受迦絺那衣。持所有衣出界。望得衣故。作是念。我不还此处作衣。断所望得。非望而得。出界已作是念。我不还本住处。亦不作衣。是比丘去时。即名舍迦絺那衣

二者若比丘受迦絺那衣。持所有衣出界。望得衣故。作是念。我不还此处作衣。断所望得。非所望而得。是比丘出界外作衣时作是念我不还本处。是衣成时。即名舍迦絺那衣

三者若比丘受迦絺那衣。持衣出界。望得衣故。作是念。我不还此处作衣。断所望得。非望而得。是比丘界外作衣。作衣已。不好守护故失。更无物作。衣失时即名舍迦絺那衣

四者若比丘受迦絺那衣。持衣出界。望得衣故。作是念。我不还此处作衣。断所望得。非望而得。是比丘界外作衣。已作尔所。尔所未作。徐徐作。久久不成。又作是念。我当还本处。是比丘过齐限时。即名舍迦絺那衣。余三四。不经理。当来还。闻已舍亦如是

第五四者。若比丘受迦絺那衣。持衣出界。望得衣故。作是念。我还此住处作衣。断所望得。非望而得。是比丘界外作衣。又作是念。我不还本处。是比丘作衣成时。即名舍迦絺那衣

二者若比丘受迦絺那衣。持所有衣出界去。望得衣故。作是念。我当还此处作衣。断所望得。非望而得。是人于界外作衣。作衣已。毗波罗衣垂成留置。作是念。此毗波罗衣不还彼处。衣成时即名舍迦絺那衣

三者若比丘受迦絺那衣。持衣出界。望得衣故。作是念。我当还此处作衣。断所望得。非望而得。是比丘界外闻已舍迦絺那衣。是比丘作是念。若僧已舍迦絺那衣。不还本处亦不作衣。以闻故。即名舍迦絺那衣

四者若比丘受迦絺那衣。持衣出界。望得衣故。作是念。我当还此处作衣。断所望得。非望而得。是比丘界外作衣。已作尔所。尔所未作。徐徐作。未舍迦絺那衣。还此处共僧舍迦絺那衣。即名为舍。是名第五四舍迦絺那衣。是名第四五四

复有二十舍迦絺那衣。一者若比丘受迦絺那衣。持所有衣出界。望得衣故。作是念。我不还此住处作衣。不得所望不断所望。非望而得。是比丘出界外已。又作是念。我不还本处亦不作衣。是比丘去时即名舍迦絺那衣。二者若比丘受迦絺那衣。持所有衣出界。望得衣故。作是念。我不还此处作衣。不得所望不断所望。非望而得。是比丘出界外作衣时。作是念。我不还本处。是衣成时。即名舍迦絺那衣

三者若比丘受迦絺那衣。持衣出界。望得衣故。作是念。我不还此住处作衣。不得所望不断所望。非望而得。是比丘出界外作衣。作衣已。不好守护故失。更无物作衣。失衣时即名舍迦絺那衣

四者若比丘受迦絺那衣。持衣出界。望得衣故。作是念。我不还此住处作衣。不得所望不断所望。非望而得。是比丘界外作衣。已作尔所。尔所未作。徐徐作。久久不成。又作是念。我当还本处。是比丘过齐限时。即名舍迦絺那衣。余三四。不经理。当来还。闻已舍亦如是。

第五四者。若比丘受迦絺那衣。持所有衣出界。望得衣故。作是念。我当还此处作衣。不得所望不断所望。非望而得。是比丘界外作衣。又作是念。我不还本处。是比丘作衣成时。即名舍迦絺那衣

二者若比丘受迦絺那衣。持所有衣出界。望得衣故。作是念。我当还此处作衣。不得所望不断所望。非望而得。是人于界外作衣。作衣已。毗波罗衣垂成留置。作是念。此毗波罗衣不还彼处。衣成时即名舍迦絺那衣

三者若比丘受迦絺那衣。持所有衣出界。望得衣故。作是念。我当还此处作衣。不得所望不断所望。非望而得。是比丘界外闻已舍迦絺那衣。是比丘作是念。若僧已舍迦絺那衣。我不还本处亦不作衣。以闻故。即名舍迦絺那衣

四者若比丘受迦絺那衣。持所有衣出界。望得衣故。作是念。我当还此处作衣不得所望不断所望。非望而得。是比丘界外作衣。已作尔所。尔所未作。徐徐作。未舍迦絺那衣。还此处共僧舍迦絺那衣。即名为舍。是名第五四舍迦絺那衣。是名第五五四

复有二十舍迦絺那衣。一者若比丘受迦絺那衣。持衣出界。望得多衣故。作是念。我不还此处作衣。不得所望不断所望。非望而得。复勤求所望。是望亦断。非望而得。是比丘出界已。又作是念。我不还本处亦不作衣。是比丘去时。即名舍迦絺那衣

二者若比丘受迦絺那衣。持衣出界。望得多衣故。作是念。我不还此处作衣。不得所望不断所望。非望而得。复勤求所望。是望亦断。非望而得。是比丘出界外作衣时。作是念。我不还本处。衣成时即名舍迦絺那衣

三者若比丘受迦絺那衣。持衣出界。望得多衣故。作是念。我不还此处作衣。不得所望不断所望。非望而得。复勤求所望。是望亦断。非望而得。是比丘界外作衣。作衣已。不好守护故失。更无物作衣。失时即名舍迦絺那衣。

四者若比丘受迦絺那衣。持所有衣出界。望得多衣故。作是念。我不还此住处作衣。不得所望不断所望。非望而得。复勤求所望。是望亦断。非望而得。是比丘界外作衣。已作尔所。尔所未作。徐徐作。久久不成。又作是念。我当还本处。是比丘过齐限时。即名舍迦絺那衣。余三四。不经理。当来还。闻已舍亦如是

第五四者。若比丘受迦絺那衣。持所有衣出界。望得多衣故。作是念。我当还此住处作衣。不得所望不断所望。非望而得。复勤求所望。是望亦断。非望而得。是比丘界外作衣。又作是念。我不还本住处。是比丘作衣成时。即名舍迦絺那衣

二者若比丘受迦絺那衣。持所有衣出界。望得多衣故。作是念。我当还此处作衣。不得所望不断所望。非望而得。复勤求所望。是望亦断。非望而得。是人于界外作衣。作衣已。毗波罗衣垂成留置。作是念。此毗波罗衣不还彼处。衣成时即名舍迦絺那衣

三者若比丘受迦絺那衣。持所有衣出界。望得多衣故。作是念。我当还此处作衣。不得所望不断所望。非望而得。复勤求所望。是望亦断。非望而得。是比丘界外闻已舍迦絺那衣。是比丘作是念。若僧已舍迦絺那衣。我不还本处亦不作衣。以闻故。即名舍迦絺那衣

四者若比丘受迦絺那衣。持所有衣出界。望得多衣故。作是念。我当还此处作衣。不得所望不断所望。非望而得。复勤求所望。是望亦断。非望而得。是比丘界外作衣。已作尔所。尔所未作。徐徐作。未舍迦絺那衣。还此处共僧舍迦絺那衣。即名为舍。是名第五四舍迦絺那衣。是名第六五四

复有十二舍迦絺那衣。一者若比丘受迦絺那衣。持衣出界。衣财不足故。作是念。我当还此处作衣。是比丘界外他语言。持衣来当为汝作。是比丘界外作是念。我不还本处亦不作衣。是比丘去时。即名舍迦絺那衣

二者若比丘受迦絺那衣。持衣出界。衣财不足故。作是念。我当还此住处作衣。是比丘界外他语言。持衣来当为汝作。是人界外令他作衣。作是念。我不还本处界外作衣。衣成时即名舍迦絺那衣

三者若比丘受迦絺那衣。持衣出界。衣财不足故。作是念。我当还此住处作衣。是比丘界外他语言。持衣财来我为汝作。是比丘界外作衣。作衣已。不好守护故失。更无物作。是比丘失衣时。即名舍迦絺那衣

四者若比丘受迦絺那衣。持衣出界外。衣财不足故。作是念。我当还此住处作衣。界外他语言。持衣来我为汝作。是比丘界外令他作衣。已作尔所。尔所未作。徐徐作。久久不成。又作是念。我当还本处。是比丘过齐限时。即名舍迦絺那衣

五者若比丘受迦絺那衣。持衣出界。衣财不足故。作是念。我当还此住处作衣。界外他语言。持衣来我为汝作。是比丘界外闻已舍迦絺那衣。作是念。我不还本处亦不作衣。是比丘去时。即名舍迦絺那衣

六者若比丘受迦絺那衣。持衣出界。衣财不足故。作是念。我当还此住处作衣。界外他语言。持衣来我为汝作。是比丘界外闻已舍迦絺那衣。又作是念。我不还本处。是比丘界外作衣。衣成时即名舍迦絺那衣

七者若比丘受迦絺那衣。持衣出界。衣财不足故。作是念。我当还此住处作衣。界外他语言。持衣来我为汝作。是比丘界外闻已舍迦絺那衣。是比丘界外作衣。作衣已。不好守护故失。更无物作衣。失衣时即名舍迦絺那衣。八者若比丘受迦絺那衣。持衣出界。衣财不足故。作是念。我当还此住处作衣。界外他语言。持衣来我为汝作。是比丘界外闻僧已舍迦絺那衣。界外作衣。已作尔所。尔所未作。徐徐作。衣久久不成。过齐限时。即名舍迦絺那衣。九者若比丘受迦絺那衣出界。衣财不足故。作是念。我当还此住处作衣。界外他语言。持衣来我为汝作衣。是比丘界外作是念。我不还本处。是比丘界外作衣衣成时。即名舍迦絺那衣

十者若比丘受迦絺那衣。持衣出界。衣财不足故。作是念。我当还此住处作衣。界外他语言。持衣来我为汝作。是比丘界外令他作衣。作衣已毗波罗衣垂成留置。是人作是念。此毗波罗衣不还本处。衣成时即名舍迦絺那衣。十一者。若比丘受迦絺那衣。持衣出界。衣财不足。作是念。我当还此住处作衣。界外他语言。持衣来我为汝作。是比丘界外闻僧已舍迦絺那衣。作是念。若僧已舍迦絺那衣。我不还本处亦不作衣。是比丘闻时。即名舍迦絺那衣

十二者。若比丘受迦絺那衣。持衣出界。衣财不足故。作是念。我当还此住处作衣。界外他语言。持衣来我为汝作。是比丘界外作衣。已作尔所。尔所未作。还此住处。僧未舍迦絺那衣。共僧舍时。即名为舍迦絺那衣

复有十二舍迦絺那衣。一者若比丘受迦絺那衣毗波罗衣。持衣出界。衣财不具足故。作是念。我当还此住处作衣。是比丘界外他语言。持衣来我为汝作。是比丘界外作是念。我不还本处亦不作衣。是比丘去时。即名舍迦絺那衣

二者若比丘受迦絺那衣毗波罗衣。持衣出界。衣财不足故。作是念。我当还此住处作衣。是比丘界外他语言。持衣来我为汝作。是比丘界外令他作衣。作是念。我不还本处界外作衣。作衣成时。即名舍迦絺那衣

三者若比丘受迦絺那衣毗波罗衣。持衣出界。衣财不足故。作是念。我当还此住处作衣。界外他语言。持衣来我为汝作。是比丘界外作衣。作衣已不好守护故失。更无物作。是比丘失衣时。即名舍迦絺那衣

四者若比丘受迦絺那衣毗波罗衣。持衣出界。衣财不足故。作是念。我当还此住处作衣。界外他语言。持衣来我为汝作。是比丘界外令他作衣。已作尔所。尔所未作。徐徐作。久久不成。又作是念。我当还本处。是比丘过齐限时。即名舍迦絺那衣

五者若比丘受迦絺那衣毗波罗衣。持衣出界。衣财不足故。作是念。我当还此住处作衣。界外他语言。持衣来我为汝作。是比丘界外闻已舍迦絺那衣。作是念。我不还本处亦不作衣。是比丘去时。即名舍迦絺那衣

六者。若比丘受迦絺那衣毗波罗衣。持衣出界。衣财不足故。作是念。我当还此住处作衣。界外他语言。持衣来我为汝作衣。是比丘界外闻已舍迦絺那衣。又作是念。我不还本处。是比丘界外作衣。衣成时即名舍迦絺那衣

七者。若比丘受迦絺那衣毗波罗衣。持衣出界。衣财不足故。作是念。我当还此住处作衣。界外他语言。持衣来我为汝作。是比丘界外闻已舍迦絺那衣。界外作衣。作衣已。不好守护故失。更无物作。失衣时即名舍迦絺那衣

八者。若比丘受迦絺那衣毗波罗衣。持衣出界。衣财不足故。作是念。我当还此住处作衣。界外他语言。持衣来我为汝作。是比丘界外闻僧已舍迦絺那衣。界外作衣。已作尔所。尔所未作。徐徐作。久久不成。过齐限时即名舍迦絺那衣

九者。若比丘受迦絺那衣毗波罗衣。持衣出界。衣财不足故。作是念。我当还此住处作衣。界外他语言。持衣来我为汝作。是比丘界外作是念。我不还本处。是比丘界外作衣。衣成时即名舍迦絺那衣。十者。若比丘受迦絺那衣毗波罗衣。持衣出界。衣财不足故。作是念。我当还此住处作衣。界外他语言。持衣来我为汝作。是比丘界外令他作衣。作衣。毗波罗垂成留置。是人作是念。此毗波罗衣不还本处。作衣成时。即名舍迦絺那衣

十一者。若比丘受迦絺那衣。毗波罗衣。持衣出界。衣财不足故。作是念。我当还此住处作衣。界外他语言。持衣来我为汝作。是比丘界外闻僧已舍迦絺那衣。作是念。若僧已舍迦絺那衣。我不还本处亦不作衣。是比丘闻时即名舍迦絺那衣

十二者。若比丘受迦絺那衣毗波罗衣。持衣出界。衣财不足故。作是念。我当还此住处作衣。界外他语言。持衣来我为汝作。是比丘界外作衣。已作尔所。尔所未作。还此住处。僧未舍迦絺那衣。共僧舍时。即名舍迦絺那衣。是为十二

复有二五舍迦絺那衣。初五者。若比丘受迦絺那衣作衣竟。持衣出界。以安隐心作是念。我当往某住处。某住处吉若彼处可乐者当住。不可乐者便还。是比丘出界已。又作是念。我不还本处。是比丘去时。即名舍迦絺那衣

二者。若比丘受迦絺那衣作衣竟。持衣出界。以安隐心作是念。我当往某住处某住处。若彼可乐者当住。不可乐者便还。是比丘出界已。又作是念。我不往某处某处。亦不还本处。是比丘去时。即名舍迦絺那衣

三者。若比丘受迦絺那衣作衣竟。持衣出界。以安隐心作是念。我当往某住处某住处。若彼可乐者当住。不可乐者便还。是比丘界外不至彼住处。亦不还本住处。久久住在界外。是比丘过齐限故。即名舍迦絺那衣

四者。若比丘受迦絺那衣作衣竟。持衣出界。以安隐心作是念。我当往某住处某住处。若彼可乐者便住。不可乐者当还。是比丘界外闻僧已舍迦絺那衣。是比丘作是念。若僧已舍迦絺那衣。我不还本住处。亦不至某处。是比丘闻时。即名舍迦絺那衣

五者。若比丘受迦絺那衣作衣竟。持衣出界以安隐心作是念。我当往某住处某住处。若彼可乐者便住。不可乐者当还。是比丘界外。若往彼住处若不往。未舍迦絺那衣。便还此住处。共僧舍迦絺那衣即名舍。是名初五舍迦絺那衣

后五者。若比丘受迦絺那衣作衣竟。持衣出界。作是念。我得伴者。当往某方某方。若不得者当还。是比丘出界。作是念我不还本住处。是比丘去时。即名舍迦絺那衣

二者若比丘受迦絺那衣作衣竟。持衣出界。作是念。我得伴者。当往某方某方。若不得者当还。是比丘出界已。又作是念。我不往某方某方。亦不还本处。是比丘去时。即名舍迦絺那衣

三者若比丘受迦絺那衣作衣竟。持衣出界。作是念。我得伴者。当往某方某方。若不得者。当还此住处。是比丘出界外。不至彼方亦不还本处。久久住在界外。是比丘过齐限时。即名舍迦絺那衣

四者若比丘受迦絺那衣作衣竟。持衣出界。作是念。我得伴者。当往某方某方。若不得者当还。是比丘界外闻僧已舍迦絺那衣。是比丘作是念。僧已舍迦絺那衣。我不还本处。亦不至某方。是比丘以闻故。即名舍迦絺那衣

五者若比丘受迦絺那衣作衣竟。持衣出界。作是念。我得伴者。当往某方某方。若不得者当还。是比丘界外。若往彼方若不往。未舍迦絺那衣。便还此处。共僧舍迦絺那衣。即名为舍。是名二五舍迦絺那衣竟(八法中迦絺那衣法第一竟)

  二六六二十　　双十二二五
  合百六十六

十诵律卷第二十九十诵律卷第三十(第五诵之二)

        后秦北印度三藏弗若多罗译

    八法中俱舍弥法第二

佛在俱舍弥。尔时有一比丘。犯可悔过罪。诸比丘怜愍。欲益利安乐故。语其过罪。教令如法悔过。是比丘言。我不知所犯。既不知。当见何罪。云何忏悔。诸比丘作是念。此比丘不肯直尔便首。当与作不见摈。作是念已。即与作不见摈。是比丘乐持戒有惭愧。多知多识。多有力势佐助。所住处四边。多诸比丘共相狎习。是人遣使语言。我无罪。而诸比丘不如法羯磨摈我。是摈可破。汝等来集。四边诸比丘即时俱集。欲灭是事故。是比丘具向诸比丘说。我以如是因缘故无罪。诸比丘不如法。强与我作不见摈。此事可破。诸比丘闻已不忍心。转谓是比丘实无罪。僧不如法。强与作不见摈。是事可破。如是决定随顺摈人。与诸作摈比丘共相违逆。以是故。相言斗诤事起。僧破僧诤僧别僧异。作破僧因缘。分作两部。一部言。此比丘有罪。一部言。此比丘无罪。一部言。如法摈。一部言。不如法摈。一部言。不如法摈可破。一部言。如法摈不可破。如是相言斗诤不息。僧遂破作二部。诸比丘以是事向佛广说。佛即时却随顺比丘及摈比丘令小远去。语诸作摈比丘。汝等若事无因缘根本。彼不自首。不应作摈。何以故。有比丘犯可悔过罪。诸比丘怜愍。欲益利安乐故。语其过罪。教令如法悔过。是比丘乐持戒有惭愧。多知多识。有大力势多人佐助。有如是人。僧先应思惟。有五法。不应作摈。何等五。若我等与是比丘作不见摈。不共说戒及僧羯磨不共怛钵那。不共中食。不随上座起礼迎送。以是因缘故。斗诤相言。僧破僧诤僧别僧异。诸比丘亦应思惟。有是五法故。不应作摈。又比丘犯可悔过罪。诸比丘怜愍。欲益利安乐故。语其过罪。教令如法悔过。是比丘乐持戒有惭愧。少知识无大势力无多相助。四边住处少知识共语共事者。佛言。僧应先思惟。有五法应摈。何等五。若我等与是比丘作不见摈。不共说戒及僧羯磨。不共怛钵那。不共中食。不随上座起礼迎送。以是因缘故。不起斗诤相言。僧和合无诤无别无异。思惟是五法已。应作摈。佛如是语已。又却作摈诸比丘令小远去。唤随顺摈诸比丘来语言。汝等比丘。莫为犯罪不自见罪人。何以故。若比丘犯可悔过罪。诸比丘怜愍。欲益利安乐故。语其过罪。教令如法悔过。是犯罪比丘。能思惟五法。如法见罪。何等五。若我是罪不如法见。僧或与我作不见摈。不得共说戒及僧羯磨。不得共怛钵那。不得共中食。不得随上座受他起礼迎送。何以故。诸比丘乐持戒有惭愧。不能为我故随爱随嗔随怖随痴行。是犯罪人。思惟是五法故。能如法见罪

佛在俱舍弥。尔时俱舍弥诸作摈比丘。在界内说戒作僧羯磨。随佛所听羯磨。皆如是作。诸随顺比丘及摈比丘。亦出界外说戒作僧羯磨。随佛所听羯磨。皆如是作。诸比丘以是事向佛广说。佛尔时。即却随顺助摈比丘及摈比丘令小远去。问诸作摈比丘。汝等实于界内共住处。说戒作僧羯磨。随我所听羯磨。皆如是作耶。答言。实尔世尊。又问彼随顺比丘及摈比丘。出界外说戒作僧羯磨。随我所听羯磨。皆如是作耶。答言。实尔世尊。佛言。善哉善哉。比丘若汝等。与随顺比丘及摈比丘。界内共说戒作僧羯磨。随我所听羯磨共作者。是诸羯磨皆名非法。何以故。汝等与彼别异故。彼不与汝共住。汝等不与彼共住。汝等不与彼共事。彼不与汝等共事。彼若共汝等。界内说戒作僧羯磨。随我所听羯磨共作者。皆名非法。何以故。彼与汝等别异故。彼不与汝等共住。汝等不与彼共住。汝等不与彼共事。彼亦不与汝等共事。彼所作羯磨亦皆如法。何以故。彼与汝等别异。不应共住共事故。有二种不共住。何等二。一者比丘身自作不共住。二者僧和合如法。与作不共住羯磨。有二种共住。一者身自作共住。二者僧和合如法。与作共住羯磨。若苦切摈比丘。舍彼部众入此部众。即应共住。若依止羯磨。驱出羯磨下意羯磨。比丘舍彼部众入此部众。即应共住。若摈人折伏下意。出界外与解摈者。即得与所解摈众共住。佛尔时。遣作摈诸比丘令小远去。告诸随顺摈比丘及摈比丘言。汝等实出界外说戒作僧羯磨。随我所听羯磨。皆如是作耶。答言。实作世尊。又问彼诸比丘。实在界内说戒作僧羯磨。随我所听羯磨。皆如是作耶。答言。实尔世尊。佛言。善哉善哉。比丘若汝等。与作摈诸比丘。界外共说戒作僧羯磨。随我所听羯磨共作者。是诸羯磨皆名非法。何以故。汝等与彼别异故。彼不共汝等住。汝等不共彼住。汝等不与彼共事。彼不与汝等共事。彼若共汝等。界外说戒作僧羯磨。随我所听羯摩共作者。皆名非法。何以故。彼等与汝别异故。彼不与汝等共住。汝等不与彼共住。汝等不与彼共事。彼亦不与汝等共事。彼所作羯磨亦皆如法。何以故。彼与汝等别异。不应共住共事故。有二种不共住。一者身自作不共住。二者僧和合如法。与作不共住羯磨。有二种共住。一者身自作共住。二者僧和合如法。与作共住羯磨。若苦切摈比丘。舍彼部众入此部众。即应共住。若依止羯磨。驱出羯磨。下意羯磨。得如是羯磨比丘。舍彼部众入此部众。即应共住。若摈比丘折伏下意。出界外与解摈者。即得与所解摈众共住

佛在俱舍弥。时有一居士。请佛及僧明日食。佛默然受请。居士知佛默然受已。头面礼佛足右绕而去。还舍通夜办种种多美饮食。早起敷座处。遣使白佛时到。佛自知时。诸比丘往居士舍。佛自房住迎食分。诸比丘入居士舍。斗诤事起相言相骂起身恶业。出家人所不应作。是居士语诸比丘言。大德小住。皆令就座。自手行水。自与多美饮食。自恣饱满已。行澡水毕。取小床坐欲听说法。上座说法已从座起去。诸比丘食后还房举衣钵。往诣佛所头面礼佛足却坐一面。诸佛常法。诸比丘食来。以是语言问讯。饮食多美。众僧满足不。佛即以是语劳问。诸比丘。饮食多美。僧饱满不。诸比丘答言。世尊。饮食多美众僧饱满。以上事向佛广说。佛以是事集比丘僧。种种因缘诃责言。云何名比丘。入白衣舍起斗诤事。相言相骂起身恶业。出家人所不应作。佛言。从今别部异众。不应共相近坐令起身恶业。如是异众集时。听知法比丘令相远。敷座中间留一床处。然后说戒作诸羯磨。及教化比丘尼

佛在俱舍弥。尔时俱舍弥比丘。喜斗诤相言。佛尔时教化是诸比丘。汝等莫斗诤相言。何以故。用嗔恨者不灭嗔恨。唯忍辱力乃能灭之。是中有比丘。白佛言。世尊法王。且置。彼人恼我云何不报。尔时世尊小却不远。作是念。我今得离常喜斗诤相言相骂俱舍弥比丘所行威仪法则。广说长寿王经已。即从座起往支提国。渐渐游行到舍卫国。尔时俱舍弥诸贤者。闻佛不喜俱舍弥比丘斗诤言语所行威仪法则故舍诣他国。作是念。我等应轻贱是诸比丘少起敬心。作是念已。即便相语咸共轻贱。不复尊重供养赞叹。敬心转少。尔时诸比丘作是念。诸居士轻贱我等。不复尊重供养赞叹。敬心转少。我等何不往舍卫国诣佛所。作是念已。随意住竟持衣钵。往舍卫国诣佛所。长老舍利弗。闻俱舍弥诸比丘喜斗诤相言彼诸贤者不复尊重供养赞叹起慢心故来向舍卫国。闻已往诣佛所。头面礼佛足却坐一面。白佛言。世尊。俱舍弥比丘喜斗诤相言。彼诸贤者。不复尊重供养赞叹。起慢心故。便来向此。世尊。我等于此比丘。当应何所作。佛语舍利弗。是中有说非法者。不应尊重供养赞叹。有说法者。应尊重供养赞叹。舍利弗白佛言。世尊。我等云何知说非法者说法者。佛语舍利弗。若比丘非法说法。法说非法。非律说律。律说非律。犯说非犯。非犯说犯。轻说重。重说轻。无残说有残。有残说无残。常所行法。说非常所行法。非常所行法。说是常所行法。说言非说。非说言说。是名说非法者。不应尊重供养赞叹。不应教读诵经法答所问疑。不应从受读诵经法从问所疑。不应与衣钵户钩时药时分药七日药尽形药。亦不应从受衣钵户钩时药时分药七日药尽形药。舍利弗。若比丘非法说非法。法说法。非律说非律。律说律。犯说犯。非犯说非犯。轻说轻。重说重。无残说无残。有残说有残。常所行法。说是常所行法。非常所行法。说非常所行法。说言是说。非说言非说。是名说法者。应尊重供养赞叹。应教读诵经法答所问疑。亦应从受读诵经法。从问所疑。应与衣钵户钩时药时分药七日药尽形药。亦应从受衣钵户钩时药时分药七日药尽形药。一切尽应与床卧具。长老目连。阿那律。难提。金毗罗。亦如是问。尔时摩诃波阇波提比丘尼。闻俱舍弥比丘喜斗诤相言彼诸贤者不尊重供养起慢心故来向舍卫国。闻已往诣佛所。头面礼足在一面立。白佛言。世尊。俱舍弥比丘喜斗诤相言。彼诸贤者。不尊重供养赞叹。起慢心故。便来向此。世尊。我等于此比丘。当应何所作。佛言。瞿昙弥。是中有说非法者。不应敬重供养赞叹。有说法者。应敬重供养。瞿昙弥言。云何知说非法者说法者。佛告瞿昙弥。善听。若比丘非法说法。法说非法。非律说律。律说非律。犯说非犯。非犯说犯。重说轻。轻说重。无残说残。残说无残。常所行法。说非常所行法。非常所行法。说是常所行法。说言非说。非说言说。是名说非法者。不应敬重供养赞叹。不应教读诵经法答所问疑。不应从受读诵经法从问所疑。不应与衣钵户钩时药时分药七日药尽形药。不应从受衣钵户钩时药时分药七日药尽形药。不应从是人受半月教诫法。瞿昙弥。若比丘非法说非法。法说法。非律说非律。律说律。犯说犯。非犯说非犯。轻说轻。重说重。无残说无残。有残说有残。常所行法。说是常所行法。非常所行法。说非常所行法。说言是说。非说言非说。是名说法者。应敬重供养赞叹。教读诵经法答所问疑。亦应从受读诵经法从问所疑。应与衣钵户钩时药时分药七日药尽形药。亦应从是人受衣钵户钩时药时分药七日药尽形药。应从是人受半月教诫法。翅舍瞿昙弥比丘尼。优钵罗花色比丘尼。周那难陀比丘尼。频头比丘尼。脂梨沙弥尼亦如是问。憍萨罗王波斯匿。闻俱舍弥比丘喜斗诤相言彼诸贤者不尊重供养故来向此国。闻已往诣佛所。头面礼足却坐一面。白佛言。世尊。我等当应何所作。佛言。大王。是中有说非法者。不应敬重供养。有说法者应供养。世尊。云何知说法者说非法者。佛言。大王。应听两人语。若比丘非法说法法说非法。是名说非法者。不应敬重供养赞叹。不应教读诵经法答所问疑。不应从受读诵经法从问所疑。不应与衣钵户钩时药时分药七日药尽形药。大王。若有比丘。非法说非法。法说是法。应恭敬供养赞叹教读诵经法答所问疑。亦应从受读诵经法从问所疑。应与衣钵户钩时药时分药七日药尽形药。大王。应与一切二部僧饮食。大居士须达多。阿难邠坻梨师达多。富罗那亦如是问。末利夫人。闻俱舍弥比丘喜斗诤相言彼诸贤者不尊重供养赞叹故来向此国。闻已往诣佛所。头面礼佛足却坐一面。白佛言。世尊。我等于此比丘。当应何所作。佛言。末利夫人。是中有说非法者。不应尊重供养赞叹。有说法者。应尊重供养赞叹。世尊。我等云何知说法者说非法者。佛言。末利夫人。应听两人语。若比丘非法说法。法说非法。是名说非法者。不应尊重供养赞叹。不应教读诵经法答所问疑。不应从受读诵经法从问所疑。不应与衣钵户钩时药时分药七日药尽形药。末利夫人。若比丘非法说非法。法说是法。是名说法者。应尊重供养赞叹教读诵经法答所问疑。亦应从受读诵经法从问所疑。应与衣钵户钩时药时分药七日药尽形药。应与一切二部僧饮食。毗舍佉鹿子母。布萨多居士妇。修阇多居士妇。亦如是问

尔时长老舍利弗。闻俱舍弥比丘喜斗诤相言故已来入界。闻已往诣佛所。头面礼佛足却坐一面。白佛言。世尊。俱舍弥比丘喜斗诤相言来入此界。我等云何与卧具分。佛言。我先说应与卧具。随彼部上座。先与卧具。舍利弗受佛教已。随彼上座先与卧具

佛在俱舍弥。尔时得摈比丘独行独住作是思惟。为我故。众僧斗诤相言僧破僧诤僧别僧异。是中有比丘言。是人有罪。有言。是人无罪。有言。如法摈。有言。不如法摈。有言。如法摈。不可破。有言。不如法摈可破。皆为我故。我实犯罪。如法摈不可破。今当云何。作是思惟已。到随顺比丘所言。我独行独住作是思惟。为我故。僧斗诤相言僧破僧诤僧别僧异。是中有比丘言。是人有罪。有言。是人无罪。有言。如法摈。有言。不如法摈。有言。如法摈不可破。有言。不如法摈可破。皆为我故。我实犯罪。如法摈不可破。我今云何。随顺诸比丘即将摈比丘。到作摈诸比丘所言。是摈比丘到我所言。我独行独住作是思惟。为我故。僧斗诤相言僧破僧诤僧别僧异。是中有比丘言。是人有罪。有言。是人无罪。有言。如法摈。有言。不如法摈。有言。如法摈不可破。有言。不如法摈可破。皆为我故。我实犯罪。如法摈不可破。我今云何。作摈诸比丘。即将摈比丘及随顺诸比丘。往诣佛所头面礼佛足却坐一面。白佛言。世尊。是随顺比丘。将摈比丘。至我等所言。是摈比丘言。我独行独住作是思惟。为我故。僧斗诤相言僧破僧诤僧别僧异。是中有比丘言。是人有罪。有言。是人无罪。有言。如法摈。有言。不如法摈。有言。如法摈不可破。有言。不如法摈可破。皆为我故。我实犯罪。如法摈不可破。我今云何。佛言。是比丘实犯罪。如法摈不可破。若是比丘。心悔折伏自首者。应与解摈。解摈法者。一心和合僧。是摈比丘应从坐起偏袒右肩。脱革屣[跳-兆+互]跪合掌作是言。大德僧忆念。为我故。僧斗诤相言僧破僧诤僧别僧异。是中有比丘言。是人犯罪。有言是人无罪。有言。如法摈。有言。不如法摈。有言。如法摈不可破。有言。不如法摈可破。皆为我故。我某甲比丘实犯罪。如法摈不可破。我今心悔折伏自首从僧乞解摈我比丘某甲。心悔折伏自首。僧当与我解摈。怜愍故。第二第三亦如是乞。即时一比丘。僧中唱言。大德僧听。是摈比丘某甲言。为我故。僧斗诤相言僧破僧诤僧别僧异。是中有比丘言。是人有罪。有言。是人无罪。有言。如法摈。有言。不如法摈。有言。如法摈不可破。有言。不如法摈可破。皆为我故。我实犯罪。如法摈不可破。是摈比丘某甲。心悔折伏自首。今从僧乞解摈。若僧时到僧忍听。与某甲比丘解摈。是名白。大德僧听。是摈比丘某甲言。为我故。僧斗诤相言僧破僧诤僧别僧异。是中有比丘言。是人有罪。有言。是人无罪。有言。如法摈。有言。不如法摈。有言。如法摈不可破。有言。不如法摈可破。皆为我故。我实犯罪。如法摈不可破。是摈比丘某甲。心悔折伏自首。僧今与某甲比丘解摈。谁诸长老忍听。与某甲比丘解摈者默然。不忍者说。如是白四羯磨。僧与某甲比丘解摈竟。僧忍默然故。是事如是持

佛在俱舍弥。尔时彼比丘独行独住作是思惟。为我故。僧斗诤相言僧破僧诤僧别僧异。是中有比丘言。是人有罪。有言。是人无罪。有言。如法摈。有言。不如法摈。有言。如法摈不可破。有言。不如法摈可破。皆为我故。我实犯罪。如法摈不可破。我心悔折伏自首。僧已与我解摈。我今应入僧中共作和合。作是思惟已。往随顺诸比丘所言。我独行独住作是思惟。为我故。僧斗诤相言僧破僧诤僧别僧异。是中有比丘言。是人有罪。有言。是人无罪。有言。如法摈。有言。不如法摈。有言。如法摈不可破。有言。不如法摈可破。皆为我故。我实犯罪。如法摈不可破。我心悔折伏自首。僧已与我解摈。我今应入僧中共作和合随顺诸比丘即将是比丘。往诣作摈比丘所言。是比丘言。我独行独住作是思惟。为我故。僧斗诤相言僧破僧诤僧别僧异。是中有比丘言。是人有罪。有言。无罪。有言。如法摈。有言。不如法摈。有言。如法摈不可破。有言。不如法摈可破。皆为我故。我实犯罪。如法摈不可破。我心悔折伏自首故。僧已与我解摈。我今应入僧中共作和合。作摈诸比丘。即将是比丘及随顺诸比丘。往诣佛所头面礼足却坐一面。白佛言。世尊。是随顺诸比丘将是比丘到我所言。是比丘说。我独行独住作是思惟为我故。僧斗诤相言僧破僧诤僧别僧异。是中有比丘言。是人有罪。有言。无罪。有言。如法摈。有言。不如法摈。有言。如法摈不可破。有言。不如法摈可破。皆为我故。我实有罪。如法摈不可破。我心悔折伏自首故。僧已与我解摈。我今应入僧中作和合。佛言。善哉善哉诸比丘。汝为和合因缘故。细求是事。如破一毛为百分。莫为破僧因缘细求是事。佛言。应共作和合若布萨时未到。应僧中唱言。大德僧听。今僧为和合故。若僧时到僧忍听。今非布萨时。作布萨说波罗提木叉为众僧和合故。是名白。即时作布萨说波罗提木叉(八法中俱舍弥法第二竟)

    八法中瞻波法第三

佛在瞻波国。尔时六群比丘。处处作非法羯磨。一人摈一人。一人摈二人三人四人。二人摈二人。二人摈三人四人一人。三人摈三人。三人摈四人一人二人。四人摈四人。是中有比丘。少欲知足行头陀。闻是事心不喜。诃责言。云何名比丘。处处作非法羯磨。一人摈一人二人三人四人。二人摈二人三人四人一人。三人摈三人四人一人二人。四人摈四人。如是诃已向佛广说。佛以是事集比丘僧。知而故问六群比丘。汝实作是事不。答言。实作世尊。佛诃责言。云何名比丘。处处作非法羯磨。一人摈一人二人三人四人。二人摈二人三人四人一人。三人摈三人四人一人二人。四人摈四人。佛但诃责而未结戒

佛在瞻波国。尔时阿叶摩伽国聚落。名王萨婆。是中有旧比丘。名共金。作摩摩帝帝帝陀罗。六群比丘游行迦尸国向瞻波国。到王萨婆聚落。是比丘遥见彼来。出迎代持衣钵开房舍示言。此房舍床卧具被枕。汝等随上座安住。与办洗浴具。与油澡豆。欲揩摩者即与揩摩。是摩摩帝夜坐禅。晨朝入王萨婆聚落。到诸贵人舍。赞叹六群比丘言。六群比丘是佛弟子。多闻善巧说法辩才无碍。以是故。汝等应与僧怛钵那食中食。即时诸婆罗门居士信者。与作怛钵那食中食与僧。六群比丘啖是食已。肥盛得色得力身柔软。共相谓言。是好善男子。尊重赞叹我等。作如是好食。数日之中更不复续。六群比丘共相谓言。是善男子转更不好。不复尊重供养赞叹我等。当唤其来。即唤来到。六群问言。汝何故不复尊重供养赞叹我等。答言。此王萨婆聚落婆罗门居士。信我语者约敕作供养。我力势正能齐是。更不能得。六群比丘言。汝见罪不。答言。我有何罪。六群言。汝看我等不如本尊重供养赞叹。彼言。我不见罪。六群比丘言。此人不肯直首。当与作不见摈。即与作不见摈。是人作是念。六群比丘无因缘。我不自首。强作不见摈。我何不向瞻波国诣佛所。如是思惟已。随意住王萨婆聚落已。持衣钵往瞻波国诣佛所。头面礼佛足一面立。诸佛常法。有客比丘来。如是问讯。可忍不足不。安乐住不。乞食不难。道路不疲极耶。佛如是语。问讯共金比丘。可忍不足不。安乐住不。乞食不难。道路不疲极耶。答言。世尊。可忍可足乞食无难道路不疲。以是事向佛广说。佛知而故问共金比丘。六群比丘何因缘故摈汝。答言。世尊。无因无缘我无罪。强与我作不见摈。佛言。若六群比丘无因无缘。汝无罪强摈汝者。汝莫愁忧。我与汝作法伴。六群比丘闻与作摈比丘向瞻波国诣佛所。我等亦当往诣佛所。如是思惟随意住已。持衣钵游行向瞻波国诣佛所。头面礼佛足一面立。诸佛常法。有客比丘来。以如是语问讯。可忍不足不。安乐住不。乞食不难。道路不疲极耶。佛即以是语。问讯六群比丘可忍不足不。安乐住不。乞食不难。道路不疲极耶。六群比丘答言。世尊。可忍可足安乐住。乞食不难道路不疲极。佛知而故问六群比丘。汝等于王萨婆聚落。有与比丘作不见摈耶。答言。实有世尊。问何因缘故摈。答言。无因无缘彼无罪。强为作摈。佛以是事及先因缘集比丘僧。种种因缘呵责六群比丘言。云何名比丘。无因无缘彼无罪强为作摈。云何名比丘。处处作非法羯磨。一人摈一人二人三人四人。二人摈二人三人四人一人。三人摈三人四人一人二人。四人摈四人。若比丘一人摈一人。犯一突吉罗。一人摈二人。犯二突吉罗。一人摈三人。犯三突吉罗。一人摈四人。四突吉罗。二人摈二人。二突吉罗。二人摈三人。三突吉罗。二人摈四人。犯四突吉罗。三人摈一人。一突吉罗。三人摈三人。三突吉罗。三人摈四人。四突吉罗。三人摈一人。一突吉罗。三人摈二人。二突吉罗。四人摈四人。偷兰遮。作破僧因缘故。一人摈一人。是非法羯磨不应作。一人摈二人三人四人。是非法羯磨不应作。二人摈二人三人四人一人。是非法羯磨不应作。三人摈三人四人一人二人。是非法羯磨不应作。四人摈四人。是非法羯磨不应作。若一人摈一人。不成羯磨。一人摈二人三人四人。不成羯磨。二人摈二人三人四人一人。不成羯磨。三人摈三人四人一人二人。不成羯磨。四人摈四人。不成羯磨。可四众作羯磨。是中四比丘成。可五众作羯磨。是中五比丘成。可十众作羯磨。是中十比丘成。可二十众作羯磨。是中二十比丘成。若四众可作羯磨。是中减四比丘作。是非法羯磨不应作。若白衣作第四人。是非法羯磨不应作。若沙弥若非比丘若外道。若不见摈人不作摈人。恶邪不除摈人不共住人种种不共住人。自言犯重罪人。本白衣污比丘尼。不能男人越济人。杀父母人杀阿罗汉破僧恶心出佛身血。如是人作第四人。是非法羯磨不应作。可五众作羯磨。减五比丘作者。是非法羯磨不应作。若白衣作第五人是非法羯磨不应作。若沙弥若非比丘若外道。若不见摈人不作摈人。恶邪不除摈人不共住人种种不共住人。自言犯重罪人本白衣污比丘尼。不能男人越济人。杀父杀母杀阿罗汉破僧恶心出佛身血。如是人作第五人。是非法羯磨不应作。可十众作羯磨。减十众作者。是非法羯磨不应作。若白衣作第十人。是非法羯磨不应作。若沙弥非比丘若外道。不见摈人不作摈人。恶邪不除摈人。不共住人。种种不共住人。自言犯重罪本白衣污比丘尼人。不能男人越济人。杀父杀母杀阿罗汉破僧恶心出佛身血。如是人作第十人。是非法羯磨不应作。可二十众作羯磨。减二十众作者。是非法羯磨不应作。若白衣作第二十人。是非法羯磨不应作。若沙弥非比丘若外道。不见摈不作摈。恶邪不除摈。不共住人。种种不共住人。自言犯重罪。本白衣污比丘尼。不能男人越济人破内外道杀父杀母杀阿罗汉破僧恶心出佛身血。如是人作第二十人是非法羯磨不应作。若可四众作羯磨减四比丘作者。不成羯磨。若可四众作羯磨。若白衣作第四人是非法羯磨。不成羯磨不应作。若沙弥乃至恶心出佛身血人。作第四人。是非法羯磨。不成羯磨不应作。若五众可作羯磨。减五比丘作者。不成羯磨。若可五众作羯磨。若白衣作第五人。是非法。不成羯磨不应作。若沙弥非比丘若外道。不见摈不作摈。恶邪不除摈。不共住。种种不共住。自言犯重罪。本白衣污比丘尼。不能男人越济人。杀父杀母杀阿罗汉破僧恶心出佛身血。如是等人作第五人。是非法不成羯磨不应作。若可十众作羯磨。减十众作者。不成羯磨不应作。若可十众作羯磨。若白衣作第十人。是非法。不成羯磨不应作。若沙弥非比丘若外道。不见摈不作摈。恶邪不除摈。不共住。种种不共住。自言犯重罪。本白衣污比丘尼。不能男人越济人。杀父杀母杀阿罗汉破僧恶心出佛身血。如是等人作第十人。是非法。不成羯磨不应作。若可二十众作羯磨者。减二十比丘作羯磨。不成羯磨不应作。若可二十僧作羯磨。若白衣作第二十人。是非法。不成羯磨不应作。若沙弥非比丘若外道。不见摈不作摈。恶邪不除摈。不共住。种种不共住。自言犯重罪。本白衣污比丘尼。不能男人越济人。杀父杀母杀阿罗汉破僧恶心出佛身血。如是等人作第二十人。是非法。羯磨不成不应作

佛言。从今别住人作第四人。不应作别住羯磨。若别住竟人作第四人。不应作别住羯磨。行摩那埵人作第四人。不应作别住羯磨。行摩那埵竟人作第四人。不应作别住羯磨。若不共住人作第四人。不应作别住羯磨。极少四清净同见比丘。得作别住羯磨。从今若别住人作第四人。不应作摩那埵羯磨。若别住竟人作第四人。不应作摩那埵羯磨。行摩那埵人。行摩那埵竟人。作第四人。不应作摩那埵羯磨。不共住人作第四人。不应作摩那埵羯磨。极少四清净同见比丘。得作摩那埵羯磨。从今若别住人作第四人。不应作本日治羯磨。别住竟人作第四人。不应作本日治羯磨。若行摩那埵人作第四人。不应作本日治羯磨。行摩那埵竟人作第四人。不应作本日治羯磨。不共住人作第四人。不应作本日治羯磨。极少四清净同见比丘。得作本日治羯磨。从今日若别住人作第二十人。不应作出罪羯磨。若别住竟人若行摩那埵人。若行摩那埵竟人。作第二十人。不应作出罪羯磨。若不共住人作第二十人。不应作出罪羯磨。极少二十清净同见比丘。得作出罪羯磨。佛语诸比丘。清净同见四比丘。是名众僧。若五比丘清净同见。是名众僧。若十比丘清净同见。是名众僧。若二十比丘清净同见。是名众僧。是中四比丘清净同见僧中。可如法作诸羯磨。除自恣羯磨。除受大戒羯磨。除出罪羯磨。是中五比丘清净同见僧中。可如法作诸羯磨。除中国受大戒羯磨。除出罪羯磨。是中十比丘清净同见僧中可如法作诸羯磨。除出罪羯磨。是中二十比丘清净同见僧中。可如法作一切羯磨

尔时长老优波离问佛言。世尊。颇有僧不如法作羯磨耶。佛语优波离。有五种僧。一者无惭愧僧。二者羺羊僧。三者别众僧四者清净僧。五者真实僧。无惭愧僧者。破戒诸比丘。是名无惭愧僧。羺羊僧者。若比丘凡夫钝根无智慧。如诸羺羊聚。在一处无所知。是诸比丘不知布萨。不知布萨羯磨。不知说戒。不知法会。是名羺羊僧。别众僧者。若诸比丘一界。内处处别作诸羯磨。清净僧者。凡夫持戒人及凡夫胜者。是名清净僧。真实僧者学无学人。是名真实僧。是中前三种僧。能作非法羯磨。后二种不能作非法羯磨。佛告优波离。复有四种羯磨。非法羯磨。如法羯磨。别众羯磨。和合羯磨。非法羯磨者。若白羯磨离白作。是名非法羯磨。若白二羯磨离白作者。是亦非法。复有作白不唱说羯磨是亦非法。若唱说羯磨不作白。是亦非法。若白四羯磨离白作者。是亦非法。若白已不三唱说羯磨。是亦非法。若三唱说羯磨不作白是非法羯磨。若应与现前比尼与忆念比尼是非法羯磨。应与忆念比尼与现前比尼。是非法羯磨。应与忆念比尼与不痴比尼。是非法羯磨。应与不痴比尼与现前比尼。是非法羯磨。应与不痴比尼与自言比尼。是非法羯磨。应与自言比尼与不痴比尼。是非法羯磨。应与自言比尼与实觅比尼。是非法羯磨。应与实觅比尼与自言比尼。是非法羯磨。应与实觅比尼与苦切羯磨。是非法羯磨。应与苦切羯磨与实觅比尼。是非法羯磨。应与苦切羯磨与依止羯磨。是非法羯磨。应与依止羯磨与苦切羯磨。是非法羯磨。应与依止羯磨与驱出羯磨。是非法羯磨。应与驱出羯磨与依止羯磨。是非法羯磨。应与驱出羯磨与下意羯磨。是非法羯磨。应与下意羯磨与驱出羯磨。是非法羯磨。应与下意羯磨与别住羯磨。是非法羯磨。应与别住羯磨与下意羯磨。是非法羯磨。应与别住羯磨与摩那埵羯磨。是非法羯磨。应与摩那埵羯磨与本日治羯磨。是非法羯磨。应与出罪羯磨与本日治羯磨。是非法羯磨。应与出罪羯磨与摩那埵羯磨。是非法羯磨。若僧种种事起。不如法不如比尼不如佛教断。皆名非法。是名非法羯磨。如法羯磨者。若白羯磨用白作。是如法羯磨。若白二羯磨白已一唱。是如法羯磨。若白四羯磨白已三唱。是如法羯磨。若应与现前比尼与现前比尼。是如法羯磨。若应与忆念与忆念。应与不痴与不痴。应与自言治与自言治。应与实觅比尼与实觅比尼。应与苦切羯磨与苦切。应与依止羯磨与依止。应与下意羯磨与下意。应与驱出羯磨与驱出。应与别住羯磨与别住。应与摩那埵与摩那埵。应与本日治与本日治。应与出罪与出罪。是名如法羯磨。若僧中种种事起。如法如比尼如佛教断。是名如法羯磨。别众羯磨者。是羯磨中所须比丘。不和合一处。可与欲者不与欲。现前比丘遮成遮。是名别众羯磨。复有别众羯磨。是羯磨中所须比丘和合一处。可与欲者不与欲。现前比丘遮成遮。是名别众羯磨。复有别众羯磨。是羯磨中所须比丘和合一处。可与欲者与欲。现前比丘遮成遮。是名别众羯磨。和合羯磨者。所须比丘和合一处。可与欲者与欲现前比丘能遮不遮是名和合羯磨

长老优波离问佛。何比丘遮可受。何比丘遮不可受。佛言。若僧如法作羯磨。是中有比丘遮不应受。若白衣遮。若沙弥。若非比丘。若外道。不见摈不作摈恶邪不除摈不共住。种种不共住。自言犯重罪。本白衣污比丘尼。不能男人越济人。杀父杀母杀阿罗汉。破僧恶心出佛身血。如是等人遮不应受。若界内人遮界外作羯磨不应受。若界外人遮界内作羯磨不应受。若在下人遮高处作羯磨不应受。若在高处人遮下处作羯磨不应受。若遮人不到作羯磨僧所。若到不乞听。若破戒人遮皆不应受。若破戒人心遮亦不应受。是名不应受。应受遮者。若僧作非法羯磨。是中有比丘遮应受。若僧界内作非法羯磨界内比丘遮应受。若遮比丘到僧所乞听已遮应受。若持戒比丘遮应受。是名应受。有诸比丘。非法别众摈比丘。有比丘僧来解。非法别众。非法和合众。似法别众。似法和合众。如法别众。如法和合众。复有诸比丘。非法和合众摈比丘。有比丘僧来解。非法别众。非法和合众。似法别众。似法和合众。如法别众。如法和合众。复有诸比丘。似法别众摈比丘。有比丘僧来解。非法别众。非法和合众。似法别众。似法和合众。如法别众。如法和合众。复有诸比丘。似法和合众摈比丘。有比丘僧来解。非法别众。非法和合众。似法别众。似法和合众。如法别众如法和合众。复有诸比丘僧。如法别众摈比丘。有比丘僧来解。非法别众。非法和合众。似法别众。似法和合众。如法别众。如法和合众。复有比丘僧。如法和合众摈比丘。有比丘僧来解。非法别众。非法和合众。似法别众。似法和合众。如法别众。如法和合众。佛语优波离。是中一众。名真实作摈。所谓如法和合众一众名真实解摈。所谓如法和合众解(八法中瞻波法第三竟)

十诵律卷第三十十诵律卷第三十一(五诵之三)

        后秦北印度三藏弗若多罗译

    八法中般茶卢伽法第四(丹本云八法中苦切羯磨法第四之初)

佛在舍卫国。尔时舍卫国有二比丘。一名般茶。二卢伽。喜斗诤相言。共诸比丘斗诤相言已。知是斗诤比丘。便到其所言。汝等决定坚持是事莫为他击。汝等取胜我当相助。复语第二部言。汝等决定坚持是事莫为他击。汝等取胜我当相助。以是因缘故。未破比丘便破。已破者不可和合。僧中未起事便起。已起事不可灭。是中有比丘。少欲知足行头陀。闻是事心不喜。呵责言。云何名比丘。喜斗诤相言。知是斗诤比丘。便到其所言。汝等决定坚持是事莫为他击。汝等取胜我当相助。复语第二部言。汝等决定坚持是事莫为他击。汝等取胜我当相助。以是因缘故。未破比丘便破。已破者不可和合。未起事便起。已起事不可灭。如是呵已向佛广说。佛以是事集比丘僧。知而故问般茶卢伽比丘。汝等实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘。喜斗诤相言。知是斗诤相言便到其所言。汝等决定坚持是事莫为他击。汝等取胜我当相助。复语第二部言。汝等决定坚持是事莫为他击汝等。取胜我当相助以是因缘故。未破比丘便破。已破者不可和合。僧中未起事便起。已起事不可灭。如是呵已语诸比丘。汝等与般茶卢伽比丘作苦切羯磨。若更有如是人者。亦应与作苦切羯磨。若比丘于三事中有犯。应与作苦切羯磨。若破戒若破正见若破威仪。复有三事。应与作苦切羯磨。喜斗喜诤喜相言。有三种。作苦切羯磨。非法非比尼。可破人不现前作。不先说其事作。不令忆念作。有三种如法。不可破人现前作。先说其事作。令忆念作。有三种。可破非法作。别众作。人不现前作。有三种。不可破如法作。和合僧作。人现前作。有三种。可破非法作。别众作。不先说其事作。有三种。不可破如法作。和合僧作。先说其事作。有三种。可破非法作。别众作。不令忆念作。有三种。不可破如法作。和合僧作。令忆念作。复有三种。非法非比尼。可破与不犯罪人作。与犯不可悔过作。与已悔过作。有三种如法。不可破为犯罪人作。为犯可悔过作。与未悔过作。有三种可破不如法作。别众作。与不犯罪作。有三种不可破如法作。和合僧作。为犯罪作。有三种。可破非法作。别众作。不为可悔过作。有三种。不可破如法作。和合僧作。为犯可悔过作。有三种。可破非法作。别众作。与已悔过作。有三种。不可破如法作。和合僧作。与未悔过作。苦切羯磨法者。一心和合僧。一比丘僧中唱言。大德僧听。是般茶卢伽比丘。喜斗诤相言。知是斗诤比丘。便到其所言。汝等坚持是事莫为他击。汝等取胜我当相助。复语第二部比丘言。汝等坚持是事莫为他击。汝等取胜我当相助。以是因缘故。未破比丘便破。已破者不可和合。僧中未起事便起。已起事不可灭。若僧时到僧忍听。僧与般茶卢伽比丘作苦切羯磨。随汝般茶卢伽比丘几时作不清净行恶口不止。随尔所时。僧与汝等作苦切羯磨。是名白。如是白四羯磨。僧与般茶卢伽比丘作苦切羯磨竟。僧忍默然故。是事如是持。得苦切羯磨比丘行法者。是比丘不应与他受大戒。不应受他依止。不得畜沙弥。不得受教诫比丘尼羯磨。若先受不应教诫不应重犯苦切羯磨罪。不应作相似罪。不应作过是罪。不应呵诸羯磨。不应呵作羯磨人。不应出清净比丘过罪。不应从他乞听。不应言我当出汝罪。不应遮布萨自恣。不应违逆清净比丘。应折伏心如法恭敬。若不如是法行者。尽形不得离是苦切羯磨。即时诸比丘。受佛教小却一面。与般茶卢伽比丘作苦切羯磨。般茶卢伽比丘。得苦切羯磨已。心悔折伏恭敬柔软。从僧乞解苦切羯磨。诸比丘以是事白佛。佛语诸比丘。若般茶卢伽心悔折伏。僧应与解。若更有如是人者。亦应与解。若比丘不如法行。僧不应与解苦切羯磨。若与他受大戒。与他作依止畜沙弥。若受教诫比丘尼羯磨。若教诫比丘尼。若重犯罪。若作相似罪。若作过是罪。若呵羯磨。若呵羯磨人。若从他乞听。出清净比丘罪。若言我当出汝罪。若遮说布萨自恣。违逆清净比丘。不心悔折伏不柔软。不应与解。若如法行。僧应与解苦切羯磨。不与他受大戒。不与他作依止。不畜沙弥。不受教诫比丘尼。若已羯磨。不教诫比丘尼。不重犯罪。不作相似罪。不作过是罪。不呵羯磨。不呵羯磨人。不从他乞听。不出清净比丘罪。不言我当出汝罪。不遮布萨自恣。不违逆清净比丘。若心悔折伏柔软。应与解苦切羯磨。解苦切羯磨法者。一心和合僧。般茶卢伽比丘从坐起。偏袒右肩脱革屣胡跪合掌。作是言。大德僧念。我般茶卢伽比丘。喜斗诤相言。知是斗诤相言比丘。便到其所言。汝等坚持是事莫为他击。汝等取胜我当相助。复语第二部比丘言。汝等坚持是事莫为他击。汝等取胜我当相助。以是因缘故。未破比丘便破。已破者不可和合。僧中未起事便起。已起事不可灭。故僧与我等作苦切羯磨。我等得苦切羯磨。心悔折伏。今从僧乞解苦切羯磨。我等般茶卢伽比丘。今心悔折伏。僧怜愍故。与我等解。第二第三亦如是乞。即时一比丘僧中唱言。大德僧听。是般茶卢伽比丘。喜斗诤相言。知是斗诤比丘。便到其所言。汝等坚持是事。莫为他击。汝等取胜我当相助。复语第二部比丘言。汝等坚持是事。莫为他击。汝等取胜我当相助。以是因缘故。未破比丘便破。已破者不可和合。僧中未起事便起。已起事不可灭。故僧与作苦切羯磨。是般茶卢伽比丘。得苦切羯磨故。心悔折伏。今从僧乞解苦切羯磨。若僧时到僧忍听。僧般茶卢伽比丘解苦切羯磨。是名白。如是白四羯磨。僧与般茶卢伽比丘解苦切羯磨竟。僧忍默然故。是事如是持

佛在舍卫国。尔时施越比丘。数数犯罪数数悔过。无有齐限。诸比丘以是事白佛。佛语诸比丘。汝等与施越比丘作依止羯磨。若更有如是比丘。亦应与作依止羯磨。佛言。比丘三事中有犯。应与作依止羯磨。若破戒若破见若破威仪。复有三种。喜斗喜诤喜相言。有三种。作依止羯磨。非法非比尼。可破人不现前作。不先说其罪作。不令忆念作。有三种。作依止羯磨。如法如比尼。不可破人现前作。先说其罪作。令忆念作。有三种。可破非法作。别众作。人不现前作。有三种。不可破如法作。和合众作。人现前作。有三种。可破非法作。别众作。不先说其罪作。有三种。不可破如法作。和合僧作。先说其罪作。有三种。可破非法作。别众作。不令忆念作。有三种。不可破如法作。和合僧作。令忆念作。有三种。可破与不犯罪作。为不可悔过作。与已悔过作。有三种。不可破为犯作。为可悔过作。与未悔过作。有三种。可破非法作。别众作。与不犯作。有三种。不可破如法作。和合僧作。为犯作。有三种。可破非法作。别众作。为不可悔过作。有三种。不可破如法作。和合僧作。为可悔过作。有三种。可破非法作。别众作。为已悔过作。有三种。不可破如法作。和合僧作。与未悔过作。依止羯磨有二种。一应教汝依止某甲住。二者应说依止羯磨法。依止羯磨法者。一心和合僧。一比丘众中唱言。大德僧听。是施越比丘。数数犯罪。数数忏悔。无有齐限。若僧时到僧忍听。僧与施越比丘作依止羯磨。随汝施越几时作不清净行不随顺道。随尔所时。僧与汝作依止羯磨。是名白。如是白四羯磨。僧与施越比丘作依止羯磨竟。僧忍默然故。是事如是持。得依止羯磨比丘行法者。不应与他受大戒。不应受他依止。不得畜沙弥。不得受教诫比丘尼羯磨。若先受不应教诫。不应重犯罪。不应作相似罪。不应作过是罪。不应呵羯磨。不应呵作羯磨人。不应出清净比丘过罪。不应从他乞听。不应言我当出汝罪。不应遮布萨自恣。不应违逆清净比丘。即时诸比丘。受佛教小却一面。与施越比丘作依止羯磨。施越得羯磨故。心悔折伏柔软。从僧乞解依止羯磨。诸比丘以是事白佛。佛语诸比丘。若施越比丘心悔折伏。僧应与解。若更有如是人者。亦应与解。若比丘不如法行。僧不应与解依止羯磨。若与他受大戒。与他作依止。畜沙弥。若受教诫比丘尼羯磨。若先受不应教诫比丘尼。若重犯罪。若作相似罪。若作过是罪。若呵羯磨。若呵羯磨人。若从他乞听。若出清净比丘罪。若言我当出汝罪。若遮布萨自恣。违逆清净比丘。若不心悔折伏柔软。不应与解。若如法行。僧应与解依止羯磨。不与他受大戒。不与他依止。不畜沙弥。不受教诫比丘尼羯磨。若先受不应教诫比丘尼。不重犯罪。不作相似罪。不作过是罪。不呵羯磨。不呵羯磨人。不从他乞听不出清净比丘罪。不言我当出汝罪。不遮布萨自恣。不违逆清净比丘。若心悔折伏柔软。应与解依止羯磨。解依止羯磨法者。一心和合僧。施越比丘从坐起。偏袒右肩脱革屣胡跪合掌。作是言大德僧念。我施越比丘。数数犯罪数数悔过。无有齐限。故僧与我作依止羯磨。我得依止羯磨故。心悔折伏。今从僧乞解依止羯磨。僧怜愍故。与我解。第二第三亦如是乞。即时一比丘僧中唱言。大德僧听。是施越比丘。数数犯罪数数悔过。无有齐限僧与作依止羯磨。是施越比丘。得依止羯磨故。心悔折伏。今从僧乞解依止羯磨。若僧时到僧忍听。僧与施越比丘解依止羯磨。是名白。如是白四羯磨。僧与施越比丘解依止羯磨竟。僧忍默然故。是事如是持

佛在舍卫国。尔时黑山国土。有马宿满宿二比丘。污他家行恶行。污他家皆见皆闻皆知。行恶行亦见亦闻亦知。是比丘共女人一床坐。共一盘食共器饮酒。中后食共食宿啖宿食。不受而食不受残食法。鼓簧捻唇作音乐声。齿作伎乐弹铜杅。弹多罗树叶。作余种种伎乐歌舞。着鬘璎珞以香涂身。着香薰衣以水相洒。自手采华亦使人采。自贯花鬘亦使人贯。自头上着华亦使人着。自着耳环亦使人着。自将他妇女去若使人将去。若令象斗马斗车斗步斗羊斗水牛斗狗斗鸡斗男斗女斗。亦自共斗手打脚蹋四向驰走。变易服饰驰行跳踯。水中浮没破截树木。打臂拍髀啼哭大唤或啸谬语诸异国语。踯绝反行如鱼婉转。掷物空中还自接取。与女人共大船上载令作伎乐。乘象马车舆。与多人众吹贝。导道入园林中。作如是种种恶不净事。诸比丘以是事白佛。佛语诸比丘。汝等与马宿满宿比丘作驱出羯磨。若更有如是比丘。亦应与作驱出羯磨。佛言。比丘于三事中有犯。僧应与作驱出羯磨。若破戒破见破威仪。有三种。应作驱出羯磨。喜斗喜诤喜相言。有三种。非法非比尼。作驱出羯磨。可破人不现前作。不先说其罪作。不令忆念作有三种。如法如比尼。作驱出羯磨。不可破人现前作。先说其罪作。令忆念作。有三种。可破非法作。别众作。人不现前作。有三种。不可破如法作。和合僧作。人现前作。有三种。可破非法作。别众作。不先说其罪作。有三种。不可破如法作。和合僧作。先说其罪作。有三种。可破非法作。别众作。不令忆念作。有三种。不可破如法作。和合僧作。令忆念作。有三种。作驱出羯磨可破与不犯罪作。为不可悔过作。与已悔过作。有三种。作驱出羯磨。不可破为犯罪作。为可悔过作。与未悔过作。有三种。可破非法作。别众作。与不犯罪作。有三种。不可破如法作。和合僧作。为犯罪作。有三种。可破非法作。别众作。为不可悔过作。有三种。不可破如法作。和合僧作。为可悔过作。有三种。可破非法作。别众作。与已悔过作。有三种。不可破如法作。和合僧作。与未悔过作驱出羯磨。驱出羯磨法者。一心和合僧。一比丘应僧中唱言。大德僧听。是马宿满宿比丘。污他家行恶行。污他家皆见皆闻皆知。行恶行亦见亦闻亦知。僧今与某甲作驱出羯磨。若僧时到僧忍听。僧与马宿满宿比丘作驱出羯磨。随汝马宿满宿几时不舍是不清净行。随尔所时。与汝作驱出羯磨。是名白。如是白四羯磨。僧与马宿满宿比丘作驱出羯磨竟。僧忍默然故。是事如是持。得驱出羯磨比丘行法者。不应与他受大戒。不得受他依止。不得畜沙弥。不得受教诫比丘尼羯磨。若先受不应教诫。不应重犯得驱出羯磨罪。不应作相似罪。不得作过是罪。不应呵羯磨。不应呵作羯磨人。不应出清净比丘过罪。不应从他乞听。不应言我当出汝罪。不应遮布萨自恣。不应违逆清净比丘。应折伏心如法恭敬。若不如是法行者。尽形寿不得离驱出羯磨。即时诸比丘。受佛教小却一面。与马宿满宿作驱出羯磨。马宿满宿得驱出羯磨故。心悔折伏柔软。从僧乞解驱出羯磨。诸比丘以是事白佛。佛语诸比丘。若马宿满宿比丘心折伏者。僧应与解。若更有如是人。僧亦应与解。若比丘不如法行。僧不应与解驱出羯磨。若与他受大戒。与他作依止畜沙弥。若受教诫比丘尼羯磨。若教诫比丘尼。若重犯罪。若作相似罪。若作过是罪。若呵羯磨。若呵羯磨人。若从他乞听。若出清净比丘罪。若言我当出汝非。若遮布萨自恣。违逆清净比丘。不心悔折伏柔软。不应与解。若如法行。僧应与解驱出羯磨。不与他受大戒。不与他作依止。不畜沙弥。不受教诫比丘尼羯磨。不教诫比丘尼。不重犯罪。不作相似罪。不作过是罪。不呵羯磨不。呵羯磨人。不从他乞听。不出清净比丘罪。不言我出汝罪。不遮布萨自恣。不违逆清净比丘。若心悔折伏柔软。应与解驱出羯磨。解驱出羯磨法者。一心和合僧。马宿满宿比丘从坐起。偏袒右肩脱革屣胡跪合掌。作是言。大德僧忆念。我马宿满宿比丘。污他家行恶行。污他家皆见皆闻皆知。行恶行亦见亦闻亦知。故僧与我作驱出羯磨。我等得驱出羯磨故。心悔折伏。今从僧乞解驱出羯磨。僧怜愍故与我等解。第二第三亦如是乞。即时一比丘僧中唱言。大德僧听。是马宿满宿比丘。污他家行恶行。污他家皆见皆闻皆知。行恶行亦见亦闻亦知。僧与作驱出羯磨。是马宿满宿比丘。得驱出羯磨故。心悔折伏。今从僧乞解驱出羯磨。若僧时到僧忍听。僧与马宿满宿比丘解驱出羯磨。是名白。如是白四羯磨。僧与马宿满宿比丘作解驱出羯磨竟。僧忍默然故。是事如是持

佛在舍卫国。尔时迦尸国有聚落。名磨叉止陀。是中有豪贵居士。名曰质多罗。饶财多宝田宅人民奴婢眷属。是人归依佛法僧。不疑佛法僧。不疑苦集尽道。见谛得道。于磨叉止陀聚落庵罗林中。起僧房请比丘僧。愿诸大德。于此庵罗林僧房中住。我当供养衣钵户钩时药夜分药七日药尽形药。亦能教读诵经法答所问疑。唯除比尼。时有比丘。名郁多罗。于质多罗居士庵罗林中。作僧房摩摩帝帝帝陀罗。尔时有优波斯那比丘和檀提子。与大比丘众五百人俱。皆阿练儿纳衣乞食。乐处空地来去坐立。饮食衣钵威仪清净。起人敬心。游行迦尸国。到磨叉止陀聚落。质多罗居士。见是客比丘来去坐立。饮食衣钵威仪清净。即起敬心清净。因是客比丘故。请僧明日到自舍食。时僧房主。闻质多居士不先语我因客比丘故请僧舍食。我是质多居士庵罗林中摩摩帝帝帝陀罗僧房主。质多居士不问我。因客比丘故请僧舍食。过是夜已。我当共是居士语。是郁多罗比丘作是思惟。至地了着衣持钵到是居士舍。见办种种多美饮食敷种种杂色坐具。问言。何以无胡麻欢喜丸。居士答言。我今乐说一喻。若听者当说之。大德郁多罗。北方有估客众。担鸡东方市易。有乌来下。与鸡共合生子。鸣时亦不能作鸡声。复不能作乌声。设欲鸣时作鸡乌声。郁多罗。汝亦复如是。虽种种说佛法善语。又说恶语。郁多罗比丘言。汝呵骂我。此是汝庵罗僧房。还以相付。我当往东方诣佛所供养亲侍。居士言。大德。住我僧房中。我当尽形供给衣钵户钩时药夜分药七日药尽形药。又当教读诵经法答所问疑。唯除比尼。是比丘再三语居士言。汝呵骂我。此是汝庵罗僧房。还以相付。我往东方诣佛所供养亲侍。是居士又第二第三请言。郁多罗。住我僧房中。当尽形供养衣钵户钩时药夜分药七日药尽形药。又当教读诵经法答所问疑。唯除比尼。尔时郁多罗比丘。欲往东方诣佛所。时居士语言。汝所说事及我所说。具向佛说莫得增减。汝今不受我请。后必还来。郁多罗比丘即持衣钵游行。向舍卫国诣佛所。头面礼佛足在一面立。诸佛常法。有客比丘来。以是语言问讯。可忍可足安乐住不。乞食不难道路不疲极耶。佛以是语问讯郁多罗比丘。可忍可足安乐住不。乞食不难。道路不疲极耶。答言世尊。可忍可足安乐住。乞食不难道路不疲极。以是事向佛广说。佛闻已语诸比丘。汝等与郁多罗比丘作下意羯磨令向质多罗居士下意忏悔。若更有如是人。僧亦应与作下意羯磨。若比丘三事中有犯。应与作下意羯磨。破戒破见破威仪。又三种。应与作下意羯磨。喜斗喜诤喜相言。若比丘有五法。僧应与作下意羯磨。若比丘呵责佛。若呵法若呵僧。若破戒若破威仪。又有五法。僧应与下意羯磨。若恶口向白衣若骂白衣。若毁呰白衣家。若别离白衣家。若方便求驱白衣出。欲令得衰恼。复有五法。僧应与作下意羯磨。恶口向比丘骂比丘。毁呰比丘。破比丘利养。求方便驱比丘出。令得衰恼。复有五法。僧应与作下意羯磨。教白衣共白衣斗。教白衣共比丘斗。教比丘共比丘斗。教比丘共白衣斗。说白衣所不喜事。僧作下意羯磨。作下意羯磨时。先应思惟三事。是居士所说为实不实。此比丘能作是事不。是比丘可令下意不。如是思惟已。然后作下意羯磨。作下意羯磨法者。一心和合僧。一比丘唱言。大德僧听。质多居士供给僧。如事大家。是郁多罗比丘。现前恶口呵骂。若僧时。到僧忍听。僧与郁多罗比丘作下意羯磨。令向质多居士忏悔。是名白。如是白四羯磨。僧与郁多罗比丘作下意羯磨。令向质多居士忏悔竟。僧忍默然故。是事如是持。尔时僧应遣一堪能比丘。将郁多罗比丘。到质多罗居士所。语居士言。是比丘现前恶口呵骂汝。僧已如法治。汝今听是比丘忏悔。若受忏悔者。即时令是居士离闻处着可见处。郁多罗比丘。应向是比丘作突吉罗忏悔。若是居士不受者。僧尔时应更与二堪能比丘语居士言。郁多罗比丘现前恶口呵骂汝。僧已如法治。汝当受忏悔。若受者即令居士离闻处住可见处。郁多罗比丘。应向二比丘作突吉罗忏悔。若复不受者。尔时僧即更受与若三若四堪能比丘语居士。是比丘现前恶口呵骂汝。僧已如法治。汝当受忏悔过。若受者即。令居士离闻处住可见处。郁多罗比丘。应向是诸比丘作突吉罗忏悔。若复不受者。若是居士多知多识。有大势力有官力贼力。自能作恶事恼乱众僧。若令人作。僧应语是比丘言。是居士多知多识。有官力有贼力。能自作恶事。亦能令人作。汝当离是住处去。若是比丘强住者。众僧无罪

佛在俱舍弥。尔时车匿比丘。犯可悔过罪。诸比丘怜愍欲益利安乐故。语其罪。教令如法见罪悔过。莫覆藏。车匿言。我不见罪。云何悔过。诸比丘以是事向佛广说。佛语诸比丘。汝等与车匿作不见摈。若更有如是比丘。亦应与作。若比丘三事中有犯。应与作不见摈。破戒破见破威仪。复有三事。僧应与作不见摈。喜斗喜诤喜相言。僧欲作不见摈时。先应思惟五事。若我等与是比丘作不见摈。不共布萨说戒自恣。不共作诸羯磨。不共中食。不共带钵那。不得随上座起礼迎送。以是因缘故。斗诤事起相言相骂。僧破僧诤僧别僧异。思惟是五法已。不应作摈。若我等与是比丘作不见摈。不共布萨说戒自恣作诸羯磨。不共中食不共带钵那。不随上座起礼迎送。以是因缘故。不起斗诤相言相骂。僧和合无诤无别无异。思惟是五事已。应与作不见摈。犯罪比丘亦应思惟五事。若诸比丘与我作不见摈。不得共我布萨说戒自恣作诸羯磨。不共中食不共带钵那。不得随上座起礼迎送。何以故。诸比丘乐持戒有惭愧。不能为我故随爱随嗔随怖随痴行。思惟是法已。应受不见摈。作不见摈羯磨法者。一心和合僧。一比丘僧中唱言。大德僧听。是车匿比丘。犯罪不如法见。若僧时到僧忍听。僧与车匿比丘作不见摈。随汝车匿几时犯罪不如法见。僧随尔所时。与汝作不见摈。诸比丘不共汝作羯磨。不共汝住于僧事中。若白羯磨白二羯磨白四羯磨布萨自恣。不得入十四人数。不与汝共事共住。猒恶汝如旃陀罗。是名白。如是白四羯磨。僧与车匿比丘作不见摈羯磨竟。僧忍默然故。是事如是持。得不见摈比丘行法者。不应与他受大戒。不应受他依止。不应畜沙弥。不应受教诫比丘尼羯磨。若先受不应教诫。不应重犯罪。不应作相似罪。不应作过是罪。不应呵羯磨。不应呵羯磨人。不应受清净比丘起礼迎送供养衣钵卧具洗脚拭脚脚机。若无病不应受他按摩。心悔折伏柔软。佛言。若不如是法行者。尽形不得离是羯磨。即时诸比丘。受佛教已小远一面。与车匿比丘作不见摈羯磨。作不见摈羯磨已。车匿比丘心不折伏。作是言。我何豫汝等事。我不数汝等。作是语已便持衣钵。向鸯伽国摩竭国迦尸国憍萨罗国鸠留国般阇罗国阿叶摩伽阿般提国。从一住处至一住处。诸国土比丘闻车匿被摈。不共作羯磨。若白羯磨白二羯磨白四羯磨布萨自恣。不入立十四人数。不得共事。猒恶如旃陀罗。皆不共住不共事。还来俱舍弥国。心悔折伏。从僧乞解不见摈。诸比丘以是事白佛。佛语诸比丘。汝等与车匿比丘解不见摈。若更有如是人。亦应与解。若比丘不如法行者。僧不应与解不见摈。若与他受大戒。与他作依止。若畜沙弥。若受教诫比丘尼羯磨。若教诫比丘尼。若重犯罪。若作相似罪。若作过是罪。若诃羯磨若呵羯磨人。若受清净比丘起礼迎送供养衣钵卧具洗脚拭脚脚机。若不病受他按摩。若作白衣相。若作外道相。若与外道共事。不应作便作。不学比丘戒。呵骂比丘。恶口向比丘。毁呰比丘。作方便令僧失住处失供养。欲折伏界内界外比丘。喜斗诤相言。心不折伏不恭敬柔软。若如是行者。不应与解不见摈。若得不见摈比丘。不与他受大戒。不与他作依止。不畜沙弥。不受教诫比丘尼。羯磨。不教诫比丘尼。不重犯罪。不作相似罪。不作过是罪。不呵羯磨。不呵羯磨人。不受清净比丘起礼迎送供养衣钵卧具。不受洗脚拭脚脚机。若不病不应受他按摩。不作白衣相外道相。不与外道共事。作所应作。学比丘戒。不呵骂比丘。不恶口向比丘。不毁呰比丘。不作方便令僧失住处失供养。不欲折伏界内界外比丘。不喜斗诤相言。心悔折伏恭敬柔软。若如是行者。应与解不见摈。解不见摈法者。一心和合僧。车匿比丘。应从坐起偏袒右肩脱革屣胡跪合掌作是言。大德僧念。我车匿。犯可悔过罪。不如法见故。僧与我作不见摈。诸比丘不与我共事共住作白羯磨白二羯磨白四羯磨布萨自恣及诸羯磨。不得入立十四人数。厌恶我如旃陀罗。今我车匿。已心悔折伏柔软。从僧乞解不见摈羯磨。僧怜愍故。与我解。第二第三亦如是乞。即时一比丘僧中唱言。大德僧听。是车匿比丘。犯罪不如法见。僧与作不见摈羯磨。诸比丘不与共事共住作白羯磨白二羯磨白四羯磨布萨自恣。不得入十四人数。厌恶如旃陀罗。车匿比丘。今心悔折伏。从僧乞解不见摈羯磨。若僧时到僧忍听。与车匿比丘解不见摈羯磨。是名白。如是白四羯磨。僧与车匿比丘解不见摈羯磨竟。僧忍默然故。是事如是持

佛在俱舍弥国。尔时长老车匿。犯可悔过罪。诸比丘怜愍欲利益安乐故。语其过罪。教令如法悔过。答言。我见是罪。不能如法悔过。诸比丘以是事白佛。佛语诸比丘。汝等与车匿。作不作摈羯磨。若更有如是人。亦应与作。佛言。若比丘三事中随犯。应与作不作摈羯磨。若破戒若破见若破威仪。应与不作摈。复有三事。僧应与不作摈。喜斗喜诤喜相言。僧欲作不作摈时。先应思惟五事。若我等与是比丘作不作摈。不共布萨作诸羯磨。不共中食。不共带钵那。不随上座起礼迎送。以是因缘故。斗诤事起相言相骂。僧破僧诤僧别僧异。思惟是五法已。不应作摈。若我等与是比丘作不作摈。不共布萨作诸羯磨。不共中食带钵那。不随上座起礼迎送。以是因缘故。不起斗诤相言相骂。僧和合无诤无别无异。思惟是五法已。应与作摈。犯罪比丘亦应思惟五法。是诸比丘与我作不作摈。不得共我布萨自恣作诸羯磨。不共中食带钵那。不随上座起迎礼拜。何以故。诸比丘乐持戒有惭愧。不能为我故随爱随嗔随怖随痴行。思惟是五法已。应受不作摈羯磨。不作摈羯磨法者。一心和合僧。一比丘僧中唱言。大德僧听。是车匿比丘。犯罪见罪。不能如法悔过。若僧时到僧忍听。僧与车匿比丘作不作摈。随汝车匿几时犯罪见罪不能如法悔过。僧随尔所时。与汝作不作摈。诸比丘不共汝作诸羯磨。若白羯磨白二羯磨白四羯磨布萨自恣。不得入立十四人数。不与汝共事共住。厌恶汝如旃陀罗。是名白。如是白四羯磨。僧与车匿比丘作不作摈羯磨竟。僧忍默然故。是事如是持。得不作摈比丘行法者。不应与他受具戒。不应与他作依止。不应畜沙弥。不应受教诫比丘尼羯磨。若先受不应教诫。不应重犯罪。不应作相似罪。不应作过是罪。不应呵羯磨。不应呵羯磨人。不应出清净比丘过。不应受清净比丘起礼迎送供养衣钵卧具。不应受洗脚拭脚脚机供养。除病不应受他按摩。应心悔折伏柔软。佛言。若不如是法行者。尽形不得离是羯磨。即时诸比丘。受佛教小却一面。与车匿比丘作不作摈羯磨已。车匿比丘心不折伏。作是言。我何豫汝等事。我不数汝等。作是语已便持衣钵。向鸯伽国摩竭国迦尸国憍萨罗国鸠留国阿叶磨伽阿般提国。从一住处至一住处。诸国土比丘。闻车匿比丘被摈。诸比丘不共作羯磨不共住。于众事中若白羯磨白二羯磨白四羯磨布萨自恣。不得入立十四人数。不得共事共住。厌恶如旃陀罗。皆不共住共事。车匿比丘还俱舍弥国。心悔折伏。从僧乞解不作摈羯磨。诸比丘以是事白佛。佛语诸比丘。汝等与车匿比丘解不作摈。若更有如是人。亦应与解。若摈比丘不如行法者。僧不应与解。若与他受具戒。与他作依止。若畜沙弥。若受教诫比丘尼羯磨。若教诫比丘尼。若重犯罪。若作相似罪。若作过是罪。若呵羯磨。若呵羯磨人。若受清净比丘起礼迎送供养衣钵卧具洗脚拭脚脚机。若不病受他按摩。若作白衣相。作外道相。若与外道共事。不应作便作。不学比丘戒。呵骂比丘。恶口向比丘。毁呰比丘。作方便令僧失住处失供养。欲折伏界内界外比丘。喜斗诤相言。心不悔折伏恭敬柔软。若不如是行者。不应与解不作摈。若得不作摈比丘。不与他受具戒。不与他作依止。不畜沙弥。不受教诫比丘尼羯磨。不教诫比丘尼。不重犯罪。不作相似罪。不作过是罪。不呵羯磨。不呵羯磨人。不受清净比丘起礼迎送供养衣钵卧具洗脚拭脚脚机不病不受按摩。不作白衣相。不作外道相。不与外道共事。作所应作学比丘戒。不呵骂比丘。不恶口向比丘。不毁呰比丘。不作方便令僧失住处失供养。不欲折伏界内界外比丘。不喜斗诤相言。心悔折伏恭敬柔软。若如是行者。应与解不作摈。解不作摈法者。一心和合僧。车匿比丘。应从坐起偏袒右肩脱革屣胡跪合掌作是言。大德僧忆念。我车匿犯罪见罪不能如法悔故。僧与我作不作摈。诸比丘不与我共事共住作白羯磨白二羯磨白四羯磨布萨自恣。不得入立十四人数。厌恶我如旃陀罗。我车匿。今心悔折伏柔软从僧乞解不作摈羯磨。僧怜愍故。与我解。第二第三亦如是乞。即时一比丘僧中唱言。大德僧听。是车匿比丘。犯罪见罪不能如法悔过。僧与作不作摈羯磨。诸比丘不与共事共住共作白羯磨白二羯磨白四羯磨布萨自恣。不得入立十四人数。厌恶如旃陀罗。车匿比丘。得是羯磨故。心悔折伏柔软。从僧乞解不作摈羯磨。若僧时到僧忍听。与车匿比丘解不作摈羯磨是名白。如是白四羯磨。僧与车匿比丘解不作摈羯磨竟。僧忍默然故。是事如是持

佛在舍卫国。尔时阿利吒比丘。生恶邪见言。我如是知佛法义。佛所说障法行。是障法不能障道。诸比丘以是事白佛。佛语诸比丘。汝等与阿利吒比丘作不舍恶邪见摈。若更有如是人。亦应与作。佛言。若比丘三事中有犯应与作恶邪不除摈。若破戒若破见若破威仪。复有三事。喜斗喜诤喜相言。僧与作恶邪不除摈。尔时先应思惟五法。若我等与是比丘作恶邪不除摈。不共布萨自恣作诸羯磨。不共中食带钵那。不随上座起礼迎送。以是因缘故。斗诤事起相言相骂。僧破僧诤僧别僧异。思惟是事已。不应作摈。若我与是比丘作恶邪不除摈。不共布萨作诸羯磨。不共中食带钵那。不随上座起礼迎送。以是因缘故。不起斗诤相言相骂。僧和合无诤无别无异。思惟是事已。应与作摈。犯罪比丘亦应思惟五事。是诸比丘与我作恶邪不除摈。不得共我布萨作诸羯磨。不得共我中食带钵那。不随上座起礼迎送。何以故。诸比丘有惭愧乐持戒。不能为我故随爱随嗔随怖随痴行。思惟是事已。应受恶邪不除摈。恶邪不除摈法者。一心和合僧。一比丘僧中唱言。大德僧听。是阿利吒比丘生恶邪见言。我如是知佛法义。佛所说障法行。是障法不能障道。若僧时到僧忍听。僧与阿利吒比丘作恶邪不除摈。汝阿利吒。随汝几时生恶邪见不如法悔过。僧随尔所时。与汝作恶邪不除摈。诸比丘不共汝作羯磨。不共汝住于僧事中。若白羯磨白二羯磨白四羯磨布萨自恣。不得入十四人数。不与汝共事共住。厌恶汝如旃陀罗。是名白。如是白四羯磨。僧与阿利吒比丘作恶邪不除摈羯磨竟。僧忍默然故。是事如是持。恶邪不除摈比丘行法者。不应与他受具戒。不应与他作依止。不应畜沙弥。不应受教诫比丘尼羯磨。若先受者不应教诫。不应重作罪。不应作相似罪。不应作过是罪。不应呵羯磨。不应呵羯磨人。不应受清净比丘起礼迎送供养衣钵卧具洗脚拭脚脚机。若不病不应受他按摩。应悔心折伏柔软。佛言。若得摈比丘不如是行者。尽形不得离是羯磨。即时诸比丘。受佛教已小却一面。与阿利吒比丘作恶邪不除摈。心悔折伏柔软。从僧乞解。诸比丘以是事白佛。佛语诸比丘。汝等与阿利吒比丘解恶邪不除摈。若更有如是人。亦应与解。若摈比丘。不如恶邪不除摈行法者。僧不应与解。若与他受具戒。与他作依止。若畜沙弥。若受教诫比丘尼羯磨。若教诫比丘尼若重犯罪。若作相似罪。若作过是罪。若呵羯磨。若呵羯磨人。若受清净比丘起礼迎送供养衣钵卧具洗脚拭脚脚机。若不病不应受他按摩。若作白衣相作外道相。若与外道共事。不应作便作。不学比丘戒。呵骂比丘。恶口向比丘。毁呰比丘。作方便令僧失住处失利养。欲折伏界内界外比丘。喜斗诤相言。心不折伏恭敬柔软。若如是行者。不应与解。若摈比丘。不与他受具戒。不与他作依止。不畜沙弥。不受教诫比丘尼羯磨。不教诫比丘尼。不重犯罪。不作相似罪。不作过是罪。不呵羯磨。不呵羯磨人。不受清净比丘起礼迎送供养衣钵卧具洗脚拭脚脚机。不病不应受他按摩。不作白衣相外道相。不与外道共事。作所应作。学比丘戒。不呵骂比丘。不恶口向比丘。不毁呰比丘。不作方便令僧失住处失利养。不欲折伏界内界外比丘。不喜斗诤相言。心悔折伏恭敬柔软。若如是行者。应与解恶邪不除摈。解恶邪不除摈法者。一心和合僧。阿利吒比丘。应从坐起偏袒右肩脱革屣胡跪合掌作是言。大德僧忆念。我阿利吒生恶邪见。作如是言。我知佛法义。佛所说障法行。是障法不能障道故僧与我作恶邪不除摈。诸比丘不与我共事共住作白羯磨白二羯磨白四羯磨布萨自恣。不得入十四人数。厌恶我如旃陀罗。我阿利吒。今心悔折伏柔软。从僧乞解恶邪不除摈羯磨僧怜愍故。与我解。第二第三亦如是乞。即时一比丘僧中唱言。大德僧听。是阿利吒比丘生恶邪见。作如是言。我知佛法义。佛说障法行。是障法不能障道。僧与作恶邪不除摈羯磨。诸比丘不与共事共住作白羯磨白二羯磨白四羯磨布萨自恣。不得入十四人数。厌恶如旃陀罗。阿利吒比丘。得是羯磨故。心悔折伏柔软。从僧乞解恶邪不除摈羯磨。若僧时到僧忍听。与阿利吒比丘解恶邪不除摈羯磨。是名白。如是白四羯磨。僧与阿利吒比丘解恶邪不除摈羯磨竟。僧忍默然故。是事如是持

(八法般茶卢伽法第四竟)

十诵律卷第三十一十诵律卷第三十二(第五诵之四)

        后秦北印度三藏弗若多罗译

    悔法第五(八法中苦切羯磨第四之余)

佛在舍卫国。尔时迦留陀夷比丘。故出精。犯一僧伽婆尸沙罪。不覆藏。语诸比丘言。大德。我故出精。犯一僧伽婆尸沙罪。不覆藏我当云何。诸比丘。以是事白佛。佛语诸比丘。迦留陀夷比丘。故出精犯一僧伽婆尸沙罪。不覆藏。应与作六夜摩那埵羯磨。若更有如是比丘。僧亦应与作。作法者。一心和合僧。是迦留陀夷比丘。从坐起偏袒右肩脱革屣胡跪合掌作是言。大德僧忆念。我迦留陀夷比丘。故出精。犯此僧伽婆尸沙罪。一罪不覆藏。我迦留陀夷比丘。故出精。犯此僧伽婆尸沙罪。一罪不覆藏。我今从众僧乞六夜摩那埵。僧与我迦留陀夷比丘故出精犯此僧伽婆尸沙罪一罪不覆藏。与我六夜摩那埵。怜愍故

第二更说。大德僧忆念。我迦留陀夷比丘。故出精。犯此僧伽婆尸沙罪。一罪不覆藏。我迦留陀夷比丘。故出精。犯此僧伽婆尸沙罪。一罪不覆藏。我今从众僧乞六夜摩那埵。僧与我迦留陀夷比丘故出精犯此僧伽婆尸沙罪一罪不覆藏。与我六夜摩那埵。怜愍故

第三更说。大德僧忆念。我迦留陀夷比丘。故出精。犯此僧伽婆尸沙罪。一罪不覆藏。我迦留陀夷比丘。故出精。犯此僧伽婆尸沙罪。一罪不覆藏。我今从众僧乞六夜摩那埵。僧与我迦留陀夷比丘故出精犯此僧伽婆尸沙罪一罪不覆藏。与我六夜摩那埵怜愍故。即时一比丘僧中唱言。大德僧听。是迦留陀夷比丘。故出精。犯此僧伽婆尸沙罪。一罪不覆藏。是迦留陀夷比丘。故出精。犯此僧伽婆尸沙罪。一罪不覆藏。从僧乞六夜摩那埵。若僧时到僧忍听。是迦留陀夷比丘。故出精犯此僧伽婆尸沙罪一罪不覆藏。与六夜摩那埵。是名白

第一大德僧听。是迦留陀夷比丘。故出精。犯此僧伽婆尸沙罪。一罪不覆藏。是迦留陀夷比丘。故出精。犯此僧伽婆尸沙罪。一罪不覆藏。从僧乞六夜摩那埵。僧迦留陀夷比丘。故出精。犯此僧伽婆尸沙罪。一罪不覆藏。当与六夜摩那埵。谁诸长老忍。迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪不覆藏。当与六夜摩那埵者默然。若不忍便说。是初羯磨。第二我更说。大德僧听。是迦留陀夷比丘。故出精。犯此僧伽婆尸沙罪。一罪不覆藏。是迦留陀夷比丘。故出精。犯此僧伽婆尸沙罪。一罪不覆藏。从僧乞六夜摩那埵。僧是迦留陀夷比丘。故出精犯此僧伽婆尸沙罪。一罪不覆藏。当与六夜摩那埵。谁诸长老忍。迦留陀夷比丘。故出精。犯此僧伽婆尸沙罪。一罪不覆藏。当与六夜摩那埵者默然。若不忍便说。是第二羯磨第三我更说。大德僧听。是迦留陀夷比丘。故出精犯此僧伽婆尸沙罪。一罪不覆藏。是迦留陀夷比丘。故出精。犯此僧伽婆尸沙罪。一罪不覆藏。从僧乞六夜摩那埵。僧迦留陀夷比丘。故出精。犯此僧伽婆尸沙罪。一罪不覆藏。当与六夜摩那埵。谁诸长老忍。迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪不覆藏。当与六夜摩那埵者默然。若不忍说第三羯磨

僧已与迦留陀夷比丘犯此僧伽婆尸沙罪故出精一罪不覆藏六夜摩那埵竟。僧忍默然故。是事如是持

迦留陀夷比丘。僧中行六夜摩那埵竟。语诸比丘言。诸大德。我当云何。诸比丘以是事白佛。佛语诸比丘汝等当与迦留陀夷比丘出罪犯此。僧伽婆尸沙罪故出精一罪不覆藏已。僧中行六夜摩那埵。当与出罪。若更有如是人。亦应与出罪。出罪法者。一心和合僧。是迦留陀夷比丘。应从坐起偏袒右肩脱革屣胡跪合掌作是言。大德僧忆念。我迦留陀夷比丘。故出精。犯此僧伽婆尸沙罪。一罪不覆藏。我先已僧中乞六夜摩那埵。僧已与我六夜摩那埵。我已僧中行六夜摩那埵。我迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪不覆藏。僧中行六夜摩那埵竟。今从僧乞出罪。僧我迦留陀夷比丘。犯僧伽婆尸沙罪。故出精一罪不覆藏。已僧中行六夜摩那埵竟。僧当与我出罪。怜愍故。第二我更说。大德僧忆念。我迦留陀夷比丘。故出精犯此僧伽婆尸沙罪一罪不覆藏。我先已僧中乞六夜摩那埵。僧已与我六夜摩那埵。我已僧中行六夜摩那埵。我迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪不覆藏。僧中行六夜摩那埵竟。今从僧乞出罪。僧我迦留陀夷比丘。犯此僧伽婆尸沙罪。一罪不覆藏。已僧中行六夜摩那埵竟。僧当与我出罪。怜愍故。第三我更说

大德僧忆念。我迦留陀夷比丘。故出精。犯此僧伽婆尸沙罪。一罪不覆藏。我先已僧中乞六夜摩那埵。僧已与我六夜摩那埵。我已僧中行六夜摩那埵。我迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪不覆藏。僧中行六夜摩那埵竟。今从僧乞出罪。僧我迦留陀夷比丘。犯此僧伽婆尸沙罪。一罪不覆藏。已僧中行六夜摩那埵竟。僧当与我出罪。怜愍故。即时一比丘僧中唱言。大德僧听。是迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪不覆藏。先已从僧乞六夜摩那埵。僧与六夜摩那埵。已僧中行六夜摩那埵竟。是迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪不覆藏。僧中已行六夜摩那埵竟。从僧乞出罪。若僧时到僧忍听。僧是迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪不覆藏。已僧中行六夜摩那埵竟。僧今当与出罪。如是白

第一大德僧听。是迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪不覆藏。先已从僧乞六夜摩那埵。僧与六夜摩那埵已。僧中行六夜摩那埵竟。是迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪不覆藏。僧中已行六夜摩那埵竟。今从僧乞出罪。僧迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪不覆藏。已行六夜摩那埵竟。僧当与出罪。谁诸长老忍。是迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪不覆藏。已行六夜摩那埵竟。僧今当与出罪者默然。若不忍便说。是初羯磨

第二我更说。大德僧听。是迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪不覆藏。先已从僧乞六夜摩那埵。僧与六夜摩那埵已。僧中行六夜摩那埵竟。迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪不覆藏。僧中已行六夜摩那埵竟。今从僧乞出罪。僧迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪不覆藏。已行六夜摩那埵竟。僧当与出罪。谁诸长老忍。是迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪不覆藏。已行六夜摩那埵竟。僧今当与出罪者默然。若不忍便说。是第二羯磨

第三我更说。大德僧听。是迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪不覆藏。先已从僧乞六夜摩那埵。僧与六夜摩那埵。已僧中行六夜摩那埵竟。是迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪不覆藏。僧中已行六夜摩那埵竟。今从僧乞出罪。僧迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪不覆藏。已行六夜摩那埵竟。僧当与出罪。谁诸长老忍。是迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪不覆藏。已行六夜摩那埵竟。僧今当与出罪者默然。若不忍便说。是第三羯磨。僧已与迦留陀夷比丘出罪竟。犯此僧伽婆尸沙罪。故出精一罪不覆藏。已僧中行六夜摩那埵竟。僧忍默然故。是事如是持

佛在舍卫国。尔时迦留陀夷比丘故出精。犯一僧伽婆尸沙罪。不覆藏。语诸比丘。我故出精。犯一僧伽婆尸沙罪。不覆藏。我今云何。诸比丘以是事白佛。佛语诸比丘。汝等与迦留陀夷比丘六夜摩那埵。若更有如是人。亦应作。作是法者。一心和合僧。迦留陀夷。从坐起偏袒右肩脱革屣胡跪合掌作是言。大德僧忆念。我迦留陀夷比丘。故出精。犯此僧伽婆尸沙罪。一罪不覆藏。我迦留陀夷比丘。故出精。犯此僧伽婆尸沙罪。一罪不覆藏。我今从僧乞六夜摩那埵。僧与迦留陀夷比丘故出精犯此僧伽婆尸沙罪。一罪不覆藏。与我六夜摩那埵。怜愍故。第二更说。大德僧忆念。我迦留陀夷比丘。故出精。犯此僧伽婆尸沙罪。一罪不覆藏。我迦留陀夷比丘。故出精。犯僧伽婆尸沙罪。一罪不覆藏。我今从僧。乞六夜摩那埵。僧与迦留陀夷比丘故出精犯此僧伽婆尸沙罪一罪不覆藏。与我六夜摩那埵怜愍故。第三更说。大德僧忆念。我迦留陀夷比丘。故出精。犯此僧伽婆尸沙罪。一罪不覆藏。我迦留陀夷比丘。故出精。犯此僧伽婆尸沙罪。一罪不覆藏。我今从僧乞六夜摩那埵。僧与我迦留陀夷比丘故出精犯此僧伽婆尸沙罪。一罪不覆藏。与我六夜摩那埵。怜愍故。即时一比丘僧中唱言。大德僧听。是迦留陀夷比丘。故出精。犯此僧伽婆尸沙罪。一罪不覆藏。是迦留陀夷比丘。故出精。犯此僧伽婆尸沙罪。一罪不覆藏。从僧乞六夜摩那埵。若僧时到僧忍听。是迦留陀夷比丘。故出精。犯此僧伽婆尸沙罪。一罪不覆藏。与六夜摩那埵。是名白。大德僧听。是迦留陀夷比丘。故出精。犯此僧伽婆尸沙罪。一罪不覆藏。是迦留陀夷比丘。故出精。犯此僧伽婆尸沙罪。一罪不覆藏。从僧乞六夜摩那埵。僧迦留陀夷比丘。故出精。犯此僧伽婆尸沙罪。一罪不覆藏。当与六夜摩那埵。谁诸长老忍。与迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪不覆藏。当与六夜摩那埵者默然。若不忍便说。是初羯磨

第二大德僧听。是迦留陀夷比丘。故出精。犯此僧伽婆尸沙罪。一罪不覆藏。是迦留陀夷比丘。故出精。犯此僧伽婆尸沙罪。一罪不覆藏。从僧乞六夜摩那埵。僧是迦留陀夷比丘。故出精。犯此僧伽婆尸沙罪。一罪不覆藏。当与六夜摩那埵。谁诸长老忍。迦留陀夷比丘。故出精。犯此僧伽婆尸沙罪。一罪不覆藏。当与六夜摩那埵者默然。不忍便说。是第二羯磨。第三更说。大德僧听。是迦留陀夷比丘。故出精。犯此僧伽婆尸沙罪。一罪不覆藏。是迦留陀夷比丘。故出精。犯此僧伽婆尸沙罪。一罪不覆藏。从僧乞六夜摩那埵。僧迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪不覆藏。当与六夜摩那埵。谁诸长老忍。迦留陀夷比丘。故出精。犯此僧伽婆尸沙罪。一罪不覆藏。当与迦留陀夷比丘六夜摩那埵者默然。不忍便说。是第三羯磨。僧已忍。与迦留陀夷比丘犯此僧伽婆尸沙罪。故出精一罪不覆藏六夜摩那埵竟。僧忍默然故。是事如是持。是迦留陀夷比丘。行六夜摩那埵时。已过尔所日。尔所日未过。是中故出精。更犯一僧伽婆尸沙罪。不覆藏。迦留陀夷语诸比丘。大德。我故出精。犯一僧伽婆尸沙罪。不覆藏。故从僧乞六夜摩那埵。僧与我六夜摩那埵。我行六夜摩那埵时已尔所日。尔所日未过。是中故出精。更犯一僧伽婆尸沙罪。不覆藏。今当云何诸比丘。以是事白佛。佛语诸比丘。汝等与迦留陀夷比丘行摩那埵时。故出精犯一僧伽婆尸沙罪。不覆藏故。与作本日治。若更有如是人。亦应与作。作法者。一心和合僧。迦留陀夷比丘。从坐起偏袒右肩脱革屣。胡跪合掌作是言。大德僧忆念。我迦留陀夷比丘。故出精犯此僧伽婆尸沙罪。一罪不覆藏。从僧乞六夜摩那埵僧与我六夜摩那埵。我行六夜摩那埵已尔所日。尔所日未过。更犯一僧伽婆尸沙罪。故出精一罪不覆藏。今从僧乞本日治。僧与我迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪不覆藏。僧当与我本日治。怜愍故。第二大德僧忆念。我迦留陀夷比丘。故出精犯此僧伽婆尸沙罪。一罪不覆藏。从僧乞六夜摩那埵。僧与我六夜摩那埵。我行六夜摩那埵已尔所日。尔所日未过。更犯一僧伽婆尸沙罪。故出精一罪不覆藏。今从僧乞本日治。僧我迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪不覆藏。僧当与我本日治。怜愍故。第三更说。大德僧忆念。我迦留陀夷比丘。故出精犯此僧伽婆尸沙罪。一罪不覆藏。从僧乞六夜摩那埵。僧与我六夜摩那埵。我行六夜摩那埵已尔所日。尔所日未过。更犯一僧伽婆尸沙罪。故出精一罪不覆藏。今从僧乞本日治。僧我迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪不覆藏。僧当与我本日治。怜愍故

即时一比丘僧中唱言。

大德僧听。是迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪不覆藏。先已从僧乞六夜摩那埵。僧与六夜摩那埵。行六夜摩那埵已尔所日。尔所日未过。是中更犯此僧伽婆尸沙罪。故出精一罪不覆藏。僧是迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪不覆藏。从僧乞本日治。若僧时到僧忍听。是迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪不覆藏。僧今当与本日治。如是白

大德僧听。是迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪不覆藏。先已从僧乞六夜摩那埵。僧与六夜摩那埵。行六夜摩那埵已尔所日。尔所日未过。是中更犯此僧伽婆尸沙罪。故出精一罪不覆藏。僧是迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪不覆藏。从僧乞本日治。僧迦留陀夷比丘。犯僧伽婆尸沙罪。故出精一罪不覆藏。僧今当与本日治。谁诸长老忍。是迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪不覆藏。当与本日治者默然。若不忍便说。是初羯磨第二更说。大德僧听。是迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪不覆藏。先已从僧乞六夜摩那埵。僧与六夜摩那埵。行六夜摩那埵已尔所日。尔所日未过。是中更犯此僧伽婆尸沙罪。故出精一罪不覆藏。僧是迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪不覆藏。从僧乞本日治。僧迦留陀夷比丘。犯僧伽婆尸沙罪。故出精一罪不覆藏。僧今当与本日治。谁诸长老忍。是迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪不覆藏。当与本日治者默然。若不忍便说。是第二羯磨。第三更说。大德僧听。是迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪不覆藏。先已从僧乞六夜摩那埵。僧与六夜摩那埵。行六夜摩那埵已尔所日。尔所日未过。是中更犯此僧伽婆尸沙罪。故出精一罪不覆藏。僧是迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪不覆藏。从僧乞本日治。僧迦留陀夷比丘。犯僧伽婆尸沙罪。故出精一罪不覆藏。僧今当与本日治。谁诸长老忍。是迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪不覆藏。当与本日治者默然。若不忍便说。是第三羯磨。僧已与本日治竟。迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪不覆藏。僧忍默然故。是事如是持。迦留陀夷比丘。中间犯一罪。行本日治。行六夜摩那埵竟。语诸比丘。我当云何。诸比丘以是事白佛。佛语诸比丘。汝等当与迦留陀夷比丘出罪。中间犯一罪。行本日治。行六夜摩那埵竟。若更有如是人。亦应与出罪。出罪法者。一心和合僧。是迦留陀夷比丘。从坐起偏袒右肩脱革屣。胡跪合掌作是言。大德僧忆念。我迦留陀夷比丘。故出精犯此僧伽婆尸沙一罪不覆藏。从僧乞六夜摩那埵。僧与我六夜摩那埵。我行六夜摩那埵时已尔所日。尔所日未过。中间更犯一罪。我先从僧乞本日治。僧与我本日治。迦留陀夷比丘中间犯一罪。得本日治行六夜。摩那埵竟。今从僧乞出罪。僧与我迦留陀夷比丘中间犯一罪。行本日治行六夜摩那埵竟。当与我出罪。怜愍故

第二大德僧忆念。我迦留陀夷比丘。故出精犯此僧伽婆尸沙罪。一罪不覆藏。从僧乞六夜摩那埵。僧与我六夜摩那埵。我行六夜摩那埵。时已尔所日。尔所日未过。中间犯一罪。我先从僧乞本日治。僧与我本日治。我迦留陀夷比丘。中间犯一罪。行本日治。行六夜摩那埵竟。今从僧乞出罪。僧与我迦留陀夷比丘中间犯一罪。行本日治行六夜摩那埵竟。僧当与我出罪。怜愍故。第三大德僧忆念。我迦留陀夷比丘。故出精。犯此僧伽婆尸沙。一罪不覆藏。从僧乞六夜摩那埵。僧与我六夜摩那埵。我行六夜摩那埵。时已尔所日。尔所日未过。中间犯一罪。我先从僧乞本日治。僧与我本日治。我迦留陀夷比丘。中间犯一罪。行本日治。行六夜摩那埵竟。今从僧乞出罪。僧我迦留陀夷比丘。中间犯一罪。行本日治。行六夜摩那埵竟。僧当与我出罪。怜愍故。即时一比丘僧中唱。大德僧听。是迦留陀夷比丘。故出精犯此僧伽婆尸沙罪。不覆藏。从僧乞六夜摩那埵。僧与六夜摩那埵。僧中行六夜摩那埵。时已尔所日。尔所日未过。是中更犯一罪。故出精。犯此僧伽婆尸沙罪。一罪不覆藏。从僧乞本日治。僧已与本日治。是迦留陀夷比丘。中间犯一罪。已行本日治。已僧中行六夜摩那埵竟。今从僧乞出罪。若僧时到僧忍听。僧是迦留陀夷比丘。中间犯一罪。已行本日治。已僧中行六夜摩那埵竟。僧今当与出罪。如是白

大德僧听。是迦留陀夷比丘。犯僧伽婆尸沙罪。故出精不覆藏。先已从僧乞六夜摩那埵。僧与六夜摩那埵。僧中行六夜摩那埵。时已尔所日。尔所日未过。是中间犯一僧伽婆尸沙罪。故出精不覆藏。先已从僧乞本日治。僧与本日治。是迦留陀夷比丘。是中更犯一罪。行本日治。僧中行六夜摩那埵竟。从僧乞出罪僧迦留陀夷比丘。是中犯一罪。行本日治竟。已行六夜摩那埵竟。当与出罪。谁诸长老忍。是迦留陀夷比丘。是中犯一罪。行本日治。行六夜摩那埵竟。当与出罪者默然。若不忍便说。是初羯磨

第二更说。大德僧听。是迦留陀夷比丘。犯僧伽婆尸沙罪。故出精不覆藏。先已从僧乞六夜摩那埵。僧与六夜摩那埵。僧中行六夜摩那埵。时已尔所日。尔所日未过。是中间犯一僧伽婆尸沙罪。故出精不覆藏。先已从僧乞本日治。僧与本日治。是迦留陀夷比丘。是中更犯一罪。行本日。治僧中行六夜摩那埵竟。从僧乞出罪。僧迦留陀夷比丘。是中犯一罪。行本日治已。行六夜摩那埵竟。当与出罪。谁诸长老忍。是迦留陀夷比丘。是中犯一罪。行本日治。行六夜摩那埵竟。当与出罪者默然。若不忍便说。是第二羯磨

第三更说。大德僧听。是迦留陀夷比丘。犯僧伽婆尸沙罪。故出精不覆藏。先已从僧乞六夜摩那埵。僧与六夜摩那埵。僧中行六夜摩那埵。时已尔所日。尔所日未过。是中间犯一僧伽婆尸沙罪。故出精不覆藏。先已从僧乞本日治。僧与本日治。是迦留陀夷比丘。是中更犯一罪。行本日治。僧中行六夜摩那埵竟。从僧乞出罪。僧迦留陀夷比丘。是中犯一罪。行本日治。行六夜摩那埵竟。当与出罪。谁诸长老忍。是迦留陀夷比丘。是中犯一罪。行本日治。行六夜摩那埵竟。当与出罪者默然。若不忍便说。是第三羯磨

僧已与迦留陀夷比丘出罪。中间犯一罪。行本日治。行六夜摩那埵竟。僧忍默然故。是事如是持

佛在舍卫国。尔时迦留陀夷比丘。故出精。犯一僧伽婆尸沙罪覆藏。语诸比丘。诸长老。我迦留陀夷比丘故出精。犯一僧伽婆尸沙罪覆藏。今当云何。诸比丘以是事白佛。佛语诸比丘。汝等当与迦留陀夷比丘故出精。犯一僧伽婆尸沙罪若干日覆藏。随覆藏日。与作别住。若更有如是比丘。僧亦应和合与作别住。如是应作。一心和合僧。迦留陀夷比丘。从坐起偏袒右肩脱革屣。胡跪合掌作是言。大德僧忆念。我迦留陀夷比丘故出精。犯一僧伽婆尸沙罪覆藏。我迦留陀夷比丘。故出精犯僧伽婆尸沙罪。若干日覆藏。随覆藏日。从僧乞别住。僧我迦留陀夷比丘故出精。犯僧伽婆尸沙罪。随覆藏日。与我别住。怜愍故

第二更说。大德僧忆念。我迦留陀夷比丘故出精。犯一僧伽婆尸沙罪覆藏。我迦留陀夷比丘故出精。犯僧伽婆尸沙罪。若干日覆藏。随覆藏日。从僧乞别住。僧我迦留陀夷比丘故出精。犯僧伽婆尸沙罪。随覆藏日。与我别住。怜愍故

第三更说。大德僧忆念。我迦留陀夷比丘故出精。犯一僧伽婆尸沙罪覆藏。我迦留陀夷比丘故出精。犯僧伽婆尸沙罪。若干日覆藏。随覆藏日。从僧乞别住。僧我迦留陀夷比丘故出精。犯僧伽婆尸沙罪。随覆藏日。与我别住。怜愍故

即时一比丘应僧中唱言。大德僧听。是迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪覆藏。是迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪若干日覆藏。从僧乞别住法。若僧时到僧忍听。是迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪若干日覆藏。与别住法。如是白

大德僧听。是迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪覆藏。是迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪若干日覆藏。从僧乞别住法。僧迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪若干日覆藏。当与别住。谁诸长老忍。迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪若干日覆藏。今与别住者默然。若不忍便说。是初羯磨

第二更说。大德僧听。是迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪覆藏。是迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪若干日覆藏。从僧乞别住。僧迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪若干日覆藏。当与别住。谁诸长老忍。迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪若干日覆藏。今与别住者默然。若不忍便说。是第二羯磨

第三更说。大德僧听。是迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪覆藏。是迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪若干日覆藏。从僧乞别住。僧迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪若干日覆藏。当与别住。谁诸长老忍。迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪若干日覆藏。今与别住者默然。若不忍便说。是第三羯磨。僧与迦留陀夷比丘。犯此僧伽婆尸沙罪。一罪若干日覆藏。与别住竟。僧忍默然故。是事如是持

是迦留陀夷比丘。行若干日覆藏别住竟。语诸比丘言。诸长老。我当云何。诸比丘以是事白佛。佛语诸比丘。汝等当与迦留陀夷比丘六夜摩那埵。犯此僧伽婆尸沙罪。故出精一罪若干日覆藏。已僧中行别住。当与六夜摩那埵。若更有如是人。亦应与作六夜摩那埵。作法者。一心和合僧。是迦留陀夷比丘。从坐起偏袒右肩脱革屣。胡跪合掌作是言。大德僧忆念。我迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪若干日覆藏。我先已僧中乞别住。僧已与我别住。我已僧中行别住。我迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪若干日覆藏。僧中行别住竟。今从僧乞六夜摩那埵。僧我迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪若干日覆藏。已僧中行别住竟。僧当与我六夜摩那埵。邻愍故如是三说

即时一比丘僧中唱言。大德僧听。是迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪若干日覆藏。先已从僧乞别住。僧与别住。已僧中行别住。今从僧乞六夜摩那埵。是迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪若干日覆藏。已僧中行别住竟。从僧乞六夜摩那埵。若僧时到僧忍听。僧是迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪若干日覆藏。已僧中行别住竟。僧今当与六夜摩那埵。如是白。大德僧听。是迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪若干日覆藏。先已从僧乞若干日别住。僧与若干日别住。已僧中行若干日别住竟。是迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪若干日覆藏。僧中行别住竟。今从僧乞六夜摩那埵。僧迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪若干日覆藏。已僧中行若干日别住竟。僧当与六夜摩那埵。谁诸长老忍。是迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪若干日覆藏。已行若干日别住竟。僧今当与六夜摩那埵者默然。不忍便说。是初羯磨如是应三说

僧已与迦留陀夷比丘。犯此僧伽婆尸沙罪。故出精一罪若干日覆藏。与别住竟。与六夜摩那埵。僧忍默然故。是事如是持

是迦留陀夷比丘。僧中行若干日覆藏别住六夜摩那埵竟。语诸比丘言。诸长老我当云何。诸比丘以是事白佛。佛语诸比丘。汝等当与迦留陀夷比丘出罪。若干日覆藏别住竟。僧与六夜摩那埵竟。若更有如是比丘。亦应与作。作法者。一心和合僧。是迦留陀夷比丘。从坐起偏袒右肩。脱革屣胡跪合掌作是言。大德僧忆念。我迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪若干日覆藏。我先已僧中乞若干日覆藏别住。僧与我若干日覆藏别住。我僧中行若干日覆藏别住。我僧中行若干日覆藏别住竟。从僧乞六夜摩那埵。僧与我六夜摩那埵。我僧中行六夜摩那埵。我迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪若干日覆藏。僧中行若干日别住竟。僧中行六夜摩那埵竟。今从僧乞出罪。我迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪若干日覆藏。已行若干日别住竟。僧中行六夜摩那埵竟。僧当与我出罪。怜愍故。如是三说

即时一比丘僧中唱言。大德僧听。是迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪覆藏。先已从僧乞若干日覆藏别住。僧与若干日覆藏别住已。僧中行若干日覆藏别住已。僧中行若干日覆藏别住竟。僧中乞六夜摩那埵。僧与六夜摩那埵已。僧中行六夜摩那埵竟。是迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪覆藏。已僧中行若干日覆藏别住竟。僧中行六夜摩那埵竟。从僧乞出罪。若僧时到僧忍听。僧是迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪覆藏。已僧中行若干日覆藏别住竟。已僧中行六夜摩那埵竟。僧今与出罪。如是白。大德僧听。是迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪覆藏。先已从僧乞若干日覆藏别住。僧与若干日覆藏别住已。僧中行若干日覆藏别住已。僧中行若干日覆藏别住竟。僧中乞六夜摩那埵。僧与六夜摩那埵已。行六夜摩那埵竟。是迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪覆藏。已僧中行若干日覆藏别住竟。僧中行六夜摩那埵竟。今从僧乞出罪。僧迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪覆藏。已行若干日覆藏别住竟。已僧中行六夜摩那埵竟。僧当与出罪。谁诸长老忍。是迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪覆藏已行若干日覆藏别住竟。僧中行六夜摩那埵竟。僧今当与出罪者默然。若不忍便说。是初羯磨如是三说。僧已与迦留陀夷比丘出罪。犯此僧伽婆尸沙罪。一罪覆藏。已行若干日覆藏别住竟。僧中行六夜摩那埵竟。僧忍默然故。是事如是持

佛在舍卫国。尔时迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪覆藏。语诸比丘。我迦留陀夷故出精。犯僧伽婆尸沙罪。一罪覆藏。我当云何。诸比丘以是事白佛。佛语诸比丘。汝等与迦留陀夷比丘。故出精犯此僧伽婆尸沙罪一罪覆藏。随覆藏日与别住。若更有如是人。亦应与作。作法者。一心和合僧。迦留陀夷比丘。从坐起偏袒右肩脱革屣。胡跪合掌作是言。大德僧忆念。我迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪覆藏。我迦留陀夷故出精。犯此僧伽婆尸沙罪。一罪覆藏。随覆藏日。从僧乞别住。僧与我迦留陀夷比丘故出精犯此僧伽婆尸沙罪。一罪覆藏。随覆藏日与我别住。怜愍故。如是三乞

即时一比丘僧中唱言。大德僧听。是迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪覆藏。是迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪覆藏。随覆藏日。从僧乞别住。若僧时到僧忍听。僧是迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪覆藏。随覆藏日。僧当与别住。如是白

大德僧听。是迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪覆藏。是迦留陀夷比丘故出精。犯僧伽婆尸沙罪。一罪覆藏。随覆藏日。从僧乞别住。僧迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪覆藏。随覆藏日。当与别住。谁诸长老忍。是迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪覆藏。随覆藏日与别住者默然。若不忍便说。是初羯磨如是三说。僧已与迦留陀夷比丘故出精犯此僧伽婆尸沙罪。一罪覆藏。随覆藏日与别住竟。僧忍默然故。是事如是持

迦留陀夷比丘。随覆藏日行别住竟。语诸比丘我当云何。诸比丘以是事白佛。佛语诸比丘。汝等与迦留陀夷比丘故出精犯僧伽婆尸沙罪一罪覆藏。随覆藏日行别住竟。与作六夜摩那埵。若更有如是比丘。亦应与六夜摩那埵。作法者。一心和合僧。迦留陀夷比丘。从坐起偏袒右肩脱革屣。胡跪合掌作是言。大德僧忆念。我迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪覆藏。随覆藏日。从僧乞别住。僧随覆藏日。与我别住。我已僧中随覆藏日行别住。我迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪覆藏。随覆藏日行别住竟。今从僧乞六夜摩那埵。僧我迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪覆藏。随覆藏日行别住竟。僧当与六夜摩那埵。怜愍故。如是应三乞

即时一比丘僧中唱言。大德僧听。是迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪覆藏。随覆藏日。从僧乞别住。僧随覆藏日与别住已。僧中随覆藏日行别住竟。是迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪覆藏。随覆藏日行别住竟。今从僧乞六夜摩那埵。若僧时到僧忍听。僧是迦留陀夷比丘故出精。犯僧伽婆尸沙罪。一罪覆藏。随覆藏日行别住竟。当与六夜摩那埵。如是白

大德僧听。是迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪覆藏。随覆藏日。从僧乞别住。僧随覆藏日与别住已。僧中随覆藏日行别住。是迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪覆藏。随覆藏日行别住竟。从僧乞六夜摩那埵。僧是迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪覆藏。随覆藏日行别住竟。僧当与六夜摩那埵。谁诸长老忍。是迦留陀夷比丘故出精。犯此僧迦婆尸沙罪。一罪覆藏。随覆藏日行别住竟。今僧当与六夜摩那埵者默然。若不忍便说。是初羯磨如是三说

僧已与是迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪覆藏。随覆藏日行别住竟。与六夜摩那埵。僧忍默然故。是事如是持

迦留陀夷比丘。僧中行六夜摩那埵。时已尔所日。尔所日未过。更故出精。犯僧伽婆尸沙罪。一罪不覆藏。语诸比丘。诸长老。我迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪不覆藏。行六夜摩那埵。时已尔所日。尔所日未过。更故出精。犯此僧伽婆尸沙罪。一罪不覆藏。我当云何。诸比丘以是事白佛。佛语诸比丘。汝等当与迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪不覆藏。当与本日治。若更有如是比丘。亦应作本日治。作法者。一心和合僧。是迦留陀夷比丘。从坐起偏袒右肩脱革屣。胡跪合掌作是言。大德僧忆念。我迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪覆藏。随覆藏日。从僧乞别住。僧随覆藏日与我别住。我随覆藏日。僧中行别住。随覆藏日僧中行别住竟。从僧乞六夜摩那埵。僧已与六夜摩那埵。我僧中行六夜摩那埵。时已尔所日。尔所日未过。更故出精。犯此僧伽婆尸沙罪。一罪不覆藏。僧我迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪不覆藏。今从僧乞本日治。僧我迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪不覆藏。僧当与我本日治。怜愍故。如是三说

即时一比丘僧中唱言。大德僧听。是迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪覆藏。随覆藏日。从僧乞别住。僧随覆藏日与我别住已。僧中随覆藏日行别住。僧中随覆藏日行别住竟。从僧乞六夜摩那埵。僧与六夜摩那埵。僧中行六夜摩那埵。时已尔所日。尔所日未过。更故出精。犯此僧伽婆尸沙罪。一罪不覆藏。是迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪不覆藏。从僧乞本日治。若僧时到僧忍听。僧是迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。当与本日治。如是白

大德僧听。是迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪覆藏。先以随覆藏日。从僧乞别住。僧随覆藏日与别住已。僧中随覆藏日行别住。僧中随覆藏日行别住竟。从僧乞六夜摩那埵。僧与六夜摩那埵。僧中行六夜摩那埵。僧中行六夜摩那埵。时已尔所日。尔所日未过。更故出精。犯此僧伽婆尸沙罪。一罪不覆藏。是迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪不覆藏。从僧乞本日治。僧是迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪不覆藏。从僧乞本日治。僧是迦留陀夷比丘故出精。犯僧伽婆尸沙罪。一罪不覆藏。僧与本日治。谁诸长老忍。是迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪不覆藏。从僧乞本日治。迦留陀夷比丘故出精。犯此僧伽婆尸沙罪。一罪不覆藏。与本日治者默然。若不忍便说。是初羯磨如是三说

僧已与本日治。迦留陀夷比丘故出精。犯僧伽婆尸沙罪。一罪不覆藏。与本日治竟。僧忍默然故。是事如是持

是迦留陀夷比丘。中间犯罪得本日治。先罪行别住竟。僧中行六夜摩那埵竟。语诸比丘。长老。我当云何。诸比丘以是事白佛。佛语诸比丘。汝等与迦留陀夷比丘出罪。中间犯罪得本日治。先罪行别住竟。僧中行六夜摩那埵竟。与出罪。若更有如是比丘。亦应作出罪。出罪法者。一心和合僧。是迦留陀夷比丘。从坐起偏袒右肩脱革屣。胡跪合掌作是言。大德僧忆念。我迦留陀夷比丘故出精。犯僧伽婆尸沙罪。一罪覆藏。随覆藏日。从僧乞别住。僧随覆藏日与我别住。我随覆藏日僧中行别住。随覆藏日僧中行别住竟。从僧乞六夜摩那埵。僧已与我六夜摩那埵。我僧中行六夜摩那埵。时已尔所日。尔所日未过中间故出精。犯此僧伽婆尸沙罪。一罪不覆藏。从僧乞本日治。僧与我本日治。我迦留陀夷比丘。中间犯罪行本日治。先罪行别住竟。行六夜摩那埵竟。今从僧乞出罪。僧我迦留陀夷比丘。中间犯罪行本日治。先罪行别住。行六夜摩那埵竟。与我出罪。怜愍故。如是三说

即时一比丘僧中唱言。大德僧听。是迦留陀夷比丘故出精。犯僧伽婆尸沙罪。一罪覆藏。随覆藏日。从僧乞别住。僧随覆藏日与别住已。僧中随覆藏日行别住。僧中随覆藏日行别住竟。从僧乞六夜摩那埵。僧与六夜摩那埵。僧中行六夜摩那埵。时已尔所日。尔所日未过。中间故出精。犯僧伽婆尸沙罪。一罪不覆藏。从僧乞本日治。僧与本日治。迦留陀夷比丘。中间犯罪行本日治。先罪行别住竟。行六夜摩那埵竟。从僧乞出罪。若僧时到僧忍听。迦留陀夷比丘。中间犯罪行本日治。先罪行别住竟。行六夜摩那埵竟。僧当与出罪。如是白。大德僧听。是迦留陀夷比丘故出精。犯僧伽婆尸沙罪。一罪覆藏。随覆藏日从僧乞别住。僧随覆藏日与别住已。僧中随覆藏日行别住。僧中随覆藏日行别住竟。从僧乞六夜摩那埵。僧与六夜摩那埵。僧中行六夜摩那埵。时已尔所日。尔所日未过。更故出精。犯僧伽婆尸沙罪。一罪不覆藏。从僧乞本日治。僧中行本日治。是迦留陀夷比丘。中间犯罪行本日治。先罪行别住竟。僧中行六夜摩那埵竟。从僧乞出罪。僧迦留陀夷比丘。中间犯罪行本日治。先罪行别住竟。僧中行六夜摩那埵竟。当与出罪。谁诸长老忍。迦留陀夷比丘。中间犯罪行本日治。先罪行别住竟。僧中行六夜摩那埵竟。与出罪者默然。若不忍便说。是初羯磨如是三说

僧已与迦留陀夷比丘出罪。中间犯罪行本日治。先罪行别住竟。僧中行六夜摩那埵竟。僧忍默然故。是事如是持

佛在舍卫国。尔时迦留陀夷比丘。犯种种僧伽婆尸沙罪。第一犯故出精一夜覆藏。第二犯触女人身二夜覆藏。第三与女人粗恶语三夜覆藏。第四赞叹己身供养四夜覆藏。第五犯媒嫁五夜覆藏。语诸比丘。我当云何。诸比丘以是事白佛。佛语诸比丘。应与是人五夜别住羯磨。行别住竟。与六夜摩那埵。行摩那埵竟。与出罪羯磨

佛在舍卫国。尔时有一比丘。犯种种僧伽婆尸沙罪。覆藏。第一犯故出精。犯一僧伽婆尸沙罪。一夜覆藏。第二犯触女人。二夜覆藏。第三犯与女人粗恶语。三夜覆藏。第四犯赞叹己身供养。四夜覆藏。第五犯行媒嫁。五夜覆藏。第六犯无主自为身作房。六夜覆藏。第七犯有主自为身作大房舍。七夜覆藏。第八无根波罗夷法谤余比丘。八夜覆藏。第九犯取小片事作波罗夷法谤余比丘。九夜覆藏。第十破和合僧勤求方便。十夜覆藏。第十一犯助破和合僧。十一夜覆藏。第十二犯污他家行恶行。十二夜覆藏。第十三犯戾语。十三夜覆藏。以上事语诸比丘。我当云何。诸比丘以是事白佛。佛语诸比丘。汝等应与是人十三日别住。别住竟与六夜摩那埵。六夜摩那埵竟。与出罪羯磨(八法中苦切羯磨竟)

十诵律卷第三十二(八法卷第四)十诵律卷第三十三(第五诵之五)

        后秦北印度三藏弗若多罗译

    八法中僧残悔法之余(丹本云八法中顺行法第五)

佛在王舍城。尔时六群比丘犯罪。同相似同未净同未脱同未起同出界外。与余比丘作别住摩那埵本日治出罪。犯罪同相似同未净同未脱同未起同入界内。受清净比丘随上座起迎礼拜合掌供养。是中有比丘。少欲知足行头陀。闻是事心不喜。作是言。云何名比丘。犯罪同相似同未净同未脱同未起同出界外与余比丘作别住六夜摩那埵本日治出罪。犯罪同相似同未净同未脱同未起同入界内。受清净比丘随上座起迎礼拜合掌供养。如是诃已向佛广说。佛以是事集比丘僧已。知而故问六群比丘。汝等实作是事不。答言。实作世尊。佛种种因缘呵责。云何名比丘。犯罪同相似同未净同未脱同未起同出界外。与余比丘作别住六夜摩那埵本日治出罪。犯罪同相似同未净同未脱同未起同入界内。受住戒比丘随上座起迎礼拜合掌供养。种种呵已语诸比丘。从今行别住人。作第四人不应作别住羯磨。若行别住竟人。作第四人亦不应作别住羯磨。若行摩那埵人。作第四人不应作别住羯磨。若行摩那埵竟人。作第四人不应作别住羯磨。若不共住人。作第四人不应作别住羯磨。极少清净同见四比丘。得作别住羯磨。从今行别住人。作第四人不应作摩那埵羯磨。若行别住竟人。行摩那埵人。行摩那埵竟人。不共住人。作第四人皆不应作摩那埵。极少清净同见四比丘。得作摩那埵羯磨。从今行别住人。作第四人不应作本日治羯磨。行别住竟人。行摩那埵人行摩那埵竟人。不共住人。作第四人皆不应作本日治羯磨。极少清净同见四比丘。得作本日治羯磨。从今行别住人。作第二十人。不应作出罪羯磨。若行别住竟人。行摩那埵羯磨人。行摩那埵竟人。不共住人。作第二十人。不应作出罪羯磨。极少清净同见二十比丘。得作出罪羯磨。若比丘自有罪。不得受他除罪。从今说别住人行法。是别住人应当学别住人法。不应受住戒比丘随上座迎送礼拜合掌恭敬供养衣钵卧具洗手洗脚洗手洗脚水拭脚脚机。若不病不应受他按摩供养。行别住人不得共住戒比丘同一床坐。不得好床上坐。若住戒比丘行别住人不应坐。若二别住人不得共同一床坐何况多。不得在住戒比丘经行处行。不得与住戒比丘共一经行处行。不得好经行处行。不得在清净比丘前经行。二别住人不得共同一经行。处行何况多。别住人有客比丘来。应向说己所犯罪。布萨时应入僧中三自说罪。若病应遣使到僧中白言。某别住人病不得来。僧当知。别住人不得受他忏悔。不应与他受具戒。不应与他作依止。不应畜沙弥。不应受教诫比丘尼羯磨。若先受不应教诫。不应重犯罪。不应作相似罪。不应作过是罪。不应呵羯磨不应呵羯磨人。不应从清净比丘乞听。不应言我当出汝罪不应违逆清净比丘。不应遮布萨自恣及诸羯磨。不应出清净比丘罪。不应令他忆念罪。不应相言。应心悔折伏柔软恭敬。应在清净比丘后行在下行坐。若僧次第差会。应随上座次第受。应随上座次第满钵水。应随上座次第受雨浴衣。应随上座次第坐自恣。不应以是心语清净比丘。与我迎食分。恐人知我见我罪故。诸别住人共饮食时。随上座次第坐。应与诸别住人最下房舍下卧具卑下座处。诸别住人若多。随上座次第与房舍卧具坐处。行别住人。不应作前行比丘入他舍。作后行者随意。二别住人。有比丘住处无比丘不应住。无比丘无住处不应住。若行别住人与行别住竟人。若行别住人与行摩那埵人。若行别住人与行摩那埵竟人。若行别住人与不共住人。有比丘住处无比丘不应住。无比丘无住处亦不应住。行别住人。不应共清净比丘一覆住处住。不应共一覆非住处住。若行别住人与别住竟人。若别住人与行摩那埵人。若别住人与行摩那埵竟人。若别住人与不共住人。不应共一覆住处住。不应共一覆非住处住。若别住人欲行时先思惟。我今日行。当到前比丘住处不。若知能到便去。若不去者即失是一夜。若不及行是法者。应作是念。我不及行是事。应作是言。我应行别住摩那埵法。小停我不及作。长老忧波离问佛。行别住人行摩那埵人。若有因缘不及行是事。应听停几夜。佛言。应听二十五夜。从今行别住人。作第四人不应作别住羯磨。若二别住人二清净人。亦不得作别住羯磨。若三别住人一清净人一切别住人。不得作别住羯磨。极少四清净共住同见比丘。得作别住羯磨。从今行别住竟人。作第四人不得作别住羯磨。若二别住竟人二清净人。若三别住竟人一清净人。若一切别住竟人。皆不得作别住羯磨。极少四清净共住同见比丘。得作别住羯磨。从今若行摩那埵人。作第四人不得作别住羯磨。二行摩那埵人二清净人。若三行摩那埵人一清净人。若一切行摩那埵人。皆不得作别住羯磨。极少四清净共住同见比丘。得作别住羯磨。从今若行摩那埵竟人。作第四人不应作别住羯磨。若二行摩那埵竟人二清净人。若三行摩那埵竟人一清净人。若一切摩那埵竟人。皆不得作别住羯磨。极少四清净共住同见比丘。得作别住羯磨。从今不共住人。作第四人不应作别住羯磨。若二不共住人二清净人。若三不共住人一清净人。若一切不共住人。皆不应作。极少清净同见四比丘。应作别住羯磨。从今若别住人。作第四人不应作摩那埵羯磨。若二别住人二清净人。若三别住人一清净人。若一切别住人。皆不应作摩那埵羯磨。极少四清净共住同见比丘。得作摩那埵羯磨。从今若别住竟人。作第四人不应作摩那埵羯磨。若二别住竟人二清净人。若三别住竟人一清净人。若一切别住竟人。皆不应作摩那埵羯磨。极少四清净共住同见比丘。得作摩那埵羯磨。从今行摩那埵人。作第四人不应作摩那埵羯磨。若二摩那埵人二清净人。若三摩那埵人一清净人。若一切摩那埵人。皆不应作摩那埵羯磨。极少四清净共住同见比丘。得作摩那埵羯磨。从今若行摩那埵竟人。作第四人不应作摩那埵羯磨。若二行摩那埵竟人二清净人。若三行摩那埵竟人一清净人。若一切行摩那埵竟人。皆不应作摩那埵羯磨。极少四清净共住同见比丘。得作摩那埵羯磨。从今不共住人。作第四人不应作摩那埵羯磨。若二不共住人二清净人。若三不共住人一清净人。若一切不共住人。皆不应作摩那埵羯磨。极少四清净同见比丘。应作摩那埵羯磨。从今别住人。作第四人不应作本日治羯羯磨。若二别住人二清净人。若三别住人一清净人。若一切别住人。皆不应作本日治羯磨。从今若别住竟人。作第四人不应作本日治羯磨。若二别住竟人二清净人。若三别住竟人一清净人。若一切别住竟人。皆不应作本日治羯磨。从今行摩那埵人。作第四人不应作本日治羯磨。若二行摩那埵人二清净人。若三行摩那埵人一清净人。若一切行摩那埵人。皆不应作本日治羯磨。极少四清净共住同见比丘。得作本日治羯磨。从今行摩那埵竟人。作第四人不应作本日治羯磨。若二摩那埵竟人二清净人。若三摩那埵竟人一清净人。若一切摩那埵竟人。皆不应作本日治羯磨。从今不共住人。作第四人不应作本日治羯磨。若二不共住人二清净人。若三不共住人一清净人。若一切不共住人。皆不应作本日治羯磨。极少四清净同见比丘。应作本日治羯磨。从今别住人。作第四人不得是众中行别住。若二别住人二清净人。若三别住人一清净人。若一切别住人。皆不应是众中行别住。极少四清净同见比丘。应是中行别住。从今行别住竟人。作第四人是众中不得行别住。若二别住竟人二清净人。若三别住竟人一清净人。若一切别住竟人。皆不得是众中行别住。极少四清净同见比丘。是中得行别住。从今行摩那埵人。作第四人不应是众中行别住。若二摩那埵人二清净人。若三摩那埵人一清净人。若一切摩那埵人。不应是众中行别住。从今若摩那埵竟人。作第四人不应是众中行别住。若二摩那埵竟人二清净人。若三摩那埵竟人。一清净人。若一切摩那埵竟人。皆不应是众中行别住。极少四清净同见比丘。应是众中行别住。从今不共住人。作第四人不应是众中行别住。若二不共住人二清净人。若三不共住人。一清净人。若一切不共住人。皆不应是众中行别住。极少四清净同见比丘。应是众中行别住。从今行别住人。作第四人不应是众中行。摩那埵。若二别住人二清净人。若三别住人。一清净人。若一切别住人。皆不应是众中行摩那埵。极少四清净同见比丘。应是众中行摩那埵。从今别住竟人。作第四人不应是众中行摩那埵。若二别住竟人。二清净人。若三别住竟人。一清净人。若一切别住竟人。皆不应是众中行摩那埵。极少四清净同见比丘。应是众中行摩那埵。从今行摩那埵人。作第四人不应是众中行摩那埵。若二摩那埵人。二清净人。若三摩那埵人。一清净人。若一切摩那埵人。皆不应是众中行摩那埵。从今行摩那埵竟人。作第四人不应是众中行摩那埵。若二摩那埵竟人。二清净人。若三摩那埵竟人。一清净人。若一切摩那埵竟人。皆不应是众中行摩那埵。极少四清净同见比丘。应是众中行摩那埵。从今不共住人。作第四人不应是众中行摩那埵。若二不共住人二清净人。若三不共住人。一清净人。若一切不共住人。皆不应是众中行摩那埵。极少四清净同见比丘。应是众中行摩那埵。从今行别住人。作第四人不应是众中行本日治。若二别住人。二清净人。若三别住人。一清净人。若一切别住人。皆不应是众中行本日治。从今行别住竟人。作第四人不应是众中行本日治。若二别住竟人。二清净人。若三别住竟人。一清净人。若一切别住竟人。不应是众中行本日治。极少四清净同见比丘。应是众中行本日治。从今行摩那埵人。作第四人不应是众中行本日治。若二摩那埵人。二清净人。若三摩那埵人。一清净人。若一切摩那埵人。皆不应是众中行本日治。从今行摩那埵竟人。作第四人不应是众中行本日治。若二摩那埵竟人。二清净人。若三摩那埵竟人。一清净人。若一切摩那埵竟人。皆不应是众中行本日治。极少四清净同见比丘。应是众中行本日治。从今不共住人。作第四人不应是众中行本日治。若二不共住人。二清净人。若三不共住人。一清净人。若一切不共住人。皆不应是众中行本日治。极少四清净同见比丘。应是众中行本日治。从今别住人。作第二十人不应作出罪羯磨若二别住人。十八清净人。若三别住人。十七清净人。若四别住人。十六清净人。若五别住人。十五清净人。六别住人。十四清净人。七别住人。十三清净人。八别住人。十二清净人。九别住人。十一清净人。若十别住人。十清净人。十一别住人。九清净人。若十二别住人。八清净人。若十三别住人。七清净人。若十四别住人。六清净人。若十五别住人。五清净人。十六别住人。四清净人。十七别住人。三清净人。十八别住人。二清净人。若十九别住人。一清净人。若一切别住人。皆不应作出罪羯磨。极少二十清净同见比丘。得作出罪羯磨。从今别住竟人作第二十人。行摩那埵人作第二十人。若行摩那埵竟人作第二十人。若不共住人作第二十人。皆不应作出罪羯磨。从今二别住竟人。十八清净人。乃至一切不共住人亦如是。极少二十清净同见比丘。应作出罪羯磨(八法中顺行法第五竟)

    八法中遮法第六

佛在瞻波国。尔时世尊。十五日布萨时。在众僧前敷座处坐。观诸比丘心。观诸比丘心已。初夜默然入定。尔时有一比丘。从坐起偏袒右肩右膝着地合掌白佛言。世尊。初夜分过。佛及僧坐久。愿世尊说波罗提木叉。佛时默然。至中夜分。是比丘第二从坐起偏袒右肩合掌白佛言。世尊。初夜已过中夜又过。佛及僧坐久。愿世尊说波罗提木叉。佛故默然。至后夜。是比丘第三从坐起偏袒右肩合掌白佛言。世尊。初夜分过中夜亦过。后夜分多过。东方欲动。佛及僧坐久。愿世尊说波罗提木叉。尔时佛语是比丘。我众不清净。时长老目连在众中坐。便作是念。佛为谁故作是言。我众不清净。我当入定观之。佛为谁故乃说是语。即便入定观一切众心。如是观时。见佛所为不清净比丘。寻从定起。诣是比丘所。捉臂拽出语言。痴人。汝远去灭去。永离比丘法。汝今僧中末后共住。时目连驱比丘出已闭门下橝。往诣佛所头面礼佛足却坐一面白佛言。世尊。佛所说众不清净比丘。我已驱出语言。痴人。远去灭去。永离比丘法。汝今僧中末后共住世尊。初夜已过中夜亦过。后夜多过东方欲动。佛及僧坐久。愿世尊说波罗提木叉。佛语目连。是痴人得大重罪。恼佛及僧故。目连。若佛于不净众中说波罗提木叉者。是不清净人头破七分。目连。从今汝等当自说波罗提木叉。佛不复为汝等说。目连。譬如大海渐渐深广。佛法亦如是。次第结戒次第立制次第教学。目连。若我法中次第结戒次第立制次第教学。是我法中希有。目连。譬如大海不越常限。我法亦如是。若比丘比丘尼优婆塞优婆夷。乃至失命因缘护戒不缺。目连。若我法中所可制戒。若比丘比丘尼优婆塞优婆夷。乃至失命因缘不越戒。是我法中希有。目连。譬如大海深广深广无量。佛法亦如是。深义无量。目连。若佛法义深广深广无量。是我法中希有。目连。譬如大海淳一碱味。佛法亦如是。淳一解脱味。目连。若佛法淳一解脱味者。是我法中希有。目连。譬如大海大众生住处。摩竭鱼鼋鼍婆留耆鱼提麑鱼提麑耆罗鱼。此等在海中未足为奇。有百由旬身者二百三百乃至七百由延身。此等众生处海中亦未为奇。目连。佛法海中大人住处亦如是。大人者。若阿罗汉向阿罗汉。若阿那含向阿那含。若斯陀舍向斯陀舍。若须陀洹向须陀洹。目连。佛法大海中大人所住。若阿罗汉乃至向须陀洹。是我法中希有。目连。譬如大海多宝无量宝种种积满。诸宝者。金银真珠砗渠玛瑙琉璃摩尼珠贝珊瑚楼枝等。目连。佛法海亦如是。多宝无量宝种种积满。所谓四念处四正勤四如意足五根五力七觉八正道。目连。若佛法中多宝无量宝种种积满。四念处四正勤四如意足五根五力七觉八道。是我法中希有。目连。譬如大海清净不宿臭尸。若有臭尸风吹上岸。目连。如来法海清净亦如是。不宿臭尸。臭尸者。所谓破戒人也。心乐恶法内烂外流。非梵行自说梵行。非沙门自言沙门。是名臭尸。如是等人。虽常随众而实远离。佛法清净不宿臭尸。是我法中希有。目连。譬如大海阎浮提界四大河流入。所谓恒河流夜摩那河婆罗河阿醯罗婆提摩驮河流入大海。有龙力出水及澍洪雨如车轴下。受如是水海不增不减。佛法中亦如是。刹利种以信出家。剃除须发服三法衣。得证不坏心解脱。不增不减。如是若婆罗门种违舍种首陀罗种。以信出家剃除须发服三法衣。得不坏证心解脱。无增无减。目连。若佛法中有刹利种。乃至首陀罗种。以信出家得不坏心解脱。不增不减。是我法中希有。佛说是已语诸比丘。从今汝等自共说戒。如来不复为汝等说。尔时佛不复说戒故。诸比丘说戒。时有来者。有不来者。坐中比丘有犯罪者。诸比丘以是事白佛。佛言。布萨说波罗提木叉时。一切比丘应来。若有因缘者。应当与欲清净。中有犯戒者应遮。时诸比丘。有欲遮者。有不欲遮者。佛言。欲遮者应遮。不欲者不应强遮。诸比丘闻欲遮者应遮。不知当云何遮。佛言。若眼见事应遮

尔时有比丘得天眼者。见诸比丘犯罪如雨駚下。见已便遮以是因缘故。斗诤事起。不得布萨说波罗提木叉。是事白佛。佛语诸比丘。莫用天眼。随以肉眼所见应遮。诸比丘以肉眼遮时。有斗诤事起。不得布萨说波罗提木叉。佛言。应以所闻事遮。用闻遮时多有所闻。闻某比丘犯波罗夷。某犯僧伽婆尸沙。某犯波夜提。某犯波罗提提舍尼。某犯突吉罗。闻已皆遮。以是因缘故。斗诤事起。不得布萨说戒。佛言。应以疑遮。诸比丘多有所疑。若疑身犯口犯。若疑犯有残犯无残。若聚落中若阿练儿处。以是疑故。遮斗诤事起。不得布萨说戒。佛言。应以自言遮。清净者默然

有一非法遮说戒。有一如法遮说戒。若比丘于五种犯中。无根遮说戒。是名非法。如法者。若比丘于五种犯中。有根本遮说戒。是名如法。有二种非法遮说戒二种如法遮说戒。二非法者。于五种犯中无根。若作若不作遮说戒。是名二非法。二如法者。于五种犯中有根作不作。是名二如法。复有三种非法遮说戒。三种如法遮说戒三非法者。若比丘无根破戒。无根破见。无根破威仪。是名三非法遮说戒。三如法者。有根破戒破见破威仪。是名三如法遮说戒。复有四种非法遮说戒。四如法遮说戒。四非法遮者。无根破戒破正见破正命破威仪。是名四非法遮说戒。四如法者。有根破戒破正见破正命破威仪。是名四如法遮说戒。复有五非法遮说戒五如法遮说戒。五非法遮者。无根波罗夷遮说戒。是名非法遮。无根僧伽婆尸沙。波夜提。波罗提提舍尼。突吉罗。遮说戒。是名五非法遮。五如法遮者。有根波罗夷遮说戒。是名如法遮。有根僧伽婆尸沙。波夜提。波罗提提舍尼。突吉罗。遮说戒。是名五如法遮。复有六非法遮说戒。六如法遮说戒。六非法者。无根破戒作不作。无根破见作不作。无根破命作不作。是名六非法遮。六如法者。有根破戒作不作。有根破见作不作。有根破命作不作。是名六如法遮说戒。复有七非法遮说戒。七如法遮说戒。七非法者。无根波罗夷遮说戒。无根僧伽婆尸沙。波夜提。波罗提提舍尼。突吉罗。从恶口起突吉罗。从偷兰遮起突吉罗。是名七非法遮。七如法者。有根波罗夷。僧伽婆尸沙。波夜提。波罗提提舍尼。突吉罗。从恶口起突吉罗。从偷兰遮。起突吉罗。遮说戒。是名七如法遮。复有八非法遮说戒。八如法遮说戒。八非法者。无根破戒作不作。无根破见作不作。无根破命作不作。无根破威仪作不作。遮说戒。是名八非法遮说戒。八如法者。有根破戒作不作。有根破见作不作。有根破命作不作。有根破威仪作不作遮说戒。是名八如法遮说戒。复有九非法遮说戒。九如法遮说戒。九非法者。无根有残作遮说戒。若无根有残不作。若无根有残作不作。若无根无残作。若无根无残不作。若无根无残作不作。若无根有残无残作。若无根有残无残不作。若无根有残无残作不作遮说戒。是名九非法遮。九如法者。有根有残作。有根有残不作。有根有残作不作。有根无残作。有根无残不作。有根无残作不作。有根有残无残作。有根有残无残不作。有根有残无残作不作遮说戒。是名九如法遮说戒。复有十非法遮说戒。十如法遮说戒。十非法者。若比丘不犯波罗夷。若比丘犯波罗夷。僧未出是罪。若不轻呵僧。若比丘轻呵僧。僧未欲出罪。若不舍戒。若僧未欲出舍戒事。若随顺如法僧事。若破戒破见破威仪。不见不闻不疑。遮说戒。是名十非法遮。十如法者。若比丘犯波罗夷。若僧欲出波罗夷事。若轻呵僧。若僧欲出轻呵僧事。若舍戒。若僧欲出舍戒事。若比丘不随顺如法僧事。若破戒若破见若破威仪。若见若闻若疑。遮说戒。是名十如法遮说戒。若比丘犯波罗夷者。有比丘见余比丘犯波罗夷相貌。若从他闻某比丘犯波罗夷。若彼自说我犯波罗夷。若比丘虽不现前眼见。展转闻信闻疑。某比丘犯波罗夷。诸比丘若用见若用闻若用疑。欲此住处彼住处遮是比丘说戒。应作是言。遮某比丘说戒。某比丘在众中。僧不得布萨说戒。是名比丘犯波罗夷。僧欲出波罗夷事者。如比丘犯波罗夷事。僧欲捡挍是比丘事时。有是难起及余难若八难中一一难起是。事未决断。僧从坐起去。即时一比丘僧中唱言。大德僧听。今僧欲捡挍某比丘犯波罗夷事。有是难起及余难起。若八难中一一难起。是事未断。僧从坐起去。若僧时到僧忍听。僧后布萨时。当先断某比丘事。是名白。若诸比丘后布萨时。能先断是比丘事者善。若不能断。诸比丘若欲此住处彼住处遮是比丘说戒。应作是言。遮某比丘说戒。某比丘在众中。僧不得布萨说戒。是名僧欲出比丘犯波罗夷事。轻呵僧者。若比丘见余比丘轻呵僧相貌。以是相貌轻呵僧。若从他闻某比丘轻呵僧。若彼比丘自说我轻呵僧。若比丘虽不现前眼见。展转闻信闻疑。某比丘轻呵僧。诸比丘若用见若用闻若用疑。若欲此住处彼住处遮是比丘说戒。应作是言。遮某比丘说戒。某比丘在众中。僧不得说戒是名轻呵僧。僧欲出轻呵僧事者。如比丘轻呵僧。僧欲捡挍是比丘事时。有是难起及余因缘。若八难中一一难起。是事未断。僧从坐起去。即时一比丘僧中唱言。大德僧听。今僧欲捡挍某比丘轻呵僧事。以是难起若余因缘若八难中一一难起。是事未断。僧从坐起去若僧时到僧忍听。僧后布萨时。当先断某比丘是事。是名白。若诸比丘后布萨时能先断是比丘事者善。若不能断。诸比丘若欲此住处彼住处遮是比丘说戒。应作是言。遮某比丘说戒。某比丘在众中。僧不应布萨说戒。是名欲出轻呵僧事。舍戒者。若比丘见余比丘舍戒相貌。以是相貌舍戒。若从他闻某比丘舍戒。若彼比丘自说我舍戒。若比丘虽不现前眼见。展转闻信闻疑。某比丘舍戒。诸比丘若用见若用闻若用疑。若欲此住处彼住处遮是比丘说戒。应作是言。遮某比丘说戒。某比丘在众中。僧不得说戒。是名舍戒。欲出舍戒事者。如比丘舍戒僧欲捡挍是比丘事时。有是难起及余难起。若八难中一一难起。僧从坐起去。即时一比丘僧中唱言。大德僧听。今欲捡挍某比丘舍戒事为是难起及余因缘若八难中一一难起。是事未断。僧从坐起去。若僧时到僧忍听。僧后布萨时。当先断某比丘是事。是名白。若诸比丘后布萨时。能先断是比丘事者善。若不能断。诸比丘若欲此住处彼住处遮是比丘说戒。应作是言。遮某比丘说戒。某比丘在众中。僧不应布萨说戒。是名欲出舍戒事。不随顺如法僧事者。随僧所作事。若白一羯磨白二羯磨白四羯磨布萨自恣立十四人羯磨。若比丘见余比丘不随顺如法僧事相貌。若从他闻某比丘不随顺如法僧事。若彼比丘自说我不随顺如法僧事。若比丘虽不现前眼见。展转闻信闻疑。某比丘不随顺如法僧事。诸比丘若用见若用闻若用疑。若此住处彼住处遮是比丘说戒。应作是言。遮某比丘说戒。某比丘在众中。僧不应布萨说戒。是名不随顺如法僧事。破戒者。有比丘犯波罗夷。犯僧伽婆尸沙。波夜提。波罗提提舍尼。突吉罗。若诸比丘。见比丘犯戒相貌。若从他闻某比丘破戒。若彼自说。若比丘虽不现前眼见。展转闻信闻疑。某比丘破戒。诸比丘若用见若用闻若用疑。若欲此住处彼住处遮是比丘说戒。应作是言。遮某比丘说戒。某比丘在众中。僧不得说戒。是名破戒。破见者。除身见为本六十二见。若起余见。谓无罪无福无施无善无恶无善恶果报无今世后世无父无母。无世间阿罗汉得正行今世后世自身作证我生已尽所作已办梵行已立从是身更不受后有。若诸比丘见是比丘破见相貌。若从他闻若彼比丘自说。若比丘虽不现前眼见。展转闻信闻疑。某比丘破见。诸比丘若用见若用闻若用疑。若此住处彼住处。欲遮是比丘说戒应作是言。遮某比丘说戒。某比丘在众中。僧不得说戒。是名破见。破威仪者。有比丘于和上阿阇梨一切上座所。作邪恶破威仪行。若诸比丘见是比丘破威仪相貌。若从他闻某比丘破威仪。若彼自说。若比丘虽不现前眼见。展转闻信闻疑。某比丘破威仪。诸比丘。若用见若用闻若用疑。若此住处彼住处。欲遮是比丘说戒者。应作是言。遮某比丘说戒。某比丘在众中。不得说戒。是名破威仪八法中遮法第六竟

十诵律卷第三十三十诵律卷第三十四(第五诵之六)

        后秦北印度三藏弗若多罗译

    八法中卧具法第七

佛在王舍城。尔时诸比丘。互相轻慢无恭敬行。佛见诸比丘互相轻慢无恭敬行。以是因缘故。集比丘僧。问诸比丘。于汝等意云何。谁比丘应作上座。先受水先受饮食。有比丘答言。世尊。若比丘刹利种。以信出家剃除须发服法衣。是人应先坐先受水先受饮食。复有比丘言。世尊。若比丘是婆罗门种。以信出家剃除须发服法衣。是人应先坐先受水先受饮食。复有比丘言。世尊。若比丘毗舍种。以信出家剃除须发服法衣。是人应先坐先受水先受饮食。复有比丘言。世尊。若比丘得阿罗汉漏尽。所作已办舍离重担。尽诸有结能具正智心得解脱。如是比丘。应先坐先受水先受饮食。复有比丘言。世尊。若比丘得阿那含。断五下分结不还生此世界。如是比丘。应先坐先受水先受饮食。复有比丘言。世尊若比丘得斯陀含。断三结三毒薄。一来生此世间得尽苦际。如是比丘。应先坐先受水先受饮食。复有比丘言。世尊。若比丘得须陀洹。断三结不堕三恶道必至净智。往来人天七死七生得尽苦际。如是比丘。应先坐先受水先受饮食。诸比丘虽种种说。不合佛意。佛语诸比丘。汝等当一心听。谁比丘应先坐先受水先受饮食。尔时世尊说本生因缘。语诸比丘。过去世时。近雪山下。有三禽兽共住。一鵽二猕猴三象。是三禽兽。互相轻慢无恭敬行。是三禽兽同作是念。我等何不共相恭敬。若前生者。应供养尊重教化我等。尔时鵽与猕猴问象言。汝忆念过去何事。时是处有大荜茇树。象言。我小时行此。此树在我腹下过。象鵽问猕猴言。汝忆念过去何事。答言。我忆小时。坐地捉此树。头按令到地。象语猕猴汝年大我。我当恭敬尊重汝。汝当为我说法。猕猴问鵽言。汝忆念过去何事。答言。彼处有大荜茇树。我时啖其子于此大便。乃生斯树长大如是。是我所忆。猕猴语鵽。汝年大我。我当供养尊重汝。汝当为我说法。尔时象恭敬猕猴。从听受法为余象说。猕猴恭敬鵽。从听受法为余猕猴说。鵽为余鵽说法。此三禽兽。先喜杀生偷夺他物邪淫妄语。斯诸禽兽咸作是念。我等何不舍杀生偷夺邪淫妄语恶业。作是念已。即舍杀盗邪淫妄语。畜生中无犹。具足行是四法。命终皆生天上。佛言。尔时鵽法广行流布。显现诸天世人。畜生等何故行善。不复侵食人谷。又作是念。畜生尚能相敬。何况我等。尔时世人皆相敬重。广修鵽法奉行五戒。命终生天。佛语诸比丘。尔时鵽者。岂异人乎。则我身是。猕猴者舍利弗是。象者目连是。佛言。畜生无知。尚相恭敬行尊重法。自得大利亦利益他。何况汝等以信出家。剃除须发服法衣。应相尊敬。有三人不如。何等三。一切未受大戒人。不如受大戒人。一切下座不如上座。一切受事说非法人虽作上座。不如下座。不受事人说如法者。一切受大戒人。胜不受戒人。一切上座胜下座。佛胜众圣。尔时世尊。即说偈言

  若人不敬佛　　及佛弟子众
  现世人诃骂　　后世堕恶道
  若人知敬佛　　及佛弟子众
  现世人赞叹　　后世生天上

佛种种因缘赞叹恭敬法已。语诸比丘。从今先受大戒乃至大须臾时。是人应先坐先受水先受饮食

佛在舍卫国。尔时有一居士。请佛及僧明日食。佛默然许。居士知佛受请。还家通夜办种种多美饮食。早起敷坐处。遣使白佛时到。唯圣知时。时佛及僧往居士舍。跋难陀释子常出入他家。时跋难陀释子。早起着衣持钵入出他家。时次跋难陀释子下座比丘。问跋难陀弟子达磨言。汝师来不。答言。我和上多事多缘。喜入出他家。今旦早起入出他家。或来或不来。是比丘不留跋难陀坐处便坐。时居士见佛及僧坐竟。自手行水下食未遍。跋难陀释子来就次第坐。令下座比丘起。是比丘又令次下比丘起。如是三四诸下座皆起。以是因缘僧坐散乱。诸居士呵责跋难陀言。饮食甚多一切等施。何须次坐。若汝急欲次坐者。何不早来。我今不知谁得不得谁重得不重得。佛闻居士呵责见诸比丘散乱已默然。食后以是因缘集比丘僧。种种因缘诃责跋难陀释子。云何名比丘。下饮食时以上座故令下坐起。如是呵已语诸比丘。从今下饮食时若下已讫。不应令下座起。若令起者得突吉罗。若比丘有和上阿阇梨因缘。以恭敬心故起。不应令第二下座起。若令起得突吉罗。佛言。从今听比丘三岁中间得共一床坐。听三比丘共一粗梐床上坐。听细梐床二人共坐。独坐床上一人坐。佛在波罗奈国。尔时五比丘白言。世尊。我等当何处住。佛言。汝等应山岩竹林树下住。诸比丘于山岩竹林树下宿。早起到和上阿阇梨所。受读经诵经问疑受法故

尔时跋提居士。早起出王舍城。欲诣竹园礼觐世尊。时居士见诸比丘从山岩竹林树下来问言。大德。从何处来。答言。从山岩竹林树下来。居士言。何故在此山岩竹林树下耶。诸比丘言。更无住处。居士言。我当为汝等起诸房舍。答言。佛未听我等房舍中住。诸比丘以是事白佛。佛言。从今听诸比丘房舍中住。时居士即为诸比丘作诸房舍。高广严好杂色彩画。无卧覆处物。诸比丘不得卧。是事白佛。佛言。听敷草树叶卧。别作覆身衣。别作覆处物。是国土多热草叶生虫。佛言。听作荐席[竺-二+處]篨。虽受教犹故生虫。佛言。听作床榻。诸比丘取软木作床桄床箦。故隐身苦恼。是事白佛。佛言。听作褥。长老优波离问佛。以何物作褥。佛言。听用甘蔗滓瓠蔓瓜蔓毳刍摩劫贝文阇草婆婆阇草麻乃至水衣贮褥。时诸比丘卧无枕头垂。是事白佛。佛言。听作草枕。诸比丘头软草枕刺头。佛言。听用纳若毳。诸房舍无户有。狗牛马獐鹿猕猴来入。是事白佛。佛言。听作户扇。户扇不作关钥故。贼入偷衣钵。是事白佛。佛言。听绳系。诸比丘不知云何系。佛言。听下[戶@古]。诸比丘不知云何作。佛言。应作孔用绳穿牵闭。闭已不能开。佛言。应作开户钩。长老优波离问佛。用何等作。佛言。应用铁若铜若木作。作已不知云何开。佛言。户扇中作孔内钩却橝。诸比丘闭户时无所捉。佛言。户扇上应作孔施纽。长老优波离问佛。以何物作纽。佛言。应用铁若铜若木毛刍摩劫贝文阇草麻皮。时诸房舍无向故闇。佛言。听作向作向已有鹅雁孔雀鹦鹉舍利鸟鸠耆罗鸟命命鸟燕雀。从向中入作声故。妨诸比丘坐禅读经。是事白佛。佛言。应施棂子。施棂子已鸟故得入。佛言。应施网。长老优波离问佛。何等物。作网。佛言。应用毛刍摩劫贝文阇婆婆阇麻皮作。作已朽坏。佛言。应遮。长老优波离问佛。以何物遮。佛言。应用木作施辘轳。作已室中阇。佛言。应作雀目。作已亦闇。佛言。应作向阘。尔时热过寒到。向中无扇寒入。佛言。应作扇。作扇已小动便脱。佛言。应上下作掩。作已两扇间不合。佛言。应广作令掩。作已动摇。佛言。施关向高。不知云何闭。佛言。应以绳牵闭。闭已不能开。佛言。应作孔施两绳。一绳牵闭一。绳挽开。尔时诸房舍不泥故。墼间有蛇蜈蚣毒虫生。啮诸比丘。佛言应泥。泥已壁粗涩破衣。佛言。应细泥涂。尔时诸房舍用泥覆故。久雨便漏。佛言。应用草覆。覆已当脊上漏。佛言。脊上厚覆。覆已为风所发。佛言。应系两边。系已两头故漏。佛言。应多着草泥以橛钉上。雨时泥烂堕落。佛言。应用盆覆盆。又堕地破坏。佛言。应穿盆以橛钉之。雨从孔入。佛言。应作覆盆盖盖孔上

佛在王舍城。尔时舍卫国给孤独氏。有少因缘至王舍城。宿一居士舍。是居士请佛及僧明日食。故后夜起。唤儿息奴婢内外作人。汝等速起。破薪取水安施釜镬煮饭作羹。是居士自庄严堂舍敷众坐处。时给孤独作是念。是居士为欲嫁娶。为请国王及大臣耶。为作大施会耶。作是念已。问居士言。汝欲嫁娶。为欲请国王大臣。为作大施会耶。居士答言。我不嫁娶。亦不请王及大臣也。请佛及僧明日食。故作大施会。给孤独氏初闻佛名。心喜毛竖。问言。何人是佛。居士答言。有释王太子。以信出家得无上道。故号为佛。又问。何名为僧。答言。有种种人种种杂姓种种异人出家。剃除须发服法衣随佛出家。是名为僧。又问。佛今所在。答言。近在寒林。欲见随意。给孤独氏至心欲见。夜现明相。即从舍出至大势神门。门自然开。此门常法。初夜吹呗。为客入故。后夜吹呗。为人出故。尔时给孤独氏见此门开。念必夜了。出门不远明相不现。闇无所睹。即时惊怖毛竖。将无非人娆固我耶。寻欲退还。时大势门神。为现光明彻照寒林。语言。汝去。勿复恐惧。我前世时。是汝善知识密肩婆罗门。同心相敬居士。我昔因到王舍城见舍利弗目连。我头面作礼现前坐。即为我说法示教利喜。示教利喜已。我受三归五戒。以是因缘故。生四王天上。顿止斯门。是故语汝。去得大利。直进勿疑。是时天神即说偈言

  若人得百马　　百璎珞严具
  草马车一百　　不如前一步
  若百雪山象　　修广大身牙
  又以纯金饰　　严身最殊异
  不如前一步　　十六分之一
  北方百美女　　璎珞环金印
  以是庄严具　　年少端正妙
  比汝前一步　　十六不及一
  乃至转轮王　　第一玉女宝
  比汝前一步　　十六不及一
  是故汝直前　　勿复疑悔还

时给孤独氏。念佛法僧必大不小。乃令天神殷勤致教。即从光中进到寒林。于时地了。佛在露地经行。住待居士。尔时居士。以白衣法问讯佛。世尊。卧安隐不。佛说偈言

  我除诸欲漏　　解脱离世间
  已断一切漏　　心灭诸热恼
  得寂灭处故　　我卧常安隐

尔时世尊。即于经行处坐。是居士头面礼佛足却坐一面。佛为说法示教利喜。为说初法布施持戒生天果报。说五欲过世间苦恼。出家安乐分别垢净。佛知是人心调柔软堪受上法。为说四谛苦习尽道。如白净衣易受染色。是人亦尔。闻法开悟。即于座上见法得法。知法通达法。断疑不随他。于佛法中得无所畏。从坐起头面礼佛足作是言。世尊。我心乐佛法。知我尽寿作优婆塞。愿世尊及僧。受我夏请住舍卫国。佛知故问居士。汝字何等。答言。我字须达。供给孤独故。国人称我。为给孤独氏。佛问须达。舍卫国有僧坊不。答言。未有世尊。佛言。若有僧坊住处。诸比丘可得来往。若无有者。诸比丘不得往来止顿。又言。愿世尊但受我请。我能为办僧坊。令诸比丘得来往止顿。愿世尊遣舍利弗。为我作僧坊师。佛敕舍利弗。汝与居士作僧坊师。是居士即往诣竹园。看讲堂温室食堂作食处洗浴处门屋坐禅处厕处。取相貌已。是居士于王舍城因缘事讫。还向舍卫国。行路知佛所当宿处。语诸知亲相识诸负债人言。汝等知不。今佛出世。我当为佛于此作如是讲堂温室食堂食厨洗浴处门屋禅坊大小便处。尔时给孤独氏。限半由旬起僧坊。约敕左右供给所须。如是次第约敕至舍卫国。到已不入城内不还自舍。绕城推求立僧坊处。路行思惟。谁有好园来往稳便。树林丰茂流水清洁。无诸毒螫蚊虻之类。无大风热昼夜少声。我于斯处当起僧坊施佛及僧。如是行时。见只陀王子有园来往稳便。树林丰茂有好流水。无诸毒虫蚊虻之类。无大风大热。昼夜闲静少诸音声。即便生念。我于斯处当起僧坊奉佛及僧。时给孤独氏。还舍卫城不自入舍。即诣只陀王子所白言。买君园。愿以与我。王子答言。我此园非可买者。乃至侧布金钱满中。亦不卖也。居士言。园价已断。王子答言。我不断价。以是因缘遂相共诤。即诣断事。大臣富贵人所具说是事。时大臣能断事者语王子言。汝园已卖。宜时纳价。汝何故。言侧布金钱。给孤独氏寻便还归。遣象马车乘。负载金钱到只陀园。侧布其地。余少未足。居士思惟。出何藏金令满此地。而不多不少。王子只陀见其静默。语居士言。欲悔随意。以金相付园地还我。报言。王子。吾心不悔。但自思惟。开何藏金不多不少。而得满足。王子闻已便作是念。佛法僧众必大不小。能令居士舍尔所宝物。作是念已语居士言。莫复布钱。吾于此中当起门屋施佛及僧。时居士便听。以怜愍故。王子于中起立门屋施佛众僧。尔时居士以舍利弗为师。于此园中起十六大重阁作六十窟屋。佛知舍卫国僧坊已办。集比丘僧而告之言。吾将游行至舍卫国。汝等俱去。比丘受教。愿皆随从。尔时世尊。与大比丘众五百人俱。向舍卫国。时六群比丘。知佛及僧暮所宿处。告其弟子。汝等往宿处好房留佛。余有好者为我占取。弟子受教。先往宿处好房留佛。次有好者为师占取。尔时舍利弗目连。从佛后至。除佛房舍次欲取房。有比丘言。他已先取。如是第二第三第四皆言先取。舍利弗目连取边房住。佛知故问阿难。舍利弗目连今何处住。答言。世尊边房中住。佛言。唤来。即时来至。问舍利弗。汝等何故边房中住。答言。世尊。六群比丘知佛暮所宿处。先遣弟子。汝往宿处好房留佛。余有好者为我占取。弟子受教。先来到此。好房留佛次占好者。我等从佛后至。除佛房舍次欲取房。有比丘言。他已先取。如是第二第三第四。皆言先取。是故我等边房中住。佛言。从今听随上座次第取房舍住。即时六群比丘遣病比丘出房。时看病比丘持病比丘大小便器涕唾器草席从一房至一房。受诸疲苦病者增剧。是事白佛。佛言。从今不应随上座驱病比丘出房驱出者突吉罗。六群比丘闻佛不听随上座驱病比丘出房。即时托病。有时客比丘。日没来打户索住。六群比丘在内应声。客比丘问汝几岁。六群比丘言。我是病人何须问岁。问汝何病。答言。我患口悬痈痛兼患脚指间劈。诸比丘以是事白佛。佛言。是人若托病。应次第驱出。僧中作使一切应作。诸病比丘闻佛语已皆住好房。是事白佛。佛言。虽实病人。不应好上房舍中住。知卧具人。应筹量房舍及诸病人与中房舍。中房舍者。容受病人看病人及卧具。令得坐卧尔时佛次第到舍卫国。诸比丘欲安居。先作本事。泥涂壁孔及土埵。急床榻绳抖擞被褥枕。六群比丘性懒。立住遥看作是念。待彼作竟受床榻已。我等当往随上座次第驱出。诸比丘作本事竟。敷床榻卧具坐已。六群比丘打户。房内比丘应声。六群比丘言。汝等几岁。答言。若干岁。六群比丘言。汝起出去我是上座。诸比丘言。汝等共我来不。答言。共来。作本事不。答言。不作。诸比丘言。汝等与我俱来。不作本事我不能去。六群比丘言。佛不说不作本事不与次第住。但说随上座次第受房舍卧具。我等是上座。汝云何不去。六群比丘剿健多力不念护戒。即便入舍强捉曳出。诸比丘身软头首伤坏衣钵破裂。是事白佛。佛言。从今应立知分卧具人。立知分卧具人法者。一心和合僧应作是言。谁能为僧作分卧具人。是中若有比丘言我能。佛言。若有五法。不应立作知分卧具人。何等为五。随爱随嗔随怖随痴不知得不得。若成就五法应立作分卧具人。何等五。不随爱不随嗔不随怖不随痴知得不得。即时一比丘应僧中唱言。大德僧听。比丘某甲。能为众僧作知分卧具人。若僧时到僧忍听。僧立比丘某甲作知分卧具人。如是白。如是白二羯磨。僧立某甲比丘作知分卧具人竟。僧忍默然故。是事如是持。作知分卧具人。应问旧比丘中善好不妄语能分别卧具者。问此别房中有何等供养。彼别房中此重阁上。悉有何等供养。彼重阁上悉有何等供养。旧比丘应以实答。知分卧具人。应筹量卧具多少及诸比丘多少。如是筹量卧具诸比丘多少。若一比丘应得一房。便与别房。应先随上座自恣取。作是言。大德上座。某别房中有如是供养。某甲别房复有如是供养。上座欲取何者。随所欲取。取已次应语第二上座。随意取已。又语第三上座。若初上座言。我欲取第三上座房。佛言。不应与。应教作突吉罗悔过。如是次第一切应与。若比丘房舍足者与房舍。如是次第若重足者重与。如是次第。若床卧具足者。与床卧具。与法者。知卧具人。应先语上座自恣随意取。应言。某床上有如是供养。某床上有如是供养。上座欲取何者。初上座随意取已。次语第二上座。第二上座取已。次语第三上座。第三上座取已。若初上座言。我欲取第三上座床卧具。佛言。不应与。应教作突吉罗悔过。有一时跋难陀释子。于祇洹中取卧具分余处复取诸比丘言。汝于此处取分。何故复余处取。答言。我不复取。诸比丘不知云何。是事白佛。佛言。若比丘更于彼取卧具者。此处已名为舍。若言我不复取。亦名舍彼卧具。如守牧婆罗门妇本生经广说。佛言。昔者有守牧婆罗门妇。教贼杀夫持财物去。中道值水。贼语妇言。汝住此岸。我先渡物还当渡汝。贼寻持衣物渡彼岸。妇便唤言。汝渡我来。贼言。弊婢。汝自夫不爱。何能爱我。即便舍去。妇裸形住。跋难陀亦如是。舍此卧具更彼处取。此处已失。复言我不复取。彼处复失。复有往昔野干。衔肉到水岸上。见鱼水中反腹。即便舍肉欲往取鱼。时有飞鸟持此肉去。跋难陀释子亦如是。佛如是呵已语诸比丘。从今若比丘取一分卧具已。不应复取。若更取者突吉罗

佛在憍萨罗国。与大比丘众俱一处安居。尔时祇洹中安居比丘少。而卧具多。诸比丘各各分已。有余不尽。随居士所造房者来问言。我所作卧具。有比丘住不。答言。无人住。何以故。今祇洹比丘少卧具多。佛听受一卧具。不听受多卧具。故无有人住。诸居士言。我房中先有敷具。被枕前食时食。我当与房舍衣住中食用者善。诸比丘不知云何。是事白佛。佛言。应先人与一。若有长者又应更与。为尽藏物故。若复不尽。应第三更与。为经行故。若复不尽。次与令尽。为护治故。尔时憍萨罗国荒乱。以怖畏故。诸比丘多集一处安居结夏。坐已有客比丘来。在洗脚处讲堂门屋经行处经行头持衣钵着是诸处。住待卧具。佛见诸比丘在洗脚处讲堂门屋经行处经行头持衣钵着是诸处住待卧具。佛知故问阿难。诸比丘何以故持衣钵着讲堂门屋经行处经行头住何所待。答言。是憍萨罗国荒乱。诸比丘怖畏故。多集一处安居。是客比丘来。在洗脚处讲堂门屋经行处经行头。持衣钵着是诸处待卧具分。佛言。从今听二种安居。一先安居。二后安居。当与后安居比丘房舍卧具。彼闻佛听与后安居比丘房舍卧具。即欲从前安居上座比丘取房舍卧具。以是因缘故。斗诤事起。佛言。后安居上座比丘。不应从前安居上座比丘取房舍卧具。若前安居上座有二分卧具者。应与后一分。憍萨罗国又复荒乱。有诸比丘。多集一处安居。分房舍卧具竟。有余处诸比丘来。在洗脚处讲堂门屋经行处经行头。持衣钵着是诸处待卧具分。佛见诸比丘持衣钵着是诸处待卧具分。佛知而故问阿难。诸比丘何故在洗脚处讲堂门屋经行处经行头持衣钵着是诸处住何所待。答言。世尊。憍萨罗国荒乱怖畏。诸比丘安居分卧具竟。是诸比丘从余处来。在洗脚处讲堂门屋经行处经行头持衣钵着是诸处待卧具分。佛言。若有未分卧具者应与分。已分者应共住。又时憍萨罗国荒乱。有臣处处斗战。诸比丘已结后安居。多有客比丘来。在洗脚处讲堂门屋经行处经行头持衣钵着是诸处待卧具分。佛见客比丘持衣钵着是诸处待卧具分。佛知故问阿难。诸客比丘何故在洗脚处讲堂门屋经行处经行头。持衣钵着是诸处住何所待答言。世尊。憍萨罗国荒乱。有臣处处斗战。诸比丘后结坐竟。是客比丘来至。洗脚处讲堂门屋经行处经行头持衣钵着是诸处待卧具分。佛言。若有空房者应与。若无者应共住。与温室令安衣钵。应当随僧乞食。若是中有旧比丘善好乐福德者。应为客比丘求索衣物。莫令是比丘无所得去。时有阿练儿比丘。从旧比丘求索举衣钵屋。诸比丘言。佛未听我等与阿练儿举衣钵屋。是事白佛。佛言。从今听与阿练儿比丘举衣钵屋。尔时有诸客比丘。暂来无住处疲极苦恼。是事白佛。佛言。应暂与房舍卧具。有时一比丘来宿已。早起便去。是房中所有供养。前食时食乃至房舍衣。旧比丘生疑。客比丘来是房中宿。早起便去。有是供养分。不知云何。是事白佛。佛言。客比丘虽在中宿。住者房舍应受

佛在舍卫国。尔时诸比丘废学比尼。诵读修多罗阿毗昙远离比尼。佛见诸比丘不学比尼诵读修多罗阿毗昙远离比尼故。见已赞叹比丘通利比尼者。面前赞叹长老优波离。诸持比尼中最胜第一。诸比丘作是念。佛赞叹比丘通利比尼者。面前赞叹。长老优波离诸持比尼中最为第一。我等何不读诵比尼。诸上座长老比丘。从长老优波离受诵比尼。长老优波离。不为高处坐教。恭敬上座故。亦不下处坐教。为尊法故。若经行时若立时教。尔时长老优波离。行立久故。患脚痛[跳-兆+專]膝髀。腰胁脊痛。是事白佛。佛以是事集比丘僧。知而故问长老优波离。优波离。实有上座比丘。从汝受比尼。汝不高处坐教。恭敬上座故。又不下处坐教。为尊法故。汝经行时若立时教。行立久故。患脚痛[跳-兆+專]膝髀腰胁脊痛。汝实尔不。答言。实尔世尊。佛种种因缘赞戒赞持戒。赞戒赞持戒已语诸比丘。从今听下座比丘欲教上座法者。应在高处坐教。为尊法故。若上座欲从下座受法者。应在下处坐受法。为尊法故。从今听。下座比丘教上座法者。得共等床坐。为上座故

佛与大比丘众俱。游行憍萨罗国。诸长老舍利弗目连阿那律难提金毗罗。皆随从佛。是诸长老所言真实。能苦切语折伏众人。为诸比丘作种种羯磨。苦切羯磨依止羯磨下意羯磨驱出羯磨。时憍萨罗国有一住处。多诸比丘住。是诸比丘。闻佛与大比丘僧舍利弗目连阿那律难提金毗罗等俱来游行憍萨罗国。是诸长老所言真实。能苦切语折伏众人。为诸比丘作诸羯磨。苦切羯磨依止羯磨下意羯磨驱出羯磨。今当至此必为我等作诸羯磨。我等何不以此住处羯磨付一比丘。作是念已。即用羯磨付一比丘。佛来到是处。是比丘为佛敷好坐具置好房中。然后小远避藏作是念。若我住者。佛必令我为诸客比丘敷坐卧具。佛受是房已。余客比丘。在洗脚处讲堂门屋经行处经行头。持衣钵着是诸处待卧具分。佛见诸比丘持衣钵着是诸处待卧具分。佛知故问阿难。诸比丘何以故洗脚处讲堂门屋经行处经行头以衣钵着是诸处住何所待。答言。世尊。待旧比丘与卧具分。佛告阿难。汝往语旧比丘。开房与客比丘卧具。阿难受教。语旧比丘开房与客比丘卧具。旧比丘言。汝知不。此非僧房。我等以羯磨付一比丘。是中有比丘。少欲知足行头陀。闻是事心不喜。呵责言。云何名比丘。以僧房羯磨与一比丘呵已向佛广说。佛以是事集比丘僧。种种因缘呵责旧比丘。云何名比丘。以僧房羯磨与一比丘。呵已语诸比丘。从今不听以僧房羯磨与一比丘。若与者得突吉罗。是僧房虽与不成与

佛复与大比丘僧。游行诸国土。或无僧房处。投林中宿。尔时六群比丘告其弟子。汝先往宿处。好树留佛。次有好者与我占取。弟子先去。好树留佛占次好者。舍利弗目连随佛后至。次欲取树。有比丘言。他已先取。如是第二第三第四。皆言已取。乃至外行树下宿。佛知故问阿难。舍利弗目连今在何处。答言。在外行树下。佛言。唤来。阿难受教即往唤来。佛知故问舍利弗目连。汝等何故外行树下。答言。世尊。六群比丘知佛宿处。告其弟子。汝先往宿处。好树留佛次有好者。为我占取。我等随佛后到。次欲取树。有比丘言。他已占取。如是第二第三第四。皆言已取。是故我等外行树下。佛言。从今听诸比丘随上座次住树下。诸下座比丘闻已。好树下所有草敷叶敷。尽取持去。下座比丘从索不与。以是故。斗诤事起。佛言。不应持去。诸上座比丘闻不听持去。树下先有草敷叶敷及下座比丘自。所敷者。皆不与去。佛言。先者应留。余者听持去

佛与大比丘众。迦尸国中游行诸大弟子。舍利弗目连阿那律难提金毗罗等。皆悉随从。是诸长老所言真实。能苦切语折伏众人。与诸比丘作诸羯磨。苦切羯磨依止羯磨下意羯磨驱出羯磨。尔时迦罗山上有诸比丘。不念护戒。闻佛与大比丘众舍利弗目连阿那律难提金毗罗等迦尸国游行。是诸长老所言真实。能苦切语折伏众人。与诸比丘作苦切羯磨依止羯磨下意羯磨驱出羯磨。是等今来。将无为我等作诸羯磨。佛比尼中说不得以僧房羯磨与一比丘。我等今以此僧房作四分。随僧地房舍园林根茎枝叶花果。皆作四分。作是念已。即分僧房僧地房舍园林根茎枝叶花果。皆分作四分。羯磨与四比丘佛与诸比丘游行次到是处。是中旧比丘敷一好房与佛。小远避藏作是念。恐佛约敕。为诸比丘开房与卧具分。诸客比丘来。洗脚处讲堂门屋经行处经行头持衣钵着是诸处立待卧具分。佛见诸比丘以衣钵着是处待卧具分。知而故问阿难。诸比丘何故以衣钵着洗脚处讲堂门屋经行处经行头住何所待。答言。世尊。是诸比丘。待旧比丘与卧具分。佛告阿难。汝往约敕旧比丘。开房与客比丘卧具。阿难受教。即往语旧比丘。开房与客比丘房舍卧具。旧比丘言。此处僧坊房舍园林根茎枝叶花果皆作四分。羯磨与四比丘。非是僧物。是中有比丘。少欲知足行头陀。闻是事心不喜。呵责言。云何名比丘。以僧坊分作四分。羯磨与四比丘。呵已向佛广说。佛言。从今不听以僧房舍分作四分。若分者突吉罗。此不成为分

佛在阿罗毗国。尔时阿罗毗国僧坊崩坏佛知故问阿难。是僧房重阁何故崩坏。答言。世尊。修治是僧坊人。有死者病者反戒者余国去者。佛言。死者反戒者所应作事。僧更应羯磨立知是事人。若有病者应问。汝故能治是坏房舍不。若言我能。应待。若言不能应更立余人。他国去者。若疑当还。应待。若知不还者。应更立余人。令知是人所作事。佛作是语已。诸比丘便立知事人。是知事人。有扫少地者。有塞小孔者。或以少草覆舍者。佛言。如是作小小事者。不应立作知事人。若能办大事。应羯磨立作知事人。诸比丘有能多致财物能成办事者。诸比丘便尽形立作知事人。佛言。不应尔。若房舍故坏。应六年立作。若新房舍。应十二年立作。佛言。从今知房舍人。应三事自恣。冬房春房夏房。僧问言。汝须何房。冬房春房夏房耶。若言我须冬房。以春房夏房随上座次与。若言我须夏房。以冬房春房随上座次与

佛在王舍城。尔时跋提居士。起僧房重阁高大庄严多诸男女观看。诸人生念。此必佛塔。若阿罗汉塔。是僧坊中多人礼拜围绕。多象声马声男女声。妨坐禅读经。尔时长老上座。舍是重阁住小房中。时有客比丘来者。皆作是念。重阁中必有上座。我等何不至边小房住。即往打户。房内应声。客比丘问。汝几岁。答言。我尔所岁。客比丘念。若小房中比丘尔所岁者。何况大房。有诣洗脚处讲堂中门屋下宿。晨起至重阁前。立欲礼敬上座。有年少比丘及沙弥。从重阁上来下。问客比丘。汝作何等。答言。欲礼敬上座。语言。此无上座。问言。唯是中宿。答言。我等。客比丘言。我等知者应是中宿。问客比丘。汝何处宿。有洗脚处宿者。答言洗脚处宿。讲堂中者。答言讲堂中宿。乃至门屋下者。答言门屋中宿。诸比丘以是事白佛。佛言。应立知敷卧具人。知敷卧具人。应随上座次第与。应作是言。此是上座房舍卧具次第住

佛在迦尸国。与大比丘众一处安居。诸居士见佛及僧众。故共相约令。今日汝办种种饮食。明日次某。如是展转种种饮食。相食故作食。十五日食。三十日食。立如是制已。有早办者。有晚办者。有近者有远者。有美者有不美者。是中无知食比丘约敕令至某家。有早办者。有晚办者。有近者。是食美好。尔时六群比丘数数从是处取。居士问言。汝等何以数来。诸大长老何故不来。答言。无知食人约敕我等。汝舍近早办饮食美好。是故我等数来。居士言。我等施食为诸长老。不但为汝等。何故数来。诸比丘不知云何。是事白佛。佛言。应立知食人。立知食人法者。一心和合僧应问言。谁能为僧作知食人。是中若有一比丘言我能。若有五法。不应立作知食人。何等为五。随爱随嗔随怖随痴不知得不得。若成就五法。应立作知食人。何等五。不随爱不随嗔不随怖不随痴知得不得。即时一比丘应僧中唱言。大德僧听。比丘某甲。能为众僧作差食人。若僧时到僧忍听。某甲比丘作差食人。是名白。如是白二羯磨。僧立某甲比丘作差食人竟。僧忍默然故。是事如是持。差食人法者。应次第差。若汝某甲至某家。所差比丘。有早得者。有晚得者。近得者远得者。有得美者得不美者。有晚得者作是言。故与我是处。得远处者亦言。故与我远处。得不美者言。故与我如是中间。更作余语。佛言。应条名。有比丘得恶处者。便拭名改易好处。佛言。应书板作字集置一处和合从上座随次第取。有晚得者。有得远处者。早至主人门外。在巷头立待食久住。心闷吐逆不乐。诸居士出见语言。我等门内自恣听汝入坐。比丘言。佛未听我等入白衣门内坐待食。是事白佛。佛言。听是比丘入白衣门内坐待食。时有象声马声男女声。妨读经坐禅。佛言。若妨者出门外。门外待时。诸人来绕四边看。见已皆笑。是事白佛。佛言。应作土基。为风雨所恼。佛言。听作屠苏覆。薄故雨漏。佛言。应厚覆。厚覆已脊上漏。佛言。更覆。又无坐处。佛言。应觅板木坐上。有人偷板去。佛言。应陷着地中。又复失去。佛言。应作土埵。不泥故。中有毒蛇蜈蚣。啮诸比丘。佛言。应泥。泥已粗涩破衣。佛言。应以细埿。诸比丘须水。佛言。应作井。作井已即以钵键镃取水甚难。佛言。应作瓶取水。取水时不及。佛言。应以绳系。诸比丘手软牵绳手痛。佛言。应作辘轳有人堕井。佛言。应作栏。长老优波离问佛。以何物作井栏。佛言。应以木石塼作。作已有妇女大小诣井取水。时两手相触。佛言。井上作隔障。应各在一边汲水。有居士从舍内出。语比丘言。我某僧坊作食。汝尔所人往彼僧坊中食。去时道中师子虎狼熊罴诸难。是事白佛。佛言。应语檀越。是中有如是怖畏。此间与我食

佛在王舍城。尔时诸居士作种种粥。酥粥胡麻粥油粥乳粥小豆粥磨沙豆粥麻子粥薄粥。办是粥已。持诣竹园。时六群比丘在僧坊门边立。遥见已问言。持何等物。答言。是粥。又问。何等粥。答言。酥粥胡麻粥油粥乳粥小豆粥磨沙豆粥麻子粥薄粥。尔时六群比丘言。我等行去。先与我等酥粥胡麻粥油粥乳粥小豆粥磨沙豆粥麻子粥。汝持薄粥入僧坊与上座。诸比丘闻不知云何。是事白佛。佛言。从今应羯磨立分粥人。所持盛粥器。即用是器分粥。是中酥粥胡麻粥油粥乳粥小豆粥磨沙豆粥麻子粥。上座得上肥腻者。下座得底滓。若分薄粥时。上座得汁。下座得滓。是事白佛。佛言。从今听畜大盔大瓮。以粥集着是器中和合。以大钵大键镃分与。分与时不便。佛言。应作杓用分。用分已有残者有不足者。佛言。应更作小杓用分

佛在王舍城竹园中。诸居士办种种带钵那。胡麻欢喜丸。石蜜欢喜丸。蜜欢喜丸。舍俱梨饼。波波罗饼。曼提罗饼。象耳饼。馄饨饼。阎浮梨饼。持是饼向僧坊。六群比丘早起在门边立。见已问言。持何等物。答种种带钵那饼。所谓胡麻欢喜丸。石蜜欢喜丸。蜜欢喜丸。舍俱利饼。波波罗饼。曼提罗饼。象耳饼。馄饨饼。阎浮梨饼。六群比丘言。我欲行去。先与我等胡麻欢喜丸石蜜欢喜丸舍俱梨饼波波罗饼曼提罗饼。汝持象耳馄饨持阎浮梨饼入与上座。诸比丘不知云何。是事白佛。佛言。应羯磨立分带钵那人。分带钵那人。应和合等分。若更有美者来。亦应次第与。若今日不遍者。明日更有。应续次与

佛在王舍城。尔时诸居士办种种药。所谓酥油蜜石蜜姜胡椒荜茇黑盐诃梨勒鞞醯勒阿摩勒波栌路毗咒曼陀多耶摩那伽头栌醯持诣竹园。尔时六群比丘早起门边立。见已问言。持何等物。答言。种种药。所谓酥油蜜石蜜姜椒荜茇黑盐诃梨勒鞞醯勒阿摩勒波栌路毗咒曼陀多耶摩那伽头栌醯。六群比丘言。我欲行去。与我酥油蜜石蜜姜椒荜茇黑盐。汝持诃梨勒鞞醯勒呵摩勒波栌路毗咒曼陀多耶摩那伽头栌醯入僧坊与上座。诸比丘不知云何。是事白佛。佛言。从今应立分药人。分药人和合平等分与。若有贵价药来者。应别举置。若病比丘索者。应与两钱半价药。若索多者。应从索直

佛在阿罗毗国。尔时阿罗毗国诸比丘。常从居士索作器。诸居士言。我等云何能常供给汝。汝等何不自畜作器。答言。佛未听我等畜作器。是事白佛。佛言。从今听畜作器。阿罗毗国僧坊中。有客作木师。有半月客作者。有一月一岁客作者。是木师昼日作。暮去留作器。便失。佛言。应立知作器比丘。立知作器比丘。作竟持作器聚在一处。又复失尽。是事白佛。佛言。应羯磨一房舍举作器。立作器房法者。一心和合僧一比丘僧中唱言。大德僧听。某房舍。僧立作举作器房。若僧时到僧忍听。某房作举作器处。是名白。如是白二羯磨。僧立某房作举作器房竟。僧忍默然故。是事如是持。立是房已。知作器比丘。便持作器着上下二房中。佛言。不应置两处。若着上房者。下房应与僧。若着下房。应与僧上房。又一时诸比丘从憍萨罗国向舍卫国。道中过一空僧坊中宿。诸比丘明日入村乞食。诸居士问。汝何处宿。答言。僧坊中宿。是何房舍中宿。答言。某房中。居士言。此是我房。何不遣使语我等。当供养汤药油灯烛卧具种种所须。诸居士随所房中宿者。各自将归。与敷坐处坐。自手行水。自与多美饮食。自恣饱满。以水澡漱。取小床坐听说法。语诸比丘。我僧房中有卧具前食后食。何不住此。复当供养衣被愿令是僧坊有。用诸比丘不知云。何是事白。佛佛。言从今。听若先空僧坊。中诸比丘欲去。应羯磨立一比丘令常住。知僧坊立法者。一心和合僧问言。谁能作常住比丘。知某甲空增坊。若有比丘言我能。有五法。不应立作常住比丘。何等为五。随爱随嗔随怖随痴不知分别应作不应作。若成就五法。应立作常住比丘。不随爱不随嗔不随怖不随痴知分别应作不应作。即时一比丘僧中唱言。大德僧听。某甲比丘。能作常住知某甲空僧坊人。若僧时到僧忍听。立某甲比丘常住知某甲空僧坊人。是名白。如是白二羯磨。僧立某甲比丘常住知某甲空僧坊竟。僧忍默然故。是事如是持。知空僧坊常住比丘。应巡行僧坊。先修治塔。次作四方僧事。次知僧料理饮食事。次知应可分物。次知上座中座下座比丘事。随有大德高明比丘。不应作使知僧坊比丘。应作是愿。诸比丘未来者。当来。已来者供给衣食卧具汤药。不令有乏。能作是愿行者。僧随彼意与若须食。应自恣与好食。若须房舍卧具。皆应自恣与

有众多王臣。数数诣竹园房舍观看。若来时索食薪火灯烛。若与畏犯。不与惧作患。不知云何。以是事白佛。佛言。应立分处人。立分处人已。不白众僧。得用十九钱供给客。若更须。应白僧竟与

憍萨罗国有阿练儿住处。尔时有贼到阿练儿处乞食。作食人言。食不由我不得与汝。汝自从沙弥索。诸贼即从沙弥索。沙弥言。我不得与汝。汝自从知食比丘索。即从知食比丘索。知食比丘言。为僧故办是食。不为汝等。贼相谓言。是比丘何肯正尔与我食。便捉一比丘手脚截腰断。诸比丘不知云何。是事白佛。佛言。若有如是怖畏处。若少乞与少。若乞半与半。若都索都与。莫以是因缘故得大衰恼

佛在王舍城。尔时众僧得衣。无人守护。佛言。应立守护衣人。立守护衣人法者。一心和合僧应问言。谁能为僧守护诸衣。若比丘言我能若有五法不应立。何等五。不知是衣所从得。不知衣价若得衣不知云何受。不知头数。忘着衣处。若成就五法应立。何等五。知衣所从得。知是衣价。知应受。知头数。不忘着衣处。即时一比丘僧中唱言。大德僧听。是某甲。能为僧作守护衣人。若僧时到僧忍听。僧立某甲比丘作守衣人。是名白。如是白二羯磨。僧立某甲比丘作守护衣人竟。僧忍默然故。是事如是持。立守衣人已。未有分衣人。佛言。应立分衣人。立法者。一心和合僧应问言。谁能为僧作分衣人。若有比丘言我能。若有五法不应立。何等五。不知衣财。不知衣色。不知衣价。不知衣头数。不知与未与。复有五法。不应立作分衣人。何等五。随爱随嗔随怖随痴不知与未与。若比丘成就五法。应立作分衣人。知衣财知衣色知衣价知衣头数知与未与又有五法。不随爱不随嗔不随怖不随痴知与未与。即时一比丘僧中唱言。大德僧听。某甲比丘。能为僧作分衣人。若僧时到僧忍听。僧立某甲比丘作分衣人。是名白。如是白二羯磨。僧立某甲比丘作分衣人竟。僧忍默然故。是事如是持

佛在舍卫国。无分浴衣人。是事白佛。佛言。应立分浴衣人。是知分浴衣人。应随上座次与。佛在舍卫国。尔时只陀林中僧坊中。无比丘知时限唱时。无人打揵稚。无人扫洒涂治讲堂食处。无人次第相续敷床榻。无人教净果菜。无人看苦酒中虫。饮食时无人行水。众散乱语时。无人弹指。是事白佛。佛言。应立维那。立法者。一心和合僧应问。谁能为僧作维那是中若比丘言我能。有五法。不应立作维那。何等五。随爱随嗔随怖随痴不知净不净。若成就五法。应立作维那。五法者。不随爱不随嗔不随怖不随痴知净不净。即时一比丘僧中唱言。大德僧听。是某甲比丘。能为僧作维那。若僧时到僧忍听。僧立某甲比丘作维那。是名白。如是白二羯磨。僧立某甲比丘作维那竟。增忍默然故。是事如是持。作维那比丘。应知时限知唱时知打揵稚。知扫洒涂治讲堂食处。知次第相续敷床榻。知教净果菜。知看苦酒中虫。知饮食时行水。众散乱语时弹指。尔时诸沙弥。随与和上阿阇梨作。随同和上阿阇梨。随相识共语共事。随同国土同城邑同聚落。诸比丘无沙弥者。有诸恼乱。是事白佛。佛言。应立一人为主使沙弥作。先修治塔事。次作四方僧事。次作饮食事。次作可分物。次教与上座中座下座。如是周遍一切僧作。应立分处沙弥人。立分处沙弥人竟。应教先修治塔事。四方僧事作饮食事。次作可分物。次第与上座中座下座。如是周遍一切僧作

佛在王舍城。尔时瓶沙王。往诣竹园观看。王问。长老摩诃迦叶今何所在。比丘答言。大王。长老大迦叶。今于耆阇崛山上蹋泥。王即往见问言。大德。何故自作。答言。大王。谁当为我作。王言。我当与作人语已便还。第二瓶沙王。又时往到竹园观看。王问。长老大迦叶今何所在。比丘答言。于耆阇崛山上蹋泥。王即往见问言。大德。何故自作。答言。大王。谁当为我作。王言。我当与作人。大迦叶答言。大王。数数。语而不与。时王惭愧小却一面。问诸大臣。我先有是言不。大臣答言。王先有是言。王言。何时。答言。某时日月。即计。先语已来经五百日。王即下山。时人捕得五百群贼与王。王问。此是何人。答言。是贼。王问。应与何罪。大臣答言。罪应至死。王问贼言。汝能随我意行不。贼言。大王。欲何所作。王言。汝等能供给善人以不。贼言。若我等受王大恩。不随行者当随阿谁。大臣言。此贼必当偷夺诸比丘物。王言。我能作方便令不偷夺。时王多给田宅人民倍与粟食。去竹园不远。立作净人聚落。时诸净人。随相识共语共事。随同国城邑随怖畏。随有因缘者供给。余者不供给。是事白佛。佛言。应立使净人率。应教先作塔事。次作四方僧事。次作饮食事。次作可分物事。次教与上座中座下座作。如是周遍一切僧作。听立使净人主者。还立白衣中勤修能处分者(八法中卧具法第十竟)

十诵律卷第三十四十诵律卷第三十五(第五诵之七)

        后秦北印度三藏弗若多罗译

    八法中诤事法第八

佛在王舍城。尔时诸比丘。共比丘诤。恶口相言。诸比丘尼共比丘尼诤。诸式叉摩尼共式叉摩尼诤。诸沙弥共沙弥诤。诸沙弥尼共沙弥尼诤。恶口相言。迦留陀夷比丘。共诸比丘诤。恶口相言已。随顺佐助诸比丘尼。是中有比丘。少欲知足行头陀。闻是事心不喜。诃责言。云何名比丘。共比丘诤已。强佐助比丘尼。如是诃已。向佛广说。佛以是事集比丘僧。知而故问迦留陀夷比丘。汝实作是事不。答言。实作世尊。佛种种因缘诃责迦留陀夷比丘已云何名比丘。共诸比丘诤恶口相言已。强佐助诸比丘尼。如是诃已语诸比丘。从今有四种诤事出。一者斗诤事。二者无根事。三者犯罪事。四者常所行事。斗诤事者。如诸比丘共比丘诤恶口相言。是法是非法。是善是不善。是中共诤故。相助别异。是名斗诤事。无根事者。如诸比丘出余比丘犯罪。若有残作。有残不作。有残作不作。若无残作。无残不作。无残作不作。若有残无残作。有残无残不作。有残无残作不作。是中出犯罪。无根故。共相缠着。是名无根事。犯罪事者。有五种犯。犯波罗夷僧伽婆尸沙波逸提波罗提提舍尼突吉罗。若犯若污若不悔。是名犯罪事。常所行事者。众僧所作事。若白一羯磨。白二羯磨。白四羯磨。布萨自恣。立十四人羯磨。是名常所行事。斗诤事者。以何为本。有十四破僧因缘及六斗诤本。是名斗诤事本。无根事。以何为根本。有三根本。见根闻根疑根。若比丘与比丘斗诤相言。己身作罪令他人说。有残作有残不作。有残作不作。若无残作无残不作。无残作不作。若有残无残作。有残无残不作。有残无残作不作。若口若意作罪。令他人说。有残作有残不作。有残作不作。无残作无残不作。无残作不作。有残无残作。有残无残不作。有残无残作不作。从是中出他罪异。是名无根事根本。犯罪诤。以何为本。从何事起。从五种犯起。以五种犯为本。有犯身作非口非心作。有犯口作非身非心作。有犯身作心作非口作。有犯口作心作非身作。有犯身作口作心作。无但心犯。从是犯起。是名犯罪根本。常所行事。以何为本。从何事起。所作事从僧起。僧为根本。是名常所行事根本。所有斗诤。皆名诤事耶。有诤事亦名斗诤耶。有斗诤非诤事。有诤事非斗诤。有斗诤亦是诤事。有非斗诤非诤事。有斗诤非诤事者。若比丘但相道说。未成斗诤。有诤事非斗诤者。三种诤事。有斗诤亦是诤事者。若比丘相道说。亦成斗诤事。有非斗诤非诤事者。除上三句。所有无事诤。皆名为诤事耶。有诤事亦名无事诤耶。有无事诤非诤事。有诤事非无事诤。有无事诤亦诤事。有非无事诤非诤事。有无事诤非诤事者。但说他罪未起诤事。有诤事非无事诤者。三种诤事是。有无事诤亦诤事者。有比丘无事诤亦起诤事。非无事诤非诤事者。除上三句。所有犯罪。皆名诤事耶。有诤事亦名犯罪耶。有犯罪非诤事。有诤事非犯罪。有犯罪亦诤事。有非犯罪非诤事。有犯罪非诤事者。所名犯罪。有诤事非犯罪者。三种诤事。有犯罪亦诤事者。所名犯罪亦诤。非犯罪非诤事者。除上三句。所有常所行事。皆名诤事耶。有诤事亦名常所行事耶。有常所行事非诤事。有诤事非常所行事。有常所行事亦诤事。有非常所行事非诤事。有常所行事非诤事者。所名作法。有诤事非常所行者。三种诤事。有常所行亦诤事者。常所行亦诤。非常所行事非诤事者。除上三句。斗诤事。为善为不善为无记。或善或不善或无记。云何名善。有诸比丘善心共诤。所谓是法是非法。是律是非律。是名善。云何不善。有比丘不善心共诤。是法是非法。是律是非律。是名不善。云何名无记。有诸比丘不以善心不善心共诤。是法是非法。是律是非律。是名无记。无根事诤。为善为不善为无记。或善或不善或无记。善者。若诸比丘善心共诤。出他比丘罪。有残作有残不作。有残作不作。无残作无残不作。无残作不作。有残无残作。有残无残不作。有残无残作不作。是名为善。不善者。若诸比丘。不善心共诤出他罪。有残作有残不作。有残作不作。无残作无残不作。无残作不作。有残无残作。有残无残不作。有残无残作不作。是名不善。无记者。若诸比丘。不以善心不善心。共诤出他罪。有残作有残不作。有残作不作。无残作无残不作。无残作不作。有残无残作。有残无残不作。有残无残作不作。是名无记犯罪事。为善为不善为无记耶。犯罪事。或不善或无记。不善者。若诸比丘知佛结戒故犯。是名不善。无记者。不故犯佛所结戒。是名无记。常所行事。为善为不善为无记。或善或不善或无记。善者。若诸比丘善心。作白羯磨白二羯磨白四羯磨布萨自恣立十四人羯磨。是名善。不善者。若诸比丘以不善心。作白羯磨白二羯磨白四羯磨布萨自恣立十四人羯磨。是名不善。无记者。若诸比丘不以善心不善心。作白羯磨白二羯磨白四羯磨布萨自恣立十四人羯磨是名无记。长老优波离问佛。斗诤事。以几灭诤事灭。佛言。以二灭诤事灭。何等二。以现前比尼灭及多觅比尼灭。又问。世尊。无根事。以几灭诤事灭。佛言。以四灭诤事灭。以现前比尼及忆念比尼灭。现前比尼及不痴比尼灭。现前比尼及实觅比尼灭。又问。世尊。犯罪事。以几灭诤事灭。佛言。以三灭诤事灭。现前比尼及自言比尼灭。现前比尼及布草比尼灭。又问。世尊。常所行事。用几灭诤事灭。佛言。以一灭诤事灭。现前比尼灭。斗诤事。云何以二灭诤事灭。随以何住处有诤相言比丘。是事付闼赖吒断。闼赖吒比丘。应受此事如法如比尼如佛教灭。若闼赖吒比丘。能如法如比尼如佛教灭者。是事名灭以一灭诤事灭。谓现前比尼。现前者。人现前比尼现前。人现前者。是中随助举事人有事人共集一处。是名人现前。比尼现前者。如法如毗尼如佛教灭是事。是名比尼现前。若是闼赖吒。不能如法如比尼如佛教断是事者。应舍付僧。僧应受是事如法如比尼如佛教断是事。若僧能如法如比尼如佛教断是事者。是名为断用一比尼。所谓现前比尼。现前比尼者。僧现前人现前比尼现前。僧现前者。是中所有可中共作羯磨比丘。共同心和合一处。可受欲者持欲来。现在比丘能遮者不遮。是名僧现前。人现前者。有随助举事人有事人共集一处。是名人现前。比尼现前者。如法如比尼如佛教断是事。是名为断。若僧不能如法如比尼如佛教断是事者。尔时应僧中立二乌回鸠罗。应羯磨此人令断是事。羯磨者。一心和合僧。一比丘僧中问言。谁能作乌回鸠罗。如法如比尼如佛教断是事。僧中若言我能。若有五法。不应立作乌回鸠罗。何等五。随爱行随嗔行随怖行随痴行不知断不断。成就五法。应立作乌回鸠罗。不随爱行不随嗔行不随怖行不随痴行知断不断。即时一比丘应僧中唱言。大德僧听。某甲某甲比丘。能作乌回鸠罗。如法如比尼如佛教。断随僧中事。若僧时到僧忍听。立某甲某甲比丘作乌回鸠罗。能如法断随僧中事。是名白。如是白二羯磨。僧立某甲某甲比丘作乌回鸠罗断随僧中事竟。僧忍默然故。是事如是持。是二乌回鸠罗比丘。若是上座。诸下座比丘。应与此二人欲已远去。若此二乌回鸠罗是下座。应从诸上座取欲已小远去。当如法如比尼如佛教断是事。若二乌回鸠罗。能如法如比尼如佛教断是事者。是名为断用一比尼。所谓现前比尼。现前比尼者。僧现前人现前比尼现前。僧现前者如上说。人现前比尼现前亦如上说。若二乌回鸠罗。不能如法如比尼如佛教断是事者。是二乌回鸠罗。应更立二乌回鸠罗。立法者。一心和合僧。一比丘僧中问言。谁能作乌回鸠罗。断随僧中事。若言我能。一比丘僧中唱言。大德僧听。某甲某甲比丘。能作乌回鸠罗。如法如比尼如佛教断随僧中事。若僧时到僧忍听。僧立某甲某甲比丘作乌回鸠罗。能如法断随僧中事。是名白。如是白二羯磨。僧立某甲某甲比丘作乌回鸠罗断随僧中事竟。僧忍默然故。是事如是持。是二乌回鸠罗。若是上座。诸下座比丘。应与欲已小远去。若二乌回鸠罗是下座。应从诸上座比丘取欲已小远去。当如法如比尼如佛教断是事。若二乌回鸠罗。能如法如比尼如佛教断是事者。是名为断用一比尼。所谓现前比尼。现前比尼者。僧现前人现前比尼现前。僧现前者如上说。人现前比尼现前亦如上说。若是二乌回鸠罗。不能如法断者。还付先二乌回鸠罗。先二乌回鸠罗。应如法如比尼如佛教断。若能如法断是事者。是名为断用一比尼。谓现前比尼。现前比尼者。僧现前人现前比尼现前。僧现前者如上说。人现前比尼现前亦如上说。若是先二乌回鸠罗。复不能如法如比尼如佛教断是事者。应舍付僧。僧应受是事如法如比尼如佛教断。若僧取是事。能如法如比尼如佛教断者。是名为断用一比尼。谓现前比尼。现前比尼者。僧现前人现前比尼现前。僧现前如上说。人现前比尼现前亦如上说。僧不能如法如比尼如佛教断是事者。僧应遣使往近住处僧所作是言。此事如是如是因缘起。闼赖吒不能断。众僧不能断。二乌回鸠罗不能断。后二乌回鸠罗复不能断。还先二乌回鸠罗。复不能断。还僧复不能断。汝等大德。和合为断是事故。即时彼众应和合。若僧先安居。应受七日去。若七日尽。应受三十九夜去。若三十九夜尽。应破安居来集一处。受是事应断。近处僧应受是事。如法如比尼如佛教断是事。若近处僧。能如法如比尼如佛教断者。是名为断用一灭诤事灭。所谓现前比尼。现前比尼者。僧现前人现前比尼现前。僧现前如上说。人现前比尼现前亦如上说。若近处僧。不能如法如比尼如佛教断是事者。尔时。应僧中立二乌回鸠罗令断。立二乌回鸠罗羯磨法者。一心和合僧。一比丘僧中问言。谁能作乌回鸠罗。如法如比尼如佛教。断此随僧中事。是中若言我能。若有五法。不应立作。何等五。随爱随嗔随怖随痴不知断不断。若成就五法。应立作乌回鸠罗。不随爱不随嗔不随怖不随痴知断不断。即时一比丘僧中唱言。大德僧听。某甲某甲比丘。能作乌回鸠罗。能如法如比尼如佛教。断随僧中事。若僧时到僧忍听。某甲某甲比丘作乌回鸠罗。如法断随僧中事。是名白。如是白二羯磨。僧立某甲某甲比丘作乌回鸠罗断随僧事竟。僧忍默然故。是事如是持。是二乌回鸠罗比丘。若是上座。诸下座比丘。应来与此二乌回鸠罗比丘欲已小远去。若此二乌回鸠罗比丘是下座。应从上座比丘取欲已小远去。当如法如比尼如佛教断是事。是二乌回鸠罗。若能如法如比尼如佛教断是事者。是名为断用一比尼。谓现前比尼。现前比尼者。僧现前人现前比尼现前。僧现前者如上说。人现前比尼现前亦如上说。若二乌回鸠罗。不能如法如比尼如佛教断是事者。应更立二乌回鸠罗。立法者。一心和合僧中问言。谁能作乌回鸠罗。如法断随僧中事。若言我能。一比丘僧中唱言。大德僧听。某甲某甲比丘。能作乌回鸠罗。如法断随僧中事。若僧时到僧忍听。某甲某甲比丘。作乌回鸠罗。断随僧中事。是名白。如是白二羯磨。僧立某甲某甲比丘作乌回鸠罗断随僧中事竟。僧忍默然故。是事如是持。是二乌回鸠罗。若是上座。诸下座比丘。应与欲已小远去。若二乌回鸠罗是下座。应从诸上座取欲已小远去。应如法如比尼如佛教断是事。若二乌回鸠罗。能如法如比尼如佛教断是事者。是名为断用一比尼。谓现前比尼。现前比尼者。僧现前人现前比尼现前。僧现前如上说。人现前比尼现前亦如上说。若是乌回鸠罗。不能如法断是事者。应还付先鸠罗。先鸠罗应受是事。如法如比尼如佛教断是事。是乌回鸠罗。若能如法如比尼如佛教断是事者。是名为断用一比尼。谓现前比尼。现前比尼者。僧现前人现前比尼现前。僧现前者如上说。人现前比尼现前亦如上说。若是先乌回鸠罗。复不能如法如比尼如佛教断者。应舍付僧。僧应受是事。如法如比尼如佛教断。用一比尼。谓现前比尼。现前比尼者。僧现前人现前比尼现前。僧现前如上说。人现前比尼现前亦如上说。若是近住处僧。不能如法如比尼如佛教断是事者。近处僧。若闻某处有众僧好上座知说波罗提木叉法。是僧多有比丘持修多罗者。持比尼者。持摩多罗伽者。是近住处僧。应以是事遣使至某处大僧中。应先立传事人。若界外令满众僧数。立法者。一心和合僧应问。谁能作传事人。从是处持是事至某处。若道中能断是事。是中若有人言我能。若有五法。不应立作传事人。随爱随嗔随怖随痴不知灭不灭。若成就五法。应立作传事人。不随爱不随嗔不随怖不随痴知灭不灭。尔时传事人。应持是事去。若道中能如法如比尼如佛教断是事者。是名为断用一比尼。谓现前比尼现前比尼者。僧现前人现前比尼现前。僧现前如上说。人现前。比尼现前亦如上说。若传事人。不能道中如法如比尼如佛教断者应持至彼住处。至彼住处已。是中若有上座多知多识长老比丘。应语是人言。是事诤事如是因缘起。闼赖吒不能断。众僧不能断。先二乌回鸠罗不能断。后二乌回鸠罗不能断。还付先二乌回鸠罗。复不能断。还付僧。僧复不能断近住处僧亦不能断。近住处二乌回鸠罗不能断。后二乌回鸠罗亦不能断。还付先二乌回鸠罗。复不能断。还付近住处僧。复不能断。传事人道中不能断是事。来至此间。汝长老。能受是事断不。若言能断。应与作期。若不作期不得与汝。期者。乃至九月。事有五种难断。一者坚。二者强。三者佷戾。四者往来。五者疑畏。坚者。执是事。强者。举事人有事人。剿健强力。佷戾者。举事人有事人恶性佷戾恶性。往来者。此事从一住处至一住处。疑畏者。诸比丘畏断事时破一心和合僧作两段故。先应立行筹人。如是应立。一心和合僧应问。谁能作行筹人。是中有人言我能。有五法不应立作行筹人。随爱随嗔随怖随痴不知行筹不行筹。若成就五法。应立作行筹人。不随爱不随嗔不随怖不随痴知行筹不行筹。是中一比丘唱言。大德僧听。某甲比丘。能为僧作行筹人。若僧时到僧忍听。僧立某甲比丘作行筹人。是名白。如是白二羯磨。僧立某甲比丘作行筹人竟。僧忍默然故。是事如是持。若比丘已作行筹人。随僧多少应作二种筹。一分长。一分短。一分白。一分黑。说如法者。为作长筹。说非法者。为作短筹。说如法者。为作白筹。说非法者。为作黑筹。说如法筹以右手捉。说非法筹以左手捉。说如法筹缓捉。说非法筹急捉。先行说如法筹。后行说非法筹。行筹人应作是言。此是说如法者筹。此是说非法者筹。若行筹竟。说如法者筹乃至多一。是事名断用二比尼。谓现前比尼多觅比尼。现前比尼者。是中若有随助举事人有事人。共和合一处现前。如法如比尼如佛教现前除断。是名现前比尼。是中多觅比尼者。是中应求觅往来问如法除断。若说非法者筹乃至多一。是事亦名为断用二比尼。现前比尼多觅比尼。现前比尼者。是中若有随助举事人及有事人。共和合一处现前。如法如比尼如佛教除断。是名现前比尼。是中多觅比尼者。是中应求觅往来问非法除断。行筹人有四种。一者藏行筹。二者颠倒行筹。三者期行筹。四者一切行筹。藏行筹者。若有人闇中行筹。若有壁障处行筹。是名覆藏行筹。颠倒行筹者。若颠倒行筹。以说如法人筹与说非法人。以说非法人筹与说如法人。是名颠倒。期者。若诸比丘随和上阿阇梨作期。随同和上同阿阇梨随相识随共语。随善知识随同心。随国土随聚落。随处共作期。我等取如是如是筹。汝等莫远我边。莫别莫异莫不共语。共同一事。是名期。一切僧取筹者。尔时一切僧应和合一处。不得取欲何以故。或多比丘说非法故。是名一切僧取筹。若是众僧及大上座大长老。能如法如比尼如佛教断是事者。即名为断用一比尼。谓现前比尼。现前比尼者。僧现前人现前比尼现前僧现前如上说。人现前比尼现前亦如上说。若是众僧及上座。说波罗提木叉不能断是事者。应还付传事人。传事人应取是事于道中断。如法如比尼如佛教断。若是传事人。于道中能如法如比尼如佛教断是事者。是名为断用一比尼。谓现前比尼。现前比尼者如上说。若是传事人。不能如法如比尼如佛教断者。是比丘道中。若闻彼处僧坊中若有三比丘。若二若一比丘。能持修多罗持比尼持摩多罗伽。四部众所恭敬尊重。是传事人应到彼住处。应语一比丘言。大德。是事如是如是因缘起。闼赖吒不能断。僧不能断。先乌回鸠罗不能断。后乌回鸠罗不能断。还先乌回鸠罗复不能断。还僧复不能断。近住处僧亦不能断。先乌回鸠罗不能断。后乌回鸠罗不能断。还先乌回鸠罗复不能断。还近住处僧复不能断。传事人道中亦不能断。有大众僧及上座知说波罗提木叉不能断。传事人于道中不能断。三比丘二比丘。能持修多罗者。持比尼者。持摩多罗伽者。四众所恭敬者。皆不能断。大德取是事。如法如比尼如佛教断是事。是一比丘四众所恭敬尊重者。应作是言。不可二人相言俱得胜。是中必一胜一负。若作如是语者。是名说如法者。若不作如是语者。是名说非法者。若比丘如法灭事已。还更发起者波逸提。若但诃责突吉罗。有十种如法行筹。有十非法行筹。十非法行筹者。不以小事行筹。已过事行筹。不问长老行筹。非法行筹。别众行筹。非法别众行筹。用是行筹欲令多有非法者。用是行筹当多有非法者。用是行筹欲破和合僧。用是行筹当破和合僧。问言。云何名不以小事行筹。答不为可忏悔事行筹。已过事行筹者。是事从此住处到彼住处。不问长老行筹者。有比丘持修多罗比尼摩多罗伽者。不数往咨问。何善何不善。何者有罪何者无罪。何者白何者黑。何者今世利。何者后世利。何者导利人行。是好非恶。非法行筹者。不如法行筹。别众行筹者。同一界内别处行筹。非法别众行筹者。不如法同一界中别处行筹。用是行筹欲令多有非法者。是比丘先作意。用是行筹令多有说非法者。用是行筹当多有比丘非法者。是比丘先立意。用是行筹当多有说非法者。用是行筹欲破和合僧者。是比丘先作意。用是行筹令破和合僧。用是行筹当破和合僧者。是比丘先作意。我是行筹当破和合僧。是名十种非法行筹。十如法行筹者。以小事行筹。未过事行筹。问长老行筹。如法行筹。和合众行筹。如法和合众行筹。用是行筹欲令多有如法者。用是行筹当多有如法者。用是行筹欲令僧和合。用是行筹当和合僧。问云何名以小事行筹。答为可忏悔事行筹。未过事行筹者。是事在此住处未到彼住处。问长老行筹者。有比丘持修多罗比尼摩多罗伽者。数往咨问。何善何不善。何者有罪何者无罪。何者白何者黑。何者今世利。何者后世利。何者导利人行。是好非恶。如法行筹者。不违法行筹。和合众行筹者。同界内僧和合一处行筹。如法和合众行筹者。如法同界内众一处集行筹。用是行筹欲令多有如法者。是比丘先作意。以此行筹。令多有说如法者。用是行筹当多有比丘如法者。是比丘先作意。用是行筹当多有比丘说如法者。用是行筹欲和合僧者。是比丘先作意。用是行筹欲令僧和合。用是行筹当和合僧者。是比丘先作意。用是行筹当和合僧。是名十如法行筹。若僧事可付僧。可付三人二人一人。僧事者。僧应受僧事。三人二人一人应受僧事。僧应灭僧事。三人二人一人应灭。是名诤事用二比尼灭。云何无根事诤用四比尼灭。所谓现前及忆念灭。若现前及不痴灭。若现前及实觅罪灭。云何现前及忆念灭。如陀骠力士子比丘弥多罗比丘尼。以无根波罗夷法谤。以是事故。或僧或三人二人一人。数数说是事令忆念。是陀骠比丘。从僧乞忆念比尼。僧与忆念比尼。如法如比尼如佛教。现前比尼者。所与忆念比尼人。得忆念比尼者。和合一处。如法如比尼如佛教。是名现前及忆念比尼灭。云何现前及不痴灭。如施越沙比丘狂心颠倒。作种种恶不清净事不随顺道出家人所不应作。是人还得本心。以是事故。或僧或三人二人一人。数数说令忆念。是施越沙比丘。从僧乞不痴比尼。僧与不痴比尼。如法如比尼如佛教。是中何等是现前比尼。与不痴比尼人。得不痴比尼者。和合一处。如法如比尼如佛教。是名现前及不痴比尼灭。云何现前及实觅比尼。如象首比丘释子。无惭无愧犯见闻疑罪。先自言犯后言不作。僧与是人实觅比尼。如法如比尼如佛教。是中何等是现前比尼。与实觅比尼人。得实觅比尼者。和合一处。如法如比尼如佛教。是名现前比尼及实觅比尼灭。是名无根事用四比尼灭。所谓现前及忆念。现前及不痴。现前及实觅。问犯罪事云何以三灭诤事灭。答所谓现前及自言。现前及布草。云何现前及自言。如比丘若他比丘说罪若不说罪。若令忆念若不令忆念。自言。我犯僧伽婆尸沙。是比丘从僧乞别住。僧如法如比尼如佛教与别住。是中云何名现前。与别住人。及得别住者。和合一处。如法如比尼如佛教作。作者。与彼人作别。住是中云何复名如法自言。如比丘若他比丘说罪若不说。罪若令忆念若不令忆念。自言。我犯僧伽婆尸沙。是应与摩那埵本日治。应与出罪。是比丘从僧乞摩那埵本日治出罪羯磨。僧如法如比尼如佛教。作出罪羯磨。是事何等现前。与出罪人。得出罪者。和合一处。如法如比尼如佛教作。作者。与是比丘作出罪。是中云何复名如法自言。如比丘若他说罪若不说罪。若令忆念若不令忆念。自言。我犯可悔过罪。是中现前者。与悔过人。作悔过人。和合一处。如法如比尼如佛教作。作者。与作可悔过。是名现前比尼及自言比尼灭。又问。云何现前比尼及布草。如一住处诸比丘。喜斗诤恶口相言。是诸比丘和合一处。作是念言。我等大衰失利。我等于佛法中以信出家。而今作恶口相言。我等若求觅是事根本者。未起事便起。已起事不可灭。是中一比丘应唱言。大德僧听。若僧时到僧忍听。是事以布草比尼灭。是名白。即时是诸比丘。应分作两部。是中若有上座若次上座。若波罗提木叉通义。若波罗提木叉。语此一部言。我等大失非得大衰非利大恶不善。我等信故。佛法中出家求道。然今喜斗诤相言。若我等求是事根本者。僧中有未起事便起。已起事不可灭。今汝等当自屈意我等所作罪。除偷兰罪。除白衣相应罪。是事汝等现前发露悔过不覆藏。是中若无一比丘语者。应到第二部众所。是中有长老上座应语言。我等大失非得大衰非利大恶不善。我等信故。于佛法中出家求道。今喜斗诤相言。若我等求是事根本者。僧中未起事便起。已起事不可灭。今汝等当自屈意。我等所作罪。除偷兰遮。除白衣相应罪。今自为及为彼故。当现前发露悔过不覆藏。诸比丘言。汝自见罪不。答言。见罪。如法悔过莫复更起。第二部众亦应如是说。是名布草比尼。是中云何名现前。与布草人及得布草者。和合一处。如法如比尼如佛教作。作者。与作布草羯磨。是名现前及布草灭。是名犯罪事用三比尼灭。所谓现前自言布草。问常所行事。云何以一现前比尼灭。与作白人。得作白者。和合一处。如法如比尼如佛教作。白一羯磨白二羯磨白四羯磨。布萨说戒自恣受岁。立十四人羯磨。与羯磨人得羯磨者。和合一处。如法如比尼如佛教作者。是名常所行事用一比尼灭。所谓现前比尼(八法中诤事法第八竟)

十诵律卷第三十五十诵律卷第三十六(第六诵之一)

        后秦北印度三藏弗若多罗译

    杂诵第一(调达事上)

佛在王舍城。尔时调达。于佛法中信敬心清净。着三十万金钱直庄严具出家。乘调善象直十万金钱。是象以金网等庄严。亦直十万金钱。调达所著衣服。复直十万金钱。是调达出家作比丘。十二年中善心修行。读经诵经问疑受法坐禅。尔时佛所说法皆悉读诵。时诸比丘有大神通势力。以阎浮树故。名阎浮提。斯诸比丘。从是阎浮树取果还啖。去阎浮树不远。有诃梨勒林阿摩勒林鞞醯勒林。取是诸果还所住啖。从郁单越取自然粳米还啖。从忉利天取须陀天食还啖。东西南北现种种神力。调达见已即生贪心。作是念。我何时当能有大神通势力。以阎浮树故。名阎浮提。从是阎浮树取果还啖。去阎浮树不远。有诃梨勒林阿摩勒林鞞醯勒林。取是诸果还所住啖。从郁单越取自然粳米还啖。从忉利天取须陀食还啖。东西南北现种种神力。我今何不往诣佛所问神通道。作是念已。即诣佛所头面礼佛。问神通道。佛先知是人于此法中当作恶事。是故不说。语言。调达汝止。何用是神通道为。当观无常苦空无我。调达闻是语不忍不乐。但一心向神通力。作是念。舍利弗于佛第一经中说。诸智慧弟子中最上第一。我当往诣舍利弗所问神通道。当为我说。念已即往问神通道。舍利弗亦先知是人于此法中当作恶事。是故不说。语言。调达汝止。何用是神通道为。当观无常苦空无我。调达闻是语不忍不乐。但一心向神通道。作是念。目连于佛第一经中说。诸神通道弟子中最胜第一。我当往诣问神通道。当为我说。念已即往问神通道。目连先知是人于此法中当作恶事。是故不说。语言。调达汝止。何用神通道为。当观无常苦空无我。调达闻已不忍不乐。但一心向神通道。如是展转至最少一不满五百大弟子所皆不为说。尔时调达作是念。阿难是我弟。佛第一经中说。诸多闻弟子中阿难最胜第一。我何不往诣其所问神通道。当为我说。念已即往问神通道。阿难未离欲故。不知过去未来事。便以多闻慧为说神通道。调达受神通法已。于山林旷野坑谷中勤修习。勤修习故。得世俗四禅。因是四禅起神通力。起神通力已。以阎浮树故名阎浮提。从是阎浮树取果还啖。去阎浮树不远。有大诃梨勒林阿摩勒林鞞醯勒林。取是诸果还所住啖。从郁单越取自然粳米还啖。从忉利天上取须陀天食还啖。东西南北现种种神力。是调达先来恶心。于佛作是念。是沙门瞿昙。种姓不胜我。彼姓瞿昙生释家。我亦姓瞿昙生释家。诸人以清净心多有供养者。皆为神通力故。我于何家。以神通力摄取。令多人随顺我。作是念。瓶沙王于国中最大是佛不退转弟子。我正使神通力。牵终不可得。调达素知种种外书星宿。相人吉凶天地怪相。见瓶沙王太子阿阇世王相明了。我当以神通力摄取。决定是我檀越。以是因缘多人随从。作是念已。变身作象宝。于阿阇世太子家。不从门入从门中出。或从门入不从门出。现如是相欲令知是调达。复变身作马宝。或从非门入门中出。或从门入非门出。现如是相欲令知是调达。复现作宝鬘。从太子膝上出。时太子捉鬘以系额上。现如是相欲令知是调达。复现作端正小儿。着金宝璎珞。在太子膝上东西宛转。太子呜抱共戏唾其口中。现如是相欲令知是调达。以是神通力。牵阿阇世太子心。令生恶邪见。谓调达神通力胜佛。生爱敬心。供养衣服卧具汤药。乃至日日送五百釜饮食。五百乘车围绕。来至调达所。自手下食

尔时诸比丘。中前着衣持钵入王舍城乞食。闻阿阇世太子如是供养调达衣服卧具汤药。日日送五百釜饮食。五百乘车围绕自至调达所自手下食。调达与五百弟子受是供养。闻已食后往诣佛所。头面礼足却坐一面白佛言。世尊。我今日着衣持钵入城乞食。闻阿阇世太子如是供养调达衣服卧具汤药。日日送五百釜饮食。五百乘车围绕。自至调达所自手下食。调达与五百比丘受是供养。佛语诸比丘。汝等莫贪调达供养。何以故。是调达得供养。自损减故。如竹以实死。芭蕉实亦然。如骡怀妊死。调达得供养亦如是。为自损减故。譬如竹芦以实死尔时世尊。欲明了此事。而说偈言

  芭蕉以实死　　竹芦实亦然
  骡怀妊故死　　小人得养坏

此亦复如是。调达痴人。随几时得如是利养。随尔所时长夜受诸苦恼。生恶处故。语诸比丘。譬如健夫打破恶狗鼻。于汝等意云何。是狗宁更恶不。答言。实恶世尊。佛言。调达痴人亦如是。随几时得是供养。随尔所时长夜受苦恼。生恶处故。尔时调达。供养转增贪着供养覆心。生如是恶心。佛今舍僧者。我当将导众僧。生如是心时退失神通。尔时目连。在支提国迦陵伽卢谷中。时有迦扶陀比丘俱罗子。是长老目连弟子。是比丘舍离五欲修四梵行。命终生梵世。迦扶陀梵天。见调达退失神通。见已如壮士屈伸臂顷。于梵世没目连前现。从禅定起语目连言。汝知不。调达退失神通。汝向佛所说者善以是事白佛。目连作是念。我何不入定观调达心。即时入定观调达心。见已失神通。即从定起默然。受迦扶陀梵天语

尔时梵天。知目连默然受已。头面礼足右绕即没。目连受梵天请已。即入禅定。于支提国迦陵伽卢谷中没。于王舍城现。离佛不远

尔时目连。即从定起往诣佛所。头面礼佛足却坐一面白佛言。世尊。如迦扶陀梵天所说。调达实退神通

佛言。汝先不知调达心如迦扶陀梵天语耶。佛共目连作如是语时。调达即时与四弟子俱来。佛遥见调达来。语目连言。汝莫有所说。是痴人来自现其事。目连作是念。我何不入定于此座上令调达不见。即寻入定。于此座而调达不见。调达前诣佛所头面礼佛足。及四弟子却坐一面白佛言。世尊。年已老耄。可以众僧付我。佛但独受现法乐。令僧属我。我当将导。佛言。舍利弗目连有大智慧神通。佛尚不以众僧付之。况汝啖唾痴人死人。而当付嘱

尔时调达。闻佛说啖唾痴人死人如是名字。即便大嗔欲毁世尊。两眉垂下忧戚低头默然无说。作是思惟已即便起去。作是念言。佛但赞叹舍利弗目连令大。而毁呰我等使令卑小。是调达初向佛所生嗔恨心。及舍利弗目连等诸大弟子。尔时阿难在佛后立以扇扇佛。佛顾语阿难。诸比丘依王舍城住者令集讲堂。集已白我。阿难受教。即令诸比丘依王舍城住者皆集讲堂。集已往白佛言。世尊。依王舍城诸比丘已集讲堂。佛自知时。佛即将侍者阿难往诣讲堂。于众僧中敷座处坐。教化诸比丘。世有五师。何谓为五。一师者。不清净持戒。自言持戒清净。是弟子共住故。知师不持戒不清净自言持戒清净。若我等说师实者。或当不喜。若师不喜当云何说。我等蒙师故。得衣服卧具汤药饮食。师好看我等者。自当觉知。如是师为弟子覆护持戒。是师亦从弟子求覆护持戒。是世间初师。第二师者。不净命自言净命。弟子共住故。知师不净命自言净命。若我等说师实者。或当不喜。若师不喜当云何说。我等蒙师故。得衣服卧具汤药饮食。师好看我等者。自当觉知。如是师者为弟子覆护净命。是师亦从弟子求覆护净命。是名世间第二师。第三师者。知见不清净自言知见清净。弟子共住故。知师知见不清净自言知见清净。若我等说师实者。或当不喜。若师不喜当云何说。我等蒙师故。得衣服卧具汤药饮食。师好看我等者。自当觉知。如是师者为弟子覆护知见。是师亦从弟子求覆护知见。是名世间第三师。第四师者。不善记事自言善记事。弟子共住故。知师不善记事自言善记事。若我说师实者。或当不喜。若师不喜当云何说。我等蒙师故。得衣服卧具汤药饮食。师好看我等者。自当觉知。如是师者为弟子覆护善记事。是师亦从弟子求覆护善记事。是名世间第四师。第五师者。非说清净法自言说清净法。弟子共住故。知师非说清净法。自言说清净法。若我等说师实者。或当不喜。若师不喜当云何说。我等蒙师故。得衣服卧具汤药饮食。师好看我等者。自当觉知。如是师者为弟子覆护说清净法。是师亦从弟子求覆护说清净法。是名世间第五师。佛言。如来清净持戒。亦自言我清净持戒。诸弟子不覆护如来清净持戒。如来亦不求诸弟子覆护清净持戒。如来是净命。自言我净命。弟子不覆护如来净命。如来亦不求诸弟子覆护净命。如来是知见清净。自言我知见清净。诸弟子不覆护如来知见清净。如来亦不求诸弟子覆护知见清净。如来是善记事。自言我善记事。诸弟子不覆护如来善记事。如来亦不求诸弟子覆护善记事。如来是说清净法。自言我说清净法。诸弟子不覆护如来说清净法。如来亦不求诸弟子覆护说清净法。佛言。如来实有是法。何不如实说。佛非随顺他。又非弱语人。譬如陶师持坏瓶时不敢疾捉。如来是真实语了了语折伏语。若坚固者住。不坚固者去。汝等于如来法语中。宜应忍受

佛在王舍城。尔时调达。欲破和合僧。受持破僧事。妒心方便故作是念。我独不能得破沙门瞿昙和合僧坏转法轮。是调达有四同党弟子。一名俱伽梨。二名乾陀骠。三名迦留罗提舍。四名三闻达多。调达到是四人所。作是言。我与汝等。当共破沙门瞿昙和合僧坏转法轮。我等当得如是名声。破沙门瞿昙和合僧坏转法轮。我等能破。彼四人语调达言。沙门瞿昙诸弟子。有大智慧大神通力。得天眼知他心。是人知见我等欲破沙门瞿昙和合僧坏转法轮。我等云何能破。调达语四人言。沙门瞿昙有年少弟子。新入彼法出家不久。我等到是边用五法诱取。语诸比丘言。汝尽形寿受着纳衣。尽形寿受乞食法。尽形寿受一食法。尽形寿受露地坐法。尽形寿受断肉法。若比丘受是五法。疾得泥洹。若有长老上座比丘。多知多识久习梵行得佛法味。当语之言。佛已老耄年在衰末。自乐闲静受现法乐。汝所须事我当相与。我等以如是方便。能破沙门瞿昙和合僧坏转法轮。四比丘言。如是调达。调达后时。到诸年少比丘所。以五法诱之。语诸比丘言。汝尽形寿受着纳衣法。尽形寿受乞食法。尽形寿受一食法。尽形寿受露地坐法。尽形寿受断肉法。汝等行是五法。疾得泥洹。复语诸长老上座比丘。佛已老耄年在衰末。自乐闲静受现法乐。汝所须事我当相与。尔时调达。非法说法。法说非法。非律说律。律说非律。非犯说犯。犯说非犯。轻说重。重说轻。有残说无残。无残说有残。常所行法说非常所行法。非常所行法说常所行法。非教说教。教说非教。时诸比丘。见调达欲破和合僧坏转法轮已。往诣佛所头面礼佛足却坐一面白佛言。世尊。是调达今欲破和合僧。受持破僧因缘事。是人非法说法。法说非法。非律说律。律说非律。非犯说犯。犯说非犯。轻说重。重说轻。有残说无残。无残说有残。常所行法说非常所行法。非常所行法说常所行法。非教说教。教说非教。佛语诸比丘。汝等当诃调达令舍是破僧因缘事。是诸比丘受佛语已。到调达所言。汝莫求破和合僧。莫受持破僧事。当与僧和合。与僧和合者欢喜无诤。一心一学如水乳合。得安乐住。汝当舍是破僧因缘事。时调达不舍是事。尔时调达四伴党诃诸比丘言。汝等莫说调达是事。何以故。是人说法说律。是人所说是我等意。是知说非不知说。是人所说皆是我等所欲乐忍。如是诸比丘再三谏调达。不能令舍恶邪。便从座起往诣佛所。头面礼足一面座已白佛言。世尊。我等已约敕调达。不舍恶邪。有四伴党复作是言。汝等莫说调达是事。何以故。是人说法说律。是人所说皆我等意。是知说非不知说。是人所说皆是我等所欲乐忍。诸比丘再三约敕。不舍是事。尔时佛作是念。如调达痴人及四伴党。或能破我和合僧坏转法轮。我当自约敕调达令舍是事。佛作是念已。即自约敕调达。汝莫求破和合僧。莫受持破僧因缘事。汝当与僧和合。与僧和合者欢喜无诤。一心一学如水乳合。得安乐住。汝莫非法说法。法说非法。非律说律。律说非律。非犯说犯。犯说非犯。轻说重。重说轻。有残说无残。无残说有残。常所行法说非常所行法。非常所行法说常所行法。非教说教教说非教。汝当舍是破僧因缘事。尔时调达闻佛口教。暂舍是事。佛在王舍城。尔时阿阇世太子。所有大臣将帅。信敬调达。是诸人民。为助调达比丘作供养。前食后食怛钵那。诸有年少比丘出家不久者。调达以大钵小钵大小键镃衣钩禅镇绳带匙匕钵支扇盖革屣。随比丘所须物。皆用诳诱。调达自共百比丘。或二百三百四百五百比丘恭敬围绕。入王舍城别受好供养。前食后食怛钵那。诸有上座长老比丘。得佛法味久修梵行。是诸比丘入城乞食。得宿冷饭或不得。或得臭糗或不得。如是粗食或饱不饱。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘诃责。云何名比丘。自共百人二百三百四百五百比丘恭敬围绕。别受供养前食后食怛钵那。诸有上座长老比丘。得佛法味久修梵行。是诸比丘入城乞食。得宿冷饭或不得。或得臭糗或不得。如是粗食或饱不饱。种种因缘诃已向佛广说。佛以是事集比丘僧。知而故问。汝实作是事不。答言。实作世尊。佛以种种因缘诃责。云何名比丘。自共百人二百三百四百五百比丘恭敬围绕。别受供养前食后食怛钵那。诸上座长老比丘。得佛法味久修梵行。是诸比丘入城乞食。得宿冷饭或不得。或得臭糗或不得。如是粗食或饱不饱。种种因缘诃已语诸比丘。从今以二利因缘故遮别众食。听三人共食。一利者。守护檀越。以怜愍故。二利者。破诸恶欲比丘力势故。莫令恶欲人别作众别作法与僧共诤

佛在王舍城耆阇崛山上。钦婆罗夜叉石窟中住。早起着衣持钵入王舍城乞食。食后还耆阇崛山。入钦婆罗夜叉石窟中坐禅。尔时调达。勤作方便欲害佛。即雇四恶健人。往上耆阇崛山。共持大石。到钦婆罗夜叉石窟上。待佛经行时。佛晡时从石窟出。在石窟前阴中经行。时四恶人共调达。推石欲掷佛上。尔时钦婆罗夜叉深敬念佛。见已以两手接石掷着余处。有碎石迸来向佛。佛欲令众生生厌畏心。及示诸业不失果报。以是因缘故。入定于经行头没现于东方。碎石随去。南西北方亦复如是。佛尔时没大海水中。碎石亦随。佛复入须弥山中。石亦随逐。到四天王上。石亦随逐。佛从四天王上至忉利天炎摩天兜率陀天化乐天他化自在天。复至梵众天梵辅天大梵天少光天无量光天光曜天少净天无量净天遍净天阿那婆诃天福德天广果天不热天喜见天乐见天阿迦尼吒天。石亦随逐。尔时世尊。摄神足力还经行头立。石堕佛足上。伤足上血出。深生苦恼。佛以精进力遮是苦已。而说偈言

  非空非海中　　非入山石间
  非天上地中　　可遮业报处
  非空非海中　　非入山石间
  非天上地中　　得免宿恶殃

尔时调达及四恶健人。初作逆罪。佛即仰看四人怖走。似如人捕。佛唤四人。来为汝说法。寻还佛所。头面礼足在一面坐。佛种种说法示教利喜。示教利喜已语言。汝去莫从来道。调达即嗔。更雇八人教往杀是四人。佛见八人语言。汝来为汝说法。八人即诣佛所。头面礼足于一面坐。佛种种说法示教利喜。示教利喜已语言。童子汝去莫从来道。尔时调达复遣十六人欲杀八人。语言。汝往杀是八人。断口舌故。佛遥见十六人语言。年少汝来为汝说法。即诣佛所头面礼足却坐一面。佛种种因缘说法示教利喜。示教利喜已语言。汝去莫从来道。调达复遣三十二人语言。汝往杀是十六人。转灭口舌故。佛遥见三十二人语言。年少汝来为汝说法。寻诣佛所头面礼足却坐一面。佛种种因缘说法示教利喜。示教利喜已语言。随汝意去。尔时诸比丘。绕石窟四边。有立者坐者。恐调达害佛。佛见诸比丘。知而故问阿难。诸比丘何故石窟四边立坐住何所待。答言。世尊。调达欲害佛。是故诸比丘绕石窟四边立坐住待。愿令调达不来害佛。佛语阿难。若调达能害佛命。无有是处。若佛为他因缘死。亦无是处。尔时佛语阿难。汝将从行比丘。入王舍城巷陌市肆多人住处唱言。调达所作事。若身作口作。莫谓是佛事法事僧事。此是调达及弟子所作事。阿难受教。即将从行比丘诣王舍城巷陌市肆多人住处唱言。调达身作口作事。莫谓是佛事法事僧事。此调达及弟子所作事。如是唱已。阿阇世太子内宫大官。闻是语作是念。沙门瞿昙妒嗔调达故。令作是唱。是上人调达。身口可作恶邪。调达亦闻沙门瞿昙遣人入王舍城巷陌市肆多人住处唱言。调达身作口作事莫谓是佛事法事僧事此是调达及弟子事。闻已倍增嗔恨向佛。即往阿阇世太子所言。汝杀父我杀佛。汝于摩竭国作王。我当作佛。此摩竭国便有新王新佛。不亦快乎。阿阇世太子闻是语。喜深入其心。受调达语。有时瓶沙王。驾駃马车入林园中游戏。尔时太子。持利剑于巷头待。尔时王昼日于园中伎乐自娱。向暮还宫王来转近。即以频迟罗剑遥用掷王。马车速疾故。得免斯难。太子以不害王故。即便走逃。众官寻时围绕收捕。将诣王所。王问太子言。汝欲作何等。答言。欲夺王命。问言。用谁语耶。答言。用上人调达语。尔时大臣有言。一切沙门释子皆应打杀。有言。一切沙门释子有何等罪。应杀调达及其弟子。有言。调达弟子有何等罪。但杀调达。有言。何以杀诸沙门释子。何以杀调达弟子。何以杀调达。大王善好贤柔。应死者放。云何杀诸沙门出家人耶。我等何不以此事白王。随王教治事亦成断。何烦我等自用力耶。王还宫已。因此事故。于治处坐。大臣官属皆来朝觐。于一面立。王言。昨所起事。当云何断。答言。大臣有言。一切沙门释子皆应打杀。有言。一切沙门释子有何等罪。应杀调达及其弟子。有言。调达弟子有何等罪。但杀调达。有言。何以杀诸沙门释子。何以杀调达弟子。何以杀调达。大王善好贤柔。应死者放。云何杀诸沙门出家人也。我等何不以此事白王。随王教治事亦成断。何烦我等自用力耶。王言。诸沙门释子先时遣人唱言。调达身口所作事。莫谓是佛事法事僧事。此是调达及弟子所作事。此事先已唱说。王闻大臣。有言。一切沙门释子皆应打杀。王不可是语。有言。诸沙门释子有何等罪应杀调达及其弟子。王亦不可是语。有言。调达弟子有何等罪应杀调达。王亦不可是语。有言。何以杀一切沙门释子。何以杀调达弟子。何以杀调达。大王善好贤柔。应死者放。随王教治事亦成断。何烦我等自用力耶。王即可之。赏赐聚落田宅财物。时王自问太子言。汝欲作何等。即除惭愧。答言。我欲夺王命。何以故。王有王鼓王伎乐王持盖王行时金澡瓶导前。我无王鼓王伎乐王持盖王行时持金澡瓶导前。王便与太子王鼓王伎乐王持盖王行时金澡瓶导前。尔时二王打鼓二王唱导二王持盖二王持金澡瓶在前。治国土法。不可随一切人意。瓶沙王先未得道时。所可作恶不随人意。是诸人民心怀嗔恨。而作是念。时到当报。是诸恶人亲近阿阇世白言。何国土中有二主者。王言。云何二主。答言。二王打鼓二王作伎乐二王持盖二王行时持金澡瓶在前二王唱导。汝父王后若治国时。当夺汝命独自作王。汝应方便治王。阿阇世王闻已心喜忍受。即敕大臣官人。捕取父王令着狱中。大臣受教。即便收捕系在牢狱。大王善好贤柔。百千万人持诸肴膳往问讯王。王啖以自活。过数日已。阿阇世王问。大王活不。答言活。云何得活。答言。问讯人与饮食活。王即敕狱官。自今已后莫听人入。后王夫人盗持食入王啖得活。过数日已。王复问言。大王活耶。答言活。云何得活。答言。有王夫人。来与饮食故。即敕狱官莫听夫人入。有大夫人。深敬念大王。以食涂衣更着上衣往到狱中。脱衣与王令食得活。过数日已。王复问言。父王活耶。答言活。云何得活。答言。大夫人来缘得食活。王言。莫听大夫人入。父王在狱中遥见耆阇崛山。大王见佛及僧舍利弗目连。阿那律难提金鞞罗上山下山。大王得遥见佛及僧欢喜故活。过数日已。阿阇世复问。父王活耶。答言活。云何得活。大臣妒心答言。遥见佛及僧故活。王即敕令障隔。莫令得见。诸佛常法。有大因缘入城时。现如是神通力。象深鸣马悲鸣诸牛吼。鹅雁孔雀鹦鹉舍利鸟俱耆罗鸟猩猩诸鸟出和雅音。大鼓．小鼓．箜篌．筝．笛．琵琶．箫．瑟．筚篥．铙钹。不鼓自鸣。诸贵人舍所有金银宝器内外庄严具。若在箱箧中自然作声。盲者得视。聋者得听。哑者能言。痀躄者得伸。跛蹇得手足。睐眼得正。瘿者得除苦痛。得乐毒者消歇。狂者得止。杀者离杀。偷者离偷。邪淫者不邪淫。妄语者不妄语。两舌恶口绮语者不绮语。贪者不贪。嗔者不嗔。邪见者离邪见。牢狱闭系枷锁杻械。悉得解脱急闹处者皆得空闲。未种善根者种。已种者增长。已增长者得解脱。诸伏藏宝物自然出现。如是希有事。诸众生得利益。尔时佛入王舍城。以右足蹈门阃上。悉现如是种种瑞应。瓶沙王曾见是相。知佛当入城。王从楼阁向孔间立看佛入城。王得圣道。见佛及僧欢喜故活。过数日已。阿阇世复问。王今活耶。答言活。云何得活。诸大臣妒心答言。佛入城现神通力。父王从向孔中见佛故活。阿阇世王言。以利刀削大王脚底。皮却急系莫令东西。即受教。削大王脚底。急系不得东西。王以是故。卧日就羸笃。又一时阿阇世王共母俱食。王有一子。字优陀耶跋陀。于道头与狗子共戏。王问。优陀耶跋陀。今何所在。答言。道中与狗子共戏。王言唤来。我与共食。即抱狗子随信俱至。王子不食。王言。何故。王子言。王听我与狗子食者。尔乃食耳。王言。随意。王子自食随持与狗。王语母言。我作难事。何以故。我浇顶刹利王。以爱念儿故。与狗共食。母言。此非作难事。何以故。人有啖狗肉者。与食何怪。会知汝父作难事不。王言。作何难事。母言。汝年小时手指生痈。受急苦痛昼夜不寐。汝父抱着膝上口含痈指。大王体软汝得安睡。由口暖故。痈熟脓溃。大王心念。却指唾脓复增子苦。即随咽脓。汝父作是难事愿汝时放。王闻默然。母谓已放。宫中声出已放大王。巷陌诸处闻大王得出。王贤善故。百千种人皆称善哉。咸到狱所各作是言。大王得出。大王闻已作是念。我儿恶逆无慈愍心。不知当复何事治我。作是念已。自投床下遂便命绝尔时阿阇世王。夺父王命得大逆罪

佛在王舍城耆阇崛山中。与大比丘众五百人俱。尔时世尊。中前着衣持钵入王舍城乞食。食已还上耆阇崛山。七日之中结加趺坐受禅定乐。过七日已。中前着衣持钵入城。为乞食故。尔时调达。闻瞿昙沙门在王舍城耆阇崛山中。与大比丘众五百人俱。瞿昙中前着衣持钵入王舍城乞食。食已还上耆阇崛山。七日之中结加趺坐受禅定乐。过七日已。中前着衣持钵入城。为乞食故。尔时阿阇世王。有象名守财。凶恶多力四方无双。于时调达。持五百金钱与象师言。汝知不耶。王敬待我。我今于人能有损益。此五百金钱今并与汝。若事果成。厚相供给田宅人民。问言。何事。答言。沙门瞿昙。与大比丘众五百人俱。在耆阇崛山中。沙门瞿昙。中前着衣持钵入王舍城乞食。食已还上耆阇崛山。七日之中结加趺坐受禅定乐。过七日已。中前着衣持钵入城。为乞食故。汝能以酒与象令醉。解锁却靽。令夺瞿昙沙门命不。象师答言尔。此是小事。斯象属我想不忘报。调达语言。我闻沙门瞿昙却后七日当来入城。即屈指度筹到七日时。与象酒醉系住待佛。诸佛常法。有大因缘入城时。现如是瑞应。象深鸣马悲鸣诸牛王吼。鹅雁孔雀鹦鹉舍利鸟俱耆罗鸟猩猩诸鸟出和雅音。大鼓小鼓箜篌筝笛琵琶箫瑟筚篥铙钹不鼓自鸣。诸贵人舍所有金器银器内外庄严具。若在箱箧中自然作声。盲者得视。聋者得听。哑者能言。痀躄者得伸。跛蹇得手足。睐眼得正。瘿者得除苦痛。得乐毒者消歇。狂者得止。杀者离杀。偷者离偷。邪淫者不邪淫。妄语者不妄语。两舌恶口绮语者不绮语。贪者不贪。嗔者不嗔。邪见者离邪见。牢狱闭系枷锁杻械。悉得解脱。急闹处者皆得空闲。未种善根者种。已种者增长。已增长得解脱。诸伏藏宝物自然发出。现如是诸希有事。一切众生皆得利益。佛到城以右足着门阃上。即现如是种种瑞应。象师曾见是相。知佛入城。即解象靽放去。欲令害佛。无能遮者。是象面有三瘤。醉狂蹴踏。百千万众皆大怖畏。有入舍者在屏覆处者。巷陌皆空。除佛及弟子。有贤者。遥见守财象来。向佛所白佛言。世尊。是象饮能醉酒。象已离羁靽遣来害佛。无能遮者。愿佛入舍。若还出城。勿令此象害佛世尊命。佛言。若守财象夺佛命者。无有是处。若佛为他因缘死。亦无是处。是贤者心大欢喜言。若守财象能夺佛命。无有是处。若佛为他因缘死者。亦无是处。尔时众人。于屋上楼阁上向中立。作高大声。时有不信者言。是守财象或能杀佛。有信者言。是守财象能杀佛者。无有是处象遥见佛。即便啮齿举鼻竖尾弭耳努力走向佛所。诸比丘遥见象来。皆大惊怖舍佛走逃。唯除一阿难。象来逼佛。佛即以慈三昧力。象醉即醒。头面礼佛以鼻拭佛足。佛以右手摩其头。即说偈言

  世尊以长臂　　柔软相轮手
  摩抆象头教　　如父教其子

  佛言大象　　莫起恶业　　起恶业者
  不生善处　　伊罗辕象　　跋陀和象
  提罗遮象　　醯摩和象　　有凶行象
  有牛王象

  天象等礼佛　　不放逸调戏
  放逸调戏者　　不得生善处
  若汝不放逸　　当得生天上

佛说偈已。为守财象说法示教利喜。示教利喜已默然。时守财象。从佛闻法故。心悔泪出。头面礼佛足右绕而去。尔时众人闻佛摧伏恶象希有事故。无量众集。佛见无量众集已。告阿难言。汝为我敷座办水。阿难受教。即于是处敷座办水。合掌白佛言。世尊。已敷座办水。佛自知时。佛即洗足。就所敷座坐已。便入禅定。于此处没。出于东方虚空中。现四威仪行立坐卧。入火光三昧。现种种色光。青黄赤白红缥紫碧。身下出火。身上出水。复从身上出火。身下出水。南西北方亦复如是。现如是种种神通力已。还坐本处时坐。众人先怀厌恶怖畏心者。见佛神变及调伏醉象。即于佛所深生信敬。佛知众生深信柔软。随其所应为说道法。是众中。有人得暖法者。顶法者。顺道忍法者。三毒薄者。离欲者。世间第一法者。有得须陀洹果斯陀含果阿那含果者。有种声闻乘因缘者。有种辟支佛乘因缘者。有种佛乘因缘者。如是利益无量众生。佛于是日无所食啖。捉阿难臂。便从虚空还耆阇崛山中。诸比丘闻世尊还。皆诣佛所头面礼佛足却坐一面白佛言。希有世尊。如是急怖畏时。阿难不舍离佛。佛语诸比丘。阿难不但今急怖时不舍离佛。乃过去世急怖时亦不舍离佛。今当说之。有过去世近雪山下有鹿王。名威德。作五百鹿主。时有猎师。安谷施罥。鹿王前行。右脚堕毛罥中。鹿王心念。若我现相。则诸鹿不敢食谷。须啖谷尽尔乃现相。现脚相时诸鹿皆去。唯一女鹿住。说偈言

  大王当知　　是罥师来　　愿勤方便
  出是罥去

尔时鹿王以偈答言

  我勤方便　　力势已尽　　毛罥转急
  不能得出

尔时女鹿。见猎师转近。重说偈言

  大王当知　　罥师转近　　愿勤方便
  求出是罥

鹿王答言

  我勤方便　　力势已尽　　毛罥转急
  不可得脱

女鹿见猎师到已。向说偈言

  汝以利刀　　先杀我身　　然后愿放
  鹿王令去

猎师闻之。生怜愍希有心。畜生深爱他故。乃能与命。以偈答言

  我终不杀汝　　亦不杀鹿王
  放汝及鹿王　　随意所乐去

猎师即时解放鹿王。佛语诸比丘。昔鹿王者。岂异人乎。莫作异观。则我身是。五百鹿者。则汝等五百比丘是。汝等过去世急怖时舍离我。今急怖时亦舍我去。时猎师者。则守财象是。过去世不恼害我。今世亦不害我。时女鹿者。阿难是。过去世急怖时不舍我去。今世急怖时亦不舍我去。佛即以是因缘故。说第二本生。佛言。过去世时。有波罗奈城。城边有池。池名雨成。是池中有多水多鱼多龟多鹅雁鸭。中有雁王。名治国。作五百雁主。尔时有猎师。先施毛罥近谷。是雁王前行右脚着罥中。作是念。若我出是罥脚者。余雁不敢啖谷。须啖谷尽然后当现。啖谷尽已。即便现脚相。众雁舍王飞去。唯有一大臣。名苏摩。不舍王去。治国雁王语大臣言。我与汝职作王。在诸雁前行。答言。不能。问言。何故。尔时大臣以偈答言

  我愿随王　　死生不变　　宁共王死
  胜相离生　　大王当知　　是罥师来
  但勤方便　　求脱此罥

尔时雁王以偈答言

  我勤方便　　力势已尽　　毛罥转急
  不能得脱

尔时大臣见罥师转近。复说偈言

  大王当知　　罥师欲至　　愿勤方便
  求脱此罥

尔时雁王以偈答言

  我勤方便　　力势已尽　　毛罥转急
  不可得脱

苏摩大臣见罥师到已向说偈言

  大王毛脂肉　　我与等无异
  汝以刀杀我　　放王不损汝

尔时罥师作是念。畜生深爱他故。乃能与命。甚为希有。作是念已。语大臣言。我不相杀。放汝及王。随意乐去。猎师即解雁王放去。是二雁小远。共相谓言。是猎师作希有事。与我等寿命。若先杀一后杀一。谁能遮者。我等资生之具。当以厚报猎师闻已问言。汝等何说不能去耶。二雁答言。我等能去。但具说汝作希有事。与我等命。若汝先杀一后杀一。谁能遮者。我等资生之具。当以厚报。猎师问雁。汝是畜生。有何生具以用报我。二雁答言。波罗奈王。名梵德。汝持我与。时猎师言。彼或害汝。云何当与。雁言。汝莫系缚我。但散将去。尔时猎师持二雁着两肩上。到城巷陌中行。是雁端正。众人乐见多人爱念。众中有言。我与汝五钱。有与十钱二十钱者。皆言。小待莫杀。是人比至王宫。大得财物。猎师到王宫门已。置雁于地。雁王语守门者。汝白梵德王治国雁王今在门外。便往白王。王即听入。与设金床。苏摩大臣随所应与共相问讯。然后就座。以偈问讯梵德王言

  王体安隐不　　国土丰足不
  如法化民不　　等心治国不

尔时梵德王以偈答言

  我常自安隐　　国土恒丰宁
  以法化国民　　等心无偏私

如是詶对说五百偈。梵德王闻其所说。而作是念。雁王乃尔明达。苏摩大臣时默然住。梵德王言。汝何故默然。大臣答言。汝是人王国主。此雁王陂泽国主。二主共语。何敢间错。王作是念。此是贤臣。语言。苏摩。我有好园。汝能于中住不。当更集诸雁。为汝等作池。与汝等作随所乐食。答言。不能。王问。何故。雁王言。王或睡觉忘不蠲我。敕作雁肉食。若宰人不能得余雁。或杀我等以充王厨。治国雁王入王宫中。诸雁从雨成池出。于王宫上徘徊悲鸣。翅湿有水洒污宫殿。王仰看见水污宫殿。怪而问曰。此是何等。雁王答言。是我眷属。王言。汝欲去耶。答言。欲去。王言。汝何所须。答言。我为猎师所得。于我等作希有事。与我等寿。若先杀一后杀一。谁能遮者。王言。当何以报之。二雁答言。与金银车磲玛瑙衣服饮食。作是语已飞升虚空。佛语诸比丘。尔时治国雁王岂异人乎。则我身是。五百雁者则五百比丘是。过去急怖时舍我去。今世急怖时亦舍我去。猎师者守财象是。过去世时不恼害我。今亦不恼害我。梵德王者即净饭王是。苏摩大臣者阿难是。过去急怖畏时不舍我。今急怖畏时亦不舍我。佛即时以是因缘故。说第三本生。有过去世近雪山下。有师子兽王住。作五百师子主。是师子王后时老病瘦眼闇。在诸师子前行。堕空井中。五百师子皆舍离去。尔时去空井不远。有一野干。见师子王作是念。我所以得此林住安乐饱满肉者。由师子王故。师子王今堕急处云何当报。时此井边有渠流水。野干即以口脚通水入井。随水满井。师子浮出。时此林神。而说偈言

  身虽自雄健　　应以弱为友
  小野干能救　　师子王井难

佛语诸比丘。尔时师子王者。岂异人乎。则我身是。五百师子者。诸比丘是。过去世急怖时舍离我去。今急怖时亦舍我去。野干者。阿难是。过去世时爱念我。今亦爱念我

佛即以是因缘故。如是广说五百本生

十诵律卷第三十六十诵律卷第三十七(第六诵之二)

        后秦北印度三藏弗若多罗译

    杂诵中调达事之二

佛在王舍城方黑石圣山。与大比丘众七百人俱。尔时世尊中前着衣持钵。阿难随后入王舍城乞食。食后往诣讲堂。于众僧前敷坐处坐。调达亦如是。中前着衣持钵。迦留罗提舍随后。入王舍城乞食。食后诣讲堂随次第坐。坐已调达僧中唱言。比丘应尽形受着纳衣。应尽形受乞食。应尽形受一食。应尽形受露地住。应尽形受断肉鱼。是五法随顺少欲知足。易养易满知时知量。精进持戒清净一心远离。向泥洹门。若比丘行是五法。疾得泥洹。调达尔时。非法说法法说非法。善说非善非善说善。犯说非犯非犯说犯。轻说重重说轻。有残说无残。无残说有残。常所行法说非常所行法。非常所行。法说常所行法言。说非言非言说言。佛尔时自约敕调达。汝莫作方便破和合僧。莫受持破僧因缘事。汝与僧共和合。和合者欢喜无诤。一心一学如水乳合安乐行。汝莫非法说法法说非法。非善说善善说非善。非犯说犯犯说非犯。轻说重重说轻。有残说无残无残说有残。常所行法说非常所行法。非常所行法说常所行法。言说非言非言说言。调达闻佛如是约敕。不舍破僧因缘事。当佛约敕调达不舍是事。尔时迦留罗提舍比丘。在调达后以扇扇调达。加留罗提舍比丘。即时偏袒右肩合掌白佛言。如佛赞叹头陀功德。上人调达亦赞叹头陀功德。佛何以生妒心。佛言。痴人。我有何妒心。过去诸佛赞叹纳衣听着纳衣。我今亦赞叹纳衣听着纳衣。亦听着居士衣。痴人。过去诸佛赞叹乞食听乞食。我今亦赞叹乞食听乞食。亦听请食。痴人。过去诸佛赞叹一食听一食。我今赞叹一食听一食。亦听再食。痴人。过去诸佛赞叹露地住听露地住。我今赞叹露地住听露地住。亦听房舍住。痴人。我不听啖三种不净肉。若见若闻若疑。见者。自眼见是畜生为我故杀。闻者。从可信人闻为汝故杀是畜生。疑者。是中无屠卖家。又无自死者。是人凶恶。能故夺畜生命。痴人。如是三种肉我不听啖。痴人。我听啖三种净肉。何等三。不见不闻不疑。不见者。不自眼见为我故杀是畜生。不闻者。不从可信人闻为汝故杀是畜生。不疑者。是中有屠儿。是人慈心。不能夺畜生命。我听啖如是三种净肉。痴人。若大祠。所谓象祠马祠人祠和阇毗耶祠三若波陀祠随意祠。若诸世会杀生处祠。如是大祠世会中。不听沙门释子啖肉。何以故。是大祠世会。皆为客故。佛说是已。即从坐起入室坐禅。尔时调达作是言。我调达僧中唱言。比丘应尽形着纳衣。应尽形乞食。应尽形一食。应尽形露地住。应尽形不啖肉鱼。随何比丘。喜乐是五法者。便起捉筹。唱已调达及四伴即起捉筹。调达第二复作是言。我调达僧中唱言。比丘应尽形着纳衣。应尽形乞食。应尽形一食。应尽形露地住。应尽形不啖肉鱼。随何比丘。喜乐是五法者。便起捉筹。唱第二语已。有二百五十比丘。从坐起捉筹。调达第三复作是言。我调达僧中唱言。比丘应尽形着纳衣。应尽形乞食。应尽形一食。应尽形露地住。应尽形不啖肉鱼。随何比丘。喜乐是五法者。便起捉筹。第三唱已。复有二百五十比丘。从坐起捉筹。尔时调达。即将是众还自住处。更立法制。调达作是言。应尽形着纳衣。应尽形乞食。应尽形一食。应尽形露地住。应尽形不啖肉鱼。随何比丘。不喜乐不忍受是五法者。是人去我等远。与我别异不共语。世尊晡时从禅室起。于僧中坐。告诸比丘。调达以八邪法覆心。不觉破僧。何等八。利衰毁誉称讥苦乐恶知识恶伴党。调达闻佛说其破僧坏转法轮。欢喜作是念。瞿昙沙门有大神通力势。我能破彼和合僧。我好名声流布四方。瞿昙沙门有大神通力势。调达能破彼和合僧。便如佛在僧中坐时。右舍利弗目连在左。调达亦如是。右俱迦梨左迦留罗提舍。时舍利弗目连白佛言。世尊。我等今往调达众中。有可化者开导令还。佛言。随意。舍利弗目连。即诣调达讲堂。有一比丘。见舍利弗目连往调达众所。宛转啼哭似木段转作是念。如是恶世。舍利弗目连舍离世尊。反就调达。佛见比丘。知而故问。汝今何以宛转啼哭。如似木段。答言。世尊。如是恶世。舍利弗目连舍离如来。反就调达。佛言。比丘。若舍利弗目连。舍我去。更求智慧者。无有是处。比丘闻佛语。心大欢喜。称言。舍利弗目连。舍如来去。更求智慧者。无有是处。尔时调达遥见舍利弗目连来。心大欢喜作是念。瞿昙沙门第一好大弟子二人。今转属我如佛见舍利弗目连来时。举右手言。善来舍利弗目连。调达亦尔。见舍利弗。目连来。亦举右手言。善来舍利弗目连。即遣右俱伽梨安舍利弗。遣左迦留罗提舍安目连。如佛在众中语舍利弗目连。汝等为众说法。我脊痛小息。调达亦尔。在众中语舍利弗目连。汝等为诸比丘说法。我脊痛小息。如佛四亵郁多罗僧敷。以僧伽梨作枕。右胁卧。调达亦尔。四亵郁多罗僧敷。以僧伽梨作枕。右胁卧。时有天神。深爱佛法故。令调达睡。转左胁卧鼾睡[穴/(爿*臬)]语。嚬呻振摆断齿作声。时舍利弗为诸比丘说法。种种因缘赞叹佛法僧戒。种种呵责说调达过罪恶道分。当堕阿鼻地狱一劫寿不可救。目连即入如是禅定。以是定力。于是处没。出于东方虚空中。现四威仪行立坐卧。入火光三昧。现种种色光青黄赤白紫碧缥绿。身上出水身下出火。或身上出火身下出水。南西北方亦复如是。现神变已还坐本处。时是众中五百比丘。见神通闻说法已作是念。我等或错堕邪道中。第二舍利弗。复为诸比丘说法。种种因缘赞叹佛法僧戒。种种呵责说调达过罪恶道分。当堕阿鼻地狱一劫寿不可救。目连即入如是禅定。以是定力。于是处没。出于东方虚空中。现四威仪行立坐卧。入火光三昧。现种种色光。青黄赤白紫碧缥绿。身上出水身下出火。或身上出火身下出水。南西北方亦复如是。现神变已还坐本处。第二诸比丘生疑作是念。我等在邪道耶。第三舍利弗复为说法。种种因缘赞叹佛法僧戒。种种呵责说调达过罪恶道分。当堕阿鼻地狱一劫寿不可救。目连即入如是禅定。以是定力。于是处没。出于东方虚空中。现四威仪行立坐卧。入火光三昧。现种种色光。青黄赤白紫碧缥绿。身上出水身下出火。或身上出火身下出水。南西北方亦复如是。现神变已还坐本处。第三诸比丘作是念。我等实错定堕邪道。舍利弗目连即从坐起去。五百比丘亦从坐起去。时舍利弗目连及五百比丘。俱诣佛所头面礼佛足却坐一面。时调达讲堂空无大众。唯有四伴在。迦留罗提舍。先在调达左。调达见目连来。驱迦留罗提舍安目连。尔时迦留罗提舍。以是因缘故。以右脚蹴调达。令觉语言。乐众调达。舍利弗目连夺汝众去。调达觉已见讲堂空。迷闷堕床。时四伴以冷水洒。还得醒悟。作是念。我是释种姓瞿昙大人。不可屈下从他。语诸比丘。先有外道法隐没不了。我今当发起明了住是法中。汝等当知。我从今不复属沙门瞿昙。作是语时。即名舍戒。诸比丘白佛言。希有世尊。舍利弗目连。求调达便疾得其便。佛言。不但今世得调达便。过去世时亦得其便。汝今善听。佛即广说本生因缘。语诸比丘。过去世时。有一射师。多诸弟子。师作是念。诸弟子中第一巧者。以女妻之及四马车。附钗千箭千金钱。其后知一弟子最上巧射。即嫁女与及四马车。附钗千箭及千金钱。弟子与女同载一车还所住处。道中有千贼。余人见贼语弟子言。是中有千贼。莫从此道。为贼所恼。是弟子发憍慢心。自恃技能。从是道去。时千贼下道侧食。是弟子亭车道中。遣妇语贼主。与我食分。妇即诣彼语其贼主言。某射师弟子。故遣我来索食分。贼主作是念。如是道中遣如是使。必是无畏。当与食分。诸贼忧愁咸作是念。我等用是活为。何不杀是人取是女作妇取四马车千箭千金钱用语女言。还去。不与食分。是女还言。不肯与我等食分。更遣往语言。若汝等不肯与我食分。各起庄严来共斗战。即复往语。时彼贼中百人庄严来共斗战。弟子以百箭杀百人。如是二百三百乃至九百九十九人。唯留一箭以拟贼主。贼主作是念。我用是活为。一人杀灭千人。即起着杖捉弓擩箭。是二人皆善知射俱相求。便弟子作是念。我云何当得其便。即语妇云。汝小远于彼歌舞动身。令庄严具作声举衣现身。是妇即于一面歌舞动身。令庄严具作声举衣现身。贼主见闻已心动。弟子得便放一箭杀之。佛言。尔时射师者。岂异人乎。则我身是。弟子者。舍利弗是。女人者。目连是。尔时贼主。调达是。尔时二人求便得便。今亦求便得便。尔时世尊。广说如是本生

佛在舍卫国。尔时长老优波离问佛言。世尊。所言破僧者。云何名破僧。齐几所名破僧。佛语优波离。用十四破僧事。若从是中随所用事。十四者。非法说法。法说非法。非善说善。善说非善。犯说非犯。非犯说犯。轻说重。重说轻。有残说无残。无残说有残。常所行法说非常所行法。非常所行法说常所行法。非说言说。说言非说。于是中非法说法偷兰遮。法说非法偷罗遮。非善说善偷罗遮。善说非善偷罗遮。非犯说犯偷兰遮。犯说非犯偷兰遮。有残说无残偷兰遮。无残说有残偷兰遮。轻说重偷兰遮。重说轻偷兰遮。常所行法说非常所行法偷兰遮。非常所行法说常所行法偷兰遮。非说言说偷兰遮。说言非说偷兰遮。若是比丘非法说法。以是非法教众折伏众。破和合僧。破和合僧已得大罪。得大罪已。一劫寿堕阿鼻地狱中。若比丘非法说法法说非法。非善说善善说非善。犯说非犯非犯说犯。有残说无残无残说有残。轻说重重说轻。常所行法说非常所行法。非常所行法说常所行法。说言非说非说言说。若比丘以是等十四非法。教众折伏众破和合僧破和合僧已得大罪。得大罪已。一劫寿堕阿鼻地狱中。优波离。是十四事名破僧。若十四事中随用何事。亦名破僧。若比丘非法中生非法想。于破僧中生非法见。知破僧是非法。以是心破僧。得逆罪。若比丘非法中生非法想。破僧中生疑。以是心破僧。得逆罪。若比丘非法中生非法想。破僧中生是法见。是人不得逆罪。若比丘非法中生法想。破僧中生法见。是比丘不得逆罪。若比丘非法中生法想。破僧因缘中生疑。是比丘不得逆罪。优波离又问佛言。世尊。云何名和合僧。佛语优波离。有十四事。名破僧。若灭此事。名和合僧。十四者。非法说非法。法说法。善说善。非善说非善。犯说犯。非犯说非犯。有残说有残。无残说无残。轻说轻。重说重。常所行法说常所行法。非常所行法说非常所行法。说言是说。非说言非说。若比丘非法说非法。以是教众折伏众和合破众。永受天上乐。若比丘如法说如法。以是教众折伏众和合破众。永受天上乐。若比丘善说善非善说非善。犯说犯非犯说非犯。有残说有残无残说无残。轻说轻重说重。常所行法说常所行法。非常所行法说非常所行法。说言说非说言非说。若以是等十四法。教众折伏众和合破众。永受天上乐。是名十四事和合僧。若比丘从十四事中。随所用事和合僧。永受天上乐。佛语优波离。一比丘不能破和合僧。若二若三四五六七八。亦不能破和合。比丘僧极少乃至九清净同见比丘。能破和合比丘僧优波离。一比丘尼不能破和合僧。若二若三四五六七八九清净同见比丘尼。亦不能破和合僧。优波离。非一式叉摩尼。非一沙弥沙弥尼。非一出家出家尼能破和合僧。若二若三四五六七八九清净同见。亦不能破和合僧。优波离。有二因缘。名破僧。一唱说二取筹。唱说者。如调达于僧中乃至第二第三唱言。我调达作是语。取筹者。如调达初唱竟共四伴取筹。长老优波离问佛言。世尊。摈比丘能破僧不。及随顺摈比丘。助随顺摈比丘。若作摈比丘。及随顺作摈比丘。助随顺作摈比丘。若大长老。及随顺大长老比丘。助随顺大长老比丘。皆能破僧不。佛言。一切比丘皆能破僧。唯除摈人。不能破僧

佛在王舍城。尔时六群比丘。以木棒自打治身。诸居士呵责言。诸沙门释子自言善好有德。以木棒自治身。如王如大臣。是事白佛。佛言。从今不应以木棒治身。治者突吉罗。诸比丘以木丸自治身。佛言。从今不听以木丸治身。治者突吉罗。佛在舍卫国。六群比丘洗浴。以刨刮身毛脱。诸居士呵责言。诸沙门释子自言善好有德。洗浴以刨刮身毛脱。如王如大臣。是事白佛。佛言。从今洗浴不听以刨刮身毛脱。刮者突吉罗。尔时有比丘。名强耆罗多毛。洗浴已毛中水湿衣烂坏身体臭秽。是事白佛。愿听洗浴时以刨刮去水。佛言听。尔时六群比丘以香涂身。诸居士呵责言。诸比丘自言善好有德。以香涂身。如王如大臣。是事白佛。佛言。从今不听以香涂身。涂者突吉罗。六群比丘以掌治身。诸居士呵责言。诸比丘自言善好有德。以掌治身。如王如大臣。是事白佛。佛言。从今不听以掌治身。治身者突吉罗。掌有二种。手掌脚掌。手掌治突吉罗。脚掌治亦突吉罗。除手掌脚掌。以余身分治者亦突吉罗。尔时六群比丘就柱治身是事白佛。佛言。从今不听就柱治身。就治者突吉罗。六群比丘就壁治身就石治身佛。言从。今不应就壁石治身。就治者突吉罗

佛在迦维罗卫国。尔时释摩男。请佛及僧明日食。佛默然受。释摩男。知佛默然受请已。头面礼佛足右绕而去。还舍通夜办种种多美饮食。早起敷坐处。遣使白佛时到。唯圣知时。尔时诸比丘以油涂足。是国多尘土著比丘脚。诸居士妇以两手接比丘足作礼。然后洗手捉钵下食。有比丘语居士妇言。先洗手已捉钵。答言。已洗。若汝不油涂脚上来者。当有何过。佛见居士妇呵责比丘作如是事。佛食后还僧坊。以是事集比丘僧。语诸比丘。从今不应以油涂足入白衣家。涂足入白衣舍者突吉罗。若有泥有疮涂入者不犯。六群比丘油涂头。诸居士呵责言。诸沙门释子自言善好有德。以油涂头如白衣。佛言。从今不听比丘以油涂头。涂者突吉罗。若新剃发若头痛若房舍内涂者不犯。六群比丘庄严面目。诸居士呵责言。诸比丘自言善好有德。庄严面目。如王如大臣。是事白佛。佛言。从今不应庄严面目。庄严者突吉罗。六群比丘以庄严故画眼。诸居士呵责言。诸比丘自言善好有德。画眼如王如大臣。是事白佛。佛言。从今不听比丘为庄严故画眼。画者突吉罗。画眼有五种。一者墨画。二者空青画。三者杂画。四者华画。五者树汁画。若为治病故画眼不犯。六群比丘腕上系缕。诸居士呵责言。诸比丘自言善好有德。以杂色缕系腕上。如王如大臣。是事白佛。佛言。从今不听以杂色缕系腕上。系者突吉罗。六群比丘缕络腋。诸居士呵责言。诸比丘自言善好有德。以缕络腋如婆罗门。是事白佛。佛言。从今不听比丘以缕络腋。络腋者突吉罗。六群比丘畜庄严身具。诸居士呵责言。诸沙门释子自言善好有德。畜庄严身具自庄严身。如王如大臣。是事白佛。佛言。从今不听比丘畜庄严身具。畜者突吉罗。六群比丘以臂钏自庄严。佛言。不应畜臂钏自庄严。畜者突吉罗。六群比丘着指环。如王如大臣。佛言。不应着指环。著者突吉罗。六群比丘着璎珞。佛言。比丘不应着璎珞。著者突吉罗。六群比丘着缕臂钏。佛言。比丘不应着缕臂钏著者突吉罗。六群比丘以金银锁镊穿耳。佛言。不得以锁镊穿耳。穿耳者突吉罗。长老跋提。本白衣时着葡萄叶镊。作比丘已本习气故。犹故着之。诸居士呵责言。是比丘着葡萄叶镊。如王如大臣。是事白佛。佛言。从今不应着。著者突吉罗。佛遮一切庄严具故。六群比丘便以币帛绳树叶树皮木白镴铅锡作耳圈着。诸居士言。汝等不着金银叶镊。何用圈耳为。佛言。从今不听比丘以币帛绳树叶树皮木白镴铅锡作耳圈着。著者突吉罗。乃至以草簪穿耳孔中者突吉罗。尔时六群比丘着耳环。佛言。不应着耳环。著者突吉罗。又六群比丘畜约发宝物。诸居士呵责言。诸沙门释子自言善好有德。畜约发宝物。如王如大臣。是事白佛。佛言。从今不应畜约发宝物。畜者突吉罗。又六群比丘着金鬘。诸居士呵责言。沙门释子自言善好有德。着金鬘如王如大臣。佛言。比丘不应着金鬘。著者突吉罗。又六群比丘治爪使白。佛言。不应治爪使白。治者突吉罗。佛在王舍城。尔时诸比丘入王舍城乞食。得庵罗果庵罗果羹。诸比丘言。佛不听我等受庵罗果庵罗果羹。是事白佛。佛言。从今听比丘受庵罗果庵罗果羹。佛在王舍城。尔时瓶沙王。有庵罗树常生果。王信敬佛法故。问诸比丘。食庵罗果不。答言食。王言。食我此庵罗树果。是守果人不信敬佛法。有黄熟好果。留作王分及夫人王子大臣大官分。此果中有生者青者瘀者虫鸟所落者。持与比丘。六群比丘到是处。取黄熟好果已。语守果人。授与我来。是人答言。汝等已取。何须更受。是中有比丘。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是因缘集比丘僧。集比丘僧已。问六群比丘。汝实作是事不。答言。实作世尊。佛以种种因缘呵责六群比丘。云何名比丘。先自触庵罗果。然后从净人受啖。从今比丘。若自手触庵罗果。后从净人受者不应食。食者突吉罗。如庵罗果。余一切果亦如是

佛在舍卫国。尔时憍萨罗国波斯匿王。遣使至瓶沙王所。赞叹波斯匿王言。我王善好有福德。四瓶自然有乳满。以供王饮。自然粳米日满八斗器。以供王食。瓶沙王亦自赞叹己国。我此土有庵罗果常生。树提居士树果生妙衣。瓶沙王即遣信敕守园人。送庵罗果。守园人作是念。以此沙门取果因缘故。世尊必遮比丘啖庵罗果。守园人即语王使言。此园无有庵罗果。所有果沙门释子先已啖尽。使还白王。守园人言。所有庵罗果。沙门释子先已啖尽。王言。我亦自知此。非果时。若少多有者。可示彼使令知相貌。守园人得少多果已。往送奉王。有比丘。少欲知足行头陀。闻是事心不喜。呵责言。云何名比丘。啖庵罗常生果。令灌顶王自遣使索不得。呵责已以是事白佛。佛以是因缘集比丘僧。集僧已佛种种因缘呵责。云何名比丘。啖庵罗常生果。令灌顶王自遣使索不得。种种因缘呵责已。语诸比丘。从今庵罗常生果不应啖。啖者突吉罗

佛在舍卫国。尔时诸比丘入舍卫国乞食。得庵罗羹。诸比丘疑不受。作是念。我等将不堕乞美食耶。是事白佛。佛言。若不索他自与得取。憍萨罗国一住处僧得施果。诸比丘不知云何。是事白佛。佛言。应以五种作净啖。何谓为五。火净刀净爪净鹦鹉净子不生净

佛在刍摩国。尔时阿那律共行弟子口干病。医师教含阿摩勒。口可得差。弟子答言。佛未听我含阿摩勒是事白佛。佛言。听比丘口病含阿摩勒。何以故。口干病相宜故。有憍萨罗国一住处。僧得施果。从净人受未作净。诸比丘不知云何。是事白佛。佛言。应食外肤。莫食子。佛在王舍城。尔时树提居士举物。客从海中还持一栴檀段。饷树提居士。居士大富。多金银珍宝。车磲马瑙珊瑚等无量。得是栴檀不以在意。即使作栴檀钵着络囊中。悬高象牙杙上。作是言。若沙门婆罗门不以梯杖能得者便取。尔时富楼那迦叶。闻树提居士为我故作栴檀钵。即往问言。汝为我作栴檀钵耶。居士答言。我作栴檀钵悬高象牙杙上。沙门婆罗门不以梯杖能得者与。富楼那作是念。居士欲见神通力。即挑头而去。摩伽梨俱赊子。珊阇耶毗罗荼子。尼揵陀若提子。迦求陀迦旃延。阿耆陀翅舍钦婆罗。闻树提居士为我作栴檀钵。往诣其所问言。汝为我作栴檀钵耶。居士言。我作栴檀钵悬高象牙杙上。沙门婆罗门不以梯杖能得者与。非不与。皆作是念。是居士欲见神通力故挑头而去。尔时长老宾头卢颇罗堕。闻树提居士作栴檀钵络囊盛悬高象牙杙上沙门婆罗门不以梯杖能得者与非不与。闻已诣目连所言。长老目连。汝知不。树提居士作栴檀钵络囊盛悬高象牙杙上作是言。诸沙门婆罗门不以梯杖能取者与非不与。目连言。汝师子吼中第一。便可往取。尔时长老宾头卢颇罗堕。过夜中前着衣持钵。以好威仪行住坐立。往诣树提居士舍。树提居士。遥见宾头卢行住坐立威仪清净着衣持钵。作是念。如是比丘行住坐立威仪清净着衣持钵。必能取钵。居士即从坐起。偏袒右肩合掌向宾头卢言。善来颇罗堕。久不来此。命就座坐。树提居士头面礼颇罗堕足。宾头卢坐已问居士言。汝实作栴檀钵盛络囊中悬高象牙杙上作是言。诸沙门婆罗门不以梯杖能取者与非不与。答言。实尔。宾头卢即入如是禅定。便于座上申手取钵以示居士。居士语言。如我先语即便属汝。居士又言。暂与我来。即取钵入。盛满粳米饭授与宾头卢。宾头卢食已。便持是钵示诸比丘言。汝等看是钵香好可爱。诸比丘言。实尔。从何处得。宾头卢广说上事。是中有比丘。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘。为赤裸外道物故。未受大戒人前。现过人圣法。呵已向佛广说。佛以是事集比丘僧。知而故问宾头卢颇罗堕。汝实作是事不。答言。实作世尊。佛种种因缘呵责宾头卢。云何名比丘。为赤裸外道物木钵故。于未受大戒人前现过人圣法。呵责已语颇罗堕。尽形寿摈汝。不应此阎浮提住。宾头卢受佛教已头面礼佛足右绕还自房。所受僧卧具床榻。尽以还僧。持衣钵入如是定于阎浮提没瞿耶尼现。到已多教化优婆塞优婆夷。多畜弟子。起僧坊房舍。畜共行弟子近行弟子。广宣佛法。佛尔时遣。宾头卢去不久集比丘僧。集僧已语诸比丘。从今不听畜八种。钵何等八。金钵银钵琉璃钵摩尼珠钵铜钵白镴钵木钵石钵。畜者突吉罗。听汝等畜二种钵。铁钵瓦钵。瓦钵喜破。佛言。缀用。优波离问佛。以何物缀。佛言。应用毛刍摩劫贝麻文阇草婆婆草。彼国多热故。缀中生虫。佛言。应解缀晒已还缀。诸比丘日日解晒还缀疲极。有一比丘能锻铜。是比丘白佛言。愿听以二种物缀钵若铁若铜。佛言。听用若铁若铜

佛在舍卫国。尔时有比丘。起欲心故。自截男根苦恼垂死。诸比丘以是事白佛。佛言。汝等看是痴人。应断异所断异。应断者。贪欲嗔恚愚痴。如是呵已语诸比丘。从今不听断男根。断者偷兰遮。复有比丘。为作浴破薪故。毒蛇从朽木中出啮比丘指。比丘作是念。此毒必入身。即自断指。由是指撅。诸居士入寺中见比丘撅指作是言沙门释子亦有撅指。是中有比丘。少欲知足行头陀。闻是事心不喜。是事白佛。佛种种因缘呵责。云何名比丘。自断指。如是呵已语诸比丘。从今不应自断指。自断指者突吉罗。佛言。从今有如是因缘。听以绳缠指以刀刺出毒有六群比丘。往观伎乐歌舞。诸居士呵责言。诸沙门释子自言善好有德。往观听伎乐歌舞。如王如大臣。是中有比丘。少欲知足行头陀。闻是事心不喜。是事白佛。佛知故问六群比丘。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘。自往观听伎乐歌舞。如是呵已语诸比丘。从今比丘不应往观听伎乐歌舞。往观者突吉罗。又六群比丘自歌诸居士呵责言。诸沙门释子自言善好有德。歌如白衣。是中有比丘。少欲知足行头陀。闻是事心不喜。是事白佛。佛语诸比丘。从今不应歌。歌者突吉罗。歌有五过失。自心贪着。令他贪着。独处多起觉观。常为贪欲覆心。诸居士闻作是言。诸沙门释子亦歌。如我等无异。复有五过失。自心贪著令他起贪着。独处多起觉观。常为贪欲覆心。诸年少比丘闻亦随学。随学已常起贪欲心。便反戒。有比丘名跋提。于呗中第一。是比丘声好。白佛言。世尊。愿听我作声呗。佛言。听汝作声呗。呗有五利益。身体不疲不忘。所忆。心不疲劳。声音不坏。语言易解。复有五利。身不疲极。不忘所忆。心不懈惓。声音不坏。诸天闻呗声心则欢喜

佛在舍卫国。尔时诸比丘铁钵中食已。置钵在地湿气生坏。佛言。从今听用弊纳着钵下。是国中多热。纳衣中生虫。佛言。应作安钵物。长老优波离问佛。以何物作安钵物。佛言。应以白镴铅锡作。作已故生虫。佛言。应作安钵栈。作已瓦钵栈上堕地破坏。佛言。应着箱中。露钵着箱中相触作声。佛言。听以弊纳裹着箱中。长老疑离越比丘。洗瓦钵置日中日炙津出。语诸比丘。瓦钵不净有腻。比丘不应用食。诸比丘不知云何。是事白佛。佛知故问疑离越。汝实洗瓦钵置日中日炙津出语诸比丘瓦钵津腻不净比丘不应用食。答言。实尔世尊。佛言。从今洗瓦钵已。不应着日中炙。着日中者突吉罗。尔时比丘有贵价衣。水中浣净欲裁作衣。以齿啮边若共挽裂此衣处处纵横破裂。佛言。从今听畜月头刀子用裁衣。尔时以鸡毛鸟毛缝衣缝已易坏褰缩。佛言。听用二种针铁针铜针尖鼻圆鼻方鼻。时诸比丘以衣着膝上缝。缝时皱。佛言。敷地缝。诸比丘敷地缝时土著。佛言。当以牛屎涂地。时或有不正。佛言。听绳缀四边。缀已或有不直。佛言。处处拼拼。时或有不均。佛言。刻木为准。缝时针难得前。指头伤破。佛言。听着指[打-丁+沓]。尔时针刀指[打-丁+沓]木准。各着异处求觅难得。佛言。听以物盛着一处。缀衣缝时喜坏衣缘。佛言。听着伪缘。此衣舒在外边喜失。佛言。听卷叠。卷时喜舒。佛言。以绳系。或时风雨污衣。佛言。听着覆处。在覆处着地有虫啖。佛言。听打撅着壁上。时撅头滑衣堕地。佛言。听作曲头撅。诸比丘身有长短。有短比丘。截缝衣床就身。有长比丘。更处处觅求长床。佛言。听凿作孔盈两头出令得共用。佛在王舍城。尔时六群比丘以镜照面。佛言。不听照面。照面者突吉罗。尔时六群比丘。或以钵中照面。或水中照面。佛言。若钵中水中照面者突吉罗。若照看面疮者不犯佛在王舍城。尔时六群比丘。以梳梳头。佛言。比丘不得以梳梳头。若梳头者突吉罗。尔时六群比丘。又以刷刷头。佛言。若刷者突吉罗

佛在王舍城。尔时六群比丘。顶上留少发。佛言。不听留。若留者突吉罗。尔时六群比丘。留发令卷。佛言。不应留发令卷。若留者突吉罗。尔时六群比丘。留发令长。佛言。不应留发令长。若留者突吉罗。若阿练儿比丘长至二寸无罪

佛在舍卫国。尔时比丘。有癞病疥[癈-(弓*殳)+虫]病。语药师耆婆。治我病。耆域言。入浴室洗可差。比丘言。佛未听入浴室洗。诸比丘以是事白佛。佛言。听入浴室洗。洗有五功德。一者除垢。二者身清净。三者除去身中寒冷病。四者除风。五者得安隐。尔时浴室中无有坐物。诸比丘无处可坐洗。佛言。浴室中听安坐物。长老优波离问佛。用何物作。佛言。用木石塼作。尔时浴室地泥出。诸比丘以泥水洗。佛言。听浴室安橙。优波离问佛。用何物作橙。佛言。以木石塼作。尔时当浴室中着火炉。诸比丘浴时不安隐。佛言。应着壁安。尔时不作窖。火炎直上至屋。佛言。听安窖。窖中一时着薪。后比丘来洗时火势已尽。佛言。筹量着。尔时着长薪喜堕落。若以手举便烧手。佛言。以叉举。当举叉时。比丘头上无发热痛。佛言。以湿物覆头。尔时须土涂身。佛言。应畜盛土物。尔时须水。佛言。应畜盛水器。尔时水器小。佛言。听畜瓮瓮中盛满水尔时瓮水着窖埵上。有木薪堕上破瓮。佛言。凿壁安木着水瓮。尔时瓮高。有比丘取水不及。佛言。不应高安。尔时安着下处。有比丘橖触。佛言。不得太下太高。齐肩齐头安。时浴室无户风入。佛言。应安户扇。时比丘入浴室时不得闭户。佛言。令一比丘看户。时浴室无窗故闇。佛言。安窗。时浴室无出烟处故熏黑。佛言。施出烟处。时比丘或有用澡豆。或有用土。以湿热故。浴室虫生。佛言。应荡除令净。尔时浴室中大有水。佛言。应出水。出水时诸比丘吐闷或得病。佛言。应安伏窦。伏窦中有蛇蝎蜈蚣。来入螫诸比丘。佛言。应织物遮水窦口。尔时浴竟弃浴室去。后火烧浴室。佛言。最后比丘应收诸物事。却瓮却瓨灭火。闭户下[橝-早+卑]乃去

佛在维耶离。有一长者。名大名梨昌。大富多饶财宝。大有田宅力势。有一比丘。名迦留罗提舍。与是长者相识知旧出入往反。时迦留罗提舍。食时着衣持钵持坐具。往大名梨昌所。是梨昌遥见比丘来赞言善来。在此处坐。即敷坐具。时大名梨昌。头面礼足已一面坐。比丘语大名梨昌。今可往世尊所向世尊作如是说。云何比丘作非梵行。是陀骠力士子。共我妇作非梵行。大名梨昌语迦留罗提舍。云何以无根谤清净比丘。迦留罗提舍比丘语大名梨昌言。若不向佛说此语者。不复与汝言语来往。不入汝舍。大名梨昌。与此比丘深相爱敬故。即作是念。若我不作是语者。迦留罗提舍比丘。必不共我语。不入我舍。便语比丘。我当向佛作是语。是时大名梨昌。往诣佛所白佛言。世尊。云何比丘作非梵行。是陀骠力士子共我妇作非梵行。佛尔时语诸比丘。汝等皆覆钵。莫至是大名梨昌家。诸比丘比丘尼。式叉摩尼沙弥沙弥尼。不得到大名梨昌家自手受食。更有如是人。亦应与作覆钵。作覆钵法者。一心和合僧一比丘唱言。大德僧听。此大名梨昌诽谤比丘。是陀骠力士子清净梵行。无根波罗夷谤。若僧时到僧忍听。僧和合。与是大名梨昌作覆钵。诸比丘比丘尼式叉摩尼。沙弥沙弥尼。不得至是家手受食。如是白。白二羯磨。僧作覆钵竟。僧忍默然故。是事如是持。尔时诸比丘作如是念。僧已为是大名梨昌覆钵。诸比丘比丘尼。式叉摩尼沙弥沙弥尼。不得至大名梨昌家手受食。诸比丘复作是念。谁能往长者家作如是言。僧已覆钵。一切比丘比丘尼。式叉摩尼沙弥沙弥尼。不得至汝家手受食。复作是念。长老阿难是佛侍者。于诸比丘中赞叹清净梵行。阿难能至是大名梨昌家。作如是言。僧已作覆钵。一切比丘比丘尼。式叉摩尼沙弥沙弥尼。不复得至汝家手受食。诸比丘共相谓言。我等往至阿难所作是言。僧已为大名梨昌作覆钵。一切比丘比丘尼。式叉摩尼沙弥沙弥尼。不得往大名梨昌家手受食。诸比丘作是语已。往至阿难所。头面礼足在一面坐已。白阿难言。长老阿难。僧已为大名梨昌作覆钵。一切五众。不得往大名梨昌家手受食。我等心念。谁能往长者家作是语。众僧为汝作覆钵。一切五众。不得至汝家手受食。诸比丘复作是念。唯长老阿难是佛侍者。佛常于比丘众中。赞叹梵行清净。堪任能往作是言。僧今已为长者作覆钵。一切五众。不得至汝家手受食。长老阿难。今可往大名梨昌家作是言。僧已为汝覆钵。一切五众。不复至汝家手受食。尔时阿难默然受。诸比丘见阿难受已。从坐起作礼右绕而去。尔时阿难过夜已。中前着衣持钵至大名梨昌家。大名梨昌。遥见阿难来即从坐起。着衣在一处立叉手言。善来阿难。就此处坐。阿难答言。我不得坐。大名梨昌问言。何故不得。阿难言。僧已为大名梨昌作覆钵。一切五众。不得至汝家手受食。大名梨昌语阿难。我今便为自损功德不生。阿难答言。汝实自损功德不生。问阿难言。我今可得往佛所仰钵不。阿难言。不得。大名梨昌闻是语已。心愁迷闷躄地。大名梨昌妇。扶头起以水洒面久乃得醒。妇语大名梨昌。正有是苦。更有过是苦耶自言。我无过罪而面向佛说我过。于清净比丘众中我谤作非梵行。尔时大名梨昌。往诣佛所白佛言。世尊。愿为我仰钵。佛语诸比丘。为是大名梨昌仰钵。仰钵法者一心和合僧。是大名梨昌。偏袒右肩合掌胡跪言。众僧忆念。我大名梨昌骂詈道说比丘陀骠力士子清净梵行人。我以无根非梵行故谤。僧作覆钵。一切五众。不得至我家手受食。我今愿众僧还仰钵。一切五众。如本往来我舍手受食。怜愍故。如是三乞。一比丘应僧中唱言。大德僧听。是大名梨昌。骂詈道说比丘陀骠力士子清净梵行人。以无根波罗夷谤故。僧为作覆钵。一切五众。不得往至大名梨昌家手受食。若僧时到僧忍听。为大名梨昌仰钵。如本往来自手受食。如是白。白四羯磨。僧已仰钵竟。僧忍默然故。是事如是持

十诵律卷第三十七(杂诵第二)十诵律卷第三十八(第六诵之三)

        后秦北印度三藏弗若多罗译

    明杂法之三

佛游波伽国。人间教化。有一处。名失守罗。毗师蓝蜜伽蓝。是失守罗处。菩伽王子家有新堂成。名鸠摩罗。未有沙门婆罗门入中坐者。尔时王子闻佛游波伽国人间教化在失守罗处毗师蓝蜜伽蓝教化。我今有新堂。名鸠摩罗。成来未久。修饰画治讫亦未久。未有沙门婆罗门入中坐者。若世尊与众僧。先入我舍者我大得利。何以故。佛入我舍故。佛入已我当后入。菩伽王子。即唤萨若瞿妒路摩牢。向作是语。我闻世尊游波伽国人间教化在失守罗处毗师蓝蜜伽蓝游行教化。我今有新堂。名鸠摩罗。新成。未有沙门婆罗门入中坐者。若佛先入者。我得大利。佛入已我当后入。萨若瞿妒路摩牢。汝往世尊所。以我语白佛言。世尊。菩伽王子头面礼佛足。问讯世尊作是言。菩伽王子有新成堂。名鸠摩罗。未有沙门婆罗门入者。菩伽王子请佛及僧。时萨若瞿妒路摩牢。受王子语已。往世尊所作如是言。世尊。菩伽王子。头面礼足问讯世尊。少病少恼安乐住不。我有新成堂。名鸠摩罗。成来未久。修饰画治讫亦未久。请佛及僧明日食。佛言。使是王子常得安乐。佛语萨若瞿妒路摩牢。天人常求乐。诸龙夜叉乾闼婆阿修罗迦留罗紧那罗摩睺罗伽及余众生亦皆求乐。佛说已默然。时萨若瞿妒路摩牢。见佛默然右绕而去。到菩伽王子所。作如是言。瞿昙沙门已受王子请。随王子意。尔时菩伽王子。竟夜办具种种多美饮食。办已晨朝敷坐处。以衣布地。庄严鸠摩罗堂及阶。陛庄严竟。即语萨若瞿妒路摩牢。往世尊所白言时到。萨若瞿妒路摩牢受语已。即往世尊所白言时到。尔时世尊。中前着衣持钵大众围绕。到菩伽王子舍。尔时王子约敕家内。一切大小皆出门外。时王子遥见世尊来。即从坐起叉手在一面立。作如是言。善来世尊。王子前诣佛所。头面礼足迎。世尊到鸠摩罗堂。王子在阶道边立。佛及僧往至阶头立住。尔时菩伽王子。叉手白佛言。世尊。愿前堂上。从敷[疊*毛]处上。令我等长夜安隐。时长老阿难在佛后以扇扇佛。佛语阿难。随法约敕王子。尔时阿难语菩伽王子。却地所敷衣被床上者置。王子不肯。阿难语王子。佛怜愍后来众生故且却。时菩伽王子即却地所敷衣被。尔时王子叉手白佛言。已却地敷愿佛上堂。令我等常得安隐。佛即上堂敷坐具。在诸比丘前坐。尔时王子自行水已。下种种饮食。僧得饱满。食已摄钵行水。行水时王子执澡盘承水竟。听佛说法。佛为说种种法示教利喜。示教利喜已从坐起去。时佛食后集比丘僧。语诸比丘。若地敷衣。不应在上行。在上行者突吉罗

佛在舍卫国。有一婆罗门。大富多饶财宝田宅牛羊。唯少一种。无有儿息。求一切天神。所谓水神树神。为求儿故。穷极不能得。有一比丘尼。常出入其舍。后日来时。婆罗门妇有不净现。时比丘尼语妇人言。汝不清净。我曾闻。取阿罗汉行迹处物浣取汁洗浴。便得有儿。此中除佛及弟子众。余处更无。世尊若来入汝舍者。可得生儿。时婆罗门妇闻已。云何方便令佛入舍。便以方便语婆罗门。我曾闻。取阿罗汉行迹处物。浣取汁洗浴。便得有儿。除佛及弟子众。余处更无。若佛入舍者。可得生儿。时婆罗门不信是语。以求儿故。答言。随意。妇言。汝往请佛。时婆罗门往世尊所。一面坐问讯世尊。佛为种种说法示教利喜已默然。婆罗门言。愿佛及僧。明日受我请。佛默然受。知佛受已。从坐起右绕而去。到自舍通夜办种种多美饮食。办已晨朝敷坐处。以种种物布地乃至外门往白佛言。时到食具已办佛自知时。诸比丘往婆罗门舍。佛自住房迎食分。尔时诸比丘自却地敷前入其舍。时婆罗门心念。入时不行地敷上。出时当在上行。诸比丘坐已。自行澡水下食。僧饱满食已。摄钵洗手咒愿。咒愿已从上座次第。却地敷而出。时婆罗门心意不乐。是沙门断种人。破我婆罗门行我有所为作是供养。而常不果。诸比丘食后到佛所。头面礼足在一面坐。诸佛常法。食后比丘来。以是语劳问诸比丘。饮食多美僧饱满不。佛即以是语劳问诸比丘。饮食多美僧饱满不。诸比丘言。饮食多美众僧饱满。以上因缘向佛广说。佛以是事集比丘僧。集僧已种种因缘赞戒赞持戒。赞戒赞持戒已语诸比丘。从今怜愍众生故。听汝等地敷上行。时诸比丘尼闻佛听地敷上行。以婆罗门因缘故。先往婆罗门家。比丘尼便往语婆罗门妇言。佛先结戒。不听比丘地敷上行。以是因缘故听。汝可更请令蹈上过。时婆罗门妇。以方便语夫。佛先结戒。不听比丘行地敷上。以是因缘故听。今可更请。婆罗门心亦不喜。以为儿故。答言。随意。妇语夫言。可往请佛。婆罗门往到世尊所。一面坐问讯世尊。佛为婆罗门说种种法示教利喜。示教利喜已默然。婆罗门白佛言。愿受我明日请。佛默然受。婆罗门知佛受。已从坐起去。竟夜办种种多美饮食。晨朝以种种物布地乃至外门。往白佛时到食具已办。尔时世尊着衣持钵。诸比丘僧前后围绕。到舍就座坐已。自行澡水下食。食已摄钵行澡水。婆罗门在佛前听说法。听说法已白佛言。世尊。我家当生儿不。佛言生。生已当出家。第二生者亦当出家。第三生者亦当出家。次后生者当在家。佛自恣后游行教化。有一比丘。手捉钵药草革屣而行。佛见此比丘。知而故问。汝何以捉钵药草革屣游行。答言。我更无著处。佛言。从今听畜三种囊。钵囊药草囊革屣囊。佛在王舍城。尔时六群比丘。所受持坐具。置一处已余处宿。佛言。从今日所受坐具不应离宿。犯者突吉罗。佛在舍卫国。憍萨罗国有阿练儿处。有二比丘在彼住。一人犯戒一人净持戒。此二比丘未曾见佛。欲共往见佛。道中值有虫水。破戒者语持戒者言。可共饮是水。持戒者言。水中有虫。云何可饮。犯戒者言。我若不饮便死不得见佛闻法及僧。持戒者言。至死不饮。时犯戒者便饮。持戒者不饮便死。即生三十三天上。得天身具足。先到佛所头面礼足在一面立。在一面立已。佛为种种说法。得法眼净。即时礼佛足言。归依佛归依法归依僧。我尽形寿为优婆塞。佛更为说法已默然。时天礼佛已忽然不现。时饮水者后到佛所。佛为无量众围绕说法。佛见此比丘来到佛所。佛时披忧多罗僧示金色身。汝痴人。欲见我肉身为。不如持戒者先见我法身。佛说偈言

  心不善观察　　见则不审谛
  愚如蛾投火　　而贪观我身
  色身但不净　　汝欲见何为
  肉有脂血肉　　外为薄皮覆
  彼为渴所烧　　犹行恭敬戒
  至死护我教　　彼见我非汝

佛说是偈已告诸比丘。从今不持漉水囊不听行。若不持行者突吉罗。不犯者。有清流水。或大河或泉水。从此寺至彼寺。二十里内不犯。尔时比丘聚落中有缘事。无漉水囊故不去。若不去者此事不成。以是事白佛。佛言。若一比丘有漉水囊。便得共去。尔时六群比丘。聚落中有缘事。往语知识比丘。我有缘事可共至聚落。是比丘言。我无漉水囊。六群比丘言。我有可共俱往。答言。可尔。行时道中共诤。值有虫水。六群比丘以漉水囊自漉水饮。彼比丘索不与。是比丘极渴急垂死。以是因缘白佛。佛言。若比丘先不共诤。无嫌心者应共行。有嫌心者不应共去

佛在王舍城。尔时六群比丘木上食。佛言。从今不听木上食。若用食者突吉罗。尔时六群比丘。自畜木橙食。或畜床子食。或畜盘食。佛言。不听畜木橙木床木槃食。若用食者突吉罗。佛在王舍城。尔时六群比丘。二人共一钵食。佛言。不得共钵食。若共钵食突吉罗。不犯者。食休已过与不犯

佛在王舍城。六群比丘不着袈裟食。佛言。不听不着袈裟食。不着食者突吉罗

佛在王舍城。尔时六群比丘露形揩。佛言。不得露形揩。犯者突吉罗。又六群比丘揩露形者。佛言。不听揩露形者。犯者突吉罗。有二比丘俱露形相揩。佛言。若露形相揩者。俱突吉罗

佛在舍卫国。有比丘。名疑离越。小豆羹中得生小豆。便出着地。此豆可生芽叶华实。是比丘语诸比丘。此羹不净不应食。诸比丘以是事白佛。佛知故问疑离越。汝实羹中得生小豆。出着地可生芽叶华实。语诸比丘此羹不净不应食耶。答言。实尔世尊。佛种种因缘赞戒赞持戒。赞戒赞持戒已语诸比丘。此羹若未熟者。应更煮。若先生者。应作净已煮

佛在舍卫国。诸比丘作净地羯磨。佛言。从今不听作净地。若作者突吉罗。佛在舍卫国。有比丘名牛齝。食已更齝。诸比丘见非时嚼食。各相谓言。是比丘过中食。闻已心愁不乐。是事白佛。佛以是因缘集比丘僧。语诸比丘。莫谓是比丘过中食。何以故。是比丘先五百世时。常生牛中。是比丘虽得人身。余习故在。佛言。若更有如是齝食者。应在屏覆处。不应众人前齝

佛在波伽国。尔时菩伽王子。请佛及僧明日食。佛默然受。王子知佛受已从坐起去。还家竟夜办种种多美饮食。晨朝敷坐处。往白佛时到。食具已办唯圣知时。尔时佛与诸比丘前后围绕。至菩伽王子家就座而坐。其家大小多不信佛。或是婆罗门或边地人。行食不如法。半着钵中半弃在地。是诸比丘不知云何得食。是事白佛。佛言。食堕所受草叶上者应食。若有土著者。吹土却而食。或有多土著者。水洗得食。佛在王舍城。尔时六群比丘。铜杅中食。诸居士呵责言。诸沙门释子自言善好有德。铜杅中食加婆罗门。佛言。不听铜杅中食。犯者突吉罗。佛在王舍城。尔时六群比丘。洗脚处洗脚。洗脚时并共人语。余比丘见吐闷。佛言。从今不得洗脚时共他语。犯者突吉罗。佛自恣后游行教化。有比丘手捉革屣行。佛见是比丘。知而故问。汝何以手捉革屣行。答言。革屣啮脚。脚中痒闷。无揩脚物。佛言。听畜揩脚木用。除脚痒故

佛在王舍城。尔时有檀越施僧扇。诸比丘不受。佛未听我等畜扇。是事白佛。佛言。听畜。僧得畜一人亦得畜。复有人施僧拂。诸比丘不受。佛未听我等畜拂。是事白佛。佛言。听畜。僧得畜一人亦得畜。时有人施僧牦牛尾拂。诸比丘不受。不知何所用。是事白佛。佛言。听受用。拂佛塔及诸阿罗汉塔。尔时有人以摩尼珠作拂柄施比丘。诸比丘不受。不知云何用。是事白佛。佛言。听受用。拂佛塔及阿罗汉塔。尔时有檀越施僧多罗树叶。诸比丘言。佛未听我等畜多罗树叶。是事白佛。佛言。僧得受一人亦得受

佛在王舍城。尔时六群比丘。自持盖入他舍。诸居士诃责言。云何名比丘。持盖入他舍如王如大臣。是事白佛。佛言。不听持盖入他舍。犯者突吉罗。不犯者。若解若置门外

佛在舍卫国。有二婆罗门。一名瞿婆。二名夜婆。于佛法中笃信出家。本诵外道四围陀书。出家已以是音声诵佛经。时一人死一人独在所诵佛经忘不通利。更求伴不得。心愁不乐。是事白佛。佛言。从今以外书音声诵佛经者突吉罗

佛在舍卫国。有比丘。舍修多罗阿毗昙。舍毗尼。诵外书文章兵法。远离佛经。佛言。从今诸比丘。若有学诵外书文章兵法者。突吉罗。佛未制是戒时。长老舍利弗目连处高座上。为诸新比丘沙弥说法。教学诵外书。为破外道论故。制是戒已。长老舍利弗目连。便不处高座为新比丘沙弥说法教学外书。尔时诸外道。闻沙门瞿昙不听弟子学诵外书。是婆罗门便往语诸信佛。优婆塞言。可共往到诸比丘所。答言。随意。外道到已。与新比丘沙弥共论议。诸新比丘沙弥皆不能答。以二事故。一者新入道。二者佛制不听学故。时诸外道轻弄。诸优婆塞言。汝之大师汝所供养。汝所尊重上坐先食者。正如是耶。诸优婆塞闻是事心愁不乐。以是事白佛。佛言。从今听为破外道故诵读外道书。佛在舍卫国。尔时长老迦留陀夷。放火烧诸草木。以放烧故。多杀种种虫。佛言。从今比丘不得放火烧。若放火烧者。随所杀得罪

佛在舍卫国。有看病人。未满五腊。为病人出行。离依止入聚落。求药不得。尔时心念佛制戒。不得离依止一夜别宿。即于彼处便求依止。依止师复病。是人心念。彼依止师病。此依止师亦病。我今当作何等。是事白佛。佛言。从今听。若五夜若六夜无依止不犯结此戒已。六群比丘闻佛听故。便五夜不求依止。何以故。若得依止者。须我供给。诸比丘以是事白佛。佛言。从今有好依止师者。乃至一夜不依止突吉罗。若比丘无依止。乃至不得取僧洗脚水用。佛在舍卫国。尔时长老迦留陀夷反着俱执。诸比丘见已怖畏。是事白佛。佛言。从今不得反着俱执。犯者突吉罗。自舍内覆身不犯。佛在舍卫国。尔时有人持表里[卄/毦]俱执。施长老须菩提。须菩提言。佛未听受表里[卄/毦]俱执。是事白佛。佛言。从今听畜表里[卄/毦]俱执。众得畜一人亦得畜。复有人施长老须菩提俱执。半成色半不成色。时须菩提不受。作是言。佛未听我等受半成色半不成色俱执。是事白佛。佛言。从今听畜半成色半不成色俱执。众僧得受一人亦得受。佛在舍卫国。有五比丘。得长五肘广三肘衣。着是衣入聚落乞食。衣长曳地土所污。脚蹑头堕地着不周正。是事白佛。佛言。听长衣施鞙纽施近缘。故衣曳地土污脚蹑堕地着不周正。佛言。从今听反摄上着。尔时佛自施鞙纽。前去缘四指施鞙。后八指施纽。语诸比丘。应如是作

佛在舍卫国。有比丘。不系泥洹僧入聚落。于聚落中堕地。是比丘大惭愧。是事白佛。佛言。从今不系泥洹僧入聚落者突吉罗。有比丘一匝系泥洹僧。入聚落时啑故。带断堕地是事白佛。佛言。从今不听一匝系泥洹僧入聚落。犯者突吉罗。尔时有人。施长老须菩提细缕系腰带。须菩提不受作是言。佛未听我受细缕系腰带。是事白佛。佛言。听畜三种带。一者细缕带。二者索绳。三者编带。带时泥洹僧喜破。佛言。应施环。六群比丘如两耳着泥洹僧。细襵着泥洹僧。釿头着泥洹僧。参差着泥洹僧。着细生疏泥洹僧。佛言。不得如两耳着泥洹僧。细襵着泥洹僧。釿头着泥洹僧。参差着泥洹僧。着细生疏泥洹僧。著者突吉罗。佛在王舍城。尔时六群比丘。手摩须发。如牛舌舐。是事白佛。佛言。从今不听手摩须发犯者突吉罗

佛在王舍城。尔时六群比丘。二人共床卧。是事白佛。佛言。从今不听二人共一床卧。犯者突吉罗。若一人坐一人卧不犯。尔时六群比丘。二人共地敷卧。佛言。从今不听二人共一敷卧。犯者突吉罗。各自别有敷具不犯。尔时六群比丘。二人共一覆衣中卧。佛言。从今不得共一覆衣中卧。犯者突吉罗。不犯者。各别有衬身衣。佛在王舍城。尔时六群比丘着俗人衣。诸居士呵责言。沙门释子自言善好有德。着俗衣。与白衣何异。是事白佛。佛言。从今不得着俗衣。犯者突吉罗

佛在王舍城。尔时六群比丘。抄襞泥洹僧。如相扑人又似作人。是事白佛。佛言。从今不得抄襞衣着。犯者突吉罗。不犯者。登梯覆屋泥屋。佛在王舍城。尔时六群比丘负担行。如似驴牛负驮。是事白佛。佛言。从今不听负担行。犯者突吉罗

佛在舍卫国。尔时憍萨罗国。有边聚落。是中常畏贼。聚落人民畏贼故。舍此处去。尔时有比丘。从憍萨罗国向舍卫国。是比丘捉瓦钵捉杖。所经聚落中人。遥见来作是念。此是贼来。捉槊捉楯见已怖畏还入楼阁。比丘渐渐来近。知是沙门。问言。汝是何沙门。答言。释子沙门。言汝失沙门法坏沙门法。令我等怖畏。是比丘不知云何。是事白佛。佛言。从今行时不听捉杖捉络囊。犯者突吉罗。佛自恣后人间游行。有一羸瘦比丘。手捉钵行。佛知故问。汝何以手捉钵行。答言。无物可盛。佛言。从今羸瘦老病比丘。僧羯磨听杖络囊盛钵行。应如是作。一心和合僧。是老病比丘从坐起。偏袒右肩脱革屣胡跪合掌作是言。大德僧听。我某甲老病比丘。从僧乞捉杖络囊盛钵行。僧怜愍故。听我老病比丘捉杖络囊盛钵行。如是三乞。僧应听。实是比丘若言老病。实不老病不应听。若言老病。实老病应听。一比丘僧中唱言。大德僧听。某甲比丘老病。从僧乞捉杖络囊盛钵行。若僧时到僧忍听。与是老病比丘捉杖络囊盛钵行。如是白。白二羯磨。僧与是老病比丘捉杖络囊盛钵行竟。僧忍默然故。是事如是持

佛在舍卫国。佛与大众前后围绕说法。尔时憍萨罗王波斯匿。在会中坐。有比丘啖蒜远大众行。是比丘作是念。莫使佛及王闻臭。佛遥见是比丘。佛为王说种种法示教利喜。王闻法已心大欢喜。佛说法已默然。王右绕佛而去。尔时长老阿难。佛后以扇扇佛。王去不久。佛知故问阿难。此比丘何以远大众行。答言。此比丘啖蒜。恐佛及王闻臭。不敢近佛。佛知故问阿难。比丘啖如是比相食耶。答言啖。若啖如是比相食失法利。佛言。此比丘若入众中。闻我法应得正见。语诸比丘。是事不应作。佛告诸比丘。比丘不得啖蒜。若啖者突吉罗

佛在舍卫国。尔时长老舍利弗得风病。药师教言。乳中煮蒜啖。舍利弗言。佛未听乳中煮蒜啖。是事白佛。佛言。听乳煮蒜啖。随啖蒜法行。云何随法行。啖蒜者。不应近佛乃至和上阿阇梨一切上座佛塔声闻塔温室讲堂僧食厨下。不得近僧坊外门立。不得入僧厕大小便。不得入僧浴室。不得入众人坐处。当于屏房住。若急大小便者。应使人掘地作处。若无净人。应就远屏处大小便。若病差已。应扫洒所住处涂地卧具床席。更应抖擞。故有臭者应洗浣。是比丘从房出闭户下掸。下掸已去

佛在王舍城。尔时六群比丘。自取诃梨勒果与净人已从受啖。是事白佛。佛语诸比丘。不应自手取诃梨勒果与净人更从受啖。犯者突吉罗。余一切果亦如是。佛在舍卫国。有比丘名难提。是比丘作与净学沙弥。如先所说。佛在舍卫国尔时长老毕陵伽婆蹉眼痛。时药师教言。和药作丸着火上烧服烟。优波离问佛用何物作药。佛言。但除青木香药和合。余一切香着火中手接取烟而咽。时以手接烟不得。佛言。作筒。时筒太长不得烟。佛言。莫长作。又复短作便烧手。佛言。莫太短。又时丸药在一处。筒在一处。取时难得。佛言。应畜囊盛。盛时筒破药丸。佛言。中应施鬲。施鬲已不系头筒堕地。佛言。应系头。佛在舍卫国。有病比丘。苏油涂身不洗痒闷。是事白佛。佛言。应用澡豆洗。优波离问佛。用何物作澡豆。佛言。以大豆小豆摩沙豆豌豆迦提婆罗草梨频陀子作。佛在舍卫国。长老舍利弗患热血病。时药师教言。以娑摩尼水洗。优波离问佛。用何物作娑摩尼。佛言。除毒树。取余一切树华叶作。佛在舍卫国。长老毕陵伽婆蹉患眼痛。时药师教言。应脂灌鼻。时比丘以指渧鼻中。或以毳取而渧。渧时不便流入。眼更增痛剧。是事白佛。佛言。作筒灌。作筒大鼻不受。复小作溢失不中。用是事白佛。佛言。莫大莫小作。得受一波罗。若一波罗半。欲唾以手承取。以手承取故便欲吐。佛言。听用弊衲承取

佛在舍卫国。尔时长老毕陵伽婆蹉患眼痛。时亲里遣乘来唤。答言。佛未听乘乘。是事白佛。佛言。病者听乘车舆。尔时佛不听乘辇。是事白佛。佛言。听乘辇。是比丘乘辇时垂脚。佛言。应摄脚在板上摄脚。己身不安。佛言。听捉木格。尔时有少乐比丘。捉木格手痛。佛言。以物缠木。坐时日照面。佛言。应施轩。若一切乘上所须庄严物。皆听作。佛在舍卫国。尔时诸比丘。只桓中处处大便。密迹执金刚神诸非人。皆嗔呵责言。此中应作不净耶。佛语诸比丘。不应处处大便。当在一处作。一处作已大聚粪。佛言。除却。除却时诸比丘吐闷。佛言。掘地作坑。作坑已坑边有大便。污比丘脚。佛言。应施安脚处。优波离问佛。用何等物作安脚处。佛言。以木石塼作。大便时露地无障人见。佛言。应作障。时两相见。佛言。应施鬲。施鬲已出入时故相见。佛言。应别施户。时有老比丘。上厕时喜倒。欲起时便却偃。佛言。应施格令得企。起时须水洗大便处。佛言。应畜水器。又无土洗手。佛言。应安土。土或少。佛言。大器盛。是时平地着器。或畜生牛马獐鹿猕猴狗来蹈坏。佛言。应凿地安器。又不覆上。有毒蛇蛆[虫*賴]蜈蚣百足。入中啮比丘。佛言。应覆上。又洗手时。地大作泥污脚。佛言。应作安脚处。长老优波离问佛。用何物作安脚处。佛言。用木石塼作。诸比丘洗时露现。佛言。应施障。或二三人俱洗相见。佛言。应施鬲。又出入时相见。佛言。应别施户

佛在舍卫国只桓中。诸比丘处处小便。金刚神诸非人皆嗔呵责。此中应作不净耶。是事白佛。佛言。不得处处小便。应在一处作。一处已如渠流。佛言。应安瓮。瓮满。佛言。应弃。弃时比丘吐闷。佛言。瓮下作孔令出。瓮久便臭。佛言。应盖上。比丘却盖时小便臭剧。佛言。盖上开小孔令臭气出。时瓮四边小便流污脚。佛言。应作安脚处。优波离问佛。用何物作。佛言。应用木石塼作。诸比丘小便时露现。佛言。应施障。小便时两相见。佛言。应施鬲。施鬲已出入时故相见。佛言。应施户。佛在舍卫国。尔时有人施僧瓦瓨。诸比丘不受。不知何所用。是事白佛。佛言。应受用。盛水取水浴室中用

佛在刍摩国与大比丘僧说五阴法。所谓色受想行识。尔时佛啑遍。五百比丘一时同声言老寿。佛语诸比丘。以汝等言老寿故。便得老寿耶。不也世尊。佛言。从今不得称老寿。称老寿者得突吉罗

佛在舍卫国诸比丘入舍卫城乞食。时檀越施种种好食。乳酪生酥熟酥油蜜鱼肉脯。诸比丘不取。将无是乞美食耶。是事白佛。佛言。不乞而得应受。初二十法竟。中二十法上

佛在王舍城。尔时跋提长者。作大僧坊种种庄严。不覆上房舍漏。是事白佛。佛言。应覆。覆已脊上漏。佛言。更厚覆。厚覆已风发。佛言。应钉撅。钉撅已撅孔头漏。佛言。应施盆覆。覆已盆喜堕地。佛言。应穿底作孔钉。钉已水入。佛言。应钉上安覆釜。安覆釜已风吹撅动摇作声。佛言。应以草叶树皮缠头。缠头已安覆釜。佛在舍卫国。尔时比丘畜贵价火浣衣。时诸比丘二三人共抖擞抖擞时衣褰缩不正。佛言。应细杖打尘土。打时土入长条中。佛言。更以小杖打。打时土入短条中。佛言。更以小杖打

佛在舍卫国。尔时比丘新成染衣。以扫彗扫却染滓。是衣色坏衣上成道。是事白佛。佛言。应以新手巾却滓

佛在王舍城。尔时跋提长者作僧坊。极广大种种庄严。多人来看。无地覆故。多尘土出坌僧坊内。诸比丘心念若佛听地覆者善。是事白佛。佛言。应安地覆。佛在舍卫国。诸比丘无捣药物。是事白佛。佛言。应石上磨

佛在王舍城。尔时瓶沙王。于竹园中起五百僧坊。有成者有未成者。时王命终。王阿阇世到竹园中看。见是房舍即问此为谁作。比丘答言。大王。是父王所作。有成者有未成者。王便命终。王问比丘。何不成竟。答言。无直。王言。我当与直。时房舍成竟。无蹬道故。无人在上住。王问诸比丘。是房中有人不。答言无。何以故。答言以无蹬道故。王言。我当作。比丘答言。佛未听作。是事白佛。佛言。听作时长老优波离问佛。用何物作蹬道。佛言。用木石塼作。佛住王舍城。时僧坊极大。一切时多有客比丘来。初夜中夜后夜来者。有持大床去。有持绳床去者。有持大褥去者。有持座褥去者。夜即彼间宿。明日弃去。尔时陀骠摩罗子知僧卧具后日处处持床褥来时极苦。作是念。佛听以针缀床褥者善。是事白佛。佛言。听缀缀时床褥中央不缀。持床东西时。毳并聚一处。即作是念。佛听我缀中央者善。是事白佛。佛言听以针缀长老优波离问佛。用何物作针。佛言。以铁作铜作木作

佛在舍卫国。尔时长老舍利弗热血病药师教言。烧石着乳中饮。答言。佛未听烧石着乳中饮。是事白佛。佛言。听烧石着乳中饮。烧石时诸比丘或以草木叶若破瓦。捻着乳中灰土污乳。是事白佛。佛言。从今听以铜铁作支安锁。以石着中烧。举锁抖擞。去灰着乳中

佛在舍卫国。有人持火炉施长老须菩提。须菩提言。佛未听受。是事白佛。佛言。得受。时然薪火焦堕地。比丘以手举烧手。佛言。听作抄火物

佛在舍卫国。尔时长老舍利弗风病。药师教言。以暖水洗。答言。佛未听暖水洗。是事白佛。佛言。听暖水洗。洗时或用钵揵镃暖水水少不足。是事白佛。佛言。听釜中暖。诸比丘盛满釜水着露地。四边着薪然时釜破。是事白佛。佛言。应施三碣。时碣上安釜下然火薪难然。是事白佛。佛言。应以斧破薪然

佛在阿罗毗国。时寺门楣破。佛见已知而故问阿难。是寺门楣何以破耶。答言。木师忙懅不得作。佛语阿难。求木作具来。阿难受佛教。求木取作具来与佛。佛取以自手治塔门楣。治已语诸比丘。从今听。一切木作具应畜。随比丘能治者治。佛在阿罗毗国。时覆僧坊。比丘在地立授草不及。佛言。应施橙。施橙已故不及。佛言。应施梯。施梯已不遍。佛言。应施棚施棚已不知云何施。佛言。栿上应钉橛以绳系。橛随意移棚。佛在舍卫国。有比丘患男根肿。脓血污衣。是事白佛。佛言。应以物缠裹。佛在舍卫国。有比丘病。看病人岁小。立抱病比丘久立。迷闷躄地垂死。是事白佛。佛言。年少看病比丘得共病人坐。病人怜愍故

佛在舍卫国。诸比丘着新染色衣。入舍卫城乞食值雨。时比丘襞衣着一处湿故色异。是事白佛。佛言。应晒。晒时敷地晒。晒已土著。佛言。应以牛屎涂地晒。应已衣不时干。佛言。绳上晒。故不时干。佛言。应施曲橛。施曲橛已故不时干。佛言应床上晒。晒已故不时干。佛言。应施架。施架时妨行处。佛言。应并一处。并一处已近壁土污。佛言。应离壁。离壁已故不时干。佛言。应高悬晒。佛在阿罗毗国。时诸比丘办浴具。有比丘浴时脱衣着空地入浴室洗。有毒蛇蛆[虫*賴]百足入衣中。比丘着衣时为虫所螫。佛言。施衣架安衣已入浴室洗。佛在舍卫国。尔时末利夫人入只桓听法。诸比丘闇中说法。末利夫人语诸比丘。何不然灯。答言。无灯。夫人言。我与灯。答言。佛未听我等然灯。是事白佛。佛言听

佛在舍卫国。时末利夫人施僧高座。诸比丘言。佛未听我等受。是事白佛。佛言听受。末利夫人心念。佛听我画此高座者善。佛言。除男女交会像。余者听画

佛在舍卫城。尔时六群比丘嚼长杨枝。时诸居士见已呵责言。诸沙门释子自言善好有德。云何嚼长杨枝。有比丘。少欲知足行头陀。闻是事心不喜。是事白佛。佛以是事集比丘僧。知而故问六群比丘。汝实作是事不。答言。实作世尊。佛种种呵责六群比丘。云何名比丘。嚼长杨枝。佛言。从今不得嚼长杨枝。犯者突吉罗。时诸比丘嚼短杨枝。佛是处经行。诸比丘遥见佛来。恭敬故。即咽是杨枝。塞咽不下垂死。是事白佛。佛以是事集比丘僧。语诸比丘。从今听用三种杨枝上中下。上者长十二指。下者长六指。此二中间名中。佛在舍卫国。时有比丘。度儿作共行弟子。弟子不如法。余比丘言。此弟子不如法。何不驱去。答言。此是我子弟子。云何驱去。比丘不知云何。是事白佛。佛言。若儿若弟子不如法者。应驱去。佛在舍卫国。尔时沙弥罗睺罗。违逆师迦留陀夷。时迦留陀夷驱出寺。时沙弥罗睺罗。在只桓门外啼泣。佛从外来入只桓。时见罗睺罗啼泣。佛知故问。何故啼耶。罗睺罗向佛广说是事。佛语诸比丘。从今不得驱沙弥出僧伽蓝。应驱出房舍

佛在舍卫国。时诸比丘唾净地地发坏。是事白佛。佛言。从今不得唾净地。犯者突吉罗。时诸比丘不知唾何处。是事白佛。佛言。应以手承唾。承唾时心中吐闷。佛言。应畜唾器。时唾器满。佛言。应弃。弃时复欲吐。佛言。唾器中着灰着沙着焦物令消唾

佛在王舍城。时长老迦叶从耆阇崛山出。上下时日炙面污入眼眼痛。是事白佛。佛言。听畜手巾拭

佛在舍卫国。长老跋提行头陀。入浴室洗时。不听他人揩摩。作是念。若佛听我编绳自揩身者善。是事白佛。佛言。听用编绳。长老优波离问佛。以何物作。佛言。以毳刍摩劫贝文阇草麻婆娑草。舍利弗病患脊痛。作是念。佛听我着禅带坐者善。是事白佛。佛言。听着禅带坐。优波离问佛。以何物作禅带。佛言。用毳刍摩劫贝文阇草及婆娑草皮作。佛在舍卫国。时世尊患风脊痛。时药师教言。酥油涂身涂身已。槽盛暖水入中卧。佛语阿难。暖水着槽中持来。阿难受教。槽盛暖水来。时佛酥油涂身入中卧。卧已病得除愈。佛以是事集比丘僧。语诸比丘。从今听若有风病以酥油涂身暖水中卧。佛在阿罗毗国。诸比丘办卧具时。暮多有客比丘来。僧敷具少。诸比丘不知云何。是事白佛。佛言。从今应上座次第与。不得敷具者。与草与叶。各令自敷卧具卧。佛在舍卫国。憍萨罗国阿练儿处。有一比丘住。是比丘以颇梨珠出火。时贼住彼处。见比丘珠中出火。作是念。必是毗琉琉珠。贼即语比丘。与我此琉璃珠。比丘答言。善人。我无琉璃珠。时贼心念。是比丘不肯正尔与我。我当杀此比丘。即杀比丘已觅珠。于针线囊中乃得颇梨珠。是贼相语言。乃以此颇梨珠故。杀此比丘。时贼仰卧死比丘。还以颇梨珠。着其脐中便去。时诸比丘食后经行。见是死比丘。各相谓言。以此珠故。为人所害。诸比丘不知云何。是事白佛。佛以是事集比丘僧已。语诸比丘。从今不得畜月珠日珠。若畜者突吉罗

佛在王舍城。时诸比丘。以大价火浣衣石上浣。浣已破坏。佛言。应着板上手揉浣

佛在舍卫国。时末利夫人作一讲堂种种庄严施僧。诸比丘言。佛未听我等受种种庄严讲堂在中出入。诸比丘不知云何。是事白佛。佛言。此堂清净。可受在中出入。时有鹅鸳鸯孔雀俱舍罗鸟乌耆罗命命飞燕诸鸟入出作声。妨诸比丘坐禅诵经。是事白佛。佛言。应施栏楯。施已故来入。佛言。应施网。时优波离问佛。以何物作网。佛言。以毳以刍摩劫贝文阇草麻龙须皮等作。作已喜烂坏。佛言。应施雀目。诸鸟故得来。佛言。应悬帘。悬帘时闇。佛言。应施绳牵上。佛在阿罗毗国。新作僧伽蓝无扫地物。诸比丘不知云何。是事白佛。佛言。应作扫彗

佛在舍卫国。时长老毕陵伽婆蹉眼痛心念。若听我高处坐者善。是事白佛。佛言。听高处坐。在高处时畏堕地。作是念若佛听我高处作栏楯者善。是事白佛。佛言。听高处作栏楯。佛在舍卫国。时僧坊无门。牛马猕猴狗等来入。是事白佛佛言。应作门。佛在舍卫国。时诸比丘不知何处着针。佛言。应作针筒

佛在舍卫国。诸比丘不知何处着药草。是事白佛。佛言。应畜盛药物。诸比丘无晒药物。是事白佛。佛言。应作晒药物。佛在舍卫国。给孤独居士施僧褥。诸比丘言。佛未听受褥。是事白佛。佛言。听僧畜私亦得畜。时诸比丘不自畜褥覆坏僧卧具。露身坐上起时毛着身。是事白佛。佛言。应自畜褥覆着僧褥上。若不自敷者突吉罗

佛在阿罗毗国。比丘露地翘一脚洗。便倒地垂死。是事白佛。佛言。应畜洗脚物。长老优波离问佛。用何物作洗脚物。佛言。用木石塼作佛在阿罗毗国。作新僧伽蓝。时天久旱地干焦。后便大雨地皆发坏。诸比丘行出入时。脚蹈地坏。佛言。应施脚蹈处。长老优波离问佛。用何物作蹈处。佛言。应用木石塼作。彼僧伽蓝多房舍。时诸比丘各自房前作脚蹈处。佛言。应周匝行行作蹈处者好。佛在舍卫国。诸比丘从憍萨罗国向舍卫国。中道有流水渠。诸比丘到渠岸边住。脱革屣已两屣相拍。相拍时尘出。诸天神皆嗔呵责比丘此中不应作是。诸比丘不知云何。是事白佛。佛言。从今不得道中拍革屣。犯者突吉罗。若道中行革屣有土时。应用软羊皮拭。佛在舍卫国。尔时龙子信乐佛法。来入只桓。为听法故。有比丘。以绳系咽弃无人处。时龙子向母啼泣。母言。汝何以啼泣。答言。我为听法入只桓中。有一比丘。以绳罥我项弃无人处。龙母大嗔。往诣佛所向佛言。诸比丘时佛为大众围绕说法。佛遥见龙来。佛以慈心三昧力灭彼毒心。龙母到佛所在一面立白佛言。是诸比丘弊恶不善。我子信心故。来入只桓听法。诸比丘以绳罥咽远着无人处。龙子在彼被绳罥者。是大不好。如被摈弃。尔时佛种种因缘为龙母说法示教利喜已默然。时龙母闻法已。礼佛右绕而去。龙母去不久。佛以是事集比丘僧。语诸比丘。从今不得罥蛇弃。犯者突吉罗。听以器盛覆头远着无人处。不得畜押蛇罥。犯者突吉罗

佛在舍卫国。时放马人有缘事。来至舍卫城。为僧作种种[麩-夫+并]。盛满器施僧。诸比丘言。佛未听我受怛钵那。是事白佛。佛言。是净食应受。佛在舍卫国。诸比丘无物浸衣。是事白佛。佛言。应畜槽杅盆浸衣。佛在舍卫国。诸比丘无物浣衣。是事白佛。佛言。应畜槽杅盆浣衣。佛在舍卫国。时跋提长者作大僧坊。青赤白黑种种庄严施僧。作是念。若佛听我以青赤白黑色庄严房施僧者善。是事白佛。佛言听。汝以青赤白黑色庄严房施僧

佛在舍卫国。忧伽长者。持牛头旃檀器直十万两金及阎浮敷具持到佛所白佛言。世尊。此牛头栴檀器直十万两金及阎浮敷具。愿佛受之。若佛得风病。以此栴檀器盛油涂身。佛默然受。时长者见佛默然受已。即持牛头栴檀器与佛已。头面作礼右绕而去。是长者去不久。佛以是事集比丘僧。语诸比丘。今忧伽长者。施牛头栴檀器直十万两金及阎浮敷具。从今若有如是病比丘。不求自与应受用。佛在舍卫国。有人施僧种种和香。诸比丘不受。不知何所用。是事白佛。佛言。应受。用涂房舍。时诸比丘涂舍外。多有众人来看塔寺。众人见此香涂舍外。谓是佛塔声闻塔。时多有人众象马牛车男女音声。妨诸比丘坐禅读经。诸比丘心不喜。是事白佛。佛言。从今若得和香。应涂舍内。涂床床髀床脚床板。床档衣橛衣架。涂地四壁。如是涂者。坊舍得香。施者得福

十诵律卷第三十八(杂诵卷第三)十诵律卷第三十九(第六诵之四)

        后秦北印度三藏弗若多罗译

    明杂法之四

佛在刍摩国。与五百大众共会。尔时世尊。与五百比丘说五阴法。所谓色受想行识。时诸比丘持钵着露地。天魔变作大牛身来向钵。有一比丘遥见牛来向钵。语比座比丘言。看此大牛来向我钵。不破我钵耶。佛语诸比丘。此非牛是魔所作。欲坏汝等心。佛言。从今房舍中。应作安钵处

佛在舍卫国。有比丘。从憍萨罗国。共估客游行。来向舍卫国。时估客载满车油。在道行险难处。有一估客。车破牛脚跛。是人语诸伴言。随力多少为我取油。莫弃于此。诸伴言。我等车各自满重。若取者共汝俱失。诸伴舍去。是一估客。独守此油心愁不乐。诸比丘从后来。诸比丘以二事故在后。一者恐尘坌。二者恶车声。守油人见比丘来。大欢喜作是念。此油非是我有。今当施僧。诸比丘来至。便语诸比丘。集在一处我施僧油。时诸比丘各分取油。盛钵中半钵中键镃中。盛已持去。道经市中前去。估客见诸比丘持油来。即生妒心语诸比丘言。汝此油何处买来。何处卖去。何处下驮。何处取利。诸比丘闻是语心不喜。是事白佛。佛言。从今不得道中檐油行。犯者突吉罗。佛自恣后游行教化。有比丘手执革屣行。佛见已知而故问。何以手执革屣行。答言。我脚指间破无物可涂。佛言。从今听畜盛苏油囊。受一升若半升。又更应畜覆囊物

佛从迦罗卫国。与诸比丘行。向舍卫国。诸天神随比丘行。作是念。若诸比丘或能说法。我等当听得大利益。诸比丘行时。作戏调言语。诸天神皆嗔。呵责比丘言。沙门释子道路游行。何不说法咒愿。诸天神得欢喜利益。诸比丘不知云何。是事白佛。佛言。从今诸比丘道路行时。应说法咒愿天神欢喜利益。若比丘在园中住树下住。或水边住或泉边住。或多人处住时。诸天神多有来集。皆作是念。诸比丘或能说法。我等听受得大利益。诸比丘在园中住。树下住水边住。泉边住多人处住时。说法咒愿。诸天神得欢喜利益。诸比丘不知云何。是事白佛。佛言。从今园中住。树下住水边住。泉边住多人处住时。当说法咒愿。天神欢喜利益

佛在舍卫国。比丘向暮有贼处行。见贼已是比丘畏贼故失衣。诸比丘不知云何。是事白佛。佛言。从今比丘不得向暮贼处行。若有事缘向暮行时。以衣分着两肩上。以绳系腰疾过贼道。佛在阿罗毗国。时阿罗毗无水。诸比丘是事白佛。佛言。应作井。佛在阿罗毗国。是国中有新成僧坊。比丘扫地无弃粪物。是事白佛。佛言。应畜粪箕。佛在舍卫国。有比丘患下数数起故大疲极。是事白佛。佛言。应床上穿孔床下安器。佛在舍卫国。长老优波离问佛。世尊。如弗迦罗沙王婆罗门。从佛乞三种礼敬。若沙门瞿昙。见我乘象时。若手持辔。若着革屣。若敛脚时。若却头上襆。见是已当知。我已礼敬沙门瞿昙。我在道行时。成竖脚。或却天冠。或却盖。见是已当知。我已礼敬世尊。若沙门瞿昙。见我在大众中。大声语时。喜笑时。或掉衣角时。见是已当知。我已礼敬世尊。比丘应作是三种礼不。佛言。不得。佛语优波离。称和南者。是口语。若曲身者。是名心净。优波离。若比丘礼时从座起。偏袒右肩脱革屣右膝着地。以两手接上座足。佛在舍卫国。诸比丘于只桓中处处剃发。时诸天神金刚神皆嗔诃责。此处不应作是。诸比丘不知云何。是事白佛。佛言。从今不应处处剃发。时多积发。佛言。应除弃。除弃时比丘吐逆。佛言。应一处作坑。佛在舍卫国。有人施僧华鬘。诸比丘不受。不知用华鬘作何物。是事白佛。佛言。听受。应以针钉着壁上。房舍得香施者得福。佛在舍卫国。时众僧发长。时剃发人大懅。时有一剃发人作比丘。是比丘作是念。若佛听我畜剃发刀剃僧发者善。是事白佛。佛言。听畜剃刀与僧剃发。佛在舍卫国。时僧指爪长。剃发人懅。时有剃发人作比丘。是比丘作是念。若佛听我畜截爪刀与僧截爪者善。是事白佛。佛言。听畜刀与僧截爪。佛在舍卫国。尔时僧鼻毛长。时剃发人懅。时有剃发人作比丘。是比丘作是念。若佛听我畜镊拔僧鼻中毛者善。是事白佛。佛言。听畜镊拔僧鼻中毛。佛在舍卫国。诸比丘露地敷绳床。结跏趺坐禅。天热睡时头动。有一毒蛇绳床前行。见比丘头动。蛇作是念。或欲恼我。即跳螫比丘额。是比丘故睡不觉。第二螫额亦复不觉。第三螫额比丘即死。诸比丘食后彼处经行。见是比丘死不知云何。是事白佛。佛以是事集比丘僧。集比丘僧已语诸比丘。从今绳床脚下施支令八指。佛在舍卫国。尔时长老毕陵伽婆蹉眼痛。入浴室洗时。汗入眼中便增痛。佛言。应以泥涂额上。时泥气入眼眼复增剧。是事白佛。佛言。应以香和泥涂额上。佛在舍卫国。长老优波离问佛。如佛说。汝目连。从今僧自说戒。我不入僧中。诸比丘不知谁应说戒。佛言。应上座说。若上座不利。次第二上座。如是次第能者说。时有说戒人处处忘。忘时默然住。佛言。应授。诸比丘便次第授。佛言。不应次第授。但授忘处。佛在舍卫国。长老优波离问佛。阿耆达婆罗门。施佛八种浆。周罗浆牟罗浆俱罗浆楼伽浆说盘提浆颇梨沙梨浆桃浆蒲萄浆等。今日受明日得饮不。佛言。无滓病者得饮。有滓不听饮。佛在王舍城。有大僧坊。是中有客比丘。初夜中夜后夜一一时。来见下座比丘。脱衣坐遣令起。下座答言。住上座不知时。诸比丘不知云何。是事白佛。佛言。从今若唱时。若打揵稚时。分取卧具然后敷私卧具然灯。星宿出时。禅镇着头上。自是已后。不应遣下座起。遣者突吉罗。佛在阿罗毗国。阿罗毗上座。初夜坐禅中夜还房。还房时道中畏师子虎狼熊罴。是事白佛。佛言。房舍四边应作墙。若作篱绕四边竖栅。佛在阿罗毗国。有新房舍。天旱久不雨。后卒雨大水渍墙壁烂坏。是事白佛。佛言。应作水窦绕。四边应作堑

佛在舍卫国。尔时比丘尼僧发长。时剃发人懅不得剃。有一比丘尼名提舍。先是剃发人。作是念。若佛听我畜剃刀与比丘尼剃发者善。是事白佛。佛言。听畜剃刀剃比丘尼发。佛在舍卫国。时比丘尼僧爪长。剃发人懅。有比丘尼名提舍。先是剃发人。作是念。若佛听我畜剪爪刀与诸比丘尼剪爪者善。是事白佛。佛言。听畜剪爪刀与比丘尼僧剪爪

佛在舍卫国。时诸比丘尼僧鼻毛长。剃发人懅。有一比丘尼名提舍。先是剃发人。作是念。若佛听我畜镊与比丘尼拔鼻中毛者善。是事白佛。佛言。听畜镊拔诸比丘尼鼻中毛

佛在王舍城。尔时六群比丘。以贝珠裈衣着。诸居士呵责言。诸沙门释子自言。善好有德。以贝珠裈衣着。如王如大臣。是中有比丘。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是因缘集比丘僧。知而故问六群比丘。实作是事不。答言。实作世尊。佛以种种因缘呵责六群比丘。云何名比丘。以贝珠裈衣着。种种因缘呵已。语诸比丘。从今不得贝珠裈衣着。著者突吉罗

佛在舍卫国。阿耆达婆罗门持衣施佛。佛语阿耆达。是衣分与僧。时分与僧。诸比丘不受。作是言。我三衣具足。何用是衣为。是婆罗门还到佛所。作是言。世尊。诸比丘不受我衣。时佛持刀与阿耆达教言。以刀割一张[疊*毛]作衣缘。一人与一段

佛在舍卫国。时长老跋提。着衲衣段段裂坏。佛见是跋提。知而故问跋提。汝衲衣何以破坏。答言。我粪扫衣故。世尊。是以破坏。佛语跋提。若粪扫衣。若居士衣。好割截治缝。令周正别施缘。佛自恣后人间游行教化。有一比丘手执革屣行。佛见是比丘知而故问。何以故手执革屣行。答言。革屣败断。尔时革师懅不得治。佛言。从今听畜锥刀畜皮。若能缝者随意缝治。佛在舍卫国。尔时比丘尼僧诵戒不利。瞿昙弥比丘尼往到佛所。头面作礼在一面立。已白佛言。比丘尼僧诵戒不利。愿世尊教令诵利。佛言。不得。何以故。若比丘尼能一闻我语能受持者将来。瞿昙弥还所住处。诸比丘尼问瞿昙弥。得教诵戒不。答言。不得。何以故不得。佛言。若比丘尼能一闻我语能受持者将来。时修目佉比丘尼。是婆罗门种出家。有大念力。白瞿昙弥言。我能受持。时瞿昙弥。将修目佉比丘尼。往到佛所。尔时世尊。欲二月游行教化。是时多有诸天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人与非人皆诣佛所。时二比丘尼不得闻戒。即还住处。诸比丘尼问言。得教诵戒不。答言。不得。何以故不得。答言。佛欲二月游行。多有天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人与非人。皆诣佛所。不得闻戒。尔时世尊。二月游行竟。还舍卫国。即时瞿昙弥。将修目佉比丘尼往到佛所。头面作礼在一面立。已白佛言。世尊。诸比丘尼诵戒不利。愿世尊教诸比丘尼。佛言。不得。何以故。若有比丘尼一闻我语能受持者将来。瞿昙弥言。愿世尊说。是修目佉比丘尼能受持。佛即为说。修目佉比丘尼即时受持。尔时世尊。更为瞿昙弥修目佉比丘尼。种种说法示教利喜。时佛为瞿昙弥修目佉比丘尼说法示教利喜已默然。即从座起。头面作礼右绕而去。时佛见瞿昙弥修目佉比丘尼右绕去。不久以是事集比丘僧。集僧已语诸比丘。从今比丘应诵比丘尼戒。莫令忘失。何以故。诸女人喜忘智慧散乱。我般泥洹后诸比丘尼。当从大僧问戒法。佛在舍卫国。尔时长老阿难。与大众围绕说法。时有上座比丘后来。起第二下座。第二下座复起第三。如是上座来时。次第起故。众乱妨听说法。诸长者作是念言。此中亦无有前食后食。何用次第坐为。妨听说法。尔时世尊见诸长者呵责比丘。佛以是事集比丘僧。语诸比丘。从今听法时上座来。不应遣下座起。起者突吉罗。若和上阿阇梨来。恭敬故自起。不得起他。若起他者突吉罗。佛言。从今三比丘中间隔三岁。得共大床坐。二人得共一绳床坐。不得三人。独坐床上应一人坐不应二人

佛在舍卫国。有一长者。请佛及僧明日食。佛默然受。知佛受已从座起。头面作礼右绕而去。还家竟夜办种种多美饮食。尔时六群比丘。与十七群比丘先共诤。时十七群次应守僧坊。六群比丘次与迎食。不时来还。如上树因缘说。佛在舍卫国。有二比丘。一名旃陀。二名苏陀。是二比丘共作知识。是二比丘试着他衣。如善诵中说。佛在舍卫国。有一放猪人失猪。有弊恶人。祇洹堑边杀猪。割肉各分持去。尔时诸比丘。中前着衣持钵入舍卫城乞食。见地猪肠。各相谓言。汝取是煮。我入城乞食。有煮者有乞食者。时失猪人入祇洹求猪。见烟起至比丘边问言。大德。此中何所作。答言。煮猪肠。是人言。我今失猪。汝等煮肠必杀我猪。答言。不杀。问言。何处得。答言。堑边地得。共相谓言。是比丘不肯直首。将诣官断。即将诣官。时断事人言。大德。实杀猪不。答言。不杀。我等祇洹堑边地得是肠。时断事人。多信佛法能正断事。作是言。比丘必不杀猪。诸比丘去。从今莫复取露地猪肠。是比丘向诸比丘说。诸比丘以是事向佛广说。佛言。从今露地猪肠不得取。取者突吉罗。及园中甘蔗多罗果亦如是。尔时有一人亲里死。是人即以白[疊*毛]缠死人弃。阿难从道行。见是死人上有[疊*毛]欲往取。时死人动肩言。莫取我[疊*毛]阿难即舍[疊*毛]而去。至祇洹中向诸比丘说。我道中行。见死人上有白[疊*毛]。时有比丘。名黑阿难。身体强壮。问死人在何处。阿难言。在某处。是比丘即到。死人上取白[疊*毛]。死人动肩语。长老黑阿难。莫取我白[疊*毛]。尔时黑阿难。唾是死人。作是言。饿鬼。汝从何处来贪着此衣。汝前世悭贪故。堕饿鬼中。黑阿难即担衣前去。鬼随后啼逐。黑阿难持此白[疊*毛]入祇洹中。尔时守祇洹门大力善神。不听此鬼入。即堕堑中。时黑阿难。以[疊*毛]示诸比丘言。我从彼死人边取是[疊*毛]来。诸比丘问言。死人在何处。答言。今堕祇洹堑中。诸比丘不知云何。是事白佛。佛言。从今死尸未坏不得取物。取者偷兰遮。尔时六群比丘。以针画死尸身令坏取衣。有人见呵责言。沙门释子自言。善好有德。云何如旃陀罗。以针破死尸取衣。是中有比丘。少欲知足行头陀。闻是事心不喜。是事白佛。佛言。从今不得以针破死尸。画者突吉罗。尔时佛语黑阿难。还送死尸着本处。还以白[疊*毛]覆上。当在饿鬼后行。莫在前行。当在左边。莫在右边。当近头莫近脚。莫为鬼所持

佛在舍卫国。有人施比丘尼僧木桶。诸比丘尼不受。不知何所用。是事白佛。佛言。应取用盛澡豆。佛在舍卫国。有比丘尼。名周那难提。面貌端正颜色清净。以粗系腰绳并襵两边着泥洹僧。令胯粗大而腰细。有估客见已语诸伴言。看是比丘尼胯。比丘尼闻已心不喜。是事白佛。佛语诸比丘。从今比丘尼。不得并襵两胯上着泥洹僧。犯者突吉罗。佛在舍卫国。有一比丘。不着衬身衣。倚新画壁立。彩画剥落。是事白佛。佛言。从今比丘不着衬身衣。倚画壁者突吉罗

佛在舍卫国。诸比丘于祇洹中处处然火。如似锻作处。诸金刚神皆嗔呵责言。云何名比丘。污此地。诸比丘不知云何。是事白佛。佛言。从今不得处处然火。犯者突吉罗。应一处然

佛在舍卫国。诸比丘于祇洹中处处洗浴。或用澡豆或用土。以湿热故生虫。诸金刚神皆嗔呵责言。云何名比丘。污此地。诸比丘不知云何。是事白佛。佛言。从今不得处处洗浴。应一处就水窦洗。佛在释迦国。释摩诃男。请佛及僧明日食。佛默然受。知佛受已。头面作礼右绕而去。到舍通夜办种种多美饮食。晨朝敷坐处已。往到佛所白言。时到佛自知时。佛与诸比丘僧入其舍。是会有肉。佛及僧次第坐竟。释摩诃男自手行饭下肉。尔时六群比丘畜狗。疾食竟拾满钵骨置前举眼高视。时释摩诃男。循行看僧食。谁得谁不得谁重得。见是钵中盛满物。语诸比丘。大德。此钵是恒沙诸佛幖帜。何以轻贱此钵。汝自贱钵。我亦不忧。但恐汝后持此不净钵受我食。尔时佛见释摩诃男呵责已。时佛呵责六群比丘。云何以钵盛不净物。从今不得以钵盛不净物。盛者突吉罗。佛在王舍城。尔时六群比丘。以脚扶钵受食。是事白佛。佛言。从今不得以脚扶钵受食。犯者突吉罗。尔时六群比丘。以革屣头扶钵受食。是事白佛。佛言。从今不得革屣头扶钵受食。犯者突吉罗。佛在王舍城。六群比丘与无钵人受具戒。尔时六群比丘。与十七群比丘喜共诤。时六群比丘次守僧坊。十七群次与迎食。时十七群比丘。从守僧坊比丘索钵来。问作何等。答言。与汝请食。彼比丘言。无钵。问言。汝无钵出家耶。答言。如是。时十七群比丘作是言。汝是大智德人。无钵便得受具戒。是比丘闻是语心不喜。是事白佛。佛言。从今无钵人。不得与出家受具戒。若与受者突吉罗

佛在王舍城。尔时跋难陀释子。度一贼主。出家作比丘。后入王舍城乞食。所可到家诸妇女。见是比丘来。便藏衣物作是言。此人诈作乞食。看我衣物必欲来取。是比丘闻是语心不喜。向诸比丘说。诸比丘以是事向佛广说。佛以是事集比丘僧已。知而故问跋难陀。汝实作是事不。答言。实作世尊。佛以种种因缘呵责跋难陀。云何名比丘。度贼主出家。种种因缘呵已语诸比丘。从今不得度贼主出家。若度者突吉罗。若因缘欲度者。度已应令离本处去五六由旬。若知善好有德。还可将来

佛在舍卫国。尔时饥饿乏食。有一比丘未满五腊应受依止。往到亲里家四五日住已。辞别欲去。亲里问言。何以故去。答言。我须依止故。亲里言。大德。今饥饿世或当饿死。何用依止。诸比丘不知云何。是事白佛。佛言。从今饥饿时。可得日日见和上处听住。可日日来。若日日不得来者。可至五日。若五日不得来者。布萨时应来。若布萨时不得来。乃至二由旬半。至自恣时。应来见和上

佛在舍卫国。憍萨罗国有边聚落。尔时波斯匿王税是边聚落。边聚落人即皆舍去。彼处有比丘住。不得衣食故。舍房舍去。王后有教不复税夺。诸人闻已即还本处。诸比丘未还。尔时诸外道。从憍萨罗国来向舍卫国。经入僧坊。见是僧坊清净庄严釜镬瓮器盆物坐具卧具满僧坊中。语诸居士。汝此僧坊空。听我等住者善。答言。随意。诸外道便住。有诸比丘。从憍萨罗国游行向舍卫国。到是僧坊。乃见是房中清净庄严釜镬瓮器盆物坐具卧具满是坊中。诸比丘共相谓言。此裸形外道无田宅民户。何由能办如是供养。必是先比丘住处。诸比丘语言。汝去。答言。何以去。语言。此先是我等住处。外道答言。大德。此不从汝等得。汝亦不安我在此。我从居士边得。居士遣者我等当去。诸比丘往语居士。此本是我等沙门住处。还使我等此中住者善。诸居士问比丘言。舍是僧坊去几岁。答言。十岁。诸居士问外道。汝等此中住来几岁。答言。十岁。诸居士作是言。是不可得。何以故。比丘舍去已经十岁。外道住来亦经十岁。不得遣去。诸比丘默然以是事白王。王言。谁言十岁舍去。十岁住中不得遣去。时王即遣人往以拳打外道齿折遣去。诸比丘不知云何。是事白佛。佛言。从今两寺相近者。应共作羯磨一处受施两处布萨。如是应作。作法者。一心和合僧一比丘唱言。大德僧听。是某处某处应一处受施两处布萨。若僧时到僧忍听。某处某处一处受施两处布萨。如是白。大德僧听。是某处某处一处受施两处布萨。谁诸长老忍。某处某处一处受施两处布萨者默然。不忍者说。僧作某处某处一处受施两处布萨竟。僧忍默然故。是事如是持。是二处中或一处空。是中所有衣被卧具诸物。应并着一处。后有僧来则还分取

佛在王舍城。尔时六群比丘。或头上戴物。或腰间带物。诸比丘以是事白佛。佛言。从今不得头上戴物腰间带物行。犯者突吉罗。佛在王舍城。尔时跋难陀释子。度王军将。尔时边国人叛。时王捡挍此将。有人答言。出家。何处出家。答言。沙门。何等沙门。答言。释子沙门。王嗔言。是比丘必当度我一切将。是中有比丘。少欲知足行头陀。闻是事心不喜。是事白佛。佛以是事集比丘僧。知而故问跋难陀。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘。辄度王所识将。佛言。从今不得度王所识将。犯者突吉罗

佛在舍卫国。跋难陀释子。共一估客儿诤。估客儿嗔以拳打跋难陀。时跋难陀往到断事所言。此估客儿打我。问何以诤。即答以上事。时断事人即唤估客儿。来已问言。打比丘不。答言。实打。时断事人便问法制。打比丘得何罪。答言。依制。随以何身分打。应断此分。即问估客儿言。以何身分打。答言。右手。时断事人截其右手。时城中人闻沙门释子言人截手。一人语二人。二人语三人。如是恶名流布满舍卫城。是中有比丘。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集比丘僧。知而故问跋难陀。汝实作是事不。答言。实作世尊。佛种种。因缘诃责跋难陀释子。云何名比丘。言人截手。佛言。从今不得言人截手。犯者偷兰遮。佛在舍卫国。有一外道。有信乐心欲得出家。往语诸比丘。我欲出家。出家法中有何难事。比丘答言。有四依法。一者依着粪扫衣得出家受具足戒。答言。我不能着死人弊衣。问言。除是更有何难。比丘言。常依乞食得出家受具足戒。答言。我法乞食。更有何难。答言。依树下住得出家受具足戒。答言。我法树下住。更有何难。答言。依尘弃药得出家受具足戒。答言。我不能服是药。闻是事不肯出家受具足戒。诸比丘不知云何。是事白佛。佛语诸比丘。不应先说四依。应先与受具足戒竟。乃说四依。佛在舍卫国。有比丘失衣钵。有一知识比丘。余处见是衣钵。即捉是衣言。此是某衣钵。今从汝手中得。彼言。我买得。问言。买时谁见。诸比丘不知云何。是事白佛。佛言。买得者非贼。若偷取者是贼。佛语诸比丘。此衣买用几许。实买得者。应还本直取

佛在舍卫国。尔时诸比丘二月游行。时六群比丘。有知识比丘。以衣寄六群比丘去。亦如先说。佛在王舍城。尔时有五比丘问佛。用何物染衣。佛言。应以根染茎染叶染花染果染新生犊屎染。佛在阿罗毗国。新作僧伽蓝。诸比丘无经行处。是事白佛。佛言。应作经行处。彼土热经行时汗流。佛言。应经行处种树(中二十法上竟)

中二十法下

佛初成阿耨多罗三藐三菩提时。估客施酥乳糜。佛食已腹内风发。时释提桓因。见佛患风。因阎浮树故。名阎浮提。去是树不远。有诃梨勒林。尔时释提桓因。取好诃梨勒来奉上佛。作是言。世尊。去阎浮树不远。有诃梨勒林。我取色好诃梨勒来。愿佛受食。可除风病得游步进止。佛默然受。尔时释提桓因见佛受已。头面作礼右绕而去。释去不久。佛即服此诃梨勒。风病即除。以子掷地即生诃梨勒。树长大生诃梨勒。熟黄色堕地遍满。佛见已知而故问阿难。诸比丘何故。不啖此诃梨勒。阿难言。世尊。制不得啖宿受食故。佛语阿难。先受诃梨勒已灭此今啖无罪。佛在舍卫国。诸比丘无盛衣物。佛言。应作箱。彼土热故生虫。佛言。应以青木香那毗罗草根着衣箱中。以香故虫不生。佛在舍卫国给孤独居士施众僧被。诸比丘不受。佛未听我受被。是事白佛。佛言。僧得受一人亦得受

佛在王舍城。尔时六群比丘。着留缕头衣。结缕头衣。交结缕头衣。刷缕头衣。不作净衣。是事白佛。佛言。不得着留缕头衣结缕头衣交结缕头衣刷缕头衣。著者突吉罗。若着不作净衣者。波逸提

佛在舍卫国。尔时诸比丘。不着僧及居士留缕头衣结缕头衣交结缕头衣刷缕头衣不作净衣。是事白佛。佛言。若僧及居士。有留缕头衣结缕头衣交结缕头衣刷缕头衣不作净衣得着佛在舍卫国。有阿罗汉般涅槃。诸比丘心念。如佛所说。身中有八万户虫。若烧身者。当杀是虫。诸比丘不知云何。是事白佛。佛言。人死时诸虫亦死。诸比丘心念。佛听我烧阿罗汉身者善。是事白佛。佛言。听烧阿罗汉身。诸比丘心念。佛听我等与阿罗汉起塔者善。是事白佛。佛言。听起阿罗汉塔。诸比丘心念。佛听我等供养阿罗汉塔者善。是事白佛。佛言。听供养阿罗汉塔

佛在舍卫国。长老迦旃延。有一估客弟子。从海中还。以贝作饱身物施迦旃延。迦旃延不受佛未听我受贝饱身物是事白佛。佛言。得受。佛在舍卫国。有一病比丘。语看病人。汝能好看我爱念我。我若命终。所有物尽当与汝。语已便终。打揵稚集僧。僧语看病人。死比丘所有物尽持来。现前僧应分。看病人言。非僧物。何以故。我看病人。病人语我言。汝能好看我爱念我。我若命终。所有诸物尽当与汝。是事故非僧物。诸比丘不知云何。是事白佛。佛言。无如是死。当与法。若比丘命终物。现前僧应分。佛在舍卫国。有比丘。净施一比丘已。物主命终。即打揵稚集僧。僧遣人取死比丘衣物来时。受净施比丘答言。非僧物。何以故。死比丘先净施我。诸比丘不知云何。是事白佛。佛言。此为净故施。彼命终已。现前僧应分。佛在舍卫国。有比丘。净施一比丘。受施者死。时打揵稚集僧。彼比丘。自持衣来与僧。作是言。此是僧物。僧问。何故。答言。我先净施死比丘。诸比丘不知云何。是事白佛。佛言。若彼受净施人死。更应净施余人。佛在舍卫国。有比丘。净施一比丘。受施者反戒。诸比丘不知云何。是事白佛。佛言。若反戒。更净施余人。佛在舍卫国。有比丘。净施共行弟子。弟子有不如法事。师责语言。莫我边住。是弟子往到六群比丘边住。弟子先欲悔过。以近六群比丘故。无有悔心。师往语弟子言。汝何不悔过于我。答言。不能。师言。我先净施汝衣。弟子言。今当与佛。诸比丘不知云何。是事白佛。佛言。若弟子被师责不听执作。应更净施余人

佛在毗舍离国。尔时地湿。诸比丘作衣帐住。诸比丘作是念。此中将不犯过十夜长衣耶。诸比丘不知云何。是事白佛。佛言。此衣作舍用不犯

佛在阿罗毗国。时井水有虫。诸比丘不知云何。是事白佛。佛言。应漉。漉时二三人共捉。捉时不正。佛言。应作棬漉水已泻虫着井中。井中虫转多。佛言。一器盛水。漉水已以虫泻中。泻中已持泻流水中。长老优波离问佛。颇有比丘。在僧中受功德衣时。有不得者耶。答言有。若比丘余处安居。此处受功德衣。是名不得。长老优波离问佛。颇有比丘。不受功德衣。得名受耶。答言有。若比丘是处安居自恣已。出界行还来入界。闻僧今日受功德衣。闻已随喜者。得名为受。长老优波离问佛。颇有比丘。舍功德衣时。有不舍者耶。佛言有。若比丘余处受功德衣。此处僧舍衣。彼比丘虽在中。不名为舍。长老优波离问佛。颇有比丘。僧舍功德衣。彼比丘不在。得名舍耶。答言有。若比丘受功德衣出界行。闻舍功德衣随喜。是名得舍

佛在舍卫国。憍萨罗国住处。有人施僧物。打犍稚集僧。和合分物已起。尔时六群比丘。从界外来语诸比丘。此众僧所有物。我当共分。诸比丘还更共分。诸比丘不知云何。是事白佛。佛言。若打犍稚僧和合分物已起。界外有比丘来。欲与者与。不得强分。佛在舍卫国。憍萨罗国有人施僧衣。尔时有六群比丘。到僧坊中两两共语。看诸比丘欲分衣时。在屏处住。彼分物已。我等当出到边使更共分。尔时六群比丘。看彼比丘已在屏处住。尔时打犍稚集僧。诸比丘共相谓言。唤是六群比丘来。求觅所在处不得。有人言。是比丘多缘事。必当出行。即和合分物已起。六群比丘便界内来言。此应共我等分时六群比丘作是言。若不信我在界内者。此中有比丘。见诸比丘更与共分。诸比丘不知云何。是事白佛。佛言。若打犍稚僧分物已起。若有界内比丘来。欲与者与。不得强分。佛在舍卫国。尔时比丘。贵价火浣衣。及深摩根衣。敷床上坐。起时欲破坏。诸比丘不知云何。是事白佛。佛言。应敷者敷。应著者着。随所宜作

佛在舍卫国。诸比丘为布萨故打犍稚。说戒者言。若不来嘱授者说。有一比丘作是言。某比丘清净与欲。问言。彼比丘那去。答言。出界去。诸比丘不知云何。是事白佛。佛言。从今与欲者不得出界。犯者突吉罗

佛在舍卫国。诸比丘为布萨故打犍稚。说戒者言。与欲者说。有一比丘唱言。某甲比丘清净与欲。问言。是比丘在何处。答言。在界外。诸比丘不知云何。是事白佛。佛言。从今不得受界外人欲。犯者突吉罗

佛在舍卫国。为布萨故。打犍稚集僧。说戒者言。谁受教诫比丘尼。答言。迦留陀夷。问言。在何处。答言。出界行诸比丘不知云何。是事白佛。佛言。从今受教诫比丘尼者。不得出界行。犯者突吉罗

佛在王舍城。尔时六群比丘。展转与清净与欲与自恣与除罪。诸比丘不知云何。是事白佛。佛言。从今不得展转与清净与欲与自恣与除罪。犯者突吉罗。佛在舍卫国。憍萨罗国去僧坊不远。有阿练若处。布萨时天雨。坊中僧心念。阿练若比丘当来。阿练若处僧复作是念。僧坊中比丘当来。尔时两不相就。不得布萨。诸比丘不知云何。是事白佛。佛言。应羯磨一处布萨。应如是作。作法者。一心和合僧一比丘僧中唱言。大德僧听。此某堂舍。应作布萨处。若僧时到僧忍听。某堂舍作布萨处。如是白。白二羯磨。僧听某堂舍作布萨处竟。僧忍默然故。是事如是持

佛在舍卫国。尔时末利夫人。为听法故。到祇洹中问诸比丘言此处有几僧。答言。不知。诸比丘不知云何。是事白佛。佛言。应数。尔时诸比丘唤名字数。唤名字数时参错失数。佛言。应行筹。夫人又问。有几沙弥。答言。不知。诸比丘不知云何。是事白佛。佛言。沙弥亦应行筹

佛在舍卫国。僧布萨时。末利夫人施僧钱。诸比丘不受。佛未听受布萨钱。诸比丘不知云何。是事白佛。佛言。听受。时诸比丘未到布萨。二日三日便说戒布萨。比丘为布萨故来。不得布萨施。诸比丘不知云何。是事白佛。佛言。不得先前二日三日说戒。犯者突吉罗。佛言。布萨时应布萨。为布萨比丘来。令得布施故。尔时诸沙弥索分。答言。汝不布萨不作羯磨不说戒。不入布萨故不与分。诸比丘不知云何。是事白佛。佛言。沙弥受筹故应与分。佛虽听与。不知与几许。佛言。若沙弥在行次。檀越自手与者应等与。若但施僧。大比丘得三分。沙弥得一分。佛在王舍城。尔时六群比丘。共白衣一床坐。诸比丘不知云何。是事白佛。佛言。从今不得与白衣共一床坐。犯者突吉罗

尔时六群比丘。共沙弥一床坐。诸比丘不知云何。是事白佛。佛言。从今不得与沙弥共床坐。犯者突吉罗

佛在舍卫国。尔时比丘。共沙弥二夜宿。第三夜遣出。出时沙弥先以油涂脚。蹈地敷上油污地敷。诸比丘不知云何。是事白佛。佛言。从今油涂脚不得地敷上行。犯者突吉罗

佛在舍卫城。尔时六群比丘。互相诱弟子。时上座呵责言。诸比丘不知云何得畜弟子。教化如法。如是六群比丘诱我弟子。诸比丘不知云何。是事白佛。佛言。从今不得诱他弟子。犯者突吉罗。尔时六群比丘。各咒誓言。我若诱汝弟子者。作佛咒法咒僧咒。诸比丘不知云何。是事白佛。佛言。从今比丘不得自咒不得咒他。若自咒若咒他者突吉罗。尔时六群比丘以物作誓。我若诱汝弟子者。便没是物。诸比丘不知云何。是事白佛。佛言。从今不得以物自誓誓他。若以物自誓誓他者突吉罗。佛在王舍城。尔时六群比丘失衣钵。语诸比丘言。我失衣钵。当共作投窜。时诸比丘各各思惟。不知云何。是事白佛。佛言。从今比丘不得自投窜。亦不得令他投窜。若自作令他作者突吉罗。何以故。咒与投窜一种故。佛在王舍城。尔时六群比丘。贷白衣物。语取物者言。至时不得者当倍责汝。取物者怖畏。诸比丘不知云何。是事白佛。佛言。从今不得要他索倍。犯者突吉罗。佛在舍卫国。尔时虎狼杀鹿选择好肉啖。有比丘过中从此道行。见是死鹿。各相谓言。当持归明日食。即持残鹿归。时虎饥起求觅残鹿。绕祇洹吼声。佛见虎吼。佛知而故问阿难。是虎何故吼。答言。世尊。比丘持虎残肉来故。佛言。从今不得取虎残。犯者突吉罗。何以故。虎不断望故。若取师子残者无犯。何以故。师子断望故。佛在舍卫国。有比丘。先不从比丘求听出罪。便出他罪。是比丘闻是事心不喜是事白佛。佛言。从今他不听。不得说他罪。不得令他忆罪。不得遮他说戒自恣。不得遮他教诫比丘尼。遮者突吉罗

佛在舍卫国。尔时有下座比丘。不恭敬唤上座。上座闻已心不喜。诸比丘不知云何。是事白佛。佛言。从今不得不恭敬唤上座。若不恭敬唤上座者突吉罗。尔时诸比丘不知云何唤上座。是事白佛。佛言。从今下座比丘唤上座言长老。尔时但唤长老不便。佛言。从今唤长老某甲。如唤长老舍利弗。长老目犍连。长老阿难。长老难提。长老金毗罗。佛在舍卫国。有那罗比丘。有施罗比丘尼。二人共戏笑言语。恼乱诸比丘。是事白佛。佛言。是那罗比丘施罗比丘尼所作不善。所啖食如偷盗。佛以是事集比丘僧。语诸比丘。应与是二人作不清净羯磨。一心和合僧一比丘唱言。大德僧听。是那罗比丘施罗比丘尼。共戏笑言语恼乱诸比丘。若僧时到僧忍听。是那罗比丘施罗比丘尼共戏笑言语恼乱诸比丘。是所啖食如偷盗。如是白。白二羯磨。僧与那罗比丘施罗比丘尼作不清净羯磨竟。僧忍默然故。是事如是持。僧与二人作不清净羯磨竟。是二人心生悔。自见过罪四布忏悔。作是言。我先恼乱众僧。今生清净心。乞舍不清净羯磨。诸比丘不知云何。是事白佛。佛言。是那罗比丘施罗比丘尼悔过生清净心。应与舍不清净羯磨应如是作。一心和合僧。是那罗比丘施罗比丘尼从座起。偏袒右肩脱革屣右膝着地合掌作是言。大德僧听。我那罗比丘施罗比丘尼。共戏笑言语恼乱僧故。僧与我等作不清净羯磨。所啖食如偷盗。我等今悔过生清净心。乞舍不清净羯磨。我那罗比丘施罗比丘尼。所受食莫如偷盗。怜愍故。第二第三亦如是乞。僧中一比丘唱言。大德僧听。是那罗比丘施罗比丘尼。共戏笑言语恼乱僧故。与不清净羯磨。所啖食如偷盗。是二人今自悔过生清净心。从僧乞舍不清净羯磨。所啖食莫如偷盗。若僧时到僧忍听。僧与是那罗比丘施罗比丘尼舍不清净羯磨。所啖食莫如偷盗。如是白。白四羯磨。僧与那罗比丘施罗比丘尼舍不清净羯磨竟。僧忍默然故。是事如是持。尔时比丘问佛。用何等皮作革屣。佛言。除五种皮。师子皮虎皮豹皮獭皮猫皮。更除五种皮。象皮马皮狗皮野干皮黑鹿皮。余者听作。佛在舍卫国。尔时有人。施僧鳣鱼皮革屣。诸比丘不受。佛未听我着鳣鱼皮革屣。是事白佛。佛言。应受鳣鱼皮革屣。为粗故。以牛皮覆上。佛在舍卫国。尔时有人。施僧错鱼皮革屣。诸比丘不受。佛未听我受错鱼皮革屣。是事白佛。佛言。听受错鱼皮革屣。以眼痛故。以牛皮覆上

佛在舍卫国。有人施僧筋。诸比丘不受。不知何所用。是事白佛。佛言。听受用。作闭户纽开户绳。佛在舍卫国。有人施僧熊皮。诸比丘不受。不知何所用。是事白佛。佛言。应受。应着僧房户内用拭脚入房。佛自恣后游行教化有一比丘。手捉革屣行。佛见已知而故问。何以故手捉革屣行。白佛言。世尊。革屣坏我脚故。佛言。应以软皮遮。遮已行时拨地。佛言。应后施网。佛在阿罗毗国。有营理比丘。日日为材木为竹入山。入山时道中。畏师子虎狼熊罴多罗叉。畏不依道行。行时棘刺皂荚刺刺脚。是比丘以龙须草作履。道中多受泥水坏脚。佛言。应作鞋通泥水出。佛在舍卫国只梨园。有佛亲里。闻同姓中有出家得佛。即白父母。我欲往见佛。父母作是念。若往佛所或当出家。尔时父母为说诸难言。道中有师子怖虎狼熊罴等怖。又白父母。我必当去。父母知必欲去。作是言。我今与汝别。若出家者当来至此。答言尔。即往佛所。到已头面作礼在一面立。佛与出家受戒。后辞白佛言。世尊。我欲还见父母亲里。佛言。去莫久住。即便还家。诸亲里多人。人留一日如是经久。时新雨雪堕。尔时是比丘。与亲里别欲还佛所。答言。新雨雪云。何得去。汝能着白衣靴不。答言。佛未听我着白衣靴。即时还道中手冷脚疼眼痛。来到佛所。头面作礼在一面立。诸佛常法。客比丘来。以如是语劳问。忍不足不。安乐住不。乞食不乏。道路不疲耶。佛即以是语劳问是比丘。忍不。足不安乐住不。乞食不乏。道路不疲耶。比丘言。忍足安乐住乞食不乏道路不疲。即以如是事向佛广说。佛知而故问。彼土何如。答言。多雪。佛言。从今多雪国土。听着白衣靴。为遮雪故。佛在舍卫国。尔时给孤独居士。以赤朱涂五百绳床脚。施祇洹僧。诸比丘不受言。佛未听我朱涂绳床脚。是事白佛。佛言。是床清净应受。佛在王舍城。尔时跋提长者。种种庄严僧坊施僧。诸比丘不受。佛未听我受种种庄严僧坊。是事白佛。佛言。是坊清净应受

佛在舍卫国。郁伽苏跋那长者。往到佛所头面作礼在一面坐已。佛以种种说法。示教利喜已默然。尔时郁伽长者。见佛种种说法默然已白佛言。世尊。请佛及僧明日食。佛默然受。知佛默然受已。还家竟夜办种种多美饮食。又庄严五百金床银床琉璃床颇梨床。作是念。不受一当受一。又办五百金槃银槃琉璃槃颇梨槃。作是念。不受一当受一。又办五百金钵银钵琉璃钵颇梨钵。作是念。不受一当受一。明朝往白佛时到。佛着衣持钵。与比丘僧俱入其舍。以五百金床奉佛。时佛不受。又奉银床琉璃床颇梨床。佛亦不受。尔时长者除是宝床。更敷余床以褥重覆上。佛即就坐。尔时长者以五百金槃奉佛。佛亦不受。又奉银槃琉璃槃颇梨槃施佛。佛亦不受。尔时长者以五百金钵奉佛。佛亦不受。又奉银钵琉璃钵颇梨钵。佛亦不受。佛言。我先听二种钵。铁钵瓦钵。八种钵不应畜。长者即行水下食。种种丰美。佛及僧满足收钵已。持小床佛前坐欲听法。佛为种种说法。示教利喜竟。从座起去

十诵律卷第三十九十诵律卷第四十(第六诵之五)

        后秦北印度三藏弗若多罗译

    明杂法之五

佛在舍卫国有一婆罗门生女。面貌端正颜色清净。颜色清净故。名曰妙光。此女生时。相师占曰。是女后当与五百男子共通。诸人闻已。女年十二无有求者。时婆罗门有邻比估客。常入海采宝。是估客于楼上遥见是女。即生欲心问余人言。是谁女。答言。是某甲婆罗门女。有娶者耶。答曰无也。有求者耶。答曰未也。又问曰。何故无人求耶。答曰。此女有一过。有何过。答曰。此女生时有相师占曰。是女后当与五百男子共通。诸人闻已。女年十二无有求者。时估客作是念。除沙门释子。无能强入我舍者。沙门释子亦无是过。我当娶之。即往求娶女。到舍未久诸估客结伴欲入海中。彼国入海法。要得曾入海者。若自不肯去。要强将去。时估客唤守门者作是言。我欲入海。莫听男子强入我舍。除沙门释子。沙门释子亦无此过。答言尔。作是语已便去。后沙门婆罗门于其舍乞食。是女见已语言。共我行欲。诸比丘不知云何。是事白佛。佛言。从今日如是舍。未曾往者不应往。若往者不应坐。何以故。此舍必有非梵行过故。此女后得病。于夜命终。其家人以庄严具合弃死人处。时有五百贼。于此处行。见是死女。即生欲心便就行欲。行欲已五百人去。是女以先语沙门婆罗门共我行欲因缘故堕恶道。在彼国北方。生作淫龙。名毗达多

佛在王舍城。有比丘病痈。往语耆婆治我此病。耆婆答言。膒令熟。比丘言。佛未听膒熟。诸比丘是事白佛。佛言。听膒令熟。耆婆又言。应破。答言。佛未听破痈。是事白佛。佛言。听破。耆婆又言。应捺去脓。比丘言。佛未听捺。是事白佛。佛言。听捺。耆婆又言。应着食脓物。比丘言。佛未听着。是事白佛。佛言。听着种种治脓药

佛在王舍城。尔时王舍城。一月大祠耆梨龙。尔时诸人。于王仓库中出物。办具种种饮食。与一切人。时处处多有人来集。或有人胸凹。或有人胸凸。或有人脚似象脚。或有如马脚。又似象耳马耳。或耳如箕。如是似象马人众多男女大小。皆满其中甚大欢乐。时客观中。多有四方诸估客来。王作祠时。不取税故。亦无禁限度者。不税行不须送。此祠有少日在。诸估客各作是念。此王不一时税我等耶。祠未竟即去。于后祠竟。诸人各还本处。时凹胸凸胸象脚马脚象耳马耳如箕耳者悉住。后日往诸多人处天祠处沙门婆罗门处游行。尔时六群比丘弊恶故。好沙弥弟子不在边住。以二事故。一者犯戒。二者畏令我等犯戒。时六群比丘见如是人已。作是念。我等若度余人。必舍我去。今当度此无教去者。六群比丘往语彼人。汝等何不出家。答言。我等如是谁当度我。有能度者我便出家。时六群比丘言。汝能为我守舍。与我迎食。能担钵者。我当度汝。六群比丘即度此人。若有请佛及僧处。先遣持钵去。以二事故。一者行迟。二者羞共行。诸外道见已呵诸檀越言。汝等所供养者。是汝等塔者。汝等第一者。汝等先食者。汝等在前行者。汝等所供养者。正如是耶。诸优婆塞闻已心不喜。以是事向佛广说。佛以是事集比丘僧已。知而故问六群比丘。汝实作是事不。答言。实作世尊。佛以种种因缘呵责六群比丘。云何名比丘。度凹胸人凸胸人象脚马脚象耳马耳箕耳人。种种呵已语诸比丘。从今不得度凹胸凸胸人象脚马脚象耳马耳如箕耳人。若度者突吉罗

佛在舍卫国。长老优婆离有二沙弥。一名陀萨。二名波罗。当受戒时。沙弥陀萨语波罗言。汝先受戒。我供汝所须。波罗语陀萨言。汝先受戒。我供汝所须。时长老优波离问佛。得二沙弥一时羯磨受具戒不。佛言。得应如是作。一心和合僧。是中一比丘唱言。大德僧听。是陀萨波罗。优波离与受具戒。从僧乞受具戒。长老优波离作和上。若僧时到僧忍听。僧与陀萨波罗受具戒。长老优波离作和上。如是白。白四羯磨。僧已与陀萨波罗受具戒。长老优波离作和上竟。僧忍默然故。是事如是持

佛在舍卫国。长老优波离问佛。世尊。我等不知佛在何处说修多罗毗尼阿毗昙。我等不知云何。佛言。在六大城。瞻波国。舍卫国。毗舍离国。王舍城波罗奈。迦维罗卫城。何以故。我多在彼住。种种变化皆在是处

佛在舍卫国。尔时长老耶舍。与五百比丘。从憍萨罗。来至舍卫国。欲安居。时旧比丘客比丘共相问讯。代客比丘担衣钵。担衣钵时。有大高声多人声。佛闻是大声多人声。知而故问阿难。此僧坊内。何故有是大声多人声。白佛言。世尊。是长老耶舍。与五百比丘。从憍萨罗国。来至舍卫国。欲安居。时旧比丘客比丘共相问讯。代客比丘担衣钵。是故有是大声多人声。佛语阿难。汝往语耶舍等五百人言汝等作大声故驱。汝等不得舍卫国安居。阿难受教。往语耶舍言。汝等作大声故世尊驱。汝等不得舍卫国安居。尔时耶舍等五百人。即往婆求摩河边聚落中安居。尔时诸比丘作是念。佛遣我等。以大声故。我等默然者善是事白佛。佛言。听默然。时诸比丘睡睡已共相谓言。佛听我等独房住者善。是事白佛。佛言。听独房中住。独房中住亦睡。复相谓言。佛听我等众住者善。是事白佛。佛言。听众住。众住亦睡。复相谓言。佛听我等水洗头者善。是事白佛。佛言。听水洗头。时诸比丘以手取水洗时不便。佛言。应作器。器大水浇衣湿。即便小作。小作不得水。是事白佛。佛言。不得大不得小。受一钵罗。若一钵罗半。时作器无柄。浇时堕他头上。痛恼垂死。是事白佛。佛言。应施柄。有比丘坐睡。余比丘以水浇。便言。我不睡何以水浇我。是事白佛。佛言。睡者不可信浇者可信。有五法以水浇他。一者怜愍。二者不恼他。三者睡。四者头倚壁。五者舒脚。诸比丘故睡。共相谓言。听手敲者善。是事白佛。佛言。听以手敲。有比丘坐睡。余比丘以手敲。便言我不睡。何以故推我。诸比丘不知云何。是事白佛。佛言。睡者不可信敲者可信。有五法以手敲他。一者怜愍。二者不恼他。三者睡。四者头倚壁。五者舒脚。诸比丘故睡。共相谓言。佛听我等以鞠掷者善。是事白佛。佛言。听以鞠掷。掷已后日还归。后日诸比丘不知与谁。佛言。归本掷主。若掷主不在。与然灯者。然灯者不在。与执作者。执作者不在。应着堂中央地覆上。着堂中央地覆上已还坐。坐已见余比丘睡者。取是鞠掷。彼言不睡。何以掷我。佛言。睡者不可信掷者可信。有五法以鞠掷他。一者怜愍。二者不恼他。三者睡。四者头倚壁。五者舒脚。诸比丘故睡。共相谓言。佛听我用禅杖者善。是事白佛。佛言。听用禅杖。时禅杖头尖。筑时坏安陀会。共相谓言。佛听我等以物裹杖头者善。是事白佛。佛言。应以物裹杖头。时禅杖着地作声。佛言。下头亦应裹。诸比丘不知云何取禅杖。是事白佛。佛言。取禅杖时应生敬心。诸比丘不知云何生敬心。是事白佛。佛言。应以两手捉杖戴顶上。有比丘坐睡。一比丘捉禅杖筑睡者。睡者惊起立看。诸比丘默然无声。即时迷闷躄地。诸比丘不知云何。是事白佛。佛言。若比丘坐睡应起。看余睡者。应以禅杖筑。筑已还坐。若无睡者。应出户彷佯来入更看。若见睡者。以禅杖筑。筑已还坐。若无睡者。还以杖着本处已坐。有比丘坐睡。余比丘以禅杖筑。便言不睡。何以筑我。是事白佛。佛言。睡者不可信筑者可信。有五法以禅杖筑他。一者怜愍。二者不恼他。三者睡。四者头倚壁。五者舒脚。诸比丘故睡。共相谓言。佛听我着禅镇者善。是事白佛。佛言。听着禅镇。时禅镇无孔。着时堕地。共相谓言。佛听我作孔者善。是事白佛。佛言。听作孔。作孔已以绳贯孔中。绳头施纽串。耳上去额前四指着禅镇。诸比丘以绳络头后着。是事白佛。佛言。从今不得以绳络头后着禅镇。络者突吉罗。时禅镇堕故睡。是事白佛。佛言。禅镇一堕听一舒脚。二堕二舒脚。三堕者应起行。行时来往故相乱。是事白佛。佛言。应如鹅法次第行。行时下坐触上座肩。是事白佛。佛言。下座行时不得触上座肩。下座应在上座后行。不得近上座。诸比丘故睡。共相谓言。佛与我等作时节者善。是事白佛。佛言。听作时节。诸比丘共相谓言。佛听作两时者善。是事白佛。佛言。听作两时。复相谓言。夜作时节者善。是事白佛。佛言。听夜作时节。复相谓言。听我昼日作时节者善。是事白佛。佛言。听昼日作时节。复相谓言。佛听我等七日坐者善。是事白佛。佛言。听七日坐。复相谓言。佛听我等常坐禅者善。是事白佛。佛言。听常坐禅

尔时听作时节两时夜时昼时七日时常坐时。不嚼杨枝口中气臭。共相谓言。佛听我等嚼杨枝者善。是事白佛。佛言。听嚼杨枝。有五利益。一者口不苦。二者口不臭。三者除风。四者除热病。五者除痰荫。复有五利益。一者除风。二者除热。三者口滋味。四者能食。五者眼明。尔时便作时节两时夜时昼时七日时常坐禅时。不洗浴垢臭。诸比丘共相谓言。佛听洗者善。是事白佛。佛言。听洗。尔时渠水流驶入者为水所漂。是事白佛。佛言。水中应施柱作障碍捉洗。尔时听作时节两时夜时昼时七日时常坐禅时。诸比丘得无量知见。证得须陀洹斯陀含阿那含阿罗汉。佛知诸比丘已得证。以是因缘集僧。语诸比丘。彼处有光明。诸佛在世法。岁二时大会。春末月夏末月。春末月者。诸方国土处处诸比丘来。作是念。佛所说法。我等当安居时修习得安乐住。是名初大会。夏末月者。诸比丘夏三月安居竟作衣毕。持衣钵诣佛所。作是念。我等久不见佛久不见世尊。是第二大会。是时婆求摩河边诸比丘。夏安居三月过作衣竟。持衣钵来到佛所。佛遥见婆求摩河比丘来已。佛入初禅。婆求摩河比丘亦入初禅。佛从初禅起。入第二禅第三禅第四禅空无想无作。婆求摩比丘亦从初禅起。入第二禅第三禅第四禅空无想无作。尔时长老阿难。遥见婆求摩比丘来。即合掌白佛言。世尊。愿世尊共婆求摩比丘语。令婆求摩比丘长夜安乐。佛语阿难。莫作是语。阿难如我所知。汝能知耶。阿难。我遥见婆求摩比丘来时。我入初禅。婆求摩比丘亦入初禅。我起初禅。入第二第三第四禅空无想无作。婆求摩比丘亦起初禅。入第二第三第四禅空无想无作

佛在舍卫国。尔时黑山土地有比丘。名马宿满宿。在此处住污他家。皆见皆闻皆知。是比丘共女人一床坐。共一盘食。共器饮酒。中后食。共食宿。啖残宿食。不受而食。不受残食法食。弹琴鼓簧。捻唇作音乐声。齰齿作伎乐。弹铜杅。弹多罗树叶。作余种种伎乐歌舞。着鬘璎珞。以香涂身。着香熏衣。以水相洒。自手采华亦使人采。自贯华鬘亦使人贯。头上着华亦使人着。自着耳环亦使人着。自将他妇女去。若使人将去。若令象斗车斗步斗羊斗水牛斗狗斗鸡斗男女斗大男斗。大女斗。小男斗。小女斗。亦自共斗。拍手蹈节。四向驰走变异服。饰驰行跳踯。水中浮没。斫截树木。振臂拍髀啼哭大唤。作啸谬语诸异国语。踯绝返行如鱼婉转。掷物空中还自接取。与女人共船上载。令作伎乐。或骑象马乘车辇舆与多人众吹呗。导道入园林中。作如是等种种恶不净事。尔时长老阿难。从伽尸国来向舍卫城。到黑山邑宿。晨朝时到着衣持钵入城乞食。阿难持空钵入城。还空钵出城。出城不远多人众集。阿难到彼问众人言。汝此土地。丰乐多诸人众。今我乞食。持空钵入。还持空钵出。无有沙门释子在此多少作恶事耶。尔时有贤者。名忧楼伽。在彼众中。从坐起偏袒右肩合掌。语阿难言。大德知不。此有马宿满宿比丘。作诸恶行。如上广说。大德阿难。是二比丘作此诸恶。悉污诸家。皆见闻知。时忧楼伽贤者。即请阿难将入自舍。敷座令坐。自手与水。多美饮食自恣饱满。饱满已洗手摄钵。贤者取小床座。欲听法故。阿难以种种因缘说法示教利喜已。从坐起去向自房舍。随所受卧具。还付旧比丘。持衣钵游行向舍卫国。渐到佛所。头面礼足在一面立。诸佛常法。有客比丘来。以如是语劳问。忍不足不。安乐住不。乞食不乏。道路不疲耶。佛以如是语劳问。阿难。忍不足不。安乐住不。乞食不难。道路不疲耶。阿难答言。世尊。忍足安乐住。乞食不乏道路不疲。以是因缘向佛广说。佛以是事集比丘僧。种种因缘呵责马宿满宿。云何名比丘。共女人一床坐乃至谬语。种种因缘呵已。语诸比丘。从今不得共女人一床坐。共坐者突吉罗。不得与女人共食。共食者突吉罗。不共女人一器饮酒。饮者突吉罗。不得非时食。食者波逸提。不得啖残宿食。食者波逸提。不得恶捉食。食者突吉罗。不得不受食。食者波逸提。不受残食法食者波逸提。内宿食啖者突吉罗。不得弹琴鼓簧。不得齰齿作节。不得吹物作节。不得弹铜杅作节。不得击多罗树叶作节。不得歌。不得拍节。不得舞。犯者皆突吉罗。不得着华璎珞。不得着香璎珞。不得香油涂身。不得着香熏衣。犯者皆突吉罗。不得以水相洒。犯者随得罪。不得自采华及使人采。若自取若教他者波逸提。不得贯华鬘及使人贯华璎。若自贯使人贯者突吉罗。不得自作华鬘。不得教他作。若自作教他作者突吉罗。不得自贯杂华。不得教他贯。若自贯使他人贯者突吉罗。不得自作使到童男童女家。不得教他作使到童男童女家。若自到教他到者随得突吉罗。不得斗象斗马斗车。不得合人戏。不得斗羊。不得斗水牛。不得斗鸡。不得斗狗。不得斗女人。不得斗男子。不得斗小男小女。不得自斗。不得教他斗。犯者突吉罗。不得振臂。不得蹈节。不得空中掷物。不得庄面。不得走。不得跳。犯者皆突吉罗。不得斩伐草木。犯者波逸提。不得作伥行。犯者突吉罗。不得哭。不得大唤。不得啸。犯者皆突吉罗。不得倒立。不得掷绝。不得如鱼婉转。犯者皆突吉罗。不得弄铃。犯者随得罪。不得共女人船上歌作乐。犯者皆突吉罗。不得乘象马。车不得乘人。不得作卤薄入园观中。犯者皆突吉罗。不得祠火。不得谬语。犯者随得罪

佛在舍卫国。迦罗梨比丘。往看斗象斗马斗车相扑斗羊斗水牛斗鸡斗狗斗男女。斗小男小女。自往观看。诸比丘以是事白佛。佛言。从今不得往看斗象马乃至小男小女。犯者皆突吉罗。中二十法竟

次明比丘尼法

佛在舍卫国。尔时长老优波离问佛言。世尊。摩诃波阇波提瞿昙弥。受八重法故。即是出家受具足戒。成比丘尼法余比丘尼当云何佛言。应现前白四羯磨

佛在王舍城。尔时诸比丘。与比丘尼作羯磨。诸比丘尼心不喜。是事白佛。佛言。从今诸比丘。不应与比丘尼作羯磨。比丘尼还比丘尼作羯磨。除受具足戒羯磨摩那埵羯磨出罪羯磨

佛在舍卫国。尔时诸比丘尼。与比丘作羯磨。诸比丘心不喜。是事白佛。佛言。诸比丘尼。不应与比丘作羯磨。比丘还与比丘作羯磨。除不礼拜不共语不供养羯磨

佛在王舍城。尔时诸妇人。为夫舅姑所苦恼故。出家作比丘尼。尔时为和上尼阿阇梨尼共住比丘尼所苦恼故。还作白衣。诸居士呵责言。是诸不吉弊女辈。我等先是其主。中间作比丘尼受我尊重。今我等还受其尊重。无有决定。是事白佛。佛言。若比丘尼一反戒。不复听出家受具戒

佛在王舍城。尔时长老摩诃迦叶。中前着衣持钵。从耆阇崛山出。入王舍城乞食。尔时偷兰难陀比丘尼。在大迦叶前趋行。大迦叶言。妹汝。若疾行若避我道。即骂言。汝本是外道。有何急事而不徐徐行。大迦叶言。恶女。我不责汝。我责阿难。是事白佛。佛言。从今不听比丘尼在比丘前行。若在前行突吉罗

佛在舍卫国。尔时偷兰难陀比丘尼。中前着衣持钵行乞食。食后以尼师檀着左肩上。入安陀林中大坐一树下。时有蛇来入女根中。是事白佛。佛言。从今不听比丘尼大坐。若大坐突吉罗。若展一脚坐不犯

佛在舍卫国尔时优波离问佛言。世尊。不听比丘尼出比丘见闻疑罪。颇有因缘。比丘尼出比丘见闻疑罪。不犯罪耶。佛言。无也。除语莫近恶知识恶伴党

佛在舍卫国。尔时有比丘。教一比丘反戒随得罪。若教比丘尼式叉摩尼沙弥沙弥尼令反戒突吉罗。若比丘尼。教比丘尼反戒突吉罗。若比丘尼。教式叉摩尼沙弥沙弥尼比丘反戒突吉罗若式叉摩尼。教式叉摩尼反戒突吉罗。若教沙弥沙弥尼比丘比丘尼反戒突吉罗。若沙弥。教沙弥反戒突吉罗。若教沙弥尼比丘比丘尼式叉摩尼反戒突吉罗。若沙弥尼。教沙弥尼反戒突吉罗。若教比丘比丘尼式叉摩尼沙弥反戒突吉罗。若比丘。以种种物诱余比丘得罪。若诱比丘尼式叉摩尼沙弥沙弥尼突吉罗。若比丘尼。以种种物诱比丘尼犯罪。若诱式叉摩尼沙弥沙弥尼比丘突吉罗。若式叉摩尼。以种种物诱式叉摩尼突吉罗。若诱沙弥沙弥尼比丘比丘尼突吉罗。若沙弥。以种种物诱沙弥突吉罗。若诱沙弥尼比丘比丘尼式叉摩尼突吉罗。若沙弥尼。以种种物诱沙弥尼突吉罗。若诱比丘比丘尼式叉摩尼沙弥突吉罗。若比丘。向余比丘暗嗌突吉罗。若向比丘尼式叉摩尼沙弥沙弥尼暗嗌突吉罗。若比丘尼。向比丘尼喑嗌突吉罗。若向式叉摩尼沙弥沙弥尼喑嗌突吉罗。若比丘尼。向比丘喑嗌波逸提。若式叉摩尼。向式叉摩尼喑嗌突吉罗。若向比丘比丘尼沙弥沙弥尼喑嗌突吉罗。若沙弥。向沙弥喑嗌突吉罗。若向比丘比丘尼式叉摩尼沙弥尼喑嗌突吉罗。若沙弥尼。向沙弥尼喑嗌突吉罗。若向比丘比丘尼式叉摩尼沙弥喑嗌突吉罗。若比丘。轻比丘突吉罗。若比丘。轻比丘尼式叉摩尼沙弥沙弥尼突吉罗。若比丘尼。轻比丘尼突吉罗。若比丘尼。轻式叉摩尼沙弥沙弥尼突吉罗。若式叉摩尼。轻式叉摩尼突吉罗。若轻沙弥沙弥尼比丘比丘尼突吉罗。若沙弥。轻沙弥突吉罗。若轻沙弥尼比丘比丘尼式叉摩尼皆突吉罗。若沙弥尼。轻沙弥尼突吉罗。若轻比丘比丘尼式叉摩尼沙弥皆突吉罗。若比丘。恶语向余比丘犯罪。若恶语向比丘尼式叉摩尼沙弥沙弥尼。突吉罗。若比丘尼。恶语向比丘尼犯罪。若恶语向式叉摩尼沙弥沙弥尼比丘突吉罗。若式叉摩尼。恶语向式叉摩尼突吉罗。若向沙弥沙弥尼比丘比丘尼皆突吉罗。若沙弥。恶语向沙弥突吉罗。若向沙弥尼比丘比丘尼式叉摩尼恶语突吉罗。若沙弥尼。向沙弥尼突吉罗。若向比丘比丘尼式叉摩尼沙弥突吉罗

佛在舍卫国。尔时诸比丘尼。到祇洹听法。诸比丘敷敷具竟。多有残在。诸比丘尼求敷具故苦恼。语比丘言。大德已敷敷具。余者借我等坐。诸比丘言。佛未听我等敷敷具竟残与比丘尼。诸比丘不知云何。是事白佛。佛言。从今听诸比丘敷敷具竟残与比丘尼坐

佛在王舍城。尔时长老大迦叶。中前着衣持钵。从耆阇崛山。入王舍城乞食。偷兰难陀比丘尼随后来至。以肘隐大迦叶背。大迦叶言。恶女。我不责汝。我责阿难。是时白佛。佛言。从今不听比丘尼隐比丘背。若隐者突吉罗

佛在舍卫国。尔时助提婆达多比丘尼。着杂彩裲裆。诸居士呵责言。诸比丘尼自言。善好有德。着杂彩服。如王夫人大臣妇。是事白佛。佛言。从今比丘尼。不应着杂彩服。若着突吉罗

佛在王舍城。尔时诸比丘尼。以杂色绳猪肠带杂彩綖系身。是事白佛。佛言。从今不听比丘尼以杂色绳猪肠带杂彩綖系身。若系者突吉罗

佛在王舍城。尔时助提婆达多比丘尼。着细襵衣。着毦衣。着生起衣。着细疏衣。是事白佛。佛言。从今不听比丘尼着四种衣。若着突吉罗

佛在舍卫国。尔时偷兰难陀比丘尼故嚬呻。诸比丘尼问言。汝作何等。答言。受触乐。是事白佛。佛言。比丘尼不应嚬呻。若故嚬呻突吉罗

佛在舍卫国。有异比丘乞食。一时乞两分。先乞者自食。后乞者还房与比丘尼。此比丘乞二分食。时天雨故。比丘尼不来。无人食此分。弃着僧坊内众鸟来集作大音声。佛食后将阿难往至其所。佛见已知而故问阿难。此中何以众鸟来集作大音声。阿难白佛言。世尊。有异比丘乞二分食。前乞者自食。后分与比丘尼。乞两分食。时天雨故。比丘尼不来。无人食此分。弃着僧坊中。以是因缘故。众鸟大集作大音声。佛知故问阿难。诸比丘与非亲里比丘尼食耶。阿难答言。世尊与。佛以是因缘集比丘僧。集僧已种种因缘呵责诸比丘。云何名比丘。与非亲里比丘尼食。佛告诸比丘。从今比丘。不应与非亲里比丘尼食。与者突吉罗

佛在舍卫国。时世饥俭乞食难得。诸比丘节日得食。多有余残。诸比丘尼求食不得。生苦恼语诸比丘言。汝等与我残食。诸比丘言。佛未听我等与诸比丘尼残食。是事白佛。佛言。如是饥俭时。听与比丘尼残食。饥俭世过至丰乐时。诸比丘如饥饿时。与比丘尼残食。诸比丘尼不受。作是言。汝等残宿。于我亦残宿。汝等不净。于我亦不净。诸比丘不知云何。是事白佛。佛言。从今比丘残宿比丘尼净。比丘尼残宿比丘净

佛在舍卫国。诸比丘问比丘尼遮道法。诸比丘尼羞不喜。是事白佛。佛言。从今不听比丘问比丘尼遮道法。比丘尼应问比丘尼遮道法

佛在舍卫国。尔时诸比丘尼。问比丘遮道法。比丘羞不喜。是事白佛。佛言。从今不听比丘尼问比丘遮道法。比丘应问比丘遮道法

佛在舍卫国。尔时诸比丘尼。与不能正语式叉摩尼受具戒。是式叉摩尼白佛言度我。语不正故。便言涂我。诸年少比丘尼笑之。是式叉摩尼羞故起去。以是事故。遂不复受具戒。是事白佛。佛言。从今有语不正式叉摩尼。余比丘尼应代乞。代乞法者。一心和合比丘尼僧。代乞比丘尼。应从坐起偏袒右肩胡跪合掌作是言。大德僧听。是某甲式叉摩尼语不正。从僧乞受具戒。和上尼某甲。僧当济度与某甲式叉摩尼受具足戒。怜愍故。第二亦应言。大德僧听。是某甲式叉摩尼语不正从僧乞受具足戒。和上尼某甲。僧当济度与某甲式叉摩尼受具足戒。和上尼某甲。怜愍故。第三亦应言。大德僧听。是某甲式叉摩尼语不正。从僧乞受具足戒。和上尼某甲。僧当济度与某甲式叉摩尼受具足戒。怜愍故

佛在王舍城。尔时长老摩诃迦叶。雨时中前着衣持钵。入王舍城乞食。偷兰难陀比丘尼。随后来至嗅大迦叶。大迦叶言。妹若在前行莫嗅我。比丘尼言。大德先去。复嗅不已。大迦叶言。恶女。我不责汝。我责阿难。是事白。佛。佛言。从今不听比丘尼嗅比丘若嗅突吉罗

佛在舍卫国。尔时城中有一估客妇。夫行不在。与他男子私通。腹渐渐大。是妇怖畏夫故。即自堕胎。作是念。无同心人持死儿去者。愁守是儿。有一比丘尼。常出入是家。中前着衣持钵到是家。见妇愁忧。问言。何故。答言。我夫不在。与他私通有娠。畏夫嗔故。即自堕胎。无同心人与我弃者。汝能与我持去不。答言。我能。若我持去谁有知者。即以死儿着一盆中一盆盖上持去弃屏处。时有年少戏笑人见比丘尼弃盆。共相谓言。是所弃盆中有何物。即便往看。见死小儿作是言。诸沙门释子作淫欲。令比丘尼生儿杀弃。一人语二人。二人语三人。如是展转恶名流布。满舍卫城。有诸比丘。少欲知足行头陀。闻是事心不喜。是事白佛。佛言。从今比丘尼。不应为他弃死胎。若弃犯罪

佛在舍卫国。尔时崛多生男儿。作是念。佛结戒。不听触男子。我生男儿不知云何。是事白佛。佛言。从今听母自触小儿。乃至未能离母。余比丘尼不应触。若触者犯罪。若能离母。母触者突吉罗

佛在舍卫国。尔时崛多生男儿。作是念。佛结戒。乃至一夜不应共男子宿。我生此儿。今当云何。是事白佛。佛言。从今听乃至未能离乳得共宿。若能离乳共宿者。母得突吉罗。余比丘尼共宿波逸提

佛在舍卫国。尔时崛多生男儿。作是念。佛说比丘尼不得独房宿乃至一夜。须一比丘尼共房宿。我今云何。是事白佛。佛以是事集僧。语诸比丘尼。汝等与崛多比丘尼作独房羯磨。若更有如是比丘尼者。亦应与作独房羯磨。独房羯磨法者。一心和合僧。崛多比丘尼。从坐起脱革屣。偏袒右肩右膝着地。作是言。大德比丘尼僧忆念。我崛多生男儿。从僧乞独房羯磨。僧与我作独房羯磨。怜愍故。第二第三亦如是乞。是中一比丘尼应僧中唱言。大德僧听。是崛多生男儿。从僧乞独房羯磨。若僧时到僧忍听。僧与崛多比丘尼作独房羯磨。是名白。白二羯磨。僧与崛多比丘尼作独房羯磨竟。僧忍默然故。是事如是持

佛在舍卫国。尔时诸比丘。入出他家共作知识。诸居士妇语比丘言。汝度我女令作优婆夷。比丘答言我等手不触女人。云何得度。诸比丘不知云何。是事白佛。佛言。慈愍心故。应度令作优婆夷

佛在舍卫国。尔时诸比丘尼。出入他家共作知识。诸居士言。度我儿作优婆塞。比丘尼言。我等手不触男儿。云何得度。是事白佛。佛言。慈愍心故。应度为优婆塞

佛在舍卫国。尔时诸比丘尼。入出他家共作知识。诸居士妇语比丘尼言。汝等与我少许弊坏衣。守护小儿故。比丘尼言。汝等倒语。汝白衣应供养我等。云何反索。诸比丘尼不知云何。是事白佛。佛言。慈愍心故。应与

佛在舍卫国。尔时多有诸贵释种女。出家作比丘尼。露胸行乞食。诸居士呵责言。诸比丘尼自言。善好有德。露胸行乞。如王夫人大臣妇。诸比丘尼不知云何。是事白佛。佛言。从今听诸比丘尼用覆胁衣覆胸行乞食

佛在舍卫国。尔时有比丘尼。独入乐善园中。值贼剥脱裸形。诸比丘尼不知云何。是事白佛。佛言。从今不听诸比丘尼入乐善园中。余一切园中亦不得入。犯者突吉罗

佛在王舍城。助提婆达多比丘尼。男子前入池浴。诸居士呵责言。诸比丘尼自言。善好有德。在男子前浴。如淫女无异。有比丘尼。少欲知足行头陀。闻是事心不喜。以是事白佛。佛以是事集僧。集僧已种种因缘呵责言。云何名比丘尼。男子前浴。从今比丘尼。不应男子前浴。浴者波逸提

佛在舍卫国。尔时摩诃波阇波提瞿昙弥。深护佛法。以折伏语。为诸比丘尼作羯磨。谓苦切羯磨依止羯磨驱出羯磨下意羯磨。诸比丘尼轻慢言。某是我和上尼。某是我阿阇梨尼。我从某僧中受具足戒。是老弊比丘尼。不知谁是其和上尼阿阇梨尼。从何僧中受具戒。瞿昙弥闻是事心不喜。是事白佛。佛以是事集僧。语比丘尼。汝等莫恼摩诃波阇波提瞿昙弥。瞿昙弥。随受八重法时。即出家得具足戒。成比丘尼

佛在舍卫国。尔时华色比丘尼。中前着衣持钵入城乞食。食后以尼师檀着肩上。入安陀林中敷尼师檀。在一树下半跏趺坐。尔时有婆罗门儿。于比丘尼生贪着心。到比丘尼所言。共行不净事来。华色比丘尼念言。我若逆者。或强捉我。语言。小住。问言何故。但当小住。是比丘尼即以神力。变内身为外身。婆罗门儿嗔言。为我厌恶。即以拳打头。两目脱出。余比丘尼即以水器承眼。往诣佛所。佛语诸比丘尼。当作诚实语。华色比丘尼。于佛法中深心信乐。于佛法僧无有净物于佛法僧而不施者。以此实故。令其两眼还复如故。诸比丘尼作是实语已。眼复如故。佛语诸比丘。从今比丘尼。不得住阿练儿处。若住得突吉罗

佛在舍卫国。尔时诸比丘尼。依放牧人住。以象声马声男女声童男童女声故。妨坐禅诵经。是诸比丘尼。早起着衣持钵。到亲里知识檀越家。诸居士问言。汝安隐不。答言。不安隐。何以故。我等近放牧人住。象声马声男女声童男童女声故。妨我等坐禅诵经行道。诸居士言。我为汝等作房舍。比丘尼言。佛未听我等住房舍。是事白佛。佛言。从今听诸比丘尼起僧坊

佛在王舍城。尔时助提婆达多比丘尼。共诸善比丘尼住恼诸善比丘尼。诸善比丘尼。中前着衣持钵。到亲里知识檀越家。诸居士问言。汝等安隐不。答言。不安隐。何以故。答言。与助提婆达多比丘尼共住。恼乱我等。居士语言。我为汝等别作房舍。比丘尼言。佛未听我等别住房舍。是事白佛。佛言。从今听诸比丘尼别作房舍

佛在王舍城。尔时助提婆达多比丘尼。喜在门外高处立看。诸居士呵责言。诸比丘尼自言。善好有德。门外高处立看。如淫女。是事白佛。佛言。从今不听诸比丘尼门外高处立看。若立看波夜提。佛既不听门外高处立看。故便于窗棂中看。诸居士呵责言。诸比丘尼自言。善好有德。在窗棂中看。如王夫人如大臣妇。有比丘尼。少欲知足。闻是事心不喜。是事白佛。佛种种因缘呵责。云何比丘尼。窗棂中看。从今不得窗棂中看。看者突吉罗

佛在舍卫国。尔时诸比丘尼。与式叉摩尼受具戒。问言。汝是女耶。答言。我有二根。诸比丘尼不知云何。是事白佛。佛言。是二根人不能女。不能女故。不听出家受具戒。若已出家受具戒者。当作灭摈。何以故。二根人不能女。于我法中。不生善比尼法故

佛在舍卫国。尔时诸比丘尼。与式叉摩尼受具戒。问言。汝是女人耶。答言。我小便时大便出。大便时小便出。诸比丘尼不知云何。是事白佛。佛言。二道合不能女。不应与出家受具戒。若已出家受具戒者。应作灭摈。何以故。二道合人不能女。于我法中。不生善法比尼故

佛在舍卫国。尔时诸比丘尼。与式叉摩尼受具戒。问言。汝有月忌不。答言。常有。诸比丘尼不知云何。是事白佛。佛言。常有月忌不能女。不应与出家受具戒。若已出家受具戒者。应作灭摈。何以故。常月忌不能女。于我法中。不生善法比尼故

佛在舍卫国。尔时诸比丘尼。与式叉摩尼受具戒。问言。汝有月忌止耶。答言。我常无月忌。诸比丘尼不知云何。是事白佛。佛言。常无月忌不能女。不听出家受具戒。若已出家受具戒者。应作灭摈。何以故。常无月忌不能女。于我法中。不生善法比尼故

佛在舍卫国。尔时诸比丘尼。与式叉摩尼受具戒。问言。汝是女人耶。答言。我少有女相。诸比丘尼不知云何。是事白佛。佛言。少有女相不能女。不听出家受具戒。若已出家受具戒者。应作灭摈。何以故。少有女相不能女。于我法中。不生善法比尼故

佛在舍卫国。尔时有偷兰难陀比丘尼。月忌未止而巷中行。血堕污地。诸居士呵责言。不吉弊女。若有此月忌病。何以出巷中行。诸比丘尼不知云何。是事白佛。佛言。从今比丘尼。月忌未止。出外行者突吉罗。有诸比丘尼贫穷。月忌未止。从他乞饭羹菜薪草灯烛。受诸苦恼。是事白佛。佛言。应以衣裹出外行乞

佛在王舍城。尔时长老大迦叶。中前着衣持钵。从耆阇崛山向王舍城乞食。时偷兰难陀比丘尼。早起城门中立。看出入男子。谁好谁丑。是大迦叶入。即唾言。不吉。我早起见本外道。大迦叶言。恶女。我不责汝。我责阿难。诸比丘尼以是事白佛。佛言。诸比丘尼。不应唾比丘。若唾突吉罗

佛在舍卫国。尔时诸比丘尼。在比丘前忏悔。发露粗罪。诸比丘尼羞愧。不知云何。是事白佛。佛言。从今比丘尼粗罪。不应比丘前发露。应向比丘尼前发露。诸比丘尼发露时。不知是何罪摄在何处。是事白佛。佛言。应问比丘作是言。大德。作是事。犯何罪。是罪何名。比丘应答。作是事者。得如是罪。摄在某处。是罪名某

佛在舍卫国。尔时比丘尼。月忌未止。至祇洹听法。坐比丘敷具上。有血污之。陀骠力士子知众僧敷具。余日浣时嫌言。诸比丘尼有如是病。何故坐僧敷具上。是事白佛。佛言。从今若比丘尼。月忌未止。不得坐僧敷具上。坐者突吉罗

佛在王舍城。尔时助提婆达多比丘尼。立沽酒店。索价时受诸苦恼。诸居士呵责言。汝出家人何以立酒店。诸比丘尼不知云何。是事白佛。佛言。从今比丘尼。不应立酒店。若作突吉罗

佛在舍卫国。尔时偷兰难陀比丘尼。畜婢为眷属。诸居士呵责言。诸比丘尼自言。善好有德。畜婢为眷属。如王夫人大臣妇。诸比丘尼不知云何。是事白佛。佛言。从今不听畜婢为眷属。若畜为眷属者突吉罗

佛在舍卫国。偷兰难陀比丘尼。度淫女为弟子。晨朝时到。着衣持钵入舍卫城乞食。先共作不净行诸居士。语诸居士。我先共此比丘尼作不净。彼比丘尼愁恼。是事白佛。佛言。从今不听度淫女若度者突吉罗

佛在舍卫国。尔时长老迦留陀夷。中前着衣持钵入城乞食。偷兰难陀比丘尼随后来至。以手摩触迦留陀夷。迦留陀夷即以手脚蹴打卧地。语言。弊女。汝唾摩诃迦叶。谓我亦尔耶。诸比丘尼不知云何。是事白佛。佛言。从今比丘尼。不得摩触比丘身。摩触者犯罪

佛在俱舍弥国。尔时迦留罗提舍比丘命过。是人有姊妹比丘尼七人。偷兰难陀。周那难陀。提舍。优婆提舍。域多提舍。和梨提舍。勒叉多。有大力势。祭祀被烧死尸。诸居士呵责言。汝等出家入道。何以与死人饮食。诸比丘尼不知云何。是事白佛。佛言。从今诸比丘尼。不得祭祀死人。若祭祀者突吉罗

佛在舍卫国。尔时有比丘。失男根成女根。诸比丘不知云何。是事白佛。佛言。即以先出家受具戒岁数。遣入比丘尼众中

佛在舍卫国。尔时有比丘尼。失女根得男根。诸比丘尼不知云何。是事白佛。佛言。即以先出家受具戒岁数。遣入比丘众中

十诵律卷第四十十诵律卷第四十一(第六诵之六)

        后秦北印度三藏弗若多罗共罗什译

    明杂法之六

佛在舍卫国。尔时有比丘。不失男根得女根。诸比丘不知云何。是事白佛。佛言。应与灭摈

佛在舍卫国。尔时有比丘尼。不失女根得男根。诸比丘尼不知云何。是事白佛。佛言。应与灭摈

佛在舍卫国。尔时迦尸国有婆罗门。生一女。端正姝好。价直半迦尸国。此女嫁与婆罗门家。不久婿死。多有人来求此女。所谓大臣大官居士萨薄主。是女人心乐出家。作是言。我欲出家作比丘尼。不乐处俗。即诣王园作比丘尼。诸弊恶人。闻半迦尸女出家。我等今当劫夺取之。复作是念。诸比丘尼王所守护。若强夺者。或得官罪。若出家受具戒时。我等当道路劫取。诸比丘尼闻是事。不知云何。是事白佛。佛言。从今听半迦尸尼遣使受具戒。若有如是端正者。亦听遣使受具戒。使受戒法者。一心和合僧。是使从坐起。偏袒右肩脱革屣胡跪合掌。作是言。大德僧听。某半迦尸尼。和上尼某甲。是半迦尸尼。遣我从僧乞受具戒僧当济度与受具戒。和上尼某甲。僧怜愍故。第二亦言。大德僧听。某半迦尸尼。和上尼某甲。是半迦尸尼。遣我从僧乞受具戒。僧当济度与受具戒。和上尼某甲。僧怜愍故。第三亦言

大德僧听。某甲半迦尸尼。和上尼某甲。是半迦尸尼。遣我从僧乞受具戒。僧当济度与受具戒。和上尼某甲。僧怜愍故。尔时一比丘。应僧中唱言。大德僧听。某半迦尸尼。和上尼某甲。是半迦尸尼。遣使从僧乞受具戒。和上尼某甲。若僧时到僧忍听。我当僧中问半迦尸尼使六法事。是名白。应作是言。汝半迦尸尼使听。今是实语时。今僧中问汝。实当言实。不实当言不实。问使言。半迦尸尼先来清净不。二岁学六法不。比丘尼为作本事不。比丘尼僧一心和合。作属和上尼羯磨不。五衣钵具不。半迦尸尼字何等。和上尼字何等。和上尼字某甲。半迦尸尼字某甲。若未问事当问。问竟语言。汝默然。大德僧听。半迦尸尼某甲。和上尼某甲。是半迦尸尼。遣使从僧乞受具戒。和上尼某甲。使说。半迦尸尼先来清净。二岁学六法。诸比丘尼已作本事。一心和合比丘尼僧。作属和上尼羯磨。五衣钵具。半迦尸尼字某甲。和上尼字某甲。若僧时到僧忍听。僧用使与半迦尸尼受具戒。和上尼某甲。是名白。大德僧听半迦尸尼某甲。和上尼某甲。是半迦尸尼。遣使从僧乞受具戒。和上尼某甲。使说。半迦尸尼先来清净。二岁学六法。诸比丘尼已作本事。一心和合比丘尼僧。作属和上尼羯磨五衣钵具。僧与半迦尸尼某甲受具戒。和上尼某甲。谁诸长老忍与半迦尸尼受具戒者默然。不忍者说。是名初羯磨竟。第二更应说。大德僧听。半迦尸尼某甲。和上尼某甲。是半迦尸尼。遣使从僧乞受具戒。使说。半迦尸尼先来清净。二岁学六法。诸比丘尼已作本事。一心和合比丘尼僧。作属和上尼羯磨。五衣钵具。半迦尸尼某甲。和上尼某甲。僧与半迦尸尼受具戒。和上尼某甲。谁诸长老忍僧与半迦尸尼某甲受具戒和上尼某甲者默然。谁不忍者说。是名第二羯磨竟。第三更应说。大德僧听。半迦尸尼某甲。和上尼某甲。是半迦尸尼。遣使从僧乞受具戒。和上尼某甲。使说。半迦尸尼先来清净。二岁学六法。诸比丘尼已作本事。一心和合比丘尼僧。作属和上尼羯磨。五衣钵具。半迦尸尼某甲。和上尼某甲。僧与半迦尸尼受具戒。和上尼某甲。谁诸长老忍与半迦尸尼某甲受具戒和上尼某甲者默然。谁不忍者说。是第三羯磨竟。僧与半迦尸尼某甲受具戒和上尼某甲竟。僧忍默然故。是事如是持。是使即应还比丘尼僧坊中向半迦尸尼说羯磨。不应多不应少。亦应为说三依止八堕法。余残戒法。和上阿阇梨。当渐渐为汝广说

佛在舍卫国。尔时有一比丘尼。于迦留陀夷所。作过失事。迦留陀夷遮是比丘尼。不听入寺。诸比丘尼语是比丘尼。汝何不向迦留陀夷悔过。答言。遮我不听入寺。云何悔过。诸比丘尼不知云何。是事白佛。佛言。比丘不应遮比丘尼入寺。应遮自坊舍不应入。佛在舍卫国。尔时诸比丘尼。于比丘所作过失。诸比丘心不喜。是事白佛。佛言。若比丘尼。于比丘所作过失。是比丘应遮是比丘尼说戒自恣受教诫法。佛如是约敕已。是比丘遮比丘尼说戒自恣受教诫法。余比丘便听。以是事故斗诤起。诸比丘不知云何。是事白佛。佛言。是遮比丘应听。余人不应听

佛在舍卫国。尔时诸比丘。于比丘尼所有过失。诸比丘尼心不喜。作是言。我等比丘尼所作过失。比丘遮我等说戒自恣受教诫法。比丘于我等所作过失。谁能共语。是事白佛。佛言。若比丘于比丘尼所作过失。比丘应还向是比丘尼悔过。佛如是约敕已。比丘悔过向比丘尼。比丘尼不受。是事白佛。佛言。比丘悔过向比丘尼。比丘尼应受

佛在舍卫国。尔时有比丘尼。于迦留陀夷所作过失。迦留陀夷遮受教诫法竟出界去。诸比丘尼言。汝何不悔过向迦留陀夷。是比丘尼言。遮我教诫法已出界去。向谁悔过。诸比丘尼不知云何。是事白佛。佛言。从今比丘遮比丘尼。不应出界去。若出界得突吉罗。佛在舍卫国。尔时王园比丘尼精舍。有剃发师。与比丘尼剃发。诱诳一式叉摩尼坏出家心。如是诱诳第二第三人。以是事故尼僧减少。诸比丘尼不知云何。是事白佛。佛言。剃须时应令一善比丘尼在边立看

佛在王舍城。尔时助提婆达多比丘尼。赁房舍。后责价时得苦恼。诸居士呵责言。汝等出家何以赁舍。是事白佛。佛言。从今诸比丘尼。不得赁舍。若赁得突吉罗

佛在王舍城。尔时助提婆达多比丘尼。以治身具治身。诸居士呵责言。诸比丘尼自言。善好有功德。以治身具治身。如王夫人大臣妇。是事白佛。佛言。诸比丘尼。不应以治身具治身。若治突吉罗。有比丘尼。便以瓦石手拳自治身。是事白佛。佛言。不应以瓦石手拳治身。若以是物自治身得突吉罗。佛言。略说比丘尼。不应以一切物治身。若治突吉罗

佛在舍卫国。尔时自恣时。两部僧和合。尔时驱式叉摩尼沙弥沙弥尼出。自相谓言。汝等知不。何故驱我等出。今夜是等共集一处。各随所喜共和合故。诸比丘闻是事心不喜。是事白佛。佛言。从今比丘尼。不应夜来自恣。诸比丘尼。应早起来从比丘作自恣

尔时诸比丘尼多。五百余人一一自恣。食时已过。是事白佛。佛言。从今诸比丘尼。不应一一从比丘僧自恣。应一比丘尼代一切比丘尼僧从比丘僧自恣。代自恣法者。代自恣人从坐起。脱革屣胡跪合掌。作是言。比丘尼僧和合。礼大德僧足。问讯少病少恼起居安不。问讯已作是言。大德僧忆念。我等三月安居竟。我等今求大德说见闻疑罪。僧怜愍故。大德僧。为我等说罪者。增长善法。第二亦应言。大德僧忆念。和合比丘尼僧稽首。礼大德僧足。问讯少病少恼起居安不。问讯已作是言。我等三月安居竟。今求僧自恣说见闻疑罪。僧怜愍故。大德僧。为我等说罪者。增长善法。第三亦应言。大德僧忆念。和合比丘尼僧稽首。礼大德僧足。问讯少病少恼起居安不。问讯已作是言。我等三月安居竟。今求僧自恣说见闻疑罪。僧怜愍故。大德僧。为我等说罪者。增长善法

佛在舍卫国。尔时有一居士。请佛及二部僧明日食。佛默然受。居士知佛受已。头面礼足右绕而去。还自舍通夜办种种多美饮食。早起敷座。遣使白佛时到。食具已办唯圣知时。佛及二部僧入其舍。诸比丘尼随智慧多者先坐。是居士见佛及二部僧坐已。自手行水欲下饮食。助提婆达多比丘尼语居士言。此比丘尼是第一上座。此是第二上座。此是持律。此是持阿毗昙。居士言。我等不知不识。谁是第一上座。第二上座。持律持阿毗昙。多有饭食足饱一切。莫散乱语。汝若不止者。汝等起行食。我等当坐。佛遥见比丘尼作是语闻居士呵责。食后以是事故集比丘僧。语诸比丘。从今听诸比丘尼随上座次第坐

佛在舍卫国。尔时有居士。请佛及二部僧明日食。佛默然受居士知佛受已。头面礼足右绕而去。还自舍通夜办种种多美饮食。早起敷座。遣使白佛时到。食具已办唯圣知时。佛及二部僧入其舍。有比丘尼。问一比丘尼。汝几岁。答言。小住。当问和上尼阿阇梨尼共活尼。即往问和上尼阿阇梨尼共活尼言。我几岁。和上尼等答言。我等疑忘。诸比丘尼不知云何。是事白佛。佛言。上座两三人。应问次第坐。余不忆念者但坐

佛在舍卫国。尔时有比丘尼。上山至阿练若处。欲受教诫故。遇贼剥衣裸形。诸比丘尼不知云何。是事白佛。佛言。诸比丘尼。应住聚落中待比丘。比丘尼聚落中待。有比丘入聚落乞食。从余道还山阿练若处。日已向中。诸比丘尼垂当断食。是事白佛。佛言。应二人共行。即二人共行。二人不知法。所可至处看彩画舍。比丘问言。汝等欲受教诫耶。答言。如是。是事白佛。佛言。应遣二知法了了比丘尼受教诫。即遣二知法了了比丘尼。是二比丘尼。欲令一切比丘僧和合。我等当受教诫。是事白佛。佛言。不须一切僧和合。随所见比丘。应受教诫。余时到比丘所。有欲教诫者。有不欲者。不欲者便舍起去。诸比丘尼即便随去。诸居士在僧坊者。作是言。比丘尼欲行淫欲。比丘不欲故舍起去。诸比丘不知云何。是事白佛。佛言。比丘不应起去。若不欲者应言。我不能教诫比丘尼

佛在舍卫国。诸比丘尼受教诫法。还说戒竟。明日诣僧坊不知报谁。是事白佛。佛言。随受教诫比丘。应还报是人。时是比丘尼门下立问言。此中有是人不。答言。谁耶。比丘尼言。如此者。是事不应尔。诸比丘尼不知云何。是事白佛。佛言。比丘尼应问所教诫比丘名字种姓善好忆持。应问言。某比丘和上。某比丘阿阇梨。某比丘弟子

佛在舍卫国。尔时比丘尼僧。得裮布施。诸比丘尼不受。作是言。佛未听我等畜裮。是事白佛。佛言。从今听比丘尼僧受裮施私亦受

佛在舍卫国。尔时有比丘尼。乞食时。手持钵食巷中行。屋上有毒蛇。屎堕食中。比丘尼啖是食。毒发垂死。是事白佛。佛言。应作盖覆食器上

佛在王舍城。尔时助提婆达多比丘尼。背上负物。似畜生负驮。是事白佛。佛言。从今诸比丘尼。不应背上负物。若负物者突吉罗

佛在王舍城。尔时助提婆达多比丘尼。客作华鬘。责价时受苦恼。诸居士呵责言。汝等出家何用客作华鬘。是事白佛。佛言。从今不听比丘尼客作华鬘。客作者突吉罗

佛在王舍城。尔时助提婆达多比丘尼。畜盛大便器。铜盘澡盘铜杓。诸居士呵责言。诸比丘尼自言。善好有德。畜如是器。如王夫人大臣妇。是事白佛。佛言。从今不听比丘尼畜铜盔盛大便器铜盘澡盘铜杓。若畜突吉罗。不犯者。畜铜水瓶铜澡罐铜盖

佛在舍卫国。有比丘尼作酒。居士言。汝等出家人。何以作酒。有少欲知足比丘尼。闻是事心不喜。以是事白佛。佛以是事集比丘僧。集僧已语诸比丘。从今比丘尼不得作酒。作酒者突吉罗

佛在舍卫国。尔时诸妇人新来不久。其夫出行死。是诸妇人舍舍市肆。出家作比丘尼。作比丘尼已。赁舍与他住。后索价时受诸苦恼。诸居士呵责言。汝等出家。何用赁舍。是事白佛。佛言。从今不听比丘尼赁舍市肆。若赁与他者突吉罗

佛在舍卫国。尔时偷罗难陀比丘尼。着新疏衣。市巷多人中行。内身露现。诸居士言。善女是名何衣。答言。是名新疏衣。诸居士呵责言。诸比丘尼自言。善好有德。云何着新疏衣。如王夫人如大臣妇。是事白佛。佛言。从今不听比丘尼着薄疏衣。著者突吉罗

佛在王舍城。尔时有助提婆达多比丘尼。在女人洗处浴。诸居士呵责言。诸比丘尼自言。善好有德。在女人洗处浴。如王夫人大臣妇。是事白佛。佛言。从今不听诸比丘尼女人洗处浴。若浴突吉罗

佛在舍卫国。尔时偷罗难陀比丘尼。用澡豆浴身入女根中。是事白佛。佛言。从今不听比丘尼用澡豆浴用者突吉罗

佛在舍卫国。尔时偷罗难陀比丘尼。水中逆行。诸比丘尼问言。汝何以逆水行。答言。欲受触乐。是事白佛。佛言。从今不听比丘尼水中逆行。若逆水行突吉罗

佛在王舍城。尔时助提婆达多比丘尼。畜杂色庄严钵支。诸居士呵责言。诸比丘尼自言。善好有德。畜杂色钵支。如王夫人大臣妇。是事白佛。佛言。从今不听比丘尼畜杂色钵支。若畜突吉罗

佛在舍卫国。尔时比丘尼僧。得水精器布施。诸比丘尼不受。我何用是为。是事白佛。佛言。从今听比丘尼受水精器。作僧水器用

后二十法下

佛在舍卫国。有乞食比丘。中前着衣持钵。入舍卫城乞食。到乞食家入外门。不记识中门。内门亦不记识。还时错入余门。谓是出门。入已见一女人仰卧。此女人梦中失不净。比丘见已惭愧还出。出已此女人夫来。见妇露身卧不净出。即作此念。是比丘必共我妇作非梵行。便往捉比丘言。比丘汝好耶。共我妇作不净行。比丘答言。不作。夫言。何以入我舍耶。答言。我谓是可出门。即骂比丘。云何入我房户。谓是可出门。是人即以手脚极打是比丘。便放打比丘声故。女人即觉。语夫言。作何物。答言。打比丘。何以故打。以汝故打。妇语夫言。此比丘于我无过。我自梦中失不净。夫即骂妇。汝共作不净事。云何不伏耶。以手脚打是比丘。劳熟已舍去。是比丘大受苦痛已还去。以是事向诸比丘说。诸比丘以是事向佛广说。佛以是事集比丘僧已语诸比丘。乞食有二种。一者受请。二者不受请。若受请已。欲受僧物分者。应舍乞食法已受僧物分。若不舍乞食法。受僧物分者。得突吉罗。若受僧物僧物分已。故言我乞食者。犯妄语波夜提。不受请人。若欲受请。若欲受僧物分者。应舍乞食法已受请受僧物分。若不舍乞食法。受请受僧物分者。得突吉罗。若受请受僧物分已。故言我乞食者。犯妄语波夜提。佛言。从今教汝等乞食法。若比丘乞食时。应学行是法。若欲下床时。应徐下一脚。次下第二脚。安徐起。徐就架上取安陀卫。莫牵。安徐着。着已应左右看。齐正不。若不齐正者。更应着。若齐正者止。徐就架上取泥洹僧。莫牵安徐着。着已左右看。齐正不。若不齐正者。更应着。若齐正者止。徐就架上取郁多罗僧。莫牵。安徐着。着已左右看。齐正不。若不齐正者。更应着。若齐正者止。徐就架上取僧伽梨。莫牵。安徐着左肩上。徐徐取钵。莫放地。徐取锡杖。不应曳地。向户时。安徐推橝开户徐出。出户时。莫以衣触两边。出已应左手牵户扇右手牵橝。若户扇在右橝在左者。以右手牵扇左手下橝。下橝已应排看。坚牢不。若不坚牢更闭坚牢者止。若共佛行。应在佛后。应白和上。应右绕佛塔声闻塔。已徐徐泻水着钵中。莫使瓶钵相触。应安徐洗钵。莫使有声。不得挑水浇钵底。若僧坊门闭者。应徐却橝开门安徐出门。出门时。莫以衣触两边。应徐以钵杖着一处。已徐着一重革屣。应徐取钵杖。应安徐在道行。行时莫拖曳革屣。近聚落已。徐以钵杖着一处。应徐取僧伽梨着。着已应看。齐正不。若不齐正应更着。若齐正者止。应徐取钵杖。入巷时。不得上下看。应直前。若遥见狂象狂马狂牛狂狗狂裸形人者。应避道。若至乞食家。应好识外门中门内门相。入庭中住弹指。若无所得。应第二弹指。若复不得。应更三弹指。三弹指已。若得者应两手捉钵曲身受食。若更余处乞食时。应看日时节。若日故早更乞。若日时至便止。不应上下看。直视前行。若遥见狂象狂马狂牛狂狗狂裸形人者应避。出聚落时。徐捉钵杖着一处。徐取僧伽梨。中牒抖擞着右肩上。徐取钵杖。若先到食处。应敷座床。取揩脚物拭脚物安水瓨水瓶。应扫洒食处涂地。若和上阿阇梨在食处者。若得好食。先与和上阿阇梨。与饮时。莫令指入器中。若在后者。应举床座。举揩脚物拭脚物安水瓨水瓶。扫洒除粪还入房中。入房中时。应牵橝闭户就床座。徐徐摄一脚。次摄一脚。结加趺坐。思惟法行

佛在舍卫国。尔时一长者有好芦卜。是长者为芦卜故。请佛及僧怛钵那。佛默然受。知佛受已。还家竟夜办种种多美饮食。晨朝敷座。往白时到。佛自知时。佛与比丘僧。往入其舍坐已。长者自手行水自行芦卜根。诸比丘嚼芦卜根作声有一比丘。先是伎儿。见食作声。即便起舞。时有比丘笑。芦卜根从口鼻中出。诸居士呵责言。诸沙门释子自言。善好有德。云何使他笑如伎儿。佛见是比丘作如是事诸居士呵责。食已还去。佛以是事。集比丘僧。知而故问是比丘。汝以何心作。答言。以二事故。一者看他。二者欲令笑。佛言。为看他故无罪。为笑故突吉罗。佛语诸比丘。从今已若先未啖熟食。不得啖菜果。若先啖者突吉罗

佛在舍卫国。新造祇洹竟。诸居士办供具。多诸比丘来。千二百五十人。诸比丘乱入乱坐乱食乱起乱去。诸居士呵责言。有余沙门婆罗门。次第入次第坐次第食次第起次第去。是沙门释子自言。善好有德。乱入乱坐乱食乱起乱去。不知谁得谁不得谁重得。诸比丘不知云何。是事白佛。佛言。从今日应次第入次第坐次第食次第起次第去。时诸比丘次第入次第坐次第食次第起次第去。时默然入默然坐默然食默然起默然去。诸居士呵责言。有余沙门婆罗门。赞呗咒愿赞叹。沙门释子自言。善好有德。默然入默然坐默然食默然起默然去。我等不知食好不好。诸比丘不知云何。是事白佛。佛言。从今食时。应呗咒愿赞叹。诸比丘不知谁应作。佛言。上座作。尔时偷罗难陀少学寡闻。时为上座。佛言。若上座不能。次第二应作。第二不能。第三应作。如是次第。能者应作

佛在舍卫国。时诸女人次第请佛及僧。办种种饮食。诸比丘食已。不呗不咒愿而去。诸女人作是言。我等女人薄福。谁当为我等呗咒愿赞叹。诸比丘不知云何。是事白佛。佛言。从今亦应为女人呗咒愿赞叹。若无净人者。留上座四人住。住时诸上座吐闷。问佛。佛言。应语诸女人已去

佛在舍卫国。有一比丘。名曼头罗。是婆罗门种。出家作比丘患下。作是念。云何数数用水洗。佛言。应以物拭。拭时用一叶拭。拭已不净。佛言。应用两重。用两重拭时。一重舒污手。佛言。应截屈处。时截处伤大便道。佛言。不应截。应用一枚净拭。拭时掷弃着厕中。着已厕满。佛言。应着一处。时净叶不净叶共着一处。取时污手。佛言。右边安净叶。左边弃不净叶。着一处时大聚。佛言。除却。除却时吐逆。佛言。应安器。若满远弃余处

佛在王舍城。尔时六群比丘。洗脚处嚼杨枝。后比丘来见不净吐逆。诸比丘不知云何。是事白佛。佛以是事集僧。知而故问六群比丘。汝实作是事不。答言。实作世尊。佛以种种因缘呵责六群比丘。云何名比丘。僧洗脚处嚼杨枝。呵已语诸比丘。从今佛前不得嚼杨枝。和上阿阇梨前。一切上座前。佛塔前声闻塔前。温室讲堂厨下大门前。厕边安水处小便处。浴室中多人行处。不得嚼杨枝。嚼者突吉罗。不犯者。同岁比丘前不犯

佛在王舍城。有裸形外道病疥瘙。往语耆婆。治我此病。答言。浴室中洗乃可得差。外道作是言。我是外道。裸形无所著。何由得浴室洗耶。耆婆言。颇有亲里相识比丘不。答言无。耆婆言。唯得浴室洗可差。是外道即往到竹园。问新学比丘及沙弥言。汝等何时浴室洗耶。答言。某日。时外道屈指数日。或掷石数日。或作筹数日。若干日已过。若干日在。到浴日来至入竹园。在一面立。看诸比丘云何入浴室洗。或有比丘着衣入。或有以泥涂身入。是外道即以泥涂身入。如似老上座。诸比丘作是念。是上座比丘从何处来。共相谓言。上座来与上座床。即便与床。盛满器水着前。汗出已。诸比丘亦与揩脚髀膊胸背。举身揩已。疥瘙即除。身得清净。清净已。唤担衣来与上座。是外道言。汝等不好用着衣为。诸比丘言。不善。将不与外道洗耶。诸比丘不知云何。是事白佛。佛言。从今日露身不得揩。他亦不得。揩露身者两露身亦不得相揩。比丘闇中不得作礼。不得礼覆面者。不得礼睡者。不得礼入三昧者。不得礼嚼杨枝者。自嚼杨枝亦不得作礼。自洗面不得作礼。亦不得向洗面者礼。自食时不得礼。不得礼食者。自缝衣时不得礼。不得向缝衣者作礼。自剃发时不得作礼。亦不得礼剃发者。自在高处不得礼下处。下处亦不得礼高处。佛前不得礼人。佛塔前声闻塔前亦不得礼人。大小便处取水处。浴室乃至不安隐处。皆不得礼。在道行时不得礼。若至心欲礼者。语上座住。我欲礼。若住者应礼。不住者不应礼

佛在舍卫国。有客比丘暮来。次得空房舍。时床上有盘蛇睡。比丘不看便坐蛇上。为蛇所螫与蛇俱死。经五六日有青蝇出。诸比丘见蝇出入。共相谓言。此房中有青蝇出。当入看来。入已便见。作是言。是比丘必坐是蛇上。为蛇所螫二俱死耳。诸比丘不知云何。是事白佛。佛以是事集比丘僧。语诸比丘。从今教客比丘仪法。若客比丘到僧坊中。应偏袒着衣。着泥洹僧。高应下着。衣囊在右肩上。应转着左肩上。若杖油囊革屣针筒。在右手中。应移左手中。若欲大小便。应先外却已入僧坊。若得水洗足已入。若不得水。以草树叶拭足已入。若门闭应求开门。若开应入。若不开。僧坊外有墙堑刺棘。应在现处立。一心净持威仪。作大人相起他善心。若见旧比丘应问。此僧坊中有若干岁比丘房不。若言有。即语开门已入。又问。是房中为有人不。若言空。应问。用何水。若言井水。应索盥及绳扫彗。应开房户弹指。若有毒蛇弹指令去。当徐往出枕被褥床榻覆地物。出已应扫洒涂地。抖擞床席被褥枕覆地物觅虫已。还敷如本。洗脚盆常用水瓶皆着水。持革屣至水边浣。拭革屣物捩晒已。捉革屣先拭前头。次拭后中拭带。若水器在左边。应左手取水右手洗足。若在右边。右手取水左手洗足。洗足已着革屣入房。闭门下橝却坐绳床。先摄一脚次摄一脚。摄已大坐正观诸法。地了时应问旧比丘。此僧坊中。有前食无前食。有时食无时食。何处有恶狗恶牛大童女寡妇家。何处是僧羯磨学家覆钵羯磨家。何处可行。何处不可行。问是事已。应行乞食。若客比丘欲去时。以灌绳扫彗。还付本主。摒挡卧具。闭门下橝已去

佛在阿毗罗国。时新作僧伽蓝。有比丘作匠。着僧伽梨辇石辇墼辇草辇泥。以手泥壁。黑泥糠泥污洒泥壁。赤色泥白色泥涂壁。洒扫僧坊涂地故污衣。着是污衣入聚落乞食。诸居士呵责。有余沙门婆罗门。着净衣入聚落乞食。是沙门释子自言。善好有德。着是污衣入聚落乞食。如压油人。是中有比丘。少欲知足行头陀。闻是事心不喜。以是事白佛。佛以是事集比丘僧。语诸比丘。从今不得着僧伽梨辇石辇泥辇草泥涂壁。以手涂壁糠泥污洒涂壁。黑色赤白色涂壁扫洒僧坊涂地。不得脚蹑僧伽梨。不得敷僧伽梨坐。不得卧僧伽梨上。不得衬身着僧伽梨。着僧伽梨。如着僧伽梨法。着郁多罗僧。如着郁多罗僧法。着安陀卫。如着安陀卫法。以三种坏色作净。不得着五种纯色衣。除纳衣。若比丘贫少衣。不能得割截衣。衣上安牒。若五若七若九若十一若十三。若十五若过十五。若能得应割截作僧伽梨郁多罗僧安陀卫。是为衣法

佛在王舍城。有大僧坊。初夜中夜后夜。多有客比丘。一切时来宿。晨朝便去。上座问下坐言。何以无客比丘。答言有。何以不来见上座。我等不知彼人来去。诸比丘不知云何。是事白佛。佛言。若客比丘来应先礼。拜上座时彼僧坊有千二百五十比丘。客比丘一一礼拜过初夜。道行疲极不能得遍。诸比丘不知云何。是事白佛。佛言。应问讯四上座。有客比丘暮来问。第一上座在何处。答言。在耆阇崛坊。又问。第二上座复在何处。答言。在毗伽罗坊。又问。第三上座在何处。答言。在贵守陀罗坊。又问。第四上座在何处。答言。在萨多诃求坊往问讯时。道中有师子虎狼畏豹熊罴多罗刹等畏。诸比丘不知云何。是事白佛。佛言。随所入坊舍中。即礼彼四上座。礼时在大坊舍门外住立久。迷闷吐逆不乐。诸比丘不知云何。是事白佛。佛言若时得见上座者应礼。不时得见者则止

佛在舍卫国。憍萨罗国阿练若处。有一比丘在中住。时贼来入僧坊。见是比丘在阁上。即遣人将是比丘来下。时彼贼主信敬佛法。作是言。莫将比丘下。当看。有火不。言无。有食不。言无。有水不。言无。共相谓言。是沙门释子清净。看洗脚处有水不。言无。看净水瓶常用水瓶。有水不。言无。作是言。将是比丘来。即将来下。问言。大德。有火不。答言无。有钻火具不。欲钻火。答言无。大德。我等饥。有食不。答言无。问有食器不。我欲作食。答言无。大德。我等渴。有水不。答言无。有取水器不。答言无。大德。是沙门释子清净。有洗脚水不。有净水瓶常用水瓶不。答言无。又问。大德。我欲至彼聚落。示教我道处。答言。不知。又问。时节早晚。答言。不知。又问。今是何日。答言。不知。又言。作呗。答言。不能。又言。咒愿。答言。不能。又言。赞法。答言。不能。是贼共相谓言。此阿练若比丘。无一阿练若法。是比丘当不能自活故出家。当熟打之。即以手脚打是比丘已舍去。是比丘大受苦恼。以是事语诸比丘。诸比丘以是事白佛。佛以是事集比丘僧。语诸比丘。从今当教阿练若比丘仪法。应学是法。从今阿练若比丘。有人来先应共语好正忆念和悦颜色。不应垂头。应言善来。应畜火及火钻。应畜食食器。应畜水水器。应畜洗脚水水器。净水瓶常用水瓶盛满水。应知道知日知时知夜知夜分。应知星宿。应学星宿法。应诵修多罗毗尼阿毗昙。应学解修多罗毗尼阿毗昙。应知初禅二禅三禅四禅须陀洹斯陀含阿那含阿罗汉果。若未得者。应知诵读。不应畜日珠月珠。如是法应广知。应畜禅杖。如瞿尼沙修多罗中广说。应修行之

佛在舍卫国。阿耆达婆罗门。担释俱梨饼。往到佛所与佛。佛言。分与僧。即分与僧已。在佛前听咒愿。佛为种种说法。诸比丘啮饼作声。阿耆达叉手白佛言。世尊。沙门瞿昙教化一切弟子。皆能受耶。佛言。有受者不受者。婆罗门言。实尔瞿昙。有为法者有为食者。佛为阿耆达种种说法示教利喜已默然。时阿耆达闻佛说法示教利喜已。从坐起礼佛足右绕而去。去不久。佛以是事集比丘僧。语诸比丘。从今说法时咒愿时。赞法时不得食。食者突吉罗

佛在波罗奈国。佛中前着衣持钵。入波罗奈城欲乞食有一新比丘。中前着衣持钵。先入城乞食。佛遥见是比丘在他门前。是比丘亦见佛。见佛已惭愧低头。佛乞食还摄衣钵竟。以是事集比丘僧。语诸比丘。我今日中前着衣持钵入城乞食。见一新比丘亦着衣持钵先入城乞食。我见是比丘。比丘见我故。惭愧低头。语诸比丘。谁中前着衣持钵入城乞食。是比丘惭愧。长跪合掌白佛言。我是。佛言。善哉善哉。见我故惭愧摄情。若见比丘比丘尼优婆塞优婆夷及诸外道沙门婆罗门。亦应摄情低头。长夜得安乐

佛在舍卫国。长老郁提有共行弟子。无恭敬心。入僧坊中亦无恭敬心。时长老郁提。往到佛所。头面礼足在一面坐已白佛言。世尊。我共行弟子无恭敬心。入僧坊中亦无恭敬心。世尊。云何令弟子于和上有恭敬心。佛言。小住郁提。我问汝时当说。佛以是事集比丘僧已。语郁提言。汝欲说者说。郁提言。世尊。我共行弟子无恭敬心。入僧坊中亦无恭敬心。云何令弟子于和上有恭敬心。佛语郁提。共行弟子于和上应生敬心。入僧坊亦应生敬心。应与和上钵衣户钩时药时分药七日药尽形寿药。若和上作衣时应代作。浣衣时。染衣时。割截衣时。簪衣时。刺衣时。舒展时。皆应代作。若自不能者。应赁他作。若自不能尽作者。亦应借他。若能尽作者应作。不得闲住。佛语郁提。若和上欲浴室中洗时。弟子先应办浴具。着薪着油澡豆。若和上入浴室时。弟子应持浴衣与。摄取所著衣与床。应与水瓶授杖。若和上少力。弟子应手扶。若大羸劣。应负入浴室。应摄衣着一面。应坐着床上以水盆着前。若弟子欲洗时。应白和上向壁洗。应生病想生药想。佛言。和上汗出时。弟子先应揩脚。次揩膊髀腰脊胸背。若和上洗竟。应授衣与取床取水器取杖。应以薪着窖中。若和上少力者应手扶。若大羸劣。应负还房坐床上。应取浴衣举。应授卧衣。应安大小便器。应安唾器。若弟子更欲洗。应白和上已洗。若最后浴室中洗者。应举绳床着一处举水瓶水瓨。应以灰覆火出浴室闭门下橝已去。若欲诵时。至三问能得者。应随力从和上受。受已在一处忆念思惟。若得者诵。若不得者更问。明日应摄大小便器唾器。弃已应问和上。须粥须食不。若言须粥。应安釜器办杓办匕。若言须食。应办食。应办食器。若和上病者。弟子应看若活若死。应觅随病食随病药。应取和上物作供养。若和上无者自办。若自无者从他求。若无知识不能得者。乞食时得好者。应与和上郁提。若僧与和上忆念羯磨。若与不痴羯磨时。应代和上去作是言。僧与我和上忆念羯磨若不痴羯磨。僧与和上苦切羯磨依止羯磨驱出羯磨下意羯磨时。弟子以法佐和上言。僧莫与我和上苦切羯磨依止羯磨驱出羯磨下意羯磨。若僧已与和上作是苦切羯磨依止羯磨驱出羯磨下意羯磨竟。弟子应言。僧与我和上轻作羯磨。莫重作。郁提。若僧与和上觅罪相羯磨。弟子应往言。僧如法莫与我和上觅罪羯磨。若僧与和上觅罪羯磨竟。弟子应从僧乞。轻作莫重作。若僧与和上不见摈羯磨不作摈羯磨恶邪不除摈羯磨。弟子应往白僧言。不见教见不作教作不除教除。郁提。若和上犯僧残罪。应与别住摩那埵本日治出罪羯磨。弟子应往言。僧如法与我和上别住摩那埵本日治出罪羯磨。郁提。是弟子不白和上。不得教他读经。不得诵经令他忆念。不得并诵。不白和上不得从他受法。不得授他法。不得从他受忆念。不得并诵。不得与他衣钵户钩时药时分药七日药。尽形寿药。不得与他作衣。不得使他作衣。不得与他剃发。不得使他剃发。不白和上不得一切有所作。除大小便及嚼杨枝礼佛。郁提。若和上欲入聚落。弟子应授入聚落衣。应揲卧衣举。弟子若随和上入聚落。应取钵杖僧伽梨。不应在前行。不应大逼近。不得并行。若师说非法者应谏止。若说法应随喜。若说法时得施。弟子应取。若到聚落。应授钵杖僧伽梨。弟子若在前出聚落。不应远住。应取和上钵杖僧伽梨。若和上共道行。弟子应取杖取盛油囊革屣针綖囊。郁提。弟子应日日三时至和上边。早起食后日没时。早起时应除大小便器唾器。食后时应扫洒涂地。日没时应持大小便器唾器着边。郁提白佛言。世尊。弟子于和上行如是法。和上于弟子当云何。佛语郁提。弟子作是行者。和上应教诵修多罗毗尼阿毗昙与衣钵杖户钩。与时药时分药七日药尽形药。若弟子作衣时。和上应佐作。若浣衣染衣割截簪刺舒展时。皆应佐作。若自不能倩他。若自不能尽作。亦应使他。若随能者尽佐作。不得闲住。若和上见弟子病时。应看若活若死。应与觅随病食随病药。应取弟子物作。弟子无者和上与物。若自无物从他求与无知识求不能得。若乞食时得好食者与。若僧与弟子忆念羯磨与不痴羯磨。作是言。如法与我弟子忆念羯磨不痴羯磨。若僧与弟子苦切羯磨依止羯磨驱出羯磨下意羯磨。和上应如法佐言。莫与我弟子苦切羯磨依止羯磨驱出羯磨下意羯磨。若僧已作苦切羯磨依止羯磨驱出羯磨下意羯磨竟。应言。轻作莫重作若僧欲与弟子觅罪羯磨。应如法佐言。莫作。若僧与觅罪羯磨竟。和上应佐言。轻作莫重作。郁提。若僧与弟子不见摈羯磨。不作摈羯磨。恶邪不除摈羯磨。和上应言。不见教见不作教作不除教除。郁提。若弟子犯僧残罪。应与作别住摩那埵本日治出罪羯磨。和上作是言。僧与我弟子别住摩那埵本日治出罪羯磨。郁提。应日日三时教弟子。早起食后日没时。早起教言。莫近恶知识恶伴弊恶人。食后教言。莫近恶知识恶伴弊恶人。日没时教言。莫近恶知识恶伴弊恶人。若作非法应呵止。郁提。有三种呵止。一者不唤作。二者不共语。三者欲有所作不听作

十诵律卷第四十一十诵律卷第四十二(第七诵之一)

        后秦北印度三藏弗若多罗共罗什译

    尼律第一(不共之戒)八波罗夷法

佛在舍卫国。尔时舍卫国中王园精舍。有比丘尼。名周那难陀。年少端正。有鹿子居士儿。亦年少端正。是男子于周那难陀比丘尼。深生漏心。是比丘尼于是男子。亦生漏心。是鹿子儿如是思惟。若我语是比丘尼。作是事者。身自得罪。王当治我。恶名流布四方。身坏命终当堕地狱。比丘尼亦如是思惟。若我语是男子。作是事者。身自得罪。而令他得罪。恶名流布四方。诸比丘比丘尼以法治我。诸天善神不复守护我。身坏命终当堕地狱。是比丘尼常忆念是男子。不得从意故。生病羸瘦在房内卧。断威仪不能行来。是男子闻是比丘尼得病受苦恼在房内卧不能行来。闻已作是念。是比丘尼更无有病。但以念我故。致是羸瘦受诸苦恼。我何不往是比丘尼所。不说是事亦能除病。作是念已。即往王园比丘尼精舍。到已问诸比丘尼言。周那难陀比丘尼为在何处。答言。在某房内病卧受苦恼。断威仪不能行来。是男子即往到比丘尼房中。摩触抱捉作是言。汝病小差不。可忍不。苦恼不增长耶。答言。病不差不可忍。苦恼增长。尔时比丘尼。口出恶不净语。作是言。此是我分。他不爱念我。我便爱念他。是中有比丘尼。少欲知足行头陀。闻是事心不喜。呵责言。云何名比丘尼。有漏心听漏心男子摩触抱捉。种种因缘呵已向佛广说。佛以是事集二部僧。佛知故问周那难陀比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘尼。有漏心听漏心男子摩触抱捉。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。摄僧故。僧极好摄故。僧安乐住故。折伏高心人故。有惭愧者得安乐故。不信者得净信故。已信者增长信故。遮今世恼漏故。断后世恶趣故。梵行久住故。从今是戒应如是说。若比丘尼有漏心。听漏心男子发际以下至腕膝以上却衣。顺摩逆摩牵推按掐抱上抱下。是比丘尼得波罗夷不共住。漏心者。于是人边生爱结深厚。男子漏心亦如是。男者。谓人男能作淫事。波罗夷者。是罪弊恶深重。退堕不如。是故名波罗夷。不共住者。诸比丘尼。不与此比丘尼共作法事。谓白羯磨白二羯磨白四羯磨说戒自恣作十三比丘尼羯磨。是中犯者。有八种。若比丘尼生漏心。听漏心男子却衣顺摩面。犯波罗夷。若摩咽若胸胁脊腹脐大小便处髀乃至膝。如顺摩逆摩牵推按掐亦如是。发际以上腕以前膝以下。却衣摩触偷兰遮。若比丘尼有漏心。听漏心男子却衣。从地抱着机上波罗夷。从机上着独坐床上。从独坐床上着大床上。从大床上着舆上。从舆上着车上。从车上着马上。从马上着象上。从象上着堂上。皆波罗夷。又比丘尼有漏心。听漏心男子却衣。从堂上抱着象上。从象上着马上。从马上着车上。从车上着舆上。从舆上着大床上。从大床上着独坐床上。从独坐床上着机上。从机上着地上。皆波罗夷。能发际以上腕以前膝以下听却衣抱举上下偷兰遮。若比丘尼有漏心。听漏心男子合衣顺摩面偷兰遮。若咽若胸胁脊腹脐大小便处髀膝。得偷兰遮。如顺摩逆摩牵推按掐亦如是。合衣摩触发际以上腕以前膝以下突吉罗。又比丘尼有漏心。听漏心男子合衣抱。从地着机上偷兰遮。从机上着独坐床上。从独坐床上着大床上。从大床上着舆上。从舆上着车上。从车上着马上。从马上着象上。从象上着堂上。皆偷兰遮。又比丘尼有漏心。听漏心男子合衣抱。从堂上着象上。从象上着马上。从马上着车上。从车上着舆上。从舆上着大床上。从大床上着独坐床上。从独坐床上着机上。从机上着地上。皆偷兰遮。若发际以上腕以前膝以下。听合衣抱举上下突吉罗。不犯者。若父想兄弟想儿子想。若水漂若火烧。若刀槊弓杖若欲堕坑。若值恶兽难恶鬼难不犯。一切无著心不犯(五事竟)

佛在王舍城。尔时助调达比丘尼。听六群比丘捉手。捉衣。共立共语共期。入屏覆处待男子来。举身如白衣女尔时有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘诃责言。云何名比丘尼。有漏心。听漏心男子捉手捉衣。共立共语共期。入屏覆处待男子来。举身如白衣女。种种因缘诃已向佛广说。佛以是事集二部僧。知而故问助调达比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘尼。有漏心。听漏心男子捉手捉衣。共立共语共期。入屏覆处待男子来。举身如白衣女。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼有漏心。听漏心男子捉手捉衣。共立共语共期。入屏覆处。待男子来。举身如白衣女。以是八事示贪着相。是比丘尼犯波罗夷不应共住。漏心者。于是人边生爱结深厚。男子漏心亦如是。男子者。谓人男能作淫事。捉手者。从腕前。名为手。捉衣者。捉衬身衣。共立者。可说不净语处。共语者。可说不净语处。共期者。可作恶处。入屏覆处者。若壁覆障。草席覆障。衣幔覆障处。待男子来者。可作恶处。举身如白衣女者。若捉若抱。不逆男子意。如白衣女。用是八事示贪着相。犯波罗夷。波罗夷者。是罪弊恶深重。退堕不如。若比丘尼犯是罪者。不名沙门尼。非释女。失比丘尼法。不共住者。诸比丘尼不共作法事。谓白羯磨白二羯磨白四羯磨说戒。自恣立十三比丘尼羯磨。是中犯者。若比丘尼有漏心。听漏心男子捉手偷兰遮。听捉衣偷兰遮。若共立偷兰遮。若共语偷兰遮。若共期偷兰遮。若入屏覆处偷兰遮。待男子来偷兰遮。身与男子如白衣女偷兰遮。若具作八事。犯波罗夷(第六事竟)

佛在王舍城。尔时有二比丘尼是姊妹。姊名弥多罗妹名弥帝隶。弥多罗比丘尼。作不净行犯淫欲。弥帝隶比丘尼善好。不犯淫欲。弥多罗比丘尼。后时反戒作白衣。诸比丘尼。往语弥帝隶比丘尼言。汝姊反戒作白衣。为好不。答言。我亦先知是比丘尼犯如是如是不净行。我但不欲自举。不欲向僧说。或有人言。云何名比丘尼。自污姊。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。有知他比丘尼有粗罪覆藏。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问弥帝隶比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘尼。知比丘尼犯粗罪覆藏。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼。知比丘尼犯粗罪。覆藏乃至一夜。是比丘尼。知彼比丘尼若退若住若灭若去。后作是言。我亦先知是比丘尼犯如是如是不净行。但不欲自举。不欲向僧说。或有人言。云何名比丘尼。自污姊。是比丘尼犯波罗夷。不应共住。知者。若自知若从他闻。若罪比丘尼自说。粗罪者若波罗夷若僧伽婆尸沙。复次一切罪。皆名为粗。但分别五种罪故。二种名粗。一夜者。从日没至地未了。是名夜。彼比丘尼退者。退失比丘尼法。住者。住白衣法中。灭者。如法如毗尼如佛教。与灭摈羯磨。去者。入外道去。然后作是言。我先知是比丘尼犯如是如是不净行。我不欲自举。不欲向僧说。或有人言。云何妹自污姊。是比丘尼犯波罗夷。不应共住。波罗夷者。是罪弊恶深重。退堕不如。若比丘尼作是罪。非沙门尼非释女。失比丘尼法。不共住者。诸比丘尼不共作法事。谓白羯磨白二羯磨白四羯磨说戒自恣立十三比丘尼羯磨。是中犯者。若比丘尼。见余比丘尼地了时犯波罗夷罪。是比丘尼。波罗夷中生波罗夷想。竟日覆藏至地了时。犯波罗夷若是比丘尼。僧与作不见摈不作摈恶邪不除摈。狂心乱心病坏心。尔时覆藏不犯。若解摈若苦痛止还得本心。是时覆藏他罪至地了时。犯波罗夷。若比丘尼。见余比丘尼。地了已日出时日出已。中前日中日昳。晡时日没时日没已。初夜初分初夜中分初夜后分。中夜初分中夜中分中夜后分。后夜初分后夜中分后夜后分。覆藏至地了时。犯波罗夷。是波罗夷中生波罗夷想。覆藏至地了时。犯波罗夷。若是比丘尼。僧与作不见摈不作摈恶邪不除摈。狂心乱心病坏心。尔时覆藏不犯。若解摈若苦痛止还得本心。尔时覆藏他罪至地了时。犯波罗夷。若比丘尼。见余比丘尼地了时犯波罗夷。于波罗夷中。谓波罗夷。谓僧伽婆尸沙。谓波逸提。谓波罗提提舍尼。谓突吉罗。是比丘尼。于波罗夷中生僧伽婆尸沙想。覆藏至地了时犯波罗夷。又比丘尼。日出时日出已。中前日中日昳晡时日没日没已。初夜初分初夜中分初夜后分。中夜初分中夜中分中夜后分。后夜初分后夜中分后夜后分。见比丘尼犯波罗夷是波罗夷中。谓僧伽婆尸沙。谓波逸提。谓波罗提提舍尼。谓突吉罗。于波罗夷中。生僧伽婆尸沙想。覆藏至地了时。犯波罗夷。生波逸提想。生波罗提提舍尼想。生突吉罗想。亦如是。若僧与是比丘尼作不见摈不作摈恶邪不除摈。狂心乱心病坏心。尔时覆藏不犯。若解摈若苦痛止还得本心。尔时覆藏他罪至地了时。犯波罗夷若比丘尼。见余比丘尼地了时犯波罗夷罪。于波罗夷中生疑。为波罗夷为非波罗夷。后时断疑。于波罗夷中生波罗夷想。覆藏至地了时。犯波罗夷。又比丘尼。日出时日出已。中前日中日昳。晡时日没日没已。初夜初分初夜中分初夜后分。中夜初分中夜中分中夜后分。后夜初分后夜中分后夜后分。见比丘尼犯波罗夷。于波罗夷中生疑。为波罗夷非波罗夷。后时断疑。于波罗夷中生波罗夷想覆藏至地了时。犯波罗夷。若僧与作不见摈不作摈恶邪不除摈。若是比丘尼狂心乱心病坏心。尔时覆藏不犯。若僧与是比丘尼解摈。若苦痛止还得本心。尔时覆藏他罪至地了时。犯波罗夷。若比丘尼见余比丘尼地了时犯波罗夷。于波罗夷中生疑。为波罗夷为僧伽婆尸沙。为波罗夷为波逸提。为波罗夷为波罗提提舍尼。为波罗夷为突吉罗。后时断疑于波罗夷中生波罗夷想。覆藏至地了时犯波罗夷。又比丘尼。日出时日出已。中前日中日昳。晡时日没时日没已。初夜初分初夜中分初夜后分。中夜初分中夜中分中夜后分。后夜初分后夜中分后夜后分。见比丘尼犯波罗夷罪。于波罗夷中生疑。为波罗夷为僧伽婆尸沙。为波罗夷为波逸提。为波罗夷为波罗提提舍尼。为波罗夷为突吉罗。后时断疑。于波罗夷中生波罗夷想。覆藏至地了时犯波罗夷。若僧与是比丘尼作不见摈不作摈恶邪不除摈。若狂心乱心病坏心。尔时覆藏不犯波罗夷。若僧与是比丘尼解摈。若苦痛止还得本心。尔时覆藏至地了时。犯波罗夷。若比丘尼。见余比丘尼地了时犯波罗夷。于波罗夷中生疑。为波罗夷。为僧伽婆尸沙。为波逸提。为波罗提提舍尼。为突吉罗。后时断疑。于波罗夷中生僧伽婆尸沙想。覆藏至地了时。犯波罗夷。又比丘尼。日出时日出已中前日中日昳。晡时日没日没已。初夜初分初夜中分初夜后分。中夜初分中夜中分中夜后分。后夜初分后夜中分后夜后分。见余比丘尼犯波罗夷。于波罗夷中生疑。为波罗夷为僧伽婆尸沙。为波罗夷为波逸提。为波罗夷为波罗提提舍尼。为波罗夷为突吉罗。后时断疑。于波罗夷中。生僧伽婆尸沙想。覆藏至地了时。犯波罗夷。若僧与是比丘尼作不见摈不作摈恶邪不除摈。若狂心乱心病坏心。尔时覆藏不犯。若僧与是比丘尼解摈。若苦痛止还得本心尔时覆藏他罪至地了时。犯波罗夷。若比丘尼。见他比丘尼地了时犯波罗夷。于波罗夷中生疑。为波罗夷。为僧伽婆尸沙。为波逸提。为波罗提提舍尼。为突吉罗。后时断疑。于波罗夷中生波逸提想。覆藏至地了时。犯波罗夷。又比丘尼。日出时日出已。中前日中日昳。晡时日没日没已。初夜初分初夜中分初夜后分。中夜初分中夜中分中夜后分。后夜初分后夜中分后夜后分。见比丘尼犯波罗夷。于波罗夷中生疑。为波罗夷。为僧伽婆尸沙。为波逸提。为波罗提提舍尼。为突吉罗。后时断疑。于波罗夷中生波逸提想。覆藏至地了时。犯波罗夷。若僧与是比丘尼作不见摈不作摈恶邪不除摈。若狂心乱心病坏心。尔时覆藏不犯波罗夷。若僧与是比丘尼解摈。若苦痛止还得本心。尔时覆藏他罪至地了时。犯波罗夷。若比丘尼。地了时见他比丘尼犯波罗夷。于波罗夷中生疑。为波罗夷。为僧伽婆尸沙。为波逸提。为波罗提提舍尼。为突吉罗。后时断疑。于波罗夷中生波罗提提舍尼想。覆藏他罪至地了时。犯波罗夷。又比丘尼。日出时日出已。中前日中日昳。晡时日没日没已。初夜初分初夜中分初夜后分。中夜初分中夜中分中夜后分。后夜初分后夜中分后夜后分。见比丘尼犯波罗夷。于波罗夷中生疑。为波罗夷。为僧伽婆尸沙。为波逸提。为波罗提提舍尼。为突吉罗。后时断疑。于波罗夷中生波罗提提舍尼想。覆藏他罪至地了时。犯波罗夷。若僧与是比丘尼作不见摈不作摈恶邪不除摈。若是比丘尼狂心乱心病坏心。尔时覆藏不犯波罗夷。若僧与是比丘尼解摈。若苦痛止还得本心。尔时覆藏他罪至地了时。犯波罗夷。若比丘尼。地了时见他比丘尼犯波罗夷。于波罗夷中生疑。为波罗夷。为僧伽婆尸沙。为波逸提。为波罗提提舍尼。为突吉罗。后时断疑。于波罗夷中生突吉罗想。覆藏他罪至地了时。犯波罗夷。又比丘尼。日出时日出已。中前日中日昳。晡时日没日没已。初夜初分初夜中分初夜后分。中夜初分中夜中分中夜后分。后夜初分后夜中分后夜后分。见比丘尼犯波罗夷于波罗夷中生疑。为波罗夷。为僧伽婆尸沙。为波逸提。为波罗提提舍尼。为突吉罗。后时断疑。于波罗夷中生突吉罗想。覆藏他罪至地了时。犯波罗夷。若僧与是比丘尼作不见摈不作摈恶邪不除摈。若是比丘尼狂心乱心病坏心。尔时覆藏不犯波罗夷。若僧与是比丘尼解摈。若苦痛止还得本心。尔时覆藏他罪至地了时。犯波罗夷(七事竟)

佛在俱舍弥国。尔时众僧一心和合。与迦留罗提舍比丘作不见摈。是迦留罗提舍比丘。有姊妹比丘尼七人。一偷罗难陀尼。二周那难陀尼。三提舍尼。四优波提舍尼。五提舍域多尼。六提舍波罗那尼。七提舍罗叉多尼。是诸比丘尼。闻迦留罗提舍僧与作不见摈。往问迦留罗提舍言。僧实与汝作不见摈耶。答言。实作是。诸比丘尼言。汝莫下意软语折伏。我等当供养汝财物衣钵户钩时药夜分药七日药尽形药。若读经诵经问疑我等教汝。汝何故折伏。是中有比丘尼。少欲知足行头陀。闻是事呵责言。云何名比丘尼。知比丘一心和合僧作不见摈。独一无二无伴无侣。不休不息。随顺行。诸比丘尼如是呵已。向佛广说。佛以是事集二部僧。知而故问是诸比丘尼。汝等实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘尼。知比丘一心和合僧如法作不见摈。独一无二无伴无侣不休不息随顺行。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼。知是比丘一心和合僧如法作不见摈。独一无二无伴无侣不休不息随顺行。诸比丘尼。应如是谏是比丘尼。是比丘一心和合僧作不见摈。独一无二无伴无侣不休不息。汝莫随顺行。是比丘尼。诸比丘尼如是谏时。坚持是事不舍者。诸比丘尼。应第二第三谏令舍是事。第二第三谏时。若舍是事善。若不舍者。是比丘尼犯波罗夷不共住。知者。若自知若从他闻。若彼罪比丘自说。如法者。如法如毗尼如佛教摈。独一无二无伴无侣者。一切摈比丘尼独一无二无伴无侣。不休者。不下意不折伏。不息者。不舍恶邪见。随顺者。有二种。与财与法。诸比丘尼。应语是摈比丘。汝应折伏下意向大僧。汝若不折伏下意者。诸比丘尼僧。当作不礼拜不共语不供养羯磨。若是比丘折伏下意者善。若不折伏悔过者。诸比丘尼。应当一心和合与是比丘作不礼拜不共语不供养羯磨。羯磨法者。一心和合比丘尼僧。一比丘尼唱言。大德尼僧听。某甲比丘。一心和合僧作不见摈。独一无二无伴无侣不休不息。若僧时到僧忍听。与某甲比丘作不礼拜不共语不供养羯磨。是名白。如是白四羯磨。僧与某甲比丘作不礼拜不共语不供养羯磨竟。僧忍默然故。是事如是持。比丘尼僧。亦应如是语是随助比丘尼。是比丘一心和合。僧作不见摈。独一无二无伴无侣不休不息。汝等莫随顺助行。是比丘尼。诸比丘尼如是谏时坚持是事不舍者。诸比丘尼。应第二第三谏令舍是事。第二第三谏时舍是事善。若不舍者。是比丘尼犯波罗夷不共住。波罗夷者。是罪弊恶深重。退堕不如。若比丘尼犯是事者。不名沙门尼非释种女。失比丘尼法。不共住者。诸比丘尼不共作法事。谓白羯磨白二羯磨白四羯磨说戒自恣立十三比丘尼羯磨。是中犯者。若比丘尼僧。未作不礼拜不共语不供养羯磨。尔时比丘尼教是比丘经。若是偈说。偈偈突吉罗。若是章说。章章突吉罗。若是别句说。句句突吉罗。若摈比丘。教比丘尼读诵经若比丘尼受偈说。偈偈突吉罗。若受章说。章章突吉罗。若受别句说。句句突吉罗。若比丘尼与财供养与钵突吉罗。与衣突吉罗。与户钩时药夜分药七日药尽形药。皆突吉罗。若摈比丘。与比丘尼财供养。若与衣钵。比丘尼受者。皆突吉罗。若与户钩时药夜分药七日药尽形药。比丘尼受者。皆突吉罗。若比丘尼僧。作不礼拜不共语不供养羯磨竟。尔时比丘尼。教比丘读诵经。若是偈说。偈偈偷兰遮。若章说章章偷兰遮。若别句说。句句偷兰遮。若摈比丘。教比丘尼读诵经。若是偈说。偈偈偷兰遮。若章说。章章偷兰遮。若别句说。句句偷兰遮。若比丘尼。与摈比丘财供养若与钵。偷兰遮。若与衣偷兰遮。若与户钩时药。皆偷兰遮。夜分药七日药尽形药。皆偷兰遮。若摈比丘。与比丘尼财供养若与钵。比丘尼受者偷兰遮。若与衣户钩时药夜分药七日药尽形药。比丘尼受者。皆偷兰遮。诸比丘尼。先应软语教是随助比丘尼言。汝莫佐助摈比丘。莫随顺行。若软语时舍者。应教令作众多突吉罗众多偷兰遮悔过出罪。若软语不舍者。应与白四羯磨约敕。约敕法者。一心和合比丘尼僧。一比丘尼唱言。大德尼僧听。某甲比丘一心和合僧与作不见摈。独一无二无伴无侣不休不息。某甲比丘尼随助。已软语约敕不舍。若僧时到僧忍听。今僧约敕某甲比丘尼。是比丘。一心和合僧与作不见摈。独一无二无伴无侣不休不息。汝等比丘尼。莫随顺行。是名白。如是白四羯磨。僧约敕某甲比丘尼竟。僧忍默然故。是事如是持。如佛先说。是诸比丘尼应约敕。乃至三教令舍是事者。是名约敕。是名为教。是名约敕教。若软语约敕不舍者未犯。若初说未竟说竟。第二说说未竟说竟。第三说说未竟。若非法别众。非法和合众。似法别众。似法和合众。若如法别众。异法异律异佛教。若约敕不舍者未犯。若如法如律如佛教。三约敕竟不舍者。是比丘尼犯波罗夷(八波罗夷竟)

    十七僧残中不共戒有十之初(此初一事即十七中第四)

佛在舍卫国。尔时有比丘尼。名施越。年少端正。有一估客。见已生漏心。作是念。诸比丘尼王所守护。不得强为不净事。我当请供养所须。作是念已。便到是比丘尼所言。汝所须物。若饮食衣服卧具汤药所须。我当相给。比丘尼言。当受汝请。是比丘尼后时。所须饮食衣服卧具汤药薪草灯烛。皆从索取。估客知比丘尼心转柔软。便语比丘尼言。作淫事来。比丘尼言。莫作是语。我是持戒断淫欲人。估客嗔言。小婢汝若持戒断淫欲者。何故受我衣食供养。即便强捉比丘尼。比丘尼高声大唤。即时多人来集问言。何故大唤。估客言。是比丘尼受我衣食。不随我意。诸居士语比丘尼。汝受他物。何故不随他意。比丘尼言。我不为淫欲故受彼财物。是估客自来请我作是言。汝所须衣食汤药薪草灯烛自恣相给。我不知以何心故与我。诸居士言。是估客为是汝父亲里母亲里耶。比丘尼言。不是。诸居士言。若非汝父母亲。又非贤者不求福德。何故不知与汝财物。与汝财衣时必为淫欲事。诸居士呵责言。云何诸比丘尼自言。善好有功德。如淫女法取他财物。是中有比丘尼。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集二部僧。知而故问施越比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。有漏心。从漏心男子自手取食。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼有漏心。从漏心男子自手取食。是法初犯僧伽婆尸沙可悔过。漏心者。于是人边爱结深厚。男子漏心亦如是。男子者。谓人男能作淫事。食者五佉陀尼。五蒲阇尼。五似食。五佉陀尼者。根食茎食叶食华食果食。五蒲阇尼者。饭糗糒鱼肉。五似食者。糜粟[麩-夫+黃]麦莠子加师食。僧伽婆尸沙者。是罪属僧。僧中有残。因僧前悔过得除灭。故名僧伽婆尸沙。是中犯者。若比丘尼有漏心自手。从漏心男子手取根食。得僧伽婆尸沙。若取茎叶华果饭糗糒鱼肉糜粟[麩-夫+黃]麦莠子加师食。皆僧伽婆尸沙。若有居士。因是比丘尼故。与比丘尼僧作食。偏与所爱比丘尼多食。比丘尼受者偷兰遮(第四戒竟)

佛在王舍城。尔时有比丘尼。往语施越比丘尼言。若汝无漏心。男子有漏心。但从自手取食啖。若随意用。于汝何所能。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。语他比丘尼言。汝无漏心。男子有漏心。但从自手取食啖。若随意用。于汝何所能。种种因缘呵责已。向佛广说。佛以是事集二部僧。知而故问是比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责是比丘尼言。云何名比丘尼。劝他比丘尼言。汝无漏心。从漏心男子自手取食啖。若随意用。于汝何所能。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼言。若汝无漏心。从漏心男子自手取食啖。若随意用。于汝何所能。是法初犯僧伽婆尸沙可悔过。僧伽婆尸沙者。是罪属僧。僧中有残。因僧前悔过除灭。是名僧伽婆尸沙。是中犯者。若比丘尼语比丘尼言。汝有漏心。从漏心男子自手取食啖。若随意用。于汝何所能。僧伽婆尸沙若比丘尼语比丘尼言。若汝无漏心。漏心男子与汝食。但取啖随意用。于汝何所能。僧伽婆尸沙。若比丘尼语比丘尼言。若汝有漏心。漏心男子于汝何所能。汝莫从彼自手取食啖。莫随意用。偷兰遮。若比丘尼语比丘尼言。若汝无漏心。男子有漏心。于汝何所能。但莫自手取食啖。莫随意用偷兰遮(第五事竟)

佛在舍卫国。尔时有比丘尼。名跋陀。是加毗罗婆罗门女。跋陀比丘尼有姊死。往问讯姊夫。因为说法。遂至日没。比丘尼作是念。我若还精舍。恐道中有贼。即住居士舍。是居士思惟。此比丘尼不还去者。必欲得反戒。我当求令代其姊处。作是念已语比丘尼言。我舍多有财物珍宝。汝姊所有手脚头面庄严具悉在。我若更取余人作妇。则不能好看我儿。儿亦不爱乐。汝若欲反戒者。作我儿母。汝看我儿如儿。我儿等看汝如母。比丘尼作是念。若我违逆是语者。或强逼我。何不默然。即默然坐。居士心念谓欲反戒。但以姊新死故默然。中夜复作是语。后夜复作是语。地了时是比丘尼。从急恼处得脱。还至精舍。向诸比丘尼广说是事。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。一身独宿。种种因缘呵已。向佛广说。佛以是事集二部僧。知而故问跋陀比丘尼汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。一身独宿。种种因缘呵已语。诸比丘。以十利故。与比丘尼结戒。从今是戒应如。是说若。比丘尼一身独宿。乃至一夜是法初犯僧伽婆尸沙可悔过。夜者。从日没至地未了。是中间名夜。僧伽婆尸沙者。是罪属僧。僧中有残。因僧前悔过除灭。是名僧伽婆尸沙。是中犯者。若比丘尼。日没时一身独宿。至地了时犯僧伽婆尸沙。日没已。初夜初分初夜中分初夜后分。中夜初分中夜中分中夜后分。后夜初分后夜中分后夜后分。亦如是。又比丘尼。地了时一身独宿。乃至明日地了时。犯僧伽婆尸沙。若共行比丘尼。若反戒若死。若入外道。若八难中。随有一一难起。不犯(第六戒有四事中一事竟)

佛在舍卫国。尔时有比丘尼。名偷兰难陀。多知多识。喜入出诸家。是比丘尼早起着衣。入一家出一家。出一家复入一家。晡时来还大疲极。僧房中卧自言脚痛[跳-兆+專]痛胁痛背痛。语诸比丘尼。与我按摩。诸比丘尼言。善女。从何处来。答言。入某家出某家。出某家复入某家。问言。汝为佛事僧事耶。答言。不为。诸比丘尼言。若不为佛事僧事去者。何以故。为作是行得大疲极。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。昼日一身独行。种种因缘呵已。向佛广说。佛以是事集二部僧。知而故问偷罗难陀比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。昼日一身独行到白衣家。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼。若夜若昼。一身独行到白衣家。是法初犯僧伽婆尸沙可悔过。昼日者。从地了至日未没。是中间名昼日。是中犯者。若比丘尼一身独行。地了时去。至日没时来。犯僧伽婆尸沙。日出时日出已。中前日中日昳。晡时日没时去。日没已来还。皆僧伽婆尸沙。若共行比丘尼。若反戒若死。若入外道。若八难中。随有一一难起。不犯(二事竟)

佛在舍卫国。偷兰难陀比丘尼。喜见男子故。晨朝至城门下立。看男子出入谁好谁丑。见一男子出。端正生着心。问言。汝欲何去。答言。诣某聚落。偷兰难陀言。我共汝去。居士言。随意。是比丘尼于道中。共居士戏笑语言大唤。居士有因缘故入聚落。是比丘尼无事。于聚落外立待居士。居士又入第二聚落。比丘尼亦复在外立待。居士又入第三聚落。是比丘尼。晡时来还僧房中卧。语诸比丘尼言。我大疲极。脚痛[跳-兆+專]痛膝痛胁痛背痛。与我按摩。诸比丘尼言。汝从何来。答言。我从聚落至一聚落来。问汝为佛事僧事耶。答言。不为。诸比丘尼言。若不为佛事僧事去者。何故为作是行得大疲极。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。独一。身至余聚落。种种因缘呵已。向佛广说。佛以是事集二部僧。知而故问偷兰难陀比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。独一身往余聚落。种种因缘呵责已语诸比丘。从今是戒应如是说。若比丘尼。若夜若昼。一身独行往余聚落。初犯僧伽婆尸沙可悔过。行者。有二种。水道行陆道行。是中犯者。若比丘尼。陆道一人独行往余聚落。僧伽婆尸沙。中道还偷兰遮。若无聚落空地乃至一拘卢舍。僧伽婆尸沙。中道还偷兰遮。水道亦如是。若共行比丘尼。若反戒若死。若入外道若八难中随有一一难起。不犯(第五事竟)

佛在舍卫国。尔时诸比丘尼游行憍萨罗国向舍卫国。道中至河岸上住言。谁能先入水看深浅。是中有比丘尼。名修目佉。剿健多力。出婆罗门家。作是言。我能先入。即便入水渡到彼岸。水寻瀑涨不能得还。独彼岸宿。夜有贼来剥衣裸形。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责。云何名比丘尼。独彼岸宿。种种因缘呵责已。向佛广说佛以是事集二部僧。知而故问修目佉比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘尼。独彼岸宿。种种因缘呵已语诸比丘。从今是戒应如是说。若比丘尼。若夜若昼。若异聚落若异界。若渡河彼岸一身独宿。是法初犯僧伽婆尸沙可悔过河者。有二种。一者脱衣得渡。二者不脱衣得渡。有两岸中有水来去处随岸中流。是名为河。是中犯者若比丘尼。独一身脱衣渡河。僧伽婆尸沙。中道还偷兰遮。若二比丘尼共渡河。一渡一还渡者僧伽婆尸沙。还者偷兰遮。若比丘尼脱衣渡池水渡者偷兰遮。中道还者突吉罗。若二比丘尼共渡池水。一渡一还渡者偷兰遮还者突吉罗。若比丘尼褰衣渡河。渡者偷兰遮。中道还者突吉罗若二比丘尼褰衣渡河。一渡一还渡者偷兰遮。还者突吉罗。若比丘尼褰衣独渡池水渡者突吉罗。中道还者亦突吉罗。若二比丘尼褰衣渡池水。一渡一还渡者突吉罗。还者亦突吉罗。若从桥梁船渡不犯。若共渡比丘尼若反戒若死。若入外道。若八难中。随有一一难起。不犯(第六事竟)

佛在舍卫国。尔时诸比丘近婆只多城起僧坊是中渐渐多。有居士家围绕有象鸣马鸣大小男女音声故。妨诸比丘读经坐禅行道。是中有居士。名安阇那。有威德多饶财宝。人民田宅[王*車]磲马瑙。种种富贵相貌成就。诸比丘教令余处起僧坊。居士即于安阇那林中起僧坊。诸比丘舍近城僧坊。入安阇那林僧坊中住。诸比丘尼游行憍萨罗国向舍卫国。次到婆只陀城。故僧坊中宿。见其中床榻卧具盆器釜镬种种备具清净可住。诸比丘尼往语比丘言。诸大德已舍此僧坊者。我等当于中住。诸比丘言。随意。是僧坊主死。后诸儿分财物。是僧坊亦在分中。一儿得此僧坊者。往语比丘尼言。汝等出去。诸比丘尼言。何故使我等出耶。答言。我分得此僧坊。比丘尼言。我不从汝得。我从诸比丘得。若诸比丘使我出者。我当出。不随汝语。是中有比丘尼。名修目佉。是婆罗门种中出家。剿健多力。作强语共诤。居士儿不忍嗔故。便打比丘尼。是比丘尼即诣众官言。某甲儿打我。众官问言。何故打汝。比丘尼即广说上事。众官言。诸沙门释子不应失是僧坊。何以故。公与儿夺。儿与公夺。事不得尔。众官遣人召是儿来。问言。汝打比丘尼不。答言。实打。众官按法律捡校。打出家人应得何罪。律言。随所用身分即应截之。众官问言。汝以何物打。答言手打。又问何手。答言右手。即截右手。尔时恶名流布。诸沙门释女言人截他手。一人语二人。二人语三人。如是展转满婆只多城。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责。云何名比丘尼。言人令截他手。种种因缘呵已。向佛广说。佛以是事集二部僧。知而故问修目佉比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。言人令截他手。种种因缘呵已语诸比丘。以十利故。与诸比丘尼结戒。从今是戒应如是说。若比丘尼。诣王若官人若婆罗门若居士所。恃势言人者。是法初犯僧伽娑尸沙可悔过王者。刹利种受王位水浇顶。是名为王刹利水浇顶。若婆罗门若居士若女人受王职。亦名为王水浇顶。官人者。食官廪田宅。婆罗门者。婆罗门种中生。居士者。除王除官人除婆罗门。余不出家人。名为居士。恃势言人者。依他势力喜斗诤相言。僧伽婆尸沙者。是罪属僧。僧中有残。因僧前悔过除灭。是名僧伽婆尸沙。是中犯者若比丘尼。诣王若众官婆罗门居士。恃势力言人者。僧伽婆尸沙。若断事时。在断事人前嗔恨呵骂本所打人者。僧伽婆尸沙。若向余人。呵骂本所打人者。偷兰遮。若屏处嗔骂。不言者不犯(第七戒竟)

十诵律卷第四十二十诵律卷第四十三(第七诵之二)

        后秦北印度三藏弗若多罗共罗什译

    尼律第二(十七僧残中不共戒有十之余)

佛在舍卫国。尔时波斯匿王。有千斗将。半刹利种。半婆罗门种。一部名伊舍罗。一部名达多摩那。波斯匿王。有小国反叛。约敕千斗将。令往伐之。即往伐破还。白王言。我等得胜。愿王常胜王闻心欢喜悦。汝欲何愿。我当与汝。斗将白言。我妇有罪。不随我意。听六日与死饮至七日以牛舌刀破裂其身。王言。与汝此愿。尔时一刹利将妇不随夫意。欲六日与死饮至七日以牛舌刀裂破其身。是妇多有亲里力势来遮。不听与死饮。诸斗将法。一人有事余者尽助。刹利众集已。强与死饮。待至七日。以牛舌刀。裂破其身作两分。时有比丘尼名斯那。是摩那居士女。常是家出入。早起着衣入是家。见诸刹利妇澡浴庄严身着好衣服璎珞。是刹利妇独着垢衣不庄严身愁忧而坐。比丘尼问言。余妇皆着庄严好衣。汝何故独着垢衣。又不庄严愁忧而坐。答言。汝不闻邪。问言何等。答言。我不随夫意。今受六日死饮。至七日当以牛舌刀裂破我身作两分。汝能将我去不。我去谁当觉者。答言能。比丘尼即袈裟覆此妇。将走诣尼僧坊中与出家。后日诸刹利众集以牛舌刀欲杀。众人言。唤此妇来。即入舍觅不见。求觅不得。刹利众言。谁常出入是家。答言。有斯那比丘尼。常出入我。家或能将去。刹利众即往围绕王园比丘尼僧坊。刹利妇出家未久。诸比丘尼欲遮刹利众。是众中有年少刹利。不知罪福。作是言。一切比丘尼。皆应以牛舌刀破裂作两分。中有长老刹利言。比丘尼是王所守护。我等不宜横作恶事。或能不可。汝等小待。我先白王。王有所敕当随王教。诸比丘尼即诣末利夫人广说上事。夫人即向王说。王先知故于殿上坐。诸刹利往诣王所拜言。大王常胜。王言。我先与汝愿。汝今当与我愿。刹利众言。随大王所愿当与。王言。是刹利妇今已出家。便是更生。非刹利妇。刹利众言。今随王意当放去。王即遣使语比丘尼。诸善女。是事不是。汝等知是贼女应死。知王不听刹利不听。如是女人不应与出家。诸刹利若破汝等作两分者。我当云何。佛闻是事必当与汝等结戒。若比丘尼知是贼女决断堕死。众人皆知。王及刹利不听。不得度作弟子。是中有比丘尼。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集二部僧。知而故问斯那比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。知贼女决断堕死。度作弟子。种种因缘呵已语诸比丘以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼知贼女决断堕死。众人皆知。王及刹利众不听度作弟子。是法初犯僧伽婆尸沙可悔过。知者。若自知若从他闻。若贼女自说。贼者。有二种。一者偷夺财物。二者偷身堕死者作罪应死。众人知者。多人所知见闻。不听者。王不听活。刹利众不听者。二部不听活。僧伽婆尸沙者。是罪属僧。僧中有残。因僧前悔过除灭。是名僧伽婆尸沙。是中犯者。若和上尼知。阿阇梨尼知。比丘尼僧知。和上尼犯僧伽婆尸沙。阿阇梨尼偷兰遮。僧犯突吉罗。若和上尼知。阿阇梨尼知。僧不知。和上尼犯僧伽婆尸沙。阿阇梨尼偷兰遮。僧不犯。和上尼知。阿阇梨尼不知。僧不知。和上尼犯僧伽婆尸沙。阿阇梨尼及僧不犯。若都不知都不犯(第八事竟)

佛在俱舍弥国。尔时长老车匿母。作比丘尼。名忧婆和。妹作比丘尼。名阐提。阐提为人恶性。作不善行。常恼诸比丘尼。诸比丘尼欲为阐提作摈羯磨。是忧婆和。是众僧断事人。于僧中遮不得作羯磨。有时忧婆和余行不在。诸比丘尼言。我等今与阐提比丘尼作摈羯磨。有比丘尼言。忧婆和或能中间遮。更有比丘尼言。忧婆和已余处去。多知识卒未得还。诸比丘尼即打揵捶集尼僧。与阐提作摈羯磨。明日众人闻阐提比丘尼被摈。忧婆和比丘尼。还到其妹所。共相问讯。阐提言。莫共我语。问言何故。答言。诸比丘尼羯磨摈我忧婆和念言。是事不是。我作僧断。事人不在便强作摈。今我不能问诸比丘尼不取欲。出界外当与解摈。时忧婆和。不问诸比丘尼不取欲。即出界外为阐提解摈。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责。云何名比丘尼。知尼僧如法和合作羯磨摈比丘尼。不问比丘尼僧。不取诸比丘尼欲。出界外与他解摈。种种因缘呵已。向佛广说。佛以是事集二部僧。知而故问忧婆和比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘尼。知比丘尼僧如法作摈。不问比丘尼僧。亦不取欲。出界外与比丘尼解摈。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼。知比丘尼一心和合僧作不见摈。不问比丘尼僧。亦不取欲。出界外与他解摈。是法初犯僧伽婆尸沙可悔过。知者。若自知若从他闻。若彼自说。如法者。如法如毗尼如佛教摈。不问比丘尼僧者。不以是事白比丘尼僧。不取欲者。乃至不取四人欲。出界外者。众僧篱外壁外障外。解摈者。若自解若使他令解。僧伽婆尸沙者。是罪属僧。僧中有残。因僧前悔过除灭。是名僧伽婆尸沙。是中犯者。若和上尼知。作羯磨人知。僧知。和上尼犯僧伽婆尸沙。羯磨人犯偷兰遮。僧犯突吉罗。若和上尼知。羯磨人知。僧不知。和上尼犯僧伽婆尸沙。羯磨人犯偷兰遮。僧不犯。若和上尼知羯磨人不知。僧不知。和上尼犯僧伽婆尸沙。羯磨人及僧不犯。若一切不知不犯(第九事竟)

佛在舍卫国。尔时有比丘尼。名曰迦罗。本是外道。喜斗诤相言。是比丘尼。共余比丘尼斗诤时。作是言。我舍佛舍法舍僧舍戒。非但沙门释子知道。更有余沙门婆罗门。有惭愧善好乐持戒。我当从彼修梵行。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘。尼斗诤时作是言。我舍佛舍法舍僧舍戒。非但沙门释子知道。更有余沙门婆罗门。有惭愧善好乐持戒。我当从彼修梵行。种种因缘呵已。向佛广说。佛以是事集二部僧。知而故问迦罗比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。共斗诤时作是言。我舍佛舍法舍僧舍戒。不但沙门释子知道。更有余沙门婆罗门。有惭愧善好乐持戒。我当从彼修梵行。种种因缘呵已语诸比丘。以十利故与比丘尼结戒。从今是戒应如是说。若比丘尼共比丘尼斗诤时。作是言。我舍佛舍法舍僧舍戒。非但沙门释子知道。更有余沙门婆罗门。有惭愧善好乐持戒者。我当从彼修梵行。诸比丘尼应谏是比丘尼言。汝莫共诸比丘尼斗诤时作是言。我舍佛舍法舍僧舍戒。非但沙门释子知道。更有余沙门婆罗门。有惭愧善好乐持戒者。我当从彼修梵行。汝应佛法中乐修梵行。当舍离自不乐心。是比丘尼。诸比丘尼如是谏时。坚持是事不舍者。诸比丘尼应第二第三谏令舍是事。若是比丘尼。第二第三谏时舍者善。若不舍者。是法乃至三谏。僧伽婆尸沙可悔过。僧伽婆尸沙者。是罪属僧。僧中有残。因僧前悔过除灭。是名僧伽婆尸沙。是中犯者。若比丘尼言。我舍佛偷兰遮。若言舍法偷兰遮。若言舍僧偷兰遮。若言舍戒皆偷兰遮。若言非但沙门释子知道。更有余沙门婆罗门。有惭愧善好乐持戒。我当从彼修梵行。呵众僧故。得波逸提。诸比丘尼先应软语约敕。尔时舍者。应教四偷兰遮一波逸提悔过出罪。若软语不舍者。应白四羯磨约敕。约敕法者。僧一心和合。一比丘尼应唱言。大德尼僧听。是迦罗比丘尼。先是外道。今共诸比丘尼斗诤时。作如是言。我舍佛舍法舍僧舍戒。非但沙门释子知道。更有余沙门婆罗门。有惭愧善好乐持戒。我当从彼修梵行。已软语约敕不舍恶邪。若僧时到僧忍听。今僧约敕迦罗比丘尼。汝莫共诸比丘尼斗诤时作是言。我舍佛舍法舍僧舍戒。非但沙门释子知道。更有余沙门婆罗门。有惭愧善好乐持戒。我当从彼修梵行。是名白。如是白四羯磨。僧约敕某甲比丘尼竟。僧忍默然故。是事如是持。如佛先说。是比丘尼。诸比丘尼应约敕。乃至三谏令舍是事者。是名为约敕。是名为教。是名约敕教。若软语约敕不舍者未犯。初说说未竟说竟。第二说说未竟说竟。第三说说未竟。非法别众。非法和合众。似法别众。似法和合众。如法别众。异法异律异佛教。若约敕不舍者未犯。若如法如律如佛教。三约敕不舍者。是比丘尼犯僧伽婆尸沙(第十四事竟)

佛在舍卫国。尔时迦罗比丘尼。喜斗诤相言时。作是言。诸比丘尼僧。随爱行随嗔行随怖行随痴行。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。共斗诤时作是言。诸比丘尼僧。随爱行随嗔行随怖行随痴行。种种因缘呵已。向佛广说。佛以是事集二部僧。知而故问迦罗比丘尼言。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。共斗诤时作是言。诸比丘尼僧。随爱行随嗔行随怖行随痴行。种种因缘呵责已语诸比丘。以十利故。与诸比丘尼结戒。从今是戒应如是说。若比丘尼。共比丘尼斗诤时。作是言。比丘尼僧。随爱行随嗔行随怖行随痴行。是比丘尼。诸比丘尼应如是谏。汝莫共诸比丘尼斗诤时作是言。比丘尼僧。随爱行随嗔行随怖行随痴行。何以故。比丘尼僧。不随爱行。不随嗔行。不随怖行。不随痴行。汝比丘尼。舍是随爱语随嗔语随怖语随痴语。是比丘尼。诸比丘尼如是谏时。坚持是事不舍者。诸比丘尼应第二第三谏令舍是事。若第二第三谏时。舍是事者善。若不舍者。是比丘尼。乃至三练僧伽婆尸沙可悔过。僧伽婆尸沙者。是罪属僧。僧中有残。因僧前悔过除灭。是名僧伽婆尸沙。是中犯者。若比丘尼作是言。比丘尼僧。随爱行偷兰遮。随嗔行偷兰遮。随怖行偷兰遮。随痴行偷兰遮。诸比丘尼先应软语约敕。尔时舍者。应教作四偷兰遮悔过出罪。若软语不舍者。应白四羯磨约敕。约敕法者。一心和合僧。一比丘尼应僧中唱言。大德尼僧听。迦罗比丘尼。先是外道。今共诸比丘尼斗诤时。作是言。诸比丘尼。随爱行随嗔行随怖行随痴行。已软语约敕不舍。若僧时到僧忍听。今僧约敕迦罗比丘尼。汝莫共诸比丘尼斗诤时作是言。诸比丘尼。随爱行随嗔行随怖行随痴行。是名白。如是白四羯磨。僧约敕迦罗比丘尼竟。僧忍默然故。是事如是持。如佛先说。是比丘尼。诸比丘尼应约敕。乃至三谏令舍是事者。是名为约敕。是名为教。是名为约敕教。若软语约敕不舍者未犯。初说说未竟说竟。第二说说。未竟说竟。第三说说未竟。非法别众。非法和合众。似法别众。似法和合众。如法别众。异法异律异佛教。若约敕不舍者未犯。若如法如毗尼如佛教。三约敕不舍者。是比丘尼犯僧伽婆尸沙(第十五事竟)

佛在舍卫国。尔时有二比丘尼。一名达摩。二名昙弥同心共作恶业。有恶名声。常恼比丘尼僧。互相覆罪是中有比丘尼。少欲知足行头陀闻是事心不喜。种种因缘呵责言。云何名比丘尼。同心共作恶业。有恶名声。常恼比丘尼僧互相覆罪。种种因缘呵已。向佛广说。佛以是事集二部僧。知而故问达摩昙弥比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘尼。同心共作恶业。有恶名声。常恼比丘尼僧。互相覆罪。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若二比丘尼。同心共作恶业。有恶名声。常恼比丘尼僧。互相覆罪。是二比丘尼。诸比丘尼应如是谏汝等莫共同心共作恶业有恶名声常恼比丘尼僧互相覆罪。汝等各远离行。若汝等远离行者佛法得增长。汝等舍是随顺恶行。诸比丘尼如是谏时。是二比丘尼坚持是事不舍者。诸比丘尼应第二第三谏令舍是事。第二第三谏时舍者善。若不舍者。是法乃至三谏僧伽婆尸沙可悔过。二比丘尼作恶业者。作恶邪事身口恶业。有恶名声者。四方闻知。恼比丘尼僧者。乃至恼四比丘尼。互相覆罪者。共作不清净事。各相覆藏不令人知。僧伽婆尸沙者。是罪属僧。僧中有残。因僧前悔过除灭。是名僧伽婆尸沙。是中犯者。若二比丘尼同心共作不善因缘偷兰遮。有恶名声偷兰遮。恼比丘尼僧偷兰遮。互相覆罪偷兰遮。诸比丘尼先应软语教舍是事。若舍者。应教作四偷兰遮悔过出罪。若软语不舍者。应白四羯磨约敕。羯磨法者。一心和合僧。一比丘尼僧中唱言。大德尼僧听。是二比丘尼达摩昙弥。同心作恶业。有恶名声。常恼众僧。互相覆罪。已软语约敕不舍。若僧时到僧忍听。今僧约敕是二比丘尼。汝等莫同心作恶业有恶名声常恼比丘尼僧互相覆罪。是名白。如是白四羯磨。僧约敕竟。僧忍默然故。是事如是持。如佛先说。是比丘尼。诸比丘尼应约敕。乃至三谏令舍是事者。是名为约敕。是名为教。是名约敕教。若软语约敕不舍者未犯。初说说未竟说竟。第二说说未竟说竟。第三说说未竟。非法别众。非法和合众。似法别众。似法和合众。如法别众。异法异律异佛教。若约敕不舍者未犯。若如法如毗尼如佛教。三约敕不舍者。是比丘尼僧伽婆尸沙(第十六事竟)

佛在王舍城。尔时助调达诸比丘尼。往语达摩昙弥二比丘尼。作是言。汝等莫别离行。当同心行。若汝等别离行者不得增长。同心行者便得增长。比丘尼僧中亦有如汝等者。僧以嗔故。教汝别离行。是中有比丘尼。少欲知足行头陀。闻是事心不喜种种因缘呵责言。云何名比丘尼。往语达摩昙弥比丘尼言汝等莫别离行。当同心行。若别离行者不得增长。同心行者便得增长。比丘尼僧中亦有如汝等者。僧以嗔故。教汝别离行。种种因缘呵已。向佛广说。佛以是事集二部僧。知而故问助调达比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。往语达摩昙弥比丘尼言。汝等莫别离行。当同心行。若别离行者不得增长。同心行者便得增长。比丘尼僧中亦有如汝等者。僧以嗔故。教汝别离行。种种因缘呵责已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼教二比丘尼言。汝等莫别离行。当同心行。别离行者不得增长。同心行者便得增长。比丘尼僧中亦有如汝等者。僧以嗔故。教汝别离行。诸比丘尼。应如是谏是比丘尼。汝莫教是二比丘尼作是言。汝等莫别离行。当同心行。别离行者不得增长。同心行者便得增长。比丘尼僧中亦有如汝等者。僧以嗔故。教汝别离行。汝当舍是劝邪行事。诸比丘尼如是谏时。是比丘尼坚持是事不舍者。诸比丘尼应第二第三谏令舍是事。第二第三谏时舍者善。若不舍者。是法乃至三谏。僧伽婆尸沙可悔过。僧伽婆尸沙者。是罪属僧僧中有残因僧前悔过除灭。是名僧伽婆尸沙。是中犯者。若比丘尼劝二比丘尼言。汝等莫别离行偷兰遮。当同心行偷兰遮。若言别离行者不得增长偷兰遮。同心行者便得增长偷兰遮。若言比丘尼僧中亦有如汝等者。僧嗔故教汝别离行。呵责比丘尼僧故波逸提。诸比丘尼先应软语教舍者。应教作四偷兰遮一波逸提悔过出罪。若软语不舍者。应白四羯磨约敕。羯磨法者。一心和合僧。一比丘尼僧中唱言。大德尼僧听。是某甲比丘尼。教某甲二比丘尼。作是言。汝等莫别离行。当同心行。别离行者不得增长。同心行者便得增长。比丘尼僧中亦有如汝等者。但僧嗔故。教汝别离行。已软语约敕不舍。若僧时到僧忍听。今僧约敕某甲比丘尼。汝莫教某甲二比丘尼作是言。汝莫别离行。当同心行。别离行者不得增长。同心行者便得增长。僧中亦有如汝等者。僧以嗔故。教汝别离行。汝当舍是劝邪行事。是名白。如是白四羯磨。僧与某甲比丘尼约敕竟。僧忍默然故。是事如是持。如佛先说。是比丘尼。诸比丘尼乃至三谏令舍是事者。是名为约敕。是名为教。是名约敕教。若软语约敕不舍者未犯。初说说未竟说竟。第二说说未竟说竟。第三说说未竟。非法别众。非法和合众。似法别众。似法和合众。如法别众。异法异律异佛教。若约敕不舍者未犯。若如法如律如佛教。三约敕不舍者。是比丘犯僧伽婆尸沙(第十七事竟)

    尼三十舍堕法第三(此中十九同故不出余不同者具出之)

佛在王舍城。尔时有助调达比丘尼。多畜钵破坏不用。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。多畜钵破坏不用。种种因缘呵已。向佛广说。佛以是事集二部僧。知而故问助调达比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。多畜钵破坏不用。种种因缘呵责已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼畜长钵乃至一夜。过是畜者尼萨耆波逸提。一夜者。从日没至地未了。是中间名一夜。钵者。有三种。上中下。上钵者。受三钵他饭一钵他羹余可食物半羹。是名为上钵。下钵者。受一钵他饭半钵他羹余可食物半羹。是名下钵。上下中间。是名中钵。若过上减下不名钵。尼萨耆波逸提者。是钵应舍。波逸提罪应悔过。是中犯者。若比丘尼畜长钵。过一夜者。尼萨耆波逸提(第十九事竟前注既云同故不出此同比丘何独重出此但一夜彼过十日耳)

佛在舍卫国。尔时有善比丘尼是旧。助调达比丘尼是客。是住处得布施衣。安居僧应分。旧比丘尼言。是夏末后月。是住处受迦絺那衣此是时衣。安居僧应分。助调达比丘尼言。汝等不善知。虽夏末月受迦絺那衣。此是非时衣。现前僧应分。尔时助调达比丘尼。时衣作非时衣分。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。时衣作非时衣分。种种因缘呵已。向佛广说。佛以是事集二部僧。知而故问助调达比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。时衣作非时衣分。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼时衣作非时衣分。尼萨耆波逸提。尼萨耆波逸提者。是衣应舍。波逸提罪应悔过。是中犯者。若比丘尼时衣作非时衣分者。随分时随得尔所尼萨耆波逸提(第二十事竟)

佛在王舍城。尔时助调达比丘尼是旧。有善比丘尼是客。是中僧得布施衣。现前僧应分。客比丘尼言此非夏末月。是住处不受迦絺那衣。是衣应现前僧分。助调达比丘尼言。虽非夏末月不受迦絺那衣。然此是时衣。此安居僧应分。尔时助调达比丘尼。非时衣作时衣分。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。非时衣作时衣分。种种因缘呵责已。向佛广说。佛以是事集二部僧。知而故问助调达比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘尼。非时衣作时衣分。种种因缘呵已语诸比丘。以十利故与比丘尼结戒。从今是戒应如是说。若比丘尼非时衣作时衣分。尼萨耆波逸提。尼萨耆波逸提者。是衣应舍。波逸提罪应悔过。是中犯者。若比丘尼非时衣作时衣。分尼萨耆波逸。提随分时随得尔所尼萨耆波逸提(第二十一事竟)

佛在舍卫国。尔时偷兰难陀比丘尼。有弟子。名施越沙。善好有功德。偷兰难陀。与是弟子一割截衣。着诣祇洹。是比丘尼。与跋难陀知旧相识。跋难陀见是比丘尼来。于是衣中心生贪着。是比丘尼头面礼足一面坐。跋难陀言。善女。汝衣好可爱。比丘尼言。实好。跋难陀言。可以施我。比丘尼言。我不得与。跋难陀言。我当以衣与汝贸。比丘尼言。不能。跋难陀是大法师。辩才能善说法。即为说种种微妙法。令比丘尼生欢喜心。持割截衣与跋难陀。跋难陀即与一可可衣。比丘尼着是衣。入比丘尼精舍。和上尼问言。汝衣所在。答言。与他贸易。为与谁贸。答言。与跋难陀。和上尼言。跋难陀欺诳诱汝。弟子言。若诳若诱已与贸竟。和上尼言。是衣价大。汝今所著者价直甚少。弟子言。大价小价我以贸竟。和上尼言。可还取来。若不得者终身驱汝出。是弟子畏尽形驱出故。即往索衣言。本衣还我。我还汝衣。跋难陀言。我已贸竟。不还汝衣。施越沙言。汝诳我诱我。答言。若诳若诱我已贸竟。终不相还。施越沙言。若不还我割截衣者。和上尼尽形驱我。答言。若驱以不驱我已贸竟。是中有比丘尼。少欲知足行头陀。闻是事心不喜。呵责施越沙言。云何名比丘尼。与比丘贸衣。还悔言。我还汝衣汝还我衣。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问施越沙比丘尼。汝实作是事不答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。与比丘贸衣。还悔言。我还汝衣汝还我衣。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼与比丘贸衣。后到比丘所作是言。我还汝衣汝还我衣。尼萨耆波逸提。尼萨耆波逸提者。是衣应舍。波逸提罪应悔过。是中犯者。若比丘尼与比丘贸衣。后到比丘所作是言。我还汝衣汝还我衣。尼萨耆波逸提。若比丘尼后到比丘所言。汝衣还属汝。我衣虽非我许。但与我来。突吉罗(第二十二事竟)

佛在舍卫国。尔时众多居士居士妇。为偷兰难陀比丘尼故。各各办衣价作是言。我等以是衣价。买如是如是衣。与偷兰难陀。偷兰难陀闻已问诸居士。实尔不。答言实尔。问言。是衣何似。答言。如是如是。比丘尼言。善好。我等比丘尼贫穷。汝等不能常有施心。若不能得。各各办者。可共作如是如是一衣与我。诸居士言尔。诸居士先所办衣价。更出再三倍价买衣。与比丘尼竟。嗔呵责言。诸比丘尼不知时不知量。若施者不知量。受者应知量。我等先所办物。更再三倍出。我等不是失利。供养是难满难养无厌足人。是中有比丘尼。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集二部僧。知而故问偷兰难陀比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘尼。众多非亲里居士居士妇作同意。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若为比丘尼故。众多非亲里居士居士妇。各各办衣价作是言。我等持是衣价。各各买如是如是衣。与某甲比丘尼。是比丘尼先不请。后到众多居士居士妇所。作是言。汝等以是衣价。共买如是如是一衣与我。为好故。是比丘尼得衣者。尼萨耆波夜提。为比丘尼者。为偷兰难陀。非亲里者。亲里名父母兄弟乃至七世因缘。除是名非亲里。居士居士妇者。白衣男名居士。白衣女名居士妇。衣者。白麻衣赤麻衣刍麻衣翅夷罗衣钦婆罗衣劫贝衣憍施耶衣。衣价者。金银车磲马瑙乃至米谷。如是如是衣者。如是价如是色如是量。与某甲比丘尼者。与偷兰难陀。先不请者。众多居士居士妇。先不言汝有所须来至我家取。同心者。信是居士随我所索不嗔故。众多居士共买如是如是一衣与我为好者。难满难养无厌足故。若得是衣。尼萨耆波夜提。尼萨耆波夜提者。是衣应舍。波夜提罪应悔过。是中犯者。有三种。价色量。价者。若比丘尼到众多居士所言。汝等共买一钱直衣与我。若得衣者。三种。犯尼萨耆波夜提。三种者。若言与我一钱直衣。若言众共合。若言合买一衣。若不得突吉罗。若言二钱三钱乃至百钱直。得衣者。三种。犯尼萨耆波夜提。三种者。若言百钱直。若言众共合。若言共买一衣。不得者突吉罗。是名价。色者。若比丘尼语居士言。与我青衣。得者。三种犯尼萨耆波夜提。三种者。若言青。若言众共合。若共买一衣。不得者突吉罗。黄赤白黑赤麻白麻刍麻翅夷罗憍施耶衣钦婆罗劫贝衣。得衣者。三种犯尼萨耆波夜提。三种者。若言劫贝。若言众共合。若言共买一衣。不得者突吉罗。是名色。量者。若比丘尼言。与我四肘衣。得衣者。三种犯尼萨耆波夜提。三种者。若言与我四肘衣。若言众共合。若言共买一衣。不得者突吉罗。若言五肘六肘乃至十八肘衣。得衣者。三种犯尼萨耆波夜提。三种者。若言十八肘。若言众共合。若言共买一衣。不得者突吉罗。若比丘丘尼。乞异衣得异衣。若乞青衣得黄突吉罗。若乞青得赤白黑白麻赤麻刍麻衣翅夷罗衣憍施耶衣钦婆罗衣劫贝衣。皆突吉罗。如是等索异得异者突吉罗。若从亲里索。若自恣请。若不索自与。不犯(第二十三事竟)

佛在王舍城。尔时助调达比丘尼。自为身故乞金银。诸居士问言。汝出家人用金银为。汝比丘尼法。政应乞羹饭灯烛薪草。诸比丘尼言。汝等居士无所知。若乞饮食灯烛薪草者。乞名虽多所得利少。若乞金银者。乞名少所得利多。诸居士嗔呵责言诸比丘尼自言。善好有功德。自为乞金银。如王夫人大臣妇。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。从居士自为乞金银。种种因缘呵已。向佛广说。佛以是事集二部僧。知而故问助调达比丘尼言。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。自为身乞金银。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼自为身乞金银者。尼萨耆波夜提。尼萨耆波夜提者。是金银应舍。波夜提罪应悔过。是中犯者。若比丘尼自为乞金银。得尼萨耆波夜提。随乞随得尔所尼萨耆波夜提。若为佛图乞。若为僧乞。若不乞自与。不犯(第二十四事竟)

佛在舍卫国。尔时有比丘尼。名施越。多知多识。能多得酥油蜜石蜜。有一估客。见是比丘尼即请言。若汝所须酥油蜜石蜜者。到我舍取。比丘尼即受请。有一时。施越比丘尼到估客舍。作是言。我须酥。即与酥。便言。我不须酥。当与我油。复与油。又言。我须蜜。复与蜜。又言。我须石蜜。复与石蜜。又言。我不用石蜜。还与我酥。估客言。善女。汝欲觅我。何等过。适与是。便言不须。更与余者。又言不须。汝谓我独施汝耶。多人待我。以汝故妨尔所人。诸居士闻是事。呵责言。诸比丘尼自言。善好有功德。乞是适与。便言不须。如王夫人大臣妇。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。乞是适与。便言我不须。更索余物。种种因缘呵已。向佛广说。佛以是事集二部僧。知而故问施越比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。乞是与是。便言不须。更索余物。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼乞是已更索余者。尼萨耆波夜提。尼萨耆波夜提者是物应舍。波夜提罪应悔过。是中犯者。若比丘尼乞酥适与酥。便言不须酥。我须油蜜石蜜。尼萨耆波夜提若乞油与油。便言我不须油。与我蜜石蜜酥。尼萨耆波夜提。若比丘尼。乞蜜与蜜。便言我不须蜜。与我石蜜酥油。尼萨耆波夜提。若比丘尼。乞石蜜与石蜜。便言我不须石蜜。与我酥油蜜尼萨耆波夜提。所乞者未受。更取余者。尼萨耆波夜提(第二十五事竟)

佛在舍卫国。尔时诸比丘尼。乞财物欲作尼僧坊。诸居士问言。汝用作何等。答言。作比丘尼僧坊。有信婆罗门居士多与财物。是比丘尼得财物已值世饥俭。比丘尼作是思惟。今时俭世宜自活命。若我活者。后当作比丘尼僧坊。即于俭世食是物尽。饥俭世过丰乐时至。诸比丘尼复行乞物欲作僧坊。诸居士问言。用作何等。答言。作比丘尼僧坊。诸居士言。我等先所施物今何所在。答言。我先乞财物已值世饥俭。我等作是思惟。如今饥俭宜自活命。我若活者。后当作僧坊。我等饥俭时食此物尽。诸居士呵责言。诸比丘尼自言。善好有功德。为异事乞作异事用。如王夫人大臣妇是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责。云何名比丘尼。异乞异用。种种因缘呵已。向佛广说。佛以是事集二部僧。知而故问是比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。异乞异用。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼为僧事乞作余事用。尼萨耆波夜提。尼萨耆波夜提者。是物应舍。波夜提罪应悔过。是中犯者。若比丘尼为僧事乞作余事用。随用随得尔所尼萨耆波夜提(第二十六事竟)

佛在舍卫国。尔时诸比丘尼。行乞财物欲自作房。诸居士问言。用作何等。答言。欲自作房。有婆罗门居士信者。多与财物。诸比丘尼得财物已值世饥俭。作是思惟。今世饥俭宜自活命。若我活者。后当作房。即于俭世食是物尽。饥俭世过丰乐时至。诸比丘尼复行欲乞自作房。诸居士问言。欲作何等。答言。欲自作房舍。居士言。我先所与财物。今何所在。答言。我等先得财物。于饥俭世作是思惟。如今俭世宜自活命。若我等活者。后当起房舍。我等于饥俭时食此物尽。诸居士呵责言。诸比丘尼自言。善好有功德。自为是事乞作余事用。如王夫人大臣妇。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。异乞异用。如王夫人大臣妇。种种因缘呵已。向佛广说。佛以是事集二部僧。知而故问是比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。异乞异用种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼自为是事乞作余事用。尼萨耆波夜提。尼萨耆波夜提者。是物应舍。波夜提罪应悔过。是中犯者。若比丘尼自为是事乞作余事用。尼萨耆波夜提。随用时随得尼萨耆波夜提(第二十七事竟)

十诵尼律卷第四十三十诵律卷第四十四(第七诵之三)

        后秦北印度三藏弗若多罗共罗什译

    尼律第三(三十舍堕法之一)

佛在舍卫国。尔时诸比丘尼。行乞欲为多人作房舍。诸居士问言。欲作何等。答言。为多人起房舍。诸婆罗门居士有信者。多与财物。比丘尼得财物已值世饥俭。作是思惟。今世饥俭宜自活命。若我活者。后当为多人作房。即于俭世食是物尽。饥俭世过丰乐时到。诸比丘尼复行乞财物。诸居士问言。欲作何等。答言。欲作多人房舍。诸居士言。我等先所施物今何所在。答言。我等先所乞财物已值世饥俭。作是思惟。如今饥俭时宜自活命。若我活者。后当作多人房舍。我等于饥俭时食是物尽。诸居士呵责言。诸比丘尼自言。善好有功德。异乞异用。如王夫人大臣妇。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。异乞异用。种种因缘呵已。向佛广说。佛以是事集二部僧。知而故问是比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责是比丘尼。云何名比丘尼。异乞异用。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼为多人是事乞作余事用。尼萨耆波夜提。尼萨耆波夜提者。是物应舍。波夜提罪应悔过。是中犯者。若比丘尼为多人是事乞作余事用。尼萨耆波夜提。随用时随得尔所尼萨耆波夜提(二十八事竟)

佛在舍卫国。尔时有比丘尼。名达摩提那。于冬八夜寒风破竹。时着单薄衣行乞食。有估客。见是比丘尼。往语诸斗将言。汝得富乐。皆由达摩提那比丘尼因缘。汝等不能各各与比丘尼作厚衣耶。是比丘尼今冬八夜寒风破竹时。着单衣行乞食。汝等若不能各各作一衣与者。当共合作一衣与。估客令其发憍慢心故。皆言。当共作与。即唤比丘尼言。汝须何衣。随汝意与。是比丘尼言。我须五百钱直衣。时诸斗将随意买与。是比丘尼着贵价衣行乞食。诸居士呵责言。诸比丘尼自言。善好有功德。着贵价衣行乞食。如王夫人大臣妇。是中有比丘尼。少欲知足行头陀。闻是事心不喜。呵责言。云何名比丘尼。着贵价衣行乞食。种种因缘呵已。向佛广说。佛以是事集二部僧。知而故问达摩提那比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘尼。着贵价衣行乞食。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼欲乞重衣。乃至直四钱应乞。若过是乞者。尼萨耆波夜提。钱者。谓大钱乃至直十六小钱。尼萨耆波夜提者。是衣应舍。波夜提罪应悔过。是中犯者。若比丘尼乞过四钱重衣。尼萨耆波夜提。随乞随得尔所尼萨耆波夜提(二十九事竟)

佛在舍卫国。尔时冬寒过至热时。达摩提那比丘尼。着重衣头面流汗。眼闇而行乞食。有一估客。见已即往语诸斗将言。聚落主。汝等得富乐者。皆由达摩提那比丘尼因缘。汝等不能各各与作轻衣耶。是比丘尼今热时着重衣头面流汗眼闇而行乞食。汝等若不能各各作轻衣与者。当共合作一衣与。估客令诸斗将发憍慢心。皆言。当共作与。即唤比丘尼来问言。汝须何衣。随汝意与答言。我须二百五十钱直衣。时诸斗将随意买与。是比丘尼着是衣行乞食。诸居士呵责言。诸比丘尼自言。善好有功德。着贵价轻衣行乞食。如王夫人大臣妇。是中有比丘尼。少欲知足行头陀闻是事心不喜。种种因缘呵责言。云何名比丘尼。着贵价轻衣行乞食。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问是比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。着贵价轻衣行乞食。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼欲乞轻衣。应乃至直二钱半。过是乞者尼萨耆波夜提。钱者。谓大钱乃至直十六小钱。尼萨耆波夜提者。是衣应舍。波夜提罪应悔过。是中犯者。若比丘尼乞过二钱半轻衣。尼萨耆波夜提。随乞随得尔所尼萨耆波夜提(三十事竟)

    百七十八单波夜提法(前七十一与大僧同故不出从此第七十二戒已下一百七戒不同比丘故别明之)

初食蒜戒

佛在舍卫国。尔时有守蒜园人。名阿耆达多。是人蒜菜茂盛。请诸比丘尼言。须蒜者来取。时式叉摩尼沙弥尼。一年来拔蒜至二三年蒜园不成。即舍蒜园去。不能复种。更有居士。于故处种蒜。诸式叉摩尼沙弥尼。以本意故。复来拔蒜。是园主作是念。谁偷我蒜。我当伺捕。是居士即于屏处伺看。见诸式叉摩尼沙弥尼拔蒜。居士言。莫取我蒜。答言。舍卫城阿耆达多居士。请我取蒜。何豫汝事。是居士言。本田主以汝等因缘故。舍田而去。今我于中种蒜。汝等莫取。诸式叉摩尼沙弥尼羞。作是言。我等不知。自今以后不敢复取。诸居士嗔呵责言。诸比丘尼自言。善好有功德。啖蒜如白衣女。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。啖蒜如白衣女。种种因缘呵已。向佛广说。佛以是事集二部僧。知而故问是比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。啖蒜如白衣女。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼啖生蒜熟蒜波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼啖生蒜波夜提。啖熟蒜波夜提。若啖蒜子波夜提若啖茎叶波夜提。若啖蒜皮蒜须突吉罗。若治病若涂疮不犯(七十二事竟)

佛在舍卫国。尔时偷兰难陀比丘尼。使人剃大小便处毛。诸比丘尼问言。汝作何等。答言。剃大小便处毛。为好故。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。使人剃大小便处毛种种因缘呵已。向佛广说。佛以是事集二部僧。知而故问偷兰难陀。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。使人剃大小便处毛。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼剃大小便处毛波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼剃大便处毛波夜提剃小便处毛波夜提。除二处剃余处毛。突吉罗(七十三事竟)

佛在舍卫国。尔时偷兰难陀比丘尼。以指刺女根中。诸比丘尼问言汝作何等。答言。受细滑故。是中有比丘尼少欲知足行头陀。闻是事心不喜。呵责言。云何名比丘尼。以指刺女根中。受细滑故。种种因缘呵已。向佛广说。佛以是事集二部僧。知而故问偷兰难陀。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘尼。以指刺女根中。为细滑故。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼以指刺女根中波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼以指刺女根中。波夜提。随着随得尔所波夜提。一时有比丘尼。久不洗女根故臭烂。诸比丘尼以是事白佛。佛以是事集二部僧。赞戒赞持戒。赞戒赞持戒已语诸比丘。从今是戒应如是说。若比丘尼以指刺女根中。除洗时波夜提。是中犯者。若比丘尼不洗。以指刺女根中波夜提。随着随得尔所波夜提又比丘尼洗因缘故。以指深刺女根中。诸比丘尼以是事白佛。佛以是事集二部僧。语诸比丘。从今是戒应如是说。若比丘尼洗时。以指刺女根中。过二指节波夜提。是中犯者。若比丘尼以指刺女根中。洗时过二指节波夜提。随着随得尔所波夜提(七十四竟)

佛在舍卫国。尔时偷兰难陀比丘尼。以掌拍女根。诸比丘尼问言。汝作何等。答言。欲使肥好。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。以手掌拍女根欲使肥好。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问偷兰难陀。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘尼。以手掌拍女根欲使肥好。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼以掌拍女根波夜提。掌者。有二种。手掌脚掌。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼以手掌拍女根。波夜提。若以脚掌拍。亦波夜提。除手脚掌以余物拍。突吉罗(七十五竟)

佛在舍卫国。尔时有二比丘尼。一名罗吒二名波罗吒。本出贵家。是二比丘尼早起。行至诸亲里知识檀越家。得好饮食啖。皆言不美。问言。谁作此食。主人答言。厨士所作。比丘尼言。何以作无气味食。主人问言。汝能作不。比丘尼言能。若有好日欲作节会。若欲诣水上便来语我。我当为汝作饮食。后时主人好日至。欲入园中。便唤比丘尼。是比丘尼来为作饮食。是家中有客作食人。护厨到门下立。见有熟食。来出问言。谁煮是食。主人答言。有二比丘尼。一名罗吒。二名波罗吒。煮是食。客作食人嗔言。是失比丘尼法。烧比丘尼法。夺我生活业。是中有比丘尼。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集二部僧。知而故问二比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。煮生物作食。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼煮生物作食波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼煮生物作食波夜提。随煮随得尔所波夜提。不犯者。若重煮若有急因缘。以火净煮者不犯(七十六事竟)

佛在舍卫国。尔时有一居士。以无常因缘故。失财物田宅。家人死尽。唯有夫妇二人。居士作是念。诸福德乐人无衰恼者。无过沙门释子。我何不诣彼求出家。夫即诣祇洹作比丘。妇诣王园精舍作比丘尼。是比丘得食时。持食诣比丘尼精舍。是比丘尼先为办盘酱菜果蓏。待比丘来。时此比丘。持食诣比丘尼精舍坐食。此比丘尼起与酱菜。并说本居家中时事。比丘嗔不忍故。即以手中饭掷比丘尼面。比丘尼嗔故。以热羹浇比丘头。不净可羞。是中有比丘尼。少欲知足行头陀。闻是事心不喜。呵责言。云何名比丘尼。比丘食时在前立侍。种种因缘呵已。向佛广说。佛以是事集二部僧。知而故问是比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘尼。比丘食时在前立侍。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼比丘食时在前立侍波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼。比丘食时在前立侍波夜提。随立随得尔所波夜提。若与比丘食已还坐。若余处去不犯(七十七事竟)

佛在舍卫国。尔时偷兰难陀比丘尼。掷大小便墙外。是僧坊近大巷。时波斯匿王大臣名摩尼。着净衣服从是巷过。屎堕头上。是大臣尔时为王所责。有知相婆罗门。随大臣后行。婆罗门言。汝疾洗头还到王所。此是吉相。必得大利。大臣即洗头诣王所。王欢喜还复本职。诸比丘尼。闻偷兰难陀比丘尼以屎尿掷墙外。堕波斯匿王大臣头上。污大臣头故。王与本职。是摩尼大臣凶恶无慈。知当与我等作何苦恼事。以是思惟。怖畏故。除老病比丘尼。余皆走去。尔时摩尼大臣作是念。我得本职者。皆由比丘尼僧房因缘故。我当往安慰诸比丘尼。是摩尼大臣。即往比丘尼僧房。见诸比丘尼少。问诸老病比丘尼言。是中比丘尼僧何以故少。比丘尼言。汝不知耶。答言不知。比丘尼言。偷兰难陀比丘尼。以屎尿掷墙外。波斯匿王大臣摩尼。从此巷过。堕其头上。王与本职。是人凶恶无慈。诸比丘尼作是思惟。知当与我等作何等苦恼事。如是思惟。怖畏故。诸比丘尼皆悉走去。我等老病无力。故不能去。是大臣言。波斯匿王大臣摩尼者。即我身是。汝等莫怖畏。我与汝等饮食薪草灯烛衣服及无畏施。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。以屎尿掷墙外。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问偷兰难陀比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。以屎尿掷墙外。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼以屎尿掷墙外波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼以屎尿掷墙外波夜提。随掷随得尔所波夜提。若二比丘尼。共大小便一器中。一人举授一人掷墙外。举者突吉罗。掷者波夜提。若比丘尼。若以手掷波夜提。若以草土里掷墙外者。突吉罗(七十八事竟)

佛在舍卫国。尔时王园精舍。比丘尼僧房门前。有好生草。多有杂人在中集坐看诸比丘尼出入时形相。轻笑言。汝看是比丘尼睐眼。是眼烂是短鼻是瘿。是白是黑是好是丑。诸比丘尼闻是语心不喜。作是念。诸人集此中者。皆由生草茂盛好故。若无草者。不于中住。诸比丘尼集诸屎尿弃着草上。草即臭烂干死。诸居士呵责言。诸比丘尼不吉弊女。余无屏厕耶。于此净茂草处着大小便。是中有比丘尼。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集二部僧。知而故问是比丘尼。汝等实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。弃屎尿生草上。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼弃屎尿着生草上波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼弃屎尿生草上波夜提。随弃随得尔所波夜提(七十九事竟)

佛在王舍城。尔时助调达比丘尼。独与六群比丘。屏处共立共语。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种因缘呵责。云何名比丘尼。独与一比丘屏处共立共语。种种因缘呵已。向佛广说。佛以是事集二部僧。知而故问助调达比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。独与一比丘屏处共立共语。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼独与一比丘。屏处共立共语。波夜提。独者。一比丘尼一比丘。更无第三人。屏处者。若壁障若衣障篱障。共立者。可疑处。共语者。可疑处。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼独与一比丘。屏处共立共语波夜提。随共立共语。随得尔所波夜提(八十竟)

佛在王舍城。尔时助调达比丘尼。独与六群比丘。露地共立共语。是中有比丘尼。少欲知足行头陀闻是事心不喜。种种因缘呵责言。云何名比丘尼。独与一比丘。露地共立共语。种种因缘呵已。向佛广说。佛以是事集二部僧。知而故问助调达比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘尼。独与一比丘露地共立共语。种种因缘呵已语诸比丘。以十利故与比丘尼结戒。从今是戒应如是说。若比丘尼独与一比丘。露地共立共语。波夜提。独者。一比丘尼一比丘。更无第三人。露地者。无壁障无衣障无篱障。共立者。可疑处。共语者。可疑处。波夜提者。烧煮覆障若不悔过能障碍道。是中犯者。若比丘尼独与一比丘。露地共立共语。波夜提。随共立共语。随得尔所波夜提(八十一竟)

佛在王舍城。尔时助调达比丘尼。独与一白衣男子。屏处共立共语。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。独与一白衣男子。屏处共立共语。种种因缘呵已。向佛广说。佛以是事集二部僧。知而故问助调达比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘尼。独与一白衣男子。屏处共立共语。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼。独与一白衣男子。屏处共立共语。波夜提。独者。一比丘尼一白衣男子。更无第三人。屏处者。若壁障若篱障若衣障。共立者。可疑处。共语者。可疑处。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼独与一白衣男子。屏处共立共语。波夜提。随共立共语。随得尔所波夜提(八十二竟)

佛在王舍城。尔时助调达比丘尼。独与一白衣男子。露地共立共语。诸居士呵责言。看此等为是妇为是私通。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责。云何名比丘尼。独与一白衣男子。露地共立共语种种因缘呵已。向佛广说。佛以是事集二部僧。知而故问助调达比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。独与一白衣男子。露地共立共语种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼独与一白衣男子。露地共立共语。波夜提。共立者。可疑处。共语者。可疑处。波夜提者。烧煮覆障若不悔过能障碍道。是中犯者。若比丘尼独与一白衣男子。露地共立共语。波夜提。随共立共语。随得尔所波夜提(八十三竟)

佛在舍卫国。尔时王园比丘尼僧坊中。有客作人。日暮雨堕故。入助调达比丘尼房中。时助调达比丘尼。有大式叉摩尼。是客作人先不与期。夜中摩触式叉摩尼。式叉摩尼大唤。多比丘尼集问言。何故。式叉摩尼言。然灯。问言何故。但然灯来。即然灯来。见偷兰难陀比丘尼于闇中共男子坐。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责。云何名比丘尼。闇中无灯共男子坐。种种因缘呵责已。向佛广说。佛以是事集二部僧知而故问。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。闇中无灯共白衣男子坐。种种因缘呵已语诸比丘以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼闇中无灯。与男子共立共坐。波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼闇中无灯。与男子共立共坐。波夜提。随共立共坐。随得尔所波夜提(八十四事竟)

佛在舍卫国。尔时偷兰难陀比丘尼。以树胶作男根。系着脚跟。后着女根中。尔时失火。烧比丘尼房舍。偷兰难陀比丘尼。忘不解却走出房外。语诸居士言。是中失火。以水浇灭。有一估客。见偷兰难陀有如是事。语余人言。汝等看是比丘尼。有如是好庄严具。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责已。向佛广说。佛以是事集二部僧。知而故问。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。作男根着女根中。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼作男根着女根中。波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼。以树胶作男根着女根中。波夜提。若韦囊若脚指。若肉脔若藕根。若萝卜根若芜菁根。若瓜若瓠若梨。着女根中。皆波夜提。作时突吉罗。若着他比丘尼女根中。突吉罗(八十五事竟)

佛在舍卫国。尔时偷兰难陀比丘尼恶性喜嗔。诸善比丘尼善比丘尼不喜共住。诳一无智比丘尼言。汝来共我住。诸所须物我当与汝。是比丘尼答言。可尔。偷兰难陀比丘尼。喜出入他家多知多识。天雨堕时。早起至他家。从一家复至一家。日没时衣被皆湿。如阿罗罗鸟。还入房舍作是言。我脚痛[跳-兆+專]痛胁痛背痛。无智比丘尼言。汝从何来。答曰。我从某家出复到某家。曰汝为佛事为僧事耶。答言不为。若不为佛事僧事。何以雨中去。诸白衣多事。尚不于雨中出行。汝不善汝何以于雨中去。偷兰难陀比丘尼言。汝是我和上阿阇梨耶。何以教我。我前唤汝时。欲使汝教我耶。汝远出去。是比丘尼老病无力。偷兰难陀比丘尼强拽出垂死。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责云何名比丘尼。自唤他比丘尼言。善女来共我住。诸所须物我当与汝。后嗔拽出。种种因缘呵已。向佛广说。佛以是事集二部僧。知而故问偷兰难陀比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。自唤他比丘尼言。善女来共我住。诸所须物我当与汝。后嗔拽出。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼语比丘尼言。善女来共我房中住。后嗔不喜。若自拽出。若使人拽出作如是言。汝远灭去。莫此中住。以是因缘无异者。波夜提。波夜提者烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼嗔不喜。若自拽若使人拽。皆波夜提。不能拽出者突吉罗。随自拽出随使人拽。随得尔所波夜提。不能出者突吉罗(八十六事竟)

佛在王舍城。尔时助调达二比丘尼。共一床卧作种种不清净事。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。二人共一床卧。作种种不清净事种种因缘呵已。向佛广说。佛以是事集二部僧。知而故问助调达比丘尼。汝等实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。二人共一床卧。作种种不清净事。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若二比丘尼共一床卧波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若二比丘尼共一床卧波逸提。随共卧随得尔所波夜提。不犯者。若一人卧一人坐不犯(八十七事竟)

佛在王舍城。尔时助调达二比丘尼。共一敷卧。作种种不清净事。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。共一敷卧。种种因缘呵已向佛广说。佛以此事集二部僧。知而故问助调达比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。共一敷卧。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若二比丘尼共一敷卧波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若二比丘尼共一敷卧。波夜提。随共卧随得尔所波夜提。不犯者。若各各有别褥。不犯(八十八事竟)

佛在王舍城。尔时助调达二比丘尼。共一衣覆卧。作种种不清净事。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。二人共一衣覆卧。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问助调达比丘尼。汝等实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。共一衣覆卧。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若二比丘尼共一衣覆卧波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若二比丘尼共一衣覆卧波夜提。随共卧随得尔所波夜提。不犯者。若各各别有衬身衣。不犯(八十九事竟)

佛在王舍城。尔时助调达比丘尼入檀越舍。独与六群比丘共立共语窃语。遣共行比丘尼去。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责。云何名比丘尼。入白衣舍。独与一比丘。共立共语窃语。种种因缘呵已。向佛广说。佛以是事集二部僧。知而故问助调达比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。入白衣舍。独与一比丘。共立共语窃语。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼入白衣舍。独与一比丘共立共语窃语。遣共行比丘尼去。求闲便故波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼入白衣舍。独与一比丘共立突吉罗。共语突吉罗。共窃语突吉罗。求闲便故。遣共行比丘尼离闻处去波逸提。不离闻处突吉罗(九十事竟)

佛在王舍城。尔时助调达比丘尼入白衣舍。独与白衣男子共立共语窃语。遣共行比丘尼去。求闲便故。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。入白衣舍。独与一白衣男子。共立共语共窃语。遣共行比丘尼去。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问是比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。入白衣舍。独与一白衣男子。共立共语共窃语。遣共行比丘尼去。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼入白衣舍。独与一白衣男子。共立共语窃语。遣共行比丘尼去。求独语故波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼入白衣舍。独与一男子共立突吉罗。共语突吉罗。共窃语突吉罗。求独语故。遣共行比丘尼离闻处去波夜提。不离闻处突吉罗(九十一事竟)

佛在舍卫国。尔时迦罗比丘尼。本是外道。共诸比丘尼斗诤相嗔。自打身啼。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。共比丘尼斗诤相嗔。自打身啼。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问迦罗比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘尼。共比丘尼斗诤相嗔。自打身啼。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼。共比丘尼斗诤相嗔。自打身啼者波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼。共诸比丘尼斗诤相嗔。自打身啼波夜提。若自打身不啼。得突吉罗。随打身啼。随得尔所波夜提(九十二事竟)

佛在舍卫国。尔时迦罗比丘尼。本是外道。共诸比丘尼斗诤时。自作法咒泥犁咒。若汝谤我是事者。令汝不得四念处四正勤四如意足五根五力七觉八道。令汝世世堕地狱畜生饿鬼。若我有是事者。令我不得四念处四正勤四如意足五根五力七觉八道。当世世堕地狱畜生饿鬼。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。共比丘尼斗诤时。作法咒泥犁咒。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问迦罗比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。共比丘尼斗诤时。作法咒泥犁咒。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼。共比丘尼斗诤时。作法咒泥犁咒波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼。共比丘尼斗诤时。作法咒泥犁咒。作是言。若汝以是事谤我者令汝不得四念处波夜提。不得四正勤四如意足五根五力七觉八道。皆波夜提。若言汝当世世堕地狱波夜提堕畜生饿鬼皆波夜提。若言我有是事者令我不得四念处四正勤四如意足五根五力七觉八道皆波夜提。若言我世世堕地狱畜生饿鬼皆波夜提。随作是语。随得尔所波夜提(九十三事竟)

佛在舍卫国。尔时偷兰难陀比丘尼。有共行弟子名施越沙。善好乐持戒。喜忘师教。令举物时。着异处余处求。须是物时。觅不能得。又时偷兰难陀比丘尼从聚落还。弟子施越沙往迎。欲代持衣钵。却身不与。施越沙即嗔。语诸比丘尼言。我不偷夺。和上尼不信我诸比丘尼言。云何不信。师行来还。我于道中迎。欲代持钵却身不与。我欲代持衣。又却身不与。诸比丘尼往语偷兰难陀比丘尼言。汝弟子善好持戒。何故不信。答言。我云何不信。诸比丘尼言。汝弟子欲代汝持钵。汝却身不与。欲代汝持衣。又却身不与。偷兰难陀比丘尼言。我非不信。是人喜忘。举物异处便余处觅。若须物时觅不能得。是故不与。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。不审谛看物便嫌恨。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问施越沙比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。不审谛看物便嫌恨。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼不审谛看物便嫌恨波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼不审谛看物便嫌恨波夜提。随嫌恨随得尔所波夜提(九十四事竟)

佛在王舍城。与多比丘僧。王舍城安居。舍利弗目连阿那律难提金毗罗等。是诸大弟子皆共佛安居。尔时诸比丘尼夏中游行。到他国土行时。杀诸生草小虫。诸居士嗔呵责言。佛与大众舍利弗目连阿那律难提金毗罗等。王舍城安居。是诸比丘尼自言善好有功德。夏中游行诸国。杀诸生草小虫。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。夏中游行诸国。杀诸生草小虫。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问诸比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。夏中游行诸国。杀诸生草小虫。佛以种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼夏中无因缘游行他国波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼夏中无因缘游行他国波夜提。随游行随得尔所波夜提(九十五事竟)

佛在王舍城。自恣竟二月游行他国。舍利弗目连阿那律难提金毗罗等诸大弟子。皆从佛游行他国。是诸比丘尼住不去。诸居士呵责言。佛在王舍城。自恣竟二月游行他国。与大弟子舍利弗目连阿那律难提金毗罗等游行。诸比丘尼不去。不善小女。不欲出是房舍。是中有比丘尼。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集二部僧。知而故问诸比丘尼。汝等实尔不。答言。实尔世尊。佛以种种因缘呵责言。云何名比丘尼。自恣竟不游行余处一宿。种种因缘呵已语诸比丘。以十利故与比丘尼结戒。从今是戒应如是说。若比丘尼自恣竟。不游行余处一宿波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼自恣竟。不游行余处一宿波夜提。随不去随得尔所波夜提(九十六事竟)

十诵尼律卷第四十四十诵律卷第四十五(第七诵之四)

        后秦北印度三藏弗若多罗共罗什译

    尼律第四(百七十八单提之二)

佛在舍卫国。尔时憍萨罗国主波斯匿王。有小国反。王集四种兵。象兵马兵车兵步兵。集四种兵已王自往伐。诸比丘尼。从憍萨罗国游行向舍卫国。道中见是军。是比丘尼众中。有长老知法比丘尼言。我等小避。诸年少比丘尼言。何故避去。波斯匿王信佛法。王子只陀居士给孤独尼师达多富罗那等。皆信佛法。谁能遮我等者。但当直去。语已直去。为前军人所剥脱裸形。诸比丘尼白王言。前行军人剥脱我等。王言。此兵众我悉供给聚落金银廪赏尔乃斗耳。今夺汝衣不可还得。今国土内有兵众。汝等何以游行。若佛闻者。必当与汝结戒。国内疑处畏处不应游行。是中有比丘尼。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集二部僧。知而故问诸比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。国内疑处畏处游行。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼国内疑处畏处游行波逸提。波逸提者烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼国内疑处畏处游行。波逸提。随游行随得尔所波逸提(九十七事竟)

佛在王舍城。尔时阿阇世王国界边。有小国反。集四种兵。象兵马兵车兵步兵。集四种兵已王自往伐。诸比丘尼。从跋耆国向王舍城。道中见王军。是中有长老比丘尼知法。遥见军来言。我等避去。诸年少不知法比丘尼言。何苦是。阿阇世王信佛法。阿婆跋陀童子耆婆童子阿卢耶。皆信敬佛法。我等但当直去。语已直去。为前行军人剥脱裸形。诸比丘尼白王言。前行军人剥脱我等。王言。此诸兵众我悉供给聚落金银廪赏尔乃斗耳。今夺汝等衣不可还得。今国外疑处畏处。汝等何以游行。若佛闻是事。必当与汝等结戒。诸比丘尼国外疑处畏处不应游行。是中有比丘尼。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集二部僧。知而故问诸比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。国外疑处畏处游行。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼国外疑处畏处游行波逸提。波逸提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼国外疑处畏处游行波逸提。随游行。随得尔所波逸提(九十八事竟)

佛在舍卫国尔时迦罗比丘尼。本是外道。喜行游观。是比丘尼早起。到天祠中伎乐舍论法舍出家舍看画彩舍。诸居士呵责言。诸比丘尼自言善好有功德。故往看画舍。如外道女。是中有比丘尼。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集二部僧。知而故问迦罗比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。故往看画舍。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼故往看画舍波逸提。波逸提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼。故往看画舍。能得见者波逸提。不得见者突吉罗。若从下至高处。能得见者波逸提。不得见者突吉罗。若从高至下。能得见者波逸提。不能得见者突吉罗。若不故往道由中过者。不犯(九十九事竟)

佛在王舍城。尔时助调达比丘尼旧住。有善好比丘尼是客。时旧比丘尼往迎。与持衣钵共相问讯。与汤洗足与油涂足与好床榻客比丘尼言。然灯。旧比丘尼言。欲作何等。客比丘尼言。初夜当坐禅诵经呗咒愿。旧比丘尼言。汝等行路疲极但当卧。作是语已。即便自卧。客比丘尼作是念。我等云何初夜不坐禅不诵经呗不咒愿便卧。即然灯坐禅诵经呗咒愿竟欲卧。助调达比丘尼闻声已觉问言。善女。汝作何物。答言。我等坐禅诵经呗咒愿竟欲卧。旧比丘尼言。诸善女。睡无果无报。佛赞不睡眠呵责睡眠。今我等觉不卧不睡眠。即展一脚坐。善比丘尼思惟。我等云何于灯明中卧。旧比丘尼于中夜分坐禅诵经呗咒愿。至后夜分便卧。客比丘尼作是思惟。我等云何于后夜分卧。客比丘尼道路疲极。竟夜不得卧故。身体不安。是中有比丘尼。少欲知足行头陀。闻是事心不喜。呵责言。云何名比丘尼。先住者恼后住者。种种因缘呵责已向佛广说。佛以是事集二部僧。知而故问是比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。先住恼后住者。佛以种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼先住恼后住者波逸提。波逸提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼先住恼后住者。波逸提。随恼随得尔所波逸提(一百事竟)

佛在舍卫国。尔时诸善比丘尼是旧。助调达比丘尼是客。时旧比丘尼见客比丘尼来。出迎问讯代担衣钵。与汤洗脚以油涂足与床卧具。旧比丘尼言。善女然灯。客比丘尼言。莫然灯。我道路疲极。不得坐禅诵经呗咒愿。我等欲卧。旧比丘尼思惟。我等云何初夜不坐禅不诵经呗不咒愿便卧。即起然灯坐禅诵经呗咒愿已欲卧。客比丘尼闻是声觉作是言。善女欲作何等。答言。我等坐禅竟欲卧。客比丘尼言。睡眠无果无报。佛赞叹不睡眠法呵责睡眠。我等觉今不睡。即然灯坐禅。旧比丘尼思惟。我等云何灯明中卧。客比丘尼中夜分坐禅竟。至后夜分便卧。旧比丘尼思惟。我等云何后夜分卧。以是故竟夜不卧。身不安隐。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。后住恼前住者。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问客比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。后住恼先住比丘尼。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼后住恼前住者波逸提。波逸提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼后住恼前住者波逸提。随恼随得尔所波逸提(一百一事竟)

佛在舍卫国。尔时偷兰难陀比丘尼。有共活比丘尼病苦。偷兰难陀比丘尼弃到余聚落。恐须供给看病人故。诸比丘尼往到病比丘尼所言。偷兰难陀所有作事。汝悉与作。汝今病苦。云何看汝病。比丘尼言。偷兰难陀比丘尼。当能供给我耶。恐须看我故。弃舍我去。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。共活比丘尼病苦。弃至余聚落。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问偷兰难陀。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。共活比丘尼病苦。弃至余聚落。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼。共活比丘尼病苦不供给波逸提。波逸提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼。共活比丘尼病苦不供给波逸提。随不供给随得尔所波逸提(一百二事竟)

佛在舍卫国。尔时长老大迦叶中前着衣持。钵入一居士家。为乞食故。时所立处有居士妇。遥见大迦叶即起出迎。偷兰难陀先在其家。遥见大迦叶不起往迎。是居士妇以手接足。头面礼长老摩诃迦叶已。洗手取钵。盛满饭以羹浇上与。大迦叶持去。居士妇到偷兰难陀所言。汝知是长老大迦叶。是佛大弟子。天人所敬良祐福田。汝若起迎者有何恶事偷兰难陀言。大迦叶本是外道婆罗门。汝所贵敬。非我所尊。居士妇嗔呵责言。诸比丘尼自言善好有功德。见比丘来不起。如外道女。是中有比丘尼。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集二部僧。知而故问。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。见比丘来不起。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼见比丘来不起波逸提。波逸提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼见比丘来不起。波逸提。随见不起。随得尔所波逸提(一百三事竟)

佛在舍卫国。尔时长老迦留陀夷。常出入一家。中前着衣持钵到其舍。有比丘尼。名瘦瞿昙弥。先在是家。遥见迦留陀夷来。即起出迎入示坐处共相问讯头面礼足前叉手立。迦留陀夷为说法久。是比丘尼迷闷眼闇倒地。居士妇即以水洒面还得本心。居士妇言。汝何所患苦。何所忧愁。答言。我无病无忧愁。但久立住故。迷闷倒地。诸比丘尼以是事白佛。佛以是事集二部僧。种种因缘赞戒赞持戒。赞戒赞持戒已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼。不问比丘便坐者波逸提。波逸提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼。不问比丘辄坐者。波逸提。随不问坐。随得尔所波逸提(一百四事竟)

佛在舍卫国。尔时诸比丘尼。欲游行他国。白王言。我等欲游行他国。王当为我约敕诸国。莫令人民遮道恼我。王即遣使约敕四方。莫恼诸比丘尼。供给所须饮食灯烛。诸比丘尼游行次。到无僧坊聚落。至一居士家欲宿。谓居士言。汝出舍去。我于中宿。居士言。善女。我在自舍。教我何去。比丘尼重言。汝但出去。汝欲恼我欺我耶。汝若不去者。我有官力。令汝得恼。居士作是思惟。诸比丘尼为王所护。有官力势。或当恼我。作是念已怖畏即出。是居士老瘦无力。于冬寒时出舍垂死。诸居士呵责言。云何诸比丘尼自言善好有功德。不问主人便敷卧处。如王夫人大臣妇。是中有比丘尼。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集二部僧。知而故问。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。不问主人便敷卧具。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼。不问主人便敷卧具。若使人敷波逸提。波逸提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼。不问主人若自敷卧具波逸提。若使人敷波逸提。随不问自敷使人敷。随得尔所波逸提(一百五事竟)

佛在舍卫国。尔时诸比丘尼。欲共诸比丘等。作是言。汝等五岁不依止他。我等亦如是。汝等十岁畜弟子。我等亦尔。有何差别。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责。向佛广说。佛以是事集二部僧。知而故问诸比丘尼。汝等实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。轻大众。种种因缘呵已语诸比丘。从今听诸比丘尼受大戒满六岁不依止他。不满六岁依止他。十二岁得畜众。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼。不满十二岁畜众者波逸提。波逸提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼。不满十二岁畜众者。波逸提。随畜随得尔所波逸提(一百六事竟)

佛在舍卫国。尔时偷兰难陀比丘尼。满十二岁欲畜众。语诸比丘尼。我受大戒满十二岁。今欲畜众。当作何等。诸比丘尼以是事白佛。佛言。汝等当为偷兰难陀比丘尼作畜众羯磨。若更有如是比丘尼。亦应与作畜众羯磨。畜众羯磨法者。一心和合比丘尼僧。偷兰难陀比丘尼。应从坐起偏袒右肩脱革屣。胡跪合掌作如是言。大德尼僧听。我偷兰难陀比丘尼。受大戒满十二岁。欲畜众。我今从僧乞畜众羯磨。僧为我偷兰难陀比丘尼作畜众羯磨。僧怜愍故。第二第三亦如是乞。尔时一比丘尼。应僧中唱言。大德尼僧听。是偷兰难陀比丘尼。受大戒满十二岁。欲畜众。是偷兰难陀比丘尼。从僧乞畜众羯磨。若僧时到僧忍听。僧今与偷兰难陀比丘尼作畜众羯磨。是名白。如是白四羯磨。僧与偷兰难陀比丘尼作畜众羯磨竟。僧忍默然故。是事如是持。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼满十二岁。未作畜众羯磨。畜众者波逸提。波逸提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼满十二岁。未作畜众羯磨。畜众者波逸提。随畜随得尔所波逸提(一百七事竟)

佛在舍卫国。尔时偷兰难陀比丘尼。畜不满十二岁已嫁女作众。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。畜未满十二岁已嫁女作众。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问偷兰难陀比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。畜未满十二岁已嫁女作众。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼。畜未满十二岁已嫁女作众。波逸提。波逸提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼。畜未满十二岁已嫁女作。众波逸提。随畜随得尔所波逸提(一百八事竟)

佛在舍卫国。尔时偷兰难陀比丘尼。满十二岁已嫁女。未作属和上尼羯磨。便畜作众。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责。云何名比丘尼。满十二岁已嫁女。未作属和上尼。羯磨。便畜作众。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。满十一岁已嫁女。未作属和上尼羯磨。便畜作众。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼。满十二岁已嫁女。未作属和上尼羯磨。便畜作众。波逸提。波逸提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼。满十二岁已嫁女。未作属和上尼羯磨。便畜作众。波逸提。随畜随得尔所波逸提(一百九事竟)

佛在舍卫国。尔时偷兰难陀比丘尼。畜众不教诫不为说法。弟子白言。和上尼。何以不教化我。不为我说法。答言。我不教化汝。不为汝说法。弟子以是事向诸比丘尼说。诸比丘尼以是事向佛广说。佛以是事集二部僧。知而故问偷兰难陀比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。畜众不教化。不为说法。种种因缘呵已。语诸比丘尼。汝等为偷兰难陀作止羯磨。若更有如是者。亦应与作止羯磨。作止羯磨法者。一心和合僧。一比丘尼僧中唱言。大德尼僧听。偷兰难陀比丘尼。畜弟子不教化。不为说法。若僧时到僧忍听。僧与偷兰难陀作止羯磨。汝偷兰难陀。莫复畜众。是名白。如是白二羯磨。僧与偷兰难陀作止畜众羯磨竟。僧忍默然故。是事如是持。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼僧与作止羯磨。畜众者波逸提。波逸提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼僧与作止羯磨。畜众者波逸提。随畜众。随得尔所波逸提(一百一十事竟)

六法坛文

佛在舍卫国。尔时舍卫城有居士妇。名和罗诃。大富多财田宅种种富相成就。是居士妇。以无常因缘故。财物失尽家人分散。唯一身在。是居士妇有娠。以忧愁失亲里财物夫婿故。身自枯瘦儿胎。缩小便作是念。我腹中儿若死若烂又作是念。诸福德乐人。无过沙门释子。我当是中出家作比丘尼。便往诣王园精舍作比丘尼。是人出家欢乐。肥故腹渐渐大。诸比丘尼驱出僧坊。汝犯淫人莫住此间。答言。我出家以来不作淫欲。先在家时有娠。诸比丘尼以是事向佛广说。佛语诸比丘尼。汝莫说是比丘尼是事。是比丘尼非破梵行。先白衣时有娠。从今听沙弥尼二岁学六法。可知有娠无娠。受六法者。若沙弥尼初来。应教次第头面一一礼僧足。礼已次应乞和上尼。戒师应教言。我沙弥尼某甲。求尊为我作和上尼。尊为我作和上尼故僧。当与我二岁学戒。第二亦应言。我沙弥尼某甲。求尊为和尚尼。尊为我作和尚尼故。僧当与我二岁学戒。第三亦应言。我沙弥尼某甲。求尊为和尚尼。尊为我作和尚尼故。僧当与我二岁学戒。一比丘尼应问和上尼。能为某甲作和上尼不。若言能。即应将至界场内。着眼见处离闻处。尔时应问。僧和合不。僧一心和合。当作僧事。是和上尼某甲。沙弥尼某甲。僧当与二岁学戒。第二亦应言。僧一心和合。当作僧事。是和尚尼某甲。沙弥尼某甲。僧当与二岁学戒。第三亦应言。僧一心和合。当作僧事。是和尚尼某甲。沙弥尼某甲。僧当与二岁学戒。若僧一心和合者。应唤沙弥尼来。教一一礼比丘尼僧足。头面礼足已。次应教令从僧乞二岁学戒作是言。我沙弥尼某甲。因和上尼某甲。从僧乞二岁学戒。因和上尼某甲。僧当与我二岁学戒。和上尼某甲。怜愍故。第二亦应言。我沙弥尼某甲。因和上尼某甲。从僧乞二岁学戒。因和上尼某甲。僧当与我二岁学戒。和上尼某甲。怜愍故。第三亦应言我沙弥尼某甲。因和上尼某甲。从僧乞二岁学戒。因和上尼某甲。僧当与我二岁学戒。和上尼某甲怜愍故。即时戒师应僧中唱言。大德尼僧听。是沙弥尼某甲。因和上尼某甲。从僧乞二岁学戒。和上尼名某甲。若僧时到僧忍听。僧与沙弥尼某甲二岁学戒。和上尼某甲。如是白。大德尼僧听。是沙弥尼某甲。从僧乞二岁学戒。和上尼某甲。僧今与沙弥尼某甲二岁学戒。和上尼某甲。谁诸尼僧忍。与沙弥尼某甲二岁学戒。和上尼某甲者默然。若不忍者说。是名初羯磨。第二更说。大德尼僧听。是沙弥尼某甲。从僧乞二岁学戒。和上尼某甲。僧今与沙弥尼某甲二岁学戒。和上尼某甲。谁诸尼僧忍。与沙弥尼某甲二岁学戒。和上尼某甲者默然。若不忍者说。是名第二羯磨。第三更说。大德尼僧听。是沙弥尼某甲。从僧乞二岁学戒。和上尼某甲。僧今与沙弥尼某甲二岁学戒。和上尼某甲。谁诸尼僧忍。与沙弥尼某甲二岁学戒。和上尼某甲者默然。若不忍者说。是名第三羯磨。僧已忍。与沙弥尼某甲二岁学戒。和上尼某甲竟僧忍默然故。是事如是持。即时为说式叉摩尼六法。汝式叉摩尼听。佛世尊多陀阿竭度阿罗诃三耶三佛陀。是知者见者。说式叉摩尼六法。汝式叉摩尼。尽形受行。佛世尊种种因缘。呵欲欲想欲欲欲觉欲热。佛说断欲除欲想灭欲热。若式叉摩尼。入式叉摩尼法。不舍戒戒羸不出。相随心想受淫欲乃至共畜生。是非式叉摩尼。非沙弥尼。非释女。失式叉摩尼法。是事尽形不应作。若能持者当言能。佛世尊以种种因缘呵责偷夺。赞叹不偷夺。乃至一条缕。一寸纳一渧油。不与不应取。是中佛制。极少至五钱。若五钱直。若式叉摩尼随所偷事。若王捉若打若缚若摈出。若作是言。汝贼汝小儿汝痴汝堕官罪。若式叉摩尼如是偷夺者。非式叉摩尼。非沙弥尼。非释女。失式叉摩尼法。是事尽形不应作。若能持者当言能。佛世尊种种因缘呵责杀生。赞叹离杀。乃至蚁子向不应故夺命。何况于人。若式叉摩尼。故自手夺人命。若与刀若教死叹死。作是言。咄人用恶活为。死胜生。随是人意。种种因缘教死叹死。若作忧多杀。作头多杀。作网作弶作拨。若作毗陀罗杀。若作似毗陀罗杀。若断气杀。若堕胎杀。若按腹杀。若推着火中。推着水中。若从高推下。若遣使道中杀。若母腹中初受二根。身根命根迦罗罗中。生恶心方便令夺命。若以是因缘死者。是非式叉摩尼。非沙弥尼。非释女。失式叉摩尼法。是事尽形不应作。若能持者当言。能佛以种种因缘呵责妄语。赞叹不妄语。乃至戏笑尚不应妄语。何况故妄语。若式叉摩尼不知不见过人法。自言我如是知如是见。我是阿罗汉向阿罗汉。我是阿那含向阿那含。若斯陀含向斯陀含。若须陀洹向须陀洹。若得初禅第二禅第三禅第四禅。若得慈悲喜舍无量心。若得无色空处定识处定无所有处定非想非非想处定。若得不净观阿那般那念。诸天来到我所。诸龙夜叉薜荔伽毗舍阇鸠槃茶罗刹来到我所。彼问我我答彼。我问彼彼答我。若式叉摩尼如是妄语者。非式叉摩尼。非沙弥尼。非释女。失式叉摩尼法。是事尽形不应作。若能持者当言能。佛以种种因缘。呵欲欲想欲欲欲觉欲热。佛说断欲除欲想灭欲热。若式叉摩尼有漏心。听漏心男子边。发际至腕。膝已上裸身。受细滑。若顺身摩若逆摩。若推若牵。若从下抱着上。从上抱着下。若捺疮。是非式叉摩尼。非沙弥尼非释女失式叉摩尼法。若犯者可更受。是中尽形寿不应作。汝能持不。若能持当言能。佛以种种因缘。呵欲欲想欲欲欲觉欲热。赞叹断欲除欲想灭欲热。若式叉摩尼漏心。听漏心男子边。若受捉手若捉衣。若共立。若共语。若共期。若入屏处。若待男子。若自身与。如在家女法。以此八事自身与。是非式叉摩尼。非沙弥尼。非释女。失式叉摩尼法。若犯可更受。是中尽形寿不应作。汝能持不。若能当言能。汝某甲听。僧已与汝学戒法。式叉摩尼受持六法。名式叉摩尼。汝得具满和上尼。具满阿阇梨尼。具满比丘尼僧。得具满行处。得具满国土。得转轮王愿。汝今已满。当恭敬三宝佛宝法宝僧宝和上尼阿阇梨尼。恭敬上中下座。当勤三学善戒学善定学善慧学。当修三脱门空无相无作。当勤三业坐禅诵经劝化作福行。是诸法开涅槃门。得须陀洹果斯陀含果阿那含果阿罗汉果。如莲华在水中日日增长开敷。汝亦如是增长道法。后当受具足戒

  释师子法中　　已获难得戒
  无难时难得　　已得勿使空
  头面礼僧足　　右绕欢喜去

以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼弟子。不二岁学六法。畜为众者波逸提。波逸提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼弟子。不二岁学六法。便畜为众波逸提。随畜随得尔所波逸提(一百一十一事竟)

佛在舍卫国。尔时偷兰难陀比丘尼。弟子二岁学六法。未作属和上尼羯磨。便畜为众。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。弟子二岁学六法。未作属和上尼羯磨。便畜为众。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问偷兰难陀比丘尼。汝实作是事不。答言实作世尊。佛以种种因缘。呵责云何名比丘尼。弟子二岁学六法。未作属和上尼羯磨。便畜为众。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼。弟子二岁学六法。未作属和上尼羯磨。便畜为众。波逸提。波逸提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼。弟子二岁学六法者。未作属和上尼羯磨。便畜为众。波逸提。随畜随得尔所波逸提(一百一十二事竟)

佛在舍卫国。尔时诸比丘尼。为畜众故受勤苦。为浣衣染衣割截篸摓。弟子受大戒竟。舍和上尼去。诸比丘尼闻是事。呵责言。是不吉弊女。我为汝作衣浣衣染衣割截篸摓。受大辛苦受大戒已便舍我去。种种因缘呵已。向佛广说。佛以是事集二部僧。语诸比丘。从今听比丘尼二岁随逐和上尼。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼受大戒已。不二岁随和上尼波逸提。波逸提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼受大戒已。不二岁随和上尼。波逸提。随不随逐和上尼。随得尔所波逸提(一百一十三事竟)

佛在舍卫国。尔时偷兰难陀比丘尼。畜众不与财法。诸弟子言。和上尼何不与我等财法。偷兰难陀比丘尼言。我不与汝等财法。诸弟子言。若不以财法与我等者。当余处去。偷兰难陀言。佛结戒。汝等应二岁随逐我。若余处去得波逸提罪。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。畜弟子不与财法。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问。汝实作是事不。答言实作世尊。佛以种种因缘呵责言。云何名比丘尼。畜弟子不与财法。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼畜弟子不与财法波逸提。波逸提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼畜众不与财法波逸提。随不与随得尔所波逸提(一百一十四事竟)

佛在舍卫国。尔时偷兰难陀比丘尼。畜淫女为众。是淫女比丘尼。中前着衣持钵。入舍卫城乞食。是中有居士。作是言。我曾共是比丘尼。作如是如是事。此比丘尼闻是事心不喜。向诸比丘尼说。诸比丘尼以是事向佛广说。佛以是事集二部僧。知而故问偷兰难陀比丘尼。汝实作是事不。答言实作世尊。佛以种种因缘呵责言。云何名比丘尼。畜淫女为众。种种因缘呵已语诸比丘。从今不应畜淫女为众。畜者突吉罗。若有因缘畜者。应将远本处。五由延若六由延。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼畜淫女为众。不远本处五六由延。波逸提。波逸提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼畜淫女为众。不远本处五六由延。波逸提。随不远去。随得尔所波逸提(一百一十五事竟)

佛在舍卫国。尔时偷兰难陀比丘尼。畜未满二十岁童女为众。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。畜未满二十岁童女为众。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问偷兰难陀比丘尼。汝实作是事不。答言实作世尊。佛以种种因缘呵责。云何名比丘尼。畜未满二十岁童女为众。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼。畜未满二十岁童女为众。波逸提。波逸提者。烧煮覆障。若不悔过若障碍道。是中犯者。若比丘尼畜未满二十岁童女为众波逸提。随畜随得尔所波逸提(一百一十六事竟)

佛在舍卫国。尔时偷兰难陀比丘尼。未作属和上尼羯磨。畜二十岁童女为众。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责。云何名比丘尼。未作属和上尼羯磨。畜二十岁童女为众。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问偷兰难陀比丘尼。汝实作是事不。答言实作世尊。佛以种种因缘呵责。云何名比丘尼。未作属和上尼羯磨。畜满二十岁童女为众。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼。满二十岁童女。未作属和上尼羯磨。畜为众者。波逸提。波逸提者。烧煮覆障。若不悔过能障碍道。是中犯者若比丘尼未作属和上尼羯磨。畜满二十岁童女为众波逸提。随畜随得尔所波逸提(一百一十七事竟)

佛在舍卫国。尔时偷兰难陀比丘尼。畜孝女为众。是孝女比丘尼。不诵经不问答不坐禅。诸比丘尼问言。汝何以故。不读诵经问答坐禅。答言。诸善女。我父死若母死兄弟死姊妹儿女死夫婿死故忧愁。云何能读诵经问答坐禅。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责云何名比丘尼。畜孝女为众。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问偷兰难陀比丘尼。汝实作是事不。答言实作世尊。佛以种种因缘呵责言。云何名比丘尼。畜孝女为众。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼畜孝女为众。波逸提。波逸提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼畜孝女为众波逸提。随畜随得尔所波逸提(一百一十八事竟)

佛在舍卫国。尔时偷兰难陀比丘尼。畜有男女自随女人为众。是比丘尼。中前着衣持钵。男女前后围绕共行乞食。诸居士共相谓言。汝知不。诸沙门释子作淫欲人。共比丘尼。僧坊中生儿女。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。畜将男女自随女人为众。种种因缘呵责已向佛广说。佛以是事集二部僧。知而故问偷兰难陀比丘尼。汝实作是事不。答言实作世尊。佛以种种因缘呵责。云何名比丘尼。畜将男女自随女人为众。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼。畜有男女自随女人为众。波逸提。波逸提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼畜有男女自随女人为众波逸提。随畜随得尔所波逸提(一百一十九事竟)

佛在舍卫国。尔时偷兰难陀比丘尼。畜恶性女人为众。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。畜恶性女为众。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问偷兰难陀比丘尼。汝实作是事不。答言实作世尊。佛以种种因缘呵责。云何名比丘尼。畜恶性女人为众。种种因缘呵已语诸比丘。以十利故与比丘尼结戒。从今是戒应如是说。若比丘尼。畜恶性女人为众。波逸提。波逸提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼畜恶性女人为众。波逸提。随畜随得尔所波逸提(一百二十事竟)

佛在舍卫国。尔时偷兰难陀比丘尼。满二十岁童女。不二岁学六法。畜为众。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。满二十岁童女不二岁学六法畜为众。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问偷兰难陀比丘尼。汝实作是事不。答言实作世尊。佛以种种因缘呵责。云何名比丘尼满二十岁童女不二岁学六法畜为众。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼满二十岁童女不二岁学六法畜为众者。波逸提。波逸提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼满二十岁童女不二岁学六法畜为众者波逸提。随畜随得尔所波逸提。尔时诸比丘尼。不知云何为六法。佛言。共四波罗夷。及发际至腕膝已上。受八事示贪着相是名六法(一百二十一事竟)

佛在舍卫国。尔时偷兰难陀比丘尼。满二十岁童女二岁学六法。不作属和上尼羯磨畜为众。是中有比丘尼。少欲知足行头陀闻是事心不喜。种种因缘呵责。云何名比丘尼。满二十岁童女二岁学六法。不作属和上尼羯磨畜为众。种种因缘呵责已向佛广说。佛以是事集二部僧。知而故问偷兰难陀比丘尼。汝实作是事不。答言实作世尊。佛以种种因缘呵责。云何名比丘尼。满二十岁童女二岁学六法。不作属和上尼羯磨。便畜为众。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼满二十岁童女二岁学六法。不作属和上尼羯磨。便畜为众者。波逸提。波逸提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼。满二十岁童女二岁学六法。不作属和上尼羯磨。便畜为众波逸提。随畜随得尔所波逸提(一百二十二事竟)

十诵尼律卷第四十五十诵律卷第四十六(第七诵之五)

        后秦北印度三藏弗若多罗共罗什译

    百七十八单提法之三

佛在王舍城。尔时助调达比丘尼。常入出他家。有居士妇言。汝度我出家。比丘尼言。汝与我钵。我当度汝。与我衣户钩时药时分药七日药尽形药。我当度汝出家。居士妇言。汝等客作度人耶。是比丘尼言尔。他日诸善比丘尼。至是居士舍。居士妇问言。汝等实客作度人耶。善比丘尼言。谁作是语。居士妇言。我语助调达比丘尼。汝当度我出家。便语我言。与我钵来。我当度汝。与我衣户钩时药时分药七日药尽形药。我当度汝。是中有比丘尼。少欲知足行头陀。闻是事心不喜呵责言。云何名比丘尼。作是言。汝与我钵。与我衣户钩时药时分药七日药尽形药。我当度汝。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问助调达比丘尼。汝实作是事不。答言实作世尊。佛以种种因缘呵责。云何名比丘尼。作是言。汝与我钵衣来户钩时药时分药七日药尽形药。我当度汝。佛种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼作是言。若汝与我钵衣户钩时药时分药七日药尽形药。我当度汝波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼作是言。汝与我钵衣户钩时药时分药七日药尽形药。我当度汝。皆波夜提。随作是语。随得波夜提(一百二十三事)

佛在舍卫国。尔时舍卫国。居士有妇不随夫教。以手脚打驱出自舍。有比丘尼常入出是家。妇往至比丘尼所。是居士到余聚落。作是念。我妇将无走去耶。还舍觅不得。居士念言。我妇必往至比丘尼精舍。居士复作是念。置使在彼令好调伏。后当将还。是妇五六日住已。语所知识比丘尼。善女何不度我。答言。汝婿尚在。云何度汝。妇言。夫不用我。若须我者。应当自来。亦当遣使。比丘尼即度令出家。是居士闻妇出家。嗔恚语妇师言。汝恶比丘尼贼比丘尼。汝破我家。何故破汝家。答言。夺我妇作比丘尼。比丘尼言。此是汝妇汝便将去。诸居士呵责言。诸比丘尼自言善好有功德。主不听便度他妇。如王夫人大臣妇。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。主不听便度他妇。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问是比丘尼。汝实作是事不。答言实作世尊。佛以种种因缘呵责。云何名比丘尼。主不听便畜为众。种种因缘呵责已。语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼。女人主不听畜为众者。波夜提。主不听者。有三种若未嫁女父母不听。若已嫁未至夫家者。尔时两边不听。若已至夫家。夫主不听。波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼夫主不听便度波夜提。随不听度。随得波夜提(一百二百四事竟)

佛在王舍城。尔时助调达比丘尼。有大式叉摩尼。可受大戒。施越沙比丘尼。见是大式叉摩尼。即便语言。汝何不受大戒。答言。助调达比丘尼凶恶喜斗。我不欲从彼受大戒。汝若与我作和上尼者。我当受大戒。施越沙言。汝二岁学六法。我当畜汝为众。是大式叉摩尼二岁学六法已。语施越沙言。汝语我二岁学六法。我当畜汝为众。我已二岁学六法。汝当畜我。施越沙言。我不畜汝。何以故。是助调达比丘尼。凶恶喜斗诤。自能伤他亦能教人作。以是故我不畜汝。又言。汝若不能畜我。何以语我二岁学六法。若汝先不语我者。我不二岁学六法。是中有比丘尼。少欲知足行头陀。闻是事种种因缘呵责言。云何名比丘尼。语他言。汝二岁学六法。我当畜汝。后便不畜。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问是比丘尼。汝实作是事不。答言实作世尊。佛以种种因缘呵责言。云何名比丘尼。语他言。汝二岁学六法。我当畜汝。后便不畜。种种因缘呵已语诸比丘。以十利故。与诸比丘尼结戒。从今是戒应如是说。若比丘尼语他言。汝二岁学六法。后当畜汝。若不畜者波夜提波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼语他言。汝二岁学六法。我当畜汝。后便不畜者波夜提。随不畜随得波夜提(一百二十五事竟)

佛在舍卫国。尔时偷兰难陀比丘尼。岁岁度弟子。语诸弟子言。我所入处。汝等皆随我入。若我有所得者。汝亦当得。偷兰难陀比丘尼。一时着衣持钵行乞食。入一家得满钵去。次弟子入。又得满钵去。第二第三亦复次入。居士不能复与。即闭门作是言。谁能与是诸不吉比丘尼食。是中有比丘尼。少欲知足行头陀闻是事心不喜向佛广说。佛以是事集二部僧。知而故问。汝实作是事不。答言实作世尊。佛以种种因缘呵责偷兰难陀比丘尼。云何名比丘尼。岁岁度弟子。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼岁岁度弟子者。波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼岁岁度弟子者波夜提。随岁岁度随得波夜提。不犯者。若隔岁度一若度二者不犯(一百二十六事竟)

比丘尼坛文

佛在舍卫国。尔时有迦毗罗女作比丘尼。名跋陀。有式叉摩尼。可受大戒。尔时阿难。常为比丘尼差十比丘众。与受大戒。时阿难中前着衣持钵入舍卫城乞食。跋陀比丘尼。遥见阿难舍卫城乞食。往到其所。头面礼足一面住。白言。大德阿难。我有式叉摩尼可受大戒。愿差十比丘众。阿难问言比丘尼僧。作乞属和上尼羯磨未答言已作何时作耶。答言昨日作。阿难即默然受。跋陀比丘尼。知阿难受已。头面礼足而去。阿难乞食食已到祇洹。持户钩游行。从一房至一房。佛遥见阿难持户钩从房至房游行。佛知故问阿难。汝何故持户钩游行从房至房。阿难白言世尊。跋陀比丘尼。有式叉摩尼。可受大戒。语我差十比丘众。我今欲差。是故持户钩游行诸房。佛问阿难。诸比丘尼。作乞属和上尼羯磨未。答言已作。何时作耶。答言昨日作。佛知故问阿难。诸比丘尼。用宿作乞属和上尼羯磨。欲畜众耶。答言。用宿作世尊。佛以是事集二部僧。知而故问跋陀比丘尼。汝实作是事不。答言实作世尊。佛以种种因缘呵责。云何名比丘尼。用宿作乞属和上尼羯磨畜众。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼宿作乞属和上尼羯磨畜众者。波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼用宿作乞属和上尼羯磨畜众者波夜提。随畜随得波夜提。佛虽如是听受大戒法。诸比丘尼不知云何受。佛言。受具足法者。比丘尼初来。将式叉摩尼入尼僧中。教人人头面礼僧足竟。尼羯磨师。应教受衣钵。问此衣是汝有不。答言是。应教效我语。我某甲。是衣僧伽梨若干条受。割截衣持。第二是衣僧伽梨。若干条受。条受。割截衣持。第三是衣僧伽梨若干条受。割截衣持。次问。此衣是汝有不。答言是。我某甲。是衣郁多罗僧七条受。两长一短割截衣持。第二是衣郁多罗僧七条受。两长一短割截衣持。第三是衣郁多罗僧七条受。两长一短割截衣持。次问此衣是汝有不。答言是。我某甲。是衣安陀会五条受。一长一短割截衣持。第二是衣安陀会五条受。一长一短割截衣持。第三是衣安陀会五条受。一长一短割截衣持。若僧伽梨缦。是僧伽梨缦衣受持。若郁多罗僧缦。是郁多罗僧缦衣受持。安陀会缦。是衣缦安陀会受持。次教言。此衣覆肩衣受是是汝有不。答言是。应教言此衣覆肩衣受。长四肘广二肘半。是覆肩衣持。第二此衣覆肩衣受。长四肘广二肘半。是覆肩衣持。第三此衣覆肩衣受。长四肘广二肘半。是衣覆肩衣持。次教。此衣厥修罗受。长四肘广二肘半。此衣厥修罗衣持。第二此衣厥修罗受。长四肘广二肘半。此衣厥修罗衣持。第三此衣厥修罗受。长四肘广二肘半。此衣厥修罗衣持。次问言。此钵多罗。是汝有不。答言是。应教言。我某甲。此钵多罗应量受。长用故。第二此钵多罗应量受。长用故。第三此钵多罗应量受。长用故。受衣钵已。次教令乞属和上尼。我某甲式叉摩尼。求尊为和上尼。愿尊。为我作和上尼。我某甲。因尊和上尼故。僧当与我作乞属和上尼羯磨。怜愍故。第二我某甲。求尊为和上尼。愿尊。为我作和上尼。我某甲。因尊和上尼故。僧当与我作乞属和上尼羯磨。怜愍故。第三我某甲。求尊为和上尼。愿尊。为我作和上尼。我某甲。因尊和上尼故。僧当与我作乞属和上尼羯磨。怜愍故应问和上尼能不。若言能应教着见处离闻处。即时尼羯磨师。应僧中如是唱谁能为某甲作教师。若有一比丘尼言我能。佛言。是比丘尼有五法。不应令作教师。何等五。随爱教随嗔教随怖教随痴教不知教不教。若成就五法。应作教师。何等五法。不随爱教不随嗔教不随怖教不随痴教知教不教。即时应唱言。大德尼僧听。是式叉摩尼某甲。从和上尼某甲欲受具足戒。比丘尼某甲。能为作教师。教某甲故。若僧时到僧忍听。比丘尼某甲为教师。教某甲故。如是白。大德尼僧听。是某甲式叉摩尼。从和上尼某甲欲受具足戒。某甲能作教师。教某甲。谁诸尼僧忍。立某甲为教师。教某甲者默然。谁不忍便说。僧已立某甲为教师。教某甲竟。僧忍默然故。是事如是持(已被羯磨者应往教正衣服右膝着地合掌而问言)

汝某甲听。今是至诚时实语时。后尼僧中亦如是我今问汝。若实者当言实。若不实当言不实。我今问汝。汝是女不。是人不。非是非人不。非畜生不。非是不能女不。女根上有毛不。不枯坏不。无[病-丙+帶]下病不。非偏不。不二道合不。女根不小不。非是不能产不。非是无乳不。非是一乳不。非是恒有月水不。非无月忌不。非婢不。非客作不。非买得不。非破得不。非兵妇不。非吏妇不。非犯官罪不。不负他物不。女人有如是等病。癞病痈疽病。痟尽病癫狂病长热病。无如是等病不。父母夫主在不。父母夫主听出家不。五衣钵具不。汝字何等。和上尼字谁。答言。我字某甲。和上尼名某甲(尼教师问竟应白僧是式叉摩尼某甲我已问竟尼羯磨师应言若清净者将来更一一礼尼僧足已)

次教乞属和上尼羯磨。羯磨法者。我某甲从和上尼某甲欲受具足戒。我今从僧乞属和上尼羯磨。和上尼某甲。僧当与我属和上尼羯磨。和上尼某甲。怜愍故。第二我某甲。从和上尼某甲欲受具足戒。我今从僧乞属和上尼羯磨。和上尼某甲。僧当与我作乞属和上尼羯磨。和上尼某甲。怜愍故。第三我某甲。从和上尼某甲欲受具足戒。我今从僧乞属和上尼羯磨。和上尼某甲。僧当与我某甲作乞属和上尼羯磨。和上尼某甲。怜愍故

尼羯磨师。应僧中作如是唱。大德尼僧听是某甲。从某甲和上尼欲受具足戒。是某甲。从僧乞属和上尼羯磨。和上尼某甲。若僧时到僧忍听。我今僧中问某甲遮道法。如是白。应作是言。汝某甲听。今是至诚时实语时。我今僧中问汝。若实言实。若不实当言不实。汝是女不。是人不。非是非人不。非畜生不。非是不能女不。女根上有毛不。不枯坏不。无[病-丙+帶]下病不。非偏不。不二道合不。女根不小不。非是不能产不。非是无乳不。非是一乳不。非恒有月水不。非无月忌不。非婢不。非客作不。非买得不。非破得不。非兵妇不。非吏妇不。非犯官事不。不负他物不。女人有如是等病。癞病痈疽病痟尽病癫狂病长热病。无有如是等病不。父母夫主在不。父母夫主听出家不。五衣钵具不。汝名何等。和上尼字谁。应答言。我名某甲。和上尼名某甲。颇有未问者不。若未问者我当更问。若已问者应哩然。即语言。汝某甲默然。是中尼羯磨。师僧中唱。大德尼僧听。某甲式叉摩尼。从和上尼某甲欲受具足戒。是某甲。从僧乞属和上尼羯磨。和上尼某甲。某甲自说清净无遮道法。五衣钵具。某甲名某甲。和上尼名某甲。若僧时到僧忍听。僧与某甲为作乞属和上尼羯磨。和上尼名某甲。如是白。大德尼僧听。某甲式叉摩尼。欲从和上尼某甲受具足戒。是某甲。从僧乞属和上尼羯磨。和上尼名某甲。某甲自说清净无遮道法。五衣钵具。某甲名某甲和上尼名某甲。僧当与某甲作乞属和上尼羯磨。和上尼名某甲。谁诸比丘尼僧忍。某甲作乞属和上尼羯磨和上尼某甲者默然。不忍者说。是初羯磨竟。第二大德尼僧听。某甲式叉摩尼。欲从和上尼某甲受具足戒。是某甲。从僧乞属和上尼羯磨。和上尼名某甲。某甲自说清净无遮道法。五衣钵具。某甲名某甲和上尼名某甲。僧当与某甲作乞属。和上尼羯磨。和上尼名某甲。是中谁诸比丘尼僧忍。某甲作乞属和上尼羯磨和上尼某甲者默然。不忍者说。是第二羯磨竟。第三大德尼僧听。某甲式叉摩尼。欲从和上尼某甲受具足戒是某甲。从僧乞属和上尼羯磨。和上尼名某甲。某甲自说清净无遮道法。五衣钵具。某甲名某甲和上尼名某甲。僧当与某甲作乞。属和上尼羯磨。和上尼名某甲。谁诸比丘尼僧忍。某甲作乞属和上尼羯磨和上尼名某甲者默然。不忍者说。是第三羯磨竟。僧已为某甲。作属和上尼羯磨。和上尼名某甲。僧忍默然故。是事如是持

(比丘尼众应在比丘尼寺中作如是羯磨作竟即将至大僧寺中二部僧和合与受具戒)

将至大僧中一一礼僧足。应教从僧乞受具足戒。我某甲。从和上尼某甲欲受具足戒。今从僧乞受具足戒法。和上尼名某甲。僧当济度我与我受具足戒。怜愍故。第二我某甲。从和上尼某甲欲受具足戒。我今从僧中乞受具足戒法。和上尼名某甲。僧当济度我与我受具足戒。怜愍故。第三我某甲。从和上尼某甲欲受具足戒。我今从僧乞受具足戒法。和上尼名某甲。僧当济度我与我受具足戒。怜愍故。一比丘应僧中唱言。大德僧听。是某甲。从和上尼某甲欲受具足戒。今从众僧中乞受具足戒和上尼名某甲。若僧时到僧忍听。我当僧中问某甲六法。如是白。应语彼言。汝某甲听。今是至诚时实语时。我今僧中问汝。实者当言实。不实者当言不实。汝某甲清净不。汝从出家来。顺行出家法不。二岁学六法不。比丘尼僧作本事不。比丘尼僧和合已。作乞属和上尼羯磨未。五衣钵具不。汝字谁。和上尼字谁。答言。我名某甲。和上尼名某甲。颇有未问者不。若未问者。我当更问。已问者汝默然。大德僧听。某甲。从和上尼某甲欲受具足戒。某甲。今从僧乞受具足戒。和上尼名某甲。某甲自说清净。顺行出家法。已二岁学六法。比丘尼僧已作本事竟。比丘尼僧和合。已作属和上尼羯磨。五衣钵具。某甲名某甲。和上尼名某甲。若僧时到僧忍听。与某甲受具足戒。某甲名某甲。和上尼名某甲。如是白。大德僧听。某甲。从和上尼某甲欲受具足戒。今从众僧中乞受具足戒。和上尼名某甲。某甲自说清净。顺行出家法。已二岁学六法。比丘尼僧已作本事竟。比丘尼僧和合。已作属和上尼羯磨。五衣钵具。某甲名某甲。和上尼名某甲。僧当与某甲受具足戒。和上尼名某甲。谁诸长老忍。某甲受具足戒和上尼名某甲者默然。谁不忍者说是初羯磨说竟。第二大德僧听。某甲。从和上尼某甲欲受具足戒。今从众僧中乞受具足戒。和上尼名某甲。某甲自说清净。顺行出家法。已二岁学六法。比丘尼僧已作本事竟。比丘尼僧和合。已作属和上尼羯磨。五衣钵具。某甲名某甲和上尼名某甲。僧当与某甲受具足戒。和上尼名某甲。谁诸长老忍。某甲受具足戒和上尼名某甲默然。谁不忍者说是第二羯磨说竟。第三大德僧听。某甲。从和上尼某甲欲受具足戒。今从众僧中乞受具足戒。和上尼名某甲。某甲自说清净。顺行出家法。已二岁学六法。比丘尼僧已作本事竟。比丘尼僧和合。已作属和上尼羯磨。五衣钵具。某甲名某甲。和上尼名某甲。僧当与某甲受具足戒。和上尼名某甲。谁诸长老忍。某甲受具足戒和上尼名某甲者默然。谁不忍者便说。是第三羯磨说竟。僧已与某甲受具足戒竟。和上尼名某甲。僧忍默然故。是事如是持。应教言。若人问。汝几岁。应答言。无岁。何时节。随时应答。若春若夏若冬若闰无闰。皆应随实答是事。汝尽形应忆念。即应为说三依止法。汝某甲听。佛世尊多陀阿竭阿罗呵三耶三佛是知者见者。说受大戒比丘尼三依止法。比丘尼依是法。得出家受戒行比丘尼法。何等三。一者依粪扫衣。比丘尼依是。得出家受戒行比丘尼法。若更得盈长衣。所谓亦麻衣白麻衣刍麻衣翅夷罗衣缯衣钦婆罗衣劫贝衣。如是清净衣。皆是盈长衣得。是中汝尽形依粪扫衣。能持不。若能当言能。二者依乞食。比丘尼出家受戒行比丘尼法。若更得盈长施食。若相食故作食斋日食月一日食十六日食众僧食别房食请食若僧若别请。如是等清净诸食。皆名盈长得。是中尽形依乞食。能持不。若能当言能。三者依腐弃药。比丘尼出家受戒。行比丘尼法。若更得盈长施。酥油蜜石蜜。四种净脂。熊脂驴脂猪脂鳣脂。五种根药。舍梨姜赤附子波提鞞沙菖蒲根。五种果药。诃梨勒阿摩勒鞞醯勒胡椒荜茇罗。五种盐。紫盐赤盐白盐黑盐卤楼盐。五种汤。华汤叶汤根汤茎汤果汤。五种树胶。兴渠胶萨阇赖胶底夜胶底夜和提胶底夜和那胶。如是等诸余清净药。是盈长得故。当依腐弃药。汝尽形能持不。若能当言能。次应说八堕法。汝某甲听。佛世尊多萨阿竭阿罗呵三耶三佛。是知者见者。说是受具足戒比丘尼。得三依止八堕法。若比丘尼于八堕法中。随所犯一一法。非比丘尼。非沙门尼。非释女。失灭比丘尼法。如截多罗树头毕竟不生不复增长。比丘尼亦如是。八堕法中随所犯者。非比丘尼。非沙门尼。非释女。失灭比丘尼法。佛世尊种种因缘。呵责欲欲想欲欲欲觉欲热。佛赞叹断欲除欲想灭欲热。若比丘尼。同入比丘尼戒法。不舍戒戒羸不出想。随心受淫欲乃至共畜生。是非比丘尼。非沙门尼。非释女。失灭比丘尼法。是事尽形不应作。若能持者当言能。佛种种因缘呵责偷夺法。赞叹不偷夺法。乃至一条缕一寸纳一渧油。尚不应偷夺。是中佛制。极少乃至五钱若五钱直。若比丘尼随所偷事。若王捉若打若缚若摈出。作是言。汝贼汝小儿汝痴汝堕官罪。若比丘尼如是偷夺者。非比丘尼。非沙门尼非释女。失灭比丘尼法。是事尽形不应作。若能持者当言能。佛种种因缘呵责杀生。赞叹不杀生。乃至蚁子尚不应故夺命。何况于人。若比丘尼。自手故夺人命。若与刀若教死叹死。作是言。咄人用恶活为。死胜生。随彼心乐死。种种因缘教死叹死。若作忧多杀。若作头多杀。作弶作网作拨。若作毗陀罗。若作似毗陀罗。若断气杀。若堕胎杀。若按腹杀。若推着火中水中。若从高推下。若使道中死。若母腹中初受二根。身根命根加罗罗中。生恶心方便令夺命。若以是因缘死者。是非比丘尼。非沙门尼。非释女。失灭比丘尼法。是事尽形不应作。若能持者当言能。佛种种因缘呵责妄语。种种因缘赞叹不妄语。是中乃至戏笑。尚不应妄语。何况故妄语。若比丘尼不知不见过人法。自言我如是知如是见。我是阿罗汉向阿罗汉。若阿那含向阿那含。若斯陀含向斯陀含。若须陀洹向须陀洹。若得初禅第二禅第三禅第四禅。若得慈悲喜舍无量心。若得无色虚空定识处定无所有处定非想非非想处定。若得不净观阿那般那念。诸天来至我所。诸龙夜叉薜荔伽毗舍阇鸠槃茶罗刹来到我所。彼问我我答彼。我问彼彼答我。若比丘尼如是妄语者。非比丘尼。非沙门尼。非释女。失灭比丘尼法。是事尽形不应作。若能持者当言能。佛以种种因缘。呵欲欲想欲欲欲觉欲热。佛说断欲除欲想灭欲热。若比丘尼有漏心。听漏心男子。发际至腕膝已上却衣。顺摩逆摩抱抱牵推。举上举下捺疮者。非比丘尼。非沙门尼非释女。失灭比丘尼法。是事尽形不应作。若能者当言能。佛种种因缘呵欲欲想欲欲欲觉欲热。佛说断欲除欲想灭欲热。若比丘尼有漏心。听漏心男子捉手捉衣共立共语。共期入屏覆处。待男子来自身往就。如白衣女。以此八事示贪着相。是非比丘尼。非沙门尼非释女。失灭比丘尼法。是事尽形不应作。若能持者当言能。佛种种因缘呵责恶知识恶伴党。赞叹善知识善伴党。若比丘尼。知他比丘尼犯重罪。覆藏乃至一夜。是比丘尼。知彼比丘尼若退若住若失若远去。后作是言。我先知是比丘尼有如是如是事。不欲自向人说。不欲向僧说。不欲令人知。作是言。云何妹自污姊。是非比丘尼。非沙门尼。非释女。失灭比丘尼法。是事尽形不应作。若能持者当言能。佛种种因缘呵责恶知识恶伴党。赞叹善伴党善知识。若比丘尼。知比丘一心和合僧作不见摈。独一无二无伴无侣不休不息。随顺相助。诸比丘尼应语是比丘尼言。僧一心和合作不见摈。是比丘独一无二无伴无侣不休不息。汝莫随顺。若是比丘尼。诸比丘尼如是谏时。坚持是事不舍者。诸比丘尼应第二第三谏。令舍是事故。第二第三谏时舍者善。不舍者。是非比丘尼。非沙门尼。非释女。失灭比丘尼法。是事尽形不应作。若能持者当言能。应语言。汝从今应善软心易教化随顺师教。汝某甲已受大戒竟。好和上尼。好阿阇梨尼。好众僧。好僧坊。好檀越。好行道处。好国土。转轮圣王所愿。尚不能得满汝。今得满。汝应恭敬三宝佛宝法宝僧宝。应学三学善戒学善心学善慧学。修三脱门空无相无愿。勤行三业坐禅诵经。佐助众事。汝勤行是法者。得开须陀洹果门斯陀含果门阿那含果门阿罗汉果门。如青赤白莲华在水中日日增长。汝等诸善根亦日日增长。余残戒法。和上阿阇梨渐渐为汝广说。即说偈言

  汝得受具戒　　深知于佛法
  普善真微妙　　广大珍宝聚
  天王释所愿　　转轮王所愿
  阎罗王所愿　　汝今已得满
  常当勤精进　　修习诸善法
  勤修行三业　　当开甘露门
  于一切法中　　得无障碍慧
  如华日增长　　汝善根亦尔
  余残诸戒法　　佛世尊所说
  和上阿阇梨　　当为汝广说
  头面礼僧足　　右绕欢喜去

(一百二十七事竟)

佛在舍卫国。尔时舍卫城诸居士妇。向阿耆罗河洗浴。先有比丘尼。裸形河中洗浴。诸居士妇呵责言。不吉弊女粗身大腹垂乳。何用作比丘尼为。何不反戒作婢。是中有比丘尼。少欲知足行头陀。闻是事心不喜。以是事向佛广说。佛以是事集二部僧。知而故问是比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。裸形露处洗。种种因缘呵责已语诸比丘。从今听比丘尼畜浴衣着露地洗。尔时诸比丘尼。知佛听畜浴衣。便广长作。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责。云何名比丘尼。知佛听畜浴衣。便广长大作。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问诸比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。知我听畜浴衣。便广长大作。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼欲作浴衣。当应量作。量者。长五修伽陀搩手。广二搩手半。过是作者波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼欲作浴衣。若过长量不过广量波夜提。若过广量不过长量波夜提。随过长广量。随得波夜提(一百二十八事竟)

佛在王舍城。尔时有助调达比丘尼。数数易衣服。是时有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责。云何名比丘尼。数数易衣服。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问助调达比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘尼。数数易衣服。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼数数易衣服。波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼数数易衣服波逸提。随易随得波逸提(一百二十九事竟)

佛在舍卫国。尔时偷兰难陀比丘尼。有弟子。名施越沙。善好乐持戒。但喜忘。施越沙摘故衣。不自缝不使人缝。所摘衣散在异处。是中有比丘尼。少欲知足行头陀。闻是事心不喜。呵责。云何名比丘尼。摘故衣不自缝不使人缝。散在异处。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问施越沙比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘尼。摘故衣不自缝不使人缝。散在异处。种种因缘呵已语诸比丘。从今听诸比丘尼作衣极久五夜。应还受。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼作衣。极久乃至五夜。过是成者波逸提。波逸提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼作衣时过五夜波逸提。随过随得波逸提(一百三十事竟)

佛在王舍城。尔时助调达比丘尼。多畜衣不分别。何者是所受僧伽梨。何者是所受郁多罗僧。何者是所受安陀会。何者是所受覆肩衣。何者所受俱修罗。诸比丘尼问助调达比丘尼。何者是汝所受僧伽梨郁多罗僧安陀会覆肩衣俱修罗。答言。小住。我问和上尼。问阿阇梨尼。问共活尼。即往问言。何着我所受僧伽梨郁多罗僧安陀会覆肩衣俱修罗诸人答言。我不知不忆。疑何者是汝所受非所受。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。多畜衣不知。何者是所受僧伽梨郁多罗僧安陀会覆肩衣俱修罗。种种因缘呵责已向佛广说。佛以是事集二部僧。知而故问助调达比丘尼言。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘尼。多畜衣不知。何者是所受僧伽梨郁多罗僧安陀会覆肩衣俱修罗。种种因缘呵已语诸比丘。从今比丘尼五夜应看五衣。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼五夜不看五衣。波逸提。波逸提者烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼五夜不看五衣波逸提。随不看随得波逸提(一百三十一事竟)

佛在王舍城。尔时助调达比丘尼。常入出诸家诸居士妇言。与我少许衣段。守护小儿故。是比丘尼即脱衣与。后诸善比丘尼复到是家。诸居士妇言。与我少许衣段。守护小儿故。善比丘尼言。汝等倒语。白衣应与出家人衣。而反从我索。我等受他信施。云何坏他供养。居士妇言。汝等悭惜。前有比丘尼来。我索小段。便脱衣与我。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责。云何名比丘尼。以衣与白衣。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问助调达比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘尼。以衣与白衣。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼以衣与白衣。波逸提。波逸提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼以衣与白衣波逸提。随与随得波逸提(一百三十二事竟)

佛在舍卫国。尔时偷兰难陀比丘尼。月病休止。浣病衣已净不欲起去。妨余有月病比丘尼。不得故处。诸比丘尼苦恼。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责。云何名比丘尼。月病休止。浣病衣已净不欲起去。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问偷兰难陀比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。月病休止。得浣衣竟不欲起去。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼月病休止。浣衣已净不起去者。波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼月病休止。浣衣已净不起去者。波夜提。随不起随得波夜提(一百三十三事竟)

佛在舍卫国。尔时有一居士。欲与比丘尼僧衣。偷兰难陀比丘尼。常入出是家。闻已往问言。汝实欲与比丘尼僧衣耶。答言。实尔。偷兰难陀言。比丘尼僧多有衣。厚举畜腐烂不能用。汝今有事且出城。还更自思惟。以是因缘故。是衣竟不与比丘尼僧。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。居士欲与比丘尼僧衣。遮令不与。种种因缘呵责已向佛广说。佛以是事集二部僧。知而故问偷兰难陀比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。居士欲与比丘尼僧衣。遮令不与。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼遮与僧衣波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼遮与僧衣波夜提。随遮随得波夜提(一百三十四事竟)

佛在舍卫国。尔时偷兰难陀比丘尼。所望得衣弱。便受迦絺那衣。后时打犍捶舍迦絺那衣。偷兰难陀比丘尼不欲来。遣比丘尼唤言。僧欲舍迦絺那衣。汝来。答言。不去。问何故不去。偷兰难陀言。我所望衣未得。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。所望得衣弱。而受迦絺那衣。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问偷兰难陀比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘尼。所望得衣弱。而受迦絺那衣。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼所望得衣弱。而受迦絺那衣。波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼所望得衣弱。而受迦絺那衣。波夜提。随所望得衣弱。随受随得波逸提(一百三十五事竟)

佛在舍卫国。尔时诸比丘尼僧。打揵捶欲舍迦絺那衣。优婆和比丘尼。作僧断事人。不欲到僧中。遣比丘尼唤言。善女来。比丘尼僧欲舍迦絺那衣。嗔言。我是僧断事人。何故不问我而打揵捶。我不能去。即以是因缘故。不成舍迦絺那衣。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。僧欲舍迦絺那衣。不随顺从。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问优婆和比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘尼僧舍迦絺那衣。不随顺。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼僧舍迦絺那衣时。不随者波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼僧。舍迦絺那衣时不随者波夜提。随不随顺随得波夜提(一百三十六事竟)

佛在舍卫国。尔时比丘尼僧。打揵捶和合欲分衣。优婆和比丘尼作僧断事人。不往僧中。遣使唤言。僧已和合欲分衣。汝来。答言。不往。汝远去。是事非法不正邪事。随欲随嗔随怖随痴。我是僧断事人。云何离我分衣。是故不去。以是因缘故。僧不得分衣。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责。云何名比丘尼僧分衣不随顺。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问优婆和比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵言言。云何名比丘尼僧分衣不随顺。种种因缘呵已。语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼僧分衣时不随者波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼僧分衣时不随者波夜提。随不随得波夜提(一百三十七事竟)

佛在舍卫国。尔时比丘尼僧打揵捶和合欲断事。优婆和比丘尼不往。遣使唤言。僧已和合欲断事。汝来。答言。汝远去。我思惟是事。非法不正。随爱随嗔随怖随痴。是故不去。以是因缘故。僧不成断事。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼僧断事不随顺。种种呵已向佛广说。佛以是事集二部僧。知而故问优婆和比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘尼僧断事不随顺。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼僧断事时不随顺者。波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼僧断事时不随顺者。波夜提。随不随顺。随得波夜提(一百三十八事竟)

佛在舍卫国。尔时偷兰难陀比丘尼。不嘱他房舍游行聚落中。后失火烧僧坊。诸比丘尼各各自出衣钵。共相谓言。出偷兰难陀比丘尼衣钵。有比丘尼言。偷兰难陀恶性喜嗔。失言不失。烧言不烧。都不与出。火烧物尽。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责。云何名比丘尼。不嘱他房舍游行聚落中。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问偷兰难陀比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘尼。不嘱他房舍游行聚落中。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼。不嘱他房舍至聚落中。波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼不以房舍嘱他至聚落中波夜提。随不嘱他。随得波夜提(一百三十九事竟)

佛在舍卫国。尔时有迦罗比丘尼。先是外道。弃舍经律阿毗昙。诵读种种咒术。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责。云何名比丘尼。弃舍经律阿毗昙。诵读种种咒术。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问迦罗比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘尼。弃舍经律阿毗昙。读诵种种咒术。种种因缘诃已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼读诵种种咒术波逸提。波逸提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼读诵种种咒术。若是偈说。偈偈波逸提。若是章说。章章波逸提。若别句说。句句波逸提。不犯者。若读诵治齿。咒腹痛咒治毒咒。若为守护安隐不犯(一百四十事竟)

佛在舍卫国。尔时迦罗比丘尼。先是外道。弃舍经律阿毗昙。教白衣儿读诵种种咒术。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。弃舍经律阿毗昙。教白衣读诵种种。术种种因缘呵责已向佛广说。佛以是事集二部僧。知而故问迦罗比丘尼汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。弃舍经律阿毗昙。教白衣读诵种种咒术。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼。教白衣读诵种种咒术。波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼教白衣读诵种种咒术。若是偈说。偈偈波夜提。若是章说。章章波夜提。若别句说。句句波夜提。不犯者。教读诵治齿咒腹痛咒治毒咒。若为守护安隐故不犯(一百四十一事竟)

佛在舍卫国。尔时助调达比丘尼。常入出他家。到他家中。居士妇言。善女汝扫洒敷床榻然火煮食下食。是比丘尼即随所教。更有善比丘尼来到是家。居士妇言。善女。汝扫洒敷床榻然火煮食下食。答言。我是汝婢供养汝耶。今汝等坐。使我执作。居士妇言。汝恶性憍慢。助调达比丘尼来。随我语作。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责。云何名比丘尼。与白衣扫洒敷床榻然火煮食下食。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问助调达比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘尼与白衣作。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼与白衣作波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼。白衣使扫地。扫者波夜提。若使洒地敷床榻然火煮食煮羹下食。作者波夜提。若随语闭门突吉罗(一百四十二事竟)

佛在舍卫国。尔时舍卫国节日。诸居士办种种好饮食。出城至园中。但有诸新妇在家。偷兰难陀比丘尼。与一家知识。早起着衣持钵入是家。新妇畏婿来。若婿父母来。于中门外与敷坐。共相问讯便坐。诸新妇头面礼比丘尼足。现前而坐。比丘尼即为说法。经久闭目便呗。新妇恐婿来见。若婿父母来故。即便起去。第二第三新妇亦复如是。比丘尼开眼看见前无人在。心生惭愧舍坐处去。是家近大巷。有诸蔽恶人。入门见其坐床。四顾无人。便偷持去。诸新妇不闻比丘尼声。共相谓言。往看在不。咸言。不在。坐床在不。答言。不在。作是念。比丘尼必持至僧坊中。遣使索言。还我床来。是比丘尼羞嗔故。不复至是家。是居士后于市中见人卖床。即还夺取。遣使语比丘尼言。以得先床。汝可还来。是中有比丘尼。少欲知足行头陀。闻是事心不喜种种因缘呵责言。云何名比丘尼。坐白衣床不付嘱主便去。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问偷兰难陀比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘尼。坐白衣床。不还付主便去。种种因缘呵已语诸比丘。以十利故与比丘尼结戒。从今是戒应如是说。若比丘尼坐白衣床。不还付主便去。波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼坐白衣床。不还付主便去。波夜提。随不付去。随得波夜提(一百四十三事竟)

佛在舍卫国。尔时舍卫国有一大臣。净洁自喜好出他过。语其妇言。诸比丘尼不净着弊弃衣。莫听坐我床上妇答言尔言已便去。偷兰难陀常入出是家。中前着衣持钵往到其家。居士妇言。我丈夫净洁自喜好出他过。是语我言。诸比丘尼不净着弊弃衣。莫听坐我床上。偷兰难陀比丘尼即便嗔言。速去。汝等姓胜我耶。家胜我耶。若我不作比丘尼者。汝等当供给我。即高褰衣坐其床上。诸居士呵责言。诸比丘尼自言。善好有功德。不问主人辄坐他床上。如王夫人如大臣妇。是中有比丘尼。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集二部僧。知而故问偷兰难陀比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。不问主人坐他床上。种种呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼。不问主人坐他床上。波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼不问主人坐他床上波夜提。随不问坐。随得波夜提(一百四十四事竟)

佛在舍卫国。尔时舍卫国节日。诸居士办种种好饮食。欲出城诣园林中。诸白衣妇洗浴以香涂身庄严头面。治目涂发。着新好衣。内外庄严具。助调达比丘尼入是家见居士妇问言。汝洗浴以香涂身。庄严头面治目涂发。着新好衣内外庄严具。欲作何等。答言。欲诣园林中游戏。语比丘尼言。善女。汝能去不。答言。能去。问言。汝欲乘乘。为当步去。比丘尼言。我等为是婢供养汝耶。云何当步。居士妇言。汝能上乘不比丘尼言。汝等尚能。我何以不能。是中有妇女。羞夫婿羞夫婿父母者。便闭车前后。有无婿及父母者。开车而去。诸比丘尼无所畏故。开车大语戏。共相随去。诸居士呵责言。诸比丘尼自言。善好有功德。乘车行。如王夫人大臣妇。是中有比丘尼。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集二部僧。知而故问助调达比丘尼。汝实作是事不。答言实作世尊。佛以种种因缘呵责云何名比丘尼乘乘。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼无病乘乘。波夜提。波夜提者。烧煮覆障若不悔过能障碍道。是中犯者。若比丘尼无病乘乘波夜提。随无病乘乘。随得波夜提。若病不犯(一百四十五事竟)

佛在舍卫国。尔时舍卫城。王园精舍诸比丘尼。在中庭讲堂内土埵上有立作者有纺者。有擘治者有抖擞者。有作萦者有缠手者。尔时众多斗将。到王园精舍。见诸比丘尼种种作。作是言。若王闻者。诸粗[疊*毛]细[疊*毛]杂色[疊*毛]钦婆罗。如是等物一时多办。是中有比丘尼少欲知足行头陀。闻是事心不喜向佛广说。佛以是事集二部僧。知而故问诸比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。纺作。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼纺绩波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼纺绩波夜提。若萦若绩若擘若抖擞若缠手。皆波夜提。随动手随得波夜提。方便欲作突吉罗。若还合缕一转一突吉罗。若为缝衣绳綖乃至六两不犯(一百四十六事竟)

佛在舍卫国。尔时偷兰难陀比丘尼得他质钱。腰络着市中行。有铃声出。诸居士闻已呵责言。诸比丘尼自言善好有功德。着腰络行市中。如王夫人如大臣妇是中有比丘尼。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集二部僧。知而故问偷兰难陀比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。着腰络。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼着腰络波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼着腰络波夜提。若作突吉罗。若治突吉罗。若与他着突吉罗(一百四十七事竟)

佛在王舍城。尔时助调达比丘尼。捉盖入他舍。诸居士呵责言。诸比丘尼自言。善好有功德。捉盖入他家。如王夫人如大臣妇。是中有比丘尼。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集二部僧。知而故问助调达比丘尼。汝实作是事不答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。捉盖入白衣家舍。种种因缘。呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼捉盖入白衣舍波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼捉盖入白衣舍波夜提。随捉随得波夜提。若倒盖入不犯(一百四十八事竟)

佛在舍卫国。尔时有比丘尼。名修阇多。端正姝好。人所喜见。有一长者儿。名郁多罗。旧相知识。共语共事。是儿住憍萨罗国钵多罗聚落。是比丘尼为是儿故。离有比丘住处安居。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼离有比丘住处安居。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问修阇多。汝实作是事不。答言实作世尊。佛以种种因缘呵责言。云何名比丘尼。离有比丘住处安居。种种呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼。离有比丘住处安居。波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼离有比丘住处安居波夜提。随离随得波夜提(一百四十九事竟)

佛在王舍城。尔时助调达比丘尼。安居竟不二部僧中求三事自恣说见闻疑罪。是中有比丘尼。少欲知足行头陀闻是事心不喜。种种因缘呵责言。云何名比丘尼。安居竟不二部僧中求三事自恣说见闻疑罪。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问助调达比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。安居竟不二部僧中求三事自恣说见闻疑罪。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼安居竟。不二部僧中求三事自恣说见闻疑。波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼安居竟。不于二部僧中求三事自恣说见闻疑罪波夜提。随不求三事自恣说。随得波夜提(一百五十事竟)

佛在王舍城。尔时助调达比丘尼。半月半月不往僧中求教诫。是中有比丘尼。少欲知足行头陀。闻是事心不喜种种因缘呵责言。云何名比丘尼。半月半月不往僧中求教诫种种因缘呵已向佛广说。佛以是事集二部僧。知而故问助调达比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。半月半月不往僧中求教诫。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼。半月半月不往僧中求教诫。波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼半月不往僧中求教诫波夜提。随不求随得波夜提(一百五十一事竟)

佛在王舍城。尔时助调达比丘尼。无病不往受教诫。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。无病不往受教诫。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问助调达比丘尼。汝实作是事不答言。实作世尊佛以种种因缘呵责言。云何名比丘尼。无病不往受教诫。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼无病不往僧中受教诫。波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼无病不往受教诫。波夜提。随无病不往受教诫。随得波夜提。若病不犯(一百五十二事竟)

十诵尼律卷第四十六十诵律卷第四十七(第七诵之六)

        后秦北印度三藏弗若多罗共罗什译

    尼律第六

佛在俱舍弥国。尔时迦留罗提舍比丘命终。有姊妹比丘尼七人。名偷兰难陀尼。周那难陀尼。提舍尼。忧波提舍尼。提舍域多尼。提舍婆罗那尼。提舍叉多尼。是诸比丘尼有大势力。集薪木材烧是比丘身。拾骨起塔。尔时有一比丘。名迦陀。从和耆国游行向维耶离。道中见是塔。问是谁塔。答言。迦留罗提舍比丘塔。又言。此凡夫人。何用起塔。即坏是塔。敷绳床坐上。偷兰难陀比丘尼。闻迦陀比丘破其兄塔敷床坐上。闻已嗔恚。语诸妹言。各持针线来。缝是比丘着床。是僧坊近道。时优波离过。闻如是事。即往语是比丘言。汝在此中坐者。诸比丘尼正尔当来缝汝着床。答言。若缝我着床者。我从此臭身得脱。优波离言。汝虽脱臭身。诸比丘尼当得大罪是比丘即入禅定。令身不现。优波离即出去。诸比丘尼入。共相谓言。是比丘在不。即看不见。手摸绳床看犹觉有暖。作是言。必是本剃毛人优波离教使走去。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。有比丘住处外门不问便入。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问偷兰难陀比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘尼。有比丘住处外门不问便入。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼有比丘住处外门不问便入。波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼。有比丘住处外门不问便入。波夜提。随不问入。随得尔所波夜提(一百五十三事竟)

佛在舍卫国。尔时佛不在比丘尼僧前结同戒。在比丘僧前结同戒已语诸比丘。汝等向比丘尼僧说。佛即入房坐禅。诸比丘共相谓言。佛结同戒。教我等向诸比丘尼僧说。谁能为诸比丘尼僧说。又念。长老跋提比丘。有福德威力名闻流布。是长老跋提比丘。能往诣王园精舍。为比丘尼僧说同戒。诸比丘即往是比丘所言。佛为我等结同戒。语我等言。汝等向比丘尼僧说。即入房坐禅。我等作是思惟。谁能为比丘尼僧说同戒。又作是念。长老跋提比丘。有福德威力名闻流布。必能为说。汝能为王园精舍比丘尼僧说同戒不长老跋提默然受之。诸比丘即头面礼跋提足右绕而去。是夜过已。跋提比丘着衣持钵。共后行比丘。入舍卫城乞食。食后到王园比丘尼精舍。诸比丘尼遥见长老跋提比丘来。即起与敷床榻坐处。有办水者。有办草者。跋提到已。洗脚就座坐已。令集比丘尼僧。集已语言。诸善女。佛结同戒。我及汝等应共受持。是中有长老善好比丘尼。皆言善好。偷兰难陀比丘尼喑嗌不受。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。喑嗌向比丘。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问是比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。喑嗌向比丘。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼喑嗌向比丘者波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼喑嗌向比丘波夜提。随喑嗌向比丘。随得尔所波夜提(一百五十四事竟)

佛在舍卫国。尔时迦罗比丘尼。本是外道。喜斗诤嗔恚。共诸比丘尼斗诤恶口恐他。作是言。某王是我相识是我檀越。某大臣斗将居士。是我相识檀越。当用是力治汝。诸比丘尼恐怖。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。共他斗诤恶口恐他。作是言。某王是我相识是我檀越。某大臣斗将居士。是我相识檀越。当用是力治汝。令诸比丘尼恐怖。种种因缘呵责已向佛广说。佛以是事集二部僧。知而故问汝实作是事不。答言。实作世尊。佛以种种因缘诃责言。云何名比丘尼。共他斗诤恶口恐他。作是言。某王与我相识是我檀越。某大臣斗将居士。与我相识檀越。当用是力治汝。令诸比丘尼恐怖。种种因缘呵已语诸比丘丘。以十利故与比丘尼结戒。从今是戒应如是说若比丘尼。共比丘尼斗诤恶口恐怖他波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者若比丘尼。共比丘尼斗诤恶口。恐怖他言。某王是我知识。当以王力治汝。波夜提。大臣力斗将力居士力治汝。皆波夜提。随作是语。随得尔所波夜提(一百五十五事竟)

佛在舍卫国尔时偷兰难陀比丘尼。喜入出他家。早起行诣诸家。中庭立大门中立。厨下立。是中若有沙门婆罗门来。为乞食故来。偷兰难陀比丘尼语言。食未办。若言主人不在。如是从家至家。遮诸乞食人。诸乞食人不得食故呵责言。是不吉弊女悭惜他家。故令我等不得食。是中有比丘尼。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集二部僧知而故问偷兰难陀比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。护惜他家。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼护惜他家。波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼护惜白衣家波夜提。随护惜随得尔所波夜提(一百五十六事竟)

佛在迦维罗卫国。尔时摩诃男释。请佛及二部僧明日食。佛默然受。知佛默然受已。头面礼足右绕而去。还家通夜办种种多美饮食。早起敷坐处。遣使白佛时到。食具已办唯圣知时。佛与二部僧入已皆坐。知佛坐已。自手行水。自与种种多美饮食。自恣满足。尔时助调达比丘尼。满钵中饭以羹浇上。在前不啖四向顾视。摩诃男释作是念。我当遍看谁少谁不少。谁食谁不食。见助调达比丘尼满钵饭羹在前不食。语言。善女。何故不食。答言。我先已食。何故取饭。答言。汝便持去。摩诃男释善好不嫌。诸居士随摩诃男释者作是言。摩诃男释。供给众僧如事大家。诸比丘尼现前呵辱。佛遥见比丘尼所作。闻诸居士呵责。食后到僧坊中集二部僧。种种因缘呵责助调达比丘尼。摩诃男释。供给众僧如事大家。云何现前毁辱。种种因缘呵责已语诸比丘。从今听诸比丘尼数数食。何以故。女人喜数数食故。以十利故。与比丘尼结戒从今是戒应如是说。若比丘尼。受请都不食者。波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼受请乃至不食一口波夜提。随受请不食。随得尔所波夜提(一百五十七事竟)

佛在释氏国。是中有比丘尼。名结发。作法师善能说法。见一年少比丘。无深智慧。即问难阿毗昙事。是比丘不能随顺问答。是比丘尼出。自贡高语诸比丘尼言。我今问一比丘阿毗昙事。不能随顺答我。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。比丘不听问经律阿毗昙事便问。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问结发比丘尼。汝实作是事不。答言实作世尊。佛以种种因缘诃责言云何名比丘尼比丘不听问经律阿毗昙事便问。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼。比丘不听问经律阿毗昙事便问。波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼。比丘不听问难经律阿毗昙中事。若以偈问。偈偈波夜提。若以章问。章章波夜提。若别句问。句句波夜提(一百五十八事竟)

佛在王舍城。尔时助调达比丘尼。裸形露地洗浴。诸居士见不喜。呵责言。诸比丘尼自言。善好有功德裸形露地洗浴。如淫女是中有比丘尼。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集二部僧。知而故问助调达比丘尼。汝实作是事不。答言。实作世尊佛以种种因缘呵责。云何名比丘尼。裸形露地洗浴。种种因缘呵已语诸比丘。以十利故与比丘尼结戒。从今是戒应如是说。若比丘尼裸形露地洗浴。波夜提波夜提者烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼裸形露地洗浴波夜提。随裸形露地洗浴。随得尔所波夜提(一百五十九事竟)

佛在王舍城。尔时助调达比丘尼。着白衣严身具诸居士呵责言。诸比丘尼自言善好有功德。着白衣严身具。如王夫人大臣妇。是中有比丘尼。少欲知足行头陀。闻是事心不喜向佛广说。佛以是事集二部僧。知而故问助调达比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘诃责言。云何名比丘尼。着白衣严身具。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼。着白衣严身具。波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼着白衣严身具波夜提。随着随得尔所波夜提(一百六十事竟)

佛在王舍城。尔时助调达比丘尼。故往观听歌舞伎乐。看庄严伎儿。诸居士呵责言。诸比丘尼自言。善好有功德。故往观听歌舞伎乐庄严伎儿。如王夫人如大臣妇。是中有比丘尼。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集二部僧。知而故问是比丘尼。汝实作是事不。答言。实作世尊佛以种种因缘呵责言。云何名比丘尼。故往观听歌舞伎乐庄严伎儿。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼。故往观听歌舞伎乐庄严伎儿。波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼。故往观听歌舞伎乐庄严伎儿。得见者波逸提。不得见者突吉罗。若从下至高得见波夜提。不得见突吉罗。若从高至下得见波夜提。不得见突吉罗。不犯者。不故往道由中过不犯(一百六十一事竟)

佛在舍卫国。尔时偷兰难陀比丘尼。两道中间生痈。即唤白衣解看还系。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。屏处有疮。令白衣解看还系。种种因缘呵已向佛广说。佛以是事集二部僧。知而故问偷兰难陀比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。屏处有疮。使白衣解看还系。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼有疮。使白衣解系者波夜提。疮者有三种。一者痈疮等自生。二者物伤。三者中风坚癖。癖有三种冷癖热癖风癖。若比丘尼。自能系不能解。应自系令他解。若自能解不能系应自解令他系。是中犯者。若比丘尼。令白衣系而不解。波夜提。若令解不系波夜提。随令系解。随得尔所波夜提(一百六十二事竟)

佛在舍卫国。尔时修阇陀比丘尼。年少端正。与郁多罗长者儿共相识共事。是比丘尼共行坐起言语说俗事。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。共男子行说俗事。种种因缘呵已。向佛广说佛以是事集二部僧。知而故问。修阇陀比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘尼。与男子共行说俗事。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼与男子共行说俗事。波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼与男子共行说俗事。波夜提。随共行说俗事。随得尔所波夜提(一百六十三事竟)

佛在王舍城尔时助调达比丘尼。以好香揩身复以涂香胡麻屑胡麻滓揩身。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。以香揩身。以涂香胡麻屑胡麻滓揩身。种种因缘呵已。向佛广说。佛以是事集二部僧。知而故问。助调达比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责。云何名比丘尼。以涂香胡麻屑胡麻滓揩身。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼。以涂香胡麻屑胡麻滓揩身。波夜提波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼以香揩身波夜提。若以涂香胡麻屑胡麻滓揩身。皆波夜提。随用揩身。随得尔所波夜提(一百六十四事竟)

佛在王舍城。尔时助调达比丘尼。不自以香涂身。复不自以香揩身。胡麻屑胡麻滓揩身。使式叉摩尼沙弥尼白衣女揩身。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。使式叉摩尼沙弥尼以香涂身复以香揩身胡麻屑胡麻滓揩身种种因缘呵已向佛广说佛以是事集二部僧。知而故问助调达比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。使式叉摩尼沙弥尼白衣女以香涂身复以香揩身胡麻屑胡麻滓揩身。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼。使人以香涂身复以香揩身胡麻屑胡麻滓揩身。波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼。使人以香揩身波夜提。若使人以香涂身波夜提。胡麻屑胡麻滓揩身。皆波夜提。随使人揩。随得尔所波夜提(一百六十五事竟)

佛在舍卫国。尔时偷兰难陀比丘尼。着头光在淫女门中立。诸婆罗门居士来欲近之。即以脚蹴蹋。作是言。汝欲共我作淫欲耶。诸居士呵责言。诸比丘尼自言。善好有功德。着头光在淫女门中立。见诸人来近以脚蹴蹋。是中有比丘尼少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集二部僧。知而故问偷兰难陀比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。着头光在淫女门中立。种种呵已语诸比丘以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼着头光波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼着头光波夜提。若作突吉罗。若治故光突吉罗。若与他着突吉罗(一百六十六事竟)

佛在王舍城。尔时助调达比丘尼。有大式叉摩尼。年少端正可爱。欲受大戒。有弊恶人见生贪着心作是念。比丘尼为王所守护。不得强夺。诸比丘尼法。应从比丘受大戒。若是式叉摩尼出受戒时。我当捉取将去。是式叉摩尼出受大戒。是弊恶人强捉将去。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。不语僧坊中比丘尼。出远门去。种种因缘呵已。向佛广说。佛以是事集二部僧。种种因缘呵责言。云何名比丘尼。不语僧坊中比丘尼。出远门去。种种呵已语诸比丘。以十利故与比丘尼结戒。从今是戒应如是说。若比丘尼。不语余比丘尼出远门去波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼。从比丘尼僧坊中。不语余比丘尼。出门远去。波夜提。随不语出门。随得尔所波夜提(一百六十七事竟)

佛在王舍城。尔时助调达比丘尼。以刷刷头。诸居士呵责言。诸比丘尼自言。善好有功德。以刷刷头。如白衣女。是中有比丘尼。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集二部僧。知而故问助调达比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。以刷刷头。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼以刷刷头。波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼以刷刷头波夜提。随刷刷随得尔所波夜提(一百六十八事竟)

佛在王舍城。尔时助调达比丘尼。使他刷头诸居士呵责言。善女。汝等已出家。何用刷头为。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。使他刷头。种种因缘呵已。向佛广说。佛以是事集二部僧。知而故问助调达比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。使他刷头。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼使他刷头波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼使他刷头波夜提。随使他刷头。随得尔所波夜提(一百六十九事竟)

佛在王舍城。尔时助调达比丘尼。以梳梳头。是中有比丘尼。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集二部僧。知而故问助调达比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。以梳梳头。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼以梳梳头波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼以梳梳头波夜提。随梳随得尔所波夜提(一百七十事竟)

佛在舍卫国。尔时助调达比丘尼。使他梳头。是中有比丘尼。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集二部僧。知而故问助调达比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。使他梳头。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼使他梳头波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼使他梳头波夜提。随使他梳头。随得尔所波夜提(一百七十一事竟)

佛在王舍城。尔时助调达比丘尼。编头发。诸居士呵责言。汝比丘尼出家人。何故编头发为。是中有比丘尼。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集二部僧。知而故问助调达比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。编头发。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼编头发波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼编头发波夜提。随编随得尔所波夜提(一百七十二事竟)

佛在王舍城。尔时助调达比丘尼。使他编头发。是中有比丘尼。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集二部僧。知而故问助调达比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。使他编头发。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼使他编头发波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼使他编头发波夜提。随使他编头发。随得尔所波夜提(一百七十三事竟)

佛在舍卫国。尔时王园比丘尼精舍门前。有好草地。净洁故多人众集。是中多有弊恶人。见诸比丘尼出入时。便形相说其过罪。共相谓言。是睐眼。是烂眼。是瘿是黑是白。是好是丑。是有威德。是无威德。诸比丘尼闻是事心不喜。作是念诸人集此者。以是好草故。我等何不坏是草耶。即大小便其上。草即干死。诸居士呵责言。不吉弊女。更无余行处耶。净草中大小便。是中有比丘尼。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集二部僧。知而故问诸比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘诃责言。云何名比丘尼。生草上大小便。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼生草上大小便波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼生草上大小便波夜提。随生草上大小便。随得尔所波夜提(一百七十四事竟)

佛在舍卫国。尔时偷兰难陀比丘尼。故出精。是中有比丘尼。少欲知足行头陀。闻是事心不喜。种种因缘呵责言。云何名比丘尼。故出精。种种因缘呵已。向佛广说。佛以是事集二部僧。知而故问偷兰难陀比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。故出精。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼故出精波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼故出精波夜提。随故出精。随得尔所波夜提

佛在舍卫国。尔时诸比丘尼梦中失精。觉已作是念。佛结戒。不听我等故出精。今梦中失精。我当云何。是事白佛。佛以是事集二部僧。种种因缘赞戒赞持戒。赞戒赞持戒已语诸比丘。从今是戒应如是说。若比丘尼故出精。除梦中波夜提(一百七十五事竟)

佛在舍卫国。尔时迦留陀夷。与掘多比丘尼相识知旧。共语共事。时迦留陀夷。二月游行他国。掘多比丘尼闻已心不喜。迦留陀夷二月游行。还到舍卫国。掘多比丘尼闻已。洗浴庄严面目。香油涂发着轻染衣。到迦留陀夷所。头面礼足在前而坐。时迦留陀夷。生染着心谛视其面。比丘尼亦生染心。视比丘面。比丘尼作是念。此视我面必生染着。我何不在前起行。时迦留陀夷但着泥洹僧。共行来往欲心动发。畏犯戒故。不敢相触。谛相视面便失不净。离急热已即还本坐。掘多比丘尼知失不净。语迦留陀夷。持是衣来。我当与浣。即脱衣与。比丘尼持是衣。小却一面綟衣。取汁分作二分。一分饮一分着女根中。即时有福德人来受母胎。是比丘尼腹渐渐大。诸比丘尼言。汝是犯淫欲人。驱出僧坊。是比丘尼言。我不作淫。自说如上因缘。诸比丘尼不知云何。以是事向佛广说。佛以是事集二部僧。知而故问是比丘尼。汝实作是事不。答言。实作世尊。佛语诸比丘尼。汝等莫说是比丘尼此事。以如是因缘故得娠。佛以种种因缘呵责言。云何名比丘尼。饮精。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼饮精波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼饮男子精波夜提。随饮随得尔所波夜提(一百七十六事竟)

佛在王舍城。尔时助调达比丘尼。男子洗处浴。诸居士呵责言。诸比丘尼自言。善好有功德。在男子洗处浴。如淫女。是中有比丘尼。少欲知足行头陀。闻是事心不喜。向佛广说。佛以是事集二部僧。知而故问助调达比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。在男子洗处浴。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼男子洗处浴波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼男子洗处浴波夜提。随男子洗处浴随得尔所波夜提(一百七十七事竟)

佛在王舍城。尔时助调达比丘尼。喜门中立。诸居士呵责言。诸比丘尼自言。善好有功德。在门中立。如淫女。是中有比丘尼。少欲知足行头陀闻是事心不喜。向佛广说。佛以是事集二部僧。知而故问助调达比丘尼。汝实作是事不。答言。实作世尊。佛以种种因缘呵责言。云何名比丘尼。喜门中立。种种呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼在门中立波夜提。波夜提者。烧煮覆障。若不悔过能障碍道。是中犯者。若比丘尼在门中立波夜提。随门中立。随得尔所波夜提(一百七十八波夜提事具足竟)

    八波罗提提舍尼法

佛在释氏国。尔时释摩男。请佛及二部僧明日食。佛默然受。知佛默然受已。头面礼佛足右绕而去。还舍通夜办种种多美饮食。煮药草乳汁。早起敷坐处。遣使白佛。食具已办唯圣知时。佛及二部僧。往入其舍就座而坐。释摩男。见佛及二部僧坐已。自手行水。自下饭与药草乳汁浇上。尔时助调达比丘尼。盛满钵饭。以药草乳汁浇上。着前不食四向顾视。释摩男作是念。我当遍看。谁少谁不少。谁食谁不食。见助调达比丘尼。置钵在前不食。问言。何故不食。答言。汝有未煎乳不有者当食。答言。是药草乳汁美好可食。若有未煎乳者。当以相与。又问。汝有酪生酥熟酥油鱼肉脯者。我当得食。语言。药草乳汁可并食。若有酪生酥熟酥油鱼肉脯。当以相与。助调达比丘尼言。汝请佛及僧。汝若无力能随意与者。何故请佛及僧耶。若余人请者。当随意与。是熟乳何处无有。释摩男善好。闻是语不嗔余随从释摩男者嗔言。诸比丘尼自言。善好有功德。是释摩男供给众僧。如事大家。云何现前呵辱。佛见助调达比丘尼作是事。闻诸居士呵责。食后以是事集二部僧。种种因缘呵责助调达比丘尼言。云何名比丘尼。释摩男供给众僧如事大家。云何现前呵辱。种种因缘呵已语诸比丘。以十利故。与比丘尼结戒。从今是戒应如是说。若比丘尼无病。自为索乳。是比丘尼。应诸比丘尼前说是事作是言。诸善女。我堕可呵法。不随顺道可悔过。我今悔过。是名初波罗提提舍尼法。是中犯者。若比丘尼无病自为索乳得者波罗提提舍尼。不得者突吉罗。为病者索得者不犯。若从亲里索。若先请。若不索自与。不犯。(一事竟)酪生酥熟酥油鱼肉脯亦如是。是名为八波罗提提舍尼法(不共戒都竟共戒如比丘戒中广说)

    比丘尼八敬法

比丘尼。布萨日到寺中。随意请一比丘。受教诫法。比丘尼僧。要当自和合。僧差一比丘尼。来受教诫。要须伴共来。来到已。头面礼教诫比丘足问讯应如是语。比丘尼僧和合。头面礼和合比丘僧足。乞半月教诫法。所敕教诫法。我当受持比丘应语比丘尼言。释迦牟尼佛多陀阿伽度阿罗呵三藐三佛陀知者见者。为比丘尼说半月八敬法。何等八。一者百岁比丘尼。见新受具戒比丘。应一心谦敬礼足。二者比丘尼。应从比丘僧乞受具戒。三者若比丘尼犯僧残罪。应从二部僧乞半月摩那埵法。四者无比丘住处。比丘尼不得安居。五者比丘尼安居竟。应从二部僧中自恣求见闻疑罪。六者比丘尼。半月从比丘受八敬法。七者比丘尼语比丘言。听我问修多罗毗尼阿毗昙。比丘听者应问。若不听者不得问。八者比丘尼不得说比丘见闻疑罪。是为八。一比丘尼受是八敬法。布萨时应白比丘尼僧中说是八敬法。布萨竟至明日。是先受八敬法比丘尼。应还来礼是教诫比丘足。比丘尼僧和合。头面礼和合比丘僧足比丘尼僧和合布萨竟

次说比丘法。僧和合说戒时。是教诫比丘尼比丘。若闻说戒比丘言。僧今和合先作何事。是受教诫比丘尼比丘。应至上座所偏袒右肩胡跪合掌。比丘尼僧和合。头面礼和合比丘僧足。乞半月教诫法所敕教诫法。我当都受。上座应语和合比丘尼僧。不须作教诫羯磨。是比丘还语比丘尼。众僧语汝和合比丘尼僧教诫比丘尼羯磨佛已舍。凡教诫比丘尼比丘。不得出界外。若出界外得突吉罗罪

十诵尼律卷第四十七十诵律卷第四十八(第八诵之一)

        后秦北印度三藏弗若多罗共罗什译

    增一法之一

佛婆伽婆住舍婆提。长老优波离问佛。若男子作女人威仪。女人相女人服作女人形制已。如男子法受戒。得戒不。佛言。得戒。众僧得罪

又问。若女人作男子威仪。男子相男子服。作男子形制已如女人法受戒。得戒不。佛言。得戒。众僧得罪

又问。若未度出家。便与受具戒。得戒不。佛言。得戒。众僧得罪。尔时六群比丘。诱他弟子与法与食。诸上座呵责言。云何得教化弟子如法。六群比丘便诱将去与法与食诸比丘不知云何。以是事白佛。佛言。从今不得诱他弟子与法与食。若诱者得突吉罗

又问若比丘不欲反戒。便语他言。汝与我作和上为受和上即反戒耶。佛言。不也是戏语耳。佛知故问阿难。小儿能食上驱乌不。答言能世尊佛言。从今听沙弥能驱乌乃至七岁得作沙弥。尔时瓶沙王。以六岁一闰诸比丘不知云何。以是事白佛。佛言。应随王法。时王瓶沙。一岁作六月小。诸比丘不知云何。以是事白佛。佛言。应随王法。春初月大二月小。三月大四月小。夏初月大二月小。三月大四月小。冬初月大二月小。三月大四月小。又问。若非比丘住处说戒。是说戒不。佛言。若比丘尼说戒者。是说戒

又问。得戒沙弥说戒。是说戒不。佛言。不名说戒。得听说戒受岁。不得足数说戒受岁及余羯磨。颇有比丘。在地与空中清净不。佛言。不得在空中与地清净不。佛言。不得。二俱在空中得与清净不。佛言。不得。界内得与界外清净不。佛言。不得。界外得与界内清净不。佛言。不得。合界者得。共界内者得。又问。在地者得与空中清净说戒不。佛言。不得。空中得与地清净说戒不。佛言。不得。又问。二俱在空中。得与清净说戒不。佛言。不得。界内得与界外清净说戒不。佛言。不得。界外得与界内清净说戒不。佛言。不得。若合界者得。共在界内者得。又问在地得与空中欲不。佛言。不得。空中得与地欲不。佛言。不得。二俱在空中。得与欲不。佛言。不得。界内得与界外欲不。佛言。不得。界外得与界内欲不。佛言。不得合界者得。共在界内者得。又问在地得与空中欲羯磨不。佛言。不得。空中得与在地欲羯磨不。佛言。不得。二俱在空中。得与欲羯磨不。佛言。不得。界内得与界外欲羯磨不。佛言。不得。界外得与界内欲羯磨不。佛言。不得。合界者得共在界内者得。又问。在地得与空中欲不。佛言。不得。在空中得与地欲不。佛言。不得。二俱在空中。得与欲不。佛言。不得。界内得与界外欲不。佛言。不得。界外得与界内欲不。佛言。不得。合界者得。共在界内者得。又问。在地得与空中欲结界不。佛言。不得。空中得与地欲结界不。佛言。不得二俱在空中。得与欲结界不。佛言。不得。界内得与界外欲结界不。佛言。不得。界外得与界内欲结界不。佛言。不得。合界者得。共在界内者得。又问。若不舍先界。得广界狭界不。佛言。不得。又问。得并结界不。佛言。周匝说内相外相者得。又问。颇有结界不随羯磨舍耶。佛言有若墙堑内。又问。比丘在树上得结界不。佛言。若羯磨时众数满者得。又问。若僧破得结界不。佛言。如法者结界得。又问。过去佛法几时住世。佛言。随清净比丘不坏法说戒时。名法住世。又问。未来佛法几时住世。佛言。随清净比丘不坏法说戒时。名法住世。又问今世尊法几时住世。佛言。随清净比丘不坏法说戒时。名法住世。又问。若比丘聚落中初作僧坊齐几许作界。佛言。随聚落。随聚落界。齐行来处。又问。若比丘。阿练若住处初作僧坊齐几许作界。佛言。面各一拘卢舍。一拘卢舍此内诸比丘。皆共一处布萨作羯磨。不得别众说戒作羯磨别作者得罪。又问法灭时结界。名结界不。佛言不名结界。法灭时一切结界一切受戒一切戒一切羯磨皆灭。又问。若作羯磨比丘死。余比丘不知界相。得舍界不。佛言。得舍。又问比丘山上作僧坊。山下十拘卢舍得安居不。佛言得。又问。何处与安居物。佛言。安居处应与。又问。比丘山下作僧坊山上十拘卢舍得安居不。佛言得。何处应与安居物。佛言。随安居处与。又问。僧破作二分。若一分中有比丘出界。至地了时。是名破安居。失衣得自违言罪不。佛言。不破安居不失衣。但得自违言罪。又问。何处受七日法。佛言。界内受。从谁受。佛言。从五众受。比丘比丘尼式叉摩尼沙弥沙弥尼。又问心念得受七日法不。佛言。不得。除五种人。所谓阿练儿。独住人。远行人。长病人饥饿时亲里边住人。又问。有外道亲里。遣使唤比丘。大德来。今祠摩醯首罗天揵陀天摩尼跋陀天。得破安居去不。佛言。得去。为彼清净故。又问。若比丘诵阿含不通利。欲更诵利欲问欲更从他受。得破安居去不。佛言。得。又问。若未得者求得。未解者求解。未证者求证故。得破安居去不。佛言。得去

比丘白佛。用何皮作革屣。如先说。又问。云何名坐皮上。佛言。身著者。名为坐。又问。云何名为卧皮上。佛言。胁著者。名为卧。云何名著。佛言。从足至脐。是名为着。又问师子皮肉血筋。得食不。佛言。一切不得啖食。又问。黑鹿皮肉血筋。得食不。佛言。除皮余者得食。又问。佛先说不得食生肉血。若病余药不能治者。得食不。佛言。得食。若余药能治差者不得食。食者。得偷兰遮。有比丘病痔。往语耆域言。治我此病。耆域言。应刀割。比丘言。佛不听刀割。是事白佛。佛言。以指爪掐。掐时不能断。佛言。用[竺-二+韋]竹签竹割。割又不能断。是事白佛。佛言。应屏处刀割。

瓶沙王死时。诸比丘互相谓言。瓶沙王死。我等将不内宿耶。佛言。比丘。汝谓瓶沙王死故内宿耶。阿阇世王代处故。不名内宿。有比丘。为沙弥净人担食共道行。食时净人持食与比丘。比丘不食。将非残宿食耶。诸比丘不知云何。是事白佛。佛言。为他担者无犯。又问。不割截衣得受持不。佛言。得受。又问。得着入聚落不。佛言。不得。云何应割截。佛言。长五肘广三肘。有衣不满五肘。佛言。听畜三种衣。上中下。上者长五肘广三肘。下者长四肘广二肘半。此二中间名为中。以绳系泥洹僧故破。佛言。应作俱修罗著有软体。比丘揩膊伤破。是事白佛。佛言。下开五寸许。又问。比丘应受俱修罗不。佛言。不应受。得坏所受衣作俱修罗

憍萨罗国有人施僧衣。诸比丘不知云何分。是事白佛。佛言。分作四分。三分与比丘。一分与沙弥。憍萨罗国有一比丘死。不知云何分衣钵。是事白佛。佛言。分作四分。三分与比丘。一分与沙弥

新作只桓竟。多有比丘集。千二百五十人。诸居士见大众集。施比丘僧衣。诸比丘不受。佛未听我等受僧施衣。是事白佛。佛言。得受施僧衣。有人施比丘尼僧衣。诸比丘尼不受。佛未听我等受比丘尼僧施衣。是事白佛。佛言。听受比丘尼僧施衣。有人施二部僧衣。是二部僧不受。佛未听我等受二部僧衣。是事白佛。佛言。听受二部僧衣。不知云何分。是事白佛。佛言。作四分。三分与比丘比丘尼。一分与式叉摩尼沙弥沙弥尼

有居士见大众集。施比丘僧衣。居士心念。一比丘与我等唱说者善诸比丘以是事白佛。佛言。听唱。唱者在地不得远闻佛言。听在埵上。埵上亦不得远闻。佛言。应在高处令远处得见亦闻有诸居士。见大众集施衣。作是念。听我安衣架上入僧者善。以是事白佛。佛言听。有居士。见大众集施僧衣。作是念。听一人赞叹僧者善。以是事白佛。佛言。听赞叹。赞叹僧者作是言。僧持戒具足。念具足。三昧具足。智慧具足。解脱具足。度知见具足。学无学俱解脱。向果得果。是中有未得道者。疑不受分。我非学无学非俱解脱。非向果得果故。不应受分以是事白佛佛言。应受。若持戒与僧和合。求解脱离生死。向泥洹不求后生行三业坐禅诵经佐助众事。如是行者。得清净受分

尔时世尊。与五百阿罗汉。入首波城。到长者蛆毗揵挐舍受食已。至阿耨达池上食。鹿子母闻。今日世尊与五百阿罗汉入首波城。诣长者蛆毗揵挐舍受食已。到阿耨达池上食。闻已生信净心往到佛所。头面礼足在一面坐已白佛言。世尊。今日与五百阿罗汉入首波城。诣长者蛆毗揵挐舍受食已至阿耨达池上食。世尊。我今请佛及别请五百阿罗汉明日食。佛默然受。知佛默然受已。头面作礼右绕而去。到舍竟夜办种种多美饮食。晨朝敷坐处。阿难与佛迎食分。时鹿子母。先唤阿难入舍已闭门。往白时到。饮食已办佛自知时。时五百阿罗汉。各以神力。从窗孔入者。或从空中下者。或从地出者。有座上出者。鹿子母见僧坐已开门。自手行食。时阿难。先自食已送佛食分。往到佛所行水授食。佛食已行澡水摄钵摄钵已阿难白佛言。世尊。今日鹿子母。别请五百阿罗汉食。佛知故问阿难。僧中请一比丘不。答言无。佛言。是鹿子母无知不善。不僧中请一人。佛语阿难鹿子母。若僧中请一人者。因是后身得大功德。得大果报。得大利益。一切远近遍闻佛语。僧中请一人得大福。胜别请五百阿罗汉

有信婆罗门居士。与僧作小食中食怛钵那。作是念。佛听请一人赞叹僧者善。是事白佛。佛言听赞叹。赞叹者作是言。持戒具足念具足。三昧具足智慧具足。解脱具足度知见具足。学无学具足。俱解脱向果得果。是中有未得道者。心疑不受。我非学非无学。非俱解脱。非向果得果故。不食。是事白佛。佛言。听食。若持戒与僧和合。求解脱离生死。向泥洹不求后生。行三业坐禅。诵经佐助众事。如是行者。得清净受食

又问。若僧受迦絺那衣时。有比丘在中不名受耶。佛言有。如杂诵中说。颇有比丘。受迦絺那衣时。不在中得名受耶佛言有。如杂诵中说。颇有比丘。舍迦絺那衣时。在中不名舍耶。佛言有。如杂诵中说。颇有比丘。不舍迦絺那衣。得名舍耶。佛言有。如杂诵中说

又问。得戒沙弥得遮他不。佛言。不得。又问。得受嘱受遮他不。佛言。不得。又问。得遮羯磨不。佛言。不得。又问。白衣得遮不。佛言。不得。又问。沙弥得遮不。佛言。不得。又问。非比丘外道。不见摈不作摈。恶邪不除摈。不共住种种不共住。自言犯重罪。本白衣污比丘尼。不能男越济人。杀父母杀阿罗汉。破僧恶心出佛身血。如是等人得遮不。佛言。不得

又问。若在地空中。空中在地。二俱在空中。界内界外。界外界内。不到僧中。不白众僧破戒人。心念欲遮。得遮不。佛言。不得。又问。得戒沙弥。得说羯磨不。佛言。不得。如先说。先犯重罪人。贼诈作比丘。本白衣时破戒人。若先言我破戒。后作羯磨。得名羯磨不。佛言。不得。若先作羯磨。后言我破戒。得名羯磨不。佛言得

又问。颇有受戒时作羯磨受戒已舍羯磨耶。佛言有。舍何羯磨。答言。大戒羯磨是。颇有受戒人。作羯磨未受大戒人舍耶。佛言有。云何有。答言。我是白衣。即舍一切羯磨。颇有摈比丘心悔下意。界外与舍摈。得舍不。佛言。得舍。诸比丘得罪

又问。犯何罪与苦切羯磨。佛言。斗诤。又问。犯何罪作依止羯磨。佛言。数数犯戒。又问。犯何罪作驱出羯磨。佛言。污他家。又问。犯何罪作下意羯磨。佛言。骂白衣。又问。若比丘骂比丘。得作下意羯磨不。佛言。得作。若骂比丘尼式叉摩尼沙弥沙弥尼。得作下意羯磨不。佛言。得作。若比丘尼骂比丘尼。得作下意羯磨不。佛言。得作。若骂式叉摩尼沙弥沙弥尼比丘。得作下意羯磨不。佛言。得作。若式叉摩尼骂式叉摩尼得作下意羯磨不。佛言。得作。若骂沙弥沙弥尼比丘比丘尼。得作下意羯磨不。佛言。得作。若沙弥骂沙弥。得作下意羯磨不。佛言。得作。若骂沙弥沙弥尼比丘比丘尼式叉摩尼。得作下意羯磨不。佛言。得作。若沙弥尼骂沙弥尼。得作下意羯磨不。佛言。得作。若骂比丘比丘尼式叉摩尼沙弥。得作下意羯磨不。佛言。得作。又问。沙弥自言作。淫与灭摈不。佛言。与灭摈又问。颇有比丘。减五岁尽形不依止他。不得罪耶。佛言有。若比丘未满五岁便死若尽形和上边住

又问。颇有比丘。犯僧伽婆尸沙不相似罪。犯故出精。一夜覆藏。犯故触女身二夜覆藏。犯恶口。三夜覆藏。犯赞叹以身供养。四夜覆藏。犯媒嫁。五夜覆藏。五夜别住。六夜摩那埵。得与出罪羯磨不。佛言得。又问。如佛所说。犯相似罪不相似罪。云何名相似。佛言。波罗夷。波罗夷相似。僧伽婆尸沙。僧伽婆尸沙相似波夜提。波夜提相似。波罗提提舍尼。波罗提提舍尼相似。突吉罗。突吉罗相似。是名犯相似。云何不相似。波罗夷。与僧伽婆尸沙波夜提波罗提提舍尼突吉罗。不相似。僧伽婆尸沙。与波夜提波罗提提舍尼突吉罗波罗夷。不相似。波夜提。与波罗提提舍尼突吉罗波罗夷僧伽婆尸沙。不相似。波罗提提舍尼。与突吉罗波罗夷僧伽婆尸沙波夜提。不相似。突吉罗。与波罗夷僧伽婆尸沙波夜提波罗提提舍尼。不相似

又问。如佛说有犯可量犯不可量。云何可量犯。佛言。可得说数。云何不可量犯。佛言。不可说数。又问。如佛说犯覆藏犯不覆藏。云何犯覆藏。佛言。须臾顷不发露。云何。名不覆藏。须臾顷不覆藏。佛语优波离。有一种犯。性各各异。波罗夷性各各异。僧伽婆尸沙性各各异。波夜提性各各异。波罗提提舍尼性各各异。突吉罗性各各异。诸比丘与他别住已。遣使扫余房舍。处处出入多有人见。佛言。与他别住已。应使扫住。处房内。不得遣使扫余房舍。时在屏处住。客比丘来不见。佛言。不应在屏处住。客比丘来时应见。尔时自唤客比丘。唤已扰乱。佛言。不得唤他但语令知。有客比丘去便走逐。佛言。如常行法不应走逐。时逐出界。佛言。不应出界。若前人出界自齐界住。从今语汝等别住法。应扫洒佛塔涂地。布萨处亦应扫洒涂地。食处亦应扫洒涂地。次第敷床座。应办洗脚水净水瓶常用水瓶盛满水。应语客比丘令知。应拭富罗拭脚。一切别住法应作。下应屏处住。不应现处住。又问。得别住已。得与他作别住摩那埵本日治出罪不。佛言。不得。又问。得戒沙弥。得与他作别住摩那埵本日治出罪不。佛言。不得。又问。得就别住人边行别住不。佛言。不得。又问。得就得戒沙弥行别住摩那埵不。佛言。不得。又问。得与别住人欲清净受岁出罪不。佛言。不得。又问。得与得戒沙弥清净欲受岁出罪不。佛言。不得。又问。得受别住人清净欲受岁出罪不。佛言。不得。又问。得受得戒沙弥清净欲受岁出罪不。佛言。是大比丘故得受。又问。用何物作户纽。佛言。以铜铁木羊毛刍摩劫贝龙须麻婆婆草皮等作。又问。用何物作络。佛言。以羊毛刍摩劫贝龙须麻婆婆草皮等作。又问。用何物作禅带。佛言。用羊毛刍摩劫贝龙须麻婆婆草皮等作。又问。用何物作雀目。佛言。用木竹作。尔时瓶沙王。请佛及僧百岁供养。所供给人少信。作食不如法。诸比丘求食时恼乱。多人见。是王信心清净。问。诸比丘恼乱耶。答言。恼乱。王言。我亦知大德恼乱。我当供给田宅具足随意。诸比丘言。佛未听我等受田宅。是事白佛。佛言。听受。又居士祇洹中作房舍已。供养衣食卧具医药。是房舍主比丘。后日往到居士舍索所须。到已就坐问讯时。居士妇头面礼足在前坐。即为种种说法。善软说法辩才说法。以如是说妙法。居士妇闻法已信心清净。白言。大德。此衣为大德故。施僧房中僧。是男女儿妇等。亦施僧坊内僧。是比丘作是念。我正须一衣。今此衣多。不知云何以是事向佛广说。佛言。若居士作僧房若为一比丘。施僧房内僧者。房内僧应共分。时阿罗毗僧房坏。佛见已知而故问阿难。此房何以坏。阿难答言。六群比丘所护故。无人敢治。佛言。是六群比丘房舍坏不能治者。应与他治。余人得已少治便止若着一团泥。一把草涂少地。少塞壁孔。少治土埵。佛言。少治者不应与。多治者与又尽形与。佛言。不应尽形与。不应少时与若坏房舍者六岁与。若新房舍十二岁与。阿罗毗巧匠比丘。日日从他索作具。诸居士言。大德何不自作。答言。佛未听畜。是事白佛。佛言。应畜作具。阿罗毗新作僧房。时有半月客作人。或一月或一岁作。若天雨时。索食薪草灯。比丘与时。心疑畏罪不与。若不与便不作。诸比丘不知云何。是事白佛。佛言。若知早晚唤来便作者应与。有比丘着新染衣。天雨时露地洗脚。污衣失色。斑驳如白癞病。是事白佛。佛言。应作舍。作已不覆故雨时漏。佛言。应覆。覆已脊上漏。佛言。应厚覆脊上。王舍城大僧坊。常多有客比丘来初夜中夜后夜来。时上座比丘。驱下座起扰乱。诸比丘不知云何。是事白佛。佛言。若打犍捶唱时。然灯分坐具敷卧具。见星宿出时。着禅镇头上。若上座来不应驱起若驱起者突吉罗。又下座在上座处坐。上座呵责。云何下座在上座处坐。是事白佛。佛言。下座不得坐上座处。若坐者突吉罗。下座比丘。应看坐处看腊数。应可坐处坐。阿罗毗上座。初夜坐禅中夜还房。时弟子送上座去。后下坐比丘沙弥从地起。或从板上起。就床上卧。上座还来。次第驱去不肯。与起斗诤。诸比丘不知云何。是事白佛。佛言。若中夜敷卧具竟。不得次第起他。若起他者突吉罗。六群比丘。大小便处取水处。随上座次第驱起恼乱。有比丘得恼。诸比丘不知云何。是事白佛。佛言。从今大小便处取水处。不得次第驱起。驱起者。突吉罗罪。六群比丘。洗脚处次第驱他起恼乱。诸比丘不知云何。是事白佛。佛言。从今洗脚处他已着水。不得次第驱他起。僧拭脚物。有比丘先取浣捩展拭富罗。时六群比丘次第夺取。他不与斗诤。诸比丘不知云何。是事白佛。佛言。前取者用。后来者应待用竟

众僧煮粥釜杓朼。有比丘已取洗。六群比丘次第夺取。他不与斗诤。诸比丘不知云何。以是事白佛。佛言。先取者用。后来者应待竟。僧有木盔木盂。有比丘取洗欲用。六群比丘次第夺取。他不与斗诤。诸比丘不知云何。是事白佛。佛言。先取者用。后来者应待竟。僧有钵盆子杅子键瓷。有比丘已取澡豆洗用。六群比丘次第夺取。他不与斗诤。诸比丘不知云何。是事白佛。佛言。先取者用。后来者应待竟。僧有剃刀镊截甲刀。有比丘先取磨用。六群比丘次第夺取他不与斗诤。诸比丘不知云何。是事白佛。佛言。先取者用。后来者应待竟。僧有衣床絣衣绳针刀木灌指[打-丁+沓]。有比丘先取张衣缀衣缝衣。六群比丘。次第夺取破裂坏衣。他不与斗诤。诸比丘不知云何。是事白佛。佛言。不应与。先用者用。后来者待竟。从今如是种种事。不得次第夺他取。若夺取者突吉罗。尔时长老毕陵伽婆蹉患眼痛。往到医所。医言。应灌鼻。答言。佛未听灌鼻。是事白佛。佛言。听灌。时或以指着。或以物着。流入眼更增痛。是事白佛。佛言应作灌鼻筒。大不可用。又小作。亦不可用。是事白佛。佛言。莫大作莫小作。可受一波罗半波罗许

僧有香炉香奁针筒。有比丘先取用。六群比丘次第夺取。他不与斗诤。诸比丘不知云何。是事白佛。佛言。先取者用。后来者待竟。尔时六群比丘浴室中相谓言。是揩某甲是揩某甲。诸比丘不知云何。以是事白佛。佛言。浴室中不得言揩某甲揩某甲。犯者突吉罗。有比丘。共白衣浴室中洗。有下座比丘沙弥揩上座。是白衣共相谓言。但揩是耶。更作如是如是事。诸比丘闻已心不喜。以是事白佛。佛言。从今不得共白衣浴室中洗。犯者得突吉罗罪。有优婆塞病。欲入浴室中洗。佛言。应白比丘已入洗。时白比丘。比丘不听。佛言。诸比丘若知是优婆塞善好无口过者听入。有比丘浴室中揩白衣。佛言。浴室中不得揩白衣。犯者得突吉罗。阿罗毗国分卧具。多有客比丘暮来。卧具少。诸比丘不知云何。以是事白佛。佛言。随上座次与。不得者与草叶。各敷敷具各着衬身衣。六群比丘以浮石揩身毛落。佛言。不得以浮石。揩身。犯者得突吉罗。维耶离庵罗树园。有好果黄色在地。佛见是已。知而故问阿难。诸比丘。何不啖此果。阿难言。世尊。佛先结戒。四种物僧不应分。三人二人一人亦尔。不应分僧坊地僧坊舍僧园林僧卧具。佛言。果应分。分时一人取二人三人分。有多得者有不得者。时共斗诤。佛言。果不应分。使净人作五种净已受啖。有比丘共比丘斗。是比丘后更共余比丘斗。即捉是人耳作证。失声大唤。多有比丘来问。何故大唤。答言。是比丘打我。问言。实打不。答言。我不打。但捉耳作证。是比丘先共我斗。欲谤我故大唤。佛言。从今不得捉他耳作证。犯者突吉罗罪。若有如是事。应语谤人言。是比丘骂我打我。时六群比丘诱他弟子。诸上座呵责言。我等云何得教化弟子如法。是六群比丘便诱将去。佛言。从今不得诱他弟子。犯者得突吉罗罪。有诸比丘舍僧坊去。作是言。我不复还是处。是名舍界不。佛言舍。又问。用何物作锥。佛言。用铜铁作。又问。用何物作刀。佛言。用铜铁作。又问用何物作熨斗。佛言。用铜铁泥作又问。用何物作瓮。佛言。用铜铁泥木作。又问。用何物作釜。佛言。用铜铁泥作又问用何物作澡豆。如先说。憍萨罗国父子共出家。父语子言何不与我衣食。答言。俱共出家无物可用与诸比丘不知云何。是事白佛。佛言。有者应与。无者不得强索。尔时六群比丘。有大沙弥。隐处毛生。小违逆师意。师即剥衣裸身可羞。人所不喜。是事白佛。佛言。不应以小事折伏沙弥。若折伏时应留一衣。诸比丘不能得簁药物。佛言应作簁药器给孤独居士施僧褥。诸比丘言佛未听我受。是事白佛。佛言。僧得受一人亦得受。又问佛先说床脚下安高八指榰。云何床脚下着八指榰佛言。若床脚减八指者应着木榰。有比丘。先取价与他药吐下。是人即死。有比丘谓言。汝犯波罗夷。何以故。答言。先取价与他下药。是比丘心疑。将不犯波罗夷耶。是事白佛。佛知故问。汝以何心与。答言。怜愍故与。佛言。无罪。佛言。从今不得先取价与他药。犯者得突吉罗。有比丘。从憍萨罗。共估客向舍卫国。时贼来劫。估客才得活命。是估客为贼所剥。才得活命已。诸比丘拾他衣取。心疑将不犯波罗夷耶。是事白佛。佛言。无罪。憍萨罗国有天祠舍。有冢以血污洒。有诸比丘。从憍萨罗游行向舍卫国。右绕此冢左绕祠舍。时天祠主言。大德。何以右绕冢左绕祠答言。我谓是佛塔声闻塔。诸比丘不知云何。以是事白佛。佛言。若冢若天祠。不必右绕亦不必左绕。但随道行。有比丘。饥饿时至亲里家。四五日住已言。我欲还去。何故去。如先说。六群比丘授无钵人戒。是六群常与十七群共诤。六群次守僧坊。十七群次与迎食。往语六群弟子言。取钵来。与汝迎食。答言。无钵。语言。汝无钵受戒耶。答言尔。又言。汝是大力势人无钵受戒。是比丘闻是事心不喜。是事白佛。佛言。从今不得授无钵人戒。犯者得突吉罗。有二比丘共斗。一比丘书他钵作字。着淫女门前。时有识字婆罗门居士入是舍。见钵有字作是言。比丘亦入是舍。比丘闻是语心不喜。是事白佛。佛言。从今不得钵上作字。若钵上作字者突吉罗。如钵一切余物亦尔。不犯者。作帜。有外道信心欲出家。往到比丘所言。大德。与我出家。问言。有钵无。答言。无钵。我等不得与无钵人出家。闻是语已还去。断出家因缘。诸比丘不知云何。以是事白佛。佛言。不得先问钵。度出家已求钵。给孤独居士施僧被。诸比丘不受。佛未听我受。是事白佛。佛言。僧得受一人亦受。有居士儿出家是居士得病语诸亲里。我若死后财物与我儿。语已命终此儿后还家看。坐已共相问讯。诸亲里言。汝父临死时作是言。我死后财物与儿。比丘答言。佛未听我受死后布施。是比丘不知云何。是事白佛。佛言。我先为比丘故说。不为白衣。应随意取。有比丘二月游行。与六群比丘知识。即以衣寄六群。六群问言。何去。答言。我欲二月游行。如先说。尔时助调达比丘尼。语白衣言我共汝作婚姻。诸居士言。汝是出家人。云何共我作婚姻。诸比丘尼不知云何。是事白佛。佛言。从今比丘尼。不得语白衣共作婚姻。若语者突吉罗。有一比丘。先与居士衣价。是比丘后命终。诸比丘不知云何。是事白佛。佛言。应索物取与僧分。有比丘。先取他衣未与价。是比丘后命终。是居士到比丘所言。大德。是比丘先取我衣。未与我价。诸比丘。答言。是比丘生时何不来索。诸比丘不知云何。是事白佛。佛言。若是衣故在者应还。若无者应卖衣钵还。六群比丘与白衣。作义仲取发取华。诸白衣呵责言。汝等出家人。何用此义仲用取发取华为。诸比丘闻是事白佛。佛言从今不得作义仲截发取华。犯者突吉罗。六群比丘与一比丘作善知识。是比丘寄一比丘钵与六群。是钵中道破。是比丘见六群时。作是念。我若不疾语者。或多索价。便言。某甲比丘寄我钵与汝。是钵中道破。六群言。是汝钵不破。破我钵。汝偿我来是比丘不知云何。是事白佛。佛言。若好心捉破者。不应从责偿。有比丘。用未熏钵食。放地剥落垢生。是事白佛。佛言应熏。时比丘取钵放地。四边着牛屎烧时破。是事白佛。佛言应作熏钵炉。作已放地烧。烧时融坏。是事白佛。佛言。先下着灰着灰已污钵。是事白佛。佛言。应以石支。支时不周匝遮。炉风入故皱起。是事白佛。佛言。应周匝好遮

给孤独居士往到佛所。头面作礼一面坐已。白佛言。世尊。若世尊游行人间教化时。我恒渴仰欲见佛。愿世尊与我少物使得供养。佛即与发爪甲。汝供养是。即白佛言。世尊。听我以发爪起塔。佛言。听起。又言。佛听我以赤色黑色白色涂壁不。佛言。听以赤色黑色白色涂壁。又言。佛听我画塔者善。佛言。除男女和合像。余者听画。有人作盖供养。无安盖处。佛言应钉橛安。时塔户无扇。牛鹿猕猴狗等入。以是事白佛。佛言。应作户扇。佛听我户前施栏楯者善。以是事白佛。佛言。听作。佛听我周匝施栏楯者善。以是事白佛。佛言。听作。是中无著华处。是事白佛。佛言。听作安华物。着华已器满。佛言应施曲橛。施曲橛亦满。佛言。应周匝悬绳。时居士作是念。佛听我作摩尼珠鬘新华鬘者善。以是事白佛。佛言。听作。又作是言。佛听我作窟者善。佛言。听作。又言。佛听我窟中作塔者善。佛言。听窟中起塔。佛听我施窟门者善。是事白佛。佛言。听作。佛听我覆窟中塔者善。佛言。听覆。佛听我出舍栿头者善。佛言。听出。佛听我安栌拱者善。佛言。听作。佛听我施柱作塔者善。佛言。听作。佛听我以彩色赭土白灰庄严塔柱者善。佛言。听庄严柱。佛听我画柱塔上者善。佛言。除男女合像。余者听作。尔时给孤独居士信心清净。往到佛所头面作礼一面坐已。白佛言。世尊。如佛身像不应作。愿佛听我作菩萨侍像者善。佛言。听作。又作是言。佛本在家时。引幡在前。愿佛听我作引幡在前者善。佛言。听作。佛听我塔前作高垛安师子者善。佛言。听作。佛听师子四边作栏楯者善。佛言。听作。佛听我以铜作师子者善。是事白佛。佛言。听作佛。听铜师子上系幡者善。是事白佛。佛言。听系。佛听我以香华灯伎乐供养者善。是事白佛。佛言。听作。佛听我以香华油涂塔地者善。是事白佛。佛言。听香华油涂塔地。佛听我作安华垛者善。佛言。听作。佛听我作安灯处者善。佛言。听作。佛听我作团堂者善。佛言。听作。佛听堂上安木悬幡者善。佛言。听作。

时给孤独居士。亲里相识举物人。庄严男女。盘案上着华香璎珞。遣至居士家。居士见已作是念。此物在前行者善。以是事白佛。佛言听。佛听我作香炉在前行者善。佛言。听在前行。有诸外道。主嫉妒心。见已呵责言。如送死人。是居士作是念。佛听我像前作伎乐者善。以是事白佛。佛言。听作。尔时给孤独居士信心清净。作是念。以何方便。得集大众供给衣食。往白佛言。愿佛听我集大众食者善。佛言。听集大众食。作是言。佛听我供养塔时与大众食者善。是事白佛。佛言。听作。佛听我作般阇于瑟会者善。是事白佛。佛言。听作般阇于瑟会。佛听我作六年会者善。是事白佛。佛言。听作。佛听我正月十六日乃至二月十五日作会者善。是事白佛。佛言。听作。佛听我寺中作会者善。是事白佛。佛言。听作。时诸比丘。不次第入。不次第坐。不次第食。不次第起。不次第去。有前入者。有行食时入者。有食时入者。有食竟入者。佛言。应唱时至。唱时至声不远闻。是事白佛。佛言。应打揵捶。打揵捶已亦不远闻是事白佛。佛言。应打鼓。打鼓时在地打鼓亦不远闻。是事白佛。佛言。在垛上打。垛上打时亦不远闻。佛言。应在高处打使远处得闻时。见大众集多人来看。与供养塔物。与四方僧物。与食物。与应分物。诸比丘不知。何者是塔物。何者四方僧物。何者食物何者应分物。是事白佛。佛言。与物时使一比丘在彼立看知分别。是塔物四方僧物食物应分物。长老优波离问佛言。世尊。是四种物。塔物四方僧物食物应分物。得错互用不。佛言。不得。佛语优波离。塔物者。不得与四方僧。不得作食。不得分。四方僧物者。不得作食。不得分。不得作塔。食物者。不得分。不得作塔。不得与四方僧。应分物者。随僧用

一法初

说一语竟。名为舍戒。云何说一语。名为舍戒。谓言舍佛。说是一语。名为舍戒。如是法僧和上阿阇梨同和上阿阇梨。比丘比丘尼式叉摩尼沙弥沙弥尼知。我是白衣。我是沙弥。我非比丘我是外道。非沙门非释子。我不受汝法。说是一语。名为舍戒。若比丘多知识有力势。所可说者人皆信用。众所知识能供给僧非法说法。法说非法。非毗尼说毗尼毗尼说非毗尼。犯说不犯。不犯说犯。重说轻。轻说重。无残说残。残说无残。非常所行事说是常所行事。是常所行事说非常所行事。非说言说。说言非说。是人得大罪。若比丘多知识有力势。所可说者人皆信用。众所知识能供给僧。非法说非法。法说法。非毗尼说非毗尼毗尼说毗尼。犯说犯。非犯说非犯。重说重。轻说轻。无残说无残。残说残。非常所行事说非常所行事。是常所行事说是常所行事。非说言非说。说言是说。是人得大功德。若比丘多知识有力势。所可说者人皆信用众所知识能供给僧。非法说法。法说非法。乃至说言非说。非说言说。是人不能自利。亦不利他。不能益多人。不能怜愍众生。不能利益安乐天人。若比丘多知识有力势。所可说者人皆信用。众所知识能供给僧。非法说非法。法说法。乃至非说言非说。说言是说。是人能自利亦能利他。能益多人。怜愍众生利安天人。若比丘多知识有力势。所可说者人皆信用众所知识能供给僧。非法说法。法说非法。乃至非说言说。说言非说。是人有罪有犯有悔。心恼所作皆生悔心。非清净非解脱。损减不增长。自羞退没人所轻毁。造诸罪业。若比丘多所知识有力势。所可说者人皆信用。众所知识能供给僧。非法说非法。法说法。乃至非说言非说。说言说。是人无罪无犯无悔。无恼所作不悔。清净解脱不损减得增长。自身所作人所赞叹。造诸善业。如来出世现毗尼法。不一时说戒。渐渐说。如来出世现毗尼法。不一时破。渐渐破。有比丘。多知识有力势。所可说者人皆信用。众所知识能供给僧。于如来所现毗尼法中。更生异想。于文字中。更作相似文句。遮法覆法。不随顺法。所说不了。是边人下贱人。无益于世。无男子行。若比丘多知识有力势。所可说者人皆信用。众所知识能供给僧。于如来所现毗尼法中。不生异想。于文字中。不作相似文句。不遮法不覆法。随顺法所说明了。是非边人。非下贱人。非无利益。有男子行

佛在释迦国。大爱道往到佛所。在一面立已白佛言。世尊。愿寿一劫住世。以是因缘故。佛语大爱道。不应如是赞叹如来。汝所赞叹者。非好赞叹。不应以是赞叹如来。是非赞叹如来法。有一法。令法灭亡没。破僧故。有一法。法不灭不亡不没。和合僧故。有一法。法灭亡没。斗故。法灭亡没。如是共诤相骂相言故。法灭亡没。有一法。法不灭不亡不没。不斗故。法不灭不亡不没。如是不共诤不相骂不相言故。法不灭不亡不没。有一法。法灭亡没。贪故。法灭亡没。如是无厌多欲不知足恶欲恶见故。法灭亡没。有一法。法不灭不亡不没。不贪故。法不灭不亡不没。如是有厌少欲知足不恶欲不恶见故。法不灭不亡不没。随何方有比丘斗。共诤相骂相言。如是方不应闻。何况忆念。有如是斗诤相骂相言过故。随何方有比丘斗诤相骂相言。更不应念。何况往到。多有斗诤相骂相言过故。随何方有比丘。不斗不诤不相骂不相言。如是方应闻。何况不忆念。无是斗诤相骂相言过故。随何方有比丘。不斗不诤不相骂不相言。如是方应更忆念。何况不往。无如是斗诤相骂相言过故。随何方有比丘。斗诤相骂相言。实知是处舍三法受三法。舍三法者。舍遮欲觉。舍遮嗔觉。舍遮嫉妒觉。是名舍三法。受三法者。受欲觉受嗔觉受嫉妒觉。是名受三法。多有是斗诤相骂相言过故。随何方有比丘。不斗不诤不相骂不相言。实知是处舍三法受三法。舍三法者。舍欲觉舍嗔觉舍嫉妒觉。受三法者。受遮欲觉。受遮嗔觉。受遮嫉妒觉。无是斗诤相骂相言过故。随何方有比丘。斗诤相骂相言。实知彼处舍三法受三法。舍三法者。舍遮欲想。舍遮嗔想。舍遮嫉妒想。是名舍三法。受三法者。受欲想受嗔想受嫉妒想。是名受三法。有是诸过斗诤相骂相言故。随何方有比丘。不斗不共诤不相骂不相言。实知彼处舍三法受三法。舍三法者。舍欲想舍嗔想舍嫉妒想。是名舍三法。受三法者。受遮欲想。受遮嗔想。受遮嫉妒想。是名受三法。无是斗诤相骂相言过故。随何方有比丘。共斗诤相骂相言。实知是处舍三法受三法。舍三法者。舍遮欲界。舍遮嗔界。舍遮嫉妒界。是名舍三法。受三法者。受欲界受嗔界受嫉妒界。是名受三法。有是斗诤相骂相言过故。随何方有比丘。不斗诤不相骂不相言。实知是处舍三法受三法。舍三法者。舍欲界舍嗔界舍嫉妒界。是名舍三法。受三法者。受遮欲界。受遮嗔界。受遮嫉妒界。是名受三法。无是斗诤相骂相言过故(一法竟)

    二法初

有二法。无智犯罪。不自见过。不悔是罪。有二法。有智犯罪。见过。见过已能悔是罪。有二犯。轻犯重犯。更有二犯。有残无残。更有二犯。可向他悔过。可自心悔过。有二众。法众非法众。复有二众。浊众清净众。有二法故。僧名苦住。不乐住数数犯。不随顺教随顺恶法。有二无智。应悔不悔。不应悔便悔。有二智。应悔便悔。不应悔不悔。有二无智。有犯有覆藏。有二智。不犯不覆藏。无智覆藏者。有二果。地狱饿鬼。有智不覆藏者。有二果。人天。佛言。我有所说。不信受故。便覆藏。覆藏者。不得离生老病死忧悲苦恼。我有所说。能信受者。是名不覆藏。不覆藏者。得离生老病死忧悲苦恼。有二善。知犯知悔过。有二清净。戒清净见清净。有二非法见。非法见法。法见非法。有二法见。非法见非法。法见法。有二毗尼。贪欲毗尼。嗔恚毗尼。有二毗尼。比丘毗尼。比丘尼毗尼。有二毗尼。遍毗尼。不遍毗尼。有二法。多知识人有过。非法作法。法作非法。是名有过。有二法。多知识人无过。非法作非法。法作法。是名无过。有二法断事人有过。非法作法断。法作非法断。是名有过。有二种。断事无过。非法作非法断。法作法断。是名无过。有二种说有过。非法说法。法说非法。是名有过。有二说无过。非法说非法。法说法。是名无过

有二种法。教化人有过。非法作法教。法作非法教。是名有过。有二法。教化人无过。非法作非法教。法作法教。是名无过。有二法。法灭亡没。有比丘。疑法疑毗尼。是名二法法灭亡没。有二法。法不灭不亡不没。不疑法不疑毗尼。是名二法法不灭不亡不没。有二法。法灭亡没。有比丘。教他非法。教他非毗尼。是名二法法灭亡没。有二法。法不灭不亡不没。如法教如毗尼教。是名二法法不灭不亡不没。有二事故。佛断别众食。利益檀越。不令恶比丘得力。清净众得安乐。有二事故。世尊作苦切羯磨。令恶人不得力。清净人得力。如是依止羯磨。驱出羯磨。下意羯磨。不见摈不作摈。恶邪不除摈。别住摩那埵。本日治出罪。令恶人不得力。清净人得力。有二法斗诤。非法言法。法言非法。是名二法斗诤。相骂相言不止。种种相言不用毗尼法。僧破僧恼僧别僧异。有二法不斗诤。非法言非法。法言法。如是不斗诤不相骂不相言。止不种种相言。用毗尼法。僧不破僧不恼僧不别僧不异。有二事故。世尊教作和上。现得清净持戒。后得安乐梵行久住。如是阿阇梨。共行弟子。近行弟子沙弥。教诫比尼波罗提木叉。说波罗提木叉。遮波罗提木叉自恣。自恣人遮自恣。证他罪令他忆罪。羁系羯磨。共要羯磨。听听羯磨。听白羯磨。皆现得清净持戒。后得安乐梵行久住。有二事故。世尊说现前毗尼。现得清净持戒。后得安乐梵行久住。如是忆念毗尼。不痴毗尼。自言毗尼。觅罪相毗尼。多觅毗尼。布草毗尼。是亦现得清净持戒。后得安乐梵行久住。有二事故。世尊说苦切羯磨。现得清净持戒。后得安乐梵行久住。如是依止羯磨驱出羯磨下意羯磨。不见摈不作摈恶邪不除摈别住摩那埵本日治出罪羯磨。是亦现得清净持戒。后得安乐梵行久住。有二谤佛。非法言法。法言非法。有二不谤佛。非法言非法。法言法。有二出佛过。非法言法。法言非法。有二不出佛过。非法言非法。法言法。有二不随佛语。非法言法。法言非法。有二随佛语。非法言非法。法言法。有二不随毗尼。非法言法。法言非法。有二随毗尼。非法言非法。法言法。有二罪。非法言法。法言非法。有二无罪。非法言非法。法言法。有二弃。自作弃所须。和合僧如法弃所须。有二不弃。自作不弃所须。和合僧如法不弃所须。有二不共住。自作不共住。和合僧如法与不共住。有二共住。自作共住。和合僧如法与共住。有二不共住有过。自作不共住。和合僧如法与不共住。有二共住无过。自作共住。和合僧如法与共住。有二损。自作损。和合僧如法与损。有二不损。自作不损。和合僧如法与不损。有二狂人。与痴羯磨。有念者。有不念者。有二本先狂。有二咒狂。有二药狂。有二心狂。有二苦痛狂。有二白法。护世间。有惭有愧。若是二白法惭愧。不护世间者。则不分别父母兄弟姊妹儿女亲里。则破人法。如牛羊鸡狗野干鸟兽。若是二白法惭愧。在世间者。则分别父母兄弟姊妹儿女亲里。不破人法。非如牛羊鸡狗野干鸟兽。无是惭愧。有白法者。终无是处。心无白法。但有生死无有解脱。有是惭愧白法在心即得清净。则不生死度生死岸。更不受有(二法竟)

十诵律卷第四十八

给孤独居士。往到佛所。头面作礼一面坐已。白佛言。世尊。若世尊游行人间教化时。我恒渴仰欲见佛。愿世尊与我少物使得供养。佛即与发指甲。汝供养是。即白佛言。世尊。听我以发爪起塔。佛言。听起。又言。佛听我以赤色黑色白色涂壁。佛言听。以赤色黑色白色涂壁。又言。佛听我画塔者善。佛言。除男女合像。余者听画。又人作盖供养。无安盖处。佛言。听打橛安。时塔户无扉。牛鹿猕猴狗等入。是事白佛。佛言。应作户扉。佛听我户前施栏楯者善。佛言。听汝作栏楯。佛听我周匝作栏楯者善。是事白佛。佛言。听汝作周匝栏楯。是中无著华处。是事白佛。佛言。听作安华物。着华已器满。佛言。应施曲橛亦满。佛言。应周匝悬绳。时居士作是念。佛听我作摩尼珠鬘新华鬘者善。佛言。听作摩尼珠鬘新华鬘。作是言。佛听我作窟者善。佛言。听作窟又言。佛听我窟中作塔者善。佛言。听窟中起塔。佛听我施窟门者善。是事白佛。佛言。听施窟门。佛听我覆窟中塔者善。佛言。听覆窟中塔。佛听我出舍伏头者善。佛言。听出舍伏头。佛听我安栌栱者善。佛言。听作安栌栱。佛听我施柱作塔者善。佛言。听施柱作塔。佛听我以彩色赭土白灰庄严塔柱者善。佛言。听彩色赭土白灰庄严柱。佛听我画柱上塔上者善。佛言。除男女合像。余者听画作。尔时给孤独居士。信心清净往到佛所。头面作礼一面坐已。白佛言。世尊。如佛身像不应作愿。佛听我作菩萨侍像者善。佛言。听作菩萨像。又作是言。佛本在家时。引旛在前。愿佛听我作引旛在前者善。佛言。听作引旛在前。佛听我塔前作高垛安师子者善。佛言。听作高垛安师子。佛听师子四边作栏楯者善。佛言。听汝师子四边安栏楯。佛听我以铜作师子者善。是事白佛。佛言。听汝铜作师子。佛听我铜师子上系旛者善。是事白佛。佛言。听汝铜师子上系旛。佛听我以香华灯妓乐供养者善。是事白佛。佛言。听汝香华灯妓乐供养。佛听我以香华油涂塔地者善。是事白佛。佛言。听香华油涂塔地。佛听我作安华垛者善。佛言。听汝作安华垛。佛听我作安灯处者善。佛言。听汝作安灯处。佛听我作团堂者善。佛言。听汝作团堂。佛听我堂上安木悬旛者善。佛言。听汝堂上安木悬旛。尔时给孤独居士亲里相识举物人。庄严男女。盘桉上着华香璎珞。遣至居士家。居士见已作是念。此物在前行者善。是事白佛。佛言。听汝盘桉上着华香璎珞在前行。佛听我作香炉在前行者善。佛言。听汝香炉在前行。有诸外道。生嫉妒心。见已呵责言。如送死人。是居士作是念。佛听我像前作妓乐者善。是事白佛。佛言。听作妓乐

尔时给孤独居士。信心清净作是念。以何方便得集大众供给衣食。往白佛言。愿佛听我集大众食者善。佛言。听集大众食作是言。佛听我供养塔时与大众食者善。是事白佛。佛言。听供养塔时与大众食。佛听我作般阇于瑟会者善。是事白佛。佛言。听作般阇于瑟会。佛听作六岁会者善。是事白佛。佛言。听作六岁会。佛听我正月十五日至二月十五日作会者善。是事白佛。佛言。听作。佛听我寺中作会者善。是事白佛。佛言。听汝寺中作会。时诸比丘。不次第入。不次第坐。不次第食。不次第起。不次第去。有前入者。有行食时入者。有食时入者。有食竟入者。佛言。应唱时至。唱时至声不远闻。是事白佛。佛言。应打犍椎。打犍椎已亦不远闻。是事白佛。佛言。应打鼓。打时在地打鼓。亦不远闻。是事白佛。佛言。在垛上打。垛上打时亦不远闻。佛言。应在高处打使远处得闻见。时大众集。多人来看。与供养塔物。与四方僧物。与食物。与应分物。诸比丘不知何者是塔物。何者四方僧物。何者食物。何者应分物。是事白佛。佛言。与物时使一比丘在彼立看知分别。是塔物。四方僧物。食物。应分物。长老优波离问佛言。世尊。是四种物。塔物四方僧物食物应分物。得错互用不。佛言。不得。佛语优波离。塔物者。不得与四方僧。不得作食。不得分。四方僧物者。不得作食。不得分。不得作塔。作食物者。不得分。不得作塔。不得与四方僧。应分物者。随僧用十诵律卷第四十九(第八诵之二)

        后秦北印度三藏弗若多罗共罗什译

    毗尼增一之二三法初

有三羯磨摄诸羯磨。谓白羯磨。白二羯磨。白四羯磨。有三人必堕恶趣地狱中。何等三。若人以无根波罗夷。谤清净梵行比丘。是名初人必堕地狱。有人生恶邪见作是言。诸欲中无罪。以是故。是人深作放逸。自恣五欲。是第二人必堕地狱。有人出家作比丘。犯戒内烂流出。非沙门自言沙门。非梵行自言梵行。是第三人必堕地狱。尔时世尊。欲明此事。而说偈言

  妄语堕地狱　　及余作重罪
  是恶不善人　　后俱受罪报
  夫人生世间　　斧在口中生
  以是自斩身　　斯由作恶言
  应呵而赞叹　　应赞叹而呵
  口过故得衰　　衰故不受乐
  如奄失财物　　是衰为鲜少
  恶口向善人　　是衰重于彼
  尼罗浮地狱　　其数有十万
  阿浮陀地狱　　三十六及五
  恶心作恶言　　轻毁圣人故
  寿终必当堕　　如是地狱中

有三种证罪。见证罪。闻证罪。疑证罪。有三法。毗尼中歌。如哭法。毗尼中露齿笑。如狂法。毗尼中掉臂舞。如小儿法。如来有三种不护无能知无能见。如来身行清净。无不清净。是如来不护无能知无能见。如来口业意业清净。无不清净。是如来不护无能知无能见。世间有三大贼。无能及者。久寿作大罪。人无能捉。何等三。有人野住。有崄处住。有强力住。云何野住。谓草林藂中。云何崄处住谓山崄水曲中。云何强力住。谓手力脚力。是名三法世间大贼久寿作大罪人无能捉。如是三事。有恶比丘。久寿作大罪久住。僧不能摈。有野住山崄住强力住。野住者。破戒内烂流出。非沙门自言沙门。非梵行自言梵行。是名野住。崄住者。邪见不如实说。如是见如是语。无施无果无善恶报。无父母世间。无阿罗汉。无须陀洹。无斯陀含。无阿那含。无今世无后世。无得证法。是名崄住。强力住者。依语力依广解力。是名强力住。是名三法有恶比丘久寿作大罪僧不能疾摈。有三法。名大贼。久寿作大罪。人不能疾捉。野住崄处住。多有财物。云何名野住。如先说。云何名崄处住。如先说。云何名多有财物。大有田宅人民财宝。是人作是念。若有道我者。我当与财物。是名多有财物。是名三法大贼久寿作大罪人不能疾捉。如是三法。有恶比丘。久寿作大罪。僧不能疾摈。野住崄住依物住。云何野住。如先说。云何崄住。如先说。云何依物住。若多得施物。衣被饮食卧具医药种种诸物。作是念。若有道我者。我与是物。是名依物住。是名三法有恶比丘久寿作大罪僧不能疾摈。复有三法。名大贼。久寿作大罪。人不能疾捉。依野住依崄处住依力住。云何依野住。如先说。云何依崄住如先说。云何依力住。若依王若依王等。故作是念。有道我者。此人助我。是名依力住。是为三法大贼久寿作大罪人不能捉。如是三法。有恶比丘。久寿作大罪。僧不能疾摈。依野住依崄住依力住。云何依野住。如先说。云何依崄住。如先说。云何依力住。若比丘依诵修多罗者诵毗尼者诵阿毗昙者。作是念。有人道我者。此人助我。是名三法有恶比丘久寿作大罪僧不能疾摈。世间有三大贼。何等三。一者作百人主故。百人恭敬围绕。二百三百四百五百人主故。五百人恭敬围绕。入城聚落穿踰墙壁。断道偷夺破城杀人。是名初大贼。二者有比丘。用四方僧园林中竹木根茎枝叶华果财物饮食。卖以自活。若与白衣知识。是名第二大贼。三者有比丘。为饮食供养故。空无过人圣法。故作妄语自说言得。若与百人乃至五百人恭敬围绕。入城聚落受他供养小食中食。是名第三大贼。是中百人贼主。二百三百四百五百人主。恭敬围绕。入城聚落穿踰墙壁。断道偷夺破城杀人。此名小贼。若有比丘。用四方僧园林中竹木根茎枝叶华果财物饮食。卖以自活。若与知识白衣。亦是名小贼。佛言。是第三贼。于天人世间魔界梵世沙门婆罗门天人众中。最是大贼。谓为饮食故。空无过人圣法。故作妄语自说言得。若与百人至五百人。恭敬围绕入城聚落。受他供养小食中食。是名大贼。佛说偈言

  比丘未得道　　自说言得道
  天人中大贼　　极恶破戒人
  是痴人身坏　　当堕地狱中

(三法竟)

    四法初

有四种和上。有和上。与法不与食。有和上。与食不与法。有和上。与法与食。有和上。不与法不与食。是中与法不与食者。应住是和上边。与食不与法者。不应住。与法与食者。如是应尽形住。不与法不与食者。不应住。闇夜亦应舍去。阿阇梨亦如是。有四种人。数数犯数数悔过。一者无羞。二者轻戒。三者无怖畏心。四者愚痴。是名四种人数数犯戒数数悔过。世间有四种人。见犯罪生怖畏。何等四。若有人着黑衣。奔头往至多人所。作是言。我作恶罪不善可羞。随众人所喜。我当作之。时彼众人呵责驱出。有智人见已作是念。是人着黑衣。奔头往多人所。作是言。我作恶不善可羞。随众人所喜。我当作之。作恶业故。众呵驱弃。我当自敕亦教余人。莫作如是恶业。如是有比丘。于波罗提提舍尼中。生怖畏心。应如是知。未犯者不犯。若已犯者。疾如法悔过。是名初人见罪怖畏。有人着黑衣。奔头捉棒着肩上。往多人所作是言。我作恶罪不善可羞。随众所喜我当作之。时彼众人即取其棒打已驱出。有智人见作是言。是人作恶不善故得大罪。我当自敕亦教余人莫作如是恶业。如是有比丘。于波夜提中生怖畏心。应如是知。未犯者不犯。若已犯者疾悔过。是名第二见罪怖畏。有人着黑衣。奔头捉铁钪着肩上。往多人所作是言。我作恶不善。随众所喜我当作之。时彼众人即取铁钪打之。便捉利刀恐之。驱出城西门。着于堑中。有智人见已作是言。是人作恶业故得大罪。我当自敕亦教余人。莫作如是恶。如是有比丘。于僧伽婆尸沙中生怖畏心。应如是知。未犯者不犯。若已犯者疾悔过。是名第三见罪怖畏。有如捕贼师捕得实贼。反缚两手打鼓循行。出南城门坐着标下。便截其首。有智人见已作是言。是人作恶业故得大罪。我当自敕亦教余人莫作如是恶业。如是有比丘。于波罗夷中生怖畏心。应如是知。未犯者终不敢犯。是名第四见罪怖畏。有四种羯磨。非法别众。非法和合众。有法别众。有法和合众。是中非法别众羯磨者。是不名作羯磨。非法和合众作羯磨者。亦不名作羯磨。有法别众作羯磨者。亦不名作羯磨。有法和合众作羯磨者。是名作羯磨。非法别众作羯磨者。是羯磨。非法别众应遮应置。非法和合众作羯磨者。是羯磨。非法和合众应遮应置。有法别众作羯磨者。是羯磨。有法别众应遮应置。有法和合众作羯磨者。是羯磨。有法和合众。不应遮不应置。非法别众作羯磨者。是非法别众羯磨莫作。不名作不好不名好。应遮应置。非法和合众作羯磨者。是羯磨。非法和合众莫作不名作不好不名好。应遮应置。有法别众作羯磨者。是羯磨。有法别众莫作。不名作不好不名好。应遮应置。有法和合众作羯磨者。是羯磨。有法和合众应作。名作是好名好。不应遮不应置。有四种人。一者粗人。二者浊人。三者中间人。四者上上人。如是僧中。有四种断事人。有僧断事人。无羞不善义不善文句。有僧断事人。无羞善义善文句。有僧断事人。有羞不善。义不善文句。有僧断事人。有羞善义善文句。若僧断事人。无羞不善义不善文句者。是名粗人。若僧断事人。无羞善义善文句者。是名浊人。若僧断事人。有羞不善义不善文句者。是名中间人。若僧断事人。有羞善义善文句者。是名上人。若僧断事人。无羞不善义不善文句者。无人亲近。若僧断事人。无羞善义善文句者。有人亲近。若僧断事人。有羞不善义不善文句者。无人亲近。若僧断事人。有羞善义善文句者。有人亲近。若僧断事人。无羞不善义不善文句者。是名不可共语。若僧断事人。无羞善义善文句者。是可共语。若僧断事人。有羞不善义不善文句者。是不可共语。若僧断事人。有羞善义善文句者。是可共语。若僧断事人。无羞不善义不善文句者。如是断事人。可嫌可诃可摈。是不好人。迷乱愁忧生悔恨心。何以故。如是断事人。僧中未起诤事便起。已起事不能灭。若僧断事人。无羞善义善文句者。如是断事人。可嫌可诃可摈。是不好人。迷乱。愁忧生悔恨心。何以故。如是断事人。僧中未起诤事便起。已起事不能灭。若僧断事人。有羞不善义不善文句者。如是断事者。应教义应教文句。若僧断事人。有羞善义善文句。是断事者应赞叹称善。何以故。是人来僧中断事时。未起诤者不起。已起者灭。有四种义。有义非法分别他不捡究捡究不受。有义非法不分别他捡究捡究受。有义如法分别他不捡究捡究不受。有义如法不分别他捡究捡究受。是中义。非法分别他不捡究捡究不受。是名三过。如非法者。是过。如分别他者。是过。如不捡究捡究不受者。是过。是中有义。非法不分别他捡究捡究受。是一过。如非法者。是过。如不分别他者。是非过。如捡究捡究受。是非过。是中义。如法分别他不捡究捡究不受。是二过。如法者。是非过。如分别他者。是过。如不捡究捡究不受。是过。是中义。如法不分别他捡究捡究受。是皆非过。如法者是非过。如不分别他者。是非过。如捡究捡究受者。是非过。有四行。闼赖吒比丘不能灭诤。爱嗔怖痴。是名四行。闼赖吒比丘不能灭诤。有四行。闼赖吒比丘能灭诤。不爱不嗔不怖不痴。是名四行。闼赖吒比丘能灭诤。有四行。闼赖吒比丘。不善观义。不善取义。不应赞便赞。应赞而不赞。不应清净令清净。应清净不令清净。不应敬而敬。应敬而不敬。有四行。闼赖吒比丘。善观义善取义。不应赞不赞。应赞而赞不应清净不与清净。应清净令清净。不应敬不敬。应敬而敬。是名四行。闼赖吒比丘能灭诤。有四行。闼赖吒比丘不善观义。不善取义。以力势语。不从他乞听便出他罪。先有嫌心悔心。有见嫌见悔。自用意。是名四行不能灭诤。有四行。闼赖吒比丘能灭诤。善观义善取义。不以力势。从他乞听。先无嫌心悔心。无见嫌见悔。不自用意是名四行能灭诤。有四行。闼赖吒比丘有罪。爱嗔怖痴故有罪过。有四行。闼赖吒比丘无罪。不爱不嗔不怖不痴故无罪过。有四行。闼赖吒比丘有罪过。不善观义。不善取义。不应赞而赞。应赞不赞。不应清净令清净。应清净不令清净。是名四行有罪过。有四行闼赖吒比丘无罪过。善观义善取义。不应赞不赞。应赞而赞。不清净不与清净。应清净与清净。是名四行无罪过。有四行。闼赖吒比丘有罪过。不善观义不善取义。以力势不乞听。先有嫌心悔心。有见嫌见悔自用意。是名四行有过。有四行。闼赖吒比丘无过。善观义善取义。不以力势。从他乞听。先无嫌心悔心。无见嫌见悔。不自用意。是四无过(四法竟)

    五法初

佛婆伽婆住释迦国。大爱道比丘尼。往诣佛所。头面作礼在一面立白佛言。善哉世尊。愿略说法非法毗尼非毗尼。令我知是法是毗尼是佛法。佛言。瞿昙弥。若知是法。随欲不随无欲。随过不随无过。随增长不随不增长。一向不转随烦恼不离。大爱道。汝定知是非法非毗尼非佛法。瞿昙弥。若知是法。不随欲随无欲。不随过随无过。随不增长不随增长。不随烦恼。大爱道。汝定知是法。是毗尼是佛法。尔时瞿昙弥比丘尼。往诣佛所。头面作礼在一面立。白佛言。善哉世尊。愿略说法非法毗尼非毗尼。令我知是法是毗尼是佛法。佛言。瞿昙弥。汝若知是法。随贪不随无贪随无厌不随厌。随多欲不随少欲。随难满不随不难满。随难养不随不难养。瞿昙弥。汝定知是非法非毗尼非佛法。瞿昙弥。汝知是法。随无贪不随贪。随少欲不随多欲。随有厌不随无厌。随不难满不随难满。随不难养不随难养。瞿昙弥。汝定知是法是毗尼是佛法

尔时长老优波离往诣佛所。头面作礼在一面坐。白佛言。世尊。有几法正法灭亡没。佛言。优波离。有五法正法灭亡没。何等五。有比丘无欲。是名一。钝根是名二。虽诵义句不能正受。亦不能令他解了。是名三。不能令受者有恭敬威仪。有说法者不能如法教。是名四。斗诤相言不在阿练若处。亦不爱敬阿练若处。优波离。是名五法。令正法灭亡没。有五法。正法不灭不亡不没。有欲利根能诵义句。能正受能为人解说。能令受者有威仪恭敬。有说法者能如法教。无斗诤相言。在阿练若处。爱敬阿练若处。是名五法。正法不灭不亡不没。优波离。更有五法。正法灭亡没。何等五。有比丘。不随法教随非法教。不随忍法随不忍法。不敬上座无有威仪。上座不以法教授。上座说法时愁恼。令后众生不得受学修多罗毗尼阿毗昙。上座命终已后。比丘放逸习非法失诸善法。是名五法。正法灭亡没。佛语优波离。更有五法。正法不灭不亡不没。有比丘。随法教不随非法教。随忍不随不忍。敬上座有威仪。上座能以法教。说法时不愁恼。令后众生得受学修多罗毗尼阿毗昙。上座命终已后。比丘不放逸习善法。是名五法。正法不灭不亡不没。长老难提往诣佛所。头面作礼在一面坐。白佛言。世尊。正法灭像法时。有几非法在世。佛言。难提。正法灭像法时。有五非法在世。何等五。佛言。正法灭像法时。有比丘。心得小止。便谓已得圣法。是名初非法在世。难提。正法灭像法时。白衣生天。或有出家者。堕恶道中。是名第二非法在世。难提。正法灭像法时。有人舍世间业出家破戒。是名第三非法在世。难提。正法灭像法时。有破戒者多人佐助。有持戒者无人佐助。是名第四非法在世。难提。正法灭像法时。无不被骂者。乃至阿罗汉亦被他骂。是名第五非法在世。更有比丘重问此事。佛即以是事语诸比丘。佛告优波离。当来有五怖畏。今者未有。应知是事求方便灭。何等五。后有比丘。不修身不修戒不修心不修智。是不修身戒心智。已度他出家受戒。不能令修身修戒修心修智。自不调伏。复度他出家受戒。是亦不能令修身修戒修心修智。是法中过比尼中过。毗尼中过是法中过。优波离。是名当来初怖畏。今未有当来有。应知是事求方便灭优波离。后有比丘。不修身不修戒不修心不修智。是不修身戒心智。已与他依止畜沙弥。不能令修身修戒修心修智。是不调伏。复与他依止畜沙弥。不能令修身修戒修心修智。是法中过毗尼中过。毗尼中过是法中过优波离。是名第二第三怖畏。应知是事求方便灭。优波离。后有比丘。不修身不修戒不修心不修智。是不修身戒心智。已与净人沙弥相近住。不知三相掘地断草用水溉灌。是法中过毗尼中过。毗尼中过是法中过。优波离。是名第四怖畏。今未有当来有。应知是事求方便灭。优波离。后有比丘。不修身不修戒不修心不修智。是不修身戒心智。已共诵修多罗毗尼阿毗昙。以前后着中。以中着前后。现见不知白法犯非犯。是名法过毗尼过。毗尼过法过。优波离。是名第五怖畏。今未有当来有。应知是事求方便灭。佛语优波离。更有五怖畏。今未有当来有。应知是事求方便灭。何等为五。优波离。当来有比丘。不修身不修戒不修心不修智。是不修身戒心智。已无欲钝根。虽诵句义不能正受。优波离。是初怖畏。今未有当来有。应知是事求方便灭。优波离。当来有比丘。不修身不修戒不修心。不修智。是不修身戒心智。已与比丘尼相近。或犯大事舍戒还俗。优波离。是第二怖畏。今未有当来有。应知是事求方便灭。优波离。当来有比丘。不修身不修戒不修心不修智。是不修身戒心智。已如来所说甚深修多罗。空无相无愿十二因缘诸深要法。不能信乐受持。虽受不能通利。如是说时。无怜愍心无爱乐心。如好作文颂庄严章句。乐世俗法。随世所欲有信乐心。说俗事时有爱乐心。是故如来所说甚深修多罗。空无相无愿十二因缘诸深法灭。优波离。是第三怖畏。今未有当来有。应知是事求方便灭。优波离。当来有比丘。不修身不修戒不修心不修智。是不修身戒心智。已为衣食故。舍阿练若处。舍林树下。入聚落中。若为衣食故。多所求觅。求觅时扰乱。优波离。是名第四第五怖畏。今未有当来有。应知是事求方便灭。尔时有迦罗比丘。喜往不可行处。与他共语。大童女寡妇妇淫女比丘尼。佛言。比丘有五不应行处。何等五。童女寡妇妇淫女比丘尼。更有五不应行处。何等五。贼家栴陀罗家屠儿家淫女家沽酒家。若比丘往五不应行处。与他共语。令人生疑谓非梵行。童女寡妇妇淫女比丘尼。是名五不应行处。令人生疑谓非梵行。复有五事不应行处。与他共语。令人生疑谓作恶法行。贼家栴陀罗家屠儿家淫女家沽酒家。是名五不应行处。令他生疑谓作恶法。有五恶法故应知恶比丘。如小儿不能善语。无男子行。所谓欲嗔怖痴。不消供养。是五法故名恶比丘。如小儿痴。不能善语无男子行。如是恶比丘尼。恶式叉摩尼。恶沙弥沙弥尼皆如是小儿痴不善语无男子行。欲嗔怖痴不消供养故。有五法。恶比丘有罪过。欲嗔怖痴不消供养。是名五法恶比丘有罪有过。如是恶比丘尼。恶式叉摩尼。恶沙弥沙弥尼。欲嗔怖痴不消供养故有罪过。有五非毗尼。何等五。犯波罗夷僧伽婆尸沙波夜提波罗提提舍尼突吉罗。是名五非毗尼。有五毗尼。不犯波罗夷僧伽婆尸沙波逸提波罗提提舍尼突吉罗。是名五毗尼有五尘坌不受得啖。食尘谷尘水尘衣尘一切尘。是名五尘坌。不须更受得啖。有五种受。手来手受。衣裓来衣裓受。箧来箧受。器来器受。污贱国放地受。是名五受。更有五受。身身受。身身相触受。身身并受。身并相触受。污贱国放地受。是名五受。有五非法自言。何等五。以王怖自言。以贼怖自言。以断事人怖自言。以恶兽怖自言。诬己自言。是名五非法自言。有五如法自言。非王怖自言。非贼怖自言。非断事人怖自言。非恶兽怖自言。非诬己自言。是名五如法自言。有五非法见过。何谓五。向别住人。不共住人。非受大戒众。犯无残事。不见是事悔过。是名五非法见过。有五如法见过。不向别住人。不向不共住人。不向未受大戒众。犯有残事。见是事悔过。是名五如法见过。有五种阿阇梨。出家阿阇梨。教授阿阇梨。羯磨阿阇梨。依止阿阇梨。受法阿阇梨。是名五种阿阇梨。有五种弟子。出家弟子。教授弟子。羯磨弟子。依止弟子。受法弟子。是名五种弟子。应好恭敬五种阿阇梨。若不恭敬者有罪过。有五种布萨。说戒经布萨。心念布萨。独在住处布萨。清净布萨。自恣布萨。是名五种布萨。有诸比丘。不乞听。举他罪。令忆念。是比丘嫌。以是事白佛。佛言。从今先不乞听。不得举他罪令忆念。若举令忆念者突吉罗罪。是有罪人于僧中。无恭敬心无恭敬语。佛言。若来者应教住五法中。教从坐起偏袒着衣脱革屣右膝着地合掌在前。有举罪者无恭敬。佛言。应教住五法中。教从坐起偏袒右肩脱革屣右膝着地合掌在前。诸比丘不知云何乞听。佛言。有五事乞听。应语彼言。我今语汝示汝举汝令汝忆念汝听我。诸比丘不知云何与听。是事白佛。佛言。有五事与听。应言。语我示我举我令我忆念听汝。是名五。又现前不知云何与听。佛言。有五种与。汝云何举我。见耶闻耶疑耶。身犯口犯。更有五种。现前与听。汝举我波罗夷僧伽婆尸沙波逸提波罗提提舍尼突吉罗耶。更有五种。现前与听。汝举我犯恶口突吉罗耶。犯偷兰遮突吉罗耶。犯毗尼突吉罗耶。犯众学法耶。犯威仪耶。更有五法。现前应与听。汝举我何事。有残犯。无残犯。有残无残犯。聚落中犯。阿练若处犯。如是现前语已生怖畏。佛言。有五事。现前应安慰。莫怖莫惊莫覆藏。莫走莫群党。莫不犯言犯。莫群党已。犯言不犯。更有五事应安慰。我不凶暴说。不受不具足事。亦不直受。不受不定说。我当三问汝。如是安慰时。彼作异种语。佛言。应以五事捡究问是事。更以异事答当记识。若默然当记识。有恼他所犯。不见过。当作不见摈。见罪不悔。当作不作摈。检究恶邪见。恶邪见不舍已。当作不舍恶邪见摈举。更有五法。应捡究。应苦切作苦切。应依止作依止。应驱出作驱出。应下意作下意。应觅罪相作觅罪相。如是优波离。是名乞听安慰有羞。无羞人来时。应知乞听。应知与听。又非法者不应助。如法者应助。优波离。我见比丘举他。非实不以实。非时不以时。粗恶不以软善。有嗔无慈。无益利不以益利。若比丘不实举他。有是五事。应教令生悔。若不实举他。无实有悔。是事应置。非时不以时。粗恶不以软善。有嗔无慈。无益不以益利。优波离。是比丘以非实举他。有五事应教令生悔。优波离。是名五事不实举他。应断被非实举者。有五事不应悔。非实不以实。非时不以时。恶不以善。嗔不以慈。无益不以益利。优波离。被非实举者。有是五事不应悔。优波离。我见比丘举他。实非不实。时非不时。善非不善。慈非不慈。益非不益。是名五实举比丘不生悔。优波离。被实举者。有五事应悔。是实非不实。时非不时。善非不善。慈非不慈。益非不益。是名五。被实举者应悔。有五非法语。非实不以实。非时不以时。非善不以善。非慈不以慈。非益不以益。有五如法语。实非不实。时非不时。善非不善。慈非不慈。益非不益。有五嫌呵。责不责问约敕教。责者。有所责。谓莫淫莫偷莫杀生莫身相触莫杀草莫过中食莫饮酒。是名责。不责者。不淫不偷不杀生不身相触不杀草不过中食不饮酒。问者问言淫耶盗耶杀生耶身相触耶杀草耶过中食耶饮酒耶。约敕者。若淫堕地狱饿鬼畜生中。若偷若杀生若身相触杀草过中食饮酒。生地狱饿鬼畜生中。教者。言不应淫不应偷不应杀生不应身相触不应杀草不应过中食不应饮酒。更有五嫌呵。责不责问现他过激列他。责不责问。如先说。现他过者。我不淫他淫。随语得突吉罗。我不偷不杀不身相触不杀草不过中食不饮酒他饮酒。随语得突吉罗。是名现他过。激列者。激列言我不淫不偷不杀生不身相触不杀草不过中食不饮酒。是名激列。有五调伏。苦切依止驱出下意不见摈。有五举事。见举闻举疑举身犯口犯。复有五举事。犯波罗夷僧伽婆尸沙波逸提波罗提提舍尼突吉罗。复有五举事。恶口突吉罗。偷兰遮突吉罗。毗尼突吉罗。众学法突吉罗。威仪突吉罗。持律者有五利益。何等五。戒身牢固。无能教者。说戒经时无所畏难。能断他疑。能立正法。持律复有五利。知犯。知不犯。知轻。知重。善广诵戒。持律有五利。知出家法。知羯磨。知威仪。知依止。知障道法。不障道法。有五事。闼利吒比丘不能灭诤。非法言法。法言非法。非毗尼言毗尼。毗尼言非毗尼。犯言不犯。是名五事。闼利吒比丘不能灭诤。有五事。闼利吒比丘能灭诤。非法言非法。法言法。非毗尼言非毗尼。毗尼言毗尼。犯言犯。复有五。闼利吒比丘不能灭诤。不犯言犯。犯言不犯。轻言重。重言轻。有残言无残。是名五事。闼利吒比丘不能灭诤。复有五。闼利吒比丘能灭诤。犯言犯。不犯言不犯。轻言轻。重言重。残言残。是名五。闼利吒比丘能灭诤。复有五。闼利吒比丘不能灭诤。有残言无残。无残言有残。常所行事言非常所行事。非常所行事言是常所行事。斗诤相言。是名五事不能灭诤。复有五事。闼利吒比丘能灭诤。有残言有残。无残言无残。常所行事言是常所行事。非常所行事言非常所行事。不斗诤相言。是名五事能灭诤。复有五。闼利吒比丘不能灭诤。不通利毗尼。不能分别相似句义。不能善说戒。不能令有疑者亲近不能立正法。是名五事。闼利吒比丘不能灭诤。复有五。闼利吒比丘能灭诤。通利毗尼。能分别相似句义。善说戒。能令有疑者亲近。能立正法。是名五。闼利吒比丘能灭诤。复有五。闼利吒比丘不能灭诤。破戒。破见。不能如法求灭诤事。不能通经与阿毗昙相应。不能分别句义相应。是名五。闼利吒比丘不能灭诤。复有五。闼利吒比丘能灭诤。不破戒。不破见。能求灭诤事。能通经与阿毗昙相应。能分别句义相应。是名五。闼利吒比丘能灭诤。复有五。闼利吒比丘不能灭诤。不能和合众。不能取二众意。不能止二诤。不能断罪所受法。不能次第说。是名五。闼利吒比丘不能灭诤。复有五。闼利吒比丘能灭诤。能和合众。能取二众意。能止二诤。能断罪所受经法。能次第说。是名五闼利吒比丘能灭诤。复有五。闼利吒比丘不能灭诤。不善取灭诤事。不能善知诤起因缘。不能善和诤。不能善灭诤。不能灭已令更不起。是名五闼利吒比丘不能灭诤。复有五。闼利吒比丘能灭诤。能善取灭诤事。善知诤起因缘。能善和诤。能善灭诤。灭已更不令起。是名五闼利吒比丘能灭诤。复有五。闼利吒比丘不能灭诤。爱嗔怖痴不能善灭诤。是名五闼利吒比丘不能灭诤。复有五。闼利吒比丘能灭诤。不爱不嗔不怖不痴能善灭诤。是名五。闼利吒比丘能灭诤。复有五。闼利吒比丘不能灭诤。不能分别相似句义。不应赞而赞。应赞而不赞。不应清净令清净。应清净不令清净。不应敬而敬应敬而不敬。是名五。闼利吒比丘不能灭诤。复有五。闼利吒比丘能灭诤。能分别相似句义。不应赞不赞。应赞而赞。不应清净不令清净。应清净令清净。不应敬不敬。应敬而敬。是名五。闼利吒比丘能灭诤。复有五。闼利吒比丘不能灭诤。不能善分别句义。僧中恃力而说。不从他乞听便举他罪。于他有嫌。悔过已故有嫌见。有嫌说他事不能止诤。是名五。闼利吒比丘不能灭诤。复有五。闼利吒比丘能灭诤。善知分别句义。不恃力说。乞听而举。于他无嫌。悔过已无嫌见能灭诤。是名五。闼利吒比丘能灭诤

知食人有五事。先未差不应差。若差应置。爱嗔怖痴不知得不得。是名五。知食人先未差。不应差已差应置复有五事。知食人。先未差应差。若已差不应置。无爱无嗔无怖无痴知得不得。是名五。应差知食人。复有五事。知食人。未差不应差。已差不应约敕。爱嗔怖痴不知得不得。是名五。复有五。知食人。未差应差。已差应约敕。不爱嗔怖痴知得不得。是名五。应差知食人。复有五。不应差。已差应灭。爱嗔怖痴不知得不得。是名五。复有五。知食人。未差应差。已差不应灭。不爱嗔怖痴知得不得。是名五。应差不应灭也。如是应灭。如是不应灭。如是应呵。如是不应呵。如是应举。如是不应举。如是应毁。如是不应毁。如是迷乱。如是不迷乱。如是应嫌。如是不应嫌。生疑悔无疑悔。有犯无犯。有事无事。有恼无恼。恼他不恼他。变异不变异。热不热。爱语不爱语。有损无损。差贤圣。贤圣所赞。向恶道不向恶道。趣地狱趣天上。生死久远。生死不久远。住生死入泥洹。如差知食人。十三人亦如是

有五事诤难灭。不求僧断。不顺佛语。不如法白。二众诤心不息。所犯不求清净。是名五诤难灭。复有五诤易灭。求僧断。顺佛语。如法白。二众诤心息。所犯求清净。是名五诤易灭有五事。不应取诤诤心不息。依恃官势。依恃白衣。有势力者。不依僧。不依闼利吒比丘。是名五不应取诤。有五事。应取诤。诤心息。不恃官势。不恃白衣。有势力者。依僧。依闼利吒比丘。是名五应取诤。优波离。闼利吒比丘。取诤时有五事。自观观他已应取诤。先来戒清净。多闻广知经法。僧中多有持修妒路毗尼摩多罗伽者。有说佛法处能取。僧中多有上座闼利吒比丘中座比丘下座比丘。二众和合如法分别僧中多有持戒者。乃至不破小戒。依修多罗。善求觅除灭二诤。利益安乐众生。怜愍世间生人天因缘。是名自观观他。有五事诤难灭。共诤比丘。依恃官。恃白衣。恃白衣故恼上座。与白衣衣食不与法。不如法求诤。是名五诤难灭。有五事诤易灭。不恃官。不恃白衣。不恼僧。与白衣法不与衣食。如法求诤。是名五诤易灭。复有五事诤难灭。二众以力取诤。不善取诤。不善取灭诤事。不善取灭诤义。诤比丘不敬上座中座下座比丘。是名五诤难灭。有五事诤易灭。二众不以力取诤。善取诤善取灭诤事。善取灭诤义。诤比丘恭敬上座闼利吒比丘中座比丘下座比丘。是名五诤易灭

复有五事不应取诤。依恃官。依恃白衣。恼僧与白衣衣食不与法。不如法求诤。是名五不应取诤。复有五事应取诤。不恃官。不恃白衣。不恼僧。与白衣法不与衣食。如法求诤。是名五应取诤。复有五事不应取诤。二众以力取诤。不善取诤。不善取灭诤事。不善取灭诤义。不敬上座中座下座。是名五不应取诤。复有五事应取诤。二众不以力取诤。善取诤。善取灭诤事。善取灭诤义。恭敬上座闼利吒比丘中座下座比丘。是名五事应取诤。复有五事。闼利吒比丘不能灭诤。不善诵毗尼。不能说相似句义。诤比丘执所犯事。如钩锁难解不满五岁依止他。不解十直。是名五法。闼利吒比丘不能灭诤。复有五法成就。闼利吒比丘能灭诤。善诵毗尼。善能分别相似句义。净比丘不执所犯。满五岁不依止他。解十直。是名五。闼利吒比丘能灭诤。佛语优波离。闼利吒比丘取诤时。应以五事观。此中谁先来清净持戒。谁多闻智慧善诵阿含。谁于师如法。谁信佛法僧。谁不轻佛戒。是名五。闼利吒比丘。应以此五事善观诤者。又优波离。有诤比丘。到闼利吒比丘边。求断诤相言时。是闼利吒比丘。以此五事观已取诤。谁先来持戒清净。谁多闻诵阿含。谁有呵责事。先不与闼利吒比丘有嫌耶。能取灭诤。如佛法毗尼灭。是名优波离有诤比丘相言时。闼利吒比丘以五事观

十诵律卷第四十九十诵律卷第五十(第八诵之三)

        后秦北印度三藏弗若多罗译

    增一法之三五法下

有五事群党。能于僧中起诤。如是起诤多有恼乱。减损天人。有诤比丘以非法约敕。有群党说。轻读诵修多罗比丘。遮说戒者。助斗诤相言。是名五事。有群党僧中起诤。如是起诤多有恼乱。减损天人。有五事不群党。僧中不起诤。如是不起诤不恼乱。增益天人。有诤比丘如法约敕。不群党说。敬诵修多罗者。不遮说戒者。不助斗诤相言。是名五。非群党不起诤。如是不起诤故不恼乱。增益天人。有五举事者。有羞不能次第答。若上座问时。不能次第答。若问时怖。问异答异。恃群党轻上座。非法言法。法言非法。是名五举事者。羞不能次第答。有五举事者。为他所难。能次第答。若上座问时。能次第答。问时不怖。问答不异。不恃群党。不轻上座。非法言非法。法言法。是名五。为人所难能次第答。有五事举事人。羞不能次第答。不善知句义。先有嫌取二诤根本。若白衣沙弥诤根本。使他比丘举。不知修多罗句义。若说不定。不知比丘三事所住见闻疑处。是名五举事人。不能次第答。有五法举事。比丘为人所难。能次第答。知句义。先无嫌。不取二诤根本。不求白衣沙弥诤根本。不使他比丘举。知修多罗句义。说定。知比丘三事所住见闻疑处。是名五法举事。比丘为人所难。能次第答。有五种成羯磨。现前成。与欲成。同见成。从有信优婆塞闻成。作羯磨竟默然已成。有五法共要。若乞听已不举他是事应此处说共要。此事应彼处说共要。此事应随处说共要。随汝所犯事我乐示汝。出过已。如恶马难调拔橛合缰驱去。佛语优波离。求义比丘从他闻义时。有五事应善分别义。是实非实时非时似义不似义。是义起斗诤相言。僧破僧恼僧别僧异。于是义不起斗诤相言。僧不破不恼不别不异。优波离。是名求义比丘从他闻义时以五事善分别义。比丘有五事。能使僧不生清净。谓说佛法僧戒过不随威仪。是名五事能使僧生不清净。有五事。能使僧生清净。谓不说佛法僧戒过随威仪。是名五事能使僧生清净。有五事。闼利吒比丘不能灭诤。不如根本说。趣说因他说。所说不与句义相应。以不相应句义说。有五事。闼利吒比丘能灭诤。如根本说。不趣说。不因他说。所说与句义相应不以不相应句义说。是名五法。闼利吒比丘能灭诤。复有五法。闼利吒比丘不能灭诤。不筹量受他所说。受他不具足语。受他趣语。受他不定语。不三重问。是名五法。闼利吒比丘不能灭诤。有五事。贵比丘能灭诤。筹量受他语。受具足语。不受趣语。不受不定语。三重问。是名五贵比丘能灭诤

复有五事。贵比丘不能灭诤。自说不能了义。亦不解他所说。不能令他解所说。重说扰乱忘失句义。不知修多罗句义。是名五事。贵比丘不能灭诤。复有五事。贵比丘能灭诤。自说能了。解他所说。所说能令他解。不重说不失句义。不失修多罗句义。是名五贵比丘能灭诤。复有五事。贵比丘不能灭诤。不差自说。事未成便先说。不知和合众所说。恼他。重说扰乱。是名五事。贵比丘不能灭诤。有五事。贵比丘能灭诤。差而说。事成便说。知和合众所说。不恼他。不重说。是名五事。贵比丘能灭诤。复有五法成就。贵比丘持律者不差自说。若是上座若上座等。若是说戒人若说戒人等。观群党有力势。若白僧。若欲呵上座。是名五法。贵比丘持律。他不差得自说。有五法。贵比丘持律得自说。若诤比丘破戒轻戒无威仪。如小儿无智。不广知毗尼。乐作非法无羞无羞群党。是名五法。闼利吒比丘持律。有五法成就。不差得说。又上座比丘五事应呵若破戒轻戒无威仪。如小儿无智。不广知毗尼。乐于非法非法群党。是名上座有五事应呵。上座比丘复有五事应呵。若上座恶邪见。恶邪见故生倒见。乐非法非时说非实说。于正法中趣有所说。无羞无羞群党。是名上座有五事应呵。优波离。僧中断事比丘。若欲到僧中断事时。应先住五法。然后往到僧中。应恭敬恭敬入脱革屣。不覆右肩不覆头。又应恭敬恭敬入脱革屣。不覆右肩不现胸。又应恭敬恭敬入脱革屣。不覆右肩不反抄衣。又应恭敬恭敬入脱革屣。不覆右肩不得披衣令两向。又应恭敬恭敬入惭愧毁誉不异善心慈心怜愍心。不说世间事。在座坐时。应生善心。不僧中无恭敬恭敬心。佛语优波离。如是僧中断事时。有斗诤者。是断事比丘。应嘱授已从座起去。若善说者应默然住。优波离。僧中断事比丘。应在自坐处说法。若自说若劝他说言。比丘汝说法。有五大贼。劫贼盗贼诈取贼诋谩贼受寄贼。有五种取他物。劫取盗取诈取诋谩取法取。是名五取。有五种人不应与听。无羞人。无所畏人。先有嫌人。少智人。欲舍比丘法人。有五种施无福。施女人。施戏具。施画男女合像。施酒。施非法语。是名五无福施。复有五无福。施器仗。施刀。施毒药。施恶牛。施教他作。如是施。是名五无福施。有五布萨。如先说。有五种。自说阿罗汉得罪。不狂心说。不乱心说。不苦痛说。非实向未受大戒人说。非增上慢说。是名五自说阿罗汉得罪。复有五自说阿罗汉无罪。狂心说。乱心说。苦痛说。实得向大戒人说。增上慢说。是名五自说阿罗汉无罪。复有五自说阿罗汉得罪。不狂不乱不苦痛。不实向未受大戒人说。无所畏说。是名五自说阿罗汉得罪。复有五自说阿罗汉无罪。狂说乱说苦痛说。实得向受大戒人说。不无畏说。是名五自说阿罗汉无罪。复有五不自说阿罗汉得罪。作相作异相异威仪先教他说以他名说。是名五不自说阿罗汉得罪。复有五不自说阿罗汉无罪。不作相。不作异相。不异威仪。先不教他说。不以他名说。是名五不自说阿罗汉无罪。复有五不自说阿罗汉得罪。作相作异相异威仪。先教他说。先教他屏处说。是名五不自说阿罗汉得罪。复有五不自说阿罗汉无罪。不作相。不作异相。不异威仪。不教他说。不先教他屏处说。是名五不自说阿罗汉无罪。喜忘比丘往白衣家数数犯五事。犯非时入家。独与女人屏处。有食家与女人坐。数数食。无净人与女人说法。是名五喜忘比丘入白衣家数数犯。有五种折伏。不使作。不共语。不看视。不教授。不听有所作。是名五种折伏。有五相似。世尊相似。法相似。僧相似。戒相似。闼梨吒比丘相似。是名五相似。复有五不相似。世尊不相似。法不相似。僧不相似。戒不相似。贵比丘不相似。是名五不相似。有五事犯僧伽婆尸沙。人女有命。取女人相。生欲心。欲作非梵行。触小便处。是名五事犯僧伽婆尸沙。复有五种犯僧伽婆尸沙。女人女人想。人人想生欲心。欲作非梵行。触小便处。身身相触。是名五种犯僧伽婆尸沙。有五大贼世间希有。何等五。一者作百人主。二百三百四百五百人主。如先说。是名初大贼。复有大贼。用四方僧物。如先说。是名第二大贼。复有大贼。为饮食故妄语。如先说。是名第三大贼。复有大贼。破戒弊恶内烂流出。非沙门自言沙门。非梵行自言梵行。是名第四大贼。复有大贼。若有佛所说。若声闻所说。仙人所说。诸天所说。化人所说。从彼闻已。自言我说。有人言是持戒人得须陀洹。答言实尔。或默然受。是名第五大贼。因食生五罪。若啖若食若索若取若担出界去。是名因食生五罪。因威仪生五罪。来时去时住时坐时大小便时。是名五因威仪生罪。因人生五罪。女人不能男人。二根人。外道人。不受大戒人。是名五因人生罪。复有五因人生罪。苦切人。依止人。驱出人。下意人。觅罪相人。是名五因人生罪。复有五因人生罪。不见摈人。不作摈人。恶邪不除摈人。别住人。不共住人。是名五因人生罪。复有五因人生罪。别住人。别住竟人灭摈人。贼住人。污比丘尼人。是名五因人生罪。复有五种人。不应与听。别住人。别住竟人。摩那埵人。摩那埵竟人。灭摈人。是名五不应与听。复有五人。不应与听。苦切人。依止人。驱出人。下意人。觅罪相人。是名五不应与听。复有五种人。不应与听。不见摈人。不作摈人。恶邪不除摈人。别住人。不共住人。是名五不应与听。复有五种人。不应与听。无羞人。无所畏人。先有嫌人。少智人。恐怖人是名五人不应与听。不应共要。不应与听遮说戒。不应与听遮自恣。不应与听遮教诫。如是五种人。若与听。若共要。若听遮说戒。若听遮自恣。若听遮教诫。得罪。佛语优波离。比丘欲举他时。应自住五法。然后举他。身清净。口清净。先来清净。多闻广知通利阿含。不至恶聚落。优波离。先自住是五法。然后举他。优波离。何故先自住五法。若后有比丘言。汝身不清净。云何举他。先自净身然后举他。身不清净。如是口不清净。先来不清净。寡闻不通利阿含。至恶聚落。如是等应先自净。然后举他。优波离。是名五先自净然后举他。有五法成就。不应差守物。不知得处。不知价。不知受。不知数。喜忘。是名五法不应差守物。有五事应差守物。知得处知价知受知数不喜忘。是名五法应差。有五事不应差守衣。不知得处。不知价。不知受不知数。喜忘。是名五不应差守衣。有五事应差守衣。知得处知价知受知数不喜忘。是名五法应差守衣。有五事不应差分衣。不识衣。不识衣色。不知价。不知数。不知与不与。是名五法不应差分衣。有五法成就。应差。分衣。识衣识衣色知价知数知与不与。是名五法成就应差分衣。复有五法成就。不应差分衣爱嗔怖痴不知分不分。是名五法成就不应差分衣。有五法成就。应差分衣。无爱嗔怖痴知分不分。是名五法成就应差分衣。有五布萨难。王难贼难若王等难人难恶兽难。是名五布萨难。有五种移布萨。从阿练若处至僧坊。从僧坊至阿练若处。若王敕贼敕。若僧破为和合。是名五移布萨。有破戒比丘。数至他家有五过。教他非法。教他非毗尼。教他至恶威仪边。教他邪见。教听非法。是名五破戒比丘数至他家有五过。有不破戒比丘。至他家有五益利。以法教。以毗尼教。教至善威仪边。教正见。教往听正法。是名五不破戒比丘至他家有五利。复有五破戒比丘。至他家有五过。教身业不善口业不善。教近恶知识。教邪见。教往听非法。是名五破戒比丘至他家有五过。有不破戒比丘。至他家有五益利。教身善口善近善知识。教正见。教听正法。是名不破戒比丘至他家有五益利。比丘有五不可行处。童女寡妇妇淫女比丘尼。是名五比丘至不可行处。复有五比丘至不可行处。童女寡妇淫女外道不能男。是名五比丘至不可行处。复有五。比丘至不可行处。僧能与作苦切羯磨。童女寡妇妇淫女比丘尼。是名五。如苦切。依止驱出下意觅罪相亦如是。复有五。比丘至不可行处。僧能与作苦切羯磨。童女寡妇淫女外道不能男。是名五。如苦切。依止驱出下意觅罪相亦如是。复有五。比丘至不可行处。僧不与舍苦切羯磨。童女寡妇妇淫女比丘尼。是名五。如苦切。依止驱出下意觅罪相亦如是。复有五。比丘至不可行处。僧不与舍苦切羯磨。童女寡妇淫女外道不能男。是名五。僧不与舍苦切羯磨。如苦切。依止驱出下意觅罪相亦如是。复有五。僧不生清净心。说佛过如先说。复有五。僧生清净心。不说佛过如先说。复有五不相似。如先说。有五法相似。亦如先说。有五事。应折伏共行弟子。于和上无爱无敬无惭无愧。乐不应行处。是名五应折伏共行弟子。复有五事。应折伏共行弟子。于和上无爱无敬。无惭无愧。不与和上法衣食。是名五应折伏共行弟子。复次共行弟子有五事。和上不折伏得罪。无爱无敬无惭无愧。乐不应行处。是名五事。和上不折伏共行弟子。和上得罪。复有五事。共行弟子和上不折伏。和上得罪。无爱无敬无惭无愧。不与和上法衣食。是名五。和上不折伏共行弟子。和上得罪。有五事。和上不应受共行弟子悔过。于和上无爱无敬无惭无愧。乐不应行处。是名五。和上不应受共行弟子悔过。复有五事。不应受悔过。于和上无爱无敬无惭无愧。不与和上法衣食。是名五。和上不应受共行弟子悔过。有五事。和上受共行弟子悔过得罪。无爱无敬无惭无愧。乐不应行处。是名五。和上受共行弟子悔过得罪。复有五事。和上受共行弟子悔过得罪。无爱无敬无惭无愧。不与和上法衣食。是名五法。和上受共行弟子悔过得罪。有五事。和上不应折伏共行弟子。于和上有爱有敬有惭有愧乐应行处。是名五法。和上不应折伏共行弟子。复有五事。不应折伏共行弟子。于和上有爱有敬有惭有愧。与和上法与衣食。是名五。和上不应折伏共行弟子。复有五事。和上折伏共行弟子。有过罪有爱有敬有惭有愧乐应行处。是名五。折伏共行弟子得罪。复有五。和上折伏共行弟子得罪。有爱有敬有惭有愧。与和上法衣食。是名五。和上折伏共行弟子得罪。有五事。应受共行弟子悔过。于和上。有爱有敬有惭有愧乐应行处。是名五。应受共行弟子悔过。复有五。应受共行弟子悔过。有爱有敬有惭有愧。与和上法衣食。是名五。应受共行弟子悔过。有五事。和上受共行弟子悔过无罪。于和上有爱有敬有惭有愧乐应行处。是名五。和上受共行弟子悔过无罪。复有五。和上受共行弟子悔过无罪。于和上有爱有敬有惭有愧。与和上法衣食。是名五。和上受共行弟子悔过无罪。有五种人。不应为说毗尼。试问。无疑问。不为悔所犯问。诘问。不受语问。是名五种人不应为说。有五种人应为说比尼。不试问。有疑问。为悔所犯问。不诘问。受语问。是五种人。应为说比尼。有五事。闼利吒比丘不能灭诤。恃力势语。无畏难语。怖语。惊语。不利根语。是名五闼利吒比丘不能灭诤。复有五事。闼利吒比丘能灭诤。不恃力语。有所畏语。不怖语。不惊语。利根语。是名五闼利吒比丘能灭诤。复有五事。闼利吒比丘不能灭诤。大语不相善语。疾语改易语。不与法相应语。是名五闼利吒比丘不能灭诤。有五事。闼利吒比丘能灭诤。不大语相善语。不疾语不改易语。与法相应语。是名五事闼利吒比丘能灭诤。复有五事。闼利吒比丘不能灭诤。语喜忘。不审谛语。恶性语。嗔语试语。是名五事闼利吒比丘不能灭诤。有五事。闼利吒比丘能灭诤。语不喜忘。审谛语不恶性语。不嗔语不试语。是名五闼利吒比丘能灭诤。复有五事。闼利吒比丘不能灭诤。毁呰语遏截语讥刺语。不唱善语。出过语。是名五闼利吒比丘不能灭诤。有五事。闼利吒比丘能灭诤。不毁呰语。不遏截语。不讥刺语。唱善语。不出过语。是名五闼利吒比丘能灭诤。复有五事。闼利吒比丘不能灭诤。不具足语。覆藏语。窃语浑杂语。被呵折语。是名五事闼利吒比丘不能灭诤。有五事。闼利吒比丘能灭诤。具足语不覆藏语。不窃语不浑杂语。不被呵折语。是名五闼利吒比丘能灭诤。复有五事。闼利吒比丘不能灭诤。不实语诡语。改易语。非时语。失期语。是名五闼利吒比丘不能灭诤。有五事。闼利吒比丘能灭诤。实语不诡语。不改易语。不非时语。不失期语。是名五闼利吒比丘能灭诤。复有五事。闼利吒比丘不能灭诤。欲举他语。举他语。轻他语。呵责语。有嫌语。是名五闼利吒比丘不能灭诤。有五事。闼利吒比丘能灭诤。不欲举他语。不举他语。不轻他语。不呵责语。无嫌语。是名五闼利吒比丘能灭诤。复有五事。闼利吒比丘不能灭诤。破众语。欲破众语。破义语。乐破语。求名语。是名五闼利吒比丘不能灭诤。有五事。闼利吒比丘能灭诤。不破众语。不欲破众语。不破义语。不乐破语。不求名语。是名五闼利吒比丘能灭诤。复有五事。闼利吒比丘不能灭诤。爱语嗔语怖语痴语人不信受语。是名五闼利吒比丘不能灭诤。复有五事。闼利吒比丘能灭诤。不爱语不嗔语。不怖语不痴语。人信受语。是名五闼利吒比丘能灭诤。复有五事。闼利吒比丘不能灭诤不恭敬语。不恭敬入语。着革屣语。覆右肩语。覆头语。是名五闼利吒比丘不能灭诤。有五事。闼利吒比丘能灭诤。恭敬语。恭敬入语。脱革屣语。不覆右肩语。不覆头语。是名五闼利吒比丘能灭诤。复有五事。闼利吒比丘不能灭诤。不通利修多罗语。不通利毗尼语。不善诤义语。不善知诤。起因缘语。不善知灭诤义语。是名五闼利吒比丘不能灭诤。有五事。闼利吒比丘能灭诤。善修多罗义语。善毗尼义语。善诤义语。善知诤起因缘语。善灭诤义语。是名五闼利吒比丘能灭诤。复有五事。闼利吒比丘不能灭诤。身力语口力语。非修多罗语。非法语非毗尼语。是名五闼利吒比丘不能灭诤。有五事。闼利吒比丘能灭诤。不身力语。不口力语。如修多罗语。如法语如毗尼语。是名五闼利吒比丘能灭诤。复有五事。闼利吒比丘不能灭诤。不被劝语。不被差语。不白众语。不观察语。无畏难语。是名五闼利吒比丘不能灭诤。有五事。闼利吒比丘能灭诤。被劝语被差语。白众语观察语。不无畏语。是名五闼利吒比丘。能灭诤。复有五事。闼利吒比丘不能灭诤。慰恤语。受慰恤语。筹量语。为利语。取他意语。是名五闼利吒比丘不能灭诤。有五事。闼利吒比丘能灭诤。不慰恤语。不受慰恤语。不筹量语。不为利语。不取他意语。是名五闼利吒比丘能灭诤。复有五事。闼利吒比丘不能灭诤。不善义语。不善句语。应先语便后语。应后语便先语。应说此语便说彼语。是名五闼利吒比丘不能灭诤。有五事。闼利吒比丘能灭诤。善义语善句语应先先语。应后后语。应说此语说此语。是名五闼利吒比丘能灭诤。复有五。闼利吒比丘不能灭诤。少智。少诵阿含。不通达阿含。不受学阿含。不知阿含句义。是名五闼利吒比丘不能灭诤。有五闼利吒比丘能灭诤。不少智。多诵阿含。通达阿含。受学阿含。知阿含句义。是名五闼利吒比丘能灭诤。复有五。闼利吒比丘不能灭诤。为斗语。为破语。为相持语。为相言语。为诤语。是名五闼利吒比丘不能灭诤。有五闼利吒比丘能灭诤。不为斗语。不为破语。不为相持语。不为相言语。不为诤语。是名五闼利吒比丘能灭诤。复有五。闼利吒比丘不能灭诤。违誓语。不问语。不三问语。不识言者语。不识诤者语。是名五闼利吒比丘不能灭诤。有五事。闼利吒比丘能灭诤。不违誓语问语三问语。识言者语。识诤者语。是名五闼利吒比丘能灭诤。复有五事。闼利吒比丘不能灭诤。忘阿含语。失文句语。漏失阿含语。不通利阿含语。不恭敬受阿含语。是名五闼利吒比丘不能灭诤。有五闼利吒比丘能灭诤。不忘阿含语。不失文句语。不漏失阿含语。通利阿含语。恭敬受阿含语。是名五闼利吒比丘能灭诤。复有五。闼利吒比丘不能灭诤。重说众语。持众语异语。为利语求他语。是名五闼利吒比丘不能灭诤。有五事。闼利吒比丘能灭诤。不重说众语。不持众语。不异语。不为利语。不求他语。是名五闼利吒比丘能灭诤。复有五事。闼利吒比丘不能灭诤。众说悔过便说其罪。令不嗔者嗔。嗔者不止。所说如风。人不信受。所说义不合毗沙耶经。是名五闼利吒比丘不能灭诤。有五事。闼利吒比丘能灭诤。众说悔过不说其罪。令不嗔者不起嗔。嗔者能止。所言信受。所说义合毗沙耶经。是名五闼利吒比丘能灭诤。佛语优波离。若下座比丘向上座悔过时。应先住五法向上座悔过。从座起。偏袒着衣。脱革屣。右膝着地。以两手捉上座足。如是三说。如悔过。与欲清净受自恣出罪亦如是。有五法。举事者不能举他。身不清净。口不清净。少智。不通利阿含。乐不可行处。是名五举事者不能举他。身不清净。口不清净。不通利阿含。少智。乐不可行处。复有五事。举事者能举他。身清净口清净。多智。通利阿含。不乐不可行处。是名五法能举他。身清净口清净。通利阿含多智。不乐不可行处。有五事。十岁比丘应畜大戒弟子。受大戒若十岁若过十岁。持戒有智能断弟子疑。能破弟子邪恶见。复有五事。十岁比丘应畜大戒弟子。能教持戒能教毗尼。教阿毗昙。若弟子在他方不乐。能自将来若因他将来。若病能自看若使他看。复有五事。十岁比丘应畜大戒弟子。有信有戒有施多闻智慧。又能令弟子入信。随信住信戒施闻慧。能令入能令随住。是名五。复有五事。十岁比丘应畜大戒弟子。自住无学戒无学定无学慧无学解脱无学解脱知见。能教弟子住是无学戒定慧解脱解脱知见。是名五法十岁比丘应畜大戒弟子。若十岁比丘。无是五法畜大戒弟子。有罪。若有是五法。应与他依止。若十岁比丘。无是五法与他依止。有罪。若有是五法应畜沙弥。若十岁比丘。无是五法畜沙弥。有罪(五法竟)

    六法初

有六诤本。一者嗔恨不语。二者恶性欲害。三者贪嫉。四者谄曲。五者无惭愧。六者恶欲邪见。是名六诤本。有六教法。应随不应逆。和上教。阿阇梨教。众僧教王教。若王等教。闼利吒比丘教。是名六教不应逆。有六羯磨。白羯磨。白二羯磨。白四羯磨。僧羯磨。闼利吒比丘羯磨。说戒羯磨。是名六羯磨。有六学。增上戒。增上意。增上智。增上威仪增上毗尼。增上波罗提木叉。是名六学。有六请。僧请众人请。人请钵请。衣请食请。是名六请。有六不具足。戒不具足。见不具足。命不具足。威仪不具足。自不具足。他不具足。是名六不具足。有六具足。戒具足。见具足。命具足。威仪具足。自具足。他具足。是名六具足。时长老优波离。往到佛所头面礼足在一面立已白佛言。善哉世尊。愿略说法要。令我知是法是毗尼是佛教。佛语优波离。若法随欲不随无欲。随和合不随不和合随过不随无过。随增长不随不增长。随往来不随不往来。随烦恼不随无烦恼。汝知是非法非毗尼非佛教。又优波离。有法随无欲不随欲随不和合不随和合。随无过不随过。随不增长不随增长。随不往来不随往来。随非烦恼不随烦恼。汝知是法是毗尼是佛教。长老阿那律。往到佛所头面作礼白佛言。善哉世尊。愿略说法。令我知是法是毗尼是佛教。佛言。善哉。若法随贪不随无贪。随无厌不随厌。随多欲不随少欲。随不知足不随知足。随恶见不随不恶见。阿那律。汝知是非法非毗尼非佛教。阿那律。若法随无贪不随贪。随厌不随无厌。随少欲不随多欲。随知足不随不知足。随不恶见不随恶见。汝知是法是毗尼是佛教。如优波离所问。大爱道亦如是问。如长老阿那律所问。鸡舍瞿昙弥亦如是问。有六现前。僧现前。众人现前。人现前。和上现前。阿阇梨现前戒现前。是名六现前

有六取。劫取盗取。诈取受寄取。诋谩取如法取。是名六取。有六和摄法。以修身慈劝梵行者。尊重敬爱思惟摄取。发起精进向一泥洹。口慈意慈亦复如是。如法得施衣钵。余物施诸梵行。尊重敬爱思惟摄取。发起精进向一泥洹。护戒不缺不犯不退。清净满足为佛所叹。能尽受持劝诸梵行。尊重敬爱思惟摄取。发起精进向一泥洹。所得正见能出正要。劝诸梵行。尊重敬爱思惟摄取。发起精进向一泥洹。是名六和摄法(六法竟)

    七法初

有七财。信财戒财闻财施财慧财惭财愧财。是名七财。有七力。信力精进力惭力愧力念力定力慧力。是名七力。有七止诤。现前止自言止忆念止不痴止觅罪相止多觅罪止布草止。是名七止诤。有七衣。麻衣沙拏衣刍摩衣憍施耶衣翅夷罗衣钦婆罗衣劫贝衣。是名七衣。有七内众。比丘比丘尼式叉摩尼沙弥沙弥尼优婆塞优婆夷。是名七内众。有七法。令正法灭亡没。无信懈怠无惭无愧喜忘无定少智。是名七法。令正法灭亡没。有七非正法。不敬法不敬义不敬时不知足不自敬不敬众不分别人。是名七。有七正法敬法敬义敬时知足自敬敬众分别人。是名七正法。持律有七德。能持佛内藏。能善断诤。以持戒故在外道顶上住。以持律故无能诘者。以持律故不咨问他。于众中说戒无所畏。能断有疑。能令正法久住。是名持律七德。有七大持律。毗婆尸佛。式佛。随叶佛。俱留孙佛。俱那含牟尼佛。迦叶佛。释迦牟尼佛。是名七大持律(七法竟)

    八法初

有八众。刹利众。婆罗门众。居士众。沙门众。比丘众。比丘尼众。优婆塞众。优婆夷众。是名八众。有八法。能证泥洹果。正见正志正语正业正命正方便正念正定。是名八法。能证泥洹果。有八施。果得施。依止得施。制限得施。因缘得施。僧得施。现前得施。安居得施。指示得施。是名八施。因八事舍迦絺那衣。三衣足时衣成时。去时闻时失衣时。发心不还时。过齐限时。共僧舍时。是名因八事舍迦絺那衣。有八种屐不应畜。木屐多罗屐。波罗舍屐竹屐。叶屐文若屐。披披屐钦婆罗屐。是名八种屐不应畜。有八随世法。利衰毁誉称讥苦乐。是名随世八法。有八种难。王难贼难火难水难恶兽难龙难人难非人难。是名八难。有比丘。行别住时舍戒。舍已还受。还受已白诸比丘。我行别住中。舍戒已还受。我当云何。诸比丘以是事白佛。佛语诸比丘。本已行别住。即以是行别住。更不应与。如舍戒自言我是沙弥。不见摈不作摈恶邪不除摈亦尔。若别住竟舍戒。舍已还受戒。受戒已白诸比丘。我别住竟舍戒。舍戒已更受戒。我当云何。诸比丘以是事白佛。佛语诸比丘。本已行别住竟。应教求摩那埵。如舍戒自言我是沙弥。不见摈不作摈恶邪不除摈亦尔。有比丘。行摩那埵时舍戒。舍已还受戒。受戒已语诸比丘。我行摩那埵中。舍戒还受戒。我当云何。诸比丘以是事白佛。佛言。即本行摩那埵。更不须与。如舍戒自言我是沙弥。不见摈不作摈恶邪不除摈亦尔。若行摩那埵竟舍戒。舍戒已还受戒。受戒已白诸比丘。我行摩那埵竟舍戒。舍戒已还受戒。我当云何。诸比丘以是事白佛。佛言。本已行摩那埵竟。应教求出罪羯磨。如舍戒自言我是沙弥。不见摈不作摈恶邪不除摈亦尔(八法竟)

    九法初

有九恼。是人已侵损我。当侵损我。今侵损我。于彼生恼。是人已利益我怨家。当复利益。今复利益。于彼生恼。是人已侵损我知识。当复侵损。今复侵损。于彼生恼。是名九恼。有九舍恼。是人已侵损我。当侵损我。今侵损我。云何令彼不侵损我而利益我。当于彼舍恼心。是人已利益我怨家。当复利益。今复利益。云何令彼不利益我怨家。当舍彼恼心。是人已侵损我知识。当复侵损。今复侵损。云何令彼不侵损我知识。当于彼舍恼心。是名九舍恼(九法竟)

    十法初

有十事。令正法灭亡没。非法言法。法言非法。非毗尼言毗尼。毗尼言非毗尼。非犯言犯。犯言非犯。轻言重。重言轻。无残言残。残言无残。是名十事令正法灭亡没。有十事。不令正法灭亡没。非法言非法。法言法。非毗尼言非毗尼。毗尼言毗尼。非犯言非犯。犯言犯。无残言无残。残言残。轻言轻。重言重。是名十事不令正法灭亡没。有十法名上座。有所住处。无畏无能遮者。有长老息烦恼。多知识有名闻。能令他生净心。辩才具足无能胜者。无有滞碍义趣明了。闻者信受。善能安详入他家。能为白衣说深妙法。分别诸道。劝令行施斋戒。令他舍恶从善。自具四谛。现法安乐无有所乏。是名上座十法。乌回鸠罗比丘成就十法。僧不应差。不知诤根。本来往处。不知诤。不善分别诤。不能知诤起因缘。不能知诤义。不善灭诤。不能令诤灭已更不起。戒不清净。不能多闻。少智。是名十乌回鸠罗比丘僧不应差。乌回鸠罗比丘。有十事僧应差。知诤来往处根本。善知诤。能分别诤。知诤起因缘。知诤义善灭诤。灭诤已更不令起。持戒清净多闻多智。是名十乌回鸠罗比丘僧应差

佛在婆伽国那梨槃聚落。是中有优婆塞。以信乐清净心作一房舍。别与长老罗云。长老罗云受已二月游行。彼优婆塞闻长老罗云受舍已二月游行。便持此舍施四方僧。长老罗云二月游行。还到所住处。闻是优婆塞以是房施四方僧。闻已往到佛所。头面作礼白佛言。世尊。我在那梨槃聚落中住。有优婆塞。以信乐清净心作一房舍。别施我。我受已二月游行。游行还闻是优婆塞以是房施四方僧。世尊我今云何。佛语罗云。汝往语优婆塞言。我将不犯汝耶。汝见我非沙门非沙门行耶。作身口过耶。长老罗云受佛语已。从坐起礼佛足右绕而去。还自住处。过是夜已。着衣持钵入那梨槃聚落行乞食。食已洗钵。往是优婆塞家。是优婆塞遥见长老罗云来。见已着衣在一面立。叉手合掌向长老罗云。作是言。善来长老罗云。久不来。罗云。何以故来。可就座坐。时长老罗云即就座坐。是优婆塞头面礼足在一面坐已长老罗云语优婆塞。我将不犯汝耶。汝见我非沙门非沙门行耶。作身口过耶。答言。大德不犯我。我亦不见汝非沙门非沙门行作身口过。时长老罗云。为种种说法示教利喜已。从坐起去。往到佛所。头面礼足在一面坐。以是事向佛广说。佛以是事集比丘僧。语诸比丘言。有十非法施十非法受十非法用。何等十。已施一僧。转与余僧。是名非法施非法受非法用。若已施一比丘尼僧。转与余比丘尼僧。是名非法施非法受非法用。若已施三比丘。转与余三比丘。是名非法施非法受非法用。若转与二比丘。若与一比丘。若与僧。是名非法施非法受非法用。若已施二比丘。转与余二比丘。是名非法施非法受非法用。若转与一比丘。若与僧若与三人。是名非法施非法受非法用。若已施一比丘。转施余一比丘。是名非法施非法受非法用。若转施僧。若施三人二人。是名非法施非法受非法用。若已施三沙弥。转施余三沙弥。是名非法施非法受非法用。若转施二沙弥一沙弥若施僧。是名非法施非法受非法用。若已施二沙弥。转与余二沙弥。是名非法施非法受非法用。若转施一沙弥。若施僧若施三人。是名非法施非法受非法用。若已施一沙弥。转施余一沙弥。是名非法施非法受非法用。若转与僧若施三人若施二人。是名非法施非法受非法用。若已施三比丘尼。转施余三比丘尼。是名非法施非法受非法用。若转施二比丘尼一比丘尼若施僧。是名非法施非法受非法用。若已施二比丘尼。转施余二比丘尼是名非法施非法受非法用。若转施一比丘尼。若与僧若施三人。是名非法施非法受非法用。若已施一比丘尼。转施余一比丘尼。是名非法施非法受非法用。若转施僧若施三人若二人。是名非法施非法受非法用。若已施三式叉摩尼。转施余三式叉摩尼。是名非法施非法受非法用。若转施二式叉摩尼一式叉摩尼若施僧。是名非法施非法受非法用。若已施二式叉摩尼。转施余二式叉摩尼。是名非法施非法受非法用。若转施一式叉摩尼。若施僧若施三人。是名非法施非法受非法用。若已施一式叉摩尼。转施余一式叉摩尼。是名非法施非法受非法用。若施僧若施三人若二人。是名非法施非法受非法用。若已施三沙弥尼。转施余三沙弥尼。是名非法施非法受非法用。若转施二沙弥尼若一若僧。是名非法施非法受非法用。若已施二沙弥尼。转施余二沙弥尼。是名非法施非法受非法用。若转施一沙弥尼。若僧若施三人。是名非法施非法受非法用。若已施一沙弥尼。转施余一沙弥尼。是名非法施非法受非法用。若转施僧若三人若二人。是名非法施非法受非法用。若已施三畜生。转施余三畜生。是名非法施非法受非法用。若施二畜生若一畜生。是名非法施非法受非法用。若已施二畜生。转施余二畜生。是名非法施非法受非法用。若转施一畜生若三畜生。是名非法施非法受非法用。若已施一畜生。转施一畜生。是名非法施非法受非法用。若转施三若二。是名非法施非法受非法用。若已施比丘僧。转施比丘尼僧。是名非法施非法受非法用。若已施比丘尼僧。转施比丘僧。是名非法施非法受非法用。若僧破为二部。已施此一部。转施彼一部。是名非法施非法受非法用。若已施彼一部。转施此一部。是名非法施非法受非法用。前施是施。后施非施。如王为地主檀越。是房舍卧具主。但得看视。不得夺一与一(十法竟)

    增一后一法初

有三羯磨。摄一切羯磨。白羯磨。白二羯磨。白四羯磨。有一破法堕恶道。何等一。所谓破僧。有一犯堕恶道。从身作。谓出佛身血。有一犯堕恶道。从口作。谓谤佛。有一犯堕恶道。所谓意念作别众。有一犯堕恶道。谓两舌教他破僧。有一犯诘问堕恶道。谓僧诘问。非法非法想。非法见故破僧。非法作法想。非法见故破僧。非法法想疑破僧。有一犯堕恶道。从杀生起。谓杀阿罗汉。又一犯堕恶道。从盗起。偷佛物僧物。又一犯堕恶道。从淫起。谓淫罗汉比丘尼。又一犯堕恶道。从妄语起。谓自说得过人法(一法竟)

    二法初

有二犯。不善犯无记犯。又二犯。身犯口犯。又二犯。方便犯非方便犯。又二犯。调戏犯不调戏犯。又二犯。有同犯不同犯。又二事同。轻重。又二事同。有残无残。又二不同。轻重。又二不同。有残无残。又二不同。若向他悔若自悔。又二犯。有限犯无限犯。又二犯。处犯方犯。又二犯。可数犯不可数犯。又二犯。有出时犯欲出犯。又二犯。入犯欲入犯又二犯。起犯欲起犯。又二犯。时犯非时犯。又二犯。堕犯不堕犯。又二犯。偷兰遮犯白衣相应犯。又二犯。重破犯不重破犯。又二犯有残犯无残犯。又二犯。轻犯重犯。又二犯。被举犯。举者犯。又二犯。向他悔犯自悔犯。又二犯。戒中犯非戒中犯。又二犯。白犯不白犯。又二犯。暂犯尽形犯。又二犯。有过犯无过犯。比丘尼有二同犯。轻犯重犯又二同犯。残犯无残犯。又二不同。轻重。又二不同。有残无残。又二不同。向他悔自悔。又二犯。出界犯欲出界犯。又二犯自称叹犯不自称叹犯。又二犯。起犯坐犯。又二犯。眠犯不眠犯。又二犯语犯默然犯。又二犯故犯不故犯。有二痴。无知痴放逸痴。有二覆。无知覆放逸覆。又二人。应与别住。有二人。应与摩那埵。有二人。应与本日治。有二人。应与出罪。所谓比丘非比丘受大戒非受大戒者。又二僧中断事者。有被差不被差。又二断事者。被羯磨不被羯磨。羯磨者有二功德。谓得众意能无畏断事。又二断事者。有羞无羞。又二断事者。有私无私。若以非法有私。若如法无私。又二断事者。若自闻若从他闻。又二断事者。若自驱若教他驱。又二断事者。诤不诤。又二断事者。通利阿含不通利阿含。又二断事者。善分别阿含。不善分别阿含。又二断事者了语不了语。又二断事者。善语不善语。又二断事者。诘问不诘问。又二断事者。急性不急性。又二断事者。自知不自知又二断事者。知量不知量。又二断事者。随众不随众。又二断事者。自誉不自誉。又二断事者。能止不能止。又二断事者。软语粗语。又二断事者。持戒不持戒。有可呵不可呵。应举不应举。应敬不应敬亦尔。又二无智。戒犯见犯。又二智。戒不犯见不犯。又二犯。戒犯见犯。又二不犯。戒具见具。又二种呵。比丘非比丘受戒不受戒。又二苦切。有罚羯磨若僧和合与。又二依止。有罚若僧和合与。有二驱出。有罚羯磨若僧驱出。又二下意。有罚羯磨若僧与下意。又二人应别住。又二人应与摩那埵。又二人应与本日治。又二人应与出罪。谓比丘非比丘受戒非受戒。有二清净。悔过发露罪名。又二清净。白不白若悔过若发露。若僧诤应还付僧若与三人二人一人。若僧诤僧应受。三人二人一人亦应受。若僧诤僧应灭。三人二人一人亦应灭。又二非法捡挍。非法作法捡挍。法作非法捡挍。又二如法捡校。非法作非法捡挍。法作法捡挍。又二梵罚。不使作不教化(二法竟)

    三法初

有三毗尼。贪欲毗尼。嗔恚毗尼。愚痴毗尼。有三非毗尼。非贪欲毗尼。非嗔恚毗尼。非愚痴毗尼。有三羯磨。白羯磨白二羯磨白四羯磨。有三应屏处。大便小便嚼杨枝。有三犯。贪欲犯嗔恚犯愚痴犯。有三共住。犯者不犯者自说者。有三别住。犯者不犯者自说者。有三世所供养。谓如来至真等正觉。漏尽阿罗汉。转轮圣王。有三华供养。有三香供养。有三伎乐供养。有三幡供养。有三盖供养。有三缯供养。有三世所尊敬。谓如来至真等正觉漏尽阿罗汉。转轮圣王。有三同意上中下。上同意者。应上中下同意。中同意者。不应上同意。应中下同意。下同意者。应下同意。不应上中同意。上同意者。作上中下同意好。中同意者。作中下同意好。若作上同意者不好。下同意者。作下同意好。若作上中同意者不好。上同意者。应作上中下同意取。中同意者。应作中下同意取。不应上同意取。下同意者。应下同意取。不应上中同意取。有三知。知犯知不犯知制戒(三法竟)

    四法初

有四诤。斗诤无根诤犯罪诤常所行诤。有四药。时药时分药七日药尽形药。有四众。刹利众婆罗门众居士众沙门众。复有四众。比丘众比丘尼众优婆塞众优婆夷众。复有四众。四天王众忉利天众魔众梵天王众。复有四众。被教众不被教众浊众清净众。有四悲。一怜愍。二利益。三不恼害。四住正法。有四止。贪欲止嗔恚止愚痴止邪见止。有四事故如来设教。犯不犯轻重有四事故如来制戒。为利益为处为时为人。有四调伏。苦切依止驱出下意有四药应观。有净药杂不净。不净杂净。净杂净。不净杂不净。有四事。斗诤事。无根诤事。犯罪诤事。常所行诤事。复有四事。苦切依止驱出下意。有四事。不见摈。不作摈。恶邪不除摈。觅罪相摈。有四事。若呵若骂若异语若默然。如来以四境界故制戒。神足境界。智境界。法境界。人境界(四法竟)

十诵律卷第五十十诵律卷第五十一(第八诵之四)

        后秦北印度三藏弗若多罗译

    五法初

有五事故僧与下意。说佛过法过僧过戒过。作非威仪。复有五事。僧与作下意。骂比丘。道说比丘。出比丘过。处处说他过。使他不得施不得住处。复有五事。僧与下意。骂白衣道说白衣出白衣过。处处说他过。使白衣不得利失住处。复有五事。僧与下意。比丘两舌斗他。以比丘向比丘两舌。以白衣向白衣两舌。以比丘向白衣两舌。以白衣向比丘两舌。作世间法骂有五事。形相生种作犯病。复有五事。形相生相作多烦恼作世间法骂。有五种皮不应畜。师子皮虎皮豹皮獭皮狸皮。有五种皮不应畜。象皮马皮狗皮野干皮黑鹿皮。有五种粪扫衣。不应畜。火烧衣牛嚼衣鼠啖衣初嫁衣产衣。有五事。老比丘语不应受。无义语。非法语。非毗尼语。无怜愍语。非教敕语。有五。自说阿罗汉。如先说。佛语优波离。比丘欲入僧。应住五法中。如先说。有五事。犯僧伽婆尸沙。如先说。有五处分。界处分。施处分道径行处分。戒处分。见处分。有五纯色不应畜。纯赤纯青纯郁金色纯黄蓝色纯曼提咤色。有五种大色不应畜。穹伽色黔蛇色卢耶那色嵯梨多色呵梨陀罗色。有五事。闼利咤比丘不能灭诤。不见言见。不闻言闻。不忆言忆。不知言知。非法言法。是名五事闼利吒比丘不能灭诤。复有五事。闼利吒比丘能灭诤。见言见。闻言闻。忆言忆。知言知。法言法。是名五闼利吒比丘能灭诤。复有五事。闼利吒比丘不能灭诤。随爱嗔怖痴非法言法。是名五事闼利吒比丘不能灭诤。复有五事。闼利吒比丘能灭诤。不随爱嗔怖痴法言法。是名五闼利吒比丘能灭诤。复有五事。闼利吒比丘有犯。不见言见。不闻言闻。不忆言忆。不知言知。非法言法。是名五闼利吒比丘有犯。有五事。闼利吒比丘无犯。见言见。闻言闻。忆言忆。知言知。法言法。是名五事闼利吒比丘无犯。复有五事。闼利吒比丘有犯。随爱随嗔随怖随痴非法言法。是名五事闼利吒比丘有犯。复有五事。闼利吒比丘无犯。不随爱嗔怖痴法言法。是名五闼利吒比丘无犯。有五事。闼利吒比丘不能灭诤。不善知诤。不善知诤住处。不善分别诤。不知灭诤因缘。不善知灭诤已更起因缘。是名五闼利吒比丘不能灭诤。复有五事。闼利吒比丘能灭诤。善知诤。善知诤住处。善分别诤。善知灭诤因缘。善知灭诤已更不复起因缘。是名五闼利吒比丘能灭诤。复有五事。闼利吒比丘不能灭诤。不善知修多罗。不善知毗尼。不善知诤不善知诤住处。不善分别诤。是名五闼利吒比丘不能灭诤。有五事。闼利吒比丘能灭诤。善修多罗。善毗尼。善知诤。善知诤住处。善分别诤。是名五闼利吒比丘能灭诤。有五事。五岁比丘不依止他。知犯知不犯知轻知重广通利戒。是名五。五岁比丘不依止他。有五同意取。若亲厚若活在若现前。若取已当语令知。取已彼必欢喜。是名五同意取。有五事故。如来按行诸房舍。为断比丘俗语故。以床卧具不料理者为料理故。已料理好安隐故。看病比丘故。未制戒欲制故。是名五事如来按行房舍。有五事。如来知而故问。为起因缘故。为制戒故。为分别义句故。与修多罗文句相似故。为后众生令自解故。是名五事如来知而故问。经行有五利益。剿健有力不病消食意得坚固。是名经行五利。复有经行五利益。能行故。解劳故。除风故。消冷热病故。意得坚固。是名经行五利。有五非法发露。向别住人。不共住人。未受大戒众。无残事。不见是事发露。是名五非法发露。有五如法发露。不向别住人。不向不共住人。不向未受大戒众。以有残事。见是事发露。是名五事如法发露。有五事。非法作苦切羯磨。非法非毗尼。应遮应置。无事不现前作。无举者不令他忆不三问作。是名五事作非法苦切羯磨。有五如法作苦切羯磨。是法是毗尼。不应遮不应置。有事现前作。有举者令他忆念。三问作。是名五如法与苦切羯磨。有五事。名善好闼利吒比丘。见言见。闻言闻。忆言忆。知言知。法言法。是名五善好闼利吒比丘。有五事。名好闼利吒比丘。不随爱嗔怖痴法言法。是名五好闼利吒比丘。有五事。名好闼利吒比丘。善分别取事。无过者不说有过。有过者说过。不清净边生不清净。清净边生清净。法言法。是名五好闼利吒比丘。有五事。名好闼利吒比丘。善分别事不恃力。僧中断事。得听已举他事。无偏私受悔过。无偏私见他过。无偏私说他过。法言法。是名五好闼利吒比丘。有五事。名好闼利吒比丘。善取诤。善知诤处。善分别诤。善知诤灭已更不起。法言法。是名五好闼利吒比丘。有五事。名好闼利吒比丘。善知修多罗。善知毗尼。善知诤。善知诤处。法言法。是名五好闼利吒比丘。复有五事。名好闼利吒比丘。受戒满十岁若过十岁。若持戒若多闻。善如法断自疑他疑。善能断自他恶邪见。是名五好闼利吒比丘。有五事。名好闼利吒比丘。善能令他住戒。善教毗尼阿毗昙。弟子若入他方不乐能将来。能看病教他看。是名五好闼利吒比丘。有五事。名好闼利吒比丘。能令他有信有持戒有多闻有施有智。是名五好闼利吒比丘。复有五事。名好闼利吒比丘。若自住无学戒无学定无学。智无学解脱解脱知见。亦能令他住无学戒定慧解脱解脱知见。是名五好闼利吒比丘。复有五事。名好闼利吒比丘。知犯知不犯知轻知重广通利戒。是名五好闼利吒比丘。有五事。名好闼利吒比丘。知出家知羯磨知教授知依止知障道不障道。是名五好闼利吒比丘(五法竟)

    六法如先说

    七法如先说

    八法初

不应畜八种钵。金钵银钵琉璃钵颇梨钵铜钵白镴钵木钵石钵。是名八种钵不应畜。余如先说

    九法初

佛语优波离。一比丘不能破僧。二三四乃至九比丘清净同见者能破。一比丘尼一式叉摩尼一沙弥一沙弥尼一出家一出家尼不能破僧。二三四乃至九亦不能破。优波离。若有九比丘清净同见者能破僧。有九犯。犯波罗夷犯僧伽婆尸沙。犯波逸提。犯波罗提提舍尼。犯突吉罗。犯恶口突吉罗。犯偷兰遮突吉罗。犯毗尼突吉罗。犯威仪突吉罗。是名九犯有九退。戒退见退命退。威仪退自退他退。知识退资生物退生死退。是名九退。有九不退。戒不退见不退命不退。威仪不退自不退他不退。知识不退资生物不退生死不退。是名九不退。佛语优波离。闼利吒比丘若断诤时。应以九事。观言者。观诤者。观威仪。观来往处。观亲里。观知识。观身口行。观先来。观云何相言。应听他语应从他闻。是名九应观言者诤者。何等九事观彼言者。观斗不斗。观诤不诤。观相持不相持。观相言不相言。观犯戒。观犯见。观犯命。观言语。观从他闻。是名九应观。彼言者。尔时长老优波离。往到佛所头面作礼在一面立。善哉世尊。愿略说法。令我知是法是毗尼是佛教。佛语优波离。若法随欲不随无欲。随嗔不随无嗔。随嫉妒不随无嫉妒。随往来不随不往来。随增长不随不增长。随斗不随无斗。随诤不随无诤。随相持不随不相持。随相言不随不相言。优婆离。汝定知是非法非毗尼非佛教。优婆离。若法随无欲不随欲。随无嗔不随嗔。随无嫉妒不随嫉妒。随不往来不随往来。随不增长不随增长。随不斗不随斗。随不诤不随诤。随不相持不随相持。随不相言不随相言。汝定知是法是比尼是佛教

尔时长老阿那律。往到佛所头面作礼在一面坐。白佛言。善哉世尊。愿略说法。令我知是法是比尼是佛教。佛语阿那律。若法随贪不随无贪。随无厌不随厌。随多欲不随少欲。随不知足不随知足。随难满不随易满。随放逸不随不放逸。随非法不随法。随背法不随不背法。随世俗语不随毗尼语。佛语阿那律。汝定知是非法非毗尼非佛教。阿那律。若法随无贪不随贪。随厌不随无厌。随少欲不随多欲。随知足不随不知足。随易满不随难满。随不放逸不随放逸。随法不随非法。随顺法不随背法。随比尼语不随俗语。汝定知是法是毗尼是佛教。如长老优波离所问。大爱道亦如是问。如长老阿那律所问。瘦瞿昙弥亦如是问。有九依止。若善男子依止信心。舍不善取善者。是名舍不善取善。戒闻施智亦尔。是名善男子依止信心舍不善取善。是人住是五法已。应更证四法。法忍随忍乐忍弃舍忍。是名九依止。有外道。名婆呵树和。往到佛所问讯在一面坐已白佛言。瞿昙。先在优楼频蠡国尼连禅河边。在一迦和罗树下。得阿耨多罗三藐三菩提。不久我时彼处从瞿昙闻。漏尽阿罗汉。不还生死不作五事。不故杀生不盗不淫不故妄语不饮酒。我从瞿昙闻说是语。即便信受。佛言。我先已说今亦复说。漏尽阿罗汉。不还生死不作九事。不故杀生不盗不淫不故妄语不饮酒不随爱嗔怖痴。是名九事。有外道。名沙陀。往到佛所问讯。在一面坐已白佛言。瞿昙。先在优楼频螺国尼连禅河边。在一迦和罗树下。得阿耨多罗三藐三菩提。不久我时彼处从瞿昙闻。漏尽阿罗汉。不还生死不作五事。不故杀生不盗不淫不故妄语不饮酒。我从瞿昙闻说是语。即便信受。佛言。我先已说今亦复说。漏尽阿罗汉。不还生死不作九事。不故杀生。不盗不淫。不故妄语。不饮酒。不来还。不起邪见。见常法。观生死无常。是名九事。有九恼。无利无益。恼我不安隐我。余如先说(九法竟)

    十法初

有十利。摄僧故。僧一心故。僧安乐行故。折伏高心故。不信者令得信故。已信者令增长故。惭愧者令得安乐故。遮今世恼漏故。断后世漏故。佛法久住故。是名十利。有十语。随修多罗语毗尼语阿毗昙语。和上语阿阇梨语。戒语衣语钵语食语药语。是名十语。有十愿。修多罗愿毗尼愿阿毗昙愿。和上愿阿阇梨愿。戒愿衣愿钵愿食愿药愿。是名十愿。有十羯磨。白羯磨。白二羯磨。白四羯磨。僧羯磨。闼赖吒比丘羯磨。戒羯磨。非法羯磨。如法羯磨。别众羯磨。和合众羯磨。是名十羯磨。有十治。苦切。依止。驱出。下意。不见摈。不作摈。恶邪不除摈。别住。摩那埵。本日治。是名十治。有十罚。苦切依止驱出下意。不见摈不作摈。恶邪不除摈。别住摩那埵本日治。是名十罚有十遮受戒法。杀父杀母。杀阿罗汉。出佛身血。本犯重罪。贼住比丘。本白衣。不能男。污比丘尼。越济人。是名十遮受戒法。有十难。王难贼难火难水难恶兽难龙难人难。非人难命难梵行难。是名十难。有十非毗尼。谓十不善业。有十毗尼。谓十善业。复有十非毗尼。谓十邪。有十毗尼。谓无学十真。有十无志。别住者。别住竟者。行摩那埵。行摩那埵竟。苦切依止。驱出下意。不见摈不作摈。是名十无志。有十非法遮说戒。非波罗夷。不出波罗夷事。不轻呵僧。不出轻呵僧事。不舍戒。不出舍戒事。随顺如法僧事。不破戒不破见不破威仪。不见不闻不疑。是名十非法遮说戒。何等十如法遮说戒。犯波罗夷。出波罗夷事。轻呵僧。出轻呵僧事。舍戒。出舍戒事。不随顺如法僧事。破戒破见破威仪。见闻疑。是名十如法遮说戒

尔时佛在婆伽那梨槃国。是中有一优婆塞。有信乐心。造一房舍。别施长老罗云。如先说。有十利故如来结戒。摄僧故。僧一心故。僧安乐住故。折伏高心故。不信者令信故。已信者令增长故。惭愧者得安隐住故。遮今世恼漏故。断后世漏故。佛法久住故。如来制戒制修多罗制毗尼制阿毗昙。诵修多罗诵毗尼诵阿毗昙。持修多罗持毗尼持阿毗昙。持修多罗者。持毗尼者。持阿毗昙者。摄修多罗。摄毗尼。摄阿毗昙。和上阿阇梨。共行弟子近行弟子沙弥。教威仪毗尼。说毗尼者。波罗提木叉。说波罗提木叉者。遮波罗提木叉。遮波罗提木叉者。受自恣。受自恣者。遮受自恣。遮受自恣者。与欲。与欲者受欲。受欲者持欲。持欲者说欲。说欲者取欲。取欲者与清净。与清净者受清净。受清净者持清净。持清净者说清净。说清净者取清净。取清净者与欲清净。与欲清净者受欲清净。受欲清净者持欲清净。持欲清净者说欲清净。说欲清净者取欲清净。取欲清净者与自恣。与自恣者受自恣。受自恣者持自恣。持自恣者说自恣。说自恣者取自恣。取自恣者依止。依止者与依止与依止者受依止。受依止者舍依止。舍依止者折伏驱出。同意悔过。受悔过者。白羯磨。白二羯磨。白四羯磨。苦切羯磨。依止羯磨。驱出羯磨。下意羯磨。不见摈不作摈。恶邪不除摈。别住摩那埵本日治。出罪觅罪相。举他令忆念共要羯磨。羁系羯磨。乞听羯磨。听白羯磨。不调伏者令调伏。皆以十利故(十法竟)

    增十一相初

有所犯事。应言白应言不白。答言。犯应言白。又犯。应言色应言非色。答言。犯应言色。又犯。应言可见不可见。答言。应言可见。又犯。应言根数非根数。答言。应言根数。又犯。应言有漏非漏。答言应言有漏又犯。应言。有为无为。答言。应言有为。又犯。应言世间出世间。答言。应言世间。又犯。应言阴摄非阴摄答言。应言阴摄。又犯。应言界摄非界摄。答言。应言界摄。又犯。应言受不受。答言。应言受。又犯。应言四大造。非四大造。答言。四大造。又犯。应言想非想。答言。应言想。又犯应言乱心非乱心。答言。应言乱心。又犯。应言染不染。答言。有染有不染。染者故犯。佛结戒。不染者不故犯戒。又犯。应言杂不杂。答言。应言杂。又犯应言有欲无欲。答言。有欲。又犯。应言有着无著。答言。有着。又犯。应言有对无对。答言。有对。又犯。应言心非心。答言。有心。又犯。应言有报无报。答言。有报。又犯。应言业非业。答言。业。又犯。应言外入内入。答言。内入。又犯。应言过去未来现在。答言。有过去未来现在。过去者。若所犯事已向他发露悔过。是名过去。未来者。未犯必当犯者。是名未来。现在者。现有所犯。是名现在。又犯。应言善不善无记。答言。不善无记。不善者故犯。佛结戒。是名不善。无记者。不故犯戒。是名无记。又犯。应言欲界色界无色界。答言。犯应言欲界。又犯。应言学无学。答言。非学非无学。又犯。应言见谛断思惟断答言。思惟断。颇有作是事犯即作是事非犯耶。佛言。有。若比丘不受迦絺那衣畜长衣。数数食。别众食。不白入聚落。不着僧伽梨入聚落。是名犯。若比丘受迦絺那衣畜长衣。数数食别众食。不白入聚落。不着僧伽梨入聚落。是名非犯。是名作是事犯即作是事非犯。有作羯磨者有犯。有作羯磨者非犯。云何作羯磨者有犯。作羯磨者非犯。若比丘。与比丘作不见摈不作摈恶邪不除摈。是比丘自见罪向他说。若界外与舍羯磨。即与共事共住教授。有余比丘作是言僧与是比丘不见摈不作摈恶邪不除摈。莫与是比丘共事共住教授。答言。是人见罪已与舍羯磨。问言。何处舍。答言。界外。又言。是不善舍。若比丘。与比丘不见摈不作摈恶邪不除摈。若自见罪向他说。界内与舍。共事共住教授。有比丘言。僧与是比丘不见摈不作摈恶邪不除摈。莫与是比丘共事共住教授。答言。是罪已舍。问言。何处舍。答言。界内。又言。善舍。如是作羯磨者有犯。如是作羯磨者非犯。有知犯有不知犯。知犯者。知五种犯体。是名知犯。不知犯者。不知五种犯体。是名不知犯。是人虽不知。亦名为犯。有自知犯有罪。有他知犯有罪。自知犯有罪者。若知五种犯体。是名自知犯有罪。他知犯有罪者。若可信优婆塞证知。是名他知犯有罪。有忆犯不忆犯。忆犯者。忆五种犯体。是名忆犯。不忆犯者。不忆五种犯体。是名不忆犯。有现前犯不现前。犯现前犯者。现有所犯。是名现前。犯不现前犯者。若未犯必当犯。是名不现前犯有犯事不共住。有犯事种种不共住。有种种不共住非不共住。若不见摈不作摈恶邪不除摈狂心乱心苦痛心。是名有犯事不共住有犯事种种不共住有种种不共住非不共住。有作羯磨不共住。有作羯磨种种不共住。有种种不共住非不共住。若不见摈不作摈恶邪不除摈狂心乱心苦痛心。是名作羯磨不共。住作羯磨种种不共住有种种不共住非不共住。有知不共住。有知种种不共住。有种种不共住非不共住。若不见摈不作摈恶邪不除摈狂心乱心苦痛心。是名有知不共住有知种种不共住有种种不共住非不共住。不知不共住。不知种种不共住。有种种不共住非不共住。若不见摈不作摈恶邪不除摈狂心乱心苦痛心。是名不知不共住不知种种不共住有种种不共住非不共住。有自说不共住。有自说种种不共住。有种种不共住非不共住。若不见摈不作摈恶邪不除摈狂心乱心苦痛心。是名自说不共住自说种种不共住有种种不共住非不共住。有他说不共住。有他说种种不共住。有种种不共住非不共住。若不见摈不作摈恶邪不除摈狂心乱心苦痛心。是名他说不共住他说种种不共住有种种不共住非不共住。有忆不共住。有忆种种不共住。有种种不共住非不共住。若不见摈不作摈恶邪不除摈狂心乱心苦痛心。是名有忆不共住有忆种种不共住。有种种不共住非不共住。有不忆不共住。有不忆种种不共住。有种种不共住非不共住。若不见摈不作摈恶邪不除摈狂心乱心苦痛心。是名不忆不共住不忆种种不共住有种种不共住非不共住。有现前不共住。有现前种种不共住。有种种不共住非不共住。若不见摈不作摈恶邪不除摈狂心乱心苦痛心。是名现前不共住现前种种不共住有种种不共住非不共住。有不现前不共住。有不现前种种不共住。有种种不共住非不共住。若不见摈不作摈恶邪不除摈狂心乱心苦痛心。是名不现前不共住不现前种种不共住有种种不共住非不共住。有犯。僧与作羯磨三人二人一人。云何有犯僧与作羯磨三人二人一人。若比丘。与比丘作不见摈不作摈恶邪不除摈狂心乱心苦痛心。犯是事。僧与作羯磨。即是事三人二人一人有知者。僧与作羯磨三人二人一人云何知僧与作羯磨三人二人一人。若比丘。与比丘作不见摈不作摈恶邪不除摈狂心乱心苦痛心。是名知者僧与作羯磨。即是事三人二人一人有不知者。僧与作羯磨三人二人一人。云何不知者僧与作羯磨三人二人一人。若比丘。与比丘不见摈不作摈恶邪不除摈狂心乱心苦痛心。是名不知者僧与作羯磨。即是事三人二人一人有自说。僧与作羯磨三人二人一人。云何自说僧与作羯磨三人二人一人。若比丘。与比丘作不见摈不作摈恶邪不除摈狂心乱心苦痛心。是名自说僧与作羯磨。即是事三人二人一人有不自说。僧与作羯磨三人二人一人。云何不自说僧与作羯磨三人二人一人。若比丘。与比丘不见摈不作摈恶邪不除摈狂心乱心苦痛心。是名不自说僧与作羯磨。即是事三人二人一人有忆者。僧与作羯磨三人二人一人。云何忆者僧与作羯磨三人二人一人。若比丘。与比丘作不见摈不作摈恶邪不除摈狂心乱心苦痛心。是名忆者僧与作羯磨。即是事三人二人一人有不忆。僧与作羯磨三人二人一人。云何不忆僧与作羯磨三人二人一人。若比丘。与比丘不见摈不作摈恶邪不除摈狂心乱心苦痛心。是名不忆者僧与作羯磨。即是事三人二人一人。有现前僧与作羯磨三人二人一人。云何现前僧与作羯磨三人二人一人。若比丘。与比丘不见摈不作摈恶邪不除摈狂心乱心苦痛心。是名现前僧与作羯磨。即是事三人二人一人。有不现前僧与作羯磨三人二人一人。云何不现前僧与作羯磨三人二人一人。若比丘。与比丘不见摈不作摈恶邪不除摈狂心乱心苦痛心。是名不现前僧与作羯磨即是事三人二人一人。有四调伏羯磨。苦切。依止。驱出。下意。颇有从是事。自说破僧。未受戒不应受。已受者应灭。即是事自说破僧。未受戒者与受。已受者不应灭邪。佛言。有。若非法非法想。作法见破僧。未受戒者不应受。已受者应灭。若法想破僧。未受戒者应受。已受者不应灭。颇有从是事。自言贼住比丘。未受戒者不应受。已受者应灭。即是事自言贼住比丘。未受戒者应受已受者不应灭耶。佛言。有。若再三听布萨。是人未受戒者不应受。已受者应灭。若一布萨或听或不听。未受者应受。已受者不应灭。颇有是事。污比丘尼。未受者不应受。已受者应灭。即是事污比丘尼。未受戒者应受。已受者不应灭耶。佛言。有。若以淫污比丘尼。未受戒者不应受。已受者应灭。若以身相触污比丘尼。未受应受。已受者不应灭。颇有是事。自言我杀父母。未受戒者不应受。已受者应灭。即是事自言我杀父母。未受者应受。已受者不应灭耶。佛言。有。若知是父母。无有异想不误杀。未受者不应受。已受者应灭。若不知有异想误杀父母。未受戒者应受。已受者不应灭

尔时长老优波离问佛言。世尊。颇有善心杀父母。得波罗夷并逆罪耶。不善心杀父母。无记心杀父母耶。佛语优波离。有善心杀父母得波罗夷并逆罪不善心杀无记心杀。云何善心杀。若母病受苦恼。杀令离苦。是名善心杀母得波罗夷并逆罪。云何不善心杀母。若为利杀。是名不善心杀母。得波罗夷并逆罪。云何无记心杀母。若作方便已。自眠时母死。是名无记心杀母。得波罗夷并逆罪。又问。颇有善心杀母。犯波罗夷是逆罪。有善心杀母。不犯波罗夷非逆罪耶。佛言。有善心杀母。犯波罗夷是逆罪。有善心杀母。非波罗夷非逆罪。云何善心杀母。犯波罗夷是逆罪。云何善心杀母。非波罗夷非逆罪耶。若母病受苦恼断其命。是名犯波罗夷是逆罪。若母病。与饭与粥与羹。食已命终。是名善心杀非波罗夷非逆罪。优波离。如是善心杀母。得波罗夷并逆罪。如是无波罗夷无逆罪。又问。颇不善心杀母。犯波罗夷是逆罪。不善心杀母。非波罗夷非逆罪耶。佛言。有不善心杀母。犯波罗夷是逆罪。有不善心杀母。非波罗夷非逆罪。云何不善心杀母。犯波罗夷逆罪。不善心杀母。非波罗夷非逆罪。若为利断母命。是名不善心杀母犯波罗夷并逆罪。若为杀畜生故施弶。母堕死者。非波罗夷非逆罪。优波离。是名不善心杀母犯波罗夷并逆罪。如是不善心杀母。非波罗夷非逆罪。又问。颇无记心杀母。犯波罗夷逆罪。无记心杀母。非波罗夷非逆罪耶。佛言。有无记心杀母。犯波罗夷并逆罪。有无记心杀母。不犯波罗夷不得逆罪。云何无记心杀母。犯波罗夷并逆罪。云何无记心杀母。不犯波罗夷非逆罪。若作方便欲杀母。自眠时母死。是名犯波罗夷是逆罪。若射壁树误射母杀。不犯波罗夷非逆罪。优波离。如是无记心杀母。犯波罗夷是逆罪。如是无记心杀母。不犯波罗夷非逆罪。优波离。杀父杀阿罗汉亦如是

颇有共事比丘。不入僧中亦不与欲。在界内作一切羯磨不犯耶。佛言。有。如来至真等正觉是。我先语目连。汝等从今日。自说波罗提木叉。我更不来说波罗提木叉。颇有比丘不听五种说戒得作布萨耶。佛言。有。若比丘独处布萨者是。如佛言未受大戒人前不应说戒。颇有未受大戒人前得说戒不犯耶。佛言有。我先说。除却波斯匿王眷属。独为王说。令心清净故。长老优波离问佛。为善心犯。为不善心犯。为无记心犯耶。佛言。有善心犯。有不善心犯有无记心犯。善心犯者。若新受戒比丘不知戒相。自手拔塔前草。自治经行处草。自采花。是名善心犯。不善心犯者。故犯佛结戒。是名不善心犯。无记心犯者。不故犯戒。长老优波离问佛。阿罗汉。为善心犯。为不善心犯。为无记心犯耶。佛言。优波离。若阿罗汉。有所犯者皆无记心。世尊。云何阿罗汉有所犯是无记心。佛言。若阿罗汉。心不忆有长衣。数数食。别众食。不白入聚落。不着僧伽梨入聚落。若睡时他持着高广床上。若睡时他。持着女人床上。若未睡时未受大戒人出房。睡眠时未受大戒人入房。觉已即悔过。优波离。是名阿罗汉所犯皆是无记心。若僧破是僧恼。若僧恼是僧破耶有僧破非僧恼。有僧恼非僧破。有僧破是僧恼。有非僧破非僧恼。僧破非僧恼者。若僧破不取不观十四破僧事。是名僧破非僧恼。僧恼非僧破者。若取观十四破僧事。而僧不破。是名僧恼非僧破。僧破僧恼者若。僧破取观十四破僧事。是名僧破僧恼。非僧破非僧恼者。除上事。有僧破非僧诤。有僧诤非僧破。有僧破亦僧诤。有非僧破非僧诤。僧破非僧诤者。若僧破。事不异。得施不异。界不异。是名僧破非僧诤。僧诤非僧破者。若僧事异。得施异。界异。而不破。是名僧诤非僧破。僧破僧诤者。若僧破。事异。得施异。界异是名僧破僧诤。非僧破非僧诤者。除上事。有僧破非僧别。有僧别非僧破。有僧破亦僧别。有非僧破非僧别。僧破非僧别者。若僧破。事不异。界不异。得施不异。是名僧破非僧别。僧别非僧破者。若僧事异界异得施异而不破。是名僧别非僧破。僧破僧别者。若僧破事异界异得施异。是名僧破僧别。非僧破非僧别者。除上事。若破僧是一劫寿。一劫寿是破僧耶。有破僧非一劫寿。一劫寿非破僧。有破僧是一劫寿。有非破僧非一劫寿。破僧非一劫寿者。若法想破僧。是名破僧非一劫寿。一劫寿非破僧者。伊罗龙王。摩那斯龙王。迦留伽罗龙王。难陀龙王。跋难陀龙王。迦毗罗龙王。阿摄波罗龙王。阎罗王。梵迦夷天。是名一劫寿非破僧。破僧是一劫寿者。如调达。是名破僧是一劫寿。非破僧非一劫寿者。除上事。若破僧是一劫报。一劫报是破僧耶。有破僧非一劫报。有一劫报非破僧。有破僧是一劫报。有非破僧非一劫报。破僧非一劫报者。若法想破僧。是名破僧非一劫报。一劫报非破僧者。如伊罗龙王摩那斯龙王迦留伽罗难陀跋难陀迦毗罗阿摄波罗阎罗王。是名一劫报非破僧。破僧是一劫报者。如调达是名破僧一劫报。非破僧非一劫报者。除上事。若破僧是邪见。邪见是破僧耶。有破僧非邪见。有邪见非破僧。破僧是邪见。有非破僧非邪见。破僧非邪见者。以法想破僧。是名破僧非邪见。邪见非破僧者。六师是。是名邪见非破。僧破僧是邪见者。调达是。非破僧非邪见者。除上事。若破僧是无明。无明是破僧耶。有破僧非无明。有无明非破。僧有破僧是无明。有非破僧非无明。破僧非无明者。以法想破僧。是破僧非无明。无明非破僧者。杀父母杀阿罗汉恶心出佛身血。是名无明非破僧。破僧是无明者。调达是。是名破僧是无明。非破僧非无明者。除上事。尔时长老优波离白佛言世尊。为比丘能起破僧事耶。为比丘尼式叉摩尼沙弥沙弥尼能起破僧事耶。佛言。比丘能起破僧事。非比丘尼式叉摩尼沙弥沙弥尼能起破僧事。又问。破僧犯何罪。佛言。犯偷兰遮。又问。破僧罪云何悔。佛言。偷兰遮悔。若受事者是不共住。不共住者。是受事耶。有受事非不共住。有不共住非受事。有不共住是受事。有非受事非不共住。受事非不共住者。受持五法不犯波罗夷。是名受事非不共住。不共住非受事者。于四波罗夷中。随有所犯不受五法。是名不共住非受事。受事是不共住者。受五法四波罗夷中随有所犯。是名受事是不共住。非受事非不共住者。除上事。有不共住。是种种不共住。有种种不共住。非不共住。谓不见摈不作摈恶邪不除摈狂心乱心苦痛心。若呵责是折伏。折伏亦是呵责。云何是羯磨。云何羯磨事。若犯是羯磨因。起事处亦是羯磨。悔过是羯磨事。云何是迦絺那衣。云何受迦絺那。云何舍迦絺那。佛语优波离。名字是迦絺那衣。能起九心。是受迦絺那。有八事。名舍迦絺那。有非比丘犯比丘得脱。有比丘犯非比丘得脱。非比丘犯比丘得脱者。若比丘尼。犯不同僧伽婆尸沙。转根作比丘。得灭是罪。是名非比丘犯比丘得脱。比丘犯非比丘得脱者。若比丘不同。犯僧伽婆尸沙。转根作比丘尼。得灭是罪。如是比丘灭。如是非比丘灭

有不知犯知悔过。有知犯不知悔过。不知犯知悔者。如睡比丘。他持着高床上。持着女人床上。未受大戒人出。时睡后还来入。觉已悔过。是名不知犯知悔。知犯不知悔者。若比丘犯僧伽婆尸沙。作出罪羯磨时。闻白已睡至羯磨竟。是名知犯不知悔。有睡犯觉悔。有觉犯睡悔睡犯觉悔者。若比丘睡时。他持着高床上女人床上。未受大戒人出。时睡后还来入是名睡犯觉悔。觉犯睡悔者。若比丘犯僧伽婆尸沙。作出罪羯磨时。闻白已睡。是名觉犯睡悔。颇有比丘说一方便犯三波罗夷耶。佛言。有。若比丘。与比丘共要言。汝见我偷某甲重物。断某甲人命。知我得阿罗汉。是名说一方便犯三波罗夷。颇有比丘尼说一方便犯四波罗夷耶。佛言。有。若比丘尼。与比丘尼共作要言。汝见我取某甲重物。见我断某甲人命。知我助不见摈比丘。知我得阿罗汉。是名说一方便犯四波罗夷。颇有比丘在一处坐犯五种戒体耶。佛言。有。若落饭食犯突吉罗。学家中自手取食。犯波罗提提舍尼。无净人为女人说法。过五六语。犯波逸提。向女人说恶语。犯僧伽婆尸沙。说得过人法。犯波罗夷。颇有比丘以一方便犯百千罪若过是耶。佛言。有。若比丘在大众中坐。以一把小豆一把大豆一把沙。散大众上。随粒堕他上。犯尔所罪。颇有比丘盗心取他重物不犯波罗夷耶。佛言。有。若衣钵在地拽去未离本处。犯偷兰遮。颇有盗三钱犯波罗夷耶。佛言。有。钱贵时。颇有盗五钱不犯波罗夷耶。佛言。有。钱贱时。颇有少取犯少取不犯耶。佛言。有。若少取黑羊毛不犯。少取下。羊毛犯。颇有多取犯多取不犯耶。佛言。有。若多取黑羊毛过量者犯。多取下羊毛不犯。颇如量作衣有犯不犯耶。佛言。有。如佛衣量作衣者犯。自如量作者不犯。颇染衣有犯染衣不犯耶。佛言。有。若比丘得新衣。不以三种染有犯。以三种染不犯。颇从是事未入初禅。犯僧伽婆尸沙。即是事入初禅。犯僧伽婆尸沙耶。佛言。有。若比丘。使比丘作房舍。语已入初禅。入已他与成房舍。犯僧伽婆尸沙。颇有从是事未入第二第三第四禅犯僧伽婆尸沙。即是事乃至入第四禅有犯耶。佛言。有。若比丘。使比丘作房舍。语已乃至入第四禅。入已他与成房舍。犯僧伽婆尸沙。颇有比丘尼无所犯乃至突吉罗非比丘尼耶。佛言。有。转根者是。颇有比丘无所犯乃至众学法非比丘耶。佛言。有。转根者是。颇有比丘独入房犯四波罗夷耶。佛言。有。如优波离中说。颇有比丘在房中衣边破安居失衣自违言耶。佛言。有。如先说。颇有比丘断比丘命非父非阿罗汉犯波罗夷是逆罪耶。佛言。有。若母出家受戒转根者是。颇有比丘尼断比丘尼命非母非阿罗汉犯波罗夷是逆罪耶。佛言。有。若父出家受戒转根者是。颇有比丘尼因他说犯波罗夷耶。佛言。有。若比丘尼。随顺被摈比丘。三谏不止者是。颇有比丘因他说犯僧伽婆尸沙耶。佛言。有。若比丘欲破僧。随顺破僧污他家戾语。三谏不止者是。颇有比丘因他说犯波逸提耶。佛言。有。若比丘恶见。三谏不止者是。颇有因他说犯波罗提提舍尼耶。佛言。有。若比丘尼在白衣家。指示与比丘食。不呵而食者是。颇有因他说犯突吉罗耶。佛言。有。若比丘说戒中三问清净时。不向他发露者是。如佛说。比丘尼若舍戒。更不得受戒。颇有比丘尼舍戒更与受戒不犯耶。佛言。有。若比丘尼舍戒已。转根作男子。与受戒者不犯。颇有身口无犯非比丘尼耶。佛言。有。若比丘尼。覆藏比丘尼重罪。乃至地了。犯波罗夷。颇有比丘犯四种罪不悔不发露不犯耶。佛言。有。转根者是。颇有比丘尼。犯五种罪。不悔过不发露不犯耶。佛言。有。转根者是。颇有比丘断人命不犯波罗夷耶。佛言。有。误杀者是。颇有比丘尼行淫彼犯罪耶。佛言。有。若比丘尼。见彼比丘尼行淫。覆藏乃至地了者是。又问。颇从是事犯波罗夷。即是事犯僧伽婆尸沙耶。佛言。有。若比丘尼犯身相触。是波罗夷。若比丘犯身相触。是僧伽婆尸沙。又问。颇有从是事犯波罗夷即是事犯波逸提耶。佛言。有。比丘尼见比丘尼恶罪。覆藏一夜犯波罗夷。比丘覆藏犯波逸提。颇有从是事犯波罗夷。即是事犯突吉罗耶。佛言。有。比丘尼随顺被摈比丘。三谏不止。犯波罗夷。比丘随顺犯突吉罗。颇有从是事犯僧伽婆尸沙。即是事犯波罗夷耶。佛言。有。比丘犯身相触。是僧伽婆尸沙。比丘尼身相触。是波罗夷。颇有从是事犯僧伽婆尸沙。即是事犯波逸提耶。佛言。有。比丘故出精。僧伽婆尸沙。比丘尼故出精。波逸提。颇有从是事犯波逸提。即是事犯僧伽婆尸沙耶。佛言。有。比丘尼故出精。波逸提。比丘故出精。僧伽婆尸沙。颇有从是事犯波逸提。即是事犯波罗提提舍尼耶。佛言。有。比丘索美食。波逸提。比丘尼索美食。波罗提提舍尼。颇有从是事犯波逸提。即是事犯突吉罗耶。佛言。有。比丘尼生草菜上大小便。波逸提。比丘突吉罗。颇有从是事犯波罗提提舍尼。即是事犯波逸提耶。佛言。有。若比丘尼索美食。波罗提提舍尼。比丘波逸提。颇有从是事犯波罗提提舍尼。即是事犯突吉罗耶。佛言。有。比丘学家中自手取食。波罗提提舍尼。比丘尼突吉罗。颇有从是事犯突吉罗。即是事犯波逸提耶。佛言。有。比丘生草菜上大小便。突吉罗。比丘尼波逸提。颇有从是事犯突吉罗。即是事犯波罗提提舍尼耶。佛言。有。若比丘尼学家中自手取食。突吉罗。比丘波罗提提舍尼。颇有从是事犯无残。即是事犯有残耶。佛言。有。比丘尼犯不同四波罗夷者是无残。比丘是有残。颇有从是事犯波罗夷。即是事不犯波罗夷耶。佛言。有。若比丘尼身触男子者。犯波罗夷。比丘身相触女人者。非波罗夷。比丘尼覆藏他犯。是波罗夷。比丘覆藏他犯。非波罗夷。比丘尼随顺被摈比丘犯波罗夷。比丘随顺。非波罗夷。颇有从是事犯僧伽婆尸沙。即是事不犯耶。佛言。有。若比丘犯身相触。是僧伽婆尸沙。比丘尼非僧伽婆尸沙。比丘故出精。犯僧伽婆尸沙。比丘尼故出精。非僧伽婆尸沙。比丘尼恃势言人。犯僧伽婆尸沙。比丘恃势言人。非僧伽婆尸沙颇有从是事犯波逸提。即是事不犯波逸提。若比丘尼故出精。犯波逸提。比丘故出精。非波逸提。比丘索美食。犯波逸提。比丘尼索美食。非波逸提。比丘尼生草上大小便。犯波逸提。比丘生草上大小便。非波逸提。颇有从是事犯波罗提提舍尼。即是事不犯波罗提提舍尼耶。佛言。有。若比丘学家中自手取食。犯波罗提提舍尼。比丘尼非波罗提提舍尼。比丘尼自索美食。犯波罗提提舍尼。比丘自索美食。非波罗提提舍尼。颇有是事犯突吉罗。即是事不犯突吉罗耶。佛言。有。若比丘生草菜上大小便。犯突吉罗。比丘尼生草菜上大小便。非突吉罗。颇有得脱时犯犯时得脱耶。佛言。有。若比丘犯僧伽婆尸沙。作出罪羯磨时。着革屣。覆两肩。襆头。杀草木。指画地。是名得脱时犯。犯时得脱者。若比丘污他家时转根。是名犯时得脱。颇有舍有结耶。佛言。有。若舍界时结聚落界。若去者为何所去。佛言界。尔时长老优波离问佛。若论毗尼时从何处求。佛言。应从比丘比丘尼戒中求。七法八法增一中求。同不同中求若无根可转。不入佛法不取灭。终不取灭。为是谁耶。佛言。化人是若杀化人得何罪。佛言。得偷兰遮。应以何悔过。佛言。作偷兰遮悔过

十诵律卷第五十一十诵律卷第五十二(第九诵之一)

        后秦北印度三藏弗若多罗译

    比丘中优波离问部问淫第一

佛在毗耶离国。长老优波离。往诣佛所头面礼足。于一面坐。问佛言。若比丘咒术自作畜生形行淫。得波罗夷不。佛言。若自忆念我是比丘。得波罗夷。若不忆念偷兰遮。又问。若二比丘咒术。俱作畜生形共行淫得波罗夷不。佛言。若自忆念我是比丘。得波罗夷。若不忆念得偷兰遮。又问。如佛所说。与非人女行淫。得波罗夷。云何是非人女。答可得捉者是。又问。口中行淫齐何处得波罗夷。答节过齿得波罗夷。又问。女人身作两段。比丘还续行淫。得波罗夷不。答言。得。又问。女人头断口中行淫。得波罗夷不。答言。得。又问。女人头断于大小便道行淫。得波罗夷不。答言。得。又问。余身分处作孔于中行淫。得波罗夷不。答言。不得。得偷兰遮。若出精。得僧伽婆尸沙。又问。若齿外唇里行淫。得何罪。答得偷兰遮。若出精。得僧伽婆尸沙。又问。如佛所说。三道中行淫得波罗夷。颇有比丘三道中行淫不得波罗夷耶。答言。若不触四边若屈。得偷兰遮。若出精。得僧伽婆尸沙。又问。如佛所说。女人命终形体不坏行淫得波罗夷。云何名形坏。答。若女根烂若堕若干若虫啮。是处行淫不得波罗夷。得偷兰遮。若出精。得僧伽婆尸沙。又问。云何命终形体不坏。答。若女根不烂不堕不干不虫啮。是中行淫得波罗夷。又问。如佛所说。若死女人身体不坏共行淫得波罗夷。云何死女人身坏。答。若女根烂若堕若干若胀若虫啮。是中行淫不得波罗夷。得偷兰遮。若出精。僧伽婆尸沙。又问。云何死女人名不坏。答。若女根不烂不堕不干不胀不虫啮。是中行淫得波罗夷。又问。若于热猪肉中行淫。得波罗夷不。答不得。得偷兰遮。若出精。僧伽婆尸沙。又问。有比丘独入空舍。得波罗夷不。答言有。如蓝婆那比丘弱脊比丘是。又问。若女人身破裂。比丘还合共行淫。得波罗夷不。答不得波罗夷。得偷兰遮。若出精。僧伽婆尸沙。又问。如佛所说。若比丘裹男根于三道中行淫。得波罗夷。颇有裹而入不得波罗夷耶。答曰。有。以厚衣厚皮厚木皮若竹[竺-二+韋]叶裹。如是行淫不得波罗夷。得偷兰遮。若出精。得僧伽婆尸沙。又问。颇有比丘行淫不得波罗夷耶。答有。若先破戒。若贼住。若先来白衣。又问。颇有不受具戒人行淫得波罗夷耶。答有。与学沙弥是也

    问盗事第二

佛在王舍城。优波离问佛。若比丘于二部众。各八十人。身在众数中。若口语若取筹。得何罪。佛言。得偷兰遮。若言我在数中故妄语。得波逸提。云何得波罗夷。答。若物从他手入己手。得波罗夷。又问。有比丘。非钱非衣物不覆藏取。以盗心移置异处。得波罗夷不。答得。若樗蒲以盗心转齿是。又问。若比丘到贼所语贼言。去来我知物处而实不知。得何罪。答故妄语。得波夜提。知贼不能得彼物不应说故。得突吉罗。若示是物得五钱。若直五钱物入手中。得波罗夷。又问。若比丘过关逻应输税物而不输。得何罪。答得波罗夷。若估客语比丘。与我过是物。比丘与过。若税物直五钱以上。得波罗夷。若估客到关逻。语比丘言。与我过是物税直当与比丘半。比丘若过是物税直乃至五钱。若直五钱得波罗夷。若估客到关。语比丘言。与我过是物。税直尽与汝。比丘若过是税物乃至五钱。若直五钱得波罗夷。若估客到关。应输税物。比丘示异道令过。断官税物。是税物乃至五钱。若直五钱得波罗夷。若估客应输税物未到关。比丘示异道令过。是税物乃至五钱。若直五钱。断官税物故。得偷兰遮。又问。颇有比丘过关应输税物乃至五钱若直五钱不得波罗夷罪耶。答曰。有。若余人着衣囊中若针筒中。是比丘不知无罪。若持物飞过无罪。难数物持过偷兰遮。不可数物持过波罗夷。非关处过偷兰遮。关处过波罗夷。又问。有六种取他物。苦切取。轻慢取。以他名字取。抵突取。受寄取。出息取。是六种取中。何等取得波罗夷。答。除出息取。余取得波罗夷。若具足取得波罗夷。不具足取偷兰遮。又问。若盗佛舍利得何罪。答曰。偷兰遮。若尊敬心作是念。佛亦我师。清净心取无罪。又问。若盗经卷得何罪。答曰。随计价直犯。若不直五钱偷兰遮。又问。若盗塔寺精舍中供养具。得波罗夷不。答。是物若有守护。随计直犯。若不直五钱偷兰遮。又问。常入出檀越家比丘语妇言。汝夫与我尔所物。得何罪。答。若诈称夫语。故妄语得波夜提。若得物直五钱已上入手。得波罗夷。若减五钱偷兰遮。又问。若闇处有衣。四比丘以盗心俱取。得波罗夷不。佛言。不得。得偷兰遮。若分割取直五钱已上。得波罗夷。若不直五钱得偷兰遮。若橛上有衣物。以盗心取离本处。得波罗夷。若选择时得偷兰遮。若选择已取。乃至五钱若直五钱物。得波罗夷。若并橛持去。得偷兰遮。问何时得波罗夷。答若离橛时得波罗夷。若衣物在架上。比丘盗心取离本处。得波罗夷。若选择时得偷兰遮。选择已乃至取五钱若直五钱物。得波罗夷。若并架持去得偷兰遮。问何时得波罗夷。答若离架时得波罗夷。若比丘语余比丘言。汝知某甲居士有重物不。比丘言。知。是比丘语言。汝盗取来。彼比丘随教取离本处。得波罗夷。若不随教取者偷兰遮。取者得波罗夷。问颇有比丘取不具足物得波罗夷耶。答有。若取不具足物价直五钱。得波罗夷。又问。颇有比丘重物以盗心处处移转不犯波罗夷耶。答有。若比丘。持和上阿阇梨衣囊。移上着下移下着上。一一重物以盗心。若疑惑是耶非耶。若取是者波罗夷。是彼所有耶。非彼所有耶。若取是彼所有。波罗夷。又问。如佛所说。若比丘盗心取他物。乃至五钱若直五钱物。得波罗夷。云何是五钱。答若一铜钱直十六小铜钱者是。未受具戒人盗心取是物。未受具戒人离本处。得突吉罗。未受具戒人盗心取是物。受具戒时离本处。得突吉罗。未受具戒人盗心取是物。受具戒人离本处。得波罗夷。受具戒时盗心取是物。受具戒时离本处。得突吉罗。受具戒时盗心取是物。受戒竟离本处。得波罗夷。受具戒人盗心取是物。受具戒人离本处。得波罗夷。受具戒人盗心取是物。非具戒人离本处。得偷兰遮。问如佛所说。有二种盗取地。一相言取。二摽相取。若相言得胜取。得波罗夷。不胜取得偷兰遮。若不胜已更作相。若所得地乃至直五钱。得波罗夷。房舍亦如是。若比丘摇树落果。若一时堕。随计直犯。问。若比丘取拘耶尼人物。齐几许得波罗夷。答计彼物价直五钱已上。得波罗夷。弗于逮亦如是。问。若取郁单越物。齐几许得波罗夷。答。彼国人无我无所属故无罪。问。若比丘取铁器铜器。随计价直犯。问。颇比丘盗三钱得波罗夷耶。答曰。得。若钱贵时是。问。颇比丘盗五钱不犯波罗夷耶。答有。若钱贱时是。若比丘先以盗。心斫衣架。后生自心得偷兰遮。若先以自心斫衣架。后生盗心得波罗夷。又问。若比丘破谷仓取谷。云何得罪。答。随时取随计直犯。问颇有比丘取多物不犯波罗夷耶。答有。若取众未分物是。若盗木器。应随计直犯。问。颇有比丘盗金鬘不犯波罗夷耶。答有。取非人金鬘是。又复若金鬘不直五钱亦是。若比丘盗水。应随计直犯。若决渠盗水。应随计直犯。问。颇比丘持戒清净畏罪不与取千钱不得波罗夷耶。答有。若生己物想。若同意取。若暂取用。若知是物无所属。若狂若心乱。若病荒错无罪。若居士有千钱在一处。比丘以盗心方便取。居士言。是我物持与汝。比丘闻是语已若取。得偷兰遮。问。颇比丘取五钱离本处不犯波罗夷耶。答有。若一时取一钱离本处。若二若三若四。不一时取五钱。不犯

有比丘。盗心取他物。自心覆藏。得偷兰遮。自心取他物。他心覆藏。得波罗夷。又问。若诸人有五宝若似五宝。藏在地中。若比丘。以咒术力若药草力。若破坏若变色。破他利故得何罪。答得偷兰遮。若比丘。檀越请僧食。次未至。自言我应去。故妄语得波夜提。若遣使若与信若遣疏。得突吉罗。若是食。随计直犯。又问。若比丘取他不中用钱。得何罪。答是钱应随计价直犯。问颇比丘移他重物离本处不得波罗夷耶。答有。他人若衣钵若衣物在地。曳去不出界。得偷兰遮。若居士衣在比丘所。比丘盗心方便。作相言是我衣。故妄语得波夜提。作方便居士来语比丘言。此是我衣。汝欲得者当相与。知居士舍已取得偷兰遮。若比丘治铜作金色过关。得偷兰遮。若问更有物不。实有物而言无。故妄语得波夜提。若比丘贷他物。抵言不贷。故妄语得波夜提。若先用尽后断当断当已。得波罗夷。若先断当后离本处。离本处时得波罗夷。若比丘受他寄物。若主问。抵言不受。故妄语得波夜提。若先用尽后断当断当已。得波罗夷。若先断当后离本处。离本处时得波罗夷。若比丘取钱直。应计是钱若取似钱。亦应随计直犯。问颇比丘取多物不得波罗夷耶。答有。物虽多不直五钱是未受具戒作盗方便。未受具戒人离本处。得突吉罗。未受具戒人作盗方便。受具戒时离本处。得突吉罗。未受具戒人作盗方便。受具戒人离本处。得波罗夷。受具戒时作盗方便。受具戒时离本处。得突吉罗。受具戒时作盗方便。受具戒已离本处。得波罗夷。受具戒人作盗方便。受具戒人离本处。得波罗夷。受具戒人作盗方便。非具戒人离本处。得偷兰遮。若诸人有象马牛羊驴骡骆驼。如是等畜生利益人民。若比丘快心故。若截其足。若坏余身分。若放令去。得偷兰遮。若诸人有象马牛羊驴骡骆驼。如是等畜生利益人民。比丘快心故。解放令去。得偷兰遮。若比丘为盗方便。变形作比丘尼。比丘尼离本处。得波罗夷。若比丘尼为盗方便。变形作比丘。比丘离本处。得波罗夷。问颇比丘盗他重物不得波罗夷耶。答有。先破戒若贼住若先来白衣是。问颇有不受具戒人盗他重物得波罗夷耶。答有。与学沙弥是

    问杀事第三

优波离问佛。若比丘以咒术。变身作畜生形。夺人命。得波罗夷不。答若自忆念我是比丘。得波罗夷。若不忆念偷兰遮。问颇有比丘杀母得大福不得罪耶。答有。爱名为母。若杀得大福。不得罪也。问颇有比丘杀父得大福不得罪耶。答有。漏名为父。杀得大福不得罪也。问若比丘作方便欲杀母而杀非母。得波罗夷并逆罪耶。答不得。得偷兰遮。问若比丘作方便。欲杀非母。而自杀母。得波罗夷并逆罪耶。答不得。得偷兰遮。若比丘作方便。欲杀人而杀非人。得偷兰遮。若比丘作方便。欲杀非人而杀人。得突吉罗。问若比丘作方便。欲杀阿罗汉。而杀非阿罗汉。得波罗夷并逆罪耶。答不得。得偷兰遮。问若比丘作方便。欲杀非阿罗汉。而杀阿罗汉。得波罗夷并逆罪耶。答不得。得偷兰遮。问若比丘实是阿罗汉比丘。谓非罗汉生恶心杀。得波罗夷并逆罪耶。答得波罗夷。亦得逆罪。问若比丘实非阿罗汉比丘。谓是阿罗汉。生恶心杀。得波罗夷并逆罪耶。答得波罗夷。不得逆罪。问有一女人弃加罗逻。一女人还取用。后生子。何者是母。答先者是也。问比丘杀何母。得波罗夷并逆罪耶。答杀先母得波罗夷并逆罪。问若是子欲出家应问何母。答应问后者。问颇比丘堕人胎不犯波罗夷耶。答有。若人怀畜生是。问颇比丘堕畜生胎犯波罗夷耶。答有。若畜生怀人是。问若比丘欲杀父母。方便作杀因缘。作已自投深坑。得波罗夷并逆罪耶。答父母先死比丘后死。得波罗夷并逆罪。若比丘先死父母后死。得偷兰遮问颇比丘欲杀父母。方便作杀因缘。作已持刀自杀。得波罗夷并逆罪耶。答若父母先死比丘后死。得波罗夷并逆罪。若比丘先死父母后死。得偷兰遮。问颇比丘杀父母不得波罗夷并逆罪耶。答有。若比丘病。父母来问讯。比丘经行倒父母上。父母若死。比丘无罪。又复比丘病。父母扶将归家。比丘蹴蹶倒父母上。父母若死。比丘无罪。若比丘欲杀父母。心生疑。是父母非。若心定。知是父母杀。得波罗夷并逆罪。若生疑。是人非人。若心定。知是人杀。得波罗夷。若人捉贼欲将杀。贼得走去。若以官力。若聚落力。追逐是贼。比丘逆道来。追者问比丘言。汝见贼不。是比丘。先于贼有恶心嗔恨心。语言。我见在是处。以是因缘令贼失命。比丘得波罗夷。若人将众多贼欲杀。是贼得走去。若以官力若聚落力追逐。是比丘逆道来。追者问比丘言。汝见贼不。是贼中或一人。是比丘所嗔恨者。比丘言。我见在是处。若得杀。非所嗔者偷兰遮问。若比丘作非母想杀母。得波罗夷并逆罪耶。答得波罗夷并逆罪。问比丘作母想杀非母。得波罗夷并逆罪耶。答得波罗夷。不得逆罪。问若比丘非人想恶心杀人。得波罗夷不。答得波罗夷。问若比丘作人想恶心杀非人。得波罗夷不。答不得。得偷兰遮。问颇比丘夺人命不得波罗夷耶。答有。自杀身无罪。若比丘戏笑打他。若死得突吉罗。未受具戒人作杀人方便。未受具戒人夺命。得突吉罗。未受具戒人作杀人方便。受具戒时夺命。得突吉罗。未受具戒人作杀人方便。受具戒人夺命。得波罗夷。受具戒时作杀人方便。受具戒时夺命。得突吉罗。受具戒时作杀人方便。受具戒已夺命。得波罗夷。受具戒人作杀人方便。受具戒人夺命。得波罗夷。受具戒人作杀人方便。非具戒人夺命。得偷兰遮。问颇比丘杀人不得波罗夷耶。答有。若先破戒若贼住若先来白衣是。问颇有不受具戒人杀人得波罗夷耶。答有。与学沙弥是也

    问妄语事第四

优波离问佛言。世尊。大妄语边。云何得轻重罪。答比丘言我退失须陀洹斯陀含阿那含果阿罗汉果。未得言失。得偷兰遮。若言我得果。得波罗夷。问若比丘言。我得须陀洹斯陀含阿那含阿罗汉果。有人急问。便言我非。得何罪。答得偷兰遮。问若比丘言。我退失阿罗汉果阿那含果。得何罪。答若不得而言退失。得偷兰遮。若自言我有下果失上果。得波罗夷。问比丘言我是学人。有人急问。云何学人。比丘答言。我多闻利根读诵通利。若坐禅无胜我者。比丘法应学一切善法。是故我是学人。得何罪。答得偷兰遮。若言我得无漏学法故名学人。得波罗夷。问若比丘言。我是无学人。有人急问。云何无学。比丘答言。我不复学。多闻利根读诵通利及坐禅。是故我是无学人。得何罪。答得偷兰遮。若言我不复学无漏法。是故名无学人。得波罗夷。问若比丘言我无所有。若人急问。云何无所有。比丘言。我无衣钵。无户钩。无时无时分。无七日无尽形药。是故名无所有。得何罪。答得偷兰遮。若言我无贪欲嗔恚愚痴。是故名无所有。得波罗夷。问若比丘言。我是末后身。有人急问。云何名末后身。比丘言。我于过去无数生死身。此为末后身。是故言末后身。得何罪。答得偷兰遮。若言我身。分尽更不受后身。是故名末后身。得波罗夷。问若比丘语比丘言。汝当称我为须陀洹斯陀含阿那含阿罗汉。若问已便言。我非须陀洹斯陀含阿那含阿罗汉。得何罪。答得偷兰遮。若人问一比丘言。谁道汝是须陀洹斯陀含阿那含阿罗汉。比丘言。谁作是语。我非须陀洹斯陀含阿那含阿罗汉。得何罪。答得偷兰遮。问若比丘言。我耆阇崛山中须陀洹果。毗婆罗婆山中斯陀含果。萨婆娑罗颇罗山中阿那含果。萨钵那求呵山中阿罗汉果。若问汝何因缘说耆阇崛山中须陀洹果。比丘便言。我在耆阇崛山中。读诵思惟精进。求觅须陀洹果。作如是语。得何罪。答得偷兰遮。乃至阿罗汉果亦如是。若言我在耆阇崛山中得须陀洹果。乃至萨钵那求呵山中得阿罗汉果。作如是语。得波罗夷。问若他问比丘言。汝得果不。比丘尔时手中有庵婆果瞻婆果婆罗头果紧头果那梨罗果。因是故言我得果。作如是语。应得何罪。答得偷兰遮。问若比丘言。某甲檀越舍入出比丘。是须陀洹斯陀含阿那含阿罗汉。若问何者是。答言我是。我亦非须陀洹斯陀含阿那含阿罗汉。作如是语。应得何罪。答得偷兰遮。问若比丘言。某甲檀越舍入坐受水饮食已随意而出。是须陀洹斯陀含阿那含阿罗汉。若问谁是。答言我是。我非须陀洹斯陀含阿那含阿罗汉。作如是语。应得何罪。答得偷兰遮。问若比丘言。某甲檀越舍敷庄严坐处。若得须陀洹斯陀含阿那含阿罗汉。是人得坐是座。我次得坐是座。我亦非须陀洹斯陀含阿那含阿罗汉。作如是语。应得何罪。答得偷兰遮。问若人问比丘言。汝衣被饮食卧具汤药资生之具。从何处得。比丘言。某甲檀越舍其有此物。檀越言。若得须陀洹斯陀含阿那含阿罗汉者。便取是物。我取是物。我亦非须陀洹斯陀含阿那含阿罗汉。作如是语。应得何罪。答得偷兰遮。问若比丘言。我无不活畏。无恶名畏。无死畏。无恶趣畏。无大众畏。若言我不畏是五畏。应得何罪。答得偷兰遮。若言我断是五畏。得波罗夷。问若比丘言。我尽结使欲缚盖缠。若问言云何尽。若言我过去结使欲缚盖缠败坏尽。应得何罪。答得偷兰遮。若言断结使欲缚盖缠尽。得波罗夷。问若比丘言。圣弟子所应得。我得是事。若人问言。汝得何物。若言。我得读诵通利问难。若坐禅精进不怠故。名我得是事。应得何罪。答得偷兰遮。若说得圣弟子法。得波罗夷。问若比丘说。我修习五根五力七觉意。若人问言。云何修习。便言。我读诵通利问难坐禅修集。不怠故名修习。应得何罪。答得偷兰遮。若言我得五根五力七觉意。得波罗夷。问颇有比丘虚妄说圣法不得波罗夷耶。答曰。有。比丘欲说须陀洹果。误说斯陀含果。欲说斯陀含果。误说阿那含果。欲说阿那含果。误说阿罗汉果是。问比丘若言。我今日不入世间禅定。若人问言。昨日云何。若言昨日亦不入。作如是语。应得何罪。答得偷兰遮。若说禅法。得波罗夷。问若比丘言我是大师。若人问言。云何大师。若言。我为人说法教化作大师事故名大师。应得何罪。答得偷兰遮。若说大师法。得波罗夷。问若比丘言。我是佛。若人问言。云何名佛。若言。我觉三不善根十不善道。不应作故名为佛。应得何罪。答得偷兰遮。若说佛法。得波罗夷。问若比丘言。我是毗婆尸佛弟子。若人问言。云何毗婆尸佛弟子。便言。若人归命释迦文佛。是人亦归命毗婆尸佛尸弃佛维叶佛拘留孙佛拘那含牟尼佛迦叶佛。如是等一切诸佛。作如是语。应得何罪。答得偷兰遮。若说宿命神通。得波罗夷。问若比丘言。我喜须陀洹斯陀含阿那含阿罗汉果。若人问言。汝得是道耶。答我不得须陀洹斯陀含阿那含阿罗汉果。作如是语。应得何罪。答得偷兰遮。问若人问比丘言。汝得果耶。尔时比丘手中。有庵罗果波那萨果阎浮果那利耆陀果。因是故说得果。应得何罪。答得偷兰遮。若说果事。波罗夷。问若比丘自作书言。我是须陀洹斯陀含阿那含阿罗汉果。作如是语已语比丘言。此书说我得果。我非须陀洹斯陀含阿那含阿罗汉果。作如是语者。应得何罪。答得偷兰遮。问颇比丘虚妄。说我得圣法。不得波罗夷耶。答有。若先破戒若贼住先来白衣是。问颇有不受具戒虚妄说我得圣法得波罗夷耶。答有。与学沙弥是。问颇一比丘独入空房。一时得四波罗夷耶。答曰。有。淫欲者如蓝婆罗。及弱脊盗者。先作盗方便已入舍。杀者亦先作杀因缘已入舍。妄语者自唱言阿罗汉。在此房中是也(四事竟)

    问十三事

佛在舍卫国。优波离问佛言。世尊。如佛所说。故出精得僧伽婆尸沙。若比丘睡眠中弄觉已出精。得何罪。佛言。若觉已不动无罪。若动得偷兰遮。若觉时弄唾眠已出。得偷兰遮若比丘捉疮奈疮故弄出精。得僧伽婆尸沙。若比丘捉疮奈疮欲出精。心还悔休。得偷兰遮。若比丘捉疮奈疮欲受细滑。心还悔休。得偷兰遮。未受具戒人弄。未受具戒出精。得突吉罗。未受具戒人弄。受具戒时出。得突吉罗。未受具戒人弄。受具戒人出。得僧伽婆尸沙。受具戒时弄。受具戒时出。得突吉罗。受具戒时弄。受具戒已出。得僧伽婆尸沙。受具戒人弄。受具戒人出。得僧伽婆尸沙。受具戒人弄。非具戒人出。得偷兰遮。问若比丘作僧伽婆尸沙罪。不忆日月。应从何日来治。答从受具戒来治。问齐何名出精。答从疮出。问颇非比丘作罪比丘得脱耶。颇比丘作罪非比丘得脱耶。颇是人作罪即是人得脱耶。答有。非比丘作罪比丘得脱者。若比丘尼。得不共比丘僧伽婆尸沙罪。是比丘尼转根作比丘。即时得脱。是名非比丘作罪比丘得脱。比丘作罪非比丘得脱者。若比丘。得不共比丘尼僧伽婆尸沙罪。是比丘转根作比丘尼。即时得脱。是名比丘作罪。非比丘得脱。是人作罪即是人得脱者。若比丘作僧伽婆尸沙。如法治灭。若比丘尼作僧伽婆尸沙。如法治灭。是名是人作罪即是人得脱。诸比丘眠中弄觉已出。若觉已不动无罪。若动得偷兰遮。问颇比丘故。出精不得僧伽婆尸沙耶。答有。若未结戒作是。四人本白衣弄。一比丘出精。是比丘得偷兰遮。问颇比丘故出精不得僧伽婆尸沙耶。答有。若先破戒若贼住是。问颇不受具戒人故出精得僧伽婆尸沙耶。答曰有。与学沙弥是也。问如佛所说。摩触女人身得僧伽婆尸沙。颇比丘摩触女人身。不得僧伽婆尸沙耶。答。有。若女人身根坏。比丘摩触。得偷兰遮。若比丘身根坏摩触女人。得偷兰遮。若比丘与女人期。疑是不是。若是摩触。得僧伽婆尸沙。疑是人非人。若是人女摩触。得僧伽婆尸沙。若比丘。以爪以齿以毛以疮以无肉骨。摩触女人身。得偷兰遮。若比丘。以身摩触女人爪齿毛疮无皮骨。偷兰遮。若比丘爱一女人。而摩触余女人身。得偷兰遮。若摩触二根女人身。得偷兰遮。若摩触不能女人身。得偷兰遮。若比丘不能男摩触女人身。得偷兰遮。若比丘摩触男子身。得偷兰遮。若比丘摩触女人身。是女人即时转根作男子。比丘摩触男子。得偷兰遮。若比丘摩触女人身。比丘转根作比丘尼。比丘尼摩触女人身。得偷兰遮。若比丘摩触男子身。是男子转根作女人。比丘摩触女人身。得僧伽婆尸沙。若比丘摩触男子身。比丘转根作比丘尼。比丘尼摩触男子。得波罗夷。若比丘尼摩触男子身。是男子转根作女人。比丘尼摩触女人身。得偷兰遮。若比丘尼摩触男子身。是比丘尼转根作比丘。比丘摩触男子。得偷兰遮。若比丘尼摩触女人身。是女人转根作男子。比丘尼摩触男子。得波罗夷。若比丘尼摩触女人身。是比丘尼转根作比丘。比丘摩触女人。得僧伽婆尸沙。问颇比丘摩触女人身不得僧伽婆尸沙耶。答有。若为寒为热为暖无染心无罪。若摩触不能女。得偷兰遮。若摩触入灭尽定女人。得偷兰遮。问颇比丘摩触女人身。不得僧伽婆尸沙耶。答有。若救火救水救刀兵救深坑救恶兽救恶鬼诸难无罪。问颇比丘与女人粗语。不得僧伽婆尸沙耶。答有。若为他作粗语。若遣使若本性粗语。若遣书若示相。得偷兰遮。若与不能女粗语。得偷兰遮。若比丘与二道合一道女人共粗语。得偷兰遮。若与入灭尽定女人共粗语。得偷兰遮。问颇比丘向女人称赞以身供养。不得僧伽婆尸沙耶。答有。若为他故向女人称赞以身供养。得偷兰遮。若遣使若书若示相。得偷兰遮。若向不能女称赞以身供养。得偷兰遮。若比丘向二道合一道女人称赞以身供养。得偷兰遮。若向入灭尽定女人称赞以身供养。得偷兰遮

优波离问佛。若媒合男女事已。成比丘后来佐助。得何罪。答得偷兰遮。若居士与女人共期。语比丘言。汝为我语彼女人来。比丘语彼女人。彼女人不随语。比丘还语居士言。彼女人不随我语。是比丘得偷兰遮。若比丘受富贵人语。向贫贱人说。受贫贱人语。向富贵人说。得偷兰遮。受富贵人语。向富贵人说。受贫贱人语。向贫贱人说。得僧伽婆尸沙。问齐何名富贵人。答乃至三语令官受用。是名富贵。若比丘语余比丘言。汝买女人。得偷兰遮。若言买是。得偷兰遮。若买已合偶事成。得僧伽婆尸沙。若女人一怀妊男一怀妊女。比丘媒合。得偷兰遮。若比丘持主人语。转语余人。展转乃至第三人。得偷兰遮。若比丘从使边受语。转语余人。后还自来语其主。得僧伽婆尸沙。若比丘与未有男家作媒言。若男当与某女。得偷兰遮。若比丘与不能男不能女二道合一道女石女作媒。得偷兰遮。问颇比丘作媒。不得僧伽婆尸沙耶。答有。若女是人。男是非人。若男是人。女是非人。若二俱非人。比丘媒合。得偷兰遮。问若一居士与女人期。比丘言。是女人在何处。比丘答言。在外墙边。比丘得偷兰遮。若比丘惶心受语。狂心语彼人。得偷兰遮。若狂心受语。惺心语彼人。得僧伽婆尸沙。若比丘受惺心者语。语狂心者。得偷兰遮。若受狂心者语。语惺心者。得僧伽婆尸沙。有一居士。到众僧中语众僧言。汝等与我语某甲居士。与我儿若女若姊。是中若有比丘。受是语语彼居士。得僧伽婆尸沙。若众僧差遣一比丘。是比丘持是语。语彼居士。众僧得僧伽婆尸沙。有二居士作善知识。二居士妇俱怀妊。是二居士共作要言。若我生男汝生女。汝女当与我男。若我生女汝生男。我女当与汝男。若一人生男一人生女。生男者死。居家贫穷。生女者违要不与。此男子闻。语其家入出比丘言。汝能为我语彼女人言。汝未生时。汝父母持汝与我。今见我家贫穷。不欲与我。汝不应尔。汝今但来。我还当富贵。是比丘持是语。向彼女人说。女人心濡。闻如是事。走到男所得共和合。是比丘生疑。我将不犯僧伽婆尸沙耶。以是事白佛。佛言。不犯。得偷兰遮。若比丘受男子语。是男子转根为女。与二女人作媒。得偷兰遮。若比丘受女人语。是女人转根为男子。与二男子作媒。得偷兰遮。若比丘受他人语。比丘自转根作比丘尼。得僧伽婆尸沙。若比丘尼受男子语。是男子转根为女人。与二女人作媒。得偷兰遮。若比丘尼受女人语。是女人转根为男子。与二男子作媒。得偷兰遮。若比丘尼受他人语。比丘尼自转根作比丘。得僧伽婆尸沙。未受具戒人受语。未受具戒时语彼。得突吉罗。未受具戒人受语。受具戒时语彼。得突吉罗。未受具戒人受语。受具戒人语彼。得僧伽婆尸沙。受具戒时受语。受具戒时语彼。得突吉罗。受具戒时受语。受具戒已语彼。得僧伽婆尸沙。受具戒人受语。受具戒人语彼。得僧伽婆尸沙。受具戒人受语。非具戒人语彼。得偷兰遮。若比丘和合父母。得偷兰遮。问颇比丘作媒不得僧伽婆尸沙耶。答。有。若先破戒若贼住若先来白衣是。问颇不受具戒人作媒。得僧伽婆尸沙耶。答有。与学沙弥是。优波离问佛。如佛所说。若比丘为自身乞作房舍。当应量作。颇比丘为自身乞作房。不得僧伽婆尸沙耶。答有。从众僧乞地不乞作房。是中作房。得偷兰遮。若乞作房不乞地。得僧伽婆尸沙。问颇比丘自乞作房。不得僧伽婆尸沙耶。答有。若余人作房未成。比丘后成。得偷兰遮。若比丘作房未成反戒。得偷兰遮。问齐何名房。答得容四威仪坐卧行立是。大舍戒亦如是。问如佛所说。比丘以无根波罗夷谤比丘。得僧伽婆尸沙。问颇比丘以无根波罗夷谤比丘。不得僧伽婆尸沙耶。答有。若作书若遣使若作相示。若谤先破戒若贼住若先来白衣诸摈人不共住种种不共住人狂人散乱心人病坏心人是。何以故。是诸人等。心不安隐故。若比丘语比丘言。我犯淫。是比丘以无根谤言。汝犯杀盗妄语。得僧伽婆尸沙。若比丘语比丘言。我犯盗。是比丘以无根谤言。汝犯杀妄语淫。得僧伽婆尸沙。若比丘语比丘言。我故夺人命。是比丘以无根谤言。汝犯妄语淫盗。得僧伽婆尸沙。若比丘语比丘言。我犯妄语。是比丘以无根谤言。汝犯淫盗杀。得僧伽婆尸沙。若比丘尼以无根波罗夷谤比丘尼。得僧伽婆尸沙。问颇比丘尼以无根波罗夷谤比丘尼。不得僧伽婆尸沙耶。答有。若作书若遣使若作相示。若不能女。若二道合一道。若先破戒。若贼住。若先来白衣。诸摈人不共住种种不共住人。狂人散乱心人。病坏心人是。何以故。是诸人等心不安隐故。若比丘尼语比丘尼言。我犯淫。是比丘尼以无根谤言。汝犯杀盗妄语。得僧伽婆尸沙。若比丘尼语比丘尼言。我犯盗。是比丘尼以无根谤言。汝犯杀妄语淫。得僧伽婆尸沙。若比丘尼语比丘尼言。我故夺人命。是比丘尼以无根谤言。汝犯妄语淫盗。得僧伽婆尸沙。若比丘尼语比丘尼言。我犯妄语。是比丘尼以无根谤言。汝犯淫盗杀。得僧伽婆尸沙。若比丘。以无根波罗夷谤比丘。得僧伽婆尸沙。若比丘以无根波罗夷。谤比丘尼式叉摩尼沙弥沙弥尼。得突吉罗。若比丘尼。以无根波罗夷。谤比丘尼。得僧伽婆尸沙。若比丘尼。以无根波罗夷。谤式叉摩尼沙弥沙弥尼比丘。得突吉罗。若式叉摩尼。以无根波罗夷。谤式叉摩尼。得突吉罗。若式叉摩尼。以无根波罗夷。谤沙弥沙弥尼比丘比丘尼。得突吉罗。若沙弥。以无根波罗夷谤沙弥。得突吉罗。若沙弥。以无根波罗夷。谤沙弥尼比丘比丘尼式叉摩尼。得突吉罗。若沙弥尼。以无根波罗夷。谤沙弥尼。得突吉罗。若沙弥尼。以无根波罗夷。谤比丘比丘尼式叉摩尼沙弥。得突吉罗。若比丘。以无根逆罪。谤比丘如法。得罪。若谤言。汝杀母杀父杀阿罗汉。得僧伽婆尸沙。若谤言。汝恶心出佛身血若坏僧。得偷兰遮。问颇比丘以无根逆罪谤比丘不如法得罪耶。答有。若谤先破戒若贼住若先来白衣。若作书若遣使若作相示。若诸摈人不共住。种种不共住人。狂人散乱心人。病坏心人是。何以故。是诸人等心不安隐故。若比丘语比丘言。我杀母。是比丘以无根逆罪谤言。汝杀父杀阿罗汉。得僧伽婆尸沙。若谤言。汝恶心出佛身血若坏僧。得偷兰遮。若比丘语比丘言。我杀父。是比丘以无根逆罪谤言。汝杀母杀阿罗汉。得僧伽婆尸沙。若谤言。汝恶心出佛身血若坏僧。得偷兰遮。若比丘语比丘言。我杀阿罗汉。是比丘以无根逆罪谤言。汝杀母杀父。得僧伽婆尸沙。若谤言。汝恶心出佛身血若坏僧。得偷兰遮。若比丘语比丘言。我破众僧。是比丘以无根逆罪谤言。汝杀父母杀阿罗汉。得僧伽婆尸沙。若谤言。汝恶心出佛身血。得偷兰遮。若比丘语比丘言。我恶心出佛身血。是比丘以无根逆罪谤言。汝杀母杀父杀阿罗汉。得僧伽婆尸沙。若谤言。汝坏僧。得偷兰遮。若比丘尼。以无根逆罪。谤比丘尼如法。得罪。若谤言。汝杀母杀父杀阿罗汉。得僧伽婆尸沙。若谤言。汝恶心出佛身血若坏僧。得偷兰遮。问颇比丘尼。以无根逆罪。谤比丘尼不如法。得罪耶。答有。若谤先破戒若贼住若先来白衣。若作书若遣使若作相示。若不能女。若二道合一道。若石女。若诸摈人。不共住。种种不共住人。狂人散乱心人。病坏心人是。何以故。是诸人等心不安隐故。若比丘尼语比丘尼言。我杀母。是比丘尼以无根逆罪谤言。汝杀父杀阿罗汉。得僧伽婆尸沙。若谤言。汝恶心出佛身血若坏僧。得偷兰遮。若比丘尼语比丘尼言。我杀父。是比丘尼以无根逆罪谤言。汝杀母杀阿罗汉。得僧伽婆尸沙。若谤言。汝恶心出佛身血若坏僧。得偷兰遮。若比丘尼语比丘尼言。我杀阿罗汉。是比丘尼以无根逆罪谤言。汝杀父杀母。得僧伽婆尸沙。若谤言。汝恶心出佛身血若坏僧。得偷兰遮。若比丘尼语比丘尼言。我坏僧。是比丘尼以无根逆罪谤言。汝杀父杀母杀阿罗汉。得僧伽婆尸沙。若谤言。汝恶心出佛身血。得偷兰遮。若比丘尼语比丘尼言。我恶心出佛身血。是比丘尼以无根逆罪谤言。汝杀母杀父杀阿罗汉。得僧伽婆尸沙。若谤言。汝坏僧。得偷兰遮。若比丘。以无根逆罪。谤比丘如法。得罪。若比丘以无根逆罪。谤比丘尼式叉摩尼沙弥沙弥尼。得突吉罗。比丘尼。以无根逆罪。谤比丘尼如法。得罪。若比丘尼。以无根逆罪。谤式叉摩尼沙弥沙弥尼比丘。得突吉罗罪。若式叉摩尼。以无根逆罪。谤式叉摩尼。得突吉罗。式叉摩尼。以无根逆罪。谤沙弥沙弥尼比丘比丘尼。得突吉罗。沙弥。以无根逆罪谤沙弥。得突吉罗。沙弥。以无根逆罪。谤沙弥尼比丘比丘尼式叉摩尼。得突吉罗。沙弥尼。以无根逆罪。谤沙弥尼。得突吉罗。沙弥尼。以无根逆罪。谤比丘比丘尼式叉摩尼沙弥。得突吉罗。若以无根谤言。汝尽破戒。得偷兰遮。若说汝破四重戒。得僧伽婆尸沙。犯片罪以无根谤亦如是。优波离问佛。如佛所说。若诸比丘不先濡语约敕。便以白四羯磨约敕。是如法约敕不。佛言。是约敕。作羯磨人得突吉罗。又问。若未作白四羯磨便摈出。得名摈不。答得摈。作羯磨人得突吉罗。若未作三语约敕。于界内别请人作羯磨。得不。答得羯磨。作羯磨者得偷兰遮。破僧因缘故。若众僧知。众僧得罪。比丘若未作出羯磨。出诸比丘过罪言。诸比丘随爱随嗔随怖随痴行。是比丘得突吉罗。问是人应约敕不。答言。不应。若令出。为如法不。答不如法。问若先作出羯磨竟。是比丘出诸比丘过罪。若言诸比丘随爱随嗔随怖随痴行。是比丘得偷兰遮。应约敕是比丘莫作是语不。答言。应约敕。如法不。答言。如法。优波离问佛。如佛所说。若诸比丘不举不忆念。自身作不可共语。是比丘得突吉罗。可约敕不。答不得约敕。若约敕。成约敕不。答不成。若诸比丘若举若令忆念。自身作不可共语。闻是已故作自身不可共语。是比丘得偷兰遮。应约敕不。答言。应约敕。若约敕成约敕不。答言。成约敕。若有罪比丘在地。作羯磨人在高上。得约敕不。答言。不得。若有罪比丘在高上。羯磨人在地。得约敕不。答言。不得。若有罪比丘在界内。羯磨人在界外。得约敕不。答不得。若有罪比丘在界外。羯磨人在界内。得约敕不。答不得。若有罪比丘羯磨人俱在界内。得约敕不。答言。得约敕。问颇有比丘。于四住处作约敕。得约敕不得罪耶。答有。若材木若床榻连接四界。比丘坐上作约敕。得约敕四处。问颇有比丘。足四处众作约敕。得如法耶。答得。若材木床榻连接四界。比丘坐上足四处众。得如法约敕。问颇一人于四住处。约敕四人各各所作。得约敕不得罪耶。答有。若材木床榻连接四界。比丘坐上。若是比丘。能一时以一羯磨如法约敕。四人各随所作是也(十三事竟)

十诵律卷第五十二十诵律卷第五十三(第九诵之二)

        后秦北印度三藏弗若多罗译

    优波离问二不定法

优波离问佛。若信语优婆夷。见比丘于初犯四波罗夷中随所破戒。语诸比丘。应随信语优婆夷语治不。佛言。应随语治。应与实罪相羯磨不。佛言。应与。又问。若二信语优婆夷。一人见比丘犯淫。一人见犯盗。是二人语诸比丘。应随此信语优婆夷语治不。答言。应治。应与实罪相羯磨不。答言。应与。问信语优婆夷见比丘行道时与女人作淫。语诸比丘。应随信语优婆夷治不。答言。不应。应与实罪相羯磨不。答言。不应。应问是信语优婆夷言。更有信语优婆夷不。答言。有。应问第二人。若二人语同。应随信语优婆夷治。应与实罪相羯磨。若语不同。言我不见行道时作淫。我见立坐作淫。尔时应问是比丘。汝实云何。应随是比丘语作。问若信语优婆夷。见比丘与刹利女作淫。语诸比丘。应随信语优婆夷治不。答言。不应。应与实罪相羯磨不。答言。不应。应问言。更有信语优婆夷不。答言。有。应问第二人。若二人语同。应随信语优婆夷治。应与实罪相羯磨。若语不同。言我不见与刹利女作淫。我见与婆罗门女毗舍首陀罗女作淫。尔时应问是比丘。汝实云何。应随是比丘语作。问若信语优婆夷。见比丘与一白色女作淫。语诸比丘。应随信语优婆夷治不。答言。不应。应与实罪相羯磨不。答言。不应。应问言。更有信语优婆夷不。答言。有。应问第二人。若第二人语同应随信语优婆夷治。应与实罪相羯磨。若语不同。言我不见与白色女作淫。我见与黑色女若黄色女青色女作淫。尔时应问是比丘。汝实云何。应随是比丘语作。问若信语优婆夷。见比丘与长女人作淫。语诸比丘。应随信语优婆夷语治不。答言。不应应与实罪相羯磨不。答言。不应。应问言。更有信语优婆夷不。答言。有。应问第二人。若第二人语同。应治。应与实罪相羯磨。若语不同。言我不见与长女人作淫。我见与短女人中女人作淫。尔时应问是比丘。汝实云何。应随是比丘语作。问若信语优婆夷。见比丘与女人于小便道作淫。语诸比丘。应随信语优婆夷语治不。答言。不应。应与实罪相羯磨不。答言。不应。应问言。更有信语优婆夷不。答言。有。应问第二人。若第二人语同。应随信语优婆夷治。应与实罪相羯磨。若语不同。言我不见小便道作淫。我见大便道口中作淫。尔时应问是比丘。汝实云何。应随是比丘语作。问若信语优婆夷。见比丘与女人大便道中作淫。语诸比丘应随信语优婆夷治不。答言。不应。应与实罪相羯磨不。答言。不应。应问。更有信语优婆夷不。答言。有。应问第二人。若第二人语同。应随信语优婆夷治。应与实罪相羯磨。若语不同。言我不见大便道中作淫。我见小便道口中作淫。尔时应问是比丘。汝实云何。应随是比丘语作。问若信语优婆夷。见比丘与女人口中作淫。语诸比丘。应随信语优婆夷治不。答言。不应。应与实罪相羯磨不。答言。不应。应问。更有信语优婆夷不。答言。有。应问第二人。若第二人语同。应随信语优婆夷治。应与实罪相羯磨。若语不同。言我不见口中作淫。我见于大小便道中作淫。尔时应问是比丘。汝实云何。应随是比丘语作。问若信语优婆夷。见比丘非时啖石蜜。谓是啖肉。语诸比丘。应随信语优婆夷治不。答言。不应。应与实罪相羯磨不。答言。不应。应问是比丘。有是事不。若比丘言。我不食肉。我啖黑石蜜。应随是比丘语作。问若信语优婆夷。见比丘非时啖酥。谓是啖穄米糜。语诸比丘。应随信语优婆夷语治不。答言。不应。应与实罪相羯磨不。答不应。应问是比丘。汝实有是事不。若比丘言。我不食穄米糜。我啖酥。应随是比丘语作。问若信语优婆夷。见比丘非时饮石蜜浆。谓是啖粥。语诸比丘。应随信语优婆夷治不。答言。不应。应与实罪相羯磨不。答言。不应。应问是比丘。有是事不。若比丘言。我不啖粥。我饮石蜜浆。应随是比丘语作。问若信语优婆夷。见比丘于女人股间出精。谓正作淫欲。语诸比丘。应随信语优婆夷治不。答言。不应。应与实罪相羯磨不。答言。不应。应问是比丘。有是事不。若比丘言。我股间出精不犯正淫。应随自言治。问若比丘共一女人行道。有二信语优婆夷随来。一信语优婆夷见比丘摩触女人身。谓作淫。语诸比丘。应随信语优婆夷治不。答言。不应。应问第二人。若事相违。我如所见说。应随信语优婆夷治不。答言。不应。应与实罪相羯磨不。答言。不应。应问是比丘。是事云何。随比丘自言作。问若信语优婆夷。见比丘于后四品戒中随所犯戒。语诸比丘。应随信语优婆夷治不。答言。不应。应与实罪相羯磨不。答言。应与。问若二信语优婆夷。一人见比丘故出精。一人见比丘摩触女人身。语诸比丘。应随信语优婆夷治不。答言。应治。应与实罪相羯磨不。答言。应与。问若信语优婆夷。见比丘行时故出精。语诸比丘。应随信语优婆夷治不。答言。不应。应与实罪相羯磨不。答言。不应。应问言。更有信语优婆夷不。答言。有。应问弟二人。若弟二人语同。应随信语优婆夷治。应与实罪相羯磨。若语不同。言我不见行时出精。我见若坐若立时出精。尔时应问是比丘。是事云何。应随是比丘语作。问若信语优婆夷。见比丘摩触刹利女身。语诸比丘。应随信语优婆夷治不。答言。不应。应与实罪相羯磨不。答言。不应。应问。更有信语优婆夷不。若言有。应问第二人。若弟二人语同。应治。应与实罪相羯磨。若语不同。言我不见刹利女。我见婆罗门毗舍首陀罗女。尔时应问是比丘。是事云何。应随是比丘语作。问若信语优婆夷。见比丘摩触白色女人身。语诸比丘。应随信语优婆夷治不。答言。不应。应与实罪相羯磨不。答言。不应。应问。更有信语优婆夷不。答言。有。应问第二人。若第二人语同。应治。应与实罪相羯磨。若语不同。言我不见是比丘摩触白色女人身。我见摩触黑色黄色青色女人身。尔时应问是比丘。是事云何。应随是比丘语作。问若信语优婆夷。见比丘摩触长女人身。语诸比丘。应随信语优婆夷治不。答言不应。应与实罪相羯磨不。答言。不应。应问。更有信语优婆夷不。若言有。应问第二人。若第二人语同。应治。应与实罪相羯磨。若语不同。言我不见摩触长女人身。我见摩触短女人中女人身。应治不。应与实罪相羯磨不。答言。不应与。应问是比丘。随比丘自言作。问若比丘于道中行。有一女人。有二信语优婆夷。一信语优婆夷。见比丘行时摩触女人身。语诸比丘。应随是语治不。答言。不应。应与实罪相羯磨不。答言。不应与。应问第二人。若事相违。我如所见说。应随信语优婆夷治不。答言。不应。应与实罪相羯磨不。答言。不应与。应问是比丘。是事云何。应随是比丘语作(二不定竟)

    问三十舍堕法

优波离问佛。若比丘多有尼萨耆衣。若为火烧若腐烂。若断坏。若虫啮。应舍不。佛言。不应舍。是比丘应但如法灭罪。若有残段破。应舍不。答不应舍。是比丘但应如法灭罪。问若衣经净纬不净纬净经不净。若二俱不净。不净者。若骆驼毛牛毛羖羊毛。若杂织衣。应舍不。答不应舍。问若比丘得长衣五日。是比丘狂心散乱心病坏心。齐何数作十日。答数得自心日。问颇比丘尽形畜长衣不得尼萨耆波夜提耶。答有。若得长衣。未满十日便命终是。问颇比丘畜长衣过十日一夜在耶。佛言有。比丘不断望衣。第十日得衣。不遣与人不作净不受持。至十一日地了时过此十。余一夜在是也。优波离问佛。若比丘受众僧衣离宿。应舍不。答不应舍。是比丘但应如法灭罪。问若比丘衣在界内。比丘出界外。至地晓是离衣宿耶。答言。离宿。问若衣在界外。比丘在界内。至地了时。是名离衣宿耶。答言。离宿。问若衣在地比丘在上。至地了时。是名离衣宿耶。答言。离衣宿。问若衣在上比丘在地。至地了时。是名离衣宿耶。答言。离衣宿。问若未作不离衣羯磨。齐远近名不离衣。答若墙壁堑篱栅。齐是来比丘不离三衣。比丘尼不离五衣。与学沙弥不离三衣。与学沙弥尼不离五衣。问得一月衣财。何等是一月衣财。乃至一月畜。答净衣是。问衣量大小。答乃至得覆身三分是。诸衣不净者。经净纬不净。纬净经不净。若二俱不净。不净者。一切骆驼毛牛毛羖羊毛若杂织衣。是名不净。如是衣不应畜至一月。问颇比丘使非亲里比丘尼浣染打故衣。不得尼萨耆波夜提耶。答有。若比丘先自小浣更令浣。先自小染更令染。先自小打更令打。若浣不名浣如不浣。得突吉罗。若染不名染如不染。得突吉罗。若打不名打如不打。得突吉罗。若展转令浣。若遣使。若作书。若作相示。若为他若浣染。若二人共衣。若众僧衣。入尼萨耆衣。若作净衣。皆得突吉罗。问颇比丘着净衣入白衣舍。得尼萨耆出耶。答有。若比丘着净衣入白衣舍。若屎尿牛尿泥着。令非亲里比丘尼浣。得尼萨耆波逸提。若衣经净纬不净。若纬净经不净。若二俱不净。不净者。一切骆驼毛牛毛羖羊毛若杂织衣令浣。得突吉罗。若比丘令非亲里比丘尼浣故衣。是比丘尼转根作比丘。得突吉罗。若比丘令非亲里比丘尼浣故衣。比丘转根为比丘尼。得突吉罗。问颇比丘令非亲里比丘尼浣染打故衣。不得尼萨耆波夜提耶。答有。若先破戒若贼住若先来白衣是。问颇有不受具戒人。令非亲里比丘尼浣染打故衣。得尼萨耆波逸提耶。答有。与学沙弥是也。问颇比丘从非亲里居士居士妇乞衣。不得尼萨耆波夜提耶。答有。若不能男居士。不能女居士妇。二根居士。二道合一道居士妇。比丘从是乞衣。得突吉罗。问颇有不受具戒人。从非亲里居士居士妇乞衣。得尼萨耆波逸提耶。答有。与学沙弥是也。若衣经净纬不净。纬净经不净。若二俱不净。不净者。若一切骆驼毛牛毛羖羊毛若杂织。比丘乞是衣。得突吉罗。若乞毳得突吉罗。若乞缕得突吉罗。未受具戒人乞。未受具戒人得。得突吉罗。未受具戒人乞。受具戒时得。得突吉罗。未受具戒人乞。受具戒已得。得尼萨耆波夜提。受具戒时乞。受具戒时得。得突吉罗受具戒时乞。受具戒已得。得尼萨耆波逸提。受具戒人乞。受具戒人得。得尼萨耆波逸提。受具戒人乞。非具足戒人得。得突吉罗。若比丘从非亲里居士居士妇乞衣。比丘转根作比丘尼。比丘尼得是衣。尼萨耆波逸提。若比丘尼。从非亲里居士居士妇乞衣。是比丘尼转根作比丘。比丘得是衣。尼萨耆波逸提。问颇比丘非亲里中作亲厚意索。不得尼萨耆波夜提耶。答有。若比丘为办衣价。比丘作亲厚意索。得突吉罗。若比丘尼式叉摩尼沙弥沙弥尼。为办衣价。比丘作亲厚意索得。得突吉罗。若众多居士为办衣价。比丘作亲厚意索得。得突吉罗。若比丘所不应畜物。作亲厚意索。得突吉罗。未受具戒人作亲厚意索。未受具戒人得。得突吉罗。未受具戒人作亲厚意索。受具戒时得。得突吉罗。未受具戒人作亲厚意索。受具戒已得。得尼萨耆波逸提。受具戒时作亲厚意索。受具戒时得。得突吉罗。受具戒时作亲厚意索。受具戒已得。得尼萨耆波逸提。受具戒人作亲厚意索。受具戒人得。得尼萨耆波逸提。受具戒人作亲厚意索。非具戒人得。得突吉罗。若是衣价。属天龙夜叉罗刹饿鬼拘槃荼毗舍遮等非人。若属先破戒人若贼住人若先来白衣若摈人不共住人种种不共住人狂人散乱心人病坏心人及诸外道。此中作亲厚意索。得突吉罗。问颇比丘勤求衣。乃至过六返。不得尼萨耆波逸提耶。答有。是衣价属人。寄在天龙夜叉罗刹饿鬼拘槃荼毗舍遮等非人边。是中勤求乃至过六返。得突吉罗。若是衣价。属天龙夜叉罗刹饿鬼拘槃荼毗舍遮等非人。寄在人边。是中勤求乃至过六返。得突吉罗。若是衣价。属出家外道。寄在人边。是中勤求乃至过六返。得突吉罗。问颇比丘以憍施耶作新敷具。不得尼萨耆波逸提耶。答有。若憍施耶腐坏。若憍施耶作劫贝。若憍施耶作钵妒路慕。若憍施耶作突突路。若经净纬不净。纬净经不净若二俱不净。不净者。骆驼毛牛毛羖羊毛若杂织作敷具。得突吉罗。若减量作。突吉罗。若佛衣等量作。得突吉罗。问颇比丘用纯黑羺羊毛作新敷具。不得尼萨耆波夜提耶。答有。羺羊毛腐坏作。得突吉罗。若经净纬不净。纬净经不净。若二俱不净。不净者。骆驼毛牛毛羖羊毛若杂织作敷具。得突吉罗。若减量作突吉罗。若如来衣等量作。得突吉罗。问颇比丘不用二分纯黑三分白羺羊毛四分下羊毛作新敷具。不得尼萨耆波夜提耶。答有。经净纬不净。纬净经不净。若二俱不净。不净者。骆驼毛牛毛羖羊毛杂织作敷具。得突吉罗。若减量作突吉罗。若佛衣等量作。得突吉罗。问颇有比丘。六年内故敷具。若舍若不舍。更作新敷具。不得尼萨耆波夜提耶答有。余人先作未成。比丘足成竟。得突吉罗。若作未成便反戒。得突吉罗。若经净纬不净。若纬净经不净。若二俱不净。不净者。若骆驼毛牛毛羖羊毛杂织作。得突吉罗。问颇比丘持羺羊毛过三由延。不得尼萨耆波夜提耶。答有。飞持过不犯。若与化净人持过。得突吉罗。若比丘知是化人不犯。问颇有比丘。使非亲里比丘尼浣染擘羺羊毛。不得尼萨耆波夜提耶。答有。先已小浣更浣。先已小染更染。先已小擘更擘。浣如不浣。染如不染。擘如不擘。皆突吉罗。若展转令浣染擘。若遣使若教他若作书若示相。使浣染擘。皆得突吉罗。若浣染擘枕毳。得突吉罗。二人共毳使浣染擘。得突吉罗。使浣染擘众僧毳。得突吉罗。使浣染擘尼萨耆毳。得突吉罗。使浣染擘作净施毳。得突吉罗。问颇比丘自手取钱。不得尼萨耆波逸提耶。答有。若取似钱者。得突吉罗。问颇比丘以钱种种用。不得尼萨耆波夜提耶。答有。用似钱买者。得突吉罗。共非人买物。非人者。天龙夜叉罗刹鸠槃荼薜荔伽毗舍遮等共买物。得突吉罗。若共狂人散乱心人病坏心人若亲里共买。得突吉罗。未受具戒人与。未受具戒人得。突吉罗。未受具戒人与。受具戒时得。得突吉罗。未受具戒人与。受具戒已得。得尼萨耆波夜提。受具戒时与。受具戒时得。得突吉罗。受具戒时与。受具戒已得。得尼萨耆波逸提。受具戒人与。受具戒人得。得尼萨耆波夜提。受具戒人与。非具戒人得。得突吉罗。种种贩买亦如是。问颇比丘尽形畜长钵。不得尼萨耆波夜提耶。答有。若比丘畜长钵。未满十日便命终者是。问若比丘得长钵五日。是比丘便狂心散乱心病坏心。齐何数作十日。答数得自心日。问颇比丘久畜长钵。不犯尼萨耆波夜提耶。答有。若他送钵与久久乃至者是也。问颇比丘过一夜畜长钵。得尼萨耆波逸提耶。答有。是比丘得长钵日。便转根作比丘尼者是。问颇比丘尼畜长钵十夜。不得尼萨耆波逸提耶。答有。是比丘尼得长钵已。转根作比丘者是。问颇有比丘。多有钵入尼萨耆。一切钵应僧中行不。答不应。但僧中行一钵。余者随意与亲厚。问颇比丘钵减五缀更求新钵。不得尼萨耆波夜提耶。答有。若求坏钵白铁钵。若二人共求。若遣使若书若示相。若展转求若为他求钵。皆得突吉罗。若从异道出家人乞得钵。突吉罗。若比丘所用钵未满五缀。以自物买钵。突吉罗。问若比丘不乞缕乞毳。得何罪。答得突吉罗。问颇比丘自乞缕。令非亲里织师织。不得尼萨耆波夜提耶。答有。是衣经净纬不净。纬净经不净。若二俱不净。不净者。若骆驼毛牛毛羖羊毛。若杂缕令织。得突吉罗。问颇比丘于非亲里中作同意劝不得尼萨耆波夜提耶。答有。若居士不能男。居士妇不能女。若居士二根。居士妇二道合一道。是中作同意劝。得突吉罗。问颇比丘。与他比丘衣。后嗔还夺。不得尼萨耆波夜提耶。答有。受法比丘。与不受法比丘衣。后嗔还夺。不受法比丘。与受法比丘衣。后嗔还夺。得突吉罗。若衣经净纬不净。纬净经不净。若二俱不净。不净者。若骆驼毛牛毛羖羊毛。若杂织衣。与已后嗔还夺。得突吉罗。若与先破戒若贼住若先来白衣。与已还夺。得突吉罗。是衣若减量。后嗔还夺。得突吉罗。若佛衣等量。后嗔还夺。得突吉罗。若比丘与他比丘衣。他比丘转根为比丘尼。比丘还夺比丘尼衣。得突吉罗。若比丘与他比丘衣。是比丘自转根为比丘尼。比丘尼还夺比丘衣。得突吉罗。问受迦絺那衣竟。官作闰月。受迦絺那衣人当云何。答随安居数。问受伽絺那衣。应如布萨作羯磨不。答言应作。问讫迦絺那衣。应作舍羯磨不。答言。应作。问应何时受迦絺那衣。答夏末后月。问几时应舍。答从夏末月竟冬四月应舍。问急施衣可得作时衣不。答言。得。若衣经净纬不净。纬净经不净。若二俱不净。不净者。若骆驼毛牛毛羖羊毛。若杂织衣。如是等不净衣不应停。问颇比丘三衣中随离一衣宿。不得尼萨耆波逸提耶。答有。后安居中未满岁。阿练若比丘三衣中。若以一一衣置界内舍。以少因缘出界。作是言。我今日当还此宿。是比丘更有因缘起。不得还宿界外。地了得突吉罗。问颇比丘。春残过一月求雨浴衣。过半月畜不得尼萨耆波夜提耶。答有。若是衣经净纬不净纬净经不净。若二俱不净。不净者。若骆驼毛牛毛羖羊毛若杂织。如是等衣。得突吉罗。问颇比丘从母乞衣。得尼萨耆波夜提耶。答有。若母为众僧作衣。是比丘自回向已。得尼萨耆波夜提。若是物界外取。得突吉罗。若二三四恣心取。如法得罪。问颇比丘从母乞顺比丘物。得尼萨耆波夜提耶。答有。若母为众僧作顺比丘物。比丘自回向已。得尼萨耆波夜提。若是物界外取。得突吉罗。若二三四恣心取。如法得罪。问若比丘非时受甘蔗。非时压非时漉非时受。非时应饮不。答言。不得。问若时受甘蔗。非时压非时漉非时受。非时得饮不。答不得。问若时受甘蔗。时压非时漉非时受。非时得饮不。答言。不得。问若时受甘蔗。时压时漉非时受。非时应饮不。答言。不得。问若时受甘蔗。时压时漉时受。非时应饮不。答言。若尽时净应饮。问若非时受酪。非时压非时漉非时受。非时应饮不。答言。不得。若尽时净应得。问若比丘非时受胡麻。非时压非时漉非时受。非时得饮不。答言。不得。若尽时净应得。问若比丘非时受肉。非时煮非时压非时漉。非时受非时得服不。答言。不得。若尽时净应得。即日受时药时分药七日药尽形药。共和合一处。得服不。答时药力故时中应服。非时不得服。即日受时分药七日药尽形寿药。共和合一处。得服不。答时分药力故。时分中应服。过时分不得服即日受七日药尽形寿药。共和合一处。得服不。答七日药力故。七日应服。过七日不得服。尽形寿药随意应服。昨日受时药。即日受时分药七日药尽形寿药。和合一处。得服不。答不得服。昨日受时分药。即日受七日药尽形寿。药和合一处。得服不。答言。不得服。昨日受七日药。即日受尽形寿药。和合一处。得服不。答不得服。问是诸时药时分药七日药尽形寿药。举残宿可服不。答不得。问若比丘先自取。后更从净人受。得服不。答不得。问是诸药手受口受。无病比丘得服不。答不得。若手受口受。病比丘得服不。答言得(三十舍堕竟)

    问波夜提事之一

优波离问佛。若比丘作梵志形服。于道行得何罪。答得偷兰遮。若作秦形服大秦安息薄佉利波罗大形服。得何罪。答得突吉罗。如是等亦得突吉罗。问若人问比丘言。汝见人用盖行不。比丘言不见为因脚故言我不见。得何罪。答得突吉罗。扇革屣珠钏羺头璎珞宝鬘钦跋罗[疊*毛]拘执车乘帽辇舆等亦如是。若比丘至婆罗门姓人边语言。汝是剃毛人。故妄语故。得波逸提。乃至语不破戒人言。汝破戒故妄语故。得波逸提。问若人问比丘言。汝是何人。比丘言。我是比丘尼。是反戒不。答不反戒。故妄语得波逸提。若言我是式叉摩尼沙弥沙弥尼优婆塞优婆夷白衣外道遮逻伽波离婆罗遮尼揵驼阿耆毗等。若言我是天龙夜叉揵闼婆阿修罗伽楼罗薜荔伽鸠槃茶毗舍遮罗刹等。作如是语。是反戒不。答不反戒。故妄语得波逸提。问若比丘以天眼见天耳闻他比丘罪。他不听便出他罪。得何罪。答言。得突吉罗。问若比丘于众僧前破戒。请应举。答随能举者举。问若比丘至婆罗门姓人边语言。汝作剃毛人来。得何罪。答得突吉罗。问若比丘毁訾比丘。得何罪。答波逸提。问颇比丘毁訾他比丘。不得波逸提罪邪。答有。若先破戒若贼住若先来白衣是。问颇不受具戒人毁訾比丘。得波逸提邪。答有。与学戒沙弥是。若作书若遣使若示相若展转毁訾。得突吉罗。若比丘以毁訾比丘。得波逸提。毁訾比丘尼式叉摩尼沙弥沙弥尼。得突吉罗。若比丘尼。以毁訾比丘尼。得波逸提。毁訾式叉摩尼沙弥沙弥尼比丘。得突吉罗。式叉摩尼。毁訾式叉摩尼。得突吉罗。毁訾沙弥沙弥尼比丘比丘尼。得突吉罗。若沙弥。毁訾沙弥。得突吉罗。毁訾沙弥尼比丘比丘尼式叉摩尼。得突吉罗。沙弥尼。毁訾沙弥尼。得突吉罗。毁訾比丘比丘尼式叉摩尼沙弥。得突吉罗罪。问若比丘两舌谗比丘。得波逸提。若比丘两舌。谗比丘尼式叉摩尼沙弥沙弥尼。得突吉罗。若比丘尼两舌。谗比丘尼。得波逸提。若比丘尼两舌。谗式叉摩尼沙弥沙弥尼比丘。得突吉罗。若式叉摩尼两舌。谗式叉摩尼。得突吉罗。若式叉摩尼两舌。谗沙弥沙弥尼比丘比丘尼。得突吉罗。若沙弥两舌。谗沙弥。得突吉罗。若沙弥两舌。谗沙弥尼比丘比丘尼式叉摩尼。得突吉罗。若沙弥尼两舌。谗沙弥尼。得突吉罗。若沙弥尼两舌。谗比丘比丘尼式叉摩尼沙弥。得突吉罗。若比丘在界内。谗界外比丘。得突吉罗。若在界外。谗界内比丘。若在地谗高上比丘。若在高上谗在地比丘。得突吉罗。若比丘住界内。若坐若立若卧。谗界内比丘。得波逸提。若作书若遣使若示相若展转谗。得突吉罗罪。问颇比丘如法灭事后还发起。不得波逸提耶。答言。有是事。若比丘比丘尼事。若比丘式叉摩尼。若比丘沙弥。若比丘沙弥尼事。如法灭已。比丘还发起。突吉罗。问颇比丘如法灭事还发起。不得波逸提耶。答言有。若先破戒若贼住若先来白衣是。问颇不受具戒人。如法灭事还发起。得波逸提耶。答言有。与学戒沙弥是也。若作书若遣使若示相若展转语。如法灭事已还发起。得突吉罗罪。问如佛所说。比丘于不能男净人前。为女人说法过五六语。何等是不能男净人前。为女人说法过五六语。答若。不动者是。无知净人前。与女人说法过五六语。得突吉罗。若作书若遣使若示相若展转语。说法过五六语。得突吉罗。若作净人睡眠。与女人说法过五六语。得突吉罗。若女人净。男子不净。男子净。女人不净。若二俱不净。若是中无作净人。比丘为女人说法过五六语。得突吉罗。若有不能男作净者。比丘为女人说法过五六语。得突吉罗。若无作净者。比丘为不能女人说法过五六语。得突吉罗。若无作净人。比丘为二道合一道女人说法过五六语。得突吉罗。若比丘哑净人前。为女人说法过五六语。得突吉罗。若聋净人前。与女人说法过五六语。得突吉罗。若哑聋净人前。与女人说法过五六语。得突吉罗。若非人天龙夜叉薜荔伽鸠槃茶毗舍遮罗刹等净人前。与女人说法过五六语。得突吉罗。问颇比丘以音句诵法。教未受具戒人诵。不得波夜提耶。答有。若教天龙夜叉薜荔伽拘槃茶毗舍遮罗刹等非人赞诵。得突吉罗。教吃人诵。得突吉罗。独处诵。得突吉罗。独非独想。非独独想。以中国语教边地人诵。是边地人不解是语。以边地语教中国人诵。是中国人不解是语。若教哑人聋人哑聋人诵。若作书若遣使若示相若展转语狂人病坏心散乱心。如是等教赞诵。得突吉罗。问颇不受具戒人。以音句诵法。教未受具戒人赞诵。得波夜提耶。答有。与学沙弥是也。若与学沙弥。教哑人聋人哑聋人赞诵。得突吉罗。若与学沙弥。以音句诵法。教比丘比丘尼赞诵。得突吉罗。问颇比丘。未受具戒人前说过人法。言我有如是知如是见。不得波夜提耶。答言有。若天龙夜叉薜荔伽鸠槃茶毗舍遮罗刹等非人前说。得突吉罗。若独处说。得突吉罗。独非独想。非独独想。若以中国语向边地人说。边地人不解。以边地人语向中国人。中国人不解是语。若向哑人聋人哑聋人说。若作书若遣使若示相若展转语。得突吉罗。若向狂人散乱心人病坏心人说。得突吉罗。问颇比丘以粗罪向未受具戒人说。不得波夜提耶。答言有。向未受具戒人。说比丘尼粗罪。得突吉罗。说式叉摩尼沙弥沙弥尼粗罪。得突吉罗。若向天龙夜叉薜荔伽拘槃茶毗舍遮罗刹等非人。说比丘粗罪。得突吉罗。问颇未受具戒人。向未受具戒人。说比丘粗罪。得波夜提耶。答言有。与学沙弥是也。若在地向高上人说。若在高上向在地人说。得突吉罗。若在界内向界外人说。若在界外向界内人说。得突吉罗。若俱在界内。若坐若立若卧。若向界内人说。得波夜提。问颇比丘。先同心与。后作是言。汝随亲厚回僧物与。不得波夜提耶。答有。若是施物。属比丘尼僧。作如是语。得突吉罗。若作书若遣使若示相若展转语。得突吉罗。问颇比丘。说戒时作是言。何用半月半月说是杂碎戒为。令诸比丘心生疑悔心恼心热。愁忧不乐生反戒心。作是轻诃戒。不得波夜提耶。答有。若独处诃戒。得突吉罗。若独非独想。非独独想。若以中国语向边地人呵戒。边地人不解。若以边地语向中国人呵戒。中国人不解。若向哑人聋人哑聋人呵戒。若作书若遣使若示相若展转语呵戒。若向狂人散乱心。人病坏心人诃戒。皆得突吉罗。问若比丘以土。覆生草菜草上。为灭故。得何罪。答波夜提。若食果吞子。得突吉罗。问若比丘语他人言。汝摇树落果。得何罪。答波夜提。问颇比丘语他人令摇树落果。不得波夜提耶。答有。若作书若遣使若示相若展转语。得突吉罗。若杀地菌得突吉罗。问颇不受具戒人。语他人令摇树落果。得波夜提耶。答有。与学沙弥是也。问颇比丘杀草木。不得波夜提耶。答有。若示相得突吉罗。若飞去时伤杀无罪。问若比丘言。汝杀是树好。得何罪。答得波夜提。问若比丘以种子着热汤中。若日曝火炙。得何罪。答得突吉罗。问颇比丘杀草菜。不得波夜提耶。答有。若先破戒若贼住若先来白衣是也。问颇不受具戒人杀草菜。得波夜提耶。答有。与学沙弥是也。若取水上浮萍。若取石韦。得突吉罗。问颇比丘嗔恨轻讥。不得波夜提耶。答有。若天龙夜叉薜荔伽拘槃茶毗舍遮罗刹等非人。得突吉罗。若嗔恨轻讥先破戒若贼住若先来白衣。得突吉罗。若独处嗔恨轻讥。得突吉罗。若独非独想。非独独想。嗔恨轻讥。得突吉罗。若以中国语。嗔恨轻讥边地人。边地人不解是语。若以边地语。嗔恨轻讥中国人。中国人不解是语。皆得突吉罗。若嗔恨轻讥哑人聋人哑聋人。若作书若遣使若示相。若展转嗔恨轻讥。若嗔恨轻讥狂人散乱心人病坏心人。皆得突吉罗。若嗔恨轻讥善性人。突吉罗。问颇比丘。不随问答恼他。不得波夜提耶。答有。若向哑人聋人哑聋人。不随问答恼他。得突吉罗。除犯余事中。不随问答恼他。得突吉罗。若独处异语恼他。得突吉罗。若独非独想。非独独想。异语恼他。若以中国语。向边地人。边地人不解。若以边地人语。向中国人。中国人不解。若无知若作书若遣使若示相若展转语。若向狂人散乱心人病坏心人。若向天龙夜叉薜荔伽拘槃茶毗舍遮罗刹等非人。若向先破戒人若贼住若先来白衣。不随问答。皆得突吉罗。问颇比丘。众僧卧具。若粗梐绳床。若细梐绳床。若被若褥。露地若自敷若使人敷。是中若坐若卧。去时不自举不教人举。不得波夜提耶。答有。若是卧具。经净纬不净。纬净经不净。二俱不净。不净者。若骆驼毛牛毛羖羊毛杂织作。不自举不教人举。得突吉罗。若是粗梐绳床。细梐绳床。足过八指。不自举不使人举。得突吉罗。问颇比丘。比丘房中取卧具。若自敷若教人敷。是中若坐若卧。去时不自举不教人举。不得波夜提耶。答有。若此房舍。天龙夜叉薜荔伽拘槃荼毗舍遮罗刹等非人作。比丘取敷。不自举不教人举。得突吉罗是人。若先破戒若贼住若先来白衣作房舍。比丘取敷。若不自举若不教人举。得突吉罗。若是房舍。属比丘尼僧。比丘取敷。不自举不教人举。得突吉罗。若是房舍。属外道出家。比丘取敷不自举不使人举。得突吉罗。问颇比丘。嗔恨不喜。僧房舍中。若自牵若使人牵。作如是言。汝出去灭去。以是因缘不异。不得波逸提耶。答有。若牵出天龙夜叉薜荔伽拘槃荼毗舍遮罗刹等非人作比丘。比丘若自牵若使人牵出。得突吉罗。若牵恶比丘出。得突吉罗。若牵恶比丘衣钵出。得突吉罗。若牵曳外道出家出。得突吉罗。问颇比丘。知余比丘僧房舍中先敷卧具。后来强敷卧具。作如是念。若不乐者自当出去。是因缘故不异。不得波逸提耶。答有。是诸房舍。属天龙夜叉薜荔伽拘槃荼毗舍遮罗刹等非人。是中强敷卧具。得突吉罗。若是房舍。属先破戒贼住若先来白衣。是中强敷卧具。得突吉罗。若是房舍。属比丘尼僧。是中强敷卧具。得突吉罗。若是房舍。属外道出家。是中强敷卧具。得突吉罗。若比丘。除水以余有虫汁。浸草土作泥。随所杀虫数。得波逸提。问颇比丘。过若二若三重覆舍。不得波逸提耶。答有。若以板覆。若优尸罗草。若鸟翅覆者无罪。问颇比丘。众僧不差教诫比丘尼。不得波逸提耶。答有。若先破戒。若贼住比丘尼。若先来白衣。若诸摈人。不共住人。种种不共。住人教诫如是。等比丘尼得突吉罗。问颇比丘。僧差教诫比丘尼。乃至日没。不得波逸提耶。答有。若先破戒。若贼住比丘尼。若先来白衣。若诸摈人。不共住人。种种不共住人。教诫如是等比丘尼。得突吉罗。问颇比丘。语比丘言。汝为供养财利因缘故。教诫比丘尼。不得波逸提耶。答有。若受法比丘。语不受法比丘。不受法比丘。语受法比丘言。汝为供养财利因缘故。教诫比丘尼。得突吉罗。问颇比丘。与比丘尼共道行。乃至一聚落。不得波逸提耶。答有。若诸比丘尼。先破戒。若贼住比丘尼。若先来白衣。若不能女。若二道合一道。若诸摈人。不共住人。种种不共住人。共道行。得突吉罗。问颇比丘。与比丘尼共期载舡。若上水若下水。不得波逸提耶。答有。若诸比丘尼。先破戒。若贼住比丘尼。若先来白衣。若不能女。若二道合一道。若诸摈人。不共住人。种种不共住人。期共载舡上水下水。得突吉罗。问颇比丘。与非亲里比丘尼衣。不得波逸提耶。答有。受法比丘。与不受法比丘尼衣。不受法比丘。与受法比丘尼衣。若先破戒。若贼住比丘尼。若先来白衣。若诸摈人。不共住人。种种不共住人。狂人散乱心人。病坏心人。与如是等比丘尼衣。得突吉罗。问颇比丘。与非亲里比丘尼作衣。不得波逸提耶。答有。若受法比丘。与不受法比丘尼作衣。不受法比丘。与受法比丘尼作衣。若先破戒。若贼住比丘尼。若先来白衣。若诸摈人。不共住人。种种不共住人。狂人散乱心人。病坏心人。与如是等比丘尼作衣。得突吉罗。问颇比丘。独与比丘尼屏处坐。不得波逸提耶。答有。若比丘尼先破戒。若贼住比丘尼。若先来白衣。若诸摈人。不共住人。种种不共住人。狂人散乱心人。病坏心人。与如是等比丘尼独屏处坐。得突吉罗。问颇比丘。独与女人露地坐。不得波逸提耶。答有。若与天龙夜叉薜荔伽拘槃荼毗。舍遮罗刹等非人女。独共露处坐。若与不能女若二道合一道女人。独共露处坐。皆突吉罗。问颇比丘。知比丘尼赞因缘得食食。不得波逸提耶。答有。若比丘尼先破戒。若贼住。若先来白衣。若不能女。若二道合一道。若诸摈人。不共住人。种种不共住人。若作书若遣使若示相。若展转赞因缘故得食食。突吉罗。若受法比丘。不受法比丘尼赞因缘得食食。不受法比丘。受法比丘尼赞因缘得食食。得突吉罗。问颇比丘数数食。不得波逸提耶。答有。若檀越请明日食。比丘往至。檀越言。小住待食。常自恣请。除五种食请。与余食。若与不净食。若净食不净食杂。问颇比丘。不病于作福舍。过一食。不得波逸提耶。答有。若是福舍。属天龙夜叉薜荔伽拘槃荼毗舍遮罗刹等非人。过一食得突吉罗。若诸福舍属比丘。是中过一食得突吉罗。若是福舍。属比丘尼式叉摩尼沙弥沙弥尼。是中过一食。得突吉罗。若是福舍。属诸亲里。是中过一食无罪。若比丘自作福舍。是中过一食。无罪。问颇比丘。他家自恣与食。过两三钵取。不得波逸提耶。答有。若天祠中过两三钵取。得突吉罗。若诸天龙夜叉薜荔伽鸠槃荼毗舍遮罗刹等。若受法比丘。不受法比丘檀越舍取。若不受法比丘。受法比丘檀越舍取。过两三钵。得突吉罗。于是家中坐自恣食无罪。问颇比丘尼檀越舍过两三钵取食。不得波逸提耶。答有。若天祠中取过两三钵。得突吉罗。若诸龙夜叉薜荔伽鸠槃荼毗舍遮罗刹等非人舍。取过两三钵。得突吉罗。若受法比丘尼。不受法比丘尼檀越舍取。若不受法比丘尼。受法比丘尼檀越舍取。过两三钵。得突吉罗。于是家中坐自恣食。无罪。问颇比丘。知比丘食已。不受残食法。从座处起。语言。汝自恣食。欲恼令疑悔故。不得波逸提耶。答有。若除五种食。劝食余食。若劝食不净食。若净食不净食杂。不得波逸提。问颇比丘。别象食不得波逸提耶。答有。受一切时故无罪。问拘耶尼国用何时应食。答若此间宿。用此间时。若彼间宿。用彼间时。余二方亦如是。问拘耶尼国残宿食。应食不。答言。不得。弗婆提亦如是。问郁单越残宿食。应食不。答彼无我所无所属。随意食。无罪。问若手若钵。若二若三澡豆洗。残余腻气不尽。名为洗不。答若用心。若二若三澡豆洗。名为洗也。比丘三种。名为共食内宿。若比丘。比丘僧。与学沙弥。比丘尼四种。名为共食内宿。比丘尼。比丘尼僧。与学沙弥尼。式叉摩尼。是四种人。内宿不应食。若食得突吉罗。若白衣若沙弥。为自身共食内宿。比丘食无罪

问。若比丘求水瓶误取酥油瓶。应破应弃不。答言。不应。有二种触食。食无罪。一清净持戒比丘。误触。二破戒比丘无惭愧触。是二俱净。若比丘。为沙弥为白衣故。担食于道行。还与沙弥白衣。沙弥白衣持与比丘。比丘以共举宿故不取。佛言。若比丘先无心自为得食。问若水浊应饮不。答若先疑不应饮。若先无疑得饮。问受法比丘。从不受法比丘边受食。可食不。答言。得食。不受法比丘。从受法比丘受食得食。问颇有比丘。乞美食不得波逸提耶。答有。若从诸亲里乞无罪。问除水用余有虫汁。得波逸提耶。答有。除水若用有虫汁。随所杀虫数。得波逸提。问颇比丘。食如是食堕大罪耶。答有。女人名男子食。若食是食得大罪。问颇比丘。食家中坐。不得波逸提耶。答有。是家中童女为主是。问颇比丘。食家中强坐。不得波逸提耶。答有。若在童女家强坐是。问颇比丘。自手与裸形梵志食。不得波逸提耶。答有。若与不净食。若与净食不净食杂。不得波逸提。问颇比丘。观军发行。不得波逸提耶。答有。若军中有应死囚杀。观无常故无罪。问颇比丘。一时作百罪千罪。过百千罪耶。答有。若比丘嗔意。把沙把小豆胡豆。洒散大众。随所著人得罪

问颇比丘。知比丘粗罪。故覆藏乃至一宿不得波夜提耶。答有。若覆先破戒若贼住若先来白衣。若诸摈人不共住人种种不共住人。得突吉罗。问颇比丘。语他比丘言。来至诸家。我是中令与汝多美饮食。是比丘后不使与。作是言。汝长老还去。我不乐与汝共坐起言语。我乐独坐起言语。驱是比丘。故欲令乃至小许时得恼。以是因缘不异者。不得波夜提耶。答有。若天龙夜叉薜荔伽拘槃茶毗舍遮罗刹等非人。受戒作比丘。比丘若驱突吉罗。又驱余出家者。得突吉罗。问颇比丘。露地可烧物着火中。不得波夜提耶。答有。若比丘以苏油胡麻小豆磨沙豆着火中。得突吉罗。问颇比丘。如法僧事与欲已。后还说过。不得波夜提耶。答有。若受法比丘。与不受法众僧欲。不受法比丘。与受法众僧欲。后还说过。得突吉罗。问若比丘。与未受具戒人共宿二夜。第三夜与女人共宿。得名转宿不。答不得女人边。得波夜提。问若比丘。与未受具戒人共二宿。第三夜与不能男共宿。得名转宿不。答不得不能男边。得突吉罗。问若比丘。与未受具戒人共二宿。第三夜与黄门共宿。得名转宿不。答不得黄门边。得突吉罗。问颇有比丘。与未受具戒人共二宿。第三夜与二根人共宿。得名转宿不。答曰。不得二根人边。得突吉罗。问若比丘。与未受具戒人共二宿第三夜与摈人共宿。得名转宿不。答不得摈人边。得突吉罗。问若比丘。与未受具戒人共二宿。第三夜与灭摈沙弥共宿得名转宿不。答不得灭摈沙弥边得波夜提问若比丘。与未受具戒人共二宿。第三夜与变化沙弥共宿。得名转宿不。答得。若不知是化人。得突吉罗。若知是化人无罪。问比丘人所有金银琉璃座处。得坐不。人所有金银琉璃器得食不。答不应坐不应食。问比丘天所有金银琉璃座处应坐不。答言。应坐。天上所有金银琉璃器应食不。答言。应食。问天上金银琉璃车磲马瑙地比丘得行不。答言。应行。问颇比丘。捉如是宝。得僧伽婆尸沙耶。答言。有。若捉宝女。得僧伽婆尸沙。若捉轮宝珠宝。得波夜提。捉化宝。得突吉罗。若知是化无罪。问颇比丘。不作净染衣着。不得波夜提耶。答言有。是衣经净纬不净。纬净经不净。若二俱不净。不净者。骆驼毛牛毛羖羊毛若杂织。如是等不净衣。不作净染着。得突吉罗。问颇比丘常洗浴。不得波逸提耶。答言有。若比丘天雨时空地立洗浴无罪。问若比丘杀恶兽毒蛇等。不得波逸提耶。答得波逸提。若杀余善兽。亦得波逸提。问颇比丘。故令他疑悔。令是比丘乃至少时生恼。不得波逸提耶。答有。若先破戒若贼住先来白衣。除生时受具足戒时。若以余事令他生疑悔。得突吉罗。问颇比丘。指击擽他。不得波逸提耶。答有。若指击擽天龙夜叉薜荔伽拘槃荼毗舍遮罗刹等非人。得突吉罗。若击擽身根坏人。得突吉罗。若比丘除水余汁戏。得突吉罗。问颇比丘。与女人共宿。不得波逸提耶。答有。若竹林若树下与女人共宿。得突吉罗。若与天龙夜叉薜荔伽拘槃荼毗舍遮罗刹等非人女共宿。得突吉罗。若与大母畜生共宿。得波逸提。若小雌畜生如鸡等共宿。得突吉罗。问颇比丘。若自怖若使人怖他比丘。不得波逸提耶。答有。若怖先破戒若贼住若先来白衣。除六事若以余事。若自怖若使入怖他比丘。得突吉罗。若受法比丘。怖不受法比丘。若不受法比丘。怖受法比丘。得突吉罗。问颇比丘。若自藏若使人藏他比丘衣钵户钩革屣针筒等。不得波逸提耶。答有。若藏所禁钵。得突吉罗。若藏所禁衣。得突吉罗。若藏先破戒若贼住若先来白衣衣钵等物。得突吉罗。问颇比丘。与他比丘衣。他不归还取用。不得波逸提耶。答有。若与先破戒贼住若先来白衣衣。不归还取。得突吉罗。问比丘衣应与何人得作净耶。答应与五众比丘比丘尼式叉摩尼沙弥沙弥尼。问应从谁边受衣。答应从五众受。问颇比丘。以无根僧伽婆尸沙罪。谤他比丘。不得波逸提罪耶。答有。若谤先破戒若贼住若先来白衣。得突吉罗。问颇比丘。与女人共期道行。不得波逸提耶。答有。若与天龙夜叉薜荔伽拘槃茶毗舍遮罗刹等非人女期共道行。得突吉罗。若与不能女人若二道合一道女人期共道行。得突吉罗。若与化女人期共道行。得突吉罗。若知是化女人无罪。问颇比丘与贼众期共道行。不得波逸提耶。答有。若贼众是比丘。比丘期共道行。得突吉罗。若天龙夜叉薜荔伽拘槃荼毗舍遮罗刹等非人作贼众。比丘期共道行。无罪。问颇比丘。与未满二十岁人受具戒。不得波逸提耶。答有。若与曾嫁式叉摩尼受具戒是也。问云何名掘地。答掘生地不曾毁坏者是也。又若比丘过夏四月。无病从檀越乞酥。若得波逸提。若不得突吉罗。若乞油蜜石蜜姜椒荜茇罗黑盐。若得波逸提。若不得突吉罗。若乞呵梨勒阿摩勒鞞醯勒多罗耶摩那伽楼迦卢醯尼。若得不。得突吉罗。问颇比丘。说戒时作是言。我未学是戒。先当问诸比丘持修多罗持毗尼持摩多罗迦者。不得波逸提耶。答有。若作不净教故。作如是言。我不学是戒。先当问持修多罗持毗尼持摩多罗伽者。无罪。若诸受法比丘。遣使语不受法比丘言。汝来受是五法。不受法比丘言。我不能学如是。无罪。不受法比丘。遣使语受法比丘言。汝来学我法舍离五法。受法比丘言。我不能学如是。无罪。问颇比丘。盗听诸比丘斗乱诤讼。作是念。是诸比丘所说。我当忆持。不得波逸提耶。答有。是事是比丘比丘尼事。比丘式叉摩尼事。比丘沙弥事。比丘沙弥尼事。是中盗听。得突吉罗。若使畜生往听。得突吉罗。若使余比丘听。得突吉罗。若使余比丘听已还语。得波逸提。问颇比丘。僧事始发默然起去。不得波逸提耶。答有。若发时去即发时还。得突吉罗。问颇比丘。不敬畏他。不得波逸提耶。答有。若诸上座说非法非善非佛教。下座言。此非法非善非佛教。无罪。若下座说法说善说佛教。上座言。此非法非善非佛教。得突吉罗。问颇比丘。过中得饮苦酒不。答若无酒气无糟清净得饮。问若诸根汁。枝汁茎汁叶汁华汁果汁。是诸汁等。比丘何时应饮。答随离酒势时应饮。问颇比丘。过中不白他比丘入聚落。不得波逸提耶。答有。若比丘与摈比丘共住不白入聚落。得突吉罗。若不受法比丘。与受法比丘。共住。不白入聚落。得突吉罗。若受法比丘与不受法比丘共住。不白入聚落。得突吉罗。若病若飞去无罪。若与哑比丘聋比丘哑聋比丘共住。不白入聚落。得突吉罗。若比丘在地。不白高处比丘入聚落。得突吉罗。若在高上。不白在地比丘入聚落。得突吉罗。若在界内。不白界外比丘入聚落。得突吉罗。若在界外。不白界内比丘入聚落。得突吉罗。若俱在界内。若坐若立。不白入聚落。得波逸提。问入何处不白余比丘。不得波逸提耶。答曰。若入三处。若入住处。入阿练若处。若入近聚落僧坊。不须白。问颇比丘。受人请食。前食后行至他家。不得波逸提耶。答曰有。除五种食请。与余食。不得波逸提。若不净食净食不净食杂。得突吉罗。若请处食不足。余家求无罪。问颇比丘。刹利灌顶王。地未了未藏宝。若过门闑。若门闑边过。不得波逸提耶。答曰有。若过诸天王诸龙王诸夜叉王阿修罗王迦楼罗王门闑门闑边。过不犯。问颇比丘。说波罗提木叉时言。我今始知是法半月半月波罗提木叉经中说。不犯波逸提耶。答曰有。若比丘尼僧说戒时。比丘作是语。我始知是法半月半月波罗提木叉中说。得突吉罗。若比丘僧说戒时。比丘尼作是言。我始知是法半月半月波罗提木叉中说。得突吉罗。问颇比丘。若骨若齿若角作针筒。不得波逸提耶。答曰有。若为他使人作。得突吉罗。若为他故作自用。得突吉罗。问颇比丘。过八指作床足。不得波逸提耶。答曰有。若以珠脚牙脚。若尖脚作床足坐。得突吉罗。问颇比丘。以兜罗绵贮褥。若自贮若使人贮。不得波逸提耶。答曰有。若经净纬不净。纬净经不净。若二俱不净。不净者。若骆驼毛牛毛羖羊毛若杂织。以兜罗绵贮。得突吉罗。问颇比丘。作雨浴衣若过量。不得波逸提耶。答曰有。若经净纬不净。纬净经不净。若二俱不净。不净者。若骆驼毛牛毛羖羊毛。若杂织广长过量作。得突吉罗。问颇比丘。作覆疮衣广长过量。不得波逸提耶。答曰有。若经净纬不净。纬净经不净。若二俱不净。不净者。若骆驼毛牛毛羖羊毛。若杂织过量作。得突吉罗。问颇比丘。作尼师檀广长过量。不得波逸提耶。答曰有。若经净经不净。纬净经不净。若二俱不净。不净者。若骆驼毛牛毛羖羊毛。若杂织广长过量作。得突吉罗。问颇比丘。等佛衣量作衣。不得波逸提耶。答有。若经净纬不净。经净经不净。若二俱不净。不净者。若骆驼毛牛毛羖羊毛。若杂织若作。得突吉罗(波夜提竟)

    问七灭诤法

问颇有诤。不用七灭法一一灭。得名灭耶。答有。若比丘来欲灭事。事未决断。即便命终。是事名为灭。又自言。我是白衣。若沙弥。若非比丘。若不见摈人。不作摈人。不舍恶邪摈人。不共住人。种种不共住人。若贼住人。先来白衣。若不能男。若言犯四重罪。若杀父母。杀阿罗汉。破僧。恶心出佛身血。若是比丘勤读诵经。若勤作福业。若勤断余事若远行。若长病。若到他国不还。是事皆名为灭。又复始发灭是事时。即便命终。若自言我是白衣。乃至到他国不还故。是事皆名为灭(七灭诤法竟)

十诵律卷第五十三十诵律卷第五十四(第九诵之三)

        后秦北印度三藏弗若多罗译

    问上第四诵七法

优波离问佛。若比丘白四羯磨受戒时。不说几事名。不名受具戒。答若不说四事名。不名受具戒。何等四。一和上。二众僧。三求受戒人。四羯磨。不说是四事名。不名受具戒。若说是四名。得名受具戒。又复不说三事名。不名受具戒。何等三。一众僧。二求受戒人。三羯磨。不说是三名。不名受具戒。说是三名。得名受具戒。又复不说二事名。不名受具戒。何等二。一求受具戒人。二羯磨。不说是二名。不名受具戒。若说是二名。得名受具戒。问颇有比丘。四人界内一时受具戒。得名为受戒耶。答有。若四处展转与欲得。问若诸比丘。与拘耶尼人受戒。是人得名受戒不。答得名受戒。与受具戒人得罪。弗婆提人亦如是。问若诸比丘。与郁单越人受戒。是人得受戒不。答不得。彼无所属故。问若诸比丘。与先破戒人受戒。是人得受戒不。答不得。问若诸比丘。与贼住人受戒。是人得戒不。答不得。问若诸比丘。与无和上人受戒。得受戒不。答是人得受戒。说羯磨人众僧得罪。若诸比丘。与哑人受戒。是人得受戒不。答不得。若诸比丘。与聋人受戒。得受戒不。答不得。若与哑聋人受戒。得受戒不。答不得。问若以哑人足数受戒。得受戒不。答不得。若以聋人足数受具戒。得受戒不。答曰。不得。若以聋人哑聋人足数受戒。得受戒不。答不得。问养儿欲出家。应问何母答。应问所养母。问如佛所言。父母不听不得出家受戒。颇有父母不听得出家受具戒耶。答有。若父母是畜生得。问如佛所说。故杀父母人不得出家受戒。若出家受戒应灭摈。颇有杀父母人。诸比丘与受戒。是人得受戒耶。答有。若杀畜生父母。又复若异想异因缘杀父母。是人得受戒。不应灭摈。问如佛所说。欲出家人二时白众僧。出家时。剃发时。颇不二时白得出家受戒耶。答有。若是人父母是畜生。问如佛所言。污比丘尼人不得出家受戒。若出家受戒应灭摈。颇有污比丘尼人。诸比丘与受戒。是人得出家受戒耶。答有。若八人以八事污比丘尼。比丘尼名污。是八人不名污比丘尼。又复一人以八事污比丘尼。比丘尼名污。是人不名污比丘尼。问如佛所言。贼住人不应出家受戒。若出家受戒应灭摈。几种名贼住。答若比丘。于四波罗夷中随所破。入众僧中。听白羯磨白二羯磨白四羯磨。作布萨自恣。听十四人羯磨。亦名贼住。问如佛言越济人不得出家受戒。若出家受戒应灭摈。云何名越济人。答若比丘不舍戒入外道。作外道相。说外道见。受外道业是也。问如佛所言。杀阿罗汉人不应出家受戒。若出家受戒应灭摈。颇杀阿罗汉人。诸比丘与受戒。是人得出家受戒耶。答有。若杀阿罗汉。不得五逆罪者是。问求受戒人在地。与受戒人在高上。得名受戒不。答不得。求受戒人在高上。与受戒人在地。得名受戒不。答不得。求受戒人在界内。与受戒人在界外。得名受戒不。答不得。求受戒人在界外。与受戒人在界内。得名受戒不。答不得。若求受戒人与受戒人。俱在界内若坐若立。得名受戒。问诸比丘在地。足数人在高上。与受戒。得名受戒不。答不得。诸比丘在高上。足数人在地。与受戒。得名受戒不。答不得。诸比丘在界内。足数人在界外。与受戒。得名受戒不。答不得。诸比丘在界外。足数人在界内。与受戒。得名受戒不。答不得。诸比丘足数人。俱在界内若坐若立。与受戒。得名受戒。问颇有一人在四住处中。诸比丘与受戒。得名受戒耶。答得。若床榻材木连接四界与受戒。得名受戒。问颇有一足数人在四住处中与受戒。得名受戒耶。答有。若床榻材木连接四界与受戒。得名受戒(受戒法竟)

问布萨法

优波离问佛。若比丘于众僧前与欲。谁应与说。答诸比丘随意与说。问若僧坊近聚落。齐几名不失衣。答齐聚落界外。问诸比丘于先无僧坊聚落中。起僧坊未结界。齐几名为界。答齐是聚落界通行处。问若比丘无聚落阿练若处。始起僧坊未结界。是中齐几名为界。答面齐一拘卢舍。是中诸比丘。应一处和合说波罗提木叉作诸羯磨。是中诸比丘。不应别布萨别羯磨。若别布萨别羯磨。一切诸比丘得罪。问说戒人在地。诸比丘在高上。得名布萨不。答不得说戒。人在高上。诸比丘在地。得名布萨不。答不得说戒。人在界内。诸比丘在界外。得名布萨不。答不得说戒。人在界外。诸比丘在界内。得名布萨不。答不得。若说戒。人诸比丘俱在界内。若坐若立。得名布萨。问若诸比丘夜垂过。诸比丘忆念。今日布萨。诸比丘当说波罗提木叉不。答不应说。若说波罗提木叉竟。诸比丘不成布萨。问若比丘受他清净已出界。得何罪。答得突吉罗。问谁应教授比丘尼。答旧比丘。问若众僧坏为二部。比丘尼应从何部教授。答随说如法者。若无说如法者。闼利吒比丘应出界外教授比丘尼。问若诸比丘舍界。不离衣界亦舍不。答亦舍。若舍不离衣界。大界亦舍不。答不舍。问若先界不舍。更得结界若大若小不。答不得。问若诸比丘布萨时。说戒序及四波罗夷乃至七灭诤法。一切僧得名说波罗提木叉布萨不。答言得。问如佛所言。有一住处。布萨说戒时。诸比丘非法别众。非法和合众。如法别众。如法和合众。世尊。云何非法别众说戒。答言。诸比丘别为二部。不如法说戒。所应说事不说。谁应说而不说。乃至所应说而不说。是名非法别众说波罗提木叉。云何非法和合众说波罗提木叉。答诸比丘一心和合不如法说戒。所应说事不说。谁应说而不说。乃至所应说而不说。是名非法和合众说波罗提木叉。云何如法别众说波罗提木叉。答诸比丘别为二部如法说戒。所应说事而说。谁应说而说。乃至所应说而说。是名如法别众说戒。云何如法和合众说波罗提木叉。诸比丘和合一处如法说戒。所应说事而说。谁应说而说。乃至所应说而说。是名如法和合众说波罗提木叉。问如佛言。一住处诸比丘小不了如羺羊。云何小不了如羺羊。答若比丘。不知布萨。不知布萨羯磨。不知说波罗提木叉。不知会坐是。问颇比丘。僧事未讫从坐起去。不得波夜提耶。答有。若大小行若不离闻处。问如佛言宿受欲人。不应共布萨说戒。除僧未起。云何名僧未起。答乃至四人坐未起。云何名起。乃至减四人。问若狂人足数说戒。得名说戒不。答不得。若散乱心人病坏心人足数说戒。得名说戒不。答不得。若众僧未与痴比丘作痴羯磨。不应离是比丘说波罗提木叉。若作痴羯磨已。是比丘若在若不在。诸比丘随意布萨说波罗提木叉。作诸羯磨。问诸比丘在地。足数人在高上说戒。得名说戒不。答不得。诸比丘在高上。足数人在地说戒。得名说戒不。答不得。诸比丘在界内。足数人在界外说戒。得名说戒不。答不得。诸比丘在界外。足数人在界内。得名说戒不。答不得。诸比丘足数人俱在界内。若坐若立说波罗提木叉。得名说波罗提木叉。问若哑人足数说戒。得名说戒不。答不得。若聋人哑聋人足数说戒。得名说戒不。答不得。问受法比丘。与不受法比丘说戒。得名说戒不。答不得。不受法比丘。与受法比丘说戒。得名说戒不。答不得。问受法比丘。以不受法比丘足数说戒。得名说戒不。答不得。不受法比丘。以受法比丘足数说戒。得名说戒不。答不得。问颇比丘。一界内四处一时说戒。得名说戒不得罪耶。答有。展转与欲清净是。问颇一比丘与四处说戒。得名说戒不得罪耶。答有。若以床榻材木连接四界。若坐若立说戒是。问颇一比丘足数四住处说戒。得名说戒不得罪耶。答有若床榻材木连接四界。若坐若立足数。得说波罗提木叉(布萨法竟)

问自恣法

优波离问颇比丘。十日未至自恣。得名自恣不得罪耶。答有。比丘若二若三若四。促作布萨出界去。彼间自恣无罪。问颇比丘。未至后自恣。而自恣。不得罪耶。答有。若比丘后安居。受七日出界去。彼间自恣。彼间比丘少。随是客比丘自恣。无罪。问自恣人在地。诸比丘在高上。得名自恣耶。答不得。自恣人在高上。诸比丘在地。得名自恣耶。答不得。自恣人在界内。诸比丘在界外。得名自恣不。答不得。自恣人在界外。诸比丘在界内。得名自恣不。答不得。自恣人诸比丘俱在界内。若坐若立。得名自恣。诸比丘在地。足数人在高上自恣。得名自恣不。答不得。诸比丘在高上。足数人在地自恣。得名自恣不。答不得。诸比丘在界内。足数人在界外自恣。得名自恣不。答不得。诸比丘在界外。足数人在界内自恣。得名自恣不。答不得。诸比丘足数人。俱在界内若坐若立。得名自恣。问诸比丘遮哑比丘自恣。得遮不。答不应遮。诸比丘遮聋人自恣。得遮不。答不应遮。诸比丘遮哑聋人自恣。得遮不。答不。得遮问哑人遮诸比丘自恣。得遮不。答不应遮。若聋人遮诸比丘自恣。得遮不。答不应遮。若哑聋人遮诸比丘自恣。得遮不。答不应遮。问如佛言自恣时不应去。有比丘有住处。有比丘无住处。有比丘有住处无住处。颇有比丘。自恣时至彼三处。不得罪耶。答有。安居比丘。闻彼比丘欲来斗乱破此比丘自恣。尔时安居比丘作是念。我不欲闻是斗乱事。故至彼有比丘有住处有比丘无住处有比丘有住处无住处去无罪。有病比丘。遮不病比丘自恣。僧应语是病比丘。汝自病。莫遮无病比丘自恣。何以故。病人少安隐故。有不病比丘。遮病比丘自恣。僧应语无病人。莫遮病比丘自恣。何以故。病人少安隐故。有病比丘遣使。遮不病比丘自恣。僧应语是使。长老。汝莫受病人语遮不病比丘自恣。何以故。病人少安隐故。是使到病人边语。长老。僧约敕汝。病莫遮不病比丘自恣。何以故。病人少安隐故。病人言。为遮。是病比丘得突吉罗。是使受病比丘语。遮不病比丘自恣。是使得突吉罗。不病比丘遣使。遮病比丘自恣。僧应语是使。长老。汝莫受不病比丘语遮病比丘自恣。何以故。病人少安隐故。是使到不病比丘边言。僧约敕汝。莫遮病比丘自恣。何以故。病人少安隐故。若不病比丘言为遮。得突吉罗。若使比丘。受不病比丘语。遮病比丘自恣。是使得突吉罗。问如佛言有一住处。自恣时识事不识人。何者是事何者是人。答事名罪。罪因缘起。得罪者。名为人。问如佛说比丘若得清净共住同见比丘。是中云何名同见。答诸比丘若见波罗夷罪如所见说。若见僧伽婆尸沙罪。如所见说。若见波逸提罪波罗提提舍尼突吉罗罪。如所见说。是名同见。问若比丘遮他比丘自恣。彼转根遮比丘尼自恣。成遮。比丘遮比丘自恣。自转根。比丘尼所不成遮。比丘尼遮比丘尼自恣。彼转根。比丘尼所不成遮。比丘尼遮比丘尼自恣。此自转根。比丘所成遮问受法比丘。与不受法比丘共自恣。得名自恣不。答不得。不受法比丘。与受法比丘共自恣。得名自恣不。答不得。受法比丘。以不受法比丘足数。得自恣不。答不得。不受法比丘。以受法比丘足数。得自恣不。答不得。哑人足数共自恣。得自恣不。答不得。聋人哑聋人足数共自恣。得名自恣不。答不得。问颇有界内。四处一时自恣。得名自恣耶。答有。转展与欲得。问颇有一比丘。四住处自恣。得名自恣无罪耶。答有。若床榻材木连接四界得。问颇有一比丘。足四处数自恣。得名自恣耶。答有。若床榻材木连接四界得(自恣法竟)

问安居法

问若比丘安居己心生疑悔。我得安居不耶。是人得名安居不。答言得。是人应与安居衣不。答言。应与。问若优婆夷欲出家。遣使到比丘所言。大德来。我欲出家。是比丘破安居去。应去不。答得去。问比丘尼安居中。应与忆念比尼不痴比尼。遣使到比丘所言。大德来。今僧与我忆念比尼不痴毗尼。是比丘应破安居去不。答得去。若是比丘中道。闻是比丘尼命终。若反戒若入外道。若八难中一一难起。应去不。答不应去。若去得何罪。答得突吉罗。问诸比丘夏三月未竟摈比丘。是人应摈不。答应摈。应与安居衣分不。答言。不应与。若比丘自恣七日在。受宿出界去。无罪。若六日五日四日三日二日一日在。受宿出界去。无罪。问安居比丘有几自誓。答有五。钵自誓。衣自誓。时自誓。安居自誓。语自誓。问颇比丘在彼房。衣亦在彼房。名破安居。亦名离衣宿。亦名坏自誓。得罪耶。答言有。若比丘后安居。独入房若置三衣。着床榻上若衣架上。不受七日法。飞在上住至于地了。是名破安居。亦名离衣宿。亦名违自誓。得罪。问诸比丘众多住处。共一界内安居。自恣竟舍是大界。各以寺墙壁作界。是中檀越施安居众僧现前可分物。是物应属谁。答虽离大界。应属本大界内安居众僧。云何应分。次第等分。第四分与沙弥。问颇有一比丘。四住处安居。亦名安居不。答若床榻材木连接四界。是中安居。得名安居。又问。是比丘何处应与安居施物。答四处一切合与一分。问若比丘虚空中受安居。得名安居不。答不得。一切虚空无界故。一切僧事诸羯磨不成。问若比丘船箄筏上安居。得名安居不。答若是船箄筏上水下水不得。若系在柱若树若橛。若石沈不移。得安居。是比丘何处应与安居衣物分。答即随船箄筏上所得。问若比丘。不受前安居。不受后安居。名为何人。答是破安居无所得人

问药法

优波离问佛。若以酥油着酒中。可饮不。答比丘若病得饮。不病不得饮。即日受时药时分药七日药尽形寿药。共和合一处。中前应服。时药力故。过中不应服。即日受时分药七日药尽形药。共合一处。时分应服。时分药力故。过时分不应服。即日受七日药尽形药。共合一处。七日应服。七日药力故。过七日不应服。尽形药随意应服。即日受时药不净。即日受时分药七日药尽形药。共合一处不应服。即日受时分药不净。即日受七日药尽形药。共合一处不应服。即日受七日药不净即日受尽形药。共合一处不应服。尽形药应尽形服。问时药时分药七日药尽形药。是诸药举残宿。得服不。答不得又问。若比丘先自取。后从净者边受。可服不。答。不得。又问。是诸药手受口受。无病应服不。答不应服。问手受口受。病人得服不。答应服。问若火在净地。净者在不净地。以火作净。得净不。答得净。可食不。答不得食。若火在不净地。净者在不净地。以火作净。得净不。答得净。可食不。答不可食。若火在不净地。净者在净地。以火作净。得净不。答得净。可食不。答不得食。问若火在净地。净者在不净地。以火作净。得净不。答得净。可食不。答不得食。是中立以炎作净。得净不。答得净。可食不。答不得食。是中立以断炎作净。得净不。答得净。可食不。答不得食。是中立以炭作净。得净不。答得净。可食不。答不得食。是中立以灰火作净。得净不。答得净。可食不。答不得食。是中立以热灰作净。得净不。答得净。可食不。答不得食。问若火在净地。净者在高上。以火作净。得净不。答得净。可食不。答不得食。是中立以炎火掷作净。得净不。答得净。可食不。答得食。是中立以炎作净。得净不。答得净。可食不。答不可食。是中立以断炎作净。得净不。答得净。可食不。答可食。是中立以灰炭作净。得净不。答得净。可食不。答不得食。是中立以热灰洒作净。得净不。答得净。可食不。答得食。问若火在不净地。净者在净地。是中立以炎作净。得净不。答得净。可食不。答不得食。是中立以断炎作净。得净不。答得净。可食不。答得食。是中立以炭作净。得净不。答得净。可食不。答不得食。是中立以灰炭作净。得净不。答得净。可食不。答不得食。问若火在不净地。净者在高上。以火作净。得净不。答得净。可食不。答不得食。是中立以炎火掷作净。得净不。答得净。可食不。答得食。是中立以炎作净。得净不。答得净。可食不。答不得食。是中立以断炎作净。得净不。答得净。可食不。答可食。是中立以灰炭作净。得净不。答得净。可食不。答不得食。是中立以热灰洒作净。得净不。答得净。可食不。答得食。问火在净地。三碣在不净地。是中煮食可食不。答不可食。问若一碣在净地。二碣在不净地。是中煮食可食不。答不可食。若二碣在净地。一碣在不净地。是中煮食得食不。答不得食。若火在不净地。三碣在净地。是中煮食得食不。答以断炎煮得食。问若比丘自以火以刀以爪作净。得净不。答得净。得食不。答除火净。余残得食。若比丘以火作净。自不应食。余比丘亦不应食。问谁于鬼村得波逸提。答若作净者是净地。羯磨佛在时舍。问果在不净地。净者在净地。若以火刀。爪作净。得净不。答得净。可食不。答不可食。若果在净地。净者在不净地。若以火刀爪作净。得净不。答得净。可食不。答不可食。问若以酥油着酒中煮。可饮不。答若离酒势得饮。问象乳酪酥可饮不。答可饮。问八种浆非时可饮不。答若无酒气味。无食清净可饮。问天食过中可食不。答可食。问应七日受不。答可受

问衣法

问摈人应羯磨分衣不。答不得摈人。云何分衣。答自受分展转分堕筹分。问颇比丘。从非亲里居士居士妇乞衣。不得尼萨耆波逸提耶。答除别房衣白衣家中施衣安居衣。从余非亲里出家乞。得突吉罗。问为一人故送衣。四人同意故取。应取不。答不应取。若为四人故送衣。一人同意取。可取不。答可取。问衣价应取不。答不应取。问若转是价作衣钵等余净物。可取不。答可取。问颇比丘。施僧衣还自取。大得福无罪耶。答有。若一比丘独一处住。是中施僧衣。余比丘不来。还自取用。大得福无罪。若比丘。语余比丘施僧物。语已命终。是施物僧。应用羯磨分不。答不应。问当云何分。答以自受分展转分堕筹分。何以故。物非现前僧物故。问安居比丘灭摈。应与安居衣分不。答不应。问聋比丘云何名得衣。答若见与衣我亦应得。盲比丘云何名得衣。答着手中若着膝上。心念。我得是衣。问与学沙弥云何应与衣分。答与大比丘等分分(分衣法竟)

    问上第五诵中八法初迦絺那衣法第一

优波离问佛。无岁比丘受作迦絺那衣。得名受衣不。答言。不得。问与学沙弥受作迦絺那衣。得名受不。答不得。问摈人受作迦絺那衣。得名受不。答不得。问犯僧残别住人。受作迦絺那衣。得名受不。答不得。问比丘如法应量作衣。受作迦絺那衣。得受不。答得受。问若比丘如法应量作纳衣。得受作迦絺那衣不。答得受。问受迦絺那衣得几种利。答得九种利。得至十夜六夜一夜。无有五因缘留僧伽梨。无有五因缘留雨浴衣。数数食别众食二时不白得入聚落。问诸比丘众多僧坊共结一界内安居。得安居不。答得名安居。诸比丘应住何僧坊。答随意住。应何处自恣。答随意自恣。何处名安居竟。答随意处至地了是。问何处应与安居衣物。答随自恣处与。又随安居日多处应与。问诸比丘多僧坊。共一界内安居。诸比丘自恣竟。受迦絺那衣。是诸比丘皆得受不。答得受。问诸比丘众多僧坊。共一界内安居。是诸比丘受自恣竟。受迦絺那衣。受已舍是大界。是诸比丘。皆名受迦絺那衣不。答皆得。问诸比丘众多僧坊。共一界内安居自恣。自恣竟受迦絺那衣。受已舍是大界。舍已舍迦絺那衣。一切比丘。皆名舍迦絺那衣不。答随舍者舍。不舍者不舍。问诸比丘安居竟。众多僧坊共结一界。受迦絺那衣。是诸比丘。皆得名受迦絺那衣不。答一切比丘得名受迦絺那衣。又问。诸比丘安居竟。众多僧坊共结一界。受迦絺那衣。受迦絺那衣已舍是大界。是诸比丘皆名受迦絺那衣不。答一切比丘皆得受迦絺那衣。问诸比丘安居竟。众多僧坊共结一界。受迦絺那衣。受已舍是大界。舍已舍迦絺那衣。一切比丘皆名舍迦絺那衣耶。答舍者舍。不舍者不舍。问颇比丘。受檀越请食。前食后到余家。不得波逸提耶。答有。若是请处在巷陌市肆边。问诸比丘四边僧坊。若八若九若十若过。共结一界安居。是诸比丘皆得安居不。答皆得。何处应住。答随意。应何处受自恣。答随意。何处名安居竟。答随意处至地了是。何处应与安居衣物。答随自恣处应与。又随安居日多处。问诸比丘四边僧坊。若八若九若十若过。共结一界安居。诸比丘自恣竟。受迦絺那衣。是诸比丘皆得名受不。答得受。问诸比丘四边僧坊。若八若九若十若过。共结一界安居。是诸比丘自恣竟。受迦絺那衣已。舍是大界。是诸比丘。皆得名受迦絺那衣耶。答皆得。问诸比丘四边僧坊。若八若九若十若过。共结一界安居自恣。自恣竟受迦絺那衣。受已舍是大界。舍已舍迦絺那衣。一切比丘皆名舍迦絺那衣耶。答随舍者舍。不舍者不舍。问诸比丘安居竟。四边僧坊。若八若九若十若过。共结一界受迦絺那衣。是诸比丘皆名得受迦絺那衣耶。答一切比丘皆得名受迦絺那衣。又问。诸比丘安居竟。四边僧坊。若八若九若十若过。共结一界受迦絺那衣。受已舍是大界。是诸比丘皆名受迦絺那衣耶。答一切比丘皆得名受迦絺那衣。问诸比丘安居竟。四边僧坊若八若九若十若过。共结一界受迦絺那衣。受已舍是大界。舍已舍迦絺那衣。一切比丘皆名舍迦絺那衣耶。答舍者舍。不舍者不舍。问诸比丘受迦絺那衣。官作闰月。何时舍迦絺那衣。答随安居日数。问诸比丘受迦絺那衣已作十四日。客比丘来作十五日。若旧比丘随客比丘。是日作布萨。若是日得布施物。应属谁。答一切。云何应分。答等分。第四分与沙弥。问若旧比丘受迦絺那衣已出界。客比丘来舍迦絺那衣。是日得施物。应属谁。答或属安居比丘。或属现前比丘。何者属安居比丘。何者属现前比丘。若夏末月得属安居比丘。余者属现前比丘。问受迦絺那衣。众僧坏为二部。一切众得名受迦絺那衣耶。答一切得受。问受迦絺那衣已。僧坏为二部。一部舍迦絺那衣。是迦絺那衣得名舍不。答如法者舍得名舍。不如法者舍不得名舍。问不净衣受作迦絺那衣。得名受不。答不得。问后安居人得受迦絺那衣不。答不得。问颇有受迦絺那衣住处得施物。但此一处自恣比丘得分耶。答有。若诸比丘夏末月受迦絺那衣。即夏末月舍。是中得施物是。问如佛言。乃至在闻处亦名舍迦絺那衣。云何是闻处。答若比丘受迦絺那衣在界外。闻僧舍迦絺那衣声。得名舍迦絺那衣(迦絺那衣法竟)

    问拘舍弥法第二

问若僧众坏为二部。诸比丘尼受半月教授法。应从何部受。答从说如法者受。若无说如法者闼赖吒比丘应出界外教授。问拘舍弥比丘毗耶离比丘舍界。得名舍不。答不得。问毗耶离比丘拘舍弥比丘舍界。得名舍不。答得舍。问俱舍弥比丘布萨处。二部共合一处。闼赖吒云何布萨。答应出界作布萨。问是中檀越来。捉上座手言。布施众僧。是施物应属谁。答随何部作上座。是物应属一部。若檀越捉第一上座第二上座手言。是物施僧。是物应属谁。答若二上座是一部上座。应属一部。若二上座各是一部。应属二部。云何应分。答次第等分。第四分与沙弥。问若众僧欲坏。知法者次第敷独坐床。中间各留一床处。是中坐应作僧羯磨。亦应教授比丘尼。是中云何名成法。答若二部随顺。闼赖吒比丘共和合是(俱舍弥法竟)

    问瞻波法第三

问若睡眠比丘众僧摈。得名摈不。答若闻白已睡眠得名摈。问若众僧睡眠摈一比丘。是比丘得名摈不。答若众僧闻白已睡眠得名摈。问若乱语愦闹时摈比丘。得名摈不。答乃至四比丘闻白声得名摈。问贼住比丘。摈比丘。不共住人种种不共住人别住比丘狂人散乱心人病坏心人足数。摈比丘。得名摈不。答不得。若痴比丘未作痴羯磨。诸比丘不得离作布萨及诸羯磨。若作痴羯磨已若来不来。诸比丘随意作布萨及诸羯磨。问颇比丘众僧事未讫从坐处起不得波逸提耶。答有。若大小行若不离闻处是问如佛言比丘不现前不应作羯磨。若作。诸比丘得罪。颇有比丘。不现前作羯磨。不得罪耶。答有。诸比丘尼。为比丘不现前。与作不礼拜不共语不问讯不供养羯磨是。问如佛言不自首不应作羯磨。颇有不自首得作羯磨耶。答有。若比丘不自首。比丘尼僧。得作不礼拜不共语不问讯不供养羯磨。诸比丘在地。有事人在高上。得作羯磨不。答不得。诸比丘在高上。有事人在地。得作羯磨不。答不得。诸比丘在界内。有事人在界外。得作羯磨不。答不得。诸比丘在界外。有事人在界内。得作羯磨不。答不得。诸比丘有事人俱在界内。若坐若立。得作羯磨。问受法比丘。与不受法比丘作羯磨。得羯磨不。答不得。不受法比丘。与受法比丘作羯磨。得羯磨不。答不得。受法比丘。以不受法比丘足数作羯磨。得羯磨不。答不得。不受法比丘。以受法比丘足数作羯磨。得羯磨不。答不得。问颇有界内一时四处作羯磨不得罪耶。答有。四处展转与欲得。问颇一比丘。于四住处中作羯磨。不得罪耶。答有。若床榻材木连接四界得。问颇一足数比丘。足四住处作羯磨。不得罪耶。答有。若床榻材木连接四界。若坐若立得(瞻波法竟)

    问般茶卢伽法第四

优波离问佛。诸比丘作灭羯磨。摈一比丘。诸比丘还舍是羯磨。得名舍不。答言。得舍。诸比丘得罪。诸比丘在地。被摈比丘在高上。得解摈不。答不得。诸比丘在高上。被摈比丘在地。得解摈不。答不得。诸比丘在界内。被摈人在界外。得解摈不。答不得。诸比丘在界外。被摈人在界内。得解摈不。答不得。若诸比丘被摈人俱在界内。若坐若立。得解摈诸比丘得罪。问比丘无比丘住处住。得僧伽婆尸沙罪。不得发露。名覆藏罪不。答不名覆藏。问若比丘得僧伽婆尸沙罪。竟日与比丘共住不发露。出界至地了。得覆藏罪耶。答不名覆藏。问若比丘得僧伽婆尸沙罪。与贼住比丘诸摈比丘别住比丘不共住人种种不共住人狂人散乱心人病坏心人共住不向说。得名覆藏不。答不得。问若比丘与哑人共住。不向哑人说。名覆藏不。答不名覆藏。不能语故。若与聋人共住不向说得名覆藏不。答不得。不闻语故。若与哑聋人共住不向说。得名覆藏不。答不得。不解不闻语故。若与边地人共住不向说。得名覆藏不。答不得。不解语故。若比丘向比丘尼说。名发露不。答不名发露。若向式叉摩尼沙弥沙弥尼优婆塞优婆夷说。得名发露不。答不得名发露。问若比丘语余比丘言。若作如是如是罪。得何等罪。云何治。不自说己作。得名发露不。答不名发露。问若比丘随覆藏罪。不别住不行摩那埵。诸比丘但与作出罪羯磨。得名出罪不。答得名出罪。诸比丘得罪。问若比丘随覆藏罪。作别住不行摩那埵。诸比丘但与作出罪羯磨。得名出罪不。答得名出罪。诸比丘得罪。问若比丘随覆藏罪。作别住行摩那埵。诸比丘与出罪羯磨。得出罪不。答得名出罪。诸比丘无罪。问若比丘覆藏罪。六夜行摩那埵。诸比丘与作出罪羯磨。得名出罪不。答得名出罪。诸比丘得罪。问若比丘不覆藏罪。众僧中六夜行摩那埵。诸比丘与作出罪羯磨。得名出罪不。答得名出罪。诸比丘无罪。问诸比丘在地。有罪比丘在高上。得名出罪不。答不得。诸比丘在高上。有罪比丘在地。得名出罪不。答不得。诸比丘在界内。有罪比丘在界外。得名出罪不。答不得。诸比丘在界外。有罪比丘在界内。得名出罪不。答不得。若诸比丘与有罪比丘。俱在界内若坐若立。得名出罪不。答得(般茶卢伽法竟)

十诵律卷第五十四十诵律卷第五十五(第九诵之四)

        后秦北印度三藏弗若多罗译

    问顺行法第五

优波离问佛。颇有比丘。即是别住人。即是别住竟人。即是行摩那埵人即是行摩那埵竟人耶。答有。若比丘出精。得僧伽婆尸沙罪。是罪不覆藏。是人从僧乞六夜行摩那埵。僧与此比丘六夜摩那埵。是比丘六夜行摩那埵时。尔所日已行竟。更作出精。得僧伽婆尸沙罪。是第二罪亦不覆藏。是比丘复从僧乞六夜行摩那埵。僧复与此比丘六夜摩那埵。是人行六夜摩那埵时。尔所日已行竟。更故出精。得僧伽婆尸沙罪。是罪覆藏。是比丘随覆藏日。从僧乞别住。是比丘随覆藏日行别住时。尔所日已行竟。更故出精。得僧伽婆尸沙罪。是第二罪亦覆藏。二罪覆藏。一罪一夜覆藏。一罪二夜覆藏。是比丘过一夜。以一罪故。名别住人。以一罪故。名别住竟人。以一罪故。名行摩那埵人。以一罪故。名行摩那埵竟人。问如佛说。别住人不得与别住人。有住处不得同一覆。无住处不得同一覆。有僧房无僧房处。颇有别住人。得与别住人。有住处无住处同一覆。于僧坊若无僧坊。不得罪耶。答有。若本外道是。问颇有人无罪亦名别住耶。答有。若本是外道。问颇有比丘。得僧伽婆尸沙罪。不随覆藏日。不从僧乞别住。众僧亦不与是人随覆藏日别住。是人不从僧乞六夜摩那埵。僧亦不与是人六夜摩那埵。是人不从僧乞出罪。僧亦不与是人出罪。是人亦名净不。答有。若是比丘转根作比丘尼是。问颇比丘尼得僧伽婆尸沙罪。不从二众乞半月摩那埵。二众亦不与半月摩那埵。不从二众乞出罪羯磨。二众亦不与出罪羯磨。亦名净不。答有。若比丘尼转根作比丘是也。问出罪人在地。余比丘在高上与出罪。得名出罪不。答不名出罪。出罪人在高上。余比丘在地与出罪。得名出罪不。答不名出罪。出罪人在界内。诸比丘在界外与出罪得名出罪不。答不名出罪。出罪人在界外。诸比丘在界内与出罪。得名出罪不。答不名出罪。出罪人诸比丘。俱在界内若坐若立。得名出罪不。答得名出罪。问别住人与别住人。有住处不得同一覆。无住处不得同一覆。别住人与行别住竟人。与行摩那埵人别住人。与行摩那埵竟人别住人。与不共住人。若有住处不得同一覆。无住处不得同一覆。别住人清净比丘。有住处不应同一覆。无住处亦不应同一覆。别住人别住竟人。别住人摩那埵人。别住人摩那埵竟人。别住人不共住人。有住处不得同一覆。无住处不得同一覆。若别住人出界去。若能得有比丘住处可去。若不去失是行。若言。我不能行别住法摩那埵法。是人白僧言。我不能行。众僧应置。问应置几日。答应置二十五日。问颇有人无罪。亦从僧乞别住。众僧与。名为善与耶。答本外道是。问颇有不受具戒人。得僧伽婆尸沙罪。随覆藏日。从僧乞别住。僧与是人随覆藏别住。名为善与耶。从众僧乞六夜摩那埵。众僧若与摩那埵。亦名善与耶。从僧乞出罪羯磨僧与出罪羯磨。亦名善与耶。答与学沙弥是也(顺行法竟)

    问遮法第六

优波离问佛。颇得宿听出他过耶。答不得。又问。以宿听得遮波罗提木叉。得遮自恣。得遮教化比丘尼耶。答不得。问在地住人。得与高上人作覆钵不。答不得。高上人得与地人作覆钵不。答不得。界内与界外人作覆钵不。答不得。界外与界内人作覆钵不。答不得。若与作覆钵人俱在界内。若坐若立得作覆钵。问诸比丘在地。足数人在高上。作覆钵。得不答不得。诸比丘在高上。足数人在地。作覆钵。得不。答不得。诸比丘在界内。足数人在界外。作覆钵。得不。答不得。诸比丘在界外。足数人在界内。作覆钵。得不。答不得。若诸比丘足数人俱在界内。若坐若立。得作覆钵。诸比丘在地。与高上人作仰钵。得不。答不得。诸比丘在高上。与在地人作仰钵。得不。答不得。诸比丘在界内。与界外人作仰钵。得不。答不得。诸比丘在界外。与界内人作仰钵得不。答不得。诸比丘与作仰钵人。俱在界内若坐若立。得作仰钵。诸比丘在地。足数人在高上作仰钵。得不。答不得。诸比丘在高上。足数人在地作仰钵。得不。答不得。诸比丘在界内。足数人在界外作仰钵。得不。答不得。诸比丘在界外。足数人在界内作仰钵。得不。答不得。诸比丘足数人。俱在界内若坐若立。得作仰钵。问如佛所说。不得以宿听出他过。颇比丘宿听出他过无罪耶。答有。若受自恣时得。余时不得。问应从何处求听。答应从众僧中。问何处应与听。答众僧中。问何处应遮波罗提木叉。答众僧中。问何处应遮自恣。答众僧中。问何处如法自言。答众僧中。问何处如法断事。答众僧中。问诸比丘遮哑人波罗提木叉得名遮不。答不得。问遮聋人哑聋人狂人散乱心人病坏心人波罗提木叉。得名遮不。答不得。问若诸比丘以哑人足数。遮波罗提木叉。得名遮不。答不得。问若以聋人哑聋人狂人散乱心人病坏心人足数。遮波罗提木叉。得名遮不。答不得。问受法比丘。遮不受法比丘波罗提木叉。得名遮不。答不得。问不受法比丘。遮受法比丘波罗提木叉。得名遮不。答不得。问受法比丘。以不受法比丘足数。遮波罗提木叉。得名遮不。答不得。问不受法比丘。以受法比丘足数。遮波罗提木叉。得名遮不。答不得。问颇有一比丘遮四住处波罗提木叉。得名遮不。答有。若床榻材木连接四界。得名遮。问颇有一足数人。足四处遮波罗提木叉。得名遮不。答有。若床榻材木连接四界。得名遮(遮法竟)

    问卧具法第七

优波离问佛。如佛所说。受法人虽是长老。不名尊长。说非法人虽是上座。不名尊长。云何名尊长非尊长。答受法比丘。应礼敬不受法比丘。不受法比丘。不应礼敬受法比丘。是名尊长非尊长。问如佛所说。此间安居比丘。不应彼处取卧具。颇有比丘。此间安居彼处取卧具。不得罪耶。答有。后安居若阿练若比丘。此间安居彼处取卧具。欲来岁安居无罪。问如佛所说。佛告舍利弗。汝等先筹量人。后当分布取卧具。云何名筹量人。答一一部清净上座和合。是名筹量人。问沙弥在僧坊。应取卧具不。答应取。问一比丘独在僧坊应取卧具不。答应取。问若二比丘在僧坊中住。应取卧具不。答应取。问若三比丘在僧坊中住。应取卧具不。答应取。问若四比丘在僧坊中住。应唱分卧具不。答应唱分。问颇一比丘。四处住。取卧具耶。答有。若床榻材木连接四界。得取卧具。问颇有比丘。不现前与卧具不。答言。或与或不与。谁应与知当来。谁不应与知当不来。不嘱者不与。若嘱者一切卧具应与。一切作事令代作(卧具法竟)

    问灭事法第八

优波离问佛。颇有以一事多觅法灭得名。灭不得罪耶。答有。唱分卧具事是也。问如佛所说。二因缘故破僧。一唱说。二取筹。是中若贼住比丘唱说行筹。得名破僧不。答不名破僧。问若狂人散乱心人病坏心人唱说行筹。得名破僧不。答不名破僧

    问杂事初

优波离问佛。如佛所说。边地人持律第五得受具戒。颇有十人但取五人。得名受具戒不。答得名受具戒。与受具戒者得罪。问聋人云何名得布施。答若眼见若盲人。若着手中若着膝上。心生念。我得是物。问若坐卧具上。若织若画作女人像。若半有半无。得坐卧不。答不得。不犯者。若多坏若敷尼师坛坐。问捉牸牛尾。得渡河不。答不得。问除牸牛。若捉余畜生尾。得渡河不。答若捉师子虎狼象特牛驴马尾者。得捉渡河。问受石蜜浆。举宿经七日。糁杂得服不。答若杂余糁不得。问不净药草着油中煮。得服不。答不得。若病人涂身手足灌鼻无罪。问若以不净脂煮盐。得食不。答病人若烧得服。问比丘以火刀爪净果。得食不。答不得。问若果树在净地。枝在不净地。果堕是中。可食不。答不可食。若果树在不净地。枝在净地。果堕是中。可食不。答可食。佛语诸比丘。从今日不听汝作净地羯磨。若作得突吉罗。从是语已舍是事也

问诸大小槃团槃机案上。得食不。答不得食。问人乳得饮不。答不得。若病以洗疮涂眼得。问人肉得食不。答不得。若食得偷兰遮。问故为杀畜生肉可食不。答不得食。若食得突吉罗。不净鸟兽肉不应食。若食突吉罗。燕肉不应食。若食突吉罗。鸱鹫鸟等肉不应食。若食突吉罗。虾蟆肉不应食。若食得突吉罗。水蛭不应食。若食得突吉罗。即日受时药时分药七日药尽形药。共合一处。中前应服。时药力故。过中不应服。即日受时分药七日药尽形药。共合一处。时分应服。时分药力故。过时分不应服。即日受七日药尽形药共合一处。七日应服。七日药力故。过七日不应服。尽形药随意应服。昨日受时药不净。即日受时分药七日药尽形药。共合一处不应服。昨日受时分药不净。即日受七日药尽形药。共合一处不应服。昨日受七日药不净。即日受尽形药。共合一处不应服。尽形药尽形应服。问颇有从一物边作时药时分药七日药尽形药。答有。甘蔗是时药。清汁是时分药。作石蜜是七日药烧作灰是尽形药。酪是时药。清汁如水是时分药。作酥是七日药。烧作灰是尽形药。胡麻是时药。压作油是七日药。烧作灰是尽形药。肉是时药。煮取脂是七日药。烧作灰是尽形药。问时药时分七日尽形药。是诸药举残宿。得服不。答不得。问若比丘先自取。后从净人边受。可服不。答不得。问是药手受口受。无病应服不。答不得。问若手受口受。病比丘得服不。答得服。问八种浆非时可饮不。答若无酒气味清净得服。问得从狂人取衣不。答或可取或不可取。若知有父母兄弟居家与。可取。若知无父母兄弟非居家中与。不可取。问狂人何时应受衣。答还得本心时。有一比丘独一处住。是中檀越施僧现前可分物。是比丘应心念口言。是衣物为此住处现前僧可分。是衣物今属我。我应受自用。若能作是语。得名羯磨。若余比丘来从索。不应与。若不作。是语。是物不应取。若取得突吉罗。亦应共余比丘分。若不如是作出界外。得突吉罗。问若贤者责罚儿。是儿持物与比丘。可取不。答不可取。问自恣竟先檀越施僧衣。作是言。是物施是间安居僧。是时非夏末月。诸比丘亦不受迦絺那衣。是衣应属谁。答虽非夏末月诸比丘亦不受迦絺那衣。是衣应属此间安居竟僧应分。问诸檀越持衣施。作是言。是衣施是间现前僧。是时夏末月。诸比丘受迦絺那衣。是衣应属谁。答虽是夏末月。虽受迦絺那衣。是衣应是一住处现前僧应分。问檀越持衣施。作是言。是衣施此住处去年乃至十岁安居僧。是安居时非夏末月。不受迦絺那衣。是衣应属谁。答虽非夏末月不受迦絺那衣。是衣但去年乃至十年。此处安居僧应分。问檀越持衣入僧坊。作是言。是衣施此住处将来一年二年乃至十年是中安居僧。尔时是夏末月。受迦絺那衣。是衣应属谁。答虽是夏末月受迦絺那衣。是衣应来一年乃至十年此间安居僧分。问劝化主为僧事出界去。谁当与安居衣分。答随所为出界处应与。又随所住日多处应与。问破安居比丘。应与衣分不。答或应与或不应与。何者应与。若知前安居若后安居。应与。若多住应与。若半住应与。何者不应与。若知不前安居。若知不后安居。若住日少是。问看病人。为病人故出界去。病人命终。应与看病人衣分不。答。或应与或不应与。与者。实为病人故出。应与。若余事故出。不应与。问云何名看病人。答若能看视疗治病人乃至若死。若差与随病药随病食。具足供给亲近益利。使离诸衰损所作无阙。是名看病人。问若白衣作看病人。应与看病人物分不。答不应与。问若比丘尼作看病人。应与看病人物不。答不应与。若是看病比丘余处安居。应与看病人物不。答应与。问若看病人后安居。病比丘前安居。应与看病人物不。答应与。问若沙弥作看病人。应与看病人物不。答应与。云何与。答大比丘等与。问与学沙弥齐何作净施。答随所得时作净施。问钱云何作净施。答应言。此是不净物。若净当受。问颇一比丘四住处一时安居。得名安居无罪耶。答若以床榻材木连接四界。得名安居。何处应与安居衣分。答应四处各与四分之一。若比丘雨浴衣若小受。得突吉罗。若覆疮衣若小受。得突吉罗。若比丘分盈长衣。得突吉罗。问若比丘作三相。一赤裸。二着角鸱翅衣。三着发钦婆罗。得何罪。答得偷兰遮。问若比丘除是三相。更作余相。得何罪。答得突吉罗。问如佛所说。故衣不得受作迦絺那衣。若受不名受。云何名故衣。答以曾受作迦絺那衣。是名故衣。又问如佛所说。新衣应受作迦絺那衣。云何名新衣。答若衣未曾受作迦絺那衣。是名新衣

佛告优波离。令僧作迦絺那衣人。应次第作浣染割截簪缀连缝量度作迦絺那衣。浣时应生是心。以是衣令僧受作迦絺那衣。染时割截时簪缀时连缝时量度时。应生是心。以是衣令僧受作迦絺那衣。若能生是六心。得名受作迦絺那衣。若不生是六心。不名受作迦絺那衣。又复作迦絺那衣人应生三心。以是衣令僧受作迦絺那衣。以是衣今受作迦絺那衣。以是衣受作迦絺那衣竟。若能生是三心。得名受作迦絺那衣。若不生是三心。不得名受作迦絺那衣。又复作迦絺那衣。应生二心。得名受作迦絺那衣。何等二心。是衣今受作迦絺那衣。以是衣今受作迦絺那衣竟。若生是二心。名受迦絺那衣。若不生是二心作迦絺那衣比丘。皆得突吉罗。问若受举宿衣。受迦絺那衣。不名受迦絺那衣。云何名举宿衣。答若长衣过十夜是。若受不净衣。不名受迦絺那衣。云何是不净衣。答得望衣是。问如佛所说。去来衣不得受作迦絺那衣。云何名去来衣。答若衣覆死人。到冢间还取来。是名去来衣。问如佛所说。用净衣受作迦絺那衣。云何名净衣。答佛所听赞叹者。是名净衣。问若未受迦絺那衣。僧坏为二部。何部应受迦絺那衣。答如法部应受。若诸比丘受迦絺那衣竟。僧坏为二部。是诸比丘。得名受迦絺那衣不。答皆得名受。问若受迦絺那衣住处。僧坏为二部。是二部中有诸比丘。舍迦絺那衣。是名舍不。答若如法者舍。得名为舍

佛告优波离。作迦絺那衣人。若浣染割截簪缀连缝二长一短时。应生三心用是衣。当令受作迦絺那衣。以是衣今受作迦絺那衣。以是衣今受作迦絺那衣竟。若能生是三心得名受作迦絺那衣。若不生是三心。不得名受作迦絺那衣。又复应生二心。以是衣今受作迦絺那衣。以是衣今受作迦絺那衣竟。若生是二心。得名受迦絺那衣。若不生是二心。不得名受作迦絺那衣。作迦絺那衣人得突吉罗。优波离问佛。是衣有何义故名迦絺那。佛告优波离。是衣名字为迦絺那。优波离问佛。何者是迦絺那衣。答以是衣受迦絺那。问何者是迦絺那义。答衣名迦絺那义。生九心故名受迦絺那。八因缘故名舍迦絺那。问如佛所说。是迦絺那衣住处。名荫覆。荫覆义云何。答迦絺那衣住处荫覆僧。得受衣物等施。问如佛所说。得用急施衣。令僧受作迦絺那衣。云何名急施衣。答十日未至自恣得衣物。是名急施衣。问如佛所说。得时衣令僧受作迦絺那衣。云何名时衣。答若夏末月得衣物。是名时衣。佛告优波离。五比丘不得作迦絺那衣人。何等五。一无岁。二破安居。三后安居。四摈。五别住。是名为五。佛言。若减五人受迦絺那衣。不得名受迦絺那衣。若四比丘第五白衣。亦不名得受。若沙弥。非比丘。外道。不见摈人。不作摈人。不舍恶邪见摈人。不共住人。种种不共住人。自言我犯重罪人。若先来白衣。若污比丘尼人。不能男人。越济人。若杀父母阿罗汉。破僧恶心出佛身血人。如是等作第五人。不名受迦絺那衣。问颇有随日受迦絺那衣。彼日舍不作羯磨。不得罪耶。答有。受迦絺那衣诸比丘。作十四日。客比丘来作十五日。若旧比丘随客比丘。即日作布萨舍迦絺那衣无罪。问云何得破僧罪。答若人非法知是非法。邪见故坏僧。如是得破僧罪。又非法谓是法。邪见故坏僧。得破僧罪。又非法中疑。邪见故坏僧。得破僧罪。问所有破僧。皆是僧诤声耶。所有僧诤声。皆是破僧耶。答或有破僧。无僧诤声。或有僧诤声非破僧。或有破僧亦僧诤声。或非破僧无僧诤声。问云何破僧无僧诤声。答若僧坏为二部。未受十四破僧事。是名破僧无僧诤声。云何僧诤声非破僧。答若诸比丘。执是十四破僧事僧未作二部。是名僧诤声非破僧。云何破僧亦僧诤声。答若僧坏为二部。受十四破僧事。是名破僧亦僧诤声。云何非破僧亦非僧诤声。答除上尔所事。问所有破僧。皆是别离僧耶。所有别离僧。皆是破僧耶。答或有破僧非是别离。或有别离非是破僧。或有破僧亦是别离。或非破僧亦非别离。云何破僧非是别离。答若僧破共一处住。是名破僧非是别离。云何别离非是破僧。答若二众别异住。异地异界异施异衣。是名别离非是破僧。云何破僧亦是别离答。若众僧坏为二部。别异住异地异界异施异衣。是名破僧亦是别离。云何非破僧亦非别离。答除上尔所事。问所有破僧。皆是僧别异耶。有僧别异。皆是破僧耶。答或有破僧。非僧别异。或僧别异。非是破僧。或有破僧亦僧别异。或非破僧非僧别异。云何破僧非僧别异。答若僧破未别异住。未异地异界异施异衣。是名破僧非是别异。云何别异非是破僧。答若僧不破。别异住异地异界异施异衣。是名别异非是破僧。云何破僧亦是别异。答若众僧破为二部别住。异地异施异界异衣。是名破僧亦是别异。云何非破僧亦非别异。答除上尔所事。问若僧破为二部。若一部舍界。可得舍不。答如法者舍。得名舍。问若众僧破。比丘尼应作布萨不。答应作布萨。比丘尼不同事故。问若众僧破。闼赖吒比丘云何应布萨。答是闼赖吒比丘。应出界作布萨说戒。问若众僧破为二部。比丘尼应从何部受半月教化。答应从如法部受。若无如法。闼赖吒比丘应出界教化。问三摈比丘。一比丘随顺供给。得何罪。答是比丘。得二突吉罗一波夜提。问摈比丘名为独。名为有伴党耶。答一切摈比丘。名为独。无有伴党。问比丘摈未决定。应共住同事不。答若共住同事无罪。问受法比丘。得与不受法比丘作羯磨不。答不得。不受法比丘。得与受法比丘作羯磨不。答不得。若有一摈比丘。四比丘随顺。名破僧不。答名破僧。何以故。众僧摈是人。而四比丘随顺故。问如佛所说。如是人不应作不见摈。如是人若欲作不见摈时。得偷兰遮。何以故。近破僧因缘故。云何名如是人。答知是大德人若多知多识多闻大德明。解修妒路毗尼阿毗昙义。是故说名。如是人。不应与作不见。摈若与作不见。摈者得偷兰遮。近破僧故。问如佛所说。用可信比丘语应见罪。云何名可信。答从可信语比丘边闻。亦自信是罪。问如佛所说。若僧欲破。应次第空一床处敷独坐床。知法者应作诸羯磨。及教化比丘尼。是中云何成法。答若诸比丘共心悔知罪。互相恭敬礼拜问讯是。问如佛所说。若破一毛为百分。当如是细求和合众僧因缘。莫求破僧因缘。问云何名细求。答应求语言。应求义趣。应分别筹量细求和合僧因缘。莫求破僧因缘。若摈比丘心悔知罪。恭敬礼拜众僧。诸比丘将界外解摈。得解摈不。答得解摈。诸比丘得罪。俱舍弥何时名破僧。答若俱舍弥比丘界内共一住处。别作布萨及诸羯磨。尔时名破僧。问俱舍弥谁名破众僧。答如法比丘界内共住处。别作布萨及诸羯磨者是。问若比丘尼僧破为二部。比丘尼来诣诸比丘求教化。诸比丘应与教化不。答应与。应作是言。诸姊善共和合。问二因缘故名破僧。一唱说。二者取筹。若以余因缘唱说取筹。名破僧不。答不名破僧。问若众僧破为二部。诸比丘尼来求教化。应教化不。答应与教化。何以故。不欲令比丘尼僧破故。问毗耶离比丘受比丘尼。求教化。若俱舍弥比丘。尔时在界内毗耶离比丘。云何。作教化答。应出界教化。问俱舍弥二部朋党。一布萨处集。闼赖吒比丘云何作布萨。答应出界作布萨说戒是。檀越捉上座手。布施众僧。是施物应属谁。答随何部作上座。是物应属。若檀越捉第一上座第二上座手言。是物施众僧。应属谁。答若第一上座第二上座同一部。应属一部。第一上座第二上座。各在一部。应属二部。云何应分。次第分。第四分与沙弥。问毗耶离比丘。就闼赖吒比丘。共作布萨说戒。得名布萨说戒不。答得。显闼赖吒相故。若闼赖吒比丘。就毗耶离比丘。共作布萨说戒。得名布萨说戒不。答得布萨说戒。但失闼赖吒相故。问俱舍弥比丘。就闼赖吒比丘布萨说戒。得名布萨说戒不。答得显闼赖吒相故。闼赖吒比丘。就俱舍弥比丘。共作布萨说戒。得名布萨说戒不。答得布萨说戒。但失闼赖吒相故。如佛所说。有一住处。诸比丘作羯磨。非法别众。非法和合众。似法别众。似法和合众。如法别众。如法和合众。云何名非法别众。答应与苦切羯磨。与作不见摈羯磨。僧不和合。是名非法别众。云何名非法和合众。答应与苦切羯磨。与作不见摈羯磨。僧和合。是名非法和合众。云何名似法别众。答若作不见摈羯磨时。先唱说后白。僧不和合。是名似法别众。云何似法和合众。答若作不见摈羯磨时。先唱说后白。僧和合。是名似法和合众。云何名如法别众。答若应与作不见摈。与作不见摈羯磨。僧不和合。是名如法别众云何如法和合众。答若应与作不见摈。与作不见摈羯磨。僧和合。是名如法和合众。问若一比丘摈一人。一突吉罗。一人摈二人。二突吉罗。一人摈三人。三突吉罗。一人摈四人。四突吉罗。二人摈二人。二突吉罗。二人摈三人。三突吉罗。二人摈四人。四突吉罗。二人摈一人。一突吉罗。三人摈三人。三突吉罗。三人摈四人。四突吉罗。三人摈一人。一突吉罗。三人摈二人。二突吉罗。问若四比丘摈四比丘。得何罪。答得偷兰遮罪。以破僧因缘故。问一切众僧睡眠。尔时摈比丘。得摈不。答若众僧闻白已睡眠。得摈。问若众僧以余因缘和合。即摈比丘。得名摈不。答曰。得摈。说羯磨者得罪。问若减四比丘摈人。得名摈不。答不得。问若三比丘。第四若白衣。沙弥。非比丘。外道。不见摈。不作摈。恶邪不除摈。不共住。种种不共住。自言犯重罪。先来白衣。污比丘尼。杀父母。杀阿罗汉。破僧。恶心出佛身血人。作第四人。得摈人不。答不得。问如佛所说。有一住处。诸比丘应作羯磨者。彼不集一处。应与欲而不与。现前比丘能遮者遮成遮。云何应作羯磨比丘。答若应四众作羯磨。四比丘应作。若应五众作羯磨者。五比丘应作。若十众应作羯磨者。十比丘应作。若应二十众作羯磨者。二十比丘应作。诸比丘清净共住同见。是名应作羯磨比丘。问若比丘睡眠。诸比丘作摈。得摈不。答若比丘闻白已睡眠。得名摈。问若入定比丘。诸比丘得摈不。答若是比丘闻白已入定。得名摈。问若众僧破为二部。互相摈。得摈不。答若如法者摈。得名摈。问以闼赖吒比丘足数摈比丘。得摈不。答得摈。但失闼赖吒相。问所有非法羯磨。是别众羯磨耶。所有别众羯磨。是非法羯磨耶。答或非法羯磨。非别众。或别众羯磨。非非法。或非法羯磨。亦是别众。或非非法羯磨。亦非别众。云何非法羯磨非别众。答所有中作羯磨比丘。和合一处。应与欲者皆与欲来。现前比丘遮成遮而不遮。若人不现前。不先说其事。与作羯磨。是名非法羯磨非是别众。云何别众羯磨非非法。答所有中作羯磨比丘。不和合一处。应与欲者不与欲来现前比丘能遮者遮成遮。若人现前。先说其事与作羯磨。是别众羯磨非非法。云何非法羯磨亦别众。答所有中作羯磨比丘。不和合一处。应与欲者不与欲来。现前比丘能遮者遮成遮。若人不现前。不先说其事。与作羯磨。是名非法羯磨亦别众。云何非非法亦非别众。答所有中作羯磨比丘和合一处。应与欲者皆与欲来。现前比丘遮成遮而不遮。若人现前。先说其事与作羯磨。是名非非法亦非别众。问所有是法羯磨。皆是和合耶。所有和合羯磨。皆是有法耶。答或是有法羯磨。非是和合。或是和合羯磨。非是有法。或有法羯磨。亦是和合。或非有法羯磨。亦非和合。云何有法羯磨非是和合。答所有中作羯磨比丘不和合一处。应与欲者不与欲来。现前比丘遮成遮而遮。若人现前先说其事乃作羯磨。是名有法羯磨非是和合。云何和合非是有法羯磨。答所有中作羯磨比丘和合一处。应与欲者皆与欲来。现前比丘遮成遮而不遮。若人不现前。不先说其事。与作羯磨。是名和合非有法羯磨。云何有法羯磨亦和合。答所有中作羯磨比丘和合一处。应与欲者皆与欲来。现前比丘遮成遮而不遮。若人现前先说其事。与作羯磨。是名有法羯磨亦和合。云何非有法羯磨亦非和合。答所有中作羯磨比丘不和合一处。应与欲者不与欲来。现前比丘遮成遮而遮。若人不现前不先说其事。与作羯磨。是名非法羯磨亦非和合。问如佛所说。所有罪人。众僧乃至三教敕。颇比丘无罪。众僧乃至三教敕耶。答若除诸罪。余教敕是也。问宿白僧中得作羯磨不。答除属和上尼羯磨若僧未起。得作一切羯磨。问诸比丘唱说。后向摈比丘说。得名摈不。答得名摈。作羯磨人得突吉罗。问诸比丘因宿与欲作诸羯磨。得名作耶。答除属和上尼羯磨若僧未起。得作一切羯磨。问比丘自为作羯磨。得作不。答不得。若作者。众僧应语是人言。汝自顺自受持。优波离问佛。是诸本破戒人。贼住比丘。先来白衣等。是人云何如法自言。答是人僧中乃至三自说是。问可得一时唱说四人令得戒耶。答不得。问可得一时唱说令四人受具戒耶。答不得。问三比丘第四筹摈比丘。得摈不。答不得。问第四别住比丘摈比丘。得摈不。答不得。问诸比丘摈折伏。得摈不。答得摈。先折伏羯磨得灭。问诸比丘得摈可依止比丘。可出忏悔比丘不耶。答得摈。先可依止可出忏悔羯磨得灭。问诸比丘。与已摈比丘作折伏羯磨。名作不。答不得。以不中同事故。问诸比丘。与摈比丘作依止遣出忏悔羯磨。得名作不。答不得。以不中同事故。问除比丘。谗余人得何罪。答得突吉罗

优波离问佛。折伏羯磨有何义耶。佛言。此是羯磨名字。是筹磨从斗诤相言边出。应语是人众僧后当筹量汝事。又问。世尊。依止羯磨有何义。答此是羯磨名字。是但数作众罪。众僧应语是人。汝当依止某甲比丘住。问世尊。驱出羯磨有何义。答此是羯磨名字。是羯磨污他家比丘边出。应语是人。汝出去。莫是中住。优波离问佛。破慢羯磨有何义。答此是羯磨名字。是羯磨从轻骂白衣边出。应语是人。汝应向某甲居士悔过。优波离问。如佛所说。汝应依止某甲比丘住。此说有何义。佛言。随是罪比丘深心爱念恭敬者畏难者应依止是比丘。住问如佛所说。众僧后当筹量。此说有何义。答应语言。汝若有罪。应入僧中三自首。僧当随罪治汝。是名筹量。问若比丘语两眼人言。汝是一眼人。得何罪。答故妄语故。得波逸提。又问。语一眼人言。汝一眼人。得何罪。答轻恼他故。得波逸提。问如佛所说。比丘若内若外轻恼他。是中云何内云何外。答内者界内外者界外。复次舍内名内。露地名外。问如佛所说。阿利吒比丘。竭驮婆罗门本弟子。说遮道法作不遮道。问云何是遮道。答我说欲是遮道(问杂事竟)

十诵律卷第五十五十诵律卷第五十六(第十诵之一)

        后秦北印度三藏弗若多罗译

    比丘诵

佛在王舍城。语诸比丘。十种明具足戒。何等十。佛世尊自然无师得具足戒。五比丘得道即得具足戒。长老摩诃迦叶自誓即得具足戒。苏陀随顺答佛论故得具足戒。边地持律第五得受具足戒。摩诃波阇波提比丘尼受八重法即得具足戒。半迦尸尼遣使得受具足戒。佛命善来比丘得具足戒。归命三宝已三唱我随佛出家即得具足戒。白四羯磨得具足戒。是名十种具足戒。三种得具足戒。一善来作比丘。二归命三唱。三白四羯磨。于是中若未结白四羯磨。若人归命三唱。我随佛出家。是善受具足戒。若结白四羯磨后。若归依三唱出家。不名得具足戒。善来作比丘。若结白四羯磨前。若结白四羯磨后。皆善来得具足戒。何以故。佛法王自与受戒。无有在学地命终故。诸比丘尼三种得受具足戒。一受八重法。二遣使。三白四羯磨。是中受八重法。初一人得后不得。遣使者。如半迦尸尼得。若有欲出家道路障碍。相似亦得。是使人众僧中受羯磨。不多不少。向半迦尸尼说。亦说三依止。应说受戒岁月时节。亦应广说八波罗夷法。如是名得具足戒。若不如是。不得具足戒。可受具足戒者。若男子女人无遮受戒法。是名可受具足戒。不可受具足戒者。若男子女人有遮法。无和上阿阇梨。无衣钵。不能男。污比丘尼。杀父母杀阿罗汉。破僧恶心出佛身血。如是人不可受具足戒。若受戒污众僧。与受戒者得突吉罗。若人诸根具足无障碍。某种姓某名字某事业。众僧一心如法和合。问无遮受戒法已。然后与受戒。如苏陀等如法得受具足戒。于是中十三人先来。不得具足戒。杀父杀母杀阿罗汉。破僧恶心出佛身血。先破戒贼住比丘。先来白衣不能男。污比丘尼。越济人。灭羯磨人及非人。如是等名污众僧人。不得受戒。与受戒者得罪。是名善受具足戒法。有二种羯磨。一治罪羯磨。二成善羯磨。治罪羯磨者。谓苦切羯磨依止羯磨驱出羯磨下意羯磨摈羯磨。如是等苦恼羯磨。是名治罪羯磨。成善羯磨者。谓受戒羯磨布萨羯磨自恣羯磨出罪羯磨布草羯磨。如是等能成善法羯磨。是名成善羯磨。羯磨事者。随所从因缘作羯磨。是名羯磨事。遮羯磨者。若羯磨时不如法作白。不如法唱说。别众非法可坏。是名遮羯磨。不遮羯磨者。若羯磨时如法作白如法唱说。和合众如法不可坏。是名不遮羯磨。出羯磨者。诸比丘语摈比丘言。汝已被举。出去。僧不得与汝同事。何以故。僧已作羯磨。汝今出去。是名出羯磨。舍羯磨者。摈比丘僧还与解摈。还共作羯磨同事共住。是名舍羯磨。苦切事者。若比丘喜斗乱诤讼。僧因是故作苦切羯磨。是名苦切。出罪事者。三种出罪事。若见若闻若疑。是三种事应以时出。莫以非时。当以实出。莫以妄语。当以利益出。莫以无益。当软语出。莫以恶口。以慈悲心莫以嗔恨。因缘事者。随所从因缘作羯磨。是名因缘事。如跋陀婆罗经中广说五摄。语治事者。四种羯磨名为治事。谓苦切羯磨依止羯磨驱出羯磨下意羯磨。除灭事者。随所从因缘灭斗诤乱事。是人得心悔折伏。恭敬礼拜软语问讯舍离本事。是名除灭事。学者。三学。善戒学善心学善慧学。是名为学。还戒者。若比丘言。我舍佛舍法舍僧舍戒。舍和上阿阇梨。舍同和上同阿阇梨。舍比丘比丘尼式叉摩尼沙弥沙弥尼。汝等当知。我是白衣若沙弥。我非比丘非沙门非释种子。乃至言。我不喜与汝等共住。是名还戒。不舍戒者。若狂人舍戒。不名舍戒。若散乱心病坏心舍戒。不名舍戒。若向狂人散乱心人病坏心人舍戒。不名舍戒。若独舍戒。若独非独想。若非独独想舍戒。不名舍戒。若中国人向边地人。若边地人向中国人舍戒。不相解语。不名舍戒。若向哑人聋人哑聋人不智人非人睡眠人入定人舍戒。若隔障若自嗔若向嗔人舍戒。若梦中舍戒。若不决定心舍戒。若人不了其语。若前人不决定知舍。是皆不名舍戒。是名不舍戒。戒羸者。若比丘愁忧不乐比丘法。厌恶比丘法。欲堕圣相。欲立白衣相须在家法。不须比丘法求白衣法。作是言。我忆念父母兄弟姊妹妻子。速教我世间诸巧便事。教我令得世间安隐住处。嘱累我令得善知识。是比丘愁忧不乐比丘法。乃至求白衣法。如是言说音声惭愧故。不欲了了向人说我反戒。是故名戒羸。戒羸不出者。不令他人了知。诤事者。云何是诤事。有四种诤事。相言诤。无事诤。犯罪诤。常所行诤。是名为诤事。正取事者。随事起因缘正取其实。是名正取事。灭事者。七灭事法。现前灭事法。忆念灭事法。不痴灭事法。自言灭事法。实觅灭事法。多觅灭事法。如草布地灭事法。是名灭事。除灭事者。有五因缘事则易灭。是事白僧。用佛语断二部伴党。共软语。诤讼比丘嗔恨必折。有罪比丘可出。若事有此五因缘。则易除灭。是名除灭事。说者。若布萨说戒时。若说四事。若说十三事等。是名说。不说者。若住处布萨说戒时。上座不谙不诵次第二上座应说。若复不谙不诵。第三上座应说。如是展转一切皆不谙不诵故不说。是名不说。独住法者。若比丘独阿兰若处十五日布萨时。应洒扫塔寺布萨处及中庭次第敷座。应求火应求火炉燃烛应办筹。若客比丘未布萨者来。应共作布萨说戒。若无比丘来。应高上遥望。若遥见比丘。唤言速来。今是布萨日。若不见。是比丘还坐处坐。应心念口言。今众僧布萨。若十四日若十五日。我某甲亦布萨。若十四日若十五日。是比丘如是作。名得布萨。是名独住法。痴羯磨者。若比丘狂心颠倒。或来布萨或不来。或来众会或不来。或来羯磨或不来。是比丘应以白二作痴羯磨。广说如施越比丘。是名痴羯磨。不痴羯磨者。除痴羯磨。余诸羯磨。名不痴羯磨。不消供养者。施与持戒人。持戒人转与破戒人。是名不消施。与正见人。正见人转与邪见人。是名不消。若过度用。是名不消供养。十种不现前羯磨者。覆钵羯磨。仰钵羯磨。作学家羯磨。舍学家羯磨。治僧伽蓝羯磨。监僧伽蓝民羯磨。使沙弥羯磨。不礼拜羯磨。不共语羯磨。不供养羯磨。是名十不现前羯磨。非羯磨者。若应四众作羯磨。而减四众。是不名作羯磨。若白衣作第四人。若沙弥非比丘外道。不见摈不作摈恶邪不除摈。不共住种种不共住。自言犯重罪先来白衣。污比丘尼不能男。杀父杀母杀阿罗汉。破僧恶心出佛身血。如是等作第四人。是不名作羯磨。若应五众作羯磨。而减五众作。是不名作羯磨。若白衣作第五人。若沙弥非比丘外道。不见摈不作摈恶邪不除摈。不共住种种不共住。自言犯重罪先来白衣。污比丘尼不能男。杀父杀母杀阿罗汉。破僧恶心出佛身血。如是等作第五人。是不名作羯磨。若应十众作羯磨。而减十众作羯磨。是不名作羯磨。若白衣作第十人。沙弥非比丘外道。不见摈不作摈恶邪不除摈。不共住种种不共住。自言犯重罪先来白衣。污比丘尼不能男。杀父杀母杀阿罗汉。破僧恶心出佛身血。如是等作第十人。是不名作羯磨。若应二十众作羯磨。而减二十众作羯磨。是不名作羯磨。若白衣作第二十人。若沙弥非比丘外道。不见摈不作摈恶邪不除摈。不共住种种不共住。自言犯重罪先来白衣。污比丘尼不能男。杀父杀母杀阿罗汉。破僧恶心出佛身血。如是等作第二十人。是不名作羯磨。善者。如毗尼中广说善法。出罪者。有五种如法出罪。不向不共住人别住人未受具足戒人出罪。出残罪出见罪。是名如法出罪。白者。白众是事故名白。有僧事初向僧说故名白。白羯磨者。受具足戒布萨说戒自恣等。是名白羯磨。白二羯磨者。若白已一唱说如是白二羯磨。是名白二羯磨。白四羯磨者。若白已三唱说。是三羯磨并白为四。是名白四羯磨。佛言。白羯磨。若离白作。是则可坏。白二羯磨。若离白作。是名可坏。若白不唱说。若唱说不白。亦可坏。白四羯磨。若离白作。是则可坏。若白不三唱说。若三唱说不白。亦可坏。白羯磨。若以白作。是不可坏。白二羯磨者。若先白已唱说。是不可坏。白四羯磨者。若先白已三唱说。是不可坏。如是等诸羯磨。皆应以是闻知。或有重说羯磨无罪。若减不名作羯磨。若和合众僧中。若白未唱说若唱说。不白众僧从坐起去。应语众言。诸长老。还和合应更作白唱说。若具足是事作羯磨。堕不可坏中。是名羯磨。苦切羯磨者。为斗诤相言比丘。以白四作苦切羯磨。是名苦切羯磨。依止羯磨者。为喜作罪比丘。以白四作依止羯磨。是名依止羯磨。驱出羯磨者。为污他家比丘。以白四作驱出羯磨。是名驱出羯磨。下意羯磨者。为骂白衣比丘。以白四作下意羯磨。是名下意羯磨。不见摈羯磨者。为比丘作罪不如法见。以白四作不见摈羯磨。是名不见摈羯磨。不作摈羯磨者。为比丘见罪不如法除。以白四作不作摈羯磨。是名不作摈羯磨。恶邪见不除摈羯磨者。为贪着邪见不舍。比丘以白四。作恶邪不除摈羯磨。是名恶邪不除摈羯磨。别住羯磨者。若比丘十三事中。得一一罪覆藏。随覆藏日。以白四作别住羯磨。是名作别住羯磨。摩那埵羯磨者。若比丘十三事中得一一罪不覆藏。僧以白四作六夜摩那埵羯磨。是名摩那埵羯磨。本日治羯磨者。若比丘六夜行摩那埵中。更得僧伽婆尸沙罪。是比丘众僧还以本日。以白四作本日治羯磨。是名本日治羯磨。出罪羯磨者。若比丘得僧伽婆尸沙罪。行摩那埵竟。众僧心悦。以白四作出罪羯磨。令出不善法。是名出罪羯磨。问何故善法中别住。答为摩那埵故。问何故本日治。答为折伏心故。问何故摩那埵。答为出罪故。问何故出罪。答为戒清净故。问何故别住为摩那埵。答是比丘行别住法。能令诸比丘心悦。诸比丘发心思惟。欲与摩那埵。问何以故。本日治为折伏心。答若还从本日行是事。令心折伏。诸比丘作是念。是人结使厚重。以本日治令惭愧。更不复作。尔时诸比丘发心与摩那埵。是故名本日治。为折伏心故。问何以故。行摩那埵为出罪。答是比丘行摩那埵法时。能令诸比丘心悦。诸比丘作是念。长老。一心好作善法。欲出是罪不欲违逆。我等当令是人得从罪出。是故名摩那埵。为出罪故。问何以故。出罪为戒清净。答是比丘若得出罪。离诸罪得清净戒。如比尼中说二人清净。一人先不作罪。一人作罪已如法除灭。二俱清净。是比丘以出罪羯磨故。还得清净戒。是故名以出罪。为戒清净故。觅罪相羯磨者。若比丘自言。我犯是罪。后还言。我不作。众僧与是人觅实罪相羯磨。广说如象首比丘觅实罪相羯磨。阿跋提者。五种罪。名阿跋提。何等五。谓波罗夷僧伽婆尸沙。波夜提波罗提提舍尼突吉罗。于此五种罪。比丘若作若覆障不远离。是名阿跋提。无阿跋提者。波罗夷。僧伽婆尸沙。波夜提。波罗提提舍尼。突吉罗。是五种罪不作不覆障远离。净身口业净命。若狂人病坏心人散乱心人作罪。若无先作。是名无阿跋提罪。轻阿跋提罪者。可忏悔即觉心悔。是名轻阿跋提罪。重阿跋提罪者。若罪可以羯磨得出者。是名重阿跋提罪。残阿跋提罪者。五种罪中后四种罪可除灭。是名残阿跋提罪。无残阿跋提罪者。五种罪中初种。是名无残阿跋提。恶罪者。谓波罗夷僧伽婆尸沙。虽一切罪皆名恶。此是恶中之恶。故名恶罪。非恶罪者。波夜提波罗提提舍尼突吉罗。是非恶罪。可治罪者。可出可除灭。是名可治罪。不可治罪者。不可出不可除灭。是名不可治罪。若犯罪者若四若五。法中作是念信是罪如法灭。若犯罪者若四若五。法中不作是念。不信是罪不如法灭。摄罪者。以一因缘故尽摄所犯。所谓恶律仪。摄无罪者。以一因缘故摄一切不犯。所谓行善律仪故。以一因缘故说一切罪。所谓恶律仪。以一因缘故说一切无罪。所谓善律仪。语者。比丘应语。长老。汝作某罪。是罪当发露。莫覆藏。当如法除灭。是名为语。忆念者。比丘应语。长老。汝忆念某时某处作如是罪不。是名忆念。说事羯磨者。汝长老。于此处不白我等不得余处去。是名说事羯磨。萨耶罗羯磨者。有五种。比丘语余比丘言。长老。听我语是事。应此处作萨耶罗。余事当彼间作萨耶罗。某事当随处作萨耶罗是比丘说犯事示他过故。拔羁系逸去。如恶马。是名萨耶罗羯磨。诬谤者。诬谤事诬谤方便。是名诬谤事。诬谤发者。发起诬谤。是名诬谤发。诬谤灭者。不作诬谤。是名诬谤灭。应五种从他求听。长老。我说汝事语汝。令汝忆念。出汝事听我。是故名求听与听者。应五种与听。说来语来忆念来出来听汝来。是名与听。用听者。以是听如法出他事。是名用听。遮波罗提木叉者。有十种如法遮波罗提木叉。说波罗提木叉时。若比丘犯波罗夷者。若欲出波罗夷事。若轻呵僧。欲出轻呵僧事。若舍戒。若欲出舍戒事。若比丘不随顺如法僧事。若见闻疑他破戒事。若见闻疑他有破正见事。若见闻疑他有破威仪事。以是事故遮。是名如法遮波罗提木叉。遮自恣者。四种如法遮自恣。以有根破戒遮自恣。以有根破正见破正命破威仪遮自恣。是名四种如法遮自恣。内宿者。若以羯磨结净地已。僧坊内宿饮食。大比丘不应食。故名内宿。内熟者。以羯磨结净地已。僧坊内煮饮食。大比丘不应食。故名内熟。自熟者。若大比丘自作饮食不应食。如佛在毗耶离。俭时诸檀越欲与僧作饮食。作如是念。若我自舍作饮食。多诸知识亲里来。皆应与分。若佛听僧坊内作者我当作。佛即听近僧坊外作。是火起烟尘。多人来索。若与则不供。若不与恐来伤害。往白佛。佛言。听汝僧坊内作。僧坊内作时。诸沙弥守园人。先自食饱满。余残与僧。僧食不足故皆疲极羸瘦。是事白佛。佛言。从今日如是饥饿时。若结净地若未结。听大比丘自作自食。从今日若非饥饿时。结净地已二事不应用。谓内宿内熟。不应食。若结净地若不结。大比丘自作饮食。不应食。若食者犯突吉罗。是故说名自熟。恶捉者。若持净戒比丘。故自取食。大比丘不得食。是名恶捉。不受者。若男若女若黄门若二根人不授与。大比丘不应食。是名不受。恶捉受者。若大比丘先自取。然后从净人受。大比丘不应食。是故名恶捉受。初日受者。如佛在毗耶离。饥饿时饮食难得。语诸比丘。从今日如是饥饿时。听汝若食竟不受残食法初日受食。听汝食初日受食者。若比丘早起。从他受饮食。未食留置食后。是名初日受食。从是出者。如佛在毗耶离。语诸比丘。从今日如是饥饿时。从是出食听汝食。从今听诸比丘。食竟若不受残食法。从是出食应食。从是出者。诸比丘所从檀越家食已。从是家中持食出。是名从是出。食木果者。如鸡尼耶结发梵志。多持木果来诣佛所与佛。佛语鸡尼耶。与众僧作分。是人即与诸比丘。诸比丘不受。作是言。我等食已竟。佛言。从今日如是饥饿时。食已虽不受残食法。听汝食木果。木果者。胡桃栗捺婆陀摩。如是等木果。是名木果。池物者。舍利弗热血病发。诸药师教食池物。舍利弗言。佛未听我等食池物。是事白佛。佛言。从今日听食池物。目连以神通力。曼陀耆尼池中。多持大藕根来。大如人髀。香美第一。如净白蜜。若折乳汁流出。持与舍利弗。舍利弗问。何处得来。答言。曼陀耆尼池中得来。舍利弗言。是非人处谁授汝耶。答非人授我。舍利弗言。佛未听我等从非人受食。是事白佛。佛言。从今日听从非人受食食。如是藕等池物。多煮多食多残。以是余与诸比丘。诸比丘不食。作是言。我等食竟不受残食法。是事白佛。佛言。从今日如是饥饿时。虽不受残食法。听食池物。池物者。藕根藕子菱芡根鸡头子等。是名池物。受者。受迦絺那衣处得七种利。随意畜长衣。常不失三衣。数数食别众食。过中不白善比丘入聚落。若檀越请食。食前食后随意至余处。有住处无住处。得迦絺那衣施物。应属安居比丘。余比丘不应分。是故名受。与上相违。是名不受。舍者。有八事舍迦絺那衣。一者衣足时。二者衣成时。三者去时。四者闻时。五者失时。六者发心。七者出界。八者舍时。是名为舍。不舍者。与上相违。是名不舍。可分物者。若物诸比丘现前应分。何等是。除死比丘重物。余轻物。是名可分物。不可分物者。若物诸比丘现前不应分。何等是。除死比丘衣物。余重物。是五事不分不可取。若众僧若三人若二人若一人不应分。何等五。僧伽蓝地。房舍地。僧伽蓝房舍。床卧具。是名不可分。轻物者。可分物。是故名轻物。重物者。不可分物。是故名重物。属物者。若在聚落若空处属他。若男若女若黄门若二根。是名属物。不属物者。若物在聚落空地不属他。若男若女若黄门若二根。是名不属物。手受物者。若物从他受用。何等是。一切入口物。除水及齿木。是名手受物。非手受物者。若物不从他受中用。何等是。一切所用衣钵等。不入口物及水齿木。是名不手受物。人物者。佛听僧坊使人佛图使人。是人属佛图属众僧。是名人物。非人物者。佛听象马骆驼牛羊驴骡。属佛图属僧。是名非人物。因缘衣者。若般遮于瑟等诸大会中得。是名因缘衣。死衣者。若五众死。五众所应分物。是名死衣。粪扫衣者。五种粪扫衣不应畜。一火烧。二牛嚼。三鼠啮。四初嫁女不净衣。五产衣。是五种不应畜。四种粪扫衣应畜。一冢间衣二往还衣。三无主衣。四弊纳衣。是四种应畜。是名粪扫衣。灌鼻者。佛听眼病比丘畜灌鼻筒。如毕陵伽婆蹉等。是名灌鼻。刀治者。若病余药所不能治佛听猥处以刀治。若病余药能治。而以刀治。得偷兰遮罪。是名刀治。活帝治者。佛言。若比丘病。余药不能治。听活帝。若余药能治。而以活帝治。得偷兰遮罪。是名活帝治。剃毛者。除须发。身上余毛不应剃。若剃得突吉罗。是名剃毛。剃发者。不得移处剃。应一处剃。是名剃发。故用者。如比丘五种子。五种净应用。八种浆以水净。十种衣三种坏色。是名故用。果蓏者。毗耶离诸比丘多有果蓏。诸比丘各自恣啖。佛言。作分分与。是中一比丘取二三人分。有啖不能尽者不得者。是时斗诤。佛言。从今日诸果蓏不应分。若有净人受取。以五种比丘净法。以火刀爪鹦鹉。若不生子净应啖。人用物者。人间若金银琉璃颇梨床榻器物。比丘不应坐不应用。是名人用物。非人用物者。天上金银琉璃颇梨地床榻器物。比丘应行应坐应用。是名非人用物。五百人集比尼者。佛初灭度后。五百比丘和合一处。集一切修多罗一切比尼一切阿毗昙。是名五百人集比尼。七百人集比尼者。佛灭度后百一十岁。毗耶离十事出。非法非比尼非佛教。是十事不入修多罗比尼中。与法相违威仪相违。是十事七百比丘和合一处灭。是名七百人集比尼。比尼摄者。二部波罗提木叉。并义解比尼。增一余残杂说。若共若不共。是名摄比尼。黑印者。四黑印。如经中说。四大印亦如经中说。问佛何以故。说是四黑印。答欲说真实佛法相故。来世比丘当了了知是佛说是非佛说。是故说黑印。何以故。说四大印。为成就大事不令诸比丘错谬故。说大印。合药者。诸根药茎药叶药华药果药。是药草各各差别和合。是名合药。和合药者。即日受时药。受时分药。受七日药。受尽形药。共合一处。时应服。过时不得服。即日受时分药。受七日药尽形药。共和合一处。时分应服。过时分不应服。即日受七日药。受尽形药共和合一处。七日应服。过七日不应服。若尽形药。随意应服。即日受时药昨日受时分药七日药尽形药。共和合一处不应服。即日受时分药。昨日受七日药尽形寿药。共和合一处不应服。即日受七日药。昨日受尽形药。共和合一处不应服。是名和合法。问时分七日尽形寿得宿受不。答不得。恶捉不受得受不。答不得。手受口受无病得服不。答不得。手受口受病得服不。答得。僧坊净法者。若五宝若似五宝。在僧坊内。比丘取时应作是念。此谁物当还。是名僧坊净法。林净法者。林名众多树一处。是中应随上座取。是名林净法。房舍净法者。僧坊中多有别房舍。是中应随上座取次第应住。是中随檀越分处供养应受。是名房舍净法。时净法者。饥饿时。老病时。因缘时。佛有所听。是名时净法。方净法者。如比丘阎浮提住至俱耶尼。用阎浮提时俱耶尼食。三方亦如是。是名方净法。国土净法者。得神通诸比丘。至恶贱国土乞食。是比丘先从恶贱人受食啖。此人心悔。我等堕不净数。便不复乞。是人持食于比丘前弃地而去。诸比丘不知云何。佛言。从今日至恶秽国土。弃食着地得自取食。随国土法故。如边地持律。第五得受具足戒。阿叶波伽阿槃提国土。听着一重革屣常洗浴皮褥覆。如寒雪国土中。听畜俗人靴具。是名国土净法。衣净者。佛听着十种衣。何等十。白麻衣。赤麻衣。刍摩衣。憍施耶衣。翅夷罗衣。钦跋罗。衣劫贝衣。钵兜路衣。头头罗衣。俱遮罗衣。是名衣净法(具足戒竟)

自恣法者。安居比丘应一处和合。众僧应三种自恣。若见若闻若疑问。何以故。佛听自恣。答以摄众僧故。好恶相教化故。尔时出过罪如法得清净。是名自恣法。与自恣者。病比丘不能来。应与自恣。若不病比丘自恣时不来。得突吉罗。若是比丘。畏失命若破戒。若八难中一一难起。不得止。应与自恣。是名与自恣。受自恣法者。若比丘从他比丘受自恣。界内应受。若畏失命破戒若八难中一一难起。尔时应出界去。是名受自恣法。说自恣法者。比丘从他受自恣。到僧中应说。若不说得突吉罗。若受自恣人睡眠若入定。若八难中一一难起不说无罪。是名说自恣法。布萨法者。半月半月诸比丘和合一处。自筹量身。昼作何罪夜作何罪。从前说戒以来。将不作罪耶。若有罪。当向同心净戒比丘如法忏悔。若不得同心净戒比丘。当生心。我后得同心净戒比丘。当如法忏悔。问何以故。佛听作布萨。答令诸比丘安住善法中舍离不善离不善法得清净故。是名布萨法。与清净法者。布萨时病比丘不能来。应与清净。若能来而不来。得突吉罗。若是比丘。畏失命若破戒。若八难中一一难起。不得已与清净。是名与清净法。受清净法者。若比丘从他比丘受清净。界内应受。若是比丘。畏失命破戒。若八难中一一难起。尔时应出界去。是名受清净法。说清净者。比丘受他清净。到僧中说者善。若不说。得突吉罗。若受清净人。若睡眠若入定。若八难中一一难起。不说无罪。是名说清净法。欲法者。欲名发心。如法僧事中随僧法与欲。是名欲法。与欲法者。若比丘病不能来。应与欲。若不病能来而不来。得突吉罗。若比丘畏失命畏破戒。若八难中一一难起。不得止故与欲。得来而不来。得突吉罗。与欲者应言。比丘与欲来。若言与。是名得欲。若身业与。是名得欲。若口业与。是名得欲。若身口业不与。不名得欲。应将是比丘来僧中。若不来应一切僧就是比丘诸比丘不应别作羯磨。若别作羯磨。诸比丘得罪。是名与欲法受。欲法者。若比丘从他比丘受欲。界内应受。若是比丘畏失命畏破戒。若八难中一一难起。应出界去。是名受欲法。说欲法者。受欲比丘到僧中。应说彼比丘。欲若说者善。若不说得突吉罗。若是比丘。若睡眠若入定。若八难中一一难起。不说。无罪。是名说欲法。清净法者。比丘语他。我清净无罪。是名清净法。与清净法者。若比丘病不能来。应与清净。若无病能来而不来。得突吉罗。若比丘畏失命畏破戒。若八难中一一难起。不得止故。应与清净。与清净法者。语比丘言。与清净来。若言与。是名得清净。若身业与。亦名得清净。若口业与。是名得清净。若不以身口业与。不名得清净。应将是比丘来僧中。若不来。一切僧应就是比丘。诸比丘不应别作布萨。若别作。诸比丘得罪。是名与清净法。欲清净法者。若布萨时僧欲作种种羯磨。尔时应俱与欲清净。是名欲清净法。与欲清净法者。若比丘病不能来。应与欲清净。若不病能来。应到众僧布萨羯磨处。若无病能来而不来。得突吉罗。若是比丘。畏失命畏破戒。若八难中一一难起。不得出故。应与欲清净。比丘应语他比丘。与欲清净来。若言与。是名得欲清净。若身业与。亦名得欲清净。若口业与。是名得欲清净。若不以身口业与。不名得欲清净。应将是比丘到僧中。若不能来。一切僧应就是比丘。诸比丘不应别作布萨羯磨。若别作。诸比丘得罪。是名与欲清净法。受欲清净法者。比丘欲受他欲清净。应界内受。若畏失命畏破戒。若八难中一一难起。应出界去。是名受欲清净法。说欲清净法者。受他欲清净者。应到僧中说。彼比丘欲清净。若说者善。若不说。得突吉罗。是比丘若睡眠若入定。若八难中一一难起。不说无罪。是名说欲清净法。起塔法者。给孤独居士深心信佛。到佛所头面礼足一面坐。白佛言。世尊。世尊游行诸国土时。我不见世尊故甚渴仰。愿赐一物我当供养。佛与爪发言。居士。汝当供养是爪发。居士即时白佛言。愿世尊。听我起发塔爪塔。佛言。听起发塔爪塔。是名起塔法。塔地者。属塔地者。园田谷田。于中初起塔。是名塔地。龛塔法者。佛听作龛塔柱塔。佛广听一切作塔。是名塔法。塔物无尽者。毗耶离诸估客。用塔物翻转得利供养塔。是人求利故欲到远处。持此物与比丘言。长老。是塔物。汝当出息令得利供养塔。比丘言。佛未听我等出塔物得利供养塔。以是事白佛。佛言。听僧坊净人若优婆塞出息塔物得供养塔。是名塔物。无尽供养塔法者。所应供养塔。若白色赤色青色黄色诸色等。听供养塔及诸严饰具。是名供养塔法。庄严塔法者。所应庄严塔。若金刚座。高堂高楼重阁。悬诸宝铃光相璎珞缯幡华盖金银真珠车磲马瑙琉璃颇梨等种种宝物。如是等妙庄严具。是应供养塔。是名庄严塔法。花香璎珞法者。所应供养塔。花香末香涂香。花璎珞宝璎珞。罗列然灯作众伎乐。香涂墙壁分布香奁。应布花香香油洒地。是名花香璎珞法。坚法者。比丘随所住房。是中随檀越分处应受供养。是名坚法。坚坚法者。若檀越与比丘饮食并衣被。以是因缘故。舍离二事数数食别众食。是名坚坚法。粥法者。佛听食八种粥。酥粥油粥。胡麻粥乳粥。小豆粥摩沙豆粥。麻子粥清粥。啜时不作声。是名粥法。啖法者。佛听九种啖。根啖茎啖叶啖。磨啖果啖胡麻啖。石蜜啖白蜜啖。啖时勿令大作声。是名啖法含消法者。佛听四种含消。酥油蜜石蜜。比丘含是四含消时。应作是念。我以治病因缘故含。不为美味。是名含消法。食法者。佛听食五种食。饭糗糒鱼肉。比丘食是食。应生厌心。为存身命故。念莫堕数数食别众食。又作是念。受残食想。是名食法。钵法者。佛听畜二种钵。瓦钵铁钵。八种钵不应畜。金钵银钵。琉璃钵摩尼钵。铜钵白镴钵。木钵石钵。是名钵法。衣法者。七种衣。不须作净。得自畜。僧伽梨。郁多罗僧。安陀会。雨浴衣。覆疮衣。尼师坛。及余如法所用衣物。是名衣法。尼师坛法者。佛听畜尼师坛。为爱护卧具故。无尼师坛不应坐僧卧具上。是名尼师坛法。针法者。佛听畜二种针。铜针铁针。糠米鼻小豆鼻圆鼻。是名针法。针筒法者。佛听畜针筒。为爱护针不令数失。更求觅妨行道故。是名针筒法。水瓶法者。佛听畜水瓶。好净洁畜。是名水瓶法。常用水瓶法者。亦应净洁畜水瓶水。盖亦如是。是名常用水瓶法。和上法者。诸比丘无和上。则作诸弊恶。若病无人瞻视。是故佛听有和上。和上当教化瞻视为汝说法。佛虽听作和上。诸比丘不欲作和上。佛教令作和上。是名和上法。共行弟子法者。所欲出行应白和上。行时应随和上后供给所须。常随逐不远离。如法事中莫违逆意。一切所作皆应白和上。除大小便啮齿木礼佛法僧。是名共行弟子法。阿阇梨法者。诸比丘无阿阇梨。作诸弊恶若病无人瞻视是故佛听有阿阇梨。阿阇梨常教化瞻视为汝说法。佛虽听作阿阇梨。诸比丘不欲作阿阇梨。佛教令作阿阇梨。是名阿阇梨法。近行弟子法者。所欲出行应白阿阇梨。行时应随阿阇梨后供给所须。当随逐不远离。如法事中莫违逆意。一切所作皆应白阿阇梨。除大小便啮齿木礼佛法僧。是名近行弟子法。和上阿阇梨共行近行弟子法者。和上阿阇梨。于共行近行弟子。应生儿子想。共行近行弟子。于和上阿阇梨。应生父想。汝等能如是者。于我法中增长善法。是名和上阿阇梨。共行近行弟子法沙弥法者。佛听沙弥极小乃至七岁能驱食上乌者。是名沙弥法。依止法者。有一客比丘。未满五岁。日暮来入僧坊求依止。久而不得。迷闷躄地垂死。诸比丘以是事白佛。佛言。从今日莫即日急求依止。听一宿息已当求依止。尔时诸比丘。不问好恶趣得依止。不能增长善法。佛言。莫趣得依止。当观是比丘能教化弟子令善不。如是观察。具足功德者。当求依止。若无具足功德者。当更求依止。是名依止法。与依止法者。比丘若满十岁。应与他依止法。满十岁钝根不了。不应与他依止。是名与依止法。受依止者。比丘应从座处起。偏袒着衣脱革屣胡跪曲身。两手捉上座两足。应三说求依止。是名受依止法。舍依止法者。有五因缘舍依止。一师波那祢。二自舍住处去。三反戒。四舍此部到异部中。五见本和上。是名舍依止法。地法者。随应何地欲起塔僧坊。先应看是地中作。不妨行来处。树林具足。水具足。昼夜静寂。少蚊虻少风少热少诸毒蝎。如是观察地起塔僧坊。若不观察是地。起塔僧坊者。治塔僧坊比丘。得突吉罗。是名地法。僧坊法者。佛听诸僧坊中温室讲堂楼阁一重舍尖头舍揵那舍。佛听是诸坊舍众僧畜。亦听一人畜。是名僧坊法。卧具法者。佛所听诸比丘卧具。粗陛绳床细陛绳床。毡褥卧具种种覆处。佛听众僧畜。亦听一人畜。是名卧具法。治塔僧坊法者。阿罗毗国诸塔僧坊毁坏。佛知已故问阿难。是诸塔僧坊。何以故毁坏。阿难言。诸六群比丘欲治故。余比丘畏不敢治。佛言。此六群比丘所欲治塔僧坊。众僧应羯磨与余人治。受羯磨比丘少多造手。或着一土墼。或以一束草或塞一孔。或涂地泥壁。或以牛粪涂地涂壁。如是少多作已言。我更不欲作。佛言。如是人不应与作羯磨。若是比丘能大作功德修治者。应与治塔僧坊羯磨。是名治塔僧坊法。治塔僧坊人法者。若比丘欲新起塔僧坊新作卧具。佛言。以是事故。僧应令十二岁悉舍余事。当随事大小。或十一岁十岁。九岁八岁。七岁六岁。五岁四岁三二一岁。应舍余事。但令垒壁构架材木泥覆污饰。是名治塔僧坊人法。恭敬法者。随上座次第。礼拜迎来送去。合掌曲身上座边立。是名恭敬法。澡豆法者。佛听用小豆大豆摩沙豆豍豆胡豆屑一梨梨频陀等干草屑。莫杂香作。除病人。余不听用。若不索。檀越自与。随意得用。是名澡豆法。浆法者。佛听八种浆等。比丘应饮。昭梨浆。莫梨浆。拘罗浆。舍梨浆。舍多浆。蒲桃浆。颇楼沙浆。梨浆。是八种浆等。以水作净应饮。是名浆法。药法者。根药茎药叶药花药果药。佛听是药草。亦听众僧畜。亦听一人畜。是名药法。苏毗罗浆法者。佛听饮苏毗罗浆。为冷病比丘故。如为舍利弗故听饮。是名苏毗罗浆法。皮韦法者。若诸皮韦。比丘不应畜着不应坐。除富罗。除革屣。除富罗带革屣带。除摩栈皮鹿皮。及除革屣网纽。是名皮韦法。革屣法者。佛听二种革屣。一重革屣。破慢净革屣。若杂色庄严革屣不应畜。是名革屣法。支足法者。佛听二种支足物。一者厕蹬。二者支床脚物。八种支足物不听用。是名支足法。机法者。若动摇若有声若庄严。如是机不应畜。是名机法。杖法者。佛听杖[矛*(替-曰+貝)]。若铁若铜。为坚牢故。上作楼环。又杖法者。佛在寒园林中住。多诸腹行毒虫啮诸比丘。佛言。应作有声杖驱遣毒虫。是名杖法。杖囊法者。佛听以络囊盛杖。为爱护故。莫令破失。更求觅妨行道故。是名杖囊法。啖蒜法者。佛听冷病比丘啖蒜。以药和啖。如舍利弗等。随啖蒜法应行。是名啖蒜法。剃刀法者。佛听众僧畜剃刀。一人亦畜。为剃须发故。是名剃刀法。剃刀鞘法者。佛听诸比丘畜剃刀鞘。为赏护莫令失。更求觅妨行道故。户钩法者。佛听畜户钩。为守护房舍。守护房舍故则守护自身。守护自身故则守护卧具。若锁若户橝鑐钥等亦如是。是名户钩法。乘法者。佛听眼病诸比丘乘乘。如毕陵伽婆蹉。是名乘法。盖法者。不应捉盖入白衣舍。除施盖持入。是名盖法。扇法者。佛听众僧畜扇。一人亦畜。是名扇法。拂法者。佛听众僧畜拂。一人亦畜。是名拂法。镜法者。比丘不应镜中观面。不应钵中水中自看面。除面上有疮。是名镜法。治眼法者。有五种治眼物。黑物青白物屑草屑华屑果汁。佛言。莫为端严故治眼。为治眼病故。是名治眼法。治眼筹法者。佛听治眼筹法以铁作铜作贝象牙角木瓦作。是名治眼筹法。盛眼药筹物法者。是物应好赏护。莫令失更求觅妨行道。是名盛眼药筹物法。华香璎珞法者。比丘自不得着。亦不应教他人着。若不乞而得。应随意受已持供养佛塔及阿罗汉塔。是名花香璎珞法。歌舞伎乐法者。歌舞伎乐。比丘自不应往观。亦不应教他往观。是事一切不听。是名歌舞伎乐法。卧法者。无病比丘昼日不应卧。夜若然烛不应卧。若喜鼾眠。应起经行。若不能起。应屏处去。莫以是因缘恼乱余人。是名卧法。坐法者。比丘昼日若坐若经行。以遮恼盖法。昼日若坐若经行。遮恼盖已。初夜若坐若经行。亦以遮恼盖法。初夜若坐若经行。遮恼盖已至中夜。息故入房舍。四牒敷郁多罗僧僧伽梨枕头下。方胁着床累足。明相现前忆念起想。后夜早起。若坐若经行。遮恼盖法。是名坐法。禅杖法者。佛听法杖及安法杖处。为赏护莫令失。更求觅妨行道。是名禅杖法。禅带法者。佛听腰病比丘畜禅带。如为舍利弗故听畜。是名禅带法。带法者。佛听三种带。绳织带编带毳绳带。是名带法。衣鞙带法者。佛听畜衣鞙带。为摄衣令不堕落。应好赏护。莫令失。更求觅妨行道故。是名衣鞙带法。抄系衣法者。除上高作。余时不应抄系。是名抄系衣法。挑掷法者。佛听挑掷作声。为怨贼故。莫令着。余时不得作。是名挑掷法。地法者。佛听受地。为僧伽蓝故。听僧起坊舍故。林者。林名众树。事者。名斗乱相言谗谤出罪过咎。共相憎共相别离。如是于自身恶。亦令他恶。亦二恶故。不应作如是等种种衰恼事。一切不应作破僧。有二种破羯磨破轮。破羯磨者。若诸比丘一界内别作布萨羯磨。是名破羯磨。破轮者。轮名八种圣道分。令人舍八圣道入邪道中。是名破轮。是名二种破僧。如是应看和上阿阇梨。看上座中座下座。如上所说法应学。如上所说法中。亦应善知(法部竟)

行法之初

行法者。摈比丘云何行。诸比丘应教摈比丘舍是恶事。摈比丘。不应与他受具足戒。不应与他依止。不应畜沙弥。众僧不应羯磨是人令教化比丘尼。若僧羯磨作教化比丘尼。是人不应受。不应重犯所摈罪。又不应作相似罪。过本罪亦不应作。不应呵羯磨。不应呵作羯磨人。不应受不摈比丘礼拜。亦不应受起迎。不应受合掌曲身恭敬。不应受衣钵供养。不应受所敷卧具坐具供养。不应受洗足水供养。不应受拭足供养。不应受承足机。不应受按摩手足。不应出不摈比丘过罪。不应言不摈比丘。不应共事。常行自折伏心。随顺诸比丘。应礼拜迎送种种供养。若不如是法行。尽形不得解摈。是名摈比丘行法。种种不共住行法。云何种种不共住。有二种。一自作不共住。二众僧羯磨作不共住。种种不共住比丘。不应与他受具足戒。不应与他依止。不应畜沙弥。众僧不应羯磨令教化比丘尼。若僧羯磨作教化比丘尼。不应受。不应起本所作种种不共住罪。亦不应犯相似罪。亦不应作过本罪。不应呵羯磨。亦不应呵作羯磨人。不应受不别住比丘礼拜。不应受起迎合掌曲身种种供养。不应受衣钵供养。不应受所敷坐具卧具供养。不应受洗足水承足机按摩手足等供养。不应出不别住比丘过罪。不应言不别住比丘。不应共事。僧不应羯磨作敷卧具人。若僧羯磨作。不应受。僧羯磨作使沙弥人。不应受。僧若羯磨不应作。僧若羯磨作使守园人。不应受。僧若羯磨不应作。若僧羯磨作处分受请人。不应受。若僧羯磨不应作。一切羯磨作典知众事人。不应受。若僧羯磨不应作。应折伏心行。莫犯诸比丘。若犯诸比丘。更增种种不共住。诸比丘应语是比丘言。长老。当折伏恶心下意除去嗔恨破憍慢。莫令众僧合种种不共住罪。驱汝去。处处皆不容汝。汝应在此众僧中忏悔此罪。汝此罪此僧能解。余处僧不得解。若是人闻是语。心不折伏。当驱遣。如恶马拔羁系逸去。是名种种不共住比丘行法。闼赖吒比丘行法。云何有二十二法。当知是利根多闻。何等二十二。善知事起根本。善分别事相。善知事差别。善知事本末。善知事轻重。善知除灭事。善知灭事更不起。善知作事人有事人。有教敕力。能使人受力。有方便软语力。亦能使人受。有自折伏力。亦能使人受。知惭愧心不憍慢无憍慢语。身口意业无所偏着。不随爱行。不随恚行。不随怖行。不随痴行。成就是二十二法能遏诤事。不依二伴党求法求财。是名闼赖吒比丘行法。实觅罪相行者。若比丘自言。我有是罪。后还言无。是比丘。以白四羯磨。与实觅罪相。广作羯磨。如象首比丘。若比丘得是实觅罪相羯磨。是比丘亦不应与他受具足戒。不应与他依止。不应畜沙弥。众僧不应羯磨令教化比丘尼。若僧羯磨作教化比丘尼。不应受。不应起本所作罪。亦不应犯相似罪。亦不应作过本罪。不应呵羯磨。亦不应呵作羯磨人。不应受净戒比丘礼拜。不应受起迎合掌曲身种种供养。不应受衣钵供养。不应受所敷坐具卧具供养。应受洗足水承足机按摩腰背手足等供养。不应出净戒比丘过罪。不应言净戒比丘。常行自折伏心。随顺诸比丘。应礼拜迎送种种供养。若不如是法行。尽形不得解是羯磨。是名实觅罪相比丘行法。波罗夷与学沙弥行法者。若比丘作淫欲已。乃至弹指顷。不生覆藏心。众僧以白四羯磨。还与是比丘学法。广说如与难提。是名与学沙弥。大比丘戒一切应持。应在大比丘下行坐。应授大比丘饮食。自应从未受具戒人受饮食。得与大比丘同室再宿。自不得与未受大戒人过再宿。是与学沙弥。得作二羯磨。布萨羯磨自恣羯磨。是与学沙弥。不得与众僧足数作布萨及诸羯磨。是名波罗夷与学沙弥行法

十诵律卷第五十六十诵律卷第五十七(第十诵之二)

        后秦北印度三藏弗若多罗译

    比尼诵行法之余

僧上座法者。上座法。若僧唱时。若打揵椎时。应疾到坐。坐已看上中下座。莫令失次。教令相近坐。应示相。若不觉。应弹指向。若弹指不觉。应语比坐。应徐徐软语。若饮食时。上座应教一切等与。应待唱僧跋一切众僧应随顺上座。是名僧上座法。僧坊上座法者。若僧坊破坏。是上座应自治。若使人治。若不见比丘。应推觅。若有病比丘。应看视问讯。若无看病人。应与看病人。若僧差看病人。是人不肯。应次第看。若是僧坊中僧应得利施。上座应一心勤作方便令不失若得是利施物。应置随所堪能比丘令分处。若僧坊中有所作事。上座应先自手作。是名僧坊上座法。别房上座法者。是别房若毁坏。上座应自治若使人治。若不见房中比丘。应推觅。若有病比丘。应看视问讯。若无看病人。应与看病人。若看病人不肯。别房中应次第看若是别房中僧应得利施。上座应一心勤作方便令不失。若得是利施物。应置随所堪能比丘令分处。若别房中有所作事。上座应先自手作。是名别房上座法。阿蓝者。僧伽蓝。僧伽蓝中种种制限。是制限若随法。不自恼亦不恼他。是应受。若知制限失利。为自恼亦恼他。不应受。应余处去。若是比丘。自知有同见势力能如法灭是恶制。当白众僧灭。是名阿蓝法。林法者。林名丛树。是林枝叶相接。面拘卢舍内。随意不失衣。是名林法。阿蓝者。僧伽蓝。僧伽蓝中多诸别房。别房中有种种制限。是制限若随法。不为自恶亦不为他恶。是应受。若知是制限失利。为自恶亦他恶。不应受。应余处去。若是比丘。自知有同见势力能如。法灭是恶制。当白众灭。是名别房法。房舍法者。若比丘随所住房舍。应扫洒泥涂晒治卧具。若有垢应浣。若欲出行。应还僧卧具闭户下钥。是名房舍法。卧具法者。若比丘着僧卧具。得出僧坊门外四十九寻。不得过。若过至地了时。得突吉罗。户法者。户名出入处。若打户时不应大打。若开户时不得大排。若闭户时当徐徐。入出户时亦应安徐一心。莫令衣摩户两边。是名户法。向法者。应施橝去时当闭。为守护僧房亦守护自身故。是名向法。空僧坊法者。比丘若入空僧坊。应扫洒令净。是中若有器物。应洗者当净洗着覆处。若有净人。当令却僧坊中草。若无净人。比丘如法应作者当作。不应空僧房中直出入。是名空僧房法。钵法者。比丘应看钵如自眼。不应置地。不应置石上。不应置高处。不应置屋霤处。不应置墙头。不应置大小便处及洗大小便处。不应持入浴室。不应以杂沙牛屎洗。若未干不应举。亦不得令太干。不应故破。不得轻用。应好赏护。勿令破失。以更求因缘故妨行道。是名钵法。衣法者。当赏护衣如自皮。若着僧伽梨。不得捉持瓦石泥土草木等。不应以青黄等色涂染。若着僧伽梨。不应扫洒涂地。不应以足蹑。不应敷坐。不应敷卧。不应衬身着僧伽梨。随僧伽梨法应用。郁多罗僧。随郁多罗僧。法应用。安陀会。随安陀会法应用。是三衣应用净染坏色畜。五种纯色不应着。余异色点及纳衣。若比丘贫少衣。不能得割截衣。应衣上安叶。若五若七若九若十一若十三若十五。若过十五若能得应。割截作僧伽梨郁多罗僧安陀会。是名衣法。尼师坛法者。比丘不应受单尼师坛。先受尼师坛不应离。若舍得突吉罗。是名尼师坛法。针法者。如上说。针筒法者。佛听畜针筒。为安针故。比丘当赏护。莫令失。更求觅妨行道故。破戒无惭愧沙弥不应令举。是名针筒法。净水瓶法常用水瓶法。亦如上说。粥法者。有五利益故。听啜粥。除饥除渴下气除脐下冷消熟藏中生者。是名粥法。食法者。比丘食五食时应观。是食难求得难成办。当观入口在生藏熟藏。若出时由是。食因缘故。起种种烦恼罪业受苦果报。是名食法。食处法者。比丘若到食处。应默然一心净持威仪。能起他净心。当徐入徐坐。是名食处法。与食法者。比丘未受食。不应与他。先受已后当与他。阿谁应与。若父若母。若与闭系人。若与急须食人。若妊娠女人来。应正观当少多与。畜生应与一口。是名与食法。乞食法者。比丘应一心从檀越受食。莫散乱心。勿观好恶。应生不净想。是名乞食法。乞食人法者。如杂部中广说。乞食持来法者。当一心持食。莫令散失。勿观好恶。应观时节早晚持食来。是名乞食持来法。阿兰若法者。阿兰若比丘。应常一心先问讯人。喜心和视共语。舍离颦蹙。赞言善来。应畜火及火炉。少多办食及食器。常畜水及水器。洗足水器常令有水。净澡罐厕澡罐中。亦应令有水。应善知道径。善知日数。善知夜善知夜分。善知星宿。读诵星宿经。善知修妒路比尼阿毗昙。若善知初禅二三四禅。应善知须陀洹斯陀含阿那含阿罗汉果。若不能得修学。当问知当读诵。不应畜日爱珠月爱珠。应畜法杖。所畜物皆随顺道。如俱尼舍经广说。是名阿兰若法。阿兰若上座法者。若诸比丘出界。阿兰若上座。应善教化下座比丘。应为说阿兰若法示教利喜。诸下座比丘应随上座教行。若诸居士至阿兰若处。应为说甚深法。应示正道邪道。应说知见。若诸居士去者善。若不去。少多与食。应作是言。我唯有是食。是名阿兰若上座法。近聚落住法者。近聚落住比丘。应常一心先问讯人。喜心和视共语。舍离颦蹙。赞言善来。应畜火及火炉。少多办食及食器。常畜水及水器。洗足水器常令有水。净澡罐厕澡罐中。亦应令有水。应善知道径。善知日数。善知夜善知夜分。善知星宿。读诵星宿经。善知诵修妒路毗尼阿毗昙。善知初禅二三四禅。应善知须陀洹斯陀含阿那含阿罗汉果。若不能得修学。当问知当读诵。不应畜日爱珠月爱珠。所畜物皆随顺道。如俱尼舍经广说。是名近聚落住法。近聚落住上座法者。若近聚落住上座比丘。诸比丘出界。上座应教化下座比丘。为说近聚落住法示教利喜。诸下座比丘应随上座教行。若诸居士来。应为说甚深法示正道邪道。应说知见。教布施持戒忍辱行。善受持八戒。是名近聚落住上座法。洗足盆法者。比丘见洗足盆空。应自着水。若使人着。是名洗足盆法。洗足上座法者。若下座已洗足。上座不应驱遣。若驱得突吉罗。是名洗足上座法。客法者。若客比丘初到僧房中。偏袒着衣。若泥洹僧高。应下着。若衣囊在右肩上。应转着左肩上。若杖油囊革屣针筒在右手中。应移着左手中。若有大小便。应先在外却已入僧房。若得水洗足已入。若不得水。以草木树叶拭足已入。若门闭。应求开门。若开应入。若不开。僧房外有墙堑刺蕀。应在现处立。一心净持威仪。能起他善心。若见旧比丘应问。此僧房中有若干岁比丘房舍不。若言有。即语开门。开门已入复问。是房舍中为有人为空耶。若言空。应问。用何等水。若言井水。应索罐及绳扫彗。应开房户弹指。若有毒虫闻声便去。当安徐往出枕被褥床榻覆地物。出已应扫洒泥涂。抖擞荐席被褥枕覆地物觅虫。觅虫已还如本敷。洗足瓮净澡罐厕澡罐中皆着水。持革屣至水边。浣拂拭物。浣已绞捩。绞捩已擘散。然后捉革屣。先拭前头。次拭后拭中拭带。若水瓶在右边。应右手取水左手洗足。若在左边。应左手取水右手洗足。洗足已着革屣入房。闭户下橝坐绳床。先徐摄一脚。次摄第二脚。摄已大坐正观诸法。地了已应问旧比丘。此僧房中有前食后食不。应问乞食处。何处有恶狗恶牛大童女寡妇。何处是僧学家羯磨覆钵羯磨。何处可行。何处不可行。问是等事已应行乞食。若是客比丘欲去。罐绳扫彗还付本主。摒挡卧具闭户下橝已去。是名客比丘法。客比丘上座法者。客上座应筹量客比丘多少。应语旧比丘言。我尔所客比丘来。当知须尔所卧具。是名客比丘上座法。欲行比丘法者。若比丘明日欲行。今日应辞和上阿阇梨。若听去便去。若不听去。不得强去。若是中住。知不能增长善法。当出此僧房观诸方筹量伴侣。是人真实不。同心不。若道路病痛。不弃我去耶。如是筹量已应去。若不如是筹量去。得突吉罗。是名欲行法。欲行比丘上座法者。欲行时上座应最后发。当付嘱僧卧具。出僧房已语诸伴党。莫有所忘。若伴党有所忘物。上座应不远待道中。应教化等伴。莫令作非法散乱调戏。是名欲行上座法。非时法者。若比丘非时欲行。应白和上阿阇梨。我至某城邑某聚落某甲舍。若听便去。若不听不应强去。是名非时法。非时会法者。除六斋日。余非时会非时事非时坐。若闻唱时。打揵椎时。应速去速次第坐。应随法随比尼随佛教行。莫轻上下座。是名非时会法。非时会上座法者。如上说。僧上座会坐法者。月六斋。所谓八日十四日十五日二十三日二十九日三十日。于是日无病比丘。应和合一处说法。是中若外道论议师。怀嫉妒心。来欲破说法。比丘当如法难诘降伏。莫嗔恶口。是名会坐法。会坐上座法者。若下座先坐。上座来不应令起。若驱令起。得突吉罗。是名会坐上座法。说法人法者。应一心说法生慈悲利益心。当净洁明了庄严语言次第相续辩才无尽。如是说法随顺诸法实相。为法故说不为利养。是名说法人法。说法人上座法者。若下座法师说法。上座法师应观察所说。为次第说。为不次第说。为说法。为说非法。若次第说法。应随顺赞善。不次第若说非法。应呵止。是名说法人上座法。诸外道梵志六斋日和合一处说法。大得利养增长徒众。洴沙王深爱佛法故。作是念。愿诸比丘。六斋日和合一处说法。我当引导大众自往听法。令诸比丘以是因缘大得供养增长徒众。以是事白佛。佛言。从今日听诸不病比丘六斋日和合一处说法。诸比丘随佛教。听六斋日一处说法。国王群臣皆来听法。诸比丘大得供养。徒众增长。诸比丘或有坐地说法。音声不能远闻。作是念。佛听我立说法善。以是事白佛。佛言。听立说法。尔时诸比丘广说大经。说者劳闷听者疲极。以是事白佛。佛言。若宜止时到听止。时诸比丘。取佛经义自用心广分别说。诸比丘心疑。将无坏法耶。以是事白佛。佛言。从今日听取佛经义庄严言辞次第解说。佛经本当直读诵。莫杂论议。尔时诸比丘处处乱呗。佛言。不应处处乱呗。尔时二比丘一处合呗。佛言。不得二比丘合呗。若合呗得突吉罗。时诸比丘以是说法呗取财利。佛言。不应以法取财利。若取得突吉罗。尔时说法呗者。将大众到余处说法呗。佛言。不应将大众到余处说法呗。除自徒众。尔时诸比丘。令一眼无眼通精瘿无手偻脊跛人说法赞呗。时有贤者深爱佛法。诸外道嗤弄言。此是汝等赞施师。汝等塔。汝等所尊敬。先受供养在前食。在汝等前行者。正如是耶。诸贤者皆大羞愧。以是事白佛。佛言。从今日一眼无眼通精瘿无手跛偻脊。不应请说法赞呗。若请得突吉罗。尔时有诸破戒破正见人令说法。是人说法因缘。大得供养徒众势力。行非法事不可禁止。诸比丘以是事白佛。佛言。从今日不应请破戒破正见人说法。若请说得突吉罗。不知使谁说法赞呗。佛言。若请先习说法赞呗者令作。若无先习说法赞呗者。当次第语令说法呗。若诸比丘中无先习说法呗者。又不次第说法呗。诸比丘得突吉罗。是名说法法。不说法法者。如杂部中广说。安居法者。比丘若欲安居。先应筹量住处。若住处出入安隐。有好树林有好水。昼夜少音声。少蚊虻蜈蚣毒蛇。少风少热。是中有真实比丘得同意比丘。共安隐坐禅说法听法。若疾病当得随病药随病饮食瞻病人。筹量如是事已应安居。若不如是筹量安居。得突吉罗。安居中法者。比丘安居中无佛所听因缘。不应出界宿乃至一夜。如伽尸王子出家作比丘。父王欲起佛图。遣使唤儿。汝来共起佛图。是比丘言。佛未听我为作佛图故破安居。以是事白佛。佛言。从今日听为起佛图故去。是名安居中法。安居上座法者。安居上座应观诸房舍。谁治谁不治。若治应赞言善好。若不治教令治。是名安居上座法。安居竟法者。比丘安居已应作三事。更唱界分。若受迦絺那衣。随得施物。迦絺那衣所摄。随所住房。应洒扫泥涂。若卧具有尘土垢腻。应抖擞浣。浣治已还置本处。出户下橝听随意去。是名安居竟法。受众法者。比丘应筹量。众为乐说法。为乐默然。若乐说法。应随宜为说。若乐默然则止。是名受众法。往众会法者。比丘应先分别。往刹利众应如是。往婆罗门众应如是。往居士众应如是。往比丘众应如是。往到是众中应如是。入出行坐应如是。问讯如是言说。或时应默然。是名往众会法。受众法者。受众比丘应观。是众谁善行谁不善行。若善行者。应好看视供给衣钵汤药所须。若有罪。应佐助令得出。若非善行者。应如法呵责令心调伏。是名受众法。受众上座法者。受众上座。应如法教化众。莫令非法调戏散乱。是名受众上座。说波罗提木叉法者。五种说波罗提木叉。说戒序。余残如僧常闻。乃至僧说戒布萨竟。是名为一。又复说戒序说四波罗夷。余残如僧常闻。乃至僧说戒布萨竟。是名为二。又复说戒序说四波罗夷说十三僧伽婆尸沙。余残如僧常闻。乃至僧说戒布萨竟。是名为三。又复说戒序说四波罗夷说十三僧伽婆尸沙说二不定法。余残如僧常闻。乃至僧说戒布萨竟。是名为四。第五广说。是名波罗提木叉法。说波罗提木叉人法者。说波罗提木叉比丘。先当闇诵令利。莫众僧中说时错谬。是名说波罗提木叉人法。僧会法者。除月六斋日。余残僧会僧事僧坐处。唱时打揵椎时。诸比丘应速去如法次第坐。应随法随比尼随佛教行。不轻上中下座。是名增会法。上座法者。如上非时会上座说。中座法者。中座。下座比丘欲入白衣舍。当推上座在前。应恭敬上座。若上座便利。中座下座。应待。不应远去。若白衣来语。诸长老入。当答言。小待。须上座至。若檀越急唤入。当留上座所坐处然后坐。檀越言。受水。当言。小待。须上座入。是名中座法。下座法者。下座比丘。应扫洒佛图讲堂布萨处佛图门中众僧会处地。应次第敷坐床。应办火及火炉。应办灯及灯具。洗足盆中着水。净澡罐厕澡罐中皆着水。如是僧所有作事。下座皆应作。是名下座法。上中下座法者。上中下座比丘。随佛所说戒尽应受持。是名上中下座法。浴室法者。比丘入浴室。应一心小语好持威仪收摄诸根。是名浴室法。浴室洗法者。浴室中洗得五利。一除尘垢。二治身皮肤令一色。三破寒热。四除风气。五少病痛。是名浴室洗法。浴室上座法者。浴室中上座若见下座比丘已洗。不应驱遣。若驱遣得突吉罗。是名浴室上座法。和上法者。和上应教化共行弟子。遮令离恶知识。令近善知识。当佐助衣钵汤药。若有罪。佐助令得出。是名和上法。共行弟子法者。共行弟子不应轻慢和上。有所作事皆应白和上。行时当随从和上后。常供给一切所须。常随和上意。不得违逆。若有所作。不白和上不得作。除礼佛法僧用齿木大小便。若共行弟子。于和上边知不能增长善法。应白和上。持我付嘱某甲比丘。和上应筹量。是比丘教化法何似。弟子众复何如。若知是比丘具足善法。当付嘱。若知不具足。当更付嘱余比丘。若知和上不好。应舍去。是名共行弟子法。阿阇梨法者。阿阇梨应教化近行弟子。遮令离恶知识。令亲近善知识。当佐助衣钵汤药。若有罪。佐助令得出。是名阿阇梨法。近行弟子法者。近行弟子。不应轻慢阿阇梨。其所作事。皆应白阿阇梨。行时当随从阿阇梨后。常供给一切所须。常随顺阿阇梨意。不得违逆。若不白阿阇梨不得有所作。除礼佛法僧用齿木大小便。若近行弟子。知阿阇梨边不能增长善法。应白阿阇梨。持我付嘱某比丘。阿阇梨应筹量。是比丘教化法何似。弟子众复何如。若知是比丘具足善法。当付嘱。若知不具足。当付嘱余比丘。若阿阇梨不好。当舍去。是名近行弟子法。沙弥法者。沙弥不应轻慢和上。有所作事。皆应白和上。行时当随从和上后。常供给一切所须。随顺和上意。不得有违逆。若有所作。不白和上不得作除礼佛法僧用齿木大小便。沙弥住和上边。知不能增长善法。应白和上。持我付嘱某甲比丘。和上应筹量。是比丘教化法何似。弟子众复何如。若知是比丘具足善法。当付嘱。若知不具足。当更付嘱余比丘。若和上不好应舍去。应令取草树叶取果齿木。除僧坊中草。扫洒授饮食汤药。是名沙弥法。出力法者。若白衣于寺中。欲作恶事侵恼诸比丘。诸比丘尔时应苦切语令其折伏。若不折伏。不应直向王言。先语是恶人知识。次语王夫人及王子大臣等。若是人舍恶事便止。莫令得事。是名出力法。随后比丘法者。随后比丘不应在前。亦不应太在后。不得并肩行。莫先语。不应多语。不问不应语。若问当时答。若前行比丘说非法。后比丘应呵止。若说法应随喜。若如法得施应受。是名随后比丘法。常入出家比丘法者。入出家时。常摄诸根不应调戏。净持威仪如法。能起檀越善心。是名常入出家比丘法。至家法者。若比丘散乱心不厌离心至檀越家。常得五罪。一不请自入。二屏处坐。三强坐。四数数食。五无男子与女人过五六语。是名至家法。住家法者。住家比丘。应善知坐处坐法差别。应为诸白衣说甚深法示邪道正道应说知见。常应教布施持戒忍辱行。善与受八戒。是名住家法。住家上座法者。住家上座。应好观自徒众。莫令诸根散乱调戏。常净持威仪起檀越善心。是名住家上座法。语言法者。客比丘初来时。旧比丘不应疾与卧具。先应共语。次问用僧卧具。随是比丘上中下应与卧具。是名共语言法。息法者。客比丘初来时。不应从旧比丘疾索房舍卧具。初入僧坊先应在现处立。净持威仪守摄诸根。然后向旧比丘说房舍卧具。是名息法。漉水囊法者。比丘无漉水囊。不应远行。若有净水若河水流水。又复二十里有住处。不须漉水囊。是名漉水囊法。经行法者。比丘应直经行不迟不疾。若不能直当画地作相随相直行。是名经行法。虚空法者。一切虚空无界。他人向空中人。空中人向地人。不得遮羯磨作羯磨。是名虚空法。便利法者。比丘若欲入厕。先应弹指。若有先入者。应待出。出已脱衣着一处。然后入厕。应蹲坐。若便利未下者不应待。下者不应留。是名便利法。近厕法者。比丘不应近厕读诵经论议说法。不应近厕浣染割截刺衣。一切所作不应近厕。除便利。是名近厕法。厕板法者。比丘应安徐便利。勿令污板。是名厕板法。厕上坐法者。若下座先入厕已举衣。上座后来不应驱遣。若驱遣得突吉罗。是名厕上座法。拭法者。不应用利物拭。不应用草拭。应用滑石软木。是名拭法。洗处法者。若不沈大便处。不应坐卧僧卧具上。若坐卧得突吉罗。若无水。若白衣事水。若着药不得洗。如是不洗无罪。是名洗处法。近洗处法者。若近洗处。不应读诵经论议说法。不应浣染割截刺衣。一切有所作。不应近洗处。但除洗。是名近洗处法。洗处板法者。比丘应安徐洗。勿令湿板。是名洗处板法。洗处上座法者。若下座先在洗处坐。上座后来不应驱遣。若驱遣得突吉罗。是名洗处上座法。小便处法者。不得处处小便。应在常处。是名小便处法。近小便处法者。比丘不应近小便处读诵经论议说法。不应近小便处浣染割截刺衣。一切所作。不应近小便处。但除小便。是名近小便处法。小便处板法者。比丘应一心安徐小便。勿令湿板。是名小便处板法。小便处上座法者。若下座先入。上座来不应驱起若驱起者得突吉罗。是名小便处上座法。唾法者。比丘不应大声唾。不应唾净洁治地。是名唾法。唾器法者。佛听二种唾器。若瓦若铜。应好守护。勿令失。更求觅妨行道故。是名唾器法。钵支法者。佛听用鋀石铜铁铅锡白镴瓦作。应好赏护。莫令失。更求觅妨行道。是名钵支法。齿木法者。佛听齿木三种枝。上中下。上者尺二寸。下者六寸。余者是中。是名齿木枝法。擿齿法者。不应用利物擿齿。不应强擿。不应破龂。是名擿齿法。刮舌法者。不应用利物刮令伤舌。是名刮舌法。擿耳法者。不应用利物擿耳垢。不得强擿。当徐徐擿。勿伤耳肌。是名擿耳法。如是等比丘法。当应受学修行。与上法相违。是名非法(行法竟)

    二种毗尼及杂诵

三事决定知比尼相。一本起。二结戒。三随结。复有二种比尼。诤比尼犯比尼。复有二种比尼。净比尼烦恼比尼。复有二种比尼。比丘比尼比丘尼比尼。复有二种比尼。遍比尼不遍比尼。诤比尼者。相言共斗诤讼相骂相打作二分。诸比丘应观察。是事何因缘起。云何可灭。起斗乱事因缘者。十四破僧事。六斗诤根本。起斗乱因缘。灭相言事者。以二比尼灭。现前比尼。多觅比尼。是名灭比尼。云何犯比尼。五众犯定犯。摄犯比尼。云何五种。所谓波罗夷。僧伽婆尸沙。波夜提。波罗提提舍尼。突吉罗。犯是五众犯。应求本起。应觅除灭。本起者。五众罪所起因缘。有身犯非口非意。有口犯非身非意。有身意犯非口。有口意犯非身。有身口意犯。无但意犯。是名犯起因缘。有犯下罪。心念便除灭。有犯中罪。从他除灭。有犯须出罪羯磨。有犯不可除灭。犯出罪羯磨。有二种。一者覆藏。二者不覆藏。覆藏者。随覆藏日与别住。不覆藏罪。但与六日六夜摩那埵。犯不可治。则不可除灭。烦恼比尼者。应觅起因缘灭因缘。起因缘者。可系法中贪着心见利味诸烦恼发。是名起因缘。灭因缘者。于可系法中。观无常生灭厌离舍灭。善心住诸禅定三昧地中。和合诸行系心缘中。入三脱门。能断见谛所断思惟所断结使。二种结断故证沙门果。随得果故。有圣人差别。是名摄断结。比丘比尼者。是净是不净。比丘尼比尼者。是净是不净。遍不遍一切遍。一切遍时净者。初夜受浆。二时净者。初夜后夜分。应若坐禅若读经。一夜净者。比丘尼应一夜畜长钵。二夜净者。得二夜共未受大戒人宿。三夜净者。第三夜未受大戒人应移处宿。五夜净者。佛听极久五夜不受依止。六夜净者。阿兰若比丘怖畏处。得六夜离衣宿。七夜净者。病听极久七夜畜残药得服。十夜净者。比丘畜长衣钵。极久得至十夜。半月净者。应半月一处和合说戒作布萨。一月净者。得非时衣。极久得一月畜衣。二月净者。比丘听二月无依止。三月净者。比丘应三月安居。四月净者。受露坐比丘在多雨国土。应四月空地住八月在覆处。五月净者。比丘五月受迦絺那衣。八月净者。受露坐比丘。在少雨国土。应八月在露地住四月在覆处。九月净者。比丘有事未了。极久应停至九月。一岁净者。一岁比丘得受迦絺那衣。二岁净者。二岁比丘尼。应常随逐和上。三岁净者。比丘中间相降三岁。得共大绳床上坐小绳床上得共二人坐。独坐床上但一人坐。五岁净者。五岁比丘应依止他。满五岁已得离依止宿。六岁净者。比丘尼六岁应依止他。满六岁已得离依止宿。七岁净者。佛听沙弥极小乃至七岁。九岁净者。九岁比丘应随僧作使。十岁净者。十岁比丘应畜弟子。又极小十岁曾嫁沙弥尼。得受六法。十二岁净者。曾嫁式叉摩尼年十二应受具足戒。十二岁净者。比丘尼应畜弟子。十八岁净者。童女沙弥尼年十八岁。应受六法。二十岁净者。沙弥年二十。应受具足戒。童女式叉摩尼年二十。应受具足戒。二十岁比丘僧。应令教化比丘尼。一净者。应一比丘作阿地檀布萨。二净者。二比丘应共分施物展转分。三净者。三语布萨。四净者。四比丘应说波罗提木叉。五净者。五比丘应差自恣人。八净者。八比丘应受大众会法。十净者。十比丘应受具足戒。二十净者。二十比丘应作出罪羯磨。钵净者。佛听二种钵。瓦钵铁钵。八种钵不应畜。衣净者。七种衣不作净施得畜。僧伽梨。郁多罗僧。安陀会。雨浴衣。覆疮衣。尼师坛。及余百一物。刀子净者。佛听畜月头刀子。为割截衣故。针净者。佛听畜二种针。铜针铁针。三种鼻。糠鼻圆鼻小豆鼻。比丘无针不应行。染净者。五比丘白佛言。世尊。我等用何等物染衣。佛言。用根汁茎汁叶汁花汁果汁新生犊子粪汁染。坏色净者。比丘得新衣。应三种坏色。若青若泥若茜。量净者。不应等佛衣量作衣。应随自身量。如是等诸净。尽应思惟观察。及二部波罗提木叉。并义解比尼增一。无本起因缘比尼共不共。是事净不遮。是事不净遮。如青黄赤白色。是不净遮。非青黄赤白色。是净不遮。如酒色酒香酒味酒力。是不净遮。非酒色非酒香非酒味非酒力。是净不遮。又如诸比丘作净已得用。如五种子生。比丘五种作净得食。八种浆以水作净得饮。十种衣三种坏色净得用。是事净。比丘。比丘尼应用。是事不净。比丘比丘尼不应用。是事某方某时净。比丘比丘尼应用。是事某方某时不净。比丘比丘尼不应用。是事某时某人应用。如饥饿时如老病比丘应用。若丰乐时。若年少无病比丘不应用。如是事应筹量轻重本末已应用(二犯等竟)

    波罗夷法初戒

佛在毗耶离。尔时须提那迦兰陀子比丘作是念。佛结戒断淫欲先作无罪。我多作淫欲。不知我何处是先何处非先。如是心生疑悔。是事白佛。佛言。是须提那迦兰陀子比丘。未结戒前一切淫欲不犯。问佛说狂人不犯。齐何名狂。佛言。有五相名狂人。亲里死尽故狂。财物失尽故狂田业人民失尽故狂。或四大错乱故狂。或先世业报故狂。比丘虽有是五狂相。若自知我是比丘作淫欲。得波罗夷。若不自知不犯。问比尼中说散乱心不犯。云何名散乱心。佛言。有五种因缘。令心散乱。为非人所打故心散乱。或非人令心散乱。或非人食心精气故心散乱。或四大错故心散乱。或先世业报故心散乱。比丘有是五种散乱心。自觉是比丘。犯波罗夷。若不自觉知不犯。问佛言。病坏心人不犯。云何名病坏心人。有五种病坏心。或风发故病坏心。或热发故病坏心。或冷发故病坏心。或三种俱发故病坏心。或时节气发故病坏心。比丘有是五种病坏心。若自觉是比丘。得波罗夷。若不自知不犯。有跋耆子比丘。是比丘不还戒戒羸不出到自家作淫欲已。还生信心故出家。作是念。我当问诸比丘。我还得受具足戒。当出家作比丘。若不得当止。是人问诸比丘。比丘以是事白佛。佛言。若比丘不还戒戒羸不出。自至家作淫欲。是人不得受具足戒。随今日是戒应如是说。若比丘入比丘法。不反戒戒羸不出。作淫欲乃至共畜生。得波罗夷。有一比丘。作道想非道中作淫欲。心生疑。我将无得波罗夷耶。是事白佛。佛言。道中道想作淫欲。得波罗夷。道中非道想。亦得波罗夷。道中疑亦得波罗夷。非道中非道想。得偷兰遮。非道道想得偷兰遮。非道中疑亦得偷兰遮。道者。小便道大便道口道。若令入大便道中。得波罗夷。入小便道中。得波罗夷。入口道中。得波罗夷。比丘于象作淫欲。若触肌得波罗夷。若不触偷兰遮。若不触出精。僧伽婆尸沙。牛马骆驼驴骡猪羊犬猿猴獐鹿鹅雁孔雀鸡等亦如是。若触波罗夷。若不触偷兰遮。若不触出精。僧伽婆尸沙。有一比丘。常淫欲发。语善知识。我淫欲常发忧恼。不能自止。得一女人共作淫欲可休。知识语言。便可作去。即随知识语作淫欲。知识比丘心生疑悔。我将不得波罗夷耶。以是事白佛。佛言。不犯波罗夷。得偷兰遮罪。长老优波离问佛言。世尊。偷兰遮。云何忏悔除灭。佛言。有四种偷兰遮。有偷兰遮罪从波罗夷生重。有偷兰遮罪从波罗夷生轻。有偷兰遮从僧伽婆尸沙生重。有偷兰遮从僧伽婆尸沙生轻。优波离。从波罗夷生重偷兰遮。应一切僧前悔过除灭。从波罗夷生轻偷兰遮。应出界外四比丘众悔过除灭。从僧伽婆尸沙生重偷兰遮。亦出界外四比丘众悔过除灭。从僧伽婆尸沙生轻偷兰遮。一比丘悔过除灭

佛在舍卫国。有乞食比丘。名难提。中前着衣持钵入城乞食。食竟持尼师坛。着左肩上。入安陀林。一树下敷尼师坛大坐。有魔天神来。欲破是比丘三昧。化作端正女人。在比丘前立。比丘从三昧起。开眼见此女人。即时起贪着心。世俗禅定不坚固。发淫心失禅定。欲摩女身。女人即却渐渐远去。是比丘即起随逐。时林中有死马。到死马边女身不现。是比丘淫欲烧身故。共死马作淫。作淫已欲热小止。即时生悔言。我已堕非是比丘非释种子。诸比丘必弃我。不复共我住我不应以是不净身着袈裟。即揲袈裟着囊中置肩上。诣佛所。尔时佛与百千万大众围绕恭敬说法。佛遥见是比丘来。作是念。若我不软语劳问。是人必破心肝热血从面孔出。是比丘到佛所。佛言。善来难提。汝能还学比丘所学耶。是比丘闻佛言善来难提。心大欢喜。作是念。我当得共诸比丘住。必不摈我。如是思惟已答佛言。世尊。我能还学比丘所学。尔时佛告诸比丘。汝等还与难提比丘学法。若有如难提比丘者。亦与学法。应一心和合僧。难提比丘偏袒右肩脱革屣胡[跳-兆+詹]合掌。作是言。大德僧忆念。我难提比丘。不还戒戒不羸作淫欲。我难提从僧乞还学法。僧怜愍难提故。还与我学法。第二第三亦如是乞。众中一比丘应僧中唱说。大德僧听。难提比丘不还戒戒不羸作淫欲。难提从僧乞还与学法。今僧怜愍故。还与学法。若僧时到僧忍听。还与难提比丘学法。白如是。如是用白四羯磨。还与难提比丘学法竟。僧忍默然故。是事如是持。与学沙弥行法者。与学沙弥。佛所结一切戒尽应行。在诸比丘下坐。应授与大比丘饮食汤药。自应从沙弥白衣受饮食。不得与大比丘同室过二宿。自不得与白衣沙弥过二宿。得与大比丘布萨自恣二羯磨。与学沙弥。不得足数作布萨自恣羯磨。憍萨罗国有一比丘。深山林中独住。有非人女来。语比丘言。共作淫欲来。比丘言。莫作是语。我是断淫欲人。女言。汝若不来。我当破汝利与汝衰恼。比丘言。随汝作。我不共汝作淫欲。作是语已中夜比丘卧眠。鬼女合纳衣。持比丘着王宫内夫人边卧眠。王觉见已问言。汝何人耶。比丘言。我是沙门。是何沙门。答曰。我是释子沙门。王言。汝何以来此。比丘以是事具向王说。王言。汝何用在深山林中住。为恶鬼所娆。汝去。我知佛法故。不与汝事是比丘有。大事得脱向。诸比丘具说诸比丘。以是事白佛。佛言从今日如是无人深。山林中可畏处。不应住。憍萨罗国有一比丘。阿兰若处住。有毗舍遮鬼女人来。语比丘言。作淫欲来。比丘言。莫作是语。我是断淫欲人。鬼女言。汝若不作。我当破汝利与汝衰恼。比丘言。随汝作。我终不与汝作淫欲。比丘夜卧。鬼女以纳衣裹。持着酒舍酒盆中。酒家人明日见比丘在酒盆中。问言。汝是何人。答言。我是沙门。是何沙门。答言。释子沙门。问言。汝何故在是中。比丘具说是事。酒舍人言。汝去。比丘以从是大事得脱故。向诸比丘说。诸比丘以是事白佛。佛言。从今日比丘深山林中空处可异无人处。不应住。有比丘。在恶牛群中行。恶牛逐欲触比丘。走倒女人上。女人抱捉比丘。比丘出手推却。是比丘心生疑。我将无得波罗夷耶。以是事白佛。佛言。不犯。从今日应安徐行牛群中。有一比丘。看井堕井中。井中先有女人。比丘堕上。女人抱捉比丘。比丘推却。有居士入僧坊。井上看见是比丘。即时牵出。出时与女人俱出。居士问言。比丘与女人是中作何等。比丘言。是女人先堕我后堕。是比丘生疑。我将无得波罗夷耶。以是事白佛。佛言。无罪。从今日应一心看井。莫令堕。有一乞食比丘。中前着衣持钵入舍卫城乞食。到小门中欲入。有女人欲出。二人肩。相触。是比丘。生疑。我将无得波罗夷耶。以是事白佛。佛言。若无心无罪。从今日应徐徐行乞食。有比丘。女人共乘船渡水。船没水中女人抱捉比丘。比丘推却。比丘后生疑。我将无得波罗夷耶。以是事白佛。佛言。不犯。从今日当徐徐乘船

有一男子。名迦毗罗紧度。状似女人。喜女人事到比丘尼所。语比丘尼言。度我出家。诸比丘尼不思惟便度。是人摩扪比丘尼。比丘尼驱出。复摩扪式叉摩尼。式叉摩尼驱出。复摩扪沙弥尼。沙弥尼驱出。比丘尼自念。我将无得波罗夷耶。以是事白佛。佛言。无罪。从今日当好思惟然后应度。有一估客远行。其妇与他人作淫欲。有娠转大。怖畏故自堕胎。堕胎已看是死儿大愁忧。无有同意人可使弃此死儿者。是家中有一比丘尼。常入出其家。是比丘尼中前着衣持钵来入其舍。比丘尼问言。汝何故愁忧。答言。我夫远行。我于后与他作淫欲有娠。闻夫欲来我怖畏故自堕胎。我今无同意人与我弃此死儿者。是故愁忧。语比丘尼言。善女。汝能为。我弃此死儿不。答言。我能持去。谁能知者。即盛着盆中以物覆头。远弃着无人行处。是中有诸博掩人。见是比丘尼持盆来。各相谓言。往看。比丘尼弃何物。即共往看见死儿。见已自相语言。释子比丘无断淫欲。共比丘尼行淫欲。有娠生儿弃之。一人语二人。二人语三人。如是展转恶名流布。遍舍卫城。有比丘。少欲知足行头陀。闻是事心大愁忧。以是事白佛。佛以是因缘故和合僧。佛知故问是比丘尼。汝实尔不。答言。实尔世尊。佛种种因缘呵是比丘尼言。云何名比丘尼。弃他死胎。从今日诸比丘尼。不应弃死胎。若弃得罪。俱萨罗王波斯匿。闻跋陀迦毗罗出家。即请来入宫中。夏四月共止一处。后时王欲到园中。语守门人言。汝好守门。莫令是比丘尼出。守门人言。尔。王出后时守门人作是念。是比丘尼乐住不走。时守门人有余因缘。比丘尼着夫人被服从门出迳到祇洹。尔时佛与百千众恭敬围绕说法。佛遥见来近已。佛言。善来跋陀迦毗罗。当佛作是语时。即失夫人被服。头发自落。袈裟着身。作比丘尼。作比丘尼已到佛所。头面礼佛于一面立。佛为说四如意足神通道。即时比丘尼得神通力。是时王闻跋陀迦毗罗女走去。便将兵众围绕比丘尼坊。是比丘尼便飞虚空中。王仰看见已生悔心。我云何污是阿罗汉比丘尼。心闷躄地。时诸群臣以冷水洒。还得醒悟。向比丘尼悔过。诸比丘尼驱出。汝是行淫欲人。出去。是比丘尼言。我无受欲心。诸比丘尼言。汝夏四月共王在宫殿中。云何不受。是比丘尼不知云何。以是事白佛。佛知而故问是比丘尼。汝实受细滑不。答言。世尊。我云何当受。我觉是细滑。如热铁入身。佛言。汝若无受细滑心无罪。尔时佛语诸比丘尼。汝等勿复说是跋陀迦毗罗事。女人业报因缘故得是女根。他人强行淫。若比丘尼他人强捉行淫。无受欲心无罪。有比丘尼。名善生。端正可爱能动人心。迦毗罗紧度。先不语直来摩触是比丘尼。比丘尼驱出。驱出已心生疑悔。我将无得波罗夷耶。以是事白佛。佛言。无受欲心无罪。有比丘尼。名陀尼。端正可爱能动人心。中前着衣持钵欲入舍卫国乞食。道中有诸博掩人。将入深林中。强共行淫。诸比丘尼驱令出坊。作是言。汝是行淫人不应住此。是比丘尼言。我无心受细滑。诸比丘尼言。诸博掩人将汝到深林中行淫。云何不受。是比丘尼不知云何。以是事白佛。佛知故问。汝实受细滑不。答言。世尊我云何受。我以手推脚蹋转身。不能得脱。佛言。若无心不受无罪

佛语诸比丘尼言。汝等勿复说是比丘尼事。是比丘尼手推脚蹋转身不受。为他强捉无罪。有比丘尼。名守园。中前着衣持钵行乞食。有诸博掩人。牵入深林中。强为淫欲。诸比丘尼驱令出坊。是比丘尼言。诸善女。我无心受细滑。诸比丘尼言。诸博掩人牵汝入深林中作淫欲。云何不受。是时阿难在比丘尼坊中。诸比丘尼语言。阿难在此。阿难问。是比丘尼。敬畏阿难故不能答。阿难嫌其不答。是比丘尼心念。诸比丘尼驱我出坊。长老阿难复嫌我。我用活为。今当至阿耆罗婆河自投而死。是比丘尼盛满瓶沙。自系其颈沈于水中。沙瓶绳断身或浮没。尔时诸博掩人游戏岸边。见已相语。汝看是比丘尼。为水所漂浮。往取来。即共出之。扶着岸边。水出得稣。将入深林共作淫欲。还来入坊。诸比丘尼复驱出言。汝先言无心受细滑。今博掩人将汝入深林中作淫已放来。是比丘尼不知云何。以是事白佛。佛知故问比丘尼言。汝有心受细滑不。答言。世尊。我云何受。我啼哭大唤。语言莫作。不能得脱。佛言。汝若无心受细滑无罪。佛语诸比丘尼言。汝等勿复说是比丘尼事。女人以先世业因缘故。得是女根。不得自在。虽啼哭亦强捉。虽言莫作亦强作。虽大唤亦强作。若比丘尼。为他强捉。无受欲心无罪(初波罗夷竟)

    第二盗戒之初

佛在王舍城。因达尼迦陶师子比丘。结不盗戒言。先作不犯。是比丘心生疑悔言。我多盗取材木。不知何者是先何者非先。是事白佛。佛言。达尼迦比丘未结戒前一切时取材木不犯。是名先作不犯。有比丘。空处取无所属物持去。心生疑。我将无得波罗夷耶。以是事白佛。佛言。若知是物属他。得波罗夷。若是物属他。生无属想取。得波罗夷。属他物中疑。亦得波罗夷。是物无属。生有属想取。得偷兰遮。无所属物生疑。亦得偷兰遮。若无属物。生无属想。无罪。比丘他不与饭食。自取持去。心生疑。我将无得波罗夷耶。以是事白佛。佛言。当计是饭食直。饭糗糒鱼肉饼亦应计直。有一比丘。不请自来食。心生疑。我不得波罗夷耶。以是事白佛。佛言。不犯。从今日不请不应往食。若往食得突吉罗。有旧住比丘至聚落。有知识比丘。与取食分。是比丘从聚落还。知识比丘言。我与汝取食分。是比丘言。汝何故取。答言。为汝故取。是比丘言。我不语汝。汝何故取。知识比丘生疑。我将不得波罗夷耶。以是事白佛。佛言。不犯。从今日比丘若他不语。不应取食分。若不语而取。得突吉罗。有一比丘。至聚落。众僧分饭。是比丘有二共行弟子。是弟子不相知故。俱取食分。后二弟子自相语言。汝所取分。我所取分。谁具足取。得波罗夷耶。心生疑。以是事白佛。佛言。不犯。从今日应自相语令一人取。取时当言。我与某甲比丘取食分。有一比丘病。众僧分饭。看病人为取饭。是比丘死。诸比丘不知云何。以是事白佛。佛言。若病人先死后取饭。还归本处。若先取饭后死。应同死比丘余物分

十诵律卷第五十七十诵律卷第五十八(第十诵之三)

        后秦北印度三藏弗若多罗译

    比尼诵盗戒之余

诸比丘自相语言。共作贼去来。答言。随意。是比丘发去。中道心悔生惭愧。我等云何于善佛法中以信出家。而作贼耶。作是念已便不复去。心疑。我等将无得波罗夷耶。是事白佛。佛言。不得波罗夷。得偷兰遮。诸比丘自相语言。共作贼去来。答言。随意。发去时。中道一人心悔生惭愧。我云何于善佛法中以信出家。而作贼耶。复作是念。若我不去。余人或当杀我。当共去。我不用物。不取分。作是思惟已逐去。逐去已是中不夺他物。亦不取分。是比丘生疑。我将无得波罗夷耶。是事白佛。佛言。不犯波罗夷。得偷兰遮。又复诸比丘自相语言。共作贼去来。答言。随汝等意发去。去到处都无所得。是诸比丘生疑。我将无得波罗夷耶。是事白佛。佛言。不得波罗夷。得偷兰遮。诸比丘自相语言。共作贼去来。答言。随汝意发去。是中半比丘逻道。半比丘取物。逻道者言。我等不取他物。无罪也。后生疑。我等作如是事。将无得波罗夷耶。是事白佛。佛言。不得波罗夷。得偷兰遮。诸比丘自相语言。共作贼去来。答言。随意。发去已半得物。半不得物。不得物者言。我不得他物不取分。无罪也。又复生疑。我等将无得波罗夷。是事白佛。佛言。不得波罗夷。得偷兰遮。又复诸比丘自相语言。共作贼去来。答言。随意。相语言。当少少取。莫令具足。取已合众人物欲分。物满五钱。诸比丘生疑。我等将无得波罗夷耶。以是事白佛。佛言。随人取物离本处计直。守逻人与比丘衣。比丘不取。作是念。是中谁是檀越谁是主。是事白佛。佛言。但随施者受。有贼捉弟子将去。和上还夺取。和上疑。我将无得波罗夷耶。以是事白佛。佛言。若决定属贼。得波罗夷。若未决定无罪。阿阇梨近行弟子亦如是。有贼捉一比丘将去。还自盗身走来生疑。我将无得波罗夷耶。以是事白佛。佛言。自偷盗身无罪。比丘持可税物行到关门。作是念。我若持是物过。得波罗夷。又作是念。是税直我宁持与。若佛法僧。若和上阿阇梨。若父母。如是思惟已。为守关人共软语言。我持是物供养若佛法僧若和上阿阇梨若父母。因是物与他。若作信。若作自供所须。如是等口软语力得过。无咎。飞过无罪。比丘从余比丘。借独坐床已作是念。我后不复还。主求索言。长老。还我床。作是言。不与汝。寻生疑悔心。我将无得波罗夷耶。是事白佛。佛言。不得波罗夷。得偷兰遮。比丘从他借经卷已作是念。我不复还。主来索言。长老。还我经来。作是言。不与汝。寻生疑悔心。我将无得波罗夷耶。是事白佛。佛言。不得波罗夷。得偷兰遮。有比丘偷弊衣囊。囊中有大价衣。见已生念。我将无得波罗夷耶。是事白佛。佛言。计衣囊价直五钱。得波罗夷。若不直得偷兰遮。诸贼持酒至阿兰若处。饮半藏半。诸比丘游行林中见酒语弟子。持到住处用作苦酒。弟子随教持归。贼还求酒不得。贼到诸比丘所问言。长老。彼处酒汝持来不。比丘言。持来。贼嗔言。汝是贼贼。比丘言。何故贼贼。贼言。我是贼。汝复偷我。故言贼贼。是比丘生疑。我将无得波罗夷耶。是事白佛。佛知故问。汝以何心取。比丘言。世尊。我谓是酒无主故取。佛言无罪。从今日若见物。应好思量已取。诸贼持肉至山林中。食半藏半。诸比丘游行林中见肉。语诸弟子。持到舍以供明日。弟子随教持归。贼还求肉不得。到比丘所问言。长老。彼处肉汝持来不。比丘言。我持来。贼嗔言。汝是贼贼。比丘言。何以故贼贼。贼言。我是贼汝复偷我。故言贼贼。是比丘生疑。我将无得波罗夷耶。是事白佛。佛知故问。汝以何心取。比丘言。世尊。我谓是肉无主故取。佛言无罪。从今日若见物。应好思量已取。诸贼破城邑聚落。若持钱物上至阿兰若处。后官力来围绕是处。是贼怖畏急故。持物施诸比丘。施已便出去。诸白衣。来见物在比丘所。语言。长老。此是我物。今在汝手。比丘言。贼布施我。诸白衣言。谁信汝语。汝或自作贼。或从贼得。诸比丘不知云何。是事白佛。佛言。莫从贼取物。若贼主与当取。取已便染坏色着。若坏色已。主故索者当还。有居士脱衣着道边便利。有纳衣比丘。见四向顾视不见人。便取持去。居士言。比丘莫持我衣去。比丘不闻故去不止。居士走逐夺取。语言。比丘法。应不与强取耶。比丘答言。我谓是衣无所属。居士言。是我衣非无所属。比丘言。若是汝衣持去。是比丘生疑。我将无得波罗夷耶。是事白佛。佛知故问。汝以何心取。比丘言。我谓无所属故取。佛言无罪。从今日见物应好思量已取。物实有所属。似无所属。诸人有亲里死。弃着死人处。是国土人法。好净洁脱衣。着死人处外。然后入烧尸。纳衣比丘见是衣。四顾不见人。便持去。白衣见已语比丘言。莫持我衣去。比丘不闻其言故去不止。白衣走逐捉夺衣取。语言。比丘法。应不与取耶。比丘答言。我谓是衣无所属。白衣言。是我衣非无所属。比丘言。若是持去。是比丘生疑。我将无得波罗夷耶。是事白佛。佛知故问。汝以何心取。比丘言。我谓无所属故取。佛言。无罪。从今日若见物。应好思量已取。有物实有所属。似无所属。浣衣人持诸衣。浸着水中忘去。到余聚落。还忆念言。我不失是衣耶。尔时纳衣比丘。求弊纳衣故到是处。见是衣四顾不见人。便持去。浣衣人来见比丘持去。语言。莫持我衣去。比丘不闻故去不止。浣衣人走逐捉夺取语言。比丘之法。应不与取耶。比丘答言。我谓是衣无所属。浣衣人言。是我衣非无所属。比丘言。若是持去。是比丘生疑。我将无得波罗夷耶。是事白佛。佛知故问。汝以何心取。比丘言。我谓是无所属故取。佛言。无罪。从今日若见物。应好思量已取。有物实有所属。似无所属。复有浣衣人。持衣至水边。浣浣已绞捩。晒已一处坐看。有纳衣比丘。求弊纳衣。是处见衣。四顾不见人。便持去。浣衣人来见比丘持衣去。语比丘言。莫持我衣去。比丘不闻故去不止。浣衣人走逐捉夺取语言。比丘法。应不与取耶。比丘答言。我谓是衣无所属。浣衣人言。是我衣非无所属。比丘言。若是汝衣持去。是比丘生疑。我将无得波罗夷耶。是事白佛。佛知故问。汝以何心取。比丘言。我谓无所属故取。佛言。无罪。从今日若见物。应好思量已取。有物实有所属。似无所属。有一小儿。持舍勒终日在道中戏。忘舍勒归去。纳衣比丘求弊纳衣。到是处见已。四顾不见人。便持去。小儿舍有女出见。语比丘言。莫持我舍勒去。比丘言。我道中得。女人言。我小儿持舍勒终日道中戏。忘持归。汝莫持去。比丘言。若是汝许便持去。比丘生疑。我将无得波罗夷耶。是事白佛。佛知故问。汝以何心取。比丘言。我谓是无所属故取。佛言。无罪。从今日若见衣。好思量已取。诸纳衣比丘。着不净污纳衣。诸天神金刚神不喜。亦失威德。是事白佛。佛言。不净污纳衣不应着。着得突吉罗。有一居士。闻诸释子比丘能着纳衣。持大价[疊*毛]裹八枚钱。着粪壤中令缕现。远处立看。有一纳衣比丘。求弊纳故到是处。见缕已便取。取已见是大价[疊*毛]。便持去。居士唤言。长老。是我[疊*毛]。汝莫担去。比丘言。我自粪壤中得。何预汝事。居士言。我闻释子比丘能着弊纳衣。我欲试故。持大价[疊*毛]裹八枚钱。是[疊*毛]中有八枚钱。若不信我可数看。数看已实有八枚钱。比丘言。若是汝许便持去。比丘生疑我将无得波罗夷耶。是事白佛。佛知故问。汝以何心取。比丘言。我谓无所属故取。佛言。无罪。从今日若见物。应好思量已取。有一纳衣比丘。藏纳衣着一处。入舍卫城乞食。更有纳衣比丘。求弊纳故到是衣边。见已四顾不见人。便持去。以水浣之只桓门边晒。衣主比丘乞食还。久求不得。欲入只桓见在门边。语取衣比丘言。长老。汝得波罗夷耶。取衣比丘言。何以故。衣主言。我纳衣汝辄持来。取衣比丘生疑。我将无得波罗夷耶。是事白佛。佛知故问。汝以何心取。比丘言。我谓无所属故取。佛言。无罪。从今日若见物。应好思量已取。藏物异无所属物亦异。憍萨罗国近死人处。有诸天祠舍。守祠舍人浣衣绞捩。晒已不收捡。风吹堕死人处。有一比丘。死人处住。观死尸见是衣。四顾不见人。便持去。守祠人见语言。长老。莫夺我衣去。比丘言。我死人处得。何预汝事。守祠人言。是我衣。我浣绞捩晒。有小因缘不时收捡。风吹堕死人处。比丘言。若是汝衣便持去。比丘生疑。我将无得波罗夷耶。是事白佛。佛知故问。汝以何心取。比丘言。我谓无所属故取。佛言。无罪。从今日若见物应好思量已取。诸比丘取属死人处中衣。诸旃陀罗言。长老。莫取。我是中输税物。诸比丘不知云何。是事白佛。佛言。从今日有属死人处衣。比丘不应取。若取得罪。尔时于属死人处外边。捡取小叚弊纳。诸旃陀罗亦不听取。是事白佛。佛言。是中若遮莫取。若取得突吉罗。有一居士。请佛及僧明日食。佛默然受。居士知佛受已。头面礼佛足右绕已去。到自舍是夜办多美饮食。办食已晨朝敷座处。时到遣使诣佛所。白佛言。世尊。食具已办唯圣知时。佛及众僧入居士舍。长老耶舍守僧坊请食分。给孤独居士二小儿。到只桓僧坊中庭游戏。诸贼欲侵恼劫夺。耶舍比丘见已作是念。此儿可愍。无所知故。当为是贼伤害劫夺。即入禅定。以神通力起四种兵。诸贼见已心大怖畏。谓是官力若聚落力所见围绕。我或当了。如是思惟。便疾远去。诸比丘来语耶舍言。汝得波罗夷。耶舍言。何以故。诸比丘言。贼欲侵恼夺是儿物。汝便为夺取故。耶舍生疑。是事白佛。佛知故问。汝云何夺取。耶舍言。我现神通力。佛言。现神通力取无罪。有一居士。请佛及众僧明日食。佛默然受。居士知佛默然受已。头面礼佛足右绕已去。到自舍是夜办具多美饮食。办已晨朝敷坐处。时到遣使诣佛所。白佛言。世尊。食具已办唯圣知。时佛及众僧入居士舍。一比丘守僧坊请食分。新诵咒术。给孤独居士二小儿。到只桓游戏。诸贼欲侵恼劫夺。比丘见已念言。是儿可愍。无所知故。为贼所伤害劫夺。我新诵咒术。可试诵救是小儿。有验以不。即诵咒术时。有四种兵出。诸贼见已心大怖畏。念言。是或官力若聚落力围绕我。我或当了。如是思惟已。便疾走去。诸比丘来语守僧坊比丘言。长老。汝得波罗夷。守僧坊比丘言。何以故。诸比丘言。人欲侵恼夺是儿物。汝便夺取故。是比丘生疑。我将无得波罗夷耶。是事白佛。佛知故问。汝以何心取。比丘言。我试诵新咒术。救是小儿故。出四种兵取。佛言。若诵新咒术取无罪。旧比丘到余聚落。众僧分衣。是比丘有善知识。为是比丘取衣分。是比丘从聚落还。善知识比丘语比丘言。长老。为汝取衣分。是比丘言。何以故取。善知识比丘生疑。我将无得波罗夷耶。是事白佛。佛言。无罪。从今日若比丘不语。不应为他取衣分。若取得突吉罗。旧比丘到余聚落。众僧分衣。是比丘有二共行弟子。是二弟子不相知故。各为和上取衣分。后二弟子自相语言。汝亦取衣分。我亦取衣分。谁具足得波罗夷耶。心生疑。以是事白佛。佛言。不犯。从今日应自相语令一人取。取时当言。我与某甲比丘取衣分。有一比丘病。众僧分衣。看病比丘为取衣分。是病比丘死。诸比丘不知云何。是事白佛。佛言。若先死后取衣分者。应还归本处。若先取衣分后死者。应同死比丘余物分。有一居士。数数用众僧田。不与众僧税直。是居士后时欲种。旧比丘来语居士言。汝数数用众僧田。而不与直。汝今莫种。若欲种者当与僧价。居士闻是语故强种。时旧比丘卧地遮犁。居士惭愧即休不种。是比丘生疑。我将无得波罗夷耶。是事白佛。佛言。无罪。从今日莫身作可羞事。有一比丘。盗佛图物。生疑。我将无得波罗夷耶。是事白佛。佛言。若有守护者应计直。若具足得波罗夷。旧比丘令人种众僧田。是众僧田近一居士田。比丘亦令人种居士田。居士语比丘言。莫种我田。比丘言。我自种众僧田。何预汝事。居士言。是田我有非人作证。是国土诸田中。以橛若死人脚骨头骨。着土中为识。居士示其相。比丘见已惭愧舍犁牛去。是比丘后还复遣人过相种。居士后见语比丘言。我先与汝共诤时。出地相已不知耶。今日云何复种。是比丘即舍犁牛去。心生疑。我将无得波罗夷耶。是事白佛。佛言。应计价直。若具足得波罗夷。不具足得偷兰遮。有一比丘。不与取花树。生疑。我将无得波罗夷耶。是事白佛。佛言。应计是花树价直。若具足得波罗夷。果树亦如是。有一比丘。破雕巢。时雕常来围绕精舍空中悲鸣。佛问阿难。是雕何故大悲鸣耶。阿难言。有一比丘破其巢。是故悲鸣。佛言。从今日不应破雕巢。若破得突吉罗。复有比丘。取雕巢煮染。时雕常来围绕精舍空中悲鸣。佛问阿难。是雕何故悲鸣。阿难言。有一比丘。取巢煮染。是故悲鸣。佛言。从今日不应取雕巢煮染。若取得突吉罗。有居士。萝卜园盛好。一比丘诣居士所语言。与我萝卜。居士问言。汝有价耶。为当直索。比丘答言。我无价。居士言。若人须萝卜者当持价来。若我直与云何得活。比丘言。汝心定不与我耶。居士言。我定不与汝。时比丘以咒术力咒令干枯。是比丘如是作已。心生疑。我将无得波罗夷耶。是事白佛。佛言。应计是萝卜直。若具足得波罗夷。若不具足得偷兰遮。茎园花园叶园果园。亦应如是计价直。有马行食。比丘以一束草示马。马随比丘去。比丘指示余草。心念使食他草。是比丘生疑我将无得波罗夷耶。是事白佛。佛言。不得波罗夷。得偷兰遮。诸比丘游行憍萨罗国向舍卫城。共估客俱来。是中有崄道。诸估客乘好马语诸比丘。汝亦乘如是好马令疾过崄道。是中有比丘。乘是好马。生心作是方便。是马可得身亦小动。寻生疑。我将无得波罗夷耶。是事白佛。佛言。不得波罗夷。得偷兰遮。有估客乘满船宝。比丘寄载渡河。生心作如是方便。是宝可得身亦小动寻生疑。我将无得波罗夷耶。是事白佛。佛言。不得波罗夷。得偷兰遮。有一估客。载满船宝渡水。船没水中宝物沉下。衣箱随流而去。船主怖惧不得往取。有比丘下流洗。见已取持去。估客见已语比丘言。莫夺我衣箱。比丘言。我自水中得。何预汝事。估客言。我船没水中沈失宝物。衣箱随流下。我怖惧故。不得时取。比丘言。若是便持去。是比丘生疑。我将无得波罗夷耶。是事白佛。佛言。无罪。有一比丘。持四方众僧物。移着余坊。心生疑。我将无得波罗夷耶。是事白佛。佛言。不得波罗夷。得突吉罗。诸贼牵牛上至阿兰若处系着树而去。诸比丘食后经行林中。见绕树挽靷。比丘怜愍解放。寻生疑。我将无得波罗夷耶。是事白佛。佛言。不得波罗夷。得突吉罗

舍卫国有一天神像。能与人愿。有一居士。从求所愿。得随意愿。欢喜故。以白[疊*毛]裹天像身。是中有比丘。名黑阿难。有大力不畏神像。夺神[疊*毛]持去。后生疑。我将无得波罗夷耶。是事白佛。佛言。不得波罗夷。得偷兰遮。有天神像。能护人身。有一居士。从求所愿。得随意愿。是居士欢喜故。以金鬘系头上。黑阿难大勇健。欲往夺金鬘欲到神便怖之。是比丘心惊毛竖。犹故不畏。降伏此神夺金鬘持去。后生疑。我将无得波罗夷耶。是事白佛。佛言。不得波罗夷。得偷兰遮。舍卫国有居士妇。到阿耆罗婆河边浴。是诸居士妇。脱庄严具衣服。着岸上入水洗浴。岸边树上有猕猴来下。持珠璎珞还上树去。是居士妇自恣洗浴竟上岸着衣。求珠璎珞久不得。便舍去。猕猴见去已。还持璎珞着本处已还上树。比丘食后游行。树林中见是璎珞。识其主。便持还居士妇。居士妇言。比丘汝是贼。偷我璎珞。心悔已方还我。比丘言。我不尔。居士妇言。汝云何得。是比丘以是事具说。比丘心生疑。我将无得波罗夷耶。是事白佛。佛言。无罪。经行道头窟上。康郎鸟在上作巢。常持骨及弊纳衣来弃着地。经行比丘便坏是巢。是鸟常来围绕精舍空中悲鸣。佛知故问阿难。是鸟何故悲鸣。阿难言。有一比丘坏巢。是故悲鸣。佛言。从今日不应坏是康郎鸟巢。若坏得突吉罗

诸比丘一处有库藏。以饮食钱物着中。鼠从穴中出。偷钱物弊衣饮食持入穴。诸比丘疑。谁偷是物去。时有一比丘。乞食置库边。待时至当食。鼠从库中出。持食入穴。比丘见知是鼠偷物。是比丘坏是穴。亦得鼠物。亦得自物尽自取。诸比丘言。汝得波罗夷罪。是比丘言。何以故。诸比丘言。汝取鼠物故。是比丘生疑。我将无得波罗夷耶。是事白佛。佛言。不得波罗夷。从今日当取自物。鼠物不应取。一比丘在房中卧。夜鼠持食来着床下。比丘早起澡手。从净人受已便食。诸比丘不大见是比丘乞食。手足常净洁。便问言。长老。不见汝乞食。手足常净耶。是比丘言。诸长老。有鼠夜持食来。着我床下。我早起澡手已。从净人受已食。是故我常不乞食。手足净洁。诸比丘言。长老。汝得波罗夷。是比丘言。何以故。诸比丘言。鼠不与汝自取食故。是比丘生疑。我将无得波罗夷耶。是事白佛。佛语诸比丘。汝莫说是比丘事。何以故。是鼠次前世。是此比丘父。爱念子故。见便心爱故。常持食着床下。是比丘无罪。有诸猎师。逐鹿走入僧坊。是猎师来求鹿。诸比丘不与。猎师久不得。便还去。诸比丘生疑。我将无得波罗夷耶。是事白佛。佛言。无罪。复有一猎师。以无毒箭射一鹿。逐走入僧坊。猎师来求。比丘不与。久不得便还去。比丘生疑。我将无得波罗夷耶。是事白佛。佛言。无罪。有一猎师。以毒箭射鹿。鹿走入僧坊。猎师来求。比丘不与。猎师言。是鹿被毒箭必当死。比丘言。死便死不得与。猎师久不得便去。去未久鹿便死。诸比丘不知云何。是事白佛。佛言。应还归猎师。有诸猎师作鹿弶。比丘以快心坏。得偷兰遮。以怜愍心坏。得突吉罗。有捕鸟师张[(ㄇ@人)/沓]。比丘以快心坏。得偷兰遮。怜愍心坏。突吉罗。诸捕鸟师张罗。比丘快心坏。得偷兰遮。怜愍心坏。得突吉罗。有捕鸟师张细网。比丘以快心坏。得偷兰遮。怜愍心坏。得突吉罗。捕鸟师有笼鸟车。比丘快心坏偷兰遮。怜愍心坏突吉罗。卖衣人买衣比丘。见是衣便持去。卖衣人言。莫持我衣去。比丘言。我持衣示彼已还归汝。后生心欲不复还。寻生疑。我将无得波罗夷耶。是事白佛。佛言。不得波罗夷。得偷兰遮。有比丘。使木师作。不与木师价。木师索直。比丘生心不与。寻生疑悔。我将无得波罗夷耶。是事白佛。佛言。不得波罗夷。得偷兰遮。有一比丘。取陶师瓦器不与直。陶师从索与我价。比丘生心不与。寻生疑悔。我将无得波罗夷耶。是事白佛。佛言。不得波罗夷。得偷兰遮。比丘从店肆买物不与价。店肆卖物人从索价。比丘心生不与。寻生疑悔。我将无得波罗夷耶。是事白佛。佛言。不得波罗夷。得偷兰遮。有病比丘。与诸看病比丘价言。汝持是价作三新粥。我啜是粥亦与众僧。是看病诸比丘作是言。我何为以是价作粥与众僧。我等但作少粥与病人。是钱我等当自分取。共作是筹量已。作粥与病人。钱便共分取。是诸看病比丘。即时生疑。我将无得波罗夷耶。是事白佛。佛言。不得波罗夷。得突吉罗。有一比丘病思饼。与诸看病比丘价言。汝持是价作饼。我自食亦与众僧。诸看病比丘作是言。我何为以是价作饼与众僧。我但作饼与病比丘。是钱我等当自分取。共作是筹量已。作饼与病人。钱便共分取。是诸看病比丘即时生疑。我将无得波罗夷耶。是事白佛。佛言。不得波罗夷。得突吉罗。有一比丘病。多有钱作是念。我死后众僧必当分我钱。我今当令僧不得分。念已语看病人言。作摩沙豆羹与我来。看病人作羹与。以小因缘故。看病人出。病人以钱着羹中合啜。是食难消故便死。看病人持弃死人处。诸鸟来破腹出肠钱堕地。时众僧即打揵椎。呼看病人来言。是死比丘多有钱。汝持来众僧当分。诸看病比丘求钱不得。有一冢间比丘。到死人处观无常。见是钱持来与众僧。即生疑悔。我将无得波罗夷耶。是事白佛。佛言。无罪。有病比丘多有田地。语诸看病人言。唤诸比丘来。我处分此地。与佛与众僧若与人。诸看病人生念。病比丘若以是地。与佛与众僧与人。我等无所得。便不为唤诸比丘。病比丘死。诸看病比丘不知云何。是事白佛。佛言。莫以小因缘违逆病人语。当随病人处分皆为作。有病比丘。多衣钵多生活物。病比丘语诸看病比丘言。唤诸比丘来。我当处分是物与佛与众僧与人。诸看病人生念。是病比丘。若以是物与佛与众僧与人。我等无所得。便不为唤诸比丘。病比丘死。诸看病比丘不知云何。是事白佛。佛言。莫以小因缘违逆病比丘语。当随所处分皆为作。有东方比丘尼。与波梨比丘尼共道行。波梨比丘尼在前。东方比丘尼在后。波梨比丘尼失衣。东方比丘尼得。共合一处时。东方比丘尼唱言。谁失此衣我地得。波梨比丘尼言。汝取是衣耶。答言。我取衣。主言。汝得波罗夷。问言。何以故。答言。汝以盗心取。是比丘尼心生疑。我将无得波罗夷耶。是事白佛。佛言。无罪。有施越比丘尼。喜得供养。大得酥油蜜石蜜。有一估客。见是比丘尼。心喜作是言。善女。汝若须酥油蜜石蜜。随意我舍取。比丘尼言尔。作是请时。有余比丘尼闻。过数日便往到估客舍。诈言。施越比丘尼须五升油。估客言。用作何物。答言。我持至比丘尼寺中。估客便与。是比丘尼持至寺中。便服过数日。估客见施越比丘尼语言。善女。汝何以但索油。不索饭肉羹等。比丘尼言。汝何所道。估客言。先有一比丘尼来云。汝索五升油。我便与。施越言好。若更索余物亦应与。施越到彼比丘尼边言。汝是弊比丘尼。恶比丘尼。贼比丘尼。汝得波罗夷。是比丘尼言。何以故。施越言。估客不施汝。汝诳他取油故。答言。我非不与取。我以汝名字故取。是比丘尼生疑。我将无得波罗夷耶。是事白佛。佛知故问。汝以何心取。答言。我以施越名字故取。佛言。不得波罗夷。故妄语故。得波夜提。从今日不得诈称他名字取。若取得罪

舍卫城有估客。庄严船入大海。入已龙来捉船。诸估客各自求所事神天。礼拜求愿犹不蒙恩。不蒙得脱。中有一估客。是目连弟子。目连常出入其舍。此人即作此念。若目连见念者。必得免济。如是思惟已。一心礼拜目连。时长老目连以天眼见。即入禅定。以神通变作金翅鸟王。在船头立。诸龙见是金翅鸟王。甚大怖畏。舍船沉没大海。诸估客皆得安隐往还到舍卫城赞叹目连。实成就大神通力。我等从海得脱。皆是目连恩力故。诸比丘到目连所语言。汝得波罗夷。目连言。何以故。诸比丘言。是船属龙。汝便夺之。目连生疑。是事白佛。佛知故问。汝云何救。目连言。我以神通力。佛言。若以神通力救无罪

舍卫国估客。出行城邑聚落治生。于崄道中为贼围绕。不得进退。诸估客各自求所事神天。礼拜求愿了不蒙恩。不能得脱。中有一估客。目连是师。常出入其舍。此人即作是念。若目连见念者必得免济。如是思惟已。一心礼拜目连。时长老目连以天眼见。即入禅定。以神通力现四种兵。诸贼见已即作是念。此或是王力若是聚落力来围绕。必不得出。如是怖畏舍远去。诸估客从崄道中得安隐往还。到舍卫国赞叹目连。实成就大神通力。我等从崄道得脱。皆是目连恩力故。诸比丘到目连所语言。汝得波罗夷。目连言。何以故。诸比丘言。是估客属贼。汝便夺故。目连生疑。是事白佛。佛知故问。汝云何救。目连言。我以神通力。佛言。若神通力救无罪

长老毕陵伽婆蹉常出入一檀越舍。有一小儿。比丘到其舍时。一小儿接足作礼。接足而起。是小儿在水岸边立戏。有船贼来渐渐诱进上船。长老毕陵伽婆蹉以天眼见。即入禅定。以神通力在船头立。小儿见以如常法接足作礼。各以两手捉一足。是长老即时飞去。小儿随去到舍。诸比丘到毕陵伽婆蹉所言。汝得波罗夷。毕陵伽婆蹉言。何以故。诸比丘言。是小儿属贼。汝便夺故。毕陵伽婆蹉生疑。是事白佛。佛知故问。汝云何救。答言。我以神通力。佛言。若以神通力救无罪

洴沙王与竹园中众僧五百守园人。此五百人去竹园不远。作大聚落止住其中。贼常来劫夺。长老毕陵伽婆蹉见以作是念。宁可使此人为贼所娆害耶。即入禅定。以神通力作高垣墙。贼夜来作高梯。未办地以了。贼便怖畏舍去。诸比丘到毕陵伽婆蹉所言。汝得波罗夷。毕陵伽婆蹉言。何以故。诸比丘言。贼来坏聚落。汝便夺故。毕陵伽婆蹉生疑。是事白佛。佛知故问。汝云何救。毕陵伽婆蹉言。我以神通力。佛言。若神通力救无罪

跋难陀释子。夏末月处处游行历观诸寺。欲知诸寺安居僧数并物多少。时到一处。诸比丘遥见从坐起。即与坐处问讯就坐小默然已。问诸比丘。此住处众僧。得安居施物不。诸比丘言得。问分未。答言。未。跋难陀言。持来与汝分。诸比丘持此物来令分。跋难陀与作分。上座得分已欲持起去。跋难陀言。上座小住勿便去。上座言。住作何等。跋难陀言。汝等已得财施。当与汝法施。是跋难陀辩才利根。能严饰语为说种种妙法。上座心欢喜故。尽以物分与跋难陀言。我分尽以施汝。第二第三上座皆亦如是。如是展转一切众僧亦如是。如是展转至处处寺中。皆如是得多物。持衣襆来入只桓。尔时诸比丘在只桓门边经行。遥见跋难陀来。作是言。是跋难陀释子无惭无愧。有见闻疑罪。多欲无厌持是衣襆来。渐渐近已。诸比丘问跋难陀。何处得是多衣物来。跋难陀广说上事。是中有比丘。少欲知足行头陀。闻是事心嫌恨言。云何比丘余处安居余处受物。诸比丘种种呵责跋难陀已。是事白佛。佛以是因缘和合僧。佛知故问跋难陀。汝实尔不。答言。实尔。世尊。佛种种因缘呵责跋难陀。云何名比丘。余处安居余处受物。佛但呵责而未结戒

佛复憍萨罗国一住处。与多比丘安居。诸白衣居士见多众僧。为作房舍衣家中衣安居衣。佛后岁还只桓安居。是处有二长老比丘安居。此诸居士心念。我等亦当如去年施法。令诸比丘得衣。我得布施福不断绝。此诸居士如前所施。多持衣物至此住处。布施此二长老。是比丘作是念。是衣物分多。我等若分知得何罪。竟不敢分。跋难陀释子夏末月游行。从一住处到一住处。遍观诸住处安居僧数所得施物多少。又作是念。佛去年安居处。是中必多有施物。今当诣彼。念已便去。是二长老遥见已。从坐起迎与坐处问讯。跋难陀坐已小默然住。问是长老。是处众僧安居有施物不。答言有。问言。分未。答言。未分。何以故。长老答言。是衣物多。我等人少。若分不知得何罪。跋难陀言。汝未分者好。若分知汝等得何罪。二长老语跋难陀。汝能分不。答言能。跋难陀言。此中应作羯磨。不得直分。时二长老尽持衣出。着跋难陀前跋难陀分是衣作三分。语言。汝二人坐一聚边。自坐二聚间。语言。汝长老一心听。羯磨言。汝等二人一聚衣名为三。我一人二聚衣名为三。是羯磨好不。答言。善好。持是衣裹缚欲担去。二长老言。是聚衣我等未分。云何便去。跋难陀言。我若与汝分者。是中一好衣。应与知法人。然后当分。答言。当与。即持一上价衣出着一边。分余衣作二分与二长老。跋难陀即裹缚多衣物。担负到只桓。诸比丘只桓门边经行。遥见跋难陀来。自相谓言。此无惭无愧。有见闻疑罪。多欲无厌。人来渐渐近已问言。跋难陀。汝从何处得是多衣物来。跋难陀向诸比丘广说上事。是中有比丘。少欲知足行头陀。闻是事心嫌恨。种种呵责跋难陀。云何名比丘。故夺二长老物。呵责已是事白佛。佛以是因缘和合众僧。佛知故问跋难陀。汝实尔不。答言。实尔世尊。佛种种呵责跋难陀。汝云何欺诳。故夺是长老比丘物。种种因缘呵责已语诸比丘。是跋难陀。非但今世夺是二长老比丘物。是跋难陀。先世欺诳是二长老比丘夺物。是事中间今听。过去世河曲中有二獭。在是中住。河边得一鲤鱼。无能分者。二獭守住。有野干来饮水。见已问言。阿舅汝作何等。獭言。外甥。我等得此大鱼不能分。汝能为我分不。答言能。此中应依经书语分。不得直尔分。时野干即分鱼作三分。头为一分。尾为一分。中间肥者作一分。作三分已问言。谁喜近岸行。答言。此是。谁喜入深水行。答言。此是。时野干言。汝一心听说经书言。近岸行者与尾。入深水行者与头。中间身分与知法者。尔时野干口衔是大鱼身归去。妇见持是大鱼来。说偈问言。善哉智者。何处得是满口无头无尾鲤鱼来。答言。有愚痴不知断事喜斗诤者。智者因是得为王者。得增库藏。此无头尾鱼。我以断事故得。佛语诸比丘。汝谓此二獭。岂异人乎。即今二长老比丘是。时野干者。岂异人乎。今跋难陀是。尔时跋难陀夺獭物故。今世亦夺。佛种种因缘呵责跋难陀已。语诸比丘。从今日不应余处安居余处取物。若取得突吉罗

阿难有共行弟子。名直信。软善好人。常入出一居士舍。是居士有二儿。居士得重病。直信比丘往问讯。居士与施坐处。共相问讯。是居士小默然已。语直信比丘。若我死后观我二儿。若有好者当与户钥。作是语已便命终。是直信比丘。即观善好儿便与户钥。第二儿索分物。得户钥者不与。时小儿到阿难所。言直信比丘。阿难便摈直信比丘。直信比丘是释种子。语五百释子言。为我求请和上听我忏悔。答言。云何能令汝得忏悔。直信言。汝等尽为我将男女小儿诣和上所。头面礼足在前坐。和上必当为汝等说法。和上说法默然已。汝等尽留诸小儿便舍去。和上必当言。汝等将是诸小儿去。作是语时汝等当言。听直信比丘忏悔者。我当将去。诸释子言尔。时即五百诸释子。如直信比丘教。将小男女至阿难所。头面礼足在前坐。阿难为说法已默然。诸释子留诸小儿便舍去。时诸小儿啼哭。阿难语言。将诸小儿去。彼言。若听直信比丘忏悔者我当将去。阿难思量已语诸释子言。我听忏悔。阿难后语弟子。汝得突吉罗罪

有二比丘。共作善知识。一名旃陀罗。二名苏陀夷旃陀罗比丘。有僧伽梨欲贸易。苏陀夷比丘须僧伽梨。旃陀罗置僧伽梨着房中。苏陀夷谓旃陀罗欲贸是衣。我今须之便试着看。若可身者我便取之。旃陀罗入见着己衣便语言。汝得波罗夷。苏陀夷言。何以故。答言。汝盗心着我衣。苏陀夷言。不尔。汝欲贸僧伽梨。我须之。汝出后我取试着看耳。时苏陀夷心生疑悔。我将无得波罗夷耶。是事白佛。佛知故问。汝以何心取。答言。我以同意取。佛言。若以同意取无罪。从今日非同意物不应取。若取得罪。有五种同意取。一可信善知识。二人现在。三物现在。四取时白他。五取彼必欢喜。是名五种。有二比丘共为善知识。一名须尸摩。二名和修达。须尸摩能裁割衣。和修达须裁割衣。持衣财到须尸摩所。问言。谁能割截是衣者。我当与是人钵。须尸摩言。我能与汝裁割衣。汝与我钵不。答言能。须尸摩言。若能与我钵者。留衣财着我边去。即便留衣去。后须尸摩即与裁割。缝两向出叶卷牒已还主。语言。我用汝衣财作衣讫。汝与我瓦钵来。和修达言。汝是客作贫穷。不能自活人耶。答言。汝不知耶我是。即时和修达。净洗钵着一面未与便出去。时须尸摩作自物想取持去。和修达来不见钵。语须尸摩言。善知识。汝得波罗夷。何以故。汝以盗心取我钵。须尸摩生疑悔。我将无得波罗夷耶。是事白佛。佛知故问。汝以何心取。答言。我以自物想取。佛言。无罪。从今日不应为取物故与他作。若为取物故作得突吉罗。不犯者。若彼言。汝有事我当代汝作。我若守僧房。汝当代我迎食分。如是无罪

有二客比丘。一名阿逸多。二名舍摩达多。是二客比丘向暮来。舍摩达多比丘着新染好衣。阿逸多见是衣即生贪心。是二人共房舍宿。各自卷牒是衣缠裹置一处。以小因缘故是衣易本处。阿逸多比丘。夜未晓谓己衣是舍摩达多衣。以盗心而持去。地了看乃是己衣。心生疑。我将无以自盗衣故得波罗夷耶。是事白佛。佛知故问。汝以何心取。答言。我以盗心取。佛言。先作故无罪。从今日自衣不应以盗心取。若盗心取得偷兰遮。放猪人失猪。诸贼在只桓堑中。杀猪取好肉持去。留肠着堑中。诸比丘早起乞食。见是肠语弟子言。持此肠煮。我乞饭食去。放猪人不见。求觅到是中。遥见烟便往看。见煮猪肠。问言。诸比丘此中煮何等。答言。我煮猪肠。放猪人言。我失猪。汝等煮猪肠。汝必偷我猪。诸比丘答言。我等不偷汝猪。我于堑中得是肠耳。放猪人言。诸比丘语我实。诸比丘若不肯语我实。我当向官言。言已官人问比丘言。汝实偷猪耶。比丘言。不我自于只桓堑中得。官人言。此诸比丘终不能杀猪。即放比丘令去。余时若空地见猪肠莫复取。是比丘于是诤讼事边得脱。诸比丘闻是事白佛。佛言。从今日如是不净弃物不应取。若取得突吉罗。有守甘蔗园人失甘蔗。守多罗园人失多罗果亦如是。有诸人民亲里死。以白[疊*毛]裹弃着死人处。时阿难游行是中。见便持去。死人即动。语阿难言。莫夺我衣。阿难还以[疊*毛]覆死人已去。阿难到只桓语诸比丘言。某处死人以[疊*毛]覆。有比丘。名黑阿难。凶健有力。问阿难言。在何处。答言。在彼处。即便往取。时死人便动。语黑阿难言。夺我衣。黑阿难骂言。小鬼弊鬼。汝何处有是衣。汝以贪着是衣故。生此鬼中。黑阿难持衣在前去。死尸啼哭逐后。黑阿难持是[疊*毛]入只桓中。只桓中有大威德诸天鬼神。不听是小鬼入。时死尸堕只桓堑中。时黑阿难以[疊*毛]示诸比丘言。此是死人衣我持来。诸比丘问言。死人今在何处。答言。在只桓堑中。诸比丘生疑。是事云何。即以白佛。佛语黑阿难。还将死尸去置本处。还以白[疊*毛]覆。行时当在后。莫在前。在左边行。莫在右边。近头边。莫近足。勿令打汝。佛以是因缘语诸比丘。从今日死尸若未坏。不应取衣。若取得突吉罗。有一比丘福德。喜得酥油蜜石蜜。一估客见是比丘语言。大德。汝须酥油蜜石蜜。来至我舍我当与汝。比丘言尔。是比丘有共行弟子。闻作是念。此估客常请我和上。自恣与酥油蜜石蜜。我今当往试之。实能与不。如是思惟已。过数日往索五升酥。估客即与。是弟子持着食中与和上。过少时。估客见是比丘语言。大德。何以不索饭肉羹等。但索五升酥耶。比丘言。汝道何等。答言。大德弟子来。索五升酥不索余。比丘言好。若更索余当与。是比丘到弟子所言。汝得波罗夷。弟子言。何以故。估客不与。汝汝辄取估客五升酥。故弟子。言我非不与。取是估客常自。言请和上与酥油蜜石蜜。我试往索。看为实能与不。得酥还着和上食中。我不自用。是弟子生疑。我将无得波罗夷耶。是事白佛。佛言。不得波罗夷。故妄语故。得波夜提。油蜜石蜜亦如是。有一住处。林中虎杀鹿食肉。余骨肉在。诸比丘食后经行林中。见此残鹿。见已自相语言。持此残鹿着房中。明日当食。诸比丘持归着房中已。虎饥还至本处。求鹿不得。绕只桓精舍吼。佛知故问。阿难。虎何以故吼。阿难言。诸比丘持虎残骨肉着房中。是故吼。佛言。从今日虎残骨肉不应取。若取得突吉罗。何以故。虎于肉不断望故。若师子残肉可取。何以故断望故(第二波罗夷竟)

    第十诵杀戒

佛在婆耆国婆求沫河边。佛与婆求沫诸比丘。结不杀戒言。先作无罪。是诸比丘生疑悔。我多为诸比丘。赞叹死令发死心而杀。不知何时是先。佛言。未结戒前婆求沫诸比丘一切时不犯。故说先作无罪。有一比丘。以非人想杀人。是比丘生疑。我将无得波罗夷耶。是事白佛。佛言。人作人想杀。得波罗夷。人作非人想杀。得波罗夷。人中生疑杀。得波罗夷非人非人想杀。得偷兰遮。非人人想杀。得偷兰遮。非人中生疑杀。得偷兰遮。有一比丘久来病。有相识比丘来问讯。病人言。觅刀与我。比丘言。用作何等。病人言。但与我来。即持刀与。病人得刀。持入房坐床。以自割咽。是相识比丘。过五六日已生疑。是病人持刀入房。五六日不出。不还我刀。为作何等。即入房看。见病比丘死刀在地。是比丘作是念。是病人死。是我因缘。若彼索刀。我不与者则不死。是比丘生疑。我将无得波罗夷耶。是事白佛。佛言。无罪。从今日不应令病人得刀。若令得刀得突吉罗。有比丘。常入出一居士舍。是比丘早起着衣持钵入居士舍。居士行不在。其妇为敷座处。坐已共相问讯。小默然已语比丘言。共作淫欲来。比丘言。莫作是语。汝夫甚恶。妇言。我能令善。比丘出后。即与夫毒药。是居士食即死。后时比丘。着衣持钵复到居士舍。是妇与敷坐处。坐已共相问讯。小默然已语比丘言。共作淫欲来。比丘言。姊莫作是语。我断淫欲人。彼言。汝先何不语我是断淫欲人。我为汝故杀夫。而今方言我断淫欲人耶。比丘言。我不教汝杀夫。彼言。汝先言。我夫甚恶。比丘言。我但言。汝夫恶性。不教汝杀。是比丘生疑。我将无得波罗夷耶。是事白佛。佛言。无罪。有一比丘。常入出一居士舍。是比丘中前着衣持钵入居士舍。居士病。妇语比丘言。共作淫欲来。比丘言。汝夫病。云何作是语。答言。我能令无病。比丘出后。妇即以毒药杀夫。比丘后时。复着衣持钵到其舍。妇言。作淫欲来。比丘言。我断淫欲人。汝莫作是语。其妇言。我为汝故杀夫。汝今云何方言我断淫欲人。比丘言。我不教汝杀夫。我言。汝夫病云何作此言。是比丘生疑。以是事白佛。佛言。无罪。比丘杀心打人。是人若死。得波罗夷。若不死得偷兰遮。比丘以杀心打人。是人未死顷。比丘若狂若返戒。得偷兰遮。比丘嗔母堕胎若母死。得波罗夷。若儿死得偷兰遮。若俱死得波罗夷。俱不死得偷兰遮。若嗔儿故堕母胎。若儿死得波罗夷。若母死得偷兰遮。若俱死得波罗夷。俱不死得偷兰遮。比丘堕他胎若动胎。是人死已产出。得波罗夷。若胎是鬼。死已产出。得偷兰遮。若胎是畜生。死已产出。得波夜提。比丘尼亦如是。有一比丘病。语看病人言。我欲得苏毗罗浆。看病人即与饮已便死。是比丘生疑。我将无得波罗夷耶。是事白佛。佛言。无罪。有一梵志病疥瘙。到诸比丘所言。我若得苏毗罗浆当得差。比丘言。汝是贫穷乞儿腹中常空。何故生此疮。答言。我曾有是疮。饮是浆得差。比丘与浆。饮已便死。是比丘生疑。我将无得波罗夷耶。是事白佛。佛言。无罪。有一人。贯在木头极受苦恼。有一冢间比丘。到死人处观无常。见此人。此人语比丘言。我得苏毗罗浆。当得活。比丘即与。饮已便死。比丘生疑。我将无得波罗夷耶。是事白佛。佛言。无罪。有一人。被截手足着只桓堑中。诸比丘尼为听法故来到只桓。闻是人啼哭声。女人轻躁便往就观。共相语言。若有能与是人药。使得时死者。则不久受苦恼。中有一愚直比丘尼。与苏毗罗浆。是人即死。诸比丘尼语言。汝得波罗夷。是比丘尼言。何以故。答言。汝若不与是人浆。是人不死。是比丘尼生疑。我将无得波罗夷耶。是事白佛。佛知故问。汝以何心与。比丘尼言。我欲令早死不久受苦故与。佛言。是人死时。汝即得波罗夷。阿罗毗国僧房中起新舍。比丘在上作。手中錾堕木师头上便死。是比丘生疑。我将无得波罗夷耶。是事白佛。佛言。无罪。从今日作应一心好观下。复有阿罗毗国僧房中起新舍。比丘在上作。斧堕杀木师。比丘生疑。我将无得波罗夷耶。是事白佛。佛言。无罪。从今日作应一心好观下。复有阿罗毗国僧房中起浴室。挽材上。比丘少材重。捉不禁。材堕杀木师。诸比丘生疑。我将无得波罗夷耶。是事白佛。佛知故问。汝以何心。比丘言。人少材重。力不禁故失材。佛言。无罪。从今日当一心好观下

复有阿罗毗国作治浴室。故挽梁上。比丘少梁重。捉不禁故。梁堕杀木师。诸比丘生疑。我将无得波罗夷耶。是事白佛。佛知故问。汝以何心。比丘言。诸比丘少材梁重。捉不禁故失。佛言。无罪。从今日作当一心观。莫令杀人。若人少不应挽重材。阿罗毗国覆浴室故。囊盛泥牵上。绳断杀木师。诸比丘生疑。我将无得波罗夷耶。是事白佛。佛言。无罪。从今日作应好用心。莫令杀人。有一比丘。山上坐禅。更有一比丘。在上推石。堕坐禅比丘头上即死。比丘生疑。我将无得波罗夷耶。是事白佛。佛言。无罪。从今日欲推石时。当唱言。石来石来。有一比丘。在牛群中行。有恶牸牛。逐欲触比丘。比丘走堕一小儿上。小儿即死。比丘生疑。我将无得波罗夷耶。是事白佛。佛言。无罪。从今日应安详牛群中行。有一比丘。病久羸瘦脊偻。作是念。我何用是活。今可自投深坑死。即自投坑。坑中先有野干啖死人。比丘堕上。野干死。比丘脊便得直。是比丘生疑。我将无得波夜提耶。是事白佛。佛言。无罪。从今日莫以小因缘便自杀。有一比丘暖坐处坐。以衣自覆。有余比丘唤言。起起。是比丘言。勿唤。我起我起便死。余比丘复重唤言。起起。便即死。是比丘生疑。我将无得波罗夷耶。是事白佛。佛言。不得波罗夷。得偷兰遮。比丘狂以杀心打他。若是人死得波罗夷。若不死得偷兰遮。有一比丘病久。看病比丘看视故。作是念。我看来久。是病人不死不差。今不能复看。置令死。是看病人便不看故。病人便死。是看病比丘生疑。我将无得波罗夷耶。是事白佛。佛言。不得波罗夷。得偷兰遮。有一比丘病。多有衣钵财物。看病人瞻视来久。作如是念。我今不能复看。置令死。财物当入众僧分。更不看故。病人便死。是比丘生疑。我将无得波罗夷耶。是事白佛。佛言。不得波罗夷。得偷兰遮。有一比丘。食不消故。以厚衣被自缠裹坐一处。有余比丘来唤言。起。答言。莫唤。我起我起当死。有余比丘。重唤言。起起。便即死。是比丘生疑。我将无得波罗夷耶。是事白佛。佛言。不得波罗夷。得偷兰遮。有一比丘。痈疮未熟。有一比丘来破。是比丘即死。是比丘生疑。我将无得波罗夷耶。是事白佛。佛言。若痈疮未熟破人死。得偷兰遮。若破熟痈死无罪。有一比丘病。看病人久来与求随病饮食。不能得。语病人言。我久为汝求随病饮食。不能得。今趣得食便啖。是病人趣得食。食故便死。是比丘生疑。我将无得波罗夷耶。是事白佛。佛言。不得波罗夷。得偷兰遮。有一比丘病。看病人为多求药。而不能得。是看病人到病人所言。我为汝故求随病药。而不能得。汝今趣得药当服。是病人趣得便服即死。是比丘生疑。我将无得波罗夷耶。是事白佛。佛言。若趣与药死者。得偷兰遮。若与随病药死无罪。有一比丘病。语看病人言。汝扶我起。扶我坐。与我着衣。扶我出房坐。与我洗浴。与我着衣。将我日中。将我阴中。还将我房中。令我坐。令我卧。是比丘即便死。看病比丘生疑。我将无得波罗夷耶。是事白佛。佛言。无罪。坐禅比丘睡。行禅比丘。以法杖触令觉。即便死。是比丘生疑。我将无得波罗夷耶。是事白佛。佛言。是比丘刀风发。若触若不触。必当死故。无罪。坐禅比丘睡。行禅比丘以绵鞠掷令觉。即便死。是比丘生疑。我将无得波罗夷耶。是事白佛。佛言。是比丘刀风发。若掷若不掷。必当死故。无罪。坐禅比丘睡。有一比丘。持水灌头令觉即死。是比丘生疑。我将无得波罗夷耶。是事白佛。佛言。是比丘刀风发。若灌若不灌。必当死故。无罪。十七群众中有一小儿喜笑。诸比丘捉击擽。令大笑故便死。是比丘生疑。我将无得波罗夷耶。是事白佛。佛知故问。汝以何心。答言。以戏笑故击擽。大笑故便死。佛言。无罪。从今日不应击擽人。若击擽得波夜提。有一居士得新谷新菜。先与众僧后自啖。有一阿兰若比丘。常入出此居士舍。是阿兰若。中前着衣持钵入居士舍。至坐处坐共相问讯。是居士见阿兰若。作是念。是新谷新菜。当与此阿兰若。不与众僧。即持与阿兰若比丘。诸比丘生念。此居士常得新谷新菜。先与众僧然后自食。今岁何以不与众僧耶。诸比丘自相问言。谁是彼舍入出比丘。有比丘言。有一阿兰若比丘。常入出其舍。必当是彼所遮。诸比丘言。唤是阿兰若比丘来。此比丘来已。诸比丘语言。某甲居士。岁岁常持新谷新菜。先与众僧然后自食。今岁不与。必是汝遮。答言。我何故遮。诸比丘言。此比丘不肯直首。当以两木压取其辞。压时便死。诸比丘生疑。我将无得波罗夷耶。是事白佛。佛言。不得波罗夷。得偷兰遮。有一居士。常与众僧安居衣。有一阿兰若比丘。常入出其舍。是比丘中前着衣持钵入居士舍。至坐处坐共相问讯。居士见已作是念。是衣我当与是阿兰若。不与众僧。念已即持衣与是比丘。诸比丘作如是念。某甲居士。常与众僧安居衣。今岁何故不与。共相问言。谁是彼舍常入出比丘。有比丘言。有一阿兰若比丘。常入出其舍。必是阿兰若所遮。诸比丘言。唤是比丘来。来已诸比丘问言。某甲居士。岁岁常与安居僧衣。今岁不与。必是汝遮。答言。我何以故遮。诸比丘言此比丘必不肯直首。当掷着池中。着时即死。诸比丘生疑。我将无得波罗夷耶。是事白佛。佛言。不得波罗夷。得偷兰遮。有一乞食比丘。中前着衣持钵入舍卫城乞食。游行时到一多人闹处门中。掷衣。角触木杵。木杵倒压杀一小儿。比丘生疑。我将无得波罗夷耶。是事白佛。佛言。无罪从今日乞食时当一心观前后。有一乞食比丘。中前着衣持钵入舍卫城乞食。游行诸处到一婆罗门舍。是舍主。晨朝洗头洗身着新白衣。在中门间座。上坐比丘在门下立弹指。婆罗门闻弹指声。即出看。见比丘即生恶心。作是念。我未祠天。未祠亡父母亲里。秃道人着坏色弊衣。断种人先来从我乞食。以嗔心推胸令去。比丘倒一小儿上。小儿即死。是比丘生疑。我将无得波罗夷耶。是事白佛。佛言。无罪。从今日乞食时。当一心观前后。有一比丘。有拍病咒术。拍一人颊。即时死。是比丘生疑。我将无得波罗夷耶。是事白佛。佛言。无罪。从今日欲拍时当徐徐莫令死。有一比丘。食时噎。一比丘与槌颈。所噎食并血来出。即时便死。是比丘生疑。我将无得波罗夷耶。是事白佛。佛言。无罪。从今日当安徐槌。但令食出。莫令死。迦留陀夷常入出一家。中前着衣持钵往到其舍。是家有妇人乳儿。早起持儿着床上。以白[疊*毛]覆舍去。迦留陀夷门下立弹指。妇人出看。见迦留陀夷言。大德坐此床。迦留陀夷不观。便坐小儿上。小儿大唤。妇人言。此中有小儿有小儿。迦留陀夷身重。坐时小儿即死肠出。迦留陀夷作是事已。还到寺中语诸比丘。我今日作如是事。诸比丘以是事白佛。佛知故问。汝以何心作是事。世尊。我先不观是床便坐。佛言。无罪。从今日床榻坐处。当好看然后坐。若不看坐。得突吉罗。偷罗难陀比丘尼亦如是。复有父子二比丘。共游行憍萨罗国。欲诣舍卫城。日暮是中有崄道未度。儿语父言。是中有崄道。当疾行过。即从儿语疾行即乏死。儿比丘生疑。我将无得波罗夷并逆罪耶。是事白佛。佛知故问。汝以何心语。儿比丘言。日暮恐不过崄道。我以恩爱心语令疾行。疾行时乏死。佛言。无罪。从今日莫以小因缘故日暮崄道中行。若已入崄道。老比丘所担物。年少比丘应代担。应语言。我若前去。汝当于后来。是时诸比丘便生疑。云何比丘杀父。不得波罗夷及逆罪耶。佛知诸比丘心所念。为说本生。语诸比丘。有过去世。有秃头染衣人。共儿持衣诣水边。浣诸衣已绞捩晒卷牒。盛着囊中持复道还归。尔时大热眼闇。道中见一树。便自以衣囊枕头下睡。有蚊子来饮其头血。儿见已嗔作是念。我父疲极睡卧。是弊恶婢儿蚊子。何以来饮我父血即持大棒欲打蚊子。蚊子飞去。棒着父头即死。时此树神说偈言

  宁为智者仇　　不与无智亲
  愚为父害蚊　　蚊去破父头

佛语诸比丘。谓彼时秃染衣人。岂异人乎。莫作是观。即此长老比丘是也。尔时儿者。今此比丘是。尔时此儿虽杀父而不得逆罪。今杀父亦不得波罗夷及逆罪

十诵律卷第五十八十诵律卷第五十九(第十诵之四)

        后秦北印度三藏弗若多罗译

    比尼诵杀戒之余

有父子二比丘。游行憍萨罗国。欲到舍卫国。至一无僧伽蓝聚落中。儿语父言。今于何处宿。父言。此聚落中宿。儿言。此聚落中白衣住处。若我在中宿与此何异。父言。当何处宿。儿言。当此空地宿。父言。此中有虎畏。若我睡时汝当莫睡。答言尔。父即卧睡。有鼾声。虎闻便来啮父头。父便大唤。儿看见父头破。父因是即死。儿比丘生疑。父由我故死。父欲在聚落中宿。我若用父教者。父则不死。我欲空地卧故令父死。我将无得波罗夷并逆罪耶。是事白佛。佛言。无罪。应当大唤然火怖虎令去。比丘以杀心。遣使杀某甲人。是人若死。是比丘得波罗夷。若不死得偷兰遮。有比丘。杀一猕猴。诸比丘言。汝得波罗夷。是比丘言。何以故。诸比丘言。猕猴似人。若杀与人何异。是比丘生疑。我将无得波罗夷耶。是事白佛。佛言。不得波罗夷。得波逸提。诸比丘游行憍萨罗国。向舍卫城。见一空寺入中观看。见卧具床榻釜镬盆器斗斛瓶瓮众僧生活物。无所乏少。自相谓言。我等何不是中安居。余比丘告言。随意。是中安居已立制。我等三月过不自恣。到八月当自恣。夏末月布施物我等当得。夏末八月贼发时。贼作是念。何处有不须器仗斗战而得钱物耶。作是念已共相谓言。当夺沙门释子物。贼即来围绕是寺。是僧中有比丘。得神通力。亦有本是大力士。及本是大射家子。是诸比丘作是念。我等以好心出家。不应与贼共斗。作是念已默然住。贼来劫夺衣被令皆裸露。诸佛常法。二时大会集诸弟子。一春末月。二夏末月。春末月。诸方处处国土诸比丘来至佛所。佛与我等说法。我等三月安居中。当念修习。是初大会。为听法故夏末月。自恣竟作衣毕。持衣钵到佛所。作是念。我等久不见佛世尊。是第二大会。为见佛故。是被贼比丘。自恣已作衣竟。持衣钵向舍卫。到佛所顶礼佛足。在一面坐。诸佛常法。客比丘来。以软语劳问。如是言。汝忍不足不。安乐住不。乞食不乏。道路不疲耶。尔时佛以如是语劳问诸比丘。汝忍不足不。安乐住不。乞食不乏。道路不疲耶。诸比丘言。世尊我等忍足安乐住。乞食不乏道路不疲。具以上事向佛广说。佛即以是因缘故集僧。集僧已种种因缘赞戒赞持戒。赞戒赞持戒已语诸比丘。汝等贼来时。应作大音声击钟振铃令贼怖畏。诸比丘从佛闻是事。见是过罪。后岁还本处安居。安居已还复立制。我等不应三月自恣。当到八月自恣。为夏末月得安居施物用故。夏末八月如本贼发时。贼作是念。何处当有不须器仗斗战而得钱物耶。作是念。沙门释子不与人斗。我当往劫取财物。念已即往围绕僧房。诸比丘先备防贼具。贼来已即入房舍。闭门下店上楼阁上。作大音声恐怖诸贼。击钟振铃。有二比丘。闇中掷石恐怖。石堕杀贼。是两比丘自相谓言。我与汝俱放石。不知谁石杀贼。即生疑。我将无得波罗夷耶。是事白佛。佛言。无罪。放石时应唱言。石下石下(第三波罗夷竟)

    大妄语戒

佛在毗耶离婆求沫河边。佛与婆求沫河诸比丘结戒言。先作无罪。是诸比丘作是念。我等多时空无过人法妄语。不知何者是先何者非先。心生疑悔。是事白佛。佛言。未结戒前婆求沫诸比丘一切时不犯。是故先作无罪。比丘人前作非人想。自说得过人法。是比丘生疑。我将无得波罗夷耶。是事白佛。佛言。人中生人想。得波罗夷。人中生非人想。得波罗夷。人中生疑。得波罗夷。非人中生非人想。得偷兰遮。非人中生人想。得偷兰遮。非人中生疑。得偷兰遮。有比丘。居士前自称得过人法。是居士不解。居士言。大德何所道。比丘言。置不须问。是比丘生疑。我将无得波罗夷耶。是事白佛。佛言。不得波罗夷。得偷兰遮。有人问比丘言。汝是阿罗汉不。汝应受上座上水上供养不。若默然受。得偷兰遮。人问比丘言。汝是婆罗门除灭恶法不。若默然受。得偷兰遮。人问比丘言。汝好守六根门不。若默然受。得偷兰遮。人问比丘言。汝若是阿罗汉便受是衣被。若默然受。得偷兰遮。饮食汤药资生之物亦如是。比丘常入出一居士家。是比丘中前着衣持钵到是居士舍。居士出在门下立言。若是阿罗汉。入我舍坐处坐。手受水受饮食。受已咒愿。咒愿已去。若是比丘默然入坐。饮食咒愿。咒愿已去时得偷兰遮。有一比丘常入出一居士家。是比丘中前着衣持钵到其舍。居士出在门下立言。大德。若是阿罗汉便入。比丘言。我非阿罗汉。若听入当入。若居士听入无罪。坐处坐受水饮食咒愿出门亦如是。一时目连语诸比丘。从阿鼻地狱乃至阿迦尼吒天。我能于中遍至。身自在来往。诸比丘言。目连。汝何有此事。声闻弟子身通。极远能至梵世。汝空无过人法故妄语。汝目连灭摈驱出。是事问佛。佛语诸比丘言。汝等莫说目连是事罪过。何以故。若人依初禅。善修习如意足得神通。是人则能从阿鼻地狱乃至阿迦尼吒天。身自在往来。若比丘依第二禅第三禅第四禅亦如是。目连比丘依四禅。善修如意足得大神通。若欲从阿鼻地狱上至阿迦尼吒天。于中身得往反自在。目连语实无罪。又一时目连语诸比丘言。从阿鼻地狱乃至阿迦尼吒天。其中众生所有音声。我以天耳皆悉能闻。诸比丘言。目连汝何有此事。声闻弟子天耳。极远能闻上至梵世。汝目连空无过人法妄语。汝目连灭摈驱出。是事问佛。佛语诸比丘。汝等莫说目连是事过罪。何以故。若有依初禅得天耳。是人则能从阿鼻地狱乃至阿迦尼吒天。其中音声自在能闻。若比丘依第二第三第四禅亦如是。目连比丘依四禅。善修天耳通。若欲闻阿鼻地狱乃至阿迦尼吒天其中众生所有音声。皆悉能闻。目连实语无罪。又一时目连语诸比丘言。从阿鼻地狱乃至阿迦尼吒天。其中众生所有心念。我能悉知。诸比丘言。目连。汝何有是事。声闻弟子极远能知乃至梵世。汝空无过人法故妄语。汝目连灭摈驱出。是事问佛。佛语诸比丘。汝等莫说目连是事过罪。何以故。若比丘依初禅。善修知他心通。是人则能从阿鼻地狱乃至阿迦尼吒天。其中众生所有心念。皆悉能知。若比丘依第二第三第四禅亦如是。目连比丘。依四禅善修他心通。若欲知从阿鼻地狱乃至阿迦尼吒天其中众生所有心念。皆悉能知。目连语实无罪。又一时目连语诸比丘。从阿鼻地狱乃至阿迦尼吒天。其中众生宿命。我悉能知。诸比丘言。目连。汝何有此事。声闻弟子宿命通。极远能知从阿鼻地狱乃至梵世。汝空无过人法故妄语。汝目连灭摈驱出。是事问佛。佛语诸比丘。汝等莫说目连是事过罪。何以故。若比丘依初禅善修宿命通。是人则能从阿鼻地狱乃至阿迦尼吒天。其中众生所有宿命。皆悉能知。若比丘依第二第三第四禅亦如是。目连比丘。依四禅善修宿命通。若阿鼻地狱上至阿迦尼吒天。其中众生所有宿命。皆悉能知。目连语实无罪。又一时目连语诸比丘。从阿鼻地狱上至阿迦尼吒天。其中所有众生死此生彼。我以天眼悉能见之。诸比丘言。汝目连。何有此事。声闻弟子天眼。极远能见阿鼻地狱乃至梵世。汝空无过人法故妄语。汝目连灭摈驱出。是事问佛。佛语诸比丘。汝等莫说目连是事过罪。何以故。若比丘依初禅善修天眼通。是人则能从阿鼻地狱上至阿迦尼吒天。其中众生死此生彼。皆悉能见。若人依第二第三第四禅亦如是。目连比丘。依四禅善修天眼通。若从阿鼻地狱乃至阿迦尼吒天。其中众生死此生彼。皆悉能见。目连语实无罪。又一时目连语诸比丘言。若人言求漏尽阿罗汉。梵行已立所作已办。舍于重担逮得己利。尽诸有结正智已得解脱者。则我身是。何以故。我是阿罗汉漏尽。乃至正智已得解脱。诸比丘言。汝何有此事。得阿罗汉漏尽。乃至正智已得解脱。何以故。目连多事多欲。目连。汝空无过人法故妄语。灭摈驱出。是事问佛。佛语诸比丘。汝等莫说目连是事过罪。何以故。若人求实阿罗汉漏尽。梵行已立所作已办。舍于重担逮得己利。尽诸有结。正智已得解脱者。目连是也。何以故。目连实是阿罗汉漏尽。乃至正智已得解脱目连语实无罪。又一时目连语诸比丘。我见有一众生五百由旬大火焰烧身虚空中来大唤啼哭极受苦切。诸比丘言。何处有是众生。有如是大火焰。汝空无过人法故妄语。汝目连灭摈驱出。是事问佛。佛语诸比丘。汝等莫说目连是事过罪。何以故。我亦见是众生五百由旬火焰烧身虚空中来大唤啼哭极受苦切。但不欲向余人说。何以故。畏人不信。若人不信如来语。长夜受大衰恼。目连语实无罪。又一时目连语诸比丘。我见有一众生。五百夜叉鬼持五百斧。经五百日夜斫一肋。是肋堕海水中。海即扰浊。诸比丘言。目连。何处有如是众生。有如是肋。汝目连。空无过人法故妄语。汝目连灭摈驱出。是事问佛。佛语诸比丘。汝等莫说目连是事过罪。何以故。我亦见是众生。五百夜叉鬼持五百斧。经五百日夜斫断一肋。堕海水中海即扰浊。而不欲向人说。何以故。畏人不信。若人不信如来语。长夜受大衰恼。目连语实无罪。又一时目连语诸比丘。我见一众生。身如一大木船。头如酒瓮。喘息如雷声。眼睛如憍萨罗大铜釪。口中出舌如黑云中掣电。诸比丘语目连言。何处有此众生。汝目连。空无过人法故妄语。汝目连灭摈驱出。是事问佛。佛语诸比丘。汝等莫说目连是事过罪。何以故。我亦见是众生。身如一大木船。头如酒瓮。喘息如雷声。眼睛如憍萨罗大铜釪。口中出舌如黑云中掣电。如来而不欲向人说。何以故。畏人不信。若人不信如来语者。长夜受大衰恼目连语实无罪。又一时目连语诸比丘。北方有池。名漫陀紧尼。广长五十由旬。周围二百由旬。底布金沙。八功德水常满其中。甜美如真蜜。青黄赤白红紫种种杂色莲花遍覆池上。种种众鸟哀声相和甚可爱乐。绕池四边种种花树果树。诸比丘语目连。何有如此池。汝空无过人法故妄语。汝目连灭摈驱出。是事问佛。佛语诸比丘。汝等莫说目连是事过罪。何以故。北方有是漫陀紧尼池。纵广五十由旬。周围二百由旬。底布金沙。八功德水常满其中。甜美如真蜜。青黄赤白红紫种种杂色莲花遍覆池上。种种众鸟哀声相和甚可爱乐。绕池四边种种华树果树。目连语实无罪。又一时目连在耆阇崛山中。入虚空无色定。善取入定相。不善取出定相。从三昧起。闻萨卑尼池岸上大象声。闻已还疾入三昧。作是念。我入三昧中闻是象声。从三昧起语诸比丘。我一时在耆阇崛山中。入虚空无色定。闻萨卑尼池岸上象声。诸比丘语目连。何有此理。入虚空无色定中。若见若闻无有是事。何以故。若人入无色定。破坏色相舍离声相故。汝空无过人法故妄语。汝目连灭摈驱出。是事问佛。佛语诸比丘。汝等莫说目连是事过罪。何以故。目连见先事不见后事。如来亦见先亦见后。目连在耆阇崛山中。入虚空无色定。善取入定相。不善取出定相。是人从三昧起。闻萨卑尼池岸上象声已。还疾入虚空无色定。便谓我入定闻声。若人入无色定。若见色闻声。无有是处。何以故。是人破坏色相舍离声相故。若目连空无过人法故妄语者。亦无是处。目连随心想说无罪。又一时目连在耆阇崛山中。入识处无色定。善取入定相。不善取出定相。从三昧起。闻天城中诸天歌声。闻已还疾入定。作是念。我在三昧中闻诸天歌声。从三昧起语诸比丘。我一时在耆阇崛山中。入识处定。闻天城中诸天歌声。诸比丘语目连。何有此理。入无色定而当见色闻声耶。何以故。若人入无色定。破坏色相舍离声相。汝空无过人法故作妄语。汝目连灭摈驱出。是事问佛。佛语诸比丘。汝等莫说目连是事过罪。何以故。目连见先事不见后事。如来亦见前亦见后。目连在耆阇崛山中。入识处无色定。善取入定相。不善取出定相。从三昧起。闻天城中诸天歌声。闻已还疾入定。便谓我入定闻声。若人入无色定。若见色若闻声。无有是处。何以故。是人破坏色相舍离声相故。若目连空无过人法故妄语者。亦无是处。目连随心想说无罪。又一时目连在耆阇崛山中。入无所有处无色定。善取入定相。不善取出定相。从三昧起。闻阿修罗城中阿修罗伎乐音声。闻已还疾入定。作是念。我在定中闻阿修罗城中伎乐音声。从定起已语诸比丘。我一时在耆阇崛山中。入无所有处无色定。闻阿修罗城中阿修罗伎乐音声。诸比丘语目连。何有此理。入无色定而当见色闻声耶。何以故。若人入无色定。破坏色相舍离声相。汝空无过人法故作妄语。汝目连灭摈驱出。是事问佛。佛语诸比丘。汝等莫说目连是事过罪。何以故。目连见先事不见后事。如来亦见前亦见后。目连在耆阇崛山。入无所有处无色定。善取入定相。不善取出定相。从定起闻阿修罗城中伎乐音声。闻已还疾入定。便谓我入定闻声。若人入无色定。若见色若闻声。无有是处。何以故。是人破坏色相舍离声相故。若目连空无过人法故妄语者。亦无是处。目连随心想说无罪。又一时目连语诸比丘。北方有阿耨达池。纵广五十由旬。周围百五十由旬。底有金沙。八功德水常满其中。甜美如真蜜。青黄赤白杂色莲花遍覆水上。种种众鸟哀声相和如音乐声甚可爱乐。绕池四边种种花树果树。善住象王宫殿住处。有八千象以为眷属。若转轮圣王出于世时。八千象中最下小者。出为象宝给圣王乘。诸比丘言。何有此池。何有此象。汝空无过人法故妄语。汝目连灭摈驱出。是事问佛。佛语诸比丘。汝等莫说目连是事过罪。何以故。北方有阿耨达池。纵广五十由旬。周围百五十由旬。底有金沙。八功德水常满其中。甜美如真蜜。青黄赤白杂色莲花遍覆水上。种种众鸟哀声相和如音乐声甚可爱乐。绕池四边种种花树果树。善住象王宫殿住处。有八千象以为眷属。若转轮圣王出于世时。八千象中最下小者。出为象宝给圣王乘。目连语实无罪。又一时目连语诸比丘。外大海内洲有明月山。婆罗醯马王宫殿住处。有八千马以为眷属。若转轮圣王出于世时。八千马中最下小者。出为马宝给圣王乘。诸比丘言。何有此处。有如此马。汝空无过人法故作妄语。汝目连灭摈驱出。是事问佛。佛语诸比丘。汝等莫说目连是事过罪。何以故。外大海内洲有明月山。婆罗醯马王宫殿住处。有八千马以为眷属。若转轮圣王出于世时。八千马中最下小者。出为马宝给圣王乘。目连语实无罪。又一时诸比丘问目连。是多浮河水从何处来。目连答言。此水从阿耨达池中来。诸比丘言。阿耨达池其水甜美。有八功德。此水沸热碱苦。何有此事。目连。汝空无过人法故作妄语。汝目连灭摈驱出。是事问佛。佛语诸比丘。汝等莫说目连过罪。何以故。阿耨达龙住处。去此极远。是水本有八功德甜美。经历五百小地狱上来。是故碱热。汝等若问目连是水何故碱热。目连能随相答汝。目连实语无罪。又一时目连语诸比丘。耆阇崛山底有五百由旬池。池底有金沙。八功德水充满其中。甜美如真蜜。青黄赤白杂色莲花遍覆水上。种种众鸟哀声相和如音乐声。绕池四边有种种花树果树。是摩那斯龙王宫殿。诸比丘言。何有是池。何有是龙。汝空无过人法故作妄语。汝目连灭摈驱出。佛闻是事语诸比丘。汝等莫说目连是事过罪。何以故。是耆阇崛山底。有五百由旬池。底布金沙。八功德水充满其中。甜美如真蜜。青黄赤白杂色莲花遍覆水上。种种众鸟哀声相和如音乐声。绕池四边有种种花树果树。是摩那斯龙王宫殿。目连语实无罪。又一时目连语诸比丘。三十三天有善法堂。堂有五百柱。有一宝柱。如毫毛许。不到碠上有宝楼。是释提桓因坐处。众花庄严。其边皆有诸天坐处。亦以花庄严。诸比丘语目连。何有是事。汝空无过人法故作妄语。汝目连灭摈驱出。佛闻是事语诸比丘。汝等莫说目连是事过罪。何以故。忉利天上善法堂。堂有五百柱。有一宝柱。如毫毛许。不到碠上有宝楼。是释提桓因坐处。众花庄严。其边皆有诸天坐处。亦以花庄严。目连语实无罪。又一时目连入定。见跋耆夜叉与摩伽陀夜叉共斗。跋耆夜叉破摩伽陀夜叉。目连从三昧起语诸比丘。跋耆人当破摩伽陀人。后阿阇世王。善将兵众破跋耆人诸比丘语目连。汝先言跋耆人当破摩伽陀人。而今摩伽陀人破跋耆人。汝空无过人法故妄语。汝目连灭摈驱出。佛闻是事语诸比丘。汝等莫说目连是事过罪。何以故。目连见前不见后。如来见前亦见后是跋耆夜叉与摩伽陀夜叉共斗。跋耆夜叉破摩伽陀夜叉。尔时跋耆人亦破摩伽陀人。后阿阇世王。更集兵众共战得胜目。连随心想说无罪。目连又复入定。见摩伽陀夜叉与跋耆夜叉共斗。摩伽陀夜叉破跋耆夜叉。目连从三昧起语诸比丘。摩伽陀人当破跋耆人。后战时跋耆人破摩伽陀人。诸比丘语目连。汝先言摩伽陀人当破跋耆人。而今跋耆人破摩伽陀人。汝空无过人法故妄语。汝目连灭摈驱出。佛闻是事语诸比丘。汝等莫说目连是事过罪。何以故。目连见前不见后。如来见前亦见后。是摩伽陀夜叉。与跋耆夜叉共斗得胜。破跋耆夜叉。尔时摩伽陀人亦破跋耆人。后跋耆人更集兵众共斗得胜。目连随心想说无罪。目连常入出一居士舍。又一时目连中前着衣持钵入其舍。居士与敷坐处共相问讯。是家中有妊身妇人。檀越问目连。大德。是妇为生男为生女。目连答言。生男。语已便去。更有一梵志来入其舍。主人问言。此妇人为生男为生女。梵志言。生女。是妇人便生女。诸比丘语目连。汝先说某居士舍妇人生男。今乃生女。汝空无过人法故妄语。汝目连灭摈驱出。佛闻是事语诸比丘。汝等莫说目连是事过罪。何以故。目连见前不见后。如来见前亦见后。尔时此儿是男。后转根为女。目连随心想说无罪。目连后相生女亦如是。又一时大旱无雨。目连入定见。却后七日天当大雨。满诸沟坑。城邑聚落。悉闻此言皆大欢喜。国中人民皆舍众务覆屏盖藏。各各屈指过筹数日。到第七日雨风尚无。何况雨耶。诸比丘语目连。汝言七日天当大雨满诸沟坑。今雨风尚无。何况雨耶。汝空无过人法故妄语。汝目连灭摈驱出。佛闻是事语诸比丘。汝等莫说目连是事过罪。何以故。目连见前不见后。如来见前亦见后。七日有大雨下。有罗睺阿修罗王。以手接去置大海中。目连随心想说无罪。长老莎伽陀语诸比丘。我入禅定。能令从阿鼻地狱上至阿迦尼吒天满其中火。诸比丘言。何有是事。声闻弟子能作大火。从阿鼻地狱极至梵天。汝空无过人法故妄语。汝莎伽陀灭摈驱出。佛闻是事语诸比丘。汝等莫说莎伽陀是事过罪。何以故。若比丘依初禅。修如意足得神通。是比丘则能从阿鼻地狱至阿伽尼吒天。自在能满中火。若比丘依第二第三第四禅亦如是。莎伽陀依止四禅。善修如意足得大神通。若念从阿鼻地狱至阿迦尼吒天自在能满中火。莎伽陀语实无罪。长老输毗陀语诸比丘。我能一念中识宿命五百劫事。诸比丘语输毗陀。何有是事。声闻弟子一念中。极多能知一世。汝空无过人法故妄语。汝输毗陀灭摈驱出。佛闻是事语诸比丘。汝等莫说。输毗陀是事过罪。何以故。是输毗陀前身。从无想天命终。来生此间。无想天寿五百劫以是故说一念中知五百劫。输毗陀随心想说。无罪(四波罗夷竟略问僧残不定舍堕单提悔过此五篇略问不问众学七灭诤也)

    僧伽婆尸沙初

佛在舍卫国。因迦留陀夷结戒。先作无罪。长老迦留陀夷。作是念生疑。我多时出精。不知何时是先是不先。是事白佛。佛言。未结戒前善男子迦留陀夷一切时出精不犯。故言先作无罪。一比丘身不动便出精。心生疑。我将无得僧伽婆尸沙耶。是事问佛。佛言。无罪。毗舍佉鹿子母。信众僧两手接足头面作礼。次到迦留陀夷接足作礼。迦留陀夷即失精堕其头上。优婆夷小却两手拭精。欢喜唱言。我得大利。我诸同学。有如是多淫欲人。亦能断欲修梵行。迦留陀夷生疑。我将无得僧迦婆尸沙耶。是事白佛。佛言。无罪若有如是多欲比丘。应当裹系。有一比丘洗浴时失精。心生疑。我将无得僧伽婆尸沙耶。是事白佛。佛言。无罪。有比丘。洗浴时余比丘与摩身即时失精。心生疑。我将无得僧伽婆尸沙耶。佛言。无罪。有一比丘。摩触男根时失精。心生疑。我将无得僧伽婆尸沙耶。佛言。若逆摩失精。得僧伽婆尸沙。若顺摩为覆故失精无罪。有一比丘。邪念故失精。心生疑。我将无得僧伽婆尸沙耶。佛言。无罪。有一比丘见端正女色便失精。心生疑。我将无得僧伽婆尸沙耶。佛言。无罪。有比丘。若为女人捉手捉脚捉膝捉[跳-兆+尃]故比丘失精心生疑。我将无得僧伽婆尸沙耶。佛言。无罪。有比丘。为母抱捉鸣说邪语。是比丘失精。心生疑。我将无得僧伽婆尸沙耶。佛言。不得僧伽婆尸沙。得突吉罗。姊妹本二先私通妇亦如是。有比丘。于新死女人胀女人青瘀女人臭烂女人啖残女人血涂女人干枯女人胀坏女人骨女人身上出精。得僧伽婆尸沙(初僧伽婆尸沙竟)

佛因迦留陀夷结戒。先作无罪。是迦留陀夷作是念生疑。我多时摩触女人身。不知何时是先是不先。是事白佛。佛言。迦留陀夷。未结戒前摩触女人身一切时不犯。故名先作无罪。有比丘。人女中生非人女想摩触。后生疑。我将无得僧伽婆尸沙耶。是事白佛。佛言。若人女中生人女想摩触。得僧伽婆尸沙。人女中生非人女想摩触。僧伽婆尸沙。人女中生疑摩触。得僧伽婆尸沙。非人女中生非人女想摩触。偷兰遮。非人女中生人女想摩触。偷兰遮。非人女中生疑摩触。得偷兰遮。比丘以脚蹋触女人身。得突吉罗。若女人以脚蹋触比丘身无罪。比丘捉女衣得突吉罗。若女人捉比丘衣无罪。比丘捉女人鬓。捉发花捉真珠捉耳璎珞捉耳珰捉如是等女人庄严具。偷兰遮。有女人。与比丘泻水。水流不断。比丘于是女人生邪心。即生疑。我将无得僧伽婆尸沙耶。是事白佛。佛言。不得僧伽婆尸沙。得偷兰遮。比丘为母抱捉鸣说邪语。心生疑。我将无得僧伽婆尸沙耶。是事白佛。佛言。不得僧伽婆尸沙。得突吉罗。姊妹本二先私通妇亦如是。有比丘。于新死女人胀女人青瘀女人臭烂女人啖残女人血涂女人干枯女人胀坏女人骨女人摩触。得偷兰遮(第二僧伽婆尸沙竟)

佛因迦罗比丘鹿子儿结戒。先作无罪。是比丘生疑。我多时媒嫁。不知何时是先是不先。是事白佛。佛言。未结戒前迦罗比丘一切时媒嫁不犯。故名先作无罪。有比丘。常入出一家中。是比丘一时中前着衣持钵至居士舍。与坐处坐已共相问讯。居士小默然已语比丘言。汝能语某甲女人至我边不。比丘言。我能语彼不能还答汝。居士言。云何知此事得成以不。比丘言。我当令比丘在某处立。是比丘作是语已出居士舍。见一比丘语言。汝小住此中。彼比丘言。住此何为。答汝但住莫问。是比丘留彼比丘已便去。居士出便见彼比丘住所期处。语言。善哉善哉我事得成。彼比丘言。得成何事。居士答言。何用问为。此是期处。先比丘生疑。我将无得僧伽婆尸沙耶。是事白佛。佛言。不得僧伽婆尸沙。得偷兰遮。有比丘。常入出一家。是比丘一时中前着衣持钵到居士舍。居士与坐处坐已共相问讯。居士小默然已语比丘言。汝能语某甲女来不。答言能。比丘往语女人。女人言。我不须是事。比丘生疑。我将无得僧伽婆尸沙耶。是事白佛。佛言。不得僧伽婆尸沙。得偷兰遮。有夫妇。相嗔不和合。有一比丘。常入出其家。是比丘中前着衣持钵到其舍。与坐处坐已共相问讯。是比丘令二人忏悔。是二人忏悔已和合行欲。比丘生疑。我将无得僧伽婆尸沙耶。是事白佛。佛言人有三种妇。一用财得。二礼法得。三破坏得。是三种妇。若作券言非我妇。礼法未断犹故出入。未唱言非我妇。比丘和合是妇。得偷兰遮。是三种妇。若作券言非我妇。礼法已断不复出入。而未唱言非我妇。尔时比丘和合。得偷兰遮。是三种妇。若已作券言非我妇。礼法已断不复出入。已唱言非我妇。尔时比丘媒合。得僧伽婆尸沙。一比丘常入出一家。是比丘中前着衣持钵到居士舍。与坐处坐已共相问讯。居士小默然已语比丘言。汝能语某甲淫女来不。比丘言。我当语。即往语是淫女来向居士。道中为余人将去。是比丘生疑。我将无得僧伽婆尸沙耶。是事白佛。佛言。不得僧伽婆尸沙。得偷兰遮。有一比丘。常入出一居士家。是比丘中前着衣持钵到居士舍。与坐处坐已共相问讯。居士小默然已语比丘言。汝能语某甲女人来不。比丘言能。即往语。是女人庄严身欲往。夫即来入。以是因缘不得去。比丘生疑。我将无得僧伽婆尸沙耶。是事白佛。佛言。不得僧伽婆尸沙。得偷兰遮。有一比丘。入出一家。是比丘中前着衣持钵到是居士舍。与坐处坐已共相问讯居士小默然已语比丘言。汝能语某甲女人来不。比丘言能。即往语。女人便许。是女人生念。我至彼必不得睡。今先睡已当往。女人睡至地了。竟不得去。比丘生疑。我将无得僧伽婆尸沙耶。是事白佛。佛言。不得僧伽婆尸沙。得偷兰遮。有一居士。贪着一女人。至此女人所言。听我作淫欲。女人答言。我今懅。居士言。我云何知汝闲时。女人言。有一比丘。常入出我舍。我遣是比丘打汝背。当知我闲。是比丘中前着衣持钵至其舍。与坐处坐已共相问讯。女人语比丘言。往打某甲居士背。比丘言。何以故。女人言。但往打莫问。比丘即往以拳打居士背。居士言。事成已。比丘言。何所成。居士言。是期事也。比丘生疑。我将无得僧伽婆尸沙耶。是事白佛。佛言。不得僧伽婆尸沙。得偷兰遮。有一比丘。常入出一家。是比丘中前着衣持钵到居士舍。与坐处坐已共相问讯。居士小默然已语比丘言。大德。能语某甲女人来不。比丘言。我等不应作使。汝急欲见者。当为众僧作会。我当请是女人来。居士即与比丘会直。比丘以是直与众僧作会。请是女人来。居士于中得共女人作淫欲。比丘生疑。我将无得僧伽婆尸沙耶。是事白佛。佛言。不得僧伽婆尸沙。得偷兰遮。有一估客妇。甚有容色。有一居士。欲共私通彼妇不从。其夫命终。有小因缘。居士不听余人出入其舍。其母问其女言。颇有方便可得使人出入不。女言有。母问。是谁。答彼居士为我故数数遣信。欲共我通。我不从。母言。汝可从其意。以汝故令多人得乐。女言。当使谁语。母言。可使常入出比丘语。有一比丘。常入出其家。中前着衣持钵入其舍。与坐处坐已。共相问讯已问言。大德。能语某甲居士如是如是事不。答言能。即往语。居士便往。比丘生疑。我将无得僧伽婆尸沙耶。是事白佛。佛言。不得僧伽婆尸沙。得偷兰遮。有一居士。作僧坊。常供给是处衣被饮食汤药资生所须。是居士后少时便死。更无人供给是处衣被饮食汤药资生所须。有一比丘。到是居士妇边语言。汝何以不供给是处众僧衣被饮食汤药资生所须。居士妇言。大德。是居士福德勇健。本所供给皆是其力。大德。汝若能令某甲居士此间处分作务。若尔可得供给。比丘即到彼居士边语言。汝能与某甲居士妇。在外处分作务不。彼居士言。我家自多事处分不遍。比丘言。为受为供养塔僧人故。是居士信佛法僧故便言。能。是居士常入出。与居士妇和合。比丘生疑。我将无得僧伽婆尸沙耶。是事白佛。佛言。无罪。有一居士。作僧房。常供给是处衣被饮食汤药资生所须。是居士妇死。更无有人供给是处衣被饮食汤药资生所须。有一比丘。到居士所语言。汝何以不复供给僧房中诸比丘衣被饮食汤药资生所须。居士言。大德是妇有大福德。本所供给皆是其力。汝若能令某甲居士妇修理我家内事处分者。可得供给。比丘即到居士妇边语言。汝能与某甲居士。在内修理家事不。居士妇言。大德。我家中自多事务。处分不遍。比丘言。为受为供养塔僧人故。是居士妇信佛法僧故。便言能。是妇常入出故。与居士共和合。比丘生疑。我将无得僧伽婆尸沙耶。是事白佛。佛言。无罪。有一比丘。常入出一家。是比丘中前着衣持钵到居士舍。与坐处坐共相问讯。小默然已。居士语比丘言。大德。汝能语某甲女人来不。答言能。即往语彼女人。居士及彼女人俱时得病。不得和合。比丘生疑。我将无得僧伽婆尸沙耶。是事白佛。佛言。不得僧伽婆尸沙。得偷兰遮。有一比丘。常入出一家。是一比丘中前着衣持钵入是舍。舍主妇人与坐处坐。共相问讯小默然已。妇人语比丘言。大德。汝能语某甲居士来不。答言能。即往语妇人及居士俱得病。不得和合。比丘生疑。我将无得僧伽婆尸沙耶。是事白佛。佛言。不得僧伽婆尸沙。得偷兰遮。有比丘。常入出一家。是比丘中前着衣持钵入是舍。居士与坐处坐。共相问讯小默然已。语比丘言。大德。汝能为我儿故。语某甲居士。与我儿若姊若妹若女不。答言能。便往语是居士儿及彼女俱时得病。脊偻狂发更嫡余人。是比丘生疑。我将无得僧伽婆尸沙耶。是事白佛。佛言。不得僧伽婆尸沙。得偷兰遮。比丘问佛。如人有可信语优婆塞。非人亦当有耶。佛言有。得道天是。又问。人女有可信语优婆夷。非人女亦当有耶。佛言有。得道天女是。比丘语余人。我能虚空中结加趺坐。是比丘空无是事。得波罗夷。又言。我能变一身为多身。多身还为一身。我以智慧。若现事不现事。皆能通达。墙壁山树能过无碍。出没地中如出入云。履水如地凌虚如鸟。是日月有大威德。我能不动以手摩扪。乃至梵世往来。自在。是事若空无实。得波罗夷。比丘问佛。颇有比丘作不净衣着不得波逸提耶。佛言有。若衣经净纬不净。纬净经不净。若二俱不净。不净者。若骆驼毛牛毛羖羊毛若杂织。着如是不净衣。得突吉罗。问毗尼中说。比丘不应畜长发。若头上有疮。当云何。佛言。以剪刀剪却。问比丘得净食。以疑心啖。作是念。此食为净为不净。得何罪耶。佛言。得突吉罗。问颇有比丘为女人说法。过五六语不得波逸提耶。佛言有。若作书若手示相若遣使与天女龙女夜叉饿鬼女毗舍遮女鸠槃荼女罗刹女说法过五六语。得突吉罗。问颇有比丘过第三重覆舍不得波逸提耶。佛言有。若先作舍以板随意覆。问颇有比丘与女人期共道行不得波逸提耶。佛言有。比丘与天女期共道行。若龙女夜叉女饿鬼女毗舍遮女鸠槃荼女罗刹女期共道行。得突吉罗。问云何漱口。佛言。以水着口中三回转。是名漱口。问颇有比丘别众食不得波逸提耶。佛言有。若虚空中食是。问颇比丘啖食得波罗夷耶。佛言有。若以盗心食是。问颇有比丘食家中坐不得波逸提耶。佛言有。若女人受一日戒。男子不受。是家中坐。得突吉罗。若男子受一日戒。女人不受。是家中坐。亦得突吉罗。若二俱受一日戒。是家中坐无罪。问颇比丘食家中。独与一女人共坐不得波逸提耶。佛言有。若女人受一日戒。男子不受。是中坐。得突吉罗。若男子受一日戒。女人不受。是中坐。得突吉罗。若二俱受不犯。问颇比丘往观军发行不得波逸提耶。佛言有。若往观夜叉军。得突吉罗。问颇有比丘。语余比丘言。共我去至诸家。当与汝多美饮食。是比丘后时语彼比丘。我不喜与汝若坐若语。我独坐独语乐。不得波逸提耶。佛言有。若未至他舍。里巷中语令还。得突吉罗。若僧坊中语无罪。问颇有比丘。无病入白衣舍。从非亲里比丘尼。自手受饮食。不得波罗提提舍尼耶。答曰有。若比丘尼自持饮食。就白衣舍与比丘。自手受无罪。问颇比丘尼约敕白衣。与如是饭如是羹比丘食。不得波罗提提舍尼耶。答曰有。若比丘尼。是比丘亲里。劝与食。比丘不呵而食。得突吉罗(五段竟)

十诵律卷第五十九十诵律卷第六十(善诵毗尼序卷上)

        东晋罽宾三藏卑摩罗叉续译

    五百比丘结集三藏法品第一

佛婆伽婆。在拘尸城娑罗双树间力士住处般涅槃。拘尸诸力士供养佛身。是时长老摩诃迦叶。将五百比丘。从波婆城。欲到拘尸城。二城中间。尔时有梵志。持天曼陀罗华。发拘尸城。欲诣波婆城。长老摩诃迦叶问。汝识我大师不。答言识。汝大师娑罗双树间力士住处般涅槃。今已七日。诸天世人供养佛身。我从彼得此天曼陀罗华来。摩诃迦叶不乐。诸弟子中有大忧愁者。有举手哭者。有躄地者。皆言。佛取涅槃一何驶哉。世间眼灭。诸比丘有宛转地者。有心中愁戚者。有行舍心观诸法相者。所谓一切无常苦空无我。此无常相法。何可得常。佛在时常说。一切众生所可乐着不可久保。皆当别离散坏磨灭。尔时有一愚痴不善不及老比丘。发此恶言。彼长老常言。应当行是不应行是。我今快得自在。所欲便作。不欲便止。如是粗言。唯迦叶独闻。余无知者。是诸天神力所隐蔽故。尔时阎浮提中。长老阿若憍陈如第一上座。长老均陀第二上座。长老十力迦叶阿难和上第三上座。长老摩诃迦叶第四上座。摩诃迦叶多知广识。四部众尽皆恭敬信受其语。四部众闻摩诃迦叶从波婆城来欲诣拘尸城。四部众皆出到半道。奉迎摩诃迦叶。摩诃迦叶见四部众来。于道外树下。敷尼师檀结加趺坐。四众既到。头面敬礼。在一面听其说法。时大迦叶说种种法。示教利喜竟。发遣四众。还至双树顶结支夷。大迦叶言。我正尔当到。莫燃佛[卄/積]。我欲礼佛全身。尔时大迦叶。与大众俱到顶结支夷。到已天为开发金棺解撤缠裹。时大迦叶稽首敬礼佛身。四部大众亦得礼拜。又告诸人言。更以天新绵[疊*毛]。好缠佛身以新香油。灌满金棺。安措佛身而阖棺盖。更积一切众香杂薪。以为大[卄/積]。大迦叶告诸力士。汝自知时。诸力士主即燃香薪大[卄/積]。尔时长老阿难见薪[卄/積]然。悲恼哽塞即说偈言

  世尊此身　　乃至梵天　　今在金棺
  以千[疊*毛]缠　　灌以香油　　燃以香薪

尔时佛[卄/積]燃尽。大迦叶思惟言。当云何灭火。即念应以牛乳灭之。尔时大迦叶适生此念。四边自然有牛乳池。净洁香好。是时大迦叶。即取此乳以灭是火而说偈言

  千[疊*毛]缠佛身　　以火阇维之
  佛之神力故　　常一内衣在
  最外亦不烧　　中者皆燃尽

尔时长老摩诃迦叶。以成治[疊*毛]。取佛舍利。与诸力士。诸力士从长老摩诃迦叶。取佛舍利。盛以金瓶。举着车上。烧种种香。持诸幡盖作诸妓乐入拘尸城。尔时拘尸城中有新论义堂。扫洒清净香洁无量。悬缯幡盖散诸杂华。敷象牙床。以佛舍利金瓶着上。阿难先以花香伎乐种种供养。亦教诸比丘比丘尼优婆塞优婆夷供养礼拜。尔时波婆城中诸力士闻。佛在拘尸城般涅槃。念言。佛亦是我师。我之所尊。来从诸人请舍利分。欲于波婆城中起塔。烧香悬缯幡盖。尽世供养。拘尸城诸力士答言。佛在我国般涅槃。我自起塔香华供养。舍利分不可得。时遮勒国诸刹帝利姓。婆蹉婆罗。罗摩聚落拘楼罗种。毗[少/兔]国中诸婆罗门。毗耶离国诸梨昌种。迦毗罗婆国诸释子。摩伽陀国主阿阇世王。韦提希子。闻佛于拘尸城般涅槃。今众人以香华伎乐供养舍利。尔时阿阇世王。敕其大臣婆罗门婆利沙迦罗言。汝往到拘尸城诸力士所。持我言致问无量。气力安隐身心乐不。又语诸人。佛亦我师我之所尊。今于汝国般涅槃。请分舍利。欲于王舍城中起塔供养。与我者善。若不见与。当举兵众以力夺汝。受敕即严四种兵。直至拘尸城。语诸力士言。摩伽陀国主。阿阇世王致问无量。气力安隐身心乐不。又言。佛亦我师我之所尊。在此般涅槃。来请舍利分。汝当与我。我于王舍城起塔供养。拘尸城诸力士答大臣婆罗门言。佛在我国土地般涅槃。我自于此拘尸城起塔供养。舍利分不得与汝。大臣婆罗门言。摩伽陀国主阿阇世王语汝。汝等以舍利与我者善。若不见与。当举四兵以力夺汝。诸力士言。我自供养不以与汝。波婆城力士亦集四兵。在一面住。罗婆聚落拘婆罗。亦集四兵在一面住。遮勒国诸刹帝利。亦集四兵在一面住。毗[少/兔]国诸婆罗门。亦集四兵在一面住。毗耶离国诸梨昌。亦集四兵在一面住。迦毗罗婆诸释子。亦集四兵在一面住。婆罗沙迦罗婆罗门。更增四兵。拘尸城一面住。尔时拘尸城外。八军围绕。为舍利故。各欲夺取。尔时大众中。有一婆罗门姓烟。在八军中。高声大唱。拘尸城诸力士主听。佛无量劫积善修忍。诸君亦常闻赞忍法。今日何可于佛灭后为舍利故起兵相夺。诸君当知此非敬事。舍利现在。但当分作八分。诸力士言。敬如来议。尔时姓烟婆罗门。即分舍利作八分。分竟复高声大唱。汝诸力士主听盛舍利瓶。请以见惠。欲还头那罗聚落起瓶塔。华香幡盖伎乐供养。诸力士答言。敬从来请。尔时必波罗延那婆罗门居士。复以高声大唱。拘尸城中诸力士主听。烧佛处炭与我。欲还我国起炭塔。华香伎乐供养。诸力士答婆罗门。敬从来请。尔时拘尸城诸力士。得第一分舍利。即于国中起塔。华香伎乐种种供养。波婆国得第二分舍利。还归起塔种种供养。罗摩聚落拘楼罗。得第三分舍利。还归起塔种种供养。遮勒国诸刹帝利。得第四分舍利。还国起塔种种供养毗[少/兔]诸婆罗门。得第五分舍利。还国起塔种种供养。毗耶离国诸梨昌种。得第六分舍利。还国起塔种种供养。迦毗罗婆国诸释子。得第七分舍利。还国起塔华香供养。摩伽陀国主阿阇世王。得第八分舍利。还王舍城起塔华香供养。姓烟婆罗门。得盛舍利瓶。还头那罗聚落。起塔华香供养。必波罗延那婆罗门居士。得炭还国起塔供养。尔时阎浮提中。八舍利塔第九瓶塔第十炭塔。佛初般涅槃后起十塔。自是已后起无量塔

尔时长老摩诃迦叶。知佛舍利流布十方白衣起塔。以是因缘故集僧。集僧竟。语诸比丘。我昔时从波婆城。将五百比丘。向拘尸城。于二城中间。见一梵志持天曼陀罗华。从拘尸城来。欲诣波婆城。我问梵志言。优婆伽从何所来。欲至何所。梵志答言。我从拘尸城来。欲到波婆城。问识我大师不。梵志答言识。汝大师娑罗双树间般涅槃。今已七日。诸天世人供养舍利。我从彼得此天曼陀罗华。我尔时心不乐。作是言。佛取涅槃一何驶哉世间眼灭。诸比丘中有大忧愁者。有举手哭者。有躄地者。皆言佛取涅槃一何驶哉。世间眼灭。诸比丘有宛转地者。有愁戚者。有行舍心观诸法相者。一切无常苦空无我。此无常法相。何可得常。佛在时自言。一切众生所可乐着。难得久保皆当别离散坏磨灭。尔时有一顽愚不善及老比丘。出恶口言。彼长老常言。应当行是不应行是。我今得自在。所欲便作不欲便止。是愚痴比丘作是语时。唯我独闻余无知者。是诸天神力之所隐蔽。复有一比丘。在我前说。法言非法。非法言法。善言不善。不善言善。我等今应当集一切修妒路。一切毗尼。一切阿毗昙。摩诃迦叶自思惟。我当僧中集一切修妒路。一切毗尼。一切阿毗昙。或有无知比丘。作如是言。不应如是集一切修妒路。一切毗尼。一切阿毗昙。我等今当于僧中。择取聪明能集法人。僧中作羯磨取。尔时长老摩诃迦叶。僧中取五百少一比丘。一一称字。是诸比丘。皆读三藏得三明灭三毒。皆得共解脱。摩诃迦叶僧中唱。大德僧听。是五百少一比丘。称名字。皆读三藏得三明灭三毒。皆得共解脱。若僧时到僧忍听。是五百少一比丘。皆是集法人。如是白。尔时长老阿难在僧中。长老大迦叶思惟。是阿难好善学人。佛说阿难于多闻人中最第一。我等今当使阿难作集法人。长老大迦叶思惟已。僧中唱。大德僧听。是阿难好善学人。佛说阿难多闻人中最第一。若僧时到僧忍听。我等今当使阿难作集法人。如是白。大德僧听。是阿难好善学人。佛说阿难于多闻人中最第一。我等今当使阿难作集法人。谁诸长老忍阿难作集法人者默然。谁不忍是长老说僧已。忍听长老阿难作集法人竟。僧忍默然故。是事如是持。长老大迦叶复思惟。今集一切修妒路。一切毗尼。一切阿毗昙。是事多非一日二日乃至七日可竟。今僧中当作羯磨。能作集法人。共一处安居。不作羯磨人。不得共一处安居。如是思惟竟。长老摩诃迦叶。僧中唱。大德僧听。今集法多非一日二日乃至七日可竟。今僧中作羯磨。能集法人共一处安居。不作羯磨人。不得共一处安居。如是白。尔时长老摩诃迦叶。复作是念。何处国土安隐。有好精舍。四事供养饮食无乏。无诸寇贼。即念王舍城中。四事供养具足无乏。国土安隐无诸贼寇。我等今当往到王舍城安居。如是思惟已。摩诃迦叶独身先往治精舍。泥涂壁孔治土埵。敷床洒扫抖擞被褥教备药具饮食衣被。摩诃迦叶知安居时到。共五百比丘。王舍城安居。摩诃迦叶清旦着衣持钵。入王舍城。教化诸人。持饮食供养集法人教已。摩诃迦叶自行乞食食竟。出城还至精舍。以是因缘集僧。集僧已思惟。何等比丘能诵毗尼明了。我等难问能随问答。当从此人集毗尼。即念优波离比丘。佛常赞诵毗尼。比丘中明了第一。念已白僧。佛常赞优波离比丘。于诵毗尼。比丘中明了第一。优波离比丘。我等问难能随问答。尔时摩诃迦叶。为敷法座。优波离比丘升高座坐竟。摩诃迦叶问优波离。初波罗夷因缘从何处出。优波离答言。初波罗夷。从毗耶离国须提那比丘迦兰陀子出。是中云何犯云何不犯。尔时优波离广说犯不犯相。摩诃迦叶。问阿若憍陈如。尔不答言尔。如优波离所说。摩诃迦叶问阿若憍陈如竟。次问长老均陀。次问十力迦叶。次第问五百阿罗汉。乃至阿难。阿难答言。我亦如是闻。是事是法是善。如长老优波离所说。阿难问摩诃迦叶。尔不。答言尔。是中长老。摩诃迦叶。僧中高声大唱。大德僧听。初波罗夷法集竟。是法是毗尼是佛教。无有比丘言是法言非法。非法言是法。是毗尼言非毗尼。非毗尼言是毗尼。是法是毗尼是佛教。僧忍默然故。是事如是持。摩诃迦叶复问长老优波离。第二波罗夷因缘。从何处出。优波离答。王舍城中。为达尼迦比丘瓦师子。第三波罗夷因缘何处出。优波离答。跋耆国中。为婆求摩题河边住诸比丘。第四波罗夷因缘何处出。答言毗耶离国。为婆求摩题河边住诸比丘。第一僧伽婆尸沙因缘何处出。答言舍婆提国。为迦留陀夷比丘。第二第三第四。皆为舍婆提国迦留陀夷比丘。第五僧伽婆尸沙因缘何处出。答舍婆提国中。为迦罗比丘弥梨迦子。摩诃迦叶复问。云何犯云何不犯。优波离。广说犯不犯相。摩诃迦叶问优波离竟。次问阿若憍陈如。尔不。阿若憍陈如答言。长老大迦叶。我亦如是知。如优波离所说。次问长老均陀。次问十力迦叶。次第问五百阿罗汉。乃至阿难。阿难答言。长老大迦叶。我亦如是知。如长老优波离所说。阿难问摩诃迦叶。如优波离所说不。答言阿难我亦如是知。如优波离所说。如是次第一切毗尼集竟。尔时长老大迦叶。僧中高声大唱。大德僧听。如是一切毗尼法集竟。是法是毗尼是佛教。无有比丘言。是法言非法。非法言是法。是毗尼言非毗尼。非毗尼言是毗尼。是法是毗尼是佛教。僧忍默然故。是事如是持。长老摩诃迦叶思惟。何等比丘诵修妒路阿毗昙明了。我等难问能随问答。我等当从此人。集修妒路阿毗昙。即时作是念。佛赞阿难比丘。于诸多闻比丘中最第一。持一切修妒路一切阿毗昙。迦叶思惟竟。僧中唱。大德僧听。是阿难比丘好善学人。佛常赞阿难比丘。于诸多闻中最第一。我等从是人。了了问修妒路阿毗昙集。如是白。尔时摩诃迦叶。敷好高座。阿难升高座坐竟。摩诃迦叶问阿难。佛修妒路初从何处说。阿难答如是我闻。一时佛在波罗柰仙人住处鹿林中。阿难说此语时。五百比丘皆下地胡跪。涕零而言。我从佛所面受见法。而今已闻。摩诃迦叶语阿难。从今日一切修妒路。一切毗尼。一切阿毗昙。初皆称如是我闻一时。阿难言尔。是时佛告五比丘。是苦圣谛。我先不从他闻法。中正忆念时。于诸法中。生眼生智生明生觉。是集圣谛。是尽圣谛。是道圣谛。我先不从他闻法。中正忆念时。于诸法中。生眼生智生明生觉。诸比丘是苦圣谛知故应知。我先不从他闻法。中正忆念时于诸法中。生眼生智生明生觉。是苦集圣谛知已应断。是苦灭圣谛知已应证。是苦灭道圣谛知已应修。我先不从他闻法。中正忆念时。于诸法中。生眼生智生明生觉。诸比丘是苦圣谛知故知已。我先不从他闻法。中正忆念时。于诸法中。生眼生智生明生觉。是苦集圣谛知故断已。是苦灭圣谛知故证已。是苦灭道圣谛知故修已。我先不从他闻法。中正忆念时。于诸法中。生眼生智生明生觉。诸比丘若我随尔许时。四圣谛中。三转十二分法轮行。不生眼智明觉。我于一切世间。若魔若梵及沙门婆罗门天人等众中。不得解不得离不得舍。亦不得不颠倒心。是时我亦不作是念。得阿耨多罗三藐三菩提。以我尔许时。四圣谛中。三转十二分法轮行。生眼智明觉。我于一切世间。若魔若梵及沙门婆罗门天人等众中。得解得离得舍。得不颠倒心。是时我作是念。得阿耨多罗三藐三菩提。说是法时。长老憍陈如。及八万诸天。远尘离垢诸法中法眼生。尔时佛告憍陈如。得法已不。憍陈如言。得已。世尊憍陈如得法已不。憍陈如言得已。世尊憍陈如得法已不。憍陈如言得已。世尊憍陈如。以初得故。故名阿若憍陈如。阿若憍陈如得法已。是时地神高声大声唱言。诸众生佛在波罗奈国仙人住处鹿林中。三转十二分法轮。诸余沙门若波罗门。若天若魔若梵。如是等一切世间中。不能如法转。为饶益众生故。安乐多众生。怜愍世间故。利益安乐诸天人。增益诸天种。减损阿修罗众。虚空中神。闻地神唱声已。亦高声大声唱。佛转法轮。四天王闻虚空神唱。亦高声大声唱。三十三天夜摩天兜率陀天化乐天他化自在天。即时唱声。乃到梵天处。皆高声大声唱言。诸众生佛在波罗奈国仙人住处鹿林中。三转十二行法轮。诸余沙门若婆罗门。若天若魔若梵。如是等一切世间中。不能如法转。为饶益多众生故。安乐多众生怜愍世间故。利益安乐诸天人。增益诸天种。减损阿修罗众。佛在波罗奈国仙人住处鹿林中。三转十二行法轮已。是故是经名转法轮经。大迦叶问阿若憍陈如。如阿难所说尔不。答言尔。长老大迦叶。我亦如是知。如阿难所说。次问长老均陀。次问十力迦叶。乃至次第问五百阿罗汉。末后问优波离。如阿难所说不。答言尔。长老优波离。问摩诃迦叶。如阿难所说不。答言尔。长老优波离我亦如是知。如阿难所说。如是展转问已。一切修妒路藏集竟。尔时摩诃迦叶。僧中唱大德僧听。一切修妒路集竟。是法是毗尼是佛教。无有比丘言。是法言非法。非法言是法。是毗尼言非毗尼。非毗尼言是毗尼。是法是毗尼是佛教。僧忍默然故。是事如是持。长老摩诃迦叶。复问阿难。佛何处始说阿毗昙。阿难答言。如是我闻。一时佛在舍婆提。尔时佛告诸比丘。若人五怖五罪五怨五灭。是人五怖罪怨故。死后譬如力士屈伸臂顷。堕于地狱。何等五。一者杀。二者偷。三者邪淫。四者妄语。五者饮酒。若人五怖五罪五怨五灭。是人五怖罪怨灭故。死后譬如力士屈伸臂顷。生于天上。何等五。一者不杀怖罪怨灭。不偷不邪淫不妄语不饮酒。亦如是怖罪怨灭。长老摩诃迦叶。问阿若憍陈如。如阿难所说不。答言。长老大迦叶。我亦如是知。如阿难所说。次问长老均陀。次问十力迦叶。乃至次第问五百阿罗汉。末后问优波离。如阿难所说不。答言。长老大迦叶。我亦如是知。如阿难所说。长老优波离。问摩诃迦叶。尔不。答言实尔。如是一切阿毗昙集已。尔时摩诃迦叶。僧中大唱大德僧听。一切阿毗昙集竟。是法是毗尼是佛教。无有比丘言。是法言非法。非法言是法。是毗尼言非毗尼。非毗尼言是毗尼。是法是毗尼是佛教。僧忍默然故。是事如是持。尔时一切修妒路。一切阿毗昙。一切毗尼集竟。长老阿难。偏袒右肩长跪叉手。白大德摩诃迦叶。我面从佛闻受是语。佛言。我般涅槃后。若僧一心和合。筹量放舍微细戒。摩诃迦叶答。阿难。汝从佛问不。何名微细戒。一心和合放舍。阿难答。大德不问。迦叶言。汝应当了了问。何名微细戒。僧一心和合而放舍此戒。长老阿难。汝若不问佛。汝得突吉罗罪。是罪汝当如法忏悔。莫覆藏。阿难答言。我不轻戒故不问。是时佛欲灭度。我心愁闷故不问。摩诃迦叶语阿难。佛三语汝。阎浮提地种种事。乐寿命最快。若人有修四如意足。能住寿一劫。若减一劫。阿难佛四如意足善修。若欲住寿一劫。若减一劫。自在能住。汝何以不请佛久住。以是事故。汝得突吉罗罪是罪汝当如法忏悔。莫覆藏。阿难答。我不轻戒。非不敬佛故不请久住。是时魔蔽我心。不自觉知是故不即请佛久住。大迦叶复语阿难。汝以足蹑佛衣。得突吉罗。是罪如法忏悔。阿难答言。我不轻戒。非不敬佛。是时大风卒起。更无余人。我襞佛衣。以是故足蹑。大迦叶复语阿难。佛语汝。迦拘陀河取一钵水。汝言迦拘陀河水浊未清。不即取水。以是事故。汝得突吉罗是罪如法忏悔。阿难答言。我不轻戒。非不敬佛。时五百乘车濿渡未久。水浊水清。以是故不即取水与佛。大迦叶复语阿难。佛不听女人出家。汝乃至三请。令女人出家。以是事故得突吉罗是罪如法忏悔。阿难答言。我不轻戒。非不敬佛。但以过去诸佛。皆有四众。今我世尊云何独无四众。是故乃至三请。大迦叶复语阿难。佛灭度后。汝何以出佛阴藏相。以示女人。以是事故。汝得突吉罗。是罪如法忏悔。阿难答言。是女人福德浅薄。欲得见佛相。见已厌离女身。后得男子形。以是故示

尔时大迦叶。令长老阿难六突吉罗罪。僧中悔过。长老摩诃迦叶。集僧言。我等不听放舍微细戒。何以故。外道异学若闻是事。便言弟子聪明。所以者何。师结戒弟子放舍。以是故。我等一心集会筹量。不听舍微细戒。外道异学有如是言。大师在时释子沙门皆具持戒。师灭度后不能具持戒。便还放舍。释子法灭不久。譬如燃火烟出。火灭烟止。以是故。我等一心集会筹量。不听舍微细戒。若我等听放舍微细戒者。诸比丘。不知何者是微细戒。或如是言微细戒非独是突吉罗。更有四波罗提提舍尼。亦名微细戒。以是故。我等不听舍微细戒。若我等一心集会。听舍微细戒者。或有比丘。不知何者是微细戒。作如是言。非独突吉罗。四波罗提提舍尼。九十波夜提。亦名微细戒。以是故。我等一心集会。不听放舍微细戒。若我等一心集会。听舍微细戒者。或有诸比丘。不知何者是微细戒。如是言。非独突吉罗。四波罗提提舍尼。九十波夜提。是微细戒。三十尼萨耆波夜提。亦名微细戒。以是故我等不听舍微细戒。若我等一心集会。听舍微细戒者。或有诸比丘。不知何者是微细戒。作如是言。非独突吉罗。四波罗提提舍尼。九十波夜提。三十尼萨耆波夜提。二不定法亦名微细戒。以是故。我等不听舍微细戒。若我等一心集会筹量听舍微细戒者。或有比丘不知何者是微细戒。作如是言。微细戒非独是突吉罗。四波罗提提舍尼。九十波夜提。三十尼萨耆波夜提。二不定法。十三僧伽婆尸沙。亦名微细戒。以是故。我等不听舍微细戒。若我等一心集会筹量。听舍微细戒者。或有比丘作如是言。我受持四戒余残戒放舍。以是故。我等一心集会筹量。不听舍微细戒。我等随佛结戒。若佛结戒一切受持。佛经中说摩伽陀国中大臣婆罗沙迦婆罗门因缘。七不灭法中。若诸比丘佛不结戒不结。已结戒不舍。如说戒受持。诸比丘善法增益不灭。以是故。我等尽当受持不应放舍(三藏集法品竟)

    七百比丘集灭恶法品第二之上

佛般涅槃后一百一十岁。毗耶离国十事出。是十事非法非善。远离佛法。不入修妒路。不入毗尼。亦破法相。是十事。毗耶离国诸比丘。用是法行是法言是法清净。如是受持。何等十事。一者盐净。二者指净。三者近聚落净。四者生和合净。五者如是净。六者证知净。七者贫住处净。八者行法净。九者缕边不益尼师檀净。十者金银宝物净。毗耶离诸比丘。又持憍萨罗国大金钵。出憍萨罗国。入毗耶离国。次第乞钱。随多少皆着钵中。时人或以万钱。或千五百五十乃至以一钱。悉着钵中。是时有长老耶舍陀迦兰提子。毗耶离住。得三明持三藏法。修妒路毗尼阿毗昙。耶舍陀是长老阿难弟子。耶舍陀闻毗耶离国十事出已。非法非善远离佛法。不入修妒路。不入毗尼。亦破法相。是十事。毗耶离国诸比丘。用是法行是法言是法清净。如是受持。何等十。一者盐净乃至金银宝物净。毗耶离国诸比丘。又持憍萨罗大金钵。出憍萨罗国。入毗耶离国。次第乞钱。随多少皆着金钵中。时人或以万钱。千五百五十一钱着钵中。长老耶舍陀闻是事已。知是事作非法。遣使诣毗耶离诸白衣所。语言。沙门释子不应乞金银宝物畜。佛种种因缘为摩尼周罗聚落主说法。从今日比丘。须薪乞薪。须草乞草。须乘借乘。须作人借作人。沙门释子。是中佛不听乞金银宝物畜。毗耶离国诸比丘。闻耶舍陀遣使诣毗耶离诸白衣所言。沙门释子不应乞金银宝物畜。佛种种因缘为摩尼周罗聚落主说法。从今日诸比丘。须薪乞薪。须草乞草。须乘借乘。须作人借作人。沙门释子乃至佛不听乞金银宝物畜。闻已集会。所有金银宝物当分。是中有比丘。自取分持出。或使沙弥白衣持去。或着床上持去。或着靴中持去。或衣裹持去。或遣使持分与耶舍陀。耶舍陀即还遣使此不净物。何以教。我受。沙门释子不应受此不净物。佛种种因缘说法从今日比丘。须薪草应乞。须车乘作人应借。金银宝物不听受畜。毗耶离比丘思惟言。耶舍陀于诸白衣前出我等罪。我等当与耶舍陀作下意羯磨。令向毗耶离诸白衣忏悔。思惟已集僧。与耶舍陀作下意羯磨。令向毗耶离诸白衣忏悔。耶舍陀闻毗耶离诸比丘作下意羯磨令向毗耶离诸白衣忏悔。闻已如是思惟。我向诸白衣忏悔时。能事事说法。使诸白衣得信言。佛种种因缘为摩尼周罗聚落主说因缘。乃至沙门释子。不应乞金银宝物畜。尔时耶舍陀。明日食时着衣持钵。入毗耶离城乞食。食已到毗耶离诸白衣所忏悔时。事事说法使诸白衣得信言。佛种种因缘为摩尼周罗说。比丘须薪草应乞。车乘作人应借。不应乞金银宝物畜。如是长老耶舍陀事事说法。诸白衣即得信解。知沙门释子不应乞金银宝物畜毗耶离诸比丘闻。长老耶舍陀。向毗耶离白衣忏悔时。事事说法使白衣信解。知佛种种因缘说。比丘须薪草应乞。车乘作人应借。不应乞金银宝物畜。闻已如是思惟。我等不应令耶舍陀是中住。今当作出羯磨。汝不应毗耶离住。如是思惟已集僧。与耶舍陀作出羯磨。不得毗耶离住。长老耶舍陀闻。毗耶离诸比丘作出羯磨。不得住毗耶离。闻已还房付授卧具。持衣钵发毗耶离去。未远自念。我于毗耶离诸比丘边得脱。是诸比丘畜金银宝物。多欲多求恶法成就。耶含陀住憍萨罗国夏安居。尔时长老三菩伽。住摩偷罗国僧伽遮僧伽蓝精舍阿波大罗林中乌头婆罗树下。是三菩伽。持三藏得三明。有名称大阿罗汉。长老阿难弟子。长老耶舍陀闻。长老三菩伽。住摩偷罗国僧伽遮僧伽蓝阿波大罗林中乌头波罗树下。持三藏得三明。有名称大阿罗汉。闻已遣使诣三菩伽言。长老知不。毗耶离国有十事出。非法非善远离佛法。不入修妒路。不入毗尼。亦破法相。毗耶离诸比丘。用是法行是法。言是法清净。如是受持。何等十。一者盐净。二者指净。三者近聚落净。四者生和合净。五者如是净。六者证知净。七者贫住处净。八者行法净。九者缕边不益尼师檀净。十者金银宝物净。毗耶离国诸比丘。又持憍萨罗大金钵。出憍萨罗国。入毗耶离国。乞钱次第乞。随多少皆着钵中。或得万钱千五百五十乃至一钱。诸长老比丘。应集会灭是恶法。今若不灭后必将大。长老三菩伽闻是事已。即遣使诣达嚫那国阿槃提国。如是诸国皆遣使语言。汝知不。毗耶离国十事出。何等十。一者盐净乃至金银宝物净。是诸恶法。今若不灭后将必大。尔时达嚫那国阿槃提国等诸比丘。即皆集会毗耶离。是时长老梨婆多。住萨寒若国。持三藏得三明。有名称大阿罗汉。好行四无量心。是长老阿难弟子。长老三菩伽闻。长老梨婆多住萨寒若国。持三藏得三明。有名称大阿罗汉。好行四无量心。闻已长老三菩伽如是思惟。我等以何长老为上座。当求是长老为上座摄诸比丘。作是思惟已。我等当求长老梨婆多为诸比丘说实法。尔时长老三菩伽。集诸比丘。从白衣索四事供养。索已乘舡至萨寒若国。到长老梨婆多所。长老梨婆多。遥见三菩伽来。善心起迎问讯。道路疲不。代持衣钵示房舍。语三菩伽等诸比丘。是汝床榻被褥卧具。若上座为办浴具。澡豆灰麻油薪。浴竟至夜。是时梨婆多。与三菩伽共一房宿。夜多坐禅至天明。时长老梨婆多语三菩伽。我供养客法作竟。汝从出家法。长老三菩伽闻是语竟。食时着衣持钵。入萨寒若城乞食。乞食竟食后。还梨婆多所头面礼足

尔时长老三菩伽思惟。是梨婆多大法师。或能难问我阿毗昙。我或不疾解。我今当先问梨婆多毗耶离比丘十事。即合手问。盐净应受不。梨婆多还问三菩伽。云何名盐净。大德梨婆多。毗耶离诸比丘。盐举残宿着净食中啖。言是事净。我问长老实净不。梨婆多答。不净不应食。若食得何罪。答得突吉罗罪。三菩伽又问。佛何处结戒。是事不应食。答舍婆提毗尼药法中说。三菩伽问。大德梨婆多。应受二指净不。还问。云何名二指净。答言。毗耶离诸比丘。食竟从座起。不受残食法。两指抄食啖。言是事净。我问长老实净不。梨婆多答。不净。不净得何罪。答得波逸提罪。又问佛何处结戒。是事不应行。答毗耶离国为不受残食法故结戒。三菩伽言。大德梨婆多。近聚落净实净不。还问。云何名近聚落净。答言。毗耶离诸比丘。近聚落边得食。不受残食法啖。言是事净。我问长老实净不。梨婆多答。不净。不净得何罪。答得波逸提罪。又问。佛何处说是事不应行。答毗耶离国佛为不受残食法结戒。三菩伽言。大德梨婆多。应受生和合净。实净不。还问。云何名生和合净。答言。毗耶离诸比丘。食竟从座起。不受残食法。乳酪酥共和合而啖。言是事净。我问长老实净不。答不净。不净得何罪。答得波逸提罪。又问。佛何处结戒。是事不应行。答毗耶离。佛为不受残食法结戒。三菩伽言。大德梨婆多。如是净实净不。梨婆多还问。云何名如是净。答毗耶离诸比丘。内界共住处别作羯磨竟。入僧中唱言。彼住处作羯磨。长老是事净。今我问。是事实净不。答不净。不净得何罪。答得突吉罗罪。又问。佛何处结戒。答占波国毗尼行法中。三菩伽言。大德梨婆多。证知净实净不。梨婆多还问。云何名证知净。答毗耶离诸比丘。各各住处作不如法羯磨竟。入僧中白。我等处处作羯磨。诸僧证知。言是事证知净。今我问长老实净不。答不净。不净得何罪。答得突吉罗罪。又问。佛何处结戒。答占波国毗尼行法中。三菩伽言。大德梨婆多。贫住处净实净不。梨婆多还问。云何贫住处净。答毗耶离诸比丘言。我等住处贫作酒饮。言是贫住处净。实净不。答不净。不净得何罪。答得波逸提罪。又问。佛何处结戒。答支婆提国颰陀罗婆提城。为长老婆伽陀阿罗汉结戒。不得饮酒。三菩伽言。大德梨婆多行法净实净不。梨婆多答。有行法净。行亦净。不行亦净。有行法不净。行亦不净。不行亦不净。何等行法不净。行亦不净。不行亦不净。答杀罪。行亦不净。不行亦不净。偷邪淫妄语两舌恶口绮语悭贪嗔恚邪见。行亦不净。不行亦不净。是为行法不净。行亦不净。不行亦不净。何等行法净。行亦净。不行亦净。答不杀不偷不邪淫不妄语两舌恶口绮语悭贪嗔恚邪见。是为行法净。行亦净。不行亦净。三菩伽言。大德梨婆多。不益缕边尼师檀净。实净不。还问。云何不益缕边尼师檀。答毗耶离诸比丘。作不益缕边尼师檀。言是事净。为净不。答不净。问不净得何罪。答得波逸提罪。又问。佛何处结戒。答舍婆提国。佛为长老迦留陀夷。听缕边益一搩手。尼师檀结戒。三菩伽言。大德梨婆多。金银宝物净。实净不。还问。云何金银宝物净。答毗耶离诸比丘。取金银宝物。言是事净。实净不。答不净。不净得何罪。答得波逸提罪。佛何处结戒。答毗耶离。佛为跋难陀结戒。不得取金银宝物。三菩伽言。善哉善哉。大德梨婆多。善说十事。三菩伽言。此诸比丘当云何。梨婆多答。当共勤方便灭是不善法

尔时长老沙罗。住毗耶离国。持三藏得三明。有名称大阿罗汉。是长老阿难弟子。如是思惟。我所学智。皆从和上口受诵戒。我当分别观察客比丘毗耶离比丘。如是思惟已。着衣持钵入城乞食。食后向沙树林间。入树林已。于一树下敷尼师檀坐观所诵法。知谁是。为毗耶离比丘是。为客比丘是。如是观已。知毗耶离比丘不是。知阿槃提达嚫那婆多国诸客比丘是。是树林中有神天。合手向沙罗言。如是如是长老。是毗耶离比丘非法语。诸客比丘是法语。大德沙罗。汝欲作何等。答当勤方便灭是不善法。毗耶离诸比丘闻。阿槃提达嚫那婆多国诸客比丘。勤方便欲灭是事。闻已如是思惟。我等当请何等上座为好上座故。多比丘来。上座梨婆多。我等当请。为是上座故。诸比丘当来集。如是思惟竟。毗耶离诸比丘。着衣持钵诣萨寒若国。到已见长老梨婆多。已同阿槃提达嚫那婆多国诸比丘。见已如是思惟。长老梨婆多已同彼。复作是念。诸上座弟子。我等今当软语令请。是上座当用弟子语。毗耶离诸比丘。到上座弟子所。与衣钵户钩革屣。与三种药尽与竟。诸上座弟子即觉问。是上座供养何以故与我。毗耶离诸比丘答。当语汝师。毗耶离比丘。是有法语。阿槃提达嚫那婆多国诸比丘。不是法语。一切诸佛皆出东方。长老上座。莫与毗耶离中国比丘斗诤。诸上座弟子答。此是小事。我经营之。汝等当受我恩。诸弟子即到上座梨婆多所言。阿槃提达嚫那婆多国诸比丘。非法非善。言一切诸佛皆。出东方。长老上座。莫与毗耶离中国比丘斗诤。梨婆多语弟子。汝愚痴人。我自知见毗耶离诸比丘非法非善。阿槃提达嚫那婆多国诸比丘。实是法是善语。汝愚痴人。云何教我非法非善非佛语。汝去莫来。我乃至死不用见汝。是时长老梨婆多语三菩伽。此事是间可灭。或有不知人言。此事不可是间灭。本从何处出。应还至本处灭。尔时长老梨婆多三菩伽。及阿槃提达嚫那婆多国诸比丘。随意多少。往萨寒若国。持衣钵向毗耶离国。次第行到毗耶离。毗耶离国比丘。亦持衣钵向毗耶离城。次第行到。是时长老萨婆伽罗婆梨婆罗上座。住毗耶离。持三藏得三明。有名称大阿罗汉。好行空三昧。是长老阿难弟子。长老梨婆多。到萨婆伽罗波梨婆罗上座所。是上座遥见梨婆多来。欢喜问讯。长老具醯善来具醯。久不相见具醯。到已共坐。诸上座有如是法。若客比丘来。共一处宿。告给事。汝为客比丘敷卧具。给事如是思惟。上座如是约敕。我与客比丘敷床卧具。上座必与客比丘一房宿。给事受敕已即向上座房。与客比丘敷床卧具。弟子受敕。与客比丘敷床卧具竟。还白上座言。与客比丘敷床卧具已。上座自知时。上座即从座起。向房舍自坐处。敷尼师坛结加趺坐。长老梨婆多亦向上座房。入已头面礼上座足。卧具上敷尼师坛。结加趺坐。萨婆伽罗婆梨婆罗上座。如是思惟。长老梨婆多。客来道路疲极。客比丘未卧。我不应先卧。客比丘卧竟我乃应卧。长老梨婆多亦思惟。今僧中第一上座未卧。我不应先卧。上座卧竟尔乃我卧。是夜二人俱坐禅。后夜长老第一上座问长老梨婆多。汝何以不卧。答我如是思惟。长老是僧中第一上座未卧。我不应先卧。上座卧竟尔乃我卧。上座问梨婆多。是夜心入何等三昧。答我多行慈三昧。上座言。汝长老具醯。此是小三昧行。汝夜行小三昧行。梨婆多答。此实小三昧行。我阿罗汉一切漏尽。是行长夜喜念。以是故。常行是三昧行。问上座何以不卧。上座答。我亦思惟。汝道路行极未卧。我不应先卧。汝卧竟我乃应卧。问上座是夜入何等三昧。上座答。多行空三昧。梨婆多言。此是上三昧行。汝夜行上三昧行。上座答。此实上三昧行。我阿罗汉一切漏尽。是行长夜喜念。以是故。常行是三昧。是二善人。俱得阿罗汉道出所行法。长老三菩伽。是夜过已向第一上座。头面礼足一面坐。上座问三菩伽。汝三菩伽。是事云何欲灭。答长老一切僧中上座。当知是事云何灭。汝三菩伽。今日食后集一切僧。三菩伽受上坐语竟。食时着衣持钵入毗耶离城乞食。食后一处集僧。是时毗耶离国少一比丘。不满七百集会。为灭是非法非善非佛语恶事灭故。是时有长老。名级阇苏弥罗。在婆罗梨弗国住。持三藏得三明。有名称大阿罗汉。喜用天眼。是长老阿难弟子。以天眼遥见少一比丘。不满七百。在毗耶离国集。为灭非法非善非佛语恶事故。即入三昧。如力士屈伸臂顷。于婆罗梨弗国没。毗耶离国僧住处门下出住。是级阇苏弥罗出三昧。说偈索开门

  婆罗梨弗国　　诸旧比丘中
  持律多闻人　　已断诸狐疑
  今从彼间来　　在此门下立
  婆罗梨弗国　　诸旧比丘中
  持律多闻人　　调御六情根
  今从彼间来　　在此门下立
  婆罗梨弗国　　诸旧比丘中
  持律多闻人　　级阇苏弥罗
  今从彼间来　　在此门下立

十诵律卷第六十十诵律卷第六十一(善诵毗尼序卷中)

        东晋罽宾三藏卑摩罗叉续译

    七百比丘集灭恶法品第二之余

长老级阇苏弥罗来。满七百僧。苏弥罗入僧中已。是时长老三菩伽。如是思惟。我等若在僧中灭是恶事。或有不智比丘言。是事不应如是灭。是事应如是灭。我今当僧中作羯磨。一切僧当听灭是事。长老三菩伽僧中唱。大德僧听。我等僧中灭是恶事。若有不智比丘。言是事不应如是灭是事应如是灭。我今当僧中作羯磨。一切僧当忍听灭是事。如是白。是时三菩伽。僧中唱四比丘名字。阿盘提达嚫那婆多国四客比丘。东方四旧比丘。何等阿盘提达嚫那婆多国四客比丘。一萨婆伽罗婆梨婆罗上座。二沙罗。三耶输陀。四级阇苏弥罗。是为四客比丘。何等东方四旧比丘。一上座梨婆多。二长老三菩伽。三修摩那。四萨波摩伽罗摩。是为东方四旧比丘。长老三菩伽僧中唱。大德僧听。我唱是八人名字。阿盘提达嚫那婆多四客比丘。东方四旧比丘。若僧时到僧忍听。是八人作乌回鸠罗。为断灭僧中恶事故。如是白。是时长老阿嗜多受戒五岁。善诵持毗尼藏在僧中。长老三菩伽如是思惟。是阿嗜多比丘受戒五岁。善诵持毗尼藏。在此间僧中。若我等令阿嗜多比丘依上座乌回鸠罗。灭僧中恶事。诸上座或能不喜。我等使阿嗜多依受上座作乌回鸠罗。沙树林中为诸上座作敷坐具人。三菩伽如是思惟竟。僧中唱。大德僧听。是阿嗜多比丘受戒五岁。善诵持毗尼藏。学持阿含。若僧时到僧忍听。是阿嗜多比丘依受诸上座作乌回鸠罗。沙树林中作敷坐具人。如是白。如是白二羯磨。僧听阿嗜多比丘依上座作乌回鸠罗。沙树林中与上座敷坐具竟。僧忍默然故。是事如是持。是时阿嗜多比丘。从座起至树林中。与诸上座比丘敷坐具已。还到集僧中白诸上座。大德上座我已于树林中敷坐具竟。上座自知时。诸上座从座起。向树林中敷坐具处。自敷尼师檀结加趺坐。长老三菩伽。从座起偏袒右臂合手。向上座萨婆伽罗婆梨婆罗。如是言大德。上座盐净。实净不。上座还问。云何名盐净。三菩伽言。毗耶离诸比丘。盐共宿着净食中啖。言是事净。实净不。上座答。不净不净。得何罪。答得突吉罗罪。三菩伽问。佛何处结戒。上座答。舍婆提国毗尼药法中。三菩伽问萨婆伽罗婆梨婆罗上座竟。次问上座沙罗上座耶输陀级阇苏弥罗梨婆多修摩那婆弃伽弥。问一切上座。乃至问阿嗜多。汝亦如是知。如上座答不。阿嗜多答。我亦如是知。如上座答。阿嗜多亦问三菩伽。长老亦如是知。如上座答不。三菩伽答。我亦如是知。如上座答。是时长老三菩伽僧中唱。大德僧听。今僧以灭十事中第一事已。如法如善如佛教。现前僧中灭是恶事。是中无有一比丘非法言法法言非法非善言善善言非善。是非法非善非佛教。如是不净。作是语竟行一筹。为灭一恶事故。三菩伽问上座萨婆伽罗婆梨。婆罗大德二指净。实净不。上座还问。云何名二指净。答毗耶离诸比丘。食竟从座起。不受残食法。两指抄饭食啖。言是事净。实净不。上座答。不净不净。得何罪。上座答。得波逸提罪。问佛何处结戒。答毗耶离国为不受残食法结戒。三菩伽问萨婆伽罗波梨婆罗竟。次问上座沙罗耶输陀级阇苏弥罗梨婆多修摩那婆弃伽弥。问一切上座。乃至问阿嗜多。汝亦如是知。如上座答不。阿嗜多答言。我亦如是知。如上座答。阿嗜多转问三菩伽。长老亦如是知。如上座答不。三菩伽言。我亦如是知。如上座答。是时长老三菩伽僧中唱。大德僧听。今僧以灭十事中第二事已。如法如善如佛教。现前僧中灭是恶事。是中无有一比丘非法言法法言非法非善言善善言非善。是非法非善非佛教。如是不净。作是语竟行二筹。为灭二恶事故。三菩伽问上座萨婆伽罗波梨婆罗大德。近聚落净。实净不还问云何名近聚落净。答毗耶离诸比丘。近聚落边得食。不受残食法啖。言是事净。为实净不。上座答。不净不净。得何罪。答得波逸提罪。问佛何处结戒。答毗耶离国为不受残食法故结戒。三菩伽问萨婆伽罗波梨婆罗上座竟。次问上座沙罗耶输陀级阇苏弥罗梨婆多修摩那波弃伽。问一切上座。乃至问阿嗜多。汝亦如是知。如上座答不。阿嗜多言。我亦如是知。如上座答。阿嗜多亦问三菩伽。长老亦如是知。如上座答不。三菩伽言。我亦如是知。如上座答。是时长老三菩伽僧中唱。大德僧听。今僧以灭十事中第三恶事已。如法如善如佛教。现前僧中灭是恶事。是中无有一比丘非法言法法言非法非善言善善言非善。此非法非善非佛教。如是不净。作是语竟行三筹。为灭三恶事故。三菩伽问萨婆伽罗波梨婆罗。生和合净。大德上座。是净实净不。还问。云何名生和合净。答毗耶离诸比丘。食竟从座起。生乳酪酥共和合啖。言是事净。为实净不。答不净。问不净得何罪。答得波逸提罪。问佛何处结戒。答毗耶离为不受残食法故结戒。三菩伽问萨婆伽罗波梨婆罗上座竟。次问上座沙罗耶输陀级阇苏弥罗梨婆多修摩那波弃伽弥。问一切上座。乃至问阿嗜多。汝亦如是知。如上座答不。阿嗜多言。我亦如是知。如上座答。阿嗜多还问三菩伽。长老亦如是知。如上座答不。三菩伽言。我亦如是知。如上座答。是时长老三菩伽僧中唱。大德僧听。今僧以灭十事中第四事已。如法如善如佛教。现前僧中灭是恶事。是中无有一比丘非法言法法言非法非善言善善言非善。此非法非善非佛教。如是不净。作是语竟行四筹。为灭四恶事故。三菩伽问萨婆伽罗波梨婆罗。大德上座。如是净实净不。上座还问云何名如是净。答毗耶离诸比丘。内界共住处别作羯磨。言是事净。为实净不。答不净。问不净得何罪。答得突吉罗罪。问佛何处结戒。答占波国中毗尼行法中。三菩伽问一切上座竟。乃至阿嗜多。汝亦如是知如上座答不。阿嗜多言。我亦如是知。如上座答。阿耆多转问三菩伽。长老亦如是知。如上座答不。答我亦如是知。如上座答。三菩伽僧中唱。大德僧听。今僧以灭十事中第五事已。如法如善如佛教。现前僧中灭是恶事。是中无有一比丘非法言法法言非法非善言善善言非善。此非善非法非佛教。如是不净。作是语竟行五筹。为灭五恶事故。三菩伽问萨婆伽罗波梨婆罗。大德上座。证知净实净不。上座还问。云何名证知净。答毗耶离诸比丘。各各住处作非法羯磨竟。入僧中白。我等处处作羯磨。诸僧证知。言是事证知净。为实净不。答不净。问不净得何罪。答得突吉罗罪。问佛何处结戒。答占波国毗尼行法中。三菩伽问萨婆伽罗波梨婆罗上座竟。次问一切诸上座乃至阿嗜多。汝亦如是知。如上座答不。阿嗜多言。我亦如是知。如上座答。阿嗜多转问三菩伽。长老亦如是知。如上座答不。答言。我亦如是知。如上座答。三菩伽僧中唱。大德僧听。今僧以灭十事中第六事已。如法如善如佛教。现前僧中灭是恶事。是中无有一比丘非法言法法言非法非善言善善言非善。此非法非善非佛教。如是不净。作是语竟行六筹。为灭六恶事故。三菩伽问萨婆伽罗波梨婆罗。大德上座。贫住处净实净不。上座还问。云何名贫住处净。答毗耶离诸比丘言。我等住处贫作酒饮。言是事净。为净不。答不净。问不净得何罪。答得波逸提罪。问佛何处结戒。答婆提国跋陀婆提城。为长老婆伽陀结戒。不得饮酒。三菩伽问萨婆伽罗波梨婆罗上座竟。次问一切上座。乃至阿嗜多。汝亦如是知。如上座答不。阿嗜多言。我亦如是知。如上座答。阿嗜多转问三菩伽。长老亦如是知。如上座答不。答言。我亦如是知。如上座答。三菩伽僧中唱。大德僧听。今僧以灭十事中第七事已。如法如善如佛教。现前僧中灭是恶事。是中无有一比丘非法言法。法言非法。非善言善。善言非善。此非法非善非佛教。如是不净。作是语竟行七筹。为灭七恶事故。三菩伽问萨婆伽罗波梨婆罗。大德上座。行法净实净不。答有行法净。行亦净。不行亦净。有行法不净。行亦不净。不行亦不净。何等行法不净。行亦不净。不行亦不净。答杀罪。行亦不净。不行亦不净。偷淫妄语两舌恶口绮语悭贪嗔恚邪见。行亦不净。不行亦不净。是为行法不净。行亦不净。不行亦不净。何等行法净。行亦净。不行亦净。答曰。不杀不偷不邪淫不妄语两舌恶口绮语悭贪嗔恚邪见。是为行法净。行亦净。不行亦净。三菩伽问萨婆伽罗波梨婆罗上座竟。次问一切上座。乃至阿嗜多。汝亦如是知。如上座答不。阿嗜多言。我亦如是知。如上座答。阿嗜多转问三菩伽。长老亦如是知。如上座答不。三菩伽言。我亦如是知。如上座答。三菩伽僧中唱。大德僧听。今僧以灭十事中第八事已。如法如善如佛教。现前僧中灭是恶事。是中无有一比丘非法言法法言非法非善言善善言非善。此非法非善非佛教。如是不净。作是语竟行八筹。为灭八恶事故。三菩伽问萨伽婆伽罗波梨婆罗。大德上座。不益缕边尼师檀净。实净不。还问。云何不益缕边尼师檀净。答毗耶离诸比丘。作不益缕边尼师檀。言是事净。为净不。答不净。不净得何罪。答得波逸提罪。问佛何处结戒。答舍婆提国。佛为长老迦留陀夷。听益缕边一磔手尼师檀结戒。三菩伽问萨婆伽罗波梨婆罗上座竟。次问一切上座。乃至阿嗜多。汝亦如是知。如上座答不。阿嗜多言。我亦如是知。如上座答。阿嗜多转问三菩伽。长老亦如是知。如上座答不。三菩伽言。我亦如是知。如上座答。三菩伽僧中唱。大德僧听。今僧以灭十事中第九事已。如法如善如佛教。现前僧中灭是恶事。是中无有一比丘非法言法法言非法非善言善善言非善。此非善非法非佛教。如是不净。作是语竟行九筹。为灭九恶事故。三菩伽问萨婆伽罗波梨婆罗。大德上座。金银宝物净不。还问云何金银宝物净。答毗耶离诸比丘。言金银宝物净。为净不。答不净不净。得何罪。答得波逸提罪。问佛何处结戒。答毗耶离为跋难陀释子结戒。不得取金银宝物。三菩伽问萨婆伽罗波梨婆罗上座竟。次问一切上座。乃至阿嗜多。汝亦如是知。如上座答不。阿嗜多言。我亦如是知。如上座答。阿嗜多转问三菩伽。长老亦如是知。如上座答不。三菩伽言。我亦如是知。如上座答。三菩伽僧中唱。大德僧听。今僧以灭十恶事尽。皆如法如善如佛教。现前僧中灭是恶事。是中无有一比丘非法言法法言非法非善言善善言非善。此非法非善非佛教。如是不净。作是语竟行十筹。为灭十恶事故。是时上座萨婆伽罗波梨婆罗。语长老三菩伽。是事今已灭竟。如法如善如佛教。现前行十筹了了问答。或有不智比丘。作是语。今灭是十事。为如法灭耶。为不如法灭耶。皆不可知。以是故。汝三菩伽。当往大会僧中使大会僧皆共普问是十事。如此我答。汝令一无异。如是教竟。诸上座从座起。往至大会僧处。还至本坐处坐。长老三菩伽起合手。向上座萨婆伽罗波梨婆罗。如是言。大德上座。盐净实净不。答不净不净。得何罪。答得突吉罗罪。佛何处结戒。答舍婆提国毗尼药法中。大德上座。二指净实净不。答不净不净。得何罪。答波逸提罪。佛何处结戒。答毗耶离为不受残食法故结戒。大德上座。近聚落净实净不。答不净不净。得何罪。答得波逸提罪。佛何处结戒。答毗耶离为不受残食法故结戒。大德上座。生和合净实净不。答不净不净。得何罪。答得波逸提罪。佛何处结戒。答毗耶离为不受残食法结戒。大德上座。如是净实净不。答不净不净。得何罪。答得突吉罗罪。佛何处结戒。答占波国毗尼行法中。大德上座。证知净实净不。答不净不净。得何罪。答得突吉罗罪。佛何处结戒。答占波国毗尼行法中。大德上座。贫住处净实净不。答不净不净。得何罪。答得波逸提罪。佛何处结戒。答婆提国跋陀婆提城为长老娑伽陀结戒不得饮酒。大德上座。行法净实净不。答有行法净。行亦净。不行亦净。有行法不净。行亦不净。不行亦不净。何等行法不净。行亦不净。不行亦不净。答杀罪乃至邪见。行亦大净。不行亦不净。何等行法净。行亦净。不行亦净。答不杀等法。是为行法净。行亦净。不行亦净。大德上座。不益缕边尼师檀净实。净不。答不净不净。得何罪。答得波逸提罪。佛何处结戒。答舍婆提国为迦留陀夷听益缕边一磔手尼师檀结戒。大德上座。金银宝物净实净不。答不净不净。得何罪。答得波逸提。佛何处结戒。答毗耶离为跋难陀结戒。不得取金银宝物。长老三菩伽。僧中如法灭。是毗耶离诸比丘十事罪。如法灭竟。便说此偈

  若人不知罪不除　　他为除罪便嗔恚
  是名无智愚痴人　　日日妄失功德利
  譬如月十六日后　　其光渐渐消灭尽
  若有人知罪得除　　他为除罪便欢喜
  是名有智黠慧人　　日日大得功德利
  譬如月生一日后　　其光渐渐转增上

七百比丘集灭恶品竟

    毗尼中杂品第三

佛在舍婆提城。有比丘。与一比丘相嫌礼拜恭敬。是比丘高声大唤。诸比丘大集问。何以故大声唤。答言。此比丘打我。诸比丘问此比丘。实打不。比丘答言。我礼拜恭敬。实不打。是比丘先相嫌故。为我作过耳。诸比丘是事白佛。佛以是因缘会僧。会僧已告诸比丘。从今日若先相嫌。不应礼拜。若礼拜得突吉罗罪。长老优波离问佛。如佛所言。先相嫌不应礼拜。若未受具戒人先相嫌者。得礼拜不。佛言不得。若僧都会时听礼无罪。优波离问。沙弥受具足羯磨时。男根转成女。为名比丘名比丘尼耶。佛言。名比丘尼。又问。式叉摩尼受具戒羯磨时。女根转成男。为名比丘尼名比丘耶。佛言。名比丘。又问。若一切比丘结界羯磨时。僧都转成女。是界名比丘界名比丘尼界耶。佛言。名比丘尼界。问若一切比丘尼结界羯磨时。都转成男。是界名比丘尼界名比丘界耶。佛言。是名比丘界。问若比丘结界羯磨时。或转者或不转者。是界名比丘界名比丘尼界耶。佛言。若说羯磨人。是男界属比丘。成女界属比丘尼。问比丘结界羯磨时。说羯磨比丘独转成女。是界名比丘界名比丘尼界耶。佛言。名比丘尼界。问比丘尼结界羯磨时。说羯磨人独转成男。是界名比丘尼界名比丘界耶。佛言。名比丘界

诸比丘。为比丘尼作种种羯磨。诸比丘尼不受。是事白佛。佛言。比丘不应与比丘尼作羯磨。还比丘尼应与比丘尼作羯磨。除三种羯磨。何等三。一者受具戒。二者行摩那埵。三者出罪羯磨

诸比丘尼。为比丘作种种羯磨。诸比丘不受。是事白佛。佛言。比丘尼不应与比丘作羯磨。还比丘应与比丘作羯磨。除三种羯磨。何等三。一者不礼拜。二者不共语。三者不敬畏羯磨

佛在舍卫国。时诸比丘尼。到祇洹欲听法。其日说戒。诸比丘语。姊妹汝出去。我欲作法事说戒。比丘尼言。我等欲听诸比丘戒。诸比丘言。佛未听我等比丘尼前说比丘戒。是事白佛。佛言。听比丘比丘尼前说比丘戒。不听比丘尼说比丘戒。若比丘说戒时忘。听比丘尼口授。时诸比丘。到王园比丘尼精舍中欲听法。其日说戒。诸比丘尼言。大德汝出去。我欲作法事说戒。诸比丘言。我欲听比丘尼戒。诸比丘尼言。佛未听我等比丘前说比丘尼戒。是事白佛。佛言。听比丘尼比丘前说比丘尼戒。不听比丘说比丘尼戒。若比丘尼说戒时忘。听比丘口授波斯匿王。请佛及阿难明日入宫食。阿难先已受他请。时忘不忆复受王请。佛默然受请竟。王头面礼佛足还宫。是夜办种种饮食。办竟敷佛坐处。遣使白佛。唯圣知时食具已办。佛着衣持钵。共阿难入王宫食。尔时阿难。二请忘不与他一请。阿难以食着口中。是时乃忆知。有二请不与他一请。不敢吐食。为恭敬佛故。又不敢咽。为持戒故。佛知阿难心悔告阿难。心念与他已便食。长老优婆离问佛。佛听阿难心念与他得食。若余人心念与他。亦得食不。佛言。不得。除五人一者坐禅人。二者独处。三者远行。四者长病。五者饥饿时依亲里住。如是人更无余人。听心念与他

有比丘。与一比丘相嫌与清净。是人高声大唤。诸比丘大集问。何以大唤。答言。是比丘重罪欲我边忏悔。诸比丘问是比丘汝实重罪欲忏悔不。答言不。我欲与清净。此人与我相嫌。是故大唤与我作过。是事白佛。佛言。从今日先相嫌人。不应与清净。不应与欲。不应与自恣。不应与忏悔。若与忏悔得突吉罗罪。优波离问佛。若比丘一处僧摈。余处得忏悔不。佛言。不得。除是精舍空。若诸比丘死。若反戒若入外道。听余处忏悔无罪。憍萨罗国有二聚落界相连。是中一比丘尼。谓是一聚落。入异聚落界。诸比丘尼语此比丘尼。汝得僧伽婆尸沙罪。是比丘尼言。何等僧伽婆尸沙。诸比丘尼言。汝独入异聚落。是比丘尼心中悔。出界故。得僧伽婆尸沙。以是事白佛。佛知故问。汝谓是一界。谓是异界耶。比丘尼言。我谓是一界。佛言无罪。从今日听。若有两聚落界相连。是中应作一界羯磨。云何作。一比丘尼应僧中唱。大德尼僧听。某甲某甲聚落界。是中欲作一界羯磨。若僧时到僧忍听。某甲某甲聚落界。作一界羯磨。如是白。白二羯磨。僧已听。某甲某甲聚落界作一界羯磨竟。僧忍默然故。是事如是持

诸比丘从憍萨罗国游行。欲至舍婆提城。近祇洹有好林木茂盛。其中净洁。诸比丘心乐是处。其日说戒。诸比丘言。是中作说戒。说戒竟入祇洹。祇洹比丘打揵槌欲说戒。客比丘问。何以打揵槌。答欲说戒。客比丘言。我等已说戒竟。问长老汝等何处说戒。答某处。祇洹比丘言。汝等破僧。客比丘言。云何破僧。汝等界内二处说戒。轻我等故。客比丘心悔。我等破僧。或得偷兰遮罪。是事白佛。佛知故问。汝心云何。客比丘言。我谓是外界。佛言无罪。从今日不得为小因缘故住道中说戒。若欲说戒。当上高处立观知。近处有精舍无。若有应入中作布萨说戒

憍萨罗国有边聚落。诸比丘畏贼。弃精舍入是聚落。其日说戒日。有比丘共贼来。是比丘不知。何者是外界。何者是内界。是事白佛。佛言。有聚落属贼。是一切外界。是时随所在处。自在说戒

舍婆提国有贾客主。欲至他国。占沸星日发。有比丘。以此布萨。日欲共贾客主去。是比丘到贾客主所语言。小住。我有法事。贾客主答。今是沸星日好不得住。汝作法事竟随后来。诸比丘不知当云何。是事白佛。佛言。若贾客住广说戒。若小住略说戒。若不住三语说。若都不听住。各各口语。今日布萨说戒。若白衣在比丘中不得各各口语。是时应一心念。今日布萨说戒。是贾客主发。到宿处作制限。不得散住。若散住尽夺财物及夺命。是日说戒日。诸比丘不知当云何。是事白佛。佛言。从今日若有如是布萨说戒日。应但一心念。今日布萨说戒。有贾客主。到有龙处宿。诸比丘语贾客主。我等欲作法事。贾客主言。大德。是处龙处莫作声。龙傥嗔我等得大愁怖。诸比丘不知当云何。便白佛。佛言。从今日如是布萨说戒日。应但一心念。今日布萨说戒。有贾客主。到鬼神处宿。是日说戒日。诸比丘语贾客主。我等欲作法事。贾客主言。大德。是处鬼神处莫作声。鬼傥来我等得大愁怖。诸比丘不知当云何。便白佛。佛言。从今日若如是布萨说戒日。但应一心念。今日布萨说戒

长老优波离问佛。阿兰若比丘。在独处一身当云何说戒。云何自恣。云何受衣。云何受七日法。云何受七日药。云何与一请。云何衣物以清净故施。佛告优波离。若阿兰若比丘。独处一身。听一心念。今日布萨说戒。得说戒法。自恣受衣受七日法。受七日药与一请。及净施衣物亦尔

神通大德大力比丘。至净国乞食。国人多恶。若受饮食先好洗手。是比丘先受食便欲啖。净人言。我等非不净人。持饮食来与比丘。不手授便着地。诸比丘不知当云何。白佛。佛言。从今日净国中。听不手授得取。以净国土故有一住处。一上座犯僧伽婆尸沙。上座言。我当行波利婆沙行摩那埵。诸人言。上座行波利婆沙摩那埵。何况中座下座生不信心。诸比丘是事白佛。佛言。若一心生念。从今日更不作。是时即得清净

有一住处。有比丘大德多知。我行波利婆沙行摩那埵。诸人言。大德多知比丘。行如是事。何况余人。生不信心。诸比丘以是事白佛。佛言。若一心生念。从今日是事更不作。是时即得清净

有比丘犯僧伽婆尸沙罪。诸比丘言。汝行波利婆沙摩那埵。是罪如法忏悔。其人言。我不能行。我宁当反戒。诸比丘以是事白佛。佛言。若一心生念。从今日更不作。是时即得清净。有比丘病。犯僧伽婆尸沙罪。诸比丘言。汝行波利婆沙摩那埵。是罪如法忏悔。其人言。我不能行忏悔法。无力故。诸比丘言。汝乞出罪羯磨。其人言。我不能胡跪住。诸比丘以是事白佛。佛言。若一心生念。从今日更不作。是时即得清净

有一住处。比丘犯僧伽婆尸沙罪。众不满二十人。是比丘欲至他处忏悔。道路遇贼死。诸比丘言。是比丘不清净死。或堕恶道。是事白佛。佛言。一心生念如法忏悔。是人清净。死不堕恶道。得生天上

有一住处。比丘犯僧伽婆尸沙罪。众不清净。是比丘至他众欲忏悔。道路遇贼夺命诸比丘言。是比丘不清净死。或堕恶道。是事白佛。佛言。一心生念如法忏悔。是人清净。死不堕恶道得生天上(凡有六种忏法不可妄用及侥幸也唐为自欺罪亦不除要须广问明律者能断之耳相甚难知)

憍萨罗国远住处。二比丘共住。有贼来捕是比丘。欲祠祀故贼一面住守。是二比丘其日说戒日。二比丘言。聚落主小放。我等欲作法事。贼言。听汝作法事。二比丘小远。一人言。我有罪。一人言。我亦有罪。佛说俱有罪人不得清净。贼言。汝道何物。汝欲走去耶。答不去。道何等。答言。我等有过欲忏悔耳。贼言。汝有何过。答如是如是过。贼言。汝等是好人。有尔许小事。持是作过。我等是恶人。恼如是好善人。贼到贼主所言。是比丘好善人。可放使去。我更觅余人。贼主言。放去。比丘从恐怖中得脱。是二比丘以是事向诸比丘说。诸比丘以是事白佛。佛言。从今日如是急事。若不相应罪听忏悔憍萨罗国远住处。有二比丘共住。有贼来捕是比丘。为祠祀故贼一面住守。是二比丘。其日是说戒日。比丘言。聚落主小放我等。我等欲作法事。贼言。听汝作法事。二比丘小远。一人言。我有罪。一人言。我亦有罪。佛说相应罪不得忏悔。不相应罪得忏悔。今我等是相应罪。不得共忏悔。贼言。汝道何等。欲走去耶。答言不去。问若不走道何等。答言。我等有过欲忏悔耳。贼言。汝有何过。答如是如是过。贼言。汝等是好善人。有尔许小事持作过。我等是恶人。恼如是善人。贼到贼主所言。是比丘善人。可放使去。我等更觅余人。贼主言。放去。是二比丘恐怖中得脱。向诸比丘说。诸比丘白佛。佛言。从今日若有相应罪。是比丘一心生念口言。后当向清净比丘忏悔。听受相应罪忏悔

有一住处。比丘病。堕罪语看病人。我有罪。看病人言。我亦同有是罪。佛说。有相应罪。一心生念口言忏悔。后听受他忏悔。我等是事故欲从汝忏悔。看病人答。远住处二比丘。为贼捕得欲祠祀。是故佛听。若相应罪忏悔。不听病人如是忏悔。是病比丘死。心悔故堕恶道。是事白佛。佛言。从今日若有相应罪。若贼捕得。若病人。听心生口言忏。后当从清净比丘忏悔。后听受他忏悔

憍萨罗国舍利弗。欲游行至舍婆提。中道有空精舍。是说戒日不知何者是内界何处是界外。是事白佛。佛言。若有弃空精舍。是名一切界外。是中随意说戒

憍萨罗国有二聚落连界。是时饥饿有比丘尼。将一比丘尼伴。到异聚落亲里舍。与二三日食。更不能与。语比丘尼言。汝一人尚不能活。何以将人来。比丘尼答。佛不听我独余聚落行。以是故将来。比丘尼不知当云何。便白佛。佛言。从今日连界。是中应作一界羯磨。云何作。僧一心会。一比丘尼应唱言。大德尼僧听。某甲某甲聚落。作一界羯磨。若僧时到僧忍听。某甲某甲聚落。作一界羯磨。如是白。白二羯磨。僧已听某甲某甲聚落作一界羯磨竟。僧忍默然故。是事如是持

憍萨罗国诸比丘游行。与贾客俱经过大泽。诸比丘从贾客主乞水。贾客主即出水与着钵中。水上有少食。诸比丘弃水。贾客主言。汝亦知是中无水水难得。何以弃水。比丘言。日时已过。是水上有少食。不应饮故。是比丘不知当云何。是事白佛。佛言。不应一切弃。弃上少许水。下净水听饮

憍萨罗国诸比丘游行。与贾客俱经过大泽故。诸比丘从贾客主乞水。贾客主即出水与着钵中。水底有少许食。诸比丘弃水。贾客主言。汝亦知是中无水水难得。何以弃是水。比丘答言。日过中。是水底有少食。不应饮。是故弃。是比丘不知当云何。是事白佛。佛言。不应一切弃。上水听饮。下底应弃。诸比丘从放牛人乞水。水瓶腻泻水着钵中。水上凝酥如芥子。诸比丘不知当云何。是事白佛。佛言。酥可却者却。净水应饮。诸比丘持腻钵。着汪池水中取水。水腻尽凝。诸比丘不知当云何。是事白佛。佛言。酥可却者却。净水应得饮。诸比丘钵有残食着钵。着潢池水中取水。食没入水。遥见饭白。诸比丘不知当云何。便白佛。佛言。可却者却。残余净水得饮

沙弥白衣捉瓶酥麻油。澍着比丘钵中不断。诸比丘心中疑。我或非是受法。便白佛。佛言。是澍下流非上流。不破受法

憍萨罗国比丘。游行至舍波提国。经过大泽是时有小沙弥持净物。沙弥不能担。便白佛。佛言。比丘应并担净人去。诸比丘舍内壁上有棚。棚上有食。沙弥小。不及举食。不及取食。诸比丘不知当云何。便白佛。佛言。比丘明日当担净人棚上取

憍萨罗国诸比丘。游行至舍婆提。道中值河水。沙弥小。担净物不能渡。诸比丘不知当云何。便白佛。佛言。比丘当担沙弥渡河

憍萨罗国诸比丘。游行至舍婆提。道中值河水。沙弥小担净物。是河水駃长。比丘担沙弥渡。为水所漂。比丘手触食。诸比丘疑。是食或能不净。便白佛。佛言。净人恒念守视食囊。虽触无罪。有河浮囊渡。担净物沙弥小。诸比丘不知当云何。便白佛。佛言。比丘当使净人持食。着浮囊上。渡到彼岸上。莫手触食。还使净人捉。比丘新熏钵。酥着钵。二三过洗。腻气不净。便白佛。佛言。若一心三洗者。是钵名净

比丘用不净脂涂钵受糗。是比丘一切弃。白佛。佛言。不应一切弃。泻着余器中应食。余着钵糗是应弃。比丘绳缀钵用受热粥。少腻从缀间出。比丘都一切弃。佛言。不应一切弃。应弃此腻余应食。比丘使沙弥持钵。是沙弥持食。不净钵与师。是比丘不知当云何。便白佛。佛言。无急事不应使沙弥持钵。若使持应从沙弥受。比丘净食中着不净食。诸比丘不知当云何。便白佛。佛言。不净除却。余残应食。比丘不净食中着净食。诸比丘不知当云何。便白佛。佛言。不净者却。应取净者食。比丘净饭中着不净饭。诸比丘不知当云何。便白佛。佛言。不净除却。余残应食。比丘不净饭中着净饭。诸比丘不知当云何。便白佛。佛言。不净者应却。取净者食

憍萨罗国诸比丘。与贾客俱向舍婆提城。经过大泽。诸比丘从贾客主乞食贾客主言。汝知此间食难得。何以不自担粮。诸比丘答。佛未听我等道路赍粮。诸比丘不知当云何。便白佛。佛言。从今日听自担粮。从他易净食乃听啖。不易不听啖。诸比丘欲易食。他人不与。言汝食中有何不可故。易诸比丘不知当云何。便白佛。佛言。从今日清净故与。与竟他不还。是事白佛。佛言。当从乞取。是贾客主到宿处。净人办饮食。满钵着一面。贾客夜半发去。诸比丘忘自持食。后忆念此食不净便弃。佛言。不应弃。忆念时从人受

有守逻人。从比丘乞食。若与食少若不与。此人嗔作不可事。是事白佛。佛言。从今日听担食藏。莫使人见。若食当出道取一搦不受得食。以经旷泽故。频婆娑罗王。请佛及僧与粥田。诸比丘守谷不肯取。以上场不净故。佛言。未分应取。若分不应故取。若取得突吉罗罪。饮食具车载来入车欲倾。将车人呼。大德佐捉。诸比丘不肯捉。以不净故。佛言。听佐正车。正车后不应更捉。若捉得突吉罗罪

饮食具舡载。诸比丘不肯上舡。以不净故。佛言。从今日听着芦[卄/博]。若席应坐。若坐触食具。佛言。敷令遍。莫触食具

饮食具骡驴牛象驮来。诸驮倾转。驱驮人唤。诸大德。佐我正驮。比丘不肯若佐。是食具或不净。是事白佛。佛言。从今日听佐正。若正后更莫捉。若触得突吉罗罪。白衣沙弥负食具来。负倾转。语诸大德。与我正负。诸比丘不肯。以是事白佛。佛言。从今日听正。若正已莫复触。若触得突吉罗罪。沙弥白衣持酥油瓶泻着异瓶中。瓶倾动。净人语。大德与我正。诸比丘不肯。是事白佛。佛言。从今日听与正。正已莫复触。若触得突吉罗罪。比丘使沙弥白衣僧。釜中煮肉饭粥羹。釜倾转。呼佐我支。诸比丘不肯。是事白佛。佛言。从今日听佐正。正已不应复触。若触得突吉罗罪。有看马人。从波罗奈国诣舍婆提放马。是人信佛法。办种种饮食。入着僧前。是人闻马屋失火。是人言。大德自食。我等有急事。留食便去。诸比丘不知当云何。是事白佛。佛言。信佛法人一心与。若舍去便应食。比丘乞食食着一面。待时到我当食。乌来啄一口去。比丘一切弃食。佛言。不应一切弃。但弃啄处。余残应食。比丘乞食食着一面。待时当食。蝇来入食钵中。比丘言。此食或破受法。日近中无净人。是比丘心疑。不敢食。佛言。蝇不可遮不破受法

长老优波离问佛。有比丘求水瓶。误取酥油瓶。是瓶破净应弃不。佛言。有二种不坏净。一无羞破戒人捉。二持戒人忘误捉。俱净应食。诸比丘为小沙弥担饮食。行道中与沙弥食。沙弥食时还与比丘。比丘不肯受。共宿故。佛言。先不共要得食。若要不应食

诸比丘夏安居。聚落中有因缘应出。是比丘畏犯戒不去。是众所可作事废。佛言。听受七夜法去。诸比丘受七夜去聚落。若七夜未尽。所作事未竟来还。诸比丘不知云何。是事白佛。佛言。受余残夜去。言我受七夜法。若干夜已过。余若干夜在。受彼出界佛在舍婆提。波斯匿王有园。名波罗陀。清凉净洁。众事作竟唯无有水。一时波斯匿王出诣园四顾看不见水。王告大臣侍人。此中何以无水。大臣答。素无水。王告大臣。汝等方便引水令来。园无水不可爱乐。大臣侍人中。有恶心不信法者言有一因缘水可得来。王言。水云何可得。大臣言。当于祇洹中作渠通水来。作渠者。当破祇洹中树及佛图精舍。王言。吾欲使水来。不知余事。王为是故至桑奇多国。恐诸比丘傥来从我乞救。是事故王去。后工匠即诣祇洹。引绳使直欲凿渠。语比丘问言。聚落主欲作何等。工匠言。波斯匿王有园。名波罗陀。清凉净洁。众事作竟唯无水。欲于祇洹作渠通水。诸比丘言。聚落主。汝等欲伐树木。房舍非复僧伽蓝。工匠答言。大德。我是官人。不得自在。从王约敕。非是我意。憍萨罗主波斯匿王意耳。工匠言。我等唯能小停不作。汝等自诣王求令不作渠。诸比丘不知当云何。是事白佛。佛言。应受七夜去诸比丘受七夜去。到彼间久住。无人与白王。七日向尽而事未了。心疑即还祇洹。诸比丘见彼比丘来问。是事办不。答言不办。祇洹诸比丘言。何以不办。答我等彼间久住。无人白王。七夜向尽而事未了。我等心疑便还。是事白佛。佛言。听受三十九夜去。云何应受。一比丘应僧中唱。大德僧听。某甲某甲诸比丘。受三十九夜。僧事故出界。是处安居自恣。若僧时到僧忍听。某甲某甲比丘。受三十九夜。僧事故出界。是处安居自恣。如是白。大德僧听。某甲某甲比丘。受三十九夜。僧事故出界。是处安居自恣。谁诸长老忍。某甲某甲比丘。受三十九夜。僧事出界。是处安居自恣者默然。谁不忍者便说。僧已听。某甲某甲比丘。受三十九夜。僧事故出界。是处安居自恣竟。僧忍默然故是事如是持。是诸比丘到彼亦久住。无人白王。王余时小出。王举眼视。遥见比丘。王语臣言。往问沙门释子。来何所作。受教往问。为何所作。比丘答言。我欲见王。臣还白言。比丘欲见王。即语臣言。唤比丘来。即往言。王唤比丘。比丘即入就座坐已。共相问讯乐不乐。王小默然。王忘先事故便问比丘。何故来。比丘即以此事向王广说。王言去。莫复使作。工匠即不作渠

六群比丘畜五大皮。师子皮。虎皮豹皮獭皮。狸皮。是事白佛。佛言。五大皮不应畜。若师子皮虎皮豹皮獭皮狸皮。更有五皮不应畜。象皮马皮豺皮狗皮黑鹿皮。若畜得突吉罗罪。阿阇世王见父诸好大床。心悔忧恼。以是物故。我父清净人无过人。而抂死。便告大臣侍者。持是诸床去。即持着空地。王出犹见。王言。除却。彼即移着外门屋中。王出入复数见。王言。持去。彼即移着中门屋中。王见犹数。王言。何以置此耶。臣言。大王。不知当移置何处。王言。持去施竹园众僧。臣即持去与竹园僧。僧着空地讲堂门间。诸兵将吏到竹园看见之言。我眼初不得见。是好物何缘弃之。若王闻者心或不净。诸比丘闻。不知当云何。是事白佛。佛言。从今日听。白衣舍大床高床。比丘不得畜不得坐不得卧。若人施高床大床听受应护藏举。不得坐不得卧

波斯匿王母死。母所有生时一切众物。持诣祇洹与诸比丘。诸比丘得是贵衣被。从阿蛾罗弥国出。户摩根衣。婆蹉阿婆多兰国出。以是好贵衣被。敷着地在上经行。诸兵将吏到祇洹观看见已言。我等初不得手捉着头上。云何敷地脚蹑。若波斯匿王闻。心或不净。诸比丘不知当云何。便白佛。佛言。听贵衣中可作卧具者便作。中作衣者便作。是物任所用者便作。是大贵衣阿蛾罗弥国出。户摩根衣婆蹉阿婆多兰国出。贵价衣是比丘受用。作四方僧卧具有时大雷。诸飞鸟怖死。诸居士知是事即出择取好鸟。除大乌鸟鹫秃枭角鸱阿罗。如是诸鸟不取不中食故。诸比丘时到着衣持钵。入舍婆提乞食。见此诸鸟皆死无人取。诸比丘语余比丘。汝持去煮炙。我乞食还。共汝等啖。是时有比丘。持来煮炙。有诸比丘问。是何等肉。答乌肉。诸比丘以种种因缘。呵云。何名比丘。啖乌肉。佛所未听。诸比丘种种因缘呵竟。是事白佛。佛言。乌肉不得啖。若啖得突吉罗罪。诸比丘问。是复何等肉。答小乌肉鹫肉鸿肉婆娑秃枭角鸱阿罗肉等。诸比丘种种因缘呵。云何名比丘。啖大乌肉鹫肉鸿肉婆娑秃枭角鸱阿罗等肉。佛所不听。呵竟白佛。佛言。不得啖如是等肉。一切啖死尸鸟肉。皆不得啖。若啖得突吉罗罪。诸比丘食后。至阿耆罗河上经行。见水中漂豺来。诸比丘语一比丘。取此豺来。明日当食。是比丘即取。明日有煮豺肉者。有乞食者。诸比丘问。长者是何等肉。答豺肉。诸比丘种种因缘呵。云何名比丘。佛未听啖。豺肉而啖。呵竟白佛。佛言。云何名比丘。啖豺肉。豺肉狗肉无异。从今日不得啖豺肉。若啖得突吉罗罪。诸人骡死弃着堑中。诸比丘食时着衣持钵。入舍婆提城乞食。见堑中有死骡。语余比丘。持去煮。我等乞食还。当共啖。诸比丘问。是何等肉。答骡肉。诸比丘种种因缘呵。云何名比丘。佛未听啖骡肉而啖。是事白佛。佛言。骡马何异。从今日不得啖骡肉。若啖得突吉罗罪。诸比丘食后。入安陀林经行。见死猕猴。语余比丘。持去明日当食。是比丘即取。明日有煮者。有行乞食者。诸比丘问。长老是何等肉。答猕猴肉。诸比丘种种因缘呵。云何名比丘。佛未听啖猕猴肉而啖。是事白佛。佛言。猕猴似人肉。与人肉何异。若啖得突吉罗罪

毗尼杂品竟

毗尼序卷下

    因缘品第四

佛在迦毗罗婆国。诸贵释子出家得长病。病人早起。到亲里家檀越知识家。诸主人问言。乐不。答长病不乐。主人问。得何等病。答得如是如是病。主人言。白衣时病云何治。答牛胞中着药灌。主人言。与汝是药治。比丘言。佛未听我着是药。是事白佛。佛言。听灌用。薄皮不中灌。佛言。听厚皮灌屏处。听若药师教亲亲人灌

诸贵释子出家得长病。病人早起。到亲里檀越知识家。主人问。乐不。答长病不乐。主人问。何等病。答如是如是病。主人言。白衣时病云何治。答用刀治。主人言。与汝刀。比丘言。佛未听我等用刀治。是事白佛。佛言。听莲华茎割。比丘言。不中用。佛言。听用金银琉璃铜铅锡珠刀割。比丘言。如是诸刀不中用治。佛言。屏处听用铁刀治

有比丘病。语看病人言。持生熟酥油蜜石蜜来。看病人言。无。若有是佛僧物不净举宿恶捉不受内宿。是事白佛。佛言。听若佛物僧物不净举宿恶捉不受内宿。若病人得上物。差竟应与。长老毕陵伽婆蹉患眼痛。药师教罗散禅那着眼中。作是言。佛未听罗散禅那着眼中。佛言。听用治眼。毕陵伽婆蹉钵中有罗散禅那。小钵半钵大揵瓷小揵瓷络囊悬着象牙杙上。取时流污壁卧具房舍卧具垢臭。是事白佛。佛言。听罗散禅那函盛。比丘作函不盖。比丘不知当云何。是事白佛。佛言。听作盖。比丘直作盖喜堕。佛言。作子口盖。用乌翅鸡翅收漏罗翅。涂着眼中眼痛更增。佛言。作筹。长老优波离问。何物作筹。佛言。铁铜贝牙角木瓦作。佛言。从今日界内不应作净处。若作得突吉罗罪。长老优波离问佛。阿耆达婆罗门为佛作八种粥。酥粥胡麻粥油粥乳粥。小豆粥摩沙豆粥麻子粥清粥。是八种粥。杂根药茎药叶药华药果药。煮可饮不。佛言。病比丘可饮。不病者不得饮

佛在苏摩国。是时长老阿那律比丘弟子病。服下药中后心闷。佛言。与熬稻华汁。与与竟闷不止。佛言。竹笋汁与。与竟不差。佛言。囊盛米粥绞汁与。与竟不差。佛言。将屏处与米粥

优波离问佛。佛听结发鸡尼耶梵志施八种浆。昭梨浆牟梨浆。拘梨多浆舍梨浆。阿说陀浆波流沙浆。劫必陀浆蒱萄浆。是八种浆。根汤茎汤叶汤华汤果汤。合可饮不。佛言。若无酒味不杂食。清不浊听饮

佛在舍婆提。尔时憍萨罗国诸居士。道中无水处。以水施并施石蜜。六群比丘从憍萨罗国至舍婆提。次第行到施水处。六群比丘但啖石蜜不饮水居士言。何以独啖石蜜不饮水。六群比丘言。我嗜石蜜不喜饮水。施主言。我为饮水故施石蜜。今汝何以但啖石蜜不饮水。六群比丘言。我嗜石蜜不喜饮水。是六群比丘有大力。复不畏破戒。是居士不能面前讥说。去后心嗔呵骂。沙门释子自言善好有德。但啖石蜜不欲饮水。诸比丘少欲知足行头陀。闻是事心惭愧。是事白佛。佛言。从今日五时听啖石蜜。一远行来。二若病。三若食少。四若不得食。五若施水处。是五时听啖石蜜。从今日若不饮水不听啖石蜜。若啖得突吉罗罪

优波离问佛。石蜜浆举宿得饮不。佛言。病比丘得饮。不病不得饮

比丘若得二种请。一请与他一比丘受。问汝与不。答我与。更问。何时与。答瓶沙王请佛及僧百岁四事供养。是时与。是事白佛。佛言。比丘有二请。一今日请。二冷请。若有一日得二请。一请与他一请自受。冷请有二种。随受净随受不净。随受云何净。随受五佉陀尼。五食五似食。何等五佉陀尼。根茎叶果磨何等五食。饭糗面鱼肉。何等五似食。糜粟大麦迦师莠子。何等不净随受。五宝五似宝。五宝者。金银摩尼珠玻梨毗琉璃。何等五似宝。赤铜铁鋀石水精铅锡白镴。若净物直受。不净物作净已受。阿罗毗国诸比丘。日日借作具。居士言。诸作具何以不自作。而日日借。比丘言。佛未听我等畜作具。是事白佛。佛言。为僧听畜一切作具。有居士祇洹作房舍。是中有少供养具。客比丘房舍中宿。问是房舍谁作。答某甲居士作。是比丘一宿。早起着衣持钵诣居士所。语言。汝房舍中供养具何以少。居士言。我先时大多与。是比丘言。我是中。一宿住。见供养具少不足言。居士语比丘。共诣本作房舍比丘所。居士到本营房舍比丘所言。我本与长老是中供养具。斯何所在。比丘答。本所与供养具。异房比丘用去。居士言。我本不与异房比丘用。与自作房舍中住比丘用。我房舍空。是供养具着异处。是不应尔。是比丘不知当云何。是事白佛。佛言。从今日听。檀越与何房舍。是中住者应用分

舍婆提有一人亲里为他杀。着祇洹堑中空处。比丘求觅粪扫衣。到死人边取一衣去。诸亲里觅到祇洹。见是比丘问言。大德。如是人若见若闻不。比丘答。此人死弃在祇洹堑中。我是边取一衣来。亲里言。将我示处。比丘即将示处。亲里见死悲咽言。汝或能以衣故杀我人。比丘言。我实不杀。若杀何以不取余残衣物也。亲里如是思惟。我等软语是比丘不实语。我当将去诣官。便将去诣官。官问是比丘。汝实杀不。比丘答言。我是比丘云何杀人。我若杀应当持余衣物去。官人聪明信佛法。知释子比丘不作是事。放此比丘去。若后如是。比丘不问他莫取。是比丘从恐怖得脱。是事语诸比丘。诸比丘是事白佛。佛言。从今日不问他。杀人衣不应取。若取得突吉罗。诸比丘取有主死人地衣。旃陀罗言。死人地衣莫取。我曹输王如是如是物。诸比丘不知当云何。是事白佛。佛言。有主死人地衣不应取。若取得罪。诸比丘取有主死人地四边有粪扫衣。是中旃陀罗亦遮。是事白佛。佛言。若遮莫取。若取得突吉罗

时舍婆提有大疫病。多有人死。诸比丘取烧死人间薪。为僧办温室。是焦薪鬼逐来。一切僧得病苦。是事白佛。佛言。不听取死人间薪。若取得突吉罗罪

诸比丘取天祠中衣毳劫贝白[疊*毛]。守祠人言。大德。此诸衣物属祠莫取。比丘言。此泥木天用衣物为。守祠人言。佛阿罗汉塔物我亦当取。是事白佛。佛言。从今日天祠中衣毳劫贝白[疊*毛]不得取。若取得偷兰遮罪

有比丘病。多钵多衣多物。看病人思惟。若交与我一切物。或教六物与僧余残与我。思惟竟语病比丘。汝病久不差。汝死后现前一切物。僧当分。汝亦不得大福。不得恩分。汝今活时。分处六物与僧。余残物与我。病比丘思惟。若不与。恐不好看我。思惟竟。即以六物与僧。余残物与看病人。是比丘后病差。是时佛及僧。夏后月游行诸国土。余比丘着新染衣。是比丘独着弊衣。佛知故问比丘。何以独着弊故衣。是比丘以是事白佛。佛种种因缘呵。何以名比丘。六物不应与僧。不应分与他。亦不应教他与。佛种种因缘呵竟告诸比丘。从今日六物不应自与。不应教与。若自与教他与。得突吉罗罪

长老优波离问佛。僧坊中房舍破。是中有所用敷具覆具。得持博贸治不。佛言得。若僧中有两房舍欲坏。得卖一房治一房不。佛言得。憍萨罗国有边聚落。是时有贼。诸居士畏贼弃聚落去。是时诸比丘乞食难得。便弃塔物僧物已。自持衣钵出去。是贼世静已。诸居士还本住处。诸比丘为塔物僧物乞求钱财。居士言。先有塔物僧物。皆何所在。比丘言。于贼世中失去。居士言。汝自衣钵在不。比丘言。我持随身。居士言。汝等自爱衣钵。不爱佛物僧物。诸比丘不知当云何。是事白佛。佛言。若贼世怖畏时。听担去后还着本处

更有贼世。诸比丘取自衣钵及佛物僧物持出去。六群比丘道中逢言。是僧卧具我当用之。时比丘不与便斗诤。诸比丘不知当云何。是事白佛。佛言。担去者应用余不应索

诸比丘持塔物僧物着空地。自着衣持钵乞食。来还失是物去。佛言。行乞食时担佛物僧物。自持衣钵担荷不好。佛言。乞食时听以物着衣裹

是比丘持佛物僧物着空地。上厕出失衣物。白佛。佛言。护是物欲使不失。当寄人若着屏处。憍萨罗国一住处。檀越为比丘僧施衣。是中比丘僧不在。是事白佛。佛言。现在三比丘应分。二比丘亦应分。一比丘心生口言受。沙弥若三若二应分。一人心生口言应受

憍萨罗国一住处。檀越为比丘尼僧施诸衣物。是中比丘尼僧不在。是事白佛。佛言。现前三比丘尼应分。二比丘尼亦应分。一比丘尼心生口言应受。三式叉摩尼二式叉摩尼应分。一式叉摩尼心生口言应受。三沙弥尼二沙弥尼应分。一沙弥尼若心生口言应受。憍萨罗国一住处。檀越为比丘僧施衣物。比丘僧不在。是事白佛。佛言。现在三比丘二比丘应分。一比丘心生口言应受。三沙弥二沙弥应分。一沙弥心生口言应受。若时都无比丘无沙弥。是事白佛。佛言。是物比丘尼僧应分。若时亦无比丘尼僧。三比丘尼二比丘尼应分。一比丘尼心生口言应受。三式叉摩尼二式叉摩尼应分。一式叉摩尼心生口言应受。三沙弥尼二沙弥尼应分。一沙弥尼心生口言应受

憍萨罗国一住处。檀越为比丘尼僧施衣物。是中无比丘尼僧。白佛。佛言。现在三比丘尼二比丘尼应分。一比丘尼心生口言应受。三式叉摩尼二式叉摩尼应分。一式叉摩尼心生口言应受。三沙弥尼二沙弥尼应分。一沙弥尼心生口言应受。若时都无比丘尼。又无式叉摩尼沙弥尼。尔时比丘僧应分。乃至沙弥亦如是

憍萨罗国一住处。檀越为二部僧施衣物。比丘僧不在。佛言。比丘尼僧应分。比丘尼僧亦不在。佛言。三比丘二比丘应分。一比丘若心生口言应受。三比丘尼二比丘尼应分。一比丘尼心生口言应受。三式叉摩尼二式叉摩尼应分。一式叉摩尼若心生口言应受。三沙弥二沙弥应分。一沙弥心生口言应受。三沙弥尼二沙弥尼应分。一沙弥尼若心生口言应受

佛在舍婆提。有一居士。请佛及僧明日食。佛默然受。居士知佛默然受已。从座起头面礼佛足绕竟还归。是夜办种种饮食。早起敷床座。遣使白佛。食具已办。唯圣知时。僧着衣持钵入居士舍。佛住精舍迎食分。是居士见众坐定。自行澡水。上座中座多美饮食。下座及沙弥。与六十日稻饭胡麻滓合菜煮。与诸居士与众僧多美饮食竟。自行澡水。取小座具僧前坐听说法。上座舍利弗说法竟。从座出去。是时罗睺罗作沙弥。食后行到佛所。头面礼佛足一面立。诸佛常法。比丘食。后如是劳问。多美饮食饱满不。尔时佛问罗睺罗。僧饮食饱满足不。罗睺罗言。得者足不得者不足。佛问。何以作是语。罗睺罗言。世尊。诸居士与上座中座多美饮食饱满。下座及沙弥与六十日稻饭胡麻滓合菜煮。是时罗睺罗羸瘦少气力。佛知故问罗睺罗。汝何以羸瘦少气力。罗睺罗即说偈言

  食胡麻油大得力　　有食酥者得净色
  胡麻滓菜无色力　　佛天中天自当知

佛知故问罗睺罗。是僧中谁作上座。答和上舍利弗。佛言。比丘舍利弗不净食。长老舍利弗闻。今日世尊呵言。比丘舍利弗不净食。闻竟吐食出。尽寿断一切请食及僧布施。常受乞食法。诸大贵人居士。欲作僧食。欲得舍利弗入舍。白佛。愿佛敕舍利弗还受请。佛告诸人。汝等莫求舍利弗使受请。舍利弗性。若受必受若弃必弃。舍利弗非适今世有是性。乃前过去亦有是性。若受必受若弃必弃。汝等今听。尔时世尊广说本生因缘。过去世时有一国王。为毒蛇所螫。能治毒师。作舍伽罗咒。将毒蛇来。先作大火。语蛇言。汝宁入火耶。宁还嗽毒。毒蛇思惟。唾竟云何为命故复嗽已吐。不可还啖。我宁入火死。如是思惟竟投身火中。佛语诸人。蛇者今舍利弗是。此人过去世。若受必受。若弃必弃。今亦如是。是时佛种种因缘呵舍利弗竟。告诸比丘。从今日应行上座法。云何应行。若闻揵捶声若时到声。应疾往坐处坐。观中座比丘下座比丘。或有坐不应法者。若坐不应法者。应示。是比丘若不觉。应弹指。弹指不觉。应语比座。安祥语。若上座施主与僧食时。不应先食。待得遍。闻等供声乃食。一切僧应随上座法行

佛在王舍城。王舍城中有居士。名尸利仇多。大富多钱财。有大德力。是外道婆罗门弟子。此人疑沙门瞿昙有一切智不。行到佛所。问讯佛竟一面坐。佛为尸利仇多说法示教利喜。是应行是不应行。种种因缘说法已默然。居士尸利仇多闻法已。叉手向佛白佛言。沙门瞿昙。明日我舍食。怜愍故。以彼应度故。佛默然受请。时尸利仇多见佛默然受。从座起为佛作礼。绕佛三匝而还到舍。于外门间作大火坑。令火无烟无焰。以沙覆上。如是心生口言。若沙门瞿昙是一切智人。当知是事。若非一切智人。沙门瞿昙并诸弟子。当堕此坑中。即入舍敷不织坐床上敷白[疊*毛]。如是心生口言。若是一切智人。当知是事。非一切智人。并弟子当堕。尸利仇多以毒和饮食。心生口言。若是一切智人。当知是事。非一切智人。当中毒死。早起遣使白佛。饮食已办佛自知时。尔时佛语阿难。令僧诸比丘皆不得先佛前行。一切应在佛后。阿难受教。令诸比丘皆不得先佛前行。一切应在佛后。令僧竟。是时佛着衣持钵在前行。诸比丘从佛后。佛入尸利仇多舍。佛变火坑作莲华池。满中清净水。既甘而冷。水中有赤白种种色莲华。遍覆水上。时佛与僧皆行广叶莲华上。告尸利仇多。汝居士。当除心中疑。我实一切智人。佛作是语竟。入舍上不织床。变令成织。告尸利仇多。汝居士。当除心中疑。我实一切智人。是尸利仇多见二神力。信心即生清净。恭敬尊重于佛。是时尸利仇多欢喜叉手。白佛言。食中有毒。僧或得病。愿佛小待。更作饮食。佛言。居士。但施此食。僧不得病。佛告阿难。僧中令未唱等供一不得食。阿难受教。即僧中令。大德僧。佛约敕。未唱等供一不得食。是时佛如是咒愿。淫欲嗔恚愚痴是世界中毒。佛有实法。除一切毒解除舍已。一切诸佛无毒。以是实语故。毒皆得除。佛作是语。食即净无毒。是时居士尸利仇多。从座起行澡水。手自斟酌多美饮食。饱满多美饮食。饱满与竟。洗手摄钵。尸利仇多。取小座具。于佛前欲听法佛随意说。甚深净妙法。尸利仇多。即于坐处得诸法法眼净。如是尸利仇多。得法见法知法。善法净法心除疑悔。不信他法。得不随他语。佛法中得无畏力。从座起头面礼佛足。大德。我从今日归依佛归依法归依僧。持五戒为优婆塞。佛为尸利仇多。更多说法示教利喜。佛从座起而还。以是因缘故会僧。会僧已告诸比丘。从今日不得在佛前行。不得和上阿阇梨一切上座前行。从今日未唱等供不得食。若食得突吉罗罪

憍萨罗国一住处。二部僧得衣物。比丘多比丘尼少。比丘言。我取二分。汝取一分。比丘尼言。中半分。诸比丘不知当云何。白佛。佛言。比丘比丘尼等分。式叉摩尼沙弥沙弥尼。四分与第四分

佛在王舍城。有居士。名婆提。为佛及僧作房舍。极好庄严多备饮食。多比丘会。千二百五十。便有居士。为大众布施衣物。是居士言。佛听于众中大声唱。是事白佛。佛言。听布施时于众中大声唱。比丘平地立唱。众多不闻。是事白佛。佛言。听座上立唱。立唱亦不闻。高处立唱亦见亦闻。更有居士。见大众集布施衣物。作是言。佛若听我衣摩罗鞞诃罗施。佛言。听摩罗鞞诃罗施。众人言。佛若听我人捉衣角去。曳土中或脚蹑上。是事白佛。佛言。听着绳上系两头各一人捉中央。故曳泥土中。是事白佛。佛言。听作木叉擎。时小儿男女擎木叉。道中见人作伎乐饮食嬉戏。舍衣绳着一面。走往看失衣物。佛言。若六岁以下至无岁。及式叉摩尼沙弥沙弥尼。为五众担衣。居士更言。佛听持香炉在前。白佛。佛言听。时众默然行。诸外道人嫉妒言。是沙门释子如担死人出无异。居士言。佛若听我如世俗法作唱伎乐去。佛言听。有一居士。见大众集。多施衣物。居士言。佛若听处处唱赞。佛言听。无人受是衣物。佛言。听先作羯磨使一人受。无人守。佛言听。作羯磨使一人守。比丘无五法。不应作羯磨受衣物。何等五。不知得不知不得。不知受得物。不知价。不知数。若着不知忆念处。比丘有五法。应作羯磨受衣。知得。知受得物。知价。知数。若着忆念处

憍萨罗国一住处。二部僧得衣物。比丘尼言。佛听我布施物各着一处。佛言听。诸比丘尼无人布施衣物饮食卧具随病药。或有人。少多与余人。轻笑言。爱念妇故与。诸比丘尼白佛言。听我施物还着一处。佛言听。无人分是衣物。佛言。知分物人。应作羯磨。无五法。是比丘不应羯磨作分衣人。何等五。不知相。不知衣色。不知衣价。不知数。若与若不与不忆念。比丘有五法。应作分衣人。知衣相。知衣色。知衣价。知数。与不与忆念。诸比丘尼分衣时赞叹。是好是不好。乱众。佛言。分衣时不应赞叹。乱众故应默然受衣分

佛在舍婆提。尔时祇洹有人。为新房舍因缘故作饮食。多比丘会。千二百五十。诸比丘乱入乱坐乱食。无有次第。或有比丘先食入。或有比丘食时入。或有比丘食后入。是事白佛。佛言。应唱时到。虽唱时到远处不闻。是事白佛。佛言。应打揵捶。虽打远处不闻。佛言。应打鼓。平地打鼓远处不闻。佛言。应立埵上打。亦不闻。佛言。应高处立打。亦见亦闻。或时无有看食人。食未办未熟。虽时到食不好。或时有看食人。食办食熟时到食好。是事白佛。佛言。看食人应僧中作羯磨

憍萨罗国一住处。二部僧得衣物。比丘少比丘尼多。比丘言。是衣物作中半。半与比丘僧。半与比丘尼僧。比丘尼言。我本众少。诸比丘取二分。我等取一分。今日多。何以与半分。是事白佛。佛言。比丘比丘尼应等分。式叉摩尼沙弥沙弥尼四分与第四一分

有时檀越施僧食。在空露地。盘上有残饼。箧中有残饭。木盆器中有羹。诸外道异学嫉妒。持酒糟着诸饭羹中。如是思惟。是食不净。使出家人不得食。诸比丘不知当云何。便白佛。佛言。若可却者却。余可食之。若诸比丘共沙弥传钵食。比丘转食与沙弥。沙弥食转与比丘。比丘洗手更从沙弥受。意中疑。此或不净食。便白佛。佛言。若一心实与沙弥钵食。是为净。诸沙弥持器盆筐盔杓行食时。比丘为沙弥受食分。若沙弥行食。比丘为受。比丘心疑。将非触食。不知云何。是事白佛。佛言。比丘受触无所犯。诸比丘食竟。以食不净钵与沙弥白衣。沙弥白衣洗钵竟。还着诸盆筐器中。诸比丘思惟。是或不净。佛言。一心与净人钵。是为净。诸比丘有檀越。施食在空地。诸比丘食竟。舍诸食器去。风雨污泥不净。佛言。器物净洗应着覆处。诸比丘二三用澡豆。腻故不尽。木刮却腻。与澡豆净洗。取水极远。诸居士以水布施。居士言。知水极远。何以大用水。诸比丘不知当云何。佛言。若一心二三遍。与澡豆净洗。是事应净。时有潢水。僧取用。是中有象马驴牛羊猪狗。皆入中饮屎尿不净。树叶华果皆堕水中。烂臭不净。是事白佛。佛言。水中不净者可却。便却余水应饮。诸比丘白佛。水浊碱。应得饮不。佛言先疑不净不应饮。若先不疑应饮

憍萨罗国有一住处。僧得衣物施。非一切处在。羯磨比丘不知当云何。便白佛。佛言。是衣物应作二分。如是言。是分属上座。是分属下座。如是言。是分属下座。是分属上座。作竟即应羯磨竟。异比丘来。不欲与不应与。若不作如上法。不应受。若受得突吉罗罪。若不如是作出界。得突吉罗罪。亦应共异比丘分。是衣物中应作价数。如是分我应取。余残属汝我如是分。我应受。若作如上法。应羯磨竟。异比丘来。不欲与不应与。若不如是作。应与余比丘分。若不如上法。不应受出界。得突吉罗罪。若一比丘言取是衣。中一衣言我分。足余残属汝等。如是作应羯磨法竟。余法如上。是衣物。应与一比丘作羯磨。云何应与。一心会僧。应一比丘众中唱。大德僧听。是衣物。是住处现前僧应分。若僧时到僧忍听。比丘某甲僧羯磨与。如是白。白四羯磨。僧某甲比丘羯磨与衣物竟。僧忍默然故。是事如是持。是比丘受衣竟。不肯还归。作是言。何处善法善言善施法与。都是僧中我何以还归。诸比丘不知当云何。便白佛。佛言。清净故与。如是言。是比丘还归便好。不归应强夺。是比丘应教突吉罗罪忏悔

优波离问佛。佛听诸比丘所著衣。覆身衣拭身巾拭脚巾拭面巾僧祇枝泥洹僧。是衣名何等。佛言。名波迦罗(晋言助身衣也)

优波离问。是衣云何受。答言。是衣如是言。是波迦罗衣我受用故。何等人边应受。佛言。五众边应受

优波离问佛。上座比丘不聪明。作非法遮。如是成遮不。佛言。不成。复问。持戒作非法非善遮。如是成遮不。佛言。不成

优波离问佛。如佛所说。遮如法羯磨。不成遮羯磨。一切不成遮耶。佛言。不也优波离。或有沙弥。受具戒时心悔。不用受具戒。作是言。我不用受具戒。是言成遮。沙弥尼受六法。作式叉摩尼。作是言。我不用受六法。是言成遮。式叉摩尼受具戒时。作是言。我不用受具戒。是言成遮。若比丘有僧伽婆尸沙罪。与作波利婆沙摩那埵本日治。作阿浮呵那羯磨。是比丘言。莫作。我不用是言成遮。若比丘十四人应僧中羯磨。作是言。我不用。是言成遮。优波离问。有比丘被摈欲忏悔。忏悔时下意随僧法。界外得作羯磨解摈不。佛言。不得。作解摈者得罪

优波离问佛。佛余处说。有二因缘知破僧。一僧中唱。二受筹。有贼住。僧中唱行筹。是名破僧不。佛言。不破。与学沙弥。僧中唱行筹。是名破僧不。佛言。不破。优波离问。四人本白衣。众中唱行筹。破僧不。佛言。不破。数满一比丘男根转为女。破僧不。佛言。不破

优波离问。若草敷座若长床。得共未受具戒人坐不。佛言。可坐。得共黄门坐不。佛言。不可。与学沙弥可共坐不。佛言。可坐。二与学沙弥。可共坐不。佛言。不可

优波离问佛。几许为长床坐处。佛言。极小床容四人坐处。是名为长床

有居士。于祇洹中作房舍。是房舍中比丘。着衣持钵入舍婆提城乞食。居士见问。汝何以乞食。比丘言。不能得食故。居士言。长老可还。我当为长老送食。言已便送。比丘问。是食与谁。使人言。是食与僧。比丘即将使人。持食着僧食处。是比丘明日更着衣持钵。入舍婆提乞食。居士见复问。长老何以乞食。比丘言。无食故乞。居士言。我昨日送食。何以不啖。比丘言。汝所送食我问使人。是食与谁。使人言。与僧。我即持着僧食处。是故不食。居士言。我不为一切僧送食。为住我房中僧送食。比丘不知当云何。便白佛。佛言。若施主供养物。为住房舍中。僧住房舍比丘应取

有一居士于祇洹中作房。是居士过数日。到祇洹中欲听法。入所作房日暮打揵槌欲听法。诸比丘闇中坐说法。居士言。大德然灯。比丘言。无苏油。居士言。我与大德遣人送。即送比丘言。与谁。使人言。与僧。比丘即将使人。持苏油着僧然灯处用。居士余时。到祇洹入自所作房欲听法。如本日暮打揵槌。僧闇中坐说法。居士言。大德然灯。比丘言。无苏油。居士言。我前与送。何以不然。比丘言。汝送与僧。我便将使人。持苏油着一切僧然灯处。居士言。我不与一切僧送苏油。为住房比丘送。比丘不知当云何。便白佛。佛言。若是供养物为住房中比丘。是物住房比丘应用。应分取涂脚苏油。革屣衣钵果药亦如是。佛言。若檀越言。大德于中几时住。随大德所用听用。若言是物属汝听担出去。得持去。诸比丘僧卧具。不着覆身衣便取用。僧卧具弊失色不好。垢臭有虱。是事白佛。佛言。从今日僧卧具。不听比丘不着覆身衣便取用。若用得突吉罗罪

诸比丘不知长几许作覆身衣。佛言。极下乃至能覆身三分。何等三。胸腰膝。诸比丘不护惜用僧卧具。余比丘以是事白佛。佛言。僧卧具不得不护惜用。若不护用得突吉罗罪。五事不护惜。何等五。水日尘垢揩突。是为五不护惜。诸比丘用僧卧具雨中立。卧具失色染汁流出。是事白佛。佛言。从今日不得着僧物雨中立。若立得突吉罗罪。比丘用僧卧具向火炙身。是衣烟臭色弊减损脆烂襵皱。佛言。着僧卧具不应向火炙身。若炙得突吉罗罪。若被着脊上向火炙身无罪。比丘着僧卧具。入大小便处。入洗大小便处。入浴室。是衣卧具失色垢臭生虱。佛言。从今日不得着僧卧具衣入大小便处及洗大小便处入浴室。若着入得突吉罗罪。六群比丘欲剃发。一小比丘剃未竟未着袈裟。六群比丘驱小比丘去汝小。佛言。剃发时小比丘。有少许发在。不应驱去若驱去得突吉罗罪。僧剃刀镊剪爪刀子。诸比丘已磨利欲用。六群比丘来驱去。我上座汝小。与我用。诸比丘不与。斗诤骂詈。佛言。不应与。若有先受磨利者。用竟后应与他。六群比丘见诸小比丘入大小便处。入洗大小便处。入驱去言。我上座汝小。令诸无病者得病。病者增剧。佛言。大小便处洗大小便处。后入者不应驱先入者出。若驱得突吉罗罪。六群比丘。浴室中语余比丘。汝起去。我是上座汝小。佛言。浴室中上座不应驱下座去。待出时若驱得突吉罗罪

佛在舍婆提。时长老阿难。在多众中说法。有第一上座来。阿难教起。第二第三亦如是起。是众散去皆不一心。诸白衣言。大德。此中无小食亦无中食。上座来何以起。使众散去破听法众。若上座欲上座处坐。何以不先入。是阿难说法。不知初不知后。不知次第不知因缘。为谁故说。是事白佛。佛言。从今日说法时听法时。上座来不应起。上座亦不应驱下座起。若自起若驱他起。俱得突吉罗罪。佛言。若和上阿阇梨来。恭敬故起。不应语余人起。若语余人起。得突吉罗罪。从今日粗[打-丁+坒]长绳床上。听三人共坐。若三岁中间得共坐。四岁不得共坐。细[打-丁+坒]绳床上听二人共坐。独坐床上听一人坐。有僧釜镬盆。诸比丘用煮染汁竟着余处。持衣着染汁中。六群比丘来语余比丘。与我釜盆瓶。我上座汝小。我欲用。持染汁泻着一物中竟。复泻着一物中。染汁渐少衣色变黑。诸比丘不与。斗诤骂詈。是事白佛。佛言。不应与。比丘若先取用竟。后应与上座。染汁残少许在。上座来索不欲与。佛言。若少许残。可却着余处者。应与。诸比丘取僧园中树木。用煮饭煮羹煮肉煮汤煮药煮染。旧比丘不喜。如是言。我等经营种树木勤苦。汝等客比丘。不语我默然取烧。佛言。应语旧比丘。佛言。从今日僧园中树华。应取用供养佛塔及阿罗汉塔。若有净人应使取果啖。树上大木。四方僧应用作梁椽。树皮枝叶。诸比丘自在用

佛在舍婆提。给孤独作祇洹竟。种种庄严。四事供养与僧。诸比丘不受言。佛未听我等受如是庄严房舍。是事白佛。佛言。听受清净房舍。六群比丘驱坐禅比丘。汝起。我上座汝小。是事白佛。佛言。坐禅时不应计大小。不应驱去。若驱去得突吉罗罪

诸比丘用僧水洗脚。六群比丘驱去。汝小我上座。是事白佛。佛言。洗脚时不应计大小驱去。若驱得突吉罗罪。诸比丘促僧拭脚物浣捩晒。欲拭复罗革屣。六群比丘言。汝起去。我上座汝小取拭脚物来我用。诸比丘不与。斗诤骂詈。是事白佛。佛言。不应与。若前人用竟应与

有一住处。旧比丘属塔物自贷用。是比丘死。诸比丘不知当云何。是事白佛。佛言。衣钵物还计直输塔。余残僧应分。一住处一比丘。衣钵物为塔用。是比丘死。诸比丘不知当云何。是事白佛。佛言。塔物计直还取。现前僧应分。一住处一比丘。贷取四方僧物私用。是比丘死。诸比丘不知当云何。是事白佛。佛言。财物还计直输四方僧。余残现前僧应分

一住处一比丘。衣钵物贷四方僧用。是比丘死。诸比丘不知当云何。是事白佛。佛言。衣钵物四方僧物计直。还现前僧应分。客比丘旧比丘亦如是

一比丘衣钵寄居士。居士失去。是比丘往居士边索。居士言失。比丘言。汝自失我不失。若失汝自偿。诸比丘是事白佛。佛言。若好看失不应偿。若不好看失应偿

有贾客。寄比丘衣物。比丘失去。是贾客往比丘边索。比丘言。失去。贾客言。汝自失我不失。若失汝自偿。诸比丘是事白佛。佛言。若得自在不应偿。若不得自在应偿

有居士。祇洹中作房舍竟设饭食。众多比丘千二百五十。是时四方国土不知法人皆来会。有布施诸比丘者。诸比丘咒愿时赞佛言。佛大力大德。赞法大德大力。赞僧大德大力。赞大德舍利弗目揵连阿那律难提金毗罗。如是三宝无数无量阿僧祇。是中或有人持佛名字。或人持法名字。或人持僧名字。或人持舍利弗目揵连阿那律难提金毗罗名字。或人持无数无量阿僧祇名字。是大众会不久各还散去。是人辈各还田舍聚落。余时诸比丘出诸国田舍乞。有持佛名字者。言佛来与布施。持法名字者。言法来与布施。持僧名字者。言僧来与布施。持舍利弗名字者。言舍利弗来与布施。持目连阿那律难提金毗罗。无数无量阿僧祇如是等名字者。言无数无量阿僧祇来与无数无量阿僧祇布施。诸比丘不受是食。是事白佛。佛言。是边国人不知为是比丘故与食。而名与佛法僧舍利弗无数无量阿僧祇饮。食自在应受

有比丘病。余住处有亲。亲比丘来问讯。病比丘语坐。坐已问讯。客比丘小住便起欲去。病比丘言。何以去。答我不持衣钵来。病比丘言。我与汝衣即与。客比丘一处宿。明日担此衣去。病比丘见言。我衣莫担去。客比丘言。是衣实与我。病比丘言。非常与汝。受故与汝。客比丘言。是实常与。病比丘不知当云何。便白佛。佛言。是非实与。清净故与。是比丘应还归衣。软语归好。不归强夺取。教受突吉罗罪忏。佛在祇洹精舍住。时火灾渐次来烧祇洹。是时佛咒愿言。我一切漏尽真阿罗呵得佛道。是实语故火即灭。诸比丘持僧卧具出着一处。火灭后不知此诸卧具本属何房舍。是事白佛。佛言。应作帜作帜故不可分别。应更作异相。作异相故不可知。应作轮应作券文应作德字。如是作故不识。佛言。应作字。是物某甲某甲居士所布施。属某甲某甲房舍。是卧具物虽知有所属。复不知是物为属何重阁。何者属上阁。何者属中阁。何者属下阁。佛言。应了了上作字。是属上是属中是属下。给孤独居士作楼施僧。僧不受。是事白佛。佛言。听受楼。给孤独居士施僧褥。僧不受。白佛。佛言。听受褥。居士白佛。愿听我缕文氍毹施僧。佛言。除作女像。余尽听

给孤独居士。作五百独座漆画床并褥施僧。僧不受言。佛未听我等畜如是上好独坐床。是事白佛。佛言。听受如是净上好独坐床

佛在舍婆提。居士给孤独死。以是故。只陀槃那破坏无人治。诸比丘是事白佛。佛言。应作羯磨。如七法衣法中说。佛在舍婆提。诸人亲里死。以白[疊*毛]裹。弃着死人处。如是思惟。是人死用是[疊*毛]为持布施僧。可得福德。思惟竟。即持白[疊*毛]诣祇洹。布施诸比丘。诸比丘不受言。佛未听我等受弃死人处衣物。是事白佛佛言。听受

有一贫穷人死。以衣裹弃死人处。如是思惟是死人用是衣为当布施僧可。得福德。思惟竟即持诣祇洹。布施诸比丘。诸比丘不受言。此衣无主。当从谁受。是事白佛。佛言。无余人法应受。彼人亲里死。如是思惟。更用异衣裹。异衣裹不净。还从比丘索本衣。裹送着弃死人处。诸亲里往到比丘所索本衣。诸比丘不与。是事白佛。佛言。应与。亲里裹死人。如是思惟。是衣不吉。裹二死人。谁当受者。并死人弃。弃竟还去。是衣即失。诸比丘还从彼人索。答言。已失。以是事白佛。佛言。出来软语索得好。不得法应强索

有一比丘。赊酤酒未偿便死。酒主从诸比丘责酒价。诸比丘答。此比丘在时何以不责。酒主言。偿我酒价。不偿者出汝恶名声。释种沙门饮酒不肯偿价。诸比丘不知当云何。以是事白佛。佛言。是比丘有衣钵物应用偿。若主无物应取僧物与偿。何以故。恐出诸比丘恶名声故

佛在舍婆提。舍婆提诸贾客欲发去。是估客道中空泽畏处。有极好精舍。估客入精舍中。见诸比丘默然坐不眠不睡坐禅入深禅定。是估客见诸比丘。心生厚信清净。语诸子弟。汝看少多有饮食者取来。布施是好比丘。子弟答。更无余食。有少葡萄。估客言。随少多与。若不布施无福德。即以葡萄施诸比丘。诸比丘各各分。人得五枚。诸比丘各各觅净人。或得或不得。不知当云何。以是事白佛。佛言。都合诸葡萄一处火净。应食

佛在阿罗毗国。诸上座比丘初夜坐禅。中夜各各还房宿。道中诸恶虫怖师子怖虎豹豺罴怖。以是事白佛。佛言。从今日听然炬行。末利夫人诣祇洹欲听法。诸比丘闇冥中说法。末利夫人言。大德然灯。诸比丘答。无苏油。夫人言。我当送。后日即送。诸比丘即然灯。着地不大明。末利夫人即与灯树。诸比丘言。佛未听我等受灯树。诸比丘不知当云何。是事白佛。佛言。从今日听受灯树

佛在王舍城。六群比丘以不净脂。用师子虎豹豺罴脂涂脚已。到他象马牛羊驴厩中。是畜生等闻脂臭。皆拽顿羁靽惊走。诸人问。畜生何以惊走。六群比丘言。我有大威德神力。是故惊走。诸居士嗔呵骂言。沙门释子自称善好有德。似如猎师。用恶兽脂涂脚。使畜生惊怖散走。而言。我有大神力威德。诸比丘少欲知足。闻是事心不喜。是事白佛。佛言。从今日诸恶兽脂。不应用涂脚。若用得突吉罗罪。佛在舍婆提。波斯匿王诣祇洹欲听法。其日布萨说戒。诸比丘言。大王。汝出。我等欲作法事。王言。我欲听法事。诸比丘言。佛未听我等未受大戒人前说戒法事。是王必欲得听。诸比丘不知当云何。是事白佛。佛言。从今日听在波斯匿王等诸王前说戒。大臣兵吏遣去。时波斯匿王得心清净

有一人。大有诸地布施诸比丘。诸比丘不受。以是事白佛。佛言。从今日听众僧受用。作园林别房房舍经行处受用。五比丘着五三肘衣。入聚落乞食。是衣曳地。脚蹑土污风吹露身。以是事白佛。佛言。从今日听诸比丘受泥洹僧。着入聚落。泥洹僧。长四肘广二肘。阿罗毗国诸比丘。日日檐石土墼[鹿*瓦]甎泥土。治佛塔精舍。衣不净垢污行乞食。诸居士嗔呵骂。沙门释子自言善好有德。诸外道婆罗门尚着净衣来乞食。是释子今著作垢衣来乞食。如作胡麻油人。如土作人。诸比丘以是事白佛。佛言。从今日若作时。听着内小泥洹僧

佛在迦毗罗卫国。诸贵释子出家。戏笑露胸行乞食。婆罗门言。诸释子自言。善好有德。今戏笑露胸乞食。使众人见。以是事白佛。佛言。从今日听着僧祇枝用覆胸入聚落乞食。诸比丘早起。入聚落乞食。得食着一面。待时当食。是时大风雨尘土入钵食中。诸比丘心悔言。是食更受。日时到。求净人不可得。诸比丘不得净人日时欲过。是事白佛。佛言。从今日听五尘不受应食。米尘谷尘水尘衣尘风尘。是为五尘

憍萨罗国诸比丘。得甘蔗作分。诸上座得多无齿。中座下座及沙弥得少。齿利啖即尽。眼看上座欲更得。以是事白佛。佛言。从今日饮食时。应等分

憍萨罗国众多比丘夏安居。诸居士等见众多比丘。便欲次第请食。若自减食分布施比丘。或半月食。或一月食。诸比丘受食竟。自恣已夏后月。分衣物分食分竟。各各自出去。余比丘憍萨罗游行。欲至舍婆提到住处。非时大雨堕。诸比丘问。是中有檀越能与食不。有比丘言无。问有僧食。不答本有僧食。夏后月安居竟。分衣物分食分已。各自去。诸比丘少欲知足。闻是事心不喜。呵责诸比丘言。何以名比丘。僧食物夏安居竟。各自分去。诸比丘种种因缘呵竟。以是事白佛。佛言。从今日僧食不应分。若分得突吉罗罪。从今日听树下安居时。若有好树让上座。如树下露地亦如是。有事应羯磨十四人

佛在婆伽国。国中有贵人子。名满提。请佛及僧明日于舍食。佛及僧默然受请。满提知佛受请。为佛作礼绕三匝还归。是夜办种种饮食布坐处。遣使白佛。食具已办唯佛知时。佛与比丘僧前后围绕俱入满提舍。佛在僧中敷座处坐。满提子弟。不信佛法僧。皆是婆罗门。边国人下食时。不疾与少与不一心与。与时触比丘手。比丘语言。高举手莫触我手。子弟言。我非白癞。非旃陀罗。汝等何以恶我。诸比丘不知当云何。是事白佛。佛言。若不轻与得受。若轻故触手不应受

憍萨罗国一住处。一比丘死。是死比丘。以衣钵物寄比丘尼精舍。诸比丘言。我等应分。比丘尼言。我等应分。比丘不知云何。以是事白佛。佛言。若比丘死前。寄比丘尼衣钵物。现前比丘僧应分

憍萨罗国一住处。比丘尼死。是死比丘尼。以衣钵物寄比丘精舍。诸比丘尼言。我等应分。比丘言。我等应分。比丘尼不知云何。以是事白佛。佛言。若比丘尼死前。寄比丘衣钵物。现前比丘尼僧应分

佛在舍婆提。释子跋难陀死。衣钵直三十万两金。憍萨罗国王波斯匿言。是人无儿子故。是物应属我。佛遣使语波斯匿王言。大王。王赐城邑聚落人禀。颇少多与跋难陀禀分不。王言。不与。佛言。谁力故令得生活。是应分。僧力故今应取。王闻好教便止。诸刹利辈言。是比丘与我同姓同生。同是刹利种。是衣钵物应属我等。佛遣使语刹帝利言。汝等作国事大事官事。颇问跋难陀不。答不问。跋难陀不在时汝作官事。颇待跋难陀不。答言。不待。佛言。跋难陀共僧羯磨。跋难陀不在时僧不羯磨。是衣钵物应属僧。诸刹利闻是好教便止。诸亲族中表内外皆言。是跋难陀是我伯叔父舅外甥兄子。是衣钵物应属我等。佛遣使语言。汝等嫁女娶妇会同取与钱财颇待跋难陀与分不。答言。不。佛言。诸与跋难陀衣食分者。应得是衣分。跋难陀僧与食故。是衣钵物应属僧。诸亲族闻是好教便止。跋难陀衣钵物寄在余处。是跋难陀于余处死。寄物处诸比丘言。是衣钵物我等应分。死处诸比丘言。是衣钵物我等应分。以是事白佛。佛言。是诸衣钵物。在界内现前僧应分。跋难陀衣钵物。处处出息与人。应异处死。异处人负其债。死后负债处诸比丘言。是物我等应分。死处诸比丘言。是物我等应分。佛言。负债处界内。彼比丘应分。跋难陀衣钵物。保任出息余处死。余处出息。余处保任。死处诸比丘言。是衣钵物应属我等。出息处诸比丘言。是衣钵物应属我等。保任处诸比丘言。是衣钵物应属我等。佛言。保任处界内现前僧应分。跋难陀衣钵出息质物。跋难陀异处死。质物复在异处。取钱人亦在异处。死处诸比丘言。是财物应属我等。质物处诸比丘言。是财物应属我等。取钱处诸比丘言。是财物应属我等。佛言。质物处界内现前比丘应分。跋难陀衣钵财物。与他作券出息。跋难陀异处死。取钱者在异处。作券人亦在异处。死处诸比丘言。是物应属我等。取钱处诸比丘言。是物应属我等。有手执券处诸比丘言。是物应属我等。诸比丘不知当云何。以是事白佛。佛言。有手执券处界内现前比丘应分。若手执券若质物。是二无异佛在舍婆提。牟罗破求那比丘死。是衣钵物。本寄长老阿难。牟罗破。求那在异处死。长老阿难在异处。所寄衣钵物在异处死。处诸比丘言。是衣钵物应属我等。长老阿难所住处诸比丘言。是衣钵物应属我等。寄衣钵物处诸比丘言。是衣钵物应属我等。诸比丘不知当云何。以是事白佛。佛言。阿难所在处界内现前比丘应分

十诵律卷第六十一


受十善戒经

    No. 1486

受十善戒经

        后汉失译人名

    十恶业品第一

如是我闻。一时佛在舍卫国只陀林须达长者美称夫人精舍中。与大比丘众一千二百五十人俱。尔时世尊以慈梵音告舍利弗。今为汝等说除十恶不善业报。谛听谛受。一心忆持慎莫忘失。十恶业者。一杀生业。二偷盗业。三淫欲业。四妄语业。五两舌业。六恶口业。七绮语业。八贪欲业。九嗔恚业。十愚痴业。舍利弗。汝今应当普教众生。清净身业。清净口业。清净意业。五体投地归依和上。诚心忏悔此三恶业。如是三说。既忏悔已。身业清净口业清净意业清净。次第应当自称其名。归依于佛。归依于法。归依于僧。如是三说。归依佛竟。归依法竟。归依僧竟。如是三说。复应问言。善男子善女人汝能持不。若言能持复应问言。汝今身心无过患耶。身过患者。出佛身血。杀阿罗汉。破和合僧。诽谤断善。逆佛正法不。若言不者。复当问言。汝心中念欲作五逆谤正法不。汝曾偷盗佛物法物贤圣僧物现在僧物招提僧物不。于母姊妹比丘尼边作不净不。若言不者。复当更教。汝今如是身心清净。大德忆念。我今欲受十善业戒。十不善业我已忏悔。唯愿大德。慈愍我故听我受持。尔时应教。优婆塞某甲。优婆夷某甲。汝今应当一心数息系念在前。过去七佛。现在释迦牟尼尊佛。及弥勒等未来诸佛。教念佛已应作是言。七佛僧听。释迦牟尼诸佛僧听。须陀洹斯陀含阿那含阿罗汉贤圣僧听。某甲优婆塞。某甲优婆夷。身口意净堪为法器。今欲乞受十善心戒及八戒法。如是三白。然后教言。我归依于佛。归依于法。归依于僧。如是三说。弟子某甲。归依佛竟。归依法竟。归依僧竟。如是三说。某甲忆念坚持汝身。持身如佛。持身如法。持身如僧。身三业者。一不杀生。二不偷盗。三不淫欲。如是身三汝当受持。一日十日乃至终身。若言能持。复当问言。汝今欲作少分善不。多分善不。满分善不若言能者复当白言。事实如是当随师教弟子某甲。归依于佛。归依于法。归依于僧。如是三说。归依佛竟。归依法竟。归依僧竟。如是三说。某甲忆念坚持汝口持口如佛。持口如法。持口如僧。口四业者。一不妄语。二不两舌。三不恶口。四不绮语。如是口四。汝当受持。一日十日乃至终身若言能持。复当问言。汝今欲作少分善不。多分善不。满分善不。若言能者复当白言。事实如是。当随师教。弟子某甲。归依于佛。归依于法。归依于僧。如是三说。归依佛竟。归依法竟。归依僧竟。如是三说。某甲忆念坚持汝心。持心如佛。持心如法。持心如僧。意三业者。一者贪欲。二者嗔恚。三者愚痴。如是意三汝当受持。一日十日乃至终身。若言能持。复当问言汝今欲作少分善不。多分善不。满分善不。若言能者。复当白言。事实如是当随师教。若受十善不持八戒终不成就若毁八戒十善俱灭。弟子某甲。从今清旦至明清旦。大德忆念。大德当为我作和上。八戒法者。应当至心坚持八戒。归依于佛持心如佛。归依于法持心如法。归依于僧持心如僧。如是三说。归依佛竟。归依法竟。归依僧竟。如是三说。大德忆念。从今清旦至明清旦欲受八戒。唯愿大德慈愍听许。复应告言。汝能受持八戒斋不。若言能者。汝当持心。心如诸佛及阿罗汉。若言能者。复当告言。汝从前际至于今际于其中间。若身口意犯舍堕法不。如此之罪乃至根本最大重罪。今于三世诸佛阿罗汉前和上僧前。至诚发露五体投地忏悔诸罪。是名行布萨法。既布萨已名清净住。堪为法器。次当受持如来八戒。汝能持不。如是三问。八戒斋者。是过去现在诸佛如来。为在家人制出家法。一者不杀。二者不盗。三者不淫。四者不妄语。五者不饮酒。六者不坐高广大床。七者不作倡伎乐故往观听。不着香熏衣。八者不过中食。应如是受持

  不杀亦不盗　　不淫不妄语
  远酒避花香　　高床过中食
  圣人皆远离　　如是等八法
  汝等应受持

持此受斋功德。不堕地狱不堕饿鬼不堕畜生。不堕阿修罗。常生人中正见出家得涅槃道。若生天上恒生梵天。值佛出世请转法轮。得阿耨多罗三藐三菩提。尔时世尊为赞叹此法。而作颂曰

  若能行十善　　随顺正法教
  生生常见佛　　身意悉开解
  永离诸苦缚　　疾成无上道
  若人持八戒　　随律顺毗尼
  如诸佛正法　　受持不毁犯
  当知身与意　　俱时得解脱
  此名涅槃路　　诸佛之所行

说是偈已告舍利弗。汝好受持十善八戒。慎莫忘失破灭法种。普为一切天人广说。舍利弗白佛言。如是如是。当谨受持。时舍利弗及会听者。闻佛所说欢喜奉行

    受十善戒经十施报品第二

  佛告舍利弗　　汝今应当知
  一切受生者　　无不爱身命
  是故应行施　　普慈等众生
  视众如眼目　　是名不杀戒
  过去来今佛　　一切智所说
  恕己可为喻　　勿杀勿行杖
  若见杀生者　　如刀刺其心

  普视众生己无异　　持是不杀生天上
  常值诸佛菩萨众　　所以受持不杀戒
  为施一切无畏故　　命终生于忉利天
  象马玉女相娱乐　　梵天摩尼琉璃殿
  色如白银黄金花　　常坐七宝妙座上
  金机宝器七宝花　　无量天女作妓乐
  捧足举宫游虚空　　头戴宝冠坐正殿
  舍除贪淫入正受　　值遇诸佛说四谛
  悟解疾得须陀洹　　或有踊跃发大心
  未来当成菩提道　　亦生兜率焰摩陀
  首陀会天阿只多　　梵辅富楼光遍净
  上至阿迦腻吒天　　往反游戏诸天园
  与大慈悲菩萨俱　　坐卧进止同甘膳
  昼夜六时常听法　　弥勒天王常为说
  不退转行大法轮　　未来必当见弥勒
  降魔成佛转法轮　　于彼佛法得出家
  复见贤劫千如来　　毗楼至佛为授记
  阿耨多罗三菩提　　是名不杀最胜果
  亦名慈悲梵行本　　一切诸佛之所说
  一切诸佛之所行

  一切爱眼目　　爱子亦复尔
  爱寿命无极　　是故不杀生
  名为梵行最　　不杀无杀想
  亦不瞰于肉　　见杀者如贼
  必知堕地狱　　啖肉者多病
  断命自庄严　　当行大慈心
  奉持不杀戒　　必成菩提道

告舍利弗汝今当知。杀生之业当知极重。我昔与汝游巴连弗邑。彼大城中有长者女名提婆跋提。生一男儿端正无双。如红莲花天女无比。母甚怜念抱至我所。而白我言世尊。我儿可爱如天童子。我爱此儿过于我身百千万倍。我时告言。善女当知。一切凡夫自爱寿命。如海吞流终无厌足。汝今云何自言爱子。以何为证。时女白言。世尊。我爱此子。设使火起焚烧我身终不放舍

尔时世尊为化彼女。以神通力作四夜叉。各擎火山从四面至。火在远时。女自以身及随身服障蔽此子。火渐渐近。举手覆面以儿遮火。佛告善女。汝言爱子。云何持子障火自救。时彼女人白言。世尊。唯愿救我不惜此子。佛摄神力母子清凉。即发无上正真道心。佛告女人。汝爱自身及爱汝子。云何自杀及教他杀。当知杀生受大恶报。必定当堕极剧苦处阿鼻地狱。系属法律阎罗王所。何等名为极重法律。彼阎罗王昼夜六时说杀生报有十恶业。一者杀生之业。恒生刀山焰炽地狱。刀轮割截节节支解。作八万四千段。一日一夜六十亿生六十亿死。时阎罗王呵责罪人汝乐杀生今受此苦。是事乐不。汝今复当百千万劫偿他人债。终不可尽二者杀生之业。必定当生剑林地狱。有八万四千剑树。各高八万四千由旬。一一树生八万四千剑枝。一一枝生八万四千剑花。一一花生八万四千剑果。此杀生人寻剑树上。心遍一切诸剑树头其余支节遍可剑林。一一节遍八万四千剑枝。削骨彻髓剑花剑果无不周遍。身体碎坏如葶苈子。一日一夜八万四千生八万四千死。杀生之业其事如是。时阎罗王呵责罪人。汝乐杀生今受此苦。是事乐不。汝今复当百千万劫偿他人债。终不可尽。三者杀生之业生镬汤地狱。百千万沸肉尽出骨。置铜柱上自然还活。百千棘刺化为铁刀自割肉食还落汤中。一日一夜八万四千生八万四千死。时阎罗王呵责罪人。汝乐杀生今受此苦。是事乐不汝今复当百千万劫偿他人债。终不可尽四者杀生之业生铁床地狱。有一铁床纵广正等五十由旬。四方铁铓俱来射心。大铁网车轹其顶上劈足而出。一日一夜八万四千生八万四千死。杀生之业其事如是。时阎罗王呵责罪人。汝乐杀生今受此苦。是事乐不。汝今复当百千万劫偿他人债。终不可尽。五者杀生之业生铁山地狱。四方铁山状如铁窟。窟中出火从四面来。有五夜叉斫罪人身。分为四段掷于火中。四山便合碎散如尘。火鸟卒起铁嘴诸乌及以铁蛇。从支节入破骨出髓。一日一夜八万四千生八万四千死。杀生之业其事如是。时阎罗王呵责罪人。汝乐杀生今受此苦。是事乐不。汝今复当百千万劫偿他人债。终不可尽。六者杀生之业。生铁网地狱。有大铁山。高百千由旬。满中铁汤铁网在上。一一网间铁嘴诸虫无量无边从顶上入贯骨彻髓劈足而出。一日一夜八万四千生八万四千死。杀生之业其事如是。时阎罗王呵责罪人。汝乐杀生今受此苦。是事乐不。汝今复当百千万劫偿他人债。终不可尽。七者杀生之业。生赤莲花地狱。有一莲花八万四千叶。一一华叶状如刀山。高五由旬。百亿剑林同时火然。罪人坐中花一叶开。一叶开时火山剑林烧肉破骨。苦痛百端此相合时。百千刀山同时切己。一日一夜八万四千生八万四千死。杀生之业其事如是。时阎罗王呵责罪人。汝乐杀生今受此苦。是事乐不。汝今复当百千万劫偿他人债终不可尽。八者杀生之业。生五死五活地狱之中。有五大山五百亿刀轮在山顶。上有大水轮在刀轮上。罪人在中身如华敷卧寒冰上。五山刀轮从五方来。唱言活活。分为五段五死五活碎身如尘。一日一夜八万四千生八万四千死。杀生之业其事如是。时阎罗王呵责罪人。汝乐杀生今受此苦。是事乐不。汝今复当百千万劫偿他人债。终不可尽。九者杀生之业。生毒蛇林地狱之中。有无量恒河沙热铁毒蛇。一一蛇长数千由旬。口中吐毒如热铁丸。从罪人顶入遍身中。一一支节有无量蛇。吐毒吐火焚烧罪人。一日一夜八万四千生八万四千死。杀生之业其事如是。时阎罗王呵责罪人。汝乐杀生今受此苦。是事乐不。汝今复当百千万劫偿他人债。终不可尽十者杀生之业。生铁械枷锁地狱之中。十二由旬铁山为械。六十由旬铁柱火网为锁。八十由旬铁狗口中吐火为杻。虚空铁箭自落射心。杻械枷锁化生铜丸。从眼而入遍体支节从足而出。一日一夜八万四千生八万四千死。杀生之业其事如是。时阎罗王呵责罪人。汝乐杀生今受此苦。是事乐不。汝今复当百千万劫偿他人债。终不可尽。尔时世尊告舍利弗。杀生之业在地狱中。虽复受苦此名华报。方生人中多病短命。复生四生诸众生中。受种种苦无量无边不可称计

云何名不盗戒。不盗戒者。普施一切众生财物外命。是故诸佛说不盗戒。名为甘露清凉安隐。护持是戒名生天路。名得道处名涅槃衣名解脱命。是故诸佛赞叹不盗断饿鬼因。偷盗果报有十种恶。一者盗报。必定当堕肉山地狱。肉山罪人项如大山有百千头。于一一头颊生肉埠。百千铁狗从铁山出。啀喍嗥吠争取食之。有诸铁钉从狗口出。入罪人顶从足跟出。剥取其皮敷百千由旬铁刺之上。身皮俱苦经八万四千岁。心如刀割苦痛难处。是名第一偷盗果报。是时阎罗王呵责罪人。汝乐偷盗今受此苦。是事乐不。汝今复当百千万劫偿他人债。终不可尽。第二盗报。生饿鬼中。身极长大五十由旬。行如五百车声。节间火然如十火车。饥啖铁丸渴饮融铜。发如铁刺自缠身体。百千万岁受无量苦。耳不曾闻水谷之声。是名第二偷盗果报。时阎罗王呵责罪人。汝乐偷盗今受此苦。是事乐不。汝今复当百千万劫偿他人债。终不可尽。第三盗报。生于寒冰地狱之中。百千万岁八方冰山以为衣服如莲花敷。自啖其肉火箭入心。是为第三偷盗果报。时阎罗王呵责罪人。汝乐偷盗今受此苦。是事乐不汝今复当百千万劫偿他人债。终不可尽。第四盗报生罗刹中。女如天女面貌端正。男有千眼以铁羁头。狗牙上出耳端生火。女作姿时举体火然。饮血啖肉啖火啖炭。食脓食吐。百千万岁受罗刹身极大苦恼。是为第四偷盗果报。时阎罗王呵责罪人。汝乐偷盗今受此苦是事乐不。汝今复当百千万劫偿他人债。终不可尽。第五盗报。生铁鹿地狱受铁鹿形。有百千头有百千手。百千尾百十蹄甲百千重皮五百亿铁虎。百千亿铁师子剥取其皮。一一皮间生无量铁刺。犹如刀剑削骨彻髓苦痛无量百千万岁受苦无极。是名第五偷盗果报。时阎罗王呵责罪人。汝乐偷盗今受此苦。是事乐不。汝今复当百千万劫偿他人债。终不可尽。第六盗报。生在人中。裸形黑瘦眼目角睐。口气臭秽常处牢狱。执除粪秽为王家使。虽生人中状如牛马。父不爱子子不孝父。母不爱子子不孝母。百千万岁苦痛无量。是名第六偷盗果报。时阎罗王呵责罪人。汝乐偷盗今受此苦。是事乐不。汝今复当百千万劫偿他人债。终不可尽。第七盗报。生刀剑花大地狱中。刀林剑林无量无边。有诸罪人身如铁瓮。纵广正等百千由旬狱卒驱蹴如风吹花。生剑花端百千剑花。分剥其皮作无数段。削骨彻随从空而落。生刀花上刀花诸刺。分剥其皮作无量段。劈破其骨为无数段。彻髓刺心求死不得。四方铁山化生无量铁蒺[卄/梨]刺。如大弩箭同时射心。无量亿岁受如此苦。是为第七偷盗果报。时阎罗王呵责罪人。汝乐偷盗今受此苦。是事乐不。汝今复当百千万劫偿他人债。终不可尽。第八盗报。生于火山大地狱中。受大狱形有百千头。于其背上担负五百火形猕猴。手执火刀以剥其皮掷火山上。心生火狼啮骨彻髓。身如火聚四方逃走。经火山中终不得脱。受苦万端求死不得。百千万岁受如是苦。时阎罗王呵责罪人。汝乐偷盗今受此苦。是事乐不。汝今复当百千万劫偿他人债。终不可尽。第九盗报。生于穿鼻大地狱中。穿鼻狱者有十二铁钩。钩其眼耳及鼻口舌。打棒折齿剥其面皮。化为肉段内置口中。成大火箭射心至足。求死不得百千万岁受苦如是。时阎罗王呵责罪人。汝乐偷盗今受此苦。是事乐不。汝今复当百千万劫偿他人债。终不可尽。第十盗报。生屠剥狱卧铁机上。狱卒以刀剥皮割心。终不肯死百千万岁受苦如是。时阎罗王呵责罪人。汝乐偷盗今受此苦。是事乐不。汝今复当百千万劫偿他人债。终不可尽

云何名不淫戒。不淫戒者。有五功德利。过去现在未来诸佛之所赞叹。不淫者。住佛威仪身香如佛。何等为五。一者不动眼识不视淫色。设见色时如见粪虫。如刀入心如火烧眼。心不起爱无常所切。眼火横动何爱之有。二者不闻淫声。设闻淫声不动耳识悦可耳根。愚痴音声动毒蛇林为爱种子。此名贼风。从耳根出妄见所起。如夜叉吟何爱之有。此是幻响愚夫爱之。鼓动诸根是露人声。从痴爱河顺五欲流。深知是贼不动耳识。三者鼻根嗅香。当知是香从八风起。痴风鼓动爱风吹来。花等诸香从妄想生。颠倒横有从鼻识起。横言是香或称美味。鼻识惊动草木众花皆称是香。如来摄身不嗅香臭。体解非真不赞香触。四者不动舌识。不说世利不赞淫事。口终不说淫欲触乐。不住狂惑黐胶屋宅。亦不乐说可爱乐事。增长无明五贼痴爱。是故诸佛不动舌识。五者意寂不动。不起淫心不念淫事。不想淫乐不动淫根。淫识不转如解脱心。住寂灭处处常乐城。安隐无为随学佛心住真如际。一向入于十八大空九种涅槃。佛及菩萨得五功德。身形清净常生莲花。身净无垢心亦淡泊。是故诸佛说不淫戒。最胜清净无上功德具足五利。赞叹称美为解脱因不可穷尽。淫为极重无索系缚。譬如老象溺五欲泥普为一切诸罪根本。淫欲之罪吾今当说

  汝等一心听　　淫浊恶万行
  没溺诸禅定　　障蔽解脱道
  善男子女等　　欲求解脱道
  远离三界狱　　火坑五欲河
  汤火寒冰山　　解脱生死畏
  持心如诸佛　　当持不淫戒
  欲求长寿天　　寿命无量劫
  梵天转轮王　　富有七财宝
  持心如诸佛　　当持不淫戒
  欲得见诸佛　　闻法证道果
  具足六神通　　游诸十方国
  持心如诸佛　　当持不淫戒

淫有十过患。何等为十。一者贪淫之人。虽生天上为天帝释受五欲乐。心如偷食狗常醉不醒。没于五欲驶流河中。二者贪淫之人。虽为人王威力自在。作恩爱奴野人所使。多得财宝如火受薪不知厌足。亡身丧国死堕恶道。三者贪淫之人。恒系属他六贼驱策。无常大象蹑其背上。心如猿猴不知众难。欲火焚烧不识父母兄弟姊妹。犹如猪狗更相荷担无复惭愧。四者贪淫之人。常饮不净女人脓血。于无量劫常处胞胎。生藏熟藏子藏诸虫以为衣服。唼[口*束]女根用为饮食。五者贪淫之人。心如利刀眼如火车。割截烧灭功德行藏。六者贪淫之人。到刹利众。然结使火起贪欲薪。意欲剥夺犹如罗刹。到婆罗门众不生惭愧。犹若幻人但作妖祥说不净事。到沙门众不知归依。动诸情根如胶着草。欲染诸使围绕意根。六情火起烧善种子。破灭先世梵行白业。举手动足犹如利刀。眼如猛火口如罗刹。遍体毛孔淫火所使。七者贪淫之人造八种业。杀生作杀生具刀剑杖等。和合男女作大妄语。饮酒歌颂作淫境界。或复偷盗一切宝器。庄严虫聚为心王所使。眼根恶狗偷啖臭秽。八者贪淫之人为淫所使。心如大火亦如铁聚。直当陷坠破灭梵行必堕地狱。九者贪淫之人。身坏命终如掷贝珠顷。必定当堕赤铜地狱。赤铜地狱纵广正等七千由旬。如铜花林。下有铁床。床上复有百千由旬热铜八楞柱。柱端有镜。镜中自然有诸女像或作男形。淫人爱念动诸情根同时火起。铜花化为大热铁钉。铜柱变成沸铜镬汤铁床火然。女化为狗男化为刀。驱蹴罪人受无量苦。啖热铁丸吞饮洋铜求死不得经无量岁。寿命一劫。十者贪淫之人。不得见佛如重云障。破梵行故。必定当堕阿鼻地狱。身满狱中寿命一劫。左右宛转复经一劫。时阎罗王呵责罪人。汝乐淫欲今受此苦。是事乐不。汝今复当百千万劫偿他人债。终不可尽。地狱命终生鸠鸽中。受龙蛇身污梵行故。百生千生不见于佛不闻于法终不得道。尔时世尊。以偈颂曰

  淫欲不断绝　　相续生众生
  无明为根本　　老死刀所切
  横受毒蛇林　　血盛囊不净
  如粪虫乐屎　　贪淫者亦然
  九孔流欲火　　恩爱如毒刺
  颠倒妄见起　　幻惑故生爱
  一切女色滑　　如树生狂花
  颠倒风所吹　　萎花为虫聚
  女人如画瓶　　渧渧脓血流
  瓶满复淋漏　　不净盈于外
  眼见不净汁　　如偷狗贪淫
  当自灭诸爱　　一心观不净
  服饮于甘露　　住大涅槃城

佛告舍利弗。若有持心持身不造淫欲。持眼不视淫色。持耳不听淫声。持鼻不嗅淫香。持舌不触淫舌。如此名为具足智慧行八正路。不淫净身心。喻如莲花不着尘垢。成须陀洹道斯陀含道阿那含道阿罗汉道。辟支佛道无上大道。皆从不淫清净故得。口四业者。妄语两舌恶口绮语。赞叹邪见语

  若能不妄语　　说不妄语戒
  持口如佛口　　常说诚实语
  是人生天上　　口香熏诸天
  若生于世间　　谓诸香庄严
  犹如香山水　　流入涅槃河
  若能不两舌　　心亦无二种
  舌如诸佛舌　　莲花叶覆面
  五种杂色光　　从于舌相出
  常说大人法　　至诚不两舌
  若能不恶口　　是名大丈夫
  人中端正者　　一切皆乐见
  如栴檀杂香　　若能不绮语
  口常出妙香　　犹如优钵罗
  生处得值佛　　口业如实净
  若不赞邪见　　不说邪见业
  生处常出家　　正命常具足
  如佛住涅槃　　皆从实语得

佛告舍利弗。口四过者。有十大恶业。何等为十。一者妄语人诽谤人。不闻言闻。不得道果言得道果不见言见。如此恶人。虽不得病犹如癞狗。尔时世尊。而说偈言

  一切天人中　　猛火烧铁丸
  烧破一切人　　此贼不为胜
  何等为大贼　　唯有一种人
  宁使节节火　　骨化为融铜
  吞啖于刀山　　镬汤刀锯解
  碎身作火聚　　此苦不为恶
  妄语大毒害　　烧坏天人福
  游行阿鼻狱　　刀轮为脚足
  铁毒蛇为舌　　口火烧大千
  眼如迸铁丸　　雨大镬汤雨
  烧灭善根花　　毕定堕恶道
  无量亿千劫　　求出无由脱
  如是大恶人　　举身是火山
  烧坏一切善

恶口者。口虽含香臭如死尸。恒乐说他诸不善事。口所吐说如刺如刀如剑如戟。如屎如尿如虫如脓。天人中香无过善语。三界中臭无过恶口。二者恶口之人口有所吐。如雨铁丸烧坏他家。此人未来堕大地狱。热铁烧身饮热铁汁。设生世间作病癞狗及病癞人。无量劫中常食脓血。心所念者。纯是不善与恶相应。三者两舌。其两舌人犹如水火。不作言作。他人作善实言净语狂横言非。他所不作横为他作。一切世人常不乐见。必定当堕大恶道中。铜锯解舌为数千段。四者绮语。绮语者反上作下。反下作上。调戏无节巧言利辞。说无益语。说不利语。说无义语。赞叹五欲语。心不明了语。黑暗语。如刺如林钩罥众生。此人恶报命终。当堕刺林地狱。百千铁刺钩其舌出作百千段。五者赞叹邪见。邪见之人。口如盛火烧诸善根。无父无母无佛无法。无比丘僧无阿罗汉无辟支佛。无师无友无善知识。心如疾风吹崩一切诸善根树。此是大贼说无因果。口如大水漫流三界。淫欲无度调弄同类。造五无间断绝般若。犯四重禁至无间罪。皆从邪见颠倒恶心。邪风吹动恶不善口。阿鼻狱火铁刺舌生。如此妄语恶口两舌绮语赞叹邪见。此大恶人。虽在世间四大所成五阴严饰。当知地大即是铁山刀林剑树。百千铁刺无数铁虫。铁嘴诸乌铁网蒺车轹绝其身。当知水火即是融铜。无数镬汤是热铁丸。沸屎铁河以流节间。当知大小节节自然犹如铜柱。众火同时从六根起。烧坏身心堕大地狱。当知风大犹如雹雨。无数刀林百千剑树。动于支节从溪谷生。当知五阴即是五贼。十八罗刹系属狱种阎罗王民。识为热铁状如融铜满阿鼻狱。自高强健多力恶口。骂詈诽谤毁呰人者。今安所在。佛告舍利弗。恶口妄语两舌绮语赞邪见者。此人不为一人作贼。普为一切诸天世人作大劫贼。譬如群贼威力自在烧破一城。杀害一切及四天下一切人民。此人所得罪报。为多少耶。舍利弗白佛言。世尊。此人所得罪。如须弥山不可称量。佛告舍利弗。此人虽复获大罪报。不如妄语恶口两舌绮语赞叹邪见。须臾所造获大重报。身坏命终堕大地狱。经无量劫受苦无穷。百千诸佛不能得救。诸佛观此谤法罪人。与十方界地狱俱生地狱俱灭。是故智者当摄身口。佛告舍利弗。若有受持此十善戒。破十恶业。上生天上为梵天王。下生世间作转轮王十善教化。永与地狱三恶道别。譬如流水至涅槃海。若有毁犯十善戒者。堕大地狱经无量世受诸苦恼。舍利弗。汝好受持十善戒羯磨法。破十不善业。时舍利弗及诸大众闻佛所说。欢喜奉行

佛说受十善戒经


四分比丘戒本

    No. 1429 [No. 1430; cf. No. 1428]

    四分比丘戒本(并序)

        西太原寺沙门怀素集

夫戒者。乃是定慧之宏基。圣贤之妙趾。穷八正之道。尽七觉之源。然既树五制之良规。传须获实。扬六和之清训。学者知诠。窃寻流行。总有四本。据其理虽复同。会其文则有异。致使弘扬失于宗叙。修奉乖于行仪。亏鹿野之微言。紊龙城之要旨。故今详捡律本参验戒心。依于正文录之如左。庶使顺菩提之妙业。成实相之嘉谋。作六趣之舟航。为三乘之轨躅者也

四分律比丘戒本

        后秦三藏佛陀耶舍译

  稽首礼诸佛　　及法比丘僧
  今演毗尼法　　令正法久住
  戒如海无涯　　如宝求无厌
  欲护圣法财　　众集听我说
  欲除四弃法　　及灭僧残法
  障三十舍堕　　众集听我说
  毗婆尸式弃　　毗舍拘楼孙
  拘那含牟尼　　迦叶释迦文
  诸世尊大德　　为我说是事
  我今欲善说　　诸贤咸共听
  譬如人毁足　　不堪有所涉
  毁戒亦如是　　不得生天人
  欲得生天上　　若生人间者
  常当护戒足　　勿令有毁损
  如御入险道　　失辖折轴忧
  毁戒亦如是　　死时怀恐惧
  如人自照镜　　好丑生欣戚
  说戒亦如是　　全毁生忧喜
  如两阵共战　　勇怯有进退
  说戒亦如是　　净秽生安畏
  世间王为最　　众流海为最
  众星月为最　　众圣佛为最
  一切众律中　　戒经为上最
  如来立禁戒　　半月半月说

僧集(答言僧集)和合(答言和合)未受大戒者出(有者遣出。答言。未受大戒者已出。无者答言。此中无未受大戒者)不来诸比丘。说欲及清净(有依法竟答言。说欲已。无者答言。此中无说欲者)谁遣比丘尼来请教诫(有受尼嘱者。为说讫答言。请教诫。已无者答云。此中无尼来请教诫)僧今和合何所作为(答云说戒羯磨)大德僧听。今十五日众僧说戒。若僧时到僧忍听。和合说戒。白如是。作白成不(若成答云成若不成答云不成)诸大德。我今欲说波罗提木叉戒汝等谛听善思念之。若自知有犯者。即应自忏悔不犯者默然。默然者知诸大德清净。若有他问者亦如是答。如是比丘在众中乃至三问。忆念有罪而不忏悔者。得故妄语罪。故妄语者。佛说障道法。若彼比丘忆念有罪。欲求清净者应忏悔忏悔得安乐

诸大德。我已说戒经序今问诸大德。是中清净不(第二第三亦如是说)

诸大德。是中清净。默然故。是事如是持

诸大德。是四波罗夷法。半月半月说戒经中来

若比丘共比丘同戒。若不还戒戒羸不自悔。犯不净行。乃至共畜生。是比丘波罗夷不共住

若比丘。若在村落。若闲静处。不与盗心取。随不与取法若为王王大臣所捉若杀若缚若驱出国。汝是贼汝痴汝无所知。是比丘波罗夷不共住

若比丘。故自手断人命。持刀授与人。叹誉死快劝死咄男子。用此恶活为。宁死不生。作如是心。思惟种种方便叹誉死快劝死是比丘波罗夷不共住

若比丘。实无所知。自称言。我得上人法。我已入圣智胜法。我知是我见是。彼于异时。若问若不问。欲自清净故。作是说。我实不知不见。言知言见虚诳妄语。除增上慢。是比丘波罗夷不共住

诸大德。我已说四波罗夷法。若比丘犯一一波罗夷法。不得与诸比丘共住。如前后亦如是。是比丘得波罗夷罪不应共住

今问诸大德。是中清净不(第二第三亦如是说)

诸大德。是中清净。默然故。是事如是持

诸大德。是十三僧伽婆尸沙法半月半月说戒经中来

若比丘故弄阴出精。除梦中僧伽婆尸沙

若比丘淫欲意。与女人身相触。若捉手若捉发。若触一一身分者。僧伽婆尸沙

若比丘淫欲意。与女人粗恶淫欲语。随所说粗恶淫欲语。僧伽婆尸沙

若比丘淫欲意。于女人前自叹身言。大妹。我修梵行持戒。精进修善法。可持是淫欲法供养我。如是供养第一最。僧伽婆尸沙

若比丘。往来彼此媒嫁。持男意语女。持女意语男。若为成妇事。若为私通事。乃至须臾顷。僧伽婆尸沙

若比丘。自求作屋。无主自为己。当应量作。是中量者。长佛十二磔手。内广七磔手。当将余比丘指授处所。彼比丘当指示处所。无难处无妨处。若比丘有难处妨处。自求作屋。无主自为己。不将余比丘指授处所。若过量作者。僧伽婆尸沙

若比丘欲作大房。有主为己作。当将余比丘往指授处所。彼比丘应指授处所。无难处无妨处。若比丘有难处妨处作大房。有主为己作。不将余比丘指授处所。僧伽婆尸沙

若比丘嗔恚所覆故。非波罗夷比丘。以无根波罗夷法谤。欲坏彼清净行。彼于异时。若问若不问。知此事无根说。我嗔恚故作是语。若比丘作是语者。僧伽婆尸沙

若比丘以嗔恚故。于异分事中取片。非波罗夷比丘。以无根波罗夷法谤。欲坏彼清净行。彼于异时。若问若不问知是异分事中取片。是比丘自言。我嗔恚故作是语。作是语者僧伽婆尸沙

若比丘欲坏和合僧。方便受坏和合僧法。坚持不舍。彼比丘应谏是比丘言。大德。莫坏和合僧。莫方便坏和合僧。莫受坏僧法坚持不舍。大德。应与僧和合欢喜不诤。同一师学如水乳合。于佛法中。有增益安乐住。是比丘如是谏时坚持不舍。彼比丘应三谏。舍此事故。乃至三谏舍者善不舍者僧伽婆尸沙

若比丘有余伴党。若一若二若三乃至无数。彼比丘语是比丘言。大德。莫谏此比丘。此比丘是法语。比丘律语比丘。此比丘所说我等喜乐。此比丘所说我等忍可。彼比丘言。大德。莫作是语言。此比丘是法语比丘律语比丘。此比丘所说我等喜乐。此比丘所说我等忍可。然此比丘。非法语比丘非律语比丘。大德。莫欲破坏和合僧。汝等当乐欲和合僧。大德。应与僧和合欢喜不诤。同一师学如水乳合。于佛法中。有增益安乐住。是比丘如是谏时坚持不舍。彼比丘应三谏。舍此事故。乃至三谏舍者善。不舍者僧伽婆尸沙

若比丘。依聚落若城邑住。污他家行恶行。污他家亦见亦闻。行恶行亦见亦闻。诸比丘当语是比丘言。大德。污他家行恶行。污他家亦见亦闻。行恶行亦见亦闻。大德。汝污他家行恶行。今可远此聚落去。不须住此。是比丘语彼比丘。作是语。大德。诸比丘有爱有恚有怖有痴。有如是同罪比丘。有驱者有不驱者。诸比丘报言。大德。莫作是语。有爱有恚有怖有痴。有如是同罪比丘有驱者有不驱者。而诸比丘不爱不恚不怖不痴。大德。污他家行恶行。污他家亦见亦闻。行恶行亦见亦闻。是比丘如是谏时。坚持不舍。彼比丘应三谏。舍此事故乃至三谏舍者善。不舍者僧伽婆尸沙

若比丘恶性不受人语。于戒法中。诸比丘如法谏已。自身不受谏语言。诸大德。莫向我说若好若恶。我亦不向诸大德说若好若恶。诸大德。且止莫谏我。彼比丘应谏是比丘言。大德。莫自身不受谏语。大德。自身当受谏语。大德如法谏诸比丘。诸比丘亦如法谏大德。如是佛弟子众得增益。展转相谏。展转相教。展转忏悔。是比丘如是谏时。坚持不舍。彼比丘应三谏。舍此事故。乃至三谏舍者善。不舍者僧伽婆尸沙

诸大德。我已说十三僧伽婆尸沙法。九初犯四乃至三谏。若比丘犯一一法。知而覆藏。应强与波利婆沙。行波利婆沙竟。增上与六夜摩那埵。行摩那埵已。余有出罪。应二十人僧中出是比丘罪。若少一人不满二十众。出是比丘罪。是比丘罪不得除。诸比丘亦可呵。此是时。今问诸大德。是中清净不(如是三说)

诸大德。是中清净。默然故。是事如是持

诸大德是二不定法。半月半月说戒经中来

若比丘共女人。独在屏处覆处障处可作淫处坐。说非法语。有住信优婆夷。于三法中一一法说。若波罗夷若僧伽婆尸沙若波逸提。是坐比丘自言。我犯是罪。于三法中应一一治。若波罗夷。若僧伽婆尸沙。若波逸提。如住信优婆夷所说。应如法治是比丘。是名不定法

若比丘共女人。在露现处不可作淫处坐。作粗恶语。有住信优婆夷。于二法中一一法说。若僧伽婆尸沙若波逸提。是坐比丘自言。我犯是事。于二法中应一一法治。若僧伽婆尸沙若波逸提。如住信优婆夷所说。应如法治是比丘。是名不定法

诸大德。我已说二不定法。今问诸大德。是中清净不(如是三说)诸大德。是中清净。默然故。是事如是持

诸大德。是三十尼萨耆波逸提法。半月半月说戒经中来

若比丘衣已竟。迦絺那衣已出。畜长衣经十日。不净施得畜。若过十日尼萨耆波逸提

若比丘衣已竟。迦絺那衣已出三衣中离一一衣异处宿。除僧羯磨尼萨耆波逸提

若比丘衣已竟。迦絺那衣已出。若比丘得非时衣。欲须便受。受已疾疾成衣。若足者善。若不足者。得畜一月。为满足故。若过畜尼萨耆波逸提

若比丘从非亲里比丘尼取衣。除贸易尼萨耆波逸提

若比丘。令非亲里比丘尼浣故衣。若染若打。尼萨耆波逸提

若比丘。从非亲里居士若居士妇乞衣除余时尼萨耆波逸提余时者。若比丘夺衣失衣烧衣漂衣。是谓余时

若比丘失衣夺衣烧衣漂衣。若非亲里居士居士妇。自恣请多与衣。是比丘当知足受衣。若过受者尼萨耆波逸提

若比丘居士居士妇。为比丘办衣价。买如是衣与某甲比丘。是比丘先不受自恣请。到居士家作如是说。善哉居士。为我买如是如是衣与我。为好故。若得衣者尼萨耆波逸提

若比丘。二居士居士妇。与比丘办衣价。持如是衣价买如是衣。与某甲比丘。是比丘先不受居士自恣请。到二居士家作如是言。善哉居士。办如是如是衣价。与我共作一衣。为好故。若得衣者尼萨耆波逸提

若比丘。若王若大臣若婆罗门。若居士居士妇。遣使为比丘送衣价。持如是衣价与某甲比丘。彼使人至比丘所。语比丘言。大德。今为汝故。送是衣价受取。是比丘应语彼使如是言。我不应受此衣价我若须衣。合时清净当受。彼使语比丘言。大德。有执事人不。须衣比丘应语言。有。若僧伽蓝民。若优婆塞。此是比丘执事人。常为诸比丘执事。时彼使往至执事人所。与衣价已还至比丘所。作如是言。大德所示某甲执事人。我已与衣价。大德。知时往彼当得衣。须衣比丘当往执事人所。若二反三反为作忆念。应语言我须衣。若二反三反为作忆念。若得衣者善。若不得衣。应四反五反六反在前默然住。令彼忆念。若四反五反六反在前默然住。得衣者善。若不得衣。过是求得衣者。尼萨耆波逸提。若不得衣。从所得衣价处。若自往若遣使往。语言汝先遣使持衣价。与某甲比丘。是比丘竟不得衣。汝还取莫使失。此是时(一十)

若比丘杂野蚕绵。作新卧具。尼萨耆波逸提

若比丘。以新纯黑羺羊毛。作新卧具。尼萨耆波逸提

若比丘作新卧具。应用二分纯黑羊毛。三分白四分尨。若比丘不用二分黑三分白四分尨。作新卧具者尼萨耆波逸提

若比丘作新卧具持至六年。若减六年不舍故。更作新者。除僧羯磨。尼萨耆波逸提

若比丘作新坐具。当取故者。纵广一磔手帖着新者上。用坏色故。若作新坐具。不取故者纵广一磔手帖。着新者上用坏色故。尼萨耆波逸提

若比丘道路行得羊毛。若无人持。得自持乃至三由旬。若无人持自持过三由旬尼萨耆波逸提

若比丘使非亲里比丘尼浣染擘羊毛者。尼萨耆波逸提

若比丘。自手捉钱若金银。若教人捉若置地受者。尼萨耆波逸提

若比丘种种卖买宝物者。尼萨耆波逸提

若比丘种种贩卖者尼萨耆波逸提(二十)

若比丘畜长钵。不净施得齐十日若过者尼萨耆波逸提

若比丘畜钵。减五缀不漏。更求新钵。为好故。若得者尼萨耆波逸提。彼比丘应往僧中舍。展转取最下钵。与之令持。乃至破应持。此是时

若比丘自乞缕线。使非亲里织师织作衣者。尼萨耆波逸提

若比丘。居士居士妇。使织师为比丘织作衣。彼比丘先不受自恣请。便往织师所语言。此衣为我作。与我极好织令广大坚致。我当少多与汝价。是比丘与价乃至一食直。若得衣者尼萨耆波逸提

若比丘先与比丘衣。后嗔恚故。若自夺若教人夺取。还我衣来不与汝。是比丘还衣。彼取衣者尼萨耆波逸提

若比丘有病。残药酥油生酥蜜石蜜。齐七日得服。若过七日服者。尼萨耆波逸提

若比丘春残一月在。当求雨浴衣。半月应用浴。若比丘过一月前求雨浴衣。过半月前用浴。尼萨耆波逸提

若比丘十日未竟夏三月。诸比丘得急施衣。比丘知是急施衣。当受。受已乃至衣时应畜。若过畜者尼萨耆波逸提

若比丘夏三月竟。后迦提一月满。在阿兰若有疑恐怖处住。比丘在如是处住。三衣中欲留一一衣置村舍内。诸比丘有因缘得离衣宿。乃至六夜。若过者尼萨耆波逸提

若比丘知是僧物。自求入己者。尼萨耆波逸提(三十)

诸大德我已说三十尼萨耆波逸提法。今问诸大德。是中清净不(如是三说)诸大德。是中清净。默然故。是事如是持

诸大德。是九十波逸提法。半月半月说戒经中来

若比丘。知而妄语者。波逸提

若比丘。种类毁呰语者。波逸提

若比丘。两舌语者。波逸提

若比丘。与女人同室宿者。波逸提

若比丘。与未受大戒人共宿。过二宿至三宿者。波逸提

若比丘。与未受大戒人共诵者。波逸提

若比丘知他比丘有粗恶罪。向未受大戒人说。除僧羯磨波逸提

若比丘向未受大戒人。说过人法言。我见是我知是。实者波逸提

若比丘。与女人说法。过五六语。除有知男子波逸提

若比丘。自手掘地若教人掘者。波逸提(一十)

若比丘坏鬼神村者波逸提

若比丘妄作异语。恼他者波逸提

若比丘嫌骂者波逸提

若比丘。取僧绳床木床若卧具坐蓐。露地敷若教人敷舍去。不自举不教人举。波逸提

若比丘于僧房中。敷僧卧具。若自敷若教人敷。若坐若卧。去时不自举不教人举。波逸提

若比丘知先比丘住处。后来强于中间敷卧具止宿。念言。彼若嫌迮者。自当避我去。作如是因缘非余非威仪。波逸提

若比丘嗔他比丘不喜。僧房中若自牵出。教他牵出。波逸提

若比丘。若房若重阁上脱脚绳床木床。若坐若卧。波逸提

若比丘知水有虫。若自浇泥。若浇草。若教人浇者。波逸提

若比丘作大房。户扉窗牖及余庄饰具。指授覆苫齐二三节。若过者波逸提(二十)

若比丘僧不差。教诫比丘尼者。波逸提

若比丘。为僧差教授比丘尼。乃至日暮者。波逸提

若比丘语余比丘。作如是语。诸比丘为饮食故。教授比丘尼者。波逸提

若比丘与非亲里比丘尼衣。除贸易波逸提

若比丘。与非亲里比丘尼作衣者。波逸提

若比丘与比丘尼。在屏处坐者。波逸提

若比丘与比丘尼。共期同一道行。从一村乃至一村间。除异时波逸提。异时者。与估客行若疑畏怖时。是谓异时

若比丘与比丘尼。共期同乘一船。上水下水。除直渡者波逸提

若比丘。知比丘尼赞叹教化因缘得食食。除檀越先有意者。波逸提

若比丘与妇女。共期同一道行。乃至一村间。波逸提(三十)

若比丘施一食处。无病比丘应一食。若过受者波逸提

若比丘展转食。除余时波逸提。余时者。病时施衣时。是谓余时

若比丘别众食。除余时波逸提。余时者。病时。作衣时。施衣时。道行时。乘船时。大众集时。沙门施食时。此是时

若比丘至白衣家。请比丘与饼糗饭。若比丘欲须者。当二三钵受。还至僧伽蓝中。应分与余比丘食。若比丘无病。过二三钵受持。还至僧伽蓝中。不分与余比丘食者。波逸提

若比丘足食竟。或时受请不作余食法而食者。波逸提

若比丘。知他比丘足食己若受请不作余食法。殷勤请与食。长老取是食。以是因缘非余。欲使他犯者。波逸提

若比丘非时。受食食者波逸提

若比丘残宿食。而食者波逸提

若比丘。不受食若药着口中除水及杨枝。波逸提

若比丘得好美饮食乳酪鱼及肉。若比丘如此美饮食。无病自为已索者。波逸提(四十)

若比丘外道男外道女。自手与食者。皆波逸提

若比丘先受请已。前食后食行诣余家。不嘱授余比丘。除余时波逸提。余时者。病时。作衣时。施衣时。是谓余时

若比丘。在食家中有宝。强安坐者。波逸提

若比丘。食家中有宝。在屏处坐者。波逸提

若比丘。独与女人露地坐者。波逸提

若比丘。语余比丘作如是语。大德。共至聚落当与汝食。彼比丘竟不教与是比丘食。语言。汝去。我与汝一处。若坐若语不乐。我独坐独语乐。以此因缘非余。方便遣去者。波逸提

若比丘请四月与药。无病比丘应受。若过受。除常请更请分请尽形寿请者。波逸提

若比丘往观军阵。除时因缘。波逸提

若比丘有因缘。听至军中二宿三宿。若过者波逸提

若比丘二宿三宿军中住。或时观军阵斗战。若观游军象马力势者。波逸提(五十)

若比丘饮酒者波逸提

若比丘水中嬉戏者波逸提

若比丘以指。相击擽者波逸提

若比丘不受谏者波逸提

若比丘恐怖他比丘者波逸提

若比丘半月洗浴。无病比丘应受。不得过。除余时波逸提。余时者。热时。病时。作时。风时。雨时。道行时。此是余时

若比丘无病。自为炙身故。在露地然火。若教人然。除时因缘波逸提

若比丘藏他比丘衣钵坐具针筒。若自藏教人藏。下至戏笑者波逸提

若比丘与比丘比丘尼式叉摩那沙弥沙弥尼衣。后不语主还取著者。波逸提

若比丘得新衣。应作三种坏色。一一色中随意坏。若青若黑若木兰。若比丘不以三种坏色。若青若黑若木兰。着余新衣者。波逸提(六十)

若比丘。故杀畜生命者波逸提

若比丘知水有虫。饮用者波逸提

若比丘。故恼他比丘。令须臾间不乐者。波逸提

若比丘。知他比丘犯粗罪。覆藏者波逸提

若比丘知年不满二十与受大戒此人不得戒。彼比丘可呵痴故。波逸提

若比丘。知诤事如法忏悔已。后更发起者。波逸提

若比丘知是贼伴结要。共同一道行。乃至一村间者波逸提

若比丘作如是语。我知佛所说法。行淫欲非障道法。彼比丘谏此比丘言。大德。莫作是语。莫谤世尊。谤世尊者不善。世尊不作是语。世尊无数方便说行淫欲。是障道法。彼比丘谏此比丘时。坚持不舍。彼比丘乃至三谏。舍此事故。若三谏舍者善。不舍者波逸提

若比丘。知如是语人未作法如是邪见而不舍。供给所须。共同羯磨止宿言语者。波逸提

若比丘知沙弥作如是语。我从佛闻法。行淫欲非障道法。彼比丘谏此沙弥如是言。汝莫诽谤世尊。谤世尊者不善。世尊不作是语。沙弥。世尊无数方便说淫欲是障道法。彼比丘谏此沙弥时。坚持不舍。彼比丘应乃至再三呵谏。令舍此事故。乃至三谏舍者善。

不舍者彼比丘应语此沙弥言。汝自今已去。不得言佛是我世尊。不得随逐余比丘。如诸沙弥得与比丘二三宿。汝今无是事。汝出去灭去。不应住此。若比丘知如是众中被摈沙弥。而诱将畜养共止宿言语者。波逸提(七十)

若比丘。余比丘如法谏时。作如是语。我今不学此戒。当难问余智慧持律比丘者。波逸提。若为知为学故。应难问

若比丘说戒时。作如是语。大德。何用说是杂碎戒为。说是戒时。令人恼愧怀疑。轻呵戒故。波逸提

若比丘说戒时。作如是语。我今始知此法戒经所载。半月半月说戒经中来。余比丘知是比丘。若二若三说戒中坐何况多。彼比丘无知无解。若犯罪应如法治。更重增无知罪。语言。长老。汝无利不善得。汝说戒时不用心念不一心摄耳听法。彼无知故。波逸提

若比丘。共同羯磨已。后如是语。诸比丘随亲厚。以众僧物与者。波逸提

若比丘。众僧断事未竟。不与欲而起去者。波逸提

若比丘与欲已。后悔者波逸提

若比丘比丘共斗诤已。听此语向彼说。波逸提

若比丘。嗔恚故不喜。打比丘者。波逸提

若比丘。嗔恚不喜。以手搏比丘者。波逸提

若比丘嗔恚故。以无根僧伽婆尸沙法谤者。波逸提(八十)

若比丘刹利水浇头王种。王未出未藏宝而入。若过宫门阈者。波逸提

若比丘若宝中宝庄饰具。若自捉若教人捉。除僧伽蓝中及寄宿处。波逸提。若比丘在僧伽蓝中。若寄宿处。捉宝若宝庄饰具。自捉教人捉。当作是意。若有主识者当取。作如是因缘非余若比丘。非时入聚落。不嘱比丘者。波逸提

若比丘作绳床木床。足应高如来八指。除入梐孔上。截竟若过者波逸提

若比丘。作兜罗绵贮绳床木床大小蓐。成者波逸提

若比丘作骨牙角针筒刳刮。成者波逸提

若比丘作尼师檀。当应量作。是中量者。长佛二磔手。广一磔手半。更增广长各半磔手。若过裁竟波逸提

若比丘作覆疮衣。当应量作。是中量者。长佛四磔手。广二磔手。裁竟过者波逸提

若比丘作雨浴衣。当应量作。是中量者。长佛六磔手。广二磔手半。过者裁竟波逸提

若比丘与如来等量作衣。若过量作者。波逸提。是中如来衣量者。长佛九磔手。广六磔手。是谓如来衣量(九十)

诸大德。我已说九十波逸提法。今问诸大德。是中清净不(如是三说)诸大德。是中清净。默然故。是事如是持

诸大德。是四波罗提提舍尼法。半月半月说戒经中来

若比丘入村中。从非亲里比丘尼。无病自手取食食者。是比丘应向余比丘悔过言。大德。我犯可呵法所不应为。我今向大德悔过。是名悔过法

若比丘至白衣家内食。是中有比丘尼指示。与某甲羹与某甲饭。是比丘应语彼比丘尼如是言。大姊。且止须诸比丘食竟。若无一比丘语彼比丘尼如是言。大姊。且止须诸比丘食竟者。是比丘应向余比丘悔过言。大德。我犯可呵法所不应为。我今向大德悔过。是名悔过法

若先作学家羯磨。若比丘于如是学家。先不请无病自手受食食者。是比丘应向余比丘悔过言。大德。我犯可呵法所不应为。我今向大德悔过。是名悔过法

若比丘在阿兰若迥远有疑恐怖处住。若比丘在如是阿兰若处住。先不语檀越。若僧伽蓝外不受食。在僧伽蓝内。无病自手受食食者。是比丘应向余比丘悔过言。大德。我犯可呵法所不应为。我今向大德悔过。是名悔过法

诸大德我已说四波罗提提舍尼法。今问诸大德。是中清净不(如是三说)诸大德。是中清净。默然故。是事如是持

诸大德。此众学戒法。半月半月说戒。经中来

当齐整着涅槃僧。应当学

当齐整着三衣。应当学

不得反抄衣行入白衣舍。应当学

不得反抄衣入白衣舍坐。应当学

不得衣缠颈入白衣舍。应当学

不得衣缠颈入白衣舍坐。应当学

不得覆头入白衣舍。应当学

不得覆头入白衣舍坐应当学

不得跳行入白衣舍。应当学

不得跳行入白衣舍坐。应当学(一十)

不得白衣舍内蹲坐。应当学

不得叉腰行入白衣舍。应当学

不得叉腰入白衣舍坐。应当学

不得摇身行入白衣舍。应当学

不得摇身行入白衣舍坐。应当学

不得掉臂行入白衣舍。应当学

不得掉臂行入白衣舍坐。应当学

好覆身入白衣舍。应当学

好覆身入白衣舍坐。应当学

不得左右顾视行入白衣舍。应当学(二十)

不得左右顾视行入白衣舍坐。应当学

静默入白衣舍。应当学

静默入白衣舍坐。应当学

不得戏笑行入白衣舍。应当学

不得戏笑行入白衣舍坐。应当学

用意受食。应当学

平钵受食。应当学

平钵受羹。应当学

羹饭等食。应当学

以次食。应当学(三十)

不得挑钵中而食。应当学

若比丘无病。不得为己索羹饭。应当学

不得以饭覆羹更望得。应当学

不得视比坐钵中食。应当学

当系钵想食。应当学

不得大抟饭食。应当学

不得大张口待食。应当学

不得含饭语。应当学

不得抟饭遥掷口中。应当学

不得遗落饭食。应当学(四十)

不得颊食食。应当学

不得嚼饭作声食。应当学

不得大噏饭食。应当学

不得舌舐食。应当学

不得振手食。应当学

不得手把散饭食。应当学

不得污手捉饮器。应当学

不得洗钵水弃白衣舍内。应当学

不得生草叶上大小便涕唾。除病。应当学

不得水中大小便涕唾。除病。应当学(五十)

不得立大小便。除病。应当学

不得与反抄衣不恭敬人说法。除病。应当学

不得为衣缠颈者说法。除病。应当学

不得为覆头者说法。除病。应当学

不得为裹头者说法。除病。应当学

不得为叉腰者说法。除病。应当学

不得为着革屣者说法。除病。应当学

不得为着木屐者说法。除病。应当学

不得为骑乘者说法。除病。应当学

不得在佛塔中止宿。除为守护故。应当学(六十)

不得藏财物置佛塔中。除为坚牢故。应当学

不得着革屣入佛塔中。应当学

不得手捉革屣入佛塔中。应当学

不得着革屣绕佛塔行。应当学

不得着富罗入佛塔中。应当学

不得手捉富罗入佛塔中。应当学

不得佛塔下坐食留草及食污地。应当学

不得担死尸从佛塔下过。应当学

不得在佛塔下埋死尸。应当学

不得在佛塔下烧死尸。应当学(七十)

不得向佛塔烧死尸。应当学

不得佛塔四边烧死尸使臭气来入。应当学

不得持死人衣及床从佛塔下过。除浣染香董。应当学

不得佛塔下大小便。应当学

不得向佛塔大小便。应当学

不得绕佛塔四边大小便使臭气来入。应当学

不得持佛像至大小便处。应当学

不得在佛塔下嚼杨枝。应当学

不得向佛塔嚼杨枝。应当学

不得佛塔四边嚼杨枝。应当学(八十)

不得在佛塔下涕唾。应当学

不得向佛塔涕唾。应当学

不得佛塔四边涕唾。应当学

不得向佛塔舒脚坐。应当学

不得安佛像在下房。己在上房住。应当学

人坐己立。不得为说法。除病。应当学

人卧己坐。不得为说法。除病。应当学

人在座己在非座。不得为说法。除病。应当学

人在高坐己在下坐。不得为说法。除病。应当学

人在前行己在后。不得为说法。除病。应当学(九十)

人在高经行处己在下经行处。不得为说法。除病。应当学

人在道已在非道。不得为说法。除病。应当学

不得携手在道行。应当学

不得上树过人头。除时因缘。应当学

不得络囊盛钵贯。扙头着肩上而行。应当学

人持杖不恭敬。不应为说法。除病。应当学

人持剑。不应为说法。除病。应当学

人持鉾。不应为说法。除病。应当学

人持刀。不应为说法。除病。应当学

人持盖。不应为说法。除病。应当学(一百)

诸大德。我已说众学戒法。今问。诸大德。是中清净不(如是三说)诸大德。是中清净。默然故。是事如是持

诸大德。是七灭诤法。半月半月说戒经中来。若有诤事起。即应除灭

应与现前毗尼。当与现前毗尼

应与忆念毗尼。当与忆念毗尼

应与不痴毗尼。当与不痴毗尼

应与自言治。当与自言治

应与觅罪相。当与觅罪相

应与多人觅罪。当与多人觅罪

应与如草覆地。当与如草覆地

诸大德。我已说七灭诤法。今问。诸大德。是中清净不(如是三说)诸大德。是中清净。默然故。是事如是持

诸大德。我已说戒经序已。说四波罗夷法已。说十三僧伽婆尸沙法已。说二不定法已。说三十尼萨耆波逸提法已。说九十波逸提法已。说四波罗提提舍尼法已。说众学戒法已。说七灭诤法。此是佛所说戒经。半月半月说戒经中来

若更有余佛法。是中皆共和合应当学

  忍辱第一道　　佛说无为最
  出家恼他人　　不名为沙门

此是毗婆尸如来无所著等正觉。说是戒经

  譬如明眼人　　能避崄恶道
  世有聪明人　　能远离诸恶

此是尸弃如来无所著等正觉。说是戒经

  不谤亦不嫉　　当奉行于戒
  饮食知止足　　常乐在空闲
  心定乐精进　　是名诸佛教

此是毗叶罗如来无所著等正觉。说是戒经

  譬如蜂采华　　不坏色与香
  但取其味去　　比丘入聚然
  不违戾他事　　不观作不作
  但自观身行　　若正若不正

此是拘楼孙如来无所著等正觉。说是戒经

  心莫作放逸　　圣法当勤学
  如是无忧愁　　心定入涅槃

此是拘那含牟尼如来无所著等正觉。说是戒经

  一切恶莫作　　当奉行诸善
  自净其志意　　是则诸佛教

此是迦叶如来无所著等正觉。说是戒经

  善护于口言　　自净其志意
  身莫作诸恶　　此三业道净
  能得如是行　　是大仙人道

此是释迦牟尼如来无所著等正觉。于十二年中。为无事僧说是戒经。从是已后广分别说。诸比丘。自为乐法乐沙门者。有惭有愧乐学戒者。当于中学

  明人能护戒　　能得三种乐
  名誉及利养　　死得生天上
  当观如是处　　有智勤护戒
  戒净有智慧　　便得第一道
  如过去诸佛　　及以未来者
  现在诸世尊　　能胜一切忧
  皆共尊敬戒　　此是诸佛法
  若有自为身　　欲求于佛道
  当尊重正法　　此是诸佛教
  七佛为世尊　　灭除诸结使
  说是七戒经　　诸缚得解脱
  已入于涅槃　　诸戏永灭尽
  尊行大仙说　　圣贤称誉戒
  弟子之所行　　入寂灭涅槃
  世尊涅槃时　　兴起于大悲
  集诸比丘众　　与如是教诫
  莫谓我涅槃　　净行者无护
  我今说戒经　　亦善说毗尼
  我虽般涅槃　　当视如世尊
  此经久住世　　佛法得炽盛
  以是炽盛故　　得入于涅槃
  若不持此戒　　如所应布萨
  喻如日没时　　世界皆闇冥
  当护持是戒　　如[犛-未+牙]牛爱尾
  和合一处坐　　如佛之所说
  我已说戒经　　众僧布萨竟
  我今说戒经　　所说诸功德
  施一切众生　　皆共成佛道

四分比丘戒本


四分比丘尼羯磨法

    No. 1434 [Nos. 1432, 1433; cf. No. 1428]

四分比丘尼羯磨法

        宋罽宾三藏求那跋摩译

    结界法第一(其诸结界羯磨作法。与上大僧同。唯称尼大师为异)

    受戒法第二

比丘尼乞畜众羯磨文(若比丘尼欲度人者。当往比丘尼僧中。偏露右肩脱革屣。礼僧足已。右膝着地合掌乞畜众羯磨。作如是白)

大姊僧听。我比丘尼某甲。今从僧乞度人授具足戒。愿僧与我度人授具足戒(如是三说)

与畜众羯磨文

大姊僧听。此比丘尼某甲。今从僧乞度人授人具足戒。若僧时到僧忍听僧今听比丘尼某甲度人授人具足戒白如是

大姊僧听。此比丘尼某甲。今从僧乞度人授人具足戒。僧今听比丘尼某甲度人授人具足戒。谁诸大姊忍。僧听比丘尼某甲度人授人具足戒者默然。谁不忍者说

僧已忍。听比丘尼某甲度人授人具足戒竟。僧忍默然故。是事如是持

度沙弥尼文(若欲在寺内剃发者。应白一切僧。若不和合应房房语令知。若和合应作白。然后与剃发。应作如是白)

大姊僧听。此某甲。欲从某甲求剃发。若僧时到僧忍听。为某甲剃发。白如是(白已为剃发欲在寺内出家者应白一切僧若不和合应房房语令知。若和合应作白。然后与出家。应作如是白)

大姊僧听。此某甲欲从某甲求出家。若僧时到僧忍听。与某甲出家。白如是(应作如是出家。教出家者着袈裟已。偏露右肩脱革屣。右膝着地合掌。教作如是白)

我阿夷某甲。归依佛归依法归依僧。我今随佛出家。和尚尼某甲。如来无所著等正觉。是我世尊(如是三说)我阿夷某甲。归依佛竟。归依法竟。归依僧竟。我今随佛出家竟。和尚尼某甲。如来无所著等正觉。是我世尊(亦如是三说已应与受戒)

尽形寿不得杀生是沙弥尼戒。能持不(答言能)

尽形寿不得盗。是沙弥尼戒。能持不(答言能)

尽形寿不得淫。是沙弥尼戒。能持不(答言能)

尽形寿不得妄语。是沙弥尼戒。能持不(答言能)

尽形寿不得饮酒。是沙弥尼戒能持不(答言能)

尽形寿不得着花鬘香油涂身。是沙弥尼戒能持不(答言能)

尽形寿不得歌舞倡伎。亦不欢听。是沙弥尼戒。能持不(答言能)

尽形寿不得高广大床上坐。是沙弥尼戒。能持不(答言能)

尽形寿不得捉持生像金银宝物。是沙弥尼戒。能持不(答言能)

尽形寿不得非时食。是沙弥尼戒。能持不(答言能)

如是沙弥尼十戒。尽形寿不得犯。能持不(答言能)

汝已受戒竟。当供养三宝佛宝法宝僧宝。当修三业坐禅诵经劝助众事(听童女十八者二岁学戒。年满二十。二部僧中受大戒。若年十岁曾出适者。听二岁学戒。年满十二。与受大戒。应如是与二岁学戒)

式叉摩那受六法文(沙弥尼应往比丘尼众中。偏露右肩脱革屣。礼比丘尼僧足已。右膝着地合掌白如是言)

大姊僧听。我沙弥尼某甲。今从僧乞二岁学戒。和尚尼某甲。愿僧济度我。慈愍故(如是三说应将沙弥尼。至离闻处着见处已。众中应差堪作羯磨者如上应作白言)大姊僧听。此某甲沙弥尼。今从僧乞二岁学戒。和尚尼某甲。若僧时到僧忍听。僧今与某甲沙弥尼二岁学戒。和尚尼某甲。白如是

大姊僧听。此某甲沙弥尼。今从僧乞二岁学戒。和尚尼某甲。僧今与某甲沙弥尼二岁学戒。和尚尼某甲。谁诸大姊忍。僧与某甲沙弥尼二岁学戒。和尚尼某甲者默然。谁不忍者说。是初羯磨(如是三说)

僧已忍与某甲沙弥尼二岁学戒和尚尼某甲竟。僧忍默然故。是事如是持(应如是与六法)某甲谛听如来无所著等正觉说六法。不得犯

不得行淫欲法。若式叉摩那行淫欲法。非式叉摩那非释种女。与染污心男子。共身相摩触缺戒。应更与受戒。是中尽形寿不得犯。能持不(答言能)

不得偷盗乃至草叶。若式叉摩那。取人五钱若过五钱。若自取教人取。若自斫教人斫。若自破教人破。若烧若埋若坏色。非式叉摩那非释种女。若取减五钱缺戒。应更与受戒。是中尽形寿不得犯。能持不(答言能)

不得故断众生命乃至蚁子。若式叉摩那。故自手断人命。求刀授与人。教死劝死赞死。若与非药。若堕胎厌祷咒术。自作教人作者。非式叉摩那非释种女。若断畜生不能变化者命缺戒。应更与受戒。是中尽形寿不得犯。能持不(答言能)

不得妄语乃至戏笑。若式叉摩那。不真实非己有。自称言得上人法。言得禅得解脱得三昧正受。得须陀洹果斯陀含果阿那含果阿罗汉果。言天来龙鬼神来供养我。此非式叉摩那非释种女。若于众中故作妄语缺戒。应更与戒。是中尽形寿不得犯。能持不(答言能)

不得非时食。若式叉摩那。非时食犯戒。应更与戒。是中尽形寿不得犯。能持不(答言能)

不得饮酒。若式叉摩那饮酒犯戒。应更与受戒。是中尽形寿不得犯。能持不(答言能)

式叉摩那。于一切尼戒中应学除为比丘尼过食自受食食

式叉摩那受大戒法(若式叉摩那学戒。已年满二十。若满十二。应与受大戒先至比丘尼僧中请和尚。应如是言)大姊一心念。我某甲。求阿姨为和尚。愿阿姨。为我作和尚。我依阿姨故。得受大戒(如是三说。和尚尼应答言尔。应如是受持。受戒人离闻处着见处应差教授师。是中戒师应如是问言)此众中谁能为某甲。作教授师(若有者答言我能。尔时戒师即应作白)大姊僧听。此某甲。从和尚尼某甲求受大戒。若僧时到僧忍听某甲为教授师。白如是(教授师应往至受戒人所语言)此安陀会郁多罗僧僧伽梨。此僧祇支覆肩衣。此衣钵是汝有不(答言己有)善女人谛听。今是真诚时。我今问汝。有便言有。无当言无。汝不犯边罪不。汝不犯净行比丘不。汝不贼心受戒不。汝不破内外道不。汝非黄门不。汝不杀父不。汝不杀母不。汝不杀真人阿罗汉不。汝不破僧不。汝不恶心出佛身血不。汝非非人不。汝非畜生不。汝非二根不。汝字何等。和尚尼字谁。年岁满不。衣钵具足不。父母夫主听汝不。汝不负债不。汝非婢不。汝是女人不。女人有如是诸病。癞白癞干痟癫狂二根二道合道小大小便常漏涕唾常出。汝有如是诸病不(答言无者应语言)如我向问汝。僧中亦当如是问。如汝向者答我。僧中亦当如是答(教授师问已。应至僧中如常威仪。至舒手及处立。应作白)大姊僧听。此某甲。从和尚尼某甲求受大戒。若僧时到僧忍听。我已教授竟。听使来。白如是(彼应语言来。来已应与捉衣钵。教礼僧足已。在戒师前胡跪合掌。作如是乞)

大姊僧听。我某甲。从和尚尼某甲求受大戒。我某甲。今从僧乞受大戒。和尚尼某甲。愿僧济度我。慈愍故(如是三说。是中戒师应作白)大姊僧听。此某甲。从和尚尼某甲求受大戒。此某甲。今从僧乞受大戒。和尚尼某甲。若僧时到僧忍听。我问诸难事。白如是

汝谛听。今是真诚时。我今问汝。有当言有。无当言无。汝不犯边罪不。汝不犯净行比丘不。汝不贼心受戒不。汝不破内外道不。汝非黄门不。汝不杀父不。汝不杀母不。汝不杀真人阿罗汉不。汝不破僧不。汝不恶心出佛身血不。汝非非人不。汝非畜生不。汝不二根不。汝字何等。和尚尼字谁。年岁满不。衣钵具足不。父母夫主听汝不。汝不负债不。汝非婢不。汝是女人不。女人有如是诸病。癞白癞干痟癫狂二根二道合道小大小便常漏。汝有如是诸病不(答言无应作白)大姊僧听。此某甲。从和尚尼某甲求受大戒。此某甲。今从僧乞受大戒。和尚尼某甲。某甲自说清净无诸难事。年满二十衣钵具足。若僧时到僧忍听。僧今为某甲受大戒。和尚尼某甲。白如是

大姊僧听。此某甲。从和尚尼某甲求受大戒。此某甲。今从僧乞受大戒。和尚尼某甲。某甲自说清净无诸难事。年岁已满衣钵具足。僧今为某甲受大戒。和尚尼某甲。谁诸大姊忍。僧今为某甲受大戒。和尚尼某甲者默然。谁不忍者说。是初羯磨(第二第三亦如是说)僧已忍与某甲受大戒竟。和尚尼某甲。僧忍默然故。是事如是持

尼往比丘僧中受大戒法(彼受戒者。与比丘尼僧俱至比丘僧中。礼僧足已右膝着地。合掌作如是言)

大德僧听。我某甲。从和尚尼某甲求受大戒。我某甲。今从僧乞受大戒。和尚尼某甲。愿僧救济我。慈愍故(如是三说。此中戒师。应问诸难事作白)

大德僧听。此某甲。从和尚尼某甲求受大戒。此某甲。今从僧乞受大戒。和尚尼某甲。若僧时到僧忍听。我问诸难事。白如是

善女人谛听。今是真诚时实语时。我今问汝。有当言有。无当言无。汝不犯边罪不。汝不犯净行比丘不。汝不贼心受戒不。汝不破内外道不。汝非黄门不。汝不杀父不。汝不杀母不。汝不杀真人阿罗汉不。汝不破僧不。汝不恶心出佛身血不。汝非非人不。汝非畜生不。汝不二根不。汝字何等。和尚尼字谁。年满二十未。衣钵具足不。父母夫主听汝不。汝不负债不。汝非婢不。汝是女人不。女人有如是诸病。癞白癞癫干痟狂二根二道合道小大小便常漏涕唾常出。汝有如是诸病不(答言无者应问言)汝学戒未清净不(答言学戒清净。应问余比丘尼)某甲学戒未清净不(答言已学戒清净)大德僧听。此某甲。从和尚尼某甲求受大戒。此某甲。今从僧乞受大戒。和尚尼某甲。某甲自说清净无诸难事。年岁已满衣钵具足。已学戒清净。若僧时到僧忍听。僧今为某甲受大戒。和尚尼某甲。白如是。大德僧听。此某甲。从和尚尼某甲求受大戒。此某甲。今从僧乞受大戒。和尚尼某甲某甲自说清净无诸难事。年岁已满衣钵具足。已学戒清净。僧今为某甲受大戒。和尚尼某甲。谁诸长老忍。僧为某甲受大戒。和尚尼某甲者默然。谁不忍者说。是初羯磨(如是三说)

僧已忍为某甲受大戒竟。和尚尼某甲。僧忍默然故。是事如是持

善女人谛听。如来无所著等正觉说八波罗夷法。若比丘尼犯者。非比丘尼非释种女。不得犯不净行行淫欲法。若比丘尼作不净行行淫欲法。乃至共畜生。此非比丘尼非释种女。是中尽形寿不得犯。能持不(答言能)

不得偷盗乃至草叶。若比丘尼盗人五钱若过五钱。若自取教人取。若自斫教人斫。若自破教人破。若烧若埋若坏色。非比丘尼非释种女。是中尽形寿不得犯。能持不(答言能)

不得断众生命乃至蚁子。若比丘尼若自手断人命。持刀授与人。教死赞死劝死。与人非药堕胎厌祷咒术。若作方便教人作方便彼非比丘尼非释种女。是中尽形寿不得犯。能持不(答言能)

不得妄语乃至戏笑。若比丘尼不真实非己有。自称言得上人法。得禅得解脱三昧正受。得须陀洹果斯陀含果阿那含果阿罗汉果。言天来龙来鬼神来供养我。彼非比丘尼非释种女。是中尽形寿不得犯能持不(答言能)

不得身相触乃至共畜生。若比丘尼有染污心。与染污心男子身相触。腋已下膝已上若摩。若逆摩若顺摩。若牵若推。若举若下。若捉若急捺。彼非比丘尼非释种女。是中尽形寿不得犯。能持不(答言能)

不得犯八事乃至共畜生。若比丘尼有染污心与染污心男子受捉手捉衣。至屏处屏处立屏处语。若共行若身相近若共期行犯此八事。彼非比丘尼非释种女。是中尽形寿不得犯。能持不(答言能)

不应覆藏他罪。乃至突吉罗恶说。若比丘尼知比丘尼犯波罗夷。不自举亦不白僧不语人令知。后于异时。此比丘尼若休道若灭摈。若作不共住若入外道。后作如是言。我先知此人如是如是。彼非比丘尼非释种女。覆藏重罪故是中尽形寿不得犯。能持不(答言能)

不得随被举比丘语乃至沙弥。若比丘尼知比丘为僧所举。如法如毗尼如佛所教。犯威仪未忏悔不作共住。便随顺彼比丘。彼比丘尼谏此比丘尼言大姊。彼比丘为僧所举。如法如毗尼如佛所教。犯威仪未忏悔不共住莫随顺彼比丘。彼比丘尼谏此比丘尼时坚持不舍。彼比丘尼应乃至三谏。舍此事故。乃至三谏舍者善。若不舍者彼非比丘尼非释种女。犯随举。是中尽形寿不得犯。能持不(答言能)

善女人谛听。如来无所著等正觉说四依法。比丘尼依此出家受大戒是比丘尼法。依粪扫衣出家受大戒是比丘尼法。是中尽形寿能持不(答言能)

若得长利。若檀越施衣。若得轻衣。若得割裁衣应受。依乞食出家受大戒。是比丘尼法。是中尽形寿能持不(答言能)

若得长利。僧差食。若檀越送食。月八日食。十五日食。月初日食。众僧常食。檀越请食得受。依树下坐出家受大戒。是比丘尼法。是中尽形寿能持不(答言能)

若得长利。若别房楼阁小房石室两房一户应受。依腐烂药出家受大戒。是比丘尼法。是中尽形寿能持不(答言能)

若得长利。酥油生酥蜜石蜜应受

汝已受戒竟。白四羯磨如法成就得处所和尚如法阿阇梨如法二部僧具足满。当善受教法。当勤供养佛法僧。和尚阿阇梨一切如法教敕。不得违逆。当学问诵经勤求方便。于佛法中得须陀洹果斯陀含果阿那含果阿罗汉果。汝始发心出家。功不唐捐。果报不绝。余所未知者。当问和尚阿阇梨(使受戒人在前而去)

    除罪法第三

尼忏僧残罪法(尼以女弱。事须相假以肃其怀。如若私己容恶则自坏。彼犯在不轻故。尼覆僧残。但增罪治半月行摩那埵。无别覆藏调伏法故。尼忏僧残。要在二部僧中。作摩那埵羯磨。大僧与尼。二部各满四人。若作出罪羯磨。大僧与尼。二部各满二十人。不得减)

乞摩那埵羯磨文(比丘尼犯僧残罪。应二部僧中半月行摩那埵。行摩那埵时。应至二部僧中。偏露右肩脱革屣。礼僧足右膝着地。合掌作如是乞)

大德僧听。我比丘尼某甲。犯某甲若干僧残罪。今从二部僧乞半月摩那埵。愿僧与我半月摩那埵。慈愍故(如是三说)

与摩那埵羯磨文

大德僧听。此比丘尼某甲。犯某甲若干僧残罪。今从二部僧乞半月摩那埵。若僧时到僧忍听。僧今与比丘尼某甲半月摩那埵。白如是

大德僧听。此比丘尼某甲。犯某甲若干僧残罪。今从二部僧乞半月摩那埵。僧今与比丘尼某甲半月摩那埵。谁诸长老忍僧与比丘尼某甲半月摩那埵者默然。谁不忍者说。是初羯磨(如是三说)

僧已忍与比丘尼某甲半月摩那埵竟。僧忍默然故。是事如是持(比丘尼行摩那埵法与上大僧同。唯应二部僧中日日白。应作如是白)

大德僧听。我比丘尼某甲。犯某甲若干僧残罪。已从二部僧乞半月摩那埵。僧已与我半月摩那埵。我比丘尼某甲。已行若干日过。余有若干日在。白大德僧令知。我行摩那埵

乞出罪羯磨文(比丘尼半月行摩那埵竟。应至二部僧中作如是乞)

大德僧听。我比丘尼某甲。犯某甲若干僧残罪。已从二部僧乞半月摩那埵。僧已与我半月摩那埵。我已于二部僧中行半月摩那埵竟。今从僧乞出罪羯磨。愿僧与我出罪羯磨。慈愍故(如是三说)

与出罪羯磨文

大德僧听。此比丘尼某甲。犯某甲若干僧残罪。已从二部僧乞半月摩那埵。僧已与比丘尼某甲半月摩那埵。此比丘尼某甲。已于二部僧中行半月摩那埵竟。今从僧乞出罪羯磨。若僧时到僧忍听。僧今与比丘尼某甲出罪羯磨。白如是。大德僧听。此比丘尼某甲。犯某甲若干僧残罪。已从二部僧乞半月摩那埵。僧已与比丘尼某甲半月摩那埵。此比丘尼某甲。已于二部僧中行半月摩那埵竟。今从僧乞出罪羯磨。僧今与比丘尼某甲出罪羯磨。谁诸长老忍。僧今与比丘尼某甲出罪羯磨者默然。谁不忍者说。是初羯磨(如是三说)僧已忍与比丘尼某甲出罪羯磨竟。僧忍默然故。是事如是持

    说戒法第四(其说戒法一与上大僧同)

尼僧差请教授人羯磨文(尼僧应半月半月至大僧请教诫故。今须差此使为尼僧请教诫。应如是差)

大姊僧听。若僧时到僧忍听。僧今差比丘尼某甲。为比丘尼僧故。半月往比丘僧中求教授。白如是。大姊僧听。僧今差比丘尼某甲。为比丘尼僧故。半月往比丘僧中求教授。谁诸大姊忍。僧差比丘尼某甲。为比丘尼僧故。半月往比丘僧中求教授者默然。谁不忍者说

僧已忍。差比丘尼某甲为比丘尼僧故半月往比丘僧中求教授竟。僧忍默然故。是事如是持(更差一人为伴。往大僧中至旧住比丘所。礼足曲身低头合掌。白如是言)

大德一心念。比丘尼僧某甲等和合。礼比丘僧足求教授(如是三说。受嘱比丘说戒时应作如是白)

比丘尼僧某甲众和合。礼大德僧足求教授(如是三说)比丘尼明日应问可否。比丘教授师应期往。比丘尼应期迎比丘。期往不往者突吉罗。比丘尼僧期迎而不迎者突吉罗。若比丘尼闻教授师来。当半由旬迎至寺内。供给所须洗浴具。羹粥饮食果蓏以此供养。若不者突吉罗。若比丘僧尽病。若众不和合。若众不满。遣信往礼拜问讯。若比丘尼僧尽病。不和合众不满亦当遣信往礼拜问讯。若不往者突吉罗

    安居法第五(其安居法皆与大僧同)

    自恣法第六

尼僧差往大僧中受自恣人羯磨文(比丘尼僧夏安居竟。应往大僧中受自恣故。今须差此使。为尼僧诣大僧中求受自恣。应如是差)

大姊僧听。若僧时到僧忍听。僧今差比丘尼某甲。为比丘尼僧故。往大僧中说三事自恣见闻疑。白如是

大姊僧听。僧今差比丘尼某甲。为比丘尼僧故往大僧中。说三事自恣见闻疑。谁诸大姊忍。僧差比丘尼某甲。为比丘尼僧故往大僧中说三事自恣见闻疑者默然。谁不忍者说

僧已忍。差比丘尼某甲为比丘尼僧故往大僧中说三事自恣竟。僧忍默然故。是事如是持

往大僧中受自恣文(差人为伴。往大僧中礼僧足已。曲身低头合掌作。如是说)

比丘尼僧夏安居竟。比丘僧夏安居竟。比丘尼僧。说三事自恣见闻疑。大德慈愍故语我。我若见罪。当如法忏悔(如是三说)

彼即比丘僧自恣日便自恣。而皆疲极。佛言。不应尔。若比丘僧十四日自恣。比丘尼僧十五日自恣。若大僧病。若众不和合。若众不满。比丘尼应遣信礼拜问讯。不者突吉罗。若比丘尼僧病。若众不和合。若众不满。比丘僧亦当遣信礼拜问讯。不者突吉罗(其至大僧中受自恣人还。共尼僧作自恣。其自恣一与上大僧同)

    分衣法第七(与上大僧同)

    衣食净法第八(尼无作余食法。除此已余皆与大僧同)

    杂法第九(尼无乞处分作房法。自余皆与上大僧同)

内护匡救僧众摈罚羯磨法

律藏所明僧之正法。宗要有三。故结集称言。是法是毗尼是佛所教

法者。谓五种远离行。何等五。一者出离非世法。二越度非受法。三无欲非有欲。四无结非有结。五不亲近生死非亲近

毗尼者。谓五种出要行何等五。一少欲非多欲。二知足非无厌。三易护非难护。四易养非难养。五智慧非愚痴

佛所教者。谓五种教诫行。何等五。一有罪行者制。二无罪者听。三若制若听法。有缺减者如法举之。四数数违犯折伏与念。五真实功德爱念称叹。故经云。正法住正法灭。谓之。于此传法之人。亦有于三。故圣诰称言。知法知律知摩夷。知法者。谓善持修多罗藏。如阿难等。知律者。谓善持毗尼藏。如优波离等。知摩夷者。谓善于训导宰任玄纲。如大迦叶等。故凡欲晖踪圣迹以隆道教继轨后代不绝于时者。非兹而谁

五种入众法。何等五。一应以慈心。二应自卑下如拭尘巾。三应善知坐起上下威仪。四不杂说俗事。为众说法。若请他说。五若见僧中有不可事。心不安忍应作默然

五种如法默然。何等五。一见他非法而默然。二不得伴而默然。三犯重而默然。四同住默然。五在同住地默然

五种非法默然。何等五。一如法羯磨而心不同。默然在之。二得同意伴亦默然任之。三若见小罪而默然。四为作别住而默然。五在戒场上而默然

五种弃法。何等五。一比丘犯罪。余比丘问。汝犯罪见不。答言不见。彼语言。汝若见罪应忏悔。二比丘犯罪。余比丘问。汝犯罪见不。答言不见。彼语言。汝若见罪。应僧中忏悔。三比丘犯罪。余比丘问言。汝犯罪见不。答言不见。彼语言。汝若见罪。当于此僧中忏。四比丘犯罪。余比丘问言。汝犯罪见不。答言不见。众僧应舍弃语言。汝不见罪。随所至处。不听汝布萨。如恶马难调合缰杙俱弃。汝亦如是。五比丘犯罪。余比丘问言。汝犯罪见不。答言不见。彼应僧中作不见举羯磨

五种作羯磨法。何等五。一见前。二自言。三不清净。四如法。五和合

斯谓知病知药知对治。善于废兴通塞存护之仪。故致任持之功义显于此

三种调法谓呵责羯磨。摈羯磨。依止羯磨

三种灭法谓罪处所。多人语。如草覆地

三种不共住法。谓三举羯磨恶骂治灭摈羯磨

呵责羯磨文(先作举作忆念与罪已。然后作羯磨)

大德僧听。此比丘某甲。喜共斗诤共相骂詈。口出刀剑互求长短。彼自共斗诤已。若复有余比丘斗诤者。即复往彼劝言。汝等免力莫不如他。汝等多闻智慧财富。亦胜多有知识。我等当为汝作伴傥。令僧未有诤事而有诤事。已有诤事。而不除灭。若僧时到僧忍听。为比丘某甲作呵责羯磨。若后复更斗诤共相骂詈言。众僧当更增罪治白如是

大德僧听。此比丘某甲。喜共斗诤共相骂詈。口出刀剑互求长短。彼自共斗诤已。若复有余比丘斗诤者。即复往彼劝彼言。汝等免力莫不如他。汝等智慧多闻财富。亦胜多有知识。我等当为汝作伴傥。令僧未有诤事而有诤事。已有诤事而不除灭。僧为比丘某甲作呵责羯磨。谁诸长老忍。僧与比丘某甲作呵责羯磨。若复更斗诤共相骂詈者。众僧当更增罪治。忍者默然。不忍者说。是初羯磨(如是三说)

僧已忍。为比丘某甲作呵责羯磨竟。僧忍默然故。是事如是持(与羯磨已以夺三十五事。令其折伏。后若随顺改悔者。僧应还与解羯磨)

与罪处所羯磨文(先作举作忆念与罪已。然后作羯磨)

大德僧听。是比丘某甲。无惭无愧多犯诸罪。有见闻疑。先自言犯后言不犯。前后言语相违。若僧时到僧忍听。僧今与比丘某甲罪处所羯磨。白如是

大德僧听。是比丘某甲。无惭无愧多犯诸罪。有见闻疑。先自言犯后言不犯。前后言语相违。僧今与是比丘某甲罪处所羯磨。谁诸长老忍。僧今与比丘某甲罪处所羯磨者默然。谁不忍者说。是初羯磨(如是三说)

僧已忍与比丘某甲罪处所羯磨竟。僧忍默然故。是事如是持(与羯磨已以三十五事。令其折伏后若随顺改悔。僧应还与解羯磨)

与灭摈羯磨文(先作举作忆念与罪已。然后作羯磨)

大德僧听。是比丘某甲。犯某甲波罗夷罪。若僧时到僧忍听。僧今与比丘某甲波罗夷罪灭摈羯磨。不得共住不得共事。白如是

大德僧听。是比丘某甲。犯某甲波罗夷罪。僧今与比丘某甲波罗夷罪灭摈羯磨。不得共住不得共事。谁诸长老忍僧与比丘某甲波罗夷罪灭摈羯磨不得共住不得共事者默然。谁不忍者说。是初羯磨(如是三说)

僧已忍。与比丘某甲波罗夷罪灭摈羯磨不得共住不得共事竟。僧忍默然故。是事如是持(此永摈无解法)此后三羯磨。皆是治罚法。但以过有轻重。阶之为三。前呵责羯磨等。是调伏法。罪处所羯磨等。是折伏法。灭摈羯磨等。是驱出法。故经言应调伏者而调伏之。应折伏者而折伏之。应罚黜者而罚黜之。若随事而言。羯磨非一。备明律典。宁容具集。故各当其分唯标一羯磨。示之恒式。余类准以可知

四分比丘尼羯磨法一卷按此羯磨一卷。宋本与国本则同。丹本将二本独异何耶。今捡丹本。与怀素所集文义大同。又其起尽有伦叙可观。知是跋摩所译正本。故取之入藏。彼国宋二本甚是错乱。凡尼出家始终之例。初求出家。次受十戒学法。二岁受具足戒。久后方乞畜众羯磨度人授戒。乃其序也。二本于受六法请和尚文。重用沙弥请十戒文。此一乱也。以乞畜众文系乎受大戒前。二乱也。凡尼受戒。先于尼僧中受。后至大僧而受。二本即云。二部僧听。不分先后。三乱也。其学戒六法中。四分即以非时食与饮酒为第五六。而二本乃以摩触八事为五为六。四乱也。首题既云尼羯磨。二本即有比丘度沙弥法。沙弥受十戒法。大僧受具戒法等。五乱也。开元录云。宋求那跋摩译。二本但云。女人出家法。六乱也。故知二本是乃后代无稽之人臆度乱钞耳。不可依用。今故遆之

不来诸比丘尼说欲及清净(除结界无受欲法。若自恣时应言)说欲及自恣(复应白僧言)大姊僧听。僧今何所作为(僧中一人应随前事答)某甲羯磨(但结界法。二界不得相接。应留中间。亦不得隔驶流水结。除常有桥梁。若欲大界内安戒场者。先竖戒场四方相。于外下至相去一肘。竖大界内相。外随远近亦竖四方相。使一旧住比丘尼唱其方相。众中差堪能羯磨者结。应先结大界后结戒场。如欲唱此大界相者。先从外相东南角起。四方一周。又唱内相。亦令一周言。彼为外相。此为内相。此是大界内外相一周。如是三唱。若内无戒场。直唱外相结大小界法。僧应尽集。不得受欲)

结大界羯磨文

大姊僧听。此住处比丘尼某甲。唱四方大界相。若僧时到僧忍听。僧今于此四方相内结大界。同一住处同一说戒。白如是。大姊僧听。此住处比丘尼某甲唱四方大界相。僧今于此四方相内结大界。同一住处同一说戒。谁诸大姊忍僧于此四方相内结大界同一住处同一说戒者默然。谁不忍者说。僧已忍于此四方相内结大界。同一住处同一说戒竟。僧忍默然故。是事如是持

结界场羯磨文(元戒场之兴。为以住处众大难集故。别结此界。用拟众中有于要事随时得作。故不容即解。若不依住处。但为暂时作法者。事讫去即便解。不容不解)

大姊僧听。此住处比丘尼某甲。称四方小界相。若僧时到僧忍听。僧今于此四方小界相内。结作戒场。白如是。大姊僧听。此住处比丘尼某甲。称四方小界相。僧今于此四方小界相内。结作戒场。谁诸大姊忍僧于此四方相内结作戒场者默然。谁不忍者说。僧已忍于此四方相内结作戒场竟。僧忍默然故。是事如是持

解大界羯磨文(时诸比丘尼意有欲广作界者。有欲陜作界者。佛言。自今已去若欲改作者。先解前界然后欲广陜从意。当白二羯磨解)

大姊僧听。今此住处比丘尼。同一住处同一说戒。若僧时到僧忍听解界。白如是。大姊僧听。此住处比丘尼。同一住处同一说戒。今解界。谁诸大姊忍。僧同一住处同一说戒解界者默然。谁不忍者说。僧已忍同一住处同一说戒解界竟。僧忍默然故。是事如是持

结不失衣界羯磨文(不失衣界。即依大界相结。无别异相。故文言还称此住处)

大姊僧听。此住处同一住处同一说戒。若僧时到僧忍听。僧今结不失衣界。除村村外界。白如是。大姊僧听。此住处同一住处同一说戒。僧今结不失衣界。除村村外界。谁诸大姊忍僧于此住处。同一住处同一说戒。结不失衣界。除村村外界者默然。谁不忍者说。僧已忍同一住处同一说戒。结不失衣界。除村村外界竟。僧忍默然故。是事如是持

解不失衣界羯磨文(大界不失衣界。既是一处重结。故前后解结互易不同。若欲解者。应先解不失衣界。却解大界)

大姊僧听。此住处比丘尼。同一住处同一说戒。若僧时到僧忍听。僧今解不失衣界。白如是。大姊僧听。此住处比丘尼。同一住处同一说戒。僧今解不失衣界。谁诸大姊忍。僧同一住处同一说戒解不失衣界者默然。谁不忍者说僧已忍同一住处同一说戒。解不失衣界竟。僧忍默然故。是事如是持

结小界羯磨文(若布萨日诸比丘尼。于无村野路中行欲说戒众多难集不得和合。听随同师善友知识。下道别集一处结小界说戒)

大姊僧听。今有尔许比丘尼集。若僧时到僧忍听。结小界。白如是。大姊僧听。今有尔许比丘尼集。结小界。谁诸大姊忍。尔许比丘尼集结小界者默然。谁不忍者说。僧已忍尔许比丘尼集结小界竟。僧忍默然故。是事如是持

解小界羯磨文

大姊僧听。今有尔许比丘尼集。若僧时到僧忍听。解此处小界。白如是。大姊僧听。今有尔许比丘尼集。解此处小界。谁诸大姊忍僧解此处小界者默然。谁不忍者说。僧已忍解此处小界竟。僧忍默然故。是事如是持

结同一说戒同一利养羯磨文(若二住处彼此各别今欲共合同一说戒同一利养者。先彼此各自解本界。然后两住处通竖标相。合为一界。僧尽集一处羯磨结)

大姊僧听。如所说界相。若僧时到僧忍听。僧今于此处彼处。结同一说戒同一利养。白如是。大姊僧听。如所说界相。僧今于此处彼处。结同一说戒同一利养。谁诸大姊忍僧于此处彼处同一说戒同一利养结界者默然。谁不忍者说。僧已忍于此处彼处同一说戒同一利养结界竟。僧忍默然故。是事如是持

结同一说戒别利养羯磨文(亦先彼此各解本界。然后两住处。通竖标相。合为一界。僧尽集一处作羯磨结之)

大姊僧听。如所说界方相。若僧时到僧忍听。僧今于此处彼处。结同一说戒别利养。白如是。大姊僧听。如所说界方相僧今于此处彼处。结同一说戒别利养。谁诸大姊忍僧于此四方相内结同一说戒别利养者默然。谁不忍者说僧已忍于此四方相内结同一说戒别利养竟。僧忍默然故。是事如是持

(若二住处先共同说戒同利养或同说戒别利养。后还欲别者。应先解界。后各自唱界相依旧别结)

结别说戒同一利养羯磨文

大姊僧听。若僧时到僧忍听。僧今于此彼住处。结别说戒同一利养。为守护住处故。白如是。大姊僧听。僧今于此彼住处。结别说戒同一利养。为守护住处故。谁诸大姊忍僧于此彼住处结别说戒同一利养为守护住处故者默然。谁不忍者说。僧已忍于此彼住处结别说戒同一利养为守护住处故竟。僧忍默然故。是事如是持


四分律

    No. 1428 [cf. Nos. 1429-1434]

    四分律序

夫戒之兴。所以防邪检失。禁止四魔。超世之道。非戒不弘。斯乃三乘之津要。万善之窟宅者也。然群生愚惑。安寝冥室。宛转四流。甘履八苦。开恶趣之原。杜归真之路。游游长夜。莫能自觉。时有出家庶几玄微者。徒怀远趣。迷于发足。是以如来。悼群瞽之无目。睹八难以增哀。开戒德之妙门。示涅槃之正路。始于毗耶离初结兹戒。凡有二百五十八篇。以此七罪科分。升降相从轻重位判。斯皆神口之所制祸福之定楷者也。然律藏渊旷。卷舒无常。略而至三。广则无量。此二百五十。盖因时人之作也。足以启曚。足以阶道。三宝之隆。以之为盛。先圣之道。斯为美矣。自大教东流。几五百载。虽蒙余晖。然律经未备。先进明哲。多以戒学为心。然方殊音隔。文义未融。推步圣踪。难以致尽。所以怏怏终身。西望叹息。暨至壬辰之年。有晋国沙门支法领。感边土之乖圣。慨正化之未夷。乃亡身以俎险。庶弘道于无闻。西越流沙。远期天竺。路经于阗。会遇昙无德部。体大乘三藏。沙门佛陀耶舍。才体博闻。明炼经律。三藏方等。皆讽诵通利。即于其国。广集诸经于精舍还。以岁在戊申。始达秦国。秦主姚。欣然。以为深奥冥珍嘉瑞。而谓大法渊深。济必由戒。神众所传。不可有阙。即以其年。重请出律藏。时集持律沙门三百余人。于长安中寺出。即以领弟子慧辩。为译校定。陶炼反覆。务存无朴。本末精悉。若睹初制。此土先所出戒。差互不同。每以为惑以今律藏检之。方知所以。盖由大圣迁化后。五部分张。各据当时所闻。开闭有以。于是师资相传。遂使有彼此之异。会曩推之。虽复小小差互。终归一本。何以明之。如萨婆多部律。着涅槃僧。着三衣。分为多名。余部亦尔。此律藏。总为一名。齐整而已。高下参差。乃是齐整之义说。以是推之。五部之差粗。亦可领想。诸寻求不以为惑。今律藏画然。正教明白。可以济神。可以无惑。而今之学者。多修文饰之印。不以戒学为先。由使佛藏有鸟鼠之喻。众集有猿猴之况。斯之苦切亦以极矣。凡我之徒。宜各勖励。明慎执持。令大法久住焉

四分律卷第一(初分之一)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

  稽首礼诸佛　　及法比丘僧
  今演毗尼法　　令正法久住
  优波离为首　　及余身证者
  今说戒要义　　诸贤咸共听
  今欲说深戒　　为乐持戒者
  为能讽诵者　　利益诸长老
  今说十句义　　诸佛之戒法
  令僧喜永安　　摄取于僧故
  不信者令信　　已信者增长
  断不持戒者　　令邪道入正
  惭愧者安隐　　佛法得久住
  是以世最胜　　演布禁戒经
  众山须弥最　　众流海为最
  众经亿百千　　戒为第一最
  欲求第一最　　今世及后世
  当持此禁戒　　终身莫毁犯
  除结无挂碍　　缚着由此解
  以戒自观察　　如镜照面像
  夫欲造善法　　备具三种业
  当审观其意　　如罗云经说
  所以立王者　　由世诤讼故
  众人之所举　　古昔之常法
  犯罪者知法　　顺法者成就
  戒律亦如是　　如王治正法
  如医观众病　　进止得其所
  可治则进药　　不可者则舍
  如医经所说　　四事不可治
  可救有十三　　余者不须救
  譬如有死尸　　大海不容受
  为疾风所飘　　弃之于岸上
  诸作恶行者　　犹如彼死尸
  众所不容受　　以是当持戒
  如守门牢固　　不忧失财物
  若垣墙缺坏　　有财者忧惧
  佛戒不缺漏　　奉持者无忧
  禁戒不牢固　　毁犯者怀忧
  坏器多穿漏　　瓦师怀愁忧
  器物若完具　　眷属皆欢喜
  持戒有缺漏　　为恶者常忧
  不毁禁戒者　　心常怀欢喜
  如熛火虽微　　莫轻以为小
  所经诸草木　　烧尽无有余
  所造恶虽微　　慎莫谓为轻
  如破伊罗叶　　常在于龙中
  如师子虎吼　　醉者不恐怖
  小兽声虽微　　醒者闻则惧
  如是三垢人　　一切恶不惧
  智者于微恶　　常怀于恐畏
  如合和众药　　择去不良者
  病者服除愈　　身康得安乐
  如是念修戒　　能避诸恶行
  除诸结使患　　安隐入涅槃
  若欲涉远路　　当自护其足
  足若毁坏者　　不能涉远道
  求天若涅槃　　方便守护戒
  如是无毁坏　　必能度险道
  如人欲渡河　　用手及浮囊
  虽深无没忧　　便能到彼岸
  如是诸佛子　　修行禁戒本
  终不回邪流　　没溺生死海
  譬如帝释堂　　雕饰众宝成
  七宝为阶陛　　天人之所行
  如是正法堂　　七觉意庄严
  禁戒为阶陛　　贤圣之所行
  如善学世间　　一切众技艺
  为王所爱念　　以是得安乐
  佛所说禁戒　　能善修学者
  终不堕恶趣　　永得安隐处
  如先自牢众　　然后破彼军
  贤圣众牢固　　然后破魔军
  圣众若和合　　世尊所称誉
  以众和合故　　佛法得久住
  如乳母慈爱　　养护于其子
  一切水火难　　护使不伤害
  禁戒犹慈母　　守护于行者
  终不堕畜生　　饿鬼地狱中
  如有勇猛将　　善习战斗法
  降伏于彼敌　　没死不顾命
  佛子亦如是　　善学于禁戒
  五阴散坏时　　终不畏命尽
  从佛戒所生　　尔乃是真生
  犹如鸯崛魔　　如来所记别
  若有舍戒者　　于佛法为死
  持戒如护命　　守之无毁失
  譬如得王印　　所往无挂碍
  毁缺则难诘　　全失则被缚
  戒印全具者　　所至无挂碍
  小毁则不定　　大毁入三恶
  为一切人故　　降伏诸魔鬼
  神仙五通人　　造设于咒术
  为彼惭愧者　　摄诸不惭愧
  如来立禁戒　　半月半月说
  已说戒利益　　稽首礼诸佛

(此偈非是迦叶千众集律。时人所造。乃是后五部分张各据所传。即是居一众之首者。将欲为众辨释律相故。先偈赞然后说之)

    四波罗夷法之一

尔时佛游苏罗婆国。与大比丘众五百人俱。渐渐游行至毗兰若。即于彼宿那邻罗滨洲曼陀罗树下。毗兰若婆罗门闻。瞿昙沙门释家子。离释种出家为道。从苏罗婆国。将大比丘众五百人俱。渐渐游行来至此毗兰若。那邻罗滨洲曼陀罗树下住。此沙门瞿昙。有如是大名称。如来无所著等正觉明行足为善逝世间解无上士调御丈夫天人师佛世尊。彼于诸天魔梵沙门婆罗门众中。获神通作证常说正法。上善中善下善义味清净。自然具足修习梵行。善哉我等得见如是无著人。我今宁可宜往问讯沙门瞿昙。尔时毗兰若婆罗门。即往世尊所。到已共相问讯在一面坐。时世尊无数方便为说法开化令得欢喜。闻佛说法得欢喜已。即白佛言。世尊。唯见哀愍当受我请。及比丘僧三月夏安居。时世尊及比丘僧默然受请。毗兰若婆罗门见世尊默然受请。即从坐起绕佛而去。世尊与五百比丘众受彼夏安居三月。时有波离国贩马人。驱五百疋马住毗兰若。夏九十日。时世谷贵人民饥饿。白骨狼藉乞求难得。时毗兰若婆罗门。虽请如来及比丘僧。三月都不供养供给所须。何以故。皆是魔波旬所作。尔时诸比丘从毗兰若乞食不得。次往彼贩马人所乞食。时贩马人自念。如今此间时世谷贵人民饥饿乞食难得白骨狼藉。彼诸比丘从彼乞食不得故来此耳。我今宁可日施比丘马麦五升世尊一斗耶。即如所念。日与诸比丘马麦五升世尊一斗。时佛所得麦分与阿难。阿难使人磨作干饭奉佛。佛食干饭。诸比丘各各得成煮麦而食。佛与比丘所食各异。时尊者大目连。往世尊所头面作礼却坐一面。白世尊言。大德。今此间谷贵人民饥饿乞求难得。诸比丘食饮粗恶而皆羸瘦。若世尊听诸神足比丘诣郁单越取自然粳米食者当往。佛告目连言。诸有神足比丘可往至彼取粳米食。无神足者当云何。目连白佛。诸有神足者随意自往。不得神足者我当以神足力接往至彼。佛告目连。止止。莫作是语。何以故汝等丈夫得神足可尔。未来世比丘当云何。时尊者舍利弗。于闲静处作是念言。何者等正觉修梵行佛法久住。何者等正觉修梵行佛法不久住。尔时舍利弗从静处起。整衣服至世尊所。头面礼足在一面坐。须臾退坐。白世尊言。向者我于静处坐。作是念。何者等正觉修梵行佛法久住。何者等正觉修梵行佛法不久住。愿为开示。佛告舍利弗。毗婆尸佛式佛拘留孙佛迦叶佛。此诸佛修梵行法得久住。随叶佛拘那含牟尼佛法不久住。舍利弗白佛言。以何因缘毗婆尸佛式佛拘留孙佛迦叶佛。修梵行法得久住。以何因缘故随叶佛拘那含牟尼佛。修梵行法不得久住耶。佛告舍利弗。拘那含牟尼佛随叶佛。不广为诸弟子说法。契经。祇夜经。授记经。偈经。句经。因缘经。本生经。善道经。方等经。未曾有经。譬喻经。优波提舍经。不为人广说契经乃至优波提舍经。不结戒亦不说戒。故诸弟子疲厌是以法不久住。尔时彼世尊知诸弟子疲厌心故但作如是教。是事应念是不应念。是应思惟是不应思惟。是应断是应具足住。舍利弗。乃往昔时。随叶佛依恐畏林中住。与大比丘千人俱。舍利弗。若有人未离欲。入彼林中身毛皆竖故名恐畏林。又舍利弗。拘那含牟尼佛随叶佛如来至真等正觉。观千比丘心中疲厌为说法。是事应念是不应念。是事应思惟是事不应思惟。是应断。是应具足住。舍利弗当知。尔时彼佛及诸声闻在世佛法广流布。若彼佛及诸声闻灭度。后世间人种种名种种姓种种家出家。以是故疾灭佛法不久住。何以故不以经法摄故。舍利弗。譬如种种花散置案上。风吹则散。何以故以无线贯穿故如是。舍利弗。彼佛及声闻众在世者佛法流布。若彼佛及诸声闻众灭后。世间人种种名种种姓种种家出家者令法疾灭不久住。何以故不以经法摄取故。尔时世尊告舍利弗。毗婆尸佛式佛拘留孙佛迦叶佛。为诸弟子广说经法。从契经乃至优波提舍经。亦结戒亦说戒。弟子众心疲厌。时佛知彼心疲厌。作如是教。是应念是不应念。是应思惟是不应思惟。是应断是应具足住。如是舍利弗。彼诸佛及声闻众在世佛法流布。若彼诸佛及声闻众灭度后。诸世间人种种名种种姓种种家出家不令佛法疾灭。何以故以经法善摄故。舍利弗。譬如种种华置于案上以线贯。虽为风吹而不分散。何以故以线善贯摄故。如是舍利弗。彼佛及声闻众在世者佛法广说如上。舍利弗以此因缘故。毗婆尸佛乃至迦叶佛佛法得久住。以此因缘故拘那含牟尼佛随叶佛佛法不得久住。尔时舍利弗从坐而起。偏露右臂右膝着地合掌白佛言。世尊。今正是时。唯愿大圣。与诸比丘结戒说戒。使修梵行法得久住。佛告舍利弗且止。佛自知时。舍利弗。如来未为诸比丘结戒。何以故比丘中未有犯有漏法。若有犯有漏法者。然后世尊为诸比丘结戒。断彼有漏法故。舍利弗。比丘乃至未得利养。故未生有漏法。若得利养便生有漏法。若有漏法生。世尊乃为诸比丘结戒。欲使彼断有漏法故。舍利弗。比丘未生有漏法者。以未有名称为人所识多闻多财业故。若比丘得名称乃至多财业。便生有漏法。若有漏法生。然后世尊当为结戒。欲使彼断有漏法故。舍利弗。汝且止。如来自知时

尔时世尊在毗舍离。时迦兰陀村须提那子。于彼村中饶财多宝持信牢固出家为道。时世谷贵乞求难得。时须提那子作是思惟。今时世谷贵诸比丘乞求难得。我今宁可将诸比丘诣迦兰陀村乞食。诸比丘因我故大得利养。得修梵行。亦使我宗族快行布施作诸福德。作是念已。即将诸比丘诣迦兰陀村。须提那母闻其子将诸比丘还归本村。即往迎。到彼子所语其子言。可时舍道还作白衣。何以故汝父已死。我今单独。恐家财物没入于官。但汝父财既多。况祖父已来财物无量甚可爱惜。是以汝今应舍道就俗。即答母言。我不能舍道习此非法。今甚乐梵行修无上道。如是至三。其子亦答言。不能舍道还俗。其母便舍之而去。诣其妇所语言。汝月期时至便来语我。妇自知时到往语其姑。大家欲知我月期时至。母语其妇汝取初嫁时严身衣服尽着而来。即如其教便自庄严。与母共俱至其儿所。今正是时便可舍道就俗。何以故。汝若不舍道者我财物当没入于官。儿答母言。我不能舍道。母如是再三语子言。汝妇今日华水已出。便可安子使汝种不断。子白母言。此事甚易我能为之。时迦兰陀子。佛未制戒。前不见欲秽。便捉妇臂将至园中屏处三行不净。时园中有鬼命终即处其胎。处胎九月生男。颜貌端政与世无双。字为种子。诸根具足渐渐长大。剃发被袈裟以信坚固出家学道。精勤不懈得阿罗汉。神足变化威德无量。故号尊者种子。须提那习沙门威仪。无事不知触事皆行。亦能转教于人。尔时须提那。行不净已来常怀愁忧。诸同学见已问。汝何愁忧耶。汝久修梵行。威仪礼节无事不知。何所愁为不乐梵行耶。须提那言。我甚乐梵行。近在屏处犯恶行。与故二行不净故愁耳。诸比丘言。须提那。汝云何乃作如是恶事。于如来清净法中。于欲无欲于垢无垢。能断渴爱破坏巢窟。除众结缚爱尽涅槃。汝今云何于此清净法中。与故二共行不净行耶。尔时诸比丘往至世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集诸比丘。世尊知而问知而不问。时而问时而不问。义合问。义不合不问。尔时世尊知时义合。问须提那。汝实与故二行不净行耶。如是世尊。我犯不净行。尔时世尊以无数方便呵责言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。汝须提那。云何于此清净法中行乃至爱尽涅槃。与故二行不净耶。告诸比丘。宁持男根着毒蛇口中。不持着女根中。何以故不以此缘堕于恶道。若犯女人。身坏命终堕三恶道。何以故我无数方便说断欲法。断于欲想灭欲念。除散欲热越度爱结。我无数方便说欲如火。如把草炬亦如树果。又如假借犹如枯骨。亦如段肉如梦所见。如履锋刃如新瓦器盛水着于日中。如毒蛇头如轮转刀。如在尖标如利戟刺。甚可秽恶佛所呵责。须提那。于我清净法中乃至爱尽涅槃。与故二行不净行。尔时世尊无数方便呵责已告诸比丘。须提那痴人。多种有漏处最初犯戒。自今已去。与诸比丘结戒。集十句义。一摄取于僧。二令僧欢喜。三令僧安乐。四令未信者信。五已信者令增长。六难调者令调顺。七惭愧者得安乐。八断现在有漏。九断未来有漏。十正法得久住。欲说戒者当如是说。若比丘犯不净行行淫欲法。是比丘波罗夷不共住。如是世尊。与诸比丘结戒。尔时有跋阇子比丘。愁忧不乐净行。即还家共故二行不净行。彼作是念。世尊与诸比丘结戒。若比丘犯不净行。行淫欲法。是比丘波罗夷不共住。然我愁忧不乐净行。还家与故二共行不净行。我将不犯波罗夷耶。我当云何即便语诸同学言。长老。世尊为诸比丘结戒。若比丘犯不净行行淫欲法。是比丘犯波罗夷不共住。然我有愁忧不乐净行。还家与故二共行不净行。我将无不犯波罗夷耶。我今当云何。善哉长老。为我以此事白佛。随佛所教我当奉行。尔时诸比丘往至世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。无数方便呵责跋阇子比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何痴人。不乐净行。还家与故二行不净行。初入便波罗夷。汝痴人得波罗夷不共住。是故比丘。若有余人不乐净行。听舍戒还家。若复欲出家于佛法中修净行。应度令出家受大戒。自今已去当如是说戒。若比丘共比丘同戒。若不舍戒。若戒羸不自悔。犯不净行行淫欲法。是比丘波罗夷不共住。如是世尊与诸比丘结戒。尔时有一乞食比丘依林中住。有一雌猕猴先在彼林中。时乞食比丘到村乞食还在林中食。食已余食与此猕猴。如是渐渐调顺。逐比丘后行乃至手捉不去。此比丘即捉猕猴共行不净。时有众多比丘案行住处。次至彼林中。时彼猕猴在比丘前。回身背之现其淫相。时诸比丘作是念。此猕猴在我等前回身现其淫相。将无与余比丘作不净行耶。咸共相告在屏处伺之。彼比丘乞食还在林中食已以余食与彼猕猴。猕猴食已便共行不净行。诸比丘见已即来语言。如来不制言比丘不得行不净行耶。彼比丘报言。如来所制男犯妇女。不制畜生。诸比丘闻此语已往至佛所。头面作礼以此因缘具白世尊。世尊尔时以此因缘即集比丘僧。无数方便呵责彼乞食比丘言。云何比丘。与猕猴共行不净行耶。初入波罗夷。欲说戒者当如是说。若比丘共比丘同戒。若不还戒戒羸不自悔。犯不净行乃至共畜生。是比丘波罗夷不共住。若比丘者。名字比丘。相似比丘。自称比丘。善来比丘。乞求比丘。着割截衣比丘。破结使比丘。受大戒白四羯磨如法成就得处所比丘。是中比丘。若受大戒白四羯磨如法成就得处所。住比丘法中。是谓比丘义。是中共比丘者。余比丘受大戒白四羯磨如法成就得处所住比丘法中。是共比丘义。云何名为同戒。我为诸弟子结戒已宁死不犯。是中共余比丘一戒同戒等戒是名同戒云何名不舍戒。颠狂舍戒。颠狂人前舍戒。心乱舍戒。心乱人前舍戒。痛恼舍戒。痛恼人前舍戒。哑舍戒。聋舍戒。哑聋舍戒。哑人前舍戒。聋人前舍戒。哑聋人前舍戒。中国人边地人前舍戒边地人中国人前舍戒。不静静想舍戒。静作不静想舍戒。戏笑舍戒。若天若龙若夜叉若饿鬼若睡眠人若死人若无知人。若自不语。若语前人不解。如是等不名舍戒。云何舍戒。若比丘不乐修梵行。欲得还家厌比丘法。常怀惭愧贪乐在家。贪乐优婆塞法。或念沙弥法。或乐外道法。乐外道弟子法。乐非沙门非释子法。便作如是语。我舍佛舍法舍比丘僧。舍和上舍同和上舍阿阇梨舍同阿阇梨。舍诸梵行舍戒舍律舍学事。受居家法我作净人。我作优婆塞。我作沙弥。我作外道。我作外道弟子。我作非沙门非释种子。若复作如是语。我止不须佛。佛于我何益。离于佛所。如是乃至学事亦如是。若复作余语。毁佛法僧乃至学事。便赞叹家业乃至非沙门非释子。以如是语了了说是名舍戒。戒羸者。或有戒羸不舍戒。或有戒羸而舍戒。何者戒羸不舍戒。若比丘愁忧不乐梵行。欲得还家厌比丘法。常怀惭愧意乐在家。乃至乐欲作非沙门非释子法。便作是言。我念父母兄弟姊妹妇儿村落城邑园田浴池。我欲舍佛法僧乃至学事。便欲受持家业。乃至非沙门非释种子。是谓戒羸不舍戒。何者戒羸而舍戒。若作如是思惟。我欲舍戒便舍戒。是谓戒羸而舍戒。不净行者是淫欲法。下至共畜生者。可行淫处者是也。云何名波罗夷。譬如断人头不可复起。比丘亦复如是。犯此法者不复成比丘故名波罗夷。云何名不共住。有二共住。同一羯磨同一说戒。不得于是二事中住故名不共住。三种行不净行波罗夷。人非人畜生。复有五种行不净行波罗夷。人妇童女有二形黄门男子。于此五处行不净行波罗夷。于三种妇行不净行波罗夷。何者三。人妇非人妇畜生妇。于此三处行不净行犯波罗夷。三种童女。三种二形。三种不能男三种男子。于此行不净行波罗夷亦如是。犯人妇三处波罗夷大便道小便道及口。非人妇畜生妇。人童女非人童女畜生童女。人二形非人二形畜生二形。三处亦如是。人黄门二处行不净行波罗夷。大便道及口。非人黄门畜生黄门亦如是。人男非人男畜生男二处亦如是。比丘有淫心向人妇女大便道小便道及口。若初入犯。若不入不犯。有隔有隔。有隔无隔。无隔有隔。无隔无隔。波罗夷。若比丘有淫意。向非人妇女畜生妇女人童女非人童女畜生童女人二形非人二形畜生二形。三处亦如是人黄门非人黄门畜生黄门。人男非人男畜生男。二处亦如是。若比丘淫意向人睡眠妇女。若死形未坏多未坏大便道小便道及口。若初入犯。不入不犯。有隔无隔亦如是广说。乃至男子亦如是。若比丘为怨家将至人妇女所。强持男根令入三处。始入觉乐。入已乐。出时乐。波罗夷。始入乐。入已乐。出时不乐。波罗夷。始入乐。入已不乐。出时乐。波罗夷。始入乐。入已不乐。出时不乐。波罗夷。始入不乐。入已乐。出时乐。波罗夷。始入不乐。入已不乐。出时乐。波罗夷。有隔无隔亦如是。从非人女乃至男子亦如是。若比丘为怨家将至人睡眠妇女若死形未坏。若多未坏觉乐亦如是。有隔无隔亦如是。从非人女乃至男子亦如是。若怨家强捉比丘大便道中行不净。若入觉乐波罗夷。入已觉乐出时觉乐亦如上乃至有隔无隔亦如上。从道入道。从道入非道。从非道入道。若限齐入。若尽入。若语不语若以淫心乃至入如毛头波罗夷。方便而不入偷兰遮。若比丘方便求欲行不净行。成者波罗夷不成者偷兰遮。若比丘教比丘行不净行。彼比丘若作教者偷兰遮。若不作教者突吉罗。比丘尼教比丘行不净行。若比丘作尼偷兰遮。不作尼突吉罗。除比丘比丘尼。余众相教行不净行。作不作尽犯突吉罗。若死尸半坏行不净入便偷兰遮。若多分坏若一切坏偷兰遮。若骨间行不净偷兰遮。若穿地作孔抟泥作孔若君持口中犯偷兰遮。若道想若疑如是一切偷兰遮。若道作道想波罗夷。若道疑波罗夷。若道非道想波罗夷。非道道想偷兰遮。非道疑偷兰遮。比丘尼波罗夷。式叉摩那沙弥沙弥尼突吉罗灭摈。是谓为犯。不犯者若睡眠无所觉知不受乐一切无有淫意不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠无犯(一竟)

尔时世尊。游罗阅城耆阇崛山中。时罗阅城中有比丘字檀尼迦陶师子。在闲静处止一草屋。彼比丘入村乞食。后有取薪人破其草屋持归。比丘乞食还作是念。我今独在闲静处自取草木作屋。入村乞食。后取薪柴人破我屋持归。我今自有技艺。宁可和泥作全成瓦屋。时彼比丘即便和泥作全成瓦屋。取柴薪牛屎烧之。屋成色赤如火。尔时世尊从耆阇崛山下。遥见此舍色赤如火。见已知而故问。诸比丘此是何等赤色。诸比丘白佛言。世尊。有一比丘名檀尼迦陶师子。独处闲静住一草屋。乞食后诸取薪人破其屋持归。彼还见舍破即作是念。我自有技艺今宁可作全成瓦屋于中止住。即便作之。是其屋色赤如是。尔时世尊以无数方便呵责彼比丘言。汝所为非。非威仪非沙门法非净行非随顺行所不应为。云何檀尼迦比丘陶师子。自作此屋大集柴薪牛屎而烧之。我常无数方便说慈愍众生。云何痴人。自作泥屋聚积柴薪牛屎而烧之。自今已去不得作赤色全成瓦屋。作者突吉罗。尔时世尊敕诸比丘。汝等共集相率速诣檀尼迦屋所打破。时诸比丘即如佛教往诣打破。时檀尼迦见诸比丘破屋已便作是语。我有何过而破我屋。诸比丘答曰。汝无有过亦不憎汝。我向受世尊教故来破汝屋耳。檀尼迦比丘言。若世尊教敕者正是其宜。尔时摩竭国瓶沙王有守材人。与此檀尼迦比丘少小亲厚知识。时檀尼迦比丘往至守材人所语言。汝知不耶。王瓶沙与我材木。我今须材便可与我。彼人言。若王与者好恶多少随意自取。王所留要材比丘辄取斫截持去。时有一大臣统知城事。至材坊见王所留要材斫截狼藉。见已即问守材人言。此王所留要材谁斩截持去。守材人言。是檀尼迦比丘。来至我所而作是言。王与我材。今须材用便可见与。我寻报言。王与汝材恣意取之。时比丘即入材坊斫截持去。时大臣闻此语已即嫌王言。云何以此要材与比丘。幸自更有余材可以与之。而令此比丘斫截要材持去。时大臣往至王所白言。大王。先所留要材云何乃与比丘令斫截持去。幸自更有余材可以与之。何故坏此好材。王报言。我都不自忆以材与人。若有忆者语我。时大臣即摄守材人来将诣王所。时守材人遥见檀尼迦比丘语言。大德。以汝取材故今摄我去。汝可来为我决了。慈愍故。比丘报言。汝但去我正尔往。时檀尼迦比丘后往王所在前默然而住。王即问言。大德。我实与汝材不。比丘答言。实与我材。王言。我不忆与汝材。汝可为我作忆念。比丘报言。王自忆不。初登位时口自发言。若我世时于我境内。有沙门婆罗门知惭愧乐学戒者。与而取不与不取与而用不与不用。从今日沙门婆罗门草木及水听随意用。不得不与而用自今已去。听沙门婆罗门草木及水随意用。王言大德。我初登位时实有如是语。王言大德。我说无主物不说有主物。大德应死。王自念言。我刹利王水浇头种。云何以少材而断出家人命。是所不应尔时王以无数方便诃责比丘已。敕诸臣放此比丘去。即如王教放去。后诸臣皆高声大论不平。王意云何。如此死事但尔呵责而放也。时罗阅城中有诸居士不信乐佛法众者。皆讥嫌言。沙门释子无有惭愧无所畏惧不与而取。外自称言。我知正法。如是何有正法。尚取王材何况余人。我等自今已往勿复亲近沙门释子礼拜问讯供养恭敬。无使入村勿复安止。时诸比丘闻诸少欲知足行头陀知惭愧乐学戒者。嫌责檀尼迦。云何偷瓶沙王材木耶。尔时诸比丘往至佛所头面礼足已在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。知而故问。檀尼迦比丘。汝审尔王不与材而取不答言。实尔世尊。世尊尔时以无数方便诃责檀尼迦比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何檀尼迦王不与材而取。我无数方便称叹与者当取取者当用。汝今云何王不与材而取耶尔时复有一比丘名曰迦楼。本是王大臣善知世法去世尊不远在众中坐。尔时世尊。知而故问迦楼比丘言。王法不与取。几许物应死。比丘白佛言。若取五钱若直五钱物应死。云何檀尼迦比丘王不与材而取。尔时世尊以无数方便呵责檀尼迦比丘已。告诸比丘。檀尼迦比丘痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘。若在村落。若闲静处。不与盗心取。随不与取法。若为王王大臣所捉。若杀若缚若驱出国。汝是贼汝痴汝无所知。是比丘波罗夷不共住。比丘义如上。村者有四种。一者周匝垣墙。二者栅篱。三者篱墙不周。四者四周屋。闲静处者。村外空静地是谓闲静处。不与者他不舍。盗者盗心取也。随不与取者若五钱若直五钱。王者得自在不属人。大臣者种种大臣辅佐王。波罗夷不共住者如上说。有三种不与取波罗夷。若自手取。若看取。若遣人取。复有三种取波罗夷。非己物想取。非暂用取。非同意取。复有三种取。他物他物想取若举离本处。复有三种取。有主有主想取若举离本处。复有三种取。他护他护想取若举离本处。复有四种不与取波罗夷。自手取若看取若遣人取举离本处。复有四种取波罗夷。非己物想取不暂取。不同意取若举离本处。复有四种取。他物他物想取若重物若举离本处。复有四种有主有主想若重物若举离本处。复有四种。他护他护想若重物若举离本处。复有五种不与取波罗夷。若自手取若看他取若遣人取若重物若举离本处。复有五种。非己物想取不暂取非同意取若重物若举离本处。复有五种。若他物他物想若重物盗心举离本处。复有五种。有主有主想若重物盗心举离本处。复有五种。他护他护想若重物盗心举离本处。复有六种不与取波罗夷。自手取看取遣人取若重物盗心举离本处。非己物非己物想有六种亦如是。是为六种取得波罗夷。处者若地处若地上处若乘处若担。若虚空若树上若村若阿兰若处。若田若处所若船若水处。若私度关塞不输税。若取他寄信物。若取水杨枝树果草木无足众生若二足四足多足。若同财业若要若伺候。若守护若逻要道。是谓处。地处者。地中伏藏未发出七宝金银真珠琉璃贝玉砗渠玛瑙生像金宝衣被。若复有余地中所须之物属主者。若以盗心取五钱若过五钱。若牵挽取若埋藏若举离本处。初离处波罗夷。若方便欲举而不举偷兰遮。地上处者。金银七宝乃至衣被不埋。若复有余地上所须之物属主者。若以盗心取五钱若过五钱。若牵挽取若埋藏若举离本处。初离处波罗夷。若方便欲举而不举偷兰遮。乘处者。乘有四种。象乘马乘车乘步乘。若复有余乘尽名为乘。乘上若有金银七宝乃至衣被。若复有余所须有主物。若以盗心取五钱若过五钱。若牵挽取若埋藏若取离本处。初离处波罗夷。方便欲举而不举偷兰遮。若取乘从道至道。从道至非道。从非道至道。从坑中至岸上。从岸上至坑中。如是取离本处。初离处波罗夷。若方便欲取而不取偷兰遮。担处者。头担肩担背担若抱若复有余担。此诸担上有金银七宝乃至衣被。若复有余所须之物。有主。以盗心取五钱若过五钱。若牵挽取若埋藏若取离本处。初离处波罗夷。若方便欲举而不举偷兰遮。若取担者从道至道从道至非道从非道至道从坑中至岸上从岸上至坑中如是以盗心取离本处。初离波罗夷。若方便欲取而不取偷兰遮。空处者。若风吹毳若劫贝拘遮罗若差罗波尼若刍摩若麻若绵若钵耽岚婆若头头罗若雁若鹤若孔雀鹦鹉鸲鹆。若复有余所须之物。有主。以盗心取五钱。若过五钱离本处。初离波罗夷。方便欲取而不取偷兰遮。上处者。若举物在树上墙上篱上杙上龙牙杙上衣架上绳床上木床上。若大小蓐。上机上地敷上。有金银乃至衣被及余所须之物在上。以盗心取五钱若过五钱。若牵挽取若埋藏若举离本处初离波罗夷。方便欲举而不举偷兰遮。村处者。有四种如上。若村中有金银乃至衣被及余所须之物。有主。以盗心取五钱若过五钱。若牵挽取若埋藏若举取离处。初离波罗夷。方便欲举而不举偷兰遮。若以机关攻击破村。若作水浇或依亲厚强力。或以言辞辩说诳惑而取。初得波罗夷。方便欲取而不取偷兰遮。阿兰若处者。村外有主空地。彼空处有金银七宝衣被及余所须有主物。以盗心取五钱若过五钱。若举取若埋藏举离处初离波罗夷。方便欲举而不举偷兰遮。若以方便坏他空地。若作水浇或依亲厚强力。或以言词辩说诳惑而取。初得波罗夷。方便欲取而不得偷兰遮。田处者。稻田麦田甘蔗田若复有余田。彼田中有金银七宝衣被及余所须之物。有主。以盗心取五钱若过五钱。若举取若埋藏举离处。初离波罗夷。方便欲举而不举偷兰遮。若以方便坏他田若作水浇坏。若依亲厚强力。或以言词辩说诳惑而取。初得波罗夷。方便欲取而不取偷兰遮。处所者。若家处所若市肆处。若果园若菜园若池若庭前。若舍后若复有余处。彼有金银七宝衣被及余所须之物。有主。以盗心取五钱若过五钱。若举取若埋藏取举离处。初离波罗夷。方便欲举而不举偷兰遮。若坏他处所。若依亲厚强力。若以言词辩说诳惑而取。初得波罗夷。方便不得偷兰遮。船处者。小船大船台船一木船舫船橹船龟形船鳖形船皮船浮瓠船果船悬船筏船。若复余船上有金银七宝衣被及余所须之物。有主。以盗心取五钱若过五钱。若埋藏离本处。初离波罗夷。方便欲取而不得偷兰遮。若从此岸至彼岸从彼岸至此岸。若逆流若顺流若沉着水中若移岸上。若解移处波罗夷。方便欲取而不得偷兰遮。水处者。若藏金银七宝及诸衣被沉着水中。若水獭若鱼若鳖若失收摩罗。若优钵罗华钵头摩华拘物头华分陀利华及余水中物。有主。以盗心取五钱若过五钱。若牵取若埋藏离本处。初离波罗夷方便欲取而不得偷兰遮。若以方便坏他水处取乃至偷兰遮如上。不输税者。比丘无输税法若白衣应输税物。比丘以盗心为他过物若掷关外。若五钱若过五钱。若埋藏举若以辩辞言说诳惑。若以咒术过乃至方便偷兰遮如上。取他寄信物者。寄持信物去作盗心取五钱。若过五钱。头上移着肩上。肩上移着头上。从右肩移着左肩上。从左肩移着右肩上。若从右手移着左手。从左手移着右手。若抱中若着地举离处。初离波罗夷。方便偷兰遮。水者若大小盆及余种种水器。若众香水若药水。以盗心取五钱若过五钱。若牵取若弃。波罗夷。方便偷兰遮。杨枝者。若一若两若众多若一把若一束若一抱若一担若香所熏若药涂。若贼心取五钱若过五钱。若牵挽取离本处。初离处波罗夷。方便偷兰遮。园者。诸一切草木丛林华果有主。以盗心取五钱若过五钱。若牵挽取若举若埋藏离本处。初离处波罗夷。方便偷兰遮。无足众生者。蛇鱼及余无足众生有主者。盗心取直五钱若过五钱波罗夷。方便偷兰遮。二足众生者。人非人鸟及余二足众生有主者。以盗心取直五钱若过五钱波罗夷。方便偷兰遮。四足众生者。象马牛骆驼驴鹿羊及余有四足众生有主者。以盗心取直五钱若过五钱波罗夷。方便偷兰遮。多足者。蜂郁周隆伽。若百足及余多足众生有主者。以盗心取直五钱若过五钱波罗夷。方便偷兰遮。同财业者。同事业得财物当共。以盗心取直五钱若过五钱波罗夷。方便偷兰遮。共要者。共他作要教言。某时去某时来若穿墙取物若道路劫取若烧从彼得财物来共。以盗心取。直五钱若过五钱波罗夷。方便偷兰遮。伺候者。我当往观彼村若城邑若船渡处若山谷若人所居处市肆处作坊处。于彼所得物一切共。以盗心取直五钱若过五钱波罗夷。方便偷兰遮。守护者。从外得财来我当守护若所得物一切共。若以盗心取直五钱。若过五钱波罗夷。方便偷兰遮。看道者。我当看道若有王者军来。若贼军来。若长者军来当相告语。若有所得财物一切共。若以盗心取直五钱若过五钱波罗夷。方便偷兰遮。方便求过五钱得过五钱波罗夷。若方便求过五钱得五钱波罗夷。方便求过五钱得减五钱偷兰遮。方便求过五钱不得偷兰遮。方便求五钱得过五钱波罗夷。方便求五钱得五钱波罗夷。方便求五钱得减五钱偷兰遮。方便求五钱不得偷兰遮。方便求减五钱得过五钱波罗夷。方便求减五钱得五钱波罗夷。方便求减五钱得减五钱偷兰遮。方便求减五钱不得突吉罗。教人方便求过五钱得过五钱二俱波罗夷。方便教人求过五钱得五钱二俱波罗夷。方便教人求过五钱得减五钱二俱偷兰遮。方便教人求过五钱不得二俱偷兰遮。方便教人求五钱得过五钱二俱波罗夷。方便教人求五钱得五钱二俱波罗夷。方便教人求五钱得减五钱二俱偷兰遮。方便教人求五钱不得二俱偷兰遮。方便教人求减五钱得过五钱。取者波罗夷教者偷兰遮方便教人求减五钱得五钱。取者波罗夷教者偷兰遮。方便教人求减五钱得减五钱二俱偷兰遮。方便教人求减五钱不得二俱突吉罗。方便教人求五钱若过五钱。受教者取异物。取者波罗夷教者偷兰遮。方便教人求五钱若过五钱。受教者异处取物。受教者波罗夷教者偷兰遮。若方便教人求五钱若过五钱。受教者谓使取物无盗心而取得五钱若过五钱。教者波罗夷受使者无犯。若教人取物。受教者谓教盗取若取得直五钱若过五钱。受教者波罗夷教者无犯。有主有主想不与取五钱若过五钱波罗夷。有主疑若取五钱若过五钱偷兰遮。无主有主想取五钱若过五钱偷兰遮。无主物疑取五钱若过五钱偷兰遮。取有主物有主想减五钱偷兰遮。取有主物疑减五钱突吉罗。无主有主想取减五钱突吉罗。无主物疑取减五钱突吉罗。比丘尼波罗夷。式叉摩那沙弥沙弥尼突吉罗灭摈。是谓为犯。不犯者。与想取。已有想。粪扫想。暂取想亲厚意想一切无犯。无犯者。最初未制戒痴狂心乱痛恼所缠。是谓无犯(二竟)

四分律卷第一四分律卷第二(初分之二)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    四波罗夷法之二

尔时世尊。游毗舍离猕猴江边讲堂中。以无数方便与诸比丘说不净行叹不净行叹思惟不净行。诸比丘作是念。今世尊为我等说不净行叹不净行叹思惟不净行。时诸比丘即无数方便习不净观。从定觉已厌患身命愁忧不乐。譬如自喜男子女人以死蛇死狗死人系其颈甚厌患臭秽。诸比丘亦复如是。以无数方便习不净观。厌患身命愁忧不乐。便求刀欲自杀。叹死赞死劝死。诸比丘在婆裘河边园中住。作是念。世尊无数方便说不净行叹不净行叹思惟不净行。彼以无数方便习不净观。厌患身命愁忧不乐求刀欲自杀叹死赞死劝死。时有比丘字勿刀伽难提。是沙门种出家(言沙门种是姓)手执利刀入婆裘园中。见有一比丘厌患身命秽污不净。遥见勿力伽难提比丘来语言。大德。断我命来我以衣钵与汝波即受其雇衣钵已便断其命。于彼河边洗刀心生悔恨言。我今无利非善。彼比丘无罪过。而我受雇断他命根。时有一天魔知彼比丘心念。即以神足而来在勿力伽难提比丘前。于水上立而不陷没劝赞言。善哉善哉善男子。汝今获大功德度不度者。时难提比丘闻魔赞已悔恨即灭。便作是念。我今获大功德度不度者。即复持刀入园中而问言。谁未度者我今欲度之。时有未离欲比丘。见勿力伽难提比丘甚大怖惧毛竖。勿力伽难提见已语诸比丘言。汝等勿惧诸根未熟未任受化。须待成熟当来相化。其中比丘欲爱尽者。见勿力伽难提心不怖惧身毛不竖。时勿力伽难提比丘或日杀一比丘或杀二三四五乃至六十人。时彼园中死尸狼藉臭处不净状如冢间。时有诸居士礼拜诸寺。渐次至彼园中见已皆共惊怪讥嫌言。此园中乃有是变。沙门释子无有慈愍共相杀害。自称言我修正法如是何有正法。共相杀害。此诸比丘犹自相杀况于余人。我等自今勿复敬奉承事供养沙门释子。即告诸村邑勿复容止往来。时诸居士见此园中如是秽恶便不复往返。尔时毗舍离比丘以小因缘集在一处。尔时世尊观诸比丘众减少。诸大德比丘有名闻者皆不复见。尔时世尊知而故问阿难言。众僧何故减少。诸名闻大德者。今为所在皆不见耶。尔时阿难以先因缘具白佛言。世尊先以无数方便广为诸比丘说不净行叹不净行叹思惟不净行。时诸比丘闻已厌患身命求人断命是以少耳。唯愿世尊。与诸比丘更作方便说法。使心开解永无疑惑

佛告阿难。今可集诸比丘会讲堂。时阿难受佛教。即集诸比丘会讲堂集比丘僧已往世尊所。头面礼足在一面住。白世尊言。今众僧已集。愿圣知时。尔时世尊即诣讲堂在众中坐。告诸比丘。有阿那般那三昧。寂然快乐。诸不善法生即能灭之永使不生。譬如秋天降雨之后无复尘秽。又如大雨能止猛风阿那般那三昧亦复如是。寂静快乐。诸不善法生即能灭之。尔时世尊以无数方便为诸比丘说阿那般那三昧。叹阿那般那三昧。叹修阿那般那三昧。彼诸比丘便作是念。世尊今日无数方便为我等说阿那般那三昧。叹阿那般那三昧。叹修阿那般那三昧。当勤修习之。时诸比丘即以种种方便思惟入阿那般那三昧。从阿那般那三昧觉已。自知得增上胜法住于果证。尔时世尊以此因缘集比丘僧。无数方便呵责婆裘园中比丘。汝所为非非威仪非沙门法非净行非随顺行。所不应为。云何婆裘园中比丘痴人。而自共断命。世尊无数方便呵责已。告诸比丘。婆裘园中比丘痴人。多种有漏处最初犯戒。自今已去与诸比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘故自手断人命。持刀与人叹誉死快劝死。咄男子用此恶活为宁死不生。作如是心思惟。种种方便叹誉死快劝死。是比丘波罗夷不共住。比丘义如上。人者从初识至后识而断其命。杀者若自杀。若教杀。若遣使杀。若往来使杀。若重使杀若展转遣使杀。若求男子杀。若教人求男子杀。若求持刀人杀。若教求持刀人杀。若身现相若口说若身口俱现相若遣书。若教遣使书。若坑陷。若倚发。若与药。若安杀具。自杀者。若以手若瓦石刀杖及余物而自杀杀者波罗夷。方便不杀偷兰遮。教杀者。杀时自看教前人掷水火中。若山上推着谷底。若使象踏杀。若使恶兽啖。或使蛇螫。及余种种教杀杀者波罗夷。方便不杀偷兰遮。遣使杀者。比丘遣使断某甲命。随语住若断命波罗夷。方便不断偷兰遮。往来使者。比丘遣使往断某甲命。随语往欲杀未得杀便还。即承前教复往杀。若杀波罗夷。方便不杀偷兰遮。重使者。比丘遣使汝去断某甲命。续复遣使如是乃至四五。彼使即往杀。杀者波罗夷。方便不杀偷兰遮。展转使者。比丘遣使汝断某甲命。彼使复转遣使若百若千。往断其命者波罗夷。方便不杀偷兰遮。求男子。者。是中谁知有如是人能用刀有方便久习学不恐怖不退能断某甲人命。彼使即往断其命者波罗夷。方便不杀偷兰遮。教求男子者教人求是中谁知有如是人能用刀有方便久学习不恐怖不退能断某甲人命。彼使即往断其命波罗夷。方便不杀偷兰遮。求持刀者。自求谁勇健能持刀断某甲命。彼即往杀者波罗夷。不杀偷兰遮。教求持刀者亦如是。身现相者。身作相杀令堕水火中。从上堕谷底。令象踏杀。令恶兽食毒蛇螫。彼因此现身相故自杀者波罗夷。方便不杀偷兰遮。口说者。或作是说。汝所作恶无仁慈。怀毒意不作众善行。汝不作救护。汝生便受罪多不如死。若复作是语。汝不作恶暴有仁慈。不怀毒意汝已作众善行汝已作功德汝已作救护。汝生便受众苦汝若死当生天。若彼因此言故便自杀者波罗夷。方便不杀偷兰遮。身口现相亦如是。遣使者。若遣使往彼汝所作善恶广说如上。承此使口叹死。自杀者波罗夷。方便不死偷兰遮。遣书杀者执书言汝所作善恶如是广说。亦如上遣使书者亦如是。坑陷者。审知彼所行道必从是来往。当于道中凿深坑着火若刀若毒蛇若尖橛若以毒涂刺若堕中死者波罗夷。方便不死偷兰遮。倚发者。知彼人必当倚发彼处。若树若墙若栅于彼外若着火若刀若橛若毒蛇若毒涂刺机发使堕中死者波罗夷。方便不死偷兰遮。药者。知彼人病与非药或杂毒或过限与种种药。使死波罗夷。与药不死偷兰遮。安杀具者。先知彼人本来患厌身命秽贱此身。即持刀毒若绳及余死具置之于前。若彼用一一物自杀者波罗夷。方便不杀偷兰遮。若作如此比及余方便杀具死者波罗夷。方便不死偷兰遮。若天子若龙子阿须罗子揵闼婆子夜叉饿鬼。若畜生中有智解人语者。若复有能变形者。方便求杀杀者偷兰遮。方便不死突吉罗。畜生不能变形若杀波夜提。方便不杀突吉罗。实人人想杀波罗夷。人疑偷兰遮。人非人想偷兰遮。非人人想偷兰遮。非人疑偷兰遮。比丘尼波罗夷。式叉摩那沙弥沙弥尼突吉罗灭摈此是犯。不犯者。若掷刀杖瓦石误着彼身死者不犯。若营事作房舍误堕堑石材木椽柱杀人不犯重病人扶起若扶卧浴时服药时。从凉处至热处。从热处至凉处。入房出房向厕往返一切无害心而死不犯。不犯者。最初未制戒痴狂心乱痛恼所缠不犯(三竟)

尔时世尊。游于毗舍离猕猴江边高阁讲堂。时世谷贵人民饥饿乞食难得。时世尊告阿难。诸有在毗舍离比丘尽令集在讲堂。阿难即承佛教敕。诸比丘集会讲堂。众僧集已。头面礼佛足却住一面。白佛言。毗舍离比丘已集讲堂。唯圣知时。尔时世尊即诣讲堂在大众中坐。告诸比丘。汝等当知。今时世谷贵人民饥饿乞食难得。汝等诸有同和上同师随亲友知识各共。于此毗舍离左右随所宜安居。我亦当于此处安居。何以故饮食难得令众疲苦。时诸比丘闻世尊教已。即各随同和上同师亲友知识。于毗舍离左右安居。世尊于毗舍离城内安居。时有众多比丘于婆裘河边僧伽蓝中安居者作是念。如今此国谷贵人民饥饿乞食难得我等作何方便不以饮食为苦。寻即念言。我今当至诸居士家语言。我得上人法。我是阿罗汉。得禅得神通知他心并复叹彼某甲得阿罗汉得禅得神通知他心。中有信乐居士。所有饮食不敢自啖不与妻子当持供养我等。彼诸居士亦当称叹我等。此诸比丘真是福田可尊敬者。我等于是可得好美饮食。可得安乐住。不为乞食所苦。尔时婆裘河边诸比丘作是念已。即往至诸居士家自说我得上人法是阿罗汉得禅得神通知他心。并复叹彼某甲比丘得阿罗汉得禅得神通知他心。时诸信乐居士信受其言。即以所有饮食妻子之分不食尽持供养诸比丘言。此是世间可尊敬者。此诸比丘受诸居士供养。颜色光泽和悦气力充足。诸余比丘在毗舍离安居者。颜色憔悴形体枯燥衣服弊坏。安居竟摄持衣钵。往世尊所头面作礼在一面坐。尔时世尊慰问诸比丘言。汝等住止和合安乐不。不以饮食为苦耶。诸比丘白佛言。我等住止和合安乐。时世谷贵人民饥饿乞食难得以此为苦。在婆裘河边僧伽蓝中安居诸比丘。颜色光泽和悦气力充足。安居竟摄衣持钵往世尊所。到已头面作礼在一面坐。时世尊慰问诸比丘。汝等住止和合安乐不。不以饮食为苦耶。诸比丘白佛言。我等住止和合安乐不以饮食为苦。佛问言。今世谷贵人民饥馑乞食难得。汝等以何方便不以饮食为苦耶。诸比丘即以上因缘具白世尊。以是故不以饮食为苦。世尊问诸比丘。汝等有实不。答言。或有实或无实。佛告诸比丘。汝等愚人有实尚不应向人说。况复无实而向人说。时世尊告诸比丘。世有二贼。一者实非净行自称净行。二者为口腹故不真实非己有。在大众中故作妄语。自称言。我得上人法是中为口腹故不真实非己有。于大众中故妄语自称言我得上人法者最上大贼。何以故以盗受人饮食故。时世尊以无数方便诃责婆裘河边僧伽蓝中安居诸比丘已。告诸比丘。此愚人。多种有漏处最初犯戒。自今已去与诸比丘结成。集十句义乃至正法久住。欲说戒者当如是说。若比丘实无所知自称言。我得上人法我如是我见是。彼于异时若问若不问。欲自清净故作是说。我实不知不见言知言见虚诳妄语。是比丘波罗夷不共住。如是世尊。与诸比丘结戒。尔时有一增上慢比丘语人言。我得道。彼于后时精进不懈勤求方便证最上胜法。彼作是念。世尊与诸比丘结戒。若比丘实无所知自称言。我得上人法我知是我见是。彼于异时若问若不问。欲自清净故言。我实不知不见言知言见虚诳妄语。是比丘波罗夷不共住。而我慢心自言我得道。后勤方便精进不懈证最上胜法。我将无犯波罗夷耶。今当云何。寻语诸同意比丘。世尊与诸比丘结戒。若比丘实无所知自称言。我得上人法我知是我见是。彼于异时若问若不问。欲自清净故言。我实不知不见言知言见。虚诳妄语波罗夷不共住。我以增上慢故自称言。我得道后勤方便精进不懈证最上胜法。我将不犯波罗夷耶。善哉大德。为我白佛。随佛教敕我当奉行。尔时诸比丘往至世尊所。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。为诸比丘随顺说法。无数方便赞叹头陀端严少欲知足乐出离者。告诸比丘。增上慢者不犯自今已去当如是说戒。若比丘实无所知自称言。我得上人法。我已入圣智胜法我知是我见是。彼于异时若问若不问。欲自清净故作是说。我实不知不见言知言见虚诳妄语。除增上慢是比丘波罗夷不共住。比丘义如上。不知不见者实无知见。自称者自称说有信戒施闻智慧辩才。人法者人阴人界人入上人法者诸法能出要成就自言念在身自言正忆念。自言持戒。自言有欲。自言不放逸。自言精进。自言得定自言得正受。自言有道自言修习。自言有慧。自言见。自言得。自言果自言念在身者。有念能令人出离狎习亲附此法修习增广如调伏乘。守护观察善得平等。已得决定。无复艰难而得自在是为自言得身念处。自言正忆念者。有念能令人出离狎习亲附此法修习增广如调伏乘。守护观察善得平等。已得决定无复艰难而得自在。是为自言正忆念。自言得戒。自言有欲。自言不放逸。自言精进。亦如上说。自言得定者。有觉有观三昧。无觉有观三昧。无觉无观三昧。空无相无作三昧。狎习亲附思惟此定余如上说。自言得正受者。想正受。无想正受。随法正受。心想正受。除色想正受。不除色想正受。除入正受。一切入正受。狎习亲附思惟此正受余如上说。自言有道者。从一支道乃至十一支道狎习亲附思惟此道余如上说。自言修者。修戒修定修智修解脱慧修见解脱慧。狎习亲附余如上说。自言有智者。法智比智等智他心智。狎习亲附思惟此智余如上说。自言见者。见苦见集见尽见道。若复作如是言。天眼清净观诸众生。生者死者。善色恶色。善趣恶趣。知有好丑贵贱。随众生业报如实知之。狎习亲附余如上说。自言得者。得须陀洹斯陀含阿那舍阿罗汉。狎习亲附余如上说。自言果者。须陀洹果斯陀含果阿那含果阿罗汉果。狎习亲附余如上说。如是虚而不实不知不见向人说言。我得上人法口自向人说前人知者波罗夷。说而不知者偷兰遮。若遣手印若遣使若书若作知相若知者波罗夷。若不知者偷兰遮。自在静处作不静想口说言我得上人法偷兰遮。不静处作静处想口说言我得上人法偷兰遮。诸天阿须罗乾闼婆夜叉饿鬼畜生能变形有智向说得上人法知者偷兰遮。说而不知者突吉罗。手印遣使若书若作知相使彼知偷兰遮。彼不知突吉罗。畜生不能变形者向说得上人法突吉罗。若人实得道向不同意大比丘说得上人法突吉罗。若为人说根力觉意解脱三昧正受我等得是波罗夷。人作人想波罗夷。人疑者偷兰遮。人非人想偷兰遮。非人人想偷兰遮。非人疑亦偷兰遮。比丘尼波罗夷。式叉摩那沙弥沙弥尼突吉罗灭摈。是为犯。不犯者。增上慢人自言。是业报因缘非修得。若向同意大比丘说上人法。若向人说根力觉意解脱三昧正受法不自称言我得。若戏笑说。或疾疾说。屏处独说。梦中说。欲说此错说彼。不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(四竟)

    二十三僧残法之一

尔时世尊。游舍卫城。时迦留陀夷。欲意炽盛颜色憔悴身体损瘦。于异时独处一房。敷好绳床木床大小褥被。枕地复敷好敷具。户外别安汤水洗足具。饮食丰足欲意炽盛。随念忆想弄失不净。诸根悦豫颜色光泽。诸亲友比丘见已问言。汝先时颜色憔悴身形损瘦。如今颜色和悦光泽。为是住止安乐不。以饮食为苦耶。云何得尔。答言。住止安乐不以饮食为苦。彼复问言。以何方便住止安乐不以饮食为苦。答言大德。我先欲意炽盛颜色憔悴形体损瘦。我时在一房住。敷好绳床木床大小褥被。枕地复敷好敷具。户外别安汤水洗足之具。饮食丰足。我欲意炽盛随念忆想弄失不净。我以是故住止安乐颜色和悦光泽。诸比丘言。汝所为甚苦。何以言安乐耶。所为不安而言安耶。此正法中说欲除欲。说慢除慢。灭除渴爱。断诸结使。爱尽涅槃。汝云何欲意炽盛随念忆想弄失不净耶。尔时诸比丘往至世尊所。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。知而故问迦留陀夷。汝审尔欲意炽盛随念忆想弄阴失精耶。报言实尔。世尊以无数方便呵责。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。汝今云何于我清净法中出家。作秽污行弄阴失精耶。汝今愚人。舒手受人信施。复以此手弄阴堕精。尔时世尊以无数方便呵责已。告诸比丘。此愚人。多种有漏处最初犯戒。自今已去与诸比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘故弄阴失精僧伽婆尸沙。如是世尊与比丘结戒。时有一比丘乱意睡眠于梦中失精有忆念觉已作是念。世尊与诸比丘结戒。弄阴失精僧伽婆尸沙。而我乱意睡眠于梦中失精而有忆念。将不犯僧伽婆尸沙耶。我今当云何。即具向同意比丘说。世尊与诸比丘结戒。弄阴失精僧伽婆尸沙。我今乱意睡眠于梦中失精。觉已作是念我将不犯僧伽婆尸沙耶。今当云何。大德。可以此因缘为我白佛。若佛有所教敕我当修行。尔时诸比丘往至世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊以此因缘即集诸比丘告言。乱意睡眠有五过失。一者恶梦。二者诸天不护。三者心不入法。四者不思惟明相。五者于梦中失精。是为五过失。善意睡眠有五功德。不见恶梦。诸天卫护心入于法。系意在明相。不于梦中失精。是谓五功德。于梦中失精不犯。自今已去当如是说戒。若比丘故弄阴失精除梦中僧伽婆尸沙。比丘义如上。弄者实心故作失精。精有七种。青黄赤白黑酪色酪浆色。何者精青色转轮圣王精也。何者精黄色转轮圣王太子精也。何者精赤色犯女色多也。何者精白色负重人精也。何者精黑色转轮圣王第一大臣精也。何者精酪色须陀洹精也。何者精酪浆色斯陀含人精也。尔时有一婆罗门居闲静处诵持咒术。彼经所说若故堕精者命终生天。彼欲求天道常弄阴失精。时有一婆罗门出家为道者。闻此言为生天故即便弄阴失精。彼疑语诸比丘。诸比丘白佛。佛言。僧伽婆尸沙。若为乐故。为药故。为自试出精故。为福德故。为祠天故。为生天故。为施故为种子故。为自憍恣故。为自试力故。为好颜色故。为如是事弄失一切僧伽婆尸沙。若忆念弄失精僧伽婆尸沙。若忆念弄欲出青精若出僧伽婆尸沙。若忆念弄欲出青精乃出黄赤白黑酪酪浆色僧伽婆尸沙。若欲出黄乃出赤白黑酪酪浆青色僧伽婆尸沙。赤白黑酪色酪浆色亦如是。欲为乐故忆念弄失不净僧伽婆尸沙。欲为乐故忆念弄欲失青不净若失僧伽婆尸沙。欲为乐故忆念弄欲失青不净。乃至黄赤白黑酪色酪浆色僧伽婆尸沙。欲为乐故忆念弄欲失黄赤白黑酪色酪浆色青色亦如是。若欲为药故。为欲自试故。为福德故。为祭祀故。为生天故为施故。为种子故。为自憍恣故。为自试力故。为颜色和悦故。亦如是。若于内色外色内外色水风空。内色者受色。外色者不受色。内外色者受不受色。水者若顺水若逆水若以水洒。风者若顺风若逆风或口吹。空者自空动身。若于内色弄失不净僧伽婆尸沙。若于内色忆念弄欲失青不净若失僧伽婆尸沙。若于内色弄欲失青不净乃失黄赤白黑酪酪浆色僧伽婆尸沙。若为乐故于内色忆念弄失不净僧伽婆尸沙。若为乐故于内色忆念弄欲失青不净若失僧伽婆尸沙。若为乐故于内色忆念弄欲失青不净乃失黄赤白黑酪酪浆色僧伽婆尸沙。若为药故乃至为颜色和悦故亦如是。于外色亦如是。于内外色亦如是。水风空亦如是。忆念弄失不净僧伽婆尸沙。不失偷兰遮。若比丘方便弄失不净僧伽婆尸沙。不失偷兰遮。若比丘教比丘方便弄失不净若失偷兰遮。不失突吉罗。若比丘尼教比丘方便弄失不净若失偷兰遮不失突吉罗。除比丘比丘尼。教余人弄失不失一切突吉罗。比丘尼波夜提。式叉摩那沙弥沙弥尼突吉罗。是名为犯。不犯者梦中失。觉已恐污身污衣床褥。若以弊物树叶器物盛弃。若以手捺弃。若欲想出不净若见好色不触失不净。若行时自触两髀若触衣触涅槃僧失不净。若大便小便时失不净。若冷水暖水洗浴失不净。若在浴室中用树皮细末药泥土浴失不净。若手揩摩失不净。若大啼哭。若用力作时。一切不作出不净意不犯。不犯者。最初未制戒痴狂心乱痛恼所缠(一竟)

佛在舍卫国。时迦留陀夷。闻佛所制不得弄阴堕精。便手执户钥在门外立。伺诸妇女居士家妇女童女来。语言大妹。可来入房看。将至房中捉扪摸鸣口。乐者便笑其所作。不乐者便嗔恚骂詈出房。语诸比丘言。大德当知。不善非法非宜不得时。我常谓。是安隐处无患无灾变无怖惧处。今更于中遭遇灾变恐惧。本谓水能灭火。今更水中生火。迦留陀夷将我等至房中牵捉呜口扪摸。我等夫主在本房中牵挽作如是事犹不堪忍。况今沙门释子乃作此事。时诸比丘闻。中有少欲知足行头陀乐学戒知惭愧者。呵责迦留陀夷言。世尊制戒不得弄阴失精。汝今云何手执户钥于门外立。伺诸妇女若居士家妇女来。将入房看便捉扪摸呜口耶。如是呵责已。往至世尊所头面礼足在一面坐。以此因缘具白世尊。世尊以此因缘集诸比丘。知而故问。迦留陀夷云何汝实尔不。答言尔。世尊尔时呵责迦留陀夷言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。以无数方便呵责已。告诸比丘此痴人。多种有漏处最初犯戒。自今已去与比丘结戒集十句义乃至正法久住。欲说戒者当如是说。若比丘淫欲意。与女人身相触。若捉手若捉发。若触一一身分者僧伽婆尸沙。比丘义如上。淫欲意者爱染污心。女人者如上说。身者从发至足。身相触者若捉摩重摩。或牵或推或逆摩或顺摩。或举或下或捉或捺。若捉摩者摩身前后。牵者牵前。推者推却。逆摩者从下至上。顺摩者从上至下。举者捉举上。下者若立捉令坐。捉者若捉前捉后捉乳捉髀。捺者捺前捺后若捺乳捺髀。僧伽婆尸沙。若女作女想女扪摸比丘身。身相触欲意染着受触乐僧伽婆尸沙。女作女想。女以手扪摸比丘。动身欲意染着受触乐僧伽婆尸沙。如是乃至捉捺亦如是。是女疑者偷兰遮。若女作女想。身触彼衣璎珞具。欲心染着受触乐偷兰遮。若女作女想身触彼衣璎珞具欲心染着不受触乐偷兰遮。若女作女想女以身衣璎珞具触比丘身欲心染着受触乐偷兰遮。若女作女想女以身衣璎珞具触比丘身欲心染着不受触乐偷兰遮。女作女想以身触女衣璎珞具欲心染着动身不受触乐偷兰遮。若女作女想以身触女衣璎珞具欲心染着不动身受触乐偷兰遮。若女作女想女以身衣璎珞具触比丘身欲心染着动身不受触乐偷兰遮。女作女想女以身衣璎珞具触比丘身欲心染着受触乐不动身偷兰遮。女作女想身相触欲心染着不受触乐动身偷兰遮。女作女想身相触欲心染着受触乐不动身偷兰遮。如是捉摩乃至捉捺一切偷兰遮。若女疑突吉罗。女作女想以身衣触身衣璎珞具欲心染着受触乐突吉罗。女作女想以身衣触身衣璎珞具欲心染着不受触乐突吉罗。女作女想以身衣触身衣璎珞具欲心染着不受触乐动身突吉罗。女作女想以身衣触身衣璎珞具欲心染着受触乐不动身突吉罗。女作女想以身衣触身衣璎珞具欲心染着不受触乐不动身突吉罗。女作女想以身衣触身衣璎珞具欲心染着受触乐动身突吉罗。乃至捉捺一切突吉罗。是女疑突吉罗。若比丘与女人身相触。一触一僧伽婆尸沙。随触多少一一僧伽婆尸沙。若天女阿修罗女龙女饿鬼女畜生女能变形者身相触偷兰遮。畜生不能变形者身相触突吉罗。若与男子身相触突吉罗。与二形身相触者偷兰遮。若女人作礼捉足觉触乐不动身突吉罗。若比丘有欲心触衣钵尼师檀针筒草[卄/告]乃至自触身一切突吉罗。人女人女想僧伽婆尸沙。人女生疑偷兰遮。人女非人女想偷兰遮。非人女作人女想偷兰遮。非人女生疑偷兰遮。比丘尼波罗夷。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若有所取与相触。戏笑相触。若相解时相触不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(二竟)

四分律卷第二四分律卷第三(初分之三)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    十三僧残法之二

佛在舍卫国。时迦留陀夷。闻世尊所制戒不得弄阴堕精不得身相摩触。便持户钥在门外立。伺诸妇女若居士家妇女来语言。诸妹可入我房看。将至房中已。向彼以欲心粗恶语。诸女乐者笑其所言。不乐者嗔恚骂詈出房。语诸比丘。大德当知。今我所见事非善非法非宜不得时我常谓。是处安隐无患无灾变无怖惧处。今日乃更生畏怖身毛为竖。我等本谓水能灭火。而今火从水生。何以知之。迦留陀夷见将入房淫欲意粗恶语见向。我在家时夫主作粗恶语向我犹不能堪忍。况今出家之人恶口如是。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责迦留陀夷广说如上。已往至世尊所头面礼足在一面坐。以此因缘具白世尊。世尊以此因缘集诸比丘。于大众中知而故问。云何迦留陀夷。汝审有此事耶。答言如是。时世尊呵责。汝所为非。非威仪非沙门法非净行非随顺行所不应为。世尊以无数方便呵责已。告诸比丘。此迦留陀夷痴人。多种有漏处最初犯戒。自今已去与诸比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘淫欲意与女人粗恶淫欲语。随所说粗恶淫欲语僧伽婆尸沙。比丘义如上淫欲意者如上。女人者亦如上。粗恶者非梵行。淫欲语者称说二道好恶。若自求若教他求。若问若答若解若说若教若骂。求者言与我二道作如是如是事。若复作余语。教他求者。若天若梵水神摩醯首罗天祐助我。共汝作如是如是事。若复作余语。问者问汝大小便道何似。汝云何与夫主共事。云何复与外人共通。若复作余语。答者汝大小便道如是。汝与夫主外人共通如是。若复作余语。解者说者亦如是。教者我教汝如是治二道。汝可令夫主外人敬爱。若复作余语。骂者若言汝破坏腐烂烧燋堕落与驴作如是。若复作余语骂。若比丘与女人一返粗恶语一僧伽婆尸沙。随粗恶语多少说。而了了者一一僧伽婆尸沙。不了了者偷兰遮。若与指印书遣使作相令彼女人知者僧伽婆尸沙。不知者偷兰遮。除此大小便道说余处好恶偷兰遮。天女阿须罗女夜叉女龙女畜生女能变形者黄门二形粗恶语令彼知者偷兰遮。不知者突吉罗。若指印若书若遣使若现知相令彼知者偷兰遮。不知者突吉罗。畜生不能变形者向说粗恶语者突吉罗。若向男子粗恶语突吉罗。若比丘欲意粗恶语粗恶语想僧伽婆尸沙。粗恶语生疑者偷兰遮。非粗恶语粗恶语想偷兰遮。非粗恶语疑偷兰遮。人女人女想僧伽婆尸沙。人女疑偷兰遮。人女非人女想偷兰遮。非人女作人女想偷兰遮。非人女疑偷兰遮。比丘尼偷兰遮。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若为女人说不净恶露观。大妹当知。此身九疮九孔九漏九流。九孔者二眼二耳二鼻口大小便道。当说此不净时彼女人谓说粗恶语。若说毗尼时言次及此彼谓粗恶语。若从受经。若二人同受若彼问。若同诵若戏笑语。若独语。若疾疾语。若梦中语。欲说此错说彼。一切不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(三竟)

佛在舍卫国。时迦留陀夷。已闻世尊制戒。不得弄阴堕精不得与女人身相触。不得向女人粗恶语。便执户钥在门外立。伺诸妇女若居士家妇女来。语言诸妹。可入我房看。将入房已自赞叹身言。诸妹知不。我学中第一我是梵行持戒修善法人。汝可持淫欲供养我。时喜乐者默然笑其所言。不乐者骂詈而出。告诸比丘言。大德当知。我等向所见事。非善非宜非法不得时。我常信。此处无患无灾变无恐惧处。云何今日乃更生畏怖身毛为竖。我本谓水能灭火而今火从水生。我在家时夫主向我作如是语犹不堪忍。况出家之人乃作如是言。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责迦留陀夷。汝云何闻世尊制戒。不得弄阴失精。不得与女人身相触。不得淫欲粗恶语。呵责广说如上已。往世尊所头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集诸比丘。知而故问迦留陀夷。汝审尔不。答言尔。尔时世尊呵责迦留陀夷。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。世尊以无数方便呵责已。告诸比丘。迦留陀夷痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘淫欲意于女人前自叹身言。大妹。我修梵行持戒精进修善法。可持是淫欲法供养我。如是供养第一最。僧伽婆尸沙。比丘义如上。淫欲意者如上。女人者如上。叹身者叹身端正好颜色。我是刹帝利长者居士婆罗门种。梵行者勤修离秽浊。持戒者不缺不穿漏无染污。善法者乐闲静处。时到乞食着粪扫衣。作余食法不食一坐食一抟食。冢间坐露坐树下坐常坐随坐。持三衣呗匿多闻能说法持毗尼坐禅。作如是自叹誉已供养我来。不说淫欲者偷兰遮。若说淫欲僧伽婆尸沙。若在人女前一自叹誉身一僧伽婆尸沙。随自叹身多小了了者一一僧伽婆尸沙。说而不了了者偷兰遮。若手印若书信若遣使若现知相。令彼知者僧伽婆尸沙。不知者偷兰遮。除二道更为索余处供养偷兰庶。天女阿须罗女龙女夜叉女饿鬼女畜生女能变形者向自叹誉身说而了了者偷兰庶。不了了者突吉罗。若指印若书信若遣使若现知相叹说身令彼知者偷兰遮。说而不知者突吉罗。畜生不能变形向彼自叹誉身者突吉罗。向男子自叹誉身突吉罗。人女人女想僧伽婆尸沙。人女疑偷兰遮。人女作非人女想偷兰遮。非人女作人女想偷兰遮。非人女疑偷兰遮。比丘尼偷兰遮。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若比丘语女人言。此处妙尊最上。此比丘精进持戒修善法。汝等应以身业慈口业慈意业慈供养彼。诸女意谓比丘为我故自赞身。若为说毗尼时言说相似。而彼自谓赞身。若从受经诵经若二人共受诵。若问若同诵。若戏笑语。若疾疾语。若梦中语。若欲说此错说彼。不犯。不犯者最初未制戒。痴狂心乱痛恼所缠(四竟)

佛在罗阅只耆阇崛山中。时罗阅城中有一比丘名迦罗。本是王大臣善知俗法。彼作如是媒嫁向男说女向女说男。时罗阅城中诸居士。欲有所嫁娶尽往咨问迦罗。迦罗答言。须我至彼家先当观视。观视已往诸居士家语言。汝欲与某甲为婚者随意。时诸居士即如其言与作婚娶。时诸男女婚娶得适意者便欢喜供养赞叹言。令迦罗常得欢乐如我今日。何以故。由迦罗故使我得如此欢乐。令迦罗及余比丘亦得供养。若彼男女婚娶不得适意者便作是言。当令迦罗常受苦恼如我今日。何以故。由迦罗故令我嫁娶受如是苦。令迦罗及诸比丘亦受苦恼不得供养。时罗阅城中不信佛法僧诸居士自相谓言。汝等若欲得与大富多财饶宝为婚者。可往沙门释子中问之。随时供养亲近恭敬可得如意。何以故。此沙门释子善知媒嫁。此男可娶彼女彼女可与此男。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责迦罗比丘。云何媒男与女媒女与男。呵责已往世尊所头面礼足在一面坐。以此因缘具白世尊。世尊以此因缘集诸比丘僧。知而故问迦罗。汝审尔媒嫁不。答曰实尔。世尊以无数方便呵责。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。我以无数方便与诸比丘说离欲事。汝今云何乃作和合欲事。诃责已告诸比丘。此迦罗愚人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘往来彼此媒嫁持男意语女持女意语男。若为成妇事若为私通乃至须臾顷僧伽婆尸沙。比丘义如上。往来者使所应可和合者是。女人有二十种。母护父护父母护兄护姊护兄姊护自护法护姓护宗亲护。自乐为婢与衣婢与财婢同作业婢水所漂婢。不输税婢放去婢客作婢他护婢边方得婢。母护者母所保。父护者父所保。父母护兄护姊护兄姊护亦如是。自护者身得自在。法护者修行梵行。姓护者不与卑下姓。宗亲护者为宗亲所保。自乐为婢者乐为他作婢。与衣者与衣为价。与财者乃至与一钱为价。同业者同共作业若未成夫妇礼。水所漂者水中救得。不输税者若不取输税。若放去婢者若买得若家生。客作者雇钱使作如家使人。他护者受他华鬘为要。边方得者抄劫得。是谓二十种男子亦有二十种亦如是。母护男母护女遣比丘为使语彼言。汝为我作妇若与我私通。若言须臾间若一念顷。若比丘自受他语。自往语彼受彼语还报者僧伽婆尸沙。若比丘自受语自往语彼遣使持报语还僧伽婆尸沙。若比丘自受语遣使语彼自持报语还僧伽婆尸沙。若比丘自受语若遣使语彼遣使持报语还僧伽婆尸沙。若比丘自受语自作书持往彼自持报书还僧伽婆尸沙。若比丘自受语自作书持至彼遣使持报书还僧伽婆尸沙。若比丘自受语遣使持书至彼自持报书还僧伽婆尸沙。若比丘自受语遣使持书至彼遣使持报书还僧伽婆尸沙。指印现相各作四句亦如是。若比丘自受书持至彼自持报书还僧伽婆尸沙。若比丘自受书持至彼遣使持报书还僧伽婆尸沙。若比丘自受书遣使持至彼自持报书还僧伽婆尸沙。若比丘自受书遣使持书至彼遣使持报书还僧伽婆尸沙。若比丘自受书自持指印往彼自持指印还报僧伽婆尸沙。若比丘自受书自持指印往彼遣使持指印还报僧伽婆尸沙。若比丘自受书遣使持指印往彼自持指印还报僧伽婆尸沙。若比丘自受书遣使持指印往彼遣使持指印还报僧伽婆尸沙。现相四句亦如是。受语四句亦如是。指印十六句亦如是。现相十六句亦如是。若比丘自受语自持书至彼自持指印还报僧伽婆尸沙。若比丘自受语自持书往彼遣使持指印还报僧伽婆尸沙。若比丘自受语遣使持书往彼自持指印还报僧伽婆尸沙。若比丘自受语遣使持书往彼遣使持指印还报僧伽婆尸沙。若比丘自受语自持书往彼自持现相还报四句亦如是。若比丘自受语自持指印往彼自持现相还报四句亦如是。若比丘自受书自持指印往彼自持现相还报四句亦如是。若比丘自受语往彼还报僧伽婆尸沙。自受语往彼不还报偷兰遮。若闻语往彼说不还报偷兰遮。若与语而不受便往彼说还报偷兰遮。若受语不往彼说不还报突吉罗。若闻语不往彼说不还报突吉罗。若不受语往说不还报突吉罗。若言已嫁与他若言至余处若言死若言贼将去若言无一切偷兰遮若言癞病若痈若白癞干痟瘨狂若痔病若道有疮若有脓出不断如是还报此语僧伽婆尸沙。若比丘一返媒嫁人女僧伽婆尸沙。随媒嫁多少说而了了一一僧伽婆沙尸。若说不了了偷兰遮。若书指印若现相来往说僧伽婆尸沙。若现相令彼知僧伽婆尸沙。不知偷兰遮。除二道说身处处支节媒嫁者偷兰遮。天女阿须罗女龙女夜叉女饿鬼女畜生女能变形者黄门二根媒嫁说而了了者偷兰遮。若不了了突吉罗。书指印现相令彼知偷兰遮。不知者突吉罗。若畜生不能变形媒嫁突吉罗。媒嫁男突吉罗。若比丘来往媒嫁作媒嫁想僧伽婆尸沙。媒嫁疑偷兰遮。媒嫁作不媒嫁想偷兰遮。不媒嫁作媒嫁想偷兰遮。不媒嫁疑偷兰遮。人女人女想媒嫁者僧伽婆尸沙。人女疑偷兰遮。人女作非人女想偷兰遮。非人女作人女想偷兰遮。非人女疑偷兰遮。若比丘持他书往不看者突吉罗。若为白衣作余使突吉罗。比丘尼僧伽婆尸沙。式叉摩那沙弥沙弥尼突吉罗。此是犯。不犯者。若男女先已通而后离别还和合。若为父母病患。若系闭在狱看书持往。若为信心精进优婆塞病。若系在狱看书持往。若为佛为法为僧为塔。若为病比丘看书持往。如是无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(五竟)

佛在罗阅只耆阇崛山中。尔时世尊听诸比丘作私房舍。时有旷野国比丘。闻世尊听诸比丘作私房舍。彼即私作大房舍。彼作大房舍功力烦多。常行求索为务言。与我工匠巧人。给我车乘并将车人。给我材木竹草绳索。以比丘乞求烦多故。时诸居士遥见比丘回车远避。或入诸里巷。或入市肆。或自入舍。或低头直去。不与比丘相见。何以故。恐比丘有所求索故。时复有一旷野比丘欲起房舍自斫树。时彼树神多诸子孙。彼作是念。我今子孙多此树我所依止为我覆护。而此比丘斫截坏。我今宁可打此比丘。彼鬼复作是念。我今不先捡挍便打恐违道理。今宁可至世尊所以此因缘具白世尊。若世尊有所教敕我当奉行。念已即往世尊所。头面礼足在一面立。以上事具白世尊。世尊赞叹言。善哉。乃能不打持戒比丘。若打获罪无量。汝今速往恒河水边。有一大树名曰娑罗。有神始命终。汝可居止。时彼神头面礼世尊足绕三匝已即没不现。时尊者摩诃迦叶。从摩竭国将大比丘众五百人俱。来至旷野城止宿。明旦至时着衣持钵入城乞食。行步端严视瞻不斜屈伸俯仰与众有异。时城中诸居士遥见比丘便避。入里巷及入市肆或自入舍或低头直去。不与比丘相见。迦叶见此事已便问一人言。此诸居士何故见比丘各逃避不与相见耶。彼人答言。迦叶。世尊听诸比丘作私房舍。乞求烦多以是故诸人逃避耳。时迦叶闻此语已怅然不乐。尔时世尊从罗阅城将诸比丘千二百五十人诣旷野城。各敷座而坐。时迦叶往世尊所头面礼足在一面立。偏露右臂胡跪合掌白佛言。向者入城乞食。见诸居士遥见诸比丘各自逃避不与相见广说如上已。头面礼足绕三匝而去出旷野城。何以故。恐旷野诸比丘生嗔恚心故。世尊以此因缘集比丘僧。告言。我忆昔日。在此罗阅只耆阇崛山中时有一神来诣我所。头面礼足已在一面立白我言。世尊。听旷野比丘作私房舍多所乞求广说如上。我今问汝等。审尔私作房舍多所乞求不。答言审尔。世尊以无数方便呵责诸比丘。汝云何以我听作私房舍而便作大房舍。多所乞求非法而乞此物难受。呵责彼比丘已告诸比丘。往昔此恒水侧有一蠡髻梵志。常居此水边颜貌憔悴形体羸瘦。时我诣彼与共相见问言。汝何以形体羸瘦颜貌憔悴。彼即报我言。此河水中有一龙王名曰摩尼揵大。自出其宫来至我所。以身绕我头覆我上。时我作是念。龙性暴急恐害我命。我以此忧患致使形体羸瘦颜貌憔悴耳。时我语彼梵志言。汝欲使此龙常在水中不出至汝所汝意住不。梵志答言。实欲使此龙不来至我所。我即问梵志。彼龙有璎珞不。梵志答言。颈下有好珠璎珞。佛语梵志若此龙出水来至汝所。时当起迎语言。龙王且止。持汝颈下珠璎珞与我来。并为说偈

  我今须如此　　颈下珠璎珞
  汝以信乐心　　施我严好珠

时彼梵志受我语已。后龙王从水中出至梵志所。遥见即起往迎语言。止止龙王。愿持汝颈下珠璎与我。而说偈言

  我今须如此　　颈下珠璎珞
  汝以信乐心　　施我严好珠

尔时龙王。复以偈报梵志言

  我所致财宝　　缘由此珠故
  汝是乞求人　　不复来相见
  端正好净洁　　索珠以惊我
  不复来相见　　何为与汝珠

于是龙王即时还宫止不复还。尔时世尊即说偈言

  多求人不爱　　过求致怨憎
  梵志求龙珠　　便不复相见

汝等比丘当知。乃至畜生尚不喜人乞。而况于人多求无厌而不憎恶。云何旷野比丘痴人。私作大房舍多所乞索广说如上已。世尊复告诸比丘。吾昔一时在舍卫国祇树给孤独园。时有一比丘来至我所头面礼足在一面坐。我慰劳问讯。汝曹住止安乐不。不以乞食为苦耶。答我言。我等住止安乐不以乞食为苦。我所住林间正患众鸟。于夜半后悲鸣相呼乱我定意以此为患。佛告诸比丘言。欲令此鸟不复还林止宿不耶。比丘白佛言。大德。我等实不欲令此鸟还林止宿。佛告诸比丘。汝伺彼鸟还林宿时语鸟言。与我两翅来我今急须用。比丘报言。尔时彼比丘受我教已。便伺彼鸟还林宿时。夜欲过半至彼鸟所语言。我今急须汝两翅与我来。时诸鸟心自念言。此比丘从我乃乞如是。即出林去更不复还

佛告诸比丘。汝等当知。乃至鸟兽犹尚不喜乞索。况复于人多所求索而不憎恶。旷野比丘痴人。私作大房舍多所求索广说如上已

复告诸比丘。昔有族姓子名赖吒婆罗出家为道。乃至父母家终不乞求。时父语赖吒婆罗言。汝知不。我自省察希有人不从我乞者。汝亲是我子何不从我乞耶。时赖吒婆罗为父说偈言

  多求人不爱　　不得怀怨恨
  是故我不乞　　恐生增减故

比丘当知。赖吒婆罗自于父母家尚不从乞。况汝等比丘乃在诸居士家多所求索令彼不喜

尔时世尊以无数方便呵责诸比丘。非时乞求不耎乞求不正乞求。世尊无数方便称赞知时乞求柔软乞求正乞求已。告诸比丘。旷野比丘痴人。多种有漏处最初犯戒自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘自求作屋无主自为己当应量作。是中量者长佛十二搩手内广七搩。手当将余比丘指授处所。彼比丘当指示处所无难处无妨处。若比丘有难处妨处自求作屋无主自为己。不将余比丘指授处所。若过量作者僧伽婆尸沙。比丘义如上。自乞者彼处处乞索。屋者房也。无主者彼无有人若一若两若众多。自为己者自求索自为作也。应量者长佛十二搩手内广七搩手。难处者有虎狼师子诸恶兽下至蚁子。比丘若不为此诸虫兽所恼。应修治平地若有石树株荆棘当使人掘出。若有陷沟坑陂池处当使人填满若畏水淹渍当预设堤防。若地为人所认当共断。当无使他有语。是谓难处。妨处者不通草车回转往来是谓妨处彼比丘看无难处无妨处已。到僧中脱革屣偏露右肩右膝着地合掌作如是白。大德僧听我某甲比丘。自乞作屋无主自为己。我今从众僧乞知无难无妨处。如是再三说。尔时众僧当观察。此比丘为可信不。若可信即当听使作。若不可信一切众僧应到彼处看。若众僧不去遣僧中可信者到彼处看。若彼处有难有妨处不应与处分。若无难有妨处不应与处分。若有难处无妨处不应与处分。若无难无妨处应与处分。应如是与。众中应差堪能作羯磨者。若上座若次座若诵律若不诵律应作白。大德僧听。某甲比丘自乞作屋无主自为己。今从众僧乞处分无难无妨处。若僧时到僧忍听当与某甲比丘处分无妨无难处。白如是。大德僧听。此某甲比丘自求作屋无主自为己。从僧乞处分无难无妨处。僧今与某甲比丘处分无难无妨处。谁诸长老忍。僧与某甲比丘处分无难无妨处者默然。谁不忍者说。僧已忍。与某甲比丘处分无难无妨处竟。僧忍默然故是事如是持。彼作房应知初安。若石若土墼泥团乃至最后泥治讫是。若不被僧处分过量有难有妨处。二僧伽婆尸沙二突吉罗。僧不处分过量有难无妨处。二僧伽婆尸沙一突吉罗。僧不处分过量无难有妨处。二僧伽婆尸沙一突吉罗。僧不处分不过量有难有妨处一僧伽婆尸沙二突吉罗。僧不处分不过量有难无妨处一僧伽婆尸沙一突吉罗。僧不处分不过量无难有妨处一僧伽婆尸沙一突吉罗。僧处分过量有难有妨处一僧伽婆尸沙二突吉罗。僧处分过量有难无妨处一僧伽婆尸沙一突吉罗。僧处分过量无难有妨处一僧伽婆尸沙一突吉罗。僧处分不过量有难有妨处二突吉罗。僧处分不过量有难无妨处一突吉罗。僧处分不过量无难有妨处一突吉罗。僧不处分过量无难无妨处二僧伽婆尸沙。僧不处分不过量无难无妨处一僧伽婆尸沙。僧处分过量无难无妨处一僧伽婆尸沙。若比丘僧不处分过量有难有妨处。自作屋成者二僧伽婆尸沙二突吉罗。作而不成二偷兰遮二突吉罗。若使他作成二僧伽婆尸沙二突吉罗。作而不成二偷兰遮二突吉罗。若为他作屋成二偷兰遮二突吉罗。作而不成四突吉罗若作屋以绳拼地应量彼作者过量作者犯。若比丘教人按绳墨作彼受教者言如法作而过量彼受教者犯。彼教人案绳墨作即如法作不还报作者犯。若教人案绳墨作即如法作教者不问如法作不教者犯。若僧不处分作不处分想僧伽婆尸沙。若僧不处分疑偷兰遮僧不处分作处分想偷兰遮。僧处分作不处分想偷兰遮。僧处分有疑偷兰遮。过量亦如是。若有难有难想突吉罗。有难疑突吉罗。若有难无难想突吉罗。若无难有难想突吉罗。若无难疑突吉罗。妨处亦如是。比丘尼偷兰遮。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。如量作。减量作。僧处分作。无难处无妨处作。如法拼作。若为僧作。为佛图讲堂草庵叶庵。若作小容身屋。若作多人住屋。如是者不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(六竟)

尔时世尊。在拘睒弥国瞿师罗园中。时优填王。与尊者阐陀亲友知识。语言。欲为汝作屋随意所好。何处有好地堪起房舍亦任意作。报言大佳。尔时近拘睒弥城有尼拘律神树。多人往反象马车乘止息其下。时尊者阐陀往伐此树作大屋。时诸居士见皆讥嫌言。沙门释子无有惭愧断众生命。外自称言我知正法。如是何有正法。有如是好树。多人往反象马车乘止息其下。而斫伐作大屋。时诸比丘闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责阐陀言。有如是好树。多人往反象马车乘止息其下。云何斫伐作大屋。尔时诸比丘呵已。往世尊所头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集诸比丘。知而故问阐陀。汝实尔不。答曰实尔。世尊以无数方便呵责。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。有如是好树。多人往返象马车乘止息其下。云何斫伐作大屋。汝不应斫伐神树。若斫伐得突吉罗。世尊以无数方便诃责已。告诸比丘。阐陀痴人。多种有漏处最初犯戒。自今已去为诸比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘欲作大房有主为己作。当将余比丘往指授处所。彼比丘应指授处所无难处无妨处。若比丘有难处妨处作大房有主为己作。不将余比丘往看指授处所僧伽婆尸沙。比丘义如上大者多用财物。房者屋也。有主者若一若二若众多人。为己者自为己身作。难处者师子虎狼熊罴下至蚁子。若比丘不为彼所娆者应平治地。若有树株若有石若有刺棘应除去。若有坑坎泥水应填满平治。若畏水应设提防若有人识认者应先断了。是谓无难处。无妨处者中间容草车回转是谓无妨处。彼比丘作无难无妨处竟。应至僧中偏露右肩脱革屣礼上座足胡跪合掌作如是白。大德僧听。我某甲比丘欲作大房有主自为己。今从僧乞指授无难无妨处。如是第二第三说。众僧应观察彼人。为可信不。有智慧不。若有信有智慧。即信彼应与羯磨。若无信无智慧应举众往。若遣有信有智慧者往指授处所。若彼处所有难有妨处不应指授若有难无妨处亦不应指授若无难有妨处亦不应指授。若无难无妨处应与指授应作如是指授。众中应差堪能羯磨者。如上应作如是白。大德僧听。此某甲比丘欲作大房有主自为己。今从僧乞指授无难无妨处。若僧时到僧忍听。与某甲比丘指授无难无妨处。白如是。大德僧听。此某甲比丘作大房有主自为己。从僧乞指授无难无妨处。今僧与某甲比丘指授无难无妨处。谁诸大德忍。僧与某甲比丘指授无难无妨处者默然。谁不忍者说僧已忍。与某甲比丘指授无难无妨处竟。僧忍默然故是事如是持。彼作房者应知初安石安土墼泥抟。是房竟者乃至泥治讫者是也。若僧不差指授有难有妨处一僧伽婆尸沙二突吉罗。僧不处分有难无妨处一僧伽婆尸沙一突吉罗。僧不处分无难有妨处一僧伽婆尸沙一突吉罗。僧处分有难有妨处二突吉罗。僧处分有难无妨处一突吉罗。僧处分无难有妨处一突吉罗。僧不处分无难无妨处一僧伽婆尸沙。若比丘僧不处分有难有妨处。起大房有主自为己作竟一僧伽婆尸沙二突吉罗。作而不成者一偷兰遮二突吉罗。若教人作成者一僧伽婆尸沙二突吉罗。作而不成者一偷兰遮二突吉罗。为他起房竟者一偷兰遮二突吉罗。作而不竟者三突吉罗。僧不处分作不处分想僧伽婆尸沙。僧不处分生疑偷兰遮。僧不处分作处分想偷兰遮。僧处分作不处分想偷兰遮。僧处分生疑偷兰遮。有难有难想有妨有妨想各五句亦如是。比丘尼偷兰遮。式叉摩那沙弥沙弥尼突吉罗。是谓为犯不犯者。僧处分无难处无妨处作。为僧为佛图讲堂草庵叶庵小容身屋。为多人作屋不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(七竟)

尔时佛在罗阅只耆阇崛山中。时尊者沓婆摩罗子得阿罗汉。在静处思惟心自念言。此身不牢固我今当以何方便求牢固法耶。复作是念我今宜可以力供养分僧卧具差次受请饭食耶。时沓婆摩罗子晡时从静处起。整衣服往至世尊所。头面礼足在一面坐。白世尊言。我向在静处心作是念。是身不牢固以何方便求牢固法。我今宁可以力供养分僧卧具及差次受请饭食耶。世尊告诸比丘。差沓婆摩罗子分僧卧具及差次受请饭食。白二羯磨。众中应差堪能羯磨者如上如是白。大德僧听。若僧时到僧忍听。差沓婆摩罗子分僧卧具差次受请饭食。白如是。大德僧听。僧今差沓婆摩罗子分僧卧具差次受请饭食。谁诸长老忍。僧差沓婆摩罗子分僧卧具及差次受请饭食者默然。谁不忍者说。僧已忍。差沓婆摩罗子分僧卧具差次受请饭食竟。僧忍默然故是事如是持。时尊者沓婆摩罗子。即为僧分卧具。同意者共同。阿练若阿练若共同。乞食乞食共同。纳衣纳衣共同。不作余食法不作余食法共同。一坐食一坐食共同。一抟食一抟食共同。冢间坐冢间坐共同。露坐露坐共同。树下坐树下坐共同。常坐常坐共同。随坐随坐共同。三衣三衣共同。呗匿呗匿共同。多闻多闻共同。法师法师共同。持律持律共同。坐禅坐禅共同。时罗阅只有客比丘来。沓婆摩罗子即随次第所应得卧具分与。时有一长老比丘向暮上耆阇崛山。时尊者沓婆摩罗子手出火光与分卧具语言。此是房此是绳床是木床是大小蓐是卧枕是地敷是唾壶是盛小便器此是大便处此是净地此是不净地。时世尊赞言。我弟子中分僧卧具者沓婆摩罗子最为第一。时有慈地比丘来至罗阅城中。时沓婆摩罗子为客比丘分卧具随上座次第随应得处与。时彼慈地比丘众中下座得恶房恶卧具。便生嗔恚言。沓婆摩罗子有爱随所喜者与好房好卧具。不爱者与恶房恶卧具。不爱我等故与我恶房恶卧具。众僧云何乃差如此有爱者分僧卧具耶。时尊者沓婆摩罗子。夜过已明日差僧受请饭食。时罗阅城中有檀越。常为僧一年再作肥美饭食。时慈地比丘被差次至其家。彼檀越闻慈地比丘次来受食。便于门外敷弊坐具施设恶食。时慈地比丘得此恶食倍复嗔恚言。沓婆摩罗子有爱随所喜者与好房好卧具。所不喜者与恶房恶卧具。不爱我等故与恶房恶卧具。今日以不爱我等故复差与恶食。云何众僧乃差如是有爱比丘为僧分卧具差次受请也。时罗阅城中有一比丘尼名曰慈。是慈地比丘妹。闻慈地比丘来至罗阅城中。即至慈地比丘所。在前立问讯。远行劳耶不疲极耶。作如是善言问讯。时慈地比丘默然不答。比丘尼言。大德。我有何过而不见答。彼答言。何须与汝语。为沓婆摩罗子触娆我而不能助我。比丘尼言。欲使我作何等方便。令沓婆摩罗子不触娆大德。慈地比丘言。汝伺佛比丘僧会时。便往众中作如是言。大德。此非善非宜非好不随顺所不应不合时。我本所凭无有恐惧忧恼。云何今日更生怖惧忧恼。云何水中生火。此沓婆摩罗子乃来犯我。众僧即应和合为作灭摈。如是便不来娆我。比丘尼言。此有何难便可作之。时慈比丘尼往至僧中如上所说

四分律卷第三四分律卷第四(初分之四)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    十三僧残法之三

时尊者沓婆摩罗子去佛不远。世尊知而故问。汝闻此比丘尼所说不。答言闻。唯世尊当知之。世尊告言。今不应作如是报我。若实当言实若不实当言不实。时沓婆摩罗子闻世尊教已。即从坐起偏露右臂右膝着地合掌白佛言。我从生已来未曾忆梦中行不净。况于觉悟而行不净。世尊报曰。善哉善哉。沓婆摩罗子。汝应作是说。时世尊告诸比丘。汝等应检问此慈地比丘。莫以无根非梵行谤此沓婆摩罗子比丘清净人。若以无根非梵行谤者获大重罪。诸比丘答言。如是世尊。诸比丘从佛受教。寻至慈地比丘所检问本末。此事云何为实尔不。莫以无根非梵行谤此沓婆摩罗子清净梵行人。若以无根非梵行谤清净梵行人得大重罪。时慈地比丘得诸比丘诘问已报言。我知沓婆摩罗子清净梵行人无是事。我来到罗阅城。彼为僧分房卧具。与我等恶房恶卧具。我即生不忍心言。沓婆摩罗子有爱。随所喜者与好房好卧具。不喜者与恶房恶卧具。以不爱我故与恶房恶卧具。差次受请与我恶食处。由此倍增嗔恚言。众僧云何差此有爱人为僧分房舍卧具差次受请饭食也。而此沓婆摩罗子清净梵行人无如是事。时诸比丘闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责慈地比丘。汝云何以无根非梵行谤沓婆摩罗子梵行人耶。时诸比丘往世尊所头面作礼在一面坐。以此因缘具白世尊。世尊尔时以此因缘集诸比丘。以无数方便呵责慈地比丘。汝所为非。非威仪非沙门法非净行非随顺行所不应为。云何以无根非梵行谤清净梵行人耶。世尊告诸比丘。有二种人一向入地狱。何谓二。若非梵行自称梵行。若真梵行以无根非梵行谤之。是谓二一向入地狱。世尊以无数方便呵责慈地比丘已。告诸比丘言。此慈地比丘痴人。多种有漏处最初犯戒。自今已去与诸比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘嗔恚所覆故。非波罗夷比丘以无根波罗夷法谤欲坏彼清净行。若于异时若问若不问。知此事无根说。我嗔恚故作是语。若比丘作是语者僧伽婆尸沙。比丘义如上。嗔恚者有十恶法因缘故嗔十事中以一一生嗔。根者有三根。见根闻根疑根。见根者。实见犯梵行见偷五钱过五钱见断人命。若他见者从彼闻是谓见根。闻根者若闻犯梵行闻偷五钱若过五钱。闻断人命闻自叹誉得上人法。若彼说从彼闻是谓闻根。疑根者有二种生疑。从见生从闻生。从见生者。若见与妇女入林出林无衣裸形男根不净污身手。捉刀血污与恶知识为伴。是谓从见生疑。从闻生疑者。若在暗地。若闻床声。若闻草蓐转侧声。若闻身动声。若闻共语声。若闻交会语声。若闻我犯梵行声。若闻言偷五钱过五钱声。若闻言我杀人。若闻言我得上人法。是谓从闻生疑。除此三根已。更以余法谤者是谓无根。若彼人不清净。不见犯波罗夷不闻犯波罗夷不疑犯波罗夷。便作是言。我见闻疑彼犯波罗夷。以无根法谤僧伽婆尸沙。若彼人不清净。不见犯波罗夷不闻犯波罗夷不疑犯波罗夷。生见闻疑想。后忘此想。便作是言。我见闻疑彼犯波罗夷。以无根法谤僧伽婆尸沙。若彼人不清净。不见闻疑彼犯波罗夷。彼有疑后便言。我是中无疑。我见闻疑以无根法谤僧伽婆尸沙。若彼人不清净。不见闻疑彼犯波罗夷。彼生疑后便忘疑。便言。我见闻疑以无根法谤僧伽婆尸沙。若彼人不清净。不见闻疑彼犯波罗夷。是中无疑。彼便言。我是中有疑见闻疑犯波罗夷。以无根法谤僧伽婆尸沙。若彼人不清净。不见闻疑彼犯波罗夷。是中无疑后忘无疑。彼便言。我见闻疑彼犯波罗夷。以无根法谤僧伽婆尸沙。若彼人不清净不见彼犯波罗夷。便言。我闻疑彼犯波罗夷。以无根法谤僧伽婆尸沙。若彼人不清净。不见彼犯波罗夷。是中有见想。后忘此想。便言。我闻疑彼犯波罗夷。以无根法谤僧伽婆尸沙。若彼人不清净。不见彼犯波罗夷。是中有疑。便言。是中无疑。我闻疑彼犯波罗夷。以无根法谤僧伽婆尸沙。若彼人不清净。不见彼犯波罗夷。是中有疑后忘疑。便言。我闻疑彼犯波罗夷。以无根法谤僧伽婆尸沙。若彼人不清净。不见彼犯波罗夷。是中无疑。便言。我有疑。我闻疑彼犯波罗夷。以无根法谤僧伽婆尸沙。若彼人不清净。不见彼犯波罗夷。是中无疑。后忘此无疑。便言。我闻疑彼犯波罗夷。以无根法谤僧伽婆尸沙。闻疑亦如是(此中更有诸句文繁不出)若比丘以无根四事谤比丘。说而了了僧伽婆尸沙。不了了偷兰遮。若指印书遣使。若作知相了了僧伽婆尸沙。不了了偷兰遮。除四波罗夷。更以余非比丘法谤言。汝犯边罪。犯比丘尼。贼心受戒。破内外道黄门。杀父杀母杀阿罗汉破僧恶心出佛身血。非人畜生二根。说而了了者僧伽婆尸沙。不了了者偷兰遮。若指印书使若作知相。了了僧伽婆尸沙。不了了偷兰遮。除此非比丘法。更以余无根法谤比丘。随前所犯若以八无根波罗夷法谤比丘尼。说而了了僧伽婆尸沙。不了了偷兰遮。若指印若书使若作知相。了了僧伽婆尸沙。不了了偷兰遮。除此八波罗夷。更以余无根非比丘尼法。谤了了僧伽婆尸沙。不了了者偷兰遮。若以指印书使若作知相了了僧伽婆尸沙。不了了偷兰遮。除非比丘尼法。更以余无根法谤比丘尼者随前所犯。除比丘比丘尼。以无根罪谤余人者突吉罗比丘尼僧伽婆尸沙。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。见根闻根疑根说实。戏笑说若疾疾说若独说静处说梦中说。若欲说此错说彼无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(八竟)

佛在罗阅只耆阇崛山中。时慈地比丘从耆阇崛山下见大羝羊共母羊行淫。见已自相谓言。此羝羊即是沓婆摩罗子。母羊即是慈比丘尼。我今当语诸比丘言。我先以闻无根法谤沓婆摩罗子我等今亲自眼见沓婆摩罗子实与慈比丘尼行不净即便往诣诸比丘所言。我等前闻以无根波罗夷谤沓婆摩罗子。今亲自眼见沓婆摩罗子与慈比丘尼行淫。诸比丘言。此事云何。汝等莫以无根法谤沓婆摩罗子修梵行人。以无根法谤梵行人得重罪。尔时慈地比丘。得诸比丘诘问已。便作是言。沓婆摩罗子无有此事。是清净人。我等向者从耆阇崛山下。见诸羝羊与母羊行淫。我等即自相谓言此羝羊是沓婆摩罗子。母羊是慈比丘尼。我等今日目自见之。当向诸比丘说言。我本以闻无根法谤沓婆摩罗子。今眼自见共慈比丘尼行淫。然此沓婆摩罗子是清净人实无此事。诸比丘闻已。中有少欲知足行头陀乐学戒知惭愧者。嫌责慈地比丘。汝等云何以异分无根波罗夷谤沓婆摩罗子清净人。诸比丘即往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊以此因缘集比丘僧。以无数方便呵责慈地比丘。汝等所为非。非威仪非沙门法。非净行非随顺行。所不应为。沓婆摩罗子修梵行。汝等云何以异分无根波罗夷谤沓婆摩罗子清净人。呵责已告诸比丘。慈地比丘痴人。多种有漏处最初犯戒。自今已去与诸比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘以嗔恚故于异分事中取片。非波罗夷比丘以无根波罗夷法谤。欲坏彼清净行。彼于异时若问若不问。知是异分事中取片。是比丘自言。我嗔恚故作是语。作是语者僧伽婆尸沙。比丘义如上嗔恚如上说异分者。若比丘不犯彼罗夷言见犯波罗夷。以异分无根法谤僧伽婆尸沙。若比丘不犯波罗夷。谓犯僧伽婆尸沙。以异分无根波罗夷法谤僧伽婆尸沙。若比丘不犯波罗夷。彼见犯波夜提波罗提提舍尼偷兰遮突吉罗恶说。以异分事无根波罗夷法谤僧伽婆尸沙。若比丘犯僧伽婆尸沙彼言犯波罗夷。以异分无根波罗夷法谤僧伽婆尸沙。若比丘犯僧伽婆尸沙。彼谓犯波逸提波罗提提舍尼偷兰遮突吉罗恶说。以异分事无根波罗夷法谤僧伽婆尸沙。不清净不清净人相似。名同姓同相同以此人事谤彼。以异分无根波罗夷法谤僧伽婆尸沙。若不清净人与清净人相似。名同姓同相同以此人事谤彼以异分无根波罗夷法谤僧伽婆尸沙。若清净人与不清净人相似。名同姓同相同以此人事谤彼。以异分无根波罗夷法谤僧伽婆尸沙。若清净人清净人相似。名同姓同相同以此人事谤彼。以异分无根波罗夷法谤僧伽婆尸沙。若见本在家时犯淫盗五钱若过五钱若杀人。便语人言。我见比丘犯淫盗五钱若过五钱若杀人。以异分无根波罗夷法谤僧伽婆尸沙。若闻本在家时犯淫闻盗五钱若过五钱闻杀人闻自称得上人法。彼便作是言。我闻彼犯淫闻盗五钱若过五钱闻断人命闻自称得上人法。以异分无根波罗夷法谤僧伽婆尸沙。若比丘自语闻响声。我犯淫闻盗五钱若过五钱闻断人命闻自称得上人法。以异分无根波罗夷法谤僧伽婆尸沙。若比丘以异分无根四事法谤比丘说而了了者僧伽婆尸沙。说而不了了者偷兰遮。若指印若书若使若作知相。了了者僧伽婆尸沙。不了了者偷兰遮。除四波罗夷以余异分无根非比丘法谤言汝犯边罪乃至二形如上说。说而了了者僧伽婆尸沙。不了了者偷兰遮。若指印若书若使若作知相了了者僧伽婆尸沙。不了了者偷兰遮。除上事更以余异分无根法谤比丘随前所犯。若比丘以异分无根八波罗夷法谤比丘尼。说而了了者僧伽婆尸沙。不了了者偷兰遮。若指印若书若使若作知相。了了者僧伽婆尸沙不了了者偷兰遮。除八波罗夷以余异分非比丘尼法谤。说而了了者僧伽婆尸沙。不了了者偷兰遮。若指印若书若使若作知相。了了者僧伽婆尸沙。不了了者偷兰遮。除非比丘尼法。更以余异分无根法谤比丘尼随所犯。除谤比丘比丘尼。以异分无根法谤余人者突吉罗。比丘尼僧伽婆尸沙。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者见根闻根疑根说实。戏笑说疾疾说若独说梦中说。若欲说此错说彼不犯不犯者。最初未制戒。痴狂心乱痛恼所缠(九竟)

尔时佛在弥尼搜国阿奴夷界。时诸豪族释子执信牢固。从世尊求出家。时有释种子兄弟二人一名阿那律次名摩诃男。阿那律者其母爱念常不离目前。其母与设三时殿。春夏冬使与诸婇女五欲自恣共相娱乐。时摩诃男释子语阿那律言。今诸释种豪族子孙尽以信坚固从世尊求出家而我一门都无出家者。兄可知家业。公私之事一以相付。弟欲出家。若不能者弟当持家业。兄可出家。阿那律言。我今不能出家。卿能可去。摩诃男如是再三语。阿那律亦再三报言。我不能出家。摩诃男语阿那律言。若不能出家者我今当白兄持家业事。应典领作人修治屋宅。奉望贵胜及诸知亲。出入王所威仪礼节其事如是。耕田种作务及时节。阿那律报言。卿之所说极为繁碎我所不堪。何不说言于五欲中共相娱乐耶。居业之事卿自为之。我欲以信从世尊求出家。摩诃男报言。兄可往辞母。时阿那律即诣母所白言。听子所说。当知诸释种子皆共出家而我居门独无出家者我今欲往诣世尊所求出家若母听许便当出家修清净行。其母报言。吾正有汝等二人。爱念情深初不欲离目前。今云何令汝出家也。乃至于死犹不欲相离况当生别。时阿那律如是再三白母欲求出家。其母亦再三答终不放汝。时阿那律再三从母求出家。母即自思念。当以何方便令子不出家。寻复念言。释种子跋提其母甚爱念必不听出家。当语阿那律言。若跋提母放子出家。我亦放汝出家。念已即语阿那律。时阿那律闻母此言已。往跋提所语言。卿今知不。诸释子尽出家。然我等未有出家者。我等二人可共出家。跋提报言。我不堪出家。卿欲出家任意。阿那律如是再三劝之。跋提亦再三报言我不出家。阿那律报言。我今日出家之事一以由汝。彼报言。卿云何以出家之事一以见由。阿那律报言。我辞母出家。母报我言。汝若能令跋提出家者当放汝出家。是以相由耳。跋提报言。卿且止。须我往白母。时跋提释子即往母所。长跪白母言。母今知不。诸释种子尽出家。唯我一门独无。我今信乐欲从世尊求出家。愿母见听。其母报言。我不听汝出家。何以故。我正有汝一子。心甚爱念不欲须臾离目前。乃至于死犹不欲相离而况生别。跋提如是再三白母唯见听许。其母亦再三报子不听出家。其母见儿心至。窃自念言。我当作何方便令子不出家。时母思惟。阿那律母甚爱其子。彼终不听令出家。若彼听出家者我亦当放子出家。念已即语跋提言。若阿那律母听子出家。我当放汝。时跋提释子往阿那律所语言。我母已听我出家。我等今可且复自停。更在家七年五欲极意共相娱乐然后出家。阿那律报言。七年极远人命无常。跋提复言。若不能七年者宁可六年。若五四三二一年在家五欲自娱耶。阿那律报言。一年极远我不堪忍人命无常。跋提言。若不堪一年。可七月中五欲自娱耶。阿那律报言。七月极远我不堪忍人命无常。跋提言。若不堪七月。可六五四三二一月共相娱乐耶。阿那律言。一月极远我不堪忍人命无常。跋提子言。若不能一月者可七日之中共相娱乐耶。阿那律报言。七日不远。若七日竟能出家者善。若不出家我当出家。时诸释子七日之中极意五欲共相娱乐。满七日已。时阿那律释子。跋提释子。难提释子。金毗罗释子。难陀释子。跋难陀释子。阿难陀释子。提婆达释子。优波离剃发师第九各净洗浴已。以香涂身梳治须发着珠璎珞。乘大象马出迦毗罗卫城。时国人民见诸释子。自相谓言。此诸释子。先洗浴其身着璎珞具。乘大象马入园游观亦如今日。时诸释子乘大象马齐其界内下象。脱衣服璎珞具并象。与优波离语言。汝常依我等以自存活。我等今者出家。以此宝衣并大象与汝用自资生活。时诸释子即前进至阿[少/兔]夷弥尼国。优波离在后心自思念。我本由此释子得自存活。今日以信乐舍我从世尊出家。我今宁可随逐出家。若彼有所得我亦当得。时优波离即以所得宝衣璎珞以白叠裹之悬着高树。念言。其有来取者与之。于是便往诣诸释子所。白诸释子言。汝等来后。我即生念。我常依诸释子得自生活。今日诸释子以信乐从世尊求出家。而况我不随逐出家耶。诸释子所得我亦当得。时诸释子及优波离。相将诣世尊所头面礼足却住一面。白佛言。世尊。我等父母已听出家。愿大德听我出家。唯愿世尊先度优波离。何以故。我等多有憍慢欲除憍慢故。尔时世尊即先度优波离次度阿那律。次跋提释子。次难提释子。次金毗罗释子。次难陀释子。优波离受大戒最为上座。时有大上座名毗罗荼。别度释子阿难陀。余次上座度跋难陀提婆达多。尔时世尊度诸释子已遣诣占波国。尔时诸释子受世尊及诸上座教授已往诣彼国。各自思惟证增上地。提婆达得神足证。时跋提释子独在阿兰若处树下冢间思惟。于夜过已高声称言。甚乐甚乐。其边诸比丘闻。念言。此跋提比丘本在俗时恒五欲以自娱乐。舍彼荣乐出家为道。独在阿兰若处树下冢间。于夜过已而自称言。甚乐甚乐。此跋提释子将无自念。本在家时五欲自娱而自称言甚乐耶。时诸比丘明旦诣世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊敕一比丘。汝可速唤跋提比丘来。比丘受教即便往唤跋提比丘言。世尊唤汝来。时跋提比丘即诣世尊所。头面礼足在一面坐。世尊知而故问。云何跋提。汝实独在阿兰若处冢间树下至中夜自称言甚乐甚乐耶。跋提答言。实尔世尊。佛言。跋提。汝观察何义而自称言甚乐甚乐耶。跋提白佛言。我本在家时内外常以刀杖而自卫护。如是卫护犹有恐怖。惧有外怨贼而来侵夺我命。今我独在阿兰若处冢间树下。至于中夜无有恐惧身毛不竖。大德。我念出离之乐。是故自称言甚乐甚乐耳。世尊告言。善哉善哉族姓子。是汝所应以信出家乐清净行。尔时世尊在罗阅只耆阇崛山。时瓶沙王无子。时王即集能相婆罗门令占相诸夫人。语言。汝占此诸夫人何者应生子。婆罗门占相言。此少壮夫人当生子而是王怨。王闻是语已。于其夜与此夫人交会。即便有娠。后生男颜容端正。未生子时婆罗门记言。当是王怨。因此立字名未生怨。然此王子年渐长大。提婆达以神通力使王子信乐。提婆达念言。我欲畜徒众。尔时世尊在拘睒毗国。时彼国中有人。名迦休拘罗子。命终未久生化自在天中。时迦休天子中夜时来至大目揵连所。头面礼足在一面立。白目连言。提婆达心欲为恶。而生念言。我欲畜徒众。时迦休天子作此语已。头面作礼绕竟即没不现。时目连夜过已往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊问目连言。汝意云何。如迦休天子所言实尔无错耶。目连白佛言。实尔世尊。世尊告目连。莫作是说。我不见诸天世人诸魔梵王沙门婆罗门所说如实无违。唯除如来言不虚也。佛告目连。世有五事最尊。(如后所说)尔时提婆达往至太子阿阇世所。以神通力飞在空中。或现身说法。或隐身说法。或现半身说法。或不现半身说法。或身出烟。或身出火。或变身作婴孩。身着璎珞在太子抱上转侧[朿*欠]太子指。时太子阿阇世见此变恐惧身毛为竖。时提婆达知太子恐惧即语言。勿怀恐惧勿怀恐惧。太子问曰。汝是何人。答言我是提婆达。太子言。汝实是提婆达者还复汝身。寻复其身。见已即增信乐。既信乐已更增所供养。时阿阇世日日将从五百乘车朝暮问讯并供五百釜饮食。时诸比丘闻阿阇世日从五百乘车朝暮问讯提婆达。并供养五百釜饮食。即至世尊所头面礼足在一面坐。以此因缘具白世尊。世尊尔时告诸比丘。汝等各自摄心莫生贪着提婆达利养也。何以故。正使阿阇世日日从五百乘车。朝暮问讯并供五百釜饮食。正可增益提婆达恶心。譬如男子打恶狗鼻而令彼狗更增凶恶。比丘当知此亦如是。正使阿阇世日日从五百乘车。朝暮问讯提婆达。并供五百釜饮食。正可增提婆达恶心耳。时摩竭国王瓶沙闻阿阇世日日从五百乘车。朝暮问讯提婆达。并供五百釜饮食。时王瓶沙日将从七百乘车。朝暮问讯世尊并供七百釜饮食。尔时提婆达闻瓶沙王将从七百乘车朝暮问讯世尊并供七百釜饮食。闻已以利养故生嫉妒心即失神通。便作是念。我今当伺候佛大众集时。往至佛所求哀请言。世尊年已老迈。寿过于人。学道亦久。宜居闲静默然自守。世尊是诸法之主。宜可以僧付嘱于我。我当将护。尔时提婆达伺大众集。即如所念具白世尊。佛告言。我尚不以僧付舍利弗目连。况汝痴人涕唾之身岂可付嘱。时提婆达生此念。今世尊于大众中乃言。我愚痴涕唾之身。即生不忍心。此是提婆达于此生中最初于世尊所生不忍心。时提婆达往阿阇世所语言。王以正法治者得长寿。汝父死后乃得作王。年已老耄不得久在五欲中而自娱乐。汝可杀父我当杀佛。于摩竭国界有新王新佛。治国教化不亦乐耶。王子报言可尔。即问提婆达。汝须何等。答言。我须人众。即便与人。时提婆达即遣二人往欲害佛。教言。汝往杀佛已更从余道来。遣二人去。后复更遣四人语言汝逆彼二人若得便杀更从余道来。后复更遣八人语言。汝逆彼四人。若于道路得便杀之更从余道来。如是转倍遣人乃至六十四人。如是根本断灭不可分别不知谁害世尊。世尊尔时在猪坎窟中坐。从此窟出于山岩下经行。佛自念言。昔我所作缘对期在今日。时二人受提婆达教。即着铠执持刀杖往趣世尊。彼二人心念我欲害佛。适生此念即时不能得前。念言世尊有大神德威力无量。正使弟子亦有神力。我等岂能得害世尊。适生此念即便得往。遥见世尊颜貌端正。诸根寂定得上调伏第一寂灭。诸根坚固如调龙象。意不错乱犹水澄清内外清彻。见已发欢喜心。即舍刀杖置在一处。前诣世尊所。头面作礼在一面坐。世尊渐渐为二人说微妙法。使发欢喜劝令修善。说施说戒说生天福。呵欲不净赞叹出离。二人即于座上诸尘垢尽得法眼净见法得法。白佛言。自今已去受三自归。归依佛归依法归依僧。作优婆塞。自今已去尽形寿不杀生乃至不饮酒。时世尊告二人言。汝欲还者乃更从彼道去莫从此道。即从坐起头面礼佛绕三匝而去。到提婆达所语言。世尊有大神德威力。无量弟子亦有神力。我等岂能害世尊耶。时提婆达报言。汝出去灭去何用汝为。云何二人不能杀一人。提婆达乘此恚意。自往耆阇崛山。手执大石遥掷世尊。时有天即接石置山顶上。从彼石边有小迸石片来打佛足指伤皮血出。时世尊即右顾犹如大龙作如是言。未曾有瞿昙乃作是事。时世尊即还入窟。自襞僧伽梨四叠。右胁卧犹如师子。脚脚相累极患疼痛一心忍之。时众多比丘闻提婆达遣人害佛。各各皆执杖石绕窟高声大唤。佛从窟出语诸比丘。汝等何为执此杖石绕窟大唤。如捕鱼者得鱼唤声。诸比丘白佛言。向闻提婆达欲来害佛。是故我等手执杖石来至窟所恐怨家来害世尊。佛告比丘。汝等各还所止专意修道。诸佛常法无所覆护。何以故。已胜诸怨故。汝等比丘。当知转轮圣王若为外怨所害无有是处。如来亦复如是。若有众恶来害无有是处。告诸比丘。世有五种尊。何谓五或有尊戒不清净自称言我戒清净。诸弟子亲近如实知之言。今我师戒不清净。自称我戒清净。我若向诸白衣说彼即不喜。若彼不喜则不应说。置令受人施。后自当知。如是诸比丘。彼世间尊法。弟子为戒生护。师求弟子护。二者诸比丘或有命不清净。自称言。我命清净如上说。三者诸比丘或有见慧不清净。而自称我见慧清净如上说。四者或有言说不清净。自称言我言说清净。如上说。五者或有在法律外。而自称言我在法律内清净。如上说。如是诸比丘。世有是五种以为尊法。诸比丘。我今持戒清净。亦自称言我持戒清净。不令弟子护我我亦不求弟子护。如是诸比丘。我命清净自称言。我命清净。如上说。如是诸比丘。我见慧清净自称言。我见慧清净。如上说。诸比丘。我言说清净。自称言。我言说清净。如上说。诸比丘。我在法律内。自称言。我在法律内。如上说。时世尊告诸比丘。汝等可差舍利弗使告诸白衣大众。若提婆达所为事者则非佛法僧事。是提婆达所作。应作白二羯磨。当差堪能羯磨人。如上作如是白。大德僧听。若僧时到僧。忍听。今差舍利弗比丘向诸白衣大众说。提婆达所为事者非佛法僧事。当知是提婆达所作。白如是。大德僧听。僧今差舍利弗比丘。向诸白衣大众说。提婆达所作事非佛法僧事。是提婆达所作。谁诸长老忍僧差舍利弗向诸白衣大众说。提婆达所作非佛法僧者默然。谁不忍者说。僧已忍。差舍利弗向诸白衣大众说提婆达所作事。非佛法僧竟。僧忍默然故是事如是持。时舍利弗闻此语已心疑。即往至世尊所。头面礼足在一面坐白佛言。世尊我当云何在白衣众中说其恶。何以故。我本向诸白衣赞叹其善言。大姓出家聪明有大神力颜貌端正。佛告舍利弗。汝先赞叹提婆达聪明有大神力大姓出家。实尔以不。答言。大德实尔。是故舍利弗汝今应往至白衣大众中语言。提婆达先时如是。今日如是。当知提婆达所作非佛法僧。是提婆达所作。尔时舍利弗承佛教已。往白衣大众中。语言。提婆达先时如是今日如是。当知提婆达所作者非佛法僧。是提婆达所作。时大众中忍可提婆达者即言。沙门释子以供养故生嫉妒心。不喜提婆达得供养故。便于大众中说言。提婆达所作非佛法僧。是提婆达所作耳中有信乐佛者便作此言。提婆达或能已作或方当作。时阿阇世密自衣裹带刀疾疾入宫欲害其父。时守门者发觉搜求身上得刀。问言。执此刀欲作何等。报言。我欲入宫害王。守门者问言。谁教汝乃生此心耶。答言。提婆达教我。时守门者即将诣诸大臣所语言。阿阇世欲害王时诸大臣问言。谁教汝。答言。提婆达教我。众中有臣言。沙门释子皆作此事尽应当杀。或有臣言诸沙门释子不尽为恶不应尽杀。唯是王子提婆达所作今当杀之。或有臣言。此沙门释子不尽为恶。但提婆达阿阇世所作。虽应死不应杀。何以故。王是法王闻必不悦。时即卫守将诣瓶沙王所白王言。此阿阇世欲害于王。王问谁教汝耶。答言。是提婆达。中有大臣言。沙门释子一切皆恶尽应杀之。王闻此言心甚不悦。中有臣言。沙门释子不尽为恶不应尽杀。但提婆达阿阇世所作王应杀之。王闻此言心亦不悦。中有大臣言。沙门释子不尽为恶不应尽杀。是提婆达阿阇世所作。今虽应死不应杀。何以故。王是法王恐闻必不悦。时王瓶沙悦可此语。告诸臣言。此一切沙门释子不必皆恶。是故不应尽杀。是提婆达阿阇世所作亦不应杀。何以故。佛先命舍利弗在大众中说言。提婆达所作者非佛法僧。是提婆达所作耳。是故不应杀。时父王呵责太子阿阇世已。告诸大臣。可恕太子阿阇世。寻即放去。时诸大臣皆共高声言。阿阇世所为事大应死。云何小尔呵责便放去耶。尔时提婆达既教人害佛复教阿阇世害父。恶名流布利养断绝。时提婆达通己五人家家乞食。一名三闻达多。二名骞荼达婆。三名拘婆离。四名迦留罗提舍。及其身为五。时诸比丘闻提婆达教人害佛。复教阿阇世害父。恶名流布利养断绝。通己五人家家乞食。往世尊所头面礼足在一面坐。以此因缘具白世尊。世尊即集大众。知而故问提婆达言。汝实将四人家家乞食耶。答言。如是世尊。世尊尔时以无数方便呵责提婆达。汝所为非。非威仪非沙门法。非净行非随顺行。所不应为。汝云何别将四人家家乞食耶。我无数方便说应慈愍白衣家。汝今云何别将四人家家乞食。时世尊以无数方便呵责提婆达已。即告诸比丘。自今已去不得别众食。听齐三人食。所以然者。有二事利故。为摄难调故。为慈愍白衣家故。何以故。恐彼难调人故。自结别众以恼众僧。提婆达即生此念。未曾有瞿昙沙门乃断人口食。我宁可破彼僧轮。我身灭后可得名称言。沙门瞿昙有大神力智慧无碍。而提婆达能破彼僧轮。时提婆达即往伴比丘所。语言。我等今可共破彼僧轮。我等死后可得名称言。沙门瞿昙有大神力智慧无碍。而提婆达能破彼僧轮。时提婆达伴。名三闻达多。智慧高才。即报言。沙门瞿昙有大神力。及其弟子徒众亦复如是。我等何能得破彼僧轮。提婆达言。如来常称说头陀少欲知足乐出离者。我今有五法亦是头陀胜法少欲知足乐出离者。尽形寿乞食。尽形寿着粪扫衣。尽形寿露坐。尽形寿不食酥盐。尽形寿不食鱼及肉。我今持此五法教诸比丘足令信乐。当语诸比丘言。世尊无数方便叹誉头陀少欲知足乐出离者。我等今有五法。亦是头陀胜法。尽形寿乞食。乃至不食鱼及肉可共行之。年少比丘必多受教。上座比丘恐不信受。由此方便故得破其僧轮。时三闻达多语提婆达言。若作如是足得破彼僧轮。时提婆达即以五法教诸比丘言。世尊无数方便叹誉头陀少欲知足乐出离者。我等今有五法。亦是头陀少欲知足乐出离胜法。我等尽形寿乞食。尽形寿着粪扫衣。尽形寿露坐。尽形寿不食酥盐鱼及肉。尔时众多比丘闻提婆达以五法如是教诸比丘令其信乐。广说如上。诸比丘闻已往至世尊所。头面礼足在一面坐。以此因缘具白世尊。佛告诸比丘。提婆达今日欲断四圣种。何等四。我常以无数方便说衣服趣得知足。我亦叹说衣服趣得知足。我亦以无数方便说饮食床卧具病瘦医药趣得知足。亦叹说饮食床卧具病瘦医药趣得知足。比丘当知。提婆达今日欲断四圣种。时世尊以此因缘集比丘僧。知而故问提婆达言。汝审欲以五法教诸比丘不。广说如上。对曰。如是世尊

四分律卷第四四分律卷第五(初分之五)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    十三僧残法之四

世尊尔时。以无数方便呵责。汝云何以五法教诸比丘。广说如上。提婆达汝莫断四圣种。何等四如上所说。提婆达。汝今莫方便破和合僧。莫方便受破和合僧坚持不舍。汝当与僧和合不斗诤。同一水乳于佛法中安乐住。是故提婆达。当知破和合僧甚恶艰难得大重罪。破和合僧在泥犁中一劫受罪不可救。时世尊以无数方便令提婆达破僧心暂息。以无数方便呵责提婆达已。告诸比丘。听僧与提婆达呵谏。舍此事故白四羯磨。众中应差堪能羯磨者如上作如是白。大德僧听。此提婆达欲方便破和合僧坚持不舍。若僧时到僧忍听与作呵谏。舍此事故。提婆达汝莫破和合僧坚持不舍。汝提婆达当与僧和合欢喜不诤同一水乳。于佛法中安乐住。白如是。大德僧听。此提婆达欲受破和合僧法坚持不舍。今僧与呵谏。舍此事故。汝莫破和合僧坚持不舍。汝提婆达当与僧和合欢喜不诤同一水乳。于佛法中安乐住。谁诸长老忍。僧与提婆达呵谏舍此事者默然。谁不忍者说是初羯磨。第二第三亦如是说。僧已忍。与提婆达呵谏舍此事竟。僧忍默然故是事如是持。应作如是呵谏。僧为提婆达作如是呵谏白四羯磨。诸比丘以此事故白世尊。世尊告言。若余比丘。方便欲破和合僧者。亦当以此白四羯磨呵谏。自今已去为诸比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘欲坏和合僧方便受坏和合僧法坚持不舍。彼比丘应谏是比丘。大德莫坏和合僧。莫方便坏和合僧莫受坏僧法坚持不舍。大德应与僧和合。与僧和合欢喜不诤。同一师学如水乳合。于佛法中有增益安乐住。是比丘如是谏时坚持不舍。彼比丘应三谏。舍此事故。乃至三谏时舍者善。不舍者僧伽婆尸沙。比丘义如上说。和合者同一羯磨同一说戒。僧者四比丘若五若十乃至无数。破者破有十八事。法非法律非律。犯不犯若轻若重。有残无残粗恶非粗恶。常所行非常所行。制非制说非说。是为十八。住破僧法者即住此十八事是。若比丘方便欲破和合僧受破僧法坚持不舍。彼比丘当谏此比丘言。大德。莫方便欲破和合僧。莫受破僧法坚持不舍。大德。当与僧和合欢喜不诤同一水乳。于佛法中有增益安乐住。大德可舍此事。莫令僧作呵谏而犯重罪。若用语者善。若不用语者。复令比丘比丘尼优婆塞优婆夷。若王大臣种种异道沙门婆罗门求。若余方比丘闻知其人信用言者应来。若用言者善。若不用言者应作白。作白已应更求。大德我已白竟。余有羯磨在。汝今可舍此事。莫令僧为汝作羯磨更犯重罪。若用语者善。不用语者应作初羯磨。作初羯磨已应更求。大德。我已白作初羯磨竟。余有二羯磨在。汝可舍此事。莫令僧更为汝作羯磨而犯重罪。若用语者善不用语者应作第二羯磨。作第二羯磨已应更求。大德。我已作白二羯磨竟。余有一羯磨在。汝可舍此事。莫令僧更为汝作羯磨而犯重罪。若能舍者善。若不舍者与说第三羯磨竟僧伽婆尸沙。作白二羯磨竟舍者三偷兰遮。作白一羯磨竟舍者二偷兰遮。作白竟舍者一偷兰遮。若初白未竟舍者突吉罗。若一切未白方便欲破和合僧受破和合僧法坚持不舍一切突吉罗。若僧为破僧人作呵谏羯磨时。有比丘教言莫舍此比丘偷兰遮。若不呵谏突吉罗。若比丘尼教言莫舍。尼偷兰遮。未作呵谏尼教莫舍突吉罗。除比丘比丘尼。更有余人教莫舍尽突吉罗。比丘尼僧伽婆尸沙。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者初谏便舍。若非法别众作呵谏。非法和合众作呵谏。法别众。法相似别众。法相似和合众。非法非律非佛所教。若一切未作呵谏。若破恶友恶知识。若破方便欲破僧者遮令不破。若破方便助破僧者。二三人羯磨。若欲作非法非毗尼羯磨。若为僧为塔为和上同和上。为阿阇梨同阿阇梨为知识。作损减作无住处破者是谓不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(十竟)

佛在罗阅只耆阇崛山中。时提婆达故执此五法。复往教诸比丘言。世尊以无数方便常叹说头陀少欲知足乐出离者。尽形寿乞食。着粪扫衣。露坐。不食酥盐。不食鱼及肉。时诸比丘语提婆达言。汝莫破和合僧。莫住破僧法坚持不舍。何以故。与僧和合欢喜不诤同一水乳。于佛法中有增益安乐住。时提婆达伴党方便助破和合僧比丘语诸比丘言。汝莫呵提婆达所说。提婆达是法语比丘律语比丘。提婆达所说我等忍可。诸比丘闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责提婆达伴党比丘。汝等云何言。提婆达是法语比丘律语比丘。提婆达所说我等忍可。诸比丘嫌责已。往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊以此因缘集比丘僧。无数方便呵责提婆达伴党比丘。汝所为非。非威仪非沙门法。非净行非随顺行。所不应为。云何语诸比丘言。莫呵提婆达所说。提婆达是法语比丘律语比丘。提婆达所说我等忍可。尔时世尊以无数方便呵责提婆达伴党比丘已。告诸比丘。听僧与提婆达伴党比丘作呵谏。舍此法故白四羯磨。众中当差堪能羯磨者如上作如是白。大德僧听。此提婆达伴党比丘。顺从提婆达作如是言。汝等诸比丘莫呵提婆达。何以故。提婆达是法语比丘律语比丘。提婆达所说我等忍可。若僧时到僧忍听。僧今与提婆达伴党比丘作呵谏。舍此事故。汝等莫言提婆达是法语比丘律语比丘。提婆达所说我等忍可。然提婆达非法语比丘非律语比丘。汝莫欲坏和合僧。汝等当助和合僧。大德。与僧和合欢喜不诤同一水乳。于佛法中。有增益安乐住。白如是。大德僧听。此提婆达伴党比丘。顺从提婆达作如是语。汝等诸比丘莫呵提婆达。提婆达是法语比丘律语比丘。提婆达所说我等忍可。僧今为提婆达伴党比丘作呵谏。舍此事故。大德。莫作如是语。提婆达是法语比丘律语比丘。提婆达所说我等忍可。而提婆达非法语比丘非律语比丘。汝等莫坏和合僧。汝等当助和合僧。大德。与僧和合欢喜不诤同一水乳。于佛法中有增益安乐住。谁诸长老忍。僧呵谏提婆达伴党比丘。令舍此事者默然。谁不忍者说。是初羯磨。第二第三亦如是说。僧已忍。呵谏提婆达伴党比丘令舍此事竟。僧忍默然故。是事如是持。当作如是呵谏提婆达伴党比丘白四羯磨。诸比丘白佛。佛告诸比丘。从今已去若有如是伴党。相助坏和合僧者。亦当作如是呵谏白四羯磨。自今已去与诸比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘有余伴党若一若二若三乃至无数。彼比丘语是比丘。大德。莫谏此比丘。此比丘是法语比丘律语比丘。此比丘所说我等喜乐。此比丘所说我等忍可。彼比丘言。大德。莫作是说言。此比丘法语比丘律语比丘。此比丘所说我等喜乐。此比丘所说我等忍可。然此比丘非法语比丘非律语比丘。大德。莫欲破坏和合僧。汝等当乐欲和合僧。大德。与僧和合欢喜不诤。同一师学如水乳合。于佛法中有增益安乐住。是比丘如是谏时坚持不舍。彼比丘应三谏。舍是事故。乃至三谏舍者善。不舍者僧伽婆尸沙。比丘义如上说。顺从者有二顺从。法顺从衣食顺从。法顺从者。以法教授增戒增心增慧讽诵承受。衣食顺从者。给与衣被饭食床卧敷具病瘦医药。伴党者若四若过四人。助伴党语者。若一若二若三若众多。若比丘作非法群党语诸比丘言。大德。汝莫谏此比丘。此比丘是法语比丘律语比丘。此比丘所说我等忍可。汝莫作是语。此比丘是法语比丘律语比丘。此比丘所说我等忍可。而此比丘非法语比丘非律语比丘。汝等莫坏和合僧。当助和合僧。大德。与僧和合欢喜不诤同一水乳。于佛法中有增益安乐住。可舍此事。勿为僧所呵更犯重罪。若随语者善。若不随语者当白。白已当语彼人言。我已白。余有羯磨在。汝可舍此事。勿为僧所呵更犯重罪。若随语者善。若不随语者当作初羯磨。作初羯磨已当语彼人言。我已白及初羯磨。余有二羯磨在。可舍此事。勿为僧所呵更犯重罪。若随语者善。不随语者当作第二羯磨。作第二羯磨已当语彼人言。已白二羯磨竟余有一羯磨在。汝可舍此事。勿为僧所呵更犯重罪。若随语者善。不随语者作三羯磨。作三羯磨竟僧伽婆尸沙。白竟二羯磨舍者三偷兰遮。白竟一羯磨舍者二偷兰遮。白竟舍者一偷兰遮作白未竟舍者突吉罗。若未白一切随破僧伴党尽突吉罗。若比丘谏群党比丘时。更有余比丘语莫舍。此比丘偷兰遮。若未作呵谏突吉罗。若比丘谏群党比丘时。比丘尼语坚持莫舍者尼偷兰遮。若未作谏尼言莫舍者突吉罗。除比丘比丘尼。余人教言。莫舍尽突吉罗。比丘尼僧伽婆尸沙。式叉磨那沙弥沙弥尼突吉罗。是谓为犯。不犯者初语时舍。非法别众。非法和合众。法别众。法相似别众。法相似和合众。非法非律非佛所教。若一切未作呵谏不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(十一竟)

尔时佛在舍卫国祇树给孤独园。时羁连有二比丘。一名阿湿婆二名富那婆娑。在羁连行恶行污他家。污他家亦见亦闻。行恶行亦见亦闻。彼作如是非法行。自种华树教人种花树。自溉灌教人溉灌。自摘花教人摘花。自作华鬘教人作华鬘。自以线贯系若教人线贯系。自持花教人持花。自持华鬘与人教人持华鬘与人。若彼村落中有妇女若童女。共同一床坐起同一器饮食言语戏笑。或自歌舞倡伎或他作已唱和。或俳说或弹鼓簧吹贝作孔雀音。或作众鸟鸣或走或佯跛行。或啸或自作弄身或受雇戏笑。时有众多比丘从迦尸国渐渐游行至羁连止宿。晨朝着衣持钵入村乞食。法服齐整行步庠序。低目直前不左右顾视以次乞食。时诸居士见已自相谓言。此是何人低目而行不左右顾视。亦不言笑亦不周接亦不善言问讯。我等不应与其饮食。我等阿湿婆富那婆娑二人亦不低目而行。左右顾视与人周接善言问讯。应与饮食供养。时彼比丘在羁连乞食困乃得之。彼自念言。此住处恶恶比丘在此住。彼作如是恶乃至受雇戏笑。时诸比丘即从羁连往至舍卫城到世尊所头面礼足在一面坐。尔时世尊慰问客比丘言。汝等住止安乐不。众僧和合不。不以饮食为苦耶。诸比丘白世尊。大德。住止安乐众僧和合。我曹从迦尸国游行至羁连。以上因缘具白世尊。世尊尔时以无数方便遥呵责阿湿婆富那婆娑二比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何阿湿婆富那婆娑。在羁连污他家行恶行。污他家亦见亦闻行恶行亦见亦闻。乃至受雇戏笑。时世尊以无数方便呵责已。告舍利弗目连。汝等二人。往羁连与阿湿婆富那婆娑作羯磨。何以故。是汝等弟子故。应作白四羯磨。应如是作集僧已为彼二人作举。作举已为作忆念。作忆念已应与罪。众中应差堪能羯磨人如上作如是白。大德僧听。此阿湿婆富那婆娑在羁连污他家行恶行污他家亦见亦闻。行恶行亦见亦闻。若僧时到僧忍听。今僧为阿湿婆富那婆娑作摈羯磨。汝等污他家行恶行污他家亦见亦闻。行恶行亦见亦闻。汝等行恶行出去不应在此住。白如是。大德僧听。此阿湿婆富那婆娑在羁连污他家行恶行污他家亦见亦闻。行恶行亦见亦闻。今僧与阿湿婆富那婆娑作摈羯磨。此二人污他家行恶行。污他家亦见亦闻。行恶行亦见亦闻。汝等污他家出去不应在此住。谁诸长老忍。僧为此二人作摈羯磨者默然。谁不忍者说。此是初羯磨。第二第三亦如是说。僧已忍。与阿湿婆富那婆娑作摈羯磨竟。僧忍默然故是事如是持。尔时舍利弗目连。闻佛教已。即从坐起礼佛足绕三匝而去。舍利弗目连。着衣持钵与五百大比丘众俱。从迦尸国游行至羁连。时阿湿婆富那婆娑。闻舍利弗目连将五百大比丘众俱从迦尸国游行来至羁连。必为我等作摈羯磨。彼二人即往诣诸居士所语言。今有二比丘来。一名舍利弗。二名目连。其一比丘善能幻术飞行虚空。第二比丘行恶行自能说法。汝等好自观察莫为彼所惑。时舍利弗目连从迦尸国渐渐游行。来至羁连止宿。晨朝着衣持钵入村乞食。大目连现神足踊身空中。舍利弗亲自说法。时诸居士见已自相谓言。此二比丘。一善知幻术飞行空中。第二比丘行恶行自能说法。时舍利弗目连。即为羁连诸居士说法令得信乐。时尊者舍利弗目连。食讫洗钵还至住处。以此因缘集比丘僧。集僧已为阿湿婆富那婆娑作举。作举已为作忆念。作忆念已与罪。时舍利弗在众中即作羯磨如上说时。阿湿婆富那婆娑僧为作羯磨时作是言。众僧有爱有恚有怖有痴。更有余同罪比丘。有驱者有不驱者而独驱我。时舍利弗目连。在羁连为阿湿婆富那婆娑作羯磨已。还舍卫国祇树给孤独园。至世尊所头面礼足在一面坐。一面坐已白佛言。我等已于羁连与阿湿婆富那婆娑作摈羯磨已。众僧作摈羯磨时。阿湿婆富那婆娑作如是言。众僧有爱有恚有怖有痴。有如是同罪比丘。有驱者有不驱者。尔时世尊。以无数方便遥诃责阿湿婆富那婆娑。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何众僧与作摈羯磨时言。众僧有爱有恚有怖有痴。有如是同罪比丘有驱者有不驱者。世尊以无数方便呵责彼阿湿婆富那婆娑已。告诸比丘。自今已去听僧与阿湿婆富那婆娑作呵谏白四羯磨。众中应差堪能羯磨人如上应作如是白。大德僧听。此阿湿婆富那婆娑在羁连僧与作摈羯磨时。便作是言。僧有爱有恚有怖有痴。有如是同罪比丘。有驱者有不驱者。若僧时到僧忍听。今僧与阿湿婆富那婆娑作呵谏。舍此事故。汝等莫作是言。僧有爱有恚有怖有痴。有如是同罪比丘。有驱者有不驱者而诸比丘不爱不恚不怖不痴。汝等污他家行恶行。污他家亦见亦闻。行恶行亦见亦闻。汝等污他家行恶行。白如是。大德僧听。此阿湿婆富那婆娑。在羁连僧与作羯磨。时便作是言。僧有爱有恚有怖有痴。有如是同罪比丘。有驱者有不驱者。僧今与阿湿婆富那婆娑作呵谏。舍此事故。汝等莫作是言。僧有爱有恚有怖有痴。有如是同罪比丘。有驱者有不驱者。而诸比丘不爱不恚不怖不痴。汝等污他家行恶行。污他家亦见亦闻。行恶行亦见亦闻。汝等污他家行恶行。谁诸长老忍。僧与阿湿婆富那婆娑作呵谏。舍此事者默然。谁不忍者说。是初羯磨。第二第三亦如是说。僧已忍。与阿湿婆富那婆娑作呵谏舍此事竟。僧忍默然故是事如是持。如是与阿湿婆富那婆娑作呵谏白四羯磨已。时诸比丘往白佛。佛言。若有余比丘若僧已摈若摈时若未摈。作如是言。僧有爱有恚有怖有痴。亦应如是与作呵谏白四羯磨呵谏。自今已去与诸比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘依聚落若城邑住。污他家行恶行。污他家亦见亦闻。行恶行亦见亦闻。诸比丘当语是比丘言。大德。污他家行恶行。污他家亦见亦闻。行恶行亦见亦闻。大德。汝污他家行恶行。今可远此聚落去不须住此。是比丘语彼比丘作是语。大德。诸比丘有爱有恚有怖有痴。有如是同罪比丘。有驱者有不驱者。诸比丘报言。大德。莫作是语。有爱有恚有怖有痴。有如是同罪比丘。有驱者有不驱者。而诸比丘不爱不恚不怖不痴。大德。污他家行恶行。污他家亦见亦闻。行恶行亦见亦闻。是比丘如是谏时坚持不舍者。彼比丘应再三谏。舍此事故。乃至三谏舍者善。不舍者僧伽婆尸沙。比丘义如上。村者有四种如上。聚落城邑者属王。家者有男有女。污他家者。有四种事。依家污家。依利养污家。依亲友污家。依僧伽蓝污家。云何依家污家。从一家得物与一家。所得物处闻之不喜。所与物处思当报恩。即作是言。若有与我者我当报之。若不与我者我何故与。是为依家污家。云何依利养污家。若比丘如法得利。乃至钵中之余。或与一居士不与一居士。彼得者即生是念当报其恩。其有与我者我当报之。若不与我我何故与。是为依利养污家。云何依亲友污家。若比丘依王若大臣。或为一居士或不为一居士。所为者即思当报恩。其为我者我当供养。不为我者我不供养。是为依亲友污家。云何依僧伽蓝污家。若比丘取僧华果与一居士不与一居士。即作是念。其有与我者我当供养。不与我者我不供养。是为依僧伽蓝污家。以此四事故污家。是故言污他家。行恶行者。自种华树教人种华树。乃至受雇戏笑如上说。若比丘依聚落住。污他家行恶行。污他家亦见亦闻。行恶行亦见亦闻。彼比丘谏此比丘言。大德。污他家亦见亦闻。行恶行亦见亦闻。大德。污他家行恶行可舍此事。莫为僧所呵更犯重罪。若随语者善。若不随语者应作白。作白已应求言。大德。已作白。余有三羯磨在。可舍此事。莫为僧所呵更犯重罪。若舍者善。若不舍者应作初羯磨。作初羯磨已应更求。大德。已作白作初羯磨竟。余有二羯磨在。大德。可舍此事。莫为僧所呵更犯重罪。若随语者善。不随语者应作第二羯磨。作第二羯磨已应更求。大德。已作第二羯磨已。余有一羯磨在。大德。可舍此事。莫为僧所呵更犯重罪。若随语者善。若不随语者作第三羯磨。作第三羯磨已僧伽婆尸沙。若白二羯磨舍者三偷兰遮。若白一羯磨舍者二偷兰遮。若白竟舍者一偷兰遮。若初白未竟舍者突吉罗。若未白前言僧有爱有恚有怖有痴一切突吉罗。若僧作呵谏时更有余比丘教莫舍此比丘偷兰遮。若未作呵谏者突吉罗。若僧作呵谏时有比丘尼教言莫舍者尼偷兰遮。若未作呵谏前教者尼突吉罗。除比丘比丘尼。余人教莫舍呵不呵尽突吉罗。若不看书持往突吉罗。若为白衣作信使突吉罗。比丘尼僧伽婆尸沙。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。初语时舍。非法别众。非法和合众。法别众。法相似别众。法相似和合众。非法非律非佛所教。若一切未作呵谏前。若与父母若与病人与小儿与妊娠妇女与牢狱系人与寺中客作者不犯。若种花树复教人种供养佛法僧。教人取花供养佛法僧。自造花鬘教人造供养佛法僧。自以线贯花教人贯供养佛法僧。自持花教人持花供养佛法僧。自以线贯华鬘教人贯持供养佛法僧。皆不犯。若人举手欲打。若被贼若象熊罴师子虎狼来恐难之处。若担刺棘来于中走避者不犯。若渡河沟渠坑跳踯者不犯。若同伴行在后还顾不见而啸唤者不犯。若为父母病。若闭在狱。若为笃信优婆塞有病。若闭在狱看书往。若为塔为僧为病比丘事持书往返者一切不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(十二竟)

尔时佛在拘睒毗国瞿师罗园。时尊者阐陀比丘。恶性不受人语。语诸比丘言。汝莫语我若好若恶。我亦不语诸大德若好若恶。诸大德止。莫有所说。何用教我为。我应教诸大德。何以故。我圣主得正觉故。譬如大水初来漂诸草木积在一处。诸大德亦复如是。种种姓种种名种种家出家集在一处。亦如大风吹诸草木集在一处。诸大德亦如是。种种姓种种名种种家出家集在一处。是故诸大德。不应教我。我应教诸大德。何以故。我圣主得正觉故。时诸比丘。闻中有少欲知足行头陀乐学戒知惭愧者。嫌责阐陀比丘。云何恶性不受人语。语诸比丘言。诸大德。莫语我若好若恶。我亦不语诸大德若好若恶。诸大德且止。莫有所说。何用教授我为。我应教诸大德。何以故。我圣主得正觉故。譬如大水初来漂诸草木集在一处。亦如大风吹诸草木聚在一处。诸大德亦复如是。种种姓种种名种种家出家集在一处。是故我应教诸大德。诸大德不应教我。何以故。我圣主得正觉故。诸比丘往到世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。以无数方便呵责阐陀比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何阐陀恶性不受人语。广说如上。乃至我圣主得正觉。时世尊呵责阐陀已。告诸比丘。听僧与阐陀比丘作呵谏白四羯磨。如是呵谏。僧中应差堪能羯磨者如上作如是白。大德僧听。此阐陀比丘恶性不受人语。诸比丘以戒律如法教授。自作不可共语语诸比丘言。大德莫语我若好若恶。我亦不语诸大德若好若恶。大德且止。不须教我。若僧时到僧忍听。僧今与阐陀比丘作呵谏。舍此事故。汝阐陀莫自作不可共语。当作可共语。阐陀汝应如法谏诸比丘。诸比丘亦当如法谏汝。如是佛弟子众得增益。展转相教展转相谏展转忏悔。白如是。大德僧听。此阐陀比丘恶性不受人语。诸比丘以戒律如法教授。自作不可共语语诸比丘言。大德莫语我若好若恶。我亦不语诸大德若好若恶。大德且止。不须教我。今僧为阐陀比丘作呵谏舍此事故汝阐陀莫自作不可共语。当作可共语。汝当如法谏诸比丘。诸比丘亦当如法谏汝。如是佛弟子众得增益。展转相教展转相谏展转忏悔。谁诸长老忍。僧为阐陀比丘作呵谏。舍此事者默然。谁不忍者说。是初羯磨。第二第三亦如是说。僧已忍。与阐陀比丘作呵谏舍此事竟。僧忍默然故是事如是持。当如是呵谏。僧与阐陀比丘作呵谏白四羯磨令舍此事已。诸比丘白佛。佛言。若有余比丘。恶性不受人语者僧亦当与作如是呵谏白四羯磨。自今已去。与诸比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘恶性不受人语。于戒法中诸比丘如法谏已。自身不受谏语言。诸大德莫向我说若好若恶。我亦不向诸大德说若好若恶。诸大德且止莫谏我。彼比丘谏是比丘言。大德莫自身不受谏语。大德自身当受谏语。大德如法谏诸比丘。诸比丘亦如法谏大德。如是佛弟子众得增益。展转相谏展转相教展转忏悔。是比丘如是。谏时坚持不舍。彼比丘应三谏。舍是事故。乃至三谏舍者善。不舍者僧伽婆尸沙。比丘义如上说。恶性不受语者。不忍不受人教诲。以戒律如法教授者。有七犯聚波罗夷。僧伽婆尸沙。波逸提。波罗提提舍尼。偷兰遮。突吉罗。恶说。如法者如法如律如佛所教。若比丘恶性不受人语。诸比丘以戒律。如法教授。自身作不可共语。大德莫语我若好若恶。我亦不语诸大德若好若恶。大德。且止不须谏我。彼比丘谏此比丘言。大德莫自作不可共语。当作可共语。大德如法谏诸比丘。诸比丘亦当如法谏大德。如是佛弟子众得增益。展转相教展转相谏展转忏悔。大德。可舍此事。莫为僧所呵更犯重罪。若随语者善。不随语者应作白。作白已应更求。大德。我已作白竟。余有三羯磨在。大德可舍此事。勿为僧所呵更犯重罪。若随语者善。不随语者作初羯磨。作初羯磨已应更求。大德已作白初羯磨竟。余有二羯磨在。大德。可舍此事。勿为僧所诃更犯重罪。若随语者善不随语者为说第二羯磨。说第二羯磨已应更求。大德。我已作白第二羯磨竟。余有一羯磨在。大德。可舍此事。勿为僧所呵更犯重罪。若随语者善。不随语者为说第三羯磨。说第三羯磨竟僧伽婆尸沙。白二羯磨舍者三偷兰遮。白一羯磨舍者二偷兰遮。白已舍者一偷兰遮。作白未竟舍者突吉罗。未白前恶性不受人语尽突吉罗。若为恶性作呵谏时。若有余比丘教言莫舍此比丘偷兰遮。若未作呵谏而语者突吉罗。若比丘尼教言莫舍此比丘尼偷兰遮。若未呵谏突吉罗。除比丘比丘尼。余人教莫舍呵不呵尽突吉罗。比丘尼僧伽婆尸沙。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者初语时舍。非法别众。非法和合众。法别众。法相似别众。法相似和合众。非法非律非佛所教。若一切未作呵谏前不犯。若为无智人呵谏时语彼如是言。汝和上阿阇梨所行亦如是。汝可更学问诵经。若其事如是。若戏笑语若疾疾语。若独语若梦中语。欲说此错说彼。是谓不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(十三竟)

    二不定法

尔时世尊。在舍卫国祇树给孤独园。迦留陀夷先白衣时有亲友妇。名曰斋优婆私。颜貌端正。迦留陀夷亦颜貌端正。迦留陀夷系意在彼。彼优婆私亦系意在迦留陀夷。时迦留陀夷。到时着衣持钵诣斋优婆私家。与共独屏覆处坐。时迦留陀夷。与斋优婆私语。时有毗舍佉母。有小缘事往彼比舍。遥闻迦留陀夷语声。此优婆私有信乐之心。闻内比丘语声。作是念。或能说法。即就倚壁而听。但闻说非法语声。复念言。闻比丘声而说非法言。比丘不应作如是语。即窥看之。见迦留陀夷与斋优婆私共床坐作非法语。见已便作是念。此比丘在非法处坐。又说非法言。若此夫主见当呵骂其妇生不信心。时优婆私即还出其舍。疾疾往世尊所。头面礼足在一面立。以此因缘具白世尊。白世尊已头面礼足绕三匝而去。时世尊集比丘僧。知而故问迦留陀夷言。汝审与斋优婆私独在屏覆处坐耶。答言。实尔世尊。世尊以无数方便呵责。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。汝今云何与斋优婆私独在屏覆处坐耶。时世尊以无数方便呵责迦留陀夷已。告诸比丘。迦留陀夷愚人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘共女人独在屏覆处障处可作淫处坐说非法语。有住信优婆私。于三法中一一法说。若波罗夷若僧伽婆尸沙若波逸提。是坐比丘自言。我犯是罪。于三法中应一一治。若波罗夷若僧伽婆尸沙若波逸提。如住信优婆私所说应如法治是比丘。是名不定法。比丘义如上说。女人者人女有智未命终。独者一比丘一女人。屏覆者二种。一者见屏覆。二者闻屏覆。见屏覆者。若尘若雾若黑暗中不相见也。闻屏覆者。乃至常语不闻声处。障覆者。若树若墙壁若篱若衣及余物障。可作淫处者。得容行淫处。说非法语者。说淫欲法。信乐优婆私者。信佛法僧归依佛法僧。不杀不盗不邪淫不妄语不饮酒。善忆持事不错所说真实而不虚妄。若比丘自言所趣向处自言所到处。自言坐自言卧自言作。即应如比丘所语治。若比丘自言所趣向处自言所到处自言坐自言卧。不自言作。应如优婆私所说治。若比丘自言所趣向处自言所到处自言坐。不自言卧不自言作。应如优婆私所说治。若比丘自言所趣向处自言所到处。不自言坐不自言卧不自言作。应如优婆私所说治。若比丘自言所趣向处。不自言所到处不自言坐不自言卧不自言作。应如优婆私所说治。若比丘不自言所趣向处不自言所到处。不自言坐不自言卧不自言作。应如优婆私所说治。是中无定法故言不定(一竟)

尔时世尊。在舍卫国祇树给孤独园。时迦留陀夷先白衣时有知友妇。名曰斋优婆私。颜貌端正。迦留陀夷亦颜貌端正。迦留陀夷常系意在斋优婆私。斋优婆私亦系意在迦留陀夷。时尊者迦留陀夷。到时着衣持钵往至斋优婆私家。二人俱露现处坐共语。时毗舍佉母以小因缘往到比舍。遥闻迦留陀夷语声。作是念言。或能说法。即就倚壁而听。但闻在内说非法语声。复自念言。闻比丘声而说非法言。比丘不应作如是语。即窥看之。见迦留陀夷与斋优婆私俱露现处共坐说非法语。见已作是念。今此比丘坐既非法处又说非法语。夫主见者当呵骂其妇生不信心。时优婆私即还出其家疾疾往世尊所。头面礼足在一面立以此因缘具白世尊。白世尊已头面礼足绕三匝而去。时世尊知而故问迦留陀夷。汝审与斋优婆私在露现处共坐言语不。答言。实尔世尊。世尊以无数方便呵责言。汝所为非。非威仪非沙门法非净行非随顺行所不应为。汝今云何与斋优婆私在露现处共坐说非法事耶。时世尊以无数方便呵责迦留陀夷已。告诸比丘。迦留陀夷痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘共女人在露现处不可作淫处坐作粗恶语。有住信优婆私于二法中一一法说。若僧伽婆尸沙若波逸提。是坐比丘自言。我犯是事。于二法中应一一法治。若僧伽婆尸沙若波逸提。如住信优婆私所说应如法治是比丘。是名不定法。比丘义如上。露处者。无墙壁若树木无篱障及余物障。不可作淫处者。不容行淫处。粗恶语者。说淫欲法赞叹二道好恶。信乐优婆私者。信佛法僧归依佛法僧。不杀生不盗不邪淫不妄语不饮酒。善忆持事不错所说真实而不虚妄。若比丘自言所趣向处自言所到处自言坐自言卧。即应如比丘语治。若比丘自言所趣向处自言所到处自言坐。不自言卧。应如优婆夷所说治。若比丘自言所趣向处自言所到处。不自言坐不自言卧。应如优婆私所说治。若比丘自言所趣向处。不自言所到处不自言坐不自言卧。应如优婆私所说治。若比丘不自言所趣向处不自言所到处不自言坐不自言卧。应如优婆私所说治。是中无定法故言不定(二不定法竟)

四分律卷第五四分律卷第六(初分之六)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    三十舍堕法之一

尔时佛在舍卫国祇树给孤独园。世尊听诸比丘持三衣不得长。时六群比丘畜长衣。或早起衣或中时衣。或晡时衣。彼常经营庄严如是衣服藏举。诸比丘见已语六群比丘言。佛听持三衣不得长。此是谁衣。答曰。是我等长衣。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。如来听持三衣。汝等云何畜长衣。早起衣中时衣晡时衣。诸比丘即往至世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。以无数方便呵责六群比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何六群比丘。如来听持三衣。汝等畜长衣。以无数方便呵责已。告诸比丘。六群比丘痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘畜长衣者尼萨耆波逸提。如是世尊与比丘结戒。时阿难从人得一贵价粪扫衣欲以奉大迦叶。大迦叶常头陀着此衣故。迦叶不在。阿难作是念。世尊与诸比丘结戒。若比丘畜长衣者尼萨耆波逸提。我今得此贵价粪扫衣欲以奉大迦叶。大迦叶常头陀着此衣而不在。不知云何。即往至佛所。头面礼足在一面立。白佛言。世尊。与诸比丘结戒。若比丘畜长衣尼萨耆波逸提。我今得一贵价粪扫衣欲以奉上大迦叶。大迦叶常头陀着粪扫衣。佛问阿难。迦叶何时当还。阿难白佛言。却后十日当还。世尊以此因缘集比丘僧。与诸比丘随顺说法。无数方便说少欲知足行头陀乐出离法已。告诸比丘。自今已去听畜长衣齐十日。欲说戒者当如是说。若比丘衣已竟迦絺那衣已出畜长衣经十日不净施得畜。若过十日尼萨耆波逸提。比丘义如上。衣竟者三衣迦絺那衣已出。衣者有十种。絁衣劫贝衣钦婆罗衣刍摩衣谶摩衣扇那衣麻衣翅夷罗衣鸠夷罗衣谶罗半尼衣。长衣者若长如来八指若广四指是。若比丘一日得衣畜。二日得衣乃至十日得衣畜。至十一日明相出一切尼萨耆。若比丘一日得衣二日不得三日得衣四日得。如是乃至十日得衣。至十一日明相出。九日中所得衣尽尼萨耆。若比丘一日得衣二日得衣三日不得四日得(如是转降。乃至十日不得衣。作句亦如上)若比丘一日得衣二日三日不得。四日得乃至十日得衣。至十一日明相出。八日中所得衣尽尼萨耆。若比丘一日得衣二日得衣三日四日不得五日得(如是转降。乃至九日十日不得衣。作句亦如上)若比丘一日得衣二日三日四日不得衣五日得衣乃至十日得衣。十一日明相出。七日中所得衣尽尼萨耆。若比丘一日得衣二日得衣三日四日五日不得衣六日得(如是转降。乃至八日九日十日不得衣。作句亦如上)若比丘一日得衣二日三日四日五日不得衣六日得衣乃至十日得衣。十一日明相出。六日中所得衣尽尼萨耆。若比丘一日得衣二日得衣三日四日五日六日不得衣七日得(如是转降。乃至七日八日九日十日不得衣。作句亦如上)若比丘一日得衣二日三日四日五日六日不得衣七日得衣乃至十日得衣。至十一日明相出。五日中所得衣尽尼萨耆。若比丘一日得衣二日得衣三日四日五日六日七日不得衣八日得衣。(如是转降。乃至六日七日八日九日十日不得衣。作句亦如上)若比丘一日得衣二日三日四日五日六日七日不得衣八日得衣乃至十日得衣。十一日明相出。四日中所得衣尽尼萨耆。若比丘一日得衣二日得衣。三日四日五日六日七日八日不得衣九日得衣。(如是转降。乃至五日六日七日八日九日十日不得衣。作句亦如上)若比丘一日得衣二日三日四日五日六日七日八日不得衣九日十日得衣。三日中所得衣至十一日明相出尽尼萨耆。若比丘一日得衣二日得衣。三日四日五日六日七日八日九日不得衣十日得衣(如是转降。乃至四日五日六日七日八日九日十日不得衣。作句亦如上)若比丘一日得衣二日三日四日五日六日七日八日九日不得衣十日得衣。十一日明相出。二日中所得衣尽尼萨耆。若比丘一日得衣。二日得衣。三日四日五日六日七日八日九日十日不得衣(如是转降。乃至三日四日五日六日七日八日九日十日不得衣。作句亦如上)若比丘一日得衣二日三日四日五日六日七日八日九日十日不得衣。十一日明相出。一日中所得衣尽尼萨耆。若比丘一日得衣不净施二日得衣净施。三日得衣乃至十日得衣不净施。至十一日明相出九日中所得衣尽尼萨耆。若比丘一日得衣二日得衣不净施。三日得衣净施。四日得衣不净施(如是转降。乃至十日。得衣净施不净施。作句亦如上)如是若遣与人(句亦如上)若失衣(句亦如上)若故坏(句亦如上)若作非衣(句亦如上)若作亲友意取(句亦如上)若忘去(句亦如上)尽尼萨耆。若犯舍堕衣不舍持更贸余衣。一尼萨耆波逸提一突吉罗。此舍堕衣应舍与僧。若众多人若一人。不得别众舍。若舍不成舍突吉罗。舍与僧时。往僧中偏露右肩脱革屣向上座礼。胡跪合掌当作是语。大德僧听。我某甲比丘故畜尔所长衣过十日犯舍堕。我今舍与僧。彼舍衣竟当忏悔。受忏悔人当作白然后受忏如是白。大德僧听。此某甲比丘故畜尔所长衣犯舍堕。今舍与僧。若僧时到僧忍听。我受某甲比丘忏悔。白如是。作此白已。然后受忏悔。当语彼人言。自责汝心。答言尔。若众僧多难集。此比丘若因缘事欲远行。应问言。汝此衣与谁。随彼说便与僧。即应还此比丘衣。白二羯磨应如是与。僧中当差堪能羯磨人如上说作如是白。大德僧听。某甲比丘故畜尔所长衣犯舍堕。今舍与僧。若僧时到僧忍听。僧持此衣与彼某甲比丘。彼某甲比丘当还此比丘。白如是。大德僧听。此某甲比丘故畜尔所长衣犯舍堕。今舍与僧。僧持此衣与彼某甲比丘。彼某甲比丘当还此比丘。谁诸长老忍。僧持此衣与彼某甲比丘。彼某甲比丘当还此比丘者默然。谁不忍者说。僧已忍。与彼某甲比丘衣竟。僧忍默然故是事如是持。是比丘于僧中舍衣竟不还者突吉罗。若还时有人言莫还者突吉罗。若作净施。若遣与人。若持作三衣。若作波利迦罗衣。若故坏若烧。若作非衣。若数数着坏者。尽突吉罗。比丘尼尼萨耆波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。齐十日内若转净施若遣与人。若贼夺想若失想若烧想若漂想不净施不遣与人不犯。若夺衣失衣烧衣漂衣。取着若他与着若他与作彼不犯。彼受付嘱衣者若命终若远出若休道若为贼强将去。若为恶兽所害若为水漂溺。如此不作净施不遣与人不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(一竟)

尔时佛在舍卫国祇树给孤独园。时六群比丘持衣付嘱亲友比丘往人间游行。受付嘱比丘得此衣数数在日中晒。诸比丘见已便问言。佛听比丘畜三衣不得长。此是谁衣。彼即答言。此六群比丘衣。是我亲友寄我游行人间。恐虫坏故晒耳。诸比丘闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘。汝等云何以衣付嘱亲友比丘离衣人间游行。嫌责已往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何以衣付嘱亲友比丘离衣游行人间。世尊以无数方便呵责已。告诸比丘。六群比丘痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘衣已竟迦絺那衣已舍。三衣中若离一一衣异处宿尼萨耆波逸提。如是世尊与比丘结戒。时有一比丘。有干痟病。有粪扫僧伽梨患重。此比丘有因缘事。欲游行人间不堪持行。自思念言。世尊与比丘结戒。不得离衣宿。离衣宿尼萨耆波逸提。而我今干痟病。有粪扫僧伽梨极重。有因缘事欲往人间行不堪持行。我今当云何。即语同伴比丘。世尊与诸比丘结戒。若比丘三衣已竟迦絺那衣已出。比丘三衣中若离一一衣宿尼萨耆波逸提。而我得干痟病。此衣极重。有因缘事欲人间行不堪持行。我今云何。诸大德为我往白世尊。世尊有所教敕我当奉行。时诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊即集诸比丘僧告言。自今已去听僧与此病比丘结不失衣白二羯磨。应如是与。彼比丘应往至僧中。偏露右臂脱革屣向上座礼。胡跪合掌当作是说。大德僧听。我某甲比丘得干痟病。此粪扫僧伽梨重。有因缘欲人间行不堪持行。我今从僧乞结不失衣法。应如是求。乃至三说僧中当差堪能羯磨人。如上作如是白。大德僧听。某甲比丘得干痟病。有粪扫僧伽梨衣重。有因缘事欲人间行不堪持行。从僧乞结不失衣法。若僧时到僧忍听。与此比丘结不失衣法。白如是。大德僧听。某甲比丘得干痟病。有粪扫僧伽梨衣患重。有因缘事欲人间行不堪持行。今从僧乞结不失衣法。今僧与某甲比丘结不失衣法。谁诸长老忍。僧与某甲比丘结不失衣法者默然。谁不忍者说。僧已忍。与某甲比丘结不失衣法竟。僧忍默然故。是事如是持。自今已去当如是说戒。若比丘衣已竟迦絺那衣已出。三衣中离一一衣异处宿除僧羯磨尼萨耆波逸提。比丘义如上说。衣已竟者三衣也。迦絺那衣已出。三衣者僧伽梨郁多罗僧安陀会。衣者有十种如上说。僧者一说戒一羯磨。不失衣者。僧伽蓝里有一界。失衣者。僧伽蓝里有若干界。不失衣者。树有一界。失衣者。树有若干界。不失衣者。场有一界。失衣者。场有若干界。不失衣者。车有一界。失衣者。车有若干界。不失衣者。船有一界。失衣者。船有若干界。不失衣者。村有一界。失衣者。村有若干界。不失衣者。舍有一界。失衣者。舍有若干界。不失衣者。堂有一界。失衣者。堂有若干界。不失衣者。库藏有一界。失衣者。库藏有若干界。不失衣者。仓有一界。失衣者。仓有若干界。僧伽蓝者。有四种如上。树者。与人等足荫覆跏趺坐。场者。于中治五谷处。车者。若车回转处。船者。若船回转处。村者。有四种如上。堂者。多敞露。库者。储积藏诸车乘辇舆贩卖之物。仓者。储积米谷。僧伽蓝界者。此僧伽蓝界非彼僧伽蓝界。此僧伽蓝界非彼树界。乃至库藏界非彼库藏界亦如是。此树界非彼树界。乃至库藏界僧伽蓝界亦如是。此场界非彼场界。乃至僧伽蓝界树界亦如是。余者作句亦如上。僧伽蓝界者在僧伽蓝边。以中人若用石若塼掷所及处是名界。乃至库藏界亦如是。若比丘置衣。在僧伽蓝内。乃在树下宿。明相未出。若舍衣。若手捉衣。若至掷石所及处。若不舍衣。若不手捉衣。若不至掷石所及处。明相出。随所离衣宿。尼萨耆波逸提。除三衣若离余衣。突吉罗。若比丘留衣。着僧伽蓝内。往场处宿。明相未出。若舍衣。若应手捉衣。若至掷石所及处。若不舍衣。若不手捉衣。若不至掷石所及处。明相出。随所离衣宿。尼萨耆波逸提。乃至库藏宿。一一句亦如是。若比丘留衣树下。往场处宿。乃至库藏僧伽蓝处宿亦如是。不失衣者。若阿兰若处无界。八树中间一树间。七弓。遮摩梨国作弓法。长中肘四肘。若比丘无村阿兰若处。留衣着此八树间。异处宿。明相未出。不舍衣不手捉衣。若不至掷石所及处。明相出。尼萨耆波逸提。除三衣。离余杂衣。突吉罗。此舍堕衣。应舍与僧。若众多人若一人。不得别众舍。若舍不成舍。突吉罗。舍与僧时。当往僧中偏露右臂脱革屣向上座礼。胡跪合掌作如是白。大德僧听。我某甲比丘离衣宿犯舍堕。我今舍与僧。彼舍已当忏悔。受忏人当作白。然后受忏如是白。大德僧听。此某甲比丘离衣宿犯舍堕。今舍与僧。若僧时到僧忍听。我受某甲比丘忏白如是。作此白已。然后受忏当语彼人言。自责汝心。彼答言尔。僧应即还此比丘衣。白二羯磨应如是与。僧中当差堪能羯磨人如上作如是白。大德僧听。某甲比丘离衣宿犯舍堕。今舍与僧。若僧时到僧忍听。持此衣还彼某甲比丘。白如是。大德僧听。此某甲比丘离衣宿犯舍堕。今舍与僧。僧持此衣还彼某甲比丘。谁诸长老忍。僧持此衣还彼某甲比丘者默然。谁不忍者说。僧已忍。与彼某甲比丘衣竟。僧忍默然故。是事如是持。若僧中舍衣竟不还者。突吉罗。还时若有人言莫还者突吉罗。若转作净施。若遣与人。若持作三衣。若作波利迦罗衣。若故坏若烧。若作非衣。若数数着坏者。尽突吉罗。比丘尼。尼萨耆波逸提。式叉摩那沙弥沙弥尼。突吉罗。是谓为犯。不犯者。僧与作羯磨。明相未出。手捉衣。若舍衣。若至掷石所及处。若劫夺想若失想若烧想若漂想若坏想。若水道断路崄难。若贼难若恶兽难。若渠水涨若强力者所执。若系缚或命难或梵行难。若不舍衣不手捉衣不至掷石所及处。不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(二竟)

尔时佛在舍卫国祇树给孤独园。时有比丘。有僧伽梨故烂弊坏。自念言。世尊与比丘结戒。衣已竟迦絺那衣已出。听十日内畜长衣。过者犯尼萨耆波逸提。然我此僧伽梨故烂弊坏。十日中间更不能办。我今当云何。即语同意比丘言。善哉大德。为我白世尊。若世尊有教我当奉行。时诸比丘往至世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊以此因缘集诸比丘告言。自今已去听比丘畜长衣为乃至满足故。时六群比丘闻。世尊听畜长衣为乃至满足故。彼有粪扫衣及余种衣。同者不足。取中粪扫衣浣染四角头点作净。持寄亲友比丘已人间游行。时受寄比丘以其行久不还便出晒之。诸比丘见已问言。世尊制戒听畜三衣不得过。此是谁衣耶。报言。此是六群比丘衣。六群比丘作是言。世尊制戒听畜长衣乃至满足。而彼有粪扫衣及余种衣。同者不足。取中粪扫衣浣染四角头点作净。持寄我往人间行。恐腐坏故为晒之耳。时诸比丘闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘。云何言世尊听畜长衣为乃至满足故。而以同衣不足。取中粪扫衣浣染四角头点作净。寄亲友比丘往人间行。诸比丘即往至世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊以此因缘集诸比丘。呵责六群比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何六群比丘。世尊听比丘畜长衣为满足故。而以同衣不足。取中粪扫衣浣染四角头点作净。寄亲友比丘往人间行。以无数方便呵责已。告诸比丘。此痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘衣已竟迦絺那衣已出。若比丘得非时衣欲须便受。受已疾疾成衣。若足者善。若不足者得畜一月。为满足故。若过畜尼萨耆波逸提。比丘义如上。衣已竟者三衣竟迦絺那衣已出。时者无迦絺那衣自恣后一月。若有迦絺那衣自恣后五月。非时者若过此限。衣者十种衣如上。若十日中同衣足者应裁割。若綖拼若缝作衣。若作净施若遣与人。若不裁割缝作衣若不綖拼不净施不遣与人。十一日明相出。随衣多少尼萨耆波逸提。若同衣不足至十一日。同衣足即十一日应裁割缝作衣若綖拼。若不裁割缝作衣若不綖拼若不净施若不遣与人。至十二日明相出。随衣多少尽尼萨耆波逸提。如是乃至二十九日亦如是。若同衣不足三十日若足若不足。若同衣若不同衣应即日裁割缝作衣若綖拼若净施若遣与人。若不裁割缝作衣若不綖拼若不净施若不遣与人。至三十一日明相出尼萨耆波逸提。此尼萨耆应舍与僧若众多人若一人。不应别众舍若舍不成舍突吉罗。舍与僧时。当往僧中偏露右肩脱革屣向上座礼。右膝着地合掌作如是白。大德僧听。我某甲比丘。有尔所衣过尔所日犯舍堕。我今舍与僧舍已当忏悔。受忏人当作白。大德僧听。此某甲比丘有尔所衣过尔所日犯舍堕。今舍与僧。若僧时到僧忍听。我受某甲比丘忏。白如是。作如是白已。然后受忏当语彼人言。自责汝心。彼答言尔。僧应即还此比丘衣。白二羯磨应如是与。僧中应差堪能羯磨人。如上当作如是白。大德僧听。此某甲比丘有尔所衣过尔所日犯舍堕。今舍与僧。若僧时到僧忍听。持此衣还某甲比丘。白如是。大德僧听。此某甲比丘有尔所衣。过尔所日犯舍堕。今舍与僧。僧今持此衣还此某甲比丘。谁诸长老忍。僧持此衣还此某甲比丘者默然。谁不忍者说。僧已忍。与彼某甲比丘衣竟。僧忍默然故。是事如是持。若僧中舍衣竟不还者突吉罗。还时若有人教言莫还者突吉罗。若不还转作净施若遣与人若持作三衣若作波利迦罗衣若故坏若烧若作非衣若数数着坏者。尽突吉罗。比丘尼尼萨耆波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若十日内同衣足若裁割若綖拼若缝作衣。若同衣不足至十一日。同衣足应裁割若綖拼若缝作衣若净施若遣与人。乃至二十九日亦如是。至三十日若足若不足若同衣若不同衣。即日应裁割若綖拼若缝作衣若净施若遣与人不犯。若夺想若失想烧想漂想不裁割不綖拼不缝作衣不净施不遣与人不犯。若夺衣若失衣若烧衣若漂衣。而取着若他与着若作被不犯。若受寄衣比丘命终。或远行或休道或被贼或为恶兽所害。若为水所漂若不裁割不綖拼不缝作衣不遣与人不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(三竟)

尔时佛在罗阅城迦兰陀竹园中。时有女人名莲华色。其父母嫁与郁禅国人。后遂怀妊彼欲产还父母家。产一女颜貌端正。彼莲华色与其女共在屋内。时莲华色夫与莲华色母私通。时莲华色有婢见之便语莲华色。莲华色闻已内自思惟。咄云何女与母同一夫何用女人身为。即舍抱上女着屋内而去。往至波罗奈城住城门外立。身蒙尘土涂跣足破。时城中有长者其妇命终。乘车将从出波罗奈城至园游看。见此莲华色在门外立。颜貌端正而身蒙尘土涂跣破足。便系意在彼。即至女前问言。汝属谁。莲华色报言。我无所属。长者复问。若无所属能为我作妇不。答言可尔。即呼上车同载而归为妇。后于异时莲华色夫大集财宝。从波罗奈往至郁禅国治生。时值彼国童女节会戏笑之日。莲华色所生女着好服饰亦在其中。此女端正长者见之即系念在心。便问傍人。此是谁女。报言。此某甲女。复问住何处。答言在某处。复问在何街巷。答言在某街巷。长者复问。其家门户何向。答向某处。即往其家问其父言。此是汝女耶。答曰。是我女。复问能嫁与我不。报曰可尔。长者问索几许物耶。其父报言。与我百千两金即便与之。其父便庄严其女。从郁禅国还至波罗奈。时莲华色遥见。便作所生女想视之。此女见莲华色亦作其母意视之。遂久狎习。莲华色与女梳头。问言。汝是何国人谁家女耶。答言。我是郁禅国人。复问家在何处在何里巷门为那向父为是谁。其女报言。我家在某处里巷某处门向某处父名某甲。复问。汝母何姓。女报言。我不识母。但闻人言。母名莲华色。少舍我去。时莲华色心自念言。此即是我女。便自怨责。咄何用女人身为。云何今日母子复共一夫。即舍彼家而去。往至罗阅城迦兰陀竹园。尔时世尊。与无数大众围绕说法。遥见世尊。颜貌端正诸根寂定得上调伏如调龙象如水澄清无有尘秽。见已发欢喜心。至世尊所头面礼足在一面立。时世尊渐为说微妙法。说施说持戒生天之福。呵欲不净赞叹出离。复说四谛苦集尽道具足分别。时莲华色即于座上得法眼净。譬如新净。白叠无有尘垢易以为色。莲华色得法清净亦复如是。见法得法得成果证。前白佛言。愿世尊。听我出家。于佛法中修清净行。佛告阿难言。汝将此莲华色到摩诃波阇波提所令度之。阿难即受佛教。将诣摩诃波阇波提所语言。世尊有教令。汝度此妇人。即度令出家。彼于异时思惟。日进逮得阿罗汉有大神力。时有众多比丘尼在空闲处住。时莲华色比丘尼别在一林中坐思惟。莲华色住处有贼帅常在中住。莲华色比丘尼执持威仪礼节庠序。彼贼见已即生善心。后异时贼帅大得猪肉食啖之。余裹之悬着树枝言。此林中若有沙门婆罗门有大神力者与之持去。而心为莲华色比丘尼。时莲华色比丘尼天耳闻声天眼清净即见以白叠裹猪肉悬着树枝上。夜过已语式叉摩那沙弥尼。汝往彼某处树上。有白叠裹猪肉。取来。即往取来与莲华色比丘尼。莲华色比丘尼敕令煮。至食时自往耆阇崛山上与诸上座比丘食之。时有一比丘着弊故补纳僧伽梨。莲华色比丘尼见已发慈愍心。即问比丘言。大德。何故乃着此弊故僧伽梨耶。答言大姊。此尽法故弊坏耳。莲华色比丘尼着一贵价僧伽梨。语比丘言。大德。我持此衣与大德。大德所著衣可与我不。比丘答言可尔。即脱僧伽梨与比丘尼。彼取比丘弊故衣着之。后于异时。莲华色着此弊衣往世尊所。头面礼足在一面立。世尊知而故问言。汝所著衣何以弊故。莲华色比丘尼即以因缘具白世尊。世尊告言。汝不应如是。莲华色。听汝畜持五衣完坚者。余衣随意净施若与人。何以故。妇人着上衣服犹尚不好。何况弊衣。世尊以此因缘集比丘僧。知而故问彼比丘言。汝实从莲华色比丘尼取衣耶。答曰。实尔世尊。以无数方便呵责彼比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何从比丘尼取衣。呵责已告诸比丘言。此痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘从比丘尼取衣者尼萨耆波逸提。如是世尊与比丘结戒已。诸比丘皆畏慎。不敢从亲里比丘尼取衣。佛言。自今已去听诸比丘从亲里比丘尼取衣。何以故。若非亲里亦不筹量。不能知可取不可取。若好若恶若故若新。若是亲里筹量知有无可取不可取若好若恶若新若故。自今已去当如是结戒。若比丘从非亲里比丘尼取衣者尼萨耆波逸提。如是世尊与比丘结戒。时祇洹中二部僧得施衣共分。时比丘尼衣比丘错得。比丘衣比丘尼错得。时比丘尼持衣至僧伽蓝中语比丘言。我持此衣与大德。大德衣与我。诸比丘报言。佛不听我等取非亲里比丘尼衣。时诸比丘以此因缘具白世尊。世尊告诸比丘。自今已去若贸易衣听。欲说戒者当如是说。若比丘从非亲里比丘尼取衣。除贸易尼萨耆波逸提。比丘义如上。非亲里者非父母亲里乃至七世非亲里也。亲里者父母亲里乃至七世是亲里也。衣者有十种如上。贸易者以衣贸衣。以衣易非衣。或以非衣贸衣。或以若针若筒若刀若綖若小叚物乃至一丸药贸衣。若比丘从非亲里比丘尼取衣。除贸易尼萨耆波逸提。此尼萨耆当舍与僧。若众多人若一人。不得别众舍。若舍不成舍突吉罗。舍与僧时。当往僧中偏露右肩脱革屣向上座礼。胡跪合掌作如是白。大德僧听。我某甲比丘取非亲里比丘尼衣犯舍堕。今舍与僧。舍已当忏悔。前受忏人当作如是白。大德僧听此某甲比丘取非亲里比丘尼衣犯舍堕。今舍与僧。若僧时到僧忍听。我受某甲比丘忏白如是。白已当受忏当语彼人言。自责汝心。彼答言尔。僧应即还此比丘衣。白二羯磨应如是与。僧当差堪能羯磨人如上当作如是白。大德僧听。某甲比丘取非亲里比丘尼衣犯舍堕。今舍与僧。若僧时到僧忍听。还此比丘衣。白如是。大德僧听。此某甲比丘取非亲里比丘尼衣犯舍堕。今舍与僧。僧今持此衣还此某甲比丘谁诸长老忍。僧持此衣还此某甲比丘者默然。谁不忍者说。僧已忍。与彼某甲比丘衣竟。僧忍默然故。是事如是持。若于僧中舍衣竟不肯还者突吉罗。还时若有人教莫还者突吉罗。若转作净施若遣与人。若自作三衣或作波利迦罗衣。若故坏若数数着坏尽突吉罗。比丘尼突吉罗式叉摩那沙弥沙弥尼突吉罗是谓为犯。不犯者从亲里比丘尼边取衣。若贸易为僧为佛图取者无犯。无犯者最初未制戒。痴狂心乱痛恼所缠(四竟)

尔时佛在舍卫国祇树给孤独园。时尊者迦留陀夷颜貌端正。偷兰难陀比丘尼亦复端正。迦留陀夷系意在偷兰难陀。偷兰难陀亦系意在迦留陀夷。时迦留陀夷乞食时至着衣持钵。到偷兰难陀比丘尼所在前露形而坐。比丘尼亦复露形而坐。各各欲心相视。迦留陀夷寻失不净污安陀会。偷兰难陀见已语言。大德。持此衣来我欲为浣。即脱衣与之。偷兰难陀比丘尼得此衣已。即于屏处以爪扴取不净着口中。复以少许着小便道中。后遂有娠。诸比丘尼见已语言。汝无惭愧作不净行。答言大姊。我非无惭愧不犯不净行。诸比丘尼言。汝若不犯不净行何故有娠。诸比丘尼不犯不净行者何不有娠。时偷兰难陀即具说因缘。诸比丘尼闻。中有少欲知足行头陀乐学戒知惭愧者。以此因缘嫌责迦留陀夷。云何尊者。乃与偷兰难陀比丘尼作如是事。时比丘尼白诸比丘。诸比丘往白佛。佛尔时以此因缘集诸比丘。知而故问迦留陀夷。汝审与偷兰难陀比丘尼有如是事不。答言实尔。佛以无数方便呵责迦留陀夷言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何乃与偷兰难陀比丘尼作如是事。呵责已告诸比丘言。此痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘令比丘尼浣故衣若染若打尼萨耆波逸提。如是世尊与比丘结戒。后诸比丘各各有畏慎。不敢令亲里比丘尼浣故衣若染若打。佛言。听诸比丘令亲里比丘尼浣故衣若染若打。自今已去当如是说戒。若比丘令非亲里比丘尼浣故衣若染若打尼萨耆波逸提。比丘义如上。非亲里亦如上说。亲里者亦如上说。故衣者乃至一经身着。衣者。有十种如上。若比丘令非亲里比丘尼浣故衣若染若打三尼萨耆波逸提。语使浣染打。彼浣染不打。二尼萨耆波逸提一突吉罗。语使浣染打。彼浣不染而打。二尼萨耆波逸提一突吉罗。语使浣染打。彼不浣而染打。二尼萨耆波逸提一突吉罗。语使浣染打。彼不浣染打三突吉罗。若比丘使非亲里沙弥尼式叉摩那浣染打故衣突吉罗。若使非亲里比丘尼浣染打新衣突吉罗。此尼萨耆当舍与僧。若众多人若一人。不得别众舍。若舍不成舍突吉罗。舍与僧时应往僧中偏露右肩脱革屣向上座礼。右膝着地合掌如是白。大德僧听。我某甲比丘使非亲里比丘尼浣染打故衣犯舍堕。今舍与僧。舍已当忏悔。前受忏人当作如是白。大德僧听。某甲比丘使非亲里比丘尼浣染打故衣犯舍堕。今舍与僧。若僧时到僧忍听。我受某甲比丘忏。白如是。白已然后受忏。当语彼人言。自责汝心。报言尔。僧应即还此比丘衣。白二羯磨应如是与僧。当差堪能羯磨人如上作如是白。大德僧听。此某甲比丘使非亲里比丘尼浣染打故衣犯舍堕。今舍与僧。若僧时到僧忍听。持此衣还某甲比丘。白如是。大德僧听。此某甲比丘使非亲里比丘尼浣染打故衣犯舍堕。今舍与僧。僧今持此衣还此比丘。谁诸长老忍。僧持此衣还此比丘者默然。谁不忍者说。僧已忍与彼某甲比丘衣竟。僧忍默然故。是事如是持。是比丘僧中舍衣竟不肯还者突吉罗。当还时有人教言莫还者突吉罗。若不还转作净施。若遣与人若复自作三衣。若作波利迦罗衣。若烧若故坏若数数着坏。尽突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。与亲里尼故衣浣染打。若病浣染打。若为僧佛图浣染打。若借他衣浣染打者不犯。不犯者最初未制戒。痴狂心乱痛恼所缠(五竟)

四分律卷第六四分律卷第七(初分之七)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    三十舍堕法之二

尔时佛在舍卫国祇树给孤独园。时舍卫城中有长者。晨朝严驾将从诣园游观已。复回车诣祇洹精舍。置车在祇洹门外。步入见跋难陀释子礼敬问讯在前坐听法。跋难陀释子辩才智慧善能说法。即为长者种种方便说法开化劝令欢喜。彼闻法已即语跋难陀言。欲何所须愿见告语。报言。无所须此便是供养已。长者复言。愿见告语若有所须莫有疑难。跋难陀言。止止不须复说。正使我有所须俱不能见与。长者复言。但见告语。我当随所须给与。时彼长者身着贵价广长白叠衣。跋难陀言。汝所著者可与我我须之。长者报言。明日来至我家中我当相与。跋难陀言。我先语汝。正使所须汝俱不能与我。如今果如我所言。长者报言。我与汝非为不与。但明日来。若与汝此衣。或更有好者相与。我今若即脱此衣与汝者。我不能无衣入舍卫城。跋难陀言。且止且止。我不复须。时长者嗔恚不悦。即脱衣襞叠授与跋难陀语言。我向者语大德。明日来我当与汝此衣或更与好者。而不见信。今使我着一衣入舍卫城。时长者即出只桓精舍乘车着一衣入城。时守门者见已即语长者言。从何所来为谁所劫。长者报言。向者在只桓中被贼劫。时守门者即执持刀杖欲往只桓。长者言。止止不须去。时守门者问言何故。时长者具说因缘。时诸居士闻已皆讥嫌言。沙门释子多求无足无有惭愧。外自称言。我知正法。如是何有正法。云何乃索长者身上衣。檀越虽施无厌而受者应知足。时诸比丘闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责跋难陀释子。汝云何乃从长者索身上如此贵价衣。时诸比丘诣世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时集诸比丘。知而故问跋难陀汝实从长者索身上衣耶。答言实尔。世尊以无数方便呵责跋难陀言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为云何乃从长者索身上衣。呵责已告诸比丘。跋难陀痴人。多种有漏处最初犯戒。自今已去与诸比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘从居士索衣者尼萨耆波逸提。如是世尊与比丘结戒。诸比丘皆畏慎。不敢从亲里居士索衣佛言。听诸比丘从亲里居士索衣不犯。自今已去欲说戒者当如是说。若比丘从非亲里居士索衣者尼萨耆波逸提。如是世尊与诸比丘结戒。时有众多比丘。在拘萨罗国夏安居竟。十五日自恣已。十六日执持衣钵往世尊所。昼日热不可行夜便行。失正道从邪道行。时值贼劫他大得财物还。于邪道相值。贼语比丘言。汝等求觅我来耶。诸比丘答言。我等不为汝等来。我等于拘萨罗国夏安居竟。十五日自恣已。十六日持衣钵欲往见世尊。从彼来。昼日热不可行夜行失道故来此耳。不为汝等来也。彼贼复言。汝等若不相觅何故从此道行岂不欲相害耶。即打比丘次死夺取衣钵。诸比丘露形而去。至只桓在门外立。诸比丘见已语言。汝等露形尼揵子不足入只桓。比丘报言。我等非尼揵子是沙门释子耳。时优波离去彼不远经行。诸比丘往至其所语言。今有众多裸形人在门外立。我等语言。汝是尼犍子勿入只桓精舍彼人报言。我非尼犍子是沙门释子。时诸比丘语优波离言。汝可往看为是何人。时即出门往问。汝是何等人耶。报言。我是沙门释子。复问言。汝等几岁报言我若干岁。复问。汝等何时受戒。报言。我某时。汝师和上是谁。报言师和上某甲。何以故裸形。诸比丘即具说因缘。时优波离还至诸比丘所语言。此非尼揵尽是沙门释子。优波离语诸比丘言。汝等可权借衣着。莫令露形见佛。诸比丘即借衣着已往世尊所。头面礼足在一面坐。时世尊慰劳诸比丘言。汝等身安隐不。住止和合安乐不。不以饮食为苦耶。诸比丘报言。大德。身安隐住止和合安乐不以饮食为苦。我等在拘萨罗国夏安居讫。自恣已摄持衣钵欲来问讯世尊。昼日热不可行夜行失道遇诸贼劫夺。如上因缘具白世尊。世尊尔时以无数方便呵责诸比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为云何痴人。裸形而行若裸形行突吉罗。若有如是事当以软草若树叶覆形。应往寺边。若先有长衣应取着。若无者诸知友比丘有长衣应取着。若知友无衣应问僧中。有何等衣可分。若有者当与。若无者应问有卧具不。若有者当与。若不与应自开库看。若有褥若地敷若毡若被应摘解取裁作衣以自覆形。出外乞求衣。时诸比丘畏慎不敢持此处物往彼处。佛言。听时诸比丘夺衣失衣烧衣漂衣。畏慎不敢着僧衣。佛言听着。彼得衣已僧衣不还本处。佛言不应尔。若得衣已应还。浣染缝治安着本处。若不安本处如法治。时有比丘。夺衣失衣烧衣漂衣。畏慎不敢从非亲里居士若居士妇乞衣。佛言。若失衣夺衣烧衣漂衣听从非亲里居士若居士妇乞衣。自今已去当如是说戒。若比丘从非亲里居士若居士妇乞衣。除余时尼萨耆波逸提。余时者。若比丘夺衣失衣烧衣漂衣。是谓余时。比丘义如上说。亲里非亲里如上。居士居士妇如上说。衣者有十种如上。若比丘从非亲里居士若居士妇乞衣除余时尼萨耆波逸提。此尼萨耆应舍与僧。若众多人若一人。不得别众舍。若舍不成舍突吉罗。舍与僧时当往僧中偏露右肩脱革屣向上座礼。右膝着地合掌作如是白。大德僧听。我某甲比丘从非亲里居士若居士妇乞衣犯舍堕。今舍与僧。舍已当忏悔。前受忏人作如是白。大德僧听。此某甲比丘。从非亲里居士若居士妇乞衣犯舍堕。今舍与僧。若僧时到僧忍听。我受此比丘忏。白如是。白已然后受忏。当语彼比丘言。自责汝心。彼答言尔。僧即应还此比丘衣。白二羯磨应如是与。僧中应差堪能羯磨人如上当作如是白。大德僧听。此某甲比丘从非亲里居士若居士妇乞衣犯舍堕。今舍与僧。若僧时到僧忍听。持此衣还某甲比丘。白如是。大德僧听。此某甲比丘。从非亲里居士若居士妇乞衣犯舍堕。今舍与僧。僧今持此衣还此某甲比丘。谁诸长老忍。僧持此衣还此比丘者默然。谁不忍者说。僧已忍。与彼某甲比丘衣竟。僧忍默然故是事如是持。于僧中舍衣竟。不还者突吉罗。当还时有人教言莫还突吉罗。若不还转作净施。若遣与人。若自作三衣。若作波利迦罗衣。若故坏。若烧。若数数着坏。尽突吉罗。比丘尼尼萨耆波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若夺衣失衣烧衣漂衣得从非亲里居士若居士妇乞若从亲里居士若居士妇乞。若从同出家人乞或为他乞。他为己乞。或不求而得。不犯。不犯者最初未制戒。痴狂心乱痛恼所缠(六竟)

尔时佛在舍卫国祇树给孤独园。时有众多比丘。遇贼失衣来到只桓精舍。时有优婆塞闻。诸比丘遇贼失衣来至只桓精舍。多持好衣来诣诸比丘所。问言向闻。有诸比丘失衣来。何者是。报言我等是。何故问耶。答言。我等闻诸比丘遇贼失衣来至只桓。故持此衣来。为诸大德须衣随意取。报言止止。便为供养已。我等自有三衣不须也。六群比丘语诸比丘言。诸大德。汝等三衣足者何不取与我等若与余人耶。时诸居士以诸比丘失衣故与衣。而诸比丘三衣具足。取居士衣与六群比丘及与余人。时诸比丘闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责诸比丘言。舍卫居士以诸比丘失衣故施衣。而汝等三衣具足。云何取他衣与六群比丘及与余人。嫌责已。往至世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊以此因缘集诸比丘。知而故问。汝等诸比丘。实三衣具足而取他衣与六群比丘及余人耶。答言。实尔世尊。世尊以无数方便呵责诸比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。舍卫居士以诸比丘失衣故施衣。云何汝等三衣具足而取彼衣与六群比丘及与余人。呵责已告诸比丘。此痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘失衣夺衣烧衣漂衣。若非亲里居士居士妇自恣请多与衣。是比丘当知足受衣。若过者尼萨耆波逸提。比丘义如上。非亲里亲里者如上。居士居士妇者如上说。衣者有十种如上。若失一衣不应取。若失二衣余一衣若二重三重四重应摘作。若僧伽梨若郁多罗僧若安陀会。若三衣都失。彼比丘应知足受衣。知足有二种。在家人知足出家人知足。在家人知足者。随白衣所与衣受之。出家人知足者三衣也。若居士自恣请多与比丘衣。若衣细若薄若不牢。应取作若二重三重四重。当安缘当肩上。应帖障垢腻处。应安钩纽。若有余残。语居士言。此余残衣裁作何等。若檀越言。我不以失衣故与。我曹自与大德耳。彼若欲受者便受。若比丘过知足受衣尼萨耆波逸提。此尼萨耆应舍与僧。若众多人若一人。不得别众舍。若舍不成舍突吉罗。舍时应往僧中偏露右肩脱革屣向上座礼。右膝着地合掌作如是白。大德僧听。我某甲比丘。过知足取衣犯舍堕。今舍与僧。舍已当忏悔。前受忏者。当作如是白。大德僧听。某甲比丘。过知足取衣犯舍堕。今舍与僧。若僧时到。僧忍听。我受某甲比丘忏。白如是。白已然后受忏。当语彼比丘言。自责汝心。彼答言尔。僧即应还此比丘衣。白二羯磨应如是与。僧中当差堪能羯磨人如上作如是白。大德僧听。此某甲比丘。过知足取衣犯舍堕。今舍与僧。若僧时到僧忍听。僧今持此衣还某甲比丘。白如是。大德僧听。此某甲比丘。过知足受衣犯舍堕。今舍与僧。僧今持此衣还此比丘。谁诸长老忍。僧持此衣还此比丘者默然。谁不忍者说。僧已忍。与某甲比丘衣竟。僧忍默然故是事如是持。若僧中舍衣竟。不还者突吉罗。若还时有人教言莫还者突吉罗。若不还转作净施。若遣与人。若自作三衣。若作波利迦罗衣。若故坏若烧。若数数着坏。尽突吉罗。比丘尼尼萨耆波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若知足取。若减知足取。若居士多与衣。若细薄不牢若二重三重四重作衣。安缘帖障垢处。安纽及钩。若有余残衣。语居士言作何等。若居士言。我不以失衣故与。我曹自欲与大德。若欲受者受。不犯。不犯者最初未制戒。痴狂心乱痛恼所缠(七竟)

尔时佛在舍卫国祇树给孤独园。时有一乞食比丘。到时着衣持钵入舍卫城。至居士家乞食。闻居士夫妇共议言。跋难陀释子是我知旧。当持如是衣价买如是衣与彼比丘。乞食已还来至僧伽蓝中。见跋难陀释子语言。未曾有瞿昙汝大福德人。即问言。我有何事言我是福德人。报言。我入城乞食闻居士夫妇共议言。跋难陀释子是我知旧。当持如是衣价买如是衣与。即问言实尔不。比丘报言。实尔。复问言。彼居士家在何处门那向。比丘报言。居士家在某处门向某方。跋难陀即语比丘言。是我知旧檀越常供养我实如汝言。明日晨朝着衣持钵入舍卫城到居士家语言。实欲与我衣耶。报言。我在屏处有此语耳。跋难陀语居士言。若欲与我衣者。当如是广大作新好坚致。中我受持。若不中我受持者何用是为。时彼居士即讥嫌言。沙门释子无有惭愧多求无厌。外自称言。我知正法。而强从人索好衣。如是何有正法。施者虽无厌而受者应知足。乃寻屏处私语耶。时乞食比丘闻。嫌责跋难陀释子。云何如是强从人索好衣。乞食比丘即还出家。至僧伽蓝中。以此因缘向诸比丘说。其中有少欲知足行头陀乐学戒知惭愧者。嫌责跋难陀释子。汝云何如是强从人索好衣。嫌责已往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责跋难陀释子。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何如是强从人索好衣。呵责已告诸比丘。此痴人。多种有漏处最初犯戒。自今已去与诸比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘居士居士妇欲为比丘办衣价持是衣价买如是衣与某甲比丘。是比丘便到居士家言买如是衣与我为好故。若得衣者尼萨耆波逸提。如是世尊与比丘结戒。居士自恣请比丘问言。大德须何等衣。是比丘意疑不答。若居士恣比丘所索应答。居士欲为比丘作贵价衣。是比丘少欲知足不须大价衣。欲须不如者。比丘意疑不敢随意求索。佛言。听诸比丘少欲知足索不如者。自今已去应如是说戒。若比丘居士居士妇为比丘办衣价买如是衣与某甲比丘。是比丘先不受自恣请。到居士家作如是说。善哉居士。为我买如是如是衣与我为好故。若得衣者尼萨耆波逸提。比丘义如上。居士居士妇者如上。衣价者。若钱若金若真珠若琉璃若贝若玉石若璎珞若生像金。衣者有十种如上。求者有二种。一者求价。二者求衣。求价者檀越与作大价衣求乃至增一钱十六分之一分。求衣者语居士言。作如是广长衣乃至增一綖。是比丘先不受自恣请。而往求贵价广大衣。若得衣者尼萨耆波逸提。求而不得突吉罗。此尼萨耆应舍与僧。若众多人若一人。不得别众舍。若舍不成舍突吉罗。舍与僧时应往僧中偏露右肩脱革屣向上座礼。右膝着地合掌作如是白。大德僧听。我某甲比丘。先不受自恣请与衣往求取贵价衣犯舍堕。今舍与僧。舍已当忏悔。前受忏人当作如是白。大德僧听。此某甲比丘。先不受自恣请与衣往求贵价衣犯舍堕。今舍与僧。若僧时到僧忍听。我受某甲比丘忏白如是。白已然后受忏。当语彼比丘言。自责汝心。彼比丘答言尔。僧即应还此比丘衣。白二羯磨应如是与。僧中当差堪能羯磨人如上作如是白。大德僧听。此某甲比丘先不受自恣请与衣往求贵价衣犯舍堕。今舍与僧。若僧时到僧忍听。僧今还此某甲比丘衣。白如是。大德僧听。此某甲比丘先不受自恣请与衣往求贵价衣犯舍堕。今舍与僧。僧今持此衣还此比丘。谁诸长老忍。僧持此衣还此比丘者默然。谁不忍者说。僧已忍。与彼某甲衣竟。僧忍默然故是事如是持。是比丘于僧中舍衣竟不还者突吉罗。当还时有人教言莫还者突吉罗。若不还转作净施。若遣与人。若自作三衣。若作波利迦罗衣。若故坏若烧。若数数着坏。一切突吉罗。比丘尼尼萨耆波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。先受自恣请而往求索。知足减少求。从亲里求。从出家人求。或为他求。他为已求。或不求自得。无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(八竟)

尔时佛在舍卫国祇树给孤独园。时乞食比丘时到着衣持钵入舍卫城乞食。以次行乞到居士家。闻居士夫妇二人共议。跋难陀释子是我等知旧。当买如是衣与。复闻异处居士夫妇二人共议。跋难陀是我等知旧。当买如是衣与。时彼乞食比丘。乞食已还出舍卫城。往到僧伽蓝中。见跋难陀释子语言。尊者大福德人。跋难陀问言。汝以何事称我大福德人。报言。我向者入舍卫城乞食。以次行乞到一居士家闻夫妇二人共议。跋难陀释子是我知旧当买如是衣与。复闻异居士家夫妇共议。跋难陀是我知旧。当买如是衣与。跋难陀问言。为实尔不。报言实尔。复问。居士家在何处门户那向。报言。在某处门户向某方跋难陀语彼比丘言。此诸居士实是我檀越常供养供给我。明日晨朝着衣持钵入舍卫城。到彼二居士家语言。汝等诸人实欲与我作衣耶。居士报言。屏处有如是语。跋难陀释子语言。若欲与我作衣者。可共作一衣与我。极使广大坚致。中我受持。若不中受持非我所须。居士闻之即共讥嫌。跋难陀释子不知厌足无有惭愧。外自称言我知正法。如是贪求不知止足何有正法。施者虽无厌而受者应知足。屏处言语而来求索。时乞食比丘闻之。呵责跋难陀释子。云何强从人索衣。时彼乞食比丘还出城至僧伽蓝中。以此因缘向诸比丘说。诸比丘闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责跋难陀释子。汝云何强从人索衣。呵已往世尊所。头面礼足具白世尊。世尊以此因缘集比丘僧。呵责跋难陀释子。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何强从人索衣。世尊以无数方便呵责已。告诸比丘。此跋难陀痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘二居士居士妇。欲与比丘办衣价。我曹办如是衣价与某甲比丘。是比丘到二居士家作如是言。善哉办如是如是衣价与我共作一衣为好故。若得衣者尼萨耆波逸提。如是世尊与比丘结戒。时居士自恣请比丘问言。欲须何等衣。是比丘有疑不答。若居士自恣请比丘索衣应答。时居士欲为比丘作贵价衣。是比丘少欲知足不须贵价衣。须不如者。比丘有疑不敢随意求索。佛言。听诸比丘少欲知足索不如者。自今已去应如是说戒。若比丘二居士居士妇。与比丘办衣价持如是衣价买如是衣与某甲比丘。是比丘先不受居士自恣请。到二居士家作如是言。善哉居士办如是如是衣价与我共作一衣为好故。若得衣者尼萨耆波逸提。比丘义如上。居士居士妇如上。衣价者如上。衣者有十种如上。求有二种求如上。若比丘先不受自恣请。求得贵价衣广大衣。得衣者尼萨耆波逸提。若往索不得突吉罗。此尼萨耆当舍与僧。若众多人若一人。不得别众舍。若舍不成舍突吉罗。舍时应往僧中偏露右肩脱革屣向上座礼。右膝着地合掌作如是白。大德僧听。我某甲比丘。先不受自恣请往求得贵价衣犯舍堕。今舍与僧。舍已当忏悔。前受忏人当作如是白。大德僧听。此某甲比丘。先不受自恣请往求得贵价衣犯舍堕。今舍与僧。若僧时到僧忍听。我受某甲比丘忏。白如是。作白已当受忏。当语彼比丘言。自责汝心。彼比丘言尔。僧即应还彼比丘衣。白二羯磨应如是白。众中应差堪能羯磨人如上。作如是白。大德僧听。此某甲比丘先不受自恣请往求索得贵价衣犯舍堕。今舍与僧。若僧时到僧忍听。僧还此比丘衣。白如是。大德僧听。此某甲比丘先不受自恣请往求索得贵价衣犯舍堕。今舍与僧。僧今持此衣还此比丘。谁诸长老忍。僧持此衣还此比丘者默然。谁不忍者说。僧已忍。与彼比丘衣竟。僧忍默然故是事如是持。是比丘僧中舍衣竟不还者突吉罗。若有人教言莫还者突吉罗。若作净施。若遣与人。若自作三衣。若作波利迦罗衣。若故坏。如是一切突吉罗。比丘尼尼萨耆波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。前人先受自恣请而往求索。若于贵价好衣中求不如者。从亲里求从出家人求。或为他求。他为己求。或不求自得。无犯。无犯者最初未制戒。痴狂心乱痛恼所缠(九竟)

尔时佛在舍卫国祇树给孤独园。时罗阅城中有一大臣。与跋难陀释子亲友。数数往来。遣使持衣价语言。跋难陀释子是我知旧常所敬重持是衣价买如是衣与。时彼使持衣价至僧伽蓝中。到跋难陀所如是言。善哉汝是大福德人。问言。汝以何事言我福德人。报言。罗阅城中有一大臣。遣我持此衣价来买如是衣与汝。复问实尔不。报言实尔。跋难陀即问言。大臣家在何处门户那向。答言。家在某处门户向某方。跋难陀言。实如汝所言。此是我知旧檀越常供养承事我。时舍卫城中复有一长者。与跋难陀亲旧数数来往。时跋难陀释子即将此使入舍卫城。诣彼长者家语言。罗阅城中有一大臣。遣此使持衣价来与我作衣。愿为掌之。居士即为掌之。大臣于异时问使人言。我前遣使持衣价与跋难陀。作衣竟为与我着不。使人报言不着。大臣更遣使语跋难陀言。我先遣使送衣价与汝。竟不着我衣何用为。今可送来。时跋难陀闻此语已。即疾疾至彼长者家语言。我前所寄衣价。我今须衣可与我作衣。时舍卫城中诸长者集会。先有制。其有不至者罚钱五百。长者报言。此大会法有制。其有不至者罚钱五百。我今暂往赴之。大德小待我赴会还。勿令我输钱五百。跋难陀报言。不得尔。先持衣价与我作衣。时长者持衣价为作衣竟。会坐已罢。时众人以其不到即罚钱五百。时长者讥嫌言。沙门释子乃令众人罚我钱五百。时舍卫城中有诸居士。不信佛法众者尽共讥嫌言。沙门释子不知止足无有惭愧。外自称言我知正法。如是何有正法。乃令居士不赴集会输钱五百。自今已去不应亲近礼拜问讯承事供养。诸比丘闻。中有少欲知足行头陀乐学戒知惭愧者。呵责跋难陀。云何汝乃令众人罚长者钱五百。往至世尊所。头面礼足具白世尊。世尊以此因缘集比丘僧。以无数方便呵责跋难陀言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何跋难陀乃使长者为众人罚钱五百。时世尊以无数方便呵责跋难陀已。告诸比丘。此痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘若王若大臣若婆罗门若居士居士妇。遣使为比丘送衣价。持如是衣价与某甲比丘。彼使人至比丘所语比丘言。大德。今为汝故送是衣价受取。是比丘应语彼使如是言。我不应受此衣价。我若须衣合时清净当受。彼使语比丘言。大德有执事人不须衣比丘应语言有。若僧伽蓝民若优婆塞。此是比丘执事人。常为诸比丘执事。时彼使往至执事人所。与衣价已。还至比丘所作如是言。大德。所示某甲执事人。我已与衣价。大德知时往彼当得衣。须衣比丘当往执事人所若二反三反为作忆念。应语言。我须衣。若二反三反为作忆念。若得衣者善。若不得衣。四反五反六反在前默然立。若四反五反六反在前默然住得衣者善。若不得衣。过是求得衣者。尼萨耆波逸提。若不得衣。从所得衣价处。若自往若遣使往语言。汝先遣使持衣价与某甲比丘。是比丘竟不得。汝还取莫使失此是时。比丘义如上。王者。得自在无所属。大臣者。在王左右。婆罗门者。有生婆罗门。居士者。除王王大臣婆罗门。诸在家者是。居士妇者。亦在家妇人。衣价者如上。衣者。有十种如上。忆念者。若执事人。若在家若在市若在作处。至彼处二反三反语言。我今须衣与我作衣。为作忆念者是。若二反三反为作忆念。得衣者善。若不得衣。四反五反六反往在前默然立。在前立者。彼执事人若在家若在市若作处。至彼前默然立。若执事人问言。汝何缘在此立。比丘报言。汝自知之。若彼人言我不知。若有余人知者。比丘当语言。彼人知之。若比丘作一语破二反默然。作二语破四反默然。作三语破六反默然。若比丘过二三往语索。过六往默然立。若得衣者尼萨耆波逸提。此尼萨耆应舍与僧。若众多人若一人。不得别众舍。若舍不成舍突吉罗。舍与僧时。往僧中偏露右肩脱革屣向上座礼。右膝着地合掌作如是白。大德僧听。我某甲比丘。过三反语索衣过六反默然立。得衣犯舍堕。今舍与僧。舍已当忏悔。受忏者应作如是白。大德僧听。此某甲比丘过三反语索衣过六反默然立。得衣犯舍堕。今舍与僧。若僧时到僧忍听。我受此比丘忏。白如是。白已当受忏。当语彼比丘言。自责汝心。报言尔。僧即当还彼比丘衣。作白二羯磨应如是与。僧中应差堪能羯磨人如上作如是白。大德僧听。此某甲比丘。过三反语索衣过六反默然立。得衣犯舍堕。今舍与僧。若僧时到僧忍听。还此比丘衣。白如是。大德僧听。此某甲比丘。过三反语索衣过六反默然立。得衣犯舍堕。今舍与僧。僧今持此衣还此比丘。谁诸长老忍。僧持此衣还此比丘者默然。谁不忍者说。僧已忍。与彼某甲比丘衣竟。僧忍默然故是事如是持。是比丘于僧中舍衣竟不还者突吉罗。若还时有人教言莫还者突吉罗。若转作净施。若自作三衣。若作波利迦罗衣。若遣与人。若数数着坏。尽突吉罗。比丘尼尼萨耆波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。三反语索得衣。六反默然立得衣。若不得衣。从所得衣价处。若自往若遣使往语言。汝先遣使与某甲比丘衣。是比丘竟不得。可还取莫使失。若彼言。我不须即相布施。是比丘应以时软语方便索衣。若为作波利迦罗故与。以时索。软语索。方便索得者不犯。不犯者最初未制戒。痴狂心乱痛恼所缠(十竟)

尔时佛在旷野国界。时六群比丘作新杂野蚕绵卧具。彼索未成绵。或索已成绵。或索已染未染。或索新者。或索故者。至养蚕家语言。我等须绵。彼报言小待。须蚕熟时来。彼六群比丘在边住待看。彼暴茧时蚕蛹作声。诸居士见尽共讥嫌言。沙门释子无有惭愧害众生命。外自称言。我修正法。如是何有正法。求索蚕茧作新卧具。以如上事呵责诸比丘闻。其中有少欲知足行头陀乐学戒知忏愧者。嫌责六群比丘。云何求索蚕茧作新卧具。如上呵责已往世尊所头面礼足在一面坐。以此因缘具白世尊。世尊以此因缘集诸比丘。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何六群比丘。求索蚕茧作新卧具。呵责已告诸比丘。此痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘杂野蚕绵作新卧具。尼萨耆波逸提。比丘义如上。杂者若毳若劫贝拘遮罗乳叶草。若刍摩若麻若比丘自用杂野蚕绵作新卧具成者尼萨耆波逸提。作而不成突吉罗。若语他人作成者尼萨耆波逸提。作而不成突吉罗。为他作成不成突吉罗。此应舍。是中舍者若以斧。若以斤细。剉斩和泥。若涂壁若涂埵。比丘尼突吉罗式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者若得已成者。若以斧斤剉斩和泥。若涂壁若涂埵无犯。无犯者最初未制戒。痴狂心乱痛恼所缠(十一竟)

尔时佛在毗舍离猕猴江侧住楼阁舍。时毗舍离诸梨车子等多行邪淫。彼作纯黑羺羊毛作毡被体夜行使人不见。时六群比丘见已便效。选取纯黑羺羊毛作毡卧具。时诸梨车见之。皆共语言。大德。我等在于爱欲为淫欲故作黑羊毛毡。汝等作此纯黑羊毛毡何所为耶。尔时诸比丘闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘。何故效诸梨车。作纯黑羺羊毛毡。呵责已往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊以此因缘集诸比丘以无数方便呵责六群比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何六群比丘。效诸梨车作纯黑羺羊毛毡。时世尊无数方便呵责已。告诸比丘。此痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘以新纯黑羺羊毛作新卧具尼萨耆波逸提。比丘义如上。纯黑毛者或生黑或染黑。若比丘自用纯黑羺羊毛作新卧具。成者尼萨耆波逸提。作而不成者突吉罗。教他作成者尼萨耆波逸提。作而不成者突吉罗。为他作成不成突吉罗。此尼萨耆应舍与僧。若众多人若一人。不得别众舍。若舍不成舍突吉罗。舍与僧时。往僧中偏露右肩脱革屣向上座礼。右膝着地合掌作如是白。大德僧听。我某甲比丘。以纯黑羺羊毛作卧具犯舍堕。今舍与僧。舍已当忏悔。前受忏人作如是白。大德僧听。此某甲比丘。以纯黑羺羊毛作卧具犯舍堕。今舍与僧。若僧时到僧忍听。我受某甲比丘忏。白如是。作是白已然后受忏。当语彼比丘言。自责汝心。报言尔。僧即应还彼比丘卧具。作白二羯磨应如是与。僧中应差堪能羯磨人如上作如是白。大德僧听。此某甲比丘。以纯黑羺羊毛作卧具犯舍堕。今舍与僧。若僧时到僧忍听。还彼某甲比丘卧具。白如是。大德僧听。此某甲比丘。以纯黑羺羊毛作卧具犯舍堕。今舍与僧。僧今持此卧具还此比丘。谁诸长老忍。僧持此卧具还此比丘者默然。谁不忍者说。僧已忍还此某甲比丘卧具竟。僧忍默然故是事如是持

是比丘于僧中舍卧具竟不还者突吉罗。还时有人教言莫还。若作净施若遣与人若数数敷坏者尽突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若得已成者。若割截坏若细薄叠作两重。若以作褥。若作枕。若作方小坐具。若作卧毡。或作[打-丁+親]钵毡。或作剃刀囊。或作帽。或作袜。或作摄热巾。或作裹革屣巾。尽不犯。不犯者最初未制戒。痴狂心乱痛恼所缠(十二竟)

四分律卷第七四分律卷第八(初分之八)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    三十舍堕法之三

尔时佛在舍卫国祇树给孤独园。时六群比丘以纯白羊毛作新卧具。诸居士见皆讥嫌言。沙门释子不知惭愧无有厌足。外自称言我修正法。如是何有正法。作新白羊毛卧具似王若王大臣。时诸比丘闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘。云何作此纯白羊毛卧具。诃责已往世尊所头面礼足在一面坐。以此因缘具白世尊。世尊以此因缘集比丘僧。呵责六群比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等乃作此纯白羊毛卧具。时世尊以无数方便呵责六群比丘已。告诸比丘。此痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘作新卧具应用二分纯黑羊毛三分白四分尨。若比丘不用二分黑三分白四分尨作新卧具者尼萨耆波逸提。比丘义如上。白者或生白或染令白。尨色者头上毛耳毛若脚毛若余尨色毛。若比丘欲作四十钵罗羊毛卧具者。二十钵罗纯黑十钵罗白十钵罗尨。欲作三十钵罗卧具者。十五钵罗纯黑十五钵罗半白半尨。若欲作二十钵罗卧具者。十钵罗纯黑五钵罗白五钵罗尨。若比丘不以二分黑三分白四分尨自作新卧具成者尼萨耆波逸提。不成者突吉罗。若使他作成尼萨耆波逸提。不成者突吉罗。若为他作成不成尽突吉罗。此尼萨耆当舍与僧。若众多人若一人。不得别众舍。若舍不成舍突吉罗。舍与僧时。应往僧中偏露右肩脱革屣向上座礼。右膝着地合掌作如是白。大德僧听。我某甲比丘不以二分黑三分白四分尨作新卧具犯舍堕。今舍与僧。舍已当忏悔。前受忏人当作白。大德僧听。此某甲比丘不以二分黑三分白四分尨作新卧具犯舍堕。今舍与僧若僧时到僧忍听。我受此比丘忏。白如是作白已然后受忏。当语彼人言。自责汝心。比丘报言尔。僧即应还彼比丘卧具。白二羯磨应如是与。僧中当差堪能羯磨人如上作如是白。大德僧听。此某甲比丘不以二分黑三分白四分尨作新卧具犯舍堕今舍与僧。若僧时到僧忍听还某甲比丘卧具白如是。大德僧听。此某甲比丘不以二分黑三分白四分尨作新卧具犯舍堕。今舍与僧。僧今持此卧具还此比丘。谁诸长老忍。僧持此卧具还此比丘者默然。谁不忍者说。僧已忍。还此某甲比丘卧具竟。僧忍默然故。是事如是持。是比丘僧中舍卧具竟不还者突吉罗。若有人教言莫还。若转作净施。若遣与人若数数敷坏一切突吉罗。比丘尼突吉罗式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若二分黑三分白四分尨作新卧具。若白不足以尨足之。若作纯尨者。若得已成者。若割截坏。若作坏色。若作枕。若作褥。若作卧毡。若作小方坐具。若作衬钵裹毡。若作剃刀囊。或作袜。或作摄热巾。或作裹革屣巾。一切不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(十三竟)

尔时佛在舍卫国祇树给孤独园。时六群比丘嫌卧具或重或轻。或嫌薄或嫌厚。不舍故卧具更作新者。彼如是常营求卧具藏积众多。时诸比丘闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。云何嫌故卧具。或轻或重或薄或厚。不舍故者而更作新卧具卧具众多。嫌责已往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊以此因缘集比丘僧。无数方便诃责六群比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何六群比丘嫌卧具或轻或重或薄或厚。作新卧具而藏积众多。时世尊以无数方便呵责已。告诸比丘言。此六群比丘痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘作新卧具持至六年若减六年。不舍故更作新卧具尼萨耆波逸提。如是世尊与比丘结戒。时有比丘得干痟病。有粪扫卧具极重。有小因缘欲出人间游行。内自思念。世尊制戒。若比丘作新卧具持至六年若减六年。不舍故卧具更作新者尼萨耆波逸提。我今得干痟病。此卧具重。有小因缘欲人间游行。我当云何。语诸比丘言。大德。我今干痟病。有粪扫卧具极重。有小因缘事须人间游行不堪持行。诸大德与我白世尊。世尊若有教敕我当奉行。诸比丘闻此语已。往世尊所头面礼足在一面坐。以此因缘具白世尊。世尊尔时集诸比丘告言。自今已去听僧与彼比丘作白二羯磨。此比丘当往僧中偏露右肩脱革屣向上座礼。右膝着地合掌作如是白。大德僧听。我某甲比丘得干痟病。有小因缘欲至人间游行。有粪扫卧具极重不堪持行。我今从僧乞作新卧具羯磨如是至三。众中当差堪能羯磨人如上作如是白。大德僧听。此某甲比丘得干痟病。欲人间游行。有粪扫卧具重。今从僧乞作新卧具羯磨。若僧时到僧忍听。僧与此比丘作新卧具羯磨。白如是。大德僧听。此某甲比丘得干痟病。有粪扫卧具重。欲人间游行。今从僧乞更作新卧具羯磨。今僧与彼某甲比丘更作新卧具羯磨。谁诸长老忍。僧与彼某甲比丘更作新卧具者默然。谁不忍者说僧已忍。与某甲比丘更作新卧具羯磨竟。僧忍默然故是事如是持。自今已去当如是说戒。若比丘作新卧具持至六年若减六年。不舍故更作新者除僧羯磨尼萨耆波逸提。比丘义如上。若比丘减六年。不舍故更作新卧具尼萨耆波逸提。作而不成者突吉罗。若使他作成者尼萨耆波逸提不成者突吉罗。为他作成不成突吉罗。此尼萨耆当舍与僧。若众多人若一人不得别众舍若。舍不成舍突吉罗。舍与僧时应往僧中偏露右肩脱革屣向上座礼。右膝着地合掌作如是白。大德僧听。我某甲比丘减六年。不舍故卧具更作新卧具犯舍堕。今舍与僧。舍已当忏悔。前受忏人当作白。大德僧听。此某甲比丘减六年。不舍故卧具更作新卧具犯舍堕。今舍与僧。若僧时到僧忍听。我受此比丘忏。白如是。作此白已然后受忏。当语彼比丘言。自责汝心。比丘报言尔。僧即应还彼比丘卧具。白二羯磨应如是与。僧中应差堪能羯磨人如上。作如是白。大德僧听。此某甲比丘减六年。不舍故卧具更作新者犯舍堕。今舍与僧。若僧时到僧忍听。还此比丘卧具。白如是。大德僧听。此某甲比丘减六年。不舍故卧具更作新者犯舍堕。今舍与僧。僧今持此卧具还此比丘。谁诸长老忍僧。持此卧具还此比丘者默然。谁不忍者说。僧已忍还彼比丘卧具竟。僧忍默然故是事如是持。是比丘于僧中舍卧具竟不还者突吉罗。若有人教莫还者突吉罗。若转作净施。若遣与人若数数敷坏若作非卧具一切突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者僧听及满六年减六年。舍故更作新者若复无者更自作若他作与若得已成者无犯。无犯者最初未制戒。痴狂心乱痛恼所缠(十四竟)

尔时佛在舍卫国祇树给孤独园。时世尊遣人请食。诸佛常法。诸比丘受请后遍行诸房。见故坐具在温室中。或教授堂中。若经行处。若洗脚石上。或在户前埵上。或在杙上。或在龙牙橛上。或在衣架上。或在绳床木床上。或在枕上。或在地敷上。处处狼藉无人收摄。世尊见已作是念。诸比丘嫌坐具或重或轻。或言厚或言薄。不舍故更作新者。坐具众多处处狼藉无人收摄。我今云何令诸比丘用故坐具。复作是念。我当听诸比丘作新坐具。取故者纵广一搩手帖着新者上坏色故。世尊食讫。以此因缘集比丘僧。告言。我向者众僧受请后遍行诸房。见诸故坐具。处处狼藉无人收摄。我见已作是念。诸比丘或言。我坐具重或言轻或言薄或言厚。不舍故坐具更作新者。故者处处狼藉无人收摄。我作是念。云何令诸比丘用故坐具。而复念言。我今听诸比丘作新坐具。当取故者纵广一搩手帖着新者上以坏色故。是故听诸比丘作新坐具。取故者纵广一搩手帖着新者上以坏色故。时六群比丘闻。世尊听比丘作新坐具。当取故者纵广一搩手帖着新者上以坏色故。而作新坐具。不取故者纵广一搩手帖新者上坏色故。诸比丘闻。中有少欲知足行头陀乐学戒。知惭愧者。嫌责六群比丘言。云何世尊。听诸比丘作新坐具。当取故者纵广一搩手帖新者上用坏色故。而汝等作新者不以故者纵广一搩手帖着新者上。嫌责已往世尊所头面作礼在一面坐。以此因缘具白世尊。世尊以此因缘集比丘僧呵责六群比丘。汝所为非。非威仪非沙门法非净行非随顺行所不应为。云何我与比丘制戒。若比丘作新坐具当取故者纵广一搩手帖着新者上用坏色故。云何汝等。作新坐具不取故者纵广一搩手帖新者上。时世尊以无数方便呵责已。告诸比丘。此六群比丘。痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘作新坐具。当取故者纵广一搩手帖着新者上坏色故。若作新坐具不取故者纵广一搩手帖着新者上用坏色故。尼萨耆波逸提。比丘义如上。彼比丘作新坐具。时若故坐具未坏未有穿孔。当取浣染治牵挽令舒裁割取纵广一搩手帖新者上。若帖边若中央坏色故。若比丘不取故者帖新者上用坏色故。而更作新坐具成者尼萨耆波逸提。不成者突吉罗。若令他作成者尼萨耆波逸提。不成者突吉罗。为他作成不成尽突吉罗。此尼萨耆应舍与僧。若众多人若一人。不得别众舍若舍不成舍突吉罗。舍与僧时。应往僧中偏露右肩脱革屣向上座礼。右膝着地合掌作如是白大德僧听。我某甲比丘。作新坐具不以故者帖新者上用坏色故犯舍堕。今舍与僧。舍已当忏悔。前受忏人当作白。大德僧听。此某甲比丘。作新坐具不以故者帖新者上坏色故犯舍堕。今舍与僧若僧时到僧忍听。我受某甲比丘忏。白如是作是白已然后受忏。当语彼比丘言。自责汝心。比丘报言尔。僧即当还彼比丘坐具作白二羯磨与。应如是与。僧当差堪能羯磨人如上作如是白。大德僧听。某甲比丘作新坐具不以故者帖新者上坏色故犯舍堕。今舍与僧。若僧时到僧忍听还此某甲比丘坐具。白如是。大德僧听此某甲比丘作新坐具不以故者帖新者上坏色故犯舍堕今舍与僧。僧今持此坐具还此比丘。谁诸长老忍。僧持此坐具还此比丘者默然谁不忍者说。僧已忍。与彼某甲比丘坐具竟。僧忍默然故是事如是持。若比丘于僧中舍坐具竟。不还者突吉罗。若有人教莫还者突吉罗。若转作净施。若自受。若遣与人。若数数坐坏。一切突吉罗比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者裁取故者帖新者上坏色故。若彼自无得更作新者。若他为作。若得已成者。若纯故者作不犯。不犯者最初未制戒。痴狂心乱痛恼所缠(十五竟)

尔时世尊。在舍卫国祇树给孤独园。时跋难陀释子道路行。多得羊毛贯杖头担在道行。诸居士见嫌责言。沙门释子云何贩卖羊毛。即问言。大德此羊毛卖不。诸比丘闻此语已。其中有少欲知足行头陀乐学戒知惭愧者。嫌责跋难陀言。云何取羊毛贯杖头担在道行耶。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊以此因缘集比丘僧。呵责跋难陀释子。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何自取羊毛担在道行。乃为居士所讥。世尊以无数方便呵责已。告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说若比丘道路行得羊毛若无人持得自持乃至三由旬。若无人持自持过三由旬尼萨耆波逸提。比丘义如上。若比丘在道行。若在住处得羊毛须者应取。若无人持自持至三由旬。若有人持应语彼人言。我今有此物当助我持。乃至彼处比丘于此中间不得助持。若助持突吉罗。若令比丘尼持过三由旬突吉罗。若令式叉摩那沙弥沙弥尼持过三由旬突吉罗。除羊毛若持余物拘遮罗。若乳叶草若刍摩若麻若厕罗婆尼。持过三由旬者突吉罗。若复担余物着杖头行者亦突吉罗。此尼萨耆应舍与僧。若众多人若一人。不得别众舍。若舍不成舍突吉罗。舍与僧时。应往僧中。偏露右肩脱革屣向上座礼。右膝着地合掌作如是白。大德僧听。我某甲比丘担羊毛行过三由旬犯舍堕。今舍与僧。舍已当忏悔。前受忏人当作白。大德僧听。此某甲比丘担羊毛行过三由旬犯舍堕。今舍与僧若僧时到僧忍听。我受某甲比丘忏。白如是。作是白已然后受忏。当语彼比丘言。自责汝心。比丘报言尔。僧即当还彼比丘羊毛。作白二羯磨。应如是与。僧中应差堪能羯磨人如上作如是白。大德僧听。此某甲比丘。担羊毛行过三由旬犯舍堕。今舍与僧。若僧时到僧忍听。还某甲比丘羊毛。白如是。大德僧听。此某甲比丘。担羊毛行过三由旬犯舍堕。今舍与僧。僧今持此羊毛还此比丘。谁诸长老忍。僧持此羊毛还此比丘者默然。谁不忍者说。僧已忍。与某甲比丘羊毛竟。僧忍默然故。是事如是持。若比丘僧中舍竟不还者突吉罗。若复有人教言莫还者突吉罗。若复转作净施。若遣与人。若数数用。一切突吉罗。比丘尼式叉摩那沙弥沙弥尼一切突吉罗。是谓为犯。不犯者若持至三由旬。若减三由旬若有人与持者语使持。乃至某处中间更不助担。使比丘尼式叉摩那沙弥沙弥尼担三由旬。若担毳庄毳绳。若担头毛项上毛脚毛。若作帽。若作摄热巾。若裹革屣。尽无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(十六竟)

尔时佛在释翅瘦迦维罗卫尼拘律园。时六群比丘取羊毛作新坐具。使比丘尼浣染擘。时摩诃波阇波提比丘尼为染。染色污手往至世尊所。头面礼足已在一面立。时世尊知而故问。何故瞿昙弥汝手有染色犹若染师耶。即白佛言。六群比丘欲作新坐具持羊毛来使我等浣染擘。是故污手。即头面礼佛足还所止处。尔时世尊。以此因缘集比丘僧。知而故问六群比丘。汝等实作新坐具使比丘尼浣染擘耶。报言。实尔世尊。世尊以无数方便呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何乃使比丘尼浣染擘羊毛。世尊以无数方便呵责已。告诸比丘。六群比丘。痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘使比丘尼浣染擘羊毛者。尼萨耆波逸提。如是世尊与比丘结戒已。诸比丘各自有疑。不敢使亲里比丘尼浣染擘羊毛。佛言。听亲里者得浣染擘。自今已去与比丘结戒。若比丘使非亲里比丘尼浣染擘羊毛者。尼萨耆波逸提比丘义如上。非亲里及亲里如上。若比丘与非亲里比丘尼羊毛浣染擘者三尼萨耆波逸提。若使浣染擘。彼浣染而不擘者。二尼萨耆波逸提一突吉罗。使浣染擘。彼浣不染而擘。二尼萨耆波逸提一突吉罗。使浣染擘。彼不浣而染擘者。二尼萨耆一突吉罗。使浣染擘。彼不浣染擘者三突吉罗。使非亲里沙弥尼式叉摩那浣染擘者突吉罗。此应舍与僧。若众多人若一人。不得别众舍。若舍不成舍突吉罗。舍时应往僧中偏露右肩脱革屣向上座礼。右膝着地合掌作如是白大德僧听。我某甲比丘使非亲里比丘尼浣染擘羊毛犯舍堕。今舍与僧。舍已当忏悔。前受忏人当作白。大德僧听。此某甲比丘。使非亲里比丘尼浣染擘羊毛犯舍堕。今舍与僧。若僧时到僧忍听我受此某甲比丘忏。白如是。白已然后受忏。当语彼比丘言。自责汝心。比丘报言尔。僧即当还彼。比丘羊毛作白二羯磨。应如是与。僧当差堪能羯磨人如上作如是白。大德僧听。此某甲比丘使非亲里比丘尼浣染擘羊毛犯舍堕今舍与僧。若僧时到僧忍听。还此某甲比丘羊毛。白如是。大德僧听。此某甲比丘。使非亲里比丘尼浣染擘羊毛犯舍堕。今舍与僧。僧今持此羊毛还此比丘。谁诸长老忍。僧持此羊毛还此比丘者默然。谁不忍者说。僧已忍。与彼某甲比丘羊毛竟。僧忍默然故是事如是持。僧中舍羊毛竟不还者突吉罗。若有人教莫还者突吉罗。若转作净施。若遣与人。若数数用。若故坏。一切突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼。尽突吉罗。是谓为犯。不犯者。使亲里比丘尼浣染擘。若为病人浣染擘。若为众僧为佛为塔浣染擘不犯。不犯者最初未制戒。痴狂心乱痛恼所缠(十七竟)

尔时佛在罗阅城耆阇崛山中。时城内有一大臣。与跋难陀亲旧知识。彼于异时大得猪肉。即敕其妇。跋难陀释子是我亲友为其留分。其妇即与留分。时王舍城世人节会日。作众伎乐竟夜不眠。时大臣儿亦在其中竟夜不眠。饥乏问其母言。有残肉不。母报言。肉尽。唯有跋难陀释子肉在。儿即与母钱语言。持此钱更市肉与跋难陀。此肉与我。母即取钱与肉。跋难陀释子晨朝着衣持钵诣大臣家就座而坐。时大臣妇语言。近者大得肉。长者敕我言。跋难陀释子是我知旧。为其留分。我即受敕。为大德留分。我儿以节会日戏。竟夜不眠饥乏来从我索肉。以五钱与我言。更市肉与跋难陀。此肉与我。我即便与之。今有此钱正尔市肉。大德可小留待。跋难陀问言。彼为我故与钱耶。答言尔。若为我故可与我钱不须肉。时即置钱于地与。时跋难陀得此钱已。持寄市肆上而去。诸居士见皆共嫌之。沙门释子贩卖钱财。持钱来置肆上而去。诸比丘闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责跋难陀言。云何自取钱置肆上而去耶。时王及诸大臣集会共作是言。沙门释子得捉金银若钱。沙门释子不舍金银若钱珍宝珠璎生像。尔时座中复有一大臣名曰珠髻。即语诸大臣言。莫作是言。沙门释子得捉金银若钱。不舍珍宝珠璎。何以故。我自从如来闻。沙门释子不得捉金银若钱。沙门释子舍离珍宝珠璎。时珠髻大臣。有威势有能善说。令诸人欢喜信解。即往诣世尊所。头面礼足在一面坐。以此因缘具白世尊。我向所说。于法无有违失耶。佛告大臣。如汝所说。于正法中多有所益。无有违失。何以故。沙门释子不得捉持金银若钱。沙门释子舍离珍宝珠璎。不着饰好。汝今当知。若应捉金银若钱。不离珠璎珍宝。亦应受五欲。若受五欲。非沙门释子法。大臣。汝今当知。若见沙门释子以我为师。而捉金银若钱珍宝。则决定知非沙门释子法。我有如是言。比丘若为作屋故求材木竹草树皮得受。不应自为身受。大臣当知。日月有四患。不明不净不能有所照亦无威神。云何为四。阿修罗烟云尘雾是日月大患。若遇此患者不明不净不能有所照亦无威神。沙门婆罗门亦有四患。不明不净不能有所照亦无威神亦复如是。云何为四。若沙门婆罗门不舍饮酒不舍淫欲不舍手持金银不舍邪命自活。是谓沙门婆罗门四大患。能令沙门婆罗门不明不净不能有所照亦无威神。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责跋难陀已。往世尊所头面作礼在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。以无数方便呵责跋难陀。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何自手持钱。着肆上而去耶。呵责已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘自手捉钱若金银若教人捉若置地。受者尼萨耆波逸提。比丘义如上。钱者上有文像。若比丘自手捉金银若钱。教人捉若置地。受尼萨耆波逸提。此应舍。是中舍者。若彼有信乐守园人若优婆塞。当语言。此是我所不应汝当知之。若彼人取还与比丘者。比丘当为彼人物故受敕净人使掌之。若得净衣钵针筒尼师檀应持贸易受持之。若彼优婆塞取已与比丘净衣钵。若尼师檀若针筒应取持之。若彼取已不还者令余比丘语言。佛有教为净故与汝。应还彼比丘物。若余比丘语不还者当自往语言。佛有教为净故与汝。汝今可与僧与塔与和上与同和上与阿阇梨与同阿阇梨与诸亲旧知识。若还本主。何以故。不欲使失彼信施故。若不语彼人知是看是者突吉罗。比丘尼尼萨耆波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者若语言知是看是。若彼有信乐优婆塞守园人。当语彼人言。此物我所不应汝当知之。若彼人受已还与比丘者。比丘当为彼故受持与净人掌之。后若得净衣钵针筒尼师檀得持贸易持之。若彼人取已与净衣钵若坐具若针筒应取持之若彼人不肯与衣者。余比丘当语其人言。佛有教为净故与汝。应还彼比丘物。若彼人不与。自往语言。佛教比丘作净故与汝。若与僧与塔与和上与同和上与阿阇梨与同阿阇梨与诸亲属知识。若教使与本施主不欲令失彼信施故。如是一切。无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(十八竟)

尔时世尊。在罗阅只耆阇崛山中。时跋难陀往市肆上以钱易钱持去。诸居士见已皆讥嫌言。沙门释子以钱易钱善能卖买。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责跋难陀言。云何持钱易钱持去。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责跋难陀言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何以钱易钱。世尊以无数方便呵责已。告诸比丘。此痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘种种卖买宝物者尼萨耆波逸提。比丘义如上。种种卖买者。以成金易成金。易未成金易已成。未成金易成银易未成银。易已成未成银易钱以未成金易成金。易未成金易已成未成金。易成银易未成银。易已成未成银易钱。以已成未成金易成金易未成金。易已成未成金易成银。易未成银易已成未成银易钱。以成银易金乃至易钱亦如是。以未成银易金乃至易钱亦如是。以已成未成银易金乃至易钱亦如是。以钱易金乃至易钱亦如是。钱者有八种。金钱银钱铁钱铜钱白镴钱铅锡钱木钱胡胶钱。若比丘种种卖买宝物。以成金易成金乃至易钱。尼萨耆波逸提。此应舍。是中舍者。若守园人。若信乐优婆塞。当语彼人言。此物我所不应受汝知之。若彼人受已还与比丘者。比丘当为彼人故受令净人掌之。后若得净衣钵坐具针筒得持贸易持之。若彼人受已与比丘净衣钵坐具针筒当受持之。若彼人受已不与比丘者当令余比丘语言。佛有教为净故与汝。应还彼比丘物。若余比丘语。复不还者。应自往语言。佛有教为净故与汝。汝今可与僧与塔与和上与同和上与阿阇梨与同阿阇梨与亲旧知识。若还本施主。何以故。不欲失他信施故。若比丘不语彼人言看是知是突吉罗。比丘尼尼萨耆波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者若语彼人言看是知是。若有守园人信乐优婆塞语言。此是我所不应汝知之。若彼人受已还与比丘。比丘应为彼人故受令净人掌之。若得净衣钵坐具针筒持贸易受持之。若彼受已与比丘净衣钵坐具针筒受持之。若彼人受已不还比丘。比丘应令余比丘语言。佛有教为净故与汝。汝应还此比丘。若不还自往语言。佛有教为净故与汝。汝应与僧与塔与和上与同和上与阿阇梨与同阿阇梨与亲友知识。若还与本施主。何以故。不欲令失信施故。若以钱贸璎珞具为佛法僧。若以璎珞具易钱为佛法僧。无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(十九竟)

尔时世尊。在舍卫国祇树给孤独园。时跋难陀释子。在拘萨罗国道路行。往一无住处村。至村中已持生姜易食。食已去。时舍利弗亦在拘萨罗国人间游行。至无住处村中。到时着衣持钵入村乞食。渐渐至卖饭食家默然住。卖饭人见已问言。大德。何所求欲。报言。居士我须食。彼人言。持价来。报言。居士勿作此言。我等所不应。彼人言。向者跋难陀以生姜易食。食已去。大德何故不应。时舍利弗闻此语已惭愧无言。乞食已还至僧伽蓝中。以此因缘语诸比丘时舍卫城中有一外道得一贵价衣。心自念言。我何用此贵价衣为。我今宁可易余衣。复念言。我当何处贸易衣。唯有沙门释子。喜着好衣彼必能易。即持衣至僧伽蓝中。语诸比丘言。我欲贸易此衣。谁欲易者共易之。跋难陀见已语言。汝明日来。当与汝易衣。跋难陀善能治衣。即其夜浣故衣捣治光泽如新衣。彼外道晨朝持衣至僧伽蓝中。语诸比丘言。谁欲易衣共贸易之。时跋难陀便出衣示语外道言。我以此衣与汝。汝与我衣不。报言与汝。即便共易衣。外道得衣已还所止园中。示诸外道言。当知我已所著衣易得此衣。外道中有智慧者语言。汝为他所欺。何以故。汝所著衣新好广大坚致。此衣是故衣直更捣治光泽似如新耳。此外道即持衣还至僧伽蓝中。语跋难陀言。我还汝衣。汝还我衣。跋难陀言。已共汝贸易竟不得相还。外道言。我衣新好广大坚致。汝衣弊故更捣治光泽如似新耳。跋难陀报言。我贸易已终不相还。彼外道讥嫌言。自是我衣求不可得耶。我衣新好广大坚致。汝衣弊故。云何俱共出家共贸易衣不得还悔。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责跋难陀。云何以生姜易食食。复与外道贸易衣而不听悔。诸比丘往至世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集诸比丘。呵责跋难陀言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何生姜易食食。与外道贸易衣而不听悔。世尊以无数方便呵责已。告诸比丘。自今已去听五众出家人共贸易。应自审定。不应共相高下如市道法。不得与余人贸易。应令净人贸易。若悔听还。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘种种贩卖尼萨耆波逸提。比丘义如上。种种贩卖者以时易时。以时易非时。以时易七日。以时易尽形寿。以时易波利迦罗以非时易非时。以非时易七日。以非时易尽形寿。以非时易波利迦罗衣。以非时易时。以七日易七日以七日易时。乃至非时亦如是。以尽形寿易尽形寿乃至易七日亦如是。以波利迦罗易波利迦罗。乃至尽形寿亦如是。卖者价直一钱数数上下。增卖者。价直一钱言直三钱。重增卖者。价直一钱言直五钱。买亦如是。若比丘种种贩卖得者尼萨耆波逸提。不得者突吉罗。此尼萨耆当舍与僧。若众多人若一人。不得别众舍。若舍不成舍突吉罗。舍时应往僧中偏露右肩脱革屣向上座礼右膝着地合掌作如是白。大德僧听。我某甲比丘。种种贩卖得财物犯舍堕。今舍与僧。舍已当忏悔。前受忏人应作如是白。大德僧听。此某甲比丘种种贩卖得财物犯舍堕。今舍与僧。若僧时到僧忍听。我受某甲比丘忏。白如是。如是白已。然后受忏。当语彼人言。自责汝心。彼比丘报言尔。僧即应还彼比丘物。白二羯磨如是与僧中应差堪能羯磨人作如是白。大德僧听。此某甲比丘种种贩卖犯舍堕。今舍与僧。若僧时到僧忍听。还彼某甲比丘物。白如是。大德僧听。此某甲比丘种种贩卖得财物犯舍堕。今舍与僧。僧今持此物还此比丘。谁诸长老忍僧持此物还此比丘者默然。谁不忍者说。僧已忍。与彼比丘物竟。僧忍默然故是事如是持。若于僧中舍竟不还者突吉罗。若还时有人教言莫还者突吉罗。若转作净施。若遣与人。若故坏。若数数用。若持作余用。一切突吉罗。比丘尼尼萨耆波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者与五众出家人贸易。自审定不相高下如市易法。不与余人贸易。若使净人贸易。若悔者应还。若以酥易油以油易酥。无犯无犯者最初未制戒。痴狂心乱痛恼所缠(二十竟)

四分律卷第八四分律卷第九(初分之九)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    三十舍堕法之四

尔时佛在舍卫国祇树给孤独园。时六群比丘畜钵好者持。不好者置。如是常营觅好钵畜钵遂多。时有诸居士诣房观看。见六群比丘畜多钵。见已皆讥嫌言。沙门释子求欲无厌不知惭愧。外自称言。我知正法。如是何有正法。乃畜尔所多钵如陶师卖瓦肆处。诸比丘闻。其中有少欲知足行头陀。乐学戒知惭愧者。嫌责六群比丘言。云何畜钵好者受持。不好者便置。常营觅好钵畜钵遂多。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责跋难陀言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何畜钵好者受持不好者置。常营觅好钵畜钵遂多。以无数方便呵责已。告诸比丘。跋难陀痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘畜长钵尼萨耆波逸提。如是世尊与比丘结戒。时阿难得苏摩国贵价钵。意欲与大迦叶。以迦叶常畜此国钵故。而迦叶不在。作是念。世尊与比丘结戒。若比丘畜长钵者尼萨耆波逸提我今得苏摩国贵价钵。意欲与大迦叶。然不在。不知云何。时阿难往至世尊所。头面礼足在一面立。白佛言世尊。世尊与比丘结戒。若比丘畜长钵者。尼萨耆波逸提。我今得苏摩国贵价钵。意欲与大迦叶。然不在。不知云何。佛问阿难。大迦叶更几日当还。阿难白佛言。却后十日当还。时世尊以此因缘集比丘僧。随顺说法无数方便赞叹头陀严整少欲知足乐出离者。告诸比丘。自今已去听诸比丘畜长钵至十日。当如是说戒。若比丘畜长钵不净施得齐十日。过者尼萨耆波逸提。比丘义如上。钵者有六种。铁钵苏摩国钵乌伽罗国钵忧伽赊国钵黑钵赤钵。大要有二种铁钵泥钵。大者三斗小者一斗半。此是钵量。如是应持。应作净施。若比丘一日得钵乃至十日得钵。畜至十一日明相出。十日中所得钵尽尼萨耆波逸提。若比丘一日得钵二日不得三日得四日得如是乃至十日得钵至十一日明相出。九日中所得钵尽尼萨耆波逸提。若比丘一日得钵二日得三日不得(如是转降。乃至十日不得钵。作句亦如上)若比丘一日得钵二日三日不得四日得乃至十日得钵至十一日明相出。八日中所得钵尽尼萨耆。若比丘一日得钵二日得钵三日四日不得五日得钵(如是转降。乃至九日十日不得钵。作句亦如上)若比丘一日得钵二日三日四日不得钵五日得钵乃至十日得钵。至十一日明相出七日中所得钵尽尼萨耆。若比丘一日得钵二日得钵三日四日五日不得钵(如是转降。乃至八日九日十日不得钵。作句亦如上)若比丘一日得钵二日三日四日五日不得钵六日得钵乃至十日得钵。十一日明相出。六日中所得钵尽尼萨耆。若比丘一日得钵二日得三日四日五日六日不得钵(如是转降。乃至七日八日九日十日不得钵。作句亦如上)若比丘一日得钵二日三日四日五日六日不得钵七日得钵乃至十日得钵。至十一日明相出。五日中所得钵尽尼萨耆。若比丘一日得钵二日得三日四日五日六日七日不得钵八日得钵(如是转降。乃至六日七日八日九日十日不得钵。作句亦如上)若比丘一日得钵二日三日四日五日六日七日不得钵八日得钵乃至十日得钵。至十一日明相出。四日中所得钵尽尼萨耆。若比丘一日得钵二日得三日四日五日六日七日八日不得钵(如是转降。乃至五日六日七日八日九日十日不得钵。作句亦如是)若比丘一日得钵二日三日四日五日六日七日八日不得钵九日十日得钵。三日中所得钵。至十一日明相出尽尼萨耆。若比丘一日得钵二日得钵三日四日五日六日七日八日九日不得钵(如是转降。乃至四日五日六日七日八日九日十日不得钵。作句亦如上)若比丘一日得钵二日三日四日五日六日七日八日九日不得钵十日得钵。十一日明相出二日中所得钵尽尼萨耆。若比丘一日得钵二日得三日四日五日六日七日八日九日十日不得钵(如是转降。乃至三日四日五日六日七日八日九日十日不得钵。作句亦如上)若比丘一日得钵二日三日四日五日六日七日八日九日十日不得钵。十一日明相出。一日中所得钵尼萨耆。若比丘一日得钵不净施二日得钵净施三日得钵乃至十日得钵不净施。至十一日明相出。九日中所得钵尽尼萨耆。若比丘一日得钵二日得钵不净施三日得钵净施四日得钵不净施(如是转降。乃至十日得钵不净施净施作句亦如上)如是遣与人(句亦如上)若失(句亦如上)若故坏(句亦如上)若作非钵(句亦如上)若作亲友意取(句亦如上)若忘去(句亦如上)尽尼萨耆。若犯尼萨耆钵不舍更贸余钵。一尼萨耆波逸提一突吉罗。此尼萨耆钵当舍与僧。若众多人若一人。不得别众舍。若舍不成舍突吉罗。舍时应往僧中偏露右肩脱革屣向上座礼右膝着地合掌作如是白。大德僧听。我某甲比丘畜长钵过十日犯舍堕。今舍与僧。彼舍已当忏悔前受忏人当作如是白。大德僧听。此某甲比丘畜长钵过十日犯舍堕。今舍与僧。若僧时到僧忍听。我受此某甲比丘忏白如是。如是白已受彼忏。当语彼比丘言。自责汝心。比丘报言尔。僧即应还彼比丘钵白二羯磨。应如是与。众中当差堪能羯磨人如上作如是白。大德僧听。此某甲比丘畜长钵过十日犯舍堕。今舍与僧。若僧时到僧忍听。还此某甲比丘钵白如是。大德僧听。此某甲比丘畜长钵过十日犯舍堕。今舍与僧。僧今还此某甲比丘钵。谁诸长老忍。僧还此某甲比丘钵者默然。谁不忍者说。僧已忍。还此某甲比丘钵竟。僧忍默然故是事如是持。若僧中舍钵竟不还者突吉罗。若有人教言莫还者突吉罗。若转净施。若遣与人。若故坏若作非钵。若数数用。一切突吉罗。比丘尼尼萨耆波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。十日内若净施若遣与人若劫夺想若失想若破想漂想不犯。若夺钵若失钵若烧钵若漂钵。取用若他与用若受寄钵比丘死。若远行若休道若被贼若遇恶兽所害。若为水所漂不遣与人不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(二十一竟)

尔时世尊在舍卫国祇树给孤独园。时跋难陀释子钵破。入舍卫城语居士言。知不。我钵破。汝为我办之。时彼居士即市钵与。复至余居士家言。我钵破汝为我办之。彼诸居士即复市钵与。彼破一钵求众多钵畜。时诸居士于异时共一处集。有一居士语诸居士言。我今获福无量。诸居士问。云何获福无量。答言。尊者跋难陀钵破我买钵与。是故获福无量。诸居士各各自言。我等亦得福无量。余居士问言。汝何因缘得福无量。诸居士答言。跋难陀钵破我等亦市钵与之。诸居士皆讥嫌言。沙门释子。不知惭愧求欲无厌。外自称言。我知正法。如是何有正法。破一钵求众多钵畜。檀越虽施无厌。而受者应知足。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责跋难陀释子言。云何汝破一钵求众多钵畜。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时集诸比丘。呵责跋难陀释子。汝所为非非威仪非沙门法非净行非随顺行。所不应为。云何破一钵而求多钵畜。世尊以无数方便呵责已告诸比丘。此跋难陀痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘畜钵减五缀不漏。更求新钵为好故尼萨耆波逸提。彼比丘应往僧中舍。展转取最下钵与之令持。乃至破应持此是时。比丘义如上。五缀者。相去两指间一缀。若比丘钵破减五缀不漏。更求新钵尼萨耆波逸提。若满五缀不漏。更求新钵者突吉罗。此尼萨耆应舍与僧。是中舍者。于此住处僧中舍。应往僧中偏露右肩脱革屣向上座礼右膝着地合掌作如是白。大德僧听。我某甲比丘。钵破减五缀不漏。更求新钵犯舍堕。今舍与僧。舍已当忏悔。前受忏人当作白。大德僧听。此某甲比丘。钵破减五缀不漏。更求新钵犯舍堕。今舍与僧。若僧时到僧。忍听我受此某甲比丘忏。白如是。如是白已受彼忏。当语彼人言。自责汝心。彼比丘答言尔。此比丘钵若贵价好者。应留置取最下不如者与之。应作白二羯磨。应如是与。僧中当差堪能羯磨人如上作如是白。大德僧听。此某甲比丘。钵破减五缀不漏。更求新钵犯舍堕。今舍与僧。若僧时到僧忍听与此某甲比丘钵。白如是。大德僧听。此某甲比丘。钵破减五缀不漏。更求新钵犯舍堕。今舍与僧。僧今与此某甲比丘钵。谁诸长老忍僧与此某甲比丘钵者默然。谁不忍者说。僧已忍。与此某甲比丘钵竟。僧忍默然故是事如是持彼比丘钵应作白已问僧。作如是白。大德僧听。若僧时到僧忍听。以此钵次第问上座。白如是。作此白已。当持与上座。若上座欲取此钵与之。应取上座钵与次座若与彼比丘。彼比丘应取。不应护众僧故不取亦不应以此因缘受持最下钵若受突吉罗。若第二上座取此钵。应取第二上座钵与第三上座若与彼比丘。彼比丘应受不应护众僧故不受不应以此因缘受最下钵。若受突吉罗。如是展转乃至下座。若持此比丘钵还此比丘。若持最下座钵与。与时应作白二羯磨。应如是与。僧中应差堪能羯磨人如上作如是白。大德僧听。若僧时到僧忍听。僧今以此最下座钵与某甲比丘受持乃至破。白如是。大德僧听。僧今以此最下座钵与某甲比丘受持。乃至破。谁诸长老忍僧与此比丘钵者默然。谁不忍者说。僧已忍。与此比丘钵竟。僧忍默然故是事如是持。彼比丘守护此钵。不得着瓦石落处。不得着倚杖下。及着倚刀下。不得着悬物下。不得着道中。不得着石上。不得着果树下。不得着不平地。比丘不得一手捉两钵。除指隔中央。不得一手捉两钵开户。除用心。不得着户阈内户扉下。不得持钵着绳床木床下。除暂着。不得着绳床木床间。不得着绳床木床角头。除暂着。不得立荡钵乃至足令钵破。彼比丘不应故坏钵不应故令失。若故坏不应作非钵用。僧中舍钵竟不还者突吉罗。若教莫还者突吉罗。若作净施。若遣与人。若故失若故坏若作非钵用。若数数用。一切突吉罗。比丘尼尼萨耆波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。五缀漏。若减五缀漏。更求新钵。若从亲里索。若从出家人索。若为他索。他为己索若不求而得。若施僧钵时当次得。若自有价得买畜。一切不犯。不犯者最初未制戒。痴狂心乱痛恼所缠(二十二竟)

尔时世尊。在舍卫国祇树给孤独园。时跋难陀释子欲缝僧伽梨。入城至诸居士家语言。汝今知不。我欲缝僧伽梨须线。居士即与线复往余居士家语言。我欲缝僧伽梨须线。如是处处乞得线遂多。彼作是念言。我可更余时异处索线缝僧伽梨。比丘衣服难得应办三衣。我今宁可持此线使织师织作三衣。即持线往与织师。彼手自作繀自看织。诸居士见已讥嫌言。汝等观此跋难陀释子。乃手自作繀自看织师织作三衣。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责跋难陀。云何多求线使织师织作三衣。手自作繀自看织师织作耶。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责跋难陀。汝所为非。非威仪非沙门法非净行非随顺行所不应为。云何多求线手自作繀自看织师织作三衣。世尊以无数方便呵责已。告诸比丘。此痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘自乞缕线使非亲里织师织作衣者尼萨耆波逸提。比丘义如上。自乞者。在在处处自乞。缕线者有十种如上十种衣缕线也。织师非亲里。与线者非亲里。非亲里者犯。织师非亲里。与线者或亲里或非亲里。非亲里者犯。织师非亲里。与线者是亲里。非亲里者犯。或织师是亲里或非亲里。与线者非亲里。非亲里者犯。或织师是亲里或非亲里。与线者或亲里或非亲里。非亲里者犯。或织师是亲里或非亲里。与线者是亲里。非亲里者犯。织师是亲里。与线者非亲里。非亲里者犯。织师是亲里。与线者或亲里或非亲里。非亲里者犯。若比丘自乞线使织师织作衣者犯舍堕。若看织若自织若自作繀者尽突吉罗。此尼萨耆应舍与僧。若众多人若一人。不得别众舍若舍不成舍突吉罗。舍时应往僧中偏露右肩脱革屣向上座礼右膝着地合掌作如是白。大德僧听。我某甲比丘自多乞缕线使织师织作衣犯舍堕。今舍与僧舍已忏悔。前受忏人当作如是白。大德僧听。此某甲比丘自多求线使织师织作衣犯舍堕。今舍与僧。若僧时到僧忍听。我受此比丘忏。白如是。白已当受忏应语彼比丘言。自责汝心。比丘答言尔。僧即应还此比丘衣作白二羯磨。应如是与。众中当差堪能羯磨人如上作如是白。大德僧听。此某甲比丘多求线使非亲里织师织作衣犯舍堕。今舍与僧。若僧时到僧忍听。僧今还此比丘衣。白如是。大德僧听。此某甲比丘多求线使非亲里织师织作衣犯舍堕。今舍与僧。僧今还此某甲比丘衣。谁诸长老忍僧还此某甲比丘衣者默然。谁不忍者说僧已忍。还彼某甲比丘衣竟。僧忍默然故是事如是持。僧中舍衣竟不还者突吉罗。若有人教言莫还者突吉罗。若转作净施。若遣与人若自作三衣。若作波利迦罗衣。若坏若烧。若作非衣若数数着。一切突吉罗。比丘尼尼萨耆波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。织师是亲里。与线者是亲里。若自织作钵囊革屣囊针毡。若作禅带若作腰带。若作帽若作[袖-由+未]。若作摄热巾裹革屣巾无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(二十三竟)

尔时世尊。在舍卫国祇树给孤独园。时舍卫城中有一居士。是跋难陀释子亲友知识。出好线令织师织作如是如是衣与跋难陀释子。彼与织师线已往余村。时彼织师。来至僧伽蓝中语跋难陀释子言大德。未曾有是福德人。问言。以何事知我是福德人。答言。某甲居士持此线见与言。跋难陀释子是我亲友知识。为我织作如是如是衣与。以是故知大德是福德人复问实尔不耶。识师报言实尔。跋难陀言若欲与我织衣者。广大极好坚致识使任我受持。若不任我受持者是所不须。织师报言。如大德所说此线少不得成衣。跋难陀语言。汝但织我当更求线足之。时跋难陀晨朝着衣持钵至居士家就座而坐。语居士妇言。居士先持线与织师为我作衣。今线少不足。时居士妇即持线箱置前语言。随意多少取。时跋难陀即恣意择取好者。持往诣织师家语言。我已得尔许线可与我织成衣。织师报言。如大德今所作衣与我价少。跋难陀报言。但与我织我当更与汝价。时织师成衣已即送与居士妇。时居士从他处行还。问其妇言。我前与织师线为跋难陀释子作衣。今者成未耶。其妇报言。所织衣已成今在此。居士言。持衣来看之。即开箱出衣示。居士语妇言。此衣非我先敕织衣。妇报言。此衣即是耶。居士语言。如先所与线教令织作衣此衣非。时妇即具说因缘。居士与妇共披衣看。时跋难陀释子即来至居士家。问居士言。先所与我织作衣此衣是耶。报言是。语言。若是者便可与我。居士即讥嫌言。沙门释子受取无厌不知惭愧。外自称言我知正法。如是何有正法。从人乞衣。施者虽无厌而受者应知足。乃至屏处而不得语。时乞食比丘闻是语已。嫌责跋难陀释子言。云何贪着从他乞衣耶。嫌责已还至僧伽蓝中。以此因缘语诸比丘。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责跋难陀言。云何贪着从他乞衣。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责跋难陀言。汝所为非非威仪非沙门法非净行非随顺行。所不应为。云何贪着从他乞衣。以无数方便呵责已。告诸比丘。此痴人多种有漏处最初犯戒。自今已去与诸比丘结戒。集十句义乃至正法久住。欲说戒者。当如是说若比丘若居士居士妇使织师为比丘织作衣。彼比丘便往其家语织师言。汝知不。此衣为我作。好织令广长坚致。我当多少与汝价。彼比丘与价下至一食直。若得衣尼萨耆波逸提。如是世尊与比丘结戒。时诸居士自恣请与比丘衣。大德须何等衣耶。诸比丘疑不敢答。佛言。若先自恣请与衣应随意答。若居士欲与比丘贵价衣。然比丘少欲知足欲得不如者疑不敢索。佛言。自今已去听少欲知足索不如者随意答。自今已去当如是说戒。若比丘居士居士妇。使织师为比丘织作衣。彼比丘先不受自恣请。便往织师所语言。此衣为我作与我极好织令广大坚致。我当少多与汝价。是比丘与价乃至一食直。若得衣尼萨耆波逸提。比丘义如上。居士居士妇如上。衣者十种衣如上。求者有二种如上。若比丘先不受自恣请便往求衣。若得者尼萨耆波逸提。不得衣者突吉罗。此尼萨耆当舍与僧。若众多人若一人。不得别众舍。若舍不成舍突吉罗。舍时应往僧中偏露右肩脱革屣向上座礼右膝着地合掌作如是白。大德僧听。我某甲比丘。先不受自恣请。便往求得好衣犯舍堕。今舍与僧。舍已当忏悔。前受忏人当作如是白。大德僧听此某甲比丘先不受自恣请便往求得好衣犯舍堕。今舍与僧。若僧时到僧忍听。我受此比丘忏。白如是。作是白已。然后受忏。当语彼人言。自责汝心。彼比丘报言尔。僧即应还彼比丘衣白二羯磨如是与。僧中当差堪能羯磨人如上作如是白。大德僧听。此某甲比丘。先不受自恣请便往求得好衣犯舍堕。今舍与僧。若僧时到僧忍听僧。今还此比丘衣白如是大德僧听。此某甲比丘先不受自恣请便往求得好衣犯舍堕今舍与僧。僧今还此某甲比丘衣。谁诸长老忍僧还此比丘衣者默然。谁不忍者说。僧已忍。还此比丘衣竟。僧忍默然故是事如是持。彼比丘僧中舍衣竟不还者突吉罗。若有人。教言莫还者突吉罗。若转作净施。若遣与人。若自作三衣。若作波利迦罗衣。若故坏若烧。若作非衣。若数数着。一切突吉罗。比丘尼尼萨耆波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者先受自恣请往求知足减少求。若从亲里索。从出家人索。或为他。或他为己。或不索而得者不犯。不犯者最初未制戒。痴狂心乱痛恼所缠(二十四竟)

尔时佛在舍卫国祇树给孤独园。时尊者难陀弟子善能劝化。跋难陀语言。汝今与我共人间行当与汝衣。答言可尔。跋难陀即先与衣。余比丘语言。汝以何事共跋难陀人间行。跋难陀痴人。不知诵戒不知说戒不知布萨不知布萨羯磨。彼比丘即答言。实尔者我不复随行。后余时跋难陀语言。可共人间行。即答言。汝自去。我不能随汝去。跋难陀语言。我先所以与汝衣。欲共人间行。汝今不欲去还我衣来。比丘语言。以见与衣不复相还。时跋难陀嗔恚。即前强夺衣取。比丘高声言。莫尔莫尔。比房诸比丘闻声尽来集聚。问此比丘言。汝何以高声大唤。时比丘以此因缘具向诸比丘说。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责跋难陀言。云何与比丘衣。嗔恚还夺取耶。嫌责已往至世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时集比丘僧。呵责跋难陀。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何嗔恚还夺他衣。以无数方便呵责已。告诸比丘。此痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘先与比丘衣后嗔恚。若自夺若教人夺取还我衣来不与汝。若比丘还衣。彼取衣者尼萨耆波逸提。比丘义如上。衣者十种衣如上。若比丘先与比丘衣。后嗔恚若自夺若教人夺取藏举者尼萨耆波逸提。若夺而不藏举者突吉罗。若着树上墙上篱上橛上龙牙橛上衣架上若绳床木床上若小褥大褥上若枕上若地敷上。若取离处尼萨耆波逸提。取不离处者突吉罗。此尼萨耆应舍与僧。若众多人若一人。不得别众舍。若舍不成舍突吉罗。舍与僧时应往僧中遍露右肩脱革屣向上座礼右膝着地合掌作如是白。大德僧听。我某甲比丘与比丘衣已后嗔恚还夺取犯舍堕。今舍与僧。舍已当忏悔。前受忏人当作如是白。大德僧听。此某甲比丘与比丘衣已后悔嗔恚还夺取犯舍堕。今舍与僧。若僧时到僧忍听。我受此比丘忏。白如是。作是白已然后受忏当语彼人言。自责汝心。比丘答言尔。僧即应还彼比丘衣作白二羯磨。应如是与。众中当差堪能羯磨人如上作如是白。大德僧听。此某甲比丘与比丘衣已后嗔恚还夺取犯舍堕。今舍与僧。若僧时到僧忍听。僧今还此某甲比丘衣。白如是。大德僧听。此某甲比丘与比丘衣已后嗔恚还夺取犯舍堕。今舍与僧。僧今还此某甲比丘衣。谁诸长老忍僧还此某甲比丘衣者默然。谁不忍者说。僧已忍。还此某甲比丘衣竟。僧忍默然故。是事如是事。若僧中舍衣竟不还者突吉罗。若有人教言莫还者突吉罗。若转作净施。若自作三衣。若遣与人。若作波利迦罗衣。若故坏若烧。若作非衣。若数数着。一切突吉罗。比丘尼尼萨耆波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者不嗔恚言。我悔不与汝衣还我衣来。若彼人亦知其人心悔。即还衣。若余人语言此比丘欲悔还他衣。若借他衣着他着无道理还夺取不犯。若恐失衣若恐坏。若彼人破戒破见破威仪。若被举若灭摈若应灭摈。若为此事命难梵行难。如是一切夺取不藏举不犯。不犯者最初未制戒。痴狂心乱痛恼所缠(二十五竟)

四分律卷第九四分律卷第十(初分之十)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    三十舍堕法之五

尔时佛在舍卫国祇树给孤独园。时诸比丘秋月风病动。形体枯燥又生恶疮。世尊在闲静处念言。此诸比丘今秋月风病动。形体枯燥又生恶疮。我今宁可方宜使诸比丘得服众药。当食当药如食饭干饭不令粗现。复作是念。今有五种药世人所识。酥油生酥蜜石蜜。听诸比丘服此五种药。当食当药如食饭干饭不令粗现。时世尊从静室起。以此因缘集比丘僧。告言。我于静室中作是念。今诸比丘秋月风病动。形体枯燥又生恶疮。我今宁可方宜使诸比丘得服众药。当食当药如食饭干饭不令粗现。我作是念。今有五种药世人所识。酥油生酥蜜石蜜。听诸比丘服。当食当药如食饭干饭不令粗现。是故听服五种药。若比丘病因缘时应服。时诸比丘得肥美食。若得肉肉羹不能及时而食。况得此五种药而能及时食。畜药虽多病复不差。形体枯燥又生恶疮。时世尊知而故问阿难。此诸比丘何故形体枯燥又生恶疮。阿难白佛言。此诸病比丘得好肥美食。得肉肉羹不能及时食。况能随时服五种药。畜药虽众多病亦不差。是故形体枯燥又生恶疮。佛告阿难。自今已去听诸比丘时非时有病因缘服此五种药。时诸病比丘得肥美饭食。得肉肉羹不能及时食。尽与看病人。看病人足食已不食便弃之。众乌诤食鸣唤。尔时世尊知而故问阿难。众乌何故鸣唤。阿难白佛言。诸病比丘得肥美饮食。得肉肉羹。不能及时食。尽与看病人。看病人足食已不食便弃之。众乌诤食是故鸣唤。佛告阿难。自今已去听诸病人食残看病人足食不足食自恣食之。时诸比丘朝受小食已入村乞食。足食已还僧伽蓝中。以朝所受食与诸比丘。诸比丘足食已不食便弃之。众乌诤食鸣唤。时世尊知而故问阿难。众乌何故鸣唤。阿难具以上因缘说之。是故众乌鸣唤。佛告阿难。自今已去若受早起小食已。若足食已。听作余食法食。作余食法者。言大德我足食已汝看是知是。是为作余食法。彼应语言。止汝贪心。应作如是余食法食(更有余因缘事。如波逸提余食法中说不异。故不复烦文。故不出也)尔时尊者舍利弗风病动。医教服五种脂。熊脂鱼脂驴脂猪脂摩竭鱼脂。听服此五种脂。时受时煮时漉如服油法时。非时受非时煮非时漉若服者如法治

尔时世尊。从舍卫国游行人间。与大比丘众千二百五十人俱。时世谷贵人民饥馑乞食难得。时有五百乞人随逐世尊后行。时世尊往一树下坐。时有私诃毗罗[口*荼]象师。五百乘车载黑石蜜从彼道来。时象师见道上有如来迹千辐轮现光相具足清净明好。见已寻迹求之。遥见世尊在一树下坐。容颜端正诸根寂定。得上调伏已得自在如调龙象亦如澄渊内外清净。见已发欢喜心。于如来所。前至世尊所。头面礼足在一面坐。时世尊无数方便为象师说微妙法使发欢喜心。时象师闻如来说法发欢喜心已。供养诸比丘人别一器石蜜。诸比丘不敢受之。语言。如来未听比丘受黑石蜜。以此因缘具白世尊。世尊告言。自今已去听诸比丘受黑石蜜。佛语象师。但一器量石蜜与诸比丘。时象师受如来教已。一器量石蜜与诸比丘已。故有遗余。佛语象师。汝更再三随意满足与之。时彼象师受佛教。即再三行之。故有遗余。佛语象师。汝今可持此残石蜜与彼乞儿。即与之。故有遗余。佛复语象师。汝可持此残石蜜再三行与乞儿令满足。即复再三行。故复有遗余。佛语象师。汝今持此残石蜜着净地无虫水中。何以故。我不见诸天魔梵沙门婆罗门及世人食此残石蜜而能消化。唯除如来一人。时象师即持此残石蜜。着净地无虫水中。时水中声响震动烟出火然。犹如烧大热铁着水中声响震烈烟出火燃。以残石蜜泻着水中亦复如是。时象师见此变已身毛皆竖心怀恐怖。往至世尊所头面礼足在一面坐。以向因缘具白世尊。世尊尔时见象师恐怖。即与说微妙法。布施持戒生天之福。呵欲不净赞叹出离。即于座上诸尘垢尽得法眼净。见法得法得果证已。白佛言。自今已去归依佛法僧。唯愿世尊听为优婆塞尽形寿不杀生乃至不饮酒。时象师闻佛说法得欢喜开解已。从座起礼佛足绕三匝而去。时诸比丘入村乞食。见作石蜜以杂物和之。皆有疑不敢非时食。佛告比丘。听非时食作法应尔。得未成石蜜疑。佛言听食。得薄石蜜疑。佛言听食。得浓石蜜佛言听食。得白石蜜听食。得杂水石蜜听饮。得甘蔗浆若未熟听饮。若熟不听饮。若饮如法治。得甘蔗佛言听时食。尔时世尊从摩竭国界人间游行至罗阅城。时毕陵伽婆蹉在此城中住。多有知识亦多徒众。大得供养酥油生酥蜜石蜜与诸弟子。诸弟子得便受之。积聚藏举满大瓮君持。卮中簜中大钵小钵。或络囊中漉水囊中。或着橛上或象牙曲钩上。或窗牖间处处悬举。溢出流漫房舍臭秽。时诸长者来入房看见如是储积众药狼藉。皆讥嫌言。沙门释子不知止足多求无厌。外自称言我知正法。如是何有正法。乃作如是储积诸药。如王瓶沙库藏无异。时诸比丘闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责毕陵伽婆蹉弟子。云何储积众药乃至处处悬举溢出流漫。嫌责已往至世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。无数方便呵责毕陵伽婆蹉弟子言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何多储积众药乃至溢出流漫如王瓶沙库藏无异。世尊以无数方便呵责已。告诸比丘。此痴人。多种有漏处最初犯戒。自今已去与诸比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘有病残药酥油生酥蜜石蜜齐七日得服。若过七日服者尼萨耆波逸提。比丘义如上。病者医教服尔所种药也。药者酥油生酥蜜石蜜。若比丘一日得药畜二日三日四日乃至七日得药畜。八日明相出。七日中所得药尽尼萨耆波逸提。若比丘一日得药二日不得三日得四日得。如是乃至七日得药。至八日明相出。六日中所得药尽尼萨耆。若比丘一日得药二日得三日不得(如是转降。乃至七日不得药。作句亦如是)若比丘一日得药二日三

日不得四日得乃至七日得药。至八日明相出。五日中所得药尽尼萨耆。若比丘一日得药二日得三日四日不得五日得(如是转降。乃至六日七日不得作句亦如是)若比丘一日得药二日三日四日不得五日得药。乃至七日得药。至八日明相出。四日中所得药尽尼萨耆。若比丘一日得药二日得三日四日五日不得(如是转降。乃至五日六日七日不得。作句亦如上)若比丘一日得药二日三日四日五日不得六日七日得。至八日明相出。三日中所得药尽尼萨耆。若比丘一日得药二日得三日四日五日六日不得七日得(如是转降。乃至四日五日六日七日不得。作句亦如是)若比丘一日得药二日三日四日五日六日不得七日得。至八日明相出。二日中所得药尽尼萨耆。若比丘一日得药二日得三日四日五日六日七日不得(如是转降。乃至三日四日五日六日七日不得。作句亦如是)若比丘一日得药二日三日不得。乃至七日不得。至八日明相出。一日中所得药尼萨耆。若比丘一日得药不净施二日得药净施三日得药乃至七日得药不净施。至八日明相出。六日中所得药尽尼萨耆。若比丘一日得药不净施二日得药三日得药净施四日得药不净施(如是转降。乃至七日得药净施不净施。作句亦如上)遣与人(作句亦如上)若失若故坏。若作非药。若作亲友意取。若忘去(作句亦如是)尽尼萨耆。若犯舍堕药不舍更贸易余药。一尼萨耆一突吉罗。此尼萨耆当舍与僧。若众多人若一人。不得别众舍。若舍不成舍突吉罗。舍与僧时应往僧中偏露右肩脱革屣向上座礼右膝着地合掌作如是白。大德僧听。我某甲比丘故畜余药过七日犯舍堕。今舍与僧。舍已应忏悔。前受忏人当作如是白。大德僧听。此某甲比丘故畜余药过七日犯舍堕。今舍与僧。若僧时到僧忍听。我受某甲比丘忏。白如是。白已然后受忏。当语彼人言。自责汝心比丘报言尔。僧即当还彼比丘药。彼比丘所有过七日酥油涂户响。蜜石蜜与守园人。若至第七日所舍与比丘。彼比丘应取食。若减七日应还此比丘。应作白二羯磨如是与。僧中当差堪能羯磨人如上作如是白。大德僧听。此某甲比丘故畜余药犯舍堕今舍与僧。若僧时到僧忍听。还此比丘药。白如是。大德僧听。此某甲比丘故畜余药犯舍堕。今舍与僧。僧今还此比丘药。谁诸长老忍僧还此某甲比丘药者默然。谁不忍者说。僧已忍还此某甲比丘药竟。僧忍默然故。是事如是持。此比丘取已当用涂脚若燃灯僧中舍已不还者突吉罗。若有人教言莫还者突吉罗。若转作净施。若遣与人。若故坏若烧。若作非药。若数数服。一切突吉罗。比丘尼尼萨耆波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者若彼过七日药。若酥油涂户响。若蜜石蜜与守园人。若至七日所舍与比丘食之。若未满七日还彼比丘。彼当用涂脚若燃灯无犯。无犯者最初未制戒。痴狂心乱痛恼所缠(二十六竟)

尔时佛在舍卫国祇树给孤独园。时毗舍佉母请佛及比丘僧明日食。即其夜办具甘膳种种饮食。明日晨朝遣婢往至僧伽蓝中白时到。时天大雨如象尿下。尔时世尊告诸比丘。汝等今日尽出在雨中浴。此最后雨。如今阎浮提雨。当知四天下雨亦如此。时诸比丘闻佛教已。各出屋裸形雨中浴。时彼婢往僧伽蓝门外。遥见诸比丘尽裸形洗浴。见已作是念。无有沙门尽是裸形外道。婢还白毗舍佉母言。大家当知。僧伽蓝中尽是裸形外道。无有沙门。毗舍佉母聪明智慧。即作是念。向者天雨。诸比丘等或脱衣裸形雨中洗浴。婢无知谓为裸形外道。复更敕。速诣僧伽蓝中。白诸比丘今时已到。即往僧伽蓝门外。时诸比丘浴讫着衣还入静室坐思惟。婢在门外立。见僧伽蓝空寂无人。复作是念。今僧伽蓝空无有比丘。即还归语毗舍佉母言。大家当知。僧伽蓝中空无有比丘。时毗舍佉母智慧聪明。即作念言。诸比丘浴讫必入静室思惟。而婢无知谓为僧伽蓝中无有比丘。复重敕之。速往僧伽蓝中。高声白言今时已到。婢即至僧伽蓝中。高声白言今时已到。时世尊从静室出。语彼婢言。汝并前去。我正尔往。世尊语诸比丘。着衣持钵今时已到。诸比丘受世尊教各持衣钵。世尊与大比丘僧千二百五十人俱。譬如力士屈申臂顷。从只桓精舍忽然不现。在毗舍佉母舍就座而坐。衣服不湿及比丘僧悉皆如是。时婢在后晚乃到舍。见世尊及比丘僧先已至舍次第而坐衣服不湿。见已作是念。世尊甚奇甚特有大神力。在我后来而先我至。时毗舍佉母以种种多美饮食。供养佛及比丘僧。食讫舍钵更取卑床在前而坐。白佛言。唯愿世尊。当与我愿。佛告毗舍佉母。如来不与人过愿。毗舍佉母复白佛言。大德。若清净可办愿与我。佛告言随意。毗舍佉母白世尊言。或有诸客比丘从远方来不知所趣。愿世尊听我与客比丘食尽形寿供给。复白世尊言。欲远行比丘或以食故而不及伴。愿世尊听我与远行比丘食尽形寿供养。复白世尊言。诸病比丘若不得随病食便命终。若得随病食便得除差。唯愿世尊听我与病比丘食尽形寿供给。复白世尊言。诸病比丘不得随病药便命终。若得随病药病得差。愿世尊听我与病比丘随病药尽形寿供给。复白世尊言。瞻病比丘自求食故便阙看病。愿世尊听我与看病人食尽形寿供给。复白佛言。世尊听阿那频头国诸比丘食粥。若世尊当听比丘食粥者。我当尽形寿供给。复白世尊言。我晨朝遣婢至僧伽蓝中白时到。诸比丘尽露形雨中浴。愿世尊听我尽形寿供给比丘雨浴衣。复白世尊言。我有小因缘至阿夷罗跋提河边。见诸比丘尼裸形洗浴。时有诸贼女淫女往至比丘尼所语言。汝等年少颜貌端正腋下未有毛及今年壮。何不习爱欲。老乃修习梵行。于二宜无失。其中年少比丘尼便生不乐心。愿世尊听我尽形寿与比丘尼浴衣。尔时佛语毗舍佉母。汝以何利义。故求此八愿耶。毗舍佉母白佛言。若有远来比丘至。白世尊言。有某甲比丘命过为生何处。尔时世尊即为记说。于四道果中必当证成。须陀洹果若斯陀含果若阿那含果若阿罗汉果。我当问言。彼命过比丘曾来至此舍卫国不。若我闻曾来时。我复当作是念。是客比丘或当曾受我客比丘食。若远行比丘食若病比丘食。若受病比丘药若受瞻病人食。若受粥若受雨浴衣。我闻是语已便发欢喜心。既发欢喜心便舍众恶。身恶既除便得身乐。已得身乐心则得定。心既得定便能长夜修习根力觉意。世尊叹言。善哉善哉。毗舍佉母。此事如实。何以故。汝是聪明智慧信乐檀越。时世尊为毗舍佉母而说颂曰

  欢喜施饮食　　持戒佛弟子
  布施于众人　　降伏悭嫉心
  依乐受乐报　　永得安隐乐
  得天上处所　　得无漏圣道
  心乐于福德　　快乐无可喻
  得生于天上　　长寿常安乐

尔时世尊。与毗舍佉母种种方便说法劝令欢喜。即从坐起而去还至僧伽蓝中。以是因缘集比丘僧随顺说法。无数方便赞叹头陀严好乐出离者。告诸比丘言。自今已去听与客比丘食远行比丘食病比丘食病比丘药及瞻病人食。听食粥听受雨浴衣。与比丘尼浴衣。尔时毗舍佉母闻世尊听诸比丘受客比丘食乃至与比丘尼雨浴衣。即便尽形寿供给客比丘食乃至与比丘尼雨浴衣。时毗舍佉母闻世尊听已。即作众多雨浴衣。使人持往至僧伽蓝中。与诸比丘。诸比丘分。佛言不应分随上座次与。若不遍当忆行次。若更得衣以次行令遍。彼持贵价衣随次与。佛言不应尔。应从上座次问。若不须者然后随次与。若不遍应取僧中可分衣与令遍。时六群比丘闻佛听比丘得畜雨浴衣。即一切时春夏冬常求雨浴衣。不舍雨衣便持余用。现有雨衣犹裸形而浴。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘。如来虽听比丘得畜雨浴衣。云何春夏冬常求雨浴衣。不舍雨衣便持余用。现有雨衣犹裸形而浴。时诸比丘呵责已。往世尊所头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何春夏冬常求雨浴衣。以无数方便诃责已。告诸比丘。此痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘。春残一月在。当求雨浴衣半月应用浴。若比丘过一月前求雨浴衣过半月前用浴尼萨耆波逸提。比丘义如上。雨衣者比丘用雨中浴衣者。有十种如上。彼比丘三月十六日应求雨浴衣。四月一日应用。若比丘三月十六日前求雨衣四月一日前用者尼萨耆波逸提。此尼萨耆当舍与僧。若众多人若一人。不得别众舍。若舍不成舍突吉罗。若欲舍与僧时应往僧中偏露右肩脱革屣向上座礼右膝着地合掌作如是白。大德僧听。我某甲比丘过一月前求雨浴衣过半月前用犯舍堕。今舍与僧舍已当忏悔。前受忏人当作如是白。大德僧听。此某甲比丘过一月前求雨浴衣过半月前用犯舍堕。今舍与僧若僧时到僧忍听。我受彼比丘忏。白如是。白已然后受忏。当语彼人言。自责汝心。比丘报言尔。僧即当还彼比丘雨衣作白二羯磨。应如是与。僧中应差堪能羯磨人如上作如是白。大德僧听。此某甲比丘过一月前求雨浴衣过半月前用犯舍堕。今舍与僧。若僧时到僧忍听。还彼某甲比丘雨衣。白如是。大德僧听。此某甲比丘过一月前求雨浴衣过半月前用犯舍堕。今舍与僧。僧今还此某甲比丘雨浴衣。谁诸长老忍僧还彼某甲比丘雨浴衣者默然。谁不忍者说。僧已忍。还此某甲比丘雨浴衣竟。僧忍默然故。是事如是持。僧中舍雨衣竟不还者突吉罗。还时有人教言莫还者突吉罗。若转作净施。若遣与人。若自作三衣。若作波利迦罗衣。若故坏若烧。若数数用。一切突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者三月十六日求四月一日用。若舍雨衣已乃更作余用。若着浴衣浴。若无雨衣。若作浴衣。若浣染。若举处染无犯无犯者最初未制戒。痴狂心乱痛恼所缠(二十七竟)

尔时佛在毗兰若夏安居。佛告阿难。汝往语毗兰若婆罗门。我受汝夏安居讫今欲人间游行。阿难承佛教往至毗兰若婆罗门所。语婆罗门言。如来语汝。我受汝请夏安居讫。今欲人间游行。时毗兰若婆罗门闻世尊如是语。即忆念。我无利无善利。我无得无善得。何以故。我请沙门瞿昙及僧九十日中竟不供养。时毗兰若婆罗门。与阿难俱往世尊所。礼佛足却住一面。时世尊渐与毗兰若婆罗门说微妙法发欢喜心。即白佛言。唯愿世尊及比丘僧。于毗兰若重受我九十日请。佛语婆罗门。我已受汝请夏安居九十日讫。今欲游行人间。婆罗门重白言。愿世尊及僧受我明日请。世尊默然受请。婆罗门见世尊默然受请。即从坐起礼佛足三绕而去。还其家即夜办具种种好食。明日白佛时到。世尊着衣持钵及比丘僧五百人俱往诣其家。到已就座而坐。时婆罗门行种种好食。饭佛及比丘僧悉令满足。食讫各自收钵。婆罗门以三衣施佛。诸比丘各施二衣。为夏安居故。时诸比丘不受衣。即语施主言。世尊未听受夏衣。时诸比丘以此因缘具白世尊。佛告诸比丘。听受夏衣。时六群比丘闻世尊听受夏衣。春夏冬一切时常乞衣。安居未竟亦乞衣亦受衣。时跋难陀释子在一处安居竟。闻异处夏安居比丘大得利养衣。即往彼安居处。问诸人言。所得夏安居衣为分未耶。答言未。持来我与汝分。复更至余处如是非一。皆问言。汝得安居衣分未耶。答言未。持来我与汝分。时跋难陀处处分衣。大得衣分持来入只桓精舍。诸比丘见已。语跋难陀言。世尊听畜三衣。三衣外不听畜长衣。此是谁衣耶。跋难陀答言处处有夏安居得衣。我于彼得是分来。诸比丘闻已。中有少欲知足行头陀乐学戒知惭愧者。呵责六群比丘。跋难陀释子。云何如来听受夏安居衣。何以复春夏冬一切时常乞衣。安居未竟亦乞衣亦受衣耶。跋难陀释子。异处安居异处受衣。时诸比丘往至世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。种种呵责六群比丘跋难陀释子。我听比丘受夏安居衣。汝云何一切时春夏冬常乞衣。安居未竟亦乞衣亦受衣。跋难陀释子异处安居异处受衣耶。时世尊以无数方便呵责六群比丘跋难陀释子已。告诸比丘。不得一切时春夏冬常乞衣。亦不得安居未竟亦乞衣亦受衣。不得异处安居异处受夏衣分。尔时世尊在舍卫国。时波斯匿王境内人民有反叛者。时王遣二大臣。名利师达多富罗那。王敕使征。时二大臣作是念。我等今当征。未知为得还不。我等常众僧夏安居竟为僧设食及施衣。今者安居未竟宁可办食具并诸衣物。如安居法施僧衣耶。诸长者自往僧伽蓝中。白诸比丘如是言。明日欲设饭食并施安居衣。愿各屈意。诸比丘报长者言。但施食不须衣施。何以故。夏安居未竟不得受衣不得乞衣。长者白言。我等今为波斯匿王遣征。我等自念。未知当得还。不欲如先法夏安居讫饭食众僧并施衣。今者亦欲设食并施衣。时诸比丘以是事往白佛。佛言。自今已去听诸比丘受急施衣。诸比丘若知是急施衣应受。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘十日未竟夏三月。诸比丘得急施衣。比丘知是急施衣当受。受已乃至衣时应畜。若过畜者尼萨耆波逸提。比丘义如上急施衣者。若受便得不受便失。衣者有十种如上。衣时者。自恣竟。不受迦絺那衣一月。受迦絺那衣五月。自恣十日在。若比丘得急施衣。知是急施衣应受。受已即十日应畜。到自恣竟。不受迦絺那衣一月。受迦絺那衣五月。若自恣有九日在。比丘得急施衣。比丘知是急施衣应受。受已即九日应畜到自恣竟。不受迦絺那衣一月受迦絺那衣五月。更增一日。若自恣八日在。比丘得急施衣。比丘知是急施衣应受。受已即八日应畜。到自恣竟。不受迦絺那衣一月。受迦絺那衣五月。更增二日。若自恣七日在。比丘得急施衣。比丘知是急施衣应受。受已即七日应畜。到自恣竟不受迦絺那衣一月。受迦絺那衣五月。更增三日若自恣六日在。比丘得急施衣。比丘知是急施衣应受。受已即六日应畜。到自恣竟。不受迦絺那衣一月。受迦絺那衣五月。更增四日。若自恣五日在。比丘得急施衣。比丘知是急施衣应受。受已即五日应畜到自恣竟。不受迦絺那衣一月。受迦絺那衣五月。更增五日若自恣四日在。比丘得急施衣。比丘知是急施衣应受。受已即四日应畜。到自恣竟。不受迦絺那衣一月。受迦絺那衣五月。更增六日。若自恣三日在。比丘得急施衣。比丘知是急施衣应受。受已即三日应畜。到自恣竟。不受迦絺那衣一月。受迦絺那衣五月。更增七日。若自恣二日在比丘得急施衣。比丘知是急施衣应受。受已即二日应畜。到自恣竟。不受迦絺那衣一月。受迦絺那衣五月。更增八日。若明日自恣。比丘得急施衣。比丘知是急施衣应受。受已即今日应畜。到自恣竟。不受迦絺那衣一月。受迦絺那衣五月。更增九日。若比丘得急施衣。若过前过后尼萨耆波逸提。此衣应舍与僧。若众多人若一人。不得别众舍。若舍不成舍突吉罗。若欲舍与僧者。应往僧中偏露右肩脱革屣向上座礼胡跪合掌作如是白。大德僧听。我某甲比丘得急施衣。若过前若过后犯舍堕。今舍与僧。舍已当忏悔。前受忏人。白已然后受忏。作如是白。大德僧听。此某甲比丘得急施衣。若过前若过后犯舍堕。今舍与僧。若僧时到僧忍听。我受某甲比丘忏。白如是。作是白已。然后受忏。受忏者语其人言。当自责汝心。比丘报言尔。僧即当还彼比丘衣白二羯磨与众中当差堪能羯磨人如上作如是白。大德僧听。此某甲比丘得急施衣。过前过后犯舍堕。今舍与僧。若僧时到僧忍听。还此某甲比丘衣。白如是。大德僧听。此某甲比丘得急施衣。过前过后犯舍堕。今舍与僧。僧今还此比丘衣。谁诸长老忍僧还此某甲比丘衣者默然。谁不忍者说。僧已忍还此某甲比丘衣竟。僧忍默然故是事如是持。僧中舍衣竟不还者突吉罗。若教言莫还者突吉罗。若转作净施。若受作三衣及余衣。若遣与人。若数数着。一切突吉罗。比丘尼尼萨耆波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。得急施衣不过前不过后不犯若为贼夺衣。若失衣。若烧衣。若漂衣过前不犯。作夺想失想烧想漂想。有崄难道路不通。多诸贼盗恶兽难。若河水大涨。王者所执系闭命难梵行难。若彼受寄比丘或死或出行。或舍戒或贼劫。或为恶兽所害。或为水漂过后无犯。无犯者。最初未制戒痴狂心乱痛恼所缠(二十八竟)

尔时佛在舍卫国祇树给孤独园。诸比丘夏安居讫。后迦提一月满在阿兰若处住。时多有贼劫夺比丘衣钵坐具针筒什物。兼打扑诸比丘。诸比丘畏贼皆来趣只桓精舍聚住。尔时世尊知而故问阿难。此诸比丘何故来趣只桓精舍聚住耶。阿难白佛言。诸比丘夏安居讫。后迦提一月满在阿兰若处住。为贼劫夺衣钵坐具针筒什物。又打扑诸比丘诸比丘畏怖故皆来趣只桓精舍住。佛告阿难。自今已去听诸比丘在阿兰若有疑多恐惧处住。在如是阿兰若处住比丘欲留衣。三衣中若一一衣得留置舍内。尔时六群比丘闻佛听阿兰若处有疑恐惧处住。在如是处住欲留衣。三衣中若一一衣留置舍内。即便留衣置舍内。嘱亲友比丘已出行。后亲友比丘出衣日中晒。诸比丘见已。自相谓言。世尊制戒。听比丘畜三衣不得长。此是谁衣耶。彼比丘言。六群比丘与我知识亲友。留衣在此出人间游行。是故我等为晒衣。时诸比丘闻已。其中有少欲知足行头陀乐学戒知惭愧者。呵责六群比丘言。云何世尊听诸比丘在阿兰若处有疑恐惧处住。于三衣中留一一衣着舍内。汝等云何今多寄衣知识亲友。人间游行而离衣宿。时诸比丘往至世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊即以此因缘集比丘僧。诃责六群比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何六群比丘。我听诸比丘在阿兰若有疑恐惧处住比丘在如是处住三衣中留一一衣着舍内。汝等云何今多寄衣亲友人间游行离衣宿。尔时世尊以无数方便呵责六群比丘已。告诸比丘。此六群比丘痴人。多种有漏处最初犯戒。自今已去。与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘夏三月竟。后迦提一月满在阿兰若有疑恐惧处住比丘在如是处住。三衣中欲留一一衣置舍内。诸比丘有因缘离衣宿乃至六夜。若过者尼萨耆波逸提。比丘义如上。阿兰若处者去村五百弓。遮摩罗国弓长四肘用中肘量取。有疑处者疑有贼盗。恐怖者中有恐怖贼盗。舍内者村聚也。三衣者僧伽梨。郁多罗僧。安陀会。衣者有十种如上说。若比丘有因缘离衣宿。彼六夜竟第七夜明相未出前。若舍三衣若手捉衣若至掷石所及处。若比丘六夜竟第七夜明相未出前。不舍三衣不手捉衣不至掷石所及处住。第七夜明相出离衣宿一切犯尼萨耆。除三衣已离余衣宿者突吉罗。此尼萨耆当舍与僧。若众多人若一人。不得别众舍。若舍不成舍突吉罗。若欲舍与僧者。应往至僧中偏露右肩。脱革屣右膝着地礼上座足胡跪合掌作如是言。大德僧听。我某甲比丘离衣宿过六夜犯舍堕。今舍与僧。舍已当忏悔。前受忏人白已然后受忏。当作如是白。大德僧听。此某甲比丘离衣宿过六夜犯舍堕。今舍与僧。若僧时到僧忍听。我受某甲比丘忏白如是。如是白已然后受忏。当语彼人言。自责汝心。比丘报言尔。僧即应还彼比丘衣白二羯磨。应如是与。众中当差堪能羯磨人如上作如是白。大德僧听。此某甲比丘离衣宿过六夜犯舍堕。今舍与僧。若僧时到僧忍听。还彼比丘衣。白如是。大德僧听。此某甲比丘离衣宿过六夜犯舍堕。今舍与僧。僧今还彼比丘衣。谁诸长老忍僧还此比丘衣者默然。谁不忍者说。僧已忍还彼比丘衣竟。僧忍默然故是事如是持。若比丘舍衣竟不还彼比丘衣者突吉罗。若教不还者突吉罗。若净施。若遣与人。或受作三衣。若作波利迦罗衣。若数数取着。一切突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者已经六夜第七夜明相未出前到衣所。若舍衣若手捉衣若至掷石所及处不犯。若劫夺想失想漂想烧想不舍衣不手捉衣不至掷石所及处不犯。若船济不通道路崄难。多诸盗贼有恶兽。河水瀑涨强力所执。或为系闭或命难或梵行难。不舍衣不捉衣不至掷石所及处。一切无犯。无犯者最初未制戒。痴狂心乱痛恼所缠(二十九竟)

尔时佛在舍卫国祇树给孤独园。时跋难陀释子先有一居士恒好惠施。意欲饭佛比丘僧兼布施好衣。时跋难陀释子。闻彼居士欲饭佛比丘僧兼施好衣。即往彼居士家。问居士言。实欲饭佛及比丘僧并施好衣耶。居士报言尔。跋难陀释子语居士言。众僧有大善利有大威力有大福德。施众僧者多。汝今食施众僧。衣可施我一人。居士言可尔。尔时长者便不复与僧办具衣。即其夜供办种种多美饮食。明日白僧时到。诸比丘僧着衣持钵往居士家就座而坐。时居士见长老比丘威仪具足。发大声言。我云何为如是严整众僧衣而作留难。时诸比丘问居士言。何故作如是语。时居士以实而答。时众中有少欲知足行头陀乐学戒知惭愧者。呵责跋难陀释子。云何断众僧利而自入己。诸比丘往世尊所头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。无数方便呵责跋难陀释子。汝所为非。非威仪非沙门法非净行非随顺行所不应为。云何断众僧利而自入己耶。尔时世尊无数方便呵责跋难陀释子已。告诸比丘。此痴人。多种有漏处最初犯戒自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘断僧物而自入己者尼萨耆波逸提。如是世尊与比丘结戒。时诸比丘不知是僧物非僧物。为许僧不许僧。后乃知是僧物已许僧。或有作尼萨耆波逸提忏悔。或惭愧。若不知者不犯。自今已去当如是说戒。若比丘知是僧物自求入己者尼萨耆波逸提。比丘义如上。僧物为僧故已与僧。僧物者已许僧。为僧者为僧故作未许僧。已与僧者已许僧已舍与。僧物者衣钵坐具针筒下至饮水器。若比丘知是僧物自求入己者尼萨耆波逸提。若物许僧转与塔者突吉罗。若许塔转与僧者突吉罗。若物许四方僧转与现在僧者突吉罗。若物许现前僧转与四方僧者突吉罗。若物许比丘僧转与比丘尼僧者突吉罗。若许比丘尼僧转与比丘僧者突吉罗。许异处与异处突吉罗。若已许作许想者尼萨耆波逸提。若已许心疑突吉罗。若未许作许想突吉罗。若未许疑突吉罗。此尼萨耆当舍与僧。若众多人若一人。不得别众舍。若舍不成舍突吉罗。若欲舍与僧者。应往僧中偏露右肩右膝着地礼上座胡跪合掌作如是白。大德僧听。我某甲比丘知是物已许僧而自入己犯舍堕。今舍与僧。舍已当忏悔前受忏人白已然后受忏。当作如是白。大德僧听。此某甲比丘知是物已许僧而自入己犯舍堕。今舍与僧。若僧时到僧忍听。我受某甲比丘忏。白如是。白已然后受忏。当语彼人言。自责汝心。彼比丘答言尔。僧即应还彼比丘所舍物。应作白二羯磨与。众中当差堪能羯磨人如上作如是白。大德僧听。此某甲比丘知是物已许僧而自入己犯舍堕。今舍与僧。若僧时到僧忍听。还彼比丘所舍物。白如是。大德僧听。此某甲比丘知是物已许僧求自入己犯舍堕。今舍与僧。僧今还彼比丘所舍物。谁诸长老忍僧还彼比丘所舍物者默然。谁不忍者说。僧已忍。还彼比丘所舍物竟。僧忍默然故是事如是持。若舍与竟不还彼比丘所舍物者突吉罗。若教人莫还者突吉罗。若转作净施。若遣与人若受作三衣。若作波利迦罗衣。若数数用。一切突吉罗。比丘尼尼萨耆波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者若不知。若已许作不许想。若许少劝令与多。若许少人劝与多人。欲许恶劝与好者。或戏笑语。若误语。或独处语。或梦中语。欲说此乃说彼无犯。无犯者最初未制戒。痴狂心乱痛恼所缠(三十竟)

四分律卷第十四分律卷第十一(初分之十一)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    九十单提法之一

尔时佛在释翅瘦迦维罗卫尼拘类园中。尔时释种中有释迦子。字象力。善能谈论。常与外道梵志论议。若不如时便违反前语若僧中问是语时即复违反前语。于众中知而妄语。诸梵志等讥嫌言。沙门释子无有惭愧常作妄语。而自称言。我行正法。如今有何正法。论议不如时便违反前语。于众僧中问时复违反前语。于众中知而妄语。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责象力释子。汝云何与梵志共论议。设不如时便自违反前语。于众僧中问即复违反前语。于众僧中知而妄语耶。时诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责象力比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何象力比丘。与梵志共论议。设不如时便违反前语。于众僧中问即复违反前语。于众中知而妄语耶。尔时世尊。无数方便呵责象力比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘知而妄语者波逸提。比丘义如上。知而妄语者。不见言见不闻言闻。不触言触不知言知。见言不见闻言不闻。触言不触知言不知。见者眼识能见。闻者耳识能闻。触者三识能触。鼻识舌识身识。知者意识能知。不见者。除眼识余五识是。不闻者。除耳识余五识是。不触者。除三识余眼识耳识意识是。不知者。除意识余五识是。若不见不闻不触不知。彼如是言。我见闻触知。知而妄语者波逸提。若不见不闻不触不知。是中见想闻想触想知想。彼便言。我不见不闻不触不知。知而妄语者波逸提。若不见不闻不触不知。意中生疑。彼作是言。我无有疑便言。我见我闻我触我知。知而妄语者波逸提。若不见不闻不触不知。意中有疑。便言。我是中无疑。便言。我不见不闻不触不知。知而妄语者波逸提。若不见不闻不触不知。意中无复疑。便言。我有疑我见我闻我触我知。知而妄语者波逸提。我不见我不闻我不触我不知。意中无疑。便言。我有疑我不见不闻不触不知。知而妄语者波逸提。此应广说。本作是念。我当妄语。妄语时自知是妄语。妄语已知是妄语。故妄语波逸提。本作是念。我当妄语。妄语时自知是妄语。妄语竟不自忆作妄语。故妄语波逸提。本不作是念。我当妄语。妄语时自知是妄语。妄语竟知是妄语。故妄语波逸提。本不作妄语意。妄语时知是妄语。妄语已不忆是妄语。故妄语波逸提。所见异所忍异本所欲异所触异所想异所心异。如此诸事皆是妄语。于大众中知而妄语者波逸提。说而了了者波逸提。说而不了了者突吉罗。说戒时乃至三问忆念罪而不说者突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。不见言不见。不闻言不闻。不触言不触。不知言不知。见言见闻言闻。触言触知言知。意有见想便说者不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(一竟)

尔时佛在舍卫国祇树给孤独园。时六群比丘。断诤事种类骂比丘。比丘惭愧忘失前后不得语。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责六群比丘。云何六群比丘。断诤事种类骂比丘。使惭愧忘失前后。不得语。时诸比丘往世尊所头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何六群比丘。断诤事种类骂比丘。使惭愧忘失前后使不得语。尔时世尊以无数方便呵责六群比丘已告诸比丘。往古世时得刹尸罗国婆罗门有牛。昼夜养飤刮刷摩扪。时得刹尸罗国复有长者。于城市街巷遍自唱言。谁有力牛与我力牛共驾百车货金千两。时婆罗门牛闻唱声自念。此婆罗门昼夜餧飤我刮刷摩扪。我今宜当尽力自竭取彼千两金报此人恩。时彼牛即语婆罗门言。汝今当知。得刹尸罗国中有长者作是唱言。谁有牛与我牛共驾百车货金千两。主今可往至彼长者家语言。我有牛可与汝牛共驾百车货金千两。时婆罗门即往至长者家语言。我有牛可与汝牛共驾百车货金千两。长者报言。今正是时。婆罗门即牵己牛与长者牛共驾百车货金千两。时多人观看。婆罗门于众人前作毁呰语。一角可牵。时牛闻毁呰语。即怀惭愧不肯出力与对诤竞。于是长者牛胜。婆罗门牛不如。输金千两。时婆罗门语彼牛言。我昼夜餧飤摩扪刮刷。望汝当与我尽力胜彼牛。云何今日反更使我输金千两耶。牛语婆罗门言。汝于众人前毁呰我言。一角可牵。使我大惭愧于众人。是故不能复出力与彼竞驾。若能改往言更不名字形相毁我者。便可往语彼长者言。能更与我牛共驾百车者更倍出二千两金。婆罗门语牛言。勿复令我更输二千两金。牛报婆罗门言。汝勿复在众人前毁呰我言一角可牵。于众人前当赞叹我好牵端严好角。时婆罗门至彼长者家语言。能更与我牛共驾百车者货二千两金。长者报言。今正是时。时婆罗门牛与长者牛共驾百车货二千两金。多人共看。时婆罗门于众人前赞叹牛言。好牵端严好角。牛闻此语。即便勇力与彼竞驾。婆罗门牛得胜。长者牛不如。婆罗门得二千两金。尔时佛语诸比丘。凡人欲有所说。当说善语不应说恶语。善语者善。恶语者自热恼。是故诸比丘。畜生得人毁呰犹自惭愧不堪进力。况复于人得他毁辱能不有惭愧耶。此六群比丘痴人。断诤事种类骂诸比丘。使惭愧忘前失后使不得语。尔时世尊以无数方便呵责六群比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘种类毁呰语者波逸提。比丘义如上说。种类毁呰人者。卑姓家生行业亦卑。伎术工巧亦卑。或言汝是犯过人。或言汝多结使人。或言汝盲人。或言汝秃瞎人。卑者旃陀罗种除粪种竹师种车师种。卑姓者。拘凑拘尸婆苏昼迦叶阿提利夜婆罗堕。若本非卑姓习卑伎术即是卑姓。卑业者。贩卖猪羊杀牛放鹰鹞猎人网鱼作贼捕贼者守城知刑狱。卑伎者。锻作木作瓦陶作皮韦作剃发作簸箕作。犯者。波罗夷僧伽婆尸沙波逸提波罗提提舍尼偷兰遮突吉罗恶说。结者。从嗔恚乃至五百结。盲瞎者。盲瞎癵躄跛聋哑及余众患所加。若比丘骂余比丘言。汝生卑贱家汝业卑伎术卑。汝犯汝结使汝秃瞎。如是等若面骂若喻骂若自比骂。面骂者。言汝是旃陀罗家生除粪家生。竹师种车师种。拘凑拘尸婆苏昼迦叶阿提梨夜婆罗堕种。若本非卑姓习卑伎术即是卑姓。汝是贩卖人。杀牛猪羊人。汝是作贼捕贼人。汝是守城知刑狱人。汝是锻作木作瓦陶作皮韦作剃发作人。汝是犯波罗夷僧伽婆尸沙波逸提波罗提提舍尼偷兰遮突吉罗恶说人。汝是从嗔恚结人。乃至五百结人。汝是盲瞎秃躄跛哑聋及众患所加人。喻骂者。汝似旃陀罗种。汝似除粪种。汝似竹师种。汝似车师种。汝似拘凑。汝似拘尸婆苏昼种。汝似迦叶种。汝似阿提梨夜种。汝似婆罗堕种。汝似贩卖猪羊人。汝似杀牛人。汝似放鹰鹞人。汝似网鱼猎人。汝似作贼者捕贼者。汝似守城知刑狱人。汝似锻作人。汝似木作人。汝似瓦陶作人。汝似皮韦作人。汝似剃发人。汝似犯波罗夷人。汝似犯僧伽婆尸沙人。汝似犯波逸提人。汝似犯波罗提提舍尼人。汝似犯偷兰遮人。汝似犯突吉罗人。汝似犯恶说人。汝似结使人。汝似盲瞎人。汝似秃人。汝似躄跛人。汝似哑聋人。自比骂者。我非旃陀罗种。我非除粪种。我非竹师种。我非车师种。我非拘凑拘尸婆苏昼迦叶阿提梨夜婆罗堕贩卖猪羊杀牛人放鹰鹞人网鱼猎人作贼人捕贼守城知刑狱人锻作人木作人竹作人车作人瓦陶作人皮韦作人剃发人。我非犯波罗夷人僧伽婆尸沙人波逸提人波罗提提舍尼偷兰遮突吉罗恶说人。我非结使。我非盲瞎秃跛躄哑聋人。若比丘如上说。种类毁呰者波逸提。若种类毁呰语了了波逸提。不了了者突吉罗。若以说善法而面骂。若喻骂自比骂。说善法者。阿兰若乞食补纳衣乃至坐禅人。说善法面骂者。汝是阿兰若乃至坐禅人。喻骂者。汝似阿练若乃至坐禅人。自比骂者。我非是阿练若。乃至我非坐禅人。若比丘。说善法面骂人喻骂自比骂说而了了者突吉罗。说不了了者亦突吉罗比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。相利故说。为法故说。为律故说为教授故说。为亲友故说。或戏笑故说。或因语次失口说。或在独处说。或于梦中语。或欲说此而误说彼无犯。无犯者最初未制戒。痴狂心乱痛恼所缠(二竟)

尔时佛在舍卫国祇树给孤独园。尔时六群比丘传彼此语。传此屏语向彼说。传彼屏语向此说如是不息。遂至众中未有斗事而生斗事。已有斗事而不灭。诸比丘各作是念。众僧以何因缘本无斗诤而有此诤。已有诤事而不能灭耶。诸比丘自知此六群比丘传彼此语。遂至僧中斗诤。先未有诤事而生诤事。已有诤事而不能灭。时众中有少欲知足行头陀乐学戒知惭愧者。呵责六群比丘言。云何汝等。传彼此语。遂至僧中先未有诤事而生诤事。已有诤事而不能灭诸比丘往至世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊以此因缘集比丘僧。呵责六群比丘。云何汝等传彼此语。遂至僧中先未有诤事而生诤事。已有诤事而不灭耶。尔时世尊以无数方便呵责六群比丘已告诸比丘。汝等当听。古昔有两恶兽为伴。一名善牙师子。二名善博虎。昼夜伺捕众鹿。时有一野干逐彼二兽后。食其残肉以自全命时彼野干窃自生念。我今不能久与相逐。当以何方便斗乱彼二兽令不复相随。时野干即往善牙师子所。如是语善牙。善博虎有如是语言。我生处胜种姓胜。形色胜汝力势胜汝。何以故。我日日得好美食。善牙师子逐我后。食我残肉以自全命。即说偈言

  形色及所生　　大力而复胜
  善牙不能善　　善博如是语

善牙问野干言。汝以何事得知。答言。汝等二兽共集一处相见自知尔时野干窃语善牙已。便往语善博虎言。汝知不。善牙有如是语。而我今日种姓生处悉皆胜汝力势亦胜。何以故。我常食好肉。善博虎食我残肉而自活命。即说偈言

  形色及所生　　大力而复胜
  善博不能善　　善牙如是语

善博问言汝以何事得知。答言。汝等二兽共集一处相见自知。后二兽共集一处嗔眼相视。善牙师子便作是念。我不应不问。便先下手打彼。尔时善牙师子向善博虎。而说偈问

  形色及所生　　大力而复胜
  善牙不如我　　善博说是耶

彼自念言。必是野干斗乱我等。善博虎说偈答善牙师子言

  善博不说是　　形色及所生
  大力而复胜　　善牙不能善
  若受无利言　　信他彼此语
  亲厚自破坏　　便成于冤家
  若以知真实　　当灭除嗔恼
  今可至诚说　　令身得利益
  今当善降伏　　除灭恶知识
  可杀此野干　　斗乱我等者

即打野干杀。二兽还和合。尔时佛告诸比丘。此二兽为彼所破。共集一处相见不悦。况复于人。为人所破心能不恼。云何六群比丘。斗乱彼此。先无诤事而生诤事。已有诤事而不能灭。尔时世尊。以无数方便呵责六群比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘两舌语波逸提。比丘义如上说。两舌者。比丘斗乱比丘比丘尼式叉摩那沙弥沙弥尼优婆塞优婆夷国王及大臣外道异学沙门婆罗门。比丘尼还斗乱比丘尼式叉摩那沙弥沙弥尼优婆塞优婆夷国王及大臣外道异学沙门婆罗门比丘。式叉摩那还斗乱式叉摩那沙弥沙弥尼优婆塞优婆夷国王及大臣外道异学沙门婆罗门比丘比丘尼。沙弥还斗乱沙弥沙弥尼优婆塞优婆夷国王及大臣外道异学沙门婆罗门比丘比丘尼式叉摩那。沙弥尼还斗乱沙弥尼优婆塞优婆夷国王及大臣外道异学沙门婆罗门比丘比丘尼式叉摩那沙弥沙弥尼。优婆塞还斗乱优婆塞优婆夷国王及大臣外道异学沙门婆罗门比丘比丘尼式叉摩那沙弥沙弥尼。优婆夷还斗乱优婆夷国王及大臣外道异学沙门婆罗门比丘比丘尼式叉摩那沙弥沙弥尼优婆塞。国王还斗乱国王及大臣外道异学沙门婆罗门比丘比丘尼式叉摩那沙弥沙弥尼优婆塞优婆夷。大臣还斗乱大臣外道异学沙门婆罗门比丘比丘尼式叉摩那沙弥沙弥尼优婆塞优婆夷国王。种种外道沙门婆罗门还斗乱种种外道沙门婆罗门比丘比丘尼式叉摩那沙弥沙弥尼优婆塞优婆夷国王大臣。斗乱者。某甲说是言。汝是旃陀罗种除粪种竹师种车师种拘凑拘尸婆苏昼种迦叶阿提梨夜婆罗堕贩卖猪羊杀牛放鹰网鱼猎师作贼捕贼守城刑狱锻作陶师皮师剃发师。汝犯波罗夷僧伽婆尸沙波逸提波罗提提舍尼偷兰遮突吉罗恶说结使者。从嗔恚乃至五百结。秃盲瞎跛躄聋哑。若有比丘破皆是比丘斗乱。说而了了者波逸提。说而不了了者突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。破恶知识。破恶伴党。破方便坏僧者。破助坏僧者。破二人三人作羯磨者。破若作非法羯磨非律羯磨者。破若僧若塔若庙若和上同和上若阿阇梨同阿阇梨若知识若亲友若数数语者无义无利欲方便作无义无利。破如是人者不犯不犯者。最初未制戒。痴狂心乱痛恼所缠(三竟)

尔时佛在舍卫国祇树给孤独园。尔时尊者阿那律。从舍卫国向拘萨罗国。中路至无比丘住处村。问言。谁与我住处。闻彼有一淫女家常安止宾客在门屋下住。时阿那律即往至彼淫女家语言。大妹。欲寄止一宿可得尔不。淫女答曰。可住门下宽广随意止宿。阿那律即入门下。自敷草蓐坐具结加趺坐。一心思惟系念在前。尔时拘萨罗国诸长者有行缘之便。亦投彼村求觅宿处。亦复闻彼淫女家常止宾客。即便往其家求寄宿言。欲于此寄一宿可尔不。淫女答言。我已先听一沙门宿。君可问彼沙门。可得共宿者便可止宿。其人即往阿那律所语言。我向语主人求宿即见听许。今欲共宿不相妨耶。阿那律答言。我草蓐敷竟门屋宽大可随意宿勿疑也。时诸长者即入门屋下。长者伴多坐相逼近。时淫女见已即生愍念心言。此阿那律是豪贵子孙。习乐来久不能忍苦。今诸长者共相逼近。即至阿那律所语言。尊者习乐来久不能忍苦。今诸长者共相逼近。尊者能入我舍内宿不。即报言可。尔时尊者阿那律即便入舍。在其坐处结加趺坐系念在前。时淫女室中然灯烛竟夕不绝。彼淫女于初夜来往阿那律所语言。近有诸长者婆罗门种。多诸财宝。皆来语我言。可与我作妇。我即语彼诸长者言。汝等丑陋不能为汝等作妇。若是端正者我今当为其作妇。我观尊者形貌端正。可为我作夫耶。时尊者阿那律虽闻此语默然不答亦不观视。何以故由尊者得无上二俱解脱故。到后夜末明相欲出。时复语阿那律言。诸婆罗门长者种皆多财宝语我言。为我作妇。我即不许。然阿那律颜貌端政可为我作夫耶。阿那律复默然不答亦不观视。何以故。由是尊者得无上二俱解脱故。尔时此淫女即脱衣来前捉之。时阿那律。以神足力踊身在空中。淫女见之惭愧裸身蹲住。即疾疾取衣着已叉手合掌。仰面空中向阿那律言。忏悔忏悔如是至三。愿尊者还来在本处坐。阿那律即下在本处坐。此女人礼阿那律足已却坐一面。阿那律为说种种微妙法。所谓施义戒义生天之义。呵欲不净度有漏缚。称赞出离为乐增益解脱。时淫女即于座上诸尘垢尽得法眼净。时淫女见法得法已。唯愿听许为优婆夷。归依佛法僧。自今已去尽形寿不杀生。乃至不饮酒。愿尊者今日受我请食。阿那律默然受之。彼淫女知阿那律默然受请已。即办具种种甘膳饮食而供养之。食已取一小床在阿那律前坐。阿那律为说种种法劝喻令其心喜。为说法已从坐而去。还僧伽蓝中。以此因缘具向诸比丘说。时众中有少欲知足行头陀乐学戒知惭愧者。讥嫌阿那律言。云何阿那律。与妇女同室宿耶。诸比丘往至世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊即以此因缘集比丘僧。知而故问阿那律言。汝实与女人独同室宿不。答言实尔。佛无数方便呵责阿那律言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何阿那律。与妇女同室宿。世尊以无数方便呵责阿那律已告诸比丘。自今已去与诸比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘与妇女同室宿者波逸提。比丘义如上说。妇女者。人女有知命根不断。室者。有四周墙壁。障上有覆。或前敞而无壁。或有四壁上无覆。或有虽覆而不遍。或有虽覆遍而有开处。是谓室若比丘先宿妇女后至。或妇女先至比丘后到。或二人俱至。若亚卧随胁着地波逸提。随转侧波逸提。若天女阿修罗女若龙女夜叉女饿鬼女同室宿者突吉罗。与畜生女能变化不能变化者同室宿突吉罗。若与黄门二根人同室宿突吉罗。昼日妇女立比丘卧者突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯不犯者。若比丘不知彼室内有妇女而宿。若比丘先至而妇女后至比丘不知。若屋有覆而无四边障。或尽覆而半障。或尽覆而少障。或尽障而不覆。或有尽障而少覆。或半覆半障。或少覆少障。或不覆不障露地无犯。此室中若行若坐无犯。若头眩倒地。若病卧无犯。或为强力所捉。若为人所缚。若命难净行难无犯无犯者。最初未制戒。痴狂心乱痛恼所缠(四竟)

尔时世尊在旷野城。六群比丘与诸长者共在讲堂止住。时六群中有一人。散乱心睡眠无所觉知。小转侧形体发露。时有比丘以衣覆已。复更转侧露形。一比丘复以衣覆之。寻复转侧而形起。时诸长者见已。便生讥嫌大笑调弄。时眠比丘心怀惭愧无颜。诸比丘亦惭愧。其中有少欲知足知惭愧行头陀乐学戒者。讥嫌此比丘言。云何六群比丘。与诸长者共止宿耶。时诸比丘即往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集诸比丘。呵责六群比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何六群比丘。与诸长者共止宿耶。以无数方便呵责六群比丘已告诸比丘言。此六群比丘痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘与未受大戒人共宿波逸提。如是世尊与比丘结戒。尔时佛在拘睒毗国。诸比丘如是言。佛不听我曹与未受大戒人共宿。当遣罗云出去。时罗云无屋住往厕上宿。时佛知之。往诣厕所作謦欬声。时罗云亦复謦欬。世尊知而故问。此中有谁。罗云答言。我是罗云。复问汝在此中作何等耶。答言。诸比丘言。不得与未受具戒人共宿驱我出。世尊即便言。云何愚痴比丘。无有慈心乃驱小儿出。是佛子不护我意耶。即便授指与之令捉。将来自入住房共止一宿。明日清旦集诸比丘告言。汝等无慈心乃驱出小儿。是佛子不护我意耶。自今已去听诸比丘与未受大戒人共二宿。若至三宿。明相未出时应起避去。若至第四宿。若自去若使未受戒人去。自今已去当如是说戒。若比丘与未受大戒人共宿。过二宿至三宿波逸提。比丘义如上说。未受戒人者。除比丘比丘尼。余未受大戒人是。同室宿者如前说。若比丘先至。未受大戒人后至。未受戒人前至。比丘后至。或二人俱至。若胁着地犯。若小转侧亦犯。若天男阿须罗男。乾闼婆男。夜叉男。饿鬼男。及与畜生中能变化者不能变化者。共过二宿三宿突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若比丘先不知在彼住。而未受戒人在后至。若未受戒人在前至。比丘在后至。若屋上有覆无四障。或尽覆而半障。或有尽障而少覆。或半障半覆。或少障少覆。若空露地。若坐若经行不犯若头眩倒地。若病卧。或为强力所执。若为系闭。若命难净行难是为不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(五竟)

尔时佛在旷野城。六群比丘。与诸长者。共在讲堂诵佛经语。语声高大。如婆罗门诵书声无异。乱诸坐禅者。时诸比丘闻已。其中有少欲知足行头陀乐学戒知惭愧者。讥嫌六群比丘言。云何与诸长者在讲堂中。共诵经如婆罗门诵书声耶。时诸比丘往至世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘。汝等云何与长者共在讲堂中诵经声如婆罗门无异耶。世尊以无数方便呵责六群比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘与未受戒人共诵者波逸提。比丘义如上说。未受戒者除比丘比丘尼余者是。句义非句义。句味非句味。字义非字义。句义者。与人同诵不前不后。诸恶莫作诸善奉行自净其意是诸佛教。非句义者。如一人说诸恶莫作未竟。第二人抄前言诸恶莫作。句味者。二人共诵不前不后。眼无常耳无常乃至意无常。非句味者。如一人未称眼无常。第二人抄前言眼无常字义者。二人共诵不前不后阿罗波遮那。非字义者。如一人未称言阿也。第二人抄前言阿也。句法者佛所说声闻所说仙人所说诸天所说。若比丘与未受戒人共诵。一说二说三说。若口授若书授若了了波逸提。说而不了了突吉罗。天子阿修罗子夜叉子龙子乾闼婆子畜生能变化者。一说二说三说。说而了了不了了者突吉罗。若师不教言我说竟汝可说者师突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。我说竟汝说。一人诵竟一人书。若二人同业同诵或戏笑语。或疾疾语。或独语。或梦中语。或欲说此乃说彼无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(六竟)

尔时佛在罗阅城耆阇崛山中。时有行波利婆沙摩那埵比丘在下行坐。时六群比丘语诸白衣。汝等知如许人在下行坐者不耶。白衣报言我等不知。六群比丘语言。此等犯如是事。犯如是事故。众僧罚使在下行坐。有过比丘闻之惭愧。余比丘闻之亦惭愧。中有少欲知足行头陀乐学戒知惭愧者。讥嫌六群比丘言。云何比丘犯粗恶事。乃向白衣说耶。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊以此因缘集比丘僧。呵责六群比丘言。汝等云何知比丘犯粗恶事。乃向白衣说耶。以无数方便呵责已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘比丘犯粗恶罪。向未受大戒人说波逸提。如是世尊与比丘结戒。尔时比丘。或不知粗恶不知不粗恶。后乃方知粗恶或有作波逸提忏悔者。或有畏慎者。佛言不知无犯。自今已去当如是说戒。若比丘知比丘犯粗恶罪。向未受大戒人说者波逸提。如是世尊与比丘结戒。尔时舍利弗为众所差。在王众中及诸人民众中说调达过。调达所作者。莫言是佛法僧。当知是调达所作。舍利弗闻已便生畏慎心。诸比丘知已往白世尊。世尊告言。众僧所差无犯。自今已去当如是说戒。若比丘知他有粗恶罪。向未受大戒人说。除僧羯磨波逸提。比丘义如上说。未受大戒者。除比丘比丘尼余者是。粗恶罪者。四波罗夷僧伽婆尸沙。僧者。一羯磨一说戒。若比丘知他有粗恶罪。向未受大戒人说。除僧羯磨波逸提。若说了了波逸提。不了了者突吉罗。除粗恶罪已。更以余罪。向未受大戒人说者突吉罗。自犯粗恶罪。向未受大戒人说者突吉罗。除比丘比丘尼。以余人粗恶罪。向未受大戒人说者突吉罗。粗恶罪粗恶想波逸提。粗恶罪疑突吉罗。非粗恶粗恶罪想突吉罗。非粗恶疑突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若不知。若众僧差。粗恶非粗恶想。若白衣先已闻此粗恶罪无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(七竟)

尔时佛在毗舍离猕猴池楼阁精舍。以此因缘集比丘僧。佛知而故问。婆求园比丘颇实尔耶。白佛言。实尔世尊。佛言。汝等痴人。真实犹不得向人说。何况不实。世尊以无数方便呵责婆求园比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘向未受大戒人说过人法言。我见是我知是。实者波逸提。比丘义如上说。未受大戒者。除比丘比丘尼余者是。人法者。人界人阴人入。上人法者诸法出要。自言。得身念善思惟有戒有欲有不放逸有精进有定有正定有道有修行有智慧有见有得有果。若彼真实有此事。向未受大戒人说。了了者波逸提。说而不了了者突吉罗。若手印书。若作知相遣人。了了波逸提。不了了突吉罗。若天子阿修罗子夜叉子乾闼婆子龙子饿鬼子畜生能变化不能变化者向说得上人法。了了不了了突吉罗。若实得上人法。向受大戒人非同意者说突吉罗。若自称言。我得根力觉道禅定解脱入三昧向人说者波逸提。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若增上慢。若自言是业报不言是修得。若实得上人法向同意比丘说。若说根力觉道解脱入三昧。不向人说我得。或戏笑语独语。若梦中语。欲说此乃说彼无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(八竟)

尔时佛在舍卫国祇树给孤独园。尔时尊者迦留陀夷。时到着衣持钵诣一大长者家。在姑前与儿妇耳语说法。姑见已即问妇言。向比丘说何等事耶。妇报言与我说法。姑语妇言。若说法者。当高声说令我等闻。云何耳中独言耶。其妇报言。向者语如兄弟语无异。更无余过失。时乞食比丘闻已。即呵责迦留陀夷言。云何尊者。于姑前与儿妇耳语说法耶。尔时乞食比丘还至僧伽蓝中。以此因缘具向诸比丘说。其中有少欲知足行头陀乐学戒知惭愧者。讥嫌迦留陀夷。云何尊者。在姑前为他儿妇耳语说法耶。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊即集比丘僧。知而故问迦留陀夷。汝实尔于姑前与他儿妇耳语说法耶。答曰实尔。尔时世尊。以无数方便呵责迦留陀夷。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。汝云何于姑前为他儿妇耳语说法耶。呵责迦留陀夷已告诸比丘。此迦留陀夷痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘与女人说法波逸提。如是世尊与比丘结戒。时有诸女人请诸比丘言。唯愿诸尊。与我等说法。时诸比丘各有畏慎心。世尊制戒。比丘不得与女人说法。诸比丘以此因缘具白世尊。世尊告曰。自今已去。听诸比丘与女人五六语说法。自今已去当如是说戒。若比丘为女人说法。过五六语波逸提。如是世尊与比丘结戒。诸比丘复有畏慎心。以无有知男子便休。不与女人说法。佛告诸比丘。自今已去有有知男子。听过五六语与女人说法。自今已去当如是说戒。若比丘与女人说法。过五六语除有知男子波逸提。时有诸女人。请诸比丘言。大德。愿授我五戒。时诸比丘有畏慎心。以无有知男子便不与戒佛言。自今已去听无有知男子与女人受五戒。时有女人请诸比丘。大德为我说五戒法。时无有知男子。比丘有畏慎心。不与说五戒法。佛告诸比丘。自今已去听诸比丘无有知男子与女人说五戒法。时有诸女人欲受八关斋法。诸比丘有畏慎心。以无有知男子不与受斋法。佛告诸比丘。自今已去听诸比丘无有知男子与女人受八关斋法。时诸女人请诸比丘。大德为我说八关斋法。时无有知男子。比丘畏慎心不与说八关斋法。佛告诸比丘。自今已去听诸比丘无有知男子与女人说八关斋法。尔时诸女人白诸比丘。大德我等欲闻八贤圣道法。时无有知男子。比丘心有畏慎。不与说八圣道法。佛告诸比丘。自今已去听比丘无有知男子与女人说八圣道法。时有诸女人白诸比丘言。大德为我说十不善法。时无有知男子。比丘心有畏慎。不与说十不善法。佛告诸比丘。自今已去听诸比丘无有知男子与女人说十不善法。时有诸女人白诸比丘。大德为我等说十善法。诸比丘有畏慎心。无有知男子。不与说十善法。佛告诸比丘。自今已去听诸比丘无有知男子与女人说十善法。时有诸女人来问诸比丘义。比丘有畏慎心。以无有知男子。不答诸女人问义。佛告比丘。自今已去听无有知男子答诸女人问义。若不解当广为说。自今已去欲说戒者当如是说。若比丘与女人说法。过五六语除有知男子波逸提。比丘义如上说。女人亦如上说。五语者。色无我受想行识无我。六语者。眼无常耳鼻舌身意无常。有知男子者解粗恶不粗恶事。若比丘为女人说法。过五六语除有知男子。说而了了者波逸提。不了了者突吉罗。若天女阿修罗女龙女夜叉女乾闼婆女饿鬼女畜生女能变化者。为说过五六语了了不了了突吉罗。畜生中有不能变化者。为说过五六语一切突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯不犯者。若五六语有知男子前过说。若无有知男子前。授优婆夷五戒。及说五戒法。与八关斋法。说八斋法。及说八圣道法。为说十不善法十善法及女人问义。如是无有知男子应答。若不解得广为说。若戏笑语。疾疾语。独语梦中语。欲说此乃说彼无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(九竟)

尔时佛在旷野城。时六群比丘。与佛修治讲堂绕堂周匝自掘地。时诸长者见讥嫌言。沙门释子不知惭耻断他命根。外自称言我知正法。如今观之有何正法。而自掘地断他命根。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。讥嫌六群比丘言云何为佛修治讲堂自掘地。使诸长者讥嫌耶。诸比丘即往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以无数方便呵责六群比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何自掘地使诸长者讥嫌耶。世尊以无数方便呵责六群比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘自手掘地波逸提。如是世尊与比丘结戒。尔时六群比丘。修治讲堂教人掘地言掘是置是。时诸长者见已讥嫌。云何沙门释子不知惭愧。教人掘地断他命无有慈心。自称我知正法。如今观之何有正法。尔时诸比丘闻已。其中有少欲知足行头陀乐学戒知惭愧者讥嫌六群比丘。云何修治佛讲堂教人掘地言掘是置是。使诸长者讥嫌耶。呵责已。往世尊所头面礼足在一面坐。以此因缘具白世尊。世尊即集比丘僧。呵责六群比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何修治讲堂。教人掘地言掘是置是。使诸长者讥嫌耶。世尊以无数方便呵责已告诸比丘。自今已去与比丘结戒。若比丘自手掘地若教人掘者波逸提。比丘义如上说。地者已掘地。未掘地。若已掘地经四月被雨渍还如本若用锄或以钁斲。或以椎打。或以镰刀刺。乃至指爪掏伤地一切波逸提。打橛入地者波逸提。地上然火波逸提。地有地想波逸提。若不教言看是知是突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若语言知是看是。若曳材木曳竹。若蓠倒地扶正。若反塼石取牛屎取崩岸土。若取鼠坏土。若除经行处土。若除屋内土。若来往经行。若扫地。若杖筑地。若不故掘一切不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(十竟)

四分律卷第十一四分律卷第十二(初分之十二)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    九十单提法之二

尔时佛在旷野城。世尊以此因缘集诸比丘僧告言。有一旷野比丘修治屋舍故自斫树耶。答曰。实斫。尔时世尊。以无数方便呵责言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何修治屋舍故自斫树耶。世尊以无数方便呵责已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘坏鬼神村波逸提。比丘义如上说。鬼者非人是。村者一切草木是。若斫截堕故名坏。村有五种。有根种枝种节生种覆罗种子子种。根种者。呵梨陀姜忧尸罗贸他致吒卢揵陀楼及余根所生种者是。枝种者。柳舍摩罗婆罗醯他及余枝种等是。节生种者。苏蔓那华苏罗婆蒱醯那罗勒蓼及余节生种者是。覆罗种者。甘蔗竹苇藕根及余覆罗生种者是。子子种者。子还生子者是。若生生想。自断若教他断若自炒教他炒自煮教他煮波逸提。若生疑。若自断教他断自炒教他炒自煮教他煮突吉罗。生非生想。若自断教他断乃至煮突吉罗。非生生想。若自断教他断乃至煮亦突吉罗非生疑。若自断教他断。乃至煮亦突吉罗。草木七种色。青黄赤白黑缥紫色。生草木作生草木想。若自断教他断乃至煮波逸提。生草木疑。若自断教他断。乃至煮突吉罗。生草木非生草木想。若自断教他断乃至煮突吉罗。非生草木生草木想。若自断教他断乃至煮突吉罗。非生草木疑。若自断教他断乃至煮突吉罗。若打撅着生树上波逸提。若以火着生草木上波逸提。若断多分生草木波逸提。断半干半生草木突吉罗。若不言看是知是突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。言看是知是。若断枯干草木。若于生草木上曳材曳竹正蓠障。若拨墼石。若取牛屎。若生草覆道以杖披遮令开。若以瓦石柱之而断伤草木。若除经行地上。若扫经行来往处地。误拨断生草木。若以杖筑地拨生草木断无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(十一竟)

尔时世尊。在拘睒毗瞿师罗园中。尔时尊者阐陀比丘犯罪。诸比丘问言。汝自知犯罪不耶。即以余事报诸比丘。汝向谁语。为说何事。为论何理。为语我为语谁耶。是谁犯罪。罪由何生。我不见罪。云何言我有罪。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。讥嫌阐陀比丘言。汝云何自知犯罪。余比丘问。乃以余事报诸比丘。汝向谁语为说何事为论何理为我说为余人说谁犯罪罪由何生我不见罪云何言我有罪耶。诸比丘往至世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊即集比丘僧。呵责阐陀比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何阐陀比丘。汝犯罪诸比丘问言。汝自知罪不。即以余语答诸比丘。汝向谁语为说何事为论何理为我说为余人说谁犯罪罪由何生我不见罪云何作如是语耶。时世尊以无数方便呵责阐陀比丘已告诸比丘。自今已去听白已当名作余语。应如是白。大德僧听。此阐陀比丘犯罪。诸比丘问言。汝今自知犯罪不。即以余事报诸比丘言。汝向谁语为说何事为论何理为我说为余人说谁犯罪罪由何生我不见罪。若僧时到僧忍听。当名阐陀比丘作余语。白如是。作是白已。名作余语。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘余语者波逸提。如是世尊与比丘结戒。尔时尊者阐陀比丘。众僧与制不得作余语。后便触恼众僧。唤来不来。不唤来便来。应起不起。不应起便起。应语不语不应语便语。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。讥嫌阐陀比丘言。云何众僧名作余语已后故触恼众僧。唤来不来不唤来便来。应起不起不应起便起。应语不语不应语便语。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊以此因缘集比丘僧。呵责阐陀比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何阐陀比丘。众僧与制名作余语。后故触恼众僧。唤来不来不唤便来。应起不起不应起便起。应语不语不应语便语。世尊以无数方便呵责阐陀比丘已语诸比丘。自今已去白已名阐陀比丘作触恼。当作如是白。大德僧听。阐陀比丘。僧名作余语已触恼众僧唤来不来不唤便来。应起不起不应起便起应语不语不应语便语。若僧时到僧忍听。制阐陀比丘名作触恼。白如是。白已名作触恼。自今已去当如是说戒。若比丘妄作异语恼他者波逸提。比丘义如上说。余语者。僧未作白便作余语。汝向谁说为说何事为论何理为我说为余人说我不见此罪。如是语者尽突吉罗。若作白已如是语者一切尽波逸提。触恼者。若未白前。唤来不来不唤来便来应起不起不应起便起应语不语不应语便语。一切尽突吉罗。若白竟作如是语一切尽波逸提。若上座唤来不来突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者重听不解前语有参错。汝向谁说乃至我不见此罪。若欲为作非法羯磨非毗尼羯磨。若僧若塔寺若和上同和上若阿阇梨同阿阇梨若亲旧知识欲为作无利益羯磨。不与和合唤来不来不犯。若欲为作非法羯磨非毗尼羯磨。若僧若塔寺若和上同和上阿阇梨同阿阇梨若亲旧知识欲为作无利益羯磨。若欲知教言莫来便来不犯。若一坐食若不作余食法食。若病唤起不起不犯。或舍崩坏或烧。或毒蛇入舍。或遇贼或虎狼师子。或为强力将去。或为他所缚。或命难或梵行难。教莫起便起不犯若恶心问若问上人法汝说是不与说不犯。若作非法羯磨非毗尼羯磨。若僧若塔寺若和上同和上若阿阇梨同阿阇梨若亲旧知识。若欲为作无利益教莫语便语不犯若小语若疾疾语若梦中语若独语。欲说此错说彼无犯。无犯者最初未制戒痴狂心乱痛恼所缠(十二竟)

尔时世尊在罗阅城耆阇崛山中。时尊者沓婆摩罗子。为众僧所差。知僧坐具及差僧食。时慈地比丘。其中间相去。齐眼见耳不闻处。自相谓言此沓婆摩罗子有爱有恚有怖有痴余比丘语言此沓婆摩罗子为众僧所差。知僧坐具及差僧食。汝等莫说彼有爱有恚有怖有痴。慈地比丘报言。我等不面说。在屏处讥嫌耳。尔时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌慈地比丘言。此沓婆摩罗子。为僧所差知僧坐具及差僧食。云何汝等言彼有爱有恚有怖有痴。时诸比丘往至世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊即以此因缘集比丘僧。呵责慈地比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何慈地比丘。沓婆摩罗子为僧所差。知僧坐具及差僧食。汝等云何嫌责彼言。有爱有嗔有怖有痴。世尊以无数方便呵责慈地比丘已告诸比丘。慈地比丘痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘讥嫌波逸提。如是世尊与比丘结戒。慈地比丘后复更作方便。便齐沓婆摩罗子闻而不见处。自相谓言。此沓婆摩罗子有爱有嗔有怖有痴。诸比丘语言。佛不制戒言讥嫌波逸提耶。慈地比丘报言。我等不嫌是骂耳。时有比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。讥嫌慈地比丘言。此沓婆摩罗子为僧所差。知僧坐具及差僧食。汝等云何骂耶。诸比丘呵责已往至世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊即以此因缘集比丘僧。呵责慈地比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。沓婆摩罗子为僧所差。知僧坐具及差僧食。汝等云何骂耶。世尊以无数方便呵责慈地比丘已告诸比丘。自今已去与诸比丘结戒。若比丘嫌骂波逸提。比丘义如上说。若面见讥嫌若背面骂。面见嫌者。齐眼见不闻处言。有爱有嗔有怖有痴。背面骂者。齐耳闻不见处言。有爱有嗔有怖有痴。比丘嫌骂比丘说而了了者波逸提。不了了者突吉罗。若上座教汝嫌骂。若受教嫌骂突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。其人实有其事。而有爱有嗔有怖有痴恐后有悔恨。语令如法发露。便言有爱有嗔有怖有痴无犯。若戏笑语独语梦中语。欲说此乃错说彼无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(十三竟)

尔时佛在舍卫国祇树给孤独园。尔时舍卫城中有一长者欲请众僧饭食。时有十七群比丘。取僧坐具。在露地敷。而经行望食时到。时到已不收摄僧坐具便往彼食。僧坐具即为风尘土坌。虫鸟啄坏污秽不净诸比丘食已还至僧伽蓝中。见僧坐具风尘土坌虫鸟啄坏污秽不净。即问言。谁敷僧坐具不收摄而舍去耶。乃使风尘土坌虫鸟啄坏污秽不净。答言。十七群比丘取敷。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。讥嫌十七群比丘言。汝云何敷僧坐具而不收摄。使风尘土坌虫鸟啄坏污秽不净耶。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊即以此因缘集比丘僧。呵责十七群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何十七群比丘。敷僧坐具不收摄而去。使风尘土坌虫鸟啄坏污秽不净。世尊以无数方便呵责十七群比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘取僧绳床木床若卧具坐褥。露地自敷若教人敷舍去。不自举不教人举波逸提。比丘义如上。众僧物为僧属僧。僧物者。已舍与僧。为僧者。为僧作未舍与僧。属僧者。已入僧已舍与僧。绳床者有五种。旋脚绳床。直脚绳床。曲脚绳床。入陛绳床。无脚绳床。木床亦如是。卧具者或用坐或用卧褥者用坐。若比丘。以僧绳床木床卧具坐褥在露地敷若教人敷。去时若彼有旧住比丘若摩摩帝若经营人。当语言。我今付授汝。汝守护看。若都无人者。当举着屏处而去若无屏处。自知此处必无有破坏当安隐。持粗者覆好者上而去。若即时得还便应去。若疾雨疾还不坏坐具者应往。若中雨中行及得还者应往。若少雨少行及得还者应往。彼比丘应次第作如是方便去。若比丘不作如是方便而行初出门波逸提。若一足在门外一足在门内。意欲去而不去还悔一切突吉罗。若二人共一绳床木床坐。下坐应收而去。下坐作如是意。谓上座当收。而上座竟不收。而下座犯波逸提。复以非威仪故突吉罗。上座意谓下座当收。而下座不收上座犯波逸提。若二人不前不后俱不收二俱波逸提。及余空绳床木床踞床。若机浴床。若卧具表里若地敷。若取绳索毳放在露地不收便去突吉罗。若敷僧卧具在露地不收。而入房坐思惟突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯不犯者。若取僧绳床木床踞床。若机若卧具坐褥在露地自敷若教人敷。去时语旧住人若摩摩帝若经营人言。守护此付授汝。若无人者收着屏处而去。若无屏处可安。自知此处必无忘失不畏坏。若以粗者覆好者上而去。若即去即时还。若暴风疾雨疾得还。若中雨中行。若少雨徐行得还者。若次第作如是方便去无犯。若为力势所缚。若命难若梵行难。不作次第而去不犯。若二人共一绳床坐。下座应收。诸余空木床绳床踞床。若机浴床若卧具表里。若地敷绳索毳[袖-由+宁]敷在露地若收而去。若在露地敷僧坐具收摄已入房思惟无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(十四竟)

尔时佛在舍卫国祇树给孤独园尔时有客比丘。语旧住比丘。我在边僧房中敷卧具宿。后异时不语旧比丘便去。僧卧具烂坏虫啮色变。时旧住比丘。于小食大食时夜说法时说戒时。不见客比丘。旧住比丘作是念。何以不见客比丘耶。将不命过。或能远去。或能反戒作白衣。或能被贼。或为恶兽所食。或为水所漂。彼即往到房。见众僧坐具烂坏虫啮色变。见已嫌彼客比丘所为。云何客比丘。语我在边房敷众僧卧具宿不语我而去。使众僧坐具烂坏虫啮色变。尔时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。讥嫌客比丘。云何客比丘。语旧比丘在边房敷众僧卧具宿不语而去。使众僧卧具烂坏虫啮色变。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时集比丘僧。呵责客比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何在边房敷众僧卧具宿去。而不语旧比丘。使众僧敷具烂坏色变。世尊以无数方便呵责客比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘。于僧房中敷僧卧具。若自敷若教人敷。若坐若卧。去时不自举不教人举波逸提。比丘义如上说。众僧物者如上说。卧具绳床木床卧褥坐具枕地敷下至卧毡。彼比丘。僧房中若敷众僧卧具。若自敷若教人敷。若坐若卧。去时不自举不教人举。是中若有旧住比丘有经营人若摩摩帝。当语言与我掌护牢举。于中若无人付授。不畏失当移床离壁高搘床脚。持枕褥卧具置里。以余卧具覆上而去。若恐坏败。当取卧具毡褥枕举置衣架上竖床而去。彼比丘当如是作而去。若比丘不作如是而去。若出界外波逸提。一脚在界外一脚在界内还悔而不去一切突吉罗。若期去而不去突吉罗。若即还不久二宿在界外至第三宿明相未出。若自往到房中。若遣使往语。若摩摩帝若知事人语言。汝掌护此物。若比丘出界外二宿。至第三宿明相未出。不自往至房中不遣使语言汝掌护此物者波逸提。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若敷众僧卧具。若自敷若教人敷若坐若卧。若彼去时。是中有旧住人若摩摩帝若知事人语言。汝守护是物于中作摩摩帝。若无人付授。应量宜不坏败。当举床离壁持卧具枕毡褥举着床上重覆而去。若畏坏败当举卧具着衣架上竖床而去。作如是而去者无犯。若房舍坏崩落火烧。若毒蛇在内。盗贼虎狼师子强力势者所执。若被系若命难若梵行难。若时还不久。若二宿界外。第三宿明相未出当自去。若遣使语彼旧住人。汝掌护此物作摩摩帝。若水道留难。若道路有贼虎狼师子。若大水涨。为力势所持。若被系若命难若梵行难。二夜在界外第三宿明相出自不得往。不得遣使语人掌护此物与我作摩摩帝无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(十五竟)

尔时佛在舍卫国祇树给孤独园。尔时六群比丘及十七群比丘。在拘萨罗国。道路行向余聚落。至无比丘住处。时十七群比丘语六群比丘言。汝等先前去求止住处。六群比丘语言。汝自去我何豫汝事。六群比丘是十七群比丘上座。十七群比丘语六群比丘言。汝是我等上座。上座应先求住处。我等后当求。六群比丘报言。汝等去我不求住处。时十七群比丘即往求住处。自敷卧具止宿。时六群比丘知十七群比丘求得宿止处敷卧具竟。往语言汝等起。当以大小次第止住。彼言我不与汝起。六群问言。汝等今者几岁耶。十七群报言。诸长老实是我上座。我等先已语长老。可先求住处。然后我等当求住处。而今已住终不能复移。时六群比丘。强在坐间敷卧具宿。十七群比丘高声称言。诸尊莫尔诸尊莫尔。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。讥嫌六群比丘言。云何六群比丘。十七群比丘先得住处。后来强于中间敷卧具。而宿耶。诸比丘往诣世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时集比丘僧。呵责六群比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何六群比丘。十七群比丘先得住处。后来强于中间敷卧具而宿耶。尔时世尊。以无数方便呵责六群比丘已告诸比丘。此六群比丘痴人。多种有漏处最初犯戒。自今已去与诸比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘。先比丘得住处。后来强于中间敷卧具止宿念言。若彼人嫌窄者自当去。作如是因缘非余非威仪波逸提。如是世尊与比丘结戒。时诸比丘。不知是先住处非先住处。后乃知是先住处。或有作波逸提忏者。或有畏慎者佛言。不知者无犯。自今已去当如是结戒。若比丘。知先比丘住处。后来强于中间敷卧具止宿念言。彼若嫌窄者自当避我去。作如是因缘非余非威仪波逸提。比丘义如上说。中间者。若头边若脚边若两胁边。卧具者。草敷叶敷下至地敷卧毡。若比丘。知他比丘先得住处。后来强于中间敷卧具止宿。随转侧胁着床波逸提。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。先不知若语已住。若先与开间。若间宽广不相妨阂。若有亲旧人。亲旧人教言。但于中敷。我自当为语其主。若倒地若病转侧堕上。若为力势所持。若被系闭。若命难若梵行难无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(十六竟)

尔时佛在舍卫国祇树给孤独园。尔时六群比丘及十七群比丘。在拘萨罗旷野道中行至小住处。时十七群比丘语六群比丘言。长老先去敷卧具。六群报言。汝自去我何豫汝事。六群比丘是十七群比丘上座。彼如是言。长老是我等上座。长老先去敷卧具。我等当次第敷之。六群报言。汝但去我不敷。十七群比丘净洁自喜。入寺里扫洒房舍令净。敷好卧具于中止宿。时六群比丘。知十七群入寺扫洒房舍净洁敷好卧具已。即往入房语言。长老起随次坐。语言我等不起。六群即问言。汝等今几岁耶。十七群比丘报言。长老实是我等上座。我先已语上座先敷我等后次第敷。今已坐不能起。今已逼暮但当尽共宿。尔时六群比丘强牵嗔不喜驱出房。时十七群比丘高声言。莫尔诸贤莫尔诸贤。时比房比丘闻之即问言。汝等何故高声大唤。时十七群比丘具以此事说之。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘。云何嗔不喜强牵十七群比丘驱出僧房。时诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何六群比丘。嗔不喜强牵十七群比丘驱出僧房耶。世尊以无数方便呵责六群比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘。嗔他比丘不喜僧房舍中住。若自牵出教他牵出波逸提。比丘义如上说。僧房者如上。若比丘嗔他比丘不喜在僧房舍中。若自牵若教人牵。随所牵多少随出房波逸提。若牵多人出多户。多波逸提。若牵多人出一户。多波逸提。若牵一人出多户。多波逸提。若牵一人出一户。一波逸提。若持他物出突吉罗。若持物掷着户外突吉罗。若闭他着户外突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗是谓为犯。不犯者。无恚恨心随次第出若共宿二夜至三夜遣未受戒人出。若破戒若破见若破威仪。若为他所举若为他所摈若应摈。以是因缘故有命难梵行难。驱逐如此人等无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(十七竟)

尔时佛在舍卫国祇树给孤独园。诸比丘在重阁上住。坐脱脚床上坐不安庠。阁下有比丘止宿阁薄床脚脱堕下比丘上。坏身血出。时比丘仰向恚骂。云何比丘。在重阁上住坐脱脚床上坐不安庠。使床脚下脱打伤我身至令血出。诸比丘闻之。其中有少欲知足行头陀乐学戒知惭愧者。嫌责彼比丘言。云何比丘。乃在重阁上坐脱脚床上坐不安庠。床脚下脱打彼比丘身使血出。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊即集比丘僧。呵责彼比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何比丘在重阁上坐脱脚床上坐不安庠令床脚下脱打彼比丘身伤血出耶。世尊以无数方便呵责彼比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒集十句义乃至正法久住。欲说戒者当如是说。若比丘。若房若重阁上脱脚绳床若木床若坐若卧波逸提。比丘义如上说。舍者。僧房若私房。重阁者。立头不至上者是。脱脚床者脚入陛。比丘在重阁上坐脱脚床。若坐若卧随胁着床随转侧波逸提。除脱脚床已。若在独坐床或一板床或浴床一切突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯不犯者。若坐旋脚绳床直脚绳床曲脚床无脚床若床榰大若脱脚床安细腰。若彼重阁上有板覆。若刻木作华覆若重厚覆。若反床坐。若脱床脚坐无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(十八竟)

尔时世尊在拘睒弥国。尔时尊者阐陀比丘。起大屋以虫水和泥教人和。诸长者见嫌责言。沙门释子。不知惭愧无有慈心害众生命外自称言我修正法。如今观之有何正法。以虫水和泥教人和害众生命。尔时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责阐陀言。云何起房屋以虫水和泥教人和害众生命。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时即集比丘僧。呵责阐陀言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何阐陀。起屋以虫水和泥教人和耶。世尊以无数方便呵责阐陀已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘以虫水和泥若教人和波逸提。如是世尊与比丘结戒。尔时诸比丘。未知有虫水无虫水。后乃知有虫。或有波逸提忏悔者或有畏慎者。佛言。不知无犯。自今已去当如是说戒。若比丘知水有虫。若自浇泥若草若教人浇者波逸提。比丘义如上说。若知水有虫以草若土掷中者波逸提。除水已若有虫酪浆清酪浆若酢若渍麦浆以浇泥若草若教人者波逸提。若以土若草著有虫清酪浆中酢中水中渍麦浆中若教人者波逸提若有虫水有虫水想波逸提。虫水疑突吉罗无虫水有虫水想突吉罗。无虫水疑突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者不知有虫作无虫想若虫大以手触水令虫去。若漉水洒地。若教人洒者一切无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(十九竟)

尔时世尊在拘睒弥国瞿师罗园中。尔时尊者阐陀比丘。起大房覆已有余草复更重覆。故有余草第三覆。犹复有余草在。时彼作是念。我不能常从檀越求索草。为更重覆不止屋便摧破。诸居士见嫌其所为沙门释子不知惭愧乞求无厌。外自称言我知正法。如今观之有何正法。作此大舍重覆不止。致使摧折崩破耶。檀越虽与受者应知足。时诸比丘闻之。其中有少欲知足行头陀乐学戒知惭愧者。嫌责阐陀比丘。云何起大房重覆不止。而使摧折崩破。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时集比丘僧。呵责阐陀比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何阐陀。起大房重覆不止。使摧折崩破耶。世尊以无数方便呵责阐陀比丘已告诸比丘。阐陀比丘痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘作大房舍。户扇窗牖及余庄饰具。指授覆苫齐二三节。若过波逸提。比丘义如上说。大舍者多用物及余庄饰者刻镂彩画。覆者有二种纵覆横覆。彼比丘指授二节覆已。第三节未竟当去至不见不闻处。若比丘二节覆已。第三节未竟不去至不见不闻处。若第三节竟波逸提。若舍闻处至见处。舍见处至闻处。一切突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。指授覆苫二节竟。至第三节覆未竟至不见不闻处。水陆道断贼难诸恶兽难水大涨或为力势所持若被系若命难若梵行难。指授覆二节至第三节未竟不去至不见不闻处无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(二十竟)

尔时世尊在舍卫国祇树给孤独园。与大比丘众五百人俱。于中夏安居。尽是众所知识。如舍利弗大目揵连尊者大迦叶尊者大迦旃延尊者劫宾那尊者摩诃拘絺罗尊者摩诃朱那尊者阿那律尊者离越尊者阿难尊者难陀尊者那提。如是等五百人俱。尔时大爱道比丘尼。差摩比丘尼。莲华色比丘尼。提舍瞿昙弥比丘尼。波梨遮罗夷比丘尼。诉弥比丘尼。数那比丘尼。苏罗比丘尼。遮罗夷比丘尼。婆遮罗比丘尼。尸罗婆遮那比丘尼。阿罗婆比丘尼。摩罗毗比丘尼。朱泥比丘尼。婆泥比丘尼。如是等五百比丘尼。大爱道为首。于舍卫国王园中夏安居。尔时大爱道往至世尊所。头面礼足在一面坐。坐已白世尊言。唯愿世尊。听诸比丘与比丘尼教诫说法。佛告大爱道瞿昙弥。今听诸比丘与比丘尼教诫与比丘尼说法。尔时大爱道头面礼足而去。尔时世尊告阿难曰。自今已去听随次差上座大比丘教诫比丘尼为说法。尔时阿难闻世尊教。即往般陀比丘所语言。长老。为比丘尼教诫说法。般陀报阿难言。我所诵唯一偈耳。云何教诫比丘尼云何说法。阿难复重语般陀。长老。教诫比丘尼为说法。般陀复报阿难言。我所诵者唯一偈耳。云何教诫比丘尼为说法。阿难第三语般陀比丘。世尊有教。差上座比丘教诫比丘尼为说法。长老。应教诫比丘尼为说法。时尊者般陀默然受敕。时六群比丘尼闻尊者般陀比丘明日当次来教授。自相谓言。此愚闇般陀。唯诵一偈耳。说已当默然更何所说。尔时尊者般陀。明日清旦着衣持钵入舍卫城乞食已。还入僧伽蓝中。整衣服将一比丘。往诣王园中比丘尼安居所。尔时诸比丘尼。遥见尊者般陀来。各前往迎。有拂拭衣服者。有捉钵敷坐具者。有办净水洗足器者。尔时尊者般陀。即就座而坐。诸比丘尼等前礼足已在一面坐

尔时大爱道。白尊者般陀言。今正是时。可为诸比丘尼教诫说法。尔时般陀即说偈言

  入寂者欢喜　　见法得安乐
  世无恚最乐　　不害于众生
  世间无欲乐　　出离于爱欲
  若调伏我慢　　是为第一乐

尔时尊者般陀。说此偈已即入第四禅。时六群比丘尼。各相向调戏言。我先有此语。般陀比丘痴人唯诵一偈。若来为我等说已。更何所说。今者默然果如所言。时诸罗汉比丘尼。闻般陀所说皆大欢喜。知般陀有大神力。时大爱道。复语尊者般陀。为诸比丘尼教诫说法。尔时般陀比丘。即重说向者偈已入第四禅默然无言。时大爱道。复重请尊者般陀。为诸比丘尼教诫说法。般陀比丘即复重说向者偈已还入第四禅默然而住。时六群比丘尼复自相谓言。尊者般陀闇塞唯诵一偈。若来为我等说者一说则已。如今默然果如所言。唯有阿罗汉比丘尼。知般陀是阿罗汉有大神力。时尊者般陀便作此念。我今观众人心闻我向者所说为欢喜不。尔时尊者般陀。即观诸比丘尼心。或有喜者或有不喜者即复更念言。我今宁可为其作悔恨相。即升虚空或现身说法。或隐形而说法。或现半身说法。或不现半身而说法。或身出烟炎或不现。尔时尊者般陀在空中。为诸比丘尼现此众变说法已。即于空中而去。尔时六群比丘遣信语六群比丘尼言。我等次当与比丘尼教诫说法。时六群比丘尼即白比丘尼僧。六群比丘次当教授说法。尔时六群比丘夜过已。明日清旦着衣持钵入舍卫城乞食。乞食已还僧伽蓝中。更整衣服摄持威仪往诣王园。至比丘尼安居所就座而坐。时诸比丘尼礼足已各就座而坐。时六群比丘。教诫比丘尼乃说余事。不说戒定智慧解脱解脱知见少欲知足出要进业舍离趣善不处愦闹十二因缘论。但说王者论人民论军马论斗诤论大臣论骑乘论妇女论华鬘论酒会论淫女论床卧论衣服论美饮食论浴池娱乐论作亲里论别异论思惟俗事论入海论。多入如是论中。或笑或舞或鼓唇弹鼓簧或啸。或鼓口作吹贝声。或作孔雀鸣。或作鹤鸣。或并走或一脚跛行或干战。时六群比丘尼见如是事极大欢喜言。六群比丘作如是教授最是其宜。罗汉比丘尼以恭敬心故默然无言。尔时大爱道。往世尊所头面礼足已在一面立。须臾白世尊言。六群比丘次当教授比丘尼。乃说余事。亦不与说戒论定论乃至不处愦闹十二因缘论。但为说王者论乃至思惟俗事入海论乃复戏笑或歌舞。乃至一脚跛行干战。尔时大爱道白世尊说此事已。头面礼足而去。尔时世尊以此因缘集比丘僧。知而故问六群比丘言。汝等实尔如是教诲比丘尼不。时六群比丘报言。实尔世尊。世尊尔时呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等如是教授比丘尼耶。尔时世尊以无数方便呵责六群比丘已告诸比丘。自今已去当众僧中差教授比丘尼人。白二羯磨当差堪能羯磨者如上作如是白。大德僧听。若僧时到僧忍听。差某甲比丘教授比丘尼。白如是。大德僧听。差此某甲比丘教授比丘尼。谁诸长老忍。差此比丘教授比丘尼者默然。谁不忍者说。僧已忍。差某甲比丘教授比丘尼竟。僧忍默然故是事如是持。时六群比丘作是言。僧不差我等教授比丘尼。即出在界外。更互相差教授比丘尼。遣使语六群比丘尼。为我白尼僧言。六群比丘。僧差当来教诫比丘尼。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。僧不差汝教授比丘尼。云何在界外。更互相差教诫比丘尼。遣使语比丘尼言僧已差我等教诫比丘尼耶。时六群比丘尼即为白比丘尼僧言。众僧已差六群比丘教诫比丘尼。时大爱道闻此语已。往至世尊所。头面礼足在一面立。以此因缘具白世尊已头面礼足而去。尔时诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时集比丘僧。知而故问六群比丘言。汝等实出界外更互相差教授比丘尼僧不。答言实尔。世尊以无数方便呵责六群比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何痴人。僧不差教授比丘尼。出界外更互相差教授比丘尼。遣使语六群比丘尼言。为我白尼僧言。僧差我等教诫比丘尼。我今当教授比丘尼。世尊呵责已告诸比丘。自今已去。若有比丘成就十法者。然后得教授比丘尼。戒律具足。多闻诵二部戒。利决断无疑。善能说法。族姓出家。颜貌端正。比丘尼众见便欢喜。堪任与比丘尼众说法劝令欢喜。不为佛出家而披法服犯重法。若满二十岁若过二十岁。如此等可与比丘尼教诫。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘僧不差教诫比丘尼者波逸提。比丘义如上说。僧者一说戒一羯磨。差者僧中所差白二羯磨。教授者八不可违法。何等八若百腊比丘尼见初受戒比丘。当起迎逆问讯礼拜请令坐。此法应尊重恭敬赞叹。尽形寿不应违。比丘尼不得骂比丘。不得诽谤言破戒破见破威仪。如此法应尊重恭敬赞叹。尽形寿不应违。比丘尼不得举比丘罪言汝所作尔汝所作不尔。不得作自言。不得遮他觅罪。不得遮他说戒自恣。比丘尼不得说比丘过失。比丘得说比丘尼过失。如此法应尊重恭敬赞叹。尽形寿不应违。已学于戒式叉摩那应从众僧求受大戒。如此法应尊重恭敬赞叹。尽形寿不应违。若比丘尼犯僧残罪。应半月在二部僧中行摩那埵。如此法应尊重恭敬赞叹。尽形寿不应违。比丘尼于半月当从众僧中求索教授人。如此法应尊重恭敬赞叹。尽形寿不应违。比丘尼不应在无比丘处夏安居。如此法应尊重恭敬赞叹。尽形寿不应违。比丘尼夏安居讫。当诣众僧中求三事见闻疑自恣。如此法应尊重恭敬赞叹。尽形寿不应违。于说戒时上座当问比丘尼众。遣何人来耶。若有即起白僧言。比丘尼僧和合。礼比丘僧足求索教诫人。说戒时上座应更问言。谁为教诫比丘尼。若有者应差。若教诫比丘尼者多。应遣使语比丘尼僧。此多有教诫人。汝为请谁耶。若彼尼言我请此人。若复报言。我随僧处分者。僧应随常教授比丘尼者次第差。比丘僧应克时到比丘尼亦克时往迎。若比丘克时不至突吉罗。比丘尼至时不迎亦突吉罗。若闻教授师来。比丘尼当出半由旬迎。供给所须办洗浴具。为作粥种种饭食。不作如是供办者突吉罗。若僧不差或非教授日而往与说八不可违法者突吉罗。若僧不差而往与说法者波逸提。若比丘僧病。应遣人礼拜问讯。若比丘不和合众不满足。应遣人礼拜问讯。若不突吉罗。若比丘尼僧病。亦应遣人礼拜问讯。比丘僧若比丘尼众不和合众不满足者。亦当遣人礼拜问讯。若不突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。众僧差教授比丘尼。说戒时上座问谁遣比丘尼来。若有即应起白僧言。比丘尼僧和合礼比丘僧足求教授比丘尼人。上座当问言。谁应教诲比丘尼耶。若有应差教授。若教授人多。上座应问。为请谁教授耶。若比丘尼言。我正请某甲。僧应随所言差。若比丘尼言一以任僧处分者。尔时即当于常教授人中随次差往。众僧当克时而往。比丘尼亦当克时而迎。时比丘尼闻教授师来。当出半由旬迎。安置坐处办洗浴具。办粥种种饭食。若众僧所差至集会日与说八不违法。应次往与说法。若众僧病。比丘尼遣信礼众僧。众僧不满别部不和合遣信礼。若比丘尼病若众不满不和合。亦遣信礼拜问讯众僧。若水道留难道路崄难贼盗虎狼师子河水暴涨力势所持。若被系闭命难梵行难。不容遣人礼拜问讯。如此等无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(二十一竟)

四分律卷第十二四分律卷第十三(初分之十三)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    九十单提法之三

尔时佛在舍卫国祇树给孤独园。时尊者难陀。为众僧所差教授比丘尼。教授比丘尼已默然而住。尔时大爱道语言。尊者难陀。我等欲得闻法。愿更与我等说。尔时尊者难陀。与说法已默然而住。大爱道复重请言。我等欲得闻法愿与我等说。时尊者难陀好音声为说法。听者乐闻遂至日暮。时比丘尼。出只桓精舍往舍卫城。城门已闭不得入门。即便依门外城堑中宿。晨旦门开在前入城。时诸长者见已皆言。沙门释子无有惭耻无清净行。自称言我修正法。如是有何正法。汝等皆观此比丘尼。竟夜与比丘共宿昼便放还。诸比丘闻已。众中有少欲知足行头陀乐学戒知惭愧者嫌责言。云何难陀。与比丘尼教诫乃至日暮。使诸长者嫌责耶。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。知而故问尊者难陀。汝实与比丘尼教诫至日暮耶。答曰实尔。尔时世尊以无数方便呵责难陀言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何难陀与比丘尼说法教诫乃至日暮耶。呵责已告诸比丘。此难陀痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说若比丘为僧差教授比丘尼乃至日暮者波逸提。比丘义如上。僧者一教授一羯磨。教授者众僧中差白二羯磨。彼比丘众僧所差教授比丘尼。应乃至日未暮当还。若比丘教授比丘尼乃至日暮者波逸提。除教授若受经若诵经若问若以余事乃至日暮突吉罗。除比丘尼已若为余妇女诵经若受经若问若以余事至日暮突吉罗。若日暮日暮想波逸提。日暮疑突吉罗。日暮不日暮想突吉罗。不日暮日暮想突吉罗。不日暮疑突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。教授比丘尼日未暮便休。除妇女已若为余人若教诵经受经若问若以余事不犯。若船济处说法比丘尼听。若与贾客共行夜说法。若至比丘尼寺中说法。若说戒日来在众中请教授人值说法便听无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(二十二竟)

尔时佛在舍卫国祇树给孤独园时彼比丘尼闻教授师来半由旬迎。安处房舍办粥若饮食床座具洗浴处。尔时六群比丘作是念。彼诸比丘不差我等教授比丘尼。生嫉妒心言。彼诸比丘教授比丘尼无有真实。但为饮食故教授比丘尼诵经受经若问。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘。云何作如是语。诸比丘不差我等教授比丘尼。便生嫉妒心彼诸比丘教授比丘尼无有真实。但为饮食故教授比丘尼若诵经受经若问。诸比丘往世尊所头面礼足在一面坐。以此因缘具白世尊。世尊尔时集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何六群比丘乃作是言。彼诸比丘不差我等教授比丘尼。便生嫉妒心。彼诸比丘教授比丘尼无有真实。但为饮食故教授比丘尼若诵经受经若问。世尊以无数方便呵责六群比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘语诸比丘作如是语。比丘为饮食故教授比丘尼者波逸提。比丘义如上。彼比丘作是言。诸比丘为饮食故教授比丘尼。为饮食故教诵经受经若问。说而了了者波逸提。不了了者突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。其事实尔。为饮食供养故教授比丘尼。为饮食故教诵经受经若问。若戏笑语独处语梦中语。欲说此乃错说彼无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(二十三竟)

尔时佛在舍卫国祇树给孤独园。尔时舍卫城中有一乞食比丘威仪具足。时有比丘尼见便生善心。数请彼比丘。比丘不受。后于异时只桓众僧分衣物。此比丘持衣分出只桓门。彼比丘尼方来入只桓。彼比丘念言。此比丘尼数数请我而我不受。我今宁可持此衣分用请彼。彼必不取足以相遗。时此比丘语比丘尼言。大妹。此衣是我分。须者可取。时比丘尼辄便受之。此比丘嫌责比丘尼言。我数数向人说言。彼比丘尼数请我。以钵中遗余与我而我不取。我作如是念。彼比丘尼数数请我。以钵中遗余与我而我不取。我今宁可持此衣分与彼比丘尼。彼必不受足以相遗。而彼便受之。尔时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责彼比丘言。云何比丘。与比丘尼衣不舍而请他耶。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时集比丘僧呵责彼比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何比丘。与比丘尼衣不舍而请他。以无数方便呵责彼比丘已。告诸比丘言。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘与比丘尼衣波逸提。如是世尊与比丘结戒。其中有比丘畏慎不敢与亲里比丘尼衣白佛。佛言。自今已去听与亲里比丘尼衣。若与非亲里比丘尼衣者波逸提。如是世尊与比丘结戒。尔时只桓中二部僧共分衣物。比丘衣分比丘尼得。比丘尼衣分比丘得。时比丘尼所得衣持来诣僧伽蓝中。白诸比丘。大德。持此衣共贸易耶。比丘答言诸妹。我曹不得与非亲里比丘尼衣。尔时诸比丘白佛佛言。自今已去若贸易听与非亲里比丘尼衣。自今已去当如是说戒。若比丘与非亲里比丘尼衣除贸易波逸提。比丘义如上说。非亲里者如上说。亲里者亦如上。衣者有十种如上说。贸易者。以衣易衣。以衣易非衣。以非衣易衣。针贸刀若缕线下至药一片。若比丘与非亲里比丘尼衣。除贸易波逸提。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。与亲里尼。衣共相贸易与塔与佛与僧无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(二十四竟)

尔时佛在舍卫国祇树给孤独园。尔时有比丘尼欲作僧伽梨。以作衣故来至僧伽蓝中。语尊者迦留陀夷。大德。我持此衣财欲作僧伽梨。愿尊者与我作。迦留陀夷报言。我不能作。问言。何故不与我作。报言。汝等喜数来相催促故不能作。比丘尼报言。我不数来相催随作竟与我。迦留陀夷报言可尔。时比丘尼授衣与之而去。迦留陀夷善知作衣法。即与裁之作男女行淫欲像。时比丘尼来至僧伽蓝中。问迦留陀夷言。大德。为我成衣未耶。答言衣已成。比丘尼言。衣若成者今可见与。时迦留陀夷即襞衣授与之。语言大妹。当知此衣不得妄解披看亦莫示人若白时到当着此衣在比丘尼僧后行。时比丘尼如其教。亦不披衣看复不语人知。后于异时白时到。即着此衣。在比丘尼僧后行。诸居士见皆共讥笑。或拍手相向。或打木或啸。或高声大笑言。汝等看此比丘尼所著衣。汝等看此比丘尼所著衣。时摩诃波阇波提比丘尼。见已语此比丘尼言大妹。速脱襞此衣。即便襞之着肩上。时摩诃波阇波提比丘尼。食后还僧伽蓝中。语彼比丘尼言。取汝向者衣来我欲看之。即持出示之。问言。谁与汝作此衣。报言是迦留陀夷作。语言何不披看持示同学耶。缝割好不牢不。时比丘尼以迦留陀夷所敕事具向说之。时比丘尼众中。有少欲知足行头陀乐学戒知惭愧者。嫌责迦留陀夷。云何与比丘尼乃作如是衣。尔时比丘尼白诸比丘。诸比丘即往白世尊。世尊以此因缘集比丘僧。知而故问迦留陀夷言。汝实与比丘尼作如是衣耶。答曰实尔。世尊以无数方便呵责迦留陀夷言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为云何乃与比丘尼作如是衣耶。呵责迦留陀夷已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒集十句义乃至正法久住。欲说戒者当如是说若比丘与比丘尼作衣者波逸提。如是世尊与比丘结戒。时诸比丘畏慎。不敢与亲里比丘尼作衣。往白佛。佛言。自今已去听比丘与亲里比丘尼作衣。自今已去当如是说戒。若比丘与非亲里比丘尼作衣者波逸提。比丘义如上。非亲里亲里者如上。衣者有十种亦如上。若彼比丘与非亲里比丘尼作衣。随刀截多少波逸提。随一缝一针亦波逸提。若复披看牵挽熨治以手摩扪。若捉角头挽方正安帖。若缘若索綖若续綖。一切突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。与亲里比丘尼作。与僧作若为塔。若借着浣染治还主无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(二十五竟)

尔时世尊在舍卫国祇树给孤独园。尔时尊者迦留陀夷颜貌端正。偷兰难陀比丘尼亦复颜貌端正。与人有异。迦留陀夷有欲意于偷兰难陀比丘尼。偷兰难陀比丘尼亦有欲意于迦留陀夷尔时迦留陀夷。清旦着衣持钵。往至偷兰难陀所。在门外共一处坐。时诸居士见已皆共嫌之。各自相谓言。汝等观此二人共坐。犹如夫妇亦如鸳鸯。尔时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责迦留陀夷云何与偷兰难陀比丘尼在门外共一处坐耶。尔时诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊以此因缘集比丘僧。知而故问迦留陀夷言。汝实与偷兰难陀比丘尼在门外共一处坐耶。答曰实尔。世尊以无数方便呵责迦留陀夷言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何与偷兰难陀比丘尼共在门外一处坐耶。呵责迦留陀夷已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘与比丘尼在屏处坐者波逸提。比丘义如上。一处者一是比丘一是比丘尼。屏障处者。见屏处闻屏处。见屏处者。若尘若雾若烟云若黑闇不见也。闻屏处者。乃至不闻常语声。障者。若树若墙若篱若衣若复以余物障。若比丘独在屏处与比丘尼坐者波逸提。若盲而不聋聋而不盲突吉罗。立住者突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若比丘有伴。若有智人有二不盲不聋不聋不盲。若行过卒倒地。若病转侧。若为力势所持。若被系闭。若命难梵行难无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(二十六竟)

尔时世尊。在舍卫国祇树给孤独园。尔时六群比丘。与六群比丘尼在拘萨罗国人间游行。诸居士见皆共嫌之。沙门。释子无有惭愧不修梵行。外自称言。我修正法。如是有何正法。与比丘尼人间游行。若有所欲便下道。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。云何与六群比丘尼共人间游行耶。诸比丘往至世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何六群比丘。与六群比丘尼共在拘萨罗人间游行耶。世尊以无数方便呵责六群比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘与比丘尼共行。从一村乃至一村间者波逸提如是世尊与比丘结戒。时诸比丘不先与比丘尼共期。卒道路相遇畏慎不敢共行。佛言。若不共期无犯。自今已去应如是说戒若比丘与比丘尼共期。同一道行乃至一村间波逸提。如是世尊与比丘结戒。尔时众多比丘。从舍卫国欲至毗舍离。时众多比丘尼。亦从舍卫国欲至毗舍离。诸比丘尼问比丘言。大德。欲何所至耶。诸比丘报言。我欲至毗舍离。比丘尼言。大德。我亦欲往。诸比丘报言。大妹。若欲往者当在前。我等在后。若我等在前大妹在后何以故世尊制戒不得与比丘尼同道行。诸比丘尼言。大德。是我等上尊。应在前我等在后。时诸比丘尼在后。为贼所劫失衣钵。诸比丘以此事具白世尊。世尊言。自今已去若与贾客行若疑畏怖无犯。自今已去当如是说戒。若比丘与比丘尼期同一道行。从一村乃至一村除异时波逸提。异时者。与贾客行若疑畏怖时。是谓异时比丘义如上。期者。言共去至某村某城某国土。有疑处者。疑有贼劫盗。恐怖者。恐有贼劫盗。道者村间有分齐行处是。若比丘与比丘尼期同一道行。乃至村间分齐处。随众多界多少一一波逸提。非村若空处。行乃至十。里波逸提。若减一村若减十里突吉罗。若多村间同一界行突吉罗。方便欲去共期庄严一切突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。不共期大伴行疑恐怖处。若往彼得安隐。若为力势者所持。若被系若命难梵行难无犯。无犯者最初未制戒。痴狂心乱痛恼所缠(二十七竟)

尔时佛在舍卫国祇树给孤独园。尔时六群比丘。与六群比丘尼共乘船上水下水。时诸居士见皆共嫌之。自相谓言。沙门释子不知惭愧不修梵行。外自称言我修正法。如是何有正法。与比丘尼共乘船上水下水。若有所欲时便住船岸边随意。尔时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘。云何与六群比丘尼共乘船上水下水。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊以此因缘集比丘僧。呵责六群比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何与六群比丘尼共乘船上水下水。世尊呵责已告诸比丘。此六群比丘痴人。多种有漏处最初犯戒自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘与比丘尼共乘船上水下水者波逸提。如是世尊与比丘结戒。尔时诸比丘不期而畏慎。佛言。不期无犯。自今已去当如是说戒。若比丘与比丘尼共期同。一船上水下水者波逸提。如是世尊与比丘结戒。尔时有众多比丘。欲渡恒水从此岸至彼岸。尔时众多比丘尼。亦欲渡恒水从此岸。至彼岸诸比丘尼往问言大德。欲何所至耶。比丘报言。我等欲渡恒水。比丘尼言。可得共伴渡不。诸比丘报言。诸妹在前我等在后。若不尔者。诸妹在后我等在前。何以故。世尊制戒不得与比丘尼同一船渡水。是故不得。比丘尼白言。大德是我等所尊。则应在前我等在后。尔时夏月天大暴雨。江水泛涨船到彼岸。未还之间日已暮。诸比丘尼即在岸边宿。夜遇恶贼劫夺。尔时诸比丘往白佛。佛言。直渡至彼岸者无犯。自今已去当如是结戒。若比丘与比丘尼共期同乘一船上水下水除直渡者波逸提比丘义如上。共期亦如上。船者如上所说。若比丘与比丘尼共期同一船上水下水。除直渡若入船里波逸提。若一脚在船上一脚在地。若方便欲入而不入。若共期庄严一切突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。不共期。若直渡彼岸。若入船船师失济上水下水。若往彼岸不得安隐。或为力势者所持。或被系或命难梵行难无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(二十八竟)

尔时世尊。在舍卫国祇树给孤独园。尔时舍卫城中有一居士。请舍利弗目连与饭食。彼即于夜办具种种美食。明日露地敷好坐具已白时到。尔时偷兰难陀比丘尼。先是居士家比丘尼。时偷兰难陀。明旦着衣持钵诣彼居士家。见居士在露地敷众多好坐具见已。即问居士言。居士敷此众多坐具欲请诸比丘耶。答言欲请。比丘尼即问言。请何等比丘耶。报言。我请舍利弗目连。比丘尼语言。居士所请者尽是下贱人。若先语我者我当为居士请龙中之龙。居士问言。何者是龙中之龙。比丘尼答言。尊者提婆达三闻陀罗达骞驮罗达婆瞿婆离迦留罗提舍是。言语之顷舍利弗目连已至。比丘尼见已语居士言。龙中之龙已至。居士即语比丘尼言。汝向者言下贱人。今云何言龙中之龙耶。自今已去勿复来往我家。尔时居士白舍利弗目连坐即就座而坐。时居士出种种甘美饮食供养。食已除去食器。头面礼足已更取小床在一面坐。白言。我欲得闻法。时舍利弗目连。为说种种微妙法劝令欢喜。与说法已从坐而去。还至僧伽蓝中。往世尊所头面礼足在一面坐。世尊知而故问舍利弗目连言。汝等今日受请食为得充足不耶。舍利弗目连白佛言。食虽充足。我于居士家。亦是下贱。亦是龙中之龙。佛问言。何故耶。尔时舍利弗目连。以此因缘具白世尊言。是提婆达遣部党比丘尼。为作劝化供养彼受饮食。尔时世尊。以此因缘集比丘僧。知而故问提婆达部党比丘言。汝等实遣比丘尼往叹誉劝化檀越得食不。对曰实尔。时世尊以无数方便呵责提婆达部党比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等。遣比丘尼劝化檀越受彼食耶。呵责提婆达部党比丘已告诸比丘言。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘遣比丘尼劝化得食波逸提。如是世尊与比丘结戒。尔时诸比丘。不知有劝化无劝化。然后乃知。或有作波逸提忏者。或有疑者。先不知无犯。自今已去当如是说戒。若比丘知比丘尼教化得食者波逸提。如是世尊与比丘结戒。尔时罗阅城中有大长者。是梨师达亲友知识。彼作是言。若大德梨师达来至罗阅城者。我等当为梨师达初至故供养众僧。长者家比丘尼闻此语默然在怀。于异时尊者梨师达来入罗阅城。尔时比丘尼闻尊者梨师达来入城。便往语长者言。欲知不。梨师达已来入罗阅城。长者即遣信至僧伽蓝中请之。明日清旦愿尊屈意。并及众僧受我食。尔时长者。即其夜办具种种甘美饮食。清旦往白时到。尔时诸比丘。着衣持钵往诣长者家就座而坐。时长者往诣梨师达所语言。正为尊者故饭食众僧。时梨师达问长者言。云何知我来至此也。长者报言。家所供养比丘尼见语。梨师达语长者言。若实尔者。我不应食此食。长者报言。我亦不从此比丘尼语设此食。我先有誓愿。若梨师达来者。我设饭食供养众僧。梨师达复语长者言。虽有此语我亦不应食此食。时梨师达即止不食。尔时诸比丘具白世尊。世尊告言。若檀越先意者无犯。自今已去当如是说戒。若比丘知比丘尼赞叹教化因缘得食食。除檀越先有意者波逸提。比丘义如上。教化者。阿练若乞食人着粪扫衣作余食法不食一坐食一抟食冢间露地坐树下坐常坐随。坐持三衣赞偈多闻法师持律坐禅也。食者。从旦至中得食。彼比丘知比丘尼教化得食。食咽咽波逸提。除此饭食已。教化得余衬体衣灯油涂脚油一切突吉罗。知教化教化想波逸提。教化疑突吉罗。不教化教化想突吉罗。不教化疑突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若不知若檀越先意。若教化无教化想。若比丘尼自作。若檀越令比丘尼经营。若不故教化而乞食与无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(二十九竟)

尔时佛在舍卫国祇树给孤独园。时毗舍离嫁女与舍卫国人。后与姑共诤还诣本国。尔时阿那律。从舍卫国欲至毗舍离国。时彼妇女问尊者阿那律言。尊者欲至何处耶。答言。我欲至毗舍离。妇女即言。可见将去不。答言可尔。尔时尊者阿那律。便与此妇女同一道行。尔时妇女夫主先行不在。后日还家不见其妇。即问母言。我妇为所在耶。其母报言与我斗竟便逃走去不知所在。尔时夫主速疾往逐之。于道路得妇。将诣阿那律所语言。何故将我妇逃走耶。时阿那律答言。止止莫作此语。我等不尔。长者语言。云何言不尔。汝今现与同道行。其妇语夫主言。我与此尊者行如兄弟相逐无他过恶。夫主报言。此人今日将汝逃走。岂可不作此言耶。尔时其人即打阿那律垂断命根。尔时尊者阿那律。即下道在一静处结加趺坐。直身正意系念在前入火光三昧。时长者见已便生善心。长者念言。若此阿那律从三昧起者。我当礼拜忏悔。时尊者阿那律从三昧觉已。长者即便忏悔。唯愿大德。受我忏悔。阿那律受其忏悔。尔时长者礼足已在一面坐。尔时阿那律。为长者说种种微妙法令发欢喜心。与说法已即从坐起而去。尔时阿那律食已。往到僧伽蓝中。以此因缘具向诸比丘说。尔时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责阿那律。云何阿那律。独与妇女共一道行。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时即集比丘僧。知而故问阿那律言。汝实共妇女同一道行耶。答言实尔。尔时世尊。以无数方便呵责阿那律言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。汝今云何与妇人共同一道行耶。尔时世尊。以无数方便呵责阿那律已告诸比丘。此阿那律多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘与妇女同一道行。乃至村间波逸提。如是世尊与比丘结戒。时诸比丘不共期道路相遇。有畏慎不敢共行。佛言不期不犯。自今已去当如是说戒。若比丘与妇女共期同一道行。乃至村间波逸提。比丘义如上。妇女者如上说。共期者亦如上说。道者亦如上说。若比丘与妇女共期同一道行。乃至村间。随众多界分齐一一波逸提。若无村若空处行十里波逸提。若减一。村减十里突吉罗。若村里一界共行者突吉罗。若方便欲行而不行。若共期庄严而不去一切突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。先不共期事须往彼得安隐。若为力势所持。若被系闭。若命难若梵行难无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(三十竟)

尔时佛在舍卫国祇树给孤独园。尔时拘萨罗国有无住处村。有居士为比丘作住处。常供给饮食。若在此住者当听一食。尔时有六群比丘。欲往拘萨罗国无住处村。至彼住处经一宿得美好饮食。故复住第二宿复得美好饮食。彼六群比丘作如是念。我所以游行者正为食耳。今者已得彼于此住处数数食。时诸居士皆共讥嫌。此沙门释子无有厌足不知惭愧。外自称言我知正法。如是有何正法。于此住处数数受食。正似我曹常为此沙门释子供给饮食。我本为周给一宿住者耳。尔时诸比丘闻已。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。云何六群比丘。于此住处数数受食。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何六群比丘。于此住处数数受食。尔时世尊。以无数方便呵责六群比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘一住处食应受一食。若过一食者波逸提。如是世尊与比丘结戒。尔时舍利弗在拘萨罗国游行。诣此无住处村住一宿。明日清旦得好食。舍利弗于彼得病。念言。世尊制戒比丘一宿处应一食。若过者波逸提。即扶病而去。病遂增动。尔时比丘往白佛。佛言。自今已去听病比丘过受食。自今已去当如是说戒。若施一食处无病比丘应一食。若过受者波逸提。比丘义如上。住处者在中一宿食者。乃至时食。病者离彼村增剧者是。若无病比丘。于彼一宿处过受食咽咽波逸提。除食已更受余衬身衣灯油涂脚油尽突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。一宿受食病过受食。若诸居士请大德住我当与食。我等为沙门释子故设此宿处供给饮食。若不得沙门释子亦当与余人耳。若檀越次第请食。若儿若女若妹及儿妇次第请食无犯。或今日受此人食。或明日乃受彼人食。或水瀑涨道路涩难。若有贼盗虎狼师子。或为力势者所持。或被系闭。或命难梵行难过一食者无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(三十一竟)

尔时世尊在罗阅只迦兰陀竹园中。世尊从罗阅城出游行人间。与大比丘众千二百五十人俱。尔时国界。田殖不收米谷勇贵。乞食难得人皆饥色。时有五百乞人随逐世尊后。时有婆罗门名曰沙菟。有五百乘车载满饮食。经冬涉夏随逐世尊后。伺候空缺无食之日便欲设供。尔时世尊。从摩竭国界渐渐教化至阿那频头国界。彼国人民竞兴供具。饭佛及比丘僧无有空日。时婆罗门终日伺候无有空缺不得设供。即便往阿难所语阿难言。我沙菟有五百乘车载满饮食。经冬涉夏随逐世尊。伺候空缺无食之日便欲设供。然我今者不得次供。我等处俗多诸难故。属官役使。至于断事之日当应往赴。兼复料理家业。复供官财谷。公私驱驰初无停息。唯愿尊者为我白佛。佛若有教我当奉行。若佛及僧不得次食者。我当以此五百乘车饮食布在道中。令佛及僧脚蹈而过者。则为受我供养已。阿难报言。且小住。我正尔当为白佛。时阿难往世尊所。头面礼足在一面立以此因缘具白世尊言。沙菟婆罗门来至我所作是说。有五百乘车载满饮食。经冬涉夏随逐世尊。伺候空缺无食之日便欲设供。然我今日不得次供。我等处俗多诸难故。属官使役。至于断事之日当复往赴。兼复料理家业公私无停。唯愿尊者为我白佛。佛若有教我当奉行。若不得次供者。我当以此五百乘车饮食布在道中。令佛及僧脚蹈上而去者。则为受我供养。我向者报言可小住。正尔当为白佛。是故启尊。尔时世尊告阿难。汝可往语婆罗门。明旦以此饮食具用作粥与诸比丘使食。后当受时食。尔时阿难受佛教。即往婆罗门所。语婆罗门言。汝可以此饮食具用作粥与诸比丘使食。后当受时食。时婆罗门观诸供养之者皆无有饼。即其夜供办种种美味酥油胡麻子乳净水姜椒荜苃。作种种粥及饼。夜过已以此粥供养佛及比丘僧。然诸比丘不敢受。语婆罗门言。世尊未听比丘受酥油乃至三种药作种种粥。尔时诸比丘以此因缘具白世尊。世尊尔时告诸比丘。自今已去听诸比丘受酥油乃至三种药作种种粥食之。食粥有五事。善除饥除渴消宿食大小便调适除风患。食粥者有此五善事。时婆罗门复行[麩-夫+并]。比丘不敢受。语婆罗门言。世尊未听比丘受饼。即往白佛。佛言。自今已去听诸比丘受饼食。时阿那频头国诸居士。闻世尊听诸比丘食粥及[麩-夫+并]。皆大欢喜自相谓言。我等快得作福供养。已复有一少信大臣。见佛及僧大得供养。如是言。此非是少福田者。乃于谷贵中佛及比丘僧致如是供养。我今宁可办具种种肥美饮食人别一器肉。尔时即遣人至僧伽蓝中。白言大德僧。愿受我明日请食。即其夜办种种肥美饮食。明日清旦往白时到。尔时世尊自住僧伽蓝中遣人请食。时阿那频头诸居士。先闻佛听诸比丘食粥。即其夜办具种种粥如上。明日送至僧伽蓝中与诸比丘。诸比丘先已受他请食。复食此种种浓粥。然后往彼大臣家食。尔时少信大臣与诸比丘僧种种饮食。诸比丘言。止止檀越稍稍着。大臣语比丘僧言。我故为比丘僧。办具肥美饮食人别一器肉。莫以我信心薄少故而不饱食。诸大德。但食我有信心耳。诸比丘报言。不为此故不食。城中人民闻佛听诸比丘食粥及[麩-夫+并]。即于其夜办具种种酥油胡麻子乳净水姜椒荜苃作粥。明日送至僧伽蓝中与诸比丘。我等先食彼粥故。今者不能复多食耳莫怪也。时少信大臣即嫌之言。我故为众僧作此种种好食人别一器肉者。欲使众僧尽食。云何先食浓粥已方受我食。时大臣嗔恨。即便留种种[麩-夫+并]肉美味。唯施设羹饭。往世尊所头面礼足在一面坐。坐已白佛言。向者所设供养众僧者。福多耶罪多耶。佛告大臣。汝所设供养者得福极多。乃是生天之因。诸比丘乃至受汝一抟食者其福无量。尔时世尊。渐与说法。布施持戒生天之法。呵欲过恶及上有漏。称赞出离增益解脱。为说此法已。即于座上诸尘垢尽得法眼净。见法得法修于正法得增上果。白佛言。自今已去归依佛法僧。听为优婆塞。尽形寿不杀生乃至不饮酒

尔时世尊食后以此因缘集比丘僧。知而故问诸比丘言。汝等清旦食他浓粥已然后受大臣请耶。答言实尔。尔时世尊。以无数方便呵责诸比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等愚痴。先食彼浓粥然后受请耶。不得先受请已食稠粥。稠粥者。以草画之不合不得食。若食者当如法治。尔时世尊。从阿那频头国人间游行。与千二百五十比丘俱。尔时国界米谷勇贵乞。食难得人皆饥色。然有五百乞人常随逐世尊后。尔时世尊。于摩竭提国渐渐游行还罗阅城。时佛及众僧多得供养。时罗阅城中有一少信乐师。见佛及比丘僧大得供养。作是念言。此非是少福田者。于此谷贵中佛及比丘僧大得供养。我今宁可以一年所出之物供办种种肥美饮食人别肉一器施佛及僧耶。于是即自往僧伽蓝中。白诸比丘言。明日清旦受我请食供养。即夜办具种种好食已。明日清旦往白时到。尔时罗阅城中节会日。诸居士竞持饭糗干饭鱼及肉。往诣僧伽蓝中施诸比丘。时诸比丘得而食之然后受请。尔时乐师手自斟酌种种饮食。诸比丘言。止止居士。莫多着食。彼乐师言。我一年已来所出众物。故为比丘僧办种种肥美饮食人别肉一器。莫以我少信故恐生不信而不多食。愿但食我有信乐耳。尔时诸比丘答此乐师言。我不以此事故不食。以向先受王舍城诸人食。是故今者食少耳。更无余心莫见怪也。尔时少信乐师闻此语已。即生讥嫌言。云何我一岁之中所出物。故为众僧办具种种肥美饮食人别肉一器。云何诸比丘。先受他饭糗干饭鱼及肉。然后乃受我食。乐师嗔恨。即便留种种肥美饮食。正与羹饭而已。往诣世尊所。头面礼足在一面坐。坐已问佛言。我向者所设饮食。福多耶罪多耶。佛告言。汝今所施食者生天之因。诸比丘乃至食一抟其福无量。何况今者施设如是。此福不可量也。尔时世尊为说妙法。布施持戒生天之因。呵欲过恶及上有漏。尔时乐师闻此语已。即于座上诸尘垢尽得法眼净。见法得法修于正法得增上果。即白佛言。自今已去愿听为优婆塞。尽形寿不杀生乃至不饮酒。尔时世尊。以此因缘集比丘僧。知而故问诸比丘。汝等实先受他请五种食。然后受此请食耶。答曰实尔。尔时世尊。以无数方便呵责诸比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何痴人。先受他五种食已。然后受他请耶。世尊以无数方便呵责诸比丘已告诸比丘。不应先受他请食五种食已然后受请也。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘展转食者波逸提。如是世尊与比丘结戒。时诸病比丘。所请食处。无有随病食随病药。若有随病美食及药。畏慎不敢食。恐犯展转食。尔时诸比丘以此事往白佛。佛告言。自今已去听病比丘展转食。自今已去当如是说戒。若比丘展转食。除异时波逸提。异时者病时。如是世尊与比丘结戒。尔时有一居士。请佛及比丘僧欲设饮食供养。复有一居士。亦请佛及僧欲设饮食及衣供养。即往僧伽蓝中语诸比丘言。我欲请佛及比丘僧供养饮食。比丘报言。我等先以受请。居士白言。大德。我欲施好饮食及衣。唯愿众僧受我请。尔时诸比丘畏慎往白世尊。世尊告言。自今已去听诸比丘布施衣时听展转食。自今已去当如是说戒。若比丘展转食除余时波逸提。余时者。病时施衣时是谓余时。比丘义如上。展转食者请也。请有二种。若僧次请别请。食者饭糗干饭鱼及肉。病者不能一坐食好食令足。施衣者。自恣竟无迦絺那衣一月。有迦絺那衣五月。若复有余施食及衣。若今日得多请食。应自受一请。余者当施与人如是施与言。长老。我应往彼今布施汝。若比丘不舍前请受后请食咽咽波逸提。不舍后请受前请食者咽咽突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。病时施衣时。若一日之中有多请者。自受一请余者当施与人。若请与非食。或食不足。或无请食者。或食已更得食。或一处有前食后食无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(三十二竟)

四分律卷第十三四分律卷第十四(初分之十四)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    九十单提法之四

尔时佛在罗阅只耆阇崛山中。尔时提婆达多教人害佛。复教阿阇世王杀父。恶名流布利养断绝。时与五比丘俱家家乞食。三闻他罗达多骞[馬*犬]达婆拘婆离迦留罗提舍。尔时诸比丘闻。提婆达多教人害佛。复教阿阇世王杀父。恶名流布利养断绝。与五比丘俱家家乞食。尔时诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧知而故问提婆达多言。汝实与五比丘家家乞食耶对曰。实尔世尊。世尊尔时以无数方便呵责提婆达多言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何提婆达多。与五比丘家家乞食耶。提婆达多我以无数方便利益慈愍诸白衣家。云何提婆达多痴人。与五人家家乞食耶。尔时世尊以无数方便呵责提婆达多已告诸比丘言。此提婆达多痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘别众食者波逸提。如是世尊与诸比丘结戒。时诸病比丘有请食处。不得随病食及药。有美好随病食及药。畏慎不敢受。恐犯别众食。世尊告诸比丘。自今已去听病比丘受别众食。自今已去当如是说戒若比丘别众食除余时波逸提。余时者病时。如是世尊与比丘结戒。时诸比丘自恣已迦提月中作衣时。诸忧婆塞作是念言。此诸比丘自恣已。于迦提月中作衣。我今宜与众僧作食。何以故。恐比丘不能得食疲苦。彼来至僧伽蓝中白诸比丘言。愿诸尊明日受我等请食。诸比丘报言。但请三人食。我等不得别众食。彼优婆塞白诸比丘言。我等诸人各有此念。诸尊自恣竟。于迦提月中作衣。恐诸比丘不能得食疲苦。是故今日请众僧欲饭食。诸比丘复语言。但请三人来。我等不应别众食。尔时诸比丘往白世尊。世尊告言。自今已去听作衣时受别众食。自今已去当如是说戒。若比丘别众食除余时波逸提。余时者病时作衣时是谓余时。如是世尊与诸比丘结戒。尔时有居士。欲施食及衣。来至僧伽蓝中白诸比丘言。我欲施食。愿众僧受我明日食。诸比丘报言。但请三人与食。我等不得别众食。居士言大德。我欲施食及衣。愿受我请。彼比丘言。但请三人。我等不得别众食。尔时诸比丘往白世尊。世尊告言。自今已去听诸比丘受施衣时别众食自今已去当如是说戒。若比丘别众食除余时波逸提。余时者病时作衣时施衣时。如是世尊与比丘结戒。尔时众多比丘。与诸居士往诣拘萨罗国共同道行。乞食时到语诸居士。我欲诣村乞食。小见留待还当共俱。诸居士报言。但逐我去当相与饮食。诸比丘报言。但与三人。我等不得别众食。诸居士白言大德。此道崄难有疑恐怖。但来我当供给饮食。莫在后来汝曹人少。诸比丘言。但与三人。我等不得别众食。时诸比丘即入村乞食。伴便前进比丘在后不及。为贼所劫夺衣服。诸比丘以此因缘具白世尊。世尊。尔时告诸比丘。自今已去若崄道中行听比丘别众食。自今已去当如是说戒。若比丘别众食除余时波逸提。余时者病时作衣时施衣时道行时。如是世尊与诸比丘结戒。尔时有众多比丘。与诸居士乘船顺流而去。乞食时到语居士言。小住船我等欲入村乞食还当共俱。诸居士言。但去我当供给饮食。比丘报言。但与三人我等不得别众食。诸居士言。此岸上多有贼盗有疑恐怖处。汝伴少莫在后为贼劫夺。但去我当供给饮食。诸比丘报言。但与三人。我等不得别众食。诸比丘即上岸乞食。船伴前去。诸比丘后来。悉为贼劫夺衣服。时诸比丘以此因缘具白世尊。世尊告言。自今已去听乘船时别众食。自今已去当如是说戒。若比丘别众食除余时波逸提。余时者病时作衣时施衣时道路行时乘船时。如是世尊与诸比丘结戒。尔时众多比丘。从拘萨罗国游行诣一小村。诸居士念言。众僧多而村落小。我等宁可与众僧作食耶。勿令众僧疲苦。即来至僧伽蓝中白诸比丘言。大德受我明日食。比丘报言。但请三人。我等不得别众食。诸居士言。我等作是念。众僧既多村落又小。恐不得饮食令众僧疲苦耳。比丘报言。但请三人。我等不得别众食。尔时诸比丘往白世尊。世尊告言。自今已去听诸比丘大集时别众食。自今已去当如是说戒。若比丘别众食除余时波逸提。余时者病时作衣时施衣时道行时乘船时大众集时。如是世尊与比丘结戒。尔时瓶沙王姊子名曰迦罗。为诸沙门施食。欲于外道异学中出家。即往至瓶沙王所白言。我已为诸沙门设食已。今欲出家。王问言。欲于何处出家。答言。欲于尼揵子中出家。王复问言。竟与我曹沙门设饮食不。迦罗报言大王。何者是沙门。王告言。沙门释子是。迦罗报言。我竟不与设食。王告言。汝今往与沙门释子设食。即往僧伽蓝中白诸比丘言。我今欲饭比丘僧。愿受我请。诸比丘报言。但与三人。我等不应别众食。时迦罗语诸比丘。我为诸沙门设食。欲于外道中出家。即往瓶沙王所白言。我已为诸沙门设食已。今欲出家。王问我言。欲于何处出家。我答言。欲于尼揵子中出家。王复问我言。与我曹沙门设食未。时我问言大王。何者是沙门。王告我言。沙门释子是。时我报王言。我未与沙门释子设食。王告我言。汝今到彼与沙门释子设食。然后听行。以此事故。来诣僧伽蓝中请诸大德。愿受我请。尔时诸比丘闻是语已往白世尊。佛告诸比丘。自今已去听沙门施食时得别众食。自今已去当如是说戒。若比丘别众食除余时波逸提。余时者。病时作衣时施衣时道行时乘船时大众集时沙门施食时此是时。比丘义如上说。别众食者。若四人若过四人。食者饭糗干饭鱼及肉。病者下至脚跟躄。作衣时者。自恣竟无迦絺那衣一月有迦絺那衣五月。乃至衣上作马齿一缝施衣者。自恣竟无迦絺那衣一月。有迦絺那衣五月。及余所施食及衣。道行者。下至半由旬内有来者有去者。乘船行者。下至半由旬内乘船上下。大众集者。食足四人长一人为患。五人十人乃至百人长一人为患。沙门施食者。在此沙门释子外诸出家者。及从外道出家者是。若比丘无别众食因缘。彼比丘即当起白言。我于此别众食中无因缘欲求出。佛言听出。若余人无因缘亦听使出。若二人若三人随意食。若四人若过四人。应分作二部更互入食。若比丘有别众食因缘欲入。寻即当起白言。我有别众食因缘欲求入。佛言。当听随上座次入。若比丘别众食咽咽一波逸提。若有因缘不说者突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。病时作衣时施衣时道路行时乘船时大众集时沙门施食时。若三人四人更互食。若说有因缘去无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(三十三竟)

尔时佛在舍卫国祇树给孤独园。时有一女名伽若那。先住大村。来至郁禅国中与人作妇。经历数月遂便有娠。即还父母家。有诸比丘来至其家乞食者。身自持食若果施诸比丘。后于异时。其夫遣使呼妇还家。其妇出报使言小留住。我今方欲办具饮食庄严衣服然后共往。时有诸比丘来至其家乞食。时女见之。即复以所办饮食尽施与比丘。白言大德。可食是食。尔时诸比丘尽取食之无有遗余。其妇在后方更庄严。未还之间。其夫已更取妇。遣使语其妇言。我今已更取妇。欲来不来便随卿意。伽若那父闻之。往至僧伽蓝中。诸比丘见已语言。汝女伽若那笃信好喜布施。其父报言。如诸尊言实有笃信。但为今日妇人所不喜者今日得之。诸比丘问言何所得耶。其父报言。其夫已更取妇。尔时波罗奈城门外。众多商贾车伴共止宿。时有一乞食比丘。到时着衣持钵。入此贾客营中乞食。尔时彼比丘以次行乞。渐渐往至一信乐商贾主前默然立住。商主问言。尊今何故在此。比丘报言我乞食。即语言过钵来。时比丘即授钵与。贾客取钵盛满美好饮食与。时乞食比丘持食出营。未远复有一乞食比丘来入车营乞食。问得食比丘。乞食可得不。报言可得。复问从谁得耶。报言从某甲贾客所得。尔时乞食比丘往至贾客前默然而立。贾客问言何故在此。比丘报言我今乞食。贾客语言过钵来。时彼比丘即授钵与。贾客取钵盛满美好饮食授与比丘。比丘得已还出车营。去营未远复有一乞食比丘来诣车营乞食。问言乞食可得不。答言可得。复问从谁得耶。报言从某甲贾客所得。如是相。告乃至令他食尽。时商主方入波罗奈城更市籴粮食。诸伴已去在后不及。道路为贼所劫。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责诸比丘言。云何比丘。食他归妇食商贾道路食具令尽无余。时诸比丘往至世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时集比丘僧呵责诸比丘。汝所为非。非威仪非沙门法非净行非随顺行所不应为。云何诸比丘。食他归妇食商贾道路粮令尽无余。尔时世尊以无数方便呵责彼比丘已告诸比丘。此诸比丘痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘至白衣家请比丘与食若[麩-夫+并]若糗。比丘若须二三钵应受。受已迁至僧伽蓝中分与诸比丘食若过两三钵受。还至僧伽蓝中。不分与诸比丘食者波逸提。如是世尊与诸比丘结戒。尔时诸病比丘。畏慎不敢过受食。往白佛。佛言。自今已去听诸病比丘过受食。自今已去当如是说戒。若比丘至白衣家。请比丘与食若[麩-夫+并]若糗。比丘欲须者当二三钵受。还至僧伽蓝中应分与余比丘食。若比丘无病过两三钵受持。还至僧伽蓝中不分与余比丘食者波逸提。比丘义如上说。白衣家者有男有女。病者不能一处坐食好食竟。若比丘至白衣家请与[麩-夫+并]糗食。当。问其主言。为是归妇食。为是贾客道路粮。若言归妇食贾客道路粮者。即应食已出。还僧伽蓝中白诸比丘。某甲家有归妇食有贾客道路粮。若欲食者食已应出。若欲持食还者齐二三钵。我今不持食来。若欲持一钵食来还至僧伽蓝中与诸比丘共分食之。当语余比丘言。某甲家有归妇食商贾道路粮。若有至彼家者即于彼食。若持食还者应取两钵。我以持一钵还。若持两钵还。应共余比丘分食之。复语诸比丘言。某甲家有归妇食商客道路粮。若欲至彼家乞食者。可即彼家食。欲持来者应取一钵还。我今已持两钵还。若尽持三钵还到僧伽蓝中分与诸比丘共食。白余比丘言。今某甲家有归妇食商贾客道路粮。若欲至彼家乞食者可即于彼家食。若欲持还者慎勿持还。我已持三钵来。若比丘无病。于彼家过两三钵受食。还出彼门波逸提。若一足在门内一足在门外。方便欲去还住者一切突吉罗。若不问归妇食贾客道路粮而取食者突吉罗。若持至僧伽蓝中不分与余比丘而独食者突吉罗。若不语余比丘突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者两三钵受食。病者过受食。问归妇商客道路粮。还至僧伽蓝中分与比丘共食。白余比丘使知村处。若彼自送至僧伽蓝中得受。若复送至比丘尼寺中亦得受无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(三十四竟)

尔时佛在舍卫国祇树给孤独园。尔时世尊。与诸比丘说一食法赞叹一食法。尔时诸比丘。闻世尊说一食法叹誉一食法。时诸比丘。食佉阇尼食。若食五种正食。若饮浆若服药。便当一食更不食。令形体枯燥颜色燋悴。尔时世尊知而故问阿难言。此诸比丘。何故形体枯燥颜色燋悴。阿难白佛言。世尊。无数方便与诸比丘说一食法叹誉一食法。而诸比丘闻已。即一座上啖佉阇尼食。若食五种食。若饮浆若服药便当一食更不食。以是故形体枯燥颜色燋悴。佛告阿难。自今已去听诸比丘于一坐上食令饱满。诸比丘闻世尊听于一坐上食乃至饱满。时诸比丘。若食佉阇尼。若食五种食。若饮浆若服药。便令饱足更不复食。诸比丘形体枯燥颜色燋悴。尔时世尊知而故问阿难言。此诸比丘何故形体枯燥颜色燋悴。尔时阿难白佛言。诸比丘闻世尊听诸比丘于一坐上食乃至饱足。若食佉阇尼。若食五种食。若饮浆若服药。便令饱足更不复食。以是故形体枯燥颜色燋悴。尔时世尊告阿难言。自今已去听诸比丘食五种食。若饭若糗若干饭鱼及肉令饱足。于此五种食中。一一食随所得令饱足。时诸病比丘。虽得好食饭糗干饭鱼及肉。不能一坐食。形体枯燥颜色燋悴。尔时世尊知而故问阿难言。诸病比丘何故形体枯燥颜色燋悴。尔时阿难白世尊言。此病比丘虽得五种食不能一坐食。是故形体枯燥颜色燋悴。佛告阿难。自今已去听诸病比丘数数食。病人无足食法。时诸病比丘。若得好美食。食不能尽。与瞻病人。瞻病人足食已。不敢食便弃之。众鸟竞来诤食鸣唤。世尊知而故问阿难言。何故众鸟鸣唤。阿难白佛言。此诸病比丘得好美饮食。食不能尽。余残与瞻病人。瞻病人足食已不敢食便弃之。是故众鸟诤食鸣唤。佛告阿难。自今已去听瞻病者食病人残食。食病人残食无余食法。尔时诸比丘清旦受食举已入村乞食。食已还取所举食与诸比丘。诸比丘足食已不敢食便弃之。众乌诤食鸣唤。世尊知而故问阿难言。此乌鸟何故鸣唤。阿难白佛言。诸比丘清旦受食。举已入村乞食。食已还持所举食与诸比丘。诸比丘足食已。不敢食便弃之。是故众乌诤食鸣唤。佛告阿难。自今已去听取所受食作余食法应食。作如是余食法言。大德我足食已。知是看是此作余食法。彼比丘应取少许食已语彼比丘言。随意取食。应作如是余食法食。后有一长老多知识比丘入村乞食。大得积聚一处共食。即持余食来至僧伽蓝中与诸比丘。诸比丘足食已。不敢食遂弃之。众鸟诤食鸣唤。尔时世尊知而故问阿难。众鸟何故鸣唤。阿难白佛言。长老多知识比丘入村乞食。大得饮食积聚一处共食。持残食来还与诸比丘。诸比丘足食已。不敢食便弃之。众乌诤食是故鸣唤。佛告阿难。自今已去听诸比丘从彼持食还当作余食法而食之。当作如是余食法言。大德我足食已。知是看是。此作余食法。彼应取少许食已当语彼比丘言。我止汝取食之。彼比丘当作如是余食法食。时舍卫国中有一比丘。贪餮不知足食不足食。不知余食不余食。得便食之。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责彼比丘。云何贪餮。不知足食不足食。不知余食不余食。得便食之。时诸比丘往至世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时集比丘僧。知而故问彼比丘言。汝实尔贪餮不知足食不足食不知余食不余食得便食之耶。答言实尔。佛以无数方便呵责彼比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何比丘贪餮如是耶。世尊呵责已告诸比丘。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘足食竟。或时受请不作余食法。而食者波逸提。比丘义如上说。食者五种食饭糗干饭鱼及肉。于五种食中若食一一食。若饭若糗若干饭若鱼及肉令饱足。有五种足食。知是饭知持来知遮知威仪知舍威仪。足食已舍威仪。不作余食法得而食之。咽咽波逸提。尔时尊者忧波离。即从座起偏露右臂右膝着地合掌白佛言。行比丘有几处应足食。佛告忧波离。有五处应足食。云何为五。忧波离。比丘知行时知饭食知持来知遮知威仪知舍威仪。知足食已舍威仪不作残食法得而食之。咽咽波逸提。是中忧波离。比丘知行时知糗干饭鱼及肉知持来知遮知威仪知舍威仪。足食已舍威仪。不作余食法得而食之。咽咽波逸提。是中忧波离。比丘知行时知糗食知持来知遮知威仪知舍威仪。足食已舍威仪。不作余食法得而食之。咽咽波逸提。是中忧波离。比丘知行时知干饭知鱼及肉饭知持来知遮知威仪知舍威仪。足食已舍威仪。不作余食法得而食之。咽咽波逸提。是中忧波离。比丘知行时知干饭食知持来知遮知威仪知舍威仪。足食已舍威仪。不作余食法得而食之。咽咽波逸提。是中忧波离。比丘知行时知鱼及肉饭糗知持来知遮知威仪知舍威仪。足食已舍威仪。不作余食法得而食之。咽咽波逸提。是中忧波离。比丘知行时知鱼食知持来知遮知威仪知舍威仪足食已舍威仪。不作余食法得而食之。咽咽波逸提。是中忧波离。比丘知行时知肉饭糗干饭知持来知遮知威仪知舍威仪。足食已舍威仪不作余食法得而食之。咽咽波逸提。是中忧波离。比丘知行时知肉食知持来知遮知威仪知舍威仪足食已舍威仪。不作余食法得而食之。咽咽波逸提。是中忧波离。比丘知行时知饭糗干饭鱼知持来知遮知威仪知舍威仪。足食已舍威仪。不作余食法得而食之。咽咽波逸提。忧波离。是为行比丘五处足食。住坐卧亦如是。佉阇尼食者。有根佉阇尼食。枝叶华果佉阇尼食。油胡麻黑石蜜磨细末食。彼比丘足食已。不作余食法得而食之。咽咽波逸提。若足食已为他作余食法不成余食法突吉罗。若知他足食已作余食法不成余食法突吉罗。若比丘自手捉食。作余食法不成余食法突吉罗若持食置地。作余食法不成余食法突吉罗。若比丘使净人持食作余食法不成余食法突吉罗。若比丘净人前作余食法突吉罗。以不好食覆好食上作余食法不成余食法突吉罗。若比丘受他余食法尽持去不成余食法突吉罗。若足食足食想波逸提若足食疑突吉罗。若比丘不足食足食想突吉罗。不足食疑突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。食作非食想不受作余食法。非食不作余食法。自取作余食法。若不置地作余食法。乃至手及处若与他他与已作余食法。若病不作余食法。病人残食不作余食法。若已作余食法。无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(三十五竟)

尔时佛在舍卫国祇树给孤独园。时舍卫国中兄弟二人作比丘一比丘贪餮嗜食。不知足食不足食余食不余食。得而食之。有异比丘语言。未曾有如汝今贪餮嗜食者。不知足食不足食余食不余食得而食之时彼比丘闻此语已心怀恚恨。于异时见彼比丘食已不作余食法。殷勤请与食彼即受食之。贪餮比丘语言。未曾有如汝贪餮。如是不知足食不足食。不知余食不余食。得而食之不知厌足。彼比丘报言。我虽食而未足。彼比丘语言。汝食先已饱足。彼比丘问言。知我足食耶。答言知。彼比丘问言。汝知而故作耶。答言知。尔时彼比丘嫌责此比丘如是言。云何知他比丘足食已。殷勤请与食。欲使他犯戒。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责彼比丘。云何知他足食已。殷勤请与食。欲使他犯戒也。尔时彼比丘往至世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。知而故问彼比丘。汝实知他足食已。殷勤请与食。欲使他犯戒耶。答言实尔世尊。世尊尔时以无数方便呵责彼比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何知他足食已。殷勤请与食。欲使他犯戒耶。尔时世尊。以无数方便呵责彼比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘知他比丘食竟。殷勤请与食长老食是食。以是因缘非余欲令他犯波逸提。如是世尊。与比丘结戒。尔时诸比丘。未知已食未食。不知足食不足食。后乃知已食已足食。或作波逸提忏者。或有畏慎者。佛言。不知者无犯自今已去当如是说戒。若比丘知他比丘足食已。若受请不作余食法。殷勤请与食长老取是食。以是因缘非余欲使他犯戒波逸提。比丘义如上说。食者五种亦如上。请亦有五种亦如上。彼比丘知他比丘足食已不作余食法。殷勤请与食言。长老食是。彼即受食之。咽咽二俱波逸提。若与令食前比丘。不食弃之。与者突吉罗。若比丘与令食。前人受而不食举置。与者突吉罗。若比丘与令食。前人受已转与余人。与者突吉罗。若比丘不作余食法。与前人。前人作余食而食之。与者突吉罗。若与病人食欲令他犯。与者突吉罗。持病人残食与他欲令他犯。与者突吉罗。若作余食法已与他。欲使他犯。与者突吉罗。足食足食想波逸提。足食疑突吉罗。不足食足食想突吉罗。不足食疑突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若先不知足食不足食想。若与令弃而食之。若与令举置而食之。若使令送与人取而食之。若未作余食法。与令作余食法而食之。彼不作余食法而食之。若持病人余食与不令他犯。作余食法与不令他犯不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(三十六竟)

尔时佛在罗阅城耆阇崛山中。尔时罗阅城中人民节会作众伎乐。时难陀跋难陀二释子。到彼看伎难陀跋难陀释子颜貌端正。众人皆共观看。时有一人语众人言。汝等空看视沙门释子。何不供给饮食供养然后瞻看。时众人即与饮食。时难陀跋难陀二释子食讫故看伎。向暮还至耆阇崛山。诸比丘见即问言。汝等何故逼暮行。时难陀跋难陀以此因缘具向诸比丘说。于时日暮迦留陀夷。着衣持钵入罗阅城乞食。天阴闇至。一怀妊妇女家乞食。此妇女持食出门。值天雷电暂见其面。时妇女怖称言。鬼鬼即堕娠。迦留陀夷语言大妹。我非鬼我是沙门释子。妇女恚言。沙门释子宁自破腹不应夜乞食。时迦留陀夷。闻此语已还至僧伽蓝中。以此因缘向诸比丘说。其中有少欲知足行头陀乐学戒知惭愧者。嫌责难陀跋难陀释子及迦留陀夷。云何难陀跋难陀迦留陀夷。非时乞食并观伎乐耶。时诸比丘往世尊所。头面礼足。在一面坐。以此因缘具白世尊。世尊以此因缘集比丘僧。无数方便呵责难陀跋难陀释子及迦留陀夷。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何难陀跋难陀释子及迦留陀夷。非时乞食并观伎乐。世尊以无数方便呵责难陀跋难陀释子及迦留陀夷已告诸比丘。自今已去不得观伎观伎者突吉罗自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘非时受食食者波逸提。比丘义如上。时者明相出乃至日中按此时为法。四天下食亦尔。非时者。从日中乃至明相未出。食者有二种。佉阇尼食如上。蒱阇尼五种食如上。若比丘非时受食食咽咽波逸提。若非时过非时波逸提。七日过七日波逸提。尽形寿药无因缘服者突吉罗。非时非时想波逸提。非时疑突吉罗。非时时想突吉罗。时非时想突吉罗。非时疑突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。时有乞食比丘。见他作黑石蜜中有罽尼。畏慎不敢非时啖。佛言听啖无犯。作法应尔。时有病比丘服吐下药。比丘煮粥熟顷日时已过。应煮麦令皮不破漉汁饮之无犯。若喉中哯出还咽无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(三十七竟)

尔时佛在罗阅城耆阇崛山中。尔时尊者迦罗。在中住常坐禅思惟。若乞食时到。迦罗着衣持钵入罗阅城中乞食。尔时罗阅城中乞食易得。时迦罗作如是念。我今何为日日入城乞食疲苦。我宁可食先得者。食当持还。后即如所念。时诸比丘。于小食大食上不见迦罗。时诸比丘自相谓言。我曹于小食大食上不见迦罗。将不命终耶。不远行耶。不休道耶。不被贼耶。不为恶兽所害耶。不为水所漂耶。后于异时见迦罗。问言。汝昨来何处来。于小食大食上不见汝。我等谓。汝命过。若远行。若罢道。若为恶兽所害。时迦罗以此因缘具向诸比丘说。其中有少欲知足行头陀乐学戒知惭愧者。嫌责迦罗言。云何藏举宿食而食。尔时诸比丘往至世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊以此因缘集比丘僧。知而故问迦罗。汝实举宿食而食耶。答言实尔。尔时世尊以无数方便呵责迦罗。汝所为非。非威仪非沙门法非净行非随顺行所不应为。云何迦罗举宿食而食耶。汝意虽欲少欲知足。后来众生相法而行。世尊呵责迦罗已告诸比丘。此迦罗痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘残宿食而食者波逸提。比丘义如上。宿食者。今日受已至明日。于一切沙门释子受大戒者皆不清净。食有二种。正食非正食。非正食者。根食乃至细末食。正食者。饭糗干饭鱼及肉。若比丘举宿食而食咽咽波逸提。非时过非时食者波逸提。受七日药过七日食者波逸提。尽形寿药无病因缘而服者突吉罗。宿作宿想波逸提。宿疑突吉罗。非宿宿想突吉罗。非宿疑突吉罗比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。宿受食有余。与父母与塔作人与房舍作人计价与食直。后于异时乞食比丘。从作人边乞食得食。钵盂有孔罅食钵中。彼擿洗穿坏如法洗余不出者无犯。若宿受酥油脂用灌鼻。若缩鼻时酥油随唾出。应弃之余无犯无犯者。最初未制戒。痴狂心乱痛恼所缠(三十八竟)

四分律卷第十四四分律卷第十五(初分之十五)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    九十单提法之五

尔时佛在舍卫国祇树给孤独园。尔时舍卫城中有一比丘。作是念。我今宁可常乞食着粪扫衣。彼即如所念便行。尔时舍卫城中诸居士。为命过父母及兄弟姊妹及夫。于四衢道头或门下或河边树下或在石边或在庙中。作饮食祭祀供养。时彼乞食比丘自取食之。诸居士见皆共嫌之。沙门释子不知惭愧犯不与取。外自称言我修正法。如是有何正法。我等为命过父母及兄弟姊妹。作饮食祭祀供养。而取食之。如似我曹故为沙门释子饮食供养置如是处。而我等乃为命过父母及兄弟姊妹故设此饮食祭祀。而自取食之。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责乞食比丘言。云何乞食比丘。舍卫城中诸居士。为命过父母及兄弟姊妹设饭食祭祀供养。而自取食之。尔时诸比丘往至世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊以此因缘集诸比丘僧。以无数方便呵责彼比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何乞食比丘。自取舍卫城居士祭祀饮食而食之。世尊以无数方便呵责彼乞食比丘已告诸比丘。此乞食比丘痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘不受食若药着口中波逸提。如是世尊与比丘结戒。时诸比丘于中生疑。不敢自取杨枝净水。佛言。比丘自取杨枝净水不犯。自今已去当如是说戒。若比丘不受食若药着口中除水及杨枝波逸提。比丘义如上。不与者未受者是。受者有五种受。手与手受。或手与持物受。若持物授手受。若持物授持物受。若遥过物与。与者受者俱知中间无所触碍。得堕手中。是谓五种受。复有五种受食。若身与身受若衣与衣受。若曲肘与曲肘受若器与器受。若有因缘置地与是为五种受食。佉阇尼食者。从根食乃至细末磨食。食者糗饭干饭鱼及肉。奢耶尼食者。酥油生酥蜜石蜜。若比丘不与食自取着口中。除水及杨枝咽咽波逸提。非时过非时食者波逸提。受七日药过七日食者波逸提。尽形寿药无因缘不受而食者突吉罗。不受不受想波逸提。不受疑突吉罗。受作不受想突吉罗。若受有疑突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。取水及杨枝。若不受酥油脂灌鼻与唾俱出。余者不犯。若乞食比丘鸟衔食堕钵中。若风吹堕钵中。欲除去此食乃至一指爪可除去。余者无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(三十九竟)

尔时佛在舍卫国祇树给孤独园。时跋难陀释子。有一商主为檀越。时跋难陀释子。时到着衣持钵。诣彼商贾家作如是言。我今欲得杂食。商贾问言。今有何患乃思此食。报言。无所患苦但意欲得杂食耳。商贾报言。我曹贾客常买卖生活。犹尚不能得杂食。况乃出家人。时乞食比丘闻此语。嫌责跋难陀释子。云何自为身乞求如是美食。时乞食比丘食讫。还至僧伽蓝中。以此因缘向诸比丘说。其中有少欲知足行头陀乐学戒知惭愧者。嫌责跋难陀释子。云何自为身乞如是美食。尔时诸比丘往至世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊以此因缘集比丘僧。无数方便呵责跋难陀释子。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何跋难陀释子。自为身乞求如是美食。世尊以无数方便呵责跋难陀释子已告诸比丘。跋难陀痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若有如是美食乳酪鱼及肉。若比丘如是美食自为身索食者波逸提。如是世尊与比丘结戒。时诸病比丘。闻此语已皆畏慎不敢乞。不敢为病比丘乞。得食已不敢食。佛言自今已去听病比丘乞彼人。亦听为病比丘乞。乞得已听食之。自今已去当如是说戒。若得好美饮食乳酪鱼及肉。若比丘如此美饮食。无病自为身索者波逸提。比丘义如上。美食者乳酪鱼及肉。病者乃至一坐间不堪食竟。若比丘无病自为身乞如此美食食咽咽波逸提。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。病人自乞。为病人乞。乞得而食。或已为彼彼为己。若不乞而得无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(四十竟)

尔时佛将千二百五十弟子。从拘萨罗国游行来至舍卫国。尔时诸檀越供养佛及众僧大得饼食。时世尊告阿难。汝与众僧分此饼阿难即受教。以饼分与众僧。分已故有余在世尊复告阿难。以此余饼与乞人。阿难即受教。人与一饼。时彼乞儿众中。有一裸形外道家女。颜貌端正。时阿难赋饼。饼粘相着。谓是一饼与此女人。此女人即问傍人言。汝得几饼。时彼报言。我得一饼。彼即复还问。汝得几饼。报言。我得二饼。时彼妇女即语此女言。彼与汝私通。何得不与汝二饼也。时阿难闻此语即怀愁忧。诸比丘闻亦复不乐。时彼会中有一梵志。在此食已便向拘萨罗国。道逢一笃信瞻相婆罗门。即问言汝从何来。报言我从舍卫国来。复问。云何舍卫国中。乞求饮食可得不。复可得持行不。报言所索可得。复问言从谁间得耶。报言秃头居士边得。复问何者是秃头居士。报言沙门瞿昙是。婆罗门问言。汝是何人。食他食已发此恶言也。彼婆罗门至僧伽蓝中。如所闻事语诸比丘。时诸比丘以此二因缘具白世尊。世尊尔时以此因缘集比丘僧告言。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘与裸形外道若男若女食者波逸提。如是世尊与比丘结戒。诸余外道等皆有怨言。一二外道有过。我曹复有何过而不得食耶。诸比丘白佛。佛言。自今已去若诸比丘欲与食者。当置地与。若使人与。自今已去当如是说戒。若比丘外道男外道女自手与食者波逸提。比丘义如上。外道者。裸形异学人波私波罗阇者。在此众外出家者是。佉阇尼食者。根食乃至果食油食乃至磨细末食。食者饭糗干饭鱼及肉。若比丘裸形外道若男若女自手与食者波逸提。若与而受者波逸提。与而不受者突吉罗。方便欲与而不与还变悔者一切突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若舍着地与。若使人与。若与父母。与塔作人别房作人。计作食价与。若为力势强夺去无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(四十一竟)

尔时佛在舍卫国祇树给孤独园。时舍卫城中有一豪族长者。与跋难陀释子知旧亲友。彼作如是念言。若跋难陀释子来入此城者。当为跋难陀故饭食众僧。于异时跋难陀释子来入城中。长者闻来至。即遣人诣僧伽蓝中。语诸比丘明日请食。即于其夜办具种种甘馔饮食。明日清旦往白时到。时诸比丘到时着衣持钵。诣长者家就座而坐。诸比丘语长者言。众僧已集。饮食办者可时施设。长者报言。诸尊小留待须跋难陀释子至。诸比丘报言。众僧已集。若饮食已办者便可施设。何须留待日时晚过。恐诸比丘不得具足满食。时长者白诸比丘。我先有誓愿。若跋难陀释子来入此城者。我当为跋难陀释子饭食众僧。愿诸尊小留待跋难陀。尔时跋难陀。小食时乃更诣余家。日时垂欲过方来。时诸比丘见时欲过。虽得饮食竟不满足。其中有少欲知足行头陀乐学戒知惭愧者。嫌责跋难陀释子。云何跋难陀释子。小食时更诣余家。时垂欲过方来。使诸比丘饮食不得满足耶。尔时诸比丘往至世尊所。头面礼足已在一面坐。以此因缘具白世尊。世尊以此因缘集比丘僧。以无数方便呵责跋难陀释子。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何跋难陀释子。小食时到余家时欲过方来。使诸比丘不得满足食耶。世尊以无数方便呵责跋难陀释子已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘先受请。小食时至余家者波逸提。如是世尊与比丘结戒。尔时罗阅城中有一大臣。与跋难陀释子知旧亲友。时彼大臣。于异时大得甘果。即敕一人言。跋难陀释子是我知旧亲友。汝可持此果往至僧伽蓝中示之语言。我与汝知旧。可持此果众僧中分布。时彼使人即持果诣僧伽蓝中。白诸比丘。大德。此是僧新果。诸比丘语言。若与众僧者便可赋之。其人报言。罗阅城中大臣敕我言。汝持此果诣僧伽蓝中。示跋难陀释子令赋与僧。今须跋难陀释子至当赋与僧。时跋难陀后食已方诣余家时过乃还。使众僧不得食新果。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责跋难陀言。云何后食已方诣余家时过乃还。使诸比丘不得食新果也。诸比丘往世尊所。头面礼足已在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责跋难陀释子。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何跋难陀释子。后食已更诣余家时过方还。使诸比丘不得食新果。世尊以无数方便呵责已告诸比丘。自今已去当如是说戒。若比丘先受请。前食后食诣余家者波逸提。如是世尊与诸比丘结戒。尔时罗阅城中众僧大有请处。诸比丘皆畏慎。不敢入城受请。白佛。佛言。自今已去听诸比丘相嘱授入城。比丘不知当嘱授谁。佛言。当嘱授比丘。若独处一房中当嘱授比近住者。自今已去当如是说戒。若比丘先受请已。前食后食诣余家不嘱授者波逸提。如是世尊与诸比丘结戒。时病比丘。先语檀越家作羹作粥作饭。彼畏慎不敢入城。恐犯食后至余家。白佛。佛言。听病比丘不嘱授得入。自今已去应如是说戒。若比丘先受请。前食后食至余家不嘱授余比丘除时因缘波逸提。是中时者病时。如是世尊与比丘结戒。时诸比丘作衣时到。或须大釜或须小釜或须瓶或须杓或须[土*瓦]或须斧或须盂或须盆或须小碗或须铫或须绳或须衣悬或须伊尼延陀或须毛氀。诸比丘皆畏慎不敢入城。恐犯不嘱授入村。白佛。佛言。自今已去听诸比丘作衣时不嘱授入村。自今已去当如是结戒。若比丘先受他请已。前食后食诣余家不嘱授余比丘除余时波逸提。余时者病时作衣时。如是世尊与比丘结戒。时诸比丘施衣时到。或有已得施衣处。或有方当求索。彼畏慎不敢入城。恐犯不嘱授入城。佛言。自今已去听诸比丘布施衣时不嘱授入城。自今已去当如是说戒。若比丘先受请已。前食后食诣余家不嘱授余比丘除余时波逸提。余时者病时作衣时施衣时。是谓余时。比丘义如上。前食者明相出至食时是。后食者从食时至日中是。家者有男子女人所居也。余比丘者同一界共住也。病者如上。作衣时者自恣竟。无迦絺那衣一月。有迦絺那衣五月。乃至衣上作一马齿缝是也。施衣时者。自恣竟。无迦絺那衣一月。有迦絺那衣五月。除此已余时劝化作食并施衣者是也。若比丘嘱授欲诣村。而中道还失前嘱授。后若欲去者当更嘱授。若比丘嘱授欲诣村。不至所嘱授处。乃更诣余家失前嘱授。若欲往应更嘱授而去。若嘱授至白衣家。乃更至库藏处及聚落边房。若至比丘尼僧伽蓝中若即白衣家还出。失前嘱授应更嘱授而往。若比丘先受请已。前食后食诣余家不嘱授比丘入村间除余时波逸提。若一脚在门内一脚在门外方便庄严欲去而不去者一切突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。病时作衣时施衣时嘱授比丘。若无比丘不嘱授至余库藏聚落边房。若至比丘尼僧伽蓝。至所嘱白衣家。若众多家敷坐具请比丘。若为力势所持。或命难梵行难无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(四十二竟)

尔时佛在舍卫国祇树给孤独园。尔时尊者迦留陀夷。本处俗时有同友白衣妇。颜貌端正名曰斋。迦留陀夷亦复颜色端正。时迦留陀夷系意在彼斋忧婆私所。斋忧婆私亦系意在迦留陀夷所。时迦留陀夷到时着衣持钵。往至斋忧婆私家就座而坐。时斋忧婆私洗浴庄严其身。夫主心极爱敬未曾相离。夫主问迦留陀夷言。欲须何等耶。报言。我须食。其夫即语妇言。出食与之。妇即如言与食。迦留陀夷食已坐住不去。其夫语迦留陀夷言。汝向者言须食。已与汝食竟。何以不去耶时斋忧婆私现相令其不去。时彼夫主嗔责迦留陀夷言。比丘妨我。向言须食。食已何故不去。更欲作何等。我今舍汝出去。随汝在后欲何所作。时彼夫主嗔恚作是语已便出去时有乞食比丘来至其家。时乞食比丘复嫌责迦留陀夷言。汝云何在食家中安坐。尔时乞食比丘。还出舍卫城到僧伽蓝中以此因缘向诸比丘说。其中有少欲知足行头陀乐学戒知惭愧者。嫌责迦留陀夷言。汝云何在食家中安坐。尔时诸比丘往至世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊以此因缘集比丘僧。知而故问迦留陀夷言。汝实在食家中安坐耶。对曰实尔。世尊以无数方便呵责迦留陀夷。汝所为非。非威仪非沙门法。非净行非随顺行。所不应为。云何在食家中有宝安坐。尔时世尊以无数方便呵责迦留陀夷已告诸比丘。此愚痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘在食家中有宝强安坐者波逸提。比丘义如上。食者男以女为食女以男为食是名为食。家者如上说。宝者车磲马瑙真珠虎珀金银。若比丘在食家中有宝舒手得及户应坐。若比丘在食家中有宝强安坐者波逸提。盲而不聋者突吉罗。聋而不盲者亦突吉罗。立而不坐者突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若入食家中有宝舒手及户处坐。若有二比丘为伴。若有识别人。或有客人在一处不盲不聋。不聋不盲或从前经过不住。或卒病发倒地。或为力势者所持。或被系闭。或命难或梵行难无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(四十三竟)

尔时佛在舍卫国祇树给孤独园。尔时尊者迦留陀夷。本处俗时有白衣同友妇名曰斋。颜貌端正。迦留陀夷亦颜貌端正。时迦留陀夷系意在斋忧婆私。斋忧婆私亦系意在迦留陀夷所。尔时尊者迦留陀夷。到时着衣持钵。往至斋忧婆私家。自念言。世尊作如是语。食家中有宝不应安坐。应在舒手及户处坐。即便在户扇后坐。时迦留陀夷与斋忧婆私共语。时有乞食比丘来至彼家。闻迦留陀夷语声嫌责言。云何在食家中有宝屏处坐。令我等不知为何所作。时乞食比丘出还舍卫城至僧伽蓝中。以此因缘具白诸比丘。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责迦留陀夷言。云何在食家中有宝屏处坐。诸比丘往至世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。知而故问迦留陀夷。汝审在食家中有宝在屏处坐语耶。答言实尔世尊。世尊尔时以无数方便呵责迦留陀夷。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何在食家中有宝在屏处坐耶。呵责迦留陀夷已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与诸比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘食家中有宝在屏处坐者波逸提。比丘义如上说。食者女是男食男是女食。宝者车磲马瑙真珠虎珀金银。屏处者。若树墙壁篱栅若衣障及余物障。彼比丘入食家中有宝屏处坐。使舒手得及户令乞食比丘见。若比丘食家中有宝在屏处坐者波逸提。盲而不聋突吉罗。聋而不盲突吉罗。立而不坐突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若在食家中有宝坐。舒手得及户使乞食比丘见。若有二比丘为伴。若有识别人在边。或有客人在一处不盲不聋。或从前过不住。或卒病倒地。或力势者所持。或被系闭。或命难或梵行难不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(四十四竟)

尔时佛在舍卫国祇树给孤独园。尔时尊者迦留陀夷。本处俗时有白衣亲友妇名曰斋。颜貌端正。迦留陀夷亦颜貌端正。时迦留陀夷系意在斋优婆私所。斋优婆私亦系意在迦留陀夷所。尔时尊者迦留陀夷到时着衣持钵。往至斋优婆私家。在露地共一处坐语。有一乞食比丘来至其家。见迦留陀夷与斋忧婆私共露地一处坐语。即嫌责尊者迦留陀夷言。云何与斋忧婆私露地共一处坐语耶。时乞食比丘舍卫城中食已。还僧伽蓝中。以此因缘语诸比丘。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责迦留陀夷言云何在斋忧婆私家露地共一处坐语。尔时诸比丘往至世尊所头面礼足在一面坐。以此因缘具白世尊。世尊以此因缘集比丘僧。知而故问迦留陀夷。汝实与斋忧婆私露地共一处坐语耶。答言实尔世尊。尔时世尊以无数方便呵责迦留陀夷。汝所为非非威仪非沙门法非净行非随顺行。所不应为。云何迦留陀夷。在斋忧婆私家露地共一处坐语耶。呵责迦留陀夷已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住欲说戒者当如是说。若比丘独与女人露地坐波逸提。比丘义如上。女人者人女有智命根不断。独者一女人一比丘。屏处者。见屏处闻屏处。见屏处者。若尘雾黑闇不见面。闻屏处者。常语不闻声。彼比丘独与女人露地共一处坐波逸提。若盲而不聋突吉罗。若聋而不盲突吉罗。若立不坐突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。有二比丘为伴。若有识别人在边。或有客人在一处不盲不聋。或从前过不住。或卒病倒地。或为力势所持。或被系闭。或命难或梵行难不犯。不犯者最初未制戒。痴狂心乱痛恼所缠(四十五竟)

尔时佛在舍卫国祇树给孤独园。时跋难陀释子。与余比丘共斗欲求忏悔。跋难陀结恨在心。后于异时跋难陀释子语彼比丘言。汝随我行到村中当与汝食。比丘报言。尔时跋难陀到时着衣持钵。与彼比丘俱入舍卫城中。将至无食处。周回遍行。余有少时在。跋难陀念言。若此比丘出舍卫城至只桓中日时已过。跋难陀语彼比丘言。未曾有汝是大恶人。比丘问言。我作何等过。跋难陀报言。今由汝故并使我不得食。长老速去。我共汝若坐若语不乐。我独坐独语乐跋难陀语彼比丘已。便入舍卫城中有食处而食时彼比丘出舍卫城到祇洹精舍。日时已过不得食乏极。诸比丘闻其中有少欲知足行头陀乐学戒知惭愧者。嫌责跋难陀释子。云何语余比丘言。将汝至聚落与汝食竟不与比丘食便语言汝速去。我共汝若坐若语不乐。我独坐独语乐。遣彼比丘还祇洹中。日时过竟不得食乏极。尔时诸比丘往至世尊所头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧呵责跋难陀释子。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何将余比丘言与汝食竟不与食。便语言汝速去。我共汝若坐若语不乐。我独坐独语乐。使彼比丘入祇洹中。日时过不得食乏极耶。尔时世尊以无数方便呵责跋难陀释子已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘语余比丘如是语。大德共至聚落。当与汝食彼比丘竟不教与是比丘食语言汝去。我与汝一处若坐若语不乐。我独坐独语乐。以此因缘非余方便遣他去波逸提。比丘义如上。村者四种村如上。食者时食。彼比丘语此比丘言。至聚落间与汝食。彼竟不与比丘食。便语言汝去。我与汝若坐若语不乐。我独坐独语乐。彼方便遣去舍见处闻处波逸提。舍见处至闻处突吉罗。舍闻处至见处突吉罗。方便遣去自舍见处闻处波逸提。舍见处至闻处舍闻处至见处突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者与食遣去。若病若无威仪。人见不喜者。语言汝去。我当送食至僧伽蓝中。彼若破戒破见破威仪。若众中所举。若被摈若应摈。若见命难净行难方便遣去。不以嫌恨故遣去不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(四十六竟)

尔时佛在释翅搜迦维罗卫尼拘律园中。尔时摩呵男释种。请众僧供给药。彼恭敬上座施与好者。求者亦与不求者亦与。时六群比丘自相谓言。此摩诃男释种子。请众僧供给药。彼恭敬上座施与好者。于我等无恭敬心。恶者施与我等。求索犹不见与况不求而得。自相谓言。我等当往诣其家求索难得所无有药于是即往诣其家语言。我等须如是如是药。摩诃男报言。若我家中有者当相与。若无者当为诣市求买供给六群比丘报言。汝家可无如是如是药耶。摩诃男报言。我家有者当相与无者当为诣市求索相与。时六群比丘复语言。汝请众僧供给药。恭敬上座与好者。求者与之不求者亦与之。与下座恶者。又不殷勤恭敬。求索而不见与。况不求而得。汝家中所无有。而请众僧与药。汝有爱又复妄语。摩诃男报言。我先有要誓。请众僧家中所有者随供给之。若无者当诣市求索与。汝今云何言。我有爱是妄语人无有至诚耶。长老去。我自今已去不复能供给众僧药也。尔时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。摩诃男释子信乐恭敬供给好药布施常供给众僧药。云何汝等骂詈言。他有爱妄语。使断众僧药耶。尔时诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何摩诃男释子有信心。好乐布施常供给众僧药。而汝等骂詈言。有爱妄语。使断众僧药耶。尔时世尊以无数方便呵责六群比丘已告诸比丘言。此六群比丘痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘应受四月请因缘请与药若过受者波逸提。如是世尊与比丘结戒。时诸病比丘。有畏慎心不敢过受药白佛。佛言。自今已去听诸病比丘过受药。自今已去当如是说戒。若比丘无病受四月请与药过受者波逸提。如是世尊与比丘结戒。时诸居士常请诸比丘与药。诸比丘有畏慎心。不敢受常请供给药白佛。佛言。自今已去听诸比丘受常请供给药。自今已去当如是说戒。若比丘无病受四月请与药若过受除常请者波逸提。如是世尊与比丘结戒。时摩诃男释子复作是念。我宁可以一人二人故断众僧药耶。今故应当更请众僧供给药。作是念已即便至僧伽蓝中。请诸比丘言。愿诸大德僧受我请供给药。诸比丘各各有畏慎心。不敢受更请与药白佛。佛言自今已去听诸比丘受更请给药。诸比丘便计前日数白佛。佛言。不应计前日数应从断药还与已来日从此为数。自今已去当如是说戒。若比丘无病受四月请与药若过受。除常请更请波逸提。如是世尊与比丘结戒。时诸居士请诸比丘与分药。诸比丘畏慎不敢受白佛。佛言。自今已去听诸比丘受分药。自今已去当如是说戒。若比丘无病受四月请与药。若过受除常请更请分请与分药波逸提。如是世尊与比丘结戒。尔时诸居士请比丘与尽形寿药。诸比丘畏慎不敢受尽形寿药白佛。佛言。自今已去听诸比丘受尽形寿药自今已去与比丘结戒。若比丘受四月请与药无病比丘应受请。若过受除常请更请分请尽形寿请波逸提。比丘义如上。四月者夏四月也。因缘者药请也。病者医所教服药者也常请者。其人作如是言。我常与药。更请者。断已后复更与请。与分药者。持药至僧伽蓝中分与尽形寿请者。其人言我当尽形寿与药。请者有四种。或有请夜有限齐药无限齐。或有请药有限齐夜无限齐。或有请药有限齐夜亦有限齐或有请夜无限齐药无限齐。云何请夜有限齐药无限齐。彼作夜分齐不作药分齐我与尔许夜药是谓请夜有分齐药无分齐。云何请药有分齐夜无分齐。彼作药分齐不作夜分齐。作如是言。我与如是药是为请药有分齐。夜无分齐云何请夜有分齐。药亦有分齐。彼作夜分齐药分齐作如是言。尔许夜与如是药。是谓请夜有分齐药有分齐。云何请夜无分齐。药无分齐彼不作夜分齐药分齐。作如是言。我请汝与药。是谓请夜及药俱无分齐。是中请夜有分齐药无分齐。夜有分齐药有分齐。应夏四月受请。是中药有分齐夜无分齐。夜无分齐药无分齐。应随施时受。彼比丘无病应受夏四月与药。若过受除常请更请分请尽形寿请咽咽波逸提。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯不犯者。受四月请与药。病者过受请常请更请分请尽形寿请无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(四十七竟)

尔时佛在舍卫国祇树给孤独园。时王波斯匿土境民人反叛时王自领六军征罚。时六群比丘往至军中观看军阵。时王波斯匿语言。诸尊。在此军中欲何所为。六群报言。我无所作来看军阵耳。时波斯匿王闻已心甚不悦。王复问言。今者欲何所至耶。六群报言。我等欲诣舍卫国见佛。时王语言。若至舍卫国者。持我名礼拜问讯世尊言。起居轻利游步康强教化有劳耶。今持此一裹石蜜奉上世尊。以此因缘具白世尊。尔时六群比丘。即往舍卫国诣只桓精舍。礼世尊足已在一面坐。即称波斯匿王名言。礼拜问讯世尊起居轻利游步康强教化有劳耶。以此一裹石蜜奉上世尊。即以此因缘具白世尊。世尊尔时以此因缘呵责六群比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等痴人。乃观王者军阵势力耶。世尊以无数方便呵责六群比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘往观军阵波逸提。如是世尊与比丘结戒。尔时波斯匿王土境人民反叛。有大臣兄弟二人。兄名利师达。弟名富罗那。王使此二人领军征罚。此二人渴仰欲见比丘。即遣使往请比丘。大德来我欲相见。诸比丘皆有畏慎心言世尊制戒。若比丘往观军阵者波逸提。时诸比丘往白世尊。世尊告言。若须有所白若有请唤者听往。自今已去当如是说戒。若比丘往观军阵除余时因缘波逸提比丘义如上。阵者若戏若斗。军者或一军二军三军四军。一军者。一象军一马军一车军一步军也。若纯有马军纯象军步军车军也。二军者。二象二马二车二步。或有象马或象车或象步或马车或马步或车步也。三军者。三象三马三车三步也。或象马车或象马步或马车步也。四军者。四象四马四车四步也。或象马车步也。彼比丘往观军阵。从道至道。从道至非道。从非道至道。从下至高。从高至下。去而见者波逸提。不见者突吉罗。若方便庄严欲观而不去者一切突吉罗。若比丘先在道行。军阵后至。比丘应下道避若不避者突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若比丘有事往。若被请去。或力势者将去。若先前行军后至下道避。若水陆道断。贼难恶兽难水大涨。若为势力所系缚去。或命难梵行难不下道无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(四十八竟)

尔时佛在舍卫国祇树给孤独园。尔时六群比丘。时有因缘至军中宿。时诸居士见自相谓言。我等为恩爱故在此宿耳。而此沙门复在此何为耶。尔时诸比丘闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。世尊制戒有时因缘乃得至军中。汝等云何乃于军中止宿耶。尔时诸比丘往至世尊所。以此因缘具白世尊。世尊以此因缘集比丘僧。呵责六群比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何六群比丘。有时因缘得至军中。汝等何事乃在军中宿耶。世尊以无数方便呵责六群比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘有因缘听至军中二宿三宿。过者波逸提。比丘义如上。若比丘有因缘欲至军中得二宿住。至第三宿明相未出时应离见闻处。彼比丘军中二宿已。至第三宿明相未出不离见闻处。明相出波逸提。若离见处至闻处突吉罗。离闻处至见处突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。得二宿已至第三宿明相未出离见闻处。若水陆道断。若恶兽难。盗贼难。水大涨。为势力者所执留。或被系闭。或梵行难命难。得至二宿军中住至三宿明相未出不离见闻处不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(四十九竟)

四分律卷第十五四分律卷第十六

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    九十单提法之六

尔时佛在舍卫国祇树给孤独园。尔时六群比丘。闻世尊制戒听比丘有时因缘二宿三宿军中住。彼在军中住。观军阵斗战。观诸方人象马。时六群比丘中有一人。以看军阵故为箭所射。时同伴比丘即以衣裹之舁还。诸居士见已问比丘言。此人何所患耶。报言无患。向往观军阵斗为箭所射。时诸居士皆共讥嫌言。我等为恩爱故兴此军阵。汝等出家人往军中何所作耶。诸比丘闻已。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。世尊制戒听比丘有时因缘至军中应二宿三宿住。汝住军中二宿三宿已。云何乃往观军阵战斗。而为箭所射耶。尔时诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何六群比丘。世尊听比丘有时因缘往军中二宿三宿住。而汝等往军中二宿三宿住。乃观军阵战斗为箭所射耶。尔时世尊以无数方便呵责六群比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘二宿三宿军中住。或时观军阵斗战。若观游军象马力势者波逸提。比丘义如上。斗者。若戏斗若真实斗。军者。一种军乃至四种军。或有王军贼军居士军。力势者。第一象力第一马力第一车力第一步力也。阵者。四方阵或圆阵。或半月形阵。或张甄阵或减相阵。象王马王人王阵。彼比丘往观军阵斗战象马势力者。从道至道。从道至非道。从非道至道。从高至下。从下至高。往而见者波逸提。往而不见者突吉罗。方便庄严欲往。而不往者一切突吉罗。若比丘先在道行。军阵后至应避。不避者突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。有时因缘。若有所白。若请唤。若为势力所将去。或命难。或梵行难。若先前行军阵后至下道避。若水陆道断。盗贼恶兽水大涨。或被强力所执系。或命难净行难不避道无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(五十竟)

尔时佛在支陀国。与大比丘众千二百五十人俱。时尊者娑伽陀。为佛作供养人。尔时娑伽陀。下道诣一编发梵志住处。语梵志言。汝此住处第一房我今欲寄止一宿。能相容止不。梵志答言。我不惜可止宿耳但此中有毒龙恐相伤害耳。比丘言。但见听止。或不害我。编发梵志答言。此室广大随意可住。尔时长老娑伽陀。即入其室自敷草蓐。结跏趺坐系念在前。时彼毒龙。见娑伽陀结加趺坐。即放火烟。娑伽陀亦放火烟。毒龙恚之复放身火。娑伽陀亦放身火。时彼室然如似大火。娑伽陀自念言。我今宁可灭此龙火令不伤龙身耶。于是即灭龙火使不伤害。时彼毒龙火光无色。娑伽陀火光转盛有种种色。青黄赤白绿碧颇梨色。时娑伽陀其夜降此毒龙盛着钵中。明日清旦持往诣编发梵志所语言。所言毒龙者。我已降之置在钵中故以相示。尔时拘睒弥主。在编发梵志家宿。彼作如是念。未曾有。世尊弟子有如是大神力。何况如来。即白娑伽陀言。若世尊来至拘睒弥时。愿见告敕欲一礼觐。娑伽陀报言大佳。尔时世尊从支陀国人间游行至拘睒弥国。时彼国主。闻世尊将千二百五十弟子至此国。即乘车往迎世尊。遥见世尊颜貌端政诸根寂定。其心息灭得上调伏。如调龙象犹若澄渊。见已笃信心生。以恭敬心即下车至世尊所。头面礼足已在一面住。尔时世尊无数方便说法劝化令得欢喜。时拘睒弥主。闻佛无数方便说法劝化。心大欢喜已。顾看众僧不见娑伽陀。即问诸比丘言。娑伽陀今为所在耶。诸比丘报言。在后正尔当至。尔时娑伽陀与六群比丘相随在后至。时拘睒弥主见娑伽陀来。即往迎头面礼足已在一面立。时娑伽陀。复为种种方便说法劝化令心欢喜。时拘睒弥主闻娑伽陀种种方便说法劝化。得欢喜已白言。何所须欲可说之。娑伽陀报言。止止此即为供养我已。彼复白言。愿说何所须欲。六群比丘语彼言。汝知不。比丘衣钵尼师坛针筒此是易得物耳。更有于比丘难得者与之。彼即问言。于比丘何者难得。六群比丘报言。欲须黑酒。彼报言。欲须者明日可来取随意多少。时彼礼娑伽陀足绕已而去。明日清旦。娑伽陀着衣持钵。诣拘睒弥主家就座而坐。时彼拘睒弥主出种种甘馔饮食兼与黑酒极令饱满。时娑伽陀食饮饱足已从座起去。于中路为酒所醉倒地而吐。众鸟乱鸣。尔时世尊知而故问阿难。众鸟何故鸣唤。阿难白佛言。大德此娑伽陀。受拘睒弥主请食种种饮食。兼饮黑酒醉卧道边大吐。故使众鸟乱鸣。佛告阿难。此娑伽陀比丘痴人。如今不能降伏小龙。况能降伏大龙。佛告阿难。凡饮酒者有十过失。何等十。一者颜色恶。二者少力。三者眼视不明四。者现嗔恚相。五者坏田业资生法六者增致疾病。七者益斗讼。八者无名称恶名流布。九者智慧减少。十者身坏命终堕三恶道。阿难是谓饮酒者有十过失也。佛告阿难。自今以去以我为师者。乃至不得以草木头内着酒中而入口。尔时世尊以无数方便呵责娑伽陀比丘已告诸比丘。此娑伽陀比丘痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘饮酒者波逸提。比丘义如上。酒者。木酒粳米酒余米酒大麦酒。若有余酒法作酒者是。木酒者。梨汁酒阎浮果酒甘蔗酒舍楼伽果酒蕤汁酒蒲桃酒。梨汁酒者。若以蜜石蜜杂作。乃至蒲桃酒亦如是杂。酒者。酒色酒香酒味不应饮。或有酒非酒色酒香酒味不应饮。或有酒非酒色非酒香酒味不应饮。或有酒非酒色非酒香非酒味不应饮。非酒酒色酒香酒味应饮。非酒非酒色酒香酒味应饮。非酒非酒色非酒香酒味应饮。非酒非酒色非酒香非酒味应饮。彼比丘若酒酒煮酒和合。若食若饮者波逸提。若饮甜味酒者突吉罗。若饮醋味酒者突吉罗。若食麴若酒糟突吉罗。酒酒想波逸提。酒疑波逸提。酒无酒想波逸提。无酒有酒想突吉罗。无酒疑突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯不犯者。若有如是如是病。余药治不差以酒为药。若以酒涂疮一切无犯无犯者。最初未制戒。痴狂心乱痛恼所缠(五十一竟)

尔时佛在舍卫国祇树给孤独园。尔时十七群比丘。在阿耆罗婆提河水中嬉戏。从此岸至彼岸。或顺流或逆流或此没彼出。或以手画水。或水相浇灒。尔时波斯匿王。与末利夫人在楼观上。遥见十七群比丘。在此河水中嬉戏。从此岸至彼岸。或顺流或逆流。或此没彼出。或以手画水。或以水相浇灒。见已即语末利夫人言。看汝所事者。时末利夫人报王言。此诸比丘。是年少始出家者。在佛法未久。或是长老痴无所知。时末利夫人即疾疾下楼。语那陵迦婆罗门言。汝持我名往至只桓中问讯世尊。游步康强教化有劳耶。以此一裹石蜜奉上世尊。以此因缘具白世尊。时彼婆罗门即受夫人教。往诣世尊所。问讯已在一面坐。那陵迦婆罗门白世尊言。末利夫人故遣我来问讯世尊。游步康强起居轻利教化有劳耶。今奉此一裹石蜜。以向因缘具白世尊。世尊尔时以此因缘集比丘僧。以无数方便呵责十七群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何十七群比丘。在阿耆婆提河水中嬉戏。从此岸至彼岸。或顺流或逆流。或从此没彼出。或以手画水。或水相浇灒。尔时世尊呵责十七群比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘水中嬉戏者波逸提。比丘义如上。水中戏者。放意自恣。从此岸至彼岸。或顺流或逆流。或此没彼出。或以手画水。或水相浇灒。乃至以钵盛水戏弄一切波逸提。除水已若酪浆若清酪浆若苦酒若麦汁。器中弄戏者突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若道路行渡水。或从此岸至彼岸。或水中牵材木。若竹若箄顺流上下。若取石取沙。若失物沉入水底此没彼出。或欲学知浮法。而浮擢臂画水灒水一切无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(五十二竟)

尔时佛在舍卫国祇树给孤独园。尔时六群比丘中有一人。击擽十七群比丘中一人乃令命终。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。云何击擽十七群比丘乃令命终耶。尔时诸比丘往世尊所。头面礼足已在一面坐。以此因缘具白世尊。世尊尔时以是因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何六群比丘。汝等击擽十七群比丘乃令命终耶。世尊以无数方便呵责六群比丘已告诸比丘言。此六群比丘痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘以指相击擽者波逸提。比丘义如上。指者。手有十脚有十。若比丘以手脚指相击擽者一切波逸提。除手脚指已。若杖若户钥若拂柄及一切余物。相击擽者一切突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若不故击擽。若眠触令觉。若出入行来。若扫地误触。误以杖头触无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(五十三竟)

尔时佛在拘睒毗国瞿师罗园中。尔时阐陀欲犯戒。诸比丘谏言。汝莫作此意不应尔。时阐陀不从诸比丘谏即便犯戒。诸比丘闻已。其中有少欲知足行头陀乐学戒知惭愧者。嫌责阐陀言。云何阐陀欲犯戒。诸比丘谏而不从语便犯耶时诸比丘往世尊所。头面礼足已在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责阐陀言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何阐陀。诸比丘谏而不从语便犯戒耶。以无数方便呵责阐陀已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘不受谏者波逸提。比丘义如上。不受谏者。若他遮言莫作是不应尔。然故作犯根本不从语突吉罗。若自知我所作非。然故作犯根本不从语者波逸提。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者若无智人来谏者报言。汝可问汝师和上学问诵经知谏法然后可谏。若谏者当用。若戏笑语若独处语若在梦中语。若欲说此乃错说彼一切无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(五十四竟)

尔时佛在波罗梨毗国。尔时尊者那迦波罗比丘。常侍世尊左右供给所须。佛语那迦波罗。汝取雨衣来。我欲至经行处经行。即受教取雨衣授与世尊。世尊尔时受雨衣已。至经行处经行。尔时释提桓因。化作金经行堂已。合掌在世尊前白言。我世尊经行。我善逝经行。诸佛常法。若经行时。供养人在经行道头立。尔时那迦波罗比丘。在经行道头立。知前夜已过。白世尊言。初夜已过可还入房。尔时世尊默然。时那迦波罗知中夜后夜过明相已出众鸟觉时天欲明了。白世尊言。初中后夜已过。明相出。众鸟觉时天欲明了。愿世尊还入房。尔时世尊默然。时那迦波罗心自念言。我今宁可恐怖佛使令入房耶。尔时那迦波罗即反被拘执。来至佛所作非人恐怖声。沙门我是鬼。世尊报言。当知此愚人心亦是恶。时释提桓因白佛言。众中亦有如此人耶。佛告释提桓因言。众中有如是人。语释提桓因言。此人于此生中当得清净之法。尔时释提桓因。以偈赞佛

  圣独步不放逸　　若毁誉不移动
  闻师子吼不惊　　如风过草无碍
  引导一切诸众　　决定一切人天

尔时世尊。以偈报言

  天帝谓我怖　　故说此言耶

尔时释提桓因。即礼佛足隐形而去。尔时世尊。夜过已清旦集比丘僧。以此因缘具向诸比丘说之。此那迦波罗痴人。乃欲恐怖我。尔时世尊。以无数方便呵责那迦婆罗比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘恐怖他比丘者波逸提。比丘义如上。恐怖者。若以色声香味触法恐怖人。云何色恐怖。或作象形马形。或作鬼形鸟形。以如是形色恐怖人令彼见。若恐怖若不恐怖波逸提。以如是形色恐怖人。前人不见者突吉罗。云何声恐怖人。或贝声鼓声波罗声象声马声驼声啼声。以如是声恐怖人令彼人闻。恐怖不恐怖波逸提。若以如是声恐怖人。彼不闻突吉罗。云何香恐怖人。若根香萨罗树香树胶香皮香肤香叶香花香果香若美香若嗅气若以此诸香恐怖人彼人嗅香若怖以不怖波逸提。若以如是香恐怖人前人不嗅者突吉罗。云何味恐怖人。若以味与人。若醋若甜若苦若涩若碱若袈裟味。以如此味恐怖人令彼人尝味。怖以不怖波逸提。若作如是味恐怖人。彼不尝者突吉罗。云何触恐怖人。若以热若以冷若轻若重若细若粗若滑若涩若软若坚以如是触恐怖人令彼人触。怖以不怖波逸提。以如是触恐怖人。彼人不触者突吉罗。云何以法恐怖人。语前人言。我见如是相。若梦汝当死。若失衣钵若罢道。汝师和上阿阇梨亦当死。失衣钵若罢道。若父母得重病若命终。以如是法恐怖人。彼知怖不怖波逸提。若以如是法恐怖人。彼不知者突吉罗。若比丘以色声香味触法恐怖人。若说而了了者波逸提。说而不了了者突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或闇地坐无灯火或大小便处。遥见谓言。是象若贼若恶兽便恐怖。若至闇室中无灯火处大小便处。闻行声若触草木声若謦咳声而怖畏。若以色示人不作恐怖意。若以声香味触与人不作恐怖意。若实有是事。若见如是相。或梦中见。若当死或罢道若失衣钵。若和上师当死失衣钵罢道。若父母病重当死。便作如是语。语彼言。我见汝如是诸变相事。若戏语若疾疾语若独语梦中语。欲说此乃错说彼一切无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(五十五竟)

尔时佛在罗阅只迦兰陀竹园。中有池水。尔时摩竭国[泳-永+瓦]沙王。听诸比丘。常在池中洗浴时六群比丘。于后夜明相未出时入池洗浴。尔时洴沙王。于后夜明相未出。与婇女俱诣池欲洗浴。闻六群比丘在池洗浴声。即问左右言。此中谁洗浴。答言是比丘。王言莫大作声。勿使诸比丘不及洗浴而去。彼六群比丘。以种种细末药更相洗浴。乃至明相出。时洴沙王竟不得洗浴而去。时诸大臣皆共讥嫌自相谓言。此沙门释子不知惭愧。外自称言我修正法。如此何有正法。于后夜中相将入池水。以种种细末药更相洗浴。乃至明相出。使王竟不得洗浴而去。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。云何于后夜中入池水浴。以种种细末药更相洗浴。乃至明相出。使王不得洗浴。尔时诸比丘往世尊所。头面礼足已在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等于后夜中入池水。以种种细末药更相洗浴。乃至明相出。使王不得洗浴而去。尔时世尊。以无数方便呵责六群比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘半月应洗浴。若过者波逸提。如是世尊与比丘结戒。尔时诸比丘。盛热时身体疱痱出污垢臭秽。畏慎不敢洗浴。恐犯过半月洗浴。诸比丘白佛。佛言。听诸病比丘热时数数洗浴。自今已去应如是说戒。若比丘半月应洗浴除余时。若过波逸提。余时者热时。如是世尊与比丘结戒。其中诸病比丘。身体疱痱出污垢臭秽。或大小便吐污不净。畏慎不敢洗浴。恐犯过半月洗浴。诸比丘白佛。佛言。听诸病比丘数数洗浴。自今已去当如是说戒。若比丘半月应洗浴不得过。除余时波逸提。余时者热时病时。如是世尊与比丘结戒。时诸比丘。作时身体污垢臭秽。诸比丘。有畏慎心不敢洗浴。白佛。佛言。听诸比丘作时数数洗浴。自今已去当如是说戒。若比丘半月洗浴不得过。除余时波逸提。余时者。热时病时作时。如是世尊与诸比丘结戒。时诸比丘。风雨中行。身体疱痱污出尘坌污秽不净。有畏慎不敢洗浴。白佛。佛言。听诸比丘风雨时数数洗浴。自今已去当如是说戒。若比丘半月洗浴不得过。除余时波逸提。余时者。热时病时作时风时雨时。如是世尊与比丘结戒。时诸比丘。道行时身体热疱痱出污垢尘土污秽不净。畏慎不敢洗浴白佛。佛言。听诸比丘道行时数数洗浴。自今已去当如是说戒。若比丘半月洗浴。无病比丘应受不得过。除余时波逸提。余时者。热时病时作时风雨时道行时此是余时。比丘义如上。热时者。春四十五日夏初一月是热时。病者。下至身体臭秽是诸病。作者。下至扫屋前地风雨时者。下至一旋风一渧雨着身。道行者。下至半由旬若来若往者是也。若比丘半月洗浴。除余时若过一遍浇身者波逸提。若水洗半身者波逸提。若方便庄严欲洗浴不去一切突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。半月洗浴。热时病时作时风时雨时道行时数数洗浴。若为力势所持强使洗浴无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(五十六竟)

尔时世尊在旷野城。时六群比丘自相谓言。我等在上座前不得随意言语。即出房外在露地。拾诸柴草及大树株然火向炙。时空树株中有一毒蛇。得火气热逼从树孔中出。诸比丘见已皆惊怖言。毒蛇毒蛇。即取所烧薪散掷东西。迸火乃烧佛讲堂。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。汝等云何自相谓言。我等在上座前不得随意言语。出房外拾诸草木大树株在露地然火向空。树孔中有毒蛇出。惊怖取所烧薪。散掷东西。使迸火乃然佛讲堂耶。尔时诸比丘即往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何六群比丘自相谓言。我等在上座前不得随意言语。出房外拾诸草木大树株。在露地然火向。有毒蛇出。惊怖取所烧薪散掷东西。使迸火烧佛讲堂耶。世尊尔时以无数方便呵责六群比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘。为自炙故露地然火若教人然波逸提。如是世尊与比丘结戒。尔时病比丘。畏慎不敢自然火不教人然。比丘白佛。佛言。听病比丘露地然火及教人然。自今已去当如是说戒。若比丘无病为自炙故露地然火教人然者波逸提。如是世尊与比丘结戒。尔时诸比丘。欲为诸病比丘煮粥若羹饭。若在温室若在厨屋若在浴室中。若熏钵若染衣若然灯若烧香。诸比丘皆畏慎不敢作。佛言。如是事听作。自今已去当如是说戒。若比丘无病。自为炙故在露地然火若教人然。除时因缘波逸提。比丘义如上。病者若须火炙身。若比丘无病。为自炙故在露地然火。若然草木枝叶纻麻刍麻。若牛屎糠粪扫[麩-夫+戈]。一切然者波逸提。若以火置草木枝叶麻纻牛屎糠粪扫[麩-夫+戈]中然者一切波逸提。若被烧半燋掷着火中者突吉罗。若然炭突吉罗。若不语前人言汝看是知是者突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。语前人言看是知是。若病人自然教人然。有时因缘看病人为病人煮糜粥羹饭。若在厨屋中若在温室中若在浴室中。若熏钵若煮染衣汁然灯烧香一切无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(五十七竟)

尔时佛在舍卫国祇树给孤独园。时有居士。请众僧明日食。即于其夜办具种种肥美饮食。明日清旦往白时至。尔时十七群比丘。持衣钵坐具针筒着一面。经行彷佯数望食时到。时六群比丘。伺彼经行背向时。取其衣钵坐具针筒藏举。彼闻白时到。即看言。我等衣钵坐具针筒在此谁持去耶。余比丘问言。汝等何处来。答言。我等在此。持衣钵坐具针筒置一面。经行望食时到。六群比丘在前调弄。余比丘察之。见六群比丘调弄。必是其人取衣钵藏之。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。云何汝等。取十七群比丘衣钵坐具针筒藏之耶。尔时诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何六群比丘。伺十七群比丘经行背向时。取他衣钵坐具针筒藏耶。尔时世尊以无数方便呵责六群比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘。藏比丘衣钵坐具针筒。若自藏若教人藏。下至戏笑者波逸提。比丘义如上。彼比丘藏他比丘衣钵坐具针筒。若教人藏下至戏笑者波逸提。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若实知彼人物相体悉而取举。若在露地为风雨所漂渍取举。若物主为性慢藏。所有衣钵坐具针筒放散狼藉。为欲诫敕彼故而取藏之。若借彼衣着。而彼不收摄。恐失便取举之。或以此衣钵诸物故。有命难梵行难。取藏之一切无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(五十八竟)

尔时佛在舍卫国祇树给孤独园。尔时六群比丘。真实施亲厚比丘衣已。后不语主还取着。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。云何汝等。先持衣施亲厚比丘已。后不语主还取着耶。尔时诸比丘往世尊所。头面礼足已在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何六群比丘。先持衣施亲厚比丘已。后不语主还自取着耶。尔时世尊。以无数方便呵责六群比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘与比丘比丘尼式叉摩那沙弥沙弥尼衣。后不语主还取著者波逸提。比丘义如上。衣者有十种如上说。与衣者净施衣。净施衣有二种。一者真实净施。二者展转净施。真实净施者。言此是我长衣未作净。今为净故与长老。作真实净故。展转净施者此是我长衣未作净。今为净故与长老。彼应如是语。长老听。长老有如是长衣未作净。今与我为净故。我便受。受已当问言。欲与谁耶。应报言。与某甲。彼应作如是语。长老有如是长衣未作净。今与我。为净故我便受。受已与某甲比丘。此衣是某甲所有。汝为某甲故。守护持随意用。是中真实净施者。应问主然后取着。展转净施者。语以不语随意取着。若比丘。真实净施衣不语主。而取著者波逸提。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若真实净施语主取着。展转净施者。语以不语取着无犯。无犯者最初未制戒。痴狂心乱痛恼所缠(五十九竟)

尔时世尊在舍卫国祇树给孤独园。时六群比丘着白色衣行。时诸居士见皆共讥嫌。此沙门释子不知惭愧受取无厌。外自称言我修正法。如今观之有何正法。云何着新白色衣行。如似王王大臣。诸比丘闻已。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。云何汝等。着白色新衣行尔时诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何六群比丘着白色衣行。尔时世尊以无数方便呵责六群比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘得新衣应三种坏色。一一色中随意坏。若青若黑若木兰若比丘不以三种坏色。若青若黑若木兰。着余新衣者波逸提。比丘义如上。新者。若是新衣。若初从人得者。尽名新也。衣者。有十种衣如上。坏色者。染作青黑木兰也。彼比丘得新衣。不染作三种色青黑木兰。更着余新衣者波逸提。若有重衣不作净而畜者突吉罗。若轻衣不作净者突吉罗。若非衣钵囊革屣囊针綖囊禅带腰带帽袜摄热巾裹革屣巾。不作净畜者突吉罗。若以未染衣寄着白衣家突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若得白衣。染作三种色青黑木兰。若重衣作净畜。若轻衣亦作净畜。若非衣钵囊。乃至裹革屣巾。皆作净畜。若染衣寄着白衣家。若衣色脱更染无犯无犯者。最初未制戒。痴狂心乱痛恼所缠(六十竟)

尔时佛在舍卫国祇树给孤独园。尔时尊者迦留陀夷。不喜见乌。作弓射乌。射之不已。大杀众乌。僧伽蓝中遂成大积。时诸居士。来入僧伽蓝礼拜。见此大积死乌。各共嫌之。自相谓言。沙门释子不知惭愧。无有慈心杀众生命。外自称言我修正法。如今观之何有正法。射杀众乌乃成大积。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责迦留陀夷言。云何汝射杀众乌乃成大积耶。时诸比丘往世尊所。头面礼足已在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。知而故问迦留陀夷。汝实不喜见乌。而以竹弓射杀众乌而成大积不。答曰实尔。尔时世尊。以无数方便呵责迦留陀夷。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何迦留陀夷射杀众乌以成大积耶。呵责迦留陀夷已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘断畜生命者波逸提。如是世尊与比丘结戒。时诸比丘。坐起行来多杀细小虫。中或有作波逸提忏。或有畏慎者。诸比丘往白佛。佛言。不知者不犯。自今已去当如是说戒。若比丘故杀畜生命者波逸提。比丘义如上。畜生者。不能变化者断其命。若自断若教人断。若遣使若往来使杀。若重使杀。若展转遣使杀。若自求使。若教人求使。若自求持刀人。教人求持刀人。若以身相。若口语若身口。若遣使教。若遣书教。若遣使书教。若安坑陷杀。若安刀着常所倚住处。若毒药若安杀具在前。作如是方便。若复有余所欲杀畜生。若杀者波逸提。方便欲杀而不杀突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。不故杀。或以瓦石刀杖掷余处。而误断命。若比丘经营作房舍。手失瓦石而误杀。若土墼材木。若屋柱栌栋椽。如是手捉不禁堕而杀者。若扶病起而死。或还卧而死。若洗浴时死。若服药时死。将入房时死。将出房时死。或将日中坐时死。或在荫处而死。作如是众多事。无有害心而死者无犯无犯者。最初未制戒痴狂心乱痛恼所缠(六十一竟)

尔时世尊在舍卫国祇树给孤独园。时六群比丘取杂虫水而饮用。诸居士见已皆嫌责言。此沙门释子无有慈心杀害虫命。外自称言我修正法。如今观之何有正法。乃取杂虫水用。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。云何汝等。无有慈心乃饮虫水以害其命耶。尔时诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等。饮用杂虫水以害其命耶。尔时世尊。以无数方便呵责六群比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘饮用杂虫水者波逸提。如是世尊与比丘结戒。尔时诸比丘。不知有虫无虫。后乃知。或作波逸提忏。或有畏慎者。白佛。佛言。不知者无犯。自今已去当如是说戒。若比丘知水有虫饮用者波逸提。比丘义如上。彼比丘知是杂虫水饮用者波逸提。除水已若杂虫浆苦酒清酪浆清麦汁饮用波逸提。有虫水有虫想波逸提。有虫水疑突吉罗。无虫水有虫水想突吉罗。无虫水疑突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。先不知有虫无虫想。若有粗虫触水使去。若漉水饮者无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(六十二竟)

四分律卷第十六四分律卷第十七(初分之十七)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    九十单提法之七

尔时佛在舍卫国祇树给孤独园。尔时十七群比丘往语六群比丘。长老。云何入初禅第二第三第四禅。云何入空无相无愿。云何得须陀洹果斯陀含果阿那含果阿罗汉果耶。时六群比丘报言。如汝等所说者。则已犯波罗夷法非比丘。时十七群比丘。便往上座比丘所问言若有诸比丘作如是问。云何入初禅二禅乃至四禅空无相愿须陀洹乃至阿罗汉果。为犯何罪。上座比丘报言无所犯十七群比丘言。我等向者诣六群比丘所问言。云何入初禅乃至四禅空无相愿云何得须陀洹果乃至阿罗汉果。彼即报言。汝等自称得上人法。犯波罗夷非比丘。彼比丘即察知。此六群比丘与十七群比丘作疑恼。尔时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘。云何汝等。与十七群比丘作疑恼。尔时诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等与十七群比丘作疑恼。尔时世尊。以无数方便呵责六群比丘已告诸比丘。此六群比丘痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘与他作疑恼波逸提。如是世尊与比丘结戒。尔时众多比丘。集在一处共论法律。有一比丘退去。退去者心疑作是言。彼诸比丘与我作疑。诸比丘白佛。佛言。不故作者无犯。自今已去当如是结戒。若比丘故疑恼他比丘。令须臾间不乐者波逸提。比丘义如上。疑恼者。若为生时若为年岁若受戒若为羯磨若为犯若为法也。为生时疑者。即问言。汝生来几时耶。报言。我生来尔所时。语言。汝不尔所时生。汝如余人生。非尔所时生。是谓问生时疑。云何问年岁时生疑。问言汝几岁。报言我尔所岁。语言汝非尔所岁。如余人受戒者。汝未尔所岁。是谓问年岁时生疑。云何问受戒生疑。问言。汝受戒既年不满二十。又界内别众。是谓问受戒时生疑。云何问羯磨生疑。问言。汝受戒时白不成。羯磨不成。非法别众。是谓问羯磨生疑。云何于犯生疑。语言。汝犯波罗夷僧伽婆尸沙波逸提波罗提提舍尼偷兰遮突吉罗恶说。是谓于犯生疑。云何于法生疑。汝等所问法者。则犯波罗夷非比丘。是谓于法生疑。若比丘。故为比丘作疑。若以生时若岁时乃至法时疑。说而了了者波逸提。说而不了了者突吉罗。比丘尼。波逸提式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。其事实尔不故作。彼非尔许时生。恐后有疑悔。无故受他利养受大比丘礼敬。便语言。汝非如许时生。如余人生。知汝非如许时生。其事实尔。彼无尔许岁。恐后有疑悔。无故受他利养受大比丘礼敬。便语言。汝无尔许岁。如余比丘岁。汝未如许岁。其事实尔。若年不满二十。界内别众。恐后有疑悔。无故受他利养受大比丘礼敬。语令彼知。还本处更受戒。故便语言。汝年不满二十界内别众。其事实尔。白不成羯磨不成非法别众。恐后有疑悔。无故受他利养受大比丘礼敬。语彼令知。还本处更受戒。故便语言。汝白不成羯磨不成就非法别众。其事实尔。犯波罗夷僧伽婆尸沙波逸提波罗提提舍尼偷兰遮突吉罗恶说。恐后疑悔。无故受人利养受持戒比丘礼敬欲令彼知如法忏悔故便语言。汝犯波罗夷乃至恶说有。复若彼为性粗疏不知言语。便言。如汝所说自称上人法。犯波罗夷非比丘行。或戏笑语或疾疾语或独语或梦中语。或欲说此错说彼无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(六十三竟)

尔时佛在舍卫国祇树给孤独园。时跋难陀释子与一比丘亲厚。然跋难陀释子数数犯罪。向彼比丘说。长老。我实犯如是如是罪。汝勿语人。彼比丘报言可尔。复于余时跋难陀释子。与彼比丘共斗。时彼比丘向余比丘说。跋难陀释子犯如是如是罪。诸比丘问彼比丘言。汝云何知耶。比丘报言。跋难陀释子向我说。诸比丘问言。汝何不向余比丘说耶。彼比丘报言。我先忍便不说。今不忍故说。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责彼比丘言。云何汝等。覆藏跋难陀释子罪。尔时诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责彼比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何比丘覆跋难陀释子罪耶。尔时世尊。以无数方便呵责彼比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘覆藏余比丘粗罪波逸提。如是世尊与比丘结戒。彼比丘不知犯粗罪不犯粗罪后。乃知粗罪。或有作波逸提忏者。有疑者。佛言不知无犯。自今已去应如是结戒。若比丘知他比丘犯粗罪覆藏者波逸提。比丘义如上。粗罪者。四波罗夷僧伽婆尸沙。彼比丘知他比丘犯粗罪。小食知食后说者突吉罗。食后知至初夜说突吉罗。初夜知至中夜说突吉罗。中夜知至后夜。欲说而未说。明相出波逸提。除粗罪覆余罪者突吉罗。自覆藏粗罪突吉罗。除比丘比丘尼覆余人粗罪突吉罗。粗罪粗罪想波逸提。粗罪疑突吉罗。非粗罪粗罪想突吉罗。非粗罪疑突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。先不知粗罪不粗罪想若向人说。或无人可向说。发心言我当说。未说之间明相已出。若说或有命难梵行难不说无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(六十四竟)

尔时世尊在罗阅城迦兰陀竹园。尔时罗阅城中有十七群童子。先为亲厚。最大者年十七。最小者年十二。最富者八十百千。最贫者八十千。中有一童子名优波离。父母唯有此一子。爱念未曾离目前。父母念言。我等教此儿当学何技术。我等死后令快得生活无所乏短。即自念。当教先学书。我等死后快得生活。无所乏短不令身力疲苦。复作是念。教儿书亦有身力疲苦耳。更当学何技术。我等死后令儿快得生活。无所乏短身力不疲苦。念言。今当教儿学算数技术。我等死后快得生活。无所乏短身不疲苦。父母念言。今教儿学算数。亦有身力疲苦耳。今当更教此儿学何技术。我等死后令快得生活无所乏短身力不疲苦。今当教此儿学画像技术。我等死后令快得生活无所乏短。复念。今教学画。恐令儿眼力疲劳。当教此儿更学何技术。我等死后令快得生活无所乏短眼不疲苦。即自念言。沙门释子善自养身安乐无众苦恼。若当教此儿于沙门释子法中出家为道。我等死后令快得生活。无所乏短身不疲苦。后于异时。十七群童子语优波离童子言。汝可随我等出家为道。答言。我何用出家为。汝自出家。十七群童子第二第三语优波离言。可共出家为道来。何以故。如我等今共相娱乐。于彼亦当如是共相娱乐嬉戏。时优波离童子语诸童子言。汝等小待须我往白父母。优波离童子即往父母所白言。我今欲出家为道。愿父母见听。父母报言。我等唯有汝一子。心甚爱念。乃至不欲令死别。而况当生别。优波离童子如是再三白父母言。唯愿听我出家。父母亦如是报言。我等唯有汝一子。心甚爱念。不欲令死别况当生别。尔时父母得优波离童子再三殷勤。便作是念。我等先已有此意。当教此儿学何技术。我等死后令儿快得生活。无所乏短。令身力不疲苦耳。即作是念。若教学书乃至画像。我等死后快得生活。无所乏短令身力不疲苦。而恐劳儿身力眼力以致疲苦。念言。唯有沙门释子。善自养身无众苦恼。若令此儿在中出家者。快得生活无有众苦。时父母即报儿言。今正是时。听汝出家。时优波离童子还至十七群童子所语言。我父母已听我出家。汝等欲去者今正是时。时诸童子即往僧伽蓝中白诸比丘言。大德。我等欲出家学道。愿诸尊见度为道。尔时诸比丘即度令出家受大戒。时诸童子小来习乐不堪一食。至于夜半患饥高声大唤啼哭言。与我食来与我食来。诸比丘语言。小儿待须天明。若众僧有食当共食。若无食者当共乞食。何以故。此间先都无作食处。尔时世尊。夜时在静处思惟。闻小儿啼声。知而故问阿难。何等小儿夜半啼声。尔时阿难以此因缘具白世尊。世尊告阿难。不应授年未满二十者大戒。何以故。若年未满二十者。不堪忍寒热饥渴暴风蚊虻毒虫。及不忍恶言。若身有种种苦痛不能堪忍。又复不堪持戒。不堪一食。阿难当知。年满二十者。堪忍如上众事。尔时世尊夜过已集比丘僧。以此因缘告诸比丘。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘年满二十当受大戒。若年未满二十受大戒。此人不得戒。彼比丘可呵责痴故波逸提。如是世尊与比丘结戒。彼比丘不知年满二十不满二十。后乃知不满二十。或作波逸提忏者。或有疑者。佛言。不知者无犯。自今已去当如是结戒。年满二十应受大戒。若比丘知年不满二十与受大戒此人不得戒。彼比丘可呵痴故波逸提。比丘义如上。其受戒人年不满二十。和上知年不满二十。众僧及受戒人亦知不满二十。于众中问。汝年满二十。未受戒人报言。或满二十。或不满二十。或疑。或不知年数。或默然。或众僧不问。和上波逸提。众僧突吉罗。其受戒人年未满二十。和上知年未满二十。众僧及受戒人谓年满二十。众僧问。汝年满二十。未受戒人报言。或满二十或不满。或疑或不知或默然。僧或不问。和上波逸提。众僧无犯。其受戒人年未满二十。和上知年未满二十。众僧及受戒人疑。众中问言。汝年满二十。未受戒人报言。或满二十或不满二十。或疑或不知或默然。僧或不问。和上波逸提。众僧突吉罗。其受戒人年未满二十。和上亦知年未满二十。众僧及受戒人不知。众中问言。汝年满二十。未受戒人报言。或满二十或不满二十。或疑或不知或默然。僧或不问。和上波逸提。众僧无犯。其受戒人年未满二十。和上谓年满二十。众僧及受戒人知年未满二十。众中问言。汝年满二十。未受戒人报言。或满二十或不满二十。或疑或不知或默然。僧或不问。和上无犯。众僧突吉罗。其受戒人年未满二十。和上谓年满二十。众僧及受戒人谓年满二十。众中问言。汝年满二十。未受戒人报言。或满二十或未满二十。或疑或不知或默然。僧或不问。和上无犯。众僧亦无犯。其受戒人年未满二十。和上谓年满二十。众僧及受戒人疑。众中问言。汝年满二十。未受戒人报言。或满二十或不满二十。或疑或不知或默然。众或不问。和上无犯。众僧突吉罗。其受戒人年未满二十。和上谓年满二十。众僧及受戒人不知。众中问言。汝年满二十。未受戒人报言。或满二十或不满二十。或疑或不知或默然。众僧或不问。和上及众僧无犯。其受戒人年未满二十。和上疑。众僧及受戒人知不满二十。众中问言。汝年满二十。未受戒人报言。或满二十或不满或疑或不知或默然。众或不问。和上波逸提。众僧突吉罗。其受戒人年未满二十。和上疑。众僧及受戒人谓年满二十。众中问言。汝年满二十。未受戒人报言。或满或未满或疑或不知或默然。众或不问。和上波逸提。众僧无犯。其受戒人年未满二十。和上疑。众僧及受戒人亦疑。众中问言。汝年满二十。未受戒人报言或满二十。或未满或疑或不知或默然。众或不问。和上波逸提。众僧突吉罗。其受戒人年未满二十。和上疑。众僧及受戒人不知。众中问言。汝年满二十。未受戒人报言。或满二十或未满或疑或不知或默然。众或不问。和上波逸提。众僧无犯。其受戒人年未满二十。和上不知。众僧及受戒人知年未满二十。众中问言。汝年满二十。未受戒人报言。或满二十或未满二十。或疑或不知或默然。众或不问。和上无犯。众僧突吉罗。其受戒人年未满二十。和上不知。众僧及受戒人谓年满二十。众中问言。汝年满二十。未受戒人报言。或满二十或未满或疑或不知或默然。众或不问。和上及众僧无犯。其受戒人年未满二十。和上不知。众僧及受戒人疑。众中问言。汝年满二十。未受戒人报言。或满二十或未满。或疑或不知或默然众或不问。和上无犯。众僧突吉罗。其受戒人年不满二十。和上不知。众僧及受戒人亦不知。众中问言。汝年满二十。未受戒人报言。或满二十或未满。或疑或不知或默然。众或不问。和上众僧无犯。彼比丘知年未满二十。授大戒三羯磨竟。和上波逸提。白已二羯磨竟。和上三突吉罗。白已一羯磨竟。和上二突吉罗。白竟和上一突吉罗。白未竟和上突吉罗。若未白为作方便剃发。若欲集众和上一切突吉罗。若众僧集和尚突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。先不知信受戒人语。若傍人证。若信父母。若受戒已疑。佛言。当听数胎中年月数闰月。若数一切十四日说戒以为年数者无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(六十五竟)

尔时佛在舍卫国祇树给孤独园。时六群比丘。斗诤如法灭已。后更发起作是言。汝不善观不成观。不善解不成解。不善灭不成灭。令僧未有诤事而有诤事起。已有诤事而不除灭。时诸比丘作如是念言。何故众僧未有诤事而有诤事起。已有诤事而不除灭。时诸比丘即观察。知六群比丘诤事如法灭已后更发起。作如是言。汝不善观不成观。不善解不成解。不善灭不成灭。令僧未有诤事而有诤事起。已有诤事而不除灭。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。汝等云何。斗诤事如法灭已。后更发起言。汝不善观不成观乃至不成灭。令僧未有诤事而有诤事。已有诤事而不除灭。时诸比丘往至世尊所。头面礼足已在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何斗诤事如法灭已。后更发起言。汝等不善观不成观。乃至不成灭。令僧未有诤事而有诤事。已有诤事而不除灭。世尊以无数方便。呵责六群比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘斗诤如法灭已。后更发起者波逸提。如是世尊与比丘结戒。尔时诸比丘。不知诤事如法灭不如法灭。后乃知如法灭。或有作波逸提忏者。或有疑。佛言。不知者无犯。自今已去当如是结戒。若比丘知诤事如法忏悔已。后更发起者波逸提。比丘义如上。如法者。如法如毗尼如佛所教。诤者有四种。言诤觅诤犯诤事诤。彼比丘知诤事如法灭已。后更发起作如是言。不善观不成观。不善解不成解。不善灭不成灭。说而了了者波逸提。不了了者突吉罗。除此诤已。若作余斗诤骂詈者后更发起一切突吉罗。若自发起已斗诤事者突吉罗。除比丘比丘尼已。共余人斗诤骂詈后更发起者突吉罗。观作观想者波逸提。观疑者突吉罗。不成观有观想突吉罗。不成观疑突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若先不知。若观作不观想。若事实尔。不善观不成观。不善解不成解。不善灭不成灭。便作是言。不善观乃至不善成灭。若戏笑语若疾疾语若梦中语。欲说此错说彼无犯无犯者。最初未制戒。痴狂心乱痛恼所缠(六十六竟)

尔时佛在舍卫国祇树给孤独园。有众多比丘。从舍卫国欲至毗舍离。时有贾客伴。欲私度关不输王税。时贾客问诸比丘言。大德。欲何所至。比丘报言。欲至毗舍离。贾客人言。我等可得与诸尊共伴不。诸比丘报言可尔。尔时诸比丘。与此贼贾客共伴行私度关。时守关人捉得已。即将至波斯匿王所。白王言。此人等。私度关而不输税。王即问言。此贾客私度关不输税。此沙门复有何事。守关人报言。与此人为伴。王复问诸比丘言。大德。实与此贾客为伴耶。报言实尔。复问言。诸尊。知此人不输王税不。报言知。王言。若实知者法应死。时王自念言。我今作水浇顶王种。岂当杀沙门释子耶。时王无数方便呵责诸比丘已。于众人前即敕傍人。放比丘令去。受教即放。时王众中皆大声称言。沙门释子犯王重法。罪应入死。然王直小小呵责而放。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘。汝等云何与贼贾客共伴行。尔时诸比丘往至世尊所。头面礼足已在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧呵责诸比丘言。汝等云何与贼贾客共伴行耶。以无数方便呵责诸比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘共贼伴同道行乃至一村间者波逸提。如是世尊与比丘结戒。诸比丘不知是贼。以非贼共伴行。后乃知是贼伴。或有作波逸提忏者。或有疑者。佛言。不知者不犯。自今已去当如是说戒。若比丘知是贼伴共同道行乃至一村间波逸提如是世尊与比丘结戒。彼比丘不结要疑。佛言。不结要不犯。自今已去应如是结戒。若比丘知贼伴结要共同道行。乃至一村间波逸提。比丘义如上。贼伴者。若作贼还。若方欲去。结要者。共要至城若至村。道者。村间处处道。若比丘。知是贼伴共要同道行。至村间向处处道行。至一一道波逸提。无村空旷无界处。共行至十里者波逸提。若共行村间半道突吉罗。减十里突吉罗。村间一道行者突吉罗。方便欲去而不去。共要去而不去。一切突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若先不知不共结伴。若逐行安隐有所至。若为力势所持。若被系缚将去。若命难梵行难无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(六十七竟)

尔时佛在舍卫国祇树给孤独园。尔时有比丘。字阿梨吒。有如是恶见生。我知世尊说法其有犯淫欲非障道法。时诸比丘闻。阿梨吒比丘有如是恶见生。我知世尊说法犯淫欲非障道法。时诸比丘闻。欲除去阿梨吒比丘恶见。即往阿梨吒所。恭敬问讯已在一面坐。诸比丘语阿梨吒比丘言。汝实知世尊说法犯淫欲非障道法耶。阿梨吒报言。我实知世尊说法。犯淫欲非障道法。时诸比丘。欲除阿梨吒恶见。即殷勤问之。阿梨吒。莫作如是语。莫谤世尊。谤世尊者不善。世尊不作是语。阿梨吒。世尊无数方便说法。教断欲爱知欲想。教除爱欲断爱欲想。除爱欲所烧。度于爱结。世尊无数方便说。欲如大火坑。欲如炬火。亦如果熟。欲如假借。欲如枯骨。欲如段肉。如梦所见。欲如利刀。欲如新瓦器盛水置日中。欲如毒蛇头。欲如捉利剑。欲如利戟。世尊作如是说欲。阿梨吒。世尊如是善说法。断欲无欲去垢无垢。调伏渴爱灭除巢窟。出离一切诸结缚。爱尽涅槃。佛如是说法。汝云何言犯淫欲非障道法。时诸比丘殷勤问阿梨吒如是说时。阿梨吒比丘坚持恶见。实定而言。此是真实余皆虚妄。尔时诸比丘。不能除阿梨吒比丘恶见。便往世尊所头面礼足已在一面坐。以此因缘具白世尊世尊尔时告一比丘。汝持我言往速唤阿梨吒比丘来。彼比丘受教。即往阿梨吒比丘所语言。世尊有教唤汝。时阿梨吒比丘闻世尊唤。即往世尊所头面礼足在一面坐。佛问阿梨吒比丘言。汝实有是语。我知佛所说法行淫欲非障道法耶。阿梨吒答言大德。实有如是言佛告阿梨吒。汝云何知我所说如是。我无数方便说断欲爱法如上所说。尔时世尊。以无数方便呵责阿梨吒比丘已告诸比丘。听众僧为阿梨吒比丘作呵谏。舍此事故。白四羯磨呵谏。应如是谏。众中应差堪能羯磨者。如上作如是白。大德僧听。此阿梨吒比丘作如是语。我知佛所说法行淫欲非障道法。若僧时到僧忍听。僧今与阿梨吒比丘作呵谏。舍此事故阿梨吒汝。莫作是语。莫谤世尊。谤世尊者不善。世尊不作是语。世尊无数方便说淫欲是障道法。若犯淫欲即是障道法白如是。大德僧听此阿梨吒比丘作如是语。我知佛所说法犯淫欲非障道法。僧今与作呵谏。舍此事故。阿梨吒。莫作是语。莫谤世尊。谤世尊者不善。世尊不作是语。世尊无数方便说淫欲是障道法。若犯淫欲即是障道法。谁诸长老忍。僧为阿梨吒比丘作呵谏。舍此事者默然。谁不忍者说。是初羯磨。第二第三亦如是说。僧已为阿梨吒比丘作呵谏竟。僧忍默然故。是事如是持。应作如是呵责阿梨吒比丘。舍此事故白四羯磨。诸比丘白佛。佛言。若有余比丘作是言。我知佛所说行淫欲非障道法。众僧亦应呵谏白四羯磨。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘作如是语。我知佛所说法行淫欲非障道法。彼比丘谏此比丘言。大德。莫作是语莫谤世尊。谤世尊者不善。世尊不作是语。世尊无数方便说行淫欲是障道法。彼比丘谏此比丘时坚持不舍。彼比丘乃至三谏。舍此事故。若三谏舍者善。不舍者波逸提。比丘义如上。彼比丘作如是言。我知佛所说法行淫欲非障道法。彼比丘谏此比丘言。汝莫作是语莫谤世尊。谤世尊者不善。世尊不作是语。世尊无数方便说行淫欲是障道法。汝今可舍此事。莫为僧所呵更犯重罪。若受语者善。不随语者应白。白已当语言。我已白竟。余有羯磨在。汝可舍此事。莫为众僧所呵责更犯重罪。若随语者善。不随语者当作初羯磨。初羯磨已当语言。我已白初羯磨竟余有二羯磨在。汝当舍是事。莫为僧所呵责更犯重罪。若随语者善。不随语者当作第二羯磨。作第二羯磨已当语言。已作白二羯磨竟。余有一羯磨在。汝可舍是事。莫为众僧所呵责更重犯罪。若随语者善。不随语者唱三羯磨竟波逸提。作白已二羯磨竟舍者三突吉罗。作白已一羯磨竟舍者二突吉罗。白已舍者一突吉罗。若白未竟舍者突吉罗。若未作白作是语。我知佛所说行淫欲者非障道法一切突吉罗。彼比丘谏此比丘时。余比丘遮。若比丘尼遮者。若有余人遮。汝莫舍此事。众僧谏已不谏遮者一切突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。初语时舍。若非法别众谏。若非法和合谏。法别众。法相似别众。法相似和合。非法非毗尼非佛所教。若无谏者无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(六十八竟)

尔时佛在舍卫国祇树给孤独园。时阿梨吒比丘恶见。众僧呵谏而故不舍。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责阿梨吒比丘言。云何汝恶见。众僧呵谏而故不舍。时诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责阿梨吒比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何阿梨吒比丘恶见。众僧呵谏而故不舍耶。世尊以无数方便呵责阿梨吒比丘已告诸比丘。自今已去。众僧。与阿梨吒比丘。作恶见不舍举白四羯磨。应如是作。为阿梨吒比丘作举。作举已作忆念。作忆念已与罪。众中应差堪能羯磨者。如上作如是白。大德僧听。此阿梨吒恶见。众僧呵谏而故不舍。若僧时到僧忍听。僧今与阿梨吒比丘作恶见不舍举羯磨。白如是。大德僧听。此阿梨吒比丘恶见。众僧呵谏而故不舍。僧今为阿梨吒比丘作恶见不舍举羯磨。谁诸长老忍。僧今为阿梨吒比丘。作恶见不舍举羯磨者默然。谁不忍者说。是初羯磨。第二第三亦如是说。僧已忍。与阿梨吒比丘作恶见不舍举羯磨竟。僧忍默然故。是事如是持。时阿梨吒比丘。僧作恶见不舍举羯磨。六群比丘。供给所须共同羯磨止宿言语。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责六群比丘。阿梨吒比丘。僧与作恶见不舍举羯磨。云何供给所须共止宿言语。尔时诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何六群比丘。阿梨吒比丘。僧为作恶见不舍举羯磨。而供给所须止宿言语。世尊以无数方便呵责六群比丘已告诸比丘。此六群比丘痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘。与如是语人未作法有是恶见不舍。供给所须共同羯磨止宿言语波逸提。如是世尊与比丘结戒。时诸比丘。不知有如是语不如是语。后乃知有如是语。或有作波逸提忏。或有疑者。佛言。不知者无犯。自今已去当如是说戒。若比丘知如是语人未作法如是邪见而不舍。供给所须共同羯磨止宿言语者波逸提。比丘义如上。如是语者。作如是语。我闻世尊说法行淫欲者非障道法。未作法者。若被举未为解。如是见者。作如是见。知世尊所说法非障道法。不舍恶见者。众僧呵谏而不舍恶见。供给所须者。有二种若法若财。法者。教修习增上戒增上意增上智学问诵经。财者。供给衣服饮食床卧具病瘦医药。同羯磨者。同说戒。止宿者。屋有四壁一切覆一切障。或一切覆不一切障。或一切障不一切覆。或不尽覆不尽障。若比丘先入屋。后有如是语人来。若如是语人先入。比丘后来。若二人俱入宿。随胁着地一切波逸提。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。比丘不知便入宿。若比丘先在屋。如是语人后来入屋比丘不知。若屋一切覆无四壁。或一切覆而半障。或一切覆少障。或一切障而无覆。或一切障而半覆。或一切障少覆。或半覆半障。或少覆少障。或不覆不障。或露地。如是一切不知无犯。若病倒地。若病转侧。若为力势所持。或被系闭或命难梵行难无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(六十九竟)

尔时佛在舍卫国祇树给孤独园。时跋难陀释子有二沙弥。一名羯那。二名摩睺迦。不知惭愧共行不净。尔时羯那摩睺伽自相谓言。我等从佛闻法。其有行淫欲非障道法。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责二沙弥言。云何汝等自相谓言。我从佛闻法。行淫欲非障道法。尔时诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责此二沙弥言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等自相谓言。我从佛闻法。其行淫欲者非障道法。尔时世尊以无数方便呵责此二沙弥已告诸比丘。自今已去与此二沙弥作呵谏。舍此事故。白四羯磨应如是作呵谏。立此二沙弥于众僧前眼见耳不闻处。众中当差堪能羯磨者。如上作如是白。大德僧听。彼二沙弥自相谓言。我从世尊闻法。行淫欲者非障道法。若僧时到僧忍听。呵责彼二沙弥。舍此事故。沙弥。莫作是语。莫诽谤世尊。诽谤世尊者不善。世尊不作是语。沙弥。世尊无数方便说行淫欲是障道法。白如是。大德僧听。彼二沙弥自相谓言。我从世尊闻法。行淫欲者非障道法。僧今与彼二沙弥作呵谏。令舍此事故。汝沙弥。莫诽谤世尊。诽谤世尊者不善。世尊不作是语。世尊无数方便说淫欲是障道法。谁诸长老忍。僧今呵责二沙弥令舍此事者默然。谁不忍者说。是初羯磨。第二第三亦如是说。众僧已呵责二沙弥竟。僧忍默然故。是事如是持。彼二沙弥众僧呵责而故不舍此事。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责二沙弥。云何汝等。僧呵责而故不舍恶见耶。尔时诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责二沙弥言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等二沙弥。众僧呵责而故不舍恶见。世尊以无数方便呵责二沙弥已告诸比丘。众僧应与此二沙弥作恶见不舍灭摈白四羯磨。应如是作。将二沙弥至众僧前。立着见处不闻处。众中当差堪能羯磨者。如上作如是白。大德僧听。此二沙弥。众僧呵责故不舍恶见。若僧时到僧忍听。僧今为二沙弥作恶见不舍灭摈。自今已去此二沙弥。不应言佛是我世尊。不得随逐余比丘。如诸沙弥。得与比丘二宿三宿。汝等不得。汝出去灭去不应住此。白如是。大德僧听。此二沙弥。众僧呵责故不舍恶见。众僧今与二沙弥作恶见不舍灭摈羯磨。自今已去此二沙弥。不得言佛是我世尊。不应随逐余比丘。如诸沙弥得与比丘二宿三宿。汝今不得。汝出去灭去不应住此。谁诸长老忍。僧为二沙弥作恶见不舍灭摈者默然。谁不忍者说。是初羯磨。第二第三亦如是说。僧已忍。与二沙弥作恶见不舍灭摈竟。僧忍默然故是事如是持。时六群比丘。知僧为此二沙弥作恶见不舍灭摈羯磨。而便诱将畜养共止宿。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。云何汝等知僧为此二沙弥作恶见不舍灭摈羯磨。而诱将畜养共止宿耶。尔时诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等。知僧为此二沙弥作恶见不舍灭摈羯磨。而诱将畜养共止宿耶。世尊以无数方便呵责六群比丘已告诸比丘。此六群比丘痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住欲说戒者当如是说。若沙弥作是言。我知世尊所说法行淫欲非障道法。彼比丘谏此沙弥如是言。汝莫作是语莫诽谤世尊。诽谤世尊者不善。世尊不作是语。世尊无数方便说行淫欲是障道法。彼比丘作如是谏时。此沙弥坚持不舍。彼比丘应乃至再三呵谏。令舍此事故。若乃至三谏而舍者善。不舍者彼比丘当语彼沙弥言。汝自今已去。不得言佛是我世尊。不得随逐余比丘。如诸沙弥得与比丘二三宿。汝今无是事。汝出去灭去不应住此若比丘知如是众中被摈沙弥。而诱将畜养共止宿者波逸提。如是世尊与比丘结戒彼二沙弥。城中摈出便往外村。城外摈出还入城中。尔时诸比丘。亦不知是灭摈不灭摈。后乃方知是灭摈。或作波逸提忏者。或有疑者。佛言。不知者无犯。自今已去应如是说戒。若比丘。知沙弥作如是言。我从佛闻法若行淫欲非障道法。彼比丘谏此沙弥如是言。汝莫诽谤世尊。诽谤世尊者不善。世尊不作是语。沙弥。世尊无数方便说淫欲是障道法。彼比丘谏此沙弥时。坚持不舍。彼比丘应乃至再三呵谏。令舍此事故。乃至三谏而舍者善。不舍者彼比丘应语彼沙弥言。汝自今已去。不得言佛是我世尊。不得随逐余比丘。如诸沙弥得与比丘二三宿。汝今无是事。汝出去灭去不应住此。若比丘知如是众中被摈沙弥。而诱将畜养共止宿者波逸提。比丘义如上。灭摈者。僧与作灭摈白四羯磨。畜养者。若自畜若与人。畜诱者。若自诱若教人诱。共宿者如上说。若比丘先入宿。灭摈者后至。若灭摈者先至。比丘后至。或二人俱至。随胁着地转侧波逸提。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。先不知。若比丘先至。灭摈者后至。比丘不知。若房四方无障上有覆。广说如上。露地无犯。若癫发倒地。若病动转。或为力势所持。被系闭命难梵行难无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(七十竟)

四分律卷第十七四分律卷第十八(初分之十八)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    九十单提法之八

尔时佛在拘睒毗国瞿师罗园中。尔时阐陀比丘。余比丘如法谏时。作如是言。我今不学此戒。当问余智慧持律比丘。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责阐陀比丘言。云何诸比丘如法谏时。便作如是言。我今不学此戒。当问余智慧持律比丘。尔时诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责阐陀比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何阐陀比丘。余比丘如法谏时。作如是语。我今不学此戒。当问余智慧持律比丘。以无数方便呵责阐陀已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘。余比丘如法谏时如是语。我今不学此戒。当难问余智慧持律比丘者波逸提。若为知为学故应难问。比丘义如上。如法者。如法如律如佛所教。彼比丘如法谏此比丘时。此比丘作是语。我今不学此戒。当难问余智慧持律比丘。若说而了了波逸提。不了了者突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。彼谏比丘痴不解故。此比丘作如是语汝还问汝和上阿阇梨。汝可更学问诵经。若其事实尔。或戏笑语或疾疾语或独语或梦中语。或欲说是错说彼无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(七十一竟)

尔时佛在舍卫国祇树给孤独园。尔时有众多比丘。共集在一处。诵正法诵毗尼。时六群比丘自相谓言。此比丘等集在一处。诵正法诵毗尼。彼诸比丘诵律通利必当数数举我罪。我今宁可往语彼比丘。长老何用此杂碎戒为。若欲诵者。当诵四事。若必欲诵者。当诵四事十三事。余者不应诵。何以故。汝等若诵者。使人怀疑忧恼。时六群比丘。便往语彼比丘言。长老何用诵此杂碎戒为。若欲诵者。当诵四事。若必欲诵者。当诵四事十三事。余者不应诵。何以故。说是戒时。令人怀疑忧恼。余比丘即观察。此六群比丘欲灭法故作是语耳。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。云何汝等。欲灭法故作如是语耶。尔时诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等。欲灭法故作如是语耶。世尊以无数方便呵责六群比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘说戒时作是语。大德。何用说是杂碎戒为说是戒时令人恼愧怀疑。轻呵戒。故波逸提。比丘义如上。彼比丘。若自说戒时。若他说时。若诵时。作如是语。长老。何用诵此杂碎戒为。若欲诵者。当诵四事。若必诵者。当诵四事十三事。何以故。若诵是戒时。令人怀疑恼愧。说而了了者波逸提。不了了者突吉罗。毁呰毗尼者波逸提。毁呰阿毗昙者突吉罗。及余契经毁呰者突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若语言。先诵阿毗昙然后诵律。先诵余契经然后诵律。若有病者须差然后诵律。当勤求方便。于佛法中成四沙门果。然后当诵律。不欲灭法故作是语。或戏笑语或疾疾语或梦中语或独语。欲说此乃错说彼无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(七十二竟)

尔时佛在舍卫国祇树给孤独园。时六群比丘中有一比丘。当说戒时犯罪。自知罪障。恐清净比丘发举。便先诣清净比丘所语言。我今始知是法戒经所载半月半月说戒经来。诸比丘察知。六群比丘布萨时犯戒。自知罪障。恐清净比丘发举。便先诣清净比丘所语言。我今始知此法戒经所载半月半月说戒经来。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。云何汝等。说戒时犯罪而自知罪障。恐清净比丘发举。便先诣清净比丘所语言。半月半月说戒经来。我今始知此法戒经所载。尔时诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何说戒时犯罪。自知罪障。恐清净比丘发举。便先诣清净比丘所语言。我今始知此法戒经所载半月半月说戒经来。尔时世尊以无数方便呵责六群比丘中一比丘已告诸比丘言。此愚痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘说戒时作如是语。我今始知此法戒经所载半月半月说戒经来。余比丘知是比丘若二若三说戒中坐何况多。彼比丘无如无解。若犯罪应如法治。更重增无知罪。语言长老。汝无利不善得。汝说戒时。不用心念不一心摄耳听法。彼无知故波逸提。比丘义如上。彼比丘若自说戒时。若他说戒时。若诵戒时。作如是语。长老。我今始知是法戒经所载半月半月说戒经来。余比丘。知是比丘二三在布萨中坐何况多。彼比丘无知无解随所犯罪。应如法治应重增无知罪。长老。汝无利不善得。汝说戒时。不善用意思惟。不一心听法。无知故重与波逸提。若不与者彼比丘突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若未曾闻说戒今始闻。若未曾闻广说今始闻。若戏笑语若疾疾语若独语若梦中语。欲说此错说彼无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(七十三竟)

尔时佛在罗阅城耆阇崛山中。尔时尊者沓婆摩罗子比丘。众中差令典众僧床座卧具及分饮食。彼以僧事以塔事故。外人有为初立寺初立房初作池井。而设会布施。不得往赴彼。衣服破坏垢腻不净。于异时有人施众僧贵价衣。众僧自相谓言。此尊者沓婆摩罗子比丘。众僧差典床座卧具及分饮食。彼以僧事塔事故。外人有初立寺初立房初作池井而设会布施。不得赴彼请。衣服破坏垢腻不净。我等宜可以此衣与之。时众僧白二羯磨已以衣与之。当白羯磨时。六群比丘亦在众中。既与衣已便作是语。此诸比丘随所亲以众僧衣与之。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。云何汝等。共在众中作羯磨施与彼衣后方言。诸比丘逐所亲以众僧衣与之耶。尔时诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等。共集一处作白羯磨以衣与彼。既与衣已后方言。诸比丘随所亲以众僧衣与之耶。世尊以无数方便呵责六群比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘共同羯磨已后如是语。诸比丘随亲厚以众僧物与者波逸提。比丘义如上。亲厚者。同和上同阿阇梨坐起言语亲厚者是。僧物者。如上所说。物者衣钵针筒尼师坛下至饮水器。彼比丘先共众中作羯磨已后悔言。诸比丘逐亲厚以僧衣物与之。说而了了波逸提。不了了突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。其事实尔。随亲厚以僧物与之无犯。或戏笑语或疾疾语或独处语或梦中语。或欲说此乃错说彼一切无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(七十四竟)

尔时佛在舍卫国祇树给孤独园。时有众多比丘集在一处共论法毗尼。时六群比丘自相谓言。看此诸比丘共集一处。似欲为我等作羯磨。即从坐起而去。诸比丘语言。汝等且住勿去。众僧有事而故去不住。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。众僧集欲论法事。云何便从坐起去。尔时诸比丘往至世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等。众僧集欲论法事。从坐起而去。世尊以无数方便呵责已告诸比丘。此六群比丘痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘。众僧断事未竟起去者波逸提。如是世尊与比丘结戒。诸比丘或营僧事。或营塔寺事。或瞻视病比丘事疑。佛言。自今已去听与欲。自今已去当如是说戒。若比丘。众僧断事未竟。不与欲而起去波逸提。比丘义如上。僧者一说戒一羯磨。事者有十八破僧事法非法乃至说不说。若比丘。僧断事未竟而起去。动足出户外波逸提。一足在户外一足在户内。方便欲去而不去。若共期欲去而不去。一切突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。有僧事塔寺事。有瞻视病人事。与欲无犯。若口噤不能与欲。若非法羯磨非毗尼羯磨。或为僧事。或为塔寺事。或为和上同和上阿阇梨同阿阇梨。或为知识亲厚方便。为作损减无利作无住处羯磨。如是不与欲去一切无犯。无犯者最初未制戒。痴狂心乱痛恼所缠(七十五竟)

尔时佛在舍卫国祇树给孤独园。时六群比丘中有犯事者。恐众僧弹举六人。便共相随至大食小食上。若众僧大集说法时若说戒时。六人共俱不相离。使诸比丘无由得与作羯磨。后于异时。六群比丘作衣。诸比丘自相谓言。此六群比丘今在此作衣。欲作羯磨者今正是时。即遣使唤言。汝等来。众僧有事。六群比丘报言。僧有何等事。我等停作衣不得往。僧报言。汝等若不得来。可令一二比丘持欲来。六群比丘即令一比丘受欲来。尔时众僧。即与此一比丘作羯磨。作羯磨已。即还至彼六群比丘所。彼问言。众僧何所作为。此比丘报言。于我身无利。问言。以何事于汝身无利耶。报言。众僧与我作羯磨。六群比丘前与欲已。后便悔言。彼作羯磨者。非为羯磨。羯磨不成。我以彼事故与欲。不以此事时诸比丘闻其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。云何汝等与欲已后自悔言。我以彼事与欲不以此事。尔时诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何前与欲已后自悔言。我以彼事与欲。不以此事耶。世尊以无数方便呵责已告诸比丘。此六群比丘痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘与欲已后悔者波逸提。比丘义如上。若比丘与欲已后悔。作是言。汝等作羯磨非羯磨羯磨不成。我以彼事故与欲。不以此事。说而了了者波逸提。不了了突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。其事实尔。非羯磨羯磨不成故。便作是言。非羯磨羯磨不成不犯。若戏笑语疾疾语独处语梦中语。欲说此乃错说彼一切无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(七十六竟)

尔时佛在舍卫国祇树给孤独园。时六群比丘。听诸比丘斗诤言语已。而向彼人说。令僧未有诤事而有诤事。已有诤事而不除灭。诸比丘作如是念。以何因缘令僧未有诤事而有诤事。已有诤事而不除灭。诸比丘即察知之。是六群比丘。听诸比丘斗诤语言已。而向彼说故耳。尔时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。汝等云何。听诸比丘斗诤。已。而向彼说。令僧未有诤事而有诤事。已有诤事而不除灭。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等。听诸比丘诤已而向彼说。令僧未有诤事而有诤事。已有诤事而不除灭。世尊以无数方便呵责已告诸比丘。此六群比丘痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘。比丘共斗诤已听此语向彼说者波逸提比丘义如上。斗诤有四种。言诤觅诤犯诤事诤。听者。屏听他语。若比丘往听他诤比丘语。从道至道。从道至非道。从非道至道。从高至下。从下至高。往而闻波逸提。不闻突吉罗。若方便欲去而不去。若共期去而不去。一切突吉罗。若二人共在闇地语。当弹指若謦欬惊之。若不尔者突吉罗。若二人隐处语。亦当弹指謦欬。若不者突吉罗。若在道行有二人在前共语。亦当弹指謦欬。若不者突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若二人在闇处共语。謦欬弹指。若二人在屏处语。弹指謦欬。在道行二人在前行共语。若后来謦欬弹指。若欲作非法羯磨非毗尼羯磨。若为众僧。若为塔寺。若为和上同和上若阿阇梨同阿阇梨亲厚知识。欲作损减无利无住处。如是等羯磨。欲得知之而往听无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(七十七竟)

尔时佛在舍卫国祇树给孤独园。尔时六群比丘中有一比丘。嗔恚打十七群比丘。其被打人高声大唤言。止止莫打我。时比房比丘闻。即问言。汝何故大唤。时被打比丘答言。向为彼比丘所打。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。云何以嗔恚乃打十七群比丘。时诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等乃打十七群比丘。世尊以无数方便呵责六群比丘已告诸比丘。此六群比丘痴人。多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘。嗔恚故不喜打比丘者波逸提。比丘义如上。打者若手若石若杖。若比丘。以手石杖打比丘者一切波逸提。除杖手石。若以余户钥曲钩拂柄香炉柄挃者一切突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若有病须人椎打。若食噎须椎脊。若共语不闻而触令闻。若睡时以身委他上。若来往经行时共相触。若扫地时杖头误触一切无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(七十八竟)

尔时佛在舍卫国祇树给孤独园。时六群比丘以手搏十七群比丘。其被搏人高声大唤言。止止莫尔。比房比丘闻。即问言。汝何故大唤。报言。此比丘以手搏我故大唤。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。汝云何以手搏十七群比丘。时诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非非威仪非沙门法非净行非随顺行。所不应为。云何汝等以手搏十七群比丘。世尊以无数方便呵责六群比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘。嗔恚不喜以手搏比丘者波逸提。比丘义如上。手者两手。彼比丘嗔恚以手搏比丘者波逸提。除手已。若户钥拂柄香炉柄挃一切突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若他欲打举手遮。若象来。若盗贼来。若恶兽来。若持刺来举手遮无犯。若渡水。若欲从沟渎泥水处过相近举手招唤余比丘触彼无犯。若彼不闻语手挃令闻。若眠时。若行来入出。若扫地。若以杖误触。不故作一切无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(七十九竟)

尔时佛在舍卫国祇树给孤独园。尔时六群比丘。嗔恚故。以无根僧伽婆尸沙。谤十七群比丘。时诸比丘闻已。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。汝云何嗔恚故。以无根僧伽婆尸沙。谤十七群比丘。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。汝云何嗔恚故。以无根僧伽婆尸沙。谤十七群比丘。世尊以无数方便呵责六群比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘。嗔恚故以无根僧伽婆尸沙谤者波逸提。比丘义如上。根者有三根。见根闻根疑根。见根者。实见弄阴失精。或见与妇女身相触。或见与妇女粗恶语。或见与妇女前自叹誉身。或见共相媒嫁时。若余人见。从彼人闻者。是谓见根。闻根者。闻弄阴失精或闻与妇女身相近。或闻与妇女粗恶语。或闻妇女前自叹誉身。或闻共相媒嫁。若彼人闻从彼闻。是谓闻根。疑根者。有二因缘生疑。见生疑闻生疑。云何见生疑。其人见共妇女出林时见入林时。或见露身无衣不净流出污身。或见与恶知识从事或共戏。是为见而生疑。云何闻中生疑。或闇处闻动床声。闻草蓐声。闻喘息声。闻语声。或闻交会声。或闻彼人自言我犯失精。或言我与女人身相触。或言我与妇女粗恶语。或言我于妇女前自叹说身。或言我媒嫁男女。闻如是等于中生疑。除此三根已。以余谤者。是为无根。若比丘嗔恚故。以无根僧伽婆尸沙谤。说了了者波逸提。不了了者突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。见根闻根疑根。若说其实事欲令改悔而不诽谤。若戏笑语疾疾语独处语梦中语。若欲说此错说彼无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(八十竟)

尔时佛在舍卫国祇树给孤独园。时舍卫城中。有一大姓婆罗门。名耶若达。多饶财宝生业无量。田地壳食不可称计。金银车磲马瑙真珠虎魄水精琉璃。象马奴婢库藏溢满威相具足。时有一婢名曰黄头。常守末利园。时彼婢常愁忧言。我何时当免出于婢。时彼婢晨朝得已食分干饭持诣园中。尔时世尊。时到着衣持钵欲入城乞食。时黄头婢遥见如来。心自念言。我今宁可持此饭施彼沙门。或可脱此婢使。即持饭施如来。尔时世尊。慈愍故为受还精舍。时黄头婢即前进入末利园中。时波斯匿王。严四种兵出外游猎。从人各各分张驰逐群鹿。天时大热王疲乏。遥见末利园相去不远。即回车往留车在外步入园中。时黄头遥见王波斯匿来。即生念。彼人来者。行步举动非是常人。即前奉迎言。善来大人。可就此处坐。即脱一衣敷之令王坐。黄头问言。不审须水洗脚不。王言可尔。黄头即以藕叶取水与王。王自以水洗。黄头为王揩脚。黄头复问王言。欲洗面不。王言可尔。黄头即更以藕叶盛水与王洗面黄头复问王言。欲饮水不。王言欲饮。黄头即诣池更洗手。取好藕叶盛水与王饮。黄头复问王言。不审欲小卧息不。王言欲卧息即复更脱一衣与王。敷之令王卧息。时黄头见王卧已。在前长跪。按脚及处处支节。解王疲劳。黄头。身如天身。细软妙好。王着细滑。心念言。未曾有如此女聪明。我所不教而悉为之。王即问言。汝是谁家女。黄头报言。我是耶若达家婢。使差我常守此末利园。如是语顷。波斯匿王大臣。寻王车迹来诣园中。跪拜王足已各在一面立。王敕一人言。汝速唤耶若达婆罗门来。即受王教。唤婆罗门将来诣王所。跪拜王足在一面立。王问言。此女人是汝婢耶。婆罗门答言是。王言。吾今欲取为妇。汝意云何。婆罗门报言。此是婢使。云何为妇。王言无苦。但共论价直。婆罗门报言。欲论价直直百千两金。我岂可取王价直。今持奉上大王。王言不尔。我今取为妇。云何不与价。王即出百千两金与婆罗门已。遣使诣宫取种种璎珞衣裳服饰。沐浴澡洗庄严女身。同载入宫众臣卫从。时黄头心自念言。此非余人乃是王波斯匿。既得处宫里。习学种种技术书算印画众形像歌舞戏乐。无事不知。从末利园中将来故。即号之。为末利夫人。年遂长大。王甚爱敬。复于异时。王于五百女人中立为第一夫人。在高殿上。便自念言。我以何业报因缘得免于婢。今受如是快乐。复作是念。将是我先以和蜜干饭分施与沙门。以此因缘故今得免婢。受如是快乐耳。即问左右人言。舍卫城中颇有如此像貌沙门不。答言有。是如来无所著至真等正觉。夫人闻已欢喜。便欲往至佛所。即诣王波斯匿白言。我欲见佛礼拜问讯。王报言。宜知是时。末利夫人。即严驾五百乘车五百婇女侍从。出舍卫城诣只桓精舍。到已下车。步入园中。遥见如来。颜貌端正诸根寂定。得上调伏如调象王。又如澄渊清净无秽。见已欢喜来诣佛所。头面礼足在一面坐。白佛言。以何因缘受女人身。颜貌丑陋见者不欢。资财乏少无有威力。复何因缘颜貌丑陋见者不欢。资财无乏无有威力。复何因缘颜貌丑陋见者不欢。资财无乏大有威力。复何因缘颜貌端正见者欢喜。资财无乏大有威力。尔时世尊告末利夫人。或有女人。心多嗔恚喜恼于人。若以少言现大嗔恚。若以多言亦现大嗔恚。亦不布施沙门。婆罗门贫穷孤老来乞求者。衣服饮食象马车乘香华璎珞房舍卧具灯烛一切皆不施与。若见他得利养而生嫉心。是故末利女人。多嗔恚故。颜貌丑陋见者不欢。以不布施故。资财乏少。见他得利养生嫉妒故。无有威力若末利女人。心多嗔恚喜恼于人。以少言现大嗔恚。以多言亦现大嗔恚。而能布施沙门婆罗门贫穷孤老来乞求者。衣服饮食象马车乘香华璎珞房舍卧具皆给与之。见他得利养而生嫉姤。是故女人。多嗔恚故。颜貌丑陋。以布施故。资财无乏。心生嫉姤故。无有威力。若末利女人。心多嗔恚喜恼于人。以少言现大嗔恚。以多言亦现大嗔恚。而能布施沙门婆罗门贫穷孤老来乞求者。衣服饮食华香璎珞乃至房舍卧具灯烛皆给与之。见他得利养者心不嫉姤。是故。女人。以嗔恚故。颜貌丑陋。以布施故。资财无乏。以见他得利养不生嫉姤故。有大威力。若末利女人。无有嗔恚不恼于人。若闻少言多言亦不现大嗔恚。而能布施沙门婆罗门贫穷孤老来乞求者。象马车乘衣服饮食乃至灯烛皆给与之。见他得利不生嫉妒。是故末利女人。不嗔恚故。颜貌端正。以布施故。资财无乏。不嫉妒故。有大威力。如是末利。以此因缘故。女人颜貌丑陋资财乏少无有威力。以此因缘女人颜貌丑陋资财无乏无有威力。以此因缘女人颜貌丑陋资财无乏有大威力。以此因缘女人颜貌端正资财无乏有大威力。尔时末利夫人。重白佛言。大德。我前世时。多嗔恚喜恼于人。少言而现大嗔恚。以多言亦现大嗔恚。何以故。而今我受形丑陋人不好喜。以是故知。大德。我前世时。能行布施沙门婆罗门贫穷孤老来乞求者。衣服饮食乃至灯烛皆给与之。是故我今日资财无乏。大德。我前世时见他得利养不生嫉妒心。故今日有大威力。今此波斯匿王宫中五百女人。皆是刹利种姓。而我于中尊贵自在。大德。我自今已去不复嗔恚恼于他人。不以少言多言而现大嗔恚。常当布施沙门婆罗门贫穷孤老来乞求者。衣服象马车乘乃至灯烛皆给与之。若见他得利养心不生嫉妒。大德。我自今已去尽形寿归依佛法僧。听为忧婆私。自今已去尽形寿不杀生乃至不饮酒。尔时世尊。与末利夫人无数方便说法开化。劝令欢喜。所谓法者。说施说戒说生天之法。呵欲为过欲为不净。上漏缠缚赞叹出离解脱为乐。即于座上。诸尘垢尽得法眼净。见法得法已得果证。时末利夫人重白佛言。我今第二第三归依佛法僧。听为优婆私。自今已去尽形寿不杀生乃至不饮酒。从坐起头面礼佛足绕三匝而去。还至宫中劝喻波斯匿王令得信乐。王既信乐已。便听诸比丘入出宫合无有障阂。时迦留陀夷。到时着衣持钵往入波斯匿王宫。时王与夫人昼日共眠。夫人遥见迦留陀夷来。即起被衣。以所被大价衣拂拭床座令坐。时夫人失衣堕地形露惭愧而蹲。时迦留陀夷见已。寻还出宫。王问夫人。向者比丘见汝形耶。夫人白王言。虽见如兄弟姊妹无异。此事无苦。时迦留陀夷还至僧伽蓝中。语诸比丘。波斯匿王第一宝者。我今悉见。比丘问言。汝见何等宝耶。迦留陀夷答言。我见末利夫人形露悉得见之。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责迦留陀夷言。云何乃入王宫至婇女间。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。知而故问迦留陀夷言。汝实入王宫乃至婇女间耶。答言。实尔世尊。世尊以无数方便呵责迦留陀夷言。汝所为非。非威仪非净行非随顺行。所不应为。云何乃入王宫婇女间。世尊以无数方便呵责迦留陀夷已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘。刹利水浇头王种。王未出未藏宝。而入若过宫门阈者波逸提。比丘义如上。王刹利水浇头种者。取四大海水取白牛右角收拾一切种子盛满中置金辇上。使诸小王舆辇。王与第一夫人共坐辇上。大婆罗门以水灌王顶上。若是刹利种。水灌顶上作如是立王。故名为刹利王水浇顶种。若是婆罗门种。毗舍守陀罗种。以水灌顶作如是立王。亦名为刹利王水浇头种。未出者。王未出婇女。未还本处。未藏宝者。金银真珠车磲玛瑙水精琉璃贝玉一切众宝璎珞。而未藏举。若比丘。王刹利水浇头种。王未出未藏宝。若入王宫过门阈者波逸提。若一足在外一足在内。发意欲去。若共期而不去者。一切突吉罗。除王刹利种。若入余粟散小王豪贵长者家。入过门阈者一切突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若王已出。若婇女还本处。所有金宝璎珞已藏举。若有所奏白。若被请唤。或为力势所执将去。若命难梵行难一切无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(八十一竟)

尔时佛在舍卫国祇树给孤独园。尔时有外道弟子居士。从拘萨罗国在道行。道边止息。忘千两金囊而去。时有众多比丘。亦从彼道行。后来亦止息道边。见此金囊在地。自相谓言。为且持去。若有主识者当还。即持而去。时彼居士。忘此金囊前行数里乃忆。疾疾而还。诸比丘遥见。自相谓言。此人来者行疾。必是金主。诸比丘即问言。欲何所至。居士报言。汝自去。何须问我为。诸比丘言。见语所往处何苦耶。报言。我乃于某处止息。忘千两金囊。故今往彼取之。诸比丘即出金囊示之言。是汝物非。居士报言。是我囊耳。但此中物何故少。诸比丘言。我等实正得尔许耳。居士即诣官了之。时王波斯匿。身自在座断事。遣信唤诸比丘。诸比丘往。问言。诸大德。此事云何。如彼人语不。诸比丘白王言。我等所得正有此耳更无。时居士言。我所有物者乃有若干。王即敕人。如彼所说斤两。取库中金来盛着此囊中。即如教取金盛之。其囊不受。王语居士言。此非汝物。汝更自求去即治其罪。更税家财物。并此金一切入官。尔时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责诸比丘言。云何自手捉金银。使居士为官治罪并税家财物尽没入于官。时诸比丘往至世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责诸比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等自手捉金银。使王罚谪居士并财物没入于官。世尊以无数方便呵责诸比丘已告诸比丘言。此痴人多种有漏处最初犯戒。自今已去与比丘结戒集十句义乃至正法久住。欲说戒者当如是说。若比丘。若宝若宝庄严。自捉若教人捉者波逸提。如是世尊与比丘结戒。尔时舍卫城中世俗常法妇女节会日。毗舍佉母。自庄严璎珞。从只桓边过。而彼得信乐心。复作是念。我何用女人节会为。我今宁可往世尊所礼拜问讯。彼即回还入只桓精舍。心自念言。我不宜着璎珞庄严具往见世尊。今当先脱却然后乃见礼拜世尊。时将从在一树下脱身宝衣璎珞积置树下乃成大积。往世尊所头面礼足在一面立。尔时世尊。即与方便说法开化欢喜。时毗舍佉母。闻如来说法甚大欢喜。前礼佛足绕已而去。心存于法。直出只桓门。忘取璎珞宝衣严身具。还家乃忆。作是念言。若我遣信往取衣脱不得。便能辱诸比丘。即止不遣使往取。有一比丘。见毗舍佉母入只桓诣树下时。又见出时竟不诣此树下。彼比丘便往树所。见诸宝衣璎珞积在一处。见已心疑不敢取。念言。世尊制戒。若比丘。捉宝若宝庄饰。自捉若教人捉波逸提。彼比丘往白世尊。世尊告言。自今已去听在僧伽蓝内见有遗物为不失坚牢故当取举之。自今已去当如是说戒。若比丘。捉金宝若宝庄严。自捉若教人捉。除僧伽蓝中波逸提。如是世尊与比丘结戒。尔时有众多比丘。从拘萨罗国在道行。下道至一无住处村。问彼人言。此中何处有空房舍可止宿处。诸人语言。此有某甲巧师家。有空房舍可往止宿。诸比丘往巧师舍语言。我欲寄宿可尔不。报言可尔。诸比丘即入其舍内敷草蓐而坐。正身正意系念在前。尔时巧师。有已成金未成金。已成未成金。已成银未成银。已成未成银。置舍内而舍去。时诸比丘。为守护故竟夜不眠。恐人盗此金银去。夜过已巧师来入屋。问讯诸比丘言。诸尊夜得安眠不。比丘报言。不得眠。即问言。何故不得眠。比丘报言。汝留此杂物置屋中。我等竟夜为守护故不得眠。时诸比丘以此因缘具白世尊。世尊告曰。自今已去听诸比丘在他家止宿时。若屋中有物为不失坚牢故应收举。自今已去当如是说戒。若比丘。若宝及宝庄饰。自捉若教人捉。除僧伽蓝中及寄宿处波逸提。若比丘。在僧伽蓝中若寄宿处。捉宝若以宝庄严自捉教人捉。当作是意。若有主识者当取。作如是因缘非余。比丘义如上。宝者。金银真珠虎珀车渠马瑙琉璃贝玉生像金。宝庄严者。铜铁铅锡白镴以诸宝庄饰也。若比丘。在僧伽蓝内若舍内。若宝宝庄饰。自捉若教人捉。当识囊器相识裹相识系相。应解囊器看。知几连缀。几未连缀。几方几圆。几故几新。若有求索者。应问言。汝物何似。若相应应还。若不相应应语言。我不见如是物。若有二人俱来索。应问言。汝物其形何似。若言相应者应还。若不相应当语言。我不见如是物。若二人语俱相应。应持物着前语言。是汝等物各取去。若比丘。在僧伽蓝内若舍内。若宝若宝庄饰。若自捉若教人捉。若不识囊相裹相系相突吉罗。若解囊不看几连缀几未连缀几方几圆几新几故。一切突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若至僧伽蓝内。若宿处。若宝若宝庄饰。若自捉若教人捉。识囊相裹相系相解囊看知几连缀几未连缀几方几圆几新几故。若二人俱来索问言。汝物形何似。若语相应者还。若不相应当语言。我不见如是物。若二人语俱相应者。当持物着前语言。是汝物者持去。若是供养塔寺庄严具。为坚牢故收举。如是一切无犯无犯者。最初未制戒。痴狂心乱痛恼所缠(八十二竟)

四分律卷第十八四分律卷第十九(初分之十九)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    九十单提法之九(并四提舍尼众学法初)

尔时佛在舍卫国祇树给孤独园。时跋难陀释子非时入村。与诸居士共樗蒱。比丘胜诸居士不如。居士以悭嫉故便言。比丘晨朝入村为乞食故。非时入村为何事耶。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责跋难陀释子。云何非时入村与诸居士共樗蒱戏。诸比丘往至世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责跋难陀释子。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何跋难陀释子。非时入村与诸居士而共樗蒱戏。世尊无数方便呵责跋难陀释子已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘非时入聚落波逸提。如是世尊与比丘结戒。其中比丘。或有僧事或塔寺事或瞻视病人事。佛言自今已去听诸比丘有事缘嘱授已入聚落。诸比丘不知嘱授何人。佛言。当还嘱比丘。若独处一房当嘱授比房。自今已去当如是说戒。若比丘非时入聚落不嘱比丘者波逸提。比丘义亦如上。时者。从明相出至中时。非时者。从中后至明相未出。村聚落者。四种村如上。有比丘者。同住客得嘱及处。若比丘非时入村。有比丘不嘱授动足初入村门波逸提。一脚在门内一脚在门外。方便欲去不去。若共期不去。一切突吉罗。比丘尼波逸提式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若比丘。营众僧事塔寺事瞻视病人事。嘱授比丘若道由村过。若有所启白。若为唤。若受请或为力势所执。或为系缚将去。或命难梵行难无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(八十三竟)

尔时佛在舍卫国祇树给孤独园。时尊者迦留陀夷。预知世尊必从此道来。即于道中敷高好床座。迦留陀夷遥见世尊来。白佛言。世尊看我床座善逝看我床座。佛言。当知此痴人内怀弊恶。尔时世尊。以此因缘集比丘僧。告诸比丘此痴人迦留陀夷。敷高广大床但自为己。尔时世尊以无数方便呵责迦留陀夷已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘。作绳床木床。足应高如来八指。除入陛孔上截竟。若过者波逸提。比丘义如上。床者。五种床如上。若比丘。自作绳床木床。足应高八指截竟。过者波逸提。作而不成突吉罗。若教人作过八指截竟波逸提。作而不成突吉罗。若为他作成不成。一切突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若作足高八指。若减八指。若他施已成者截而用之。若脱脚却无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(八十四竟)

尔时佛在舍卫国祇树给孤独园。时六群比丘。作兜罗绵纻绳床木床大小褥。诸居士见皆共嫌之。自相谓言。此沙门释子不知惭愧。无有慈心断众生命。外自称言。我修正法。乃作兜罗纻木床及绳床大小褥。如似国王亦如大臣。如是有何正法。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘。云何作兜罗纻绳床木床大小褥。时诸比丘往至世尊所。头面作礼在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何作兜罗纻绳床木床大小褥。令居士嫌也。呵责六群比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘作兜罗纻绳床木床大小褥成者波逸提。比丘义如上。兜罗者。白杨树华杨柳华蒲台也。大床者有五种如上。绳床者有五种如上。大褥者为坐卧故。小褥者为坐故。若比丘。以兜罗纻绳床木床大小褥。若自作成者波逸提。不成者突吉罗。若教他使作成者波逸提。不成突吉罗。若为他作成不成一切突吉罗。比丘尼波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若鸠罗耶草文。若草娑婆草。若以毳劫贝碎弊物。若用作搘肩物作舆上枕无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(八十五竟)

尔时佛在罗阅城耆阇崛山中。时有信乐工师为比丘作骨牙角针筒以是故。令此工师废家事业。财物竭尽无复衣食时诸世人皆作此言。此工师未供养沙门释子时。多财饶宝。自供养沙门释子已来。居家贫匮无所食瞰。所以供养者。望得其福。而反得殃。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责诸比丘。汝等云何。使彼工师作骨牙角针筒。废家事业财物竭尽。时诸比丘往至世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧呵责诸比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何诸比丘。使工师作牙骨角针筒财物竭尽。世尊以无数方便呵责诸比丘已。告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘作骨牙角针筒刳刮者波逸提。比丘义如上。若比丘。骨牙角自刳刮作而成者波逸提。不成者突吉罗。若教他作而成者波逸提。不成者突吉罗。若为他作成不成一切突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若铁若铜若铅锡若白镴若竹若木若苇若舍罗草用作针筒不犯。若作锡杖头镖[金*纂]。若作伞盖子及斗头镖。若作曲钩。若作刮污刀。若作如意。若作玦钮。若作匙。若作杓。若作钩衣[金*刮]若作眼药篦。若作刮舌刀。若作摘齿物。若作挑耳篦。若禅镇。若作熏鼻筒。如是一切无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(八十六竟)

尔时佛在舍卫国祇树给孤独园。时世尊不受请檀越送食。诸佛常法。若不受请遍行房舍。见异处以众僧卧具敷在露地不净所污。时天大暴雨世尊即以神力令众僧卧具不为雨渍。诸比丘还。世尊以此因缘集比丘僧告言。我向者遍行房舍。看见有异处敷众僧卧具在露地不净所污。时天大雨。我以神力使雨不渍。当知此污。是有欲人非是无欲人。是嗔恚人非是无嗔恚人。是痴人非是无痴人也。若离欲外道仙人离欲者无有此事。况阿罗汉若比丘念不散乱而睡眠者无有此事。况阿罗汉。自今已去听诸比丘为障身障衣障卧具故作尼师坛。世尊既听作尼师坛。六群比丘便多作广长尼师坛时诸比丘见问言。世尊制戒。听畜三衣不得过长。此是何衣。六群比丘报言。是我等尼师坛。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。云何汝等。多作广长尼师坛。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等作广长尼师坛。世尊以无数方便呵责六群比丘已告诸比丘言。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘。作尼师坛当应量作。此中。量者。长佛二搩手广。一搩手半。过者裁竟波逸提。如是世尊与比丘结戒。时尊者迦留陀夷。体大尼师坛小不得坐。知世尊从此道来。便在道边手挽尼师坛欲令广大。世尊见迦留陀夷手挽尼师坛已。知而故问言。汝何故挽此尼师坛。答言。欲令广大是故挽耳。尔时世尊。以此事与诸比丘随顺说法。赞叹头陀少欲知足乐出离者。告诸比丘。自今已去听诸比丘更益广长各半搩手。自今已去当如是说戒。若比丘。作尼师坛当应量作。是中量者。长佛二搩手广一搩手半更增广长各半搩手。若过裁竟波逸提。比丘义如上。尼师坛者。敷下坐。若比丘。作尼师坛。长中过量广中不过量。若广中过量长中不过量。广长俱过量。自作成者波逸提。不成者突吉罗。教他使作成者波逸提。不成者突吉罗。为他作成不成尽突吉罗。比丘尼突吉罗式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。应量作。或减量作。若从他得已成者。裁割如量。若叠作两重无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(八十七竟)

尔时佛在舍卫国祇树给孤独园。时诸比丘患痈疮疥种种疮病。脓血流出污身污衣污卧具。诸比丘往白佛。佛言。自今已去听诸比丘畜覆疮衣。时诸比丘覆疮衣粗。多毛着疮举衣时患痛。比丘白佛。佛言。自今已去听诸比丘以大价细软衣覆疮上着涅槃僧。若至白衣家请坐时。应语言我有患。若主人语言。但坐。当褰上涅槃僧。以此衣覆疮而坐。时六群比丘闻世尊听作覆疮衣。便多作广长覆疮衣。诸比丘见即问言。世尊制戒。畜三衣不得过长。此是何衣。六群比丘报言。是我等覆疮衣。诸比丘闻。嫌责六群比丘。云何汝等。多作广长覆疮衣。时诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行所不应为。云何汝等。多作广长覆疮衣。尔时世尊。以无数方便呵责六群比丘已告诸比丘言。此痴人多种有漏处最初犯戒。自今已去。与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘。作覆疮衣当应量作。是中量者。长佛四搩手广二搩手。裁竟过者波逸提。比丘义如上。覆疮衣者。有种种疮病持用覆身。若长中应量广中不应量。广中应量长中不应量。若广长俱不应量。自作成者波逸提。不成者突吉罗。教人作成者波逸提。不成突吉罗。若为他作成不成者尽突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。应量作。或减量作。若从他得裁割如量。如叠作两重无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(八十八竟)

尔时佛在舍卫国祇树给孤独园。尔时毗舍佉母闻如来听诸比丘作雨浴衣。即大作雨浴衣。遣人持诣僧伽蓝中与诸比丘。诸比丘得便分。佛言。此衣不应分。自今已去若得雨浴衣。随上坐次付与。若不足者忆次。更得续次与使遍彼。时得贵价衣续次与。佛言。不应尔。应与上座易之。以上座先得者。转次与下座。若不遍者。当以僧可分衣物与之令遍。时六群比丘闻如来制戒听诸比丘作雨浴衣。辄自多作广大雨浴衣。诸比丘见已即问言。如来制戒畜三衣不得过长。此是谁衣。六群比丘报言。是我等雨浴衣。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。汝等云何。乃多作广大雨浴衣。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等多作广大雨浴衣。世尊以无数方便呵责六群比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘。作雨浴衣应量作。是中量者。长佛六搩手广二搩手半。过者裁竟波逸提。比丘义如上。雨浴衣者。诸比丘着在雨中洗浴。若比丘。作雨浴衣。长中不应量广中应量。若广中不应量长中应量。若广长俱不应量。自作而成波逸提。不成突吉罗。若教人作成波逸提。不成突吉罗。若为他作成不成尽突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。应量作减量作。若从他得裁割如量。若叠作两重无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(八十九竟)

尔时佛在释翅搜尼拘类园中。尔时尊者难陀。短佛四指。诸比丘遥见难陀来。皆谓是佛来。即起奉迎。至乃知是难陀。诸比丘皆怀惭愧。时难陀亦怀惭愧。尔时诸比丘。以此因缘具白世尊。世尊告诸比丘。自今已去制难陀比丘着黑衣。时六群比丘。与如来等量作衣或过量作。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘。汝等云何。与如来等量作衣或过量作。时诸比丘往至世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何六群比丘。与如来等量作衣或过量作。无数方便呵责六群比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘。与如来等量作衣或过量作者波逸提。是中如来衣量者。长佛十搩手广六搩手。是谓如来衣量。比丘义如上。衣者十种衣如上。若比丘。等如来衣量。长中不应量广中应量。广中不应量长中应量。若广长中俱不应量。自作成者波逸提。不成突吉罗。若教他作成波逸提。不成突吉罗。若为他作成不成亦突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。从他得作成衣当裁割如量。若不裁割叠作两重无犯。无犯者。最初未制戒痴狂心乱痛恼所缠(九十竟)

    四提舍尼

尔时佛在舍卫国祇树给孤独园。时世俭谷贵。人民饥饿。死者无限。乞求难得。尔时莲华色比丘尼。到时着衣持钵入舍卫城乞食。所得初日食持与比丘。得二日食若三日食亦与比丘。莲华色比丘尼复于异时。着衣持钵入舍卫城乞食。时有长者。乘车将从往问讯波斯匿王。从者驱人避道。时莲华色比丘尼。见已避道堕深泥中面奄地而卧。长者见之。慈愍即止车。敕左右人扶出。长者问言。阿姨有何患苦。报言。我无所患饥乏故耳。尔时长者问言。何故饥乏。乞求难得耶。答言。易得耳。我得初日食持与比丘。二日三日食亦持与比丘。故我饥耳。时长者嫌言。沙门释子。受无厌足不知惭愧。外自称言我知正法。如是何有正法。受此比丘尼所乞得食。不知义让。施虽无厌而受应知足。时长者。即将此比丘尼还家浣濯衣服。为作酥粥供给所须。语言。自今已去可常在我家食。勿复余去。若外有所得者随意与人。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责彼比丘言。云何汝等。于比丘尼边受食。尔时诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责彼比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何受彼莲华色比丘尼食。不知止足。以无数方便呵责彼比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘。入村中自受比丘尼食。食者。彼比丘应向余比丘说。大德。我犯可呵法。所不应为。今向大德悔过。是法名悔过法。如是世尊与比丘结戒。尔时诸比丘皆有疑。不敢取亲里比丘尼食。佛言。自今已去听受亲里比丘尼食。时诸病比丘复有疑。不敢受非亲里比丘尼食。佛言。自今已去听病比丘受非亲里比丘尼食。时诸比丘复有疑。非亲里比丘尼持食置地不敢取。或使人授与。亦不敢取。佛言。自今已去听诸比丘受如是食。自今已去当如是说戒。若比丘。入村中从非亲里比丘尼若无病自手取食食者。是比丘应向余比丘。悔过言。大德。我犯可呵法。所不应为。我今向大德悔过。是法名悔过法。比丘义如上说。非亲里亲里亦如上。病者亦如上。食者。二种食亦如上。彼比丘入村中从非亲里比丘尼若不病而自手受如是食食咽咽波罗提提舍尼。比丘尼突吉罗式叉摩那沙弥沙弥尼突吉罗。是谓为犯不犯者。受亲里比丘尼食。若有病。若置地与。若使人授与。若在僧伽蓝中与若在村外与。若在比丘尼寺内与如是受取食无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(一竟)

尔时佛在舍卫国祇树给孤独园。时众多比丘。与六群比丘在白衣家内共坐食。时六群比丘尼。为六群比丘索羹饭语言。与此羹。与此饭。而舍中间不与。乃越次与六群比丘而食之。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。云何汝等。食六群比丘尼所索羹饭而食耶。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等。食六群比丘尼所索羹饭。而令中间比丘不得食。以无数方便呵责六群比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒集十句义乃至正法久住欲说戒者当如是说。若比丘至白衣家内食。是中有比丘尼指示。与某甲羹与某甲饭。比丘应语彼比丘尼如是言。大姊且止。须比丘食竟。若无一比丘语彼比丘尼如是言大姊且止须比丘食竟者。是比丘应悔过言。大德。我犯可呵法。所不应为。我今向诸大德悔过。是法名悔过法。比丘义如上。家内者有男女者是。食者如上说。彼比丘于白衣家内食。是中有比丘尼指示。与某甲羹与某甲饭。彼比丘当语言。大姊小止。须诸比丘食竟。若无一比丘语言大姊小止须诸比丘食竟而食者咽咽波罗提提舍尼。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若语言。大姊且止。须诸比丘食竟。若比丘尼自为檀越。若檀越设食。令比丘尼处分。若不故作偏为与此置彼如是无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(二竟)

尔时佛在罗阅城耆阇崛山中。时有居士家夫妇。俱得信乐为佛弟子。诸佛见谛弟子常法。于诸比丘无所爱惜。乃至身肉。若诸比丘至家者。常与饭食及诸供养故。令其贫穷衣食乏尽。比居诸人皆作此言。彼家先大富多财饶宝。从供养沙门释子已来。财物竭尽贫穷乃尔。如是恭敬供养乃反得贫弊。尔时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责诸比丘言。汝等云何。数至居士家。受饮食供养而不知足。使彼居士财物竭尽乃尔耶。时诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责诸比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。汝等云何。数至居士家受供养饮食。乃令彼家贫穷如是。以无数方便呵责诸比丘已告诸比丘。自今已去听僧与彼居士作学家白二羯磨。作如是与。众中当差堪能羯磨者。如上当作如是白。大德僧听。此罗阅城中一居士家夫妇。得信为佛弟子。财物竭尽。若僧时到僧忍听。僧今作学家羯磨。诸比丘不得在其家受食食。白如是。大德僧听此罗阅城中一居士家夫妇。得信为佛弟子。财物竭尽。僧今与作学家羯磨。诸比丘不得在其家受食食。谁诸长老忍。僧与彼居士作学家羯磨者默然。谁不忍者说。僧已忍。与彼居士作学家羯磨竟。僧忍默然故。是事如是持。自今已去与诸比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘知是学家。僧与作学家羯磨竟。而在其家受饮食食。当向余比丘悔过言。大德。我犯可呵法。我今向大德悔过。是法名悔过法。如是世尊与比丘结戒。其中比丘先受学家请皆有疑不敢往。佛言。听先请者往时病比丘疑不敢受学家食。佛言。自今已去听诸病比丘受学家食食。时诸比丘。见施食者置地与疑不敢取。若使人与亦不敢受。佛言听受。自今已去当如是说戒。若先作学家羯磨。若比丘。于如是学家先不请无病自手受食食。是比丘应向余比丘悔过言。我犯可呵法。所不应为。我今向大德悔过。是法名悔过法。比丘义如上。学家者。僧与作白二羯磨。居士家者如上。病者亦如上。若比丘。如是学家僧先与作学家羯磨已。比丘先不受请又无病。于如是学家中自手受食食者咽咽波罗提提舍尼。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若先受请。若有病。若置地与。若从人受取。若学家施与后财物还多无犯彼学家财物还多。从僧乞解学家羯磨。诸比丘白佛。佛言。若彼学家财物还多。从僧乞解学家羯磨者。僧应与作白二羯磨解。众中应差堪能羯磨者。如上当作如是白。大德僧听。此罗阅城中有一居士夫妇。得信为佛弟子。好施财物竭尽。僧先与作学家羯磨。今财物还多。从僧乞解学家羯磨。若僧时到僧忍听。僧今解学家羯磨白如是。大德僧听。此罗阅城中一居士家夫妇。得信为佛弟子。好施财物竭尽。僧先与作学家羯磨。今财物还多。从僧乞解学家羯磨。僧今与彼居士解学家羯磨。谁诸长老忍。僧与彼居士解学家羯磨者默然。谁不忍者说。僧已忍。与彼居士解学家羯磨竟僧忍默然故。是事如是持。时诸比丘皆疑。不敢受已解学家羯磨居士食。白佛。佛言。自今已去听诸比丘受食无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(三竟)

尔时佛在释翅搜国迦维罗卫尼拘类园中。舍夷城中诸妇女俱梨诸女人。持饮食诣僧伽蓝中供养。时诸盗贼闻之。于道路娆触。时诸比丘闻。往白世尊。世尊言。自今已去。诸比丘应语诸妇女。莫出道路有贼恐怖。若已出城应语言。莫至僧伽蓝中。道路有贼恐怖。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘在阿兰若有疑恐怖处住。僧伽蓝外不受食。僧伽蓝内受食而食。当向余比丘悔过言。大德。我犯可呵法。我今向大德悔过。是法名悔过法。如是世尊与诸比丘结戒。时诸檀越。先知有疑恐怖而故持食来。诸比丘疑不敢受食。佛言。自今已去听诸比丘受如是食。时诸病比丘亦疑不敢受如是食。佛言。自今已去听诸病比丘受如是食。时有施主。以食置地与。若教人与。诸比丘疑不敢受。佛言。自今已去听诸比丘受如是食。自今已去当如是说戒。若比丘在阿兰若迥远有疑恐怖处。若比丘在如是阿兰若处住。先不语檀越。若僧伽蓝外不受食。在僧伽蓝内无病自手受食食者。应向余比丘悔过言。大德。我犯可呵法。我今向大德悔过。是法名悔过法。比丘义如上。阿兰若处者。去村五百弓。遮摩罗国弓量法也。有疑恐怖者。疑有贼盗恐怖。病者如上说。若阿兰若比丘。在如是迥远处住。若先不语檀越。于僧伽蓝外不受食。僧伽蓝内无病自手受食食咽咽波罗提提舍尼。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若先语檀越。若有病。若置地与。若教人与。若来受教敕听法时。比丘自有私食令授与者无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(四竟)

    式叉迦罗尼法

(胡音不正。应言式叉迦罗尼。诸有读写者。尽应从此式叉迦罗尼。不能一一就文治。故斑之出。丹本即云百众学法之一)

尔时佛在舍卫国祇树给孤独园。时六群比丘。着涅槃僧。或时下着。或时高着。或作象鼻。或作多罗树叶。或时细襵。诸居士见已皆讥嫌言。此沙门释子无有惭愧。外自称言。我知正法。如是有何正法。云何着涅槃僧。或时下或时高。或时作象鼻。或作多罗树叶。或时细襵。如似国王长者大臣居士。如似节会戏笑俳说人着衣。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。云何汝等。着涅槃僧。或时下或时高。或时作象鼻。或作多罗树叶。或时细襵耶。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等。着涅槃僧。或时下着。或时高着。或作象鼻。或作多罗树叶。或时细襵。以无数方便呵责已告诸比丘言。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。当齐整着涅槃僧。式叉迦罗尼。比丘义如上。是中不齐整着。或时下着。或时高着。或作象鼻。或作多罗树叶。或时细襵。下者系带在脐下。高者褰齐膝。象鼻者垂前一角。多罗树叶者垂前二角。细襵者绕腰襵皱。若比丘。高着下着涅槃僧。或作象鼻。或作多罗树叶。或时细襵。故作。犯应忏突吉罗。以故作故。犯非威仪突吉罗。若不故作突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。脐中生疮下着。若脚[跳-兆+專]有疮高着。若僧伽蓝内。若村外。若作时。若在道行无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(一竟)

尔时佛在舍卫国祇树给孤独园。时六群比丘所著衣。或高着或下着。或作象鼻。或作多罗树叶。或细襵。诸长者见已皆讥嫌言。此沙门释子不知惭愧。外自称言。我知正法。如是有何正法。云何着衣或高着或下着。或作象鼻。或作多罗树叶。或时细襵。如似国王大臣长者居士种。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。云何汝等着三衣。或高着或下着。或作象鼻。或作多罗树叶。或时细襵。时诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等着衣。或高着或下着。或作象鼻。或作多罗树叶。或时细襵耶。以无数方便呵责已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。当齐整着三衣。式叉迦罗尼。比丘义如上。是中不齐者。或高着或下着。或作象鼻。或作多罗树叶。或时细襵。下着衣者下垂过肘露胁。高着衣者过脚[跳-兆+專]上。象鼻者下垂一角。多罗树叶者。垂前两角后褰高也。细襵者细襵已安缘。若比丘。故高着下着衣作象鼻。或作多罗树叶或时细襵。故作。犯应忏突吉罗。以故作故。犯非威仪突吉罗。若不故作突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。或时肩臂有疮下着。或时脚[跳-兆+專]有疮高着。若僧伽蓝内。若村外。若在道行。作时无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(二竟)

尔时佛在舍卫国祇树给孤独园时六群比丘。反抄三衣行入白衣舍。诸居士见皆共讥嫌言。此沙门释子不知惭愧。外自称言。我持正法。如是有何正法。云何反抄衣入白衣舍。如似国王大臣长者居士种。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责六群比丘言。云何汝等反抄衣入白衣舍。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等。反抄衣入白衣舍。以无数方便呵责已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住欲说戒者当如是说。不得反抄衣行入白衣舍式叉迦罗尼。比丘义如上。白衣舍者村落也。反抄衣者。或左右反抄衣着肩上。若比丘。故左右反抄衣着肩上入白衣舍。故作。犯应忏突吉罗。以故作故。犯非威仪突吉罗。若不故作犯突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。胁肋边有疮。若僧伽蓝内。若村外。若在道行。若作时无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(三竟)

不得反抄衣入白衣舍坐。式叉迦罗尼如上(四竟)

尔时佛在舍卫国祇树给孤独园。尔时六群比丘。以衣缠颈入白衣舍。诸居士见已皆讥嫌言。此沙门释子不知惭愧。乃以衣缠颈入白衣舍。如似国王大臣长者居士种。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。汝等云何衣缠颈入白衣舍。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等衣缠颈入白衣舍。以无数方便呵责已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得衣缠颈入白衣舍。式叉迦罗尼。比丘义如上。缠颈者。总捉衣两角着左肩上。故作衣缠颈入白衣舍。犯应忏突吉罗。以故作故。犯非威仪突吉罗。若不故作犯突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。肩臂有疮。若僧伽蓝内。若村外。或作时。或在道行无犯。无犯者。最初未制戒。痴狂心乱。痛恼所缠(五竟)

不得衣缠颈入白衣舍坐。式叉迦罗尼。亦如是(六竟)

尔时佛在舍卫国祇树给孤独园。尔时六群比丘。以衣覆头入白衣舍。诸居士见已皆讥嫌言。此沙门释子不知惭愧。外自称言。我知正法。如是有何正法。衣覆头行似如盗贼。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。汝等云何持衣覆头入白衣舍。比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等衣覆头入白衣舍。以无数方便呵责六群比丘已告诸比丘言。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得覆头入白衣舍。式叉迦罗尼。比丘义如上。白衣舍者村落也。覆头者。若以树叶。若以碎段物。若衣覆头行入白衣舍。故作犯应忏突吉罗。以故作故。犯非威仪突吉罗。若不故作犯突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。或时患寒。或头上疮生。或命难梵行难覆头而走无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(七竟)

不得覆头入白衣舍坐。式叉迦罗尼。亦如是(八竟)

四分律卷第十九四分律卷第二十(初分之二十)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    百种学法之二

尔时佛在舍卫国祇树给孤独园。尔时六群比丘。跳行入白衣舍。诸居士见皆讥嫌言。此沙门释子不知惭愧。外自称言。我知正法。如是有何正法。跳行入舍似如鸟雀。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。汝等云何跳行入白衣舍。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等跳行入白衣舍。以无数方便呵责已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得跳行入白衣舍。式叉迦罗尼。比丘义如上。白衣舍者如上。跳行者双脚跳。若比丘。故作跳行入白衣舍。犯应忏突吉罗。以故作故。犯非威仪突吉罗。若不故作犯突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。若为人所打。若有贼。若有恶兽。若有棘刺。或渡渠。或渡坑堑。或渡泥跳过者无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(九竟)

不得跳行入白衣舍坐。式叉迦罗尼。亦如是(十竟)

尔时佛在舍卫国祇树给孤独园。时有居士请众僧欲设饮食。即其夜办具甘膳好食。晨朝往白时到。时诸比丘。到时着衣持钵诣居士家就座而坐。时六群比丘。在白衣舍内蹲坐。比坐比丘以手触之。即时却倒露形体。诸居士见之讥嫌言。此沙门释子不知惭愧。外自称言。我知正法。如是有何正法。蹲在舍内似如裸形婆罗门。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。汝等云何在白衣舍内蹲坐。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等在白衣舍内蹲坐。以无数方便呵责已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得白衣舍内蹲坐。式叉迦罗尼。比丘义如上。白衣舍者如上。蹲坐者。若在地若在床上尻不至地。若比丘。故作蹲坐在白衣舍内者。犯应忏突吉罗。以故作故。犯非威仪突吉罗。若不故作犯突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。或尻边生疮。若有所与。若礼若忏悔若受教诫无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(十一竟)

尔时佛在舍卫国祇树给孤独园时六群比丘。手叉腰行入白衣舍。时诸居士见皆讥嫌言。沙门释子不知惭愧。外自称言。我知正法。如是有何正法。如似世人新婚娶得志憍恣。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。汝等云何。如是手叉腰行入白衣舍。时诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等手叉腰行入白衣舍。以无数方便呵责已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得叉腰行入白衣舍。式叉迦罗尼。比丘义如上。白衣舍如上。叉腰者以手叉腰[身*匡]肘。若比丘。故作叉腰行入白衣舍。犯应忏突吉罗。以故作故犯非威仪突吉罗。若不故作犯突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。胁下生疮。若僧伽蓝内。若村外。若作时。若在道路行无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(十二竟)

不得手叉腰入白衣舍坐。式叉伽罗尼。手叉腰[身*匡]肘白衣舍妨比坐。亦如是(十三竟)

尔时佛在舍卫国祇树给孤独园。尔时六群比丘摇身行入白衣舍。时诸居士见皆讥嫌言。此沙门释子不知惭愧。外自称言。我知正法。如是有何正法。摇身行入白衣舍。如似国王大臣。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。汝等云何摇身行入白衣舍。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等摇身趍行入白衣舍。以无数方便呵责已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得摇身行入白衣舍。式叉迦罗尼。比丘义如上。白衣舍如上。摇身者左右戾身趍行。若比丘。故作摇身左右戾身趍行入白衣舍。犯应忏突吉罗。以故作故犯非威仪突吉罗。若不故作犯突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。或时为人所打回戾身避杖。或恶象来。或被贼。或师子恶兽所触。或逢担棘刺人。如是事戾身避。或渡坑渠泥水处于中摇身过。或时着衣回身看衣齐整不犯高下耶。不象鼻多罗树叶细襵耶。作如是回身看者无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(十四竟)

不得摇身行入白衣舍坐。式叉迦罗尼。亦如是(十五竟)

尔时世尊在舍卫国祇树给孤独园。时六群比丘。掉臂行入白衣舍。时诸居士见皆讥嫌言。此沙门释子不知惭愧。外自称言。我知正法。如是有何正法。今掉臂行入白衣舍。似如国王大臣长者居士种。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。汝等云何掉臂行入白衣舍。呵责已往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等掉臂行入白衣舍。尔时世尊以无数方便呵责六群比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得掉臂行入白衣舍。式叉迦罗尼。比丘义如上。掉臂者垂臂前却。若比丘。故作掉臂行入白衣舍。犯应忏突吉罗。以故作故。犯非威仪突吉罗。若不故作犯突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。或为人所打举手遮。或值暴象来。或师子恶兽盗贼。或逢担棘刺人来举手遮。或浮渡河水。或跳渡坑堑。或泥水。或共伴行不及以手招唤无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(十六竟)

坐亦如上(十七竟)

尔时佛在舍卫国祇树给孤独园。时六群比丘。不好覆身行入白衣舍。时诸居士见皆讥嫌言。此沙门释子不知惭愧。所著衣服不好覆身行入白衣舍。如似婆罗门。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。汝等云何不好覆身行入白衣舍。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等着衣不好覆身行入白衣舍。尔时世尊以无数方便呵责已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。好覆身入白衣舍。式叉迦罗尼。比丘义如上。白衣舍者村落也。不好覆身处处露。若比丘。故作不好覆身行入白衣舍。犯应忏突吉罗。以故作犯非威仪突吉罗。若不故作犯突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。或时被缚。若风吹衣离体无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(十八竟)

坐亦如是(十九竟)

尔时佛在舍卫国祇树给孤独园。尔时六群比丘。左右顾视行入白衣舍。诸居士见皆讥嫌言。此沙门释子不知惭愧。受取无厌。外自称言。我知正法。如是有何正法。如似盗窃人。左右顾视行入白衣舍。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。汝等云何左右顾视行入白衣舍耶。尔时诸比丘往世尊所。头面礼足已在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等左右顾视行入白衣舍。以无数方便呵责六群比丘已告诸比丘言。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得左右顾视行入白衣舍。式叉迦罗尼。比丘义如上。白衣舍者村落也。彼左右顾视者处处看。若比丘。故作左右顾视行入白衣舍。犯应忏突吉罗。以故作故。犯非威仪突吉罗。若不故作犯突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。或仰瞻日时节。或命难梵行难左右处处伺求方便道欲逃走无犯。无犯者。最初未制戒。痴狂心乱病恼所缠(二十竟)

坐亦如是(二十一竟)

尔时佛在舍卫国祇树给孤独园。尔时六群比丘。高声大唤行入白衣舍。时诸居士见皆讥嫌言。此沙门释子不知惭愧。受取无厌。外自称言。我知正法。如是有何正法。高声大唤如似婆罗门众。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责六群比丘言。汝等云何高声入白衣舍。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法。非净行非随顺行。所不应为。云何汝等高声入白衣舍。以无数方便呵责六群比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。静默入白衣舍。式叉迦罗尼。比丘义如上。是中不静默者。高声大唤若嘱授若高声施食。若彼故作高声大唤。犯应忏突吉罗。以故作故。犯非威仪突吉罗。若不故作犯突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。若聋不闻声须高声唤。或高声嘱授。若高声施食。若命难梵行难高声而走无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(二十二竟)

坐亦如是(二十三竟)

尔时佛在舍卫国祇树给孤独园。时六群比丘。戏笑行入白衣舍。时诸居士见皆讥嫌言。此沙门释子不知惭愧受取无厌。外自称言。我知正法。如是有何正法。戏笑行入白衣舍。如似猕猴。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。云何汝等戏笑行入白衣舍。时诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法。非净行非随顺行。所不应为。云何汝等戏笑行入白衣舍。以无数方便。呵责六群比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得戏笑行入白衣舍。式叉迦罗尼。比丘义如上。戏笑者露齿而笑。若比丘。故作戏笑行入白衣舍。犯应忏突吉罗。以故作故。犯非威仪突吉罗。若不故作犯突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。或唇痛不覆齿。或念法欢喜而笑无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(二十四竟)

坐亦如是(二十五竟)

尔时佛在舍卫国祇树给孤独园。尔时有居士。请众僧供设饮食。即其夜办具种种美食。晨朝往白时到。尔时诸比丘。着衣持钵诣居士家就座而坐。居士手自斟酌种种饮食。六群比丘。不用意受食捐弃羹饭。时诸居士见已自相谓言。此沙门释子不知惭愧受取无厌。外自称言。我知正法。如是有何正法。云何不用意受食。贪心多受如谷贵时。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。汝等云何不用意受食。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法。非净行非随顺行。所不应为。云何汝等不用意受食。而捐弃羹饭。以无数方便呵责已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。用意受食式叉迦罗尼。比丘义如上。彼不用意受食者。弃羹饭食。若比丘。故作不用意受食。犯应忏突吉罗。以故作故。犯非威仪突吉罗。若不故作犯突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。或钵小故食时弃饭。或还堕案上无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(二十六竟)

尔时佛在舍卫国祇树给孤独园。时有居士。请众僧设饭食。即其夜办具饮食。晨朝往白时到。尔时诸比丘。到时着衣持钵往居士家就座而坐。时居士手自斟酌羹饭。六群比丘。溢钵受食捐弃羹饭。时居士见已皆讥嫌言。此沙门释子无有惭愧受取无厌。外自称言。我知正法。如是何有正法。受食溢钵。似如饥饿之人贪多。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。汝等云何溢钵受食弃捐羹饭耶。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法。非净行非随顺行。所不应为。云何汝等受食溢钵弃捐羹饭。以无数方便呵责六群比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。当平钵受食式叉迦罗尼。比丘义如上。不平钵者溢满。若比丘。故作不平钵受食。犯应忏突吉罗。以故作故。犯非威仪突吉罗。若不故作犯突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。或时钵小。或时还堕案上无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(二十七竟)

尔时佛在舍卫国祇树给孤独园。时有居士。请众僧欲设饭食。即其夜供办食具。明日往白时到。时诸比丘。着衣持钵往居士家就座而坐。时居士手自斟酌种种饮食羹饭。六群比丘。取饭过多不容受羹。时诸居士见之皆讥嫌言。此沙门释子不知惭愧受取无厌。外自称言。我知正法。如是何有正法。受饭过多不容受羹。似如饥饿贪食之人。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。云何汝等受饭食过多不容受羹。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等受饭过多不容受羹。佛以无数方便呵责六群比丘已告诸比丘言。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。平钵受羹式叉迦罗尼。比丘义如上。彼比丘。故作不平钵受羹。犯应忏突吉罗。以故作故。犯非威仪突吉罗。若不故作犯突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。或时钵小堕食案上若等受无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(二十八竟)

尔时佛在舍卫国祇树给孤独园。时有居士。请众僧供设饭食。即夜办具种种甘膳。晨朝往白时到。时诸比丘。到时着衣持钵往居士家。就座而坐。居士手自斟酌种种饮食及羹。时居士下饭已入内取羹比取羹还。六群比丘食饭已尽。居士问言。饭在何处。比丘报言。我已食尽。时居士。与羹已复还取饭。比取饭还食羹已尽。居士问言。羹在何处。报言。我已食尽。时居士即嫌言。沙门释子不知惭愧受无厌足。外自称言。我知正法。如是有何正法。饭至羹未至。饭已尽。羹至饭未至。羹已尽。似如饥饿之人。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。汝等云何受饭羹未至饭已尽。羹至饭未至羹已尽。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法。非净行。非随顺行。所不应为。云何汝等受饭羹未至饭已尽羹至饭未至羹已尽。以无数方便呵责六群比丘已告诸比丘言。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。羹饭等食式叉迦罗尼。比丘义如上。彼不等者。饭至羹未至饭已尽。羹至饭未至羹已尽。若比丘。故作不等羹饭食者。犯应忏突吉罗。以故作故。犯非威仪突吉罗。若不故作犯突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。或时正须饭不须羹。或时正须羹不须饭。或日时欲过。或命难梵行难疾疾食无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(二十九竟)

尔时佛在舍卫国祇树给孤独园。时有居士。请众僧供设饭食。即夜办具种种多美饮食。晨朝往白时到。时诸比丘。着衣持钵诣居士家就座而坐。时居士手自斟酌饮食。时六群比丘。不次第取食食。时诸居士见已皆讥嫌言。此沙门释子。不知惭愧受取无厌。外自称言。我知正法。如是有何正法。不次第受食食。譬如猪狗食。亦如牛驴乌鸟食。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。汝等云何不次第受食。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法。非净行非随顺行。所不应为。云何汝等不次第食。以无数方便呵责六群比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。以次食式叉迦罗尼。比丘义如上。彼不次第食者。钵中处处取食食。彼比丘。故为不次第取食食者。犯应忏突吉罗。以故作故。犯非威仪突吉罗。若不故作犯突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。或时患饭热挑取冷处食。若日时欲过。若命难梵行难。如是疾疾食无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(三十竟)

尔时佛在舍卫国祇树给孤独园。尔时有居士。请众僧欲供设种种羹饭。即夜办供具。明日往白时到。诸比丘。着衣持钵往诣其家就座而坐。居士手自斟酌种种饮食。时六群比丘。受食当挑钵中而食令现空。时居士讥嫌言。此沙门释子。不知惭愧受取无厌。外自称言。我知正法。如是有何正法。受食似如牛驴骆驼猪狗。似如乌鸟食无异。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。云何汝等当挑钵中而食。时诸比丘往世尊所。头面礼足在一面座。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法。非净行非随顺行。所不应为。云何汝等受食当挑钵中而食。以无数方便呵责六群比丘已。告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得挑钵中而食。式叉迦罗尼。比丘义如上。彼挑钵中食者。置四边挑中央至钵底。若比丘。故为挑钵中食者。犯应忏突吉罗。以故作故。犯非威仪突吉罗。若不故作犯突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗是谓为犯。不犯者。或时有如是病。若患食热开中令冷。若日时欲过。若命难梵行难疾疾刳钵中食者无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(三十一竟)

尔时佛在舍卫国祇树给孤独园。尔时有居士。请众僧欲供设种种好食。即夜办具已。晨朝往白时到。诸比丘着衣持钵诣居士家就座而坐。尔时居士。手自斟酌种种羹饭。尔时六群比丘。自为己索食如似饥饿。时诸居士见已皆讥嫌言。此沙门释子。不知惭愧受取无厌。外自称言。我知正法。如是有何正法。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。汝等云何自为己索食。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。汝等云何自为己索食。以无数方便呵责六群比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得自为己索羹饭。式叉迦罗尼。如是世尊与比丘结戒。时诸病比丘皆有疑。不敢自为己索食。亦不敢为他索若他索食与亦不敢食。佛言。自今已去听病比丘自为己索食为他索若他为己索得食。自今已去当如是说戒。若比丘不病。不得自为己索饭羹。式叉迦罗尼。比丘义如上。彼比丘不病故自为己索羹饭。犯应忏突吉罗。以故作故。犯非威仪突吉罗。若不故作犯突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若病者自索。若为他索。他为己索。若不求而得无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(三十二竟)

尔时佛在舍卫国祇树给孤独园。尔时有居士。请众僧供设种种羹饭。即夜办具已。晨朝往白时到。诸比丘着衣持钵往居士家就座而坐。居士手自斟酌羹饭。时居士与一六群比丘羹已。识次更取羹。比丘于后即以饭覆羹。居士还问言。羹在何处。比丘默然。时居士即嫌言。此沙门释子。不知惭愧受取无厌。外自称言。我知正法。以饭覆羹如似饥饿人。如是有何正法。时诸比丘闻已皆共嫌责六群比丘言。汝等云何受食以饭覆羹更望得耶。尔时诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法。非净行非随顺行。所不应为。云何汝等以饭覆羹更望得耶。以无数方便呵责六群比丘已。告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得以饭覆羹。式叉迦罗尼。如是世尊与比丘结戒。时有比丘。请食。羹污手污钵污衣手巾。有疑不敢以饭覆羹。佛言。自今已去听请食者无犯。欲说戒者当如是说。不得以饭覆羹更望得。式叉迦罗尼。比丘义如上。若彼故为以饭覆羹更望得者。犯应忏突吉罗。以故作故。犯非威仪突吉罗。若不故作犯突吉罗。比丘尼突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。若请食。或时正须羹。有时正须饭无犯。无犯者。最初未制戒。痴狂心乱痛苦所缠(三十三竟)

尔时佛在舍卫国祇树给孤独园。尔时有居士请诸比丘欲设羹饭并种种好食。即夜办具已。晨朝往白时到。诸比丘着衣持钵往诣家士家就座而坐。时居士手自斟酌羹饭种种好食。时六群比丘中一比丘。得食分少。见比坐分多。即语居士言。汝今请僧与食自恣。欲与多者便与多。欲与少者便与少。汝居士有爱。居士报言。我平等想与耳。何故言我有爱耶。尔时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责六群比丘言。汝云何左右视比坐钵中耶。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等。左右视比坐钵中多少。以无数方便呵责六群比丘已。告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得视比坐钵中。式叉迦罗尼。比丘义如上。是中视比坐钵中者。谁多谁少耶。若彼比丘故为视比坐多少者。犯应忏突吉罗。以故作故。犯非威仪突吉罗。若不故作犯突吉罗。比丘尼式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。若比坐病。若眼闇。为看得食不得食净不净受未受。如是无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(三十四竟)

尔时佛在舍卫国祇树给孤独园。尔时有居士。请比丘僧欲供设种种好食。即夜办具已。晨朝往白时到。诸比丘着衣持钵往诣居士家就座而坐。居士手自斟酌种种饮食。有六群比丘。受羹饭已左右顾视不觉比坐比丘取其羹藏之。彼自看不见羹。问言。我向受羹今在何处。比坐比丘言。汝何处来耶。彼答言。我在此置羹在前。左右看视而今无。尔时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。云何汝受羹左右顾视。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等。受羹食而左右顾视。以无数方便呵责六群比丘已。告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。当系钵想食式叉迦罗尼。比丘义如上。不系钵想者左右顾视也。若比丘故作不系钵想食。犯应忏突吉罗。以故作故。犯非威仪突吉罗。若不故作犯突吉罗。比丘尼式叉摩那沙弥沙弥尼突吉罗是谓为犯。不犯者。或时有如是病。或比坐比丘病。若眼闇为受取。瞻看净不净得未得受未受。或看日时。或命难梵行难。欲逃避左右看视者无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(三十五竟)

尔时佛在舍卫国祇树给孤独园。时有居士。请诸比丘欲设种种多美饮食。即夜办具已。晨朝往白时到。诸比丘着衣持钵往居士家就座而坐。时居士手自斟酌饮食。六群比丘。大抟饭食令口不受。居士见讥嫌言。沙门释子。不知惭愧受取无厌。如似猪狗骆驼驴牛乌鸟食。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。云何大抟饭食乃如是也。诸比丘往世尊所。头面礼足却坐一面。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等大抟饭食。以无数方便呵责已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得大抟饭食式叉迦罗尼。比丘义如上。大抟饭者口不容受。若比丘故作大抟饭食。犯应忏突吉罗。以故作故。犯非威仪突吉罗。若不故作犯突吉罗。比丘尼乃至沙弥沙弥尼突吉罗。是谓为犯。不犯者。或有如是病。或日时欲过。或命难梵行难疾疾食无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(三十六竟)

尔时佛在舍卫国祇树给孤独园。时有居士。请诸比丘欲供设种种好食。即夜办具。明日往白时到。诸比丘着衣持钵诣居士家就座而坐。居士手自斟酌饭食。六群比丘受食。食未至先大张口。居士见已讥嫌言。沙门释子。不知惭愧受取无厌。云何食未至先大张口。如似猪狗骆驼牛驴乌鸟。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。汝等云何大张口待食。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等大张口待食。以无数方便呵责六群比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得大张口待饭食。式叉迦罗尼。大张口者。饭抟未至先大张口待。若比丘故作大张口待饭者。犯应忏突吉罗。以故作故。犯非威仪突吉罗。若不故作犯突吉罗。比丘尼乃至沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。或日时欲过。或命难梵行难疾疾食无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(三十七竟)

尔时佛在舍卫国祇树给孤独园。时有居士。请众僧欲设羹饭种种好食。即夜办具已。明日往白时到。诸比丘着衣持钵往居士家就座而坐。居士手自斟酌饭食供养。时六群比丘。受食食含饭语。居士见已讥嫌言。此沙门释子。不知惭愧受取无厌。云何含饭语。似如猪狗骆驼乌鸟食。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。汝等云何含饭语诸比丘往白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等含饭语。以无数方便呵责六群比丘已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与诸比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得含饭语。式叉迦罗尼。彼含饭语者。饭在口中语不可了令人不解。若比丘故作含饭语者。犯应忏突吉罗。以故作故。犯非威仪突吉罗。若不故作犯突吉罗。比丘尼乃至沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。或时噎而索水。或命难梵行难作声食无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(三十八竟)

尔时佛在舍卫国祇树给孤独园。尔时有居士。请诸比丘欲设羹饭种种好食供养。即夜办具。明日往白时到。诸比丘着衣持钵往至其家就座而坐。居士手自斟酌饮食。六群比丘抟饭遥掷口中。居士见已讥嫌言。此沙门释子。不知惭愧受取无厌。如似幻师。时诸比丘。闻其中有少欲知足行头陀乐学戒知惭愧者。嫌责如上已往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。如上呵责六群比丘。乃至最初犯戒已。告诸比丘言。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得抟饭遥掷口中。式叉迦罗尼。若比丘故作遥掷饭抟口中者。犯应忏突吉罗。以故作故。犯非威仪突吉罗。若不故作犯突吉罗。比丘尼乃至沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。若被系缚掷口中食者无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(三十九竟)

尔时佛在舍卫国祇树给孤独园。尔时有居士。请诸比丘欲设羹饭种种好食供养。即夜办具。明日往白时到。诸比丘着衣持钵往至其家就座而坐。居士手自斟酌饭食。时六群比丘。受食不如法。手把饭抟啮半食。居士见已讥嫌言。此沙门释子。不知惭愧受无厌足。食如似猪狗骆驼驴牛乌鸟。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责已往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。无数方便如上呵责六群比丘。乃至最初犯戒已。告诸比丘言。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得遗落饭食。式叉迦罗尼。是中遗落者。半入口半在手中。若比丘故作手把饭抟食半留半者。犯应忏突吉罗。以故作故。犯非威仪突吉罗。若不故作犯突吉罗。比丘尼乃至沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。啖薄饼燋饭。或时啖肉若芥甘蔗。啖菜庵婆罗果梨阎卜果蒱桃蕊叶心不犯。不犯者最初未制戒。痴狂心乱痛恼所缠(四十竟)

四分律卷第二十四分律卷第二十一(初分之二十一)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    百众学法之三

尔时佛在舍卫国祇树给孤独园。时有居士。请诸比丘欲供设种种饮食。即其夜办具。明日往白时到。诸比丘。着衣持钵往其家就座而坐。居士手自斟酌饮食。时有六群比丘颊食。居士见已嫌言。此沙门释子。不知惭愧食如似猕猴。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责已往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。如上呵责六群比丘。乃至最初犯戒已。告诸比丘。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得颊食食尸叉罽赖尼。是中颊食者。令两颊鼓起。如似猕猴状耶。若故作大满口鼓起颊食者。犯应忏突吉罗。以故作故。犯非威仪突吉罗。若不故作犯突吉罗。比丘尼乃至沙弥沙弥尼突吉罗。是为犯不犯者。或时有如是病。或日时欲过。或命难梵行难疾疾食者无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(四十一竟)

尔时佛在舍卫国祇树给孤独园。时有居士。请诸比丘供设种种好美食。即夜办具。明日往白时到。诸比丘。着衣持钵往其家就座而坐。居士手自斟酌饭食。六群比丘嚼饭作声食。居士见已嫌言。此沙门释子无有惭愧。乃至何有正法。如上食如似猪狗骆驼牛驴乌鸟。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。云何嚼饭作声食。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。如上诃责六群比丘。乃至最初犯戒已。告诸比丘言。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得嚼饭作声食。尸叉罽赖尼。若比丘故嚼饭作声食者。犯应忏突吉罗。以故作故。犯非威仪突吉罗。若不故作犯突吉罗。比丘尼式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。嚼干饼及燋饭肉甘[這-言+蔗]苽果庵婆罗果阎卜果蒲萄胡桃椑桃梨风梨无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(四十二竟)

尔时世尊在舍卫国祇树给孤独园。时有居士。请诸比丘供设种种好食。即夜办具。明日往白时到。诸比丘。着衣持钵往诣其家就座而坐。居士手自斟酌饮食。六群比丘大噏饭食。居士见已嫌言。此沙门释子无有惭愧。乃至何有正法。如上食如似猪狗骆驼牛驴乌鸟。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘已往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。如上呵责六群比丘。乃至最初犯戒已。告诸比丘。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得大噏饭食。尸叉罽赖尼。是中噏饭者。张口遥呼噏食。若比丘故噏饭食。犯应忏突吉罗。以故作故。犯非威仪突吉罗。若不故作犯突吉罗。比丘尼乃至沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。若口痛。若食羹。若食酪酪浆酥毗罗浆。若苦酒无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(四十三竟)

尔时佛在舍卫国祇树给孤独园。时有居士。请诸比丘供设种种好食。即其夜办具。明日往白时到。诸比丘。着衣持钵往诣其家就座而坐。居士手自斟酌饮食。六群比丘吐舌舐食。时居士。见已嫌言。此沙门释子无有惭愧。乃至何有正法。如上食如似猪狗骆驼牛驴乌鸟。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘已。往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。如上呵责六群比丘。乃至最初犯戒已。告诸比丘言。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得舌舐食。尸叉罽赖尼。舌舐者。以舌舐饭抟食。若比丘故作舌舐食。犯应忏突吉罗。以故作故。犯非威仪突吉罗。若不故作犯突吉罗。比丘尼乃至沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。或时被缚。或手有泥及垢腻污手舌舐取无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(四十四竟)

尔时佛在舍卫国祇树给孤独园。尔时有居士。请诸比丘供设种种好食。即夜办具。明日往白时到。诸比丘。着衣持钵往诣其家就座而坐。居士手自斟酌饮食。时有六群比丘振手而食。居士见已嫌言。此沙门释子无有惭愧。乃至何有正法。如上食如似王若王大臣。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责已往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。如上呵责。乃至最初犯戒已。告诸比丘。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得振手食。尸叉罽赖尼。若比丘故作振手食。犯应忏突吉罗。以故作故。犯非威仪突吉罗。若不故作犯突吉罗。比丘尼乃至沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。或食中有草有虫。或时手有不净欲振去之。或有未受食手触而污手振去之无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(四十五竟)

尔时佛在舍卫国祇树给孤独园。时有居士。请诸比丘供设种种好食。即夜办具。明日往白时到。诸比丘。着衣持钵往诣其家就座而坐。居士手自斟酌饮食。时有六群比丘。手把散饭食。居士见已嫌言。此沙门释子无有惭愧。乃至何有正法。如上食如似鸡鸟耶。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责已往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊。尔时以此因缘集比丘僧。如上呵责六群比丘。乃至最初犯戒已。告诸比丘。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得手把散饭食。尸叉罽赖尼。把散饭者。散弃饭也。若比丘故作手把散饭食。犯应忏突吉罗。以故作故。犯非威仪突吉罗。若不故作犯突吉罗。比丘尼乃至沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。或时食中有草有虫。或有不净污。或有未受食舍弃无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(四十六竟)

尔时佛在舍卫国祇树给孤独园。时有居士。请诸比丘供设种种好食。即夜办具。明日往白时到。诸比丘。着衣持钵往至其家就座而坐。居士手自斟酌饮食。时有六群比丘。以不净腻手捉饮器食。居士见已嫌言。沙门释子无有惭愧。乃至何有正法。如上以不净手捉饮器。如似王王大臣。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责已往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。如上呵责六群比丘。乃至最初犯戒已。告诸比丘。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得污手捉饮器。尸叉罽赖尼。是中污手者。有腻饭着手。若比丘故作不净腻手捉饮器者。犯应忏突吉罗。以故作故。犯非威仪突吉罗。若不故作犯突吉罗。比丘尼乃至沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。或草上受叶上受洗手受无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(四十七竟)

尔时佛在舍卫国祇树给孤独园。时有六群比丘。在居士家食已洗钵。弃洗钵水及余食狼藉在地。居士见已讥嫌言。沙门释子无有惭愧乃至何有正法。如上多受饮食如饥饿之人。而捐弃狼藉如王大臣。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责已往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。如上呵责六群比丘。乃至最初犯戒已。告诸比丘。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得洗钵水弃白衣舍内。尸叉罽赖尼。是中洗钵水者。杂饭水。若比丘。故作洗钵水弃白衣舍内。犯应忏突吉罗。以故作故。犯非威仪突吉罗。若不故作犯突吉罗。比丘尼乃至沙弥沙弥尼突吉罗。是谓为犯不犯者。或时有如是病。或时以器若澡槃承取水持弃外无犯。无犯者。最初未制戒痴狂心乱痛恼所缠(四十八竟)

尔时佛在舍卫国祇树给孤独园。时六群比丘。大小便涕唾生草菜上。时有居士见已嫌言。沙门释子无有惭愧。外自称言。我知正法。如是何有正法。大小便及涕唾生草菜上。如猪狗骆驼牛驴。时诸比丘闻其中有少欲知足行头陀乐学戒知惭愧者。嫌责已往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。如上呵责六群比丘。乃至最初犯戒已。告诸比丘。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得大小便涕唾生草菜上。尸叉罽赖尼。如是世尊与比丘结戒已。病比丘不堪避生草菜疲极。佛言。病比丘无犯。自今已去当如是说戒。不得生草菜上大小便涕唾除病。尸叉罽赖尼。若比丘不病故生草菜上大小便者。犯应忏突吉罗。以故作故。犯非威仪突吉罗。若不故作犯突吉罗。比丘尼乃至沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。若在无草菜处大小便流堕生草菜上。或时为风吹。或时为乌所衔而堕生草菜中者无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(四十九竟)

尔时佛在舍卫国祇树给孤独园。时六群比丘。水中大小便涕唾。居士见已嫌言。此沙门释子无有惭愧。外自称言。我知正法。如是何有正法。水中大小便。如似猪狗牛驴骆驼。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘已往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。如上呵责六群。乃至最初犯戒。已告诸比丘。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得水中大小便涕唾。尸叉罽赖尼。如是世尊与比丘结戒。时病比丘避有水处疲极。佛言。病者无犯。自今已去当如是说戒。不得净水中大小便涕唾除病。尸叉罽赖尼。若比丘故于水中大小便涕唾。犯应忏突吉罗。以故作故犯非威仪突吉罗。若不故作犯突吉罗。比丘尼乃至沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。或时于岸上大小便流堕水中。或时为风吹乌衔堕水中无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(五十竟)

尔时佛在舍卫国祇树给孤独园。时六群比丘立大小便。居士见已嫌言。此沙门释子无有惭愧。外自称言我知正法。如是何有正法。立大小便。如似牛马猪羊骆驼。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘已往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。如上诃责六群比丘。乃至最初犯戒。已告诸比丘。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得立大小便。尸叉罽赖尼。如是世尊与比丘结戒。时诸病比丘疲极不堪蹲。佛言。病者无犯。自今已去当如是说戒。不得立大小便除病。尸叉罽赖尼。若比丘故作立大小便者。犯应忏突吉罗。以故作故犯非威仪突吉罗。若不故作犯突吉罗。比丘尼乃至沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。被系缚。或时脚[跳-兆+專]有垢腻。若泥污无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(五十一竟)

尔时佛在舍卫国祇树给孤独园。时有六群比丘。与不恭敬反抄衣人说法。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群已往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。如上诃责六群比丘。乃至最初犯戒。已告诸比丘。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得与反抄衣不恭敬人说法。尸叉罽赖尼。尔时诸比丘疑。病反抄衣者不敢为说法。佛言。病者无犯。自今已去不得与反抄衣不恭敬人说法除病。尸叉罽赖尼。若比丘故为反抄衣不恭敬无病人说法。犯应忏突吉罗。以故作故犯非威仪突吉罗。若不故作犯突吉罗。比丘尼乃至沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。若为王王大臣无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(五十二竟)

不得为衣缠颈者说法除病。尸叉罽赖尼。如上(三)

不得为覆头者说法除病。尸叉罽赖尼如上(四)

不得为裹头者说法除病。尸叉罽赖尼。如上(五)

不得为叉腰者说法除病。尸叉罽赖尼。如上(六)

不得为着革屣者说法除病。尸叉罽赖尼。如上(七)

不得为着木屐者说法除病。尸叉罽赖尼。如上(八)

不得为骑乘者说法除病。尸叉罽赖尼。如上(九)

尔时佛在舍卫国祇树给孤独园。时六群比丘止宿佛塔中。时有诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。云何止宿佛塔中。往世尊所头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。如上呵责六群乃至最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得在佛塔中止宿。尸叉罽赖尼。如是世尊与比丘结戒。时有比丘疑。不敢为守护故止宿佛塔中。佛言。为守护故无犯。自今已去应如是说戒。不得在佛塔中止宿。除为守护故。尸叉罽赖尼。若比丘故为佛塔中止宿。犯应忏突吉罗。以故作故犯非威仪突吉罗。若不故作犯突吉罗。比丘尼乃至沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。若为守护故止宿。或为强力者所执。或命难梵行难止宿无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(六十竟)

尔时佛在舍卫国祇树给孤独园。时有六群比丘。藏财物置佛塔中。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘已往世尊所。头面礼足却坐一面。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。如上呵责六群比丘。乃至最初犯戒。已告诸比丘。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得藏财物置佛塔中。尸叉罽赖尼。如是世尊与比丘结戒。时比丘有疑。不敢为坚牢故藏财物着佛塔中。佛言。若为坚牢无犯。自今已去应如是说戒。不得藏财物置佛塔中。除为坚牢。尸叉罽赖尼。若比丘故为持财物置佛塔中。除为坚牢。犯应忏突吉罗。以故作故犯非威仪突吉罗。若不故作犯突吉罗。比丘尼乃至沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。为坚牢故藏着佛塔中。或为强力者所执。或命难梵行难无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(六十一竟)

尔时佛在舍卫国祇树给孤独园。时六群比丘。着革屣入佛塔中。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘。云何汝等。着革屣入佛塔中。诸比丘呵责已。往诣世尊所头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。如上呵责六群比丘。乃至最初犯戒。自今已去与诸比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得着革屣入佛塔中。尸叉罽赖尼。若比丘故为着革屣入佛塔中者。犯应忏突吉罗。以故作故犯非威仪突吉罗。若不故作犯突吉罗。比丘尼乃至沙弥沙弥尼突吉罗。是谓为犯。不犯者或时有如是病。或为强力者所执将入塔中无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(二竟)

不得手捉革屣入佛塔中。尸叉罽赖尼。如上(三)

不得着革屣绕塔行。尸叉罽赖尼。如上(四)

不得着富罗入佛塔中。尸叉罽赖尼。如上(五)

不得手捉富罗入佛塔中。尸叉罽赖尼。如上(六)

尔时佛在舍卫国祇树给孤独园。时六群比丘。在塔下坐食已留残食及草污地而去。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘已。往世尊所头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘如上。乃至最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得塔下坐食。尸叉罽赖尼。如是世尊与比丘结戒。时诸比丘。作塔已施食。作房已施食。若施池井。若众集坐处迮狭。疑佛未听我等塔下坐食。往白佛。佛言。听坐食。不应留草及食污地。时有一坐食比丘若作余食法不食比丘若有病比丘不敢留残食草污地。佛言。听聚着脚边出时持弃之。自今已去当如是说戒不得塔下坐食留草及食污地。尸叉罽赖尼。若比丘。故为在塔下食已留草及残食污地者。犯应忏突吉罗。以故作故犯非威仪突吉罗。若不故作犯突吉罗。比丘尼乃至沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。或时聚一处出时持弃无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(七竟)

尔时佛在舍卫国祇树给孤独园。时六群比丘。担尸死从塔下过。护塔神慎。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。云何汝等。于佛塔下担死尸过。呵责已往诣佛所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。如上呵责六群比丘。乃至最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得担死尸从塔下过。尸叉罽赖尼。若比丘。故担死尸从塔下过者。犯应忏突吉罗。以故作故犯非威仪突吉罗。若不故作犯突吉罗。比丘尼乃至沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。或时须此道行或为强力者所将去无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(八竟)

不得塔中埋死尸。尸叉罽赖尼。如上(九)

不得在塔下烧死尸。尸叉罽赖尼。如上(七十)

不得向塔烧死尸。尸叉罽赖尼。如上(七十一)

不得佛塔四边烧死尸使臭气来入。尸叉罽赖尼。如上(二)

尔时佛在舍卫国祇树给孤独园。时有六群比丘。持死人衣及床从塔下过。彼所住处神嗔。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责已往至佛所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。如上呵责六群比丘。乃至最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得持死人衣及床从塔下过。尸叉罽赖尼。如是世尊与比丘结戒。尔时诸粪扫衣比丘疑。不敢持如是衣从塔下过。比丘白佛。佛言。听浣染香熏已持来入。自今已去应如是说戒。不得持死人衣及床从塔下过。除浣染香熏。尸叉罽赖尼。若比丘。故持死人粪扫衣不浣不染不熏从塔下过。犯应忏突吉罗。以故作故犯非威仪突吉罗。若不故作犯突吉罗。比丘尼乃至沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。若浣染香熏者无犯。无犯者最初未制戒。痴狂心乱痛恼所缠(三)

不得佛塔下大小便。尸叉罽赖尼。如上(四)

不得向佛塔大小便。尸叉罽赖尼。如上(五)

不得绕佛塔四边大小便使臭气来入。尸叉罽赖尼。如上(六)

不得持佛像至大小便处。尸叉罽赖尼。如上。有三事不犯或时有如是病。或时道由中而过。或为强力者所持将去无犯(七)

不得在佛塔下嚼杨枝。尸叉罽赖尼。如上(八)

不得向佛塔嚼杨枝。尸叉罽赖尼。如上(九)

不得佛塔四边嚼杨枝。尸叉罽赖尼。如上(八十)

不得在佛塔下涕唾。尸叉罽赖尼。如上(八十一)

不得向佛塔涕唾。尸叉罽赖尼。如上(二)

尔时佛在舍卫国祇树给孤独园。尔时六群比丘。佛塔四边涕唾。时诸比丘见已嫌责言。汝等云何塔四边涕唾耶。诸比丘往世尊所。头面礼足在一面坐以此因缘具白世尊。世尊尔时以此因缘集比丘僧。诃责六群比丘。乃至最初犯戒。如上告诸比丘。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得塔四边涕唾。尸叉罽赖尼。若比丘。故为塔四边涕唾者。犯应忏突吉罗。以故作故犯非威仪突吉罗。若不故作犯突吉罗。比丘尼乃至沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。或为大鸟衔置塔边。或为风吹去无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(三)

尔时佛在舍卫国。时六群比丘向塔舒脚。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责已往诣佛所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘。乃至最初犯戒如上。已告诸比丘。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得向塔舒脚坐。尸叉罽赖尼。如是世尊与比丘结戒。彼比丘疑。不敢向塔间舒脚。佛言。中间有隔听。自今已去当如是说戒。不得向塔舒脚坐。尸叉罽赖尼。若比丘。故作向塔舒脚者。犯应忏突吉罗以故作故犯非威仪突吉罗。若不故作犯突吉罗。比丘尼乃至沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。若中间隔障。或为强力者所持无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(四)

尔时佛在拘萨罗国游行。向都子婆罗门村。尔时六群比丘。安佛塔在下房已在上房住。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群已往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘。乃至最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得安佛塔在下房已在上房住。尸叉罽赖尼若比丘。故为安佛塔在下房已在上房住。犯应忏突吉罗。以故作故犯非威仪突吉罗。若不故作犯突吉罗。比丘尼乃至沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。持佛塔在下房已在上房住。或命难梵行难无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(五)

人坐己立。不得为说法。尸叉罽赖尼。如上。彼疑。不敢为病人说法。佛言听。自今已去应如是说戒。人坐己立不得为说法。除病。尸叉罽赖尼。若比丘。人坐己立故为说法者。犯应忏突吉罗。以故作故犯非威仪突吉罗。若不故作犯突吉罗。比丘尼乃至沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。若王王大臣捉立无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(六)

人卧己坐。不得为说法。除病。尸叉罽赖尼。如上(七)

人在座己在非座。不得为说法。除病。尸叉罽赖尼。如上(八)

人在高坐己在下坐。不得为说法。除病。尸叉罽赖尼。如上(九)

人在前行己在后。不得为说法。除病。尸叉罽赖尼。如上(九十)

人在高经行处己在下经行处。不应为说法。除病。尸叉罽赖尼。如上(九十一)

人在道己在非道。不应为说法。除病。尸叉罽赖尼。如上(二)

尔时佛在舍卫国祇树给孤独园。时六群比丘。携手在道行或遮他男女。诸居士见已皆讥嫌言。沙门释子不知惭愧。外自称言。我知正法。如是有何正法。携手在道行。如似王王大臣豪贵长者。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘已往世尊所。头面作礼在一面住。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘。乃至最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得携手在道行。尸叉罽赖尼。若比丘故作犯应忏突吉罗。以故作故犯非威仪突吉罗。若不故作犯突吉罗。比丘尼乃至沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。或时有比丘患眼闇须扶接无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(三)

尔时佛在舍卫国祇树给孤独园。时有一比丘。在大树上受夏安居。于树上大小便下。尔时树神慎。伺其便欲断其命根。尔时诸比丘闻。嫌责已往白世尊。世尊尔时以此因缘集比丘僧。如上呵责此一比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何乃于树上大小便。呵责已告诸比丘。自今已去不得树上安居。不得绕树大小便。若先有大小便处大小便无犯。以无数方便呵责已告诸比丘。此痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得上树过人。尸叉罽赖尼。如是世尊与比丘结戒。尔时诸比丘。向拘萨罗国游行。于道中值恶兽。恐怖上树齐人。自念言。世尊制戒不得上树过人。不敢过上。即为恶兽所害。尔时诸比丘。以此因缘往白佛佛言。自今已去听诸比丘若命难梵行难得上树过人。自今已去当如是说戒。不得上树过人。除时因缘。尸叉罽赖尼。若比丘。故作上树过人。犯应忏突吉罗以故作故犯非威仪突吉罗。若不故作犯突吉罗。比丘尼乃至沙弥沙弥尼突吉罗。是谓为犯不犯者。或时有如是病。或命难梵行难上树过人无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(四)

尔时佛在舍卫国祇树给孤独园。尔时跋难陀。络囊中盛钵。贯着杖头肩上担。尔时诸居士。见已谓是官人。皆下道避于屏处看之。乃知是跋难陀。时诸居士皆嫌言。此沙门释子不知惭愧。云何络囊盛钵肩上担在道而行。如似官人。令我下道避之。时有比丘闻。呵责已往白世尊。世尊尔时以此因缘集比丘僧。呵责跋难陀言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝络囊盛钵贯杖头肩上担行。使诸居士下道避之。以无数方便呵责已告诸比丘。是痴人多种有漏处最初犯戒。自今已去与比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。不得络囊盛钵贯杖头着肩上而行。尸叉罽赖尼。若比丘故作犯应忏突吉罗。以故作故犯非威仪突吉罗。若不故作犯突吉罗。比丘尼乃至沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。或为强力者所逼。若被系缚。若命难梵行难无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(五)

尔时佛在舍卫国祇树给孤独园。时有六群比丘。为执杖不恭敬者说法。时诸比丘闻。呵责如上。往白世尊。世尊尔时亦呵责如上已告诸比丘。自今已去与诸比丘结戒。集十句义乃至正法久住。欲说戒者当如是说。人持杖不应为说法。尸叉罽赖尼。彼疑。不敢为病人持杖者说法。佛言。为病人无犯。自今已去与诸比丘结戒。人持杖不恭敬不应为说法。除病。尸叉罽赖尼。若比丘。故为持杖者说法。犯应忏突吉罗。以故作故犯非威仪突吉罗。若不故作犯突吉罗。比丘尼乃至沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。或为王及大臣无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(六)

人持剑。不应为说法。除病。尸叉罽赖尼。如上(七)

人持鉾。不应为说法。除病。尸叉罽赖尼。如上(八)

人持刀。不应为说法。除病。尸叉罽赖尼。如上(九)

人持盖。不应为说法。除病。尸叉罽赖尼。如上(一百竟)

七灭诤法

如是七悔过法。半月半月说戒经来。若有诤事起。即应除灭。应与现前毗尼。当与现前毗尼。应与忆念毗尼。当与忆念毗尼。应与不痴毗尼。当与不痴毗尼。应与自言治。当与自言。治应与觅罪相。当与觅罪相。应与多人觅罪。当与多人觅罪。应与如草覆地。当与如草覆地

四分律卷第二十一四分律卷第二十二(二分之一明尼戒法)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    八波罗夷法

尔时世尊。在毗舍离猕猴江边楼阁讲堂上。时世尊。以此因缘集诸比丘僧。告言。自今已去。我与诸比丘尼结戒。集十句义。一摄取于僧。二令僧欢喜。三令僧安乐。四令未信者信。五已信者令增长。六难调顺者令调顺。七惭愧者得安乐。八断现在有漏。九断未来有漏。十正法得久住。欲说戒者当如是说。若比丘尼。作淫欲犯不净行。乃至共畜生。是比丘尼波罗夷不共住。若比丘尼者。名字为比丘尼。相似比丘尼。自称比丘尼。善来比丘尼。乞求比丘尼。着割截衣比丘尼。破结使比丘尼。受大戒白四羯磨如法成就得处所比丘尼。是中比丘尼。若受大戒白四羯磨如法成就得处所。住比丘尼法中。是谓比丘尼义。作淫欲犯不净行乃至共畜生者。所可得行淫处者是。波罗夷者。譬如人断头不可复起。比丘尼亦复如是。犯波罗夷已不复成比丘尼。故名波罗夷。云何名不共住。有二不共住。一羯磨一说戒。彼比丘尼。不得于是二事中住。是故名不共住。有三处行淫波罗夷。人非人畜生。于此三处共行淫犯波罗夷。复于三种男行淫犯波罗夷。人男非人男畜生男。于此三处共行淫犯波罗夷。于三种二形行淫犯波罗夷。人二形非人二形畜生二形。于此三处二形共行淫波罗夷。于三种黄门行淫犯波罗夷。人黄门非人黄门畜生黄门。于此三处行淫波罗夷。比丘尼有淫心。捉人男根。着三处大小便道及口。入者犯。不入者不犯。有隔有隔有隔无隔无隔有隔无隔无隔波罗夷。非人男畜生男二形男黄门亦如是。比丘尼有淫心。捉眠男子及死者身未坏者少坏者男根入三处。入者犯。不入不犯。有隔有隔有隔无隔无隔有隔无隔无隔波罗夷。非人男畜生男二形男黄门亦如上。若比丘尼。为贼所捉。将诣人男所。以彼男根着三处。初入觉乐入已乐出时乐波罗夷。初入乐入已乐出时不乐波罗夷。初入乐入已不乐出时乐波罗夷。初入乐入已不乐出时不乐波罗夷。初入不乐入已不乐出时乐波罗夷。初入不乐入已乐出时不乐波罗夷。初入不乐入已乐出时乐波罗夷。此是第六句。有隔乃至无隔无隔亦如上。非人男畜生男二形男黄门。有隔乃至无隔无隔亦如上。若比丘尼为贼所捉。将至眠男子所及死者身未坏少坏者所。以彼男根着三处。初入乐入已乐乃至初入不乐入已不乐出时乐亦如上。有隔有隔乃至无隔无隔亦如上。乃至黄门亦如上。有隔有隔乃至无隔无隔亦如上。若比丘尼为贼所捉。于三处行淫。从初入乐入已乐出时乐。乃至初入不乐入已不乐出时乐亦如上。有隔有隔乃至无隔无隔亦如上。若比丘尼方便欲行不净。若作者波罗夷。不作者偷兰遮。比丘方便教比丘尼犯淫。作者偷兰遮。不作者突吉罗。比丘尼教比丘尼犯淫。作者偷兰遮。不作者突吉罗。除比丘比丘尼。教余者作不作一切突吉罗。比丘波罗夷。式叉摩那沙弥沙弥尼突吉罗灭摈。是谓为犯。不犯者。眠无所觉知不受乐一切无欲心不犯不犯者。最初未结戒。痴狂心乱痛恼所缠(一竟)

尔时世尊在罗阅城耆阇崛山中。尔时世尊以此因缘集比丘僧告言。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。在聚落若空处。不与怀盗心取随所盗物。若为王若王大臣所捉。若缚若杀若驱出国。汝贼汝痴。若比丘尼作如是不与取。是比丘尼波罗夷不共住(二竟)

尔时世尊在毗舍离。以此因缘集诸比丘僧。告诸比丘。自今已去与诸比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。故自手断人命。若持刀授与人。若叹死誉死劝死。咄人用此恶活为。宁死不生。作如是心念。无数方便叹死誉死劝死。此比丘尼波罗夷不共住(三竟)

尔时世尊在毗舍离猕猴江边楼阁讲堂上。以此因缘集诸比丘僧告诸比丘。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。实无所知自叹誉言。我得过人法入圣智胜法。我知是我见是。后于异时。若问若不问。欲求清净故作如是言。诸大姊。我实不知不见。而言我知我见。虚诳妄语。除增上慢。是比丘尼波罗夷不共住(四竟)

尔时世尊在舍卫国祇树给孤独园。时有大豪贵长者。名大善鹿乐。颜貌端政。偷罗难陀比丘尼亦颜貌端政。长者鹿乐系心于偷罗难陀所。偷罗难陀亦系心于长者所。后于异时。为偷罗难陀故。请诸比丘尼及偷罗难陀设食。即于其夜办具种种饮食。清旦往白时到。偷罗难陀知长者为己故请僧。彼即自住寺不往。诸比丘尼。到时着衣持钵诣长者家就坐已。时长者。遍观尼众不见偷罗难陀。即问。偷罗难陀何处而不来耶。答言。在寺不来。于是长者疾疾行食已。即往寺中至偷罗难陀所。偷罗难陀。遥见长者来即卧床上。长者前问。阿姨何所患苦。答言。无所患苦。我所欲者而彼不欲。彼言我欲非不欲。时长者即前抱卧以手摩捉呜。长者还坐问言。阿姨所须何物。答言。我欲得酸枣。长者言。欲得者明日当送。时有守房小沙弥尼。见作如此事。诸尼食还已具向说之。比丘尼众闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责偷罗难陀比丘尼言。云何汝与长者作如此事耶。诸比丘尼白诸比丘。诸比丘往白世尊。世尊即以此因缘集比丘僧。以无数方便呵责偷罗难陀比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何偷罗难陀。汝与长者作如此事。尔时世尊以无数方便呵责已告诸比丘。此偷罗难陀比丘尼痴人。多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼染污心。共染污心男子。从腋已下膝已上身相触。若捉摩若牵若推若上摩若下摩若举若下若捉若捺。是比丘尼波罗夷不共住。是身相触也。比丘尼义如上。染污心者意相染着。染污心男子亦如是。腋已下者腋已下身分。膝已上者膝已上身分也。身者。从足指乃至头发。身相触者二身若捉摩若牵若推若逆摩若顺摩若举若下若捉若捺。捉摩者。手摩身前后。牵者牵前。推者推却。逆摩者从下至上。顺摩者从上至下。举者抱举。下者抱下或坐或立。捉者或捉前或捉后或捉髀或捉乳。捺者。或捺前捺后捺乳捺髀。男子男子想。男子以手摩尼。身身相触欲意染着。受触乐波罗夷。男子男子想。男子以手摩尼身动身欲意染着。受触乐波罗夷。乃至捉捺亦如是。是男子疑者。偷兰遮。若男作男想。以身触彼衣璎珞具。欲心染着受触乐偷兰遮。若男作男想。以身触彼衣璎珞具。欲心染着不受触乐偷兰遮。若男作男想。男以身衣璎珞具触尼身。欲心染着受触乐偷兰遮。若男作男想。男以身衣璎珞具触尼身。欲心染着不受触乐偷兰遮。男作男想。以身触男衣璎珞具。欲心染着动身不受触乐偷兰遮。若男作男想。以身触男衣璎珞具。欲心染着不动身受触乐偷兰遮。若男作男想。男以身衣璎珞具触尼身。欲心染着动身不受触乐偷兰遮。男作男想。男以身衣璎珞具触尼身。欲心染着受触乐不动身偷兰遮。若男作男想。身相触欲心染着不受触乐动身偷兰遮。男作男想。身相触欲心染着受触乐不动身偷兰遮。如是捉摩乃至捺一切偷兰遮。若男疑突吉罗。男作男想。以身衣触身衣璎珞具。欲心染着受触乐突吉罗。男作男想。以身衣触身衣璎珞具。欲心染着不受触乐突吉罗。男作男想。以身衣触身衣璎珞具。欲心染着不受触乐动身突吉罗。男作男想。以身衣触身衣璎珞具。欲心染着受触乐不动身突吉罗。男作男想。以身衣触身衣璎珞具。欲心染着不受触乐不动身突吉罗。男作男想。以身衣触身衣璎珞具。欲心染着受触乐动身突吉罗。乃至捉捺一切突吉罗。是男疑突吉罗。若比丘尼与男子身相触一触一波罗夷。随触多少一一波罗夷。若天男阿修罗男乃至畜生男能变形者。身相触偷兰遮。不能变形者。身相触突吉罗。若与女人身相触突吉罗。若与二形人身相触者偷兰遮。若男子作礼捉足。觉触乐不动身突吉罗。若比丘尼有欲心。触衣钵尼师檀针筒革屣。乃至自触身一切突吉罗。人男人男想波罗夷。于人男疑偷兰遮。人男非人男想偷兰遮。非人男作人男想偷兰遮。非人男生疑偷兰遮。比丘僧伽婆尸沙。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若取与时触身。若戏笑时触。若有所救解时触。一切无欲心不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(五竟)

尔时世尊在舍卫国祇树给孤独园。尔时舍卫城中有长者。名沙楼鹿乐。颜貌端正。偷罗难陀比丘尼亦颜貌端正。鹿乐长者系心偷罗难陀所。偷罗难陀亦系心鹿乐所。尔时偷罗难陀比丘尼欲心。受长者捉手捉衣。共入屏处共立共语共行以身相倚共期。尔时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责偷罗难陀比丘尼。汝云何欲心。受长者捉手捉衣。入屏处共立共语共行以身相倚共期。尔时诸比丘尼白诸比丘。诸比丘往白世尊。世尊尔时以此因缘集诸比丘僧。呵责偷罗难陀。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何偷罗难陀比丘尼。欲心受此长者捉手捉衣乃至共期。尔时世尊。以无数方便呵责偷罗难陀已告诸比丘。此偷罗难陀多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼染污心。知男子染污心。受捉手捉衣。入屏处共立共语共行。或身相倚或共期。是比丘尼波罗夷不共住。犯此八事故。比丘尼义如上。染污心者心有染着。染污心男子亦有染着。捉手者。捉手乃至腕捉衣者捉身上衣。入屏处者离见闻处也。屏处共立者离见闻处也。共语者亦离见闻处。共行者亦离见闻处。身相倚者身得相及处。共期者得共行淫处也。彼比丘尼染污心。受染污心男子捉手。偷罗遮。捉衣偷罗遮。入屏处。屏处共立。屏处共语。屏处共行。以为乐。以身相倚。一一偷罗遮。于七事中。若不发露忏悔罪未除。若犯第八事波罗夷。天子龙子阿修罗子夜叉子饿鬼畜生能变形者。犯七事一一突吉罗。若犯第八事偷罗遮。畜生不能变形者。犯第八事突吉罗。与染污心女人犯第八事者突吉罗。比丘随所犯式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若有所取与时手相触。或戏笑。或有所救解捉衣。若有所施与。若礼拜。若悔过。若受法入屏处共住。若有所施与。若礼拜。若悔过。若受法入屏处共立。若有所施与。若礼拜。若悔过。若受法入屏处共语。若有所施与。若礼拜。若忏悔。若受法入屏处共行。若为人打。若贼来。若有象来。若恶兽来。若有刺来回身避。若来求教授。若听法。若受请。若来至寺内。若共期不可作恶事处无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(六竟)

尔时世尊在舍卫国祇树给孤独园。时偷罗难陀比丘尼妹。字坻舍难陀。其人犯波罗夷法。时偷罗难陀比丘尼。知便作是念。此坻舍难陀是我妹。今犯波罗夷法。我正欲向人说。惧彼得恶名称。若彼得恶名称于我亦恶。遂默然不说。彼于异时。坻舍比丘尼。休道诸比丘尼见。语偷罗难陀言。见汝妹已舍道不。答言。彼所作是非为不是。诸比丘尼问。云何所作是。偷罗难陀答言。我先知彼有如是如是事。诸比丘尼言。汝若先知。何以不向诸比丘尼说。偷罗难陀答言。坻舍是我妹。犯波罗夷法即欲向人说。惧得恶名称。若彼得恶名称于我亦恶。以是故我不向人说。尔时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责偷罗难陀言。汝云何覆藏坻舍重罪。诸比丘尼白诸比丘。诸比丘往白世尊。世尊尔时以此因缘集诸比丘僧。呵责偷罗难陀比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何偷罗难陀。汝乃覆藏坻舍比丘尼重罪。尔时世尊。以无数方便呵责偷罗难陀比丘尼已。告诸比丘。偷罗难陀比丘尼。多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼知他犯波罗夷。不自举不白僧不语人。彼于异时。彼比丘尼。或休道。若灭摈。若众僧遮。若入外道。后作是言。我先知有如是如是罪。是比丘尼波罗夷不共住。覆重罪故。如是世尊与比丘尼制戒。或于城内犯波罗夷。出至村中。或村中犯波罗夷。来入城内。时诸比丘尼。亦不知犯波罗夷不犯。后乃知犯波罗夷。或有言犯波罗夷者。或有疑者。佛言。不知者无犯。自今已去当如是说戒。若比丘尼。知比丘尼犯波罗夷。不自发露。不语众人。不白大众。若于异时。彼比丘尼。或命终。或众中举。或休道。或入外道众。后作是言。我先知有如是如是罪。是比丘尼波罗夷不共住。覆藏重罪故。比丘尼义如上。知者我知犯如是如是罪。僧者一羯磨一说戒。大众者。或四人或过四人。休道者出此法外。灭摈者。僧与作白四羯磨除去。遮者。众中断决罪时遮不听入众。入外道者。受外道法。重罪者。八波罗夷。于八法中犯一一罪。彼比丘尼。知是比丘尼犯波罗夷。前食时知后食时说偷兰遮。后食时知初夜说偷兰遮。初夜知中夜说偷兰遮。中夜知后夜说偷兰遮。后夜知不说至明相出波罗夷。除八波罗夷法。覆余罪不说者。随所犯自覆重罪偷兰遮。除比丘比丘尼。覆余人罪突吉罗。比丘波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若不知。若向人说。若无人可向说。意欲说而未说明相出。若说者。有命难有梵行难。不得说不犯。不犯者最初未制戒。痴狂心乱痛恼所缠(七竟)

尔时世尊在拘睒弥瞿师罗园中。时尊者阐陀比丘。僧为作举。如法如律如佛所教。不顺从不忏悔。僧未与作共住。时有比丘尼。名尉次。往返承事阐陀比丘。诸比丘尼语言。阐陀比丘。僧为作举。如法如律如佛所教。不顺从不忏悔。僧未与作共住。汝莫顺从。尉次答言。诸大姊。此是我兄。今日不供养。更待何时。犹故随顺不止。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责尉次比丘尼言。阐陀比丘。僧为作举。如法如律如佛所教。而不顺从不忏悔。僧未与作共住。汝今云何故顺从也。尔时诸比丘尼语诸比丘。诸比丘往白世尊。世尊以此因缘集诸比丘僧。呵责尉次比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。阐陀比丘。僧为作举。如法如律如佛所教。而不顺从不忏悔。僧未与作共住。云何故顺从。以无数方便呵责已。告诸比丘。听僧与尉次比丘尼作呵责白四羯磨。当作如是呵责。尼众中应差堪能人。若上座若次座若诵律若不诵律堪能作羯磨者。作如是白。大姊僧听。是尉次比丘尼。知阐陀比丘。僧为作举。如法如律如佛所教。而不顺从不忏悔。僧未与作共住。而顺从阐陀比丘。诸比丘尼语言。阐陀比丘。僧为作举。如法如律如佛所教。不顺从不忏悔。僧未与作共住。汝莫顺从。而故顺从。若僧时到僧忍听。僧与尉次比丘尼作呵责。舍此事故。大姊。阐陀比丘。僧为作举。如法如律如佛所教。而不顺从不忏悔。僧未与作共住。汝莫随顺。白如是。大姊僧听。是尉次比丘尼。知阐陀比丘。僧为作举。如法如律如佛所教。不顺从不忏悔。僧未与作共住。而顺从阐陀比丘。诸比丘尼语言。阐陀比丘。僧为作举。如法如律如佛所教。不顺从不忏悔。僧未与作共住。汝莫随顺。而故随顺。僧今与尉次比丘尼作呵责。舍此事故。阐陀比丘。僧为作举如法如律如佛所教。不顺从不忏悔。僧未与作共住。汝莫随顺。谁诸大姊忍。僧与尉次比丘尼作呵责。舍此事者默然。谁不忍者说。是初羯磨。第二第三亦如是说。僧已与尉次比丘尼作呵责。舍此事竟。僧忍默然故。是事如是持。当作如是呵责。尉次比丘尼。僧与作白四羯磨已。白诸比丘。诸比丘往白世尊。世尊言。若有如此比丘尼顺从为僧所举比丘者。僧亦应如是与作呵责白四羯磨。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼知比丘僧为作举。如法如律如佛所教。不顺从不忏悔。僧未与作共住而顺从。诸比丘尼语言。大姊。此比丘。为僧所举。如法如律如佛所教。不顺从不忏悔。僧未与作共住。汝莫顺从。如是比丘尼谏彼比丘尼时。是事坚持不舍。彼比丘尼应乃至第二第三谏。令舍此事故。若乃至三谏舍者善。若不舍者。是比丘尼波罗夷。不共住犯随举。比丘尼义如上僧者如上举者。为僧所举。白四羯磨是也。法者。如法如律如佛所教。不顺从者。不顺治罪法。不忏悔者所犯罪未忏悔清净。僧未与作共住者。僧未与解罪羯磨。随顺者有二种。一法二衣食。法随顺者。教增戒增心增慧教语学问诵经。衣食者。与饮食衣服床卧具病瘦医药。若比丘尼知比丘为僧所举。如法如律如佛所教。不随顺不忏悔。僧未与作共住而随顺。诸比丘尼语言。此比丘。僧与作举。如法如律如佛所教。不顺从不忏悔。僧未与作共住。汝莫随顺。可舍此事。莫为僧所举更犯重罪。若随语者善。不随语者。当作白。白已当复语言。妹当知。我白已。余有羯磨在。汝舍此事。莫为僧所举更犯重罪。若随语者善。不随语者。当作初羯磨。作初羯磨已当语言。妹我已与汝作白初羯磨竟。余有二羯磨在。汝可舍此事莫为僧所举更犯重罪。若随语者善。不随语者。当作第二羯磨。作第二羯磨已。当复语言。妹知不。我已作白二羯磨竟。余有一羯磨在。汝舍此事。莫为僧所举更犯重罪。若随语者善。不随语者。作第三羯磨竟波罗夷。白二羯磨竟舍者三偷兰遮。白一羯磨竟舍者二偷兰遮。白竟舍者一偷兰遮。若作白未竟舍者突吉罗。若未白前随顺所举比丘者一切突吉罗。若僧为随举比丘尼作呵责时。有比丘教言。汝莫舍。若僧与作呵责偷兰遮。若不呵责突吉罗。若比丘尼语言。莫舍。若僧与呵责偷兰遮。若不呵责突吉罗。除比丘比丘尼。余人教莫舍。呵责不呵责一切突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者初谏时舍。非法别众。非法和合众。法别众。似法别众。似法和合众。异法异毗尼异佛所教。一切未作呵责前不犯。不犯者最初未制戒。痴狂心乱痛恼所缠(八竟)

    十七僧残法之初

尔时世尊。在罗阅城耆阇崛山中。时世尊以此因缘集比丘僧。告诸比丘。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼媒嫁持男语语女。持女语语男。若为成妇事。若为私通乃至须臾间。是比丘尼犯初法应舍僧伽婆尸沙(一竟)

尔时世尊。在罗阅城耆阇崛山中。时世尊以此因缘集比丘僧。告诸比丘。自今已去与比丘尼结戒集十句义乃至正法久住。欲说戒者当如是说。若比丘尼嗔恚不喜。以无根波罗夷法谤。欲破彼清净行。后于异时。若问若不问。知是事无根。说我嗔恚故如是语。是比丘尼。犯初法应舍僧伽婆尸沙(二竟)

尔时世尊。在罗阅城耆阇崛山中。时世尊以此因缘集比丘僧。告诸比丘自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼嗔恚不喜。于异分事中取片。非波罗夷比丘尼以无根波罗夷法谤欲破彼人梵行。后于异时。若问若不问。知是异分事中取片。彼比丘尼住嗔恚法故。作如是说是比丘尼。犯初法应舍僧伽婆尸沙(三竟)

尔时世尊。在舍卫国祇树给孤独园。有比丘尼在阿兰若处住。有一居士于此处作一精舍。施与比丘尼僧住。后异时。阿兰若处比丘尼有恶事出。诸比丘尼舍此精舍去。居士后命终。时居士儿即耕此精舍地。诸比丘尼见语言。此是众僧地莫耕。居士儿答言实尔。我父在时作此精舍与比丘尼僧比丘尼僧舍去。我父命终。我今自由何为空此处地彼此无用耶。时居士儿如故耕之。诸比丘尼即往断事官所言。尔时诸断事官。即唤居士儿依法决断。罚其财货尽入于官。尔时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责彼比丘尼。云何比丘尼诣官言。居士儿使财物入官也。尔时诸比丘尼白诸比丘。诸比丘往白世尊。世尊尔时以此因缘集比丘僧。呵责彼比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何比丘尼诣官言人。尔时世尊以无数方便呵责彼比丘尼已。告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼言人。若居士居士儿。若奴若客作人。若昼若夜。若一念顷。若弹指顷。若须臾顷。是比丘尼。犯初法应舍僧伽婆尸沙。如是世尊与比丘尼结戒。尔时拘萨罗国波斯匿王小妇。作一精舍施与比丘尼。彼比丘尼受住。已后舍人间游行。时王小妇。闻比丘尼舍精舍人间游行。辄复以此精舍转与女梵志。时彼比丘尼闻。念言。我行不在。辄以我精舍与人。时彼比丘尼即还精舍。语女梵志言避我去莫住我精舍。彼女梵志答言。此实是汝精舍。施主为汝作。汝出人间游行。持用与我。我今不能出去。时彼比丘尼嗔。即牵曳令出。时女梵志即诣断事官言。时诸断事官。唤比丘尼。比丘尼疑难不去。自念。世尊制戒。不得诣断事官相言。尔时比丘尼白诸比丘。诸比丘往白世尊。世尊告诸比丘。自今已去若有唤应往。时彼比丘尼。即往断事官所。诸断事官问言。阿姨此事云何好说。比丘尼答言。此一切地皆属王。家事属居士。房舍属施主。床座卧具亦尔。修治房舍令众僧住止。得福多。何以故。由其施我得安住故。诸断事官答言。如阿姨所说。一切地属王。家事属居士。屋舍属施主。床座卧具亦尔。修治房舍令僧住止。得福多。何以故。由其施我得安住故。今此精舍应与女梵志令住。尔时诸比丘往白世尊。世尊告诸比丘。此比丘尼不善说。断事官亦不善答。何以故。前施是法。后施非法。尔时波斯匿王闻。比丘尼如是说。诸断事官如是答。世尊作如是语时。王罚诸断事官财物尽入官。诸比丘闻往白世尊。世尊尔时告诸比丘。自今已去当如是说戒。若比丘尼诣官言。居士若居士儿。若奴若客作人。若昼若夜。若一念顷。若弹指顷。若须臾顷是比丘尼。犯初法应舍僧伽婆尸沙。比丘尼义如上。相言者。诣官共诤曲直。居士者。不出家人。儿者居士所生。奴者或买得或家所生。客作者财雇使作也。女梵志者。在此法外出家者是。若比丘尼言人。若居士居士儿。若奴客作人。若昼若夜。若一念顷。若弹指顷。若须臾顷。如女梵志诣官称其事。若断事官。下手疏事者僧伽婆尸沙。口说不著名字者偷罗遮。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若被唤。若欲有所启。若为强力所持去。若被系将去。若命难若梵行难虽口说不告官不犯。不犯者最初未制戒。痴狂心乱痛恼所缠(四竟)

尔时世尊。在毗舍离猕猴江侧。在楼阁堂上时。有离奢妇女出外游戏。时有贼女在是众中共行。伺其作乐戏时偷彼财物逃走。时诸妇女遣使往告离奢。此有贼女取我财物走去。愿与我求觅。时诸离奢。遣人求觅得便当杀之。时贼女闻此语。遣人求觅得便杀。即舍毗舍离逃走。诣王舍城。至比丘尼僧伽蓝中。语诸尼言。我有信心贪乐出家。诸尼闻已。即便度出家受具足戒。时诸离奢闻。此贼女逃走诣王舍城。即往告摩竭国瓶沙王。此有贼女。取我妇女财物逃走来此。愿王与我求觅。时洴沙王。即敕左右检校求之。左右白王言。有贼女已在尼僧伽蓝中出家为道。时洴沙王闻有贼女来此比丘尼已度出家为道。即遣信语诸离奢。闻有贼女在尼僧伽蓝中已出家为道。我不能语。时诸离奢皆共讥嫌言。诸比丘尼。不知惭愧皆是贼女。外自称言。我知正法。云何度他贼女。其罪应死。多人所知。度令出家受具足戒。如是何有正法。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责彼比丘尼。汝云何度贼女令出家为道。时诸比丘尼白诸比丘。诸比丘往白世尊。世尊以此因缘集诸比丘。呵责彼比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。知是贼女。云何度令出家受具足戒。尔时世尊。以无数方便呵责彼比丘尼已。告诸比丘。是比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。度他贼女应死者多人所知。度令出家受具足戒。是比丘尼。犯初法应舍僧伽婆尸沙。如是世尊与比丘尼结戒。彼城中作贼出外村。外村作贼入城内。时诸比丘尼。不知贼与不贼。应死不应死人知不知。后乃知是贼应死人所知。或有言犯僧伽婆尸沙或疑。佛言。不知者不犯。自今已去当如是说戒。若比丘尼。先知是贼女罪应死人所知。不问王大臣。不问种姓。便度出家受具足戒。是比丘尼犯初法应舍僧伽婆尸沙。比丘尼义如上。贼者。若盗五钱若过五钱。应死者处在死中也。多人知者王所知大臣所知庶民共知。王者。不依人食。大臣者。受王重位佐理国事。种姓者。舍夷拘离弥宁跋耆满罗苏摩。彼比丘尼。知贼女罪应死多人所知。不问王大臣种姓。便度为道。作三羯磨竟。和上尼僧伽婆尸沙。若作白二羯磨竟三偷罗遮。白一羯磨竟二偷罗遮。白竟一偷兰遮。若白未竟突吉罗。若未白前。若与剃发。若与出家与受戒集众僧。一切突吉罗。众满亦突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若不知。或白王大臣种姓。若罪应死王听出家。若有罪听出家。若于系缚中放令出家。若救使得脱不犯。不犯者最初未制戒。痴狂心乱痛恼所缠(五竟)

尔时世尊。在舍卫国祇树给孤独园。时尉次比丘尼。为僧所举。如法如律如佛所教。不顺从有罪不忏悔。僧未与作共住。时偷罗难陀比丘尼。不白尼僧。僧不约敕。辄自出界外。与尉次作解罪羯磨。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责偷罗难陀比丘尼。云何尼僧如法如律如佛所教举尉次比丘尼。而不顺从有罪不忏悔。僧未与作共住。尼僧不约敕。汝辄自出界外与解罪。尔时诸比丘尼白诸比丘。诸比丘往白世尊。世尊以此因缘集诸比丘僧呵责偷罗难陀。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何偷罗难陀。尼僧如法如律如佛所教。举尉次比丘尼。而不顺从有罪不悔。僧未与作共住。尼僧不约敕。汝辄自出界外与作羯磨解罪。尔时世尊告诸比丘。偷罗难陀多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。知比丘尼为僧所举。如法如律如佛所教。不顺从未忏悔。僧未与作共住羯磨为爱故。不问僧僧不约敕。出界外作羯磨与解罪。是比丘尼犯初法应舍僧伽婆尸沙。比丘尼义如上。僧者如上说。举者僧所举白四羯磨也。法者如法如律如佛所教。不顺从者。佛所制治罪法不行不悔者。有罪不向人说。未与作共住者。为僧所举未与解罪。爱故不问僧僧不约敕。出界外作羯磨与解罪。三羯磨竟僧伽婆尸沙。白二羯磨竟三偷罗遮。白一羯磨竟二偷罗遮。白竟一偷罗遮。白未竟突吉罗。未白前集众众满一切突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。白众僧。若被僧约敕。若能下意悔本罪。若僧以恚故不与解罪。彼人与解无犯。若先僧与作羯磨已。此僧移或死。若远行若休道。为贼所将去为水所漂。彼与解罪不犯。不犯者最初未制戒。痴狂心乱痛恼所缠(六竟)

尔时世尊。在舍卫国祇树给孤独园。时有比丘尼。独高褰衣渡水。从此岸至彼岸然。彼比丘尼颜貌端政。时有贼见已系意在彼。令渡水竟便捉触娆。诸居士见皆共嫌之。此比丘尼不知惭愧行不净法。外自称言。我知正法。而独自行高褰衣渡水。如淫女无异。如是何有正法。尔时差摩比丘尼。多诸弟子。去彼僧伽蓝不远有亲里村。有少事缘舍众独入村。诸居士见共相谓言。此差摩比丘尼所以独行者。欲得男子故耳。彼比丘尼即于彼村中独宿不还。诸居士复言。所以独宿者。正须男子故耳。时有六群比丘尼。及偷罗难陀与众多比丘尼。于拘萨罗国旷野中行。时六群比丘尼。及偷罗难陀比丘尼。常在后独行下道诸比丘尼见已语言。诸妹。汝等何故在后行不与我等俱。答言。汝等但自行。何与汝事。彼即问言。汝等不闻佛结戒当共伴相逐行耶。六群比丘尼偷罗难陀答言。汝等不知我耶。答言不知。彼言。我等所以在后行者。欲得男子。诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责彼比丘尼。云何比丘尼。高褰衣渡水独行诣村落独宿共伴行而独在后。时诸比丘尼白诸比丘。诸比丘往白世尊。世尊尔时以此因缘集比丘僧。以无数方便呵责彼比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何比丘尼。独高褰衣渡水独行诣村独宿共伴行独在后。时世尊以无数方便呵责彼比丘尼已。告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼独渡水独入村独宿独在后行。犯初法应舍僧伽婆尸沙。比丘尼义如上。水者河水独不能渡。彼比丘尼。当求一比丘尼共渡。比丘尼应渐褰衣入水待伴。前比丘尼疾疾入水令伴不及。僧伽婆尸沙。若入水时随水深浅褰衣待后伴。若疾疾入水不待后伴。偷兰遮。若至彼岸渐渐下衣待后伴。若发意速疾不渐渐下衣上岸不待后伴。偷兰遮。彼比丘尼。当求一比丘尼共行诣村。若比丘尼。独行诣村随所至村。僧伽婆尸沙。若无村独诣空旷无道处行一鼓声间僧伽婆尸沙。独行未至村偷兰遮。减一鼓声偷兰遮。独行村中一界突吉罗。求方便欲行而不去。若结伴欲去而不去。一切突吉罗。彼比丘尼共宿应在舒手相及处。彼比丘尼独宿随胁着地。僧伽婆尸沙。随转侧僧伽婆尸沙。若比丘尼共在村中宿。卧时使舒手相及。若舒手不相及。一一转侧一一僧伽婆尸沙。彼比丘尼共在道行。不得离见闻处行。若比丘尼在道行离见闻处僧伽婆尸沙。离见处不离闻处偷兰遮。离闻处不离见处偷兰遮。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。二比丘尼共渡水。入水时随水深浅渐渐褰衣。待后伴入水。去时不疾疾去待伴。上岸时渐渐下衣待后伴。或神足渡乘船渡。或桥上渡蹑梁渡。若伴比丘尼命终。若休道若远行。若贼将去。若命难或梵行难。或恶兽难。或为强力者将去。被缚将去。或为水所漂无犯。若二比丘尼入村。若于村中间一伴比丘尼死。或休道或远行或为贼将去。乃至水所漂如上无犯。若共二比丘尼宿舒手相及处。若一比丘尼出大小便。或受经诵经。若乐静独处经行。或为病尼煮羹粥作饭。若命终若休道。若远行若贼将去。乃至为水所漂。亦如上无犯。与二比丘尼共行不离见闻处不犯。若一比丘尼出大小便。或命终或休道或为贼所将去。乃至为水所漂如上不犯。不犯者最初未制戒。痴狂心乱痛恼所缠(七竟)

四分律卷第二十二四分律卷第二十三(二分之二明尼戒法)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    十七僧残法之余

尔时佛在舍卫国。时世谷米勇贵乞食难得。时有比丘尼入城乞食空钵而还。时提舍难陀比丘尼。到时着衣持钵入城乞食。渐次到一贩卖人家默然而立。是堤舍比丘尼颜貌端政。贩卖人见已便系心在彼。即前问言。阿姨何所求索。报言。我欲乞食。彼言。授钵来。即便与钵。彼盛满钵羹饭。授与堤舍比丘尼。堤舍比丘尼。后数数着衣持钵。诣贩卖人家默然而立。彼复问言。阿姨何所求索。报言我欲乞食。彼即复盛满钵羹饭授与。诸比丘尼见已便问言。如今谷米勇贵乞求难得。我等诸人入城乞食空钵而还。汝日日乞满钵而来。何由得尔。报言诸妹乞食可得耳。堤舍比丘尼复于异日。到时着衣持钵诣贩卖人家。彼人遥见比丘尼来。便自计念。如我前后与此比丘尼食。计价可五百金钱。足直一女人。即前捉比丘尼欲行淫。比丘尼即唤言。莫尔莫尔。比近贩卖者即问言。向者何故大唤。答言。此人捉我。彼问言。汝何故捉比丘尼耶。贩卖人答言。我前后与此比丘尼食。计其价可五百金钱。足直一女人。若此比丘尼。意不贪乐我者。何以受我食。彼人问比丘尼言。汝实尔不。答言实尔。彼问比丘尼言。汝知彼与汝食意不。答言知。彼复言。汝若知者何故大唤。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责提舍难陀比丘尼。云何比丘尼。染污心受染污心人食。诸比丘尼白诸比丘。诸比丘往白世尊。世尊尔时以此因缘集比丘僧。呵责提舍难陀比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何以染污心受染污心人食。以无数方便呵责已。告诸比丘。此提舍难陀比丘尼。多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼有染污心。从染污心男子。受可食者及食并余物。是比丘尼。犯初法应舍僧伽婆尸沙。如是世尊与比丘尼结戒。时诸比丘尼。亦不知有染污心无染污心。后方知有染污心。或有言犯僧伽婆尸沙。或有疑者。不知者不犯。自今已去当如是说戒。若比丘尼染污心。知染污心男子。从彼受可食者及食并余物。是比丘尼。犯初法应舍僧伽婆尸沙。比丘尼义如上。染污心者欲染着心。染污心男子者亦欲心染着。可食者。根食茎食叶食华食果食油食胡麻食黑石蜜食细末食也。食者饭糗干饭鱼及肉。余物者。金银珍宝摩尼真珠玭琉璃珂贝璧玉珊瑚若钱生像金若比丘尼染污心。知染污心男子从受可食物及食并余物者。彼与此受僧伽婆尸沙。彼与此不受偷兰遮。方便欲与而不与。若共期若悔还。一切偷兰遮。天子阿修罗子揵闼婆子夜叉子饿鬼子畜生能变形者。从受可食者及食并余物。彼与此受偷兰遮。不能变形者突吉罗。从染污心女人。受可食者及食并余物突吉罗。染污心染污心想僧伽婆尸沙。染污心疑偷兰遮。不染污心染污心想偷兰遮。不染污心疑突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。先不知若已无染污心。彼亦无染污心不犯。不犯者最初未制戒。痴狂心乱痛恼所缠(八竟)

尔时佛在舍卫国祇树给孤独园。时世谷米勇贵乞求难得。时诸比丘尼入城乞食空钵而还。堤舍难陀比丘尼亦入城乞食空钵而还。诸比丘尼见已问堤舍比丘尼言。汝常乞食满钵而归今何以空钵而归乞求难得耶。答言实尔。问言何以故尔。答言诸妹。我前常诣贩卖人乞故易得。而今不往从乞。是以难得。时六群比丘尼偷罗难陀。及堤舍比丘尼母。语堤舍比丘尼言。正使彼有染污心。无染污心。能那汝何。汝自无染污心。若得食。但以时清净受取。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群偷罗难陀及堤舍比丘尼母言。汝等云何语堤舍比丘尼言。正使彼染污心无染污心。能那汝何。汝自无染污心。若得食。但以时清净受。时诸比丘尼白诸比丘。诸比丘往白世尊。世尊尔时以此因缘集诸比丘僧。呵责六群偷罗难陀及堤舍比丘尼母。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等。语堤舍比丘尼言。正使彼有染污心无染污心。能那汝何。汝自无染污心。若得食。但以时清净受。时世尊以无数方便呵责六群偷罗难陀及堤舍比丘尼母已。告诸比丘此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。教比丘尼作如是语。大姊。彼有染污心无染污心。能那汝何。汝自无染污心。于彼若得食。以时清净受取。此比丘尼犯初法应舍僧伽婆尸沙。比丘尼义如上。彼比丘尼语比丘尼言。大姊。正使彼人有染污心无染污心。能那汝何。汝自无染污心。若得食但以时清净受取。说而了了僧伽婆尸沙。说不了了者偷兰遮。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯不犯者。或戏笑说。若疾疾说。独处说梦中说。欲说此错说彼不犯。不犯者最初未制戒。痴狂心乱痛恼所缠(九竟)

尔时佛在罗阅城耆阇崛山中。时世尊以此因缘集比丘僧。告诸比丘。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。欲坏和合僧。方便受破僧法。坚持不舍。是比丘尼应谏彼比丘尼言。大姊。汝莫坏和合僧。莫方便坏和合僧。莫受破僧法。坚持不舍。大姊。应与僧和合。与僧和合欢喜不诤。同一师学如水乳合。于佛法中有增益安乐住。是比丘尼谏彼比丘尼时。坚持不舍。是比丘尼应三谏。舍此事故。乃至三谏舍者善。不舍者。是比丘尼。犯三法应舍僧伽婆尸沙(十竟)

尔时佛在罗阅城耆阇崛山中。时世尊以此因缘集比丘僧。告诸比丘。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼有余比丘尼群党。若一若二若三乃至无数。彼比丘尼语是比丘尼言。大姊。汝莫谏此比丘尼。此比丘尼。是法语比丘尼。律语比丘尼。此比丘尼所说。我等心喜乐。此比丘尼所说。我等忍可。是比丘尼语彼比丘尼言。大姊。莫作是说言。此比丘尼。是法语比丘尼。律语比丘尼。此比丘尼所说。我等喜乐。此比丘尼所说。我等忍可。何以故。此比丘尼所说。非法语非律语。大姊。莫欲破坏和合僧。当乐欲和合僧。大姊。与僧和合欢喜不诤。同一师学如水乳合。于佛法中有增益安乐住。是比丘尼谏彼比丘尼时。坚持不舍。是比丘尼应三谏。舍此事故。乃至三谏舍者善。不舍者是比丘尼。犯三法应舍僧伽婆尸沙(十一竟)

尔时佛在舍卫国祇树给孤独园。时世尊以此因缘集比丘僧。告诸比丘。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。依城邑若村落住。污他家行恶行。行恶行亦见亦闻。污他家亦见亦闻。是比丘尼谏彼比丘尼言。大姊。汝污他家行恶行。行恶行亦见亦闻。污他家亦见亦闻。大姊。汝污他家行恶行。今可离此村落去。不须住此。彼比丘尼语此比丘尼作是言。大姊。诸比丘尼。有爱有恚有怖有痴。有如是同罪比丘尼。有驱者有不驱者。是诸比丘尼语彼比丘尼言。大姊。莫作是语。有爱有恚有怖有痴。亦莫言有如是同罪比丘尼有驱者有不驱者。何以故。而诸比丘尼。不爱不恚不怖不痴。有如是同罪比丘尼有驱者有不驱者。大姊。污他家行恶行。行恶行亦见亦闻。污他家亦见亦闻。是比丘尼谏彼比丘尼时。坚持不舍。是比丘尼应三谏。舍此事故。乃至三谏舍者善。不舍者是比丘尼。犯三法应舍僧伽婆尸沙(十二竟)

尔时佛在拘睒弥瞿师罗园中。时世尊以此因缘集比丘僧。告诸比丘。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。恶性不受人语。于戒法中诸比丘尼如法谏已。自身不受谏语言。大姊。汝莫向我说若好若恶。我亦不向汝说若好若恶。诸姊止莫谏我。是比丘尼当谏彼比丘尼言。大姊。汝莫自身不受谏语。大姊。自身当受谏语。大姊。如法谏诸比丘尼。诸比丘尼亦当如法谏大姊。如是佛弟子众得增益。展转相谏。展转相教。展转忏悔。是比丘尼如是谏时。坚持不舍。是比丘尼应三谏。舍此事故。乃至三谏舍者善。不舍者是比丘尼。犯三法应舍僧伽婆尸沙(十三竟)

尔时佛在舍卫国祇树给孤独园。时有二比丘尼。一名苏摩二名婆颇夷。常相亲近住共作恶行。恶声流布展转共相覆罪。余比丘尼语言。大姊。汝等二人。莫相亲近共作恶行。恶声流布展转共相覆罪。汝等。若不相亲近共作恶行。恶声流布展转共相覆罪者。于佛法中有增益安乐住。而彼犹故不改悔。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责苏摩婆颇夷比丘尼。云何汝等。相亲近共作恶行。恶声流布展转共相覆罪。余比丘尼语言。大姊。汝莫相亲近共作恶行。恶声流布展转共相覆罪。汝等。若不相亲近共作恶行。恶声流布共相覆罪。于佛法中有增益安乐住。而彼犹故不改悔。时诸比丘尼白诸比丘。诸比丘往白世尊。世尊尔时以此因缘集诸比丘僧。呵责苏摩婆颇夷比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等。共相亲近共作恶行。恶声流布展转共相覆罪。余比丘尼语言。大姊。汝莫相亲近共作恶行。恶声流布莫展转共相覆罪。汝等。若不相亲近共作恶行。恶声流布展转共相覆罪。于佛法中有增益安乐住。而犹不改悔耶。时世尊以无数方便呵责已。告诸比丘。听僧与苏摩婆颇夷比丘尼作呵谏。舍此事故。白四羯磨应作如是呵谏。尼众中应差堪能作羯磨人。如上当作如是白。大姊僧听。此苏摩婆颇夷比丘尼。相亲近住共作恶行。恶声流布展转共相覆罪。余比丘尼谏言。大姊。汝等莫相亲近共作恶行。恶声流布莫相覆罪。汝等若不相亲近共作恶行恶声流布者。于佛法中有增益安乐住。而彼犹故不改悔。若僧时到僧忍听。僧与苏摩婆颇夷比丘尼作诃谏。舍此事故。汝等莫相亲近共作恶行。恶声流布莫共相覆罪。汝等若不相亲近不作恶行恶声流布。于佛法中有增益安乐住。白如是。大姊僧听。此苏摩婆颇夷比丘尼。共相亲近共作恶行。恶声流布展转共相覆罪。余比丘尼语言。大姊。莫相亲近共作恶行。恶声流布展转共相覆罪。汝等若不相亲近共作恶行恶声流布。于佛法中得增益安乐住。而彼犹故不改悔。今僧与苏摩婆颇夷比丘尼作呵谏。舍此事故。汝等莫相亲近共作恶行。恶声流布莫展转共相覆罪。汝等若不相亲近共作恶行。恶声流布。于佛法中有增益安乐住。谁诸大姊忍僧与苏摩婆颇夷比丘尼作呵谏。舍此事者默然。谁不忍者说。是初羯磨。第二第三如是说。僧已忍。与苏摩婆颇夷比丘尼作呵谏。舍此事竟。僧忍默然故。是事如是持。僧作如是呵谏白四羯磨已。白诸比丘。诸比丘往白佛。佛言。若有如此比丘尼。比丘尼僧亦当与作如是呵责白四羯磨。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。相亲近住共作恶行。恶声流布展转共相覆罪。是比丘尼当谏彼比丘尼言。大姊。汝等莫相亲近共作恶行。恶声流布共相覆罪。汝等若不相亲近。于佛法中得增益安乐住。是比丘尼谏彼比丘尼时。坚持不舍。是比丘尼应三谏。舍此事故。乃至三谏舍者善。不舍者是比丘尼犯三法应舍僧伽婆尸沙。比丘尼义如上。亲近者。数数共戏笑。数数共相调。数数共语。恶行者。自种华树教人种。自溉灌教人溉灌。自采华教人采华。自作华鬘教人作。自以线贯教人贯。自持去教人持去。自持鬘去教人持去。自以线贯持去教人线贯持去。设彼村中若人若童子。共同一床坐起。同一器饮食。言语戏笑。自歌舞唱伎。或他作己唱和。或俳说。或弹鼓簧吹贝作孔雀鸣。或作众鸟鸣。或走或佯跛行。或啸或自作弄身。或受雇戏笑。恶声者。恶言流遍四方无不闻者。罪者。除八波罗夷法。覆余罪者是。若比丘尼。共相亲近共作恶行。恶声流布共相覆罪。余比丘尼当谏此比丘尼言。大姊。汝等莫共相亲近共作恶行恶声流布共相覆罪。汝等若不相亲近共作恶行恶声流布。于佛法中得增益安乐住。汝等宜舍此事。勿为僧所呵谏更犯重罪。若随语者善。不随语者当作白。白已当语言。妹我已白竟。余有羯磨在。宜舍此事。莫为僧所呵谏更犯重罪。若随语者善。不随语者当作初羯磨。作初羯磨已当复语言。妹已作白初羯磨竟。余有二羯磨在。可舍此事。莫为僧所呵谏更犯重罪。若随语者善。不随语者当作二羯磨。作二羯磨已当语言。妹已白二羯磨竟。余有一羯磨在。可舍此事。莫为僧所呵谏更犯重罪。若随语者善。不随语者说三羯磨竟僧伽婆尸沙。白已二羯磨竟舍者三偷罗遮。白已一羯磨竟舍者二偷罗遮。白已舍者一偷罗遮。白未竟舍者突吉罗。未白前共相亲近共作恶行恶声流布者一切突吉罗。比丘随所犯。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。初语时舍。非法别众呵谏。非法和合众。法别众似法别众。似法和合众。非法非律非佛所教呵谏。若一切不作呵谏不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(十四竟)

尔时佛在舍卫国祇树给孤独园。时苏摩婆颇夷比丘尼为僧呵谏已。六群比丘尼偷罗难陀比丘尼教作如是言。汝等当共住。何以故。我亦见余比丘尼共住共相亲近共作恶行恶声流布共相覆罪。众僧以恚故教汝等别住。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘尼及偷罗难陀比丘尼。僧与苏摩婆颇夷比丘尼作呵谏已。云何汝等教作如是言。汝等莫别住。何以故。我亦见诸比丘尼共相亲近作恶行恶声流布共相覆罪。僧以恚故。教汝等别住。时诸比丘尼白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责六群及偷罗难陀比丘尼。僧为苏摩婆颇夷比丘尼作呵谏。汝等云何教作如是言。汝等莫别住当共住。何以故。我亦见诸比丘尼共住作恶行恶声流布共相覆罪。僧以恚故教汝等别住。时世尊以无数方便呵责六群及偷罗难陀比丘尼已告诸比丘。听比丘尼僧与六群及偷罗难陀比丘尼作呵责白四羯磨。当作如是呵。尼众中应差堪能作羯磨者。如上当作如是白。大姊僧听。此六群比丘尼及偷罗难陀比丘尼。僧与苏摩婆颇夷比丘尼作呵谏。而教作如是言。汝等莫别住当共住。何以故。我亦见诸比丘尼共相亲近共作恶行。恶声流布共相覆罪。僧以恚故教汝等别住。若僧时到僧忍听。僧与六群及偷罗难陀比丘尼作呵责。舍此事故。汝莫作如是语言。莫别住当共住。亦莫言我亦见诸比丘尼共相亲近共作恶行。恶声流布共相覆罪。僧以恚故教汝别住。今正有此二比丘尼。共相亲近共作恶行。恶声流布共相覆罪。更无有余。若此比丘尼。不相亲近共作恶行恶声流布者。于佛法中有增益安乐住。白如是。大姊僧听。此六群比丘尼及偷罗难陀比丘尼。僧与苏摩婆颇夷比丘尼作呵谏。而教作如是言。汝等莫别住当共住。我亦见诸比丘尼。共相亲近作恶行恶声流布共相覆罪。僧以恚故教汝等别住。僧今与六群比丘尼及偷罗难陀比丘尼作呵责。舍此事故。汝等莫别住当共住。莫言我亦见诸比丘尼共相亲近共作恶行恶声流布共相覆罪。僧以恚故教汝等别住。今正有此二比丘尼。共相亲近作恶行恶声流布共相覆罪。更无有余。若此比丘尼。不相亲近者。于佛法有增益安乐住。谁诸大姊忍。僧为六群比丘尼及偷罗难陀比丘尼作诃谏。舍此事者默然。若不忍者说。是初羯磨。第二第三亦如是说。僧已呵谏六群比丘尼及偷罗难陀比丘尼令舍此事竟。僧忍默然故是事如是持。僧为六群比丘尼及偷罗难陀比丘尼作诃谏白四羯磨竟。诸比丘尼白诸比丘。诸比丘往白佛。佛言。若复有如此比丘尼。僧亦当与作诃谏。舍此事白四羯磨。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。比丘尼僧为作诃谏时。余比丘尼教作如是言。汝等莫别住当共住。我亦见余比丘尼不别住共住作恶行恶声流布共相覆罪。僧以恚故教汝别住。是比丘尼。应谏彼比丘尼言。大姊。汝莫教余比丘尼言。汝等莫别住。我亦见余比丘尼共住共作恶行。恶声流布共相覆罪。僧以恚故教汝别住。今正有此二比丘尼。共住共作恶行恶声流布共相覆罪。更无有余。若此比丘尼别住。于佛法中有增益安乐住。是比丘尼。谏彼比丘尼时。坚持不舍。是比丘尼应三谏。令舍此事故。乃至三谏舍者善。不舍者是比丘尼犯三法应舍僧伽婆尸沙。比丘尼义如上。僧者如上。若比丘尼僧为作诃谏时。余比丘尼教作如是言。汝等莫别住当共住。我亦见余比丘尼共相亲近住共作恶行恶声流布共相覆罪。僧以恚故教汝等别住。是比丘尼谏彼比丘尼言。大姊。汝莫教余比丘尼言。汝等莫别住当共住。我亦见余比丘尼共相亲近共作恶行。恶声流布共相覆罪。僧以恚故教汝别住。今正有此二比丘尼。更无有余。汝等共相亲近共作恶行。恶声流布共相覆罪。若此比丘尼别住者。于佛法有僧益安乐住。汝今可舍此事。莫为僧所呵更犯重罪。若随语者善。不随语者当作白。作白已当语言。大妹。我已作白竟。余有羯磨在。汝可舍此事。若随语者善。不随语者当作初羯磨。作初羯磨竟当语言。已白初羯磨竟。余有二羯磨在。汝可舍此事。莫为僧所呵谏更犯重罪。若随语者善。不随语者当作二羯磨。作二羯磨已当语言。妹已白二羯磨竟。余有一羯磨在。汝可舍此事。莫为僧所呵谏更犯重罪。若随语者善。不随语者作三羯磨竟僧伽婆尸沙。白二羯磨竟。舍者三偷兰遮。白一羯磨竟。舍者二偷兰遮。白已舍者一偷兰遮。白未竟舍者突吉罗。未白前教言。汝莫别住我亦见余比丘尼。共住共作恶行恶声流布共相覆罪。僧以恚故教汝别住。一切突吉罗。若有如是比丘尼。僧与作呵谏时。若有比丘教言。莫舍若呵责偷兰遮。若不呵责突吉罗。若比丘尼教莫舍若呵责偷兰遮。若未呵突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。初语时舍。非法别众呵责。非法和合众。法别众。似法别众。似法和合众。非法非律非佛所教呵责。若一切不呵责不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(十五竟)

尔时佛在舍卫国祇树给孤独园。时六群比丘尼。趣以一小事嗔恚不喜。便作是语。我舍佛舍法舍僧。不独有沙门释子。更有余沙门婆罗门修梵行者。我等亦可于彼修梵行。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘尼。云何汝等。趣以一小事嗔恚不喜。作如是语。我舍佛舍法舍僧。不独有沙门释子。更有余沙门婆罗门修梵行。我等亦可于彼修梵行。时诸比丘尼白诸比丘。诸比丘往白世尊。世尊以此因缘集诸比丘僧。呵责六群比丘尼言。云何汝等。趣以一小事嗔恚不喜。作是语。我舍佛舍法舍僧。不独有沙门释子。更有余沙门婆罗门修梵行。我等亦可于彼修梵行。时世尊以无数方便呵责六群比丘尼已。告诸比丘。听僧与六群比丘尼作呵责。舍此事故白四羯磨。当作如是呵责。众中应差堪能羯磨者。如上当作如是白。大姊僧听。此六群比丘尼趣以一小事嗔恚不喜。便作是语。我舍佛舍法舍僧。不独有此沙门释子。亦更有余沙门婆罗门修梵行者。我等亦可于彼修梵行。若僧时到僧忍听。僧今呵责六群比丘尼舍此事。大妹。莫趣以一小事嗔恚不喜便作是语。我舍佛舍法舍僧。不独有此沙门释子。更有余沙门婆罗门修梵行。我等亦可于彼修梵行。白如是。大姊僧听。此六群比丘尼趣以一小事嗔恚不喜。便作是语。我舍佛舍法舍僧。不独有此沙门释子。更有余沙门婆罗门修梵行者。我等亦可于彼修梵行。今僧与六群比丘尼作呵责。舍此事故。大姊。莫趣以一小事嗔恚不喜。便作是语。我舍佛舍法舍僧。不独有此沙门释子。更有余沙门婆罗门修梵行者。我等亦可于彼修梵行。谁诸大姊忍。僧为六群比丘尼作呵责。舍此事者默然。若不忍者便说。是初羯磨。第二第三亦如是说。僧已忍。与六群比丘尼作呵责舍此事竟。僧忍默然故。是事如是持。僧作如是呵责六群比丘尼舍此事。白四羯磨已。白诸比丘。诸比丘往白世尊。世尊告诸比丘。若有如是比丘尼。僧当与呵责白四羯磨。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼趣以一小事嗔恚不喜便作是语。我舍佛舍法舍僧。不独有此沙门释子。亦更有余沙门婆罗门修梵行者。我等亦可于彼修梵行。是比丘尼当谏彼比丘尼言。大姊。汝莫趣以一小事嗔恚不喜便作是语。我舍佛舍法舍僧。不独有此沙门释子。亦更有余沙门婆罗门修梵行者。我等亦可于彼修梵行。若是比丘尼谏彼比丘尼时坚持不舍。彼比丘尼应三谏。舍此事故。乃至三谏舍者善。不舍者是比丘尼。犯三法应舍僧伽婆尸沙。比丘尼义如上。若比丘尼趣以一小事嗔恚不喜。便作是语。我舍佛舍法舍僧。不独有此沙门释子。亦更有余沙门婆罗门修梵行者。我等亦可于彼修梵行。是比丘尼谏彼比丘尼作是语。大姊。汝莫趣以一小事嗔恚不喜便作是语。我舍佛舍法舍僧。不独有此沙门释子。更有余沙门婆罗门修梵行者。我等亦可于彼修梵行。汝可舍此事。莫为僧所呵责更犯重罪。若随语者善。不随语者当作白。白已当语言。我已白竟。余有羯磨在。可舍此事。莫为僧所呵责更犯重罪。若随语者善。不随语者当作初羯磨。作初羯磨已当语言。已作白初羯磨竟。余有二羯磨在。汝可舍此事。莫为僧所呵责更犯重罪。若随语者善。不随语者当作第二羯磨。作第二羯磨已当复语言。我已作白二羯磨竟。余有一羯磨在。汝可舍此事。莫为僧所呵责更犯重罪。若随语者善。不随语者作三羯磨竟僧伽婆尸沙。白二羯磨竟舍者三偷罗遮。白一羯磨竟舍者二偷罗遮。白竟舍者一偷罗遮。白未竟舍者突吉罗。未白前趣以一小事嗔恚不喜。便作是语。我舍佛舍法舍僧。不独有此沙门释子。更有余沙门婆罗门修梵行者。我等亦可于彼修梵行。一切突吉罗。若僧为如是比丘尼作呵责时。若比丘教言莫舍。若僧作呵责偷罗遮。若不呵责突吉罗。若比丘尼教言莫舍。若僧作呵责偷罗遮。若不呵责突吉罗。除比丘比丘尼。教余人莫舍。呵责不呵责。一切突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。初语时舍。非法别众呵责。非法和合众。法别众。似法别众。似法和合众呵责。非法非律非佛所教。若一切不作呵责不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(十六竟)

尔时佛在拘睒弥瞿师罗园中。时有比丘尼名黑。喜斗诤不善忆持诤事。后遂嗔恚作是言。僧有爱有恚有怖有痴。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责黑比丘尼言。云何喜斗诤不善忆持诤事。后嗔恚作是语。僧有爱有恚有怖有痴。时诸比丘尼往白诸比丘。诸比丘往白世尊。世尊尔时以是因缘集比丘僧。呵责黑比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。汝云何喜斗诤不善忆持诤事。后嗔恚作是语。僧有爱有恚有怖有痴。时世尊以无数方便呵责已告诸比丘。自今已去听僧与黑比丘尼作呵责。舍此事故。白四羯磨当如是作。尼众中应差堪能羯磨者。如上当作如是白。大姊僧听。此黑比丘尼。喜斗诤不善忆持诤事。后嗔恚作是语。僧有爱有恚有怖有痴。若僧时到僧忍听。僧今与黑比丘尼作呵责。舍此事故。大姊。汝莫喜斗诤不善忆持诤事。后嗔恚作如是语。僧有爱有恚有怖有痴。而僧不爱不恚不怖不痴。妹汝自有爱有恚有怖有痴。白如是。大姊僧听。此黑比丘尼喜斗诤不善忆持诤事。后嗔恚作是语。僧有爱有恚有怖有痴。今僧与黑比丘尼作呵责舍此事。妹汝莫喜斗诤不善忆持诤事后嗔恚作是语。僧有爱有恚有怖有痴。而僧不爱不恚不怖不痴。汝自有爱有恚有怖有痴。谁诸大姊忍。僧与黑比丘尼作呵责舍此事者默然谁不忍者便说。是初羯磨。第二第三亦如是说。僧已与黑比丘尼作呵责舍此事竟。僧忍默然故。是事如是持。僧与黑比丘尼作呵责白四羯磨已。白诸比丘。诸比丘以此因缘白佛。佛言。若有如此比丘尼。比丘僧亦当与作呵责白四羯磨。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。喜斗诤不善忆持诤事。后嗔恚作是语。僧有爱有恚有怖有痴。是比丘尼应谏彼比丘尼言。妹汝莫喜斗诤不善忆持诤事后嗔恚作是语。僧有爱有恚有怖有痴。而僧不爱不恚不怖不痴。汝自有爱有恚有怖有痴。是比丘尼谏彼比丘尼时坚持不舍。彼比丘尼应三谏。舍此事故。乃至三谏舍者善。不舍者是比丘尼犯三法应舍僧伽婆尸沙。比丘尼义如上。斗诤有四种。言诤觅诤犯诤事诤。僧者一羯磨一说戒。若比丘尼。喜斗诤不善忆持诤事。后嗔恚作是语。僧有爱有恚有怖有痴。是比丘尼当谏彼比丘尼言。大姊。汝莫喜斗诤不善忆持诤事后嗔恚作是语。僧有爱有恚有怖有痴。而僧不爱不恚不怖不痴。汝自有爱有恚有怖有痴。汝今可舍此事。莫为僧所呵责更犯重罪。若随语者善。不随语者当作白。作白已语言。我已白竟。余有羯磨在。汝可舍此事。莫为僧所呵责更犯重罪。若随语者善。不随语者当作初羯磨。作初羯磨已当复语言。我已作初羯磨竟。余二羯磨在。汝可舍此事。莫为僧所呵责更犯重罪。若随语者善。不随语者当作二羯磨。作二羯磨已当复语言。我已作白二羯磨竟。余有一羯磨在。汝可舍此事。莫为僧所呵责更犯重罪。若随语者善。不随语者作三羯磨竟僧伽婆尸沙。白二羯磨竟舍者三偷罗遮。白初羯磨竟舍者二偷罗遮。白竟舍者一偷罗遮。白未竟舍者突吉罗。未白前喜斗诤不善忆持诤事。后嗔恚言。僧有爱有恚有怖有痴。一切突吉罗。若比丘尼喜斗诤。僧与呵责时。比丘教言莫舍。若僧作呵责偷罗遮。若不呵责突吉罗。若比丘尼教言莫舍。若作呵责偷罗遮。若不作呵责突吉罗。除比丘比丘尼。教余人莫舍。一切突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。初语时舍。非法别众呵责。非法和合众。法别众。似法别众。似法和合众。非法非律非佛所教。若一切不作呵责不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(十七竟)

    三十舍堕法

尔时佛在舍卫国祇树给孤独园。时世尊以此因缘集比丘僧。告诸比丘。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如此说。若比丘尼。衣已竟迦絺那衣已舍。畜长衣经十日不净施得持。若过尼萨耆波逸提(一竟)

若比丘尼。衣已竟迦絺那衣已舍。五衣中若离一一衣异处宿经一夜。除僧羯磨尼萨耆波逸提(二竟)

若比丘尼。衣已竟迦絺那衣已舍。若得非时衣。欲须便受。受已疾疾成衣。若足者善。若不足者得畜一月。为满足故。若过畜者尼萨耆波逸提(三竟)

若比丘尼。从非亲里居士居士妇乞衣。除余时尼萨耆波逸提。是中时者。若夺衣失衣烧衣漂衣。是名时(四竟)

若比丘尼。夺衣失衣烧衣漂衣。是非亲里居士若居士妇。自恣请多与衣。是比丘尼当知足受衣。若过尼萨耆波逸提(五竟)

若居士居士妇。为比丘尼办衣价。买如是衣与某甲比丘尼。是比丘尼先不受自恣请。到居士家作如是说。善哉居士。为我办如是如是衣价与我。为好故。若得衣者尼萨耆波逸提(六竟)

若二居士居士妇。与比丘尼办衣价。我曹办如是衣价。与某甲比丘尼。是比丘尼先不受自恣请。到二居士家作如是言。善哉居士。办如是如是衣价与我。共作一衣为好故。若得衣尼萨耆波逸提(七竟)

若比丘尼。若王若大臣若婆罗门若居士居士妇。遣使为比丘尼送衣价。持如是衣价与某甲比丘尼。彼使至比丘尼所语言。阿姨。为汝送衣价受取。是比丘尼语彼使如是言。我不应受此衣价。我若须衣合时清净当受。彼使语比丘尼言。阿姨。有执事人不须衣。比丘尼言。有若僧伽蓝民若优婆塞。此是比丘尼执事人。常为比丘尼执事。彼使至执事人所。与衣价已还到比丘尼所如是言。阿姨。所示某甲执事人。我已与衣价。大姊。知时往彼当得衣。比丘尼若须衣者。当往彼执事人所二反三反语言。我须衣。若二反三反为作忆念得衣者善。若不得衣四反五反六反在前默然住令彼忆念。若四反五反六反在前默然住得衣者善。若不得衣。过是求得衣者尼萨耆波逸提。若不得衣。随使所来处。若自往若遣使往语言。汝先遣使持衣价。与某甲比丘尼。是比丘尼竟不得。汝还取莫使失。此是时(八竟)

若比丘尼。自取金银若钱。若教人取。若口可受。尼萨耆波逸提(九竟)

若比丘尼。种种买卖宝物者。尼萨耆波逸提(十竟)

若比丘尼。种种贩卖者。尼萨耆波逸提(十一竟)

若比丘尼。畜钵减五缀不漏更求新钵为好故。尼萨耆波逸提。是比丘尼。当持此钵于尼众中舍。从次第贸至下坐。以下坐钵与此比丘尼言。妹持此钵乃至破。此是时(十二竟)

若比丘尼。自求缕使非亲里织师织作衣者。尼萨耆波逸提(十三竟)

若比丘尼。居士居士妇。使织师为比丘尼织作衣。彼比丘尼先不受自恣请。便往到彼所。语织师言。此衣为我织极好。织令广长坚致齐整好。我当少多与汝价。若比丘尼。与价乃至一食得衣者。尼萨耆波逸提(十四竟)

若比丘尼。与比丘尼衣已。后嗔恚。若自夺若教人夺取。还我衣来不与汝。是比丘尼应还衣。彼取衣者。尼萨耆波逸提(十五竟)

若诸病比丘尼。畜药酥油生酥蜜石蜜得食残宿。乃至七日得服。若过七日服。尼萨耆波逸提(十六竟)

若比丘尼。十日未满夏三月。若有急施衣比丘尼知是急施衣应受。受已乃至衣时应畜。若过畜尼萨耆波逸提(十七竟)

若比丘尼。知物向僧。自求入己。尼萨耆波逸提(十八竟)

四分律卷第二十三四分律卷第二十四(二分之三明尼戒法)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    三十舍堕法之二

佛在舍卫国祇树给孤独园。时偷罗难陀比丘尼有檀越。晨朝着衣持钵诣其家语言。我须酥。彼言可尔。即买与之。既买酥与。而言。我不须酥须油。彼言可得。彼即往卖酥家语言。我不须酥须油。其人报言。当作买酥法取汝酥。当作卖油法与汝油。彼檀越即讥嫌言。比丘尼无有厌足不知惭愧。外自称言。我知正法。求酥索油求油索酥。如是何有正法。若须酥直应索酥。须油便应索油。若须余物便应索余物。时诸比丘尼闻。其中有少欲知足行头陀。乐学戒知惭愧者。呵责偷罗难陀比丘尼言。云何索酥求油索油求酥。时诸比丘尼白诸比丘。诸比丘往白世尊。世尊尔时以此因缘集比丘僧。呵责偷罗难陀比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。汝云何求酥索油求油索酥。时世尊以无数方便呵责偷罗难陀比丘尼已告诸比丘。此偷罗难陀比丘尼。多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼欲索是。更索彼者尼萨耆波逸提。比丘尼义如上。欲索是更索彼者。求酥已更求油。索油已更索酥。若求余物亦如是。若比丘尼欲索是。更索彼者尼萨耆波逸提。此尼萨耆应舍与尼僧。若众多人若一人。不得别众舍。若舍不成舍突吉罗。若欲舍时。应往僧中偏露右肩脱革屣礼僧足已右膝着地合掌作如是言。大姊僧听。我某甲比丘尼索是更索彼犯舍堕。今舍与僧。舍已应忏悔。前受忏人白已然后受忏。作如是白。大姊僧听。此某甲比丘尼索是更索彼犯舍堕。今舍与僧。若僧时到僧忍听。我受某甲比丘尼忏。白如是。应如是白已受彼忏。语彼言自责汝心。答言尔。比丘尼僧。即应还彼比丘尼舍物。白二羯磨应如是与僧中应差堪能羯磨者。如上当如是白。大姊僧听。此某甲比丘尼索是更索彼犯舍堕。今舍与僧。若僧时到僧忍听。持此舍物还某甲比丘尼。白如是。大姊僧听。此某甲比丘尼索是更索彼犯舍堕。今舍与僧。僧持此舍物还某甲比丘尼。谁诸大姊忍。僧还某甲比丘尼舍物者默然。谁不忍者说。僧已忍。还某甲比丘尼舍物竟。僧忍默然故。是事如是持。舍物竟不还者突吉罗。若还时有人教言莫还者突吉罗。若不还转作净施。若遣与人。若故坏。若烧。若作非物。若数数用。一切突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若须酥索酥。若须油索油。若须余物便索余物。若从亲里索。从出家人索。若为彼彼为己索。若不求而得不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(十九竟)

尔时佛在舍卫国祇树给孤独园。时有众多比丘尼于露地说戒。有居士见问言。阿姨。何故露地说戒。无有说戒堂耶。答言无。若与堂直能作堂不。答言能。即与作说戒堂物。时诸比丘尼便作是念。我曹说戒时趣得坐处。便坐说戒。比丘尼衣服难得应具五衣。我今宁可持此物贸衣共分。即便贸衣共分。后于异时。诸比丘尼故在露地说戒。彼居士见即问言。何以故在露地说戒无有堂耶。答言无。居士言。我前所与说戒堂物作何等。答言无所作。复问所由不作。比丘尼语言。我等作是念。我趣得坐处便可说戒。比丘尼衣服难得。应具五衣。我等宁可持此物贸衣。即以此物贸衣共分。时彼居士讥嫌言。此比丘尼等。不知惭愧受取无厌。外自称言。我知正法。如是有何正法。以我堂物贸衣共分。谓我不知衣服难得当具五衣耶。如佛所说。能造第一福者。作好房施四方僧。是时诸比丘尼闻。中有少欲知足行头陀乐学戒知惭愧者。呵责彼比丘尼。云何汝等。居士施作说戒堂物而贸衣共分。诸比丘尼白诸比丘。诸比丘往白世尊。世尊尔时以此因缘集比丘僧。呵责彼比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何比丘尼。以居士作堂物贸衣共分。时世尊以无数方便呵责彼比丘尼已。告诸比丘彼比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。知檀越所为僧施异。回作余用者。尼萨耆波逸提。比丘尼义如上。所为僧施异者。与作说戒堂用作衣。与作衣用作说戒堂。与此处乃彼处用。僧物为僧属僧。僧物者已许僧。为僧者为僧作而未许僧。属僧者已许与僧已舍与僧。若比丘尼。知檀越所为僧施异。回作余用者。尼萨耆波逸提。此尼萨耆应舍与僧。若众多人若一人。不得别众舍。若舍不成舍突吉罗。舍与僧时。应往僧中偏露右肩脱革屣礼僧足已右膝着地合掌作是语。大姊僧听。我某甲比丘尼所为僧施异而回作余用犯舍堕。今舍与僧。舍已当忏悔。前受忏人。当作白已然后受忏。如是白。大姊僧听。此某甲比丘尼所为僧施异而回作余用犯舍堕。今舍与僧。若僧时到僧忍听。我受某甲比丘尼忏。白如是。作此白已然后受忏。当语彼人言。自责汝心。答言尔。僧即应还此比丘尼衣作白二羯磨。应如是与。僧中应差堪能作羯磨者。如上当作如是白。大姊僧听。此某甲比丘尼所为僧施异回作余用犯舍堕。今舍与僧。若僧时到僧忍听。还某甲比丘尼衣白如是。大姊僧听。此某甲比丘尼所为僧施异回作余用犯舍堕今舍与僧。谁诸大姊忍。僧还此某甲比丘尼衣者默然。谁不忍者说。僧已忍。还某甲比丘尼衣竟。僧忍默然故。是事如是持。于僧中舍衣竟不还者突吉罗。还时若有人教言莫还者突吉罗。若受作五衣。若转作净施。若作余用。若遣与人。若故坏。若烧。若作非衣。若数数着。一切突吉罗。比丘突吉罗。式叉摩那沙尔沙弥尼突吉罗。是谓为犯。不犯者。若问主用随所分处用。若与物时语言随意用不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(二十竟)

尔时佛在舍卫国祇树给孤独园。时安隐比丘尼。欲来诣舍卫国。先旧住比丘尼。闻安隐比丘尼当来。为往诣家家乞求大得财物饮食。至期日而彼比丘尼竟不到。旧住比丘尼等自相谓言。我等与安隐比丘尼共期至舍卫国。而彼不到。比丘尼衣服难得。应办五衣。我等宁可取此物贸衣共分。即作五衣分之。后于异时。安隐比丘尼来至舍卫国。夜过已。到时着衣持钵入舍卫城乞食。时诸居士见即问。阿姨何所求索。答言乞食。又问众僧无食耶。答言无。后日居士至旧比丘尼所问言。我等先各各出物。为供给安隐比丘尼。为作食不。答言不作。问言。何故不作。答言。我先与安隐比丘尼共期来至舍卫国。而彼不至。我等作是念。与安隐共期至舍卫国。而彼不到。比丘尼衣服难得。应办五衣。我等宁可以此物贸衣共分。即便贸衣共分。时居士皆共讥嫌言。此诸比丘尼。无有惭愧受取无厌。外自称言。我知正法。云何先为安隐比丘尼各各出物作饮食。而后贸衣共分。如是何有正法。我等亦知比丘尼衣服难得应具五衣。而我等所以施者。正为安隐远至供给饮食耳。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责彼比丘尼。汝等云何居士施物为供给安隐比丘尼作食。乃贸衣而共分耶。时诸比丘尼往白诸比丘。诸比丘往白世尊。世尊尔时以此因缘集比丘僧。呵责彼比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何比丘尼。居士施物供给安隐比丘尼作食。而乃贸衣共分。时世尊以无数方便呵责彼比丘尼已告诸比丘。彼比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。所为施物异自求为僧回作余用者。尼萨耆波逸提。比丘尼义如上。所为施异者。若为食施用作依。为衣施用作食。若为余处乃更为余处用。自求者处处求。僧物者如上说。若比丘尼。所为施物异自求为僧回作余用者。尼萨耆波逸提。此尼萨耆应舍与僧如上法。舍已忏悔如上。僧即应还彼舍衣。白二羯磨还如上。若不还受作五衣。乃至作非衣。数数着。一切突吉罗如上。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。语居士随意用。若居士与物已语言随意用不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(二十一竟)

尔时婆伽婆在舍卫国祇树给孤独园。时安隐比丘尼。有居士为檀越。到时着衣持钵至其家敷座而坐。时居士问讯住止安乐不。答言不安乐。问言何故尔。答言。所止处愦闹。是故不安乐。即问无别房耶。答言无。若与舍直能作舍不。答言能。彼即以舍直与之。时彼比丘尼作是念。我设作舍者多诸事务。比丘尼衣服难得应办五衣。我今宁可以此舍直贸衣耶。即便贸衣。后于异时。安隐比丘尼着衣持钵至居士家就座而坐。居士问言。阿姨。住止安乐不。答言不安乐。问言何以不安乐。答言。所止处愦闹故不安乐。即问言无别房耶。答言无。复问前所与舍直竟不作舍耶。答言不作。复问何以故不作。答言。我自作是念。若以此物作舍者多诸事务。比丘尼衣服难得应办五衣。即以此物贸衣时居士讥嫌言。此比丘尼受无厌足。外自称言。我知正法。如是何有正法。我与舍直作舍。而乃用贸衣。我岂不知比丘尼衣服难得应具五衣耶。但我等闻世尊所说。最第一福者。作房施四方僧也。时诸比丘尼闻。中有少欲知足行头陀乐学戒知惭愧者。呵责安隐言。汝云何檀越与物作房舍。乃用作衣。诸比丘尼白诸比丘。诸比丘往白世尊。世尊尔时以此因缘集比丘僧。呵责安隐比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何檀越与物作屋。乃用作衣。时世尊以无数方便呵责已告诸比丘。安隐比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。檀越所施物异回作余用者。尼萨耆波逸提。比丘尼义如上。所为施物异者。作别房用作衣。施作衣用作别房。若为余处施乃余处用。若比丘尼。所为施物异作别房回作余用者。尼萨耆波逸提。此尼萨耆。应舍与僧如上法。舍竟忏悔如上。僧即应还彼舍衣。白二羯磨还如上。若不还受作五衣。乃至作非衣用。若数数着。一切突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。问檀越用随檀越处分用。若与时语言随意用。若亲厚人语言随意用。我当语主不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(二十二竟)

尔时婆伽婆。在舍卫国祇树给孤独园。时众多比丘尼。为作房舍故。人间乞求处处乞索多得财物。诸比丘尼即自念言。若我以此物作屋者多诸事故。比丘尼衣服难得应办五衣。我等今宁可以此物用贸衣共分。念已贸衣共分。后于异时。诸居士问言。前与物作舍者竟作舍不。答言不作。问言何以故不作。答言。我等自念。设作屋者多诸事故。比丘尼衣服难得应具五衣。我等宁可以此物贸衣共分。念已即贸衣共分。时诸居士闻已皆共讥嫌言。此诸比丘尼受取无厌。外自称言。我知正法。如是何有正法。以我等舍直贸衣共分。我等岂不知比丘尼衣服难得应具五衣耶。但我等闻世尊所说。最第一福者。作房施四方僧。是诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责彼比丘尼。汝等云何以他舍直贸衣共分。诸比丘尼往白诸比丘诸比丘往白世尊。世尊尔时以此因缘集比丘僧。呵责诸比丘尼。汝所为非。非威仪。非沙门法非净行非随顺行。所不应为。云何比丘尼。檀越与舍直贸衣共分。以无数方便呵责诸比丘尼已告诸比丘。彼诸比丘尼痴人。多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。檀越所为施物异自求为僧回作余用。尼萨耆波逸提。比丘尼义如上。所为施物异者。施与作僧房用作衣。施作衣用作僧房。若为余处施乃余处用。自求者。自处处乞求。为僧者。僧物如上说。若比丘尼。所为施物异自求为僧回作余用者。尼萨耆波逸提。此尼萨耆。应舍与僧如上法。舍已忏悔如上。僧即应还彼舍衣。作白二羯磨还如上。若不还受作五衣。乃至作非衣。数数着。一切突吉罗如上。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若问物主随物主处分用。若与物时语言随意用。若是亲厚者语言随意用。我当语主不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(二十三竟)

尔时婆伽婆在舍卫国祇树给孤独园。时六群比丘尼。受持好色钵。故者留置。彼畜多钵而不洗治。狼藉在地。诸居士诣寺观看。见已讥嫌言。此比丘尼受取无厌外自称言。我知正法。如是何有正法。多畜好色钵。故钵狼藉在地。与瓦肆无异。诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责六群比丘尼。汝云何多畜好色钵。故钵不洗治狼藉在地。诸比丘尼往白诸比丘诸比丘往白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何六群比丘尼。受持好色钵。故者不洗治狼藉在地。时世尊以无数方便呵责六群比丘尼已告诸比丘。此六群比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼畜长钵尼萨耆波逸提比丘尼义如上。彼比丘尼。即日得钵即日应受持。一钵余者。当净施若遣与人。若比丘尼畜长钵。尼萨耆波逸提。此尼萨耆。应舍与僧如上法。舍竟忏悔如上。僧即应还彼舍钵。作白二羯磨还如上。若不还乃至非钵用。一切突吉罗如上比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。即日得钵即日受一钵。余钵净施或遣与人若夺想若失想若破想若漂想。不净施不遣与人不犯。若夺钵若失钵若破钵若漂钵。若自取用若他与用不犯。若所寄钵者命终若远行若休道。若为贼所将去。若遇恶兽难。为水所漂。不作净施。不遣与人不犯不犯者。最初未制戒。痴狂心乱痛恼所缠(二十四竟)

尔时婆伽婆。在舍卫国祇树给孤独园。时六群比丘尼。多畜好色器。不好者留置。彼畜如是多器。不洗治料理狼藉在地。时有众多居士。诣诸寺观看。见已讥嫌言。此六群比丘尼。受取无厌不知惭愧。外自称言。我知正法。如是何有正法。多畜器狼藉在地。如瓦肆无异诸比丘尼。闻其中有少欲知足行头陀乐学戒知惭愧者。呵责六群比丘尼。云何汝等多畜器狼藉在地。时诸比丘尼往白诸比丘。诸比丘往白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘尼。汝等所为非。非威仪非沙门法非净行非随顺行。所不应为。云何六群比丘尼。多畜器狼藉在地。时世尊以无数方便呵责六群比丘尼已告诸比丘。此六群比丘尼。多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼多畜好色器者。尼萨耆波逸提。比丘尼义如上。彼比丘尼。即日得器应即日受。可须用者十六枚。余者。当净施若遣与人。十六者。大釜釜盖大盆及杓小釜釜盖小盆分杓水瓶瓶盖盆及杓洗瓶瓶盖盆及杓。若比丘尼畜多器者。尼萨耆波逸提。此尼萨耆。应舍舍与僧如上。舍竟忏悔如上法。僧即应还彼舍器。白二羯磨还如上。若僧不还。乃至数数用。一切突吉罗如上。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯不犯者。即日得器当受十六枚。余者。当净施若遣与人。若作夺想若失想若破想若漂想。不作净不遣与人不犯。若夺器若失器若破器若漂器。若取自用。若他与器用。若彼所寄器比丘尼命终。若休道若远行。若贼将去。若恶兽难。若水漂。不作净不遣与人不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(二十五竟)

尔时婆伽婆。在舍卫国祇树给孤独园。时诸比丘尼。月期水出污身衣坐具。诸比丘尼白诸比丘。诸比丘往白佛。佛言。听着遮月期衣。若脱听安带。月水犹从两边出污衣。更听作病衣重着外着涅槃僧。若至白衣舍应语言。我有病。若白衣语。但坐无苦。彼比丘尼。当褰涅槃僧以此病衣遮身坐。时有旃檀输那比丘尼。常自谓无有欲想语余一比丘尼言。汝若月水出时从我取此衣。彼报言可尔。余比丘尼常望此衣更不办衣。于异时。栴檀输那比丘尼月期水出。余比丘尼亦月水出。时余比丘尼遣使。诣栴檀输那比丘尼所语言前许我病衣今可见与。答言妹。我今亦月期水出不得相与。彼比丘尼嫌责栴檀输那比丘尼言。前语我。若月期水出。从我取病衣。我常望得衣不自办衣。而今往索不与我耶。诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责栴檀输那比丘尼。汝云何许彼比丘尼病衣。使不自办衣。今索不与。时诸比丘尼往白诸比丘。诸比丘往白世尊。世尊。尔时以此因缘集比丘僧。呵责栴檀输那比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何栴檀输那比丘尼。许彼病衣使不自办。今索不与。以无数方便呵责栴檀输那比丘尼已。告诸比丘。栴檀输那比丘尼。多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。许他比丘尼病衣。后不与者。尼萨耆波逸提。比丘尼义如上。病衣者。月水出时遮内身上着涅槃僧。衣者有十种衣如上。彼比丘尼。许彼病衣不与者。尼萨耆波逸提。除病衣已。许余衣不与者突吉罗。除余衣已许余。所须物不与者突吉罗。若比丘尼许比丘尼病衣后不与尼萨耆波逸提。此尼萨耆应舍与僧如上。舍已忏悔如上。僧即当还彼舍衣如上。若不还。受作五衣。乃至数数用。一切突吉罗如上。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。许病衣与。若无病衣。若作病衣。若浣染打举在牢处求不与无犯。彼比丘尼。或破戒或破见或破威仪。若被举若灭摈若应灭摈。若由此因缘命难梵行难许病衣不与不犯。不犯者最初未制戒。痴狂心乱痛恼所缠(二十六竟)

尔时婆伽婆。在舍卫国祇树给孤独园。时六群比丘尼以非时衣受作时衣。诸比丘尼见语言。世尊许比丘尼畜五衣。此衣是谁衣。答言是我等时衣。即语言妹今是时非时。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘尼。云何汝等。以非时衣受作时衣。诸比丘尼白诸比丘。诸比丘往白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘尼。汝所为非。非威仪非沙门法非净行非随顺行所不应为。云何六群比丘尼。以非时衣受作时衣。时世尊以无数方便呵责六群比丘尼已告诸比丘。此六群比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。以非时衣受作时衣者。尼萨耆波逸提。比丘尼义如上。时者安居竟。无迦絺那衣一月有迦絺那衣五月。非时者。除此于余时得长衣是。衣者。有十种衣如上。若比丘尼。以此非时衣受作时衣者。尼萨耆波逸提。此尼萨耆应舍与僧如上。舍竟忏悔如上。僧即应还彼所舍衣。白二羯磨还如上。若不还受作五衣乃至数数着一切突吉罗如上。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。非时衣受作非时衣。时衣受作时衣不犯。不犯者最初未制戒。痴狂心乱痛恼所缠(二十七竟)

尔时婆伽婆。在舍卫国祇树给孤独园。时偷罗难陀比丘尼。与比丘尼贸衣。后嗔恚还夺取。妹还我衣来。我不与汝。汝衣属汝。我衣属我。汝自取汝衣。我自取我衣时诸比丘尼。闻其中有少欲知足行头陀乐学戒知惭愧者。嫌责偷罗难陀比丘尼。汝云何与比丘尼贸衣。后嗔恚。还自夺取。妹还我衣来。我不与汝。汝衣属汝。我衣属我。汝自取汝衣。我自取我衣。时诸比丘尼往白诸比丘。诸比丘往白世尊。世尊。尔时以此因缘集比丘僧。呵责偷罗难陀比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何偷罗难陀比丘尼。与比丘尼贸衣。后嗔恚还夺耶以无数方便呵责偷罗难陀比丘尼已告诸比丘。此偷罗难陀多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。与比丘尼贸易衣。后嗔恚。还自夺取若使人夺。妹还我衣来。我不与汝。汝衣属汝。我衣还我者。尼萨耆波逸提。比丘尼义如上。衣者十种衣如上。贸易者。或以衣贸衣。或以衣贸非衣或以非衣贸衣。若以非衣。贸非衣。若针若刀若缕若碎段物乃至一丸药。彼比丘尼。与比丘尼贸衣后嗔恚。自夺若教人夺。藏者尼萨耆波逸提。夺而不藏者突吉罗。若彼得衣者。举树上墙上篱上。若橛上象牙杙上衣架上若绳床上木床上大小褥上若地敷上。若取离处尼萨耆。取而不离处突吉罗。此尼萨耆。当舍与僧如上。舍已忏悔如上。僧即应当还彼衣。白二羯磨还如上。若不还。受作五衣乃至数数着。一切突吉罗如上。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者和喻语妹我悔还我衣。彼知有悔意还衣。若有余比丘尼语言。此比丘尼欲悔汝还衣。或彼借着无道理故还取。若豫知当失。若恐坏。若彼人破戒若破见若破威仪。若被举若灭摈若应灭摈。若为此事命难梵行难夺而不藏者不犯。不犯者最初未制戒。痴狂心乱痛恼所缠(二十八竟)

尔时婆伽婆。在毗舍离猕猴江侧高阁讲堂上。时毗舍离梨奢。有因缘应从一居士得财物。时有比丘尼。名迦罗。常出入此居士家。以为檀越。时梨奢语迦罗言。我欲及阿姨一财物事。报言可尔。即为办其事。彼得财物欢喜。问言阿姨。欲须何物。报言止。此便为供养我已。彼复问言。阿姨。若有所须便说。报言且止。何须说。正使我有所须。俱不见与。居士报言但说。所须我当相与。彼即指示一衣价直千张叠言。我须如是衣。时居士皆共讥嫌言。比丘尼受取无厌。外自称言我知正法。如是何有正法。云何乃索价直千张叠衣。正使檀越施与。犹应知足。彼即持与。复作是语。若我往者。足自办此事。可不失此衣。时跋陀迦毗罗比丘尼。至亲里家就座而坐。诸居士问言。阿姨。何所须欲。报言且止。便为供养我已。复语言但说。欲须何物。报言何须说。正使欲有所须俱不见与。报言当与。非为不与。但说。欲须何物。彼即指示价直千张叠衣。我须此衣。时诸居士讥嫌言。比丘尼受取无厌。外自称言。我知正法。如是何有正法。乃索价直千张叠衣。正使檀越施与。犹应知足。即与衣已语言。比丘尼何用此贵价衣为。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责跋陀迦毗罗比丘尼。云何比丘尼。乃从彼索价直千张叠衣。时诸比丘尼往白诸比丘。诸比丘往白世尊。世尊尔时以此因缘集比丘僧。呵责迦罗跋陀迦毗罗比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何乃从彼索价直千张叠衣。时世尊以无数方便呵责已告诸比丘。此迦罗跋陀迦毗罗比丘尼。多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义。乃至正法久住。欲说戒者当如是说。若比丘尼。乞重衣齐价直四张叠。过者尼萨耆波逸提。比丘尼义如上。重衣者。障寒衣也。衣者十种如上。若比丘尼求重衣时。极至十六条。若比丘尼求重衣价直过四张叠者。尼萨耆波逸提。此尼萨耆。当舍与僧如上。舍衣竟忏悔如上法。僧即应还彼比丘尼衣。作白二羯磨与如上。僧若不还。若受作五衣乃至数数着。一切突吉罗如上。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。索齐四张叠若减。若从出家人乞。若彼为己己为彼。若不索而自得不犯。不犯者最初未制戒。痴狂心乱痛恼所缠(二十九竟)

尔时婆伽婆。在毗舍离时。毗舍离梨奢。有因缘应从一居士得财物。有一迦罗比丘尼。常出入其家以为檀越。时梨奢语此迦罗比丘尼言。阿姨。我欲及一财物事。能为我办不。答言能。即为办之。彼得财物欢喜。语言。阿姨。欲得何物。报言止。此便为供养我已。彼复语言。若有所须便说。报言且止。正使我有所须俱不见与。彼报言当与。非为不与。但说。即指示一轻衣价直五百张叠。语言。我须如是衣。时居士皆共讥嫌言。比丘尼受取无厌。外自称言。我知正法。如是何有正法。乃索价直五百张叠衣。正使檀越施与。犹应知足。即持衣与已。如是言。若我往者自足办事。乃不失此衣。时有跋陀迦毗罗比丘尼。还至亲里家就座而坐。时居士问言。阿姨。欲须何物。报言且止。便为供养我已。复言。但说无苦。欲须何物。报言。止不须说。正使欲有所须俱不见与。报言当与。非为不与。欲须何物。即指示直五百张叠轻衣言。我须此衣。时彼居士讥嫌言。此比丘尼受取无厌。外自称言。我知正法。如是有何正法。乃索直五百张叠轻衣。正使檀越施与。犹应知足。即与衣已便言。比丘尼何用此贵价衣为。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责迦罗跋陀迦毗罗比丘尼。云何乃从彼索直五百张叠轻衣。时诸比丘尼往白诸比丘。诸比丘往白世尊。世尊尔时以此因缘集比丘僧。呵责迦罗跋陀迦毗罗比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等。比丘尼。乃从彼索价直五百张叠轻衣。时世尊以无数方便呵责已告诸比丘。此迦罗跋陀迦毗罗比丘尼。多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。欲乞轻衣。极至价直两张半叠。过者尼萨耆波逸提。比丘尼义如上。轻衣者障热衣。衣者有十种如上。若比丘尼乞轻衣时极至齐十条。若比丘尼乞轻衣过二张半叠。尼萨耆波逸提。此尼萨耆应舍与僧如上。舍竟忏悔如上法。僧即应还彼舍衣。白二羯磨还如上。若不还。若受作五衣。乃至作非衣数数着。一切突吉罗如上。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。乞价直两张半叠。若减二张半。若从出家者乞。若为他乞他为己乞不乞而得不犯。不犯者最初未制戒。痴狂心乱痛恼所缠(三十竟)

    一百七十八单提法之一

尔时婆伽婆。在释翅搜迦维罗卫国尼俱律园中。时世尊以此因缘集诸比丘告言。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说

若比丘尼。故妄语者。波逸提(一)

若比丘尼。毁呰语波逸提(二)

若比丘尼。两舌语波逸提(三)

若比丘尼。与男子同室宿者。波逸提(四)

若比丘尼。共未受戒女人同一室宿。若过三宿。波逸提(五)

若比丘尼。与未受具戒人共诵法者。波逸提(六)

若比丘尼。知他有粗恶罪。向未受大戒人说。除僧羯磨波逸提(七)

若比丘尼。向未受大戒人说过人法言。我知是我见是。实者波逸提(八)

若比丘尼。与男子说法过五六语。除有智女人波逸提(九)

若比丘尼。自掘地若教人掘。波逸提(十)

若比丘尼。坏鬼神村波逸提(十一)

若比丘尼。妄作异语恼他者。波逸提(十二)

若比丘尼。嫌骂者波逸提(十三)

若比丘尼。取僧绳床若木床若卧具坐褥。露地自敷若教人敷舍去。不自举不教人举。波逸提(十四)

若比丘尼。于僧房中取僧卧具。自敷若教人敷。在中若坐若卧。从彼处舍去。不自举不教人举者。波逸提(十五)

若比丘尼。知比丘尼先住处。后来于中间。敷卧具止宿。念言。彼若嫌迮者。自当避我去。作如是因缘非余非威仪。波逸提(十六)

若比丘尼。嗔他比丘尼不喜。众僧房中自牵出。若教人索出者。波逸提(十七)

若比丘尼。若在重阁上。脱脚绳床若木床。若坐若卧。波逸提(十八)

若比丘尼。知水有虫。自用浇泥若草。若教人浇者。波逸提(十九)

若比丘尼。作大房户扉窗牖及余庄饰具。指授覆苫齐二三节。若过者波逸提(二十)

若比丘尼。施一食处。无病比丘尼应一食。若过受者波逸提(二十一)

若比丘尼。别众食除余时波逸提。余时者。病时作衣时。若施衣时行道时船上时大会时沙门施食时。此是时(二十二)

若比丘尼。至檀越家殷勤请与饼糗食比丘尼欲须者二三钵应受。持至寺内分与余比丘尼食。若比丘尼无病过三钵受。持至寺中不分与余比丘尼食者波逸提(二十三)

若比丘尼。非时食者波逸提(二十四)

若比丘尼。残宿食啖。波逸提(二十五)

若比丘尼。不受食及药。着口中除水杨枝。波逸提(二十六)

若比丘尼。先受请已。若前食后食行诣余家。不嘱余比丘尼。除余时波逸提。余时者。病时作衣时施衣时。此是时(二十七)

若比丘尼。食家中有宝。强安坐者。波逸提(二十八)

若比丘尼。食家中有宝。在屏处坐者。波逸提(二十九)

若比丘尼。独与男子露地一处共坐者。波逸提(三十)

若比丘尼。语比丘尼。如是言。大姊。共汝至聚落当与汝食。彼比丘尼。竟不教与是比丘尼食。如是言。大姊去。我与汝一处共坐共语不乐。我独坐独语乐。以是因缘非余方便遣去。波逸提(三十一)

若比丘尼。四月与药。无病比丘尼应受。若过受。除常请更请分请尽形请。波逸提(三十二)

若比丘尼。往观军阵。除时因缘。波逸提(三十三)

若比丘尼。有因缘至军中。若二宿三宿。过者波逸提(三十四)

若比丘尼。军中若二宿三宿。或时观军阵斗战。若观游军象马势力。波逸提(三十五)

若比丘尼。饮酒波逸提(三十六)

若比丘尼。水泥中戏者。波逸提(三十七)

若比丘尼。以指击擽他比丘尼者。波逸提(三十八)

若比丘尼。不受谏者。波逸提(三十九)

若比丘尼。恐他比丘尼者。波逸提(四十)

若比丘尼。半月洗浴。无病比丘尼应受。若过受。除余时波逸提。余时者。热时病时作时大风时雨时远行来时。此是时(四十一)

若比丘尼。无病为炙故露地然火。若教人然。除余时波逸提(四十二)

若比丘尼。藏比丘尼若钵若衣若坐具针筒。自藏教人藏。下至戏笑。波逸提(四十三)

四分律卷第二十四四分律卷第二十五(二分之四明尼戒法)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    一百七十八单提法之二

若比丘尼。净施比丘比丘尼式叉摩那沙弥沙弥尼衣。后不问主取著者。波逸提(四十四)

若比丘尼得新衣。当作三种染坏色青黑木兰。若比丘尼得新衣。不作三种染坏色青黑木兰。新衣持者波逸提(四十五)

若比丘尼。故断畜生命者。波逸提(四十六)

若比丘尼。知水有虫。饮者波逸提(四十七)

若比丘尼。故恼他比丘尼。乃至少时不乐。波逸提(四十八)

若比丘尼。知比丘尼有粗罪。覆藏者波逸提(四十九)

若比丘尼。知诤事如法忏悔已。后更发举者波逸提(五十)

若比丘尼。知是贼伴。共一道行。乃至一聚落。波逸提(五十一)

若比丘尼。作如是语。我知佛所说法行淫欲非是障道法。彼比丘尼谏此比丘尼言。大姊。莫作是语。莫谤世尊。谤世尊者不善。世尊不作是语。世尊无数方便说淫欲是障道法。犯淫者是障道法。彼比丘尼谏此比丘尼时。坚持不舍。彼比丘尼乃至三谏。令舍是事。乃至三谏时。舍者善。不舍者波逸提(五十二)

若比丘尼。知如是语人未作法如是恶邪不舍。若畜同一羯磨同一止宿。波逸提(五十三)

若沙弥尼如是言。我知佛所说法行淫欲非障道法。彼比丘尼谏此沙弥尼言。汝莫作是语。莫诽谤世尊。诽谤世尊不善。世尊不作是语。沙弥尼。世尊无数方便说淫欲是障道法。犯淫欲者是障道法。彼比丘尼谏此沙弥尼时坚持不舍。彼比丘尼应乃至三呵谏。舍此事故。乃至三谏时若舍者善。不舍者彼比丘尼应语是沙弥尼言。汝自今已去非佛弟子。不得随余比丘尼。如诸沙弥尼得与比丘尼二宿。汝今无是事。汝去灭去不须此中住。若比丘尼知如是摈沙弥尼。若畜共同止宿。波逸提(五十四)

若比丘尼。如法谏时。作如是语。我今不学是戒。乃至问有智慧持律者当难问。波逸提。若为求解应难问(五十五)

若比丘尼。说戒时如是语。大姊。用说是杂碎戒为。说是戒时。令人恼愧怀疑轻毁戒故。波逸提(五十六)

若比丘尼。说戒时作如是语。大姊。我今始知是戒半月半月说戒经来。余比丘尼知是比丘尼若二若三说戒中坐。何况多。彼比丘尼无知无解。若犯罪应如法治。更重增无知法。大姊。汝无利得不善。汝说戒时。不用心念不一心摄耳听法。彼无知故。波逸提(五十七)

若比丘尼。共同羯磨已后作如是说。诸比丘尼随亲厚以众僧物与者。波逸提(五十八)

若比丘尼。僧断事时不与欲而起去者。波逸提(五十九)

若比丘尼。与欲竟后更呵。波逸提(六十)

若比丘尼。比丘尼共斗诤。后听此语已欲向彼说。波逸提(六十一)

若比丘尼。嗔恚故不喜。打彼比丘尼者。波逸提(六十二)

若比丘尼。嗔恚故不喜。以手搏比丘尼者。波逸提(六十三)

若比丘尼。嗔恚故不喜。以无根僧伽婆尸沙法谤者。波逸提(六十四)

若比丘尼。刹利水浇头王。王未出未藏宝。若入宫过门阈者。波逸提(六十五)

若比丘尼。捉宝及宝庄饰。自捉若教人捉。除僧伽蓝中及寄宿处。波逸提。若僧伽蓝中若寄宿处。若宝若以宝庄饰。自捉若教人捉。若识者当取。如是因缘非余(六十六)

若比丘尼。非时入聚落。又不嘱比丘尼。波逸提(六十七)

若比丘尼。作绳床若木床。足应高佛八指。除入陛孔上。若截竟过者。波逸提(六十八)

若比丘尼。持兜罗绵贮。作绳床木床若卧具坐具。波逸提(六十九)

尔时婆伽婆。在毗舍离猕猴江侧高阁堂上。时异处有蒜园。偷罗难陀比丘尼去园不远而行。园主问言。阿姨欲须蒜耶。报言须蒜。即时蒜与。此比丘尼得蒜已。后数数复往去。彼不远而行。其人见已复语言。阿姨更须蒜耶。报言须。我若得蒜便能食。即复与蒜。与蒜已敕守园人言。从今日给比丘尼人各五枚蒜。时园主留一人守园。自持蒜诣毗舍离卖。偷罗难陀比丘尼还至僧伽蓝中。语诸比丘尼言。汝等知不。某处某甲檀越。日给比丘尼人各五枚蒜。可往迎取。时偷罗难陀。将沙弥尼式叉摩那即往蒜园。问守蒜人言。园主何处。报言。诣毗舍离卖蒜。时守蒜人言。何故问耶。答言。园主日给比丘尼人各五枚蒜。今可与我。守蒜人言。小住。须园主来。我不得自在。我正可守视而已耳。比丘尼语言。大家见施奴不肯与。偷罗难陀。即敕沙弥尼拔取蒜。数知多少。此与上座次座和上阿阇梨。此与同和上同阿阇梨亲厚知识。此今日食。此明日食。此后日食。即时现园蒜取尽。蒜主还见蒜尽。问守园者言。蒜何故尽。答言大家。先信乐故。日给比丘尼僧人各五枚蒜。向有沙弥尼式叉摩那来至我所语我言。蒜主今为所在。我答言。入毗舍离卖蒜。我问言何故问。答我言。蒜主日与我人各五枚蒜。今可与我。我答言。小住。待园主还。我正守视而已耳。不得自由。比丘尼言。大家与我蒜。而奴不肯与我。时即敕沙弥尼拔取蒜已。数知多少言。此与上座。此与次座。此与和上。此与阿阇梨。此与同和上同阿阇梨。此与亲厚知识。此今日食。此明日食。此后日食。并复并啖。以是故园蒜都尽耳。园主即讥嫌言。此比丘尼无有惭愧。受无厌足。外自称言。我知正法。如是何有正法。正使檀越施与。犹应知足。况不见主而取尽。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责偷罗难陀比丘尼。汝等云何。尽拔取他蒜并并啖持去不留遗余。时诸比丘尼往白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责偷罗难陀比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何不见主拔取他蒜尽。尔时世尊以无数方便呵责已告诸比丘。往昔有一婆罗门。年百二十形体羸瘦。此婆罗门妇端政无比多生男女。此婆罗门系心其妇及诸男女。初不舍离。以此爱着情笃遂至命终。便生雁中其身毛羽尽为金色。以前福因缘故自识宿命。内白思惟。我当以何等方便养活此男女使不贫苦。日日来至其家日落一金羽而去。男女得之便自思惟。以何因缘此雁王日来落一金羽与我而去。我等宁可伺其来时方便捉之尽取金羽。如其所谋。即捉拔取金羽。取已即更生白羽。佛告诸比丘。欲知尔时婆罗门死为雁者。岂异人乎莫作异观。即园主是。其端政妇多生男女者。即偷罗难陀比丘尼是。男女者。即式叉摩那沙弥尼等是。以本贪爱故令金羽尽。更生白羽。今复爱故令蒜尽。更得贫穷。世尊以无数方便呵责偷罗难陀比丘尼已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼啖蒜者波逸提。比丘尼义如上。若比丘尼啖生蒜熟蒜若杂蒜者咽咽波逸提。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或有如是病。以饼裹蒜食。若余药所不治。唯须服蒜差听服。若涂疮不犯。不犯者最初未制戒。痴狂心乱。痛恼所缠(七十竟)

尔时婆伽婆在舍卫国。时偷罗难陀比丘尼剃三处毛。往诣檀越家在妇女前就座而坐。不自覆身露其形体。时彼妇女见已语言。阿姨共洗浴来。答言且止。便为得供养已。复语言但来共浴。答言我不须洗浴。时诸妇女即强脱衣见其剃处。即语言。阿姨。世人所以剃毛者为欲事。阿姨以何故剃之。偷罗难陀答言。我从俗已来习此法不但今也。时诸居士妇女即讥嫌言。比丘尼不知惭愧习不净行。外自称言。我知正法。如是有何正法。乃剃三处毛。犹如淫女贼女。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责偷罗难陀言。汝云何乃剃三处毛。诸比丘尼往白诸比丘。诸比丘往白世尊。世尊。以此因缘集比丘僧。呵责偷罗难陀。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何偷罗难陀乃剃三处毛。时世尊以无数方便呵责偷罗难陀已告诸比丘。此偷罗难陀比丘尼。多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼剃三处毛者波逸提。比丘尼义如上。三处毛者。大小便处及腋下。若比丘尼剃三处毛。一动刀一波逸提。若拔若揃灭若烧。一切突吉罗。比丘偷罗遮。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或有如是病。若有疮须剃去着药或为强力者所执不犯。不犯者最初未制戒。痴狂心乱痛恼所缠(七十一)

尔时婆伽婆。在释翅搜迦维罗卫尼俱律园中。时摩诃波阇波提比丘尼。往至世尊所。头面礼足在一面立。白佛言。世尊。女人身臭秽不净。说是语已。即礼佛足绕三匝而去。时世尊以此因缘集比丘僧。告诸比丘。自今已去听诸比丘尼以水作净。时偷罗难陀闻此制已。即以水作净。欲心内指水道中。指深爪伤内。血出污身衣卧具。诸比丘尼即问言。何所患苦。即具说因缘。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责偷罗难陀比丘尼。云何水作净。乃以指内水道中伤内血出污身衣及污卧具。诸比丘尼往白诸比丘诸比丘往白世尊。世尊尔时以此因缘集比丘僧。呵责偷罗难陀比丘尼。汝所为非。非威仪。非沙门法非净行非随顺行。所不应为。云何汝以水作净。以欲心内指爪深伤内血出污身衣及卧具。时世尊以无数方便呵责偷罗难陀已告诸比丘。此偷罗难陀多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼以水作净。应齐两指各一节。若过者波逸提。比丘尼义如上。水作净者以水洗内。彼比丘尼。以水作净。内两指各一节。过者波逸提。式叉摩那沙弥尼突吉罗。是谓为犯。不犯者。若齐两指各一节。若减一节。或有如是病。或内有草。或内有虫挽出不犯。不犯者最初未制戒。痴狂心乱痛恼所缠(七十二)

尔时婆伽婆。在舍卫国祇树给孤独园。时六群比丘尼。欲心炽盛颜色憔悴身体羸瘦。往诣波斯匿王宫内。宫内诸妇女见已问言。阿姨有何患苦。答言我有色患。即问言。有何等色患。答言。我欲心炽盛。诸妇女言。我在宫内。时时乃得男子。若不得男子时。或以胡胶作男根内着女根中。既得适意不名行淫。阿姨亦可作如是。既得适意不名行淫。时有二六群比丘尼。作如是男根已共行淫事。余比丘尼见谓共男子行淫。见起已方知非男子。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘尼言。云何汝等。以胡胶作男根共行淫。时诸比丘尼往白诸比丘。诸比丘往白世尊。世尊。以此因缘集比丘僧。呵责六群比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何六群比丘尼。以此胡胶作男根共行淫。时世尊以无数方便呵责六群比丘尼已告诸比丘。此六群比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼以胡胶作男根波逸提。比丘尼义如上。作男根者。用诸物作。或以胡胶作。若饭作。或用糗作。或蜡作。若比丘尼。以此诸物作男根内女根中者。一切波逸提。若不摩治内女根中者突吉罗。式叉摩那沙弥尼突吉罗。是谓为犯。不犯者。或有如是病。着果药及丸药。或衣塞月水。或为强力者所执不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(七十三)

尔时婆伽婆。在舍卫国祇树给孤独园。时六群比丘尼。欲意炽盛颜色憔悴形体羸瘦。往诣波斯匿王宫。时宫中诸妇女见已问言。阿姨何所患苦。答言以不从愿故。问言。有何愿不从。答言。我淫心炽盛。诸妇女言。我等在宫内。时时乃得男子。若不得时。以胡胶杂物作男根内女根中。既适淫意不名行淫。诸尊何不如是作。诸比丘尼报言。诸姊。世尊制戒不得尔。彼即复言。阿姨。我等在宫。时时乃得男子。若不得男子时。共相拍以适淫乐不名行淫。阿姨何不尔。时二六群比丘尼共相拍。余比丘尼见谓共男子行淫。起已方知非男子。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘尼言汝等云何共相拍。时诸比丘尼往白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责六群比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。汝等云何共相拍。世尊以无数方便呵责六群比丘尼已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒集十句义乃至正法久住。欲说戒者当如是说。若比丘尼共相拍波逸提。比丘尼义如上。拍者。若以手掌。若脚拍。若女根女根相拍。若比丘尼共相拍。拍者突吉罗。受拍者波逸提。若二女根共相拍。二俱波逸提。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或有如是病。或来去。若经行。若扫地。若以杖触不故作。若洗时手触不犯。不犯者最初未制戒。痴狂心乱痛恼所缠(七十四)

尔时婆伽婆。在舍卫国祇树给孤独园。时有一长者共妇出家为道。食时诣村乞食得已持还尼僧伽蓝中。食时本妇比丘尼持水在前立。并以扇扇。比丘语言。小避去我羞人。莫在我前立。比丘尼语言。大德何以羞我。彼复言。何不速去我羞比丘尼。答言。我在前立便言可羞。本来作如是如是事何以不羞。其妇比丘尼嗔恚。以扇柄打以水浇头而舍入房。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责此比丘尼。汝云何嗔恚打比丘。时诸比丘尼往白诸比丘。诸比丘往白世尊。世尊。以此因缘集比丘僧。呵责此比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何比丘尼打比丘。时世尊以无数方便呵责此比丘尼已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。比丘食时供给水。以扇扇者波逸提。如是世尊与比丘尼结戒。时诸比丘尼疑。不敢瞻视病比丘。无人与水不敢问。佛言。听诸比丘尼看病比丘。若无水听问。自今已去应如是结戒。若比丘尼。比丘无病食时供给水以扇扇者波逸提。比丘尼义如上。若彼比丘尼比丘不病食时供给水在前立以扇扇者波逸提。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。瞻视病比丘无水问不犯。不犯者最初未制戒。痴狂心乱痛恼所缠(七十五)

尔时婆伽婆。在舍卫国祇树给孤独园。时六群比丘尼。乞求生谷胡麻米若大小豆大小麦。时诸居士见已讥嫌言。诸比丘尼乞求无厌不知惭愧。外自称言。我知正法如是有何正法。乃乞如是等种种生谷米。似如淫女贼女无异。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘尼言。云何汝等。乞是种种生谷米。时诸比丘尼往白诸比丘。诸比丘往白世尊。时世尊以此因缘集比丘僧。呵责六群比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等。乞是种种生谷米。时世尊以无数方便呵责六群比丘尼已告诸比丘。此六群比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼乞生谷者波逸提。比丘尼义如上。彼比丘尼乞生谷乃至大小麦一切波逸提。比丘突吉罗式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若从亲里乞。若从出家人乞。若他为己己为他。若不乞自得者不犯。不犯者最初未制戒。痴狂心乱痛恼所缠(七十六)

尔时婆伽婆。在舍卫国祇树给孤独园。去比丘尼精舍不远。有好结缕草生。时有诸居士。数来在中坐卧调戏。或呗或歌或舞。或有啼哭音声。乱诸坐禅比丘尼。诸比丘尼患之。居士去后。以大小便粪扫置草上。诸居士还来在中戏。时诸不净污身及衣服。以此不净污草。草遂枯死。时诸居士以此事故皆讥嫌言。此诸比丘尼。受取无厌不知惭愧。外自称言我知正法如是有何正法。我等数来在此戏笑歌舞。云何比丘尼。乃以大小便污坏净草。复污我身及衣服。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。诃责此诸比丘尼。云何汝等。于居士所游戏之处。以大小便不净置生草上。污居士身及衣服。又使生草枯死。时诸比丘尼往白诸比丘。诸比丘往白世尊。世尊。尔时以此因缘集比丘僧。呵责此比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何比丘尼。居士所游戏之处。以大小便置生草上。污身及衣服。世尊以无数方便呵责此比丘尼已告诸比丘。此诸比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼在生草上大小便波逸提。比丘尼义如上彼比丘尼于生草上大小便者波逸提。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯不犯者或有如是病。若在无草处大小便。流堕草上。或风吹。或鸟衔污草不犯。不犯者最初未制戒。痴狂心乱痛恼所缠(七十七)

尔时婆伽婆。在罗阅只耆阇崛山中。时有一六群比丘尼。夜大小便器中。明旦不看墙外弃之。时有不信乐大臣。清旦乘车欲问讯洴沙王。路由比丘尼精舍边过。尼所弃大小便。堕此大臣头上污身衣服。时大臣念言。我当向官断事人说此事。时有笃信知相婆罗门言。欲何所诣。大臣答言。比丘尼以大小便污辱我。我欲向官断事人言。知相婆罗门谏言。且止。勿以此事向官言。或不成事更得其罪。时此大臣随语便还。彼知相婆罗门。即诣比丘尼精舍。问何等比丘尼。夜以器盛大小便不看墙外弃之。诸比丘尼答言。我等不知。诸比丘尼言。何故问此事。时婆罗门以此因缘具向诸比丘尼说。我已呵谏此大臣令止。自今已去后莫复尔。诸比丘尼即自相检校。谁为此事。即知六群比丘尼中有作此事者。时诸比丘尼。呵责六群比丘尼。云何汝夜大小便器中。明旦不看墙外弃之。时诸比丘尼往白诸比丘。诸比丘往白世尊。世尊。以此因缘集比丘僧。呵责六群比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何六群比丘尼。夜大小便器中。不看墙外弃之。时世尊以无数方便呵责六群比丘尼已告诸比丘。此六群比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。夜大小便器中。昼不看墙外弃者波逸提。比丘尼义如上。彼比丘尼。夜大小便器中。昼日当看墙外然后弃之。若夜起者要先弹指謦欬。若比丘尼。夜大小便器中。昼不看墙外弃者波逸提。若夜不謦欬不弹指弃者突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。夜大小便器中。昼则看墙外弃之。若夜弹指謦欬。若彼有瓦有石若有树株若有刺诸不净之处弃。若有汪水若有坑岸若有粪聚者不犯。不犯者最初未制戒。痴狂心乱痛恼所缠(七十八)

尔时婆伽婆。在罗阅只耆阇崛山中。时国人俗节会日伎乐嬉戏。时六群比丘尼往看。时诸居士见皆共讥嫌。此诸比丘尼不知惭愧习不净行。外自称言。我知正法如是有何正法。乃共看此种种戏事。与淫女贼女何异。诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘尼。云何汝等共看戏事。时诸比丘尼往白诸比丘。诸比丘往白世尊。世尊。尔时以此因缘集比丘僧。呵责六群比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等共看戏事。时世尊以无数方便呵责六群比丘尼已告诸比丘。此六群比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼往观看伎乐者波逸提。比丘尼义如上。观看者看种种戏笑。彼比丘尼。若从道至道。从道至非道。从非道至道。从高至下。从下至高。往看伎乐。若见波逸提。不见突吉罗。若发意欲去而不去。若期去中道还。尽突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或有所启。若被唤道由边过。或彼宿止处。或为强力将去。或缚去。或命难或梵行难不犯。不犯者最初未制戒。痴狂心乱痛恼所缠(七十九)

尔时婆伽婆。在舍卫国祇树给孤独园。时六群比丘尼。入村在屏处与男子共立语。诸居士见皆共讥嫌言。此比丘尼。不知惭愧犯不净行。外自称言。我知正法。如是有何正法。入村与男子屏处共语。如淫女贼女无异。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘尼。汝等云何入村在屏处与男子共立语。时诸比丘尼往白诸比丘。诸比丘往白世尊。世尊。尔时以此因缘集比丘僧。呵责六群比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等入村屏处与男子共立语。时世尊以无数方便呵责六群比丘尼已告诸比丘。此六群比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。入村内与男子在屏处共立共语波逸提。比丘尼义如上村者白衣舍。屏处者。不见不闻处。不见处者若尘雾闇。不闻处者乃至不闻常语声若比丘尼。入村内与男子在屏处立共语波逸提。若同伴盲而不聋突吉罗。聋而不盲突吉罗。立而不语突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若二比丘尼为伴。若有可知人为伴。若有多女人共立。或不盲不聋。或行不住。或病倒地。或为强力者所执。或被缚将去。或命难或梵行难不犯。不犯者最初未制戒。痴狂心乱痛恼所缠(八十竟)

尔时婆伽婆。在舍卫国祇树给孤独园。时六群比丘尼。与男子共入屏障处。时诸居士见皆共讥嫌言。此比丘尼。不知惭愧犯不净行。外自称言。我知正法如是有何正法。云何比丘尼。与男子共入屏障处。如淫女贼女不异时诸比丘尼。闻其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘尼。云何汝等。与男子共入屏障处。诸比丘尼往白诸比丘。诸比丘往白世尊。世尊。尔时以此因缘集比丘僧。呵责六群比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何六群比丘尼。与男子共入屏障处。时世尊以无数方便呵责六群比丘尼已告诸比丘。此六群比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼与男子共入屏障处者波逸提。比丘尼义如上。屏障处者。若树若墙若篱若衣若复余物障。彼比丘尼与男子共入屏障处波逸提。若同伴盲而不聋聋而不盲突吉罗。立住突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯不犯者。若有二比丘尼为伴。或有可知人为伴。若有余女人为伴。若不盲不聋。或行不住。或病倒地。若为强力者所将入。或被缚或命难或梵行难不犯。不犯者最初未制戒。痴狂心乱痛恼所缠(八十一)

尔时婆伽婆。在舍卫国祇树给孤独园。时六群比丘尼。在村内街巷中屏处与男子共立共语。若遣伴远去独与男子耳语。时诸居士见皆共讥嫌言。此比丘尼。不知惭愧犯梵行。外自称言。我知正法如是有何正法。云何比丘尼。入村内街巷中屏处与男子共立共语。若遣伴远去独与男子耳语。如似淫女贼女无异。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘尼。汝等云何入村在巷陌中屏处与男子耳语。时诸比丘尼往白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责六群比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何比丘尼。入村内巷陌中屏处独与男子耳语。时世尊以无数方便呵责六群比丘尼已告诸比丘。此六群比丘尼。多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。入村内巷陌中遣伴远去在屏处与男子共立耳语者波逸提。比丘尼义如上。村者白衣舍巷陌屏处者。有见屏处闻屏处。见屏处者烟云雾尘黑闇眼所不见。闻屏处者。乃至常语不闻声也。耳语者耳边语。彼比丘尼。入村巷陌中遣伴至不见不闻处在屏处与男子共立共耳语波逸提。离见处至闻处突吉罗。离闻处至见处突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若二比丘尼为伴。或与可知女人为伴。或有余人为伴。若伴不盲不聋。或病发倒地。或为强力者所执。或被缚将去。或命难梵行难。若有所与遣伴远去。若伴病。若无威仪。而语言妹汝去。我当送食与汝。若破戒破见破威仪。若被举若应灭摈。若以此事有命难梵行难不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(八十二)

尔时婆伽婆。在舍卫国祇树给孤独园。时有比丘尼。到时着衣持钵诣一居士家。到已居士妇敷一独坐床令坐。已舍入屋内。此比丘尼坐须臾。不语主人便舍座去。适出门。有一摩纳来入其家。四顾不见人。便作是念。此床座于我有益。即取持去。居士妇出。不见比丘尼。亦不见独坐床。即遣信问比丘尼。独坐床为何所在。比丘尼答言。我不知。当我出时。有一摩纳来入汝家。或彼持去。可从彼推求。即往推求还得床座。时诸居士皆共讥嫌言。比丘尼不知惭愧。外自称言。我知正法如是有何正法。云何坐主人床坐。不语便舍去。如似淫女贼女无异。诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责此比丘尼。云何比丘尼。坐主人床座不语便舍去。时诸比丘尼往白诸比丘。诸比丘往白世尊。世尊尔时以此因缘集比丘僧。呵责此比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何比丘尼。坐主人床座不语主便舍去。时世尊。以无数方便呵责此比丘尼已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。入白衣家内坐。不语主人舍去者波逸提。比丘尼义如上。彼比丘尼入白衣家坐。不语主人便去出门波逸提。一脚在门内一脚在门外。若方便欲去不去。若共期去而不去。一切突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。语主人而去。若座上更有人坐。若去时嘱比坐人而去。比坐人语言。但去无苦。或坐石上木上墼上草敷上若垛上。若屋欲崩。或火烧。若有毒蛇恶兽盗贼。若为强力所执。或被系。或命难或梵行难。不语主人而去不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(八十三)

尔时婆伽婆。在罗阅只耆阇崛山中。时罗阅城中有一不信乐大臣。有一独坐床无人敢坐上者。偷罗难陀比丘尼。常入出其家以为檀越。偷罗难陀。到时着衣持钵往诣其家。不语便坐大臣床座上。大臣见已问言。谁令此比丘尼坐我床上。答言。无有语者。自来坐耳。时大臣讥嫌言。偷罗难陀比丘尼无有惭愧。外自称言。我知正法。如是有何正法。云何比丘尼。不语主人便坐他座上。如贼女淫女无异。偷罗难陀。坐床上时。有月水不净。污他床褥即舍而去。大臣见已复更嗔恚言。此比丘尼不知惭愧。外自称言。我知正法。如是有何正法。不语其主坐他座上。如似淫女贼女有何等异。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责偷罗难陀比丘尼。云何比丘尼。不语主人辄坐他床上。时诸比丘尼往白诸比丘。诸比丘往白世尊。世尊尔时以此因缘集比丘僧。呵责偷罗难陀比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何偷罗难陀比丘尼。不语主人辄坐他床上。时世尊以无数方便呵责偷罗难陀比丘尼已告诸比丘。此偷罗难陀比丘尼。多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼入白衣家内不语主人辄坐床者波逸提。比丘尼义如上。彼比丘尼入白衣家不语主人辄坐床座者波逸提。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。语主人而坐。或有常处坐。若是亲厚。若有亲厚人语言。汝但坐无苦。我当语主人。若坐石上木上埵上草敷上。若癫病发卧地。或为强力者所执。或命难梵行难不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(八十四)

尔时婆伽婆。在舍卫国祇树给孤独园。时有众多比丘尼。道路行向拘萨罗国。诣一无住处村。到已不语主人便自敷坐具于中止宿。诸居士见问言。谁安此诸比丘尼在中止宿。答言。无有安者。自来止住。时诸居士讥嫌言。此比丘尼不知惭愧。外自称言。我知正法。如是有何正法。云何比丘尼。不语其主。便入他舍辄自安止。与淫女贼女何异。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责诸比丘尼。云何比丘尼。不语主人辄入他舍坐卧止宿。时诸比丘尼往白诸比丘。诸比丘往白世尊。世尊尔时以此因缘集比丘僧。呵责此诸比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何比丘尼。不语主人辄入他舍止宿坐卧。时世尊以无数方便呵责此比丘尼已告诸比丘。此诸比丘尼。多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。入白衣家内不语主人辄自敷座宿者波逸提。比丘尼义如上。敷座者。或敷草或敷树叶乃至敷卧毡。彼比丘尼。入白衣舍内不语主人自敷座具宿止。随胁着地。若一转一波逸提。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。语主人宿止。若是空舍。或作福舍。或是知识。若有亲厚者语言。汝但坐我当与汝语主人。或强力者所执。或被缚。或命难梵行难不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(八十五)

尔时婆伽婆。在舍卫国祇树给孤独园。时六群比丘尼。与男子共入闇室中。诸居士见皆共讥嫌言。此比丘尼。不知惭愧。犯不净行。外自称言。我知正法。如是何有正法。云何比丘尼。与男子共入闇室中。如淫女贼女无异。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘尼。汝等云何与男子共入闇室中。时诸比丘尼往白诸比丘。诸比丘往白世尊。世尊尔时以此因缘集比丘僧。诃责六群比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何六群比丘尼。与男子共入闇室中。时世尊以无数方便呵责六群比丘尼已告诸比丘。此六群比丘尼。多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。与男子共入闇室中者。波逸提。比丘尼义如上。闇室者。无灯火无窗牖无光明。彼比丘尼与男子共入闇室中者波逸提。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若有灯火向牖光明。若为强力者将入。若命难或梵行难不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(八十六)

四分律卷第二十五四分律卷第二十六(二分之五明尼戒法)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    一百七十八单提法之三

尔时婆伽婆。在舍卫国祇树给孤独园。时提舍难陀比丘尼。是谶摩比丘尼弟子。师语。汝取衣钵尼师檀针筒来。时提舍比丘尼。受师教不审谛。语诸比丘尼言。师教我偷衣钵尼师檀针筒。时诸比丘尼闻此语已。即问谶摩比丘尼。汝实教弟子偷衣钵尼师檀针筒耶。答言诸妹。我岂当有此意教弟子偷衣钵尼师檀针筒耶。我直语取衣钵尼师檀针筒来。不教偷也。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责提舍难陀比丘尼。云何汝受师语不审谛。向诸比丘尼言。师教我偷衣钵尼师檀针筒。时诸比丘尼往白诸比丘。诸比丘往白世尊。世尊尔时以此因缘集比丘僧。呵责提舍难陀比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何受师语不审谛。便语诸比丘尼言。师教我偷衣钵尼师檀针筒耶。时世尊以无数方便呵责提舍难陀比丘尼已告诸比丘此提舍难陀比丘尼。多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼不审谛受语。便向人说波逸提。比丘尼义如上。彼比丘尼不审谛受语。便语诸比丘尼言。师教我偷衣钵尼师檀针筒。说而了了者波逸提。不了了者突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。其事实尔。语言汝往偷取衣钵尼师檀针筒来。语诸比丘尼言。师教我偷衣钵尼师檀针筒来。或戏笑语。或疾疾语。或独语或梦中语。或欲说此乃错说彼不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(八十七竟)

尔时婆伽婆。在舍卫国祇树给孤独园。时六群比丘尼。以小事便共嗔恚作咒诅言。堕三恶道不生佛法中。我若作是事者。使我堕三恶道不生佛法中。若汝作是事。者亦堕三恶道不生佛法中。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘尼。云何汝等。自有小事便嗔恚作是咒诅言。堕三恶道不生佛法中。若我有是事。使我堕三恶道不生佛法中。若汝有是事。亦堕三恶道不生佛法中。时诸比丘尼往白诸比丘。诸比丘往白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何六群比丘尼。自有小事便嗔恚作是咒诅言。堕三恶道不生佛法中。若我有是事。使我入三恶道不生佛法中。若汝有是事。亦当堕三恶道不生佛法中。时世尊以无数方便呵责六群比丘尼已告诸比丘。此六群比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼有小因缘事便咒诅。堕三恶道不生佛法中。若我有如是事。堕三恶道不生佛法中。若汝有如是事。亦堕三恶道不生佛法中。波逸提。比丘尼义如上。佛言。自今已去听称南无佛。若我有如是事南无佛。若汝有如是事。亦南无佛。彼比丘尼有小事便自咒诅。堕三恶道不生佛法中。若我有是事。堕三恶道不生佛法中。若汝有是事。亦入三恶道不生佛法中。说而了了者波逸提不了了者突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若言南无佛。或戏笑语。或疾疾语。或独语。或梦中语。或欲说此错说彼不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(八十八)

尔时世尊。在拘睒弥瞿师罗园中。时迦罗比丘尼。与他共斗诤。不善忆持诤事。便自手槌胸啼哭。时比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责迦罗比丘尼。汝云何与他共斗诤。自手槌胸啼哭。时诸比丘尼往白诸比丘。诸比丘往白世尊。世尊尔时以此因缘集比丘僧。呵责迦罗比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何迦罗比丘尼。与他共斗诤。手槌胸啼哭。时世尊以无数方便呵责迦罗比丘尼已告诸比丘。此迦罗比丘尼。多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼共斗诤。不善忆持诤事。槌胸啼哭者。波逸提。比丘尼义如上。彼比丘尼。与他共斗诤者。有四种诤如上。若比丘尼。共斗诤不善忆持诤事。槌胸啼哭。一槌胸一波逸提。一渧泪堕一波逸提。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。或食噎而自槌。或因大小便泪出。或因风寒热泪出。或烟熏泪出。或闻法心生厌离泪出。或眼病着药泪出不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(八十九)

尔时婆伽婆。在婆只陀国。时六群比丘尼二人同一床卧。诸比丘尼见谓与男子共卧。见起时乃知非男子。时有一大将。勇健多智众术备具善能斗战。始娶妇未久被官敕当征。便生此念。我今远征妇当付谁。正欲付嘱居士。居士家多诸男子不得付嘱。大将先与跋提迦毗罗比丘尼知识。念言。我今宁可将妇付嘱迦毗罗比丘尼已然后出征。即便付之。时迦毗罗比丘尼。受其妇为拥护故共同床止宿此迦毗罗比丘尼身体细软。此妇人身触生染着心。时大将征还迎妇归家。其妇乐着比丘尼身细软便逃走还至彼尼所。此大将作是念。我欲作好而更得恶。云何我妇今不爱乐我。染着比丘尼逃走还趣彼所。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘尼及跋提迦毗罗比丘尼。云何汝等。二人同床共卧。时诸比丘尼往白诸比丘。诸比丘往白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘尼及迦毗罗比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等。二人。共同床卧。时世尊以无数方便呵责六群及迦毗罗比丘尼已告诸比丘。此六群及迦毗罗比丘尼。多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼二人共同床卧者波逸提。如是世尊与比丘尼结戒。时有疑者。不敢与病比丘尼共床卧。亦不敢更互坐更互卧。佛言。听与病者同床卧。听更坐更卧。自今已去应如是结戒。若比丘尼无病二人共床卧波逸提。比丘尼义如上。床者。有五种如上。彼比丘尼无病二人共同床卧。随胁着床敷一一波逸提。随转一一波逸提。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若与病人共床卧。若更互坐更互卧。或病倒地为强力者所执。或被缚。或命难梵行难不犯不犯者。最初未制戒。痴狂心乱痛恼所缠(九十)

尔时婆伽婆。在婆只陀国。时六群比丘尼二人同一褥同一被共卧。时诸比丘尼见谓与男子共卧。起时乃知非男子。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘尼。云何汝等二人同一褥同一被共卧。时诸比丘尼往白诸比丘。诸比丘往白世尊世尊尔时以此因缘集比丘僧。呵责六群比丘尼。汝所为非。非威仪非沙门法非净行非随顺行所不应为。云何汝等二人同一褥同一被共卧耶。时世尊以无数方便呵责六群比丘尼已告诸比丘。此六群比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼二人同一褥同一被共卧波逸提。如是世尊与比丘尼结戒。彼比丘尼有一敷。或是草或是树叶。诸比丘尼疑不敢共卧。佛言。听诸比丘尼各别敷卧毡。若寒时正有一被。听各内着衬身衣得共卧。自今已去应如是结戒。若比丘尼共一褥一同被卧除余时波逸提。比丘尼义如上。彼比丘尼二人同一褥共一被卧随胁着床波逸提。随转一一波逸提若同一褥别被突吉罗。若同一被别褥突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若有一敷若草若叶敷各别敷卧毡。若寒时同一被内各着衬身衣。或病倒地。或为强力者所执。或被系或命难或梵行难不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(九十一)

尔时婆伽婆。在舍卫国祇树给孤独园。时六群比丘尼。为恼故先住后至后至先住。故在前诵经问义教授。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘尼。云何汝等。为恼故先住后至后至先住在前诵经问义教授。时诸比丘尼往白诸比丘。诸比丘往白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘尼。云何汝等。为恼故先住后至后至先住在前诵经问义教授耶。时世尊以无数方便呵责六群比丘尼已告诸比丘。此六群比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼为恼故先住后至后至先住在前诵经问义教授波逸提。如是世尊与比丘尼戒结。彼比丘尼。亦不知是先住非先住。不知后至非后至。后乃知。其中或有作波逸提忏者。或有疑者。不知者不犯。自今已去当如是结戒。若比丘尼知先住后至后至先住。为恼故在前诵经问义教授者波逸提。比丘尼义如上。彼比丘尼知先住后至后至先住。为恼故在前诵经问义教授。说而了了者波逸提。不了了者突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者若不知。若先听。若是亲厚。若亲厚人语言。汝但教授。我当为汝语。若先住者从后至者受经。若后至从先住者受诵。若二人共从他受。若彼问此答。若共诵。若戏笑语。若疾疾语。若梦中语。若欲说此乃错说彼不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(九十二)

尔时婆伽婆。在舍卫国祇树给孤独园。时偷罗难陀比丘尼。同活比丘尼病。而不瞻视。诸比丘尼语言。汝同活比丘尼病。何不看视。彼犹故不瞻视。以不瞻视故彼遂命过。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责偷罗难陀比丘尼。汝云何同活比丘尼病。而不瞻视诸比丘尼劝汝。而不从语瞻视。遂令命终。时诸比丘尼往白诸比丘。诸比丘往白世尊。世尊尔时以此因缘集比丘僧。呵责偷罗难陀比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何偷罗难陀比丘尼。同活比丘尼病。而不瞻视诸比丘尼劝汝看视。而不从语遂令命终。时世尊以无数方便呵责偷罗难陀比丘尼已。告诸比丘此偷罗难陀比丘尼。多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者。当如是说。若比丘尼同活比丘尼病不瞻视者波逸提。比丘尼义如上。同活者二比丘尼共生活。彼比丘尼。同生活比丘尼病。不看视者。波逸提。除同活病。若余比丘尼病。若和上若阿阇梨。若同和上同阿阇梨。若弟子亲厚知识病。不瞻视一切突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。瞻视同活病。若己身病。不堪瞻视病者。若由是故命难或梵行难不看不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(九十三)

尔时婆伽婆。在舍卫国祇树给孤独园。时偷罗难陀比丘尼安居。初听余比丘尼在房中敷床。安居中嗔恚挽床驱出时。彼比丘尼惭愧惧失宿即便休道。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责偷罗难陀比丘尼。汝云何安居初听余比丘尼在房中安床。安居中嗔恚挽床驱出。使彼惭愧休道。时诸比丘尼往白诸比丘。诸比丘往白世尊。世尊尔时以此因缘集比丘僧。呵责偷罗难陀比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何偷罗难陀比丘尼。安居初听余比丘尼在房中安床。安居中嗔恚挽床驱出。使彼惭愧休道。时世尊以无数方便呵责偷罗难陀比丘尼已告诸比丘。此偷罗难陀比丘尼。多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼安居。初听余比丘尼在房中安床。后嗔恚驱出者。波逸提。比丘尼义如上。安居中者受安居已。床者五种床如上。彼比丘尼安居。初听余比丘尼在房中安床。后嗔恚驱出随作方便。随出门一一波逸提。若方便驱众多人出众多户。众多波逸提。若方便驱众多人出一户众多波逸提。若方便驱一人出众多户众多波逸提。若方便驱一人出一户一波逸提。若出余衣物者突吉罗。若闭户使不得入突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。不以嗔恚。随上座次驱下座出。未受大戒人共宿。过二宿第三宿驱出。若令病人出在大小便处便利。若破戒破见破威仪。若被举若灭摈若应灭摈。若以此事命难梵行难。一切驱出不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(九十四)

尔时婆伽婆。在舍卫国祇树给孤独园。时六群比丘尼。春夏冬一切时人间游行。时遇暴雨河水泛涨。漂失衣钵尼师檀针筒。踏杀生草。时诸居士见皆共讥嫌言。此比丘尼。不知惭愧断众生命。外自称言。我知正法。如是有何正法。云何比丘尼。春夏冬一切时人间游行。遇天暴雨河水泛涨漂失杂物。又踏杀生草断众生命。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责六群比丘尼。云何汝等。春夏冬一切时人间游行。遇雨河水泛涨漂失衣物。踏杀生草使居士讥嫌。时诸比丘尼往白诸比丘。诸比丘往白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何六群比丘尼。春夏冬一切时人间游行。遇雨河水泛涨漂失衣物踏杀生草。使居士等讥嫌。时世尊以无数方便呵责六群比丘尼已告诸比丘。此六群比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼春夏冬一切时人间游行者波逸提。如是世尊与比丘尼结戒。若彼比丘尼。为佛事法事僧事病比丘尼事。佛言。听受七日法出界去。自今已去当如是说戒。若比丘尼春夏冬一切时人间游行。除余因缘者波逸提。比丘尼义如上。彼比丘尼春夏冬一切时人间游行。随入村界一一波逸提。若无村无界处行十里间者波逸提。减一村减十里者突吉罗。一村间行一界内者突吉罗。方便欲去而不去。若共期去而不去。一切突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。为佛法僧事。为病比丘尼事。受七日法出界行。或为强者所执。或被缚去。或命难或梵行难不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(九十五)

尔时婆伽婆。在舍卫国祇树给孤独园。尔时舍卫诸居士。请谶摩比丘尼共立制度。我等共供养众僧乃至安居竟。谶摩比丘尼安居竟。而彼即住不去。时诸居士皆讥嫌言。我等先有制度。请谶摩比丘尼来。共供养众僧。乃至安居竟。谶摩比丘尼而今安居竟。犹故不去时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责谶摩比丘尼言。诸居士共立制度。请谶摩比丘尼来。共供养众僧至安居竟。今安居已讫。故住不去。尔时诸比丘尼往白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责谶摩比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何居士供养汝夏安居。今者已讫。云何故住。使诸居士讥嫌。尔时世尊。以无数方便呵责谶摩比丘尼已。告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼夏安居讫不去者波逸提。比丘尼义如上。若比丘尼安居竟应出行乃至一宿。若比丘尼安居竟不出行波逸提。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。夏安居讫去。若彼居士更请住。我当更供养。若家家传食。若亲里男女请。今日食或明日食。若遇病无伴瞻视者。或水难或恶兽难或贼难。或水瀑涨。或为强力所执。或被系缚。或命难梵行难。如是诸难夏安居讫。不出行者无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(九十六)

尔时婆伽婆。在舍卫国祇树给孤独园。时王波斯匿。边界人民反叛。时六群比丘尼。于彼人间有疑恐怖处游行。时诸贼见已作是言。此六群比丘尼。皆为波斯匿王所供养。我等当共触娆。时诸居士见已皆讥嫌言。此比丘尼。无有惭愧皆犯梵行。外自称言。我修正法。如是有何正法。于边界人间恐怖处游行。与贼女淫女无异。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责六群比丘尼。汝等云何。于人间恐怖处游行。即往白诸比丘。诸比丘白佛。佛尔时以此因缘集比丘僧。呵责六群比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等在人间恐怖处游行。尔时世尊以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。边界有疑恐怖处人间游行者波逸提。比丘尼义如上。边界者远城处。有疑者疑有贼盗。恐怖者恐有贼盗。彼比丘尼。于边界有疑恐怖处游行。随入村行一一界。一一波逸提。无村阿兰若处行十里。一波逸提。行减一村减十里。一突吉罗。若村中行一界内突吉罗。方便欲去共期而不去。一切突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若被唤。若被请。若有所白。若为强力者所执。若被系缚。或命难梵行难。若先至后有疑恐怖事起者无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(九十七)

尔时婆伽婆。在舍卫国祇树给孤独园。时波斯匿王界内人民反叛。尔时六群比丘尼。在彼界内有疑恐怖处游行。时诸贼见已皆作是言。此六群比丘尼。皆为波斯匿王所供养。我等当共触娆。时诸居士见皆共讥嫌言。此比丘尼。无有惭愧皆犯梵行。外自称言。我修正法。如是有何正法。乃于界内。有疑恐怖处游行。如贼女淫女无异。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘尼。汝等云何于人间恐怖处游行。即往白诸比丘。诸比丘往白世尊。世尊尔时以此因缘集比丘僧。呵责六群比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等。在界内人间恐怖处游行。时世尊以无数方便呵责已告诸比丘。此六群比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼于界内有疑恐怖处在人间游行波逸提。比丘尼义如上。界内者绕城四面。有疑者疑有贼盗也。恐怖者恐有贼盗。若比丘尼。于彼界内有疑恐怖处人间游行。随入村内行一一界。一一波逸提。无村阿兰若处。行至十里。一波逸提。减一村减十里。突吉罗村中行一界内。一突吉罗。若方便欲去而不去。共期去而不去。一切突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若有所白。若被唤。若请去。若为强力者所执。若被系缚。或命难梵行难。若先至后有疑恐怖事起者无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(九十八)

尔时婆伽婆。在舍卫国祇树给孤独园。时有比丘尼。亲近居士居士儿共住作不随顺行。时诸比丘尼谏言。汝莫亲近居士居士儿作不随顺行。汝妹可别住。汝若别住。于佛法中得增益安乐住。而彼故不别住。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责彼比丘尼。汝云何亲近居士居士儿共住作不随顺行。时诸比丘尼往白诸比丘。诸比丘白佛。佛以此因缘集比丘僧。呵责彼比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何乃与居士居士儿亲近共住作不随顺行。呵责已告诸比丘。自今已去听僧与彼比丘尼作呵责。舍此事故。白四羯磨当作如是呵责舍此事。众中应差堪能羯磨者。如上当作如是白。大姊僧听。此某甲比丘尼。亲近居士居士儿共住作不随顺行。余比丘尼呵谏言。汝妹莫亲近居士居士儿作不随顺行。汝妹可别住。汝若别住。于佛法有增益安乐住。彼比丘尼故不改。若僧时到僧忍听。僧与彼某甲比丘尼作呵责令舍此事。汝妹莫亲近居士居士儿共住作不随顺行。汝妹可别住。若别住。于佛法有增益安乐住。白如是。大姊僧听。此某甲比丘尼。亲近居士居士儿共住作不随顺行。余比丘尼谏言。妹莫亲近居士居士儿共住作不随顺行。汝妹今可别住。汝若别住。于佛法有增益安乐住。而彼故不改。今僧与彼某甲比丘尼作呵责舍此事故。汝妹莫亲近居士居士儿共住作不随顺行。汝妹可别住。汝若别住者。于佛法有增益安乐住。谁诸大姊忍。僧与彼某甲比丘尼作呵责舍此事者默然。谁不忍者说。如是第二第三说。僧已忍。与彼比丘尼作呵责舍此事竟。僧忍默然故。是事如是持。当作如是呵责。众僧为彼比丘尼作呵责白四羯磨舍此事已。诸比丘尼往白诸比丘。诸比丘往白佛。佛告诸比丘。若有如是比丘尼。比丘尼僧亦当作白四羯磨呵谏舍此事。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。亲近居士居士儿共住作不随顺行。余比丘尼谏此比丘尼言。妹汝莫亲近居士居士儿共住作不随顺行。妹汝可别住若别住。于佛法中有增益安乐住。彼比丘尼谏此比丘尼时坚持不舍。彼比丘尼应三谏。舍此事故。乃至三谏舍此事善。若不舍者波逸提。比丘尼义如上。亲近者。数数语数数笑数数调戏。居士者未出家人。儿者亦未出家人。彼比丘尼。亲近彼居士居士儿共住作不随顺行。彼比丘尼谏此比丘尼言。妹莫亲近居士居士儿作不随顺行。汝当别住。汝若别住。于佛法中有增益安乐住。汝今可舍此事。莫为僧所呵责而犯重罪。若随语者善。不随语者当作白。白已当语言。妹我已白。余有羯磨在。可舍此事。莫为僧所呵责而更犯罪。若随语者善。不随语者当作初羯磨。作初羯磨已当语言。妹已白已作初羯磨。余有二羯磨在。可舍此事。莫为僧所呵责而更犯罪。若随语者善。不随语者作第二羯磨。作第二羯磨已当语言。已作白第二羯磨。余有一羯磨在。可舍此事。莫为僧所呵责而更犯罪。若随语者善。不随语者作三羯磨竟波逸提。若白二羯磨竟三突吉罗。白一羯磨竟二突吉罗。白已一突吉罗。白未竟未白前。亲近居士居士儿作不随顺行。如是一切突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗是谓为犯。不犯者。初语时舍。非法别众呵责。非法和合众。法别众。似法别众。似法和合众。非法非律非佛所教。若一切不作呵责不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(九十九)

尔时婆伽婆。在舍卫国祇树给孤独园。尔时六群比丘尼。往观王宫画堂园林浴池。诸居士见皆共讥嫌。此诸比丘尼。不知惭愧犯梵行。外自称言。我知正法。如是有何正法。乃往观王宫画堂园林浴池。如贼女淫女无异。尔时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘尼。汝云何乃往观王宫画堂园林浴池。尔时诸比丘尼往白诸比丘。诸比丘往白佛。佛尔时以此因缘集比丘僧呵责六群比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何六群比丘尼乃往观王宫画堂园林浴池。世尊以无数方便呵责六群比丘尼已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼往观王宫文饰画堂园林浴池者波逸提。比丘尼义如上。若比丘尼。往观王宫文饰画堂园林浴池。从道至道。从道至非道。从非道至道。从高至下。从下至高。去而见者波逸提。不见者突吉罗。方便欲去而不去。若共期去而不去。一切突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若入王宫有所白。若唤若请。若路由中过。若寄宿。若为强力者所执或被缚将去。或命难梵行难。若复为僧事塔事。而往观看画堂。欲取摸法不犯。若至僧伽蓝中受教授听法。或被请道由中过。若寄宿。或为强力者所执。或被缚将去。或为僧事塔事往观园林浴池欲取摸法者。不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(一百)

尔时婆伽婆。在舍卫国祇树给孤独园。尔时六群比丘尼。露身在河水泉水池水深水中浴。时有贼女淫女。往比丘尼所语言。汝等年少腋下未生毛。云何便出家学道修梵行耶。如今年少。可于爱欲中共相娱乐。老时可修梵行。如是二事俱得。其中年少者闻便生不乐心。时诸居士见皆共讥嫌言。此诸比丘尼不知惭愧。外自称言。我知正法。如是有何正法。而露身形在河泉池深水中浴。如淫女贼女无异。尔时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘尼言。云何汝等露形在河泉池深水中浴耶。时诸比丘尼白诸比丘。诸比丘往白佛。佛尔时以此因缘集比丘僧。呵责六群比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何比丘尼。露形在河池泉深水中浴耶。时世尊以无数方便呵责六群比丘尼已告诸比丘。此六群比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼露身形在河水泉水深水池水中浴者波逸提。比丘尼义如上。彼比丘尼应以四事覆形洗浴。若在流水岸侧曲回处。若复有树荫覆处。若复水覆障。若以衣障身上。三事不得相取与器物。以衣障者。一切如法事得作。彼比丘尼。若露形在河池泉深水中洗浴身。尽渍波逸提。不尽渍突吉罗。方便欲洗而不洗。共期而不去。一切突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。水岸曲回处。树荫覆处。水覆障。若以衣障形。若为强力所执无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(一)

尔时婆伽婆。在舍卫国祇树给孤独园。尔时世尊。听比丘尼作浴衣。时六群比丘尼。闻世尊听比丘尼作浴衣。便多作广大浴衣。时比丘尼见已问言。佛听诸比丘尼畜五衣。此是何衣。报言。此是我等浴衣。诸比丘尼闻。其中有少欲知足。行头陀乐学戒知惭愧者。嫌责六群比丘尼言。世尊听畜浴衣。云何便多广大作浴衣耶。时诸比丘尼白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责六群比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何比丘尼多作广大浴衣耶。时世尊以无数方便呵责六群比丘尼已告诸比丘言。此六群比丘尼。多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。作浴衣应量作。应量作者长佛六磔手广二磔手半。若过者波逸提。比丘尼义如上。浴衣者障身浴也。彼比丘尼作浴衣。长中过量广中足。长中足广中过量。若二俱过量。自割截作成者波逸提。不成者突吉罗。若语他作割截。成者波逸提。不成者突吉罗。若为他作成不成一切突吉罗。比丘波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。如量作减量作。若得已成者。当裁令如法。若重叠无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(二)

尔时婆伽婆。在舍卫国祇树给孤独园。尔时有一比丘尼。欲裁缝僧伽梨。时偷罗难陀比丘尼言。妹持来。我与汝裁缝。彼即与衣财。彼比丘尼聪明多知识善能教化。偷罗难陀比丘尼作是意。欲使彼比丘尼久作供养故便为裁衣不即为缝成。时偷罗难陀比丘尼所住精舍失火。衣财为火所烧。又为风吹零落。时居士见已皆讥嫌言。此比丘尼不知惭愧。外自称言。我修正法。如是有何正法。云何比丘尼裁他衣。而不即缝成。为火所烧风吹零落。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责偷罗难陀比丘尼言。汝云何为他作衣不即缝成为火所烧风吹零落。时诸比丘尼白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责偷罗难陀比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何比丘尼裁衣不即缝成。为火所烧风吹零落耶。时世尊以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼缝僧伽梨过五日波逸提。比丘尼义如上。如是世尊与比丘尼结戒。彼求僧伽梨出迦絺那衣六难事起疑。佛言。若有如是事无犯。自今已去应如是结戒。若比丘尼缝僧伽梨过五日。除求索僧伽梨出迦絺那衣六难事起者波逸提。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。求索僧伽梨出功德衣五日六难事起。若缝若料理时。若无刀无针。若无线若少不足。若衣主破戒破见破威仪。若被举若灭摈若应灭摈。若由此事故。有命难梵行难。不缝成过五日者不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(三)

尔时婆伽婆。在毗舍离猕猴江侧高阁讲堂上。时众僧多得供养。时有比丘尼。置僧伽梨在房。不看晒治虫烂色坏。后时众僧供养断。此比丘尼。不看僧伽梨至村边着欲入村方见僧伽梨虫烂色坏。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责此比丘尼言。云何置僧伽梨在房。不看晒治使虫烂色坏。时诸比丘尼往白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责此比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何置僧伽梨在房。不看晒治虫烂色坏。时世尊以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼过五日不看僧伽梨波逸提。比丘尼义如上。彼比丘尼。置僧伽梨在房中。五日五日应往看。不看波逸提。除僧伽梨。余衣不五日五日看突吉罗。除余衣。若不五日五日看余所须之物。令失者虫烂色坏突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。置僧伽梨在房。五日五日看。若举处坚牢。若寄人。彼受寄人言。但安意我当为汝看。彼若看恐失不五日五日看不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(四)

四分律卷第二十六四分律卷第二十七(二分之六明尼戒法)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    一百七十八单提法之四

尔时婆伽婆。在舍卫国祇树给孤独园。尔时偷罗难陀比丘尼。有亲旧檀越。欲为僧设食并施衣。偷罗难陀闻。即往问言。我闻汝欲设食并施僧衣。实尔以不。檀越报言尔。偷罗难陀言。众僧大功德大威神。多檀越布施。汝供给处多。今但可施食。不须施衣。檀越即言可尔。不复作衣。即其夜办具饮食。明日清旦往白时到。诸比丘尼着衣持钵往诣其家就座而坐。时檀越观诸比丘尼僧。威仪庠序法服齐整。见已自悔。不觉发言。如是好众。云何使我留难不作衣供养耶。时诸比丘尼即问言。以何因缘乃发是言。时檀越即具白因缘。比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责偷罗难陀言。云何与众僧衣作留难。时诸比丘尼白诸比丘。诸比丘往白佛。佛以此因缘集比丘僧。呵责偷罗难陀。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何与僧衣作留难。以无数方便呵责已告诸比丘。偷罗难陀比丘尼。多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。与众僧衣作留难者波逸提。比丘尼义如上。众僧者如上。衣者十种如上彼比丘尼与众僧衣作留难者波逸提。除众僧。与余人作留难者突吉罗。除衣。余物作留难突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。欲施少者劝使多与。欲施少人劝与多人。欲施粗劝施细者。或戏笑语。或屏处语。或疾疾语。或梦中语。或欲说此错说彼无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(五)

尔时婆伽婆。在舍卫国祇树给孤独园。时有比丘尼。着他僧伽梨。不语主入村乞食。时衣主不知。作失衣意。于后求觅。乃见彼比丘尼着行。即语汝犯偷。彼言。我不偷汝衣。以亲厚意故。取汝衣着耳。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责此比丘尼言。汝云何不语主盗着他衣。使他作失衣意求觅耶。即往白诸比丘。诸比丘白佛。佛以此因缘集比丘僧。呵责此比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何比丘尼。不语主盗着他衣。使衣主作失衣意求觅耶。时世尊以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼不问主便着他衣者波逸提。比丘尼义如上。彼比丘尼取他衣着不语主入村乞食者波逸提。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若问主。若是亲厚。若亲厚语言。汝但着我当为汝语主不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(六)

尔时婆伽婆。在舍卫国祇树给孤独园。时跋难陀释子有二沙弥。一名耳二名蜜。一人休道。一人着袈裟入外道众中。时六群比丘尼。以沙门衣。施与休道者。及与彼入外道者。尔时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责六群比丘尼。汝云何持沙门衣。施与休道者及与彼入外道者。诸比丘尼往白诸比丘。诸比丘往白佛。佛以此因缘集比丘僧。呵责六群比丘尼言。汝所为非。非威仪非沙门法非净行。非随顺行。所不应为。云何汝等。以沙门衣与彼休道及入外道者。尔时世尊以无数方便。呵责六群比丘尼已告诸比丘。此诸比丘尼。多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼持沙门衣。施与外道白衣者波逸提。比丘尼义如上。白衣者在家人。外道者在佛法外出家人。沙门衣者染晒衣。彼比丘尼以沙门衣施与彼受者波逸提。此与彼不受突吉罗。方便欲与而不与。期要当与而不与。一切突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若与父母。若与塔作人。与讲堂屋舍作人计挍食直与。或为强力者所夺无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(七)

尔时婆伽婆。在舍卫国祇树给孤独园。时比丘尼众得如法施衣欲分。时偷罗难陀多诸弟子分散行不在。时偷罗难陀作是意。遮众僧如法分衣。恐弟子不得。诸比丘尼知如是意。诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责偷罗难陀。云何作是意。遮众僧如法分衣。恐弟子不得。时诸比丘尼往白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责偷罗难陀。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何作是意。遮众僧如法分衣。恐弟子不得。时世尊以无数方便呵责偷罗难陀已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼作如是意。众僧如法分衣遮令不分。恐弟子不得者。波逸提。比丘尼义如上。众僧者如上。法者如法如律如佛所教。衣者有十种如上。彼比丘尼作如是意。众僧如法分衣遮令不分恐弟子不得波逸提。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或非时分。非法别众。非法和合众。法别众。似法别众。似法和合众。非法非律非佛所教。若欲分时恐失若坏遮令不分无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(八)

尔时婆伽婆。在舍卫国祇树给孤独园。时诸比丘尼众僧。如法出迦絺那衣。六群比丘尼作是念。令众僧今不出迦絺那衣。后当出令五事久得放舍。时诸比丘尼。知六群比丘尼作如是意。令众僧今不出迦絺那衣。欲令五事久得放舍。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责六群比丘尼言。汝云何作是意。令众僧今不出迦絺那衣。欲令五事久得放舍耶。诸比丘尼白诸比丘。诸比丘往白世尊。世尊以此因缘集诸比丘僧。呵责六群比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为云何作如是意。令众僧今不出迦絺那衣。欲令五事久得放舍。以无数方便呵责已告诸比丘。此六群比丘尼。多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼作如是意。令众僧今不得出迦絺那衣。后当出欲令五事久得放舍波逸提。比丘尼义如上。僧者如上。法者如法如律如佛所教。彼比丘尼作如是意。停众僧如法出迦絺那衣。欲令五事久得放舍者波逸提。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若非时出。非法别众。非法和合众。法别众。似法别众。似法和合众。非法非律非佛所教。若出时恐失坏遮令不出无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(九)

尔时婆伽婆。在舍卫国祇树给孤独园。时比丘尼僧。欲出迦絺那衣。时六群比丘尼作是意。今比丘尼僧。如法出迦絺那衣。遮使不出。欲令久得五事放舍。诸比丘尼知六群比丘尼作如是意。遮比丘尼僧。如法出迦絺那衣。欲令五事久得放舍。诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘尼言。云何作是意。遮比丘尼僧如法出迦絺那衣。欲令五事久得放舍。往白诸比丘。诸比丘往白佛。佛以此因缘集比丘僧。呵责六群比丘尼言。汝所为非非威仪非沙门法非净行非随顺行。所不应为。比丘尼众欲如法出迦絺那衣。云何遮令不出。欲令久得五事放舍耶。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼作如是意。遮比丘尼僧不出迦絺那衣。欲令久得五事放舍。波逸提。比丘尼义如上。僧者如上。法者如法如律如佛所教。彼比丘尼作是意。遮比丘尼僧如法出迦絺那衣欲令久得五事放舍。说而了了者波逸提。不了了者突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓。为犯。不犯者。出迦絺那衣非时。非法别众。非法和合众。法别众。似法别众。似法和合众非法非律非佛所教。若出恐失坏如是遮者无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(十)

尔时佛在舍卫国祇树给孤独园。时有比丘尼共诤斗。至偷罗难陀比丘尼所语言。与我止此斗诤偷罗难陀比丘尼聪明智慧。诤事起能灭。竟不为方便灭此诤事。时彼比丘尼。以斗诤事不得和合。愁忧遂便休道。时比丘尼众闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责偷罗难陀言。云何比丘尼。语言为我灭诤事。而竟不为方便灭此诤事。令彼比丘尼。以此诤事不和解。遂便休道耶。即往白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责偷罗难陀。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何竟不与彼和解斗诤事使彼休道耶。时世尊以无数方便呵责已告诸比丘。此偷罗难陀比丘尼。多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。余比丘尼语言。为我灭此诤事。而不作方便。令灭者波逸提。比丘尼义如上。斗诤有四种如上。彼比丘尼。语余比丘尼言。为我灭此诤事。而不与方便。灭此诤事。波逸提。除斗诤已。若更有余小小事诤。不方便灭突吉罗。若己身斗诤事。不方便灭突吉罗除比丘比丘尼。余人有斗诤。不方便灭突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若为灭若与作方便若病若言不行。若彼破戒破见破威仪。若被举若灭摈若应灭摈。若以此事有命难梵行难。不方便灭者无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(十一)

尔时婆伽婆。在舍卫国祇树给孤独园。时跋难陀释子有二沙弥。一名耳二名蜜。一人罢道一人着袈裟入外道众。时六群比丘尼。持食与白衣入外道者。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责六群比丘尼言。汝云何持食与白衣入外道者。时诸比丘尼白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责六群比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等持食与白衣入外道者。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒集十句义乃至正法久住。欲说戒者当如是说。若比丘尼与白衣入外道者可啖食者波逸提。如是世尊与比丘尼结戒。彼疑不敢置地与。不敢使人与。佛言。听使人与若置地与。自今已去当如是说戒。若比丘尼自手持食与白衣入外道食者波逸提。比丘尼义如上。白衣者未出家人。外道者在佛法外出家者。是可食啖者如上。彼比丘尼自手持食与白衣入外道此与彼受者波逸提。不受者突吉罗。方便欲与而不与。若期当与悔不与。一切突吉罗。比丘波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或置地与。或使人与。若与父母若与塔作人。若为强力者所夺无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(十二)

尔时世尊。在舍卫国祇树给孤独园。时六群比丘尼。营理家事舂磨或炊饭或炒麦或煮食或敷床卧具或扫地或取水或受人使令。诸居士见已皆共嗤笑言。如我妇营理家业。舂磨炊饭乃至受人使令。此六群比丘尼亦复如是。时诸居士皆生慢心不复恭敬。尔时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘尼言。云何营理家业舂磨乃至受人使令。如俗人无异耶。往白诸比丘。诸比丘白佛。佛以此因缘集比丘僧。呵责六群比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何营理家业舂磨乃至受使。如俗人无异。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼为白衣作使者波逸提。比丘尼义如上。为白衣作使者。即上舂磨乃至受使者是。彼比丘尼。营理家业舂磨乃至受人使令者一切波逸提。比丘随所犯。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若父母病若被系闭。为敷床卧具扫地取水供给所须受使。若有信心优婆塞病若被系闭。为敷床卧具扫地取水受使。若为强力者所执。如是一切无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(十三)

尔时婆伽婆。在舍卫国祇树给孤独园。时六群比丘尼手自纺绩。诸居士见已皆共嗤笑言。如我妇纺绩。此比丘尼亦如是。诸居士即生慢心无有恭敬心。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘尼。汝云何手自纺绩。往白诸比丘。诸比丘白佛。佛以此因缘集比丘僧。呵责六群比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何自手纺绩。与俗人无异耶。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼自手纺缕者波逸提。比丘尼义如上。缕者有十种如上。若比丘尼手自纺缕一引一波逸提。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若自索线合线。或强力所执者。无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(十四)

尔时婆伽婆。在舍卫国祇树给孤独园。时偷罗难陀比丘尼。到时着衣持钵诣一居士家敷座而坐。时彼居士妇。脱身璎珞衣服入后园洗浴。时偷罗难陀比丘尼。辄着他璎珞衣服在居士床上卧。时彼居士。先出行不在。后行还至家内。卒见偷罗难陀。意谓是己妇。即便就卧。手捉扪摸呜口。彼扪摸时。觉其头秃。方问言。汝是何人。报言。我是偷罗难陀比丘尼。居士语言。汝何故。着我妇璎珞衣服。在我床上卧。令我见已谓是我妇。汝可速去。自今已去莫复更来入我家。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责偷罗难陀言。汝云何着他妇璎珞衣服在床上卧。即往白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责偷罗难陀言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何入居士家。着他妇璎珞衣服在床上卧。使居士嫌怪耶。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼入白衣舍内在小床大床上。若坐若卧波逸提。比丘尼义如上。白衣舍者村。小床者坐床。大床者卧床。彼比丘尼。入白衣舍内在小床大床上。若坐若卧随胁着床。一转一一波逸提。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。若坐独坐床。若为比丘尼僧敷众多坐。若病倒地。若为强力者所执。若被系闭。若命难梵行难无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(十五)

尔时婆伽婆。在舍卫国祇树给孤独园。时有众多比丘尼。向拘萨罗国在道行。至一无住处村。语其舍主。于舍内敷敷具而宿。至明日清旦。不辞主人而去。后村舍失火烧舍。时被烧居士谓舍内有人。便不往救火火烧舍尽。即问比丘尼在何处。答言已去。诸居士皆共讥嫌言。此比丘尼等不知惭愧。外自称言。我修正法。如是有何正法。云何语主人在舍内止宿。明日不辞主人而去。我等谓舍内有人。而不救火使烧舍尽。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责诸比丘尼言。汝云何语主人在他舍内宿。去时不语其主令火烧他舍尽。即往白诸比丘。诸比丘往白佛。佛以此因缘集比丘僧。呵责诸比丘尼言。汝云何语主人在他舍内宿。去时不语使火烧他舍尽。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼至白衣舍。语主人敷座止宿。明日不辞主人而去。波逸提。比丘尼义如上。白衣舍者村。宿者在中止宿处是。敷敷者。或草敷或叶敷。下至自敷卧毡。彼比丘尼。至白衣舍内。语主人敷座止宿。明日不辞而去出门波逸提。一脚在内一脚在外。方便欲去而不去。若共期去而不去。一切突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。辞主人而去。若先有人在舍内住。若舍先空。若先为福舍。若是亲厚。亲厚者语言。汝但去。当为汝语主人。若舍崩坏。若为火烧。若中有毒蛇恶兽。若有贼入。或为强力者所执。若被系闭。或命难梵行难不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(十六)

尔时婆伽婆。在舍卫国祇树给孤独园。时有六群比丘尼。诵种种杂咒术。或支节咒。或刹利咒。鬼咒吉凶咒。或习转鹿轮卜。或习解知音声。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责六群比丘尼言。汝云何习诵如是种种支节咒乃至解诸音声咒。呵责已往白诸比丘。诸比丘往白佛。佛以此因缘集比丘僧。呵责六群比丘尼。汝所为非。非威仪非沙门法。非净行非随顺行。所不应为。云何诵习种种咒术乃至解知音声耶。呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼诵习世俗咒术者波逸提。比丘尼义如上。世俗咒术者。支节乃至解知音声也。比丘尼诵习世俗咒术乃至音声。若口受若执文诵。说而了了波逸提。不了了突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若诵治腹内虫病咒。若诵治宿食不消咒。若学书若诵世俗降伏外道咒。若诵治毒咒以护身故无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(十七)

若比丘尼。教人诵习咒术者。波逸提(十八)

尔时佛在舍卫国祇树给孤独园。时有一比丘尼。名婆罗。度他妊娠女人受具足戒已。后便生男儿。自抱入村乞食。时诸居士见已皆讥嫌言。此比丘尼。不知惭愧犯不净行。外自称言。我修正法。如是何有正法。看此出家人新生儿。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责婆罗比丘尼言。汝云何度他妊娠女人。往白诸比丘。诸比丘白佛。佛以此因缘集比丘僧。呵责婆罗比丘尼言。汝所为非。非威仪非沙门法。非净行非随顺行。所不应为。云何度他妊娠女人。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼度他妊娠女人授具足戒者波逸提。如是世尊与比丘尼结戒。时诸比丘尼。不知妊娠不妊娠。后乃知妊娠。其中或作波逸提忏或疑。不知者无犯。自今已去当如是说戒。若比丘尼。知女人妊娠。度与授具足戒者。波逸提。比丘尼义如上。彼比丘尼。若知女人妊娠。度授具足戒。作三羯磨竟和上尼波逸提。白二羯磨竟三突吉罗。白一羯磨竟二突吉罗。白已一突吉罗。白未竟突吉罗。未白前与剃头着衣与受戒。若集众众满。一切突吉罗。比丘突吉罗。是谓为犯。不犯者。若不知。若信彼人言。若信可信人语。或信父母语。与受具足戒后生儿不犯。若生已疑不敢捉抱。佛言若未能离母自活。听一切如母法乳哺长养。后有疑不敢与此男儿同室宿。佛言。若未能离母宿听共一处宿无犯。无犯者最初未制戒。痴狂心乱痛恼所缠(十九)

尔时佛在舍卫国祇树给孤独园。时有比丘尼。度他乳儿妇女。留儿在家。后家中送儿还之。此比丘尼抱儿入村乞食。时诸居士见已皆共讥嫌言。此比丘尼。不知惭愧犯不净行。外自称言我修正法。如是何有正法。看此出家人生儿抱行乞食。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责彼比丘尼言。汝云何乃度他乳儿妇女令诸居士讥嫌。往白诸比丘。诸比丘白佛。佛以此因缘集比丘僧。呵责彼比丘尼言。汝所为非。非威仪非沙门法。非净行非随顺行。所不应为。云何度他乳儿妇女。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼度他乳儿妇女受具足戒波逸提。如是世尊与比丘尼结戒。时诸比丘尼。不知产乳不产乳。后乃知产乳。不知者无犯。自今已去当如是说戒。若比丘尼。知妇女乳儿。与授具足戒波逸提。比丘尼义如上。彼比丘尼。知他妇女有乳儿。度授具足戒。作三羯磨竟和上尼波逸提。白二羯磨竟三突吉罗。白一羯磨竟二突吉罗。白竟一突吉罗。白未竟突吉罗。未白前与剃发与出家与着衣与授戒若集众众满。一切突吉罗。比丘突吉罗。是谓为犯。不犯者。若不知。信彼人言。信可信人言。或信父母语。而度与授具足戒已。后送儿来不犯。其母疑。不敢抱养。佛言。若未能自活。听如母法乳养至断乳止。后母与此儿同处宿有疑。佛言。自今已去听未断乳者无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(二十)

尔时佛在舍卫国祇树给孤独园。时诸比丘尼闻佛。制戒得度人。辄度小年童女。不知有欲心无欲心。后便与染污心男子共立共语调戏。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责诸比丘尼言。世尊制戒听度人。汝等云何乃度小年童女。与染污心人共立共语调戏耶。即白诸比丘。诸比丘往白佛。佛以此因缘集比丘僧。呵责诸比丘尼言。汝所为非。非威仪非沙门法。非净行非随顺行。所不应为。云何乃度小年童女。不知有染污心无染污心。后与染污心人共立共语调戏耶。以无数方便呵责比丘尼已。告诸比丘尼言。汝等谛听。若欲在寺内剃发者。当语一切尼僧令知。若作白已然后与剃发。当作如是白。大姊僧听。此某甲欲从某甲求剃发。若僧时到僧忍听。为某甲剃发。白如是。作如是白已。然后与剃发。若欲在寺内与出家者。当语一切尼僧。若作白已与出家。当作如是白。大姊僧听。此某甲从某甲求出家。若僧时到僧忍听。与某甲出家。白如是。作如是白已。然后与出家。当作如是出家。与剃发着袈裟已。教右膝着地合掌作如是语。我某甲归依佛归依法归依僧。我于如来法中求出家。和上尼某甲。如来至真等正觉是我世尊。如是第二第三说。我某甲归依佛竟归依法竟归依僧竟。我于如来法中求出家。和上尼某甲。如来至真等正觉是我世尊。如是第二第三说已。次应与授戒。尽形寿不杀生。是沙弥尼戒。汝能持不。能持者答言能。尽形寿不盗是沙弥尼戒。汝能持不。能持者答言能。尽形寿不淫是沙弥尼戒。汝能持不。能者答言能。尽形寿不妄语。是沙弥尼戒汝能持不。能者答言能。尽形寿不饮酒是沙弥尼戒。汝能持不。能者答言能。尽形寿不着华香璎珞是沙弥尼戒。汝能持不。能者答言能。尽形寿不歌舞伎乐不得往看。是沙弥尼戒。汝能持不。能者答言能。尽形寿不得高广大床上坐。是沙弥尼戒。汝能持不。能者答言能。尽形寿不非时食是沙弥尼戒。汝能持不。能者答言能。尽形寿不得捉金银钱是沙弥尼戒。汝能持不。能者答言能。是为沙弥尼十戒。尽形寿能持不。能者答言能。自今已去听年十八童女二岁学戒。年满二十得受具足戒。白四羯磨当如是说戒。沙弥尼当诣僧中偏露右肩脱革屣礼比丘尼僧足。右膝着地合掌当作是语。大姊僧听。我某甲沙弥尼。今从僧乞二岁学戒。某甲尼为和上愿僧与我二岁学戒慈愍故。第二第三如是说已。沙弥尼应往离闻处着见处已。比丘尼众中。当差堪能羯磨者。如上应作白。大姊僧听。彼某甲沙弥尼。今从僧乞二岁学戒。和上尼某甲。若僧时到僧忍听。与某甲沙弥尼二岁学戒。和上尼某甲。白如是。大姊僧听。彼某甲沙弥尼。从僧乞二岁学戒。和上尼某甲。今僧与某甲沙弥尼二岁学戒。和上尼某甲。谁诸大姊忍。僧与彼某甲沙弥尼二岁学戒。和上尼某甲者默然。不忍者说。是初羯磨。如是第二第三说。众僧已忍。与某甲沙弥尼二岁学戒。和上尼某甲竟。僧忍默然故。是事如是持。彼式叉摩那一切戒应学。除自手取食授食与他。彼二岁学戒已。年满二十当与授具足戒白四羯磨。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。年满十八童女二岁学戒已。满二十与授具足戒。若比丘尼年减二十受具足戒者。波逸提。如是世尊与比丘尼结戒。时诸比丘尼。不知满二十不满二十。后方知不满二十或作波逸提。忏或有疑者。不知者不犯。自今已去当如是结戒。若比丘尼。知年不满二十。与授具足戒波逸提。比丘尼义如上彼比丘尼知年不满二十授具足戒。三羯磨竟和上尼波逸提。白二羯磨竟三突吉罗。白一羯磨二突吉罗。白已一突吉罗。白未竟一突吉罗。若未白前集众众满。一切突吉罗。比丘突吉罗。是谓为犯。不犯者。年满十八二岁学戒满二十受具足戒。若不知。若自言满二十。若信可信人语。若信父母语。若受戒后疑。当数胎中月。当数闰月。数十四日说戒日无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(二十一)

尔时婆伽婆。在舍卫国祇树给孤独园。时诸比丘尼。闻世尊制戒年十八二岁学戒满二十受具足戒。彼非是十八不二岁学戒。年满二十与授具足戒。阙二岁学戒彼受具足戒已。不知当学何戒。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责诸比丘尼言。世尊制戒年十八二岁学戒满二十与授具足戒。汝云何。非是年十八不二岁学戒。年二十便与授具足戒。阙二岁学戒而不知当学何戒耶。时诸比丘尼往白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责诸比丘尼言。汝所为非。非威仪非沙门法。非净行非随顺行。所不应为。世尊制戒年十八与二岁学戒满二十受具足戒。汝云何。非是年十八不二岁学戒。满二十受具足戒。阙二岁学戒。受具足戒已。不知当学何戒耶。尔时世尊以无数方便。呵责诸比丘尼已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。年十八童女不与二岁学戒。年满二十便与授具足戒者。波逸提。比丘尼义如上。彼比丘尼。若年十八童女不二岁学戒。便与授具足戒。唱三羯磨竟。和上尼波逸提。白二羯磨竟三突吉罗。白一羯磨二突吉罗。白已一突吉罗。白未竟突吉罗。未白前集众及众满者。一切突吉罗。比丘突吉罗。是谓为犯。不犯者。年十八童女二岁学戒满二十与授具足戒无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(二十二)

尔时婆伽婆。在舍卫国祇树给孤独园。时诸比丘尼闻世尊制戒年十八童女与二岁学戒与六法满二十与授具足戒。彼不与六法。便与授具足戒。彼学戒时。作不净行。盗取五钱。断人命。自称得上人法。过中食饮酒。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责诸比丘尼言。世尊制戒年十八童女与二岁学戒与六法满二十与授具足戒。汝云何。不教六法事授具足戒。犯梵行盗五钱乃至饮酒。即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责彼比丘尼言。汝所为非。非威仪非沙门法。非净行非随顺行。所不应为。汝等比丘尼。应年十八童女与二岁学戒与六法满二十与授具足戒。而云何不与六法。令犯淫乃至饮酒耶。以无数方便呵责已告诸比丘。此比丘尼。多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。年十八童女。与二岁学戒不与六法。满二十便与授具足戒波逸提。比丘尼义如上。若式叉摩那犯淫应灭摈。若有染污心。与染污心男子身相触缺戒。应更与戒。若偷五钱过五钱。应灭摈。若减五钱缺戒应更与戒。若断人命。应灭摈。若断畜生命缺戒应更与戒。若自言得上人法者。应灭摈。若在众中故妄语者缺戒。应更与戒。若非时食缺戒。应更与戒。若饮酒缺戒。应更与戒。若比丘尼。年十八童女。与二岁学戒不与六法。满二十便与授具足戒。唱三羯磨竟。尼和上波逸提。白二羯磨竟三突吉罗。白一羯磨二突吉罗。白已一突吉罗。白未竟一突吉罗。未白前集众及众满。一切突吉罗。比丘突吉罗。是谓为犯。不犯者。年十八童女二岁学戒与六法已受具足戒不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(二十三)

尔时婆伽婆。在舍卫国祇树给孤独园。诸比丘尼闻世尊制戒。年满十八童女。二岁学戒与六法。满二十与授具足戒。时诸比丘尼。便度盲瞎癃躄跛聋喑哑及余种种病者。毁辱众僧。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责诸比丘尼言。世尊制戒。年十八童女。与二岁学戒与六法。满二十与授具足戒。汝云何。乃度盲瞎及诸病者。毁辱众僧。时比丘尼往白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责诸比丘尼言。汝所为非。非威仪非沙门法。非净行非随顺行。所不应为。比丘尼。应十八童女与二岁学戒满二十与授具足戒。汝云何。乃度盲瞎及诸病人耶。以无数方便呵责已告诸比丘。自今已去。当与比丘尼竖立具足戒白四羯磨。当作如是与。安受戒人离闻处着见处已。是中戒师。应作白差教授师。当作如是白。大姊僧听。彼某甲从和上尼某甲求受具足戒。若僧时到僧忍听某甲为教授师。白如是。彼人当往受戒人所语言。妹此是安陀会。此是郁多罗僧。此是僧伽梨。此是僧祇支。此是覆肩衣。此是钵此衣钵。是汝有不。妹听。今是真诚时实语时。我今问汝。实当言实不实当言不实。汝字何等。和上字谁。年满二十未。衣钵具足不。父母听汝不。夫主听汝不。汝不负债不。汝非婢不。汝是女人不。女人有如是诸病。癞痈疽白癞干痟瘨狂二形二道合道小常漏大小便[口*弟]唾常流出。汝有如此病不若言无。当复语言。如我向问汝事。在众中亦当如是问。如汝向者答我。众僧中亦当如是答。时教授师。问已如常威仪还来入众中。舒手相及处立。作如是白。大姊僧听。彼某甲从某甲求受具足戒。若僧时到僧忍听。我已教授竟。听使来白如是。彼即应语言。汝来。来已。教授师应为捉衣钵教礼尼僧足已。在戒师前。右膝着地合掌。教授师教作如是白。大姊僧听。我某甲从和上尼某甲求受具足戒。我某甲今从众僧乞受具足戒。某甲尼为和上。众僧慈愍故拔济我。如是第二第三说。戒师应作白。大姊僧听。此某甲从和上尼某甲求受具足戒。此某甲今从众僧乞受具足戒。某甲尼为和上。若僧时到僧忍听。我问诸难事。白如是。彼当语言。妹谛听。今是真诚时。我今问汝。实当言实不实当言不实。汝字何等。和上字谁。年满二十不。衣钵具足不。父母听汝不。夫主听汝不。汝不负债耶。汝非婢耶。汝是女人不。女人有如是诸病。癞痈疽白癞干痟瘨狂二形二道合道小常漏大小便[口*弟]唾常流出。汝有如是病不。若言无。当作白。大姊僧听。此某甲从和上尼某甲求受具足戒。此某甲今从众僧乞受具足戒。某甲尼为和上。某甲自说。清净无诸难事。年满二十衣钵具足。若僧时到僧忍听。授某甲具足戒。某甲尼为和上。白如是。大姊僧听。此某甲从和上尼某甲求受具足戒。此某甲今从众僧乞受具足戒。某甲尼为和上。某甲自说。清净无诸难事。年满二十衣钵具足。今僧授某甲具足戒。某甲尼为和上。谁诸大姊忍。僧授某甲具足戒。某甲尼为和上者默然。若不忍者说。此是初羯磨。第二第三亦如是说。众僧已忍。授某甲具足戒。某甲尼为和上竟。僧忍默然故。是事如是持

四分律卷第二十七四分律卷第二十八(二分之七明尼戒法)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    一百七十八单提法之五

时诸比丘尼僧。应将受戒者。至比丘僧中。偏露右肩礼僧足已。右膝着地合掌。作如是语。大德僧听。我某甲。从和上尼某甲求受具足戒。我某甲。今从众僧乞受具足戒。某甲尼为和上。愿众僧慈愍故拔济我。第二第三亦如是说。彼当问。汝字何等。和上字谁。乃至[口*弟]唾常流出如上。汝已学戒清净不。若言学戒清净。当复更问余比丘尼。此人学戒清净不。若言学戒清净者。彼戒师当作白。大德僧听。此某甲。从和上尼某甲求受具足戒。此某甲。今从众僧乞受具足戒。和上尼某甲。某甲已学戒清净。若僧时到僧忍听。僧今授某甲具足戒。某甲尼为和上。白如是。大德僧听。此某甲。从和上尼某甲求受具足戒。此某甲。今从众僧乞受具足戒。某甲尼为和上。某甲已学戒清净。今僧授某甲具足戒。某甲尼为和上。谁诸长老忍。僧授某甲具足戒。某甲尼为和上者默然。谁不忍者说。此初羯磨。第二第三亦如是说。众僧已忍。与某甲授具足戒某甲尼为和上竟。僧忍默然故。是事如是持。族姓女听。此是如来无所著等正觉说八波罗夷法。犯者非比丘尼非释种女。不得作不净行行淫欲法。若比丘尼。意乐作不净行行淫欲法。乃至共畜生。此非比丘尼非释种女。汝是中尽形寿不得犯。能持不。能者当言能。不得盗乃至草叶。若比丘尼。偷人五钱若过五钱。若自取教人取。若自断教人断。若自破教人破若烧若埋若坏色。彼非比丘尼非释种女。汝是中尽形寿不得犯。能持不。能者当言能。不得故断众生命乃至蚁子。若比丘尼。故自手断人命。若持刀与人。教死赞死劝死。若与非药。若堕人胎[示*厭]祷咒诅杀。若自作若教人作。彼非比丘尼非释种女。汝是中尽形寿不得犯。能持不。能者当言能。不得妄语乃至戏笑。若比丘尼。不真实非己有。自称言我得上人法。我得禅得解脱。得三昧正受。得须陀洹果斯陀含果阿那含果阿罗汉果。天来龙来鬼神来供养我。此非比丘尼非释种女。汝是中尽形寿不得作。能持不。能者当言能不得身相触乃至共畜生。若比丘尼。有染污心。与染污心男子身相触。从腋已下膝已上身相触。若捉若摩若牵若推逆摩顺摩若举若下若捉若捺。非比丘尼非释种女。汝是中尽形寿不得犯。能持不。能者当言能。不得犯八事。乃至共畜生。若比丘尼染污心。受染污心男子捉手。捉衣。入屏处。屏处共立。共语。共行。身相近。共期。犯此八事。彼非比丘尼非释种女。犯八事故。汝是中尽形寿不得犯。能持不。能者当言能。不得覆藏他罪。乃至突吉罗恶说。若比丘尼。知他比丘尼犯波罗夷罪。若不自举不白僧若众多人。后于异时。此比丘尼。若罢道若灭摈。若遮不共僧事。若入外道。后便作是说。我先知有如是如是事。彼非比丘尼非释种女。覆重罪故。汝是中尽形寿不得作。能持不。能者当言能。不得随顺被举比丘语。乃至守园人及沙弥。若比丘尼。知比丘为僧所举。如法如律如佛所教。不随顺不忏悔。僧未与作共住。而随顺。是比丘尼谏彼比丘尼言。汝妹知不。今僧举此比丘如法如律如佛所教不随顺不忏悔。僧未与作共住。汝莫随顺。是比丘尼谏彼比丘尼时坚持不舍。是比丘尼当三谏。舍此事故。乃至三谏舍者善。不舍者彼非比丘尼非释种女。由随举故。汝是中尽形寿不得犯。能持不。能者当言能。族姓女听。如来无所著等正觉说四依法。比丘尼。依此得出家受具足戒成比丘尼。依粪扫衣得出家受具足戒成比丘尼法。汝是中尽形寿能持不。能者当言能。若得长利檀越施衣割坏衣得受。依乞食得出家受具足戒成比丘尼法。汝是中尽形寿能持不。能者当言能。若得长利。若僧差食。檀越送食。月八日食。十四十五日食。若月初日食。若众僧常食。若檀越请食应受。依树下坐得出家受具足戒成比丘尼法。汝是中尽形寿能持不。能者当言能。若得长利别房尖头屋小房石室两房一户应受。依腐烂药得出家受具足戒成比丘尼法。汝是中尽形寿能持不。能者当言能。若得长利酥油生酥蜜石蜜应受。汝已受具足戒白四羯磨如法成就得处所。和上如法阿阇梨如法二部僧如法具足满。汝当善受教法。应劝化作福治塔供养众僧。若和上阿阇梨一切如法教授不得违逆。应学问诵经勤求方便。于佛法中得须陀洹果斯陀含果阿那含果阿罗汉果。汝始发心出家功不唐捐。果报不绝。余所未知。当问和上阿阇梨。令受戒人在前余尼在后而去。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。年十八童女与二岁学戒与六法满二十。众僧不听便与授具足戒。者波逸提。比丘尼义如上。僧者如上。若比丘尼。年满二十二岁学戒与六法。众僧不听。与授具足戒。三羯磨竟和上尼波逸提。白二羯磨三突吉罗。白一羯磨二突吉罗。白已一突吉罗。白未竟突吉罗。未白前集众众满。一切突吉罗。比丘突吉罗。是谓为犯。不犯者。年满二十二岁学戒众僧听受具足戒不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(二十四)

尔时婆伽婆。在舍卫国祇树给孤独园。时世尊制戒听比丘尼授人具足戒。而度他少年妇女与授具足戒。授具足戒已不知男子有染污心无染污心与染污心男子共立共语共相调戏。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责诸比丘尼。汝云何世尊制戒听比丘尼度人授具足戒。乃度他少年曾嫁妇女授具足戒。受具足戒已不知男子有染污心无染污心。与染污心男子共立共语共相调戏。往白诸比丘。诸比丘往白世尊。世尊以此因缘。集比丘僧呵责诸比丘尼言。汝所为非。非威仪非沙门法。非净行非随顺行。所不应为。云何度他少年曾嫁妇女与授具足戒。受具足戒已。不知男子有染污心无染污心。与有染污心男子共立共语共相调戏。以无数方便呵责已告诸比丘。自今已去若欲度人授具足戒者。先白众僧剃发乃至与十戒如上法。自今已去听度十岁曾嫁女人与二岁学戒年满十二与授具足戒。白四羯磨如上。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说若比丘尼。度曾嫁妇女年十岁。与二岁学戒。年满十二。听与授具足戒。若减十二与授具足戒者波逸提。比丘尼义如上。彼比丘尼。知减十二与授具足戒。三羯磨竟和上尼波逸提。白二羯磨竟三突吉罗。白一羯磨竟二突吉罗。白已一突吉罗。白未竟突吉罗。未白前集众众满。一切突吉罗。比丘突吉罗。是谓为犯。不犯者。年十岁度与二岁学戒满十二与授具足戒不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(二十五)

尔时婆伽婆。在舍卫国祇树给孤独园。诸比丘尼。闻世尊制戒得度十岁曾嫁女人与二岁学戒满十二与授具足戒。便度他盲瞎跛躄聋及余种种病者。毁辱众僧。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责诸比丘尼言。世尊制戒度年十岁曾嫁妇女与二岁学戒满十二与授具足戒。汝云何乃度他盲瞎聋及余种种病。毁辱众僧。时诸比丘尼往白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责诸比丘尼言。汝所为非。非威仪非沙门法。非净行非随顺行所不应为。云何世尊制戒听比丘尼度年十岁曾嫁妇女与二岁学戒满十二与授具足戒。而汝等乃度他盲瞎跛躄聋及余种种病。毁辱众僧。以无数方便呵责已告诸比丘。自今已去听与授具足戒白四羯磨。当作如是与。将受戒者至离闻处着见处。乃至我已教授竟。听使来亦如上。来已至尼僧中。戒师应作白。问难事乃至白四羯磨如上。乃至大僧中与授戒。一一法如上十八童女法同。自今已去当与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。度他小年曾嫁妇女与二岁学戒年满十二。不白众僧便与授具足戒波逸提。比丘尼义如上。彼比丘尼。度小年曾嫁妇女与二岁学戒年满十二。不白众僧便与授具足戒。三羯磨竟尼和上波逸提。白二羯磨三突吉罗。白一羯磨二突吉罗。白已一突吉罗白未竟突吉罗。未白前集众众满。一切突吉罗。比丘突吉罗。是谓为犯。不犯者。度年满十二曾嫁妇女白众僧受具足戒不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(二十六)

尔时婆伽婆。在舍卫国祇树给孤独园。时诸比丘尼。度他淫女与授具足戒。先与此女人亲厚者。见已自相谓言。此淫女先与我等作如是如是事。时所度比丘尼及余比丘尼闻之皆惭耻。尔时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责诸比丘尼言。云何汝等。乃度他淫女与授具足戒耶。即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责诸比丘尼言。汝所为非。非威仪非沙门法。非净行非随顺行。所不应为。汝等云何度他淫女与授具足戒耶。时世尊以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼与如是人授具足戒者波逸提。如是世尊与比丘尼结戒。诸比丘尼。不知如是人非如是人。后乃知是。或有作波逸提忏者或疑者。不知者无犯。自今已去当如是结戒。若比丘尼。知如是人与授具足戒者波逸提。比丘尼义如上。如是人者淫女也。彼或有夫主。或有夫主兄弟。乃至有故私通者。若比丘尼。与如是人授具足戒者。应将至五六由旬。若不去。当深藏安处之。彼比丘尼。度如是人授具足戒已。不将去五六由旬。若不深藏者波逸提。比丘突吉罗。是谓为犯。不犯者。先不知如是人便与授具足戒。若将至五六由旬若教人将至五六由旬。若深藏不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(二十七)

尔时佛在舍卫国祇树给孤独园。尔时安隐比丘尼。多度弟子而不教诫。以不被教授故。不按威仪。着衣不齐整。乞食不如法。处处受不净食。或受不净钵食。在小食大食上高声大唤。如婆罗门聚会法。时诸比丘尼见已语言。妹汝等云何。不按威仪。着衣不齐整。乞食不如法。处处受不净食。或受不净钵食。在小食大食上高声大唤。如婆罗门聚会法。诸比丘尼报言。我是安隐比丘尼弟子。彼弟子众多。而不教授我等。以不被教授故耳。尔时比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责安隐比丘尼言。汝云何。多度弟子而不教授。以不教授故。众事不如法也。呵责已往白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责安隐比丘尼言。汝所为非。非威仪非沙门法。非净行非随顺行。所不应为。云何多度弟子不教授。不按威仪。着衣不齐整。乞食不如法。处处受不净食。或受不净钵食。在小食大食上高声大唤。如婆罗门聚会法。以无数方便呵责已。告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。多度弟子。不教二岁学戒。不以二法摄取波逸提。比丘尼义如上。二法者。一者法二者衣食。法摄取者。教增戒增心增慧学问诵经。衣食摄者。与衣食床卧具医药随力能办供给所须。若比丘尼。多度弟子与授具足戒。不教二岁学戒二法摄取波逸提。比丘突吉罗。是谓为犯。不犯者。若度与二岁学戒。以二事摄取。一者法二者衣食。若受具足戒已离和上去。若破戒破见破威仪。若被举若灭摈若应灭摈。以此事命难梵行难无犯。无犯者最初未制戒。痴狂心乱痛恼所缠(二十八)

尔时婆伽婆。在舍卫国祇树给孤独园。时诸比丘尼多度弟子。后皆离和上去。不被教授。不按威仪。着衣不齐整。乞食不如法。处处受不净食。或受不净钵食。在小食大食上高声大唤。如婆罗门聚会法。时诸比丘尼见已问言。诸姊。汝等何故不按威仪。着衣不齐整。乞食不如法。处处受不净食。或受不净钵食。在小食大食上高声大唤。如婆罗门聚会法。诸比丘尼报言。我等受具足已离和上去。不被教授故耳。尔时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责诸比丘尼言。汝等云何。受具足已离和上去。不被教授。不按威仪。着衣服不齐整。乞食不如法。处处受不净食。或受不净钵食。在小食大食上高声大唤。如婆罗门聚会法。时诸比丘尼呵责已。往白诸比丘。诸比丘白佛。佛以此因缘集比丘僧。呵责诸比丘尼。汝所为非。非威仪非沙门法。非净行非随顺行。所不应为。云何受具足戒已离和上去。不被教授。不按威仪。乞食不如法。处处受不净食。或受不净钵食。在小食大食上高声大唤。如婆罗门聚会法。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。不二岁随和上尼者波逸提。比丘尼义如上。彼比丘尼。不二岁随和上尼者波逸提。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。受具足戒已二岁随尼和上。若和上听去得去。若和上破戒破见破威仪。若被举若灭摈若应灭摈。若由是事命难梵行难。于二岁中离去无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(二十九)

尔时佛在舍卫国祇树给孤独园。时世尊制戒。听度人授具足戒。而诸比丘尼痴者。度人不知教授。以不教授故不按威仪。着衣不齐整。乞食不如法。处处受不净食。或受不净钵食。在小食大食上高声大唤。如婆罗门聚会法。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责诸比丘尼言。汝等云何。世尊制戒听度人。而汝等愚痴。辄便度人而不知教授。以不教授故不按威仪。乃至在小食大食上高声大唤。如婆罗门聚会法。即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责诸比丘尼言。汝所为非。非威仪非沙门法。非净行非随顺行。所不应为。云何世尊制戒虽听度人。汝等愚痴。辄便度人而不知教授。以不教授故不按威仪。乞食不如法。处处受不净食。或受不净钵食。在小食大食上高声大唤。如婆罗门聚会法耶。世尊以无数方便呵责已告诸比丘。自今已去听僧与授具足戒者。白二羯磨。彼欲度人者。当往众僧中求。当作如是求。至比丘尼众中。偏露右肩脱革屣。礼诸比丘尼足。右膝着地合掌。作如是白。大姊僧听我某甲比丘尼。求众僧乞度人授具足戒。如是第二第三说。比丘尼僧当观察此人。堪能教授与二岁学戒二事摄取不。一者法二者衣食。如是听。若不堪教授。不能与二岁学戒及二法摄取法及衣食者。当语言。妹止。勿度人。若有智慧。堪能教授。与二岁学戒。以二法摄取者。众中当差堪能羯磨者。如上作如是白。大姊僧听。此某甲比丘尼。今从众僧乞授人具足戒。若僧时到僧忍听。与某甲授人具足戒。白如是。大姊僧听。此某甲比丘尼。今从众僧乞授人具足戒。僧今与某甲比丘尼授人具足戒。谁诸大姊忍。僧与某甲授人具足戒者默然。谁不忍者说。众僧已忍。听与某甲比丘尼授人具足戒竟。僧忍默然故是事如是持。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。僧不听而授人具足戒者波逸提。比丘尼义如上。僧者如上。听者众僧白二羯磨听。彼比丘尼。若僧不听授人具足戒者波逸提。众僧不听。便与依止。若畜沙弥尼式叉摩那者突吉罗。比丘突吉罗。是谓为犯。不犯者。众僧听。授人具足戒。受比丘尼依止。及畜沙弥尼式叉摩那。是谓不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(三十竟)

尔时世尊在舍卫国祇树给孤独园。时诸比丘尼。闻世尊制戒听比丘尼从众僧乞授人具足戒。彼新学少年从众僧乞授人具足戒已。不能教授。以不被教授故不按威仪。着衣不齐整。乞食不如法。处处受不净食。或受不净钵食。在小食大食上高声大唤。如婆罗门聚会法。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者嫌责诸比丘尼。汝等闻世尊制戒听度人。云何新学少年乞授人具足戒已不能教授。彼以不被教授故不按威仪。着衣不齐整。乃至小食大食上高声大唤。如婆罗门聚会法。时诸比丘尼嫌责已。往语诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责此诸比丘尼。汝所为非。非威仪非沙门法。非净行非随顺行。所不应为。云何汝等。新学少年乞授人具足戒。而不能教授。彼以不被教授故不按威仪。着衣不齐整。乞食不如法。乃至高声大唤。如婆罗门聚会法。时世尊以无数方便。呵责此诸比丘尼已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。年未满十二岁。授人具足戒者波逸提。比丘尼义如上。若比丘尼。年减十二授人具足戒者波逸提。若减十二。与人依止。畜式叉摩那沙弥尼。一切突吉罗。比丘突吉罗。是谓为犯。不犯者。年满十二授人具足戒。若与依止。畜式叉摩那沙弥尼不犯不犯者。最初未制戒。痴狂心乱痛恼所缠(三十一)

尔时世尊在舍卫国祇树给孤独园。时诸比丘尼。闻世尊制戒听年十二岁得授人具足戒。皆自称言。年满十二岁。愚痴。辄授人具足戒。不知教授。以不被教授故不按威仪。着衣不齐整乞食不如法。处处受不净食。或受不净钵食。在小食大食上高声大唤。如婆罗门聚会法。诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责此诸比丘尼。汝等闻世尊制戒年十二岁得授人具足戒。而汝云何自称年满十二。求授人具足戒。痴不知教授。彼以不被教授故不按威仪。着衣不齐整。乞食不如法。乃至如婆罗门聚会法。时诸比丘尼往白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责此诸比丘尼。汝等所为非。非威仪非沙门法。非净行非随顺行。所不应为。汝等云何。自称言。满十二岁求授人具足戒。痴不知教授。彼以不被教授故不按威仪。着衣不齐整。乞食不如法。乃至如婆罗门聚会法。时世尊以无数方便呵责已告诸比丘。此诸比丘尼。多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。年满十二岁。众僧不听。便授人具足戒者波逸提。比丘尼义如上。彼比丘尼。年满十二岁众僧不听。授人具足戒者波逸提。众僧不听。授依止及畜式叉摩那沙弥尼。一切突吉罗。比丘突吉罗。是谓为犯。不犯者。年满十二。众僧听授人具足戒。及与人依止。畜式叉摩那沙弥尼不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(三十二)

尔时婆伽婆。在舍卫国祇树给孤独园。时诸比丘尼。愚痴不堪教授。从众僧求授人具足戒。诸比丘尼谏言。妹止。勿从众僧求授人具足戒。彼以从众僧求授人具足戒不得故。便言。诸比丘尼。有爱有恚有怖有痴。所爱者便听。不爱者便不听。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责诸比丘尼。汝等云何。愚痴从僧乞授人具足戒。诸比丘尼谏言。汝妹止。勿求众僧授人具足戒。云何便言。诸比丘尼。有爱有恚有怖有痴。爱者便听。不爱者便不听。即白诸比丘。诸比丘白世尊。世尊以此因缘集比丘僧。呵责诸比丘尼言。汝所为非。非威仪非沙门法。非净行非随顺行。所不应为。云何汝等。愚痴从僧乞授人具足戒。诸比丘尼谏言。汝妹止。勿求众僧乞授人具足戒。便言。诸比丘尼有爱有恚有怖有痴。所爱者便听。不爱者不听。世尊以无数方便呵责已。告诸比丘。此比丘尼。多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。僧不听。授人具足戒。便言。众僧有爱有恚有怖有痴。欲听者便听不欲听者便不听波逸提。比丘尼义如上。僧者如上。不听者。众僧语言。妹止。不须授人具足戒。彼以不得授人具足戒故便言。诸比丘尼。有爱有恚有怖有痴。所爱者便听。不爱者便不听。若说而了了者波逸提。不了了者突吉罗。比丘突吉罗。是谓为犯。不犯者。其事实尔。有爱有恚有怖有痴。爱者便听。不爱者不听。彼人便作是语。有爱有恚有怖有痴。爱者便听。不爱者不听。若戏笑语。疾疾语。屏处语。若梦中语。欲说此乃错说彼无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(三十三)

尔时婆伽婆。在舍卫国祇树给孤独园。时诸比丘尼。闻世尊制戒听度人授具足戒。而父母夫主不听。辄便度与授具足戒。与授具足戒已。父母夫主皆来将去。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责言。汝等云何。世尊制戒听度人。父母夫主不听而度。使父母夫主还将去耶。时诸比丘尼往白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责诸比丘尼言。汝所为非。非威仪非沙门法。非净行非随顺行。所不应为。云何汝等。世尊制戒听度人。父母夫主不听而辄度。后为父母夫主还将去。以无数方便呵责已告诸比丘。此诸比丘尼。多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。父母夫主不听与授具足戒者波逸提。比丘尼义如上。彼比丘尼。若父母夫主不听与授具足戒。三羯磨竟尼和上波逸提。白二羯磨三突吉罗。白一羯磨二突吉罗。白已一突吉罗。白未竟突吉罗。未白前方便白僧与剃发集众众满。一切突吉罗。比丘突吉罗。是谓为犯。不犯者。父母夫主听。若无父母夫主无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(三十四)

尔时婆伽婆。在舍卫国祇树给孤独园。诸比丘尼。闻世尊制戒得度人。时诸比丘尼。便度与童男男子相敬爱愁忧喜嗔恚女人受具足戒。受具足戒已。彼以念男子故。愁忧嗔恚与比丘尼共斗诤。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责诸比丘尼言。世尊制戒听度人。云何乃度与童男男子相敬爱愁忧喜嗔恚者与授具足戒。受具足戒已念彼男子故。愁忧嗔恚与比丘尼共斗诤。即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责诸比丘尼言。汝所为非。非威仪非沙门法。非净行非随顺行。所不应为。云何度他与童男男子相敬爱女人愁忧喜嗔恚者与授具足戒。受具足戒已。念彼男子故愁忧嗔恚。与比丘尼共斗诤耶。以无数方便呵责已告诸比丘。此诸比丘尼。多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。度他与童男男子相敬爱愁忧嗔恚女人受具足戒波逸提。如是世尊与比丘尼结戒。尔时诸比丘尼。不知与童男男子相敬爱不相敬爱愁忧嗔恚者不愁忧嗔恚者。后乃知与童男男子相敬爱。或有作波逸提忏者。或有疑者。不知者无犯。自今已去当如是说戒。若比丘尼。知女人与童男男子相敬爱愁忧嗔恚女人。度令出家受具足戒者波逸提。比丘尼义如上。童男男子相敬爱与私通愁忧嗔恚者与受具足戒已。念彼男子故。与比丘尼共斗诤。彼比丘尼。知女人与童男男子相敬爱愁忧嗔恚。与授具足戒。三羯磨竟和上尼波逸提。白二羯磨三突吉罗。白一羯磨二突吉罗。白已一突吉罗。白未竟突吉罗。未白前剃发与授戒集众众满一切突吉罗。比丘突吉罗。是谓为犯不犯者。若先不知。若信可信人语。若信父母语。若受具足戒已病生无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(三十五)

尔时婆伽婆。在舍卫国祇树给孤独园。时偷兰难陀比丘尼语式叉摩那言。汝学是舍是。我当授汝具足戒。彼报言尔。彼式叉摩那。聪明智慧堪能劝化。时偷兰难陀作是意。欲令式叉摩那久作劝化供养故。不与作方便料理时与受具足戒。时式叉摩那嫌责偷兰难陀。偷兰难陀语我言。汝舍是学是。我当授汝具足戒。而至今不为我作方便时授具足戒耶。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责偷兰难陀言。汝云何语式叉摩那言。汝舍是学是。我当授汝具足戒。而不与授具足戒耶。即往白诸比丘。诸比丘白世尊。世尊以此因缘集比丘僧。呵责偷兰难陀。汝云何语式叉摩那言。汝舍是学是。我当授汝具足戒。云何不与授具足戒耶。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼语式叉摩那言。汝妹。舍是学是。我当与汝授具足戒。若不方便与授具足戒波逸提。比丘尼义如上。彼比丘尼语式叉摩那言。汝妹舍是学是。我当与汝授具足戒。后不方便与授具足戒者波逸提。比丘突吉罗。是谓为犯。不犯者。若许与授具足戒。便与授具足戒。若彼病若更无共活者。若无五衣若无十众。若缺戒若破戒若破见破威仪。若被举若灭摈若应灭摈。由是命难梵行难不与作方便授具足戒无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(三十六)

尔时婆伽婆。在舍卫国祇树给孤独园。时有式叉摩那。持衣往僧伽蓝中。至诸比丘尼所语言。与我受具足戒。我当持此衣与。时偷兰难陀比丘尼语言。妹与我衣。我当授汝具足戒。即持衣与之。偷兰难陀受他衣已。亦不方便与授具足戒。时式叉摩那嫌责言。云何语我言。大妹。与我衣来。我当授汝具足戒。而受我衣已。不与我授具足戒耶。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责偷罗难陀言。云何要语式叉摩那言。妹与我衣来。当与汝授具足戒。而受他衣已。竟不与授具足戒耶。呵责已白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责偷兰难陀言。汝所为非。非威仪非沙门法。非净行非随顺行。所不应为。云何语式叉摩那言。妹与我衣来。当与汝授具足戒。而受衣已。竟不与他授具足戒耶。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼语式叉摩那言。持衣来。我当与汝授具足戒。而不方便与授具足戒波逸提。比丘尼义如上。衣者有十种如上。彼比丘尼语式叉摩那言。妹持衣来。我当与汝授具足戒。受衣已。不作方便与授具足戒者波逸提。比丘突吉罗。是谓为犯。不犯者。许与授具足戒。便与授具足戒。若病若无共活者。若无五衣若无十众。若彼缺戒若破戒破见破威仪。若被举若灭摈若应灭摈。若命难梵行难。而不方便与授具足戒无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(三十七)

尔时婆伽婆。在舍卫国祇树给孤独园。时安隐比丘尼。多度弟子。与授具足戒。不能一一教授。彼以不被教授故。不按威仪。着衣不齐整。乞食不如法。处处受不净食。或受不净钵食。在小食大食上高声大唤。如婆罗门聚会法。时诸比丘尼见已问言。汝等何以不按威仪。着衣不齐整。乞食不如法。处处受不净食。受不净钵食。在小食大食上高声大唤。如婆罗门聚会法。彼即报言。我是安隐比丘尼弟子。师不教授我故耳。尔时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责安隐比丘尼言。汝云何多度弟子。不能一一教授。彼以不被教授故。不按威仪。着衣不齐整。乞食不如法。处处受不净食。受他不净钵食。在小食大食上高声大唤。如婆罗门聚会法。诸比丘尼往白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责安隐比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何多度弟子。不能一一教授。彼以不被教授故。不按威仪。着衣不齐整。乞食不如法。处处受不净食。或受他不净钵食。在小食大食上高声大唤。如婆罗门聚会法。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。不满一岁授人具足戒者波逸提。比丘尼义如上。若比丘尼。满十二月得授人具足戒。满十二月得与人依止。满十二月得授式叉摩那二岁学戒。满十二月得度沙弥尼。彼比丘尼。不满一岁授人具足戒者波逸提。不满一岁。与人依止。度式叉摩那沙弥尼突吉罗。比丘突吉罗。是谓为犯。不犯者。满十二月授人具足戒。满十二月与人依止。授式叉摩那二岁学戒。度沙弥尼无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(三十八)

尔时婆伽婆。在舍卫国祇树给孤独园。时诸比丘尼。闻世尊制戒听授人具足戒。彼便在尼众中与授具足戒。经宿已方往比丘僧中。而所与授具足戒者。中间或得盲瞎痴聋跛躄及余种种诸病。毁辱众僧。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责诸比丘尼言。世尊制戒听度人。汝等云何。乃度盲瞎痴聋跛躄及余种种病毁辱众僧耶。呵责已白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责诸比丘尼言。汝所为非。非威仪非沙门法。非净行非随顺行。所不应为。云何乃度诸盲瞎痴聋跛躄及余种种病毁辱众僧耶。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。与人授具足戒已经宿。方往比丘僧中。与授具足戒者波逸提。比丘尼义如上。比丘尼。应即日授具足戒。即日诣比丘僧中授具足戒。彼比丘尼。与授具足戒经宿已。方诣比丘僧中授具足戒波逸提。是谓为犯。不犯者。即日与授具足戒。即日往比丘僧中授具足戒。若欲往授具足戒。彼病。若水陆道断。若有恶兽难。若贼难。若水大涨。若为强力者所执。若被系闭。若命难梵行难。不得即日往诣比丘众中无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(三十九)

四分律卷第二十八四分律卷第二十九(二分之八明尼戒法)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    一百七十八单提法之六

尔时婆伽婆。在舍卫国祇树给孤独园。时诸比丘尼。教授日不往受教授。时诸比丘尼闻。中有少欲知足行头陀乐学戒知惭愧者呵责诸比丘尼言。汝等教授日。云何不往受教授。即往白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责诸比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等。教授日不来入众中受教授耶。以无数方便呵责已。告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼教授日不往受教授者波逸提。如是世尊与比丘尼结戒。时诸比丘尼有佛事法事僧事或瞻病事。佛言。听嘱授。自今已去当如是结戒。若比丘尼。不病不往受教授者波逸提。比丘尼义如上。彼比丘尼。不往受教授除余事波逸提。比丘突吉罗。是谓为犯。不犯者。教授时往受教授。佛法僧事及瞻视病人嘱授无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(四十)

尔时婆伽婆。在舍卫国祇树给孤独园。时诸比丘尼。闻世尊制戒听诸比丘尼僧半月从比丘僧求教授。而彼比丘尼不往求教授。时诸比丘尼闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责诸比丘尼言。汝等闻世尊制戒听比丘尼僧半月从比丘僧求教授。而汝等云何不往求教授耶。即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责诸比丘尼言。汝等所为非。非威仪非沙门法。非净行非随顺行所不应为。云何汝等不往比丘僧中求教授耶。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。半月应往比丘僧中求教授。若不求者波逸提。比丘尼义如上。世尊有如是教。比丘尼半月应往比丘僧中求教授。而彼一切尽往求。以是故众便闹乱佛言。不应一切往。听差一比丘尼。为比丘尼僧故。半月往比丘僧中求教授。白二羯磨应如是差。众中当差堪能羯磨者。如上作如是白。大姊僧听。若僧时到僧忍听。差某甲比丘尼。为比丘尼僧故。半月往比丘僧中求教授。白如是。大姊僧听。今僧差某甲比丘尼为比丘尼僧故。半月往比丘僧中求教授。谁诸大姊忍。僧差某甲比丘尼。为比丘尼僧故。半月往比丘僧中求教授者默然。谁不忍者说。僧已忍。差某甲比丘尼。为比丘尼僧故。半月往比丘僧中求教授竟。僧忍默然故。是事如是持。彼独行无护。听为护故应差二三比丘尼共行。彼当往大僧中礼僧足已曲身低头合掌作如是说。比丘尼僧和合。礼比丘僧足求教授。如是第二第三说。时彼比丘尼。待僧说戒竟经久住立疲极佛言。不应尔。听嘱一大比丘便去。世尊既听嘱授。彼便嘱授客比丘。佛言。不应尔。彼便嘱授远行者。佛言。不应尔。彼嘱授病者。佛言。不应尔。彼嘱授无智慧者。佛言。不应尔。彼既嘱授已。明日不往问。佛言。应往问可不。比丘应期往。比丘尼应期来迎。比丘期往而不往者突吉罗。比丘尼期迎。而不迎者突吉罗。若比丘尼。闻教授人来。当半由旬迎。在寺内供给所须洗浴具。若羹粥饭食果蓏。以此供养。若不者突吉罗。若比丘僧尽病应遣信往礼拜问讯。若别众若众不和合若众不满。当遣信往礼拜问讯。若比丘尼僧尽病。亦当遣信往礼拜问讯。若别众若尼众不和合若众不满。亦当遣信往礼拜问讫。若不往者突吉罗。比丘突吉罗。是谓为犯。不犯者。半月往大僧中求教授。今日嘱明日问。比丘期而往。比丘尼期而来迎。彼闻教授人来半由旬迎。在寺内供给洗浴具饭食羹粥果蓏。以此供养。若大僧有病。应遣信往礼拜问讯。若别众众不和合若众不满。遣信往礼拜问讯。若比丘尼僧病。若别众若众不和合若众不满。亦应遣信礼拜问讯。若水陆道断。贼寇恶兽难。若河水瀑涨。若为强力所执若被系闭。命难梵行难。如是众难。不遣信问讯者无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(四十一)

尔时婆伽婆。在舍卫国祇树给孤独园。时诸比丘尼。闻世尊制戒听比丘尼夏安居竟应往比丘僧中说三事自恣见闻疑。然此诸比丘尼。不往至大僧中说三事自恣见闻疑。时诸比丘尼闻。中有少欲知足行头陀乐学戒知惭愧者。呵责诸比丘尼言。云何世尊制戒听比丘尼夏安居竟往大僧中说三事自恣见闻疑。而汝等不往说自恣耶。即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责诸比丘尼言。汝所为非。非威仪非沙门法。非净行非随顺行所不应为。比丘尼夏安居竟应往大僧中说三事自恣见闻疑。云何不往耶。以无数方便呵责已。告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼僧。夏安居竟应往比丘僧中说三事自恣见闻疑。若不者波逸提。比丘尼义如上。时世尊既听比丘尼夏安居竟应往比丘僧中说三事自恣见闻疑。时诸比丘尼。尽往大僧中说自恣闹乱。佛言。不应尽往。自今已去听差一比丘尼。为比丘尼僧故。往比丘僧中说三事自恣见闻疑。作白二羯磨。众中当差堪能羯磨者。如上当作如是白。大姊僧听。若僧时到僧忍听。僧今差某甲比丘尼。为比丘尼僧故。往大僧中说三事自恣见闻疑。白如是。大姊僧听。今僧差某甲比丘尼。为比丘尼僧故。往大僧中说三事自恣见闻疑。谁诸大姊忍。僧差某甲比丘尼。为比丘尼僧故。往大僧中说三事自恣见闻疑者默然。谁不忍者说。众僧已忍。差某甲比丘尼。为比丘尼僧故。往大僧中说三事自恣竟。僧忍默然故。是事如是持。彼独行无护。为护故。应差二三比丘尼为伴。往至大僧中礼僧足已。曲身低头合掌作如是说。比丘尼僧夏安居竟。比丘僧夏安居竟。比丘尼僧。说三事自恣见闻疑。大德慈愍语我。我若见罪当如法忏悔。如是第二第三说。彼即比丘僧自恣日便自恣而皆疲极。佛言不应尔。比丘僧十四日自恣。比丘尼僧十五日自恣。若大僧病。若别众。众不和合。若众不满。比丘尼应遣信礼拜问讯。不者突吉罗。若比丘尼众病。若别众。若众不和合。若众不满。比丘尼亦当遣信礼拜问讯。不者突吉罗。比丘突吉罗。是谓为犯。不犯者。比丘尼僧夏安居竟。比丘僧夏安居竟。比丘尼说三事自恣见闻疑。若比丘十四日自恣。比丘尼十五日自恣。比丘僧病。若别众。若众不和合。若众不满。比丘尼应遣信往礼拜问讯。比丘尼众病。乃至众不满。亦应遣信礼拜问讯。若水陆道断。若贼寇恶兽难。河水瀑涨。若命难梵行难。为强力者所执。若不往问讯。一切无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(四十二)

尔时婆伽婆。在舍卫国祇树给孤独园。时诸比丘尼。在无比丘处夏安居。教授日无受教授处。有所疑无可咨问。时诸比丘尼闻。中有少欲知足行头陀乐学戒知惭愧者。呵责诸比丘尼言。云何乃在无有比丘处夏安居。教授日无受教授处。若有所疑事而无可咨问处。即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责诸比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何乃于无比丘处夏安居。乃至有所疑事而无可咨问耶。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。在无比丘处夏安居者波逸提。比丘尼义如上说。彼比丘尼。无比丘处夏安居者波逸提。比丘突吉罗式叉摩那沙弥沙弥尼突吉罗。是谓为犯不犯者。有比丘处夏安居。若依比丘僧夏安居。其间命过者。若远行去。若休道。或为贼所将去。或为恶兽所害。或为水所漂无犯。无犯者最初未制戒。痴狂心乱痛恼所缠(四十三)

尔时婆伽婆。在舍卫国祇树给孤独园。时舍卫城中有一多知识比丘尼命过。复有比丘尼。于比丘所住寺中为起塔。诸比丘尼。数来诣寺住立言语戏笑。或呗或悲哭者。或自庄严身者。遂乱诸坐禅比丘。时有长老迦毗罗常乐坐禅。比丘尼去后。即日往坏其塔除弃着僧伽蓝外。时彼比丘尼。闻迦毗罗坏其塔除弃。皆执刀杖瓦石来欲打掷。时迦毗罗即以神足飞在虚空。时诸比丘尼闻。中有少欲知足行头陀乐学戒知惭愧者。呵责诸比丘尼。汝云何乃欲持刀杖瓦石打迦毗罗耶。即白诸比丘。诸比丘往白世尊。世尊以是因缘集比丘僧。呵责诸比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何乃持刀杖瓦石欲打比丘。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。入比丘僧伽蓝中波逸提。如是世尊与比丘尼结戒。诸比丘尼疑。不敢入无比丘僧伽蓝中。佛言听入。自今已去应如是结戒。若比丘尼。入有比丘僧伽蓝中波逸提。如是世尊与比丘尼结戒。时诸比丘尼。亦不知有比丘无比丘。后方知有比丘。或有作波逸提忏者或疑者。不知者无犯佛言。自今已去当如是结戒。若比丘尼。知有比丘寺入者波逸提。如是世尊与比丘尼结戒。彼欲求教授。不知何从求。有疑欲问。不知从谁问。不敢入寺。佛言。自今已去听白然后入寺。彼欲礼佛塔声闻塔。佛言。欲礼佛塔声闻塔。听辄入。余者须白已入。自今已去当如是说戒。若比丘尼。知有比丘僧伽蓝。不白而入者波逸提。比丘尼义如上。若比丘尼。知有比丘僧伽蓝。不白而入门波逸提。一脚在门内一脚在门外方便欲入。若期入而不入者。一切突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若先不知。若无比丘而入。若礼拜佛塔声闻塔。余者白已入。若来受教授。若欲问法来入。若被请。若道由中过。或在中止宿。或为强力者所将去。或被系闭将去。或命难梵行难无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(四十四)

尔时婆伽婆。在舍卫国祇树给孤独园。时长老迦毗罗比丘夜过已晨朝着衣持钵入舍卫城乞食。时诸比丘尼见迦毗罗即骂詈言。此弊恶下贱工师种。坏我等塔除弃僧伽蓝外。时诸比丘尼闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责言。云何汝等。乃骂长老迦毗罗。呵责已往白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责诸比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何骂迦毗罗耶。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼骂比丘者波逸提。比丘尼义如上。骂者。下贱处生。种姓下贱。技术下贱。作业下贱。若说犯罪。若说汝有如是如是结使。或触他所讳。彼比丘尼。种类骂比丘。乃至说他所讳。说而了了者波逸提。不了了者突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若戏笑语。若疾疾语。若独语。若梦中语。欲说此乃错说彼无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(四十五)

尔时婆伽婆。在拘睒弥。时迦罗比丘尼。好喜斗诤不善忆持斗诤事。后嗔恚嫌责尼众。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责迦罗比丘尼言。汝云何喜斗诤断已怀恨经宿嫌骂尼众耶。即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责迦罗言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何喜斗诤断已怀恨经宿方便骂詈尼众耶。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。喜斗诤不善忆持诤事后嗔恚不喜骂比丘尼众者波逸提。比丘尼义如上。诤有四种如上。众者。若四人若过四人。彼比丘尼。喜斗诤经宿后骂比丘尼众。说而了了者波逸提。不了了者突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若戏笑语。若疾疾语。若独语。若梦中语。欲说此乃错说彼无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(四十六)

尔时婆伽婆。在释翅搜迦毗罗国尼拘律园中。时跋陀罗迦毗罗比丘尼。身生痈使男子破之。此比丘尼身细软如天身无异。时男子手触身觉细滑生染着。便前捉欲犯。即便高声言。勿尔勿尔。时左右比丘尼闻其声皆来问言。向何故大唤耶。即具说因缘。时诸比丘尼闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责跋陀罗迦毗罗言。云何比丘尼。乃使男子破痈耶。即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责跋陀罗迦毗罗比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何使男子破身痈疮耶。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。身生痈及种种疮。不白众及余人辄使男子破若裹者波逸提。比丘尼义如上。僧者亦如上。彼比丘尼。若身生痈及种种疮。不白众。使男子破一下刀一波逸提。若裹时一匝缠。一波逸提。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。白众僧。使男子破痈若疮若裹。若为强力者所执无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(四十七)

尔时婆伽婆。在舍卫国祇树给孤独园。时有一居士。欲办具饮食请比丘尼僧。即于其夜办种种多美饮食。夜过已清旦往白时到。时舍卫城中俗节会日。诸居士各各持饭干饭糗鱼及肉。来就僧伽蓝中。与诸比丘尼。诸比丘尼。受此施食食已。然后方诣居士家食。时居士手自斟酌羹饭与诸比丘尼。诸比丘尼言。止止居士。不须多着。居士报言。我所以办具此种种多美饮食人别一器肉者。正为阿姨故耳。勿谓我无有信心而不食。阿姨但食。我实有信心。比丘尼报言。我等不以此事。朝是节会日。诸居士各各持饭糗干饭鱼肉种种羹饭。来诣僧伽蓝中。与诸比丘尼。我等先已食。以是故少受耳。时诸居士皆共讥嫌言。此比丘尼。不知厌足。外自称言。我知正法。如是何有正法。云何先受我请已。复受他种种饭食食已。后方受我食。时诸比丘尼闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责诸比丘尼言。汝等云何先受居士请复受余食。即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责诸比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何先受居士请。后复受余食耶。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。先受请若足食已。后食饭糗干饭鱼及肉者波逸提。比丘尼义如上。彼比丘尼。先受请若足食已。后食他饭糗干饭鱼及肉食。一咽一波逸提。比丘波逸提。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。受非正食请。若不满足食请。若先不被请。若即于食上更得食。若于其家受前食后食无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(四十八)

尔时婆伽婆。在舍卫国祇树给孤独园。时提舍比丘尼。是安隐比丘尼弟子。彼有知旧檀越家。安隐比丘尼语提舍比丘尼言。可共往至檀越家。报言。欲往可尔。二人俱往。安隐比丘尼衣服齐整不失威仪。檀越见已生欢喜心。以此欢喜心便与供养。时安隐比丘尼。食后还至僧伽蓝中。语提舍比丘尼言。此檀越笃信欢喜好施供养。时提舍比丘尼有嫉妒心。便作是语。檀越笃信好施供养于汝。时诸比丘尼闻。中有少欲知足行头陀乐学戒知惭愧者。呵责提舍比丘尼言。云何生嫉妒心乃作是言。是檀越笃信好施供养于汝。即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责提舍比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何乃生嫉妒心言。檀越笃信好施供养于汝。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼于家生嫉妒心波逸提。比丘尼义如上。彼比丘尼于家生嫉妒心言。是檀越笃信好施供养于汝。说而了了者波逸提。不了了者突吉罗比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。其事实尔。若彼檀越笃信好施供养于彼。便作是言。是汝檀越笃信于汝。若戏笑语。若疾疾语。若独语。若梦中语。欲说此乃错说彼无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(四十九)

尔时婆伽婆。在舍卫国祇树给孤独园。时六群比丘尼。以香涂摩身。诸居士见皆共讥嫌言。此比丘尼等。不知惭愧犯不净行。外自称言。我知正法。如是有何正法。乃以香涂身。如似淫女贼女无异。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘尼。汝等云何。乃以众香涂身耶。即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责六群比丘尼言。汝所为非非威仪非沙门法非净行非随顺行。所不应为。云何比丘尼以香涂身。以无数方便呵责已告诸比丘。此六群比丘尼。多种有漏处最初犯戒。自今已去与比丘尼结戒集十句义乃至正法久住。欲说戒者当如是说。若比丘尼以香涂摩身者波逸提。比丘尼义如上。彼比丘尼以香涂摩身波逸提。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。或为强力所执无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(五十)

尔时婆伽婆。在舍卫国祇树给孤独园。时六群比丘尼。以胡麻滓涂摩身。诸居士见皆共讥嫌。此比丘尼。无有惭愧犯梵行。外自称言。我知正法。如是有何正法。云何持胡麻滓涂身。如似贼女淫女无异。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责六群比丘尼言。汝云何以胡麻滓涂身。即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧呵责六群比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何比丘尼。乃以胡麻滓涂身耶。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼以胡麻滓涂摩身者波逸提。比丘尼义如上。彼比丘尼以胡麻滓涂摩身者波逸提。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。或为强力所执无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(五十一)

尔时婆伽婆。在舍卫国祇树给孤独园。时六群比丘尼。使诸比丘尼揩摩身。诸居士见皆共讥嫌言。此比丘尼。不知惭愧犯梵行。外自称言。我知正法。如是有何正法。乃使诸比丘尼揩摩其身。如似贼女淫女无异。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责六群比丘尼言。汝云何乃使诸比丘尼揩摩其身。即白诸比丘。诸比丘往白世尊。世尊以此因缘集诸比丘僧。呵责六群比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何比丘尼。乃使诸比丘尼揩摩其身。以无数方便呵责已告诸比丘。是比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼使比丘尼涂摩身波逸提。比丘尼义如上。彼比丘尼使比丘尼涂摩身者波逸提。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。或为强力者所执无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(五十二)

尔时婆伽婆。在舍卫国祇树给孤独园。时六群比丘尼。使式叉摩那涂摩身。诸居士见皆共讥嫌。此比丘尼等。不知惭愧犯梵行。外自称言。我知正法。如是有何正法。使式叉摩那涂摩其身。如似淫女贼女无异。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘尼言。汝等云何使式叉摩那揩摩其身。即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责六群比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何比丘尼使式叉摩那揩摩其身。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒集十句义乃至正法久住。欲说戒者当如是说。若比丘尼使式叉摩那涂摩身者波逸提。比丘尼义如上。彼比丘尼使式叉摩那涂摩身者波逸提。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。或为强力者所执无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(五十三)

尔时婆伽婆。在舍卫国祇树给孤独园。时六群比丘尼。使沙弥尼涂摩身。诸居士见皆共讥嫌言。此六群比丘尼。不知惭愧犯梵行。使沙弥尼涂摩身。如似淫女贼女无异。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责六群比丘尼言。汝等云何乃使沙弥尼涂摩其身。即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责六群比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何比丘尼。使沙弥尼涂摩身。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住欲说戒者当如是说。若比丘尼。使沙弥尼涂摩身者波逸提。比丘尼义如上。彼比丘尼使沙弥尼涂摩身者波逸提。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。或为强力者所执无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(五十四)

尔时婆伽婆。在舍卫国祇树给孤独园。时六群比丘尼。使白衣妇女涂摩身。时诸居士见皆共讥嫌。此比丘尼。不知惭愧犯梵行。乃使白衣妇女涂摩其身。如似淫女贼女无异。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责六群比丘尼言。汝等云何使白衣妇女涂摩其身。即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责六群比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何比丘尼。使白衣妇女涂摩身。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼使白衣妇女涂摩身者波逸提。比丘尼义如上。彼比丘尼使白衣妇女涂摩身者波逸提。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。或为强力者所执无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(五十五)

尔时婆伽婆。在舍卫国祇树给孤独园。时偷罗难陀比丘尼作如是念。着[袖-由+宁]髁衣令身粗大。居士见皆共讥嫌。此比丘尼等。不知惭愧犯梵行。外自称言。我知正法。如是有何正法。云何着[袖-由+宁]髁衣令身粗大。如似淫女贼女无异。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责偷罗难陀言。汝云何作如是念。着[袖-由+宁]髁衣令身粗大耶。即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责偷罗难陀言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何比丘尼。作如是心。着[袖-由+宁]髁衣令身粗大。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼着[袖-由+宁]髁衣者波逸提。比丘尼义如上。[袖-由+宁]髁衣者。若用毳若劫贝若俱遮罗若乳叶草若刍摩若野蚕绵一切物。比丘尼作如是意。着[袖-由+宁]髁衣令身粗大波逸提。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或有如是病。内着病衣。外着涅槃僧。次着袈裟。或为强力者所执无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(五十六)

尔时婆伽婆。在舍卫国祇树给孤独园。时六群比丘尼。畜妇女庄严身具手脚钏及猥处庄严具。诸居士见皆共讥嫌言。此比丘尼。无有惭愧犯梵行。外自称言。我知正法。如是有何正法。乃畜妇女庄严身具手脚钏及猥处庄严具。如似淫女贼女无异。时诸比丘尼闻。中有少欲知足行头陀乐学戒知惭愧者。呵责六群比丘尼言。汝等云何。乃畜妇女庄严身具手脚钏及猥处庄严具耶。即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责六群比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何比丘尼。畜妇女庄严身具手脚钏及猥处庄严具。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼畜妇女庄严具者波逸提。如是世尊与比丘尼结戒。时诸比丘尼。有命难梵行难。有疑不敢着庄严身具走。佛言。自今已去。若命难梵行难。听着庄严身具走。自今已去当如是结戒。若比丘尼。畜妇女庄严身具。除时因缘波逸提。若比丘尼。畜妇女庄严身具。手脚钏猥处庄严具。乃至树皮作鬘。一切波逸提。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或有如是病。若命难梵行难着庄严具逃走。或为强力者所执无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(五十七)

尔时婆伽婆。在舍卫国祇树给孤独园。时六群比丘尼着革屣手擎盖而行。诸居士见皆共讥嫌。此比丘尼。不知惭愧犯梵行。外自称言。我知正法。如是有何正法。着革屣擎盖而行。如似淫女贼女无异。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责六群比丘尼言。汝云何乃着革屣手擎盖而行。即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责六群比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何着革屣手擎盖而行。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼着革屣持盖在道行者波逸提。如是世尊与比丘尼结戒。时诸比丘尼。至小食大食处。若夜集若说戒时。行遇雨渍坏新染色衣。佛言。自今已去听。护身护衣护卧具故。在僧伽蓝内。作树皮盖叶盖竹盖。时有比丘尼天雨时涂跣行泥。污脚污衣污坐具。佛言。自今已去听。为护身护衣护坐具故。在僧伽蓝中作屧着。诸比丘尼。虽作屧犹污衣污身污坐具。佛言。自今已去听下着树皮。若皮堕。以缕綖缀。若断。听用筋若毛。或用皮带系之。自今已去当如是说戒。若比丘尼。着革屣持盖行除时因缘波逸提。比丘尼义如上。彼比丘尼。着革屣持盖行除时因缘波逸提。彼比丘尼。着革屣持盖行。随所行村界。一一波逸提。无村阿兰若处。随行十里。一波逸提。行减一村界突吉罗。减十里突吉罗。行一界内突吉罗。方便欲去而不去。若共期去而不去。一切突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。若护身护衣护卧具。于僧伽蓝中作树皮盖叶盖竹盖。护身护衣护卧具故。于僧伽蓝内作屧着不犯。或为强力者所执。或为系闭。或命难梵行难。着革屣持盖行者无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(五十八)

四分律卷第二十九四分律卷第三十(二分之九明尼戒法)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    一百七十八单提法之七

尔时婆伽婆。在舍卫国祇树给孤独园。时六群比丘尼。乘乘在道行。诸居士见皆讥嫌言。此比丘尼。不知惭愧犯梵行。外自称言。我知正法。如是有何正法。乘乘而行。如淫女贼女无异。时诸比丘尼闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘尼言。汝云何乘乘在道行。即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责六群比丘尼。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何比丘尼乘乘行。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼乘乘在道行者波逸提。如是世尊与比丘尼结戒。时诸比丘尼。有老者或羸病气力微弱。不能从此住处至彼住处。佛言。自今已去听乘步挽乘一切女乘。时诸比丘尼。有难事或命难梵行难。疑不敢乘乘走。佛言。自今已去有如是诸难事听乘乘去。自今已去当如是说戒。若比丘尼。无病乘乘行除时因缘波逸提。比丘尼义如上。乘者有四种。象乘马乘车乘步乘。彼比丘尼。无病乘乘行。随所行村界。一一波逸提。若无村阿兰若处。行十里一波逸提。减一村界若减十里突吉罗。若行一家界内突吉罗。方便欲去而不去。共期去而不去。一切突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病乘种种安乘。若命难梵行难乘乘走。或为强力所执将去者无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(五十九)

尔时婆伽婆。在舍卫国祇树给孤独园。时六群比丘尼。不着僧祇支入村。露胸腋乳腰带。诸居士见皆共讥嫌言。此比丘尼。不知惭愧犯梵行。外自称言。我知正法。如是有何正法。不着僧祇支入村。如贼女淫女无异。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责六群比丘尼言。汝云何不着僧祇支入村露胸腋乳腰带。即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责六群比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何不着僧祇支入村露胸腋乳腰带。以无数方便呵责已告诸比丘。此六群比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。不着僧祇支入村者波逸提。比丘尼义如上。村者如上。彼比丘尼。不着僧祇支入村门波逸提。一脚在门外一脚在门内。若方便欲入而不入。若期入而不入者。一切突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。或腋下有疮。或无只支。或方便欲作。或浣染未干。若作失。或举处深固。或为强力者所执。或命难梵行难无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(六十)

尔时婆伽婆。在舍卫国祇树给孤独园。时偷罗难陀比丘尼。向暮至居士家就座而坐。随坐时顷。不语主人开门而去。时有贼先常有心欲偷其家。遇见门开。即入偷其财物去。时居士问言。向暮谁开门出去。答言。是偷罗难陀比丘尼。时居士即讥嫌言。此比丘尼。不知惭愧不与取。外自称言。我知正法。如是有何正法。乃与贼同谋偷我财物。如贼女淫女无异。诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责偷罗难陀言。汝云何向暮至居士家。即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责偷罗难陀言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何向暮至居士家。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。向暮至白衣家者波逸提。如是世尊与比丘尼结戒。时诸比丘尼。欲营佛法僧事。若有瞻病事。或为檀越唤。皆有疑而不敢去。佛言。自今已去若有请唤者听往。自今已去当如是说戒。若比丘尼。向暮至白衣家。先不被唤波逸提。比丘尼义如上。彼比丘尼。向暮至白衣家。先不被请唤入门波逸提。一脚在门外一脚在门内。若方便欲去而不去。若共期去而不去者。一切突吉罗。彼比丘尼。若至白衣家随住时顷。不语主人而去。出门者波逸提。方便欲去而不去。若共期去而不去。一切突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若为佛法僧事。若瞻视病事。若被请唤去。或为强力者所执。若被系缚将去。或命难梵行难。先不唤而去至彼家。随所住时顷语主人而去。若彼舍为火所烧崩坏。或有毒蛇或有贼或有恶兽。或为强力者所执。若系缚将去。或命难梵行难。不语主人而出者无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(六十一)

尔时婆伽婆。在舍卫国祇树给孤独园。时六群比丘尼众中。有一比丘尼。向暮辄开僧伽蓝门出。无所语而去。时诸贼见已生念。我当劫其财物。念已即便入门。劫夺财物尽。时诸比丘尼自相问言是谁向暮开门无所语而去。即闻六群比丘尼中一人开门而出。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责六群比丘尼言。汝云何向暮无所语开门而出。即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责六群比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何比丘尼。向暮无所语开门而出。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。向暮开僧伽蓝门出者波逸提。如是世尊与比丘尼结戒。时诸比丘尼。以佛法僧事。或有看视病事。皆疑不敢出。佛言。自今已去听嘱授出。自今已去当如是说戒。若比丘尼。向暮开僧伽蓝门。不嘱授余比丘尼而出者波逸提。比丘尼义如上。彼比丘尼。向暮开僧伽蓝门不嘱而出门者波逸提。一脚在内一脚在外。若方便欲去而不去。若共期去而不去。一切突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或佛法僧事。或看病事。嘱而去。若僧伽蓝破坏。若为火所烧。若有毒蛇若有贼若有恶兽。若为强力者所执。若被系缚将去。或命难梵行难不嘱而出者无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(六十二)

尔时婆伽婆。在舍卫国祇树给孤独园。时六群比丘尼中有一人。日没开僧伽蓝门出不嘱而去。时有贼囚突狱而出。遥见僧伽蓝门开便来入。时诸守狱人追后而来。问诸比丘尼。颇见如是如是贼不。不见者言不见。其守狱者。即便处处推觅得贼。时诸居士皆共讥嫌。此比丘尼等。不知惭愧作妄语。外自称言。我知正法。如是有何正法。见贼而言不见。时诸比丘尼自相问言。谁日没开门而出。报言。六群比丘尼中一人开门而出。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责六群比丘尼言。汝云何日没辄开门不嘱而出。即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责六群比丘尼中一人言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何比丘尼。日没辄开门出不嘱而去。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。日没开僧伽蓝门而出波逸提。如是世尊与比丘尼结戒。时诸比丘尼。营佛法僧事。若瞻视病事。疑不敢去。佛言。自今已后听嘱授去。自今已去当如是说戒。若比丘尼。日没开僧伽蓝门不嘱而出者波逸提。比丘尼义如上。彼比丘尼。日没开僧伽蓝门不嘱出门波逸提。一脚在内一脚在外。方便欲去而不去。共期去而不去。一切突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或为佛法僧事。或瞻视病事。若嘱而出。或彼僧伽蓝破坏。或为火所烧。或为贼或有恶兽毒蛇在中。或为强力者所执。或为系缚将去。或命难梵行难不嘱而去者无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(六十三)

尔时婆伽婆。在舍卫国祇树给孤独园。时有比丘尼不夏安居。时诸比丘尼闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责诸比丘尼言。云何不夏安居耶。即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责诸比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何比丘尼不夏安居。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼不夏安居者波逸提。如是世尊与比丘尼结戒。时诸比丘尼。有为佛法僧事。或看病事。不及安居疑。佛言。自今已去听有如是因缘后安居。自今已去当如是说戒。若比丘尼。不前安居不后安居者波逸提。比丘尼义如上。若比丘尼。不前安居者突吉罗。不后安居者波逸提。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。前安居。或为佛法僧事。或瞻视病人。受后安居不犯。不犯者。最初未制戒。痴狂心乱痛恼所缠(六十四)

尔时婆伽婆。在舍卫国祇树给孤独园。时诸比丘尼。闻世尊制戒得度人授具足戒。便度常漏大小便涕唾常出者与授具足戒。彼污身污衣污卧具。诸比丘尼闻。中有少欲知足行头陀乐学戒知惭愧者。呵责诸比丘尼言。汝等云何。辄度常漏大小便涕唾常出者。污身污衣床褥卧具。即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责诸比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何比丘尼。乃度常漏大小便涕唾常出。污身衣床褥卧具耶。以无数方便。呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。度常漏大小便涕唾常出者与授具足戒波逸提。如是世尊与比丘尼结戒。时诸比丘尼。亦不知常漏大小便不漏大小便涕唾出不出。后乃知。或有作波逸提忏者。或有疑者。佛言。不知者无犯。自今已去当如是结戒。若比丘尼。知女人常漏大小便涕唾常出者授具足戒波逸提。比丘尼义如上。彼比丘尼。知常漏大小便涕唾常出者度授具足戒。三羯磨竟和上尼波逸提。白二羯磨三突吉罗。白一羯磨二突吉罗。白已一突吉罗。白未竟突吉罗。未白前剃发与授戒集众众满。一切突吉罗。比丘突吉罗。是谓为犯。不犯者。先不知。若信可信人语。信父母语。与授具足戒。后有如是病无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(六十五)

尔时婆伽婆。在舍卫国祇树给孤独园。时有比丘尼。度二形人。大小便时有比丘尼见。白诸比丘尼。诸比丘尼闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责诸比丘尼言。汝等云何度他二形人。即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责诸比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何比丘尼乃度二形人。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。度二形人。授具足戒波逸提。如是世尊与比丘尼结戒。时诸比丘尼。不知二形不二形。后方知有二形。或有作波逸提忏者。或有疑者。不知无犯。自今已去当如是结戒。若比丘尼。知二形人与授具足戒者波逸提。比丘尼义如上。二形者男形女形。彼比丘尼。知二形人与授具足戒。三羯磨竟和上尼波逸提白二羯磨竟三突吉罗。白一羯磨竟二突吉罗。白已一突吉罗。白未竟突吉罗。未白前剃发与授戒集众众满。一切突吉罗。比丘突吉罗。是谓为犯。不犯者。先不知。若信彼人语。若信可信者语。若信父母语。与授具足戒已后变为二形无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(六十六)

尔时婆伽婆。在舍卫国祇树给孤独园。时诸比丘尼。度二道合者与授具足戒。大小便时诸比丘尼见。时诸比丘尼闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责诸比丘尼言。汝云何度二道合者与授具足戒。即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责诸比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何比丘尼。乃度二道合者与授具足戒。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。度二道合者与授具足戒波逸提。如是世尊与比丘尼结戒。时诸比丘尼。亦不知二道合不合。后乃知二道合。或有作波逸提忏者有疑者。不知者无犯。自今已去当如是结戒。若比丘尼。知二道合者与授具足戒波逸提。比丘尼义如上。二道合者大小便道不别。彼比丘尼。知二道合者度与授具足戒。白三羯磨竟和上尼波逸提。白二羯磨三突吉罗。白一羯磨二突吉罗。白已一突吉罗。白未竟突吉罗。未白前若剃发与授戒若集众众满。一切突吉罗。比丘突吉罗。是谓为犯。不犯者。先不知。若信彼人语。若信可信者语。若信父母言。若与授具足戒后二道合者无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(六十七)

尔时婆伽婆。在舍卫国祇树给孤独园。时诸比丘尼。闻世尊制戒听度弟子。便度负债人及诸病者与授具足戒已。债主来牵捉。若病者常须人守视不得远离。时诸比丘尼闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责诸比丘尼言。世尊制戒听度人。汝云何度他负债人及病者。使债主牵捉病者常须守视不得远离耶。即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责诸比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行所不应为。云何比丘尼。度他负债人及病者。债主牵捉病者须人守视不得远离耶。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。度负债人及病者与授具足戒波逸提。如是世尊与比丘尼结戒。时诸比丘尼。不知有负债难无负债难若病难不病难。后方知负债及病难者。中有作波逸提忏者。或有疑者。不知者不犯。自今已去当如是结戒。若比丘尼。知有负债难者病难者与授具足戒波逸提。比丘尼义如上。负债者。乃至一钱为十六分之一分也。病者。乃至常患头痛。彼比丘尼。知负债难及病难者度与授具足戒。白三羯磨竟和上尼波逸提。白二羯磨三突吉罗。白一羯磨二突吉罗。白已一突吉罗。白未竟突吉罗。未白前若剃发与授戒集众众满。一切突吉罗。比丘突吉罗。是谓为犯。不犯者。先不知。若信彼人语。若信可信者语。若信父母语。若与授具足戒已负债若病无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(六十八)

尔时婆伽婆。在舍卫国祇树给孤独园。时六群比丘尼。学习咒术以自活命。咒术者。或支节咒刹利咒。或起尸鬼咒。或学知死相知转禽兽论。卜知众鸟音声。诸比丘尼闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘尼言。汝等云何。乃学习如是诸咒术。乃至知众鸟音声。即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责六群比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何比丘尼。学如是诸技术。乃至知众鸟音声。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。学世俗技术以自活命波逸提。比丘尼义如上。技术者如上说。彼比丘尼。习诸技术乃至知众鸟音声。说而了了者波逸提。不了了突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若学咒腹中虫病。若治宿食不消。若学书学诵。若学世论。为伏外道故。若学咒毒。为自护不以为活命无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(六十九)

尔时婆伽婆。在舍卫国祇树给孤独园。时六群比丘尼。以世俗技术教授诸白衣语言。汝等。莫向日月及神祀庙舍大小便。亦莫向日月神祀除去粪扫及诸荡器不净水。莫向日月神祀舒脚。若欲起房舍耕田种作。当向日月及向神祀庙舍。又言。今日某甲星宿日好。宜种作作舍。宜使作人。宜与小儿剃发。亦宜长发。宜剃须。宜举取财物。宜远行。时诸比丘尼闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘尼言。汝云何。乃以如是技术教授白衣语言。汝等知不。莫向日月神祀庙舍大小便。乃至宜出远行。即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责六群比丘尼言。汝所为非。非威仪。非沙门法非净行非随顺行。所不应为。云何六群比丘尼。乃以世俗技术教授长者家语言。汝知不。莫向日月所回旋处大小便。乃至宜出远行耶。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。以世俗技术教授白衣波逸提。比丘尼义如上。技术者如上所说。若欲说者当语彼人言。莫向如来塔及声闻塔大小便及除弃粪扫荡器不净水。亦莫向如来塔及声闻塔舒脚。若欲起房舍及耕田种作者。当向如来塔及声闻塔。又不得言今日有如是星宿好。宜起舍宜种作宜使作人宜为小儿剃发长发剃须。应语言。宜入塔寺供养比丘僧受斋法。八日十四日十五日现变化日。彼比丘尼。以如是世俗技术教授白衣乃至宜出远行。说而了了者波逸提。不了了者突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。教言。莫向如来塔及声闻塔大小便及除粪扫不净水。亦莫向如来塔及声闻塔舒脚。若耕田种作若起房舍。向如来塔乃至受斋法。若戏笑语。若疾疾语。若独语梦中语。欲说此乃错说彼无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(七十)

尔时婆伽婆。在周那絺罗国。六群比丘尼。被摈而不去。时诸比丘尼闻。中有少欲知足行头陀乐学戒知惭愧者。呵责六群比丘尼。汝云何被摈而不去。即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责六群比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何被摈而不去。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。被摈不去者波逸提。比丘尼义如上。若比丘尼被摈应去而不去波逸提。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若被摈即去。若随顺不逆下意悔过求解摈羯磨。或得病。或无伴去。或水陆道断。或贼难。或恶兽难。或大水瀑涨。或为强力者所执。若被系闭。或命难梵行难。被摈而不去者无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(七十一)

尔时婆伽婆。在舍卫国祇树给孤独园。时安隐比丘尼。大智慧问诸比丘义。彼诸比丘。被问已不能答皆惭愧。时诸比丘尼闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责安隐比丘尼言。汝云何有大智慧而问诸比丘义使不能答令惭愧耶。即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责安隐比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何有大智慧而问诸比丘义令诸比丘不能答有惭愧耶。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼问比丘义者波逸提。如是世尊与比丘尼结戒。时诸比丘尼。教授曰不知从谁求教授。有疑不知当何从问义。佛言。自今已去若欲问义者。当先求听已然后问自今已去当如是结戒。若比丘尼欲问比丘义。先不求而问者波逸提。比丘尼义如上。彼比丘尼。问比丘义先不求而问。说而了了者波逸提。不了了者突吉罗。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。先求而后问。若先常听问。若先是亲厚。若亲厚者语言。汝但问。我当为汝求请。若彼从此受。若二人俱从他受。若彼问此答。二人共诵。或戏笑语。或疾疾语。或屏处语。或梦中语。或欲说此乃错说彼无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(七十二)

尔时婆伽婆。在舍卫国祇树给孤独园。时六群比丘尼。先住后至后至先住。欲恼乱彼故。在前经行。若立若坐若卧。尔时诸比丘尼闻。中有少欲知足行头陀乐学戒知惭愧者。呵责六群比丘尼言。汝云何。在先住后至比丘尼前。欲恼乱故。若经行若立若坐若卧耶。即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责六群比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等。先住后至比丘尼前。欲恼乱故。若经行若立若坐若卧耶。以无数方便呵责已告诸比丘。此六群比丘尼。多种有漏处最初犯戒自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。先住后至后至先住。欲恼乱彼故。在前经行若立若坐若卧波逸提。如是世尊与比丘尼结戒。彼比丘尼。不知先住不先住后至不后至。后乃知。或作波逸提忏者有疑者。不知者无犯。若比丘尼。知先住后至后至先住。欲恼彼故。在前经行若立若坐若卧波逸提。比丘尼义如上。彼比丘尼。知先住后至后至先住。欲恼彼故。在前经行若立若坐若卧者波逸提。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若先不知若问。若先听经行。若是上座。若更互经行。若次经行。若是亲厚。若亲厚者语言。汝但经行。我当为汝语。若病倒地。若强力者所执。或被系缚。若命难若梵行难无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(七十三)

尔时婆伽婆。在舍卫国祇树给孤独园。时舍卫城中有一多知识比丘尼命终。时诸比丘尼。在比丘僧伽蓝中立塔。彼处处取大僧洗足石破用垒塔。有客比丘来。不知是比丘尼塔。便向礼拜。时诸比丘尼闻。中有少欲知足行头陀乐学戒知惭愧者。呵责诸比丘尼言。云何乃在大僧僧伽蓝中立塔。令客比丘来不知而礼拜耶。即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责诸比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何比丘尼。乃于大僧僧伽蓝中立塔。令客比丘不知而向礼拜。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。在比丘僧伽蓝内起塔者波逸提如是世尊与比丘尼结戒。时诸比丘尼。在故坏无比丘僧伽蓝中起塔疑。佛言无犯。自今已去当如是结戒。若比丘尼。在有比丘僧伽蓝内起塔波逸提。彼比丘尼。不知有比丘无比丘。后乃知。或作波逸提忏者或有疑者。佛言。不知无犯。自今已去应如是结戒。若比丘尼。知有比丘僧伽蓝中起塔波逸提。比丘尼义如上。若比丘尼。知有比丘僧伽蓝中起塔。随所取洗足石。若团埿若草团多少。一一波逸提。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若先不知。若故坏僧伽蓝。若先起塔后作僧伽蓝无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(七十四)

尔时婆伽婆。在舍卫国祇树给孤独园。时世尊制戒听百岁比丘尼见新受戒比丘。当起迎逆礼拜恭敬问讯与敷坐具。然彼诸比丘尼。不起迎逆礼拜恭敬问讯。诸比丘尼闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责诸比丘尼言。云何世尊制戒听百岁比丘尼见新受戒比丘。应起迎逆恭敬礼拜问讯与敷坐具。云何不起迎逆耶。即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责诸比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝等。百岁比丘尼见新受戒比丘。不起迎逆礼拜恭敬问讯与敷坐具。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若百岁比丘尼见新受戒比丘。应起迎逆恭敬礼拜问讯。若不者波逸提。如是世尊与比丘尼结戒。或有一坐食。不作余食法食。或有病者。或有足食者。而不起疑。佛言。自今已去听语言大德忏悔。我有如是如是因缘不得起迎逆。自今已去当如是说戒。若比丘尼。见新受戒比丘。应起迎逆恭敬礼拜问讯请与坐。不者除因缘波逸提。比丘尼义如上。彼比丘尼。见比丘不起。除因缘波逸提。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。若起迎逆。或一坐食。或不作余食法食。或病或足食。语言。大德忍。我有如是如是因缘。或病倒地。或为强力所执。或命难梵行难者无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(七十五)

尔时婆伽婆。在舍卫国祇树给孤独园。时六群比丘尼。着衣摇身趋行。为好故。时诸居士见皆讥嫌言。此比丘尼等。不知惭愧犯梵行。外自称言。我知正法。如是有何正法。为好故摇身趋行。犹若淫女贼女无异。时诸比丘尼闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘尼言。汝等云何。为好故摇身趋行。犹若淫女贼女无异。时诸比丘尼白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责六群比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何比丘尼。为好故摇身趋行。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。为好故摇身趋行者波逸提。比丘尼义如上。彼比丘尼。为好故摇身趋行者波逸提。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。或为他所打避杖。或有暴象来。或遇贼。或遇恶兽。或有刺棘来以手遮。或渡河水。或渡沟渠汪水。若渡埿。或时欲齐整着衣。恐有高下参差象鼻多罗树叶细摄皱。如是左右顾视摇身看无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(七十六)

尔时婆伽婆。在舍卫国祇树给孤独园。时六群比丘尼。自庄严身梳发香涂摩身。诸居士见皆共嗤笑言。我等妇庄严其身梳发香涂摩身。此比丘尼亦复如是。便生慢心不恭敬。时诸比丘尼闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘尼言。汝等出家。云何如是庄严其身。即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责六群比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何六群比丘尼庄严其身。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。作妇女庄严香涂摩身波逸提。比丘尼义如上。彼比丘尼。作妇女庄严香涂摩身乃至一点者。一切波逸提。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。或时父母得病被系闭为洗沐梳发。若有笃信优婆夷遇病被系闭与洗浴。或为强力者所执无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(七十七)

尔时婆伽婆在舍卫国祇树给孤独园。时有伽罗旃陀输那比丘尼。是出家外道女姊。时彼比丘尼。使此外道妹香涂摩身。诸居士见皆共嗤笑言。此比丘尼。无有惭愧犯梵行。外自称言。我知正法。如是有何正法。使外道妹香涂摩身。如淫女贼女无异。诸比丘尼闻。中有少欲知足行头陀乐学戒知惭愧者。呵责伽罗旃陀输那比丘尼言。汝云何乃使外道妹香涂摩身耶。呵责已即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责伽罗旃陀输那比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何比丘尼。乃使外道妹香涂摩身。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼。使外道女香涂摩身波逸提。比丘尼义如上。彼比丘尼。使外道女香涂摩身者波逸提。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。或时有如是病。或为强力者所执无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠(一百七十八波逸提法竟)

尔时婆伽婆。在舍卫国祇树给孤独园。尔时六群比丘尼乞酥而食。时诸居士见皆共讥嫌言。此比丘尼。不知惭愧乞求无厌。外自称言。我知正法。如是有何正法。乞酥而食。如贼女淫女无异。时诸比丘尼闻。中有少欲知足行头陀乐学戒知惭愧者。呵责六群比丘尼言。汝云何乞酥而食耶。呵责已即白诸比丘。诸比丘往白世尊。世尊以此因缘集比丘僧。呵责六群比丘尼言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何比丘尼乞酥而食耶。以无数方便呵责已告诸比丘。此比丘尼多种有漏处最初犯戒。自今已去与比丘尼结戒。集十句义乃至正法久住。欲说戒者当如是说。若比丘尼乞酥而食。犯应忏可呵法。应向余比丘尼说言。大姊。我犯可呵法所不应为。今向大姊悔过。是法名悔过法。如是世尊与比丘尼结戒。彼有疑。不敢为病者乞。自身病亦不敢乞。他为乞复不敢食。佛言。自今已去听自病乞为病者乞他为乞得食。自今已去当如是结戒。若比丘尼。不病乞酥食者。犯应忏悔可呵法。应向余比丘尼说言。大姊。我犯可呵法所不应为。我今向大姊忏悔。是名悔过法。比丘尼义如上。彼比丘尼。无病而乞酥食。一咽一波罗提提舍尼。比丘突吉罗。式叉摩那沙弥沙弥尼突吉罗。是谓为犯。不犯者。为己病乞。为病者乞。或为他他为己。或不乞而自得无犯。无犯者。最初未制戒。痴狂心乱痛恼所缠。(一)

乞油若蜜若黑石蜜若乳若酪若鱼若肉如乞酥无异

(上四戒比丘式叉摩那沙弥沙弥尼突吉罗。下四戒比丘波逸提式叉摩那沙弥沙弥尼突吉罗。下众学戒与大僧戒无异故不出耳)

四分律卷第三十四分律卷第三十一(二分之十)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    受戒揵度之一

我曾闻有作如是说。古昔有王最初出世。名大人。众所举。时王有太子。名善王。善王有太子。名楼夷。楼夷王有子。名曰齐。齐王有子。名曰顶生。顶生王有子。名遮罗。遮罗王有子。名跋遮罗。跋遮罗王有子。名微。微王有子。名微驎陀罗。微驎陀罗王有子。名鞞醯梨肆。鞞醯梨肆王有子。名舍迦陀。舍迦陀王有子。名楼脂。楼脂王有子。名修楼脂。修楼脂王有子。名波罗那。波罗那王有子。名摩诃波罗那。举诃波罗那王有子。名贵舍。贵舍王有子。名摩呵贵舍。摩呵贵舍王有子。名善现。善现王有子。名大善现。大善现王有子。名无忧。无忧王有子。名光明。光明王有子。名梨那。梨那王有子。名弥罗。弥罗王有子。名末罗。末罗王有子。名精进力。精进力王有子。名牢车。牢车王有子。名十车。十车王有子。名百车。百车王有子。名坚弓。坚弓王有子。名十弓。十弓王有子。名百弓。百弓王有子。名能师子。能师子王有子。名真阇。从真阇王次第已来。有十转轮圣王种族。一名伽[少/兔]支。二名多楼毗帝。三名阿湿卑。四名乾陀罗。五名伽陵迦。六名瞻鞞。七名拘罗婆。八名般阇罗。九名弥悉梨。十名懿师摩。伽[少/兔]支次第相承五王。多楼毗帝次第五王。阿湿卑七王。乾陀罗八王。伽陵迦九王。瞻鞞十四王。拘罗婆三十一王。般阇罗三十二王。弥悉梨次第八万四千王。懿师摩王次第百王。从懿师摩王后。有王名大善生。大善生王有子。名懿师摩。懿师摩王有子。名忧罗陀。忧罗陀有子。名瞿罗。瞿罗有子。名尼浮罗。尼浮罗有子。名师子颊。师子颊有子。名悦头檀。悦头檀有子。名菩萨。菩萨有子。名罗睺罗。北方国界雪山侧释种子。生处豪族父母真正。众相具足。适生已时。诸相师婆罗门。皆共占相。记言大王。此儿有三十二大人之相。有此相者。必趣二道。终无差错。若不出家。当为刹利水浇顶转轮圣王。能胜一切主四天下。名为法王。为众生故。而作自在。七宝具足。所谓七宝者。一轮宝二象宝三马宝四珠宝五玉女宝六主藏臣宝七典兵宝。有千子满足雄猛勇健。能却众敌。从海内诸地不加刀杖。自以己力正法治化。无所畏惧。而行王事。所为自在不为怯弱。若当出家入非家者。当成无上正真等正觉明行足为善逝世间解无上士调御丈夫天人师佛世尊。彼于魔众梵众沙门婆罗门众天及人众。自身作证而自娱乐。与众生说法。上善中善下善。有义味具足。开现梵行。时摩竭王洴沙。备虑边国遣人处处卫逻。时王闻逻人所说。北方国界雪山侧。有释种子。生处豪族父母真正。有三十二大人之相。相师占相。如上所说。时逻人往至王所。白王言。大王当知。北方国界雪山侧。有释种子。生处豪族父母真正。有三十二大人相如上所说。王今宜设方便除去彼人。若不尔者。恐后必为王作害。亡国失土将由此起。王报言。何得除去。若彼不出家者。当为刹帝利水浇顶转轮圣王。七宝具足领四天下。所为自在无所怯弱。我当臣属给使。设当出家学道者。必成无上至真等正觉。为人说法。上中下言悉善。我当为其作弟子。尔时菩萨渐渐长大。诸根具足。于闲静处作是念。今观此世间甚为苦恼。有生有老有病有死。死此生彼以此身故。不尽苦际。如是苦身何可得尽。时菩萨年少。发绀青色颜貌殊特。年壮盛时心不乐欲。父母愁忧涕泣。不欲令出家学道。时菩萨强违父母。辄自剃须发着袈裟舍家入非家。尔时菩萨渐渐游行。从摩竭国界往至罗阅城。于彼止宿。明日清旦。着袈裟持钵。入罗阅城乞食。颜貌端正。屈申俯仰行步庠序。视前直进不左右顾眄。着衣持钵入罗阅城乞食。时摩竭王。在高楼上。诸臣前后围绕。王遥见菩萨入城乞食。屈申俯仰行步庠序。视前直进不左右顾眄。见已即向诸大臣。以偈赞曰

  汝等观彼容　　圣行为最胜
  相好甚严好　　非是下贱人
  谛视不顾眄　　视地而前进
  王即遣信问　　比丘欲所诣
  王所遣使人　　随逐比丘后
  比丘欲所至　　造诣何所宿
  家家遍乞已　　诸根寂然定
  钵饭速满已　　志意常悦豫
  时乞食得已　　圣还出城住
  山名班荼婆　　当于彼止宿
  已知彼宿处　　一使在边住
  一使速还返　　白王如是事
  大王此比丘　　今宿班荼山
  坐卧如师子　　如虎在于山
  王闻彼使言　　即严好象乘
  众人共寻从　　即往礼菩萨
  到彼问讯已　　却在一面坐
  共相问讯已　　复作如是说
  今观年盛壮　　众行甚清净
  应乘此大乘　　群臣侍从好
  颜貌甚端正　　必从刹利生
  我今与汝对　　愿说所生处
  有国大王治　　今在雪山北
  父姓名为日　　生处名释迦
  财宝技术具　　父母俱真正
  舍彼行学道　　不乐处五欲
  观欲多众恼　　出离永安隐
  要求灭欲处　　是我心所乐

时王语太子言。今可于此住。当分半国相与。菩萨报言。我不从此语。时王复重语言。汝可作大王。我今举国一切所有。及脱此宝冠相与。可居王位治化。我当为臣。时菩萨报言。我舍转轮王位出家学道。岂可贪于边国王位而处俗耶。王今当知。犹如有人曾见大海水后见牛迹水。岂可生染着心。此亦如是。岂可舍转轮王位习粟散小王位。此事不然。时王前白言。若成无上道者。先诣罗阅城与我相见。菩萨报言可尔。尔时王即从座起礼菩萨足绕三匝而去。时有人名阿蓝迦蓝。于众人中为师首。与诸弟子说不用处定。时菩萨至阿蓝迦蓝所问言。汝今以何等法。与诸弟子说令得证。报言瞿昙。我与诸弟子说不用处定。令其得证。时菩萨便作是念。阿蓝迦蓝而无有信。我今有信。阿蓝迦蓝无有精进。我今有精进。蓝无智慧。我有智慧。蓝今以此法得证。而况我不静坐思惟以证智慧。我今宁可勤精进证此法耶。彼即勤精进。不久得证此法。时菩萨得证已。往阿蓝迦蓝所语言。汝但证此不用处定为人说耶。报言。我正有此法。更无有余。菩萨报言。我亦证此不用处定。而不为人说。阿蓝迦蓝问言。瞿昙。汝正有此不用处定。而不为人说耶。我亦证不用处定为人说。瞿昙。如我所知汝亦知之。汝所知者我亦知之。汝似我我似汝。瞿昙。宁可共知僧事耶。时阿蓝迦蓝。极生欢喜恭敬心。承事菩萨。以之为匹。正与我等。时菩萨复作是念。此不用处定。非息灭。非去欲。非灭尽。非休息。非成等正觉。非沙门。非得涅槃永寂之处。不乐此法。便舍阿蓝迦蓝而去。更求胜法。时有郁头蓝子。处大众中而为师首。其师命终后。教师诸弟子。与说有想无想定。时菩萨往郁头蓝子所问言。汝师以何等法教诸弟子。报言。我师以有想无想定教诸弟子。时菩萨念言。蓝今无信。而我有信。蓝无精进。我有精进。蓝无智慧。我有智慧。蓝证此法而为人说。况我不证此法。我今宁可勤精进证此法。即勤精进。不久得证此法。时菩萨往至郁头蓝弗所问言。汝正有此有想无想定。更有余法耶。报言瞿昙。我正有此法。更无余法。菩萨报言。我亦证此有想无想定。彼问菩萨言。汝正有此有想无想定耶。我师蓝亦有此有想无想定作证。我师知者汝亦知之。汝所知者蓝亦知之。汝似蓝蓝似汝。瞿昙。今可共知僧事。时郁头蓝子。极发欢喜心。承事菩萨。推着师处。而师事之。尔时菩萨复作是念。我观此有想无想定处。非息灭。非无欲。非休息。非灭尽。非沙门。非涅槃永寂之处。不乐此法。便舍郁头蓝子而去更求胜法。时菩萨更求胜法者。即无上休息法也。从摩竭界游化南至象头山。诣郁毗罗大将村中。见一净地。平正严好甚可娱乐。生草柔软悉皆右旋。浴池清凉流水清净。园林茂好。周遍观之。左右村落人民众多。见已便生念言。夫为族姓子。欲求断结处。此是好处。我今求断结处。此处即是。我今宁可于此处坐而断结使。时有五人追逐菩萨念言。若菩萨成道当与我等说法。尔时郁鞞罗有四女。一名婆罗。二名郁婆罗。三名孙陀罗。四名金婆伽罗。皆系心菩萨所。若使菩萨出家学道。我等当为弟子。若菩萨不出家学道。在家习俗者。我等为妻妾。时菩萨即于彼处六年苦行。虽尔犹不证增上圣智胜法。尔时菩萨自念。昔在父王田上坐阎浮树下。除去欲心恶不善法。有觉有观喜乐一心。游戏初禅。时菩萨复作是念。颇有如此道可从得尽苦原耶。复作是念。如此道能尽苦原。时菩萨即以精进力修习此智。从此道得尽苦原。时菩萨复作是念。颇因欲不善法得乐法不。复作是念。不由欲不善法得乐法。复作是念。颇有习无欲舍不善法得乐法耶。然我不由此自苦身得乐法。我今宁可食少饭糗得充气力耶。尔时菩萨。于异时食少饭糗。得充气力。时菩萨食少食时五人各各厌舍而去。自相谓言。此瞿昙沙门狂惑失道。岂有真实道耶。时菩萨气力已充。复诣尼连禅水侧。入水洗浴身已出水上岸。往菩提树下。时去树不远。有一人刈草。名曰吉安。菩萨前至此人所语言。我今须草见惠少多。吉安报曰。甚善不为爱惜。即授草与菩萨。菩萨持草。更诣一吉祥树下。自敷而坐。直身正意系念在前。时菩萨除欲爱恶不善法。有觉有观喜乐一心。游戏初禅。是谓菩萨最初得胜善法。何以故。由系意专念不放逸故。时菩萨除有觉有观。得内信喜乐一心念无觉无观。游戏二禅。是谓菩萨得此二胜善法。何以故。由系意专念不放逸故。时菩萨除去喜身受快乐。得圣智所见护念乐。游戏三禅。是谓菩萨得三胜法。何以故。由系意专念不放逸故。时菩萨已舍苦乐。先已去忧喜。无苦无乐护念清净。游戏四禅。是谓菩萨得此四胜法。何以故。由系意专念不放逸故。时菩萨得此定意。诸结使除尽。清净无瑕秽。所行柔软住坚固处。证宿命智。自识宿命一生二生三生四生五生。十生二十生三十生四十生五十生。百生千生百千生。无数百生无数千生。无数百千生劫成劫败。无数劫成无数劫败。无数劫成败。我曾生某处。字某姓某如是生。食如是食。寿命如是。寿命限齐如是。住世长短如是。受如是苦乐。从彼终生彼。从彼终复生彼。从彼终生此。如是相貌。识无数宿命事。时菩萨。于初夜得此初明。无明尽明生。闇尽光生。所谓宿命通证。何以故。由精进不放逸故。时菩萨。复以三昧定意清净。无瑕无结使。众垢已尽。所行柔软。住坚固处。知众生生者死者。以清净天眼观见众生。生者死者。善色恶色。善趣恶趣。若贵若贱。随众生所造行。皆悉知之。即自察知。此众生身行恶口行恶意行恶。邪见诽谤贤圣。造邪见业报。身坏命终。堕地狱畜生饿鬼中。复观众生身行善口行善意行善。正见不诽谤贤圣。造正见业报。身坏命终。生天上人中。如是天眼清净。观见众生生者死者随所造行。是谓菩萨中夜得此第二明。无明尽明生。闇尽光生。是谓见众生天眼智。何以故。由精进不放逸故。时菩萨得如是清净定意。诸结除尽。清净无瑕。所行柔软。所住坚固。得漏尽智。而现在前。心缘漏尽智。如实谛知苦。知苦集。知苦尽。知苦尽向道。以得圣谛。如实知之。如实知漏。知漏集。漏尽向道如实知之。彼作如是知如是观。于欲漏意解脱。有漏意解脱。无明漏意解脱。已解脱得解脱智。我生已尽。梵行已立。所作已办。更不复受生。是谓菩萨后夜获此三明。无明尽明生。闇尽光生。是谓漏尽智。何以故。由如来至真等正觉发起此智得无碍解脱故。尔时世尊。于彼处尽一切漏。除一切结使。即于菩提树下。结加趺坐。七日不动。受解脱乐。尔时世尊。过七日已。从定意起。于七日中未有所食。时有二贾客兄弟二人。一名瓜二名优波离。将五百乘车载财宝。去菩提树不远而过。时树神笃信于佛。曾与此二贾客旧知识。欲令彼得度。即往至贾人所语言。汝等知不。释迦文佛如来等正觉。于七日中具足诸法。于七日中未有所食。汝等可以蜜糗奉献如来。令汝等长夜得利善安隐快乐。尔时兄弟二人。闻树神语已欢喜。即持蜜糗往诣道树。遥见如来颜貌殊异。诸根寂定最上调伏。如被调象无有卒暴。如水澄静无有尘秽。见已发欢喜心。于如来所前至佛所头面礼足在一面立。时二人白世尊言。今奉献蜜糗慈愍纳受时世尊复作如是念。今此二人奉献蜜糗。当以何器受之。复作是言过去诸佛如来至真等正觉。以何物受食诸佛世尊。不以手受食也。时四天王立在左右。知佛所念。往至四方。各各人取一石钵。奉上世尊。白言。愿以此钵。受彼贾人糗蜜。时世尊慈愍故。即受四天王钵。令合为一。受彼贾人糗蜜。受彼贾人糗蜜已。以此劝喻。而开化之。即咒愿言

  所为布施者　　必获其利义
  若为乐故施　　后必得安乐

汝等贾人。今可归依佛归依法。即受佛教言。大德。我今归依佛归依法。是为优婆塞中最初受二归依。是贾客兄弟二人为首。时二贾人白佛言。我今从此欲还本生处。若至彼间当云何作福。何所礼敬供养时世尊知彼至意。即与发爪语言。汝等持此往彼作福礼敬供养。时贾人虽得发爪。不能至心供养言。此发爪世人所贱除弃之法。云何世尊持与我等供养。时世尊知贾人心中所念。即语贾人言。汝等莫于如来发爪所生毛发许懈慢心。亦莫言世人所贱。云何如来使我供养。贾人当知。普天世界魔众梵众沙门婆罗门众天及人。于如来发爪兴供养恭敬。令一切诸天世人魔众梵众及沙门婆罗门众。得其功德不可称计。贾人白佛言。设供养此发爪有何证验。佛告贾人言。过去久远世时。有王名曰胜怨。统领阎浮提。尔时阎浮提内。米谷丰熟人民炽盛。土地极乐。有八万四千城郭。有五十五亿村。有六万小国土。时胜怨王所住治城。名莲花。东西十二由旬。南北七由旬。土地丰熟。米谷平贱。人民炽盛。国土安乐。园林茂盛。城堑牢固。浴池清凉。众事具足。街陌相当。贾人当知。时王胜怨。有婆罗门为大臣。名曰提阎浮婆提。是王少小周旋。极相亲厚。后于异时。王即分半国与此大臣。时彼大臣所得国分。即于中更起城郭。东西长十二由旬。南北广七由旬。米谷丰贱人民炽盛。国土安乐园林茂盛。城堑牢固浴池清凉。众事具足街陌相当。城名提婆跋提。胜彼莲花城邑。贾人当知。其王无有继嗣。以无嗣故。向诸神祀泉流山原河水浴池。满善神宝善神。日月帝释梵天。火神风神水神。魔醯首罗神。园神林神市神四徼巷神。鬼子母城神。天祀福神祀所在求请。愿生男儿。于异时王第一夫人怀妊。妇人有三种智慧。如实不虚。一自知有娠。二自知从某甲许得。三知男子有爱心于我。时彼夫人。往白王言。大王当知。我今怀妊。王报言大善。即敕左右。供给供养第一饮食衣服卧具。一切所须皆加一倍。至十月满已生一男儿。端正无比世之希有。始生在地无人扶侍。自行七步而说此言。我于天上世间最上最尊我当度一切众生生老病死苦。即号曰定光菩萨。贾人当知。尔时国王。即命婆罗门中善明相法者告言。汝等当知。我夫人生一男儿。颜貌端正世之希有。始生出胎无人扶侍。自行七步而说此言。我于天上世间最上最尊。能度一切众生生老病死苦。汝等善明相法。与我占相。时相师白王言。愿王出此儿令我等相之。王即自入宫抱儿出见之令相。诸相师相已。白王言。王生此儿。有大威神。有大功德。福愿具足。若此王子。在家者应作刹利水浇顶转轮王。七宝具足领四天下。千子满足勇健雄猛。能却众敌。以法治化。不加刀杖。若出家者。成如来至真等正觉明行足为善逝世间解无上士调御丈夫天人师佛世尊。天及人魔若魔天梵天沙门婆罗门。身自作证而自游戏。彼当说法。上善中善下善。有义有味。具足修梵行。贾人当知。尔时王赏赐婆罗门已。差四乳母。扶侍瞻视定光菩萨。一者肢节乳母。二者洗浴乳母。三者与乳乳母。四者游戏乳母。肢节乳母者。抱持案摩支节回戾令政。洗浴乳母者。洗身浣濯衣服。与乳乳母者。随时与乳。游戏乳母者。诸童子等。乘象乘马乘车乘舆。诸杂宝器乐器转机关。作如是种种供养之具。供养娱乐定光菩萨。擎孔雀盖从之。贾人当知。定光菩萨。年向八岁九岁时王教菩萨学种种技术。书算数印画戏笑歌舞鼓弦乘象乘马乘车射御捔力。一切技术无不贯练。贾人当知。定光转年。至十五十六时。王即为设三时殿。冬夏春给二万婇女。使娱乐之。与作园池。纵广二十由旬。现阎浮提一切华树果树香树。诸奇异树。尽殖之于园。贾人当知。首陀会天日来侍卫。作是念言。今菩萨在家已久。我今宁可为作厌离。菩萨得厌离已。早得出家。剃除须发着袈裟。修无上道耶。伺菩萨入后园时。即往化作四人一者老。二者病。三者死。四者出家作沙门。时菩萨见此四人已。极怀愁忧。厌患世苦。观世如是有何可贪。贾人当知。尔时菩萨得厌离已。即日出家即日成无上道。贾人当知。定光如来至真等正觉。遍观一切。未见有应度可为转无上法轮者。时定光如来。去提婆跋提城不远。化作一大城。高广妙好。悬缯幢旛。处处克镂。作众鸟兽形。周匝净妙浴池园果。胜于提婆跋提城化作人民颜貌形色。亦胜彼国人民。使己国人民共与往来交接为亲友。贾人当知。定光如来。观察提婆跋提城人民诸根纯熟即使化城忽尔火然。时提婆跋提城人见此已。极怀愁忧厌离心生。定光如来。于七日之中度六十六那由他人。五十五亿声闻。贾人当知。尔时定光如来。有大名称。流布十方。莫不闻知。皆共称言。定光如来至真等正觉明行足为善逝世间解无上士调御丈夫天人师佛世尊。普天世界魔若魔天梵众沙门婆罗门天及人。自身作证而自娱乐。与人说法。上中下言悉善。有义有味。具足修梵行。贾人当知。定光如来。凡常身光照一百由旬。诸佛世尊。常法光照无量。还摄光照余光七尺。贾人当知。时胜怨王。闻王提阎婆提宫中。生一太子。福德威神众相具足。即日出家即日成无上正真等正觉道。名闻远布。皆共称言。定光如来至真等正觉。乃至具足修梵行。胜怨王。即遣使往与提阎婆提王相闻知卿生太子。福德威神众相具足。即日出家即日成道。乃至具足修梵行。有大名称流布十方。今可遣来吾欲看之。若卿不遣来者。吾当身自往。彼时提阎婆提王。闻此使语已。即怀愁忧。集诸群臣语言。汝等思惟。当以何报作何等方宜称可彼意。诸臣答言。当问定光如来。随佛有所言教。我等当顺从行之。时王提阎婆提与诸群臣。即往定光佛所。头面礼足。以此因缘具白世尊。世尊告王言。今且止勿怀愁忧。我自当往彼。贾人当知。时王提阎婆提。自于其国。七日供养定光如来。衣服饮食床卧具病苦医药。及比丘僧不令有乏。贾人当知。定光如来过七日后。与诸比丘人间游行。迳诣药山龙王池边。贾人当知。此龙王宫。纵广五百由旬。尔时定光如来及比丘僧。在彼住止。时定光如来放大光明。普照三千大千刹土。昼夜不别。若忧钵钵头摩鸠勿头分陀利华等合。鸟兽不鸣。则知是夜。若忧钵诸花开。及诸众鸟兽鸣者。则知是昼。如是经历十二年中。昼夜不别。时胜怨王。即集诸大臣告言。自忆昔日。有昼有夜。如今何故无昼无夜。若忧钵众华开。及众鸟兽鸣。则知是昼。若花合鸟不鸣。则知是夜。为世有非法。为我行有阙。汝等有过耶。以诚言告我。诸臣白言。王亦无咎。国无非法。我等无过。今定光如来。在呵梨陀山龙王宫。放大光明。普照三千大千刹土。是其威神。令昼夜不别欲知昼夜者。花合鸟不鸣。则知是夜。若花开鸟鸣者。则知是昼。王亦无咎。国无非法。我亦无过。此是定光如来威神。不足畏惧。王问左右臣。呵梨陀山龙王宫。去此远近。臣白王言。去此不远可三十里。王敕左右。严驾羽宝之车。今欲往彼礼拜定光如来。左右即承教。严驾羽宝车已。前白王言。严驾已办。王知是时。贾人当知。王即乘车。诸臣侍从。诣呵梨陀山龙王宫所。到已齐不乘车处。下车步进。前至龙王宫。贾人当知。时王遥见定光如来。颜色端正诸根寂定。见已发欢喜心。即前至定光佛所。头面礼足已在一面坐。时世尊渐与王说微妙法。劝令欢喜。时王闻佛说微妙法劝令欢喜已。前白佛言。如来今正是时。应入莲花城。时定光如来默然受王请。时胜怨王。知佛默然受请已。便从座起头面礼足而去。还至国界。告敕人民。汝等从此莲花城至药山。掘地至膝。以杵捣令坚。以香汁洒地。左右道侧种殖种种花。道侧作栏楯。然好油灯安置其上。作四宝香炉金银琉璃颇梨。时诸人民受王教令已。如上所说。时王即集大臣告言。汝等庄严此莲花大城。除去粪土石沙秽恶。以好细土泥涂其地。悬缯幡盖。烧种种好香。复敷种种[毯-炎+瞿]氀。以种种好花布散其地。时诸臣即受王教。如敕庄严。时胜怨王。复告诸大臣。告下国土人民。莫使有卖香花者。若有卖者。莫使有买者。若有卖买者当重罚。何以故。我自欲供养定光如来至真等正觉故。尔时彼国有一大臣婆罗门。名曰祀施。多饶财宝。真珠虎珀车磲马瑙水精金银琉璃。珍奇异宝不可称计。时彼婆罗门。十二年中祠祀。若彼祠祀众中。有第一多智慧者。当以金钵盛满银粟。或以银钵盛满金粟。并金澡瓶极妙好盖履屣。及二张好[疊*毛]。众宝杂厕杖。并庄严端正好女。名曰苏罗婆提。与之。时彼祠祀众中。第一上座大婆罗门。是王大臣。有十二丑。瞎偻凸背瘿黄色黄头眼青锯齿齿黑手脚曲戾身不与人等凸髋。贾人当知。彼祀施婆罗门作是念。今此上座有十二丑。复是王臣。云何以我宝物并女。与此人耶。复作此念。我今宁可更延祀日。若更有端正聪明智慧婆罗门者。我当与之。贾人当知。雪山南有一仙人。名曰珍宝。少欲乐闲心无所贪。修习禅定获五神通。教授五百梵志使令诵习。时五通仙人。有第一弟子。名曰弥却。父母真正七世清净。亦复教授五百弟子。贾人当知。时弟子弥却。往至珍宝仙人所。白言。我所学者已达。当更学何等。时彼珍宝仙人。即更自造经书。一切婆罗门所不能知。造已告弟子言。汝可诵习之。此书。诸沙门婆罗门所无有者。设诵习者。于诸婆罗门中可得最胜第一。贾人当知。尔时彼弟子。即学习此书诵利已。往至珍宝仙人所。白言。所学已讫。当受习何等。师告言。汝若诵竟。夫为弟子应报师恩。汝今当报。即问言。云何当报师恩。师报言。须五百金钱。时弥却闻师语已。将五百弟子。雪山南人间游行。从国至国从村至村。渐至莲花城闻诸人言。耶若达婆罗门。十二年中祠祀天神。若有聪明第一者。当以金钵盛银粟。银钵盛金粟。并金澡瓶。及好盖极好[疊*毛]。七宝杂厕杖。庄严苏罗婆提端正好女。与之。我今宁可入彼众中。或能得彼五百金钱。贾人当知。弥却即入彼祀中。当入时有大威神光明。时耶若达婆罗门作是念。此人来入祠祀。有大威神光明。今必当移上座去。以此摩纳安置其处。若此摩纳得上座处坐者。汝等当如我所作。皆共高声称善。作众伎乐散花烧香恭敬礼事。时诸人等。即受教言可尔。当如教为之时弥却摩纳入彼众已。从下而问。汝等诵何等经书。诵得几许。随所诵多少者报言。我诵尔许。于摩纳所诵。百倍万倍巨亿万倍。不可为比。不如摩纳。次问二三人乃至百千人。汝等诵何等。知何经书。所诵得几许。随所诵报言。我等诵尔所。于摩纳所诵。百倍万倍巨亿万倍。不相为比。次问第一上座。汝知何经书。诵得几许。其人随所诵多少报言。我诵尔所。弥却摩纳复胜于彼。时弥却摩纳语言。我所诵知者出过汝上。即语其人言。汝去。我坐汝处。上座报言。汝莫使我移我设于此得好供养及金宝。两倍与汝。弥却摩纳报言。正使满阎浮提七宝与我者。我终不取。汝但移去。何以故。我有此法。应坐此座。贾人当知。时彼弥却摩纳。移彼上座即自坐之。当移坐时。地六种震动。即共高声称善。作众伎乐花香供养。贾人当知。彼耶若达。极怀欢喜。自庆无量。金钵盛银粟。银钵盛金粟。金盖七宝厕杖。金银澡瓶。极妙好[疊*毛]。庄严好女。至弥却摩纳前白言。唯愿受此众宝物并受此好女。弥却报言。我不须是。即问言。欲须何等。报言。我须五百金钱。即以五百金钱与之。贾人当知。时弥却摩纳。取此五百金钱已从坐起而去。时苏罗婆提女亦随而去。时弥却摩纳还顾语女言。汝何故随我后行。女报言。父母遣我与君作妻弥却摩纳报言。我今修梵行不须汝。若有爱欲者乃须汝耳时彼女即还入父园中。园中有清净浴池。池中有七茎莲花。五花共一茎香气芬馥花色殊妙。复有二花。共一茎。其香色殊妙见已便生此念。我今观此花极为妙好。我今宁可采此花。与弥却摩纳令心喜悦。即采花置水瓶中。出园外遍求弥却摩纳。时弥却摩纳。还入钵摩大国。见国内人民。扫除道路除去不净。以好土填治平正。以花布地香汁洒之。悬缯幡盖敷好[毯-炎+瞿]氀。见已问城中行人言。今观此城严好乃尔。为用岁节。为用星宿吉日。而修治如是耶。行人报言。今定光佛当来入城。以此故修治如是。弥却摩纳心念言。我今宜可以五百金钱。买好花鬘好香好伎乐幢幡好盖。先当持用供养定光如来。后当更与师求财。即于彼钵摩国。所可求买者皆不可得。何以故。胜怨王制重故。时苏罗婆提女。遥见弥却摩纳来。语言年少。何故行步速疾。汝有所须耶。即报女言。我须好花。问言。摩纳用花作何等。报言。我欲作佛种无上根栽。其女问言。此花已萎枯色变不可复种。云何由此作佛种无上根栽。摩纳报女言。此田良美。正使此花萎枯色变种子燋烂种之故生耳。其女报言。汝可取此花去作佛种无上根裁。摩纳报言。若受我价卖与我者我当取之。其女报言。摩纳何以惜我财物。我父名耶若达。自多饶财宝。摩纳欲买花者。与我作要誓。所生之处常与我作夫耶。摩纳报言。我行菩萨道。一切无所爱惜。有人乞者乃至骨肉不惜。唯除父母。但恐汝常与我作碍。其女报言。汝所生之处。必有大威神。我亦有威神。欲以我施随汝与之。时以五百金钱买五茎莲花。余二茎花。与弥却摩纳言。此是我花寄汝。以上定光如来。何以故。愿与汝所生之处常不相离。贾人当知。尔时弥却摩纳得此七花已。极怀欢喜不能自胜。即诣城东门。当尔之时。不可数亿千众生。皆持花香。悬缯幡盖。作众伎乐。待定光如来。时弥却摩纳。欲前散花。而不能得前。即还问胜怨王言。汝以何故。修治城内。为用岁节会日。为用星宿吉日。而作庄严国土妙好乃尔耶。时王报言。今有定光如来当入城。是故治之耳。摩纳问王言。云何得知如来三十二相耶。王报言。诸婆罗门书谶所记。是故知之耳。摩纳报言。若尔者。我诵此书明知是事。王言。汝若审知者。先可往瞻三十二相。然后我当见之。贾人当知。尔时摩纳闻王语已。欢喜不能自胜。即往城东门外。时众多人民。见摩纳来。欢喜皆与开道。何以故。承王命故。贾人当知。时摩纳遥见如来。心中欢喜。即以七茎花。散定光如来上。佛以威神。即于空中化作花盖。广十二由旬。茎在上叶在下。香气芬馥普覆其国。无不周遍视之无厌。佛所游行花盖随从。时城中人民男女。尽脱新衣敷地。时摩纳所披二鹿皮衣。脱一敷地。时城中人。捉此皮衣掷弃。时摩纳心自念言。定光如来不见愍念。时定光如来。即知彼心所念。化地作泥。无人能敷衣置上者。贾人当知。摩纳复作是念。城内人愚痴无所分别。所应敷处不敷。即持鹿皮衣敷彼泥中。然不奄泥。贾人当知。摩纳发五百岁常髻未曾解。摩纳即问如来。不审世尊。能蹈我发上过耶。报言能。摩纳即解髻发以布泥上。心发愿言。若今定光如来。不授我别者。我当于此处形枯命终。终不起也。时定光如来。知此摩纳至心宿殖善根众德具足。以左足蹈发上而过。语言。摩纳汝还起。汝于当来无数阿僧祇劫。号释迦文如来至真等正觉明行足为善逝世间解无上士调御丈夫天人师佛世尊。闻此别已。即踊在空中。去地七多罗树。发犹布地如故。贾人当知。时定光如来至真等正觉右顾犹如大象王。告诸比丘。汝等莫以足蹈摩纳发上。何以故。此是菩萨发。一切声闻辟支佛所不应蹈上。时数千巨亿万人。皆散花烧香供养其发。贾人当知。时胜怨王大臣十二丑者。闻定光如来授摩纳别号。寻往至胜怨王所。白言。我能堪任二万岁中供养定光如来及众僧。衣被饮食床卧具病瘦医药。王报婆罗门言。汝意快哉。宜知是时。时此婆罗门。于二万岁中供养定光如来及比丘僧。衣服饮食床卧具病瘦医药。已发此愿言我今二万岁中供养定光如来及比丘僧。衣服饮食床卧具病瘦医药。然摩纳移我坐处坐。夺我供养。毁我名誉。缘此福报因缘。在在生处常当毁辱此人。乃至成道。终不相舍离。贾人当知。尔时耶若达婆罗门者。岂异人乎。莫作异观。今执杖释种是。尔时苏罗婆提女者。岂异人乎。今释女瞿夷是。尔时胜怨王大臣十二丑婆罗门者。岂异人乎。莫作异观。今提婆达身是。尔时珍宝仙人者。岂异人乎。莫作异观。今弥勒菩萨是。尔时弥却摩纳者。岂异人乎。莫作异观。今我身是。贾人当知学菩萨道能供养爪发者必成无上道。以佛眼观天下。无不入无余涅槃界而般涅槃。况复无欲无嗔恚无痴。施中第一。为福最尊。受取中第一。而无报应也。尔时贾人兄弟二人。即从座起复道而去

尔时世尊。食贾人糗蜜已。即于树下结加趺坐七日不动。游解脱三昧而自娱乐。七日已从三昧起。由食糗蜜故。身内风动。所以名阎浮提地者。树名阎浮提。去彼不远有呵梨勒树彼树神笃信于佛。即取呵梨勒果来奉世尊。头面作礼已在一面立。树神白佛言世尊。由食糗蜜故。身内风动。愿今可食此果。亦可当食兼以为药得除内风。时世尊慈愍彼故。即便受之告言。汝今归依佛归依法。答言如是。即归依佛归依法。诸神受归依者。呵梨勒树神最初。尔时世尊。食呵梨勒果已。于树下结加趺坐七日思惟不动。游解脱三昧而自娱乐。七日后从三昧起。到时着衣持钵。入郁鞞罗村乞食。渐至郁鞞罗村婆罗门舍中庭默然而住。婆罗门见世尊默然住。发欢喜心。即出食施与世尊。世尊慈愍故。即受彼食。告言。汝今归依佛归依法。答言。如是世尊。我今归依佛归依法。时世尊受此婆罗门食已。更诣一离婆那树下。七日中结加趺坐思惟不动。游解脱三昧而自娱乐。时世尊七日后从三昧起。到时着衣持钵。入郁鞞罗村乞食。渐至郁鞞罗婆罗门舍中庭默然而住。时彼婆罗门妇。是苏阇罗大将女。见如来中庭默然而住。见已发欢喜心即出食施与世尊。世尊慈愍彼故。即受其食。食已告言。汝今归依佛归依法。答言如是。我今归依佛归依法。诸优婆夷。受归依佛归依法者。此郁鞞罗妇。苏阇罗大将女优婆夷为最初。尔时世尊。食彼食已。即还诣离婆那树下。七日结加趺坐思惟不动。游解脱三昧而自娱乐。时世尊七日后。到时着衣持钵入郁鞞罗村乞食。渐次至郁鞞罗婆罗门舍中庭默然而住。时郁鞞罗婆罗门男女。见如来已发欢喜心。即出食施如来。慈愍彼故。即受其食。食已告言。汝等今归依佛归依法。答言尔。我等今归依佛归依法。时世尊食彼食已。即诣文驎树文驎水文驎龙王宫。到彼已结加趺坐七日思惟不动。游解脱三昧而自娱乐。尔时七日天大雨极寒。文驎龙王自出其宫。以身绕佛头荫佛上。而白佛言。不寒不热耶。不为风飘日曝。不为蚊虻所触娆耶。尔时七日后雨止清明。时龙王已见雨止清明。还解身不复绕佛。即化作一年少婆罗门。在如来前。合掌胡跪。礼如来足。时世尊七日后从三昧起。即以此偈而赞曰

  离欲欢喜乐　　观察法亦乐
  世间无恚乐　　不娆于众生
  世间无欲乐　　越度于欲界
  能伏我慢者　　此最第一乐

尔时文驎龙王。前白佛言。我所以身绕如来头荫如来者。不欲娆触如来。但恐如来身为寒热风飘日曝蚊虻所娆。以是故。绕佛身头荫其上耳。佛告龙王。汝今归依佛法。答言如是。我今归依佛法。是谓畜生中受二归依。龙王为首。尔时世尊。游文驎龙王树下住已。便往诣阿踰波罗尼拘律树下。到已敷坐具结加趺坐。作是念言。我今已获此法。甚深难解难知永寂休息微妙最上智者。能知非愚者所习。众生异见异忍异欲异命。依于异见乐于樔窟众生。以是乐于樔窟故。于缘起法甚深难解。复有甚深难解处。灭诸欲爱尽涅槃。是处亦难见故。我今欲说法。余人不知。则于我唐劳疲苦耳。尔时世尊说此二偈。非先所闻。亦未曾说

  我成道极难　　为在樔窟说
  贪恚愚痴者　　不能入此法
  逆流回生死　　深妙甚难解
  着欲无所见　　愚痴身所覆

四分律卷第三十一四分律卷第三十二(二分之十一)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    受戒揵度之二

尔时世尊作是思惟已。默然而不说法。时梵天王于梵天上。遥知如来心中所念已。念世间大败坏。如来今日获此妙法。云何默然而住。令世间不闻耶。尔时梵天如力士屈申臂顷。从彼而来到如来前。头面礼已在一面立。白世尊言。唯愿如来说法。唯愿善逝说法。世间众生。亦有垢薄智慧聪明易度者。能灭不善法成就善法。尔时世尊告梵天王。如是如是。梵王。如汝所言。我向者在闲静处而生此念言。我今已获此法。此法甚深难知难解。永寂休息微妙最上。贤圣所知非愚者所习。众生异见异忍异欲异命。依于异见乐于樔窟。众生以是乐于樔窟故。于缘起法甚深难解。复有甚深难解处。灭诸欲爱尽涅槃。是处亦难见故。我今欲说法。余人不知。则于我唐劳疲苦耳。时世尊曾见有此二偈。非先所闻。亦未曾说

  我成道极难　　为在樔窟说
  贪恚愚痴者　　不能入此法
  逆流回生死　　深妙甚难解
  着欲无所见　　愚闇身所覆

是故梵天。我默然而不说法。尔时梵天。复白佛言。世间大败坏。今如来获此正法。云何默然不说。令世间不闻耶。唯愿世尊。时演正法。流布于世。世间亦有垢薄聪明众生易度者。能灭不善法。成就善法。尔时梵天。说此语已。复说偈言。

  摩竭杂垢秽　　而佛从中生
  愿开甘露门　　为众生说法

尔时世尊。受梵天劝请已。即以佛眼观察世间众生。世间生世间长。有少垢有多垢。利根钝根。有易度有难度。畏后世罪。能灭不善法。成就善法。犹如忧钵池。钵头池。拘牟头池。分陀利池。忧钵。钵头。拘牟头。分陀利华。有初出地未出水。或有已出地与水齐。或有出水尘水不着。如来亦复如是。以佛眼观世间众生。世间生世间长。少垢多垢。利根钝根。易度难度。畏后世罪。能灭不善法。成就善法。尔时世尊。即与梵天。而说此偈。

  梵天我告汝　　今开甘露门
  诸闻者信受　　不为娆故说
  梵天微妙法　　牟尼所得法

尔时梵天。知世尊受劝请已。礼世尊足。右绕三匝而去。即没不现。尔时世尊。复作是念。我今当先与谁说法。闻便即解。即念阿兰迦兰垢薄利根聪明有智。我今宁可先与说法。念已复更智生。今阿兰迦兰命终已经七日。亦有诸天。来白我言。阿兰迦兰命终来七日。时佛作是念言。何其苦哉。汝有所失。此法极妙如何不闻。若得闻者速疾得解。尔时世尊复作是念。我今当先与谁说法速疾得解。念言。郁头蓝子垢薄。利根聪明有智。我今宁可先与说法。作是念已。复更智生。郁头蓝子昨日命终。诸天亦来白我言。郁头蓝子昨日命终。佛言。何其苦哉。汝有所失。此法微妙如何不闻。若得闻者速得解脱

尔时世尊复作是念。我今先当与谁说法。闻我法者速得解脱。念言。此五比丘执事劳苦。不避寒暑侍卫供养。我今宁可先与说法耶。时世尊复作是念。五比丘今于何处居止。即以天眼清净过于天人。观五比丘。于波罗奈国仙人鹿苑中。见已即往诣彼仙人鹿苑所。时见优陀耶梵志。亦在路行。遥见世尊。前白佛言。瞿昙。诸根寂静颜色怡悦。汝师是谁。为从谁学。为学何法。尔时世尊以偈报言

  一切智为上　　一切欲爱解
  自然得解悟　　云何从人学
  我亦无有师　　亦复无等侣
  世间唯一佛　　澹然常安隐
  我是世无著　　我为世间最
  诸天及世人　　无有与我等
  欲于波罗奈　　转无上法轮
  世间皆盲冥　　当击甘露鼓

梵志问言。向瞿昙所说我无著最胜者。愿闻其义。佛以偈报言。

  我脱一切结　　得尽于诸漏
  我胜诸恶法　　优陀我最胜

尔时梵志默然。时世尊舍去。往仙人鹿苑所。五比丘遥见世尊来。各各相诫敕言。此瞿昙沙门。行不着路迷荒失志。若来至此。汝等莫与言语。亦莫礼敬。更别施小座令坐。时世尊渐渐至五比丘所。时五比丘不自觉。皆起迎礼敬。或有为敷座者。或有为执衣钵者。或取水与洗足者。时世尊作是念。此愚痴人。不能坚固其志共作制限。而复自坏。何以故。不堪佛威神故。我今宁可即就座而坐。五比丘见如来坐已。皆称名汝如来。时佛告五比丘言。汝等莫称名汝如来。至真等正觉。如来威神无量最胜。汝若称名汝如来。长夜受苦无量。时五人语言。瞿昙。汝本所造苦行执持威仪。犹不能得上人法神通智见。有所增益得自娱乐。况今行不着路迷荒失志。佛告五人言。汝等曾闻我有二言返覆不。报言瞿昙。昔来不闻有二言。佛言。汝等来。我今已获甘露。当教授汝等。汝等能承受我言者。如是不久必有所得。所以族姓子。以信牢固从家舍家。为道修无上梵行者。于现法中自身作证。而自娱乐。生分已尽。梵行已立。所作已办。更不受有。比丘出家者。不得亲近二边。乐习爱欲。或自苦行。非贤圣法。劳疲形神不能有所办。比丘除此二边已。更有中道。眼明智明永寂休息。成神通得等觉。成沙门涅槃行。云何名中道。眼明智明永寂休息。成神通得等觉。成沙门涅槃行。此贤圣八正道。正见正业正语正行正命正方便正念正定。是谓中道。眼明智明永寂休息。成神通等正觉。成沙门涅槃行。四圣谛。何谓为圣谛。苦圣谛。苦集圣谛。苦尽圣谛。苦出要圣谛。何等为苦圣谛。生苦老苦病苦死苦。怨僧会苦爱别离苦所欲不得苦。取要言之五盛阴苦。是谓苦圣谛。复次当知苦圣谛。我已知此。当修八正道。正见正业正语正行正命正方便正念正定。何等为苦集圣谛。缘爱本所生。与欲相应爱乐。是谓苦集圣谛。复次当灭此苦集圣谛。我已灭作证。当修八正道。正见乃至正定。云何名苦尽圣谛。彼爱永尽无欲灭舍出要解脱永尽休息无有樔窟。是谓苦尽圣谛。复次当以苦尽圣谛为证。我已作证当修八正道。正见乃至正定。何等是苦出要圣谛。此贤圣八正道。正见乃至正定。是谓苦出要圣谛。复次当修此苦出要圣谛。此苦出要圣谛。我已修此。苦圣谛本未闻法。智生眼生觉生明生通生慧生得证。复次当知。此苦圣谛本所未闻法。智生乃至慧生。复次我已知苦圣谛本未闻法。智生眼生觉生明生通生慧生。是谓苦圣谛。此苦集圣谛本未闻法。智生眼生觉生明生通生慧生。复次当灭此苦集圣谛本未闻法。智生乃至慧生复次我已灭。此苦集圣谛本未闻法。智生乃至慧生。是谓苦集圣谛。此苦尽圣谛本所未闻法。智生乃至慧生。复次此苦尽圣谛应作证本未闻法。智生乃至慧生。复次此苦尽圣谛。我已作证本未闻法。智生乃至慧生。此苦出要圣谛本未闻法。智生乃至慧生。复次当修苦出要圣谛本未闻法。智生乃至慧生。复次我已修此苦出要圣谛本未闻法。智生乃至慧生。是谓四圣谛。若我不修此四圣谛。三转十二行。如实而不知者。我今不成无上正真道。然我于四圣谛三转十二行。如实而知。我今成无上正真道而无疑滞。如来说此四圣谛。众中无有觉悟者。如来则为不转法轮。若如来说四圣谛。众中有觉悟者。如来则为转法轮。沙门婆罗门魔若魔天天及世间人所不能转。是故当勤方便修四圣谛。苦圣谛苦集圣谛。苦灭圣谛。苦出要圣谛。当如是学。尔时世尊。说此法时。五比丘阿若憍陈如。诸尘垢尽得法眼生。尔时世尊。已知阿若憍陈如心中所得。便以此言而赞曰。阿若憍陈如已知。阿若憍陈如已知。从是已来名阿若憍陈如。时地神闻如来所说。便即相告语。今如来至真等正觉。于波罗奈仙人鹿苑所。转无上法轮本所未转。沙门婆罗门魔若魔天天及人。不能转者。地神唱声。闻四天王忉利天焰天兜术天化乐天他化天。展转相告语言。今如来至真等正觉。于波罗奈仙人鹿苑中。转无上法轮。沙门婆罗门魔若魔天天及人所不能转。尔时一念顷须臾间。展转相告语声乃彻梵天。尔时尊者阿若憍陈如。见法得法成办诸法已获果实。前白佛言。我今欲于如来所修梵行。佛言来比丘。于我法中快自娱乐。修梵行尽苦原。时尊者憍陈如。即名出家受具足戒。是谓比丘中初受具足戒。阿若憍陈如为首。时尊者阿若憍陈如。前白佛言。我今欲入波罗奈城乞食。愿听。佛言。比丘宜知是时。时尊者阿若憍陈如。即从座起。头面礼世尊足已。着衣持钵入波罗奈城乞食。尔时世尊。与尊者阿湿卑摩诃摩男比丘说法。劝令欢喜。所谓法者。布施持戒生天之法。呵欲不净有漏系缚。赞叹出离为乐。即于座上诸尘垢尽得法眼净。见法得法获果实。前白佛言。我等欲于如来所出家修梵行。佛言。来比丘。于我法中快自娱乐。修梵行尽苦源。即名出家受具足戒。时阿湿卑摩诃摩男比丘。前白佛言。我等欲入波罗奈城乞食。佛言。比丘宜知是时。时尊者阿湿卑等。即从坐起头面礼世尊足已。着衣持钵入波罗奈城乞食。时世尊与婆提婆敷二人说法。劝令欢喜。所谓法者。布施持戒生天之法。呵欲不净有漏系缚。赞叹出离为乐。即于座上诸尘垢尽得法眼净。见法得法成办诸法。前白佛言。我等欲于如来所修梵行尽苦源。佛言。来比丘。于我法中快自娱乐。修梵行尽苦源。即名受具足戒。时婆提婆敷二人。前白佛言。我等欲诣波罗奈城乞食。佛言。宜知是时。时尊者婆提等。即从坐起头面礼世尊足已。着衣持钵入波罗奈城乞食时世尊与三人说法。二人乞食。二人所得食。足六人共食。若世尊五人中与二人说法。三人乞食。三人所得食。足六人共食。尔时世尊劝喻五比丘。渐渐教训。令发欢喜心。时世尊食后告五比丘。比丘。色无我。若色是我者。色不增益。而我受苦。若色是我者。应得自在。欲得如是色不用如是色。以色无我故。而色增长。故受诸苦。亦不能得随意欲得如是色便得。不用如是色便不得。受想行识亦复如是。云何比丘。色是常耶。色无常耶。诸比丘白佛言。世尊。色无常。佛言。若色无常者。是苦是乐耶。诸比丘白佛言。世尊。色是苦。佛言。若色无常苦者。变易法。汝等云何。色是我是彼是彼所是我所不。对曰非也。受想行识亦复如是。是故诸比丘。一切色过去未来现在色。若内若外若粗若细若好若丑若远若近一切色。非我非彼。非彼所非我所。应作是如实正观智慧。受想行识亦复如是。如是比丘。贤圣弟子作是观已。厌患色已。厌患便不着。已不着便得解脱。已解脱便得解脱智。我生已尽梵行已立所作已办。更不复受有。受想行识亦复如是。尔时世尊说此法时。五比丘一切有漏心解脱。得无碍解脱智生。尔时此世间有六罗汉。五弟子如来至真等正觉为六。

尔时世尊。游波罗奈国。时波罗奈国有族姓子。名耶输伽。父母只有此一子。愍念瞻视不去目前。时父母与设三时殿。春夏冬使其子常游戏其中五欲娱乐。时童子于五欲中极自娱乐已。疲极眠睡。眠睡觉已。即观第一殿。又见诸妓人所执乐器纵横狼藉。更相荷枕头发蓬乱。却卧鼾睡齘齿寱语。见已恐怖身毛为竖。即生厌离意不欲与会。此为苦哉有何可贪。即舍所居殿。更诣中殿。到彼观其殿舍并妓人。如前无异。倍生恐怖身毛为竖。即生厌离不欲与会。此为苦哉有何可贪。即舍去诣第三殿。所见亦复如上。倍生恐怖身毛为竖。生厌离心不欲与会亦复如上。即还出殿诣尸佉城门。时尸佉门神。遥见童子来。见已便生是念。此童子来必欲见如来。更无余道。我当开门使去。即与开门。时童子出尸佉城门已。诣婆罗河侧。到已于河岸上。解金屐度婆罗河。诣仙人鹿苑所。尔时世尊。在露处经行。遥见童子来。即敷座而坐。诸佛常法圆光遍照。耶输伽童子。遥见如来颜貌端正。生喜悦心。前至世尊所。到已白言。我今苦厄无所归趣。愿救济我。佛告童子。来此处无为。此处无厄。此处安隐。欲求永寂无为者。欲尽无爱处。灭尽涅槃也。尔时耶输伽童子。礼世尊已在一面坐。世尊渐与说法。劝令发欢喜心。所谓法者。布施持戒生天之法。呵欲不净。赞叹出离为乐。即于座上诸尘垢尽得法眼净。见法得法成就诸法。自身得果证。前白佛言。我欲于如来所净修梵行。佛言。比丘来。于我法中快自娱乐。修梵行尽苦源。时耶输伽。即受具足戒。第一殿舍宫人妓女。尽皆睡觉。觉已求觅耶输伽不见。往至中殿求之亦不见。复至第三殿舍求索亦复不见。时诸宫人妓女。往至其母所。白言大家。今者耶输伽不知所在。时母即速疾至其父所。告言知不。今不知儿为何所在。时父在彼中殿前。沐浴梳头速疾敛发。即敕左右人言。于波罗奈国断诸巷道。自出尸佉城门。至婆罗河所。见子金屐在河侧。便作是念。我子必当渡河。即寻迹渡河。往仙人鹿苑中。尔时如来。遥见耶输伽父来。即以神力使耶输伽父见佛不见其子。至佛所白言。大沙门。颇见我子耶输伽不。佛言。汝今且坐。或当见汝子。耶输伽父念言。此大沙门甚奇甚特。乃见慰劳如是也。时耶输伽父。礼佛足已在一面坐。世尊渐与说法。令发欢喜心呵欲不净。赞叹出离为乐。即于座上诸尘垢尽得法眼净。见法得法成办诸法。自审得果证已。前白佛言。我今归依佛归依法归依僧。唯愿世尊。听为优婆塞。自今已去尽形寿。不杀生乃至不饮酒。是为最初优婆塞三自归耶输伽父为首。尔时世尊。与耶输伽父说法。时耶输伽身漏尽意解。得无碍智解脱尔时世间有七罗汉。弟子有六佛为七。尔时世尊。即摄神足。使耶输伽父见子去佛不远坐。即到耶输伽所语言。汝母在后失汝。不知所在极怀愁忧。乃欲自害。汝可往瞻省。勿令自害。时耶输伽。瞻视世尊颜。时世尊告耶输伽父言。云何族姓子。学智学道诸尘垢尽得法眼净。彼作如是观已。有漏心得解脱。云何长者。汝已舍欲还复能习欲不耶。对曰不也。如是耶输伽族姓子。已学智学道。诸尘垢尽得法眼净。彼作如是观已有漏心得解脱。终不复习欲如本在俗时也。今耶输伽族姓子。善获大利。学智学道无漏心解脱。诸尘垢尽得法眼净。作是观已有漏心解脱。唯愿世尊。今受我请。及耶输伽并侍比丘。尔时世尊默然受请。然耶输伽不肯受别请。世尊未听我受别请。佛言。自今已去听受别请。请有二种。有僧次请有别请。时耶输伽父。知如来默然受请。即从坐起礼佛足而去。语耶输伽母及其本二言。汝今知不。耶输伽。身在大沙门所修梵行。我今日请大沙门及耶输伽侍从。后来汝今知时。可供办所须。耶输伽母及其本二。即办具种种所须饮食已。往白时到。尔时世尊。到时着衣持钵。耶输伽侍从通已二人往其父舍。到已就座而坐。时耶输伽母及本二奉世尊种种所须饮食。食讫摄钵。更取一小座于如来前坐。尔时世尊。渐次与说微妙法。劝令发欢喜心。即于座上诸尘垢尽得法眼净。见法得法成就诸法。即白佛言。自今已去归依佛法僧。听为优婆夷。我自今已去尽形寿。不杀生乃至不饮酒。是谓最初受三自归优婆夷。耶输伽母及其本二为首。时世尊。与耶输伽母及其本二说法已。即从坐起而去。尔时世尊。游波罗奈国。时耶输伽。有少小同友四人。在波罗奈住。一名无垢。二名善臂。三名满愿。四名伽梵婆提。闻耶输伽在大沙门所修梵行。各念言。此戒德必不虚。修沙门梵行亦不虚。何以故。乃使此族姓子从其受学修梵行。彼族姓子。能于彼修梵行。我等宁可于大沙门所修梵行耶。尔时同友四人。即往诣耶输伽所语言。汝今于大沙门所修梵行为胜耶。耶输伽报言。我从大沙门所修梵行。甚为微妙。此四人语耶输伽言。我亦欲于大沙门所出家修梵行。时耶输伽。即将往世尊所。头面礼足在一面坐。白世尊言。此四同友。在波罗奈住。今欲从如来出家修梵行。愿慈愍听出家修梵行。时世尊即听。渐次为说胜法。胜法者。布施持戒生天之法。呵欲不净赞叹出离为乐。即于座上诸尘垢尽得法眼净。见法得法成就诸法得果证。前白佛言。我等欲从如来所修梵行。佛言。来比丘。于我法中快修梵行尽苦源。即名为出家受具足戒。即如先所见重观察。便得尽有漏心得解脱无碍解脱智生。时此世间有十阿罗汉。弟子如来为十一。尔时世尊。游波罗奈国。时耶输伽少小同友有五十人。在波罗奈城外住。闻耶输伽在大沙门所修梵行。各生念言。此戒德所修梵行不虚。何以故知。今此族姓子。在大沙门所修梵行。以是故知。彼族姓子。能于彼修梵行。我今宁可往诣大沙门所修梵行耶。尔时同友五十人等。往诣耶输伽所语言。此处胜耶。修梵行妙耶。耶输伽报言。此处胜修梵行亦妙此五十人语耶输伽言。我亦欲于大沙门所出家修梵行。时耶输伽。即将往世尊所。头面礼足在一面坐。坐已白世尊言。此五十同友。在波罗奈城外住。今欲从如来出家修梵行。愿世尊。慈愍听出家修梵行。时世尊即听。渐次为说胜法。所谓法者。布施持戒生天之法。呵欲不净赞叹出离为乐。即于座上诸尘垢尽得法眼净。见法得法成就诸法得果证。前白佛言。我等欲从如来所出家修梵行。佛言来比丘。于我法中快修梵行尽苦源。即名为受具足戒。如先所见重观已。有漏心解脱无碍解脱智生。时此世间。有六十阿罗汉。弟子如来为六十一。尔时世尊。游波罗奈国。时有同友五十人。来向波罗奈国。欲成婚姻。在波罗奈城外处处游观。渐诣仙人鹿野苑。时五十人等遥见世尊颜貌端正众相殊特。见已发欢喜心。于如来所。即前头面礼足。在一面座已。时世尊与说胜法。劝令发欢喜心。所谓胜法者。布施持戒生天之福。呵欲不净赞叹出离为乐。即于坐上诸尘垢尽得法眼净。得法见法成就诸法得果证。前白佛言。世尊。我等欲从如来所出家修梵行。佛言。来比丘。于我法中快修梵行尽苦源。即名受具足戒。如先所见重观察已。有漏心解脱无碍解脱智生。时世间有百一十阿罗汉。弟子佛为百一十一。尔时世尊。游波罗奈国。时伊罗钵罗龙王。自出恒河水所居宫。手执金钵盛满银粟。银钵盛满金粟。将诸龙女。八日十四日十五日而说此偈。

  何者王中上　　染者与染等
  云何得无垢　　何者名为愚
  何者流所漂　　得何名为智
  云何流不流　　而名为解脱

龙王言。若有宣畅此偈义者。我当持金钵盛银粟。银钵盛金粟。及所将龙女。尽当与之。我求如来等正觉。时众人大集。或有人往观金钵银粟银钵金粟。或有往观诸龙女者。或有往欲与龙王分别偈义者。尔时有一梵志。名那罗陀。住波罗奈城侧。少垢利根多智聪明。时那罗陀。出波罗奈城。诣龙王所。到已语龙王言。汝今说偈。我欲与汝广演其义。尔时伊罗钵罗龙王。即以偈向那罗陀说言

  何者王中上　　染者与染等
  云何得无垢　　何者名为愚
  何者流所漂　　得何名为智
  云何流不流　　而名为解脱

龙王言。若有宣畅分别此偈义者。我当持金钵盛银粟。银钵盛金粟。及所将龙女。尽当与之。我求如来等正觉。时那罗陀梵志。语伊罗钵龙王言。且止龙王。却后七日当广演此偈义。时那罗陀梵志。诵此偈通利。还入波罗奈城。复作是念。此中何者高才大德沙门婆罗门。我当以此偈问之。复作是念。此不兰迦叶。众中长大为人师导。众人宗仰名称远闻。所知如海多人供养。我今宜可往彼问此偈义耶。时那罗陀梵志。往至迦叶所。以此偈与不兰迦叶说。时迦叶闻此偈实不知。即蹙眉嗔目出恶音声努项脉胀嗔恚炽盛不答。彼即舍去。作是念。今当更于何处求沙门婆罗门而问此偈义。中路复作是念。末佉梨劬奢离阿夷头翅舍钦婆罗牟提侈婆休迦栴延讪若毗罗吒子尼揵子等。在于众中为师首。众人宗仰名称远闻。所知如海多人供养。我今宜可往彼问此偈义。时那罗陀梵志。往至末佉梨尼干子等所。以此偈向说。彼闻此偈实不知。即蹙眉嗔目出恶音声努项脉胀嗔恚炽盛不能答。见已即复舍去。复作是念。更于何处求沙门婆罗门而问此义耶。即念言。此大沙门瞿昙。在大众中为师首。众人宗仰名称远闻。所知如海多人供养。我今宜可往彼问此偈义。复作是念。余有沙门婆罗门耆年出家学久。犹尚不能解此偈义。况此沙门瞿昙。年尚幼稚出家日浅。岂能解耶。复作是念。年虽幼稚亦不可轻。亦有年少出家学道得阿罗汉神足自由者。我今当往诣彼沙门问此偈义。时那罗陀梵志。出波罗奈城。往诣仙人鹿苑所。到已举手与如来共相问讯。在一面坐。白世尊言。欲有所问。若沙门瞿昙听者我当相问。佛言梵志。汝欲有问随意。时那罗陀复生此念。我见彼诸沙门婆罗门。无有赐我颜色。不与我解。亦不言随所问。今所见者甚为奇特。尔时梵志。即以偈向佛说。

  何者王中上　　染者与染等
  云何得无垢　　何者名为愚
  何者流所漂　　得何名为智
  云何流不流　　而名为解脱

尔时世尊。以偈报那罗陀梵志言

  第六王为上　　染者与染等
  不染则无垢　　染者谓之愚
  愚者流所漂　　能灭者为智
  能舍一切流　　天及于世间
  不与流相应　　不为死所惑
  能以念为主　　诸流得解脱

尔时那罗陀。从如来闻此偈。善讽诵读已。即从坐起礼世尊足绕三匝而去。还入波罗奈城。时伊罗钵龙王。七日后自出龙宫。将诸龙女。持金钵盛银粟银钵盛金粟。而来并说此偈。

  何者王中上　　染者与染等
  何者名无垢　　何者名为愚
  何者流所漂　　得何名为智
  云何流不流　　而名为解脱

若有能演说此偈义者。当以此金钵盛银粟。银钵盛金粟。及所将龙女尽当与之。欲求无上正真等正觉。尔时多有人聚集会。或有看金钵盛银粟者。或有看银钵盛金粟者。或有看龙女者。或有欲听那罗陀梵志解说偈义者。尔时那罗陀梵志。出波罗奈城。往诣伊罗钵龙王宫。语龙王言。所论偈者一一说之。吾当与汝分别解义。时龙王即以此偈。向那罗陀说。

  何者王中上　　染者与染等
  何者名无垢　　何者名为愚
  何者流所漂　　得何名为智
  云何流不流　　而名为解脱

时那罗陀。复以偈报龙王言。

  第六王为上　　染者与染等
  不染则无垢　　染者谓之愚
  愚者流所漂　　能灭者为智
  能舍一切流　　天及于世间
  不与流相应　　不为死所惑
  能以念为主　　诸流得解脱

时伊罗钵龙王问言。云何梵志。汝自有此智而说耶。为从沙门婆罗门闻而说耶。报言龙王。我无此智说。今有沙门瞿昙释子出家学道。成无上正真等正觉。从彼闻而说。时龙王便作是念。释迦文如来至真等正觉。已出现于世耶。已出现于世耶。即问那罗陀言。今日如来为在何处住。报言。今近在仙人鹿苑住。时龙王语那罗陀。可共至仙人鹿苑所。礼如来至真等正觉。时那罗陀及龙王将八万四千众前后围绕。往仙人鹿苑。到世尊所。到已礼世尊足。在一面立。那罗陀共相问讯。在一面坐。八万四千众。或有礼如来足在一面立者。或有擎拳共相问讯在一面坐者。或有向如来自称姓名而在一面坐者。或叉手视如来在一面坐者。或有默然不语在一面坐者。八万四千众已坐定。世尊渐次为说胜法。劝令发欢喜心。所谓法者。布施持戒生天之法。呵欲不净赞叹出离为乐。时那罗陀及八万四千众。即于座上诸尘垢尽得法眼净。见法得法成就诸法得果证。前白佛言。我等自今归依佛法僧。唯愿世尊。听为优婆塞。尽形寿不杀生乃至不饮酒。时伊罗钵龙王。悲泣不能自胜。或时踊跃欢喜。时那罗陀语龙王言。今者悲泣。为惜金钵盛银粟。银钵盛金粟。及龙女等。而悲泣耶。龙王报言。我不以此诸物故悲泣。那罗陀当知。汝今取金钵盛银粟。银钵盛金粟。应取无苦。若须波罗奈城中。刹利女。婆罗门女。居士女。工师女者。我当劝令与何以故。那罗陀。汝不能与龙女共会。那罗陀。报龙王言。金钵盛银粟银钵盛金粟我不须。龙女亦不须。我今欲于如来所修梵行。尔时那罗陀梵志。见法得法成就诸法自知得果证。前白佛言。唯然世尊。我今欲于如来所出家修梵行。佛言来比丘。于我法中快修梵行尽苦源。即名受具足戒。如先所见重观察已。有漏心解脱无碍解脱智生。时世间有一百一十一阿罗汉。佛为一百一十二。尔时世尊告龙王言。汝何故悲泣不能自胜耶。时龙王白佛言。世尊。我念古昔迦叶佛时。修梵行故犯戒。坏伊罗钵树叶。此当有何报应。世尊。我由此业报故。生长寿龙中。如来般涅槃法灭尽后。我乃当转此龙身。我失彼此二边利。不得修梵行。以是故。悲泣不能自胜。尔时世尊。复问龙王言。汝以何缘复欢喜耶。龙王白佛言。我身自从迦叶佛闻。而告我言。却后当有释迦牟尼佛出现于世。为如来至真等正觉。如今所见如实不异。我作此念。未曾有。如来智慧所见。如实无二。以是故。欢喜踊跃不能自胜。佛告龙王。汝今归依佛法僧。答言如是。我今归依佛法僧。是为畜生最初受三自归。伊罗钵龙王为首。尔时世尊。以偈告诸比丘

  我已脱一切　　天及于世间
  汝亦脱一切　　天及于世间

尔时魔波旬。以偈向世尊说

  汝为诸缚缚　　天及于世间
  一切众缚缚　　沙门不得脱

尔时世尊。复以偈报波旬言

  我脱于诸缚　　天及于世间
  一切缚得脱　　我今已胜汝

尔时波旬。复以偈报佛言

  汝内有结缚　　心在于中行
  以是随逐汝　　沙门不得脱

尔时世尊。复以偈报波旬言

  世间有五欲　　意识为第六
  我于中无欲　　我今得胜汝

时魔波旬作是念。如来鉴察我意皆悉知之。即怀愁忧不乐自隐形还归本处。尔时世尊。告诸比丘。说此偈言。

  我今一切解　　天及于世间
  汝等一切解　　天及于世间

佛告诸比丘。汝等人间游行。勿二人共行。我今欲诣优留频螺大将村说法。对曰。如是世尊。诸比丘受教已。人间游行说法时。有闻法得信欲受具足戒。时诸比丘。将欲受具足戒者。诣如来所。未至中道。失本信意不得受具足戒。诸比丘以此事白佛。佛言。自今已去听汝等即与出家受具足戒欲受具足戒者。应作如是教令。剃须发着袈裟脱革屣右膝着地合掌。教作如是语。我某甲归依佛归依法归依僧。今于如来所出家。如来至真等正觉是我所尊。如是第二第三竟。我某甲已归依佛归依法归依僧。于如来所出家。如来至真等正觉是我所尊。如是第二第三。佛言。自今已去听三语。即名受具足戒。尔时世尊。游郁鞞罗劫波园中。时有郁鞞罗跋陀罗跋提同友五十人。将诸妇女于此园中共相娱乐。其同友中一人无妇。以钱雇一淫女将来共相娱乐。淫女即偷其人财物逃走。时诸同友见其失物。即于园中求觅此淫女。遥见如来颜貌端正诸根寂定。见已便发欢喜心。于如来所。即前白世尊言。大沙门。颇见一妇人来此不。佛问言。汝等是何童子。求何等妇女耶。答言。大沙门当知。郁鞞罗跋陀罗跋提同友五十人。于此园中与诸妇女共相娱乐。一同友无妇。以钱雇一淫女。将来在此共相娱乐。即便偷其财物逃走。不知所在。我今同友等。故来于此求觅此女。佛问言。云何童子。宁自求耶。求妇女耶。诸童子言。宁自求不求妇女。佛言。诸童子且坐。与汝说法。时童子等礼世尊足在一面坐。尔时世尊。与童子等说胜法。劝令发欢喜心。所谓法者。布施持戒生天之法。呵欲不净赞叹出离为乐。即于座上诸尘垢尽得法眼净。见法得法成就诸法得果证。前白佛言。我等诸童子。欲于如来所出家修梵行。佛言来比丘。于我法中快修梵行尽苦源。即名为受具足戒。

尔时世尊。游郁鞞罗。时郁鞞罗婆界有梵志。名郁鞞罗迦叶。于彼住止。将五百螺髻梵志。为最尊长师首。鸯伽摩竭国中。皆称为阿罗汉。尔时世尊。诣郁鞞罗迦叶所。到已语言。吾欲借室寄止一宿。可尔以不。报言不惜。但此室有毒龙极恶。恐相害耳。佛言无苦。但见借。龙不害我。迦叶报言。此室宽广欲宿随意。时世尊即入石室。自敷坐具结加趺时。直身正意。尔时毒龙。见如来默然坐已即放烟。如来亦放烟。龙见如来放烟已复放火。如来亦复放火。时石室中烟火俱起。时迦叶遥见石室烟火俱起。便作是念。瞿昙沙门极端正。可惜必为毒龙所害无疑。时世尊作是念。我今宜可取此毒龙不伤其体而降伏之。即以神力降之。不伤龙身。毒龙身放烟火光渐渐减少。如来身中放无数种种光明。青黄赤白琉璃颇梨色。时如来即降毒龙。盛着钵中。明日清旦。往郁鞞罗迦叶所语言。汝欲知不。所言毒龙者。吾已降之。今在钵中。迦叶念言。此沙门瞿昙。有大威德神足自在。乃能降此毒龙无所伤害。此沙门瞿昙。虽神足自在得阿罗汉。不如我得阿罗汉。迦叶言。大沙门。可于此止宿。吾当给食。佛告迦叶。汝能身自白时到者。我当受汝请。迦叶白言。大沙门。但在此止宿。我当自来白时到。时如来即于迦叶所食已。还石室宿。时世尊其夜寂静入火光三昧。照彼石室烔然大明。时迦叶夜起见石室火光烔然。见已便作是念。今大沙门极端正。止彼石室为火所烧。即将徒众。围绕石室住。清旦迦叶白佛言。今时已到。可往就食。又复问言。大沙门。昨夜何故有大火光。佛告迦叶。我昨夜入火光三昧。令此石室烔然大明。迦叶念言。此大沙门有大威神。于夜寂静入火光三昧。照此石室。沙门瞿昙。虽得阿罗汉。不如我得阿罗汉。尔时世尊。食迦叶食已。更诣一林于彼止宿。明日迦叶往世尊所。白时到可往就食。佛告言。汝并在前。吾寻后往。尔时世尊。遣迦叶已。诣阎浮提树。名阎浮提者。由有阎浮提树故。如来往彼取阎浮果。先至迦叶座上而坐。迦叶后到。见佛先在坐。见已白言。云何大沙门。先遣我前来。今云何已在前至耶。佛告迦叶。我发遣汝在前已。我诣阎浮提。取阎浮果。先来至此坐。此果色好香美。汝可食之。迦叶报言。止止大沙门。此便为供养我已。大沙门自食。此是大沙门所应食。迦叶念言。此大沙门。有大神足自在得阿罗汉。不如我得阿罗汉。时世尊食迦叶食已。还本林住。时迦叶明日清旦往诣世尊所。到已白言。今时已到宜可就食。佛告迦叶。汝并在前。吾寻后至。时世尊遣迦叶已。诣阎浮提。去彼不远。有呵梨勒树。取呵梨勒果。先迦叶至在座而坐。时迦叶后至。见如来先至。问言大沙门。先遣我言当寻后至。今云何先至坐我座耶。佛告迦叶。我遣汝后。诣阎浮提。去彼不远有呵梨勒树。我诣彼取呵梨勒果来到此。此呵梨勒果。色好香美。可取食之。迦叶报言。大沙门。止止此便为得供养已。大沙门可自食。此是大沙门所应食。迦叶念言。此大沙门。有神足自在得阿罗汉。虽尔不如我得阿罗汉。阿摩勒果鞞醯勒果亦如是。时如来食迦叶食已。还本林止宿。明日迦叶。往诣如来所白言。时已到可就食。佛告迦叶。汝并在前。吾寻后往。世尊遣迦叶已。北诣郁单越。取自然粳米还。先至在座而坐。迦叶后至。见已问言。大沙门。先遣我言。并在前当寻后至。云何今者先至耶。佛言。吾遣汝后北至郁单越。取自然粳米。来至此坐。此米色好香美。汝可取食之。迦叶报言。且止。此便为得供养已。可自取食之。此是大沙门所应食者。迦叶念言。此大沙门。有神足自在得阿罗汉。虽尔不如我得阿罗汉。时世尊食已还诣本林止宿明日清旦。迦叶往诣佛所白言。时到可就食。佛告迦叶。汝并在前。吾正尔后往。时世尊遣迦叶已。往诣忉利天。取曼陀罗花先至迦叶座上坐。时迦叶后至。见已白言。大沙门。先遣我言。吾寻后至。云何今者先至坐耶。佛告迦叶。吾遣汝已。到忉利天。取此花先来至此坐。此花色好香气芬馥。迦叶须者便可取之。迦叶报言。止止大沙门。我便为得供养已大沙门可自取用之。迦叶念言。甚奇甚特。有大神足自在得阿罗汉。虽尔不如我得阿罗汉。时世尊食迦叶食已。还诣本林止宿。其夜四天王。持供养具来诣世尊所。皆欲闻法供养。夜暗时放光明照四方。犹如大火聚。合掌礼如来足已在前而住。时迦叶夜起。见彼林有大光明照四方如大火聚。明日清旦。往如来所白言。时已到可往就食。又问言。大沙门昨夜云何有此光明照四方如大火聚。佛告迦叶。昨夜四天王。持供养具来诣我所。欲听受法。是其光明照四方。非火也。迦叶言。甚奇甚特。大沙门有大神力。乃使四天王来听法。大沙门有大神足自在得阿罗汉。虽尔故不如我得阿罗汉。时世尊食迦叶食已还诣本林。时释提桓因。持供养具来欲闻法。夜闇时放大光明。照四方如大火聚。踰于前光。清净无瑕秽。叉手合掌礼如来足在前而住听法。迦叶夜起。遥见光明照四方。踰于前光清净无瑕秽。见已明日往世尊所。白时到可往就食。又复问言。大沙门。昨夜有大火光照于四方。如大火聚踰于前光。清净无瑕秽。是何光明

四分律卷第三十二四分律卷第三十三(二分之十二)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    受戒揵度之三

佛告迦叶。昨夜释提桓因。持供养具来供养我欲听法。是其光耳。迦叶念言。甚奇甚特。大沙门威德乃尔。使释提桓因持供养具来听法耶。大沙门神足自在得阿罗汉。虽尔故不如我得阿罗汉。时世尊。食彼食已还诣本林。时梵天王。欲兴供养于如来所。夜闇时放大光明。照四方如大火聚。胜于前光清净无瑕秽。叉手合掌礼如来已在前而住。迦叶夜起见林中。有大光明照四方。如大火聚清净无瑕秽。胜于前光。见已明日往如来所。白言时已到。可往就食。又复问言。昨夜有大光胜于前光。云何得尔耶。佛告迦叶。昨夜梵天王来听法。是其光耳。迦叶念言。此大沙门。有大神德。甚奇甚特。乃能令梵天王来听法。此大沙门。有大神足自在得阿罗汉。虽尔故不如我得阿罗汉。时世尊食彼迦叶食已。还彼林中。时迦叶欲大祠祀。于摩竭国界多人集会。迦叶念言。我祠祀多人集会。大沙门不来者不亦快耶。何以故。我今大祠祀。摩竭国人皆集。大沙门颜貌端正世所希有。若众人见者。必当舍我事彼为师不承事我。时世尊知迦叶心所念。即诣郁单越取自然粳米。于阿耨大泉坐昼日坐处。时迦叶复生此念。大沙门今何以不来就食。我今大祠祀。摩竭国人大集。宁可留分耶。即敕左右留分。明日清旦。迦叶诣佛所白言。日时已到。宜知是时。又复问言。大沙门。昨日何以故不来耶。我昨日大祀。多人集会。我作是念。云何今日沙门不来至耶。我即留食分。佛告迦叶。我亦先知汝意。汝自念言。今日大沙门不来者。则成我大祠。何以故。我今大祠祀。摩竭国多人集会。大沙门颜貌端正。诸人见者。皆当舍我事彼为师不复事我。我知汝心中所念已。便至郁单越取自然粳米。诣阿耨大泉坐昼日坐处。时迦叶念言。此大沙门。甚奇甚特有大神德。知我心中所念已。乃至郁单越取自然粳米。至阿耨大泉坐昼日坐处。此大沙门。虽有大神足自在得阿罗汉。故不如我得阿罗汉。尔时世尊。食迦叶食已还本林中。时世尊。得一贵价粪扫衣念言。当云何得水浣此衣耶。尔时释提桓因。知佛心中所念。即于如来前指地成大池。极为清净无有垢浊。前白佛言。愿世尊。用此水浣衣。时世尊复作是念。当于何物上浣衣。尔时释提桓因。知如来心中所念。往诣摩头鸠罗山。取四方大石置如来前。唯愿世尊。于此石上浣衣。时世尊复作是念。浣衣已当于何处晒衣。释提桓因。复知世尊心中所念。复诣摩头鸠罗山。更取大方石置如来前。愿于此石上晒衣。时世尊浣晒衣已。复生此念。我今宁可于此指地池中洗浴。即脱衣洗浴。世尊复作是念。我今当攀何物出此池时彼池侧有一大迦休树。本曲外向。世尊生此念已。树即回向池。世尊得攀而出。时迦叶明日清旦往世尊所白言。时已到可往就食。又问言。大沙门。何由有此好池本所不见。佛告迦叶。我近者得一贵价粪扫衣。我念言。当云何得水浣此衣。时释提桓因。知我所念。即以指指地。便有此池。清净无有垢浊。愿世尊可于此池浣衣迦叶当知。此池名为指地池。犹若神祠无异。复问言。何由有此大方石。本所无有。佛告迦叶。我作是念。当于何处浣衣。时释提桓因。知我所念。即诣摩头鸠罗山上。取此四方石来语我言。可于此上浣衣。复问言。此第二方石。何由而有。本来不见。佛告迦叶。我浣衣已念言。当于何处晒衣。释提桓因。知我心中所念。复诣摩头鸠罗山上。取此方石来语我言。愿于此石上晒衣复问言。此池上树。本曲外向。今何曲内向。佛告迦叶。我浣晒衣已作是念。我宁可入此池洗浴。即便入池浴。浴已念言。何所攀而出于是此树即回曲内向。令我得攀而出。是故尔耳。即告迦叶。当知犹如神树无异。时迦叶念言。大沙门甚奇甚特有大神力。释提桓因供给所须。乃使无情物随意。迦叶言。此大沙门。神足自在得阿罗汉。虽尔故不如我得阿罗汉。时世尊食迦叶食已。还诣本林。时迦叶复生此念。有人来至此。我当与食。时世尊即化作五百比丘。着衣持钵从远而至。时迦叶遥见五百比丘着衣持钵从远而至。生此念。咄哉此诸比丘。从何而来。我何由得食与之。时世尊即摄神足还使五百比丘不现。迦叶念言。此皆是大沙门神力所为。时迦叶复作是念。若有人来至此者。我当与食。时世尊复以神力。化作五百螺髻梵志。手持澡瓶从远而来。时迦叶。遥见五百编发梵志手持澡瓶来。作是念言。咄哉今五百梵志来。何由得食与之。时世尊即摄神足。令五百梵志不现。迦叶念言此大沙门所为。时迦叶复生此念。若有人来至此。我当与食。时世尊复化作五百事火梵志。去石室不远皆共祀火神。时迦叶见已作是念言。咄哉此从何来。我当何由得食与之。时世尊即摄神足。令五百梵志不现。迦叶念言。此皆是大沙门所为。时迦叶弟子诸梵志。日三入水浴。极寒战不堪。尔时世尊。即化作五百火炉皆无烟焰。使诸梵志各得自炙。诸梵志念言。此皆是大沙门所为。时诸梵志。皆欲破薪。而不能得破。诸梵志念言。此皆是大沙门威力所为适得破。便复念言。是大沙门神力所为。欲得举斧不能得举。念言。是大沙门所为。适得举斧。复念言。是大沙门所为。诸梵志欲得下斧。而不能得下。念言。此大沙门所为。适得下斧。念言。是大沙门所为。诸梵志欲然火。不能得然念言。皆是大沙门所为。火既得然。念言。大沙门所为。欲灭而不能得灭念言。皆是大沙门所为。适得灭。念言。是大沙门所为。捉澡瓶水欲泻去而不能得出。念言。大沙门所为。既得去水。念言。大沙门所为。诸梵志欲得止澡瓶水。不能得止。念言。大沙门所为。既得止。念言。大沙门所为尔时四面有大黑云起。天大雨堕如象尿。潦水齐腰。时迦叶念言。此大沙门。极为端正人中第一。或能为水所漂即将徒众。乘一树船。往求世尊。世尊尔时在外露地经行。地燥如旧。时迦叶见佛露地经行。地燥如旧犹如屋内。念言。此大沙门。甚奇甚特。使无情之物回转如意。此大沙门。神足自在得阿罗汉。虽尔故不如我得阿罗汉。迦叶他日。复往世尊所。白言。食时已到可往就食。佛言迦叶。汝并在前。吾后当往。时世尊遣迦叶已。犹如力士屈申臂顷。从经行地没。即于彼贯迦叶船底而出。见已便作是言。此大沙门有大神德。先遣我言后至。今者乃先在船耶。佛告迦叶。吾遣汝已。如力士屈申臂顷于经行地没。贯汝船底而出。迦叶作是念言。此大沙门有大神力。先遣我已。后来涌出船上。大沙门有大神力得阿罗汉。虽尔故不如我道真。尔时世尊。知迦叶心中所念。告言。汝常称言。大沙门虽得阿罗汉。不如我得阿罗汉。如今观汝。非阿罗汉。非向阿罗汉道。迦叶念言。此大沙门。有大威神。知我心中所念。此大沙门有大神足。自在得阿罗汉。我今宁可从彼修梵行。即前白佛。我今欲从如来所修梵行。佛告迦叶。汝有五百弟子。从汝学梵行。汝应告彼使知。若彼有意乐者。自随所乐修行。时迦叶即往弟子所告言。汝等知不。我今欲从沙门瞿昙所修梵行。汝等心所乐者。各自随意诸弟子白言。我等久已有信心于彼沙门所。唯待师耳。尔时五百弟子。即持螺髻事火具净衣澡瓶。往掷尼连禅水中已。来诣如来所。头面礼足在一面坐。时世尊与五百人渐次为说胜法。劝令发欢喜心。所谓法者。布施持戒生天之法。呵欲不净。赞叹出离为乐。五百人即于座上诸尘垢尽得法眼净。见法得法成就诸法得果证。前白佛言。我等欲于如来所出家修梵行。佛言来比丘。于我法中快修梵行得尽苦际。即名为受具足戒。时迦叶中弟。名那提迦叶。在尼连禅水下流居。有三百弟子。于中最为尊上。为众人师首。时彼众中有一弟子。至尼连禅水上看。见水中有事火具及发澡瓶。有净衣为水所漂。见已疾疾来至那提迦叶所语言。师当知。此尼连禅水中。有发事火具净衣澡瓶。为水所漂。不审上流大师。将无为恶人所害。时郁鞞罗迦叶小弟。名伽耶迦叶。居象头山中。有二百弟子。于中为师首。时那提迦叶语一弟子言。汝速往至象头山中。到已语伽耶迦叶言。知不。今尼连禅水中。有事火具诸物尽为水所漂。汝速来可共往看兄。将无为恶人所害耶。时弟子受那提迦叶语已。往伽耶迦叶所。小师知不。师有此语。尼连禅水中。有澡瓶净衣发诸事火具。为尼连禅水所漂。速来共往看大兄。将无为恶人所害耶。时小弟闻其语已。即将二百弟子。诣那提迦叶所到已。那提迦叶伽耶迦叶。复语一弟子言。汝速往至大兄所看。将无为恶人所害耶。时彼弟子受二师语已。即往看大兄。到已问言。云何大师。从此大沙门学修梵行为胜耶。迦叶报言。汝等当知。我从世尊出家学道。极为胜妙。时彼弟子。还至二师所语言。诸师当知。我大师已将诸弟子。诣大沙门所出家修梵行。时二师念言。从家舍家从彼学梵行者必不虚。何以故。我兄聪明垢薄多有智慧。而将诸弟子从彼受学。必思量得所故尔耳。而况我等不从受学。时那提迦叶伽耶迦叶。各将诸弟子诣大兄所。到已白兄言。大兄。此处胜耶。兄报二弟言。此处极胜。从家舍家。从大沙门修梵行者。乃为胜妙。二弟白兄言。我等亦欲从大沙门学修梵行。尔时郁鞞罗迦叶。将二弟并五百弟子。往诣世尊所。头面礼足在一面坐。时郁鞞罗迦叶。前白佛言。我有中弟。名那提迦叶。在尼连禅水边住。常教授三百弟子。为人师首。次第三弟。在象头山中住。教授二百弟子。为人师首。今各来集。欲从世尊求修梵行。唯愿世尊。听出家受具足得修梵行。世尊即听。渐次为说胜法。所谓法者。布施持戒生天之法。呵欲不净。赞叹出离为乐。即于座上诸尘垢尽得法眼净。见法得法成就诸法得果证。各前白佛言。唯然世尊。我等欲从如来法中出家修梵行。佛言来比丘。于我法中快得修梵行得尽苦际。即名为受具足戒。时世尊度此千梵志授具足已。将至象头山中。于象头山中有千比丘僧。以三事教化。一者神足教化。二者忆念教化。三者说法教化。彼神足教化者。或化一作无数。或无数还为一内外通达。石壁皆过如游虚空无所妨碍。于虚空中结跏趺坐。亦如飞鸟周旋往来。入地如水出没自在。履水如地而不没溺。身放烟火如大火聚。日月有大神德。靡所不照。能以手扪摸。身至梵天往来无碍是谓世尊神足教化千比丘忆念教化者。教言汝当思惟是。莫思惟是。当念是。莫念是。当灭是。当成就是。是谓世尊忆念教授千比丘。说法教化者。一切炽然。何等一切炽然。眼炽然。色炽然。眼识炽然。眼触炽然。若复眼触因缘生受。若苦若乐。若不苦不乐。亦名为炽然。何等为炽然。炽然者。欲火恚火痴火也。复云何名炽然。炽然者。生老病死愁忧苦恼炽然。我说此苦所生处。乃至意亦如是。尔时世尊。以此三事教授千比丘尔时千比丘。受此三事教授已。即时无漏心解脱无碍解脱智生。尔时世尊。化此千比丘已便作是念。我先许瓶沙王请。若我成佛得一切智。先来至罗阅城。我今应往见瓶沙王。即正衣服。将大比丘千人。皆是旧学螺髻梵志。皆已得定调柔永得解脱。从摩竭国界游化渐至杖林中。尔时世尊。于杖林中善住尼拘律树王下坐。时瓶沙王。闻沙门瞿昙出自释种出家学道。将千弟子游行摩竭界。皆是旧学螺髻梵志。皆已得定调柔永得解脱。从摩竭界游行来至杖林中。止善住尼拘律树王下坐。彼沙门瞿昙有大名称。靡所不闻。所谓名称者。如来至真等正觉明行足为善逝世间解无上士调御丈夫天人师佛世尊。于天及世间久魔若魔天及梵天众沙门婆罗门众中。自知得神通智证。常自娱乐。与人说法。上中下言悉善。义味深邃。具足演布。修诸梵行善哉乃得见如是阿罗汉。我今宁可自往见大沙门瞿昙。时王瓶沙。驾万二千乘车。将八万四千人前后围绕。以王威势出罗阅城。欲见世尊。时王瓶沙。往杖林中。齐车所至处。即下车步进入林。遥见世尊颜貌殊特犹如紫金。便发欢喜心。于如来所前头面礼足已在一面坐。时摩竭国人。或有礼足而坐者。或有举手相问讯而坐者。或有称姓名而坐者。或有叉手合掌向如来而坐者。或有默然而坐者。时摩竭国人作是念。为大沙门从郁鞞罗迦叶学梵行耶。为郁鞞罗迦叶并弟子众从大沙门瞿昙学梵行耶。时世尊。知其国人心中所念。即以偈向郁鞞罗迦叶说

  汝等见何变　　舍诸事火具
  吾今问迦叶　　云何舍火具

尔时迦叶。复以偈报世尊言

  饮食诸美味　　爱欲女及祀
  我见如是垢　　故舍事火具

世尊。复以偈问迦叶言

  饮食诸美味　　于中无所乐
  天上及世间　　今说乐何处

迦叶。复以偈报世尊言

  我见迹休息　　三界无所碍
  不异不可异　　不乐事火祀

时摩竭国人复生是念。大沙门说二偈。郁鞞罗迦叶亦说二偈。我等犹故未别。为大沙门从迦叶受学耶。为迦叶及弟子从大沙门受学耶。时世尊。知摩竭国人心中所念已。告迦叶言。汝起为吾扇背。答言尔。时迦叶受佛教已。即从坐起上升虚空。还下礼世尊足。以手摩扪如来足。以口呜之自称姓字。世尊是我师。我是弟子。即持扇在如来后而扇。时摩竭国人自相谓言。大沙门瞿昙。不从迦叶学梵行。迦叶及弟子众。从大沙门瞿昙学梵行。尔时世尊。知摩竭国人无有疑故。渐次为说法。劝令发欢喜心。所谓法者。布施持戒生天之法。呵欲不净。赞叹出离为乐。时摩竭国人瓶沙王为首。八万四千人十二那由他天。诸尘垢尽得法眼净。见法得法成就诸法自知得果证。前白佛言。我等归依佛法僧。听为优波塞。尽形寿不杀生。乃至不饮酒。瓶沙王见法得法。前白佛言。自念昔日。为太子时。心生六愿。一者若父寿终我登位为王。二者当我治国时愿佛出世。三者使我身见世尊。四者设我见佛已生欢喜心于如来所。五者已发欢喜心得闻正法。六者闻法已寻得信解。今我父王已命终。得登位为王。然我治国。正值佛出世。今复自见佛。见佛已发欢喜心。于佛所已发欢喜心。便得闻法。闻法已便得信解。今正是时。唯愿世尊。入罗阅城。时世尊默然。受瓶沙王请已。即从座起。着衣将千比丘。皆是旧学螺髻梵志。皆已得定调柔永得解脱万二千乘车。八万四千众前后围绕。以佛威神入罗阅城。尔时值天雨。世尊前后中。则清明上有云盖。世尊现此变化。入罗阅城。时释提桓因。化作一异婆罗门。手执金杖金澡瓶金柄扇。身在空中去地四指在如来前引导。复以无数方便赞叹佛法僧。时摩竭国人皆作是念。是谁威神化作此婆罗门形。手执金杖金澡瓶金柄扇。身在空中去地四指。在如来前引导驱却众人。复以无数方便赞叹佛法僧。那时摩竭国人。向释提桓因而说颂曰

  谁化作梵志　　今在众僧前
  叹诵佛功德　　汝所事者谁

尔时释提桓因。复以偈报摩竭国人

  勇猛一切解　　爱欲及饮食
  惭愧念知足　　我是彼弟子
  世无有与等　　不见相似者
  如来至真佛　　我是给使者
  灭欲及嗔恚　　无明永已尽
  漏尽阿罗汉　　我是给使者
  犹如度溺者　　瞿昙是法船
  最胜度彼岸　　我是给使者
  以度四流际　　能说不死法
  最胜无碍法　　我是给使者

尔时摩竭国王瓶沙。复作是念。若使世尊将诸弟子入罗阅城。先至园中者。我当即以此园地施之立精舍。时罗阅城诸园中。迦兰陀竹园最胜。时世尊。知摩竭王心中所念。即将大众诣竹园已。王即下象。自叠象上褥。作四重敷地。前白佛言。愿世尊坐。世尊即就座而坐。时瓶沙王。持金澡瓶水授如来令清净。白佛言。今罗阅城诸园中。此竹园最胜。我今施如来。愿慈愍故受。佛告王言。汝今持此竹园。施佛及四方僧。何以故。若如来有园园物房舍房舍物衣钵尼师檀针筒即是塔。诸天世人魔若魔天沙门婆罗门所不堪用。王言。我今以此竹园。施佛及四方僧。时世尊。以慈愍心受彼园已。即为咒愿

  种植诸园树　　并作桥船梁
  园果诸浴池　　及施人居止
  如是之人等　　昼夜福增长
  持戒顺正法　　彼人得生天

尔时瓶沙王。前礼世尊足已。更取一小床在如来前坐。欲得闻法。时世尊。渐次为王说法。劝令发欢喜心。发欢喜心已。从坐起礼佛而去。尔时世尊。在罗阅城。时城中有删若梵志。有二百五十弟子。优波提舍拘律陀为上首。尔时尊者阿湿卑。给侍如来。时到着衣持钵入城乞食。颜色和悦诸根寂定。衣服齐整行步庠序。不左右顾视。不失威仪。时优波提舍。时已到入园观看。见阿湿卑威仪如是。便生是念。今观此比丘威仪具足。我今宁可往问其义。复自念言。此比丘乞食时。非问义时。今且待彼乞食已。当往问义。时优波提舍。寻从其后。时阿湿卑比丘。入罗阅城乞食已。置钵在地。叠僧伽梨。优波提舍念言。此比丘乞食已竟。今正是问义时。我今当问。即往问义。汝为谁师字谁学何法。即报言。我师大沙门。是我所尊。我从彼学。优波提舍即复问言。汝师大沙门说何法耶。报言。我年幼稚出家日浅。未堪广演其义。今当略说其要。优波提舍言我唯乐闻为要不在广略。阿湿卑言。汝欲知之。如来说因缘生法。亦说因缘灭法。若法所因生。如来说是因。若法所因灭。大沙门亦说此义。此是我师说。时优波提舍闻已。即时诸尘垢尽得法眼净。时优波提舍念言。齐入如是法。至无忧处。无数亿百千那由他劫本所不见。优波提舍拘律陀。先有要言。若先得妙法者。当相告语。时优波提舍。即往至拘律陀所。拘律陀。见优波提舍来。便作是语。汝今颜色和悦诸根寂定。如有所得将不见法耶。答曰。如汝所言。问言。得何等法报言。彼如来说因缘生法。亦说因缘灭法。若法所因生。如来说是因。若法所因灭。大沙门亦说此义。拘律陀。闻是语已。即时诸尘垢尽得法眼净。拘律陀念言。齐入如此法。得至无忧处。无数亿千那由他劫。本所不见。拘律陀问言。不审世尊。今在何处住。报言。如来今在迦兰陀竹园住。拘律陀语优波提舍言。今日可共往如来所礼敬问讯。即是我等师。优波提舍报言。我等先有二百五十弟子。从我所修梵行。当语彼令知。随彼意所欲。时优波提舍。与拘律陀。诣诸弟子所语言。汝等知不。我等二人。欲从大沙门学梵行。汝等各随意所欲。诸弟子白言。我等诸人。皆从师受学。今大师犹从彼学。我等岂得不从学耶。若师所得者。我等亦当得之。时优波提舍拘律陀并诸弟子。相与俱诣竹园。时世尊。与无数百千众围绕。而为说法。遥见优波提舍拘律陀并诸弟子来。见已告诸比丘。彼远来二人者。一名优波提舍。二名拘律陀。此二人于我诸弟子中最为上首。智慧无量无上得二解脱。未至竹园。如来已授记别二人为匹。同友二人并诸弟子到如来所。头面礼足已。在一面坐。时世尊。渐次为说胜法。令发欢喜心。所谓法者。布施持戒生天之法。呵欲不净赞叹出离为乐。即于座上诸尘垢尽得法眼净。见法得法成就诸法。自知得果证已。前白佛言。我等欲从如来法中出家修梵行。佛言。善来比丘。于我法中快修梵行得尽苦源。即名出家受具足戒。尔时世尊。游罗阅城。时尊者郁鞞罗迦叶与诸弟子出家学道。复有删若二百五十梵志。出家学道罗阅城中诸贵族姓子等亦出家学道时。罗阅城中诸长者。自相诫敕言。汝等有儿者。各自慎护。妇有夫主者亦慎护之。今大沙门。从摩竭国界度诸梵志自随。今来至此复当将此诸人去。尔时诸比丘乞食时闻此诸人所说。此大沙门将诸梵志自随来此。今复当将此诸人去。诸比丘闻已皆怀惭愧。往世尊所。以此因缘具白世尊。世尊告诸比丘。汝等入罗阅城中乞食。闻诸长者作是言。大沙门来至国界。度诸梵志将自随。今复当度此诸人将去者。汝等便以此偈报之

  如来大势力　　以法而将去
  以法将去者　　汝等何忧惧

尔时诸比丘。受佛教已。入罗阅城乞食。闻诸长者说此语时。即以此偈报之

  如来大势力　　以法而将去
  以法将去者　　汝等何忧惧

时诸长者作是念。我等如所闻。大沙门以法将去。不为非法

尔时尊者郁鞞罗迦叶。将诸弟子出家学道。删若弟子。亦将二百五十弟子出家学道。罗阅城诸豪姓子。亦出家学道。大众皆集游罗阅城。时彼未被教诫者。不按威仪。着衣不齐整。乞食不如法。处处受不净食。或受不净钵食。在小食大食上高声大唤。如婆罗门聚会法。时有一病比丘。无弟子无瞻视者命终。诸比丘以此因缘往白世尊。世尊言。自今已去听有和尚。和尚看弟子。当如儿意看。弟子看和尚。当如父意。展转相敬。重相瞻视。如是正法便得久住。长益广大。当如是请和尚。请时当教。偏露右肩。脱革屣右膝着地合掌。作如是语。我某甲请大德为和尚。愿大德为我作和尚。我依大德受具足戒。第二第三亦如是说。和尚当报言可尔。若言如是。若言当教授汝。若言清净莫放逸。佛言。自今已去舍三语授具足戒。自今已去听满十人当授具足戒。白四羯磨。当如是授具足戒。欲受戒者诣僧中。偏露右臂脱革屣礼僧足。右膝着地合掌作如是白。大德僧听。我某甲。从某甲求受具足戒。我某甲。今从众僧乞受具足戒。某甲为和尚。愿僧济度我。慈愍故。如是第二第三说。众中当差堪能羯磨者。如上当作如是白。大德僧听。此某甲。从某甲求受具足戒。此某甲今从众僧乞受具足戒。某甲为和尚。若僧时到僧忍听。与某甲受具足戒。某甲为和尚。白如是。大德僧听。此某甲。从某甲求受具足戒。此某甲。今从众僧乞受具足戒。某甲为和尚。谁诸长老忍。僧与某甲受具足戒。某甲为和尚者默然。谁不忍者说。此是初羯磨。第二第三亦如是说。僧已与某甲受具足戒。某甲为和尚竟。僧忍默然故。是事如是持。时诸比丘。知世尊制戒听授人具足戒。新学比丘辄授人具足戒。不能教授。以不教授故。不按威仪。着衣不齐整。乞食不如法。处处受不净食。或受不净钵食。在小食大食上高声大唤。如婆罗门聚会法。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责彼比丘言。世尊制戒听授人具足戒。云何汝等新受戒比丘。辄授人具足戒。而不能教授。以不教授故。不按威仪。着衣不齐整。乞食不如法。处处受不净食。或受不净钵食。在小食大食上高声大唤。如婆罗门聚会法。时尊者婆先始二岁。将一岁弟子。往世尊所。头面礼足已。在一面坐。世尊知而故问。此是何等比丘。报言世尊。是我弟子。问言。汝今几岁。报言二岁。复问言。汝弟子几岁。报言一岁。尔时世尊。以无数方便呵责。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何婆先。汝自身未断乳。应受人教授。云何教授人。时诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊言。向者婆先比丘二岁。将一岁弟子来至我所。头面礼足在一面坐。一面坐已。我知而故问。此是何等比丘。报言。是我弟子。问言汝几岁。报言二岁。汝弟子几岁。报言一岁。我即以无数方便呵责。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何婆先。汝自未断乳。应受人教授。云何教授人。佛既听授人具足戒。而汝新受戒比丘。辄便授人具足戒。不知教授。以不教授故。不按威仪。着衣不齐整。乞食不如法。处处受不净食。或受不净钵食。在大食小食上高声大唤。如婆罗门聚会法。时世尊。以无数方便呵责已。告诸比丘。自今已去听十岁比丘授人具足戒。彼诸比丘。闻世尊制戒听十岁比丘得授人具足戒。十岁愚痴比丘。辄授人具足戒。而不知教授。以不教授故。不按威仪。着衣不齐整。乞食不如法。处处受不净食。或受不净钵食。在大食小食上高声大唤。如婆罗门聚会法。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责彼比丘言。世尊制戒。听十岁比丘得授人具足戒。汝云何十岁愚痴比丘。辄授人具足戒。不知教授。以不教授故。不按威仪。着衣不齐整。乞食不如法。处处受不净食。或受不净钵食。在大食小食上高声大唤。如婆罗门聚会法。时诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊以此因缘集诸比丘僧。以无数方便呵责彼比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何世尊制戒。听十岁比丘授人具足戒。云何汝十岁愚痴比丘。辄授人具足戒。不知教授。以不教授故。不按威仪。着衣不齐整。乞食不如法。处处受不净食。或受不净钵食。在大食小食上高声大唤。如婆罗门聚会法。时世尊。以无数方便呵责已告诸比丘。自今已去听十岁智慧比丘授人具足戒。时诸比丘。闻世尊制戒听十岁智慧比丘得授人具足戒。便自言。我十岁智慧得授人具足戒。而辄授人具足戒。不知教授。以不教授故。不按威仪。着衣不齐整。乞食不如法。处处受不净食。或受不净钵食。在大食小食上高声大唤。如婆罗门聚会法。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责彼比丘言。世尊制戒。听十岁智慧比丘得授人具足戒。汝云何自言智慧。辄授人具足戒。而不知教授。以不教授故。不按威仪。着衣不齐整。乞食不如法。处处受不净食。或受不净钵食。在大食小食上高声大唤。如婆罗门聚会法。时诸比丘。往世尊所头面礼足在一面坐。以此因缘具白世尊。世尊以此因缘集比丘僧。呵责彼比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。佛制戒。听十岁智慧比丘得授人具足戒。云何汝等自言智慧。辄授人具足戒。不知教授。以不教授故。不按威仪。着衣不齐整。乞食不如法。处处受不净食。或受不净钵食。在大食小食上高声大唤。如婆罗门聚会法。时世尊。以无数方便呵责已。告诸比丘。自今已去当制和尚使行和尚法。和尚于弟子所。当作如是法。应如是行。若弟子。众僧欲为作羯磨作呵责作摈。作依止。作遮不至白衣家。作举。和尚当于中如法料理。令僧不与弟子作羯磨。若作令如法。复次若僧。与弟子作羯磨。作呵责作摈。作依止。作遮不至白衣家。作举。和尚于中当如法料理。令弟子顺从于僧。不违逆求除罪。令僧疾与解羯磨。复次若弟子犯僧残。和尚当如法料理。若应与波利婆沙。当与波利婆沙。应与本日治。当与本日治应与摩那埵。当与摩那埵。应与出罪。当与出罪。复次弟子得病。和尚当瞻视。若令余人看。乃至差若命终。弟子若不乐住处。当自移若教人移。弟子若有疑事。当以法以律如佛所教如法教除之。若恶见生。当教令舍恶见住善见。当以二事将护。以法以衣食将护。是中法将护者。应教增戒增心增慧教学问诵经。是中衣食将护者。当与衣食床卧具病瘦医药。随力所堪为办。自今已去制和尚法如是。和尚应行。若不行如法治。时和尚于弟子所行和尚法。弟子于和尚所不行弟子法。不白和尚。入村入白衣家。或从余比丘。或将余比丘为伴。或与或受。或时佐助众事。或时受他佐助。或时为他剃发。或受他剃发。或不白和尚入浴室。或时为他揩摩身。或时受他揩摩身。或时不白和尚。至昼日住处房。或至冢间。或至界外。或至他方。尔时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责彼诸比丘言。云何和尚于弟子所行和尚法。而弟子于和尚所不行弟子法。而不白和尚。入村入白衣家。乃至不白至他方。时诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊。尔时以此因缘集比丘僧。呵责彼比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何和尚于弟子所行和尚法。弟子于和尚所不行弟子法。不白和尚。入村入白衣家。乃至不白至他方。尔时世尊。以无数方便呵责彼比丘已。告诸比丘。自今已去当制弟子。如弟子所行法。使弟子于和上所行弟子法。作如是行。若和尚。众僧为作羯磨。作呵责。作摈。作依止作遮不至白衣家。作举。弟子当如法料理。令僧不与和尚作羯磨。若作令轻。复次若僧与和尚作羯磨。作呵责乃至作举。弟子当于中如法料理。令和尚顺从于僧不违逆求除罪。令僧疾疾与解羯磨。复次和尚犯僧残。弟子当如法料理。若应与波利婆沙。当与波利婆沙。应与本日治。当与本日治。应与摩那埵。当与摩那埵。应与出罪。当与出罪。复次和尚若病。弟子当瞻视。若令余人看乃至差若命终。若和尚意不乐住处。当自移若教余人移。若和尚有疑事。当如法如律如佛所教。如法除之若恶见生。当劝令舍恶见住善见。当以二事将护。以法以衣食。法将护者。劝令增戒增心增慧学问诵经。衣食将护者。当供养衣食床褥卧具医药所须之物。随力所堪。自今已去制弟子法如是。弟子应行。若不行应如法治。时弟子于和尚所不行弟子法。弟子不白和尚。不得入村。不得至他家。不得从余比丘。或将余比丘为伴。不得与。不得受。不得佐助众事。不得受他佐助众事。不得使他剃发。不得为他剃发。不得入浴室。不得为人揩身。不得受他揩身。不得至昼日住处房。不得至冢间。不得至界外。不得行他方。彼当清旦入和尚房中。受诵经法问义。当除去小便器。若白时到。应澡豆若牛屎灰净洗手。若有可食物当为取。若僧中有利养当为取。当持澡豆杨枝授与和尚令和尚洗手漱口。有可食物授与和尚。僧中有别利养。当白和尚言。得如是如是物。是和尚分。彼当问和尚言。欲入村不。若言不入。当问言。从何处取食。若和尚言从某处取。当如敕往取。若报言。我欲入村。彼当洗手已衣架上徐徐取衣。勿使倒错。当取安陀会舒张抖擞看。勿令有虫蛇蜂诸恶虫。次取腰带僧祇支郁多罗僧舒张抖擞看。勿令有蛇蜂诸恶虫。当授与和尚。应叠僧伽梨着头上若肩上。复次取钵。当以澡豆若灰牛屎洗盛络囊中。若手巾裹。若钵囊中持去。应取和尚[打-丁+親]身衣叠举。复取洗足物卧毡被举之。若和尚出行时。当捉和尚行道革屣。出房舍时。当还顾闭户。复以手推看为牢不。若不牢当更重闭。若牢已。当取户扇孔中绳内之。遍观左右已。持户钥着屏处。若恐人见。若恐不牢。若不牢。若人见当持去。若移置深牢处。令和尚在前行。若道路逢相识人。当共善语善心忆念。行时当避人道。彼若欲入村时。应小下道。安钵置一面。头上若肩上。下僧伽梨舒张看。勿令有蛇蝎百足诸恶虫。授与和尚。若彼村外。有客舍坐肆舍若作坊。当持行道革屣置中。应问和尚。我得寻从不若言可尔。即当寻从。若言不须在某处住。彼应如言在某处住。若和尚入村不时出。彼当作如是意。入村乞食。此分与和尚。此分属我。彼出村已。还至革屣所。取革屣下道。持钵置地。叠僧伽梨着头上若肩上。若中路见相识人。当善意问讯。若和尚所住食处。当扫令净。与敷坐具。具净水瓶洗浴器盛食器。复当与和尚安置洗浴坐洗足石具拭脚巾。若遥见和尚来。即起奉迎。取手中钵。置钵榰上若钵床上。若绳床角头。若头上肩上。取僧伽梨舒张看之。勿令有脂腻沾污。或为尘土坌。或为泥污。或飞鸟粪污。若有如是污应去之。宜浣者浣之捩去水舒张晒置。若木床若绳床上。复当与和尚敷坐与革屣洗足石拭足巾。与盛水器。抖擞革屣已。置左面看之。恐在下地湿处。若在下地湿处。便取移彼。与和尚洗足竟当弃水。持洗足石拭足巾还置本处。复自净洗手已授净。水与和尚洗手。自所有食。当取与和尚。白言。此是我食分可食。彼须者当取。若和尚食时。当侍立看供给所须。若彼食时。有酪浆煎浆苦酒盐大麦浆菜茹授与之。若热[打-丁+毛]令冷。若须水授水与。相日时若欲过者。当即同时食。若和尚食已。当手中取钵行澡漱水。若自食竟。若有余食。当与人若非人。若着净地无草处。若着净地无虫水中。取盛食器净洗还置本处。取坐具洗足床净水瓶澡洗瓶还置本处。食处净扫除粪彼以食钵盛粪弃之。余比丘见者皆共恶之。自今已去不得持食钵盛粪弃。听用除粪器。若破器。若故竹筐。若扫帚上除去粪食。钵当好净洁持之。复次入和尚房时。当看恐有尘土。若有尘土。当出绳床木床坐具大小褥枕毡被。若床榰若地敷。当记本处出在外晒之。净扫除房中。去粪土弃时当看。若有针綖若刀。若弊故段衣。下至一丸二丸药。当取举置现处。若有主识者当取。复当拂拭向上若杙上。若龙牙杙上。若衣架上。若房有破坏处。若虫鼠孔穴。可补塞者当治之。可泥者便泥之。可捣便捣。可平治便平治。当以泥浆污洒极令净洁。当取地敷。晒令燥抖擞内房中。若本敷坐不齐当更齐整。若本齐整。当如本齐整。先内床脚榰拂拭之当急绳床绳床脚。向身内房中。安置床榰上。取大小褥枕毡被衣。内着房中。先敷大褥。次敷少褥毡被。安枕置上彼取所著衣。不着衣并置一处。取时各各错乱。自今已去。不得持所著衣不着衣并置一处。应各各别一处。彼取钵囊革屣囊针筒油器置一处。诸比丘见恶之。佛言。不应尔。自今已去。听持钵囊针筒置一处。革屣囊与油器着一处。彼应在房内安钥壮看。令不高下出房外。应还探户观中庭。恐有尘土不净。若有即扫除去。当取水瓶净洗已。还盛净水置本处。复当与和尚具水瓶洗浴瓶饮水器。若浴室中有洗浴时。当往问和尚。欲洗浴不。若言洗浴。当先至浴室中看地。若有尘土草芥当除去。应洒便洒。应扫便扫。若有不净涝水应弃便弃。应内水便内水。应内薪便内薪。应破薪便破薪。应内窖中便内窖中。应与和尚具温室中瓶。及坐机。刮汗刀水器。泥土器。若澡豆。诸洗浴具。彼当先白和上已然后然火。然火已白时到。若和尚病羸若老极。当自扶抱。若绳床木床上。若以衣舁。往温室中。当从和尚手中取衣。若浴室中有杙。若龙牙杙。若衣架。当持衣置是诸处。若有油持油与涂身。若盛油器处处在地。当取贯着龙牙弋上。若和尚病羸瘦老极。当扶抱至浴室中。至已当取浴机床浴瓶。若刮汗刀与若水器。若泥器。若澡豆。诸洗浴具。若烟熏面当持巾与障。若头背热。当以巾覆彼。当白和尚已然后入浴室。若和尚先入已。恐浴室中闹不敢入。当作是念。我今不自为己。以和尚洗浴故入。可作是意入。入已当与和尚揩摩身。当立和尚后。若欲与异人揩身。若受他揩身。当白和尚使知。然后当与揩身。若受他揩身。彼与和尚洗自洗已。若和尚病羸瘦若老极。当扶出浴室外。取座与坐。取拭身巾。若拭面巾。若拭眼巾。授与和尚已。当安洗脚石。与水洗脚。取拭脚巾。与当取洗足。革屣拂拭抖擞授与。次取衣舒张看抖擞授与。若有眼药若丸香授与。若有甜浆蜜浆黑石蜜浆。洗手已授与。若和尚病瘦老极。当以绳床木床上舁。若衣上舁还房中。还房中已。手扪摸卧处看。与敷卧氊令卧。先与榇身衣。次以被衣覆之。出房已还向闭户。还至浴室中。遍看水瓶洗浴瓶浴机刮汗刀盛水瓶盛泥土器细末药若澡豆诸洗浴物。还置本处。若浴室中有不净涝水。应除去便除去。应灭火便灭之。应覆火便覆。应闭户便闭。应持户钥去便持去。彼当日三问讯和尚。朝中日暮。当为和尚执二事。劳苦不得辞设一修理房舍。二为补浣衣服。和尚如法所教事。尽当奉行。若遣往方面周旋不得辞设。假托因缘住。若辞设者。当如法治。自今已去。制弟子修弟子法。弟子于和尚所。不修弟子法。当如法治

四分律卷第三十三四分律卷第三十四(二分之十三)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    受戒揵度之四

时诸新受戒比丘。和尚命终。无人教授。以不被教授故。不按威仪。着衣不齐整。乞食不如法。处处受不净食。或受不净钵食。在大食小食上高声大唤。如婆罗门聚会法无异时诸比丘往白世尊。世尊言。自今已去听有阿阇梨听有弟子。阿阇梨于弟子当如儿想。弟子于阿阇梨如父想。展转相教。展转相奉事。如是于佛法中倍增益广流布。当作是请阿阇梨。偏露右臂脱革屣右膝着地合掌作是言。大德一心念。我某甲。今求大德为依止。愿大德与我依止。我依止大德住。第二第三亦如是说。彼当言可尔。与汝依止。汝等莫放逸。时诸比丘。闻世尊制戒听作依止。彼新受戒比丘与他依止。不知教授。以不教授故。不案威仪。着衣不齐整。乞食不如法。处处受不净食。受不净钵食。在大食小食上高声大唤。如婆罗门聚会法。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责彼比丘言。世尊制戒听受人依止。而汝等新受戒比丘。云何受他依止而不知教授。以不教授故。不按威仪。着衣不齐整。乞食不如法。处处受不净食。受不净钵食。在大食小食上高声大唤。如婆罗门聚会法。呵责已往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊。以此因缘集比丘僧。呵责彼比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何比丘。世尊制戒听受人依止。汝等新受戒比丘。受他依止不知教授。以不教授故。不按威仪着。衣不齐整。乞食不如法。处处受不净食。受不净钵食。在大小食上高声大唤。如婆罗门聚会法。时世尊以无数方便呵责已告诸比丘。自今已去听十岁比丘与人依止。彼诸比丘。闻世尊制戒听十岁比丘与人依止。彼十岁比丘愚痴无智慧。便与人依止。不知教授。以不教授故。不按威仪。着衣不齐整。乞食不如法。处处受不净食。受不净钵食。在大小食上高声大唤。如婆罗门聚会法。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责彼比丘。云何世尊制戒。听十岁比丘与人依止。而汝等虽十岁愚痴。与人依止不知教授。以不教授故。不按威仪。着衣不齐整。乞食不如法。处处受不净食。受不净钵食。在大小食上高声大唤。如婆罗门聚会法。呵责已往白世尊。世尊。以此因缘集比丘僧。呵责彼比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何我制戒。听十岁比丘受人依止。汝等虽十岁。愚痴受人依止。不知教授。以不教授故。着衣不齐整。乃至如婆罗门聚会法耶。时世尊以无数方便呵责已告诸比丘。自今已去听十岁智慧比丘与人依止。时诸比丘。闻世尊制戒。听十岁智慧比丘与人依止。彼自称言。我十岁有智慧。便与人依止。然彼与依止已。不教授。以不教授故。着衣不齐整。乞食不如法。处处受不净食。受不净钵食。在大小食上高声大唤。如婆罗门聚会法。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责彼比丘。云何世尊制戒。听十岁有智慧。比丘应与人依止。而汝辄自言。我有智慧。便与人依止。既与已而不教授。以不教授故。不按威仪。着衣不齐整。乞食不如法。处处受不净食。受不净钵食。在大小食上高声大唤。如婆罗门聚会法。时诸比丘。往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊。以此因缘。集比丘僧。呵责彼比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何我制戒。听十岁有智慧。比丘与人依止。而汝自言有智慧。与人依止。既与依止。而不教授。以不教授故。不按威仪。着衣不齐整。乞食不如法。处处受不净食。受不净钵食。在大小食上高声大唤。如婆罗门聚会法。尔时世尊。以无数方便呵责已告诸比丘。自今已去。当制阿阇梨法。使行阿阇梨法。阿阇梨。于弟子所。当作如是法。应如是行。(阿阇梨。于弟子所。行阿阇梨法。一一如上和尚于弟子所行和尚法。弟子。于阿阇梨所。行弟子法。一一亦如上弟子。于和尚所一一行弟子法文同不异。故不出耳)

尔时诸弟子。不承事恭敬和尚。亦不顺弟子法。时诸比丘往白世尊。世尊言。自今已去当与作呵责。彼不知云何呵责。佛言。听以五事呵责。和尚当作如是语。我今呵责汝。汝去。汝莫入我房。汝莫为我作使。汝亦莫至我所。不与汝语。是谓和尚呵责弟子五事。阿阇梨呵责弟子。亦有五事。语言。我今呵责汝。汝去。汝莫入我房。莫为我作使。汝莫依止我住。不与汝语。是谓阿阇梨呵责弟子五事。世尊既听呵责。不知当以何事呵责。诸比丘往白佛。佛言。弟子有五事。和尚阿阇梨。应与作呵责。无惭无愧不受教。作非威仪。不恭敬。弟子有如是五事。和尚阿阇梨。应与作呵责。复有五事。无惭无愧。难与语。与恶人为友。好往淫女家。复有五事。无惭无愧。难与语。与恶人为友好往妇女家。复有五事。无惭无愧。难与语。与恶人为友。好往大童女家。复有五事。无惭无愧。难与语。与恶人为友。好往黄门家。复有五事。无惭无愧。难与语。与恶人为友。好往比丘尼精舍。复有五事。无惭无愧。难与语。与恶人为友。好往式叉摩那沙弥尼精舍。复有五事。无惭无愧。难与语。与恶人为友。好往看捕龟鳖。弟子有如是五事。和尚阿阇梨应与作呵责。世尊既听呵责弟子。彼尽形寿呵责。佛言。不应尽形寿呵责。彼竟安居呵责。佛言不应尔。彼呵责病者。和尚阿阇梨不看。余比丘亦不看。病者困笃。佛言。不得呵责病者。彼不在前呵责。余比丘语言。汝已被呵责。彼言。我不被呵责。佛言。不应不现前呵责。彼不与出过而呵责。时诸弟子言。我犯何过而见呵责耶。佛言。不应不出其过而呵责。当出其过言。汝犯如是如是罪。彼既被呵责已便供给作使。佛言不应尔。彼与作呵责已。便受供给作使。佛言不应尔。彼被呵责已故依止。佛言不应尔。彼与作呵责已与依止。佛言不应尔。彼被呵责已不忏悔。和尚阿阇梨便去。佛言不应尔。彼被呵责已。便于余比丘边住。不与和尚阿阇梨执事。亦复不与余比丘执事。佛言不应尔。彼被呵责已。无人为将顺。或远行。或休道。或不乐佛法。佛言。听余人作如是意受。为其和尚阿阇梨。欲令忏悔和合故受。尔时六群比丘。诱将他弟子去。诸比丘往白佛。佛言。不应诱将他弟子去。若将去应如法治。彼和尚阿阇梨。或破戒破见破威仪。若被举若灭摈若应灭摈。于沙门法无利益时。诸比丘往白佛。佛言。听作如是意。所以诱进将去。欲令其长益沙门法故。彼被呵责已。不向和尚阿阇梨忏悔。佛言。被呵责已。应向和尚阿阇梨忏悔。当如是忏悔。偏露右臂脱革屣右膝着地合掌。作如是语。大德。我今忏悔。更不复作。若听忏悔者善。若不听者。当更日三时忏悔。早起日中日暮。若听忏悔者善。若不听者。当下意随顺。求方便解其所犯。若彼下意随顺无有违逆。求解过师当受。若不受当如法治。时有新受戒乐静比丘。当须依止。彼观看房舍。见阿兰若处有窟。彼作是念。我若得依止。当于此处住。语诸比丘。诸比丘往白佛。佛言。自今已去。新受戒比丘。乐闲静须依止者。听余处依止即日得往还。若不得。新受戒比丘乐静处者。听无依止而住。尔时新受戒旧住比丘须依止。彼作是念。世尊有制。不得无依止而住。彼辄舍所住处去。住处坏。时诸比丘。以此事往白佛。佛言。自今已去。有新受戒旧住比丘须依止。听无依止住。为护住处故。时有比丘。决意出界外去。不作还意。而彼出界外。即其日还。诸比丘白佛言。此失依止不。佛言。此失依止。彼和尚阿阇梨决意出界外去。作不还意。而出界外。即其日还。诸比丘白佛言。此失依止不。佛言失依止。时有比丘。白和尚阿阇梨。暂出界外。出界外。即日还。诸比丘白佛言。为失依止不。佛言不失依止。时和尚阿阇梨念言。暂出界外。出界外即其日还。诸比丘白佛言。为失依止不。佛言不失依止。尔时诸比丘。将受戒人出界外。唤六群比丘来授戒。彼六群比丘不来。不得受戒。时诸比丘。以此事往白佛。佛言。自今已去。若作波利婆沙。本日治。摩那埵。阿浮呵那。作羯磨。若立制。若受戒。若众差人。若有所解。如此众事。唤应赴。不赴当如法治。尔时诸比丘。将欲受戒者出界外。语上座言。作白羯磨报言。我不诵。复语中座下座言作白。亦言不诵。便留难不得受戒。诸比丘以此因缘往白佛。佛言。自今已去。五岁比丘。当诵白羯磨。若不者当如法治。时有比丘。将受戒者出界外。语上座言。作白。上座报言。我曾诵今不利。复语中下座言。作白。亦言。我曾诵今不利。便不得受戒。时诸比丘。以此事往白佛。佛言。自今已去。听五岁比丘当诵白羯磨使利。不者当如法治尔时有比丘将受戒者出界外。闻有贼来皆恐怖。从坐起去不得受戒。诸比丘。以此因缘往白佛。佛言。自今已去有八难事及余因缘。二人三人听一时作羯磨不得过。所谓难处者一王二贼三火四水五病六人七非人八失梨[沙/虫]虫。所谓余因缘者。有大众集坐具少若多病人。听二人三人一时作羯磨。若有大众集房舍少。若天雨漏。听二人三人一时作羯磨。尔时尊者优波离即从坐起。偏露右臂脱革屣右膝着地合掌白佛言。若有诸重事。得过二人三人一时作羯磨不。佛言不得过。彼遣使受依止。佛言不应尔。彼遣使与依止。佛言不应尔。时和尚阿阇梨出界外行。弟子念言。和尚阿阇梨行不久当还我即依止而住。便无依止而住。诸比丘以此因缘往白佛。佛言。自今已去听和尚阿阇梨出界外行日。即日应受依止。若不受当如法治。彼诸弟子出界外远行彼自念言。我等行不久还。即以此依止和尚阿阇梨住。便无依止而住。时诸比丘以此因缘往白佛。佛言。自今已去。听新受戒客比丘。须依止者。不得先洗足。不得先饮水先当受依止。尔时客新受戒比丘须依止。彼作是念。世尊制言。新受戒客比丘须依止。不得先洗足。不得先饮水。当先受依止。当受依止。时迷闷倒地便得病。尔时诸比丘。以此因缘往白佛。佛言。自今已去。听客新受戒比丘须依止。先洗足先饮水小停息已受依止。彼不选择人受依止。而师破戒破见破威仪。若作呵责。作依止。作摈。若作遮不至白衣家。若被举。无有长益沙门行。佛言。自今已去。不得不选择师受依止。彼不选择与依止。而弟子或破戒破见破威仪若被作呵责若摈作依止作遮不至白衣家作举。佛言不得不选择与依止。尔时新受戒比丘。病须依止。彼作是念。世尊制言不依止不得住。即日舍住处去病增剧时诸比丘往白世尊。世尊言。自今已去。新受戒比丘病须依止听无依止得住。时瞻视新受戒病比丘者须依止彼作是念。世尊制言。无依止不得住。彼舍病人去。病者命终。诸比丘往白世尊。世尊言。自今已去。听瞻视新受戒病比丘者无依止得住。彼诸比丘和尚阿阇梨。众僧与作羯磨。与作呵责作摈作依止。作遮不至白衣家作举。诸比丘念言。为失依止不。佛言。不失依止。彼诸弟子众僧与作羯磨。作呵责乃至遮不至白衣家作举羯磨。诸比丘念言为失依止不。佛言不失依止。彼和尚阿阇梨。众僧为作灭摈羯磨。诸比丘念言。为失依止不。佛言失依止。彼诸弟子。众僧为作灭摈羯磨。诸比丘念言。为失依止不。佛言失依止。尔时世尊。游罗阅城。时郁毗罗迦叶。将诸徒众舍家学道。删若弟子将二百五十弟子舍家学道。罗阅城中有大富豪贵家子亦出家学道。如此大众等住罗阅城时诸大臣自相谓言。今诸外道出家学道。春秋冬夏人间游行此沙门释子。聚住此间不余处游行。将由此处为最胜故。尔时诸比丘闻已以此因缘具白世尊。世尊尔时告阿难。汝往房房敕诸比丘言。世尊今欲至南方人间游行。若有欲侍从者各随意。阿难受教。往房房语诸比丘言。世尊今欲往南方游行。诸比丘若有欲侍从者各随意。时有信乐新受戒比丘。白阿难言。若我等和尚阿阇梨去我当去。若不去我等不去。何以故我等新受戒比丘。若去须依止。还此复当受依止。人当谓我轻躁无志尔时世尊。将少比丘。游行南方。后还王舍城。时世尊观南方游行比丘众少。知而故问阿难诸比丘何以故少。阿难具以上事白世尊。世尊。尔时以此因缘集比丘僧告言。自今已去。听五岁有智慧比丘。十岁有智慧比丘。五岁比丘。应从十岁比丘受依止。若愚痴无智慧者。尽形寿依止。有五法失依止。一师呵责二去三休道四不与依止五入戒场上。复有五事。一者死。二者去。三休道。四不与依止。五若五岁若过五岁。复有五事。若死若去若休道若不与依止若见本和尚。复有五事。若死若去若休道若不与依止若和尚阿阇梨休道。复有五法。若死若去若休道若不与依止若弟子休道。复有五事。若死若去若休道若不与依止若和尚阿阇梨命终。复有五事。若死若去若休道若不与依止若弟子命终。复有五事。若死若去若休道若不与依止若还在和尚目下住。是为五事失依止。有五法不成就。不得授人具足戒。戒不成就。定不成就。智慧不成就。解脱不成就。解脱知见不成就。此五法不成就。不得授人具足戒。若成就五法者。得授人具足戒。(即反上句是)复有五法成就不得授人具足戒自身戒不成就。不能教人坚住于戒。自身定智慧解脱解脱知见不成就。不能教人坚住于定智慧解脱。解脱知见。成就此五法。不得授人具足戒。五法成就。得授人具足戒。(即反上句是)复有五法成就。不得授人具足戒。无信无惭无愧懒堕多忘。成就此五法。不得授人具足戒。有五法成就。得授人具足戒。(即反上句是)复有五法成就。不得授人具足戒。破增上戒。破增上见。破增上威仪。少闻。无智慧。成就此五法。不得授人具足戒。有五法成就。得授人具足戒。(即反上句是)复有五法成就。不得授人具足戒。不能瞻视病弟子。不能使人瞻视乃至差若命终。若弟子不乐住处方便当移异处。若有生疑事。不能开解其意如法如律如佛所教如法除之。不能教使舍恶见住善见。若减十岁。成就此五法。不得授人具足戒。有五法成就。得授人具足戒。(即反上句是)复有五法成就。不得授人具足戒。不知犯。不知不犯。不知若轻若重。减十岁。成就此五法者。不得授人具足戒。若成就五法。得授人具足戒。(即反上句是)复有五法成就。不得授人具足戒。不知教授弟子。增上威仪。增上净行。增上波罗提木叉。白羯磨。成就此五法者。不得授人具足戒。成就五法。得授人具足戒。(即反上句是)复有五法成就。不得授人具足戒。不知增戒。增心。增智慧。不知白。不知羯磨。成就此五法。不得授人具足戒。成就五法。得授人具足戒。知增戒增心增智慧知白羯磨。成就此五法者。得授人具足戒。如是不得与依止。得与依止。不得畜沙弥。得畜沙弥。尽如上

尔时佛在罗阅城。时城中有裸形外道。名布萨。善能论议。常自称说言。此间若有沙门释子。能与我论者来。时舍利弗言。我堪与汝论。时诸比丘。以此事往白佛。佛言。论有四种。或有论者。义尽文不尽。或有文尽义不尽。或有文义俱尽。或有文义俱不尽。有四辩。法辩。义辩。了了辩。辞辩。若论师有此四辩者。而言文义俱尽。无有是处。今舍利弗。成就此四辩。而言文义俱尽。无有是处。彼裸形即难问舍利弗义。舍利弗即还答遣。时彼裸形以五百迫难难舍利弗。舍利弗即称彼五百迫难。而更以深义难问。而彼裸形得难问不解。时彼裸形即生念言。甚奇甚特沙门释子。极为智慧聪明。我今宁可从彼出家学道耶。即往僧伽蓝中。遥见跋难陀释子生此念。沙门释子少知识者。犹智慧乃尔。况多知识者。岂得不多耶。前至跋难陀释子所白言。我欲出家学道。时跋难陀。即度为弟子。授具足戒。后于异时。问跋难陀义。而不能答。时彼裸形复生此念。沙门释子愚闇无所知。我今宜可休道。即着袈裟入外道众中。时诸比丘。以此因缘往白佛。佛言。自今已去。听与外道众僧中四月共住白二羯磨。当作如是与。先剃发已。着袈裟脱革屣。右膝着地合掌。教作如是言。大德僧听。我某甲外道。归依佛归依法归依僧。我于世尊所求出家为道。世尊即是我如来至真等正觉。如是第二第三说。我某甲外道。归依佛法僧已。从如来出家学道。如来是我至真等正觉。如是第二第三说。当教受戒。尽形寿不杀生是沙弥戒。乃至尽形寿不畜金银宝物是沙弥戒。此是沙弥十戒。尽形寿不得犯。彼外道应先至众僧中。偏露右臂脱革屣礼僧足已。右膝着地合掌教作如是说。大德僧听。我某甲外道。从众僧乞四月共住。愿僧慈愍故。与我四月共住。如是第二第三说已。安彼外道着眼见耳不闻处。众中应差堪能作羯磨者。如上作如是白。大德僧听。彼某甲外道。今从众僧乞四月共住。若僧时到僧忍听。与彼某甲外道四月共住。白如是。大德僧听。彼某甲外道。从众僧乞四月共住。僧今与彼四月共住。谁诸长老忍僧与彼四月共住者默然。谁不忍者说。僧已忍。与彼外道四月共住竟。僧忍默然故。是事如是持。彼外道行共住竟。令诸比丘心喜悦。然后当于众僧中受具足戒白四羯磨。云何外道。不能令诸比丘心喜悦。彼外道心。故执持外道白衣法。不亲比丘亲外道。不随顺比丘诵习异论。若闻人说外道不好事。便起嗔恚。若闻人毁呰外道师教。亦起嗔恚。闻说佛法僧非法事。便踊跃欢喜。若有异外道来。赞叹外道好事。欢喜踊跃。若有外道师来。闻赞叹外道事。亦欢喜踊跃。若闻说佛法僧非法事。亦欢喜踊跃。是谓外道不能令诸比丘喜悦。云何外道能令比丘喜悦。即反上句是。是谓外道共住和调心意令诸比丘喜悦。尔时有一外道。众僧与四月共住。当与共住时。得正决定心。时诸比丘。以此因缘往白佛。佛言。若得正决定心者。当白四羯磨与授具足。时裸形布萨闻此语。便作是念。沙门释子智慧聪明。我今宁可还彼出家学道耶。即诣僧伽蓝中语诸比丘言。我欲出家学道。时诸比丘。以此事白佛。佛言。此坏内外道者。于我法中无所长益。若未受具足戒者。不应与授具足。已受者当灭摈。尔时世尊。游罗阅城。时摩竭王瓶沙。告语国人言。欲于沙门释子中能出家学道者。听如来法中善修梵行尽诸苦际。时有一奴。来诣僧伽蓝中。语诸比丘言。我欲出家作比丘。时诸比丘。即与出家为道。渐渐人间乞食。为本主所捉。举声唤言。止莫捉我。止莫捉我。左右诸居士问言。何故唤耶。报言。此人捉我。即问彼人言。何故捉耶。报言。是我家奴。诸居士语言。汝放去。不应捉。汝或不能得此人。或为官所罚。何以故知。摩竭王瓶沙。先有教令。若有能于沙门释子中出家学道者。听如来法中善修梵行得尽苦际。莫有留难。其主即放。大唤嗔恚言。祸哉是我奴。而不得自由。如今观之。沙门释子尽是奴聚。时诸比丘。以此事往白佛。佛言。自今已去不得度奴。若度者当如法治。尔时有贼囚。突狱逃走。来至园中语诸比丘言。我欲出家学道。时诸比丘。辄度出家与受具足。时监狱官。捡挍名簿问守狱者言。某甲贼囚今为所在。守狱者报言。某甲贼囚突狱逃走。从沙门释子出家。时监狱官。皆嫌言。沙门释子不知惭愧。外自称言。我知正法。如是何有正法。今观此沙门释子。尽是贼聚。尔时诸比丘。以此事往白佛。佛言。自今已去不得度贼。若度者当如法治。尔时有负债人。逃避债主。来至园中语诸比丘言。度我出家为道。时诸比丘。辄与出家。受具足已人间乞食。为财主所捉。高声唤言。止莫捉我。止莫捉我。左右诸居士闻。即问言。何故唤耶。报言。此人捉我。问其人言。汝何故捉耶。报言。负我财物。诸人语言。汝放去莫捉。汝既不得财。或为官所罚。何以故。摩竭国王瓶沙。先有教令。若有能出家学道者。听善修梵行得尽苦际。随意莫有留难。财主即便放之。而生嗔恚言。负我财物而不能得。以此推之。沙门释子尽是负债人。时诸比丘。以此事往白佛。佛言。自今已去不得度负债人出家。若度者当如法治。尔时佛游罗阅城迦兰陀竹园。时有十七群童子。共为亲厚。最大者年十七。最小者年十二。最富者八十百千。最贫者八十千。中有一童子。名优波离。父母唯有此一子。爱之未曾离目前。父母念言。我当教此儿学何等技术。我等死后。快得生活无所乏短。即自念言。当教先学书。我等死后。快得生活。无所乏短。不令身力疲苦。复作是念。教儿学书亦有身力疲苦耳。更教学何等技术。我等死后。快得生活无所乏短。身力不疲苦。念言。今当教此儿学算数技术。我等死后。快得生活。无所乏短。身力不疲苦。父母念言。今教儿学算数亦有身力疲苦耳。今当更教此儿学何等技术。我等死后。快得生活。无所乏短。身力不疲苦。今当教此儿学画像技术。我等死后。快得生活。无所乏短。复念言。今教此儿学画像技术。恐儿眼力疲苦。当教此儿更学何等技术。我等死后。快得生活。无所乏短。眼力不疲苦。即念言。沙门释子善自养身。安乐无众苦恼。若当教此儿于沙门释子法中出家为道。我等死后。快得生活。无所乏短。身不疲苦。后于异时。十七群童子。语优波离童子言。汝可随我等出家为道。答言。我何用出家为。汝自出家。十七群童子。第二第三语优波离言。可共出家为道。何以故。我等今共相娱乐。于彼亦当如是嬉戏。共相娱乐。时优波离童子。语诸童子言。汝等小待须我白父母。优波离童子。即往父母所白言。我今欲出家为道。愿见听许。父母报言。我等唯有汝一子。心甚爱念。乃至不欲令死别。况当生别。优波离童子如是再三白父母言。愿听我出家。父母亦如是报言。我等唯有汝一子。心甚爱念。乃至不欲令死别。况当生别。尔时父母。得优波离童子再三殷勤。作如是念。我等先已有此意。当教此儿学何技术。我等死后。令儿快得生活。无所乏短。令身力不疲苦。即作是念。若教学书乃至画像。我等死后快得生活无所乏短。令身力不疲苦。而恐劳儿身力眼力以致疲苦。念言。唯有沙门释子。善自养身无众苦恼。若令此儿在中出家。快得生活无有众苦。时父母报儿言。今正是时。听汝出家。时优波离。还至十七群童子所语言。我父母已听我出家。汝等欲去者今正是时。时诸童子。即往僧伽蓝中。白诸比丘言。大德。我欲出家学道。愿诸大德。见与出家为道。尔时诸比丘。即与出家受具足戒。诸童子小来习乐。不堪一食。至于中夜患饥。高声大唤言。与我食与我食。诸比丘语言。汝小待须天明。若众僧有食。当共汝食。若无当共汝乞食。何以故。此中先都无作食处。尔时世尊。夜在静处思惟。闻小儿啼声。知而故问阿难。中夜何等小儿啼声。阿难以此因缘具白世尊。世尊告阿难。不应授年未满二十者具足戒。何以故。若年未满二十。不堪忍寒热饥渴风雨蚊虻毒虫。及不忍恶言。若身有种种苦痛不堪忍。又不堪持戒及一食。若度令出家受具足戒者。当如法治。阿难当知。年满二十者。堪忍如上众事。尔时摩竭国界五种病出。一者癞。二者痈。三者白癞。四者干痟。五者颠狂。彼国人有此病者。皆诣耆婆童子所语言。唯愿见为治。我等当与如是如是财物。耆婆童子报言。我不能治汝。时病者复语言。唯愿救济。我等当以家一切所有身及妻子供给使令。耆婆报言。我不能疗治汝患。时诸病者自相谓言。此人意正。必不与我等治病。我曹当往至彼所欲乐治处。时诸病者。来至僧伽蓝中。语诸比丘言。我欲出家学道。时诸比丘辄度出家。时耆婆童子。疗治佛及比丘僧。给与吐下药。或可与羹者作与。不可与者不与作。或与野鸟肉作羹。随病者所食。蒙此转得除差。既得除差已。皆还休道。时耆婆童子。在道行见罢道道人。在道而来。见已语言。汝先不出家耶。报言曾出家。问言。汝何故休道。报言。我先有患。诣汝所求治言。当与汝如是如是财物。而汝报我言。我不能治。我复重求汝治。当以家一切所有及身妻子供给使令。而汝犹意正不见为治。我等自相谓言。此人意正。必不为我等治病。我曹当更往至彼所乐治处。而必为我治。我等为此病故。往僧伽蓝中。权求出家治病。本无信心。于佛法众所出家。时耆婆闻已不悦即往世尊所。头面礼足在一面坐。白世尊言。昔我先疗治众僧病故舍王事。而诸比丘。度五种病者。癞痈白癞干痟颠狂。唯愿世尊。见愍为敕诸比丘。自今已去。勿复度此五种病者为道。尔时世尊。默然可之。时耆婆。知世尊默然可已。从坐起头面礼足绕三匝而去。尔时世尊。以此因缘集比丘僧。告诸比丘。汝等当知。耆婆童子。先疗治众僧病苦故舍于王事。而诸比丘辄度五种病人。自今已去。不得度五种病人授具足戒。若度者当如法治。尔时佛在罗阅城。城中有一比丘。字难提。常乐坐禅得世俗定心解脱。彼从四禅起。时魔女来在前立。彼比丘捉欲犯。魔即出外。比丘亦随出外。彼魔出屋栏外。比丘亦随出屋栏外。彼出中庭。比丘亦至中庭。魔复出至寺外。比丘亦至寺外。寺外有死草马。时魔至死马所即灭。天身不现。时难提比丘。即于此死马所作不净行。行不净已。都无覆藏心。便作是念。世尊与比丘制戒。若比丘作不净行。波罗夷不共住。我今犯不净行。无有覆藏心。将不犯波罗夷耶。我今当云何。即语亲友比丘言。世尊与比丘结戒。若犯不净行者。得波罗夷不共住。今我犯淫不净行。都无覆藏心。将无犯波罗夷耶。善哉长老。与我白世尊。若有教敕。我当奉行。时诸比丘。以此因缘具白世尊。世尊以此因缘。集比丘僧告言。僧今与难提比丘波罗夷戒白四羯磨。作如是与。使难提比丘到僧中偏露右臂脱革屣礼僧足右膝着地合掌作如是白。大德僧听。我难提比丘。犯不净行都无覆藏心。今从僧乞波罗夷戒。愿僧与我波罗夷戒。慈愍故。如是第二第三说。众中应差堪能羯磨者如上作如是白。大德僧听。此难提比丘。犯不净行无覆藏心。今从僧乞波罗夷戒。若僧时到僧忍听。僧今与难提比丘波罗夷戒。白如是。大德僧听。此难提比丘犯不净行无覆藏心。今从僧乞波罗夷戒。僧今与难提比丘波罗夷戒。谁诸长老忍僧与难提比丘波罗夷戒者默然。谁不忍者说。是初羯磨。第二第三亦如是说。僧已忍。与难提比丘波罗夷戒竟。僧忍默然故是事如是持。与波罗夷戒已。当事事随顺行之。随顺行法者。不得授人具足戒。不得与人依止。不得畜沙弥。若差教诫比丘尼不得受设差不应往教诫。不应为僧说戒。不应在僧中问答毗尼。不应受僧差使作知事人。不应受僧差别处断事。不应受僧差使命。不应早入聚落暮还。当亲近比丘。不得亲近外道白衣。当顺从比丘法。不得说余俗语。不得众中诵律若无能诵者听。不得更犯此罪。余亦不应。若相似若从此生若恶于此者。不得非僧羯磨及作羯磨者。不得受清净比丘敷座洗足水拭革屣揩摩身及礼拜迎逆问讯。不应受清净比丘捉衣钵。不得举清净比丘为作忆念作自言治。不应证正人事。不得遮清净比丘说戒自恣。不得与清净比丘共诤。与波罗夷比丘。僧说戒及羯磨时。来与不来。众僧无犯。诸比丘作是言。若与波罗夷戒比丘。彼比丘重犯淫不净行。复得更与波罗夷戒不。佛言。不应尔。应灭摈

尔时佛在释翅搜迦维罗卫城尼拘律园。时世尊时到着衣持钵入迦维罗卫城乞食。乞食已还出城。于时罗睺罗母。与罗睺罗在高阁上见佛来。语罗睺罗言。彼来者是汝父。尔时罗睺罗。疾疾下楼至如来所。头面礼足在一面立。时世尊以手摩罗睺罗头。罗睺罗自念。从生已来未曾得如是细滑柔软乐。佛问言。汝能出家学道不。答言。我能出家。尔时佛舒一指与罗睺罗捉。将至僧伽蓝中。告舍利弗言。汝度此罗睺罗童子。当如是度。与剃发教着袈裟偏露右肩脱革屣右膝着地合掌。当如是说。我罗睺罗。归依佛归依法归依比丘僧。我于如来所出家学道。如来是我至真等正觉。如是第二第三说。我罗睺罗。归依佛法僧竟。于如来所出家学道。如来即是我至真等正觉。如是第二第三说。当教受戒言。尽形寿不得杀。是谓沙弥戒。乃至不促金银宝物。是谓沙弥戒。此是沙弥十戒。尽形寿不得犯。时舍利弗答言。如是受教。度罗睺罗童子已。将至如来所。头面礼足已在一面立。时舍利弗白世尊言。我已度罗睺罗竟。云何与沙弥房舍卧具。佛言。自今已去从大比丘下次第与。时小沙弥等大小便吐污泥织绳床座卧具。诸比丘往白佛。佛言。自今已去。不得令沙弥坐卧此织绳床上。若能爱护不污听坐卧。舍利弗白佛言。若众僧得施物时。云何与沙弥分。佛告舍利弗。若众僧和合应等与。若不和合当与半。若复不和合。当三分与一分。若不尔众僧不得分。若分当如法治。舍利弗白佛言。小食大食。云何与沙弥。佛言。随大僧次第与。尔时输头檀那王。闻佛度罗睺罗出家。悲泣来僧伽蓝中至世尊所。到已头面礼足在一面坐。一面坐已白世尊言。世尊出家。我有少望心。而难陀童子当为家业。而世尊复度令出家。难陀既出家已。我复有少望心。罗睺罗当为家业。绍嗣不绝。而今世尊复度出家。父母于子多所饶益。乳养瞻视逮其成长。世人所观。而诸比丘。父母不听辄便度之。唯愿世尊。自今已去敕诸比丘。父母不听。不得度令出家。尔时世尊。默然受王语。王见世尊默然受语已。即从坐起。头面礼足绕三匝而去。尔时世尊。以此因缘集比丘僧。告诸比丘。父母于子多所饶益。养育乳哺冀其长大。世人所观。而诸比丘。父母不听辄便度之。自今已去。父母不听。不得度令出家。若度当如法治。尔时佛。游拘睒毗瞿师罗园中。时有巧师家儿。来至僧伽蓝中。求诸比丘出家为道。诸比丘辄与出家度为道。时其父母。啼泣来僧伽蓝中。问诸比丘。颇见如是小儿来不。不见者报言不见。即便于诸房中求觅得。时诸长者皆共讥嫌言。沙门释子不知惭愧。而作妄语。外自称言。我修正法。如是有何正法。今度我小儿已。皆言不见。时诸比丘。以此因缘往白世尊。世尊言。汝等善听。自今已去。若欲在僧伽蓝中剃发。当白一切僧。若不得和合。房房语令知已与剃发。僧若和合当作白。白已然后与剃发。当作如是白。大德僧听。此某甲。欲求某甲剃发。若僧时到僧忍听。与某甲剃发。白如是。若欲僧伽蓝中度令出家。当白一切僧。白已听与出家。当作如是白。大德僧听。此某甲。从某甲出家。若僧时到僧忍听。与某甲出家。白如是。作如是白已。与出家。教使着袈裟。偏露右臂脱革屣右膝着地合掌。教作如是语。我某甲。归依佛归依法归依僧。随如来出家。某甲为和尚。如来至真等正觉是我世尊。如是第二第三说。我某甲。归依佛法僧。随如来出家竟。某甲为和尚。如来至真等正觉是我世尊。如是第二第三说。当受戒。尽形寿不杀生。是谓沙弥戒。能者报言能。尽形寿不盗。是谓沙弥戒。能者报言能。尽形寿不淫。是谓沙弥戒。能者报言能。尽形寿不妄语。是谓沙弥戒。能者报言能。尽形寿不饮酒。是谓沙弥戒。能者报言能。尽形寿不得着花鬘香涂身。是谓沙弥戒。能者报言能。尽形寿不得歌舞倡伎及往观听。是谓沙弥戒。能者报言能。尽形寿不得高广大床上坐。是谓沙弥戒。能者报言能。尽形寿不得非时食。是谓沙弥戒。能者报言能。尽形寿不得执持生像金银宝物。是谓沙弥戒。能持者报言能。此是沙弥十戒。尽形寿不得犯。能持者报言能。时有小沙弥。众僧不听入近村寺及阿兰若处住沙弥遂为豹所害。诸比丘以此事往白佛。佛言。不得两边遮小沙弥。彼时或村边寺无阿兰若处遮沙弥。佛言不应尔。彼阿兰若处无村边寺彼遮沙弥。佛言不应尔。彼复遮沙弥。不听至多人处温室食堂经行堂。沙弥无有止宿处。佛言。不应遮入多人处。乃至经行堂处。若阁上多人宿处。阁下多人行处。阁下多人宿处。阁上多人行处。听语言莫入我宿处。时沙弥不为和尚阿阇梨作使。亦不为余人作使。而彼遮不与沙弥僧中利养物。佛言不应遮。此是施主物。佛言。自今已去应语沙弥言。汝应如法供给和尚阿阇梨及众僧。若僧作使次至应作。尔时有长老比丘。将儿出家已。将入村乞食。若到诸市肆前。见有饼饭舒手言。与我饼与我饭。时诸长者见已。皆共嫌之。沙门释子不知惭愧。犯梵行。外自称言。我知正法。云何出家。故生儿而将自随。如是有何正法。时诸比丘。以此因缘往白世尊。世尊言。自今已去不得度年减十二者

尔时阿难。有檀越家死尽。唯有一小儿在。将至佛所头面礼足在一面坐。佛知而故问。此是何等小儿。阿难以此因缘具白世尊。世尊告言。何故不度令出家答言。世尊先有制。不得度年减十二者。是以不度佛问阿难。此小儿。能驱乌。能持戒。能一食不。若能如是者。听令出家。阿难报言。此小儿。能驱乌能持戒能一食佛告阿难。若此小儿。尽能尔者。听度令出家。尔时跋难陀。有二沙弥。一名罽那二名摩佉。无惭无愧。更互犯不净行。时诸比丘。白佛。佛尔时。呵责跋难陀已。告诸比丘自今已去。不得畜二沙弥。尔时有一比丘儿。来至僧伽蓝中看。时比丘即为说法言。当知地狱苦畜生苦饿鬼苦。佛出世难值。如优昙钵花时乃一出耳。汝何不出家为道。彼报言。若大德。即为作和尚者。我当出家。而彼比丘。先有沙弥念言。世尊制戒。不得畜二沙弥。彼疑不畜二沙弥。时诸比丘。以此因缘往白佛。佛言。若能教持戒增心增慧学问讽诵听畜。尔时有年不满二十者。受具足已后便生疑。诸比丘往问佛。佛言。自今已去。若受具足已。有如是疑。听数胎月。若数闰月。若数十四日说戒日若得阿罗汉。即名为出家受具足。时有欲受戒者至界外。六群比丘往遮受戒。诸比丘。以此因缘往白佛。佛言。汝等善听。自今已去。不同意未出界。在界外疾疾一处集结小界。作白二羯磨已授戒。众中当差堪能羯磨者。如上作如是白。大德僧听。僧集一处结小界。若僧时到僧忍听结小界。白如是。大德僧听。今此僧一处集结小界。谁诸长老忍僧一处集结小界者默然。谁不忍者说。僧已忍结小界竟。僧忍默然故。是事如是持。若不同意者。在界外遮不成遮。彼不解界便去。余比丘疑白佛。佛言。自今已去。应解界去。不应不解界而去。作白二羯磨解。众中当差堪能羯磨者。如上作如是白。大德僧听。今众僧集解界。若僧时到僧忍听解界。白如是。大德僧听。今众僧集解界。谁诸长老忍僧集解界者默然。谁不忍者说。僧已忍解界竟。僧忍默然故。是事如是持。尔时无和尚受具足戒。佛言。不得受戒。二和尚得受戒不。佛言。不得受戒。三和尚得受戒不。佛言。不得受具足。众多和尚得受戒不。佛言。不得受具足戒。尔时和尚九岁受戒。得名受具足戒。而众僧有罪。尔时佛游波罗奈国。时国土饥俭米谷勇贵。乞求难得人民饥色。时佛及众僧多得供养。有一年少外道。见佛众僧多得供养。见已便自剃发。着袈裟出家受戒。后僧供养断。诸比丘语言。汝往入村乞食。问言。众僧无食耶。报言无。彼言。我当云何。比丘报言。汝当乞食。彼言。若乞食此亦乞彼亦乞。我当彼间乞食。其人即休道。尔时诸比丘。以此因缘往白佛。佛言。自今已去听先与四依。尔时复有一年少外道。来诣僧伽蓝中。语诸比丘言。我欲出家。诸比丘即与出家。先与四依法。彼外道报言。大德我堪受二依乞食依树下坐。我堪此二事。纳衣腐烂药。我不堪此二事。何以故。谁能自触己物。即便休道不出家。诸比丘。以此因缘往白佛。佛言。此外道不出家。大有所失。若出家者当得道证。佛言。自今已去。先受戒已。后受四依。尔时佛在舍卫国祇树给孤独园。时有一勇健大将。来至僧伽蓝中。语诸比丘言。我欲出家为道。时诸比丘。即与出家受具足戒。于异时波斯匿王土界人民反叛。即遣军往伐。逆为彼所破。重遣军往。复为彼所破。王即问言。我健将某甲。今为所在。报言。从沙门释子出家为道。时王即讥嫌言。沙门释子不知惭愧。多欲无厌外自称言我知正法。云何度我勇健大将出家为道。如是何有正法。以此推之。沙门释子尽是官人。时诸比丘。以此因缘具白佛。佛言。自今已去。不得度官人。若度者当如法治。尔时与无衣钵者出家受具足戒。诸比丘语言。汝入村乞食。彼言。我无衣钵。时诸比丘。以此事往白佛。佛言。自今已去无衣钵者。不得受具足戒。时有借他衣钵受具足戒。受戒已其主还取。裸形蹲羞惭。时诸比丘。以此因缘往白佛。佛言。自今已去不得借他衣钵受具足戒。若与衣者。当令乞与。不与者当与价直。尔时众多比丘。从拘萨罗国道路行。往黑闇河侧。其中一比丘言。此中曾有白衣。与着袈裟者共行淫。众人问言。汝云何知。答曰。我即彼之一数。尔时诸比丘。以此因缘白佛。佛言。若犯比丘尼者。于我法律中无所长益。不应与出家受大戒。若出家受大戒者应灭摈。尔时佛在波罗奈国。时国界米谷勇贵。乞求难得人皆饥色。时佛及比丘僧。多得供养。时有一年少外道。见佛及僧多得供养。便生此念。当以何方便得此食而不出家。彼即自剃发着袈裟手执钵入众中食。诸比丘问言。汝为几岁。彼不知。复问。汝何时出家。彼言不知。汝和尚谁阿阇梨谁。亦言不知。复问言。汝是谁耶。答言。我是某甲外道。见佛及僧大得供养。见已便生此念。以何方便得此食而不出家。是故我便辄自剃须发着袈裟入众中求食。时诸比丘。以此因缘具白佛。佛言。自今已去。贼心入道者。于我法中无所长益。不应与出家受具足戒。若出家受具足戒应灭摈。是中贼心入道者。或至一比丘二比丘三比丘众僧所共羯磨说戒。或至一比丘二比丘三比丘众僧所共羯磨不说戒。或至一比丘二比丘三比丘众僧所不共羯磨说戒。或至一比丘二比丘三比丘所。不至众僧所。不共羯磨说戒。或至一比丘二比丘所。不至三比丘众僧所。不共羯磨说戒。或至一比丘所。不至二比丘三比丘众僧所。不共羯磨说戒。是中贼心入道者。至一比丘所。不至二比丘三比丘众僧所。不共羯磨说戒。如是人若未出家受具足戒。不应与出家受具足戒。若已与出家受具足戒。听即名出家受具足戒。是中贼心入道者。至一比丘二比丘所。不至三比丘若众僧所。不共羯磨说戒。若未出家受具足戒。不得与出家受具足戒。若已与出家受具足戒。听即名为出家受具足戒。是中贼心入道者。至一比丘二比丘三比丘所。不至众僧所。不共羯磨说戒。若未出家受具足戒。不得与出家受具足戒。若已与出家受具足戒。听即名出家受具足戒。是中贼心入道者。至一比丘二比丘三比丘若众僧所。不共羯磨说戒。若未出家受具足戒者。不得与出家受具足戒。若已与出家受具足戒。听即名出家受具足戒。是中贼心入道者。至一比丘二比丘三比丘众僧所。共羯磨不共说戒。若未出家受具足戒。不得与出家受具足戒。若已与出家受具足戒者应灭摈。是中贼心入道者。至一比丘二比丘三比丘众僧所羯磨说戒。若未出家受具足戒者。不得与出家受具足戒。若已与出家受具足戒者。应灭摈

四分律卷第三十四四分律卷第三十五(二分之十四)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    受戒揵度之五

尔时有黄门。来至僧伽蓝中。语诸比丘言。我欲出家受具足戒。诸比丘即与出家受具足戒。受具足戒已语诸比丘言。共我作如是如是事来。比丘答言。汝灭去失去。何用汝为。彼复至守园人及沙弥所语言。共我作如是如是事来。守园人沙弥语言。汝灭去失去。何用汝为。彼黄门出寺外。共放牛羊人作淫欲事。时诸居士见已讥嫌言。沙门释子并是黄门。中有男子者共作淫欲事。时诸比丘以此因缘白佛。佛言。黄门于我法中无所长益。不得与出家受具足戒。若已出家受具足戒应灭摈。是中黄门者。生黄门。犍黄门。妒黄门。变黄门。半月黄门。生者。生已来黄门。犍者。生已都截去作黄门。妒者。见他行淫已有淫心起。变者。与他行淫时失男根变为黄门。半月者。半月能男半月不能男。尔时佛游波罗奈国。善现龙王寿极长。生厌离心而作是念。今生此长寿龙中。何时得离此身。复作是念。此沙门释子修清净行。我今宁可就彼求出家为道。可得离此龙身。即变身作一年少外道形。往至僧伽蓝中。语诸比丘言。我欲出家受具足戒。时诸比丘。不观其本辄与出家受具足戒。与一比丘同一房住。时彼比丘出外小行。善现龙王放身睡眠。诸龙常法。有二事不离本形。若眠时若淫时。不离本形。时龙王身胀满房中。窗户向孔中。身皆凸出。时彼比丘还。以手排户。手触龙身。觉内有异。即便高声唱言。蛇蛇。比房比丘闻其声。便问言。何故大唤。即以此事具为说之。时彼龙王。亦闻比丘唤声。即还觉结加趺坐直身正意系念在前。时比丘即入问言。汝是谁。答言。我是善现龙王。我生长寿龙中。厌离此身作此念。我何时当得离此龙身。复生此念。沙门释子修清净行。我今宁可从其出家学道免此龙身。时诸比丘。以此因缘往白佛。佛言。畜生者。于我法中无所长益。若未出家。不得与出家受具足戒。若已与出家受具足戒者。当灭摈。尔时有一年少外道。故杀母。既杀已。常怀愁忧念言。谁能为我除此忧者。即复念言。此沙门释子多修善法。我今宁可从其出家学道得灭此罪。即来诣僧伽蓝中。语诸比丘。我欲出家学道。时诸比丘。见已复谓。是善现龙王。即问言。汝是何等人。答言。我是某甲外道。我故杀母。既杀已。常怀愁忧念言。谁能为我除此忧苦。复作是念。沙门释子多修善法。我今宁可从其出家学道得灭此罪。是故来求出家。时诸比丘。以此事往白佛。佛言。杀母者。于我法中无所长益。若未出家。不得与出家受具足戒。若与出家受具足戒。应灭摈。时复有一外道。故杀父。既杀已。常怀愁忧念言。谁能为我除此忧苦。即念言。沙门释子多修善法。我今宁可从其出家学道。可得灭此罪。即往僧伽蓝中。语诸比丘言。我欲出家为道诸比丘见已。谓为善现龙王。问言。汝是何等人。答言。我是某甲外道。故杀父。既杀已。常怀愁忧念言。谁能为我除此忧苦。即复念言。沙门释子多修善法。我令宁可从其出家学道。可得灭此罪。是故来求出家。时诸比丘。以此事往白佛。佛言。杀父者。于我法中无所长益。若未出家。不得与出家受具足戒。若与出家受具足戒。应灭摈。时有众多比丘。从拘萨罗国在道行。见有阿兰若处。自相指示言。此是某甲阿兰若处。于中杀阿罗汉。中有一人言。此实是阿罗汉。何以故。当杀时心无有异。有人问言。云何知。答言。我即是其人之一数。时诸比丘。以此事具白佛。佛言。杀阿罗汉人。于我法中无所长益。若未出家。不得与出家受具足戒。若与出家受具足戒。当灭摈。时尊者优波离。从坐起偏露右肩脱革屣右膝着地合掌白佛言。若有破坏僧者。当云何。佛言。如提婆达比。若未出家受具足戒。不得与出家受具足戒。若与出家受具足戒者。当灭摈。又问。恶心出佛身血者当云何。佛言。如提婆达比。若未出家受具足戒者。不得与出家受具足戒。若与出家受具足戒。应灭摈。尔时有一比丘。变为女形。诸比丘念言。应灭摈不。佛言。不应灭摈。听即以先受具足戒年岁和尚阿阇梨送置比丘尼众中。尔时有一比丘尼。变为男子形。诸比丘尼念言。应灭摈不。佛言。不应灭摈。听即以先受戒年岁和尚阿阇梨当安置比丘众中。尔时有一比丘。变为男女二形。诸比丘念言。应灭摈不。佛言应灭摈。尔时有一比丘尼。变为男女二形。诸比丘尼念言。应灭摈不。佛言应灭摈。尔时有比丘。被贼截其男根并卵。诸比丘念言。应灭摈不。佛言。不应灭摈。尔时有比丘。为怨家截其男根及卵。诸比丘念言。应灭摈不。佛言。不应灭摈。尔时有比丘。为恶兽啮男根及卵。诸比丘念言。应灭摈不。佛言。不应灭摈。尔时有比丘。业报因缘男根自落。诸比丘念言。应灭摈不。佛言。不应灭摈。尔时有比丘。自截其男根。诸比丘念言。应灭摈不。佛言应灭摈。尔时有欲受具足者将出界外。诸比丘问。汝是谁。不自称字。复问言。汝和尚是谁。复不称和尚名。教乞戒而不乞。诸比丘白佛。佛言。有三种人。名为不得受具足戒。不自称字。不肯称和尚名。教乞戒而不乞。是为三种人不得受具足戒。尔时有着白衣衣服受具足戒。受具足戒已即着入村中乞食。诸居士见问言。汝是谁。答言。我是沙门释子。居士言。沙门释子不如是。佛言。不得着白衣衣服受具足戒。尔时复有着外道衣服受具足戒。受具足戒已入村乞食。诸居士见问言。汝是何等人。答言。我是沙门释子。居士言。沙门释子不如是。佛言。着外道衣服者。不应与受具足戒。尔时有着众庄严身具者。受具足戒。受具足戒已入村乞食。诸居士见问言。汝是何等人。答言。我是沙门释子。居士言。沙门释子不如是。佛言。着众庄严身具者。不得与受具足戒。有三种人。不名为受具足戒。着俗服外道服众庄严身具。是谓三种人不成受具足戒。尔时有与眠人受具足戒。觉已还家。诸比丘言。止莫还家。汝已受具足戒。彼答言。我不受具足戒。诸比丘往白佛。佛言。不得授眠者具足戒。尔时有与醉者受具足戒。酒解已即还家。诸比丘言。汝已受具足戒。止莫还家。答言。我不受具足戒。佛言。不得授醉者具足戒。尔时有与狂者授具足戒。狂者得心已便还家。诸比丘言。汝止莫去。汝已受具足戒。答言。我不受具足戒。佛言。不得与狂者授具足戒。有三种人。不得受具足戒。眠醉狂。是谓三种不得授具足戒。尔时有裸形人受具足戒。后得衣服已还家。诸比丘言。汝已受具足戒。止莫还家。答言。我不受具足戒。佛言。不得与裸形人受具足戒。尔时有与嗔恚人受具足戒。后嗔恚止还家。诸比丘语言。汝已受具足戒。莫还家。答言。我不受具足戒。佛言。不得与嗔恚者受具足戒。尔时有强授人具足戒。后便逃走还家。诸比丘言。汝已受具足戒。止莫还家。答言。我不受具足戒。佛言。不得强授人具足戒。有三种人。非受具足戒。裸形嗔恚强与受具足戒者。是谓三种人非受具足戒。如是截手。截脚。截手脚。或截耳或截鼻。或截耳鼻。或截男根。或截卵。或截男根卵。或截臂。或截肘。或截指。或常患疥疮。或死相现。或身瘿。或身如女身。或有名籍。或避官租赋。或痈疮。或身驳或尖头。或左臂坏。或右臂坏。或举齿。或虫身。或虫头。或头发痶痪。或曲指。或六指。或缦指。或有一卵。或无卵。或[病-丙+貴]或身内曲。或身外曲。或内外曲。或上气病。或瘊病。或吐沫病。或病。或诸苦恼。或男根病。或青眼。或黄眼。或赤眼。或烂眼。或有红眼。或黄赤色眼。或青翳眼。或黄翳眼。或白翳眼。或水精眼。或极深眼。或三角眼。或弥离眼。或大张眼。或凸眼。或一眼。或睐眼。或盲眼。或尖出眼。或斜眼。或嗔怒眼。或瞷眼。或眼有疮患。或身班。或身疥瘙。或身侵淫疮。或哑。或聋。或哑聋。或卷足指。或跛。或曳脚。或一手一脚一耳。或无手无脚无耳。或无发无毛。或无齿。或青发。黄发。白发。大长。大短。妇女[跳-兆+尃]。天子。阿修罗子。揵闼婆子。或有象头。或有马头。或有骆驼头。或有牛头。或有驴头。或有猪头。或羖羊头。或有白羊头。或有鹿头。或有蛇头。或有鱼头。或有鸟头。或有二头。或有三头。或有多头。一切青。一切黄。一切黑。一切赤。一切白。一切似猕猴色。或有风病。或有热病。或有痰癊病。或癖病。或有喉戾。或有兔缺。或无舌。或截舌。或不知好恶。或身前凸。或后凸。或前后凸。或虫病。或水病。或内病。或外病。或内外病。或有癖病。常卧不转病。或有常老极。或有干痟病。或有失威仪行下极一切污辱众僧。如此人不得度受具足戒。尔时有神足在虚空中受具足戒。佛言。不名受具足戒。和尚在虚空中与下人受具足戒。佛言。不名受具足戒。神足在虚空中足数受具足戒。佛言。不名受具足戒。尔时有隐没不现者受具足戒。佛言。不名受具足戒。和尚隐没受具足戒。佛言。不名受具足戒。足数比丘隐没受具足戒。佛言。不名受具足戒。尔时离见闻处受具足戒。佛言。不名受具足戒。和尚离见闻处受具足戒。佛言。不名受具足戒。足数人离见闻处受具足戒。佛言。不名受具足戒。尔时在界外受具足戒。佛言。不名受具足戒。和尚在界外受具足戒。佛言。不名受具足戒。足数人在界外受具足戒。佛言。不名受具足戒。时有不与沙弥戒便受具足戒。佛言。得受具足戒。众僧有犯。世尊有如是教。一切污辱众僧者不得受具足戒。时有欲受戒者。彼将至界外脱衣看。时受戒者惭耻。稽留受戒事。尔时诸比丘。以此事往白世尊。世尊言。不得如是露形看而为授戒。自今已去。听问十三难事。然后授具足戒。白四羯磨当作如是问。汝不犯边罪。汝不犯比丘尼。汝非贼心入道。汝非坏二道。汝非黄门。汝非杀父杀母。汝非杀阿罗汉。汝非破僧。汝不恶心出佛身血。汝非是非人。汝非畜生。汝非有二形耶。佛言。自今已去。听先问十三难事然后授具足戒。当作白四羯磨。如是授具足戒。尔时立欲受具足者。置眼见耳不闻处。时戒师当作白羯磨言。大德僧听。彼某甲。从某甲求受具足戒。若僧时到僧忍听。某甲为教授师。白如是。时教授师。当往彼语言。此安陀会郁多罗僧僧伽梨钵。此衣钵是汝有不。彼答言是。应语言。善男子谛听。今是至诚时。我今当问。汝随我问答。若不实当言不实。若实当言实。汝字何等。和尚字谁。年满二十不。衣钵具足不。父母听汝不。汝非负债人不。汝非奴不。汝非官人不。汝是丈夫不。丈夫有如是病。癞痈疽白癞干痟颠狂病。汝今有此诸病不。若无。答言无。应语言。如我今问汝。僧中亦当如是问。如汝向者答我。众僧中亦当如是答。彼教授师。如是问已。还来众僧中。如常威仪。相去舒手相及处立。当如是白。大德僧听。彼某甲。从某甲求受具足戒。若僧时到僧忍听。我已问竟听将来。白如是。彼唤言汝来。彼来已。当为捉衣钵。教礼僧足已。教在戒师前。右膝着地合掌。当教作如是语。大德僧听。我某甲。从某甲求受具足戒。我某甲。今从众僧乞受具足戒。某甲为和尚。愿僧慈愍故拔济我。第二第三亦如是说。时戒师当作白羯磨。如是白。大德僧听。此某甲。从某甲求受具足戒。此某甲。今从众僧乞受具足戒。某甲为和尚。若僧时到僧忍听。我问诸难事。白如是。善男子听。今是至诚时实语时。我今问汝。汝当随实答我。汝字何等。和尚字谁。汝年满二十未。三衣钵具不。父母听汝不。汝不负债不。汝非奴不。汝非官人不。汝是丈夫不。丈夫有如是病。癞痈疽白癞干痟颠狂病。汝今有如是病无。若言无者。当作白四羯磨。应如是白。大德僧听。此某甲。从某甲求受具足戒。此某甲。今从僧乞受具足戒。某甲为和尚。某甲自说清净无诸难事。年满二十三衣钵具。若僧时到僧忍听。僧今授某甲具足戒。某甲为和尚白如是。大德僧听。此某甲。从某甲求受具足戒。此某甲。今从僧乞受具足戒。某甲为和尚。某甲。自说清净无诸难事。年满二十三衣钵具。僧今授某甲具足戒。某甲为和尚。谁诸长老忍。僧与某甲授具足戒。某甲为和尚者默然。谁不忍者说。此是初羯磨。第二第三亦如是说。僧已忍。与某甲受具足戒。某甲为和尚竟。僧忍默然故。是事如是持。时有比丘。受具足戒已。众僧尽舍去。时所受具足戒人本二。去彼不远。即前问言。汝向者何所为。答言。我受具足戒。本二语言。汝今可共作如是如是事。可谓最后作如是如是事。时受具足者。即共行不净已。后还诣众中。诸比丘问。汝何故在后。彼即以此因缘具向诸比丘说。诸比丘语言。汝速灭去失去。何用汝为。不应住此。其人言。我所作事不应尔耶。诸比丘报言。不应尔。其人语言。汝何不先语我。我当避之不作。尔时诸比丘。以此事往白世尊。世尊言。自今已去。作羯磨已。当先说四波罗夷法。善男子听。如来至真等正觉说四波罗夷法。若比丘。犯一一法。非沙门非释种子。汝一切不得犯淫作不净行。若比丘。犯不净行受淫欲法乃至畜生。非沙门非释种子。尔时世尊。与说譬喻。犹如有人截其头终不能还活。比丘亦如是。犯波罗夷法已。不能还成比丘行。汝是中尽形寿不得作。能持不。答言能。一切不得盗。下至草叶。若比丘。盗人五钱若过五钱。若自取教人取。若自破教人破。若自斫教人斫。若烧若埋若坏色者。彼非沙门非释种子。譬如断多罗树心终不复更生长。比丘。犯波罗夷亦如是。终不还成比丘行。汝是中尽形寿不得作。能持不。答言能。一切不得故断众生命。下至蚁子。若比丘。故自手断人命。求刀授与人。教死叹死。劝死。与人非药。若堕胎若厌祷杀。自作方便。若教人作。非沙门非释种子。譬喻者说言。犹如针鼻决不堪复用。比丘亦如是。比丘。犯波罗夷法。不复成比丘行。汝是中尽形寿不得作。能持不。答言能。一切不得妄语。乃至戏笑。若比丘。非真实。非已有。自说言。我得上人法。得禅。得解脱。得定。得四空定。得须陀洹果。斯陀含果。阿那含果。阿罗汉果。天来龙来鬼神来。彼非沙门非释种子。譬喻者说。譬如大石破为二分终不可还合。比丘亦如是。犯波罗夷法。不可还成比丘行。汝是中尽形寿不得作。能持不。能者答言能。善男子听。如来至真等正觉说四依法。比丘。依此得出家受具足戒。成比丘法。比丘。依粪扫衣。依此得出家受具足戒。成比丘法。是中尽形寿能持不。答言能。若得长利。檀越施衣。割坏衣得受。比丘依乞食。比丘依是得出家受具足。得成比丘法。是中尽形寿能持不。答言能。若得长利。若僧差食。檀越送食。月八日食。十五日食。月初日食。若僧常食。檀越请。食得受。依树下坐。比丘。依此得出家受具足。成比丘法。是中尽形寿能持不。答言能。若得长利。若别房尖头屋。小房石室。两房一户。得受。依腐烂药。比丘依此得出家受具足。成比丘法。是中尽形寿能持不。答言能。若得长利酥油生酥蜜石蜜得受。汝受戒已。白四羯磨如法成就得处所和尚如法。阿阇梨如法。众僧具足满。汝当善受教法。应当劝化作福治塔。供养佛法众僧和尚阿阇梨。若一切如法教不得违逆。应学问诵经勤求方便。于佛法中。得须陀洹果斯陀含果阿那含果阿罗汉果。汝始发心出家。功不唐捐。果报不绝。余所未知。当问和尚阿阇梨。自今已去。令受具足者在前而去。尔时有比丘。众中被举已即休道。后来至僧伽蓝中。语诸比丘言。我欲还出家。时诸比丘。以此因缘往白佛。佛言。当问彼人。汝自见罪不。若报言。我不见罪。不应与出家。若言我见罪与出家。与出家已。复当问言。汝见罪不。若言不见罪。不应与受具足戒。若言见罪。应与授具足戒与授具足戒已当语言。汝能忏悔不。若言不能忏悔。不得与解羯磨。若言能忏悔。当与解羯磨。与解羯磨已当语言。汝忏悔罪。若忏悔善。不者若僧得和合。更与作举。若僧不和合。与共住止。无犯。尔时舍利弗从座起偏袒右肩右膝着地合掌白佛言。年不满二十而受具足戒。当言是受具足人不。佛言。是受具足人。复问。所授具足人是善授不。佛言。是善授。作羯磨者。是善作羯磨不。佛言。善作羯磨。自制已后。如是受具足戒。不名善受具足戒。复问。三语受具足戒。是受具足戒不。佛言。是受具足戒。所授具足戒者。是善授不。佛言。是善授。作羯磨者。是善作羯磨不。佛言。是善作羯磨。自制已后。如是受具足者。不名受具足戒。又问。不问十三难事。而受具足戒。当言是受具足戒不。佛言是善受具足戒。问言。所授具足者。为善授具足戒不。佛言。是善授具足戒。问言。作羯磨者是善作羯磨不。佛言。善作羯磨。自制后。如是受具足者。不名受具足戒。尔时阿难。即从座起偏露右肩右膝着地。合掌白佛言。若和尚。十三难事中有一一事。授弟子具足戒。当言善受具足不。佛言。善受具足戒。问言。所授具足人。名为善授具足戒不。佛言。是善授。作羯磨者善作羯磨不。佛言。是善作羯磨。自制后。若如是授人具足戒。众僧有罪。尔时有从不持戒和尚受具足戒。后有疑。佛问言。汝知和尚不持戒不。答言不知。佛言。得名受具足戒。复有从不持戒和尚受具足戒。后有疑。佛问言。汝知和尚不持戒不。报言知。汝知不应从如此人受具足戒不。报言不知。佛言。此得受具足戒。尔时复有从不持戒和尚受具足戒后有疑。佛问言。汝知和尚不持戒不。答言知汝知如此人不应从受具足戒不。答言知。佛言。汝如从如此人受具足戒不得具足戒不。报言不知。佛言得名受具足戒。尔时有从不持戒和尚受具足戒。后有疑。佛问言。汝知和尚不持戒不答言知。佛言。汝知如此人不应从受具足戒。不答言知。佛问言。汝知从如此人受具足戒不成受具足戒不。答言知。佛言。不名受具足戒(受戒揵度具足竟)

    说戒揵度上

尔时佛在罗阅城。时城中诸外道梵志。月三时集会月八日十四日十五日。众人大集来往周旋。共为知友给与饮食。极相爱念经日供养。时瓶沙王在阁堂上。遥见大众往诣梵志聚会处。即便问左右人言。今此诸人。为欲何所至。答言。王今知之。此城中梵志。月三集会。八日十四日十五日众人来往周旋。共为知友给与饮食极相爱念。是故众人往诣梵志聚集处。时瓶沙王。即下阁堂往诣世尊所头面礼足已在一面坐。白佛言。今此罗阅城中诸梵志。月三时集会。八日十四日十五日。周旋往返共为知友给与饮食。善哉世尊。今敕诸比丘。令月三时集会。八日十四日十五日。亦当使众人周旋往来。共为知友给与饮食。我及群臣亦当来集。时世尊默然受王瓶沙语。王见世尊默然受语已。即从座起头面礼足绕已而去。时世尊以此因缘集比丘僧告言。今此罗阅城中诸梵志。月三时会。八日十四日十五日。共相往来周旋。共为知友给与饮食极相爱念。汝亦月三时会。八日十四日十五日集。亦使众人来往周旋。共为知友给与饮食。瓶沙王及群臣亦当来集。答言如是世尊。时诸比丘受教已。月三时集。八日十四日十五日。时大众集周旋往来。共为知友给与饮食。王瓶沙。亦复将诸群臣大众来集。时诸比丘来集已。各各默然而坐。诸长者白诸比丘言。我等欲闻说法。诸比丘不敢说。以此事白佛。佛言。听汝等与说法。既听已。不知当说何法。佛言。自今已去。听说契经。时诸比丘。欲分别说义。当说义时。不具说文句。各自生疑。佛言。听说义不具说文句。时二比丘。共一高座说法。佛言不应尔。二比丘同一高座说法共诤。佛言不应尔。彼相近敷高座说义。互求长短。佛言。不应尔。彼因说义共相逼切。佛言不应尔。时诸比丘二人。共同声合呗。佛言。不应尔。时诸比丘。欲歌咏声说法。佛言听。时有一比丘。去世尊不远。极过差歌咏声说法。佛闻已即告此比丘。汝莫如是说法。汝当如如来处中说法。勿与凡世人同。欲说法者。当如舍利弗目揵连平等说法。勿与凡世人同说法。诸比丘。若过差歌咏声说法。有五过失。何等五。若比丘过差歌咏声说法。便自生贪着爱乐音声。是谓第一过失。复次若比丘过差歌咏声说法。其有闻者生贪着爱乐其声。是谓比丘第二过失复次若比丘过差歌咏声说法。其有闻者令其习学。是谓比丘第三过失。复次比丘过差歌咏声说法。诸长者。闻皆共讥嫌言。我等所习歌咏声。比丘亦如是说法。便生慢心不恭敬。是谓比丘第四过失。复次若比丘过差歌咏声说法。若在寂静之处思惟。缘忆音声以乱禅定。是谓比丘第五过失。时诸比丘。欲夜集一处说法。佛言听说。诸比丘不知何日集。佛言。听十五日十四日十三日若十日若九日若八日若五日若三日若二日若日日说。若说法人少。应次第请说。彼不肯说。佛言不应尔。听应极少下至说一偈一偈者。诸恶莫作诸善奉行自净其意是诸佛教。若不肯者。当如法治时诸比丘。夜集欲说法。时坐卑座有疑。佛言。若夜集说法者。座高卑无在。时诸比丘。夜集欲坐禅。佛言听。时诸比丘睡眠。佛言。比坐者当觉之。若手不相及者。当持户钥。若拂柄觉之。若与同意者。当持革屣掷之。若犹故睡眠。当持禅杖觉之。中有得禅杖觉已呵不受。佛言不应尔。若呵不受者。当如法治。若复睡眠。佛言。听以水洒之。其中有得水洒者。若呵不受。亦当如法治。若故复睡眠。佛言当抆眼。若以水洗面。时诸比丘。犹故复睡眠。佛言。当自摘耳鼻。若摩额上。若复睡眠。当披张郁多罗僧以手摩扪其身。若当起出户外瞻视四方仰观星宿。若至经行处守摄诸根令心不散。尔时世尊。在闲静处思惟。作是念言。我与诸比丘结戒。说波罗提木叉。中有信心新受戒比丘。未得闻戒。不知当云何学戒。我今宁可听诸比丘集在一处说波罗提木叉戒。尔时世尊。从静处出。以此因缘集诸比丘告言。我向者在静处思惟。心念言。我与诸比丘结戒。及说波罗提木叉戒。有信心新受戒比丘。未得闻戒。不知当云何学戒。复自念言。我今宁可听诸比丘集在一处说波罗提木叉。以是故。听诸比丘共集在一处说波罗提木叉戒。作如是说。诸大德。我今欲说波罗提木叉戒。汝等谛听。善心念之。若自知有犯者。即应自忏悔。不犯者默然。默然者。知诸大德清净。若有他问者。亦如是答。如是比丘。在众中乃至三问。忆念有罪不忏悔者。得故妄语罪故。妄语者。佛说障道法。若彼比丘。忆念有罪。欲求清净者应忏悔。忏悔得安乐。波罗提木叉者戒也。自摄持威仪住处行根面首集众善法三昧成就。我当说当结当发起演布开现反复分别。是故诸大德。我今当说戒。共集在一处者。同羯磨集在一处。应与欲者受欲来。现前应呵者不呵。是故言应集在一处。谛听善心念者。端意专心听法故。曰谛听善心念之。有犯者。所作犯事未忏悔。无犯者不犯。若犯已忏悔。若有他问亦如是答者。譬如一一比丘相问答故妄语。佛说障道法者。障何等道。障初禅二禅三禅四禅空无相无愿。障须陀洹果乃至阿罗汉果。忏悔则安乐。得何等安乐。得初禅乃至四禅空无相无愿。得须陀洹果乃至阿罗汉果。故曰忏悔则安乐。时诸比丘。欲歌咏声说戒。佛言。听歌咏声说戒。时诸比丘。日日说戒疲惓。佛言。不应日日说戒。自今已去。听布萨日说戒。时诸长者。问比丘言。今日是何日。比丘言。不知皆惭愧。时诸比丘。以此因缘。白佛。佛言。自今已去当数日。既数日而多忘。佛言。当作数法。时诸比丘。以宝作数法。佛言不应尔。听以骨牙角若铜铁铅锡白镴石泥丸作。诸比丘患数法零落。佛言。听作孔以绳缕贯。置僧常大食少食处。夜集处。说戒处。若置杙上。若龙牙杙上。若一日过。一时诸长者来问比丘言。今日是黑月是白月耶。诸比丘不知。皆怀惭愧。以此事往白佛。佛言。听作三十数法。十五属黑月。十五属白月。时诸比丘。用数法错乱。黑月数法堕白月数法中。白月数法堕黑月数法中。佛言。自今已去听黑月数法染使黑。白月数法染使白。若患数法相杂破坏者。佛言。听中间安隔。时诸比丘。欲十四日若十五日说戒。佛言。若王或改日。随王者法。时诸比丘。不知为今日说戒为明日说戒往白佛。佛言。听上座布萨日唱言今日众僧说戒。时诸比丘不知何时。佛言。听作时若量影时。若作破竹声。若打地声。若作烟。若吹贝。若打鼓。若打揵稚。若告语言。诸大德。布萨说戒时到。时六群比丘。闻世尊听说戒。便于园中若别房中。与和尚阿阇梨。和同尚同阿阇梨。同意亲厚知识。别部说戒。时诸比丘闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责六群比丘言。云何闻世尊听说戒。便自于园中。若别房中与和尚阿阇梨。若同和尚同阿阇梨。亲厚知识。别部说戒耶。尔时大迦宾[少/兔]。在仙人住处黑石山侧。在静处思惟。而作是念。我今若往说戒若不往。我常第一清净。尔时世尊。知长老大迦宾[少/兔]心中所念。譬如力士屈申臂顷。从耆阇崛山忽然不现。乃在仙人住处黑石山侧。在迦宾[少/兔]前敷座而坐。时迦宾[少/兔]。礼世尊足已在一面坐。时世尊知而故问。汝在此闲静处思惟。心作是念。我今若往说戒若不往。我常第一清净。为尔已不答言尔。佛言。如是如是迦宾[少/兔]。如汝所言。汝若往就说戒若不往。汝常第一清净。然迦宾[少/兔]。说戒法当应恭敬尊重承事。若汝不恭敬布萨尊重承事者。谁当恭敬尊重承事。是故汝应往说戒。不应不往。应当步往。不应乘神足往。我亦当往。尔时迦宾[少/兔]。默然受佛教敕。时世尊以此因缘告迦宾[少/兔]已。譬如力士屈申臂顷。没仙人住。处黑石山。还耆阇崛山。就座而坐。尔时诸比丘。往至佛所头面礼足在一面坐。以此事白佛。佛具以上事为说已。佛告诸比丘。我听诸比丘。一住处和合说戒。汝等云何与和尚阿阇梨同和尚阿阇梨亲厚知识别部说戒。若一住处不和合说戒者。得突吉罗。自今已去。听集一处说戒。尔时诸比丘。知世尊听一处说戒。或在仙人所住山黑石处相待。或在毗呵勒山七叶树窟相待。或在冢间相待。或在温泉水边相待。或在竹园迦兰陀所相待。或在耆阇崛山相待。或在大堂食堂经行堂河边树下生软草处。相待而疲惓。时诸比丘往白佛。佛言。自今已去。随所住处人多少。共集一处说戒。诸比丘不知。当于何处说戒。佛言。听作说戒堂白二羯磨。作如是白。当称名处所大堂若阁上堂经行堂若河侧若树下若石侧若生草处众中应差堪能羯磨者。如上当作如是白大德僧听。若僧时到僧忍听。在某甲处作说戒堂。白如是。大德僧听。今众僧。在某甲处作说戒堂。谁诸长老忍。僧在某甲处作说戒堂者默然。谁不忍者说。僧已忍。听在某甲处作说戒堂竟。僧忍默然故。是事如是持。尔时于耆阇崛山中先立说戒堂。复欲于迦兰陀竹园立说戒堂。时诸比丘往白佛。佛言。自今已去。听解前说戒堂然后更结。白二羯磨解。众中应差堪能羯磨者。如上作如是白。大德僧听。若僧时到僧忍听。解某处说戒堂。白如是。大德僧听。今僧解某处说戒堂。谁诸长老忍僧解某处说戒堂者默然。谁不忍者说。僧已忍。听解某处说戒堂竟僧忍默然故。是事如是持。时一住处。作二说戒堂。经营者二人共诤。二人各言。众僧应先于我堂说戒。时诸比丘。以此事往白佛。佛言。自今已去。听二人更互。从上座为始。尔时有住处。布萨日大众集。而说戒堂小。不相容受。诸比丘念言。世尊制戒。不结说戒堂。不得说戒。今当云何。诸比丘以此事往白佛佛言。僧得自在。若结若不结得说戒。时上座比丘。先至说戒堂。扫洒敷座。具净水瓶具洗足瓶。然灯具舍罗疲极。诸比丘。以此事往白佛。佛言。自今已去。年少比丘应作。年少比丘。于布萨日。应先至说戒堂中。扫洒敷座具。具净水瓶洗足瓶。然灯火具舍罗。若年少比丘不知者。上座当教。若上座不教者突吉罗。若不随上座教者亦突吉罗。时上座说戒竟。在后自收摄床座水瓶洗足瓶及灯火具舍罗复本处疲极。时诸比丘。以此事往白佛。佛言。自今已去说戒竟。年少比丘。应摄水瓶。洗足瓶。灯火及舍罗复本处。若年少不知上座当教上座不教者突吉罗。不随上座教者亦突吉罗。时六群比丘。于说戒日。与诸白衣言语问讯。作羯磨说戒说法。尔时诸比丘。以此事往白佛。佛言。此是上座应作。尔时有一住处。痴和先为上座。彼不能于说戒日与白衣言。谈问讯作羯磨说戒说法。尔时诸比丘。以此事往白佛。佛言。听请能作者作。若上座不请能者突吉罗。若不受上座请突吉罗。时诸白衣问比丘。说戒时有几人。问已不知数有惭愧。诸比丘往白佛。佛言。听数比丘。虽数犹复忘。佛言。当具舍罗。彼以宝作。佛言。不得以宝作。当用骨牙若角铜铁白镴铅锡苇若竹若木。作患零落。佛言。当绳缠。虽缠犹故零落。佛言。当作函筒盛。彼用宝作筒。佛言。不应尔。当用骨牙角铜铁白镴铅锡苇竹木。若从筒中出佛言。当作盖彼用宝作盖。佛言。不应尔。当以骨牙角铜铁白镴铅锡苇竹木。不知安筒何处。佛言。安着绳床若木床下。若悬着杙上若龙牙杙上衣架上。尔时诸比丘。闻佛听诸比丘诣罗阅城说戒。在诸方闻者。来集说戒疲极。时诸比丘白佛。佛言。自今已去。随所住处。若村若邑境界处说戒。听结界白二羯磨。当作如是结唱界方相。若空处。若树下。若山若谷。若岩窟。若露地。若草[卄/積]处。若近园边。若冢间。若水涧。若石积所。若树杌。若荆蕀边。若汪水。若渠侧。若池。若粪聚所。若村。若村界。彼称四方相已。众中应差堪能羯磨者。如上当作白。大德僧听。如所说界相。若僧时到僧忍听。于此一住处一说戒结界。白如是。大德僧听。如所说界相。僧今于此一住处一说戒结界。谁诸长老忍。僧于此一住处一说戒结界者默然。谁不忍者说。僧已忍。于此一住处。一说戒结界竟。僧忍默然故。是事如是持。佛言。自今已去。听结界应如是结。当敷座当打揵稚。尽共集一处。不听受欲。是中旧住比丘。应唱大界四方相。若东方有山称山有堑称堑。若村若城。若疆畔若园。若林若池。若树若石。若垣墙。若神祀舍。如东方相。余方亦尔。众中应差堪能羯磨者。如上当如是白。大德僧听。此住处比丘。唱四方大界相。若僧时到僧忍听。僧今于此四方相内结大界。同一住处同一说戒。白如是。大德僧听。此住处比丘。唱四方大界相。僧今于此四方相内结大界。同一住处同一说戒。谁诸长老忍。僧于此四方相内结大界。同一住处同一说戒者默然。谁不忍者说。僧已忍。于此四方相内。同一住处同一说戒。结大界竟僧忍默然故。是事如是持。时诸比丘。有须四人众羯磨事起。五比丘众。十比丘众。二十比丘众羯磨事起。是中大众集会疲极。诸比丘白佛。佛言。听结戒场。当如是结。白二羯磨称四方界相。若安杙若石若疆畔作齐限。众中当差堪能羯磨人如上。大德僧听。此住处比丘。称四方小界相。若僧时到僧忍听。僧今于此四方小界相内结作戒场。白如是。大德僧听此住处比丘。称四方小界相。今僧于此四方小界相内结戒场。谁诸长老忍。僧于此四方相内结戒场者默然。谁不忍者说。僧已忍于此四方相内结戒场竟。僧忍默然故。是事如是持。时诸比丘。意有欲广作界者有欲狭作者。佛言。自今已去。若欲改作者先解前界然后欲广狭作从意当作白二羯磨解众中当差堪能羯磨人。如上作如是白。大德僧听。今此住处比丘。同一住处同一说戒。若僧时到僧忍听解界。白如是。大德僧听。此住处比丘。同一住处同一说戒今解界。谁诸长老忍。僧今同一住处同一说戒解界者默然。谁不忍者说。僧已忍。同一住处同一说戒解界竟。僧忍默然故。是事如是持。时有厌离比丘。见阿兰若处有一好窟。自念言。我若得离衣宿者。可即于此窟住。时诸比丘。以此事往白佛。佛言。自今已去。当结不失衣界。白二羯磨结。众中当差堪能羯磨者。如上作如是白。大德僧听。此住处同一住处同一说戒。若僧时到僧忍听结不失衣界。白如是。大德僧听。此住处同一住处同一说戒。今僧结不失衣界。谁诸长老忍。僧今同一住处同一说戒结不失衣界者默然。谁不忍者说。僧已忍。此住处同一住处同一说戒。结不失衣界竟。僧忍默然故。是事如是持。时诸比丘。脱衣置白衣舍。当着脱衣时形露。时诸比丘。以此事往白佛。佛言。自今已去。听比丘结不失衣界。除村村外界。白二羯磨。众中当差堪能羯磨人。如上当作如是白。大德僧听。此住处同一住处同一说戒。若僧时到僧忍听。结不失衣界。除村村外界。白如是。大德僧听。此住处同一住处同一说戒。今僧结不失衣界。除村村外界。谁诸长老忍僧于此住处同一住处同一说戒。结不失衣界。除村村外界者默然。谁不忍者说。僧已忍听。同一住处同一说戒。结不失衣界。除村村外界竟。僧忍默然故。是事如是持。时诸比丘二界相接。佛言。不应尔当作幖帜。彼二界共相错涉。佛言。不应尔。应留中间。彼诸比丘。先解大界。却解不失衣界。佛言。不应尔。先解不失衣界却解大界。时隔駃流河水外结不失衣界。诸比丘。往取衣为水所漂。诸比丘往白佛。佛言。自今已去。不得隔駃流水外结不失衣界。除常有桥者。

尔时有二住处。别利养别说戒。诸比丘。欲结共一说戒共一利养。诸比丘往白佛。佛言。自今已去。听解界已然后结。白二羯磨如是解。彼此各自解界。应尽集一处。不得受欲。当唱界四方相。阿兰若处。树下空处。若山若谷。若岩窟露地。草[卄/積]园林。冢间河侧。若石[卄/積]若杌树。若荆棘若堑。若渠若池。若粪聚若村村界。唱界齐限处已。众中当差堪能羯磨者。如上当作如是白。大德僧听。如所说界相。若僧时到僧忍听。于此处彼处。结同一利养同一说戒。白如是。大德僧听。如所说界相。今僧于此处彼处。结同一说戒同一利养。谁诸长老忍。僧于此处彼处。结同一说戒同一利养。结界者默然谁不忍者说。僧已忍。于此处彼处同一说戒同一利养结界竟。僧忍默然故。是事如是持。尔时有二住处。别说戒别利养。时诸比丘。意欲同一处说戒别利养。佛言。自今已去。听解界已然后结。白二羯磨。彼此各自解应尽集一处。不得受欲。当唱界方相。若阿兰若空处。乃至村界如上。称二住处名。众中当差堪能羯磨者。如上作如是白。大德僧听。如所说界方相。若僧时到僧忍听。于此处结同一说戒别利养。白如是。大德僧听。如所说界方相。僧今于此处结同一说戒别利养。谁诸长老忍。僧于此界四方相内。结同一说戒别利养者默然。谁不忍者说。僧已忍。于此界四方相内。结同一说戒别利养竟。僧忍默然故。是事如是持。时有二住处。别说戒别利养。时诸比丘。欲得别说戒同一利养。欲守护住处故。佛言。听白二羯磨结众中当差堪能羯磨者。如上作如是白。大德僧听。若僧时到僧忍听。于此彼住处。结别说戒同一利养。为欲守护住处故。白如是。大德僧听。今僧于此彼住处。结别说戒同一利养。为守护住处故。谁诸长老忍。僧于此彼住处。结别说戒同一利养。为守护住处故。僧忍者默然。谁不忍者说。僧已忍。于此彼住处。结别说戒同一利养。为守护住处故竟。僧忍默然故。是事如是持。时有二住处。同一说戒同一利养。时诸比丘。欲得别说戒别利养。佛言。自今已去。听集在一处解界已随彼所住处各自更结界。尔时有二住处相去远。同一说戒同一利养。若彼得少饮食供养具。持来至此。日时已过。若此得利养持至彼。日时已过。时诸比丘往白佛。佛言。不得相去远处同一说戒同一利养。佛言。自今已去。听作如是语。若此处得少食饮供养。即于此处分。若彼得少供养。即于彼处分。尔时布萨日。有众多比丘。于无村旷野中行。心自念言。世尊制法。当集一处和合说戒。我等当云何。以此事往白佛。佛言。比丘善听。若布萨日。于无村旷野中行。众僧应和合集在一处共说戒。若僧不得和合。随同和尚同阿阇梨善友知识。当下道集一处结小界说戒。白二羯磨当作如是结界。众中当差堪能羯磨者。如上当如是白。大德僧听。今有尔许比丘集。若僧时到僧忍听结小界。白如是。大德僧听。今有尔许比丘集结小界。谁诸长老忍。今有尔许比丘集结小界者默然。谁不忍者说僧已忍。尔许比丘。集结小界竟。僧忍默然故。是事如是持。时时比丘。结界不解而去。余者嫌责往白佛。佛言。不应不解而去。作白二羯磨解。众中当差堪能者。如上作如是白。大德僧听。今有尔许比丘集。若僧时到僧忍听。解此处小界。白如是。大德僧听。今有尔许比丘集解此处小界。谁诸长老忍。僧解此处小界者默然。谁不忍者说僧已忍解此处小界竟。僧忍默然故。是事如是持。时天暴雨。河水大涨。时诸比丘。隔河水结同一住处同一说戒。十五日欲往就彼说戒。而不能得渡。即不成就说戒。诸比丘。以此事往白佛。佛言。不得合河水结同一说戒界。除有船桥梁。时有二住处。相去远结同一说戒。时诸比丘。十五日欲往相就说戒不能。即日达彼不成就说戒。诸比丘往白佛。佛言。不得住处相去远结同一说戒。若住处隔河水相去远。结同一住处同一说戒者。诸比丘十五日说戒。应十四日先往。十四日说戒。十三日应先往。不得受欲。尔时说戒日。住处有一比丘。入房闭户而眠。诸比丘说戒已。从座起而去。时眠者闻声即起。问诸比丘言。诸大德。欲何处去。不说戒耶。诸比丘报言。我等已说戒。即问。汝向者何处来耶。报言。我白日在自房闭户眠耳。诸比丘往白佛。佛言。不得于说戒日在房中眠。自今已去。比坐者当共相检校知有来者不来者。自今已去。听先白然后说戒。作如是白。大德僧听。今十五日众僧说戒。若僧时到僧忍听和合说戒。白如是。作如是白已。然后说戒

四分律卷第三十五四分律卷第三十六(二分之十五)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    说戒揵度下

尔时说戒日。有一比丘住处。心自念言。佛制戒应和合集一处说戒。我今当云何。即语诸比丘。诸比丘往白佛。佛言。汝等善听若说戒日。有一比丘住者。彼比丘。应诣说戒堂扫洒令净。敷座具具澡水瓶洗足瓶。然灯火具舍罗。若有客比丘来。若四若过四。应先白已然后说戒。若有三人各各相向说。今僧十五日说戒。我某甲清净。如是三说。若有二人。亦相向说。今僧十五日说戒。我某甲清净。如是三说。若有一人。应心念口言。今日众僧十五日说戒。我某甲清净。如是三说。若三人不得受第四人欲清净白说戒。二人不得受第三人欲清净。应各各三语说。若一人不得受第二人欲清净。应心念三说。时六群比丘。非法别众羯磨说戒。非法和合众法别众羯磨说戒。尔时诸比丘往白世尊。世尊言。不得非法别众羯磨说戒。非法和合众。不得法别众羯磨说戒。说戒有四种。时诸比丘。非法别众。非法和合众。法别众。法和合众。羯磨说戒。若彼比丘。非法别众羯磨说戒者。彼不成说戒。若非法和合众法别众羯磨说戒者。不成说戒。法和合众羯磨说戒者。此名为说戒。应如是说戒。是我所教法。时说戒日。众僧集有僧事。世尊告。诸比丘寂静今僧有事。有异比丘白佛言。大德。有病比丘不来。佛言。自今已去听与欲。受欲人当往受欲来。彼应如是与欲。若言与汝欲成与欲。若言我说欲成与欲。若言为我说欲成与欲。若现身相与欲成与欲。若言广说与欲成与欲。若不现身相。不口说欲者。不成与欲。当更与欲。若受欲比丘。往病比丘所受欲。受欲已便命过。若余处行。若罢道。若入外道众。若入别部众。若至戒场上。若明相出。若自言犯边罪。若犯比丘尼。若贼心作沙门。若破二道。若黄门。若杀父母。若杀阿罗汉。若斗乱众僧。若恶心出佛身血。若非人。若畜生。若二形。若被举。若灭摈。若应灭摈。若神足在空。若离见闻处。不成与欲。应更与余者欲。若至中道。若至僧中。亦如是。若受欲人。若睡若入定或忘。若不故作如是。名为成与欲。若故不说者突吉罗。若能如是者善。若不能如是者。彼比丘。应扶将病比丘。若床若绳床。上舁来至僧中。若虑此病比丘。或能动病或能死。一切众僧。应往病比丘所。围绕与作羯磨。若病者众多。能集一处者善。若不能者。诸比丘当出界外作羯磨。更无方便得别众作羯磨。尔时说戒日。众僧集一处欲说戒。时世尊告诸比丘。汝等寂静今欲说戒。时有异比丘白世尊言。今有病比丘不来。佛言。自今已去听与清净。听比丘往受清净。彼应如是与。若说清净成与清净。若乃至广说与清净。如上与欲法。成与清净。若不动身不口言清净。不成与清净。亦如上与欲法。当更与清净。若受清净人。到病比丘所。受清净已便命终。若余道行。若休道。若入外道众。若入别部众。或至戒场上。若明相出。若自言犯边罪。若犯比丘尼。若贼心作沙门。若破二道。若黄门。若杀母杀父。若杀阿罗汉。若斗乱众僧。若恶心出佛身血。若非人。若畜生。若二形。若被举。若灭摈。若应灭摈。若神足在空。若离见闻处。不成与清净。当更与余者。如是若至中道。若至众中。亦如是。受清净人。若眠若入定若忘。若不故作如是。成与清净。若故不说者突吉罗。若能如是者善。不能如是者。当扶病人。若床若绳床若舆上。舁来至僧中。时诸比丘作是念。若舁病比丘来。恐病增动。或不至便命终者。我等当往就与作羯磨说戒。若有众多病者集一处善。若不得集。诸比丘应出界外作羯磨说戒。若不出界外。不得别众作羯磨说戒。更无有方便得别众作羯磨说戒。尔时六群比丘。与欲不与清净。僧中有事起。不得说戒。时持欲来。比丘言。我持欲来。不得清净。而稽留羯磨说戒。诸比丘皆疲惓。时诸比丘往白佛。佛言。自今已去与欲时应与清净。应如是言。我与汝欲清净。时六群比丘称事言。我以此事与汝欲及清净。僧中有余事起。时持欲比丘言。我持某事欲清净来。不持余事欲清净来。以此事故有稽留。诸比丘皆疲惓。诸比丘往白佛。佛言。不应称事与欲清净。听如法僧事与欲清净。时受欲清净比丘。或命终。或休道。或入外道众。或入别部众。或至戒场上。若明相出。诸比丘念言。为失与欲清净不。佛言失。时受欲清净比丘。遇道路隔塞。有贼难。有恶兽难。若河水大涨不得至。便从界外来至僧中。与欲清净。诸比丘念言。为失与欲清净不。佛言不失。自今已去。听与欲清净比丘。若命难梵行难。若界内不得至僧中。听从界外来至僧中与欲清净。如是不失与欲清净。是我所说。时诸比丘。受一人与欲清净已疑。不受二人欲清净。佛言听受。彼受二人欲清净已复疑。不受三人欲清净。佛言听受。彼受三人欲清净疑。不受四人欲清净。佛言听受。佛言。若能尽记识字者。随能忆多少受。若不能忆字者。当称姓。不能记识姓者。当称相貌。若不能记相貌。但言众多比丘如法僧事与欲清净。时说戒日。一处有大众来集说戒者。声音小大众不悉闻。诸比丘往白佛。佛言。自今已去听当在众中立说戒。犹故不闻。应在众中敷高座极令高好座上说戒。犹故不闻。应作转轮高座平立手及在上座说戒。诵时若忘误。次座比丘当授语。若故忘者。次第二比丘当代说。即以次说不得重说。尔时持欲清净比丘。有事起。或有僧事佛事法事病比丘事。时诸比丘。以此事往白佛。佛言。自今已去。听转授欲清净。与余比丘。当作如是言。我与众多比丘受欲清净。彼及我身如法僧事与欲清净。时六群比丘。汝和尚阿阇梨及字。时诸比丘。以此事往白佛。佛言。不得汝和尚阿阇梨称字。时诸比丘相问。汝和尚阿阇梨字何等。疑不敢称字。诸比丘以此事往白佛。佛言。若有问者。听称和尚阿阇梨字。若比丘。行波利婆沙本日治若摩那埵阿浮呵那时。若羯磨若立制时。若受戒时。若差人时。若解时。应称和尚阿阇梨字。时比丘。有事因缘应称字。疑不敢称和尚阿阇梨名字。时诸比丘往白佛。佛言。若有事因缘。听称和尚阿阇梨字。若比丘。为事故与欲清净。与欲已事休。便生疑不敢就说戒处。诸比丘以此事往白佛。佛言。若事休应往。若不往当如法治。时六群比丘作如是念。不往说戒处。恐余比丘为我作羯磨遮我说戒。诸比丘往白佛。佛言。不应尔。彼复作如是念。我不往说戒处。恐为我亲厚知识作羯磨若遮说戒。佛言。不应尔。彼复作如是念。我往说戒处不坐。恐余比丘为我作羯磨若遮说戒。佛言不应尔。若为亲厚知识往说戒处不坐亦如是。尔时有住处。说戒日众僧大集欲说戒。时闻有贼来皆恐怖。从座起去不成说戒。诸比丘往白佛。佛言。自今已去听。八难事起若有余缘听略说戒。八难者。若王若贼若火若水若病若人若非人若恶虫。余事缘者。若有大众集床座少若众多病。听略说戒。若有大众集座上覆盖不周或天雨。听略说戒。若布萨多夜已久。或斗诤事。或论阿毗昙毗尼或说法夜已久。自今已去。听一切众未起明相未出应作羯磨说戒。更无方便可得宿受欲清净羯磨说戒。彼比丘作是念。今以此难因缘听略说戒。难来犹远未至。我等可得广说戒。时彼比丘。应广说戒。不广说者如法治。时彼比丘作是念。此难事近。我曹不得广说戒。可说至九十事。彼比丘应说至九十事。若不说者当如法治。时诸比丘作是念。此难事近。我等不得广说至九十事。可说至三十事。应广说至三十事。不说者当如法治。时诸比丘作是念。此难事近。我等不得广说至三十事。可说至二不定法。比丘应说至二不定法。若不说者当如法治。时诸比丘作是念。难事近。我等不得广说至二不定法。可说十三事。彼应说至十三事。若不说者当如法治。彼诸比丘作是念。此难事近。不得广说至十三事。可说四事。彼比丘应说四事。若不说者如法治。彼比丘作是念。此难事近。我等不得说四事。可说戒序。彼应说戒序。若不说者如法治。时诸比丘作是念。此难事近。我等不得说戒序。诸比丘。以此难事因缘。应即从座起去。有五种说戒。说序已。余者应言僧常闻。若说序四事已。余者应言僧常闻。若说序四事十三事已。余者应言僧常闻。若说序四事十三事二事已。余者应言僧常闻。广说第五。是谓说戒五种。复有五事。说序四事。余者应言僧常闻。说序四事十三事已。余者。应言僧常闻。说序四事十三事二事已。余者应言僧常闻。说序四事十三事二事三十事已。余者应言僧常闻。广说第五。复有五事。说序四事十三事已。余者应言僧常闻。说序四事十三事二事已。余者应言僧常闻。说序四事十三事二事三十事已。余者应言僧常闻。说序四事十三事二事三十事九十事已。余者应言僧常闻。广说第五。是谓说戒五种

尔时世尊在罗阅城耆阇崛山中。时有一比丘。名那那由。心乱狂痴。或时忆说戒。或不忆说戒。或时来。或不来。时诸比丘。以此事往白佛。佛言。自今已去。与那那由比丘。作心乱狂痴白二羯磨。作如是与。众中应差堪能羯磨者。如上当作如是白。大德僧听。此那那由比丘。心乱狂痴。或忆说戒或不忆说戒。或来或不来。若僧时到僧忍听。与此比丘作心乱狂痴羯磨。若忆若不忆。若来若不来。僧作羯磨说戒白如是。大德僧听。此那那由比丘心乱狂痴。或忆说戒或不忆。或来或不来。今僧与那那由比丘作心乱狂痴羯磨。若忆若不忆。或来或不来。作羯磨说戒。谁诸长老忍。与此那那由比丘作狂痴心乱。忆不忆或来或不来作羯磨说戒者默然。谁不忍者说。僧已忍。与那那由比丘作狂痴心乱。忆不忆来不来作羯磨竟。僧忍默然故。是事如是持。有三种狂痴。一者说戒时忆不忆来不来。二者或有狂痴忆说戒而来。三者或有狂痴不忆说戒不来。是谓三种狂痴。是中有忆说戒不忆说戒。有来不来。如是比丘者。众僧应与作痴狂羯磨。彼忆说戒而来者。众僧不应与作痴狂羯磨。彼狂痴不忆说戒亦不来者。不应与作痴狂羯磨。彼比丘与作羯磨已。后狂痴病止作是念言。我今当云何。即告诸比丘。诸比丘往白佛。佛言。若狂者。与作羯磨已。后狂痴病止。应与作白二羯磨解。应作如是解。那那由比丘。应往众僧中偏露右臂脱革屣右膝着地合掌白。大德僧听。我那那由比丘。先得狂痴病。说戒时。或忆或不忆。或来或不来。众僧与我作狂痴病羯磨。作已还得止。今求解狂痴羯磨。如是三说。众中当差堪能作羯磨者。如上作如是白。大德僧听。此那那由比丘。先得狂痴病。彼说戒时。或忆或不忆。或来或不来。众僧与作狂痴羯磨。与作已狂痴病还得止。今求解狂痴病羯磨。若僧时到僧忍听。僧与解狂痴病羯磨。白如是。大德僧听。此那那由比丘。先得狂痴病。说戒时。或忆或不忆。或来或不来。众僧与作狂痴病羯磨。与作已狂痴病还得止。今求众僧解狂痴病羯磨。谁诸长老忍。听与那那由比丘解狂痴病羯磨者默然。谁不忍者说。僧已忍。与那那由比丘解狂痴病羯磨竟。僧忍默然故。是事如是持。时诸比丘各心念言。与狂痴病者作羯磨已。后还得止得解狂痴羯磨。若复更狂痴。后得与作羯磨不。佛言。自今已去。随狂痴病时。与作羯磨。狂止还解。尔时世尊。在瞻婆国伽伽河侧。十五日说戒时。世尊露地坐。众僧前后围绕。时阿难。初夜过中夜初。从座起偏露右肩脱革屣右膝着地合掌白佛言。初夜已过。愿世尊说戒。世尊默然。阿难见世尊默然还就座。阿难。初夜中夜过已。从座起偏露右肩脱革屣右膝着地合掌白佛言。初夜中夜已过。愿世尊说戒。世尊默然。阿难见世尊默然还就座。阿难。初夜过中夜过后夜已过明相出众鸟鸣。阿难。从坐起偏露右肩脱革屣右膝着地合掌白佛言。初中后夜已过。明相已出众鸟鸣。众僧坐久。愿世尊说戒。佛告阿难。众中有不净者。若众中有不净者。欲令如来于中说戒者。无此理也。时阿难默然还坐。时尊者大目连作是念。今众中何者不净。如来乃说言。众中有不净者。而于中说戒。无此理耶。时目连。即观众人心。见有不净人。去如来不远坐。既非沙门而称沙门。非梵行而言梵行。犯戒恶法不净污秽。邪见覆藏恶业内怀腐烂犹如空树。见已念言。佛正为此人故。语阿难言。众中有不净。如来于中说戒者。终无此理。时目连。即往其人所语言。汝起。如来已见汝已知汝。速起去。不须住此。时目连。捉手牵出门外已。还至世尊所头面礼足白佛言。众僧已清净。愿世尊说戒。佛语目连。汝今不应为。后亦不应为。目连。自今已去。听作自言治。若不自言不应治。自今已去。汝等自作羯磨说戒

佛告目连。此如来最后说戒。何以故。有犯者。不得与说戒。有犯者。不得闻说戒。不得向犯戒者解罪。有罪者。不得受他解罪。佛告目连。海水有八奇特法。所以阿修罗娱乐住者。以此八事故。何等为八。诸一切众流皆往投之。是谓一奇特。阿修罗所娱乐。复次目连。海水常住不失潮法。是谓目连海水二奇特。阿修罗所娱乐。复次目连。今五大河。恒河阎摩那萨罗阿夷罗婆提摩河。皆投于海。而失本名。名之为海。是谓目连海水三奇特。阿修罗所娱乐。复次目连。此五大河及天雨。尽归于海。而海水无有增减。是谓目连海水四奇特。阿修罗所娱乐。复次目连。海水尽碱同为一味。是谓目连海水五奇特。阿修罗所娱乐。复次目连。海水不受死尸。设有死尸。风飘出置岸上。是谓目连海水六奇特。阿修罗所娱乐。复次目连。海水多出珍奇异宝。陆地所无有尽出于海。所谓宝者。金银真珠琉璃珊瑚车磲马瑙。是谓目连海水七奇特。阿修罗所娱乐。复次目连。大海水大形者所居处。所谓大形者。身有长百由旬二百由旬三百由旬乃至七百由旬。是谓目连海水八奇特。阿修罗所娱乐。是谓目连大海水有八奇特。阿修罗所娱乐。如是目连。我法中亦有八奇特。使诸弟子见已于中而自娱乐。何等为八。如彼大海水一切众流皆往投之。如是目连。我诸弟子渐次学戒。皆归我法。于中学诸善法。是谓目连我法中一奇特。令诸弟子见已而自娱乐。目连。犹如大海常住不失潮法。我诸弟子住于戒中。乃至于死终不犯戒。是谓于我法中二奇特。令诸弟子见已而自娱乐。目连。犹如五大河尽归于海。失于本名名之为海。如是目连。于我法中。四种姓刹利婆罗门毗舍首陀。以信坚固从家舍家学道。灭本名皆称为沙门释子。是谓目连。于我法中三奇特。令诸弟子见已而自娱乐。目连。犹如五大河及天雨皆归于海。而海水无有增减。如是目连。于我法中诸族姓子。以信坚固从家舍家学道。入无余涅槃界。而无余涅槃界无增无减。是谓目连于我法中四奇特。令诸弟子见已而自娱乐。犹如目连。大海水碱同一味于我法中同一解脱味。是谓目连于我法中五奇特。令诸弟子见已而自娱乐。目连犹如大海不受死尸设有死尸大风飘置岸上。于我法中亦复如是。不受死尸。所谓死尸者。非沙门自称为沙门。非梵行自称为梵行。犯戒恶法不净污秽邪见覆障善业。内怀腐烂如空中树。虽在众中坐。常离众僧远众僧。亦离彼远。是谓目连于我法中六奇特。令诸弟子见已而自娱乐。犹如目连大海水中多出珍奇异宝陆地所无有。所谓珍宝者。金银真珠琉璃珊瑚车磲马瑙。于我法中亦多出珍宝。所谓珍宝者。四念处四正勤四如意足四禅五根五力七觉意贤圣八正道。是谓目连于我法中七奇特。令诸弟子见已而自娱乐。犹如目连大海水大形所居处。所谓大形者。百由旬乃至七百由旬。如是目连。于我法中亦受大形所谓大形者。众僧中向须陀洹得须陀洹果乃至向阿罗汉得阿罗汉果是谓目连于我法中八奇特。令诸弟子见已而自娱乐。尔时说戒日。众多痴比丘。集一处住语上座言说戒。答言。我先不诵戒。次语中座下座说戒。皆言不诵即不成说戒。尔时诸比丘。以此事往白佛。佛言。众多痴比丘。不应共集一处。既不知戒。复不知说戒。不知布萨。不知布萨羯磨。自今已去。制五岁比丘诵戒羯磨。若不诵戒羯磨者如法治。尔时有众多痴比丘。共集一处住。语上座言说戒。报言。我等先诵。今者悉忘。次问中座下座。皆言先诵。今者悉忘。即不成说戒。时诸比丘以此事往白佛。佛言。众多痴比丘。不应集在一处。既不知戒。复不知说戒。不知布萨。不知布萨羯磨。自今已去。制五岁比丘。当诵戒诵羯磨使利。若不者如法治。自今已去。听依能诵戒比丘夏安居。尔时有比丘。依诵戒者夏安居。诵戒者安居中命终。诸比丘念言我等当云何。即白诸比丘。诸比丘往白佛。佛言。汝等善听。若有比丘。依诵戒比丘夏安居。安居中诵戒者命终。若远行若休道。若至外道众。若至别部众中。若犯边罪。若犯比丘尼。若贼心作沙门。若坏二道。若黄门或杀父母。或杀阿罗汉。或斗乱众僧。或恶心出佛身血。若非人。若畜生。若二形。若后安居未至。当诣比近处结后安居。若不者当请比近能诵戒者来过安居若已结后安居诸比丘。应诣比近处。有学诵序者若诵四事者。若十三事者。若二不定者。若三十事者。若九十事者。若诵余残法者。彼各诵所得已。还至本住处教一人使诵。若一人不能尽诵者。随先所诵得。各次第诵不得重诵。若尔者善。不者但说法诵经已。从坐起而去。尔时难陀。有弟子聪明。善能营事。时跋难陀语言。汝与我人间游行。其人报言。小留待我。往问和尚还。即往难陀所白言。听我与跋难陀人间游行。难陀报言。随汝意。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责难陀。汝云何听弟子随跋难陀人间游行耶。此人痴。不知戒不知说戒。不知布萨不知布萨羯磨。尔时诸比丘。往诣佛所头面礼足在一面坐。以此事具白佛。佛尔时以此事集比丘僧。知而故问难陀言。汝实遣弟子与跋难陀人间游行耶。跋难陀痴人。不知戒不知说戒。不知布萨不知布萨羯磨。答言如是。时世尊以无数方便呵责难陀言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何难陀。汝遣弟子。与跋难陀人间游行。痴人。既不知戒不知说戒。不知布萨。不知布萨羯磨。尔时世尊。以无数方便呵责难陀已告诸比丘。汝等善听。若有弟子。辞和尚师方面远行。和尚当问弟子。汝为何事行。同伴是谁。为诣何处。若所营事非若同伴非其人及所诣处非者。当遮令莫去。若所营事非。所诣处亦非。同伴虽好。亦当遮令莫去。若所营事非。所诣处好。同伴不善亦当遮令莫去。若所营事非。所诣处好。同伴善。亦当遮令莫去。若所营事好。所诣处不好。同伴亦不善。当遮令莫去。所营事好。所诣处好。同伴不好。亦遮令莫去。若所营事好。所诣处好。同伴亦好。当听令去。尔时有一住处。众多痴比丘共集一处。时尊者优波离。为客来至此众中。而诸痴比丘。都不瞻视迎逆承事。优波离以不瞻视迎逆承事。即于其日离彼处去。时诸比丘。以此事往白佛。佛言。善听。若有住处。有众多痴比丘共集一处。若有客比丘来至。能说法持律持摩夷能说契经义。诸比丘闻。当往至半由旬。迎逆承事瞻视安处浴洗给其所须饮食。若不尔者当如法治。尔时有住处。一比丘当说戒日犯罪。心自念言。世尊制戒。犯者不得说戒。不得闻戒。不得向犯戒者忏悔。犯者不得受他忏悔。我今当云何。即告诸比丘。诸比丘往白佛。佛言。汝等善听。若说戒日。有比丘犯罪自念言。世尊制戒。若有犯者。不得说戒。不得闻戒。不得向犯者忏悔。犯者不得受他忏悔。彼比丘当诣清净比丘所。偏露右臂脱革屣右膝着地合掌。若上座应礼足自称所犯名字。口作是说。大德忆念。我某甲比丘。犯某甲罪。今向大德忏悔。不敢覆藏。忏悔则安乐。不忏悔不安乐。忆念犯发露。知而不覆藏。愿长老忆我清净戒身具足清净布萨。如是三说彼应语言。汝当生厌离心。彼当报言尔。作如是已。得听说戒。尔时说戒日。有一比丘。于犯中生疑。彼自念言世尊制戒。有犯者。不得说戒。不得闻戒。不得从犯者忏悔。犯者不得受他忏悔。我今当云何。即告诸比丘。诸比丘往白佛。佛言。汝等善听说戒日。若比丘于犯有疑者。自念言。世尊制戒。若有犯者。不得说戒。不得闻戒。不得向犯者忏悔。犯者不得受他忏彼比丘当诣清净比丘中。偏露右臂脱革屣右膝着地合掌。若上座礼足已称所犯名字。口作是言。我某甲于所犯罪生疑。今向大德自说。须后无疑时当如法忏悔。如是已得闻戒。尔时说戒日。众僧集在一处欲说戒。当欲说戒时。有比丘犯罪彼即作是念。世尊制戒犯者不得说戒。不得闻戒。不得向犯者忏悔。犯者不得受他忏。我今当云何。语彼说戒人言。小止莫说戒。我犯某甲罪。我欲从长老忏悔。作是语顷。举众闹乱。时诸比丘。以此事往白佛。佛言。汝等善听。若有异处。众僧集在一处欲说戒。当说戒时。有比丘犯罪彼比丘。若有人举若不举。若作忆念不作忆念。其人自忆罪而发露自知有是罪。彼比丘当语边人言。我犯某甲罪。今向长老忏悔。复作是念。设语傍人者。恐闹乱众僧。不成说戒彼比丘当心念。须罢坐已。当如法忏。作如是已。得听说戒。尔时众僧集在一处欲说戒。当说戒时。有比丘于罪有疑。彼作是念言。世尊制戒。有犯者。不得说戒。不得闻戒。不得向犯者忏悔。犯者不得受他忏悔。我今当云何。即语彼说戒人言汝小止。我疑某甲罪欲向长老说。作是语已。举众闹乱。时诸比丘。以此事往白佛。佛言。汝等善听。若众僧集在一处欲说戒。当说戒时。有比丘于罪有疑。而彼比丘。有举有不举。有作忆念不作忆念。彼自忆过。当语比座言。我于罪有疑。今向长老说。须罢座已无疑时。当如法忏悔。若复作是念。我向比座语。恐众僧闹乱。不成说戒。彼应心念。须座罢已无疑时如法忏悔。作如是者。得闻说戒。尔时当说戒日。有异住处。一切僧尽有犯。皆自念言。世尊制戒。有犯者。不得说戒。不得闻戒。不得从犯者忏悔。犯者不得受他忏。我等当云何。即告诸比丘。诸比丘往白佛。佛言。汝等善听。若有异住处一切僧尽犯。皆自念言。世尊制戒。有犯者。不得说戒。不得闻戒。不得从犯者忏悔。犯者不得受他忏。若有客比丘来。清净无犯当往彼所。偏露右肩脱革屣右膝着地合掌。若上座礼足已。口自称所犯戒名。作是言。我某甲犯某甲罪。今向大德说。彼当语言。生厌离心。此报言尔。若无客比丘来者。即当差二三人诣比近清净比丘众中。偏露右肩脱革屣右膝着地合掌。自称所犯戒名。口作是言。我犯某甲罪。今向诸大德说。彼当语言。汝生厌离心。报言尔。此比丘当还来至所住处。所住处诸比丘当向此比丘说犯作如是已当说戒。尔时有一异住处。一切僧于罪有疑。各作是念世尊制戒。有犯者。不得说戒。不得闻戒。不得从犯者忏悔。犯者不得受他忏。我等当云何。即告诸比丘。诸比丘往白佛。佛言。汝等善听若异住处一切僧于罪有疑。各作是念。世尊制戒有犯者。不得说戒。不得闻戒。不得从犯者忏悔。犯者不得受他忏。若有客比丘来。清净无犯当往诣彼所。偏露右肩脱革屣。若上座礼足已。右膝着地合掌自称所犯戒名口作是语。我于某罪生疑。今向大德说。须后无疑时。当如法忏悔。若无有客比丘者。当遣二三比丘诣比近清净比丘众中。偏露右肩脱革屣右膝着地合掌若上座礼足已。自称所犯戒名。口作是语。我于某罪生疑。今向大德说。须后无疑时。当如法忏悔。彼比丘当还本住处。诸比丘当向此比丘说犯戒名。作如是已。然后说戒。尔时众僧集在一处欲说戒。当说戒时。一切众僧尽犯罪。各作是念。世尊制戒。有犯者。不得说戒。不得闻戒。不得向犯比丘忏悔。犯者不得受他忏悔。我等当云何。即告诸比丘。诸比丘往白佛。佛言。汝等善听。众僧集在一处欲说戒。当说戒时。一切众僧尽犯罪。彼各各作是念。世尊制戒。犯者不得说戒。不得闻戒。不得向犯者忏悔。犯者不得受他忏。彼比丘白已当忏悔。当作如是白。大德僧听。此一切众僧犯罪。若僧时到僧忍听。此一切僧忏悔。白如是。作是白已。然后说戒。尔时众僧集在一处欲说戒。当说戒时。一切众僧于罪有疑。彼各作是念。世尊制戒。有犯者。不得说戒。不得闻戒。不得向犯者忏悔。犯者不得受他忏悔。我等当云何。即语诸比丘。诸比丘往白佛。佛言。汝等善听。若众僧集在一处欲说戒。当说戒时。一切僧于罪有疑。各念言。世尊制戒。有犯者。不得说戒。不得闻戒。不得向犯者忏悔。犯者不得受他忏。彼一切僧。作白已应说其罪。当作如是白。大德僧听。此一切僧。于罪有疑。若僧时到僧忍听。此众僧自说罪。白如是。作如是白已。然后得说戒。尔时说戒日。一切僧尽犯罪。然不识所犯罪名不识罪相。诸比丘作是念。我等当云何。即告诸比丘。诸比丘往白佛。佛言。汝等善听。说戒日一切僧尽犯罪。而不识罪名不识罪相。若有客比丘来。持法持律持摩夷者。当往彼所。偏露右肩脱革屣右膝着地合掌。白言。大德若有比丘。作如是如是罪者犯何等。彼持律报言。犯如是如是罪。客比丘知彼比丘易教授者。将在屏处。令余比丘眼见耳不闻处立。教令如法忏悔。忏悔已还至彼比丘所作是言。此比丘所犯罪者。今已忏悔。余比丘信如是比丘忏悔者善。若不信忏悔者。余比丘。不得强逼令忏悔。尔时说戒。日有客比丘至彼客比丘十四日说戒。旧比丘十五日说戒。诸比丘不知云何。即告诸比丘。诸比丘往白佛。佛言。汝等善听。若有住处。说戒日有客比丘来少。客比丘十四日。旧比丘十五日。客比丘少当从旧比丘。若不者如法治。尔时有住处。说戒日有客比丘来。与旧比丘等。客比丘十四日说戒。旧比丘十五日。客比丘等应从旧比丘。若不从当如法治。若说戒日有客比丘来多客比丘十四日说戒。旧比丘十五日旧比丘少应从客比丘求和合。若彼与和合者善。若不与和合旧比丘。应出界外说戒时说戒日。有异住处。客比丘来少。客比丘十五日旧比丘十四日。客比丘少应从旧比丘求和合。若与和合者善。若不与和合。客比丘应出界外说戒。时说戒日。有异住处。客比丘来与旧比丘等。客比丘十五日。旧比丘十四日。应从旧比丘求和合。若与和合者善。若不与和合。客比丘应出界外说戒。时说戒日。有异住处。客比丘来多。客比丘十五日。旧比丘十四日。旧比丘少。应从客比丘求和合。若从者善。若不从如法治。当说戒日。客比丘来少。客比丘十六日。旧比丘十五日。亦如是。时说戒日有住处。旧比丘。集欲说戒说戒时客比丘来少。彼作如是念我等当云何。即告诸比丘。诸比丘往白佛。佛言。若说戒日。有住处旧比丘集欲说戒说戒时客比丘来少。旧比丘若已说戒序竟。客比丘当告清净余者当次第听若说戒竟。举众未起。若多未起。若都已起。客比丘来少。当告清净。不告者如法治。尔时说戒日。旧比丘欲说戒。客比丘来等。旧比丘当更与说戒。不说者如法治。若说戒竟。若举众未起。若多未起。若都已起。客比丘来等。旧比丘当更与说戒。不者应如法治。尔时说戒日。有一住处。旧比丘集欲说戒。时有客比丘来多。旧比丘应更与说戒不者如法治。若说戒竟。举众未起。若多未起。若都已起。客比丘来多。旧比丘应更与说戒。不者如法治。尔时有住处。说戒日客比丘坐欲说戒。旧比丘来少。客比丘若已说戒序竟。当告清净。余者当次第听。若说戒竟。举众未起。若多未起。若都已起。旧比丘来少。当告清净。不者如法治。尔时有住处。说戒日客比丘坐欲说戒。旧比丘来等。客比丘应更与说戒。不者如法治。若说戒竟。举众未起。若多未起。若都已起。旧比丘来等。客比丘应更与说戒。不者如法治。尔时有住处。说戒日客比丘坐欲说戒。旧比丘来多。客比丘应更与说戒不者如法治。若说戒竟。举众未起。若多未起。若都已起。旧比丘来多。客比丘应更与说戒。不者如法治。旧比丘说戒。旧比丘来亦如是。客比丘说戒。客比丘来亦如是。尔时有异住处。说戒日有客比丘来。知旧比丘未来。我等若有四人若过四人。可作羯磨共说戒。即便作羯磨共说戒。作羯磨说戒时旧比丘来。客比丘作是念。我等当云何即告诸比丘。诸比丘往白佛。佛言。汝等善听。若说戒日。有住处。有客比丘来。知有旧比丘未来。我等若有四人若过四人。可作羯磨共说戒。彼人即共作羯磨说戒。作羯磨说戒时。旧比丘来少。若已说戒序。当语清净。余者当次第听若说戒竟。举众未起。若多未起。若都已起。旧比丘来少。当告清净。不者如法治。时有住处。说戒日有客比丘来至。知有旧比丘未来。我等有四人若过四人。可作羯磨说戒。即作羯磨说戒。作羯磨说戒时。旧比丘来等。客比丘应更说戒。若不者如法治。若说戒竟。举众未起。若多未起。若都已起。旧比丘来等。客比丘应更说戒。不者当如法治。尔时有住处。说戒日有客比丘来。知有旧比丘未来。我等有四人若过四人。可作羯磨说戒。即作羯磨说戒作羯磨说戒时。旧比丘来多。客比丘应更说戒。若不者如法治。若说戒竟。举众未起。若多未起。若都已起旧比丘来多。客比丘应更说戒。不者如法治。尔时有住处说戒日旧比丘来。知客比丘未来。若少若等若多亦如是。客比丘说戒客比丘来亦如是。旧比丘说戒。旧比丘来亦如是。或言应说戒。或言不应说戒。若不来者失去灭去。欲作种种方便破坏他便作羯磨说戒彼作羯磨羯磨不成。得偷兰遮。尔时说戒日。有客比丘来。见旧比丘住处房舍。旧比丘相敷绳床木床座具毡褥枕具洗足石净水净水瓶。见相已不求。便作羯磨说戒。作羯磨说戒时。旧比丘来。客比丘作是念。我等当云何。即告诸比丘。诸比丘往白佛。佛言。汝等善听。若一住处说戒日。有客比丘来。见旧比丘相敷绳床木床敷具毡褥枕具洗足石净水净水瓶。见有相不求。便作羯磨说戒。若作不成羯磨说戒有罪。见相便求求而不得即应唤。若不唤便作羯磨说戒。不成羯磨说戒有罪。见相便求。求而不得。求既不得。便言灭去失去。作种种方便。欲使他破坏。便作羯磨说戒。彼比丘不成羯磨。犯偷兰遮。见相便求。求而不得。不得便唤。唤已作羯磨说戒。彼比丘羯磨不成不犯。见相便求。求而得之。和合作羯磨说戒。成羯磨说戒无犯。见疑亦如是。尔时有住处。旧比丘来。见客比丘相。见衣钵针筒尼师坛洗脚处。见已不求。便作羯磨说戒。彼比丘不成羯磨说戒有罪。若见相便求。求而不得即应唤。若不唤便作羯磨说戒。不成羯磨说戒有罪。见相便求。求而不得。便言失去灭去。种种方便欲使他破坏。便作羯磨说戒。彼比丘不成羯磨。犯偷兰遮见相便求。求而不得。不得便唤。唤已作羯磨说戒。彼比丘不成羯磨说戒不犯。见相便求。求而得和合作羯磨说戒。彼比丘成羯磨说戒无罪。见疑亦如是。尔时说戒日。有一异住处。客比丘来。闻旧比丘声经行声謦欬声。闻诵经声。闻说法声闻已不求。便作羯磨说戒。作羯磨说戒时。旧比丘来。彼不知云何。即告诸比丘。诸比丘往白佛。佛言。汝等善听。若说戒日。有一住处。客比丘来。闻旧比丘声经行声謦欬声诵经声说法声。闻已不求。便作羯磨说戒。彼比丘不成羯磨说戒得罪。若闻已求。求已不得不唤。作羯磨说戒。彼比丘不成羯磨说戒得罪。若闻已求。求已不得。不得而复不唤。既不唤便言。失去灭去。种种方便欲使他破坏。便作羯磨说戒。彼比丘不成羯磨说戒。得偷兰遮。闻已求。求已不得。不得便唤。唤已作羯磨说戒。彼比丘羯磨不成无罪。闻已求。求已得。得已和合共作羯磨说戒。彼比丘成羯磨说戒无罪。若闻疑亦如是。时有一住处。说戒日旧比丘来。闻客比丘声经行声謦欬声诵经声说法声抖擞衣声。闻已不求。便作羯磨说戒。彼比丘不成羯磨说戒有罪。闻已求。求已不得。不得已不唤。作羯磨说戒。彼比丘不成羯磨说戒有罪。闻已求。求而不得。不得已不唤。不唤已便言。失去灭去。种种方便欲使他破坏。便作羯磨说戒。彼比丘不成羯磨说戒。得偷兰遮。闻已求。求已不得。不得已便唤。唤已作羯磨说戒。彼比丘不成羯磨说戒无罪闻已求。求已得。得已和合共作羯磨说戒。彼比丘成羯磨说戒无罪。闻疑亦如是。尔时有一异住处。说戒日客比丘来。见旧比丘在界场上。见而不求。便作羯磨说戒。诸比丘作是念。我等当云何。即告诸比丘。诸比丘往白佛。佛言。汝等善听。若有异住处。说戒日客比丘来。见旧比丘在界场上。见而不求。便作羯磨说戒。彼比丘成羯磨说戒有罪。若见已便求。求不得不唤。便作羯磨说戒。彼比丘成羯磨说戒有罪。见已求。求已唤。唤已作羯磨说戒。彼比丘成羯磨说戒无罪。见疑亦如是。尔时有异住处。说戒日旧比丘来。见客比丘在界场上。见而不求便作羯磨说戒。彼比丘成羯磨说戒有罪。若见已便求。求已不得。而不唤便作羯磨说戒。彼比丘成羯磨说戒有罪。见已求求已唤。唤已作羯磨说戒。彼比丘成羯磨说戒无罪。见疑亦如是。尔时有异住处。说戒日客比丘来。闻旧比丘在界场上。闻已不求。便作羯磨说戒。彼比丘成羯磨说戒有罪。闻已求。求已不唤。不唤已便作羯磨说戒。彼比丘成羯磨说戒有罪。闻已求。求已唤。唤已作羯磨说戒。彼比丘成羯磨说戒无罪。闻疑亦如是。旧比丘来。闻客比丘在界场上亦如是。闻疑亦如是。尔时有一异住处。说戒日客比丘来。见旧比丘在界内。见而不求便作羯磨说戒。作羯磨说戒时。旧比丘来。彼作是念。我等当云何。即告诸比丘。诸比丘往白佛。佛言。汝等善听。若有一异住处。说戒日客比丘来。见旧比丘在界内。见而不求。便作羯磨说戒。彼比丘不成羯磨说戒有罪。见而求。求而不唤。便作羯磨说戒。不成羯磨说戒有罪。见便求。求已唤唤已和合作羯磨说戒。彼比丘成羯磨说戒无罪。见疑亦如是。尔时有住处。说戒日有旧比丘来。见客比丘在界内亦如是。见疑亦如是。客比丘闻旧比丘在界内亦如是。闻疑亦如是。旧比丘闻客比丘在界内亦如是。闻疑亦如是。时六群比丘作如是念。从有比丘有住处。至无比丘有住处。恐余比丘为我等作羯磨若遮说戒。时诸比丘往白佛。佛言。不应作如是念。从有比丘有住处。至无比丘有住处。恐余比丘为我等作羯磨若遮说戒。彼比丘作是念。从有比丘有住处。至无比丘无住处。恐余比丘为我等作羯磨若遮说戒。佛言。不应作如是念。从有比丘有住处。至无比丘无住处。恐余比丘为我等作羯磨若遮说戒。彼比丘作是念。我从有比丘有住处。至无比丘有住处无住处。若往比丘界场上。恐余比丘为我作羯磨若。遮说戒。佛言。不应作是念。从有比丘有住处。至无比丘有住处无住处。若往比丘界场上。恐余比丘为我作羯磨若遮说戒。若无僧共去。若无难事去者。突吉罗。从有比丘无住处。至无比丘有住处。亦如是。从有比丘无住处。至无比丘无住处亦如是。从有比丘无住处。至无比丘有住处无住处亦如是。从有比丘有住处无住处。至无比丘有住处亦如是。从有比丘有住处无住处至无比丘无住处亦如是。从有比丘有住处无住处。至无比丘有住处无住处亦如是。若为亲厚知识亦如是。时六群比丘尼作如是念。往寺内遮余比丘言勿为六群比丘作羯磨遮说戒。尔时诸比丘。以此事往白佛。佛言。比丘尼不应作如是念。往寺内遮余比丘言。勿为六群比丘作羯磨遮说戒。亦不应于比丘尼前作羯磨若遮说戒。时诸比丘尼。遣式叉摩那沙弥沙弥尼。至寺内遮余比丘。勿为六群比丘作羯磨遮说戒。诸比丘往白佛。佛言。比丘尼不应作是念。遣式叉摩那沙弥沙弥尼。至寺内遮余比丘。勿为六群比丘作羯磨遮说戒。亦不应在式叉摩那沙弥沙弥尼前作羯磨遮说戒。彼诸比丘尼复作是念。遣白衣知识往寺内遮余比丘。勿为六群比丘作羯磨遮说戒。诸比丘往白佛。佛言。比丘尼不应作如是念。遣白衣知识往寺内遮余比丘。勿为六群比丘作羯磨若遮说戒。不应在白衣前作羯磨若遮说戒。尔时摩竭国瓶沙王。为佛众僧故。遣诸将守护僧伽蓝。时诸比丘语诸将言。汝等且出在外。我等欲作羯磨说戒。诸将报言。王瓶沙见遣来。为佛众僧故守护。王意难犯。我等不能出外。尔时诸比丘。以此事往白佛。佛言。当和喻语使出。若出者善。若不出者。汝等自相将出。至不见不闻处作羯磨共说戒。不应在未受大戒人前作羯磨说戒。时有天龙鬼神来听说戒。有得天眼比丘见之皆生畏慎心。念言。世尊制戒。不听我等于未受大戒人前作羯磨说戒。尔时诸比丘。以此事往白佛。佛言。自今已去。听除人未受大戒。余者听在前作羯磨说戒。尔时拘睒弥众僧破为二部。时诸比丘。欲于舍卫和合。佛言。自今已去。听白已然后和合。当作如是白。大德僧听。所由诤事。令僧斗诤彼此不和。彼人犯罪。为作举已还为解罪。僧尘垢已灭。若僧时到僧忍听僧和合。白如是。应作如是白已作和合。尔时尊者优波离。从座起偏露右肩脱革屣右膝着地合掌白佛言。世尊。所因事令僧斗诤。而不和合众僧破坏。令僧尘垢。令僧别异。分为二部。而此事未决断除灭。众僧为成如法和合不。佛告优波离。若众僧所因事令僧斗诤。而不和合众僧破坏。令僧尘垢。令僧别异。分为二部。若能于中改悔。不相发举。此则名为众僧以法和合。自今已去。听先白然后说。戒。当作如是白。大德僧听。众僧所因诤事令僧斗诤。而不和合众僧破坏。令僧尘垢。令僧别异。分为二部。彼人自知犯罪事。今已改悔除灭僧垢。若僧时到僧忍听和合说戒。白如是。作如是白已。然后和合说戒(说戒揵度竟)

四分律卷第三十六四分律卷第三十七(二分之十六)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    安居揵度

尔时佛在舍卫国祇树给孤独园。时六群比丘。于一切时春夏冬人间游行。时夏月天暴雨水大涨。漂失衣钵坐具针筒。蹈杀生草木。时诸居士见皆共讥嫌。沙门释子不知惭愧。蹈杀生草木。外自称言。我知正法。如是何有正法。于一切时春夏冬人间游行。夏天暴雨水大涨。漂失衣钵坐具针筒。蹈杀生草木断他命根。诸外道法尚三月安居。此诸释子。而于一切时春夏冬人间游行。天暴雨水大涨。漂失衣钵坐具针筒。蹈杀生草木断他命根。至于虫鸟尚有巢窟。止住处。沙门释子。一切时春夏冬人间游行。天暴雨水大涨。漂失衣钵坐具针筒。蹈杀生草木断他命根。时诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。呵责六群比丘言。汝云何于一切时春夏冬人间游行。夏天暴雨水大涨。漂失衣钵坐具针筒。蹈杀生草木。诸居士于草木中有命根想。令居士讥嫌故得罪耶。时诸比丘。往世尊所头面礼佛足在一面坐。以此因缘具白世尊。世尊尔时。以此因缘集比丘僧。以无数方便呵责六群比丘。汝所为非。非威仪非净行非沙门法非随顺行。所不应为。云何六群比丘。于一切时春夏冬人间游行。夏天暴雨水大涨。漂失衣钵坐具针筒。蹈杀生草木。居士于草木有命根想。讥嫌故。令居士得罪。以无数方便呵责六群比丘已告诸比丘。汝不应于一切时春夏冬人间游行。从今已去。听诸比丘三月夏安居。白所依人言。我于此处夏安居。长老一心念。我比丘某甲。依某甲聚落。某甲僧伽蓝。某甲房前。三月夏安居。房舍破修治故。如是第二第三说。后三月夏安居法亦如是。时诸比丘住处。无所依人。不知何所白。诸比丘有疑。不知成安居不。即白世尊。世尊言。发意为安居故。便得成安居。从今日听诸比丘若无所依人心念安居。尔时比丘。于住处欲安居。无所依人无白处。忘不心念安居有疑。不知成安居不。往白世尊。世尊言若为安居故来。便成安居。时诸比丘。往安居处。欲安居入界内。便明相出。彼有疑为成安居不。即白世尊。世尊言。若为安居故来。便成安居。尔时比丘。往安居处欲安居。入僧园内明相出。彼有疑不知成安居不。即白世尊。世尊言。若为安居故来。便成安居。尔时比丘。往住处欲安居。一脚入界内一脚在界外明相出。有疑不知成安居不。即白世尊。世尊言。若为安居故来。便成安居。时诸比丘。往住处欲安居。一脚入僧园内一脚在僧园外明相出。有疑不知成安居不。即白世尊。世尊言。若为安居故来。便成安居。若安居竟。客比丘来移旧比丘。佛言。不应移亦不应去。时诸比丘。于住处不看房舍卧具便受房。得不好房恶卧具。便嗔旧住比丘言。汝心不平等。所喜者。便与好房好卧具不喜者。便与恶房恶卧具。不喜我故。与我恶房恶卧具。时诸比丘。以此因缘具白世尊。世尊告诸比丘。若比丘于住处欲安居。应先自往看房舍卧具然后受房。从今已去。听分房分卧具。应差分房分卧具人白二羯磨有五法者。不应差分房舍卧具。若爱若嗔若怖若痴若不知可分不可分。有如是五法。不应差分卧具房舍。有五法。应差分房舍分卧具。若不爱不嗔不怖不痴知可分不可分。有如是五法。应差分房舍分卧具。应如是差堪能羯磨者。若上座若次座。若诵律若不诵律。堪能作羯磨者。应如是白。大德僧听。若僧时到僧忍听。差某甲比丘分卧具房舍。白如是。大德僧听。僧差某甲比丘分卧具房舍。谁诸长老忍僧差某甲比丘分房舍卧具者默然。谁不忍者说。僧已忍。僧差某甲比丘分房舍卧具竟。僧忍默然故。是事如是持。差分房舍卧具人竟。应数比丘数房舍数卧具。彼应问几房有人住。几房空。几房有卧具。几房无卧具。几房有被。几房无被。几房有利养。几房无利养。几房有器物。几房无器物。几房有檀越施衣。几房无檀越施衣。几房有福饶。几房无福饶。谁是经营房主。若有经营者。应问长老欲住何处房。不住何处房。彼尽数房舍卧具竟。至上座前作如是言。大德上座。如是房舍卧具随意所乐便取。先与上座房竟。次与第二上座。第二上座竟。次与第三上座。第三上座竟。次与第四上座。如是展转乃至下座若有余房舍卧具座应从上座更分。若复有余房舍。复应更从上座分。若余故多。应开客比丘住处。若有客比丘来应与。若恶比丘来不应与。善比丘来应与。若有余应留。若留房不应遮。若遮应如法治。时有比丘。得缺坏房。心念。我不受是房。恐使我修治。诸比丘即白世尊。世尊言。应受随力当治。时诸比丘分僧集处若温室若夏堂若经行堂。客比丘来不得房无住处诸比丘。以此因缘具白世尊。世尊言。不应分僧都集处若温室。若夏堂。若经行堂。若阁下堂是众集处。阁上应分。若阁上众集处。阁下堂应分时诸比丘。遍看房舍见阿练若窟。彼自念言。我当于此处安居。后更有余比丘。见阿练若窟。彼如是言。我当于此处安居。初十六日。众多比丘共集在窟内。住处迮狭多诸疾病。诸比丘即白世尊。世尊言。若比丘欲在如是处安居。先往作相。若作手迹。若作轮。若作摩醯陀罗像。若滕像。若作葡萄蔓像。若作华。若作五色。若书作名字。某甲欲于此安居。佛听先作相者住。此比丘若于此住处去。不灭名字便去。余比丘见先已有占者不敢住。诸比丘以此白佛。佛言。不应不灭名便去。应灭名而去。尔时波斯匿王。边国人民反叛。时王自领军往讨。诸比丘往边国。彼间房舍迮狭。不相容受。诸比丘作如是言。佛敕我等应分卧具。诸比丘白佛。佛言。听齐床分。若不容受。应等绳床分。若故不容受。应等卧处分若故不容受。应共分坐处。彼比丘移此定床褥卧具置余房中。诸比丘往白佛。佛言。不应移转。或有房多卧具。或有房少卧具。诸比丘以此因缘白佛。佛言。听诸比丘语旧住人。若佛图主。若经营人。若有三月安居得房者。问如是人等。然后得移转卧具。诸比丘不还复卧具着本处便去。后比丘来。谓是此房卧具便用。诸比丘以此因缘往白佛。佛言。不应不还复卧具便去。应还复卧具而去。若不者应如法治。时有房舍缺坏。诸比丘有畏慎。佛不听移转卧具从此房至彼房。诸比丘以此因缘白佛。佛言。若房舍破坏。听移此房卧具置余房。彼移卧具不用而虫烂坏。诸比丘白佛。佛言应用。佛既听用。彼不洗脚不拭脚。用作衬体衣。诸比丘以此因缘白佛。佛言。不应不洗脚不拭脚及作衬体衣。诸比丘畏慎以此白佛。佛言。不应用作衬体衣。故不敢手脚触。诸比丘以此事白佛。佛言膝已上腋已下。不得衬体。手脚触无苦。时诸檀越有布施诸比丘衬体衣。诸比丘畏慎不敢受。佛不听用衬体衣。诸比丘白佛。佛言。听随檀越施意。若治房舍竟。先此房卧具。不还移来本处。诸比丘以此事白佛。佛言。若治房舍竟。应还移卧具着本处不者应如法治。彼比丘移此寺定卧具着余寺。诸比丘以此事白佛。佛言。不应移此寺定卧具着余寺。若有恐怖。若有怨家。若人民反叛。若国邑荒坏。人民破丧。住处亦坏。诸比丘畏慎。佛不听移此寺定卧具着彼寺。诸比丘以此事白佛。佛言。若有恐怖怨家。若反叛国邑荒坏。人民破丧。住处亦坏。听移余处移卧具。时诸比丘畏慎。佛教不听以僧卧具衬体故不得好覆藏。诸比丘以此因缘白佛。佛言。随宜覆藏应移。若有余比丘来。索不应索亦不应与。除可信后必还得者。应与。后国邑还静。人民还复。寺舍还成。不还卧具。比丘以此事白佛。佛言。若国邑已静。人民还复。寺舍已成。应还卧具。若不还者应如法治。尔时有住处。四方众僧。大得不定卧具绳床木床粗细褥枕毾[毯-炎+登][毯-炎+瞿]毹地敷澡瓶杖扇。诸比丘。不知云何处分。以此事白佛。佛言。听房中无卧具者付与。若有余从上座付尔时舍利弗目连。欲共世尊安居。十五日从所住处往。十七日乃至。不知当云何。即白诸比丘。诸比丘以此事白佛。佛言。听后安居。有二种安居。有前安居。有后安居。若在前安居应住前三月。若后安居应住后三月。前安居者欲自恣。后安居者不知得自恣不。诸比丘以此事白佛。佛言。听受自恣住待日足。前安居人自恣已数岁。后安居人不知得数岁不。诸比丘以此事白佛。佛言。不应三月未足便数岁。前安居者自恣竟。驱遣后安居者。诸比丘以此事白佛。佛言。不应遣亦不应去。前安居人自恣竟分夏所得物。后安居者畏慎不敢受分。佛不听我等三月未竟乞求受物。诸比丘以此事白佛。佛言。听比丘受余日应足令满。前安居者自恣竟分卧具。后安居者畏慎不敢受。以夏三月日未满故。诸比丘以此事白佛。佛言。听为未来故受。尔时诸比丘。露处安居。得风飘日曝。形体黑瘦皮肤剥裂。往诣佛所头面礼足却坐一面。世尊知而故问。汝等何故形体黑瘦皮肤剥裂耶。诸比丘白佛言。在露地安居故尔。佛言。不应在露地安居。自今已去。听诸比丘作覆障处安居。尔时诸比丘树上安居。即在树上大小便利。时树神嗔嫌。伺其便欲断命根。诸比丘以此事白佛。佛言。自今已去。不听比丘在树上安居。亦不应上树。除齐人头。不应绕树左右大小便利浇灒污树。尔时诸比丘。在拘萨罗国人间游行。道有恶兽。时诸比丘。上树过人畏慎还下。佛不听我等上树过人。遂为恶兽所害。诸比丘以此事白佛。佛言。自今已去。听为命难净行难。故得上树过人头。诸比丘欲取树上干薪。听作钩钩取。听作梯取。若绳罥取。后诸比丘畏慎。不敢上干树上。佛言。若树通身干听上。尔时诸比丘。欲于树下安居往白佛。佛言。自今已去。听在树下安居。若树高过人头者。枝叶足覆荫一坐。时六群比丘。用蜡蜜涂帐坐中安居。彼作如是心。我等夜在中宿。朝则藏举。其有见者。当谓我等得神通人。诸比丘以此事白佛。佛言。自今已去。不听以蜡蜜涂帐在中安居。亦不得谄曲为身故改常威仪。尔时比丘欲在小屋内安居。诸比丘白佛。佛言。自今已去听诸比丘在小屋内安居。起不碍头坐趣容膝。亦足障水雨。尔时比丘。欲在山窟中安居。即往白佛。佛言。自今已去听在山窟中安居。起不碍头坐趣容膝。亦足障水雨。尔时比丘。欲于自然山窟中安居。时诸比丘往白佛。佛言。自今已去。听比丘在自然山窟中安居。起不碍头坐趣容膝亦足障水雨。尔时比丘。欲于树空中安居。诸比丘往白佛。佛言。自今已去。听诸比丘在树空中安居。起不碍头坐趣容膝亦足障水雨。尔时比丘。欲依牧牛者安居往白佛。佛言。自今已去。听依牧牛者安居。安居中移徙随牧牛者所去处应去。尔时诸比丘欲依客压麻油人安居往白佛。佛言。自今已去。听依压油人安居。安居中移徙随压油人所去处应去。尔时比丘。欲于船上安居。往白佛。佛言。自今已去。听诸比丘在船上安居。安居中移徙随船所去处应去。尔时比丘。欲依斫材人安居。往白佛。佛言。自今已去。听诸比丘依斫材人安居。安居中移徙随斫材人所去处应去。尔时比丘。欲依聚落安居。往白佛。佛言。自今已去。听依聚落安居安居中若聚落分为二分。随所供给所须具足处住。安居中移徙随所去处应去。尔时有檀越。请比丘言。我欲布施及房舍。彼比丘自念。彼处远不得即日还。佛未听有如是因缘得去。诸比丘往白佛。佛言。自今已去。听受七日去。不应专为饮食故受七日去。除余因缘。若为衣钵坐具针筒乃至药草。至第七日应还。尔时诸比丘。请余比丘长老来。我等得僧残。为我治覆藏法本日治摩那埵出罪。比丘自念。彼处远不得即日还。佛未听有如是因缘去。诸比丘以此事白佛。佛言。听有如是事受七日去及七日还。尔时比丘尼。请比丘长老来。我等得僧残。为我作摩那埵出罪。比丘自念。彼处远不及即日还。佛未听我等有如是事去。往白佛。佛言。自今已去。听有如是事。受七日去及七日还。尔时有式叉摩那。请比丘言长老来。我等犯戒。为我等忏悔更受戒。若受大戒。比丘自念。彼处远不及即日还。佛未听有如是事去。往白佛。佛言。自今已去。听有如是事受七日去及七日还。尔时有沙弥请比丘。长老来。我欲受戒。比丘自念。彼处远不及即日还。佛未听有如是事去。往白佛。佛言。自今已去。听有如是事受七日去及七日还。尔时有沙弥尼。请比丘。大德来。我欲受六法。比丘自念。彼处远不得及即日还。佛未听有如是事去。往白佛。佛言。自今已去。听如是事受七日去及七日还。尔时有不信乐大臣。请比丘大德来。我欲相见。比丘自念。彼处远不及即日还。佛未听有如是事去。往白佛。佛言。自今已去。听有如是事受七日去。若有益无益及七日还。尔时有信乐大臣。请比丘。大德来。我欲相见。比丘自念。彼处远不及即日还。佛未听有如是事去。往白佛。佛言。自今已去。听有如是事受七日去。此信乐优婆塞。若病若有诸忧恼事。若为利养故。及七日应还。尔时有不信乐父母。请比丘。大德来。我欲相见。比丘自念。彼处远不及即日还。佛未听有如是事去。往白佛。佛言。自今已去。有如是事听受七日去。若不信乐教令信乐。若恶戒教令持戒。若悭贪教令布施。若无智教令有智。及七日应还。尔时有信乐父母。遣信请比丘。大德来。我欲相见。比丘自念。彼处远不及即日还。佛未听有如是事去。往白佛。佛言。自今已去。听有如是事受七日去。若信乐父母。若病若有诸忧恼事。若有利益事。及七日还。尔时有母请比丘。大德来。我欲相见。比丘自念。彼处远不及即日还。佛未听有如是事去往白佛。佛言。自今已去。有如是事听受七日去。及七日应还尔时有父。请比丘亦如是。兄弟姊妹及诸亲里知识亦如是。尔时有比丘。诵六十种经。如梵动经。为求同诵人故。欲人间游行。比丘自念。彼处远不及即日还。佛未听我等有如是事去往白佛。佛言。自今已去。听有如是事受七日去及七日还。尔时经劳比丘。有作事须往林树间。自念。彼处远不及即日还往白佛。佛言。自今已去。听有如是事受七日去及七日还。尔时波斯匿王。边国人民反叛。王自领军往讨。王所供养佛及众僧。衣被饮食所须之物。不信乐大臣便夺不与。诸比丘欲往白王。自念。彼处远不及即日还。佛未听有如是事去往白佛。佛言。自今已去。有如是事。听受七日去及七日还。尔时波斯匿王。边国人民反叛。时王自领军往讨。尔时有不信乐大臣。怀嫉妒恶心。欲凿只桓通渠。比丘欲往白王。自念。彼处远不及即日还。佛未听有如是事去往白佛。佛言。自今已去。有如是事听受七日去及七日还。尔时有檀越。遣信请比丘。大德来。我欲布施及房舍。比丘自念。彼处远不及七日还。佛未听有如是事去往白佛。佛言。自今已去。听有如是事受过七日法。若十五日若一月。白二羯磨。如是差堪能羯磨者。若上座若次座。若诵律若不诵律。能作羯磨者。应作如是白。大德僧听。若僧时到僧忍听。某甲比丘。受过七日法。若十五日若一月出界外。为某甲事故。还此中安居白如是。大德僧听。某甲比丘。受过七日法。若十五日。若一月出界外。为某甲事故。还此中安居。谁诸长老忍。僧听某甲比丘受过七日法。若十五日若一月出界外。为某甲事故。还此中安居者默然。谁不忍者说。僧已忍。某甲比丘受过七日法。若十五日若一月出界外。为某甲事故。还此中安居竟。僧忍默然故。是事如是持。比丘。遣信请比丘受过七日羯磨亦如是。比丘尼。请比丘受过七日羯磨亦如是。式叉摩那。请比丘羯磨亦如是。沙弥。请比丘受戒亦如是。沙弥尼。请比丘受过七日羯磨亦如是。不信大臣。请比丘受过七日法羯磨亦如是。识信大臣羯磨亦如是。不信父母。信父母。兄弟姊妹。诸亲里知识。诵六十种经。比丘。经营事比丘不信乐大臣。夺供养通渠亦如是。一切受过七日羯磨法尽同上。尔时世尊在拘睒弥国。时有大臣勇健能斗。往诣佛所以信舍家为道。时忧填王语言。汝何不休道。当与汝妇资生田宅财宝。比丘自念。我在此安居。必与我净行作留难。作此念已往白佛。佛言。若有此难事便应去。尔时有比丘。于住处安居。时有大童女来诱调比丘。汝何不休道。我当为汝作妇。彼比丘自念。我在此安居。必为净行作留难。作此念已往白佛。佛言。若有此难事应去。尔时有比丘。在住处安居。时有淫女来诱调比丘。汝可休道。我当为汝作妇。或嫁女与汝。彼比丘自念。我在此安居。必为净行作留难。作此念已往白佛。佛言。若有此难应去。尔时有比丘。在住处安居。有黄门贪爱比丘故。数唤比丘共行不净。比丘自念。我在此安居。必为我净行作留难。作此念已往白佛。佛言。若有此事应去。尔时有比丘。在住处安居。时有鬼神语比丘言。此中有伏藏。比丘自念。我在此安居。必为我净行作留难。作此念已往白佛。佛言。若有此事应去。尔时有比丘在住处安居。时有鬼神伺比丘便欲断其命根。比丘自念。我在此安居必为命作留难。作此念已往白佛。佛言。若有此事应去。尔时有比丘。在住处安居。有贼伺比丘便欲断命根。比丘自念。我在此安居。必断我命。作此念已往白佛。佛言。若有此事应去。尔时有比丘。在住处安居。毒蛇嗔恚伺比丘便欲断命根。比丘自念。我在此安居。必有断命留难。作此念已往白佛。佛言。若有此事应去。尔时有比丘。在住处安居。诸恶兽嗔伺比丘便欲断命根。比丘自念。我在此安居。必有断命留难。作此念已往白佛。佛言。若有此事应去。尔时有比丘。在住处安居。不得如意饮食。不得随意医药。不得随意使人。彼自念言。我当云何。即白诸比丘。诸比丘往白世尊。世尊言。若比丘于安居处。若不得随意饮食。不得随意医药。不得随意使人。即应以此事去。尔时有比丘。在住处安居。经行处多诸毒虫。此比丘狎习经行。经行体安。不经行不安。彼比丘自念。我在此住。必为我命作留难。作此念已往白佛。佛言。若有此事应去。尔时有比丘。在住处安居。见有比丘作方便欲破僧。时彼自念言。破僧事重。甚为丑恶。莫为我故破僧。我当云何。即白诸比丘。诸比丘以此事白佛。佛言。若比丘于住处安居。见有比丘。勤方便欲破僧。时彼作如是念。破僧事重。甚为丑恶。莫为我故破僧。彼比丘即应以此事去。尔时有比丘。在住处安居。见有比丘尼勤方便欲破僧。彼如是念。破僧事重。甚为丑恶。莫为我故破僧。彼即应以此事去。若比丘于住处。安居时闻有比丘勤方便欲破僧。彼如是念。破僧事重甚为丑恶。莫为我故破僧。彼即应以此事去。若比丘于住处安居。闻有比丘尼欲方便破僧。彼如是念。破僧事重甚为丑恶。莫为我故破僧。彼即应以此事去。尔时有比丘。于住处安居。闻彼有比丘欲方便破僧。彼自念言。我若往呵谏责数。必用我言止不破僧。复作是念。若我自往。或不用我语。不能止其破僧事。我有亲友能止彼破僧事。我若语彼必用我言。为我止彼破僧事。我当云何。即语诸比丘。诸比丘往白佛。佛言。若比丘于住处安居。闻有比丘欲方便破僧。比丘自念。我若自往彼呵谏责数。必用我言令其止不破僧。复作是念。我或不能止彼诤事。我有亲友能止彼诤事。我当语彼令止破僧事。彼即应以此事去。若比丘住处安居。闻彼有比丘尼勤方便欲破僧。彼比丘自念。彼若往彼呵谏责数必用我言止破僧事。复作是念。我或不能。我有亲友能止彼诤。若我语彼。必能为我止破僧事。彼即应以此事去。若比丘是中安居。闻彼僧破。比丘自念。我若往彼呵谏责数。必用我言令僧和合。复作是念。我或不能。我有亲友能止彼诤。我若语彼。必用我言。和合彼僧。比丘即应以此事去。若比丘是中安居。闻彼比丘尼僧破。我若往彼呵谏责数。必用我言令僧和合。复作是念。我或不能。我有亲友能止彼诤。若我语彼。必用我言和合彼僧。彼即应以此事去。尔时有比丘。受七日出界外。为其母所留。至意欲还。而遂不及七日。彼自念言为失岁为不失岁。即白诸比丘。诸比丘往白佛。佛言。不失岁父母兄弟姊妹本二。若本私通者。若夜叉鬼神难亦如是。尔时比丘。受七日出界外住。水陆道不通。若贼难虎狼师子诸难。作如是念。我为失岁为不失岁。即白诸比丘。诸比丘往白佛。佛言。不失岁。尔时佛在拘睒弥国瞿师罗园。尔时王忧陀延与跋难陀释子为亲友。请跋难陀夏安居。跋难陀。拘睒弥国结安居。闻余住处大得利养大得衣物。即便往彼住处。小住彼已。复还拘睒弥。时王忧陀延闻已嫌言。云何跋难陀释子。受我请在此住夏安居。闻彼住处大得利养大得衣物。便往至彼。在彼住已。复还来此。诸比丘闻。中有少欲知足行头陀知惭愧乐学戒者。呵责跋难陀释子。云何汝在彼夏安居。闻异住处大得利养大得衣物。便往彼住。住既不久而还此即往佛所头面礼足各坐一面。以此因缘具白世尊。世尊以此因缘集比丘僧。以无数方便呵责跋难陀言。汝无知。非威仪非净行非沙门法非随顺行。所不应为。云何跋难陀。汝于拘睒弥夏安居。闻彼异处大得利养大得衣物。便往彼住。而复还拘睒弥。呵责已告诸比丘。若比丘在前安居处。闻彼处大得利养大得衣物。即便往彼。彼比丘不得前岁。违本要得罪。若比丘。于此受他前安居请。至界外布萨已便往余处。彼比丘。破前安居违本要得罪。若比丘。受他前安居请。在界外布萨已来至请处即日还去。彼比丘。破前安居违本要得罪。若比丘。受他前安居请。界外布萨已来至请处。受房舍卧具无事便去。彼便破前安居违本要得罪。若比丘受他前安居请。界外布萨已来至住处。受七日出界外。意欲来过七日。彼比丘。破前安居违本要得罪。若比丘。受他前安居请。在界外布萨已来至住处。受七日出界外及七日还。彼比丘。成前安居不违本要无罪。若比丘。受他前安居请。在界外布萨已。来至住处。末后受七日出界外。彼比丘。若来若不来住处。彼比丘。成前安居不违本要无罪。若比丘。受他前安居请。来至界内布萨已到住处即日还去。彼比丘。破前安居违本要得罪。若比丘。受他前安居请。来至界内布萨已到住处。受房舍卧具。无事便去。彼比丘。破前安居违本要得罪。若比丘受他前安居请。来至界内布萨已到住处。受七日出界外。意欲还不及七日。彼比丘。破前安居违本要得罪。若比丘受他前安居请。来至界内布萨已到住处。受七日出界外及七日还。彼比丘。不破前安居不违本要无罪。若比丘。受他前安居请。界内布萨已到住处。末后受七日出界外。若还若不还住处。不破前安居不违本要无罪。后安居亦如是。尔时有比丘。受他前安居请。在彼见有命难若净行难。彼作如是念。我当云何即告诸比丘。诸比丘往白佛。佛言。若比丘在住处。若受前安居后安居。见有命难若净行难。彼比丘。若自往若遣信使。往白檀越求移去。若听者善。若不听便应去。(安居揵度竟)

    自恣揵度

尔时佛在舍卫国祇树给孤独园。时有众多比丘。在拘萨罗国。于异住处夏安居。彼作如是念。我曹当云何得安乐住。不以饮食为疲苦。彼作如是语。我等当共作制结安居。不得共语礼拜问讯。若先入聚落乞者。先还扫除食处。敷座具具水器具洗足器具盛食器。各自持食来置食处。若得食多者。先应减留。若足便食。食讫默然还房。若次有入聚落乞者。得食便还。持食至食处。若得食多者。应先减留。若足便食。若不足者。取先所留食足食。食讫默然还房。若末后入聚落乞者。得食便还。持食至食处。若得食多者。先应减留。若足食便食。若不足者。取先所留者足食之。有余残食。若与乞人若非人。若无与处。应置净地无草处。若置无虫水中。洗治食器还复本处。卧具水器洗足器及座具还复本处。扫除食处。若见水器洗足器空。若能胜者。即应持还。若不能胜。以手招伴。共持器还复本处。默然还房。不应以此因缘有所说。如是我等可得安乐住。不以食饮为苦。作如是制。结安居自恣竟。诣舍卫国只桓中。至佛所头面礼足各坐一面。时世尊慰劳诸比丘。汝曹安乐不。饮食足不。住止和合不。不以饮食为疲苦耶。诸比丘白佛言。住止安乐饮食不乏彼此和合不以饮食为苦。佛问诸比丘。汝等以何方便住止安乐彼此和合不以饮食为苦。诸比丘以向因缘事具白佛。佛告诸比丘。汝曹痴人。自以为乐。其实是苦。汝曹痴人。自以无患。其实是患。汝曹痴人。共住如似怨家。犹如白羊。何以故。我无数方便教诸比丘。彼此相教共相受语展转觉悟。汝曹痴人。同于外道。共受哑法。不应如是行哑法。若行哑法突吉罗。时六群比丘作如是言。佛教诸比丘。彼此相教共相受语展转觉悟。便举他清净比丘罪。诸比丘往白世尊。世尊言。不应举他无罪比丘事。若欲举有事比丘。应先当语令知求听然后应举。时六群比丘。闻佛教应先当语令知求听然后举。先清净比丘。曾从六群比丘求听。六群比丘。以嫌故覆复从清净比丘求听。诸比丘以此事往白佛。佛言。不应先清净比丘曾从六群比丘求听。六群比丘。不应以嫌故复从清净比丘求听。自今已去。听具五法得求听。何等五。知时不以非时。如实不以虚妄。有利益不以无利益。柔软不以粗犷慈心不以嗔恚。彼六群比丘。内无五法。余清净比丘。具足五法者。从六群比丘求听。六群比丘不听。诸比丘以此因缘往白佛。佛言。听比丘具足五法者若求听应听。时六群比丘。从他求听已去。或与他听已便离住处去。诸比丘以此事白佛。佛言。不应求他听。既听已便去。亦不应与他听已便去。自今已去。听言要莫去。六群比丘。便要他已而自去。或与他言要而复自去。诸比丘以此事往白佛。佛言。不应要他已而自去。不应与他言要已而复去。自今已去。听安居竟自恣。听遮自恣不应求听。何以故。自恣即是听。诸比丘作是念。佛听诸比丘自恣。诸比丘一时自恣闹乱。诸比丘以此事白佛。佛言。不应一时自恣。自今已去。听一一自恣。诸比丘不求次第随意自恣。上座疲极。诸比丘以此事白佛。佛言。不应随意自恣。应从上座自恣。听差授自恣人白二羯磨。若有五法者。不应差作受自恣人。若爱若嗔若怖若痴不知自恣未自恣。具如是五法者。不应差受自恣。有五法者。应差作受自恣人。若不爱不嗔不怖不痴知自恣未自恣。具如是五法者。应差受自恣。应如是差堪能人。若上座若次座。若诵律若不诵律。堪能羯磨者。白二羯磨当作如是白。大德僧听。若僧时到僧忍听。僧差某甲比丘作受自恣人。白如是。大德僧听。僧差某甲比丘作受自恣人。谁诸长老忍。僧差某甲比丘作受自恣人者默然。谁不忍者说。僧已忍。差某甲比丘作受自恣人竟。僧忍默然故。是事如是持。时诸比丘在座上自恣。诸比丘以此事白佛。佛言。不应在座上自恣。听离座胡跪自恣。时上座离座自恣。一切僧故在座自恣。佛言。若上座离座胡跪。一切僧亦应离座胡跪。时上座自恣竟胡跪。乃至一切僧自恣竟。上座疲极。诸比丘以此事白佛。佛言。听随自恣竟复坐。时六群比丘念言。我曹窃语自恣。彼比丘或能为我作羯磨若遮我自恣。诸比丘以此事往白佛。佛言。不应作如是念。窃语自恣。恐余比丘为我作羯磨若遮我自恣。应了了自恣。足使他闻。彼六群比丘复作是念。我当疾疾自恣。恐余比丘为我作羯磨或遮自恣。诸比丘白佛。佛言。不应作如是念。我当疾疾自恣。恐余比丘为我作羯磨。若遮我自恣。自今已去。听安居已徐徐自恣。彼六群比丘作是念。我当一说自恣。恐余比丘为我作羯磨若遮自恣。诸比丘白佛。佛言。不应作是念。我当一说自恣。恐余比丘为我作羯磨若遮自恣。彼六群比丘自念。我当再说自恣。恐余比丘为我作羯磨若遮自恣。诸比丘白佛。佛言。不应作如是念。我当再说自恣。恐余比丘为我作羯磨若遮自恣。自今已去。听诸比丘三说自恣。时六群比丘。反抄衣自恣。衣缠颈自恣。裹头自恣。通肩披衣自恣。着革屣自恣。若地坐自恣。若床上坐自恣。诸比丘往白佛。佛言。不应反抄衣缠颈裹头通肩披衣着革屣。若地坐若床自上坐自恣今已去。听诸比丘偏露右肩脱革屣胡跪合掌。作如是语。大德众僧今日自恣。我某甲比丘亦自恣。若见闻疑罪。大德长老。哀愍故语我。我若见罪。当如法忏悔。如是第二第三说。时有病比丘。偏露右肩脱革屣胡跪合掌时顷久病即更增。诸比丘白佛。佛言。自今已去。听病比丘随身所安受自恣。尔时有异住处比丘自恣。有比丘在说戒堂外。诸比丘自恣竟。起出去外。比丘问言。长老何处去。不自恣耶。彼答言。我已自恣竟。汝从何来。答言。我在说戒堂外。诸比丘白佛。佛言。自今已去。自恣时不应在说戒堂外。听比坐应知若来若不来。听先白已然后自恣。如是白。大德僧听。今日众僧自恣。若僧时到僧忍听。僧和合自恣。白如是。如是白已自恣。六群比丘非法别众自恣。非法和合自恣。法别众自恣。诸比丘白佛。佛言。不应非法别众自恣。非法和合自恣。法别众自恣。有四种自恣。若比丘非法别众自恣。非法和合自恣。法别众自恣。法和合自恣。若比丘作非法别众自恣。非法和合自恣。法别众自恣。如是不应自恣。法和合自恣。应如是自恣。是我所听自恣。尔时自恣时。异住处前安居后安居人杂住。不知云何随前安居为随后安居自恣。诸比丘白佛。佛言。随上座所在处自恣。上座或前安居或后安居。应随旧住者自恣。旧住者亦有前安居有后安居。随多者应自恣。时诸比丘。欲十四日十五日自恣。佛言。听如是自恣。若王改日时应随时。诸比丘不知。今日自恣明日自恣。诸比丘往白佛。佛言。自今已去。听若小食上中食上上座唱令。今日众僧自恣。复不知用何时。佛言。听作时相。若打揵稚。若吹呗。打鼓。若起烟。若量影。若唱言。今自恣时到。六群比丘。闻佛听自恣。便于别房中。共同和尚阿阇梨亲厚同学得意者别部作自恣。诸比丘白佛。佛言。不应于别房共同和尚阿阇梨亲厚同学得意者别部作自恣。自今已去。一处和合自恣。诸比丘复不知在何处自恣白佛。佛言。听在说戒处自恣。尔时有众多比丘。于自恣日。在非村阿练若未结界处道路行。诸比丘自念。佛教我等和合自恣。我等当云何。诸比丘白佛。佛言。若众多比丘。于自恣日。在非村阿练若未结界处道路行。诸比丘。若和合得自恣者善。若不得和合者。随所同和尚阿阇梨随亲厚同意移异处。结小界作自恣。白二羯磨。应如是结小界。差堪能者。若上座若次座。若诵律若不诵律。堪能羯磨者如是白。大德僧听。诸比丘坐处已满。齐如是比丘坐处。若僧时到僧忍听。僧于此处结小界。白如是。大德僧听。齐如是比丘座处。僧于此处结小界。谁诸长老忍。齐如是比丘座处僧于中结小界者默然。谁不忍者说僧已忍。齐如是比丘座处。结小界竟僧忍默然故。是事如是持时比丘不舍界便去。诸比丘不喜。即往白佛。佛言。不应不舍界而去。应舍界竟然后去应如是舍白二羯磨差堪能人。若上座若次座。若诵律若不诵律。堪能作羯磨者。应作如是白。大德僧听齐如是比丘座处。若僧时到僧忍听。僧解此处小界白如是。大德僧听。齐如是比丘座处。僧于中解小界。谁诸长老忍。僧齐如是比丘座处解小界者默然。谁不忍者说僧已忍。齐如是比丘座处。解小界竟。僧忍默然故。是事如是持

四分律卷第三十七四分律卷第三十八(三分之二)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    自恣揵度之二

尔时自恣日。有异住处。有一比丘住。彼自念言。世尊有教。和合一处共自恣我当云何。即白诸比丘。诸比丘白佛。佛言。自恣。日于异处有一比丘住。彼应往说戒处。扫洒敷座具具盛水器具洗脚器然灯具舍罗。为客比丘。若客比丘来五人若过五人。应作白羯磨差受自恣人。若有四人更互为自恣言。今日众僧自恣。我某甲比丘亦自恣清净。第二第三亦如是说。若有三人二人亦如是自恣。若一人心念口言自恣。今日众僧自恣。我某甲比丘自恣清净。第二第三亦如是说。若有五人一人受欲不得白差受自恣人。若有四人不得受第五人欲更互自恣。若有三人不得受第四人欲更互自恣。若有二人不得受第三人欲更互自恣。若有一人不得受第二人欲心念自恣。尔时自恣日。众僧集聚欲自恣佛告诸比丘。寂静今日众僧自恣。余比丘白佛言。有病比丘不来。佛言。听与自恣。听嘱授自恣。应如是与病人言。与汝自恣。若言。我语汝自恣。若言。为我说自恣。若动身与自恣。若广说自恣。如是名为与自恣。若不动身。若不口言。不成与自恣。应更与自恣嘱授比丘。若到病人所便命过。若出界去。若休道。若至外道所住处。若入破僧伴党。若至戒场上。若明相出若自言犯边罪。若犯比丘尼。若贼心入道。若从外道中还。若黄门。若杀父母。若杀阿罗汉。若破僧。若恶心出佛身血。若是非人。若是畜生。若二根人。若为他所举。若灭摈若应与灭摈者。若与如是人等。不成嘱授自恣。应更与余人。若在道中。若至僧中。有如是事起。若僧为作不见罪羯磨。若作不忏悔罪羯磨。若作不舍恶见羯磨。如是不成嘱授自恣。应更与余人若眠不说。若入定。若忘误。若不故作至自恣处。是为嘱授自恣到。若故不说突吉罗。若能如是作者善。若不能尔者。彼应扶将病比丘去。若以绳床木床。若合衣舁去。至自恣处。彼比丘作如是念。我曹扶将病比丘。或能增病或能死。众僧应尽来至病人所作羯磨自恣。若有多比丘病集在一处者善。若不能者。诸比丘应出界外作羯磨自恣不应别众自恣。尔时有比丘。受嘱授自恣便命过。若休道。若至戒场上。若至明相出。诸比丘自念。为失嘱授自恣不。佛言失。尔时有比丘。嘱授自恣。二道断。贼虎狼师子难水大涨。界内道断不得往。出界外持嘱授自恣来。诸比丘作如是念不失嘱授自恣不。佛言不失。自今已去受嘱授自恣。比丘若有命难净行难。界内无道。听从界外持嘱授自恣来。我说不失嘱授自恣。诸比丘受一人嘱授自恣。畏慎不敢复受。即白佛。佛言听受。时比丘受二人嘱授自恣。畏慎不敢复受。即白佛。佛言听受。时比丘受三人嘱授自恣。畏慎不敢受。四人嘱授自恣。即白佛。佛言听受。乃至随能忆字多少应受。若忆字尽应说字。若不忆字应说姓。若说相貌。若言我受众多比丘嘱授自恣。彼如法僧事与欲说自恣。年少比丘不知自恣。告诸比丘。诸比丘白佛。佛言。自今已去。应和尚阿阇梨教诏。若教喜忘不忆。应使授自恣者教诏。若故复忘。应共句句说。若比丘受嘱授自恣已有事起。诸比丘白佛。佛言。自今已去。听更转与余人。应如是与。我为众多比丘受嘱授自恣。我今有事。为彼与欲。并复自与欲。如法僧事与欲说自恣。彼比丘与欲竟事还息。彼畏慎。我已转嘱授自恣竟。不知云何。诸比丘往白佛。佛言。事还息应往。若不往应如法治。时六群比丘作是念。我不往自恣处。恐为我作羯磨若遮自恣。诸比丘白佛。佛言。不应作如是念。我不往自恣处。恐诸比丘为我作羯磨若遮自恣。若为知识亲厚。不往自恣处亦如是。时六群比丘作是念。我往自恣处不坐。恐诸比丘为我作羯磨若遮自恣。诸比丘往白佛。佛言。不应作如是念。我往自恣处不坐。恐诸比丘为我作羯磨若遮自恣。若为知识亲厚亦如是。彼作如是念。我若往彼不说自恣。恐诸比丘为我作羯磨若遮自恣。诸比丘白佛。佛言。不应作如是念。我往彼不说自恣。恐诸比丘为我作羯磨若遮自恣。若为知识亲厚亦如是。尔时自恣日。有异住处。众僧和合欲自恣。闻有贼来恐怖离座而去。竟不自恣。诸比丘以此事白佛。佛言听。若有八难事来。听略说自恣。是中难者。王难贼难火难水难病难人难非人难毒虫难。是中事者。若众僧多坐处迮。若多人病。应略说自恣。若众僧多。若房屋少。若天雨应略说自恣。若布萨夜过多。若斗诤事。若论阿毗昙。若毗尼折喻。若说法夜已久。众僧未起。明相未出。应羯磨自恣。受他嘱授自恣。不得至明相出。若至明相出不得羯磨自恣。诸比丘作如是言。为难事略说自恣。而难事尚远。我等容得广说自恣。彼比丘应广说自恣。若不广说者应如法治。诸比丘作如是言。为难事略说自恣。今难事不远。我曹不得广说三语自恣。当再说自恣。彼即应再说自恣。若不再说应如法治。诸比丘如是言。为难事略说自恣。今难事近。不容得再说自恣。可得一说自恣。彼比丘即应一说自恣。若不应如法治。诸比丘作如是言。为难事故略说自恣。难事近。不得一说自恣。我等可容各各共三语自恣。诸比丘即应作白各各共三语自恣。应如是白。大德僧听。若僧时到僧忍听。僧今各各共三语自恣。白如是。如是白已。各各共三语自恣。再说一说亦如是。诸比丘作如是言。为难事故各各共三语自恣。难事近。不得各各共三语自恣。亦不得白。彼比丘即应以此难事去。尔时有异住处比丘犯僧残。彼不知云何。告诸比丘。诸比丘往白佛。佛言。若比丘于异住处犯僧残。彼比丘。若应与覆藏。当与覆藏。与覆藏羯磨。竟应自恣。应与本日治。当与本日治。与本日治羯磨竟应自恣。应与摩那埵。当与摩那埵。与摩那埵羯磨竟应自恣。应与出罪。当与出罪。与出罪羯磨竟应自恣。尔时自恣日。异住处有比丘。犯波逸提。或言犯波逸提。或言犯波罗提提舍尼。彼作如是言。我等当云何。即告诸比丘。诸比丘白佛。佛言。若自恣日。异住处有比丘犯波逸提。是中比丘。或言犯波逸提。或言犯波罗提提舍尼。若知犯波逸提者。即应将此人在一处令彼言犯波罗提提舍尼者。眼见耳不闻处。教令忏悔已。到彼言犯波罗提提舍尼比丘所语言。彼犯罪比丘。我教忏悔已。应作如是方便已自恣。尔时自恣日。异住处有比丘。犯偷兰遮。诸比丘。或言犯偷兰遮。或言犯波罗夷言犯偷兰遮者。皆是多闻通阿含阿毗昙。持律多知识比丘比丘尼。优婆塞优婆私。若王若大臣。若种种外道沙门梵志言犯波罗夷比丘。亦是多闻。通阿含阿毗昙。持律亦复多知识。比丘比丘尼。乃至沙门梵志。诸比丘作如是言。若今日自恣。众僧必当有诤事。或能破僧。或生僧尘垢。污染众僧。使僧别异。我等当云何。即告诸比丘。诸比丘往白佛。佛言。若自恣日。异住处有比丘。犯偷兰遮。诸比丘。或言犯偷兰遮。或言犯波罗夷。言犯偷兰遮者。皆是多闻。通阿含阿毗昙。持律多知识比丘比丘尼。优婆塞优婆私。若王若大臣。若种种外道沙门梵志。言犯波罗夷者比丘。亦是多闻。通阿含阿毗昙。持律亦复多知识。比丘比丘尼乃至沙门梵志。诸比丘作如是言。若今日自恣。众僧必当有诤事。或能破僧。或生僧尘垢。污染众僧。使僧别异者。若畏破僧。不应即日自恣。应小停自恣。自恣时。六群比丘。闻佛听遮自恣。即遮清净比丘不令自恣。诸比丘往白佛。佛言。不应遮清净比丘自恣。若遮犹如不遮。若遮无根不作者。是谓不遮自恣。若遮有根有作者。是谓遮自恣。若遮无根有余不作者。是谓不遮自恣。若遮有根有余作者。是谓遮自恣。若遮无根无余不作者。是谓不遮自恣。若遮有根无余作者。是谓遮自恣。未说三语自恣若遮。是谓不遮自恣。说三语自恣竟若遮自恣。是谓不遮自恣。当三说自恣时若遮自恣。是谓遮自恣。一说再说亦如是。遮自恣人。若身业不清净。口业不清净。意业不清净。无智不分明。不知问不能答。余比丘应语此比丘。止长老。不须起此斗诤事。莫用此比丘语。便应自恣。若遮自恣人身业清净。口意业不清净。无智不分明。不知问不能答。余比丘语此比丘。止长老。不须起此斗诤事。莫用此比丘语。便应自恣。若遮自恣人。身口业清净。意业不清净。无智不分明。不知问不能答。余比丘语此比丘。止长老。不须起此斗诤事。莫用此比丘语。便应自恣。若遮自恣人。身口意业清净。有智分明。能问能答。余比丘语此比丘言。汝以何事故。遮此比丘自恣耶。为以犯戒故遮。破见故遮。破威仪故遮耶。若答言。以犯戒故遮。应问犯何等戒。若言犯波罗夷。若僧残偷兰遮。是谓犯戒。若言不以破戒故遮以破见故遮。应问云何破见。若言六十二见诸邪见。是谓破见。若言不以破见以破威仪故遮应问云何破威仪。若言犯波逸提波罗提提舍尼突吉罗恶说。是谓破威仪。复应更问。以何事故遮他自恣耶。为以见故闻故疑故耶。若言见故。应问见何事云何见。汝何因故见。彼比丘复以何因缘使汝见耶。汝在何处住。彼复在何处住。见何事为犯波罗夷。为僧残为波逸提。为波罗提提舍尼偷兰遮突吉罗恶说耶。若言不见以闻故。应问闻何事。云何闻。从谁闻。为从比丘闻。比丘尼优婆塞优婆夷闻耶。闻犯何事。为波罗夷为僧残。乃至恶说耶。若言不闻以疑故。应问疑何事。云何疑。从谁闻而生疑。为比丘比丘尼优婆塞优婆夷闻耶。疑何事。为疑波罗夷僧残乃至恶说耶。若遮自恣人。不能答有智人。若以波罗夷遮。应与僧残罪。然后僧自恣。若以僧残罪遮。应与波逸提罪。然后僧自恣。若以波逸提罪遮。应与余罪然后僧自恣。若以余事遮。应如法治然后僧自恣。若遮自恣人。能答有智人。若以波罗夷遮。应灭摈已然后僧自恣。若以僧残遮。应与波利婆沙。若本日治若摩那埵若出罪与已应自恣。若以波逸提遮。忏悔已应自恣。若以余事遮。应如法治。然后自恣。尔时自恣日。有住处。病比丘遮病比丘自恣。彼不知云何。即告诸比丘。诸比丘往白佛。佛言。若有住处。自恣日。病比丘遮病比丘自恣。彼比丘语此比丘言。佛如是语。今日病比丘不应遮。须待此病差长老应如法说。彼亦当如法说。如是作已然后自恣。尔时有住处。自恣日。病比丘遮无病比丘自恣。彼比丘语此比丘言。长老。佛如是语。须待病差。应如法说。彼亦当如法说。如是作已然后自恣。尔时有住处。自恣日。有无病比丘。遮病比丘自恣。彼比丘语此比丘言。佛如是语。须待病差。长老应如法说。彼亦当如法说。如是作已然后自恣。尔时有异住处。众多比丘结安居精勤行道得增上果证。彼作如是念。我曹若今日自恣者。便当移住余处。恐不得如是乐。我曹当云何。即告诸比丘。诸比丘往白佛。佛言。若有住处。众多比丘结安居精勤行道得增上果证。诸比丘作如是念。我曹若今日自恣。便当移住余处。恐不得如是乐。彼比丘即应作白增益自恣。作如是白。大德僧听。若僧时到僧忍听。僧今日不自恣。四月满当自恣白如是。应作如是白四月自恣。尔时有异住处众多比丘共住。自恣日诸比丘闻彼住处比丘斗诤不和合。欲来此自恣。我曹当云何。即告诸比丘。诸比丘往白佛。佛言。若有住处众多比丘共住。自恣日闻异住处比丘斗诤不和合欲来此自恣。彼比丘应若二若三减日自恣。若十五日自恣。减作十四日。若十四日自恣。减作十三日。若闻今日来。便应集僧疾疾自恣。若闻已至界内。便应出外自恣。若闻已入寺内。应为具洗浴器应具浴床浴瓶具刮垢刀水器泥器澡豆药草白上座然火。请僧入浴室。旧比丘。应密从浴室一一出至界外自恣。若客比丘唤自恣。应答言。我曹已自恣竟。若旧比丘自恣竟。客比丘遮自恣不得遮客比丘自恣时旧比丘遮得遮。若能如是方便得作者善。若不能者。彼比丘应作白增上自恣。作如是白大德僧听。若僧时到僧忍听。僧今日不自恣。至黑月十五日当自恣。白如是。应作如是白增上自恣。若客比丘住至黑月十五日。旧比丘应作白第二增上自恣。作如是白。大德僧听。若僧时到僧忍听。僧今日不自恣。后白月十五日当自恣。如是白。应作如是白第二增上自恣。若客比丘不去。旧比丘应如法如律强和合自恣。尔时自恣日。有住处。自恣时不识罪不识人。自恣竟识罪识人。彼作如是念。我曹当云何。即告诸比丘。诸比丘往白佛。佛言。有住处。自恣时不识罪不识人。自恣竟识罪识人。若自恣竟。不应以前听举他罪。尔时有住处。自恣时不识罪识人。自恣竟识罪识人。若自恣竟。不应以前听举他罪。尔时有异住处。自恣时有识罪不识人。自恣竟识罪识人。若自恣竟。不应以前听举他罪。尔时有异住处。自恣日。有客比丘来十四日。旧比丘十五日。诸比丘不知云何。即告诸比丘。诸比丘白佛。佛言。若有住处。自恣日。有客比丘来少。客比丘十四日。旧比丘十五日。客比丘应从旧比丘。若不从应如法治。若有住处。自恣时。有客比丘来。与旧比丘等客比丘十四日。旧比丘十五日。客比丘等。应从旧比丘。若不从应如法治。若自恣时。有住处客比丘来多。客比丘十四日。旧比丘十五日。旧比丘少。应从客比丘求和合。若彼与和合者善若不与者。旧比丘应出界外自恣。若自恣日。有异住处客比丘来少。客比丘十五日。旧比丘十四日。客比丘少。应从旧比丘求和合。若与和合者善。若不与客比丘应出界外自恣。若自恣日。有异住处客比丘来。此旧比丘等。客比丘十五日。旧比丘十四日。客比丘等。应从旧比丘求和合。若与和合者善。若不与客比丘应出界外自恣。若自恣日。有异住处。客比丘来多。客比丘十五日。旧比丘十四日。旧比丘少。应从客比丘。若不从如法治。十五日十六日亦如是。尔时自恣日。有住处。旧比丘集欲自恣。自恣时。客比丘来。彼比丘作如是念。我曹当云何。即告诸比丘。诸比丘白佛。佛言。若自恣日。有住处。旧比丘集欲自恣。自恣时。客比丘来少。客比丘上座。随上座次自恣。下座随下座次自恣若说自恣竟。举众未起。若多未起。若都已起。若客比丘来少应与清净。若不与如法治。尔时自恣日。旧比丘欲自恣。客比丘来等。旧比丘应更自恣。若不自恣如法治。自恣竟。若举众未起。若多未起。若都已起。客比丘来等。旧比丘应更自恣。若不者如法治。尔时自恣日。有住处。旧比丘欲自恣。有客比丘来多。旧比丘应更自恣。若不自恣应如法治。若自恣竟。举众未起。若多未起。若都已起。客比丘来多。旧比丘应更自恣。若不者如法治。尔时有住处。自恣日。客比丘坐欲自恣。旧比丘来少。旧比丘上座。随上座自恣处自恣。下座随下座处自恣。若自恣竟。举众未起。若多未起若都已起。旧比丘来少。应说清净自恣。若不说者如法治。尔时有住处。自恣日。客比丘坐欲自恣。旧比丘来等。客比丘应更自恣。若不如法治。若自恣竟。举众未起。若多未起。若都已起。旧比丘来等。客比丘应更自恣。若不如法治。尔时有住处。自恣日。客比丘坐欲自恣。旧比丘来多。客比丘应更自恣。若不自恣如法治。若自恣竟。举众未起。若多不起。若都已起。旧比丘来多。客比丘应更自恣。若不如法治。旧比丘旧比丘来亦如是。客比丘客比丘来亦如是。尔时有住处。自恣日。客比丘来。客比丘知旧比丘未来。我等若有五人若过五人。可作羯磨自恣。即作羯磨自恣。作羯磨自恣时。有旧比丘来。客比丘自念。我当云何。即告诸比丘。诸比丘白佛。佛言。若自恣日。有住处。客比丘来。客比丘知有旧比丘未来。我等若五人若过五人。可作羯磨自恣。彼比丘即作羯磨自恣。作羯磨自恣时。旧比丘来少。旧比丘上座随上座次自恣。若下座随下座次自恣。若自恣竟。举众未起。若多未起。若都已起。旧比丘来少。旧比丘应说清净自恣。若不说如法治。尔时有住处。自恣日。客比丘来。客比丘知旧比丘未来。我等若五人若过五人。可作羯磨自恣。即作羯磨自恣。作羯磨自恣时。旧比丘来等。客比丘应更自恣。若不如法治。作自恣竟。举众未起。若多未起。若都已起。旧比丘来等。客比丘应更自恣。若不如法治。尔时有住处。自恣日。客比丘来。客比丘知有旧比丘未来。我等若五人若过五人。可共羯磨自恣。即作羯磨自恣。作羯磨自恣时。有旧比丘来多。客比丘应更自恣。若不如法治若自恣竟。举众未起。若多未起。若都已起旧比丘来多客比丘应更自恣。若不如法治。尔时有住处。自恣日。旧比丘来。旧比丘知有客比丘未来。我等若五人若过五人。可作羯磨自恣。作羯磨自恣时。有客比丘来少。客比丘上座随上座自恣。下座随下座自恣。若自恣竟。举众未起。若多未起。若都已起。客比丘来少。应说清净自恣。若不说如法治。尔时有住处。自恣日。有旧比丘来。旧比丘知有客比丘未来。我等若五人若过五人。可作羯磨自恣。作羯磨自恣时。客比丘来等。旧比丘应更作自恣。若不如法治。自恣竟。若举众未起。若多未起。若都已起。旧比丘应更自恣。若不如法治。尔时有住处。自恣日。旧比丘来。旧比丘知有客比丘未来。我等若五人若过五人。可作羯磨自恣。作羯磨自恣时。客比丘来多。旧比丘应更自恣。若不如法治。若自恣竟。举众未起。若多未起。若都已起。客比丘来多。旧比丘应更自恣。若不如法治。客比丘客比丘来亦如是。旧比丘旧比丘来亦如是。或言应自恣。或言不应自恣。若不来者失去灭去。欲作种种方便。欲破坏他。便作羯磨自恣。彼若作羯磨。彼比丘不成羯磨。得偷兰遮。尔时自恣日。若客比丘来。见有旧比丘相敷绳床木床敷具毡褥枕具洗脚处。见有相不求觅。便作羯磨自恣。作羯磨自恣时。旧比丘来。客比丘自念。我当云何。即告诸比丘。诸比丘白佛。佛言。若自恣日。有客比丘来。见有旧比丘相敷绳床木床敷具毡褥枕具洗脚处。见有相不求觅。便作羯磨自恣。若作羯磨自恣。不成羯磨自恣有罪。见相便求。求而不得。即应唤。若不唤而作羯磨自恣。不成羯磨自恣有罪。见相便求。求而不得。求既不得。便言失去灭去作种种方便。欲使他破坏。便作羯磨自恣。彼比丘不成羯磨。得偷兰遮。见相便求。求而不得。不得便唤。唤已作羯磨自恣。彼比丘羯磨不成不犯罪。见相便求。求而得之。和合羯磨自恣。彼比丘成羯磨自恣。不得罪。见疑亦如是。尔时有住处。自恣日。旧比丘来见客比丘相。见衣钵座具针筒洗脚处。而不求觅。便作羯磨自恣。彼比丘不成羯磨自恣得罪。见相便求。求而不得。即应唤。若不唤而作羯磨自恣。不成羯磨自恣有罪。见相便求。求而不得。既求不得。便言失去灭去。种种方便欲使他破坏。便作羯磨自恣。彼比丘不成羯磨。得偷兰遮见相便求。求而不得。不得便唤。唤已作羯磨自恣。彼比丘不成羯磨不犯罪。见相便求。求而得之。和合羯磨自恣。彼比丘成羯磨自恣。不得罪。见疑亦如是。尔时自恣日。有住处。客比丘来。闻旧比丘声经行声謦欬声诵经声言论声。闻而不求。便作羯磨自恣。作羯磨自恣时。旧比丘来。彼不知云何。即告诸比丘。诸比丘白佛。佛言。若自恣日。有住处。客比丘来。闻旧比丘声经行声謦欬声诵经声言论声。闻而不求。便作羯磨自恣。不成羯磨自恣得罪。从闻而求。乃至和合自恣亦如是。闻疑亦如是。尔时有住处。自恣日。有旧比丘来。闻客比丘来声经行声謦欬声诵经声言论声抖擞衣声。闻而不求。便作羯磨自恣。彼比丘不成羯磨有罪。从闻而求。乃至和合自恣亦如是。闻疑亦如是。尔时有住处。自恣日有客比丘来。见旧比丘在戒场上。见而不求。诸比丘便作羯磨自恣。诸比丘不知云何即白佛。佛言。有住处。自恣日。有客比丘来。见旧比丘在戒场上。见而不求。诸比丘便作羯磨自恣。彼比丘成羯磨有罪。若见便求。求而不唤。便作羯磨自恣。彼比丘成羯磨自恣有罪。若见而求。求而唤作羯磨自恣。彼比丘不破羯磨无罪。见疑亦如是。尔时有住处。自恣日。有旧比丘来。见客比丘在戒场上。见而不求。诸比丘便作羯磨自恣。彼比丘成羯磨自恣有罪。若见便求。求而不唤。便作羯磨自恣。彼比丘成羯磨自恣有罪。若见而求。求而唤作羯磨自恣。彼比丘成羯磨无罪。见疑亦如是。客比丘闻旧比丘亦如是。闻疑亦如是。旧比丘闻客比丘亦如是。闻疑亦如是。尔时有住处。自恣日。有客比丘来。见有旧比丘在界内。见而不求。便作羯磨自恣。作羯磨自恣时。见有旧比丘来。不知云何。即告诸比丘。诸比丘白佛。佛言。若有住处。自恣日。有客比丘来。见有旧比丘在界内。见而不求。便作羯磨自恣。彼比丘不成羯磨有罪。见而求。求而不唤。便作羯磨自恣。彼比丘不成羯磨有罪。见便求。求已唤。和合作羯磨自恣。彼比丘成羯磨无罪。见疑亦如是。尔时有住处。自恣日。有旧比丘来。见客比丘在界内。见而不求。便作羯磨自恣。彼比丘不成羯磨自恣有罪。若见便求。求而不唤。便作羯磨自恣。彼比丘不成羯磨自恣有罪。若见而求。求而唤。和合作羯磨自恣。彼比丘成羯磨自恣无罪。见疑亦如是。客比丘闻旧比丘亦如是。闻疑亦如是。旧比丘闻客比丘亦如是。闻疑亦如是。时六群比丘作如是念。从有比丘有住处。至无比丘有住处。恐余比丘为我作羯磨若遮自恣。诸比丘即白佛。佛言。不应作如是意。从有比丘有住处。至无比丘有住处。恐余比丘为我作羯磨若遮自恣。彼比丘作如是念。从有比丘有住处。至无比丘无住处。恐余比丘为我作羯磨若遮自恣。佛言。不应作如是念。从有比丘有住处。至无比丘无住处。恐余比丘为我作羯磨若遮自恣。彼作如是念。从有比丘有住处。至无比丘有住处无住处。若往比丘戒场上。恐余比丘为我作羯磨若遮自恣。佛言。不应作如是意。从有比丘有住处。至无比丘有住处无住处。若往比丘戒场上。恐余比丘为我作羯磨若遮自恣。若无僧共去。无难事去者。得突吉罗。从有比丘无住处。至无比丘有住处亦如是。从有比丘无住处。至无比丘无住处亦如是。从有比丘无住处。至无比丘有住处无住处亦如是。从有比丘有住处无住处。至无比丘有住处亦如是。从有比丘有住处无住处。至无比丘无住处亦如是。从有比丘有住处无住处。至无比丘有住处无住处亦如是。若为亲友知识亦如是。尔时六群比丘尼作如是意。往寺内遮余比丘。莫为六群比丘作羯磨若遮自恣。诸比丘白佛。佛言。比丘尼不应作如是意。往寺内遮余比丘言。莫为六群比丘作羯磨若遮自恣。不应在比丘尼前作羯磨若遮自恣。时诸比丘尼。遣式叉摩那沙弥尼至寺内遮余比丘。莫为六群比丘作羯磨若遮自恣。诸比丘白佛。佛言。比丘尼不应遣式叉摩那沙弥尼至寺内遮余比丘。莫为六群比丘作羯磨若遮自恣。不应在式叉摩那沙弥尼前作羯磨若遮自恣。彼诸比丘尼。复遣白衣知识往寺内遮余比丘。莫为六群比丘作羯磨若遮自恣。诸比丘白佛。佛言。比丘尼不应作如是念。遣白衣知识往寺内遮余比丘。莫为六群比丘作羯磨若遮自恣。不应在白衣前作羯磨若遮自恣。尔时王波斯匿。遣兵卫护众僧。诸比丘语众兵人言。小却我曹欲作羯磨自恣。彼人言。王遣我等卫护众僧。今不敢往余处。诸比丘白佛。佛言。应更语使避余处去。若去者善。若不去自应去。至不见不闻处。作羯磨自恣。不应在未受大戒人前作羯磨自恣。时诸天龙夜叉来听自恣。有天眼比丘见。见已生畏慎心。佛不听我曹在未受大戒人前自恣。即白佛。佛言。除人未受大戒。余者听在前羯磨自恣。彼自恣竟说戒坐久疲极诸比丘白佛。佛言。不应自恣竟复说戒。自恣即是说戒。佛说如是(自恣揵度竟)

    皮革揵度

尔时世尊在王舍城。时瞻婆城有大长者子。字守笼那。其父母唯有此一子。甚爱念之。生来习乐。未曾蹑地而行。足下生毛。时摩竭国王。闻瞻婆城中大长者有子。父母甚爱念之。生来习乐。未曾蹑地而行。足下生毛。迟欲见之。即敕瞻婆城主。使诸长者各将其儿来至我所。时瞻婆城主。即各将其儿诣摩竭王所。到已头面礼王足在一面住。即白王言。王欲见瞻婆城中大长者子。此子生来习乐。父母爱之。未曾蹑地而行。足下生毛。愿王听以衣敷地。王言。听以衣敷地。时长者子守笼那。即以衣敷地。诣王所头面作礼。王见足下生毛。心甚欢喜。王即与现世利益已语言。我已与汝现世利益。世尊在王舍城耆阇崛山中。汝可往见礼拜问讯。当与汝后世利益。时瞻婆城主。及诸长者。闻王语已。共诣耆阇崛山。时有长老娑竭陀。为佛给使。在异处磐石上坐。时瞻婆城主。诣长老娑竭陀所问言。今世尊在何处。我等欲见如来。娑竭陀言小待长者。须我白佛。尔时长老娑竭陀。即没石上。如力士屈申臂顷。从彼来踊出佛前白言。瞻婆长者欲见世尊。佛告言。汝往屋荫中敷座。我当往坐。时娑竭陀。即受教敷座已。还到佛所。头面礼足在一面住。白世尊言。我已敷座竟。今正是时。尔时世尊。从屋中出坐已。告娑竭陀言。语瞻婆长者来。时长老娑竭陀。没于佛前。如力士屈申臂顷。踊出于石上。时诸长者。见叹未曾有。世尊。弟子神足犹尔况复如来。娑竭陀言。长者宜知。是时瞻婆城主来诣佛所。头面作礼却坐一面。世尊。尔时即为诸长者子及瞻婆城主。种种方便说法劝化。令大欢喜。布施持戒生天之法。即于座上得法眼净。见法得法得果证。不复回还。白世尊言。大德。从今已去。归依佛法僧。听为优婆塞。从今已去。不杀生乃至不饮酒。尔时长者子守笼那在会中坐。作是念言。我闻佛所说。若我在家与妻子俱。不得修清净行。我今宁可从佛求除须发舍家为道意欲令众罢散。尔时瞻婆城主。闻佛种种方便说法。心大欢喜。即从坐起。作礼绕佛而去。长者子守笼那。还诣佛所。头面作礼却住一面。即白世尊言。如我闻佛所说。若我在家与妻子俱。不得修清净行。今欲从世尊求除须发舍家为道佛问守笼那。汝父母听汝不。答言世尊。父母未听。佛言。若父母不听。如来不听出家。答言。我今当作方便令父母听。佛言。今正是时。时守笼那。还瞻婆城。至父母所白言。如我闻佛所说。若我在家与妻子俱。不得修清净行。今欲于佛所求除须发舍家为道。愿父母听。父母答言。出家之法甚难。为沙门亦不易。不如在家乐于爱欲自恣作福。不须出家。时守笼那。闻父母如是语。犹故不息。乃至第二第三亦如是。守笼那如是三白父母。犹故不听。时守笼那。即从坐起而坐地。作如是言。从今已去。止不洗浴。香不涂身。不饮不食。若或当死。若或得出家。一日不食乃至五日。时守笼那诸亲里知识。闻守笼那欲从佛求除须发欲出家为道。父母不听一日不食乃至五日。时守笼那诸亲里知识。往守笼那所语言。可起守笼那。洗浴身体以香涂身。饮食自乐恣作福德。出家不易沙门亦难。且止不须出家。守笼那闻诸亲里知识如是语。犹故不止第二。第三亦如是亲友亦如是。尔时守笼那伴等。诣守笼那父母所。作如是言。可听守笼那舍家为道。若乐出家有常相见。若不乐出家便当还此守笼那。若死当复云何。父母即言。随意出家。时守笼那。闻父母听许。心自念言。我今羸瘦如是。不堪一食。可小自将养。时守笼那少多有力。往父母所白言。我今出家去。父母言。今正是时。时守笼那。即往王舍城耆阇崛山。到世尊所头面作礼在一面住。白言。父母已听。我出家为道。愿佛度我得受大戒。佛即听出家受大戒。尔时守笼那父母。于两城中间七处安驿。为守笼那送热食及时令到。时守笼那。以此食与上座已。自入城乞食。其父母闻守笼那以所送食与诸比丘自乞食。从今已去。止不复与送食。尔时守笼那。往温水河边尸陀林中住。勤行精进。经行之处血流污地。如屠杀处。时守笼那。在静处思惟。心自念言。我今勤行精进。如佛弟子中无有胜我者。我今何故不得无漏解脱。我家中大有财宝。可自娱乐自恣作福。今宁可舍戒还家。不复为道。尔时世尊知其心念。譬如力士屈申臂顷。从耆阇崛山至尸陀林中往经行处。见血污地如屠杀处。世尊知而故问余比丘。此谁经行处。血污地如屠杀处。诸比丘白佛言。是守笼那比丘勤行精进。是其血污地。佛言。唤来。比丘受教。往守笼那所语言。世尊唤汝。守笼那闻佛唤。即往佛所礼佛足却坐一面。佛知而故问。汝于屏处作如是念。我勤行精进。如佛弟子中无胜我者。我今何故不得无漏解脱。我家中大有财宝。可自娱乐自恣作福。今宁可舍戒还家。不复为道耶。实尔世尊。世尊言。我今问汝。随意答我。汝在家时。能弹琴不。如是世尊。在家实能弹琴。守笼那云何琴。弦若急音声好不。不也世尊。守笼那云何琴弦若缓音声好不。不也世尊。云何守笼那。琴弦不缓不急。音声好不。如是世尊。佛言。如是守笼那。若大勤精进掉动。若少精进懈怠。应等精进等于诸根。尔时守笼那。闻佛略说教诫已。独在静处勤修精进心不放逸初夜后夜警意修行助道之法。所为出家得果不久。无上净行现世得证。我生已尽。梵行已立。所作已办。不复受身。知守笼那比丘得阿罗汉道。时守笼那比丘。得阿罗汉道已。往佛所头面礼足在一面住白佛言。若有比丘。得阿罗汉。尽诸有漏乐于六处。乐于出离。乐不嗔恚。乐于寂静。乐尽爱欲。乐尽受阴。乐于无痴。若有比丘。得罗汉漏尽。乐此六处。世尊。颇有不依于信得出离不。不应作如是意。不依于信。得罗汉道。尽于有漏。尽欲无欲。尽恚无恚尽痴无痴。乐于出离。世尊。颇有不依持戒故得乐无恚不。不应作如是意。不依持戒。得罗汉道。尽于有漏。尽爱无爱。尽恚无恚。尽痴无痴。乐于无恚。世尊。颇有不断诸利养乐寂静不。不应作如是意。不断利养。得罗汉道。尽恚无恚。尽痴无痴。乐于寂静。彼尽欲无欲。尽恚无恚。尽痴无痴。爱尽受阴尽。乐于无痴。如是比丘。心解脱有漏眼见多色。慧解脱心解脱。二俱不染污识。不与色杂住第四禅。耳鼻舌身意亦如是。世尊。由如大石山全为一叚不缺无孔不漏。若东方有大疾风雨来。此山不移不可倾动。南西北方亦复如是。如是世尊。若比丘得阿罗汉道。心得解脱尽于有漏。眼见多色。慧解脱心解脱。二俱不染污识。不与色杂住第四禅。耳鼻舌身意亦如是。说是语已。重说偈言

  乐出离者　　乐寂比丘　　乐不嗔恚
  及尽爱者　　乐尽受阴　　心不愚痴
  审知不起　　从是解脱　　以正解脱
  便为息灭　　已得无观　　更无有作
  譬如大山　　风不能坏　　如是色声
  香味触法　　于善恶法　　智者不动
  心住解脱　　见于灭尽

如是守笼那。说此偈已。佛即可之。从坐起前礼佛足而去。去未久。佛告诸比丘言。应作如是自记得道。但说其义不正言。得不如余愚痴比丘欢喜自记后无所得空自疲苦。尔时守笼那。于异时往佛所。头面礼足却住一面。佛告守笼那。汝生来习乐不串涉苦。听汝于寺内着一重革屣。即白佛言。我舍五象王出家为道。或致人笑言。守笼那舍五象王出家为道贪一重革屣。若世尊听诸比丘畜者。我亦当畜。佛时默然可之。即以是因缘集比丘僧。为诸比丘随顺说法。无数方便称赞行头陀少欲知足乐出离者。告诸比丘。为护身护衣护卧具故。听在寺内着一重革屣。时诸比丘着一重革屣。不久便穿坏。听以树皮若皮补之。当以缕缝。若断坏应以筋若毛若皮缕缝。彼时须锥。比丘白佛。佛言听畜锥

四分律卷第三十八四分律卷第三十九(三分之三)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    皮革揵度之余

尔时大迦旃延。在阿槃提国。在拘留欢喜山曲中住。与亿耳优婆塞使人俱。时亿耳心自念言。如我闻佛所说。若我在家与妻子俱。不得修清净行。宁可除须发。舍家为道。即往大迦旃延所。作如是言。如我闻佛所说。若我在家与妻子俱。不得修清净行。愿大德度我出家受大戒迦旃延言。出家事难沙门不易。汝但在家护持佛戒。当以时节修行佛教。尔时亿耳如是再三白迦旃延。时大迦旃延。见亿耳殷勤至三。便听出家。受戒难得三年乃受大戒。何以故。以不满十僧故。亿耳受戒未久便得阿罗汉道。自记得道。亦如上说。尔时亿耳。闻佛功德相好端正诸根寂静得上调伏犹如象王又如澄渊。闻之欢喜。便欲见佛。诣迦旃延所白言我闻佛功德如是。今欲往见如来无所著等正觉。迦旃延言。佛功德如汝所说。迦旃延言。汝持我名诣佛所。头面礼足。问讯起居少病安乐。不持五事往白佛。阿湿婆阿槃提国。少比丘受大戒难。三年中乃得受戒。何以故。以不满十僧故。从今已去。愿世尊。少开方便。听阿湿婆阿槃提国得受大戒。阿湿婆阿槃提国多诸刺棘瓦石。一重革屣不得经久。愿世尊。听着重革屣。阿湿婆阿槃提国世人好浴。愿世尊。听比丘数数洗浴如余方多好卧具。伊梨延陀耄罗耄耄罗[毯-炎+瞿]氀如是。阿湿婆阿槃提国以皮为卧具。羖羊皮白羊皮鹿皮。愿世尊听得畜皮卧具。或有比丘。往异方后住处得衣便不肯受。何以故。恐犯尼萨耆愿世尊。听开少方便。时亿耳比丘。闻大迦旃延语。默然受持即从坐起头面礼足绕已而去。亿耳闻世尊在王舍城耆阇崛山住。时亿耳持三衣钵。往到佛所头面礼足已却住一面。佛即慰劳言。住止安乐不。不以饮食为苦耶。白佛言。住止安乐。不以饮食为苦。佛敕阿难。与客比丘敷座。尔时阿难自知常法世尊欲与客比丘共宿。便使阿难敷座。时阿难闻佛语已。还佛屋内对佛座敷座。敷座已还头面礼足却住一面。白世尊言。已为客比丘敷座竟宜知是时。尔时世尊即起还屋就座而坐。亿耳亦入佛屋对佛而坐。尔时世尊。静坐须臾告亿耳言。汝可说法。亿耳闻佛教已。在佛前说十六句义。不增不减音声清好。章句次第了了可解。尔时世尊作是念。善哉比丘。十六句义。不增不减不坏经法。音声清好。章句次第了了可解。佛问亿耳。本何所作。答言。久见欲过难得受戒乃经三年。何以故。以不满十僧故。亿耳念言。今正是时。和尚迦旃延所遣五事。即白佛言和尚迦旃延稽首世尊足下。问讯世尊起居。康强少病安乐。白此五事如前所说。佛时默然听许。时世尊。明日清旦。以此事集比丘僧。为诸比丘随顺说法。无数方便称赞头陀威仪齐整少欲知足乐处空闲。告诸比丘言。听阿湿婆阿槃提国持律五人得受大戒。若有余方亦听。余方者。东方有国。名白木调国。已外便听。南方有塔。名静善塔。已外便听。西方有国山名一师梨仙人种山。方外便听。北方有国名柱方外便听如是诸方外。听持律五人得受大戒。听阿湿婆阿槃提国着重革屣。听阿湿婆阿槃提国数数洗浴。听敷羖羊皮白羊皮鹿皮卧具。听诸比丘得衣入手数满十日若过应舍。舍已忏悔。尔时比丘得皮补革屣去佛不远。便摘坏恐犯重革屣事。尔时世尊知而故问比丘。汝何故摘坏革屣耶。答言。恐犯重革屣事。佛言。革屣若穿坏听重。时诸比丘得未治皮。佛言听鞣治。若自鞣若使人鞣。鞣皮竟。裁作一重革屣。须刀佛言。听畜刀。须裁板。佛言。听畜板。须筋若毛若皮缕等。佛言听畜须刬。佛言听畜若刀钝。听畜磨石。时诸比丘刀锥筋毛皮缕刬迸散在地无安处。佛言。听作囊盛。若织竹作笼。若树皮笼。听以毛囊。裹外十种衣中。听趣用一一衣作囊。时诸比丘用皮作。佛言。不听以皮作时诸比丘着新衣革屣上坐污衣。佛言。不应着新衣革屣上坐。比丘亦不应皮上坐。除阿湿婆阿槃提国。时诸比丘持革屣在前便睡狗衔去。佛言。不应持革屣在前而睡。应以草覆。若两底相合。置尼师坛下。尔时比丘。持革屣置边而睡。转反堕革屣上。有畏慎心。恐犯眠皮上。佛言不犯。时比丘持革屣置钵中行。余比丘见甚恶之。佛言。不应以革屣置钵中。应清净持钵。时比丘一手捉革屣钵。余比丘见恶之。佛言。不听一手捉革屣钵。应一手捉钵一手捉革屣。时诸比丘渡泥水不得褰衣。衣堕泥水中。佛言。听指钩革屣钵置掌中。一手褰衣。时诸比丘。拘萨罗国人间游行。到无比丘住处村。宿陶师舍。时泥作边有皮。比丘在上眠。清旦见畏犯皮上眠。佛言不犯。时六群比丘。畜大皮师子皮虎皮豹皮獭皮野猫皮迦罗皮野狐皮。诸比丘白佛。佛言。一切大皮不得畜。时六群比丘坐高大床上。若独坐绳床木床象牙床敷马皮敷象皮锦褥杂色卧具[毯-炎+瞿]氀若獭毛用贮褥。诸比丘白佛。佛言。不应高大床上坐乃至獭毛贮褥。时诸比丘。到白衣舍。为比丘敷好高大床。请比丘坐。诸比丘言。佛不听我等坐高大床。诸白衣言。我等更何处得床。诸比丘白佛。佛言。听除宝床余者在白衣舍应坐。时诸比丘。至白衣舍。为比丘敷皮床独坐床。诸比丘畏慎不敢坐。念言。佛不听我等皮上坐。除阿湿婆阿槃提国。诸白衣言。我等更何处得床。诸比丘白佛。佛言。听在白衣舍内坐。时诸比丘至白衣舍。为敷长绳床木床。诸比丘畏慎不敢坐。佛不听我等与上座同床坐。诸白衣言。我等更何处得人人别床。诸比丘白佛。佛言。听白衣舍得坐。时诸比丘至白衣舍。白衣为敷皮囊。比丘有畏慎心。念言。佛不听我等坐皮上。诸白衣言。我等更何处得别坐。诸比丘白佛。佛言。听在白衣舍得坐。尔时跋难陀释子。有放牛人为作檀越。清旦着衣至檀越舍敷座而坐。时牧牛儿来坐听法。跋难陀释子。善为说法。种种方便劝进檀越。令大欢喜。即问言。大德何所须欲。跋难陀言。可止无所须。便为得供养已。复言。愿说所须。跋难陀言。止不须语。若我说俱不与我。答言大德。但说当与。去前不远。见一杂色犊子。跋难陀言。我须此皮。答言。小待须我杀之。彼即杀之。剥皮与跋难陀。跋难陀得皮已。从坐起持去。时牛母大吼唤。逐跋难陀至只桓门。诸比丘见问言。此牛何故吼唤逐汝后。答言。此是其子皮。我持来故尔耳。诸比丘白佛。佛言。不应乞生皮。若乞如法治。诸比丘畏慎。不敢带浮囊渡水。佛言听。时诸比丘捉牛尾渡水。渡已方见是牸牛畏慎。佛言无犯。自今已去。不应捉牸牛尾渡水。时诸比丘不敢坐皮床上渡水。佛言听。时诸比丘畏慎不敢乘皮船渡水。佛言听。在皮船上若坐若卧随意。时诸比丘。皮作刀囊不以物裹刀生坏。佛言听。若以毳若以劫贝若以大皮裹刀。时比丘畜两重革屣。佛言。不得畜两重革屣。时诸比丘畜迦那富罗革屣。佛言。不听畜迦那富罗革屣。尔时比丘。与白衣拘萨罗国道路共行。为木刺刺脚血大出甚患之不能行。时白衣即以所著革屣与比丘。时比丘畏慎不敢取。恐犯迦那富罗革屣。佛言。有如是因缘听受。时六群比丘。畜旋角革屣。佛言。不应畜旋角革屣。诸比丘畜鹿角革屣。佛言。不应畜。诸比丘畜阿罗梨革屣。佛言。不应畜。六群比丘以杂色皮作革屣带。佛言不应畜。六群比丘持绢布作革屣带。佛言不应畜。六群比丘。畜富罗跋陀罗革屣。佛言不应畜。六群比丘着真誓梨革屣。佛言不应畜。六群比丘着编边革屣。佛言不应畜。六群比丘着多带革屣。佛言不应畜。六群比丘着卷形革屣。佛言不应畜。六群比丘着大皮革屣师子皮虎皮豹皮獭皮野猫皮杂色皮野狐皮。佛言。一切不得畜。六群比丘用大皮缘革屣。或用作带或用缝。佛言。不得用缘及带缝。时六群比丘。着青色革屣。佛言不应畜。六群比丘以青缘革屣或用作带缝。佛言。不应以青缘革屣及作带缝。六群比丘着黄革屣。佛言不应畜。六群比丘着黄缘革屣。若作带若缝。佛言。不应用黄缘革屣及带缝。六群比丘着赤革屣。佛言。不应着赤革屣。缘带缝亦如是。六群比丘着白革屣。佛言不应着白革屣。缘带缝亦如是。六群比丘着似孔雀毛革屣。佛言不应畜。六群比丘着锦色革屣。佛言不应畜。彼比丘得成锦色革屣。佛言不应畜。若坏色者听畜。六群比丘着毳[袖-由+宁]革屣。佛言不应畜。六群比丘着劫贝纻革屣。佛言不应畜。六群比丘以弊帛纻革屣。佛言不应畜。六群比丘。以芒草婆娑草舍罗草汉陀罗草[袖-由+宁]革屣。佛言不应畜。六群比丘痴人。是我所遮。便更作余事。自今已去。一切[袖-由+宁]革屣不应畜。时比丘天雨泥污脚污坐具污身卧具。佛言。听护身护座具故在僧伽蓝内着蒲革屣洗足。既着蒲革屣洗足已。水入蒲革屣内。污脚污座具污身污卧具。佛言。听以树皮若皮缝着底。尔时舍卫国六群比丘。着钦婆罗屐。佛言不应畜。如是四种草屐不得畜。尔时佛在王舍城。六群比丘。剥多罗树叶作屐树便枯干。诸居士见皆共讥嫌。沙门释子无有惭愧。断绝生命。自言我知正法。如是观之何有正法。云何乃取多罗树叶作屐。使树枯干。比丘白佛。佛言不应畜。尔时世尊。在拘睒弥国。时六群比丘着木屐。犹如马行声乱诸坐禅者。诸比丘白佛。佛言。不应畜木屐。时诸比丘畏慎。不敢上大小便屐上。不敢着洗足屐。佛言。除可着行者。余者应上。尔时世尊在婆竭提国。时毗舍离跋阇子比丘。着金屐银屐。佛言不应畜。即复着琉璃屐。佛言不应畜。复着宝屐。佛言。不应畜。复着宝填屐。佛言不应畜。佛言。如是痴人。是我所遮。辄更作余事。自今已去。一切屐不得着

尔时世尊在毗舍离国。六群比丘着革屐共佛经行。佛告诸比丘。外诸巧师受学弟子。亦有恭敬于师。此六群比丘痴人。着革屣与佛共经行。佛言。自今已去。一切革屐不得畜。时六群比丘。于和尚和尚等。阿阇梨阿阇梨等前。已在好经行处。和尚等在恶处。已在高处。和尚等在下处。已在前和尚等在后。与和尚等并语与并经行。反抄衣缠颈裹头。通肩披衣着革屣。诸比丘白佛。佛言。不应和尚和尚等若阿阇梨阿阇梨等在恶经行处。已在好处乃至着革屣。一切不得。尔时六群比丘。于和尚和尚等阿阇梨阿阇梨等前。通肩披衣着革屣。若有所取与。不露右肩不脱革屣。诸比丘白佛。佛言不应尔。佛言。自今已去。听在和尚和尚等阿阇梨阿阇梨等前偏露右肩脱革屣有所取与。时诸比丘。在白衣舍。于和尚和尚等阿阇梨阿阇梨等前。有所取与。偏露右肩脱革屣时形露。诸比丘白佛。佛言。听白衣舍在和尚和尚等阿阇梨阿阇梨等前不露右肩不脱革屣随意有所取与。尔时比丘。共余比丘在道行。一比丘从余比丘索水。诸比丘作是念。佛不听着革屣有所取与。彼比丘即脱革屣取水。于是失革屣。诸比丘白佛。佛言听。若在道行着革屣随意有所取与。尔时有比丘。暮从比丘索水。彼作是念。佛不听着革屣有所取与。时彼住处去水远畏毒虫。时彼比丘。脱革屣往取水毒虫啮脚痛苦不乐。诸比丘白佛。佛言。若日入后。听去水远若畏毒虫得着革屣随意取与。时六群比丘。见和尚和尚等阿阇梨阿阇梨等不起迎。诸比丘白佛。佛言应起。若一坐食。若作余食法不食。若病。听作如是语。大德忍。我有因缘故不起。和尚者。从受得戒。和尚等者。多已十岁。阿阇梨者。有五种阿阇梨。有出家阿阇梨。受戒阿阇梨。教授阿阇梨。受经阿阇梨。依止阿阇梨。出家阿阇梨者。所依得出家者是。受戒阿阇梨者。受戒时作羯磨者是。教授阿阇梨者。教授威仪者是。受经阿阇梨者。所从受经处读修妒路。若说义乃至一四句偈依止阿阇梨者。乃至依止住一宿。阿阇梨等者。多已五岁。除依止阿阇梨。若比丘所住房应扫洒。扫洒已若故有尘。听泥浆污洒。泥浆污洒已。若故有尘。听作地敷。若伊梨延陀耄罗耄耄罗[毯-炎+瞿]氀。若十种衣随所得敷之。时诸比丘不洗足上地敷。佛言。听在户边安拭足物。若故不净。应户外安水器洗足。比丘洗足已。足未干便上地敷。地敷烂坏。佛言。足未干不得上地敷。若有急事。应以足拭膝若拭[跳-兆+專]若以手拭若以弊物拭。时诸比丘。为和尚和尚等阿阇梨阿阇梨等。有所取与。数数洗足疲劳。诸比丘白佛。佛言。自今已去。若为和尚和尚等阿阇梨阿阇梨等有所取与。听用铜盘若案若机饮食所须之物。尽持置上一时授与。时有比丘。足下恶肿。于天雨中。余比丘扶往厕上。卧泥中极患苦。诸比丘白佛。佛言。听为护身护衣护卧具故。僧伽蓝内听着一重革屣。时诸比丘。在道行为和尚和尚等阿阇梨阿阇梨等有所取与。偏露右肩脱革屣疲极。诸比丘白佛。佛言。听若在道行为和尚和尚等阿阇梨阿阇梨等有所取与。即于头上若肩上取与

尔时佛在舍卫国。时六群比丘。着革屣入聚落。时诸居士见皆共讥嫌。沙门释子自言。我知正法。云何着革屣入聚落。如今观之有何正法。如似国王大臣。诸比丘白佛。佛言。不应着革屣入聚落。时诸病比丘有畏慎心。不敢着革屣入聚落。诸比丘白佛。佛言。听病比丘着革屣入聚落。时六群比丘。托病着革屣入聚落。余比丘见语言。佛不言不得着革屣入聚落耶。彼言我病。即问言。何所患苦。答言长老。佛不作如是说。若人言。须臾间不乐。是谓病人耶我等托病。诸比丘白佛。佛言。不应托病着革屣入聚落。尔时长老毕陵伽婆蹉。脚跟破须鞔跟革屣。诸比丘白佛。佛言。听着鞔跟革屣。尔时长老毕陵伽婆蹉。在道行。眼闇。脚指蹴地坏足。诸比丘白佛。佛言。听着鞔足指革屣。尔时毕陵伽婆蹉。多知识在道行。大得大麦小麦斑豆粳米。诸比丘疑不敢受白佛。佛言听受。诸比丘受已不知置何处。白佛。佛言。听若囊若箱盛。尔时长老毕陵伽婆蹉。在道行得酥油蜜石蜜不敢受。诸比丘白佛。佛言听受。受已不知着何处白佛。佛言。听若以键瓷小钵次钵受。键瓷者入小钵。小钵者入次钵。次钵者入大钵。诸比丘。不知畜键瓷小钵次钵。当净施不。白佛。佛言。听不作净施畜。时长老毕陵伽婆蹉。老羸不堪步涉白佛。佛言。听作步挽车若舆若乘。除女人牸牛马。尔时毕陵伽婆蹉。在道行得辇不敢受白佛。佛言听受。得皮辇不敢受白佛。佛言。听取却皮。十种衣中随以一衣裹之。复得织皮辇不敢受白佛。佛言。听却皮绳发绳以余绳织应畜。诸比丘须辇辕白佛。佛言听作。诸比丘须辇绳白佛。佛言听畜。若绳数断。听用皮作。若担辇肩痛。听安枕荐。若患脚寄痛。听作橙安枕荐。时不知何人应担白佛。佛言。听比丘若僧伽蓝民若优婆塞若沙弥。若得车亦如是。若皮车应却皮。十种衣中随以一衣裹之应畜。若得织皮车。除皮绳发绳余得畜。不知何人应牵白佛。佛言。听若比丘若僧伽蓝民若优婆塞若沙弥牵。尔时长老毕陵伽婆蹉。得守僧伽蓝人。佛言应畜。尔时六群比丘。作皮床皮独坐床。诸比丘白佛。佛言不应畜。复作皮褥皮枕皮卧具皮地敷。破地生虫屋内臭秽。诸比丘白佛。佛言不应畜。时有婆罗门出家为道。持伊师皮作拭足物置户内。佛言听畜。时诸比丘。汲水罐绳数断。佛言。听以皮作索。若罐破听以皮作。若绳断以皮作绳。若户绳数断。佛言。听以皮作。若开户若闭户患手痛。听以大皮裹之。若户枢不转。应着皮。若上枢坏。听以皮縺。若向亦如是。若绳床木床脚坏。听以皮縺。时有比丘脚痛。佛言。以大皮裹脚令得患差便却。若比丘覆屋绳断。佛言。听以皮作。若户扂绳数断。听以筋若毛作。时六群比丘。畜皮钵囊革屣囊针綖囊。诸比丘白佛。佛言不应畜。尔时有木师出家比丘。畜皮囊盛作器白佛。佛言不应畜。木师出家比丘。一切作器不应畜。尔时众僧。得木作器白佛。佛言听畜。不知用何物盛。佛言。听十种衣随以一一衣作囊盛。尔时比丘酥油瓶露。佛言。听以湿皮覆。若虫啮应以泥泥。尔时比丘。得花形皮油器。畏慎不敢畜。佛言听畜。尔时比丘。得角作油器。畏慎不敢畜。佛言听畜。若下漏上漏若边漏听以皮缠覆

尔时世尊。在王舍城。有比丘。木刺刺脚破须软革屣听畜。时世尊与阿难俱行。去尸陀林冢间不远。见有贵价。重革屣。世尊知而故问阿难。汝何不取此革屣。阿难言。恐畜重革屣。佛言。听此粪扫物得畜。尔时比丘在道行。去冢不远。见有木贯死人皮厚。便剥取还房。作一重革屣。房内臭秽。余比丘问。房内何以臭。即以事答。诸比丘白佛。佛言。不应畜人皮。若畜偷兰遮。及余不净可恶皮不应畜。若畜突吉罗。尔时有比丘。从寒雪国来脚冻坏。诣佛所头面礼足却坐一面。佛知而故问比丘。汝何故脚破。白佛言。寒雪处来故冻坏。佛问比丘。彼国法何所著。比丘言。着富罗庵鞮。佛言。听着。若须靺。听作靺。听从非亲里居士居士妇乞作。不得作余用。若余用如法治。时六群比丘皮作腰带。佛言不应畜皮作禅带。佛言不应畜。比丘畜皮器。佛言不应畜。比丘畜皮帽。佛言不应畜。比丘作皮紧殊炭。佛言不应畜。比丘不拂拭革屣。污脚污卧具。佛言。不应不拂拭革屣。时比丘洗足已。未干便着革屣。革屣湿烂坏。佛言不应尔。时比丘不数浣拭脚物。诸比丘见污秽不喜。佛言听浣。彼浣已不捩不晒虫生。佛言。应浣捩晒燥(皮革揵度竟)

    衣揵度

尔时世尊。在波罗捺国鹿野苑中。时五比丘往世尊所。头面礼足却住一面。五人白佛。我等当持何等衣。佛言。听持粪扫衣及十种衣。拘舍衣劫贝衣钦跋罗衣刍摩衣叉摩衣舍兔衣麻衣翅夷罗衣拘摄罗衣嚫罗钵尼衣。如是十种衣。应染作袈裟色持。尔时比丘得冢间衣。佛言听畜。尔时比丘得愿衣。佛言听畜。尔时比丘在道行。去冢不远。见贵价粪扫衣。畏慎不敢取。佛言听取

尔时世尊在舍卫国。时有大姓子出家。于市中巷陌粪扫中。拾弊故衣作僧迦梨畜。时波斯匿王夫人见慈念心生。取大价衣破之。以不净涂弃之于外。为比丘故。比丘畏慎不敢取。比丘白佛。佛言。若为比丘者应取。尔时有比丘。大姓出家。于市中巷陌厕上粪扫中。拾弊故衣作僧伽梨畜。时舍卫长者见心生慈愍。以多好衣弃置巷陌若厕上。为比丘故。使人守护。不令人取。时有诸比丘直视而行。入村时守护衣人语言。大德。何不左右顾视也。时比丘见畏慎不敢取。诸比丘白佛。佛言。若为比丘听取。尔时比丘堑中得死人衣畏慎白佛。佛问言。汝用何心取。答言。以粪扫衣取。不以盗心取。佛言不犯。自今已去。不应取坑堑中死人衣。尔时有居士。浣衣已晒置壁上。时纳衣诸比丘。见谓是粪扫衣便取时居士见语言。莫取是我衣。比丘言。我谓是粪扫衣故取耳。便放之而去。彼比丘畏慎白佛。佛言。汝以何心取。答言。粪扫衣取。不以盗心取。佛言无犯。自今已去。不应取在园上若篱上堑中粪扫衣。时有比丘。于大官断事处前。有死人衣。比丘取此人衣。时大官敕旃陀罗。取死人弃之。旃陀罗言。何不使取衣者弃之。大官问言。何人取衣。答言。是沙门释子取。诸比丘白佛。佛言。不应在断事处取死人衣。尔时比丘在道行。去冢不远。见未坏死人有衣。即取而去。死人即起语言。大德。莫持我衣去。比丘言。汝死人何处有衣。故持去不止。死人逐比丘。至只桓门外。脚跌倒地。余比丘见问此比丘。彼何所说。比丘答言。此死人我取其衣来。诸比丘白佛。佛言。不应取未坏死人衣。尔时有牧牛人。以衣置头上而眠。时粪扫衣比丘。见谓是死人。彼作如是念。世尊不听比丘取未坏死人衣。即取死人臂骨打此牧牛人头破。彼即起语言。大德。何故见打。答言。我向谓汝死。牧牛人言。汝不别我死生耶。即打比丘次死。诸比丘白佛。佛言。死人未坏不应打令坏。时六群比丘。畜非衣作钵囊革屣囊针筒。畜锦文卧毡褥枕氍氀獭皮。诸比丘白佛。佛言。不应以非衣作钵囊及针筒。不应畜锦文卧具毡褥枕[毯-炎+瞿]氀獭皮。尔时比丘。冢间得锦文卧毡褥枕。诸比丘畏慎不敢取白佛。佛言听取用。时有比丘。冢间得伊梨延陀耄罗耄耄罗[毯-炎+瞿]氀。有畏慎不敢取白佛。佛言听取。却皮却草着余者。用作地敷畜。时有比丘于冢间得皮绳床木床独坐床白佛。佛言听取。却皮十种衣中随以何衣作听畜。尔时比丘。在冢间。得绳床木床独坐床。有畏慎不敢取白佛。佛言听取。除二种绳。皮绳发绳。余者应畜。时比丘在冢间。得辇得盖得步挽车。畏慎不敢取白佛。佛言听取畜。时比丘在冢间。得瓶澡灌得杖扇。畏慎不敢取。白佛。佛言听取畜。时有比丘在冢间。得钁钩刀镰。畏慎不敢取白佛。佛言听取畜。时有比丘。在冢间得钱自持来。比丘白佛。佛言不应取。彼比丘须铜白佛。佛言。打破坏相。然后得自持去。时有比丘。得牛嚼衣白佛。佛言听取用。时有比丘得鼠啮衣白佛。佛言听取用。有比丘得烧衣白佛。佛言听取。粪扫衣有十种。牛嚼衣。鼠啮衣。烧衣。月水衣。产妇衣。神庙中衣。若鸟衔风吹离处者冢间衣。求愿衣。受王职衣。往还衣。是谓十种粪扫衣。尔时拘萨罗国波斯匿王。与摩竭提王阿阇世。中间共斗多人死。时比丘欲往取死人衣白佛。佛言听往彼。若有人先语取。若无人辄取。尔时阿阇世王。与毗舍离梨奢。中间共斗多人死。时比丘欲往取彼死人衣白佛。佛言。应往语然后取。若无人辄自取。尔时众多居士。于冢间脱衣聚置一处埋死人。时粪扫衣比丘。见谓是粪扫衣。取之而去。时诸居士见语言。此是我衣莫持去。比丘言。我谓是粪扫衣。即放地而去。比丘畏慎白佛。佛言汝以何心取。答言。以粪扫衣取。不以盗心。佛言不犯。不应取大聚衣。尔时众多居士。于冢间烧死人。时粪扫衣比丘。见烟已唤余比丘。共往冢间取粪扫衣去。彼言可尔。即共往至彼。默然一处住。时居士见。即与比丘一贵价衣。第二比丘言。持来当共汝分。彼言。共何谁分彼自与我。二人共诤。诸比丘白佛。佛言。应还问居士。此衣与谁。若居士言。随所与者是彼衣。彼若言不知。若言俱与。应分作二分。尔时有比丘。往冢间取粪扫衣。遥见有粪扫衣。一比丘即占言。此是我衣。第二比丘即走往取。二人共诤。各言是我衣。诸比丘白佛。佛言。粪扫衣无主。属先取者。时有二比丘。俱往冢间取粪扫衣。遥见有衣便占言是我衣。二人俱走往取衣。共诤各言是我衣。比丘白佛。佛言。粪扫衣无主。随共取分作二分。尔时有众多居士。载死人置冢间。粪扫衣比丘。见即语余比丘言。我曹今往取粪扫衣可多得。彼比丘言。汝等自去我不往。比丘即疾往大得粪扫衣。持来至僧伽蓝中净浣治。彼比丘见。语此比丘言。汝作何事。而不共我往取衣。我往取衣大得来。此比丘言。持来共汝分。答言。汝不共我取云何共分。二人共诤。比丘白佛。佛言。属彼往取者。尔时有众多粪扫衣比丘。共期要往冢间取粪扫衣。有一比丘得贵价衣。余比丘言。持来共汝分。彼答言。我得此衣。何故共汝分。多人共诤。比丘白佛。佛言。随先要所得。多少应共分

尔时佛在舍卫国。时诸居士祖父母父母死。以幡盖衣物裹祖父母父母塔。粪扫衣比丘见剥取之。诸居士见皆共讥嫌言。沙门释子无有惭愧。盗取人物。自言我知正法。如今观之有何正法。我等为祖父母父母起塔。以幡盖裹塔供养。彼云何而自剥取。如似故为沙门释子裹塔供养。我等实为祖父母父母。以幡盖裹覆塔供养。诸比丘白佛。佛言。不得取如是物。若风吹漂置余处。若鸟衔去着余处。比丘见畏慎不敢取。比丘白佛。佛言。若风吹水漂鸟衔着余处听取。尔时比丘。见有庄严供养塔衣即取。取已畏慎。比丘白佛。佛言。汝以何心取。答言。以粪扫衣取不以盗心。佛言无犯不应取庄严供养塔衣

尔时世尊在王舍城。时毗舍离有淫女。字庵婆罗婆利。形貌端正。有欲共宿者。与五十两金。昼亦与五十两金。时毗舍离。以此淫女故。四方人集于毗舍离时国法。以为观望极好。时王舍城诸大臣闻毗舍离有淫女。字庵婆罗婆利形貌端正。有欲共夜宿者。与五十两金。昼亦尔。时毗舍离。以淫女故。四方人集于毗舍离。观望极好。时大臣往瓶沙王所白言。大王当知。毗舍离国有淫女。字庵婆罗婆利形貌端正。有欲共宿者与五十两金。昼亦如是。以淫女故。四方人集于毗舍离。观望极好。王敕诸臣。汝等何不于此安淫女。时王舍城有童女。字婆罗跋提。端正无比。胜于庵婆罗婆利。时大臣即安置此淫女。若有欲共宿者。与百两金。昼亦如是。时王舍城。以淫女故。四方人集于王舍城观望极好。时瓶沙王子字无畏。与此淫女共宿。遂便有娠。时淫女敕守门人言。若有求见我者。当语言我病。后日月满。生一男儿。颜貌端正。时淫女即以白衣裹儿敕婢。持弃着巷中。婢即受敕。抱儿弃之。时王子无畏。清旦乘车往欲见王。遣人除屏道路。时王子遥见道中有白物。即住车问傍人言。此白物是何等。答言。此是小儿。问言死活。答言故活。王子敕人抱取。时王子无畏无儿。即抱还舍与乳母养之。以活故。即为作字。名耆婆童子。王子所取故名童子。后渐长大。王子甚爱之。尔时王子。唤耆婆童子来语言。汝欲久在王家。无有才技。不得空食王禄。汝可学技术。答言当学。耆婆自念。我今当学何术。现世得大财富而少事。作是念已我今宁可学医方。可现世大得财富而少事。念言。谁当教我学医道。时彼闻得叉尸罗国有医。姓阿提梨。字宾迦罗。极善医道。彼能教我。尔时耆婆童子。即往彼国。诣宾迦罗所白言。我欲从师受学医道当教我。彼答言可尔。时耆婆童子。从学医术。经七年已自念言。我今习学医术。何当有已。即往师所白言。我今习学医术。何当有已。时师即与一笼器及掘草之具。汝可于得叉尸罗国面一由旬求觅诸草有非是药者持来。时耆婆童子。即如师敕。于得叉尸罗国。面一由旬。求觅非是药者。周竟不得非是药者。所见草木一切物。善能分别。知所用处无非药者。彼即空还。往师所白如是言。师今当知。我于得叉尸罗国。求非药草。面一由旬。周竟不见非药者。所见草木。尽能分别。所入用处。师答耆婆言。汝今可去。医道以成。我于阎浮提中。最为第一。我若死后。次复有汝。时耆婆自念。我今先当治谁。此国既小。又在边方。我今宁可还本国始开医道。于是即还归婆伽陀城。婆伽陀城中有大长者。其妇十二年中常患头痛。众医治之。而不能差。耆婆闻之。即往其家语守门人言。白汝长者。有医在门外。时守门人即入白。门外有医。长者妇问言。医形貌何似。答言是年少。彼自念言。老宿诸医治之不差。况复年少。即敕守门人语言。我今不须医。守门人即出语言。我已为汝白长者。长者妇言。今不须医。耆婆复言。汝可白汝长者妇。但听我治。若差者随意与我物。时守门人复为白之。医作如是言。但听我治。若差随意与我物。长者妇闻之。自念言。若如是无所损。敕守门人。唤入。时耆婆入。诣长者妇所问言。何所患苦。答言。患如是如是。复问。病从何起。答言。从如是如是起。复问。病来久近。答言。病来尔许时。彼问已语言。我治汝病。彼即取好药以酥煎之。灌长者妇鼻。病者口中酥唾俱出。时病人即器承之。酥便收取。唾别弃之。时耆婆童子。见已心怀愁恼。如是少酥不净。犹尚悭惜况能报我。病者见已。问耆婆言。汝愁恼耶。答言实尔。问言。何故愁恼。答言。我自念言。此少酥不净。犹尚悭惜。况能报我以是故愁耳。长者妇答言。为家不易。弃之何益。可用然灯。是故收取。汝但治病。何忧如是。彼即治之。后病得差。时长者妇。与四十万两金并奴婢车马。时耆婆得此物已还王舍城。诣无畏王子门。语守门人言。汝往。白王言。耆婆在外。守门人即入白王。王敕守门人唤入。耆婆入已。前头面礼足在一面住。以前因缘。具白无畏王子言。以今所得物尽用上王。王子言。且止不须。便为供养已。汝自用之。此时耆婆童子最初治病

四分律卷第三十九四分律卷第四十(三分之四)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    衣揵度之二

尔时瓶沙王。患大便道中血出。诸侍女见皆共笑言。王今所患如我女人。时王瓶沙闻已惭愧。即唤无畏王子言。我今有如是病。汝可为我觅医。即答王言。有耆婆童子。善于医道。能治王病。王言唤来。无畏王子唤耆婆来。问言。汝能治王病不。答言能治。若能汝可往治之。时耆婆童子。往瓶沙王所。前礼王足却住一面。问王言。何所患苦。王答言。病如是如是。复问。病从何起。王答言。从如是如是起。复问。患来久近。王言。患来尔许时。如此问已。答言能治。时即取铁槽盛满暖水。语瓶沙王言。入此水中。王即入水。语王坐水中。王即坐。语王卧水中。王即卧。时耆婆。以水洒王而咒之。王即睡。疾疾却水。即取利刀破王所苦处。净洗疮已。持好药涂。药涂竟。病除疮愈。其处毛生。与无疮处不别。即复还满槽水。以水洒王而咒之。王即觉。王言。可治我病。答言。我已治竟。王言善治不。答言善治。王即以手扪摸看。亦不知疮处。王即问言。汝云何治病。乃使无有疮处。耆婆报言。我治病宁可令有疮处耶。时王即集诸侍女作如是言。耆婆医大利益我有念我者。当大与财宝。时诸侍女。即取种种璎珞臂脚钏及覆形密宝形外宝钱及金银摩尼真珠毗琉璃贝玉颇梨积为大聚。时王唤耆婆来语言。汝治我病差。以此物报恩。耆婆言。大王且止。便为供养已。我为无畏王子故治王病。王言。汝不得治余人病。唯治我病佛及比丘僧宫内人。此是耆婆童子第二治病也

尔时王舍城有长者。常患头痛。无有医能治者。时有一医语长者言。却后七年当死。或有言六年。或言五年。乃至一年当死者。或有医言。七月后当死。或言六月乃至一月当死。或有言过七日后当死者。时长者自往耆婆童子所语言。为我治病。当雇汝百千两金。答言不能。复重语言。与汝二百三百四百千两金。答言不能。复言当为汝作奴家业一切亦皆属汝。耆婆言。我不以财宝少故不能治汝。以王瓶沙先敕我言汝唯治我病佛及比丘僧宫中人不得治余人。是故不能。汝今可往白王。时彼长者。即往白王言。我今有病。愿王听耆婆治我病。时王即唤耆婆语言。王舍城中有长者病。汝能治不。答言能治。汝若能者可往治。尔时耆婆。即往长者家语言。何所患苦。答言。所患如是如是。复问言。从何而起。答言。从如是如是起。问言。得来久近。答言。病来尔许。时问已语言。我能治汝。尔时耆婆。即与碱食令渴饮酒令醉。系其身在床。集其亲里。取利刀破头开顶骨示其亲里。虫满头中。此是病也。耆婆语诸人言。如先医言。七年后当死。彼作是意。七年已后脑尽当死。彼医如是为不善见。或言六五四三二年一年当死者。彼作是意。脑尽当死。彼亦不善见。或言七月乃至一月当死者。彼亦不善见。有言。七日当死者。彼作是意言。脑尽当死。彼为善见。若今不治过七日脑尽当死。时耆婆。净除头中病已以酥蜜置满头中已。还合髑髅缝之。以好药涂。即时病除肉满。还复毛生。与无疮处不异。耆婆语言。汝忆先要不。答言忆。我先有此要。当为汝作奴家业一切悉当属汝。耆婆言。且止长者。便为供养已。还用初语。时彼长者。即与四十万两金。耆婆以一百千两上王。百千两与父。二百千两自入。此是耆婆第三治病。尔时拘睒弥国。有长者子。轮上嬉戏。肠结腹内食饮不消亦不得出。彼国无能治者。彼闻摩竭国有大医善能治病。即遣使白王。拘睒弥长者子病。耆婆能治。愿王遣来。时瓶沙王。唤耆婆问言。拘睒弥长者子病。汝能治不。答言能。若能者。汝可往治之。时耆婆童子。乘车诣拘睒弥。耆婆始至。长者子已死。伎乐送出。耆婆闻声即问言。此是何等伎乐鼓声。傍人答言。是汝所为来。长者子已死。是彼伎乐音声。耆婆童子。善能分别一切音声。即言语使回还。此非死人语。已即便回还。时耆婆童子。即下车取利刀破腹披肠结处。示其父母诸亲语言。此是轮上嬉戏使肠结。如是食饮不消。非是死也。即为解肠。还复本处。缝皮肉合。以好药涂之。疮即愈毛还生。与无疮处不异。时长者子。即报耆婆四十万两金。妇亦与四十万两金。长者父母亦尔。各与四十万两金。是耆婆童子。第四治病。尔时尉禅国王。波罗殊提。十二年中常患头痛。无有医能治者。彼闻瓶沙王有好医善能治病。即遣使白王。我今有病。耆婆能治。愿遣来为我治之。时王即唤耆婆问言。汝能治波罗殊提病不。答言能。汝可往治之。王语言。彼王从蝎中来。汝好自护。莫自断命。答言尔。时耆婆童子。往尉禅国。至波罗殊提所。礼足已在一面住。即问王言。何所患苦。答言。如是如是病。问言。病从何起。答言。从如是如是起。问言。病来久近。答言。病来尔许时。次第问已语言。我能治。王言。若以酥若杂酥为药。我不能服。若与我杂酥药。我当杀汝。是病余药不治。唯酥则除。耆婆童子。即设方便语王言。我等医法治病。朝晡晨夜随意出入。王语耆婆。听随意出入。复白王言。若须贵药。当得急乘骑。愿王听给疾者。是时王即给日行五十由旬驼。即与王碱食令食。于屏处煎酥为药。作水色水味已。持与王母语言。王若眠觉。渴须水时。可持此与饮之。持水与王母已。即乘五十由旬驼而去。时王眠觉渴须水。母即持此水药与之。药欲消时觉有酥气。王言。耆婆与我酥饮。是我怨家。何能治我。急往觅来。即往耆婆住处觅之不得。问守门人言。耆婆所在。答言。乘五十由旬驼而去。王益怖惧。以酥饮我。是我怨家。何能治我。时王有一健步。名曰乌。日行六十由旬。即唤来。王语言。汝能追耆婆童子不。答言能。汝可往唤来。王言。彼耆婆大知技术。莫食其食。或与汝非药。答言尔。受王教。耆婆童子去至中道。不复畏惧。便住作食。时健步乌得及耆婆。语耆婆言。王波罗殊提唤汝即言当去。耆婆与乌食不肯食。时耆婆。自食一阿摩勒果留半。饮一器水复留半。爪下安非药。沉着水果中。语乌言。我已食半果饮半水。余有半果半水。汝可食之。乌即念言。彼自食半果饮半水。留半与我。此中必当无有非药。即食半果饮半水已。便患啑不复能去。复取药着乌前语言。汝某时某时服此药当差。耆婆童子。即便乘行五十由旬驼复前去。后王与乌所患俱差。波罗殊堤王。遣使唤耆婆语言。汝已治我病差。可来。汝在彼国所得多少。我当加倍与汝。耆婆言。且止。王便为供养已。我为瓶沙王故治王病。时波罗殊提。送一贵价衣价直半国。语耆婆言。汝不肯来。今与汝此衣以用相报。此是耆婆第五治病。尔时世尊患水。语阿难言。我患水欲得除去。时阿难闻世尊言往王舍城。至耆婆所语言。如来患水欲得除之。尔时耆婆。与阿难俱往佛所。头面礼足却住一面。白佛言。如来患水耶。佛言。如是耆婆。我欲除之。白佛言。欲须几下。答言。须三十下。时耆婆。与阿难俱往王舍城。取三把优钵花。还诣其家。取一把花。以药熏之。并复咒说。如来嗅此可得十下。复取第二把花。以药熏之。并复咒说。嗅之复可得十下。复取第三把花。以药熏之。并复咒说。嗅之可得九下。复饮一掌暖水。足得一下风。即随顺以三把花。置阿难手中。时阿难持华出王舍城。诣世尊所。持一把花。授与世尊。如来嗅之。可得十下。复授第二把。更得十下。第三把复得九下。尔时耆婆。忘语阿难与佛暖水。尔时世尊。知耆婆心所念。即唤阿难取暖水来。尔时阿难。闻世尊教。即取暖水与佛。佛即饮一掌暖水。患即消除。风亦随顺。尔时王瓶沙。闻佛有患。与八万四千人俱。前后导从诣世尊所。问讯世尊。头面礼足。却坐一面。时忧填王。闻世尊患。亦将七万人俱。波罗殊提王。与六万人俱。梵施王。与五万人俱。波斯匿王。与四万人俱。末利夫人。利师达多富罗那。四大天王。及诸营从释提桓因。与忉利诸天俱。炎天子。与炎天俱。兜率天子。与兜率诸天俱。化乐天与化乐诸天俱。他化自在天。与他化自在天俱。梵天。与梵天俱。摩醯首罗天子。与摩醯首罗诸天俱。往世尊所。头面礼足。却住一面。时舍利弗。闻世尊病。与五百比丘俱。往世尊所头面礼足却住一面。尔时摩诃波阇波提比丘尼。闻世尊病。与五百比丘尼俱。阿难宾坻。与五百优婆塞俱。毗舍佉母。与五百优婆夷俱。诣世尊所。头面礼足。问讯世尊。时提婆达多。闻世尊病。诣世尊所。头面礼足。却住一面。尔时提婆达多。见世尊前四部众会。作如是念。我今宁可服药。如佛令四部众来问讯我。即往耆婆所语言。我欲服佛所服药。汝可与我药。耆婆言。世尊所服此药。名那罗延。此药非是余人所服。除转轮王。成就菩萨如来乃能服之。提婆达多语言。若不与我。我当害汝。尔时耆婆。畏夺命故。即便与之。提婆达多以服此药故。即得重病。身心俱苦。独有一己更无余人。亦无亲厚。作如是念。如我今日无有救者。唯有如来。尔时世尊。知提婆达心念。从耆阇崛山。身出施药光明。以照提婆达多。使一切苦痛即得休息。尔时提婆达多病差未久。往王舍城巷陌唱令。太子悉达多。舍转轮王出家为道。今行医药自活。何以知之。适治我病差故知。时诸比丘闻。有少欲知足行头陀乐学戒知惭愧者。嫌责提婆达多。如来慈愍。而更无反复。尔时比丘。往世尊所头面礼足已白佛言。未曾有世尊慈愍。提婆达多而更无反复。佛告诸比丘言。非适今日慈愍。提婆达多而无反复。何以故。乃往过去世时。有王名一切施。作阎浮提王。时阎浮提。国土平博人民炽盛丰乐无比。时阎浮提。有八万四千城。有五十亿聚落。有六万边城。尔时有病人。诣一切施王所。白王言。我今无有救护。唯有王耳。尔时王集阎浮提诸医。示此病人。王问诸医。如此病人当须何药。诸医看病已白王言。如此病人。非常入所能与药。唯有成就菩萨能与药耳。王问为须何乐。医言。此病人若得慈心菩萨生肉生血食之。二十九日乃得差。一切施王心念言。生死长远轮转无际受诸苦恼。或堕地狱饿鬼畜生。截脚截手截耳截鼻挑眼斫头竟何所益。即以国付嘱诸臣。入内静处思四无量行。尔时一切施王。即取利刀割髀里肉血。使人送与病者。如是经二十九日。后王问使人。病人云何。答王言已差。王言。将来看之。时即为病人洗浴与新衣着。将诣王所。王问言。汝病云何。答言已差。王言。汝随意去。时彼人出门。右脚蹴地血出。余人见之问言。男子汝脚何故血出耶。即言。彼非法王。弊恶王。非法淫着王。贪着乐邪见王。于彼门中脚蹴此阃使我脚坏血出如是。彼诸人言。未曾有无反复人。一切施王。二十九日以身血肉治令得差。而于王所无有反复。佛告诸比丘。尔时一切施王我身是。时病人者。今提婆达多是。我前世时。慈心愍之。而无反复。今亦如是无有反复。尔时世尊。为提婆达多故。说此偈言

  一切诸山海　　我不以为重
  其无反复者　　我以此为重
  无有反复报　　癞病恶疾苦
  或受白癞病　　无反复如是

是故诸比丘。应念报恩。应存反复。当如是学。尔时耆婆童子。瞻视世尊病。煮吐下汤药及野鸟肉得差。是为耆婆童子第六治病。时耆婆童子。于异时持一领贵价衣。往世尊所。头面礼足却住一面。白世尊言。我若治国王。若治大臣。或得一国土。或得一聚落。唯世尊当与我愿。佛言。我已过于愿。不与人愿。耆婆复言。愿与我清净愿。佛言。求何等清净愿答言。我此贵价衣。从王波罗殊提间得。价直半国。愿世尊哀愍故为我受。自今已去。愿听诸比丘欲着檀越施衣欲着粪扫衣者随意着。尔时世尊默然可之。时耆婆童子。得世尊可已。即持金澡瓶水洗佛手。持此大贵价衣上佛。佛慈愍故为受之。耆婆童子。头面礼足却坐一面。佛为种种说法。令得欢喜。前礼佛已还去。时世尊以此因缘集比丘僧。为诸比丘随顺说法。以无数方便赞叹头陀摄持威仪少欲知足有智慧乐于出离者。告诸比丘。此衣贵价衣中第一。如牛出乳乳中出酪酪中出生酥生酥中出熟酥。熟酥出醍醐。最精第一。此衣如是。众多衣中最为第一。自今已去。听诸比丘随意着檀越施衣粪扫衣。尔时瓶沙王。闻佛听诸比丘畜檀越施衣。即持所著贵价钦婆罗衣。送与比丘。诸比丘不受言。佛未听我曹畜大价衣。诸比丘白佛。佛言。自今已去。听畜贵价钦婆罗衣。后复遣人送王所著贵价[毯-炎+瞿]氀。诸比丘不敢受。佛未听我曹畜贵价[毯-炎+瞿]氀。诸比丘白佛。佛言。自今已去听畜。尔时六群比丘。畜广大长毛[毯-炎+瞿]氀。诸比丘以此事白佛。佛言不应畜。佛言。自今已去听诸比丘畜氍氀广三肘长五肘毛长三指者。应净施畜。尔时耆婆童子。闻佛听诸比丘畜檀越施衣。即遣人送王所著短毛氍氀。与诸比丘。诸比丘不敢受。佛未听我畜短毛氍氀。诸比丘往白佛。佛言。自今已去听畜。尔时王舍城诸优婆塞。闻佛听诸比丘畜檀越施衣。即遣人大送种种好衣与诸比丘。诸比丘不知当云何。往白佛。佛言听分。不知云何分。佛言。当数人多少。若十人为十分。若乃至百人为百分。分衣时好恶相参。时彼分衣者。辄自取分。佛言。不应自取分。应使异人分。使异人取分。彼自取分。佛言。不应自取。当掷筹分。彼比丘自掷筹。佛言。不应自掷筹。听不见者掷筹。时有王所著大贵价衣不可分。佛言。听截破分。自今已去。听以刀截衣。尔时比丘得未浣衣。佛言。听自浣若使人浣。时须浣器。佛言。应畜浣器。若无浣板。听畜板若须剪刀。听畜

尔时世尊。出王舍城。南方人间游行。中道见有田善能作事畦畔齐整。见已告阿难。汝见此田不。答言。已见世尊。佛问阿难。汝能为诸比丘作如是衣法不。答言能。佛语阿难。汝往教诸比丘。时阿难从彼还王舍城。教诸比丘。作如是割截衣。此是长条。此是短条。此是叶。此第一缝。此第二缝。此是中缝。此条叶两向。时王舍城多着割截衣尔时世尊南方人间游行已。还王舍城。见诸比丘多着割截衣。告言。阿难聪明大智慧。我为略说。而能广解其义。过去诸如来无所著佛弟子。着如是衣。如我今日。未来世诸如来无所著佛弟子。着如是衣。如我今日。刀截成沙门衣。不为怨贼所剥。从今日已去。听诸比丘作割截安陀会郁多罗僧僧伽梨。时诸比丘。作割截安陀会衬体着。叶边速破尘垢入叶内。自今已去。听作不割截安陀会。诸比丘着割截郁多罗僧僧伽梨。叶边速破尘垢入内露湿。佛言。自今已去。听着割截郁多罗僧僧伽梨。听叶作鸟足缝若编叶边若作马齿缝。诸比丘不知当作几条衣。佛言。应五条。不应六条。应七条不应八条。应九条不应十条。乃至十九条。不应二十条。若过是条数不应畜。尔时比丘。反襵着涅槃僧。入白衣舍解脱露形。诸比丘白佛。佛言不应尔。听作带着。时六群比丘畜上色带。佛言不应畜。诸比丘以锦作。佛言不应锦作。诸比丘畜白带。佛言不应以白作。佛言。听畜袈裟色带。尔时六群比丘作广长腰带。诸比丘白佛。佛言不应作。听作广二指绕腰三周。若得已作者。应作二叠三叠四叠若三四叠。乱听缝合。若短者。听作绳续。若带细软。数结速断。应安纽若玦。诸比丘用宝作。佛言。不应用宝。若用骨若用牙若角若铁若铜若白镴若铅锡若綖若木若胡胶作。不知云何安玦。佛言。以帛缝若穿孔着。时诸比丘带断坏。听补治。复不知云何补治。佛言。若重綖更缝。若边坏听线编。若带头须坏。听更以线续若缝。尔时比丘。不系僧祇支入聚落行。使衣堕形露。佛言。不应不系衣入聚落。听安带若缝。尔时舍利弗入白衣舍。患风吹割截衣堕肩。诸比丘白佛。佛言。听肩头安钩纽

尔时世尊。在王舍城。与千二百五十比丘俱人间游行。尔时比丘多持衣。或头戴或肩担或带着腰中。时有比丘。字伽梵婆提。诣恒水边。佛欲渡处。即以神力断水。时佛渡水已。见诸比丘多持衣或头戴或肩担或带着腰中。见已念言。此诸比丘多持衣如是。我宁可为诸比丘制衣多少令有齐限。若过不应畜。尔时世尊。从婆阇国人间游行。诣毗舍离。尔时庵婆罗婆提。闻佛与千二百五十比丘俱人间游行来诣毗舍离。即乘车往世尊所。遥见世尊相好端严。恭敬欢喜。即时下车往诣佛所。头面礼足却住一面。尔时世尊。为说法劝化。令得欢喜。闻佛说法已。踊跃欢喜白佛言。唯愿世尊。受我明日请食。并比丘僧。在我园一宿。时世尊默然许可。彼知佛许已。头面礼足绕佛而去

尔时世尊。住毗舍离在庵婆罗园中。诸梨奢。闻佛与千二百五十弟子人间游行来诣毗舍离。着种种衣服璎珞。乘种种车。往迎世尊。诸梨奢。或有着绀色璎珞衣服。乘绀色车马。绀色侍从。绀色刀鉾幡盖。绀色珠毛拂。青黄赤白黑车马侍从严饰亦复如是。如是有五百梨奢。诣世尊所。时庵婆罗婆提迎佛还道。遇诸梨奢。亦不避道。车盖相突。时梨奢中有耆老者。语庵婆罗婆提言。汝何故不避道。共相逼斥车盖相突耶。婆提答言。所以尔者。我请佛及僧在我园宿。心在于佛无有余意也。梨奢语言。我与汝百千两金。听佛受我请供养。答言。我已请佛及僧止宿我园。云何当舍。梨奢复言。我与汝二百千两金。乃至十六百千。听世尊受我请供养饮食。答言不能。梨奢复言。以半国财物与汝。听佛受我请供养饮食。答言。设与我全毗舍离国者我亦不舍。何以故。我已请佛及僧在园供养。尔时五百梨奢。振手嗔恨庵婆罗婆提言。捐弃我等。即乘车诣庵婆罗园。尔时世尊。在彼园中与无数众围绕说法。遥见五百诸梨奢来。告诸比丘。其有比丘。不见忉利诸天出游时。当观此诸梨奢。忉利诸天。欲出游时。与此无异。佛告诸比丘。慎汝心念。摄持威仪。此是我教。云何比丘慎汝心念。若比丘观内身身意止。精勤摄持念不散乱。调伏贪嫉世间忧恼。观外身身意止。精勤摄持念不散乱。调伏贪嫉世间忧恼。观内外身观受心法亦如是。如是比丘得正心念。云何摄持威仪。比丘若出若入屈伸俯仰。执持衣钵若饮若食若服药。大小便利。若眠若觉。若来若去。若坐若住。若睡若觉。若语若默。常尔一心。是谓比丘摄持威仪。尔时毗舍离五百梨奢。至车所住处便下车。诣世尊所。头面礼足却坐一面。五百梨奢。在佛边无复威神。唯佛世尊。在大众中光明威德最胜无比。犹若秋天无有云翳。日行虚空威曜无比。如是世尊。在五百梨奢中。神德名称颜貌无比。尔时众中有婆罗门。字宾耆羊菟。此婆罗门。从座起偏露右肩。右膝着地白佛言。我欲有所说。佛言。听汝所说。此婆罗门。即于佛前。说偈赞佛

  摩竭王得善利　　鸯伽王持珠铠
  其有佛出此国　　声震动如雪山
  如莲花香洁　　开张香气胜
  今观佛光曜　　如日之初出
  如月行虚空　　无有诸云翳
  如是佛世尊　　光显于世间
  观佛之智慧　　如闇然大火
  施众以明眼　　决了诸疑惑

尔时诸梨奢语婆罗门言。汝可重说此偈。时婆罗门即再三说此偈。时诸梨奢以其善赞偈故。即与五百领衣。时婆罗门得此衣已。即用上佛言。愿佛哀愍故。而为受之。尔时世尊告诸梨奢。世间有五种宝难得。何等五。一者佛世尊出于世间。此宝难得。佛出世间闻佛说法为人说者。此宝难得。佛出世间为人说法闻法解者。此宝难得。佛出世间闻佛说法如法而行。此宝难得。得信乐者。此宝难得。是为五宝世间难得。尔时五百梨奢。闻佛种种方便说法开化。极大欢喜白佛言。愿明旦受我请。与比丘僧俱。佛言。我已受庵婆罗婆提请时五百梨奢振手而言。庵婆罗婆提捐弃我等。即从座起前礼佛足绕已而去。尔时庵婆罗婆提。还家办具种种多美饮食。明日往白时至。世尊清旦着衣持钵与比丘僧千二百五十人俱。往庵婆罗婆提家就座而坐。时婆提。饭佛及比丘僧。种种多美饮食。食饮足已。置钵于地。持金澡瓶水洗佛手。前白佛言。毗舍离国有诸园观。此最第一。今奉世尊。在中住止。唯愿哀愍见为受之。佛告言。汝可奉佛及四方僧。何以故。若佛园园物。若房舍房舍物。若钵若衣。若座具针筒。如佛塔庙。一切世间诸天龙神梵天沙门婆罗门诸天及人。无有能用者。婆提言。今以上佛及四方僧。愿为受之。时佛哀愍故。为咒愿受之

  若为作寺庙　　种植诸果树
  桥船以度人　　旷野施水果
  兼复施屋舍　　如是之人辈
  日夜福增长　　如法能持戒
  彼人向善道

时婆提。更取小床于一面坐。时世尊为说种种法。令大欢喜。即于座上诸垢消除得法眼净。见法得法已成果证。白佛言。自今已去。归依佛法僧作佛优婆私。从今已去。不杀生乃至不饮酒。时婆提。闻佛种种方便说法。极大欢喜。从座起礼佛足而去。尔时世尊。在静处思惟。心自念言。诸比丘在道路行多担衣。有头上戴。或有肩上担。或有带着腰中。见已作如是念。宁可为诸比丘制衣多少。过不得畜。时世尊。初夜在露地坐着一衣。至中夜觉身寒。即着第二衣。至后夜觉身寒。着第三衣。时世尊作如是念。当来世善男子不忍寒者。听畜三衣足。我听诸比丘畜三衣不得过。夜过已。世尊以此事集比丘僧告言。我在静处思惟。诸比丘在道行大担衣。或头上戴肩上担带着腰中。见已作如是念。我今宁可为诸比丘制衣多少过者不得畜。我初于夜在露地坐着一衣。至中夜觉寒着第二衣。至后夜觉寒着第三衣。我作如是念。当来善男子不忍寒者。畜三衣足。我今宁可制诸比丘畜三衣。若过不得畜。自今已去。听诸比丘畜三衣。不得过畜。尔时异住处四方僧。得贵价僧伽梨作卧具。诸比丘不知云何白佛。佛言。应持贸易余物随处用。不知使谁贸易。白佛。佛言。听比丘贸易。若使守僧伽蓝人若沙弥优婆塞易。若施主自易随处用。时世尊在跋提国。有比丘得刍摩衣。白佛。佛言听畜。有比丘得罗睺多衣白佛。佛言听畜。有比丘得阿哆睺多衣白佛。佛言听畜。时六群比丘畜上色染衣。佛言不应畜。时六群比丘畜上色锦衣。佛言。不应畜锦衣白衣。法不应畜。应染作袈裟色畜。时六群比丘着不截须衣。佛言不应畜。有六群比丘锦作衣须。佛言不应畜。六群比丘畜颇那陀施衣。佛言不应畜。如是痴人。随我所制更作余衣。时世尊在波罗捺国。有檀越送食。诸佛常法。若不往食。在后案行房舍。案行房舍时。见有比丘舒僧伽梨在地欲安帖。见已往比丘所语言。汝何故舒衣在地。比丘言。欲使里相着外有帖现。佛言。善哉善哉。比丘如汝所作。时诸比丘食还。世尊以此因缘集比丘僧告言。汝诸比丘。食后我案行房舍。见有比丘舒僧伽梨在地欲安帖。见已往比丘所语言。汝何故舒衣在地。比丘言。欲使里相着外有帖现。我即赞叹善哉。如汝所作。自今已去。听诸比丘作新衣。一重安陀会。一重郁多罗僧二重僧伽梨。若故衣听二重安陀会二重郁多罗僧四重僧伽梨。若粪扫衣随意多少重数

尔时世尊在旷野国。时众僧得善显现衣。佛言听畜。得锦衣。佛言不听畜。诸比丘得蚊厨。佛言听畜。尔时世尊在跋耆国人间游行。往失守摩罗山至恐畏林鹿野苑中住。时有菩提王子。作新殿堂。未有沙门婆罗门一切人坐者。尔时王子。闻佛从跋耆国人间游行往失守摩罗山恐畏林鹿野苑中住。即遣人唤萨阇婆罗门子语言。汝持我名往佛所。头面礼足问讯世尊。起居轻利少病少恼住止安乐。如是白佛。愿佛及僧。受我请食。我造新殿堂。未有沙门婆罗门一切人民坐者。愿佛先坐。然后菩提王子坐。得福无量。时萨阇婆罗门子。礼王子足已。往世尊所敬问讯已。却坐一面。白世尊言。菩提王子。稽首世尊足下。问讯起居轻利少病少恼住止安乐。如是白佛。愿佛及僧。受我请食。我造新殿堂。未有沙门婆罗门一切人民坐者。愿佛先坐。然后王子坐。得福无量。时世尊默然许可。时萨阇婆罗门子。闻佛许可已。从坐起绕佛而去。还菩提王子所。白如是言。沙门瞿昙。我已白竟。默然许可。今正是时时王子。即设种种美食夜过已。明日扫洒殿堂。布好新衣从阶陛至殿。时至遣人白佛。时世尊着衣持钵。与千二百五十比丘僧俱。诣菩提王子家。时王子至外门里迎佛。遥见佛来。前头面。礼足已。随侍佛后。如顺教弟子。世尊入王子堂前默然而立。王子言。愿佛在衣上行上殿。令我得福安乐。王子第二第三如是白世尊。世尊默然。时世尊顾视阿难。阿难知佛不欲蹑新衣上行为利益后众生故。阿难语王子言。可摄此衣。如来不欲在上行。为利益后众生故。时王子疾疾却衣已白佛言。愿佛上殿。令我得福。时佛即上殿就座而坐。时王子饭佛及僧种种多美饮食。食已舍钵。取一小床在一面坐。时世尊种种方便为王子说法已。从坐而去。还本住处。以此因缘集比丘僧告言。若大价衣布地。不应在上行。若行如法治。尔时比丘房舍多尘土。佛言听洒扫洒扫已故复有尘。佛言。听以泥浆污洒。若故有尘。伊梨延陀耄罗耄耄罗毛[毯-炎+瞿]氀。十种衣中。若一一衣。作地敷

尔时世尊在舍卫国。王波斯匿有异母。信乐佛法。以王所著大价锦衣。施四方僧已便命过。时比丘用作地敷。有诸不信乐大臣。至僧伽蓝中观看。见比丘以王所著大价锦衣作地敷。见已皆共讥嫌言。沙门释子不知厌足。多贪畜遗余。自言我知正法。如是观之何有正法。以王所著大价衣用作地敷。檀越虽施受者当知足。诸比丘白佛。佛言。不应以王所著大价衣作地敷。自今已去。听用作卧褥坐褥作枕作覆上衣。尔时比丘。裹头至佛所白言。大德。此是头陀端严法。愿佛听。佛言。比丘不得裹头。是白衣法。若裹头如法治。时诸比丘头冷痛白佛。佛言。听以毳若劫贝作帽裹头。尔时比丘。诞陀卢多梨着衣。往佛所白言。此是头陀端严法。愿佛听。佛言。不得如是着衣。除僧伽蓝内。此是白衣法。若如是着衣如法治。尔时比丘着一衣。往佛所白言。此是头陀端严法愿佛听。佛言。不应着一衣。除大小便处。此是白衣法。若着如法治。尔时比丘着串头衣。往佛所白言。此是头陀端严法。愿佛听。佛言。不应着此衣。是白衣法。若着如法治。尔时比丘着袄往世尊所白言。此是头陀端严法。愿佛听。佛言不应着。此是白衣法。若着如法治。尔时比丘着皮衣。往佛所白言。此是头陀端严法。愿佛听。佛言不应着。此是白衣法。若着如法治。尔时比丘着褶。往佛所白言。此是头陀端严法。愿佛听。佛言不应着。此是白衣法。若着如法治。尔时比丘着裤。往佛所白言。此是头陀端严法。愿佛听。佛言不应着。此是白衣法。若着如法治。尔时比丘着行縢。往佛所白言。此是头陀端严法。愿佛听。佛言不应着。此是白衣法。若着如法治。尔时比丘着蒲草行縢。往佛所白言。此是头陀端严法。愿佛听。佛言不应着。此是白衣法。若着如法治。佛语比丘。汝痴人。随我所制更作余事。如是一切白衣之法不得着。时诸比丘。假作编发螺髻。来指佛所白言。此是头陀端严法。愿佛听。佛言不应尔。此是外道法。若作如是如法治。尔时有比丘持木钵。往佛所白言。此是头陀端严法。愿佛听。佛言。不应持如是钵。此是外道法。若畜如法治。尔时比丘持钵楼(三奇杖到柱地持钵置中上安横串众物肩荷而行故名钵楼)往佛所白言。此是头陀端严法。愿佛听。佛言。此是外道法不应持。若畜如法治。尔时比丘着绣手衣。往佛所白言。此是头陀端严法。愿佛听。佛言不应着。此是外道法。若畜如法治。尔时比丘着草衣。往佛所白言。此是头陀端严法。愿佛听。佛言不应着。此是外道法。若着如法治。如是衣若草衣。裟婆草衣。树皮衣。树叶衣。珠璎珞衣。如是一切衣不得畜。若畜如法治。尔时比丘着外道皮衣。往佛所白言。此是头陀端严法。愿佛听。佛言不应着。若着如法治。尔时比丘着鹫毛衣。往佛所白言。此是头陀端严法。愿佛听。佛言不应着。此是外道法。若畜如法治。尔时比丘着人发钦婆罗衣。往佛所白言。此是头陀端严法。愿佛听。佛言不应着。此是外道法。若着偷兰遮。尔时比丘。着马毛[犛-未+牙]牛尾钦婆罗衣。往佛所白佛言。此是头陀端严法。愿佛听。佛言不应着。此是外道法。若着如法治。尔时比丘露身。往佛所白言。此是头陀端严法。愿佛听。佛言不应尔。此是外道法。若露身偷兰遮。佛言。如是痴人。随我所制复作余事。如是一切外道法。不应作

尔时有往处。现前僧大得可分衣物。诸比丘不知云何。往白佛。佛言听分复不知云何分。佛言。应数人多少。若十人若二十人。乃至百人为百分。若有好恶当相参分。彼便自取分。佛言。不应自取分。应掷筹分。彼便自掷筹。佛言。不应自掷筹。应使不见者掷筹。时分物时。有客比丘来。佛言应与分。作分竟。有客比丘来。应与分。未掷筹时来。应与分。掷筹时来。应与分。掷筹竟来。不与分。欢喜受分已。有客比丘来。不与分。若有余更分。竟来不应与分。若已与沙弥。使人分已来。不应与分。比丘分衣时。有客比丘。数数来。分衣疲极。应差一人令分白二羯磨如是与众中差堪能羯磨者。如上作如是白。大德僧听。此住处若衣若非衣。现前僧应分。若僧时到僧忍听。僧与某甲比丘。彼当与僧白如是。大德僧听。此住处若衣若非衣。现前僧应分僧今与某甲比丘。彼比丘当与僧。谁诸长老忍。此住处若衣若非衣现前僧应分。僧与某甲比丘。彼某甲当与僧者默然。谁不忍者说。僧已忍。与某甲比丘。彼某甲当与僧竟。僧忍默然故。是事如是持。尔时比丘得婆输伽衣白佛。佛言听畜。诸比丘患寒白佛。佛言。听着复贮衣。尔时有异住处一比丘住。时现前僧大得可分衣。诸比丘不知云何白佛。佛言。若比丘住处有一比丘住。大得现前僧可分衣。若有客比丘来。若四人若过四人。应持衣与一比丘令白二羯磨分。若有三人应彼此共三语受共分。若二人共三语受共分。若一人应心念口言此是我分。尔时有住处。有比丘有比丘想。欲别部分衣。诸比丘不知成分不成分。白佛。佛言。不成分得突吉罗。尔时有住处。有比丘疑别部分衣。诸比丘不知成分不成分。白佛。佛言。不成分得突吉罗。尔时有住处。有比丘作无比丘想别部分衣。比丘不知成分不成分白佛。佛言。不成分不犯。尔时有住处。无比丘有比丘想分衣。诸比丘不知成分不成分白佛。佛言。成分得突吉罗。尔时有住处。无比丘有疑分衣。不知成分不成分白佛。佛言成分得突吉罗。尔时住处。无比丘无比丘想分衣。诸比丘不知成分不成分白佛。佛言成分衣无犯。尔时有住处。有比丘有比丘想别部受衣。诸比丘不知成受衣不白佛。佛言。不成受衣得突吉罗。尔时有住处。有比丘疑别部受衣。诸比丘白佛。佛言。不成受得突吉罗。尔时有住处。有比丘无比丘想别部受衣。诸比丘不知成受不白佛。佛言。不成受不犯。尔时有住处无比丘有比丘想受衣。诸比丘不知成受不白佛。佛言。成受得突吉罗。尔时有住处。无比丘疑受衣。诸比丘不知成受衣不白佛。佛言。成受得突吉罗。尔时有住处。无比丘无比丘想受衣。诸比丘不知成受不白佛。佛言成受无犯

四分律卷第四十四分律卷第四十一(三分之五)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    衣揵度之三

尔时舍卫国。有多知识比丘死。有多僧伽蓝。多有属僧伽蓝园田果树。有多别房多属别房物。有多铜瓶铜盆斧凿灯台。多诸重物。多有绳床木床卧褥坐褥枕。多畜伊梨延陀耄罗耄耄罗氍氀。多有守僧伽蓝人。多有车舆。多有澡罐锡杖扇。多有铁作器木作器陶作器皮作器剃发刀竹作器。多衣钵尼师坛针筒。诸比丘不知云何白佛。佛言。多知识无知识。一切属僧。诸比丘分僧园田果树。佛言不应分。属四方僧。彼分别房及属别房物。佛言不应分。属四方僧。彼分铜瓶铜盆斧凿及诸种种重物白佛。佛言不应分。属四方僧。彼分绳床木床坐褥卧褥枕。佛言不应分。属四方僧。彼分伊梨延陀耄罗。耄耄罗氍氀。佛言不应分。属四方僧。自今已去。听诸比丘氍氀广三肘长五肘毛长三指现前僧应分。彼分车舆守僧伽蓝人。佛言不应分。属四方僧。彼分水瓶澡罐锡杖扇。佛言不应分。属四方僧。彼分铁作器木作器陶作器皮作器竹作器。佛言不应分。属四方僧。自今已去。听分剃刀衣钵坐具针筒。彼分俱夜罗器。现前僧应分。尔时有异住处二部僧。多得可分衣物。时比丘僧多。比丘尼僧少。诸比丘不知云何白佛。佛言应分作二分。时无比丘尼。纯式叉摩那。应分作二分时无比丘尼。无式叉摩那。纯沙弥尼。佛言。应分作二分。若无沙弥尼。僧应分。时有住处二部僧多。得物。比丘少比丘尼多白佛。佛言。应分作二分。无比丘有沙弥。应分作二分。无沙弥比丘尼应分。时有比丘。在拘萨罗国人间游行。到无比丘住处村。到已命过。诸比丘不知谁应分此衣钵白佛。佛言。彼处若有信乐优婆塞若守园人。彼应赏录。若有五众出家人前来者应与。若无来者。应送与近处僧伽蓝。尔时世尊。在舍卫国住处。多比丘比丘尼优婆塞优婆夷。国王大臣种种外道沙门婆罗门。时世尊告诸比丘。我欲三月静坐思惟。无使外人入。唯除一供养人。时诸比丘自立制限。世尊如是语。三月静坐思惟。不听外人入。唯除一供养人。若有入者。教令波逸提忏

尔时长老和先跋檀陀子。与波罗国六十比丘俱。尽是阿兰若乞食着粪扫衣。作余食法不食一坐食一抟食。冢间坐露地坐树下坐常坐。随坐持三衣。诣舍卫国只桓精舍。问诸比丘。如来在何处房住。我欲往见。诸比丘言。如来如是言。我三月静坐思惟。无使外人入。唯除一供养人。若有入者。作波逸提忏。和先问言。世尊有如是语耶。比丘答言。诸比丘自立制言。若有入者。波逸提忏。和先言。我不用诸长老制。何以故。佛有如是言。佛不制不应制。若已制不应违。随所制法应学。我等悉是阿兰若乃至持三衣。得随意问讯世尊。尔时长老和先。与彼六十比丘俱。径诣佛所。头面礼足却住一面。时世尊慰问言。和先。汝安乐不。饮食不乏耶。住止安静不。和先。汝从何处来。汝不闻余比丘语耶。答言。住止安乐。不以饮食为苦。亦闻余比丘语。大德。我与波罗国六十比丘俱。尽是阿兰若乃至持三衣。在拘萨罗国人间游行。至舍卫国。问只桓诸比丘。世尊在何处房住。我等欲见。诸比丘如是语。世尊三月静坐思惟。无使外人入。唯除一供养人。若有入者。教波逸提忏。我即问波逸提忏。世尊有如是语耶。诸比丘言无。我等自立制耳。我即语言。我不用汝曹制。何以故。佛有如是语。佛不制者不应制。若已制不应违。随所制法应学。我曹皆是阿兰若乃至持三衣。得随意问讯世尊。佛言。善哉善哉和先。汝等尽是阿练若持三衣。得随意问讯。若复有如是者。亦得随意问讯世尊。尔时诸比丘。闻世尊听阿兰若得随意问讯世尊。或有作阿兰若者。或有不受请者常乞食。或有舍檀越施衣持粪扫衣。或有舍长衣持三衣。时诸比丘舍衣成大积聚。诸比丘不知云何白佛。佛言。应布施众僧。若施佛若施塔若与一人。诸比丘闻言与一人。持与白衣。比丘白佛。佛言。不应与白衣若外道。时诸比丘畏慎。不敢与比丘尼非衣钵囊革屣囊针筒禅带腰带帽拭脚巾摄热巾裹革屣巾。佛言。听与比丘尼非衣。诸比丘作如是念。行波利婆沙摩那埵比丘。应与分不。佛言应与。诸比丘作如是念。诸被呵责羯磨。若摈出羯磨依止羯磨。遮不至白衣家羯磨作举羯磨。被如是诸羯磨人。当与分不。佛言与。置地与若使人与时诸比丘得外道衣不染便着白佛。佛言。不应便着。应染已着。时诸比丘。使白衣作白衣索衣分白佛。佛言。听计功多少与食与价。诸比丘自念。守僧伽蓝人沙弥。应等与衣分不。白佛。佛言。若僧和合听应与沙弥等分。若不和合应与半。若半不听应三分与一。若不与不应分。若守僧伽蓝人四分与一。若不与不应分。若分应如法治。诸比丘畏慎疑。不敢持衣与父母白佛。佛言应与。尔时佛在舍卫国。迦维罗释子。新作堂舍。未有沙门婆罗门及诸人在上坐者。时毗琉璃太子最初坐上。诸释种皆共嗔嫌。我新作堂舍。佛未得坐。下贱婢子先坐中。时有不信乐婆罗门侍从语言。舍夷诸释子。骂汝作下贱婢子。汝乃能忍耶。答言。我今无力。不得自在。若我父亡。我作王时当语我。后王波斯匿失王位。琉璃太子即自作王。不信乐大臣白言。先诸释种子骂王。王能忍耶。今可往罚。王即集四种兵。出舍卫城往舍夷国。时世尊慈愍故。即先往琉璃王所行道边。在恶树下坐。时琉璃王至。见佛在恶树下坐。即下车头面礼足却住一面白世尊言。多有大好树无恚树等而不坐。何故在此恶树下坐。佛言大王。在亲里荫下乐。彼作如是念。世尊慈愍舍夷国故耳。即回军还舍卫国。不信乐大臣婆罗门。第二第三如是语。诸释种先骂王。作下贱婢子。今可往罚。时王即复集四种兵。往舍卫国。去迦维罗卫国不远。作小营自障住。时迦维罗卫释种等。皆能远射。无抂发者。或有射一由旬中的。或有射七十里中的。或有射六十里五十里四三十里中的者。时有射琉璃王营。有中盖顶盖枓盖子。或有中车辕。或有中马勒马鞚马缰。或有中指印。或有中耳珠髻珠破珠而已。终不伤肉。时琉璃王大恐怖问。诸释子去此远近。傍臣答言。去此七十里。王闻已倍更恐怖言。我将不为诸释子所害及我军众耶。时不信乐大臣白王言。彼诸释子。皆持五戒为优婆塞。死死终不断众生命。王但前进。勿以为怖。即往围迦维罗卫城。诸比丘以此因缘白佛。佛言。彼若不与开门终不能得。时城内人自不和。或言当与城者。或言莫与。即行筹。时天魔波旬。在与城众中七返取筹。即令与琉璃王城筹多。即为开门与之。军人即入。反闭城门。街巷凿陷悉齐人腰。埋诸释种男女大小。相参而无有间。令大象蹈上。时摩诃男释子。是琉璃王外祖父。语诸释种言。汝曹莫但看琉璃王放大象蹈杀人。当观昔日业报因缘。诸释种昔日所造定业报。今当受之。时琉璃王闻。语摩诃男释子言。欲得何愿。摩诃男言。诸释种已死。我今苦恼。何用愿为。若欲与我愿者。听我入池水。随入水时节中间。听诸释种出莫杀。琉璃王念言。水中不得久与汝愿。摩诃男即入池水。以发系树根。遂于水下命过。琉璃王即问诸大臣言。释子摩诃男入水何乃久耶。傍人看之。答言已死。王言出之。即出示王。时琉璃王见即生慈心言。摩诃男乃为亲里。故不惜身命。即敕人放诸释种。彼即受教放之。诸释种被破剥脱。露形来至僧伽蓝中。诸比丘畏慎。不敢与衣。佛不听我曹与白衣衣。诸比丘白佛。佛言。借衣勿令露形来见我即便借衣。时舍利弗。与佛在拘萨罗国游行。在一处坐息。忘僧伽梨置地而去。时佛忆念。语阿难言。取此衣作亲友意取。阿难言。云何作亲友意取。佛言随所取令彼欢喜。云何随所取令彼欢喜。答言。有七法。是亲友利益慈愍故。何等七。难与能与。难作能作。难忍能忍。密事相语。不相发露。遭苦不舍。贫贱不轻。如是阿难。有此七法。名为亲友。利益慈愍。令彼欢喜。即说偈言

  难与能与　　难作能作　　难忍能忍
  是亲善友　　密事相语　　互相覆藏
  遭苦不舍　　贫贱不轻　　如此七法
  人能行者　　名为亲友　　应附近之

佛言。如此亲友应取。彼比丘非亲友作亲友意取。佛言。不应非亲友作亲友意取。彼比丘非亲友作亲友意取波利迦罗衣。佛言。不应作亲友意取此衣。若不足不应取。尔时佛在波婆城。有一摩罗。字楼延。是阿难白衣时亲友。时阿难着衣持钵往其家就座而坐。楼延出行不在。阿难问其妇言。楼延在不。答言不在。阿难言。取衣簏来。即取置阿难前。时阿难即取大价衣。持还至僧伽蓝中。为诸上座作拭面巾拭身巾。时楼延摩罗行还。其妇以此事语夫其夫即来到僧伽蓝中。至阿难所问言。汝至我家耶。答言至。汝有所取耶。答言有所取。何故取粗不取好者。阿难言。我正须如是衣。诸比丘作如是念。白衣亲厚。应取如是衣不。白佛。佛言应取。何者是亲厚应取。如阿难于楼延摩罗应取。诸比丘言。若主不在应取不。佛言。听亲厚者若在若不在应取。尔时佛在舍卫国。不就请食。诸佛常法。若不就请。在后按行诸房。按行诸房时。见有异处有比丘病。无有瞻视供养人卧大小便中。见已诣比丘所。知而故问比丘。汝何故卧大小便中。有瞻视供养人不。答言无。世尊复问。何故无。答言。我无病时不看他病。是故今病无人瞻视供养者。佛言。汝不瞻视不供养病人。无利无所得。汝曹比丘不相看视。谁当应看病者。时世尊即扶病比丘起。拭身不净。拭已洗之。洗已复为浣衣晒干。有故坏卧草弃之。扫除住处。以泥浆涂洒。极令清净。更敷新草并敷一衣。还安卧病比丘已。复以一衣覆上舍去。尔时世尊食已。以此因缘集比丘僧。以向者不就请。在后行房所。见病比丘自料理事。具告诸比丘已。汝曹比丘自今已去。应看病比丘。不应不看。应作瞻病人。不应不作瞻病人。若有欲供养我者。当供养病人。听彼比丘和尚若同和尚阿阇梨若同阿阇梨若弟子应瞻视。若都无有人看。众僧应与瞻病人。若不肯者。应次第差。若次第差不肯如法治。若无比丘。比丘尼随所可作应作。不应触比丘。若无比丘尼。式叉摩那随所可作应作。不应触比丘。若无式叉摩那。沙弥应作。若无沙弥。沙弥尼随所可作应作。不应触比丘。若无沙弥尼。优婆塞应作。若无优婆塞。优婆私随所可作应作。不应触比丘。病人有五事难看。所不应食而欲食不肯服药。看病人有至心而不如实语。应行不行应住不住。身有苦痛不能堪忍。身少有堪能而不作仰他作。病者有如是五事难。看病人有五法易看。不应食者不食喜服药。如实语瞻病者。应行便行不应行不行应住便住。身有苦痛能忍。身少有能作便作病人有如是五事易看。病人复有五法难看。四事如上。第五事不能静坐止息内心。有此五事难看。病人有五事易看。四事如上。第五能静坐止息内心。病人有如是五事易看。尔时有比丘。在拘萨罗国道路行。至一小住处。见有病比丘。无有瞻视者。卧大小便中。彼作如是念。世尊有教。应看病人。不应不看。应作瞻病人。不应不作瞻病人。应供养病人。不应不供养病人。其有供养病人。是为供养我。彼即便瞻病人。病者死。尔时比丘。持亡者衣钵。往舍卫国只桓精舍中。往佛所头面礼足。以此因缘具白世尊。世尊言。善哉善哉。比丘。汝乃能瞻视病比丘。正应供养病比丘。作瞻病比丘人。供养病比丘。是为供养我。彼持亡比丘衣钵坐具针筒来。此住处现前僧应分。尔时世尊告诸比丘。持亡比丘衣钵坐具针筒与瞻病者。应作白二羯磨如是与。时瞻病人。应至僧中偏露右肩脱革屣礼僧足。白如是。大德僧听。某甲比丘。彼住处命过。衣钵坐具针筒盛衣贮器。此住处现前僧应分。如是第二第三说。僧中当差堪能作羯磨者。若上座若次座。若诵律若不诵律。堪能作羯磨者作如是白。大德僧听。某甲比丘命过。所有衣钵坐具针筒盛衣贮器。此住处现前僧应分。若僧时到僧忍听。与某甲看病比丘白如是。大德僧听。某甲比丘命过。所有衣钵坐具针筒盛衣贮器。此住处现前僧应分。僧今与某甲看病比丘。谁诸长老忍。与某甲看病比丘衣钵坐具针筒盛衣贮器者默然。谁不忍者说。僧已忍。与某甲看病比丘衣钵坐具针筒盛衣贮器竟。僧忍默然故。是事如是持(若僧中羯磨。差一人令分亡者衣物羯磨。与此无异。唯益一句言。僧与某甲比丘衣。某甲比丘当还。与僧白如是)

尔时舍卫国。有多知识比丘死。彼有多三衣。诸比丘不知。以何者与瞻病人。诸比丘白佛。佛言。听彼亡者常所侍者与。佛听与瞻病者衣。时有比丘小小瞻病。或一扶起。或一扶卧。或一与杨枝水。便取彼衣钵。佛言。不应如是小小瞻病便取彼衣钵。有五法看病人不应取病人衣物。何等五。一不知病者可食不可食。可食而不与。不可食而与。二恶贱病人大小便唾吐。三无有慈愍心为衣食故。四不能为病人经理汤药乃至差若死。五不能为病人说法令病者欢喜。己身于善法损减。有如是五法。不应取病人衣物。有五法应与看病人衣物。何等五。一知病人可食不可食。可食能与。二者不恶贱病人大小便唾吐。三者有慈愍心不为衣食。四者能经理汤药乃至差若死。五者能为病人说法。令病者欢喜。己身于善法增益。有如是五法。应取病人衣物。若病人临欲终时。有如是言。我此众物。与佛与法。若与僧。若与塔。若与人。若我终后与。若不死还我。佛言。不应如是与。应现前僧分。彼病比丘作如是念。我当受不好三衣。恐瞻病者取去。佛言不应作如是念。我受不好三衣。恐瞻病者取去。应受好者。时病人捉衣钵送着余处。恐瞻病人取。后病差无所著。诸比丘白佛。佛言。不应作如是意。送衣余处。恐瞻病者得。尔时舍卫国有多知识比丘命过。彼比丘多三衣。诸比丘不知持何等衣与瞻病比丘。比丘白佛。佛言。应看此瞻病人云何。若能极上瞻病。应与上三衣。若中与中三衣。若下与下三衣。尔时舍卫国有负债比丘命过。诸比丘不知谁当偿白佛。佛言。听持长衣偿。若无物卖三衣与。有余与瞻病人。听瞻病人问病比丘。何者是三衣。何者是长衣。汝负谁。谁负汝。汝应与谁。若不问如法治。时有病比丘。身患疮污衣卧具。佛言。听畜覆身衣。或有衣毛结[卄/毦]着疮。或时患痛佛言。听取大价好衣覆身着内外着涅槃僧。若至白衣舍。应语言。我患疮。若白衣言无苦但坐。应褰涅槃僧坐。尔时比丘患下脱痔病。以粗木作筹草患痛。佛言。听以毳若劫贝若鸟毛故衣物拭之。用竟举置不浣。诸比丘见便污贱白佛。佛言。不应用竟举置不浣应浣。彼浣已不绞去水烂坏虫生。佛言。应绞去水晒令干。时有病比丘。身患疮污衣卧具。白佛。佛言。听畜覆疮衣。若自无衣。听僧中取衣作。作已彼比丘不敢移此住处。覆疮衣着余处。白佛。佛言听移。比丘后疮差。不持还本处白佛。佛言。若差应浣染治还本处。若不还如法治。尔时六群比丘作帐。诸白衣见皆共讥嫌。沙门释子。无有止足不知惭愧。自言我知正法。如是何有正法。犹如国王大臣。诸比丘白佛。佛言。不应作帐。时有比丘。在露处大小便露形。诸比丘白佛。佛言。听以草若树叶若树枝伊梨延陀耄罗耄耄罗若氍氀作覆障。尔时六群比丘作幰。时诸白衣见皆共讥嫌言。沙门释子。无有止足不知惭愧。自言我知正法。如是何有正法。犹如国王大臣。诸比丘白佛。佛言不应作幰。时诸比丘道行患热。白佛。佛言。听以草若叶十种衣中若一一衣作覆障。尔时众僧得复衣。佛言听畜。时比丘不知持三衣。佛言。应受持。若疑应舍已更受若有三衣不受持突吉罗。佛如是语。应受持三衣。彼受小小衣当三衣。若拭身巾若拭面巾卧毡白佛。佛言。不应持如是小小衣当三衣。佛言。听以长四肘广二肘衣作安陀会。广三肘长五肘作郁多罗僧僧伽梨亦如是。时诸比丘衣坏。佛言。听补治。彼不知云何补治。佛言。听着纳衣重綖编边随孔大小方圆补。时诸比丘不着割截衣入聚落。白衣见已皆讥嫌言。沙门释子。无有止足不知惭愧。自言我知正法。如是何有正法。不着割截衣入聚落。犹如外道。诸比丘白佛。佛言。不应不着割截衣入聚落。有五事因缘。留僧伽梨若疑恐怖。若雨若疑雨。若作僧伽梨未成。若浣若染。若坏色若坚举。有如是五事因缘。留僧伽梨。尔时比丘。反着僧伽梨入聚落。余比丘见不喜白佛。佛言。不应反着衣入聚落。比丘畏慎。不敢聚落外反着衣。风尘日曝虫鸟污秽。诸比丘白佛。佛言。听聚落外反着衣。尔时比丘。得缦衣广长足。即裁割作衣。少欲作帖叶衣白佛。佛言听作。尔时比丘。得缦衣广长足。欲作五纳衣白佛。佛言听作。时诸比丘衣犯舍白佛。佛言听舍。若于僧中若众多人若一人。应舍然后净施。不应不舍。应舍然后遣。不应不舍而遣。彼比丘不舍。便受用作三衣。作波利迦罗衣。故坏故烧用作非衣。若数数着。若不舍不应受用。作三衣波利迦罗衣。故坏故烧。用作非衣。若数数着。诸比丘作如是念。波利迦罗不现在前。得尼萨耆不。佛言不犯。彼不舍衣便着白佛。佛言不应不舍便着。彼比丘疑。不敢以舍堕衣与人。用作被衣。白佛。佛言。听与人听作被衣。时比丘畏慎烧衣夺衣漂衣。不敢着白佛。佛言听着。时比丘不舍衣。便与他贸易白佛。佛言。不应不舍衣。应舍然后贸易。诸比丘如是念。众僧衣过十日犯舍堕不白佛。佛言不犯。时比丘净施衣不还主犯突吉罗。若遮不与者突吉罗。时诸比丘不染衣不坏色便寄白衣舍。白衣取着白佛。佛言。不应不染及坏色便寄白衣舍。应染坏色作沙门衣然后寄白衣舍。尔时比丘得上狭下广衣。受用作僧祇支白佛。佛言听作。尔时异住处现前僧。大得可分衣物。六群比丘出界外共分。诸比丘白佛。佛言。不应出界外分。时有长老比丘多知识人间游行。大得现前僧应分衣物。难分彼畏慎佛不听出界外分衣。诸比丘以此事白佛。佛言应如是唱令言来向某甲。某甲处分衣。若可分衣应分。彼不知何时分。应作相若量时量影。若作烟。若吹贝。若打鼓。若打揵槌。若白时至。若自来。若遣人来。应与分。彼诸比丘转易卧具。佛言不应移易。或有房多卧具。或有房少卧具。佛言。自今已去。听旧住人若摩摩帝若经营人若次得房者应问然后移转。彼比丘移卧具已。去时不还复本处。余比丘复用。佛言。应复卧具着本处而去。若不者当如法治。时房舍崩坏。诸比丘畏慎。不敢移转卧具。佛有如是言。不应移转卧具。诸比丘白佛。佛言。若房舍崩坏。应移转卧具。彼移转卧具着余房。余房不敢卧便烂坏白佛。佛言。应用卧时。佛听用卧。诸比丘便不洗脚不拭脚。用作衬体衣。诸比丘白佛。佛言不应不洗脚不拭脚。用作衬体衣佛既不听作衬体衣。诸比丘畏慎。不敢手脚近。诸比丘白佛。佛言。从腋至膝不应衬体。时诸白衣。施比丘衬体衣。比丘畏慎不敢受白佛。佛言。应随檀越施衣应受。彼坏房舍已治。不还复卧具。比丘白佛。佛言。若房舍已治。应还复卧具。若不复者应如法治彼诸比丘从此住处移定卧具至彼处白佛。佛言。不应移此住处定卧具至彼处。有国土人民反乱恐怖住处亦坏彼畏慎不敢移卧具。佛不听移此住处定卧具至彼处。诸比丘白佛。佛言。若有如是事听移。彼移卧具时。畏衬体不敢藏覆言世尊不听作衬体衣。诸比丘白佛。佛言。随所方便覆藏应移。若余人驱起。不应起。亦不应驱他起。若有余比丘能爱护者应与。若复国土还复。人民还安房舍治竟。不还复卧具。诸比丘白佛。佛言若尔不还复卧具。当如法治。尔时舍利弗。得上色碎段衣财。欲作五纳衣。白佛。佛言听作。尔时有住处。现前僧大得可分衣物。六群比丘各相推倚。不肯藏举遂失去。诸比丘白佛。佛言。听及有见者应收举。时客比丘来。移衣物着余房。不坚牢白佛。佛言。听别房结作库藏屋。白二羯磨唱房名。若温室若重屋若经行屋是中差堪能作羯磨者。如上作如是白。大德僧听。若僧时到僧忍听。僧结某甲房作库藏屋白如是。大德僧听僧结某甲房作库藏屋。谁诸长老忍。僧结某甲房作库藏屋者默然。谁不忍者说。僧已忍。结某甲房作库藏屋竟。僧忍默然故。是事如是持。时彼库藏屋。无人守不坚牢。听差守物人白二羯磨差。众中当差堪能作羯磨者。如上作如是白。大德僧听。若僧时到僧忍听。僧差某甲比丘作守物人白如是。大德僧听。僧差某甲比丘作守物人。谁诸长老忍。僧差某甲比丘作守物人者默然。谁不忍者说。僧已忍。差某甲比丘作守物人竟。僧忍默然故。是事如是持。若比丘不肯作守物人。应福饶与粥。若故不肯。一切所受衣食分应与二分。若故复不肯。当如法治。尔时毗舍佉无夷罗母大作浴衣。遣人送至精舍中。诸比丘不知当云何。白佛。佛言。随上座次分。若不足应识次。更得应续次与。彼时得大贵价衣续次与。佛言。不应以贵价衣续次与。应从上座与。若得不等者。应僧中取可分衣物足令等分之。尔时僧得鸯伽那罗衣。比丘白佛。佛言听畜。时比丘着僧覆身衣。至温室食堂中。羹饭污泥烟熏坌尘白佛。佛言。不应着僧覆身衣至温室食堂中。时诸比丘冬月患寒白佛。佛言听着。当爱护勿令污泥。时比丘即着至厕上。大小便污泥臭秽白佛。佛言。不应着至厕上。时比丘送衣还房。大小便急。诸比丘白佛。佛言。厕边若有衣架若龙牙杙若有屋。若有树若草若有石。听持衣着上。若天雨渍应着无雨处。若雨傍来渍应着好捉不令触厕户上厕。正安脚好蹲令不污衣。彼比丘着衣至经行处。草着虫着尘坌露渍坏僧衣。比丘白佛。佛言。不应着僧衣至经行处。尔时有上座病比丘。羸老远道来有患苦听着。敷卧毡置上爱护而卧。尔时有比丘。在异住处结夏安居已。复于余住处住。彼不知当于何住处取安居物。诸比丘白佛。佛言。听住日多处应取。若二处俱等。听各取半。彼比丘分夏安居食白佛。佛言。不应分。随施应食。尔时世尊。受毗兰若婆罗门请竟。告阿难言。汝往语毗兰若婆罗门。佛受汝三月请夏安居竟。今欲人间游行。阿难受世尊教。即往毗兰若所语言。世尊如是语。受汝夏三月安居请已竟。今欲人间游行。时毗兰若。闻阿难语已。方自忆。我请沙门瞿昙及比丘僧。九十日中竟不供养。时毗兰若即往世尊所。恭敬问讯已。却坐一面。时世尊以无数方便为说法令欢喜。毗兰若闻佛说法极大欢喜。即白佛言。唯愿世尊及比丘僧。更受我九十日请。佛答言。已受汝九十日请已。今欲人间游行。复白佛言。愿受我明日请食。世尊默然受请。时毗兰若。闻佛受请已。即从坐起。欢喜绕佛而去。即于其夜办具种种饮食。明日清旦往白时到。尔时世尊与五百比丘僧俱。着衣持钵往诣其家就座而坐。时毗兰若。以种种多美饮食。供养佛及比丘僧。食已舍钵。以三衣布施世尊比丘僧。人与两端叠为夏衣。比丘不受言。佛未听我曹受夏衣白佛。佛言听受尔时六群比丘跋难陀。闻佛听受夏衣。于春夏冬一切时求索夏衣。夏安居未竟。亦乞衣亦受衣。时跋难陀释子。在一住处安居。闻有异住处大得夏安居衣。即往彼住处问言。汝曹分夏衣未耶。答言未分。语言。持来与汝分。复往余处问言。汝分夏衣未。答言未分。语言。持来与汝分。时跋难陀。在多处分衣。得多衣分。持来入只桓。余比丘见问言。世尊制听畜三衣。此多衣是谁衣耶。彼言。我于多住处分衣。故大得此多衣。其中有少欲知足行头陀知惭愧乐学戒者。嫌责六群比丘跋难陀言。世尊听比丘受夏衣。汝云何便于春夏冬一切时求索夏衣。夏安居未竟。亦乞衣亦受衣。此处安居受衣分。复于余处受衣分。诸比丘往世尊所。以此因缘具白世尊。世尊尔时集比丘僧。无数方便呵责跋难陀语言。汝所为非。非威仪非沙门法。非净行非随顺行。所不应为。跋难陀。我听比丘畜夏衣。汝云何于春夏冬一切时求索夏衣。安居未竟亦乞衣亦受衣。于此安居受衣分。复于异处受衣分耶。以无数方便呵责六群比丘跋难陀已。告诸比丘。自今已去。不应于一切时春夏冬求索夏衣。安居未竟亦乞衣亦受衣。亦不应此处安居受衣分已复于余处受衣分。若受者应如法治。尔时有比丘。未分夏衣便去。后比丘分夏衣。彼比丘行还问言。夏衣分未。答言已分。问言。取我衣分不。答言不取。时彼比丘。嗔责余比丘言。未分衣我出行。后分夏衣。我在此安居。而不取我衣分。诸比丘作如是念。是成分衣不。往白佛。佛言。成分衣。应相待。亦应嘱授后人受夏衣分。时有比丘未分衣便去。漫嘱授后人受我衣分。后诸比丘分衣问。谁为某甲比丘取衣分。时无有为取衣分者。彼比丘还问分衣未答言已分。问取我分不。答言不取。彼比丘嗔责余比丘言。未分衣我出行。嘱授后人为我取衣我在此安居而分衣不为我取分耶。诸比丘作如是念。为成分衣不。往白佛。佛言成分。应待还亦应的嘱授一人。时有比丘未分衣出行。嘱授一比丘为我取夏衣。时比丘分衣。问言。谁取某甲比丘衣分。受嘱授者忘不取。诸比丘即分衣彼比丘还问言。分夏衣未。答言已分。问言。取我分不。答言不取。彼比丘嗔责余比丘言。未分衣我出行。后嘱授一比丘。取我衣分。我在此安居而不为我取衣分。诸比丘不知成分衣不。往白佛。佛言成分。是忘者过。时诸比丘留夏安居食白佛。佛言不应留。应随施受。尔时舍利弗目连般涅槃。多有可分衣物。现前僧应分。彼比丘留过安居。诸比丘白佛。佛言。不应留。此衣现前僧应分。彼时有一檀越。为欲施塔施僧。僧伽蓝房舍施浴池。若为初生儿。若为初剃发。若长发若入新舍。若为亡人作会。现前僧大得可分衣物。诸比丘留至夏安居。比丘往白佛。佛言。不应留。此是非时衣。现前僧应分。尔时有一比丘住处。大得夏安居衣物。彼作如是念。我当云何。白诸比丘。诸比丘白佛。佛言。若有一比丘安居。大得僧夏安居衣物。彼比丘应作心念言。此是我物。若受若不受。有余比丘来。不应得分。尔时诸比丘大得可分衣物。僧破为二部。诸比丘白佛。佛言。应分为二分。若未得可分衣物。僧破为二部。佛言。应问檀越当与谁。若彼言。与某甲某甲上座。即应随彼语上座所在处与。若彼言不知。若言俱与。应分作二分。尔时诸比丘。已得衣未得衣。僧破为二部。已得衣者。应分作二分。未得衣者。应问檀越。当与谁。彼若言。与某甲某甲上座。即应随彼语上座所在处与。若彼言不知。若言俱与。应分为二分。尔时诸比丘。得可分衣物。有比丘从此部往彼部。彼不应与分。若未得衣物。有比丘从此部往彼部。不应与分。若得衣物未得衣物。有比丘从此部往彼部。不应与衣分。尔时有比丘。从此部往彼部。未至便死。诸比丘不知。其衣钵当与谁白佛。佛言随其所欲往处应与。尔时有比丘。从此部往彼部至便死。诸比丘不知其衣钵当与谁白佛。佛言。随彼所往部应与。尔时有比丘。被举已命过。诸比丘不知其衣钵当与谁白佛。佛言。随所共同羯磨举僧应与。尔时住处僧破为二部。有檀越请此二部僧。一处饭食并布施衣布施缕。诸比丘不知谁应得衣谁应得缕白佛。佛言。应问檀越。衣与谁缕与谁。若言与某甲某甲上座。应随彼语所在处上座与。若言不知。若言俱与。应分作二分。尔时众僧得夏安居衣。僧破为二部白佛。佛言。应数人多少分。若未得安居衣。僧破为二部白佛。佛言。应数人分。若得夏衣。若未得夏衣。僧破为二部。应数人分。时有比丘得夏衣往余部。佛言应与。若未得夏衣往余部。佛言应与。若未得夏衣。若已得夏衣往余部。佛言应与。尔时有一居士。集比丘住处。诸处僧供养饭食。以衣布施。诸比丘不知云何白佛。佛言。有八种施衣。若与比丘僧。若与比丘尼僧。若与二部僧。若与四方僧。若与界内僧。若与同羯磨僧。若称名字与。若与一人。佛言。若与比丘僧。比丘僧应分。若与乃至一人。应属一人。尔时诸比丘冬月患寒白佛。佛言。听着帽。露地坐患背痛。佛言。听作禅带。尔时比丘身患疮若污臭。佛言。听作拭身巾。若面污。听作拭面巾。若患眼泪。听作扪泪巾。尔时毕陵伽婆蹉。得大贵价疏衣。彼欲作夏衣畜白佛。佛言。听净施持。净施有二种。一真实净施。二展转净施。真实净施者言。大德一心念。我有此长衣未净施。今为净故。舍与大德。为真实净故。展转净施者言。大德一心念。此是我长衣未作净。为净故施与大德。为展转净故。彼受净者。即应作如是言。大德一心念。汝有长衣未作净。为净故与我。我今受之。受已当语言。汝施与谁。彼应言施与某甲。受净者应作如是言。大德一心念。汝是长衣未作净。为净故施与我。我今受之。受已汝今与某甲。是衣某甲已有。汝为某甲。善护持着随因缘作。真实净施者。应问主然后得着。展转净施者。若问若不问随意着。尔时比丘遣使借与某甲比丘衣。作彼亲厚意取衣应取不。佛言。不应作亲厚意取。若至道路应作亲厚意取不。佛言。不应取。若至彼应作亲厚意取不。佛言。不应取。若作遣衣主。亲厚意取衣应取不。佛言。应取。若至道路应取不。佛言应取。若至彼应取不。佛言应取。所遣借与衣比丘命过。即作彼命过比丘衣受应受不。佛言。不应受若至道路应受不。佛言。不应受。若至彼应受不。佛言。不应受。若遣人借与比丘衣衣主命过。彼比丘应即作命过比丘衣受不。佛言应受。若至道路应受不。佛言应受。若至彼应受不。佛言应受。尔时有比丘。遣衣与某甲比丘。彼使作遣衣主亲厚意取衣应取不。佛言。不应取。若至道路应取不。佛言。不应取。若至彼应取不。佛言。不应取。彼比丘若作所遣与衣比丘亲厚意取衣应取不。佛言应取。若至道路应取不。佛言应取。若至彼应取不。佛言应取。彼所遣衣主比丘命过。彼比丘即作命过衣受应受不。佛言。不应受。若至道路应受不。佛言。不应受。若至彼应受不。佛言。不应受。若所遣与衣比丘命过。彼比丘即作彼命过衣受应受不。佛言应受。若至道路应受不。佛言应受。若至彼应受不。佛言应受。尔时有居士。持衣来至僧伽蓝中言。与某甲比丘。此衣与大德。彼比丘言我不须。即持衣置比丘前而去。彼比丘有畏慎。不知云何。诸比丘白佛。佛言。听为施主故赏录。若须时听受持(衣揵度具足竟)

四分律卷第四十一四分律卷第四十二(三分之六)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    药揵度之一

尔时佛在波罗奈国。时五比丘。往世尊所。头面礼足却住一面。白佛言。大德。当食何食。佛言。听乞食食五种食。尔时比丘乞食得饭。佛言听食。得种种饭粳米饭大麦饭[序-予+禾]米饭粟米饭俱跋陀罗饭。佛言。听食如是种种饭得糗。佛言。听食种种糗。得干饭。佛言。听食种种干饭得鱼。佛言。听食种种鱼得肉。佛言。听食种种肉得羹。佛言。听食种种羹。得修步。佛言听食得乳。佛言。听食种种乳得酪。佛言。听食种种酪得酪浆。佛言。听饮种种酪浆。得吉罗罗。佛言听食得蔓[少/兔]。佛言。听食种种蔓[少/兔]得菜。佛言听食种种菜。得佉阇尼食。佛言。听食种种佉阇尼食。佉阇尼者。根食茎食叶食华食果食油食胡麻食石蜜食蒸食。尔时世尊。在波罗奈国。时五比丘即从坐起。前礼佛足却住一面。白佛言。当服何药。佛言。听服腐烂药。病比丘有因缘尽形寿应服。尔时世尊在绳床中。时有病比丘。医教服呵梨勒。佛言。听病比丘。有因缘尽形寿服呵梨勒。尔时佛在舍卫国。时有比丘患风。医教服酢麦汁。佛言听服。不知云何作。佛言。听净人净洗器渍麦乃至烂漉取汁饮。若麦汁臭应覆。若汁滓俱出听作漉器。不知云何作器。佛言。听若铜若木若竹作漉器。如漉水筒作。若三角若大若小。若麦中燥。令净人更益水。时病比丘。在多人前饮麦浆。余比丘见皆共恶秽之。佛言。不应在多人前。应在屏处饮。时一切僧皆须。佛言。应一切共饮。时有诸比丘。各各别用器饮。众器皆臭。佛言。不应各别器饮。应共传用一器饮。时有比丘饮已不洗器与余比丘。佛言。不应尔。应洗器已与余比丘。尔时佛在舍卫国。有比丘吐下。比煮粥顷日时已过。佛言。听以完全麦若完全稻谷煮令熟。勿使破漉汁饮。尔时有病比丘。医教服鞞醯勒。佛言听服。医教服阿摩勒。佛言听服。若比丘有病因缘尽形寿服。尔时有病比丘。医教服[卄/(麩-夫+生)]罗。佛言。听比丘有病因缘。尽形寿服。尔时病比丘。医教服果药。佛言听服。若非是常食者。比丘有病因缘。尽形寿应服。尔时有病比丘。须大五种根药。佛言听服。须小五种根药。佛言听服。比丘有病因缘尽形寿服。尔时病比丘。医教服质多罗药。佛言。病比丘有因缘尽形寿听服。尔时有病比丘。医教服罽沙药。佛言。病比丘有因缘尽形寿听服。是中罽沙者。根茎叶花果罽沙。尔时有病比丘。医教服娑梨娑婆药。佛言。病比丘听服。娑梨娑婆者。根茎叶花果若坚韧者也。式渠亦如是。帝菟(底吐二音)亦如是。尔时病比丘。医教服荜茇椒。佛言。比丘有病因缘听尽形寿服。尔时病比丘须种种细末药洗。佛言。听用种种细末药。是中细末药者。胡桐树末。马耳树末。舍摩罗树末洗。若自作若更互作须杵臼。佛言听畜。须簸箕簁扫帚。佛言听畜。时诸比丘畏慎。不敢以涂香着末药中。佛言听着。时末药无器盛。佛言。听作瓶。若患坌尘。听作盖。若欲令坚牢。当着床下。若串壁上象牙杙上。尔时病比丘。以粗末药洗身患痛。佛言。听细末若细泥。若叶若华若果取令病者得乐。是中病者。若体有疮若癣若瘑若疥癞乃至身臭。尔时比丘病。须盐为药。佛言听服。是中盐者。明盐黑盐。丸盐楼魔盐支。头鞞盐卤盐灰盐新陀婆盐施卢鞞盐海盐。若比丘有病因缘尽形寿听服。尔时病比丘须灰药。佛言。听用灰药。是中灰药者。萨阇灰宾那灰波罗摩灰。比丘有病因缘。尽形寿听用。尔时病比丘须阇婆药。佛言听用。是中阇婆者。馨牛馨莪婆提尸婆梨陀步梯夜婆提萨阇罗婆。比丘有病因缘尽形寿应服。尔时比丘病须眼药。佛言听用。是中眼药者。陀婆阇那耆罗阇那。比丘有病因缘尽形寿应服。尔时比丘眼有白翳生须人血白佛。佛言听用。尔时比丘患眼白翳须人骨。佛言听用。尔时比丘患眼白翳须细软发。听烧末着眼中。尔时毕陵伽婆蹉。患眼痛得琉璃篦。佛言。听为治眼病故畜用。尔时舍利弗患风。医教食藕根。尔时大目揵连。往舍利弗所问讯已一面坐。语舍利弗言。所患为差不。答言未差。复问舍利弗。何所须。答言。须藕根。目连言。东方有阿耨大池。水清澄无有尘秽。食之无患。去此不远。更有池广五十由旬。其水清澄无有尘秽。有藕根如车轴。若取折之。其汁如乳食之如蜜。去池不远。有金山崖高五十由旬。是中有七大龙象王兄弟共住。其最少者。供给一阎浮提王。其次大者。供给二天下王。其次转大者。供给四天下转轮圣王。伊罗婆尼龙象王。供给天帝释。彼诸龙象王。来下入池净澡浴饮水。以鼻拔取藕根。净洗泥秽而食之。得好容色气力充足。彼池藕根可得食之。时舍利弗默然可之。时目连见舍利弗默然。即于舍卫国没不现。如人屈申臂顷。至彼池边。化作大龙象王。于彼七象王中形色最胜。时彼七龙象王。见皆畏怖毛竖。恐彼来夺我池。尔时大目连。见彼七龙象王心怀恐怖。即还复故身。彼即问目连言。比丘何所须欲耶。答言。我须藕根。语言。汝须藕根何不早见语。使我恐怖毛竖。彼即入池澡浴饮水。以鼻拔取藕根洗去泥授与目连。时目连得藕根已。从此池忽然不现。还舍卫国。到只桓中。授与舍利弗语言。此是藕根。舍利弗食已病即得除差。有残藕根与看病人。看病人先已受请。不肯食之。诸比丘白佛。佛言听看病人受请不受请。食病人残食。诸比丘先受食已。至彼聚落。有檀越便请食。食已来还至僧伽蓝中。持向者食与诸比丘。诸比丘先已受请不敢受。无人食者便弃之。时有众乌鸟诤食唤呼。尔时世尊。知而故问阿难。诸乌鸟何故唤呼。阿难以此事具白世尊。世尊言。自今已去。听作余食法食。彼应持食至彼比丘前语言。大德我已受请。若已食。看是知是作余食法。彼应取少食之语言。我已食。止汝可食之。应作如是余食法食。尔时有长老上座多知识。村间乞食来。聚在一处食。食已。持残食来至僧伽蓝中。与诸比丘。诸比丘先已受请。不肯食之。无人食者便弃之。时有众乌鸟诤食唤呼。世尊知而故问阿难。诸乌鸟何故唤呼。阿难以此事具白世尊。世尊言。自今已去。听自持食来作余食法得食。应如是作。持食至彼比丘所语言。大德。我已受请。若已食。看是知是作余食法。彼应取少食食已语言。我止汝可食。应作如是余食法食。尔时毗舍佉无夷罗母。大得新果。彼作如是念。我今宁可作食请佛及僧以果布施。即便遣人往僧伽蓝中白言。愿诸大德。受我明日请食。即于其夜办种种美食。明日往白时至。尔时世尊着衣持钵。与千二百五十比丘俱。就毗舍佉无夷罗母请就座而坐。毗舍佉以种种多美饭食饭佛及僧。食已舍钵。更取一卑床却坐一面。时世尊种种方便开化说法。令得欢喜。尔时世尊为说法已从坐而去。时毗舍佉无夷罗母。行食忘不与果。彼作如是念。我为新果故。请佛及僧设饭。今正行食。忘不与果。时即遣人送果至僧伽蓝中。与诸比丘。诸比丘已食竟。不肯受之。往白佛。佛言。若从彼来。应作余食法食之如上法。尔时世尊在王舍城。时有颠狂病比丘。至杀牛处。食生肉饮血。病即差。还复本心畏慎。诸比丘白佛。佛言不犯。若有余比丘。有如是病。食生肉饮血病得差者。听食尔时世尊在波罗奈国。时世谷贵乞食难得。时诸比丘乞食不得。往至象厩乞。时彼有鬼神信敬沙门者。即令象死于彼得象肉食之。世尊慈念告诸比丘。此是王之兵众。若王闻者必不欢喜。自今已去。不应食象肉。时诸比丘。在波罗奈国乞食不得。往马厩乞。时有信敬沙门鬼神。即令马死。于彼得马肉食之。世尊慈愍告诸比丘。此是王之兵众。若王闻者必不欢喜。自今已去。不应食马肉。尔时比丘。于波罗奈国乞食不得。至能水底行人所乞。时有信敬沙门鬼神。令诸龙死。于彼得龙肉食之。尔时善现龙王。从己池出。往世尊所。头面礼足已。却住一面白佛言。世尊。有龙能烧一国土。若减一国土。诸比丘食此龙肉。善哉世尊。勿令比丘食龙肉。时世尊闻善现龙王语默然受之。时善现见佛听许。头面礼佛已还往本处。尔时世尊。以此因缘集比丘僧告言。此龙有大神力有威德。能烧一国土。若减一国土。诸比丘食此肉。自今已去。不应食龙肉。时有比丘。在波罗奈国乞食不得。往旃陀罗家。于彼得狗肉食之。诸比丘乞食。诸狗憎逐吠之。诸比丘作是念。我等或能食狗肉。故使众狗憎逐吠我耳。诸比丘白佛。佛言。自今已去。不得食狗肉。若食得突吉罗。时世尊在波罗奈国。时有比丘。服吐下药。有优婆私字苏卑。至僧伽蓝中。行看房舍。至病比丘所问言。何所患苦耶。答言。服吐下药。问比丘。何所须欲。答言须肉。答言。我当送肉即还波罗奈。遣人持钱买肉。语言男子。持此钱买肉来。时波罗奈不屠杀。彼人周行求肉不得。还至优婆私所白言。大家知不。今此不杀。遍行求肉不得。优婆私作如是念。我许与吐下比丘肉。恐此比丘不得肉。或能命过。若是生死比丘命过者。于出家法中退。若是学人不得前进。若是罗汉。则使世间失于福田即入后室。持利刀自割髀裹肉。与婢令煮已。持往僧伽蓝中。与吐下比丘。婢即如敕持与比丘。比丘食已病即除差。彼优婆私割肉时。举身患痛极为苦恼时优婆私夫主先出行还。不见苏卑。即问。苏卑优婆私何处在耶。答言病在内。即问何所患。即具答因缘。彼夫主言。未曾有苏卑于沙门所有如是信乐。无所爱惜乃至身肉。苏卑优婆私作是念。我今患苦极重。或能以此断命。我今宁可办具种种饮食请佛及僧。可作最后见佛及僧因缘。时即遣人往僧伽蓝中白言。大德。明日受我请食。时世尊默然受之。即于其夜办具种种美好饮食。明日往白时到。时世尊着衣持钵。与诸比丘僧俱。往苏卑优婆私家就座而坐。知而故问。优婆私苏卑何所在。答言病在内。佛言。唤优婆私苏卑来。彼即入内语言。佛唤汝。作如是念。世尊唤我。即便速起。身痛即止。疮复如故不异。时优婆私苏卑。往佛所头面礼足却住一面。佛告言。不应作是不应作是。苏卑优婆私。当作如是施如是学。不自苦痛。亦不恼彼。时苏卑优婆私。手自斟酌美好饮食。食已舍钵。取小床在一处坐。时世尊为优婆私。种种方便说法。令得欢喜。世尊为说法已。从坐而去还至僧伽蓝中。往吐下比丘所问言。苏卑优婆私送肉与汝不。答言与我肉问言汝食不。答言食。复问美不。答言美。如是美肉难得。佛言。汝痴人食人肉。自今已去。不得食人肉。若食偷兰遮。及余可恶肉不应食。若食突吉罗。尔时世尊在波罗捺。有居士耶输伽父。往诣佛所头面礼足却坐一面。尔时世尊。无数方便为说法开化。令得欢喜。耶输伽父。闻佛说法开化。心大欢喜已从坐起。白佛言。愿受我请。时耶输伽。侍从世尊后。时世尊默然受请。耶输伽不受请。佛未听我曹受别请。佛言。有二种请听受。若请僧若别请。尔时有异居士作是念。作何福德。令僧常得供养。我施不断绝。即白佛。佛言。听为僧常作食。彼作如是言。我不能常为众僧作食。作何福德令僧常得供养。我施不断绝。白佛。佛言。听比丘往其舍常与食。彼作是言。我不能常为道人作食。作何福德令僧常得供养我施不断绝。白佛。佛言。听僧差往食。若送食至僧中。若八日食。若布萨日。若月初日食。时有居士作是念。云何作福供养众僧便成施药。白佛。佛言听布施众僧药钱。时有居士。新作房舍无道人住念言。云何供养众僧。令诸比丘在此房住。白佛。佛言。听在房中作粥。若复不住。复听在房作种种饼及果。若故不住当与作饭食。若不住。听与房钱。若故不住。听与绳床木床坐褥卧褥枕地敷。若故不住。应与衬体衣与毡与被。若故不住。与钵与三衣。若故不住。应与作房排户钩与杖与革屣与盖与扇与水瓶与洗瓶若盛水器与浴室瓶及床与刮污刀与香熏与丸香与房衣。若故不住。沙门一切所须者应与。尔时世尊在绳床中。时诸比丘乞食。时见有人[(殼-一)/牛]牛乳。令犊子饮已复[(殼-一)/牛]。犊子口中涎沫出。与乳相似。后遂疑不复饮乳。白佛。佛言听饮。[(殼-一)/牛]乳法应尔。尔时世尊在舍卫国。时诸比丘秋月得病。颜色憔悴形体枯燥癣白。时世尊在静室作如是念。诸比丘秋月得病。颜色憔悴形体癣白枯燥。我今当听诸比丘食何等味。当食常药不令粗现。即念言。有五种药。是世常用者。酥油蜜生酥石蜜。我今宁可令诸比丘食之。当食常药不令粗现。如饭糗法作是念已。晡时从静处起。以此事集比丘僧。以向者在静处所思念事具告诸比丘。自今已去听诸比丘有病因缘听服五种药酥油生酥蜜石蜜。诸病比丘。得种种肥美食。至中不能食。况复五种药至中能食。尔时药虽多。病人不能及时服诸比丘患遂增形体枯燥颜色憔悴。尔时世尊。知而故问阿难。诸比丘何故形体颜色如是。时阿难具以上因缘白世尊。佛言。自今已去若比丘有病因缘。若时若非时。听服五种药。时诸病比丘得肥美食不能食。尽与看病人。看病人受请。不食即弃之。诸乌鸟诤食大唤呼。佛知而故问阿难。乌鸟何故尔。阿难具以因缘事白佛。佛言。听看病比丘。若受请若不受请。得食病人残食无犯。尔时舍利弗患风。医教服五种脂。罴脂鱼脂驴脂猪脂失守摩罗脂。白佛。佛言听服。时受时漉时煮如油法服。非时受非时漉非时煮不应服。若服如法治

尔时世尊。在舍卫国人间游行。与千二百五十比丘俱。时世谷贵人民饥饿乞食难得。有五百乞人常随佛后。尔时世尊。行未远。往至道边树下。敷尼师坛坐。时有居士。名私呵毗罗。调象师。乘五百乘车。载石蜜从道而过。于道中见佛足迹千辐轮相光明了了。即寻迹而去。遥见世尊在树下坐颜貌端正诸根寂静得上调伏犹如龙象王最胜无比譬如澄渊无有浊秽。见世尊已。信敬心生。即前头面礼足却坐一面。时世尊为私呵居士种种方便说法开化。令得欢喜。时私呵居士。闻佛说法极大欢喜。即施诸比丘人别一器黑石蜜。诸比丘不受。世尊未听我曹受黑石蜜。白佛。佛言。听受黑石蜜。佛语私呵。以一器黑石蜜。分与诸比丘。即受佛教。以一器黑石蜜。分与诸比丘。有余黑石蜜。佛言。应第二第三随意重与。故复有残。佛语私呵。与乞儿。与乞儿已。故复有残。佛语私呵。更随意第二第三饱与乞儿。故复有残。佛语私呵。以残黑石蜜着净地若无虫水中。何以故。未有见诸天世人诸魔梵王沙门婆罗门食此黑石蜜能消者。除如来无所著等正觉。时私呵即如教。持余黑石蜜。着无虫水中。水即烟出作声犹如烧大热铁着水中其声振裂。余黑石蜜着水中。亦复如是水沸作声。尔时私呵。见此已恐怖毛竖。往至佛所头面礼足却坐一面。以向因缘具白世尊。世尊尔时知私呵心怀恐怖毛竖。种种方便说法开化。令得欢喜。即于座上远尘离垢得法眼净。见法得法得增上果。白世尊言。大德。我归依佛法僧。为优婆塞。自今已去。不杀生乃至不饮酒。私呵闻佛说法。极大欢喜。头面礼佛而去。时比丘乞食时。见白衣作黑石蜜着罽尼。诸比丘疑不敢过中食。白佛。佛言听食。作法应尔。时诸比丘乞食得软黑石蜜。白佛。佛言听食。得黑石蜜浆。佛言听饮。得磨餐致佛言听食。得白石蜜。佛言听食。得乌婆陀颇尼。佛言听食。得水和甘蔗汁。佛言听饮。得甘蔗汁。佛言听饮。若不醉人。听非时饮若醉人不应饮。若饮如法治。得甘蔗。佛言听时食。尔时世尊。在摩竭提人间游行至王舍城。毕陵伽婆蹉。多知识多徒众。多得酥油生酥蜜黑石蜜。持与徒众。遂多积聚藏举众器皆满。大盆小盆大钵小钵奁大釜络囊漉囊。持串着壁上龙牙杙上向上。或悬着屋间。下漏上湿。房舍臭秽。时众多居士。来至僧伽蓝中行看房舍。见毕陵伽婆蹉徒众如是。多积聚饮食众药在房共宿臭秽不净。皆共讥嫌。沙门释子多贪无厌。自称我知正法。如是何有正法。观是沙门多积饮食众药。如似瓶沙王厨库。诸比丘闻。其中有少欲知足行头陀知惭愧乐学戒者。嫌责毕陵伽婆蹉言。云何多积饮食众药在房共宿臭秽不净。时诸比丘往白佛。尔时世尊。以此因缘集比丘僧。呵责毕陵伽婆蹉徒众。汝等所为非。非威仪非沙门法非净行非随顺行所不应为。云何多积饮食众药在房共宿臭秽不净。以无数方便呵责已。告诸比丘。自今已去。若病比丘。须酥油蜜生酥黑石蜜。乃至七日应服。若过服如法治。尔时世尊。从王舍城人间游行(此一条事如上展转食戒无异故不出)

尔时比丘患风须药。医教渍麦汁。佛言听服。须油渍麦汁。须颇尼渍麦汁。佛言听服。若时药和时药。非时药和时药。七日药和时药。尽形寿药和时药。应受作时药。非时药和非时药。七日药和非时药。尽形寿药和非时药。应受作非时药。七日药和七日药。尽形寿药和七日药。应受作七日药尽形寿药和尽形寿药。应受作尽形寿药

尔时比丘患疮。须唾涂以铫底熨。比丘白佛。佛言听用。时有比丘患疱医教用人脂。佛言听用。时有比丘患吐。须细软发。佛言。听烧已末之水和漉受饮之。时有比丘。自往冢间。取人发人脂持去。时诸居士。见皆憎恶污贱。诸比丘白佛。佛言听静无人时取。尔时有比丘患身热。医教用栴檀。为差病故。比丘白佛。佛言听用。若沉水若栴檀毕陵只伽罗[少/兔]婆罗。佛言听用涂身。时诸比丘患蛇入屋。未离欲比丘恐怖。佛言听惊。若以筒盛若以绳系弃之。而彼不解绳便置地蛇遂死。佛言。不应不解应解。时诸比丘患鼠入屋。未离欲比丘皆惊畏。佛言。应惊令出。若作鼠槛盛出弃之。竟不出置槛内即死。佛言。应出之不应不出。尔时诸比丘患蝎蜈蚣蚰蜒入屋。未离欲比丘惊畏。佛言。若以弊物若泥团若扫帚盛裹弃之。而不解放便死。佛言。不应不解放应解放。尔时佛在王舍城。诸比丘破浴室薪。空木中蛇出螫比丘杀。时世尊慈念。告诸比丘。彼比丘不生慈心于彼八龙王蛇。以是故。为蛇所杀。何等八。毗楼勒叉龙王。次名伽宁。次名瞿昙冥。次名施婆弥多罗。次名多奢伊罗婆尼。次名伽毗罗湿波罗。次名提头赖托龙王。比丘若慈心于彼八龙王蛇者。不为螫杀。若此比丘慈心于一切众生者。亦不为彼蛇所螫杀。佛听作自护慈念咒。毗楼勒叉慈。伽宁慈。瞿昙冥慈。施婆弥多罗慈。多奢伊罗摩尼慈。伽毗罗湿波罗慈。提头赖吒慈。慈念诸龙王乾闼婆罗刹娑。今我作慈心。除灭诸毒恶。从是得平复。断毒灭毒除毒。南无婆伽婆。佛言。听刀破出血以药涂之。亦听畜铍刀。尔时有比丘病毒。医教服腐烂药。若是已腐烂药堕地者。应以器盛水和之漉受然后服。若未堕地者。以器承之水和漉服之不须受。尔时病毒比丘。医教服田中泥。佛言。听以器盛水和之漉然后受饮。尔时世尊在王舍城。时耆婆童子。刀治比丘大小便处两腋下病。时世尊慈念告诸比丘此耆婆童子。刀治比丘大小便处及两腋下病。不应以刀治。何以故。刀利破肉深入故。自今已去。听以筋若毛绳急结之。若爪取使断皮然后着药。佛言。听作灰药。手持不坚牢。佛言听作盛灰药器。时器若易破。听角作。尔时世尊患风。医教和三种药。唤阿难取三种和药来。时阿难受佛教。自煮三种和药已授与佛。时世尊知而故问阿难。谁煮此药。答言我自煮。佛告阿难。不应自煮而服。若自煮如法治。尔时世尊在王舍城。与千二百五十比丘僧俱人间游行。时世谷贵人民饥饿乞求难得。时有六百乘车载满饮食随逐世尊。世尊尔时。从婆阇国人间游行至毗舍离。时诸净人。办具净食高声大语。或盖藏器物。时世尊知而故问阿难。诸比丘何以作此大声。犹如捕鱼人声耶。阿难白佛言。诸净人办具净食。高声大语。或盖藏器物。故有如是大声。佛告阿难。不应界内共食宿煮食食。若食如法治。尔时诸比丘。持食饮着露地不牢藏。牧牛羊人若贼持去。诸比丘白佛。佛言。应在边房静处结作净厨屋。尔时世尊在毗舍离。时有私呵将军。是尼揵弟子。时断事堂。有五百诸梨奢共坐食无数方便赞叹佛法僧。尔时私呵将军。在座中闻无数方便赞叹佛法僧。心生信乐。欲往见佛。彼作如是念。我今宁可白师尼揵往瞿昙所。时私呵即往白尼揵言。我欲往瞿昙沙门所。尼揵语言。汝说有作法。瞿昙说无作法以化弟子。止不须往。尔时私呵将军。本有见佛心即退诸梨奢。如是第二第三赞叹佛法僧。时私呵将军闻第二第三赞时作如是念。我今宁可不辞尼揵师往见瞿昙。师能使我作何等。时私呵即往佛所。头面礼足却坐一面。时世尊为无数方便说法开化。令得欢喜。私呵闻佛方便说法。心大欢喜。白佛言。我闻瞿昙说无作法以化诸弟子。若有人言。大德说无作法以化诸沙门。为是实语法语不耶。佛语私呵。或有因缘。方便言我说无作法以化诸弟子者。是实语法语。或有因缘。方便言我说有作法以化诸弟子者。是实语法语。或有因缘。方便言我说断灭法以化弟子。是实语法语。或有因缘。方便言我说秽恶法以化弟子。是实语法语。或有因缘。方便言我说调伏法以化弟子。是实语法语。或有因缘。方便言我说灭闇法以化弟子。是实语法语。或有因缘。方便言我说我生已尽不受后身以化弟子。是实语法语。或有因缘。方便言我到无畏处说无畏法以化弟子。是实语法语。佛语私呵。何以故。言我说无作法乃至到无畏处以化诸弟子。是实语法语。我说不作。身行恶。口言恶。心念恶。三种恶不善法不应作。我说作法者。三种善法应作。言我说断灭法者。断灭贪欲嗔恚愚痴。我说秽恶法者。秽恶身口意业不善法。我说调伏法者。调伏贪欲嗔恚愚痴。我说灭闇者。灭诸恶不善闇法。我说我生已尽者。我受生已尽不受胞胎。亦复化人断于生死。我说到无畏处者。自无所畏复安慰众生。以是故。私呵。有因缘故。言我说无作法乃至到无畏处以化诸弟子。是实语法语。私呵白世尊言。我归依佛法僧。自今已去。不杀生乃至不饮酒。佛语私呵。好自量宜。然后受戒。汝为国之大臣。人所知识。当益众人。莫轻举动后有悔也。私呵答言。我于外道沙门婆罗门作弟子时。持幡唱令国中言。私呵为尼揵作弟子。我今闻世尊重敕我言。好自量宜。然后受戒。汝为国之大臣。人所知识。当益众人。莫轻举动。益增信乐。复白佛言。大德。我今第二尽形寿归依佛法僧。不杀生乃至不饮酒。自今已去。于我门中不听尼楗外道来入。佛诸弟子比丘比丘尼优婆塞优婆夷。于我门中无所挂碍。佛语私呵。先尼楗外道。于汝家中昼夜受供养。如取泉水。今何得便断。复白佛言。我从外人闻。沙门瞿昙自称言。布施应与我。不应与余人。与我大得果报。与余人不得果报。应与我弟子。不应与余人弟子。与我弟子大得果报与余弟子不得果报。佛语私呵。我无是语。若人有慈心。以米泔汁若荡涤汁。弃着不净水虫中。使彼虫得此食气。我说彼犹有福。况复与人。我说布施持戒人得大果报。胜于破戒。私呵白佛言。如世尊所说。如世尊所说。我曹自知之。尔时世尊。无数方便为说法开化。令得欢喜。即于座上远尘离垢得法眼净。见法得法得果证。白佛言。我今第三尽形寿归依佛法僧。不杀生乃至不饮酒。唯愿世尊。受我明日请食。时世尊默然受之。时私呵见佛许已。即起礼佛足而去。于其夜办具种种美食。明日往白时到。世尊着衣持钵。与千二百五十比丘俱。往其家敷尼师坛就座而坐。尔时尼揵子等。往诣离奢住处。举手大哭称怨言。此私呵将军自杀大牛。与沙门瞿昙及诸比丘设饭食。为己杀知而故食之。尔时有人。即往私呵所语言。当知有诸尼揵子。往离奢住处。举手大哭称怨言。私呵将军自杀牛。为沙门瞿昙及比丘僧设饭食。私呵言。此常日夜。为佛比丘僧作怨家。我终不为命故断众生命。尔时私呵将军。以多美饭食。饭佛及比丘僧已。摄钵。更取一卑床在一面坐。佛为方便说法开化。令得欢喜。为说法已。从坐起而去。还僧伽蓝中。以此因缘集比丘僧告言。自今已去若故为杀者不应食。是中故为杀者。若故见故闻故疑。有如此三事因缘不净肉。我说不应食。若见为我故杀。若从可信人边闻为我故杀。若见家中有头有皮有毛。若见有脚血。又复此人能作十恶业常是杀者。能为我故杀。如是三种因缘不清净肉不应食。有三种净肉应食。若不故见不故闻不故疑应食。若不见为我故杀。不闻为我故杀。若不见家中有头脚皮毛血。又彼人非是杀者。乃至持十善。彼终不为我故断众生命。如是三种净肉应食。若作大祀处肉不应食。何以故。彼作如是意办具来者当与。是故不应食。若食如法治

尔时世尊。从毗舍离人间游行。与千二百五十比丘僧。俱至苏弥。从苏弥至跋提城住。时跋提城有大居士字旻茶是不兰迦叶弟子。大富多诸珍宝。多有象马车乘奴婢仆使食饮。仓库溢满有大威力。随意所欲周给人物。彼居士入仓时。如车轴孔自然谷出不休。乃至居士出去。其妇复有如是福力。以八斗米作食。供四部兵及四方来乞者。皆使饱足。食故不尽。乃至起去。其儿亦有如是福力。囊盛千两金。与四部兵及四方来乞者。随意令足。故不尽。乃至起去。其儿妇亦有如是福力。以一裹香。涂四部兵及四方来乞者。随意令足。香故不尽。乃至起去。其奴有如是福力。以一犁耕七垄出。其婢有如是福力。以八斗谷与四部兵不尽。乃至起去。其家里各各诤言。是我福力。尔时旻茶居士。闻佛从苏弥人间游行至跋提城。彼作如是念。我今宁可辞师不兰迦叶至沙门瞿昙所。念已往师所白言。大师。我闻佛从苏弥人间游行至跋提城。我今欲往见沙门瞿昙。不兰迦叶语言。居士。汝有大福力随意自在。不应往见沙门瞿昙。沙门瞿昙应来见汝。又法应尔。出家人应来问讯白衣。彼作如是念。未曾有沙门为沙门作刺。我何须辞不兰迦叶。不辞而去。能使我作何等也。即便往见瞿昙。旻茶居士。往世尊所。头面作礼却住一面。世尊为种种方便说法开化。令得欢喜。尔时旻茶闻佛说法。心大欢喜白佛言。我是跋提城居士。是不兰迦叶弟子。具以已家业福力之事白世尊言。我家中各各诤言。是我福力。唯愿世尊。为说是谁福力。佛语旻茶居士汝往过去世时。于波罗奈国作居士。大富多诸财宝库藏溢满。前世时妇儿儿妇及奴婢。即今者是。居士。尔时时世谷贵人民饥馑乞求难得。时居士家中共食。时有辟支佛。字多呵楼支。来入乞食。居士言。汝曹但食。持我分与此仙人。妇作如是言。居士但食持我分与此仙人。其儿复作如是言。父母但食。持我分与此仙人。儿妇及奴婢亦作如是言。大家但食。持我分与此仙人。于是各分食分施辟支佛。居士知不。以是因缘果报今日等共有如是福力。尔时世尊。无数方便为说法开化。令得欢喜。即于座上远尘离垢得法眼净。见法得法得果证。白佛言。听我自今已去尽形寿归依佛法僧为优婆塞。不杀生乃至不饮酒。唯愿世尊。受我跋提城中七日请。时世尊默然受之。时居士以世尊及比丘僧默然受请已。即于跋提城中。众味自具。七日供养佛及比丘僧。时世尊七日受请已。欲往旷野。时旻茶居士。以千二百五十牸牛遣人。以象载种种饮食之具。于道路供养佛及比丘僧。世尊尔时。七日受供养已。即往旷野。诸比丘在道行。见有人[(殼-一)/牛]牛令犊子饮已复[(殼-一)/牛]。犊子口中涎出似乳。诸比丘后遂不饮乳。白佛。佛言听饮。[(殼-一)/牛]乳法应尔。有五种牛汁乳酪生酥熟酥醍醐。行过旷野已故有余饮食。彼使人作如是念。居士大富多有财宝故。为比丘故送此饮食。我今宁可都以此饮食与诸比丘。时即持饮食与诸比丘。诸比丘不受言。佛未听我曹受道路粮。诸比丘白佛。佛言。自今已去听作檀越食受。令净人偿举。不应自受。若有所须随意索取

尔时世尊。从阿牟多罗国。人间游行。至阿摩那城。在翅[少/兔]编发婆罗门园中住。尔时编发婆罗门。闻沙门释种出家从阿牟多罗国至阿摩那城在我园中住。彼作如是念。沙门瞿昙。有大名称言。是如来无所著应供正遍知明行足为善逝世间解无上士调御丈夫天人师佛世尊。善哉我今当见如是无著人。尔时编发婆罗门。往至世尊所。恭敬问讯已。却坐一面。佛为无数方便说法开化。令得欢喜。时婆罗门闻佛说法极大欢喜。白佛言。愿佛及比丘僧。受我明日请食。佛言。今比丘僧多。汝信外道。婆罗门言。我虽信外道。众僧虽多。但受我明日请食。世尊如是再三语之。婆罗门亦如是再三白世尊。世尊尔时默然受请。婆罗门见佛受已。从坐起而去还家。语亲属言。我明日请佛及比丘僧供养。所应施设愿当助我。其诸亲属闻之皆喜。或有破薪者。或有作饭者。或有取水者。时婆罗门。自庄严堂舍敷床座。佛及比丘僧当在此座。时阿摩那城中。有施卢婆罗门。与五百婆罗门共往。翅[少/兔]婆罗门。常恭敬宗仰之。时施卢婆罗门。与五百婆罗门俱往其家。翅[少/兔]婆罗门常法。见其来起出迎之请人屋坐。其日见来亦不出迎亦不请坐。但见自庄严堂舍敷好床座。施卢问言。为欲娶妇。为欲嫁女。为欲请王。为欲大祠耶。彼即答言。我亦不娶妇乃至请王。我欲作大祠。请佛及比丘僧千二百五十人。沙门瞿昙有大名称。如来无所著应供正遍知明行足为善逝世间解无上士调御丈夫天人师佛世尊。施卢问翅[少/兔]言。实是佛耶。答言。实是佛。再三问言。实是佛耶。答言实是。问言。佛在何处住。我今欲见。时翅[少/兔]举右手示言。乃在彼青林中住。施卢作如是念。我不应空往。当持何物往见沙门瞿昙也即自念言。今有八种浆。是古昔无欲仙人所饮梨浆阎浮浆酸枣浆甘蔗浆[卄/(麩-夫+生)]果浆舍楼伽浆婆楼师浆蒲桃浆。尔时施卢婆罗门。持此八种浆。往诣佛所。恭敬问讯却坐一面。时世尊为方便说法开化。令得欢喜。施卢闻法极大欢喜。即以八种浆施比丘僧。比丘不敢受言。佛未听我曹受八种浆。比丘白佛。佛言。听饮八种浆。若不醉人应非时饮。若醉人不应饮。若饮如法治。亦不应以今日受浆留至明日。若留如法治。尔时世尊。从此住处至摩罗人间游行。向波婆城。时波婆城诸摩罗。闻世尊与千二百五十比丘俱从摩罗人间游行向波婆城。自共作制。世尊当来皆应共迎。若不迎者罚金百两。时有摩罗子。字卢夷。无有信乐于佛法僧是阿难白衣时亲友。时阿难遥见卢夷语言。甚善卢夷。汝能自出迎佛。彼答言。大德。我不以是出迎。波婆城中皆共作制。若不出迎佛者。罚金百两。以是因缘故来非信敬故来。时阿难闻之不乐。即往世尊所。白言。此波婆城中有摩罗子。字卢夷。是我白衣时亲友。善哉世尊愿为佐助令彼得信乐。佛语阿难。此有何难。若复有如是者。犹不为难。尔时世尊。即以慈心。感卢夷摩罗令诣世尊。犹如有人引导而往。如是卢夷往佛所头面礼足已却住一面。尔时世尊。无数方便为其说法开化。令得欢喜。即时得远尘离垢得法眼净。见法得法得果证白佛言。大德。我自今已去。归依佛法僧。为优婆塞。不杀生乃至不饮酒。唯愿世尊常受我衣服饮食医药卧具。佛告卢夷。汝今学人。以有明智远尘离垢得法眼净。便言常受我衣服饮食医药卧具。复更有余学人。已有明智远尘离垢得法眼净。亦当复言。常受我衣服饮食医药卧具。尔时世尊。波婆城中不偏受一人请。时城内家家各敛饮食聚在一处。饭佛及僧。时卢夷往作食处看唯无饼。彼即于夜办具种种饼。明日与诸比丘。诸比丘不受言。佛未听我曹前食受饼。诸比丘白佛。佛言听受。时世尊从波婆城至阿头。时阿头住处有二比丘是常剃发人。父子出家时二比丘闻佛从波婆至阿头。彼作如是念。我曹当办具何等供养世尊。其父语儿言。我今当求剃发处。汝可往作钱处求作。若有所得当办具粥供养世尊。时父即往为人剃发。儿即往作钱赁作。有所得物。尽为办粥。持往供养世尊。世尊知而故问阿难。何处得此粥。阿难即以此事具白佛。佛言出家人不应为白衣剃发。除欲出家者若剃发人出家。不应畜剃刀。若畜如法治。时众僧得剃发刀。白佛。佛言听畜。尔时世尊。从阿头至迦摩罗。诸比丘得如是根药。阿漏弥那漏比那漏提婆檀豆檀卢干漏私罗漏。诸比丘不受言。佛未听我曹受如是根药。白佛。佛言听受。是中迦摩罗国诸比丘。得如是尽形寿药。沙蔓那摩诃沙蔓那杏子人兜兜漏秦敌梨蓼。诸比丘不受言。佛未听我等受如是尽形寿药比丘白佛。佛言听受。尔时世尊从迦摩罗。至迦维罗卫国。毕陵伽婆蹉。在彼国住。患脚劈破。医教涂脚。白佛。佛言听涂。不知以何药涂。白佛。佛言。听以酥油若脂涂。手捉酥油臭。佛言。听用涂药篦。时手涂脚手腻。佛言。听脚脚相涂。涂脚药着浅器中不坚密。佛言听作瓶。若患坌尘。佛言听作盖。时油瓶举处不坚牢。佛言。听着床下若悬着壁上龙牙杙上。时诸比丘患头痛。医教顶上着油。白佛。佛言听着。彼畏慎不敢用香油着。佛言听着。油法应尔时比丘患风。医教作除风药。是中除风药者。烝稻谷烝酒糟。若大麦。若诸治风草若麸糠若煮小便。白佛。佛言听时毕陵伽婆蹉须铫煮。佛言听畜。众僧得大铫。佛言听畜。毕陵伽婆蹉。得三种釜铜釜铁釜土釜。佛言听畜。众僧亦尔听畜。后得瓶铜瓶铁瓶瓦瓶。佛言听畜。众僧亦尔听畜。毕陵伽婆蹉。得煎饼[金*敖]。佛言听畜。众僧亦尔听畜。毕陵伽婆蹉。得铜杓得樽。佛言听畜。众僧亦尔听畜

四分律卷第四十二四分律卷第四十三(三分之七)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    药揵度之二

尔时有吐下比丘。使舍卫城中人煮粥。时有因缘。城门晚开。未及得粥便死。诸比丘白佛。佛言。听在僧伽蓝内结净地。白二羯磨应如是结。应唱房若处若温室若经行处。众中差堪能作羯磨者。若上座若次坐。若诵律若不诵律。堪能作羯磨者如是白。大德僧听。若僧时到僧忍听。僧今结某处作净地。白如是。大德僧听。僧今结某处作净地。谁诸长老忍僧结某处作净地者默然。谁不忍者说。僧已忍结某处作净地竟。僧忍默然故。是事如是持。有四种净地。一者檀越若经营人。作僧伽蓝时。分处如是言。某处为僧作净地。第二者若为僧作僧伽蓝未施僧。第三者若半有篱障。若多无篱障。若都无篱障。若垣墙若堑亦如是。第四者僧作白二羯磨结。诸比丘作是念。比丘房应结作净地不。白佛。佛言。应作除去比丘比丘尼。若式叉摩那沙弥沙弥尼房亦如是。若鬼神庙屋亦如是得作净地。时诸比丘不知何处是净地。白佛。佛言应结。若疑先有净地。应解然后结。尔时比丘治故僧伽蓝。不知为得作净地不。佛言得作。尔时不净地有树生。枝叶荫覆净地。时诸比丘欲安净物着上。不知为净不净。佛言。根在不净地即不净。时有树根在净地。枝叶荫覆不净地。诸比丘欲安净物着上。不知为净不。佛言。根在净地得净。时有树根在不净地。枝叶覆净地。果堕在净地。诸比丘不知为净不。佛言。若无人触自堕者净。风吹雨打堕。有猕猴诸鸟触堕。不知为净不。佛言若不作意欲使堕者净。树根在净地果堕不净地。比丘不知为净不。佛言净。时诸比丘。在不净地种胡瓜甘蔗菜枝叶覆净地。比丘不知为净不。佛言不净。时有在净地种胡瓜甘蔗菜枝叶覆不净地。不知为净不。佛言净。时六群比丘不净果便食。诸居士见皆共讥嫌言沙门释子。不知惭愧无有厌足。自称言。我知正法。如是何有正法。食果不作净。比丘白佛。佛言。不应不净果便食。应净已食之。应作五种净法食。火净刀净疮净鸟啄破净不中种净。此五种净应食。是中刀净疮净鸟净应去子食。火净不中种净都食。复有五种净。若皮剥若[利-禾+皮]皮若腐若破若瘀燥。尔时众僧得果园。佛言听受。复不知谁当料理。佛言。若守僧伽蓝民若沙弥若优婆塞。彼守视人欲得分。佛言。应计食作价与直。尔时比丘食不破果大便已子生。比丘畏慎言。我食生种。白佛。佛言不犯即是净。时诸比丘种菜。自散种子后疑言。我自种不敢食。白佛。佛言。种子已变尽听食。时比丘移菜余处殖疑言。自殖不敢食。白佛。佛言。以重生故听食。若自种胡瓜甘蔗蒱桃。梨奈呵梨勒鞞醯勒阿摩勒椒姜荜茇。及移殖应食。尔时有小沙弥。捉净食过水不自胜举。佛言。听大比丘扶沙弥令过。时有小沙弥持净食不能上岸。佛言。听大比丘扶令上。时有沙弥小。不能举净食悬着壁上若龙牙杙上。又不能下。白佛。佛言。听下安床若机蹬上令得上下。时诸比丘有酥瓶油瓶不覆。白佛。佛言听使净人覆。若无净人。应自手捉盖悬置其上。不应手触。时六群比丘啖不净菜。诸居士见皆共讥嫌言。沙门释子。不知惭愧。无有厌足。断众生命。自言我知正法。如是何有正法。不净菜便食之。诸比丘白佛。佛言不应啖不净菜应净。时彼便自作净。佛言。不应自作净。应令净人作净。时比丘自手捉食已使人作净。佛言。不应自手捉食已使人作净。应置地使人作净。彼作净已不受便食。佛言。不应作净已不受便食。应作净已洗手受食。彼洗连根菜已更作净。佛言。不应洗已更作净。此洗即是净。时有比丘。先相嫌便触他净食。作如是意令比丘得不净食。彼比丘不知净不净。白佛。佛言。于触者是不净。不触者净。触者犯突吉罗。时有比丘嫌彼比丘。于彼小沙弥边触彼净食。作如是意。令彼和尚阿阇梨得不净食。彼比丘不知净不净。白佛。佛言。触者不净。不触者净。触者得突吉罗。时净人作如是意。强多与比丘食。彼食不尽有余我曹当食。彼比丘应口遮言莫着。若不止彼应小离食器草。彼比丘不知净不净。白佛。佛言净。时诸居士。持食饮具往僧伽蓝。与诸比丘赏举。后诸居士来。若自食。若持归。若与比丘食。比丘畏慎不敢食。作如是意。我曹先手自赏举。诸比丘白佛。佛言。此是檀越所有。听为檀越故洗手受食。时病比丘须粥。佛言听煮。若无人听自煮。若更互煮不知云何煮。佛言。听使净人净洗器。着水着米煮令沸。洗手受然后自煮令熟。时不知熟不熟。佛言。应以勺扬看。若流下循勺则熟。若熟应泻着余器中。彼泻粥者复具器疲极。佛言。不应泻粥者并具器应更一人具器。若热烧手。应捉镊热巾若草。若虫堕粥中应却。彼烧手。佛言。应以勺去之。彼欲分。佛言听分。复不知何器分。佛言。若以键[金*咨]若小钵若次钵若勺作分。钵若不正应作钵支。若尘坌应作盖。彼不洗钵器举。余比丘见恶之。佛言。应净洗然后举。既洗。不以灰澡豆洗不净。佛言。应用灰澡豆洗。洗已不干。便举器便虫生。佛言。不应不干举。应令干燥然后举。彼器有陷孔处。食入中。数摘洗穿坏。佛言。随可洗处洗余无犯。诸比丘作如是念。得界内共粥宿界内煮自煮不。佛言。不应界内共宿界内煮自煮。诸比丘作如是念。重煮粥得界内共宿界内煮自煮不。佛言不应界内共宿界内煮。听自煮。诸比丘如是念。尽形寿药得界内共宿界内煮自煮不。佛言。听尽形寿药界内共宿界内煮自煮。时有比丘欲受酥错受油。不知成受不。佛言不成受。时有比丘。欲受油错受酥。不知成受不。佛言不成受。欲受此错受彼。不知成受不。佛言不成受。有比丘忘不受食。便持在道行。渡水已忆念。我当云何。即白佛。佛言。若如是忘不受食。便持在道行者。若见有净人。应置食着地净洗手更受食。尔时世尊在波罗奈国。时世谷贵人民饥饿乞食难得。诸比丘持食着露处不盖藏。放牛羊人若贼持去。诸比丘如是念。国土饥饿。世尊应听界内共食宿。白佛。佛言。若谷贵时听界内共食宿。时诸比丘露处煮食不盖藏。牧牛羊人若贼见持去。比丘作如是念。谷贵时界内应听煮食白佛。佛言。谷贵时听界内煮。时诸比丘使净人煮食。或分取食或都食尽。诸比丘作如是念。谷贵时应听自煮食。白佛。佛言。谷贵时听自煮食。时诸比丘道路行见地有果。比丘求净人顷。他人已取去。白佛。佛言。听以草若叶覆果上。而人故取去。白佛。佛言听取。若见净人应置地洗手受食。诸比丘如是念。谷贵时世尊应听我曹自取食。佛言。谷贵时听自取食。时诸比丘早起受食已。置食入村彼受请还。余比丘边作余食法。彼或分食或食尽。比丘作如是念。谷贵时。世尊应听我等早起受食已不作余食法食。白佛。佛言。听谷贵时不作余食法食。时有多知识长老比丘。入村乞食。得食已持往一处。食已持余食。还至僧伽蓝中于余比丘间作余食法更食彼比丘或分食若都食尽。诸比丘如是念。谷贵时。世尊。应听我曹从食处持食来不作余食法食。白佛。佛言听谷贵时从食处持食来不作余食法食。时诸比丘受食已。得果胡桃。椑桃婆陀庵婆罗阿婆梨。于余比丘边作余食法。彼或分食或都食尽。诸比丘作如是念。谷贵时。世尊应听我曹得如是果不作余食法食。白佛。佛言。听谷贵时得如是果不作余食法食。时诸比丘食已。得水中可食物。藕根迦婆陀菱芰藕子。于比丘边作余食法。彼或分食或都食尽。诸比丘作如是念。世尊应听我曹谷贵时食已得如是水中可食物不作余食法食。白佛。佛言。听谷贵时食已得如是水中可食物不作余食法食。时世谷还贱。世尊知而故问阿难。我于谷贵时。慈愍诸比丘故听八事。界内共宿。界内煮。自煮。自手取食。受早起食从食处持余食来。胡桃果等食。水中可食物。足食已不作余食法听食。诸比丘今故食耶。答言故食。佛言不应食。若食如法治尔时众僧食厨坏。诸比丘以木拄之。木在不净地。有疑不知净不。佛言净得食。时夜移食堕不净地。诸比丘不知净不。白佛。佛言净。夜移食食堕净不净地间。诸比丘不知净不净。白佛。佛言净时有狗从净处衔食至不净地。诸比丘不知净不净白佛。佛言净。诸恶兽鸟衔去亦如是。时有比丘嫌彼比丘。便移他食着不净地。作如是念。使彼不得净。比丘不知净不净。白佛。佛言。触者不净。得突吉罗。不触者净。时比丘嫌彼比丘。作如是意。触净地使彼得不净。诸比丘不知净不净。白佛。佛言。触者不净。得突吉罗。不触者净。时有客比丘。来觅净地欲安食。未至净地明相出。彼不知净不净。白佛。佛言净。欲远行者亦如是。时六群比丘畜升斗斛秤。诸比丘白佛。佛言不应畜。时诸比丘得胡麻粳米得大豆小豆大麦小麦。自欲量。白佛。佛言。听手抄量若键[金*咨]若钵若小钵量。即以此器大小准以为斛斗。时诸比丘得酥油蜜黑石蜜。欲称量。白佛。佛言听。刻木作铢两如称齐限四五两。准以为斤数彼结上好房作净处酥油脂涂泥污或烟熏污。白佛。佛言。不应结上房作净。应结下者作净处。诸比丘得果。佛言听一一分。若不足应忆次第若更得续与。若得多果。应一人与四五枚若与一抄若一键[金*咨]若次钵若随能啖者与。若故有余应更与时彼与白衣若外道。佛言。不应与外道白衣。彼比丘后畏慎。不敢与父母若病人小儿若妊身妇人若被系闭者若白衣来至僧伽蓝中。白佛。佛言如是人应与。若故有余应压取汁饮。时须压具。佛言听畜。若汁未沸不醉人得饮。若醉人不应饮。若饮如法治。尔时世尊在毗舍离时众僧多有供养饮食。诸比丘身患湿。白佛。佛言。听作吐下药须羹粥与羹粥须野鸟肉应与。尔时有比丘患头痛。医教灌鼻。佛言听。不知何物灌。佛言。以酥油脂灌。不知云何灌。佛言听以羊毛若劫贝鸟毛渍油中。然后渧着鼻中。四边流出。佛言听作灌鼻筒。彼便持宝作筒佛言。不应用宝作。应用骨若牙若角若铁若铜若白镴若铅锡若苇若竹若木彼不洗便举置。佛言。不应不洗举置。洗已不燥后虫生。佛言不应洗已不燥。应令燥举置。时有比丘患头痛。医教灌鼻药不入。佛言。听手摩顶若摩脚大指若以凝酥塞鼻。尔时有比丘患风。医教用烟。佛言听用烟。时须烟筒。佛言听作。彼以宝作。佛言不应用宝作筒。应用骨若牙若角若铁若铜若白镴若铅锡若木作。若患火烧烟出处。听安铁。若患筒零落。佛言听作囊盛。手持不坚。佛言应作带系着肩上。彼须丸药。佛言听作。手持不坚。应盛着薰筒囊中。时有比丘患疮。医教作涂疮药。佛言听作。彼疮熟。应以刀破着药。自今已去。听以刀破疮。患疮臭应洗。若以根汤茎叶华果汤及小便洗时以手洗患痛。以鸟毛洗。若药汁流弃。以物拥障四边。若患燥以油涂。若上弃以物覆。若疮臭香涂。时诸比丘患疟。佛言听厚衣覆。若故寒应以卧具毡褥覆上。若寒不止应一比丘共卧。彼畏慎不敢与病者共卧。佛言。听与病人共卧。时有白衣病来至僧伽蓝。比丘为看病。诸比丘白佛。佛言应方便喻遣。若称举佛法僧者。能作事为作。病人死。诸比丘畏慎不敢弃。世尊有如是语。不应弃白衣丧。诸比丘白佛。佛言应为僧伽蓝净故弃之。时六群比丘剃三处毛。诸比丘白佛。佛言不应剃三处毛。时六群比丘互相看尾。谁尾长谁尾短着何药。诸比丘白佛。佛言。不应更相看尾问其长短着何等药。时六群比丘以酥油灌大便道。佛言不应灌。彼教人灌。佛言不应教人灌。尔时比丘在北方住安居已。形体枯燥颜色憔悴。至只桓精舍诣佛所。头面礼足却坐一面。世尊慰问客比丘。汝住处安乐和合不。不以乞食疲苦耶。答言。住处安乐和合无诤。彼国无粥。不得粥故气力羸乏。佛问言。彼国常食何等食。答言。彼国常食饼。佛言听食饼。尔时有波罗奈国市马人。来至舍卫国。欲为众僧作饼作豆糗作糗。与糗籢与量糗器。与盐与盛盐籢。与苦酒苦酒瓶。与木欓与卮与匕。与勺与摩膏与卮碗。与食根食茎食叶食华食果食油食胡麻食黑石蜜食细末食。佛言一切听受食。诸比丘如是食。不知此粥是食非食是请非请是足食非足食。佛言。若持草画无迹非食。非请非足食。时比丘作如是念饮煮饭汁。为是食非食是请非请是足食不。佛言若不合滓饮非食非请非足食。时诸比丘作如是念。不知饼是食非食是请非请是足食不。佛言。非食乃至非足食。时六群比丘。以共宿盐合食食。佛言。不应共宿盐合食食。时优波离偏露右肩右膝着地合掌白佛言。何等是尽形寿药应服。佛语优波离。不任为食者。比丘有病因缘。尽形寿应服(药揵度具足竟)

    迦絺那衣揵度第八

尔时世尊在舍卫国。时有众多比丘。在拘萨罗国安居。十五日自恣竟。十六日往见世尊。彼道路值天雨。衣服皆湿僧伽梨重疲极。诣舍卫国世尊所。头面礼足已却坐一面。尔时世尊慰劳诸比丘言。汝等住止和合安乐不。不以乞食为苦。道路不疲极耶。答言。住止和合安乐。不以乞食为苦。大德。有众多比丘。在拘萨罗国异处夏安居竟。十五日自恣已。十六日便持衣钵来见世尊。道路遇天雨。衣服湿僧伽梨重疲极。有众多粪扫衣比丘。在寒雪国异处夏安居。十五日自恣竟。十六日持所得新故衣。便往见世尊。道路遇天雨。衣服湿重疲极。诣只桓精舍到佛所。头面礼足已却坐一面。佛慰劳诸比丘言。汝等住止和合安乐不。不以乞食为苦。道路不疲极耶。答言。住止和合安乐。不以乞食为苦。大德。有众多持粪扫衣比丘。在寒雪国异处夏安居。十五日自恣竟。十六日持新故衣。来见世尊。道路遇天雨。衣服湿重疲极。尔时世尊。以此因缘集比丘僧告诸比丘。安居竟有四事应作。何等为四。应自恣应解界应结界应受功德衣。安居竟有此四事应作。有五事因缘受功德衣。何等五。有长衣。不失衣。别众食。展转食。食前食后不嘱比丘入聚落。有如此五事因缘。受功德衣。受功德衣已。得五事。何等五。得畜长衣离衣宿别众食展转食食前食后不嘱比丘入聚落。受功德衣已。得作五事。众僧应如是受功德衣。若得新衣。若檀越施衣。若粪扫衣。若是新衣。若是故衣。新物帖作净。若已浣。浣已纳作净。不以邪命得。不以相得。不激发得。不经宿得。不舍堕作净。即日来。应法。四周有缘。五条作十隔。如是衣僧应受作功德衣。若复过是者亦应受。应自浣染舒张辗治裁作十隔缝治。应在众僧前受僧已受功德衣竟。云何僧不成受功德衣。不但浣已成受功德衣。不但辗治。不但安缘。不但裁隔。不但编边。不但安纽。不但作叶。不但安钩。若邪命得若谄曲得衣。相得衣。激发得衣。经宿得衣。舍堕不作净。不即日来不应法受衣。四周不安缘。不在僧前受。若有难无僧伽梨。若僧如法受功德衣。而彼在界外住自受衣。如是不成受功德衣。云何成受功德衣。若得新衣檀越施衣粪扫衣。若是新衣若是故衣。新物帖作净。若已浣。浣已纳作净。非邪命得。非谄曲得。不以相得。不以激发得。不经宿。不舍堕作净。即日来。应法。四周安缘。五条作十隔若过。如是衣受作功德衣。自浣染舒张辗治裁作十隔缝治。在众僧前受。众僧已受功德衣竟。若如法受功德衣在界内受如是成受功德衣。时六群比丘。以大色染衣为僧受作功德衣。诸比丘白佛。佛言。不应以大色染衣作功德衣。彼用锦作。佛言不应用锦。彼用白色。佛言。不应用白色。自今已去。听用袈裟色。尔时有异住处。现前僧得大贵价功德衣。彼比丘不知云何。诸比丘白佛。佛言听作白。应如是白。大德僧听。今日众僧受功德衣。若僧时到僧忍听。众僧和合受功德衣。白如是。如是白已。差一比丘应问言。谁能为僧持功德衣。能者答言我能众中差堪能作羯磨者如是白。大德僧听。若僧时到僧忍听。僧差某甲比丘。为僧持功德衣白如是。大德僧听。僧差某甲比丘。为僧持功德衣。谁诸长老忍僧差某甲比丘为僧持功德衣者默然。谁不忍者说。僧已忍差某甲比丘为僧持功德衣竟。僧忍默然故是事如是持。僧即应羯磨衣与持功德衣比丘。作如是言。大德僧听。此住处僧得可分衣。现前僧应分。若僧时到僧忍听。僧今持此衣与某甲比丘。此比丘当持此衣为僧受作功德衣于此住处持。白如是。大德僧听此住处僧得可分衣物。现前僧应分。僧今持此衣与某甲比丘。此比丘当持此衣为僧受作功德衣于此住处持。谁诸长老忍僧持此衣与某甲比丘。某甲比丘当持此衣为僧受作功德衣于此住处持者默然。谁不忍者说。僧已忍。持此衣与某甲比丘某甲比丘当持此衣为僧受作功德衣。于此住处持竟。僧忍默然故。是事如是持。彼比丘应起捉衣随诸比丘手得及衣言得相了。应作如是言。此衣众僧当受作功德衣。此衣众僧今受作功德衣。此衣众僧已受作功德衣竟。如是第二第三说。彼诸比丘应作如是语。其受者已善受。此中所有功德名称属我。彼应答言尔。尔时优波离。从坐起偏露右肩脱革屣右膝着地白世尊言。为以过去三句为以未来为以现在受功德衣耶佛语优波离。为满足语故说九句。亦不以过去三句受功德衣。亦不以未来三句受功德衣。以现在三句受功德衣。何以故。优波离。过去已灭未来未至。是故以现在三句受功德衣。若得未成衣应众僧中羯磨差比丘令作。若得已成者。应如法受。彼六群比丘。春夏冬一切时中为僧受功德衣。诸比丘白佛。佛言。不应春夏冬一切时中受功德衣。自今已去。听自恣竟不受功德衣。一月受功德衣。五月彼六群比丘不出功德衣。作如是意。以久得五事放舍故。诸比丘白佛。佛言不应作如是意。以久得五事放舍故。而不出功德衣。自今已去。听冬四月竟僧应出功德衣。应如是出。僧集和合。未受大戒者出。不来者说欲僧今何所作为。应答言。出功德衣。大德僧听。今日众僧出功德衣。若僧时到僧忍听僧今和合出功德衣。白如是。应作如是白出功德衣。若不出过功德衣分齐突吉罗。有八因缘舍功德衣。去。竟。不竟。失。断望。闻。出界。共出。若比丘受功德衣竟出界外。作不还意出去。去便失功德衣。若比丘受功德衣竟。出界外作衣。彼作衣竟便失功德衣。若比丘受功德衣竟出界外作如是念。亦不作衣亦不还衣。不竟舍功德衣。若比丘受功德衣已。出界外作衣竟。彼比丘失衣。功德衣亦失。若比丘受功德衣竟。出界外悕望得衣。彼比丘出界外。便至悕望得衣处。比丘见已不得衣望断。更无有望处。彼望断失功德衣已。若比丘受功德衣竟。出去界外作衣。作衣竟闻众僧出功德衣。彼闻便失功德衣已。若比丘受功德衣竟。出界外作衣竟。数作还意在界外。众僧出功德衣。彼在界外失功德衣已。若比丘受功德衣竟。在界外作衣。彼衣若竟若不竟还住处。彼比丘和合出衣。是为八事

复有六事。若比丘受功德衣竟。出界外作不还意去。未得衣去。便失功德衣(除上八事中失衣及望断二句。余者如上)复有六事。若比丘受功德衣竟。持衣出界外作衣。作衣竟便失功德衣(除上八事中去及望断二句余者如上)未得衣复有十五句。(次已得衣亦有十五句)得衣未得衣复有十五句(此错互上八事。更无异故不出)复有十二事。若比丘受功德衣已出去。求悕望衣得所望衣。在界外作衣。作衣竟失功德衣。(不竟句亦如是。失亦如是。望断如上)若比丘受功德衣竟。出去望得衣。不语人当还。出界外所望衣处。而不得所望衣。乃得非所望衣。在界外作衣。作衣竟便失功德衣(不竟亦如是。失亦如是。望断如上)若比丘受功德衣竟。出去不语人当还。亦不作还意在界外至望衣处。得所望衣。不得所望衣。在界外作衣。作衣竟便失功德衣。(不竟亦如是。失亦如是。望断如上)复有十二事。得所望衣不得所望衣同上十二事。复有九事。若比丘受功德衣竟出去。未得衣在界外。余比丘问言。汝在何处宿。衣在何处。何不持来。为汝作衣。彼比丘还至住处。闻众僧出功德衣。彼作如是念。僧今出功德衣。方作衣。彼即作衣竟失功德衣。(不作衣亦如是。失衣亦如是。此是在界内闻三句。持衣出界外道路闻三句亦如是。持衣至彼比丘所三句亦如是。是为九句事。次已得衣九句亦如是。得衣不得衣各九事亦如是)若比丘受功德衣已。出界外至余方。彼作是念言。若得善伴当去。若不得善伴当还。至中道闻众僧出功德衣。彼如是念。我当作衣。作衣竟彼失功德衣。(不竟亦如是。失衣亦如是。界外亦如是。闻亦如是五句)若比丘受功德衣竟。欲往静处清净若乐彼当住。不乐当还。彼比丘至彼间。闻众僧出功德衣。彼作是言。我曹当作衣。作衣竟舍功德衣。(不竟亦如是。失衣亦如是界外亦如是。闻亦如是五句)有二种舍功德衣。持功德衣。比丘出界外宿。众僧和合共出(迦絺那衣具足竟)

    拘睒弥揵度第九

尔时世尊在拘睒弥。时有比丘犯戒。是中或有言犯戒。或有言不犯。是中见犯比丘。语不见犯比丘言。此比丘实犯。非是不犯。彼不见犯比丘意解。即言如是。是比丘实犯戒。非是不犯。彼即和合举罪。犯罪比丘言。我不犯。不成举非法。举我羯磨不成。彼即往人间觅朋党。语余比丘言。我不犯。不成举非法举我羯磨不成。彼比丘见如是。此比丘不犯。不成举非法举羯磨不成。犯罪比丘。即将余部党随举比丘。来至先言不见犯比丘所语言。长老。此比丘不犯戒。不成举。非法举他。羯磨不成。彼比丘还见不犯便言。彼不犯。不成举非法举羯磨不成彼被举随举比丘。与见犯比丘别部说戒羯磨。时举罪比丘。往世尊所头面礼足却坐一面白佛言。此被举随举比丘。与我等别部说戒羯磨。佛言。此痴人破僧。若彼如我所说羯磨说戒者。羯磨成就不犯。汝等若如我所说羯磨说戒亦成就不犯。何以故。有二不同住处。何等二。彼比丘自作不同住。若僧与作不同住。云何比丘自作不同住。若比丘僧破求外朋党。是为比丘自作不同住。云何僧与作不同住。僧与作不见犯羯磨不忏悔羯磨恶见不舍羯磨。是为僧与作不同住。是为二种不同住有二种同住处。是比丘自作同住处。若僧与作同住处。云何自作同住。此比丘僧破自部党求外善部党。此比丘自作同住。云何僧与作同住。众僧和合。先与作不见羯磨不忏悔羯磨恶见不舍羯磨后和合僧还解。是为僧与作同住。是为二种同住处。彼被举比丘随举比丘。与此举比丘斗诤共相骂詈诽谤互求长短。时众多比丘。往世尊所。头面作礼却坐一面。白世尊言。大德。彼被举比丘随举比丘。与此举比丘斗诤共相骂詈诽谤互求长短。我等当云何。佛言。听众僧破非法和合。应在如是处坐令身口不出恶。众僧破如法和合。应隔一人坐。尔时世尊。往被举比丘所。作如是言。汝曹莫犯罪。而言不犯不忏悔。何以故。若比丘犯罪。余比丘言。长老犯罪自见不。答言不见。彼比丘多闻知阿含持法。持律知摩夷。多得伴党比丘比丘尼优婆塞优婆夷国王大臣种种沙门外道。彼犯罪比丘作是念。彼比丘多闻知阿含持法持律知摩夷。多有伴党比丘比丘尼优婆塞优婆夷国王大臣种种沙门外道。我今若不见罪。此比丘今即当为我作不见罪羯磨不忏悔羯磨恶见不舍羯磨。若彼比丘与我作不见罪羯磨不忏悔羯磨恶见不舍羯磨者。彼比丘不复与我共羯磨说戒。不共我自恣同一屋住一处坐一床一板在前食后食。亦不随岁数大小恭敬礼拜执手迎逆。若彼比丘不与我同一羯磨共说戒。乃至不执手迎逆者。众僧便有斗诤事生。共相骂詈诽谤伺求长短。僧便当破。令僧尘垢。令僧别异住。若比丘重此破僧事者。应如彼言有罪应如法忏悔。止止比丘莫共斗诤骂詈共相诽谤伺求长短。汝等一切当共和合齐集同一师学如水乳合。利益佛法安乐住。尔时世尊。告被举比丘随举比丘。如是言已。便往至举他比丘所语言。汝等莫数举他比丘事。何以故。是中比丘犯事。彼比丘问言。长老。自见犯罪不。彼言不见彼比丘若多闻知阿含持法持律知摩夷。多朋党比丘比丘尼优婆塞优婆夷国王大臣种种沙门外道。彼比丘作如是念。彼比丘多闻知阿含持法持律知摩夷。多朋党比丘比丘尼优婆塞优婆夷国王大臣种种沙门外道。若彼言不见罪。我等今即便当举作。不见罪羯磨不忏悔羯磨恶见不舍羯磨。我等若与作不见罪羯磨不忏悔羯磨恶见不舍羯磨。我等便不与彼共一羯磨说戒。不共自恣。乃至不执手迎逆。我等不共一羯磨说戒。乃至不执手迎逆者。众僧便当斗诤共相骂詈诽谤伺求长短。令僧破令僧尘垢令僧别住。若比丘重此破僧事者。不应举彼比丘罪。止止比丘莫斗诤共相骂詈诽谤伺求长短。汝等一切当共齐集同一师学如水乳合利益佛法安乐住。尔时世尊语彼比丘已此夜过明旦着衣持钵。入拘睒弥乞食已还至僧伽蓝中。以此因缘集比丘僧告言。乃往过去世。有伽奢国王梵施拘萨罗王长生。父祖怨仇。梵施王兵众威力勇健财宝复多。长生王兵众威力不如财宝复少。后异时梵施王。与四部兵来至拘萨罗国罚长生王。夺得一切国土兵众库藏珍宝。时王长生。与第一夫人逃走。至波罗奈国。假作螺髻婆罗门。夫妇在陶师家住。后异时长生王第一夫人心生如是念。欲得其地平整四交道头日初出时见四部兵共斗洗刀汁饮。即至王所白言。王欲知不。我今如是念欲。得其地平整四交道头日初出时见四部兵共斗洗刀汁饮。王言汝今何由得从如是愿。梵施王与我父祖怨仇。夺我国土兵众库藏珍宝无有遗余。夫人言。我若不得从如是愿者便当死时。梵施王。有大臣字富卢醯侈是长生王伴。长生王语妇言。须我语伴令知。时长生王。即至富卢醯侈所语如是言。伴今知不。我第一夫人生如是念。欲得其地平整于四交道头日初出时见四部兵斗洗刀汁饮。念已即来白我说如是事。我语言。汝今何由得从如是愿。梵施王与我父祖怨仇。夺我一切国土兵众库藏财宝都尽。夫人即言。我若不得从如是愿者便当死。我即语言。须我以此因缘语伴令知。富卢醯侈言。小止。须我瞻其腹内。时富卢醯侈。往瞻长生王第一夫人腹内已。即偏露右肩长跪执手三反称言。拘萨罗王在腹内。语夫人言。当得其地平整于四交道头日初出时见四部兵共斗洗刀汁饮。在某处住。时富卢醯侈。往梵施王所白如是言。王欲知不。有如是星出。时应清旦。日初出时在四交道头四部兵共斗洗刀刃。王言。富卢醯侈今正是时。时富卢醯侈。即集四部兵于四交道头共斗洗刀刃。时长生王夫人。得其地平整于四交道头日初出时见四部兵共斗洗刀刃。时夫人得洗刀汁饮已胞胎成足。遂便生男儿。颜貌端正。即字为长。其年长大。王长生甚爱念之。时王梵施。闻拘萨罗王长生与第一夫人逃走作螺髻婆罗门在陶师家住。即敕傍人言。汝往陶师家。收取长生王及第一夫人。坚牢执持将来。并打恶声鼓为现死相。从右门出破为七分着尖标头。时王长生。闻梵施王作如是教敕。即唤儿长语言。汝今知不。伽奢国王梵施。是我父祖怨仇。彼夺我一切国土兵众。财宝都尽。并敕傍人令杀我等。汝可逃走。勿为梵施王所杀。时王子长即逃走。时梵施王。使人即收王长生及第一夫人执缚。并打恶声鼓现死相。众人聚集。时长生王子微服。寻父母后啼泣流泪。时王长生。顾见其子作如是言。怨无轻重。皆不足报。以怨报怨怨终不除。唯有无怨而除怨耳。如是再三言。时众人作如是念。拘萨罗王颠狂心乱。今日方教长摩纳。今谁是长摩纳也。时众人亦如是三言。时梵施王。使人即将长生王从右门出分为七分着尖标头。时长生王子长。从彼还入波罗奈城。学种种技术。学书学瞻相星宿秘谶算数及画诸形像音乐戏笑。在于众中最为第一。尔时梵施王妓女所住处。去边不远有调象师。时王子长。往象师所语言。我欲学调象。答言可学。时长摩纳。夜时过半弹琴歌戏出美音声。时王梵施。于夜闻弹琴歌戏声。其音调美。闻已即问傍人言。谁于夜过半弹琴歌戏。其音调好。答言。王今知不。去王妓女不远有调象师住。彼有弟子字长摩纳。是彼于夜过半弹琴歌戏声。其音调好。闻已即言。唤来我欲见之。即受教往唤来。头面礼王足已一面住。王问言。汝实于夜过半弹琴歌戏出美音声耶。答言尔。王言。汝今于我前可弹琴歌戏出美音声。时即于王前弹琴歌戏出美音声。王闻之极大欢喜。王言。住此当与汝食。答言尔。时王梵施第一夫人住屋无人得入者。唯王夫人及长摩纳。后异时夫人失摩尼珠。夫人至王所白言。王知不。我失摩尼珠。王言有谁入者。夫人言。更无人入。唯有王及我长摩纳。时王即唤长摩纳问言。我第一夫人失珠。汝取耶。彼作如是念。王夫人屋更无人入。唯有王夫人及我。若我言不取。恐王必当治我。我且由来习乐不堪苦毒。即报王言。我取。王言共谁取。答言共王大子。更复有谁。答言。复共第一有智慧大臣。更复有谁。答言。与王国中第一大长者。更复共谁。答言共第一淫女。时王即收长摩纳太子大臣长者第一淫女系之。王太子语长摩纳言。汝知我实不取珠。而虚言我取耶。长摩纳言。汝实不取我亦不取。汝是王第一太子。王所爱重。必不为珠故断汝命。以是故相引耳。第一有智慧大臣。语长摩纳言。汝实知我不取珠。而虚言我取耶。长摩纳言。汝实不取我亦不取。汝是有智慧大臣能觅得珠。是故相引耳。大长者语长摩纳言。汝实知我不取珠。而虚言我取耶。长摩纳答言。汝实不取我亦不取。汝是国之大长者。大富财宝无数。若王须珠汝能与之。以是故相引耳。第一淫女语长摩纳言。汝知我不取珠。而虚言我取耶。答言。汝实不取我亦不取。汝是第一淫女。多人系意在汝。未得汝者必求觅得珠。以是故相引耳。时波罗奈国白贼。闻王第一夫人失珠王收系摩纳太子大臣大长者淫女。即来至长摩纳所问言。王夫人实失珠不。答言失珠。问言谁入夫人屋。答言。唯王夫人及我。问言谁在中行。答言有猕猴在中行。彼言。长摩纳今珠可得耳。时贼即往梵施王所白王言。王今知不。今珠可得。王可出女人庄严具。王即出种种庄严具璎珞。集众猕猴令着璎珞置在宫中。时彼先在内猕猴。见诸猕猴皆着璎珞。便出所偷夫人珠。以自严身。时贼即四方围绕捕取猕猴。以白王言。王今知不。我已得珠。时王梵施。即唤长摩纳来语言。汝不取珠。何故言取耶。即答王言。我作如是念夫人屋无人入者。唯王夫人及我。我若言不取。恐王治我苦毒。而我不堪苦毒。故言取之耳。汝复何故引太子耶。答言。我作是念。太子王甚爱念。必不以珠故而断其命。以是故引太子耳。汝何故引第一大臣。答言。我作是念。大臣多知。必能作方便还求得珠。以是故引耳。汝复何故引大长者。答言。我作是念。王若须宝。长者大富。足能与王珠。是故引耳。汝复何故引淫女。答言。我作是念。国中人及与众贼。系心在彼淫女。其未得者。必能为淫女故。还觅得珠。是故引耳。王言未曾有。长摩纳。有如是智慧。王即用长摩纳作一切处尊。后于异时。梵施王严四部兵出行游猎。时王及四部兵。各各众乱逐鹿。时天热疲极。时长摩纳。即将王车至屏处止息。王下车在车阴中。枕长摩纳膝上眠。时长摩纳作如是念。此王是我父祖怨仇。破我国土。夺我父祖四部兵众及库藏宝物。一切皆尽。杀我父母。断拘萨罗王种。念昔日怨故。即时拔剑欲断王头。念父往言。怨无轻重。皆不足报。以怨除怨怨无已时。唯有无怨而怨自除耳。即还内剑。时梵施王惊觉。长摩纳问王言。何故惊耶。王言。拘萨罗王有儿。字长摩纳。拔剑欲断我命。即答王言。今此何处有长生王子长摩纳。唯有王及我耳。王但安眠。王第二眠亦如是。乃至第三眠。长摩纳如前思惟复拔剑。王即惊觉。时长摩纳即撮王头。王言汝欲杀我耶。答言尔。以何事故答言。我是长生王子长摩纳。王是我父祖怨仇。破我国土。夺我父一切兵众库藏宝物都尽。杀我父母。断拘萨罗王种。念此怨仇故。是故欲杀王耳。王即语言。今还汝父祖兵众国土一切珍宝。莫得杀我。答言当活王命。王亦莫杀我。王答言亦赦汝命。时彼共除父祖时怨。即共和合犹若父子。共同一乘还波罗[打-丁+柰]国。时王梵施。集诸大臣告如是言。若见长生王子长摩纳者当取云何。或有言治令如贝。或有言以刀杀之。或有言车掉之。或有言高悬其头。或有言然令如炬。或有言热油煎之。或有言刬其身。或有言利钩钩肉。或有言以蜜煮之。或有言缠身放火。或有言衣裹烧之。或有言截手截脚截耳截鼻。或言生贯着尖标头。或言截头。王即示诸臣言。此是长生王子长摩纳。自今已去一切众人不得论说。何以故。彼活我命我活彼命。时王即还其父时兵众及一切国土库藏珍宝。即庄严其女与之。汝等诸比丘。彼执刀剑长摩纳。有父祖怨仇。还共和合。犹若父子。汝等出家为道。同一师同一学。如水乳合。利益佛法安乐住止。止诸比丘。莫共斗诤共相骂詈诽谤互求长短。和合莫共诤。同一师学如水乳合。利益佛法安乐住。中有异比丘白佛言。世尊。但自安住。如来是法主。诸比丘斗诤事自当知。尔时世尊。第二第三语拘睒弥比丘。止止莫共斗诤骂詈诽谤互求长短。和合共住同一师学如水乳合。利益佛法安乐住。彼比丘如是言。世尊。但自安住如来是法主。比丘斗诤事自当知。尔时世尊。为拘睒弥比丘。说此偈言

  众恶声流布　　不求尊上法
  破于众僧时　　亦不以余事
  断骨害生命　　盗取牛马财
  国土斗诤乱　　亦有还和合
  汝曹可无有　　种种骂詈者
  其有如是者　　彼怨终不除
  种种恶骂詈　　终不还加报
  其能忍默者　　彼怨自得除
  以怨除怨仇　　怨仇终不除
  无怨怨自息　　其法勇健乐
  亦不教他作　　己身亦不为
  能行如是者　　如雨淹众尘
  无坚说坚牢　　坚牢不见坚
  彼不解坚牢　　堕邪忆念中
  坚牢知坚牢　　不坚知不坚
  彼解坚牢法　　入于正念中
  犹如人执箭　　执缓自伤手
  沙门不善良　　增益于地狱
  若能善执箭　　执急不伤手
  沙门善自良　　便得生善道
  虽有袈裟服　　坏抱于结使
  不能除怨害　　彼不应袈裟
  结使已除灭　　持戒自庄严
  调伏于怨仇　　彼则应袈裟
  处处遍求伴　　无有称己者
  宁独坚其心　　不与愚者同
  若处处求伴　　不得如己者
  宁独自行善　　不与愚恶伴
  独行莫作恶　　如山顶野象
  若审得善伴　　共行住勇健
  游处在诸众　　其心常欢喜
  若不得善伴　　独行常勇健
  舍于郡国邑　　无事如野象

尔时世尊。以拘睒弥比丘斗诤共相诽谤骂詈众僧恼乱。世尊不喜。不语众僧及供养人。自举卧具着本处。执持衣钵以神足力。从拘睒弥还舍卫国。时拘睒弥诸优婆塞。闻世尊以诸比丘斗诤共相诽谤骂詈众僧恼乱。世尊不喜不语众僧及供养人。自举卧具着本处执持衣钵。以神足力从拘睒弥国还舍卫国。时诸优婆塞。自共作制限。我等众人。都不应见拘睒弥比丘起迎恭敬礼拜问讯语言及供养衣服饮食病瘦医药。彼诸比丘如似被举住。比丘比丘尼。优婆塞优婆夷国王大臣种种沙门外道。尽皆远离无有与语者。彼诸斗诤比丘遂无有利养。作如是念。我等可于世尊所灭此斗诤事。即往舍卫国。时舍利弗。闻拘睒弥比丘斗诤共相诽谤骂詈口如刀剑从拘睒弥来舍卫国。即与五百比丘往佛所。头面礼足却住一面。白世尊言。此拘睒弥比丘斗诤共。相诽谤骂詈口如刀剑。从拘睒弥来至舍卫国。我曹当云何。佛告舍利弗。应听二部所说。若有比丘如法语者。则应受彼语。称誉长养与为伴党。舍利弗复白佛言。云何知彼比丘是法语非法语。佛告舍利弗有十八事破僧。法非法毗尼非毗尼犯不犯轻言重有余无余粗恶不粗恶以应行不应行制不制说不说。佛告舍利弗。汝观此事。则知彼比丘如法语非法语。复白佛言。云何与拘睒弥比丘房舍卧具。佛言应持屏处房舍卧具与。若无屏处应作屏处与。如众僧分卧具法等与。舍利弗白佛言。众僧衣物。云何与拘睒弥比丘分。佛言。随上座次到应与。舍利弗白佛言。拘睒弥比丘若小食与粥时。当云何坐。佛告舍利弗。我先不作如是语耶。众僧破非法和合。应在身口不生恶处坐。众僧破如法和合事已灭应间阙一人坐处坐。尔时摩诃波阇波提比丘尼。闻拘睒弥比丘斗诤诽谤共相骂詈互求长短。从拘睒弥来至舍卫国。即与五百比丘尼俱诣世尊所。头面礼足却住一面。白佛言。大德。此拘睒弥比丘斗诤诽谤共相骂詈互求长短从拘睒弥来至舍卫国。我等当云何。佛告瞿昙弥。应听二部语。若有比丘如法语者。则应受彼语称誉长养与为伴党。复白佛言。云何知彼比丘是法语非法语。佛告瞿昙弥。有十八事破僧。法非法乃至说不说如上。汝观此事。则知彼比丘如法语非法语。瞿昙弥比丘尼。应从众僧乞教授在如法比丘部中求。尔时阿难邠坻。闻拘睒弥比丘斗诤诽谤共相骂詈互求长短口如刀剑从拘睒弥来舍卫国。与五百优婆塞俱诣世尊所。头面礼足却坐一面。白佛言。拘睒弥比丘斗诤诽谤共相骂詈互求长短口如刀剑从拘睒弥来至舍卫国。我等当云何。佛言。应听二部语如上。若有檀越布施。应分作二分。此亦是僧。彼亦是僧。居士如破金杖为二分。二俱是金。如是居士布施物。应分为二分。此亦是僧彼亦是僧。尔时毗舍佉无夷罗母。闻拘睒弥比丘斗诤诽谤共相骂詈互求长短口如刀剑从拘睒弥来至舍卫国。与五百优婆私俱诣世尊所。头面礼足却住一面白佛言。拘睒弥比丘斗诤诽谤共相骂詈互求长短口如刀剑从拘睒弥来至舍卫国。我等当云何。佛言。应听彼二部所说如上。若有布施衣物。应分为二分。此亦是僧彼亦是僧。如破金杖为二分。彼此是金。若有布施衣物。应分为二分。此亦是僧彼亦是僧。尔时被举比丘道路行静处。心自念言。我此诤事。应当引修多罗毗尼阿毗昙检校佛法是举非举。为是如法举羯磨成就。为是不如法举羯磨不成就耶。时即看修多罗毗尼阿毗昙检校佛法律作是念。是犯非为不犯。是举非为不举。如法举羯磨成就。非为不如法举羯磨不成就。彼即至随举比丘所。作如是言。我在道路行在静处思惟作是念。我今此斗诤事。是犯非犯耶。即看修多罗毗尼阿毗昙检校佛法律。是犯非为不犯。是举非为不举。如法举羯磨成就。非为不如法举羯磨不成就。时随举比丘。即将被举比丘。至举罪比丘所白言。此被举比丘。语我如是言。在道路行在静处思惟心自念言。如上所说。尔时举罪比丘。即将随举比丘被举比丘。诣世尊所头面礼足已。却坐一面。白佛言。此随举比丘。将被举比丘来至我所。以被举比丘因缘具向我说。今即复以此因缘具白世尊。世尊告诸比丘。是犯非不犯。是举非不举。如法举此比丘羯磨成就。若彼比丘。顺从众僧忏悔改过。求索解不见举羯磨者。即应白四羯磨解。应如是解。彼比丘。应至僧中偏露右肩脱革屣礼僧足。已右膝着地合掌白如是言。大德僧听。我某甲比丘。僧举我作不见举羯磨。我今顺从众僧改过忏悔。乞解不见举羯磨。愿僧慈愍故为我解。如是第二第三说。是中应差堪能作羯磨者。若上座若次坐。若诵律若不诵律。能羯磨者如是白。大德僧听。此某甲比丘。僧作不见举羯磨。今顺从众僧改过忏悔。乞解不见举羯磨。若僧时到僧忍听。某甲比丘。僧与解不见举羯磨。白如是。大德僧听。某甲比丘。僧与作不见举羯磨。彼顺从众僧改过忏悔。今求僧乞解不见举羯磨。谁诸长老忍。僧解彼某甲比丘不见举羯磨者默然。谁不忍者说。是第一羯磨。如是第二第三说。僧已忍。与某甲比丘解不见举羯磨竟。僧忍默然故。是事如是持。佛言。听作白羯磨和合。应如是白。大德僧听。所因事令僧斗诤诽谤共相骂詈互求长短。彼人犯事被举。今已还解已灭僧尘垢。若僧时到僧忍听。僧作和合白如是。应作如是白和合。时优波离。从坐起偏露右肩脱革屣右膝着地合掌白世尊言。所因事令僧斗诤诽谤骂詈互求长短令僧破令僧别异住令僧尘垢。彼事未料理未处分未灭僧尘垢。颇得如法和合不。佛言。不得如法和合。优波离。彼所因诤事。令僧斗诤诽谤骂詈互求长短。令僧破令僧别住令僧尘垢。彼诤事已料理。已分处。已灭僧尘垢。得如法和合。佛言。自今已去听作白羯磨和合布萨。应作如是白。大德僧听。彼所因事。令僧斗诤诽谤骂詈互求长短。令僧破令僧别住令僧尘垢。彼人僧为作举罪。已还为解。已灭僧尘垢。若僧时到僧忍听。僧作和合布萨白如是。应如是白已和合布萨。尔时佛告优波离。有五种犯罪人。何等五。比丘如是犯罪。余比丘语言。汝犯罪见不。答言不见。彼语此比丘言。若见此罪应忏悔。此是第一犯罪人。比丘如是犯罪。余比丘语言。汝犯罪见不。答言不见。彼比丘言。汝若见罪。应僧中忏悔。是第二犯罪人。比丘如是犯罪。余比丘语言。汝犯罪见不。答言不见。彼比丘言。汝若见罪。当于此僧中忏悔。是第三犯罪人。比丘如是犯罪。余比丘语言。汝犯罪见不。答言不见。众僧应舍弃莫问。语如是言。汝今不见罪。汝所往之处彼亦当举汝罪为汝作自言。不听汝作阿[少/兔]婆陀。不听布萨自恣。如调马师。恶马难调。即合所系杙弃之。汝比丘不自见罪。亦复如是一切舍弃。汝所往之处。乃至不听汝布萨自恣。如是人不应从求听如是此即是听。此是第四犯罪人比丘如是犯罪。余比丘语言。汝犯罪见不。答言不见。彼应众僧中作不见举白四羯磨。此是第五犯罪人。时长老优波离。从坐起偏露右肩脱革屣右膝着地合掌白佛言。有几法应得作料理事人。佛言。有五法应料理。何等五。欲作事比丘。应观察此事实不实。或有事不实。彼比丘若知此事不实。不应作。彼比丘若知此事实。应更观察此事有利益无利益。或有事无利益。彼比丘若知此事无利益。不应作。若比丘知此事有利益。应更观察此事时作非时作。或有事非时作。彼比丘若知是事非时作。不应作。彼比丘若知此事是事作。应更重观察。若作此事。令僧斗诤诽谤骂言。令僧破令僧别住令僧尘垢。为不令僧斗诤。乃至不令僧尘垢。彼比丘若知作事令僧斗诤乃至令僧尘垢不应作。若比丘作事不令僧斗诤乃至不令僧尘垢。彼比丘应重更观察。若比丘作事为得伴党不得伴党。或作事不得比丘伴党。彼比丘若知作事不得比丘伴党。不应作。彼比丘若知得比丘伴党。应知时好心善念应作。优波离。比丘知此五法。应得作料理事人。尔时优波离。即从坐起偏露右肩右膝着地合掌向佛。而说偈言

  为僧说此语　　义利决定故
  云何得知胜　　比丘得坚持

尔时世尊。说偈答优波离言

  第一持戒不毁坏　　比丘威仪自端身
  怨家不能如法呵　　彼能得是他无语
  彼住如是清净戒　　得无畏说无疑难
  在众不怖无变异　　不失于义随问答
  如是众中而问义　　卒答不思无忧虑
  随时问义皆能答　　应答诸问心无异
  恭敬长老诸比丘　　上座中座及下座
  能说因本善分别　　解诸怨家欺诈语
  怨家不能得其胜　　亦能调伏于多人
  常为师教而不亏　　庄严智慧众所可

  若犯如是事　　不犯得罪除
  此垢二俱知　　知垢忏悔除
  不悔众所遣　　若悔众不驱
  如是人应劝　　分别如是知
  有信则能受　　为僧故而遣
  众遣能用语　　能作不自高
  恭敬于长老　　上中及下座
  智慧多利益　　是人能护法

(拘睒弥揵度具足竟)

四分律卷第四十三四分律卷第四十四(三分之八)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    瞻波揵度第十

尔时世尊。在瞻波城伽尸国婆娑婆聚落。时异住处有旧比丘。常接众人犹如泉水。作如是言。若未来客比丘。我当供给所须为作洗浴饮食供养。时有众多比丘。在伽尸国人间游行。至婆娑婆聚落。时彼比丘。即供给所须食饮供养。彼比丘异时作如是念。我不能常从白衣乞索饮食供具作洗浴作粥供养。此客比丘道路远来。今已懈息。本未有知识今已有知识。我今宁可不复求索。于是即止。彼客比丘作是念。此比丘憎我曹。本供给我等所须饮食洗浴之具。今止不复与我。我等宁可举此比丘耶。彼即和合举此比丘。彼比丘作是念。我今不能自知是犯非犯是举非举。为如法举羯磨成就。为不如法举羯磨不成就。我今宁可往瞻婆世尊所以此因缘具白世尊。世尊若有言教。随世尊所教我当施行

尔时此旧比丘持衣钵。诣瞻婆往世尊所。头面作礼已却住一面。尔时世尊慰劳客比丘。乞求易得不。住止和合不。道路不疲极不。答言。住止和合乞求易得道路不疲极。汝比丘从何所来。彼比丘言。我在伽尸国婆娑婆聚落。于异住处旧比丘常接众客所须。犹如泉水。若未来有客比丘来者。供给所须饮食若作粥洗浴具。后有众多比丘。在伽尸国人间游行至婆娑婆聚落。我时即供给所须饮食若作粥洗浴具。大德。我时作如是念。我不能常至白衣家乞索饮食所须之具。此诸客比丘今已懈息。本未有知识。今已有知识。我今宁可不复求索。于是即止彼客比丘作如是语旧比丘憎我等。先常供给我所须饮食作粥洗浴具。今不复供给我曹。宁可举彼比丘罪。即便共和合共举。大德。我作如是念。不能知是犯非犯是举非举为是如法举羯磨成就。为是不如法举羯磨不成就耶。我宁可往瞻婆城诣世尊所以此因缘具白世尊。世尊若有言教。随世尊教施行佛告彼比丘。汝比丘无犯非犯非举不成举非法举。汝比丘羯磨不成就。汝比丘可还去。至婆娑婆聚落。还供给众客所须。犹如泉水。比丘我共汝作伴。如法非不如法。时彼客比丘。从婆娑婆聚落人间游行。至伽尸国往世尊所。头面礼足却住一面

尔时世尊。慰劳客比丘。汝曹住止和合不。不以乞食疲苦耶。彼比丘答言。住止和合不以乞食为苦。问言。汝从何所来。答言。我从婆娑婆聚落来。问言。彼颇有旧住比丘。常供给众客所须。犹如泉水。汝等举耶。答言。实举世尊。佛问言。汝等以何事故举。答言无事无缘。尔时世尊以无数方便呵责彼比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何痴人。旧比丘供给客比丘。犹如泉水。而汝等无事而举。尔时世尊呵责客比丘已告诸比丘。有四羯磨。非法羯磨。非法别众羯磨。非法和合羯磨。法别众羯磨。是中二羯磨。非法羯磨别众羯磨不应作。若作如法治。法羯磨和合羯磨应作。有四满数。有人得满数不应呵。有人不得满数应呵。有人不得满数亦不应呵。有人得满数亦应呵。何等人得满数不应呵。若为作呵责羯磨摈羯磨依止羯磨遮不至白衣家羯磨。彼人得满数不得呵。何等人不得满数应呵。若欲受大戒人。此人不得满数得呵。何等人不得满数亦不得呵。若为比丘作羯磨。比丘尼不得满数不得呵。式叉摩那沙弥沙弥尼。若言犯边罪。若犯比丘尼。若贼心受戒若坏二道。若黄门。若杀父母。若杀阿罗汉。若破僧。若恶心出佛身血。若非人畜生。若二根。若被举。若灭摈。若应灭摈。若别住。若在戒场上。若神足在空。若隐没。若离见闻处。若所为作羯磨人。如是等人不得满数不应呵。何等人得满数亦得呵。若善比丘同一界住。不以神足在空不隐没。不离见闻处乃至语傍人。如是等人得满数应呵。时六群比丘。一人举一人。一人举二人。或举三人或举僧。二人举一人二人举二人。或举三人或举僧。三人举一人或举二人。或举三人或举僧。僧举僧。诸比丘白佛。佛言。不得一人举一人二人三人举僧。不得二人举一人二人三人举僧。不得三人举一人二人三人举僧。不得僧举僧。若一人举一人。非法羯磨非毗尼羯磨不应尔。若一人举二人三人僧。若二人举一人二人三人僧。若三人举一人举二人举三人举僧。僧举僧。非法羯磨非毗尼羯磨。不应尔。尔时六群比丘。重作羯磨。作呵责羯磨已。复作摈羯磨。作依止。作遮不至白衣家。与作举。与作波利婆沙。与作本日治。与摩那唾。与阿浮诃那。与现前毗尼。与忆念毗尼。与不痴毗尼。与自言治。与作多觅罪。与作多觅罪相。与如草覆地。诸比丘白佛。佛言。不应重作羯磨。不应作呵责羯磨已复作摈羯磨乃至如草覆地。尔时佛告诸比丘。有四种僧。四人僧五人僧十人僧二十人僧是中四人僧者。除自恣受大戒出罪。余一切如法羯磨应作。是中五人僧者。在中国除受大戒出罪。余一切如法羯磨应作。是中十人僧者除出罪。余一切如法羯磨应作。是中二十人僧者。一切羯磨应作。况复过二十。若应四人羯磨。四人少一人作羯磨者。非法非毗尼羯磨。若以比丘尼作第四人。若以式叉摩那沙弥沙弥尼若言犯边罪若犯比丘尼。若贼心受戒若坏二道若黄门。若杀父母杀阿罗汉恶心出佛身血。若非人若畜生若二根。若被举若灭摈若应灭摈所为作羯磨人。以如是人足满四人。非法非毗尼羯磨不应尔。五人僧十人僧二十人僧亦如是。尔时六群比丘。作非法非毗尼羯磨。彼作非法别众羯磨。非法和合羯磨。法别众羯磨。法相似别众羯磨。法相似和合羯磨。作呵不止羯磨。诸比丘白佛。佛言。不应作非法非毗尼羯磨。不应作非法别众羯磨。不应作非法和合羯磨。不应作法别众羯磨。不应作法相似别众羯磨。不应作法相似和合羯磨。不应作呵不止羯磨。云何非法非毗尼羯磨。白二羯磨。作白已不作羯磨。是名非法非毗尼羯磨不应尔。作二白不作羯磨。作三白不作羯磨。作众多白不作羯磨。非法非毗尼羯磨不应尔。白二羯磨。作一白二羯磨。非法非毗尼羯磨不应尔。作一白三羯磨。作一白众多羯磨。作二白一羯磨。作二白二羯磨。作二白三羯磨。作二白众多羯磨。作三白一羯磨。作三白二羯磨。作三白三羯磨。作三白众多羯磨。作众多白一羯磨。作众多白二羯磨。作众多白三羯磨。作众多白众多羯磨。非法非毗尼羯磨不应尔。白二羯磨。作一羯磨不作白。非法非毗尼羯磨不应尔。作二羯磨不作白。作三羯磨不作白。作众多羯磨不作白。非法非毗尼羯磨不应尔。白二羯磨。作一羯磨二白。非法非毗尼羯磨不应尔。作一羯磨三白。作一羯磨众多白。作二羯磨一白。作二羯磨二白。作二羯磨三白。作二羯磨众多白。作三羯磨一白。作三羯磨二白。作三羯磨三白。作三羯磨众多白。作众多羯磨一白。作众多羯磨二白。作众多羯磨三白。作众多羯磨众多白。非法非毗尼羯磨不应尔。白二羯磨。不如白法作白。不如羯磨法作羯磨。非法非毗尼羯磨不应尔。白四羯磨。作一白不作羯磨。非法非毗尼羯磨不应尔。作二白不作羯磨。作三白不作羯磨。作众多白不作羯磨。非法非毗尼。羯磨不应尔。作一白一羯磨。作一白二羯磨。作一白众多羯磨。作二白一羯磨。作二白二羯磨。作二白三羯磨。作二白众多羯磨。作三白一羯磨。作三白二羯磨。作三白三羯磨。作三白众多羯磨。作众多白一羯磨。作众多白二羯磨。作众多白三羯磨。作众多白众多羯磨。非法非毗尼羯磨不应尔。白四羯磨。作一羯磨不作白。非法非毗尼羯磨不应尔。作二羯磨不作白。作三羯磨不作白。作众多羯磨不作白。非法非毗尼羯磨不应尔。作一羯磨一白。作一羯磨二白。作一羯磨三白。作一羯磨众多白。作二羯磨一白。作二羯磨二白。作二羯磨三白作二羯磨众多白。作三羯磨二白。作三羯磨三白。作三羯磨众多白。作众多羯磨一白。作众多羯磨二白。作众多羯磨三白。作众多羯磨众多白。非法非毗尼羯磨不应尔。作白四羯磨。不如白法作白。不如三羯磨法作羯磨。非法非毗尼羯磨不应尔。是中有比丘见无罪。余比丘语言。汝犯罪见不。答言不见。彼即举作不见罪羯磨。佛言。非法非毗尼羯磨不应尔。是中有比丘无忏悔罪。余比丘语言。汝犯罪应忏悔。答言。我不忏悔。彼即举作不忏悔羯磨。佛言。非法非毗尼羯磨不应尔。是中有比丘。无恶见不舍。余比丘语言。汝有恶见应舍。答言我不舍。彼即举作恶见不舍羯磨。佛言。非法非毗尼羯磨不应尔。是中有比丘。见无罪无罪忏悔。余比丘语言。汝见罪不。汝应忏悔。答言。我不见罪我不忏悔。彼即举作不见罪不忏悔羯磨。佛言。非法非毗尼羯磨不应尔。是中有比丘。见无罪无恶见不舍。余比丘语言。汝见有罪恶见应舍。答言。我不见罪无恶见不舍。彼即举作不见罪恶见不舍羯磨。佛言。非法非毗尼羯磨不应尔。是中有比丘。无罪忏悔无恶见不舍。余比丘语言。汝有罪应忏悔舍恶见。答言。我不忏悔我无恶见不舍。彼即举作不忏悔不舍恶见羯磨。佛言。非法非毗尼羯磨不应尔。是中有比丘。见无罪无罪忏悔无恶见不舍。余比丘语言。汝见罪应忏悔舍恶见。答言。我不见罪不忏悔无恶见不舍。彼即举作不见罪不忏悔不舍恶见羯磨。佛言。非法非毗尼羯磨不应尔。是中有比丘。无罪见无罪。余比丘问言。汝见罪不。答言见。彼比丘即举作不见罪羯磨。佛言。非法非毗尼羯磨不应尔。是中有比丘无罪忏悔。余比丘语言。汝有罪应忏悔。答言当忏悔。彼比丘即举作不忏悔羯磨。佛言。非法非毗尼羯磨不应尔。是中有比丘无恶见不舍。余比丘语言。汝有恶见应舍。答言我当舍。彼即举作恶见不舍羯磨。佛言。非法非毗尼羯磨不应尔。是中有比丘。无罪见无罪不忏悔。余比丘语言汝见罪应忏悔。答言我见罪当忏悔。彼即举作不见罪不忏悔羯磨。佛言。非法非毗尼羯磨不应尔。是中有比丘无见罪无恶见不舍。余比丘语言。汝见罪恶见应舍。答言。我见罪当舍恶见。彼即举作不见罪不舍恶见羯磨。佛言非法非毗尼羯磨不应尔。是中有比丘无罪忏悔无恶见不舍。余比丘语言。汝有罪应忏悔恶见应舍。答言。当忏悔舍恶见。彼即举作不忏悔不舍恶见羯磨。佛言。非法非毗尼羯磨不应尔。是中有比丘见无罪无罪忏悔无恶见不舍。余比丘语言。汝见罪当忏悔恶见应舍。答言。我见罪当忏悔舍恶见。彼即举作不见罪不忏悔恶。见不舍羯磨。佛言非法。非毗尼羯磨不应尔。是中有比丘见有罪。余比丘语言。汝有罪见不。答言见。彼即举作不见罪羯磨。佛言。非法非毗尼羯磨不应尔。是中有比丘有罪忏悔。余比丘语言。汝有罪应忏悔。答言我当忏悔。彼即举作不忏悔羯磨。佛言。非法非毗尼羯磨不应尔。是中有比丘。有恶见不舍。余比丘语言。汝有恶见应舍。答言当舍。彼即举作不舍恶见羯磨。佛言。非法非毗尼羯磨不应尔。是中有比丘。见有罪有罪应忏悔。余比丘语言。汝见有罪应忏悔。答言我见罪当忏悔。彼即作举不见罪不忏悔羯磨。佛言。非法非毗尼羯磨不应尔。是中有比丘。见有罪有恶见不舍。余比丘语言。汝见有罪恶见应舍。答言。我见罪当舍恶见。彼比丘即举作不见罪恶见不舍羯磨。佛言。非法非毗尼羯磨不应尔。是中有比丘。有罪忏悔有恶见不舍。余比丘语言。汝有罪当忏悔恶见当舍。答言。我当忏悔当舍恶见。彼即举作不忏悔不舍恶见羯磨。佛言。非法非毗尼羯磨不应尔。是中有比丘。见有罪忏悔恶见不舍。余比丘语言。汝见罪当忏悔恶见应舍。答言。我见罪当忏悔舍恶见。彼即举作不见罪不忏悔不舍恶见羯磨。佛言。非法非毗尼羯磨不应尔。是为非法非毗尼羯磨。云何如法如毗尼羯磨。白二羯磨。如白法作白。如羯磨法作羯磨。如法如毗尼羯磨应尔。白四羯磨。如白法作白。如三羯磨法作羯磨。如法如毗尼羯磨应尔。是中有比丘见有罪。余比丘问言。汝有罪见不。答言不见。彼即举作不见罪羯磨。佛言。如法如毗尼羯磨应尔。是中有比丘。有罪应忏悔。余比丘语言。汝有罪应忏悔。答言。我不忏悔。彼即举作不忏悔羯磨。佛言。如法如毗尼羯磨应尔。是中有比丘恶见不舍。余比丘语言。汝有恶见应舍。答言不舍。彼即举作恶见不舍羯磨。佛言。如法如毗尼羯磨应尔。是中有比丘见有罪有罪忏悔。余比丘语言。汝见有罪有罪忏悔。答言不见不忏悔。彼即如其所犯。作不见罪。不忏悔羯磨。佛言。如法如毗尼羯磨应尔。是中有比丘见有罪有恶见不舍。余比丘语言。汝有罪有恶见应舍。答言。我不见罪恶见不舍。彼即如其所犯罪。与作不见罪恶见不舍羯磨。佛言。如法如毗尼羯磨应尔。是中有比丘。有罪忏悔恶见不舍。余比丘语言。汝有罪当忏悔恶见当舍。答言。我不忏悔不舍恶见。彼即如其所犯。作不忏悔不舍恶见羯磨。佛言。如法如毗尼羯磨应尔。是中有比丘。见有罪忏悔恶见不舍。余比丘语言。汝见有罪当忏悔恶见应舍。答言。我不见罪不忏悔不舍恶见。彼即如其所犯罪。作不见罪不忏悔不舍恶见羯磨。佛言。如法如毗尼羯磨应尔。是为如法如毗尼羯磨。云何非法别众羯磨。同一住处羯磨时有不来者。应与欲而不与欲。在现前应呵者便呵。彼作白二羯磨。作白四羯磨。白此事乃为彼事作羯磨。是为非法别众羯磨。云何非法和合羯磨。有同一住处。和合一处羯磨时有不来。应与欲者与欲。在现前应得呵者不呵。作白二羯磨作白四羯磨。白此事乃为彼事作羯磨。是为非法和合羯磨。云何法别众羯磨。同一住处羯磨时有不来者。应与欲不与欲。在现前应得呵者呵彼作白二白四羯磨如法作。是为法别众羯磨。云何法相似别众羯磨。同一住处羯磨时有不来者。应与欲不与欲。在现前应呵者呵。作白二白四羯磨。前作羯磨后作白。是为法相似别众羯磨。云何法相似和合羯磨。同一住处羯磨时有不来者。应与欲者与欲。在现前应得呵者不呵。白二白四羯磨。前作羯磨后作白。是为法相似和合羯磨。何等人作呵责成呵。或有人呵成呵。或有人呵不成呵。何者呵不成呵。为比丘作羯磨。比丘尼呵不成呵。式叉摩那沙弥沙弥尼。若言犯边罪。犯比丘尼。或贼心受戒。或坏二道黄门。杀父母杀阿罗汉。恶心出佛身血破和合僧。非人畜生二根。若被举若灭摈若应灭摈。若在戒场上。若作别住。若以神足在空若隐没。若离见闻处。若所为作羯磨人。如是人呵不成呵。云何呵成呵。若善比丘同在一界内住。不在空不隐没。不离见闻处乃至语比坐。如是人呵成呵。是为呵羯磨。尔时优波离。从坐起偏露右肩右膝着地合掌白佛言。应作呵责羯磨乃与作摈羯磨如法如毗尼羯磨不。佛语优波离。此不如法羯磨。优波离复白佛言。应与作呵责羯磨乃与作依止羯磨。若乃作遮不至白衣家羯磨乃至如草覆地。是如法如毗尼羯磨不。佛言。不如法不应与作呵责羯磨乃作摈羯磨乃至如草覆地非法非毗尼羯磨不应尔。如是展转乃至如草覆地。非法非毗尼羯磨不应尔。佛语优波离。若应作呵责羯磨与作呵责羯磨。此是如法如毗尼羯磨应尔。如是乃至如草覆地羯磨。如法如毗尼羯磨应尔。尔时有异住处。众僧与比丘作呵责羯磨。乃作非法别众羯磨。余众僧闻彼众僧与比丘作呵责羯磨。乃作非法别众羯磨羯磨不成。我曹当与作呵责羯磨。即作呵责羯磨。非法和合。复有余处僧闻彼众僧为比丘作呵责羯磨非法和合羯磨不成。我曹当为作呵责羯磨。彼即作呵责羯磨。法别众。余处僧闻彼众僧为比丘作呵责羯磨法别众羯磨羯磨不成。我曹当为作呵责羯磨。即作呵责羯磨。法相似别众。余处僧闻彼众僧为比丘作呵责羯磨。法相似别众羯磨不成。我曹当为作呵责羯磨。法相似和合羯磨。彼比丘作如是念。我当云何。即白诸比丘。诸比丘白佛。佛言。诸如是不如法羯磨不成就。如是一切羯磨亦不成就。尔时有住处。众僧为比丘作非法别众羯磨。尔时众多僧皆共诤。或言非法别众羯磨。或言非法和合。或言法别众。或言法相似别众。或言法相似和合。或言羯磨成就。或言不成就。诸比丘不知云何告余比丘。余比丘往白佛。佛言。彼住处众僧。为比丘作呵责羯磨非法别众。是中众多僧各各共诤。或言非法别众。或言非法和合。乃至言成不成。是中僧言非法别众者。此是法语。乃至法相似和合者。此亦如是是法语。尔时优波离。从坐起偏露右肩右膝着地合掌白佛言。若有比丘。僧先与羯磨。后众僧与解。成不成解耶。佛语优波离。或成或不成。复问。云何成不成。佛告优波离。有十三种人。僧先为作羯磨不成解。除此十三种人已。为余人作羯磨已。若僧与解者得成解。优波离复问佛。若僧先为作羯磨为解羯磨已。驱出成驱出为不成耶。佛言。或有成驱出。或有不成驱出。若为十三种人作羯磨已。驱出成驱出。除此十三种。为余人作羯磨。后解羯磨得解。若驱出不成驱出(瞻波揵度具足竟)

    呵责揵度第十一之一

尔时佛在舍卫国。有二比丘。一名智慧。二名卢醯那。喜斗诤共相骂詈口出刀剑互求长短。彼自共斗诤骂詈。若复有余比丘共斗诤者。即复往彼劝言。汝等好自勉力莫不如他。汝等多闻智慧财富亦胜多有知识。我等为汝作伴党。是中众僧。未有诤事便有诤事。已有诤事而不除灭。诸比丘作如是念。以何因缘。众僧未有诤事令诤事起。已有诤事而不除灭。诸比丘即知此二比丘智慧卢醯那喜共斗诤共相骂詈口出刀剑互求长短自共斗诤骂詈。若有余比丘斗诤。即复往彼劝言。汝等好自勉力莫不如他。汝等多闻智慧财富亦胜多有知识。我等当为汝作伴党。是故令僧未有诤事便有诤事。已有诤事而不除灭。时众中有比丘闻。少欲知足行头陀乐学戒者。嫌责彼二比丘已。往世尊所头面礼足却坐一面。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责彼二比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何智慧卢醯那。共相斗诤骂詈口出刀剑互求长短。令僧未有诤事而有诤事已有诤事而不除灭。世尊以无数方便呵责已告诸比丘。听诸比丘与智慧卢醯那作呵责白四羯磨。应如是作集僧。集僧已为智慧等作举。作举已为作忆念。作忆念已应与罪。众中应差堪能羯磨者如上作如是白。大德僧听。此智慧卢醯那二比丘。喜共斗诤共相骂詈口出刀剑互求长短。彼自共斗诤已。若复有余比丘斗诤者。即复往彼劝言。汝等勉力莫不如他。汝等多闻智慧财富亦胜多有知识。我等当为汝作伴党。令僧未有诤事而有诤事。已有诤事而不除灭。若僧时到僧忍听。为智慧等二比丘作呵责羯磨。若后复更斗诤共相骂詈者。众僧当更增罪治。白如是。大德僧听。此智慧卢醯那二比丘。喜共斗诤共相骂詈口出刀剑互求长短。彼自共斗诤已。若复有余比丘斗诤者。即复往彼劝言。汝等勉力莫不如他。汝等智慧多闻财富亦胜多有知识。我等当为汝作伴党。令僧未有诤事而有诤事。已有诤事。而不除灭。僧为智慧等二比丘作呵责羯磨。谁诸长老忍。僧与智慧等二比丘作呵责羯磨。若后复更斗诤共相骂詈者。众僧当更增罪治。忍者默然。谁不忍者说。此是第一羯磨竟。如是第二第三说。僧已忍。为智慧等作呵责羯磨竟。僧忍默然故。是事如是持。为作呵责竟。五事不应作。一不应授人大戒。二不应受人依止。三不应畜沙弥。四不应受僧差教授比丘尼。五若僧差不应教授。是为呵责羯磨竟五事不应作。复有五事不应作。不应说戒。若僧中问毗尼义不应答。若众僧差作羯磨不应作。若僧中拣集智慧者共评论众事不得在其例。若僧差作信命不应作。是为呵责羯磨竟五事不应作。复有五事不应作。不得早入聚落。不得逼暮还。应亲近比丘不应亲近外道。应好顺从诸比丘教。不应作异语呵责竟五事不应作。复有五事不应作。众僧随所犯为作呵责羯磨已。不应复更犯此罪。余亦不应犯。若相似若从此生者。若复重于此。不应嫌羯磨及羯磨人。呵责竟五事不应作。复有五事不应作。善比丘为敷座供养不应受。不应受他洗足。不应受他安洗足物。不应受他拭革屣。不应受他揩摩身。呵责羯磨竟五事不应作。复有五事不应作。不应受善比丘礼拜合掌问讯迎逆持衣钵。呵责羯磨竟五事不应作。复有五事不应作。不应举善比丘。为作忆念。作自言不应证他事。不应遮布萨自恣。不应共善比丘诤。是为呵责竟五事不应作。应如是作。众僧为智慧卢醯那作呵责白四羯磨竟。诸比丘白佛。佛言。有三法作呵责羯磨。非法非毗尼羯磨不成就。云何三不作举不作忆念不伏首罪。复有三事无犯。犯不应忏悔。若犯罪已。忏悔竟。复有三事不作举。非法别众。复有三事不作忆念。非法别众。复有三事不伏罪。非法别众。复有三事不犯。非法别众。复有三事犯不应忏罪。非法别众。复有三事犯罪已。忏悔竟。非法别众。复有三事不现前。非法别众。如是三法作呵责羯磨。非法非毗尼羯磨不成就。复有三事作呵责羯磨。如法如毗尼羯磨成就。何等三。为作举作忆念作自言。复有三事。犯罪。犯可忏罪。犯未忏罪。复有三事。作举法和合。作忆念法和合。作自言法和合。犯罪法和合。犯可忏罪法和合。犯未忏悔罪法和合。现前法和合。是为三法作呵责羯磨。如法如毗尼羯磨成就。有五法作呵责羯磨。非法非毗尼羯磨不成就。不在现前不自言为清净者非法别众。是为五事作呵责羯磨。非法非毗尼羯磨不成就。有五法作呵责如法如毗尼羯磨成就。何等五。在现前自言不清净法和合。是为五法作呵责羯磨。如法如毗尼羯磨成就。若众僧在小食上后食上。若说法若布萨。被呵责羯磨人。正衣服脱革屣在一面住。胡跪合掌白如是言。大德受我忏悔。自今已去自责心止不复作。时智慧卢醯那比丘。随顺众僧无所违逆。求解呵责羯磨。诸比丘白佛。佛言。若随顺众僧无所违逆。求解呵责羯磨者。听解作白四羯磨。有五法不应为解呵责羯磨。不应授人大戒乃至与善比丘共斗呵责者。有如是五法。不应为解呵责羯磨。有五法应解。不授人大戒乃至不与善比丘共斗呵责羯磨者。有如是五法应解。应如是解。被呵责羯磨人。应至众僧中偏露右肩脱革屣。右膝着地合掌白言。大德僧听。我比丘某甲。僧与作呵责羯磨。我今随顺众僧无所违逆。从僧乞解呵责羯磨。愿僧慈愍故。为我解呵责羯磨。如是第二第三白。众中当差堪能作羯磨者如上作如是白。大德僧听。某甲比丘。僧为作呵责羯磨。彼比丘随顺众僧无所违逆。从众僧乞解呵责羯磨。若僧时到僧忍听。解某甲比丘呵责羯磨。白如是。大德僧听。此某甲比丘。僧为作呵责羯磨。彼比丘随顺众僧无所违逆。今从众僧乞解呵责羯磨。谁诸长老忍。僧为某甲比丘解呵责羯磨者默然。谁不忍者说。此是第一羯磨。第二第三亦如是说。僧已忍。解某甲比丘呵责羯磨竟。僧忍默然故。是事如是持。尔时世尊在舍卫国。时羁离那国。有二旧住比丘。一名阿湿卑。二名富那婆娑。在羁离那国行恶行污他家。行恶行亦见亦闻。污他家亦见亦闻。彼作如是恶行。自种华树教他种自溉教他溉。自摘华教他摘。自作华鬘教他作。自持种种华往教他持往白衣家。有男有女同一床坐。同一器食。同一器饮。歌舞戏笑作众伎乐。若他作者。即复唱和共作。或吹唇或弹鼓簧。或作吹贝声。或作孔雀声。或作鹤鸣。或走或佯跛行。或啸或作俳说人。或受雇戏笑。时众多比丘。从伽尸国人间游行。至羁离那国。清旦着衣持钵入城乞食。行步进止威仪庠序。视瞻安谛屈申俯仰。执持衣钵直视而前。诸根不乱。于羁离那国乞食。诸居士见已作如是言。此复是何等人。谛视而不戏笑。不左右顾视。不相亲近娱乐。亦不相慰问。我曹不应与此人食。不如我曹沙门阿湿卑富那婆娑亦不谛视。言语戏笑左右顾视共相娱乐而相慰问。如是人我曹当与饭食。时诸比丘在羁离那国乞食限得饱足。彼比丘作如是念。此中旧住比丘恶。恶比丘在中住。远离善比丘。彼作如是恶行。种若干华树。乃至受他雇使。时诸比丘。从羁离那国人间游行。还舍卫国诣世尊所头面礼足却坐一面。尔时世尊慰劳诸比丘。汝曹住止和合安乐不。不以饮食为疲苦耶。白佛言。众僧住止和合安乐。我曹从伽尸国人间游行。至羁离那国。具以因缘白世尊。世尊尔时以无数方便呵责言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何阿湿卑富那婆娑。污他家行恶行。污他家亦见亦闻。行恶行亦见亦闻。作众恶行。种杂华树。乃至受他雇使。尔时世尊呵责。阿湿卑富那婆娑已告诸比丘。听僧为阿湿卑富那婆娑作摈白四羯磨。应如是作集僧。集僧已为阿湿卑富那婆娑作举。作举已为作忆念。作忆念已与罪。是中应差堪能羯磨者如上作如是白。大德僧听。此阿湿卑富那婆娑比丘。于羁离那国污他家行恶行。彼污他家亦见亦闻。行恶行亦见亦闻。若僧时到僧忍听。僧为阿湿卑富那婆娑作摈羯磨。汝污他家行恶行。污他家亦见亦闻。行恶行亦见亦闻。汝可离此住处去。不须在此住处。白如是。大德僧听。此阿湿卑富那婆娑比丘。在羁离那国污他家行恶行。污他家亦见亦闻。行恶行亦见亦闻。僧今为阿湿卑富那婆娑作摈羯磨。汝污他家行恶行。污他家亦见亦闻。行恶行亦见亦闻。汝离此住处去。不须在此住。谁诸长老忍。僧为阿湿卑富那婆娑比丘作摈羯磨者默然。谁不忍者说。此是初羯磨竟。第二第三亦如是说。僧已忍。为阿湿卑富那婆娑作摈羯磨竟。僧忍默然故。是事如是持。作摈羯磨者。有五法不应作。不得授人大戒。乃至不得与善比丘共斗。应如是作。如上呵责羯磨。除余众中说戒。众僧已为阿湿卑富那婆娑比丘作摈白四羯磨已。诸比丘白佛。佛言。有三法有五法作摈羯磨。非法非毗尼羯磨不成就如上。有三法有五法作摈羯磨。如法如毗尼羯磨成就如上。彼被摈比丘不唤自来至界内。诸比丘白佛。佛言不应不唤来至界内。听在外住。遣好信来至僧中白。大德僧忏悔。自今已去自责心。更不复尔。彼阿湿卑比丘等。随顺众僧不敢违逆。从僧乞解摈羯磨。诸比丘白佛。佛言。若随顺众僧无所违逆。从僧乞解摈羯磨者。应与解作白四羯磨。有五法不应与解摈羯磨。从授人大戒乃至与善比丘共斗。复有五法应与解摈羯磨。从不授人大戒乃至不与善比丘共斗。如是解被摈比丘。应至僧中偏露右肩脱革屣。右膝着地合掌如是白。大德僧听。我某甲比丘。僧与我作摈羯磨。我今随顺众僧不敢违逆。从僧乞解摈羯磨。愿僧慈愍故。为我解摈羯磨。如是第二第三说。众中当差堪能羯磨者如上作如是白。大德僧听。此某甲比丘。僧与作摈羯磨。随顺众僧不敢违逆。从僧乞解摈羯磨。若僧时到僧忍听。僧今为某甲比丘解摈羯磨。白如是。大德僧听。此某甲比丘。僧为作摈羯磨。随顺众僧不敢违逆。从僧乞解摈羯磨。僧今为某甲比丘解摈羯磨。谁诸长老忍。僧为某甲比丘解摈羯磨者默然。谁不忍者说。是初羯磨。如是第二第三说。僧已忍。为某甲比丘解摈羯磨竟。僧忍默然故。是事如是持。尔时世尊在舍卫国。有比丘名僧刍痴无所知多犯众罪。共诸白衣杂住。而相亲附。不顺佛法。诸比丘闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责僧刍比丘言。汝痴无所知多犯众罪。云何共诸白衣杂住而相亲附。不随顺佛法耶。诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时集比丘僧。以无数方便呵责僧刍比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝共诸白衣杂住而相亲附。痴无所知多犯众罪不顺佛法。呵责已告诸比丘。听僧为僧刍比丘作依止白四羯磨。应如是作集僧。集僧已与作举。作举已与作忆念。作忆念已与罪。众中当差堪能作羯磨者如上作如是白。大德僧听。此僧刍比丘。痴无所知多犯众罪。共白衣杂住而相亲附不顺佛法。若僧时到僧忍听。与僧刍比丘作依止羯磨白如是。大德僧听。僧刍比丘。痴无所知多犯众罪。共白衣杂住而相亲附不顺佛法。僧今为僧刍比丘作依止羯磨。谁诸长老忍。僧为僧刍比丘作依止羯磨者默然。谁不忍者说。此是第一羯磨。第二第三亦如是说。僧已忍。为僧刍比丘作依止羯磨竟。僧忍默然故。是事如是持。作依止羯磨竟。五事不应作。不得授人大戒。乃至不得与善比丘共斗。应如是作。是中众僧。与僧刍比丘作依止白四羯磨竟。诸比丘白佛。佛言。有三法有五法。得作依止羯磨不得作依止羯磨如上。彼称方作依止羯磨。彼方破坏人民反叛。佛言。不应称方作依止羯磨。彼称国土作依止羯磨。彼国土破坏人民散乱。佛言。不应称国土作依止羯磨。彼称住处作依止羯磨。彼住处人民破坏。佛言。不应称住处作依止羯磨。彼称人作依止羯磨。彼人或破戒。或破见。或破威仪。或被举。或灭摈。或应灭摈。不能增益沙门法。佛言。不应称人作依止羯磨。彼称安居作依止羯磨。彼人安居中得智慧。佛言。不应依安居。作依止羯磨。听语言汝应受依止住。尔时僧刍比丘。与聚落中比丘亲厚多闻智慧善能语言。僧刍比丘。即往彼所学法毗尼。安居中得智慧。随顺众僧不敢违逆。从众僧乞解依止羯磨。诸比丘白佛。佛言。若僧刍比丘。随顺众僧不敢违逆。从众僧乞解依止羯磨。应与解作白四羯磨。有五法不应与解依止羯磨。从与人受大戒乃至与善比丘共斗。有五法应与解依止羯磨。从不与人授大戒乃至不与善比丘共斗。如是五法应与解依止羯磨。应如是解。彼被依止羯磨者。应来至僧中偏露右肩脱革屣右膝着地合掌作如是白。大德僧听。我比丘某甲。僧与我作依止羯磨。我今随顺众僧。从僧乞解依止羯磨。愿僧慈愍故。为我解依止羯磨。如是第二第三白。众中应差堪能作羯磨者如上作如是白。大德僧听。某甲比丘。僧与作依止羯磨。彼随顺众僧不敢违逆。从僧乞解依止羯磨。若僧时到僧忍听僧今为某甲比丘解依止羯磨白如是。大德僧听。某甲比丘。僧为作依止羯磨。随顺众僧不敢违逆。从僧乞解依止羯磨。僧今与某甲比丘解依止羯磨。谁诸长老忍。僧与某甲比丘解依止羯磨者默然。谁不忍者说。是初羯磨。如是第二第三说。僧已忍。与某甲比丘解依止羯磨竟。僧忍默然故。是事如是持。尔时世尊在舍卫国。时舍利弗目连与五百比丘俱。从伽尸国人间游行。至密林中。时舍利弗目连。在阿摩梨园中。时有质多罗居士。闻舍利弗目连从伽尸国人间游行至密林中在阿摩梨园中住。时彼居士。至舍利弗目连所。头面礼足却坐一面。舍利弗目连为种种说法开化。令得欢喜。时居士闻舍利弗等说法开解欢喜已白言。愿大德。与众僧俱受我明日请。舍利弗目连默然受之。居士知舍利弗目连许已。从坐起作礼而去。即还其家办具种种饮食世间美馔无味不有。尔时阿摩梨园中旧住比丘字善法。作如是念。我宁可往质多罗居士家看其办具饮食。云何为客比丘作食。云何为旧住比丘作食。尔时善法比丘。即往其家至作食处看。见其所办最上世间所有饮食之具无味不有。见已作如是言。居士为客比丘作异种种食。为旧住比丘作异种饮食。彼嫉姤心生嗔恚。便作如是恶言。居士所办具饮食中最胜世间所有饮食之具无味不有。唯无胡麻滓。彼质多罗居士即语言。长老善法。怀如是多宝根力觉意禅定正受。作如是粗言。善法。我办如是美食。用胡麻滓作何等。即复言。我今当说譬喻。有智之人以喻自解。譬如有国土无鸡。是中有贾客。持雌鸡来至国中。时彼雌鸡。无有雄鸡。与乌共通。时鸡便生卵有子出。不作鸡鸣复不乌唤。即名之为乌鸡。如是善法。怀如是多宝根力觉意禅定正受。而作此粗言。办具如是上馔美食。方求胡麻滓用作何等。彼作如是言。居士骂我。我今欲去。居士言。大德善法。我不恶言。亦不骂詈。大德善法。可乐在此密林中住。我当供给衣被卧具饮食汤药。彼作如是言。居士骂我我欲去。即问言。大德。欲至何处去。答言。我欲至舍卫国世尊所。居士言。如我所共言语具白世尊。无令增减。何以故。汝当还来至我所。尔时善法比丘。持衣钵诣世尊所。头面礼足已却坐一面。时世尊慰问诸比丘。住止安乐不。不以饮食疲苦耶。答言。住止安乐。不以饮食为苦。以居士所言之事具白世尊。无有增减。尔时世尊以无数方便呵责善法比丘言汝所为非非威仪非沙门法非净行非随顺行。所不应为。云何善法。彼居士有信乐。作檀越多有利益供给众僧乃以下贱言骂他。时世尊呵责善法已告诸比丘。听诸比丘为善法比丘作遮不至白衣家白四羯磨。有五法。比丘不应为。作遮不至白衣家羯磨。不恭敬父母。不敬沙门婆罗门。所应持者而不坚持。有如是五法。僧不应与作遮不至白衣家羯磨。有五法应为作遮不至白衣家羯磨。恭敬父母沙门婆罗门。所应持者坚持不舍。有如是五法。僧应为作遮不至白衣家羯磨。比丘有十法。应与作遮不至白衣家羯磨。恶说骂白衣家。方便令白衣家损减。作无利。作无住处。斗乱白衣。于白衣前谤佛法僧。在白衣前作下贱骂。如法许白衣而不实。比丘有如是十法。应与作遮不至白衣家羯磨。如是有九法八法乃至一法恶说骂白衣。应与作遮不至白衣家羯磨。应如是作集僧。集僧已为作举。作举已为作忆念。作忆念已与罪。众中应差堪能作羯磨者如上作如是白。大德僧听。此善法比丘。质多罗居士信乐檀越。常好布施供给众僧。而以下贱恶骂詈之。若僧时到僧忍听僧今为善法比丘作遮不至白衣家羯磨白如是。大德僧听。善法比丘。质多罗居士信乐檀越。常好布施供给众僧。而以下贱骂詈之。僧今为善法比丘作遮不至白衣家羯磨。谁诸长老忍。僧为善法比丘作遮不至白衣家羯磨者默然。谁不忍者说。是初羯磨。第二第三亦如是说。僧已忍。与善法比丘作遮不至白衣家羯磨竟。僧忍默然故。是事如是持。彼作遮不至白衣家羯磨已。有五法不应作。不得授人大戒。乃至不得与善比丘共斗。应如是作。僧为善法比丘作遮不至白衣家白四羯磨竟。诸比丘白佛。佛言。有三法有五法。作遮不至白衣家羯磨。非法非毗尼羯磨不成就如上。有三法有五法。作遮不至白衣家羯磨。如法如毗尼羯磨成就如上。佛言。听差使至质多罗居士家为善法比丘忏悔质多罗居士作白二羯磨。有八法应差使。一闻。二能善说。三已自解。四能解人意。五受人语。六能忆持。七无阙失。八解善恶言义。有如是八法应差使。即说偈言

  在众智人前　　言无有错谬
  亦无有增减　　不失所言教
  言不可破坏　　闻不以倾动
  有如此比丘　　堪能为作使

有如是八法。阿难尽能持。闻能善说己身自解。能解人意受人语。能忆持无有阙失。解善恶言义。佛言。听僧差阿难为使为善法比丘忏悔质多罗居士。作白二羯磨。应如是作众中。差堪能作羯磨者如上作如是白。大德僧听。若僧时到僧忍听。差阿难为使。为善法比丘忏悔质多罗居士白如是。大德僧听。今僧差阿难为使。为善法比丘忏悔质多罗居士。谁诸长老忍。差阿难为使为善法比丘忏悔质多罗居士者默然。谁不忍者说。僧已忍。差阿难为使。为善法比丘忏悔质多罗居士竟。僧忍默然故是事如是持。僧差使竟。至居士家如是语。居士忏悔。僧已为善法比丘作罚谪。彼若受忏悔者善。若不受应至眼见耳不闻处安羯磨比丘着眼见耳不闻处教令如法忏悔。复来语居士言。居士忏悔。彼比丘先犯罪今已为忏悔罪已除。彼若受忏悔者善。若不受者。犯罪比丘应自往忏悔。如是阿难。闻世尊教已。将善法比丘至质多罗居士家语言忏悔居士。彼比丘僧。已为作谪罚。质多罗居士即共忏悔。时善法比丘。顺从众僧不敢违逆。从众僧乞解遮不至白衣家羯磨。诸比丘白佛。佛言。若善法比丘。随顺众僧无所违逆。乞解遮不至白衣家羯磨。应与解白四羯磨。有五法不应与解遮不至白衣家羯磨。从授人大戒乃至与善比丘共斗。有五法应与解遮不至白衣家羯磨。从不授人大戒乃至不与善比丘共斗。有如是五法。应与解遮不至白衣家羯磨。应如是解。彼被羯磨人。应来至僧中。偏露右肩脱革屣右膝着地合掌。白如是言。大德僧听。我比丘某甲。僧与作遮不至白衣家羯磨。我今随顺众僧不敢违逆。从众僧乞解遮不至白衣家羯磨。愿僧慈愍故。为我解遮不至白衣家羯磨。如是第二第三说。众中应差堪能羯磨者如上作如是白。大德僧听。某甲比丘。僧为作遮不至白衣家羯磨。彼比丘随顺众僧不敢违逆。从众僧乞解遮不至白衣家羯磨。若僧时到僧忍听。今僧为解遮不至白衣家羯磨白如是。大德僧听。彼某甲比丘。僧为作遮不至白衣家羯磨。彼比丘随顺众僧不敢违逆。从僧乞解遮不至白衣家羯磨。僧今为某甲比丘解遮不至白衣家羯磨。谁诸长老忍。僧为某甲比丘解遮不至白衣家羯磨者默然。谁不忍者说。是初羯磨。如是第二第三说。僧已忍。为某甲比丘解遮不至白衣家羯磨竟。僧忍默然故。是事如是持

四分律卷第四十四四分律卷第四十五(三分之九)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    呵责揵度之余

尔时世尊在拘睒弥。时阐陀比丘犯罪。余比丘语言。汝犯罪见不。答言不见。时诸比丘闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责阐陀比丘言。云何犯罪。诸比丘语言。汝犯罪见不。答言不见。时诸比丘即往世尊所。头面礼足却住一面。以此因缘具白世尊。世尊尔时。以此因缘集比丘僧。呵责阐陀比丘。云何阐陀比丘汝犯罪。诸比丘语言。汝犯罪见不。答言不见。世尊以无数方便呵责阐陀比丘。已告诸比丘。听众僧与阐陀比丘作不见罪举白四羯磨。应如是作。应集僧。集僧已作举。作举已与作忆念。作忆念已与罪。众中当差堪能作羯磨者如上作如是白。大德僧听。此阐陀比丘犯罪。余比丘语言。汝犯罪见不。答言不见。若僧时到僧忍听。今僧为阐陀比丘作不见罪举羯磨。白如是。大德僧听阐陀比丘犯罪。余比丘语言。汝犯罪见不。答言不见。今僧为作不见罪举羯磨。谁诸长老忍僧为阐陀比丘作不见罪举羯磨者默然。谁不忍者说是初羯磨。如是第二第三。说僧已。忍为阐陀比丘作不见罪举羯磨竟。僧忍默然故是事如是持。作不见罪举羯磨已。有五法不应作。不得授人大戒。乃至不得与善比丘共斗。应如是作。众僧为阐陀比丘作不见罪举白四羯磨已。诸比丘白佛。佛言。有三法有五法。作不见罪举羯磨非法非毗尼羯磨不成就如上。复有三法有五法。作不见罪举羯磨。如法如毗尼羯磨成就如上。彼不见罪举比丘。众僧若在小食大食上。若说法若布萨时。应往众僧中在一面住偏露右肩。脱革屣右膝着地合掌白言。大德。受我忏悔自责心意。从今已去不敢复作。阐陀比丘。随顺众僧不敢违逆。从僧乞解不见罪举羯磨。诸比丘白佛。佛言。若阐陀比丘。随顺众僧无有违逆。从僧乞解不见罪举羯磨者。应与作白四羯磨解有五法。不应与解不见罪举羯磨。从授人大戒乃至与善比丘共斗有五法。应与解不见罪举羯磨。从不授人大戒乃至不与善比丘共斗。应如是解。众中应差堪能作羯磨者如上作如是白。大德僧听。彼某甲比丘。僧与作不见罪举羯磨。随顺众僧不敢违逆。今从僧乞解不见罪举羯磨。若僧时到僧忍听。今僧为某甲比丘解不见罪举羯磨。白如是。大德僧听。某甲比丘。僧为作不见罪举羯磨。随顺众僧不敢违逆。从僧乞解不见罪举羯磨。僧今为某甲比丘解不见罪举羯磨。请诸长老忍。僧为某甲比丘解不见罪举羯磨者默然。谁不忍者说。是初羯磨。第二第三亦如是说。僧已忍。为某甲比丘解不见罪举羯磨竟。僧忍默然故。是事如是持。尔时世尊在拘睒弥。时阐陀比丘犯罪。诸比丘语。言汝有罪忏悔。答言不忏悔。诸比丘闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责阐陀比丘言。云何犯罪。余比丘语言。汝犯罪忏悔。答言不忏悔。诸比丘往世尊所。头面礼足却坐一面。以此因缘具白世尊。世尊以此因缘集比丘僧。以无数方便呵责阐陀比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何犯罪。余比丘语言。汝犯罪忏悔。答言不忏悔。呵责已告诸比丘言。听众僧与阐陀比丘作不忏悔罪举白四羯磨。应如是作。应集僧。集僧已与作举。作举已与作忆念。作忆念已与罪。众中应差堪能作羯磨者如上作如是白。大德僧听。此阐陀。比丘犯罪。余比丘语言。汝犯罪忏悔。答言不忏悔。若僧时到僧忍听。僧今与阐陀作不忏悔罪举羯磨。白如是。大德僧听。此阐陀比丘犯罪。余比丘语言。汝犯罪忏悔。答言不忏悔。谁诸长老忍。僧与阐陀作不忏悔罪举羯磨者默然。谁不忍者说。是初羯磨。第二第三如是说。僧已忍。为阐陀比丘作不忏悔罪举羯磨竟。僧忍默然故。是事如是持。彼作不忏悔罪举已。有五法不应作。从不得授人大戒。乃至不得与善比丘共斗。应如是作。众僧为阐陀作不忏悔举白四羯磨已。诸比丘白佛。佛言。有三法有五法。作不忏悔罪举羯磨。非法非毗尼羯磨不成就如上。有三法有五法。作不忏悔罪举羯磨。如法如毗尼羯磨成就如上。彼被作不忏悔罪举羯磨人。若众僧在小食大食上。若说法若布萨时。应至僧中在一面住偏露右肩脱革屣右膝着地合掌白言。大德受我忏悔。自责心意从今已去不敢复作。彼阐陀比丘。随顺众僧不敢违逆。从僧乞解不忏悔罪举羯磨。诸比丘白佛。佛言。若阐陀比丘。随从众僧不敢违逆。乞解不忏悔罪举羯磨者应与解作白四羯磨。有五法不应与解不忏悔罪举羯磨。从授人大戒乃至与善比丘共斗。有五法应与解不忏悔罪举羯磨。从不授人大戒乃至不与善比丘共斗。应如是解彼不忏悔罪举比丘。应往僧中偏露右肩脱革屣右膝着地合掌白言。大德僧听。我某甲比丘。僧与作不忏悔罪举羯磨。随顺众僧不敢违逆。今从僧乞解不忏悔罪举羯磨。愿僧慈愍故。为我解不忏悔罪举羯磨如是第二第三说。众中应差堪能羯磨者如上作如是白。大德僧听。此某甲比丘。僧为作不忏悔罪举羯磨。彼随顺众僧不敢违逆。从僧乞解不忏悔罪举羯磨。若僧时到僧忍听。今僧为某甲比丘解不忏悔罪举羯磨白如是。大德僧听。某甲比丘僧与作不忏悔罪举羯磨。顺从众僧不敢违逆。从僧乞解不忏悔罪举羯磨。谁诸长老忍僧为某甲比丘解不忏悔罪举羯磨者默然。谁不忍者说。是初羯磨。第二第三亦如是说。僧已忍。与某甲比丘解不忏悔罪举羯磨竟。僧忍默然故是事如是持。尔时世尊在舍卫国。时有比丘字阿利吒。有如是恶见生。我知佛所说法义犯淫欲非障道法。时诸比丘闻阿利吒比丘恶见生即往阿利吒比丘所。恭敬问讯已在一面坐。语阿利吒言。汝实知佛所说法行淫欲非障道法耶。答言。我实知佛所说法。行淫欲非障道法。时诸比丘欲除阿利吒比丘恶见。即殷勤问之。阿利吒。莫作如是语。莫谤世尊。谤世尊者不善。世尊不作如是语。阿利吒。世尊无数方便说断欲法断于欲想灭欲念除散欲热越度爱结。世尊无数方便说欲如大火坑。如把草炬。亦如熟果。亦如假借。犹如枯骨。欲如段肉。如梦所见。如履锋刃。欲如新瓦器盛水置日中。欲如毒蛇头。如轮转刀。如似利戟。世尊作如是说。阿利吒。如来如是善说法。断欲无欲。去垢无垢。调伏渴爱。灭除巢窟。出离一切诸结缚。爱尽涅槃。佛如是说法。汝云何言。行欲非障道法。时诸比丘殷勤问阿利吒比丘如是说时。阿利吒比丘坚持恶见审定而言。此是真实余皆虚妄。时诸比丘。不能除阿利吒恶见。往世尊所头面礼足却坐一面。以此因缘具白世尊。世尊尔时。告异比丘言。汝持我言往唤阿利吒比丘来。时彼比丘。受世尊教。往阿利吒比丘所语如是言。世尊唤汝。阿利吒。闻世尊唤。即往世尊所。头面礼足却坐一面。世尊告阿利吒言。汝实有是语。我知世尊说法行淫欲非障道法耶。答言。大德。实有如是语。问言。汝云何知我所说如是。我不无数方便说断欲爱法如上所说耶

尔时世尊。无数方便呵责阿利吒比丘已告诸比丘。听僧为阿利吒比丘作诃谏。舍此事故作白四羯磨。应如是谏。众中当差堪能羯磨者如上作如是白。大德僧听。此阿利吒比丘作如是语。行淫欲非障道法。若僧时到僧忍听。僧今与阿利吒比丘作诃谏。舍此事故。阿利吒。莫作是语。莫谤世尊。谤世尊者不善。世尊不作如是语。世尊无数方便说行淫欲是障道法。若犯欲即为障道。白如是。大德僧听。此阿利吒比丘作如是言。我知佛所说法行欲非障道法。僧今与作诃谏。舍此事故。阿利吒。莫作如是语。莫谤世尊。谤世尊者不善。世尊不作是语。世尊无数方便说欲是障道法。若犯欲者即障道法。谁诸长老忍。僧为阿利吒比丘作诃谏。舍此事者默然。谁不忍者说。是初羯磨。第二第三亦如是说。僧为阿利吒比丘作诃谏竟。僧忍默然故。是事如是持。彼阿利吒比丘。僧与作诃谏已。故不舍恶见。时诸比丘闻。中有少欲知足行头陀乐学戒知惭愧者。呵责阿利吒比丘言。云何僧与作诃谏已。故不舍恶见。时诸比丘往世尊所。头面礼足却坐一面。以此因缘具白世尊。世尊尔时。以此因缘集比丘僧。呵责阿利吒比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何僧与作诃谏已。故不舍恶见。以无数方便呵责已告诸比丘。听诸比丘与阿利吒比丘作不舍恶见白四羯磨。应如是作集僧集僧已与作举。作举已与作忆念。作忆念已应与罪。众中当差堪能羯磨者如上作如是白。大德僧听。阿利吒比丘恶见。僧与作诃谏。故不舍恶见。若僧时到僧忍听。僧今与阿利吒比丘作恶见不舍羯磨白如是。大德僧听。阿利吒比丘恶见不舍。僧与作诃谏故不舍恶见。僧今为阿利吒比丘作不舍恶见举羯磨。谁诸长老忍。僧今与阿利吒比丘作恶见不舍羯磨者默然。谁不忍者说。是初羯磨。第二第三亦如是说。僧已忍。与阿利吒比丘作不舍恶见羯磨竟。僧忍默然故。是事如是持。作恶见不舍已。有五事不应作。从不得授人大戒。乃至不得与善比丘共斗。应如是作。僧为阿利吒比丘作恶见不舍白四羯磨竟。诸比丘白佛。佛言。有三法有五法。作恶见不舍举羯磨非法非毗尼羯磨不成就如上。复有三法五法。作恶见不舍举羯磨如法如毗尼羯磨成就如上。彼被恶见不舍举比丘。若僧在小食大食上。说法时若布萨时。应往彼在一面住偏露右肩脱革屣右膝着地合掌白如是言。大德。我忏悔自责心意。从今已去不复作。彼阿利吒随顺众僧不敢违逆。从僧乞解不舍恶见举羯磨。诸比丘白佛。佛言。若阿利吒比丘随顺众僧不敢违逆。从僧乞解不舍恶见举羯磨者。僧应与白四羯磨解。复有五法不应与解恶见不舍羯磨。从授人大戒乃至与善比丘共斗。复有五法应与解不舍恶见举羯磨。从不授人大戒乃至不与善比丘共斗。应如是解。彼被恶见不舍举羯磨比丘。应往僧中偏露右肩脱革屣右膝着地合掌白如是言。大德僧听。我某甲比丘。僧与作恶见不舍举羯磨。今随顺众僧不敢违逆。从僧乞解恶见不舍举羯磨。愿僧为我解不舍恶见举羯磨慈愍故。如是第二第三说。众中应差堪能作羯磨者如上作如是白。大德僧听。此某甲比丘。僧与作恶见不舍举羯磨。今随顺众僧不敢违逆。从僧乞解不舍恶见举羯磨。若僧时到僧忍听。僧今为某甲比丘解恶见不舍举羯磨白如是。大德僧听。此某甲比丘。僧与作恶见不舍举羯磨随顺众僧不敢违逆。从僧乞解恶见不舍举羯磨。僧今为某甲比丘解不舍恶见举羯磨。谁诸长老忍僧为某甲比丘解不舍恶见举羯磨者默然谁不忍者说。是初羯磨如是第二第三说。僧已忍。为某甲比丘解不舍恶见举羯磨竟。僧忍默然故。是事如是持(呵责揵度具足竟)

    人揵度第十二之一

尔时世尊在舍卫国。时有比丘犯僧残罪覆藏作如是念。我当云何。白诸比丘。诸比丘白佛。佛言。听僧为彼比丘随覆藏日与治覆藏罪作白四羯磨。应如是与。彼比丘应来至僧中偏露右肩。脱革屣礼僧足合掌胡跪白如是言。大德僧听。我某甲比丘犯僧残罪覆藏。我某甲比丘犯僧残罪随覆藏日。今从僧乞覆藏羯磨愿僧与我随覆藏日羯磨慈愍故。如是第二第三说众中应差堪能作羯磨者如上作如是白。大德僧听。某甲比丘犯僧残罪覆藏。彼某甲比丘犯僧残罪随覆藏日从僧乞覆藏羯磨。若僧时到僧忍听。僧与某甲比丘随覆藏日羯磨白如是。大德僧听。某甲比丘犯僧残罪覆藏。彼某甲比丘犯僧残罪随覆藏日从僧乞覆藏羯磨。僧今与某甲比丘随覆藏日羯磨。谁诸长老忍僧与某甲比丘随覆藏日羯磨者默然。谁不忍者说。是初羯磨。第二第三亦如是说。僧已忍。与某甲比丘随覆藏日羯磨竟。僧忍默然故。是事如是持。彼行覆藏时更重犯。彼作如是念。我当云何。白诸比丘。诸比丘白佛。佛言。听僧为彼比丘作本日治白四羯磨。应如是治。彼比丘应来至僧中偏露右肩脱革屣礼僧足右膝着地合掌白如是言。大德僧听。我某甲比丘犯僧残罪覆藏。我某甲比丘犯僧残罪随覆藏日。已从僧乞覆藏羯磨。僧已与我随覆藏日羯磨。我某甲行覆藏时更重犯。我某甲今从僧乞覆藏本日治羯磨。愿僧与我某甲比丘覆藏本日治羯磨。慈愍故。如是第二第三说。众中应差堪能作羯磨者如上作如是白。大德僧听。某甲比丘犯僧残罪覆藏。此某甲比丘犯僧残罪随覆藏日。已从僧乞覆藏羯磨。僧已与某甲比丘随覆藏日羯磨。彼行覆藏时更重犯罪。今从僧乞覆藏本日治羯磨。若僧时到僧忍听。僧与某甲比丘覆藏本日治羯磨白如是。大德僧听。某甲比丘犯僧残罪覆藏。此某甲比丘犯僧残罪随覆藏日。已从僧乞覆藏日羯磨。僧已与某甲比丘随覆藏日羯磨。彼行覆藏时更重犯罪。彼从僧乞覆藏本日治羯磨。僧今与某甲比丘覆藏本日治羯磨。谁诸长老忍。僧与某甲比丘覆藏本日治羯磨者默然谁不忍者说是初羯磨。如是第二第三说。僧已忍。与某甲比丘覆藏本日治羯磨竟。僧忍默然故。是事如是持。彼比丘行覆藏竟白诸比丘。诸比丘白佛。佛言。听僧为彼比丘作六夜摩那埵白四羯磨。应如是与。彼比丘应至僧中偏露右肩脱革屣礼僧足右膝着地合掌白如是言。大德僧听我某甲比丘犯僧残罪覆藏。我某甲比丘犯僧残罪随覆藏日。已从僧乞随覆藏日羯磨。僧已与我随覆藏日羯磨。我行覆藏时更重犯罪。从僧乞覆藏本日治羯磨。僧已与我覆藏本日治羯磨。我某甲比丘行覆藏本日治竟今从僧乞六夜摩那埵。愿僧与我六夜摩那埵。慈愍故。如是第二第三说。众中应差堪能羯磨者。如上作如是白。大德僧听。此某甲比丘。犯僧残罪覆藏。某甲比丘犯僧残罪随覆藏日。已从僧乞覆藏羯磨。僧已与某甲比丘随覆藏日羯磨。彼行覆藏时更重犯罪。此某甲比丘从僧乞覆藏本日治羯磨。僧已与某甲比丘覆藏本日治羯磨。此某甲比丘行覆藏本日治竟。今从僧乞六夜摩那埵羯磨。若僧时到僧忍听。僧与某甲比丘六夜摩那埵羯磨白如是。大德僧听。此某甲比丘犯僧残罪覆藏。此某甲比丘犯僧残罪随覆藏日。已从僧乞覆藏羯磨。僧已与某甲比丘随覆藏日羯磨。此某甲比丘行覆藏时更重犯罪。从僧乞覆藏本日治羯磨。僧已与此某甲比丘覆藏本日治羯磨。此某甲比丘行覆藏本日治竟。今从僧乞六夜摩那埵羯磨。僧今与某甲比丘六夜摩那埵羯磨。谁诸长老忍。僧与某甲比丘六夜摩那埵羯磨者默然。谁不忍者说。是初羯磨。第二第三亦如是说。僧已忍与某甲比丘六夜摩那埵羯磨竟。僧忍默然故。是事如是持。彼行摩那埵竟白诸比丘。诸比丘白佛。佛言。听僧与彼比丘作白四羯磨出罪。应如是出罪。彼比丘应至僧中偏露右肩脱革屣礼僧足已右膝着地合掌白如是言。大德僧听。我某甲比丘犯僧残罪覆藏。我某甲比丘犯僧残罪随覆藏日。已从僧乞覆藏日羯磨。僧已与我随覆藏日羯磨。我某甲比丘行覆藏时更重犯罪。从僧乞覆藏本日治羯磨。僧已与我覆藏本日治羯磨。我某甲比丘行覆藏本日治竟。从僧乞六夜摩那埵羯磨。僧已与我六夜摩那埵羯磨。我比丘某甲行六夜摩那埵竟。今从僧乞出罪羯磨。愿僧与我出罪羯磨。慈愍故。如是第二第三说。众中应差堪能作羯磨者。如上作如是白。大德僧听。此某甲比丘犯僧残罪覆藏。此某甲比丘犯僧残罪随覆藏日。已从僧乞覆藏羯磨。僧已与某甲比丘随覆藏日羯磨。此某甲比丘行覆藏时更重犯罪。从僧乞覆藏本日治羯磨。僧已与某甲比丘覆藏本日治羯磨。此比丘行覆藏本日治竟。从僧乞六夜摩那埵羯磨。僧已与某甲比丘六夜摩那埵羯磨。此比丘行六夜摩那埵竟。从僧乞出罪羯磨。若僧时到僧忍听。僧今为某甲比丘出罪白如是。大德僧听。此某甲比丘犯僧残罪覆藏。某甲比丘犯僧残罪随覆藏日。已从僧乞覆藏羯磨。僧已与某甲比丘随覆藏日羯磨。此比丘行覆藏时更重犯罪。从僧乞覆藏本日治羯磨。僧已与某甲比丘覆藏本日治羯磨。此某甲比丘行覆藏本日治竟。从僧乞六夜摩那埵羯磨。僧已与比丘某甲六夜摩那埵羯磨。此某甲比丘行六夜摩那埵竟。从僧乞出罪羯磨。僧今为比丘某甲出罪。谁诸长老忍。僧与此某甲比丘出罪者默然。谁不忍者说。此是初羯磨。第二第三亦如是说。僧已忍。为某甲比丘出罪竟。僧忍默然故。是事如是持

尔时有比丘。犯僧残罪不覆藏。作如是念。我当云何。白诸比丘。诸比丘白佛。佛言。听僧与彼比丘六夜摩那埵白四羯磨。应如是与。彼比丘应至僧中偏露右肩脱革屣礼僧足已。右膝着地合掌白如是言。大德僧听。我某甲比丘犯僧残罪不覆藏。今从僧乞六夜摩那埵。愿僧与我六夜摩那埵。慈愍故。如是第二第三说。僧中应差堪能羯磨者。如上作如是白。大德僧听。此某甲比丘犯僧残罪不覆藏。今从僧乞六夜摩那埵。若僧时到僧忍听。僧与某甲比丘六夜摩那埵。白如是。大德僧听。此某甲比丘犯僧残罪不覆藏。今从僧乞六夜摩那埵。僧今与某甲比丘六夜摩那埵。谁诸长老忍。僧与某甲比丘六夜摩那埵者默然。谁不忍者说。是初羯磨。如是第二第三说。僧已忍。与某甲比丘六夜摩那埵竟。僧忍默然故。是事如是持。彼行摩那埵中间更犯。彼比丘作如是言。我当云何。白诸比丘。诸比丘白佛。佛言。听僧与彼比丘作摩那埵本日治白四羯磨。应如是与。彼比丘应来至僧中偏露右肩脱革屣礼僧足已右膝着地合掌白如是言。大德僧听。我某甲比丘犯僧残罪不覆藏。我某甲比丘犯僧残罪不覆藏。从僧乞六夜摩那埵。僧已与我六夜摩那埵。我行摩那埵时更重犯罪。今从僧乞摩那埵本日治羯磨。愿僧与我摩那埵本日治羯磨。慈愍故。如是第二第三说。众中应差堪能羯磨者如上作如是白。大德僧听。此某甲比丘犯僧残罪不覆藏。从僧乞六夜摩那埵。僧已与六夜摩那埵。彼比丘行六夜摩那埵时更重犯罪。从僧乞摩那埵本日治羯磨。若僧时到僧忍听。僧与某甲比丘摩那埵本日治羯磨。白如是。大德僧听。此某甲比丘犯僧残罪不覆藏。从僧乞六夜摩那埵。僧已与六夜摩那埵。此比丘行六夜摩那埵时更重犯罪。从僧乞摩那埵本日治羯磨。僧今与某甲比丘摩那埵本日治羯磨。谁诸长老忍。僧与某甲比丘摩那埵本日治羯磨者默然。谁不忍者说。是初羯磨。第二第三亦如是说。僧已忍。与某甲比丘摩那埵本日治羯磨竟。僧忍默然故。是事如是持。彼行摩那埵竟白诸比丘。诸比丘白佛。佛言。听僧为彼比丘出罪作白四羯磨。应如是作。彼比丘应来至僧中偏露右肩脱革屣礼僧足已右膝着地合掌白言。大德僧听。我某甲比丘犯僧残罪不覆藏。从僧乞六夜摩那埵。僧已与我六夜摩那埵。我行六夜摩那埵时更重犯罪。从僧乞六夜摩那埵本日治羯磨。僧已与我摩那埵本日治羯磨。我某甲比丘行摩那埵本日治竟。今从僧乞出罪羯磨。愿僧与我出罪羯磨慈愍故。如是第二第三说。僧中应差堪能作羯磨者如上作如是白。大德僧听。此某甲比丘犯僧残罪不覆藏。从僧乞六夜摩那埵。僧已与六夜摩那埵。彼比丘行六夜摩那埵时更重犯罪。从僧乞摩那埵本日治羯磨。僧已与彼比丘摩那埵本日治羯磨。彼行摩那埵本日治竟。今从僧乞出罪羯磨。若僧时到僧忍听。僧为某甲比丘出罪白如是。大德僧听。此某甲比丘犯僧残罪不覆藏。从僧乞六夜摩那埵。僧已与六夜摩那埵。彼行摩那埵时更重犯罪。从僧乞摩那埵本日治羯磨。僧已与摩那埵本日治羯磨。此比丘。行摩那埵本日治竟。今从僧乞出罪羯磨。僧今与某甲比丘出罪羯磨。谁诸长老忍。僧与某甲比丘出罪羯磨者默然。谁不忍者说。第二第三亦如是说。僧已忍。与某甲比丘出罪羯磨竟。僧忍默然故。是事如是持。时有一比丘。犯众多僧残罪。或有犯覆藏一夜。或有犯覆藏二夜。如是乃至十夜。彼比丘作如是念。我当云何。白诸比丘。诸比丘白佛。佛言。听僧与彼比丘共作犯众多僧残罪覆藏十夜白四羯磨。应如是与。彼比丘应来至僧中偏露右肩脱革屣礼僧足已右膝着地合掌白言。大德僧听。我某甲比丘犯众多僧残罪。或覆藏一夜或覆藏二夜乃至十夜者。今从僧乞覆藏一夜乃至十夜羯磨。愿僧与我覆藏一夜乃至十夜羯磨。慈愍故。如是第二第三说。众中应差堪能作羯磨者如上作如是白。大德僧听。此某甲比丘犯众多僧残罪。或有覆藏一夜乃至十夜。今从僧乞覆藏一夜乃至十夜羯磨。若僧时到僧忍听。僧与某甲比丘覆藏一夜乃至十夜羯磨。白如是。大德僧听。此某甲比丘犯众多僧残罪。或有覆藏一夜乃至十夜。今从僧乞覆藏一夜乃至十夜羯磨。今僧与某甲比丘覆藏一夜乃至十夜羯磨。谁诸长老忍。僧与彼比丘覆藏一夜乃至十夜羯磨者默然。谁不忍者说是初羯磨如是。第二第三说。僧已忍。与某甲比丘覆藏一夜乃至十夜羯磨竟。僧忍默然故。是事如是持。彼比丘行覆藏竟白诸比丘。诸比丘白佛。佛言。听僧与彼比丘六夜摩那埵白四羯磨。彼比丘应来至僧中。偏露右肩脱革屣礼僧足已右膝着地合掌白如是言。大德僧听。我某甲比丘犯众多僧残罪。覆藏一夜或二夜乃至十夜。从僧乞覆藏一夜乃至十夜羯磨。僧已与我覆藏羯磨。我某甲比丘已行覆藏竟。今从僧乞六夜摩那埵。愿僧与我六夜摩那埵。慈愍故。如是第二第三说。众中应差堪能羯磨者。如上作如是白大德僧听。此某甲比丘犯众多僧残罪覆藏或一夜或二夜乃至十夜。从僧乞覆藏十夜羯磨。僧已与此某甲比丘覆藏十夜羯磨。此比丘行覆藏竟今从僧乞六夜摩那埵。若僧时到僧忍听。僧今与某甲比丘六夜摩那埵。白如是。大德僧听。此某甲比丘犯众多僧残罪覆藏或一夜或二夜乃至十夜。已从僧乞覆藏十夜羯磨。僧已与覆藏十夜羯磨。彼比丘行十夜覆藏竟。今从僧乞六夜摩那埵。僧今与彼比丘六夜摩那埵。谁诸长老忍僧与彼比丘六夜摩那埵者默然。谁不忍者说是初羯磨。第二第三亦如是说。僧已忍。与彼比丘六夜摩那埵竟僧忍默然故。是事如是持彼行摩那埵竟白诸比丘。诸比丘白佛。佛言。听僧与彼比丘出罪白四羯磨。彼比丘应来至僧中偏露右肩脱革屣礼僧足已右膝着地白如是言。大德僧听。我某甲比丘犯众多僧残罪。覆藏或一夜或二夜乃至十夜。从僧乞覆藏十夜羯磨僧已与我覆藏十夜羯磨。我行覆藏竟。从僧乞六夜摩那埵。僧已与我六夜摩那埵。我行六夜摩那埵竟。今从僧乞出罪羯磨。愿僧与我出罪羯磨。慈愍故。如是第二第三说。众中应差堪能羯磨者如上作如是白。大德僧听。此某甲比丘犯众多僧残罪。覆藏或一夜或二夜乃至十夜。从僧乞覆藏十夜羯磨。僧已与十夜羯磨。彼某甲比丘行十夜覆藏竟。从僧乞六夜摩那埵。僧已与彼比丘六夜摩那埵。彼比丘行六夜摩那埵竟。今从僧乞出罪羯磨。若僧时到僧忍听。僧今与某甲比丘出罪羯磨。白如是。大德僧听。此某甲比丘犯众多僧残罪。覆藏或一夜或二夜乃至十夜。从僧乞覆藏十夜羯磨。僧已与十夜羯磨。彼某甲比丘行十夜覆藏竟。从僧乞六夜摩那埵。僧已与彼比丘六夜摩那埵。彼某甲比丘行六夜摩那埵竟。今从僧乞出罪羯磨。僧今与彼某甲比丘出罪羯磨。谁诸长老忍。僧与彼某甲比丘出罪羯磨者默然。谁不忍者说。如是第二第三说。僧已忍。与彼某甲比丘出罪羯磨竟。僧忍默然故。是事如是持。时有一比丘。犯二僧残罪二俱覆藏。忆一罪不忆一罪。彼比丘随所忆罪随覆藏日。从僧乞覆藏日羯磨。僧与彼比丘随所忆罪随覆藏日羯磨。彼比丘行覆藏时忆第二罪。不知云何。白诸比丘。诸比丘白佛。佛言。听僧与彼比丘随忆第二罪覆藏日与覆藏羯磨。时有比丘。犯二僧残罪二俱覆藏。一有疑二无疑。彼于无疑罪中随覆藏日。从僧乞覆藏日羯磨。僧与彼比丘随覆藏日羯磨。彼比丘行覆藏时于第二罪中即得无疑。自念我当云何。白诸比丘。诸比丘白佛。佛言。听僧随覆藏日与覆藏羯磨。时有比丘犯二僧残罪二俱覆藏。识一罪不识一罪。彼所识罪从僧乞覆藏羯磨。僧与随覆藏日羯磨。彼行覆藏时即还识第二罪。自念我当云何。即白诸比丘。诸比丘白佛。佛言听僧为彼比丘随所还识第二罪覆藏日与覆藏羯磨。时有比丘。犯二僧残罪二俱覆藏。彼乞覆藏时说一罪覆藏一罪。彼随所说罪从僧乞覆藏羯磨。僧与覆藏羯磨。彼行覆藏时于第二犯惭愧心生。自念我当云何。白诸比丘。诸比丘白佛。佛言。僧应随所犯第二罪覆藏日与覆藏羯磨。佛言。汝曹善听。若比丘犯二僧残罪二俱覆藏。忆一罪不忆一罪。彼比丘所忆罪不忆罪俱。从僧乞覆藏羯磨。僧与彼犯二罪覆藏羯磨。彼行覆藏时有客比丘来。知法知律知摩夷。彼客比丘问旧比丘。长老。此比丘何所犯。何故行覆藏。旧比丘答言。长老。此比丘犯二僧残罪二俱覆藏。忆一罪不忆一罪。二俱从僧乞覆藏羯磨。僧与彼俱覆藏羯磨。是故彼比丘行覆藏。彼客比丘言。长老。不成与彼覆藏羯磨。何以故。彼比丘所忆罪。与覆藏羯磨善。彼不忆罪。与覆藏羯磨不善。非法羯磨不成就。众僧应作突吉罗忏。彼应与摩那埵。疑不疑识不识亦如是。时有比丘。犯僧残罪覆藏两月。彼忆一月不忆一月。彼随所忆一月。从僧乞覆藏羯磨。僧与一月覆藏羯磨。彼行覆藏时忆第二月。自念我当云何。白诸比丘。诸比丘白佛。佛言。听僧与彼比丘随忆第二月覆藏羯磨。疑不疑亦如是。识不识亦如是。乞覆藏时覆藏一月发露一月亦如是。佛告诸比丘善听。若比丘犯僧残罪覆藏两月。忆一月不忆一月。二俱从僧乞覆藏羯磨。僧与彼两月覆藏羯磨。彼行覆藏时有客比丘来。知法知律知摩夷。彼客比丘问旧比丘言。长老。彼何所犯。何故行覆藏。答言。此比丘犯僧残罪。覆藏两月。忆一月不忆一月。彼忆不忆二俱。从僧乞两月覆藏。僧随彼与两月覆藏羯磨。是故彼比丘行覆藏。彼客比丘语旧比丘言。不善与覆藏。何以故。彼比丘忆一月与覆藏者善。不忆一月与覆藏者不善。非法羯磨不成就。僧应作突吉罗忏。彼比丘应与摩那埵。疑不疑亦如是。识不识亦如是。时有比丘。犯二僧残罪二俱覆藏。彼罢道。罢道已。复还受大戒。受大戒已覆藏二罪。自念我当云何。白诸比丘。诸比丘白佛。佛言。若比丘犯二僧残覆藏二罪。彼罢道。罢道已还受大戒。受大戒已覆藏二罪。僧应随先所犯覆藏日及后覆藏日与覆藏羯磨。与覆藏羯磨已。与摩那埵。时有比丘。犯二僧残罪二俱覆藏。彼罢道。罢道已还受大戒。受大戒已发露二罪。僧应随彼比丘先所覆藏日与覆藏羯磨。与覆藏羯磨已与摩那埵。时有比丘。犯二僧残罪二俱不覆藏。彼罢道。罢道已还受大戒。受大戒已覆藏二罪。彼自念言。我当云何。白诸比丘。诸比丘白佛。佛言。若比丘犯二僧残罪。二俱不覆藏。彼罢道。罢道已还受大戒。受大戒已覆藏二罪。僧应随彼比丘后覆藏日与覆藏羯磨。然后与摩那埵。时有比丘。犯二僧残罪。二俱不覆藏。彼罢道。罢道已还受大戒。受大戒已发露二罪。僧即应与二罪摩那埵。时有比丘。犯二僧残罪。覆藏一罪不覆藏一罪。彼罢道。罢道已复还受大戒。受大戒已。先发露一罪。后二俱覆藏。彼作是念。我当云何。白诸比丘。诸比丘白佛。佛言。若比丘犯二僧残罪。覆藏一罪不覆藏一罪。彼罢道。罢道已还受大戒。受大戒已。先发露一罪。后二俱覆藏。听僧与彼比丘随所犯一罪前后覆藏一罪后覆藏日羯磨。时有比丘。犯二僧残罪。覆藏一罪。发露一罪。彼罢道。罢道已还受大戒。受大戒已。先所覆藏。后复覆藏。先发露者后亦发露。僧应随前后所覆藏一罪与覆藏羯磨。所不覆藏第二罪应与摩那埵。时有比丘。犯二僧残罪。覆藏一罪。发露一罪。彼罢道。罢道已还受大戒。受大戒已。先所覆藏后发露。先所发露后便覆藏。僧应与彼随前所覆藏一罪与覆藏羯磨。随后所覆藏第二罪与覆藏羯磨。时有比丘。犯二僧残罪。覆藏一罪发露一罪。彼罢道。罢道已还受大戒。受大戒已。先所覆藏。后二俱发露。僧应与彼比丘随前所犯一罪覆藏日与覆藏羯磨。第二罪二俱与摩那埵。忆一罪不忆一罪。作四句亦如是。疑一罪不疑一罪作四句亦如是。识一罪不识一罪作四句亦如是。乞覆藏时覆藏一罪发露一罪作四句亦如是(此中从覆藏一罪不覆藏一罪至此凡有五句一句各有四句如覆一不覆一作四句凡有二十句)行覆藏时二十句亦如是。行覆藏竟二十句亦如是。行摩那埵时二十句亦如是。行摩那埵竟二十句亦如是。作沙弥还受大戒百句亦如是。癫狂百句亦如是。心乱百句亦如是。痛恼百句亦如是。僧与作不见罪举百句亦如是。不忏悔罪百句亦如是。恶见不舍罪百句亦如是。尔时行覆藏比丘罢道。罢道已还受大戒。受大戒已自念。我当云何。白诸比丘。诸比丘白佛。佛言。行覆藏比丘罢道。罢道已还受大戒。受大戒已。应续行前日次行覆藏。时有比丘应与作本日治。彼比丘罢道。罢道已还受大戒。受大戒已。僧应为彼比丘作本日治白四羯磨。时有比丘。行覆藏竟罢道。罢道已还受大戒。受大戒已。僧应与彼比丘六夜摩那埵白四羯磨。时有比丘。行摩那埵罢道。罢道已还受大戒。受大戒已。彼比丘已行摩那埵日便止。未行日应还续行。时有比丘。行摩那埵竟罢道。罢道已还受大戒。受大戒已。僧应与彼出罪白四羯磨。还作沙弥五句亦如是。癫狂五句亦如是。心乱五句亦如是。痛恼五句亦如是。僧与作不见罪举不忏悔恶见不舍举羯磨各五句亦如是。时有行覆藏比丘。中间犯罪知日数而覆藏。彼自念。我当云何。白诸比丘。诸比丘白佛。佛言。若行覆藏比丘中间犯罪知日数覆藏。僧应随中间犯罪与覆藏羯磨。与覆藏羯磨竟与本日治。行覆藏本日治竟与摩那埵。与摩那埵竟应为出罪。不知日数。覆藏亦如是。知数不知数覆藏亦如是。行覆藏竟亦如是。尔时有行摩那埵比丘。中间犯罪知日数不覆藏。彼作是念。我当云何。白诸比丘。诸比丘白佛。佛言。若行摩那埵比丘。中间重犯知日数不覆藏。僧应与摩那埵。与摩那埵已应与摩那埵本日治。行摩那埵本日治已应与出罪羯磨。不知日数不覆藏亦如是。知日数不知日数不覆藏亦如是。行摩那埵竟知日数不覆藏亦如是。不知日数不覆藏亦如是。知日数不知日数不覆藏亦如是。尔时有比丘。犯僧残罪。知日数。不知日数。覆藏不覆藏。等覆不等覆。一名多种。自性非自性。住别异。彼作如是念。我当云何。白诸比丘。诸比丘白佛。佛言。听僧与彼比丘随所覆藏日与覆藏羯磨。应如是与。彼比丘应至僧中偏露右肩脱革屣礼僧足已右膝着地合掌白言。大德僧听。我某甲比丘犯僧残罪。知日数不知日数覆藏不覆藏等覆不等覆乃至住别异。随覆藏日。从僧乞覆藏羯磨。愿僧与我随覆藏日羯磨。慈愍故。如是第二第三说。众中应差堪能作羯磨者如上作如是白。大德僧听。此某甲比丘犯僧残罪。知日数不知日数覆藏不覆藏等覆不等覆乃至住别异。彼随覆藏日。从僧乞覆藏羯磨。若僧时到僧忍听。僧与彼比丘随覆藏日羯磨。白如是。大德僧听。彼某甲比丘犯僧残罪。知日数不知日数乃至住别异。彼随覆藏日。从僧乞随覆藏日羯磨。僧今与某甲比丘随覆藏日羯磨。谁诸长老忍。僧与彼某甲比丘作覆藏日羯磨者默然。谁不忍者说。如是第二第三说。僧已忍。与某甲比丘。随覆藏日羯磨竟。僧忍默然故。是事如是持。彼行覆藏时中间重更犯罪。知日数覆藏。彼作如是念。我当云何。白诸比丘。诸比丘白佛。佛言。听僧与彼比丘前罪中间覆藏与本日治白四羯磨。应如是与。彼比丘应来至僧中偏露右肩礼僧足已右膝着地合掌作如是白。大德僧听。我某甲比丘犯僧残罪。知日数不知日数乃至住别异。我随所覆藏日。从僧乞覆藏羯磨。僧已与我覆藏羯磨。我某甲比丘行覆藏时重更犯罪。知日数覆藏。从僧乞前犯中间重犯覆藏本日治羯磨。愿僧与我前犯中间重犯覆藏本日治羯磨。慈愍故。如是第二第三说。众中应差堪能作羯磨者如上作如是白。大德僧听。此某甲比丘犯僧残罪。知日数不知日数乃至住别异。此比丘从僧乞随覆藏日羯磨。此比丘行覆藏时中间重更犯罪。知日数覆藏。今从僧乞前犯中间重犯覆藏本日治羯磨。若僧时到僧忍听。僧与此比丘前犯中间重犯覆藏本日治羯磨。白如是。大德僧听。此某甲比丘犯僧残罪。知日数不知日数乃至住别异。此比丘随覆藏日。从僧乞覆藏羯磨。僧已与此比丘随覆藏日羯磨此比丘行覆藏时中间更重犯罪知日数覆藏。今从僧乞前犯中间重犯覆藏本日治羯磨。僧今与此比丘前犯中间重犯覆藏本日治羯磨。谁诸长老忍。僧与某甲比丘前犯中间重犯覆藏本日治羯磨者默然。谁不忍者说。如是第二第三说。僧已忍。与某甲比丘前犯中间重犯覆藏本日治羯磨竟。僧忍默然。故是事如是持。彼比丘行覆藏时中间第二重犯亦如是。彼比丘行覆藏竟白佛。佛言。听僧与此比丘六夜摩那埵白四羯磨。应如是与。彼比丘应来至僧中偏露右肩脱革屣礼僧足已。右膝着地合掌白言。大德僧听。我某甲比丘犯僧残罪。知日数不知日数乃至住别异。随覆藏日。从僧乞随覆藏日羯磨。僧已与我随覆藏日羯磨。我行覆藏时中间重犯。知日数覆藏。从僧乞前犯中间重犯覆藏本日治羯磨。僧已与我前犯中间重犯覆藏本日治羯磨。我行覆藏时中间更第二犯。从僧乞前犯中间重犯第二犯覆藏本日治羯磨。僧已与我前犯中间重犯第二犯覆藏本日治羯磨。我某甲比丘行覆藏竟。今从僧乞六夜摩那埵。愿僧与我六夜摩那埵。慈愍故。如是第二第三说。众中应差堪能作羯磨者如上作如是白。大德僧听。此某甲比丘犯僧残罪。知日数不知日数乃至住别异。此某甲比丘随覆藏日。从僧乞覆藏羯磨。僧已与此比丘覆藏羯磨。此比丘行覆藏时中间重犯。知日数覆藏从僧乞前犯中间重犯覆藏本日治羯磨。僧已与此比丘前犯中间重犯覆藏本日治羯磨。此比丘行覆藏时中间更第二重犯。从僧乞前犯中间重犯第二犯覆藏本日治羯磨。僧已与此比丘前犯中间重犯第二犯覆藏本日治羯磨。彼比丘行覆藏竟。今从僧乞六夜摩那埵。若僧时到僧忍听。僧与某甲比丘六夜摩那埵。白如是大德僧听。此某甲比丘犯僧残罪。知日数不知日数乃至住别异。随覆藏日。从僧乞覆藏羯磨。僧已与此比丘随覆藏日羯磨。此比丘行覆藏时中间重犯。知日数覆藏。从僧乞前犯中间重犯覆藏本日治羯磨。僧与彼比丘前犯中间重犯覆藏本日治羯磨。彼比丘行覆藏时中间重犯第二犯知日数覆藏。从僧乞前犯中间重犯第二犯覆藏本日治羯磨。僧与彼比丘前犯中间重犯第二犯覆藏本日治羯磨。彼比丘行覆藏竟。今从僧乞六夜摩那埵。僧今与彼比丘六夜摩那埵。谁诸长老忍。僧与某甲比丘六夜摩那埵者默然。谁不忍者说。如是第二第三说。僧已忍。与某甲比丘六夜摩那埵竟。僧忍默然。故是事如是持。时彼比丘行摩那埵竟。白诸比丘。诸比丘白佛。佛言。僧应与彼比丘出罪白四羯磨。如上应如是出罪。若众僧为彼比丘出罪不如法。佛告诸比丘善听。若比丘犯僧残罪。知日数不知日数乃至住别异。彼比丘从僧乞随覆藏日羯磨。僧与随覆藏日羯磨。彼行覆藏时中间重犯。知日数覆藏。彼从僧乞前犯中间重犯覆藏本日治羯磨。僧与彼比丘前犯中间重犯覆藏本日治羯磨。彼比丘行覆藏时中间第二犯。知日数覆藏。从僧乞前犯中间重犯第二犯覆藏本日治羯磨。僧已与彼比丘前犯中间重犯第二犯覆藏本日治羯磨非法。彼比丘谓便行覆藏竟。从僧乞六夜摩那埵。僧与彼比丘六夜摩那埵。非法。彼比丘谓便行摩那埵竟。从僧乞出罪羯磨。僧与彼比丘出罪。非法。我说此比丘非清净罪不出。是中有比丘犯僧残罪。知日数不知日数乃至住别异。彼比丘随覆藏日。从僧乞覆藏羯磨。僧已与彼比丘随覆藏日羯磨。彼比丘行覆藏时中间重犯。知日数覆藏。从僧乞前犯中间重犯覆藏本日治羯磨。僧已与彼比丘前犯中间重犯覆藏本日治羯磨。彼比丘行覆藏时中间第二犯。知日数覆藏。从僧乞前犯中间重犯第二犯覆藏本日治羯磨。僧已与彼比丘前犯中间重犯第二犯覆藏本日治羯磨。如法。彼比丘行覆藏竟。从僧乞六夜摩那埵。僧与彼比丘六夜摩那埵羯磨。不如法彼比丘谓行摩那埵竟。从僧乞出罪羯磨。僧与彼比丘出罪。非法。我说彼比丘不清净罪不出。时有比丘犯僧残罪。知日数不知日数乃至住别异。彼比丘随所犯。从僧乞覆藏羯磨。僧已与彼比丘随覆藏日羯磨。彼比丘行覆藏时中间重犯。知日数覆藏。从僧乞前犯中间重犯覆藏本日治羯磨。僧已与彼比丘前犯中间重犯覆藏本日治羯磨。彼比丘行覆藏时中间第二重犯。从僧乞前犯中间重犯第二犯覆藏本日治羯磨。僧已与彼比丘前犯中间重犯第二犯覆藏本日治羯磨。如法。彼比丘行覆藏已。从僧乞六夜摩那埵。僧已与彼比丘六夜摩那埵。如法。彼比丘行摩那埵竟。从僧乞出罪羯磨。僧与彼比丘出罪。非法。我说此人不清净罪不出。此中知日数不覆藏三句亦如是。知日数覆藏不覆藏三句亦如是。不知日数覆藏三句亦如是。不知日数不覆藏三句亦如是。不知日数覆藏不覆藏三句亦如是。知日数不知日数覆藏三句亦如是。知日数不知日数不覆藏三句亦如是。知日数不知日数覆藏不覆藏三句亦如是。是中有比丘犯僧残罪。知日数不知日数乃至别异。彼比丘随覆藏日。已从僧乞覆藏羯磨。僧已与彼比丘随覆藏日羯磨。彼比丘行覆藏时中间重犯知日数覆藏。从僧乞前犯中间重犯覆藏本日治羯磨。僧已与彼比丘前犯中间重犯覆藏本日治羯磨。彼比丘行覆藏时中间第二重犯。知日数覆藏。从僧乞前犯中间重犯第二犯覆藏本日治羯磨。僧与彼比丘前犯中间重犯第二犯覆藏本日治羯磨。如法。彼比丘行覆藏竟。从僧乞六夜摩那埵。僧与彼比丘六夜摩那埵如法。彼比丘行摩那埵竟。从僧乞出罪羯磨。僧与彼比丘出罪。如法。我说此比丘清净无犯罪得出。知数不覆藏三句亦如是。知数覆藏不覆藏三句亦如是。不知数覆藏三句亦如是。不知数不覆藏三句亦如是。不知数覆藏不覆藏三句亦如是。知数不知数覆藏三句亦如是。知数不知数不覆藏三句亦如是。知数不知数覆藏不覆藏三句亦如是。尔时有异住处。有二比丘犯僧残罪。彼比丘即日从住处出去言。若得清净比丘我当忏悔。一比丘初去时覆藏第二比丘见异比丘便覆藏。是为二俱覆藏一忆罪第二不忆。彼忆而覆藏者是为覆藏。不忆者非覆藏。一疑二不疑。彼疑而覆藏者是为不覆藏。不疑而覆藏者是为覆藏。一知二不知。彼知而覆藏者是谓覆藏。彼不知而覆藏者是为不覆藏。时有比丘犯僧残罪。谓犯波罗夷覆藏。彼作如是念。我当云何。白诸比丘。诸比丘白佛。佛言。若比丘犯僧残罪。谓是波罗夷覆藏。应与作突吉罗忏后与摩那埵。时有比丘犯僧残罪。彼谓是波逸提波罗提提舍尼偷兰遮突吉罗恶说覆藏。彼作如是念。我当云何。白诸比丘。诸比丘白佛。佛言。若比丘犯僧残罪。谓是波逸提乃至恶说故覆藏者。应教作突吉罗忏悔已与摩那埵。时有比丘犯波逸提。谓是波罗夷覆藏。佛言。若比丘犯波逸提。谓是波罗夷覆藏者。教作突吉罗忏。后如法忏。时有比丘犯波逸提。谓犯僧残乃至恶说覆藏。佛言。应教突吉罗忏。忏已后如法忏。波罗提提舍尼偷兰遮突吉罗恶说亦如是。时有比丘犯僧残罪。若作僧残意覆藏。应教作突吉罗忏。忏已与覆藏。犯波逸提乃至恶说亦如是。时异住处有比丘。犯众多僧残罪。彼比丘不忆犯数不忆日数。彼作如是念。我当云何。白诸比丘。诸比丘白佛。佛言。若比丘犯僧残罪。不忆犯数不忆日数。应与清净已来覆藏。若忆犯数不忆日数。亦应与清净已来覆藏。若忆日数不忆犯数。应数日与覆藏。疑不疑亦如是。识不识亦如是。彼比丘或忆一罪数。或不忆一罪数。或忆一罪日数。或不忆一罪日数。应与清净已来覆藏。若忆犯数。或忆一罪日数不忆一罪日数。应与清净已来覆藏。若忆日数。或忆犯数。或不忆犯数。应数日与覆藏。疑不疑亦如是。识不识亦如是。时有比丘犯僧残罪。知数不覆藏。彼从僧乞六夜摩那埵。僧与彼六夜摩那埵。即于其日中间重犯。知数覆藏。彼作如是念。我当云何。白诸比丘。诸比丘白佛。佛言若比丘犯僧残罪。知数不覆藏。从僧乞六夜摩那埵。僧与六夜摩那埵。即于其日中间重犯。知数覆藏。僧应更与彼比丘摩那埵语言。汝比丘。应更行摩那埵。若行摩那埵。一夜乃至六夜中间重犯。知数覆藏。僧应与此比丘摩那埵。与摩那埵已。应与摩那埵本日治。行摩那埵本日治已。应与出罪。时有比丘犯僧残罪。知数不覆藏。从僧乞六夜摩那埵。僧与彼比丘六夜摩那埵。彼比丘即于其日中间重犯。不知数覆藏。僧应与彼比丘六夜摩那埵。语言。比丘汝更行摩那埵。若行一夜乃至六夜中间重犯。不知数覆藏。僧应与彼比丘摩那埵。与彼摩那埵已。应与摩那埵本日治。与摩那埵本日治已。应与出罪。时有比丘犯僧残罪。知日数不覆藏。从僧乞六夜摩那埵。僧与彼比丘六夜摩那埵。彼比丘即于其日中间重犯。知数不知数覆藏。僧应与彼比丘六夜摩那埵。语言。汝比丘更行摩那埵。若行一夜乃至六夜中间重犯。知数不知数覆藏。僧应与彼比丘六夜摩那埵。彼行摩那埵已。应与摩那埵本日治。与摩那埵本日治已。应与出罪。不知数不覆藏亦如是。知数不知数不覆藏亦如是(人揵度具足竟)

四分律卷第四十五四分律卷第四十六(三分之十)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    覆藏揵度第十三

尔时世尊在舍卫国。时六群比丘自行覆藏。更互与覆藏羯磨本日治摩那埵出罪羯磨。诸比丘白佛。佛言。不应自行覆藏与他覆藏羯磨本日治摩那埵出罪。彼行本日治比丘。更互作覆藏本日治摩那埵出罪。佛言。不应自行本日治更互作覆藏本日治摩那埵出罪。彼自行摩那埵比丘。更互作覆藏。佛言。不应自行摩那埵与他作覆藏羯磨乃至出罪。彼自出罪。更互作覆藏羯磨乃至出罪。佛言。不应自出罪与他覆藏羯磨乃至出罪。彼行覆藏。更互作覆藏羯磨本日治摩那埵足满二十人出罪。佛言不应尔。自行覆藏本日治亦如是。自行摩那埵亦如是。自行出罪亦如是。彼行覆藏者。与他受大戒。与他依止。畜沙弥。受僧差。差已教授比丘尼。佛言。行覆藏者不应尔。彼行覆藏者。知有余比丘能说戒者而为他说戒。于僧中或问毗尼义或答。在众僧作羯磨人数中。受僧羯磨差平断事。受众僧差使。佛言。行覆藏者不应尔。彼行覆藏者。或早入聚落逼暮还。或不亲附沙门亲近外道。不随顺比丘说异教。佛言不应尔。彼行覆藏者。若犯此罪。若相似。若从此生。若重于彼。呵他羯磨及作羯磨者。佛言不应尔。彼行覆藏者。受清净比丘敷座洗脚拭革屣揩摩身。佛言不应尔。彼行覆藏者。受清净比丘起迎逆礼拜执手恭敬问讯为持衣钵。佛言不应尔。彼行覆藏者。举清净比丘。作忆念。作自言。为他作证。遮说戒。遮自恣。与清净比丘共斗。佛言不应尔。彼行覆藏者。共清净比丘行入白衣家。或随他比丘行。或将他比丘行。或受他供养。或受清净比丘剃发。或受清净比丘作使。佛言不应尔。彼行覆藏比丘。共清净比丘行。至前食后食上在前行。或并语并行。或反抄衣。或通肩披衣。或裹头。或覆两肩。或着革屣。佛言不应尔。自今已去听偏露右肩脱革屣随从后行。彼行覆藏者。作如是意。不往食上。恐余比丘知我行覆藏。佛言不应尔。彼行覆藏者作如是意。至食上不坐。恐余比丘知我行覆藏。彼行覆藏比丘。作如是意。请取食食。恐余比丘知我行覆藏。佛言不应尔。彼行覆藏者。与清净比丘随次坐。佛言不应尔。听在末行坐。世尊有如是教。犯罪人应在下行坐。彼在白衣下坐。佛言不应尔。彼在沙弥下坐。佛言不应尔。应在大比丘末行坐。彼行覆藏者。与清净比丘共经行处行。彼在下经行处。已在高经行处。或在前行。或并语。或共行。反抄衣。通肩披衣。或裹头覆两肩。着革屣。佛言。不应尔。佛言。听偏露右肩脱革屣在后行。彼行覆藏者。道路行作如是意。不在正道行。恐余比丘知我行覆藏。佛言不应尔。彼行覆藏者。在道行作如是意。在后行恐余比丘知我行覆藏。佛言不应尔。彼行覆藏者。共清净比丘共一座一床一板。佛言不应尔。若长床板。佛言。听作隔断然后坐。若取余床在后坐。彼行覆藏者。若在小食大食上。应扫洒敷坐具水瓶洗瓶具盛残食器。应为清净比丘敷坐具。乃至洗足器物拭足巾盛水器。清净比丘来。应出远迎为持衣钵。若有钵床钵支应安置上。若僧伽梨在头上肩上。应取看之。无垢秽污不。若有尘垢秽污。应却便却。应浣当浣。浣已晒着绳床上木床上。应与清净比丘具洗足器拭足巾水器。拭革屣已着左面看之。不令泥水污不。若有泥水污者。当移避之。为清净比丘洗足已除去石水器安置本处。彼应净洗手。与清净比丘过食。清净比丘食时。应供给所须。若酪浆若蔓[少/(兔-、)]苦酒盐菜应与。若热当扇。须水应与水。若恐时过当俱食。清净比丘食已。当为取钵与洗手。若自食已有残食。应与人若非人。若着无虫水中若无草处。洗食器还复本处。应扫洒食堂除去粪土。彼比丘便用已。常食钵盛粪扫弃。余比丘见恶之。佛言。不应用钵弃粪扫。听以盆若澡盘若扫帚。钵应净洁畜。彼行覆藏比丘。若僧洗浴。应至清净比丘所问言。大德洗不。若彼答言当洗。此比丘便应先看浴室。无尘秽不。若有尘秽。应扫便扫。应水洒便洒。应取薪便取。应破便破。应然火便然火。应着薪便着。应与清净比丘具洗浴瓶若浴床若刮汗刀若水器若泥器若树皮若细末药若泥应问上座已燃火。若清净比丘病若老羸。应扶将至浴室所。若不能行者。以绳床木床若衣舁至浴室所。应取清净比丘衣安着衣架上若龙牙杙上。若有油应为涂身。彼油器无安处不坚牢。佛言。安着龙牙杙上。若悬着壁上。若清净比丘病老羸。应扶将入浴室中。与绳床木床浴瓶刮汗刀水器泥器。与树皮细末药泥。若烟来熏眼。当为安障。若头热背热应为覆。若欲洗浴入浴室。应白清净比丘。若作如是意。欲白清净比丘。恐烦乱共相逼迮者。直尔入浴室。在清净比丘后揩摩身。彼即入浴室。至清净比丘后住。应为余比丘揩摩身。不应受他揩摩身。为清净比丘洗浴已。然后自浴。若清净比丘老。应扶将出若病以绳床若木床舁出浴室。应与清净比丘敷座与洗脚器拭巾洗脚革屣。应取清净比丘衣舒看抖擞。勿令有蛇蝎诸毒虫。然后授与。若有眼药丸香应与。若有甜蒱桃浆蜜石蜜。净洗手受。授与清净比丘。若清净比丘老病乏气力者。应扶若以绳床木床若衣舁还房。应先入清净比丘房内敷卧具。若毡手扪摸看扶清净比丘卧。以衬体衣着内被覆上。若出房应闭户。至浴室中看。若有绳床木床若浴瓶若刮汗刀水器泥器树皮细末药泥。还复本处。应洗浴室便洗。有不净水应出便出。有火应灭便灭应覆便覆。若浴室户应闭便闭应脱举便举。应日三时见清净比丘。彼应作者一切应如法作。若清净比丘有所作不应违逆。若违逆应如法治。彼行覆藏者。至布萨日。应扫洒布萨处敷坐具水瓶洗脚瓶然灯具舍罗。彼行覆藏者。布萨竟应还复床座水瓶洗脚瓶舍罗着本处。彼行覆藏比丘。在上好房中住。余客比丘无住处。诸比丘白佛。佛言。行覆藏比丘。不应在上好房中住。听在小房中住。客比丘来遣行覆藏者出。佛言。不应遣亦不应去。听作如是语。大德。我曹不得二三人共宿。行覆藏比丘作如是念。众僧衣物为随次取应坐处取耶。佛言。应随次取已在下行坐。彼行覆藏比丘作如是念。我曹得更互作使不。佛言听。我曹得自相恭敬礼拜迎逆执手问讯不。佛言听。彼如是念。我曹得使僧伽蓝人沙弥不。佛言听。我曹得受僧伽蓝人沙弥礼拜迎逆执手问讯不。佛言得受。彼行覆藏者。不白清净比丘。佛言听白。应如是白。布萨日彼比丘。应至僧中偏露右肩脱革屣右膝着地作如是白。大德僧听。我某甲比丘犯僧残罪随覆藏日。从僧乞覆藏羯磨。僧已与我随覆藏日羯磨。我某甲已行若干日。余有若干日在。白大德令知我行覆藏。若大众难集。若不欲行。若彼人软弱多有羞愧。应至清净比丘所白言。大德上座。我今日舍教敕不作。若欲作时。应至清净比丘所白言。我今日随所教敕当作。彼行覆藏者。至余处见余比丘不白。佛言应白。不白失一夜得突吉罗。世尊既听白。余比丘便从此至余处白。从此至余处疲极。佛言。不应从此处至余处白听。若有因缘往应白。若复不白失一夜得突吉罗罪。彼行覆藏者。有客比丘来不白。佛言应白。若不白失一夜得突吉罗罪。世尊既听彼白客比丘。便至道路白诸疾行比丘遂疲极。佛言。不应往道路白疾行比丘。应在僧伽蓝内徐行者白。若不白失一夜得突吉罗罪。彼行覆藏者。病不遣信白。佛言应白。若不白失一夜得突吉罗罪。彼行覆藏者。二三人共一屋宿。佛言不应尔。若二三人共一屋宿。失一夜得突吉罗罪。彼行覆藏者。在无比丘处住。佛言不应尔。若住失一夜得突吉罗罪。彼行覆藏者。不半月半月说戒时白。佛言听白。若不白失一夜得突吉罗罪。有八事失夜。往余寺不白。有客比丘来不白。有缘事自出外不白。寺内徐行者不白。病不遣信白。二三人共一屋宿。在无比丘处住。不半月半月说戒时白。是为八事失夜。佛听半月半月说戒时白。应如是白。彼行覆藏者。应至僧中偏露右肩脱革屣右膝着地合掌白言。大德僧听。我某甲比丘犯僧残罪覆藏。我某甲比丘随覆藏日。从僧乞覆藏日羯磨。僧已与我随覆藏日羯磨。我某甲比丘。已行若干日。未行若干日。白大德令知我行覆藏。佛言。听行摩那埵比丘亦行如上诸事。行摩那埵者。应常在僧中宿日日白。应如是白。偏露右肩脱革屣右膝着地合掌白。大德僧听。我某甲比丘犯僧残罪不覆藏。从僧乞六夜摩那埵。僧已与我六夜摩那埵。我某甲比丘。已行若干日。未行若干日。白诸大德僧。令知我行摩那埵(覆藏揵度具足竟)

    遮揵度第十四

尔时世尊在舍卫国。时六群比丘作如是念。世尊无数方便教诸比丘。展转相教更相受语。便举清净无罪比丘。佛言。不应举清净无罪比丘。佛言。听先求听。六群比丘闻佛教先求听。彼即清净比丘先从六群比丘求听者求听。佛言不应尔。自今已去听内有五法应求听。知时不以非时。真实不以不实。利益不以损减。柔软不以粗犷。慈心不以嗔恚。时六群比丘内无五法。余比丘内有五法。从六群比丘求听而不与听。诸比丘白佛。佛言。若内有五法求听者应与。时六群比丘他求听便去。许他听已亦去。佛言不应尔。听作自言。时六群比丘。许他求自言已便去。自作自言已复去。佛言不应尔。佛言。听布萨说戒时应遮说戒。时六群比丘。闻佛听遮说戒。便遮清净比丘说戒。佛言不应尔。佛言。汝曹善听有如法遮说戒。有不如法遮说戒。一非法一如法。二非法二如法。三非法三如法。四非法四如法。五非法五如法。六非法六如法。七非法七如法。八非法八如法。九非法九如法。十非法十如法。何等一非法。若遮无根作。是为一非法。何等一如法。遮有根作。是为一如法。何等二非法。遮无根作不作。是为二非法。何等二如法。遮有根作不作。是为二如法。何等三非法。遮无根破戒破见破威仪。是为三非法。何等三如法。遮有根破戒破见破威仪。是为三如法。何等四非法。遮无根破戒破见破威仪无根邪命。是为四非法。何等四如法。遮有根破戒破见破威仪有根邪命。是为四如法。何等五非法。遮无根波罗夷僧残波逸提波罗提提舍尼遮无根突吉罗。是为五非法。何等五如法。遮有根波罗夷僧残波逸提波罗提提舍尼遮有根突吉罗。是为五如法。何等六非法。遮无根破戒作不作破见作不作破威仪作不作。是为六非法。何等六如法。遮有根破戒作不作破见作不作破威仪作不作。是为六如法。何等七非法。遮无根波罗夷僧残波逸提波罗提提舍尼偷兰遮突吉罗恶说。是为七非法。何等七如法。遮有根波罗夷僧残波逸提波罗提提舍尼偷兰遮突吉罗恶说。是为七如法。何等八非法。遮无根破戒作不作破见破威仪无根邪命作不作。是为八非法。何等八如法。遮有根破戒作不作破见破威仪有根邪命。是为八如法。何等九非法。遮无根破戒若作若不作若作不作破见若作若不作若作不作破威仪若作若不作若作不作。是为九非法。何等九如法。遮有根破戒若作若不作若作不作破见破威仪若作若不作若作不作。是为九如法。何等十非法。非波罗夷不入波罗夷说中非舍戒不入舍戒说中。随如法僧要。随如法僧要不违逆。如法僧要不入违逆说中。破戒不见不闻不疑。破见破威仪不见不闻不疑。是为十非法。何等十如法。波罗夷入波罗夷说中。舍戒入舍戒说中。如法僧要如法僧要违犯如法僧要呵说。入如法僧要呵说中。破戒见闻疑。破见破威仪见闻疑。是为十如法。云何犯波罗夷如因缘相貌犯波罗夷。比丘见此相貌知犯波罗夷。若不见此比丘犯波罗夷。闻彼比丘犯波罗夷。比丘若欲以此见闻疑于彼比丘前布萨时从坐起偏露右肩右膝着地合掌作如是言。此某甲比丘犯波罗夷。众僧不应在此比丘前说戒。今遮此比丘说戒。成遮说戒遮说戒时。众僧八难事。一一难事起王难贼难火难水难病难人难非人难恶虫难。此比丘若欲以此见闻疑此住处彼住处说戒时。于彼比丘前从坐起偏露右肩右膝着地合掌作如是言。某甲比丘入波罗夷说中。此事未决定今应决定。不应在此比丘前说戒。今遮此比丘说戒。成遮说戒。云何舍戒。如因缘相貌。知是舍戒比丘。见是相貌。知此比丘舍戒。若不见此比丘舍戒。闻彼某甲比丘舍戒。比丘若欲以此见闻疑于布萨时。在比丘前偏露右肩右膝着地合掌作如是言。某甲比丘舍戒。不应在此比丘前说戒。我今遮此比丘说戒。成遮。遮说戒时有八难事起。王难乃至恶虫难。彼比丘若欲以此见闻疑布萨时此住处彼住处。在彼比丘前从坐起偏露右肩右膝着地合掌作如是言。某甲比丘入舍戒说中。此事未决定。今应决定此事。不应在此比丘前说戒。我今遮此比丘说戒。成遮。云何如法僧要不随。如因缘相貌。如法僧要不随比丘见此相貌。知此比丘如法僧要不随。若不见此比丘如法僧要不随。闻彼某甲比丘如法僧要不随。比丘若欲以此见闻疑布萨时。在此比丘前偏露右肩右膝着地合掌作如是言。某甲比丘如法僧要不随不应在此比丘前说戒。我今遮此比丘说戒。成遮。云何如法僧要违逆如因缘相貌。如法僧要违逆。比丘见此相貌。知此比丘如法僧要违逆。若不见此比丘如法僧要违逆。闻彼某甲比丘如法僧要违逆。比丘若欲以此见闻疑布萨时。在彼比丘前从坐起偏露右肩右膝着地合掌作如是言。某甲比丘如法僧要违逆。不应在此比丘前说戒。我今遮此比丘说戒。成遮。遮说戒时。八难事中有一一事起。从王难乃至恶虫难。彼比丘若欲以此见闻疑此住处彼住处布萨时。在此比丘前从坐起偏露右肩右膝着地合掌作如是言。某甲比丘入如法僧要违逆说中。此事未决定。今应决定。不应在此比丘前说戒。我今遮此比丘说戒。成遮。云何破戒。如因缘相貌是破戒。比丘见此相貌知彼比丘破戒。若不见此比丘破戒。闻彼某甲比丘破戒。此比丘若欲以此见闻疑布萨时。在此比丘前偏露右肩右膝着地合掌作如是言。某甲比丘破戒。不应在此比丘前说戒。我今遮此比丘说戒。成遮。破见破威仪亦如是。是为十如法。若比丘欲举他者。内有五法应举他。何等五。以时不以非时真实不以不实。有益不以损减。柔软不以粗犷。慈心不以嗔恚。比丘有此五法应得举他。何以故。我见比丘举他。以非时不以时。不实不以实。或以损减不以利益。或以粗犷不以柔软。或以嗔恚不以慈心。彼余比丘应语此比丘言。举汝。非时不以时。莫起嗔恨。以不真实不以实。以损减不以利益。以粗犷不以柔软。以嗔恚不以慈心。莫以此语嗔恚。若比丘被他不实举者。应以此五事解喻。举汝。非时不真实损减粗犷嗔恚莫以是愁忧。被不实举者。应以此五事解喻。彼不实举他者。应与五事呵责。汝举他非时不以时以不实不以实以损减不以利益以粗犷不以柔软以嗔恚不以慈心可惭愧。以不实举他者应以此五事呵责。何以故。令后不复以不实举清净比丘。呵责已应如法治。被真实举比丘。应以五事呵责。举汝得时不以非时莫生嗔恨。真实不以不实利益不以损减柔软不以粗犷慈心不以嗔恚莫生嗔恨。被真实举比丘。应以此五事呵责。呵责已如法治。彼真实举他者。应以五事赞美。举他得时不以非时。莫生悔恨。真实不以不实。利益不以损减。柔软不以粗犷。慈心不以嗔恚。莫生悔恨。真实举他者。应以此五事赞美。何以故。后若复举他者。当以真实举。遮说戒比丘。至上座前作如是语。我欲遮某甲比丘说戒。愿见听。上座应问。汝内有五法不。若言无。教令莫遮。若言有。当问何等五。若不能说。应语令莫遮。若能说。应问言。汝已问中座未。若言未问。应教令问。彼应至中座比丘前语言。我欲遮某甲比丘说戒。愿长老听。中座应问。汝内有五法不。若言无。应语令莫遮。若言有。应问言。何等五。若不能说。应语令莫遮。若能说。应问言。汝已问上座未。若言未。应语令问。若言已问。应问言。汝复问下座未。若言未。应教令问。彼应至下座比丘前作如是言。我遮某甲比丘说戒。愿见听。彼应问。汝内有五法不。若言无。应语令莫遮。若言有。应问言。何等五。若不能说。应教令莫遮。若能说。应问言。汝问上座未。若言未。应教令问。若言已问。应问言。汝问中座未。若言未。应教令问。若言已问。应问。汝已问彼比丘未。若言未问。应教令问。此比丘应往彼比丘所语言。我欲遮长老说戒愿见听。彼应问言。汝内有五法不。若言无。应教令莫遮。若言有。应问言。何等五。若不能说。应教令莫遮。若能说。应问言。汝问上座未。若未问。应教令问。中下座亦如是。彼比丘应自观察。我此事得比丘伴不。若不得伴。应语彼比丘言。莫遮。得比丘伴。应语言。便可随时。尔时有异住处。布萨时有比丘犯僧残。作如是念。我当云何。即白诸比丘。诸比丘白佛。佛言。若有异住处。有比丘犯僧残罪。众僧应与波利婆沙。与波利婆沙。应与本日治便与。应与摩那埵便与。应与出罪便与出罪。尔时有异住处。有比丘犯波逸提。是中有比丘。或言犯波逸提。或言犯波罗提提舍尼。彼比丘作是念。我当云何。白诸比丘诸比丘白佛。佛言。若有异住处比丘犯波逸提。或言犯波逸提。或言犯波罗提提舍尼。是中有见犯波逸提比丘者。将彼比丘。至眼见不闻处。教如法忏悔。忏悔已。至彼比丘所语言。此比丘已如法忏悔。应作如是已说戒。时有异住处。有比丘犯偷兰遮。是中比丘。或言犯偷兰遮。或言犯波罗夷。是中言犯偷兰遮者。皆是多闻。学阿含持法持律持摩夷得伴党。比丘比丘尼优婆塞优婆夷。国王大臣种种外道沙门婆罗门。是中言犯波罗夷者。皆多闻学阿含持法持律持摩夷得伴党。比丘比丘尼优婆塞优婆私。国王大臣种种外道沙门婆罗门。彼作如是念。若今日说戒。令僧斗诤共相诽谤。令僧破坏。令僧尘垢。令僧别异住。我当云何。白诸比丘。诸比丘白佛。佛言。若有异住处比丘犯偷兰遮。是中或言犯偷兰遮。或言犯波罗夷。言犯偷兰遮者。皆是多闻乃至持摩夷得比丘比丘尼伴党。乃至沙门外道婆罗门。言犯波罗夷者。皆是多闻乃至持摩夷得比丘比丘尼伴党。乃至沙门外道婆罗门。彼作如是念。若今日说戒。令僧斗诤共相诽谤。令僧破坏。令僧尘垢。令僧别异住。若比丘重此破僧事者。不应此日说戒。佛言。听遮说戒。时六群比丘闻佛听遮说戒。便遮清净比丘说戒。佛言。不应遮清净比丘说戒。汝曹善听。虽遮说戒不成遮。遮无根作不成遮。遮有根作成遮。遮无根不作不成遮。遮有根不作成遮。遮无根作不作不成遮。遮有根作不作成遮。遮无根有余作不作亦如是。遮无根无余作不作亦如是。若五种说戒未说戒遮说戒不成遮。若说戒竟遮说戒不成遮。若说戒时遮说戒成遮。若遮说戒比丘。身行不清净口行不清净邪命痴不能言。不知方便不解问答。余比丘应语言。长老止。不须作此斗诤。应作如是已说戒。遮说戒比丘。身行清净。口行不清净。邪命痴不能言。不知方便不解问答。余比丘应语言。长老止。不须作此斗诤。应如是已说戒。若遮说戒比丘。身行清净口行清净。邪命痴不能言。不知方便不解问答。余比丘应语言。长老止。不须作此斗诤。应作如是已说戒。遮说戒比丘。身行清净口行清净。不邪命。有智慧能言。知方便能问答。余比丘应问言。长老。遮此比丘说戒。为以何事故。为破戒耶。为破见破威仪耶。若言破戒。应问言。破何等戒。若言波罗夷。若言僧残。若偷兰遮。是为破戒。若言不破戒破见故遮。应问言。破何等见。若言六十二见。此是破见。若言不破见破威仪故遮。应问言。破何等威仪。若言破波逸提波罗提提舍尼突吉罗恶说。是为破威仪。应问言。以何故遮此比丘说戒。以见故耶。以闻疑故耶。若言见。应问言。见何事。云何见。汝在何处。彼在何处见。何等为是波罗夷。为是僧残。为是波逸提。为是波罗提提舍尼偷兰遮突吉罗恶说耶。若言不见言闻。应问言。闻何事。从谁闻。为是比丘。为是比丘尼耶。为是优婆塞优婆夷耶。何所闻。此比丘为犯波罗夷。为僧残。为波逸提。为波罗提提舍尼。为偷兰遮。为突吉罗。为恶说耶。若言不闻为疑故遮。应问言。疑何事。云何疑。从谁许闻疑耶。为比丘比丘尼优婆塞优婆私。为疑犯何事。为波罗夷。为僧残波逸提波罗提提舍尼偷兰遮突吉罗恶说耶。遮说戒比丘不能答智慧持戒比丘令欢喜者。若遮波罗夷。应与作僧残已便说戒。若遮僧残。应与波逸提已便说戒。若遮波逸提。应以余罪忏悔已便说戒。若遮说戒比丘能答。智慧持戒比丘令欢喜者。若以波罗夷遮。应与灭摈已便说戒。若遮僧残。应与覆藏已说戒。若应与本日治。与本日治已说戒。若应与摩那埵。与摩那埵已便说戒。应与出罪羯磨与出罪已说戒。若以波逸提遮者。应如法忏悔已说戒。若以余事遮。应如法忏悔已说戒。尔时异住处说戒。病比丘遮病比丘说戒。病比丘作如是念。我当云何。白诸比丘。诸比丘白佛。佛言。若病比丘遮病比丘说戒。余比丘应语言。世尊有如是教。不应遮病比丘。须长老病差彼比丘病亦差。长老如法说。彼比丘亦当如法说。应作如是已说戒。时有异处说戒。时病比丘遮不病比丘说戒。余比丘应语言。世尊有如是教。病人不应遮他说戒。须病差当如法说。彼亦当如法说。应作如是已说戒。时有异处说戒。时有无病比丘遮病比丘说戒。余比丘应语言。长老。世尊有如是教。不应遮病比丘。须病差如法问彼比丘如法说。应作如是已说戒。时有异处。众多比丘说戒日。闻彼处有比丘喜斗诤骂詈共相诽谤口出刀剑。欲来此说戒。我曹当云何。诸比丘白佛。佛言。若有如此事起。应作二三种布萨。若应十五日说十四日作。若应十四日说十三日作。若闻今日来。即应疾疾集一处布萨。若闻已至界内。应出外布萨。若言已入僧伽蓝。便应扫除浴室具浴床浴瓶刮汗刀水器泥器树皮细末药若泥。问上座已与然火。彼客比丘入浴室浴时。应一一从浴室中出界外说戒。若客比丘唤旧比丘共说戒。应答言。我曹已说戒。若旧比丘说戒已。客比丘遮说戒者不成遮。若客比丘说戒时。旧比丘遮说戒成遮。若能如是者善。若不能。应作白却说戒日。应作如是白。大德僧听。僧今不说戒。至黑月当说戒。白如是。应作如是白却说戒。若客比丘便待不去。彼比丘应作白第二却说戒。应作如是白。大德僧听。僧今不说戒。至白月当说戒。应如是白第二却说戒。若客比丘不去至白月。旧比丘应如法强与客比丘问答(遮揵度具足竟)

    破僧揵度第十五

尔时世尊在王舍城。有因缘众僧集会。时提婆达多从坐起行舍罗。谁诸长老忍。此五事是法是毗尼是佛所教者便捉筹。时有五百新学无智比丘捉筹。尔时阿难从坐起。以郁多罗僧着一面。作如是言。谁诸长老忍。此五事非法非毗尼非佛教者。以郁多罗僧着一面。是中有六十长老比丘。以郁多罗僧着一面。时提婆达多语诸比丘言。长老。我曹不须佛及众僧自共作羯磨说戒。即往至伽耶山中。尔时提婆达多至伽耶山中。离佛及僧自作羯磨说戒。尔时众多比丘往世尊所。礼足已却坐一面白世尊言。王舍城中有因缘事众僧集会。时提婆达多从坐起行筹言。谁诸长老忍。此五事是法是毗尼是佛所教者便捉筹。中有五百新学无智比丘即捉筹。时长老阿难即从坐起。以郁多罗僧着一面言。谁诸长老忍。此五法非法非毗尼非是佛教者。舍郁多罗僧着一面。时有六十长老比丘舍郁多罗僧着一面。时提婆达多语诸比丘。我等可舍佛及僧自作羯磨说戒。即往伽耶山中。舍佛及僧作羯磨说戒。佛言。此痴人破僧。有八非正法。缠缚覆障消灭善心。提婆达多趣于非道。在泥犁中一劫不救。何等八。利无利誉不誉恭敬不恭敬恶知识乐恶友。有如是八非正法缠缚覆翳消灭善心。提婆达多趣于非道。在泥犁中一劫不救。我若见提婆达多有如毛发善法者。终不记言在泥犁中一劫不救。以不见提婆达多有如毛发善法故。记言在泥犁中一劫不救。譬如有人没在屎中。有人欲出都不见有如毛发处净可以手捉出之。今观提婆达多亦复如是。不见有如毛发许白法。是故我言。提婆达多在泥犁中一劫不救。尔时舍利弗目连往伽耶山中。有比丘见涕泣流泪。往世尊所头面礼足却坐一面白世尊言。世尊第一弟子亦往伽耶山中。佛告比丘。汝莫恐怖。舍利弗目连往伽耶山中求利益故。尔时提婆达多。在伽耶山中与无数众围绕说法。遥见舍利弗目连来即言善来汝大弟子。虽先不忍而今忍者虽后而善。舍利弗目连到已敷座而坐。尔时提婆达多。于大众前如佛常法。告舍利弗。为众僧说法。我今背痛小自停息。时提婆达多法像世尊。自襞叠僧伽梨为四重。以右胁着地。犹如师子。不觉左胁着地。犹如野干偃卧鼾眠。时舍利弗语目连言。今可为此大众示生厌离心。目连闻舍利弗语已。即以神通上升虚空。或现形说法。或不现形而说法。或现半形而说法。或不现半形而说法。或时出烟。或时出火。或时身下出火身上出水流。或时身上出火身下水流。或时通身火然毛孔出水。时舍利弗知大目连为此大众示生厌离心已。即为说四谛法苦集尽道。时诸比丘。即于座上远尘离垢得法眼净。尔时舍利弗目连告诸比丘。其有是世尊弟子者便随我来。时舍利弗目连。与五百比丘即从坐起而去。舍利弗目连出外未久。三闻达多触提婆达多脚指言。提婆达多可起。舍利弗目连。将五百比丘从坐而去。彼即惊怖而起。热血从面孔出。诸比丘见舍利弗目连将五百比丘来欢喜。往诣佛所。头面礼足却坐一面。白佛言。舍利弗目连。将五百比丘来。佛告比丘。舍利弗非直今者破提婆达多。此是第二舍利弗破提婆达多。乃往过去世时。有年少婆罗门。字散若。往诣射师所白言。师我欲学射术。即答言可学。时散若。于七年中学射。过七年已便作如是念。我今学射何时可已。即往师所白言。我今故可几时学射。师即教令牵弓着箭语言。我有因缘入村。须我还乃可放箭。时师敕已便入村。时散若作是念。师何故教我牵弓着箭待还而放耶。我今可放箭。知有何事。散若前有大娑罗树。即放箭着树。箭过入地不现。时师入村事讫便还。至散若所问言。汝未放箭耶。答言已放。师言。汝作不善。若汝不放箭者。于阎浮提最为大师。今我为阎浮提第一大师。若我死者次当有汝。时师。即庄严其女。以五百枚箭并一马车与之。时散若受已当度旷野。散若即安其妇着车上。持五百枚箭度旷野。时有五百群贼于旷野中食。时散若即语妇言。汝往贼所乞食。时妇即往语贼言。散若从汝乞食。时贼帅言。今观其所使非是常人。宜可与食。时有一贼。便起作是言。我曹犹活此人将妇乘车而去耶。时散若即放箭。应箭而死。余者复起作如是言。我曹犹活此人将妇乘车而去耶。散若复放一箭。应箭而死。如是其有一一起者。应箭而死。时散若余有一箭。唯有贼帅在。未得其便。而不放箭。即语妇言。汝脱衣置地。妇即脱衣。即得贼便放箭。应箭而死。佛告诸比丘。汝欲知不。昔五百贼者。即今五百比丘是。贼帅者。提婆达多是。散若婆罗门者。岂异人乎。即舍利弗是。是为舍利弗昔日破。今第二破。尔时舍利弗目连。将五百比丘往至佛所。头面礼足却坐一面白佛言。此五百比丘。随顺提婆达多作别众。今应更受大戒。佛告舍利弗目连。随顺提婆达多比丘。先戒即是。但应教令作偷兰遮忏悔。目连白佛言。世尊在无数众中告舍利弗。汝可说法。我今背痛小自停息。提婆达多亦复如是。法像世尊。自叠僧伽梨为四重。以右胁着地。犹如师子。不觉左胁着地。犹若野干。偃卧鼾眠。佛告目连。提婆达多非但今日法像我得此苦恼。此是第二苦恼。目连。乃往过去世。雪山王右面有大池水。有一大象在边止住。时彼大象。入池水中洗浴饮水。以鼻拔取藕根。洗令净而食之。气力充足形体光泽。复有一小象。常相随逐。彼小象法学大象。入池水洗浴。拔取藕根不洗合泥而食。彼食藕根。气力不足。形无光泽。遂便致病。而说偈言

  我曹大无欲　　食藕甚清净
  小象杂泥食　　学我而致病
  死尸臭有息　　食消噫自止
  人行非法者　　长夜气不灭
  贪欲嗔恚痴　　丈夫有恶心
  痴人自毁伤　　如果繁枝折
  芭蕉以实死　　竹籚亦复然
  儜人伤利养　　駏驉怀妊死

佛告目连。时大象者即我身是。小象者提婆达多是。佛告目连。此是提婆达多第二学我致此苦恼。时诸比丘作如是念。未曾有。提婆达多是世尊弟子。乃作如是背恩作非法。以邪教破坏五百弟子。尔时世尊。知诸比丘心之所念。即告诸比丘。提婆达多非但今日破坏我弟子。乃往过去世。有二阎浮提王。一名月二名月益。十四日生故名为月。十五日生故名为月益。彼此同意无有嫌隙。阎浮提中有一河水。名修罗吒。其水两边。各有四万二千城。国土平博严好人民财富炽盛饮食丰饶。时月益王。修罗吒河水边有城。亦名修罗吒。东西十二由旬南北七由旬。二王作要。若我生男当取汝女。若汝生男当取我女。时王月益不生男女。为求儿故。祠祀水神。礼事种种诸天。满善天宝善天。日月释梵地火风神。摩醯首罗天。园神林神。空野神市神。鬼子母神城郭神。为天作福希望有儿。时修罗吒河边。有二五通仙人住。时河水神白王言。修罗吒河边有二五通仙人住。若彼求愿生王家者王当有儿。时王月益。即至河边。渐行求觅。至仙人所。语仙人言知不。我家无儿。若汝等能求愿生我家者命终便得生。若生我家者五欲自恣快乐无乏。仙人答言可尔。时王月益欢喜还归。时一仙人于后七日命终。即处彼第一夫人胎中。女人有三种智。知有娠时。知所从得。知男子有欲意看。时夫人白王言。王今知不。我今有娠。王言善快。当重供养。即敕一切供具增益一倍。时第二仙人七日复命终。即处第二夫人胎中。夫人白王。王今知不。我今有娠。王即增供具如上。时王即遣人往看修罗吒河边有几仙人。使即往看。见二仙人已死。即还白王言。仙人已死。王自念言。彼二仙人命终。生我二夫人胎中彼九月满。生一男儿颜貌端正。王第一夫人生男儿时。众善自至。有五百贾客来至。五百贾客从海取宝而还。有五百伏藏悉自发出。有五百死囚从狱得出。时王月益自思惟言。当为此儿作何等字。彼国法。若初生男儿。或父母若沙门婆罗门作字。时王自念。何须沙门婆罗门作字为。此儿生日。多有善事现。即字为善行。时王即与四种母。一者治身。二者洗浴浣濯。三者与乳。四者当为娱乐。象马车乘作众伎乐种种戏笑。又持孔雀尾在后。如是严饰娱乐。善行王子年至八九。教种种技艺书数印画戏笑歌舞伎乐。又学骑象马车乘射御斗战之事。时彼王子一切皆学。时王第二夫人生子。时多有众恶事起。野干鸣。阿修罗捉日。五百应死者来至。波国法。若初生儿。当令沙门婆罗门作字。王自念言。何须沙门婆罗门作字为。此儿生日。多众恶事出。即字之为恶行。王亦复与四母。一者治身。二者洗浴浣濯。三者与乳。四者当为娱乐。象马车乘作众伎乐种种戏笑。乃至教学斗战之事。时善行王子。王甚爱念。及诸余小国王子夫人大臣侍从一切人民亦无不爱念。而恶行王子。王不爱念。诸余一切亦不爱念。时恶行王子。作如是念。善行王子。王及一切人民甚爱念之。而我独尔。王不爱念。及余一切亦不爱念。我伺求方便当断其命。尔时邻国王月第一夫人生女。即遣使来至月益王所语言。我第一夫人生女。当与汝儿善行作妇。于异时善行王子作如是念。阎浮提众生皆多贫苦。我当入海取如意珠。令阎浮提众生无有贫者。时即至王所白言。阎浮提众生皆多贫苦。我欲入海取如意珠令阎浮提众生无有贫者。王即答言。我大有金银七宝无数。库藏盈满。可随意所与。即答王言不能。必欲入大海取如意珠令阎浮提众生无有贫者。王言。随汝意。时恶行王子即作是念。今正是时。可得其便而断其命。即至王所白王言。善行是我所敬重。今欲入海。若我不见将恐丧命。今欲与相随入海。王言随意。时王子。与王及夫人眷属辞别已。往诣修婆罗城中。摇铃唱言。谁能舍离父母妻子兄弟姊妹及诸亲属。欲须金银珍宝无价宝珠者。随我入海。一切所须饮食庄严之具。我当供给。时即有五百贾客来集其所。时善行。与五百贾客俱至须波罗城。于彼城中买船并求船师。船师知海中诸难。涌浪难洄澓难大鱼难庄严船已。复重唱令如上。即放船入海。以善行福德故。风吹其船诣七宝所。告诸贾人言。今已至宝渚。好牢坚庄船。自恣取宝。满船勿令沉没。时诸贾人受教取宝。善行教授众贾人已。更诣余处。恶行王子。以恶言向众贾人说之。善行王子若安隐还至当夺汝等宝。曼今未还。可推船置海而去。时恶行说五百贾人。贾人已受其说。推船入海而去。彼薄福果报风破其船五百贾人没海而死。恶行王子得一船板。风吹展转得还趣岸。彼于海边在贫贱聚落。家家乞食自活。时善行还至故处不见众贾人。亦不见船。即便椎胸啼泣懊恼。恐诸贾人为恶鬼罗刹等所害。时宝渚神语善行言。五百贾人非恶鬼罗刹等所害。是恶行王子恶言。破坏五百贾人。使推船入海而去。薄福果报风破其船。五百贾人。没海而死恶行王子得一船板。风吹至岸。彼于海边乞食自活。善行自念。我今宁可前至海龙王宫乞如意珠。即便引道而去到罗刹渚。时五百罗刹女出迎。遥见慰问。善来童子欲至何所。答曰阎浮提众生皆多贫苦。欲往海龙王宫乞如意宝珠令阎浮提众生无贫苦者。即复问言。欲取何乘。答言。欲取大乘。罗刹女言善哉。若汝成最正觉。我当出家作汝弟子。报言可尔。彼遥见金城中有一金床。龙坐其上。时善行王子。即往金城至彼龙所。时龙王遥见慰问。善来童子。欲何所至。答言。龙王知不。阎浮提众生皆多贫苦。我欲至海龙王宫取如意珠令阎浮提人无有贫苦。彼即答言。海龙王宫难可得至。七日中行水常至膝。复七日中行水至脐。七日中行水至腋。七日中浮而过。七日中行莲华上。七日中行毒蛇头上。然后乃至海龙王宫。汝今可止。我有宝珠。能雨东方二千由旬七宝。今当与汝。答言不取要当至海龙王宫。即复问言。欲取何乘。答言。欲取大乘。复言。若汝成最正觉者。我当出家为汝作第一智慧弟子。即舍金城。遥见银城。中有龙王在银床上坐。时善行王子往诣银城至龙王所。龙王遥见慰问。善来童子。欲何所至。答言。龙王知不。阎浮提众生皆多贫苦。我欲至海龙王宫取如意珠令阎浮提人无有贫苦。答言。海龙王宫难可得至。七日中行水常至膝。七日中至脐。七日中至腋七日中浮过七日中行莲华上。七日中行毒蛇头上。然后乃至海龙王宫。汝今可止。我有宝珠。能雨南方四千由旬七宝。今当与汝。答言不取。我要当至海龙王宫。即复问言。欲取何乘。答言。欲取大乘。复言。汝若成最正觉者。我当出家为汝作第一神足弟子。即舍银城去。复见有琉璃城。有龙王坐如上。即与如意珠能雨西方六千由旬宝。答言不取。我要当至海龙王宫。复问言。欲取何乘。答言。欲取大乘。若汝成最正觉时我当出家为汝作第一多闻弟子。时善行即复前行。七日中水至于膝。乃至行莲花上。乃至毒蛇处作如是念。以何行报生毒蛇中。岂非前世嗔毒报耶。当以何法而降伏之。唯有慈心。即思惟慈心三昧。时诸毒蛇皆悉垂头。行上而过。至海龙王宫。时海龙王遥见慰问言。善来童子。何所须欲。答言。我今欲得汝髻中如意宝珠。答言。汝等短寿。此珠价大。非不相与。今当与汝。但汝命欲终时。还送珠来。即解珠与之。并遣二龙。后持珠还。时善行捉珠求愿言。若是如意珠者。便当忽然还至修波罗城。如意念顷即还修波罗城。时恶行王子。闻善行从海安隐而还。即往善行所语言。汝知不。我今在贫穷聚落。家家乞食以自生活。汝从大海安隐而还。为何所得耶。即答言。得此如意宝珠来。时善行语言。我今疲极。欲小眠息。即枕恶行膝上而眠。时恶行。即以佉陀罗木刺。刺其两眼。持珠而去。彼伤两眼血流污身。东西慞惶行不见道。遂至月王园中。时守园老母有二小儿。遥见其来血流污身行不见道。即愍伤之。问言。汝何故。乃于月王园中行东西慞惶而不见道。即具为说因缘。老母语言。我有二儿。可共汝戏。汝今可在此住。当相看视。犹如二儿。时恶行。即还修罗吒城。至王月益所。白王言。王今知不我海中遇大风破船。五百贾人没在海中。唯我安隐而还。王言。汝从海安隐而还。为得何等。答言。得此如意宝珠。王即问言。此珠何所能作耶。答言不知。时王即取珠付藏赏之。时恶行即遣使语邻国王月。善行与五百贾人入海取宝。水所漂没。汝今可与我女。王即报言。须我语女。王即唤女告之。善行与五百贾人入海取宝为水所漂。恶行安隐而还。今欲索汝为妇。答言不能。我欲自出求夫。时王即令国中皆令聚集。庄严其女。出外东西求觅夫。时善行。即调其琴而弹之。出美音声在园中住。时王女见之。即往白王言。王今知不。我欲得此人为夫。王言。此是盲人。女答王言无苦。时王月。即唤善行。问言。童子。汝是何人。答言。王今知不。我是王月益第一太子善行。王言。何故伤眼耶。即以上因缘具白王。王言。汝若是王月益子者。今当发愿令眼平复。善行即发善愿。若我为阎浮提众生贫苦苦厄故。入海求如意宝珠。欲令阎浮提众生无有穷乏。并及恶行王子。以恶言破坏五百贾人。舍我而还。复以佉陀罗木刺。破我两眼。持我如意珠而还。我于彼人无有恶心。若我真诚无虚者。眼当平复如故。时发愿亦竟眼寻平复。时王即极好庄严其女以适之。王即遣使。语王月益言。汝今知不。王子善行。安隐从海而还。今极好庄严我女以适之。今当往修罗吒城。时王月益。即敕国内种种庄严。于是王子善行往修罗吒城。头面礼王足已。具以因缘白王。王即敕人杀恶行。善行白王言。愿不须杀。时王月益遣恶行令出国。善行问王言。恶行持珠来。今为所在。王言。今在库中。白王言。可出珠。王即出珠。善行即净洗浴身着新白净衣。取珠安置幢头。着高好殿上。发愿言。若审是如意宝珠者。当雨满阎浮提七宝。其有病者皆令除愈。发愿顷间。即雨满阎浮提七宝。后于异时。王月益丧。即以善行为王。时王子恶行。来至善行所白言。我今在外。家家乞食以自存活。王答言。汝可守护我头。当以我所食与汝。答王言尔。后于异时。王小眠睡。恶行念言。今可断命。即拔刀斫之。时恶行臂寻自堕。即自称祸。王便觉问言。童子何故称祸。答王言。天自造其业。王言。何故耶。以此因缘白王。王言。实是汝自造其业。佛告诸比丘。王月益者岂异人乎。今白净王是第一夫人者即今母摩耶是。尔时月王者今执仗释种是。时月王女者。今瞿夷是。时守园老母者今摩诃波阇波提比丘尼是。二儿者今难陀阿难是。时善行者。我身是。时恶行者今提婆达多是。五百贾人者今五百比丘是。昔以恶教破此诸人。今亦复以恶教破之。尔时优波离。即从坐起偏露右肩右膝着地合掌白佛言。云何破僧。齐几人名为破僧谁破和合僧。佛言优波离。有二事破僧妄语。相似语。以此二事故破僧。优波离复有二事破僧。作羯磨。取舍罗。优波离。一比丘不能破僧。虽求方便亦不能破僧。亦非比丘尼非式叉摩那沙弥沙弥尼破僧。虽求方便破僧亦不能破僧。优波离此众一比丘彼众一比丘彼行破僧舍罗作羯磨。如是不能破僧。但令僧尘垢。二人三人亦如是。优波离。若此众四人若过。彼众四人若过行破僧舍罗作羯磨。优波离。齐是名为破僧。是为破和合僧。优波离复问。破和合僧为得何等。佛言。破和合僧者。泥犁中受罪一劫不疗。僧破已能和合者得何等。佛言。得梵天福一劫受乐。而说偈言

  众僧和合乐　　和合不诤竞
  和合则有法　　常得勤修道
  能和合众僧　　一劫受天乐

优波离复问。一切破僧者。皆堕地狱一劫受苦不。佛语优波离。一切破僧人。不必尽堕地狱受苦一劫。优波离。若比丘非法言法。坚持此法。破和合僧。彼自知非法想破。便作非法想说如是言。此是法此是毗尼是佛所教。异见畏忍行破僧舍罗。优波离如此破僧者。一劫泥犁中受苦不疗。若比丘。非法说法。坚持此事。方便破僧。非法想破法想说。此是法是毗尼。是佛所教。行破僧舍罗作羯磨。优波离。如是破僧人。一劫泥犁中受苦不疗。法想破非法想说亦如是。优波离。若比丘非法说法坚持此事。破和合僧。彼法想破法想说此是法是毗尼是佛所教不异见不异忍。行破僧舍罗作羯磨。如是优波离。此人不堕地狱一劫受苦。疑不疑四句亦如是。非法想疑四句亦如是。如是乃至说不说亦如是(破僧揵度具足竟)

四分律卷第四十六四分律卷第四十七(三分之十一)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    灭诤揵度第十六之一

尔时世尊在舍卫国。时迦留陀夷。与六群比丘往阿夷罗跋提河中浴。时迦留陀夷。浴竟上岸。着六群比丘衣。谓是己衣。不看而去。六群比丘。洗浴已上岸。不见己衣。正见迦留陀夷衣。即言迦留陀夷偷我衣。人不在现前。便作灭摈羯磨。迦留陀夷闻已有疑。即往世尊所。头面礼足却坐一面。以此因缘具白佛。佛问言。汝以何心取。答言。谓是我衣取。不以贼心。佛言。不犯。不应不看衣而着。不应人不现前而作羯磨。呵责羯磨。摈羯磨。依止羯磨。遮不至白衣家羯磨。举羯磨。灭摈羯磨。若作羯磨不成。得突吉罗。自今已去。为诸比丘结现前毗尼灭诤。应如是说现前毗尼。尔时世尊在王舍城。时沓婆摩罗子。不犯重罪波罗夷僧伽婆尸沙偷兰遮。时诸比丘皆言犯重罪。即问言。汝忆犯重罪波罗夷僧伽婆尸沙偷兰遮不。彼不忆犯波罗夷僧伽婆尸沙偷兰遮。答言。我不忆犯如是罪。即语诸比丘言。长老。莫数诘问我。诸比丘故诘问不止。彼作如是念。我当云何。白诸比丘。诸比丘白佛。佛言。自今已去。听为沓婆摩罗子作忆念毗尼白四羯磨。应如是与。沓婆摩罗子。应往僧中偏露右肩脱革屣右膝着地合掌白如是言。大德僧听。我沓婆摩罗子不犯重罪。诸比丘言。我犯重罪波罗夷僧伽婆尸沙偷兰遮。诸比丘问我言。汝忆犯重罪波罗夷僧伽婆尸沙偷兰遮不。我不忆犯重罪波罗夷僧伽婆尸沙偷兰遮。答言。我不忆犯如是重罪。诸长老。不须数数难诘问我。而诸比丘故难诘不止。我今不忆念。从僧乞忆念毗尼。愿僧与我忆念毗尼。慈愍故。如是第二第三乞。众中应差堪能羯磨者如上作如是白。大德僧听。此沓婆摩罗子。不犯重罪波罗夷僧伽婆尸沙偷兰遮。诸比丘皆言。犯重罪波罗夷乃至偷兰遮。诸比丘问言汝忆犯重罪波罗夷乃至偷兰遮不。彼不忆犯重罪。即答言。我不犯重罪。诸长老。不须难诘我。而诸比丘故难诘不止。彼不忆犯罪。今从僧乞忆念毗尼。若僧时到僧忍听。与彼忆念毗尼。白如是。大德僧听。此沓婆摩罗子。不犯重罪波罗夷僧伽婆尸沙偷兰遮。诸比丘皆言。犯波罗夷僧伽婆尸沙偷兰遮。即问言。汝忆犯重罪波罗夷乃至偷兰遮不。彼不忆犯重罪。即答言。我不忆犯重罪。诸长老。不须数难诘问我。而诸比丘故数数难诘不疑。彼不忆罪。今从僧乞忆念毗尼。今僧与沓婆摩罗子作忆念毗尼。谁诸长老忍。僧与沓婆摩罗子忆念毗尼者默然。谁不忍者说。此是初羯磨。第二第三亦如是说僧已忍。与沓婆摩罗子忆念羯磨竟。僧忍默然故。是事如是持。自今已去。与诸比丘结忆念毗尼灭诤。应如是说忆念毗尼。尔时世尊在王舍城。时有比丘名难提。癫狂心乱。多犯众罪非沙门法。言无齐限。行来出入不顺威仪。后还得心时诸比丘言。彼犯重罪波罗夷僧伽婆尸沙偷兰遮。诸比丘问言。难提汝忆犯重罪波罗夷僧伽婆尸沙偷兰遮不。彼即答言。我先癫狂心乱时多犯众罪。行来出入不顺威仪。非我故作是癫狂故耳。诸长老。不须数见难诘。诸比丘故难诘不止。彼比丘作如是念。我当云何。白诸比丘。诸比丘白佛。佛言。听僧与难提比丘不痴毗尼白四羯磨。应如是与。难提比丘。应至僧中偏露右肩脱革屣右膝着地合掌作如是白言。大德僧听。我难提比丘。癫狂心乱时。多犯众罪。行来出入不顺威仪。后还得心。诸比丘问我言。汝忆犯重罪波罗夷僧伽婆尸沙偷兰遮不。我答言。先癫狂心乱时。多犯众罪。行来出入不顺威仪。非我故作。是癫狂心故。诸长老。不须数难诘问我。而诸比丘故难问不止。我今不痴。从僧乞不痴毗尼。愿僧与我不痴毗尼。慈愍故。如是第二第三说。众中应差堪能羯磨者。如上作如是白。大德僧听。此难提比丘。癫狂心乱多犯众罪。言无齐限。出入行来不顺威仪。后还得心。诸比丘语言。汝忆犯重罪波罗夷僧伽婆尸沙偷兰遮不。即答言。我先癫狂时。多犯众罪。言无齐限。出入行来不顺威仪。此是癫狂非是故作。诸长老。莫数难诘我。而诸比丘故难诘不止。此比丘今不痴。从僧乞不痴毗尼。若僧时到僧忍听。与难提比丘不痴毗尼。白如是。大德僧听。此难提比丘。癫狂心乱。多犯众罪。言无齐限。出入行来不顺威仪。后还得心。诸比丘语言。汝忆犯重罪波罗夷僧伽婆尸沙偷兰遮不。即答言。我先癫狂心乱。多犯众罪。出入行来不顺威仪。此是我癫狂心乱。非是故作。诸长老。莫数难诘问我。而诸比丘故难诘不止。此比丘今不痴。从僧乞不痴毗尼。僧今与难提比丘不痴毗尼。谁诸长老忍。僧与难提比丘不痴毗尼者默然。谁不忍者说。是初羯磨。如是第二第三说。僧已忍。与难提比丘不痴毗尼竟。僧忍默然故。是事如是持。自今以去。与诸比丘结不痴毗尼灭诤。应如是说不痴毗尼。尔时世尊在瞻婆城在伽渠池边。时世尊。十五日布萨。白月满时。前后围绕。在众僧前。于露地坐。时阿难。初夜过已从坐起。偏露右肩右膝着地合掌白言。初夜已过。愿世尊说戒。时世尊默然。阿难即还复坐。时阿难。中夜后夜过明相已出。复从坐起偏露右肩右膝着地合掌白佛言。中夜后夜已过。明相已出。众僧坐久。唯愿说戒。佛告阿难众中不清净。欲令如来于不清净众中羯磨说戒。无有是处。时阿难默然复坐。尔时长老目连。作如是念。众中有何等人不清净。如来作如是言。众中不清净。欲令如来于不清净众中羯磨说戒。无有是处。时目连。即自思惟观察众中。以天眼清净见彼比丘坐。去佛不远。非沙门自言是沙门。非净行自言是净行。但有破戒诸恶不净。无有白法邪见覆藏所犯众恶。如空中树。虽外有枝叶而内无实。见已念言。世尊见此比丘故作如是言。欲令如来于不清净众中羯磨说戒者无有是处。时目连从坐起。往彼比丘所语言。汝今可起。世尊知汝见汝。出去灭去。汝不应此中住。时目连捉彼比丘臂牵着门外。还白世尊言。众已清净。愿世尊说戒。佛告目连。不应如是。若于异时亦不应如是。目连。令彼伏罪然后与罪不应不自伏罪而与罪。自今已去。为诸比丘结自言治灭诤。应如是说自言治。尔时世尊在舍卫国。时舍卫诸比丘诤。众僧求觅罪。如法如毗尼如佛所教。尔时佛告诸比丘。应多求觅罪用多人知法者语。自今已去。为诸比丘结用多人语灭诤法。应如是说用多人语。尔时世尊在释翅瘦。有比丘字象力。喜论议共外道论。得切问时。前后言语相违。于僧中问时。亦复如是前后言语相违。在众中故作妄语。时诸外道皆共讥嫌。沙门释子不知惭愧。但作妄语。自言我知正法。如是有何正法。得切问时。前后言语相违。故作妄语。时诸比丘闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责象力释子言。云何与外道论。得切问时。前后言语相违。在众僧中问时。亦前后言语相违耶。诸比丘往佛所。头面礼足以此因缘具白世尊。世尊尔时。以此因缘集比丘僧。呵责象力释子言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何汝与外道论议。得切问时。前后言语相违。在众中问。亦复前后言语相违。故作妄语耶。世尊以无数方便诃责象力已告诸比丘。应与彼比丘作罪处所白四羯磨。应如是与集僧。集僧已为作举。作举已为作忆念。作忆念已与罪。众中应差堪能羯磨者如上作如是白。大德僧听。此象力释子好论议与外道论。得切问时前后言语相违。设于众僧中问。亦前后言语相违。众中故作妄语。若僧时到僧忍听。僧今与象力释子作罪处所羯磨。汝象力。无利不善得。汝得切问时。前后言语相违。设众僧中问时亦复如是。在众中故作妄语。白如是。大德僧听。此象力释子好论议与外道论。得切问时前后言语相违。在众僧中问时亦复如是。在众中故作妄语。今僧与象力释子作罪处所羯磨。汝象力。无利不善得。汝得切问时前后言语相违。在众中问时亦复如是在众中故作妄语。谁诸长老忍。僧与象力释子作罪处所羯磨者默然。谁不忍者说。是初羯磨。第二第三如是说。僧已忍。与象力释子作罪处所羯磨竟。僧忍默然故。是事如是持。自今已去。为诸比丘结罪处所灭诤法。应作如是说结罪处所。尔时世尊在舍卫国。时舍卫诸比丘共诤。诸比丘多犯众戒非沙门法。亦作亦说出入无限。彼诸比丘自作如是念我曹多犯众戒非沙门法。亦作亦说出入无限。若我曹还自共善问此事。或能令此诤事转深重经历年月。不得如法如毗尼如佛所教灭除诤事。令僧不得安乐。时诸比丘白佛。佛言。应灭此诤犹如草覆。自今已去。为诸比丘结如草覆地灭诤法。应如是说如草覆地

尔时世尊在拘睒弥。拘睒弥比丘共比丘诤。比丘共比丘尼诤。比丘尼共比丘诤。比丘尼共比丘尼诤。有阐陀比丘。舍比丘助比丘尼作伴党。时诸比丘闻。中有少欲知足行头陀乐行学戒知惭愧者。嫌责诸比丘已。往世尊所。头面礼足。在一面坐。以此因缘具白世尊。世尊尔时。以此因缘集比丘僧。以无数方便诃责诸比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何拘睒弥比丘共诤。比丘共比丘诤。比丘共比丘尼诤。比丘尼共比丘诤。比丘尼共比丘尼诤。阐陀比丘。舍比丘助比丘尼与作伴党耶。以无数方便呵责已告诸比丘。有四种诤。言诤觅诤犯诤事诤。云何言诤。比丘共比丘诤。言引十八诤事。法非法若毗尼非毗尼乃至说不说。若以如是相共诤言语。遂彼此共斗。是为言诤。云何觅诤。若比丘与比丘觅罪。以三举事破戒破见破威仪见闻疑。作如是相觅罪。共语不妄。求伴势力。安慰其意。若举作忆念。若安此事不安此事。不痴不脱。是为觅诤。云何犯诤。犯七种罪波罗夷僧伽婆尸沙乃至恶说。是为犯诤。云何事诤。言诤中事作。觅诤中事作。犯诤中事作。是为事诤。言诤以何为根。贪恚痴为根。无贪无恚无痴为根。僧为根。界为根。人为根。六诤为根。十八破事为根。是为言诤根。觅诤以何为根。贪恚痴为根。无贪无恚无痴为根。僧为根。界为根。人为根。三举事为根。是为觅诤根。犯诤以何为根。贪恚痴为根。僧为根。界为根。人为根。三举事为根。六犯所起为根。是为犯诤根。事诤以何为根。贪恚痴为根。无贪无恚无痴为根。僧为根。界为根。人为根。是为事诤根。言诤是善不善无记。言诤或善或不善或无记。云何言诤是善。比丘共比丘善心诤言。法非法乃至说不说。作如是相共彼此诤言。是为言诤善。云何言诤不善。若比丘共比丘不善心诤言。法非法乃至说不说。以如是相共诤言诤。以此遂成斗诤。是为言诤不善。云何言诤无记。若比丘以无记心诤言。引十八事法非法乃至说不说。以如此事互共诤言。是为言诤无记。觅诤是善不善无记耶。觅诤或善或不善或无记。云何觅诤是善。是中比丘善心共相伺觅。以三举事破戒破见破威仪见闻疑。内有五法。令此人无犯无垢污清净罪得出。莫令此人有恶名称流布。以如是相觅罪共语。不妄求伴势力安慰其心。作举作忆念安此事不安此事不痴令脱。是为觅诤事善。云何觅诤事不善。若比丘共比丘以不善心觅罪。以三举事破戒破见破威仪见闻疑。内无五法。欲令此人有犯垢秽不清净罪不出。欲令此人不善名流布。以如是相觅罪共语。不妄求伴势力不安慰其心。作举作忆念安此事不安此事痴不脱。是为觅诤事不善。云何觅诤事无记。比丘共比丘无记心觅罪。以三举事破戒破见破威仪见闻疑。以如是相觅罪共语。不妄求伴势力安慰其心。作举作忆念安此事不安此事无痴令脱。是为觅诤事无记。犯诤是善是不善是无记也。犯诤或不善或无记。云何犯诤是不善。若凡夫人学人故犯罪。是为犯诤不善。云何犯诤无记。若凡夫人学人不故犯戒。无著人不故犯戒。是为犯诤无记。事诤是善是不善是无记。事诤或善或不善或无记。云何事诤善。比丘以善心言诤中事作。觅诤中事作。犯诤中事作。是为事诤善。云何事诤不善。以不善心言诤中事作。觅诤中事作。犯诤中事作。是为事诤不善。若以无记心作。是为事诤无记

言　言诤　言诤言　言诤诤言

或有言即是言诤。或有言非言诤。或有言诤即是言。或有言即是诤。或有言非诤。或有诤即是言。或有诤非言。云何有言即是言诤。若比丘共比丘诤言。以十八事法非法乃至说不说。以如是相共诤言。互共斗彼此不和。是为有言即是言诤。云何有言非言诤。若父共儿语。儿共父语。儿共母语。母共儿语。兄共弟语。弟共兄语。妹共姊语。姊共妹语。若复余人共语。是为有言非言诤。云何言诤即是言。若比丘共比丘诤言。以十八事法非法乃至说不说。以如是相共诤言。互共斗彼此不和。是为言诤即是言。云何言即是诤。若比丘共比丘诤言。以十八事法非法乃至说不说。以如是相共诤言。互共斗彼此不和。是为有言即是诤。云何言不诤。儿共父语。父共儿语。儿共母语。母共儿语。弟共兄语。兄共弟语。妹共姊语。姊共妹语。若复与余人共语。是为言而不诤。云何诤即是言。若比丘共比丘诤。以十八事法非法乃至说不说。以如是相共诤言。互共斗彼此不和。是为诤即是言。云何诤而非言除言诤。若余诤事。觅诤犯诤事诤。是为诤而非言。觅觅诤。觅诤觅。觅诤。诤觅(此四句曲解如上言诤四句不异故不复重出此言觅即是觅诤犯诤事诤亦如上)

若一比丘。在一比丘现前好言教语。若摈非法非毗尼非佛所教。彼作如是言。是法是毗尼是佛所教当受行。是如是诤事得灭。是为非法灭诤非法相似现前毗尼。一比丘。为二比丘为三比丘为僧亦如是。二比丘。为一比丘为二比丘为三比丘为僧亦如是。三比丘。为一比丘为二比丘为三比丘为僧亦如是。若僧。为一比丘为二比丘为三比丘为僧亦如是。若一比丘。在一比丘前好言教语。如法如毗尼如佛所教。彼作如是言。此是法是毗尼是佛所教。汝当受是忍可。若作如是诤得灭。是为如法灭诤现前毗尼。是中云何现前法毗尼人。云何法现前。所持法灭诤者是。云何毗尼现前。所持毗尼灭诤者是。云何人现前。言议往返者是。若比丘诤事灭已。若更发起者波逸提。若后来比丘。若新受戒者。谓是初诤。若更发起者波逸提。如是一比丘。为二比丘为三比丘为僧亦如是。二比丘。为一比丘二比丘三比丘为僧亦如是。三比丘。为一比丘二比丘三比丘为僧亦如是。僧为一比丘好言教语。如法如毗尼如佛所教。彼作如是言。是法是毗尼是佛所教。受是忍是。若如是诤事灭。是为如法灭诤现前毗尼。云何现前法毗尼人僧界。云何法现前。所持法灭诤者是。云何毗尼现前。所持毗尼灭诤者是。云何人现前。言义往返者是。云何僧现前。同羯磨和合集一处。不来者嘱授在现前。应呵者不呵者是。云何界现前。在界内羯磨作制限者是。若诤事灭。若更发起者波逸提。若后来比丘新受戒者。谓是初诤。而更发起者波逸提。与欲已后悔者波逸提。僧为二比丘三比丘僧亦如是。尔时阿难。从坐起偏露右肩右膝着地合掌白世尊言。言诤以几灭灭。佛告阿难。言诤以二灭灭。以现前毗尼。用多人语。阿难又问。颇有言诤以一灭灭现前毗尼不用多人语耶。佛告阿难有。问言。何者是。佛言。若一比丘。为一比丘现前好言教语。如法如毗尼如佛所教。彼作如是言。是法是毗尼是佛所教。受是忍是。如是诤事得灭。是为阿难言诤以一灭灭不用多人语。现前义如上。一比丘。为二比丘三比丘僧亦如是。二比丘。为一比丘二比丘三比丘僧亦如是。三比丘。为一比丘二比丘三比丘僧亦如是。僧为一比丘好言教语。如法如毗尼如佛所教。彼作如是言。是法是毗尼是佛所教。受是忍是。若如是诤事灭。是为阿难言诤以一灭灭现前毗尼不用多人语。现前义如上。僧为二比丘三比丘僧亦如是。佛语阿难。彼诤比丘。不忍可僧作如是灭诤。闻异住处有好众僧好上座智慧人。彼诤比丘。以此诤事故。应往彼住处。若在道路。能得如法如毗尼如佛所教灭诤者。是为阿难言诤以一灭灭现前毗尼不用多人语。是中现前义如上。若彼诤比丘在道路。不能得如法如毗尼如佛所教灭诤者。彼诤比丘。应至彼僧中上座有智慧人前作如是言。我此诤事。如是起如实因是起。僧作如是灭。我不忍可。是故来至长老所善哉长老。为我如法如毗尼如佛所教灭此诤事。若长老能为我等灭此诤事。如法如毗尼如佛所教者。我等当于长老前舍此诤事。若长老不能如法如毗尼如佛所教灭此诤事者。我等自在作诤。更令罪深重。不如法如毗尼如佛所教灭诤。诸比丘住止不安乐。彼诤比丘。应如是在僧前舍此诤事。此僧应语彼诤比丘言。长老诤事。若如是起如实如所因起。如彼众僧灭诤。若能如实说者。我等当量宜能灭此诤事不若长老诤事。如是起如实如所因起。如众僧灭诤而不如实说。如是长老此诤事更深重。非法非毗尼非佛所教。诤事不得灭。诸比丘不得安乐住。彼僧应作如是受诤。受已应断决。若彼诤比丘是下座者。应语言小出。我等自共评此事。如法如毗尼如佛所教。若诤比丘是上座者。僧应自避至余处共评断此事。如法如毗尼如佛所教。众僧作如是念。我等若在僧前评此事。恐更有余事起。令彼此善恶言说不了。我等宁可与诸智慧人别集一处共评此事。佛告阿难彼时僧即应作白共评此事。作如是白。大德僧听。若僧时到僧忍听。僧今集诸智慧者共别评断事。白如是。应作如是白已共评断事。若比丘有十法者。应差别评断事。何等十。一持戒具足。二多闻。三若诵二部毗尼极利。四若广解其义。五若善巧言语辞辩了了堪任问答令彼欢喜。六若诤事起能灭。七不爱。八不恚。九不怖。十不痴。有如此十法者。应差共别评断事。彼有十法者。应别住一处共评断此事。断事比丘中。有不诵戒者。不知戒毗尼。便舍正义作非法语。僧应白遣此比丘出。应如是白。大德僧听彼某甲比丘。不诵戒不知戒毗尼。便舍正义作非法语。若僧时到僧忍听。僧今遣此比丘出。白如是。应作如是白已遣出。佛语阿难。彼坐断事比丘中。有诵戒不诵戒毗尼。彼舍正义说少许文。佛告阿难。僧应作白遣此断事比丘出。应如是白大德僧听。彼某甲比丘。诵戒不诵戒毗尼。彼舍正义说少许文。若僧时到僧忍听。僧今遣此比丘出。白如是。白已遣出。若评断事比丘中。有法师在座。彼舍正义。以言辞力强说。佛告阿难。僧应作白遣此比丘出。作如是白。大德僧听。此某甲比丘法师。舍正法义以言辞力强说。若僧时到僧忍听。僧今遣此比丘出。白如是。应作如是白已遣出。若评断事比丘坐中。诵戒诵毗尼。彼顺正义如法说。佛告阿难。僧应如法如毗尼如佛所教佐助此比丘。若彼诤事。彼僧不如法如毗尼如佛所教灭此诤者。今此僧应如法如毗尼如佛所教灭此诤事。若彼僧如法如毗尼如佛所教灭此诤事者。今此僧亦忍可此事。僧即应语彼诤比丘言。若彼僧如法如毗尼如佛所教灭此诤事。我等亦忍可此事如法灭诤。今我等亦当作如是灭诤。若作如是得灭诤者。是为阿难言诤以一灭灭现前毗尼不用多人语。现前义法乃至界亦如上。若诤事如法灭已。后发起者波逸提如上。彼诤比丘不忍可第二僧作如是灭诤。闻彼住处有众多比丘持法持律持摩夷。彼诤比丘。应往彼持法持律持摩夷比丘所。若彼比丘至中道能灭诤事者。是为阿难言诤以一灭灭现前毗尼不用多人语。是中现前者云何现前法毗尼人。僧界如上。如法灭诤已。后更发起者。得波逸提如上。若彼诤比丘。不能中道如法如毗尼如佛所教灭诤事。彼诤比丘。应往彼众多比丘持法持律持摩夷者所作如是言。长老。我此诤事。因如是起如是实因是起。僧作如是灭诤。第二僧亦作如是灭。我不忍可。故来至长老间。善哉长老。能如法如毗尼如佛所教。灭此诤事者。我当于长老间舍此诤事。若长老不能如法如毗尼如佛所教灭此诤事者。我等便自在作诤。更令罪深重。不如法如毗尼如佛所教灭此诤事者。诸比丘住止不安乐。彼诤比丘。应在彼众多比丘前舍此诤事。彼众多比丘。应语此诤比丘言。若长老。此诤事如所起如实如所因起。如第二僧灭诤如实说。说已舍诤。我等当量宜能灭此诤不。若长老。不如实说者。此诤事自在。作罪更深重。不如法如毗尼如佛所教灭诤者。诸比丘住止不安乐阿难。彼众多比丘。应作如是受诤。受诤已决断。若彼诤比丘是下座者。应语言汝小避。我等欲评断事。若是上座者。应自避余处共评断此事。若彼僧不如法如毗尼如佛所教灭诤。第二僧亦不如法如毗尼如佛所教灭此诤事。众多比丘应如法如毗尼如佛所教灭此诤事。若彼僧如法灭诤。第二僧亦如法灭诤。众多比丘亦应忍可此事。应语彼诤比丘言。如彼第二僧灭诤。我等亦忍可。今当作如是灭诤。是为阿难言诤以一灭灭现前。毗尼不用多人语。是中现前者。法毗尼人亦如上。如法灭诤已。后更发起者。得波逸提如上。往二比丘所持法持律持摩夷亦如是。往一比丘所持法乃至持摩夷亦如是

尔时舍卫国比丘诤。时舍卫众僧如法灭诤。彼诤比丘。不忍可僧灭诤事。闻彼住处亦如上。众多比丘亦如上。二比丘一比丘亦如上。彼诤比丘。不忍可舍卫僧灭诤。乃至一比丘。便往至佛所。头面礼足在一面坐。以此因缘具白世尊。世尊即集比丘僧。无数方便呵责彼诤比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何痴人。舍卫僧如法灭诤而不忍可。乃至一比丘灭诤亦不忍可。世尊以无数方便呵责已告诸比丘。应灭此诤用多人语。听行舍罗差行舍罗人白二羯磨。有五法不应差使行舍罗。有爱有恚有怖有痴不知己行不行。有如是五法。不应差使行舍罗。不爱不恚不怖不痴知己行不行。有如是五法。应差行舍罗。众中应如是差堪能羯磨者。如上作如是白。大德僧听。若僧时到僧忍听。僧差某甲比丘行舍罗。白如是。大德僧听。僧今差某甲比丘行舍罗。谁诸长老忍。僧差某甲比丘行舍罗者默然。谁不忍者说。僧已忍。差某甲比丘行舍罗竟。僧忍默然故。是事如是持。有三种行舍罗。一显露二覆藏三就耳语。云何显露。彼诸比丘作如是念。众中非法比丘多。然彼和尚阿阇梨皆如法应显露行舍罗。彼诸比丘作如是念。众中多非法人。而上座智人持法持毗尼持摩夷者皆如法语。应显露行舍罗。诸比丘作如是念。不知此诤事为如法语者多非法语者多。然彼和尚阿阇梨皆如法。彼比丘应显露行舍罗。诸比丘作如是念。不知此诤事为法语多非法语多。然彼上座智人持法持毗尼持摩夷皆如法。说彼比丘应显露行舍罗。彼诸比丘作如是念。此诤事法语人多。即应显露行舍罗。应如是行。应作二种舍罗。一破二完。作舍罗已。应作白。作如是语者捉不破舍罗。作如是语者捉破舍罗。行舍罗已。应别处数。若如法语比丘多者。彼应作白。作如是语者诤事灭。若如法语比丘少者。即应作乱已便起去。应遣信往比丘住处。僧中白言。彼住处非法比丘多。善哉长老。能往至彼若如法语比丘多。诤事灭功德多。此比丘闻应往。若不往如法治。若作如是诤事灭者。是为阿难言诤以二灭灭现前毗尼用多人语是中现前者。法毗尼人界僧义如上。是中云何用多人语。若用多人说。持法持毗尼持摩夷。若如法灭已。后更发起者。波逸提如上。云何覆藏行舍罗。诸比丘作如是念。此诤事如法比丘多。而彼和尚阿阇梨不如法。我等若显露行舍罗。恐诸比丘随和尚阿阇梨捉舍罗。彼比丘应覆藏行舍罗。彼作如是念。此诤事如法比丘多。彼众中有上座标首智人者。持法持毗尼持摩夷而住非法。若我等显露行舍罗者。诸比丘随彼众中上座标首智人住非法者捉舍罗。是比丘应覆藏行舍罗。二句不知亦如上。应如是行舍罗。从二种乃至如法灭诤已。后更发起得波逸提。如上显露行舍罗。云何为耳语行舍罗。彼比丘作如是念。如法比丘多。彼和尚阿阇梨非法说。彼应耳语行舍罗。彼比丘作如是念。此诤事如法比丘多。而彼众中上座智人标首比丘住非法持法持毗尼持摩夷。彼比丘应耳语行舍罗二句不知亦如上。应作二种舍罗。一破二完。应作白。如是语者捉完舍罗。如是语者捉破舍罗。彼行舍罗时。应希坐间容一人身小障翳。彼比丘作耳语。语言。汝和尚同和尚阿阇梨同阿阇梨亲厚知识已捉舍罗。善哉汝亦当捉舍罗。慈愍故。若如法比丘多。诤事得灭得功德多。行舍罗已。在一面数之。从此乃至如法灭诤已。后更发起得波逸提如上。有十不如法捉舍罗。不解捉舍罗。不与善伴共捉舍罗。欲令非法者多捉舍罗。知非法比丘多捉舍罗。欲令众僧破故捉舍罗。知众僧当破故捉舍罗。非法捉舍罗。别众捉舍罗。以小犯故捉舍罗。不如所见故捉舍罗。云何不解捉舍罗。于此诤事不决了。不知是法非法乃至说不说。是为不解捉舍罗。云何不与善伴共捉舍罗。若比丘多闻持法持毗尼持摩夷。不与作伴法非法乃至说不说。是为不与善伴捉舍罗。云何令非法比丘多捉舍罗。彼比丘作如是念。此诤事多有如法比丘。我今当捉非法舍罗。令非法比丘多。是为令非法比丘多捉舍罗。云何知多非法比丘多捉舍罗。彼比丘作如是念。此诤事非法比丘多为非法伴捉舍罗。是为知非法比丘多捉舍罗。云何欲令僧破捉舍罗。彼作如是念。此诤事如法比丘多。我今捉非法舍罗令众僧破。是为欲令众僧破捉舍罗。云何知僧当破捉舍罗。彼比丘知非法比丘多。为非法伴党捉舍罗。是为知僧当破捉舍罗。云何非法捉舍罗。白二白四羯磨。白异羯磨异是为非法捉舍罗。云何别众捉舍罗。同一界羯磨不尽集。应嘱授者不嘱授。在现前应呵者便呵。是为别众捉舍罗。云何以小犯事捉舍罗。或念犯罪或不故犯或发心作如是捉舍罗。是为小犯事捉舍罗。云何不如所见捉舍罗。异见异忍捉舍罗。是为不如所见捉舍罗。是为十种非法捉舍罗。复有十如法捉舍罗。解捉舍罗乃至如所见捉舍罗。是为十如法捉舍罗(此即反上十不如法捉舍罗也)有五种平当人。或有人身不作口作。或有人口不作身作或有人身不作口不作或有人身作口作。或有人不爱不恚不怖不痴。云何有人身不作口作。有人身不现相口说言教。是为有人身不作口作。云何有人口不作身作。有人身现相口不说言教。是为有人口不作身作。云何有人身不作口不作。有人身不现相口不说言教。是为身不作口不作。云何身作口作。有人身现相口说言教。是为身作口作。是中有人。不爱不恚不怖不痴。此人于彼人中。最为尊贵殊胜第一。犹若乳出酪酪出酥酥出醍醐最胜无比。如是不爱不恚不怖不痴。于彼人中。最为尊贵殊胜无比。是为五种平当人

四分律卷第四十七四分律卷第四十八(三分之十二)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    灭诤揵度之二

尔时阿难。从坐起偏袒右肩右膝着地合掌白佛言。觅诤以几灭灭。佛告阿难。觅诤以四灭灭。现前毗尼。忆念毗尼。不痴毗尼。罪处所毗尼。阿难复问。颇有觅诤以二灭灭。不以不痴毗尼罪处所毗尼灭耶。佛告阿难有。又问。何者是。佛告阿难。若比丘不犯重罪波罗夷僧残偷兰遮。诸比丘言犯波罗夷僧残偷兰遮。而诸比丘语言。汝忆犯波罗夷僧残偷兰遮不。彼不忆即答言。我不忆犯波罗夷乃至偷兰遮。长老。莫数难诘问我。而彼比丘故难诘不止。阿难僧应与此比丘忆念毗尼。白四羯磨如上。有三非法与忆念毗尼。若比丘犯重罪波罗夷僧残偷兰遮。诸比丘言。犯重罪波罗夷僧残偷兰遮。彼比丘语言。汝忆犯重罪波罗夷乃至偷兰遮不。答言。我不忆犯。长老。莫数难诘问我。而彼比丘故难诘不止。彼从僧乞忆念毗尼。僧若与作忆念毗尼者非法。若比丘犯重罪波罗夷僧残偷兰遮。诸比丘亦言。犯重罪波罗夷僧残偷兰遮。问言。汝忆犯重罪波罗夷乃至偷兰遮不。答言。我不忆犯重罪波罗夷乃至偷兰遮。我忆犯小罪当如法忏悔。诸长老。莫数难诘问我。而诸比丘故难诘不止。彼从僧乞忆念毗尼。僧若与忆念毗尼者非法。若比丘犯重罪波罗夷僧残偷兰遮。诸比丘亦言。犯重罪波罗夷僧残偷兰遮问言。汝忆犯重罪不。答言。我不忆犯重罪波罗夷僧残偷兰遮。我忆犯小罪已如法忏悔。诸长老。莫数难诘问我。而诸比丘故难诘不止。彼从僧乞忆念毗尼。若僧与忆念毗尼者非法。是为三种与非法忆念毗尼。有三种与如法忆念毗尼(即反上三句是如法与忆念毗尼)有五不如法与忆念毗尼。不现前。不自言。不清净。非法。别众。是为五非法与忆念毗尼。有五如法与忆念毗尼。现前自言清净法和合。是为五如法与忆念毗尼。若如是诤事灭。是为阿难觅诤以二灭灭。现前毗尼忆念毗尼。不用不痴毗尼罪处所。是中云何现前法毗尼人僧界如上是中云何忆念毗尼。彼比丘此罪更不应举不应作忆念。若比丘如法诤事灭已。后更发起者。得波逸提如上阿难复问。颇有觅诤以二灭灭。现前毗尼不痴毗尼。不用忆念毗尼罪处所耶

佛告阿难有。问言。何者是。佛告阿难。是中有比丘。癫狂心乱多犯众罪。后还得心。诸比丘皆言。犯重罪波罗夷僧残偷兰遮。即问言。汝忆犯重罪波罗夷僧残偷兰遮不。彼不忆犯重罪。答言。我不犯重罪波罗夷乃至偷兰遮。我癫狂心乱时多犯众罪。此非故作。是我癫狂故耳。诸长老。莫数难诘问我。而诸比丘故难诘不止彼作如是念。我当云何。白诸比丘。诸比丘白佛。佛言。听僧与此比丘不痴毗尼。白四羯磨如上。有三非法与不痴毗尼。若比丘不痴。而诈作痴。多犯众罪非沙门法。诸比丘言。犯重罪波罗夷僧残偷兰遮。诸比丘即问言。汝忆犯重罪波罗夷乃至偷兰遮不。答言。我痴狂时多犯众罪非沙门法。非是我故作。是痴狂故耳。诸长老。莫数难诘问我。而诸比丘故难诘不止。彼从僧乞不痴毗尼。僧若与不痴毗尼。是为非法。(此是初句。次第二句亦同上。正以言我忆犯众罪如人梦中所作耳。次第三句亦同。正以言我忆犯众罪。如人从高山堕地揽捉少片物。我亦如是)是为三非法与不痴毗尼。有三如法与不痴毗尼。(即反三句是如法)有五非法与不痴毗尼。有五如法与不痴毗尼如上。若如是诤事灭者。是为阿难觅诤以二灭灭。现前毗尼不痴毗尼。不用忆念毗尼罪处所。是中现前如上。云何不痴毗尼。彼比丘此罪。更不应举不应作忆念者是。彼比丘如法诤事灭已。后更发起者。得波逸提如上。阿难又问。颇有觅诤以二灭灭。现前毗尼罪处所。不用忆念毗尼不痴毗尼耶。佛言有。问言。何者是。若比丘好论议。与外道论时得切难。便前后言语相违。若在众僧中问时。亦前后言语相违。众中故妄语。阿难。僧应与此比丘罪处所。白四羯磨如上有三非法与罪处所毗尼。不作举。不作忆念。不作自言。是为三。复有三。无犯。犯不可忏罪。若犯罪已忏。复有三。不举非法别众不作忆念非法别众不作自言非法别众不犯非法别众。犯不可忏罪非法别众。犯罪已忏非法别众。不现前非法别众。是为三非法与罪处所。复有三如法与罪处所(即反上事更不异。故不出是如法也)是为三如法与罪处所。有五非法与罪处所。不现前不作自言不清净非法别众。是为五非法与罪处所。(次有五句如法反上事是更无异故不出)若如是诤事灭。是为觅诤以二灭灭。现前毗尼罪处所。不用忆念毗尼不痴毗尼是中现前义如上。云何罪处所。彼比丘此罪。与作举作忆念者是。彼比丘若诤事如法灭已。后更发起。得波逸提如上。阿难复问犯诤以几灭灭。佛告阿难。犯诤以三灭灭。现前毗尼。自言治。草覆地。阿难复问。颇有犯诤以二灭灭。现前毗尼自言治。不用草覆地耶。佛言有。问言。何者是。佛告阿难。若比丘犯罪。若欲在一比丘前忏。应至一清净比丘所偏露右肩。若上座礼足右膝着地合掌说罪名说罪种作如是言。长老一心念。我某甲比丘犯某甲罪。今从长老忏悔。不敢覆藏。忏悔则安乐。不忏悔不安乐。忆念犯发露知而不覆藏。长老忆我清净戒身具足清净布萨如是第二第三说。彼应语言。自责汝心应生厌离。答言尔。若作如是诤事灭者。是为阿难犯诤以二灭灭。现前毗尼自言治。不用如草覆地。是中现前者。法毗尼如上。人现前者。受忏悔者是也。是中云何自言。说罪名说罪种忏悔者是。云何治。自责汝心生厌离也。若诤事灭已。后更发起者波逸提。除受欲已余者如上。若欲在二比丘边忏悔。应至彼二清净比丘所偏露右肩。若是上座。礼足已右膝着地合掌说罪名说罪种。作如是言。忏法如上。受忏者应先问彼第二比丘。若长老听我受某甲比丘忏者我当受。彼第二比丘应言可尔。若欲在三比丘边忏亦如是。若欲在僧中忏者。应往僧中偏露右肩脱革屣礼僧足已右膝着地合掌白如是言。大德僧听。我某甲比丘犯某甲罪。今从僧忏悔。如是三说。受忏者应作白然后受彼忏。应作如是白。大德僧听。彼某甲比丘犯某甲罪。今从僧忏悔。若僧时到僧忍听。我受某甲比丘忏。白如是。应作如是白已受忏。受忏者应语言。自责汝心。生厌离。彼应答言尔。若作如是诤事灭者。是为阿难犯诤以二灭灭。现前毗尼自言治。不用如草覆地。是中现前者。法毗尼乃至界如上。是中云何自言。说罪名说罪种。忏悔者是。云何治。自责汝心生厌离者是。如法诤事灭已。后更发起者如上。阿难又问。大德。颇有犯诤以二灭灭。现前毗尼草覆地。不用自言治耶。佛言有。又问何者是。答言。若比丘诤事。是中比丘。多犯众罪非沙门法。言无齐限。出入行来不顺威仪。彼作如是念。我等此诤事。多犯众罪非沙门法。言无齐限。出入行来不顺威仪。我等若自共寻究此事。恐令罪深重。不得如法如毗尼如佛所教诤事灭。令诸比丘住止不安乐。阿难。彼一众中有智慧堪能比丘。从座起偏露右肩右膝着地合掌作如是言。诸长老。我等此诤事。多犯众罪非沙门法。言无齐限。出入行来不顺威仪。若我等寻究此事。恐令罪深重。不得如法如毗尼如佛所教诤事灭。令诸比丘住止不安乐。若长老忍者。我今为诸长老作如草覆地忏悔此罪。第二众中亦如是说。阿难。彼诸比丘应作白如草覆地忏。如是白。大德僧听。若僧时到僧忍听。僧今此诤事作草覆地忏悔。白如是。应作如是白已。作如草覆地忏悔。阿难。是一众中有智慧堪能者。从座起偏露右肩右膝着地合掌作如是白。诸长老。我今此诸诤事已所犯罪。除重罪遮不至白衣家羯磨。若诸长老听者。为诸长老及己。作草覆地忏悔。第二众亦应作如是说。若作如是诤事灭者。是为阿难犯诤以二灭灭。现前毗尼草覆地。不用自言治现前义如上。云何草覆地。不称说罪名罪种忏悔者是。若诤事灭已后更发起者如上。阿难又问。事诤以几灭灭。佛言。以一切灭灭。随所犯。尔时长老优波离。从坐起偏露右肩右膝着地白佛言。作自言治。一切如法不。佛语优波离。自言治不一切如法。是中比丘不犯波罗夷。彼不作举不作忆念。自言犯波罗夷。诸比丘即与作波罗夷罪治。优波离。是为非法自言治。优波离。是中比丘不犯波罗夷。彼不作举不作忆念。彼自言犯僧残。诸比丘即与作僧残罪治。优波离。是为非法与自言治。乃至自言犯恶说亦如是。优波离。是中比丘不犯僧残。彼不作举不作忆念。彼比丘自言犯波罗夷。诸比丘与作波罗夷罪治。优波离。是为非法自言治。优波离。是中比丘不犯僧残。诸比丘不作举不作忆念。彼比丘自言犯僧残。诸比丘与作僧残法治。是为非法与自言治。是中比丘不犯僧残。自言犯波逸提乃至恶说亦如是。是中比丘不犯波逸提。自言犯波罗夷乃至恶说亦如是。是中比丘不犯波罗提提舍尼。自言犯波罗夷乃至恶说亦如是。偷兰遮乃至恶说亦如是。突吉罗乃至恶说亦如是。恶说从自言犯波罗夷。还至恶说亦如是。优波离。是中比丘不犯波罗夷。彼作举作忆念。便自言犯波罗夷。诸比丘即与作波罗夷法治。是为非法作自言治。乃至自言犯恶说。七句互作头亦如上。优波离。是中比丘犯波罗夷。彼不作举不作忆念。自言犯僧残。诸比丘即与作僧残治。是为非法自言治。乃至自言犯恶说亦如是。是中比丘犯僧残。彼比丘不作举不作忆念。便自言犯波罗夷。诸比丘即与作波罗夷罪治。是为非法与自言治。是中比丘犯僧残。彼比丘不作举不作忆念。便自言犯波逸提。诸比丘即与作波逸提罪治。是为非法与自言治。乃至自言犯恶说。互作头亦如是。优波离。是中比丘犯波罗夷。彼比丘作举作忆念。便言犯僧残。诸比丘即与作僧残罪治。乃至恶说互作句亦如是。是为优波离非法与自言治。优波离复问。云何如法自言治。佛言。若比丘犯波罗夷。彼不作举不作忆念。彼自言犯波罗夷。诸比丘即为作波罗夷罪治。是为如法与自言治。乃至恶说亦如是。优波离。是中比丘犯波罗夷彼作举作忆念。彼自言犯波罗夷。诸比丘即与作波罗夷治。是为如法与自言治。乃至恶说亦如是。优波离。是为如法与自言治。时有比丘。语余比丘言。我犯不净行欲休道。彼比丘语言。宜知是时。彼比丘去。优波离不远经行。优波离闻。至彼比丘所问言。何所论说彼言。我犯不净行欲休道。问言汝谁边犯。答言与故二俱。问言故二在何处。答言在忧禅国。问言汝往彼耶。答言不往。彼来耶。答言不来。问言汝云何犯。答言我于梦中犯。优波离言。汝去乃至不犯突吉罗。(灭诤揵度具足竟)

    比丘尼揵度第十七

尔时世尊在释翅瘦尼拘律园。时摩诃波阇波提。与五百舍夷女人俱。诣世尊所。头面礼足却住一面。白佛言。善哉世尊愿听女人于佛法中得出家为道。佛言。且止瞿昙弥。莫作是言。欲令女人出家为道。何以故。瞿昙弥。若女人于佛法中出家为道。令佛法不久。尔时摩诃波阇波提。闻世尊教已。前礼佛足绕已而去。尔时世尊从释翅瘦。与千二百五十弟子人间游行。往拘萨罗国。从拘萨罗还至舍卫国只桓精舍。时摩诃波阇波提。闻佛在只桓精舍。与五百舍夷女人俱共剃发被袈裟。往舍卫国只桓精舍。在门外立步涉破脚尘土坌身涕泣流泪

尔时阿难见已即往问言。瞿昙弥何故与舍夷五百女人剃发被袈裟步涉破脚尘土坌身在此涕泣流泪而立耶。彼即答言。我等女人。于佛法中不得出家受大戒阿难语言。且止。我为汝往佛所求请。尔时阿难即至世尊所。头面礼足却住一面。白佛言。善哉世尊。愿听女人在佛法中出家受大戒。佛告阿难。且止。莫欲令女人于佛法中出家受大戒。何以故。若女人在佛法中出家受大戒。则令佛法不久。譬如阿难有长者家男少女多则知其家衰微。如是阿难。若女人在佛法中出家受大戒。则令佛法不久。又如好稻田而被霜雹即时破坏。如是阿难。若女人在佛法中出家受大戒。即令佛法不久。阿难白佛言。摩诃波阇波提。于佛有大恩。佛母命过。乳养世尊长大。佛语阿难。如是如是。于我有大恩。我母命过。乳养令我长大。我亦于摩诃波阇波提有大恩。若人因他得知佛法僧此恩难报。非衣食床卧具医药所能报恩。我出世令摩诃波阇波提知佛法僧亦如是。佛告阿难。若有人因他信佛法僧此恩难报。非衣食床卧具医药所能报恩。我出世令摩诃波阇波提信乐佛法僧亦如是。佛语阿难。若有人因他得归依佛法僧。受持五戒。知苦知集知尽知道。于苦集尽道无有狐疑。若得须陀洹果断诸恶趣。得决定入正道。七返生死便尽苦际。阿难如是人恩难可报。非衣食床卧具医药所能报恩。我出世令摩诃波阇波提受三自归。乃至决定得入正道亦如是。阿难白佛。女人于佛法中出家受戒。可得须陀洹果乃至阿罗汉果不。佛告阿难可得。阿难白佛。若女人于佛法中出家受大戒。得须陀洹果乃至阿罗汉果者。愿佛听出家受大戒。佛告阿难。今为女人制八尽形寿不可过法。若能行者即是受戒。何等八。虽百岁比丘尼见新受戒比丘。应起迎逆礼拜与敷净座请令坐。如此法应尊重恭敬赞叹。尽形寿不得过。阿难。比丘尼不应骂詈比丘呵责。不应诽谤言破戒破见破威仪。此法应尊重恭敬赞叹。尽形寿不得过。阿难。比丘尼不应为比丘作举作忆念作自言。不应遮他觅罪遮说戒遮自恣。比丘尼不应呵比丘。比丘应呵比丘尼。此法应尊重恭敬赞叹。尽形寿不得过。式叉摩那学戒已。从比丘僧乞受大戒。此法应尊重恭敬赞叹。尽形寿不得过。比丘尼犯僧残罪。应在二部僧中半月行摩那埵。此法应尊重恭敬赞叹。尽形寿不得过。比丘尼半月从僧乞教授。此法应尊重恭敬赞叹。尽形寿不得过。比丘尼不应在无比丘处夏安居。此法应尊重恭敬赞叹。尽形寿不得过。比丘尼僧安居竟。应比丘僧中求三事自恣见闻疑。此法应尊重恭敬赞叹。尽形寿不得过。如是阿难。我今说此八不可过法。若女人能行者即是受戒。譬如有人于大水上安桥梁而渡。如是阿难。我今为女人说此八不可过法。若能行者即是受戒。尔时阿难闻世尊教已。即往摩诃波阇波提所语言。女人得在佛法中出家受大戒。世尊为女人制八不可过法。若能行者即是受戒。即为说八事如上。摩诃波阇波提言。若世尊为女人说此八不可过法我及五百舍夷女人当共顶受。阿难。譬如男子女人年少净洁庄严。若有人与洗沐头已止于堂上。持优钵罗华鬘阿希物多华鬘瞻婆华鬘苏曼那华鬘婆师华鬘授与彼。彼即受之系置头上。如是阿难。世尊为女人说八不可过法。我及五百舍夷女人当共顶受。时阿难即往世尊所。头面礼足已却住一面白佛言。世尊。为女人说八不可过法。摩诃波阇波提等闻已顶受。譬如男子女人年少净洁庄严。若有人洗沐头已止于堂上。持诸华鬘授与彼。彼即两手受之系置头上。如是阿难。摩诃波阇波提及五百女人得受戒。佛告阿难。若女人不于佛法出家者。佛法当得久住五百岁。阿难闻之不乐。心怀悔恨忧恼涕泣流泪。前礼佛足绕已而去。时有余女人欲受戒者。彼比丘尼将往佛所。中道遇贼。贼即将毁辱戏弄。诸比丘尼语诸比丘。诸比丘白佛。佛言。自今已去。听彼比丘尼即与出家受大戒。应如是与出家。若欲在比丘尼寺内剃发者应白僧。若一一语令知然后剃发。应作如是白。大姊僧听。此某甲欲从某甲求剃发。若僧时到僧忍听。为某甲剃发。白如是。应作如是白已为剃发。若欲在比丘尼寺内出家者。若白僧若一一语令知。应作如是白。大姊僧听。此某甲从某甲求出家。若僧时到僧忍听。与某甲出家。白如是。应作如是白已与出家。应作如是出家。教出家者与着袈裟已。右膝着地合掌。教作如是言。我阿姨某甲。归依佛法僧。我今随佛出家。和尚某甲。如来无所著等正觉是我世尊。第二第三亦如是说。我阿姨某甲。归依佛法僧竟。我今随佛出家已。和尚某甲。如来无所著等正觉是我世尊。如是第二第三说已应授戒。尽形寿不杀生。是沙弥尼戒。若能持者答言能。尽形寿不得偷盗。是沙弥尼戒。若能持者答言能。尽形寿不得淫。是沙弥尼戒。若能持者答言能。尽形寿不得妄语。是沙弥尼戒。若能持者答言能。尽形寿不得饮酒。是沙弥尼戒。若能持者答言能。尽形寿不得着华鬘香油涂身。是沙弥尼戒。若能持者答言能。尽形寿不得歌舞倡伎亦不得往观。是沙弥尼戒。若能持者答言能。尽形寿不得高广大床上坐。是沙弥尼戒。若能持者答言能。尽形寿不得非时食。是沙弥尼戒。若能持者答言能。尽形寿不得捉持生像金银宝物。是沙弥尼戒。若能持者答言能。如是沙弥尼十戒。尽形寿不应犯。听童女十八者二年中学戒年满二十比丘尼僧中受大戒。若年十岁曾出嫡者。听二年学戒满十二与受戒应如是与二岁学戒沙弥尼。应往比丘尼僧中偏露右肩脱革屣礼比丘尼僧足。已右膝着地合掌白如是言。大姊僧听。我某甲沙弥尼。从僧乞二岁学戒。和尚尼某甲愿僧慈愍故。与我二岁学戒。如是第二第三说。应将沙弥尼往离闻处着见处已。众中应差堪能作羯磨者。如上应作白。大姊僧听。此某甲沙弥尼。今从僧乞二岁学戒和尚尼某甲。若僧时到僧忍听。与某甲沙弥尼二岁学戒。和尚尼某甲。白如是。大姊僧听。此某甲沙弥尼。今从僧乞二岁学戒。和尚尼某甲。僧今与某甲沙弥尼二岁学戒。和尚尼某甲。谁诸大姊忍。僧与沙弥尼某甲二岁学戒。和尚尼某甲者默然。谁不忍者说。是初羯磨。如是第二第三说。僧已忍。与某甲沙弥尼二岁学戒。和尚尼某甲竟。僧忍默然故。是事如是持。应如是与六法。某甲谛听。如来无所著等正觉说六法。不得犯不净行行淫欲法。若式叉摩那行淫欲法。非式叉摩那。非释种女。与染污心男子共身相摩触犯戒。应更与戒。是中尽形寿不得犯。若能持者答言能。不得偷盗乃至草叶。若式叉摩那取人五钱若过五钱。若自取教人取。若自斫教人斫。若自破教人破。若烧若埋若坏色。非式叉摩那非释种女。若取减五钱犯戒。应更与戒。是中尽形寿不得犯。若能者答言能。不得故断众生命乃至蚁子。若式叉摩那故自手断人命。求刀授与。教死劝死赞死。若与人非药。若堕人胎。厌祷咒术。自作教人作。非式叉摩那。非释种女。若断畜生不能变化者命犯戒。应更与戒。是中尽形寿不得犯。若能者答言能。不得妄语乃至戏笑。若式叉摩那不真实无所有。自称言得上人法。言得禅得解脱得定得正受。得须陀洹果乃至阿罗汉果。天来龙来鬼神来供养我。此非式叉摩那非释种女。若于众中故作妄语犯戒。应更与戒。是中尽形寿不得犯。若能者答言能。不得非时食。若式叉摩那非时食犯戒。应更与戒。是中尽形寿不得犯。若能者答言能。不得饮酒。若式叉摩那饮酒犯戒应更与戒。是中尽形寿不得犯。若能者答言能。式叉摩那于一切比丘尼戒中应学。除为比丘尼过食自取食食。应求和尚作如是言。大姊我某甲。今求阿姨为和尚。愿阿姨为我作和尚。我依阿姨故得受大戒。如是第二第三说。和尚应答言可尔。若式叉摩那学戒已。若年满二十若满十二应与受大戒。白四羯磨应如是与戒。将受戒人离闻处着见处。是中戒师应差教授师。大姊僧听。此某甲从和尚尼某甲求受大戒。若僧时到僧忍听。某甲为教授师。白如是。教授者应至受戒人所语言。汝此安陀会郁多罗僧僧伽梨。此僧竭支覆肩衣。此是钵。此是汝衣钵不。谛听。今是真诚时。我今问汝。有便言有。无当言无。汝字何等。和尚字谁。年满二十不。衣钵具不。父母若夫主为听汝不。不负人债不。非婢不。是女人不。女人有如是诸病。癞白癞痈疽干疽癫狂二根二道合道小大小便常漏大小便涕唾常出。汝有如是诸病不。若答言无。应语言。如我向者所问。僧中亦当如是问汝。汝亦当作如是答。彼教授师问已。应还至僧中。如常威仪至舒手及比丘尼处立。应作白。大姊僧听。此某甲从和尚尼某甲求受大戒。若僧时到僧忍听。我已教授竟听使来。白如是。彼应语言来。来已应为捉钵教礼比丘尼僧足。在戒师前胡跪合掌白如是言。大姊僧听。我某甲从和尚尼某甲求受大戒。我某甲今从僧乞受大戒。和尚尼某甲。众僧拔济我。慈愍故。如是第二第三说。是中戒师应作白。大姊僧听。此某甲从和尚尼某甲求受大戒。此某甲今从僧乞受大戒。和尚尼某甲。若僧时到僧忍听。我问诸难事。白如是。汝谛听。今是真诚时。实语时。我今问汝。有当言有。无当言无。汝字何等。和尚字谁。年满二十不。衣钵具不。父母若夫主听汝不。汝非负人债不。汝非婢不。汝是女人不。女人有如是诸病。癞白癞痈疽干痟癫狂二根二道合道小大小便常漏大小便涕唾常出。汝有如是诸病不。答言无。应作白。大姊僧听。此某甲从和尚尼某甲求受大戒。此某甲今从僧乞受大戒。和尚尼某甲。某甲所说清净。无诸难事。年满二十衣钵具足。若僧时到僧忍听。为某甲受大戒。和尚尼某甲。白如是。大姊僧听。此某甲从和尚尼某甲求受大戒。此某甲今从众僧乞受大戒。和尚尼某甲。某甲所说清净。无诸难事。年满二十衣钵具足。僧今授某甲大戒。和尚尼某甲。谁诸大姊忍。僧授某甲大戒和尚尼某甲者默然。谁不忍者说。是初羯磨竟。第二第三亦如是说。僧已忍。与某甲受大戒竟。和尚尼某甲。僧忍默然故。是事如是持。彼受戒者。与比丘尼僧俱。至比丘僧中。礼僧足已。右膝着地合掌。作如是言。大德僧听。我某甲从和尚尼某甲求受大戒。我某甲今从僧乞受大戒。和尚尼某甲。愿僧拔济我。慈愍故。如是第二第三说。(此中戒师应问如上问法)问已应问言。汝学戒未。汝清净不。若答言。已学戒清净。应问余比丘尼。已学戒未。清净不。若答言。已学戒清净。即应作白。大德僧听。此某甲从和尚尼某甲求受大戒。此某甲今从僧乞受大戒。和尚尼某甲。某甲所说清净。无诸难事。年岁已满。衣钵具足。已学戒清净。若僧时到僧忍听。僧今为某甲受大戒。和尚尼某甲。白如是。大德僧听。此某甲从和尚尼某甲求受大戒。此某甲今从僧乞受大戒。和尚尼某甲。某甲所说清净。无诸难事。年岁已满。衣钵具足。已学戒清净。僧今为某甲受大戒。和尚尼某甲。谁诸长老忍。僧与某甲受大戒。和尚尼某甲者默然。谁不忍者说。是初羯磨。第二第三亦如是说。僧已忍。为某甲受大戒竟。和尚尼某甲僧忍默然故。是事如是持。善女人谛听。如来无所著等正觉说八波罗夷法。若比丘尼犯者。非比丘尼非释种女。不得作不净行行淫欲法。若比丘尼作不净行行淫欲法。乃至共畜生。非比丘尼非释种女。汝是中尽形寿不得犯。能持不。答言能。不得偷盗乃至草叶。若比丘尼取人五钱若过五钱。若自取教人取。若自斫教人斫。若自破教人破。若烧若埋若坏色者。非比丘尼非释种女。是中尽形寿不得犯。能持不。答言能。不得断众生命乃至蚁子。若比丘尼自手断人命。持刀授与人。教死赞死劝死。与人非药。若堕胎厌祷咒术。若自作方便教人作。彼非比丘尼非释种女。是中尽形寿不得犯。能持不。答言能。不得作妄语乃至戏笑。若比丘尼不真实非己有。自称言得上人法。得禅得解脱三昧正受。得须陀洹果乃至阿罗汉果。天来龙来鬼神来供养我。彼非比丘尼非释种女。是中尽形寿不得犯。能持不。答言能。不得身相触乃至共畜生。若比丘尼染污心。与染污心男子身相触。腋已下膝已上。若摩若捺。逆摩顺摩。若牵若推。若举若下。若捉若急捺。彼非比丘尼非释种女。是中尽形寿不得犯。能持不。答言能。不得犯八事乃至共畜生。若比丘尼有染污心。受染污心男子捉手捉衣至屏处住。若共立屏处语若共行。若身相近若共期。犯此八事。彼非比丘尼非释种女。是中尽形寿不得犯。能持不。答言能。不应覆藏他重罪乃至突吉罗恶说。若比丘尼知比丘尼犯波罗夷。不自举亦不白僧不语人令知。后于异时。此比丘尼。若休道若灭摈。若遮不共僧事。若入外道。彼作如是言。我先知此人犯如是如是罪。彼非比丘尼非释种女。覆藏他重罪故。是中尽形寿不得犯。能持不。答言能。不得随被举比丘语乃至沙弥。若比丘尼。知比丘为僧所举。如法如毗尼如佛所教。犯威仪未忏悔不作共住。便随顺彼比丘尼。诸比丘尼。谏此比丘尼言。大姊。彼比丘为僧所举。如法如毗尼如佛所教。犯威仪未忏悔。不作共住。莫随顺彼比丘语。诸比丘尼。谏此比丘尼时坚持不舍。诸比丘尼应乃至三谏。舍此事故。乃至三谏舍者善。不舍者。非比丘尼非释种女。犯随举。是中尽形寿不得犯。能持不。答言能。善女人谛听。如来无所著等正觉说四依法。比丘尼依此出家受大戒。是比丘尼法。是中尽形寿能持不。答言能。依粪扫衣出家受大戒。是比丘尼法。是中尽形寿能持不。答言能。若得长利檀越施衣割截衣应受。依乞食出家受大戒。是比丘尼法。是中尽形寿能持不。答言能。若得长利若僧差食若檀越送食月八日食十五日食月初日食若众僧常食檀越请食应受。依树下坐出家受大戒。是比丘尼法。是中尽形寿能持不。答言能。若得长利别房尖头屋小房石室两房一户应受。依腐烂药出家受大戒。是比丘尼法。是中尽形寿能持不。答言能。若得长利酥油生酥蜜石蜜应受。汝已受戒竟。白四羯磨如法成就得处所。和尚如法。阿阇梨如法。二部僧具足。当善受教法。应劝化作福治塔供养佛法僧。和尚阿阇梨一切如法教敕不得违逆。应学问诵经勤求方便于佛法中得须陀洹果斯陀含果阿那含果阿罗汉果。汝始发心出家。功不唐捐果报不断。余所未知。当问和尚阿阇梨。令受戒人在前而去

尔时白四羯磨受大戒者举舍夷拘梨诸比丘尼。世尊有如是言。受大戒应白四羯磨。我曹得戒。汝等不得戒。时摩诃波阇波提比丘尼闻之心疑。诸比丘白佛。佛言。摩诃波阇波提比丘尼及舍夷诸比丘尼亦得戒。尔时有立乞戒者。有白衣见即言。在此中。立者欲求男子。诸比丘白佛。佛言。不应立乞戒。应长跪乞戒。时有蹲乞戒。即倒地形露。羞惭不能乞戒。诸比丘白佛。佛言。余比丘尼应代为白时舍夷拘梨诸比丘尼将欲受大戒者诣僧伽蓝道路遇贼。毁犯比丘尼。诸比丘白佛。佛言。听遣使为受戒。听一比丘尼清净无难者僧作白二羯磨差作使。众中应差堪能羯磨者如上作如是白。大姊僧听。若僧时到僧忍听。今僧差某甲比丘尼作使为某甲比丘尼从比丘僧乞受大戒白如是。大姊僧听。僧今差某甲比丘尼作使。为某甲比丘尼从比丘僧乞受大戒。谁诸大姊忍僧差某甲比丘尼作使为某甲比丘尼从比丘僧中乞受大戒者默然。谁不忍者说。僧已忍。差某甲比丘尼作使竟。僧忍默然故。是事如是持。独行无护。应差二三比丘尼共去。受使比丘尼。应至比丘僧中礼僧足右膝着地合掌作如是白。大德僧听。此某甲比丘尼。从某甲求受大戒。此某甲今从僧乞受大戒。和尚尼某甲愿僧拔济我。慈愍故。如是第二第三说。比丘僧应问。彼字何等。和尚尼是谁。已学戒未。清净不。若答言已学戒清净者。复应问伴比丘尼。已学戒清净未耶。若答言已学戒清净者。众中应差堪能作羯磨者。如上应作白。大德僧听。此某甲比丘尼。从和尚尼某甲求受大戒。此某甲从僧乞受大戒。和尚尼某甲。某甲已学戒清净年岁已满衣钵具足。若僧时到僧忍听。僧与某甲受大戒。和尚尼某甲。白如是。大德僧听。此某甲从和尚尼某甲求受大戒。此某甲今从僧乞受大戒。和尚尼某甲。某甲已学戒清净年岁已满衣钵具足。僧今与某甲受大戒。和尚尼某甲。谁诸长老忍。僧与某甲受大戒和尚尼某甲者默然。谁不忍者说。是初羯磨。第二第三亦如是说。僧已忍。与某甲受大戒和尚尼某甲竟。僧忍默然故。是事如是持。彼使应还比丘尼寺内语言。大妹。汝已受大戒竟。世尊有如是教。听遣使受戒。彼便以小小颜貌遣使受戒。佛言。不应以小小颜貌便遣使受戒。彼授常血出者大戒。血污身污卧具。佛言。不应授血出者大戒。世尊有如是教。不应授血出者大戒。彼便授月水不出者大戒。彼放逸情多。诸比丘白佛。佛言。不应授月水不出者大戒。彼授无乳者大戒。佛言。不应授无乳者大戒。彼授一乳者大戒。佛言。不应授一乳者大戒。彼授二道烂坏者大戒。佛言。不应授二道烂坏者大戒。彼授二道烂臭者大戒。佛言。不应授二道烂臭者大戒。彼授二根者大戒。佛言。不应授二根者大戒。时诸比丘聚一处共诵法毗尼。诸比丘尼作如是念。我等亦当应诵法毗尼不。佛言应诵。不知谁间受诵。佛言。应在比丘间受诵。诸比丘作如是念。我等得与比丘尼诵偈句不。佛言听诵。在前教彼羞惭。佛言听在比丘背后敷座诵。若十种衣中一一衣听作障。时六群比丘尼。以小小因缘嗔恚不喜舍佛法僧言。不独有沙门释子种可修梵行。更有余沙门婆罗门。我今亦可于彼修梵行。诸比丘白佛。佛言。若比丘尼嗔恚舍戒。不成舍戒。时六群比丘尼作蛊道教他作。佛言不应尔。六群比丘为六群比丘尼作羯磨。彼比丘尼随顺言教不敢违逆。乞解羯磨。彼不肯解。时诸居士见已作如是言。彼不随意故便作如是语。诸比丘白佛。佛言。比丘不应与比丘尼作羯磨。时诸比丘尼与作羯磨。佛言。听比丘尼与比丘尼作羯磨。若不知者。听比丘边诵羯磨已然后作羯磨。尔时有比丘欲休道。摩诃波阇波提比丘尼知疑不敢与说法呵。世尊有如是教。比丘尼不得呵比丘。时摩诃波阇波提比丘尼。往世尊所头面礼足却住一面白佛言。比丘尼一切不得呵比丘耶。佛言。比丘尼不一切不得呵比丘比丘尼。不应骂比丘不得呵责比丘。不应诽谤若破见破戒破威仪。不应如是呵。瞿昙弥。若教持增上戒增上心增上智学问诵经。如是事应呵。时诸比丘尼发长。佛言听剃。若自剃时。有年少剃发师。为年少比丘尼剃发。觉细滑欲意起。欲犯比丘尼。比丘尼便高声言。莫尔莫尔。余比丘尼闻。问言。何故高声莫尔莫尔耶。彼即具为说之。诸比丘白佛。佛言。剃发时听共伴。若俱有欲意者不应令剃彼使男子除鼻中毛。佛言。不应令男子除鼻中毛。彼令男子剪爪。佛言。不应令男子剪爪。时比丘尼在白衣家内。有比丘来乞食。彼比丘尼不敢语。何以故。恐比丘谓是比丘尼教化食。诸比丘白佛。佛言。听语主人令知。但莫赞叹。时有比丘尼在白衣家内。有比丘来不起白佛。佛言应起。若比丘尼一坐食。若作余食法不食若病若足食已。听作如是语。大德。我有如是因缘故不起。时有比丘尼白衣家。不问比丘便坐诸比丘白佛。佛言比丘尼在白衣家。不应不问比丘便坐。尔时六群比丘。清旦着衣持钵至白衣家。白衣家内有常教化比丘尼彼见比丘来便起问言。大德我坐耶。比丘言莫坐。彼比丘尼习乐不堪久立。即便倒地得病。诸比丘白佛。佛言。应相望前人可坐便坐。时诸比丘尼。共比丘在道行在前行。或并语并行。或在前或在后。或反抄衣。或缠颈。或覆头。或通肩披衣。或着革屣。诸比丘白佛。佛言不应尔。应偏露右肩脱革屣在比丘后。时诸比丘尼有佛法僧事。有病比丘尼所须事不敢在前去。佛言。听白比丘已便去。彼有命难有梵行难畏慎不敢不问便去。佛言。若有如是难事。若问若不问听去。时有比丘尼在道行。见比丘不避道。佛言应避道。时有比丘尼在道行。见有比丘避道。天雨脚跌倒地得病。诸比丘白佛。佛言。有如是因缘。比丘尼应小曲身合掌言。大德恕我道迮。尔时有檀越请二部僧。先与比丘尼食。后与比丘食。白佛。佛言。不应先与比丘尼僧食。应先与比丘僧。然后与比丘尼僧。尔时有檀越请二部僧。彼如是念。佛有教。应先与比丘僧食然后与比丘尼僧食。彼便先与比丘僧食竟。日时已过。白佛。佛言。若时欲过应一时与。尔时有居士。请比丘尼僧明日与食。彼于夜半办具种种肥美食已晨旦往白时到。时诸比丘尼。清旦着衣持钵往诣其家。彼此相问年岁大小顷。日时便过。诸比丘白佛。佛言。若时过。听上座八比丘尼次第坐余者随坐。时诸比丘尼。来至比丘僧伽蓝中。佛言。听与床座。比丘尼月水出。污贮绳床木床卧具起去。诸比丘白佛。佛言。比丘尼不应在贮绳床木床上座。彼僧伽蓝中求教授。或受请或听法。无坐处。佛言。听若石上坐。若在墼上坐。若在杌木头上坐。若草上树叶上坐。若梁上坐。比丘尼不忍苦遂便得病。佛言。应语比丘尼言。若能爱护坐具者。便与坐

四分律卷第四十八四分律卷第四十九(三分之十三)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    比丘尼揵度之下

尔时世尊在波罗奈。时世谷贵人民饥饿乞求难得。诸比丘尼受食已故有余食。诸比丘尼作如是念。我等此食得与比丘不。佛言得与。复念得为比丘授食不。佛言得授。我等宿食与比丘为净不。佛言净。时诸比丘。受食已有余食。念言。我等此食得与比丘尼不。佛言得与。得为比丘尼授食不。佛言得授与。时有宿食。念言。与比丘尼净不。佛言净。尔时比丘尼。在阿练若处住。后异时阿练若处有事起。诸比丘白佛。佛言。比丘尼不应在阿练若处住。时有比丘尼在白衣家内住。见他夫主共妇呜口扪摸身体捉捺乳。年少比丘尼见已。便生厌离佛法心。诸比丘尼白诸比丘。诸比丘白佛。佛言。听为比丘尼别作住处。彼比丘尼便在别住处作技教他作。佛言。比丘尼不应在住处作技。比丘尼在别住处酤酒。佛言。不应在别住处酤酒。彼比丘尼安淫女在住处。佛言不应尔。彼为具香华庄身之具。佛言不应尔。时六群比丘尼。在巷陌四衢道头市中粪扫聚边立住。诸居士见皆共讥嫌呵骂言。此比丘尼。无有惭愧无有净行。外自称言。我知正法。如是何有正法。在如是处立住。如似淫女。诸比丘白佛。佛言。比丘尼不应在如是处立住。时六群比丘尼。以牙骨揩摩身作光泽。比丘白佛。佛言不应尔。六群比丘尼。以细末药揩摩身光泽。佛言不应尔。彼摩身毛令卷。佛言不应尔。彼剪身毛。佛言不应尔。彼比丘尼持衣缠腰欲令细好。佛言不应尔。彼比丘尼着女人衣。佛言不应着。彼比丘尼着男子衣。佛言不应着。听比丘尼着比丘尼衣。比丘尼以多衣缠体欲令广好。佛言不应尔。彼不好着衣欲令身现。佛言不应尔。彼腰带头作鸟耳。佛言不应尔。彼作蔓陀罗腰带。佛言不应尔。彼畜鞞(语卑反音)楼腰带。佛言不应畜。彼畜娑腰带。佛言不应畜。彼散线带系腰。佛言。听比丘尼编织作带绕腰一周。若圆织者听再周。比丘尼至女人浴处浴。时有贼女淫女。语比丘尼言。汝等年少腋下始有毛。何得便修梵行。汝今可及时行欲乐。后悔何及。老时可修梵行。如是始终无失。时年少比丘尼闻。便心生厌离不乐佛法。诸比丘白佛。佛言比丘尼不应在女人浴处浴。彼比丘尼在白衣男子边浴。诸居士见皆共讥嫌言。此比丘尼。无有惭愧不修梵行。自称。我知正法云何在白衣男子边浴。如贼女淫女无异。如是何有正法。诸比丘白佛。佛言。比丘尼不应在白衣男子边浴。时有妇女夫出行不在。于余人边得娠。彼自堕胎已。往语常教化比丘尼言。我夫行不在。于余人边得娠。我已堕汝可为我弃之。答言可尔。彼比丘尼。即以一钵盛。一钵覆上。着络囊中。持在道行。时舍卫长者。常作如是愿若不先与出家人食我终不食。要先与然后食。彼长者清旦有事欲往余处。即遣人语言。汝往道路街巷见出家人将来。时使人受教已。即往出外求觅。见比丘尼语言。阿姨来与汝食。比丘尼言。止止便为供养我已彼言不尔。但来我当与食。比丘尼言。止止不须。彼使即强将比丘尼至家内。家内使人言。过钵来与汝食。彼比丘尼言。止止便为供养已。复言出钵。当与汝食。彼复言不须即强夺取钵见钵中有新堕胎。长者见已讥嫌言。比丘尼不知惭愧不修梵行。外自称言。我知正法。如是何有正法。自堕胎而弃之。如似贼女淫女无异。诸比丘白佛。佛言。白衣家有死者。比丘尼不应为弃。若比丘尼在村内。见乞食比丘。应出钵示之。时有白衣病来至比丘尼住处须瞻视白佛。佛言。听作方便遣之。若是信乐赞叹佛法僧者。随比丘尼能可作者使瞻视。彼后命过。诸比丘尼畏慎不敢弃白佛。佛言。听为住处净故弃之。尔时王波斯匿。边国反叛人民散乱。时六群比丘尼。在彼有疑恐怖处人间游行。时诸贼伴见已作如是言。此比丘尼。是王波斯匿所敬爱。我等宁可妻弄之。时诸居士见已皆共讥嫌。比丘尼无有惭愧。外自称言。我知正法。如是何有正法。云何乃在有疑恐怖处人间游行。如似贼女淫女无异。诸比丘白佛。佛言。比丘尼不应在边国有疑恐怖处人间游行。尔时比丘尼有阿兰若住处。比丘有聚落住处。欲共贸易白佛。佛言听贸易。时比丘尼有阿兰若住处。居士有聚落间住处。欲共贸易白佛。佛言。听令净人贸易。尔时有二居士诤住处。彼一居士。布施比丘尼僧。尼僧即受。彼一居士即讥嫌言。此比丘尼不知惭愧多受无厌。外自称言。我知正法。如今何有正法。他共诤住处。而便受之。施主虽无厌而受者当知足。诸比丘白佛。佛言。共诤住处不应受。尔时摩诃波阇波提比丘尼。王园中有比丘尼住处。欲于中夏安居。畏慎不敢。世尊有教比丘尼不应在阿兰若处住。然王园中比丘尼住处牢固。诸比丘白佛。佛言。除王园中比丘尼住处余阿兰若处不应住。时有比丘尼。不往教授处。白佛。佛言应往。时有比丘尼。有佛法僧事。有病比丘尼所须。白佛。佛言听与欲去。时迦留陀夷。骂打比丘尼。若唾若华掷水洒。若说粗语诡语劝喻。骂者。令汝道破坏腐烂烧与驴通。打者若以手若杖若石。粗语者。说二道若好若恶。诡语者。若男子净洗浴。以好香涂身。梳治须发。着好华鬘璎珞严身。持孔雀毛盖。岂更有余事胜此者也。若女人亦如是。劝喻者。语言大姊。汝尚年少。腋下始有毛。何须便尔自毁修梵行为。不如及时五欲自乐。须待老时乃修梵行。时年少比丘尼。便生厌离心不乐佛法。时诸比丘尼闻。有少欲知足行头陀乐学戒知惭愧者。嫌责迦留陀夷言。云何骂打比丘尼。乃至诡语劝喻耶。时诸比丘尼白诸比丘。诸比丘白佛。佛尔时集比丘僧。以无数方便呵责迦留陀夷。云何呵骂打比丘尼。乃至诡言劝喻。时世尊无数方便呵责已告诸比丘。听比丘尼僧为迦留陀夷作不为礼白二羯磨。应如是作。众中应差堪能作羯磨者。如上作如是白。大姊僧听。此迦留陀夷。骂打比丘尼。乃至诡语劝喻。若僧时到僧忍听。为迦留陀夷作不礼羯磨。白如是。大姊僧听。此迦留陀夷。骂打比丘尼乃至诡言劝喻。今僧为作不礼羯磨。谁诸大姊忍。僧为迦留陀夷作不礼羯磨者默然。谁不忍者说。僧已忍。为迦留陀夷作不礼羯磨竟。僧忍默然故。是事如是持。尔时迦留陀夷。随顺比丘尼僧不敢违逆。从比丘尼僧求解不礼羯磨。诸比丘白佛。佛言。若随顺比丘尼僧不敢违逆。从比丘尼僧乞解不礼羯磨者。比丘尼僧。应为解作白二羯磨。应如是解众中应差堪能作羯磨者。如上作如是白。大姊僧听。此迦留陀夷。比丘尼僧为作不礼羯磨。随顺比丘尼僧不敢违逆。今从比丘尼僧乞解不礼羯磨。若僧时到僧忍听。僧今为解不礼羯磨。白如是。大姐僧听。此迦留陀夷。比丘尼僧为作不礼羯磨。随顺比丘尼僧不敢违逆。从比丘尼僧乞解不礼羯磨。僧今为迦留陀夷解不礼羯磨。谁诸大姊忍。僧为迦留陀夷解不礼羯磨者默然。谁不忍者说。僧已忍。为迦留陀夷解不礼羯磨竟。僧忍默然故。是事如是持。时六群比丘。至比丘尼住处。共六群比丘尼共住。更相调弄或共呗或共哭或共戏笑。乱诸坐禅比丘尼。诸比丘白佛。佛言听遮彼便一切遮。不听入比丘尼住处。佛言。不应一切遮。应随乱闹处遮。若都乱住处。应一切遮。时六群比丘尼。来至比丘僧住处。共六群比丘。更相调弄。或共呗或共哭或共戏笑。白佛。佛言听遮彼。便一切遮。佛言。不应一切遮应随乱闹处遮。若都乱住处应一切遮。时六群比丘沙弥。来至比丘尼住处共六群比丘尼沙弥尼式叉摩那共住更相调弄。或共呗或共哭共戏笑。乱诸坐禅比丘尼。诸比丘白佛。佛言。听唤来谪罚。若不改。应为彼沙弥和尚阿阇梨作不礼羯磨。时六群比丘尼沙弥尼式叉摩那。来至寺内。共六群比丘沙弥共住。更相调弄。或共呗或共哭或共戏笑乱诸坐禅比丘。诸比丘白佛。佛言。应唤来谪罚。若不改。应为沙弥尼和尚阿阇梨作舍教授羯磨。时去比丘尼住处不远。有渠流通水。比丘尼以道在下承流觉乐有疑。诸比丘白佛。佛言。不犯波罗夷。犯偷兰遮。比丘尼不应以道承水流。时难陀比丘尼。至华树下经行处。有贼将去淫弄。彼有疑。以此因缘白佛。佛问言。难陀汝觉乐不。答言。如似热铁入体。佛言无犯。比丘尼不应独至如是经行处。尔时莲华色比丘尼阿兰若处经行。此比丘尼颜貌端正。有年少婆罗门见系心在彼。即捉欲犯。比丘尼言。于我当往某处。彼即放。莲华色比丘尼至彼处。即以屎涂身。彼婆罗门嗔。以石打头两眼脱出。莲华色不忆。有神足后乃知。即以神足力飞往佛所。头面礼足已却住一面。佛言。此比丘尼信乐。眼当还复。即如言还复如故彼比丘尼有疑。佛言无犯。比丘尼不应至阿兰若处。时比丘尼破戒有娠。在悬厕上大小便堕胎在厕中。除粪人见之。讥嫌骂詈言。比丘尼无有惭愧不修净行。外自称言。我知正法。如是何有正法。云何堕胎在厕中。如贼女淫女不异。诸比丘白佛。佛言。比丘尼不应在悬厕上大小便。彼比丘尼有疑。不敢在水上厕大小便。佛言听。时比丘尼结跏趺坐。血不净出。污脚跟指奇间。行乞食时虫草着脚。诸居士见皆嗤笑。诸比丘白佛。佛言。比丘尼不应结跏趺坐。彼疑不敢半跏趺坐。佛言听半坐。尔时世尊在舍卫国。有六群比丘尼。在白衣家内向孔中看。时诸居士见已皆共讥嫌言。比丘尼无有惭愧。外自称言。我知正法。如是何有正法。云何在他家向孔中看。如似贼女淫女不异。诸比丘白佛。佛言。比丘尼不应在白衣家向孔中看。尔时世尊在王舍城。时阿难。与大比丘僧五百人俱。在摩竭提人间游行。时阿难有六十弟子。皆是年少欲还舍戒。时阿难至王舍城。摩诃迦叶。遥见阿难来语言。此众欲失。汝年少不知足。阿难言。大德。我头白发已现。云何于迦叶所犹不免年少耶。迦叶报言。汝与年少比丘俱。不善闭诸根。食不知足。初夜后夜不能勤修。遍至诸家但行破谷。汝众当失。汝年少比丘不知足。偷兰难陀比丘尼闻彼语。嗔恚不喜作如是言。摩诃迦叶是故外道。何故数骂阿难言是年少令彼不悦耶。时摩诃迦叶语阿难言。汝看是比丘尼嗔恚作如是骂我。阿难。唯除世尊我不忆佛法外更有余事尊。阿难言。大德。忏悔女人无知。迦叶再三如是语。阿难亦再三如是言忏悔。夜过已迦叶清旦着衣持钵至王舍城乞食。时偷兰难陀比丘尼见唾之。时诸比丘尼闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责偷兰难陀言。云何乃唾大德迦叶。比丘尼白诸比丘。比丘白佛。佛尔时以此事集比丘僧。呵责偷兰难陀比丘尼言。汝云何乃唾大德迦叶。世尊以无数方便呵责已告诸比丘。听唤来谪罚。若一比丘。唤一比丘尼应往。若不往应如法治。若一比丘。唤二比丘尼三比丘尼若僧应往。若不往应如法治。二比丘。唤一比丘尼应往。若不往应如法治。二比丘。唤二比丘尼若三比丘尼若僧应往。若不往应如法治。三比丘。唤一比丘尼应往。若不往应如法治。三比丘。唤二比丘尼三比丘尼若僧应往。若不往应如法治。僧唤一比丘尼应往。若不往应如法治。僧唤二比丘尼三比丘尼。若僧应往。若不往应如法治。时六群比丘闻。作如是言。我等欲唤比丘尼者便当唤。欲有作者便当作。何以故。世尊有如是语。一比丘。唤一比丘尼应往。若不往应如法治。乃至僧亦如是。诸比丘白佛。佛言。应相望前人。不可往不应往(尼揵度具足竟)

    法揵度第十八

尔时世尊在舍卫国。时有客比丘不问旧比丘便入空房。蛇堕其上。便大声言蛇蛇。边傍比丘闻问言。汝何故大声耶。即为说因缘。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责客比丘已。往世尊所头面礼足在一面住。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责客比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何不语旧比丘知入空房中。蛇堕其上。大声言蛇蛇。以无数方便呵责已告诸比丘。自今已去。听为客比丘制客比丘法彼客比丘应随顺客比丘法应作如是随顺。若客比丘欲入寺内。应知有佛塔若声闻塔若上座。应脱革屣手捉。彼不抖擞革屣便捉污手。佛言。不应不抖擞便捉应抖擞。世尊既言抖擞。彼便着树抖擞树神嫌责。佛言。不应着树抖擞革屣应着石抖擞。若木头若篱若两革屣相抖擞。彼应至门中手排门若有关钥应开。若不能开。应徐打令内人闻。若不闻应大打若不开应持衣钵与第二比丘捉。至下篱墙处踰墙而入开门时彼于塔边左行过。护塔神嗔。佛言不应左行过应右绕塔而过。彼至寺内若有杙若龙牙杙若衣架若渠水边若树若石若草安衣钵着上。至洗脚处洗脚。若无水问言何处有水。随彼言。有水处便往取应问言有虫无虫。若言有虫若是大虫触水而去者便持瓶取水。彼不洗手捉瓶取水余比丘皆恶之。佛言。不应不洗手捉瓶听两臂抱瓶腹若以衣角穿耳。彼至水所应净洗手盛满器水洗脚。彼以洗脚手便捉水。余比丘见恶之。佛言不应尔。应一手捉水一手洗脚彼先洗右脚后洗左脚。佛言。应先洗左脚后洗右脚。彼不拭革屣便着污衣。佛言不应不拭便着应拭已着。彼不漉去脚水便着革屣烂坏。佛言不应尔。应漉去脚水着革屣。彼应问言。我若干岁有如许房不答言有。复应问此房有人住无人住耶。若言无人住。应问。有卧具无耶。若言有。应问有被无被。若言有。应问。有利无利。若言有利。应问。有器物无器物。若言有。复问。有房衣无房衣。若言有。复应问。有福饶无福饶。若言有。若欲取者。应语言。我当取。彼应至房所排户。若有关闭。应开。彼开户已。手捉户两颊。内头看房中。勿令有蛇诸毒虫。若有应驱出。彼入户已。出床褥卧具枕地敷毡被若木上若板上。地敷应识表里。净扫房除粪土。应先看可弃处便弃。若得针线刀子若弊故物乃至一丸药。安着一处。若有主识彼当取。彼应拂拭疏向。若杙若龙牙杙若衣架。若壁破坏若鼠孔。应泥便泥。若地不平。应平治泥浆洒涂令净。取地敷抖擞曝晒持入房。若先敷不好应更好敷。若先敷好还如本敷。取床支物净拭治持入。应净扫床抖擞持入房安着支上。取卧具枕毡被净抖擞敷着绳床上。彼常着衣不着衣并置一处。取常所著衣余衣乱。佛言。常所著衣应别一处。彼以钵囊革屣囊针筒盛油器并着一处。余比丘恶之。佛言不应尔。应各各别处。应先入屋内看户橝高下然后闭。彼出房看壁四面。无有尘土不。若有应扫洒除去。应取机净洗。应具净水瓶洗瓶饮水器。应问。何处大行处。何处小行处。何处是净地。何处不净地。何者佛塔。何者声闻塔。何者是第一上座房。何者是第二第三第四上座房。彼先应礼佛塔复礼声闻塔。四上座随次礼。彼捉脚胫礼不应捉胫礼。彼捉膝礼不应捉膝礼。彼反抄衣缠颈裹头通肩披衣着革屣作礼。佛言。一切不应尔。自今已去。偏露右肩脱革屣右膝着地捉两脚如是言。大德我礼。若四上座在房内思惟。应随坐次礼房。彼应问。何处是众僧大食处小食处夜集处说戒处。何者是僧差食。檀越送食。月八日食。十五日食。月初日食。檀越请食次到何处。复问明日有何檀越请众僧小食大食。有何檀越。僧为作覆钵。谁家是学家。何处狗恶。何处是好人。何处是恶人。自今已去。我为客比丘制法客比丘应随顺。若不随顺。应如法治。自今已去。为旧比丘制法。旧比丘应随顺。应作如是随顺。旧比丘闻有客比丘来。应出外迎为捉衣钵。若有温室重阁经行处安置中。与客比丘坐。与洗足水水器拭足巾。为捉革屣着左面。看莫令泥水污。若泥水污。应移着余处。彼为客比丘洗足已。应还收洗足具还本处。应问。长老欲饮水不。若言饮。彼应持瓶为取水。彼不洗手持瓶余比丘恶之。应两臂抱瓶。若以衣角钩耳至水边净洗手。若是池水流水。应手拨除上取下净水。彼担水日中行水热。佛言。应以若草若树叶覆作荫持去。彼不洗器过水。佛言应净洗。彼饮已不洗器过与余人。余比丘恶之。佛言应洗然后与。彼与水时并语口中有灒唾堕水中。佛言不应并语。若有所语应回面语。彼不洗器便举。余比丘见皆恶之。佛言不应尔。彼应问。大德长老几岁。若言若干岁。应语言。此是房此是绳床木床褥枕毡被地敷。此是唾器此是小便器。此是大便处此是小便处。此是净处此是不净处。此是佛塔此是声闻塔。此是第一上座房。此是第二第三第四上座房。此是众僧大食处小食处夜集处布萨处。僧差食乃至次到某处。某甲檀越。明日请僧与小食大食。某甲家。僧与作覆钵羯磨。某甲家。僧与作学家羯磨。某甲处狗恶。某甲处好。某甲处恶。我今为旧比丘制法。旧比丘应随顺。若不随顺应如法治。尔时世尊在王舍城。时舍卫有婆罗门出家比丘。多恶污自恶大小便。用利厕草伤身作疮脓血出。污身污衣污卧具污床。诸比丘问。长老何所患。即具说因缘。时诸比丘闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责婆罗门出家比丘言。云何多恶污自恶大便。用利厕草伤身脓血出。污身污衣污卧具污床。诸比丘往世尊所。头面礼足却坐一面。以此事具白世尊。世尊尔时。以此因缘集比丘僧。呵责彼比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。汝云何婆罗门出家比丘。多恶污自恶大便。用利厕草伤身脓血出。污身污衣污卧具污床耶。以无数方便呵责已告诸比丘。自今已去。为比丘制便厕法。诸比丘应随顺此法。应如是随顺。不应久忍大小便。若去时捉厕草。彼下座在上座前去。或并语并行。或在前在后反抄衣。或缠颈或裹头或着革屣。佛言不应尔。若在前去者听在前。彼至厕外应弹指若謦咳。若有人非人令知。彼至厕坊里。若杙若龙牙杙若衣架衣屋。若水边若树若石若草。应安衣着上。若畏雨渍。应安着无雨处。若风飘雨渍衣。听着衣手竖捉令不触厕两边坚安脚上厕。先看若有蛇蝎蜈蚣百足驱出。彼未蹲便举衣形露。佛言不应尔。应并蹲渐举衣。蹲已当看。勿令前却近两边使大小便涕唾污厕孔。彼高声大鸣。余比丘闻恶之。佛言不应尔。彼大便时不觉卒鸣有疑。佛言不犯。彼在厕上嚼杨枝若眠若入定。佛言不应尔。彼疑不敢在水上厕中大小便。佛言无犯。彼不用厕草拭身便起。污身污衣污坐具。佛言。听用厕草然后起。世尊有如是教。听用厕草。彼用长厕草。佛言。不应用长厕草。极长一搩手。彼用叉奇厕草杂叶。若用树皮。用草牛屎抟。佛言不应尔。彼用短厕草污手。佛言不应尔。极短长四指。彼用厕草不抖擞着厕草粪便弃。余比丘见恶之。佛言不应尔。彼以已用未用厕草杂一处取时污手。佛言应别处。彼用厕草已便起形露。佛言不应尔。应徐起渐下衣。彼至洗处。应弹指令彼若人若非人知。彼至洗处应先看。若有蛇百足毒虫应驱出。彼先褰衣而后蹲形露。佛言不应尔。彼就水器中洗。余比丘恶之。佛言不应尔。彼用水洗时有声。余比丘闻恶之。佛言不应尔。彼用水尽。佛言不应尔。应留乃至足一人洗。彼洗已不却身上水污衣污身。佛言不应尔。应去水若以手若以叶若弊物拭。若手臭应洗若以卤土若灰若泥若牛屎若故臭应以石揩若土墼若澡豆。彼不下衣便起形露。佛言不应尔。应渐下衣起。彼见洗器空不着水。佛言应见者便着水。彼在厕前受经诵经经行作衣。妨余比丘大小便。佛言不应尔。彼在厕边诵经受经经行作衣。余比丘见恶之。佛言不应尔。彼上厕见有粪扫不除。佛言见者应除。我今为诸比丘说大小便法。诸比丘应随顺。若不随顺应如法治。尔时世尊在舍卫国。有异乞食比丘。年少多所不解。不看门相便入。有女人眠屋中。其女人露形仰眠不净出污女根。彼比丘见愧惧。即疾疾从屋还出。比丘适出。其夫便入屋。见其妇露形仰卧不净污身。见已作如是念。我妇露形仰卧不净污身。彼比丘从屋疾疾而出。必犯我妇。即往追问言。汝犯我妇便走耶。比丘言。居士莫作如是言。我等不应作如是事。居士言。汝从我屋出。云何言不作。彼即打比丘次死。时诸比丘闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责彼乞食比丘。云何乞食比丘。年少多所不解。不看门相乃入他女人眠屋。时诸比丘往世尊所。头面礼足却坐一面。以此因缘具白世尊。世尊尔时。以此因缘集比丘僧。呵责乞食比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何乞食比丘。年少多所不解。不看门相乃入他女人卧屋。以无数方便呵责已告诸比丘。自今已去。为乞食比丘制法。乞食比丘应如是随顺。若乞食比丘入村乞食。清旦净洗手至衣架边。一手举衣一手挽取。舒张抖擞看。勿令有蛇虫。然后着腰带僧祇支。郁多罗僧舒张抖擞看。叠僧伽梨着头上若肩上。净洗钵着络囊中。若手巾裹。若钵囊盛。举衬身衣洗足革屣毡被。取道路行革屣。彼应持户钥出房去闭户推看。若不坚牢应更安扂。若坚牢应推绳着内然后四顾看。若无人见藏举户钩。若有人见不坚牢应持去。若更着坚牢处。在道行应常思惟善法。若见人应问讯言善来。若欲至聚落。小下道安钵置地。取僧伽梨舒张抖擞看然后着。村边若有卖器处若有屋若有作人。应脱道行革屣寄之。彼入村时。应看巷相看空处。看市相门相粪聚入白衣家。应看第一门相乃至第七门。尔时乞食比丘。至他舍内风吹衣堕肩。彼向女人正衣。佛言。不应向女人正衣应向壁。彼乞食比丘。右手捉钵左手捉杖时形露。佛言不应尔。应右手捉杖左手捉钵。彼乞食比丘当道住。令男子女人避道。诸居士见皆讥嫌言。沙门释子不知惭愧无有厌足。自言我知正法。当在道住令男子女人皆避道。如是何有正法。诸比丘白佛。佛言。乞食比丘不应当道住。世尊既言。不应在道住。彼在屏处住。佛言不应尔。应在见处住。彼乞食比丘他持食出便前迎取。诸居士见皆讥嫌言。沙门释子不知厌足。自言我知正法。如是何有正法。急前取食如似谷贵。诸比丘白佛。佛言。乞食比丘不应前取食。若是女人。若病。若妊娠。若抱儿。若天雨。若两手捉物。若地泥水唤比丘。比丘疑不敢前取。佛言唤应往。乞食比丘。得饭干饭糗鱼肉。并着一处。余比丘见恶之。佛言不应尔。杂着一处。若是一钵。应以物隔。若树叶皮若键镃。若次钵若小钵。糗应手巾裹。彼乞食比丘往大家乞食。居士见讥嫌言。沙门释子不知厌足。自言我知正法。乃至大家乞食如似谷贵。如是何有正法。诸比丘白佛。佛言。不应选大家乞食。若次第乞不得应选。彼乞食比丘强乞要得乃去。诸居士见皆讥嫌。沙门释子不知惭愧无有厌足。自言我知正法。强从人乞要得乃去。如似谷贵。如是何有正法。诸比丘白佛。佛言不应尔。若知当得应待。彼出时。当看第一门相乃至粪聚相。若出村。还取道行革屣着。下道安钵置地。叠僧伽梨着肩上若头上。行时常当思惟善法。若见人应先问讯善来。彼乞食比丘常所食处。应往净扫洒具水器残食器。复应具床座洗脚石水器拭脚巾。若见有余乞食比丘来。应起远迎逆为取钵。若有钵床钵支头上。取衣舒张看。勿令有腻尘坌泥污鸟粪污。若有如是污。应拭当拭。应揉便揉。应抖擞便抖擞。应浣当浣。浣已应绞去水洒着绳床木床上。彼应与乞食比丘坐。与水器与水与洗足石拭足巾。持革屣安左边。看勿令泥水污渍。若有水渍应移。彼为乞食比丘洗足已。应持水器洗足石诸物还复本处。彼应澡豆净洗手已。授水与彼乞食比丘。次授食与彼。食时应看供给所须。若有酪浆清酪浆若苦酒若盐若菜应与。若热应为扇。须水应与。若日时欲过应俱食。乞食比丘食已。应为取钵与洗手。自食已若有余食。应与人若非人。若着无草地若无虫水中。洗盛残食器复故处。应还复床坐洗足石水器。诸物复故处。扫除食处。彼以食钵除粪。余比丘见皆恶之。佛言。不应以钵除粪。应用澡盘扫帚。钵应净洁持。时有众多乞食比丘。共一处食。有妊娠狗。看食不得食。以饥故遂堕子。比丘白佛。佛言。食时若人若非人。应与食乃至一抟。我今为乞食比丘制法应随顺。若不随顺应如法治。尔时世尊在王舍城。时阿兰若比丘窳堕都无所具。不具水器洗足物。亦不留残食。去此住处不远。有众多贼过。时有一贼语余贼言。沙门释子常有此法。具水器洗足物亦留余食。我等可往彼。若得食当共食之。时贼至彼问言。汝有水不。答言无。有洗足物不。答言无有余食不。答言无。贼语言。汝在阿兰若处住。不具水洗足器。无有余食。即打令次死。诸比丘闻。其中有少欲知足行头陀乐学戒知惭愧者。嫌责彼阿兰若比丘言。汝窳堕。云何在阿兰若处住。而不具水器。乃至不留余食。时诸比丘往世尊所。头面礼足却坐一面。以此因缘具白世尊。世尊尔时。以此因缘集比丘僧。呵责彼阿兰若比丘。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何窳堕。在阿兰若处住不具水器。乃至不留余食。以无数方便呵责阿兰若比丘已告诸比丘。自今已去。为阿兰若比丘制法。应随顺阿兰若法比丘。应如是随顺。若阿兰若比丘入村乞食。清旦净洗手至衣架已。一手举衣。一手挽衣取。舒张抖擞看。勿令有蛇虫然后着腰带僧祇支。郁多罗僧舒张抖擞看。叠僧伽梨着头上若肩上。净洗钵着络囊中。若手巾裹。若钵囊盛已。举衬身衣洗足革屣毡被。取道路行革屣打露杖。彼应持户钥。出房还闭户推看坚牢不。若不坚牢应更安扂。若坚牢应推绳着内四顾看。若无人见应藏举户钩。若有人见不坚牢应持去。若更着坚牢处。在道行应常思惟善法。若见人应先问讯言善来。若欲至聚落。小下道安钵置地。取僧伽黎舒张抖擞看然后着。若村边有卖器处若有屋若有作人。应脱道行革屣打露杖寄之。彼入村时。应看巷相若空处相市相若门相若粪聚相。入白衣家。应看第一门相乃至第七门相。尔时阿兰若比丘。至他舍内风吹衣堕肩。彼向女人正衣。佛言。不应向女人正衣应向壁。彼阿兰若比丘。右手捉钵左手捉杖时形露。佛言不应尔。应右手捉杖左手持钵。彼阿兰若比丘当道住。令男子女人避道。诸居士见皆共讥嫌。沙门释子不知惭愧无有厌足。自言我知正法。当在道住令男子女人避道。如是何有正法。诸比丘白佛。佛言。阿兰若比丘不应当道住。世尊既言。不应在道住。彼在屏处住。佛言不应尔。应在见处住。彼阿兰若比丘。他持食出便前迎取。诸居士见皆共讥嫌言。沙门释子不知惭愧无有厌足。自言我知正法。如是何有正法。急前取食如似谷贵。诸比丘白佛。佛言。阿兰若比丘不应前取食。若是女人若妊娠若抱儿若天雨若两手捉物若地泥水唤比丘。比丘疑不敢前。佛言若唤应往。阿兰若比丘。得饭若干饭糗鱼肉。并着一处。余比丘见恶之。佛言不应尔。杂一处。若是一钵。应以物隔。若树叶皮若键镃。若次钵若小钵糗应手巾裹。彼阿兰若比丘往大家乞食。诸居士见皆共讥嫌。沙门释子不知惭愧无有厌足。自言我知正法。乃选大家乞食如似谷贵如是何有正法。诸比丘白佛。佛言。不应选大家乞食。若次第乞不得应选。彼阿兰若比丘强乞食要得乃去。时诸居士见皆共讥嫌。沙门释子不知惭愧无有厌足。自言我知正法。强从人乞要得乃去如似谷贵。如是何有正法。诸比丘白佛。佛言不应尔。若知当得应待。彼得食时作如是念。此为贼此自食。出时当看第一门相乃至粪聚相。若出村还取行道革屣打露杖。小下道安钵置地。叠僧伽梨着肩上若头上。行时当常思惟善法。若见人应先问讯善来。彼阿兰若比丘常所食处。应往净扫洒具水洗器残食器。复应具床座洗脚石水器拭脚巾。若见有余阿兰若来。应起远迎逆为取钵。着钵床钵支头上。取衣舒张看。勿令有腻尘坌泥污鸟粪污。若有如是污。应拭便拭。应揉便揉。应抖擞便抖擞。若浣浣已应绞去水晒着绳床若木床上。彼应与阿兰若比丘坐。与水器与水。与洗足石拭脚巾。持革屣安左边。看勿令泥污水渍。若有泥污应移。彼为兰阿若比丘洗足已。应持水器洗足石诸物还复本处。彼应澡豆净洗手已。净洁别留残食。若有贼来应与。授水与彼阿兰若比丘。次授食与彼。食时应看供给所须。若有酪浆清酪浆若苦酒若盐若菜应与。若热应扇。须水应与。若日时欲过应俱食。阿兰若比丘食已。应为取钵与洗手。自食已若有余食。应与人若非人。若着无草地无虫水中。洗盛残食器。床座洗足石水器诸物复本处。应扫除食处。彼以食钵除粪。余比丘见皆恶之。佛言。不应以钵除粪。应用澡盘若扫帚。钵应净洁持。若有贼来应语。此是水是洗足物此是食。为汝等故别留净洁。若欲食便食。时贼问阿兰若。今夜是何时。彼比丘不能答惭愧。诸比丘白佛。佛言。阿兰若比丘应善知夜时节。时贼问阿兰若言。此是何方。阿兰若比丘不知答惭愧。诸比丘白佛。佛言。阿兰若比丘应善知方相。贼问比丘。今日是何星。阿兰若比丘不能答。诸比丘白佛。佛言。阿兰若比丘应善知星。彼阿兰若比丘敷好卧具安眠。时诸比丘白佛。佛言。阿兰若比丘不应尔。应初夜后夜警心思惟。今为阿兰若比丘制阿兰若法。阿兰若比丘应如法随顺。若不随顺应如法治。尔时世尊在舍卫国。时有居士请众僧明日食。即于其夜办具种种多美饮食。清旦往白时到。时诸比丘受请食时错乱。或有已坐者。有方坐者。或有已与食者。有方与食者。或有已食者。有方食者。或有已去者。有方欲去者。或有已出者。有方欲出者。而彼檀越不知。谁已食谁未食。时诸居士皆共嗔嫌。沙门释子不知惭愧无有厌足。自言我知正法。受檀越请错乱去。或有已坐者方坐者。或有已与食者。有方与食者。乃至或有已出者。有方欲出者。如是何有正法。令我等不知。已与谁未与谁。谁已食谁未食。时诸比丘闻。有少欲知足行头陀乐学戒知惭愧者。嫌责彼受请比丘言。云何受檀越请错乱去。或有已坐者方坐者乃至方欲出者。令檀越不知已与谁未与谁谁已食谁未食。时诸比丘往世尊所。头面礼足在一面坐。以此因缘具白世尊。世尊尔时。以此因缘集比丘僧。呵责彼受请比丘。云何受檀越请错乱去。或有已坐者有方坐者乃至方欲出者。令檀越不知已与谁未与谁谁已食谁未食耶。以无数方便呵责已告诸比丘。自今已去。为诸比丘制食上法。诸比丘应随顺食上法。应如是随顺。若比丘欲往受请。应往众僧常小食处大食处可见处住。若檀越来白时到。上座应在前如象行而去。若上座往大小便处应待。彼下座在前行。并语并行或前或后。或反抄衣。或缠颈。或裹头。或通肩披衣。或着革屣。佛言不应尔。应偏露右肩脱革屣在后行。若有为佛事法事僧事有病比丘事。佛言应白上座在前去。彼有命难梵行难。畏慎不敢不问而去。佛言。若有如是难事。若问若不问听去。彼往食处错乱聚住。佛言不应尔。应随次座。上座坐已。应看中座下座。勿令不如法坐不善覆身。若有不如法坐不善覆身者。应弹指令觉。若遣人语。令知好如法坐。中座坐已。应看上座下座。勿令不如法坐不善覆身。若有不如法坐不善覆身。应弹指令觉。若遣人语。令知好如法坐。下座坐已亦如是。时有比丘。至食上无钵食。比坐应借钵。有比丘。不洗钵至食上。蛇在钵中吐。比丘用食已得病。佛言。不应不洗钵便持往食上。应净洗已用食。时六群比丘。贪受恭敬故。在后往食上。令诸比丘见我等当起。诸比丘白佛。佛言。不应贪利恭敬故。在后往食上。令诸比丘起。若未来者。听比坐开坐处。若檀越与上座果。应问言。果净不。若言未净。上座应语令净。若已净。问言为谁送来。若为上座送来。得随意取。若言为僧。应语令传使遍。若檀越与上座种种羹。应问言为谁送来。若言为上座。随意取。若言为僧。应语令传使遍。时有比丘不得食。听比坐为索。若无比坐。应自减半与。时诸比丘得食便食。诸居士见皆共讥嫌言。沙门释子不知惭愧无有厌足。自言我知正法。得食便食如似谷贵饥饿时。如是何有正法。白佛。佛言不应尔。应唱言等得然后食。时六群比丘眶肘食妨碍比坐。诸比丘白佛。佛言。不应眶肘食。应敛肘食。六群比丘。食时大咳唾。迸唾堕比坐上。余比丘恶之白佛。佛言不应尔。应徐徐弃唾。彼食时若余果若菜根狼藉污地白佛。佛言不应尔。所食可弃之物。应聚着脚边。去时持去弃之。彼处处弃洗钵水令地污泥。佛言不应尔。以澡盘承弃外。尔时众多比丘。与六群比丘在白衣家内共机上坐食。有一六群比丘。便起不语比坐知。机倾倒地。余人皆堕形露。诸比丘白佛。佛言不应尔。应语令知好坐。时有比丘。食已默然而去。彼檀越不知食好不好食为足不足。诸居士皆讥嫌。诸外道人皆称叹布施赞美檀越。而沙门释子。食已默然而去。令我等不知食好不好足不足。诸比丘白佛。佛言。不应食已默然而去。应为檀越说达嚫。乃至为说一偈

  若为利故施　　此利必当得
  若为乐故施　　后必得快乐

世尊既言。应说达嚫。时人人皆说。遂便闹乱。佛言。不应人人乱说。应令上座说。若上座不能说。应语能者说。若上座不语突吉罗。若上座语而不说者亦突吉罗。彼说达嚫时。余者皆去彼安坐。或在静处坐。或在覆处坐。或共女人在无有知男子处说法。过五六语媟嬻。时人皆嫌责。语诸比丘。白佛。佛言。达嚫时余比丘不应去。应留上座。四人相待。余者听去。若为佛法僧事。若病比丘事。应白令知然后去。若语余比丘去。若檀越欲闻说布施。应称叹布施。若欲闻说檀越法。应为赞叹檀越法。若欲闻说天。应为赞叹天。若欲闻说过去父祖。应为赞叹过去父祖。应为檀越赞叹布施。赞叹檀越。赞叹佛法僧。为诸比丘说食上法。诸比丘应随顺。若不随顺如法治。尔时世尊在舍卫国。时诸比丘衣服垢腻。佛言。听以卤土若灰若土若牛屎浣。彼用粗涩盆石浣衣令衣坏。佛言。不应用粗涩盆石。应用细盆石。若色脱应更染。若泥若陀婆树皮。若婆茶树皮。揵陀罗若荜苃。若阿摩勒。若以树根。若以茜草染。彼在日中渍汁用染不耐久。佛言。不应尔应煮。彼不知何处煮。佛言。应以釜煮。若禁满若铜瓶镬煮。彼煮时树皮片大不受。佛言。应以斧细斩。若沸涌出以木按之。彼不知熟不熟。佛言。应取汁二三渧着冷水中。若沈者熟应漉取汁。彼不知漉着何处。佛言。漉着盆中。若汁滓俱下。应以扫帚遮若扫帚弱应以木辅。彼漉汁时兼捉盆遂疲极。佛言不应尔。应一人捉盆一人漉汁。若热捉镊热物。彼冷热着一处染汁坏。佛言。不应尔。应冷热别处。若扬令冷然后和合。彼就染汁中染染汁坏。佛言。不应尔应取少许别余器中染。彼染已敷着地色坏。佛言不应尔。彼便敷着草上令草坏。彼敷着草上叶上令色不调。佛言。不应尔。应敷着伊梨延陀耄罗耄耄罗若氍氀上。十种衣中取一一衣敷着地。以彼染衣着上若悬着绳上。彼须绳听畜绳须签听作。彼须衣头安纽听作纽。若染汁偏流应倒易。时有比丘。晒染衣已背向煮。染汁衣汁偏流。有异比丘。先与嫌诤。见之不语彼令知衣色遂坏。诸比丘白佛。佛言。不应尔。见者应为倒易。若语令知。彼比丘染衣竟。不举釜禁满铜瓶盆器镬斧斤绳签伊梨延陀耄罗耄耄罗便舍去。佛言。不应尔。应藏举然后去。若余人索应与彼染衣竟。不扫除染处。令地不净。佛言。不应尔应扫除已去彼着新衣扫地尘坌污。佛言。不应着新衣。应着故者。若无私衣应着僧衣。彼逆风扫尘来坌身。佛言。不应尔应顺风扫。有五种扫地。不得大福德。不知逆风顺风。扫地不灭迹不除粪不复扫帚本处。有如是五法扫地不得大福德。有五法得大福德。知逆风顺风。扫地灭迹除粪。复扫帚本处。有如是五法得大福德。若上座在下风。应语言小避。我欲扫地。我今为诸比丘说染衣法。应随顺。若不随顺。应如法治(法揵度具足竟)

四分律卷第四十九四分律卷第五十(第四分之一)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    房舍揵度初

尔时世尊在波罗奈时五人从坐起。偏露右肩右膝着地合掌白言。世尊。我等当住何等房舍卧具。佛言。听在阿兰若处树下。若空房若山谷窟中。若露地若草[卄/告]草[卄/積]边。若林间若冢间若水边。若敷草若叶。时诸比丘无枕卧得患。佛言。听用。石若墼若木作若枕臂。十种衣中若用一一衣作枕。尔时世尊在王舍城。摩竭王瓶沙作如是念。世尊若初来所入园。便当布施作僧伽蓝。时王舍城有迦兰陀竹园。最为第一。时世尊知王心念。即往迦兰陀竹园。王遥见世尊来。即自下象。取象上褥。叠为四重敷已。白佛言。愿坐此座。世尊即就座而坐。时瓶沙王。捉金澡瓶授水与佛。白言。此王舍城迦兰陀竹园最为第一。今奉施世尊。愿慈愍故为纳受。佛告王言。汝今以此园施佛及四方僧。何以故。若是佛所有。若园园物。若房房物。若衣钵坐具针筒。一切诸天世人魔王梵王沙门婆罗门无能用者。应恭敬如塔。王即白佛言。大德。以此迦兰陀竹园布施佛及四方僧。慈愍故。为我纳受。时世尊说此偈。而劝喻之

  施园及果树　　桥船以渡人
  旷路施泉井　　并施房舍者
  如是诸人等　　昼夜福增益
  持戒乐法者　　此人生善道

时王瓶沙。头面礼佛足却坐一面。世尊为王种种方便说法。令得欢喜。王闻佛说法欢喜。从坐起礼佛而去。时诸比丘清旦从耆阇崛山来王舍城中。有大长者见已问言。大德在何处宿。答言。在山窟中水边树下石边若草上。长者问言。无房舍耶。答言无。若作房者得不。比丘答言。世尊未听作房舍。诸比丘白佛。佛言。听作房舍。尔时长者闻佛听诸比丘作房舍。即于耆阇崛山作六十别房。一切所须皆令具足请佛及僧明日食并施房舍。即于其夜办种种多美饮食。明日往白时到。世尊清旦着衣持钵与大比丘千二百五十人俱。往大长者家就座而坐。时长者手自斟酌种种多美饮食皆令饱足。食已舍钵取金瓶水授世尊。白佛言。我于耆阇崛山作六十房舍。一切所须皆令具足。为福德故。为大祠故。为生善道故。今以奉上佛及四方僧。愿为慈愍纳受。时世尊即便受之。以此劝喻。而劝喻之

  为障寒热故　　及以诸恶兽
  蚊虻诸毒虫　　亦以障疾雨
  暴疾诸恶风　　如是得障翳
  持戒无毁缺　　勤修于佛法
  为坚为乐故　　禅定分别观
  房舍施众僧　　世尊说第一

尔时王舍城长者。更取卑床在世尊前坐。世尊无数方便为开化说法。令得欢喜。为长者开化说法已。从坐而去。时王瓶沙。闻世尊听众僧作房舍。欲于迦兰陀竹园作大讲堂。如王住殿。一切所须供给具足。佛言听作。时有檀越。欲为僧作楼阁舍。佛言听作。时有檀越。欲为僧作毗摩那房。佛言听作。时有檀越。欲为僧作如象形房。佛言听作。有檀越欲为僧作种种房。佛言听作。时诸比丘欲作房。佛言听作。随作房法所须一切听与。作房竟若地有尘应泥。无敷卧得病。佛言。听伊梨延陀耄罗耄耄罗毛氀十种衣中若以一一衣作地敷。若故有病听作床。有五种床如上。彼欲织床。佛言听织。除二种绳。皮绳发绳用余绳作。若绳不足。应绳穿床陛疏织。彼床无敷卧得病。听作褥。彼不知以何物作。佛言。听草作若毳。若劫贝作贮。若褥小应张缝着床四边。若褥缘破裂应补治。若贮聚一处应缝[穩-禾+糸]。若褥垢腻应作重褥。若重腻应作卧毡覆上。时诸比丘无枕。佛言听作。不知云何作。佛言。若四方若圆若三角。尔时王舍城众僧多得舍[少/(兔-、)]麻。诸比丘疑不敢受。佛言听受。用作绳床绳木床绳。若织作褥表里。若作地敷。若作绳若作褥贮。时诸比丘得跋磨草绳织床。佛言听受。时诸比丘。蛇蝎蜈蚣诸毒虫入屋。未离欲比丘见惊。佛言。听支床脚。时六群比丘作高支。佛言。不应作高支。大高应高尺五若一搩手。时有比丘衣无牢坚安处。佛言。应叠置头边若背后卧。转侧堕衣上。佛言。听安绳上若龙牙杙上若作衣架安。彼常所著衣。与不着衣在一处。取常所著衣时乱。佛言。不应常所著衣不着衣共安一处。彼持钵革屣囊针筒油器置一处。余比丘见恶之。佛言。钵囊针筒置一处。革屣囊油器共着一处。时诸比丘房里患闇。佛言。听燃灯须油与油。须灯炷与炷。须盛油器与器。不知持灯置何处。佛言。听着若木床若绳床角头若瓶上。若着壁龛中患蚁子饮油应障。若灯不明应出炷令高。油污手听作箸。患烧箸听铁作。彼房无户不坚牢。有贼牧牛羊人。取比丘衣钵针筒坐具去。佛言。听作户。须户枢听作。若患户里臭气。听穿户扇作孔出气。患蛇蜈蚣毒虫从孔入。听作帘板障户。无关钥。有贼放牛羊人。取比丘衣钵针筒坐具持去。佛言。听作关钥。不知在何处安。佛言。若在边若在上若在下。不知云何开。佛言。听开孔作曲排若作钩。若患闇听开向。彼向无障。贼及放牛羊人。取比丘衣钵针筒卧具。佛言。听作向扇板障。不知云何作。佛言。若方作若圆作若象耳形作。夜患蝙蝠昼患[燕*鳥]鸟入。佛言。听织作笼疏障若作向棂子。时向无关扂。贼及放牛羊人。取比丘衣钵针筒坐具去。佛言。听关扂。彼犯戒比丘挽绳开向取比丘衣钵针筒坐具去。佛言。听扂安横概。时六群比丘。私用众僧卧具。诸比丘白佛。佛言。不应私用众僧卧具。听作幖帜。不知作何幖帜。佛言。听作摩醯陀罗像。若作棬像。若作蒱桃蔓像。若作五色。若作莲华。若作名字。时六群比丘。私物上作僧幖帜。诸比丘见语言。长老。世尊不作如是语。众僧物不得私用耶。答言。此非僧物是我己有。诸比丘白佛。佛言。不应私己物上作僧幖帜。听私物染作幖帜。彼六群比丘。方作幖帜。若作半月像。若作圆幖帜。彼作如日光幖帜。彼作如麦根幖帜。彼作如一片姜像。彼作牛形像幖帜。佛言。不应尔。听作如水渧洒地幖帜。作牛屎抟幖帜。作轮幖帜。彼移房中定卧具着余处。佛言。不应移。应作名字言。是某甲房卧具。时有比丘有小沙弥。欲房中安隔障。佛言听作。时有比丘欲开房前曲障巷。佛言听作。欲作后内房。佛言。听作。须户听作。须壁听作壁。须半壁听作。须作大床。佛言听作。须小床听作。须绳床听作。须小绳床听作。须独坐床听作。须板与板。须地敷与地敷。时有比丘欲作房四边出檐上安栏楯听作一切作房所须听与。时布萨日众僧多集。堂小不相容受。诸比丘白佛。佛言。听大作。不知云何作。佛言。若四方若圆若长作若两坊若三坊若四坊听作。作大堂所须一切应与。时堂内人各一床不相容受。佛言。听若大三腊者共一床坐。若坐故不受。应作长床若长板。若复不受。应缚草作座。缚草作座已便破衣佛言。应以软草缠边。若故复不受。应以泥浆洒地若布沙若草树叶敷地坐上。彼与女人俱在草上叶上。佛言。不应尔。彼与女人共敷衣。佛言。不应尔。彼共女人俱在衣上。佛言。不应尔。彼与女人共上石上。佛言。不应尔。若上石一人不能动者听上。彼共女人上船疑。佛言。听直渡若坐若立若卧。时诸比丘露地经行。患风雨日曝得患。佛言。听作经行堂。不知云何作。佛言。听长行作。作堂所须一切给与。时彼上座老病羸顿经行时倒地。佛言。听绳索系两头循索行。捉索行手软破手。佛言。听作卷若竹筒以绳穿筒手捉循行。经行时疲极。听两头安床。时比丘洗脚天雨雨新染衣色坏。佛言。应别作洗脚处。彼须水盆与水盆。须水[土*瓦]与水[土*瓦]。须洗脚石与石。须坐具与坐具。彼洗脚天雨泥污脚污衣坐具。佛言。听以石若甎若木作道。尔时耆阇崛山中去水远。佛言。听作渠。作时患渠崩决。佛言。听以石若甎若木障两边。若寺内应作池。若池边崩决。听以石若甎若木障四边。上应作屋覆。若池边患泥应安石若甎若板若碎石。患小儿堕水。佛言。听作栏。彼池水热。佛言。听瓶盛昼日内屋中夜置在外。若屋内患泥。听别作安水屋。若地泥污脚。听安石若甎若碎石彼须水器应与。彼用宝作器。佛言。不应用宝。应用铁若铜若瓦作。彼水器无安处破坏。佛言。应水屋中别作架安。时众僧得贝。佛言听畜。复无安处。佛言。听与水器共安一处。尔时世尊在王舍城舍卫国。有居士名须达多。常好给施孤穷乞儿。遂因行更为名字给孤独食。彼于王舍城中有田业。年年从舍卫国至王舍城按行田业。王舍城中有长者是其亲厚。是长者自庄严堂舍。欲请佛及僧明日食。时给孤独食往长者家。彼长者常法。若给孤独食来时。辄起迎逆请与敷坐。而此日亦不起迎不请令坐。但自庄严堂舍。为佛及僧。时给孤独食既至已。问长者言。庄严堂舍欲何所作。为欲嫁娶。为欲请王。为欲设大祠。长者报言。我不嫁娶亦不请王。我欲设大祠。请佛及僧千二百五十人俱。彼沙门瞿昙。有如是大名称。号曰如来无所著等正觉明行足善逝世间解无上士调御丈夫天人师佛世尊。给孤独食问言。审是佛耶。答言审是佛。再三问亦再三答。审是佛。时给孤独食再三问已。问言。佛在何处。我今欲往问讯。长者答言。佛今在迦兰陀竹园中住。时给孤独食仰看日作如是念。今日见世尊非时明日乃可往。时给孤独食即还家念佛在心而眠。时有异天神。是给孤独食昔日宗亲。慈愍故利益故。作如是念。给孤独食。汝欲见世尊莫有留难。而不见佛。彼即以神力灭闇忽然大明。时给孤独食。眠觉见明谓是昼日。即往趣尸呵城门。时彼门神。见给孤独食欲见世尊无有留难。我今宁可开门。即便开门。时给孤独食出尸呵门已。时彼神还摄神力。明晓即灭忽然闇冥。时给孤独食恐怖心惊毛竖。恐将有怨家来害我耶。时彼门神。见给孤独食恐怖心惊。即慰喻言。莫恐怖莫恐怖。即说偈言

  设以马百匹　　及与百金缨
  马车有百乘　　童女有百人
  七宝为璎珞　　雪山百白象
  象皆有六牙　　并以大聚金
  及紫磨金沙　　王及王供具
  王所乘调象　　以如是布施
  行一步之福　　十六不得一

长者但前行。前行有利益。给孤独食问。汝是谁。答言。我是伺呵神。彼作是念。未曾有。天神乃安慰我。时给孤独食。即往迦兰陀竹园中。时世尊在露地经行。遥见给孤独食来。还坐处敷座而坐。诸佛常法圆光照身。时给孤独食。遥见世尊颜貌端正诸根寂静得上第一调伏诸根坚固犹若大龙亦如澄渊清净无秽。见已敬心生焉以信敬心前诣佛所。白言。安眠不。世尊答言。如世安眠。我则异于彼。时即说偈言

  一切皆安眠　　梵行得涅槃
  若不犯于欲　　诸缚得解脱
  一切爱已尽　　调伏于热恼
  息灭得安卧　　身心俱寂灭

时给孤独食前礼佛足却坐一面。时世尊为给孤独食。种种方便开化说法。令得欢喜。即于坐上得法眼净。见法得法得增上果厌患心生。白世尊言。我今归依佛法僧。作佛优婆塞。自今已去。尽形寿不杀生。乃至不饮酒。唯愿世尊。与众僧俱受我夏安居九十日请。佛言。我已受王瓶沙请。即复白言。愿受来年请。佛言。我已受王瓶沙请。复白言。大德。愿受后年请。佛报言。若有如是处。清净无有愦闹无诸恶兽。绝于人林可得坐禅。如来当于如是处住。即白佛言。世尊。我已知之。自当知时。唯愿世尊。与众僧受我明日请食。时世尊默然受请。给孤独食。从坐起前礼佛足绕已而去。时王瓶沙闻给孤独食请佛及僧明日食。即遣信语言。汝[宋-木+喬]客在。此众僧既多千二百五十人。汝可不须设供。我当为汝故设食。时即遣人答王言。此便为供养已不须。我自当办。时摩竭大长者。闻给孤独食请佛及僧明日施食。即往其所语言。汝[宋-木+喬]客在。此众僧既多。汝可不须供设。我当为汝办之。彼即答言。长者。此便为供养已。不须。我自当办。给孤独食即还其家。夜办种种多美饮食。夜过已清旦往白时到。世尊着衣持钵。与千二百五十比丘僧俱。往给孤独食家就座而坐。时给孤独食。手自斟酌种种多美饮食。供养佛及众僧令得饱满。食已舍钵。更取卑床于佛前坐。时世尊无数方便为给孤独食方便说法开化。令得欢喜。为说法已。从坐起而去。时给孤独食。从王舍城还归舍卫国。彼至村落城邑。处处宣令作如是言。可于空处种植园果并设池井及安桥船。佛已出世今受我请。于舍卫国夏安居。当从此道至舍卫国。令汝等得福无量。至舍卫国已。作如是念。今此何处。有不近不远行来游观。其地平博昼无众闹夜无音声。无有蚊虻蝇蜂毒螫之属。我当买之为佛故立僧伽蓝。即作是念。彼只陀王子有好园。于舍卫国不近不远行来游观。其地平博昼无众闹夜无音声。亦无蚊虻毒螫之属。我今宁可往只陀王子所求索买之。彼即往王子所。白言。佛已出世。天今知不。已受我请。于舍卫国夏安居。可以此园卖之。我当与百千金钱。彼言不卖。复更重白如上。愿与我园当与二百三百四百千金钱。彼言。汝若以金钱侧布满地令无间者我亦不与。给孤独食言。汝已决价。便可受之。王子言。云何决价。答言。向者言以金钱侧布满地令无间者。岂非决价言耶。天便可看王昔日旧制。彼即看王旧制已。作是言。便为决价。即语言。长者随汝意。时给孤独食。还家敕人出多金钱侧布只陀园中。有余少地布金未遍。只陀见已。便作是念。此非是常人亦非常福田。乃令给孤独食为之不惜珍宝如是。即言。长者汝止。勿复布金。余地我自欲奉上世尊。给孤独食言。便可随意。尔时世尊。从王舍城。与千二百五十比丘俱。人间游行至跋阇国。复转诣毗舍离。时六群比丘。先佛前往取房舍。为和尚同和尚阿阇梨同阿阇梨。为知识亲厚故即舍利弗与目连俱后至。佛言。此是谁房。六群比丘言。是我和尚同和尚阿阇梨同阿阇梨知识亲厚房。舍利弗目连不得房宿。宿外埵上。舍利弗目连夜过已。往世尊所头面礼足却住一面。世尊知而故问。舍利弗目连。卧起安乐不答言。安乐。世尊问言。在何处宿。答言。在外埵上。以何事故尔。即具以因缘白佛。尔时世尊以此因缘集比丘僧告言。汝等谓谁应受第一坐第一水第一食起迎逆礼拜恭敬善言问讯耶。或有言大姓出家者。或有言颜貌端正者。或有言阿兰若者。或有言乞食者。或有言粪扫衣者。或有言作余食法不食者。或有言一坐食者。或有言一抟食者。或有言冢间者。或有言露坐者。或有言树下者。或有言常坐者。或有言随坐者。或有言三衣者。或有言能呗者。或有言多闻者。或有言法师者。或有言持律者。或有言坐禅者。佛告诸比丘。汝等善听。应与不应与。乃往过去世时。有三亲友象猕猴鵽鸟。依一尼拘律树住。彼作是念。我等共住。不应不兴恭敬更相轻慢。宁可推年大小次第尊卑更相恭敬。若年长者。当尊重恭敬供养。作如是法已。依林间共住。猕猴鵽鸟共问象言。汝忆事近远。象言。我忆小时此尼拘律树我行时触我脐。象与鵽问猕猴言。汝忆事近远。猕猴答言。我忆小时此尼拘律树举手及头。象语猕猴。汝生年多我。象与猕猴共问鵽言。汝忆事近远。答言。我忆雪山王右面有大尼拘律树我于彼食果来此便出即生此树。彼作是念。鵽生年多我。时象即以猕猴置头上。猕猴以鵽置肩上。共游行人间。从村至村。从城至城。而说法言。其有敬长老者。是人能住于法。现世有名誉。将来生善道。尔时鵽说如是法。人皆随顺。法训流布。汝等于我法律中出家。应更相恭敬如是佛法可得流布。自今已去。听随长幼恭敬礼拜上座迎逆问讯。时诸比丘闻佛教。诸比丘长幼相次恭敬上座。彼礼拜白衣言。汝生年长我。佛言。不应礼白衣。汝等应礼不应礼。一切女人不应礼。前受大戒者不应礼后受大戒者。言犯边罪犯比丘尼。贼心受戒坏二道黄门。杀父杀母杀阿罗汉。破僧恶心出佛身血。非人畜生二根。若被举若灭摈若应灭摈。一切非法语者不应礼。何等人应礼。少沙弥尼。应礼大沙弥尼沙弥式叉摩那比丘尼比丘。如是等人塔一切应礼。若少年沙弥。应礼大沙弥沙弥尼式叉摩那乃至比丘。及塔一切应礼。小式叉摩那。应礼大式叉摩那比丘尼比丘。及塔应礼。年少比丘尼。应礼大比丘尼比丘。及塔亦应礼。小比丘。应礼大比丘。大比丘塔亦应礼。一切诸天世人诸魔梵王沙门婆罗门。皆应礼如来世尊。塔亦应礼。世尊既有是教。应礼塔。彼便礼白衣塔庙。佛言。不应礼白衣塔庙。彼既不得礼白衣塔庙。便左绕行护塔庙神嗔。佛言。随本所来处行。不应故左绕行。诸比丘作如是念。沙弥当以生年为次第为以出家年为次第。佛言。应以生年为次第。若生年等者。应以出家年为次第。彼比丘先至。后有比丘来大。一夜便移前比丘。佛言。不应移亦不应起。听在中间坐。既在中间坐。复更相移动。令众乱闹。佛言。听后来者在下坐。既在下坐。乃在白衣下坐。佛言不应尔。彼复在沙弥下坐。佛言。不应尔。应在大比丘下坐。彼不及后安居受大戒数以为岁。佛言。不应尔。和尚阿阇梨。应教受戒时节。作如是教。若冬若春若夏。汝得若干日。若一月若半月若一日。若前食若后食时。乃至量影时。六群比丘。在白衣家见上座来不起。此非僧地。佛言。不应尔应起在水边树下石边草上舡上不起。避上座言。此非僧地。佛言。应起。尔时有居士。为僧作房。而无人住。彼作如是言。大富长者多饶财宝为僧作房。沙门释子便在中住。我曹贫穷谁当住此。诸比丘白佛。佛言。众僧应与比丘白二羯磨。应作如是与。众中差堪能羯磨者。如上作如是白。大德僧听。今僧以此某甲房与某甲比丘料理。若僧时到僧忍听。白如是。大德僧听。此某甲房与某甲比丘料理。谁诸长老忍。僧以此某甲房与某甲料理者默然。谁不忍者说。僧已忍。以某甲房。与某甲比丘料理竟僧。忍默然故。是事如是持。时诸比丘欲作房。佛言听。彼欲平地。佛言听。若有石树根棘刺应却。若有坑渠处低下处应填平。若虑水应设堤障。若恐地有主或致余言者。应决了分明。若有大树株若石。应掘出。若不能出。烧去。若不可去。烧已以水若苦酒浇。若以石椎打破出。若难破。以铁椎打破出。若复不可出者。于边作大坑深埋。彼欲平地应耕已磨平之。不知谁当应平。佛言。若比丘若沙弥若守僧伽蓝人若优婆塞。彼须墼。听作。若自作若教人作。彼须墼摸。听与。若泥着墼摸。佛言。应以弊物内水中已拭四边。作墼处有草。佛言。应在无草处。若墼不燥。应反。若反时断草不犯墼不齐。应刬令齐若燥应积之。若天雨渍应覆上。若风吹上覆。应以木石镇上。若患牛羊畜生食上覆草应以泥。泥上彼须户应与户。彼于户边作龙蛇像。佛言。不应作如是像。听作蒱挑蔓若莲华像。彼欲于户上作华像听作。彼作兵马像。佛言。不应作。应以紫色若朱若五种色。彼倚色脱。佛言。不应倚。彼上座老病比丘及远来比丘不倚身不安。佛言。听以草叶树皮十种衣中以一一衣着背后倚之。彼比丘昼日多人处胁着地眠。诸居士见皆共讥嫌言。沙门释子自称觉悟。而自昼日胁着地眠耶。诸比丘白佛。佛言。不应尔。彼上座老病远来比丘昼日不眠疲极。佛言。听入房内闭户而眠。彼驱遣病人。佛言。不应遣病人。亦不应去。彼六群比丘托病不避上座。诸比丘白佛。佛言。不应尔。彼病比丘在阁上大房中住。大小便唾污秽臭处不净。佛言。病比丘不应在阁上大房中住。应在小房中住。若别作小屋。彼病比丘不能至大小便处。佛言。听在近处凿坑安大小便处。若不能出房。听屋中安便器。若不能起离床。佛言。听穿床作孔便器着下。彼唾房中污洒地。佛言。不应尔。彼上座老病比丘数起疲极。佛言。听作唾器。彼于多人住处舍虱弃地。佛言。不应尔。彼上座老病比丘数数起弃虱疲极。佛言。听以器若毳若劫贝若弊物若绵拾着中。若虱走出。应作筒盛。彼用宝作筒。佛言。不应用宝作筒。听用牙若骨若铁若铜若铅锡若竿蔗草若竹若[竺-二+韋]若木作筒。虱若出应作盖塞。彼用宝作塞。佛言。不应用宝作。应用牙骨乃至木作。无安处。应以缕系着床脚里。时比丘分房。有比丘得破坏房。彼作如是意。或令我修治即不取。佛言。应受。随力多少应治。彼欲治房。佛言。听治一切所须之具应供给。尔时世尊从毗舍离人间游行。经跋阇国至舍卫国。与千二百五十比丘俱。时给孤独食。闻世尊从彼来至舍卫国。即乘车往迎。遥见佛来。即下车前诣佛所。头面礼足却住一面。时世尊无数方便为给孤独食种种说法开化。令得欢喜已。白世尊言。唯愿受我明日请食。于只桓宿。世尊默然受之。时给孤独食。知佛受请已作礼而去还家。即于其夜办种种肥美饮食。清旦往白时到。世尊着衣持钵。往诣食堂就座而坐。给孤独食。手自斟酌种种美食。供养佛及众僧令满足。舍钵持金瓶授水已。白佛言。我以此只桓园奉上世尊。唯愿受之。佛言。居士。汝可持此园奉佛及四方僧。何以故。居士。若是世尊园园物房舍房舍物衣钵坐具针筒便是塔庙。一切诸天世人沙门婆罗门魔梵无能用者。即如教以园奉佛及四方僧。唯愿世尊。慈愍受之。尔时世尊。说偈劝喻

  种殖园果树　　若设于桥船
  旷野施泉井　　及与房舍施
  如是之人等　　昼夜福增益
  如法常持戒　　后得生善道

时给孤独食。头面礼足已却坐一面。世尊无数方便种种说法开化令得欢喜。给孤独食闻法欢喜已礼足而去。时只桓园牛羊来入无有禁限。佛言。掘作堑障。彼上座老病比丘行时不能度。佛言。听作桥。而不知云何作。应以板若木作。若安绳索连系。上座老病比丘度桥时脚跌倒地。佛言。听两边安索手捉顺而度。若捉索故倒地。应两边安栏楯。若堑不牢。应重作篱障。若无门听作门。若篱不坚牢应捣墙。作墙所须者一切应与。若不牢应作重楼阁。时只陀王子。欲为只桓作大贵价重门。佛言听作。时只桓园树不好。佛言。听种三种树。华树果树叶树。时上座众所知识比丘于舍卫食已还只桓患热。佛言。听以草若树叶障。十种衣中听一一衣障作荫。若故热应循阶道边种三种树如上。时只桓去水远。听作渠通水。患渠坏。佛言。听以草遮若草烂坏。复应以甎石若木遮。若复作井。作井所须一切听与。若出井泥器破。听以木压四边持器着中。若故破坏。听以毛氀囊盛。若故复破。听以皮革作。若绳断。听以皮作。比丘不惯作患手痛。听转轮牵。若轮孔坏。听以铁作。若患水还来入井。应以石若甎木障四边。若患洗处泥。应安甎石。若患小儿堕井。应以木若瓦甎石作栏遮。若牵泥器绳断堕井。应以钩钩取。彼无安井索处。佛言。听近井边作架着上。时只桓无浴室。佛言。听作。不知云何作。佛言。听若四方若圆若八角。彼在屋前作。佛言。不应尔。应在边屏处作。彼患浴室冷。佛言。听作尸。患烟听上开孔。患闇。应开窗。患泥。应以石甎若木作浴床。患泥污脚。应以石甎堲地。若木头差跌。应凿作狗牙相压。时六群比丘。上座欲得凉便闭户。欲得热便开户。诸比丘白佛。佛言。应随众僧所欲应与。彼六群比丘先入浴室在好处坐。上座后来入无处。诸比丘白佛。佛言。应随次处坐彼上座不入其处空。佛言。次座者应坐。烟熏面。听物遮面。患头热。听覆。患背热。听遮。若身污臭。听以泥洗。彼比丘疑。不敢以香着泥中。佛言。听着。浴室里地患热。应浇令冷。彼共白衣浴。更相看尾。某甲长某甲粗。诸比丘白佛。佛言。不应共白衣浴。若称叹佛法僧者听浴。时诸比丘以衣着露地天雨渍。佛言。听叠着壁上龙牙杙上若衣架上。彼患烟黑污衣。佛言。听别作衣屋。彼露形为露形者揩身。佛言。不应尔。彼露形者为不露形者揩身。佛言。不应尔。彼不露形者畏慎疑。不敢与露形者揩身。佛言听。彼露形者为露形者剃发。佛言。不应尔。彼露形者为不露形者剃发。佛言。不应尔。彼不露形者为露形者剃发。佛言。不应尔。彼露形嚼杨枝。佛言。不应尔。彼露形洗手脚面。佛言不应尔。彼露形食。佛言不应尔。彼露形大小便。佛言不应尔。彼露形者礼露形者。佛言不应尔。彼露形者礼不露形者。佛言不应尔。彼不露形者礼露形者。佛言不应尔。彼露形道行。佛言不应尔。彼露形经行。佛言不应尔。时只桓浴室去水远。听通渠凿井如上若水少应大作渠。彼汲水患手痛。听安[木*絜]槔。彼不知储水何处。听着瓮中。被天雨时患浇湿衣服。听井上安屋。时比丘露形汲水。见妇女来惭愧便坐。诸比丘白佛。佛言不应尔。时诸比丘在泉若渠若池水中浴。时龙女嗔嫌。诸比丘白佛。佛言不应尔。听四种覆障浴。若有墙壁障处。若树木草障处。若水障身。若衣障身。彼在上三处洗浴者。若有所须听互相取与。以衣障身者。一切如法。经营浴事得作。若水少应大开通水处。若患水漏下多。应在边更作小漏处。诸比丘露地浴得患。佛言。听别作小浴室。若患地泥。听安甎石若木若碎石若沙。若故泥应决去水。时诸比丘露处温水天雨湿衣。佛言听作温水屋。时诸比丘安薪露地天雨湿。佛言听作安薪屋。时有比丘露地看煮食天雨湿衣浇污净人饮食器物。佛言听作净食厨屋。时诸比丘白衣家为设饮食受请往道路遇天雨浇湿衣服。佛言。听在聚落间别安僧伽蓝处。时诸比丘露处大小便。有妇人见之。比丘疾疾起。大便不竟遂成患。佛言听作厕屋。彼安一大便处。便时多人立待。佛言应作众多处。若当户见应作障。若更相看应作隔障。彼上座老病比丘大小便起时倒地。听在边安栏架。彼在处处拭大便。或在壁角或在石上或草上。佛言不应尔。听别作洗处。彼处处小便泥污地。佛言不应尔。应在边一处小便。若故患泥污。应别作小便处。不知云何作。佛言。听掘地作坑下安石持瓮着上开瓮底漏下瓮两边安木。若患气臭作盖覆。时诸比丘露地经行。有蛇蝎蜈蚣百足。未离欲比丘见恐怖。佛言。听作悬经行处。不知云何作。佛言。下竖柱上安板木阁道行。若患风雨日曝。听作屋覆。尔时世尊在拘睒弥。六群比丘于好彩画严饰房中然火炙烟熏污房污卧具。佛言不应尔。时诸比丘冬月患寒。听露地燃火炙。露地坐患背冷。听在外燃火令烟尽持炭入屋。若不相容受。应别作燃火堂。不知云何作。佛言。听四方作若圆若长作。彼处处安胡窖。佛言不应尔。听当在中安火炉。时诸比丘得有轮火炉。佛言听畜。不知谁当推行。佛言。沙弥若比丘若守僧伽蓝人。彼比丘不惯吹火吹火得患佛言听作筒吹彼用宝作筒。佛言不应用宝。听用牙角骨若铜铁舍罗草筒若竹苇若木作。若患筒口燋。听安铁鍱窖中薪火堕应上。若患烧手作钳。彼用宝作钳。佛言不应尔。听用骨牙角铜铁木作。若患头烧。听安铜铁鍱。彼欲聚火作把推聚若欲种火。应作火坑安火。若恐火灭以灰覆上时诸比丘冷水洗面手脚患冷。佛言听暖水洗。不知云何暖。佛言澡罐盛水着火边。若澡罐多若火边不容者应安三揭杖瓶盛水着上暖。瓶大妨火。应作绳悬。若绳烧以筒盛绳若筒烧以泥泥。泻水时筒折。佛言应以余器率取。泻水瓶中时患弃水。应作澍水筒。若悬绳断上安铁镮钮。时诸比丘冬月洗脚患冷。佛言。应安澡盘洗脚器在屋里洗。洗脚所须应与。时比丘早起油涂脚已入聚落乞食。女人接足礼油污手捉比丘钵余比丘见恶之。诸比丘白佛。佛言不应早起油涂脚入聚落乞食。诸比丘脚劈破。听涂足跟足底油涂至指奇。时众僧得一重房。佛言听住。尔时世尊。从摩竭国至旷野城。时六群比丘。为世尊以男女形像文绣庄校堂屋。佛言不应尔。听用余杂色禽兽文者。时众僧得两房一户重屋。佛言听住。尔时世尊在舍卫国。尔时阿难得别房。佛言听畜。尔时罗睺罗。在那梨林中住。时那梨有居士。无人劝化。自发意作房舍。施罗睺罗。时罗睺罗。此房住已人间游行。时彼居士。闻罗睺罗在房住已人间游行。便以房舍施众僧尔时世尊。从摩竭提人间游行。至那梨林中敷座而坐。时罗睺罗。闻居士以房施众僧。便往至世尊所。头面礼足已却坐一面。白佛言。那梨有居士。无人劝化。自发意作房施我。我于房住已出人间游行。后居士即复以房施众僧。佛告罗睺罗。听汝往彼居士所语言。汝将无见我有可呵事不清净非沙门法若口说若身行邪。时罗睺罗受世尊教已。往居士所具向居士说如上语。居士答言。我不见汝有可呵责事非沙门法若口说若身行不清净。时罗睺罗往世尊所。头面礼足却坐一面。白佛言。世尊。向者所敕。我具为居士说之。居士答我言。我不见汝有可呵责事于沙门法亦无有不清净若口说若身行。时世尊以是因缘集比丘众告言。汝等善听。非法施非法受非法住。如法施如法受如法住。云何非法施非法受非法住。或有人自心喜乐作房。施一人已复施众多人。是为非法施非法受非法住。施一人已复以施僧亦如是。施一人已僧破为二部。施与已所同部亦如是。施一人已施与异部亦如是。或有人自心喜乐作房。施众多人已复施众僧。是为非法施非法受非法住。施众多人已僧破为二部。施已所同部亦如是。施众多人已施与异部亦如是。施众多人已施一人亦如是。作房施僧已。转施与余人亦如是。作房已施已所同部亦如是。作房已施与异部亦如是。是为非法施非法受非法住。云何如法施如法受如法住。或有人喜乐自作房。施一人是为如法施如法受如法住。施众多人施僧施二部僧亦如是。是为如法施如法受如法住。尔时世尊。于迦尸国人间游行。与五百比丘俱。时羁连国有四旧比丘。阿湿鞞不那婆娑般陀楼醯那。时四比丘闻世尊与五百人俱人间游行当来至羁连。世尊有二弟子舍利弗目连来至此。恐驱我等出此住处。我等宁可选择上房与世尊。余者分为四分。以为私有。僧伽蓝僧伽蓝物。房舍房舍物。作第一比丘分。盆瓶瓮釜镬斧凿。灯台诸杂重物作第二比丘分。绳床木床大褥小褥卧具杂物作第三比丘分。余林木竹草花果叶作第四比丘分。时四比丘即选上房留世尊。余者如上分为四分。时世尊从迦尸国人间游行。至羁连敷座而坐。告舍利弗目连。汝往语彼旧比丘。世尊与五百比丘俱来迦尸国。汝今可为诸比丘敷置卧具。舍利弗目连受世尊教已。往旧比丘所如所教敕敷卧具。彼比丘答言。世尊是法主。便可随意住止。我等先已选上房留世尊。余者分为四分如上。无客比丘卧具。时舍利弗目连。往世尊所头面礼足却坐一面。以此因缘具白世尊。世尊以此因缘集比丘僧。告言。此四分物。是四方僧物。不应分。不应自入。不应卖买。亦非僧所卖。非众多人乃至一人所卖。若彼僧众多人一人。自入己若分若卖买者。不成自入。不成分。不成卖买。犯偷兰遮。何等四方僧物僧伽蓝僧伽蓝物。房房物。此是第一分四方僧物。不应分。不应自入。不应卖买。若僧若众多人若一人。不得分。不得自入。不得卖买。若僧若众多人若一人。若分若自入若卖买。不成分。不成自入。不成卖买。犯偷兰遮。第二第三亦如是。第四分中果叶听分。若花上佛余者同上

四分律卷第五十四分律卷第五十一(第四分之二)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    房舍揵度之余

尔时世尊在舍卫国。时有比丘在僧地中作私房。有上座客比丘来语言。起避上座。彼答言不起。问言何故耶。答言是我私房。诸比丘白佛。佛言。应语令起。若起者善。若不起应语言。还僧地。更无有理。以僧地入已。有比丘卒成屋不坚牢。佛言不应尔。彼便尽形寿经营一房屋不时成。佛言不应尔。若作极上大好重阁堂。听十二年经营。余者随大小量宜。彼经营人一切时春夏冬受僧常营事房。佛言不应尔。听夏三月竟随上座分。时有比丘。通经营僧伽蓝便处处取房分。佛言不应尔。应九十日取一处住。彼经营人在众多人住处住。食堂温室经行堂。令客比丘无住处。佛言不应尔。若下堂众多人住处。应在上堂住。若上堂众多人住处。应在下堂住。彼作小小经营泥壁若补缺若平地。便索营事者房。佛言不应尔。彼差沙弥僧伽蓝人便作营事人。佛言不应尔。彼作小房索营事者房。佛言不应尔。若所作房受绳床木床者。听与营事房。彼作恶房。便索营事者房。佛言不应尔。若所作房庄严香薰所须具足者听与房。时有营事比丘。受房已命过。诸比丘不知此房属谁白佛。佛言随僧。时有营事比丘。遣人白僧索房。彼比丘至僧中索房已。营事比丘便命过。诸比丘不知此房与谁。佛言随僧。营事比丘遣人僧中索房已。彼使比丘命过。诸比丘不知此房与谁。佛言应与彼营事者。时营事人夏安居中命过。诸比丘不知此房与谁。佛言随僧。时有比丘作房未覆舍行。时客比丘语旧比丘言。可覆此房。旧比丘答言。作者应覆。诸比丘白佛。佛言。听作极大好重阁房六年内覆。成余小者随事量宜。时有一比丘作房。有异比丘覆。彼二比丘共诤先后治屋。诸比丘白佛。佛言。先作者应先治。时有二比丘共作房。二人共诤前后作。佛言。听更互作上座在先。时营事比丘。夏安居受所治房复受余房。佛言不应尔。即所住房作安居房。尔时世尊在拘睒弥。时王优填。与跋难陀亲厚王请在拘睒弥夏安居。时跋难陀受请安居已。闻有异处安居僧大得衣物。即往彼处少时住已还拘睒弥。时王优填闻已讥嫌。云何跋难陀。受我请夏安居已。闻有异处僧大得夏安居衣物。而往彼住后还来此。时诸比丘闻。往世尊所。头面礼足却坐一面。以此因缘具白世尊。世尊尔时。以此因缘集比丘僧。呵责跋难陀释子言。云何受请在拘睒弥夏安居。闻有异处僧大得夏安居衣物。便往彼住已复还此耶。无数方便呵责已告诸比丘。若比丘此处安居。闻有异处僧大得夏安居衣物。而往彼住即失此处。于彼少住已。复还此处复失彼处。尔时众僧房舍故坏。有异居士言。若与我者我当修理。诸比丘白佛。佛言听与。白二羯磨应如是与。众中应差堪能羯磨者。如上作如是白。大德僧听。若僧时到僧忍听。僧今持此房与某甲居士修治。某甲比丘经营。白如是。大德僧听。僧今以此房与某甲居士修治。某甲比丘经营。谁诸长老忍。僧持此房与某甲居士修治某甲比丘经营者默然。谁不忍者说。僧已忍。与某甲居士房修治某甲比丘经营竟。僧忍默然故。是事如是持。尔时营事比丘。未分房便出行。诸比丘即于后分房。彼营事比丘还问言。留我营事房不。彼答言不。即便嫌责诸比丘言。我未分房出行。而于后便分房。我于此有益。何故不与我房耶。诸比丘不知为成分不成分。佛言成分。应待还。彼亦应嘱人取。时营事比丘未分房出行。嘱余比丘取房。而不指示房处所。彼比丘营处多。此比丘不知与取何房。诸比丘分房已。彼方还问诸比丘分房未。答言已分。为我取房不。答言不。彼即嫌责言。未分房我出行。嘱余比丘为我取房。我于此有益。而不与我取房。诸比丘不知为成分不成分。佛言成分。应待还。彼亦应指授言。取某甲房。彼营事比丘取房已。后分房时。次得好房。便舍前房。诸比丘白佛。佛言不应尔。应从上座更分。若无人取者应与。彼比丘疑不敢捉众僧户钩钥若杖若环若[木*戈]若角杓若铜杓若浴床。佛言听捉。彼不敢从此住处移此诸物至彼处。佛言听移。有五法不应差为僧分粥。设差不应分。若有爱有恚有怖有痴不知已分未分。有如是五法。不应差为僧分粥。已差不应分。有五法应差为僧分粥。不爱不恚不怖不痴知已分未分。有如是五法。应差为僧分粥。若差应令为僧分粥分小食分佉阇尼。差请会敷卧具分卧具分浴衣分衣。可取可与。差比丘使。差沙弥使。一切亦如是。有五法为僧分粥。入地狱如射箭。有爱有恚有怖有痴不知分未分。有如是五法分粥。入地狱如射箭。有五法分粥。生天如射箭。不爱不恚不怖不痴知分未分。有如是五法为僧分粥。生天如射箭。乃至差沙弥使亦如是(房舍揵度具足竟)

    杂揵度之一

尔时世尊在波罗奈。五比丘来至佛所。头面礼足却坐一面。白佛言。我等应持何等钵。佛言。听持迦罗钵舍罗钵。时有比丘入僧中食无钵。佛言听比坐与。若僧中有此二种钵者借与。时有比丘蛇吐毒钵中不洗持用食食已得病。诸比丘白佛。佛言。不应不洗钵用食。听洗已用食。时诸比丘发长。佛言听剃。若自剃若使人剃。彼须剃刀听作。彼用宝作[標-示+(革*月)]。佛言不应用宝。听用铜铁。彼露捉刀难掌护。佛言听作刀鞘。彼用宝作。佛言不应用宝。听用骨牙角铜铁白镴铅锡舍罗草竹苇木作。彼作刀鞘。患动坏刃。应以物障。若毳若劫贝若犬皮。若堕落应以綖连缀。若手捉难掌护。应作囊盛。若从囊口出。应以绳系之。若手捉行恐失。绳系络着肩。时比丘用刀刀卷听手上磨。若故卷应石上磨。手捉石恐失。应盛着刀囊中。若刀钝应刮刃。若自刮教人刮。彼须刮刀。佛言听作。时比丘剃发。患发着衣。佛言听畜承发器。不知云何作。听织竹作若屈木为卷以树皮鞔之若十种衣中一一衣听作承发器。彼持承发物着地。用时着膝上。泥土污衣。佛言不应尔。听以绳悬若安[木*戈]上。时比丘患鼻中毛长。佛言听拔。若自拔若令人拔。彼须镊。佛言听作。彼用宝作。佛言不应用宝作。听用骨牙角铜铁白镴铅锡作。若患镊头破。听头安铁。手捉难掌护。听着剃刀囊中。时比丘爪长。佛言听剪。若自剪若令人剪。彼须剪爪刀。佛言听作。彼用宝作。佛言不应用宝。听用铜铁。手捉难掌护。听作筒盛。彼用宝作筒。佛言不应用宝。听用铜铁白腊铅锡竹木作患筒中出。应作盖塞。彼用宝作盖。佛言不应用宝。听用铜铁若白腊铅锡竹木。若趣着一处患零落。听着刀囊中。尔时有比丘爪长至一白衣家。此比丘颜貌端正。白衣妇女见已便系意于彼比丘。即语比丘言。共我作如是如是事。比丘言。大姊。莫作是语。我等法不应尔。彼妇女言。若不从我者。我当自以爪爬身面破已。我夫还时当语言。彼比丘唤我作如是事。我不从彼便爪爬破我身面如是。时比丘闻已愧惧。便疾疾出其家。比丘亦出。其夫亦从外入。彼妇即自爬破身面语其夫言。比丘唤我作如是事我不从便爬破我身面。其夫即疾疾逐比丘语言。汝欲犯我妇。我妇不从。便爬破身面耶比丘答言。居士莫作是语。我等法不应尔。彼便言。汝云何言不应尔。汝爪长如是。彼即打比丘次死。诸比丘白佛。佛言不应畜长爪。时六群比丘剪爪令血出。佛言不应尔。彼剪爪令如半月形。佛言不应尔。彼剪爪令头尖。佛言不应尔。彼磨爪令光出。佛言不应尔。彼以彩色染爪。佛言不应尔。佛语比丘。汝曹痴人。避我所制更作余事。听诸比丘皮次剪爪。不知长短几许应剪。佛言。极长如一麦应剪。时六群比丘以剪刀剪须发。佛言不应尔。彼剃发不剃须。佛言应剃须发。彼剃须不剃须。佛言应剃须发。彼拔发。佛言不应尔。彼留发佛言不应尔。彼捻髭令翘。佛言不应尔。汝等痴人。避我所制更作余事。自今已去。应须发尽剃。彼比丘不知发长几许应剃。佛言。极长长两指。若二月一剃。此是极长。时六群比丘梳须发。佛言不应尔。彼以油涂发。佛言不应尔。六群比丘画眼睑。时诸居士见皆共讥嫌。沙门释子多欲无厌。自称言。我知正法。如是何有正法。犹若白衣。诸比丘白佛。佛言。不应如是画眼睑。时诸比丘患眼痛。佛言听着种种药。时六群比丘镜照面或水中照面或以物摩壁令光出照面。时诸居士见皆共讥嫌。沙门释子多欲无厌。自称言。我知正法。如是何有正法。以镜照面犹如白衣。诸比丘白佛。佛言不应尔。时比丘患面疮。佛言听余比丘着药。若独在一房。听以水镜照面着药。彼比丘治身治发。佛言不应尔。彼比丘唾身揩摩。佛言不应尔。彼于露处洗浴。时诸居士见皆共讥嫌。沙门释子多欲无厌。自称我知正法。如是何有正法。露处洗浴犹如白衣。诸比丘白佛。佛言不应尔。时有比丘作如是意。自椎打肩臂欲令粗好。佛言不应尔。彼作如是意。以香涂身。为香好故。佛言不应尔。时诸比丘患身汗臭。佛言听作刮汗刀。彼用宝作。佛言不应用宝。听用骨牙角铜铁铅锡舍罗草竹木作。时六群比丘作刮汗刀。头似剃刀形。刮汗并欲去身毛。佛言不应尔。亦不应畜如是刀。时病疮比丘以粗末药洗患痛。佛言。听以细末药若细泥若叶华果。随病比丘便身。听洗病者种种疮乃至患汗臭。时六群比丘着耳铛佛言不应尔。时六群比丘耳轮上着珠。佛言不应尔。六群比丘着耳环。佛言不应尔。六群比丘以多罗叶若铅锡作环张耳孔令大佛言不应尔。彼六群比丘缠裹耳睡。佛言不应尔。彼作铅锡腰带。佛言不应尔。彼着颈璎。佛言不应尔。彼着臂脚玔。佛言不应尔。彼着指环。佛言不应尔。彼用五色綖络腋系腰臂。佛言不应尔。彼着指印。佛言不应尔

尔时世尊在王舍城。时有外道六师。与弟子共住。时不兰迦叶。与弟子九万人俱。末佉罗瞿奢罗。与弟子八万人俱。如是转减。乃至尼揵子。与四万人俱。时王舍城有长者。是六师弟子。得大段旃檀木。即用作钵。以宝作络囊盛之。于中庭竖高标安着其上。唱言。若此王舍城。有沙门婆罗门。是阿罗汉有神力者。可取此钵去。时富兰迦叶。至长者所语言。我是阿罗汉。有大神力。可持此钵并囊与我。长者语言。汝若是阿罗汉有大神力与汝。汝可往取。彼欲取而无由得。时末佉罗瞿奢罗阿夷头翅舍钦婆罗波瞿迦旃延讪毗罗吒子尼揵陀若提子等。至长者所作如是言。我是阿罗汉有神力。可以此钵并囊与我。长者言。若汝是阿罗汉有大神力者与汝。汝可往取。彼欲取而无由得。尔时宾头卢大目连。共在一大石上坐。宾头卢语目连。汝是阿罗汉。世尊记汝神足第一。汝可往取。目连言。我未曾白衣前现神足。汝亦是阿罗汉有大神力。世尊记汝师子吼最为第一。汝可往取。时宾头卢闻目连语已。即合石踊身虚空。绕王舍城七匝。国人皆东西避走言石欲堕。时彼长者在阁堂上。遥见宾头卢在虚空中。即合掌作礼作如是言。取此钵宾头卢。宾头卢即取钵。长者复言。小下住宾头卢。宾头卢即小下住。时彼长者。从手中取钵盛满美食与。时宾头卢取钵已。还以神足力乘虚而去。诸比丘闻中有少欲知足行头陀乐学戒知惭愧者。嫌责宾头卢言。云何在白衣前现神足。时诸比丘往世尊所。头面礼足却坐一面。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。知而故问宾头卢。汝于白衣前现神足耶。答言实尔。时世尊无数方便呵责宾头卢。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何于白衣前现神足。犹如淫女为半钱故于众人前自现。汝亦如是。为弊木钵故。于白衣前现神足。不应于白衣前现神足。若现突吉罗比丘不应畜旃檀钵。若畜如法治。若得已成者。听破分与诸比丘作眼药。时诸外道闻沙门瞿昙制诸比丘不得于白衣前现神足。彼沙门所制终不更犯。我等今宁可往彼所语言。汝沙门瞿昙自称得阿罗汉。我亦是阿罗汉。自称有神通。我亦有神通。自称有大智慧。我亦有大智慧。今可共现过人法神力。若沙门瞿昙现一过人法。我当现二。若现二我当现四。沙门瞿昙现四过人法。我当现八。若现八。我当现十六。若现十六。我当现三十二。若现三十二。我当现六十四。若所现转增。我现亦转一倍时诸外道在城街巷处处唱言沙门瞿昙自称有神力。我亦有神力。自称有大智慧。我亦有大智慧。我等今欲共沙门瞿昙捔现神力过人法。若沙门瞿昙现一。我当现二。如是沙门瞿昙所现多少。我当现转增一倍。时王舍城中有一处。其地广大平博。时彼长者多持华香璎珞伎乐幢幡饮食衣服医药卧具。欲于此处供养外道婆伽婆。时彼长者。欲取华供养外道。手入器辄不得出欲取香花璎珞幢幡伎乐饮食衣服医药卧具。随所取手皆着器而不得出。时彼长者。欲取华供养佛时。随手所取而无所碍。如是随手所取。乃至医药卧具而无所碍。彼作如是念。未曾有。世尊有如是大神力。时彼长者即白佛言唯愿世尊。与大比丘僧。受我明日请食。尔时世尊默然受请。时彼长者。见世尊默然许可前礼佛足绕佛而去即还其家竟夜办种种肥美饮食。明日清旦往白时到。尔时世尊着衣持钵。与大比丘僧千二百五十人俱。往彼长者家。时世尊动足行处大神力。天在虚空中。以天曼陀罗华旃檀末香天忧钵罗钵头分摩拘牟头分陀利华。以散佛行迹处。作天伎乐歌颂赞佛。时彼长者。随从世尊作是念。今此音声。为从地出。为从上来。仰视空中。遥见天曼陀罗华乃至分陀利华及天伎乐住在空中。便作是念。此音不从地出。乃从上来。时世尊至长者家就座而坐。时诸外道闻。作如是念。彼长者由来供养我诸外道。今乃更请佛及僧饮食。我今宁可往令彼供具不足。即便与眷属俱往长者家。守门人见诸外道与眷属俱来。即往白长者言。知不。今诸外道与眷属来。当听入不。长者言。莫听入。佛言长者。可听入。长者白佛。外道众多。此处窄狭。恐不容受。佛言但听入。足相容受。长者复言。外道众多坐处窄狭饮食有限。本为千二百五十人设供。今恐不供足。佛告长者。但听入。足相容受。饮食供足。尔时世尊。以神足力令地平正广博东西观。时无数百千高座自然而有。南西北方亦复如是。时世尊与大比丘僧千二百五十人并外道俱坐。时彼长者。设种种美食供养佛比丘僧及诸外道。一切充足食已舍钵。更取卑床于佛前坐。时世尊为长者无数方便说法教化令得欢喜。为长者说法已。从坐而去。尔时诸外道。与眷属俱。往瓶沙王所。合掌顶上言。愿王常胜。白言。沙门瞿昙自言是阿罗汉。我亦是阿罗汉。沙门瞿昙自言有神通。我亦有神通。沙门瞿昙自称有大智慧。我亦有大智慧。我等今欲共沙门瞿昙捔胜神力及过人法。若沙门瞿昙现一。我当现二。如是随沙门瞿昙所现多少。我尽倍之。大王。我今欲共沙门瞿昙捔现神力过人法。时瓶沙王。往诣佛所头面礼足却坐一面。以向因缘具白世尊。唯愿世尊。与外道捔现神力及过人法。世尊告王言且止我自知时。可现当现。明日当去随王所欲。世尊明日。与大比丘众俱。从王舍城去。时瓶沙王。以五百乘车载种种美食从世尊后。时诸外道闻世尊清旦出王舍城去。作是言。沙门瞿昙。不能与我等共捔神力便去。王瓶沙五百乘车载种种美食为我等。不为彼瞿昙沙门。我曹今可随彼去到所至之处唤共捔神力过人法。彼即随世尊后去。时王瓶沙闻佛清旦与千二百五十比丘从王舍城去。王从八万四千人俱随世尊后。梵身天释提桓因四天王诸天无数百千大众随从世尊后。时世尊往优禅城。优禅城王。名波罗殊提。摩竭国诸外道。优禅城诸外道。俱共往波罗殊提王所。合掌顶上赞言。愿王常胜。沙门瞿昙自称言是阿罗汉。我亦是阿罗汉。自称言有神力。我亦有神力。自称言有大智慧。我亦有大智慧。我等于王舍城中求共捔神力过人法。而沙门瞿昙。不能与我捔神力过人法。我等今欲共捔神力过人法。若沙门瞿昙现一。我当现二。如是随沙门瞿昙所现多少我尽倍之。时王波罗殊提。即往佛所头面礼足却坐一面。以此因缘具白世尊。善哉世尊。可共诸外道现神力过人法。尔时世尊告波罗殊提王言。且止。我自知时。可现当现明日当去随王意。时世尊明日清旦从优禅去。波罗殊提王。五百乘车载种种美食从世尊后。时诸外道闻世尊去。作如是言。沙门瞿昙。不能与我共捔神力过人法便去。王五百乘车载饮食为我等不为彼。我当随去到所至处与共捔神力过人法。彼即随世尊后而去。时王瓶沙闻世尊去。与八万四千人俱。波罗殊提王与七万人俱。释梵四天王诸天大众。无数百千眷属围绕从世尊后。世尊往拘睒弥国瞿师罗园中住。时优陀延为王。摩竭国诸外道。优禅国诸外道。拘睒弥诸外道俱往优陀延王所。合掌顶上赞言。愿王常胜。白如是言。沙门。瞿昙自称言是阿罗汉。我亦是阿罗汉。自称言有大神力。我亦有大神力。彼自称言有大智慧。我亦有大智慧。于摩竭国优禅国求共捔神力过人法。沙门瞿昙。不能与我共捔神力过人法而去。我等今欲共沙门瞿昙捔神力过人法。沙门瞿昙现一。我当现二。如是随彼所现多少。我尽倍之。时优陀延王。诣世尊所。头面礼足却坐一面。以此因缘具白世尊。善哉世尊。可与诸外道共捔神力过人法。佛告王言止止。我自知时可现当现。明日当去便随王意。明日清旦便去。时王优陀延。五百乘车载种种饮食随世尊后。时诸外道闻世尊去。便作是言。沙门瞿昙。不能与我捔神力过人法便去。优陀延王五百乘车载饮食。而为我等不为彼。我等今随彼所至之处当共捔神力过人法。即便随世尊后去。时瓶沙王与八万四千人俱。优禅王与七万人俱。优陀延王与六万人俱。从世尊后。释梵四天王无数百千诸天大众从世尊后。尔时世尊。往迦维罗卫国尼拘律园中住。时迦维罗卫王梵施。是佛异母弟。摩竭国诸外道。优禅诸外道。拘睒弥诸外道。迦维罗卫国诸外道。共往梵施王所。合掌顶上。愿王常胜。白梵施王言。沙门瞿昙自称言是阿罗汉。我亦是阿罗汉。自称有大神力。我亦有大神力。自称有大智慧。我亦有大智慧。我于摩竭国优禅国拘睒弥国。与沙门瞿昙捔神力过人法。而沙门瞿昙。不能与我捔神力过人法便去。我等今欲与沙门瞿昙捔现神力过人法。若沙门瞿昙现一。我当现二。如是随沙门瞿昙所现多少我尽倍之。时梵施王往诣佛所头面礼足在一面坐。白佛言。愿世尊。现神力过人法。佛告王言。止止。我自知时。可现当现。明日当出迦维罗卫国去可随王意。世尊明日清旦便去。尔时梵施王。即以五百乘车载种种饮食从世尊后。时诸外道闻世尊去。便作是言。沙门瞿昙。不能与我共捔神力过人法。舍我而去。梵施王载五百乘车饮食。而为我等不为沙门瞿昙。今当随其所至之处唤共捔神力过人法。即与眷属逐世尊后。时王瓶沙闻佛去。即与八万四千人俱。波罗殊提王与七万人俱。优陀延王与六万人俱。梵施王与五万人俱。从世尊后。释梵四天王与诸眷属无数百千天人从世尊后。尔时世尊。从迦维罗卫国人间游行。至舍卫国只桓园中住。时舍卫国波斯匿为王。时摩竭国诸外道。优禅城诸外道。拘睒弥诸外道。迦维罗卫诸外道。舍卫国诸外道。皆往王波斯匿所。合掌顶上白言。愿王常胜。作如是言。沙门瞿昙自称言是阿罗汉。我亦是阿罗汉。自称言有大神力。我亦有大神力。自称言有大智慧。我亦有大智慧。我等于摩竭国优禅城拘睒弥迦维罗卫国。欲共捔神力过人法。而不能与我共捔神力过人法便去。我等今欲共沙门瞿昙捔神力过人法。若沙门瞿昙现一。我当现二。如是随其所现多少。我尽倍之。王波斯匿。往世尊所。头面礼足却坐一面。以此因缘具白世尊。善哉世尊。愿现神力过人法。佛告王言。止止。我自知时。可现当现。于腊月十五日中从初一日至十五日。如来当现神力过人法。大王。若欲观如来现神力过人法者便来。时舍卫国有别处。其地平正广博。世尊往彼敷座而坐。时梵天王。偏露右肩右膝着地合掌白佛世尊言。我当为世尊敷高座佛告梵天且止。我自知时。天帝释四天王瓶沙王波罗殊提王优陀延王梵施王波斯匿王末利夫人长者梨师达多富罗那。各各作如是言。我当为世尊敷高座。佛告言汝等且止。我自知时。时诸居士有信外道者。为外道敷价直百千座有信乐恭敬供养世尊者次第从一日至十五日

尔时世尊东面看时。有无数百千诸座自然而有。南西北方亦复如是。中央有自然七宝师子高座。如来坐上。时诸大众皆悉就座。时有檀越次供日者授佛杨枝。世尊为受嚼已。弃着背后。即成大树根茎枝叶扶疏茂盛。时诸大众见世尊如是神力。皆大欢喜得未曾有。厌离心生。时世尊观诸大众得未曾有生厌离心。即为无数方便种种说法令得欢喜。时于座上无数百千人远尘离垢得法眼净此是世尊初日现神力变化。于第二日。此树花生色香具足树花散落周遍大众积至于膝。比丘比丘尼优婆塞优婆私及余大众皆嗅此香气。时诸大众见世尊如是神力变化。皆大欢喜得未曾有厌离心生。时世尊观诸大众得未曾有生厌离心。即为无数方便种种说法令得欢喜。时于座上无数百千人远尘离垢得法眼净。此是世尊第二日现神力变化。于第三日。树果便出色香味具足。其果不摇自落堕地不坏。比丘比丘尼优婆塞优婆私及诸大众。皆共食之。此诸大众见世尊如是神力变化。皆大欢喜得未曾有厌离心生。时世尊观诸大众得未曾有厌离心生。即为说法乃至得法眼净如上。此是世尊第三日现神力变化。尔时有檀越次供第四日者授世尊水。时世尊即取一把水弃之前地。佛神力故。即成大池。其水清净无诸尘秽。饮之无患有诸杂华优钵罗钵头摩拘牟头分陀利华。众鸟异类凫雁鸳鸯鼋龟鱼鳖水性之属。以为庄严。时诸大众见世尊神力如是变化。皆大欢喜得未曾有厌离心生。时世尊观诸大众得未曾有厌离心生。即为说法乃至得法眼净如上。尔时第五日。其池四面各出一河。直流不曲。其水恬净而无波浪。众杂奇华以为庄严。其流水声说法之音。一切众行皆悉无常苦空。一切诸法皆悉无我涅槃息灭。时诸大众见世尊神力如是变化。皆大欢喜得未曾有厌离心生。时世尊观诸大众得未曾有厌离心生。即为说法乃至得法眼净如上。此是世尊第五日变化。于第六日。世尊化诸大众皆一等类无有差降。时诸大众见世尊神力变化如是。皆大欢喜得未曾有厌离心生。时世尊观诸大众得未曾有厌离心生。即为说法乃至得法眼净如上。此是世尊第六日变化。于第七日。世尊在空中为诸大众说法。但闻如来说法声而不见形。时诸大众见世尊神力变化如是。皆大欢喜得未曾有厌离心生。时世尊观诸大众得未曾有厌离心生。即为说法乃至得法眼净如上。第八日时。诸居士信外道者。遣使唤诸外道。汝曹知不。沙门瞿昙已现神力。于今八日。汝曹何故不来耶彼欲来而不得来。时世尊告诸比丘言若使不兰迦叶以坚[革*卬]皮绳缚其身并牛牵之皮绳断身形破坏若不舍己见。而为论议故。终不能来至我所乃至尼犍子等亦复如是。时梵天王。告天帝释言。诸外道人自言。与世尊等。而不能来与世尊捔现神力今可破灭其高座。时天帝释告四天王。诸外道自言。与世尊等。而不能来与世尊捔神力。今可破灭其高座。时四天王。即召风神云雨神雷神告如是言。诸外道自言。与世尊等。而不能来与世尊捔神力。今可破坏其高座令散灭无余。时风神等闻四天王教已。即取外道高座破散令灭无余。时诸外道得风雨飘湿。即入草木丛林山谷窟中。而自藏窜。时有露形斯尼外道波梨子波私婆阇伽。以大石系颈自投深渊。时诸大众见世尊神力变化。皆大欢喜得未曾有厌离心生。世尊即为说法乃至得法眼净如上。此是世尊第八日变化。于第九日。世尊于须弥顶上为大众说法。但闻其声不见其形。时诸大众见世尊如是变化。皆大欢喜得未曾有厌离心生。世尊即为说法乃至得法眼净如上。此是世尊第九日变化。第十日世尊于梵天上说法。时诸大众但闻其声不见其形。时诸大众见世尊如是变化。皆大欢喜得未曾有厌离心生。世尊即为说法乃至得法眼净如上。此是如来第十日变化。于第十一日。世尊于大众中现神足变化。一身为多身多身为一身于近现处若远不见处若近山障石壁身过无阂。游行空中如鸟飞翔。出没于地犹若水波。履水而行如地游步。身出烟焰犹若大火。手扪摸日月身至梵天。时诸大众见世尊如是变化。皆大欢喜得未曾有厌离心生。世尊即为说法乃至得法眼净如上。此是世尊第十一日神足变化。于第十二日。世尊于大众中心念说法。是应念是不应念。是应思惟是不应思惟。是应断是应修行。是时诸大众见世尊神足变化如是。皆大欢喜得未曾有厌离心生。世尊即为说法乃至得法眼净如上。此是世尊第十二日神足变化。于第十三日。世尊为大众说法教授。说法教授者。一切皆炽然。云何一切皆炽然眼炽然色炽然识炽然。眼触炽然。眼触因缘有受。若苦若乐若不苦不乐是亦炽然。谁炽然。贪欲嗔恚痴火炽然。生老病死忧悲苦恼炽然。苦缘是生。耳鼻舌身意亦如是。一切皆炽然。尔时大众闻世尊如是说法教化皆大欢喜得未曾有。即为说法乃至得法眼净如上。此是如来第十三日变化。于第十四日。次供檀越以一掬花授世尊。世尊嗅已掷着空中。以佛神力故。变为万四千华台楼阁。华台楼阁中一切皆有座佛左右面。天帝释梵合掌敬礼。而说偈言

  敬礼丈夫王　　大人最无上
  一切无能知　　世尊所依禅

尔时大众见世尊神力变化如是。皆大欢喜得未曾有。世尊即为说法乃至得法眼净如上。尔时摩竭王瓶沙次十五日设供。即于夜办种种美食。夜过已明日。以种种多美饮食饭佛及僧。并波罗殊提王优陀延王梵施王波斯匿王末利夫人长者梨师达多富罗那。一切大众皆供养满足。食已舍钵。王瓶沙更取卑床于佛前坐。时世尊坏加趺坐。申脚案上。足至案上。时地为六反十八种震动。时世尊足下相轮。轮有千辐。轮郭成就。轮相具足。光明晃曜从轮出光。光照三千大千国土。时摩竭王。见世尊足下轮相如是。即从坐起偏袒右肩右膝着地。白世尊言。世尊。往昔作何福德。得此足下千辐轮相光明晃曜轮中出光光照三千大千国土。尔时佛告瓶沙王。乃往过去世时。有王名利益众生。作阎浮提王。时阎浮提。国土丰饶人民炽盛快乐。有八万四千城聚落有五十五亿。时利益众生王所住城。名慧光。东西十二由延。南北七由延。其城广大人民炽盛财物无限严饰快乐。王第一夫人。字慧事。无儿息。彼为儿故。礼事种种诸天河水池水满善天宝善天日月天帝释梵天王地水火风神摩醯首罗天子园神林神巷陌诸神鬼子母聚落诸神处处供养求愿有子。后于异时。王第一夫人怀娠。女人有三种智慧。知男子有欲意看。知得胎时。知所从得处。时夫人即往王所白言。王知不。我今怀妊王言大善。即为夫人倍增供养。以最上饮食衣服医药卧具一切所须皆增一倍。十月满已生一男儿。颜貌端正时儿生日。八万四千诸城。八万四千伏藏自然涌出。藏有银者银树涌出。根茎枝叶皆是白银。藏有金者金树涌出。根茎华叶皆悉是金。藏有琉璃者颇梨者。有赤真珠者。有马瑙者。有车磲者。皆亦如是。尔时国法。若儿初生。若父母为作字。若沙门婆罗门为作字。时王利益众生。作是念。何须沙门婆罗门为作字也。此儿母字慧事。我今宁可字儿为慧灯。彼即字为慧灯。时王为其儿置四种乳母。一者治身。二者浣衣。三者乳养。四者戏笑。治身母者。修治身形支节。浣衣母者为浣濯衣服洗浴身形。与乳母者。主知与乳。游戏母者。若王子在象马车乘游戏时。华香宝物种种玩弄之具与共嬉戏持孔雀盖在后。娱乐王子令得快乐。尔时世尊。师说偈言

  一切要归尽　　高者会当堕
  生者无不死　　有命皆无常
  众生堕有数　　一切皆有为
  一切诸世间　　无有不老死
  众生是常法　　生生皆归死
  随其所造业　　罪福有果报
  恶业堕地狱　　善业生天上
  高行生善道　　得无漏涅槃

时利益众生王命终王子转大。至年八九岁。其母教学诸伎艺。书画算数戏笑歌舞伎乐。象马骑乘乘车。学射勇健捷疾。于诸技艺皆悉综练。至年十四五时。诸群臣。至王子所白言。知不。王已命终。今次应登王位。为王施行教令。王子答言。我不能为王行王教令。何以故。我前世时。曾为国王经六年。以是因缘堕在地狱六万岁。以是故。今不能为王行王教令。诸臣言。颇有方便可得作王行王教令不。答言有。何者是。答言。若能令阎浮提若男若女能言之者皆行十善不杀生乃至不邪见者。我当为王。时诸臣闻王子教已。即遣使持书四方唱令。作如是言。汝等知不。利益众生。王已命过。王子慧灯。次应为王。作如是言。我不为王。乃使阎浮提人若男若女能言之者皆行十善不杀生乃至不邪见者。我当为王。时诸国人闻如是教。尽修行十善不杀生乃至不邪见。诸臣即往王子慧灯所白言。王子知不。阎浮提人若男若女能言之者皆行十善不杀生乃至不邪见。今可登王位行王教令。王子言。取绢来。即授第一白绢与。自系头上作如是言。如是时有如是王。善好不耶。诸臣答言甚善。时诸臣白王言。王初生时。有八万四千藏自然而出。今可取入王藏。王言。何须入藏。即可于彼四交道头布施沙门婆罗门贫穷孤老。随所求索者一切施与。时诸大臣闻慧灯王教已。即于八万四千城。随所在藏。于四城门中四交道头。布施沙门婆罗门贫穷孤老。随其所索一切施与。时天帝释便作是念。王慧灯于八万四千城。随所在藏。皆于四城门中四交道头。布施沙门婆罗门贫穷孤老。随其所索一切施与。将恐来夺我座。我今宁可往试王慧灯。为以无上道不退转故布施。为以退转也。彼即化作男子。自相谓言。王慧灯。教我等行十恶杀生乃至邪见。时诸大臣皆往王所白言。王实教国人行十恶杀生乃至邪见耶。王答言不。何以故。我先有是语。我不作王。乃令阎浮提人能言之类皆行十善不杀生乃至不邪见。我当为王。是故我无是语。汝等今可严驾象乘。我欲自行教化国人

四分律卷第五十一四分律卷第五十二(第四分之三)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    杂揵度之二

时天帝释作如是念。我不应令王乘世间常乘。即严驾天象。象有六牙。牙皆粗大。置于门外。时王慧灯见如是象驾。问诸大臣。此是谁象。诸臣答言。不知是谁象。此必是王象。非余人有也。愿王便可乘之。王即便乘。王言。可去示我。彼人言。我教国人行十恶者。彼即示王。王问言。王慧灯教汝行十恶耶。答言实尔。王复问言。可有方便行十善不。答言有。问言何者是耶。彼答言。若得成就菩萨生食其肉饮其血。乃得行十善不杀生乃至不邪见。时王慧灯作如是念。我于无始世已来。经历众苦轮转五道。或受截手截脚截耳鼻出眼截头。竟何所益。即取利刀自割股肉以器盛血授与彼人。而告之曰。男子汝可食饮此肉血可行十善。时彼男子。不堪王慧灯威德。即没不现。忽有天帝而在前立。问王言。王今布施。为一天下二三四天下耶。为日月天帝释魔王梵王耶。王答言。我布施不为一天下二三四天下乃至魔梵王。我作如是意。行布施欲求无上正真一切智。度未度者。解未解者。未得涅槃者令得涅槃。度生老病死忧悲苦恼如是等者。时天帝释便作是念。我今令王慧灯以此疮死者。甚非所以。当以天甘露灌其身上。即便灌之。疮即平复如故。佛告瓶沙王言。尔时利益众生王者。岂异人乎。即今父王白净是也。时王第一夫人者。今母摩耶是。时王慧灯者。即我身是。我于前世。教化阎浮提无数人民。若男若女能言之者。皆行十善不杀生乃至不邪见。以是因缘故。足下千辐轮相轮郭成就。光明晃曜照三千大千国土。尔时大众见世尊如是神力变化。皆大欢喜得未曾有厌离心生。世尊观诸大众皆大欢喜厌离心生。为无数方便说法。令无数百千人即于座上远尘。离垢得法眼净。此是世尊第十五日变化

尔时世尊在王舍城。时王瓶沙。听诸比丘入出宫合无有疑难。时王安人着屏处听。若比丘有所言说便来语我。彼重宫合以贵价尸赊婆材为柱。诸比丘见已作如是言。乃以此贵价材作柱也。为诸比丘作钵者不亦佳乎。时彼屏处人闻已。即往白王。王即敕人。更作新柱。以易取持作钵。施与诸比丘。诸比丘不受言。佛未听我等畜尸赊婆木钵。时诸比丘白佛。佛言。不应畜木钵。此是外道法。若畜如法治。时瓶沙王。以石钵施诸比丘。诸比丘不受言。佛未听我等畜石钵白佛。佛言不应畜。此是如来法钵。若畜得偷兰遮。时瓶沙王。作金钵施比丘。比丘不受言。世尊未听我等畜金钵白佛。佛言。比丘不应畜金钵。此是白衣法若畜如法治。时王瓶沙。复作银钵。作琉璃钵。作宝钵。杂宝作钵。施诸比丘。比丘不受言。佛未听我等畜如是钵。诸比丘白佛。佛言。不应畜如此等钵。此是白衣法。若畜如法治。尔时世尊在婆伽提国。毗舍离跋阇子比丘畜金钵。佛言不应畜。彼畜银钵琉璃钵畜宝钵畜杂宝钵。佛言不应畜。汝等痴人。避我所制更作余事。自今已去。一切宝钵不应畜。若畜如法治

尔时世尊在毗舍离。诸梨奢得大价摩尼钵。以旃檀末香满钵奉世尊。大德。愿慈愍故。受此摩尼钵。佛言梨奢。我不应畜此钵。复白佛言。愿慈愍故。受旃檀末香。世尊即受。时诸梨奢念言。当持此钵与谁。中有言。与不兰迦叶。或有言。与末佉罗瞿舍罗阿夷头翅舍钦婆罗。与波休迦旃延。与讪若毗罗吒子。与尼犍那耶子。与萨遮尼犍子。彼即持钵与萨遮尼犍子。时萨遮尼犍子。闻毗舍离诸梨奢以大价摩尼钵先与瞿昙沙门不受后来与我。彼怀憍慢贡高嫉妒之心。嗔恚不喜不自慎护。便作恶言。若使汝等截诸梨奢子舌满钵。尔乃当受。彼作是念。萨遮尼犍子。大欲伤毁我等种族。即以一石打杀。彼欲自料理解前恶言。而不听语便打杀。诸比丘白佛。佛言。若得语者事必得解。佛言。有五法摄言。得自申理不被咎责。令彼欢喜后无悔恨。何等五。善者便说。不善者不说。如法便说。不如法不说。爱言便说。不爱言不说。以实而说。不为虚诈。利益故说。不以无利。有如是五法摄言。得自申理不被咎责。令彼欢喜后无悔恨。即说偈言

  善说者近胜　　法说无非法
  爱语真实语　　利益无有损
  善说于言者　　令已无热恼
  亦不侵他人　　是言为善说
  善说于爱言　　不为彼所责
  说时无不爱　　诸恶不来集
  至诚甘露说　　实语为最上
  真实如佛法　　便住于涅槃
  佛所可说法　　安隐至涅槃
  能尽于苦际　　此言最善说

时瓶沙王布施比丘铁钵。比丘不受言。佛未听我等畜铁钵。诸比丘白佛。佛言听畜铁钵。时有铁作者出家。欲为诸比丘作钵白佛。佛言听作。彼须炉。佛言听作。彼须椎钳。佛言听作。彼须韛囊。听作。彼须错。佛言听作。彼须旋器。佛言听作。彼旋器诸物患零落。佛言听作。囊盛着杙上龙牙杙上。彼畜钵不熏生垢患臭。佛言听熏。彼不知云何熏。听作炉若釜若瓮种种泥涂。以杏子麻子泥里。以灰平地作熏钵场。安支以钵置上。钵炉覆上。以灰壅四边手按令坚。若以薪若牛屎壅四边烧之。当作如是熏。尔时世尊。在苏摩国人间游行。时有信乐陶师。世尊指授泥处语言。取此处土。作如是打。如是晒燥。如是作泥。如是调。作如是钵。如是揩摩。如是晒干已。作大坚炉安钵置中。以盖覆上泥涂。若以佉罗陀木。若以枣木。若以尸赊婆木阿摩勒木。安四边烧之。彼即如佛所教。随次而作即成。持异贵好苏摩钵与诸比丘。比丘不受言。世尊未听我等畜如是钵白佛。佛言听畜。时世尊在优伽罗村。时诸比丘得优伽罗钵不受言。佛未听我等畜如此钵白佛。佛言听畜。尔时世尊在优伽赊。诸比丘得优伽赊钵不受言。佛未听我等畜如此钵白佛。佛言听受。时世尊在毗舍离。诸比丘得黑钵不受言。佛未听我等畜黑钵白佛。佛言听畜。尔时世尊在舍卫国。时诸比丘得赤钵不受言。佛未听我等畜如是钵白佛。佛言听畜。有六种钵。铁钵苏摩钵优伽罗钵优伽赊钵黑钵赤钵。此总而言二种钵。铁钵瓦钵。有受一斗半。有受三斗者。此应受持。彼钵着墼欲堕处。佛言不应尔。彼安钵石欲堕处。佛言不应尔。彼安钵棚阁上。佛言不应尔。彼安钵道中。佛言不应尔。彼安钵石上。佛言不应尔。彼安钵有果树下。佛言不应尔。彼安钵不平处。佛言不应尔。彼一手捉两钵。佛言不应尔。除指隔中间。彼一手捉两钵开户。佛言不应尔。除用心。彼安钵户扉后。佛言不应尔。彼安钵户前。佛言不应尔。彼安钵绳床木床下。佛言不应尔。彼安钵绳床木床间。佛言不应尔。除须臾间。彼安钵绳床木床角头。佛言不应尔。除须臾间。彼立洗钵堕地破。佛言不应尔。彼故失钵令破更作新者。佛言不应尔。彼持长物着钵中。佛言一切物不应着钵中。彼画钵中作蒱桃蔓莲华像。佛言不应尔。彼钵中作万字。佛言不应尔。彼画钵作己名字。佛言不应尔。彼缠钵四边若口。佛言不应尔。彼都缦缠钵。佛言不应尔。应缠两分留一分。若有星孔多应尽缠。彼安钵着地坏熏。佛言不应尔。应以泥浆洒地安。若故坏熏。应安着叶上若草上。若故坏熏。应作钵支若复坏熏。以物缦底彼以宝缦底。佛言不应用宝。应以白镴铅锡。彼患堕落。佛言。应以胡胶若蜡胶。彼不洗钵便举。余比丘见恶之。佛言不应尔。应洗举。彼不以澡豆洗腻不去。佛言不应尔。应用澡豆若土若灰若牛屎若泥洗。彼以杂沙牛屎洗钵坏钵。佛言不应尔。应以器盛水渍牛屎澄去沙用洗钵。若以细末细泥。若叶若华若果洗之。取令去腻。钵有星臼孔。食入中摘出坏钵。随可摘出便摘出。余者不可出无苦。彼洗钵不干便举垢生。佛言不应尔。应令干已举。手捉钵难护持。佛言听作钵囊盛。不系囊口钵出。佛言应绳系。手捉钵囊难护持。佛言应作带络肩。时比丘挟钵腋下。钵口向胁。道行遇雨。脚跌倒地。钵隐胁遂成患。佛言不应尔。应钵口外向。苏摩钵囊中出入患破。佛言应作函若箱盛。彼用宝作函若箱。佛言不应以宝作。应以舍罗草若竹木作。若钵相枨。应以草树叶。若十种衣中一一衣作障隔。若从函箱口出。佛言应作盖。彼用宝作盖。佛言不应尔。应用舍罗草若竹木作。若安处不坚。应以带系龙牙杙上

尔时世尊在王舍城。时王瓶沙庵婆罗园。听诸比丘出入无有疑难。时六群比丘。至守园人所语言。我须庵婆罗果。彼即与。复更索。次复更与。如是遂食彼果尽。后异时。王须庵婆罗果。敕傍臣索果。臣即受敕。至守园人所索果。彼答言果尽。问言何故尽。彼答言。沙门释子食尽。彼大臣即讥嫌言。沙门释子不知厌足多所求欲。自言我知正法。如是何有正法。施者虽无厌。受者应知足。云何乃食王果尽。诸比丘白佛。佛言。不应食庵婆罗果。尔时诸比丘乞食。得庵婆罗果汁。佛言听饮。彼得成煮庵婆罗果。佛言听食。彼得庵婆罗果浆。佛言听饮。若未成酒听非时饮。成酒不应饮。若饮应如法治。后于异时。庵婆罗果大熟。阿难喜食此果。往世尊所。头面礼足却坐一面。白佛言。庵婆罗果大熟。尔时世尊。以此因缘集比丘僧。为诸比丘随顺说法。无数方便赞叹头陀端严少欲知足有智慧者。告诸比丘。自今已去。听食庵婆罗果

尔时世尊在拘睒弥。时六群比丘。反被拘执更相恐戏。时诸居士见皆共讥嫌。沙门释子不知厌足。自称我知正法。反被拘执更相恐戏。如王大臣。如是有何正法。诸比丘白佛。佛言不应反被拘执。亦不应更相恐戏。时病比丘被拘执毛在内毛着疮患痛。佛言里着衬身衣。若患热应反被以袈裟覆上。时比丘衣坏。佛言应补治。不知云何补。佛言。若以綖缝若并綖缝有孔处以物补。彼孔大以小物补令衣缩小。佛言不应尔。应及孔大小广二指补治。若补衣时患缩。以石镇四角补。若故缩四角竖杙张之。若故缩应作桄张之。不知云何作。佛言应以木作。彼须绳张。佛言听与绳张缝之。不知以何物缝。佛言听以鸟毛若簪缝。若衣细软坏衣听针缝。彼以宝作针。佛言不应尔。听以铜铁作。针缝衣患指痛。佛言听作[打-丁+沓]彼。以宝作指[打-丁+沓]。佛言不应尔。听用铜铁骨牙角铅锡白镴胡胶木作。彼缝衣时患曲。听绳墨拼令直。彼须絣缕。佛言应与。彼欲染缕用絣衣。须石灰若赤赭土若白墠若墨若雌黄一切听与。若中央不定。应以尺度量。彼以宝作尺度。佛言不应以宝作。听以铜铁乃至以木作。彼张衣着地缝尘坌衣。佛言听以泥浆洒地已张。彼缝衣时针刺地坏。佛言不应尔。彼于赊婆罗草上敷衣缝草着衣。佛言不应尔。彼敷衣草上叶上合草叶缝。佛言不应尔。听十种衣中一一衣。若伊梨延陀耄罗耄耄罗毛氀敷上缝。彼比丘患绳墨拼綖尺度缕綖针刀子补衣物零落。佛言听作囊盛。彼不举衣桄雨渍。佛言应收举。不知举何处。佛言。听安着经行堂中若温室食堂中。张衣桄大户不受不得入。应置外无雨处。若风雨飘渍。应高悬。彼补衣竟解衣取余木不举。佛言应举。不知安着何处。佛言。安着阁下若床上。彼不举绳索。佛言。应卷系着衣桄举之。时诸比丘患针零落。佛言。听作针毡。故患零落。听作筒。彼用宝作。佛言。不应用宝作。听用铜铁乃至竹木作。患针从筒口出。佛言。应安盖塞。彼用宝作。佛言。不应用宝作。听用铜铁乃至竹木作。若针鉎应着糗中。若故患鉎。随着余物取令不鉎。时诸比丘患针筒刀子碎纳缕綖零落。佛言。听作囊盛。若此诸物从口出。应以绳系。若手捉难护。应作带络着肩。时比丘铁钵穿破。佛言听补。若着钉若朱泥若以树胶胶。苏摩钵穿坏。佛言。听以胡胶塞若石灰若白墠土。迦罗黑钵破。应钻作孔以针缕缀。彼须钻。佛言听作。彼用宝作。佛言。不应用宝。听用铜铁。若患缕綖断。应用筋若用牛马尾毛。若患虫啖筋綖。应以胡胶胶上。若患食若水入内。亦以胡胶胶之。若复患坏。以铁鐷鐷。尔时世尊在王舍城。诸比丘于阿兰若处以火珠出火。有贼以珠故来触恼比丘。诸比丘白佛。佛言。不应在阿兰若处以火珠出火。时诸比丘须火。佛言。听比丘于阿兰若处作火术出火。须火母木听作。须钻火子听作。彼须绳。所须之物一切听与。彼患钻火具零落。听作囊盛。无安处患湿。听悬着床下若龙牙杙上。彼不知以何物承火。应以草若叶刍摩若麻翅奢草。若以牛马屎取火。时比丘数数钻火破手患痛。佛言。听于屏处以火珠出火

尔时世尊在舍卫国。六群比丘用杂虫水。诸居士见皆共讥嫌。沙门释子无有慈心断众生命。自称言我知正法。如是何有正法。诸比丘白佛。佛言。不应用杂虫水。听作漉水囊。不知云何作。佛言。如勺形若三角若作撗郭若作漉瓶。若患细虫出。听安沙囊中。彼以杂虫沙弃陆地。佛言不应尔。听还安着水中。时有二比丘共斗。在拘萨罗国行。一比丘持漉水囊漉水饮。其一伴比丘。从借囊不与。遂不得水饮患极。诸比丘白佛。佛言有者应与。比丘不应无漉水囊行乃至半由旬。若无应以僧伽梨角漉水。尔时世尊在婆只提国。时六群比丘二人同床宿。余比丘见谓与女人共宿。后起时乃知非女人。诸比丘白佛。佛言。不应二人同床宿。彼疑不与病人同床。佛言。听与病人同床卧。尔时世尊在婆只提国。六群比丘二人同被褥卧。余比丘见谓与女人共卧。后起时方知非女人。诸比丘白佛。佛言。不应二人同被褥卧。时诸比丘正有一敷若草若叶。佛言。听此敷上各别敷卧毡卧。寒时正有一被。听内各别被衬身衣外通覆。尔时世尊在舍卫国。时六群比丘同一钵食。时诸居士见皆共讥嫌言。沙门释子不知惭愧。自称我知正法。如是有何正法。二人同一钵食。犹如王大臣。诸比丘白佛。佛言。不应二人同钵食。时比丘共一器盛饭。佛言。应分余器中别食。若无别钵。听食时留半与彼食。若日时欲过。听一人取一抟食已授与彼人令取食。时六群比丘亚卧枕于案上食。时诸居士见皆共讥嫌言。沙门释子不知惭愧。自称言我知正法。如是有何正法。亚卧而食。如似王大臣。诸比丘白佛。佛言不应尔。时诸上座老病比丘不能自手捉钵食。听着绳床木床角头若安瓶上。时六群比丘于绳床木床上立。床绳断令褥破。诸比丘白佛。佛言不应尔。若比丘欲有所取有所举。听床梐上立。时诸外道大绳床作小绳床畜。六群比丘法外道如是畜绳床。诸比丘白佛。佛言不应尔。迦留陀夷身大浴室中床小不受。彼疑不敢取外大床作小床浴白佛。佛言。听浴室中安大小床浴。时六群比丘畜白衣器耕犁若捞白佛。佛言不应畜。彼畜宝澡罐澡盘。佛言不应畜。时有比丘名耶波徒。或礼事诸外道若火若日月。若不语道种种外道法。诸比丘白佛。佛言。不应事余种种外道法。尔时有比丘在阿兰若处齝食。余比丘语言。汝犯非时食彼言。我不犯非时食。我齝耳。诸比丘白佛。佛言。此比丘适从牛中来生此。若其不尔不得久活。若余比丘有如是病。如是以为便身无患。哯食出未出口得还咽。时只桓中有乌有鹦鹉鸟作声。乱诸坐禅比丘。佛言。应作声惊令去。若弹弓打木令去。时诸比丘夜集往布萨处患闇。佛言听执炬。若坐处复闇。听然灯。彼须然灯器听与。须油须灯炷听与。若不明高出炷。若油污手听作箸。若患箸火烧。听作铁箸。若患灯炷卧。听炷中央安铁柱。若故不明。听大作炷。若复故闇。应室四角安灯。若复不明。应作转轮灯。若故不明。应室内四周安灯。若安灯树。若以瓶盛水安油着上以布裹芥子作炷然之。尔时毗舍佉无夷罗母。遣人送六种物。独坐绳床火炉灯笼扫帚扇斗。诸比丘不受白佛。佛言听受。余者斗不应受。时有比丘字勇猛。婆罗门出家。往世尊所头面礼足却坐一面。白世尊言。大德。此诸比丘众姓出家名字亦异破佛经义。愿世尊听我等以世间好言论修理佛经。佛言。汝等痴人。此乃是毁损。以外道言论而欲杂糅佛经。佛言。听随国俗言音所解诵习佛经。尔时有比丘。拘萨罗国在道行。至一屏处欲大小便利。时有女人亦至屏处欲大小便。去此处不远有池水。时比丘往彼池水洗。彼女人亦至彼池水上洗。时诸居士见作如是言。此比丘从彼间出自洗女人亦尔。比丘必犯此女人。诸比丘闻白佛。佛言。不应在如是处大小便令人生疑。亦不应在池水上洗。尔时跋难陀释子。向暮至白衣家在内坐。须臾便出。不语主人而去。时贼白日伺其家。暮遇门开。即便入劫夺其家。家主问言。谁暮开门出去。家人答言。是跋难陀释子。时诸居士皆讥嫌言。沙门释子无有惭愧。自称言我知正法。乃与贼共期来劫我家。如是何有正法。时诸比丘白佛。佛言。不应向暮至白衣家。时诸比丘。为佛事法事僧事塔事病比丘事。若檀越唤逼暮比丘疑不敢往。佛言。若有如是事应往。时跋难陀释子欲意为女人说法。彼女人察知即语言。汝何不自为说法。诸比丘白佛。佛言。不应以欲意说法。时六群比丘与女人卜占。佛言不应尔。复从人卜占。佛言不应尔。时六群比丘共他货物。佛言不应尔。彼得物便取。佛言不应尔。六群比丘共携手在道行拨他令倒地。时诸居士见皆共讥嫌言。沙门释子不知惭愧无有厌足。自言我知正法。共携手在道行如王大臣。如是何有正法。诸比丘白佛。佛言不应尔。时诸比丘道路行。有人施革屣盛油华瓶。诸比丘疑不敢受。佛言听受。时六群比丘出息物白佛。佛言不应尔。时六群比丘从他举息物白佛。佛言不应尔。时六群比丘共他斗诤反抄衣衣缠颈裹头通肩被衣着革屣共上座语。诸比丘白佛。佛言不应尔。应偏露右肩脱革屣至上座前小曲身合掌白如是言。我欲有所白。上座应答言。如法如律说。时跋难陀在道行。持好大圆盖。诸居士遥见。谓是王若大臣恐怖避道去。彼不远谛视。乃知是跋难陀。即皆讥嫌言。沙门释子多欲无厌。自称言我知正法。而持大好圆盖在道行。犹如王大臣。令我等恐怖避道。如是有何正法。诸比丘白佛。佛言。比丘不应持圆盖在道行亦不应畜。时诸比丘天雨时往大食上小食上若夜集时布萨时雨渍衣新染色坏。诸比丘白佛。佛言。听为护衣故在寺内树皮若叶若竹作盖。彼须盖竿。佛言听作。彼用宝作。佛言。不应用宝作。听以骨牙角白镴铅锡木作。彼须盖子。佛言。听作。彼用宝作。佛言。不应用宝作。听用骨乃至木作。彼须盖宏。佛言。听与。彼用宝作。佛言。不应用宝。听用骨乃至木作。彼欲作覆盖顶。听用多罗树叶摩楼树叶皮覆。若患四边坏听重叠。彼须盖竿。佛言听作。彼用宝作。佛言。不应用宝作。听用骨牙角乃至木作。彼作盖竿长门中不得入出。佛言应解脱作。若患盖竿脱。应作孔安楬。若折若曲。听以铁作楬头作锁系。时跋难陀释子盛钵络囊中贯杖头肩荷而行。时诸居士见。谓是王家人来。恐怖避道去。不远乃知是跋难陀。皆共讥嫌言。沙门释子不知厌足无有惭愧。自称言我知正法。如是何有正法。诸比丘白佛。佛言不应尔。亦不应畜如是杖络囊。时老病比丘道行倒地。佛言老病听捉杖。患杖下头尽听作錔。彼用宝作。佛言。不应用宝听用骨牙角白镴铅锡作若上头破。亦听用如是等物作。时六群比丘畜空中杖。时诸居士皆共讥嫌言。沙门释子不知厌足无有惭愧。自称我知正法。乃持空中杖如王大臣。如是何有正法。时诸比丘白佛。佛言不应尔。诸比丘道行见蛇蝎蜈蚣百足。未离欲比丘见皆怖白佛。佛言。听捉锡杖摇。若筒盛碎石摇令作声。若摇破竹作声。时六群比丘捉正大圆扇。诸居士见皆讥嫌言。沙门释子不知厌足无有惭愧。自称言我知正法。捉大圆扇如王大臣。如是何有正法。诸比丘白佛。佛言不应尔。彼得已成者疑不敢受白佛。佛言。听受与塔。时诸比丘在道行患热白佛。佛言。听以树叶若枝若草十种衣中一一衣作扇。时六群比丘捉皮扇。佛言不应畜。六群比丘纵横十木以皮缦上作扇。佛言不应畜。时诸比丘扇坏佛言。听以树皮若叶补若皮补。若堕应以綖缝若綖断应以筋綖缝。若边坏应以皮缠。时诸比丘大小食上若夜集时说戒时患热。佛言。听作大扇。若作转关扇车。不知谁推。佛言。听比丘若沙弥若守园人若优婆塞推。时六群比丘作织毛[肖*毛]扇多杀细虫若草。时诸居士见皆讥嫌言。沙门释子无有惭愧害众生命。自称言我知正法。捉[肖*毛]扇害众生命。如是何有正法。诸比丘白佛。佛言。不应畜如是[肖*毛]扇。时诸比丘患虫草尘露堕身上。佛言听作拂。不知云何作。佛言。听以草若树皮叶以缕綖作若裁碎缯帛作。时有比丘得尾拂。诸比丘白佛。佛言。听畜

尔时世尊在王舍城。时优波离与诸比丘共论法律。时诸比丘共来听戒。坐处迮狭不相容受。佛言。相降三岁听共坐木床。相降二岁听共坐小绳床。新学年少比丘不解事数相涉。听用算子记数。彼用宝作。佛言不应用宝。听用骨牙角铜铁铅锡白镴木作。彼安置地污手。佛言不应置地。应安板上。彼安板置地已复安膝上污衣。佛言不应尔。应安脚作机。彼算子患零落。听作囊盛。不系从口出。听以绳系安杙上龙牙杙上

尔时世尊在只桓园中。与无数百千众围绕说法。时有比丘啖蒜远佛住。时世尊知而故问阿难。此比丘何故远住。阿难言。此比丘啖蒜。佛言阿难。宁可贪如是味而不听法耶。自今已去。一切不应啖蒜。尔时舍利弗病风医教服蒜。佛言听服。时有比丘背负物行。诸居士见皆讥嫌。沙门释子犹如白衣背负物而行。皆生慢心。诸比丘白佛。佛言。不应背负物行。时诸比丘须薪若染草牛屎毳纻欲自檐持。佛言。听无人处担。若见白衣应下着地若移肩上。时有比丘伊梨阿若着衣。诸居士见皆讥嫌言。如我白衣如是着衣担物皆生慢心白佛。佛言。不应如是着衣。亦不应背负物行。时诸比丘于寺内聚集墼石材木。彼畏慎不敢背负移徙白佛。佛言听寺内背负。时舍利弗目连般涅槃已。有檀越作如是言。若世尊听我等为其起塔者我当作。诸比丘白佛。佛言听作。彼不知云何作。佛言。四方作若圆若八角作。不知以何物作白佛。佛言。听以石墼若木作已应泥。不知用何等泥。佛言。听用黑泥若[卄/告]泥若牛屎泥。若用白泥若用石灰若白墠土。彼欲作塔基。佛言听作。彼欲华香供养。佛言。听四边作栏楯安华香着上。彼欲上幡盖。佛言听安悬幡盖物。彼上塔上。护塔神嗔。佛言不应上。若须上有所取听上。彼上栏上。护塔神嗔。佛言不应上。若须上有所取听上。彼上杙上龙牙杙上。佛言不应尔。若须上有所取与听上。彼上像上安盖供养。佛言不应尔。应作余方便蹬上安盖。彼塔露地华香灯油幡盖妓乐供养具雨渍风飘日曝尘土坌及乌鸟不净污。佛言。听作种种屋覆。一切作屋所须应与。若地有尘应泥。若黑泥牛屎泥。若须白以石灰泥白墠土泥。彼须洗足器应与。须石作道行。佛言听作。彼须地敷听与。时无外墙障。牛马入无限。佛言听作墙。若须门听作。时舍利弗目连檀越作如是念。彼二人存在时。我常供养饮食。今已涅槃。若世尊听我等上美饮食供养塔者我当送。诸比丘白佛。佛言听供养。不知用何器盛食。佛言。听用金银钵宝器杂宝器。不知云何持往。佛言。听象马车乘载若舁若头戴若肩担。时诸比丘自作伎若吹贝供养。佛言不应尔。彼畏慎不敢令白衣作伎供养。佛言听。彼不知供养塔饮食谁当应食。佛言。比丘若沙弥若优婆塞若经营作者应食。时舍利弗目连檀越作是念佛听我等庄严供养塔者我当作。佛言听。彼须华香璎珞伎乐幢幡灯油高台车。佛言听作。彼欲作形像。佛言听作。彼不知云何安舍利。应安金塔中若银塔若宝塔若杂宝塔。若以缯绵裹若以钵肆酖岚婆衣。若以头头罗衣裹。复不知云何持行。佛言听象马车乘辇轝驮载若肩上头上担戴。若欲倾倒应扶持。彼自作伎供养。佛言不应尔。彼畏慎不敢令白衣作伎供养。佛言听。彼欲拂拭声闻塔。佛言。应以多罗树叶摩楼树叶若孔雀尾拂拭。彼大有华。听着塔基上。若栏上若龙牙杙上若向中。若绳贯悬着屋檐前。若有多香泥。听作手像轮像魔醯陀罗像。若作藤像。若作葡萄蔓像。若作莲华像。若故有余应泥地

尔时世尊在王舍城。时恭敬世尊故无敢与佛剃发者。正有一小儿。无知未有所畏。为佛剃发。时小儿字优波离。为佛剃发。其父母在世尊前。合掌白言。优波离小儿。为世尊剃发。为好不。佛言。善能剃发。乃使身安乐而太曲身。父母即语言。汝莫太曲身令世尊不安。复问佛言小儿剃发好不。佛言。善能剃发而身太直。父母语言。汝莫太直身令世尊不安。复白佛言。小儿剃发好不。佛言。善能剃发。而入息太粗。父母语言。汝莫粗入息令佛不安。复白佛言。小儿剃发好不。佛言。善能剃发而出息太粗。父母语言。汝莫粗出息令佛不安。时小儿优波离入出息尽入第四禅。尔时世尊告阿难言。优波离已入第四禅。汝取彼手中刀。阿难受教即取刀。是时阿难持故盛发器收世尊发。佛言。不应以故器盛如来发。应用新器若新衣若缯彩若钵肆酖岚婆衣若头头罗衣裹盛。时有王子瞿婆离将军。欲往西方有所征讨。来索世尊须发。诸比丘白佛。佛言听与。彼得已不知云何安处。佛言。听安金塔中若银塔若宝塔若杂宝塔缯彩若钵肆酖岚婆衣头头罗衣裹。不知云何持。佛言。听象马车乘若辇轝若头上若肩上担。时王子持世尊发去所往征讨得胜。时彼王子还国为世尊起发塔。此是世尊在世时塔。诸比丘作如是言。若世尊听我等担世尊发行。我等当持行。诸比丘白佛。佛言听。不知云何安处。佛言。听安着金塔若银塔若宝塔若杂宝塔若钵肆酖岚婆衣若头头罗衣裹。不知云何持行。佛言。象马车乘辇轝若肩上若头上担戴。彼腋下挟世尊塔。佛言不应尔。彼反抄衣缠颈裹头通肩被衣若着革屣担世尊塔。佛言不应尔。应偏露右肩脱革屣若头戴若肩上担世尊塔行。彼持世尊塔往大小便处。佛言不应尔。应清净持。彼不洗大小便处持世尊塔。佛言不应尔。应令净者持。彼安如来塔置不好房中。已在上好房中宿。佛言不应尔。应安如来塔置上好房中已在不好房宿。彼安如来塔置下房己在上房宿。佛言不应尔。应安如来塔在上房己在下房中宿。彼共如来塔同屋宿。佛言不应尔。彼为守护坚牢故。而畏慎不敢共宿。佛言。听安杙上若龙牙杙上若头边而眠。时诸优婆塞作是念。若世尊听我等及世尊现在起塔者我当起立。诸比丘白佛。佛言听作。不知云何作。佛言。应四方若八角若圆作。复不知以何物作。佛言应以塼石若木作。一切如上法。乃至地敷亦如上彼须幢。佛言听作幢。若师子幢若龙幢若作犎牛幢。彼塔四边无篱障。牛羊践[跳-兆+(焰-火)]无阂。应作篱障如上。时诸外道塔庙常作饮食供养。诸优婆塞作如是念。若世尊听我送上好食供养者我当作。诸比丘白佛。佛言听作如上。不知谁当应食此食。佛言塔作者应食。时诸外道常庄严供养外道塔庙。诸优婆塞作如是念。若世尊听我等庄严供养世尊塔者我当作。诸比丘白佛。佛言听作如上。彼在世尊塔内宿。佛言不应尔。彼为守塔故。畏慎不敢在塔内宿。佛言若为守视者听内宿。彼于塔内藏物。佛言不应尔。彼为坚牢故。欲于塔内藏物。而畏慎不敢。佛言听。彼着革屣入塔内。佛言不应尔。彼捉革屣入塔内。佛言不应尔。彼着革屣旋塔行。佛言不应尔。彼着富罗入塔内。佛言不应尔。彼捉富罗入塔内。佛言不应尔。彼畏慎不敢着富罗旋塔外行。佛言听。彼于塔下食污秽。佛言不应塔下食。时诸比丘旋塔时若房舍时若浴池时。众多僧集会。处所迮狭不相容受。彼畏慎不敢在塔下坐食。世尊不听在塔下坐。诸比丘白佛。佛言听塔下坐食。不应令污秽不净。时诸比丘不知云何。佛言。听以不净众物聚着脚边食已持出。彼持死尸塔下过。佛言不应尔。彼于塔下埋死人。佛言不应尔。彼于塔下烧死尸。佛言不应尔。彼于塔前烧死尸。佛言不应尔。彼于塔四面烧死尸令臭气入。护塔神嗔。佛言。不应于塔四面烧死尸令臭气入。彼持死人衣若床从塔下过。护塔神嗔。佛言不应尔。彼着粪扫衣比丘畏慎。不敢持粪扫衣从塔下过。世尊有如是教。不听持死人衣塔下过。诸比丘白佛。佛言。若净浣染以香熏之听。彼于塔下大小便。佛言不应尔。彼于塔前大小便。佛言不应尔。彼于塔四边大小便令臭气来入。护塔神嗔。佛言不应尔。彼于塔下嚼杨枝。佛言不应尔。彼于塔前嚼杨枝。佛言不应尔。彼于塔四边嚼杨枝。佛言不应尔。彼于塔下[口*弟]唾。佛言不应尔。彼于塔前[口*弟]唾。佛言不应尔。彼于塔前舒脚坐。佛言不应尔。若僧伽蓝内塔隔。听在中间舒脚坐。尔时世尊在拘萨罗国。与千二百五十比丘人间游行。往都子婆罗门村到一异处。世尊笑。时阿难作是念。今世尊以何因缘笑耶。世尊不以无因缘而笑。偏露右肩脱革屣右膝着地合掌白佛言。世尊。不以无因缘而笑。向者以何故而笑。愿欲知之。佛告阿难。乃往过去世时。有迦叶佛。般涅槃已。时有翅毗伽尸国王。于此处七岁七月七日起大塔已。七岁七月七日与大供养。坐二部僧于象荫下。供第一饭。时去此处不远。有一农夫耕田。佛往彼间。取一抟泥来置此处。而说偈言

  设以百千璎珞　　皆是阎浮檀金
  不如以一抟泥　　为佛起塔胜
  设以金百千抟　　皆是阎浮檀金
  不如以一抟泥　　为佛起塔胜
  设以金百千担　　皆是阎浮檀金
  不如以一抟泥　　为佛起塔胜
  设以金百千抱　　皆是阎浮檀金
  不如以一抟泥　　为佛起塔胜
  设以金百千壁　　皆是阎浮檀金
  不如以一抟泥　　为佛起塔胜
  设以金百千岩　　皆是阎浮檀金
  不如以一抟泥　　为佛起塔胜
  设以金百千山　　皆是阎浮檀金
  不如以一抟泥　　为佛起塔胜

时诸比丘比丘尼优婆塞优婆夷。皆以一抟泥着此处即成大塔。时诸比丘患屋内臭。佛言应洒扫。若故臭以香泥泥。若复臭应屋四角悬香。时置尊在毗舍离。时众僧大得饮食供养。诸比丘不节遂成患。佛言应服药。彼须吐下应与吐下。彼须粥与粥。须野鸟肉应与。尔时耆婆童子治众僧病。为佛及僧。作吐下药。作粥及野鸟肉羹。不能供足。往世尊所。头面礼足却住一面。白世尊言。大德诸比丘得病。若听诸比丘作浴室浴者可得少病。时世尊默然听可。时耆婆童子知佛听可即从坐起前礼佛足绕佛而去。时世尊以此因缘集比丘僧。而为方便随顺说法。赞叹头陀端严少欲知足乐出离者。告诸比丘。听诸比丘作浴室洗浴

四分律卷第五十二四分律卷第五十三(第四分之四)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    杂揵度之三

尔时慈地比丘来至毗舍离国。彼与诸离奢亲友知识。诸大离奢。闻慈地比丘来至毗舍离。即往问讯。慈地比丘而不应答。彼言长老。我何所犯。故相问讯而不见答。彼即答言。我何用共汝等语为。沓婆摩罗子轻慢恼我而汝等不见佐助。彼即言。我当作何方便令沓婆摩罗子不恼汝。答言。若汝往伺佛及众僧大集时。往彼作如是言。大德。有如是事者不善不随顺非威仪不得时。我等谓此处清净安乐无有恐怖。而反生忧恼。犹水生火。何以故。沓婆摩罗子侵犯我妇。众僧当和合与作灭摈。如是则不来恼我。即答言。此有何难。彼大离奢。往佛大众所。说如上言。时沓婆摩罗子。去佛不远坐。时佛知而故问沓婆摩罗子。汝闻彼离奢语不。答言闻。唯佛知之。佛语沓婆摩罗子。汝不应作如是答。实当言实虚当言虚。时沓婆摩罗子闻佛语已。从坐起偏露右肩右膝着地合掌白佛言。我从生已来。未曾梦中犯淫。而况觉也。佛言。善哉善哉。沓婆摩罗子。此是好答。尔时世尊告诸比丘言。汝等问彼大离奢。莫以无根不净法谤此沓婆摩罗子清净比丘。以无根不净法谤清净比丘得大重罪。时诸比丘闻世尊教。即与大离奢共相诘问。汝可说实。此事云何。莫以无根不净法谤沓婆摩罗子。以无根不净法谤清净比丘得大重罪。时诸大离奢。得诸比丘诘问已。便作是言。沓婆摩罗子清净无有不净行。此是慈地比丘教我耳。诸比丘闻。中有少欲知足行头陀乐学戒知惭愧者。讥嫌彼大离奢言。沓婆摩罗子实无不净行。云何以无根不净谤耶。诸比丘往世尊所。头面礼足以此因缘具白世尊。世尊尔时集比丘僧。以无数方便呵责大离奢言。汝所为非。不随顺行非清净行。云何以无根不净法谤沓婆摩罗子耶。以无数方便呵责已告诸比丘。自今已去。与大离奢作覆钵不与往反言语。作白二羯磨。白衣家有五法。应与作覆钵。不孝顺父不孝顺母不敬沙门不敬婆罗门不供事比丘。有如是五法。应与作覆钵。有五法不应与作覆钵。何等五。孝顺父孝顺母恭敬沙门恭敬婆罗门敬事比丘。有如是五法。不应与作覆钵。复有十法众僧应与作覆钵。骂谤比丘。为比丘作损减作无利益。方便令无住处。斗乱比丘。于比丘前说佛法僧恶。以无根不净法谤比丘。若犯比丘尼。有如是十法者。僧应与作覆钵。如是九八七六五四三二一法。骂谤比丘。僧应作覆钵。有如是一法。僧应与作覆钵。应如是作。众中应差堪能羯磨者。如上作如是白。大德僧听。此大离奢。沓婆摩罗子清净。而以无根波罗夷法谤。若僧时到僧忍听。僧今为此大离奢作覆钵不相来往。白如是。大德僧听。此大离奢。沓婆摩罗子清净。而以无根波罗夷法谤。今僧为作覆钵不相往来。谁诸长老忍。僧为大离奢作覆钵不相往来者默然。谁不忍者说。僧已忍。为大离奢作覆钵不相往来竟。僧忍。默然故。是事如是持。听僧差使往大离奢所语如是言。僧为汝作覆钵不相往来作白二羯磨。有八法者应差使往。能听能说自解能令他解。能受能忆持无谬失别好恶义。有如是八法者。应差为僧使。而说偈言

  若在大众中　　心无有怯弱
  所说亦不增　　受教无损减
  言无有错乱　　问时不移动
  有如是比丘　　堪任为僧使

阿难有如是八法。听差为僧使语彼大离奢。今僧为汝作覆钵不相往来白二羯磨。众中差堪能羯磨者。如上作如是白大德僧听。若僧时到僧忍听。僧今差阿难为僧使。往大离奢所语言。今僧为汝作覆钵不相往来。白如是。大德僧听。僧今差阿难为僧使。往大离奢所作如是言。僧今为汝作覆钵不相往来。谁诸长老忍。僧差阿难为僧使者默然。谁不忍者说。僧已忍。差阿难为僧使。往彼大离奢所语言。僧为汝作覆钵不相往来竟。僧忍默然故。是事如是持。尔时阿难着衣持钵。往彼大离奢家。时大离奢在外门屋下梳头。遥见阿难远来。疾疾收发前迎阿难白言。大德善哉。愿前入舍。阿难报言。我不应入汝家受床坐饮食供养。离奢言。大德阿难。何以故。答言。僧已为汝作覆钵不相往来故。离奢言。以何事故。阿难即为具说因缘。彼即言。大德阿难。如是便为杀我耶。寻即闷绝倒地久乃醒悟。还起以手扪眼。白阿难言。我当作何方便解我覆钵还相往来耶。阿难言。汝应往忏悔众僧。时大离奢。随顺众僧不敢违逆。从僧乞解覆钵还相往来。时诸比丘白佛。佛言。若大离奢。随顺众僧不敢违逆。从僧乞解覆钵还相往来者。应为解作白二羯磨。众中差堪能羯磨者。如上作如是白。大德僧听。今僧为大离奢解覆钵不相往来。彼随顺众僧不敢违逆。从僧乞解覆钵不相往来羯磨。若僧时到僧忍听。僧今为大离奢作解覆钵还相往来。白如是。大德僧听。僧为大离奢作覆钵不相往来。彼随顺众僧不敢违逆。从僧乞解覆钵不相往来羯磨。今僧为大离奢解覆钵还相往来。谁诸长老忍。僧为彼大离奢解覆钵还相往来者默然。谁不忍者说。僧已忍。为彼大离奢解覆钵还相往来竟。僧忍默然故。是事如是持。时迦留陀夷在阿兰若处住。彼于道路烧草。火势蔓莚。遂乃烧王波斯匿鹿苑。时居士皆讥嫌言。沙门释子无有惭愧断众生命。彼自言我知正法。烧王鹿苑。如是何有正法耶。诸比丘往白佛。佛言不应尔。时诸比丘道路行有草妨阂。佛言。听以竹压草。若石若木镇上。时只桓外有野火烧蔓莚来至。诸比丘不知云何即白佛。佛言。听逆除中间草。若作坑堑断。若以土灭。若逆烧时。有比丘羸老。不能无络囊盛钵无杖而行。彼作是念。我当云何。白诸比丘。诸比丘白佛。佛言。听僧与彼老比丘杖络囊白二羯磨。应如是与。众中应差堪能羯磨者。如上作如是白。大德僧听。此某甲比丘羸老不能无络囊盛钵无杖而行。彼从僧乞杖络囊。若僧时到僧忍听。与某甲比丘杖络囊。白如是。大德僧听。此某甲比丘羸老。不能无杖络囊而行。今从僧乞杖络囊。僧今与此比丘杖络囊。谁诸长老忍。僧与某甲比丘杖络囊者默然。谁不忍者说。僧已忍与某甲比丘杖络囊竟。僧忍默然故。是事如是持。尔时舍利弗。见众僧作非法羯磨。无同意者。欲默然任之。佛言听默然。有五法不应默然。若如法羯磨而心不同。默然任之。若得同意伴。亦默然任之。若见小罪而默然。为作别住而默然在戒场上而默然。如是五法默然者非法。有五法应默然。见他非法而默然。不得伴默然犯重而默然。同住默然。在同住地默然。如是五法应默然。有五事应和合。何等五。若如法应和合。若默然任之。若与欲。若从可信人闻。若先在中默然而坐。如是五事应和合。尔时世尊。在只桓中与无数众说法。时世尊啑。诸比丘咒愿言长寿。诸比丘比丘尼优婆塞优婆夷亦言长寿。大众遂便闹乱。佛言不应尔。时有居士啑诸比丘畏慎不敢言长寿。居士皆讥嫌言。我等啑。诸比丘不咒愿长寿。诸比丘白佛。佛言。听咒愿长寿。时诸居士礼比丘。比丘畏慎不敢言长寿。世尊不听我咒愿。诸居士皆嫌言。我等礼比丘。比丘不咒愿我等长寿。诸比丘白佛。佛言听咒愿长寿。尔时六群比丘有小事。便作咒咀言。我若作如是。当堕地狱饿鬼畜生。不生佛法中。若余人作如是事。亦当堕地狱饿鬼畜生。不生佛法中。诸比丘白佛。佛言不应尔。听作如是语。若我作如是事。南无佛。若汝作如是事亦言。南无佛。尔时六群比丘畜腰带头安茸。佛言不应尔。彼畜革带。佛言不应尔。六群比丘畜阇提那带。佛言不应尔。彼畜散綖带。佛言不应尔。汝等痴人。避我所遮更作余事。自今已去。如是一切带不应畜。时六群比丘畜长广带。佛言不应尔。听作腰带广三指绕腰三周。彼六群比丘大染真色作带。佛言不应尔。彼作锦带。佛言不应尔。彼作白带。佛言不应尔。听作袈裟色带。尔时有信乐陶师。作种种器与诸比丘。比丘不敢受。白佛。佛言听受。有二种器不应畜。瓦坐床瓦斛瓦斗升合。尔时跋难陀释子。往陶师家。在瓦器上累髀坐。器破。仰倒地形露。诸比丘白佛。佛言。不应瓦器上坐。亦不应白衣家累髀坐。时六群比丘。诵外道安置舍宅吉凶符书咒。枝节咒。刹利咒。尸婆罗咒。知人生死吉凶咒。解诸音声咒。诸比丘白佛。佛言不应尔。彼教他。佛言不应尔。彼以此活命。佛言不应尔。时诸比丘口臭。佛言应嚼杨枝。不嚼杨枝。有五事过。口气臭。不别味。增益热癊。不引食。眼不明。不嚼杨枝。有如是五过。嚼杨枝有五事利益。一口气不臭。二别味。三热癊消。四引食。五眼明。嚼杨枝有如是五事利益。世尊既听嚼杨枝。彼嚼长杨枝。佛言不应尔。听极长者一搩手。彼嚼杨枝奇者。佛言不应尔。彼嚼杂叶者。佛言不应尔。彼纯嚼皮。佛言不应尔。时有比丘嚼短杨枝。见佛恭敬故便咽即以为患。诸比丘白佛。佛言不应尔。极短者长四指。彼于多人行处嚼杨枝。若在温室若在食堂若在经行堂。诸比丘见恶之。往白佛。佛言不应尔。有三事应在屏处。大小便嚼杨枝。如是三事应在屏处。时诸比丘舌上多垢。佛言听作刮舌刀。彼用宝作。佛言不应尔。听用骨牙角铜铁白镴铅锡舍罗草竹苇木。彼不洗便举。余比丘见恶之。佛言不应尔应洗。彼洗已不晒燥。便举生坏。佛言不应尔。时诸比丘患食物入齿间。佛言听作摘齿物。彼用宝作。佛言不应用宝作。听用骨牙角乃至竹木作。彼用已不洗便举。诸比丘见皆恶之。佛言不应尔。应洗。彼洗已不晒燥。便举生坏。佛言不应尔。应令燥举之。时诸比丘患耳中有垢。佛言听作挑耳篦。彼用宝作。佛言不应尔。听用骨牙角乃至竹木作。彼用已不洗便举。诸比丘见恶之。佛言不应尔。应洗已举之。彼不燥便举生坏。佛言不应尔。应令燥已举之。尔时世尊在舍卫国。时诸比丘多畜鹦鹉鸟鸲鹆鸟。初夜后夜鸣唤。乱诸比丘坐禅。诸比丘白佛。佛言不应畜如是鸟

尔时世尊在拘睒弥。时跋难陀释子畜狗子。见诸比丘吠。比丘白佛。佛言不应畜

尔时世尊在婆只提国。时毗舍离婆阇子比丘畜罴子。裂破比丘衣钵坐具针筒。乃复伤比丘身体。诸比丘白佛。佛言不应畜

尔时世尊在毗舍离国。时诸离奢。乘象马车乘辇舆捉持刀剑。来欲见世尊。彼留刀杖在寺外。入内问讯。时六群比丘出外。辄乘彼象马车乘辇舆捉持刀剑共戏。时诸居士见皆共讥嫌言。沙门释子不知厌足无有惭愧。乃乘彼象马车乘捉持刀剑共戏。犹如国王大臣。诸比丘白佛。佛言。比丘不应乘象马车乘辇舆而共戏笑。比丘亦不应捉持刀剑。时诸上座老病比丘。不能从此住处至彼处。畏慎不敢骑乘。佛言。听乘步挽车若男子乘一切畜生乘亦男。彼有命难净行难。畏慎不敢骑乘避走。佛言。若有如是难。听乘象马避。时诸白衣持刀剑来寄诸比丘藏。比丘畏慎不敢受。世尊有如是教。不听持刀剑。白佛。佛言。听为檀越牢坚故藏举

尔时世尊在拘睒弥国。王忧陀延。是宾头卢亲厚知识。王朝晡常往问讯。时有不信乐婆罗门大臣从王。白王言。云何大王。朝晡问讯此下贱业人。而见王不起。王即报言。明日清旦当往。若故不起当夺其命。王明日清旦便往宾头卢所。遥见王来便作是念。此王今怀恶心来。若我不起当夺我命。我今若起彼失王位。若我不起。当夺我命而堕地狱。令此王堕地狱耶。失王位耶。寻复念言。宁令失位。不可令堕地狱。即便起远迎。先意问讯言。善来大王。王问言。汝今何故起迎我耶。答言为汝故起。王言。昨日何故不起。答言。亦为汝故。王问言。云何为我耶。答言。汝昨日善心来。今日怀恶心来。若我不起当夺我命。若夺我命必堕地狱。我念言。此王持恶心来。若我不起当夺我命。若我起者必失王位。若夺我命必堕地狱。宁当令失王位。不令堕地狱。是故起耳。王问言。我当失位耶。答言失。王复问言。几日当失。答言。却后七日。时王即还拘睒弥。修治城堑。收检谷食柴薪。聚集军众守城警备。数日过言。今日是初日。如是乃至七日。作如是言。沙门语虚。便与诸婇女在恒水中乘船游戏。时慰禅王国内七年不雨。彼闻摩竭国王瓶沙有出水珠若出此珠天即降雨。彼便兴四部兵往王舍城围城而住。彼城牢固。非余方便可得。唯水谷饮食尽。乃可得耳。时城内有多方便智慧大臣。教以竹苇着池中令众莲花在孔中生出竹上。时彼大臣。至瓶沙王所白言。王今知不。王舍城牢固。非余方便可得。唯水谷尽乃可得耳。今应遣人语波罗殊提王如是言。今可且停。不须象马车乘刀剑共斗。汝今可用众华优钵罗钵头摩拘头摩分陀利华共斗。我亦当以如是华共斗。汝复可作饭抟相打共斗。我亦作饭抟共斗。王言可尔。时即遣使。往波罗殊提王所。具说上言。彼作是念。王舍城牢固。唯有水谷饮食尽乃可得。而城内水谷饮食丰多。彼即报使言。我不为城故来。我国内七年不雨。闻汝国中有水珠若出此珠时天即降雨。以是故来。使答言。大王。初时何不言须珠。若言须珠。我即当与。王今可去。寻当送珠。王即还军向拘睒弥国。彼闻王忧陀延与婇女游戏声。即问傍人言。戏声是何人。傍臣答言。大王知不。王忧陀延与诸婇女乘船游戏于恒水中。是彼戏声王即敕傍人勿作声。放象于恒水边。彼即放第一白象藏守象人。时王忧陀延大臣出见白象。白王言。有野象。王即敕人言。勿作声牵船近岸。彼即近岸。王忧陀延。善知调象法术。即诵术弹琴往前取象。时守象人即便捉王。王甚恐怖。彼问王言怖耶。王言我怖。彼言王勿怖。波罗殊提王唤王。王更恐怖念言。波罗殊提。将无杀我并及侍从耶。即便系之。卫送往波罗殊提王所。问言汝怖耶。答言怖。王言勿怖。汝可教我儿瞿波罗调象术并教我女弹琴。彼将至慰禅国七年中锁脚。时跋难陀释子。从拘睒弥奢弥跋提夫人所。来至慰禅国忧陀延所。持王忧陀延信。往夫人所。诸比丘白佛。佛言。比丘不应为白衣作使。若作突吉罗。时彼教王儿调象术。教女弹琴。后于异时。遂与王女共通。拘波罗王子知之。彼作是念。若我白王必夺其命。彼是我师。教我辛苦。此是王女。彼是王得应尔耳。即覆藏不语人。后王忧陀延欲逃走。即自严疾行牸象。拘婆罗知之。便作是念。彼自严疾行象。必欲逃走。若我白王必夺其命。此是我师。教我辛苦。遂藏不语人。彼安王女置象上。于象上饮。失琉璃器。未至地顷。已从慰禅至拘睒弥国。王即至奢弥跋提夫人所。语如是言。我在彼系。时誓言。当供养八婆罗门一切所须皆令具足。今欲与之。便可办具。夫人言。若如是者。诸象马车金银七宝王及我身一切。当尽如许所有并与一人。彼亦都受犹无厌足。王言。今当云何。夫人言。此摩诃迦旃延。是大婆罗门种。今可请之并更请余七婆罗门种比丘。以王如许供具与此八人。彼法不受。若与亦不受。王言可尔。时王忧陀延。即往迦旃延所。头面礼足却坐一面。时迦旃延种种方便为王说法令得欢喜。时王闻法欢喜已。白如是言。愿受我明日请食通已八人。时迦旃延默然受之。时王见迦旃延默然受请已。从座起头面礼足欢喜而去。王还其家办种种多美饮食。明日清旦往白时至。时大迦旃延。清旦着衣持钵通已八人。往王忧陀延宫敷座而坐。王忧陀延。手自斟酌种种多美饮食令得饱足。食已舍钵。取金瓶盛水授之。以象布施。迦旃延言。止止。王此便为供养已。我等不应受如是供养。复以车马人兼金银琉璃颇梨真珠车磲马瑙七宝布施。迦旃延言。止止。此便为供养。我等不应受如是供养。时王忧陀延。即礼迦旃延足已。更取卑床坐。时迦旃延。种种为王说法。令得欢喜已。从坐起而去。还寺内白诸比丘。诸比丘白佛。佛尔时以此因缘集比丘僧。为诸比丘说大小持戒揵度。如来出世应供正遍知明行足为善逝世间解无上士调御丈夫天人师佛世尊。于一切诸天世人沙门婆罗门天魔梵王众中而自觉悟证知为人说法。初语亦善中语亦善下语亦善。文义具足开显净行。若居士居士子闻。若复余种姓生者。彼闻正法便生信乐。以信乐心而作是念。我今在居家妻子系缚。不得纯修梵行。我今宁可剃除须发披袈裟以信舍家入非家道。彼于异时。钱财若多若少皆悉舍弃。亲属若多若少皆亦舍离。剃除须发披袈裟。舍家入非家道。彼与出家人同除舍饰好。与诸比丘同戒。不杀生放舍刀杖。常有惭愧慈念众生。是为不杀生舍偷盗。与便取。不与不取。其心清净无有盗意。是为不偷盗。舍淫不净行。修梵行勤精进。不着欲爱。清净香洁而住。是为舍淫不净行。舍妄语。如实不欺诈于世。是为不妄语。舍两舌。若闻此语不传至彼。若闻彼语不传至此。不相坏乱。若有离别善为和合。和合亲爱常令欢喜。出和合言所说知时。是为不两舌。离粗恶言。所言粗犷。苦恼他人。令生嗔恚。而不喜乐。断除如是粗恶言。言则柔软。不生怨害。能作利益。众人爱乐。乐闻其言。常出如是利益善言。是为不粗恶言。离无利益语。知时语实语利益语。法语律语灭诤语。有缘而说。所言知时。是为离无利益语。不饮酒离放逸处。不着华香璎珞。不歌舞倡伎。亦不往观听。不高广床上坐非时不食。若是一食。不把持金银七宝。不取妻妾童女。不畜养奴婢象马车乘鸡狗猪羊田宅园观储积畜养一切诸物。不欺诈轻秤小斗。不合和恶物不治生贩卖。断他肢节杀害系闭。断他钱财役使作业。言辄虚诈发起诤讼。弃舍他人断除如是诸不善事行。则知时非时不行。量腹而食度身而衣。取足而已衣钵自随。犹若飞鸟羽翮身俱。比丘如是所去之处。衣钵随身。如余沙门婆罗门受他信施。求种种余积饮食衣服香味触法。离如是无厌足事。如余沙门婆罗门食他信施。聚集种子种殖树木鬼神村。离如是事。如余沙门婆罗门食他信施。但作方便求诸利养。象牙杂宝高广大床。种种文绣被褥。及与杂色诸皮。离如是利养法。如余沙门婆罗门食他信施。但作方便求自严身。酥油摩身香水洗浴。以香涂身香泽梳头。着好华鬘染眼绀色。种种庄严面首。色綖系臂捉通中杖。执持刀剑并孔雀盖。以珠为扇以镜自照。着杂色革屣。着纯白衣。能离如是庄严之事。如余沙门婆罗门食他信施专为嬉戏。棋局博掩樗蒱八道十道或复拍石。断除如是种种嬉戏。如余沙门婆罗门食他信施。但说妨道法。说王事贼事斗战军马事大臣事骑乘事园观出入事卧起事女人事衣服饮食事亲里事国土事思忆世间入大海事。断除如是一切妨道之业。如余沙门婆罗门食他信施。无数方便但作谀谄美辞。现相毁訾以利求利。舍如是邪命谀谄。如余沙门婆罗门食他信施。常共讲论诤言。或在园观。若在浴池。或在讲堂。我知如是法律。汝无所知。汝趣邪道。我向正道。以前言着后。后言着前。我能忍汝不能忍。我胜汝汝但狂言。共汝论议我今得胜。能问便问。除断如是一切诤事。如余沙门婆罗门食他信施。但作方便求为使命。若为王王大臣婆罗门若居士通信。从此处往彼处。从彼还此。持此信往彼。持彼信来此。自作是教他作是。能远离如是使命事。如余沙门婆罗门食他信施。但作种种斗戏。或弓斗或刀斗或杖斗。或鸡斗或狗斗或斗猪。或斗羖羊。或斗羝羊。或斗鹿或斗象。或斗马或斗驼或斗牛。或犎牛斗或水牛斗。或斗女人或斗男子。或斗童男童女。断除如是一切嬉戏斗事。如余沙门婆罗门食他信施。行妨道法邪命自活。瞻相男女好恶相。种种畜生以求利养。断除如是种种妨道法。如余沙门婆罗门食他信施。行妨道法邪命自活。召唤鬼神或复驱遣种种厌祷。除断如是妨道法。如余沙门婆罗门食他信施。行妨道法邪命自活。或为人咒病。或诵恶术。或诵好咒。或治背病若为出汗。或行针治病。或治鼻或治下部病。除断如是邪命妨道法。如余沙门婆罗门食他信施。行妨道法邪命自活。行药疗治人病或吐或下治男治女。除断如是妨道法。如余沙门婆罗门食他信施行妨道法邪命自活或咒火。或咒行来令吉利。或诵刹利咒。或诵鸟咒。或诵枝节咒。或诵安置舍宅符咒。若火烧鼠啮物能为解咒。或诵别死生书。或诵别梦书。或相手相肩。或诵天人问。或诵别鸟兽音声书。除断如是妨道法。如余沙门婆罗门食他信施邪命自活。瞻相天时。或言当雨或言不雨。或言谷贵或言谷贱。或言多病或言少病。或言恐怖或言安隐。或言地动。或言彗星现。或言月蚀或言不蚀。或言日蚀。或言不蚀或言星蚀。或言不蚀或言月蚀有如是好报有如是恶报。日蚀星蚀亦如是。除断如是邪命法。如余沙门婆罗门食他信施行妨道法邪命自活。或言此国当胜彼国不如。或言彼国胜此国不如。或此胜彼不如。或言彼胜此不如。瞻如是吉凶好恶。除断如是妨道法。彼于此事中修集圣戒。内无所著其心安乐。眼虽视色而不取相。不为眼色所劫。眼根坚固寂然而住。无所贪欲而无忧患。不漏诸恶不善法。坚持戒品能善护眼根。耳鼻舌身意亦如是。于如是六触入中善学护持调伏令得止息。犹若平地四交道头。驾象马车乘。善调御者。左执鞚右持鞭。善学护持善学调伏善学止息。比丘亦如是。于六触入中。善学护持善学调伏善学止息。彼有如是圣戒得圣眼根。食知止足亦不贪味。以养其身。而不贡高憍慢取自支身。令无苦患。得修净行。故苦消灭。新苦不生。无有增减。有力无事。令身安乐。犹如男子女人身患疮以药涂之取令疮差。比丘食以知足。取令身安亦复如是。譬如人以膏油膏车为财物故欲令转载有所至到。比丘食知止足取令支身亦复如是。比丘有如是圣戒得圣诸根。于食中能知止足。初夜后夜精进觉悟。若在昼日若行若坐。常尔一心念除诸盖。彼于初夜若行若坐。常尔一心念除诸盖。彼于中夜侧右胁累脚而卧。念当时起。系想在明。心无错乱。至于后夜便起思惟若行若坐。常尔一心念除诸盖。比丘有如是圣戒逮圣诸根。食知止足。初夜后夜精进觉悟。常尔一心念无错乱。云何比丘念无错乱。比丘如是观内身身念处。精进不懈念无错乱。调伏悭贪世间忧恼。观外身身念处。精进不懈念无错乱。调伏悭贪世间忧恼。观内外身身念处。精进不懈念无错乱。调伏悭贪世间忧恼受心法亦如是。是为比丘念无错乱。云何比丘一心若行步入出。左右视瞻屈申俯仰。执持衣钵。受取饭食。大小便利。睡眠觉悟。若坐若立。若有所说。若复寂然。如是一切常尔一心。是为一心。譬如有人与大众共行。若在前若在中若在后。常得安乐而无有畏。比丘亦复如是。行步入出乃至默然。常尔一心。比丘有如是圣戒。得圣诸根。食知止足。初夜后夜精进觉悟。常尔一心无有错乱。乐在阿兰若处树下住。或乐处山窟若在露地粪聚边。若在冢间水岸间。彼乞食还已洗足。安置衣钵结加趺坐。直身正意系念在前。断除悭贪心不与俱。断除嗔恚无有怨嫉。心住无嗔。清净无恚。常有慈愍。除去睡眠不与共俱。系想在明念无错乱。除断调愧不与共俱。内心寂灭调愧心净。除断于疑。已度于疑。其心一向在于善法。譬如有奴大家与姓安隐脱奴。彼自念言我先是奴。而今解脱安隐。已得自在。不复从人。以是因缘便得欢喜其心安乐。又如有人举他财物而行治生。能得利息还本既毕。复有余在。足以养活妻子。彼自念言。我先举债以用治生。而得利息。既得还本。复有余在。足养妻子。我今便得自在。不复畏人。以是因缘便得欢喜其心安乐。如人久病从病得差。食饮消化身有色力。彼作是念。我先有病而今得差。饮食消化身有色力。以是因缘便得欢喜其心安乐。如人久闭牢狱从狱安隐得脱。彼作是念。我先系闭。今已得脱。无所复畏。以是因缘便得欢喜其心安隐。如人多持财宝度大旷野不遭贼劫安隐得过。彼作是念。我先多持财宝从旷野得过。而今无所复畏。以是因缘便得欢喜其心安乐。比丘有五盖亦复如是。如奴负债久病在狱行大旷野。自见未断诸结。令心染污。慧力不明。彼即舍欲恶不善法。与觉观俱而受喜乐。得入初禅。彼以喜乐润渍于身。遍满盈溢无不遍处。如人巧浴器盛细末药。以水渍之和合相得。其水润渍无有不润。而无零落。比丘得入初禅。亦复如是。喜乐遍身无有空处。此是最初现身得乐。何以故。由不放逸精进不懈念无错乱乐处寂静故。彼舍觉观便生内信。心在一处。无觉无观。心定喜乐。入第二禅。彼以心定喜乐润渍于身。遍满盈溢无不遍处。犹如山顶之泉水自中出。亦不从东西南北及从上来。即此池中清冷水出。润渍一池遍满盈溢无有空处。比丘入第二禅亦复如是。心定喜乐遍满盈溢。此是第二现身得乐。彼舍喜心。住护念乐。身受快乐。如圣所说护念快乐。入第三禅。彼于身无喜。以乐润渍。遍满盈溢。无有空处。譬如优钵罗华拘头摩分陀利华。虽生出地而未出水。根茎华叶润渍水中。无有空处。而不润渍。比丘入第三禅亦复如是。离喜住乐。润渍于身。无不遍处。此是第三禅得现身快乐所游戏处。彼舍苦乐忧喜。先断不苦不乐。护念清净。入第四禅。身心清净具满盈溢。无不遍处。由若男子女人沐浴净洁。被以新白净衣。无有不覆之处。比丘入第四禅亦复如是。其心清净遍满于身。无空缺处。彼入第四禅。心不掉动。亦不懈怠。不与爱恚相应。住无动地。譬如密屋。内外泥治。坚闭户向。无有风尘。于内然灯。无有人非人风鸟扇动。其灯焰直上。无有曲戾。恬定而然。比丘入第四禅亦复如是。无有掉动。心无懈怠。不与爱恚相应。已住无动地。此是第四禅现身得乐所游戏处。何以故。由不放逸精进不懈念不错乱乐处寂静故。彼得定心清净。无有垢秽。柔软调伏住无动地。自于身中起心。能化作异身。肢节具足诸根无阙。时即观之。此身色四大合成。彼身色化有。此四大身色异。彼化身四大色异。从此四大。身色中起心化作。彼身诸根肢节具足。譬如有人鞘中拔刀。彼作是念。此是鞘此是刀。刀异鞘异。从此鞘中拔刀出。亦如人筐中出蛇。彼作是念。此是筐此是蛇。筐异蛇异。从此筐中出蛇。譬如有人从簏出衣。彼作是念。此是簏此是衣。簏异衣异。从簏中出衣。比丘亦复如是。此是比丘初胜法。何以故。由不放逸精进不懈念无错乱乐寂静故。彼以定心清净乃至入不动地。从己四大色身中。起心化作化身。一切诸根肢节具足。彼作是念。此身是四大合成。彼身从化而有。此四大色身异。彼化四大色身异。此心在此身依此身系此身。譬如琉璃摩尼珠莹治甚明清净无垢。若以青黄赤綖贯之。有眼男子置掌而观。此是珠此是綖。珠异綖异。此珠系在于綖。比丘亦复如是。从此四大色身。起心化作化身。一切诸根肢节具足。而作是念。此身是四大合成。彼身从化而有。此四大色身异。彼化四大色身异。此心在此身依此身系。此身此是比丘第二胜法。何以故。由不放逸精进不懈念无错乱乐寂静故。彼以定心清净。乃至入无动地。一心修习神通智证。彼便能作种种变化。以一身为无数身。无数身还为一身。身能飞行石壁皆过。无所触阂如行虚空。行住空中如鸟飞翔。出没于地如水涌波或烟或焰若大火积。手能扪摸日月。身至梵天。譬如陶师善调和泥。随意所造。欲作何器便能成之而有利益。譬如巧匠善能治木随意所造自在成之而有利益。譬如治象牙师善能治牙随意所作自在。成之而有利益。譬如金师善炼真金随意所作自在成之而有利益。比丘亦复如是。定心清净至无动地。随意所作乃至梵天。此是比丘第三胜法。彼以定心清净乃至入无动地。一心修习证天耳智。彼天耳清净过出于人耳。闻二种声人非人。譬如于城郭国邑中有讲堂广大高显有聪耳人在中不劳听力而闻种种音声。比丘亦复如是。以心定故。天耳清净。得闻人非人种种音声。此是比丘第四胜法。彼以定心清净乃至入无动地。一心修习证他心智。彼知外众生心有欲无欲有垢无垢有痴无痴广心略心小心大心定心乱心缚心脱心上心无上心皆悉知之。譬如自喜男子女人以水镜自照无不得见。比丘亦复如是。以定心清净故。知外一切众生心之所念。此是比丘第五胜法。彼以定心清净乃至入无动地。一心修习宿命智证。便能忆识宿命无数若干种事。能忆一生十生百生千生无数百千生。劫烧都尽国土还生。我在彼生名字如是。种如是姓如是。食如是寿命如是在世如是。寿尽如是受苦乐如是。从彼命终复生于彼。如是展转来生于此。如是形色相貌无数种种皆悉忆识。譬如有人从己村落往至他国。在于彼间。若行若住若语若默。从彼国复往余国。若行若住若语若默。如是展转复还其国。不劳多力而能忆识所行诸国。我从此国乃往彼国。在彼国内如是行如是住如是语如是默。从彼国复至彼国。在彼国如是行如是住如是语如是默。如是展转还至本国。比丘亦如是。能以定心清净乃至无动地。以宿命智证。能忆无数百千劫种种众事。此是比丘得第一明。断灭无明。明法生。闇已去。明晓法存。此是比丘忆宿命智证明。何以故。由不放逸精进不懈心无错乱乐处寂静故。彼以定心清净乃至无动地。一心修习见众生死此生彼。智证彼天眼清净。见众生死此生彼。形色好丑善恶诸道尊贵卑贱。随众生所造业报因缘皆能知之。如此人造身恶行口恶行心恶行诽谤贤圣邪见。以邪见报故。堕地狱饿鬼畜生。如此众生。身行善口行善心念善不诽谤贤圣正见修习正业。身死得生天上人中如是天眼清净。见众生死此生彼。随众生所造业因。皆悉知之。譬如广大平地四交道头有高显大堂。有明眼人在中。见众生从东方来至西方。从西方往东方。从南方往北方。从北方往南方。比丘如是。以定心清净乃至无动地。见众生死此生彼智证以天眼清净。见众生死此生彼。乃至随众生所造业报因缘。皆悉知之此是比丘得第二明。断无明。明法生。闇已去。明晓法存。此是见众生死此生彼智证明。何以故。由不放逸精进不懈心不错乱乐寂静故。彼以定心清净。乃至无动地。一心修习无漏智证。彼如实知苦圣谛集尽道谛。如实知有漏漏集漏尽。如实知趣漏尽道圣谛。彼如是知如是见。从欲漏有漏无明漏。心得解脱。已得解脱智。我生已尽。梵行已立。所作已办。更不复生。譬如清水中。有木石鱼鳖水性之属。东西游行。有眼者观之。见木石鱼鳖。此是木石。此是鱼鳖。东西游行。比丘亦复如是。以定心清净至无动地。得无漏智证。乃至不复更生。此是比丘得第三明。断无明。明法生。闇法去明晓法存。是为无漏智明。何以故。由不放逸精进不懈念无错乱乐处寂静故(杂揵度具足竟)

四分律卷第五十三四分律卷第五十四(第四分之五)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    集法毗尼五百人

尔时世尊。在拘尸城末罗园娑罗林间般涅槃。诸末罗子。洗佛舍利已。以净劫贝裹。复持五百张叠次而缠之。作铁棺盛满香油。安舍利置中。以盖覆上。复作木椁。安铁棺着中。下积众香薪。时末罗子中为标首者。持火然之。时天即灭火。余大末罗子。展转皆以大炬然之。时天亦皆灭之。阿那律语末罗子。不须乃尔疲苦。诸天灭汝等火。即问阿那律言。大德。诸天何故灭火。答言。摩诃迦叶。在波婆拘尸城。两国中间在道行。与大比丘众五百人俱。彼作是念。我当得见未烧佛舍利不耶。诸天知迦叶心如是念。以是故灭火。末罗子言。大德阿那律。今便小停。遂彼诸天意。尔时摩诃迦叶。在彼二国中间道行。与大比丘僧五百人俱。时有异尼揵子。持世尊般涅槃时曼陀罗华在道行。时迦叶遥见而问言。汝等从何所来。彼答言。我从拘尸城来。复问言。识我世尊不。答言识。复问今故在世不。答言不在世。般涅槃来已七日。我从彼持此华来。时迦叶闻之不悦。中有未离欲比丘。闻世尊已取涅槃。便自投乎地。譬如斫树根断树倒。此诸未离欲比丘亦复如是。啼哭而言。善逝涅槃。何乃太早世间明眼。何乃速灭。我曹所宗之法。何得便尽。或有宛转在地。犹若圆木。此诸未离欲比丘。亦复如是。啼哭忧恼而言。善逝涅槃何乃太早。尔时有跋难陀释子在众中。语诸比丘言。长老且止。莫大忧愁啼哭。我等于彼摩诃罗边得解脱。彼在时数教我等。是应是不应。当作是不应作是。我等今者便得自任。欲作便作。欲不作便不作。时大迦叶闻之不悦。即告诸比丘言。且起疾捉衣钵。时往及世尊舍利未烧当得见。诸比丘闻迦叶言。即疾疾执持衣钵。于是大迦叶。与五百人俱。往拘尸城已。出城渡醯兰若河。往天观寺。至阿难所语言。阿难。我欲及世尊舍利未烧见之。阿难答言。欲及世尊舍利未烧。而欲见之。难可得见。何以故。世尊舍利已洗浴。裹以新劫贝。复以五百张叠次而缠之。置在铁棺。盛满香油。着木椁中。下积众香薪。今垂欲烧之。是故难可得见。时大迦叶渐前往佛舍利积所。棺椁即自开。世尊现足。时大迦叶。见世尊足下轮相垢污。即问阿难。世尊颜容端政身作金色。谁污足下轮相。阿难答言。大德迦叶。女人心软。前礼佛时泣泪堕上。手捉污世尊足。大迦叶闻之不悦。即礼世尊足。比丘比丘尼优婆塞优婆私诸天大众亦皆礼佛足。时世尊足还内棺中不现。时大迦叶哀叹说偈绕棺七匝。火不烧自然。时大迦叶烧舍利已。以此因缘集比丘僧。告言。我先在道行时。闻跋难陀语诸比丘。作如是言。长老且止。莫复愁忧啼哭。我等今于彼摩诃罗边得解脱。彼在世时教呵我等。是应尔是不应尔。应作是不应作是。今我等已得自在。欲作便作。不作便不作。我等今可共论法毗尼。勿令外道以致余言讥嫌。沙门瞿昙法律若烟。其世尊在时皆共学戒。而今灭后无学戒者。诸长老。今可料差比丘多闻智慧是阿罗汉者。时即差得四百九十九人。皆是阿罗汉多闻智慧者。时诸比丘言。应差阿难在数中。大迦叶言。勿以阿难在数中。何以故。阿难有爱恚怖痴。有爱恚怖痴。是故不应令在数中。时诸比丘复言。此阿难是供养佛人。常随佛行。亲从世尊。受所教法。彼必处处疑问世尊。是故今者应令在数。即便令在数。诸比丘皆作是念。我等当于何处集论法毗尼多饶饮食卧具无乏耶。即皆言。唯王舍城房舍饮食卧具众多。我等今宜可共往集彼论法毗尼。时大迦叶即作白。大德僧听。此诸比丘为僧所差。若僧时到僧忍听。僧今往王舍城集共论法毗尼。白如是。作白已。俱往毗舍离。时阿难在道行。静处心自念言。譬如新生犊子犹故饮乳。与五百大牛共行。我今亦如是学人有作者。而与五百阿罗汉共行。时诸长老皆往毗舍离。阿难在毗舍离住。诸比丘比丘尼优婆塞优婆私国王大臣种种沙门外道。皆来问讯多人众集。时有跋阇子比丘。有大神力。已得天眼知他心智。作如是念。今阿难在毗舍离。比丘比丘尼优婆塞优婆私国王大臣种种沙门外道。皆来问讯多人众集。我今宁可观察阿难。为是有欲无欲耶。即便观察阿难。是有欲非是无欲。复念言。我今当令其生厌离心。将欲令阿难生厌离心。即说偈言

  静住空树下　　心思于涅槃
  坐禅莫放逸　　多说何所作

时阿难闻跋阇子比丘说厌离已。即便独处精进不放逸寂然无乱。是阿难未曾有法。时阿难在露地敷绳床夜多经行。夜过明相欲出时身疲极。念言。我今疲极。宁可小坐。念已即坐。坐已方欲亚卧。头未至枕顷于其中间心得无漏解脱。此是阿难未曾有法。时阿难得阿罗汉已。即说偈言

  多闻种种说　　常供养世尊
  已断于生死　　瞿昙今欲卧

时诸比丘。从毗舍离往王舍城作如是言。我等先当作何等。为当先治房舍卧具。先论法毗尼耶。皆言。先当治房舍卧具。即便治房卧具。时大迦叶以此因缘集比丘僧。中有陀醯罗迦叶作上座。长老婆婆那为第二上座。大迦叶为第三上座。长老大周那为第四上座。时大迦叶。知僧事即作白。大德僧听。若僧时到僧忍听。僧今集论法毗尼。白如是。时阿难即从坐起偏露右肩右膝着地合掌。白大迦叶言。我亲从佛闻。忆持佛语。自今已去。为诸比丘舍杂碎戒。迦叶问言。阿难汝问世尊不。何者是杂碎戒。阿难答言。时我愁忧无赖失。不问世尊。何者是杂碎戒时诸比丘皆言。来我当语汝杂碎戒。中或有言。除四波罗夷。余者是杂碎戒。或有言。除四波罗夷十三事。余者皆是杂碎戒。或有言。除四波罗夷十三事二不定法。余者皆是杂碎戒。或有言。除四波罗夷十三事二不定法三十事。余者皆是杂碎戒。或有言。除四波罗夷乃至九十事。余者皆是杂碎戒。时大迦叶告诸比丘言。诸长老。今者众人言各不定。不知何者是杂碎戒。自今已去。应共立制。若佛先所不制。今不应制。佛先所制。今不应却。应随佛所制而学。时即共立如此制限

大迦叶语阿难言。汝于佛法中先求度女人得突吉罗罪。今应忏悔。阿难答言。大德。此非我故作。摩诃波阇波提于佛有大恩。佛母命过长养世尊。大德迦叶。我今于此不自见有罪。以信大德故。今当忏悔。大迦叶复言。汝令世尊三反请。汝作供养人。而言不作。得突吉罗罪。今当忏悔。阿难答迦叶言。我不故作。为佛作供养人难。是故言不能耳。我于此中不自见有罪。以信大德故。今当忏悔。迦叶复言。汝为佛缝僧伽梨。脚蹑而缝。得突吉罗罪。今应忏悔。阿难答言。大德迦叶。非我慢而故作。更无人捉故尔耳。我于此不自见有罪。信大德故。今当忏悔。迦叶复言。世尊欲取涅槃三反告汝。汝不请世尊住世若一劫若过一劫令无数人得利益慈愍世间诸天人民令得安乐。汝得突吉罗罪。今应忏悔。阿难答言。大德迦叶。非我故作。魔在我心。令我不请佛住世。我于此中不自见有罪。信大德故。今当忏悔。迦叶复言。世尊在时。从汝索水。汝不与。得突吉罗罪。今应忏悔。阿难答言。非我故作。时有五百乘车从水中过。其水甚浊。恐世尊饮之作患。是故不与。迦叶复言。汝但应与。若佛威神或复诸天能令水清净阿难言。我于此中不自见有罪。信大德故。今当忏悔。迦叶复言。汝不问世尊。何者是杂碎戒。得突吉罗罪。今应忏悔。阿难言。我非故作。时我愁忧无赖失不问世尊。何者是杂碎戒。我于此中不自见有罪。信大德故。今当忏悔。迦叶复言。汝不遮女人。令污佛足。得突吉罗罪。今应忏悔。阿难答言。非我故作。女人心软礼佛足时泣泪手污佛足。我于此中不自见有罪。信大德故。今当忏悔。时大迦叶即作白言。大德僧听。若僧时到僧忍听。僧今问优波离法毗尼。白如是。时优波离即作白。僧大德僧听。若僧时到僧忍听。僧今令上座大迦叶问我答。白如是。时大迦叶即问言。第一波罗夷。本起何处。谁先犯。优波离答言。在毗舍离须提那迦兰陀子初犯。第二复本起何处。答言。在王舍城陀尼伽比丘陶师子初犯。复问。第三本起何处。答言。在毗舍离婆裘河边比丘初犯。复问。第四本起何处。答言。在毗舍离婆裘河边比丘初犯。复问。第一僧残本起何处。答言。在舍卫国迦留陀夷初犯。如是展转随所起处。如初分说。复问。第一不定法本起何处。答言。在舍卫国迦留陀夷初犯。第二亦尔。复问。尼萨耆本起何处。答言。在舍卫国六群比丘初犯。如是展转亦如初分说。复问。初波逸提本起何处。答言。在释翅瘦象力释子比丘初犯。如是展转如初分说。复问。波罗提提舍尼本起何处。答言。在舍卫国因莲花色比丘尼起。第二第三第四如初分说。复问。第一众学法本起何处。答言。在舍卫国六群比丘初犯。如是展转如初分说。比丘尼别戒如律所说。复问。最初听受大戒本起何处。答言。在波罗奈五比丘。复问。最初听说戒在何处。答言。在王舍城为诸少年比丘。复问。初听安居本起何处。答言。在舍卫国因六群比丘起。复问。初自恣本起何处。答言。在舍卫国因六群比丘起。如是展转问乃至毗尼增一。时彼即集比丘一切事并在一处。为比丘律。比丘尼事并在一处。为比丘尼律。一切受戒法集一处为受戒犍度。一切布萨法集一处。为布萨犍度。一切安居法集一处。为安居犍度。一切自恣法集一处。为自恣犍度。一切皮革法集一处。为皮革犍度。一切衣法集一处。为衣犍度。一切药法集一处。为药犍度。一切迦絺那衣法集一处。为迦絺那衣犍度。二律并一切犍度调部毗尼增一都集。为毗尼藏。时大迦叶即作白。大德僧听。若僧时到僧忍听。僧今问阿难法毗尼。白如是。时阿难即复作白。大德僧听。若僧时到僧忍听。僧今令大迦叶问我答。白如是。大迦叶即问阿难言。梵动经在何处说。增一在何处说。增十在何处说。世界成败经在何处说。僧祇陀经在何处说。大因缘经在何处说。天帝释问经在何处说。阿难皆答。如长阿含说。彼即集一切长经。为长阿含。一切中经。为中阿含。从一事至十事从十事至十一事。为增一。杂比丘比丘尼优婆塞优婆私诸天杂帝释杂魔杂梵王。集为杂阿含。如是生经本经善因缘经。方等经未曾有经譬喻经。优婆提舍经句义经。法句经波罗延经。杂难经圣偈经。如是集为杂藏。有难无难系相应作处。集为阿毗昙藏。时即集为三藏。时长老富罗那。闻王舍城五百阿罗汉共集法毗尼。即与五百比丘俱。往王舍城。至大迦叶所。语如是言。我闻大德与五百阿罗汉共集法毗尼。我亦欲豫在其次闻法。时大迦叶。以此因缘集比丘僧。为此比丘。更问优波离。乃至集为三藏。如上所说。彼言。大德迦叶。我尽忍可此事。唯除八事。大德。我亲从佛闻。忆持不忘。佛听内宿内煮自煮自取食。早起受食。从彼持食来。若杂果。若池水所出可食者。如是皆听不作余食法得食。大迦叶答言。实如汝所说。世尊以谷贵时世人民相食乞求难得。慈愍比丘故。听此八事。时世还丰熟饮食多饶。佛还制不听。彼复作是言。大德迦叶。世尊是一切知见。不应制已还开开已复制。迦叶答言。以世尊是一切知见故。宜制已还开开已复制。富罗那。我等作如是制。是佛所不制不应制。是佛所制则不应却。如佛所制戒应随顺而学。在王舍城五百阿罗汉共集法毗尼。是故言集法毗尼有五百人

    七百集法毗尼

尔时世尊般涅槃后百岁。毗舍离跋阇子比丘。行十事言。是法清净。佛所听应两指抄食。得聚落间。得寺内。后听可。得常法。得和。得与盐共宿。得饮阇楼罗酒。得畜不截坐具。得受金银。彼于布萨日。檀越布施金银。而共分之。时有耶舍迦那子。闻毗舍离比丘行如是事。即往跋阇子比丘所。见劝檀越布萨时布施众僧金银。僧中唱令。与伽那子比丘。即言我不受。何以故。沙门释子不应受取金银。沙门释子舍弃珠宝不着饰好。彼于余日作分已。送与伽那子比丘。伽那子比丘言。我不须。我先言。沙门释子。舍弃珠宝不着饰好。彼即言。毗舍离优婆塞嗔。汝往教化令喜。时即差使共往。耶舍伽那子比丘。至毗舍离优婆塞所。语如是言。汝实嗔我语耶。我言。沙门释子不受取金银。弃舍珍宝不着饰好。语优婆塞言。世尊在王舍城时。王宫中王群臣集。说如是语。沙门释子应得受取金银。不舍珍宝非不着饰好。时彼众中。有大长者字珠髻。语诸大臣言。勿作是言。沙门释子受取金银。不舍珠宝。非不着饰好。何以故。沙门释子不应受取金银。弃舍珠宝不着饰好。时珠髻长者。为诸大臣解说各令得解欢喜。珠髻长者。后于异时。往世尊所。头面礼足却坐一面。以先因缘具白世尊言。我即为解说。各令欢喜。世尊。我说是言。将无违失圣旨不如法教耶。佛言。长者。如汝所说。如法如实。不违世尊教法何以故。沙门释子不应受取金银。除舍珠宝不着饰好。其有受取金银者。则受五欲若受五欲。则非沙门释子法。长者。汝若见沙门释子捉持金银。决定应知非沙门法。我作是说。听为竹[竺-二+韋]草木故求乞金银。终不应自受取金银。是故离奢。以此因缘。沙门释子不应受取金银。弃舍珠宝不着饰好离奢。复于异时。世尊在只桓中。告诸比丘。有四事故。令日月不明。何等为四。阿修罗烟云尘雾是。为四事令日月不明。如是沙门婆罗门。亦有四事。污染尘秽。令沙门婆罗门无有光显。何等四。或有沙门婆罗门。饮酒不能除断。此是第一尘秽。或有沙门婆罗门。行爱欲法不能舍离。此是第二尘秽。或有沙门婆罗门。受取金银不舍饰好。此是第三尘秽。或有沙门婆罗门。以邪命自活不能除断。此是第四尘秽。是为四事。以此四事故。令沙门婆罗门污秽不明无有光显。世尊尔时。即说偈言

  贪欲垢所污　　沙门婆罗门
  愚痴所覆盖　　爱着于好色
  饮酒散乱心　　复行爱欲法
  受取金宝璎　　此为无智者
  沙门婆罗门　　邪命以自活
  佛说此为结　　如日出云翳
  无光显威耀　　不净纯垢污
  盲冥闇所闭　　爱奴之所使
  造恶不善业　　痴何能行道
  怨憎甚增益　　更受未来身

是故离奢。以此因缘故。汝等当知。沙门释子。不应受取金银。除去饰好。我说是语。汝以此事不信我耶。彼离奢言。我非为不信。我有信乐于汝。汝可住此毗舍离。我当供给衣服饮食医药所须之物。时伽那子比丘。与诸离奢解说。令得欢喜已。与彼使比丘俱。还婆阇子比丘所。遥见伽那子比丘来。即问使比丘言。伽那子比丘。已解喻诸离奢得信耶。答言尔。即言。彼已信乐伽那子。持我等作非沙门释子。婆阇子比丘问言。何故耶。即具说先因缘。彼毗舍离比丘。语伽那子比丘言。汝先骂众僧。见罪不。答言。我不骂众僧。彼即和合与作举。伽那子比丘作是念。我此诤事。若得长老离婆多与我作伴者。便可得如法灭。彼即问余人言。离婆多在何处。彼即答言。闻在婆呵河边。即往婆呵河边离婆多不在。彼即问。离婆多在何处。彼即答言。闻在伽那慰阇国。即往彼国。既至。离婆多复不在。复问。离婆多在何处。答言。在阿伽楼罗国。即往彼国。而复不在。即问。离婆多在何处。答言。在僧伽赊国。即复往彼国。见离婆多值众僧集。问离婆多供养弟子言。汝大德长老离婆多。往众僧中不。答言当往。时离婆多。往集僧中听说法已。夜半后捉尼师坛还屋。时耶舍伽那子。亦在僧中。集听法已。夜半后捉尼师坛。往离婆多所。彼作是念。今正是时。当具说先因缘令其得闻。彼即问离婆多言。大德上座。得二指抄食不。彼还问言。云何二指抄食。答言。大德长老。足食已舍威仪不作余食法得二指抄食食不。离婆多言。不应尔。问言。在何处制。答言。在舍卫国不作余食法食。以是故制。复问言。大德长老。得村间不。彼还问言。云何得村间。答言大德长老。足食已舍威仪不作余食法往村中间得食。离婆多言。不应尔。问言。在何处制。答言。在舍卫国不作余食法食以是故制。彼问言。大德长老。得寺内不。彼还问言。云何得寺内。答言。大德长老。在寺内得别众羯磨。离婆多言。不应尔。问言。在何处制。答言。在王舍城布萨犍度中制。大德长老。得后听可不还问言。云何得后听可。答言。大德长老。在界内别众羯磨已后听可。离婆多言。不应尔。问言。在何处制。答言。在王舍城布萨犍度中制。复问。得常法不。还问言。云何得常法。答言。大德长老。此作是已言是本来所作。彼答言。比丘知不。应观修多罗毗尼检校法律。若不观毗尼不检校法律。而违反于法。若已作不应作。未作亦不应作。若观修多罗毗尼检校法律。与修多罗相应。与法律相应。不违本法。若已作若未作应作。复问言。大德长老。得和不。彼还问言。云何得和。答言。大德长老。足食已舍威仪以酥油蜜生酥石蜜酪和一处得食不。答言。不应尔。问言。在何处制。答言。在舍卫国不作余食法食。以是故制。复问。大德长老。得与盐共宿不。彼还问言。云何得与盐共宿。答言。大德长老。得用共宿盐着食中食。答言不应尔。问言在何处制。答言。在舍卫国药犍度中制。复问言。大德长老。得饮阇楼罗酒不。答言。不应尔。问言。在何处制。答言。在拘睒弥国因长老娑伽陀比丘制。复问。大德长老。得畜不割截坐具不。答言不应畜。问言在何处制。答言。在舍卫国因六群比丘制复问。大德长老。得受取金银不。答言不应尔。问言在何处制。答言。在王舍城因跋难陀释子制。彼言大德长老。毗舍离婆阇子比丘。行此十事言。清净如法是佛所听。彼劝檀越。于布萨时施众僧金银。令分物人分。彼言。汝莫语余人。何以故。恐诸比丘所见不同。而不与和合比丘。汝可往阿吁恒河山中。彼处有三浮陀比丘。是我同和上。与六十波罗离子比丘共住。彼皆勇猛精进度无所畏。以此因缘。具为彼说已共期。婆呵河边我亦当往。时耶舍伽那子比丘。即往彼山中。至三浮陀所。以此因缘具向彼说之。期婆呵河边。大德离婆多亦当来。时毗舍离婆阇子比丘。闻耶舍伽那子比丘往人间求索伴党。彼即大持毗舍离好衣。往离婆多弟子所语言。我为大德离婆多故。持此好衣来与。今止不复与。即回与汝可取。彼言止止我不受。彼复勤勤逼令受。彼遂便受。既受已。作是言。长老。彼波夷那波梨二国比丘共诤。世尊出在波夷那国。善哉长老。能为我白大德上座。波夷那波梨二国比丘共诤。世尊出在波夷那国。善哉大德。当助波夷那比丘。彼即答言。大德长老离婆多尊重。我难不敢言。彼即强逼之不已。便往离婆多所。白如是言。大德。彼波夷那波梨二国比丘共诤。世尊出在波夷那。愿大德。助波夷那比丘。彼即答言。汝痴人。持我在不净部中。汝去。不复须汝。彼得遣已。便往毗舍离婆阇子比丘所。语如是言。长老我先语汝。大德离婆多尊重。难可为言。我不能语。今大见责。彼问言说何等。彼言已遣我。复问言汝几腊。答言十二岁。问言汝十二岁。犹故怖畏遣耶。答言。不受我供养云何不畏。时彼离婆多及诸比丘如是语。我等今当往诤所起处。即乘船从恒水中往。时天热疲极。住船在岸边荫下息。时婆搜村有长老在道行。作如是念。我今此诤事。当观修多罗毗尼知谁法语谁非法语。彼即观修多罗毗尼捡校法律。便知波梨国比丘是法语波夷那比丘非法语。时有天不现身而赞言。善哉善男子。如汝所观。波梨比丘如法语。波夷那比丘非法语。时诸长老。即共往毗舍离。毗舍离有长老。字一切去。是阎浮提中最上座。时三浮陀语离婆多言。今往一切去上座屋中宿。具说此事。令其得闻。时二人即共相随。往至彼屋。时一切去长老。夜坐禅思惟夜已久。离婆多作是念。此上座年已老气力羸劣。而久坐如是。况我当不作如是坐。时离婆多即便坐思惟至夜久。一切去长老作是念。此客比丘远来疲极。犹故坐禅思惟如是。况我而不久坐。时彼长老。即复久坐思惟。夜已过多。语离婆多言。长老。汝此夜思惟何法。答言。我先白衣时尝习慈心。此夜思惟入慈三昧。彼即言。汝此夜入小定。何以故。慈心三昧是小定。即复问言。大德一切去。此夜思惟何法。答言。我先白衣时习空法。我此夜多入空三昧。彼言。大德此夜思惟大人之法。何以故。大人之法入空三昧。彼作是念。今正是时。可说先因缘令其得知。彼问言。大德长老。得二指抄食不。问言。云何得二指抄食。答言大德。足食已舍威仪不作余食法得二指抄食食。答言不应尔。问言在何处制。答言。在舍卫国不作余食法食。以是故制。如是一一说。乃至布萨时受取金银。令分物人分如上说。彼即言。勿语余人。恐人心不同。不得和合。一切去上座为第一上座。三浮陀第二上座。离婆多第三上座。婆搜村是第四上座。阿难皆为其和尚。时长老一切去。知僧事时。上座即作白。大德僧听。若僧时到僧忍听。今僧论法毗尼。白如是。时波夷那比丘。语波梨比丘言。汝等今可出平当人。彼即言。上座一切去离婆多耶舍。苏曼那。是平当人。波梨比丘。语波夷那比丘言。汝等亦应出平当人。彼即言。长老三浮陀婆搜村长老沙留不阇苏摩。是平当人。是中有阿夷头比丘。堪任劝化。彼诸比丘言。持此比丘在数中。何以故。彼在所处。当为我等劝化。即着数中。彼诸上座作是念。我等若在众中问此事。恐更生余诤事。不知谁语是谁语非。我等今宁可差次在别处共平论耶。彼诸长老作是念。我等于何别处而平宜此事。即言。当于婆梨林中。时一切去长老即作白。大德僧听。如此为僧所举比丘。若僧时到僧忍听。于婆梨林中论法毗尼。余比丘不在中。白如是。如是作白已。应羯磨差二三比丘。取余比丘。欲至婆梨林中。时一切去上座。以此因缘集比丘僧。如是诸上座皆集。时一切去上座即作白。大德僧听。若僧时到僧忍听。今僧论法毗尼。白如是。时离婆多即作白。大德僧听。若僧时到僧忍听。僧今问一切去上座法毗尼。白如是。时上座一切去即复作白。大德僧听。若僧时到僧忍听。僧今令离婆多问我答法毗尼。白如是。离婆多问言。大德上座。得二指净不。即还问言。云何二指净。答言。大德长老。足食已舍威仪得二指抄食食。答言不应尔。问言在何处制。答言。在舍卫国不作余食法食。以是故制。此是第一事。非法非毗尼非佛所教。别处平宜已。下一舍罗。如是一一检校。乃至十事。非法非毗尼非佛所教。皆下舍罗。彼诸长老作是语。如我等。今于别处。平宜此事已。今复欲于僧中如是检校。何以故。令众人皆知故。彼诸长老。皆往毗舍离。时一切去上座。即集比丘僧已作白。大德僧听。若僧时到僧忍听。僧今论法毗尼。白如是。长老离婆多即作白。大德僧听。若僧时到僧忍听。僧今问一切去上座法毗尼。白如是。时一切去上座即作白。大德僧听。若僧时到僧忍听。僧今令离婆多问法毗尼我答。白如是。离婆多即问言。大德长老。得二指净不。彼问言。云何得二指净。答言。大德长老。足食已舍威仪不作余食法得二指抄食食。答言不应尔。问言在何处制。答言。在舍卫国不作余食法食是故制。此是第一事非法非毗尼非佛所教。于僧中检校已。下一舍罗。如是一一检校乃至十事。非法非毗尼非佛所教。于僧中检校已。皆下舍罗。在毗舍离。七百阿罗汉集论法毗尼。故名七百集法毗尼

四分律卷第五十四四分律卷第五十五(第四分之六)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    调部之一

尔时世尊在毗舍离时优波离。即从坐起偏露右肩右膝着地合掌白佛言。须提那伽兰陀子。与故二行不净行。是犯波罗夷不。佛言。优波离。最初未制戒不犯。尔时婆阇子比丘。愁忧不乐不乐净行。即还家与故二行不净。彼作是念。世尊为诸比丘制戒。若比丘犯不净行行淫欲法。得波罗夷不共住。我愁忧不乐不乐净行。与故二行不净。我将无不犯波罗夷耶。不知云何。即语同伴比丘。世尊为诸比丘制戒。若比丘犯不净行行淫欲法。得波罗夷不共住。而我愁忧不乐不乐净行。还家与故二行不净。我将无不犯波罗夷耶。善哉长老。可为我白佛。随佛所教我当奉行。我若复得于佛法中得修净行者。我当行之。时彼比丘即往佛所。头面礼足却坐一面。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。无数方便呵责婆阇子比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何痴人不乐净行。而还家与故二行不净。入便犯波罗夷不共住。若有余比丘愁忧不乐不乐净行者。听舍戒而去。若复欲于佛法修清净行者。还听出家受大戒。尔时优波离。从坐起偏袒右肩右膝着地合掌白世尊言。是道作道想为犯不。佛言波罗夷。复问。是道疑是犯不。佛言波罗夷。复问。是道非道想是犯不。佛言波罗夷。复问。非道道想是犯不。佛言偷兰遮。复问。非道疑是犯不。佛言偷兰遮。复问。是男作女想行不净是犯不。佛言波罗夷。复问。是女作男想行不净是犯不。佛言波罗夷。复问。与此女人通作彼女人想共行不净行是犯不。佛言波罗夷。于此男作彼男想共行不净是犯不。佛言波罗夷。时有比丘与女象行不净。彼疑是犯波罗夷不。佛言犯。如是牸牛马驼鹿驴羊猪狗雁鸟孔雀鸡。如是一切尽波罗夷

尔时世尊在毗舍离。时有一乞食比丘在林间住。有雌猕猴林间行。此比丘出人间乞食。持还林中食。有余食与此猕猴。猕猴遂便亲近随逐。东西乃至手捉不去。时比丘即共行不净。时众多比丘按行房舍卧具。次至彼林中。彼猕猴来在诸比丘前住。举尾现相。彼诸比丘作如是念。此雌猕猴今在我等前现相如是。将无有余比丘犯此猕猴耶。即便隐在屏处伺之。时乞食比丘持食还林中。食已持余食与猕猴。猕猴食已共行不净。彼诸比丘观见。即问言。长老。佛不制比丘不得行不净耶。彼答言。佛制人女。不制畜生。时诸比丘往佛所。头面礼足却坐一面。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。呵责彼乞食比丘言。汝所为非。非威仪非沙门法非净行非随顺行。所不应为。云何乃与猕猴共行不净。入便波罗夷。痴人不应共住。尔时优波离。从坐起偏露右肩右膝着地合掌白世尊言。大德。若比丘与余畜生行不净。是犯波罗夷不。佛言犯

尔时世尊在王舍城。有难提比丘坐禅。得世俗心解脱。从第四禅觉已。时魔天女即在前立。比丘捉欲犯。魔女便出外。比丘亦随出外。彼出屋栏外。比丘亦随出屋栏外。彼出中庭。比丘亦随出中庭。彼出寺外。比丘亦出寺外。寺外有死草马。彼于死马所便灭。天形不现。时难提比丘。便于死马形行不净行。行不净行已。都无有覆藏心。即作是念。世尊为诸比丘制戒。不得行不净。若行不净。波罗夷不共住。而我今行不净。都无有覆藏心。将无犯波罗夷耶。我当云何。即语同伴比丘。世尊为诸比丘制戒。若比丘行不净。得波罗夷不共住。而我今犯不净。都无覆藏心。将无犯波罗夷耶善哉长老。为我白佛。随佛所教我当奉行。时诸比丘往佛所。头面作礼却坐一面。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。告言。今僧与难提比丘波罗夷戒。白四羯磨如是与。彼比丘应往僧中脱革屣偏露右肩右膝着地合掌作如是白。大德僧听。我难提比丘犯淫欲法都无覆藏心。今从僧乞波罗夷戒。愿僧慈愍故。与我波罗夷戒。如是第二第三说。众中应差堪能羯磨人。如上作如是白。大德僧听。此难提比丘犯淫欲法都无覆藏心。今从僧乞波罗夷戒。若僧时到僧忍听。僧今与难提比丘波罗夷戒。白如是。大德僧听。此难提比丘犯淫欲法都无覆藏心。今从僧乞波罗夷戒。僧今与难提比丘波罗夷戒。谁诸长老忍僧与难提比丘波罗夷戒者默然。谁不忍者说。是初羯磨。第二第三如是说。僧已与难提比丘波罗夷戒竟。僧忍默然故。是事如是持。与波罗夷戒已。应随顺行。是中随顺行法者。不应授人大戒及与人依止。不应畜沙弥。不应受教授比丘尼。设差不应往教。不应为僧说戒。不应在僧中问答毗尼。不应受僧差使作知事人。不应受僧差别处平断事。不应受僧差使命。不应早入聚落逼暮还。应亲附比丘。不应亲附外道白衣。应随顺比丘法。不说余俗语。不应更犯此罪。余亦不应。若相似。若从此生。若重于此者。不应非羯磨。非羯磨者。不应受清净比丘敷座洗足水水器拭革屣揩摩身及礼拜迎送问讯。不应受清净比丘捉持衣钵。不应举清净比丘为作忆念作自言。不应助他语。不应遮说戒自恣。不应与清净比丘诤。与波罗夷戒比丘。僧说戒及羯磨时。来不来无犯。诸比丘作如是语。比丘与波罗夷戒已复重犯。应得更与波罗夷戒不。佛言。不应尔应灭摈。尔时有比丘体软弱。以男根内口中。彼疑我将无犯波罗夷耶。佛言犯。时有比丘。字蓝婆那。男根长。持内大便道中。彼疑。我将不犯波罗夷耶。佛言犯。时有比丘男根起。异比丘即持自内口中。此比丘不以为乐。即却不受。生疑。我将无犯波罗夷耶。佛言。汝不犯彼比丘犯。时有乞食比丘。晨朝着衣持钵至白衣家。白衣家有小儿眠。男根起。比丘即持自内口中已疑。我将无犯波罗夷耶。佛言犯。时有比丘捉余比丘共行淫。彼疑。我将无犯波罗夷。佛问言。汝受乐不。答言受。佛言。二俱波罗夷。时有比丘共沙弥行淫。疑我将无犯耶。佛言。汝沙弥受乐不。答言受。佛言二俱犯。时有沙弥捉大比丘共行淫疑。佛言。比丘汝受乐不。答言受。佛言二俱犯。时有沙弥与沙弥共行淫疑。佛言。汝受乐不。答言受。佛言二俱犯。时有比丘强与比丘共行淫不受乐还出疑。佛言汝受乐不。答言不受。佛言。汝无犯入者犯。时有比丘强捉沙弥行淫不受乐还出彼疑。佛言。汝沙弥受乐不。答言不受。佛言。汝不犯入者犯。时有沙弥强捉比丘共行淫不受乐还出疑。佛言汝受乐不。答言不受乐。佛言。汝不犯入者犯。时有沙弥强捉沙弥行淫不受乐还出疑。佛言。汝沙弥受乐不。答言不受乐。佛言。汝不犯入者犯。时有比丘自身根坏无所觉触彼作是念。我不觉触行淫得无犯。彼即行淫已疑。佛言。汝犯波罗夷。时有比丘男根不起。念言。我行淫无犯。即便行淫疑。佛言。汝犯波罗夷。时有比丘作是念。我与眠女人行淫。彼不觉乐得无犯。即便行淫疑。佛言汝犯波罗夷。时有比丘作是念。与醉女人行淫。彼不觉乐得无犯。即共行淫疑。佛言汝波罗夷。时有比丘作是念。我与颠狂女人行淫。彼不觉乐得无犯。即便行淫疑。佛言汝波罗夷时有比丘作是念。我与嗔恚女人共行淫。彼不受乐得无犯。即便行淫疑。佛言。汝波罗夷。时有比丘作是念。我与苦痛女人共行淫。彼不受乐得无犯。即便行淫疑。佛言汝波罗夷。时有比丘作是念。我与身根坏女人共行淫。彼不觉乐得无犯。即便行淫疑。佛言汝波罗夷。时有比丘作是念。我强捉女人共行淫。彼不受乐得无犯。即便行淫疑。佛言汝波罗夷。时有比丘作是念。我强捉黄门行淫彼不受乐得无犯。即便行淫疑。佛言汝波罗夷。时有比丘作是念。我捉男子行淫。彼不受乐得无犯。即便行淫疑。佛言汝波罗夷。时有女人强捉比丘行淫。比丘不受乐还出彼疑。佛言。比丘汝受乐不。答言不受乐。佛言汝不犯。时有黄门强捉比丘共行淫疑。佛言。比丘汝受乐不。答言不受。佛言汝不犯。时有男子强捉比丘共行淫。彼不受乐还出疑。佛言。比丘汝受乐不。答言不受乐。佛言汝不犯。时有恶比丘恶沙弥恶阿兰若。捉比丘大便道若口中行淫。彼身受乐还出疑。佛言汝受乐不。答言受乐。佛言二俱波罗夷。时有恶比丘恶沙弥恶阿兰若。捉比丘尼沙弥沙弥尼式叉摩那。大小便道口中行淫。彼受乐还出疑。佛言汝受乐不。答言受乐。佛言二俱犯。时有恶比丘恶沙弥恶阿兰若。捉比丘大便道口中行淫。彼不受乐疑。佛言汝比丘受乐不。答言不受乐。佛言汝不犯彼犯。时有恶比丘恶沙弥恶阿兰若。捉比丘尼式叉摩那沙弥沙弥尼。大小便道口中行淫。彼不受乐还出疑。佛言汝沙弥尼受乐不。答言不受乐。佛言汝不犯彼犯。时有恶比丘恶沙弥恶阿兰若。捉眠比丘大便道口中行淫。彼眠不觉。觉时亦不知。彼疑。佛问言。汝觉不。答言不觉。佛言汝不犯彼犯。时有恶比丘恶沙弥恶阿兰若。捉眠比丘尼式叉摩那沙弥沙弥尼。大小便道口中行淫。彼眠不觉。觉时亦不知。彼疑。佛问言。汝觉不。答言不觉。佛言。汝沙弥尼不犯彼犯。时有恶比丘恶沙弥恶阿兰若。于眠比丘大便道口中行淫。彼眠觉不受乐还出彼疑。佛言汝受乐不。答言不受乐。佛言汝不犯入者犯。时有恶比丘恶沙弥恶阿兰若。于眠比丘尼式叉摩那沙弥沙弥尼大小便道口中行淫。彼眠不觉。觉已不受乐疑。佛言汝受乐不。答言不受乐。佛言汝不犯彼入者犯。时有恶比丘恶沙弥恶阿兰若。于眠比丘大便道口中行淫。彼眠不觉。觉已知受乐还出疑。佛言汝受乐不。答言受。佛言二俱犯。时有恶比丘恶沙弥恶阿兰若。于眠比丘尼式叉摩那沙弥沙弥尼大小便道口中行淫。彼眠不觉。觉乃知受乐。佛言汝受乐不。答言受乐。佛言二俱犯。时莲华色比丘尼昼日不关户眠。贼入屋行淫已去。彼眠不觉。觉已见不净污身。彼作是念。我身有不净污。将无有人淫犯我耶。彼疑。佛言不犯。比丘尼不应昼日不关户而眠。尔时有难陀比丘尼。昼日。在华树下众人戏处。有贼捉淫犯。彼疑。佛言。汝难陀受乐不答言大德。如似热铁入体。佛言无犯。比丘尼不应住如是处。尔时有乞食比丘。晨朝着衣持钵至白衣家彼门下系小狗子。见比丘便作声。比丘慈愍解放去。比丘复往余处。故二见唤共行不净。彼作是念。我放他狗子去。已犯波罗夷。便与故二共行不净。诸比丘作如是念。此比丘为犯前为犯后。佛言前不犯后犯。而不应放他狗子去。时有比丘晨朝着衣持钵往白衣家。见有豚子溺水中。见比丘便作声。比丘慈愍即出放去。复往余处。见故私通女人。唤共行不净。彼作是念。我放他豚子去。已犯波罗夷。便共行不净。余比丘作是念。此比丘为犯前为犯后。佛言前不犯后犯而不应作如是事。时有异女人。往屠牛处买肉持行。有鸱鸟抄撮其肉在空中。失堕乞食比丘钵中。彼女人见之。即语言。大德此是我肉。莫持去。比丘答言。堕我钵中非汝肉。持去不还。前行见淫女。唤此比丘共行不净。彼作是念。我向持他肉来。已犯波罗夷。即共此女人行不净。诸比丘作是念。彼比丘为犯前为犯后。佛言前无犯后犯。而不应受如是肉。时有比丘于狗口中行淫。彼疑。佛言波罗夷。时有比丘褰衣小便。有狗舐小便以渐前含男根。彼不受乐即还出便疑。佛问言。比丘汝受乐不。答言不受乐。佛言不犯。时有比丘褰衣小便。有狗舐小便。复前含男根。彼受乐已还出疑。佛问言。汝受乐不。答言受乐。佛言汝波罗夷。时有比丘褰衣渡伊罗婆提河。有鱼含男根。彼不受乐还出疑。佛问言。汝受乐不。答言不受乐。佛言不犯。时有比丘褰衣渡伊罗婆提河。有鱼含男根。彼受乐还出疑。佛问言。汝受乐不。答言受乐。佛言汝波罗夷。时有比丘大小便道中间行淫彼疑。佛言偷兰遮。在[月*冓]中曲脚间。胁边乳间。腋下耳鼻中。疮孔中。绳床木床间。大小褥间。枕边。在地泥抟间。君持口中。若道想若疑。一切偷兰遮。尔时有乞食比丘。晨朝着衣持钵往白衣家。有童女在门内仰卧而睡。彼作是念。我若男根淫犯入便波罗夷。即以足大指。内彼女根中疑。佛言僧残。时有比丘欠口。有异比丘以男根内口中。彼不受乐出之疑。佛问言汝受乐不。答言不受乐。佛言汝不犯入者犯。自今已去。若欠口时。应以手障口。时有比丘。于浴室中为异比丘揩身。此比丘身软。异比丘即生欲心。便共行淫。彼不受乐还出彼疑。佛言汝受乐不。答言不受乐。佛言。汝无犯彼入者犯

尔时世尊在舍卫国。有比丘。昼日不关户眠。男根起。时有众多女人。诣僧坊观看。至彼比丘屋。见比丘仰眠男根起。见已惭愧。疾疾而出。诸女人中有贼女共行。贼女入屋。即于比丘形上行淫。行淫已持华鬘系男根头而去。彼比丘眠不觉。觉已见不净污身男根有华鬘。便作如是念。乃有不净污身。男根有华鬘。将无有女人于我行淫耶疑。佛问言汝觉不。答言不觉。佛言无犯。而不应昼日不关户而眠。时舍卫国有比丘比丘尼母子夏安居。母子数数相见。既数相见。俱生欲心。母语儿言。汝从此出。今还入此。可得无犯。儿即如母言。彼疑。佛言波罗夷。时有比丘于死女人上行淫彼疑。佛言汝波罗夷。若多不坏波罗夷。若半坏偷兰遮。若多坏若一切坏偷兰遮。若骨间偷兰遮。尔时苏卑优婆私。语比丘言。男根女根俱遮行淫可得无犯。比丘即如言行淫已疑。佛言波罗夷。时有苏摩优婆私。语比丘言。汝共我行淫于外出精可得无犯即如言行淫已疑。佛言汝波罗夷。时有淫女语比丘言。汝以树叶裹男根行淫可得无犯。即如言行淫已疑。佛言汝波罗夷。尔时比丘在冢间行。遥见死女人。身犹衣服庄严。即便行淫已疑。佛言汝波罗夷。时有比丘守房。有小女来白时到。比丘即捉行淫。破彼女根。与大便道通。即便命终。彼疑。佛问言。汝以何心。答言不以杀心。佛言。不犯杀犯淫波罗夷。时有比丘于木女像身中行淫疑。佛言犯偷兰遮。于壁上女像形行淫。佛言偷兰遮。时有比丘与天女共行淫已疑。佛言波罗夷。阿修罗女龙女夜叉女饿鬼女若畜生能变化者女行淫。一切波罗夷。时有比丘晨朝着衣持钵至白衣家乞食。时天大雨。有女人低身除决潦水形露。彼作是念。我不触其身。但以男根入得无犯。念已即便行淫疑。佛言波罗夷

尔时世尊在舍卫国。有比丘往阿兰若处昼日眠。时有取薪女人。于比丘形上行淫已去。比丘不远而住。比丘觉已。见身不净污念言。此女必于我身上行淫生疑。佛问言汝觉不。答言我不觉。佛言不犯。比丘不应住如是处昼日眠

尔时世尊在婆只提国。有比丘往阿兰若处昼日眠。有担草女人。于比丘形上行淫。比丘不知觉已不受乐。即却之已。打女人。比丘疑。佛问言。汝受乐不。答言不受乐。佛言汝不犯。打女人得突吉罗。时世尊在瞻婆国。有比丘至阿兰若处昼日思惟系念在前。此比丘是阿罗汉。有风患男根起。时有贼女。强与比丘共行淫。比丘如是语。阿罗汉犹有欲男根起耶。诸比丘白佛。佛言。有五事因缘令男根起。大便急。小便急。风患。慰周陵伽虫啮。有欲心。是为五事。若阿罗汉。有欲心男根起者。无有是处

尔时世尊在王舍城。王子无畏。男根有病。令女人含之。后得差。得差已。即于此女人口中行淫。此女人忧愁不乐。便作是念。若王瓶沙来时。我当覆头露形在王前住。若王问我言。汝狂人耶。何故乃作如是。我当答言。不狂。是王子所须故。我今覆护。何以故。王子常于我口中行淫。是故覆护。后异时。王瓶沙往无畏所。时女人如先所念。于王前如是住。王问言。汝狂耶。何故如是。女答言。我不狂。是王子所须。是故覆护耳。王即唤无畏来语言。汝云何乃于侍女口中行欲耶。无畏闻之。甚以惭愧。后于异时。王子无畏言。此女人有罪。为着黑衣安置城门边。作如是言。若有如是病者。当于此淫女口中行淫得差。时诸比丘作如是言。若为治病故。以男根着彼女人口中含不犯耶。佛言波罗夷。尔时有城。名婆楼越奢。王字海。淫女有罪。王作是言。剥女根两边肉。以此为罚。即便剥之。诸比丘作如是言。若于生人骨间行淫为犯不。佛言偷兰遮

尔时世尊在王舍城。优波离。从坐起偏露右肩右膝着地合掌白佛言。大德。陀尼伽陶师子。取王瓶沙材木。不与而取是犯不。佛言。最初未制戒。不犯。复白佛言。大德。若空处他所守护物。若取五钱若过五钱。是犯不。佛言波罗夷。他物他物想。若五钱若过五钱。不与而取是犯不。佛言波罗夷。他物疑。若取五钱若过五钱。是犯不。佛言偷兰遮。非他物他物想。取五钱若过五钱偷兰遮。非他物疑取五钱若过五钱是犯不。佛言偷兰遮。若他物他物想取减五钱是犯不。佛言偷兰遮。若他物疑取减五钱是犯不。佛言突吉罗。非他物他物想取减五钱是犯不。佛言突吉罗。非他物疑取减五钱是犯不。佛言突吉罗。若作女想取男物五钱若过五钱。是犯不。佛言波罗夷。若作男想取女物五钱若过五钱是犯不。佛言波罗夷。若作此女想取余女物是犯不。佛言波罗夷。若作此男想取余男物是犯不。佛言波罗夷

尔时世尊在波罗奈。时世谷贵人民饥饿乞食难得。时有乞食比丘。晨朝着衣持钵往白衣家。有女人器盛饭。置地已还入屋。比丘看左右不见人。作是念。我取此食于我有益。即持而去彼疑。佛问言。汝以何心取。答言以盗心取。佛言。若价直五钱。取离本处。波罗夷。糗干饭鱼肉佉阇尼如是。一切直五钱取离本处波罗夷。时有乞食比丘。晨朝着衣持钵往白衣家。见有铜杅。看左右不见人。念言。此于我有益。即持去有疑。佛问言。汝以何心取。答言盗心取。佛言。若价直五钱取离本处波罗夷。时有乞食比丘。晨朝着衣持钵往白衣家。见有方独座榻蹬看左右不见人。念言。取此于我有益。即持去疑。佛问言。汝以何心取。答言盗心取。佛言。若价直五钱取离本处波罗夷。时有比丘于浣衣处取他衣持去疑。佛问言。汝以何心取。答言以盗心取。佛言。价直五钱取离本处波罗夷。时有比丘去浣衣处不远。见有晒贵价衣。即忆识而去。念言。还时当取便疑。佛问言。汝以何心。答言以盗心。佛言。方便求五钱未离本处偷兰遮。时有乞食比丘。晨朝着衣持钵往白衣家。见门屋下晒贵价衣。以脚转侧看彼疑。佛问言。汝以何心答言以盗心。佛言。方便求五钱未离本处偷兰遮。时有乞食比丘。晨朝着衣持钵往白衣家。见有独坐床。看左右不见人。自念此于我有益。即便持去疑。佛问言。汝以何心取。答言以盗心佛言波罗夷。时有乞食比丘。晨朝着衣持钵往白衣家。见有独坐床并衣。看左右不见人自念。此于我有益。即持去彼疑。佛问言汝以何心。答言以盗心。佛言。价直五钱取离本处波罗夷。时有乞食比丘。晨朝着衣持钵往白衣家。见有独坐床暂取用坐疑。佛问言。汝以何心。答言暂取非盗心。佛言无犯。不应不问主而暂取用。时有比丘取他塔庙中衣疑。佛问言汝以何心取。答言以粪扫衣取。佛言无犯。不应取他塔庙中庄饰衣。时有比丘与卖綖人共行。彼语比丘言。长老。汝等度关不输税。今欲以此綖托长老度关。时比丘即为过之便疑。佛言汝以何心。答言以盗心。佛言。价直五钱过关便波罗夷。时有众多比丘。方便遣一人取他物。得五钱若过五钱彼疑。佛言一切波罗夷。时有众多比丘。方便遣一人取他物。中有疑者而不遮。即往取物。得五钱若过五钱彼疑。佛言一切波罗夷。时有众多比丘。方便遣一人取他物。中有疑者即遮。彼故往取。得五钱若过五钱。彼疑。佛言。遮者偷兰遮。不遮者波罗夷。时有众多比丘。方便遣一人盗他物。即往取五钱若过五钱得减五钱。彼作是念。我等得减五钱不犯波罗夷。佛言。依本取物处直五钱波罗夷。时有众多比丘。方便遣一人。取五钱若过五钱。还共分。各得减五钱。彼作是念。我等得减五钱。不犯波罗夷。佛言。通作一分尽波罗夷。时众多比丘。方便共遣一人取他物。彼往取减五钱来至此得五钱。彼作是念。我等得五钱波罗夷。佛言。依本取物处偷兰遮。时有比丘取彼聚落物来入城疑。佛言。汝以何心。答言盗心。佛言。取五钱离本处波罗夷。时有比丘盗他经。作是念。佛语无价。应计纸墨直彼疑。佛言。汝以何心取。答言以盗心取。佛言。取五钱离本处波罗夷。时有王家勇健人。以信乐故。从世尊出家。有异破戒比丘。诱诳言。长老。彼某甲村中。多有财物亦有健人。而汝胜彼。今可共往取彼财物。即答言可尔。彼比丘语已便去不远。此比丘作是念。我信乐出家。不应作如是恶事。彼破戒比丘。于异时复来语言。今可共往取彼财物。答言我不往。问言。何以故。答言。我于汝去后思惟。作是念。我不应以信出家而作是事。以是故不往。复异时。彼破戒比丘。往彼村盗他物。各各分已。作一分送与此比丘。此比丘答言。我不须此分。我先不作如是言以信出家不应作如是事耶疑。佛问言汝以何心。即具以因缘白佛。佛言无犯。先然可彼突吉罗。时有比丘欲盗他衣而错取己衣疑。佛言汝偷兰遮。时有比丘。盗取他衣并得己衣疑。佛言。己衣偷兰遮。他衣波罗夷。时有比丘他盗取物而夺彼盗者物疑。佛言波罗夷。时有众多白衣在冢间。脱衣置一处埋死人。有粪扫衣比丘。谓是粪扫衣即持去。诸白衣见已语。大德。莫持我衣去。彼答言。我谓是粪扫衣。即置衣而去疑。佛问言汝以何心。答言。以粪扫衣想。不以盗心。佛言无犯。若多有衣聚。不应作粪扫衣取。时有比丘去冢不远行。遥见多有粪扫衣。即聚集而去。言还当取。余粪扫衣比丘。见谓是粪扫衣即持去。彼比丘还不见衣。至寺内见有比丘浣治。即语言。汝偷我衣犯盗。彼答言我不盗取。粪扫衣耳彼疑佛言汝以何心。答言作粪扫衣取。佛言不犯。而不应取聚粪扫衣。时有居士去冢不远行。遥见有大价粪扫衣。即往取置草中而去。言还当取与某甲比丘。时有粪扫衣比丘。见即持去。彼居士还不见衣。至寺中见比丘浣治即语言。汝盗我衣。比丘答言。我不盗汝衣。取粪扫衣耳疑。佛问言汝以何心。答言作粪扫衣取。佛言无犯。而不应取如是处粪扫衣。时有牧牛人。脱衣置头前而眠。有粪扫衣比丘。见谓是死人。作是念。世尊不听比丘取完死人衣。即取死人臂骨打头。彼觉起言。大德。何故打我也。比丘言。我谓汝是死人。彼牧牛人言。汝宁可不别我死生也。即打比丘熟手。诸比丘白佛。佛言。不应打死人令破取衣。时有众多小儿。脱衣置一处。作土堆戏。有粪扫衣比丘。见即持去。诸小儿见语言。莫持我衣去。比丘答言。我谓是粪扫衣置而去疑。佛问言汝以何心取。答言以粪扫衣取。佛言无犯。而不应取聚粪扫衣。时六群比丘。以石蜜诱诳小儿。欲将人间卖。父母见之。即问比丘言。大德何所说。彼答言无所说。即留小儿而去彼疑。佛问言汝以何心。答言盗心。佛言。直五钱离本处波罗夷。时有比丘盗心倒易他分物筹彼疑。佛言举筹便波罗夷。时有比丘盗他分物筹疑。佛言。直五钱离本处波罗夷。时有比丘转侧他筹疑。佛言。方便取五钱未离本处偷兰遮。时有比丘再盗取物不满五钱。彼作如是念。我前后不满五钱。不犯波罗夷。佛言。前后满五钱波罗夷。时去只桓不远。有居士耕。有客比丘见语言。此是僧地莫耕。彼答言。非僧地我地耳。比丘复语言。是僧地汝莫耕。居士即放犁去。作如是言。我自有地而不得耕也。彼客比丘入只桓问旧比丘。有居士去此不远耕。此是谁地。答言是彼居士地。旧比丘言汝何故问也。即具说因缘便疑。佛问言。汝以何心。具说因缘。佛言汝无犯。而不应作如是事。时优波离从坐起偏露右肩右膝着地白佛言。若作减损意。取五钱若过五钱。自取若教人取。自断坏若教人断坏。自破若教人破。若烧若埋若坏色。是犯不。佛言一切波罗夷。时有比丘分地移他标相彼疑。佛言汝以何心。答言以盗心。佛言移标相若直五钱波罗夷。尔时众僧园无水荒毁。六群比丘决他田水着僧园中疑。佛问言汝以何心。答言盗心。佛言波罗夷。时有比丘有檀越家田无水荒毁。彼决他水着檀越田中疑。佛言波罗夷。时有比丘与白衣家有怨。彼决他田水弃之令田毁废彼疑。佛言波罗夷。时有比丘盗他水彼疑。佛言直五钱波罗夷。诸比丘疑不敢取渠水泉陂池水。佛言。若非人所护者不犯。时有比丘字旃陀罗。有斗诤事。有贵价苏摩钵。彼以诤事故。常怀忧愁作如是语。若有能灭我诤事者。当与此钵。时有阿夷头比丘。聪明了了善灭诤事。即为彼灭诤已。持钵而去。此比丘谓失钵。便行求觅。见阿夷头手中捉。即语言。汝偷我钵。彼即答言。我不偷汝钵。汝自有要言。若有能灭我诤事者。当持此钵与。是故我取耳。彼疑。佛问言。汝以何心取。彼具答因缘。佛言汝不犯。而不应受如是物。时有比丘。字耶输伽。有僧伽梨。复有比丘。字婆修达多。不语辄着。入聚落乞食。彼谓失衣。便行求觅见婆修达多着。即便捉之。言汝犯盗彼答言我不盗汝衣。以亲厚意取耳彼疑。佛问言汝以何心。答言以亲厚意取非盗心。佛言无犯。而不应于非亲厚而作亲厚意取。时有比丘字清净有僧伽梨。有须陀夷比丘。不问主辄着。入聚落乞食。主谓失衣。便行求觅。见须陀夷着。即捉语言。汝取我衣犯盗。彼答言我不盗借着耳彼疑。佛问言汝以何心。答言借着非盗心。佛言无犯。而不应不问主辄着入聚落。时有比丘取他梨果疑。佛言。直五钱离本处波罗夷。阎婆果波梨婆果蒱桃种种果。若直五钱一切波罗夷。时有比丘摇他梨果堕欲令损减。佛言直五钱波罗夷。若摇堕阎婆果波梨婆果蒱桃种种果。欲令损减一切波罗夷。时有比丘盗他胡苽疑。佛言直五钱波罗夷。时有比丘盗甘蔗疑。佛言直五钱波罗夷。时有比丘取他菜疑。佛言直五钱波罗夷。时有比丘取他莲华疑。佛言直五钱波罗夷。钵头摩头头摩拘头摩分陀利华。直五钱一切波罗夷。若复折坏欲损减他。直五钱一切波罗夷。时有他守视人及贼。与比丘佉阇尼食。比丘作如是意言。此非彼食不受。诸比丘白佛。佛言。此即是檀越食。听净洗手受食之。时有比丘取他藕根疑。佛言直五钱波罗夷。时有比丘在他所守护林中取材疑。佛言波罗夷。时有比丘盗心无根取他食疑。佛言波罗夷。时有比丘无根。取他食疑。佛问言汝以何心。答言无盗心。佛言无犯。妄语故波逸提。时有比丘。遣比丘盗取绳床。彼使比丘谓不盗。即为取床来疑。佛言。方便教者波罗夷。使者不犯。时有比丘。遣比丘取绳床。彼使谓盗取。即取床来疑。佛言。取者波罗夷。教者无犯。时有众多比丘有舆。与六群比丘共行。六群比丘作是念。前到住处当盗取彼舆。佛言。若在此处盗波罗夷。若在道中若至住处盗亦波罗夷。时有六群比丘。见恒水中有流船。作是念。我等可盗取此船不劳身手彼疑。佛问言汝以何心。即具答因缘。佛言但意无犯。而不应生如是意。有比丘盗取他船。从此岸至彼岸疑。佛言波罗夷。从彼岸至此岸。顺水。若逆水。若沉水中。若牵着陆地。若解他船离处。一切波罗夷。若方便欲解不离处偷兰遮。时有二比丘。往阿夷罗婆提河中浴。见贵价衣簏随水流下。一比丘见便言。此簏属我。第二比丘言。簏中物属我。即共取得贵价衣便疑。佛言汝以何心。答言粪扫衣想。佛言不犯。不应取水中粪扫衣。时有比丘盗金花鬘疑。佛言波罗夷。时只桓中有众多鸟巢住。至后夜鸣唤乱诸坐禅比丘。有旧比丘。遣守园人除去鸟巢。彼于鸟巢中。见有金有碎帛。持来与旧比丘彼疑。佛言鸟兽无用无犯。而不应受如是物。时只桓中有鼠穴。比丘使守园人坏彼于鼠穴中得药碎帛持来与比丘。比丘疑。佛言畜生无用无犯。而不应受如是物。时去寺不远有村。诸鼠往村中。取胡桃来。在寺内成大聚。六群比丘以盗心取食彼疑。佛言波罗夷。时去只桓不远有猎师。安机发捕鹿。机中有死鹿。六群比丘以盗心取食疑。佛言波罗夷。时有比丘。昼日往阿兰若处。有贼系牛在树。牛见比丘泣泪。比丘慈念。便解放去。比丘疑。佛问言。汝以何心。答言。以慈心无盗意。佛言无犯。不应作如是事。时有比丘。昼日往阿兰若处。有贼缚牛置中。比丘左右不见人。念言。此于我有益。即解牛牵去。去不远。还得意念。便言。我何用此牛。即放去。比丘疑。佛问言。汝以何心。答言以盗心。佛言。直五钱离处波罗夷。时有豹捉鹿。鹿被疮来入寺而死。诸比丘取食疑。佛言无犯。时有猎师捕鹿。鹿来入寺。猎师寻鹿而来。问诸比丘言。见如是如是鹿不。诸比丘不见者言不见。彼即处处求觅得。时猎师即嗔嫌比丘言。沙门释子无有惭愧。妄语欺调。自称我知正法。见鹿而言不见。如是何有正法。诸比丘疑白佛。佛言无犯。时有比丘。盗取波利迦罗衣疑。佛言波罗夷。时有比丘。盗心举他波利迦罗衣离处疑。佛言波罗夷。时有比丘。盗心转侧波利迦罗衣疑。佛言。方便求五钱未离处偷兰遮。时有比丘。盗绳床木床大小褥枕毡被若瓶若澡罐若杖若扇。佛言直五钱一切波罗夷。时有比丘。倒易绳床言。此亦是僧。彼亦是僧。佛言不应倒易。时有比丘。倒易木床大小褥若枕。此亦是僧彼亦是僧。毡被瓶澡罐杖扇言。此亦是僧彼亦是僧。佛言不应尔。时有比丘。盗他石彼疑。佛言直五钱波罗夷。盗堑材木竹[竺-二+韋]文若草婆婆草树皮若他所守护树叶花果彼疑。佛言直五钱一切波罗夷。时有比丘。从他衣架上盗取衣疑。佛言波罗夷。时有比丘。盗心举他衣架上衣离架疑。佛言波罗夷。时有比丘。盗心从他架上转侧衣疑。佛言。方便求五钱未离处偷兰遮。时有比丘。取他衣架上带并架合取疑。佛问言汝以何心。答言以盗心。佛言。直五钱离处波罗夷。时有众多比丘。与六群比丘在白衣家内共坐食。白衣以大价衣敷为座中有一六群比丘。盗心以脚转侧疑。佛言汝以何心。答言盗心。佛言。方便求五钱未离处偷兰遮

四分律卷第五十五四分律卷第五十六(第四分之七)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    调部之二

时有差摩比丘尼。有檀越家。彼弟子往其家。语檀越言。阿姨。差摩须五斗胡麻子。檀越言。可得耳即与之。彼弟子得胡麻便自食。后于异时。差摩比丘尼晨朝着衣持钵。往檀越家敷座而坐。檀越问。胡麻子美不。彼答言。何等胡麻。檀越即具说本末。差摩比丘尼还。语彼弟子比丘尼言。汝盗我五斗胡麻。弟子答言。我不盗以亲厚意取疑。佛问言。汝以何心。答言。亲厚意取。佛言无犯。而不应非亲厚意作亲厚意取。以妄语故得波逸提。时差摩比丘尼有檀越家。其弟子往其家语言。阿姨。差摩须三种药粥。彼言。可得耳即便与。彼得便自食。后时差摩比丘尼。晨朝着衣持钵。往其家敷座而坐。檀越问。阿姨。三种药粥美不。彼即言。何等三种药粥。檀越即具为说本末。差摩还语彼比丘尼弟子言。汝盗我三种药粥。彼答言。我不盗以亲厚意取彼疑。佛问言。汝以何心取。答言亲厚意取。佛言无犯。而不应非亲厚作亲厚意取。以妄语故得波逸提。时有比丘。取和尚佉阇尼分。和尚语言。汝食我分犯盗。答言。我不盗亲厚意取彼疑。佛问言。汝以何心。答言亲厚意取。佛言无犯。而不应非亲厚意作亲厚意取。时有比丘。陶师为檀越。檀越语言。大德须器便见语。彼答言可尔。其檀越起去还家。更有异人来至卖器处卖器。后时比丘须瓶。即取他瓶持去。彼语比丘言。大德莫持我瓶去。比丘言。此是某甲瓶。某甲先语我言。若须器便取。是故我取。彼言此非某甲瓶。比丘即放瓶而去疑。佛问言。汝以何心。即具说因缘。佛言无犯。而不应不问主而取。时有比丘。沽酒家为檀越。檀越语比丘言。大德若须甑者取。答言可尔。时檀越即还家。更有异人在沽酒处住。后比丘须甑来取去。彼语言。大德莫持我甑去。比丘言此是某甲甑某甲先见语。须甑便取。是故取耳。彼言此非某甲甑。比丘放甑而去疑。佛问言汝以何心。具答因缘。佛言不犯。而不应不问主而取他物。时有比丘。估客为檀越语言。大德若有所须便取。答言可尔。彼估客还家。后更有异人在此处卖物。后比丘须米。即取米持去。彼语言。大德莫持我米去。比丘言。此是某甲米。先语我言。若有所须便取。是故我取。彼言。此非某甲米比丘即置米而去疑。佛问言。汝以何心。具答因缘。佛言无犯。而不应不问主而取。时有卖衣人为檀越。檀越语言。大德须衣便取。答言可尔。彼檀越命过。有儿在。比丘须衣。即取衣持去。彼言。大德莫持我衣去。比丘言。是某甲衣。先语我言。须衣便取。彼答言。某甲已死。比丘放衣而去疑。佛问言。汝以何心。具答因缘。佛言无犯。而不应不问主而取

尔时世尊在毗舍离。有不信乐离奢。以弊物裹五钱。置粪聚间。遣人微伺。若见取者将来。时粪扫衣比丘见。谓是粪扫衣。即取着囊中。时彼使人见已语言。某甲离奢唤。比丘答言去。去至离奢所。离奢问言。大德应捉钱宝不。比丘答言不应。汝何故取耶。答言我不取。彼言出看之。彼即从囊中出示。此比丘惭愧。余比丘亦尔。以此因缘具白世尊。世尊言。诸比丘善听。若有比丘欲取如是粪扫衣者。应以左足指蹑右足指牵解看。若有不净出之。净者持去

尔时世尊在舍卫国。迦留陀夷与六群比丘。在阿夷婆提河中浴。迦留陀夷先出岸上。错着六群比丘衣去。六群比丘后出。河岸上不见己衣。见迦留陀夷衣。便言彼犯盗。取我等衣。即不于现前作灭摈。时迦留陀夷闻之生疑。往世尊所头面礼足却坐一面。以此因缘具白世尊。世尊问言。汝以何心。答言谓是己衣。不以盗心。佛言无犯。而不应不看衣便着。亦不应不现前作呵责。若摈若依止若遮不至白衣家。若举若灭摈羯磨。若作不成。得突吉罗。尔时有比丘。得风飘衣彼疑。佛问言汝以何心取。答言以粪扫衣。不以盗心取。佛言无犯。不应取风飘及粪扫衣。尔时有居士。浣衣已着墙上晒。粪扫衣比丘见。谓是粪扫衣。即持去。时居士见语言。大德莫持我衣去。比丘言。我谓是粪扫衣。即放衣而去疑。佛问言汝以何心取。答言粪扫衣取。佛言无犯。而不应于墙上若篱上若堑中取粪扫衣。时有居士。浣衣已着篅上晒。有一六群比丘。盗心持去彼疑。佛言波罗夷。时有众多贼。出舍卫城。去只桓不远。昼日饮酒日入已。余酒举着树间。入舍卫城。时六群比丘出只桓。盗心取饮疑。佛言。汝波罗夷。时有乞食比丘。晨朝着衣持钵。往檀越家。遇天瀑雨。水飘种种脂。彼念言。此不求而得。可以为药。即取服之疑。佛问言。汝以何心。答言。粪扫取非盗心。佛言无犯。不应取水中粪扫物。不受而服波逸提。时比丘有檀越家。有异比丘语言。我欲往汝檀越家。何所说耶。答言随汝说。彼比丘须五十两石蜜。至檀越家语言。某甲比丘须五十两石蜜。檀越言可得。即与之。此比丘得便自食。不与彼比丘。后异时。彼比丘往诣檀越家。檀越语言。大德石蜜好不。比丘问言。何等石蜜。为谁石蜜。檀越即具答本末。彼比丘还语此比丘言。汝犯盗。取我石蜜。彼答言我不犯盗。汝语我言随汝说。诸比丘白佛。佛言。不应作如是语。应说言说是语。是时有比丘盗他辇彼疑。佛言波罗夷。时有比丘盗他薪疑。佛言直五钱波罗夷。尔时毕陵伽婆蹉有檀越。檀越有二小儿。黠了不畏人。毕陵伽婆蹉至家时。小儿便抱脚婉转戏。后异时。此二小儿为贼偷去。时毕陵伽婆蹉。晨朝着衣持钵。至檀越家敷座而坐。小儿父母向涕泣流泪言。小儿为贼偷去。若今在者。当来捉大德脚戏。即答言。可于屋内处处求觅。彼父母求觅不得。时毕陵伽婆蹉还。至寺内入房中。思惟入定念在于身。以清净过人天眼见小儿。贼偷在恒水中乘船而去。见已譬如人屈申臂顷。从寺内没至恒水贼船中立。时小儿见即欢喜来抱脚。婆蹉即以神足合小儿持来着阁上房中。至檀越所数座而坐。时父母涕泣而言。若我儿在者。今当抱大德脚戏。答言。可于阁上房中觅。彼言已求觅不得。毕陵伽婆蹉言但更觅。彼即更于阁上房中觅得。时儿父母大欢喜言。我儿为贼所偷。而今毕陵伽婆蹉为我将来。时诸比丘闻。中有少欲知足行头陀乐学戒知惭愧者。嫌责毕陵伽婆蹉言。云何贼偷他儿去。而夺来耶。毕陵伽婆蹉闻已疑。往佛所头面礼足。却坐一面。以此因缘具白世尊。世尊知而故问。汝以何心取。答言慈心取。无有盗意。佛言无犯。而不应作如是事。尔时有比丘字高胜。有檀越家。檀越病。比丘来问讯。彼有二小儿。黠了。时檀越示宝藏已。语此比丘处所语言。此二小儿长大已。若胜者示此宝处。于是便命过。时高胜比丘。后看此二儿胜者。即示宝处。时一小儿涕泣来至寺内。语阿难言。大德看此高胜比丘。以我父遗财二人分。并与一人。时阿难语高胜比丘言。汝云何以他父遗财二人分与一人耶。高胜汝可去。不应与汝同布萨。时阿难经六布萨不与共同。时高胜比丘与罗睺罗为伴党。时罗睺罗。晨朝着衣持钵。至迦维罗卫国。舍夷妇女拘梨妇女语如是言。汝曹可将男女着阿难前。若小儿啼。阿难当言。将小儿去。汝等当语如是言我等不能将小儿去。乃至阿难当听高胜比丘语。时诸妇女遣罗睺罗去将男女着阿难前。时小儿啼。阿难言。将小儿去。时诸女人言。我等不能将小儿去。乃至受高胜比丘语。阿难慈心即言。高胜汝事云何。高胜即为具说因缘。阿难言汝去。乃至不犯突吉罗

尔时世尊在毗舍离。优波离。从坐起偏露右肩右膝着地合掌白佛言。大德。诸比丘在婆裘河边作不净观。厌身自杀是犯不。佛言。初未制戒无犯。人作人想是犯不。佛言波罗夷。人疑是犯不。佛言偷兰遮。人作非人想是犯不。佛言偷兰遮。非人人想是犯不。佛言偷兰遮。非人疑是犯不。佛言偷兰遮。大德。若作女想断男命是犯不。佛言波罗夷。大德。若作男想断女命是犯不。佛言波罗夷。若作此女想而断彼女命是犯不。佛言波罗夷。大德。若作此男想断彼男命是犯不。佛言波罗夷。若求觅持刀人是犯不。佛言若断命犯。尔时有比丘。檀越家病。往问讯。彼檀越妇颜容端正。比丘见已欲心系着。比丘语言。可共我作如是事。其妇言。大德。莫作是语。我夫存在。不欲作如是恶事。比丘即向其夫叹死快。彼夫即死疑。佛问言汝以何心。答言杀心。佛言波罗夷。时有比丘。檀越病。往问讯。檀越妇端正。比丘见已欲心系着。语言。可共我作如是事。其妇言。我夫存在。不欲作如是事。比丘即与彼夫药令死疑。佛问言汝以何心。答言以杀心。佛言波罗夷。时有比丘。檀越病。往问讯。檀越妇端正。比丘见已欲心系着。语言。共我作如是事。其妇言。我夫存在。不欲作如是事。比丘即与其夫吐下药令断命疑。佛问言汝以何心。答言杀心。佛言波罗夷。时有比丘。檀越病。往问讯。檀越妇端正。比丘见已欲心系着。语言。共我作如是事。其妇言。我夫存在。不欲作如是事。比丘即与非所应食令断命疑。佛问言汝以何心。答言以杀心。佛言波罗夷。时有比丘。檀越病。往问讯。檀越妇端正。比丘见已欲心系着。语言。共我作如是事。其妇言。我夫存在。不欲作如是事。比丘即与其夫非药令断命疑。佛问言汝以何心。答言杀心。佛言波罗夷。时有比丘。檀越病。往问讯。比丘形貌端正。其妇见欲心系意于比丘所。语言大德。可共我作如是事。比丘答言。大姊莫作是语。我所不应。汝夫存在。云何作如是恶事。其妇作如是言。我夫未死之间。不得与共和合。即与其夫药令断命。夫既死已。语比丘言。我夫已死。可共我作如是事。比丘言。大姊莫作如是语。我所不应。彼妇语言。我为汝故断夫命。云何不作如是事。比丘闻之生疑白佛。佛问言汝以何心。即具说因缘。佛言无犯。吐下药非所应食非药亦如是。时有妇人。夫行不在。他边得娠。即往家常所供养比丘所。语言。我夫不在。他边得娠。与我药堕之。比丘即咒食与之令食。彼得堕胎。比丘疑。佛问言汝以何心。答言杀心。佛言波罗夷。时有妇人。夫行不在。他边得娠。即往家常所供养比丘所。语言大德。我夫行不在。他边得娠。与我药堕之。比丘即咒药与令胎堕比丘疑。佛问言汝以何心。答言杀心。佛言波罗夷。咒细末药咒华鬘咒熏香衣服咒胎亦如是。一切波罗夷。时有妇人。夫行不在。他边得娠。往常所供养比丘尼所。语言阿姨。我夫行不在。他边得娠。与我药堕之。比丘尼言大姊我不解药。汝来与汝按腹。即为按之令胎堕疑。佛问言汝以何心。答言杀心。佛言波罗夷。时有妇人。夫行不在。他边得娠。往常所供养比丘尼所。语言阿夷。我夫行不在。他边得娠。与我药堕之。比丘尼言。我不解药。来为汝啮之。即当胎处啮令堕疑。佛问言汝以何心。答言以杀心。佛言波罗夷。时有妇人。夫行不在。他边得娠。往常供养比丘所。语言大德。我夫行不在。他边得娠。与我药堕之。比丘即与过度吐下药。母死儿活彼疑。佛言。母死无犯。方便欲堕胎不死偷兰遮。时有比丘。扶病人起。病者命过疑。佛言无犯。若扶坐命过无犯。若为洗浴时命过无犯。若服药时命过无犯。时有比丘长病。时瞻病者厌患。与非所应食令断命疑。佛问言汝以何心。答言杀心。佛言波罗夷。时有比丘长病。瞻病者厌患。即与非药令命过疑。佛问言汝以何心。答言杀心。佛言波罗夷。时有比丘长病。多有器物。瞻病者贪利。即与非所应食令命过疑。佛问言汝以何心。答言杀心。佛言波罗夷。时有比丘长病。多有财物。瞻病者贪利即与非药令命过疑。佛问言汝以何心。答言杀心。佛言波罗夷。时有比丘。腋下有痈肿。有比丘为按语。彼语言。莫按莫按。而故为按之不止。遂便命过疑。佛问言汝以何心。答言不以杀心。佛言无犯。而不应如是强按。时有比丘通身肿。有比丘以急躁药涂之。彼言。止止莫涂。我患热痛。彼言小忍当得除差。涂之不止。遂便命过疑。佛问言汝以何心。答言不以杀心。佛言无犯。而不应如是强涂。时有比丘。从荫中移病比丘至日中。彼病者命过疑。佛言无犯。从日中至荫处亦无犯。病者自欲从荫中至日中从日中至荫中。病者命过。彼扶者疑。佛言无犯。若扶病人出屋若入屋。病者命过疑。佛言无犯。病人自欲出屋扶出屋。自欲入屋扶入屋。而命过。扶者无犯。扶病人至大便处命过。若扶还屋命过。尽无犯。扶病人至小便处命过。若还屋命过。尽无犯。时有比丘患疟。有比丘强压上。彼病者言。莫压莫压。压之不已。遂便命过疑。佛问言汝以何心。答言不以杀心。佛言无犯。而不应如是强压。时有比丘病。余比丘往问讯。拨衣看面。问言。长老病小差不。彼言。莫拨莫拨。彼拨之不已。遂便命过疑。佛问言汝以何心。答言不以杀心。佛言无犯。而不应强拨。时有众多比丘。方便遣一人断彼命。即往断命彼疑。佛言一切波罗夷。时有众多比丘。方便遣一人断他命。中有一人疑而不遮。彼便即往断命疑。佛言一切波罗夷。时有众多比丘方便共断他命。中有一人疑即遮。而使故往断命疑。佛言。遮者偷兰遮。不遮者波罗夷。时有贼盗取比丘衣钵针筒坐具。时比丘即捉贼压治遂命过疑。佛问言汝以何心。答言不以杀心。佛言无犯。而不应压治。时有贼盗比丘衣钵坐具针筒。比丘捉贼得。内着地窖中。遂命过彼疑。佛言汝以何心。答言不以杀心。佛言无犯。而不应尔。时有恶比丘。盗比丘衣钵坐具针筒。余比丘言。此恶比丘。盗比丘衣钵坐具针筒。应捉取与说法语。即捉取打令熟手。后遂命过彼疑。佛问言汝以何心。答言不以杀心。佛言无犯。而打受大戒人波逸提。时有比丘。共白衣诤。比丘即诣官言。时有大臣。教捉系闭。遂狱中命过彼疑。佛言汝以何心。答言不以杀心。佛言不犯。而言人突吉罗。时有比丘杀猕猴。彼疑我断人命波罗夷。诸比丘白佛。佛言无犯。断畜生命波逸提。时有比丘。与彼比丘共诤。彼比丘病。此比丘往问讯。余比丘察之。此比丘与病比丘先有怨。今来问讯必有异。时此比丘。即与病者非药。命过疑。佛问言。汝以何心。答言杀心。佛言波罗夷。时有比丘与比丘诤。彼比丘往人间得病。此比丘言。汝虽往人间犹不得脱。即往问讯。余比丘察之。此比丘先与病比丘有怨。今来问讯必有异。此比丘。即与病者非药。命过疑。佛问言汝以何心。答言杀心。佛言波罗夷与非食有二种亦如是。尔时偷罗难陀比丘尼。晨朝着衣持钵往白衣家。有一小儿在碓屋中睡偷罗难陀往触彼步碓杵。杵堕小儿上。即命过疑。佛问言汝以何心。答言不以杀心。佛言无犯。不应触他碓杵。时偷罗难陀比丘尼。晨朝着衣持钵往白衣家。有小儿在碓臼边眠。偷罗难陀触他碓臼。臼转压杀小儿疑。佛问言汝以何心。答言不以杀心。佛言无犯。而不应触他碓臼。时偷罗难陀比丘尼。晨朝着衣持钵往白衣家。床上有小儿眠。偷罗难陀不看而坐。檀越妇言。阿姨莫坐小儿上。彼不闻便坐。小儿即死疑。佛问言汝以何心。答言不以杀心。佛言无犯。而不应白衣家不看床座而坐

尔时舍卫国有檀越。请佛及僧明日食。即于夜办具种种多美饮食。晨朝往白时至。世尊着衣持钵。与千二百五十比丘俱。至檀越家就座而坐。诸佛常法。众未集不受饮食。时有晚出家比丘。将儿出家。小食时往余白衣家诸比丘问其儿言。汝父往何处去。乃令世尊待而不食。彼言不知。比丘语言。汝往求觅。彼求觅得之。儿语父言往何处来。以待父故。令佛众僧不得受食。其父嗔即捉儿。儿自解推。父倒地即命过彼疑。佛问言汝以何心。答言不以杀心。佛言无犯。而不应推父。时有母捉比丘。比丘自解即推。母却倒地即命过彼疑。佛问言汝以何心。答言不以杀心。佛言无犯。而不应推排母。时有父捉比丘。比丘自解推却。父倒地即命过彼疑。佛问言汝以何心。答言不以杀心。佛言无犯。而不应推兄捉比丘姊捉比丘故二捉比丘亦如是。时有故二姊。语其妹言。何不从比丘索衣食。彼言。以出家不欲从有所索若示我比丘处。我当为汝索。彼即示处。彼语比丘言。汝何不与我姝衣食。即前捉比丘。比丘推却自解。彼倒地命过疑。佛问言汝以何心。答言不以杀心。佛言无犯。而不应推。时有男女捉比丘。比丘推却自解。彼倒地命过疑。佛问言汝以何心。答言不以杀心。佛言无犯。而不应推。时去比丘尼寺不远。有男子截手截脚。时比丘尼持苏毗罗浆。去彼不远而行彼见已语言。阿姨与我浆饮。比丘尼即与。彼饮便死疑。佛问言汝以何心。答言不以杀心。佛言无犯。时去比丘尼寺不远。有人被截手截脚。比丘尼持水去彼不远而行。彼见已语言。阿姨与我水饮。即与饮已便死疑。佛问言汝以何心。答言不以杀心。佛言无犯。时去比丘尼寺不远。有人被截手截脚。有比丘尼持苏毗罗去彼不远而行。彼见已语言。阿姨我须苏毗罗洗疮。或得小差。即与令洗。洗已便死疑。佛问言汝以何心。答言不以杀心。佛言无犯。而不应与洗。持水洗亦如是。时去比丘尼寺不远。有人被截手脚。有比丘尼持苏毗罗去彼不远而行。比丘尼作是念。若以苏毗罗洗彼疮。或令早死。即为洗之便死。佛问言汝以何心。答言以杀心。佛言波罗夷。持水与洗亦如是

尔时有众多比丘。与六群比丘在耆阇崛山共破木片覆屋。有一六群比丘。捉尖头木片直当人掷。木入彼身过。即便死疑。佛问言汝以何心。答言不以杀心。佛言无犯。而不应当人直掷木。应横掷。时有经营比丘作新房。误失石堕比丘上即死疑。佛问言汝以何心。答言不以杀心。佛言无犯。失墼若木头榑拱屋栋种种材木堕亦如是。尔时耆阇崛山。有牧牛人放牛。一六群比丘以石打彼牛角。石迸堕放牛人上即死疑。佛问言汝以何心。答言不以杀心。佛言无犯。打畜生不能变化者突吉罗。尔时有比丘。在耆阇崛山中。崩石堕打道行人死疑。佛问言汝以何心。答言不以杀心。佛言无犯。而不应崩石。若有因缘欲取石。当语人避。时有比丘欲舍戒堕下业。彼作是念。我不应已于佛法中出家作如是恶事。即往摩头山顶。自投身堕斫竹人上。比丘活彼人死疑。佛言。彼人死无犯。方便欲自杀偷兰遮。时有比丘欲休道堕下业。作如是念。我于佛法中出家。不应作如是恶事。彼上波罗呵那山顶。自投身堕斫竹人上。彼死比丘活疑。佛言。彼人死无犯。方便欲自杀偷兰遮。时有比丘。持苏毗罗浆去冢不远而行。尖标头人语言。与我此浆饮。比丘即与。饮已便死疑。佛问言汝以何心。答言不以杀心。佛言无犯。时有比丘持水去冢不远而行。尖标头人言。与我水饮。即与饮已便死疑。佛言无犯。时有颠狂比丘。杀人后还醒了疑。佛言无犯。若心错乱为苦痛所恼。一切无犯

尔时世尊在毗舍离。时优波离。从坐起偏露右肩右膝着地合掌白世尊言。大德。婆裘河边比丘。为食故不真实非己有。于白衣前自叹说得上人法。是犯不。佛言。初未制戒无犯。时有比丘。增上慢自记。后精勤不懈。证增上胜法。彼作是念。世尊为诸比丘制戒。若比丘不自知。自称得上人法。我知是见是。后于异时。若问若不问为求清净故。作是言。我不知不见。而言知见。虚诳妄语。比丘波罗夷不共住。我以增上慢自记。后精勤不懈。得增上胜法。我当云何。即以因缘具向同意比丘说。善哉长老。为我白世尊。随世尊教我当修行。诸比丘往诣佛所。头面礼足却坐一面。以此因缘具白世尊。世尊尔时以此因缘集比丘僧。而为随顺说法。无数方便赞叹头陀端严少欲知足乐于出离。告诸比丘。增上慢无犯。诸比丘白佛言。大德。若于不能变化畜生前。自称得上人法。是犯不。佛言突吉罗。大德。人作人想是犯不。佛言波罗夷。人疑是犯不。佛言偷兰遮。人作非人想是犯不。佛言偷兰遮。非人作人想是犯不。佛言偷兰遮。非人疑是犯不。佛言偷兰遮。大德。若男前作女想是犯不。佛言波罗夷。女前作男想是犯不。佛言波罗夷。若于此女前作彼女想。是犯不。佛言若说了了者波罗夷。若不了了者偷兰遮。于此男前作彼男想是犯不。佛言。若说而了了者波罗夷。说而不了了者偷兰遮。若手印若使若书若现相。令了了知者波罗夷。不了了知者偷兰遮。大德。若于天龙阿修罗犍闼婆夜叉饿鬼畜生能变化者前。自称得上人法是犯不。佛言。说而了了者偷兰遮。不了了者突吉罗。手印使书现相。令了了知偷兰遮。不了了者突吉罗。时有比丘。人前自称言得上人法疑。佛言。说而了了者波罗夷。不了了者偷兰遮。欲向此说乃向彼说。一切波罗夷。时有众多比丘。于拘萨罗国游行。时有信乐能相婆罗门。见已作如是言。大德阿罗汉来。比丘问言汝何所说耶。答言大德。应受饮食衣服医药所须之具。比丘言。有是理比丘疑。佛言无犯。时有比丘。自说得根力觉意禅定解脱三昧正受。比丘疑。佛言波罗夷。时有比丘。为人说根力觉意禅定解脱三昧正受。而不自言得比丘疑。佛言无犯。时比丘有檀越。比丘语言。常为汝说法者是阿罗汉。檀越即问言。大德何所说。便默然。比丘疑。佛言。不了了偷兰遮。时比丘有檀越。比丘语言。数至汝家者是阿罗汉。檀越即问言。大德何所说。便默然。比丘疑。佛言。不了了偷兰遮。时比丘有檀越。比丘语言数坐汝座者是阿罗汉。即问言。大德何所说。便默然。比丘疑。佛言。不了了偷兰遮。时比丘有檀越。比丘语言。数受汝食者是阿罗汉。檀越问言。大德何所说。彼便默然疑。佛言。不了了偷兰遮。时有檀越。语常供养比丘言。若大德是阿罗汉者脱僧伽梨。比丘即脱现相不语疑。佛言偷兰遮。时有檀越。语常供养比丘言。大德若是阿罗汉者着僧伽梨。比丘即着现相不语疑。佛言偷兰遮。时有檀越。语常所供养比丘言。大德若是阿罗汉者可坐绳床。彼即坐现相不语疑。佛言偷兰遮。时有檀越。语常所供养比丘言。大德若是阿罗汉者起。彼即起现相不语疑。佛言偷兰遮。时有檀越问常所供养比丘言。大德若是阿罗汉上阁屋。彼即上现相不语疑。佛言偷兰遮。时有檀越语常所供养比丘言。大德。若是阿罗汉可下。比丘即下现相不语疑。佛言偷兰遮。时有比丘。有檀越。比丘语言。数为汝说法者。是佛弟子声闻。檀越问言。大德。何所说彼默然疑。佛言。不了了偷兰遮。数入檀越家若受坐若受食亦如是。时有檀越。语常供养比丘言。若大德是佛弟子声闻者脱僧伽梨。即脱现相不语疑。佛言偷兰遮。着僧伽梨若坐若起上阁屋若下亦如是。时目连告诸比丘。业报因缘得神足。诸比丘言。目连汝言业报因缘得神足。无有是处。虚称得上人法。波罗夷非比丘。诸比丘白佛。佛言。有是业报因缘得神足。目连无犯。时目连告诸比丘。业报因缘得天耳识宿命知他心天眼。诸比丘言。目连汝言。业报因缘得天耳乃至天眼。无有是处。虚称得上人法。波罗夷非比丘。诸比丘白佛。佛言。有业报因缘。得天耳乃至得天眼。目连无犯。时目连告诸比丘。诸长老。有如是众生从虚空过。闻其身骨相触声。诸比丘语目连言。大德汝言。有如是众生从虚空过。闻其身骨相触声。无有是处。虚称得上人法。波罗夷非比丘。诸比丘白佛。佛言。有如是众生。目连无犯。尔时目连告诸比丘。我见有众生举身以针为毛自于其身或出或入受苦无量号哭大唤。时诸比丘语目连言。汝见有如是众生。无有是处。虚称得上人法。波罗夷非比丘。诸比丘白佛。佛言。我先亦见如是众生。而我不说。何以故。恐人不信。其不信者。长夜受苦。此众生于王舍城中喜两舌斗乱。以此恶业因缘堕地狱中。经百千万岁受诸苦痛。以此余罪因缘。受如是形。是故目连无犯。尔时目连告诸比丘言。我见有众生没在屎中受大苦痛号哭大唤。诸比丘语目连言。汝自言见有如是众生没在屎中受大苦痛号哭大唤。无有是处。虚称得上人法波罗夷非比丘。诸比丘白佛。佛言。我先亦见如是众生。而我不说。何以故。恐人不信。其不信者长夜受苦。此众生在波罗奈国。迦叶佛时为婆罗门。时请佛及僧。以屎盛满槽已。遣人往白时到。语言大德。汝可食此饮此随意持去。以此恶业因缘堕泥犁中。百千万岁受大苦痛。余罪因缘没在屎中。是故目连无犯。尔时目连告诸比丘。我见有众生坐铁床上。铁床火出举身燋然。衣钵坐具针筒亦皆燋然。诸比丘语目连言。汝见如是众生受苦如是。无有是处。虚称得上人法。波罗夷非比丘。诸比丘白佛。佛言。我先亦见如是众生受苦如是。而我不说。何以故。恐人不信。其不信者长夜受苦。此众生过去世时。在波罗奈国。迦叶佛时恶比丘。以此因缘堕地狱中。百千万岁受诸苦痛。余业因缘受此身。是故目连无犯。恶比丘尼恶式叉摩那恶沙弥沙弥尼受苦亦如是。尔时目连告诸比丘。我见有众生其身熟烂众蝇封着苦痛大唤。诸比丘告目连言。汝见有如是众生受苦如是。无有是处。虚称得上人法。波罗夷非比丘。诸比丘往白佛。佛言。我先亦见如是众生。而我不说。何以故。恐人不信。其不信者长夜受苦。此众生是迦陵伽王第一夫人。以嫉妒故。以热沸油。第二夫人眠时。以灌其顶。以此业报因缘。堕地狱中。百千万岁受诸苦痛。余业因缘受此身。是故目连无犯。尔时目连告诸比丘。我见阿修罗宫殿城郭在海底。而水悬其上不入其宫城。诸比丘语目连言。汝自言。阿修罗宫城在海底。四边及上而无水入。无有是处。虚称得上人法。波罗夷非比丘。诸比丘白佛。佛言有如是事。阿修罗宫城四面及上。有四种风持水。住风。持风。不灭风。牢系风。是故目连无犯。尔时目连告诸比丘。我见有如是众生。无骨无皮无肉无血。无有不净。亦无疲极。女而不产。诸比丘言。目连汝自言。有如是众生乃至女而不产。无有是处。虚称得上人法。波罗夷非比丘。诸比丘白佛。佛言。有如是众生。目连无犯。尔时世尊在王舍城。时大目连告诸比丘言。诸长老。我入空慧定。闻伊罗婆尼象王入难陀池水声。诸比丘言。大德目连。汝言。入空慧定闻伊罗婆尼象王入难陀池水声。大德入空慧定而闻音声。无有是处。虚称得上人法。波罗夷非比丘。诸比丘白佛。佛言。有是定而不清净。目连无犯。时目连告诸比丘言。我入空慧定。闻八万四千象入曼陀延池水声。时诸比丘语目连。大德自言。入空慧定闻彼诸象。入曼陀延池水声。大德入空慧定而闻音声。无有是处。虚称得上人法。波罗夷非比丘。时诸比丘往白佛。佛言。有如是定但不清净。而目连无犯。尔时目连告诸比丘。我入空慧定。闻彼象王入苏池水声。时诸比丘语目连。汝自言。入空慧定闻彼象王入苏池水声。何有入空慧定而有闻声。无有是处。虚称得上人法。波罗夷非比丘。诸比丘白佛。佛言。有如是定非清净。目连无犯。识慧定处无所有慧定处亦如是。时目连告诸比丘。诸长老。比方有池名阿耨达。其水清净无有垢秽。中有分陀利华如车轮。其根如车轴。折之汁出。色白如乳。其味如蜜。诸比丘言。汝自言。北方有如是池。无有是处。虚称得上人法。波罗夷非比丘。诸比丘白佛。佛言。北方有如是池。如目连所说。目连无犯。时目连告诸比丘。北方有池名阿耨达。去彼不远。更有一池名曼陀延纵广五十由旬。其水清净无有垢秽。中有金色莲华。大如车轮。诸比丘言。目连如汝所说有如是池。无有是处。时大目连。以神足力往彼取华还寺置在屋内。唤诸比丘语言。北方有池名阿耨达。去池不远。有曼陀延池。中有金色莲华如车轮。诸比丘言。目连无有是处。虚称得上人法。波罗夷非比丘。时目连即还屋。取华示诸比丘语言。诸长老。此华如实不。诸比丘复言。汝是阿罗汉。有神足力。或能化作非真实。虚称得上人法。波罗夷非比丘。诸比丘白佛。佛言。目连所说如实无犯。时目连告诸比丘。北方有池名阿耨达。水从彼池流来涌出于此。诸比丘语目连言。汝说北方有池名阿耨达水从彼流来涌出于此。世尊有如是言。依本而知彼池水清冷。而今此水热沸而垢浊。事不相应。虚称得上人法。波罗夷非比丘。诸比丘白佛。佛言。如目连所说。而此水经过小地狱来涌出王舍城。是故热沸而垢浊。目连无犯。时目连告诸比丘。此水出处下有池水。清冷水从彼而来。诸比丘言。目连汝作如是语。如世尊所说。依本而知。此水热沸下水清冷。事不相应。虚称得上人法。波罗夷非比丘。诸比丘白佛。佛言比丘。如目连所说。沸水出处下有池水。清冷无有垢浊。水从彼来。经过小地狱来。涌出王舍城。是故热沸有垢。目连无犯。时拘萨罗国王波斯匿。摩竭王阿阇世。在二国中间共战。波斯匿王。破阿阇世王军。时大目连告诸比丘。波斯匿王阿阇世王。二国中间共战。波斯匿王胜。后阿阇世王。复更起军共战。阿阇世还得胜。时王舍城告令国内。阿阇世王破波斯匿王。诸比丘语目连言。汝言。波斯匿王与阿阇世王共战。波斯匿王破阿阇世王。而今摩竭国内告令言。阿阇世王破波斯匿王。目连虚称得上人法。波罗夷非比丘。诸比丘白佛。佛言。有如是事。波斯匿王破阿阇世王。阿阇世王后更起军。破波斯匿王。目连见前不见后。是故目连无犯。阿阇世王。与毗舍离共战。亦如是

尔时世尊告目连。汝止止不须复说。诸比丘不信汝言。何以故。令诸比丘不信故得多罪。时世尊告诸比丘。汝等当信如是阿罗汉比丘有大神力。勿疑不信长夜受苦。中有比丘。名曰严好。告诸比丘言。诸长老。我忆五百劫事。诸比丘言。世尊未曾自说忆五百劫事。而汝自说。虚称得上人法。波罗夷非比丘。诸比丘白佛。佛言。严好比丘忆一生事。我忆无数生种种之事。乃至受形相类有所言说皆悉忆之。佛言。严好比丘无犯

尔时世尊在舍卫国。优波离。从坐起偏露右肩右膝着地合掌白佛言。大德。迦留陀夷故弄出不净是犯不。佛言。最初未制戒无犯。时有比丘散乱心眠。梦中失不净。于梦中识了。彼作是念。世尊为比丘制戒。故弄失不净僧伽婆尸沙。而我散乱心眠。梦中失不净。自觉忆识。我将无不犯耶。不知云何。以此因缘具白诸比丘善哉长老。为我白佛。若佛有教。我当修行。时诸比丘往世尊所。头面礼足以此因缘具白世尊。世尊以此因缘集比丘僧。告言。散乱心眠有五过失。梦见恶事。诸天不卫护。心不忆法。不系想在明。梦中失不净。散乱心眠有此五过失。住心而眠有五功德。不见恶梦。诸天卫护。心思乐法。系想在明。不失不净。如是住心而眠有五事功德。若梦中失不犯。时有比丘梦中忆识弄失不净彼疑。佛言不犯。时有比丘邪忆念失不净。佛言不犯。若见美色不触而失不净不犯。时有比丘忆念弄失不净彼疑。佛言。僧伽婆尸沙。时有比丘忆念弄而不失疑。佛言。偷兰遮。时有女人捉比丘前。彼动身失不净疑。佛言僧伽婆尸沙。时有女人捉比丘前。不动身失不净疑。佛言突吉罗。捉比丘后。有二事亦如是。时有女人执比丘足礼。动身失不净疑。佛言。僧伽婆尸沙。时有女人执比丘足礼。不动身失不净疑。佛言突吉罗。时有女人礼难陀足。难陀多欲失不净堕女人头上。时女人惭愧。难陀亦惭愧。诸比丘白佛。佛言。听难陀作遮身衣。时有比丘行时男根触衣涅槃僧失不净。佛言不犯。若大小便时失不犯。若冷水若暖水中洗失不犯。时有比丘以男根逆水忆想身动失不净疑。佛言。僧伽婆尸沙。时有比丘以男根顺水忆想身动失不净疑。佛言。僧伽婆尸沙。时有比丘以水洒男根忆想身动失不净疑。佛言。僧伽婆尸沙。时有比丘男根逆风忆想身动失不净疑。佛言。僧伽婆尸沙。若顺风若口嘘男根忆想身动失不净。忆想空动身失不净疑。佛言。如是一切僧伽婆尸沙。时有母捉比丘儿身不动失不净疑。佛言。突吉罗。姊捉比丘故。二故私通处淫女捉比丘亦如是。时有比丘忆想骨间弄失不净疑。佛言。偷兰遮。时有比丘浴室中以细末药若泥揩摩身误触失不净疑。佛言不犯。若大唤时若出力作时失不净不犯。时有比丘忆想于大小便道中间弄失不净疑。佛言。若作道想若疑偷兰遮。若非道想不疑僧伽婆尸沙。如是于股间[月*冓]间若曲膝若胁边若乳间若腋下若耳鼻中若疮中若绳床木床间若大小褥间若枕间若地若泥抟间若君持口中。如是一切若道想若疑偷兰遮。若非道想不疑僧伽婆尸沙。时有比丘为乐故忆想弄失不净疑。佛言。僧伽婆尸沙。为乐故为自试故。为福德故为祠故。为善道故为施故。为种故为戏故。为力故为颜色故。当审定作。一切僧伽婆尸沙

四分律卷第五十六四分律卷第五十七(第四分之八)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    调部之三

尔时世尊在舍卫国。优波离。从坐起偏露右肩右膝着地合掌白佛言。大德。迦留陀夷与女人身相触是犯不。佛言。初未制戒不犯。大德。若与男子身相触是犯不。佛言。突吉罗。大德。若与黄门身相触是犯不。佛言。偷兰遮。大德。若与二根人身相触是犯不。佛言。偷兰遮。大德。若与畜生不能变化者身相触是犯不。佛言。突吉罗。人女人女想是犯不。佛言。僧伽婆尸沙。人女疑是犯不。佛言。偷兰遮。人女非人女想是犯不。佛言。偷兰遮。非人女人女想是犯不。佛言。偷兰遮。非人女疑是犯不。佛言。偷兰遮。大德。若作女想与男身相触是犯不。佛言偷兰遮。若作男想与女人身相触是犯不。佛言。偷兰遮。与此女身相触作余女想是犯不。佛言。僧伽婆尸沙。与此男身相触作余男想是犯不。佛言。突吉罗。与天女龙女阿修罗女夜叉女饿鬼女与畜生能变化者女身相触是犯不。佛言。偷兰遮。时有女人捉比丘足礼。觉触受乐动身疑。佛言。僧伽婆尸沙。时有女人捉比丘足礼。觉触受乐不动身疑。佛言。突吉罗。时有女人捉比丘足礼。觉触受乐动足大指疑。佛言。僧伽婆尸沙。时有女人笑捉比丘。比丘疑。佛问言。比丘汝觉触受乐不。答言不。佛言无犯。比丘笑捉女人亦如是。时有比丘。捉牸牛尾渡水。渡水已方知是牸牛。比丘疑。佛言无犯。不应捉牸牛尾渡水。时有比丘欲心捉女人衣角疑。佛言。偷兰遮。时有比丘欲心就女人身上捉女人严身具疑。佛言。偷兰遮。时有比丘欲心抄女人尻疑。佛言。僧伽婆尸沙。时有母捉比丘。彼觉触受乐不动身疑。佛言。突吉罗。姊故二淫女亦如是。时有比丘欲心捉女人发疑。佛言。僧伽婆尸沙。时有大童女为水所漂。比丘见已慈念即接出疑。佛问言。比丘汝觉触受乐不。答言不。佛言。无犯。时有磨香女人为水所漂。比丘见慈念即接出疑。佛问言。汝觉触受乐不。答言不。佛言。无犯。时有比丘与死女人身未坏者身相触疑。佛言。僧伽婆尸沙。若与多不坏者身相触僧伽婆尸沙。若与半坏者身相触偷兰遮。若与身多坏者。若一切坏者。身相触偷兰遮。时有女人却倚床比丘欲心动床疑。佛言。偷兰遮。时有比丘欲心捉女人手疑。佛言。僧伽婆尸沙。时有比丘欲心捉女人脚疑。佛言。僧伽婆尸沙。时有女人捉比丘手。比丘觉触受乐动身疑。佛问言。比丘汝觉触受乐不。答言尔。佛言。僧伽婆尸沙。女人捉比丘脚亦如是。时有比丘戏笑捉女人手疑。佛问言。比丘汝觉触受乐不。答言不。佛言。不犯。捉脚亦如是。时有女人戏笑捉比丘手比丘疑。佛问比丘。汝觉触受乐不。答言不。佛言。无犯。捉脚亦如是。时有比丘欲心捉女人衣角牵比丘疑。佛言。偷兰遮。时有比丘欲心共女人抖擞衣疑。佛言。偷兰遮。时有比丘欲心就捉女人耳环疑。佛言。偷兰遮。捉华鬘捉钗一切偷兰遮。时有比丘。雨中与女人共行。泥滑女人脚跌倒地。比丘亦脚跌倒地。堕女人上疑。佛问言。汝觉触受乐不。答言不。佛言。无犯。比丘倒地女人堕上亦如是。时有比丘。雨中与女人共行。俱脚跌倒地。相触婉转。还相离疑。佛问言。汝觉触受乐不。答言不。佛言。无犯。时有比丘手触女人大小便道间疑。佛言。僧伽婆尸沙。若股间[月*冓]间若曲膝间若胁边若乳间若耳中若鼻中若疮中。一切僧伽婆尸沙。时有比丘捉小沙弥摩扪呜疑。佛问言。汝以何心。答言。爱故不以欲心。佛言。无犯。不应尔。时有比丘与比丘尼身相触疑。佛言。僧伽婆尸沙。式叉摩那沙弥尼亦如是。时有比丘。持苏毗罗浆在道行。故二唤共行不净。即示其女根。彼即以苏毗罗浆洒之言。臭物还着臭物疑。佛问言。比丘汝以何心。答言。折辱其意。不以欲心。佛言。无犯。不应尔。持水在道行亦如是。时有淫女。唤比丘行不净。以女根示比丘。比丘以石打彼女根疑。佛问言。汝以何心。答言。折辱其意。不以欲心。佛言。无犯。打女人突吉罗。时有女人倚木。比丘欲心动木疑。佛言。偷兰遮。若绳床若坐床若企床若板若石若树若梯。一切偷兰遮。时有女人乘舆行。比丘欲心动舆疑。佛言。偷兰遮。辇若舡亦如是。时有女人捉比丘背。彼还顾见是女人觉触受乐疑。佛言。僧伽婆尸沙

尔时世尊在舍卫国。优波离。从坐起偏露右肩右膝着地合掌白佛言。大德。迦留陀夷与女人粗恶语是犯不。佛言。初未制戒无犯。大德。若与男子粗恶语是犯不。佛言。突吉罗。若与黄门粗恶语是犯不。佛言。偷兰遮。若与二根人粗恶语是犯不。佛言。偷兰遮。若与畜生不能变化者粗恶语是犯不。佛言。突吉罗。大德。人女人女想粗恶语是犯不。佛言。僧伽婆尸沙。人女疑是犯不。佛言。偷兰遮。人女非人女想是犯不。佛言偷兰遮。非人女人女想是犯不。佛言。偷兰遮。非人女疑。佛言偷兰遮。大德。若女想与男子粗恶语是犯不。佛言。偷兰遮。大德。男想与女人粗恶语是犯不。佛言。偷兰遮。大德。若作此女想与彼女粗恶语疑。佛言。若说而了了者僧伽婆尸沙。不了了偷兰遮。手印信书相了了知者僧伽婆尸沙。不了了知者偷兰遮。大德。若作此男想与彼男粗恶语是犯不。佛言。突吉罗。大德。若与天女龙女阿修罗女夜叉女饿鬼女畜生能变化者女粗恶语是犯不。佛言。说而了了者偷兰遮。不了了者突吉罗。手印信书相说了了知者偷兰遮。不了了知者突吉罗。时有比丘向女人粗恶语疑。佛言。说而了了者僧伽婆尸沙。不了了者偷兰遮。欲向此说错向彼说。一切僧伽婆尸沙。时有淫女。唤比丘共行不净。示其女根。比丘言。令汝女根断破坏臭烂烧燋堕。与驴作如是事疑。佛问言。汝以何心。答言。折辱彼。不以欲心。佛言。无犯。以恶言突吉罗。迦留陀夷为性好粗恶语。佛言。性好粗恶语突吉罗。六群比丘性好粗恶语。佛言。突吉罗。时有乞食比丘。晨朝着衣持钵往白衣家。语檀越妇言。可得不。彼即言。大德。问何等可得不。比丘默然不答疑。佛言。说不了了偷兰遮。时有乞食比丘。晨朝着衣持钵往白衣家。语檀越妇言。与我来。彼即问言。大德与何等。比丘默然疑。佛言。说不了了者偷兰遮。若言当与我不。若言看。若言似何等。说不了了一切偷兰遮。时比丘有檀越。檀越语妇言。某甲比丘有所须便与。妇答言可尔。于是檀越即往比丘所语言。我已敕妇言。若某甲比丘有所须者便与。大德有所须可往索。比丘言可尔。后比丘着衣持钵往檀越家敷座而坐。檀越妇语比丘言。夫敕我。某甲比丘有所须便与。大德。今有所须便说。比丘言。汝俱不能一切与我。妇答言。大德。不能何等一切与。比丘默然疑。佛言。说不了了者偷兰遮。时比丘有檀越。檀越敕妇言。某甲比丘有所须便与。檀越即往比丘所语言。我已敕妇言。大德有所须便与。大德若有所须往索。比丘言可尔。比丘后时着衣持钵往檀越家敷座而坐。檀越妇言。我夫已敕我言。某甲比丘有所须便与。大德。今有所须便说。比丘言。汝一切能与。唯有此事不能与。彼即知其心。答言。一切能与。此亦能与。比丘疑。佛言。僧伽婆尸沙。时比丘有檀越。檀越语其妇言。某甲比丘一切有所须便与。檀越往比丘所语言。我已敕妇。某甲比丘一切有所须便与。大德若有所须往索。比丘言可尔。后于异时着衣持钵往其家敷座而坐。檀越妇语言。我夫已敕我言。某甲比丘一切有所须便与。大德。今有所须便说。比丘言。汝不应一切与。彼问言。大德何等不应一切与。比丘默然疑。佛言。说不了了者偷兰遮(次句与此句同。正以言汝一切应与。此事不应与。彼言此事亦能与。比丘疑。佛言。僧伽婆尸沙)

时有乞食比丘。晨朝着衣持钵。至檀越家男根起。语檀越妇言增益。彼问言。大德。何等增益。默然疑。佛言。说不了了偷兰遮。时有比丘。式叉摩那为檀越。彼数犯戒。于比丘前忏悔。比丘言。汝无惭愧犯不净行。比丘疑。佛问言。汝以何心。答言。为教授故不以欲心。佛言。无犯。时有比丘。有童女为檀越。数犯戒语比丘。比丘言。汝无惭愧犯持戒者。比丘疑。佛问言。汝以何心。答言。以教授故不以欲心。佛言。无犯。时有比丘。晨朝着衣持钵往白衣家。有女人消酥形露。比丘见已语言。汝消酥。彼言。大德尔。我消酥。比丘默然疑。佛言。说不了了偷兰遮。时有乞食比丘。晨朝着衣持钵往白衣家。时有着赤衣女人形露。比丘见已语言。汝着赤衣。彼答言。大德。我着赤衣。彼默然疑。佛言。偷兰遮

尔时世尊在波罗奈。时有比丘。淫女为檀越。语比丘言。大德。若须此事便说。彼默然。淫女言。大德。今者须耶。何故默然。彼疑。佛言。无犯

尔时世尊在舍卫国。有外道女人形貌端正。比丘见已系意在彼。后异时此女人去只桓不远行。比丘言。汝多作。彼答言。实尔多作。比丘疑。佛言。僧伽婆尸沙

尔时世尊在舍卫国。优波离从坐起偏露右肩右膝着地白世尊言。大德。迦留陀夷于女人前自赞叹身是犯不。佛言。初未制戒不犯。大德。若于男子前自赞叹身是犯不。佛言。突吉罗。大德。若于黄门前自赞叹身是犯不。佛言。偷兰遮。大德。若于二根人前自赞叹身是犯不。佛言。偷兰遮。若于畜生不能变化者前自赞叹身是犯不。佛言。突吉罗。人女人女想是犯不。佛言。僧伽婆尸沙。人女疑是犯不。佛言。偷兰遮。人女非人女想是犯不。佛言。偷兰遮。非人女人女想是犯不。佛言。偷兰遮。非人女疑是犯不。佛言。偷兰遮。大德。若作女想于男子前自赞叹身是犯不。佛言。偷兰遮。大德。若于男子前作女想是犯不。佛言。偷兰遮。大德。若作此女想于彼女前自赞叹是犯不。佛言。说而了了者僧伽婆尸沙。不了了者偷兰遮。手印信书相了了知者僧伽婆尸沙。不了了者偷兰遮。大德。若于此男前作彼男想是犯不。佛言。突吉罗。大德。若于天女龙女阿修罗女夜叉女饿鬼女畜生能变化者女前自赞叹是犯不。佛言。说而了了者偷兰遮。不了了者突吉罗。手印信书相说。令了了知。偷兰遮。不了了者突吉罗。时有比丘有檀越。檀越语妇言。若某甲比丘有所说。随其所说汝当供养。妇言可尔。语妇已。往比丘所。语言。我已敕妇言。某甲比丘若有所说。随比丘语。供养。大德。若有所须可往索。比丘言可尔。后于异时。比丘晨朝着衣持钵往其家就座而坐。檀越妇语言。我夫已敕我言。某甲比丘有所说。随所说供养。大德。今若有说者便说。比丘语言。汝俱不能一切供养。彼问言。大德。云何不能一切供养。比丘默然疑。佛言。说不了了者偷兰遮。(此中四句。如上粗恶语中同。上以粗恶语。此以供养。为异耳。今略出一句不复须烦文。故不出也)

时有比丘。女人为檀越。至其家语言。姊此事最上第一。身慈口慈心慈。供养持戒行善法比丘。彼疑。佛言。无犯

尔时世尊在王舍城。时优波离。从坐起。偏露右肩右膝着地合掌白佛言。大德。迦罗比丘媒嫁向男叹说女向女叹说男。若为妇事若为私通事是犯不。佛言。初未制戒不犯。若受语往说而持彼语还是犯不。佛言。僧伽婆尸沙。若受语向彼说不持语还是犯不。佛言。偷兰遮。若闻向彼说不持语还偷兰遮。若不受语往向彼说持彼语还偷兰遮。若受语不向彼说不持彼语还突吉罗。若闻不向彼说不持语还突吉罗。若不受语向彼说不持语还突吉罗。时有比丘。有檀越家。其妇丧未久。比丘往问讯。檀越有二儿。比丘语言。汝何不更取妇。檀越言。恐令我小儿辛苦。若得某甲童女者我当取。时比丘即往彼童女所语言。我从某甲居士闻言。我若得某甲童女者当取为妇。童女言。若须我为妇者。我亦须彼为夫。比丘即还檀越所语言。我闻彼女言。若须我为妇者。我亦须彼为夫。比丘更不持语还疑。佛言。若闻而向彼说不持语还偷兰遮。磨香女人亦如是。时有居士。往僧伽蓝中。语诸比丘言。大德为我语。诸比丘言。居士欲说何语。彼言。为我语某甲居士。与我女作妇。比丘言。居士。当为汝语。即差一比丘作白二羯磨。使往彼居士所语言。居士我为汝说众僧语。彼言。大德僧何所见敕。比丘言众僧言。以汝女与某甲居士作妇。彼言。大德。奉僧敕当与。时使比丘。还僧伽蓝中白僧。僧即告彼居士令知。比丘疑。佛言。一切僧伽婆尸沙。时有檀越。往僧伽蓝中。语诸比丘言大德。僧为我语。比丘言。居士欲说何语。彼言。为我语某甲居士。以汝女为我作妇。比丘言。当为汝语。即差一比丘作白二羯磨。使往彼居士所语言。居士我为汝说众僧语。彼居士言。大德。僧何所见敕。比丘言。众僧语汝。以汝女与某甲居士作妇。彼言。大德。奉僧敕当与。使比丘作是念。我今若还白众僧。恩不在我。即自往语彼居士已疑。佛言。众僧偷兰遮。使比丘僧伽婆尸沙。时有檀越。往常供养比丘所。语比丘言。为我语某甲居士。以汝女与我作妇。比丘言。居士当为汝语。比丘即往彼居士所语言。汝可以女与彼某甲居士作妇。居士言。我女已与他。若言他已将去。若言死。若言贼偷去。若言无。比丘还居士所语如是语。一切偷兰遮。时有檀越。语常供养比丘言。汝为我语某甲居士。可以女与我作妇。比丘言。当为汝语。比丘即往彼居士所语言。汝可以女与彼某甲居士作妇。居士言。我女有癞病。若言痈若有白癞。若言干枯病。若言狂。若言痔病。若言常有血出病。若言足下常热病。比丘还语居士如是言已疑。佛言。一切僧伽婆尸沙。时有居士。共妇斗驱出妇。即往常供养比丘所语言。大德。夫与我共斗见驱出。我今欲共忏悔。比丘即为和合令忏悔疑。佛言。为忏悔故无犯。时有妇人。与夫共斗已出去。往常供养比丘所语言。我共夫斗已出外。今欲忏悔。比丘即往和合令忏悔疑。佛言。为忏悔无犯。时有妇人。与夫共斗语言。汝若不须我为妇。当言不须。夫言。我不须汝为妇即驱出。往常供养比丘所语言。我与夫共斗。我语夫言。若不须我为妇。当言不须为妇。夫言不须。即驱我出。今欲忏悔。比丘即和合令忏悔疑。佛言。为忏悔故无犯。时有居士取淫女为妇。先常与此女人往反者。见已语言。我欲与汝作如是如是事。余人语言。此不复作淫女。今已为某甲居士为妇。彼人即强将共行淫。时夫闻已即驱出。便往常所供养比丘所语言。大德。我自为居士作妇已来。未曾犯他男子。唯有此贼强牵犯我。我今欲共夫忏悔。比丘即往和合令共夫忏悔疑。佛言。为忏悔故无犯。时有居士。给淫女所须。往常供养比丘所语言。为我语某甲淫女。在某处待我。比丘言可尔。即往淫女所语言。某甲居士语汝。在某处待。比丘疑。佛言。先以和合无犯。为白衣使突吉罗。时有居士。占护彼童女。既不迎妇。又不听余嫁。时女语常供养比丘言。大德。为我语某甲居士。我父母欲夺汝持我与余人。汝若当迎我。若当放我。比丘言可尔。彼比丘即往居士所语言。某甲童女言。我父母欲夺汝更与余人。汝今当迎。若当放之。彼疑。佛言。彼先已言誓无犯。为白衣使突吉罗。时有居士。占护彼童女。既不迎妇。又不听余嫁。彼父母言。不知令谁语某甲居士迎此童女去。若当听令余嫁。彼家常所供养比丘狂病。便言。我当为语。比丘即往彼居士所。捉头语言。汝迎某甲童女。若当放去。后还得心疑。佛言。癫狂心乱痛恼所缠。一切无犯

尔时世尊在王舍城。优波离。从坐起偏露右肩右膝着地合掌白佛言。大德。沓婆摩罗子清净。慈地比丘以无根谤之。是犯不。佛言。初未制戒无犯。大德。若以无根法谤清净比丘是犯不。佛言。僧伽婆尸沙。时有比丘。与女人在树下坐。余比丘语言。汝淫犯女人。彼答言。我不犯共树下坐耳。彼谤者疑。佛言。为真实语故不欲毁谤无犯。时有比丘。在家与故二共通。有异比丘相似余比丘。语此相似比丘言。汝犯故二。彼言。我不犯。彼犯故二比丘。与我相似耳。彼疑。佛言。为实故不以毁谤无犯。时有比丘。淫女为檀越。余比丘语言。汝犯淫女。彼言。是我檀越不犯。彼疑。佛言。为实故不以毁谤无犯。妇女若童女若黄门若比丘尼若式叉摩那沙弥尼亦如是。时有比丘捉小沙弥摩扪呜。余比丘语言。汝犯沙弥。彼言。我不犯摩扪呜之耳彼疑。佛言。为实故不以毁谤无犯。时有比丘取比丘腰带。彼言。汝盗我带。彼言。我不盗以亲厚意取彼疑。佛言。为实语故不以毁谤无犯。时有比丘。以无根僧伽婆尸沙谤他疑。佛言波逸提

    毗尼增一之一

如是我闻一时。佛在舍卫国只桓精舍给孤独食园。时世尊告诸比丘。汝等谛听善思念之。若比丘说相似文句遮法毗尼。此比丘令多人不得利益。作诸苦业以灭正法。若比丘随顺文句不违法毗尼。如此比丘利益多人。不令作众苦业。正法久住。是故诸比丘。汝等当随顺文句。勿令增减违法毗尼。当如是学。佛说如是。诸比丘闻欢喜。信乐受持。佛言。若比丘非法说法法说非法。如此比丘令多人不得利益。作众苦业以灭正法。其有比丘。非法说言非法。是法说言是法。如此比丘利益多人。作众善业令正法久住。是故汝等当随顺此教。非法当说言非法是法说言是法。当作如是学。佛说如是。诸比丘闻欢喜。信乐受持

尔时佛告诸比丘。若比丘非毗尼说言是毗尼。是毗尼说言非毗尼。令多人不得利益。作众苦业以灭正法。若比丘非毗尼说言非毗尼。是毗尼说言是毗尼。利益多人不作苦业。令正法久住。是故汝等当随此教。非毗尼说非毗尼。是毗尼说是毗尼。当作是学。佛说如是。诸比丘闻欢喜。信乐受持

佛告诸比丘。若比丘非制而制是制便断。如是渐渐令戒毁坏。令多人不得利益。作众苦业以灭正法。若比丘非制不制是制不断。如是渐渐令戒成就。利益多人不作苦业。令正法久住。是故汝等非制不应制是制不应断。当随所制戒而学。诸比丘闻欢喜。信乐受持

尔时佛告诸比丘。如来出世。见众过失故。以一义为诸比丘结戒摄取于僧。以此一义故。如来为诸比丘结戒。佛说如是。诸比丘闻。欢喜信乐受持。乃至正法久住。句句亦如是

尔时佛告诸比丘。如来出世以一义故。为诸比丘制呵责羯磨。摄取于僧。以是一义故。如来出世为诸比丘制呵责羯磨。佛说如是。诸比丘闻欢喜。信乐受持。乃至正法久住。句句亦如是。如是摈羯磨。依止羯磨。遮不至白衣家羯磨。作不见罪举羯磨。不忏悔羯磨。恶见不舍羯磨。捡挍法律所制。制受依止。制梵罚。制举。制忆念。制求听。制自言。制遮阿[少/兔]婆陀。制遮说戒。制遮自恣。制戒。制说戒。制布萨。制布萨羯磨。制自恣。制自恣羯磨。制白白羯磨。制白二羯磨。制白四羯磨。制与覆藏与本日治与摩那埵与出罪。制四波罗夷。制十三僧伽婆尸沙。二不定法。三十尼萨耆。九十波逸提。四波罗提提舍尼。式叉迦罗尼。七灭诤。一一句如呵责羯磨

尔时佛告诸比丘。说一语便成舍戒。作如是言。我舍佛。作如是一语。便为舍戒。佛说如是。诸比丘闻欢喜。信乐受持。舍法舍僧。舍和上舍同和上。舍阿阇梨舍同阿阇梨。舍诸净行比丘。舍戒舍毗尼舍学事。我是白衣。忆我是守园人。忆我是优婆塞。忆我是沙弥。忆我是外道是外道弟子。忆我非沙门释子法。一一句亦如是

尔时佛告诸比丘。有二种犯。一轻二重。是为二种犯。佛说如是。诸比丘闻欢喜。信乐受持。复有二事。一轻而有余。二轻者得作羯磨。复有二事。波罗夷僧伽婆尸沙。复有二事。波罗夷偷兰遮。复有二事。波罗夷波逸提。复有二事。波罗夷波罗提提舍尼。复有二事。波罗夷突吉罗。复有二事。波罗夷恶说。僧伽婆尸沙乃至恶说亦如是。偷兰遮乃至恶说亦如是。波逸提乃至恶说亦如是。波罗提提舍尼乃至恶说亦如是。突吉罗恶说亦如是

尔时佛告诸比丘。有二见。出家人不应行。非法见法法见非法。复有二见。毗尼言非毗尼。非毗尼言毗尼。复有二见。非犯见犯。是犯见非犯。复有二见。轻而见重。重而见轻。复有二见。有余见无余。无余见有余。复有二见。粗恶见非粗恶。非粗恶见粗恶。复有二见。旧法见非旧法。非旧法见旧法。复有二见。制见非制。非制见制。复有二见。是说见非说。非说见说。复有二见。酒见非酒。非酒见酒。复有二见。饮见非饮。非饮见饮。复有二见食见非食。非食见食。复有二见。时见非时。非时见时。复有二见。净见不净。不净见净。复有二见。重见非重。非重见重。复有二见。难见非难。非难见难。复有二见。无虫见虫。虫见无虫。复有二见。破见不破。不破见破。复有二见。种见非种。非种见种。复有二见。已解义见未解。未解义见已解。复有二见。可亲见非亲。非亲见可亲。复有二见。怖见不怖。不怖见怖。复有二见。道见非道。非道见道。复有二见。可行见非行。非行见可行。复有二见。出离见不出离。不出离见出离。复有二见。弃见不弃。不弃见弃。复有二见。见世间常见世间无常。复有二见。见世界有际见世界无际。复有二见。是身是命身异命异。复有二见。有如来灭度无如来灭度。复有二见。有无如来灭度非有无如来灭度。于佛法内有如是二见。出家人不应修行。若修行如法治。佛说如是。诸比丘闻欢喜。信乐受持

尔时佛告诸比丘。有二种毗尼。有犯毗尼有诤毗尼。复有二种毗尼。犯毗尼结使毗尼。复有二毗尼。比丘毗尼比丘尼毗尼。复有二毗尼。方毗尼遍毗尼。是为二种毗尼。佛说如是。诸比丘闻欢喜。信乐受持

尔时佛告诸比丘。有二种人住不安乐。一喜嗔二怀怨。复有二法。一急性二难舍。复有二法。一悭二嫉妒。复有二法。一欺诈二谄曲。复有二法。一自高二喜诤。复有二法。一好饰二放逸。复有二法。一慢二增上慢。复有二法。一贪二恚。复有二法。一自誉二毁他。复有二法。一邪见二边见。复有二法。一有难教二不受训导。如是二种人住不安乐

尔时佛告诸比丘。有学比丘。心未至无学。常求修习。增进胜法。有二法得多利益。未得能得。未入能入。未证能证。何等二。善犯善能除犯。如是学人。心未至无学。常求修习增进胜法。有此二法得多利益。未得能得未入能入未证能证。是故汝等当勤修习学如是法。佛说如是。诸比丘闻欢喜。信乐受持。善入定善出定亦如是

尔时佛告诸比丘。有比丘心未至无学。常求修习增进胜法。有二法得多利益。未得能得未入能入未证能证。何等二。可厌处生厌。已厌正忆念断。如是学人。心未至无学。常求修习增进胜法。有此二法得多利益。未得能得未入能入未证能证。是故汝等。可厌处生厌。已厌当正忆念断。而说偈言

  明者在厌处　　能生厌离心
  无畏不恐怖　　能断者得圣
  比丘正念断　　得无上正道
  终不复退转　　得住于涅槃

佛说如是。诸比丘闻欢喜。信乐受持

尔时佛告诸比丘。破戒堕二道。地狱畜生中。持戒生二道。生天及人中。屏处造恶业。生堕于二道。地狱及畜生。屏处造善业。得生于二道。生天及人中。邪见生二道。地狱及畜生。正见生二道。生天及人中。佛圣弟子。天人中尊贵。有二法不得解脱。一犯戒二不见犯。有二法身得解脱。一不犯二见犯。有二法不得解脱。犯而不见罪见犯而不如法忏悔。有二法自得解脱。一见犯罪。二犯而能如法忏悔。有二法不得解脱。一见罪不如法忏悔。二若如法忏而彼不受。有二法自得解脱。一见罪能如法忏。二如法忏者彼能如法受。缚不缚亦如是。有二种清净。一不犯二忏悔。佛说如是。诸比丘闻欢喜。信乐受持

尔时佛告诸比丘。有二种人谤如来。一不信乐憎嫉。二信乐不解受持。是故我今告汝等。令知此义。谤如来得大重罪。若谤一切诸天及世人若魔梵王沙门婆罗门其罪轻。谤如来其罪最重。佛说如是。诸比丘闻欢喜。信乐受持。复有二种谤如来。一非法言法。二法言非法。有二种不谤如来。一非法说非法。二法说是法。有二种谤如来。一非毗尼说毗尼。二是毗尼说非毗尼。有二种不谤如来。一非毗尼说非毗尼。二是毗尼说毗尼。有二种谤如来。一非制言制。二是制而断。有二种不谤如来。一非制言非制。二是制不断。有二法谤如来。一非法言法。二法言非法。有二法不谤如来。一非法言非法。二法言是法。乃至说言非说亦如是。二处二事二见亦如是。复有二法。不受如来善教亦如是。复有二法。违如来亦如是。复有二法。坚持与如来诤亦如是。复有二法。不奉如来亦如是。复有二法。不值如来亦如是。复有二法。于如来所粗犷无有慈心亦如是。佛说如是。诸比丘闻欢喜。信乐受持

尔时佛告诸比丘。有二众。一法语众。二非法语众。何等非法语众。众中不用法毗尼。不以佛所教而说。应教不教而住。应灭不灭而住。是为非法语众。何等法语众。众中用法毗尼。随佛所教而说。应教教而住。应灭灭而住。是为法语众。此二众中。法语众我赞叹为尊。佛说如是。诸比丘闻欢喜。信乐受持。复有二众。如法众不如法众。何等不如法众。众中若非法者有力。如法者无力。非法者得伴。如法者不得伴。作非法羯磨不作法羯磨。作非毗尼羯磨不作毗尼羯磨。非法便行。是法不行。是为非法众。何等如法众。若众中如法者有力。非法者无力。如法者得伴。不如法者不得伴。作法羯磨不作非法羯磨。作毗尼羯磨不作非毗尼羯磨。是法行非法灭。是为如法众。此二众中。如法众我赞叹为尊。佛说如是。诸比丘闻欢喜信。乐受持。有二众。等众不等众亦如是

尔时佛告诸比丘。若国法王力弱。众贼炽盛。尔时法王不得安乐出入。边国小王不顺教令。国界人民亦不安乐出入。生业休废忧苦损减不得利益。如是非法比丘有力。是法比丘无力。如法比丘不得安乐。若在众中亦不得语。若在空处住。是时作非法羯磨。不作法羯磨。作非毗尼羯磨。不作毗尼羯磨。非法便行。是法不行。彼不勤行精进。未得令得。未入令入。未证令证。则令诸天人民不得利益长夜受苦。佛说如是。诸比丘闻欢喜。信乐受持

尔时佛告诸比丘。若国法王力强。众贼力弱。皆来归伏或复逃窜。时法王安乐出入。无有忧患。边国小王顺从教令。境内人民亦得安乐。生业自恣无诸忧苦。多得利益。无有损减。如是如法比丘得力。非法比丘无力。非法比丘来至如法比丘所。随顺教令不敢违逆。若当逃窜不作众恶。尔时如法比丘安隐得乐。若在僧中得语。若在空处住。作如法羯磨。不作非法羯磨。作毗尼羯磨。不作非毗尼羯磨。是法便行非法不行。勤修精进。未得能得。未入能入。未证能证。则令诸天人民得大利益。佛说如是。诸比丘闻欢喜。信乐受持

尔时舍利弗告诸比丘。诸长老。若有斗诤。举他比丘及有罪比丘。不自观察。当知此诤遂更增长。不得如法如毗尼除灭。诸比丘不安乐。若比丘共诤。举他比丘及有罪者。各自观过。当知此诤不复增长深重。得如法如毗尼除灭。诸比丘便得安乐住。诸比丘云何自观过。有罪比丘作是念。我已犯如是事。彼见我犯非。我若不犯者。彼不得见我犯非。以我犯故。令彼见我。我今应自悔过。令彼不复以恶语呵我。我若如是。使善法增长。是为比丘能自观其过。云何举他比丘自观其过。彼作如是念。彼比丘犯非。令我得见。若彼不犯非者。我则不见。以彼犯非故。令我得见。若彼自能至诚忏悔者。不令我出恶言。如是令善法增长。是为举他比丘自观其过。若比丘有诤事。举他比丘有罪比丘。能作如是自观其过。当知此过不复增长。如法如毗尼如佛所教。诸比丘得安乐住。舍利弗说如是语。诸比丘闻欢喜。信乐受持

尔时佛告诸比丘。有二种痴。一犯罪二不见犯。是为二种痴。复有二种智。一不犯罪。二见犯罪。是为二种智。复有二种痴。一不见犯罪。二见犯罪不如法忏悔。是为二种痴。复有二种智。一见犯罪。二见罪能如法忏悔。是为二种智。复有二种痴。一见罪不如法忏悔。二如法忏悔彼不受。复有二种智。一见罪如法忏悔。二如法忏彼受。是为二种智。佛说如是。诸比丘闻。欢喜。信乐受持

尔时佛告诸比丘。以诸比丘有过失故。世尊以二义制断诤法。一难调人令调。二知惭愧者得安乐。以此二义故。世尊为诸比丘制断诤法。佛说如是。诸比丘闻欢喜。信乐受持

尔时佛告诸比丘。举他比丘欲举他罪。应修二法。一真实二不嗔。应修如是二法。被举比丘。亦应修如是二法。一真实二不嗔。佛说如是。诸比丘闻欢喜。信乐受持

尔时佛告诸比丘。比丘有二法。疾灭正法。非法说法法说非法。乃至说不说亦如是。二处二事二犯亦如是。复有二法。不能生善法。从法非法乃至说不说亦如是。二处二事二犯亦如是。复有二法。比丘自破坏犯罪数。为有智者呵责。多得众罪。从法非法乃至说不说亦如是。二处二事二犯亦如是。复有二法。比丘堕地狱犹如射箭。从法非法乃至说不说亦如是。二处二事二犯亦如是

尔时佛告诸比丘。有二法令正法久住。非法说非法。是法说是法。乃至说不说亦如是。二处二事二犯亦如是。复有二法。比丘能生诸善。非法说非法。是法说是法。乃至说不说亦如是。二处二事二犯亦如是。复有二法。比丘不自破坏不犯罪。不为智者所呵责。受福无量。非法说非法。是法说是法。乃至说不说亦如是。二处二事二犯亦如是。复有二法。比丘疾得生天犹如射箭。非法说非法。法说是法。乃至说不说亦如是。二处二事二犯亦如是。比丘有二法者应举。非法说法。法说非法。乃至说不说亦如是。为作忆念作自言作遮阿[少/兔]婆陀遮说戒遮自恣亦如是。二处二事二见亦如是。复有二法。比丘如法举。非法说法。法说非法。乃至说不说亦如是。二处二事二犯亦如是。作忆念作自言作遮阿[少/兔]婆陀遮说戒遮自恣亦如是。二处二事二见亦如是。复有二法。比丘应与作呵责羯磨。非法说法。法说非法。乃至说不说亦如是。二处二事二犯亦如是。摈羯磨依止羯磨遮不至白衣家羯磨举羯磨亦如是。二处二事二见亦如是。有二法增长有漏。可惭不惭。非惭反惭。有比二法增长有漏。复有二法不增长有漏。可惭惭。非惭不惭。复有二法增长有漏。不净见净。净见不净。有是二法增长有漏。复有二法不增长有漏。不净见不净。净见净。有是二法不增长有漏。复有二法增长有漏。不犯见犯。犯见不犯。有是二法增长有漏。复有二法不增长有漏。不犯见不犯。犯见犯。有是二事不增长有漏。复有二法增长有漏。轻而见重。重而见轻。有是二法增长有漏。复有二法不增长有漏。轻见轻。重见重。有是二法不增长有漏。复有二法增长有漏。无余见有余。有余见无余。有是二法增长有漏。复有二法不增长有漏。无余见无余。有余见有余。有是二法不增长有漏。复有二法增长有漏。非法见法。法见非法。有是二法增长有漏。复有二法不增长有漏。非法见非法。是法见是法。有是二法不增长有漏。复有二法增长有漏。非制而制。是制便断。有是二法增长有漏。复有二法不增长有漏。非制不制。是制不断。有是二法不增长有漏。有二语舍戒。我舍佛舍法。乃至我非沙门释子如上。如来出世。见众过失故。以二义为诸比丘制戒。一摄取于僧。二令僧欢喜。复有二法。一令不信者信。二已信者令增长。复有二法。一难调者得调。二知惭比丘得安乐住。复有二法。一令正法久住。二摄取毗尼。复有二法。一断现在世怨。二断未来世怨。复有二法。一灭现在有漏。二灭未来有漏。复有二法。一断现在恐怖。二除未来恐怖。复有二法。一断现在重罪。二断未来重罪。复有二法。一断现在不善法。二断未来不善法。为此二义故。世尊为诸比丘制戒。复有二法。为二义故。世尊制呵责羯磨。一摄取于僧。二令僧欢喜。乃至断现在不善法未来不善法亦如上。如是一一句乃至七灭诤。如呵责羯磨法。佛说如是。诸比丘闻欢喜。信乐受持

四分律卷第五十七四分律卷第五十八(第四分之九)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    毗尼增一之二

尔时佛告诸比丘。有三羯磨。摄一切羯磨。何等三。白羯磨。白二羯磨。白四羯磨。是为三羯磨摄一切羯磨。佛说如是。诸比丘闻欢喜。信乐受持

尔时世尊在王舍城。告诸比丘。有三非法。与忆念毗尼。何等三。若比丘犯重罪。若波罗夷若僧伽婆尸沙若偷兰遮。时余比丘言。犯波罗夷僧伽婆尸沙偷兰遮。问言。汝忆犯波罗夷僧伽婆尸沙偷兰遮不。彼言。根本不见。诸长老。我不忆犯波罗夷僧伽婆尸沙偷兰遮。莫难诘问我。而诸比丘故难诘不止。彼从僧乞忆念毗尼。若僧与彼忆念毗尼。是为非法与忆念毗尼。若有比丘。犯重罪波罗夷僧伽婆尸沙偷兰遮。时余比丘言犯波罗夷僧伽婆尸沙偷兰遮。余比丘问言。汝忆犯波罗夷僧伽婆尸沙偷兰遮不。彼言。根本不见。诸长老。我不忆念犯如是重罪。我犯小罪当忏悔清净。诸长老。莫难诘问我。而诸比丘故难诘不止。彼从僧乞忆念毗尼。若僧与忆念毗尼。是为非法与忆念毗尼。若有比丘。犯重罪波罗夷僧伽婆尸沙偷兰遮。余比丘语言。汝忆犯重罪波罗夷僧伽婆尸沙偷兰遮不。彼言。根本不见。诸长老。我不忆犯重罪波罗夷僧伽婆尸沙偷兰遮。我犯小罪已忏悔清净。诸长老。莫为难诘问我。而诸比丘故难诘不止。彼从僧乞忆念毗尼。僧若与作忆念毗尼。非法。是为三种非法与忆念毗尼。有三种如法与忆念毗尼。若比丘不犯重罪波罗夷僧伽婆尸沙偷兰遮。余比丘言犯重罪波罗夷僧伽婆尸沙偷兰遮。问言。汝忆犯如是重罪波罗夷僧伽婆尸沙偷兰遮不。彼不忆犯便作是言。诸长老。我不忆犯如是重罪波罗夷僧伽婆尸沙偷兰遮。诸长老。莫难诘问我。而诸比丘故难诘不止。彼广忆念。从僧乞忆念毗尼。僧若与忆念毗尼。是为如法与忆念毗尼。若比丘不犯重罪波罗夷僧伽婆尸沙偷兰遮。余比丘言犯重罪波罗夷僧伽婆尸沙偷兰遮。问言。汝犯波罗夷僧伽婆尸沙偷兰遮忆不。彼言不忆犯。便作是言。长老。我不忆犯如是重罪波罗夷僧伽婆尸沙偷兰遮。我犯小罪当如法忏悔清净。诸长老。莫难诘问我。而诸比丘故难诘不止。彼广忆念。从僧乞忆念毗尼。若僧与忆念毗尼。是为如法与忆念毗尼。若比丘不犯重罪波罗夷僧伽婆尸沙偷兰遮。余比丘言犯重罪波罗夷僧伽婆尸沙偷兰遮。问言。汝犯如是重罪波罗夷僧伽婆尸沙偷兰遮忆不。彼不忆犯。便作是言。长老。我不忆犯如是重罪波罗夷僧伽婆尸沙偷兰遮。我犯小罪已忏悔清净。诸长老。莫难诘问我。而诸比丘故难诘不止。彼广忆念。从僧乞忆念毗尼。僧若与忆念毗尼。是为三种如法与忆念毗尼

复有三非法。与不痴毗尼。若比丘不痴狂。而诈为痴狂。多犯不净行非沙门法。余比丘言。汝犯重罪波罗夷僧伽婆尸沙偷兰遮。彼作是言。我颠狂心乱。多犯不净行非沙门法。此非我故作。是痴狂故耳。诸长老。莫难诘问我。而诸比丘故难诘不止。彼从僧乞不痴毗尼。若僧与不痴毗尼。是为非法与不痴毗尼。若比丘不痴狂。而诈为痴狂。多犯不净行非沙门法。余比丘言。犯重罪波罗夷僧伽婆尸沙偷兰遮。问言。汝忆犯重罪波罗夷僧伽婆尸沙偷兰遮不。彼言。我先痴狂心乱。多犯不净行非沙门法。非我故作。是痴狂故作耳。如人忆梦中事。我亦如是。诸长老。莫为难诘问我。而诸比丘故难诘不止。彼从僧乞不痴毗尼。僧若与不痴毗尼。是为非法与不痴毗尼。若比丘不痴狂。而诈为痴狂。多犯不净行非沙门法。余比丘言。犯重罪波罗夷僧伽婆尸沙偷兰遮。问言汝忆犯重罪波罗夷僧伽婆尸沙偷兰遮不。彼言。我先痴狂故耳。如人从高坠下揽少草木。诸长老。莫为难诘问我。而诸比丘故难诘不止。彼从僧乞不痴毗尼。若僧与不痴毗尼。是为非法与不痴毗尼。是为三非法与不痴毗尼。复有三种如法与不痴毗尼。若比丘狂痴故。多犯不净行非沙门法。彼后还得心。余比丘言。汝犯如是重罪波罗夷僧伽婆尸沙偷兰遮忆不。彼言。我先痴狂故。多犯不净行非沙门法。非我故作。是狂故耳。诸长老。莫为难诘问我。而诸比丘故难诘不止。彼痴狂止。从僧乞不痴毗尼。若僧与不痴毗尼。是为如法与不痴毗尼。若比丘狂痴故。多犯不净行非沙门法。彼后还得心。余比丘言。汝犯如是重罪波罗夷僧伽婆尸沙偷兰遮忆不。彼言。我先狂痴故。多犯不净行非沙门法。非我故作。是痴狂故耳。如人忆梦中所作。诸长老。莫为难诘问我。而诸比丘故难诘不止。彼从僧乞不痴毗尼。僧若与不痴毗尼。是为如法与不痴毗尼。若比丘狂痴故。多犯不净行非沙门法。余比丘言。汝犯重罪波罗夷僧伽婆尸沙偷兰遮忆不。彼言我先狂痴故。多犯不净行非沙门法。非我故作。是狂痴耳。我忆如人从高坠下揽少草木。诸长老。莫为难诘问我。而诸比丘故难诘不止。彼从僧乞不痴毗尼。若僧与不痴毗尼。是为如法与不痴毗尼。是为三如法与不痴毗尼。有三种调法。呵责摈出依止。是为三种调法。有三灭法。用多人语罪处所草覆地。是为三灭法。复有三法。应唤比丘着现前已作白然后作三羯磨。我说是如法得处所羯磨成就。若比丘喜斗诤。僧应与作三种羯磨。若呵责羯磨若摈羯磨若依止羯磨。佛说如是。诸比丘闻欢喜。信乐受持

尔时佛告诸比丘。有三法不应与受大戒。一破戒二破见三破威仪。有如是三法。不应与受大戒。有三法应与受大戒。不破戒不破见不破威仪。有如是三法。应与受大戒。比丘有三法。僧应与作呵责羯磨。破戒破见破威仪。有如是三法。僧应与作呵责羯磨。若摈羯磨依止羯磨遮不至白衣家羯磨举羯磨亦如是。被举人有三法。不应为解羯磨。应见不见应忏不忏应舍不舍。有如是三法。不应为解羯磨。被举者有三法。应为解羯磨。应见而见应忏而忏应舍而舍。有是三法。应为解羯磨。被举人有三法。不应为解羯磨。应见不见应忏不忏应信不信。有如是三法。不应为解羯磨。被举人有三法。应为解羯磨。应见而见应忏而忏应信而信。有如是三法。应为解羯磨。比丘有三法。应与作遮不至白衣家羯磨。在白衣前毁訾佛法僧。有如是三法。应与作遮不至白衣家羯磨。与比丘作遮不至白衣家羯磨时。应以三法量宜。称量比丘称量白衣称量事。有三法。称量比丘称量白衣称量羯磨。有三法。称量比丘称量白衣称量犯。复有三法。实不实。作不作。应与作遮不至白衣家羯磨。不应与作遮不至白衣家羯磨。是为与比丘三事量宜作遮不至白衣家羯磨。复有三法。作呵责羯磨。非法非毗尼羯磨不成不得处所。何等三。不作举不作忆念不作自言。是为三。复有三法。不犯。犯不可忏罪。若已忏罪。是为三。复有三。不作举非法别众。复有三。不作忆念非法别众。复有三。不作自言非法别众。复有三。不犯非法别众。复有三。犯不可忏罪非法别众。复有三。犯罪已忏非法别众。复有三。不现前非法别众。有如是三法作呵责。非法非毗尼羯磨不成不得处所。有三法作呵责。如法如毗尼羯磨成就得处所。(即反上句是不复烦文。故不出耳)有三事弄失精。犯僧伽婆尸沙。若忆念若弄若失不净。有如是三事。犯僧伽婆尸沙。复有三事。若忆念若弄。若欲出青色不净若失青不净。僧伽婆尸沙。若忆念若弄。若欲出青不净。乃出黄不净。若赤若白若黑若酪色若酪浆色不净者。僧伽婆尸沙。若忆念若弄。乃至欲出酪浆色不净若出。僧伽婆尸沙。若忆念若弄。欲出酪浆色不净。乃出青黄赤白黑不净。僧伽婆尸沙。如是为乐故。为药故。为试出故。为福德故。为祀天故。为善道故。为施故。为种子故。为憍恣故。为试力故。为颜色故。为轻慢故。一切僧伽婆尸沙。于内色亦如是。于外色亦如是。于内外色亦如是。若于水若风若虚空亦如是。有三种人犯。不癫狂不错乱不痛恼。是为三种人犯。有三种人不犯。若颠狂错乱痛恼。是为三种人不犯。有于三种众生。行淫犯波罗夷。人非人畜生。是为于三种众生行淫波罗夷。复有三种。妇女童女二根。复有三。妇女童女黄门。复有三。妇女童女男子。复有三。男子二根黄门。复于三种妇女行淫犯波罗夷。人妇女非人妇女畜生妇女。童女亦如是。二根亦如是。黄门亦如是。男子亦如是。人妇女三处行淫波罗夷。大小便道口中。非人妇女畜生妇女。人童女非人童女畜生童女。人二根非人二根畜生二根亦如是。有三种作盗。犯波罗夷。若自取。若现前指示取。若遣使取。复有三。不作己有想取。不暂取。非亲厚取。复有三。若他物。若他物想。若举离本处。有三种断命波罗夷。若人作人想若以身。若以口断命。是为三种断命波罗夷。有三种断人命。不犯波罗夷。人作非人想。若以身若以口断命。是为三种断人命不犯波罗夷。有三种自称得上人法波罗夷。不得言得。不入言入。不证言证。是为三种。复有三种。身犯口犯身口犯。是为三(此中三犯。更复有四句异名。一句言三种相。二句言三种咒。三句言三非威仪。四句言三邪命)复有三。贪恚痴。是为三。复有三。身欲口欲身口欲。是为三。复有三。身恚口恚身口恚。是为三。复有三。身痴口痴身口痴。是为三。复有三。身欲害口欲害身口欲害。是为三。恚痴亦如是。有三种人犯。一僧二众多人三一人。有三种人忏悔。若僧若众多人若一人。有三种人应受忏悔。若僧若众多人若一人。有三种人犯尼萨耆。若僧若众多人若一人。犯尼萨耆应在三种人前舍。若僧若众多人若一人。有三种人应受尼萨耆。若僧若众多人若一人。有三种默然。有知而默然。有不知而默然。有痴而默然。有三种住。戒住见住羯磨住。复有三。戒住见住威仪住。复有三。戒住见住命住。复有三种人诤。若僧若众多人若一人。有三种人起诤。若僧若众多人若一人。有三种人舍诤。若僧若众多人若一人。应三种人前舍。若僧若众多人若一人。有三种人灭诤。若僧若众多人若一人。有三种人应灭诤。若僧若众多人若一人。有三种人得灭诤。若僧若众多人若一人。比丘有三种正语。应语比丘。破戒破见破威仪。举他比丘。应以三事。若见若闻若疑。有三种覆。覆破戒覆破见覆破威仪。有三种发露。破戒破见破威仪。有三种忏悔。破戒破见破威仪。有三种放逸羯磨。破戒羯磨破见羯磨破威仪羯磨。有三学。增戒学增心学增慧学。是为三学。复有三学。威仪学净行学波罗提木叉学。是为三学。尔时有众多比丘。往世尊所头面礼足却坐一面。白世尊言。大德。是法之主。说言学。云何为学。佛告诸比丘。学于戒故言学。云何学戒。增戒学增心学增慧学。是故言学。彼增戒学增心学增慧学时。得调伏贪欲嗔恚愚痴尽。彼得贪欲嗔痴尽已。不造不善不近诸恶。是故言学。佛说如是。诸比丘闻。欢喜信乐受持。尔时佛问诸比丘。汝云何学。云何为学。诸比丘白佛言。大德。是法之根本为法之主。如世尊向所说。我等受持故言学。复有三学。增戒学增心学增慧学。学此三学。得须陀洹斯陀含阿那含阿罗汉果。是故当勤精进学此三学

尔时阿难在波罗梨子城鸡园中。时有孔雀冠婆罗门。至阿难所。问讯已在一面坐。白阿难言。沙门瞿昙。何故为诸比丘制增戒学增净行学增波罗提木叉学。阿难答言。所以尔者。为调伏贪欲嗔恚愚痴令尽故。世尊为诸比丘制戒。复问言。若比丘得阿罗汉漏尽。彼何所学。阿难答言。贪欲嗔恚愚痴尽。不造不善。不近诸恶。所作已办。名为无学。婆罗门言。如向所说便为无学耶。阿难答言如是。阿难说如是。孔雀冠婆罗门闻已。欢喜信乐受持

尔时世尊。在摩竭国崩伽弥村中。为诸比丘。无数方便说戒法。时有旧住比丘。于迦叶姓中出家。此比丘闻世尊说法。不生信乐愁忧不乐。世尊数恐我等。于是世尊。移往王舍城。去未久。彼迦叶比丘心自悔恨。我无利不善得。世尊为诸比丘无数方便说戒。而我不生信乐。愁忧不乐而言。世尊数恐我等。我今宁可于世尊前至诚悔过耶。时彼比丘。即持衣钵。往王舍城。到世尊所。头面礼足却坐一面。以此因缘具白世尊。从坐起头面礼足至诚悔过言。大德。我愚痴无智不善。而世尊为诸比丘无数方便说戒法。而我生不信乐心。怀忧恼言。世尊数恐我等。唯愿大德。受我悔过。佛告比丘言。汝自忏悔愚痴无智不善。我为诸比丘说戒。汝自不信乐。心怀忧恼言。世尊数恐我等。于我法中。能至诚如法忏悔者。便得增益。汝忏悔应生厌离心。汝比丘至诚如法忏悔。我为受之。时彼迦叶比丘。礼佛足已却坐一面。佛告言。若上座既不学戒亦不赞叹戒。若有余比丘乐学戒赞叹戒者。亦复不能以时劝勉赞叹迦叶比丘。我不赞叹如是上座。何以故。若我赞叹者。令诸比丘亲近。若有亲近者。令余人习学其法。若有习学其法。长夜受苦。是故迦叶比丘。我见如是上座过失故不赞叹。若中下座亦如是(此上中下座。是不如法者。其次应有上中下座如法者反上句。即是不复烦文。故不出也)佛说如是。迦叶比丘欢喜信乐受持。尔时佛告诸比丘。譬如有驴与群牛共行。自言我亦是牛我亦是牛。而驴毛不似牛脚。不似牛音声。亦不似牛。而与牛共行。自言是牛。如是有痴人。随逐如法比丘。自言我是比丘。此痴人无有增戒增心增慧。如善比丘与众僧共行。自言我是比丘。是故汝等。当勤修习增戒增心增慧学。佛说如是。诸比丘闻。欢喜信乐受持

尔时世尊在毗舍离。有跋阇子比丘。往世尊所头面礼足却坐一面。白世尊言。半月所说戒多。我不能学如是多戒。佛告言。听汝学三戒。增戒增心增慧学。若汝如是学三戒者。便得至贪欲嗔痴尽处。不造不善不近诸恶。比丘言。大德。愿乐受持。时跋阇子比丘。闻世尊略教已。独在静处。精勤而不放逸。初夜后夜警意思惟所为出家。修习不久。得无上净行现前。自知得证。我生已尽。梵行已立。所作已办。不复受生。跋阇子比丘。自知得阿罗汉。佛说如是。诸比丘闻。欢喜信乐受持。尔时佛告诸比丘。有三学。增戒学增心学增慧学。何等增戒学。若比丘尊重于戒。以戒为主。不重于定。不以定为主。不重于慧。不以慧为主。彼于此戒。若犯轻者忏悔。何以故。此中非如破器破石故。若是重戒。便应坚持。善住于戒。应亲近行。不毁阙行。不染污行。常如是修习。彼断下五使。于上涅槃。不复还此。若比丘重于戒。以戒为主。重于定以定为主。不重于慧不以慧为主如上。若比丘重于戒。以戒为主。重于定以定为主。重于慧以慧为主。彼漏尽得无漏心解脱慧解脱。于现在前自知得证。我生已尽梵行已立所作已办不复还此。满足行者。具满成就。不满足行者。得不满足成就。我说此戒无有唐捐。佛说如是。诸比丘闻。欢喜信乐受持。复有三学。增戒增心增慧学。何等增戒学。若有比丘。具满戒行。少行定行少行慧行。彼断下五使。便于上涅槃。不复还此。若不能至如是处。能薄三结。贪欲嗔恚愚痴。得斯陀含。来生世间。便尽苦际。若不能至如是处。能断三结得须陀洹。不堕恶趣。决定取道。七生天上七生人中便尽苦际。若比丘具满戒行具满定行少行慧行亦如上。若比丘具满戒行具满定行具满慧行亦如上。复有三学。增戒学增心学增慧学。何等增戒学。若比丘具足持波罗提木叉戒。成就威仪畏慎轻戒。重若金刚。等学诸戒。是为增戒学。何等增心学。若比丘能舍欲恶。乃至得入第四禅。是为增心学。何等增慧学。若比丘如实知苦谛知集尽道。是为增慧学。复有三学。增戒增心增慧学。增戒增心如上。增慧学者。若比丘知内有贪欲如实知之。内无贪欲如实知之。若未生贪欲如实知之。若未生贪欲后生如实知之。若已生贪欲能断如实知之。若未生贪欲不令生如实知之。嗔恚睡眠调悔疑亦如是。彼比丘作是念。我于眼色有贪欲嗔恚如实知之。无贪欲嗔恚如实知之。于眼色未生贪欲嗔恚不生如实知之。如于眼色未生贪欲嗔恚而生如实知之。如于眼色已生贪欲嗔恚断灭如实知之。如于眼色已断贪欲嗔恚后不复生如实知之。耳鼻舌身意亦如是。复次比丘。内有念觉意如实知之。内无念觉意如实知之。如未生念觉意不生如实知之。如未生念觉意而生如实知之。如已生念觉意修习满足如实知之。如是法觉意精进觉意猗觉意定觉意喜觉意护觉意亦如是。复有三聚。持戒聚定聚慧聚。毗尼有三答。我如是见如是闻如是忍。比丘有三法灭正法。非制而制。是制便断。不随所制而行。比丘复有三法不灭正法。(即反上句是)有三处具满妄语。前知欲作妄语。妄语时知是妄语。妄语竟知作妄语。复有三种具足实语(即反上句是)有三种使。一使二增使三减使。云何为使。若使能受教不增不减随所闻而说。是为使。云何增使。若使受教增益过说。是为增使。云何减使。若使受教不具足说。是为减使。复有三子。等子增子不等子。云何等子。若父母有信戒施慧。子亦有信戒施慧。是为等子。云何增子。若父母无有信戒施慧。而子有信戒施慧。是为增子。云何不等子。若父母有信戒施慧。而子无信戒施慧。是为不等子。而说偈言

  等子及增子　　应求如是子
  勿求不等子　　在家无增益
  彼子常如法　　善行优婆塞
  成就持信戒　　布施不悭嫉
  如月无云翳　　在众亦如是

复有三病。或有病若得随意食若不得。若得随病药若不得。若得随意好瞻病人若不得。病人俱死。不能从病得差。或有病人如是。或有病人。若得随意食若不得。若得随病药若不得。若得随意好瞻病人若不得。此病人不死。从病得差。或有病人如是。或有病人。不得随意食。不得随意病药。不得随意好瞻病人。此病人死。不能从病得差。若得随意食。得随病药。得好瞻病人。彼病者不死。从病得差。或有病人如是。是中病人。不得随意食。不得随病药。不得随意好瞻病人。此病人死。不能从病得差。若得随意食。得随病药。得随意好瞻病人。此病人不死。从病得差。我为是故。听与病者随意食随病药好瞻病人。以此病因缘故。余病人亦应与瞻视供养。有三种痴。一犯罪二不见罪三见罪不如法忏悔。是为三种痴。有三种智慧。一不犯罪二犯罪能见三见罪能忏悔。有三种痴。一犯罪不见二见犯罪不忏悔三不如法忏悔。彼不受有三种智慧(即反上句是)有三种安居。前安居中安居后安居。于圣法律中。歌戏犹如哭。舞如狂者。戏笑似小儿。有三种不净肉不应食。若见闻疑为己作。有三种净肉应食。不见闻疑不为己作。有三种布萨。十四日十五日月初日。有三种人布萨。若僧若众多人若一人。有三种人作布萨。若僧若众多人若一人。有三种人应作布萨。若僧若众多人若一人。或知而作。或不知而作。或见而作。或知而作。或不知而作。或痴而作。或身或口或身口。俱有三种。应平断犯罪。一戒序二制三重制。有三法。平断不犯。戒序制重制。有三种净有三种不净有三种听有三种不听亦如是。有三种不恭敬。佛法僧。复有三种不恭敬。佛法戒。有三不恭敬。佛法定。复有三不恭敬。佛法父母。有三不恭敬。佛法善法。恭敬有三。三句(即反上句是)复有三种举。一不见二不忏悔三恶见不舍。有三法。僧应作覆钵。在比丘前谤毁佛法僧。复有三念。佛念法念僧念。复有三念。佛念法念戒念。复有三念。佛念法念施念。复有三念。佛念法念天念。复有三成就。持戒成就定成就慧成就。复有三。戒成就定成就解脱成就。复有三。戒成就定成就见解脱慧成就。复有三贱法。刀贱衣贱色贱。复有三坏色。青黑木兰。复有三法名持律。持波罗提木叉戒具足多闻诵二部戒通利无疑。复有三持。波罗提木叉戒具足多闻广诵毗尼通利无疑。复有三持。波罗提木叉戒具足多闻住毗尼中不动。复有三持。波罗提木叉戒具足多闻善巧方便能灭诤事。复有三办。比丘办不放逸办清净行办。复有三种自恣。十四日十五日月初日。复有三种人自恣。若僧若众多人若一人。复有三种作自恣。若僧若众多人若一人。复有三种人。应作自恣。若僧若众多人若一人。复有三种。若知若不知若见。复有三种。若知若不知若痴。复有三种。若身若口若身口俱。复有三种。若见闻疑。复有三语舍戒。舍佛舍法舍僧。如是三三为句。乃至非沙门释子。复有三种义故。如来出世。为诸比丘制戒。从摄取于僧三三为句。乃至正法久住。有三种义故。如来出世。为诸比丘制呵责羯磨。从摄取于僧三三为句乃至正法久住亦如是。从呵责乃至七灭诤亦如是

尔时世尊。在婆阇国地城中。告诸比丘。我说四种广说。汝等善听。当为汝说。诸比丘言。大德。愿乐闻之。何等四。若比丘如是语。诸长老。我于某村某城亲从佛闻受持。此是法是毗尼是佛教。若闻彼比丘说。不应便生嫌疑。亦不应呵。应审定文句已应寻究修多罗毗尼检校法律。若听彼比丘说。寻究修多罗毗尼检校法律时。若不与修多罗毗尼法律相应。违背于法。应语彼比丘。汝所说者非佛所说。或是长老不审得佛语。何以故。我寻究修多罗毗尼法律。不与修多罗毗尼法律相应。违背于法。长老不须复诵习。亦莫教余比丘。今应舍弃。若闻彼比丘说。寻究修多罗毗尼法律时。若与修多罗毗尼法律相应。应语彼比丘言。长老所说。是佛所说。审得佛语。何以故。我寻究修多罗毗尼法律。与共相应。而不违背。长老。应善持诵习教余比丘。勿令忘失。此是初广说。复次若比丘如是语。长老。我于某村某城和合僧中上座前闻。此是法是毗尼是佛所教。闻彼比丘说时。不应嫌疑亦不应呵。应审定文句寻究修多罗毗尼检校法律。若闻彼比丘说。寻究修多罗毗尼法律时。不与相应违背于法。应语彼比丘言。长老。此非佛所说。是彼众僧及上座。不审得佛语。长老亦尔。何以故。我寻究修多罗毗尼法律。不与相应违背于法。长老。不须复诵习。亦莫教余比丘。今当弃之。若闻彼比丘语。寻究修多罗毗尼法律与相应不违背于法。应语彼比丘言。长老。是佛所说。彼众僧上座及长老亦审得佛语。何以故。我寻究修多罗毗尼法律。而与相应无有违背。长老。应善持诵习亦教余人。勿令忘失。此是第二广说(次第三句。从知法毗尼摩夷众多比丘所闻亦如是。第四句从知法毗尼摩夷一比丘所闻亦如是)是为四广说。佛说如是。诸比丘闻。信乐欢喜受持

尔时佛告诸比丘众。僧有四种断事人。何等四或有寡闻无惭。或有多闻无惭。或有寡闻有惭。或有多闻有惭。是中断事比丘。寡闻无惭者。在僧中言说断事。僧应种种苦切呵责。令无惭者后更不尔。若彼断事人多闻无惭者。在僧中言说断事。僧应种种苦切呵责。令彼无惭者后更不尔。是中断事比丘有惭寡闻者。在僧中言说断事。僧不应苦切呵责。应佐助开示。令彼有惭者后于僧中言说断事。是中断事比丘有惭多闻者。在僧中言说断事。僧不应呵责。听彼说已。应赞其善哉。令有惭者后于僧中言说断事。复有四断事比丘。或无惭不谙经文。或无惭谙经文。或有惭不谙经文。或有惭谙经文。无惭不谙经文者。有三失。彼无惭失可呵失不谙经文失。是为断事人三失。无惭谙经文者。有二失。无惭失可呵失。彼谙经文不失。是为断事比丘二失。有惭不谙经文者。有一失。彼不谙经文失。彼有惭不失无可呵不失。是为断事比丘一失。有惭谙经文者无失。彼有惭不失无有可呵不失谙经文复无失。是为断事比丘第一最胜无失。破戒四句亦如是。破见四句亦如是。破正命四句亦如是。破威仪四句亦如是(此中羁连。有四比丘。分物四分。如房舍揵度中。法不异故不出也)

尔时佛在王舍城。时优波离。从坐起偏露右肩右膝着地。合掌白佛言。大德。说言破僧。齐几名为破僧。谁破和合僧。佛告优波离。若有比丘。犯彼言不犯。若不犯彼言犯。轻言重重言轻。若比丘于此四事便求索伴若使人求。于界内别部布萨羯磨说戒。齐是名为破僧。是为破和合僧。优波离复问。云何和合僧。僧破已。谁为和合。佛告优波离。若有比丘。犯彼言犯。若不犯彼言不犯。轻言轻重言重。彼比丘于此四事不求伴不使人求。不别部羯磨布萨说戒。齐是名为和合僧。是为僧破已还和合

尔时世尊在舍卫国。时舍卫比丘共斗诤。阿尼楼陀。有弟子字婆夷。独于僧中语。独当诤事。时阿尼楼陀在众。不说一语教呵。尔时阿难往世尊所。头面礼足在一面住。世尊知而故问阿难。诤事已灭未。阿难答言。诤事何可得灭。阿尼楼陀弟子。在僧中独语独当诤事。而阿尼楼陀在僧中。曾不以一语呵责。佛告阿难。阿尼楼陀何时能灭此诤事。岂非汝舍利弗目连事耶。尔时佛告诸比丘。恶比丘有四法。见僧破欢喜。何等四。是恶比丘破戒恶法。彼恶比丘作是念。我破戒恶法。若余比丘得知我。和合为我作灭摈。有余比丘助我作伴。恶比丘有是初法。见僧破欢喜。复次恶比丘邪命自活。作是念言。我邪命自活。令余比丘知我。和合僧为我作灭摈。有余比丘助我为伴。是为恶比丘第二见僧破欢喜。复次恶比丘多求利养恭敬。作是念。我求利养恭敬。令余比丘知我。和合僧为我作灭摈。有余比丘助我为伴。是为恶比丘第三见僧破欢喜。复次恶比丘邪见边见。作是念。我邪见边见。令余比丘知我。和合僧为我作灭摈。有余比丘助我为伴。是为恶比丘第四见僧破欢喜。有四种作法。前非法作后非法作。前非法作后法作。前法作后非法作。前法作后法作。何等前非法作后非法作。前非法起事。应教呵。不教呵而住。应灭摈。不灭摈而住。是为前非法作后非法作。何等前非法作后法作。若有非法作者。前非法起事。彼应教呵者呵而后住。应灭摈灭摈而后住。是为前非法作后法作。何等前法作后非法作。若比丘如法起事。应教呵不教呵而住。应灭摈不灭摈而住。是为前如法作后非法作。何等前如法作后如法作。若比丘前如法起事。应教呵而教呵。应灭摈而灭摈而后住。是为前如法作后如法作。有四种供养。一饮食二医药三衣服四是所须者与复有四种利法。非法求非法与。非法求法与。法求非法与。法求法与。云何非法求非法与。或有比丘。周旋往反不作沙门法。说非法求利养不净。彼作如是不净求利养。有所偏为。取是。莫取是。取尔许。莫取尔许。取是来。莫取是来。持尔许来。莫持尔许来。与此。莫与彼。与尔许。莫与尔许。彼可与。彼不可与。是为非法求利养非法与。云何非法求法与。或有比丘。周旋往反作非沙门法。说非法求利养不清净。不作如上偏为。是为非法求法与。云何法求非法与。或有比丘。周旋往反说沙门法。不作非法。求利养清净。作如上偏为。是为法求非法与。云何法求法与。或有比丘。周旋往反说沙门法。不作非法。求利养清净。不作如上偏为。是为法求法与。有四法不应为他受大戒。不知增戒增心增慧学不广诵二部戒。有如是四法。不应与他受大戒。有四法应为他受大戒(即反上句是)

有四法不应为他受大戒。不知增戒学。不知增心学。不知增慧学。不广诵毗尼。如是四法。不应为他受大戒。复有四法应为他受大戒。(即反上句是)复有四法。不应为他受大戒。不知增戒增心增慧学。虽诵毗尼不能决了。如是四法。不应为他受大戒。复有四法。应为他受大戒(即反上句是)复有四法。不应为他受大戒。不持二百五十戒。不多闻。若弟子有恶见不能教化弟子令舍恶见修习善见。不满十岁。有如是四法。不应为他受大戒。复有四法。应为他受大戒(即反上句是)有四法名为持律。知犯知不犯知轻知重。复有四法。知犯知不犯知有余知无余。复有四法。知犯知不犯知粗恶知不粗恶。复有四法。知可忏罪知不可忏罪知忏悔清净知忏悔不清净。复有四诤。言诤觅诤犯诤事诤。有四犯畏。若有如是男子来。被发着黑衣持刀。至大众中。作如是言。我作极大重恶断头罪。随汝等所喜我当作。时诸大众。即捉缚打恶声鼓。为现死相。顺路唱令。从右门出。至杀处杀之。智人见已。作如是语。此人造恶极重死罪。我今当自敕并教余人。莫作如是重恶死罪。如是比丘比丘尼。于波罗夷法生大恐畏。作如是念。若未犯波罗夷终已不犯。若犯都无覆藏心如法忏悔。此是第一犯畏。有如是男子。被发着黑衣持合鞘刀。至大众中言。我作恶不善。随众人所喜我当作。时彼众人。即夺取刀。打之驱出右门。有智人见作如是言。此人作恶罪。我今当自敕并教人。莫作如是恶罪。如是比丘比丘尼。于僧残法生大恐畏。作如是念。若未犯僧残终不犯。若犯寻即忏悔。此是第二犯畏。有如是男子。被发着黑衣持杖。至大众中语言。我作恶不善。随众人所喜我当作。众人即取其杖打之。驱出右门。有智人见作如是言。此人作恶罪。我今自敕并教人。不作如是恶。如是比丘比丘尼。于波逸提生大恐畏。未犯终不犯。若犯寻即忏悔。此是第三犯畏。有如是男子。被发着黑衣至众人所。合掌作如是言。我作恶不善。随众人所喜我当作之。时众人种种呵责驱出右门。有智人见作如是言。此人作如是恶。我今当自敕并教人。不作如是恶。如是比丘比丘尼。于波罗提提舍尼生恐畏。若未犯终不犯。若犯寻即忏悔。此是第四犯畏。有四种犯人。若比丘犯罪。余比丘语言。汝犯罪见不。彼言不见。比丘复语言。长老。若见罪当忏悔。此是第一犯人。若比丘犯罪。余比丘语言。长老。汝犯罪见不。彼言不见。比丘复语言。长老。若见罪应僧中忏悔。此是第二犯人。若比丘犯罪。余比丘语言。长老。犯罪见不。彼言不见。比丘复语言。若长老见罪。当于此僧中忏悔。此是第三犯人。若比丘犯罪。余比丘语言。长老汝犯罪见不。彼言不见。时僧应都舍弃。语如是言。随汝意去所至之处。欲举汝者。彼当为汝作举作忆念作自言。遮汝阿[少/兔]婆陀遮说戒遮自恣。如调马师恶马难调即合缰杙驱弃。此比丘亦复如是。一切舍弃。是为第四犯人

尔时世尊。在王舍城耆阇崛山。优波离。从坐起偏露右肩右膝着地。合掌白佛言。长老在年少比丘前忏悔。内有几法应忏悔。佛言。内有四法应忏悔。偏露右肩脱革屣胡跪合掌说所犯名。我犯某甲罪。今于长老前忏悔。彼应语言。应改悔生厌离心。答言尔。上座比丘于下座比丘。有如是四法应忏悔。有四波罗提提舍尼如上说。四波罗夷如上说。有四羯磨。非法别众羯磨。非法和合众羯磨。法别众羯磨。法和合众羯磨。是为四羯磨。是中非法别众羯磨不应尔。非法和合羯磨不应尔。法别众羯磨不应尔。法和合羯磨应尔。是我所听。非法别众羯磨。羯磨不成。非法和合众羯磨。羯磨不成。法别众羯磨。羯磨不成。法和合羯磨。羯磨成就。非法别众羯磨。不得处所。非法和合众羯磨。不得处所。法别众羯磨。不得处所。法和合羯磨。得处所。有四种布萨。三语布萨。清净布萨。说波罗提木叉布萨。自恣布萨。有四妄语。波罗夷妄语。僧残妄语。波逸提妄语。毗尼阿毗婆罗妄语。有四众。比丘众比丘尼众优婆塞众优婆夷众。复有四众。刹利众婆罗门众居士众沙门众。复有四众。四天王众忉利天众魔众梵众。复有四众。爱恚怖痴众。复有四众。不爱不恚不怖不痴众。有四种智慧平断事人。有人身不现恶口现。有人口不现恶身现。有人身口现恶。有人身口不现恶。云何身不现恶口现。或有人身不现恶口言指授与共同见。是为身不现恶口现。云何口不现恶身现。有人身现恶口不指授不与同见。是为口不现恶身现。云何身不现恶口不现恶。有人身不现恶口不指授不与同见。是为身口不现恶。云何身口现恶。有人身现恶口语指授与同见。是为身现恶口现恶。是为四种有智平断事人。比丘有四法。自损有犯。为有智者所责。令得多罪。何等四。有爱有恚有怖有痴。比丘有是四法。而自损。为有智者所责。令得多罪。比丘有四法。不自损(反上句是)有四法趣非道。有爱有恚有怖有痴。是为四。有四法不趣非道。(即反上句是)有四法。不应差作分粥人。未差不应差。若已差不应分。有爱有恚有怖有痴。有四法。应差作分粥人。(即反上句是)分小食分佉阇尼食。差会若敷卧具分卧具分雨浴衣分衣取与差比丘使乃至差沙弥使亦如是。有四法。直入地狱犹若射箭(即上差诸知事者是)有四非法遮说戒。遮无根破戒破见破威仪破正命。是为四。有四如法遮说戒。遮有根破戒破见破威仪破正命。是为四如法遮说戒。有四清净。持戒清净见清净威仪清净正命清净。是为四清净。有四依止法。粪扫衣乞食树下坐腐烂药。是为四依止法。有四种损法。或有智能忍。或有智能亲近。或有智能解。或有智能断。是为四种损法

四分律卷第五十八四分律卷第五十九(第四分之十)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    毗尼增一之三

尔时世尊在波罗奈。世尊知而故问阿难。我于谷贵时。慈愍诸比丘故。放舍四事。内宿内煮自煮自取食。今诸比丘故食耶。阿难白佛言。故食。佛言阿难。不应食若食如法治。佛告阿难。我以谷贵时。愍诸比丘故听此法。朝受小食。从彼持来若胡桃果等及水中可食物。如是等故食耶。阿难答言尔。佛言。不应食若食如法治。有四法作呵责羯磨。非法非毗尼羯磨不成不得处所。何等四。无根破戒破见破威仪破正命。是为四法。有四法作呵责羯磨。如法如毗尼羯磨成就得处所(即反上句是)有四大贼。何等四。或有大贼。生如是意。若得百人千人破某甲城邑。于异时得百人千人。破彼城邑。如是恶比丘作是念。我何处当得百人众千人众。于某甲城邑游行。彼于异时。得百人若千人游行彼城邑。是为第一大贼。复次有大贼。非净行自言是净行。是为第二大贼。复次有大贼。以口腹故。不真实非己有。于大众中故作妄语。自称得上人法。是为第三大贼。复有大贼。以僧华叶果蓏。以自活命。是为第四大贼。有四信法。若比丘于城廓村落。作多不净行非沙门法。是中应随顺教授居士令信。彼比丘语此比丘言。汝于某甲城邑村落。多作不净行非沙门法。汝当还教化彼居士令信。若汝不能随顺教化居士令信者。汝不得在此住。若能随顺教化居士者。听汝在此住。若复不能随顺教化居士令信者。诸比丘不与汝同羯磨说戒自恣共住同一坐。于小食大食上不以次坐。亦无迎逆执手礼拜问讯若汝能随顺教化彼居士令信者。当与汝同羯磨乃至礼拜问讯。是为四信法。若居士居士儿亦如是。有四非圣法。不见言见。不闻言闻。不触言触。不知言知。是为四非圣法。有四圣法(即反上句是)有四非圣法见言不见。闻言不闻。触言不触。知言不知。是为四非圣法。有四圣法(即反上句是)有四语舍戒。舍佛舍法舍僧舍和尚。是为四语舍戒。如是舍佛法僧为首。乃至非沙门释子。四四为句亦如是。以四利义故。如来出世。为诸比丘制戒。摄取于僧乃至正法久住。四四为句亦如是。有四利义故。如来出世。为诸比丘制呵责羯磨。摄取于僧乃至正法久住(四四为句亦如是)乃至七灭诤亦如是

尔时世尊在王舍城。告诸比丘。有五法不应授人大戒。若无戒无定无慧无解脱慧无见解脱慧。有是五法。不应授人大戒。复有五法。应授人大戒(即反上句是)复有五法。不应授人大戒。自无戒无定无慧无解脱慧无见解脱慧。亦不能教人令住戒定慧乃至见解脱慧。有是五法。不应授人大戒。有五法应授人大戒(即反上句是)复有五法。不应授人大戒。不信无惭无愧懈怠多忘。有如是五法。不应授人大戒。有五法应授人大戒(即反上句是)复有五法。不应授人大戒。不知增戒增心增慧学不知白不知羯磨。有是五法。不应授人大戒。有五法应授人大戒(即反上句是)复有五法。不应授人大戒。不知威仪戒。不知增净行。不知波罗提木叉戒。不知白。不知羯磨。有是五法。不应授人大戒。有五法应授人大戒(即反上句是)复有五法。不应授人大戒。不知犯。不知犯已忏悔。不知犯已忏悔清净。不知白。不知羯磨。有是五法。不应授人大戒。有五法应授人大戒(即反上句是)复有五法。不应授人大戒。不知有难法。不知无难法。不知白。不知羯磨。不满十岁。有是五法。不应授人大戒。有五法应授人大戒(即反上句是)复有五法。不应授人大戒。不能教人增戒学增心学增慧学。不能作瞻病人。亦不能与瞻病人。若差若乃至死。若不满十岁。有是五法。不应授人大戒。有五法应授人大戒(即反上句是)复有五法。不应授人大戒。不能教弟子增威仪戒增净行增波罗提木叉戒。若弟子有恶见不能方便教令舍恶见住善见。若不满十岁。有是五法。不应授人大戒。有五法应授人大戒(即反上句是)复有五法。不应授人大戒。不知犯不知不犯不知轻不知重不广诵二部毗尼。有是五法。不应授人大戒。有五法应授人大戒(即反上句是)复有五法。不应授人大戒。不具持波罗提木叉戒。不多闻。不能教弟子毗尼阿毗昙。不满十岁。有是五法。不应授人大戒。有五法应授人大戒(即反上句是)复有五法。不应授人大戒。不具持波罗提木叉戒。不能教弟子毗尼阿毗昙。若弟子有恶见不能教令舍恶见住善见。有是五法。不应授人大戒。有五法应授人大戒(即反上句是)复有五法。不应授人大戒。不能教弟子毗尼阿毗昙。若弟子有恶见不能教令舍恶见住善见。若弟子不乐所住处不能移至乐处。若弟子有疑悔心生不能如佛法开解。有是五法。不应授人大戒。有五法应授人大戒(即反上句是)复有五法。不应授人大戒。不能教弟子毗尼阿毗昙。若弟子有恶见不能教舍恶见令住善见。若不乐所住处不能移至乐处。若不满十岁。有是五法。不应授人大戒。有五法应授人大戒(即反上句是)复有五法。不应授人大戒。不知波罗提木叉戒。亦不能说。不知布萨。不知布萨羯磨。不满十岁。有是五法。不应授人大戒。有五法。应授人大戒(即反上句是)复有五法。不应授人大戒。不善知犯。不善知犯忏悔。不善入定。不善出定。不满十岁。有是五法。不应授人大戒。有五法应授人大戒(即反上句是)复有五法。不应授人大戒不知犯。不知不犯不知轻不知重。不满十岁。有是五法。不应授人大戒。有五法应授人大戒(即反上句是)复有五法。不应授人大戒。不具持波罗提木叉戒。不多闻。不能教弟子增戒学。不能瞻病。不能与瞻病人若差乃至死。不广诵二部毗尼。有是五法不应授人大戒。有五法应授人大戒(即反上句是)复有五法。不应授人大戒。不具持波罗提木叉戒。不多闻。不能教弟子增戒学。若弟子有恶见。不能教弟子舍恶见令住善见。不善诵毗尼。有是五法。不应授人大戒。有五法应授人大戒(即反上句是)复有五法。不应授人大戒。不具持波罗提木叉戒。不多闻。不能教弟子增戒学。若弟子不乐所住处不能移至乐处。不坚住毗尼。有是五法。不应授人大戒。有五法应授人大戒(即反上句是)复有五法。不应授人大戒。不具持二百五十戒。不多闻。不能教弟子增戒学。弟子有疑不能如佛法解释。不能决断诤事。有是五法。不应授人大戒。有五法应授人大戒(即反上句是)如是增心学。增慧学。增威仪学。增净行学。增波罗提木叉学(如是五五为句如上)若比丘调顺无畏堪能语言。自有此事亦能教弟子。如是人应授人大戒。应与他依止。应畜沙弥。应授差教授比丘尼。若已差应教授。有五种人不得受大戒。自言犯边罪犯比丘尼若贼心受戒破内外道黄门。有是五法。是人不应受大戒。复有五种人。不应受大戒。杀父杀母杀阿罗汉破僧恶心出佛身血。有是五法。不应受大戒。有五种黄门。生黄门形残黄门妒黄门变黄门半月黄门。是为五种黄门。有五种病人。不应受大戒。癞若痈疽白癞干枯癫狂。如是五种病人。不应受大戒。有五种清净无难。应受大戒。是丈夫不负债非奴年满二十父母听。如是五清净无难。应受大戒。有五法与人依止。若言能若言可若言是若言善自修行若言不放逸。是为五种与依止法。有五种与人依止法。若言善哉若言好若言起若言去若言与依止。是为五种与依止。有五法不应无依止而住。无戒无定无慧无解脱慧无见解脱慧。有是五法。不应无依止而住。有五法应无依止而住(即反上句是)复有五法。不应无依止而住。若无戒又不能自勤修学戒。无定无慧无解脱慧无见解脱慧。又不能自勤修戒定慧解脱慧见解脱慧。有是五法。不应无依止而住。有五法应无依止而住(即反上句是)复有五法。不应无依止而住。不具持二百五十戒。不多闻。不能自学毗尼阿毗昙。若恶见心生不能开解习善见。有是五法。不应无依止而住。有五法应无依止而住(即反上句是)复有五法。不应无依止而住。不具持二百五十戒。不多闻。不能学毗尼阿毗昙。不满五岁。有是五法。不应无依止而住。有五法应无依止而住(即反上句是)复有五法。不应无依止而住。不能自学毗尼阿毗昙。恶见生不能舍住善见。若不乐所住处不能移至乐处有疑悔心生不能如法开解。有是五法。不应无依止而住。有五法得无依止而住(即反上句是)复有五法。不应无依止而住。不能自勤修增戒增心增慧学。有病不能自将养。亦不能令他为己瞻病。年不满五岁。有是五法不应无依止而住。有五法得无依止而住(即反上句是)复有五法。不应无依止而住。不能自勤修威仪戒。不能增净行增波罗提木叉戒。有恶见不能舍而住善见。年不满五岁。有是五法。不应无依止而住。有五法得无依止而住(即反上句是)复有五法。不应无依止而住。不知诤不知诤起不知诤灭不知向灭诤年不满五岁。有是五法。不应无依止而住。有五法得无依止而住(即反上句是)复有五法。不应无依止而住。不知犯不知忏悔。不善入定不善出定。年不满五岁。有是五法。不应无依止而住。有五法得无依止而住(即反上句是)复有五法。不应无依止而住。不知犯不知不犯不知轻不知重不广诵二部毗尼。有是五法不应无依止而住。有五法得无依止而住。(即反上句是)复有五法失依止。若驱出若去若休道若休不与依止若至戒场上。有是五法失依止。复有五法失依止。若死若去若休道若休不与依止若五岁若过五岁。有是五法失依止。复有五法失依止。若死若去。若休道若休不与依止若见本和尚。有是五法失依止。复有五法失依止。若死若去若休道若休不与依止若和尚阿阇梨命过。有是五法失依止。复有五法失依止。若死若去若休道若休不与依止若和尚阿阇梨休道。有是五法失依止。复有五法失依止。若死若去若休道若休不与依止若还随本和尚。有是五法失依止。有五法驱遣弟子。若和尚语弟子言。今驱汝去。汝不应入我房。汝不应复营劳我。莫复至我所。不共语。是为和尚五法驱遣弟子。阿阇梨有五法驱遣弟子。语言。今驱汝去。汝勿复入我房。不应复营劳我。不应依止我住。不共语。是为阿阇梨五法遣弟子。弟子有五法。为和尚阿阇梨驱遣。无惭无愧不可教呵非威仪不恭敬。弟子有是五法。为和尚阿阇梨所驱遣。复有五法。无惭无愧不可教呵亲恶知识数往淫女家。有是五法。为和尚阿阇梨所遣(如是喜往妇女家。大童女家。黄门家。若比丘尼间。若式叉摩那间。若沙弥尼间。捕龟鳖人间。如是等足上四事。五五为句。如淫女句。)有五种与欲。一言与欲二为我故说欲三现身相四口语五现身相口语。是为五种与欲。有五种失欲。若受欲比丘死若休道若至外道若往别部僧中若至戒场上明相出。有是五种失与欲。有五种与清净与自恣(亦如是若失亦如是)如来出世。见诸比丘有过失故。以五种利义。制护卧具法。不令风飘雨渍日曝尘坌不令鸟污。是为五。和尚有五非法。弟子应忏悔而去。应语和尚言。我如法和尚不知。我不如法亦不知。若我犯戒舍不教呵。若犯亦不知。若犯而忏悔亦不知。和尚有如是五法。弟子应忏悔而去。毗尼有五事答。一序二制三重制四修多罗五随顺修多罗。是为五。有五法名为持律。知犯知不犯知轻知重广诵二部戒。是为五。复有五法。知犯知不犯知轻知重广诵毗尼。是为五。复有五法。知犯知不犯知轻知重住毗尼而不动。是为五。复有五法。知犯知不犯知轻知重诤事起善能除灭。是为五。有五种持律。诵戒序四事十三事二不定广诵三十事。是初持律。若诵戒序四事十三事二不定三十事广诵九十事。是第二持律。若广诵戒毗尼。是第三持律。若广诵二部戒毗尼。是为第四持律。若都诵毗尼。是第五持律。是中春秋冬应依上四种持律。若不依住突吉罗。夏安居应依第五持律。若不依住者波逸提。持律人有五功德。戒品坚牢。善胜诸冤。于众中决断无畏。若有疑悔能开解。善持毗尼令正法久住。是为五。有五种贼心。黑闇心邪心曲戾心不善心常有盗他物心。是为五。复有五种贼。决定取恐怯取寄物取见便取倚托取。是为五。复有五种。与罪人同业。若教授人作贼。若复为贼先看知财物处所还示处。若为贼守物。若为贼逻道。是为五。复有五种犯。波罗夷僧伽婆尸沙波逸提波罗提提舍尼突吉罗。是为五。亦名五种制戒。亦名五犯聚。若不知不见五犯者。我说此人愚痴。波罗夷僧伽婆尸沙波逸提波罗提提舍尼突吉罗。是为五种犯五种制戒亦如是。五犯聚亦如是。若不知不见五犯波罗夷僧伽婆尸沙波逸提波罗提提舍尼突吉罗者。僧应与作呵责羯磨五种制戒亦如是。五犯聚亦如是。复有五种犯。或有犯自心念忏悔。或有犯小罪从他忏悔。或有犯中罪亦从他忏悔。或有犯重罪从他忏悔。或有罪不可忏悔。有五法。僧应与作呵责羯磨。破戒破见破威仪若毁佛及法。是为五。复有五法。破戒破见破威仪毁佛及僧。是为五。复有五。破戒破见破威仪毁法及僧。是为五法。应与作呵责羯磨。如是摈羯磨遮不至白衣家羯磨若举羯磨亦如是。有五法。作呵责羯磨。非法非毗尼羯磨不成不得处所。何等五。不作举不作忆念不作自言非法别众。是为五。复有五法。若不犯犯不可忏若犯已忏非法别众。是为五法。羯磨不成不得处所。复有五如法。羯磨成就得处所(即反上句是)被呵责羯磨人。有五事不应作(如呵责揵度中说)被举人有五法不应为解。若骂谤比丘。方便为比丘作损减无利作无住处。若在界内界外受善比丘礼拜供养。在无比丘处住。有是五法。不应为解举羯磨。复有五法。应为解举羯磨(即反上句是)若比丘被不见罪举羯磨者。应以五事自观察。若我不见罪。诸比丘不共我羯磨说戒自恣同一房宿。不共同一坐小食大食上。不随大小次第。不执手礼拜恭敬问讯。是为被不见罪举羯磨者以此五事自观察。被不忏悔羯磨恶见不舍举羯磨(亦如是)为他作不见罪举羯磨者。亦应以此五事自观察。不忏悔不舍恶见举羯磨(亦如是)比丘有五法。僧不应为作遮不至白衣家羯磨。不孝父母不敬沙门婆罗门不善受语。有是五法。不应为作遮不至白衣家羯磨。有五法。应为作遮不至白衣家羯磨(即反上句是)复有五法。应与作遮不至白衣家羯磨喜骂谤白衣方便为白衣家作损减无利益。作无住处斗乱白衣。是为五法。复有五法。在白衣前毁佛法僧骂白衣作下业若调诳白衣。是为五法。比丘有五法。令白衣不信(如上斗乱白衣句)比丘复有五法。令白衣不信(如上调诳白衣句)白衣有五法。僧不应与作覆钵。若不孝父母不敬沙门婆罗门不事比丘。是为五。白衣有五法。僧应与作覆钵(即反上句是)有五法。僧应与作覆钵。骂谤比丘为比丘作损减作无利益作无住处斗乱比丘。是为五。复有五法。于比丘前毁佛法僧以无根不净行谤比丘犯比丘尼。是为五。有五事毁訾。得波逸提罪。不以义故不以法故不以毗尼故不以教授故不以亲故。有是五事毁訾得波逸提。复有毁訾不得波逸提(即反上句是)若比丘僧。不差以五事。向未受大戒人。说他犯者。得波逸提。若说名字若种姓若相若衣若房舍。是为五事。有五处行淫犯波罗夷。妇人童女二根黄门男子。是为五。有五种盗。犯波罗夷。若自取若指示取若遣使取若重物若移本处。是为五。复有五事。若非己有想不暂取不亲厚取若重物移本处。是为五。复有五。是他有作他想若重物若作盗心若移本处。是为五。死人有五不好。一不净二臭三有恐畏四令人恐畏恶鬼得便五恶兽非人所住处。是为五。犯戒人有五过失。有身口意业不净。如彼死尸不净。我说此人亦如是。或有身口意业不净恶声流布。如彼死尸臭气从出。我说此人亦复如是。彼有身口意业不净。诸善比丘畏避。如彼死尸令人恐怖。我说此人亦复如是。有身口意业不净。令诸善比丘见之生恶心言。我云何乃见如是恶人。如人见死尸生恐畏令恶鬼得便。我说此人亦复如是。有身口意业不净者。与不善人共住。如彼死尸处恶兽非人共住。我说此人亦复如是。是为犯戒人五事过失如彼死尸。不忍辱人有五过失。一凶恶不忍二后生悔恨三多人不爱四恶声流布五死堕恶道。是为五。能忍辱人有五功德(即反上句是)向火有五过失。一令人无颜色二无力三令人眼闇四令人多闹集五多说俗事。是为五。常喜往反白衣家比丘有五过失。一不嘱比丘便入村。二在有欲意男女中坐。三独坐。四在屏处覆处坐。五无有知男子与女人说法过五六语。是为五。复有五。一数见女人。二既相见相附近。三转亲厚。四已亲厚生欲意。五已有欲意或犯死罪若次死罪。是为五。散乱心眠有五过失。若见恶梦。诸天不祐护。心不思法。不系意在明。失不净。是为五。不散乱心眠有五功德(即反上句是)饮酒有五过失。无颜色。体无力眼闇喜现嗔相。失财物。是为五。复有五事。生病益斗诤。恶名流布。智慧转少。死堕恶道。是为五。破戒有五过失。自害。为智者所呵。有恶名流布。临终时生悔恨。死堕恶道。是为五。持戒有五功德(即反上句是)复有五事。先所未得物不能得。既得不护。若随所在众若刹利众婆罗门众若居士众若比丘众于中有愧耻。无数由旬内沙门婆罗门称说其恶。破戒恶人死堕恶道。是为五。持戒有五功德(即反上句是)不嚼杨枝有五过失。口气臭。不善别味。热癊不消。不引食。眼不明。是为五。嚼杨枝有五事好(即反上句是)食粥五事好。除饥。解渴。消宿食。大小便通利。除风。是为五。经行有五事好。堪远行。能思惟。少病。消食饮。得定久住。有五种食。饭干饭糗肉鱼。有五种盐。青盐黑盐毗荼盐岚婆盐支都毗盐。是为五。复有五种盐。土盐灰盐赤盐石盐海盐。是为五。佉阇尼食有五事不应食。若非时若不净若不与若不受若不作余食法。是为五。有五事应食(即反上句是)有五种受食。身与身受。衣与衣受。曲肘与曲肘受。器与器受。有时因缘置地取。是为五。复有五。身与身受。或身与物受。或物与身受。或物与物受。或遥掷与得堕手中。是为五。有五种净果。火净刀净若疮净若鸟净若不任种净。是为五。复有五。若剥少皮若都剥若腐烂若破若瘀。是为五。有五种脂。罴脂鱼脂驴脂猪脂失首摩罗脂。是为五。有五种皮不应用。师子皮虎皮豹皮獭皮猫皮。是为五。复有五种皮。人皮毒虫皮狗皮锦文虫皮野狐皮。是为五。有五种皮不应畜。象皮马皮驼皮牛皮驴皮。是为五。复有五。羖羊皮白羊皮鹿皮熊皮伊师皮。是为五。有五种肉不应食。象肉马肉人肉狗肉毒虫兽肉。是为五。复有五。师子肉虎肉豹肉熊肉罴肉。是为五。有五种说戒。或说序已。应白僧言。余者如僧常闻。若已说戒序说四波罗夷竟。应白僧言。余者如僧常闻。说序说四波罗夷说十三僧残已。应白僧言。余者如僧常闻。说序四波罗夷僧残二不定已。应白僧言。余者如僧常闻。若广说。是为五。复有五。若说序四波罗夷竟。应白僧言。余者如僧常闻。若说序四波罗夷僧残竟。应白僧言。余者如僧常闻。若说序四波罗夷僧残二不定竟。应白僧言。余者如僧常闻。说序四波罗夷僧残二不定三十尼萨耆波逸提竟。应白僧言。余者如僧常闻。若广说。是为五。复有五。说序四波罗夷僧残竟。应白僧言。余者如僧常闻。如是一一增乃至波逸提若广说。是为五。有五法。不应差为分粥人。若已差不应分(如上房舍犍度中说)以五事因缘。受功德衣得畜。长衣离衣宿别众食展转食不嘱入村。有此五事因缘。受功德衣。受功德衣。已得五事(即反上句是)有五事因缘留僧伽梨。若有恐怖若疑有恐怖。若雨若疑当雨。若经营作僧伽梨。若浣若染。若深藏举。是为五事因缘留僧伽梨。以五事因缘留雨衣。若受界外请食。若渡水。若病。若饱食已。若经营作雨衣。若浣若染若深藏举。以此五事因缘留雨衣。夏安居竟。应作五事。自恣。应解界。应还结界。受功德衣。应分卧具。是为五。比丘有五法。不应与作亲厚。若喜斗诤。若多作业。若与众中胜比丘共诤。若喜游行不止。止不为人说法言示人善恶。是为五。有五法应与作亲厚(反上句是)有五法应差教授比丘尼。若具持波罗提木叉戒。多闻善巧语言。慈心辩说了了令听者得解。不为佛出家而犯重罪。二十腊若过二十。是为五。有五法令正法疾灭。何等五。有比丘。不谛受诵。喜忘误。文不具足以教余人。文既不具其义有阙。是为第一疾灭正法。复次有比丘。为僧中胜人上座。若一国所宗。而多不持戒。但修诸不善法。放舍戒行。不勤精进。未得而得。未入而入。未证而证。后生年少比丘。仿习其行。亦多破戒修不善法。放舍戒行亦不勤精进。未得而得未入而入未证而证。是为第二疾灭正法。复次有比丘。多闻持法持律持摩夷。不以所诵教余比丘比丘尼优婆塞优婆私便命终。彼既命终令法断灭。是为第三疾灭正法。复次有比丘。难可教授不受善言不能忍辱。余善比丘即舍置。是为第四疾灭正法。复次有比丘。喜斗诤共相骂詈。彼此诤言口如刀剑互求长短。是为第五疾灭正法。复有五法令正法久住(反上句是)比丘有五法。不应将作伴行。喜大在前行。喜大在后。喜抄断人语次。不别善恶语。善语不赞称美恶言。如法得利不以时为彼受。有是五法。不应将作伴行。有五法应将作伴行(反上句是)比丘有五法。而自损减。有犯为有智者所呵得罪无量。染污于人不令清净。为彼作犯不作无犯。若受彼自言不如自言法治。不知言说远近损减。是为五。复有五法。不自损减(反上句是)复有五法。自损减。不解所可言。亦不善忆识。彼语应难不难。若彼难来不能解。不具持波罗提木叉戒。是为五。复有五法。不自损减(反上句是)复有五法自损减。喜嗔恚不放舍。增益他语。受不善语。离善语。是为五。复有五不自损减(反上句是)病人有五法难瞻视。有五法易瞻视。有五法应受病人衣(如上衣揵度中说)比丘有五法。生人疑惑乃至。阿罗汉。何等五。若比丘数往淫女家妇人家大童女家黄门家比丘尼家是为五。比丘有五法。为白衣所不喜。喜亲白衣。喜嗔白衣。强至白衣家。喜与白衣窃语。喜乞求。是为五白衣所不喜见。有五法。白衣喜见(反上句是)

尔时世尊在王舍城。时优波离。从坐起偏露右肩右膝着地合掌白佛言。年少比丘。在上座比丘前忏悔。有几法。佛告优波离。有五法。偏露右肩脱革屣礼足右膝着地合掌。应说罪名种性作如是语。我某甲比丘。犯如是如是罪。从长老忏悔。上座应答言。自责汝心生厌离。彼人答言尔。年少比丘。在上座前忏悔。应以是五法。优婆离复问。年少客比丘。礼上座旧比丘。应以几法。佛告言。年少客比丘。应以五法礼上座旧比丘。应偏露右肩脱革屣右膝着地捉上座两足言。大德我和南。是为五法。年少旧比丘。礼客上座比丘亦如是。有五种人不应礼。自言犯边罪犯比丘尼贼心受戒破二道黄门。是为五。复有五法。杀父杀母杀阿罗汉破僧恶心出佛身血。是为五。比丘复有五种威仪不应礼。若大便若小便若露身若剃发时若说法时。是为五。复有五。若嚼杨枝若洗口若食若饮若食果。是为五。上座若次座。有五法。于斗诤比丘无利益。不具持二百五十戒。不多闻。不广诵二部戒不能问答。不能如法教呵及作灭摈令得欢喜。不善能灭斗诤事。是为五。复有五法。上座若次座。于斗诤比丘有利益(反上句是)有五法。名为大贼。长寿作大罪不被系缚。何等五。若住无定处有好伴。若多刀杖。若大富多有财宝。彼作是念。若有捉我者。当多与财宝。若有大人亲友。若依止王若大臣。彼作是念。若有捉我者。王及大臣当佐助我。若于远处作贼而还。是为五。如是破戒比丘有五法。长寿多作众罪。不速为他所举。若住无定处。有伴党。若多闻。若闻能忆持。有如是多闻。初中下言悉善。有文有义具说净行。于如是法中能忆持。而不能善心思惟深入正见。若能得衣服饮食卧具医药。彼作是念。若有举我者。我当多与物。若有大人为亲厚。若上座若次座。彼作是念。若有举我者。上座次座当佐助我。若在空野中住。来至大家求觅利养。是为五法。破戒比丘长寿多作众罪不速为他所举。有五非法。遮说戒。遮无根波罗夷僧伽婆尸沙波逸提波罗提提舍尼突吉罗。是为五有五如法。遮说戒(反上句是)有五非法捉筹。若不解断事受筹。若无同意受筹。若无善比丘受筹。若非法若别众受筹。是为五。有五如法受筹(反上句是)有五非法默然。有五如法默然。有五法和合(如上杂揵度中说)有五法舍弃(如拘睒弥揵度中说)

尔时佛告优波离。汝等莫数数举他比丘罪。何以故。举他比丘者。身威仪不清净。而举他罪。即生彼语。长老。先自令身清净。优波离。比丘若身威仪清净。而举他罪。不生彼语。若言不清净命不清净亦如是。复次优波离。若寡闻不知修多罗。而举他罪。即生彼语。问言长老。此事云何。此有何义。便不能分别答彼问。即生彼语。长老。先诵修多罗。然后当知。优波离。若比丘多闻诵修多罗。便不生彼语。复次优波离。比丘寡闻不诵毗尼。而举彼罪。生彼问言。长老此何所说。因何而起。若不能说所起处。复生彼语言。长老。且先自诵习毗尼。优波离。若比丘多闻诵习毗尼。而举彼罪。不生彼问。优波离。若比丘有是五法。应以时如法举彼罪。时优波离。信乐欢喜受持

尔时世尊。在迦陵伽国[(卄/麥)*壬]罗林中。时长老波摩那。诣世尊所头面礼足却坐一面。白世尊言。大德。以何因缘。如来灭后正法疾灭。而不久住。复以何因缘。正法不灭而得久住。佛告波摩那言。如来灭后比丘不敬佛法僧及戒定。以是因缘正法疾灭而不久住。波摩那。如来灭后。若比丘敬佛法僧及戒定。以是故正法不灭。而得久住

尔时世尊。在金毗罗国王园中。时长老金毗罗诣世尊所头面礼足却坐一面。白世尊言。以何因缘。如来灭后正法疾灭。而不久住(亦如上问答不异)尔时有异比丘。往佛所头面礼足却坐一面白佛言。大德。以何因缘正法疾灭而不久住。佛告比丘。若比丘在法律中出家。不至心为人说法。亦不至心听法忆持。设复坚持。不能思惟义趣。彼不知义。不能如法修行。不能自利亦不利人。佛告比丘。有是因缘令法疾灭而不久住。大德。复以何因缘令法久住而不疾灭(反上句即是)时有异比丘。往世尊所头面礼足却坐一面。善哉大德。为我略说法。我当独在静处勤修精进而不放逸。佛告比丘。汝若知世法不能出离。若知有受不能越度。若知有欲不得无欲。若知有结不得无结。若知亲近生死不得无亲近。汝比丘决定应知。此非法非毗尼非佛所教。若比丘汝知此法是出离非世法。是越度非受法。是离欲非有欲。是无结非有结。是不近生死非亲近。汝比丘应决定知此法。是法是毗尼是佛所教。时彼比丘。闻世尊略说教授。即独在静处勤行精进。而不放逸。初夜后夜警意思惟。一心修习道品之法。所为信乐出家行道。未久现世得证成阿罗汉。我生已尽梵。行已立所作已办不复还此。彼比丘自知得阿罗汉。佛说如是法。诸比丘闻。信乐欢喜受持。尔时有异比丘。往世尊所头面礼足却坐一面白佛言。善哉大德。为我略说法。我当独在静处勤修精进而不放逸。佛告比丘。若汝知有法。令多欲不令少欲。令无厌不知足。令难护不易护。令难养不易养。令愚痴无智慧。比丘汝应知如是法。非法非毗尼非佛所教。若比丘知有法。令少欲不多欲。令知足不无厌。令易护不难护。令易养不难养。令有智慧不愚痴。比丘汝应决定知是法是毗尼是佛所教。时彼比丘。闻佛略说已。即独在静处思惟。如上所说

四分律卷第五十九四分律卷第六十(第四分之十一)

        姚秦罽宾三藏佛陀耶舍共竺佛念等译

    毗尼增一之四

尔时佛告诸比丘。若我所听。波陀舍阿[少/兔]波陀舍。便阇那阿[少/兔]。便阇那恶叉罗阿[少/兔]恶叉罗。应如是作。如我所不听。波陀舍阿[少/兔]波陀舍。便阇那阿[少/兔]。便阇那恶叉罗阿[少/兔]恶叉罗。应呵不应随顺。应如是作。如我所遮。波陀舍阿[少/兔]波陀舍。便阇那阿[少/兔]。便阇那恶叉罗阿[少/兔]恶叉罗不应作。如我所不遮。波陀舍阿[少/兔]波陀舍。便阇那阿[少/兔]。便阇那恶叉罗阿[少/兔]恶叉罗。应随顺不应呵。尔时舍利弗。与五百比丘俱。摩诃波阇波提比丘尼。与五百比丘尼俱。阿难分坻。与五百优婆塞俱。毗舍佉母。与五百优婆私俱。如拘睒弥揵度中说。尔时佛告诸比丘。比丘至僧中。先有五法。应以慈心。应自卑下如拭尘巾。应善知坐起。若见上座不应安坐。若见下座不应起立。彼至僧中。不为杂说论世俗事。若自说法。若请人说法。若见僧中有不可事。心不安忍。应作默然。何以故。恐僧别异故。比丘应先有此五法然后至僧中。舍利弗。有此五法。比丘在僧中不应语。复有五法。在僧中应语。此中有六法。如上为自损减中说。举他罪有五法。具持二百五十戒。多闻。善于语言。有忆念。有智慧。是为五。有五法应举他罪。有慈悲心有欲利益令增长令忏悔清净。有是五法。应举他罪。欲举他罪者。应有五法。如上遮揵度中说。有五非法举。非时不以时。不实不以实。损减无利益。粗犷不柔和。嗔恚不以慈心。是为五。有五如法举(反上句是)不善善非毗尼是毗尼世间出世间作损减利益亦如是说。有五句语。无第三句。时与非时。此句无第三。实与不实。此句无第三。损减有利益。此句无第三。粗犷柔和此句无第三。嗔恚慈心。此句无第三。是为五句无第三。说五语舍戒。舍佛舍法舍僧舍和上舍同和上。如是五五为句。乃至非沙门释子。如来出世。见有过失故。以五利义。为诸比丘制戒。摄取于僧。令僧欢喜。令僧安乐。令不信者信。信者增长。是为五乃至正法久住亦如是。如来出世。见诸比丘有过失故。以五利义。为诸比丘制呵责羯磨摄取于僧。令僧欢喜。令僧安乐。令不信者信。信者增长。是为五。乃至正法久住。五五为句亦如是。乃至七灭诤亦如是。有六非法遮说戒。遮无根破戒作不作破见破威仪亦如是。是为六。有六如法遮说戒(反上句是)有六法。应差教授比丘尼。具持二百五十戒。多闻。广诵二部戒毗尼。善能语言辩说义句了了。不为佛故出家而犯重罪。若二十腊若过二十。有是六法。应差教授比丘尼。比丘为比丘作疑。有六法。若以所生年。若以腊数。若以受大戒。若以羯磨。若犯。若以法。是为六。有六犯所起处。或有犯由身起非心口。或有犯起于口不以身心。或有犯从身口起不以心。或有犯从身心起非口。或有犯起口心非身。或有犯从身口心起。是为六。斗诤有六根本。如中阿含说。有六处盗犯波罗夷。若自取若指授若遣使若重物以盗心移离本处。是为六。复有六非己有想。不暂取想。非亲厚想若重物。以盗心。移离本处。是为六。有七非法遮说戒。遮无根波罗夷乃至无根恶说。是为七。有七犯聚波罗夷乃至恶说。是为七。有七种精。青色乃至酪浆色。是为七。有七灭诤。如上戒文中说。有七法名为持律。知犯知不犯知轻知重知有余知无余广诵二部戒毗尼。是为七。复有七。六句同前。第七句以广诵毗尼为一句。是为七。复有七。六句同前。第七句以住毗尼不移不动为一句。是为七。复有七。六句同前。第七句以善能灭诤事为一句。是为七。复有七。六句同前。第七句以自识宿命种种所使为一句。是为七。复有七。六句同前。第七句以天眼见众生死此生彼为一句。是为七。复有七。六句同前。第七句以漏尽得无漏心解脱慧解脱现世得果证我生已尽梵行已立所作已办终不还。此为一句。是为七。有七不恭敬。不敬佛法僧戒定父母善法是为七。有七恭敬(反上句是)有七语舍戒。舍佛法僧舍和尚舍同和尚舍阿阇梨舍同阿阇梨。是为七。乃至非沙门释子亦如是。以七义故。如来出世为诸比丘制戒。摄取于僧。令僧欢喜。令僧安乐。令不信者信。信者增长。难调令调。惭愧者得安乐。是为七。如是七七为句。乃至正法久住亦如是。以七义故。如来出世为诸比丘制呵责羯磨。从摄取于僧。七七为句。乃至正法久住亦如是。乃至七灭诤亦如是。如呵责羯磨为句。有八非法遮说戒。遮无根破戒作不作。破见作不作。破威仪作不作。破正命作不作。是为八。有八如法遮说戒(反上句是)有八法应差教授比丘尼。具持二百五十戒。多闻。诵二部戒毗尼。善能言语辩义句字了了。大姓出家刹利婆罗门居士。若形颜端政。不为佛故出家而犯重罪。若二十腊若过二十腊。是为八。有八不可过法。如比丘尼犍度中说。白衣有八法。应与作覆钵。骂谤比丘。作损减。无利益。作无住处。斗乱比丘。在比丘前毁佛法僧。是为八。比丘有八法。令白衣不信。骂谤白衣。作损减。无利益。作无住处。斗乱白衣。在白衣前毁佛法僧。是为八。比丘有是八法。应与作遮不至白衣家羯磨如上说。有八法。应差作使伴。能闻能说自解令他解能受能持无失知好恶说义趣。是为八

尔时世尊。在瞻婆城伽伽池边。白月十五日说戒时。于露地坐。与众僧俱前后围绕。时有比丘。举彼比丘见闻疑罪。当举罪时。彼比丘乃作余语答。便起嗔恚。佛告诸比丘。应审定问彼人。彼人于佛法中无所任无所增长。譬如农夫田苗稊稗参生。苗叶相类不别。而为妨害。乃至莠实。方知非谷之异。既知非谷即耘除根本。何以故。恐害善苗故。比丘亦复如是。有恶比丘。行来坐起摄持衣钵。如善比丘不别。乃至不出罪。时既出其罪。方知比丘中稊稗之异。既知其异。应和合为作灭摈除之。何以故。恐妨善比丘故。譬如农夫治谷当风簁扬好谷留聚其下秕[卄/告]随风除之。何以故。恐污好谷故。如是恶比丘行来入出。如善比丘不别。乃至不出罪。时既出其罪。方知比丘中秕[卄/告]秽恶。既知已。应和合为作灭摈除之。譬如有人须木作井栏。从城中出。手捉利斧。往彼林中。遍扣诸树。若是实中者其声贞实。若是空中者其声虚而[斯/瓦]。而彼空树根茎枝叶。如贞实者不异。至于扣时方知内空。既知内空。即便斩伐截落枝叶先去粗朴。然后釿刬细治内外俱净。以作井栏。如是恶比丘。行来出入摄持衣钵。威仪如善比丘不异。乃至不出罪。时既出其罪。方知沙门中垢秽稊稗空树。若知已即应和合作灭摈。何以故。恐妨害善比丘故。而说偈言

  同住知性行　　嫉妒喜嗔恚
  人中说善语　　屏处造非法
  方便作妄语　　明者能觉知
  稊稗应除弃　　及以空中树
  自说是沙门　　虚空应灭摈
  已作灭摈竟　　行恶非法者
  清净者共住　　当知是光显
  和合共灭摈　　和合尽苦际

佛说如是。诸比丘闻。欢喜信乐受持

尔时佛告诸比丘。我今为汝等说八种恶马及八种恶人。汝曹谛听。何等八。或有恶马。授勒与鞭欲令其去。而更抵踬不去。或有恶马。授勒与鞭欲令其去。而反倚傍两辕。而不前进。或有恶马。授勒与鞭欲令其去。而颠蹶倒地。既伤其膝。又折辕槅。或有恶马。授勒与鞭欲令其去。而更却行不进。或有恶马。授勒与鞭欲令其去。而更趣非道破轮折轴。或有恶马。授勒与鞭欲令其去。不畏御者亦不畏鞭。方便啮衔[馬*奔]突不可禁制。或有恶马。授勒与鞭欲令其去。而双脚人立吐沫。或有恶马。授勒与鞭欲令其去。或蹲或卧。是为八。何等是八种恶人。或有比丘。举彼见闻疑罪。而彼比丘便言。我不忆我不忆。犹如恶马授勒与鞭欲令其去而更抵踬不去。我说此人亦复如是。或有比丘。举彼见闻疑罪。而彼比丘不言犯不言不犯默然而住。犹如恶马授勒与鞭欲令其去。倚傍两辕而不前进。我说此人亦复如是。或有比丘。举彼见闻疑罪。彼作是言。长老亦自犯是罪。云何能除他罪。犹如恶马授勒与鞭欲令其去。而更颠蹶倒地既伤其膝又折辕槅。我说此人亦复如是。或有比丘。举彼见闻疑罪。彼比丘作是言。长老自痴。犹须人教而欲教我。犹如恶马授勒与鞭欲令其去而更却行。我说此人亦复如是。或有比丘。举彼见闻疑罪。而彼便说余事答反生嗔恚。犹如恶马授勒与鞭欲令其去。而趣非道折轴破轮。我说此人亦复如是。或有比丘。举彼见闻疑罪。而彼比丘不畏众僧亦不畏犯。而不受举罪者语。便捉坐具置肩而去不可呵制。犹如恶马授勒与鞭欲令其去。而不畏御者亦不畏鞭啮衔[馬*奔]突不可禁制。我说此人亦复如是。或有比丘。举彼见闻疑罪。而彼比丘左抄郁多罗僧。在僧中举手大语。乃令汝等教授我耶。犹如恶马授勒与鞭欲令其去。而更双脚人立吐沫。我说此人亦复如是。或有比丘。举彼见闻疑罪。彼比丘言。长老亦不与我衣钵卧具医药。何故教我。彼即舍戒取于下道。至诸比丘所作是言。大德。我已休道。于意快耶。犹如恶马授勒与鞭欲令其去而更蹲卧。我说此人亦复如是。是为八种恶人。我已说八种恶马八种恶人。世尊所应。慈愍诸弟子。我已具说。汝今当住在空处树下修习禅定。莫为放逸后致悔恨。此是我教诫。佛说如是。诸比丘闻。欢喜信乐受持

尔时世尊在拘萨罗国。与千二百五十比丘俱人间游行。于中道见有大聚火炽然。见已即下道。在一树下敷座而坐。告诸比丘。汝等见彼大聚火炽然不。若使有人捉彼火扪摸呜之。即烧其皮肉筋骨消尽。若复有人。捉刹利女婆罗门女毗舍女首陀罗女扪摸呜之。如是二事何者为善。诸比丘白佛。大德。若捉彼刹利等女扪摸呜之。此事为善。何以故。若捉火即烧烂皮肉筋骨消尽。得大苦痛不可堪耐。佛告诸比丘。我今告汝。宁捉此火扪摸呜之。烧其皮肉筋骨消尽。此事为善。何以故。不以此因堕三恶道。若非沙门。自言是沙门。非净行。自言是净行。破戒行恶。都无持戒威仪。邪见覆处作罪。内空腐烂外现完净。食人信施以不消信施故。堕三恶道长夜受苦。是故应当持净戒食人信施。饮食衣服卧具医药一切所须。能令施主得大果报。所为出家作沙门亦得成就。汝等比丘。宁以热戟。刺脚。当受信乐善男子善女人接足作礼耶。如是二事何者为善。诸比丘白佛言宁受信乐善男子善女人接足作礼。何以故。热戟刺脚受大苦痛故。佛告诸比丘。我今告汝宁以热戟刺脚。何以故。不以此因堕三恶道。若非沙门。自言是沙门。非净行自言是净行。破戒行恶。都无持戒威仪。邪见覆处作罪。内空腐烂外现完净。食人信施。以不消信施故。堕三恶道长夜受苦。是故当持净戒食人信施。乃至一切所须如上说。令施者得大果报。所为出家作沙门亦得成就。汝等比丘。宁以热斧自斩其身首。当受信乐善男子善女人手扪摸身耶。如是二事何者为善。诸比丘白佛言。大德。宁受信乐善男子善女人手扪摸身。何以故。热斧斩身首受大苦痛故。我今告汝。宁以热斧自斩其身首。此事为善。何以故。不以此因堕三恶道。余如上句说。比丘汝等。宁以热铁为衣烧烂身尽。当受着信乐善男子善女人种种好衣。如是二事何者为善。诸比丘白佛言。大德宁受彼种种好衣。何以故。热铁衣烧身受大苦痛故。佛告诸比丘。我今语汝。宁以热铁为衣烧身。何以故。不以此因堕三恶道。余如上句说。比丘汝等。宁吞热铁丸烧烂五藏从下而出。当受信乐善男子善女人饮食供养耶。如是二事何者为善。诸比丘言。宁受彼饮食供养。何以故。吞热铁丸受大苦痛故。佛告诸比丘。我今告汝。宁吞热铁丸。何以故。不以此因堕三恶道。余如上句说。受种种粥亦如是。汝等比丘。宁在热铁床上坐自烧身燋烂。当受信乐善男子善女人种种好床卧具在上耶。如是二事何者为善。诸比丘白佛言。宁受彼种种好床卧具。何以故。热铁床上自烧身燋烂受大苦痛故。佛告诸比丘。我今语汝。宁受热铁床上坐卧烧身。何以故。不以此因堕三恶道。余如上句说。汝等比丘。宁在热铁屋中住烧身。当受信乐善男子善女人房舍在中止宿耶。如是二事何者为善。诸比丘白佛。宁受彼房舍止宿。何以故。在彼热铁房中受大苦痛故。我今告汝。宁在彼热铁房中烧身烂尽。何以故。不以此因缘堕三恶道。余如上句说。尔时世尊说此语时。六十比丘沸血从面孔出。六十比丘舍戒休道。六十比丘得无漏心解脱。有众多比丘。远尘离垢得法眼净。白衣家有九法。未作檀越不应作。若至其家不应坐。何等九。见比丘不喜起立。不喜作礼。不喜请比丘坐。不喜比丘坐。设有所说而不受。若有衣服饮食所须之具轻慢比丘而不与。若多有而少与。若有精细而与粗恶。或不恭敬与。是为九法不应往白衣家。复有九法。未作檀越应为檀越。已作应往坐(反上句是)有九不如法遮说戒。遮无根破戒作遮不作遮作不作。破见破威仪亦如是。是为九。有九如法遮说戒(反上句是)有九语舍戒。舍佛舍法舍僧舍和尚舍同和尚舍阿阇梨舍同阿阇梨舍诸梵行舍戒。是为九。如是九九为句。乃至非沙门释种子亦如是。如来出世。见有过失故。以九利义。为诸比丘制戒。摄取于僧。乃至断未来有漏。是为九。如来出世。见有过失故。以九利义。为诸比丘制呵责羯磨。从摄取于僧。乃至断未来有漏。是为九。乃至九灭诤亦如是。有十种衣。拘奢衣劫贝衣钦跋罗衣刍摩衣叉摩衣舍[少/兔]衣麻衣翅夷罗衣拘遮罗衣差罗波尼衣。是十种衣。应染作袈裟色。衣持有十种。粪扫衣牛嚼衣鼠啮衣烧衣月水衣初产衣神庙衣冢间衣愿衣立王衣往还衣。是为十。有十非法遮说戒。非波罗夷。不入波罗夷说中。非舍戒。不入舍戒说中。随如法僧要。如法僧要不呵。不随如法僧要呵说中。不见不闻不疑破戒。不见不闻不疑破见。不见不闻不疑破威仪。是为十。有十如法遮说戒(反上句是)复有十非法遮说戒。不犯边罪。不入边罪说中。不犯比丘尼。不入犯比丘尼说中。不贼心受戒。不入贼心受戒说中。不破二道。不入破二道说中。非黄门。不入黄门说中。是为十。有十如法遮说戒(反上句是)有十法。应差教授比丘尼。具持二百五十戒。多闻。广诵二部戒毗尼。善巧语言辩说了了。大姓出家刹利婆罗门居士。形貌端政。比丘尼恭敬。堪任为比丘尼说法令得欢喜。不为佛故出家着袈裟而犯重罪。若二十腊若过二十腊。是为十。尔时佛告优波离。汝等莫数举他比丘罪。何以故。若身威仪。不清净。举他比丘罪。即生彼语言。长老先自净身威仪。优波离。若比丘身威仪清净。不生他语。若言不清净。命不清净。不多闻。不广诵二部毗尼亦如是(如上五五法中说)复次优波离。举他比丘。复应修习五法。以时不以非时。以实不以不实。利益不以损减。柔软不以粗犷。慈心不以嗔恚。优波离。举他比丘。有此十法。然后应举。有十非法受筹。不解事受筹。不与共如法者受筹。欲令非法者多受筹。知有多非法者而受筹。欲令僧破受筹。知僧欲破受筹。以小罪受筹。不如所见受筹。非法受筹。别众受筹。是为十。有十如法受筹(反上句是)如来出世。见有过失故。以十义为诸比丘制戒。从摄取于僧。乃至正法久住。是为十。有十种人不应礼。自言犯边罪犯比丘尼贼心受戒破二道黄门杀父杀母杀阿罗汉破僧恶心出佛身血。是为十。比丘有十种威仪不应礼。大行时小行时若裸身若剃发若说法若嚼杨枝若洗口若饮若食若啖果。是为十。饮酒有十过失。令色恶少力眼不明喜现嗔失财增病起斗诤有恶名流布无智慧死堕地狱。是为十。出家人。入王宫至婇女间。有十过失。若王与夫人和合时。比丘入宫至婇女间。夫人见比丘笑。比丘见夫人亦笑。王作是意言。比丘若已作是事。若当作此。是出家人入王宫婇女间初过失。复次若王醉时。与夫人和合不忆。后夫人有娠。王作是意言。比丘来入宫。是比丘所为。是为第二过失。复次王太子欲反杀王。王作是意。比丘来入我宫内是其所教。是第三过失。复次王在内。秘密之言以闻于外。王作是念。比丘来入我宫内。是其所传。是第四过失。复次王若失宝若似宝。王作是意。比丘来入我宫内。是其取去。是第五过失。复次王或以贱人在高位处。外不喜者作是言。比丘入宫是其所作。是为第六过失。复次王或以高位者处在下职。外不喜者作是言。比丘入宫是其所作。是第七过失。复次无事因缘非时。王集四部兵。其不喜者作是言。比丘入宫是其所作。是为第八过失。复次王或集兵。中路而还。其不喜者作是言。比丘入宫是其所作。是为第九过失。复次若王在宫婇女间。出好象马端政女人。见则心生爱着非比丘法。是为第十过失。有十法不应授人大戒。不能教弟子增戒增心增慧学增威仪增净行增波罗提木叉学。不能教舍恶见令住善见。弟子不乐住处不能移至乐处。若有疑悔生不能如法如毗尼开解决断。若不满十腊。是为十。有十法应授人大戒(反上句是)有十法不应授人大戒。不具持二百五十戒。不多闻。不能教弟子阿毗昙毗尼。不能教舍恶见住善见。不知波罗提木叉。不知波罗提木叉说。不知布萨。不知布萨羯磨。若不满十腊。是为十。有十法应授人大戒(反上句是)有十法不应差别处断事。不具持二百五十戒。不多闻。不广诵二部戒。不善巧语言令人开解。不能问答教呵如法灭摈令得欢喜。设有诤起不善能灭。不知波罗提木叉。不知波罗提木叉说不知布萨。不知布萨羯磨。是为十。有十法应差别处断事(反上句是)有十法不应差别处断事。六句如上。不解断了斗诤事。不知诤起。不知诤灭不知趣灭诤道。是为十。有十法应差别处断事(反上句是)有十法不应差别处断事。六句如上。有爱有恚有怖有痴。是为十。有十法应差别处断事(反上句是)时阿难。从坐起偏露右肩右膝着地合掌。白佛言。大德。以何因缘令僧未有诤事而生诤事已有诤事而不除灭。佛告阿难。举他比丘。不犯言犯。犯言不犯。轻言重。重言轻。非法说法。法说非法。非毗尼说毗尼。是毗尼说非毗尼。非制而制。是制而断。以此因缘令僧未生诤事而生诤事。已有诤事而不除灭。阿难复问佛言。大德以何因缘令僧未有诤事而不生诤。已有诤事而得除灭。佛答阿难(反上句是)佛告阿难。有十种诤根。应当知之。善作方便令得除灭。何等十(反上句是)时优波离。从坐起偏露右肩右膝着地合掌。白佛言。大德。说言破僧者。齐几名为破僧。谁破和合僧。佛答。十事如上句。以此十事求索伴党。若教他求别部说戒布萨羯磨。齐是为破僧。名为破和合僧。优波离问和合僧(反上句是)有十一语。舍戒舍佛舍法舍僧舍和尚舍同和尚舍阿阇梨舍同阿阇梨舍净行比丘舍波罗提木叉舍毗尼舍学事。是为十一。如是十一为句。乃至非沙门释子亦如是

尔时世尊在不尸城林中。告诸比丘言。若比丘所在之处。莫斗诤共相骂詈口出刀剑互求长短。忆之不乐况能住彼。汝等决定应知三法疾灭。应知三法增长。何等三。念出离念无嗔恚念无嫉妒此三事疾断灭。何等三法遂增长。贪欲念嗔恚念嫉妒念。此三法增长。是故所在之处。若斗诤共相骂詈口出刀剑互求长短。忆之不乐况能住彼。是故汝等。决定应知三法损减三法增长。若比丘所在之处不共斗诤(反上句是)其有斗诤二俱不忍。心怀垢秽互相憎害增长嗔恚。不善调伏不相受教亦失恭敬。当知此诤转增坚固。不得如法如律如佛所教而灭。若比丘斗诤。彼此俱忍。心不怀垢秽。不相憎害。不增长嗔恚而善调伏。更相受教。不失恭敬。当知此诤而不坚固。得如法如律如佛所教而灭。若比丘共诤二俱不忍。心怀垢秽互相憎害增长嗔恚。而不善调伏不相受教亦失恭敬。若诤事起时。不以七灭诤一一法而灭诤事者。当知此诤转复增长坚固。不得如法如律如佛所教而灭。若诤如法得灭者(反上句是)若比丘斗诤。不与上中下座平宜其事。则不入修妒路毗尼法律不与相应。若诤事起时。不以七灭诤法一一灭者。当知此诤而致增长坚固。不得如法如律如佛所教而灭。若诤事如法得灭(反上句是)若不与持法持律持摩夷者共平宜诤事。诤事增长亦如上句说。若诤事如法灭(亦如上句是)

尔时世尊告优波离。汝等莫数举他比丘罪。何以故。若举他罪。身不清净。口不清净。即生他语。长老。先自净身口威仪。优波离。若比丘身口清净。不生他语。复次优波离。举他比丘。命不清净寡闻不诵修多罗。若举他罪。即生他语。长老。先自清净其命诵修多罗。若优波离。举他比丘。命清净多闻诵修多罗。不生他语。复次优波离。举他比丘。不多闻不知毗尼言不辩了。喻若白羊。若举他罪。则生他语。长老。先学毗尼学语。若优波离。举他比丘。多闻诵毗尼语言了了。则不生他语。是故优波离。比丘应作是知。若此比丘。有爱恭敬于我者。则应举罪。无爱有恭敬应举。无恭敬有爱应举。若无爱无恭敬能令舍恶就善应举。若无爱无恭敬亦不能令舍恶行善。而彼有所重比丘尊敬信乐者。能令舍恶行善应举。若无爱无恭敬不能令舍恶行善。复无有所重比丘尊敬信乐者。不能令舍恶行善。优波离。僧即应都舍置驱弃。语言。长老随汝所去处。彼当为汝作举作忆念作自言遮阿[少/兔]婆陀遮说戒遮自恣。譬如调马师恶马难调即合缰[木*戈]驱弃。此比丘亦复如是如是人不应先从其求听。此即是听。佛说如是。优波离闻。欢喜信乐受持

优波离问佛言。大德。为比丘起事以几法。佛答言。为比丘起事以三事。破戒破见破威仪。优波离复问。以此三事起事。复以几法为作举。佛言。以三事举见闻疑。优波离复问。以三事起事。以三法作举。应内有几法然后举。佛言。内有五法应作举(如上说以时不以非时如是五法)

尔时世尊在跋阇国池水边。告诸比丘。汝等谓我为衣服饮食疾病医药床卧具而说法耶。诸比丘白佛言。大德。我等不敢生如是意。谓世尊为衣服乃至卧具故而说法。佛言。若不以是。为作何心。诸比丘答言。我等作如是意。世尊慈念众生故。而为说法。佛言。汝等若实有如是心者。我所觉悟证知之法。四念处四正勤四神足四禅五根五力七觉意八圣道。应欢喜和合修学。若欢喜和合修学有余比丘犯戒。不应疾疾举。应自观察。不令自恼。亦不令害人。彼犯罪者。若不喜嗔恚。不结怨嫌。不难觉悟。自能除罪。能舍不善住于善法。若作如是。复应量宜。若自恼已。然不害彼人。彼有罪者。不喜嗔恚难悟。疾能除罪。能舍不善。住于善法。彼比丘应作是念。我得少恼。于彼无害。有爱利益。能令舍不善住于善法。则应举罪。比丘作是念。我举他罪。当得自恼。然不害彼。彼有罪者。喜嗔恚易得解悟。能疾舍罪。余如上说。比丘复作是念。若举他罪。于我得恼害。彼有罪者。喜嗔恚难可解悟。不疾舍罪。若我举罪为作忆念。当以余外语答我而生嗔恚。如是人便应舍置。不须复举。如是比丘和合欢喜。于阿毗昙中种种诤语。应语言。诸长老。所说文义相应。不应共诤。有余比丘人所信用其言者。应语言。长老。所说文义相应。不应共诤。复更有余比丘人所信用言者。亦应语如是语。复作是言长老。所说文异义同。此是小事耳。莫共斗诤。若有多人所信信用其言者。应语如是言。复更有多人信用言者。亦应语如是言。复作是言。长老。所说文同义异亦如是。复作如是语。长老。所说文义俱异。莫共斗诤。有多人信用言者。应语如是言。复更有信用言者。亦应语如是言。若作如是和合众僧有诤事起。应和合共集。共集已。应作如是观察。若共斗诤于沙门法作留难不。汝谓云何。余比丘见正理者。应作是言。斗诤法于沙门法即是留难。复问言。若有见者是可呵不。彼言。我意谓。于沙门法作留难即是可呵。复问言。若于沙门法作留难。是可呵法。能进善根得沙门果不。有见正理比丘言。我意谓。可呵不能进善根不能得沙门果。若作如是诤事灭者。应语彼比丘言。汝为我等灭此诤事。彼比丘应答言。我不知他心。但于佛所有信乐。世尊以时为我说法。最上胜妙开示善恶。如我从世尊所闻如是法。今为汝说。若彼比丘闻已。便舍诤事。比丘作如是说时。不自高己亦不下人。如是余比丘无有能呵者。佛说如是。诸比丘闻。欢喜信乐受持

有十三种人。未受大戒不应受。若受应作灭摈。自言犯边罪犯比丘尼贼心受戒破二道黄门杀父杀母杀阿罗汉破僧恶心出佛身血非人畜生二根。是为十三种人未受大戒不应受若受应灭摈。尔时佛告优波离。汝等莫数举他比丘罪。何以故。若比丘数举他罪。身不清净则生他语。长老先自净身。若举他比丘。身清净不生他语。如是口不清净。命不清净。不多闻。不诵毗尼。不观修多罗。言不辩了。喻若白羊。于善比丘身业无慈亦如是。复次优波离。若比丘欲出他罪。不令有罪。有犯便举。不犯不举。取彼比丘自言。与作自言。善能言说辩了有利益。复次优波离。举他比丘。复应有五法。以时不以非时(如是五法如上说)

优波离。若比丘有此十七法。应举他罪。有二十二法。不应授人大戒。不知法不知非法。乃至不知说不说。不知可忏罪。不知不可忏罪。不知忏悔。不知忏悔清净。有是二十二法。不应授人大戒。有二十二法。应授人大戒(反上句是)尔时佛告诸比丘以二十二种行。知是平断事人。具持二百五十戒。多闻善解阿毗昙毗尼。不与人诤亦不坚住此事。应呵者呵然后住。应教教然后住。应灭摈灭摈然后住。不爱不恚不怖不痴。不受此部饮食。亦不受彼部饮食。不受此部衣钵坐具针筒。亦不受彼部衣钵坐具针筒。不供给此部。亦不供给彼部。不共此部入村。亦不共彼部入村。不与作期要。亦不至彼后来后坐。有此二十二种。知是平断事人。佛说如是。诸比丘闻。欢喜信乐受持(毗尼增一具足竟)

四分律卷第六十


四分尼戒本

    No. 1431 [cf. No. 1428]

    四分尼戒本(并序)

        西太原寺沙门怀素集

夫戒者。乃是定慧之宏基。圣贤之妙趾。穷八正之道。尽七觉之源。然既树五制之良规。传须获实。扬六和之清训。学者知诠。窃寻流行。总有四本。据其理虽复同。会其文则有异。致使弘扬失于宗叙。修奉乖于行仪。亏鹿野之微言。紊龙城之要旨。故今详捡律本。参验戒心。依于正文录之如左。庶使顺菩提之沙业成实相之嘉谋。作六趣之舟航。为三乘之轨躅者也

四分比丘尼戒本

        后秦三藏佛陀耶舍译

  稽首礼诸佛　　及法比丘僧
  今演毗尼法　　令正法久住
  戒如海无涯　　如宝求无厌
  欲护圣法财　　众集听我说
  欲除八弃法　　及灭僧残法
  障三十舍堕　　众集听我说
  毗婆尸式弃　　毗舍拘楼孙
  拘那含牟尼　　迦叶释迦文
  诸世尊大德　　为我说是事
  我今欲善说　　诸贤咸共听
  譬如人毁足　　不堪有所涉
  毁戒亦如是　　不得生天人
  欲得生天上　　若生人间者
  常当护戒足　　勿令有毁损
  如御入崄道　　失辖折轴忧
  毁戒亦如是　　死时怀恐惧
  如人自照镜　　好丑生欣戚
  说戒亦如是　　全毁生忧喜
  如两阵共战　　勇怯有进退
  说戒亦如是　　净秽生安畏
  世间王为最　　众流海为最
  众星月为最　　众圣佛为最
  一切众律中　　戒经为上最
  如来立禁戒　　半月半月说

僧集(答云僧集)和合(答云和合)未受大戒者出(有者遣出遣已答言已出无者答无)不来诸比丘尼。说欲及清净(有依法说无答言无)僧今和合何所作为(答言说戒羯磨)大姊僧听。今十五日众僧说戒。若僧时到僧忍听。和合说戒。白如是(作白成不答云成)诸大姊。我今欲说波罗提木叉戒。汝等谛听善思念之。若自知有犯者。即应自忏悔。不犯者默然。默然者。知诸大姊清净。若有他问者。亦如是答。如是比丘尼在众中乃至三问。忆念有罪不忏悔者。得故妄语罪。故妄语者佛说障道法。若彼比丘尼忆念有罪。欲求清净者应忏悔。忏悔得安乐。诸大姊。我已说戒经序

今问。诸大姊。是中清净不(如是至三)

诸大姊。是中清净。默然故。是事如是持

诸大姊。是八波罗夷法。半月半月说戒经中来

若比丘尼作淫欲犯不净行乃至共畜生。是比丘尼波罗夷不共住

若比丘尼在聚落若空闲处。不与怀盗心取。随所盗物。若为王若王大臣所捉。若缚若杀若驱出国。汝贼汝痴汝无所知。若比丘尼作如是不与取。是比丘尼波罗夷不共住

若比丘尼故自手断人命。若持刀授与人。若叹死誉死劝死。咄人用此恶活为。宁死不生。作如是心念。无数方便叹死誉死劝死。此比丘尼波罗夷不共住

若比丘尼实无所知。自叹誉言。我得过人法。入圣智胜法。我知是我见是。后于异时。若问若不问。欲求清净故。作如是言。诸大姊。我实不知不见。而言我知我见。虚诳妄语。除增上慢。是比丘尼波罗夷不共住

若比丘尼染污心。共染污心男子。从腋已下膝已上身相触。若捉摩若牵若推。若上摩若下摩。若举若下若捉若捺。是比丘尼波罗夷不共住。是身相触也

若比丘尼染污心。知男子染污心受。捉手捉衣入屏处。共立共语共行。或身相倚或共期。是比丘尼波罗夷不共住。犯此八事故

若比丘尼。知比丘尼犯波罗夷。不自发露。不语众人。不白大众。若于异时。彼比丘尼或命终。或众中举或休道或入外道众。后作是言。我先知有如是如是罪。是比丘尼波罗夷不共住。覆藏重罪故

若比丘尼。知比丘僧为作举。如法如律如佛所教。不顺从不忏悔。僧未与作共住。而顺从。诸比丘尼语言。大姊。此比丘为僧所举。如法如律如佛所教。不顺从不忏悔。僧未与作共住。汝莫顺从。如是比丘尼谏彼比丘尼时。坚持不舍。彼比丘尼应第二第三谏。令舍此事故。乃至三谏舍者善。若不舍者是比丘尼波罗夷不共住。犯随举故

诸大姊。我已说八波罗夷法。若比丘尼犯一一波罗夷法。不得与诸比丘尼共住。如前后亦如是。比丘尼得波罗夷罪不应共住。今问。诸大姊。是中清净不(如是至三)诸大姊。是中清净。默然故。是事如是持

诸大姊。是十七僧伽婆尸沙法。半月半月说戒经中来

若比丘尼媒嫁。持男语语女。持女语语男。若为成妇事。若私通事。乃至须臾。是比丘尼犯初法应舍僧伽婆尸沙

若比丘尼嗔恚不喜。以无根波罗夷法谤。欲破彼清净行。后于异时。若问若不问。是事无根说。我嗔恚故如是语。是比丘尼犯初法应舍僧伽婆尸沙

若比丘尼嗔恚不喜。于异分事中取片。非波罗夷比丘尼。以无根波罗夷法谤。欲破彼人梵行。后于异时。若问若不问。知是异分事中取片。彼比丘尼住嗔恚。故作如是说。是比丘尼犯初法应舍僧伽婆尸沙

若比丘尼诣官言。居士若居士儿。若奴若客作人。若昼若夜。若一念顷。若弹指顷。若须臾顷。是比丘尼犯初法应舍僧伽婆尸沙

若比丘尼先知是贼女。罪应死人所知。不问王大臣。不问种姓。便度出家受具足戒。是比丘尼犯初法应舍僧伽婆尸沙

若比丘尼。知比丘尼为僧所举。如法如律如佛所教。不顺从未忏悔。僧未与作共住羯磨。为爱故不问僧。僧不约敕。出界外作羯磨与解罪。是比丘尼犯初法应舍僧伽婆尸沙

若比丘尼。独渡水独入村。独宿独在后行。是比丘尼犯初法应舍僧伽婆尸沙

若比丘尼染污心。知染污心男子。从彼受可食者及食并余物。是比丘尼犯初法应舍僧伽婆尸沙

若比丘尼。教比丘尼作如是语。大姊。彼有染污心无染污心。能那汝何。汝自无染污心。于彼若得食。以时清净受取。此比丘尼犯初法应舍僧伽婆尸沙

若比丘尼欲坏和合僧。勤方便受破僧法。坚持不舍。是比丘尼应谏彼比丘尼言。大姊。汝莫坏和合僧。莫方便坏和合僧。莫受破僧法坚持不舍。大姊。应与僧和合。与僧和合欢喜不诤。同一师学如水乳合。于佛法中有增益安乐住。是比丘尼谏彼比丘尼时。坚持不舍。是比丘尼应三谏。舍此事故。乃至三谏舍者善。不舍者。是比丘尼。犯三法应舍僧伽婆尸沙(一十)

若比丘尼。有余比丘尼群党。若一若二若三乃至无数。彼比丘尼语是比丘尼言。大姊。汝莫谏此比丘尼。此比丘尼。法语比丘尼。律语比丘尼。此比丘尼所说。我等心喜乐。此比丘尼所说。我等忍可。是比丘尼语彼比丘尼言。大姊。莫作是说言。此比丘尼是法语比丘尼律语比丘尼。此比丘尼所说我等喜乐。此比丘尼所说我等忍可。何以故。此比丘尼所说。非法语非律语。大姊。莫欲破坏和合僧。当乐欲和合僧。大姊。与僧和合欢喜不诤。同一师学如水乳合。于佛法中有增益安乐住。是比丘尼谏彼比丘尼时。坚持不舍。是比丘尼应三谏。舍此事故。乃至三谏舍者善。不舍者。是比丘尼。犯三法应舍僧伽婆尸沙

若比丘尼。依城邑若村落住。污他家行恶行。行恶行亦见亦闻。污他家亦见亦闻。是比丘尼谏彼比丘尼言。大姊。汝污他家行恶行。行恶行亦见亦闻。污他家亦见亦闻。大姊。汝污他家行恶行。今可离此村落去不须住此。彼比丘尼语此比丘尼作是言。大姊。诸比丘尼有爱有恚有怖有痴。有如是同罪比丘尼。有驱者有不驱者。是诸比丘尼语彼比丘尼言。大姊。莫作是语。有爱有恚有怖有痴。亦莫言有如是同罪比丘尼。有驱者有不驱者。何以故。而诸比丘尼不爱不恚不怖不痴。有如是同罪比丘尼。有驱者有不驱者。大姊。污他家行恶行。行恶行亦见亦闻。污他家亦见亦闻。是比丘尼谏彼比丘尼时坚持不舍。是比丘尼应三谏。舍此事故。乃至三谏舍者善。不舍者。是比丘尼。犯三法应舍僧伽婆尸沙

若比丘尼恶性不受人语。于戒法中。诸比丘尼如法谏已。自身不受谏语言。大姊。汝莫向我说若好若恶。我亦不向汝说若好若恶。诸大姊。止莫谏我。是比丘尼当谏彼比丘尼言。大姊。汝莫自身不受谏语。大姊。自身当受谏语。大姊。如法谏诸比丘尼。诸比丘尼亦当如法谏。大姊。如是佛弟子众得增益。展转相谏。展转相教。展转忏悔。是比丘尼如是谏时。坚持不舍。是比丘尼应三谏。舍此事故。乃至三谏舍者善。不舍者。是比丘尼。犯三法应舍僧伽婆尸沙

若比丘尼相亲近住。共作恶行恶声流布。展转共相覆罪。是比丘尼当谏彼比丘尼言。大姊。汝等莫相亲近共作恶行。恶声流布共相覆罪。汝等若不相亲近。于佛法中得增益安乐住。是比丘尼谏彼比丘尼时。坚持不舍。是比丘尼应三谏。舍此事故。乃至三谏舍者善。不舍者。是比丘尼。犯三法应舍僧伽婆尸沙

若比丘尼僧为作呵谏时。余比丘尼教作如是言。汝等莫别住当共住。我亦见余比丘尼。不别住共作恶行。恶声流布共相覆罪。僧以恚故教汝别住。是比丘尼应谏彼比丘尼言。大姊。汝莫教余比丘尼言。汝等莫别住。我亦见余比丘尼。共住共作恶行。恶声流布共相覆罪。僧以恚故教汝别住。今正有此二比丘尼。共住共作恶行恶声流布。共相覆罪更无有余。若此比丘尼别住。于佛法中有增益安乐住。是比丘尼谏彼比丘尼时。坚持不舍。是比丘尼应三谏。令舍此事故。乃至三谏舍者善。不舍者。是比丘尼。犯三法应舍僧伽婆尸沙

若比丘尼。趣以一小事嗔恚不喜。便作是语。我舍佛舍法舍僧。不独有此沙门释子。亦更有余沙门婆罗门修梵行者。我等亦可于彼修梵行。是比丘尼当谏彼比丘尼言。大姊。汝莫趣以一小事嗔恚不喜便作是语。我舍佛舍法舍僧。不独有此沙门释子。亦更有余沙门婆罗门修梵行者。我等亦可于彼修梵行。若是比丘尼谏彼比丘尼时。坚持不舍。彼比丘尼应三谏。舍此事故。乃至三谏舍者善。不舍者。是比丘尼。犯三法应舍僧伽婆尸沙

若比丘尼喜斗诤。不善忆持诤事。后嗔恚作是语。僧有爱有恚有怖有痴。是比丘尼应谏彼比丘尼言。妹汝莫喜斗诤。不善忆持诤事。后嗔恚作是语。僧有爱有恚有怖有痴。而僧不爱不恚不怖不痴。汝自有爱有恚有怖有痴。是比丘尼谏彼比丘尼时。坚持不舍。彼比丘尼应三谏。舍此事故。乃至三谏舍者善。不舍者。是比丘尼。犯三法应舍僧伽婆尸沙

诸大姊。我已说十七僧伽婆尸沙法。九初犯罪八乃至三谏。若比丘尼犯一一法。应半月二部僧中行摩那埵。行摩那埵已。余有出罪。应二部四十人僧中出是比丘尼罪。若少一人不满四十众。出是比丘尼罪。是比丘尼罪不得除诸比丘尼亦可呵。此是事。今问。诸大姊。是中清净不(如是至三)

诸大姊。是中清净。默然故。是事如是持

诸大姊。是三十尼萨耆波逸提法。半月半月说戒经中来

若比丘尼衣已竟。迦絺那衣已舍。畜长衣经十日。不净施得持。若过尼萨耆波逸提

若比丘尼衣已竟。迦絺那衣已舍。五衣中若离一一衣。异处宿经一夜。除僧羯磨。尼萨耆波逸提

若比丘尼衣已竟。迦絺那衣已舍。若得非时衣。欲须便受。受已疾疾成衣。若足者善。若不足者。得畜一月。为满足故。若过畜者尼萨耆波逸提

若比丘尼。从非亲里居士居士妇乞衣。除余时尼萨耆波逸提。是中时者。若夺衣失衣烧衣漂衣。是名时

若比丘尼夺衣失衣烧衣漂衣是非亲里居士若居士妇自恣请多与衣。是比丘尼当知足受衣。若过者尼萨耆波逸提

若居士居士妇。为比丘尼办衣价。具如是衣价与某甲比丘尼。是比丘尼先不受自恣请。到居士家作如是说。善哉居士。为我办如是如是衣价与我。为好故。若得衣者尼萨耆波逸提

若二居士居士妇。与比丘尼办衣价。我曹办如是衣价。与某甲比丘尼。是比丘尼先不受自恣请。到二居士家作如是言。善哉居士。办如是如是衣价。与我共作一衣。为好故。若得衣尼萨耆波逸提

若比丘尼。若王若大臣。若婆罗门。若居士居士妇。遣使为比丘尼送衣价。持如是衣价。与某甲比丘尼。彼使至比丘尼所语言。阿姨。为汝送衣价受取。是比丘尼语彼使如是言。我不应受此衣价。我若须衣。合时清净当受。彼使语比丘尼言。阿姨。有执事人不须衣比丘尼言有。若僧伽蓝民。若优婆塞。此是比丘尼执事人。常为比丘尼执事。彼使至执事人所与衣价已。还到比丘尼所如是言。阿姨所示某甲执事人。我已与衣价。大姊。知时往彼当得衣。比丘尼若须衣者。当往彼执事人所二反三反语言。我须衣。若二反三反为作忆念。得衣者善。若不得衣。四反五反六反在前默然住。令彼忆念。若四反五反六反在前默然住。得衣者善。若不得衣。过是求得衣者。尼萨耆波逸提。若不得衣。随使所来处。若自往若遣使往。语言。汝先遣使持衣价。与某甲比丘尼。是比丘尼竟不得。汝还取莫使失。此是时

若比丘尼自取金银若钱。若教人取若口可受。尼萨耆波逸提

若比丘尼种种买卖宝物者。尼萨耆波逸提

若比丘尼种种贩卖者。尼萨耆波逸提

若比丘尼。钵减五缀不漏。更求新钵为好故。尼萨耆波逸提。是比丘尼当持此钵于尼众中舍。从次第贸至下坐。以下坐钵与此比丘尼言。妹持此钵乃至破。此是时

若比丘尼自求缕使。非亲里织师织作衣者。尼萨耆波逸提

若比丘尼居士居士妇。使织师为比丘尼织作衣。彼比丘尼先不受自恣请。便往到彼所语织师言。此衣为我织。极好织令广长坚致。齐整好我当少多与汝价。若比丘尼与价。乃至一食得衣者尼萨耆波逸提

若比丘尼与比丘尼衣已。后嗔恚。若自夺若教人夺取。还我衣来不与汝。是比丘尼应还衣。彼取衣者尼萨耆波逸提

若诸病比丘尼畜药酥油生酥蜜石蜜得食。残宿乃至七日得服。若过七日服。尼萨耆波逸提

若比丘尼十日未满夏三月。若有急施衣。比丘尼知是急施衣应受。受已乃至衣时应畜。若过畜者尼萨耆波逸提

若比丘尼知物向僧。自求入己者尼萨耆波逸提

若比丘尼欲索是更索彼者。尼萨耆波逸提

若比丘尼知檀越所为僧施。异回作余用者。尼萨耆波逸提

若比丘尼所为施物。异自求为僧。回作余用者。尼萨耆波逸提

若比丘尼檀越所施物。异回作余用者。尼萨耆波逸提

若比丘尼檀越所为施物。异自求为僧。回作余用者。尼萨耆波逸提

若比丘尼畜长钵。尼萨耆波逸提

若比丘尼多畜好色器者。尼萨耆波逸提

若比丘尼。许他比丘尼病衣。后不与者。尼萨耆波逸提

若比丘尼。以非时衣受作时衣者。尼萨耆波逸提

若比丘尼与比丘尼贸易衣。后嗔恚。还自夺取。若使人夺。妹还我衣来。我不与汝。汝衣属汝。我衣还我者。尼萨耆波逸提

若比丘尼乞重衣。齐价直四张[疊*毛]。过者尼萨耆波逸提

若比丘尼欲乞轻衣。极至价直两张半[疊*毛]。过者尼萨耆波逸提

诸大姊。我已说三十尼萨耆波逸提法。今问。诸大姊。是中清净不(如是至三)

诸大姊。是中清净。默然故。是事如是持

诸大姊。是一百七十八波逸提法。半月半月说戒经中来

若比丘尼。故妄语者波逸提

若比丘尼。毁訾语波逸提

若比丘尼两舌语波逸提

若比丘尼。与男子同室宿者。波逸提

若比丘尼。共未受戒女人同一室宿。若过三宿。波逸提

若比丘尼。与未受具戒人。共诵法者。波逸提

若比丘尼。知他有粗恶罪。向未受大戒人说。除僧羯磨。波逸提

若比丘尼。向未受大戒人。说过人法言。我知是我见是。实者波逸提

若比丘尼。与男子说法过五六语。除有智女人。波逸提

若比丘尼。自掘地。若教人掘者。波逸提

若比丘尼坏鬼神村者。波逸提

若比丘尼。妄作异语恼他者。波逸提

若比丘尼。嫌骂者。波逸提

若比丘尼。取僧绳床。若木床若卧具坐褥。露地自敷若教人敷。舍去不自举不教人举者。波逸提

若比丘尼。于僧房中取僧卧具。自敷若教人敷。在中若坐若卧。从彼处舍去。不自举不教人举者。波逸提

若比丘尼知比丘尼先住处。后来于中间。强敷卧具止宿。念言。彼若嫌迮者。自当避我去。作如是因缘非余非威仪。波逸提

若比丘尼。嗔他比丘尼不喜。众僧房中自牵出。若教人牵出者。波逸提

若比丘尼。若在重阁上。脱脚绳床若木床。若坐若卧。波逸提

若比丘尼。知水有虫。自用浇泥若草。若教人浇者。波逸提

若比丘尼作大房。户扉窗牖及余庄饰具。指授覆苫齐二三节。若过者波逸提

若比丘尼。施一食处。无病比丘尼应一食。若过受者波逸提

若比丘尼。别众食。除余时波逸提。余时者。病时作衣时。若施衣时。道行时。船上时。大会时。沙门施食时。此是时

若比丘尼。至檀越家。殷勤请与饼糗食。比丘尼欲须者。二三钵应受。持至寺内。分与余比丘尼食。若比丘尼无病。过三钵受。持至寺中。不分与余比丘尼食者。波逸提

若比丘尼。非时食者。波逸提

若比丘尼。残宿食啖者。波逸提

若比丘尼。不受食。及药着口中。除水及杨枝。波逸提

若比丘尼先受请已。若前食后食行诣余家。不嘱余比丘尼。除余时波逸提。余时者。病时作衣时施衣时。此是时

若比丘尼食家中有宝。强安坐者。波逸提

若比丘尼。食家中有宝。在屏处坐者。波逸提

若比丘尼。独与男子露地一处共坐者。波逸提

若比丘尼。语比丘尼如是言。大姊。共汝至聚落。当与汝食。彼比丘尼竟不教与是比丘尼食。如是言。大姊去。我与汝一处共坐共语不乐。我独坐独语乐。以是因缘非余方便遣去。波逸提

若比丘尼。四月与药。无病比丘尼应受。若过受除常请更请分请尽形请。波逸提

若比丘尼。往观军阵。除时因缘。波逸提

若比丘尼。有因缘至军中。若二宿三宿。过者波逸提

若比丘尼。军中若二宿三宿。或时观军阵斗战。若观游军象马势力。波逸提

若比丘尼。饮酒者。波逸提

若比丘尼。水中戏者。波逸提

若比丘尼。以指相击擽者。波逸提

若比丘尼。不受谏者。波逸提

若比丘尼。恐他比丘尼者。波逸提

若比丘尼半月洗浴。无病比丘尼应受。若过受。除余时波逸提余时者。热时病时作时。大风时雨时。远行来时。此是时

若比丘尼无病。为炙身故露地然火。若教人然。除余时波逸提

若比丘尼。藏他比丘尼若钵若衣若坐具针筒。自藏教人藏。下至戏笑波逸提

若比丘尼。净施比丘比丘尼式叉摩那沙弥沙弥尼衣。后不问主。取著者波逸提

若比丘尼。得新衣。当作三种染坏色。青黑木兰若比丘尼得新衣。不作三种染坏色青黑木兰。新衣持者波逸提

若比丘尼。故断畜生命者。波逸提

若比丘尼。知水有虫。饮用者波逸提

若比丘尼。故恼他比丘尼。乃至少时不乐。波逸提

若比丘尼知比丘尼有粗罪。覆藏者波逸提

若比丘尼。知僧诤事如法忏悔已。后更发举者波逸提

若比丘尼。知是贼伴。共一道行乃至一聚落。波逸提

若比丘尼作如是语。我知佛所说法。行淫欲非是障道法。彼比丘尼谏此比丘尼言。大姊。莫作是语。莫谤世尊。谤世尊者不善。世尊不作是语。世尊无数方便说。淫欲是障道法。犯淫者是障道法彼比丘尼谏此比丘尼时。坚持不舍。彼比丘尼乃至三谏。令舍是事。乃至三谏时舍者善。不舍者波逸提

若比丘尼。知如是语人未作法如是恶邪不舍。若畜同一羯磨同一止宿。波逸提

若沙弥尼作如是言。我知佛所说法。行淫欲非障道法。彼比丘尼谏此沙弥尼言。汝莫作是语。莫诽谤世尊。诽谤世尊不善。世尊不作是语。沙弥尼。世尊无数方便说。淫欲是障道法。犯淫欲者是障道法。彼比丘尼谏此沙弥尼时。坚持不舍。彼比丘尼应乃至三呵谏。舍此事故。乃至三谏时若舍者善。不舍者彼比丘尼。应语是沙弥尼言。汝自今已去非佛弟子。不得随余比丘尼如诸沙弥尼得与比丘尼二宿。汝今无是事。汝出去灭去。不须此中住。若比丘尼知如是被摈沙弥尼。若畜共同止宿。波逸提

若比丘尼。如法谏时作如是语。我今不学是戒。乃至问有智慧持律者当难问。波逸提。若为求解。应当难问

若比丘尼说戒时如是语。大姊。用是杂碎戒为。说是戒时。令人恼愧怀疑。轻毁戒故。波逸提

若比丘尼说戒时作如是语。大姊。我今始知是戒半月半月说戒经来。余比丘尼知是比丘尼。若二若三说戒中坐。何况多。彼比丘尼无知无解。若犯罪应如法治。更重增无知法。大姊。汝无利得不善。汝说戒时。不用心念。不一心摄耳听法。彼无知故。波逸提

若比丘尼共同羯磨已。后作如是说。诸比丘尼随亲厚。以众僧物与者。波逸提

若比丘尼僧断事时。不与欲而起去者。波逸提

若比丘尼与欲竟。后更呵者波逸提

若比丘尼。比丘尼共斗诤。后听此语已。欲向彼说。波逸提

若比丘尼嗔恚故不喜。打彼比丘尼者。波逸提

若比丘尼。嗔恚故不喜。以手搏比丘尼者。波逸提

若比丘尼嗔恚故不喜。以无根僧伽婆尸沙法谤者。波逸提

若比丘尼。刹利水浇头王。王未出未藏宝。若入宫过门阈者。波逸提

若比丘尼。宝及宝庄饰具。自捉若教人捉。除僧伽蓝中及寄宿处。波逸提。若僧伽蓝中。若寄宿处。若宝若以宝庄饰具。自捉若教人捉。若识者当取。如是因缘非余

若比丘尼。非时入聚落。不嘱比丘尼。波逸提

若比丘尼。作绳床若木床。足应高佛八指。除入梐孔上。若截竟过者。波逸提

若比丘尼。持兜罗绵[袖-由+宁]。作绳床木床若卧具坐具。波逸提

若比丘尼。啖蒜者。波逸提

若比丘尼。剃三处毛者。波逸提

若比丘尼。以水作净。应齐两指各一节。若过者波逸提

若比丘尼。以胡胶作男根。波逸提

若比丘尼。共相拍者。波逸提

若比丘尼。比丘无病时供给水。以扇扇者。波逸提

若比丘尼。乞生谷者。波逸提

若比丘尼。在生草上大小便。波逸提

若比丘尼夜大小便器中。昼不看墙外弃者。波逸提

若比丘尼往观看伎乐者波逸提

若比丘尼入村内与男子在屏处。共立共语。波逸提

若比丘尼与男子共入屏障处者波逸提

若比丘尼入村内巷陌中。遣伴远去。在屏处与男子共立耳语者。波逸提

若比丘尼入白衣家内坐。不语主人舍去者。波逸提

若比丘尼入白衣家内。不语主人辄坐床座者。波逸提

若比丘尼入白衣家内。不语主人辄自敷坐宿者。波逸提

若比丘尼与男子。共入闇室中者。波逸提

若比丘尼不审谛受师语。便向人说波逸提

若比丘尼有小因缘事。便咒诅。堕三恶道不生佛法中。若我有如是事。堕三恶道不生佛法中。若汝有如是事。亦堕三恶道不生佛法中。波逸提

若比丘尼共斗诤。不善忆持诤事。捶胸啼哭者波逸提

若比丘尼无病。二人共床卧波逸提

若比丘尼共一蓐同一被卧。除余时波逸提

若比丘尼知先住后至。知后至先住。为恼故。在前诵经问义教授者。波逸提

若比丘尼同活比丘尼病。不瞻视者波逸提

若比丘尼安居。初听余比丘尼在房中安床。后嗔恚驱出者。波逸提

若比丘尼春夏冬一切时人间游行。除余因缘者波逸提

若比丘尼夏安居讫。不去者波逸提

若比丘尼边界有疑恐怖处。人间游行者。波逸提

若比丘尼于界内有疑恐怖处。在人间游行者。波逸提

若比丘尼亲近居士居士儿。共住作不随顺行。余比丘尼谏此比丘尼言。妹汝莫亲近居士居士儿。共住作不随顺行。大姊可别住。若别住。于佛法中有增益安乐住。彼比丘尼谏此比丘尼时。坚持不舍。彼比丘尼应三谏。舍此事故。乃至三谏舍此事善。若不舍者波逸提

若比丘尼。往观王宫文饰画堂园林浴池者。波逸提

若比丘尼露身形。在河水泉水流水池水中浴者。波逸提

若比丘尼作浴衣。应量作。应量作者。长佛六磔手。广二磔手半。若过者波逸提

若比丘尼缝僧伽梨过五日。除难事起。波逸提

若比丘尼过五日。不看僧伽梨。波逸提

若比丘尼与众僧衣。作留难者波逸提

若比丘尼不问主便着他衣者波逸提

若比丘尼持沙门衣。施与外道白衣者。波逸提

若比丘尼作如是意。众僧如法分衣。遮令不分。恐弟子不得者。波逸提

若比丘尼作如是意。令众僧今不得出迦絺那衣。后当出。欲令五事久得放舍。波逸提

若比丘尼作如是意。遮比丘尼僧。不出迦絺那衣。欲令久得五事放舍。波逸提

若比丘尼。余比丘尼语言。为我灭此诤事。而不与作方便令灭者。波逸提

若比丘尼自手持食。与白衣及外道食者。波逸提

若比丘尼为白衣作使者。波逸提

若比丘尼自手纺缕者。波逸提

若比丘尼入白衣舍内。在小床大床上若坐若卧。波逸提

若比丘尼至白衣舍。语主人敷座止宿。明日不辞主人而去。波逸提

若比丘尼诵习世浴咒术者。波逸提

若比丘尼教人诵习咒术者。波逸提

若比丘尼知女人妊娠。度与受具足戒者。波逸提

若比丘尼知妇女乳儿。与受具足戒者。波逸提

若比丘尼知年不满二十。与受具足戒。波逸提

若比丘尼。年十八童女。不与二岁学戒。年满二十。便与受具足戒者波逸提

若比丘尼年十八童女。与二岁学戒。不与六法。满二十便与受具足戒者。波逸提

若比丘尼年十八童女。与二岁学戒。与六法满二十。众僧不听。便与受具足戒者。波逸提

若比丘尼度曾嫁妇女年十岁。与二岁学戒。年满十二听与受具足戒。若减十二与受具足戒者。波逸提

若比丘尼度他小年曾嫁妇女。与二岁学戒。年满十二。不白众僧便与受具足戒。波逸提

若比丘尼知如是人。与受具足戒者。波逸提

若比丘尼多度弟子。不教二岁学戒。不以二法摄取。波逸提

若比丘尼不二岁随和上尼者。波逸提

若比丘尼。僧不听而授人具足戒者。波逸提

若比丘尼年未满十二岁。授人具足戒者。波逸提

若比丘尼年满十二岁。众僧不听。便授人具足戒者。波逸提

若比丘尼。僧不听授人具足戒。便言。众僧有爱有恚有怖有痴。欲听者便听。不欲听者便不听。波逸提

若比丘尼父母夫主不听。与受具足戒者。波逸提

若比丘尼。知女人与童男男子相敬爱愁忧嗔恚女人。度令出家授具足戒者。波逸提

若比丘尼语式叉摩那言。汝妹舍是学是。当与汝受具足戒。若不方便与受具足戒。波逸提

若比丘尼语式叉摩那言。持衣来与我。我当与汝受具足戒。而不方便与受具足戒者。波逸提

若比丘尼不满一岁。授人具足戒者。波逸提

若比丘尼。与人受具足戒已。经宿方往比丘僧中。与受具足戒者。波逸提

若比丘尼不病。不往受教授者。波逸提

若比丘尼半月。应往比丘僧中求教授。若不求者波逸提

若比丘尼僧夏安居竟。应往比丘僧中说三事自恣见闻疑。若不者波逸提

若比丘尼在无比丘处夏安居者。波逸提

若比丘尼知有比丘僧伽蓝。不白而入者。波逸提

若比丘尼骂比丘者波逸提

若比丘尼喜斗诤。不善忆持诤事。后嗔恚不喜。骂比丘尼众者。波逸提

若比丘尼。身生痈及种种疮。不白众及余人。辄使男子破若裹者。波逸提

若比丘尼先受请。若足食已后。食饭糗干饭鱼及肉者。波逸提

若比丘尼于家生嫉妒心。波逸提

若比丘尼以香涂摩身者。波逸提

若比丘尼以胡麻滓。涂摩身者波逸提

若比丘尼使比丘尼涂摩身者。波逸提

若比丘尼使式叉摩那涂摩身者。波逸提

若比丘尼使沙弥尼涂摩身者。波逸提

若比丘尼使白衣妇女涂摩身者。波逸提

若比丘尼着[袖-由+宁]髁衣者。波逸提

若比丘尼畜妇女庄严身具。除时因缘波逸提

若比丘尼着革屣持盖行。除时因缘波逸提

若比丘尼无病乘乘行。除时因缘波逸提

若比丘尼不着僧祇支入村者。波逸提

若比丘尼。向暮至白衣家。先不被唤。波逸提

若比丘尼向暮开僧伽蓝门。不嘱授余比丘尼而出者。波逸提

若比丘尼。日没开僧伽蓝门。不嘱授而出者。波逸提

若比丘尼不前安居。不后安居者。波逸提

若比丘尼知女人常漏。大小便涕唾常出。与受具足戒。波逸提

若比丘尼知二形人。与受具足戒者。波逸提

若比丘尼知二道合者。与受具足戒波逸提

若比丘尼知有负债难病难与受具足戒。波逸提

若比丘尼学世俗伎术。以自活命。波逸提

若比丘尼。以世俗伎术。教授白衣。波逸提

若比丘尼被摈不去者。波逸提

若比丘尼欲问比丘义。先不求而问者。波逸提

若比丘尼。知先住后至后至先住。欲恼彼故。在前经行若立若坐若卧者。波逸提

若比丘尼知有比丘僧伽蓝内起塔。者波逸提

若比丘尼见新受戒比丘。应起迎逆恭敬礼拜问讯请与坐。不者除因缘波逸提

若比丘尼为好故。摇身趋行者。波逸提

若比丘尼作妇女庄严。香涂摩身。波逸提

若比丘尼使外道女香涂摩身。波逸提

诸大姊。我已说一百七十八波逸提法。今问

诸大姊。是中清净不(如是至三)诸大姊。是中清净。默然故。是事如是持

诸大姊。是八波罗提提舍尼法。半月半月说戒经中来

若比丘尼不病。乞酥食者。犯应忏悔可呵法。应向余比丘尼说言。大姊。我犯可呵法所不应为。我今向大姊忏悔。是名悔过法

若比丘尼不病。乞油食者。犯应忏悔可呵法。应向余比丘尼说言。大姊。我犯可呵法所不应为。我今向大姊忏悔。是名悔过法

若比丘尼不病。乞蜜食者。犯应忏悔可呵法。应向余比丘尼说言。大姊。我犯可呵法所不应为。我今向大姊忏悔。是名悔过法

若比丘尼不病。乞黑石蜜食者。犯应忏悔可呵法。应向余比丘尼说言。大姊。我犯可呵法所不应为。我今向大姊忏悔。是名悔过法

若比丘尼不病。乞乳食者。犯应忏悔可呵法。应向余比丘尼说言。大姊。我犯可呵法所不应为。我今向大姊忏悔。是名悔过法

若比丘尼不病。乞酪食者。犯应忏悔可呵法。应向余比丘尼说言。大姊。我犯可呵法所不应为。我今向大姊忏悔。是名悔过法

若比丘尼不病。乞鱼食者。犯应忏悔可呵法。应向余比丘尼说言。大姊。我犯可呵法所不应为。我今向大姊忏悔。是名悔过法

若比丘尼不病。乞肉食者。犯应忏悔可呵法。应向余比丘尼说言。大姊。我犯可诃法所不应为。我今向大姊忏悔。是名悔过法

诸大姊。我已说八波罗提提舍尼法。今问诸大姊。是中清净不(如是至三)

诸大姊。是中清净。默然故。是事如是持

诸大姊。此众学戒法。半月半月说戒经中来

当齐整着涅槃僧应当学

当齐整着三衣应当学

不得反抄衣行入白衣舍应当学

不得反抄衣入白衣舍坐应当学

不得衣缠颈入白衣舍应当学

不得衣缠颈入白衣舍坐应当学

不得覆头入白衣舍应当学

不得覆头入白衣舍坐应当学

不得跳行入白衣舍应当学

不得跳行入白衣舍坐应当学

不得白衣舍内蹲坐应当学

不得叉腰行入白衣舍应当学

不得叉腰行入白衣舍坐应当学

不得摇身行入白衣舍应当学

不得摇身行入白衣舍坐应当学

不得掉臂行入白衣舍应当学

不得掉臂行入白衣舍坐应当学

好覆身入白衣舍应当学

好覆身入白衣舍坐应当学

不得左右顾视行入白衣舍应当学

不得左右顾视行入白衣舍坐应当学

静默入白衣舍应当学

静默入白衣舍坐应当学

不得戏笑行入白衣舍应当学

不得戏笑行入白衣舍坐应当学

用意受食应当学

平钵受食应当学

平钵受羹应当学

羹饭等食应当学

以次食应当学

不得挑钵中而食应当学

若比丘尼不病。不得自为己索羹饭。应当学

不得以饭覆羹更望得应当学

不得视比坐钵中食应当学

当系钵想食应当学

不得大抟饭食应当学

不得大张口待饭食应当学

不得含饭语应当学

不得抟饭遥掷口中应当学

不得遗落饭食应当学

不得颊食食应当学

不得嚼饭作声食应当学

不得大噏饭食应当学

不得舌舐食应当学

不得振手食应当学

不得手把散饭食应当学

不得污手捉饮器应当学

不得洗钵水弃白衣舍内应当学

不得生草叶上大小便涕唾。除病应当学

不得净水中大小便涕唾。除病应当学

不得立大小便。除病应当学

不得与反抄衣不恭敬人说法。除病应当学

不得为衣缠颈者说法。除病应当学

不得为覆头者说法。除病应当学

不得为裹头者说法。除病应当学

不得为叉腰者说法。除病应当学

不得为着革屣者说法。除病应当学

不得为着木屐者说法。除病应当学

不得为骑乘者说法。除病应当学

不得在佛塔中止宿。除为守护故应当学

不得藏财物置佛塔中。除为坚牢故应当学

不得着革屣入佛塔中应当学

不得手捉革屣入佛塔中应当学

不得着革屣绕佛塔行应当学

不得着富罗入佛塔中应当学

不得手捉富罗入佛塔中应当学

不得塔下坐食留草及食污地应当学

不得担死尸从塔下过应当学

不得塔下埋死尸应当学

不得在塔下烧死尸应当学

不得向佛塔烧死尸应当学

不得佛塔四边烧死尸使臭气来入应当学

不得持死人衣及床从塔下过。除浣染香薰应当学

不得佛塔下大小便应当学

不得向佛塔大小便应当学

不得绕佛塔四边大小便使臭气来入应当学

不得持佛像至大小便处应当学

不得在佛塔下嚼杨枝应当学

不得向佛塔嚼杨枝应当学

不得佛塔四边嚼杨枝应当学

不得在佛塔下涕唾应当学

不得向佛塔涕唾应当学

不得塔四边涕唾应当学

不得向塔舒脚坐应当学

不得安佛塔在下房己在上房住应当学

人坐己立。不得为说法。除病应当学

人卧己坐。不得为说法。除病应当学

人在坐己在非坐。不得为说法。除病应当学

人在高坐己在下坐。不得为说法。除病应当学

人在前己在后。不得为说法。除病应当学

人在高经行处。己在下经行处。不应为说法。除病应当学

人在道己在非道。不应为说法。除病应当学

不得携手在道行应当学

不得上树过人头。除时因缘应当学

不得络囊盛钵贯杖头着肩上而行应当学

人持杖不恭敬。不应为说法。除病应当学

人持剑。不应为说法。除病应当学

人持鉾。不应为说法。除病应当学

人持刀。不应为说法。除病应当学

人持盖。不应为说法。除病应当学

诸大姊。我已说众学戒法。今问诸大姊。是中清净不(如是三说)

诸大姊。是中清净。默然故。是事如是持

诸大姊。是七灭诤法。半月半月说戒经中来

若比丘尼有诤事起。即应除灭

应与现前毗尼。当与现前毗尼

应与忆念毗尼。当与忆念毗尼

应与不痴毗尼。当与不痴毗尼

应与自言治。当与自言治

应与多人语。当与多人语

应与觅罪相。当与觅罪相

应与如草覆地。当与如草覆地

诸大姊。我已说七灭诤法。今问诸大姊。是中清净不(如是三说)

诸大姊。是中清净。默然故。是事如是持

诸大姊。我已说戒经序。已说八波罗夷法。已说十七僧伽婆尸沙法。已说三十尼萨耆波逸提法。已说一百七十八波逸提法。已说八波罗提提舍尼法。已说众学戒法。已说七灭诤法。此是佛所说。半月半月说戒经中来

若更有余佛法。是中皆共和合。应当学

  忍辱第一道　　佛说无为最
  出家恼他人　　不名为沙门

此是毗婆尸如来无所著等正觉。说是戒经

  譬如明眼人　　能避险恶道
  世有聪明人　　能远离诸恶

此是尸弃如来无所著等正觉。说是戒经

  不谤亦不嫉　　当奉持于戒
  饮食知止足　　常乐在空闲
  心定乐精进　　是名诸佛教

此是毗叶罗如来无所著等正觉。说是戒经

  譬如蜂采花　　不坏色与香
  但取其味去　　比丘入聚然
  不违戾他事　　不观作不作
  但自观身行　　若正若不正

此是拘楼孙如来无所著等正觉。说是戒经

  心莫作放逸　　圣法当勤学
  如是无忧愁　　心定入涅槃

此是拘那含牟尼如来无所著等正觉。说是戒经

  一切恶莫作　　当奉行诸善
  自净其志意　　是则诸佛教

此是迦叶如来无所著等正觉。说是戒经

  善护于口言　　自净其志意
  身莫作诸恶　　此三业道净
  能得如是行　　是大仙人道

此是释迦牟尼如来无所著等正觉。于十二年中。为无事僧说是戒经。从是已后广分别说。诸比丘尼。自为乐法乐沙门者。有惭有愧乐学戒者。当于中学

  明人能护戒　　能得三种乐
  名誉及利养　　死得生天上
  当观如是处　　有智勤护戒
  戒净有智慧　　便得第一道
  如过去诸佛　　及以未来者
  现在诸世尊　　能胜一切忧
  皆共尊敬戒　　此是诸佛法
  若有自为身　　欲求于佛道
  当尊重正法　　此是诸佛教
  七佛为世尊　　灭除诸结使
  说是七戒经　　诸缚得解脱
  已入于涅槃　　诸戏永灭尽
  尊行大仙说　　圣贤称誉戒
  弟子之所行　　入寂灭涅槃
  世尊涅槃时　　兴起于大悲
  集诸比丘众　　与如是教诫
  莫谓我涅槃　　净行者无护
  我今说戒经　　亦善说毗尼
  我虽般涅槃　　当视如世尊
  此经久住世　　佛法得炽盛
  以是炽盛故　　得入于涅槃
  若不持此戒　　如所应布萨
  喻如日没时　　世界皆闇冥
  当护持是戒　　如[犛-未+牙]牛爱尾
  和合一处坐　　如佛之所说
  我已说戒经　　众僧布萨竟
  我今说戒经　　所说诸功德
  施一切众生　　皆共成佛道

四分比丘尼戒本


四分僧戒本(昙无德出

    No. 1430 [No. 1429; cf. No. 1428]

四分僧戒本(昙无德出)

        后秦世罽宾三藏佛陀耶舍译

  稽首礼诸佛　　及法比丘僧
  今演毗尼法　　令正法久住
  戒如海无崖　　如宝求无厌
  欲护圣法财　　众集听我说
  欲除四弃法　　及灭僧残法
  障三十舍堕　　众集听我说
  毗婆尸式弃　　毗舍拘留孙
  拘那含牟尼　　迦叶释迦文
  诸世尊大德　　为我说是事
  我今欲善说　　诸贤咸共听
  譬如人毁足　　不堪有所涉
  毁戒亦如是　　不得生天人
  欲得生天上　　若生人间者
  常当护戒足　　勿令有毁损
  如御入险道　　失辖折轴忧
  毁戒亦如是　　死时怀恐惧
  如人自照镜　　好丑生欣戚
  说戒亦如是　　全毁生忧喜
  如两阵共战　　勇怯有进退
  说戒亦如是　　净秽生安畏
  世间王为最　　众流海为最
  众星月为最　　众圣佛为最
  一切众律中　　戒经为上最
  如来立禁戒　　半月半月说

和合僧集会。未受大戒者出。不来诸比丘说欲及清净。谁遣比丘尼来受教诫。僧今和合。何所作为(答言说戒羯磨)大德僧听。今僧十五日布萨说戒。若僧时到僧忍听。和合说戒。白如是。诸大德。我今欲说戒。众集现前。默然听善思念之。若有犯者当发露。无犯者默然。默然故。当知僧清净。若有他举者。即应如实答。如是诸比丘在于众中乃至三唱。忆念有罪当发露。不发露者。得故妄语罪。佛说故妄语是障道法。彼比丘自忆念知有罪。欲求清净当发露。发露则安隐。不发露罪益深。诸大德。我已说戒经序。今问诸大德。是中清净不(如是三说)诸大德。是中清净。默然故。是事如是持

诸大德。是四弃法。半月半月戒经中说。若比丘与比丘共戒同戒。不舍戒戒羸不自悔。犯不净行。行淫欲法。乃至共畜生。是比丘波罗夷不共住

若比丘在聚落中。若闲静处。不与物怀盗心取。随不与取法。若为王王大臣所捉。若杀若缚若驱出国。汝是贼汝痴汝无所知。比丘如是盗者。波罗夷不共住

若比丘故自手断人命。持刀授与人。叹誉死快劝死。咄男子用此恶活为。宁死不生。作如是心。思惟种种方便。叹誉死快劝死。是比丘波罗夷不共住

若比丘实无所知。自称言。我得上人法。我已入圣智胜法。我知是我见是。彼于异时。若问若不问。欲自清净故。作如是说。我实不知不见言知言见。虚诳妄语。除增上慢。是比丘波罗夷不共住

诸大德。我已说四波罗夷法。若比丘犯一一波罗夷法。不得与诸比丘共住。如前后亦如是。是比丘得波罗夷罪不应共住。今问诸大德。是中清净不(如是三说)

诸大德。是中清净。默然故。是事如是持

诸大德。是十三僧伽婆尸沙法。半月半月戒经中说。若比丘。故弄阴出精。除梦中。僧伽婆尸沙若比丘淫欲意。与女人身相触。若捉手若捉发。若触一一身分者。僧伽婆尸沙

若比丘淫欲意。与女人淫欲粗恶语。随所说淫欲粗恶语者。僧伽婆尸沙

若比丘淫欲意。于女人前自叹身言。大姊。我修梵行持戒。精进修善法。可持此淫欲法供养我。如是供养第一最。如是语者僧伽婆尸沙

若比丘往来彼此媒嫁。持男意语女。持女意语男。若为成妇事。若为私通。乃至须臾顷。僧伽婆尸沙

若比丘自乞作屋。无主自为己。当应量作。是中量者。长佛十二磔手。内广七磔手。应将余比丘往看处所。彼比丘当指示处所。无难处无妨处。若比丘有难处妨处。自乞作屋。无主自为己。不将余比丘往看处所。若过量作者。僧伽婆尸沙

若比丘欲作大房。有主为己作。应将余比丘往看处所。彼比丘应看处所。无难处无妨处。若比丘难处妨处作大房。有主为己作。不将余比丘往看处所者。僧伽婆尸沙

若比丘以嗔恚所覆故。非波罗夷比丘。以无根波罗夷法谤。欲坏彼比丘净行。彼于异时。若问若不问。知此事无根说。我嗔恚故作是语。若比丘作是语者。僧伽婆尸沙

若比丘以嗔恚所覆故。于异分事中取片。非波罗夷比丘。以无根波罗夷法谤。欲坏彼比丘净行。彼于异时。若问若不问。知是异分事中取片。是比丘自言。我嗔恚故作是语者。僧伽婆尸沙

若比丘欲坏和合僧。方便受坏和合僧法。坚持不舍。彼比丘应谏是比丘言。大德。莫坏和合僧。莫方便坏和合僧。莫受破僧法坚持不舍。大德。应与僧和合欢喜不诤。同一师学如水乳合。于佛法中有增益安乐住。是比丘如是谏时。坚持不舍。彼比丘应三谏。舍是事故。乃至三谏舍者善。若不舍者僧伽婆尸沙

若比丘有余群党。若一若二若三乃至无数。彼比丘语是比丘言。大德。莫谏此比丘。此比丘是法语比丘律语比丘。此比丘所说我等心喜乐。此比丘所说我等心忍可。彼比丘应谏是比丘言。大德。莫作是说言。此比丘是法语比丘律语比丘。此比丘所说我等心喜乐。此比丘所说我等心忍可。何以故。此比丘非法语比丘非律语比丘。大德。莫欲坏和合僧。汝等当乐欲和合僧。大德。与僧和合欢喜不诤。同一师学如水乳合。于佛法中者增益安乐住。是比丘如是谏时。坚持不舍。彼比丘应三谏。舍是事故。乃至三谏舍者善。若不舍者僧伽婆尸沙

若比丘依聚落。若城邑住。行恶行污他家。行恶行亦见亦闻。污他家亦见亦闻。诸比丘语是比丘言。大德。汝行恶行污他家。行恶行亦见亦闻。污他家亦见亦闻。大德。汝行恶行污他家。今可远此村落去。不须住此。是比丘语彼比丘言。大德。诸比丘有爱有恚有怖有痴。有如是同罪比丘。有驱者有不驱者。诸比丘报言。大德。莫作是语言。诸比丘有爱有恚有怖有痴。有如是同罪比丘。有驱者有不驱者。何以故。诸比丘不爱不恚不怖不痴。大德。汝行恶行污他家。行恶行亦见亦闻。污他家亦见亦闻。是比丘如是谏时。坚持不舍。彼比丘应三谏。舍是事故。乃至三谏舍者善。若不舍者僧伽婆尸沙

若比丘恶性不受人谏语。于戒法中诸比丘如法谏已。自身不受谏语言。诸大德。莫向我说若好若恶。我亦不向诸大德说若好若恶。诸大德止莫谏我。彼比丘谏是比丘言。大德。莫自身不受谏语。大德。自身当受谏语。大德。如法谏诸比丘。诸比丘亦如法谏大德。如是佛弟子众得增益。展转相谏。展转相教。展转忏悔。是比丘如是谏时。坚持不舍。彼比丘应三谏。舍是事故。乃至三谏舍者善。若不舍者僧伽婆尸沙

诸大德。我已说十三僧伽婆尸沙法。九初犯罪四乃至三谏若比丘犯一一法。知而覆藏。应强与波利婆沙行波利婆沙竟。僧应与六夜摩那埵。行摩那埵已。余有出罪。应二十僧中出是比丘罪。若少一人不满二十众。出是比丘罪。是比丘罪不得除。诸比丘亦可呵。此是时今问诸大德。是中清净不(如是三说)

诸大德。是中清净。默然故。是事如是持

诸大德。是二不定法。半月半月戒经中说若比丘共女人。独在静处覆处可作淫处坐。说非法语。有住信优婆夷。于三法中一一法说。若波罗夷若僧伽婆尸沙若波逸提。是坐比丘自言。我犯是罪于三法中应一一治。若波罗夷若僧伽婆尸沙若波逸提。如住信优婆夷所说。应如法治是比丘是名不定法

若比丘共女人。在不覆处不可作淫处坐。作粗恶语说淫欲事。有住信优婆夷。于二法中一一法说。若僧伽婆尸沙若波逸提。是坐比丘自言。我犯是罪。于二法中应一一治。若僧伽婆尸沙若波逸提。如住信优婆夷所说。应如法治是比丘。是名不定法

诸大德。我已说二不定法。今问诸大德。是中清净不(如是三说)

诸大德。是中清净。默然故。是事如是持

诸大德。是三十尼萨耆波逸提法。半月半月戒经中说。若比丘衣已竟。迦絺那衣已出。畜长衣经十日不净施得持。若过者尼萨耆波逸提

若比丘衣已竟。迦絺那衣已出。比丘于三衣中。若离一一衣。异处宿经一夜。除僧羯磨。尼萨耆波逸提

若比丘衣已竟。迦絺那衣已出。若比丘得非时衣。欲须便受。受已疾疾成衣。若足者善。若不足者得畜经一月。为满足故。若过者尼萨耆波逸提

若比丘从非亲里比丘尼边取衣。除贸易。尼萨耆波逸提

若比丘使非亲里比丘尼浣故衣。若染若打。尼萨耆波逸提

若比丘从非亲里居士若居士妇乞衣。除余时尼萨耆波逸提余时者。若比丘夺衣失衣烧衣漂衣。此是时

若比丘夺衣失衣烧衣漂衣。是非亲里居士若居士妇。自恣请多与衣。是比丘当知足受衣。若过受者尼萨耆波逸提

若比丘居士居士妇。为比丘办衣价。持如是衣价。与某甲比丘。是比丘先不受自恣请。便到居士家作如是说。善哉居士。为我办如是衣价与我。为好故。若得衣者尼萨耆波逸提

若比丘二居士居士妇。与比丘办如是衣价。我曹办如是衣价。与某甲比丘。是比丘先不受自恣请。到二居士家作如是说。善哉居士。办如是衣与我共作一衣。为好故。若得者尼萨耆波逸提

若比丘若王王大臣若婆罗门。若居士居士妇。遣使为比丘送衣价。持如是衣价与某甲比丘。彼使至比丘所语比丘言。大德。今为汝故送是衣价受取。是比丘语彼使如是言。我今不应受此衣价。若我须衣合时清净当受。彼使语是比丘言。大德。有执事人不。须衣比丘应言。有若守僧伽蓝民。若优婆塞。此是比丘执事人。常为诸比丘执事。彼使诣执事人所。与衣价已还到比丘所。作如是言。大德所示某甲执事人。我已与衣价竟。大德。知时往彼当得衣。须衣比丘当往执事人所。若二反三反语言。我须衣。若二反三反为作忆念。得衣者善。若不得衣。四反五反六反在前默然住。令彼忆念。若四反五反六反在前默然住。若得衣者善。若不得衣过是求得衣者。尼萨耆波逸提。若不得衣。从彼所来处。若自往若遣使往语言。汝先遣使送衣价。与某甲比丘。是比丘竟不得衣。汝还取莫使失。此是时(十事)

若比丘杂野蚕绵作卧具者。尼萨耆波逸提

若比丘新纯黑羺羊毛作卧具者。尼萨耆波逸提

若比丘作新卧具。应用二分纯黑羊毛。三分白四分牻。若比丘作新卧具。不用二分纯黑羊毛三分白四分牻。作新卧具者。尼萨耆波逸提

若比丘作新卧具。应六年持。若减六年不舍故。更作新者。除僧羯磨。尼萨耆波逸提

若比丘作新坐具。当取故者纵广一磔手帖新者上。为坏色故。若比丘作新坐具。不取故者纵广一磔手帖新者上坏色者。尼萨耆波逸提

若比丘行道中得羊毛。比丘须者应取。若无人持。得自持行至三由旬。若无人持自持过者。尼萨耆波逸提

若比丘使非亲里比丘尼浣染擘羊毛者。尼萨耆波逸提

若比丘自手取金银若钱。若教人取。若口可受者。尼萨耆波逸提

若比丘种种卖买金银宝物者。尼萨耆波逸提

若比丘种种贩卖者。尼萨耆波逸提(二十事)

若比丘畜长钵。不净施得齐十日。若过者尼萨耆波逸提

若比丘破钵。减五缀不漏。更求新钵。为好故。若得者尼萨耆波逸提。彼比丘应往僧中舍。展转取最下钵与之令持。乃至破

若比丘自乞缕。使非亲里织师织作衣者。尼萨耆波逸提

若比丘居士居士妇。使织师为比丘织作衣。是比丘先不受自恣请。便到彼所语织师言。此衣为我织。极好织令广长。坚致齐整好。我少多与汝价。若比丘与价乃至一食直。若得衣者尼萨耆波逸提

若比丘先与比丘衣。后嗔恚。若自夺若使人夺取。还我衣来不与汝。是比丘应还衣。取衣者尼萨耆波逸提

若比丘病。畜酥油生酥蜜石蜜。齐七日得服。若过者尼萨耆波逸提

若比丘春残一月在。应求雨浴衣半月用浴。若比丘春一月前求雨浴衣。半月前用浴者。尼萨耆波逸提

若比丘十日未满夏三月。若有急施衣应受。受已乃至衣时应畜。若过畜者。尼萨耆波逸提

若比丘夏三月安居竟。至八月十五日满已。若迥远有疑恐怖畏难处。比丘在如是处住。于三衣中。若留一一衣置村舍内。及有因缘离衣宿。乃至六夜。若过者尼萨耆波逸提

若比丘知他欲与僧物。自回入已者。尼萨耆波逸提(三十事)

诸大德。我已说三十尼萨耆波逸提法。今问诸大德。是中清净不(如是三说)

诸大德是中清净。默然故。是事如是持

诸大德。是九十波逸提法。半月半月戒经中说

若比丘故妄语者波逸提

若比丘种类毁訾比丘者波逸提

若比丘两舌语者波逸提

若比丘与女人同室宿者波逸提

若比丘与未受大戒人。共宿过二夜。至三夜晓者。波逸提

若比丘与未受具戒人同诵者波逸提

若比丘知他比丘有粗恶罪。向未受大戒人说。除僧羯磨波逸提

若比丘向未受大戒人。说过人法言。我知是我见是。见知实者波逸提

若比丘与女人说法。过五六语者。波逸提。除有知男子

若比丘自手掘地。教人掘者波逸提(一十)

若比丘坏鬼神村者波逸提

若比丘妄作异语。恼他者波逸提

若比丘嫌骂者波逸提

若比丘取僧绳床木床卧具坐褥。露地自敷教人敷舍去。不自举不教人举者波逸提

若比丘僧房舍内。敷僧卧具坐褥。若自敷教人敷。在中若坐若卧。从彼舍去。不自举不教人举者波逸提

若比丘先知比丘住处。后来于其中间。强敷卧具止宿。念言。彼若嫌迮者。当自避我去。作是因缘非余威仪者。波逸提

若比丘嗔他比丘不喜僧房。舍内若自牵出。若教人牵出。波逸提

若比丘房重阁上。脱脚绳床木床。若坐若卧。波逸提

若比丘知水有虫。自用浇泥浇草。教人浇者波逸提

若比丘欲作大房。户扉窗牖及诸庄饰具。指授覆苫齐二三节。若过者波逸提(二十)

若比丘僧不差。教授比丘尼者。波逸提

若比丘为僧差。教授比丘尼。乃至日没波逸提

若比丘语诸比丘如是言。诸比丘为饮食故。教授比丘尼者。波逸提

若比丘与非亲里比丘尼衣。除贸易波逸提

若比丘与非亲里比丘尼作衣者。波逸提

若比丘与比丘尼。在屏处坐者波逸提

若比丘与比丘尼。期同道行乃至聚落。除余时波逸提。余时者。若伴行有疑恐怖处。此是时若比丘与比丘尼。期乘船若上水若下水。除直渡者波逸提

若比丘知比丘尼赞叹因缘得食食。除施主先有意者波逸提

若比丘与妇人。期同道行乃至聚落者。波逸提(三十)

若比丘施一食处。无病比丘应受一食。若过者波逸提

若比丘展转食。除余时波逸提。余时者。病时施衣时。此是时

若比丘别众食。除余时波逸提。余时者。病时施衣时。作衣时道行时。船行时大会时。沙门施食时。此是时

若比丘至檀越家。殷勤请与饼糗饭。比丘须者应两三钵受。持至寺内。应分与余比丘食。若比丘无病。过两三钵受。持至寺内。不分与余比丘食者。波逸提

若比丘足食竟。或时受请。不作余食法。更食者波逸提

若比丘知他比丘足食竟。若受请不作余食法。殷勤请与食。大德取是食。以是因缘非余。欲使他犯者波逸提

若比丘非时食者波逸提

若比丘食残宿食者波逸提

若比丘不受食食。若药举着口中。除水及杨枝。波逸提

若比丘得好美食乳酪鱼肉。无病自为己索者。波逸提(四十)

若比丘外道男外道女。自手与食者波逸提

若比丘先受请已。若前食后食行诣余家。不嘱余比丘。除余时波逸提。余时者。病时作衣时施衣时。此是时

若比丘食家中有宝。强安坐者波逸提

若比丘食家中有宝。屏处坐者波逸提

若比丘独与女人。露地坐者波逸提

若比丘语诸比丘如是语。大德。共至聚落当与汝食。彼比丘乃至聚落竟。不教与是比丘食。语言。汝去。我与汝共坐共语不乐。我独坐独语乐。以是因缘非余。方便遣去者波逸提

若比丘请四月与药。无病比丘应受。若过受。除常请更请分请尽形请者。波逸提

若比丘往观军阵。除时因缘波逸提

若比丘有因缘至军中。若过二宿。至三宿者波逸提

若比丘军中住。若二宿三宿。或时观军阵斗战。或观游军象马势力者。波逸提(五十)

若比丘饮酒者波逸提

若比丘水中戏者波逸提

若比丘以指击擽他比丘者波逸提

若比丘不受谏者波逸提

若比丘恐怖他比丘者波逸提

若比丘半月洗浴。无病比丘应受。若过受。除余时波逸提。余时者。热时病时作时。风时雨时。远行来时。此是时

若比丘无病。为炙身故露地然火。若教人然。除余时波逸提

若比丘藏他比丘衣钵坐具针筒。若自藏若教人藏。下至戏笑者。波逸提

若比丘净施比丘比丘尼式叉摩那沙弥沙弥尼衣。不问主辄著者波逸提

若比丘得新衣。当作三种染坏色青黑木兰

若比丘得新衣。不作三种染坏色青黑木兰。新衣持者波逸提(六十)

若比丘故断畜生命者波逸提

若比丘知水有虫。饮用者波逸提

若比丘故恼他比丘。乃至少时不乐者。波逸提

若比丘知他比丘有粗恶罪。而覆藏者波逸提

若比丘年满二十。当与受具足戒。若比丘知年未满二十。与受具足戒。此人不得戒。诸比丘亦可呵彼愚痴故。波逸提

若比丘知僧诤事起如法灭已。后更发举者。波逸提

若比丘知是贼伴。期共一道行。乃至聚落者。波逸提

若比丘作如是语。我知佛所说法。行淫欲非障道法。彼比丘应谏是比丘言。大德莫作是语莫谤世尊。谤世尊者不善。世尊不作是语。世尊无数方便说。行淫欲是障道法。彼比丘如是谏时坚持不舍。彼比丘应三谏。舍是事故。乃至三谏舍者善若不舍者波逸提

若比丘知如是语人未作法如是恶见不舍。若畜同止宿同。一羯磨者波逸提

若比丘知沙弥作如是语。我知佛所说法。行淫欲非障道法。彼比丘谏此沙弥言。汝莫作是语。莫谤世尊。谤世尊者不善。世尊不作是语。沙弥。世尊无数方便说。行淫欲是障道法。彼比丘如是谏时坚持不舍。彼比丘应三谏。舍此事故。乃至三谏舍者善。若不舍者彼比丘应语此沙弥言。汝自今已后。非佛弟子。不得随余比丘行。如诸余沙弥。得与大比丘二宿三宿。汝今无此事。汝出去灭去。不须此中住。若比丘知如是被摈沙弥。若畜同一止宿波逸提(七十)

若比丘余比丘如法谏时。作如是语。我不学此戒。乃至问有智慧持戒律者。我当难问。波逸提。欲求解者应当难问

若比丘说戒时作如是语。大德。何用此杂碎戒为。说是戒时。令人恼愧怀疑。轻呵戒故。波逸提

若比丘说戒时。作如是语。大德。我今始知是法是戒经。半月半月戒经中说。若余比丘知是比丘。若二若三说戒中坐何况多。彼比丘无知无解若犯罪应如法治。更增无知罪。大德。汝无利得不善。汝说戒时。不一心念摄耳听法。彼无知故。波逸提

若比丘共同羯磨已。后如是语。诸比丘随亲厚。以僧物与者。波逸提

若比丘僧断事时不与欲。而起去者波逸提

若比丘与欲已。后更呵者波逸提

若比丘知他比丘共斗诤。听此语已向彼说者。波逸提

若比丘嗔故不喜打他比丘者波逸提

若比丘嗔故不喜。以手搏比丘者波逸提

若比丘嗔故不喜以无根僧伽婆尸沙法谤者。波逸提(八十)

若比丘刹利水浇头王。王未出未藏宝。若入过宫门阈者波逸提

若比丘若宝及宝庄饰具。若自捉教人捉。除僧伽蓝中及寄宿处。波逸提。若在僧伽蓝中。若寄宿处。若宝及宝庄饰具。若自捉若教人捉识者当取如是因缘非余

若比丘非时入聚落。不嘱余比丘者波逸提

若比丘作绳床木床。足应高如来八指。除入梐孔上。截竟过者波逸提

若比丘持兜罗绵贮。作绳床木床卧具坐褥者。波逸提

若比丘用骨牙角作针筒。成者波逸提

若比丘作尼师檀。当应量作。是中量者。长佛二磔手。广一磔手半。更增广长各半磔手。若过者波逸提

若比丘作覆疮衣。当应量作。是中量者。长佛四磔手。广二磔手。若过成者波逸提

若比丘作雨浴衣。当应量作。是中量者。长佛六磔手。广二磔手半。若过成者波逸提

若比丘佛衣等量作衣。是中量者。长佛十磔手。广六磔手。是佛衣量。若过成者波逸提(九十)

诸大德。我已说九十波逸提法。今问诸大德。是中清净不(如是三说)诸大德。是中清净。默然故。是事如是持

诸大德。是四波罗提提舍尼法。半月半月戒经中说

若比丘入村中。无病从非亲里比丘尼边自手受食食。是比丘应向余比丘悔过言。大德。我犯可呵法所不应为。我今向大德悔过。是名悔过法

若比丘在白衣家食。是中有比丘尼指示。与某甲羹与某甲饭。诸比丘应语彼比丘尼如是言。大姊。且止须诸比丘食竟。若无一比丘语彼比丘尼如是言。大姊。且止须诸比丘食竟。是比丘应向余比丘悔过言。大德。我犯可呵法所不应为。我今向大德悔过。是名悔过法

有诸学家。僧作学家羯磨。若比丘知是学家。先不受请。无病自手受食食。是比丘应向余比丘悔过言。大德。我犯可呵法所不应为。我今向大德悔过。是名悔过法

若阿练若迥远有疑恐怖处。若比丘在如是阿练若处住。先不语檀越。僧伽蓝外不受食。在僧伽蓝内无病自手受食食。是比丘应向余比丘悔过言。大德。我犯可呵法所不应为。我今向大德悔过。是名悔过法

诸大德。我已说四波罗提提舍尼法。今问诸大德。是中清净不(如是三说)诸大德。是中清净。默然故。是事如是持

诸大德是众多学法。半月半月戒经中说

齐整着内衣应当学

齐整着三衣应当学

不得反抄衣入白衣舍坐应当学

不得反抄衣入白衣舍坐应当学

不得衣缠颈入白衣舍应当学

不得衣缠颈入白衣舍坐应当学

不得覆头入白衣应当学

不得覆头入白衣舍坐应当学

不得跳行入白衣舍应当学

不得跳行入白衣舍坐应当学(一十)

不得蹲坐白衣舍应当学

不得叉腰入白衣舍应当学

不得叉腰入白衣舍坐应当学

不得摇身入白衣舍应当学

不得摇身入白衣舍坐应当学

不得掉臂入白衣舍应当学

不得掉臂入白衣舍坐应当学

好覆身入白衣舍应当学

好覆身入白衣舍坐应当学

不得左右顾视入白衣舍应当学(二十)

不得左右顾视入白衣舍坐应当学

静默入白衣舍应当学

静默入白衣舍坐应当学

不得戏笑入白衣舍应当学

不得戏笑入白衣舍坐应当学

正意受食应当学

平钵受饭应当学

平钵受羹应当学

羹饭俱食应当学

以次食应当学(三十)

不得挑钵中央食应当学

无病不得为己索羹饭应当学

不得以饭覆羹上更望得应当学

不得视比坐钵中起慊心应当学

当系钵想食应当学

不得大揣饭食应当学

不得大张口待饭食应当学

不得含食语应当学

不得揣饭摇掷口中食应当学

不得遗落饭食应当学(四十)

不得颊饭食应当学

不得故嚼饭作声食应当学

不得噏饭食应当学

不得舌舐食应当学

不得振手食应当学

不得手把散饭食应当学

不得污手捉食器应当学

不得洗钵水弃白衣舍内应当学

不得生草上大小便涕唾。除病应当学

不得净水中大小便涕唾。除病应当学(五十)

不得立大小便。除病应当学

不得与反抄衣人说法。除病应当学

不得为衣缠颈人说法。除病应当学

不得为覆头人说法。除病应当学

不得为裹头人说法。除病应当学

不得为叉腰人说法。除病应当学

不得为着革屣人说法。除病应当学

不得为着木屐人说法。除病应当学

不得为骑乘人说法。除病应当学

不得佛塔内宿。除为守视应当学(六十)

不得佛塔内藏财物。除为坚牢故应当学

不得着革屣入佛塔中应当学

不得捉革屣入佛塔中应当学

不得着革屣绕佛塔行应当学

不得着富罗入佛塔中应当学

不得捉富罗入佛塔中应当学

不得佛塔下食留草及食污地舍去应当学

不得担死尸从佛塔下过应当学

不得塔下埋死尸应当学

不得塔下烧死尸应当学(七十)

不得向塔烧死尸应当学

不得绕塔四边烧死尸使臭气来入应当学

不得持死人衣从塔下过。除为浣染香薰应当学

不得塔下大小便应当学

不得向塔大小便应当学

不得绕佛塔四边大小便使臭气来入应当学

不得持佛像至大小便处应当学

不得塔下嚼杨枝应当学

不得向塔嚼杨枝应当学

不得绕塔四边嚼杨枝应当学(八十)

不得塔下涕唾应当学

不得向塔涕唾应当学

不得绕塔四边涕唾应当学

不得向佛塔舒脚坐应当学

不得安佛像在下房己在上房住应当学

人坐己立。不得为说法。除病应当学

人卧己坐。不得为说法。除病应当学

人在座己在非座。不得为说法。除病应当学

人在高座己在下座。不得为说法。除病应当学

人在前己在后。不得为说法。除病应当学(九十)

人在高经行处。己在下经行处。不得为说法。除病应当学

人在道己在非道。不得为说法。除病应当学

不得携手在道行应当学

不得上树过人头。除时因缘应当学

不得络囊盛钵贯杖头置肩上行应当学

人持杖。不应为说法。除病应当学

人持剑。不应为说法。除病应当学

人持鉾。不应为说法。除病应当学

人持刀。不应为说法。除病应当学

人持盖。不应为说法。除病应当学(一百)

诸大德。我已说众学法。今问诸大德。是中清净不(如是三说)诸大德。是中清净。默然故。是事是持

诸大德。是七灭诤法。半月半月戒经中说

若比丘有诤事起。即应除灭

应与现前毗尼

当与现前毗尼

应与忆念毗尼

当与忆念毗尼

应与不痴毗尼

当与不痴毗尼

应与自言治

当与自言治

应与觅罪相

当与觅罪相

应与多觅罪相

当与多觅罪相

应与如草布地

当与如草布地

诸大德我已说七灭诤法。今问诸大德。是中清净不(如是三说)诸大德。是中清净。默然故。是事如是持

诸大德。我已说戒经序。已说四波罗夷法。已说十三僧伽婆尸沙法。已说二不定法。已说三十尼萨耆波逸提法。已说九十波逸提法。已说四波罗提提舍尼法。已说众学法。已说七灭诤法。此是佛所说戒经。半月半月说戒经中来。若更有余佛法。是中皆共和合应当学

  忍辱第一道　　佛说无为最
  出家恼他人　　不名为沙门

此是毗婆尸如来无所著等正觉。说是戒经

  譬如明眼人　　能避险恶道
  世有聪明人　　能远离诸恶

此是尸弃如来无所著等正觉。说是戒经

  不谤亦不嫉　　常奉于戒行
  饮食知止足　　常乐在空闲
  心定乐精进　　是名诸佛教

此是毗叶罗如来无所著等正觉。说是戒经

  譬如蜂采华　　不坏色与香
  但取其味去　　比丘入聚落
  不违戾他事　　不观作不作
  但自观身行　　若正若不正

此是拘留孙如来无所著等正觉。说是戒经

  心莫作放逸　　圣法当勤学
  如是无忧愁　　心定入涅槃

此是拘那含牟尼如来无所著等正觉。说是戒经

  一切恶莫作　　当奉行诸善
  自净其志意　　是则诸佛教

此是迦叶如来无所著等正觉。说是戒经

  善护于口言　　自净其志意
  身莫作诸恶　　此三业道净
  能得如是行　　是大仙人道

此是释迦牟尼如来无所著等正觉。于十二年中。为无事僧说是戒经。从是已后广分别说。诸比丘。自为乐法乐沙门者。有惭有愧乐学戒者。当于中学

  明人能护戒　　能得三种乐
  名誉及利养　　死得生天上
  当观如是处　　有智勤护戒
  戒净有智慧　　便得第一道
  如过去诸佛　　及以未来者
  现在诸世尊　　能胜一切忧
  皆共尊敬戒　　此是诸佛法
  若有自为身　　欲求于佛道
  当尊重正法　　此是诸佛教
  七佛为世尊　　灭除诸结使
  说是七戒经　　诸缚得解脱
  已入于涅槃　　诸戏永灭尽
  尊行大仙说　　圣贤称誉戒
  弟子之所行　　入寂灭涅槃
  世尊涅槃时　　兴起于大悲
  集诸比丘众　　与如是教诫
  莫谓我涅槃　　净行者无护
  我今说戒经　　亦善说毗尼
  我虽般涅槃　　当视如世尊
  此经久住世　　佛法得炽盛
  以是炽盛故　　得入于涅槃
  若不持此戒　　如所应布萨
  喻如日没时　　世界皆闇冥
  当护持是戒　　如[犛-未+牙]牛爱尾
  和合一处坐　　如佛之所说
  我已说戒经　　众僧布萨竟
  我今说戒经　　所说诸功德
  施一切众生　　皆共成佛道

四分僧戒本


昙无德律部杂羯磨

    No. 1432 [Nos. 1433, 1434; cf. No. 1428]

昙无德律部杂羯磨(四分)

        曹魏天竺三藏康僧铠译

    诸结戒法第一

结戒场文(两界不得并。若欲大界内安戒场者。先竖戒场四方内相外相。相去一肘。使人唱。内一周竟言。此是内相彼为外相。如是第二第三唱。众中堪能羯磨者结。不得受欲。以未结界故)

大德僧听。此住处比丘某甲。唱四方小界相。若僧时到僧忍听。僧今于此四方小界相内。结作戒场。白如是。大德僧听。此住处比丘某甲。唱四方小界相。僧今于此四方小界相内。结作戒场。谁诸长老忍僧于此四方小界相内结作戒场者默然。谁不忍者说。僧已忍于此四方小界相内结作戒场竟。僧忍默然故。事如是持是

结大戒文(应次结大界。先标榜四方大界定相。墙周外不用远。喜妨布萨人三唱。众中堪使羯磨者结。亦不得受欲以未结界故)

大德僧听。此住处比丘某甲。唱四方大界相。若僧时到僧忍听。僧今于此四方大界相内结大界。同一住处同一说戒。白如是

大德僧听。此住处比丘某甲。唱四方大界相。僧今于此四方大界相内结大界。同一住处同一说戒。谁诸长老忍僧于此四方大界相内结大界同一住处同一说戒者默然。谁不忍者说。僧已忍于此四方大界相内同一住处同一说戒结大界竟。僧忍默然故。是事如是持

结不失衣界文(不失衣界更无别相。依大界相结故言此住处)

大德僧听。此住处同一住处同一说戒。若僧时到僧忍听。僧今结不失衣界。除村村外界。白如是。大德僧听。此住处同一住处同一说戒。僧今结不失衣界。除村村外界。谁诸长老忍僧于此住处同一住处同一说戒结不失衣界除村村外界者默然。谁不忍者说。僧已忍同一住处同一说戒结不失衣界除村村外界竟。僧忍默然故。是事如是持(若二界相近。应留中间。不得相接。若欲解界。应先解不失衣界却解大界。不得隔驶流水。或时能断渡。除常有桥梁耳)

解不失衣界文

大德僧听。此住处比丘。同一住处同一说戒。若僧时到僧忍听。僧今解不失衣界。白如是

大德僧听。此住处比丘。同一住处同一说戒。僧今解不失衣界。谁诸长老忍僧同一住处同一说戒解不失衣界者默然。谁不忍者说。僧已忍同一住处同一说戒解不失衣界竟。僧忍默然故。是事如是持

解大界文

大德僧听。此住处比丘。同一住处同一说戒。若僧时到僧忍听。今解大界。白如是

大德僧听。此住处比丘同一住处同一说戒。僧今解大界。谁诸长老忍僧同一住处同一说戒解大界者默然。谁不忍者说。僧已忍同一住处同一说戒解大界竟。僧忍默然故。是事如是持

解戒场文

大德僧听。今有尔所比丘集若僧时到僧忍听。僧今解此处戒场。白如是。大德僧听。今有尔许比丘集。僧今解此处戒场。谁诸长老忍。僧解此处戒场者默然。谁不忍者说。僧已忍解此处戒场竟僧忍默然故。是事如是持布萨日及自恣日在道行若不和合结坐处小界文

大德僧听诸比丘。坐处已满。齐如是比丘坐处。若僧时到僧忍听。僧今于此坐处结小界白如是

大德僧听齐如是比丘坐处。僧今于此坐处结小界。谁诸长老忍。僧齐如是比丘。坐处结小界者默然谁不忍者说。僧已忍齐如是比丘坐处结小界竟。僧忍默然故。是事如是持

即还解此小界文

大德僧听。齐如是比丘坐处若僧时到僧忍听。僧今解此坐处小界。白如是。大德僧听。齐如是比丘坐处。僧今解此坐处小界谁诸长老忍僧齐如是比丘坐处解此坐处小界者默然。谁不忍者说。僧已忍齐如是比丘坐处解此坐处小界竟。僧忍默然故。是事如是持

    受戒法第二

度沙弥法(若欲在僧伽蓝中剃发。当白一切僧。若不和合。房房语令知已。在剃发和合当作白。白已然后与剃发。当作如是白)

大德僧听此某甲。欲求某甲剃发。若僧时到僧忍听。与某甲剃发。白如是(若僧伽蓝中度令出家。当白一切僧。白已听与出家。当作如是白)大德僧听。此某甲。从某甲求出家。若僧时到僧忍听与某甲出家。白如是(作如是白已。与出家教使着袈裟。偏露右肩脱革屣右膝着地合掌。当教如是语)我某甲尽形寿。归依佛归依法归依僧。随佛出家。某甲为和上。如来至真等正觉。是我世尊(第二第三亦如是说)我某甲。归依佛归依法归依僧。随佛出家竟。某甲为和上。如来至真等正觉。是我世尊(第二第三亦如是说当受戒)尽形寿不得杀生。是沙弥戒能持不(答言能)尽形寿不得盗。是沙弥戒能持不(答言能)尽形寿不得淫是沙弥戒能持不(答言能)尽形寿不得妄语。是沙弥戒能持不(答言能)尽形寿不得饮酒。是沙弥戒。能持不(答言能)尽形寿不得着花鬘香油涂身。是沙弥戒。能持不(答言能)尽形寿不得歌舞倡伎及往观听。是沙弥戒。能持不(答言能)尽形寿不得高大床上坐。是沙弥戒。能持不(答言能)尽形寿不得非时食。是沙弥戒。能持不(答言能)尽形寿不得捉持生象严饰宝物。是沙弥戒能持不(答言能)此是沙弥十戒。尽形寿不得犯。汝已受戒竟。当供养三宝。佛宝法宝比丘僧宝。勤修三业。坐禅诵经劝佐众事

请和上文

大德一心念。我某甲。请大德为和上。愿大德。为我作和上。我依大德故。得受具足戒(第二第三亦如是说。和上应语言可尔。若言好尔众僧应安欲受具足者离闻处着见处时戒师应问)众中谁能为某甲作教授师(若有者答言。我能。戒师应作白)大德僧听。此某甲。从某甲求受具足戒若僧时到僧忍听。某甲作教授师。白如是(教授师应往受戒人所问言)此安陀会郁多罗僧僧伽梨钵。是衣钵是汝有不(答言是。应语言)善男子听。今是真实诚时。实言实。不实当言不实。汝曾作比丘不。若言作。持戒清净不。如法还戒不。不犯净行尼不。不贼心受戒不。不破内外道不。非黄门不。不杀父杀母杀阿罗汉破僧不。汝非非人不。非畜生不。非二根不。汝字何等。和上字谁。年满二十未。三衣钵具不。父母听汝不。汝不负债不。汝非奴不。汝非官人不。汝是丈夫不。丈夫有如是病。癞痈疽白癞干痟癫狂病。汝有如是病不(答言无。应语言)如我今问汝。僧中亦当如是问。如汝向者答我。僧中亦当如是答(教授师如是问已。还僧中如常威仪。至舒手及处立。应作如是白)大德僧听。此某甲。从某甲求受具足戒。若僧时到僧忍听。我问已听将来。白如是(教授师应唤受戒人言。汝来。来已为捉衣钵教礼僧足已。在戒师前长跪合掌。教授应教乞戒。作如是乞)大德僧听。我某甲。从某甲求受具足戒。我某甲。今从僧乞受具足戒。和上某甲。愿僧济度我。慈愍故(第二第三亦如是说。时戒师应作白)大德僧听。此某甲。从某甲求受具足戒。此某甲。今从僧乞受具足戒。和上某甲。若僧时到僧忍听。我问内法。白如是

善男子听。今是真诚时实语时。随所问汝。汝当随实答。汝曾作比丘不。若言作。持戒清净不。如法还戒不。不犯净行尼不。不贼心受戒不。不破内外道不。非黄门不。不杀父杀母杀阿罗汉破僧不。汝非非人不。非畜生不。非二根不。汝字何等。和上字谁。年满二十未。三衣钵具不。父母听汝不。汝不负债不。汝非奴不。汝非官人不。汝是丈夫不。丈夫有如是病。癞痈疽白癞干痟颠狂。汝有如是病不(若言无。应作四羯白磨也)大德僧听。此某甲。从某甲求受具足戒。此某甲。今从僧乞受具足戒。和上某甲。自说清净无诸难事。年满二十三衣钵具。若僧时到僧忍听。僧今授某甲具足戒。和上某甲。白如是

大德僧听。此某甲。从某甲求受具足戒。此某甲。今从僧乞受具足戒。和上某甲。自说清净无诸难事。年满二十三衣钵具。僧今授某甲具足戒。和上某甲。谁诸长老忍僧与某甲受具足戒和上某甲者默然。谁不忍者说。是初羯磨(第二第三亦如是说)僧已忍与某甲受具足戒竟。和上某甲僧忍默然故。是事如是持。善男子听。如来无所著等正觉。说四波罗夷法若比丘犯一一法。非沙门非释种子。汝一切不得犯淫欲作不净行。若比丘犯淫欲作不净行乃至共畜生非沙门非释种子。汝是中尽形寿不得作。能持不(答言能)一切不得盗乃至草叶。若比丘盗人五钱若过五钱。若自取教人取。自斫教人斫。自破教人破。若烧若埋若坏色。非沙门非释种子汝是中尽形寿不得。作能持不(答言能)一切不得故断众生命。乃至蚁子。若比丘故自手断人命。持刀授与人教死赞死劝死。与人非药。若堕胎若厌祷杀。自作方便若教人作。非沙门非释种子。汝是中尽形寿不得作。能持不(答言能)一切不得妄语乃至戏笑。若比丘不真实非己有。自称言得上人法。得禅得解脱得定得四空定。得须陀洹果斯陀含果阿那含果阿罗汉果。言天来龙来鬼神来供养。非沙门非释种子。汝是中尽形寿不得作。能持不(答言能)善男子听。如来无所著等正觉。说四依法比丘出家依是。出家人法依粪扫衣。是比丘出家人法是中尽形寿能持不(答言能)若得长利。檀越送衣割截衣。三种坏色衣。亦得受依乞食。是比丘出家人法。是中尽形寿能持不(答言能)若得长利。若僧差食檀越送食。月八日食。十五日食。月初日食。众僧常食。檀越请食得受。依树下坐是比丘出家人法是中尽形寿能持不(答言能)若得长利。别房尖头屋。小房石室。两房一户得受。依腐烂药是比丘出家人法。是中尽形寿能持不(答言能)若得长利。酥油生酥蜜石蜜。得受。汝已受戒竟。白四羯磨如法成就得处所。和上如法。阿阇梨如法。众僧具足。当善受教法。应劝化作福治塔供养众僧。和上阿阇梨一切如法教。不得违逆。应学问诵经勤求方便。于佛法中得须陀洹果斯陀含果阿那含果阿罗汉果。汝始发心出家。功不唐捐果报不断余所未知。当问和上阿阇梨(应令受戒人在前去)

受衣钵文

长老一心念。此僧伽梨若干条割截成。今受持不离宿(第二第三亦如是说余二衣亦如是受)

长老一心念。此钵多罗应量器。今受持常用故(第二第三亦如是说)

请依止文

大德一心念。我某甲。请大德为依止阿阇梨。愿大德。为我作依止阿阇梨。我依大德故得住(第二第三亦如是说师应言)莫放逸。若言好。若言去。弟子答言尔

    诸除罪法第三

乞覆藏羯磨文

大德僧听。我比丘某甲。犯僧残罪覆藏。我比丘某甲。犯僧残罪随覆藏日。今从僧乞覆藏羯磨。愿僧。与我随覆藏日羯磨。慈愍故(第二第三亦如是说)

与覆藏羯磨文

大德僧听。比丘某甲。犯僧残罪覆藏。此比丘某甲犯僧残罪随覆藏日。从僧乞覆藏羯磨。若僧时到僧忍听。僧今与比丘某甲。随覆藏日羯磨。白如是。大德僧听。比丘某甲。犯僧残罪覆藏。此比丘某甲。犯僧残罪随覆藏日。从僧乞覆藏羯磨。僧今与比丘某甲随覆藏日羯磨。谁诸长老忍僧与比丘某甲随覆藏日羯磨者默然。谁不忍者说。是初羯磨(第二第三亦如是说)僧已忍与比丘某甲随覆藏日羯磨竟。僧忍默然故。是事如是持(行覆藏者。有八事失宿。一一事皆得突吉罗罪。何等八。往余寺不白。有客比丘来不白。有余事出外不白。寺内余行者不白。病不遣信者白。一二三人共室宿。无比丘处住。不半月半月说戒时白。是为八事失宿。佛听半月半月说戒时白。应如是白。彼行覆藏者。应至僧中偏露右肩脱革屣右膝着地合掌白言)

大德僧听。我比丘某甲。犯僧残罪覆藏。我比丘某甲。犯僧残罪随覆藏日。从僧乞覆藏羯磨。僧已与我随覆藏日羯磨。我比丘某甲。已行若干日。未行若干日。白大德僧。令知我行覆藏

乞摩那埵羯磨文

大德僧听。我比丘某甲。犯僧残罪覆藏。我比丘某甲。犯僧残罪随覆藏日已从僧乞覆藏羯磨。僧已与我随覆藏日羯磨。我比丘某甲。行覆藏竟。今从僧乞六夜摩那埵羯磨。愿僧与我六夜摩那埵羯磨。慈愍故(第二第三亦如是说)

与摩那埵羯磨文

大德僧听。比丘某甲。犯僧残罪覆藏。此比丘某甲犯僧残罪随覆藏日。已从僧乞覆藏羯磨。僧已与比丘某甲随覆藏日羯磨。此比丘某甲行覆藏竟。今从僧乞六夜摩那埵羯磨。若僧时到僧忍听。今与比丘某甲六夜摩那埵羯磨。白如是

大德僧听。比丘某甲。犯僧残罪覆藏。此比丘某甲。犯僧残罪随覆藏日。已从僧乞覆藏羯磨。僧已与比丘某甲随覆藏日羯磨。此比丘某甲。行覆藏竟。今从僧乞六夜摩那埵羯磨。僧今与比丘某甲六夜摩那埵羯磨。谁诸长老忍僧与比丘某甲六夜摩那埵羯磨者默然。谁不忍者说。是初羯磨(第二第三亦如是说)僧已忍与比丘某甲六夜摩那埵羯磨竟。僧忍默然故。是事如是持(佛言听摩那埵比丘亦行如上诸事。行摩那埵时界内宿。常有僧日日应如是偏露右肩脱革屣右膝着地合掌白言)大德僧听。我比丘某甲。犯僧残罪覆藏。我比丘某甲。犯僧残罪随覆藏日。从僧乞覆藏羯磨。僧已与我随覆藏日羯磨。我比丘某甲。行覆藏竟。今从僧乞六夜摩那埵羯磨。僧已与我六夜摩那埵羯磨。我比丘某甲。已行若干日。未行若干日。白大德僧。令知我行摩那埵

乞出罪羯磨文

大德僧听。我比丘某甲。犯僧残罪覆藏。我比丘某甲。犯僧残罪随覆藏日。已从僧乞覆藏羯磨。僧已与我随覆藏日羯磨。我比丘某甲。行覆藏竟。从僧乞六夜摩那埵羯磨。僧已与我六夜摩那埵羯磨。我比丘某甲。行六夜摩那埵竟。今从僧乞出罪羯磨。愿僧与我出罪羯磨。慈愍故(第二第三亦如是说)

与出罪羯磨文

大德僧听。比丘某甲。犯僧残罪覆藏。此比丘某甲。犯僧残罪随覆藏日。已从僧乞覆藏羯磨。僧已与比丘某甲随覆藏日羯磨。此比丘某甲。行覆藏竟。从僧乞六夜摩那埵羯磨。僧已与比丘某甲六夜摩那埵羯磨。此比丘某甲。行六夜摩那埵竟。今从僧乞出罪羯磨。若僧时到僧忍听。僧今与比丘某甲出罪羯磨。白如是

大德僧听。比丘某甲。犯僧残罪覆藏。此比丘某甲。犯僧残罪随覆藏日。已从僧乞覆藏羯磨。僧已与比丘某甲随覆藏日羯磨。此比丘某甲。行覆藏竟。从僧乞六夜摩那埵羯磨。僧已与比丘某甲六夜摩那埵羯磨。此比丘某甲。行六夜摩那埵竟。今从僧乞出罪羯磨僧今与比丘某甲出罪羯磨。谁诸长老忍僧与比丘某甲出罪羯磨者默然。谁不忍者说。是初羯磨(第二第三亦如是说)僧已忍与比丘某甲出罪羯磨竟。僧忍默然故。是事如是持

犯舍堕衣于僧中舍文(舍与僧时往僧中偏露右肩脱革屣向上坐礼胡跪合掌作如是言)

大德僧听。我比丘某甲。故畜尔许长衣。过十日犯舍堕。今舍与僧(舍衣竟即入僧中忏悔)

僧中忏悔文(礼僧中已右膝着地合掌作如是白)

大德僧听。我比丘某甲。故畜尔许长衣。过十日犯舍堕。此衣已舍与僧。罪今从僧忏悔(第二第三亦如是说。即僧中至一比丘前。应作如是言)大德。受我忏悔。彼答言。可尔

僧中受忏悔白文(受忏悔者当作如是白言)

大德僧听。此比丘某甲。故畜尔许长衣。过十日犯舍堕。今舍与僧。若僧时到僧忍听。我受比丘某甲忏悔。白如是(作如是白已应受忏悔)

即僧中一人前忏悔文

大德一心念。我比丘某甲。故畜尔许长衣。过十日犯舍堕。此衣已舍与僧。罪今从大德忏悔不敢覆藏。忏悔则安乐。不忏悔不安乐。忆念犯发露。知而不覆藏。大德忆念。我清净戒身具足。清净布萨(第二第三亦如是说。说已受忏悔者应语如是言)自责汝心生厌离答。言尔

僧还此比丘衣羯磨文

大德僧听。比丘某甲。故畜尔许长衣。过十日犯舍堕。今与僧。若僧时到僧忍听。僧今持此衣还此比丘某甲。白如是

大德僧听。比丘某甲。故畜尔许长衣。过十日犯舍堕。今舍与僧。僧今持此衣还此比丘某甲。谁诸长老忍僧持此衣还比丘某甲者默然。谁不忍者说。僧已忍。持此衣还此比丘某甲竟。僧忍默然故。是事如是持(舍与三人二人亦如上。忏悔亦如上。三人二人中受忏悔亦如上所白)

舍与一人文(应至清净比丘偏露右肩若上座礼足右膝着地合掌作如是言)

大德一心念。我比丘某甲。故畜尔许长衣。过十日犯舍堕。我今舍与大德。舍已当忏悔

一人前忏悔文

大德一心念。我比丘某甲。故畜尔许长衣。过十日犯舍堕。此衣已舍。罪今从大德忏悔。不敢覆藏。忏悔则安乐。不忏悔不安乐。忆念犯发露。知而不覆藏。大德忆。我清净戒身具足清净布萨(第二第三亦如是说。说已受忏悔者。应作如是说)自责汝心生厌离。答言尔

犯余轻罪白一比丘忏悔文(应至一清净比丘所偏露右肩若上座礼足右膝着地合掌说罪名说罪种应作如是言)

大德一心念。我比丘某甲犯某甲罪。今从大德忏悔。不敢覆藏。忏悔则安乐。不忏悔不安乐。忆念犯发露。知而不覆藏。大德忆。我清净戒身具足清净布萨(第二第三亦如是说。说已受忏悔者应语如是言)自责汝心生厌离。答言尔(向二人三人忏亦如是上二人中受忏者应语边人言)长老听。我受比丘某甲忏。答言听(忏悔法亦如上若欲在僧中忏者一人法亦如上说)

疑罪僧中发露文

大德僧听。我比丘某甲。于所犯生疑。今白僧令知。须后无疑时。当如法忏悔(第二第三亦如是说。向三人二人一人亦如是说)

    说戒法第四

与欲清净文

大德一心念。今众僧布萨说戒。比丘某甲亦布萨说戒。我有佛法僧事。若有瞻病事。我与欲及清净。为我捉筹(病人有五事与欲若言与汝欲若言我说欲若言为我说欲若广说尽与欲不者不成)

受欲及清净文(随能忆姓字多少。时得受至僧中应如是说)

大德一心念众多比丘有佛法僧事若瞻病事。我与众多比丘受欲及清净。如法僧事与欲清净。我为捉筹

差教授尼人羯磨文

大德僧听。若僧时到僧忍听。僧今差比丘某甲教授比丘尼。白如是。大德僧听。僧今差比丘某甲教授比丘尼。离诸长老忍。僧差比丘某甲教授比丘尼者默然。谁不忍者说。僧已忍差比丘某甲教授比丘尼竟。僧忍默然故。是事如是持(彼差人往尼寺中应教集尼僧已。先为说八不可违法何等为八)

一者虽百岁比丘尼。见新受戒比丘应起迎逆礼拜与敷净坐具。此法应尊重赞叹。尽形寿不得违

二者比丘尼。不应骂比丘诃责比丘。不应诽谤言破戒破见破威仪。此法应尊重赞叹。尽形寿不得违

三者比丘尼。不应为比丘作举作忆念作自言。不应遮他见罪说戒自恣。不应呵比丘。比丘应呵比丘尼。此法应尊重赞叹。尽形寿不得违

四者式叉摩那学戒已。应从比丘僧乞受大戒。此法应尊重赞叹。尽形寿不得违

五者比丘尼犯僧残罪。应在二部僧中半月行摩那埵。此法应尊重赞叹。尽形寿不得违

六者比丘尼。半月半月。应从僧乞教授。此法应尊重赞叹。尽形寿不得违

七者比丘尼。不应在无比丘僧处夏安居。此法应尊重赞叹。尽形寿不得违

八者比丘尼僧安居竟。应比丘僧中求三事自恣见闻疑。此法应尊重赞叹。尽形寿不得违(说八不违已后随意说法)布萨说戒文(布萨日若小食上若大食上上座应唱如是言)今日布萨日。某时众僧集堂说戒(若四人若过四人应先白已然后说戒。若有三人二人各各相向说言)长老一心念。今日众僧十五日说戒。我某甲清净(第二第三亦如是说。若独有一人应心念口言)今日众僧十五日说戒我某甲清净(第二第三亦如是说)八难事起及有余缘略说戒文(八难者。王难贼难火难水难病难人难非人难恶虫难。余缘者。大众集床座少。若众多病大众集屋上覆盖不周。或天雨。若布萨多。若多斗诤事。论阿毗说法夜已久。明相未出应作羯磨说戒。若明相出不得宿受欲清净。羯磨说戒应随事远近。可广说戒便广说。不者如法治。可略说便略。不者如法治。若难事近不略说。即应从坐起去。略戒者。说序已。余者应言僧常闻。若说序四事已。余者应言僧常闻。如是乃至九十事。余者应言僧常闻)

    安居法第五

僧差人分房羯磨文

大德僧听。若僧时到僧忍听。僧今差比丘某甲分房舍卧具。白如是

大德僧听。僧今差比丘某甲分房舍卧具。谁诸长老忍。僧差比丘某甲分房舍卧具者默然。谁不忍者说。僧已忍差比丘某甲分房舍卧具竟。僧忍默然故。是事如是持(分房法先使管事人选择一房取余白上座次第耳)大德上座。如是房舍卧具。随意所乐便取(先与上座房已次第与第二第三第四。乃至下座法亦如是。若有余长房者应留客比丘也)

安居文

长老一心念。我比丘某甲。依某聚落某甲僧伽蓝某甲房。前三月夏安居。房舍坏修治故(第二第三亦如是说)依某甲持律。若有疑事。当往问(后安居法亦如是说)

受七日文

长老一心念。我比丘某甲。受七日法出界外。为某甲事故。还此中安居。白长老令知(第二第三亦如是说)

受过七日法文

大德僧听。我比丘某甲。受过七日法。若十五日若一月出界外。为某甲事故。还此中安居(第二第三亦如是说)

与过七日羯磨文

大德僧听。若僧时到僧忍听。比丘某甲。受过七日法。若十五日若一月出界外。为某甲事故。还此中安居。白如是。大德僧听。比丘某甲。受过七日法。若十五日若一月出界外。为某甲事故。还此中安居。谁诸长老忍。僧听比丘某甲受过七日法。若十五日若一月出界外。为某甲事故。还此中安居者默然。谁不忍者说。僧已忍比丘某甲受过七日法。若十五日若一月出界外为某甲事故。还此中安居竟。僧忍默然故。是事如是持

    自恣法第六

与欲自恣文

大德一心念。今日僧自恣。我比丘某甲亦自恣。我有病患不堪往。我与自恣及欲(病人有五事与自恣。若言与汝自恣。若言我说自恣。若言为我说自恣。若现身相。若广说尽成与自恣。不者不成与自恣)

受自恣欲文(随能忆性字多少得受。三说至僧中应如是说言)

大德一心念。众多比丘病患不堪来。我与众多比丘受欲自恣。如是僧事与欲自恣

僧差授自恣人羯磨文

大德僧听。若僧时到僧忍听。僧今差比丘某甲作授自恣人。如是白

大德僧听。僧今差比丘某甲作授自恣人。谁诸长老忍。僧今差比丘某甲作授自恣人者默然。谁不忍者说。僧已忍差比丘某甲作授自恣人竟。僧忍默然故。是事如是持

白僧自恣文

大德僧听。今日众僧自恣。若僧时到僧忍听。僧和合自恣。白如是(作如是白已然后自恣)

众僧自恣文

大德一心念。众僧今日自恣。我比丘某甲亦自恣。若见闻疑罪。大德哀愍语我。我若见罪。当如法忏悔(第二第三亦如是说)

若四人更互自恣文

长老一心念。今日众僧自恣。我比丘某甲亦自恣。我清净(第二第三亦如是说。若三人二人亦如是说。若一人心念口言自恣)今日众僧自恣。我比丘某甲亦自恣。我清净(第二第三亦如是说自恣法五人若减五人不得受欲)

有八难事起白僧各各三语自恣文

大德僧听。僧有难事。若僧时到僧忍听。僧今各各三语自恣。白如是(作如是白已。各各共三语自恣。再说亦如是。若事近。不得各各三语自恣。亦不得白。彼比丘即应以此难事故去)

白僧受功德衣文

大德僧听。今日众僧受功德衣。若僧时到僧忍听。众和合受功德衣。白如是(僧应问谁能持功德衣者。若言有能者应差)

差持功德衣人羯磨文

大德僧听。若僧时到僧忍听。今差比丘某甲为僧持功德衣。白如是

大德僧听。僧今差比丘某甲为僧持功德衣。谁诸长老忍。僧今差比丘某甲为僧持功德衣者默然。谁不忍者说。僧已忍差比丘某甲为僧持功德衣竟。僧忍默然故。是事如是持

羯磨功德衣与持衣人文

大德僧听。此住处僧得可分衣。现前僧应分。若僧时到僧忍听。僧今持此衣与比丘某甲。此比丘某甲。当持此衣为僧受作功德衣。于此住处持。白如是

大德僧听。此住处僧得可分衣。现前僧应分。僧今持此衣与比丘某甲。此比丘某甲。当持此衣为僧受作功德衣。于此住处持。谁诸长老忍。僧持此衣与比丘某甲。比丘某甲当持此衣为僧受作功德衣。于此住处持者默然。谁不忍者说。僧已忍持此衣与比丘某甲。此比丘某甲当持此衣为僧受作功德衣。于此住处持竟。僧忍默然故。是事如是持

持功德衣人持衣众僧前文(随诸比丘手得及衣言得相了应如是言)

此衣众僧当受作功德衣。此衣众僧今受作功德衣。此衣众僧已受作功德衣(第二第三亦如是说)众僧各受功德衣文

其受者已善受。此中所有功德名称属我。彼应答言尔

出功德衣文

僧集和合。未受大戒者出。不来者说欲。僧今何所作为(应答言出功德衣)大德僧听。今日众僧出功德衣。若僧时到僧忍听。僧今和合出功德衣。如是白

    分衣物法第七

僧分衣物羯磨文

大德僧听。此住处若衣若非衣。现前僧应分。若僧时到僧忍听。僧今与比丘某甲。彼某甲当还与僧。白如是

大德僧听。此住处若衣若非衣。现前僧应分。僧今与比丘某甲。彼某甲当还与僧。谁诸长老忍。此住处若衣若非衣现前僧应分。僧今与比丘某甲。彼某甲当还与僧者默然。谁不忍者说。僧已忍与比丘某甲。彼某甲当还与僧竟。僧忍默然故。是事如是持(若住处有三人二人得施衣物。应留各各相向作如是说)长老一心念。是住处得可分衣物。现前僧应分。是中无僧。此衣物属我。我受用(第二第三亦如是说。若独有一人应心念口言)是住处得可分衣物。现前僧应分。是中无僧。此衣物属我。我受用(第二第三亦如是说)

瞻病人持亡者衣物至僧中说文

大德僧听。比丘某甲此住处命过。所有衣钵坐具针筒盛衣[袖-由+著]器。此住处现前僧应分(第二第三亦如是说)羯磨亡者衣钵与看病人文

大德僧听。比丘某甲命过。所有衣钵坐具针筒盛衣[袖-由+著]器。现前僧应分。若僧时到僧忍听。僧今与看病人某甲。白如是

大德僧听。比丘某甲命过。所有衣钵坐具针筒盛衣[袖-由+著]器。现前僧应分。僧今与看病人某甲。谁诸长老忍。僧与看病人某甲衣钵坐具针筒盛衣[袖-由+著]器者默然。谁不忍者说。僧已忍与看病人某甲衣钵坐具针筒盛衣[袖-由+著]器竟。僧忍默然故。是事如是持

僧分亡者余衣物羯磨文

大德僧听。比丘某甲命过。所有若衣若非衣现前僧应分。若僧时到僧忍听。僧今与比丘某甲。彼某甲当还与僧。白如是

大德僧听。比丘某甲命过。所有若衣若非衣。现前僧应分。僧今与比丘某甲。彼某甲当还与僧。谁诸长老忍。比丘某甲命过。所有若衣若非衣。现前僧应分。僧今与比丘某甲。彼某甲当还与僧者默然。谁不忍者说。僧已忍与比丘某甲。彼某甲当还与僧竟。僧忍默然故。是事如是持

若三人二人分亡者衣物文(若住处有三人二人欲分亡者衣物。应各各相向作如是言)

长老一心念。比丘某甲命过。所有若衣若非衣。现前僧应分。此住处无僧。是衣物属我。我应受用(第二第三亦如是说。若独一人心念口言)比丘某甲命过。所有若衣若非衣。现前僧应分。此住处无僧。是衣物属我。我应受用(第二第三亦如是说)

    作净法第八

结作净地文(净地有四种。一者檀越若经营人。作僧伽蓝时处分。二者若为作僧伽蓝未施。三者僧伽蓝。都无篱障及堑。若半有篱墙及堑。四者僧作白二羯磨结)

大德僧听。若僧时到僧忍听。僧今结某处作净地。白如是

大德僧听。僧今结某处作净地。谁诸长老忍。僧结某处作净地者默然。谁不忍者说。僧已忍结某处作净地竟。僧忍默然故。是事如是持(若故僧伽蓝。疑先有净地。应解已然后更结)

差人监净法羯磨文(彼如法作饮食净菜叶杨枝如是等事)

大德僧听。若僧时到僧忍听。比丘某甲。能为僧作净法人。白如是

大德僧听。比丘某甲。能为僧作净法人。谁诸长老忍。比丘某甲作净法人者默然。谁不忍者说。僧已忍比丘某甲作净法人竟。僧忍默然故。是事如是持(差作维那敷僧卧具。分僧粥。分饼分雨衣。处分沙弥。守僧园人。如是等诸羯磨文同。但称事为异耳)

真实净施文

长老一心念。我某甲。有此长衣未作净。今为净故。施与长老。为真实净(作真实施者。应问受施主然后得用)

展转净施文

长老一心念。我比丘某甲。有此长衣未作净。为展转净。施与长老(彼受请者应如是语言)长老一心念。汝有此长衣未作净。为展转净故。施与我。我今受之(受已当问彼言)汝施主是谁(彼应言)施与某甲(受请者应语如此语)长老一心念。汝是长衣未作净。为展转净故施与我。我已受之。是衣某甲已有。汝为某甲故护持。用时随意(展转净施者。若问若不问随意用)

受七日药文(先从净人受已持至大比丘所作如是言)

长老一心念。我比丘某甲。有病因缘。是七日药。为共宿七日故。今于长老边受(第二第三亦如是说)

受尽形寿药文(先从净人受已。持至大比丘所作如是言)

长老一心念。我比丘某甲有病。此尽形寿药。为共宿长服故。今于长老边受(第二第三亦如是说。不经宿不口受)

    杂法第九

乞作小房羯磨文

大德僧听。我比丘某甲。自乞作屋。无主自为己。我今从众僧。乞知无难无妨处(第二第三亦如是说。僧当观此比丘。若可信即听若不可信一切僧应到彼处看。若遣可信者看。看已应作羯磨)大德僧听。比丘某甲。自乞作屋。无主自为己。今从众僧乞处分无难无妨处。若僧时到僧忍听。僧今与比丘某甲处分。无难无妨处白如是

大德僧听。此比丘某甲。自乞作屋。无主自为己。今从众僧乞处分无难无妨处。僧今与比丘某甲处分无难无妨处。谁诸长老忍。僧与比丘某甲处分无难无妨处者默然。谁不忍者说。僧已忍与比丘某甲处分无难无妨处竟。僧忍默然故。是事如是持(次后大房羯磨文与此同。但称有主为异)足食已受残食文(应持食至彼比丘所。应作如是言)

大德。我已足食大德。看是知是。作余食法(彼应取少许食已语言)我已食止。汝可食之

受请已。作残食文(应持食至彼比丘前作如是言)

长老。我已受请长老看是知是作余食法(彼应取少许食已语言)我已食止。汝可食之

受请已。食前食后入他家嘱文长老一心念。我某甲已受某甲请。有缘事。欲入某甲聚落至某甲家。白长老令知

非时入村嘱授文

长老一心念。我某甲。非时入某甲聚落至某甲家。为如是缘事。白长老令知

比丘尼杂羯磨昙无德律三藏法师出

    诸结界法第一(结解诸界法子注次第名尽与大僧同称尼大姊异)

    受戒法第二

比丘尼乞畜众羯磨文(若比丘尼欲度人者当往比丘尼僧偏露右肩脱革屣礼僧足已右膝着地合掌作如是言)

大姊僧听我比丘尼某甲。今从众僧乞度人授具足戒。愿僧。听我度人授具足戒(第二第三亦如是说)尼僧与作畜众羯磨文

大姊僧听。此比丘尼某甲。今从众僧乞度人授人具足戒。若僧时到僧忍听。僧今听比丘尼某甲度人授人具足戒。白如是

大姊僧听。此比丘尼某甲。今从众僧乞度人授人具足戒。僧今听比丘尼某甲度人授人具足戒。谁诸大姊忍僧听比丘尼某甲度人授人具足戒者默然。谁不忍者说。僧已忍听比丘尼某甲度人授人具足戒竟。僧忍默然故。是事如是持

度沙弥尼文(若欲在比丘尼寺内剃发者应白僧若房房语令知然后剃发。应作如是白)

大姊僧听。此某甲欲从某甲求剃发若僧时到僧忍听为某甲剃发。白如是(应作如是白已为剃发。若欲在比丘尼内出家应白僧。若房房语令知。应作如是白言)大姊僧听。此某甲。从某甲求出家。若僧时到僧忍听。与某甲出家。白如是(应作如是白已与出家。应作如是出家。教出家者着袈裟已。偏露右肩脱革屣右膝着地合掌。教作如是言)我某甲。归依佛归依法归依僧。我今随佛出家。和上某甲。如来无所著等正觉。是我世尊(第二第三亦如是说)我某甲。归依佛归依法归依僧。我今随佛出家竟。和上某甲。如来无所著等正觉。是我世尊(第二第三亦如是说说如是已应与受戒)尽形寿不得杀生。是沙弥尼戒。能持不(答言能)尽形寿不得偷盗。是沙弥尼戒。能持不(答言能)尽形寿不得淫欲。是沙弥尼戒。能持不(答言能)尽形寿不得妄语。是沙弥尼戒。能持不(答言能)尽形寿不得饮酒。是沙弥尼戒。能持不(答言能)尽形寿不得着华鬘香涂身。是沙弥尼戒。能持不(答言能)尽形寿不得歌舞倡伎亦不往观听。是沙弥尼戒。能持不(答言能)尽形寿不得高广大床上坐。是沙弥尼戒。能持不(答言能)尽形寿不得非时食。是沙弥尼戒。能持不(答言能)尽形寿不得捉持生象金银宝物。是沙弥尼戒。能持不(答言能)如是沙弥尼十戒。尽形寿不应犯。当供养三宝佛宝法宝僧宝。勤修三业坐禅诵经劝佐众事(听童女十八者二年学戒年满二十比丘僧中受大戒若年十岁曾出嫡者。听二年中学戒满十二与授具足戒。应如是与二岁学戒)式叉摩那受六法文(沙弥尼应往比丘尼僧中偏露右肩脱革屣礼比丘尼僧足已右膝着地合掌白如是言)大姊僧听。我沙弥尼某甲。从僧乞二岁学戒。和上尼某甲。愿僧。济度我。慈愍故。与我二岁学戒(第二第三亦如是说应将沙弥尼往离闻处着见处已众中差堪能羯磨者。如上应作如是白)大姊僧听。此沙弥尼某甲。从僧乞二岁学戒。和上尼某甲。若僧时到僧忍听。僧今与沙弥尼某甲二岁学戒。和上尼某甲。白如是

大姊僧听。此沙弥尼某甲。今从僧乞二岁学戒。和上尼某甲。僧今与沙弥尼某甲二岁学戒。和上尼某甲。谁诸大姊忍僧与沙弥尼某甲二岁学戒和上尼某甲者默然。谁不忍者说。是初羯磨(第二第三亦如是说)僧已忍与沙弥尼某甲二岁学戒竟。和上尼某甲。僧忍默然故。是事如是持(应唤来礼僧足戒师前与六法)汝谛听。如来无所著等正觉说六法。不得犯不净行行淫欲法。若式叉摩那行淫欲法。非式叉摩那。非释种女。若与染污心男子共身相摩触缺戒。应更与学戒。是中尽形寿不得犯。能持不(答言能)不得偷盗乃至草叶。若式叉摩那。取人五钱若过五钱。自取教人取。自斫教人斫。自破教人破。若烧若埋若坏色。非式叉摩那。非释种女。若取减五钱缺戒。应更与学戒。是中尽形寿不得犯。能持不(答言能)不得故断众生命乃至蚁子。若式叉摩那。故自手断人命。求刀授与。教死劝死赞死。若与人非药。若堕胎厌祷咒术。自作教人作。非式叉摩那非释种女。若断畜生不能变化者命缺戒。应更与学戒。是中尽形寿不得犯。能持不(答言能)不得妄语乃至戏笑。若式叉摩那。不真实无所有。自称言得上人法。言得禅得解脱得定得四空定。得须陀洹果斯陀含果阿那含果阿罗汉果。言天来龙来鬼神来供养我。非式叉摩那非释种女。若于众中故妄语缺戒。应更与学戒。是中尽形寿不得犯。能持不(答言能)不得非时食。若式叉摩那非时食犯戒。应更与学戒。是中尽形寿不得犯。能持不(答言能)不得饮酒。若式叉摩那饮酒犯戒。应更与学戒。是中尽形寿不得犯。能持不(答言能)式叉摩那。于一切比丘尼戒。是中应尽学。除自取食过食与比丘尼

式叉摩那尼僧中受大戒文(应求和上作如是言)

我某甲。今求阿姨为和上。愿阿姨。为我作和上。我依阿姨故。得受大戒(第二第三亦如是说。和上应答言可尔。若式叉摩那学戒已。若年满二十若满二十应与受大戒。白四羯磨应如是与戒。将受人离闻处着见处。是中戒师应差教授师)大姊僧听。此某甲。从和上尼某甲求受大戒。若僧时到僧忍听。某甲尼为教授师。白如是(教授师应至受戒人所语言)此汝安陀会郁多罗僧僧伽梨僧竭支覆肩衣钵。此衣钵是汝有不。答言有。汝谛听。今真诚时。我今问汝。有便言有。无当言无。汝不曾作比丘尼不。不贼心受戒不。不杀父杀母杀阿罗汉不。不非人不。非畜生不。非二根人不。汝字何等。和上字谁。年岁满不。衣钵具足不。父母夫主为听汝不。不负人债不。非婢不。是女人不。女人有如是诸病。癞痈疽白癞干痟癫狂二根二道合道小大小便常漏涕唾常出。汝有如是诸病不(答言无应语言)如我向者所问。僧中亦当如是问。如向者答我。僧中亦当如是答(彼教授师问已。应还至僧中如常威仪。至舒手及比丘尼僧处立。应作如是言)大姊僧听。是某甲。从和上尼某甲求受大戒。若僧时到僧忍听。我已教授竟。听使来。白如是(教授师应唤受戒人言来来已。为捉衣钵教礼比丘尼僧足在戒师前胡跪合掌白如是言)大姊僧听。我某甲。从和上尼某甲求受大戒。我某甲。今从僧乞受大戒。和上尼某甲。愿僧济拔我。慈愍故(第二第三亦如是说。是中戒师应作白)大姊僧听。此某甲。从和上尼某甲求受大戒。此某甲。今从僧乞受大戒。和上尼某甲。若僧时到僧忍听。我问诸难事。白如是

汝谛听。今是真诚时。我今问汝。有便言有。无当言无。汝不曾作比丘尼不。不贼心受戒不。不杀父杀母杀阿罗汉不。非非人不。非畜生不。非二根人不。汝字何等。和上字谁。年岁满不。衣钵具足不。父母夫主为听汝不。非负人债不。非婢不。是女人不。女人有如是诸病。癞痈疽白癞干痟癫狂二根二道合道小大小便常漏涕唾常出。有如是诸病不(答言无应作白)大姊僧听。此某甲。从和上尼某甲求受大戒。此某甲。今从僧乞受大戒。和上尼某甲。所说清净无诸难事。年岁已满衣钵具足。若僧时到僧忍听。僧今授某甲大戒。和上尼某甲。白如是。大姊僧听。此某甲。从和上尼某甲求受大戒。此某甲。今从僧乞受大戒。和上尼某甲。所说清净无诸难事。年岁已满衣钵具足。僧今授某甲大戒。和上尼某甲。谁诸大姊忍。僧今授某甲大戒。和上尼某甲者默然。谁不忍者说。是初羯磨(第二第三亦如是说)僧已忍与某甲受大戒竟。和上尼某甲。僧忍默然故。是事如是持

受戒人与尼僧俱至比丘僧中大戒文(彼受戒者应与比丘尼增俱至比丘僧中礼僧足已右膝着地合掌作如是言)

大德僧听。我某甲。从和上尼某甲求受大戒。我某甲。今从僧乞受大戒。和上尼某甲。愿僧济度我。慈愍故(第二第三亦如是说。此中戒师应作白已问诸难事)

大德僧听。此某甲。从和上尼某甲求受大戒。此某甲。今从僧乞受大戒。和上尼某甲。若僧时到僧忍听。我问诸难事。白如是

善女谛听。今是真诚时。实当言实。不实当言不实。随所问汝。汝当以实答我。汝不曾作比丘尼不。不贼心受戒不。不杀父杀母杀阿罗汉不。非非人不。非畜生不。非二根人不。汝字何等。和上字谁。年岁满不。衣钵具足不。父母夫主为听汝不。汝不负人债不。非婢不。汝是女人不。女人有如是诸病。癞痈疽白癞干痟癫狂病。汝有如是诸病不(若言无应问言)汝学戒未。汝清净不(若言已学戒清净。应问余比丘尼言)已学戒未清净不(若言已学戒清净。即应作白四羯磨)大德僧听。此某甲。从和上尼某甲求受大戒。此某甲。今从僧乞受大戒。和上尼某甲。所说清净无诸难事。年岁已满衣钵具足。已学戒清净。若僧时到僧忍听。僧今为某甲受大戒。和上尼某甲。白如是。大德僧听。此某甲。从和上尼某甲求受大戒。此某甲。今从僧乞受大戒。和上尼某甲所说清净无诸难事。年岁已满衣钵具足。已学戒清净。僧今为某甲受大戒。和上尼某甲。谁诸长老忍。僧与某甲受大戒。和上尼某甲者默然。谁不忍者说。是初羯磨(第二第三亦如是说)僧已忍为某甲受大戒竟。和上尼某甲。僧忍默然故。是事如是持

善女人谛听。如来无所著等正觉说八波罗夷法。若比丘尼犯者。非比丘尼非释种女。一切不得作不净行行淫欲法。若比丘尼作不净行行淫欲法乃至共畜生。非比丘尼非释种女。是中尽形寿不得犯。能持不(答言能)不得偷盗乃至草叶。若比丘尼取人五钱若过五钱。自取教人取。自斫教人斫。自破教人破。若烧若埋若坏色。非比丘尼非释种女。是中尽形寿不得犯。能持不(答言能)不得断众生命乃至蚁子。若比丘尼自手断。若教他断人命。持刀授与。教死赞死劝死。与人非药。若堕胎厌祷咒术。若自作方便教人作。非比丘尼非释种女。是中尽形寿不得犯。能持不(答言能)不得妄语乃至戏笑。若比丘尼不真实非己有。自称得上人法。得禅得解脱三昧正受。得须陀洹果斯陀含果阿那含果阿罗汉果。言天来龙来鬼神来供养我。非比丘尼非释种女。是中尽形寿不得犯。能持不(答言能)不得身相摩触乃至共畜生。若比丘尼有染污心与染污心男子身相触腋以下膝以上。若摩若捺若逆摩若顺摩若牵若推若举若下若捉若急捺。非比丘尼非释种女。是中尽形寿不得犯。能持不(答言能)不得犯八事乃至共畜生。若比丘尼有染污心。与染污心男子。受捉手捉衣至屏处屏处住屏处语。若共行若身相近若共期。犯此八事。非比丘尼非释种女。是中尽形寿不得犯。能持不(答言能)不得覆藏他罪乃至突吉罗恶说。若比丘尼知比丘尼犯波罗夷。不自举不白僧不语人令知。后于异时。此比丘尼若休道若灭摈若作不共住若入外道。后作如是言。我先知此人如是如是。非比丘尼非释种女。覆藏他重罪故。是中尽形寿不得犯。能持不(答言能)不得随被举比丘语乃至沙弥。若比丘尼知比丘为僧所举。如法如毗尼如佛所教。犯威仪未忏悔不作共住。便随顺。彼比丘尼谏此比丘尼言。大姊。彼比丘为僧所举。如法如毗尼如佛所教。犯威仪未忏悔不作共住。莫随顺彼比丘语。彼比丘尼谏此比丘尼时。坚持不舍。彼比丘尼应乃至三谏。舍此事故。乃至三谏舍者善。若不舍者。非比丘尼非释种女。犯随举。是中尽形寿不得犯。能持不(答言能)善女人谛听。如来无所著等正觉说四依法。比丘尼出家依是。是出家人法。依粪扫衣。是比丘尼出家法。是中尽形寿能持不(答言能)若得长利。檀越施衣。割坏衣。得受

依乞食。是比丘尼出家人法。是中尽形寿能持不(答言能)若得长利。若僧差食。檀越送食。月八日食。十五日食。月初日食。众常食。檀越请食得受

依树下坐。是比丘尼出家人法。是中尽形寿能持不(答言能)若得长利。别房尖头小屋。石室两房一户得受

依腐烂药。是比丘尼出家人法。是中尽形寿能持不(答言能)若得长利。酥油生酥蜜石蜜得受。汝已受戒竟。白四羯磨如法成就得处所。和上如法。阿阇梨如法。二部众僧具足。当善受教法。应劝化作福治塔供养众僧。和上阿阇梨一切如法教。不得违逆。应学问诵经勤求方便。于佛法中得须陀洹果斯陀含果阿那含果阿罗汉果。汝始发心出家。功不唐捐果报不断。余所不知。当问和上阿阇梨(应令受戒人在前而去)

受衣钵文(受五衣钵文。请依止文。子注尽同。尼姊异)

    除罪法第三

比丘尼从二部僧乞摩那埵羯磨文

(治比丘尼僧残罪。无覆藏。唯有半月。在二部僧中行摩那埵。行摩那埵竟与出罪。摩那埵羯磨时。大僧满四人已上。尼僧亦尔。出罪时。要二部僧各二十人。彼尼来至僧中。脱革屣偏露右肩礼僧足合掌胡跪。从二部僧乞半月摩那埵。应如是言)大德僧听。我比丘尼某甲。犯某甲僧残罪。今从二部僧。乞半月摩那埵羯磨。愿僧。与我半月摩那埵羯磨。慈愍故(第二第三亦如是说)

与摩那埵羯磨文

大德僧听。比丘尼某甲。犯某甲僧残罪。今从二部僧。乞半月摩那埵羯磨。若僧时到僧忍听。僧今与比丘尼某甲半月摩那埵羯磨。白如是

大德僧听。比丘尼某甲。犯某甲僧残罪。今从二部僧。乞半月摩那埵羯磨。僧今与比丘尼某甲半月摩那埵羯磨。谁诸长老忍。僧与比丘尼某甲半月摩那埵羯磨者默然。谁不忍者说。是初羯磨(第二第三亦如是说)僧已忍与比丘尼某甲半月摩那埵羯磨竟。僧忍默然故。是事如是持(摩那埵行法如大比丘法无异在尼僧中宿日日来白大僧令知作如是说)大德僧听。我比丘尼某甲。犯某甲僧残罪。从二部僧。乞半月摩那埵羯磨。僧已与我半月摩那埵羯磨。我比丘尼某甲。已行若干日。余有若干日在。白大德僧。令知我行摩那埵

乞出罪羯磨文(彼比丘尼来至二部僧中乞出罪羯磨应如是乞言)

大德僧听。我比丘尼某甲。犯某甲僧残罪。从二部僧。乞半月摩那埵羯磨。僧已与我半月摩那埵羯磨。我于二部僧中半月行摩那埵竟。今从僧乞出罪羯磨。愿僧。与我出罪羯磨。慈愍故(第二第三亦如是说)

与出罪羯磨文

大德僧听。比丘尼某甲。犯某甲僧残罪。从二部僧。乞半月摩那埵羯磨。已与比丘尼某甲半月摩那埵羯磨。此比丘尼某甲。已于二部僧中半月行摩那埵竟。今从僧乞出罪羯磨。若僧时到僧忍听。僧今与比丘尼某甲出罪羯磨。白如是

大德僧听。比丘尼某甲。犯某甲僧残罪。从二部僧。乞半月摩那埵羯磨。僧已与比丘尼某甲半月摩那埵羯磨此比丘尼某甲。已于二部僧中半月行摩那埵竟。今从僧乞出罪羯磨。僧今与比丘尼某甲出罪羯磨。谁诸长老忍。僧与比丘尼某甲出罪羯磨者默然。谁不忍者说。是初羯磨(第二第三亦如是说)僧已忍与比丘尼某甲出罪羯磨竟。僧忍默然故。是事如是持

舍堕衣于僧中舍文(舍堕僧中舍。舍竟。僧中忏悔。请一人能受者白。即一人前忏悔。羯磨还彼衣。三二一人边舍。忏皆亦同。犯余罪。向二三人忏。受者白边人。疑罪僧向三二一人发露。子注次第名。尽同尼姊异)

    说戒法第四

尼僧差人求教授羯磨文

大姊僧听。若僧时到僧忍听。僧今差比丘尼某甲。为比丘尼僧故。半月往比丘僧中求教授。白如是。大姊僧听。僧今差比丘尼某甲。为比丘尼僧故。半月往比丘僧中求教授。谁诸大姊忍。僧差比丘尼某甲为比丘尼僧故。半月往比丘僧中求教授者默然。谁不忍者说。僧已忍差比丘尼某甲为比丘尼僧故。半月往比丘僧中求教授竟。僧忍默然故。是事如是持(二人为伴往大僧中诣一旧比丘所礼足已。曲身低头合掌白言)大德一心念。比丘尼僧和合。礼比丘僧足。求教授(第二第三亦如是说。受嘱比丘僧说戒时如是白言)大德僧听。比丘尼僧和合。礼僧足求教授(第二第三亦如是说。比丘尼明日应往问可否。比丘应期往。比丘尼应期来迎。比丘期往。闻教授人来。当半道迎至寺内。供给所须洗浴具。美粥饮食果苽。以此供养。若不者突吉罗。若比丘尽病。若不和合。若众不满。当遣信往礼拜问讯。若比丘尼尽病。若众不和合。众不满。亦当遣信往礼拜问讯。若不往者突吉罗)与清净及欲文(与欲及清净受欲。及清净布萨说戒法。八难及缘略说戒。子注次第名。尽同尼姊异)

    安居法第五(差人分房舍。安居。受七日。受过七日文。与过七日法。子注次第名。尽同尼姊异)

    自恣法第六

尼僧差人大僧中求自恣羯磨文

大姊僧听。若僧时到僧忍听。僧今差比丘尼某甲。为比丘尼僧故往大僧中。说三事自恣见闻疑。白如是

大姊僧听。僧今差比丘尼某甲。为比丘尼僧故往大僧中。说三事自恣见闻疑。谁诸大姊忍。僧差比丘尼某甲为比丘尼僧故往大僧中。说三事自恣见闻疑者默然。谁不忍者说。僧已忍差比丘尼某甲为比丘尼僧故往大僧中。说三事自恣见闻疑竟。僧忍默然故。是事如是持(二比丘尼为伴往大僧中礼僧足已曲身低头合掌作如是说)比丘僧夏安居竟。比丘尼夏安居竟。比丘僧说三事自恣见闻疑。大德僧。慈愍故语我。我若见罪。当如法忏悔(第二第三亦如是说。彼尼即比丘僧中自恣日便自恣。而比丘疲极。佛言。不应尔。比丘僧十四日自恣。比丘尼十五日自恣。若大僧病。若众不和合。若众不满。比丘尼应遣信礼拜问讯。不者突吉罗。若比丘尼众病。若众不和合。众不满。比丘尼亦当遣信礼拜问讯。不者突吉罗)

与欲自恣文(与欲自恣。受欲自恣人。白僧自恣。尼僧自恣。四三二人互说。独一心念。说八难白僧三语自恣。白僧受功德衣人。羯磨衣与持衣人。僧前说。众僧尼受功德衣。白出功德衣。子注次第名。尽同尼姊异)

    分衣物法第七(羯磨分衣物。三二人相向受。独一心念受。听病人持亡者衣物至僧中说。羯磨衣钵与。余衣羯磨分。三二人相向受。独一心念受。尽同尼姊异)

    作净法第八(结净地。差监净人。真净展转。七日尽形寿受法。子注次第名。尽同尼姊异)

    杂法第九(自乞作小房。足食受残食。受请已作残食。受请食前食后非时入村嘱。子注次第名。尽同尼姊异。文烦故不出)

僧祇律一人安居文

我比丘某甲。于此僧伽蓝两安居前三月。我某甲比丘。是住处夏安居前三月。有缘事出界行。受七日法是住处安居自恣

昙无德律部杂羯磨


五分比丘尼戒本

    No. 1423 [cf. No. 1421]

五分比丘尼戒本

        梁建初寺沙门释明徽集

大姊僧听。春时一月过少一夜。余有一夜三月在。老死至近佛法欲灭。诸大姊。为得道故。一心勤精进。所以者何。诸佛一心勤精进故。得阿耨多罗三藐三菩提。何况余善道法

  合十指爪掌　　供养释师子
  我今欲说戒　　僧当一心听
  乃至小罪中　　心应大怖畏
  有罪一心悔　　后更莫复犯
  心马驰恶道　　放逸难禁制
  佛说切戒行　　亦如利辔勒
  佛口说教诫　　善者能信受
  是人马调顺　　能破烦恼军
  若不受教敕　　亦不爱乐戒
  是人马不调　　没在烦恼军
  若人守护戒　　如牦牛爱尾
  系心不放逸　　亦如猴着锁
  日夜常精进　　求实智慧故
  是人佛法中　　能得清净命

未受具戒者出(有者依言遣出无者答言此处无未受具戒人)诸大姊。不来诸比丘尼。说欲及清净。(有者依言说无者答言此处无说欲人)僧今和合。先作何事。(答言说戒羯磨)

大姊僧听。今十五日布萨说戒。僧一心作布萨说戒。若僧时到僧忍听。白如是

诸大姊。今布萨说波罗提木叉。一切共听。善思念之。若有罪应发露。无罪者默然。默然故当知我及诸大姊清净。如圣默然。我及诸大姊亦如是。若比丘尼如是众中乃至三唱。忆有罪不发露。得故妄语罪。故妄语罪佛说遮道法。发露者得安乐。不发露罪益深。诸大姊。已说戒经序。今问。诸大姊。是中清净不。(第二第三亦如是说)诸大姊是中清净。默然故。是事如是持

诸大姊。是八波罗夷法。半月半月戒经中说若比丘尼。共诸比丘尼同学戒法。戒羸不舍随意。行淫乃至共畜生。是比丘尼得波罗夷不共住

若比丘尼。若聚落若空地盗心不与取。若王若大臣。若捉若缚。若杀若摈。语言。汝贼汝小汝痴。是比丘尼得波罗夷不共住

若比丘尼。若人若似人。若自杀若与刀药杀。若教人杀若教自杀。誉死赞死。咄人用恶活为死胜生。作是心随心杀。如是种种因缘。彼因是死。是比丘尼得波罗夷不共住

若比丘尼。不知不。见过人法圣利满足。自称我如是知如是见。是比丘尼后时若问若不问。为出罪求清净故作是言。我不知言知不见言见。虚诳妄语。除增上慢。是比丘尼得波罗夷不共住

若比丘尼。欲盛变心。受男子种种摩触。发际已下膝已上肘已后。是比丘尼得波罗夷不共住

若比丘尼。欲盛变心。受男子捉手捉衣共期独共行独共住独共语独共一座坐身亲近男子。八法具者。是比丘尼得波罗夷不共住

若比丘尼。知僧如法与比丘作不见罪羯磨。诸比丘不共住不共事不共语。而随顺之。诸比丘尼语是比丘尼。姊妹。此比丘僧已作不见罪羯磨。诸比丘不共住不共事不共语。汝莫随顺。如是谏坚持不舍。应第二第三谏。第二第三谏舍是事善。不舍者。是比丘尼得波罗夷不共住

若比丘尼。见比丘尼犯波罗夷覆藏。彼比丘尼后时。若在若死。若远行若被摈。若罢道若变形。作是语。我先亲见其犯波罗夷。是比丘尼得波罗夷不共住

诸大姊。已说八波罗夷法。若比丘尼犯一一戒。不得共住。如前后亦如是。是比丘尼得波罗夷罪不应共住。今问。诸大姊。是中清净不(第二第三亦如是说)

诸大姊是中清净。默然故。是事如是持

诸大姊。是十七僧伽婆尸沙法。半月半月戒经中说

若比丘尼行媒法若为私通事。持男意至女边。持女意至男边乃至一交会。是比丘尼初犯僧伽婆尸沙可悔过

若比丘尼自不如法。恶嗔故。以无根波罗夷。谤无波罗夷比丘尼。欲破彼梵行。是比丘尼后时若问若不问言。我是事无根。住嗔故谤。是比丘尼初犯僧伽婆尸沙可悔过

若比丘尼自不如法。恶嗔故。于异分中取片若似片作波罗夷。谤无波罗夷比丘尼。欲破彼梵行。是比丘尼后时若问若不问言。我是事异分中取片若似片。住嗔故谤。是比丘尼初犯僧伽婆尸沙可悔过

若比丘尼知有罪女主不听度为道。除先出家。是比丘尼初犯僧伽婆尸沙可悔过

若比丘尼知僧如法摈比丘尼。比丘尼心未调伏不随顺僧。自与眷属于界外解其摈者。是比丘尼初犯僧伽婆尸沙可悔过

若比丘尼独宿独渡水。于道中独在后。染着男子。除因缘。是比丘尼初犯僧伽婆尸沙可悔过。因缘者。恐怖走时。老病疲极不及伴时。水狭浅有桥船处。畏男子处。是名因缘

若比丘尼诣官言人。是比丘尼初犯僧伽婆尸沙可悔过

若比丘尼有染着心。自手受染着心男子食食。是比丘尼初犯僧伽婆尸沙可悔过

若比丘尼教他比丘尼作是语。汝但莫生染着。受染着男子饮食何苦。是比丘尼初犯僧伽婆尸沙可悔过

若比丘尼为破和合僧勤方便。诸比丘尼语是比丘尼。汝莫为破和合僧勤方便。当与僧和合。僧和合故欢喜无诤。一心一学如水乳合。共弘师教安乐行。如是谏坚持不舍。应第二第三谏。第二第三谏舍是事善。不舍者。是比丘尼三谏。犯僧伽婆尸沙可悔过

若比丘尼助破和合僧。若一若二若众多。语诸比丘尼言。是比丘尼所说。是知说非不知说。说法不说非法。说律不说非律。皆是我等心所忍乐。诸比丘尼语是比丘尼。汝莫作是语。是比丘尼所说。是知说非不知说。说法不说非法。说律不说非律。皆是我等心所忍乐。何以故。是比丘尼非知说非说法非说律。汝莫乐助破和合僧。当乐助和合僧。僧和合故欢喜无诤。一心一学如水乳合。共弘师教安乐行。如是谏坚持不舍。应第二第三谏。第二第三谏舍是事善。不舍者。是比丘尼三谏。犯僧伽婆尸沙可悔过

若比丘尼恶性难共语。与诸比丘尼同学戒经。数数犯罪。诸比丘尼如法如律谏其所犯。答言。阿姨汝莫语我若好若恶。我亦不以好恶语汝。诸比丘尼复语言。汝莫作自我不可共语。汝当为诸比丘尼说如法。诸比丘尼亦当为汝说如法。如是展转相教转相出罪成如来众。如是谏坚持不舍。应第二第三谏。第二第三谏舍是事善。不舍者。是比丘尼三谏。犯僧伽婆尸沙可悔过

若比丘尼依聚落住。行恶行污他家。行恶行皆见闻知。污他家亦见闻知。诸比丘尼语是比丘尼。汝行恶行污他家。行恶行皆见闻知。污他家亦见闻知。汝出去不应是中住。彼比丘尼言。诸阿姨随爱恚痴畏。何以故。有如是等同罪比丘尼。有驱者有不驱者。诸比丘尼复语言。汝莫作是语。语诸阿姨。随爱恚痴畏。有如是等同罪比丘尼。有驱者有不驱者。汝行恶行污他家。行恶行皆见闻知。污他家亦见闻知。汝舍是随爱恚痴畏语。汝出去不应是中住。如是谏坚持不舍。应第二第三谏。第二第三谏舍是事善。不舍者。是比丘尼三谏。犯僧伽婆尸沙可悔过

若二比丘尼共作恶行有恶名声。更相覆罪触恼众僧。诸比丘尼语言。汝二比丘尼共作恶行有恶名声。更相覆罪触恼众僧。汝相远离舍是作恶触恼僧事。于佛法中增广得安乐住。彼二比丘尼言。我等不作恶行无恶名声。不相覆罪不触恼僧。此中更有余二比丘尼。共作恶行触恼众僧。诸比丘尼复语言。莫作是语。何以故。此中更无余二比丘尼作恶恼僧。唯有汝等。可相远离舍是作恶触恼僧事。于佛法中增广得安乐住。如是谏坚持不舍。应第二第三谏。第二第三谏舍是事善。不舍者。是比丘尼三谏。犯僧伽婆尸沙可悔过若二比丘尼共作恶行有恶名声更相覆罪触恼众僧。诸比丘尼语言。汝二比丘尼共作恶行有恶名声。更相覆罪触恼众僧。汝相远离舍是作恶触恼僧事。于佛法中增广得安乐住。二比丘尼言。我等不作恶行无恶名声。不相覆罪不触恼僧。僧见我等羸弱。轻易我故作如是语诸比丘尼复言。莫作是语。何以故。僧不见汝羸弱轻易汝等。汝等可相远离舍是作恶触恼僧事。于佛法中增广得安乐住。如是谏坚持不舍。应第二第三谏。第二第三谏舍是事善。不舍者。是比丘尼三谏。犯僧伽婆尸沙可悔过

若比丘尼好共他斗。僧断其事。便言。僧随爱恚痴畏。诸比丘尼语言。汝莫好共他斗。莫作是语僧随爱恚痴畏。何以故。僧不随爱恚痴畏。汝等舍是语。于佛法中增广得安乐住。如是谏坚持不舍。应第二第三谏。第二第三谏舍是事善。不舍者。是比丘尼三谏。犯僧伽婆尸沙可悔过

若比丘尼好共他斗。僧断其事。便言。我舍佛舍法舍僧舍戒作外道。余沙门婆罗门亦学戒亦惭愧。我于彼得修梵行。诸比丘尼语言。汝莫好共他斗。莫作是语。我舍佛法僧。何以故。余沙门婆罗门无学戒无惭愧。汝云何于彼得修梵行。汝舍是恶见。于佛法中增广得安乐住。如是谏坚持不舍。应第二第三谏。第二第三谏舍是事善。不舍者。是比丘尼三谏。犯僧伽婆尸沙可悔过

诸大姊。已说十七僧伽婆尸沙法。九初罪八乃至三谏。若比丘尼犯一一罪。应二部僧中半月行摩那埵。次到阿浮诃那如法作已。应二部僧各二十人中出罪。若少一人不名出罪。诸比丘尼亦可呵。是法应尔。今问诸大姊是中清净不。(第二第三亦如是说)诸大姊是中清净。默然故。是事如是持

诸大姊。是三十尼萨耆波逸提法。半月半月戒经中说

若比丘尼。五衣竟舍迦絺那衣已。长衣乃至十日。若过尼萨耆波逸提

若比丘尼。衣竟舍迦絺那衣已。五衣中若离一一衣宿。过一夜除僧羯磨。尼萨耆波逸提

若比丘尼。衣竟舍迦絺那衣已。得非时衣。若须应受速作受持。若足者善。若不足望更有得处。令具足成乃至一月。若过尼萨耆波逸提

若比丘尼从非亲里居士居士妇乞衣。除因缘尼萨耆波逸提。因缘者。夺衣失衣烧衣漂衣坏衣。是名因缘

若比丘尼。夺衣失衣烧衣漂衣坏衣。从非亲里居士居士妇乞衣。若居士居士妇欲多与衣。是比丘尼应受二衣。若过受尼萨耆波逸提

若非亲里居士居士妇共议。当以是衣直作衣与某甲比丘尼。是比丘尼先不受自恣请。便往问居士居士妇言。汝为我以如是衣直作衣不。答言如是。便言善哉。居士居士妇。可作如是如是衣与我。为好故尼萨耆波逸提

若非亲里居士居士妇共议。我当各以如是衣直作衣与某甲比丘尼。是比丘尼先不受。自恣请。便往问居士居士妇言。汝各为我以如是衣直作衣不。答言如是。便言善哉。居士居士妇。可合作一衣与我。为好故尼萨耆波逸提

若王若大臣婆罗门居士。为比丘尼故。遣使送衣直。使到比丘尼所言。阿姨。彼王大臣送此衣直。阿姨受之。是比丘尼言。我不应受衣直。若得净衣当手受持。使言。阿姨有执事人不。比丘尼即指示处。使便到执事所言。某王大臣送此衣直与某甲比丘尼。汝为受作取便与之。使既与已。还比丘尼所白言。阿姨所示执事人。我已与竟。阿姨须衣便可往取。是比丘尼二反三反到执事所。作是言。我须衣我须衣。若得者善。若不得四反五反六反到执事前默然立。若得者善。若过是求得者。尼萨耆波逸提若不得衣。应随使来处若自往若遣信语言。汝为某甲比丘尼送衣直。是比丘尼竟不得。汝自还索莫使失。是事应尔。若比丘尼自行乞缕。雇织师织作衣。尼萨耆波逸提

若居士居士妇。为比丘尼使织师织作衣。是比丘尼先不自恣请。便到织师所作是言。汝知不。此衣为我作。汝为我故。好织令极致广。当别相报。后若与一食若一食直。得者尼萨耆波逸提。(一十)

若比丘尼与比丘尼衣。后嗔不喜。若自夺若使人夺。作是语。还我衣不与汝。尼萨耆波逸提

若比丘尼。知檀越欲与僧物。回以入己。尼萨耆波逸提

若比丘尼病。得服四种含消药。酥油蜜石蜜。一受乃至七日。若过尼萨耆波逸提

若比丘尼。前后安居十日。未至自恣得急施衣。若须应受。乃至衣时若过。尼萨耆波逸提

若比丘尼钵未满五缀。更乞新钵为好故。尼萨耆波逸提

若比丘尼种种贩卖求利。尼萨耆波逸提

若比丘尼以金银及钱种种卖买。尼萨耆波逸提

若比丘尼自捉金银及钱。若使人捉若发心受。尼萨耆波逸提

若比丘尼先乞是。既得不用更乞余物。尼萨耆波逸提

若比丘尼非时衣作时衣受。尼萨耆波逸提(二十)

若比丘尼与比丘尼贸衣。后悔还索。得者尼萨耆波逸提

若比丘尼。诸比丘尼语。汝取遮月水衣。自言不用。临时先取。尼萨耆波逸提

若比丘尼乞重衣。应取价直四大钱者。若受贵价衣。尼萨耆波逸提

若比丘尼乞轻衣。应取价直二大钱半者。若受贵价衣。尼萨耆波逸提

若比丘尼为僧为是事。从一居士乞。而余用者。尼萨耆波逸提

若比丘尼为僧为是事。从众多居士乞。而余用者。尼萨耆波逸提

若比丘尼自为是事。从一居士乞。自作余用者。尼萨耆波逸提

若比丘尼自为是事从众多居士乞。自作余用者。尼萨耆波逸提

若比丘尼藏积器。物尼萨耆波逸提

若比丘尼多积聚钵。尼萨耆波逸提(三十)

诸大姊。已说三十尼萨耆波逸提法。今问诸大姊是中清净不。(第二第三亦如是说)

诸大姊是中清净默然故。是事如是持

诸大姊。是二百一十波逸提法。半月半月戒经中说

若比丘尼故妄语波逸提

若比丘尼毁呰比丘尼波逸提

若比丘尼两舌斗乱比丘尼波逸提

若比丘尼为男子说法过五六语。除有别知好恶语女人波逸提

若比丘尼知僧如法断事已。还更发起波逸提

若比丘尼教未受具戒女人经。并诵者。波逸提

若比丘尼与未受具戒女人同室宿。过三夜波逸提

若比丘尼向未受具戒女人。自说得过人法言。我如是知如是见。实者波逸提

若比丘尼知比丘尼粗罪。向未受具戒女人说。除僧羯磨波逸提

若比丘尼作是语。何用是杂碎戒为。说是戒时令人忧恼。作如是毁呰戒者。波逸提(一十)

若比丘尼自伐鬼村。若使人言伐是。波逸提

若比丘尼故不随问答波逸提

若比丘尼诬说僧所差人波逸提

若比丘尼于露地自敷僧卧具。若使人敷若他敷若坐若卧。去时不自举不教人举不嘱举。波逸提

若比丘尼于僧房内自敷僧卧具。若使人敷若他敷若坐若卧。去时不自举不教人举不嘱举。波逸提

若比丘尼嗔不喜。于僧坊中自牵比丘尼出。若使人牵作是语。出去灭去莫此中住。波逸提

若比丘尼知他先敷卧具。后来强自敷若使人敷。作是念。若不乐者自当出去。波逸提

若比丘尼僧重阁上。尖脚绳床木床。用力坐卧。波逸提

若比丘尼知水有虫。若取浇泥若饮食诸用。波逸提

若比丘尼数数食。除因缘波逸提。因缘者。病时作衣时施衣时。是名因缘(二十)

若比丘尼受别请众食。除因缘波逸提。因缘者。病时施衣时作衣时行路时船上行时大会时。是名因缘

若比丘尼无病。施一食处过一食者。波逸提

若比丘尼到白衣家。自恣多与饮食。若饼若糗。若不住其家食。须二三钵应受出外。应与余比丘尼共食。若无病过是受。及不与余比丘尼共食。波逸提

若比丘尼食竟。不作残食法食。波逸提

若比丘尼。食竟不作残食法。强劝令食。欲使他犯。波逸提

若比丘尼。不受食着口中。除尝食杨枝及水。波逸提

若比丘尼非时食波逸提

若比丘尼食残宿食波逸提

若比丘尼食家中与男子坐。波逸提

若比丘尼观军发行波逸提(三十)

若比丘尼有因缘到军中。乃至二三宿。若过波逸提

若比丘尼有因缘到军中二三宿。观军阵合战。波逸提

若比丘尼作如是语。如我解佛所说。障道法不能障道。诸比丘尼语是比丘尼。汝莫作是语。莫谤佛莫诬佛。佛说障道法实能障道。汝舍是恶邪见。如是谏时坚持不舍。应第二第三谏。第二第三谏舍是事善。不舍者。波逸提

若比丘尼。知是比丘尼不如法悔不舍恶邪见。共住共语共宿共事。波逸提

若沙弥尼作是语。如我解佛所说。若受五欲不能障道。诸比丘尼语是沙弥尼。汝莫作是语。莫谤佛莫诬佛。佛说五欲障道实能障道。汝沙弥尼舍是恶邪见。如是教坚持不舍。应第二第三教第二第三教舍是事善。若不舍诸比丘尼应语是沙弥尼。汝出去。从今莫言佛是我师。莫在诸比丘尼后行。如余沙弥尼得共诸比丘尼二宿。汝亦无是事。痴人出去灭去。莫此中住。若比丘尼知如法摈沙弥尼畜使共住共语。波逸提

若比丘尼故夺畜生命。波逸提

若比丘尼。故令比丘尼生疑悔。作是念。令是比丘尼乃至少时恼波逸提

若比丘尼。僧断事时不与欲起去。波逸提

若比丘尼击擽比丘尼。波逸提

若比丘尼水中戏。波逸提(四十)

若比丘尼与男子同室宿。波逸提

若比丘尼饮酒。波逸提

若比丘尼轻师。波逸提

若比丘尼自掘地。若使人掘言掘是。波逸提

若比丘尼共诤已默听。作是念。诸比丘尼所说我当忆持。波逸提

若比丘尼受四月自恣请过是受。除更请自送请长请。波逸提

若比丘尼数数犯罪。诸比丘尼如法谏。作如是语。我不学是戒。当问余比丘尼持法持律者。波逸提

若比丘尼说戒时作是语。我今始知是法半月布萨戒经中说。诸比丘尼知是比丘尼已再三说戒中坐。是比丘尼不以不知故得脱。随所犯罪如法治。应呵其不知。汝所作不善。说戒时不一心听不着心中。波逸提

若比丘尼与贼期共道行。从此聚落到彼聚落。波逸提

若比丘尼与男子期共道行。从此聚落到彼聚落。波逸提(五十)

若比丘尼无病。为炙故自然火。若使人然。波逸提

若比丘尼。若宝等物。若自取若使人取。除僧坊内及宿处。波逸提。若僧坊内及宿处。取宝等物。后有主索应还。是事应尔

若比丘尼半月内浴。除因缘。波逸提。因缘者。病时作时行路时风雨时热时。是名因缘

若比丘尼。嗔故打比丘尼。波逸提

若比丘尼。嗔故以手拟比丘尼。波逸提

若比丘尼。故恐怖比丘尼。波逸提

若比丘尼。以无根僧伽婆尸沙。谤比丘尼。波逸提

若比丘尼语彼比丘尼。共到诸家。与汝多美饮食。既到不与。作是言。汝去。共汝若坐若语不乐。我独坐独语乐。欲令恼故。波逸提

若比丘尼。新衣应三种色作帜。若青若黑若木兰。若不以三色作帜。波逸提

若比丘尼为戏笑故。藏比丘尼若衣若钵若坐具针筒。如是一一生活具若使人藏。波逸提(六十)

若比丘尼。僧断事时。如法与欲竟后更呵。波逸提

若比丘尼作是语。诸比丘尼随知识回僧物与。波逸提

若比丘尼与比丘比丘尼式叉摩那沙弥沙弥尼净施衣。强夺取。波逸提

若比丘尼受他请食前食。后行到诸家。不近白余比丘尼。除因缘。波逸提。因缘者。衣时。是名因缘

若比丘尼以兜罗贮坐卧具。波逸提

若比丘尼。自作坐卧绳床木床。足应高修伽陀八指。除入梐。若过波逸提

若比丘尼。用骨牙角作针筒。波逸提

若比丘尼。作修伽陀衣量衣。若过波逸提。修伽陀衣量者。长九修伽陀磔手广六磔手。是名修伽陀衣量

若比丘尼。知檀越欲与僧物。回与余人。波逸提

若比丘尼啖蒜波逸提(七十)

若比丘尼。以手拍女根。波逸提

若比丘尼。作男根内女根中。波逸提

若比丘尼。以水洗女根。应用二指齐一节。若过波逸提

若比丘尼。剃腋下隐处毛。波逸提

若比丘尼。与比丘独屏处共立共语。波逸提

若比丘尼。与白衣及外道。独屏处共立共语。波逸提

若比丘尼。与比丘独露处共立共语。波逸提

若比丘尼。与白衣及外道。独露处共立共语。波逸提

若比丘尼。与比丘独街巷中共立耳语。遣伴比丘尼令远去。波逸提

若比丘尼。与白衣及外道。独行巷中共立耳语。遣伴比丘尼令远去。波逸提(八十)

若比丘尼裸形洗浴。波逸提

若比丘尼离水浴衣行。波逸提

若比丘尼。比丘尼得新衣。先以供养便不复还。波逸提

若比丘尼遮僧分衣。波逸提

若比丘尼撤比丘尼衣已。无病过四五日不成。波逸提

若比丘尼离五衣行。波逸提

若比丘尼。以比丘尼衣。与白衣及外道女。波逸提

若比丘尼断施人物与僧。波逸提

若比丘尼护惜他家。波逸提

若比丘尼不安居。波逸提(九十)

若比丘尼不依比丘众安居。波逸提

若比丘尼于安居内游行。波逸提

若比丘尼安居竟。不从比丘僧请见闻疑罪。波逸提

若比丘尼就安居请竟。一宿不去。波逸提

若比丘尼于国内恐怖处。无所依怙而独行者。波逸提

若比丘尼出国境恐怖处。无所依怙而独行者。波逸提

若比丘尼安居竟。不付嘱精舍出行者。波逸提

若比丘尼安居竟。不舍精舍还主去者。波逸提

若比丘尼种种游看。波逸提

若比丘尼半月不于僧中乞教诫师。波逸提(一百)

若比丘尼入有比丘住处。见比丘不白。除急难时。波逸提

若比丘尼不满十二岁畜眷属。波逸提

若比丘尼满十二岁。僧不与作畜众羯磨。畜众者。波逸提

若比丘尼。与未满十二岁已嫁女受具足戒。波逸提

若比丘尼。满十二岁已嫁女。僧不作羯磨。与受具足戒。波逸提

若比丘尼与未满十八岁童女受学戒。波逸提

若比丘尼。虽满十八岁童女。僧不作羯磨。与受学戒。波逸提

若比丘尼语白衣归女。先与我衣我当度汝。波逸提

若比丘尼。诸比丘尼语言。如佛所说应与作畜众羯磨。汝无是事便呵诸比丘尼者。波逸提

若比丘尼。教诫及羯磨时。不往听。波逸提(一百一十)

若比丘尼。式叉摩那满二岁无难。不与受具足戒。语言汝且学是戒。波逸提

若比丘尼度淫女。波逸提

若比丘尼与未满二岁学戒尼受具足戒。波逸提

若比丘尼。满二岁学戒尼。僧不作羯磨。与受具足戒。波逸提

若比丘尼与满二岁学戒尼不学戒受具足戒。波逸提

若比丘尼与怀妊女受具足戒。波逸提

若比丘尼与新产妇受具足戒。波逸提

若比丘尼年年与弟子受具足戒。波逸提

若比丘尼异宿与弟子受具足戒。波逸提

若比丘尼新受具足戒。不六年依承和上。若使人依承者。波逸提(一百二十)

若比丘尼畜弟子。六年中不自摄取。不教人摄取。波逸提

若比丘尼。畜弟子。不自将不使人将。离本处五六由旬。波逸提

若比丘尼同学病。不自看不教人看。波逸提

若比丘尼度属人妇女。波逸提

若比丘尼度长病女人。波逸提

若比丘尼度属夫妇人。波逸提

若比丘尼度负债女人。波逸提

若比丘尼与男子闇处共立共语。波逸提

若比丘尼不语主人。辄坐其座。波逸提

若比丘尼自手与白衣及外道男子食。波逸提(一百三十)

若比丘尼向白衣说比丘过。波逸提

若比丘尼与人斗已。自打啼哭。波逸提

若比丘尼不谛了人语妄嗔他。波逸提

若比丘尼自咒誓实以咒彼。波逸提

若比丘尼。掷屎尿于篱墙外。若使人掷。波逸提

若比丘尼。掷粪扫及残食于篱墙外。若使人掷。波逸提

若比丘尼于生草上大小便。波逸提

若比丘尼掷粪扫残食生草上。波逸提

若比丘尼于有食家宿。波逸提

若比丘尼若比丘如法问不答。波逸提(一百四十)

若比丘尼乘乘行。波逸提

若比丘尼着革屣捉盖行来。波逸提

若比丘尼。捉水瓶及扇立比丘前。若给水若扇。波逸提

若比丘尼诵治病经方。波逸提

若比丘尼教他诵治病经方。波逸提

若比丘尼为人治病以为生业。波逸提

若比丘尼教他治病以为生业。波逸提

若比丘尼以饮食故为白衣家作。波逸提

若比丘尼共白衣及外道妇女同衣卧。波逸提

若比丘尼与比丘尼式叉摩那沙弥尼同衣卧。波逸提(一百五十)

若比丘尼与白衣及外道妇女更相覆眠。波逸提

若比丘尼。与比丘尼式叉摩那沙弥尼。更相覆眠。波逸提

若比丘尼以香涂身。波逸提

若比丘尼无病。以泽枯揩身。波逸提

若比丘尼畜华鬘若着。波逸提

若比丘尼着宝腰络。波逸提

若比丘尼着裨身衣。波逸提

若比丘尼畜种种严身具。波逸提

若比丘尼畜皮。波逸提

若比丘尼发长。波逸提(一百六十)

若比丘尼着严身具。波逸提

若比丘尼为他作严身具。波逸提

若比丘尼绩缕。波逸提

若比丘尼不问白衣。辄在其家敷卧具住。波逸提

若比丘尼至白衣家。敷其坐卧具。若使人敷。去时不自举。不教人举。波逸提

若比丘尼自煮生物作食。波逸提

若比丘尼先听住后慎诱者。波逸提

若比丘尼不白僧辄使男子治病。波逸提

若比丘尼夜辄开都门出。不语余比丘尼令闭。波逸提

若比丘尼白衣不唤。非时入其家。波逸提(一百七十)

若比丘尼受请。主人未唱。随意食者。波逸提

若比丘尼。被驱出羯磨。不去者。波逸提

若比丘尼。僧如法集会。不即往。波逸提

若比丘尼观歌舞作伎。波逸提

若比丘尼往边地。波逸提

若比丘尼度二根人。波逸提

若比丘尼。度二道合作一道女人。波逸提

若比丘尼度常有月水女人。波逸提

若比丘尼见比丘。不起不礼不请坐。波逸提

若比丘尼烧隐处毛。波逸提(一百八十)

若比丘尼不着僧祇支入白衣家。波逸提

若比丘尼与白衣对坐。临身相近说法。波逸提

若比丘尼自歌舞。波逸提

若比丘尼遮受迦絺那衣。波逸提

若比丘尼遮舍迦絺那衣。波逸提

若比丘尼不白比丘。辄问义者。波逸提

若比丘尼以男子不净。自内形中。波逸提

若比丘尼作外道事。火法然火。波逸提

若比丘尼在有人处浴。波逸提

若比丘尼诵外道咒术。若教人诵。波逸提(一百九十)

若比丘尼一众授具足戒。波逸提

若比丘尼自作畜众羯磨。波逸提

若比丘尼自作二岁学戒羯磨。波逸提

若比丘尼自受二岁学戒。波逸提

若比丘尼。作二岁学戒竟。羯磨经宿。乃授具足戒。波逸提

若比丘尼作二岁学戒羯磨竟。经宿乃授其学戒。波逸提

若比丘尼自织作衣着。波逸提

若比丘尼。国内恐怖处。于中游行。波逸提

若比丘尼自作己像。若使人作。波逸提

若比丘尼庄严女人。波逸提(二百)

若比丘尼水中逆流行。波逸提

若比丘尼仰卧水来下处。波逸提

若比丘尼治腰使细。波逸提

若比丘尼种种治身。波逸提

若比丘尼如妓女法着衣。波逸提

若比丘尼如白衣妇女法着衣。波逸提

若比丘尼以欲心自观形体。波逸提

若比丘尼照镜。波逸提

若比丘尼自卜。若就他卜。波逸提

若比丘尼随世俗论者。波逸提(二百一十)

诸大姊。已说二百一十波逸提法。今问。诸大姊。是中清净不(第二第三亦如是说)

诸大姊是中清净。默然故。是事如是持

诸大姊。是八波罗提提舍尼法。半月半月戒经中说

若比丘尼无病。自为乞酥食。是比丘尼应诸比丘尼边悔过。我堕可呵法。今向诸阿姨悔过。是名悔过法

若比丘尼无病。自为乞油食。是比丘尼应诸比丘尼边悔过。我堕可呵法。今向诸阿姨悔过。是名悔过法若比丘尼无病。自为乞蜜食。是比丘尼应诸比丘尼边悔过。我堕可呵法。今向诸阿姨悔过。是名悔过法

若比丘尼无病。自为乞石蜜食。是比丘尼应诸比丘尼边悔过我堕可呵法。今向诸阿姨悔过。是名悔过法

若比丘尼无病。自为乞乳食。是比丘尼应诸比丘尼边悔过。我堕可呵法。今向诸阿姨悔过。是名悔过法

若比丘尼无病。自为乞酪食。是比丘尼应诸比丘尼边悔过。我堕可呵法。今向诸阿姨悔过。是名悔过法

若比丘尼无病。自为乞鱼食。是比丘尼应诸比丘尼边悔过。我堕可呵法。今向诸阿姨悔过。是名悔过法

若比丘尼无病。自为乞肉食。是比丘尼应诸比丘尼边悔过。我堕可呵法。今向诸阿姨悔过。是名悔过法

诸大姊。已说八波罗提提舍尼法。今问。诸大姊。是中清净不(第二第三亦如是说)

诸大姊是中清净。默然故。是事如是持

诸大姊。是众学法。半月半月戒经中说

不高着下衣应当学

不下着下衣应当学

不参差着下衣应当学

不如多罗叶着下衣应当学

不为象鼻着下衣应当学

不如圆奈着下衣应当学

不细襵着下衣应当学

不高披衣应当学

不下披衣应当学

不参差披衣应当学(一十)

好覆身入白衣舍应当学

好覆身入白衣舍坐应当学

不反抄衣着右肩上入白衣舍应当学

不反抄衣着右肩上白衣舍坐应当学

不反抄衣着左肩上入白衣舍应当学

不反抄衣着左肩上白衣舍坐应当学

不左右反抄衣着两肩上入白衣舍应当学

不左右反抄衣着两肩上白衣舍坐应当学

不摇身入白衣舍应当学

不摇身白衣舍坐应当学(二十)

不摇头入白衣舍应当学

不摇头白衣舍坐应当学

不摇肩入白衣舍应当学

不摇肩白衣舍坐应当学

不携手入白衣舍应当学

不携手白衣舍坐应当学

不隐人入白衣舍应当学

不隐人白衣舍坐应当学

不叉腰入白衣舍应当学

不叉腰白衣舍坐应当学(三十)

不拄颊入白衣舍应当学

不拄颊白衣舍坐应当学

不掉臂入白衣舍应当学

不掉臂白衣舍坐应当学

不高视入白衣舍应当学

不高视白衣舍坐应当学

不左右顾视入白衣舍应当学

不左右顾视白衣舍坐应当学

不蹲行入白衣舍应当学

不蹲行白衣舍坐应当学(四十)

不企行入白衣舍应当学

不企行白衣舍坐应当学

不覆头入白衣舍应当学

不覆头白衣舍坐应当学

不戏笑入白衣舍应当学

不戏笑白衣舍坐应当学

不高声入白衣舍应当学

不高声白衣舍坐应当学

庠序入白衣舍应当学(五十)

庠序白衣舍坐应当学

一心受食应当学

不溢钵受食应当学

羹饭俱食应当学

不于钵中处处取食应当学

不刳中央食应当学

不曲指抆钵食应当学

不嗅食食应当学

谛视钵食应当学

不弃饭食应当学

不以食手捉净饮器应当学(六十)

不吸食食应当学

不嚼食作声应当学

不舐取食应当学

不满手食应当学

不大张口食应当学

饭未至不张口待应当学

不胀颊食应当学

不啮半食应当学

不缩鼻食应当学

不含食语应当学(七十)

不舒臂取食应当学

不振手食应当学

不吐舌舐食应当学

不全吞食应当学

不揣饭遥掷口中应当学

不以钵中有食水洒白衣屋内应当学

不以饭覆羹更望得应当学

不嫌呵食应当学

不为己索益食应当学

不嫌心视比坐钵应当学(八十)

不立大小便。除病应当学

不大小便净水中除病应当学

不大小便生草菜上。除病应当学

人着履不应为说法。除病应当学

人着革屣不应为说法。除病应当学

人现胸不应为说法。除病应当学

人坐比丘尼立。不应为说法。除病应当学

人在高座比丘尼在下。不应为说法。除病应当学

人卧比丘尼坐。不应为说法。除病应当学

人在前比丘尼在后。不应为说法。除病应当学(九十)

人在道中比丘尼在道外。不应为说法。除病应当学

不为覆头人说法除病应当学

不为反抄衣人说法。除病应当学

不为左右抄衣人说法。除病应当学

不为持盖覆身人说法。除病应当学

不为骑乘人说法。除病应当学

不为拄杖人说法。除病应当学

不为捉刀人说法。除病应当学

不为捉弓箭人说法。除病应当学

树过人不得上。除大因缘应当学。因缘者。恶兽诸难。是名大因缘(一百)

诸大姊。已说众学法。今问。诸大姊。是中清净不(第二第三亦如是说)

诸大姊是中清净。默然故。是事如是持

诸大姊。已说戒经序已。说八波罗夷法已。说十七僧伽婆尸沙法已。说三十尼萨耆波逸提法已。说二百一十波逸提法已。说八波罗提提舍尼法已。说众学戒法。是法入佛戒经中。半月半月波罗提木叉中说。及余随道法。是中诸大姊。一心和合欢喜不诤。如水乳合安乐行。应当学

毗婆尸如来应正遍知。为寂静僧。略说波罗提木叉

  忍辱第一道　　涅槃佛称最
  出家恼他人　　不名为沙门

尸弃如来应正遍知。为寂静僧。略说波罗提木叉

  譬如明眼人　　能避险恶道
  世有聪明人　　能远离诸恶

比叶婆如来应正遍知。为寂静僧。略说波罗提木叉

  不恼不说过　　如戒所说行
  饭食知节量　　常乐在闲处
  心寂乐精进　　是名诸佛教

拘留孙如来应正遍知。为寂静僧。略说波罗提木叉

  譬如蜂采花　　不坏色与香
  但取其味去　　比丘入聚落
  不破坏他事　　不观作不作
  但自观身行　　谛视善不善

拘那含牟尼如来应正遍知。为寂静僧。略说波罗提木叉

  欲得好心莫放逸　　圣人善法当勤学
  若有知寂一心人　　尔乃无复忧愁患

迦叶如来应正遍知。为寂静僧。略说波罗提木叉

  一切恶莫作　　当具足善法
  自净其志意　　是则诸佛教

释迦牟尼如来应正遍知。为寂静僧。略说波罗提木叉

  护身为善哉　　能护口亦善
  护意为善哉　　护一切亦善
  比丘护一切　　便得离众苦
  比丘守口意　　身不犯众恶
  是三业道净　　得圣所得道
  若人打骂不还报　　于嫌恨人心不恨
  于嗔人中心常净　　见人为恶自不作
  七佛为世尊　　能救护世间
  所可说戒经　　我已广说竟
  诸佛及弟子　　恭敬是戒经
  恭敬戒经已　　各各相恭敬
  惭愧得具足　　能得无为道

诸大姊。已说波罗提木叉竟。僧一心得布萨

五分比丘尼戒本


五分戒本(亦名弥沙塞戒本)

        宋罽宾三藏佛陀什等译

大德僧听。冬时一月过少一夜。余有一夜三月在。老死至近佛法欲灭。诸大德。为得道故一心勤精进。所以者何。诸佛一心勤精进故得无上菩提。何况余善道法。未受具足者已出。僧今和合先作何事。(一人应答布萨说戒)诸大德。为未来诸比丘说。欲及清净

  合十指爪掌　　供养释师子
  我今欲说戒　　僧当一心听
  乃至小罪中　　心应大怖畏
  有罪一心悔　　后更莫复犯
  心马驰恶道　　放逸难禁制
  佛说切戒行　　亦如利辔勒
  佛口说教戒　　善者能信受
  是人马调顺　　能破烦恼军
  若不受教敕　　亦不爱乐戒
  是人马不调　　没在烦恼军
  若人守护戒　　如牦牛爱尾
  系心不放逸　　亦如猴着锁
  日夜常精进　　求实智慧故
  是人佛法中　　能得清净命

大德僧听。今十五日布萨说戒。若僧时到僧忍听。僧一心共作布萨。白如是有罪者发露。无罪者默然。默然故。当知诸大德清净。若比丘知如是众中三唱。忆有罪不发露。得故妄语罪。佛说故妄语罪障道法。若比丘如是众中欲求清净法。忆有罪应发露。发露则安隐。不发露罪益深。诸大德已说戒序竟。今问。诸大德。是中清净不。(如是三说)诸大德。是中清净。默然故。是事如是持

诸大德。是四波罗夷法。半月半月戒经中说若比丘。于和合僧中受具足戒。不还戒戒羸不出想。行淫法乃至共畜生。是比丘犯波罗夷罪。不应共事

若比丘。若聚落中若空地旷野中物。不与取名盗物。若不与物取故。若王若王等。若捉若杀。若偷金罪。若如是言。咄汝小汝痴汝贼。有如是相比丘。是比丘犯波罗夷罪。不应共事

若比丘若人若似人。若自杀若教人杀若自持刀与若教人持刀与。若教死若赞死。若如是言。咄人用恶活为死胜生。是人因是事死者。是比丘犯波罗夷罪不应共事若比丘。不知不见说过人法。自称言。如是知如是见。后诸比丘。若问若不问。为发露求清净故。不知言知。不见言见。除增上慢。是比丘犯波罗夷罪。不应共事。诸大德。已说四波罗夷法。若比丘犯一一戒。波罗夷不共住。如前后亦如是。是比丘波罗夷不共住。今问。诸大德。是中清净不(如是三说)诸大德。是中清净。默然故。是事如是持

诸大德。是十三僧迦婆尸沙法。半月半月戒经中说

若比丘故出不净。除梦中。僧伽婆尸沙若比丘淫乱变心。与女人身共合。若捉手臂发上下摩着细滑。僧伽婆尸沙若比丘向女人说不净语。僧伽婆尸沙若比丘语女人言。以淫欲法供养我等持戒行善法梵行者是上供养。僧伽婆尸沙若比丘行媒法。持男意至女边。持女意至男边。若为妇事若私通事。乃至一交会时。僧伽婆尸沙

若比丘无主。为身自乞作大房。应问诸比丘无难处非妨处。若不问诸比丘过量作。僧伽婆尸沙

若比丘有主。为身欲作大房。应问诸比丘无难处非妨处。若不问作。僧伽婆尸沙若比丘嗔他比丘。以无根波罗夷法谤。欲破彼比丘净行。是比丘若问若不问知是事无根。是比丘住嗔法语。僧伽婆尸沙若比丘嗔他故不喜。异分事中取片若似片法。非波罗夷比丘。以波罗夷法谤。欲破彼比丘净行故。是比丘知是事异分事中取片法作异语故。僧伽婆尸沙

若比丘欲破和合僧。勤方便受持破僧缘事。诸比丘应如是谏。大德当与僧和合。莫勤方便破僧缘事。可与僧和合。所以者何。僧和合故欢喜不诤。一心一学如水乳合安乐行。如是再三谏时舍者善。不舍者僧伽婆尸沙

若比丘有同意别异语。若一若二。是比丘语诸比丘言。莫谏是比丘。何以故。是比丘知说非不知说。诸比丘应如是谏。大德当助和合僧。莫助破和合僧。所以者何。僧和合故欢喜不诤。一心一学如水乳合安乐行。如是再三谏时舍者善。不舍者僧伽婆尸沙

若比丘依止城邑聚落。行恶行污他家皆见闻知。诸比丘应语是比丘言。大德汝行恶行污他家皆见闻知。汝出去不须是间住。是比丘语余比丘言。汝等随爱嗔怖痴语。有如是同罪比丘。有驱出者。有不驱者。如是再三谏时舍者善。不舍者僧伽婆尸沙

有一比丘恶性难共语。入戒诵中入佛经中。语诸比丘如法如律如戒经中事谏是比丘。是比丘悷不受说。语诸比丘言。大德。汝莫语我好恶。我亦不语汝好恶。汝为诸比丘说。我亦为诸比丘说。如法如律令如来众得增长。如是再三谏时舍者善。不舍者僧伽婆尸沙

诸大德。已说十三僧伽婆尸沙法。九初罪四乃至三谏。若比丘犯一一戒。应从几时覆藏与波利婆沙。波利婆沙已。六夜行摩那埵。次到阿浮呵那。如是作已。应二十人中出罪。若少一人不满二十。是比丘不得出罪。如是作已。应如是呵。法应尔故。今问。诸大德。是中清净不。(如是三说)诸大德是中清净。默然故。是事如是持

诸大德。是二不定法。半月半月戒经中说

若比丘与一女人。屏障内行淫处坐。随可信优婆夷所见是比丘随三法中一一法说。若僧伽婆尸沙。若波罗夷。若波夜提。随可信优婆夷所说如法持

若比丘与一女人。不屏覆处坐不可淫处坐。随可信优婆夷所见。是比丘随二法中一一法说。若僧伽婆尸沙。若波夜提。随可信优婆夷所说如法持

诸大德已说二不定法竟。今问。诸大德。是中清净不。(如是三说)诸大德是中清净。默然故。是事如是持

诸大德是三十尼萨耆波夜提法。半月半月戒经中说

若比丘三衣具足讫。舍迦絺那衣已。长衣乃至十日应畜。若过者尼萨耆波夜提若比丘三衣具足讫。舍迦絺那衣已。三衣中若离一一衣余处宿。尼萨耆波夜提若比丘三衣具足讫。舍迦絺那衣已。得非时衣乃至一月应畜。若过尼萨耆波夜提若比丘从非亲里比丘尼边取衣。除贸易。尼萨耆波夜提

若比丘使非亲里比丘尼浣故衣。尼萨耆波夜提

若比丘从非亲里居士乞衣。除因缘。尼萨耆波夜提

若比丘夺衣失衣漂衣。从非亲里居士居士妇乞衣。乃至上下衣应受。若过者尼萨耆波夜提

若比丘非亲里居士居士妇为办衣直作是念。以如是衣直买如是衣与某甲比丘。是比丘先不受自恣请。为好故往至居士居士妇所作是言。为我办如是衣直。若得衣。尼萨耆波夜提

若比丘非亲里居士居士妇为办衣直作是念。以如是衣直买如是衣与某甲比丘。是比丘先不受自恣请。为好衣故往至居士居士妇所言。为我办如是衣直合作一衣与我者好。若得是衣。尼萨耆波夜提若比丘若王王臣婆罗门若居士。遣使至比丘所言。大德知不。如是衣直。是王王臣婆罗门居士送。大德当受。比丘言。我比丘法不得受如是衣直。使问比丘言。有执净人不。比丘言。此是。使至执净人所言。如是衣直与某甲比丘。是比丘后须衣时。至执净人所言。我须衣我须衣。如是六返默然立住。得者好。若过索尼萨耆波夜提。若不得是衣直。应从衣直来处。若自若使人语。是事法应尔

若比丘新憍奢耶作敷具。尼萨耆波夜提若比丘纯黑羊毛作敷具者。尼萨耆波夜提

若比丘作新敷具。应二分黑三分白四分下。若不者尼萨耆波夜提

若比丘作新敷具。应满六年若减六年。不舍故敷具。更作新者。除僧羯磨。尼萨耆波夜提

若比丘作新敷具。应取故敷具四边各佛一搩手。为坏色故。不者尼萨耆波夜提若比丘行道中得羊毛。担过三由旬者。尼萨耆波夜提

若比丘使非亲里比丘尼浣染擘羊毛。尼萨耆波夜提

若比丘自手取金若使人取。尼萨耆波夜提

若比丘种种用金。尼萨耆波夜提若比丘种种贩卖。尼萨耆波夜提若比丘长钵乃至十日应畜。若过尼萨耆波夜提

若比丘先所畜钵未满五缀。为好故更畜新者。尼萨耆波夜提

若比丘使非亲里织师织。尼萨耆波夜提若比丘非亲里居士若居士妇。使织师得比丘织作衣。是比丘先不受自恣请。为好衣故。往至织师所语言。为我好织令致广厚。当与汝少直。若自语若使人语。后得是衣。尼萨耆波夜提

若比丘先与他物。后嗔恚嫌恨还夺取者。尼萨耆波夜提

若比丘夏三月过。有闰未满八月。寄衣白衣家。乃至六夜应往是衣所。乃至七日晓。尼萨耆波夜提

若比丘未至岁十日有急施衣。是比丘若须衣得自手取。乃至衣时应畜。若过尼萨耆波夜提

若比丘春残一月。应求雨浴衣。半月应畜。若过尼萨耆波夜提

若比丘知物向僧。自回向己者。尼萨耆波夜提

若比丘佛听病比丘服四种含消药。酥油蜜石蜜乃至七日。若过尼萨耆波夜提诸大德。已说三十尼萨耆波夜提法竟。今问。诸大德。是中清净不。(如是三说)诸大德是中清净。默然故。是事如是持

诸大德。是九十波夜提法。半月半月戒经中说

若比丘故妄语。波夜提若比丘毁呰他语。波夜提

若比丘斗乱他比丘。波夜提若比丘知僧如法断事已。还更发起。波夜提

若比丘为女人说法。过五六语。波夜提。除有知男子

若比丘以阐陀偈句。教未受具戒人者。波夜提

若比丘内实有过人法。向未受具戒人说。波夜提

若比丘知他比丘犯僧残罪。向未受具戒人说。波夜提

若比丘先共僧和合已。后如是说诸比丘随亲友人回僧物与者。波夜提

若比丘说戒时作是言。何用半月半月说是杂碎戒为。令他比丘忧愁不乐。生返戒心。作是轻呵戒者。波夜提

若比丘杀众草木。波夜提若比丘嫌骂者。波夜提

若比丘用异事恼他比丘。波夜提若比丘露地敷卧具。乃至天晓不自举不教人举。波夜提

若比丘房内敷卧具。出界外者。波夜提若比丘房内嗔忿不喜。牵出者。波夜提若比丘知他比丘先于房内敷卧具。后来强敷者。波夜提

若比丘重阁上尖脚床。用力坐卧者。波夜提

若比丘覆盖屋一分。第二分藏头。第三分应约敕。如是过约敕者。波夜提若比丘知水有虫。用浇草土者。波夜提若比丘僧不差教比丘尼。教者。波夜提若比丘僧虽差教比丘尼。乃至日没。波夜提

若比丘语余比丘言。是比丘为财物故教比丘尼者。波夜提

若比丘与比丘尼同道行。至一聚落。波夜提

若比丘与比丘尼同载一船。除因缘。波夜提

若比丘与比丘尼。独屏覆处坐。波夜提若比丘与非亲里比丘尼衣。波夜提若比丘与非亲里比丘尼作衣。波夜提若比丘与女人独露处坐。波夜提若比丘知比丘尼赞因缘得食。食者。波夜提

若比丘数数食。波夜提若比丘有余福德处。过一食。波夜提若比丘往白衣家。自恣与[麩-夫+并]糗。得取一钵。过者。波夜提

若比丘不受残食法。更食者。波夜提若比丘知他比丘食竟。不作残食法。为恼彼故。强劝令食。波夜提

若比丘别众食。波夜提。除因缘若比丘非时食。波夜提

若比丘与残宿食。食者。波夜提若比丘不受食着口中。除水及杨枝。波夜提

若比丘不病。为己乞乳酪生酥鱼肉脯者。波夜提

若比丘知水有虫。取用者。波夜提若比丘食家中卧处坐者。波夜提若比丘食家中共女人坐者。波夜提若比丘裸形外道乞。自手与食者。波夜提若比丘往看军阵发行者。波夜提若比丘往军中过二宿者。波夜提若比丘往看军器仗者。波夜提

若比丘嗔他举手向。波夜提若比丘嗔他举手打。波夜提

若比丘知他犯波罗夷。乃至一宿覆藏。波夜提

若比丘语余比丘言去来。我将汝至他家当令。汝得好食若入门。若未入门。还遣去者波夜提

若比丘僧断事如法与欲。后还悔者波夜提

若比丘与未受具戒人一处宿。过二夜波夜提

若比丘露地然火。波夜提。除病时若比丘语余比丘言。我如是知佛法义。行淫欲不能障道。诸比丘白四羯磨三谏。不舍者。波夜提

若比丘教摈人法。若畜使共事者。波夜提若比丘教摈沙弥法。畜使共事者。波夜提若比丘若宝若似宝。若自取教人取。波夜提

若比丘着不坏色新衣者。波夜提若比丘减半月内沐浴。除因缘。波夜提若比丘故夺畜生命。波夜提

若比丘恼乱他比丘。波夜提若比丘以指相击擽。波夜提若比丘以指戏水中者。波夜提

若比丘与女人同房舍宿。波夜提若比丘恐怖他比丘。波夜提

若比丘藏他衣钵。令他恐怖者。波夜提若比丘先与五众衣。辄还用。波夜提若比丘以僧残罪。谤他比丘。波夜提若比丘与女人同道。行至一聚落。波夜提若比丘。与贼同盗行至一聚落。波夜提若比丘。未满二十人与受具戒者。波夜提若比丘自掘地。若使人掘。波夜提若比丘有余福德处。四月请僧一切药施。若过受。波夜提

若比丘。说四波罗夷法言。我不受是法。当问余持律阿毗昙者波夜提

若比丘与他斗诤已。盗往听者波夜提若比丘僧断事。默然起去。不白善比丘。波夜提

若比丘不恭敬上座。波夜提若比丘饮酒咽咽。波夜提

若比丘过中入聚落。波夜提。除因缘若比丘为他知僧事。若中前中后至余家。波夜提

若比丘刹帝利王。夜未晓未藏宝。若过门若门闑。波夜提。除因缘

若比丘说四波罗夷法言。我始知是法半月半月戒经中说。诸比丘知是比丘再三说戒中。坐若不尊重。戒不摄耳听波夜提若比丘骨牙角作针筒波夜提

若比丘过佛八指作床脚波夜提若比丘草木华作敷具波夜提

若比丘过量作雨浴衣波夜提若比丘过量作覆身衣波夜提

若比丘作尼师坛。长佛二搩手。广一搩手半。更益一搩手。过者波夜提若比丘与佛等量作衣。波夜提

诸大德。已说九十波夜提法竟。今问诸大德。是中清净不(如是三说)诸大德是中清净。默然故。是事如是持

诸大德。是四波罗提提舍尼法。半月半月戒经中说

若比丘不病入聚落。从非亲里比丘尼边自手取食者。波罗提提舍尼

若比丘受比丘尼教食食者。波罗提提舍尼

若比丘有余学家。先不受他请。后来自手取食。波罗提提舍尼

若比丘僧未与羯磨。是人僧房外自手取食。波罗提提舍尼

诸大德。已说四波罗提提舍尼法竟。今问诸大德。是中清净不。(如是三说)诸大德是中清净。默然故。是事如是持

诸大德是众学法半月半月戒经中说不高着内衣应当学

不下着内衣应当学

不参差着内衣应当学

不如多罗叶着内衣应当学

不如象鼻着内衣应当学

不如圆柰着内衣应当学

不细襵着内衣应当学

不高被衣应当学

不下被衣应当学

不参差被衣应当学

好覆身入白衣舍应当学

好覆身入白衣舍坐应当学

不眄视入白衣舍应当学

不眄视入白衣舍坐应当学

不好入白衣舍应当学

不好入白衣舍坐应当学

不嗅入白衣舍应当学

不嗅入白衣舍坐应当学

不自大入白衣舍应当学

不自大入白衣舍坐应当学

小声入白衣舍应当学

小声入白衣舍坐应当学

不胡跪入白衣舍应当学

不胡跪入白衣舍坐应当学

不覆头入白衣舍应当学

不覆头入白衣舍坐应当学

不襆头入白衣舍应当学

不襆头入白衣舍坐应当学

不叉腰入白衣舍应当学

不叉腰入白衣舍坐应当学

不现胸入白衣舍应当学

不现胸入白衣舍坐应当学

不现胁入白衣舍应当学

不现胁入白衣舍坐应当学

不反抄衣入白衣舍应当学

不反抄衣入白衣舍坐应当学

不左右反抄衣入白衣舍应当学

不左右反抄衣入白衣舍坐应当学

不放衣跳入白衣舍应当学

不放衣跳入白衣舍坐应当学

不掉臂入白衣舍应当学

不掉臂入白衣舍坐应当学

不摇肩入白衣舍应当学

不摇肩入白衣舍坐应当学

不摇头入白衣舍应当学

不摇头入白衣舍坐应当学

不摇身入白衣舍应当学

不摇身入白衣舍坐应当学

不携手入白衣舍应当学

不携手入白衣舍坐应当学

不躄行入白衣舍应当学

不躄行入白衣舍坐应当学

不累脚入白衣舍应当学

不累脚入白衣舍坐应当学

不掌扶颊入白衣舍应当学

不掌扶颊入白衣舍坐应当学

一心受羹应当学

一心受饭应当学

羹饭等食应当学

不溢钵受食应当学

不偏刳食应当学

不钵中择好食应当学

不大抟饭食应当学

抟饭可口食应当学

不张口待食应当学

不含食语应当学

不啮半饭应当学

不嚼食作声食应当学

不全吞食应当学

不未咽食食应当学

不吐舌食应当学

不嗅食食应当学

不舐手食应当学

不指抆钵食应当学

不弃饭食应当学

不振手食应当学

不污手受饮器应当学

比丘不病不得为己索羹饭应当学

不以饭覆羹更望得应当学

不得嫉心看比坐钵中食应当学

一心观钵食应当学

次第食应当学

洗钵汁不得弃白衣舍内。除语主人。应当学

骑乘人不为说法。除病应当学

人在前比丘在后不为说法。除病应当学

人在道中比丘在道外不为说法。除病应当学

人在高座比丘在下不为说法。除病应当学

人坐比丘立不为说法。除病应当学

人卧比丘坐不为说法。除病应当学

人覆头不为说法。除病应当学

人襆头不为说法。除病应当学

人叉腰不为说法。除病应当学

人现胸不为说法。除病应当学

人现胁不为说法。除病应当学

人反抄衣不为说法。除病应当学

人左右反抄衣不为说法。除病应当学

人放衣挑不为说法。除病应当学

人着屐不为说法。除病应当学

人着革屣不为说法。除病应当学

人执盖不得为说法。除病应当学

人捉杖不为说法。除病应当学

人捉五尺刀不为说法。除病应当学

人捉小刀不为说法。除病应当学

人捉弓箭种种器仗不为说法。除病应当学

不应生草上大小便涕唾。除病应当学

不应净用水中大小便涕唾。除病应当学

不应立大小便。除病应当学

树过人不应上。除因缘应当学

诸大德。已说众学法竟。今问诸大德。是中清净不(如是三说)诸大德是中清净。默然故。是事如是持

诸大德。是七灭诤法。半月半月戒经中说应与现前毗腻人。当与现前毗腻应与忆念毗腻人。当与忆念毗腻应与不痴毗腻人。当与不痴毗腻应与自言持人。当与自言持

应与觅罪相人。当与觅罪相应与觅罪相人。当与多觅罪相

种种僧中诤事生如草布地。除灭应当学

诸大德。已说七灭诤法竟。今问。诸大德。是中清净不。(如是三说)诸大德是中清净。默然故。是事如是持

诸大德。已说戒序四波罗夷十三僧残二不定三十尼萨耆波夜提九十波夜提四波罗夷提提舍尼众学法七灭。诤法竟。是事入佛经中。半月半月戒经中说。若有余学当一心学。如水乳合安乐行。应当学

佛告比丘。毗婆尸佛如来应供正遍知。为寂静僧。最初略说波罗提木叉

  忍辱第一道　　涅槃佛称最
  出家恼他人　　不名为沙门

第二尸弃佛如来应供正遍知。为寂静僧。最初略说波罗提木叉

  譬如明眼人　　能避险恶道
  世有聪明人　　能远离众恶

第三毗钵施佛如来应供正遍知。为寂静僧。最初略说波罗提木叉

  不毁亦不犯　　如戒所说行
  饭食知节量　　常乐在空处
  心常乐精进　　是名诸佛教

第四拘楼孙佛如来应供正遍知。为寂静僧。最初略说波罗提木叉

  譬如蜂采华　　不坏色与香
  但取其味去　　比丘出聚然
  不破坏他事　　不观作不作
  但自观身行　　谛视善不善

第五拘那含牟尼佛如来应供正遍知。为寂静僧。最初略说波罗提木叉

  欲得好心莫放逸　　圣人善法当勤学
  若有智寂一心人　　乃能无复愁忧患

第六迦叶佛如来应供正遍知。为寂静僧。最初略说波罗提木叉

  一切恶莫作　　当具足善法
  自净其志意　　是名诸佛教

第七我释迦牟尼佛如来应供正遍知。为寂静僧。最初略说波罗提木叉

  护身为善哉　　能护口亦善
  护意为善哉　　护一切亦善
  比丘护一切　　便得离众苦
  比丘守口意　　身不犯众恶
  是三业道净　　得圣所得道
  若人捶骂不还报　　于嫌恨人心不恨
  于嗔人中心常净　　见人为恶自不作
  七佛为世尊　　能救护世间
  所可说戒经　　我已广说竟
  诸佛及弟子　　恭敬是戒经
  恭敬戒经已　　各各相恭敬
  惭愧得具足　　能得无为道

已说戒经竟僧一心布萨

五分戒本


优波离问佛经

    No. 1466

优波离问佛经

        宋元嘉年求那跋摩译

彼时佛世尊。游舍卫祇树给孤独园。于是贤者优波离。往世尊所。稽首毕一面坐。一面坐已。白世尊言。唯世尊。比丘成就几事。尽命非不依止。优波离。我比丘成就五事。尽命非不依止。何谓五。不知布萨。不知布萨剑暮。不知戒。不知说戒。减五岁。此优波离。我比丘成就五事。尽命非不依止。优波离。我比丘成就五事。尽命不依止。何谓五。知布萨。知布萨剑暮。知戒。知说戒。五岁过五岁。此优波离。我比丘成就五事。尽命不依止。复次优波离。我比丘成就五事。尽命非不依止。何谓五。不知倩岁。不知倩岁剑暮。不知戒。不知说戒。减五岁。此优波离。我比丘成就五事。尽命非不依止。优波离。我比丘成就五事。尽命不依止。何谓五。知倩岁。知倩岁剑暮。知戒。知说戒。五岁过五岁。此优波离。我比丘成就五事。尽命不依止。复次优波离。我比丘成就五事。尽命非不依止。何谓五。不知犯非犯。不知犯轻重。不知犯有残无残。不知犯恶非恶。减五岁。此优波离。我比丘成就五事。尽命非不依止。优波离。我比丘成就五事。尽命不依止。何谓五。知犯非犯。知犯轻重。知犯有残无残。知犯恶非恶。五岁过五岁。此优波离。我比丘成就五事。尽命不依止。优波离。我比丘成就五事。尽命非不依止。何谓五。不知一制。不知二制。不知偏制。不知一切制。减五岁。此优波离。我比丘成就五事。尽命非不依止。优波离。我比丘成就五事。尽命不依止。何谓五。知一制。知二制。知偏制。知一切制。五岁过五岁。此优波离。我比丘成就五事。尽命不依止。优波离。我比丘成就六事。尽命非不依止。何谓六。不知犯非犯。不知犯轻重。不知犯有残无残。不知恶非恶。不广利二部戒分别分部决定顺经。减五岁。此优波离。我比丘成就六事。尽命非不依止。优波离。我比丘成就六事。尽命不依止。何谓六。知犯非犯。知犯轻重。知犯有残无残。知犯恶非恶。广利二部戒分别分部决定顺经。五岁过五岁。此优波离。我比丘成就六事。尽命不依止

四弃捐法

维耶离。迦兰陀子。须提难故。一制(次复二制)淫犯三事。淫未食身。波罗夷。淫大食身。土罗遮。口掁男根入不掁触。突吉罗。不犯者。不知。不听。狂。心乱。病。先作

复次制。罗阅只。瓦师子。达贰迦故。一制(次复一制)不与取。犯三事。不与偷数取五钱。五钱余直。波罗夷。不与偷数取一钱。余减五钱直。土罗遮(土罗遮重罪也)不与偷数取一钱。减一钱直。突吉罗(突吉罗者恶作)不犯者。己想。同意。有暂用。饿鬼所有。畜生所有。粪扫想。狂。先作

故断人类命。犯三事。为人当堕死掘坑者。突吉罗。堕生苦痛。土罗遮。死者波罗夷。不犯者。不故。不知。不欲杀。狂。先作

不真实称过人法。犯三事。欲着故不真实称过人法。波罗夷。说彼精舍住比丘阿罗汉。解者土罗遮。不解者。突吉罗。不犯者。增上慢。不欲称说。狂。先作(四事竟)

十三事

弄失精。犯三事。故弄失。僧伽婆尸沙。故弄不失。土罗遮。方便突吉罗。不犯者。梦中。若不欲。狂。先作

女人身相近犯三事。身摩身。僧伽婆尸沙。身摩身衣。土罗遮。身衣摩身衣。突吉罗。不犯者。不故。不念。不知。不听。狂。先作

与母人恶口语。犯三事。极称说。呰毁大小便道。僧伽婆尸沙。除二道已极称说呰毁下双膝上。土罗遮。极称说呰毁身衣。突吉罗。不犯者。为义。为法。为解。狂。先作

自叹供养。犯三事。向母人自叹供养。僧伽婆尸沙。向不成男自叹供养。土罗遮。向畜生自叹供养。突吉罗。不犯者。说衣食床座。病缘药具供给。狂。先作

使行。犯三事。受思说。僧伽婆尸沙。受思不说。土罗遮。受而不思不说。突吉罗。不犯者。为僧。为福。为病行。狂。先作

自作屋。犯三事。方便作突吉罗。一抟泥未至。土罗遮。彼泥至。僧伽婆尸沙。不犯者。窟屋草庵屋。为他除住屋。一切不犯。狂。先作

作大舍。犯三事。方便作突吉罗。一塼泥未至。土罗遮。彼泥至。僧伽婆尸沙。不犯者。窟屋草庵屋。为他除住屋。一切不犯。狂。先作

无根波罗夷法躯弃。犯三事。不问作欲殡说者。僧伽婆尸沙。突吉罗。问作欲骂说者。犯于形相事。不犯者。净见净。狂。先作

比丘有少毫片异事受波罗夷驱弃。犯三事。不问作欲殡说者。僧伽婆尸沙。突吉罗。问作欲骂说者。犯于形相事。不犯者。如想语。教语。狂。先作

破僧比丘至三谏不舍。犯三事。白者突吉罗。再语土罗遮。语竟僧伽婆尸沙。不犯者。不谏而舍。狂。先作

助破比丘至三谏不舍。犯三事。白者突吉罗。再语土罗遮。语竟僧伽婆尸沙。不犯者。不谏而舍。狂。先作

辱族比丘至三谏不舍。犯三事。白者突吉罗。再语土罗遮。语竟僧伽婆尸沙。不犯者。不谏而舍。狂。先作

戾语比丘至三谏不舍犯三事。白者突吉罗。再语土罗遮。语竟僧伽婆尸沙。不犯者。不谏而舍。狂。先作(十三事竟)

三十事

余衣过十日。犯一事舍堕。不犯者。满十日受。若施送与。失坏烧夺。同意取。狂。先作

一夜离衣宿。犯一事舍堕不犯者。若向晓舍送与。失坏烧夺。同意取。比丘要。狂。先作

取非时衣过月。犯一事舍堕。不犯者。满一月受。若施送与。狂。先作

取非亲里尼衣。犯二事。方便取突吉罗。取已舍堕。不犯者。亲里贸易。少易多。多易少。比丘同意取暂取。除衣余物取。六法尼。沙弥尼。狂。先作

非亲里尼浣故衣。犯二事。方便浣突吉罗。浣已舍堕。不犯者。亲里浣亲里。非亲弟子不语而浣。未着而浣。除衣余具浣。六法尼。沙弥尼。狂。先作

非亲里居士妇求衣。犯二事。方便求突吉罗。求已舍堕。不犯者。时故亲里。若请。为他。自物。狂。先作

过足求衣。犯二事。方便求突吉罗。求已舍堕。不犯者。余残。不为夺作与。不为失作与。亲里。若请。为他。自物。狂。先作

非亲里居士居士妇。本不请为衣往自亲。犯二事。方便自亲突吉罗。自亲已舍堕。不犯者。亲里。若请。为他。自物。欲好作教不好作。狂先作

二非亲里居士。本不请为衣往往自亲。犯二事。方便自亲突吉罗。自亲已舍堕。不犯者。亲里。若请。为他。自物。欲好作教不好作。狂。先作

过三返语过六返住成衣与。犯二事。方便成与突吉罗。成与已舍堕不犯者。三返语六返住。减三返语减六返住。不语而与。主语与。狂。先作

绣所杂作卧敷。犯二事。方便作突吉罗。作已舍堕。不犯者。作帐覆地。拘执褥枕。狂。先作

纯黑羊毛作卧敷。犯二事。方便作突吉罗。作已舍堕。不犯者。作帐覆地。拘执。狂。先作

不取等白等牻作卧具。犯二事。方便作突吉罗。作已舍堕。不犯者。取等白等牻作。取多白多牻作。取纯白纯牻。作帐覆地。狂。先作

未六年而作卧敷。犯二事。方便作突吉罗。作已舍堕。不犯者。六年作。过六年。为他作教作。他作得用。作帐覆地。拘执褥枕。比丘要。狂。先作

不取故卧敷缘善逝尺作新坐具卧敷。犯二事。方便作突吉罗。作已舍堕。不犯者。取故卧具缘善逝尺作。无有取少作。都无有不取作。他作得用。帐覆地。狂。先作

取羊毛过三由延。犯二事。初脚过三由延突吉罗。两脚过三由延舍堕。不犯者。三由延。减三由延。三由延还。夺更得。弃更得。教他领直。狂。先作

非亲里尼浣羊毛。犯二事。方便浣突吉罗。浣已舍堕。不犯者。亲里浣非亲里弟子不语而浣。未用而浣领。六法尼。沙弥尼。狂。先作

取银。犯二事。方便取突吉罗。取已舍堕不犯者。或园内园边自取教取举。彼有者当取。狂。先作

种种卖银行。犯二事。方便行突吉罗。行已舍堕。不犯者。非银。非银相似者。不犯。狂先作

种种贩卖行。犯二事。方便行突吉罗。行已舍堕。不犯者。问价直示语作净者。是我物我须是我须是。狂先作

长钵过十日。犯一事舍堕。不犯者。满十日受。若施送与。失坏夺取。同意取。狂先作

减五缀钵更作新钵。犯二事。方便作突吉罗。作已舍堕。不犯者。失钵。破钵。亲里。若请。为他。自物。狂先作

自乞缕织师织衣。犯二事。方便织突吉罗。织已舍堕。不犯者。缝衣禅带钵囊腰带肩带漉水物。亲里。若请。为他。自物。狂先作

非亲里居士本不请。为衣往织师所自亲。犯二事。方便自亲突吉罗。自亲已舍堕。不犯者。亲里若请。为他自物。欲好织教不好织。狂先作

自与比丘衣。嗔不可意夺者。犯二事。方便夺突吉罗。夺已舍堕。不犯者。彼与。同意取。狂先作

取本衣过衣时。犯一事舍堕。不犯者。当时受。若施送与。失坏烧夺。同意取。狂先作

三衣随其衣举着家内过六夜离。犯一事舍堕。不犯者。六夜离。减六夜离。六复至村内宿而去。六夜向晓舍送与。失坏烧夺。同意取。比丘要。狂先作

过春余月求雨被衣。犯二事。方便求突吉罗。求已舍堕。不犯者。春余月求。春余半月持。减春余月求减春余半月持。至夏舍浣举。夺衣失衣。时着急事。狂先作

知物向僧自求。犯二事。方便求突吉罗。求已舍堕。不犯者。问与谁。随君施法。用可得善利。随君心与。狂先作

取药过七日。犯一事舍堕。不犯者。满七日受送与。失坏烧夺同意取。至成弃与。未具戒得服。狂先作(三十事竟)

九十二事

知而妄语。犯五事。欲着故。不真实。称过人法。波罗夷。无根波罗夷法驱弃。僧迦婆尸沙。说彼精舍住比丘阿罗汉。解者。土罗遮。不解者。突吉罗。知而妄语。波逸提。不犯者。本说。误说。狂先作

形相。犯二事。形相未具足。突吉罗。形相具足。波逸提。不犯者为义。为法。为解。狂先作

两舌。犯二事。具足所两舌。波逸提。未具足所两舌。突吉罗。不犯者。不欲作别离。狂先作

知如法止更举。犯二事。方便举突吉罗。举已波逸提。不犯者。非法群党。知非剑暮作剑暮故举。狂先作

母人说法过五六语。犯二事。方便说突吉罗。句句波逸提。不犯者。有可知男。说五六语。减五六语。起更坐说。为异母人问事答事。为他说母人听。狂先作

未具足说句法。犯二事。方便说突吉罗。句句波逸提。不犯者。教诵。狂先作

实上人法。向未具足人说。犯二事。方便向说突吉罗。向说已波逸提。不犯者。向具足实。狂先作

向未具足说比丘所犯罪。犯二事。方便向说突吉罗。说已波逸提。不犯者。向说床。不事事。若说非床。比丘要。狂先作

同僧与衣后违法。犯二事。方便违突吉罗。违已波逸提。不犯爱恚痴畏与。破不成与故违。狂先作

知物向僧求与人(梵本云与私也)犯二事。方便求突吉罗。求已波逸提。不犯者。问与谁。随君施法。用可得善利。随君心与。狂先作

毁呰律。犯二事。方便毁呰突吉罗。毁呰已波逸提。不犯者。不欲毁呰言。诵经偈阿毗昙已。然后当诵律。狂先作

斫鬼村二事。方便斫突吉罗。下下波逸提。不犯者。知此与此。取此须此此语净作。不念不知。狂先作

呵责比丘。犯二事。方便诃责突吉罗。呵责已波逸提。不犯者。姓爱恚痴。作恐怖故呵责。狂先作

余语犯二事。事未成余语突吉罗。事成余语波逸提。不犯者。不知问疾不答。打僧骂诤故。破僧竞故。非法党故。非剑暮作剑暮故不答。狂先作

僧床榻褥拘执。露地布置。不举不别去。犯二事。初脚过土突吉罗。两脚过土波逸提。不犯者。举去。教别去。晒去。缘碍急事。狂先作

僧堂舍布置宿。不举不别去。犯二事。初脚过阈突吉罗。两脚过波逸提。不犯者。举去别去缘碍暂出。住彼白缘碍急事。狂先作

比丘嗔不可意驱出僧房。犯二事。方便驱出突吉罗。驱出已波逸提。不犯者。无暂故驱出教驱。彼物具出教出。狂故打骂诤乱。作斗僧故。弟子不如法故驱出教驱。彼物具出教。狂先作

知比丘先住相近宿犯二事。方便卧突吉罗。卧已波逸提。不犯者。病故住。寒热故住。急事。狂先作

僧房重阁屋。尖脚床榻用力坐。犯二事。方便用力坐突吉罗。用力坐已波逸提。不犯者。非阁屋团脚牢。无有住者立过取物。狂先作

知虫水浇泥草。犯二事。方便浇突吉罗。浇已波逸提。不犯者。不故。不知。不念。狂先作

过是再三重治者。犯二事。方便治突吉罗。治已波逸提。不犯者。再三重。减再三重。窟屋草屋。为他自物。除住居。一切不犯。狂先作

不差教比丘尼。犯二事。方便教突吉罗。教已波逸提。不犯者。问诵师语诵。问事答事。为他说尼听。六法尼。沙弥尼。狂先作

教比丘尼日入者。犯二事。方便教突吉罗。教已波逸提。不犯者。问诵师语诵。问事答事。为他说尼听。六法尼。沙弥尼。狂先作

往尼舍教。犯二事。方便教突吉罗。教已波逸提不犯者。时故问诵师语诵。问事答事。为他说尼听。六法尼。沙弥尼。狂先作

说贪食教尼。犯二事。方便说突吉罗。说已波逸提。不犯者。说衣床座病缘药具供顺。敬重供养故教。狂先作

共尼同一道行。犯二事。方便行突吉罗。行已波逸提。不犯者。时故不相随去尼随去。比丘不随不要去急事。狂先作

共尼同船上。犯二事。方便上突吉罗。上已波逸提。不犯者。度不相随上尼随上。比丘不随上不要上急事。狂先作

与非亲里尼衣。犯二事。方便与突吉罗。与已波逸提。不犯者。亲里贸易。少易多。多易少。尼同意取暂取除衣余物取。六法尼。沙弥尼。狂先作

缝非亲里尼衣。犯二事。方便缝突吉罗。针针波逸提。不犯者。亲里。除衣缝余物教缝。六法尼。沙弥尼。狂先作

共一尼一处坐。犯二事。方便坐突吉罗。坐已波逸提。不犯者。有可知男伴。立不坐。无异坐。狂先作

共一母人一处坐。犯二事。方便坐突吉罗。坐已波逸提。不犯者。有可知男伴。立不坐。无异坐。狂先作

知尼叹饭食。犯二事。当食而受突吉罗。口口波逸提。不犯者。旧檀越。六法尼。沙弥尼。除五种食。一切不犯。狂先作(昙摩罗叉云。五种食者。糗饭鱼肉煮麦饭也)展转食。犯二事。当食而受突吉罗。口口波逸提。不犯者。时故彼二请一处一食。举村请已随彼食。众人请已随彼食。请时比丘言当去。常食筹食。月半说戒。月朝。除五种食一切不犯。狂先作

过是所住食。犯二事。当食而食突吉罗。口口波逸提。不犯者。病故。不病食去已。更来食者。主请为设食。若不足。除五种食一切不犯。狂先作

过满两三钵取。犯二事。方便取突吉罗。取已波逸提。不犯者。满两三钵。减再三钵。亲里若请。为他自物。狂先作

请食已不嘱食而食。犯二事。当食而受突吉罗。口口波逸提。不犯者。嘱而食嘱已当食而受。为他受。时须七日(梵本七日者皆言七时无日字)终身因缘食。狂先作(译者解云。因缘食者食已不嘱。后饥须当自求乞一钵食。授与彼嘱食比丘。比丘即或一口或五三口食已。还授与得啖也)比丘请食已不嘱食强请食。犯二事。彼言当受食者突吉罗。食竟波逸提。不犯者。与嘱者食。为他与去。时须七日。终身因缘与食。狂先作

群食犯二事。当食而受突吉罗。口口波逸提。不犯者。时故两一处食。乞共一处食。常食筹食。月半说戒月朝。除五种食一切不犯。狂先作

非时所食所啖者。犯二事。当食而受突吉罗。口口波逸提。不犯者。时须七日。终身。狂先作

举所食。啖食啖者。犯二事。当食而食突吉罗。口口波逸提。不犯者。随时随时食。时须时须食。七日七日食。终身食。狂先作

不受着口中犯二事。当食而取突吉罗。口口波逸提。不犯者。水及齿木。狂先作

自为求好食食。犯二事。当食而受突吉罗。口口波逸提。不犯者。病为病者求。不病食病者残。亲里若请。为他自物。狂先作

知水虫饮。犯二事。方便饮突吉罗。饮已波逸提。不犯者。知饮水虫不死而。狂先作

有食舍相近坐。犯二事。方便坐突吉罗。坐已波逸提。不犯者。大家行床捡手足坐。小家床不相接坐。比丘有伴。俱出俱淫罢。非宿屋。狂先作

屏障处共母人床坐。犯二事。方便坐突吉罗。坐已波逸提。不犯者。有可知男伴。立不坐。无异意坐。狂先作

自手与无衣异学夫妇食。犯二事。方便与突吉罗。与已波逸提。不犯者。教与不自与。放地与。狂先作

去视军发行。犯二事。当去突吉罗。立彼视波逸提。不犯者。住精舍见。比丘或立坐卧来去见。因缘急事。狂先作

过二夜军宿。犯二事。方便宿突吉罗。宿已波逸提。不犯者。二夜宿。减二夜宿。三夜向晓复宿。病故为病军将逼留缘碍急事。狂先作

去视战阵犯二事。当去突吉罗。立彼视波逸提。不犯者。住精舍见。比丘或立坐卧来去。有所作去。急事。狂先作

比丘嗔不可意与手卷。犯二事。方便与突吉罗。与已波逸提。不犯者。触娆欲脱故与。狂先作

比丘嗔不可意举手相恐。犯二事。方便举突吉罗。举已波逸提。不犯者。触娆欲脱故举。狂先作

知比丘犯罪覆藏犯一事。波逸提不犯者。打僧骂故群诤故不向说。破僧竞故不向说。刚强害命复梵行。不见余好比丘。不欲覆藏。知自现故。狂先作

比丘若来村邑食。彼人已或与或不与遣者。犯二事。方便突吉罗。遣已波逸提。不犯者。俱一处不足故遣。见贵物相打起贪法故遣。见母人起不乐故遣。病守精舍与食而遣。欲作非威仪故遣。狂先作

燃火炙。犯二事。方便然突吉罗。然已波逸提。不犯者。病故他作而炙油火蛇窟。因缘急事。狂先作

法事可作已后违法。犯二事。方便违突吉罗。违已波逸提。不犯者。非法党故。知非剑暮作剑暮。狂先作(五十五)

未具足过二夜同宿犯二事。方便卧突吉罗。卧已波逸提。不犯者。二夜住。减二夜住。三夜向晓复住。一切覆不障。一切障不覆。都不覆不障。未具足卧比丘坐。比丘卧未具足坐。俱坐。狂先作

恶见至三谏不舍。犯二事。白者突吉罗。语竟波逸提。不犯者。不谏而舍。狂先作

知是非法语比丘不舍所见共止。犯二事。方便共止突吉罗。共止已波逸提。不犯者。知未举。若罢舍见。狂先作

知是摈沙弥安处。犯二事。方便安处突吉罗。安处已波逸提。不犯者。知不摈舍见。狂先作

取宝犯二事。方便取突吉罗。取已波逸提。不犯者。宝似宝者。或园内园边自取教取举。彼有者当取。似宝者。同意取暂取。粪扫想取。狂先作

不取三恶色作新衣。着犯二事。方便着突吉罗。着已波逸提。不犯者。取著作净已失脱灭。以净缝牒不净。补缘。狂先作

减半月浴。犯二事。方便浴突吉罗。浴竟波逸提。不犯者。时故半月。过半月。卒行浴。边国中。狂先作

故断众生命有四种。为当堕死掘坑者。突吉罗。人堕死。波罗夷。阅叉饿鬼畜生人像者堕死。土罗遮。畜生堕死。波逸提。不犯者。不故不知。不欲杀。狂先作

故弄比丘悔。犯二事。方便弄突吉罗。弄已波逸提。不犯者。不欲弄悔。知不满二十与具足。知过时食。知饮酒。知与母人共屏处坐。知此教悔。狂先作

指挃笑。犯二事。方便笑突吉罗。笑已波逸提。不犯者。不欲笑。有事故。狂先作

水戏犯二事。没水下戏突吉罗。在水上戏波逸提。不犯者。不欲笑。有事入水。或没或出。渡故去急。狂先作

母人同宿。犯二事。方便卧突吉罗。卧已波逸提。不犯者。一切覆不障。一切障不覆。都不覆不障母人卧比丘坐。比丘卧母人坐俱坐。狂先作

比丘恐怖。犯二事。方便怖突吉罗。怖已波逸提。不犯者。不欲怖。有贼恶虫毗舍遮故。示色声香味细滑。狂先作

藏衣钵坐具针筒腰带。犯二事。方便藏突吉罗。藏已波逸提。不犯者。不欲笑恶处与举。若举说法已与。狂先作

比丘比丘尼六法尼沙弥沙弥尼所。自求衣着不与直。犯二事。方便着突吉罗。着已波逸提。不犯者。彼与。同意取。狂先作

比丘无根僧残法驱弃。犯二事。方便驱突吉罗。驱已波逸提。不犯者。如想语教语。狂先作

知盗共一道行。犯二事。方便行突吉罗。行已波逸提。不犯者。不相随去。人随去比丘不随去。要急事。狂先作

共母人一道行。犯二事。方便行突吉罗。行已波逸提。不犯者。不相随去。母人随去比丘不随去。不要去。狂先作

知人年减二十与具足。犯二事。方便与具足突吉罗。与具足已波逸提。不犯者。年减二十想满与。年满二十与具足。狂先作

掘地犯二事。方便掘突吉罗。下下波逸提。不犯者。知此与此。须此取此。此语净作。不故不念。不知。狂先作

过是求药。犯二事。方便求突吉罗。求已波逸提。不犯者。请是药求是药。请中夜者求中夜。请我此药。我少此药。示须此药。亲里若请。为他自物。狂先作

比丘说法时语。若我不学此所学戒。当问余真持律比丘。犯二事。方便语突吉罗。语已波逸提。不犯者。言当知当学。狂先作

知比丘相打骂诤立听。犯二事。当去突吉罗。立听已波逸提。不犯者。听此已当舍止息。当自避故去。狂先作

僧断事时不嘱起去。犯二事。轻而离突吉罗。离已波逸提。不犯者。打僧骂故。乱斗诤故去。破僧竞故去非法群党。非剑暮作剑暮。若病为病急大小便。不欲坏剑暮。正尔当还故去。狂先作

作扰动。犯二事。方便作突吉罗。作已波逸提。不犯者。如我师所受问若说。狂先作

饮酒犯二事。当饮而取突吉罗。口口波逸提。不犯者。非酒似酒气味。在羹中。狂先作

有比丘不白非时入村。犯二事。初脚过障突吉罗。两脚过波逸提。不犯者。急有所作。有比丘白去。无比丘不白去。精舍去。尼舍去。异学处去。道由村过。急事。狂先作

请食时有比丘不白。食前食后彼舍中行。犯二事。初脚发过突吉罗。两脚过波逸提。不犯者。时故有比丘白而入。无比丘不白入。家边道他家去。园内去。尼舍去。异学处去。急事。狂先作

先未通入王门。犯二事。初脚发过突吉罗。两脚过波逸提。不犯者。先通。非王种。不拜为王。王夫人俱出。宿屋。狂先作

贡高犯二事。事未成贡高突吉罗。事成贡高已波逸提。不犯者。不欲贡高。不广闻。减再三返闻。狂先作

骨牙角作针筒。犯二事。方便作突吉罗。作已波逸提。不犯者。禅镇攒。药筒药匕(梵本用柿药着眼中物。不名匕也)斧拂柄。狂先作

过量作床榻(梵本不言榻也音似名小床也)犯二事。方便作突吉罗。作已波逸提。不犯者。如量作。减作他作。过量得截用。狂先作

绵缠结作床榻。犯二事。方便作突吉罗。作已波逸提。不犯者。禅带腰带钵囊。漉水物作枕他作得破用。狂先作

过重作两被。犯二事。方便作突吉罗。作已波逸提。不犯者。如量作减作。他过量作得截用。狂先作

过量作泥洹僧。犯二事。方便作突吉罗。作已波逸提。不犯者。如量作减作。他过量作得截用。狂先作

过量作坐具。犯二事。方便作突吉罗。作已波逸提。不犯者。如量作减作。他过量作得破用。狂先作

知如来衣量作衣。犯二事。方便作突吉罗。作已波逸提。不犯者。减作。他过量作得截用。狂先作(九十二事竟)

四悔过法(译者解云。四悔者。或言应说法。或言应发露者也)

入家内自手取非亲里尼食。犯二事。当食而取突吉罗。口口是悔过。不犯者。亲里。教与不自与。放地与。精舍内与。时须七日。终身因缘。六法尼。沙弥尼。狂先作

比丘尼索不诃而食。犯二事。当食而受突吉罗。口口是悔过。不犯者。自有食教与不自与。他有食与不教与。教与未得食者。六法尼沙弥尼。除五种食一切不犯。狂先作

拜为学家中自手取食。犯二事。当食而取突吉罗口口是悔过。不犯者。若请若病。请者病者。残常食。时须食。七日终身。因缘。狂先作

阿练若住处中。先不差园外自手取食。犯二事。当食而取突吉罗。口口是悔过。不犯者。若差若病。差者病者残。山所生根皮叶花果。时须七日终身。狂先作(四悔过竟)

众多法

前后参差着泥洹僧。突吉罗。不犯者。不故不念不知。病急事。狂先作

前后参差披衣。突吉罗。不犯者。不故不念不知。病急事。狂先作

露身入家内。突吉罗。不犯者。不故。狂先作

露身坐家内。突吉罗。不犯者。不故不念不知。病眠急事。狂先作

呵责入家内。突吉罗。不犯者。不故不念不知。病急事。狂先作

呵责坐家内突吉罗。不犯者。不故不念不知。

病急事。狂先作

左右视入家内突吉罗。不犯者。不故。狂先作

左右视坐家内突吉罗。不犯者。不故不念不知。狂先作

作大高声入家内突吉罗。不犯者。不故。狂先作

作大高声坐家内突吉罗。不犯者。不故不念。不知。狂先作

蹲入家内突吉罗。不犯者。不故。狂先作。

覆头入家内突吉罗。不犯者。不故不念不知。病眠急事。狂先作

覆头坐家内突吉罗。不犯者。眠。狂先作

现胸入家内突吉罗。不犯者。不故。狂先作

现胸坐家内突吉罗。不犯者。不故不念不知。病眠急事。狂先作

下垂坐家内突吉罗。不犯者。不故不念不知。

病眠急事。狂先作

抄衣入家内突吉罗。不犯者。不故。狂先作

抄衣坐家内突吉罗。不犯者。不故不念不知。

病眠急事。狂先作

摇臂入家内突吉罗。不犯者。不故。狂先作

摇身坐家内突吉罗。不犯者。不故不念不知。病眠急事。狂先作

摇头入家内突吉罗。不犯者。不故不念不知。狂先作

摇头坐家内突吉罗。不犯者。不故不念不知。病眠急事。狂先作

弄手脚入家内突吉罗。不犯者。不故。狂先作

弄手脚坐家内突吉罗。不犯者。不故。狂先作

不端一受饭突吉罗。不犯者。不故。狂先作

左右视受饭突吉罗。不犯者。不故。狂先作

多取羹突吉罗。不犯者。不故不念不知。病若种种亲里若请。为他自物。急事。狂先作

堆受饭突吉罗。不犯者。不故。狂先作

爴堆饭食突吉罗。不犯者。不故不念不知。病爴残着一处食。急事。狂先作

不端一食突吉罗。不犯者。不故。狂先作

处处采饭食突吉罗。不犯者。不故不念不知。病采与他采出。急事。狂先作

多羹食突吉罗。不犯者。不故不念不知。病种种亲里若请。自物急事。狂先作

大作抟突吉罗。不犯者。不故不念不知。病若饼果。急事。狂先作

长作抟突吉罗。不犯者。不故不念不知。病饼果急事。狂先作

抟未至张口突吉罗。不犯者。不故。狂先作

含饭语突吉罗。不犯者。狂先作

一切手入口突吉罗。不犯者。不故。狂先作作[口*(十/田/寸)][口*集]食突吉罗。不犯者。不故。狂先作

作吸食突吉罗。不犯者。不故。狂先作

舐唇食突吉罗。不犯者。不故不念不知。病急事。狂先作

吐舌食突吉罗。不犯者。不故不念不知。病急事。狂先作

缩鼻食突吉罗。不犯者。不故不念。狂先作

截抟食突吉罗。不犯者。不故不念不知。病若饼果。急事。狂先作

作吐出食突吉罗。不犯者。不故不念不知。病若饼果。急事。狂先作

舐手食突吉罗。不犯者。不故不念不知。狂先作

放钵食突吉罗。不犯者。不故不念不知。病放残着一处食。急事。狂先作

振手食突吉罗。不犯者。不故不念不知。病急事。狂先作

作酪饭食突吉罗。不犯者。不故不念不知。病急事。狂先作

腻手取水器突吉罗。不犯者。不故不念不知。病当洗教洗故取。急事。狂先作

自为索羹饭食突吉罗。不犯者。不故不念不知。病亲里若请。为他自物。急事。狂先作

羹味覆饭突吉罗。不犯者。不故不念不知。主覆与不欲更得。急事。狂先作

呵想视他钵突吉罗。不犯者。不故不念不知。不呵想视。急事。狂先作

澡钵水有饭泻家内突吉罗。不犯者。不故不念不知。病撩去若破泻外。急事。狂先作

为骑乘说法突吉罗。不犯者。不故不念。狂先作

后行为前说法突吉罗。不犯者。不故。狂先作

道外为道中说法突吉罗。不犯者。不故。狂先作

地坐为床上说法突吉罗。不犯者。不故不念不知。病急事。狂先作

卑床为高床坐说法突吉罗。不犯者。不故不念不知。病急事。狂先作

立为坐说法突吉罗。不犯者。不故不念不知。狂先作

为卧说法突吉罗。不犯者。不故。狂先作

为覆头说法突吉罗。不犯者。不故不念不知。露头急事。狂先作

为缠头说法突吉罗。不犯者。不故不念不知。病露发急事。狂先作

为垂衣坐说法突吉罗。不犯者。不故不念。狂先作

为着屣说法突吉罗。不犯者。不故不念。狂先作

为着屐说法突吉罗。不犯者。不故不念。狂先作

为持杖说法突吉罗。不犯者。不故。狂先作

为持盖说法突吉罗。不犯者。不故。狂先作

为持刀说法突吉罗。不犯者。不故不知。狂先作

为持器仗(梵本音不言器仗也更有名难转也)说法突吉罗。不犯者。不故不念。狂先作

生草上作大小便涕唾突吉罗。不犯者。不故不知病。非生草用拭。急事。狂先作

水中作大小便涕唾突吉罗。不犯者。不故不念不知。病水边洗。急事。狂先作

立作大小便突吉罗。不犯者。不故不念不知。病。狂先作(众多七十四竟)

优波离问佛经


优婆塞戒经

    No. 1488

优婆塞戒经卷第一

        北凉中印度三藏昙无谶译

    集会品第一

如是我闻。一时佛在舍卫国祇树林中阿那邠坻精舍。与大比丘僧千二百五十人。五百比丘尼。千优婆塞。五百乞儿。尔时会中有长者子。名曰善生。白佛言。世尊。外道六师常演说法教众生言。若能晨朝敬礼六方。则得增长命之与财。何以故。东方之土属于帝释。有供养者释提桓因则为护助。南方之土属阎罗王。有供养者。彼阎罗王则为护助。西方之土属婆楼那天。有供养者。彼婆楼那则为护助。北方之土属拘毗罗天。有供养者。彼拘毗罗则为护助。下方之土属于火天。有供养者。火天则为护助。上方之土属于风天。有供养者。彼亦为护。世尊。佛法之中颇有如是六方不耶。善男子。我佛法中亦有六方。所谓六波罗蜜。东方则是檀波罗蜜。何以故。始初出者。为出智慧光因缘故。彼东方者属众生心。若有众生能供养彼檀波罗蜜。则为增长寿命与财。南方即是尸波罗蜜。何以故。尸波罗蜜名之为右。若人供养亦得增长寿命与财。西方即是羼提波罗蜜。何以故。彼西方者名之为后。一切恶法弃于后故。若有供养则得增长寿命与财。北方即是毗离耶波罗蜜。何以故。北方名号胜诸恶法。若人供养则得增长寿命与财。下方则是禅波罗蜜。何以故。能正观察三恶道故。若人供养亦得增长命之与财。上方即是般若波罗蜜。何以故。上方者即是无上。无上故。若有供养则得增长命之与财。善男子。是六方者属众生心。非如外道六师所说。如是六方谁能供养。善男子。唯有菩萨乃能供养。世尊。以何义故名为菩萨。佛言。得菩提故名为菩萨。菩提性故名为菩萨。世尊。若言得菩提已名为菩萨者。若未供养彼六方时。云何得名为菩萨耶。若以性故名菩萨者。谁有此性。有此性者则能供养。若无性者则不能供养是故如来不应说言。彼六方者属众生心。善男子。非得菩提故名菩萨。何以故。得菩提者名之为佛。未得菩提乃名菩萨。亦非性故名菩萨也。善男子。一切众生无菩提性。如诸众生无人天性。师子虎狼狗犬等性。现在世中和合众善业因缘故。得人天身。和合不善业因缘故。得师子等畜生之身。菩萨亦尔。和合众善业因缘故。发菩提心故名菩萨。若有说言一切众生有菩萨性者。是义不然。何以故。若有性者。则不应修善业因缘供养六方。善男子。若有性者。则无初心及退转心。以无量善业因缘故。发菩提心名菩萨性。善男子。有诸众生受行外道。不乐外典颠倒说故。发菩提心。或有众生住寂静处内善因缘发菩提心。或有众生观生死过发菩提心。或有众生见恶闻恶发菩提心。或有众生深知自身贪欲嗔恚愚痴悭嫉为呵责故发菩提心。或有众生见诸外道五通神仙发菩提心。或有众生欲知世间有边无边故发菩提心。或有众生见闻如来不思议故发菩提心。或有众生生怜愍故发菩提心。或有众生爱众生故发菩提心。善男子。菩提之心凡有三种。谓下中上。若言众生定有性者。云何说言有三种耶。众生下心能作中心。中心作上。上心作中。中心作下。众生勤修无量善法故能增上。不勤修故便退为下。若善修进则名不退。若不修进名之为退。一切时中常为一切无边众生修集善故名不退转。若不如是是名退转。如是菩萨则有退心及怖畏心。若一切时中为一切众生修集善法得不退转。是故我记是大喜地不久当得阿耨多罗三藐三菩提。善男子。三种菩提无有定性。若有定性。已发声闻缘觉心者。则不能发菩提之心。善男子。譬如众僧无有定性。是三种性亦复如是。若有说言定有性者。是名外道。何以故。诸外道等无因果故。如自在天非因非果。善男子。或有人说菩萨之性。譬如石中定有金性。以巧方便因缘发故得为金用。菩萨之性亦如是者。是梵志说。何以故。梵志等常言。尼拘陀子有尼拘陀树。眼有火石。是故梵志无因无果。因即是果。果即是因。尼拘陀子具足而有尼拘陀树。当知即是梵志因果。是义不然。何以故。因细果粗故。若言眼中定有火者。眼则被烧。眼若被烧云何能见。眼中有石。石则遮眼。眼若有遮复云何见。善男子。如梵志说。有即是有。无即是无。无则不生。有不应灭。若言石中有金性者。金不说性。性不说金。善男子。因缘故则有和合。缘和合故本无后有。如梵志言。无即永无。是义云何。金合水银金则灭坏。若言有不应灭。是义云何。若说众生有菩萨性。是名外道。不名佛道。善男子。譬如和合石因缘故而有金用。菩萨之性亦复如是。众生有思名为欲心。以如是欲善业因缘发菩提心。是则名为菩萨性也。善男子。譬如众生先无菩提后乃方有。性亦如是先无后有。是故不可说言定有。善男子。求大智慧故名菩萨。欲知一切法真实故。大庄严故。心坚固故。多度众生故。不惜身命故。是名菩萨修行大乘。善男子。菩萨有二种。一者退转。二者不退。已修三十二相业者。名不退转。若未能修。是名为退。复有二种。一者出家。二者在家。出家菩萨奉持八重具足清净。是名不退。在家菩萨奉持六重具足清净。亦名不退。善男子。外道断欲所得福德。胜于欲界一切众生所有福德。须陀洹人胜于一切外道异见。斯陀含人胜于一切须陀洹果。阿那含人胜于一切斯陀含果。阿罗汉人胜于一切阿那含果。辟支佛人胜于一切阿罗汉果。在家之人发菩提心。胜于一切辟支佛果。出家之人发菩提心此不为难。在家之人发菩提心。是乃名为不可思议。何以故。在家之人多恶因缘所缠绕故。在家之人发菩提心时。从四天王乃至阿迦腻吒诸天。皆大惊喜作如是言。我今已得人天之师

    优婆塞戒经发菩提心品第二

善生言世尊。众生云何发菩提心。善男子。为二事故发菩提心。一者增长寿命。二者增长财物。复有二事。一者为不断绝菩萨种姓。二者为断众生罪苦烦恼。复有二事。一者自观无量世中受大苦恼不得利益。二者虽有无量恒沙诸佛悉皆不能度脱我身。我当自度。复有二事。一者作诸善业。二者作已不失。复有二事。一者为胜一切人天果报。二者为胜一切二乘果报。复有二事。一者为求菩提之道受大苦恼。二者为得无量大利益事。复有二事。一者过去未来恒沙诸佛皆如我身。二者深观菩提是可得法是故发心。复有二事。一者观六住人虽有转心犹胜一切声闻缘觉。二者勤心求索无上果故。复有二事。一者欲令一切众生悉得解脱。二者欲令众生解脱。胜外道等所得果报。复有二事。一者不舍一切众生。二者舍离一切烦恼。复有二事。一者为断众生现在苦恼。二者为遮众生未来苦恼。复有二事。一者为断智慧障碍。二者为断众生身障。善男子。发菩提心有五事。一者亲近善友。二者断嗔恚心。三者随师教诲。四者生怜愍心。五者勤修精进。复有五事。一者不见他过。二者虽见他过而心不悔。三者得善法已不生憍慢。四者见他善业不生妒心。五者观诸众生如一子想。善男子。有智之人发菩提心已。即能破坏恶业等果如须弥山。有智之人为三事故发菩提心。一者见恶世中五浊众生。二者见于如来有不可思议神通道力。三者闻佛如来八种妙声。复有二事。一者了了自知己身有苦。二者知众生苦如己受苦。为断彼苦如己无异。善男子。若有人能发菩提心。当知是人能礼六方增长命财。不如外道之所宣说

    优婆塞戒经悲品第三

善生言。世尊。彼六师等不说因果。如来今说因有二种。一者生因。二者了因。如佛初说发菩提心。为是生因。是了因耶。善男子。我为众生或说一因。或说二因。或说三因。或说四因。或说五因。或说六七至十二因。言一因者。即生因也。言二因者。生因了因。言三因者。烦恼业器。言四因者。所谓四大。言五因者。未来五支。言六因者。如契经中所说六因。言七因者。如法华说。言八因者。现在八支。言九因者。如大城经说。言十因者。如为摩男优婆塞说。十一因者。如智印说。十二因者。如十二因缘。善男子。一切有漏法无量无边因。一切无漏法无量无边因。有智之人欲尽知故发菩提心。是故如来名一切智。善男子。一切众生发菩提心。或有生因。或有了因。或有生因了因。汝今当知。夫生因者即是大悲。因是悲故便能发心。是故悲心为生因也。世尊。云何而得修于悲心。善男子。智者深见一切众生沉没生死苦恼大海。为欲拔济。是故生悲。又见众生未有十力四无所畏大悲三念。我当云何令彼具足。是故生悲。又见众生虽多怨毒亦作亲想。是故生悲。又见众生迷于正路无有示导。是故生悲。又见众生卧五欲泥而不能出犹故放逸。是故生悲。又见众生常为财物妻子缠缚不能舍离。是故生悲。又见众生以色命故而生憍慢。是故生悲。又见众生为恶知识之所诳惑。故生亲想。如六师等。是故生悲。又见众生堕生有界受诸苦恼犹故乐着。是故生悲。又见众生造身口意不善恶业多受苦果犹故乐着。是故生悲。又见众生渴求五欲如渴饮碱水。是故生悲。又见众生虽欲求乐不造乐因。虽不乐苦喜造苦因。欲受天乐不具足戒。是故生悲。又见众生于无我我所生我我所想。是故生悲。又见众生无定有性流转五有。是故生悲。又见众生畏生老死而更造作生老死业。是故生悲。又见众生受身心苦而更造业。是故生悲。又见众生爱别离苦而不断爱。是故生悲。又见众生处无明闇。不知炽然智慧灯明。是故生悲。又见众生为烦恼火之所烧然。而不能求三昧定水。是故生悲。又见众生为五欲乐造无量恶。是故生悲。又见众生知五欲苦求之不息。譬如饥者食于毒饭。是故生悲。又见众生处在恶世遭值虐王。多受苦恼犹故放逸。是故生悲。又见众生流转八苦不知断除如是苦因。是故生悲。又见众生饥渴寒热不得自在。是故生悲。又见众生毁犯禁戒。当受地狱饿鬼畜生。是故生悲。又见众生色力寿命安隐辩才不得自在。是故生悲。又见众生诸根不具。是故生悲。又见众生生于边地不修善法。是故生悲。又见众生处饥馑世。身体羸瘦互相劫夺。是故生悲。又见众生处刀兵劫更相残害恶心增盛当受无量苦报之果。是故生悲。又见众生值佛出世闻说甘露净法不能受持。是故生悲。又见众生信邪恶友终不追从善知识教。是故生悲。又见众生多有财宝不能舍施。是故生悲。又见众生耕田种作商贾贩卖一切皆苦。是故生悲。又见众生父母兄弟妻子奴婢眷属宗室不相爱念。是故生悲。善男子。有智之人应观非想非非想处所有定乐如地狱苦。一切众生等共有之。是故生悲。善男子。未得道时作如是观。是名为悲。若得道已即名大悲。何以故。未得道时虽作是观。观皆有边。众生亦尔。既得道已观及众生皆悉无边。是故得名为大悲也。未得道时悲心动转。是故名悲。既得道已无有动转。故名大悲。未得道时未能救济诸众生故。故名为悲。既得道已能大救济。故名大悲。未得道时不共慧行。是故名悲。既得道已与慧共行。故名大悲。善男子。智者修悲虽未能断众生苦恼。已有无量大利益事。善男子。六波罗蜜皆以悲心而作生因。善男子。菩萨有二种。一者出家。二者在家。出家修悲是不为难。在家修悲是乃为难。何以故。在家之人多有恶因缘故。善男子。在家之人若不修悲。则不能得优婆塞戒。若修悲已即便获得。善男子。出家之人唯能具足五波罗蜜。不能具足檀波罗蜜。在家之人则能具足。何以故。一切时中一切施故。是故在家应先修悲。若修悲已当知是人能具戒忍进定智慧。若修悲心。难施能施。难忍能忍。难作能作。以是义故。一切善法悲为根本。善男子。若人能修如是悲心。当知是人能坏恶业如须弥山。不久当得阿耨多罗三藐三菩提。是人所作少许善业。所获果报如须弥山

    优婆塞戒经解脱品第四

善男子。若善男子善女人有修悲者。当知是人得一切法体诸解脱分。善生言。世尊。所言体者。云何为体。善男子。谓身口意。是身口意从方便得。方便有二。一者耳闻。二者思惟。复有三种。一者惠施。二者持戒三者多闻。善生言。世尊。如佛所说从三方便得解脱分是三方便有定数不。不也善男子。何以故。有人虽于无量世中以无量财施无量人。亦不能得解脱分法。有人于一时中以一把糗施一乞儿。能得如见解脱分法。有人乃于无量佛所受持禁戒。亦不能得解脱分法。有人一日一夜受持八戒。而能获得解脱分法。有人于无量世无量佛所。受持读诵十二部经。亦不能得解脱分法。有人唯读一四句偈。而能获得解脱分法。何以故。一切众生心不同故。善男子。若人不能一心观察生死过咎涅槃安乐。如是之人虽复惠施持戒多闻。终不能得解脱分法。若能厌患生死过咎。深见涅槃功德安乐。如是之人虽复少施少戒少闻。即能获得解脱分法。善男子。得是法者。于三时中。佛出世时。缘觉出时。若无是二。阿迦尼咤天说解脱时。是人闻已得解脱分。善男子。我于往昔初发心时。都不见佛及辟支佛。闻净居天说解脱法。我时闻已即便发心。善男子。如是之法非欲界天之所能得何以故。以放逸故。亦非色天之所能得。何以故。无三方便故。亦非无色天之所能得何以故。无身口故。是法体者是身口意。郁单曰人亦所不得。何以故。无三方便故。是解脱分三人能得。所谓声闻。缘觉菩萨。众生若遇善知识者。转声闻解脱得缘觉解脱。转缘觉解脱得菩萨解脱。菩萨所得解脱分法。不可退转。不可失坏。善生言。世尊。说法之人复以何义能善分别。如是等人有解脱分。如是等人无解脱分。善男子。如是法者二人所得。谓在家出家。如是二人至心听法。听已受持。闻三恶苦心生怖畏。身毛皆竖涕泣横流。坚持斋戒乃至小罪不敢毁犯。当知是人得解脱分法。善男子。诸外道等获得非想非非想定寿无量劫。若不能得解脱分法。当观是人为地狱人。若复有人阿鼻地狱经无量劫受大苦恼。能得如是解脱分法。当观是人为涅槃人。善男子。是故我于郁头蓝弗生哀愍心。于提婆达多不生怜念心。善男子。如舍利弗等六万劫中求菩提道。所以退者以其未得解脱分法。虽尔犹胜缘觉根利。善男子。是法有三。谓下中上。下者声闻。中者缘觉。上者佛也。善男子。有人勤求优婆塞戒。于无量世如闻而行亦不得戒。有出家人求比丘戒比丘尼戒。于无量世如闻而行亦不能得。何以故。不能获得解脱分法。是故可名修戒。不名持戒。善男子。若诸菩萨得解脱分法。终不造业求生欲界色无色界。常愿生于益众生处。若自定知有生天业。即回此业求生人中。业者所谓施戒修定。善男子。若声闻人得解脱分。不过三身得具解脱。辟支佛人亦复如是。菩萨摩诃萨得解脱分。虽复经由无量身中常不退转。不退转心出胜一切声闻缘觉。善男子。若得如是解脱分法。虽复少施得无量果。少戒少闻亦复如是。是人假使处三恶道。终不同彼三恶受苦。若诸菩萨获得如是解脱分法。名调柔地。何故名为调柔地耶。一切烦恼渐微弱故。是名逆流。若善男子。有四种人。一者顺生死流。二者逆生死流。三者不顺不逆。四者到于彼岸。善男子。如是法者。于声闻人名柔软地。于诸菩萨亦名柔软复名喜地。以何义故名为喜地。闻不退故名为喜地。以何义故名为菩萨。能常觉悟众生心故。如是菩萨虽知外典。自不受持亦不教人。如是菩萨不名人天非五道摄。是名修行无障碍道。善男子。夫菩提者有四种子。一者不贪财物。二者不惜身命。三者修行忍辱。四者怜愍众生。善男子。增长如是菩提种子。复有五事。一者于己身中不生轻想言我不能得阿耨多罗三藐三菩提。二者自身受苦心不厌悔。三者勤行精进不休不息。四者救济众生无量苦恼。五者常赞三宝微妙功德。有智之人修菩提时。常当修集如是五事。增长炽然菩提种子。复有六事。所谓檀波罗蜜乃至般若波罗蜜。是六种事因一事增。谓不放逸。菩萨放逸不能增长如是六事。若不放逸则能增长。善男子。菩萨求于菩提之时。复有四事。一者亲近善友。二者心坚难坏。三者能行难行。四者怜愍众生。复有四事。一者见他得利心生欢喜。二者常乐称赞他人功德。三者常乐修集六念处法。四者勤说生死所有过咎。善男子。若有说言离是八法得菩提者。无有是处

善男子。若有菩萨初发无上菩提心时。即得名为无上福田。如是菩萨出胜一切世间之事及诸众生。善男子。虽有人言。无量世界有无量佛。然此佛道甚为难得。何以故。世界无边众生亦尔。众生无边佛亦如是。假使佛道当易得者。一佛世尊则应化度一切众生。若尔者世界众生则为有边。善男子。佛出世时能度九万九那由他人。声闻弟子度一那由他。而诸众生犹不可尽。故名无边。是故我于声闻经说无十方佛。所以者何。恐诸众生轻佛道故。诸佛圣道非世所摄。是故如来说无虚妄。如来世尊无有妒心。以难得故。说无十方诸佛世尊。善男子。无量众生发菩提心。不能究竟行菩萨道。若人难言。若有现在无量诸佛。何故经中但说过去未来二世有无量佛。不说现在无量佛耶。善男子。我一国说过去未来有恒沙佛。现在世中唯一佛耳。善男子。真实义者能得佛道。无量众生修行佛道多有退转。时有一人乃能得度。如庵罗花及鱼子等。善男子。菩萨有二种。一者在家。二者出家。出家菩萨得解脱分法。是不为难。在家得者。是乃为难。何以故。在家之人多恶因缘所缠绕故

    优婆塞戒经三种菩提品第五

善生言。世尊。如佛所说菩萨二种。一者在家。二者出家。菩提三种。一者声闻菩提。二者缘觉菩提。三者诸佛菩提。若得菩提名为佛者。何以故。声闻辟支佛人不名为佛。若觉法性名为佛者。声闻缘觉亦觉法性。以何缘故不名为佛。若一切智名为佛者。声闻缘觉亦一切智。复以何故不名为佛。言一切者即是四谛。佛言。善男子。菩提有三种。一者从闻而得。二者从思惟得。三者从修而得。声闻之人从闻得故不名为佛。辟支佛人从思惟已少分觉故名辟支佛。如来无师不依闻思。从修而得觉悟一切。是故名佛。善男子。了知法性故名为佛。法性二种。一者总相。二者别相。声闻之人总相知故不名为佛。辟支佛人同知总相不从闻故。名辟支佛。不名为佛。如来世尊总相别相一切觉了。不依闻思无师独悟。从修而得故名为佛。善男子。如来世尊缘智具足。声闻缘觉虽知四谛缘智不具。以是义故不得名佛。如来世尊缘智具足故得名佛。善男子。如恒河水三兽俱渡。兔马香象。兔不至底浮水而过。马或至底或不至底。象则尽底。恒河水者即是十二因缘河也。声闻渡时犹如彼兔。缘觉渡时犹如彼马。如来渡时犹如香象。是故如来得名为佛。声闻缘觉虽断烦恼不断习气。如来能拔一切烦恼习气根原。故名为佛。善男子。疑有二种。一烦恼疑。二无记疑。二乘之人断烦恼疑不断无记。如来悉断如是二疑。是故名佛。善男子。声闻之人厌于多闻。缘觉之人厌于思惟。佛于是二心无疲厌。故名为佛。善男子。譬如净物置之净器。表里俱净。声闻缘觉智虽清净。而器不净。如来不尔智器俱净。是故名佛。善男子。净有二种。一者智净。二者行净。声闻缘觉虽有净智。行不清净。如来世尊智行俱净。是故名佛。善男子。声闻缘觉其行有边。如来世尊其行无边。是故名佛。善男子。如来世尊能于一念破坏二障。一者智障。二者解脱障。是故名佛。如来具足智因智果。是故名佛。善男子。如来出言无二无谬亦无虚妄。智慧无碍乐说亦尔。具足因智时智相智。无有覆藏不须守护无能说过。悉知一切众生烦恼。起结因缘灭结因缘。世间八法所不能污。有大怜愍救拔苦恼。具足十力四无所畏大悲三念。身心二力悉皆满足。云何身力具足。善男子。三十三天有一大城。名曰善见。其城纵广满十万里。宫室百万。诸天一千六十六万六千六百六十有六。夏三月时。释提桓因欲往波利质多林中欢娱受乐。由乾陀山有一香象。名伊罗钵那。具足七头。帝释发念象知即来。善见城中所有诸天。处其头上旋行而往。其林去城五十由延。是象身力出胜一切香象身力。正使和合如是香象一万八千。其力唯敌佛一节力。是故身力出胜一切众生之力。世界无边众生亦尔。如来心力亦复无边。是故如来独得名佛。非二乘人名为佛也以是义故。名无上师。名大丈夫。人中香象师子龙王调御示导。名大船师。名大医师。大牛之王。人中牛王。名净莲花。无师独觉。为诸众生之眼目也。是大施主。是大沙门。大婆罗门。寂静持戒勤行精进。到于彼岸获得解脱。善男子。声闻缘觉虽有菩提都无是事。是故名佛。善男子。菩萨有二种。一者在家。二者出家。出家菩萨分别如是三种菩提。是不为难。在家分别。是乃为难。何以故。在家之人多恶因缘所缠绕故

    优婆塞戒经修三十二相业品第六

善生言。世尊。如佛所说菩萨身力何时成就。佛言。善男子。初修三十二相业时。善男子。菩萨修集如是业时得名菩萨。兼得二定。一菩提定。二者有定。复有二定。一者知宿命定二者生正法因定。善男子。菩萨从修三十二相业。乃至得阿耨多罗三藐三菩提。于其中间多闻无厌。菩萨摩诃萨修一一相。以百福德而为围绕。修心五十具心五十。是则名为百种福德。善男子。一切世间所有福德。不及如来一毛功德。如来一切毛孔功德。不如一好功德。聚合八十种好功德。不及一相功德。一切相功德不如白毫相功德。白毫功德复不得及无见顶相。善男子。菩萨常于无量劫中。为诸众生作大利益。至心勤作一切善业。是故如来成就具足无量功德。是三十二相即是大悲之果报也。转轮圣王虽有是相。相不明了具足成就。是相业体即身口意业。修是业时非于天中北郁单曰。唯在三方男子之身。非女人身也。菩萨摩诃萨修是业已。名为满三阿僧祇劫。次第获得阿耨多罗三藐三菩提。善男子。我于往昔宝顶佛所。满足第一阿僧祇劫。然灯佛所满足第二阿僧祇劫。迦叶佛所满足第三阿僧祇劫。善男子。我于往昔释迦牟尼佛所。始发阿耨多罗三藐三菩提心。发是心已供养无量恒沙诸佛。种诸善根。修道持戒精进多闻。善男子。菩萨摩诃萨修是三十二相业已。了了自知定得阿耨多罗三藐三菩提。如观掌中庵摩勒果。其业虽定。修时次第不必定耶。或有人言。如来先得牛王眼相。何以故。为菩萨时于无量世。乐以善眼和视众生。是故先得牛王眼相。次得余相。或有说言。如来先得八梵音相。余次第得。何以故。为菩萨时。于无量世。恒以软语先语实语教化众生。是故先得八梵音相。或有说言。如来先得无见顶相。余次第得。何以故。为菩萨时。于无量世。供养师长诸佛菩萨头顶礼拜破憍慢故。是故先得无见顶相。或有说言。如来先得白毫毛相。余次第得。何以故。为菩萨时。于无量世。不诳一切诸众生故。是故先得眉间毫相。善男子。除佛世尊余无能说如是相业。善男子。或复有人次第说言。如来先得足下平相。余次第得。何以故。为菩萨时。于无量世布施持戒。修集道时其心不动。是故先得足下平相。得是相已次第获得足下轮相。何以故。为菩萨时。于无量世供养父母师长善友。如法拥护一切众生。是故次得手足轮相。得是相已次第获得纤长指相。何以故。为菩萨时。至心受持第一第四优婆塞戒。是故次得。纤长指相足跟长相。得是相已次第获得身佣满相。何以故。为菩萨时善受师长父母善友所教敕故。是故次得身佣满相。得是相已次得手足合网缦相。何以故。为菩萨时。以四摄法摄众生故。是故次得手足网缦相。得是相已次第获得手足柔软胜余身相。何以故。为菩萨时。于无量世以手摩洗师长父母身。除去垢秽香油涂之。是故次得手足软相。得是相已次得身毛上向靡相。何以故。为菩萨时。于无量世常化众生。令修施戒一切善法。是故次得毛上靡相。得是相已次第获得鹿王腨相。何以故。为菩萨时。至心听法至心说法。为坏生死诸过咎故。是故次得鹿王腨相。得是相已次第获得身方圆相。如尼拘陀树王。何以故。为菩萨时。于无量世常施一切众生病药。是故次得身方圆相。得是相已次第获得手过膝相。何以故。为菩萨时。终不欺诳一切贤圣父母师长善友知识。是故次得手过膝相。得是相已次得象王马王藏相。何以故。为菩萨时。于无量世见怖畏者能为救护。心生惭愧不说他过善覆人罪。是故次得象马藏相。得是相已次得软身一一孔中一毛生相。何以故。为菩萨时。于无量世亲近智者乐闻乐论。闻已乐修。乐治道路除去棘刺。是故次得皮肤柔软一一孔中一毛生相。得是相已次第获得身金色相。何以故。为菩萨时。于无量世常施众生房舍卧具饮食灯明。是故次得金色身相。得是相已次第获得七处满相。何以故。为菩萨时。于无量世可嗔之处不生嗔心。乐施众生随意所须。是故次得七处满相。得是相已次第获得缺骨满相。何以故。为菩萨时。于无量世善能分别善不善相。言无错谬不说无义。可受之法口常宣说。不可受者不妄宣传。是故次得缺骨满相。得是相已次得二相。一者上身。二者颊车。皆如师子。何以故。为菩萨时。于无量世中自无两舌教他不为。是故次得如是二相。得是相已次得三相。一四十齿。二白净相。三齐密相。何以故。为菩萨时。于无量世以十善法教化众生。众生受已心生欢喜。常乐称扬他人功德。是故次得如是三相。得是相已次第获得四牙白相。何以故。为菩萨时。于无量世修欲界慈乐思善法。是故次得四牙白相。得是相已次得味中最上味相。何以故。为菩萨时。于无量世不待求已然后方施。是故次得味中上味相。得是相已次得二相。一者肉髻。二广长舌。何以故。为菩萨时。于无量世至心受持十善法教兼化众生。是故次得如是二相。得是相已次得梵音相。何以故。为菩萨时。于无量世自不恶口教他不为。是故次得梵音声相。得是相已次得牛王绀色目相。何以故。为菩萨时。于无量世等以慈善视怨亲故。是故次得牛王目相。得是相已次得白毫相。何以故。为菩萨时。于无量世宣说正法实法不虚。是故次得白毫光相。得是相已次得无见顶相。何以故。为菩萨时。于无量世头顶礼拜一切圣贤师长父母。尊重赞叹恭敬供养。是故获得无见顶相。善男子。菩萨二种。一者在家。二者出家。出家菩萨修如是业。是不为难。在家之人。是乃为难。何以故。在家之人多恶因缘所缠绕故

优婆塞戒经卷第一优婆塞戒经卷第二

        北凉中印度三藏昙无谶译

    发愿品第七

善生言。世尊。是三十二相业谁能作耶。佛言。善男子。智者能作。世尊云何名智者。善男子。若能善发无上大愿。是名智者。菩萨摩诃萨发菩提心已。身口意等所作善业。愿为众生将来得果一切共之。菩萨摩诃萨常亲近佛声闻缘觉善知识等。供养恭敬咨问深法受持不失。作是愿言。我今亲近诸佛声闻缘觉善友。宁无量世受大苦恼。不于菩提生退转心。众生若以恶心打骂毁辱我身。愿我因是更增慈心不生恶念。愿我后生在在处处。不受女身无根二根奴婢之身。复愿令我身有自在力为他给使。不令他人有自在力而驱使我。愿令我身诸根具足远离恶友。不生恶国边裔之处。常生豪姓色力殊特财宝自在。得好念心自在之心。心得勇健。凡有所说闻者乐受。离诸障碍无有放逸。离身口意一切恶业。常为众生作大利益。为利众生不贪身命。不为身命而造恶业。利众生时莫求恩报。常乐受持十二部经。既受持已转教他人。能坏众生恶见恶业。一切世事所不能胜。既得胜已复以转教。善治众生身心重病。见离坏者能令和合。见怖畏者为作救护。护已为说种种之法。令彼闻已心得调伏。见饥施身令得饱满。愿彼不生贪恶之心。当啖我时如食草木。常乐供养师长父母善友宿德。于怨亲中其心等一。常修六念及无我想十二因缘。无三宝处乐在寂静修集慈悲。一切众生若见我身闻触之者远离烦恼。菩萨虽知除菩提已不求余果。为众生故求以弘利。善男子。菩萨若能如是立愿。当知是人即是无上法财长者。是求法王未得法王善男子。菩萨摩诃萨具足三事。则得名为法财长者。一者心不甘乐外道典籍。二者心不贪着生死之乐。三者常乐供养佛法僧宝复有三事。一者为人受苦心不生悔。二者具足微妙无上智慧。三者具善法时不生憍慢。复有三事。一者为诸众生受地狱苦如三禅乐。二者见他得利不生妒心。三者所作善业不为生死。复有三事。一者见他受苦如已无异。二者所修善事悉为众生。三者善作方便令彼离苦。复有三事。一者观生死乐如大毒蛇。二者乐处生死为利众生。三者观无生法忍多诸功德。复有三事。一者舍身。二者舍命。三者舍财。舍是三事悉为众生。复有三事。一者多闻无厌。二者能忍诸恶。三者教他修忍。复有三事。一者自省己过。二者善覆他罪。三者乐修慈心。复有三事。一者至心奉持禁戒。二者四摄摄取众生。三者口言柔濡不粗。复有三事。一者能大法施。二者能大财施。三者以此二施劝众生行。复有三事。一者常以大乘教化众生。二者常修转进增上之行。三者于诸众生不生轻想。复有三事。一者虽具烦恼而能堪忍。二者知烦恼过乐而不厌。三者自具烦恼能坏他结。复有三事。一者见他得利欢喜如己。二者自得安乐不乐独受。三者于下乘中不生足想。复有三事。一者闻诸菩萨苦行不怖。二者见有求者终不言无。三者终不生念我胜一切。善男子。菩萨若能观因观果。能观因果能观果因。如是菩萨能断因果能得因果。菩萨若能断得因果。是名法果。诸法之王法之自在。善男子。菩萨有二种。一者在家。二者出家。出家菩萨立如是愿。是不为难。在家菩萨立如是愿。是乃为难。何以故。在家菩萨多恶因缘所缠绕故

    优婆塞戒经名义菩萨品第八

善生言。世尊。如佛所说菩萨二种。一者假名菩萨。二者实义菩萨。云何名为假名菩萨。善男子。众生若发菩提心已。乐受外术及其典籍持讽诵读。即以此法教化众生。为自身命杀害他命。不乐修悲乐于生死。常造诸业受生死乐。无有信心于三宝所生疑网心。护惜身命不能忍辱。语言粗穬悔恨放逸。于己身所生自轻想。我不能得无上菩提。于烦恼中生恐怖想。亦不勤修坏结方便。常生悭贪嫉妒嗔心。亲近恶友懈怠乱心。乐处无明不信六度。不乐修福不观生死。常乐受持他人恶语。是名假名菩萨。善男子。复有众生发菩提心。欲得阿耨多罗三藐三菩提。闻无量劫苦行修道然后乃得。闻已生悔。虽修行道心不真实。无有惭愧不生怜愍。乐奉外道杀羊祀天。虽有微信心不坚固。为五欲乐造种种恶。猗色命财生大憍慢。所作颠倒不能利益。为生死乐而行布施。为生天乐受持禁戒。虽修禅定为命增长。是名假名菩萨。实义菩萨者。能听深义乐近善友。乐供养师父母善友。乐听如来十二部经。受持读诵书写思义。为法因缘不惜身命妻子财物。其心坚固怜愍一切。口言柔濡先语实语。无有恶语及两舌语。于自身所不生轻想。舒手惠施无有禁固。常乐修磨利智慧刀。虽习外典为破邪见出胜邪见。善知方便调伏众生。于大众所不生恐怖。常教众生菩提易得。能令闻者不生怖心。勤修精进轻贱烦恼。令彼烦恼不得自在。心不放逸常修忍辱。为涅槃果持戒精进。愿为众生趋走给使。令彼安隐欢娱受乐。为他受苦心不生悔。见退菩提心生怜愍。能救一切种种苦恼。能观生死所有过罪。能具无上六波罗蜜。所作世事胜诸众生。信心坚固修集慈悲。亦不悕求慈悲果报。于怨亲中其心无二。施时平等舍身亦尔。知无常相不惜身命。以四摄法摄取众生。知世谛故随众生语。为诸众生受苦之时。其心不动如须弥山。虽见众生多作诸恶。有少善者心终不忘。于三宝所不生疑心乐为供养。若少财时先给贫穷后施福田。先为贫苦后为富者。乐赞人善为开涅槃。所有伎艺欲令人学。见学胜己生欢喜心。不念自利常念利他。身口意业所作诸善。终不自为恒为他人。是名实义菩萨。善男子。菩萨有二种。一者在家。二者出家。出家菩萨为实义菩萨。是不为难。在家菩萨。是乃为难。何以故。在家之人多恶因缘所缠绕故

    优婆塞戒经义菩萨心坚固品第九

善生言。世尊。义菩萨者。云何自知是义菩萨。善男子。菩萨摩诃萨修苦行时先自诫心。善男子。我念往昔行菩萨道时。先从外道受苦行法。至心奉行心无退转。无量世中以灰涂身。唯食胡麻小豆粳米粟米[序-予+禾]等日各一粒。荆棘恶刺[木*豕]木地石以为卧具。牛屎牛尿以为病药。盛夏之月五热炙身。孟冬之节冻冰儭体。或受草食根食茎食叶食果食土食风食。作如是等诸苦行时。自身他身俱无利益。虽尔犹故心无退转。出胜一切外道苦行。善男子。我于往昔为四事故舍弃身命。一者为破众生诸烦恼故。二者为令众生受安乐故。三者为自除坏贪着身故。四者为报父母生养恩故。菩萨若能不惜身命。即自定知是义菩萨。善男子。我于往昔为正法故。剜身为灯三千六百。我于尔时具足烦恼身实觉痛。为诸众生得度脱故。谕心令坚不生退转尔时即得具足三事。一者毕竟无有退转。二者得为实义菩萨。三者名为不可思议。是名菩萨不可思议。又我往昔为正法故。于一劫中周身左右受千疮苦。尔时具足一切烦恼身实觉苦。为诸众生得度脱故。谕心令坚不生退转。是名菩萨不可思议。又我往昔为一鸽故弃舍是身。尔时具足一切烦恼身实觉苦。为诸众生得度脱故。谕心令坚不生退转。是名菩萨不可思议。善男子。一切恶友诸烦恼业。即是菩萨道庄严伴。何以故。一切凡夫无有智慧正念之心。故以烦恼而为怨敌。菩萨智慧正念具足。故以烦恼而为道伴。恶友及业亦复如是。善男子。舍离烦恼终不得受恶有之身。是故菩萨虽现恶业。实非身口意恶所作。是誓愿力。以是愿力受恶兽身。为欲调伏彼畜生故。菩萨现受畜生身已。善知人语法语实语不粗恶语不无义语。心常怜愍修集慈悲无有放逸。是名菩萨不可思议。善男子。我于往昔受熊身时虽具烦恼。烦恼于我无自在力。何以故。具正念故。我于尔时怜愍众生。拥护正法修行法行。受瞿陀身劫宾耆罗身兔身蛇身龙身象身金翅鸟身鸽身鹿身。猕猴羖羊鸡雉孔雀鹦鹉虾蟆。我受如是鸟兽身时。虽具烦恼。烦恼于我无自在力。何以故。具正念故怜愍众生。拥护正法修行法行。善男子。于饥馑世我立大愿。以愿力故受大鱼身。为诸众生离于饥渴。食我身者修道念道无恶罪过。疾疫世时复立大愿。以愿力故身为药树。诸有病者见闻触我。及食皮肤血肉骨髓。病悉除愈。善男子。菩萨摩诃萨受如是苦心不退转。是名义菩萨。菩萨修行六波罗蜜时。终不悕求六波罗蜜果。但以利益众生为事。菩萨深知生死过患。所以乐处为利众生受安乐故。菩萨了知解脱安乐生死过患而能处之。是名菩萨不可思议。菩萨所行不求恩报。受恩之处常思反报。善男子。一切众生常求自利。菩萨所行恒求利他。是名菩萨不可思议。菩萨摩诃萨具足烦恼。于怨亲所平等利益。是名菩萨不可思议。善男子。若诸外道化众生时。或以恶语鞭打骂辱摈之令出。然后调伏。菩萨不尔化众生时。无粗恶语嗔语绮语。唯有濡语真实之语众生闻已如青莲遇月赤莲遇日。善男子。菩萨施时财物虽少。见多乞求不生厌心。是名菩萨不可思议。菩萨教化盲聋喑哑愚痴边地恶众生时。心无疲厌。是名菩萨不可思议。善男子。菩萨有四不可思议。一者所爱重物能以施人。二者具诸烦恼能忍恶事。三者离坏之众能令和合。四者临终见恶说法转之。是名菩萨四不可思议。复有三事不可思议。一者呵责一切烦恼。二者处烦恼中而不舍之。三者虽具烦恼及烦恼业而不放逸。是名菩萨三不可思议。复有三事不可思议。一者始欲施时心生欢乐。二者施时为他不求果报。三者施已心乐不生悔恨。是名菩萨三不可思议。善男子。菩萨摩诃萨作是行时自观其心。我是名菩萨也。义菩萨乎。众生若能作如是事。当知是人即义菩萨也。善男子。菩萨有二种。一者在家。二者出家。出家菩萨作如是事。是不为难。在家菩萨为如是事。是乃为难。何以故。在家之人多恶因缘所缠绕故

    优婆塞戒经自利利他品第十

善生言。世尊。云何菩提。云何菩提道。佛言。善男子。若离菩提无菩提道。离菩提道则无菩提。菩提之道即是菩提。菩提即是菩提之道。出胜一切声闻缘觉所得道果。是名菩提菩提之道。善生言。世尊。声闻缘觉所得道果。即是菩提。即是菩提道。云何言胜。善男子。声闻缘觉道不广大非一切觉。是故菩提菩提之道得名为胜。犹如一切世间经书。十二部经为最第一。何以故。所说不谬无颠倒故。二乘之道比菩提道。亦复如是。善男子。菩提道者。即是学。即是学果。云何名学。行菩提道未能具足不退转心。是名为学。已得不退。是名学果。未得定有。是名为学。已得定有第三劫中。是名学果。初阿僧祇劫犹故未能一切慧施一切时施一切众生施。第二阿僧祇劫虽一切施。未能一切时施一切众生施。如是二处。是名为学。第三阿僧祇劫能一切施一切时施一切众生施。是名学果。善男子。菩萨修行施戒忍辱进定智时。是名为学。到于彼岸。是名学果。善男子。有是惠施非波罗蜜。有波罗蜜不名为施。有亦惠施亦波罗蜜。有非惠施非波罗蜜。善男子。是施非波罗蜜者。声闻缘觉一切凡夫外道异见。菩萨初二阿僧祇劫所行施。是波罗蜜非惠施者。如尸波罗蜜乃至般若波罗蜜是。亦是惠施亦波罗蜜者。菩萨第三阿僧祇劫所行施是。非施非波罗蜜者。声闻缘觉持戒修定忍慈悲是善男子。非施非波罗蜜。是名为学。亦施亦波罗蜜。是名学果。善男子。夫菩提者。即是尽智无生智也。为此二智勤心修集三十七品。是名为学。得菩提已。是名学果。自调诸根次调众生。是名为学。自得解脱令众生得。是名学果。修集十力四无所畏大悲三念。是名为学。具足获得十八不共法。是名学果。为利自他造作诸业。是名为学。能利他已。是名学果。习学世法。是名为学。学出世法。是名学果为诸众生不惜身财。是名为学。为诸众生亦不吝惜。身财寿命。是名学果。能化众生作人天业。是名为学。作无漏业。是名学果。能施众生一切财物。是名为学。能行法施是名学果能自破坏悭贪嫉妒是名为学。破他悭贪嫉妒之心。是名学果。受持五根修行忆念。是名为学。教他修集成就具足。是名学果。善男子。菩萨信根既自利已复利益他。自利益者不名为实。利益他者乃名自利。何以故。菩萨摩诃萨为利他故。于身命财不生悭吝。是名自利。菩萨定知若用声闻缘觉菩提教化众生。众生不受则以天人世乐教之。是名利他。利益他者即是自利。菩萨不能自他兼利。唯求自利。是名下品。何以故。如是菩萨于法财中生贪着心。是故不能自利益也。行者若令他受苦恼自处安乐。如是菩萨不能利他。若自不修施戒多闻。虽复教他。是名利他。不能自利。若自具足信等五根。然后转教。是名菩萨自利利他。善男子。利益有二。一者现世。二者后世。菩萨若作现在利益。是不名实。若作后世则能兼利。善男子。乐有二种。一者世乐。二者出世乐。福德亦尔。菩萨若能自具如是二乐二福化众生者。是则名为自利利他。善男子。菩萨摩诃萨具足一法则能兼利谓不放逸。复有二法能自他利。一者多闻。二者思惟。复有三法能自他利。一者怜愍众生。二者勤行精进。三者具足念心。复有四法能自他利。谓四威仪。复有五法能自他利。一者信根二者持戒。三者多闻。四者布施。五者智慧。复有六法能自他利。所谓六念。复有七法能自他利。谓坏七慢。善男子。若沙门婆罗门长者男女。或大众中有诸过失。菩萨见已先随其意。然后说法令得调伏。如其不能先随其意便为说法。是则名为下品菩萨。善男子。菩萨二种。一者乐近善友。二者不乐。乐善友者能自他利。不乐近者则不能得自他兼利。善男子。乐近善友复有二种。一乐供养。二不乐供养。乐供养者能自他利。不乐供养不能兼利。乐供养者复有二种。一能听法。二不能听。至心听者能自他利。不至心听则无兼利。至心听法复有二种。一者能问二不能问。能问义者能自他利不能问者则不能得自利他利。能问义者复有二种。一至心持。二不能持。至心持者能自他利。不至心者则不能得自利他利。至心持者复有二种。一者思惟。二不思惟能思惟者能利自他不思惟者则不得名自利他利。能思惟者复有二种。一者解义。二不解义。能解义者能自他利。不解义者则不得名能自他利。解义之人复有二种。一如法住。二不如法住。如法住者能自他利。不如法住者则不得名自利他利。如法住者复有二种。一者具足八智。二者不能具足。何等八智。一者法智。二者义智。三者时智。四者知足智。五者自他智。六者众智。七者根智。八上下智。是人具足如是八智凡有所说具十六事。一者时说。二至心说。三次第说。四和合说。五随义说。六喜乐说。七随意说。八不轻众说。九不呵众说十如法说。十一自他利说。十二不散乱说。十三合义说。十四真正说。十五说已不生憍慢。十六说已不求世报。如是之人能从他听。从他听时具十六事。一者时听。二者乐听。三者至心听。四者恭敬听。五者不求过听。六者不为论议听。七者不为胜听。八者听时不轻说者。九者听时不轻于法。十者听时终不自轻。十一听时远离五盖。十二听时为受持读。十三听时为除五欲。十四听时为具信心。十五听时为调众生。十六听时为断闻根。善男子。具八智者能说能听。如是之人能自他利。不具足者则不得名自利利他。善男子。能说法者复有二种。一者清净。二不清净。不清净者复有五事。一者为利故说。二者为报而说。三者为胜他说。四者为世报说。五者疑说。清净说者复有五事。一先施食然后为说。二为增长三宝故说。三断自他烦恼故说。四为分别邪正故说。五为听者得最胜故说。善男子。不净说者。名曰垢秽。名为卖法。亦名污辱。亦名错谬。亦名失意。清净说者。名曰净洁。亦名正说。亦名实语。亦名法聚。善男子。若具足知十二部经声论因论。知因知喻知自他取。是名正说。听者有四。一者略闻多解。二者随分别解。三者随本意解。四者于一一字一一句解。如来说法正为三人。不为第四。何以故。以非器故。如是四人分为二种。一者熟。二者生。熟者现在调伏。生者未来调伏。善男子。譬如树林凡有四种。一者易伐难出。二者难伐易出。三者易伐易出。四者难伐难出。在家之人亦有四种。一者易调难出。二者难调易出。三者易调易出。四者难调难出。如是四人分为三种。一者呵责已调。二者濡语而调。三者呵责濡语使得调伏。复有二种。一者自能调伏不假他人。二者自若不能请他令调。复有二种。一者施调。二者咒调。是调伏法复有二时。一者喜时二者苦时。为是四人说正法时有二方便。一者善知世事。二者为其给使。善男子。菩萨若知是二方便则能兼利。若不知者则不能得自利他利。善男子。菩萨摩诃萨为利他故先学外典。然后分别十二部经。众生若闻十二部经。乃于外典生于厌贱。复为众生说烦恼过烦恼解脱。叹善友德呵恶友过。赞施功德毁悭过失。菩萨常寂赞寂功德。常修法行赞法行德。若能如是是名兼利。在家菩萨先自调伏。若不调伏则不出家。在家菩萨能多度人。出家菩萨则不如是。何以故。若无在家则无三乘出家之人。三乘出家修道持戒诵经坐禅。皆由在家而为庄严。善男子。有道有道庄严。道者所谓法行。道庄严者所谓在家。出家菩萨为在家者修行于道。在家之人为出家者而作法行。在家之人多修二法。一者受。二者施。出家之人亦修二法。一者诵。二者教。善男子。菩萨摩诃萨兼有四法。受施诵教。如是名为自利利他。菩萨若欲为众生说法界深义。先当为说世间之法。然后乃说甚深法界。何以故。为易化故。菩萨摩诃萨应护一切众生之心。若不护者则不能调一切众生。菩萨亦应拥护自身。若不护身亦不能得调伏众生。菩萨不为贪身命财。护身命财皆为调伏诸众生故。菩萨摩诃萨先自除恶后教人除。若不自除能教他除。无有是处。是故菩萨先应自施持戒知足勤行精进。然后化人。菩萨若不自行法行。则不能得教化众生。善男子。众生诸根凡有三种。菩萨诸根亦复三种。谓下中上。下根菩萨能化下根不及中上。中根菩萨能化中下不及上根。上根菩萨能三种化善男子。菩萨有二种。一者在家。二者出家。出家菩萨自利利他。是不为难。在家菩萨修是二利。是乃为难。何以故。在家菩萨多恶因缘所缠绕故

    优婆塞戒经自他庄严品第十一

善生言。世尊。菩萨摩诃萨具足几法能自他利。善男子。具足八法能自他利。何等为八。一者寿命长远。二者具上妙色。三者身具大力。四者具好种姓。五者多饶财宝。六者具男子身。七者言语辩了。八者无大众畏。善生言。世尊。何因缘故。菩萨得寿命长。乃至大众不生怖畏。佛言。善男子。菩萨摩诃萨无量世中慈心不杀。以是因缘获得长寿。无量世中常施衣灯。以是因缘获得上色。无量世中常坏憍慢。以是因缘生上种姓。无量世中常施饮食。以是因缘身力具足。无量世中常乐说法。以是因缘多饶财宝。无量世中呵责女身。以是因缘得男子身。无量世中至心持戒。以是因缘言语辩了。无量世中供养三宝。以是因缘无大众畏。如是八事有三因缘。一者物净。二者心净。三者福田净。云何物净。非偷盗物。非圣遮物。非众共物。非三宝物。非施一人回与多人。非施多人回与一人。不恼他得。不诳他得。不欺人得。是名物净。云何心净。施时不为生死善果。名称胜他得色力财。不断家法眷属多饶。唯为庄严菩提故施。为欲调伏众生故施。是名心净。云何福田净。受施之人远离八邪。名福田净。善男子。以如是等三因缘故八法具足。善男子。菩萨所以求于长命。欲为众生赞不杀故。菩萨所以求上色者。为令众生见欢喜故。菩萨所以求上种姓。为令众生生恭敬故。菩萨所以求具足力。为欲持戒诵经坐禅故。菩萨所以求多财宝。为欲调伏诸众生故。菩萨所以求男子身。为欲成器成善法故。菩萨所以求语辩了。为诸众生受法语故。菩萨所以求不畏大众。为欲分别真实法故。善男子。是故菩萨具足八法。能自他利。能如是行。是名实行。善男子。菩萨摩诃萨有八法者。具足受持十善之法乐以化人。具足受持优婆塞戒乐以化人。虽得妙色终不以是而生憍慢。虽持净戒多闻精进大力好姓多饶财宝。终不以此而生憍慢。不以幻惑欺诳众生。不生放逸修六和敬。菩萨具足如是等法。虽复在家不异出家。如是菩萨终不为他作恶因缘。何以故。惭愧坚故善男子。在家之人设于一世。受持如是优婆塞戒。虽复后生无三宝处。终不造作诸恶因缘。所以者何。二因缘故。一者智慧。二不放逸。善男子。于后恶处不作恶事有四因缘。一者了知烦恼过故。二者不随诸烦恼故。三者能忍诸恶苦故。四者不生恐怖心故。菩萨具足如是四法。不为诸苦一切烦恼之所倾动。善男子。不动菩萨有五因缘。一者乐修善法。二者分别善恶。三者亲近正法。四者怜愍众生。五者常识宿命。善男子。菩萨具足如是八法。若闻讥毁心能堪忍。若闻赞叹反生惭愧。修行道时欢喜自庆不生憍慢。能调恶人见离坏众能令和合扬人善事隐他过咎。人所惭耻处终不宣说。闻他秘事不向余说。不为世事而作咒誓。少恩加已思欲大报。于已怨者恒生善心。怨亲等苦先救怨者。见有骂者反生怜愍。见他偷时默然不动。见来打者生于悲心。视诸众生犹如父母。宁丧身命终不虚言。何以故。知果报故。于诸烦恼应生怨想。于善法中生亲旧想。若于外法生于贪心。寻能观察贪之过咎。一切烦恼亦复如是。虽复久与恶人同处。终不于中生亲善想。虽与善人不同居止。终不于彼而生远想。虽复供养父母师长。终不为是而作恶事。乏财之时见有求者不生恶想。虽不亲近凶恶之人。而其内心常生怜愍。恶来加已以善报之。自受乐时不轻他人。见他受苦不生欢喜。身业清净持四威仪。即以是法用化众生。口业清净诵读如来十二部经。即以是法用化众生。意业清净修四无量。亦以是法开化众生。假身受苦令他受乐甘乐为之。世间之事虽无利益。为众生故而亦学之。所学之事世中最胜。虽得通达心无憍慢。以已所知勤用化人。欲令此事迳世不绝。于亲友中不令作恶。乐以上八法教化众生。说因说果无有错谬。爱别离时心不生恼。观无常故。受乐受时心不耽荒。观苦无常。善男子。菩萨具足如上八法。则能施作如是等事。善男子。菩萨二种。一者在家。二者出家。出家菩萨修是八法。是不为难。在家修集。是乃为难。何以故。在家菩萨多恶因缘所缠绕故

    优婆塞戒经二庄严品第十二

善生言。世尊。云何菩萨自他庄严。佛言。善男子。菩萨具足二法。能自他庄严。一者福德。二者智慧。世尊。何因缘故得二庄严。善男子。菩萨修集六波罗蜜。便得如是二种庄严。施戒精进名福庄严。忍定智慧名智庄严。复有六法二庄严因。所谓六念。念佛法僧名智庄严。念戒施天名福庄严。善男子。菩萨具足是二庄严。能自他利为诸众生受三恶苦。而其内心不生忧悔。若能具足是二庄严。则得微妙善巧方便。了知世法及出世法。善男子。福德庄严即智庄严。智慧庄严即福庄严。何以故。夫智慧者。能修善法具足十善。获得财富及大自在。得是二故。故能自利及利益他。有智之人所学世法于学中胜。以是因缘便得财富及大自在。菩萨具足如是二法。则能二世自他利益。智者若能分别世法及出世法。世间法者。一切世论一切世定。出世法者。知阴入界。菩萨知是二法因缘。故能二世自他利益。善男子。菩萨虽知世间之乐虚妄非真。而亦能造世乐因缘。何以故。为欲利益诸众生故。善男子。是二庄严有一正因。一者慈心。二者悲心。修是二因。虽复流转生死苦海心不生悔。复次菩萨具足二法。而能庄严无上菩提。一者不乐生死。二者深观解脱。是故亦能二世利益。了知法相得大智慧。能令自他财命增长。善男子。菩萨摩诃萨具足二法。一切施时不生忧悔。见众恶事而能堪忍。菩萨施时观二种田。一者福田。二贫穷田。菩萨为欲增福德故施于贫苦。为增无上妙智慧故施于福田。为报恩故施于福田。生怜愍故给施贫穷。舍烦恼故施于福田。成功德故施于贫穷。增长一切乐因缘故施于福田。欲舍一切苦因缘故施于贫穷。菩萨若施所亲爱处为报恩故。若施怨仇为除恶故。菩萨摩诃萨见来求者生一子想。是故任力多少施之。是则名为施波罗蜜。菩萨施时离于悭心。名尸波罗蜜。能忍一切求者之言。名忍波罗蜜。所施之物手自授与。名精进波罗蜜。至心系念观于解脱。名禅波罗蜜。不择一切怨亲之相。名般若波罗蜜。善男子。如诸众生贪心杀时。一念具足十二因缘。菩萨施时亦复如是。一念具足如是六事。是名功德智慧庄严。复次善男子。菩萨摩诃萨造作不共法之因缘。名福庄严。教化众生悉令获得三种菩提。名智庄严。复次善男子。菩萨若能调伏众生。名智庄严。同于众生受诸苦恼。名福庄严。菩萨能令一切众生离于恶见。名智庄严。能教众生住信施戒多闻智慧。名福庄严。复次善男子。菩萨摩诃萨具足五法。则能庄严无上菩提。何等为五。一者信心。二者悲心。三者勇健。四者读诵世论不生疲厌。五者学诸世业亦不厌之。善男子。菩萨具足二种庄严则有七相。何等为七。一者自知罪过。二者不说他过。三者乐瞻病人。四者乐施贫人。五者获菩提心。六者心不放逸。七者一切时中常至心修六波罗蜜。善男子。复有七相。何等为七。一者乐化怨仇。二者化时不厌。三者要令成熟解脱。四者尽已所知世语世事。以化众生心不贪着。五者能忍一切恶事。六者终不宣说他人所不喜事。七者见破戒者及弊恶人。心不嗔恚常生怜愍。善男子。菩萨摩诃萨知是七相。则能自利及利益他。善男子。菩萨二种。一者在家。二者出家。出家菩萨为二庄严。是不为难。在家修集。是乃为难。何以故。在家多有诸恶因缘所缠绕故

优婆塞戒经卷第二优婆塞戒经卷第三

        北凉中印度三藏昙无谶译

    摄取品第十三

善生言。世尊。菩萨具足二庄严已。云何得畜徒众弟子。善男子。应以四摄而摄取之。令离诸恶增诸善法。至心教诏犹如一子。不求恩报。不为名称。不为利养。不求自乐。善男子。菩萨若无如是等事畜弟子者。名弊恶人。假名菩萨非义菩萨。名旃陀罗臭秽不净破坏佛法。是人不为十方诸佛之所怜念。善男子菩萨若能随时教戒。所言时者。贪恚痴时。起贪结时。当为种种说对治法令得除贪。余二亦尔。次当教学十二部经。禅定三昧分别深义调其身心。令修六念不放逸法。瞻养病苦不生厌心。能忍恶口诽谤骂辱。苦加身心亦当堪忍。设其有苦能为救解。除其弊恶疑网之心。善知利根中根钝根。教钝根人令生信心。中根之人能令纯淑。利根之人令得解脱。若能如是勤教诏者。名义菩萨。是名善人。分陀利花。人中香象。调御丈夫。名大船师。善男子。宁受恶戒一日中断无量命根。终不养畜弊恶弟子不能调伏。何以故。善男子。是恶律仪殃齐自身。畜恶弟子不能教诲。乃令无量众生作恶。能谤无量善妙之法破和合僧。令多众生作五无间。是故剧于恶律仪罪。善男子。菩萨二种。一者在家。二者出家。出家菩萨有二弟子。一者出家。二者在家。在家菩萨有一弟子。所谓在家。出家菩萨教出家者十二部经。随所犯罪谕令忏悔。教习八智。何等为八。一者法智。二者义智。三者时智。四者知足智。五者自智。六者众智。七者根智。八者分别智。善男子。菩萨摩诃萨若能如是教诏调伏出家弟子。是师弟子二人俱得无量利益。如是师徒能增三宝。何以故。如是弟子知八智已。能勤供养师长和上耆旧有德。能受善语能勤读诵。兼为法施心不放逸调伏众生。能瞻病苦给施贫乏。善男子。出家菩萨若有在家弟子。亦当先教不放逸法。不放逸者即是法行。供养父母诸师和上耆旧有德施于安乐。至心受戒不妄毁犯。受寄不抵。见恚能忍。恶口恶语及无义语终不为之。怜愍众生于诸国王长者大臣。恒生恭敬怖畏之心。能自调伏妻子眷属。分别怨亲不轻众生。除去憍慢不亲恶友。节食除贪少欲知足。斗诤之处身不往中。乃至戏笑不说恶语。是则名为不放逸法。出家菩萨若畜在家弟子。先当教造不放逸法。受苦乐时常当共俱。设在穷乏有所须者。六物之外有不应惜。病时当为求觅所须。瞻病之时不应生厌。若自无物应四出求。求不能得贷三宝物。差已依俗十倍偿之。如波斯匿王国之正法。若不能偿。复当教言。汝今多负三宝之物不能得偿。应当勤修得须陀洹果至阿罗汉果。若能至心发菩提心。若教千人于佛法中生清净信。若坏一人殷重邪见。出家菩萨能教在家如是等事。是师弟子二人俱得无量利益。善男子。在家菩萨若畜在家弟子。亦当先教不放逸法。不放逸者。供养父母师长和上耆旧有德。复当供给兄弟妻子亲友眷属。欲行之人及远至者。所有僮仆作使之人。先给饮食。然后自用。又复教令信向三宝。苦乐共俱终不偏独。随时赏赐不令饥寒。终不打骂鞭挞苦楚。应当软言敦谕教诏。设有病者应当瞻疗。随所乏少当为求索。世间之事悉以教之。婚姻求对无求卑下。教以如来五部经典。见离坏者能为和合。既和合已令增善心。一切出家内外诸道。随意供养终不选择。何以故。先以施摄后当调故。以六和敬而教诏之。若求财物商贾农作奉事王者。常当至心如法而作。既得财已如法守护乐为福德。见他作时心生欢喜。是则名为不放逸法。在家菩萨若能教诲在家菩萨如是事者。是师弟子二人俱得无量利益。善男子。在家菩萨若得自在为大国主。拥护民庶犹如一子。教离诸恶修行善法。见作恶者挝打骂辱终不断命。财物六分税取其一。见嗔恶者教修忍辱及不放逸。经言柔软。又能分别善恶之人。见有罪者忍而不问。随有财物常行慧施。任力读诵五部经典。善能守护身命财物。能化众生不令作恶。见贫穷者生大怜愍。自于国土常修知足。恶人谗谤终不信受。不以非法求觅财物。如法护国远七种恶。一者不乐樗蒲围棋六博。二者不乐射猎。三者不乐饮酒。四者不乐欲心。五者不乐恶口。六者不乐两舌。七者不乐非法取财。常乐供养出家之人。能令国人常于王所生父母想信因信果。见有胜己不生嫉妒。见己胜他不生憍慢。知恩报恩小恩大报。能伏诸根净于三业。赞叹善人呵责恶人。先意发言言则柔软。自无力势如法属他。取他国时不举四兵。众生恐怖能为救解。常以四摄而摄取之。善能分别种种法相。不受法者软言调之。善男子。菩萨有二种。一者在家。二者出家。出家菩萨畜二弟子是不为难。在家菩萨畜一弟子是乃为难。何以故。在家之人多恶因缘所缠绕故

    优婆塞戒经受戒品第十四

善生言。世尊。在家菩萨云何得受优婆塞戒。善男子。在家菩萨若欲受持优婆塞戒。先当次第供养六方东方南方西方北方下方上方。言东方者即是父母。若人有能供养父母。衣服饮食卧具汤药房舍财宝。恭敬礼拜赞叹尊重。是人则能供养东方。父母还以五事报之。一者至心爱念。二者终不欺诳。三者舍财与之。四者为娉上族。五者教以世事。言南方者即是师长。若有人能供养师长。衣服饮食卧具汤药。尊重赞叹恭敬礼拜。早起晚卧受行善教。是人则能供养南方。是师复以五事报之。一者速教不令失时。二者尽教不令不尽。三者胜己不生妒嫉。四者将付严师善友。五者临终舍财与之。言西方者即是妻子。若有人能供给妻子。衣服饮食卧具汤药璎珞服饰严身之具。是人则是供养西方。妻子复以十四事报之。一者所作尽心营之。二者常作终不懈慢。三者所作必令终竟。四者疾作不令失时。五者常为瞻视宾客。六者净其房舍卧具。七者爱敬言则柔软。八者僮使软言教诏。九者善能守护财物。十者晨起夜寐。十一者能设净食。十二者能忍教诲。十三者能覆恶事。十四者能瞻病苦。言北方者即善知识。若有人能供施善友任力与之。恭敬软言礼拜赞叹。是人则能供养北方。是善知识复以四事而还报之。一者教修善法。二者令离恶法。三者有恐怖时能为救解。四者放逸之时能令除舍。言下方者即是奴婢。若有人能供给奴婢。衣服饮食病瘦医药。不骂不打。是人则能供给下方。奴婢复以十事报之。一者不作罪过。二者不待教作。三者作必令竟。四者疾作不令失时。五者主虽贫穷终不舍离。六者早起。七者守物。八者少恩多报。九者至心敬念。十者善覆恶事。言上方者即是沙门婆罗门等。若有供养沙门婆罗门。衣服饮食房舍卧具病痛医药。怖时能救馑世施食闻恶能遮。礼拜恭敬尊重赞叹。是人则能供养上方。是出家人以五种事报。一者教令生信。二者教生智慧。三者教令行施。四者教令持戒。五者教令多闻。若有供养是六方者。是人则得增长财命。能得受持优婆塞戒。善男子。若人欲受优婆塞戒增长财命。先当咨启所生父母。父母若听次报妻子奴婢僮仆。此辈若听次白国主。国主听已。谁有出家发菩提心者。便往其所头面作礼软言问讯。作如是言。大德。我是丈夫具男子身。欲受菩萨优婆塞戒。惟愿大德。愍怜故听受。是时比丘应作是言。汝之父母妻子奴婢国主听不。若言听者。复应问言汝不曾负佛法僧物及他物也。若言不负。复应问言。汝今身中将无内外身心病也。若言无者。复应问言。汝不于比丘比丘尼所作非法耶。若言不作。复应问言。汝将不作五逆罪耶。若言不作。复应问言。汝将不作盗法人不。若言不作。复应问言。汝非二根无根人。坏八戒斋父母师病不弃去耶。将不杀发菩提心人。盗现前僧物。两舌恶口。于母姊妹作非法耶。不于大众作妄语乎。若言无者。复应语言。善男子。优婆塞戒极为甚难。何以故。是戒能为沙弥十戒大比丘戒及菩萨戒。乃至阿耨多罗三藐三菩提。而作根本。至心受持优婆塞戒。则能获得如是等戒无量利益。若有毁破如是戒者。则于无量无边世中。处三恶道受大苦恼。汝今欲得无量利益。能至心受不。若言能者。复应语言。优婆塞戒极为甚难。若归佛已。宁舍身命终不依于自在天等。若归法已。宁舍身命终不依于外道典籍。若归僧已。宁舍身命终不依于外道邪众。汝能如是至心归依于三宝不。若言能者。复应语言。善男子。优婆塞戒极为甚难。若人归依于三宝者。是人则为施诸众生无怖畏已。若人能施无怖畏者。是人则得优婆塞戒。乃至阿耨多罗三藐三菩提。汝能如是施诸众生无怖畏不。若言能者。复应语言。人有五事现在不能增长财命。何等为五。一者乐杀。二者乐盗。三者邪淫。四者妄语。五者饮酒。一切众生因杀生故。现在获得恶色恶力恶名短命。财物秏减眷属分离。贤圣呵责人不信用。他人作罪横罗其殃。是名现在恶业之果。舍此身已当堕地狱多受苦恼饥渴。长命恶色恶力恶名等事。是名后世恶业之果。若得人身复受恶色短命贫穷。是一恶人因缘力故。令外一切五谷果蓏悉皆减少。是人殃流及一天下。若人乐偷。是人亦得恶色恶力恶名短命。财物秏减眷属分离。他人失物于己生疑。虽亲附人人不见信。常为贤圣之所呵责。是名现在恶业之果。舍此身已堕于地狱。受得恶色恶力恶名饥渴苦恼寿命长远。是名后世恶业之果。若得人身贫于财物虽得随失。不为父母兄弟妻子之所爱念。身常受苦心怀愁恼。是一恶人因缘力故。一切人民凡所食啖不得色力。是人恶果殃流万姓。善男子。若复有人乐于妄语。是人现得恶口恶色。所言虽实人不信受。众皆憎恶不喜见之。是名现世恶业之报。舍此身已入于地狱。受大苦楚饥渴热恼。是名后世恶业之报。若得人身口不具足。所说虽实人不信受。见者不乐。虽说正法人不乐闻。是一恶人因缘力故。外物一切资产减少。善男子。若复有人乐饮酒者。是人现世喜失财物。身心多病常乐斗诤。恶名远闻丧失智慧。心无惭愧得恶色力。常为一切之所呵责。人不乐见不能修善。是名饮酒现在恶报。舍此身已处在地狱。受饥渴等无量苦恼。是名后世恶业之果。若得人身心常狂乱。不能系念思惟善法。是一恶人因缘力故。一切外物资产臭烂。善男子。若复有人乐为邪淫。是人不能护自他身。一切众生见皆生疑。所作之事妄语在先。于一切时常受苦恼心常散乱。不能修善喜失财物。所有妻子心不恋慕寿命短促。是名邪淫现在恶果。舍此身已处在地狱。受恶色力饥渴长命无量苦恼。是名后世恶业果报。若得人身恶色恶口人不喜见。不能守护妻妾男女。是一恶人因缘力故。一切外物不得自在。善男子。是五恶法。汝今真实能远离不。若言能者。复应语言。善男子。受优婆塞戒。有四事法所不应作。何等为四。无贪因缘不应虚妄。为嗔恚痴恐怖因缘不应虚妄。是四恶法汝能离不。若言能者。复应语言。善男子。受优婆塞戒。有五处所所不应游。屠儿淫女酒肆国王旃陀罗舍。如是五处汝能离不。若言能者。复应语言。善男子。受优婆塞戒。复有五事所不应作。一者不卖生命。二者不卖刀剑。三者不卖毒药。四者不得沽酒。五者不得压油。如事五事汝能离不。若言能者。复应语言。善男子。受优婆塞戒。复有三事。所不应为。一者不作罗网。二者不作蓝染。三者不作酿皮。如是三事汝能离不。若言能者。复应语言。善男子。受优婆塞戒。复有二事所不应为。一者摴蒱围棋六博。二者种种歌舞伎乐。如是二事汝能离不。若言能者。复应语言。善男子。受优婆塞戒有四种人不应亲近。一者棋博。二者饮酒三者欺诳。四者喜酤酒。如是四人汝能离不。若言能者。复应语言。善男子。受优婆塞戒。有法放逸所不应作。何等放逸。寒时热时饥时渴时。多食饱时清旦暮时。懅时作时初欲作时。失时得时怖时喜时。贼难谷贵病苦壮少年衰老时。富时贫时为命求财时。如是时中不修善法。汝能离不。若言能者。复应语言。善男子。受优婆塞戒先学世事。既学通达如法求财。若得财物应作四分。一分应供养父母己身妻子眷属。二分应作如法贩博。留余一分藏积拟用。如是四事汝能作不。若言能者。复应语言。善男子。财物不应寄付四处。一者老人。二者远处。三者恶人。四者大力。如是四处不应寄付。汝能离不。若言能者。复应语言。善男子。受优婆塞戒。有四恶人常应离之。一者乐说他过。二者乐说邪见。三者口软心恶。四者少作多说。是四恶人汝能离不。若言能者。应令是人满六月日。亲近承事出家智者。智者复应至心观其身四威仪。若知是人能如教作。过六月已。和合众僧满二十人作白羯磨。大德僧听。是某甲今于僧中乞受优婆塞戒。已满六月中净四威仪。至心受持净庄严地。是人丈夫具男子身。若僧听者僧皆默然。不听者说。僧若听者。智者复应作如是言。善男子。谛听谛听。僧已和合听汝受持优婆塞戒。是戒即是一切善法之根本也。若有成就如是戒者。当得须陀洹果乃至阿那含果。若破是戒命终当堕三恶道中。善男子。优婆塞戒。不可思议。何以故。受是戒已虽受五欲。而不能障须陀洹果至阿那含果。是故名为不可思议。汝能怜愍诸众生故受是戒不。若言能受。尔时智者次应为说三归依法。第二第三亦如是说。受三归已名优婆塞。尔时智者复应语言。善男子。谛听谛听如来正觉说优婆塞戒。或有一分。或有半分。或有无分。或有多分。或有满分。若优婆塞受三归已。不受五戒名优婆塞。若受三归受持一戒。是名一分。受三归已受持二戒。是名少分。若受三归持二戒已若破一戒。是名无分。若受三归受持三四戒。是名多分。若受三归受持五戒。是名满分。汝今欲作一分优婆塞作满分耶。若随意说。尔时智者当随意授。既授戒已。复作是言。优婆塞者有六重法。善男子。优婆塞受持戒已虽为天女乃至蚁子悉不应杀。若受戒已。若口教杀若身自杀。是人即失优婆塞戒。是人尚不能得暖法。况须陀洹至阿那含。是名破戒优婆塞臭优婆塞旃陀罗优婆塞垢优婆塞结优婆塞。是名初重。优婆塞戒。虽为身命不得偷盗乃至一钱。若破是戒。是人即失优婆塞戒。是人尚不能得暖法。况须陀洹至阿那含。是名破戒优婆塞臭旃陀罗垢结优婆塞。是名二重。优婆塞戒。虽为身命不得虚说。我得不净观至阿那含。若破是戒。是人即失优婆塞戒。是人尚不能得暖法。况须陀洹至阿那含。是名破戒优婆塞臭旃陀罗垢结优婆塞。是名三重。优婆塞戒。虽为身命不得邪淫。若破是戒。是人即失优婆塞戒。是人尚不能得暖法。况须陀洹至阿那含。是名破戒优婆塞臭旃陀罗垢结优婆塞。是名四重。优婆塞戒。虽为身命不得宣说比丘比丘尼优婆塞优婆夷所有过罪。若破是戒。是人即失优婆塞戒。是人尚不能得暖法。况须陀洹至阿那含。是名破戒优婆塞臭旃陀罗垢结优婆塞。是名五重。优婆塞戒。虽为身命不得酤酒。若破是戒。是人即失优婆塞戒。是人尚不能得暖法。况须陀洹至阿那含。是名破戒优婆塞臭旃陀罗垢结优婆塞。是名六重。善男子。若受如是优婆塞戒。能至心持不令毁犯。则能获得如是戒果。善男子。优婆塞戒名为璎珞名为庄严。其香微妙熏无边界。遮不善法为善法律。即是无上妙宝之藏。上族种姓大寂静处。是甘露味生善法地。直发是心尚得如是无量利益。况复一心受持不毁。善男子。如佛说言若优婆塞受持戒已。不能供养父母师长。是优婆塞得失意罪。不起堕落不净有作。若优婆塞受持戒已耽乐饮酒。是优婆塞得失意罪。不起堕落不净有作。若优婆塞受持戒已。污恶不能瞻视病苦。是优婆塞得失意罪不起堕落不净有作。若优婆塞受持戒已。见有乞者不能多少随宜分与空遣还者。是优婆塞得失意罪。不起堕落不净有作。若优婆塞受持戒已。若见比丘比丘尼长老先宿诸优婆塞优婆夷等。不起承迎礼拜问讯。是优婆塞得失意罪。不起堕落不净有作。若优婆塞受持戒已。若见比丘比丘尼优婆塞优婆夷毁所受戒。心生憍慢言。我胜彼彼不如我。是优婆塞得失意罪。不起堕落不净有作。若优婆塞受持戒已。月月之中不能六日受持八戒供养三宝。是优婆塞得失意罪。不起堕落不净有作。若优婆塞受持戒已。四十里中有讲法处不能往听。是优婆塞得失意罪。不起堕落不净有作。若优婆塞受持戒已。受招提僧卧具床座。是优婆塞得失意罪。不起堕落不净有作。若优婆塞受持戒已。疑水有虫故便饮之。是优婆塞得失意罪。不起堕落不净有作。若优婆塞受持戒已。崄难之处无伴独行。是优婆塞得失意罪。不起堕落不净有作。若优婆塞受持戒已。独宿尼寺。是优婆塞得失意罪。不起堕落不净有作。若优婆塞受持戒已。为于财命打骂奴婢僮仆外人。是优婆塞得失意罪不起堕落不净有作。若优婆塞受持戒已。若以残食施于比丘比丘尼优婆塞优婆夷。是优婆塞得失意罪。不起堕落不净有作若优婆塞受持戒已。若畜猫狸。是优婆塞得失意罪。不起堕落不净有作。若优婆塞受持戒已。畜养象马牛羊驼驴一切畜兽。不作净施未受戒者。是优婆塞得失意罪。不起堕落不净有作。若优婆塞受持戒已。若不储畜僧伽梨衣钵盂锡杖。是优婆塞得失意罪。不起堕落不净有作。若优婆塞受持戒已。若为身命须田作者。不求净水及陆稼处。是优婆塞得失意罪。不起堕落不净有作。若优婆塞受持戒已。为于身命若作市易斗秤卖物。一说价已不得前却舍贱趣贵。斗秤量物任前平用。如其不平应语令平。若不如是。是优婆塞得失意罪。不起堕落不净有作。若优婆塞受持戒已。若于非处非时行欲。是优婆塞得失意罪。不起堕落不净有作。若优婆塞受持戒已。商估贩卖不输官税盗弃去者。是优婆塞得失意罪。不起堕落不净有作。若优婆塞受持戒已。若犯国制。是优婆塞得失意罪。不起堕落不净有作。若优婆塞受持戒已。若得新谷果苽菜茹。不先奉献供养三宝。先自受者。是优婆塞得失意罪。不起堕落不净有作若优婆塞受持戒已。僧若不听。说法赞叹辄自作者。是优婆塞得失意罪。不起堕落不净有作。若优婆塞受持戒已。道路若在诸比丘前沙弥前行。是优婆塞得失意罪。不起堕落不净有作。若优婆塞受持戒已。僧中赋食。若偏为师选择美好过分与之。是优婆塞得失意罪。不起堕落不净有作。若优婆塞受持戒已。若养蚕者。是优婆塞得失意罪。不起堕落不净有作。若优婆塞受持戒已。行路之时遇见病者。不住瞻视为作方便付嘱所在而舍去者。是优婆塞得失意罪。不起堕落不净有作。善男子。若优婆塞至心能受持如是戒。是人名为优婆塞中分陀利花。优婆塞中微妙上香。优婆塞中清净莲花。优婆塞中真实珍宝。优婆塞中丈夫之人。善男子。如佛所说菩萨二种一者在家。二者出家。出家菩萨名为比丘。在家菩萨名优婆塞。出家菩萨持出家戒是不为难。在家菩萨持在家戒是乃为难。何以故。在家之人多恶因缘所缠绕故

    优婆塞戒经净戒品第十五

善生言世尊。有人受持如是戒已。云何当令是戒净耶。佛言。善男子。有三法能净是戒。一者信佛法僧。二者深信因果。三者解心。复有四法。一者慈心。二者悲心。三者无贪心。四者未有恩处先以恩加。复有五法。一者先于怨所以善益之。二者见怖懅者能为救护三者求者未索先开心与。四者凡所施处平等无二。五者普慈一切不依因缘。复有四法。一者终不自轻言我不能得菩提果。二者趣菩提时其心坚固。三者精进勤修一切善法。四者造作大事心不疲悔。复有四事。一者自学善法学已教人。二者自离恶法教人令离。三者善能分别善恶之法。四者于一切法不取不着。复有四法。一者知有为法无我我所。二者知一切业悉有果报。三者知有为法皆是无常。四者知从苦生乐从乐生苦。复有三法。一者于诸众生心无取着。二者施众生乐其心平等。三者如说而行。复有三法。一者能施众生乐因。二者所作不求恩报。三者自知定当得成阿耨多罗三藐三菩提。复有三法。一者为诸众生受大苦恼。二者次第受之。三者中间不息。虽受是苦心终不悔。复有三法。一者未除爱心。能舍所爱施与他人。二者未除嗔恚。有恶来加而能忍之。三者未除痴心。而能分别善恶之法。复有三法。一者善知方便。能教众生远离恶法。二者知善方便。能教众生令修善法。三者化众生时心无疲悔。复有三法。一者为令众生离身苦时。自于身命心不吝惜。二者为令众生离心苦时。自于身命心不吝惜。三者教化众生修善法时。自于身命心不吝惜。复有三法。一者自舍己事先营他事。二者营他事时不择时节。三者终不顾虑辛苦忧恼。复有三法。一者心无妒嫉。二者见他受乐心生欢喜。三者善心相续间无断绝。复有三事。一者见他少善心初不忘。二者毫末之慧辄思多报。三者于无量世受无量苦。其心坚固无退转想。复有三法。一者深知生死多诸过咎。犹故不舍一切作业。二者见诸众生无归依者为作归依。三者见恶众生心生怜愍不责其过。复有三法。一者亲近善友。二者闻法无厌。三者至心咨受善知识教。复有九法。远离三法。三时不悔。平等慧施三种众生。复有四法。所谓慈悲喜舍。善男子。菩萨若以净法净心要在二时。一佛出世时。二缘觉出时。善男子。众生善法有三种生。一从闻生。二从思生。三从修生。闻思二种在二时中。从修生者不必尔也。善男子。菩萨二种。一者在家。二者出家。出家菩萨如是净戒是不为难。在家净戒是乃为难。何以故。在家之人多恶因缘所缠绕故

    优婆塞戒经息恶品第十六

善生言。世尊。菩萨已受优婆塞戒。若有内外诸恶不净因缘。云何得离。善男子。菩萨若有内外诸恶不净因缘。是人应当修念佛心。若有至心修念佛者。是人则得离内外恶不净因缘增长悲慧。世尊。当云何修。善男子。当观如来有七胜事。一者身胜。二者如法住胜。三者智胜。四者具足胜。五者行处胜。六者不可思议胜。七者解脱胜。云何身胜。如来身为三十二相八十种好之所严饰。一一节力敌万八十伊罗钵那香象之力。众生乐见无有厌足。是名身胜。云何如法住胜。如来既自得利益已。复能怜愍救济利益无量众生。是名如法住胜。云何智胜。如来所有四无碍智。非诸声闻缘觉所及。是名智胜。云何具足胜。如来具足行命戒见。是名具足胜。云何行处胜。如来世尊修三三昧九次第等。非诸声闻缘觉所及。是名行处胜。云何不可思议胜。如来所有六种神通。亦非声闻缘觉所及。如来十力四无所畏大悲三念处。是名不可思议胜。云何解脱胜。如来具足二种解脱胜。除智慧障及烦恼障。永断一切烦恼习气。智缘二事俱得自在。是名解脱胜。是故舍利弗于契经中。赞叹如来具七胜法。如来从观不净乃至得阿耨多罗三藐三菩提。从庄严地至解脱地。胜于声闻辟支佛等。是故如来名无上尊。如来世尊修空三昧灭定三昧。四禅慈悲观。十二因缘。皆悉为利诸众生故。如来正觉发言无二。故名如来如往。先佛从庄严地出得阿耨多罗三藐三菩提。故名如来。具足获得微妙正法。名阿罗呵。能受一切人天供养。名阿罗呵。觉了二谛世谛真谛。名三藐三佛陀。修持净戒具足三明。名明行足。更不复生诸有之中。故名善逝。知二世界众生世界国土世界。名世间解。善知方便调伏众生。名调御丈夫。能令众生不生怖畏。方便教化离苦受乐。是名天人师。知一切法及一切行。故名为佛。能破四魔名婆伽婆。复观如来行戒定慧为益众生。久于无量无数世中怨亲等利无有差别。悉断一切无量烦恼。一一皆知一一众生为一烦恼。无量世中受大苦恼。如来世尊为众生故。难施能施难忍能忍。佛有二净。一庄严净。二果报净。如是二净因缘力故。从初十十至后十十。无有人天能说其过。如来具足八万音声。众生闻之不生厌离。以是因缘如来出胜一切声闻辟支佛等。善男子。若人受持优婆塞戒欲净戒者。当作如是修念佛心。若修念佛是人则离内外诸恶不净因缘。增长悲慧。贪嗔痴断具足成就一切善法。善男子。菩萨二种。一者在家。二者出家。出家菩萨修念佛心是不为难。在家修集是乃为难。何以故。在家之人多恶因缘所缠绕故

    优婆塞戒经供养三宝品第十七

善生言。世尊。菩萨已受优婆塞戒。复当云何供养三宝。善男子。世间福田凡有三种。一报恩田。二功德田。三贫穷田。报恩田者。所谓父母师长和上。功德田者。从得暖法乃至得阿耨多罗三藐三菩提。贫穷田者。一切穷苦困厄之人。如来世尊是二种福田。一者报恩田。二功德田。法亦如是是二种田。众僧三种。一报恩田二功德田。三贫穷田。以是因缘。菩萨已受优婆塞戒。应当至心勤供养三宝。善男子。如来即是一切法藏。是故智者应当至心勤心供养生身灭身形像塔庙。若于空野无塔像处。常当系念尊重赞叹。若自力作若劝人作。见人作时心生欢喜。如其自有功德力者。要当广教众多之人而共作之。既供养已。于己身中莫生轻想。于三宝所亦应如是。凡所供养不使人作不为胜他。作时不悔心不愁恼。合掌赞叹恭敬尊重。若以一钱至无量宝。若以一綖至无量綖。若以一花至无量花。若以一香至无量香。若以一偈赞至无量偈赞。若以一礼至无量礼。若绕一匝至无量匝。若一时中乃至无量时。若自独作若共人作。善男子。若能如是至心供养佛法僧者。若我现在及涅槃后。等无差别。见塔庙时。应以金银铜铁绳锁幡盖伎乐香油灯明而供养之。若见鸟兽践蹋毁坏。要当涂治扫除令净。暴风水火之所坏处。亦当自治。自若无力当劝人治。或以金银铜铁土木。若有尘土洒扫除拂。若有垢污以香水洗。若作宝塔及作宝像。作讫当以种种幡盖香花奉上。若无真宝力不能办。次以土木而造成之。成讫亦当幡盖香花种种伎乐而供养之。若是塔中草木不净鸟兽死尸。及其粪秽萎花臭烂悉当除去。蛇鼠孔穴当塞治之。铜像木像石像泥像。金银琉璃颇梨等像。常当洗治任力香涂。随力造作种种璎珞。乃至犹如转轮圣王塔。精舍内当以香涂。若白土泥。作塔像已。当以琉璃颇梨真珠绫绢彩绵铃磬绳锁而供养之。画佛像时彩中不杂胶乳鸡子。应以种种花贯散花妙绋明镜。末香涂香散香烧香。种种伎乐歌舞供养。如昼夜亦如是。如夜昼亦如是。不如外道烧酥大麦而供养之。终不以酥涂塔像身亦不乳洗。不应造作半身佛像。若有形像身不具足。当密覆藏劝人令治。治已具足然后显示。见像毁坏应当至心供养恭敬。如完无别。如是供养要身自作。若自无力当为他使。亦劝他人令佐助之。若人能以四天下宝供养如来。有人直以种种功德尊重赞叹至心恭敬。是二福德等无差别。所谓如来身心具足。身有微妙三十二相八十种好。具足大力。心有十力四无所畏大悲三念五智三昧三种法门十一种空观十二缘智无量禅定。具足七智已能度到六波罗蜜岸。若人能以如是等法赞叹佛者。是人则名真供养佛。云何名为供养于法。善男子。若能供养十二部经。名供养法。云何供养十二部经。若能至心信乐受持读诵解说。如说而行。既自为已复劝人行。是名供养十二部经。若能书写十二部经。既书写已种种供养如供养佛。唯除洗浴。若有供养受持读诵如是经者。是则名为供养法也。供养法时如供养佛。又复有法谓菩萨。一根辟支佛人。三根三谛。若信是者名供养法。若有供养发菩提心受持戒者出家之人。向须陀洹至阿罗汉果。名供养僧。若有人能如是供养佛法僧宝。当知是人终不远离十方如来。常与诸佛行住坐卧。善男子。若有人能如说多少供养如是三福田者。当知是人于无量世多受利益。善男子。菩萨二种。一者在家。二者出家。出家菩萨供养三宝是不为难。在家供养是乃为难。何以故。在家之人多恶因缘所缠绕故

优婆塞戒经卷第三优婆塞戒经卷第四

        北凉中印度三藏昙无谶译

    六波罗蜜品第十八

善生言。世尊。如佛先说供养六方。六方即是六波罗蜜。是人则能增长财命。如是之人有何等相。佛言。善男子。若能不惜一切财物。常于他人作利益事。念于布施乐行布施。随有随施不问多少。当行施时于身财物不生轻想。净施不择持戒毁戒。赞叹布施见行布施欢喜不妒。见有求者心则悦乐。起迎礼拜施床命坐。前人咨问若不咨问。辄为赞叹布施之果。见恐怖者能为救护。处饥馑世乐施饮食。虽作是施不为果报。不求恩报施。不诳众生。能赞三宝所有功德。不以斗称杂余异贱欺诳于人。不乐酒博贪欲之心。常修惭羞愧耻之德。虽复巨富心不放逸。多行惠施不生憍慢。善男子。有是相者。当知是人则能供养施波罗蜜。善男子。若有人能净身口意。常修软心不作罪过。设误作者常生愧悔。信是罪业得恶果报。所修善事心生欢喜。于小罪中生极重想。设其作已恐怖忧悔。终不打骂嗔恼众生。先意语言。言辄柔软。见众生已生爱念心。知恩报恩。心不悭吝不诳众生。如法求财乐作福德。所作功德常以化人。见穷苦者身代受之。常修慈心怜愍一切。见作恶者能为遮护。见作善者赞德说果。复以身力往营佐之。身不自由令他自在。常修远离嗔恚之心。或时暂起觉生愧悔。实语软语。远离两舌及无义语。善男子。有是相者。当知是人则能供养戒波罗蜜。善男子。若人能净身口意业。众生设以大恶事加。乃至不生一念嗔心。终不恶报。若来悔谢即时受之。见众生时心常欢喜。见作恶者生怜愍心。赞叹忍果呵责嗔恚。说嗔果报多有苦毒。修施忍时先及怨家。正观五阴众缘合和。若和合成何故生嗔。深观嗔恚乃是未来无量恶道受苦因缘。若暂生嗔则生惭愧恐怖悔心。见他忍胜不生妒嫉。善男子。有是相者。当知是人则能供养忍波罗蜜。善男子。若有人能不作懈怠。不受不贪坐卧等乐。如作大事功德力时。及营小事心亦如是。凡所作业要令毕竟。作时不观饥渴寒热。时与非时不轻自身。大事未讫不生悔心。作既终讫自庆能办。赞叹精进所得果报。如法得财用皆以理。见邪进者为说恶果。善教众生令修精进。所作未竟不中休息。修善法时不随他语。善男子。有是相者。当知是人则能供养进波罗蜜。善男子。若有人能净身口意。乐处空闲若窟若山树林空舍。不乐愦闹贪着卧具。不乐听说世间之事。不乐贪欲嗔恚愚痴。先语软语常乐出家。教化众生。所有烦恼轻微软薄离恶觉观。见怨修慈乐说定报。心若逸乱生怖愧悔。见邪定者为说罪过。善化众生置正定中。善男子。有是相者。当知是人则能供养禅波罗蜜。善男子。若有人能净身口意。悉学一切世间之事。于贪嗔痴心不贪乐。不狂不乱怜愍众生。善能供养父母师长和上长老耆旧有德。修不放逸先语软语不诳众生。能分别说邪道正道及善恶报。常乐寂静出家修道。能以世事用教众生。见学胜已不生妒心。自胜他人不生憍慢。受苦不忧受乐不喜。善男子。有是相者。当知是人则能供养般若波罗蜜。善男子。一一方中各有四事。施方四者。一者调伏众生。二者离对。三者自利。四者利他。若人于财不生悭惜。亦不分别怨亲之相时与非时。是人则能调伏众生。于财不惜故能行施。是故得离悭吝之恶。是名离对。欲施施时施已欢喜不生悔心。是故未来受人天乐至无上乐。是名自利。能令他人离于饥渴苦切之恼。故名利他。戒方四者。一者庄严菩提。二者离对。三者自利四者利他。庄严菩提者。优婆塞戒至菩萨戒。能为阿耨多罗三藐三菩提初地根基。是名庄严。既受戒已复得远离恶戒无戒。是名离对受持戒已得人天乐至无上乐。是名自利既受戒已施诸众生无恐无畏咸令一切离苦获安是名利他。忍方四者。一者庄严菩提。二者离对。三者自利。四者利他。庄严菩提者因忍故得修善。修善故得初地乃至阿耨多罗三藐三菩提。是名庄严既修忍已能离嗔恶。是名离对。忍因缘故得人天乐至无上乐。是名自利。忍因缘故人生喜心善心调心。是名利他。进方四者。一者庄严菩提。二者离对。三者自利。四者利他。庄严菩提者。因精进故得修善修善法故得初地乃至阿耨多罗三藐三菩提。是名庄严。修善法时离恶懈怠。是名离对。因是善法得人天乐至无上乐。是名自利。教众生修善令离恶法。是名利他。禅方四者。一者庄严菩提。二者离对。三者自利四者利他庄严菩提者。因修如是禅定力故。获得初地乃至阿耨多罗三藐三菩提。是名庄严。因是禅定修无量善离恶觉观。是名离对。修舍摩他因缘力故。常乐寂静得人天乐至无上乐。是名自利。断诸众生贪欲嗔恚狂痴之心。是名利他。智方四者一者庄严菩提。二者离对。三者自利。四者利他。庄严菩提者。因修智慧获得初地乃至阿耨多罗三藐三菩提。是名庄严。修智慧故远离无明。令诸烦恼不得自在。是名离对。除烦恼障及智慧障。是名自利。教化众生令得调伏。是名利他。善男子。或有说言离戒无忍离智无定。是故说有四波罗蜜。若能忍恶不还报者。即名为戒。若修禅定心不放逸。即是智慧。是故戒即是忍。慧即是定。离慧无定离定无慧。是故慧即是定。定即是慧。离戒无进离进无戒。是故戒即精进。精进即戒。离施无进离进无施。是故施即精进。精进即施。故知无有六波罗蜜者。是义不然。何以故。智慧是因布施是果。精进是因持戒是果。三昧是因忍辱是果然因与果不得为一。是故应有六波罗蜜。若有说言。戒即是忍忍即是戒。是义不然。何以故。戒从他得忍不如是。有不受戒而能忍恶。为众修善忍无数苦。无量世中代诸众生。受大苦恼心不悔退。是故离戒应有忍辱。善男子三昧即是舍摩他也智慧即是毗婆舍那。舍摩他名缘一不乱毗婆舍那名能分别。是故我于十二部经说定慧异当知定有六波罗蜜。如来所以最初先说檀波罗蜜。为调众生施时离贪。是故次说尸波罗蜜。施时能忍舍离之心。是故次说忍波罗蜜施时心乐不观时节。是故次说进波罗蜜。施时心一无有乱相。是故次说定波罗蜜。施时不为受生死乐。是故次说智波罗蜜。善男子。云何名为波罗蜜耶。施时不求内外果报。不观福田及非福田。施一切财心不吝惜不择时节是故名为施波罗蜜乃至小罪虽为身命尚不毁犯。是故名为戒波罗蜜乃至恶人来割其身忍而不嗔。是故名为忍波罗蜜三月之中一偈赞佛不休不息。是故名为进波罗蜜。具足获得金刚三昧。是故名为禅波罗蜜善男子得阿耨多罗三藐三菩提时。具足成就六波罗蜜。是故名为智波罗蜜。善男子。菩萨有二。一者在家。二者出家。出家能净六波罗蜜是不为难。在家能净是乃为难。何以故。在家之人多恶因缘所缠绕故

    优婆塞戒经杂品第十九

善生言。世尊。菩萨已修六波罗蜜。能为众生作何等事。善男子。如是菩萨能拔沉没苦海众生。善男子。若有于财法食生悭。当知是人于无量世得痴贫报。是故菩萨修行布施波罗蜜时。要作自利及利益他。善男子。若人乐施。一切怨仇悉生亲想。不自在者皆得自在。信施因果信戒因果。是人则得成就施果。善男子有人说言施即是意。所以者何。意是施根故。是义不然。何以故。施即五阴。所以者何。由身口意具足施故。布施若为自利他利及自他利。则具五阴。如是布施。即能庄严菩提之道。远离烦恼多财巨富。名施正果。寿命色力安乐辩才。名施余果。施果三种。有胜财故获得胜果。有田胜故获得胜果。施主胜故获得胜果。向须陀洹至后身菩萨乃至成佛。是名胜田。施如是田故得胜果。若有施物具足妙好色香味触。是名财胜。以是物施故得胜果。若有施主信心淳浓施戒闻慧则得胜果。善男子。有智之人施有五种。一者至心施。二者自手施。三者信心施。四者时节施。五者如法求物施。善男子。至心施者得何等果。若至心施者。是人则得多财饶宝金银琉璃车渠马瑙真珠珊瑚。象马牛羊田宅奴婢多饶眷属。至心施者得如是果。自手施者得何等果。自手施已。所得果报如上所说。得已能用。自手施者得如是报。信心施者得何等果。信心施已。所得果报如上所说。常为父母兄弟宗亲一切众生之所爱念。信心施者加如是报。时节施者得何等果。时节施者。所得果报如上所说。所须之物随时而得。时节施者兼如是果。如法财施得何等果。如法财施。所得果报如先所说。得是财已王贼水火所不能侵。若好色施以是因缘。是人获得微妙上色。若以香施是人因是名称远闻。若以味施是人因是众乐见闻。既见闻已生爱重心。若好触施是人因是得上妙触。受者受已。则能获得寿命色力安乐辩才。善男子。有人说言。施于塔像不得寿命色力安辩。无受者故。是义不然。何以故。有信心故。施主信心而行布施。是故应得如是五报。善男子。譬如比丘修集慈心。如是慈心实无受学。而亦获得无量果报。施塔像等亦应如是得五果报。善男子。如人种谷终不生苽。施于塔像亦复如是。以福田故得种种果。是故我说田得果报物得果报主得果报。善男子。施有二种。一者法施。二者财施。法施则得财法二报。财施唯还得财宝报。菩萨修行如是二施。为二事故。一令众生远离苦恼。二令众生心得调伏。善男子。复有三施。一以法施。二无畏施。三财物施。以法施者。教他受戒出家修道白四羯磨。为坏邪见说于正法。能分别说实非实等。宣说四倒及不放逸。是名法施。若有众生怖畏王者师子虎狼水火盗贼。菩萨见已能为救济。名无畏施。自于财宝破悭不吝。若好若丑若多若少。牛羊象马房舍卧具。树林泉井奴婢仆使。水牛驼驴车乘辇舆。瓶瓮釜镬绳床坐具铜铁瓦器。衣服璎珞灯明香花。扇盖帽履机杖绳索。犁鎒斧凿草木水石。如是等物。称求者意随所须与。是名财施。若起僧坊及起别房。如上施与出家之人。唯除象马。善男子。施有四累。一悭贪心。二不修施。三轻小物。四求世报。如是四累二法能坏。一修无我。二修无常。善男子。若欲乐施当破五事。一者嗔心。二者悭心。三者妒心。四者惜身命。五者不信因果。破是五事常乐布施。乐施之人获得五事。一者终不远离一切圣人。二者一切众生乐见乐闻。三者入大众时不生怖畏。四者得好名称。五者庄严菩提。善男子。菩萨之人名一切施。云何名为一切施也。善男子。菩萨摩诃萨如法求物持以布施。名一切施。恒以净心施于受者。名一切施。少物能施名一切施。所爱之物破悭能舍。名一切施。施不求报名一切施。施时不观田以非田。名一切施。怨亲等施名一切施。菩萨施财凡有二种。一者众生。二者非众生。于是二中乃至自身都不吝惜。名一切施。菩萨布施由怜愍心。名一切施。欲施施时施已不悔。名一切施。或时设以不净物施。为令前人生喜心故。酒毒刀杖枷锁等物。若得自在若不自在。终不以施。不施病人不净食药。不劫他物乃至一钱持以布施。菩萨施时虽得自在终不骂打令诸仆使生嗔苦恼。如法财施不求现在后世果报。施已常观烦恼罪过。深观涅槃功德微妙。除菩提已更无所求。施贫穷时起悲愍心。施福田时生喜敬心。施亲友时不生放舍心。若见乞者。则知所须随相给与不令发言。何以故。不待求施得无量果

善男子。施主有三。谓下中上。不信业果深着悭吝恐财有尽。见来求者生嗔碍想。是名为下。虽信业果于财生悭恐有空竭。见来求者生于舍心。是名为中。深信业果于财物所不生悭吝。观诸财物是无常想。见来求者有与则喜无与则恼。以身[貝*致]物而用与之。是名为上。复有下者。见来求者[卑*頁]面不看恶骂毁辱。复有中者。虽复施与轻贱不敬。复有上者。未求便施敬心而与。复有下者为现报施。复有中者为后报施。复有上者怜愍故施。复有下者为报恩施。复有中者为业故施。复有上者为法藏施。复有下者畏胜故施。复有中者等己故施。复有上者不择怨亲。又复下者有财言无。又复中者多财言少。又复上者少索多与。施者无财亦复三种。最下之人见来求者恶心嗔责。中品之人见来求者直言无物。上品之人见来求者自鄙无物心生愁恼。善男子。又复下者常为圣贤之所呵责。又复中者常为贤圣之所怜愍。又复上者贤圣见已心生欢喜。善男子。智人行施为自他利。知财宝物是无常故。为令众生生喜心故。为怜愍故。为坏悭故。为不求索后果报故。为欲庄严菩提道故。是故菩萨一切施已不生悔心不虑财尽。不轻财物不轻自身。不观时节不观求者。常念乞者如饥思食。亲近善友咨受正教。见来求者心生欢喜。如失火家得出财物。欢喜赞叹说财多过。施已生喜如寄善人。复语乞者汝今真是我功德因。我今远离悭贪之心。皆由于汝来乞因缘。即于求者生亲爱心。既施与已复教乞者。如法守护勤修供养佛法僧宝。菩萨如是乐行施已。则得远离一切放逸。虽以身分施于乞者。终不生于一念恶心。因是更增慈悲喜舍。不轻受者亦不自高。自庆有财称求者意。增长信心不疑业果。善男子。若能观财是无常相。观诸众生作一子想。是人乃能施于乞者。善男子。是人不为悭结所动。如须弥山风不能动。如是之人能为众生而作归依。是人能具檀波罗蜜。善男子。有智之人为四事故乐行惠施。一者因施能破烦恼二者因施发种种愿。三者因施得受安乐。四者因施多饶财宝。善男子。无贪之心名之为施。云何无贪施。即是业物即是作为业。为作具足布施。名为无贪。因于布施破烦恼者。既行惠施破悭贪嫉妒嗔恚愚痴。云何因施发种种愿。因是施已能发种种善恶等愿。因善恶愿得善恶果。何以故。誓愿力故。云何因施得受安乐。因是施故。受人天乐至无上乐。云何因施多饶财宝。因是施故。所求金银乃至畜生。如意即得。善男子。若人乐施。是人即坏五弊恶法。一者邪见。二者无信。三者放逸。四者悭吝。五者嗔碍。离是恶已心生欢喜。因欢喜故乃至获得真正解脱。是人现在得四果报。一者一切乐见乃至怨家。二者善名流布遍于四方。三者入大众时心无怖畏。四者一切善人乐来亲附。善男子。修行施已其心无悔。是人若以客尘烦恼故堕于地狱。虽处恶处不饥不渴。以是因缘离二种苦。一铁丸苦。二铁浆苦。若畜生身所须易得无所匮乏。若饿鬼身不受饥渴常得饱满。若得人身寿命色力安乐辩才。及信戒施多闻智慧胜于一切。虽处恶世不为恶事。恶法生时终不随受。于怖畏处不生恐怖。若受天身十事殊胜。善男子。有智之人为二事故能行布施。一者调伏自心。二者坏怨嗔心。如来因是名无上尊。善男子。智者施已不求受者爱念之心。不求名称免于怖畏。不求善人来见亲附。亦不求望天人果报。观于二事。一者以不坚财易于坚财。二者终不随顺悭吝之心。何以故。如是财物。我若终没不随我去。是故应当自手施与。我今不应随失生恼。应当随施生于欢喜。善男子。施者先当自试其心以外物施。知心调已次施内物。因是二施获得二法。一者永离诸有。二者得正解脱。善男子。如人远行身荷重担疲苦劳极舍之则乐。行施之人见来求者舍财与之。心生喜乐亦复如是。善男子。智者常作如是思惟。欲令此物随逐我身。至后世者。莫先于施。复当深观贫穷之苦豪贵快乐。是故系心常乐行施。善男子。若人有财见有求者言无言懅。当知是人已说来世贫穷薄德。如是之人名为放逸。善男子。无财之人自说无财。是义不然。何以故。一切水草人无不有。虽是国主不必能施。虽是贫穷非不能施。何以故。贫穷之人亦有食分。食已洗器弃荡涤汁。施应食者亦得福德。若以尘糗施于蚁子。亦得无量福德果报。天下极贫谁当无此尘许糗也。谁有一日食三揣糗命不全者。是故诸人应以食半施于乞者。善男子。极贫之人谁有赤裸无衣服者。若有衣服岂无一綖施人系疮。一指许财作灯炷耶。善男子。天下之人谁有贫穷当无身者。如其有身见他作福。身应往助欢喜无厌。亦名施主亦得福德。或时有分或有与等或有胜者。以是因缘我受波斯匿王食时亦咒愿。王及贫穷人所得福德等无差别。善男子。如人买香涂香末香散香烧香。如是四香有人触者。买者量者等闻无异。而是诸香不失毫厘。修施之德亦复如是。若多若少若粗若细。若随喜心身往佐助。若遥见闻心生欢喜。其心等故。所得果报无有差别。善男子。若无财物见他施已。心不喜信疑于福田是名贫穷。若多财宝自在无碍有良福田。内无信心不能奉施。亦名贫穷。是故智者随有多少任力施与。除布施已。无有能得人天之乐至无上乐是故我于契经中说。智者自观余一揣食。自食则生施他则死。犹应施与。况复多耶。善男子。智者当观财是无常。是无常故于无量世失坏秏减。不得利益虽是无常。而能施作无量利益。云何悭惜不布施也。智者复观世间若有持戒多闻。持戒多闻因缘力故。乃至获得阿罗汉果。虽得是果不能遮断饥渴等苦。若阿罗汉难得房舍衣服饮食卧具病药。皆由先世不施因缘。破戒之人若乐行施。是人虽堕饿鬼畜生。常得饱满无所乏少。善男子。除布施已不得二果。一者自在。二者解脱。若持戒人虽得生天。不修施故不得上食微妙璎珞。若人欲求世间之乐及无上乐。应当乐施。智者当观生死无边受乐亦尔。是故应为断生死施不求受乐。复作是观。虽复富有四天下地受无量乐犹不知足。是故我应为无上乐而行布施。不为人天。何以故。无常故有边故。善男子。若有说言。施主受者及受乐者皆是五阴。如是五阴即是无常。舍施五阴谁于彼受虽无受者。善果不灭。是故无有施者受者。应反问言有施受不。若言施即是施受即我者。复应语言。我亦如是施即是施我即五阴。若言施阴此处无常谁于彼受。谛听谛听当为汝说。种子常耶是无常乎。若言常者。云何子灭而生于芽。若见是过。复言无常。复当语言。若无常者。子时与粪水土等功。云何而令芽得增长。若言子虽无常以功业故而得芽果。应言五阴亦复如是。若言子中先已有芽。人功水粪为作了因。是义不然。何以故。了因所了物无增减。多则多住少则少住。而今水粪芽则增长。是故本无今有。若言了因二种一多二少。多则见大少则见小。犹如然灯明多见大明少见小。是义不然。何以故。犹如一种多与水粪。不能一时一日增长人等过人。若言了因虽有二种。要待时节。物少了少物多了多。是故我言了因不增。是义不然。何以故。汝法时常。是故不应作如是说。善男子。子异芽异。虽作得异相似不断。五阴亦尔。善男子。如子业增芽。芽业增茎。茎业增叶。叶业增花。花业增果。一道五阴增五道阴。亦复如是。若言如是异作异受。是义汝有。非我所说。何以故。如汝法中。作者是我受者是身。而复不说异作异受。受不杀戒即是我也。以是因缘身得妙色。是故汝法受者无因作者无果。有如是过。若言我作身受。我亦如是此作彼受。复应问言。汝身我异。身受饮食被服璎珞。妙食因缘得好色力。恶食因缘得弊色力。是好恶色。若属因缘我何所得。若言我得。忧愁欢喜。云何不是异作异受。譬如有人为力服酥。是人久服身得大力上妙好色。有人羸瘦见之心喜。是人即得大色力不。若言不得。我亦如是。身所作事我云何得。何以故。不相似故。我法不尔。阴作阴受相似不断。善男子。若言五阴无常此不至彼而得受报。是义不妨。何以故。我法或有即作即受。或有异作异受无作无受。即作即受者阴作阴受。异作异受者人作天受。无作无受者。作业因缘和合而有。本无自性何有作受。汝意若谓异作异受。云何复言相续不断。是义不然。何以故。譬如置毒乳中。至醍醐时故能杀人。乳时异故醍醐亦异。虽复有异次第而生相似不断故能害人。五阴亦尔。虽复有异次第而生相似不断。是故可言异作异受即作即受无作无受者。若离五阴者无我我所。一切众生颠倒覆心。或说色即是我。乃至识即是我。或有说言色即是我其余四阴即是我所。乃至识亦如是。若有说言离五阴已别有我者。无有是处。何以故。我佛法中色非我也。所以者何。无常无作不自在故。是故四阴不名我所。乃至识亦如是。众缘和合异法出生。故名为作实无异作。众缘和合异法出生。名为受者实无异受。是故名为无作无受。若汝意谓异作异受。何故此人作业不彼人受俱有五阴。是义不然。何以故。异有二种。一者身异。二者名异。一者佛得。二者天得。佛得天得身名各异。是因缘故身口应异。身口异故造业亦异。造业异故。寿命色力安辩亦异。是故不得佛得作业天得受果。虽俱五阴色名是一。受想行异。何以故。佛得受乐天得受苦。佛得生贪天得生嗔。是故不得名为相似色名虽一其实有异。或有佛得白色天得黑色。若以名同为一义者。一人生时。应一切生。一人死时应一切死。汝若不欲然此义者。是故不得异作异受。汝意若谓汝亦异作异受。我亦如是异作异受。若异作异受。应同我过。何故不见自过而责我者。是义不然。何以故。我异二种。一次第生亦次第灭。二者次第生不次第灭。是生异故灭亦复异。是故我言异作异受。此作此受不同汝过。譬如有人欲烧聚落。于干草中。放一粒火。是火次第生因缘故。能烧百里至二百里。村主求得即便问之。汝弊恶人。何因缘故烧是大村。彼人答言。实非我烧。何以故。我所放火寻已灭尽。所烧之处一把草耳我今当还偿汝二把。其余之物我不应偿。是时村主复作是言。痴人因汝小火次第生火。遂烧百里至二百里。辜由于汝云何不偿。虽知是火异作异烧。相续不断故彼得罪。善恶五阴亦复如是。受报时阴虽言不作。以其次第相续而生。是故受报。譬如有人与他共货。执炬远行至百里外。若不至者当输罚负。如其到者汝当输我。执炬之人至百里已。即从责物。他言。汝炬发迹已灭。云何于此从我索物。执炬者言。彼火虽灭次第相续生来至此。如是二人说俱得理。何以故。如是义者亦即亦异。是故二人俱无过失。若有说言五阴亦尔。即作即受异作异受。俱无过失譬如此彼二岸中流。总名恒河。夏时二岸相去甚远。秋时二岸相去则近。无常定相或大或小。虽复增减人皆谓河或有说言此不是河智人亦说有异不异五阴亦尔。智人亦说。即作即受异作异受。汝意若谓。二岸是土。中流是水。河神是河。是义不然。何以故。若神是河何故复言河清河浊。有此岸彼岸中流深浅。到于大海可度不度。譬如有树则有神居。若无树者神何所居。河之与神亦应如是。是故彼此二岸中流次第不断。总名为河。是故可言。即之与异五阴亦尔。譬如有人骂辱贵胜因恶口故脚被锁械。是脚实无恶口之罪。而被锁械。是故不得决定说言。异作异受即作即受。唯有智者可得说言。即作即受异作异受。譬如器油炷火人护。众缘和合乃名灯明。汝意若谓灯明增减。是义不然。何以故灭故不增来故无减。以次第生故言灯增减。汝意若谓灯是无常油即是常。油多明多油少明少者。是义不然。何以故。油无常故有尽有烧。如其常者应二念住。若二念住谁能烧尽。是故智人亦复说言。灯明即异。五阴亦尔。明即六入油即是业。油业因缘故。令五阴有增有减有彼有此。如有人说阿坻耶语。是阿坻耶久已过去不在今日。世人相传次第不灭。故得称为阿坻耶语智者。亦说是阿坻耶语非阿坻耶语。虽复是非俱不失理。五阴亦尔。亦可说言即作即受异作异受。有人巨富。继嗣中断身复丧没财当入官。有人言曰。如是财物应当属我。官人语言。是财云何异作异属。是人复言。我是亡者第七世孙。次第不断。云何是财不属我耶。官人即言如是如是。如汝所说智者说言。五阴亦尔即作即受。异作异受汝意若谓五阴作业。成已便过是身犹在。业无所依。业若无依便是无业。舍是身已云何得报。是义不然。何以故。一切过业待体待时。譬如橘子因橘而生从酢而甜。人为橘故种殖是子。是子根茎叶花生果皆悉不酢。时到果热酢味则发。如是酢味。非本无今有亦非无缘。乃是过去本果因缘身口意业。亦复如是。若言是业住何处者。是业住于过去世中。待时待器得受果报。如人服药经于时节。药虽销灭时到则发。好力好色。身口意业亦复如是。虽复过灭时到则受。譬如小儿初所学事。虽念念灭无有住处。然至百年亦亦不亡失。是过去业亦复如是。虽无住处时到自受。是故言非阴作阴受。亦复不得非阴受也。若能了了通达是事。是人则能获无上果

优婆塞戒经卷第四优婆塞戒经卷第五

        北凉中印度三藏昙无谶译

    杂品之余

善男子。若复有人于身命财悭吝不施。是名为悭。护惜悭人不施之心。不生怜愍留待福田求觅福田。既得求过。观财难得为之受苦。或说无果无施无受。护惜妻子眷属等心。积财求名见多生喜。观财是常是名悭垢。是垢能污诸众生心。以是因缘于他物中尚不能施。况出自物。智人行施不为报恩不为求事。不为护惜悭贪之人。不为生天人中受乐。不为善名流布于外。不为畏怖三恶道苦。不为他求不为胜他。不为失财不以多有。不为不用不为家法。不为亲近。智人行施为怜愍故。为欲令他得安乐故。为令他人生施心故。为诸圣人本行道故。为欲破坏诸烦恼故。为入涅槃断于有故。善男子。菩萨布施远离四恶。一者破戒。二者疑网。三者邪见。四者悭吝。复离五法。一者施时不选有德无德。二者施时不说善恶。三者施时不择种姓。四者施时不轻求者。五者施时不恶口骂。复有三事。施已不得胜妙果报。一者先多发心后则少与。二者择选恶物持以施人三者既行施已心生悔恨。善男子。复有八事。施已不得成就上果。一者施已见受者过。二者施时心不平施。三者施已求受者作。四者施已喜自赞叹。五者说无后乃与之。六者施已恶口骂詈。七者施已求还二倍。八者施已生于疑心。如是施主则不能得亲近诸佛贤圣之人。若以具足色香味触施于彼者。是名净施。若能如法得财施者。是名净施。观财无常不可久保而行布施。是名净施。为破烦恼故行布施。是名净施。为净自心因缘故施。是名净施。若观谁施谁是受者。施何等物何缘故施。是施因缘得何等果。如是布施即十二入。受者施主因缘果报皆十二入。能如是观行于施者。是名净施。若行施时于福田所生欢喜心。如诸福田所求功德。我亦如是求之不息。施于妻子眷属仆使生怜愍心。施于贫穷为坏苦恼。施时不求世间果报。破憍慢施柔濡心施离诸有施。为求无上解脱故施。深观生死多过罪施。不观福田非福田施。若能如是行布施者。报逐是人如犊随母。若求果施市易无异。如为身命耕田种作。随其种子获其果实。施主施已亦复如是。随其所施获其福报。如受施者受已得命色力安辩。施主亦得如是五报。若施畜生得百倍报。施破戒者得千倍报。施持戒者得十万报。施外道离欲得百万报。施向道者得千亿报。施须陀洹得无量报。向斯陀含亦无量报。乃至成佛亦无量报

善男子。我今为汝分别诸福田故作如是说。得百倍报至无量报。若能至心生大怜愍施于畜生。专心恭敬施于诸佛。其福正等无有差别。言百倍者。如以寿命色力安辩施于彼者。施主后得寿命色力安乐辩才各各百倍。乃至无量亦复如是。是故我于契经中说。我施舍利弗。舍利弗亦施于我。然我得多。非舍利弗得福多也。或有人说。受者作恶罪及施主。是义不然。何以故。施主施时为破彼苦。非为作罪。是故施主应得善果。受者作恶罪自钟之。不及施主。施主若以净妙物施。后得好色人所乐见。善名流布所求如意生上种姓。是不名恶。云何说言施主得罪。施主施已欢喜不悔亲近善人。财富自在生上族家。得人天乐至无上乐。能离一切烦恼结缚。施主乃得如是妙果。云何说言得恶果报。施主若能自手施已。生上姓家遇善知识。多财饶宝眷属成就能用能施。一切众生喜乐见之。见已恭敬尊重赞叹。施主受报得如是事。云何说言得恶果报。施主若已净物施已。以是因缘多饶财宝生上种姓。眷属无量身无病苦心无忧怖。所有财物王贼水火所不能侵。设失财物不生愁恼。无量世中身心安乐。云何说言受恶果报。若未施时生于信心施时欢喜。施已安乐。求时守时用时不苦。若以衣施得上妙色。若以食施得无上力。若以灯施得净妙眼。若以乘施身受安乐。若以舍施所须无乏。施主乃得如是善报。云何说言得恶果也。复次施主。若施佛已用与不用果报已定。施人及僧有二种福。一从用生。二从受生。何以故。施主施时自破悭吝。受者用时破他悭吝。是故说言从用生福。又复从用人能转用僧能增长。施已不求世之果报。不以能起烦恼因施。是故能得无上净果名曰涅槃。若有人能日日立要。先施他食然后自食。若违此要誓输佛物。犯则生愧。如其不违即是微妙智慧因缘。如是施者诸施中最。是人亦得名上施主。若能随顺求者意施。是人于后无量世中所求如意。若有净心财物福田悉清净者。是人则得无量果报。若给妻子奴婢衣食。恒以怜愍欢喜心与。未来则得无量福德。复观田仓多有鼠雀犯暴谷米。恒生怜愍复作是念。如是鼠雀因我得活。念已欢喜无触恼想。当知是人得福无量。若为自身造作衣服璎珞环玔严身之具。种种器物作已欢喜。自未服用持以施人。是人未来得如意树。若有说言离于布施得善果者。无有是处。离财得施离受有施。不离悭惜成布施者。亦无是处。若不求施若乏时施。少求多施求恶施好教他索施自往行施。当知是人未来之世多获宝藏。非宝之物悉变成宝。为戏笑施非福田施。不信因果施。如是布施不名为施。若人偏为良福田施不乐常施。是人未来得果报时不乐惠施。若人施已生于悔心。若劫他物持以布施。是人未来虽得财物常秏不集。若恼眷属得物以施。是人未来虽得大报身常病苦。若先不能供养父母。恼其妻子奴婢困苦。而布施者是名恶人。是假名施不名义施。如是施者名无怜愍不知恩报。是人未来虽得财宝常失不集。不能出用。身多病苦。若人如法以财布施。是人未来得无量福有财能用。若有不以如法财施。是人未来虽得果报恒赖他得。他若丧没寻便贫穷。有智之人深观人天转轮王乐。虽复微妙皆是无常。是故施时不为人天。善男子。施有二种一者财施。二者法施。财施名下法施名上。云何法施。若有比丘比丘尼优婆塞优婆夷。能教他人具信戒施多闻智慧。若以纸墨令人书写。若自书写如来正典。然后施人令得读诵。是名法施。如是施者未来无量得好上色。何以故。众生闻法断除嗔心。以是因缘施主未来无量世中得成上色。众生闻法慈心不杀。以是因缘施主未来无量世中得寿命长。众生闻法不盗他财。以是因缘施主未来无量世中多饶财宝。众生闻已开心乐施。以是因缘施主未来无量世中身得大力。众生闻法断诸放逸。以是因缘施主未来无量世中身得安乐。众生闻法断除痴心。以是因缘施主未来无量世中得无碍辩。众生闻法生信无疑。以是因缘施主未来无量世中信心明了。戒施闻慧亦复如是。是故法施胜于财施。或有说言。子修善法父作不善。因子修善令父不堕三恶道者。是义不然。何以故。身口意业各别异故。若父丧己堕饿鬼中。子为追福当知即得。若生天中都不思念人中之物。何以故。天上成就胜妙宝故。若入地狱身受苦恼不暇思念是故不得。畜生人中亦复如是。若谓饿鬼何缘独得。以其本有爱贪悭吝故堕饿鬼。既为饿鬼常悔本过。思念欲得是故得之。若所为者生余道中。其余眷属堕饿鬼者。皆悉得之。是故智者应为饿鬼勤作福德。若以衣食房舍卧具资生所须。施于沙门婆罗门等贫穷乞士。为其咒愿令其得福。以是施愿因缘力故。堕饿鬼者得大势力随施随得。何以故。生处尔故。诸饿鬼等所食不同或有食脓。或有食粪。或食血污呕吐涕唾。得是施已一切变成上妙色味。虽以不净荡涤汁等施应食者然有遮护竟不得食。如是施主亦得福德。何以故以施主心慈怜愍故。若有祀祠谁是受者。随其祠处而为受者。若近树林则树神受舍河泉井山林堆阜亦复如是。是人祀已亦得福德何以故。令彼受者生喜心故。是祀福德能护身财。若说杀生祀祠得福。是义不然。何以故。不见世人种伊兰子生栴檀树。断众生命而得福德。若欲祀者。应用香花乳酪酥药。为亡追福则有三时。春时二月夏时五月秋时九月。若人以房舍卧具汤药园林池井。牛羊象马种种资生。布施于他施已命终。是人福德随所施物。任用久近福德常生。是福追人如影随形。或有说言终已便失。是义不然。何以故。物坏不用二时中失非命尽失。若出家人效在家人岁节之日弃饮食者。随世法故非真实也。亦信世法出世法故。若能随家所有好恶。常乐施者名一切施。若以身分及以妻子所重之物。施于人者。是则名为不思议施。若有恶人。毁戒。怨家。不知恩义。不信因果强乞索者大势力人。健骂詈者得已嗔恚。诈现好相。大富贵者。施如是等十一种人名不思议。善男子。一切布施有三根本。施于贫穷以怜愍故。施于怨家不求报故。施福德人心喜敬故。善男子。若人多财无量岁中供养三宝。虽得无量福德果报。不如劝人共和合作。若人轻于少物恶物羞不肯施。是人增长来世贫苦。若人共施财物。福田施心俱等。是二得果无有差别。有财心俱等福田胜者。得果报胜。有田心俱下财物胜者。得果则胜。有田财俱下施心胜者。得果亦胜。有田财俱胜施心下者。得果不如。善男子智者施时不为果报何以故。定知此因必得果故。若人无慈不知恩义不贪圣人所有功德。惜财身命贪着心重。如是之人不能布施。智者深观一切众生求财物时不惜身命。既得财物能舍施人当知是人能舍身命若人悭吝不能舍财。当知是人亦惜身命。若舍身命求得财物以布施者。当知是人是大施主。若人得财贪惜不施。当知即是未来世中贫穷种子。是故我于契经中说。四天下中阎浮提人有三事胜。一者勇健。二者念心。三者行净。不见果报能预作因。不惜身命求得财已。能坏悭吝舍已思施。既舍施已心不生悔。复能分别福田非福田。是名勇健。善男子。施已生悔因于三事。一者于财贪爱。二者咨承邪见。三者见受者过。复有三事。一者畏他呵责。二者畏财尽受苦。三者见他施已受诸衰恼。善男子。智人三时不生悔心。复有三事。一者明信因果。二者亲近善友。三者不贪着财。信因果者复有二事。一者从他闻法。二者内自思惟。亲近善友复有二事。一者深信。二者智慧。不贪着财复有二事。一观无常。二不自在。善男子。施主若能如是观察如是行施。当知是人能具足行檀波罗蜜。是故我先说。有布施非波罗蜜。有波罗蜜非是布施。有亦布施亦波罗蜜有非布施非波罗蜜。善男子。智有三种。一者能舍外物。二者舍内外物。三者施内外已兼化众生。云何教化。见贫穷者先当语言。汝能归依于三宝不。受斋戒不。若言能者。先授三归及以斋戒。后则施物。若言不能。复应语言。若不能者。汝能随我说一切法。无常无我涅槃寂灭不。若言能者。复当教之。教已便施。若言我今能说二事。唯不能说诸法无我。复应语言。汝若不能说诸法无我。能说诸法是无性不。若言能者。教已便施。若能如是先教后施。名大施主。善男子。若能如是教化众生及诸怨亲无所选择。名大施主。善男子。智者若有财宝物时。应当如是修行布施。如其无财。复当转教余有财者令作是施若余施主先知此法不须教者。应以身力往佐助之。若穷无物应诵医方种种咒术。求钱汤药须者施之。至心瞻病将养疗治。劝有财者和合诸药。若丸若散若种种汤。既了医方遍行看病。案方诊视知病所在。随其病处而为疗治。疗治病时善知方便。虽处不净不生厌心。病增知增损时知损。复能善知如是食药能增病苦。知如是食药能除病苦。病者若求增病食药。应当方便随宜喻语不得言无。若言无者或增苦剧。若知定死亦不言死。但当教令归依三宝。念佛法僧勤修供养。为说病苦皆是往世不善因缘。获是苦报今当忏悔。病者闻已或生嗔恚恶口骂詈。默不报之亦不舍弃。虽复瞻养慎无责恩。差已犹看恐后劳复。若见平复如本健时。心应生喜不求恩报。如其死已当为殡葬。说法慰喻知识眷属无以增病。食药施人。若病差已。喜心施物便可受之。受已转施余穷乏者。若能如是瞻养治病。当知是人是大施主。真求无上菩提之道。善男子。有智之人求菩提时。设多财宝亦当读诵如是医方。作瞻病舍具病所须。饮食汤药以供给之。道路凹迮平治令宽。除去刺石粪秽不净。崄处所须若板若梯。若缘若索悉皆施之。旷路作井种果树林修治泉潢。无树木处为畜竖柱。负担息处为作基埵。造立客舍具诸所须。瓶盆烛灯床卧敷具。臭秽流处为作桥蹬。津济渡头施桥船筏。不能渡者自往渡之。老小羸瘦无筋力者。自手携将而令得过。路次作塔种花果树。见怖畏者辄为救藏。以物善语诱喻捕者。若见行者次至崄处。辄前扶接令得过崄。若见失土破亡之人。随宜给与善言慰喻。远行疲极当为洗浴。按摩手足施以床座。若无床座以草为敷。热时以扇衣裳作荫。寒时施火衣服温暖。若自为之若教人为。贩卖市易教令依平。无贪小利共相中欺。见行路者示道非道道者所谓多饶水草无有贼盗。宣说非道多诸患难。见人靴量衣裳钵盂朽故坏者。即为缝补浣染熏治。有患鼠蛇壁虱毒虫能为除遣。施人如意摘抓耳钩。缝治浣濯招提僧物。谓坐卧具厕上安置净水澡豆净灰土等。若自造作衣服钵器。先奉上佛并令父母师长和上先一受用。然后自服。若上佛者以花香赎。凡所食啖要先施于沙门梵志。然后自食。见远至者濡言问讯。施以净水洗浴身体与油涂足。香花杨枝澡豆灰土。香油香水蜜毗钵罗舍勒小衣。作涂油者洗已复以种种香花丸药散药。饮食浆水随所须施。复施剃刀漉水囊等。针缕衣纳纸笔墨等。若不能常随斋日施。若见盲者自前捉手施杖示道。若见有苦亡失财物父母丧没。当以财给善语说法慰喻劝谏。善说烦恼福德二果。善男子。若能修集如是施者。名净施主。善男子。菩萨二种。一者在家二者出家。出家菩萨为净施主是不为难。在家菩萨为净施主是乃为难。何以故。在家之人多恶因缘所缠绕故

    优婆塞戒经净三归品第二十

善生言。世尊。如佛先说有来乞者。当先教令受三归依然后施者。何因缘故受三归依。云何名为三归依也。善男子。为破诸苦断除烦恼受于无上寂灭之乐。以是因缘受三归依。如汝所问云何三归依者。善男子。谓佛法僧。佛者。能说坏烦恼因得正解脱法者。即是坏烦恼因真实解脱。僧者。禀受破烦恼因得正解脱。或有说言。若如是者即是一归。是义不然。何以故如来出世及不出世。正法常有无分别者。如来出已则有分别。是故应当别归依佛。如来出世及不出世。正法常有无有受者佛弟子众能禀受故。是故应当别归依僧。正道解脱是名为法。无师独觉是名为佛。能如法受是名为僧。若无三归云何说有四不坏信。得三归者。或有具足或不具足。云何具足。所谓归佛法僧。不具足者。所谓如来归依于法。善男子。得三归者无不具足。如比丘比丘尼优婆塞优婆夷戒。善男子。如佛缘觉声闻各异。是故三宝不得不异。云何为异。发心时异。庄严时异。得道时异。性分各异。是故为异。何因缘故说佛即法。能解是法故名为佛。受分别说故名为僧。若有说言佛入僧数。是义不然。何以故。佛若入僧则无三宝及三归依四不坏信。善男子。菩萨法异佛法亦异菩萨二种。一者后身。二者修道。归依后身名归依法。归依修道名归依僧。观有为法多诸罪过。独处修行得甘露味。故名为佛。一切无漏无为法界。故名为法。受持禁戒读诵解说十二部经。故名为僧。若有问言。如来灭已归依佛者。是何归依。善男子。如是归依名为归依。过去诸佛无学之法。如我先教提谓长者。汝当归依未来世僧。依过去佛亦复如是。福田果报有多少故差别为三。若佛在世及涅槃后。供养果报无有差别。受归依者亦复如是。如佛在世为诸弟子立诸要制。佛虽过去有犯之者亦获罪报。归过去佛亦复如是。犹如如来临涅槃时。一切人天为涅槃故多设供养。尔时如来未入涅槃犹故在世。悬受未来世供养事。归过去佛亦复如是。譬如有人父母在远。是人或时嗔骂得罪。或时恭敬赞叹得福。归过去佛亦复如是。是故我说。我若在世及涅槃后所设供养。施者受福等无差别。善男子。若男若女若能三说三归依者。名优婆塞名优婆夷。一切诸佛虽归依法。法由佛说故得显现。是故先应归依于佛。净身口意至心念佛。念已即离怖畏苦恼。是故应当先归依佛。智者深观如来智慧解脱最胜。能说解脱及解脱因。能说无上寂静之处。能竭生死苦恼大海。威仪庠序三业寂静。是故应当先归依佛。智者深观生死之法是大苦聚。无上正道能永断之。生死之法渴爱饥馑。无上甘露味能充足。生死之法怖畏崄难。无上正法能除断之。生死错谬邪僻不正。无常见常无我见我。无乐见乐不净见净。无上正法悉能断除。以是因缘应归依法。智者应观外道徒众。无惭无愧非如法住。虽为道行不知正路。虽求解脱不得正要。虽得世俗微善之法。悭吝护惜不能转说。非善行性作善行想。佛僧寂静心多怜愍。少欲知足如法而住。修于正道得正解脱。得已复能转为人说。是故应当次归依僧。若能礼拜如是三宝。来迎去送尊重赞叹。如法而住信之不疑。是则名为供养三宝。若有人能归三宝已。虽不受戒断一切恶修一切善。虽复在家如法而住。是亦得名为优婆塞。若有说言。先不归依佛法僧宝。当知是人不得戒者。是义不然。何以故。如我先说善来比丘。是竟未得归依三宝。而其戒律悉得具足。或有说言。若不具受则不得戒。八戒斋法亦复如是。是义不然。何以故。若不具受不得戒者。求有优婆塞云何得戒。实是得戒。但不具足八戒斋法。若不具受虽不名斋。可得名善。善男子。若能净洁身口意业受优婆塞戒。是名五阴。云何五阴。不受邪见不说邪见。信受正见说于正见修行正法。是名五阴。受三归已造作痴业。受外道法自在天语。以是因缘失于三归。若人质直心无悭贪。常修惭愧少欲知足。是人不久得寂静身。若有造作种种杂业。为受乐故修于善事如市易法。其心不能怜愍众生。如是之人不得三归。若人为护舍宅身命祠祀诸神。是人不名失归依法。若人至心信其能救一切怖畏。礼拜外道。是人则失三归依法。若闻诸天有曾见佛功德胜已。礼拜供养是人不失归依之法。或时礼拜自在天王。应如礼拜世间诸王长者贵人耆旧有德。如是之人亦复不失归依之法。虽复礼拜所说邪法慎无受之。供养天时当起慈心。为护身命财物国土人民恐怖。所说邪见何故不受。智者应观外道所说。云一切物悉是自在天之所作。若是自在之所作者。我今何故修是善业。或说投渊赴火自饿舍命即得离苦。此即苦因。云何说言得远离苦。一切众生作善恶业。以是业缘自受果报。复有说言一切万物时节星宿自在天作。如是邪说我云何受现在造业。亦受过去所作业果。智者了了知是业果。云何说言时节星宿自在作耶。若以时节星宿因缘受苦乐者。天下多有同时同宿。云何复有一人受苦一人受乐。一人是男一人是女。天阿修罗有同时生同宿生者。或有天胜阿修罗负。阿修罗胜诸天不如。复有诸王同时同宿俱共治政。一人失国一则保土。诸外道等亦复说言。若有恶年恶宿现时。当教众生令修善法以攘却之。若是年宿何得修善而得除灭。以是因缘智者云何受于外道邪错之说。善男子。一切众生随于业行。若修正见受于安乐。修邪见者受大苦恼。因修善业得大自在。得自在已众生亲近。复为宣说善业因缘。善业因缘故得自在。一切众生皆由修善业因缘故。得受安乐。非年宿也。善男子。阿阇世王提婆达多。皆由造恶业因缘故。堕于地狱。非因年宿得是报也。郁头蓝弗邪见因缘。未来当堕大地狱中。善男子。一切善法欲为根本。是欲因缘得三菩提及解脱果。入出家法破大恶业及诸有业。能受持戒亲近诸佛。能一切舍施于乞者。能作定性坏恶果报。灭大恶罪得决定聚。离于三障善能修集坏烦恼道。是欲因缘能受三归。因三归已即能受戒。既受戒已行见修道过于声闻。若有畏于师子虎狼恶兽等类。归依于佛尚得解脱。况发善心求出世者不得解脱。阿那邠坻教告家内。在胎之子悉受归依。是胎中子实不成就。何以故。是法要当口自宣说。虽不成就亦能护之。善男子。诸外道说。一切世间皆是自在天之所作。亦复说言。未来之世过百劫已当有幻出。所言幻者即是佛也。若自在天能作佛者。是佛云何能破归依自在天仪。若自在天不能作佛。云何说言。一切皆是自在天作。外道复说。大梵天王大自在天毗纽天主。悉皆是一。复说生处各各别异。自在天者名自在天。名常名主名有。名曰律陀名曰尸婆。是一一名各有异事。亦求解脱亦即解脱。是义不然。何以故。若自在天能生众生造作诸有。作善恶业及业果报。作贪嗔痴系缚众生。复言众生得解脱时悉入身中。是故解脱是无常法。是义不然。何以故。若无常者云何得名为解脱也。如婆罗门子还得寿命。是故不得名自在天。是三种天亦不得一。何以故。阿周那人毗纽大天为作解脱。以是义故。亦不得一。若言解脱是无常者。当知即幻非佛名幻。若能了了正见真我。是名解脱。复有说言。见微尘者是名解脱。复有说言。见性异我异是名解脱。是义不然。何以故。若能修道见四真谛。是人乃得见性见我。若人能受三归依者。是人乃能真见四谛。是三归依乃是一切无量善法。乃至阿耨多罗三藐三菩提之根本也。菩萨二种。一者在家。二者出家。出家菩萨净三归依是不为难。在家修净是乃为难。何以故。在家之人多恶因缘所缠绕故

    优婆塞戒经八戒斋品第二十一

善生言。世尊。若有人能受三归斋戒。是人当得何等果报。善男子。若人能受三归依者。当知是人所得福报不可穷尽。善男子。迦陵伽国有七宝藏名宾伽罗。其国人民大小男女。于七日中七月七年。常以车乘象马驼驴。担负持去犹不能尽。若有至心受三归斋。是人所得功德果报。出胜彼藏所有宝物。善男子。毗提呵国有七宝藏名半陆迦。其国人民男女大小于七日中七月七年。常以车乘象马驼驴。担负持去犹不能尽。若有至心受三归斋。是人所得功德果报。出胜彼藏所有宝物。善男子。波罗奈国有七宝藏名曰蠰佉。其国人民男女大小于七日中七月七年。常以车乘象马驼驴。担负持去亦不能尽。若有至心受三归斋。是人所得功德果报。出胜彼藏所有宝物。善男子。乾陀罗国有七宝藏名伊罗钵多。其国人民男女大小于七日中七月七年。常以车乘象马驼驴。担负持去亦不能尽。若有至心受三归斋。是人所得功德果报。胜出彼藏所有宝物。善男子。若有从他三受三归三受八戒。是名得具一日一夜优婆塞斋。明相出时是时则失。是故不得佛像边受。要当从人根本清净。受已清净庄严清净。觉观清净念心清净求报清净。是名三归清净斋法。善男子。若能如是清净归依受八戒者。除五逆罪。余一切罪悉皆消灭。如是戒者不得一时二人并受。何以故。若一时中二人共受。何因缘故。一人毁犯一人坚持。是戒力故后世生时不能造恶。受已作罪复不永失。若先遣信欲刑戮人。信迟未至。其人寻后发心受斋。当受斋时信至即杀虽复一时。以戒力故不得杀罪。若诸贵人常敕作恶。若欲受斋先当敕语。遮先诸恶乃得成就。若先不遮辄便受斋者。不名得斋。欲受斋者。先当宣令所属国境。我欲受斋。凡是斋日悉断诸恶罚戮之事。若能如是清净受持八戒斋者。是人则得无量果报至无上乐。弥勒出时百年受斋。不如我世一日一夜。何以故。我时众生具五滓故。是故我为鹿子母说善女若娑罗树能受八斋。是亦得受人天之乐至无上乐。善男子。是八戒斋。即是庄严无上菩提之璎珞也。如是斋者。既是易作而能获得无量功德。若有易作而不作者。是名放逸。善男子。菩萨二种。一者在家。二者出家。出家菩萨能教众生净八戒斋是不为难。在家菩萨教他清净是乃为难。何以故。在家之人多恶因缘所缠绕故

优婆塞戒经卷第五优婆塞戒经卷第六

        北凉中印度三藏昙无谶译

    五戒品第二十二

善生言。世尊。何等之人得三归依。何等之人不得三归。善男子。若人信因信果信谛信有得道。如是之人则得三归。若人至心信不可败。亲近三宝受善友教。如是之人则得三归。优婆塞戒亦复如是。若能观是优婆塞戒。多有无量功德果报。能坏无量弊恶之法。众生无边受苦亦尔。难得人身虽得人身难具诸根。虽具诸根难得信心。虽得信心难遇善友。虽遇善友难得自在。虽得自在诸法无常。我今若造恶业。因是恶业获得二世身心恶报。以是因缘身口意恶即是我怨。设三业恶不得恶报。现在之恶亦不应作。是三恶业现在能生弊恶色等死时生悔。以是因缘我受三归及八斋法。远离一切恶不善业。智者当观戒有二种。一者世戒。二第一义戒。若不依于三宝受戒。是名世戒。是戒不坚如彩色无胶。是故我先归依三宝然后受戒。若终身受若一日一夜。所谓优婆塞戒八戒斋法。夫世戒者不能破坏先诸恶业。受三归戒则能坏之。虽作大罪亦不失戒。何以故。戒力势故。俱有二人同共作罪。一者受戒。二不受戒。已受戒者犯则罪重。不受戒者犯则罪轻。何以故。毁佛语故。罪有二种。一者性重。二者遮重。是二种罪复有轻重。或有人能重罪作轻。轻罪作重。如鸯掘魔受于世戒。伊罗钵龙受于义戒。鸯掘魔罗破于性重不得重罪。伊罗钵龙坏于遮制而得重罪。是故有人重罪作轻轻罪作重。是故不应以戒同故得果亦同。世戒亦有不杀不盗。义戒亦有不杀不盗。至不饮酒亦复如是。如是世戒。根本不净受已不净。庄严不净觉观不净。念心不净果报不净。故不得名第一义戒。唯名世戒。是故我当受于义戒。善男子。后世众生身长八丈。寿命满足八万四千岁是时受戒。复有于今恶世受戒。是二所得果报正等。何以故。三善根平等故。或有说言可断命处乃得戒者。是义不然。何以故。夫禁戒者。悉于一切可杀不可杀中。得一切可杀不可杀者。无量无边。戒之果报亦复如是无量无边。善男子。一切施中施无怖畏最为第一。是故我说五大施者即是五戒。如是五戒能令众生离五怖畏。是五种施易可修行。自在无碍不失财物。然得无量无边福德。离是五施不能获得须陀洹果。乃至得阿耨多罗三藐三菩提。善男子。若受戒已当知是人为诸天人恭敬守护。得大名称。虽遭恶对心无愁恼。众生亲附乐来依止。阿那邠坻长者之子。虽为八千金钱受戒。亦得无量功德果报。善男子。为财受戒尚得利益。况有至心为于解脱而当不得。善男子。有五善法围绕是戒常得增长。如恒河水。何等为五。一者慈。二者悲。三者喜。四者忍。五者信。若人能破殷重邪见。心无疑网则具正念。庄严清净根本清净离恶觉观。善男子。若人能远五恶事者。是名受戒。远离一切身口意恶。若有说言离五戒已度生死者。无有是处。善男子。若人欲度生死大海。应当至心受持五戒。是五戒中四。于后世成无作戒。唯爱难断故不得成。以是因缘淫欲缠绵。应当至心慎无放逸。若有说言。更有无量极重之法。过去诸佛何缘不制而制于酒。善男子。因于饮酒惭愧心坏。于三恶道不生怖畏。以是因缘。则不能受其余四戒。是故过去诸佛如来制不听饮。若有说言如来已说酒多过失。何故不在五戒初说。是义不然。何以故。如是酒戒名为遮重。不为性重。如来先制性重之戒。后制遮重。善男子。如来先说。白黑月中各有三斋。随外道故。诸外道辈常以此日供养诸天。是故如来说有三斋。善男子。如因帐窗帐勒故不堕。三斋之法亦复如是。众生若有发心受持。终不堕于三恶道中。善男子。有人若欲施时。供养三宝时。若坐禅时。若修善时。若读经时。供养父母时。当先立制。我若不作要自克罚。是人福德日夜增长。如恒河流如是五戒有五种果。一者无作果。二者报果。三者余果。四者作果。五者解脱果。若有具足受持五戒。当知是人得是五果。若优婆塞常能出至寺庙僧坊。到已亲近诸比丘等。既亲近已咨问法味。既问法已当至心听。听已受持忆念不忘能分别义。分别义已转化众生。是名优婆塞自利利他。若优婆塞不能习学。如是所说。轻慢比丘为求过失。而往听法无信敬心。奉事外道见其功德。深信日月五星诸宿。是优婆塞不名坚固如法住也。若优婆塞虽不自作五恶之业。教人作者。是优婆塞非如法住也。若优婆塞先取他物许为了事。是优婆塞非如法住。若优婆塞典知官津税卖估物。是优婆塞非如法住。若优婆塞计价治病治已卖物。是优婆塞非如法住。若优婆塞违官私制非如法住。若优婆塞自不作恶不教他作心不念恶。名如法住。若优婆塞因客烦恼所起之罪。作已不生惭愧悔心。非如法住。若优婆塞为身命故作诸恶事。非如法住。若优婆塞虽得人身行于非法。不名为人。若得信心能作福德善修正念。观一切法皆是无常无我我所。于一切法心无取着。见一切法不得自在。生灭苦空无有寂静。人身难得虽得人身难具诸根。虽具诸根难得正见。虽具正见难得信心虽得信心难遇善友。虽遇善友难闻正法。虽闻正法难得受持。能如是观是名人身。若人能观欲界无常。乃至非想非非想处皆悉无常。以是因缘不求三恶乃至非想非非想处。如是观已见三不坚。以不坚身易于坚身。礼拜供养来迎去送。自手施与亲执福事。是名以不坚身易于坚身。以不坚财易于坚财。能自食用亦以布施。供给病瘦行路之人。供养沙门婆罗门等贫穷下贱。是名以不坚财易于坚财。以不坚命易于坚命。修于六念慈悲喜舍。证四真谛。善能观察生老病死。明信善恶业之果报。定知恩爱当有别离。一切众生不得自在。未得圣道生死力大。一切世乐常与苦俱。虽复受之心不染着。犹如寒月求火自暖。虽复为之终不作恶。修忍二施以润众生。深观苦乐其性平等。凡所发言言则柔软。善化众生令如法住。远离恶友心无放逸。饮酒博弈射猎之事悉不为之。是名以不坚之命易于坚命。善男子。若得人身多饶财物兼得自在。先应供养父母师长和上耆旧持法之人。供给远至初行之人疾病所须。言则柔软多有惭愧。不偏信敬有德一人。见有贤圣持戒多闻。能以舍宅饮食卧具衣服病药而供养之。深言僧中多有功德。修集向道得须陀洹果。乃至能修向阿罗汉得阿罗汉果。修金刚三昧电光三昧。观如是已平等奉施。如是施已得无量福。是故我于鹿子经中。告鹿子母曰。虽复请佛及五百阿罗汉。犹故不得名请僧福。若能僧中施一似像极恶比丘。犹得无量福德果报。何以故。如是比丘虽是恶人无戒多闻不修善法。亦能演说三种菩提有因有果。亦不诽谤佛法僧宝。执持如来无上胜幡。正见无谬。若供养僧。即是供养佛僧二宝。若观佛法功德微妙。即是具足供养三宝。若人施时不求果报。即是供养无上菩提。具足成就檀波罗蜜修菩提道。能得未来无量功德。亦能自利及利益他。能修慈悲为破他苦自舍己乐。未得菩提心无忧悔。虽闻菩提久远难得。而其内心初无退转。为诸众生无量世中。受大苦恼亦不疲厌。乐如法行不求世乐。乐处寂静出家修道。未得出家虽在家居。如解脱人不作众恶。得三种戒戒戒定戒无漏戒。善男子。菩萨二种。一者在家。二者出家。出家菩萨如法修行是不为难。在家菩萨如法修行是乃为难。何以故。在家之人多恶因缘所缠绕故

    优婆塞戒经尸波罗蜜品第二十三

善生言。世尊云何菩萨趣向菩提其心坚固。善男子。菩萨坚固具足四法。一者受大苦时。终不舍离如法之行。二者得大自在常修忍辱。三者身处贫穷常乐施与。四者盛壮之年常乐出家。若有菩萨具足四法。趣向菩提其心坚固。菩萨具足如是四法。复作是念是菩提道初根本地名之为戒。如是戒者。亦名初地亦名导地。亦名平地亦名等地亦名慈地亦名悲地。亦名佛迹。亦名一切功德根本。亦名福田。以是因缘。智者应当受持不毁。复次智者又作是念。戒有二果。一诸天乐。二菩提乐。智者应当求菩提乐不求天乐。若受戒已。所不应作而故作之。所不应思而故思惟。懈怠懒惰乐于睡眠。念恶觉观邪命恶愿。是名污戒。若受戒已。心生悔恨求人天乐。多诸放逸不生怜愍。是名污戒。若畏贫穷若为恐怖。若为失财若畏作役。若为身命若为利养。若为爱心而受禁戒。既受戒已心生疑惑。是名污戒。善男子。若人不乐久处生死深见过罪。观人天乐阿鼻狱苦平等无差。怜愍众生具足正念。为欲利益无量众生使得成道。为具无上菩提道故。为如法行故受持是戒心不放逸。能观过去未来现在身口意业。知轻知重凡所作事。先当系心修不放逸。作已作时亦复如是。修不放逸。若先不知作已得罪。若失念心亦得犯罪。若客烦恼时暂起者亦得犯罪。若小放逸亦得犯罪。是人常观犯轻如重。观已生悔及惭愧心。怖畏愁恼心不乐之。至心忏悔。既忏悔已心生欢喜。慎护受持更不敢犯。是名净戒。善男子。有智之人既受戒已。当观三事不作恶行。一者自为。二者为世。三者为法。云何自为。我自证知此是恶事。知作恶业得如是果。知作善业得如是果。所作恶业无有虚妄。决定还得诸恶之果。所作善业亦无虚妄。决定还得诸善之果若是二业无虚妄者。我今云何而自欺诳。以是因缘我受戒已。不应毁犯当至心持是名自为云何为世。有智者观见世间之人。有得清净天耳天眼及他心智。我若作恶是人必当见闻知我。若见闻知我。当云何不生惭愧而作恶耶。复观诸天具足无量福德神足天耳天眼。具他心智遥能见闻。虽近于人人不能见。若我作恶如是等天当见闻知。若是天等了了见我。我当云何不生惭愧故作罪耶。是名为世。云何为法。有智之人观如来法。清净无染得现在利。能令寂静度于彼岸。能作解脱不选时节。我为是法故受持戒。我若不能先受小制。云何能得受大制耶。破小制已增五有苦。若至心持增无上乐。我受身来所以未得证解脱者。实由不从过去无量诸佛如来受禁戒故。我今受戒未来定当值遇恒河沙等诸佛。深观是已生大怜愍至心受戒。受已坚持为阿耨多罗三藐三菩提。利益无量诸众生故。善男子。若在家若出家。若三归若八斋若五戒。若具足若不具足。若一日一夜若一时一念。若尽形寿至心受持。当知是人得大福德。善男子。若受戒已修三善业。多闻布施修定修善供养三宝。是则名为庄严菩提。若受戒已能读如来十二部经。是名无上大法之藏。勤加精进欲得具足尸波罗蜜。如是戒者。今世受已后虽不受成无作戒。善男子。有戒非波罗蜜。有波罗蜜非戒。有戒有波罗蜜。有非禁戒非波罗蜜。是戒非波罗蜜者。所谓声闻辟支佛戒。是波罗蜜非是戒者。所谓檀波罗蜜。是戒是波罗蜜者。如昔菩萨受瞿陀身时。为诸虫兽及诸蚁子之所唼食。身不倾动不生恶心。亦如仙人为众生故。十二年中青雀处顶不起不动。非戒非波罗蜜者如世俗施。善男子菩萨摩诃萨住尸波罗蜜时。所受众苦谁能说之。有人若受小小戒已。少欲知足不能怜愍诸苦众生。当知是人不能具足尸波罗蜜若能修忍三昧智慧。勤行精进乐于多闻。当知是人则能增长尸波罗蜜。庄严菩提证菩提果。如是戒者无量众生故。无量果报故。无量戒禁故。以是因缘庄严菩提。善男子。菩萨摩诃萨既受戒已。口不说恶耳不乐闻。不乐说世亦不乐闻。终不放心在恶觉观不亲恶友。是故得名寂静净戒。菩萨若见破戒恶人不生恶心。为设种种善巧方便而调伏之。若不调伏当生怜愍。不为身命破戒舍戒。食已先修惭愧之心不放逸心。为治身命如疗恶疮。若入村落如刀刺林。摄护诸根修集正念。观察可作及不可作不生放逸。若人作福亦因于我。若人作罪亦因于我。是故我得大供养时不应生喜。得衰苦时不应生嗔得少供养应作是念。我今信戒施闻智慧如法住少故。得如是微少供养。是故今我不应生于愁苦之念。我为二事受他信施。一者为增他福。二者为增自善。是故若得少物恶物。不应生恼。久住迟得轻骂已得。尔时复当自责其身。是我宿罪非众生过。是故我今不应生恼。若受戒已为他作罪。亦应说言。如是所作实非是道。何以故。十二部经不说诸恶为菩提道也。是故我今获得杂报。若能如是深观察者。当知是人则能具足尸波罗蜜。善男子。若有人能摄护诸根。身四威仪不作诸恶。能堪众苦不作邪命。当知是人则能具足尸波罗蜜。若于轻重戒中等生怖畏。虽遭恶时不犯小戒。不令烦恼秽污其心。修集忍辱。当知是人则能具足尸波罗蜜。若离恶友令诸众生远恶邪见。知恩报恩。当知是人则能具足尸波罗蜜。若为善事不惜身命。罢散自事营成他事。见骂詈者不生恶心。当知是人则能具足尸波罗蜜。若见如来所开之处如本持之。护众生命不惜财命。乃至命终不犯小戒。虽得微妙七珍之物。心不生贪不为报恩。以善加人为怜愍故。受持禁戒。既受持已善发大愿。愿诸众生悉得净戒。当知是人则能具足尸波罗蜜。善男子。菩萨二种。一者在家。二者出家。出家菩萨具尸波罗蜜是不为难。在家具足是乃为难。何以故。在家之人多恶因缘所缠绕故

    优婆塞戒经业品第二十四之一

善生言。世尊。诸佛如来未出世时。菩萨摩诃萨以何为戒。善男子。佛未出世是时无有三归依戒。唯有智人求菩提道修十善法。是十善法。除佛无能分别说者。过去佛说流转至今。无有漏失智者受行。善男子。众生不能受持修集十善法者。皆由过去不能亲近咨承佛故。善男子。一切众生皆有杂心。杂心因缘有杂烦恼。杂烦恼故造作杂业。杂业因缘受于杂有。杂有因缘受于杂身。善男子。一切众生得杂身已见于杂色。见杂色已生恶思惟。是恶思惟名为无明。无明因缘生于求心。名之为爱。因爱所作名之为业。是业因缘获得果报。有智之人能破析之由内烦恼。外有因缘则能系缚。修十善已则能解之。是故如来初得阿耨多罗三藐三菩提时。分别演说十善之法。因十善故世间则有善行恶行善有恶有乃至解脱。是故众生应当至心分别体解十善之道。若有风云为持大水阿修罗宫大地大山饿鬼畜生地狱四天王处。乃至他化自在天处。悉因众生十业道故。转轮圣王所有四轮金银铜铁。七众受戒求三菩提。亦因十善业因缘故。是十善业道因缘故。一切众生内外之物色之与命。皆有增减。是故智者应当具足修十善道。若诸众生少壮老时。春秋冬夏所起烦恼各各别异。小中大劫所起烦恼亦复如是各各别异。众生初修十善业时。得无量命色香味具。因贪嗔痴一切皆失。是十恶业道因缘故。时节年岁星辰日月四大变异。若人能观如是事者。当知是人能得解脱。众生皆由苦因缘故则生信心。既得信心能观善恶。如是观已修十善法意行。十处故名十道

身三道者。谓杀盗淫。口四道者。恶口妄语两舌无义语。心三道者妒嗔邪见。是十恶业。悉是一切众罪根本。若诸众生异界异有异生异色异命异名以是因缘应名无量不但有十如是十事三名为业不名为道身口七事亦业亦道。是故名十。是十业道自作他作自他共作从是而得善恶二果。亦是众生善恶因缘。是故智者尚不应念。况身故作。若人令业烦恼诸结得自在者。当知即是行十恶道。若有能坏烦恼诸结不令自在。是人即是行十善道。若人始设方便。若先不思惟当时卒作是人不得业所摄罪。是故智者应当勤修十善业道证四真谛亦复如是。作期为恶若失期者亦不得罪。是故智者应修十善。因是十善众生修已。增长寿命及内外物。烦恼因缘故十恶业增。无烦恼因缘故十善业增。善男子。是十业道。一一事中各有三事。一者根本。二者方便。三者成已。根本者。若有他想有众生想。若以疑心断其命根。若动身作相或口说杀。是名根本。求刀磨利置毒作索。是名方便。杀已手触称量提持。若自食啖若与人食。得物用度任意施与。欢喜受乐无有惭愧。心不悔恨。自赞其身生大憍慢。是名成已。是他财有亦作他想。若自往取若遣人取。若以疑心移置异处。是名根本。若坏垣墙咨问计数。置梯缘墙入舍求觅。乃至手触是名方便。若得物已负担藏隐。任意施与卖用赐遗。欢喜受乐无有惭愧。心不悔恨。自赞其身生大憍慢。是名成已。若是妇女系属他人起于他想。若以疑心作非梵行。是名根本。若遣使往若自眼见。若与信物。若以手触。若濡细语。是名方便。若事已竟遗以璎珞。共坐饮食欢喜受乐。无有惭愧。心不悔恨。自赞其身生大憍慢。是名成已。若于大众舍离本相。若于三时若二时中虚妄说之。是名根本。若于先时次第庄严构言语端。或受他语起往彼说。是名方便。若事成已受取财物。任意施与欢喜受乐。无有惭愧不生悔恨。自赞其身生于憍慢。是名成已。是妄语中杂有两舌能坏和合。是名根本。若说他过及余恶事。言和合者必有不可。若离坏者则有好事。是名方便。和合既离受他财物。任意施与欢喜受乐。无有惭愧不生悔恨。自赞其身生大憍慢。是名成已。若变容色恶口骂詈。是名根本。若闻他罪庄严辞章。起去到彼欲说是恶。是名方便。若骂詈已还受他物。任意施与欢喜受乐。无有惭愧不生悔恨。自赞其身生大憍慢。是名成已。若说欲事非时之言。是名根本。若歌若颂无义章句。随人所喜造作百端。是名方便。若教他已还受财物。任意施与欢喜受乐。无有惭愧不生悔恨。自赞其身生大憍慢。是名成已。于他财物生贪欲得。是名根本。发烦恼心是名方便。作已得财任意施与。欢喜受乐复向余说。无有惭愧不生悔恨。自赞其身生大憍慢。是名成已。若打骂人是名根本。若捉杖石问其过罪。是名方便。打已生喜受取财物。任意施与欢喜受乐。无有惭愧不生悔恨。自赞其身生大憍慢。是名成已。若诽谤业因果真谛贤圣之人。是名根本。若读诵书写信受邪书赞叹称誉。是名方便。受已向他分别演说。增其邪见受邪财物。任意施与欢喜受乐。无有惭愧不生悔恨。自赞其身生大憍慢。是名成已。或复有人于十业道。一时作二。妄语两舌。或一时三。所谓妄语两舌恶口。又复有三。所谓邪见恶口妄语。如是说者即是无义。是名为四。嗔之与贪不得一时。其余八事可得一时。云何一时。六处遣使。自作二事。一者淫他妻妇。二者谓无业果。先作期要一时得业。是十恶业。或得作色无无作色。或有作色及无作色。若无方便及成已者。则得作色无无作色。若有庄严及成已者。则得作色及无作色。是十业道有轻有重。若杀父母及辟支佛。偷三宝物。于所生母及罗汉尼作非梵行。妄说坏僧是名为重。善男子。是十业道各有三种。一从贪生。二从嗔生。三从痴生。若为贪利故害命者。是名从贪。若杀怨家是名从嗔。杀老父母是名从痴。劫盗他财亦复三种。自为己身妻子眷属。贪他财物而往劫夺。是名从贪。盗怨家物是名从嗔。劫夺下姓是名从痴。邪淫亦三。若为自乐行非梵行。是名从贪。淫怨眷属是名从嗔。于所生母作非梵行。是名从痴。妄语三种。若为财利自受快乐。是名从贪。为坏怨故是名从嗔。若畏他死是名从痴。两舌三种。为财利故是名从贪。为坏怨故是名从嗔。破坏和合邪见之众。是名从痴。恶口三种。为财利故骂詈妇儿。是名从贪。故向怨家说所恶事。是名从嗔。说他往昔先人过罪。是名从痴。无义语亦三种。若为欢乐歌叫諠哗。是名从贪。为胜他故歌叫諠哗。是名从嗔。为增邪见歌叫諠哗。是名从痴。从贪生者是名为妒。从嗔生者是名为嗔。从痴生者是名邪见。修十善已。一一事中得三解脱。是十恶业决定当得地狱果报。或有饿鬼或有畜生。余果则得人中短命。贫穷乏财。妇不贞廉。有所言说人不信受。无有亲厚常被诽谤。耳初不闻善好之言。能令外物四大衰微无有真实。恶风暴雨烂臭败坏。土地不平无有七宝。多有石沙荆棘恶刺。时节转变无有常定。果蓏少实味不具足。若欲破坏如是等事。应当至心修行十善。是十善法三天下具或有戒摄。或非戒摄。北郁单曰唯有四事。地狱有五。饿鬼畜生天中具十。非戒所摄欲界六天无有方便。唯有根本成已二事。夫业道者一念中得。如其杀者可杀俱死。是则不得根本业果。若作庄严事竟不成。唯得方便不得根本。作庄严已便得杀者。得根本罪。如其杀已不追成已无无作罪。若杀者一念中死。可杀之者次后念死。杀者不得根本业罪。若遣使杀使得作罪。口敕之者得无作罪。若恶口敕亦得作罪及无作罪。若其杀已心善无记。亦得作罪及无作罪。若有说言。过去已灭未来未生现在无住。云何名杀。一念不杀微尘不坏。若一不杀多亦不能。云何言杀。是义不然。何以故。虽复现在一念不杀。能遮未来使不起故。故得名杀。以是义故。不可以见一处无杀举一切处悉便无杀。有人刺手则便命终。或有截足而命全者。头则不尔刺截俱死。若有作已得大罪者。是名业道。三业自得七业自他。若无作者亦无无作。或有说言。身业三事有作无作。口不如是。是义不然。何以故。若口有作无无作者。口敕杀已不应得罪。是故口业亦应有作及以无作。心则不尔。何以故。贤圣之人不得罪故。何因缘故。名作无作。是业堕于三恶道故。生于人中寿命短故。所有六入常受苦故。余果相似。根本正果或有相似或不相似。受果报时在活地狱黑绳地狱。饿鬼畜生人中三处受于余果。若于一人作杀庄严。作庄严已有二人死。当知唯于本所为人得作无作。若有说言。色是无记命亦无记。如是无记。云何杀已而得杀罪。是义不然。何以故。如是身命是善恶心器。若坏是器遮于未来善恶心故。是故得罪。若王敕杀。侍臣称善。是王与臣罪无差别。猎亦如是。若有垂终其命余残有一念在。若下刀杀是得杀罪。若命已尽而下刀者。不得杀罪。若先作意规欲挝打。然下手时彼便命终不得杀罪。若作毒药与怀妊者。若破歌罗罗。是人则得作无作罪。若自刑者不得杀罪。何以故。不起他想故。无嗔恚心故。非他自因缘故。或有说言。若心在善不善无记。悉得杀罪。犹如火毒。虽复善心不善无记。触食之者悉皆死者。是义不然。何以故。世间有人捉火不烧食毒不死。非恶心杀亦复如是。不得杀罪。如诸医等或有说言。婆薮仙人说咒杀人杀羊祀天不得杀罪。是义不然。何以故。断他命故。痴因缘故。若见人死心生欢喜。当知是人得成已罪。见他杀已心生欢喜出财赏之。亦复如是。若使他杀。受使之人到已。更以种种苦毒而杀戮之。口敕之者唯得作罪。受使之人兼得二罪。作以无作。若发恶心夺取他物。是人亦得作无作罪。若数时取。若寄时取。因市易取。亦得偷罪。若自不取不贪不用。教他令取。是人亦得作无作罪。若欲偷金取时得银。出外识已还置本处。是人不得偷盗之罪。若欲偷金。得已即念无常之想心生悔恨。欲还本主而复畏之。设余方便还所偷物。虽离本处不得偷罪。奴仆财产先悉生意与主同共。后生贪想辄取主物。取已生疑而便藏避。复思是物同共无异。虽离本处不得偷罪若人行路为贼所剥。既至村落村主问言。汝失何物我当偿之。若说过所失取他物者。是得偷罪。若有发心施他二衣。受者取一云不须二。辄还留者是得偷罪。若人发心欲以房舍卧具医药资生所须施一比丘。未与之间更闻他方有大德来。辄回施之是得偷罪。若取命过比丘财物。谁边得罪。若羯磨已从羯磨僧得。若未羯磨从十方僧得。若临终时随所与处因之得罪。若偷佛物从守塔人主边得罪。若暴水漂财物谷米果蓏衣服资生之物。取不得罪。若于非时非处非女处女他妇。若属自身是名邪淫。唯三天下有邪淫罪。郁单曰无。若畜生若破坏。若属僧若系狱。若亡逃若师妇。若出家人近如是人。名为邪淫。出家之人无所系属。从谁得罪。从其亲属王所得罪。恶时乱时虐王出时。怖畏之时。若令妇妾出家剃发。还近之者是得淫罪。若到三道是得淫罪。若自若他。在于道边塔边祠边大会之处。作非梵行得邪淫罪。若为父母兄弟国王之所守护。或先与他期。或先许他。或先受财。或先受请。木埿画像及以死尸。如是人边作非梵行。得邪淫罪。若属自身而作他想。属他之人而作自想。亦名邪淫。如是邪淫亦有轻重。从重烦恼则得重罪。从轻烦恼则得轻罪。若有疑心若无疑心。若见若闻若觉若知。若问不问异本说者。是名妄语。若言不本见闻觉知。亦是妄语不名具足。若破相说无覆藏相。是非妄语。若异音说前人不解。亦是妄语不名具足。若颠倒语若发大声不了了语。若有所说前人不解。亦是妄语不名具足。两舌恶口。若坏前人不坏前人。作已得罪。无义语亦复如是。如是七事亦道亦业。其余三事是业非道。何以故。自不行故。妨于自他得大罪故。或有说言。一切微尘次第而住。亦念念灭。灭已无住。若无住者。尚无有作。况有无作。是义不然。何以故。世间之法有因有果无因无果。如面水镜则有像现离面无像。作亦如是从身有作。从是作法则出无作。如面水镜则有像现。譬如有人发恶心故则恶色现。发善心故则善色现。作以无作亦复如是。若因善业得善妙色。若因恶业得粗恶色。作以无作亦复如是。若以念念常灭无有作无作者。如先所说灯河等喻。虽念念灭。以二谛故说作无作。微尘虽复次第不住。亦复不破世谛法也。正以微尘次第得名。父母罗汉。其有杀者得无量罪。父母罗汉及以他人。阴界入等等无差别。所以得重。以是福田报恩田故。如说二字不得一时。然此二字终不和合义不可说。虽念念灭亦名妄语不破世谛。犹如射箭。虽念念灭因于身业微尘力故到不到处。作以无作亦复如是。如舞独乐。虽念念灭因于身业微尘力故。而能动转。作以无作亦复如是。如旋火轮。虽念念灭。因于身业微尘力故。火得圆匝初发心异方便心异。作时心异说时心异。众缘和合故得名。作以作因缘生于无作。如威仪异其心亦异。不可得坏故名无作。从此作法得无作已。心虽在善不善无记。所作诸业无有漏失。故名无作。若身作善口作不善。当知是人获得杂果。若身善业有作无作。口不善业唯有有作无有无作。当知是人唯得善果不得恶果。是故经中说七种业有作无作。如人重病要须众药和合治之。若少一种则不能治。何以故。其病重故。一切众生亦复如是。具诸恶故要须众戒然后治之。若少一戒则不能治

优婆塞戒经卷第六优婆塞戒经卷第七

        北凉中印度三藏昙无谶译

    业品第二十四之余

善男子。众生作罪凡有二种。一者恶戒。二者无戒。恶戒之人。虽杀一羊及不杀时。常得杀罪。何以故。先发誓故。无戒之人。虽杀千口杀时得罪。不杀不得。何以故。不发誓故。是故一切善不善法心为根本。因根本故说。诸比丘犯有二种。一者身犯。二者口犯。无心犯也。如是戒者。时不具足支不具足。则不得戒。譬如钻火。有燧有力有干粪草。然后得火。若少一法则不得火。戒法亦尔。如是戒者。若得若舍若持若毁。皆随于心。如来了了知诸法性。是故制之。若复有人。因于善业思惟力故不造诸恶。名如法戒。若从他得名为受戒。若离戒受有功德者。一切恶兽师子虎狼应得功德。然实不得。以是因缘。受善戒者得无量福。受恶戒者得无量罪。是故经中说恶律仪。一者畜羊。二者畜鸡。三者畜猪。四者钓鱼。五者网鱼。六者杀牛。七者狱卒。八畜猎狗。九作长弶。十作猎师。十一咒龙。十二杀人。十三作贼。十四两舌。十五以苦鞭靻枷锁押额铁钉烧炙加人。国王大臣受寄抵谩不知恩者。恶性恶心大恶村主典税物者。毁戒比丘心无惭悔。如是之人皆无戒也。虽复不名不善业道。而得大罪。何以故。尽寿作故。如是等事。若不立誓不从人受。则不成就。如是恶戒四时中舍。一者得二根时。二者舍寿命时。三者受善戒时。四者断欲结时。或有说言。如善戒具足恶戒亦尔。是义不然。何以故。恶戒易得故。一因缘得故。所谓立誓。善戒不尔。有五方便。所谓五根。是故难得。以难得故要须具足。若有说言。优婆塞戒无无义语两舌恶口。是故优婆塞戒八戒斋法。沙弥比丘不具足得。是义不然。何以故。我今受持净口业故。若有说言。我受五戒净身口意心若不净。当知是人不得具戒。譬如有人受恶戒已虽不杀生。是人常有恶戒成就毁禁。比丘亦复如是。何以故。受持戒已。一一戒边多业多果故。众生无量戒亦无量。物无量故戒亦无量。是善恶戒俱有三种。谓上中下。若不受恶戒虽多作罪不名恶戒。若有难言。何缘五戒尽形寿受。八戒斋法一日一夜。当言如来善知法相。通达无碍作如是说。善男子。世间福田凡有二种。一功德田。二报恩田。坏此二田名五逆罪。是五逆罪有三因缘。一者有极恶心。二者不识福德。三者不见正果。若人异想杀阿罗汉不得逆罪。父母亦尔。若无惭愧不观报恩心无恭敬。但作方便不作根本。虽非逆罪亦得大报。善教授故。生怜爱故。能堪忍故。难作作故。受大苦故。是故父母名报恩田。若复有人杀父母已。虽复修善是善无报。是故我说。人所荫处乃至少时。慎勿毁折枝条花叶。善男子。我涅槃后有诸弟子当作是说。若以异想异名杀父母不得逆罪。即昙无德。或复说言。虽以异想杀于父母故得逆罪。即弥沙塞。或复有说。异想异名杀于父母俱得逆罪。即萨婆多。何以故。世间真实是可信故。父母真实想亦不转。恶心杀之即得逆罪。实是父母无父母想不发恶心。父母虽死不得逆罪。何以故。具足四事乃得逆罪。一者实是父母作父母想。二者恶心。三者舍心。四者作众生想。具是四事逆罪成就。若不具者则不成就。若为怜愍故。若为恭敬故。若为受法故。若为怖畏故。若为名称故。授与死具虽不手杀亦得逆罪。若为他使令杀父母。啼哭忧愁而为之者。如是罪相初中后轻。欲杀父母误中他人不得逆罪。欲杀他人误中父母亦复如是。欲杀母时误杀相似。杀已藏刀。复中母身不得逆罪。母有异见儿有异杀。但得杀罪不得逆罪。是五逆罪杀父则轻杀母则重。杀罗汉重于杀母。出佛身血重杀罗汉。破僧复重出佛身血。有物重意轻。有物轻意重。有物重意重。有物轻意轻。物重意轻。如无恶心杀于父母。物轻意重者。如以恶心杀于畜生。物重意重者。以极恶心杀所生母。物轻意轻者。如以轻心杀于畜生。如是恶业。有方便重根本成已轻。有方便根本轻成已重。有方便根本重成已轻。有根本轻方便成已重。物是一种。以心力故得轻重果。善男子。有人以食欲施于我。未与我间转施饿狗。我亦称赞如是人者。是大施主。若是福田若非福田。心不选择而施与者。是人获得无量福德。何以故心善净故。是业四种。一者现报。二者生报。三者后报。四者无报。业有四种。一者时定果报不定。二者报定时不必定。三者时定果报亦定。四者时果二俱不定。时定者。所谓现在次生后世。若时不定果报不定。是业可转若果报定应后受者。是业可转现在受之。何以故。善心智慧因缘力故。恶果定者亦可转轻。何因缘故名果报定。常作无悔故。专心作故。乐喜作故。立誓愿故。作已欢喜故。是故是业得果报定。除是之外悉名不定。众生行业有轻有重有远有近。随其因缘先后受之。如有修身修戒修心修慧。定知善恶当有果报。是人能转重业为轻。轻者不受。若遭福田遇善知识。修道修善。是人能转后世重罪。现世轻受。若人具有欲界诸业。得阿那含果能转后业现在受之。阿罗汉果亦复如是。善男子。智者若能修身修戒修心修慧。是人能坏极重之业。如阿伽陀咒及除毒宝破坏恶毒。若作小罪初方便轻后成已重。是人不修身戒心慧令轻作重。众生若作一种二种乃至种种。有作不具足有作具足。先念后作名作具足。先不生念直造作者。名作不具足。复有作已不具足者。谓作业已果报不定。复有作已亦具足者。谓作业已定当得报。复有作已不具足者。果报虽定时节不定。复有作已亦具足者。时报俱定。复有作已不具足者。持戒正见。复有作已亦具足者。毁戒邪见。复有作已不具足者。信因信果。复有作已亦具足者。不信因果。复有作已不具足者。作恶之时有善围绕。复有作已亦具足者。作恶之时恶来围绕。复有作已不具足者。虽作众恶人中受报。复有作已亦具足者。人中作恶地狱受报。复有作已不具足者。有正念心。复有作已亦具足者。无有念心。复有作已不具足者。三时生悔。复有作已亦具足者。三时不悔。如恶善亦如是。因是作已亦具足故。作小得大作大得小。一意摸身身既成就有无量意。摸身初意即是善也。身既成就得二种果。杂善不善如人天。亦如是地狱众生恶意摸身。身既成已一向不善。饿鬼畜生亦恶意摸身。身既成已杂善不善。善恶中阴以善恶摸身。身既成已俱得杂报善以不善。歌罗罗时乃至老时。亦得杂报善以不善。是故经说有四种业。黑业黑报。白业白报。杂业杂报。不黑不白是业无报。黑业黑报所谓地狱。白业白报所谓色天。杂业杂报所谓欲天人中畜生饿鬼。不白不黑无报所谓无漏。善男子。若人不解如是业缘。无量世中流转生死。何以故。不解如是业因缘者。虽生非想非非想处。寿八万劫福尽还堕三恶道故。善男子。一切摸画无胜于意。意画烦恼。烦恼画业。业则画身。贪因缘故。色声妙好威仪详序。嗔因缘故色声粗恶威仪卒暴。如嗔痴亦如是。无量世界一百三十六地狱处。无量畜生无量饿鬼皆因业。作人天亦尔。无量众生获得解脱。亦因于业。善男子。是十善道有三事。一者能遮烦恼。二者能作善心。三者能增长戒。如除毒药凡有三事。一者阿伽陀药。二者神咒。三者真宝。若人善修不放逸行。具足正念分别善恶。当知是人决定能修十善业道。若多放逸。无有惭愧及以信心。当知是人决定能作十不善业道。是十业道复有三事。一者方便二者根本。三者成已。若复有人能勤礼拜供养父母师长和上。有德之人先意问讯言则柔软。是名方便。若作已竟能修念心欢喜不悔。是名成已。作时专著是名根本。善男子。是十业道复有三种。谓上中下。或方便上根本中成已下。或方便中根本上成已下。或方便下根本上成已中。是十业道三法围绕。所谓无贪恚痴有贪嗔痴。是十业道有共戒行不共戒行。舍戒有六。一者断善根时。二者得二根时。三者舍寿命时。四者受恶戒时。五者舍戒时。六者舍欲界身时。或复说言。佛法灭时便失戒者。是义不然。何以故。受已不失。未受不得。断身口意恶故名戒戒。根本四禅四未到禅。是名定戒。根本四禅初禅未到名无漏戒。舍身后世更不作恶。名无作戒。守摄诸根修正念心。见闻觉知色声香味触法。不生放逸。名摄根戒。何因缘故得名为戒。戒者名制。能制一切不善之法。故得名制。又复戒者名曰迮隘。虽有恶法性不能容故名迫迮。又复戒者名曰清凉。遮烦恼热不令得入。是故名凉。又复戒者名上。能上天上至无上道。是故名上。又复戒者名学。学调伏心智慧诸根。是故名学。善男子。或时有人具足一戒。所谓波罗提木叉戒。或具二戒加定共。戒或具三戒加无漏戒。或具四戒加摄根戒。或具五戒加无作戒。善男子。波罗提木叉戒现在得。定共戒者三世中得。善男子。若复有人欲受戒时。至心能观生死罪过解脱功德。信心欢喜。是人兼得作无作戒。如是戒者随命长短。命长长得。命短短得。是无作戒三因缘舍。一者小庄严故。二者心放舍故。三者作不坚故。不舍因缘复有三事。一者有本愿故。二者作业坚故。三者至心不放逸故。善男子。除十善业及十恶业善戒恶戒。已更有业戒所不摄者。谓善恶法。如是善恶有作无作。有人具足作及无作。若现在作善未舍之顷。具作无作。第二念中成就过去作无作。作已过去唯有无作无有作也。若人得戒虽作不善。是人现世成就二法。恶法有作善法无作。是作无作二因缘舍。一者所施物尽。二者心舍善作。二世成就过去现在无作。三世定戒二因缘舍。一者退时。二者断善根时。复有三时。一者舍身时。二者退时。三者生上时。无漏戒有三时舍。一者退时。二者转钝作利时三者得上果时心善业一时失。谓上生退时身口意善。断善根时一时俱失。善男子。若得具足戒定戒无漏戒摄根戒。是人了了解十业道。善男子。因十业道众生。寿命有增有减。减者寿命十年。增者至无量年。北郁单曰定寿千年。此寿百年。东西二方二百五十。此寿无量彼亦无量。四天王寿人数九百万岁。命亦不定如三天下三十三天寿千八百万岁。命亦不定。焰摩天上寿三千六百万岁。命亦不定。兜率天寿七千二百万岁。除后身菩萨。余一切命皆亦不定。化乐天寿万四千四百万岁。命亦不定。他化自在天寿二万八千八百万岁。命亦不定。他化自在天上一年。即热地狱一日一夜。如是三十日为一月。十二月为一岁。彼地狱寿命二万八千八百万岁。命亦不定。化乐天上一年。即是大声地狱一日一夜。如是三十日为一月。十二月为一岁。彼狱寿命万四千四百万岁。命亦不定。兜率天一年。即是小声地狱一日一夜。如是三十日为一月。十二月为一岁。彼地狱寿命七千二百万岁。命亦不定。焰天一年。即众合地狱一日一夜。如是三十日为一月。十二月为一岁。彼地狱寿命三千六百万岁。命亦不定。三十三天一年。即是黑绳地狱一日一夜。如是三十日为一月。十二月为一岁。彼地狱寿命一千八百万岁。命亦不定。四天王上一年。即是活地狱中一日一夜。如是三十日为一月。十二月为一岁。彼地狱寿命九百万岁命亦不定。阿鼻地狱寿命一劫。大热地狱寿命半劫。唯此二处寿命决定。人中五百年。是饿鬼中一日一夜。如是三十日为一月。十二月为一岁。彼鬼寿命万五千岁。命亦不定。畜生道中除难陀婆难陀。其余一切命亦不定。阿鼻地狱一年。即是非想非非想处一日一夜。如是三十日为一月十二月为一岁。彼天寿命八万大劫。无所有处六万劫。识处四万劫。空处二万劫。若有发起轻微烦恼爱着空定。当知是人生四无色。从十年增至八万岁。从八万岁减还至十年。如是增减满十八反。名为中劫。谷贵三灾。疾病三灾。刀兵一灾。名一小劫。水火二灾各五段过有一风灾。五风灾过名一大劫。阎浮提中刀兵起时。东西二方人暂生嗔。此病起时。彼小头痛力少微弱。此谷贵时彼则念食。如是恶事郁单曰无。因不杀故寿命增长。偷因缘故寿命减少。有二种劫。一者水劫。二者火劫。火劫起时地狱众生。若报尽者悉得出离。若未尽者移至他方大地狱中。若此世间八大地狱空无众生。是名众生脱于地狱。四大海中所有众生。业若尽者悉皆得脱。若未尽者悉转生于他方海中。若是海中无一众生。是名得脱。阎浮提地直下过于五百由延。有阎罗王城。周遍纵广七万五千由延。如是城中饿鬼众生。业已尽者悉得出离。业未尽者转生他方阎罗王所。若是城中乃至无有一众生者。是名得脱。尔时有人内因缘故获得初禅。得已即起大声唱言。初禅寂静初禅寂静。诸人闻已即各思惟。一切皆共获得初禅。即舍人身生初禅地。时初禅中复有一人。内因缘故修得二禅。得已即起大声唱言。二禅寂静二禅寂静。众生闻已各自思惟。复获二禅。舍初禅身生二禅处。当尔之时从阿鼻狱上至初禅。乃至无有一众生在。善男子。四天下外有由乾陀山中有七日。众生福德因缘力故。唯一日现。赖之熟成百谷草木。火劫起时七日都现烧燃一切百谷草木。山河大地须弥山王。乃至初禅。二禅众生见是火灾心生怖畏。彼中复有先生诸天。语后来天。汝等莫怖我往曾见如是火灾。齐彼而止不来至此。如诸众生增十年寿至八万岁。减八万寿还至十年。经尔所时如是火灾热犹未息。是时便从中间禅处降注大雨。复经寿命一增一减。众生业行因缘力故。为持此水。其下复出七重风云。是时雨止水上生膜犹如乳肥。四天下中须弥山王渐渐生现。水中自然具有一切种种种子。是时二禅复有一人短命福尽。业力故堕生世间寿无量岁。光明自照独处经久。心生愁恼而自念言。我既独处若我有福。愿更有人来生此间与我为伴。发是念已是时二禅有诸众生薄福命尽。业因缘故便来生此是人见已心生欢喜。即自念言。如是人者。我所化生即是我作我于彼人有自在力彼人亦念。我从彼生彼化作我。彼于我身有自在力。以是因缘。一切众生生我见想。善男子。阴界入等。众生世界国土世界。皆是十业因缘而有。善男子。菩萨二种。一者在家。二者出家出家菩萨能观如是十业道者是不为难。在家观者是乃为难。何以故。在家之人多恶因缘所缠绕故

    优婆塞戒经羼提波罗蜜品第二十五

善生言。世尊。佛先已说檀波罗蜜尸波罗蜜。菩萨云何而得修集忍波罗蜜。佛言。善男子。忍有二种。一者世忍。二者出世忍。能忍饥渴寒热苦乐。是名世忍。能忍信戒施闻智慧正见无谬。忍佛法僧骂詈挝打恶口恶事贪嗔痴等。悉能忍之。能忍难忍难施难作。名出世忍。善男子。菩萨若值他人打骂轻贱毁呰恶口骂詈。是时内心无加报想。菩萨虽作如是忍事。不为现在但为后利。有善报之恶则不反。善男子。有是忍辱非波罗蜜。有波罗蜜非是忍辱。有是忍辱是波罗蜜。有非忍辱非波罗蜜。是忍辱非波罗蜜者。所谓世忍。声闻缘觉所行忍辱。是波罗蜜非忍辱者。所谓禅波罗蜜。亦是忍辱亦波罗蜜者。所谓若被割截头目手足。乃至不生一念嗔心。檀波罗蜜尸波罗蜜般若波罗蜜。非忍辱非波罗蜜者。所谓声闻缘觉持戒布施。善男子若欲修忍。是人应当先破憍慢嗔心痴心。不观我及我所相种性常相。若人能作如是等观。当知是人能修忍辱如是修已心得欢喜。有智之人若遇恶骂当作是念。是骂詈字不一时生。初字出时后字未生。后字生已初字复灭。若不一时。云何是骂。直是风声。我云何嗔。我今此身五阴和合。四阴不现则不可骂。色阴十分和合而有。如是和合念念不停。若不停住谁当受骂。然彼骂者即是风气。风亦二种有内有外。我于外风都不生嗔。云何于内而生嗔也。世间骂者亦有二种。一者实二者虚。若说实者实何所嗔。若说虚者虚自得骂。无豫我事。我何缘嗔。若我嗔者我自作恶。何以故。因嗔恚故生三恶道。若我于彼三恶道中受苦恼者。则为自作自受苦报。是故说言一切善恶皆因我身。善男子。生忍因缘有五事。一者恶来不报。二者观无常想。三者修于慈悲。四者心不放逸。五者断除嗔恚。善男子。若人能成如是五事。当知是人能修忍辱。若人软言净身口业。和颜悦色先意问讯。能观一切苦乐因缘。当知是人能修忍辱若能修空三昧。观诸众生悉是无常受苦等想彼骂辱时。能观骂者如狂如痴稚小无智当知是人能修忍辱。智人当观胜我者骂我不应嗔。何以故。我若嗔者或夺我命。若不如者嗔亦不应报。何以故。非畴匹故。我若报者辱我身口。譬如有人授毒与他人无责者。如其自服人则嗤笑。我亦如是。若嗔彼者当于未来受大苦恼。一切圣人悉当责我。以是因缘。我身若被截斫分离不应生嗔。应当深观往业因缘。当修慈悲怜愍一切。如是小事不能忍者。我当云何能调众生。忍辱即是菩提正因。阿耨多罗三藐三菩提即是忍果。我若不种如是种子。云何获得如是正果。善男子。若有智人乐修忍辱。是人常得颜色和悦。好乐喜戏人见欢喜睹之无厌。于受化者心不贪着。智人见怨以恶来加。当发善愿。愿彼怨者未来之世。为我父母兄弟亲戚。莫于我所生憎怨想。复当观察。若人形残颜色丑恶。诸根不具乏于财物。当知皆从嗔因缘得。我今云何不修忍辱。以是因缘。智者应当深修忍德。善男子。菩萨摩诃萨修忍辱时。常乐观察生死罪过。乐修法行勤于精进。读诵书写如来正典。供养师长有德之人能瞻病苦。修于慈悲怜愍一切。见苦恼者能令远离。常乐出家乃至尽寿。持戒精进摄持六根。不令得起烦恼因缘。宁舍身命终不毁戒。若他有事乐为营理。常有惭愧乐赞忍德。为调众生堪忍众苦。于怨尚能忍于恶事。况复亲所。能忍二嗔。一众生嗔。二非众生嗔。舍己乐具令众得乐。不念多恶不忘少善。远离两舌前后默然。不说彼短说烦恼过。令众得离他所不喜不为说之。净身口意了诸罪业。若客烦恼因缘作罪。作已惭愧心生悔恨。善男子。菩萨二种。一者在家。二者出家。出家菩萨修净忍辱是不为难。在家修忍是乃为难。何以故。在家之人多恶因缘所缠绕故

    优婆塞戒经毗梨耶波罗蜜品第二十六

善生言。世尊。菩萨摩诃萨能修六波罗蜜。谁为正因。善男子。若善男子善女人。已生恶法为欲坏之。未生恶法为遮不起。未生善法为令速生。已生善法为令增广。勤修精进是名精进。如是精进。即是修行六波罗蜜之正因也是勤精进能脱一切诸烦恼界。善男子。若能受于三恶道苦。当知是人真实能修毗梨耶波罗蜜。平等修集不急不缓。精进二种。一正二邪。菩萨远离邪精进已修正精进。修信施戒闻慧慈悲名正精进。至心常作三时无悔。于善法所不生知足。所学世法及出世法。一切皆名正精进也。菩萨虽复不惜身命。然为护法应当爱惜身。四威仪常修如法。修善法时心无懈息。失身命时不舍如法。若能到于六事彼岸。悉是精进之因缘也。若自读诵书写思惟十二部经。名自为法勤行精进。若能以是转化众生令调伏者。名为他法勤行精进。若为菩提修菩提道。布施持戒多闻智慧。修学世法供养父母师长有德之人。修舍摩陀毗婆舍那。读诵书写十二部经。复能远离贪恚痴等。名为菩提勤行精进。如是悉名为正精进。是名六波罗蜜之正因也。善男子。懈怠之人不能一时一切布施不能持戒。勤行精进摄心念定。忍于恶事分别善恶。是故我言六波罗蜜因于精进。善男子。有勤精进非波罗蜜。有波罗蜜非勤精进。有亦精进亦波罗蜜。有非精进非波罗蜜。精进非波罗蜜者。如邪精进善事精进。声闻缘觉所有精进。有波罗蜜非精进者。所谓般若波罗蜜。有亦精进亦波罗蜜者。所谓布施持戒忍辱精进禅等五波罗蜜。有非精进非波罗蜜者。一切凡夫声闻缘觉。布施持戒忍辱禅定智慧。及余善法。善男子。菩萨有二种。一者在家。二者出家。出家菩萨修勤精进是不为难。在家修进是乃为难。何以故。在家之人多恶因缘所缠绕故

    优婆塞戒经禅波罗蜜品第二十七

善生言。世尊。菩萨摩诃萨修禅波罗蜜。云何禅定。善男子。禅定即戒慈悲喜舍。远离诸结修集善法。是名禅定。善男子。若离禅定尚不能得一切世事。况出世事。是故应当至心修集。菩萨欲得禅波罗蜜。先当亲近真善知识。修集三昧方便之道。所谓戒。戒摄诸根戒断于邪命。如法而住随顺师教。于善法所不生知足。修行善时心无休息。常乐寂静远离五盖。心乐思惟观生死过。常修善法至心不废。具足正念断诸放逸。省于言语亦损眠食。心净身净不亲恶友。不与恶交不乐世事。知时知法了知自身观心数法。若有喜相愁相嗔相软相坚相。知已能除犹如金师善知冷热。不令失所乐甘露味。虽处世法身心不勤。犹如须弥不为四风之所倾动。正念坚固亦见知觉有为多过。若人乐修如是三昧不休不息。当知是人能具足得。譬如攒火以不息故火则易得。善男子。若离三昧欲得世法出世菩提。无有是处。善男子。一切三昧即是一切善法根本。以是因缘应当摄心。如人执镜则见一切善恶之事。是故三昧名菩提道之庄严也。受身心乐名为三昧。不增不减名等三昧。从初骨观乃至得阿耨多罗三藐三菩提。皆名三昧。是三昧有四缘。一者从欲。二者从精进。三者从心。四者从慧。是四缘故得无量福增一切善。复有三种。一者从闻。二者从思。三者从修。从是三法渐渐而生。复有三时。所谓生时住时增时。善男子。欲界之中有三昧子。是子因缘得三菩提。是三昧者有退住增。若在四禅性则坚固。从初乃至非想非非想处。上地胜下次第。如是根本禅中则有喜乐。非中间禅六通亦尔。在于根本不在余处。是三昧名菩提庄严。因是三昧能得学道及无学道。四无量心三解脱门。自利利他无量神足。知他心智能调众生。无量智慧五根三昧。转钝为利断于一切生老病死。能得成就一切种智。见诸法性如罗縠视。善男子。智者应当作如是观。一切烦恼是我大怨。何以故。因是烦恼能破自他。以是因缘。我当修集慈悲之心。为欲利益诸众生故。为得无量纯善法故。若有说言离于慈悲得善法者。无有是处。如是慈悲能断不善。能令众生离苦受乐能坏欲界。是慈若能缘于欲界名欲界慈。善男子。众生若能修集慈心。是人当得无量功德。修慈心时若能先于怨中施安。是名修慈。善男子。一切众生凡有三聚。一者怨。二者亲。三者中。如是三聚名为慈缘。修慈之人先从亲起欲令受乐。此观既成都及怨家。善男子。起慈心时有因戒起有因施起。若能观怨作子想者。是名得慈。善男子。慈唯能缘不能救苦。悲则不尔亦缘亦救。善男子。若能观怨。一毫之善不见其恶。当知是人名为习慈。若彼怨家设遇病苦。能往问讯瞻疗所患给其所须。当知是人能善修慈。善男子。若能修忍。当知即是修慈因缘。如是慈心即是一切安乐因缘。若能修慈。当知是人能破一切憍慢因缘。能行施戒忍辱精进禅定智慧。如法修行。若人修定。当知是人修梵福德。得梵身故名梵福德。若人能观生死过罪涅槃功德。是人足下所履粪土应当顶戴。是人难忍能忍。难施能施。难作能作。是人能修四禅四空及八解脱。复作是念。一切众生身口意恶。未来若受苦恼报者悉令我受。若我所有善果报者。悉令众生同我受之。如是慈悲缘广故广缘少故少。慈悲三种。谓下中上。复有三种。一者缘亲。二者缘怨。三者缘中。复有三种。一者缘贪。二者缘众生。三者缘非众生。如是缘者悉名三昧。悲喜舍心亦复如是。善男子。有禅非波罗蜜。有波罗蜜非禅。有亦是禅亦波罗蜜。有非禅非波罗蜜。是禅非波罗蜜者。谓世俗禅。声闻缘觉所有禅定。是波罗蜜非禅定者。所谓施戒忍辱精进。亦是禅亦波罗蜜者。谓金刚三昧。非禅非波罗蜜者。谓一切众生声闻缘觉。从闻思惟所生善法。善男子。菩萨有二种。一者在家。二者出家。出家菩萨修于净禅是不为难。在家修净是乃为难。何以故。在家之人多恶因缘所缠绕故

    优婆塞戒经般若波罗蜜品第二十八

善生言。世尊。菩萨云何修净般若波罗蜜。善男子。若有菩萨持戒精进多闻正命修于忍辱。怜愍众生心多惭愧远离嫉妒。真实了知诸善方便。为众受苦不生悔退。乐行惠施能调众生。善知所犯轻重之相。勤劝众生施作福业。知字知义心无憍慢。亲近善友能自利益及利益他。恭敬三宝诸师和上长老有德。于身菩提不生轻想。能观菩提深妙功德。知善恶相知世出世一切声论。知因知果知初方便及以根本。当知是人能得智慧。如是智慧有三种。一从闻生。二从思生。三从修生。从字得义名从闻生。思惟得义名从思生。从修得义名从修生。能读如来十二部经能除疑网。能读一切世论世事。能善分别邪正之道。是名智慧。能善分别十二部经。阴界入等因果字义。毗婆舍那舍摩他相。上中下相。善恶无记。及四颠倒见道修道。能善分别如是等事。是名智慧。善男子。有智之人求于十力四无所畏大悲三念处。常亲近佛及佛弟子。世无佛法乐在外道出家修学。虽处邪道乐求正要。常修慈悲喜舍之心及五通道。得五通已观不净想及无常想。能说有为多诸过罪。为正语故教诸众生令学声论。能令众生离身心病。乐以世事教于他人。所作事业无能胜者。所谓咒方种种医药能善求财。得已能护用以道理如法惠施。虽知一切不生憍慢。得大功德不生知足。能教众生信施持戒多闻智慧。知善不善无记方便善知学行因缘次第。知菩提道及道庄严。知诸众生上中下根。知外声论心不存着。知众生时随宜调伏。知众生世及国土世。知从具足六波罗蜜。善男子。有是智慧。非波罗蜜。有波罗蜜非是智慧。有是智慧是波罗蜜。有非智慧非波罗蜜。是智慧非波罗蜜者。所谓一切世间智慧。声闻缘觉所行智慧。是波罗蜜非智慧者。无有是义是智慧是波罗蜜者。所谓一切六波罗蜜。非智慧非波罗蜜者。所谓一切声闻缘觉施戒精进。善男子。若人有能勤修如是六波罗蜜。是人名为供养六方能增财命。善男子。菩萨二种。一者在家。二者出家。出家菩萨修净智慧是不为难。在家修净是乃为难。何以故。在家之人多恶因缘所缠绕故

说是法时。善生长者子等千优婆塞。发阿耨多罗三藐三菩提心。既发心已即从坐起。礼佛而退辞还所止

优婆塞戒经卷第七


优婆塞五戒威仪经一卷

    No. 1503

优婆塞五戒威仪经一卷

        宋罽宾三藏求那跋摩译

  佛者众圣尊　　神通应自在
  随类处身形　　音声亦复尔
  见闻获安隐　　莫不信向心
  是故我归命　　愿普如世尊
  甚深菩萨戒　　功德难思议
  受者获安隐　　福慧日夜生
  诸佛常护念　　万行渐满盈
  六度四等意　　普度诸群盲
  手足初莫犯　　节言顺所行
  常乐在定意　　是名真比丘
  质直离谄曲　　常与贤圣俱
  爱众犹养已　　是名真菩萨

诸大德。一心谛听谛听。善思念之。我今欲说三世诸佛菩萨。成就利益一切众生功德戒。如是住菩萨戒者。有四波罗夷法。何等为四。若菩萨为利养故自赞毁他。是名菩萨波罗夷。若菩萨多饶财物。贫苦之人来从乞索菩萨悭贪无有慈心。乃至不施一钱之物。有求法者。乃至不为说于一偈。是名菩萨波罗夷。若菩萨嗔于前人恶言骂辱。加以手打及以杖石。意犹不息。前人求悔善言忏谢。菩萨犹嗔。愤结不解。是名菩萨波罗夷。若菩萨自谤菩萨法藏。若见人谤善可其言。既自不信反助他言。若心自解或从他受。是名菩萨波罗夷。如是菩萨四波罗夷。菩萨于中不应犯一。何况具犯。若有犯者不名菩萨。现身不能庄严菩提。亦复不能令心寂静。是似菩萨非实菩萨。犯有三种有软中上。若软中心犯。是不名失。若是增上心犯。是名为失。何者是上。若犯上四数数乐犯。心无惭耻不自悔责。是名上犯。菩萨虽犯于上四事不即永失。如比丘犯四即为永弃。菩萨不尔。何以故。比丘犯四更无受路。菩萨虽犯脱可更受。是故不同。略有二事失菩萨戒。一舍菩提愿。二增上恶心。除是二事。若舍此身戒终不失。从是以后生生之处常有此戒。若不忆念更遇善友。而更受者不名新得。如是菩萨戒者应当识知犯不犯事轻重之相。软中上异

如是住菩萨戒者。日应供养诸佛若塔若像次供养法若行法人。及菩萨藏大乘经典。供养众僧及十方土住于大地诸菩萨等。于日夜中供养三宝随其力能。乃至一念一礼一四句诵信心供养勿令有废。若不恭敬慢堕心者。犯重垢罪。若忘误者犯轻垢罪不犯者。若病若狂。若有净心逮菩萨地。如须陀洹得不坏净心。常能供养三宝不绝。是名不犯。菩萨。不知厌足。贪着利养不制心者。犯重垢罪。不犯者虽贪利养常生悔心。我当精进断除是意。极自制御贪心犹起。若取小利助断大贪。是名不犯

菩萨。见上座尊长耆宿德同师同学。生憍慢心及嗔恶心。不起承迎礼拜避座。设有言语余谈不听。若有所问不如实答者。犯重垢罪。若无慢嗔恚痴之意。直以懒惰无记散心。犯轻垢罪。不犯者。若病若狂若时睡眠。若听法说法。若先共他人语。若为调伏灭恶增善。若有僧限护多人意。是名不犯

菩萨。檀越来请。若于自舍。若僧寺内给施所须。菩萨憍慢嗔恚轻贱不往受者。犯重垢罪。若懒惰不往。犯轻垢罪。不犯者。若病若狂。若远若道崄难。若为调伏灭恶增善。若失受请。若为修善。若听未闻。若知请主欲相恼故。若有僧限护多人意。是名不犯

菩萨。从他人边。得金银琉璃种种杂宝所须之物。及地中伏藏无主财物。皆应取之念当转施。若恶心嗔故不取者。犯重垢罪。若作是心。我不与人而作因缘。若懒惰心。犯轻垢罪。不犯者。若是狂心。若为调伏灭恶增善。若知受已必生爱着。若知施已生悔。若知施主施故发狂。若虑施主施已穷苦。若知施物三宝所有。若知施物劫盗所得。若知受已多得苦恼。所谓王难贼盗。死亡系闭。恶声流布。摈令出境界。是名不犯菩萨。他来求法。以嗔恶心憎嫉他故。不与说者。犯重垢罪。若懒惰心不与说者。犯轻垢罪。不犯者。若外道求法虑还讥刺。若病若狂。若为调伏灭恶增善。若知前人不解其义。若前人不敬不如法事。若前人钝根不解深法恐生邪见。若知闻已破失本心坏灭正法。若知闻已必向非器宣说其事。是名不犯

菩萨。见恶众生犯戒毁禁作众罪行。菩萨自知能化为善。若恶心嗔心舍不教者。犯重垢罪。何以故。菩萨不于身口意净持戒人边起于悲心。若见恶人犯戒毁禁作众罪行。极生悲心。是故有犯。不犯者。若狂若为调伏灭恶增善。若有僧限护多人意。是名不犯

菩萨。如佛所制波罗提木叉。及结毗尼。欲使不信者信已信者增。此声闻戒及菩萨戒。等无有异。何以故。声闻之人顺常自为。犹欲学令不信者信已信者增。何况菩萨所修学。常为众生岂不能尔。是故名同不犯

如佛所制。声闻之人。应少欲作少因缘事。菩萨不尔。何以故。顺求自利不为他人是声闻好。菩萨若尔则不名菩萨。为他人故所可受衣。乃至百千从非亲里婆罗门居士尽力所求。如衣钵亦如是。为他人故。及应乞缕教织师织畜憍奢耶衣。受取金银乃至百千。如是之事与声闻异。若菩萨本为众生。而嗔恶心少作少因缘事。放舍众生独居其所者。犯重垢罪。若懒惰心少欲少事居其所者。犯轻垢罪。菩萨有五非法。一谄。二华。三相。四以利求利。五邪命。有此五事。以不为愧不制不息者。犯重垢罪。不犯者。觉是非法常欲制之。是名不犯

菩萨戏笑散乱高声唱说。作非威仪令他人笑。为众所轻者。犯重垢罪。若是宿习忘误作者。犯轻垢罪。不犯者。觉是非法常欲制之。若外人嗔恚欲调伏故。若人苦恼为令释故。若欲摄取戏笑故。若二人共诤为和合故。是名不犯。菩萨如是见如是语。菩萨不应乐于涅槃应背涅槃。不应畏烦恼。不应灭烦恼。何以故。菩萨三阿僧祇往来生死故。如是语者。犯重垢罪。何以故。如菩萨乐于涅槃畏于烦恼。比于声闻千万倍不可为喻。何以故。声闻之人顺自为己。菩萨常为一切众故。菩萨虽处有漏。于灭烦恼而得自在。过于罗汉处无漏者上。若菩萨起身口业应自防护。莫使他人慢惰罪。若故不自护使他惰罪者。犯重垢罪。若不作意自护。放散所作生他罪者。犯轻垢罪。不犯者。若外道。若随出家如法所作。若值多嗔恶人。是名不犯

菩萨。见前众生须加杖痛然后有利。自护不治者。犯轻垢罪。不犯者。若利少苦多。是名不犯

菩萨。以骂报骂以嗔报嗔。以打报打以牵挽者。犯重垢罪

菩萨与他共斗及共相嫌。恶心嗔心。若憍慢心不如法悔者。犯重垢罪。若懒惰放逸一不求悔者。犯轻垢罪。不犯者。若为调伏灭恶增善。若彼外道要作非法。若彼喜斗怨更增上。若知彼人终不受悔。若向彼悔起彼重慢。是名不犯

菩萨。共他嫌恨他如法求悔。菩萨恶心不受。为恼他者。犯重垢罪。若无嗔心不受他悔。犯轻垢罪。不犯者。若为调伏灭恶增善。若恶非法。是名不犯

菩萨。嗔他受者嗔事不休息者。犯重垢罪。不犯者若常制之。嗔心犹起。是名不犯

菩萨。受畜徒众但为给事及与衣食。是名犯

菩萨。起懒惰意乐于非时食。贪着睡眠若倚若卧者。犯重垢罪。不犯者。若病若狂无巧便。若道路行极。若常制之。是名不犯

菩萨。以染着心谈说世乐事者。犯重垢罪。若忘误说。犯轻垢罪。不犯者。若有人问正心少说。若谈异闻。若谈论法事。是名不犯菩萨。乐欲坐禅知他有法。以嗔慢心不能下意。从他求受法者。犯重垢罪。若懒惰心不求受者。犯轻垢罪。不犯者。若病若无巧便。若知彼人不顺法教。若自有巧便。多闻摄其心者。是名不犯

菩萨。起欲界欲。不观对治疾除灭者。犯重垢罪。不犯者。常勤欲灭欲心犹起。是名不犯。如欲余盖亦尔。若菩萨贪味于禅着功德者。犯重垢罪。不犯者。常欲舍着着心犹起。是名不犯菩萨。如是见如是语。菩萨不应听受诵学声闻法藏。菩萨之人用学是为。作是语者。犯重垢罪。何以故。菩萨于外道书尚应当学。何况佛语。不犯者。为欲调伏声闻入大乘故。是名不犯

菩萨法藏一向舍置。贪学读诵声闻经者。犯轻垢罪

菩萨。有佛经藏不能勤学。乃更勤学外道俗典。犯重垢罪。不犯者。若极根利一闻能持。同佛语者取用助化。以彼妙辞助明佛法。于佛法于佛经义意不倾动。是名不犯

菩萨。欲学外道经典。应如上学。若于中受乐生着心。不如服苦药者。犯重垢罪。菩萨若闻菩萨法藏甚深秘密。第一实义不思议事。纯是诸佛菩萨境界。于此义中生诬谤心言。此义无益非佛所说。不能祐利一切众生。作是谤者。犯重垢罪。不犯者。若思惟定义。若方便说。是名不犯

菩萨。闻于甚深义时若不生信。以不谄心为生信故应作是念。我不应尔。我如盲者无有慧眼。佛口所说我云何谤。如是菩萨自愤由痴。是佛境界非我所及若能如是是为正行。若意不解不生诽谤。是名不犯

菩萨。为饮食故。以嗔恶心自赞毁他。犯重垢罪。不犯者。若为伏外道。若伏憍慢增长佛法。若为不信者信。已信者增。是名不犯

菩萨。有说法家若说毗尼处。大法会处。嗔嫉慢心不往听者。犯重垢罪。若懒惰心不往听者。犯轻垢罪。不犯者。若自不闻又无人唤。若病若无巧便。若知彼说法不顺义理。若知说者于已有难。若知彼说更无异闻。若得总持自多闻。若勤修善根。是名不犯

菩萨。有人来倩我。有事缘当为营办。所谓共去共还营佐众事。有所营了守护财物。和合斗讼经办饮食。修福德业。若一二事不为作者。犯重垢罪。若懒惰不为。犯轻垢罪。不犯者。若病若无巧便。若自有事。若彼能办若不相倩。若无益事。若为调伏灭恶增善。若无他倩。若报他作勤修善根。若自闇钝恐失业次。若有僧限护多人意。是名不犯若菩萨。见病众生。以恶心嗔心不瞻养者。犯重垢罪。若懒惰不养。犯轻垢罪。不犯者。若自有病。若无巧便。若倩他看。若彼病者自有属眷。若知病者能自经给。若久病。若人犹能起止。若欲勤修增上善根。若极自闇钝恐失党次。若失看病如病余。贫穷苦恼亦复如是。是名不犯

菩萨。见前众生应有利宜。无有方便而能发起。菩萨恶心嗔心不教示者。犯重垢罪。若懒惰不教。犯轻垢罪。不犯者。若无方便。若使他教。若彼自有善知识。若为调伏灭恶增善。若示彼方便更嗔反戾。无有敬爱心强得自用。是名不犯菩萨。众生给施所须。应念其恩。若恶心嗔心不念恩报恩者。犯重垢罪。若懒惰不报。犯轻垢罪。不犯者。若自无力。若无巧便。若为调伏灭恶增善。若欲念报施主不受。是名不犯

菩萨。见人亲里死亡。若亡失财物种种忧苦。若恶心嗔心不往慰喻者。犯重垢罪。不犯者。如前倩菩萨中说

菩萨。有人从索饮食。所须不与者。犯重垢罪。不犯者。若自无物。若索不净物。若为调伏灭恶增善。若王所制。若护僧限。是名不犯

菩萨。弟子应随时教诲。若弟子有乏。应从笃信人边劝索供给。若恶心嗔心不教诲不供给者。犯重垢罪。若懒惰心不教供给犯轻垢罪。不犯者。若为调伏灭恶增善。若护僧限。若病若无巧便。若倩人教。若弟子福德能致供养。若弟子本是外道无好善心。是名不犯菩萨。以嗔心恶心不护他意者。犯重垢罪。若懒惰放逸不护他意。犯轻垢罪。不犯者。若非法事若病。若有僧限护多人意若外道。若为调伏灭恶增善。是名不犯

菩萨。见他德行不能称赞。以恶心嗔心隐藏他善者。犯重垢罪。若懒惰放逸不称他善。犯轻垢罪。不犯者。若知彼人不乐赞叹。若病若无巧便。若为调伏灭恶增善护僧限。若知闻赞更生憍慢。若彼无实德。若言似善实无善义。若为外道。若赞时未到。是名不犯

菩萨。为多人头首。见诸眷属不如法事。应呵应摈。若嗔心恶心舍不呵治者。犯重垢罪。若懒惰放逸不教呵者。犯轻垢罪不犯者。若知彼人恶性健嗔不受教呵。若待时教呵。若畏破僧。若知彼质直宿习少羞喜数犯悔。是名不犯

菩萨。有神通变化应为众生随时变现。或方便恐怖令生信心。若畏信施不现变化者。犯轻垢罪。不犯者。若人深着恶法邪见。若是外道。若骂贤圣。若着邪见。若狂若病。是名不犯。菩萨。戒聚成就具足无量妙果。以是戒聚因缘力故。具足尸波罗蜜。受者虽未得阿耨多罗三藐三菩提。以得具足五事功德。一者常为诸佛菩萨所护念。二者受常净乐。三者临终无悔。四者舍身得生诸佛世界。五者庄严阿耨多罗三藐三菩提。菩萨受持菩萨戒者。不自为身唯为利他。及庄严阿耨多罗三藐三菩提。是菩萨戒。悉是过去未来现在恒河沙等。诸佛菩萨之所成就。乃至十方诸佛菩萨亦复如是。菩萨弘慈普恩及六道众生三涂八难苦恼。十方无不蒙益

  功德不可计　　福慧如虚空
  略说共要竟　　欢喜礼奉行
  普发菩提心　　福慧命得成
  慈悲男女长　　喜舍次第生
  一切成佛道　　永尽无有余
  十方同其愿　　巍巍无极尊

欲为菩萨优婆塞。放逸五戒威仪者。若无师从受处。尔时受者若无师。应向佛像前自誓受。菩萨优婆塞威仪应如是作礼。偏袒右肩胡跪合掌。应如是言。我某甲白十方佛及住大地诸菩萨等。今于诸佛前欲受一切戒。学一切菩萨戒优婆塞五戒威仪。摄一切善法菩萨戒。为利众生戒。是戒过去诸菩萨已学。未来诸菩萨当学。现在诸菩萨今学。我亦如是学。第二第三亦如是说竟。其余诸事应如前广说

离欲优婆塞具行五戒。远离身四恶。一者杀。二者盗。三者淫。四者饮酒。远离口五恶。一者妄语。二者恶口。三者两舌。四者无义语。五者绮语。远离五邪命。一者卖肉。二者沽酒。三者卖毒。四者卖众生。五者卖兵仗。远离严饰五事。一者香。二者花。三者璎珞。四者香油涂身。五者香熏衣。远离放逸五事。一者歌。二者舞。三者作乐。四者严饰乐器。五者不往观听。此五戒随力所堪。若能终身具持五为上。若不能随持多少年月日夜。乃至须臾亦得暂持。不但如持全念。佛临涅槃敕四大声闻及六应真。吾灭度后如是真法之中。若出家二众净持禁戒。及在家二众随力多少。心次近持上戒者。若造房舍床褥衣服饮食。一切顺道资生之具。施四方僧及诸贤圣。汝等尽应受请。若不受者得罪。以此观之。贤圣不远感至则应。若作功德先当竭力受持上戒。然后至心请四方僧及诸贤圣。若不能终身。至一日一夕者善。若不能者。设供之时便受罢便止。此诸贤圣皆来受请。若有所犯即如法悔。此一切菩萨犯当突吉罗罪。当向大小乘人能解说。能受悔者如法忏悔

若菩萨。以增上烦恼犯波罗夷处法者。失律仪戒应当更受。若中烦恼犯波罗夷处法者。当向三人。若过三人长跪合掌。作突吉罗忏悔所犯罪多。作是说言。大德忆念。我某甲舍菩萨毗尼。如所称事犯突吉罗罪。余如比丘突吉罗罪忏悔法说

若下烦恼犯波罗夷处法。及余所犯。向一人忏三礼文

愿十方法界世性六道。三业罪障垢惑众生。崩颠倒山竭四流济。登平等道入无为国。归命敬礼七处八会卢舍那佛尽十方国诸妙觉尊

愿十方法界世性六道。沉沦诸有长没众生。摧破戒林殄灭邪照。归命敬礼七处八会佛华严藏。尽十方国修多罗海。愿十方法界世性六道。小心胶固颠倒众生。顿绝偏照须证住想。永附大乘尽未来际。归命敬礼七处八会普贤众等。尽十方国诸贤圣僧

若欲发心去时当立五愿。一者愿令我早弃此身。二者愿师僧父母使不愁恼。令我身命疾至菩提。三者愿至阿兰若处行。若有虎狼恶毒虫兽来欲啖我。我不恐怖犹如比丘得第三禅乐。四者若我至阿兰若处。若天雨风起。或有恶鬼毒龙来欲螫我。我心安隐亦不恐怖。犹如有人欲度大海。到水中央天忽风起。波浪甚大度者恐怖。天风即定度到彼岸心大欢喜。愿我亦尔。疾到菩提无上彼岸。五者愿我到阿兰若处。若当病时愿得诸天来至我所。教导我等使心不悔。我复念言。我此身中有四毒蛇同俱止中。犹如四蛇同共一窟。蛇欲出时。各相谓言我前去。诤窟不出死在窟中。犹嗔诤故四俱灭亡。我今身中有四毒蛇。斗诤嗔恚在我身中。作如是念。病得即除菩提心起。令心得安六识不乱。安心兰若四行具足。安心禅定制伏六情。是第五愿。发此愿已礼四方佛。乃有十拜作如是言。诸佛世尊。哀愍我等覆护我等。使我得无上道疾至菩提。我今忏悔。我某甲。归依佛归依法归依僧。十地菩萨辟支罗汉诸贤圣等。我从无数劫以来流转生死。百生千生无量亿生。或堕六趣受生异报。或作饿鬼畜生。受如此苦常不得乐。我自寻思过惑自缠。不睹圣道。障涅槃门闭甘露户。塞众善道不闻正法。沉没大海有如此苦罪。今悉忏悔五体投地。如此投地七遍亦然。当投地时发如此言。愿去我身无量众毒。拔出邪愚无量众毒。拔出邪愚无量尘惑。心意清净六念成就。使我到阿兰若处。心无恐怖疾到菩提。开涅槃门启甘露户。塞地狱门闭三恶道。拔三毒根出三界网。得三乐证三果真。超生死危当得智慧。离最后身疾至菩提。发此愿已从地而起。礼十方佛讫竟。合掌立住心怀欢喜。作如是念我罪永除受绳床法四种。一者请佛。二者请师。三脱革屣偏袒右肩清净。四右膝着地胡跪佛前。请师作如是白。十方诸佛及大迦叶。亲于佛前受阿兰若法。佛为作证明师。为作证知。若我四十五日。行于苦行志不退转。若生退心我即妄语。诳于诸天不到彼岸。大德当证。请师复作是言。长老一心念。今于佛前发此誓言。请大德为证。汝若退者诳于他人。自堕地狱不免苦也

汝当真成行阿兰若行。得兰若智。如是受持。答言如是。三说

受锡杖法。长跪大德前。如是三白。大德一心念。今请大德师。如是三白。大德作如是言。长老一心念。汝今发无上心。受持如法用。不得不净手捉入僧房。应当脱楼纂。不得近地。若入白衣舍。应纂在后若中前。须诣白衣舍。或受中食。种种因缘当三唤。三若不来者乃至五。五若不来者乃至七。七若不来更至余家。乃至七家。七家不得。于是中第二第三亦如是说

舍法戒

长老一心念。比丘某甲。优婆塞五戒威仪者。何缘而生日满后不死。不堕地狱中间。白十方佛及大迦叶。皆当善听。某甲竖标如是。三白已讫捉标竖树竟。复作如是白。十方诸佛四方净行大德。悉为证知。某不欺诳于诸天。不到彼岸。今赍法床及如法杖。悉皆具足。今以结坐。一切行兰若比丘亦皆结坐。如是三白作礼六拜。合掌一心如是念。念十方诸佛及大迦叶。比丘某甲。优婆塞某甲众念成就。今解坐向余处还结。若欲捉绳床时。应作四念。第一念者。念我身中皆是无常。应当苦之。二者苦身修习空智自至。宜当修之。三者当起忍心莫生嗔怒。四生欢喜心。若生欢喜心疾至菩提。作此念已。向彼放牛虎狼大声小声。淫声及迫迮。悉皆远离。离此声已安心端念。欲去诸尘时。当作二念言。一者令我身中得安隐定。不生疲极疾到菩提。二者当得闲静。心无错乱。六识安隐得灭尽定。安详放床立住礼佛乃至十拜。立住合掌便作三念。一者念佛。二者念戒。三者念禅定。作此念已。便向绳床安详而坐。复作六念。一者念诸佛护念我念成就。二者念我戒身清净。戒者谓波罗提木叉。念者是名不犯。从序至偈四事思得至于十三。念此十三成就二不定。三十九十四波罗提舍尼。众多学法。七灭诤法。从上至下皆应实念。三者念报父母师僧之恩。四者念五欲。皆是无常。大患之根本。昏网之元首。五者念地狱之苦恼。当勤修善远离此苦。我已出家。宜应谨慎弃恶修善。六者念慧。若我有慧则应忆持。慧具足无事不办者。得无上道。六念具足安心而坐。依禅法观。优婆塞若欲移时。当作三念。一者念我行时。地上蠢蠢多有虫蚁。我若误杀时得何罪。死者生天。二者当念如法行。如法仰手捉杖在身。威仪齐整安详而行。三者行不反顾。亦不摇头动手。是名三念成就。如法行来优婆塞。威仪笃信持食来时。当净受之。受得讫已结加趺坐。复作四念。一者念我身中有八万户虫。虫得此食即皆安隐。二者念我得食当少食之。若少食者令我身轻。若身轻众欲亦少。若欲少者疾至菩提。三者我不为美故。但为活命者诸善成就。善若成就成无上智。四者我食时。十方饿者悉令饱满。皆悉奉行

优婆塞五戒威仪经一卷


阿含口解十二因缘经

    No. 1508

阿含口解十二因缘经

        后汉安息优婆塞都尉安玄共沙门严佛调译

欲断生死趣度世道者。当念却十二因缘。何等为十二。一者本为痴。二者从痴为所作行。三者从作行为所识。四者从所识为名色。五者从名色为六衰。六者从六衰为所更。七者从所更为痛。八者从痛为爱。九者从爱为求。十者从求为得。十一者从得为生。十二者从生为老病死。是为十二因缘事。此十二事欲起。当用四非常灭之。何等为四非常。一为识苦。二为舍习。三为知尽。四为行道。更说念生念老念病念死。念是四事。便却是十二因缘道成。念是四事道人。欲得度世。当断十二因缘事。是为断生死根。十二因缘有内外。一者内为痴。外为地。二者内为行。外为水。三者内为识。外为火。四者内为名色外为风。五者内为六入外为空。六者内为灾外为种。七者内为痛外为根。八者内为爱外为茎。九者内为受外为叶。十者内为有外为节。十一者内为生外为华。十二者内为老死外为实。人生死从内十二因缘。万物生死从外十二因缘。何等为痴。谓不礼父母。不分别白黑。从是因缘得痛。不欲弃不信。今世亦后世。已作是事。便随行不作。是亦不得。是以有痴便为行。已有行便为识。已有识便为名色。已有名色便为六入。已有六入便为栽。已有栽便为痛。已有痛便为爱。已有爱便为受。已有受便为有。已有有便为生。已有生便为老死。故人生取十二因缘。得十二因缘生。无因缘亦不生。万物亦尔。不断十二因缘。不脱生死。行三十七品经。为从是得道。十二因缘有五事。一者痴。二者生死精行。是前世因缘。三者识。从识受身生。四者名色。色身复成五阴。是今世因缘。五者六衰。复作生死精行种栽。是后世因缘。前后三世转相因缘故。为有五事

十二因缘。本从身十事。出身十事。七事成一。三事从四七事成。一者杀盗淫两舌恶口妄言绮语。共从色为一。三事从四者。嫉嗔恚痴。从痛痒思想生死识。是十事合为五阴。便为十二因缘。地名痴行为盛阴。便作生死行。自种栽名为行。已有行便有识。受身生死。有识便有名色。身复作十事。成已五阴。已有名色便有六入。复作盛阴。行种栽后当复受转相。因缘生死故名为因缘。身十事为十二因缘者。嫉为痴。嗔恚为生死。精疑为识。杀为名色。盗为六衰。淫为更。两舌为痛。妄言为爱。恶口为成。绮语为愿。生有无故为有。十二因缘。何以故。淫为痴。嗔恚为生死。精疑为识。内三事为本。已有三事。便有七事。成五盛阴。嫉为五阴本故为疑。五阴行可意善不可意嗔。便作生死精十事。外从身内意故。疑谓不分别白黑。不识生死故为识。道人欲断。十二因缘。当先断身十事。便为痴。从痴五阴灭。十二因缘亦灭断身十事者。外从身内从意故。言身意持。谓不杀。亦谓外从口。内从嫉断者。谓万物一切意不起。便嗔恚止。嗔恚止便杀止。杀止便贪欲止。贪欲止便泣止。外口者谓声。止声者。两舌恶口妄言绮语亦止。无有疑便入道。是为还五阴断十二因缘本

人受身有三别。第一五阴盛阴。第二十八种。第三十二因缘行。是三事得身三别。第一五阴盛阴者。五阴从身十事出。从眼为色阴。从耳为痛痒阴。从鼻为思想阴。从口为生死阴。从意为识阴。心主念对是六事为根本。是为五阴地。第二十八。入十九根。十八种者。五阴行为盛阴。有对有入为十二入本。六情为十八间。有识故为十九根。言十八种者。识不生故。为十八种。是说盛阴行生十八种十九根。第三十二因缘者。谓五阴五盛阴。行求十二因缘便有身。是同身十事。俱分别之耳。从色得身。从四阴得名字。从名色得爱受。从受行痴。行痴便成十二因缘。道当为断色不为身。但名字为身。虽有眼耳鼻舌身意。亦复非身。何以故。设耳是人。当能听一切。从形得名字。譬金字。譬如以金作物。因从是得字。地水火风空。是五事作身。亦复非身。何以故身知细滑故。人已死地不知细滑故。知地水火风空非身。身亦空意亦空。俱空无所有。亦无痛痒。何以故。人已死亦不复觉痛痒。如是为空。意已离身亦无痛痒。但因缘共合故。还归无有。身中有十二风。上气风下气风。眼风耳风鼻风。背风胁风脐风。臂风足风曲风刀风。刀风至病人。杀生刀风。刀风断截人命。生老病死。生者谓初堕母腹中时为生。已生便老。止者谓意中止。用止故败气息出入。见了身本。合十事为败

身中五事。一者地。二者水。三者火。四者风。五者空。坚者为地。软者为水。热者为火。气者为风。饭食得出入为空。亦余因缘合为人。自计是我身。若欲万物当挍计有身。亦有五因缘共合。一者色。二者痛痒。三者思想。四者生死。五者识。是十事共合。便见生死。事有善恶。行善有二辈。不犯身三口四意三。是为一善。二善者。布施持戒忍辱精进不疑。是为二善。恶亦有二辈。犯身三口四意三饮酒。是为一恶。疑嫉悭贪是为二恶。护身口意是为道行人。从福得生。从行得老病死。身便坏败人卧出时。意离身在地因缘。何以故不死。四事合持未散故。人行十事就三事。人行三事就二事。人行二事就一事。何等十事。谓十恶。便得身口意三事。已有三事。便有名色二事。已有名色。便堕痴百劫。乃得为人难得完具。人生精作地识为种。五道识名异合一识。入一识便失所本。知如人生天上。含人识受入天识。便忘人间事。人从无生。从有死。无何以故生。不识无故生。有何以故死。不识有故死。识无不复生。识有不复死

意有所念以灭。便到所生处。意念不灭。亦不得行生上意。意头起以灭。复更念所念虽多。当还从上头意受因缘。生人本从妇。妇夫不净污露得身。长大便恶知识相随。为五阴六止十二衰所欺。便有老病死忧苦。生死为痴。慧人当断六止。谓地水火风空识。十二衰。谓色声香味细滑念欲。内有匿贼。是为十二衰。人生有三因缘。一者合会。二者聚。三者心意识。痛痒思想生死识。是为合会。诸爱欲是为聚。上头为上。头为心中央为意。后头为识。人初堕母腹中。如鸡子中黄。至三十七日。悉有头面手足指具足。未生四日到向下。人在母腹中。苦不可言。人在母腹中。命日益识日大。身稍老至半年时。身与识日减。得身为福亦为罪。何以故。以得人身是为福。以饥渴寒热贪淫嫉妒为罪。人生子有五因缘。一者有本愿。二者同业。三者晓礼。四者来债。五者偿债。何等为本愿。谓先世时见人子端正。便愿言我子如是。同业者。谓同计挍得利相呼。晓礼者。谓当相敬爱。来债者。谓父母主治生。子横用之。偿债者。谓子治生付父母。是为偿债。子以三因缘生。一者父母先世负子钱。二者子先世负父母钱。三者怨家来作子。父母勤苦求财已致便死。子得用之。是为父母先负子钱。子行求财产已致便死。父母用之。是为子负父母钱。有时子生百日千日便死。父母便忧愁恼。是为怨家相从生

生。子有三辈。一者福子。二者真子。三者不真子。何等为福子。谓父母持戒布施忍辱精进行道。子亦尔。是为福子。真子者。父母不信道。子独奉道教。是为真子。不真子者。父母随道业随法行。子但饮酒作恶。人所不欲见。是为不真子

子从父母生。有同意。有同行。有同念。俱长寿富贵端正。是为同行。贪欲嗔恚。是为同意。精进行道。是为同念。本行在父多类父。本行在母多类母。不同行不相类故。人生堕地未有所知。便喜向其母者。意识本因缘故耳

人来生时有因缘。身能出入无间。至七日便复坏其身。亦有地水火风空。但微难见。人年老少识多忘者。识转稍向后所生处。何以故。不预知当所生处。用未到故。他人生他人来。他人至他人所。他人忧他人所。从来久远习故。不学身有三痛。意亦有三痛。身痛者。谓得刀杖瓦石蹴蹋。二者病瘦。三者死。意痛者。一为忧父母兄弟妻子知识。二为忧财宝怨家。何以故为痛。谓五阴不调故痛。何以故为死阴。熟坏故为死。一切病皆意所作。身无所知故不作是病。是身何以故为病。四因缘不等故。何以为忧。一切不如意故何以不定。病疾过去故。何以为急。要欲坏。何以故为碎。身老毒故。何以为老死。坏故。何以为非常。不得自在故。何以为苦。急故。何以为空。无有主。言我作是如何。以为非身。不能离苦。不得受苦。是为十事

人所欲凡有三事。人之所爱。常欲得之。一者强健。二者安隐。三者长寿。如是复有三怨。一者年老。是强健怨。二者疾病。是安隐怨。三者身死。是长寿怨。亦有三救。一者归命佛。二者归命法。三者归命比丘僧

有四事可畏。一者生。二者老。三者病。四者死。人面赤有五因缘。一者近火。二者饮酒。三者恐怖。四者念怒。五者多惭愧。头白有四因缘。一者火多。二者忧多。三者病多。四者种早白。人病瘦有四因缘。一者少食。二者有忧。三者多愁。四者有病。身未和调有四事不先语人。一者头白。二者老。三者病。四者死。是四事不可避。亦不可离。亦不可却

有四事不可忍。一者饥。二者渴。三者寒。四者热。身复有四事。一者不足。二者不满。三者不饱。四者不厌。身复有四痛。一者生时痛。二者老时痛。三者病时痛。四者死时痛

一切味不过八种。一者苦。二者涩。三者辛。四者碱。五者淡。六者甜。七者酢。八者不了了味。苦增寒热。涩多增风除寒。辛除水。酢除风。令人目冥。食有三因缘。悉入骨髓血脉中。一者肥腻。二者毒。三者酒。是三者皆遍身中无有不到。诸所食饮皆有肥腻。但有薄厚多少耳。人有四种。一者长者种。二者道术种。三者师巫种。四者田家种。生者有四种。一者腹生。二者谓寒热和生。三者化生。四者卵生。腹生者。谓人及畜生。寒热和生者。谓虫蛾蚤虱。化生者。谓天及地狱。卵生者。谓飞鸟鱼鳖

人头有四十五骨。从腰以上五十一骨。四支百四骨。合二百骨。人身有七十万脉。九十九万毛孔。得观悉自见分别知之

有阿罗汉。以天眼彻视。见女人堕地狱中者甚众多。便问佛。何以故。佛言。用四因缘故一者贪珍宝物衣被欲。得多故。二者相嫉妒。三者多口舌。四者作姿态淫多。以是故堕地狱中多耳

阿含口解十二因缘经


宝髻经四法忧波提舍

    No. 1526

    宝髻经四法忧波提舍翻译之记

宝髻经者。是大集中之一集也。其宗四法玄深奥密。天亲菩萨略开其门。是故名为忧波提舍。圣自在力行之。彼古时人处会出于此。今兴和三年岁次辛酉。九月朔旦庚午之日。乌苌国人刹利王种三藏法师毗目智仙。中天竺国婆罗门人。瞿昙流支。护法大士魏骠骑大将军。开府仪同三司。御史中尉。勃海高仲密。爱法之人沙门昙林。道俗相假于邺城内金华寺译四千九百九十九字

宝髻经四法忧波提舍一卷

        天亲菩萨造

        元魏乌苌国三藏毗目智仙译

如是我闻。一时婆伽婆住王舍城耆阇崛山中。与大比丘僧大菩萨众俱。尔时世尊告宝髻菩萨言。善男子。菩萨四种发起精进不离布施。何等为四。一者满足一切众生发起精进。二者满足一切佛法发起精进。三者究竟相随形好发起精进。四者清净佛之世界发起精进。如是四种发起精进。乃至尽此修多罗说

如是菩萨四种正法。大乘经摄诸菩萨行证明说。此今解释。以何义故彼不可量无垢精勤不动最胜坚固精进大力具足如是。世尊而说此经偈言

  世尊牟尼王　　不可量精进
  无垢勤不动　　最胜精进力
  说此修多罗　　为何所饶益

又复何义名为世尊。何所饶益在王舍城。以何义故世尊告彼宝髻菩萨。何故菩萨名为宝髻。彼善男子菩萨四种发起精进不离布施。如是菩萨是何种姓。此义须释。何故发起四种精进不多不少。何者布施几种布施。满足众生发起精进。此应解释。何者众生为有为无。众生若有。一切诸法离众生说云何可避。众生若无。而言满足一切众生则不相应。菩萨布施为当满足。一切众生为不满足。若皆满足何因缘故。一切众生不觉不知。如世尊说彼言龙王。若我四法已取众生。彼诸众生一切皆应知我说法。若不满足自违所说修多罗言

若说满足。一切佛法发起精进。彼说何者名为佛法。又复云何菩萨布施。如是满足一切佛法。何须更说六波罗蜜。若彼布施如是满足。是则无有五波罗蜜。若有六者。自违所说修多罗言

若说究竟相随形好。发起精进相随形好。此义须说何者相好。又复此义世尊已说。若世尊说究竟相好。发起精进尸波罗蜜。佛如是说。若有菩萨悕望欲得相随形好而布施者。当知彼是取着菩萨。以何义故。此中随说尸波罗蜜。彼处则遮如是因缘。此义须说

若说清净佛之世界发起精进。诸佛世界几种清净几种不净。此义须说。又此世尊释迦牟尼佛之世界。为是清净为不清净。若皆清净违阿弥陀庄严经说。于彼经中如来说言

我今出于五浊恶世。阿耨多罗三藐三菩提觉。若不清净。何故此说菩萨四种发起精进不离布施。此义须说。以要言之。何者满足一切众生发起精进如是。乃至何者清净佛之世界发起精进。世尊已说此皆是难

如是第一无垢清净胜修多罗。如所问难彼义今说。此所说法其义云何。以何义故。彼无障碍不可称量。离垢胜慧不可思议。胜身口意第一天人阿修罗众之所供养。寂静胜行不可思议。无等等光已说。此经偈言

  无碍广无量　　胜慧三界上
  身不可思议　　口意亦如是
  天人阿修罗　　众等所供养
  何义故说此　　无上离垢行
  正教佛已说　　寂静第一行
  有不可思议　　无等等光明

此义今说为有疑者断疑饶益。于大会中有天有人。有阿修罗若龙夜叉鸠槃茶等闻佛世尊为菩萨说。饮食车乘衣服庄严。种种珍宝。若马若象。修道之处园林戏处。城邑聚落多人住处。或以洲埏妻子头目手足心皮肉血骨髓上身等分以用布施。闻此说已生于疑心。菩萨几许发起精进。如是种种难行布施。如来观知彼生疑心。断彼疑故为说此经言。善男子。菩萨四种发起精进不离布施。一切智人已说此法。非谓菩萨懈怠布施。是故四种发起精进如是饶益

又复如来何所饶益。而说如是檀波罗蜜施行清净。有人忆念。欲闻佛说檀波罗蜜施行清净。闻已饶益。何人欲闻此。我今说所谓宝髻诸菩萨等。如是大圣菩萨众俱。善应世界而来至此。种种胜妙供养世尊。供养已讫问言。世尊。未知菩萨几种净行。愿世尊说。我今欲闻。世尊说言。善男子。菩萨具有四种净行。何等为四。一者波罗蜜净行。二者菩提分法净行。三者通智究竟净行。四者众生淳熟净行。何者布施波罗蜜净行。彼云何说。彼世尊说菩萨四种发起精进。不离布施如是等如是饶益

又复此义何所利益。此我今说为自利益为他利益。不知自他利益因故。如来示彼自他利因。是故为说此修多罗。一切智人何以故示。有人起发菩提心已。四种发起精进布施。彼人自他利益具足。非唯忆念

究竟相好发起精进。满足佛法发起精进。是故布施得自利益满足。众生发起精进。净佛世界发起精进。是故布施得他利益如是饶益

又复更有何所饶益。此义今说。若有菩萨不学施智。令彼菩萨学施智故。如是饶益一切智示。若有菩萨不学施智而亦行施。得名为施非波罗蜜。如世尊说檀波罗蜜。彼中说言。若人恒伽河沙等劫修行布施不学施智。如是菩萨得名为施非波罗蜜

又复更有何所饶益。此义今说。若有菩萨欲少行施多得果报。以何方便。彼不学人一切智人善方便。学彼不学人。饶益彼故为说此经。一切智人四种示现。以此方便少行布施多得果报。如善方便修多罗说。善方便菩萨少施作广。广作无量如是饶益

又复更有何所饶益。此义今说。若有菩萨离于愿智。令彼菩萨愿智和合。如是饶益。一切智示。菩萨无愿则不布施。又如是愿。我今食等布施满足。愿未来世以无上法布施。满足力无所畏不共法等。如是佛法相随形好皆悉证得。我得善净佛之世界如是饶益

又复更有何所饶益。此义今说。菩萨求于四种具足不学其因。学因饶益一切智示。若汝欲求四种具足。应行四种发起精进行于布施。何等为四。一者众僧具足。二者智具足。三者身具足。四者佛世界具足。一切智示。若汝欲求四种具足。应行四种发起精进行于布施。若说满足一切众生。发起精进得僧具足。若说满足一切佛法。发起精进得智具足。若说究竟相随形好。发起精进得身具足。若说清净佛之世界。发起精进得佛世界具足。如是饶益自他利益故。说此经

又复何义名为世尊。何所饶益在王舍城。此之二难如菩提心忧波提舍。彼说应知

何故菩萨名宝髻者。彼义今说。如是无量无数百千阿僧祇劫。善根究竟得珠宝髻。直十三千大千世界满中七宝。是故彼圣名为宝髻。譬如以手执金刚故名金刚手。如是髻中有宝珠故名为宝髻。三善具足忧波提舍。彼说应知

何故发起四种精进不多不少。彼义今说。以思念因此之四种发起精进。思念饶益具足究竟。彼有何物思念饶益。此我今说自他利益。彼不须多亦不得少。又复思念饶益究竟不得说少。如是四种。世尊已说。譬如丈夫两脚得行更不用多一不得行。此亦如是

何者布施。几种布施。此二种难。三善具足忧波提舍。彼说应知。何者众生为有为无。如菩提心优婆提舍。彼说应知。菩萨布施为当满足。一切众生为不满足。彼义今说。菩萨满足云何满足。菩萨普于一切众生。心皆平等舍一切物普施众生。满足一切众生愿故。菩萨云何舍一切物所有一切内外之物。愿令一切众生解脱清净心。舍乞求人来如自己物自物想。取一切众生平等心故。若菩萨施离彼我过。舍衣食等。布施满足一切众生。若不取者非菩萨过。菩萨心施一切乞者。犹如龙王。譬如龙王一切求者皆悉等与。若不受者非龙王过。譬如龙王兴大密云覆于虚空平等降雨。药草丛林树木生长。陂池悉满。高处不受非龙王咎。如是菩萨平等普施一切乞者。若有不受非菩萨过。满足一切众生愿故。菩萨布施作如是愿。我为满足一切众生无上乐故。种种物施一切生处。我常满足一切众生。是故菩萨作愿布施。一切生处得大富乐。以彼愿力布施力熏。生生处处种种布施。无量众生皆悉满足。离杀生等种种不善是无畏施。一切众生皆悉满足。如世尊说。止杀生故是则布施。一切众生不畏不憎。如是等故如为示现毕竟涅槃。无量众生住涅槃乐。为诸菩萨授佛记已。然后菩萨自取涅槃。如是因缘舍苦得乐。如是满足一切众生

何者佛法。彼义今说。法身依止十力无畏不共法等。此是佛法。彼一切法皆是佛知故名佛法。如彼圣者文殊师利所说偈言

  不思议正觉　　不可量如来
  缘觉声闻等　　所不能测量
  况一切众生　　能知彼如来
  凡夫戏论行　　如来无戏论
  唯佛能知佛　　佛法行依止
  自然身心智　　除佛无能解

又复云何菩萨布施如是满足一切佛法。何须说六。彼义今说。实有六种。以何意故唯说布施。此义今说。此是菩萨善方便意。如善方便菩萨布施。则能满足六波罗蜜。如善方便修多罗说郁伽罗问修多罗说。在家菩萨布施满足六波罗蜜。云何满足。所谓菩萨异异种物。彼彼求者皆悉施与心不分别。如是名为檀波罗蜜。依菩提心修行布施。如是名为尸波罗蜜。于乞求者不嗔不动。如是名为羼提波罗蜜。若布施他我何所用。无如是心有如是力。如是名为毗梨耶波罗蜜。若有来乞若施施已。不热不悔自心喜乐善意心生。如是名为禅波罗蜜。若布施已。于一切法心无所得不望果报。如彼黠慧无有少法贪着喜乐如是不着。唯愿阿耨多罗三藐三菩提。如是名为般若波罗蜜。如是满足六波罗蜜。以要言之一切具足。又如世尊大乘经说无量具足。如是一切皆此中摄。又住大地诸菩萨等。有如是意。彼住大地诸菩萨意。布施满足一切佛法。又复对治诸众生故世尊说法。或有众生以布施门。为说满足一切佛法。或有众生乃至慧门

又复为示菩萨愿故。菩萨满足乞求者意。作如是愿。如我满足彼求者意。以此善根。愿令满足一切佛法。如是说者。则无有过

何者相好。彼义今说。三十二相。所谓手足皆有轮文善安平住。手网缦指手足柔软。七处平满指长身宽。正直大身。项则如贝身毛上靡。因尼鹿踹髀平臂平。阴马王藏。皮妙金色。一孔一毛。眉间则有白毫显面。师子上身肩前后圆。其背平正味中上味。身体圆满如尼拘陀顶上高圆。修广长舌妙梵音声。师子颐颊齿则鲜白。齐平而密有四十齿。目睫绀青牛王眼

八十种好。隆赤腻甲圆指锦文。脉深不见。手足踝平骨节坚密。二足趺平足下文长。手足平正文深腻润。舌次第语唇色赤好。如频婆果不高不下。舌赤软少白象王舌。雷吼云声善美音声如文殊响。满足众好两臂平等。身体净洁衣裳亦尔。普身柔软众分皆等。次第善密身分分善。分分宽博善坐圆满。舌正美言语论次第。齐舌皆深行密仙王普皆可喜第一善净。离闇电光普遍光明。师子牛王龙王鹅步右旋转行。舌不长短舌则圆美。腹胁不卓离于恶欲。身无黑黡无有垢恶外圆而利。又不前却高隆而净无有垢秽。笑微而缓。目如青叶居婆罗耶。笑则如法眉面处所次第相应。眉正不邪不少不多。皆悉离过不可毁呰皆不可嫌。诸根善胜额中善满第一可喜。面额相类上身平满。不白不黑有种种香。不坚不浊次第善紧。胜妙文章有难提旋跋陀摩那。应量身形发顺不乱

佛何以故。此中教示相好究竟尸波罗蜜。彼中便遮此义。今说初业菩萨忆念相好。悕望欲得。饶益彼故。方便教示。彼未久行故。爱相好舍离饶益。悲心布施相应饶益如是故遮。又复若人贪着妙色究竟相好。悕望忆念。为彼人遮。若有众生成熟饶益彼须教示。此有众生见如来身相好庄严。发菩提心故如是说。如转女身修多罗说。又复未发菩提心者饶益教示。又复久发菩提心者。空等相应饶益故遮。又具福德满足饶益。是故教示智具。满足饶益故遮。又求世尊相随形好满足究竟。取着故遮。又复贪着喜乐等过。寂静饶益为彼故遮。如是因缘此经不遮。诸佛世界几种清净几种不净。彼义不说。彼不清净。要有二种。何者为二。一者众生相。二者行相。众生相者。谓众生过言。行相者所谓行过。彼众生过恶行。众生依止种种虚妄诸见。彼行过者。坑坎堆阜蕀刺等过。如是地多食饮衣服宝等受用皆不具足。如是相对众生功德。行功德故世界清净。彼复菩萨无量种种愿力自在。应如是知。诸佛世界功德无边。菩萨愿力自在无边发起精进是亦无边。如是种种不可尽说。又此诸佛世界清净唯说少分。余者应知。如世尊说。有十二种诸功德场和合聚集彼清净觉得佛世界。何等十二。一者劫场和集故。得以功德场皆究竟故。二者时场和集故。得以法行等不过时故。三者众生场和集故。得以法智故。四者世界场和集故。得以善净故。五者调御众生场和集故。得以无[革*必]故。六者乘场和集故。得以一行故。七者陀罗尼场和集故。得以无余物故。八者佛法场和集故。得以无一切外道法故。九者功德场和集故。得以不谄故。十者直心深心场和集故。得以本性净生净众生处净故。十一者圣场和集故。得以不离福田故。十二者道场和集故。得以乘前佛所乘来故。又此世尊释迦牟尼佛之世界。为是清净为不清净。今说清净。何以知之。以世尊心善清净。故。若得有人心不清净故。见此佛世界不净。依彼意故。世尊说言。我今出。于五浊恶世。阿耨多罗三藐三菩提觉。知无垢称修多罗说。菩萨欲得净佛世界。当净其心。随其心净佛世界净。尔时慧命舍利弗。承佛威神作是疑念。若菩萨心净佛世界净者。今我世尊释迦牟尼。行菩萨时意岂不净而佛世界不净若此

尔时世尊以知慧命舍利弗念而问之言。舍利弗。于意云何。汝舍利弗勿作是念。日月岂不净耶。而盲者不见。慧命舍利弗言。不也世尊。是盲者过。非日月咎。佛言。舍利弗。众生如是。无智罪故。不见如来世界清净。非如来咎。舍利弗。我此世界常自清净。而汝不见。尔者蠡髻梵王。语慧命舍利弗言。大德舍利弗。仁意莫谓此佛世界为不清净。今此世尊释迦牟尼世界清净。慧命舍利弗问梵王言。此佛世界云何清净蠡髻梵言。大德舍利弗。譬如他化自在天宫庄严殊妙。我见世尊释迦牟尼世界清净功德庄严亦复如是。慧命舍利弗复言梵王。我今唯见此佛世界。丘陵坑坎蕀刺沙砾。土石诸山秽恶充满。螺髻梵言。大德舍利弗。仁者如是心有丘陵坑坎等秽。信不清净故。见此佛世界不净。复次大德舍利弗。若有能于一切众生心皆平等深心清净。则见此佛世界清净。尔时世尊足指按地。即时三千大千世界。无量百千不可计数功德珍宝具足庄严。譬如宝庄严佛无量功德胜妙珍宝庄严世界。时此三千大千世界亦复如是。大众皆见叹未曾有。而皆自见坐宝莲华。尔时世尊告慧命舍利弗言。舍利弗。汝今为见我佛世界无量功德胜庄严不。慧命舍利弗言。我见世尊。本所不见。本所不闻。今见世尊不可思议庄严世界清净悉现。佛言。舍利弗。我佛世界清净如是。下劣众生见不净耳。舍利弗。譬如诸天共宝器食。随其业力饭则不同。如是舍利弗。众生共生一佛世界。若心净者。则见世尊世界清净。我今以此修多罗量故说清净

以要言之。满足众生发起精进。一切众生等心示现。满足佛法发起精进。自证示现。究竟相好发起精进。此则示现。普贤依止清净世界发起精进。一切众生富乐示现

又复有义。初如厌病。二如闻药。三如悕药。四如病人所居舍宅。又复示现。初大悲力。二示智力。三身心力。四者直心深心修力。如是示现

又复有义。初说不舍一切众生。二者得力。四无所畏不共法等一切佛法。三者得身着不可嫌。四者得佛无上法王相应世界

又复有义。满足众生发起精进。檀波罗蜜毗梨耶波罗蜜为示现故。满足佛法发起精进。般若波罗蜜智波罗蜜故。究竟相好发起精进。羼提波罗蜜方便波罗蜜故。净佛世界发起精进。尸波罗蜜。禅波罗蜜。如是示现

宝髻经四法忧波提舍一卷


大宝积经论

    No. 1523

大宝积经论卷第一

        后魏北印度三藏菩提流支译

  归命世间救　　苦海度彼岸
  大悲降魔怨　　我释宝积经
  庄严十六种　　真实微妙义
  欲令法久住　　自利利他故

问曰。汝欲释宝积经。应先释此法。问以何义故。名为宝积。答曰。大乘法宝中。一切诸法差别义摄取故。所有大乘法宝中。诸法差别相者。彼尽摄取义故。名曰宝积。一聚。二积。三阴。四合和。义一名异。是中一切大乘法中。如来为诸菩萨。十六种相差别说法。何者十六种相。一法邪行相。如是菩萨行邪行已。名为行邪行相。二正行相。如是菩萨行正行已。名为行正行相。三行正行利益相。菩萨住正行已。名法行等行善行。四行法行诸相差别。五于诸菩萨所生慈心相。为令生敬重心行说相故。六菩萨住正行学戒相故。七声闻戒与菩萨戒中。说优劣胜如相故。八菩萨善学菩萨戒已。能与世间智等。饶益他行。差别相故。九受彼菩萨藏时。教修声闻戒相差别。十不善学沙门相差别故。十一不学沙门相差别故。十二住假名行相差别故。十三住真实行相差别故。十四如来方便化度众生相差别故。十五说微密语相差别故。十六于菩萨藏中得教诲已。善信有益相差别故。大乘经中。如来为诸菩萨说如是等十六种相差别法故。彼法门中。此一切诸相现所说故。彼大乘法宝中。所有诸相尽摄取故。此妙法门名为宝积。问曰。云何彼大乘正法宝中所有诸相。而此法门中所摄取成。答曰。迦叶有四法退失智慧。如是等黑朋所摄八种四句。摄邪行相差别故。迦叶菩萨有得四大伏藏。如是等六种四句所摄。正行利益相差别。如是此诸二十二四句。具说染净退益之事。迦叶。名菩萨者。非但名字名为菩萨。如是等有三十二种相差别。应知。迦叶。菩萨功德无量无边。我当以譬喻演说如是十九喻。所明诸相差别。应知迦叶。菩萨欲学此大宝积经。乃至其灯明者圣慧根是。其黑闇者诸结业是。是名住正行中摄诸戒相差别。应知。迦叶。譬如种在空中而能生长者。从本以来无有是处。乃至能出无量百千声闻辟支佛报。如是等明声闻戒喻。菩萨戒中。胜劣相差别摄故。应知。尔时世尊复告大迦叶言。乃至从本以来毕竟净故。如是等摄取世间出世间智。饶益他行事差别相。应知。迦叶。汝等观内莫外逃走。乃至出家人有二种病。何等为二。一者怀增上慢而自伏心。二者坏他发大乘心。如是等摄取受彼菩萨藏时。教修声闻戒相差别。应知。迦叶。沙门沙门者。以何义故名为沙门。复云何沙门。迦叶。有四种沙门。乃至如是普明。是名菩萨速疾法通。如是等摄前三种沙门不善学沙门相差别应知。尔时尊者摩诃迦叶白佛言。世尊。希有希有。此大宝积经。行大乘者而能作利益。乃至读诵受持书写此大宝积经。彼人即供养一切诸佛。如是等于菩萨得教授已。善信有益相差别摄故。应知。如是大乘中所说。十六种诸法相差别摄取故。此法门名为宝积。应知耳。佛住王舍大城。问曰。何故初明住处。答曰。佛住此处者。欲令敬重彼处故。重福众生敬此处故。增长善根。是故先明住处。问曰。何故此法唯王舍城说。非余城郭。答曰。释此法门法王住处故。喻如王舍王所止住。故明王舍。此大法门亦复如是。法王住处。释成此义故。说住王舍城。问曰。何故唯在耆阇崛山非余方中。答曰。说此大乘法。比于声闻缘觉乘中增上义故。增上自利利他行故。与大比丘众八千人俱。菩萨万六千人俱。问曰。既因菩萨明此法门。以是义故。应说菩萨大名称众。说声闻众有何义也。答曰。说声闻众。若有声闻于大乘中所有疑心。为除彼疑故。若有不定助成正信。若有自谓得清净者。为欲舍离彼净心故。复有声闻。谓尽诸结于佛法中无复所修。所谓灭诸烦恼等障。心生逮得己利。为欲舍离彼慢心故。此法门中。为诸菩萨说烦恼障灭。因彼烦恼障及灭智障。亦非余所说。胜于声闻缘觉中得上果报。问曰。声闻众数。此诸菩萨从何而至。答曰。未来世中有疑惑者。为令除彼疑惑故。经家所说。从他方诸佛国土而来集会。问曰。何故说言皆得不退转也。答曰。皆得不退转者。已得具足四忍故。一生得者。闻说此法堪为器故。问曰。是诸菩萨从他方诸佛国土而来。此土成有何益。彼世界中是诸如来各自说法。答曰。为益众生故。此世界中亦有众生。彼诸菩萨本所化受。既见本同修诸行故。是则乐见。及本所化诸菩萨法。以复受是行。余方亦有无量诸佛。为令生渴仰敬重咨请亲近之心。说无量佛故。令诸众生生堪得心起勇猛精进不生疲惓。复是释迦如来本所化故。忆本化度。修诸愿行事。从他方来亲近如来。问曰。何故明菩萨多说声闻少。答曰。说菩萨众多者。此法门中所辩诸行。彼尽因为诸菩萨说。问曰。何故先说声闻众。答曰。因彼加持所说法故。问曰。何故说言从他方来集会。皆得一生者。说懈怠我慢故令不生。往求于正法。对治此患故。言自乐法故。从他方来集会。不为顺他心故。释成远来诸佛世界中。此诸菩萨已得佛位。尚为法来。况于余者云何不来。问曰。如来何故。但对迦叶说此法门。不对菩萨。答曰。如来告大迦叶时。知堪能说故。唯未知觉复未正信。以释成堪知觉信大乘义故。是中邪行所摄。八种四句。上上相释渐次应知。第一四句。说退失智慧邪行相事。第二四句。退失智慧已忘于正念。第三四句。灭正念已令灭白法。第四四句。灭白法已。似非菩萨行恶心相。第五四句。行恶心相已难调伏故。第六四句。难调伏已行于邪盗。第七四句。行邪盗已。不应亲近而能亲近。第八四句。不应亲近而能亲近已。令不助菩萨行成于邪行。对治此故。正行所摄亦有八四句。上上相释渐次应知。第一四句。说为满足助道智已令不忘正念。第二四句。令不忘正念助道智增长故。第三四句。不忘正念已增长白法。第四四句。增长白法已。行似菩萨心想行故。第五四句。行不恶心事善调伏故。第六四句。善调伏已行于正道。第七四句。既行正道已。应亲近者而能亲近。第八四句。应亲近而能亲近已。令随菩萨所行诸行成于正行。先所说正行利益。有六种四句。上下相释渐次应知。第一四句。菩萨如是多行正行已。习成福德智慧。第二四句。依功德智慧习成已。令得障净。第三四句。依障净已。令一切法门助习通达一法门故。第四四句。依习一切白法门已。一切相一切种。利益一切众生故。复修行无量功德。第五四句。既修行无量功德已。令过无明住地。第六四句。依过无明住地已。令得无障碍地。是名此诸二十二四句之中所说渐次。自此已后。还彼前四句次第解释说。应知。经言。迦叶。菩萨有四法退失智慧。问曰。以何义故发此说。答曰。修大乘者。为得无上菩提方便故。愚痴者为令示现故。放逸者令正劝故。怯弱小心者。令助慰喻使发大意故。已行正行者。为令赞叹故。问曰。明四法者。此数无义而说自体明故。答曰。四算数者说摄取义故。广不可尽。伏防听者不乐多闻故。以数摄故。令忆持则易。如绳穿华不使零落故。问曰。何以故。唯定四。不多亦不少。答曰。遮无穷及无义问故。复有喻者。退失三种助智摄取故。明四数。复有余者。略说有三种智慧。闻思修等。是中前三法。多示尽失助闻慧智。故第四法者。多明尽失思修慧等。是故说四法。次者是诸法中示相近渐次差别解释义。佛告迦叶时。劝令听众。听众之徒。一心不念余缘听故。法者舍于人故言听法。若不言法者。容有生疑。为欲说法为欲说人。问曰。先言菩萨者。以何义故名为菩萨。答曰。行大乘者。此菩萨名为摄取多义。然今略说三义说。应知。一者信。二者修行。三者证。云何信。觉知甚深智慧而能令觉故。云何修行。为自利利他因故。往行无上菩提。云何得证。以智慧力故。令得证无上菩提。退失智慧者。明二时有二种失。一已得失。二当得失。何者退云何失。于无漏中失当得。余者世间故。二时俱失。不甄说退失智慧故。问曰。无漏亦失。答曰。解释不尔。说退失智慧者。欲明不放逸因。于所作事中令作法故。言退失智慧。何以故。有漏智者。与无漏智助道因故。是有漏智得已。未得二故便失。无漏智失者。以不得故。既证无漏智则无有退失。问曰。云何不尊重等法。令能退失智慧。答曰。嗔恨故不敬。不敬故不闻。不闻故不生解。以不生解故。即现退失智慧。吝惜诸法。所受诸法秘不尽说。故不闻。不闻故于未来世中众缘不具。缘不具故退失智慧。有乐法者为作留难。说诸因缘沮坏其心。说有余言。所犯覆藏不能悔过等故。得闻障报已。闻障报故得愚痴因。是故未来必得愚痴。以愚痴故退智慧。其心憍慢自高赞己。卑下他人故令恨他。以恨他故即为倒说。已颠倒说故。于未来世中招倒。以招倒故退失智慧。问曰。何时退失。答曰。二时中现及未来。问曰。若布施等诸法亦是退失。因有吝等诸法者。何故但说唯退失智慧因。不说布施等退失因也。答曰。易失故先说。菩提是智性故。诸余波罗蜜者。从彼智所生。智依止故。菩萨于智中邪行已。即于菩提及助菩提法中。不名正行。是故但说退失智慧因。不说布施等退失因。如是不敬等法。退失智慧因。四句显说不乐闻等四法。是中不敬重故。显说不乐闻吝惜法故。不闻障他法故。得不闻障报。我慢故。姤心倒说。如是不能助闻等智退失意。此四法已以复有余智相。谓生于四悔法。现及未来。何者四法。一不能生解。二众缘不具。三助愚痴福报。四及已颠倒故。依不闻故。于现法中不生正解。依不闻故。于未来世中众缘不具。依闻障故。亦于未来世中得愚痴报。依姤心倒说故。未来世得颠倒报。问曰。不尊重敬法及不敬法师者。此二句重说有何义。答曰。此二句重说中。显示具足不乐闻意。设有人嗔谤不敬法故。不闻其法。敬重法师故乐听闻法。复有嗔恨。不敬重法师故。不听闻法。复有嗔敬重法故。能乐听闻法。若二俱嗔恨谤不敬重者。彼众无方而能听闻。是故此二句重说。示现具足不乐听闻法意。吝惜诸法所受诸法秘不尽说者。此二句有何义。吝惜诸法。见既于他所知解中胜故。即于法中秘不尽说。护得后不敬防畏胜故。或复有义。若请不请一向不说故。吝法者。或有向说。或复不说。或复吝法故弃舍正法。已舍法故即坏其心。所受诸法秘不尽说。起吝惜心行故。说言坏行。有乐法者为作留难。说诸因缘沮坏其心。说有余言。所犯覆藏不能悔过。如是等句有何异义。是中有乐法而作留难者。此是说有余言。云何乐法者而作留难。说诸因缘沮坏其心。呵责说有余言。所犯覆藏不能悔过。云何沮坏人法并说诸恶。所有法从人所欲乐听闻者。彼法及彼人。已无实言及无义者。而言能种种说。既说已即令不复乐闻。云何说诸因缘呵责等。所说不正复言无限。或复乐闻者。为助种种难访无限等言说。闻难访等。即便不听亦不乐闻。云何不能为说教故。复请而不受。有他乐法者来请问说法。已吝惜法故即不为说。复不请余法师等。若欲请闻不为许可。云何覆藏。说其听者及呵听众。亦说彼法。汝等无智此法甚深不能通达知故。已说听众故覆藏正法。如是障法因缘。令得难处果报。其心憍慢自高赞己卑下他人。如是等句有何义。憍慢者说初句。云何憍慢。若赞己为胜毁谤于他。云何赞己为胜。自所说不善修行不正。见他所说皆善修行亦正。于中起慢妒心。云何毁谤于他。若他善说善修行中。生不善说不善修憍慢妒心想。已憍慢患故。令不能得证正觉智慧。诸法尽证所摄。此要略而说。一唯所退失。二如何退失。三以何时失。四所有既法退失。彼尽显示。何处退失者。于智慧中如何退失。以何想退失者。失已解释。何时退失者。现在及未来。所有既法而退失者。明不敬重等四法。已有此不恭敬等四法。能令退失智慧等。法障故。说四对治法。复次迦叶。菩萨有四法成大智慧。何等为四。所谓尊敬重法。及敬法师等。菩萨顺行此敬等法因故。得与大智因故。生四种智慧。何等为四。一者起。二者成熟。三者满足助道。四者能为成菩提。然彼恭敬故。乐听闻法。既闻法已便得起发智慧。随所闻读诵受持诸法。以清净心广为人说。而不求一切名闻利养恭敬等事故。令得化他成熟心智。善知智慧从多闻生。精进不懈怠。如救头燃。闻法诵持乐如说行。不随言说常求多闻。闻则忆持不忘故。令得满足助道智行其实行。行不随言语及已音声。为实行故。令能得成菩提智慧。是中尊敬重法。及敬法师者以不敬重故对治说敬重。应知。随所闻诸法读诵受持。是中闻者以耳识故。诵持者以意识故。或复闻者以闻慧故。诵持者以思慧故。经言以清净心广为人说者。以离悭妒嫉心故。不求一切名闻利养恭敬等事者。是则吝法因故。利养者衣服等。恭敬者礼拜等。名闻者称扬诸功德。以多闻故堪得闻慧等智。已如救头燃修求闻慧。为求闻慧故。劝转明修慧。譬如有人或燃头或燃衣。彼人舍一切诸事。先救头及衣服。菩萨亦如是。知闻慧是智因。智者乃至亦能得一切智因故。转勤求闻。为自利利他故。随所闻法而能诵持。及如说行者。若随闻而能取义者。彼已顺行故

则能生如顺智。非如但有音声语言者。非如但求闻。非但口说。或复无义故。或复所说皆无出世之益。顺次解释不尊敬重法及行顺法已。成吝惜诸法。吝惜法已。于乐求法者起诸障碍。秘不为说。彼灭此三种智因。已无智故则起我慢。自法对治尊敬法者。已顺行法及次法故离悭吝惜心已。随所闻法广为人说。好乐法故求多闻记。具多闻已。即能行自利利他之行。随说修行不着语言。语言音声等事。菩提心者。唯智根本。一切智者。唯菩提心为本。是以不忘菩提心故。忘菩提心及已不忘诸法因故。佛告迦叶。菩萨有四法忘失菩提心。何等为四。欺诳阿阇梨等。问曰。何故但说有四法能忘失菩提心因。不多不少。答曰。忘失有四种故。略说有四种。一不正信忘失。二信颠倒忘失。于菩提心中见有过故。三所受诸法。皆是假名心故忘失。四得法体心忘失。此四种忘失中。对有四种因。如是次第。应知。是中欺诳阿阇梨师长等者。于师长前不能如实语。既犯罪不发露故。妄语心诳故。即成欺诳师长。是中阿阇梨者。能谏及劝指授。随彼所犯为令发露。此不应作。先所犯罪为欲忏灭故。说诸方便。汝应如是作。师长者若能助益。长秀圣者。虽非师长已有诸功德故。怜愍与乐劝止恶修善。为既犯故。令彼以妄语忘失。以是义故。助得增上业报。已助得增上业报故。成不正信忘失菩提心。应知。若彼不能令忘失者。如是彼已习妄语。及得戒障故。忘失菩提心。是名初因。无疑悔者令生疑悔。同修梵行中无疑。能令生颠倒疑故。同梵行中正修戒行者。于戒中令起疑惑故。彼如是同梵行中。不至心恭敬。及行谄曲心。能于戒中生疑惑故。生深重业障。彼以是故。于菩提心中颠倒。不正信见过故。忘菩提心。彼若不能令生疑惑者。如是彼已谤说故。令忘菩提心。是名第二因。修大乘人。呵骂诽谤广彰恶名。乐修法者。随所有法利。彼能令远离背故。若有信乐修大乘者。为欲坏彼故。呵骂诽谤广彰恶名。说不善言破坏。说无利益。无利益语。是中不善语者。说恶名响彰其诸过。所谓破戒。发言说谓恶。广彰人短谓非梵行。分别说者不称功德。随彰其说恶。有如是等事。彼如是向诸菩萨说无利语。分别广彰恶名等。若欲修大乘者。如是等令退迷惑。彼如是向诸菩萨心不恭敬已。所有功德则便覆藏。已覆藏故令恶深重业障。以彼障故。本所修戒心即便灭坏。若使不能覆藏菩萨真实功德者。彼如是以得戒障故。退灭其心。是名第三因。以谄曲心与他从事。非真实心者。欲为诸法师开彰诸秘密之事令生迷惑故。是中谄者。以虚伪无有实心而与从事故。曲者以心谄诳非真实心。与人随顺。为欲诸法师开彰说行诸秘密之事。从诸法师所。闻深密微妙法已。若有修行大乘者。为彼能起诽谤意。作如是意已。令助无量恶业。以有彼业障故。应得顺法心而成远离退失。若不能诽谤远离者。彼以如是故。于戒障中心得退失。略说以何退失。所谓心何时退失。现法中及已未来行中。如何等行。于师尊长中不正恭敬等故。有何等相。具四法故。彼以显说对治彼故。说四善法。应知。经言菩萨乃至失命因缘不故妄语者。护治实语故。以不惜身命故。何况戏笑者。菩萨于微轻罪中生大怖畏故。常以真心与人从事者。以离无我谄曲心故。是中真心者。实心随顺亲近故。离无我患者。菩萨如实亲近。不示假名行离谄曲。远离不调伏恶心故。于一切菩萨生世尊想。能为诸菩萨。于四方中称扬功德者。随所得法利彼常赞叹故。自不爱乐诸小乘法。随所化众生。令彼一切住阿耨多罗三藐三菩提者。不乐狭小乘。己劣弱故。既得上义行所摄取化意欲故。此诸句渐次重释。欺诳阿阇梨等。复不供养恭敬阿阇梨师长等故。于戒法中不生殷重速疾之意。自无惭愧悔过。见他有惭愧悔过者。为令恼故。助不安乐心忧恼彼。己无惭愧开令悔故。于修大乘人中说诸恶事。以谤菩提心所起。诸利益他心无故。以谄曲心与他从事非实真心。复有不失诸句渐次重释以实语不忘菩提心集因故。不失菩提心。所起众生饶益故。自身中所有无量希有诸法。知已敬菩提心。及一切智因故。于菩提心并一切菩萨所。起世尊想已。敬菩提心故。所化众生彼一切劝令向阿耨多罗三藐三菩提。不喜乐求行狭劣小乘之法。菩提心者。是菩提应义。问曰。若是菩萨初发心者。我当成于正觉。彼心有何等性。复有何相。有何等念。有何功德。有何胜事。以何所摄。为谁根本。是谁现气因。谁所依止。答曰。初正愿性。岂欲求相菩提。为念及念众生。以一切智因无量功德一切世间声闻缘觉愿中上故。为胜信地所摄无上菩提根本。慈悲现气因。菩萨戒所依止。然是发菩提心。略有二种。一者出世因。二者不出世因。是中出世因者。若发心已永遂不忘。是名出世因。不出世因者。若心不永遂中忘彼心。退亦有二种。一者永退。二者不永退。是中永退者。若有数退而复能生。不永退者。若退已即生。然彼心以四种缘四种因及四种力而能生。何等四种缘。一者见闻如来希有变化故。发菩提心。二者因于无上菩提。以闻法为怜愍利益众生故。发菩提心。三者菩萨为欲正法久住故。发菩提心。四者见末世众生受诸重苦故。发菩提心。何者四种因。一者具性故。二者具善知识故。三者慈悲为首故。四者不惊怖世间长夜。种种深重有闻等因故。何等四力。一者自力。二者他力。三者因力。四者修行力。是中自力者。以自力故。堪乐欲发阿耨多罗三藐三菩提心。是名自力。他力者。以他所劝令发心。是名他力。前所习大乘善法者。是名因力。现在法中亲近知识。长夜之中闻思等正法习行善不息者。是名修行力。是中若广略。此四缘及四因借故。若使内自力及以因力。具此二因生彼心者。如是故名为有益。名坚不动而生。他力修行力生彼心者。名为不应动失。应知。彼心退转相。亦有四种。无性故恶知识所摄。于诸众生不起悲愍心。及恐怖世间故。不忘菩提心。菩萨还忆持彼菩提心故。能修行功德智明。助道所摄善根法中。彼如是修诸行已。善法灭不增长因故说诸法。经曰。佛语迦叶。菩萨成就四法。所生善法灭不增长。何等为四。但以憍慢心读诵世间经典咒术。如是等。问曰。何故唯有四法明因能灭善法不能增长。不多亦不少。答曰。善法有四种。灭不增长故。此略有四种善法灭不增长事。一者不生灭不增长。二者不能增长灭不增长故。三者除拔根本灭不增长。四者作及远离灭不增长。是中不生诸白法灭因者。以我慢心故。读诵世间经典求诸咒术。不能通达菩萨六波罗蜜。及菩萨法藏。菩萨以我慢心降伏故。悕望名闻利养。妒胜憎他常诳故。求于世间咒术。不能求善白等法。已不生诸白法灭尽故。能令尽灭及先所得者。以缘事故闻习转弱故。是不增长灭。何以故。贪着利养名闻故。亲近诸檀越。是中利养者衣服等。供养者礼拜等。着于利养名闻故。说着利养名闻耳。以着利养名闻故。受于邪命资养等显说应知。以亲近檀越家故。多有亲近中诸患。若彼有如是二疑助成者故。说以如法得财利养。以为不灭因。以依谄曲等意故。不住圣处。彼如是著名闻利养。亲近诸白衣家故。以多缘亲故。闻等善法不能增长。闻等不增长。已闻等诸善法悉不增长故。令尽义便灭根本因故。及增谤菩萨。已恶见还增。及谤菩萨法藏。己嗔故于诸菩萨觅诸错谬等患。令为诸菩萨以虚实等罪谤故。令得大罪。以此罪业因缘故。所有善法从根本拔除远离灭尽。远离灭因故。未闻未曾受持诸修多罗法。而能诽谤。未闻者未至耳识道故。未曾受持者。虽至耳识道不诵持。诸顿说教及诸修多罗法谤。以是义故。如来说此修多罗。大阿波提舍中亦说此义。若有邪师。能测量如来意者。彼人得大毁谤正法之事。是故彼远离诸尽法故。诸白等法令灭。颠倒对治故。明此白等法句。应知。是故如来告迦叶言。迦叶。菩萨成就四法。所生善法转胜增长。不令有失转复倍胜。何等为四。舍离邪法唯求正法。如是等。是中唯求正法者。六波罗蜜菩萨法藏所说。正闻非不正闻。所明世间咒术等。不定闻现事故。言非不定闻。复是随如劝心者。柔软善心故。显示何意。求世间语言咒术等。求因故。着我慢者。成世间咒术等事。求世间咒术。语言者。成舍利养恭敬名闻之心。令舍故言求六波罗蜜及菩萨法藏耳。以法财利养为足。舍离一切诸邪命等。及安住知足圣主性中者。以法利为足。如法所得利养心足故。舍离一切诸邪命等者。远离诸谄曲等心故。安住知足圣主性中者。不生疲倦心故。得失不以心故。彼如是行之。正行已。为成自利利他行故。防护他心。若有失事不谏向人罪过虚实。何况觅人长短诸过。是菩萨修行六波罗蜜菩萨法藏。以于诸佛法中心不通达。是中唯佛为现作证故。不生谤心。何以故。佛菩提无边及所信根非一故。演说诸法亦治诸法。总略而明。以何退失不能增长。如何退失。以何时失。及何等法。彼以显说。以何退失不能增长者。谓诸善法。如何退失者。以我慢心求世间语言咒术等。渐次说。以何时失者。现法中及未来。何等法者。具足四法。白朋中亦尔。所有善法生及如何生以何时生。及何等法生。以何对治说。复此诸法。渐次以何我慢所摄。诸利养等。希望求世间语言咒术等。求以随所。家中见利养者则能亲近此家。身为利养名闻被缚。妒吝心故。因彼家所有余菩萨亲近者。为令起嗔。及以恶谤。因嗔谤彼人故。则谤正法。白朋法中。渐次明离慢等诸患故。六波罗蜜所摄。菩萨修学正闻故。能行顺法。行顺法已如法得施以为知量。舍离一切诸邪命等。安住知足圣主性中。以着利养名闻谤因缘故。不说他人罪过。实以不实不求人短。离谤菩萨心故。能行利益如法等事。行如法行故。不谤正法。舍离灭诸白法因诸法故。修行不灭诸白法因。已舍离似非菩萨随一一相习行恶心等。修行似菩萨直心修相。习诸行故。为令劝故。明显生灭苦。不行诸恼等行故。佛语迦叶。菩萨有四种谄曲心。菩萨常应舍离。何等为四。于佛法中心生疑悔不决了。如是等。问曰。何故唯说四法。答曰。为因四种谄曲等法故。以有此四种谄曲心故。说四谄曲应知。何等四。一者于乘谄曲。二者化受谄曲。三者助功德谄曲。四者助智谄曲。是中乘谄曲者。于佛法中心生疑惑不决了等。及不敬尊。复不敬诸戒等法。于佛法中生疑惑等故。诸大乘中生不信默然行。是中于诸佛法中。以有故生疑。以有大意德故生惑。以其不可得故。生不决了等事。化受谄曲因者。于诸众生起憍慢嗔恨妄想等。以慢等心故。化诸众生中恨默故。不能化导憍慢嗔恨妄想等。于诸尊及弟子并劝谏。有益无益等中应知。助功德谄曲因者。于他利养中生妒吝等心。是中见他得利养。心起忿恼嗔意妒。若见彼求而起惜心。是名吝。彼如是既起妒吝心炽盛故。于助功德智中恨不修行故。诸功德智即便退失。助智谄曲因者。于诸菩萨广彰诸恶。恶名恶称恶行等。说恶名等事前已解说。为诸菩萨说诸恶等句。为说大乘经应知。以谤大乘故。菩萨于助道智中。默住懈怠不修行故。修道智中成于退失。以为此故说朋应知。谄曲对治故。佛语迦叶。菩萨有四质直之相。何等为四。所谓所犯诸罪终不覆藏。如是等。是中所犯诸罪终不覆藏者。是总向他发露者。发露事故说者。有犯能忏悔故。彼如是忏悔。是以后时不生悔恨等情。发起善故。或失国土或财者。以真求实故。示现不惜诸施等故。身命难者。以舍离身命。不依止余种种不举余事。舍彼事已令惑人故。忆余事故。一切恶事中。骂詈诽谤挝打系缚种种伤害。受此苦时。但求自责自忆业报。不嗔恨他。此诸句有何异义。是中骂者说虚妄故。嗔者虚实俱说故。于他苦者已说种生姓等。说诸恶事故。诽谤者。以因实见彰恶故。挝打责数者。于身中具诸缘故。责数者。具三业故。复挝打者。以手足等诸身分故。杀者依身手等及刀杖等故。系缚者。以绳索锁等。如是等事中。唯责己之业报。善恶业报因故。不嗔恨他。心不怀嗔恨等。及无诸结使。不怀嗔恨结使。彼善坚住信欲之中。设使有不可信诸佛法者彼能信。以心清净故。显说于大乘中身心成就。此诸句渐次说。于诸佛法中以疑心故。不修戒行故。令诸众生中行诸邪行。行邪行已。彼利养中即生悭吝妒心。以不能制妒心故。见闻有功德利养诸菩萨。中起诽谤广彰恶名。白朋法中。渐次亦作依持戒故。善持戒者。善护谛语。护谛语者能顺忍法。以具忍故得身心清净。以清净身心故。能信诸佛正法。略说谄曲者。是名心愧。恒事何处谄曲。于诸佛法中及以众生。以何时谄曲者。现法中习不舍故。亦至未来随所有法。及随所说二种四句。随所有真直之相。以何义中复以何时。有记等法对治明于白法。应知。于诸谄曲心中。诸菩萨谏及以诸真直心。菩萨说真直心已。为真直心菩萨。说诸调伏义故。防谄曲法故。劝彼调顺。现示调顺及不调顺等法故。佛语迦叶。菩萨有四种不调顺散坏之相。何等为四。读诵经典而生戏论。法及顺法不随而行。于诸教诲中不调散坏。如是等四法。何故但说四法。有四法。有四种不调散坏因故。何者不调散坏四法。一者处不调散坏。二者发行中不调散坏。三者受用中不调散坏。四者共住不调散坏。是中不调散坏者。名为不善调伏故。喻如恶马。此诸不调散四法。能障修彼菩萨行故。名为不调散法。是中闻诸法及修行处而生戏论者。是名处不调散坏因。喻如不调散恶马。以不调故。还安本处已。尔时不能善住。复不能调伏。不能散坏。菩萨亦尔。如法义中多闻已。多闻故心不调伏。被诸善知识正劝。令行修诸法及次法。不能正住。于教诲中不能正受法行。是名发行不调散坏因。譬如不调伏恶马。安置正道处中。以不调伏故向于恶道。不调伏菩萨亦复如是。为诸善知识所劝修行法及次法。诸悔之中。现以心颠倒分别念故。即便倒取。损他信施供养恭敬者。是名受用中不调散坏因。喻如不调伏恶马。共诸调伏马同其一处。而与诸调伏马行异故。说不调伏也。不调伏菩萨亦复如是。虽在调伏菩萨同其一处。已漏戒行故。受诸信施供养恭敬。以成其悔恨。于善调伏菩萨所行。行不相似。不乐知见。善调伏菩萨中起心诽谤不生恭敬。是名处不调伏散坏因。譬如不调恶马。共诸调伏马同其一处。以不调伏故心不悦乐。善调伏者共不调伏同其一处亦尔。不调伏菩萨亦复如是。以自有见取义故。共诸善调伏菩萨。同在一处故。心不悦乐。善调伏菩萨亦复如是。是中调者。根调胜故。伏者。一心灭恶得胜行故。转一切黑法对治。说白朋法应知。经言。善说所闻闻便信受。如所说行。依止于法不依言说者。非妒心诤胜故。但听闻正法唯求利益。不求觅见人诸短。菩萨如是行诸行已。常得值不离法善知识。随顺师教能知依止。以余言语所作皆善不失师意。不退戒定者。此诸句有异义。是中于教诲处随顺师教者。是总能令善。以喻言语者。闻善恶等忍故。所作皆善者。一切时不犯戒故。不失师意者。于教诲中心敬重故。菩萨如是行诸行已。常得值不离阿练善知识故。不退戒定。以调顺心而受供养者。所说不退戒定者。重明戒以定名说故。应知。菩萨如是行行已。诸常得不离行诸功德善知识。见诸善调顺菩萨已。恭敬爱乐随顺善人。劝受等行顺向顺意顺诸功德。为令得利。此诸句有何异义。是中善调及顺等诸句。前已解释。恭敬爱乐者。示现喜敬重心故。顺向者。乐见故。顺意者。正亲近意故。顺诸功德者乐闻意故。为令得彼利者。顺行此法意故。菩萨如是行诸行已。成不离得众首善知识。略说以何故。调顺不调顺边坏事。及云何而有。唯以闻等诸相故。以何时。现法中及未来。习学不止故。以何等相。具足四法。行闻等法对治故。说白朋等法应知。起次说者。行闻等法慢心故。顺行正法次法等行已。于正教授处不如法行。既正教授处不如法行已。所用受信施中诸事。彼令能堕不饶益处。彼如是杂垢染心故。见诸善调伏心菩萨已。即不生恭敬对治。渐次说白朋等法应知。不调伏诸法中谏已。劝修调伏等法故。防护住调伏法菩萨错谬等法。劝修不错谬等法。故说错谬不错谬等法。佛语迦叶。菩萨有四错谬法。何等为四。未与所化信受众生。而共同意。是菩萨错谬。乃至摄取破戒恶人等。是菩萨错谬。问曰。何故但说四法。答曰。依四种错谬法故。说菩萨有四种错谬。何等四种。一者不作错谬。二者过量错谬。三者不正作错谬。四者恶作错谬。是中不作错谬者。未受化众生而与同意。依化众生劝令到究竟故。信心敬众生中。所说法中断绝。是菩萨错谬。过量错谬者。非器众生中。说深妙上法故。于小乘众生希求大乘。而不随根说。是菩萨错谬。不正作错谬者。为诸上根众生说小乘法。于大乘众生求小乘。不随根说法。是名错谬。恶作错谬者。住正行众生如法持戒者。持罚不敬摄取破戒等。于持戒破戒中。偏心倒说法故。是中持戒者有三义应知。住正行者。不犯诸业故。持戒者。不缺漏诸戒故。真法者。敬戒法故。有二种相。释成破戒者。破戒缺漏戒故。恶法者。不敬重诸戒。错谬者。取不正道及示不正道故应知。此四错谬句现说四法。一者不说。二者不相似说。三者不称根说。四者恶说。不说者。对前后说法疲倦。已生恶心故。不相似说者。所说无方便故。不称根说者。喜乐小乘法故。恶说者。以利养心训诲行行故。是中恶心者以不说故。于诸善根中而便退失不能满足。以不满足故调诳众生。已说法中无方便善巧故。及不能摄取诸上善根。以乐小乘故。及远离上善根。复常悕求利养心训诲行行故。不集功德。及助诸恶故。调诳众生。对治彼故。白朋所说应知。经言。于诸众生其心平等。乃至普令众生等住正行。于诸众生其心平等者。自己及他心平等故。于不深信众生。化未成熟者而为说法。防护不作错谬。心知于一切众生平等说法者。法等故名为等法。于非器众生乐小乘等。悕求大乘者。随力说法防护过量错谬应知。随器说故。普化一切众生令入佛慧者。信乐大乘上根众生。而意求小乘法。劝令入佛慧。防护不正作错谬应知。普令众生等住正行者。舍诸利养名闻破戒持戒等心。以等同说法。护恶作错谬事应知。谏菩萨不正取因及不应亲近已。示现可亲近不可亲近因故。佛语迦叶。菩萨有四非善知识非善等侣。菩萨常应舍彼何等为四。求小乘者但欲自利。乃至亲近。以成世间利而无法利。问曰。何故定说四法。答曰。因非善知识故。说四种非善知识非善等侣应知。何等四种。一者于乘中非善知识。二者于行中非善知识。三者于佛法中非善知识。四者于正法中非善知识。是中小乘人者。但求己利不求他益。性行狭劣相似故。劝菩萨令远离大乘法中故。是名于乘中非善知识应知。求缘觉者。少欲少作。背众生益及修行处。令劝菩萨远离众生益及诸行等。以远离益故成失行因。是名于行中非善知识应知。卢伽耶陀者。说种种异言故。劝令远离于佛法中。以远离故成失行因。是名于正法中非善知识。应知。彼亲近己。唯有世间利而无法利。于善法中勤修故。得成退失因。以退失善法因故。名为于正法非善知识应知。对治非故说四种善知识。经言。诸来求者。是菩萨善知识。佛道因缘者。对不断绝大乘法故。说诸来求者是菩萨善知识。差别应知。菩萨作是念。我依来求善知识因故。修无量功德回向无上菩提。修行不虚故。不悕求小乘。所修布施助成菩提。作善根故。令不失大乘行。说法者。是菩萨善知识。生智慧纯志者。不失行对治。以多闻故能令为他说法。是故不求少欲之事。闻慧多纯志故。虽得世间苦。而不疲倦。教化人令得出家者。是菩萨善知识。纯志增长一切善法者。不断正法理对治劝出家故。于诸邪法而成远离。以一切善根纯志故。作利益而不生懈怠疲倦退失。诸佛世尊。是菩萨善知识纯志一切佛法增长者。对治不失佛法故。示现得诸佛挍量胜不退故。释成不着利养名闻等。既着利养名闻故。令远离退失诸佛法。修习纯志诸佛法。及以积善根力故。不能退失。以是义故。从非善知识中谏己劝修如是实行。行菩萨事故。明不如实及如实诸菩萨相故。佛语迦叶。菩萨有四非菩萨而似菩萨。何等为四。一者贪求利养而不求法。乃至乐聚徒众不乐远离。问曰。何故唯有四法。答曰。因四种非菩萨相故说四种非。岂菩萨相事而似菩萨应知。一者多闻相似。二者阿兰若相似。三者造作功德行相似。四者将诸徒众相似。贪求利养而不求法者。菩萨于诸信心中悕求利养者。虽复持法。是名不如实非如实。贪求名闻称己之德。不求出世功德者。乐名闻菩萨者。虽为阿兰若。是名不如实非如实。贪求自乐。不能救拔众生诸苦者。以利养悕求心缚故。菩萨虽作功德行。而名不如实非如实。乐求聚徒众不乐远离者。以供养恭敬心缚故。菩萨虽是众首。而名不如实行非如实行。菩萨如是行行已。令失持法。阿兰若作诸功德及众首之事。对治彼故。说诸真实功德应知。经言。能信解空亦信业报。以信解空故。不乐利养等事。及信业报故。喜乐诸法因。乐法故闻修无量功德忍。一切无我我所者。以忍无我故。不喜乐著名闻称等事。于一切众生起大悲心者。以大悲故悕求菩萨功德。入涅槃意者。以涅槃意不乐自乐。不舍世间行者。以不舍世间故。拔众生苦。为化众生者。心不舍众生故。而行布施者。以行施故。善知众生功德。虽修行施而不望报者。以乐寂静故。行施而不求报耳。问曰。白朋中演信乐等法说空等法何用。答曰。布施等助道诸行者。意谓与声闻缘觉等共诸行。而欲闻菩萨胜行故。及生犹豫心。为欲现说声闻缘觉不共助成正觉诸菩萨法。故

大乘宝积经论卷第一此论宋藏第一卷。与诸藏本文义迥异。未知去取。按开元录云。右释旧单卷大宝积经。则宝积第四十三会。是宝积部云。第四十三普明菩萨会一卷失译。右旧译单卷大宝积经。有释论四卷。今捡之宋本初卷则全是彼经。非论文也。是则宋本错将经本名加论字为论初卷。又为留支译。何也。今取二本为正。其所释经本。则是大经第一百一十二卷耳后贤欲知今之所去宋本初卷是何等者。请见彼经。即是耳大宝积经论卷第二

        后魏北印度三藏菩提流支译

尔时佛语迦叶。菩萨有四种得大伏藏。何等为四。能持诸佛能闻六波罗蜜。乃至乐着山林心无懈怠。问曰。何故但定四法。不多不少。答曰。为遮无穷故。亦是非问故。复为显示未曾有因故说四种。于长夜中善修空故。得一切智。犹修空因故。无明闇弊世间者。为灭无明故。说法以能亲近向涅槃心者。寂静甚深以不修故。不调伏净故。世间者说上妙法。谁能亲近。故财法二施。是妒吝心相违。久修习故。世间乐阿梨耶。为着阿梨耶故。说法时能亲近。或复摄取一切菩萨行故。略说四法。诸菩萨有二种助菩萨道行。一者助智道行。二者助功德道行。是中信空无我及不舍。涅槃等。是助智道行。信业报等三句助成功德智。广修六波罗蜜。摄取行故。助四种行。是中不舍化众生意故。财法二施而不望报。是名助檀波罗蜜行。不舍涅槃意故。助戒波罗蜜行。向涅槃心菩萨者。常恐怖世间。常防伏破戒等诸烦恼因故。得性持戒法体。菩萨成就无我忍。及以伏众生相所依故。设使众生有逼过及恼时。而心不可动。能信业报故。及意不舍世间故。助成精进波罗蜜行。助成功德智慧行果。信萨婆若事菩萨者。虽照世间重苦。己心不舍众生。及丈夫志故。不舍世间诸苦。唯在世间。为增长善根故。起大精进。以大悲故助成禅定波罗蜜。大悲者。依止根本禅定故。信空者。助成智慧波罗蜜行。菩萨不舍菩提心者。是名持谛语。不欺诳故。彼菩萨有大悲及信业报心。常向世间伴故。作众生处中而不助说颠倒。是故大悲及信业报心。不舍世间行。不舍菩提心因故。此诸法如是示现持谛语。菩萨谛语者。不舍菩提心。是即取发心处不望报财法等施。是名持势。菩萨施心者。于财法二施中破悭吝妒事。成向涅槃心者。是持寂静事。菩萨寂静者。灭除不寂静事故。能成善因信空无我等。是名持智慧。菩萨智慧者。伏灭诸烦恼。对治令得净菩提。善根及能增长。乃至得菩提不望报。及财法二施等慈。令利益他故。大悲者是名大悲。以大悲为首。及信业报故。行世间时唯作众生益等成就事中所生心喜悦等是名喜。或复心向涅槃故。能伏诸烦恼以无烦恼故。心喜事者名喜。或观诸行无我等。诸法离爱敬。或忆念如来。无量诸功德故。生喜者是名喜。或复自观知我堪能出世。或见世间诸众生堕没烦恼尘中已。我堪能于此大世间尘中拔诸无明闇弊众生已。令致寂灭涅槃界中。所有此济拔尘众生心。或我能作他利益。及见他益不相离。或见众生受诸乐故。心生喜事者是名喜。观诸行无我故。除怨亲等事。得真如平等作众生益。相违法中自然舍。菩提分法。是名舍财法等施。及不望施报。布施爱语及悲。不舍作众生益。利益余句常益持众生行故。明同事耳。是故摄取一切菩萨助道行故。释成此四句。问曰。今须说空义。以何为空。答曰。以智慧善释诸行性相。而不得者是名空。问曰。为智能灭诸行也。答曰。不也。然是识相境界故。真实中无虚妄耶。而施识境界是不实事。于有作地中同识生智慧。从发行下忍乃至性。法时。上中下渐次别分前中后。了别已能与无漏智作缘。已还灭无漏智故。真实中无故。虚妄而识故。识境界是不实事。于作地中同识生智。从发行忍乃至性法时。渐次分别前中后。了别已与无漏智作缘。已还灭无漏智。亦与真实见中障因相识境界中不能缘故。退还己真实境界故。见无相境界见法界故。过烦恼地。非自相见故。自相境界唯行识在故。彼法事等耳。唯识作世间者。修道行成向智是相者。不能自取相故。若作如是依智。非性相分别智。是自相本无常等智慧。非正事有记相是识。是故非识劣胜。是义不成。何故不能取自相故。若智非相者。智是同相境界。彼不虚自取相。若能取自相者。舍自相故。唯有记事相释成识。是不异识。随顺报者是不相违若作如是依智。共识同生是缘。然是事境界如是相累智亦取自相。无上等者。是事不然。何故。相违故。况自同相相违。已色事亦无常。若以色事成无常者。智即能取然是不成。是故智无自取相义。智随顺识故。彼性是故不灭。作真实境界相故。成舍自相义。是故智无自相境界。或识是真实相境界。问曰。以何为信空业报事能随顺。以是义故说言能信诸业报耳。答曰。以有生故说。是故无患。此亦有以智分别。观诸行众生不可见故。智知诸行生无相无分别缘此故。不善不能住事及无分别事有故。诸行谁作是谁果。而能相顺故生疑惑。生疑惑故不信业报。以是义故。佛语迦叶。宁起众生见积如须弥。不以我慢者起于我慢心。如论中说偈

  空除一切见　　见诸佛所说
  若有空见者　　是则不可治
  不正观诸空　　能坏无智明
  喻若恶捉蛇　　及行咒无方
  是中回向故　　如来说是偈
  知法及次法　　钝根难测量

菩萨善巧世谛第一义谛。虽善观分别诸行。故通达诸因缘集。甚深智已久长习故。乃识知因缘事。是故不生疑惑。成彼随所如是因。他已不成就性故。诸行无分别。以是义故。有如是种种分别。念佛方便善巧所摄作行。而作所成。如应化处故。渐次得萨婆若果。菩萨以信心故。发上勇猛精进忍无我等故。问曰。应说忍无我事。答曰。以观众生想识境界。以有世谛故。诸法同唯知善择分别。已求觅无众生故。作是念。此但有法。亦如幻无分别。不能自由迭相缘力。业烦恼柴火因生故。如灯焰体。以本法缘相似义故。而相续不断。然彼生时无所从来。灭亦无迹。及无所至。于中所有尚希用求者。是名无我忍。问曰。若无我忍能作无众生分别。及令菩萨皆众生益者。何故为说无我忍事。答曰。于诸众生所。能作利益义故。说菩萨无我忍者。唯为利益众生故。以彼无我忍故。菩萨伏诸烦恼。及观修众生相故。知诸行缘假无分别事已。设使有众生患。及世间行还来恼菩萨者。以善知众生故。不舍菩提心。还持彼心成就智慧慈悲故。不舍众生及修习种种善根。为得萨婆若故。不舍诸行为乃得菩提耳。问曰。信空及忍无我。有何异义。答曰。信空无我事者。能顺分别观一切诸行故。证法界根本处。无我忍者。自相境界彼能顺分别观众生物。唯见法处本根故。信空者。除取法性慢。无我忍者。除众生性慢。问曰。菩萨有众生相故起大悲。何故为说信无我法。是菩萨大悲相违法。答曰。是大悲因故菩萨证知一切法无我已。唯念众生界。此诸众生是无明闇弊故。但有习于无我法中。横计作众生相。已作执此是我我所。已爱缘故造复有业。以此故还不断世间生死。是故作是念。我令众生信乐此诸法。是故菩萨生深重怜愍悲心。问曰。向涅槃心者。今须释涅槃义。答曰。无业烦恼亲缘果故。无缘故阴流灭故。名为涅槃。如缘无故火灭。或智慧火暖。彼识种无缘灭。有未来缘。虽有所有有芽生如种。火熬灭有芽生。灭烦恼火是真涅槃。如树拔根。然彼涅槃有二种。一者有余。二者无余。是中有余者。唯灭烦恼。无余者缘无故。不从集苦灭故名涅槃。至涅槃故名到涅槃。亦名住涅槃。问曰。何者向涅槃心。答曰。见世间诸患生如是心。我云何如是灭烦恼已。得彼寂灭甘露处耳。向涅槃等意同识生诸白法心集。是名向涅槃意。问曰。意不舍世间者。何者是世间义。答曰。业烦恼事中迭相缘假。无始以来相续不断世间。至世间等故。名倒世间。寂灭世间有学是义。菩萨虽见诸患而心发。以世间意不舍众生故。唯修发行世间行。问曰。若随心相似发诸行时。应修白得白修黑得黑者。云何菩萨意向涅槃。与世间不相似发诸业行。答曰。菩萨心利益他故。久修习行菩萨。向涅槃意者。以利益他心能违退。善知世间多有诸患故。菩萨虽厌世间向涅槃意。以心不舍众生故。发世间行菩萨作如是念。诸菩萨非无漏法体中。增长生菩萨法。然唯有漏体中增长生诸佛法。是故菩萨不舍菩萨法。虽见世间诸患。而愿取世间。如佛所说。迦叶。譬如种在空中而能生长者。乃至有诸使杂世间法故。能长佛法。菩萨为化众生故。而行布施。问曰。今须释化众生事。答曰。以烦恼水所润作自相。诸众生心戒闻思等修。造暖相为初。乃至攒成出世善根烧暖故。随心令安无漏善根种中。随众生心戒普化故。名教化菩萨。以善修慈悲及方便善巧。为化众生心戒故。以财法二施摄取众生。摄已观众生心所乐。随于力化三乘法中。问曰。说布施者。何故名布施。答曰。不贪等同生心念。及同起一果施法持行布施及不望报心。是名布施。是中种种化受故。报种种果差别义故。不望报者。舍己之乐不求果报。是义。问曰。说不舍众生意而行布施者。岂不名为求报也。何故复说所行布施心不求报。答曰。虽不求报。行布施化众生。自然有故无患。或作如是念。此是果报处。广博方便。所谓发菩提心已。念一切众生。及不舍众生。为化众生故。行布施。行布施已世间得无量果报。后乃至得萨婆若事中相违。虽现向众生行施。为遮彼故。劝令修菩萨真实功德故。说言所行布施不望其报。而示现此义故。说菩萨成就深心直心故。不为希求己之乐故行诸布施等法而求果报。然于因及果中。心不着不希求。唯为利益众生。令他众生得佛菩提故。而发诸愿修诸善根时。作如是愿。菩萨复作是念。若有如是法者。我修萨婆若已。舍与一切众生。然诸法各自有体。修诸行者。自身得报。虽尔我此萨婆若唯为利益他。以此方便义故。菩萨从静心已来。所有行令发一切智。及布施等诸法因。所有依缘。一切智等诸果法。彼一切法皆是菩萨为益他故。起心现向成利益。以是义故。菩萨功德不与声闻缘觉同。故名为菩萨真实功德。是诸声闻辟支佛行者。是世间布施。为化自身故而行布施。诸外道为求外事果报。行邪行故。对治说住正行意故。明四种利益。四四句说应知。何等四种利益事。一者得大伏藏。自在事故。二者超过魔道故。令无诸怨家故。三者离谄曲心。在空闲处等故。于诸受用中无诸讥嫌事故。四者助无量福德庄严故。得助无边功德事。此诸益等次第相释。于中初句得大伏藏者。助成功德智慧行。是中能值诸佛者。助成功德行。余三句助成智慧行。依集功德智慧行故。第二四句超过魔道故。令净诸障。依净障故。第三四句。摄一切善根法。集一切诸白法门。依集一切诸白法门故。第四四句。助集成无量功德。能作一切众生益事相。及得无边功德应知。四种得大伏藏者。亲近善人能闻正法。寂静思惟顺行法及以次法应知。能值佛故。亲近善人。能闻六波罗蜜故。能闻正法。以无我心亲侍说法者故。寂静思惟心不放逸。乐住山林心无懈怠故。能行顺法及以次法。是中能值诸佛者。供养诸佛故。助成功德行。余三句者。闻思修等慧净故。助成智慧行。依世间势事相似法故。说此四种得大伏藏等法应知。世间四种事。一者见事相乐种种戏等。二者听受用事伎乐等。三者念受用等事库藏诸财等。四者触受用事余食等。如是见佛者闻思修等。应知。菩萨有四种超过魔道法者。依四种魔故。说超过魔道法。应知。四种魔者。于行大乘法中作障舍菩提心。教化众生中作障。于一切众生所不生恶心。于不异行中作障。能善觉知一切见故。于行满足中作障。及一切众生起憍心对治说不动乘自舍众生诸非行因。舍诸邪行因。及舍不满足正行因超过魔道。应知。菩萨有四法摄一切善根。依四种善根故。说四种法。摄一切善故。应知。一者一心地修相。二者不一心地相。是三种化众生相。修苦行相。及闻思相离谄曲心。在空闲处者。示现修相善根。于诸众生行四摄法。而不求报者。为化众生故行行。是化众生故行行。是化众生相。为一切众生故。不惜身命为求正法是难。有苦行相闻无厌足。及义无厌足故。为集一切善根及行精进。是名闻思相。菩萨有四无量福德庄严事。依欲起发众生令舍故说四处。何等四处疑惑犹豫等。为防堕恶道故。乐小乘故。及于佛法中起恶心谤等。是中心不求报而行布施者。回彼疑惑犹豫等心故。于破戒人。而生大悲者。回彼堕恶道众生故。称扬赞叹劝化一切众生菩提心者。回彼乐小乘之心故。于诸下劣修习忍者。回彼于佛法中起恶心谤等。若不护狭劣者。于正法中起恶故。说菩萨有四种超过无明烦恼地法。何等为四。以持禁戒摄取正法。及施光明世世资用乃至同意。是名四法超过无明烦恼地。菩萨有四无障碍。令得具足无障碍智。一者法施。二者摄护正法。三者不起妒心。四者不轻谤他耳。非但名字名为菩萨者。示现正行差别故。发意至渐次说法行等方便示现。依胜如等行故。菩萨法行者。示现声闻等行中胜故。等行者。自身及他身与己等故。菩萨行行示现。不以一切众生故。善行者于菩萨行中。示现胜义尽至善净。方便善巧依菩提故。行正法行者。菩萨行中示现彼方便故。是中菩萨行正法行。于声闻缘觉行中。示现有五种胜事故。常为一切众生深益求乐。令得住一切智。善能称量己之功德者。以深心胜故。菩萨深心胜故。自身常为一切众生深益与乐。非诸声闻缘觉等。能以四种胜行。劝令信入一切智人知诸菩萨者。劝众生令入一切智慧中。非诸声闻缘觉等。善能称量己之功德。不坏他智者。菩萨善能知己之所得。亦知二乘等行。非二乘等能达菩萨功德故。无谄曲心者。菩萨无执着慢心。以证知法无我故修彼。第二句声闻等。有说此是福田处胜故。深入坚意者。菩萨为化利益众生故。起深入坚意。非诸声闻缘觉等舍众生益而入涅槃故。菩萨等行中。示现有八种等故。爱敬等者。有三种差别故。心行时差别故。不虚爱敬者。示现无所悕求心故。于怨亲中其心同等者。示现于作利益不作利益中等同行行故。永能作善知识。乃至涅槃者。示现一切时爱敬故。常筹量至意念具爱敬先意问讯者。示现慰喻问讯中等同心故。有限量诸成熟心等化喜乐故。所许之事终不患息者。示现佐助同等事。随所许重担乃至未下故。普为一切众生。不断行大悲心。无疲倦者。示现悲心同等无偏心。许诸重担故。复心无疲惓者。示现不被缚。等同不喜恼心而将诸重担故。永求正法名闻无厌足者。示现方便善巧等同。文义善巧等故。随化者方便化故。但见自过。见他过者以不嗔心。令彼人说。示现于诸说中等同故。若不见自过乃以嗔心说者。是名不等同说。以菩提心行一切依仪者。示现发愿等等同一切善故。所作皆等回向大菩提。作愿善根行者示现。谓六波罗蜜所行布施而不求报。如是等一一波罗蜜。说有障对治。显说无碍。布施等诸波罗蜜事。容有身口能忍。一切众生而不能不坏心忍故。经言不坏一切众生忍故。为修集一切诸善根者。示现修习三乘善根故。勤行精进。虽生无色而起禅定行者。以有生故。色界中善劣应知。非三摩拔提中菩萨生色界中者。成熟己身佛法故。至余世界亲近诸佛故。欲界中利益众生胜故。非色界处方便所摄慧行四摄法所摄。方便者。彼方便者以四摄法所摄。示现何等四法。一者法行事。二者修行事。三者性行事。四者果修行事。有三种相行者。于持戒破戒众生中。生慈悲心。无二之心及作分别心。此教授者。是持戒是不持戒。所有教授者。诸功德及诸患等。彼即舍诸分别悕求教授。及亲近教授故。至心听法者。至心勇猛受诸教诲故。常乐山林者。依寂静治诸欲贪等故。此三句示现修行事。何等三句示现性事。心不乐着世间众事者。示现心相不散。以不乱故不着小乘。于大乘中常见大利者。过舍小乘心成就顺大乘心故。离恶知识成亲近善友者。于寂静勇猛无暂息。众生亲近忍亲近。寂静勇猛无暂息化众生。故所说法行者。奢摩他毗婆舍那不乱想所摄。随有念及随所同侣而有此法行事。性果有二种相心净故。及教化众生。是中心净者以智慧净故。世间出世间应知。成四梵行庄严游戏五通者。依净世间智慧受大功德。助集依力修果故。净世间智慧应知。常依止智慧者。修世间智慧而为知足。舍彼心而净求出世间智慧故。是名出世间智慧。应知。教化众生事四句示现。于诸众生住邪行正行。而意不舍者。住不能忍恼等诸患故。越堪忍恼而不报故。言常决定者。所说之言常定。及敬前后相覆非前说已后不喜说贵真实语者爱敬及护实语随说而行故。一切威仪所作之中。唯菩提心为首者。依为得菩提故。不喜求利养名闻故。如是分别住正行。菩萨已为显示诸胜功德故。说诸喻应知。迦叶譬如大地皆能容受者。初喻中示现菩萨依众生。令增长发种种爱果种子故。然心无分别。不求其报者。作恶不能报。作好不悕报。于利益及恶中心不足故。以第二第三第四喻。示现发依义故。为教化众生。令增长善根因尽至事。譬如月初生时。月轮光明形色。日日转明满足增长。第五喻。依众生益故。示现菩萨增长自成菩提助道行。譬如师子兽王。随所至处不惊不怖。安详而行。第七喻。示现不恐怖世间涅槃。及不着彼二。譬如善调象王。能持一切重担。不生疲惓。第八喻。示现荷负世间重担。而不住疲惓。譬如莲华生于水中。水不能着。第九喻。示现世间烦恼不能染故。譬如有人伐树根在还生。第十喻。示现虽不烦恼染而不证涅槃。譬如一切诸方一切诸河水皆入大海。入海已皆成一味。第十一喻。虽有善根及以烦恼。回向发愿摄取故。示菩提因。譬如须弥山王。忉利诸天及四天王等皆依止住。第十二喻。防声闻同涅槃。彼声闻舍自愿及诸善根而取涅槃。诸菩萨者。虽示涅槃而不舍自愿。示现于诸善根得大自在。譬如国王以臣力故。能办一切国继等事。第十三喻。示现释成云何入涅槃。而能作众生益。譬如天起大云。必能降雨。皆能增长一切果实。第十四喻。随转轮王所出之处。彼处则有具足七宝。第十五喻。何故不恒说及生示现待时。第十六喻。譬如随摩尼珠所在之处。彼处则有无量百千万金银等宝。第十六喻。示现同声闻等。涅槃中有过患故。彼声闻等则无。譬如忉利诸天入同等园。所有用物皆悉同等。第十七喻。示现彼声闻等无力。不堪证入胜法故。菩萨于己及他。等行利益一切众生。譬如咒术药力。持毒不能害人。诸大城中所有粪秽。彼若致甘蔗蒲桃田中则有利益。第十八。第十九喻。说菩萨虽未断诸烦恼。示现胜声闻等。以不能作患及作大利益功德之事。此诸喻前句显分别说。后句渐次应知。彼复云何。答曰。菩萨从初发心。前中后依助成一切众生善根心不悕报。于一切好恶中心如大地。复非如无分别地。诸众生依己。自假力而能受用。菩萨不尔。然菩萨为欲生善根因故。起敬爱等。心如水。复非如水。于正受增长中而相违。菩萨不尔。然菩萨为欲成熟诸善根故。说厌离等法。心如火。复非如火。化诸佛世界相违成。菩萨不尔。然菩萨为欲教化成熟者。示现解脱现气应化故。助正教授。心如风。复非如风。见相假力故。而能受用。菩萨不尔。然菩萨自能增长诸白法。心如月。复非如月。唯能照白月不照黑月。菩萨不尔。然菩萨于诸黑白法中。等心以智慧照明一切法故。心如日。复非如日。畏罗睺障而转行。菩萨不尔。然菩萨于一切道。生处不畏诸烦恼而行。心如师子。复非如师子。将诸重担而生退还。菩萨不尔。然菩萨能忍一切重担诸苦等。心如调伏龙王。复非如龙王得利或失利。柔软语苦乐防护益失中有染心。菩萨不尔。然菩萨于一切世间法中。增益之中心不生染。心如莲华。复非如莲华。断茎已不复能生。菩萨不尔。然菩萨虽复灭诸烦恼。以善根力故。即能世间生心。如不伐树根。复不如树根伐之唯有正根。菩萨不尔。然菩萨诸善根回向发愿。大菩提及涅槃故。心如入海水。复非如入海水。唯名顺如海水。菩萨不尔。然菩萨依修集大成就大菩提涅槃等诸善根故。而能游戏。心如须弥山王所住诸天。复非如须弥山王所住者。唯乐着自乐心多放逸。菩萨不尔。然菩萨以不共方便智慧力故。能办一切诸佛所作之事。心如国王以臣力故能办国继等事。复非如国王以臣力故唯为自利故。防护己之国。菩萨不尔。然菩萨舍己之乐。将护润益众生。心如天起大云。复非如天起大云。不能常与以时善熟。菩萨不尔。然菩萨永能增长生诸菩提分等法。心如转轮王所出之处。复非如转轮王所出之处。唯一无二大人共生。菩萨不尔。然菩萨解脱心等共同一时生故。心如摩尼珠。复非如摩尼珠。永不离库藏迦离沙波那等。菩萨不尔。然菩萨已入无漏戒中。同有所作同受诸乐。心如忉利诸天入同等园。复非如忉利诸天入同等林。己唯能增长诸烦恼业。舍身堕恶道中。菩萨不尔。然菩萨灭诸烦恼。不能令堕恶处故。如伏灭烦恼毒故。复非如持毒己。不能害物及无利益。菩萨不尔。然菩萨以自己烦恼。能利益一切众生。心如诸大城中所有粪秽烦恼。菩萨亦尔。如世间赞叹等事功德。过胜彼功德故。名无比功德。以是义故。诸菩萨者名为无比功德。应知正行差别中。已说诸胜功德。未说正行体性相。是故彼体性相。以中道义示。现舍二边。是中道义。应知。何者二边。一者外道边所有我见。彼则于阴界入中横而执。是则常见。是后时总而说言。常是一边。我是一边。二者声闻缘觉边。若于诸阴等中。执无常及执无我。是则后时总而说言。无常是二边无我是二边。所有此二边中间。是名无分别智。彼无分别义故。名无色。不可演说义故。名不可见。非识事住故。名不住。离可取所取义故。故名无相。离能取唯记识等义故名无记。不住世间及涅槃义故。名无著。应知于中是诸外道横执有我故。说对治若不观我人众生众生寿命养育丈夫富伽罗。及不观摩那婆等。所说应知。声闻缘觉于诸阴中横执无常。及以无我对治彼故。说若观色非常亦非无常。观受想行识非常亦非无常。乃至我是一边无我是二边。所有此二中间。彼一切无色无行无命无智无觉无著。迦叶。是名中道诸法真实正观。说执无常执无我为因者。无破阴无常执时亦阴无我执事应知。示现分别所取之事无量故。分别说能取之事。亦复无量。迦叶。若心有实是名一边。若心无实是名二边。是中真实心者。若本所说顺执分别无常无我真实者。若分别常我等。若无心数者。业行所依故。无心数者。唯造业行故。无意者。若非思量所说故。无识者是报。善不善法者。顺愚痴非愚痴故。彼即是不爱果对治彼故。说有罪无罪者。无诸恶世间出世间故。有漏无漏。无漏者。有漏心不能取故。有漏者。彼复黑朋所说染等法故。白朋等法者。诸净等法故。是中若心有实若心无实者。此是二乃彼所顺诸法中。有善不善乃至有垢无垢。所有此二边不可得。不可说不可办。是名诸法中道真实正观。是中不可得者。以彼见故。不可说者。唯说彼故。体不可说。他来问者。不能为正说。复有余傍义。善不善者。是本余上上句是正释。应知外道声闻等对治。说中道义已对治说。菩萨边对治说。是中有诸外道等常我执倒。从何而起。说言如盲者倒地。诸声闻缘觉等修行见人无我。已唯觉知行故。生诸行无常无我。及本见法无我。依诸行从无常无我而生。菩萨见修行法无我已。本习法无我。后生横执有边依为三种横执有边故。示现对治等自相横执。于有无事中说迦叶。有是一边无是二边。乃至无命无知无觉无著。是名中道诸法真实正观。如说应知依有障对治故。所执无明为明说。经言。迦叶。我为汝等所说十二因缘。所谓无明缘行。乃至无明灭已忧悲苦恼妄想等灭。执有为无为及灭余道故。行及灭行如是等诸句。此诸执等对治。是名不二妄想分别执性离。是平等性故。说不二相故。非明令能生非无明能灭。非行等能灭除非灭令可得者。虽有分别性相成就。如是此所有智彼能防谤边。非明非无明如是等。若不以空故令诸法空。但法性自空不以无相故。令诸法无相但法自无相。乃至但法自无起无取无性。如是等。示现何义。已得明空等相因缘生法妄想分别性。或成就性不能令空。何以故。是诸法体尔。若妄想分别性。或复成就性故。诸法亦空。如是乃至无性。此说有明及有彼障。示现离妄想成就性。已防遮护谤边。是中有七种障对治故。说明为空。乃至无性。七种障。一者见对治彼故说空。贪嗔痴相因对治彼故。说无相。复于有中取愿。对治彼故说无愿。复造有诸业行对治彼故说无作。因彼有果故有生。对治彼故说无生。生已必起苦乐。对治彼故说无起。见空故生我慢。对治彼故说诸法亦无性耳。是中作无我观。遮人执取相。余者乃至不二等相者。诸法执取相故言迦叶非无人故。名曰为空。但空自空者。遮人及法横执取相。非灭众生执取相。非灭众生执取相故而修空。然空自空。示现灭法中执相故。以妄执分别性故。空是空。何况一切法妄者分别中所执取者。故如是以空则非事。依妄执分别性中无故。复非无事。以成就性中有故。如空者。一切诸法亦尔者。诸法中执取故。示现法无我。然彼者成就示现故日月经言前际空中际空。后际亦空。示现一切时。凡夫有学无学体中示现有故。汝等当依于空者。依了义故。于空示现防方便。莫依其人者依了义故。遮依彼已。名住依了义事。所有人分别及随事因。彼二富伽罗故。言若以得空便依空。此示现何义。非妄分别空性觉故。应依空义。如是依已。本以执人我见故。怀有取执故。我法亦失令转失疾。以作彼及知疾失事。释成故言迦叶宁起我见。积如须弥不以空见。乃至一切诸见唯空能灭。以分别觉空故。识知空我慢真实义。令不能得为得而起谤。是则转难除人见故。汝药动病在内而不出者。是名有病。经言。迦叶若起空见者。我说彼人则不可治。或以妄执分别性。一切诸物一切非事。但横执是义。虚空喻者。防护转变不正执取。若有空见彼以空故。色等法中求非事故。于事中作非事分别。是名彼者转变中横执取。是诸色等法性自无喻。若起求除空诸众生者喻行。空法体中幻畏彼体已事妄分别故。若色等诸法无者。徒修诸行护此患故说画师喻。喻若实无鬼画师自分别思量已。迷没躄地。如是亦无色等事。诸凡夫横。自分别行念故。世间转轮而行可除彼无智故。修行而不虚。先者已释妄分别行。今说发行中不虚事。若此但是迷心者。云何彼心能识知。是彼心遮防护难。故言先防妄分别发取。今须遮说发行事故。说幻师喻。是中如幻师处者。如系心念智如幻师幻作者。观无事智如食者唯观无念想智观如空等故。本从圣慧根如实观见故。无彼云何不如实观。而得出世间智。遮难故。说二木相磨处寂静思惟缘故。火处生圣慧根。生已舍彼寂静观示现应知。为已生智与无智对治为当未生遮故说灯明喻。智无分别相示现智慧生时即对治无智。云何无始烦恼染有始对治。能灭遮防难故。说着内灯明喻。此喻喻中道义。略而释说。广分别者。菩萨住正行戒中故。差别应知。法行菩萨者。说世谛实语理。及分别实语。现渐教不如闻音声取。以如是相故。不依声闻乘。遇彼已说是中曾供养及修善根者。顺向大乘诸甚深法及顺空。于分别不分别。实谛理所摄故。世谛及真实谛所说。唯一法界了义中说。以是义故。顺向所依名为行寂静。行寂静故名曰顺向中道义。如是彼法指斥。释说十三种中道之事。释众生空是众生无我及法空。是法无我横分别。如边及谤边。证法并彼发愿向大菩提。如是行已。于烦苦中心无厌足。及胜信二无我。前无我中后无我为最尽至诸空。彼者亦如是释说神力云何释众生空。以一相故。言若不自观者。示现不自觉知。是中有此不分别。有三种不分别事。于众生事中。明阴事及彼种种事。转明诸界中彼受用事中诸入等。内及外并二中间。如凡夫横执

大宝积经论卷第二大宝积经论卷第三

        后魏北印度三藏菩提流支译

不见我。云何释成人无我。示现以一相觉故。是中有此觉事故。说不常观知还彼三种事中。凡夫计执所生常不见凡夫所计自异相见故。阴等无常事云何。释法空。示现亦以一相不觉故。说非无常观故。知是中有此不觉事。还彼事中无常趣故。内外及二中间。是凡夫计执假说相体性不可觉知。得无常者若计执已。于不可说事中横安云何释说法无我。示现以一相觉故。是中有此觉觉事故。还彼事中所觉见圣智境界。唯彼自内证知。余人不能说。彼有六种相。如凡夫所计执假见说性不相似。何者六种。非色者自测指斥不可得说。是此此是不可见者。是以彼不可得。示他不住者。过色根境界故。彼处色等根不能住故。无相者离念性相故。无记者离意识境界故。无著者无烦恼事故。云何释成横计执有边。示现有二种胜相正说故。及示现彼体性相正说故。是中何者胜正说性相。彼上上有八种应知。还彼事中常正执无常正执。及依常正执故。有我取正执。及依无常执有无我执。及依无我取执故。有取实心大执依有我执故。说不取实心执彼所依者。亦求彼复求者。依执故及依执共顺依取不实心所执取不善。等执着乃至取染执相有五种障患。于染法中有颠倒患谤患发起患粗恶患无常患。依执取实心。彼对治于净法中善等所安乃至净得所安。此是成八种诸胜安。是诸八种胜安。菩萨不觉念顺不执着故。不说顺不劝他故。不悟顺不动他故。是中真实执安者。上明依此八种胜安事中。凡夫系念假用性执安言有如是安云何释谤边。亦以一相故。示现有谤事故。是中有谤事者。如彼信邪法无我一切时执故。言无一切法相。以是义故。略说此横执谤边。离六种相。显说中道义。云何释成诸法证事。如经迦叶明与无明无异无别。如是知者。是名中道真实正观。乃至老死灭。是无二无别等。有三种相释说证法事。还彼本说三种事中。及第四因缘事。中有障有对治。住有为无为示现性相不可得。故示现胜事不可得故。及习彼已证得如实智。是中性相不可得者。如凡夫计执。明与无明性相不可得。是中胜事不可得者。所有彼凡夫横计执性相灭生聚集不见二相故。是中证得智者。所说彼智及依所依念相行不念故。及行不障故。以内智知证法无我故云何释菩萨证法。回发愿向大菩提故。亦是一相故。言若不以空故。令诸法空。如是等七句说。菩萨为利益众生故。以空故。不令诸法空不舍烦恼。是义如是。不以无愿故。令诸法无愿。不以无相故。令诸法无相。不现起复业生流及念生流。一切诸行无性。以涅槃灭世间流。云何如是行已。释成未离烦恼苦心事。亦以一相义故。言如诸法有性无性。如是等七句说。未灭诸怨障等法。如实观证。是中如实证者。还彼障等诸法以体性行法无我见不染及苦。云何胜释四种相故。示现见胜相故。示现还彼远相离胜故。示现失禅乱胜故示现心乱胜故。是中见胜者。经言迦叶非无人故。名曰为空。乃至中际亦空故。非但不见人故说空。是义何以故。住众生空者。不见法空。惟法自体空。未来于涅槃中。作断慢心善观所取乃至行能取无我智。离假名性空所摄。不善观三时过去未来现在。故名不正观真如智尔焰。空假名妄取法慢故。言依空不依法无我真实空。彼以不灭本所取众生空及有取生法故。名相退失。于此法中菩萨不如是。以是义故。显胜说菩萨行示法无我故。佛语迦叶。汝等当依于空。乃至于佛法中则为退失。是中有此远离胜住众生无我故。自我见是以于凡夫最下中转复最下有二种相故。一不免苦。二行苦。此是二相故。言迦叶宁起众生见积如须弥不以空见起增上慢。所以者何。迦叶一切诸见以空得脱。若起空见者。彼则不可治。此文显示彼义。宁起我见积如须弥者。以我见是可对治。可令得灭。不以空见起增上慢。以不见法无我故。起增上慢。应知我以空故。见诸行空。妄相执性空亦是空。彼不可得。体空横执分别性空。横安颠倒处故。以横安执见故。成于空见。若起空见者。彼不得与对治故不可持。应知以不可持故。不免生等诸苦。一切时不离烦恼热故。不能乐行。喻如不可治病人。灭二种执取故。为前者说有二种相。譬如病人。良医授药。乃至若起空见者。我说彼人则不可治。此喻示现。譬如病人不正将息令动诸患。顺动病因顺不动病因前后故。受二种苦受。如是人无我见不灭同我见。及生空法无我执不离。自顺烦恼病故。前后取二种灭故名为灭。菩萨不如是。是中灭善胜者。如经譬如有人怖畏虚空如是等。如人空中自念分别横执计作物怖畏。彼已作如是言。除此空除此空。如是等如是住人无我中。不住法无我。我慢故生怖畏。于虚空处不可说事中。横执虚横安执已。安执故色等故色等想求彼断事。菩萨不尔。是中有此心乱胜事故。言迦叶譬如画师自画作恐怖。夜叉鬼像如是等。如是失行乱者。住人无我故。自分别念实有境界。彼以想等倒故。令成颠倒。菩萨不尔。云何释说因以二种喻。一者幻师喻。二者二木相磨喻。初喻示现观能取者。人无我智唯取诸行。彼以法无我智观。是法无我智名为能取及观。然彼人无我智与法无我智为因。以有彼故有此喻。若幻师与幻人为因。喻若幻人食。彼师如是行者。以法无我智众生无我智离假名性故空。离彼分别故寂。可舍相故无有坚固。空无物故。不牢观者如食。第二喻示现。譬如二实证得。是中如实证得所有观。彼能取所取寂静思惟念因不舍离。永得彼内知决定智生。是中观所取者。谓众生无我智观。能取者行法无我智。彼二如上下二木顺故。寂静思惟以寂静因故。内所证知生决定知。名为真实证。此之二木喻。显示有因可得。喻如因磨二木故生火。生已还烧彼二木。如是人无我法无我智行因。生是法无我智。以缘内智决定生智。彼行智所有妄念计执性。彼如实观而能烧。云何说遍至空。亦以一相义故。还彼法无我智中如实见故。言譬如然灯时。一切黑闇皆悉自灭。此喻解释说。是中如实见故。无智等离假名性故。空者。如是不执故。不可取寂灭者不觉故。云何如是释彼空。一者业灭烦恼灭。是现对治故。言迦叶譬如宅内。若室若房若屋中过千岁以来。乃至其黑闇者。诸结业是。此喻说。是中显示灭。至失者。寻即所生智慧光明能灭无始以来诸业烦恼。若能如是速。灭诸烦恼者。何故菩萨久长行世间。二喻示现得胜果故。言迦叶譬如种在空中。乃至诸使杂世间法。能长佛法者。杂秽良田中能生长种子。如是等喻。示现此事菩萨向涅槃心故。不舍众生为得佛法故。愿取世间。已回向发愿诸善根故。长夜中行行。是中涅槃是无为。喻如虚空。彼依故不长诸佛法。世间如烦恼杂秽田。菩萨大悲亦如烦恼杂秽地处。持彼地故。能增长菩萨佛法

问曰。云何依下劣有为法中。能增长菩萨无上佛法。以莲华喻显释。故言迦叶譬如卑湿淤泥乃生莲华。菩萨亦尔。于生死泥邪定众生中。菩萨乃生佛法。问曰。若如是者。诸声闻于菩萨中。无此十二种胜事。何等十二种。所谓修习现诸杂善根胜事。修智行胜事。解脱果所摄尽无生智解脱同至胜事。灭降伏诸魔怨等胜事。无学胜事。阿罗汉胜事。应供义故说众。上胜事。依四双八人故。明诸说者上胜事。现法中得涅槃说法故。明众生中上胜事。乃至众生乃至九众生处。如是中得最寂灭胜事。于心得自在胜事。及难伏生胜事为防难故。说诸喻应知。为防初胜难故。说二种大海生酥喻。无量众生不受受用相似法故。第二防难菩萨智有二。自及他无量众生身中障对治故。第三护难彼有二种。丈夫人喻。如上夫人处解脱应知。如贫人处诸声闻乘及愿。是婢使处者。不舍众生故。王处者诸大乘愿以防护诸怨故。初转轮王喻与如来真子故。防护无学胜事。第二转轮王喻。不断佛种事故。防护阿罗汉胜事。堪应供故。说第三转轮王喻。授萨婆若因故。防护说众上胜事。以毗琉璃喻。初摄得菩提心故。防护说法者。上胜事故。说药树王喻能与众生除烦恼病故。防护明众生中上胜事喻者。无能舍月轮。如是能作一切众生智慧光明故。防护得最寂灭胜事。作月初喻集功德智因助得菩提故。防护心得自在胜事喻琉璃珠。菩萨得萨婆若果故。防护难复生胜事。喻如治毗琉璃珠故。心自在胜利养等诸声闻功德者。依菩萨故如是此诸喻略说。菩萨于声闻中示胜功德故。自此已后广说诸功德。有几种声闻声闻戒中菩萨戒有何胜事。有四种声闻。复有十三种相。诸声闻戒中菩萨戒有胜事应知。是中有四种声闻者。谓应声闻我慢声闻作菩提愿声闻。及定灭性声闻。是中应声闻者。若为度众生故。诸佛菩萨所化。是名应声闻。我慢声闻者。若唯众生无我智故。及邪法无我慢执智故。以为净。是名我慢声闻。作菩提愿声闻者。若从本来怜愍心微少。以亲近如来及以习故。于上妙佛法中。身心信作功德相熏成。虽彼尽至住无漏戒中。而诸佛为劝说诸方便。彼以此因令。得修大菩提。虽如是修菩提。然后行中而是钝根故。及乐净故。非如初发心而有佛性者。是故名菩提愿声闻。定灭性声闻者。若从本来愍心微薄性故。一向背众生及怖畏世间苦心故。唯住向涅槃故。不堪得修大菩提。譬如二王子。形貌无异等同受王诸乐。于中一善达王法技艺等事。第二不如是。此二王子有技艺中胜故。非受用乐处。如是菩萨住无漏戒中及灭定性声闻。应知彼复有胜事。身中应知及习诸白法处。智集处相似处性处。家持处行处。神力处修行处。福田处上胜处。因果处。及依生处。应知譬如种在空中而能生长者。无有是处。种在杂秽良田中。则能生长。高原陆地不生莲华。如是等喻。示现定灭性声闻。及说菩萨至心信胜事。定灭性声闻如杂秽地。诸杂行于杂泥烦恼染还恕诸众生中背故。一向涅槃界如地处炽然于净众生界中同心及住心反质菩萨向涅槃心。及住净众生。心不舍有烦恼众生度故。取杂染世间及摄取众生。虽迭互等喻集诸白法处。示现作胜事。声闻有诸白法微薄。唯益自己。菩萨法无量。利益增长一切众生如子。譬如父以生酥长养诸子。菩萨亦尔。自善根无量如生酥。养育增长新学菩萨如子男子。虚空唯等示现智集胜事。声闻以无漏智故。唯见自身空寂。诸烦恼中菩萨者。怜愍故。同证智。令回与十方一切众生发愿向无上菩提故。最大夫人及婢使喻。示现相似胜处。声闻念胜解脱。最大夫人母处狭劣小意如父贫穷心增长不成佛子。诸菩萨者舍下劣凡夫众生性念婢使母处以上念心如灌顶大王成就故。名为佛子。初转轮王喻。示现性处胜事。如转轮圣王子成就诸力。成就势力成就至威。以无转轮王相故。不堪作转轮圣王。声闻亦尔以勤精进故。成就诸力谛善巧故。成就势力不舍心故。成就至威无佛性相故。诸佛如来不与拥护摄取。菩萨以第二转轮王喻。示现持家胜事。声闻虽尽至故未来不能持佛家。初发心菩萨堪能故。第三转轮圣王喻。示现行胜处。声闻虽得尽至。诸天圣人不如是恭敬赞叹。如新行菩萨毗琉璃宝珠喻。示现神力胜事尽至。菩萨从初地。以智慧神力故。退一切声闻缘觉。雪山药树喻示现修行胜事。声闻虽成就智能灭烦恼病。智药灭众生烦恼病。反质菩萨者。唯常行益他故。星宿喻示现福田胜事。虽尽至声闻不能以智慧光照众生故。不作福田度一切人天。如不灭烦恼菩萨一切人天而作福田。月初月喻。示现于胜中示现胜事。一切时声闻中。诸佛如来常胜彼胜中诸菩萨。复转胜彼从菩萨而成故。诸菩萨有二种相故。转胜应知。如是彼亦教化众生。及成熟佛法。是故有菩提及得果。随所化众生令得解脱。譬如营作影者成奇异怖心不于食者。此亦如是应知。譬如诸天及人。一切世间善持琉璃。此喻示现因果胜事。声闻虽一向修集净法胜因。复值亲近无量善知识。不能令得大菩提果。反质故。说诸菩萨者。能令得大菩提果故。譬如治毗琉璃宝。喻示现依生胜事。诸声闻者。依菩萨故。而出现世间。非菩萨依声闻而出世间。为灭恶持住义故。语尊者摩诃迦叶言。迦叶。若有国中有骆驼咽黑头仰明者。乃至彼国无有恐怖畏等事。是故迦叶。菩萨常应救护利益众生者。有何渐次说。自此已后。示现得彼果益。胜事。前所说言杂染烦恼泥中。能长菩萨佛法。若尔非彼身中增长者。亦非诸菩萨。令助彼身中者。云何彼身中而能增长菩萨。为众生故修诸行。示现此说。若增长彼者亦增道自己。经言。菩萨常应救护如是等。示现至于四方一切世界。一切菩萨愿利益众生事真实毕竟治者。所有离良医疗治身患。乃至离外道治烦恼。是名非真实治假名故。及颠倒故。是中菩萨者喻良医。应知一切众生如病者。诸病者如贪等。药者如不净等观。如有三种相故。诸大动而生诸病。或以积诸恶故。或不应食而食故。或以舍诸病故。如是此三种因恶心相故生心病。或以积诸贪等恶故。于长夜中诸贪等习故。或以见不应行而行。复现有行诸见等事故。或行颠倒事舍故。是中初烦恼病。不净等对治。应知以不净对治诸贪。慈心对治嗔恚。四因缘观对治愚痴。如是等说有病。故为说对治诸空等。依四种众生故说。一者执见。二者乐着三摩拔提。三者喜乐诸生。四者于非解脱处而作解脱想。是中依执着诸见众生故。言一切诸见唯空能治。若起空见。如是等说。应知乐着三摩拔提故说无相。一切有无诸念分别相中无相故。示现一切有无。示令乐着三昧。依喜乐诸生故说无愿。灭一切欲色无色界等故。说言无愿。依非解脱处。而作解脱相。说非四倒。为灭一切倒故说四倒。见常等故。于非解脱处而生解脱相。舍习颠倒故。依有者故。广略说四颠倒对治。应知有凡夫复有六种。依着身者。对治彼故说诸念处。烦恼散者。对治彼故说四正勤。迭互我慢所缚者故。对治说诸如意足。离修诸善故。对治彼说诸根及力。不达诸谛故。对治说诸觉道分。及喜好吉凶等。见对治故说诸道分。云何不顺观身堕身见若我所见。不分别背善治法不信等。应知彼对治故。说诸根及力。迦叶。所有阎浮提内。诸医师及医师弟子中。耆婆医王最为第一。迦叶假使三千大千世界中所有众生。彼一切皆如耆婆医王。如是等耆婆相似诸众生。示现诸论医方多闻善巧胜故。有辨取见教悔见疑悔等难治故。是中方便定心故。诸见等能作障。如尊者阐陀说。诸大德我作如是念。色是无常。乃至然复我行舍摩陀空无分别。灭爱离欲灭及涅槃中。心不安不喜不住不解。我意回转生厌懈怠心。然何者是我所。作如是说。彼尔时以智慧心念忆涅槃。不灭我身见故。言我当无故。于涅槃中心退转生恼。然何者是我我所。不作如是念。此唯是行。以何谁彼无。然此时世间道行不能治故。名为不可治。欲摄未入定心故。缚作疑悔。能散疑悔因故。除教诲者。唯诸佛如来并诸菩萨。无有诸毒患。有大力。是故唯说见疑悔无力能觉知。意不能测。及不能说。不能诵。不能正说。不能以言。求此助道行已。求出世间行。有余中心求。然后有余。依众生无我故有二种。应知依法无我。有一缘入智等。因欲信本智信智。唯心是中谏断无缘觉及无我。因缘习中求觅。示现证人无我。于内外入中。及依彼念识处中。妄想横念性故。心不可得。及成就无色等相。见性故示现证法无我。然是成就性故。作心事有护。不正取故。言迦叶心一切诸佛不见故。言非自然故。不见示现住法体故。一切诸佛说三时见故。如是先说无横念分别性。彼横念相。示现他性相说故。有依止故。言彼以何为性耳。于中明心及心数法。若以意堕唯是相。此云何世间成生死释成如幻。唯是一心行者如河流。如是行厌离中心。何故不得解脱。释成就如风。是中远至者。一切事中以彼性故。应知如是难知。云何得解脱。释成如灯焰。以无明缘力故行。示现彼尽故不行。若心烦恼力故染成。不者顺如。彼烦恼不净故。不见觉解脱。防护此患故。示现如虚空。防护诸患故。如虚空无分别故。示现如雷电念念灭。贪等诸中不住故示现。无常相。相故示现防作异相患。虽净心念念灭故。示现如猕猴。彼非悕求种种境界故散。是以顺贪等各不能降。成有散故。何故不一切等共生释成。如画师事。何故不一切时。如是等。造业释成不住故。何故退现在业。或以木现气力故生。释成如王事。所有业修力最上。彼熏心故。得增上成显说。若如王者。何故自己能生诸苦。释成如怨家故。何故自己如怨家。释成如疾。聚家示现故。身等示现有四倒。顺等行故防护患。有如是。以何故生乐处而取生事。示现如怨家故。有三苦故。示现彼处亦生苦故。如是苦。何故不取苦对治。示现如夺人力夜叉鬼等。防护乐着三昧故。如次。复何故不乐对治中示现如贼作事。不防护不将彼。助道行善根故。若以苦中作功德乐意乐住者。如是以何患示现如具有势无势憎爱事。何故痴狂故。着色等故。释成如蛾灭灯故。佛语迦叶。求是心相而不可得。若不可得则不可见。乃至如是圣性众。非身作业。非口非意。彼性中亦无上中下差别。求是心相而不可得者。有何渐次。示现他性相行已。如彼他性相求故。亦求横妄念。及求成就性时彼示现。然彼横妄想分别性。心理中求不可得。是故性相不可得。彼亦是以不可得。所显成就性相心。彼则无为。后时当说。示彼三世生事。非如入灭尽定。当时心不等三世生。如是彼生事。应知示现过三世故。彼不过三世。起已复更生心故。若过三世者。彼亦不名有防护横执取故。傍名示现亦有亦无。妄想念他想性等故。显说成就性故有。彼则不生者。以观身因故彼则无。性者于地狱等定性因故。彼无趣者。作生因故则无。灭者已灭故。彼则无离者以灭故。不离者未灭故。彼则无行业者。谓阴故。彼是无为者。为显彼故说此一切彼无为。今欲分别释安。是一切圣性本者。以此念故得彼圣处。诸圣以此为显。然彼性以有余无余涅槃所显及菩萨涅槃所显。是中依有余涅槃故。言无有持戒亦无破戒。以善学戒故。无行有余灭故。非行有余灭有余故。非不行诸烦恼。无心无心数法者。离染故。是中业者。复有烦恼因业故。亦无业报者。依无余涅槃故。言以是义故作如是说。若无苦及无乐者。则是圣性。如前说言。彼则无业者。三修多罗句者。说彼业差别。第四句说众生差别。依菩萨涅槃故。言是性平等如虚空。乃至是性真净。从本已来毕竟净故。是性平等如虚空者。示现等同行自益他益故。是性无胜。一切诸法等味者。示现诸净菩萨中彼不异故。一切菩提分法中不异胜故。是性寂静远离身心寂静者。示现彼体不异故。是性随顺向涅槃者。示现他身中有彼身业胜故。是性寂静远离一切烦恼垢者。示现虽同解脱灭习有胜故。是性无我离我我所者。示现净世界永灭定故。是性无恶若虚若实。从平等生者。示现彼行中世间涅槃无失无得不生分别。以平等故。实义故。涅槃是实虚义故。世间不实应知。是性真实第一义谛者。示现离彼谤及非外道共故。是性无可尽毕竟不生者。示现虽得无余涅槃不断作众生益故。复是性毕竟不生者。示现彼非烦恼业生。以得胜自在力生故。是性常住一切诸真如常者。示现住世及涅槃者。彼不是故说彼性是安乐清净无我等应知。是性真净从本以来毕竟净者。示现尔焰障净故。随所应净。显示如是净故。是故乃至世间出世间对治差别大义事应知。此是以渐次及超次释应知。迦叶菩萨至于四方应利益众生者。示现以世间出世间智等利益他故。至四方者。何等四方。谓为教化众生故。从世界至余世界。以神力故。从一世界至余世界。中间如从国至余国故。还彼世界中来生故。及彼处处取生故。令净他故。随有众生。彼诸菩萨所教化者。为彼净故。作真实毕竟治者。菩萨治烦恼以烦恼。大颠狂众生。菩萨治故。得成无上大医。教授三种清净戒行故。非耆婆等诸大医王能治诸见。及治除疑悔者。或复治大者。真实治故名治大。大者谓真实不以是义。然后真实毕竟治。以出世间道行灭烦恼使故。成是中间世智有二种。一粗二中。粗灭烦恼对治故。中者以伏对治故。所谓多贪欲者。不净观对治。乃至灭一切诸倒。有四倒如是灭。粗烦恼对治。四念处乃至八正道。中者伏对治。是中粗烦恼于现境界中贪欲等行故。转成中应知。是中行者。以世间智自境界相防染等烦恼。贪伏已令净性行。是中性行。是中性行差别。在家之者多贪嗔痴等行。出家者多依诸见。以依彼故。及依不正念性念。性念分别广略四种倒。非解脱处生解脱执慢。是中贪欲等。观不净对治令清净。嗔者慈悲观对治。痴者因缘观对治。诸见者空对治。不正念所摄分别。及性胜分别中无相对治。复有悕愿者无愿对治。非解脱处生解脱者。非不倒对治。譬如此处是常。是中烦恼。何者防粗烦恼。依自对治。依染境界。贪嗔痴事。于现境界中贪等行患。集是行义。灭彼故修念处等诸菩提分法。以修念处法正念中系故。于未系念心令得系念故修行。不以此念自心起取言我。修念处诸念中系心。已修行正勤。如意足取住。以取住故。身心从男女相。以内知观故。伏中烦恼。于有无漏智行道故。出世间法对治。灭不欲等。依欲等对治。非与根力而令作见。于有因缘集痴。及人无我痴。以菩提分法伏。于有不正道及正道行中决定成。如是所有此处相粗中烦恼正防及伏对治。事智者。是名世界智。何者出世间智。如是伏贪嗔痴烦恼染处。及所有微细使烦恼。对治事智。彼复何者。于彼伏对治中。善巧三处。所谓缘智善巧因缘。无我无众生无命无养育无富伽罗法中生信智。可信人无我故。于空无分别法中不生怖故。信法无我故。求心生精进。所有尽度过诸烦恼。对治教四种。无智不取故观内心用意于智。同相自相染相及净相。于无智是中有三种想。同想义应知。彼如是求心。何者心可乐可染可耻。为过去未来现在所有。过去者是名尽。未来者未至。现在者念念不住。是中过去未来缘成心皆无觉观。现在者念念无觉故。及诸贪等自缘所生。非心所作等。诸相心自相应知。迦叶。是心不在内不在外不在中间。觉故如是心求不可得。如本说假名说性。不可得故。是心无色无形无住无相无记无著。如是如前六种相。知真如故。一切言诸佛不已见不今见不当见故。一切诸圣不以知见觉故。种相故心有染相应知。不顺不顺故。及行行故。故心如幻。以虚妄忆想分别起。种种业行生。受种种身心。诸道中受种种身生。不顺染故。心如流水。生灭不住者。还彼生以自顺念念流故。心如风远行去不可捉者。一切念中难治。顺行故心如灯焰。众因缘有行者。受润自在。顺行染故。随所行而能行故。此是行染。何处行心如电。或向作善处行。或如电生善心时心如虚空。或向不善。知如虚客尘烦恼染故。心如猕猴。一向贪诸境界故。心如画师。一向起作诸业行故。迦叶。心不一定。能逐种种烦恼者。或一向烦恼中。复能行贪欲嗔痴。不住而行故。心如独行无侣者。非彼本有染贪已而有成离已离。离欲已而复有欲。如是等释。说心如王。得一切法自在故。于乐法中得自在世力而行故。心如怨家。能生一切苦故。舍己乐能生苦故心如灰家。如鱼钩。如梦。如青蝇。以执无我故。自能生苦。然以颠倒如怨家。助自己苦不厌足故。心如夺人力夜叉鬼令修善舍。彼觅便故。心如怨家。行不善觅诸过故。常高下有势无势。爱憎等解故。心如贼至放逸故。所作不作。一切善根能灭故。心乐诸色等。色等境界乐着故。于永可得甘露界中忆念。忆念已令难安故。以三种相故。心得清净应知。不得得相故。非有为相故。二无相故。三性相故。迦叶是心求。不可得。若不可得故不可觉知。名性求觅不可得。是不得故彼不可觉知。心有如是。相观是心净因已故。有异思惟行。求心净不能得。如是思惟已令能得。是名不得得相。如是修行法。无我修行。行已以慧。是真如相。心以智见。然后真如相。心以九种相说。对有为相法故说九无为应知。过三世者。非三世行故。复非如入灭尽定。起已复能生故。彼非有非无者。假名性不可分别测故。以真如性可测知彼非二相故。彼不生者。无生相故。彼无性者。过生性因相故。彼则无起者。未来中过诸生故。彼则无灭者。过分段死故。彼无所离者。过离念念故。无所离者。则无来无去。无退无生者。过转诸道故。是中无行业者。过业烦恼故。若无为者则是圣种性。是中性相者。谓无为界相应知。以见彼故。显诸圣事。然彼现法中过五事。若圣性。彼无有持戒者。过作事故。亦无破戒者。过无作故。无行者。过作行故。非无行者。过作非行故。及非行者。过不作行故。及未来过有事故。是则无心无心数法者。过诸复有生。发起行故。无发者。过彼行故。无业报者。过彼生家故。彼无有苦亦复无乐者。过彼所依有势无势故。是中无业无起业行。然彼性中非身作业非口非心者。依苦乐一切有记动转故。无业者。过诸学戒故。无起业行者。过诸愿故。然彼性中非身等作业者。过不受报故。彼性中亦无上下差别者。过依彼种种身故。然彼有四时九种相差别性相应知。不净时净时证时及尽时。是性平等如虚空者。不净时等至一切诸相。如空如虚空遍。一切色一切相中真如亦尔。现者净时见等至。此是不净时。一相是性无分别。一切诸法等味故。是性寂静远离身心寂静者净时。一味及身心寂静故。净时有二种相应知。是相寂静随顺向涅槃故。是性清净远离一切烦恼垢者。永证故。是故随顺及以清净。是故顺向尽至证得时。是名证时。初相是性不等离我我所者。过身见证时中第二相故。是性。无恶若虚若实从平等生者。过彼根本恶见故。还彼第三相。是性真谛第一义谛者。此说永尽时。彼尽中住者。常故及成就诸乐。过三种转变故。是中三种转变事。一者生死等转。二者倒处转。三者退净转。是性无尽毕竟不生者。过生死等转变故。是名成就尽时中初相。是性常乐净无我者。过颠倒处转变故。还彼后尽至中第二相。是性真净从本以来毕竟净者。过退净转变故。还彼尽至中时第三相。是故乃至世间出世间道行示现益他。故言。迦叶。汝当自观内莫外逃走。乃至迦叶。行道比丘随心所缚应当求解。迦叶。汝当自观内者。有何渐次。如彼性所显净诸圣。彼已示现。如今随如圣所生。彼答显说

大宝积经论卷第三大宝积经论卷第四

        后魏北印度三藏菩提流支译

迦叶。有当来比丘如犬逐块者。是中向外道如犬者。色等五种境界如块。掷者如畏色声香味触示现畏诸境界。彼畏境界。不证知畏因故。示现有四种相故。唯逐境界。住空闲处者。为欲转得胜境界。取空闲处。彼住独无等侣。除彼杂染。永住无二。以身离五欲而心不舍。是人有时或念好声香味触。贪心微着而不观内。不知不觉故。忆念诸境界。忍故彼不知。云何当得离色声香味触。彼以不知不觉故。后时来入城邑聚落王都等在人众中。还复为好色声香味触五欲所缚。故还复退。若空闲处死者。持俗戒故。便得生天有。为上天五欲所爱缚。复彼从天上灭。亦不离四恶道。何等为四所谓地狱饿鬼畜生阿修罗道。天中生堕。尽依贪欲行故黑朋应知。依见行故说白朋应知。以见人无我故彼对治释成二种黑白朋等应知。如是修诸行已。有散心令使摄取。已摄者令得解脱。是中修多罗句喻。以不入定心。为得解脱故。说诸方便舍摩他取舍诸烦恼舍摩他等相错心治。故显说咽喉喻及缚人喻。等以一心定心中说解脱方便。示现见修相烦恼中说方便令灭故。彼障身见爱乐三昧故。如咽喉及缚喻等识故。证谛时以出世间智。作令难故。身见如咽喉处病应知。如是行行已防有防等法故。说二种空喻不净心。一者读诵世间外道经书诸论等。二者多畜好衣钵依业及依身故。此诸二法能令得二种缚。如次。一见缚。二利养名闻等缚。然此二种能缚。以未生善法为令不生作障当得二种法。一者圣种朋。二者亲近诸檀越。已生善法。能灭及作污染故。令得二种垢。一者忍诸烦恼垢。二者贪诸檀越知识等。永断拔诸善根法故。令助得二种雨雹坏法。一者毁谤正法。二者破戒受人信施。现法中彼不可治故。令得二种痈疮。一者求见他过。二者自覆诸罪。现法中苦恶行故。令得二种烧法。一者有垢身心受着袈裟。二者受他持戒有功德人所礼拜供养等。未来喻者。为得不得不能生故。令得二种不可治病。一者怀增上慢而自伏心。二者坏他发大乘心。谤菩萨故。依声闻戒未来更有渐次应知。迦叶。当自观内者。如是乃至中有谁黠慧。调伏贪恼等故。说增上戒行多闻喻。生厌悔意故。明增上心戒行咽喉喻。及系缚人喻者。以人无我及法无我故。增上智戒行。若以调伏贪恼等增上心戒行。经所说者。何故此中说增上戒行。答曰。能发起贪恼行故。罪多因贪嗔痴等。相发起。是故说调伏贪恼等是增上戒行。问曰。云何贪恼等令能发起罪。答曰。有二种相故。如彼不能忏悔。如彼忏悔。而不成忏悔喻。若有诸沙门及婆罗门。不知烦恼因故。怖畏色等境界。住闲空处。自心发起。不善思惟故。亦起贪恼我慢境界。或余处念见贪等。随逐如犬逐土块。以块打故唯逐块。如是不除贪等故。若以聚落等所有亲近事作现念。是名未除。顺义故名除及以除竟。何故黑朋中说贪调伏。不说于恼。白朋中说恼调伏不说于贪。答曰。二俱欲界中故。示现有余调有余不调。示现有余调有余不调者。若在空闲处而命终。如是未调故。住戒者亦坏。成增上戒故。况复不住戒者。如马下道或错。如是行者行增上戒。以错诸念亦名乱。如咽喉病能断命根。如是依人无我行增上智。以身见能断法命根。如有人随所缚处而求解脱。如是依法无我行增上智。随所性脱。妄念中令计心。此三修戒中。有八种戒相违法。有八种随顺不净心。读诵世间外道经书诸论等。多好衣钵等无所用故。如空横染。横染是缚因故。渐次说二种缚一者见缚。二者名闻利养缚。于缚作因故说此渐次。以见缚故。憎谤圣种朋。以利养名闻故。亲近白衣。如垢障因故。渐次说二种垢。一憎怨谤圣朋。忍受诸烦恼。二亲近白衣故。贪诸檀越知识等。是垢如雨雹因故。次说雨雹。忍受诸烦恼故。毁谤正法。贪诸檀越。以亲近破戒缘故。说破戒受人信施。于雨雹因故。次有痈疮。以毁谤正法及破戒受人信施故。自覆诸罪故。烧煮痈疮因故。次说烧法。求见他过。说有垢身心受着袈裟。以自覆罪故。受他持戒有功德人所礼拜供养等。于烧成病因故。次说不可治病故。言有垢身心受着袈裟。而怀增上慢。而集戒心故。受他持戒有功德人所作礼拜供养等故。坏他住发大乘心。对此故说白朋应知。此二人中初是见行人。第二贪爱行人应知。有四种沙门者。以何渐次示现。如彼违戒法患。或亲近。或舍得人患。或得人功德已所有于念中成障。或非障者。彼示现是中人患有三种依三种人故说应知。形服相沙门者。心行俱坏。依喜恶故说依义。诳诈沙门。及名闻沙门。行成就而坏心。依二种喜欲大及有喜欲。是中喜欲恶者。若言沙门而非沙门。怖大者。若有诸德。而自意过有自德。恒作是念。有喜欲者。若有德而与德等生心。初者有二种坏行。一者有余。二者无余。有余者。依四沙门故说应知。依于受戒有漏。乃至行不净意业。就此三不善调伏等。如次示现。依乞食故。说不净命。依受用故。说悭事受用畜聚[卄/積]宿等。依修业故。说不净命。依受用故。说悭事受用畜[卄/積]宿等。依修业故。说懈怠。无余者。以破戒故。教犯根本戒故。坏心者。以恶法故。及覆藏彼故。第二成就行故。依行命戒受用。及修道应知。是中成就行者。依行故。成就境界者。依命故。成就威仪者。以染心四行故。依戒者受用粗。涩食故少欲四。圣种性者。依受用故。言不亲近诸道俗等故。依修道故。少言少语故。乐寂静依论说慰喻等应知。虽行如是等法皆为诳诈不为善净心者。以坏心故。依修行行故。诳诈应知。常有我见者。依人无我不灭我见行行故。于空法中而生怖畏难。如临深坑。依法无我不分别空。及彼说者生怨家等想。第三者成就行顺住念。依止及依行。随顺诸法应知。是中住者持戒。念者多闻。念彼故得顺诸事。依止者。空闲处坐。以空闲坐故。顺诸功德。随顺诸法者。少知足少欲等。违心于亲亲中应知。是中不灭诸念者。示现有厌离欲。彼对治故。灭炽然等欲。三菩提故。灭三菩提。以道行果故。第四人二俱成就。以九种成就势应知。一常行势二多闻势。三欲势。四寂静思惟势。五正见势。六证势。七灭势。八修势。九正证势。不求身命者。以不惜身命故。是名常行势应知。乐闻空等法意喜者。明第二多闻势。亦不喜空见等。复不喜涅槃修诸梵行。何况悕求三界。不悕求诸见法。亦应灭法故。彼果彼道得涅槃意故。说第三欲势。常依止于法不依止文字章句者。诸烦恼求内解脱。不向外逃走。以依止法故。求禅解脱思心世间智等。第四寂静思惟势。于一切烦恼常求解脱不向外求见一法本来性无垢毕竟清净而自依止亦不依他者。性不染故。有学出世间法自内知见。第五正见势。以正法身尚不见佛。何况色身者。以不见三宝故。真实三宝。亦以出世间智分别念故。第六证势。以空患离上不见法。何况贪着音声言说。以灭除所应除者故。第七灭势。无所修应修者。以修故。第八修势。不生生死不着涅槃。知一切法本来寂灭。不见有缚不求解脱。是故不舍世间不证涅槃者。以灭世间因故。及以得涅槃故。不生世间不求涅槃。不悕求死及寿命。不求解不求缚。已灭故。及有余分故。不行亦不灭。是中性灭尽无生智等所摄诸无学法应知。是名第九正证势。所有彼三种沙门立沙门名。彼名无义。及不相似示现。以名所伐故。说贫穷喻。云何以名所伐。异沙门名形服故。妄受信施利养。自此已后非真实行。沙门及识知起我慢。真实行沙门故。并持戒识知。颠倒说似如持戒故。闻思修等智。依彼慢故说二喻譬。如有人漂没大水渴乏而死。此喻示现以有闻慧故生我慢。药师喻以有思慧故。乐着三摩拔提。凡夫离欲者。乐着利养恭敬故。有学者。起悔修三摩拔提者。修慧邪行故。示现行正行中起我慢故。说余三喻。初名病人喻。第二者宝喻。第三者死人喻。依戒起彼慢故。示现有四种破戒比丘。自善持戒等喻。是中初者假受戒。第二者说不善持律明了懈怠。三者以行似彼故。于破戒障坏故。说坏障戒。第四者说具受十二头陀功德。是假名持戒。是中初者见患灭破戒对治障故。名为破戒应知。有者以破戒故。不可持彼中一。于涅槃中生恐怖。不能灭破戒障故。修行对治。第二以我慢故。生得解脱相。对治彼故。说诸真实持戒功德。然破戒恶所显及修道行所显。是中初持戒者。说内入非外入故。第二说作染业无作。善无作非是身等作。染业亦无非作。是能作善无行无非行。依杂染不杂染。依乞食无所行亦无不行依。杂染不杂染受用故无名无色无余涅槃。无想无非想无相行中。离念一切想故。及念无想戒无灭无非灭。无学行于涅槃有余故。烦恼无余故。无取无舍。常行离喜忧故。及舍念同生有故。无可取无可舍。还彼初境界不取忧喜及取舍念同生故。无众生无众生名。乃至无心。无心名依解释喻既灭随所能记。及随所记随所者。无世间无非世间依器世间杂不杂行人行故。言无依止无非依止。依杂染及不杂染。依六识村田境界故。言不以戒自高不谤下他戒。依亲近家故。亦不忆想分别。彼戒不分别。我是持戒。我有如是持戒。不分别彼性故。无漏亦有世间共可灭。寻即显故说不共。然彼若三界非果。非求三界因。是二句示现是名以渐次。依于戒有顺不顺诸法故。说善学不善学沙门差别事。何者不善学沙门。是中有三种应知。形服相似沙门。不惜沙门戒。唯形服同。不同者。形命受用与命戒见心不相似等。是中形处及服处故。名形服处相似。是中服处者。以彼僧伽梨等故名服同。形处者。以剃须发执持钵故名为形同。以不净身等业行故。名行不相似。不净命故。命不相似。悭故。于受用中不相似。懈怠故。用行不相似。破戒故。于持戒中不相似。以恶法故。于见不相似。不调不伏不隐诸根故。于心不相似。二威仪诳诈沙门者。乞资用精进用等应知。增上心增上慧同。彼行及心不相似。成就用意等故。增上戒同。一心安详故。乃至不乐杂乱故。增上心行同。少言少语故。增上智行同。诳诈等彼行心不同故。三名闻沙门者。唯求名闻应知。舍摩他分同。毗婆舍那分同。彼二分修同。还彼二助行同心性不同。是中以戒故。有戒分故。舍摩他分同。戒是三昧因故。以多闻故。于毗婆舍那分同。闻能领得无漏智故。以住空闲阿兰若故。彼二修分相似同。于空闲处住修因故。少欲等彼二助道行同。彼少欲等。是助习行等故。亲近他故。心不相似应知。何者善学沙门。有四种相应知。行故心故证故及尽至故。以不惜身命故。于现法中得厌悔行故。空等沙门意喜故。未来生教化身行故。是名行势应知。以依真如行故。信法无我意故。不喜涅槃故。及不喜空故。所应得及所能得。彼亦离假名性相。不正执故。常依了义不依文字者。悕求所须义故。于烦恼中而求解脱。不向外逃走。不如随声性故。是名心势应知。见一切法体永清净不染。以真如法故。作助己形及他。不缘他智性。不染证故。是中诸报等尽见解脱。不见假名性相故。是名证势应知。一切众生自性灭故。不行善修一切烦恼染等对治故。不取灭度。真如不断故。及不观非事。是名尽至势应知。是中贫人喻。与不善学沙门。以三种相故。于名不如义应知。坏心成就行。成就心而坏行。亦坏心及坏行。是中坏心成就行有三种应知。能闻及所闻心为知足。能说彼中而为知足。得世间三昧故。及得彼功德以为乐着。是中漂堕河喻。说坏心成就行。唯有闻等事应知。医师喻还彼唯有说事应知。幻喻得彼世间三昧。唯乐着彼事应知。摩尼宝喻成就心而坏行应知。死喻说坏心及坏行应知。长者子喻成就心及成就行应知。以一相义故。善学沙门应知。说有四种。破戒比丘似善持戒。有何渐次。以真实沙门。示受真实行。以示现如戒相似住假名戒。示现假名戒。示现假名戒何者。住假名戒行有四种应知。彼复以我慢等坏身故。名为住假名戒行。初者成就六种戒。以二种障坏戒。何者六种行。分戒持成。依波罗提木叉所说而行成就。行成就坏境界成就。于微罪中而见怖畏。受而修行。于诸戒中有二种障。何者二种。身见炽盛令戒中起。及命知。第二舍彼二患。离身见炽然处故。以律师故。于诸犯戒善能发起。然以等世间净故。诸利养不能动。同生身见。第三此同法得世间净戒。复同生身见。不解法无我。闻生恐怖懈怠。第四离一切与患。然以信邪法无我故。坏我慢戒。住四种不正戒。觉知谤等法戒。彼相彼无漏应知。何者谤等法。初住假名戒者。亦见有我。亦言有我所。对治彼故。言无我无我所故。所作犯戒者是名不作。对治彼故。言无作无非作故。作行彼亦非行。对治彼故。言无有所作亦无作者故。安详行亦名非行。对治彼故。言无行无非行故。妄念行者是名非行。对治彼故。言无有所行。亦无不行故。第二住假名戒行。身见朋烦恼随顺。亦见名及见色。对治彼故。言无名无色故。未来生想定有及彼想。对治彼故。言无想无非想故。彼炽然灭使者亦名不灭。对治彼故。言无灭无非灭故。执人无我及舍取人。对治彼故。言无取无舍故。还彼众生无我执中。亦可取亦不可取。对治彼故。言无可取无可舍故。不以色等执众生相。彼说取善哉。对治彼故。言无众生无众生名。语亦说彼取善哉分别。对治彼故。言无身无身名。无口无口名故。彼分别是心。及彼取分别善哉。对治彼故。言无心无心分别名。第三住戒行者。上生世间亦向舍下故非世间。对治彼故。言无世间无非世间。依三昧亦依不贪欲。对治彼故。言无依止无非依止。摄取自戒不毁他戒。对治彼故。言不以戒自高不毁下他戒。第四住假名戒。言我是能持戒。生分别念。对治彼故。言亦不分别戒故。胜性念等戒分别念。对治彼故。言不分别戒及不念此戒故。是名谤法。无漏戒中尽能灭尽。是名诸圣持戒无漏足句。无所著者。出世间故。不至三界。理不顺一切烦恼故。离一切依止。对治离三界故。是故于有还净示现胜。彼持戒故。说诸偈应知

  具足持戒者　　无垢无所有

初偈第一句。离垢故说性清净。贪欲等有余离已。彼因净故得戒性净。示现同因等净。余三句者。还彼持戒。示现同伴等因净。是中破戒同伴。及诸同因对治故。于戒同伴及诸同因者。有三种差别应知。是中破戒同伴有三种。慢同色等。依止因故。迷惑意故。见如愚痴。同乐三摩拔提。屈复同伴取念。同事念者。如鹿处同身乐爱喜伴。是名第一偈义。还彼持戒中一切相。明依清净戒故。说第二偈应知。寂灭常毕竟如是等。是中有四种性同患对治故。说波罗提木叉戒清净应知。以不阙故。于受戒禅净。余者。无漏戒净。还依彼持戒。无诸患净。故说第三偈

  不贪惜身命

如是等有五种患。何者彼五患。一者利养恭敬患。以惜身故。二者懈怠患。继念莫死起乐命故。三者起愿持梵行患。希求一切有生故。四者唯戒为足患。不正至故。五者不出至患。如诸外道说成不正理故。远离此五种患故。释成清净无诸患应知。依无烦恼净故。说第四偈

  持戒不染世

世法不能染故。依集谛所摄染。同至炽染起欲处。二识着诸爱染故。言不依世法耳。不依世者。灭前复有爱故灭

  速得智慧明　　以得光明故
  于见谛道中

无碍无所有。无碍无所有事。以修道无明等及余对治彼故言

无我无彼相。离我他相故。依无学道离我慢清净故。说第五偈

  无此无彼岸　　亦无有中间

无相行中不着内外入故

无著缚无漏。灭烦恼及使炽然灭故。无谄及无漏。无我慢差别。明依永净故。说第六偈

  心不著名色

于有不起愿故。不离寂灭法。彼者以持戒不足故。诸根调伏故。于三昧中不足故

不生我我所乃至有顶世间。知足故。住持戒故。说于戒中永示现依世间净故。说第七偈应知

  虽行持诸戒　　其心不自高

示现以持戒故。心不生高下。无厌足故

  亦不以为上　　过是求圣道

净持戒者。此相以三昧不足故。求出世间道。依出世间净故。说第八偈

  不以戒为最

不以戒为足故。

  亦不贵
三昧

不乐着三昧故。

  过此二事已　　修
习上智慧

无分别是圣性。无分别是修摄取增上智。诸佛所称叹。是故知余者胜叹事故。依有学无学非有学非无学净故。说第九偈

  心解脱身见

灭有分别身见。示现学戒净故。

  灭除我我所

以灭同生身见故。示现无学戒净。

  信空佛境界

以信空故。示现非学非无学净事。依吝着净故。说第十偈

  依戒得三昧　　三昧能修慧

示现未得八圣道戒故。说不持戒净

  依因所修慧　　速得于净智
  以得净智故　　具足清净戒

示现以得圣智故。后得戒清净。说此偈

时八百比丘。不受诸漏心得解脱。三万二千人远尘离垢得法眼净。示现此教诲中有如是等大利益。亦复示现现即得大果。于化者有学无学等得故。及五百比丘得禅定者。闻此深法。心不信解不能通达。从座而起去者。示现彼难调伏能调伏已。不能信解不能通达入深法故。有二种相。不能通达诸法。以不信故。以信不乐故。智慧不能通达诸义故。是偈甚深者。难知故。诸佛如来菩提甚深者。意难测量故。彼若不淳种诸善根。恶知识所摄。自信力少难得信受。以恶知识所摄故。不淳修诸善根。以不信多故应知。尔时世尊。语尊者须菩提。显菩提时诸声闻是如来作。堪能化度胜义故。是故乃至假名真实差别应知。尔时世尊。即时化作二比丘者。示现如来方便应度故。示现化者有二种相故。示现信于同服及见同法事故。彼诸比丘摄取。为已说正教诲故。彼以妄执取涅槃。生我慢故。生怖畏。为信故。说如实涅槃无有众生。若入涅槃者。非诸贪欲等有故。而有尽灭。彼者如不生故。示现涅槃者。唯灭不生故。言汝等莫作忆想莫作分别者。于内外入中是我我所。如次。即于诸法无著者。以贪嗔本来无生故。无离者。未来不离故。是名寂灭者。防护此执。本非寂灭而有寂灭。所有戒等品。彼亦不住不来。复不灭尽者。以众生名永寂灭故。不住不来者。以不染故。复不灭尽者。性自灭尽故。彼者亦无余。若本不寂灭已于后成寂灭。汝等可舍离是相。所谓涅槃无彼事故。言勿我入涅槃以相向涅槃故作涅槃相。勿以贪欲等相故识为涅槃相。非贪欲等无故。名为涅槃。是名彼者相。复无相行中方便。设无漏已。次后说现法乐行方便入灭尽定行起故。或复此是异义。经言。彼若不淳种诸善根者。智慧功德助道行乏少故。增上烦恼尘是义非恶知识所摄者。以善知识所不摄故。坏是义不能信解者。离智助道行故。能信甚深处是义不能信解者。是故总不能通达者。不能测量知法体智住故。复不能信解。已不能正决真智故。如来化度方便事有二种应知。化者以我慢共体故。示现同共事故。所说能顺行教故。及得教诲有出世因故。说正净教方便教授故。彼复有四种相应知。染净中恐怖故。依顺说故。离授烦恼因。于净法中教授。舍恐怖因故。及教授现法。见最乐行方便故。此身复有我见。以我正证故。依于净染中顺空教授故。言我当无辜生怖染。以染故。世间行是名初相。汝等莫作忆想莫作分别者。烦恼因示现有二种假名性。慢执烦恼分别性故。及执彼功德患胜分别故。是名第二相。净略有二种应知。一者净道行。二者涅槃净。是中有二种相故。净道行是怖畏因应知。汝等比丘。所有戒品彼不往来复不灭尽者。计是真如中永净故。前者释有烦恼分别。及离烦恼分别亦不成。彼净道行中烦恼及离烦恼。彼分别已。于净道行中而生恐怖。有二种相故。于净涅槃因中生恐怖应知。汝等可舍离是想。所谓涅槃不异假名性想执故。莫随于想莫随非想者。是名涅槃异想。忆作心想故。莫异想识想。莫异想观名。是名寂灭内心之想。复莫以想观想者。此二无因故。于涅槃中不生恐怖。是名第三想应知。舍彼二因故。教授最上行诸方便等应知。舍彼二因事。及舍烦恼因。于净法中舍恐怖因。是名第四相应知。于中乃至如来化度方便应知。自此已后说正智作大益应知。依六事故说。一者为因事。二者依事。三者响音事。四者寂静思惟事。五者训诲事。六者证法及顺法事故。言尔时尊者须菩提。问彼比丘言。汝等比丘。去至何所今何从来。诸比丘言。须菩提。佛所说法无所从来去无所至。有何义故。作如是说。初依乐因故。以何义故。彼处无有来往。喻若世间。复问谁为汝师。答言。我等师者。若先来不生亦无有灭。有何义故。作如是说。依第二因事。依非色身。世尊故。彼无生亦无灭。是涅槃性故。复问。汝等云何。从谁闻法。答言。不为缚不为解。有何义故。作如是说。第三依响音因事为说法彼不为缚。依上等生爱对治故不为解。彼已得脱故。复问。汝等习行何法。答曰。不为灭无明不为生明者。有何义故作如是说。第四依寂静思惟事故。不为灭无明故。不为依杂无明。诸圣闻有彼行故。不为生明者。已生故。复问。汝等师是谁。答言。若无得无知者是。彼弟子若未得及未证者。以何义故作如是说。依第五训诲事故。所有化比丘身劝彼。故第六证法及顺法行事。依十事故说应知。依有余涅槃无余涅槃。灭见谛行烦恼。灭修道行烦恼。灭苦。供养尊者。行布施行过凡夫地。入住圣人地。及同得至解脱故。复问。汝等是谁同习梵行。答言。若于三界不行亦非不行者。有何义故作如是说。无余涅槃有余事故。尔时共诸同法者住故。复问。汝等几何当得涅槃也。答言。如若如来所化人入涅槃者。我等亦当得入。有何义故作如是说。依有余涅槃。彼本起灭故。他力相似法本业应故。尔时共余者住故。复问。汝等烦恼尽耶。答言。一切诸法毕竟尽相者。有何义故作如是说。以灭见谛惑故。一切法永灭者。诸趣恶处故。复问。汝等已得己利耶。答言。知断无我无我所者。有何义故作如是说。依灭修想烦恼故。及灭同生身见故。复问。汝等破于魔耶。答言。阴魔不可得者。有何义故作如是说。灭苦故。及阴魔不可得故。未来生彼不可见故。是故于中降伏一切魔怨应知。以阴无故余魔不行。复问。汝等奉如来耶。答言。不以身口心者。有何义故作如是说。恭敬尊者不以身等。得涅槃中得亲敬故。复问。汝等作福田耶。答言。无取无有作者。何等故作如是说。檀越作敬不可取及不可作。离见动恶等故。如次复问。汝等断于生死往来也。答言。无常无断者。何义故作如是说。过非圣人地故。不断世间令作少方便非上者。以有涅槃故。此示现不断等事故。复问。汝等随顺圣人地行耶。答言离一切取有得无碍解脱者。有何义故作如是说。住圣人地故。离一切取解脱故。不横执离不正取故。复问。汝等究竟当依止何所。答言。随于如来化人。所至者。有何义故作如是说。解脱同至。于如来无异胜相似法故。示现解脱同至。或复以心得自在诸善男子。是能随时以能受于正记。为如是尊者故。为次说正记。能作大利益应知。何者密语。不二相智。及一切密语。入相不二相。何者是所说句处事。然是彼性无故。所说性熏一相。境界性相有故。不二。彼不二中生执。二相是染。不执二故名净。虽说所有说一切句处有事者。彼亦假名言熏相。境界性无故。彼二熏相。境界性有故。彼二。于彼不二执二相故。有染不执尽故净。如是一切诸佛入彼密语。是不二相应知。是中五种相者。于尊处及彼教授中有五种果事。及有五种果益事。成就持故说诸密事应知。有五种相。何者五种尊。若有想说彼成就故。成就尊事应知。复有何义。谓涅槃永证彼故。佛所说法无所从来去无所至。离六种入灭故。彼界中诸有等。谤不能谤故。及无分别觉故。一切诸法何者是彼尊。而能说法。彼有何相。先来未生亦无有灭。依法身无生灭故。说何等法。若不为缚不为解。缚解者。性相无故。为令觉知诸行故。以几种性相说。不断灭无明不生明故。明与无明假名性不可得见觉故。为谁说若未得及未正觉。正觉不已彼无故。何者成就果胜事。谓无余涅槃界故。若于三界不行。依无余涅槃界处。唯净真如住处故。作如是说。有余涅槃界。若如来化者。而入涅槃真实处。唯有性涅槃。一切诸法依世谛涅槃故。作如是说。能满圣道行。所作已办故。言我作已办。于有我无我。我所。依证法无我故。作如是说。伐内怨以内力故。诸烦恼怨以证法无我故。永灭说故。作如是言。伐外怨不觉见阴魔故。所有外阴所摄。阴者。外怨声说应知。胜彼者。离分别念。阴性不觉故应知。是中成就果利益事者。已恭敬于尊。非身等耳。以顺行法故。善净受信施所施故。以了福田不取一切法故。度世间苦海。度世间者。以法无我。不断及常故。不退于福田处故。行福田地。舍取法慢故。及法化者名成佛子。依如来故。言汝等何行去无所至者。如如来所化者来故。须菩提如是问答诸比丘。时有八百比丘。不受诸法心得解脱。三万二千人远尘离垢得法眼净者。此正授记中有此大利益事。若有学者得无学。成熟凡夫得有学地。世尊此宝积法门是希有。能与住大乘善男子善女人作大利益者。自此已后显此法门说大利益事。以有益故。于诸菩萨成佛法。及化众生故。以中道义训诲等如次。彼善男子善女人得几功德者。示现闻菩萨藏中有教诲信益事。迦叶。若有善男子善女人。如是等示现有五种相现利益信事。一世界持时大德。二自在成就退因故。三转身故。四彼处故。成就说堪作器故。五听者作器故。及舍身时得见净业故。是中世界。大者。佛及彼声闻并诸塔等。持者。诸宝满诸世界衣服等。是时无量阿僧祇劫故。是中有五种相。得大自在因退事应知。以有量悕无量果因故。以有尽无尽法故。以非上得上乐故。助知道彼行性故。及以彼引取故。复有五种相。令得成就大自在退因事应知。一微恶乐因故。二不定一向乐因故。三不永乐因故。四颠倒意受乐因故。五依苦身受乐因故。是名彼者。最后受女身转身故。及彼地处所敬如圣塔故。彼处所以为作器故。随彼法法所读诵受持等者。明说者。为作器故。彼人命终时得见如来。得身口意业清净。舍身时得见净故。及得净业故。无有诸患。而令命终离诸苦受故。及以离忧恼因故。忧恼心不能降伏故。不动眴诸目识。谛知诸意有故。不动摇手足。成就威仪故。不失大小便胸分无汗。以无畏故。不作卷不摸空。无诸恶相故。随坐而舍受命者。以身调伏故。善正言音者。以离诸畏难故。滑利言音者。以离涩恶言故。上妙言音者。以上妙言说诸佛如来妙法语故。爱乐言音者。赞叹说诸如来故。天人所乐拥护言音。及柔软言音者。同法者以理施答对故。不背说言音者。以无诸妄故。快说言音者。前后言不相违故。可取言音者。不违顺理语故。天拥护言音者。信佛法诸天拥护故。诸佛所拥护言音者。诸佛摄取故。不嗔现得恶能忍故。不恨者。能忍过去恶故。不忿恼者。不覆诸恶故。不怀报者。忧悔等热不能烧故。不计过患者。不悕求贪欲等故。不怀者。以不悕求保故。无有异相不怯弱心于戒法中者。不取异见故。常不放逸勤心精进者。不乱寂静心故。以不怯弱心取佛世界清净者。以不喜自身诸佛菩萨所持而取上妙佛世界故。离慢及增上慢者。得一切佛法现气故。离慢及增上慢者。世间三昧三摩拔提。微细深心分别以不求。以用一切佛法现气因。得不以胜。一切诸佛三昧为菩萨藏。得教诲中正信利益事。如是无量阿僧祇。彼分别从本差别。信益转无量无边阿僧祇应知耳

  作此宝积论　　我所得功德
  以勇意净故　　愿世得究竟
  妙法宝积经　　无垢大智明
  此论除翳障　　造写所得福
  所有着诸见　　及堕无智网
  无障碍佛眼　　愿世速令得

大宝积经论卷第四


大乘四法经

    No. 1535

大乘四法经释

一言立所宗者。世间宗见惣有其二。一外二内。彼外宗见虽有众多不出二种。谓断及常。广说如论。内宗见者。大师在世。同一师学无有差别。佛灭度后。大小乘宗分成多部。小乘宗见有二十二。如宗轮论一一广明。大乘宗见分为三别。一胜义皆空宗。二唯识中观。三法性圆融。此三宗见一一广说。如中广百三十论等。今此经者。厥有菩萨名为世亲。位皆加行。造论释故。是故当知唯识中观宗之摄也。二言明归乘者。如来大悲引接群迷随机设教。有说三五。言说三者。一声闻乘。二缘觉乘。三菩萨乘。言有五者。更加天乘及人乘也。如是五乘所有行议。广如余处经论分别。今此经者。一一唯明菩萨行故。是大非小。是故当知。大乘宗收。三言明归分者。诸佛菩萨及以声闻所说言教。虽有众多。以类相从有十二分。谓契经等一一行相如余处明。今此经者。无请说故。自说分摄。不舍无上菩提心等。是其菩萨广大行故。方广分摄。有伽他故。应颂分摄。是了义故。论议分摄。具譬喻故。譬喻分摄。是故当知五分摄也

四言辩归藏者。如上所说十二分教。惣而言之归其三藏。一素怛揽藏。此云契经。贯穿连缀。所诠定学。契理契机益他故。藏者摄也。二者毗奈耶藏。此云调伏。所摄戒学。调和三业。制伏恶行而摄益故。三阿毗达磨藏。此云对法。所诠惠学。对向涅槃。对观四谛。而摄益故。契经等分云何三藏而相摄耶。对法集云。契经。应颂。记别。讽颂。自说。此是声闻素怛揽藏。缘起。譬喻。本事。本生。并伽眷属。名毗奈耶藏。方广。希法。此是菩萨素怛揽藏之所摄也。若唯了义亦阿毗达磨藏摄。如理应思。次当释经之正文。门分为二。一释经题。二释正经。初释题者。一切圣教夫立名者。皆约四种而立其名。谓人处法喻。今此经者。约法立也。言大者。有七大义。一所缘大般若等经所明。一切难行苦行。广大境界。是其菩萨所缘境故。二修行大。广修自行及他行故。三智大。能了人法二无我故。四精进大。三无数劫行难行故。五方便不住生死及涅槃故。六业大。尽生死际。能作诸佛一切业故。七成就大。而能成就十力无畏不共法等大功德故。以此七大。而起二乘故言大也。言乘者。运载之义。生死为此岸。涅槃名彼岸。有情名中流。此经所说四种法船。运载有情。超生死海。令至涅槃故。名为乘。言四者。数也。何故列数。论中自明。言法者。轨持为义。下经所说四种行法。即是菩萨轨则故也。言经者。梵言素怛揽。乃四义。谓依綖廗经。今取綖义。如綖穿花风不散。能以教贯义。邪不能除。如经持律方织物成以教摄生。令得圣果故。以教法目乎。綖经若真实论说有五义。一曰潒泉。二称绳墨。三名结鬘。四谓出生。五号显示。若准此方经者。常也。法也。迳也。古今不易故。揩定正邪故。津通物理故。庄严经论云。示处及于相法义名为经。释题竟


分别功德论卷

    No. 1507

分别功德论卷第一

        失译人名附后汉录

建初偈所说曰。迦叶思惟正法本者。谓思惟经法言教甚多。何以知之。迦叶即以比较明其多少。较法从十驴始。云十驴力不如一凡骆驼力。十凡骆驼力不如一凡象力。十凡象不如一细脚象力。十细脚象不如一盗食象力。十盗食象不如一莲华象力。十莲华象不如一青莲华象力。十青莲华象不如一红莲华象力。十红莲华象不如一白莲华象力。十白莲华象不如一雪山象力。十雪山象不如一香象力。从驴至香象为一分。如是八万四千香象。以较皮表里书经满如是数香象比载。阿难所闻所知事。粗可都较知大数。欲一一演其文字者。毕寿不能畅也。思惟经法甚为浩大。云何当使流布天下千载众生得蒙法泽耶。深思至理。谁能撰法。唯有阿难乃能集耳。迦叶即时鸣揵槌集众。于时寻有八万四千诸罗汉等。承命来集。此等无漏皆是俱解脱人。所以召此诸贤圣者。以其尽能入灭尽定故也。诸有入灭尽定者。能使众生现世得福济其苦厄。大千世界诸无著等。其数难算。除诸三道。各各一倍。今但录利根俱解脱。能以灭尽定度脱众生。是故称为福田。何以明之。昔日天帝释福尽命终。时五瑞应至。心即恐惧。欲求救护。正欲至佛所求救。念佛恩宽缓。惧不解命急。念舍利弗目连等亦恐不能济命。唯有大迦叶。以灭尽定力。寻济危急。即往迦叶所。时迦叶适欲至贫家。福度谛念正欲现天身。惧恐不受我施。便于中路现作草屋。羸病在中。迦叶从乞。病人即申手施食。迦叶以钵受之。变成甘露。还现天身于虚空中。迦叶曰。何以妄语诳我耶。天答曰。不妄语。我至诚施。我是天帝。五瑞至命欲终故来求愿。愿济我命。迦叶即默然可之。天至佛所听法。须臾便睡睡即觉。佛语天帝。汝向已死。今已还活。不复命终。还复本身。此即是迦叶灭尽定力之所感也。迦叶所以用灭尽定力最胜者。以迦叶本是辟支佛故也。夫辟支佛法。不说法教化。专以神足感动。三昧变现。大迦叶虽复罗汉取证。本识犹存。向所录八万四千众德。能所感功齐迦叶。难曰。迦叶以本是辟支佛故称其胜。此等罗汉复是辟支佛耶。答曰。虽非辟支佛。遍习灭尽定。其力是同。以是故言。迦叶众僧众生福田也。偈云尽得罗汉心解脱者。俱解脱也。偈云已脱缚着处福田者。谓迦叶所集八万四千众。皆得俱解脱。以灭尽定。能使众生现世脱苦。后获涅槃故曰处福田也。偈云集四部者。略也。理应四部表更有八部。人天。刹帝利。婆罗门。长者。沙门。四天王。三十三天。魔王。梵王。是为八部。凡有十二部。言四部者。粗举其要耳。诸法甚深者。谓十二因缘也。佛为阿难说十二因缘甚深微妙。阿难云。此之因缘有何深妙耶。佛语阿难。勿言不深妙。汝乃前世时亦言不深。昔有阿须轮王。身长八千由旬。上下唇相去千由旬。王有小儿。常爱此儿。抱在膝上。海深三百三十六万里。阿须轮立中正齐腹脐。儿见父谓海为浅。欲得入水。父语不可。海深没汝。故欲得入。父即放之。没于海底。惶怖[口*彊]嘅。父即申手还执出水。语曰。语汝不可。而汝不信。今者何似。尔时王者我身是。儿者汝是。昔日不信深。今故不信。汝但思无明缘行尚不能了。况了三十七品乎

如来所说四不可思议。何谓四。众生不可思议。世界不可思议。龙不可思议。佛不可思议。所以世界不可思议。昔满愿子与梵志共论。梵志自云。我曾至池水上思惟。见有四种兵众。来入莲华孔中。即自惊怪。不知我眼华为实有。是向人说之人皆不信。遂至佛所云所见。如是佛语。此是实事非为虚妄。阿须轮兴四种兵与诸天斗。阿须轮不如。退入此莲华孔中自隐。此非思度所及。故曰世界不可思议。世界或云梵天所造。或云六天所造。梵志又云。梵天谁造。或云梵天有父。或云自造。言有父者。父即莲华也。有云。莲华者何从出。曰忧陀延齐中出也。忧陀延从何出。曰从散嵯王出。又曰。散嵯王出何姓。曰刹帝利种也。又曰。梵天是婆罗门种。今言由刹帝利出。是何言欤。又曰。劫烧时粗可得别。何以言之。曰劫。烧时从地际已上。至十五天。荡然焦尽。如似可知。然复有十六已上三十三天在。此间虽烧他世界在。以此言之。复不可知。是为世界不可思议

何谓众生不可思议。或云劫烧后。水补火处。随岚吹造宫殿讫。下有地肥。光音天上诸天辈。游戏至地渐尝地肥遂便身重不能复还。食多化为女。转减至薄饼粳米。失神足光明。还复为人。善行生天。恶行三涂。流转五道无有常准。正使欲穷尽一人根本所由。尚不能知。况复一切众生而可思度也。是为众生不可思议也

何谓龙不可思议。凡兴云致雨者。皆由于龙。雨之从龙眼耳鼻口出。为从身出耶。为从心出乎。依须弥山止有五种天。亦能降雨。何以别龙雨天雨。天雨者。细雾下者是。粗下是龙雨。何谓五种天。第一曲脚天。第二顶上天。第三放逸天。第四饶力天。第五四天王。阿须轮兴兵上天斗时。先与曲脚天斗。得胜然后次至顶上。次至放逸及与四天王乃至三十三天。下四天欲斗时。以雨却敌。更无兵仗。有二种雨。有欢喜雨。有嗔恚雨。和调降雨是欢喜也。雷雹霹雳是嗔恚也。阿须轮亦降雨。天亦下雨。龙亦降雨。各各致雨理不可定。故曰龙雨不可思议

佛不可思议者。昔时佛在静室。诸梵天如恒边沙。来至佛所。欲知佛在何三昧。而不能知在何定中三昧。如是神足变现秘密之事。二乘所不能思议。岂况复凡庶。阿难推先迦叶云。耆年堪任为众演法。所以然者。尊长旧学多识世尊所委。为将来众生故。欲使正法久存于世。是以如来半坐相命。仁尊既是众僧上座。又复智慧包博。唯垂慈愍时宣法宝。外国师云。迦叶所以不说法者。于四辩中无有辞辩。又云。本是辟支佛。但以神足现化。初不演法。迦叶答让自云。朽迈情闇多忘。答曰。四谛真法岂可衰亡耶。喻如金刚不可亏损。生死四大乃有增减耳。萨婆多家又云。九种罗汉有退转者。以几事退。有四事。年在衰迈。疾病苦逼。好远行游。服药不顺。以此四事乃有误忘耳。真谛妙慧岂可忘乎。迦叶劝阿难曰。汝今年在盛时。加复有闻智等智。总持强记。佛每说经常嘱累汝。以是故汝当宣布经法。何以知阿难有等智。昔舍卫城东。有尼拘类大树。荫五百乘车。城中有梵志。明于算术。于九十五种中最为第一。在此树下与阿难相遇。谓阿难曰。人云。瞿昙弟子智慧第一。颇有此不。答曰。所知少耳。曰少欲问一事。此树茎节枝叶凡有几枚。阿难举头视树。便答之曰。此树茎节枝叶各有若干。即便舍去。梵志在后思惟。此沙门必不知数。其于见答乃尔。今当试之。即处处取叶六十枚。藏之土中。阿难乞食还。复问曰。我向忘数更与我说。阿难举头视之再遍。答曰。此树叶何以少耶。又曰。少几枚。答曰。少六十枚。梵志即叉手谢曰。未曾有也。又问曰。君是罗汉耶。答曰。非也。是阿那含斯陀含耶。曰非也。是须陀洹耶。曰何以问耶。又曰。有师耶。答曰有。真净王子出家得佛。即是我师。心念曰。此假师智非己所知。即随至佛所。求为沙门。即得罗汉。以是知阿难有等智

阿难所以推先迦叶者。既是上座。又是所尊。昔五百世常为其父。宿识尊仰凭仗情深也。迦叶所以殷勤于阿难者。以其曩积厚缘遗恩末嗣。加复闻等智强记。于众为上。属集遗典八万莫先。二人相须犹盲跛相赖也。互相为利。若二人卒遇千斤段金。正欲相并。力所不胜。正欲分割。不可加功。于是共议并势持归。遂得大用。可谓俱智迦叶阿难其喻如是。二人齐契法宝长存

时阿难说经无量。谁能备具为一聚。(经无量者十二部经浩漫甚多适时而说不论次绪或说一事也)乃云十事。或说十事乃论二事。或说三事乃说十一事。上下不次。不得为一聚。或有说者。如来说法。或说教诫。或说断结。或说生天人中。以是言之。复不得为一聚。阿难思惟。一便从一。二从二。三四五六乃至十。各令事类相着。或有说者。理不可尔。按如佛语不可次比也。阿难复思惟。经法浩大当分作三聚。阿难独生此念。首陀会天密告阿难曰。正当作三分耳。即如天所告。判作三分。一分契经。二分毗尼。三分阿毗昙。契经者佛所说法。或为诸天帝王。或为外道异学。随事分别。各得开解也。契者。犹线连属议理使成行法。故曰契也。毗尼者。禁律也。为二部僧。说捡恶[僉*殳]非。或二百五十。或五百事。引法防奸。犹王者秘藏非外官所司。故曰内藏也。此戒律藏者亦如是。非沙弥清信士女所可闻见。故曰律藏也。阿毗昙者。大法也。所以言大者。四谛大慧诸法牙旗。断诸邪见无明洪痴。故曰大法也。亦名无比法。八智十慧无漏正见。越三界阂无与等者。故曰无比法也。迦旃延子撰集众经。抄撮要慧呈佛印可。故名大法藏也。阿难复思惟。此三藏义与三脱相应。何者契经。妙慧理与空合。毗尼制恶。玄齐无相。大法正见。迹同无愿。故曰三藏三脱冥迹玄会。阿难复思惟。契经大本义分四段。何者文义混杂。宜当以事理相从大小相次。第一增一。次名曰中。第三名长。第四名曰杂。以一为本。次至十。一二三随事增上故曰增一。中者。不大不小不长不短。事处中适。故曰中也。长者。说久远事历劫不绝本末源由事经七佛圣王七宝。故曰长也。杂者。诸经断结。难诵难忆。事多杂碎喜令人忘。故曰杂也。阿难撰三藏讫。录十经为一偈。所以尔者。为将来诵习者惧其忘误。见名忆本思惟自寤故。以十经为一偈也

所谓杂藏者。非一人说。或佛所说。或弟子说。或诸天赞诵。或说宿缘三阿僧祇菩萨所生。文义非一多于三藏。故曰杂藏也。佛在世时。阿阇世王问佛菩萨行事。如来具为说法。设王问佛。何谓为法。答法即菩萨藏也。诸方等正经。皆是菩萨藏中事。先佛在时已名大士藏阿难所撰者。即今四藏是也。合而言之为五藏也。或有一法义。亦深难持难诵不可忆。(一法者即空法也无形无像不可护持)寂无声响。无心无念泊然无想。最第一空。义无二故。无容可测故曰难持。无言可詶故曰难诵。无意可思故言叵忆也。所谓深义其事如此。又复一法者。众数之本。一者数之始十者数之终。终于十复从一起。正至千万。常始于一。如是诸一不可穷尽。诸经之中或一义一法一行一事。各各相从。不失其绪也。故曰一一相从不失绪也。二法就二者。或云善恶。或云止观。或云名色。止者虚也。观者实也。止者三昧定。泊然灭想冥尔亡怀。故曰虚也。观所以言实。以其分别有行。是非好恶。识别明了意不惑乱。故曰实也。三法就三。三者布施也。功德也。思惟也。此三行世俗生天法。三脱门行至涅槃法也。诸有三法。三行三福三分法身。三三相从。喻如连珠也。四法就四五亦然。五法次六。六次七八法义广。九次第十。法从十至十一。如是诸数。皆同二三事类相从。阿难即时升于座。座者师子座也。经所以喻师子座者。师子兽中之王。常居高地不处卑下。故喻高座也。又取其无畏。阿难无量博闻。于声闻中独步无畏。故曰无畏座也(阿难升高座如此也)弥勒称善快哉说(弥勒所以下者惧阿难合菩萨法在三藏大小不别也)鋀金同贯。是以殷勤。劝请分部。昔大天圣王具四梵堂。展转相绍。乃至八万四千王。皆有梵堂。唯大天一人是大士。其余皆是小节。以是言之。大乘难辩多趣声闻。弥勒亦知阿难部分三藏。然犹惧后学专。习空法断结取证。是以显扬大乘。分为别藏。故说六度诸行。大士目要也。云施有二种。有信施。有恐怖施。立根得忍。则曰信施。威力逼迫不由本心。则名恐怖施。信则成度。畏则求福。道俗之殊。不待言而自别也。其人云头目施者。七住已上。财物施者。六住已下。从此退者。不堕生死。要至涅槃耳。何以明之。大品本无说中云。六十菩萨得罗汉道。此其事。戒如金刚者。大乘戒也。戒如坏瓶者。小乘戒。何者。金刚者不可沮坏。昔者菩萨比丘端正无比。出行乞食。路遇一端正女人。女视菩萨便起欲意。愿为夫妇。覆自思惟。此同叵得。但共坐者。我便发无上意。菩萨知女心便前共坐。有顷便前牵之。比丘默然不答。复重近之。如故寂然。比丘即与说空法。眼本从何来去至何所。欲言从父母来耶。未会之时亦无此眼。至后坏时复到何所。以是言之。眼无所有。五情亦然。豁然解空得须陀洹。应与说有乃更说空。菩萨法当入有而说空。是以不全本意。阿难时见此比丘与女坐犯比丘仪。即还白佛。向见比丘与女人共坐。佛以先知便默然。比丘知阿难白世尊曰。念我正不往。恐诽谤者堕罪。正欲现变。佛所不许。直飞至佛所。佛语阿难。向所见犯律比丘者。今此飞来比丘是。汝颇见犯欲人能飞不也。此比丘向者与女人共坐。时以女人心念。是比丘与我共坐者。我当发无上意。此比丘知女人意。便与共坐。即与说空法分别眼空。五情亦尔。女即恐畏便得道迹。以其恐惧心生。畏生死故得小乘。若此比丘向者与说有行者。还成本心。以此事知。是菩萨未成不退。于观人心未尽善也。所谓金刚戒也。所谓忍度者。见骂见毁默受不报。菩萨行忍。常以慈等等于彼我。彼我既齐怨亲不二。故经曰。小乘之慈慈犹肌肤。大士之慈彻于骨髓。何以明之。若人割截菩萨手足。变成为乳者。即是慈证也。羼提比丘便是其事也。喻若母人生子。便有乳出。此慈念所感。自然变成也。大士如是。入慈三昧故能感乳也。行慈之至。虽执弓矢。众生反来附己。慈之不彻。虽不执杖见皆舍走。以是证故。大小之殊有自来矣。作善恶行者。谓精进作诸善功德。恶行者。犹昔火鬘童子诽迦叶佛言。秃头沙门何有道。道难得能得道也。由是后受六年勤苦。方乃得道。遗法之中诸比丘常诤此。犹口不可言而言报也。六年苦行者。不可行而行报也。是为菩萨身口恶行也。禅定入寂泊然不动。智慧知尘数及江河沙数。亿载不可计。慧明所了不可穷尽。此六度无极事。尽在菩萨藏。不应与三藏合。阿难欲使大小殊因缘。彼不相知。其理自空。难可明了。大士疑空者。不取证故。云狐疑也

分别功德论卷第一分别功德论卷第二

        失译人名附后汉录

弥勒称善者。以其集此六度大法为一分。此即菩萨藏也。断结者。断诸望见结使也。成道果大乘萨云然事也。阿难但云闻不云见者。岂可不见如来说法也。所以言见为非者。为将来四部故。不得言见也。设言见者。后四部众复承阿难。言见者则为虚妄也。以是故但称闻不言见耳。初说法度阿若拘邻等五人。摩竭国降三迦叶。释翅即迦毗罗卫。若不得说经处。但称在舍卫者。以佛在舍卫经二十五年。比在诸国最久。所以久者。以其国最妙多诸珍奇。人民炽盛最有义理。祇树精舍有异神验。当众僧在讲集时。诸猕猴有数千来。在左右观听。寂寞无声。及诸飞鸟普皆来集。众僧正罢各还所止。揵捶适鸣已复来集。此由国多仁慈故。异类影附。佛或能暂行受请。或能神力适化寻还本所。是以但称舍卫。足知其要也。所以别称祇洹孤独二人名者。此二人先亡今在天上。亦集诸天说法教化。时心念言。我等本是众僧檀越。初不复称我等名字耶。欲适彼所念故。复别称二人名耳。云当修一法者。亦非次第说。若按初成说法。当从波罗奈鹿野苑。说四谛为始。次至摩竭降三迦叶。因称其精舍主名。便云当修一法者。以其一法之与四法其理味不异故也。一法亦断结。四法亦断结。俱至涅槃。殊途同归耳。都结二十一演为三十六。数虽盈缩俱为是结。凡事有百一舒。复为八万四千。是以一法之与千万。同是至道之径耳。犹师子杀象之杀兔同是一死耳。以其理趣不异故。便从一法始。无放逸者一法之宗也。或问曰。戒应在前。先当持戒然后念三尊。或曰。此为新学者。先念三尊。即三自归。运意在佛法众以次受戒。以是言之。戒应第四息念后。解云。闲静身苦念者。谓观身三十六物不净恶露。以自觉悟。可以成道。何以明之。昔有比丘。作阿练若行乞食。逢一长者女从乞食。比丘女人俱端正。女见比丘便起欲想。比丘见女亦起欲意。意动手掉。投饭于钵错注于地。女自怪笑。比丘见女齿白。即自觉悟曰。女人口中钝是骨耳。如佛语。人身中有三百二十骨。有六百节。七十万脉。九十万毛孔。一孔入九孔出。泄漏不净。无一可贪。谛观女身三十六物。惨然毛竖。专自惟察即解身空。得须陀洹道。复自念曰。我因女见法则是我善知识。今当报恩。即复为女说向所解观身法。女即心开亦得须陀洹道。以是言之。身念为胜也。死念者。念人福尽命终时见地狱瑞惊恐失粪。若见饿鬼。若见畜生。随行所堕见。皆恐怖。意欲舍去。反为对所牵。若当生人。缘父母会。若受男胎爱彼女人。若受女胎爱彼男子。除其疾难三事不差。便得入胎。既受又认以为己有。七日一变巧风刻割。至三十八七乃成其形。若生天上天乐来迎。不胜喜悦即失小便。此五道瑞各有所见。此之死应行者已为明戒深惟无常。命速若电若云过庭。老病死来无不逝丧。常念此变以自觉悟。故曰死念也。前十念佛自说。未有问者故不解。后十念比丘问佛。更为演说。一一析解。尊弟子者。谓五百罗汉各有所便。或智慧第一。或神足。或辩才。或福德。或守戒。或知足。或说法。各据第一。欲论先兄而后弟者。以阿若拘邻最长。以须跋为最小。此佛法阶次之大要。若以聪哲博达为元首者。此乃是婆罗门法也。云千二百五十者。举其常侍从者。或云。五百人者。佛受阿耨达请时。简五百人可者。寻从至龙王宫。何者。此阿耨达泉。非有漏阂形所可周旋也。阿难出经时集八万四千罗汉。以是言之。数不可计也。此经今正出百人。第一通四部众。二百二十各第一。其余者。岂复可计耶。其人云。此经本有百事。阿难嘱优多罗。增一阿鋡出。经后十二年。阿难便般涅槃时。诸比丘各习坐禅。不复诵习。云佛有三业坐禅第一。遂各废讽诵经十二年。优多罗比丘复般涅槃。由是此经失九十事。外国法师徒相传。以口授相付不听载文。时所传者尽十一事而已。自尔相承正有今现文耳。虽然萨婆多家无序及后十一事。经流浪经久所遗转多。所以偏嘱累此弟子增一者。以其人乃从七佛以来偏综习增一阿鋡。前圣亦皆嘱及此经。是以能仁时转复勤及此比丘。时优多罗弟子名善觉。从师受诵增一。正得十一事。优多罗便般涅槃。外国今现三藏者。尽善觉所传。师徒相授于今不替。所以迦叶每谓阿难为小儿者。故以累世已来父意相加故也。于时阿难妹为比丘尼。闻迦叶语大用嫌恨。阿难者聪明博达。众人所瞻望。而尊谓为小儿耶。迦叶谓比丘尼曰。大妹。阿难有二事可耻。何所为恨也。正坐阿难劝佛度母人。使佛法减千年。是一也。阿难有六十弟子。近日三十比丘还为白衣。佛教度弟子法。若在家有信来求道者。当试之七日。若外学来求道者。当试之四月。何以不等也。以外道家或以恶心欲求长短。是以先试知为至诚。不然阿难来便度之。是可耻二。此三十比丘所以还者。闻阿难于九十六种道中等智第一。从阿难求度者。欲请等智。然阿难不与说等智。是以不合本心。于是而还。还必诽谤阿难。谓无等智。度弟子喻若鱼生子千亿万。若心念者便生。不念者即烂坏。弟子亦如是。若留心教诏者便成就。不留心者即退还。此岂非可耻耶。此比丘尼以恚心向迦叶故。即现身入地狱。以阿难有此阙故。迦叶谓为小儿耳。阿难白引往昔为转轮圣王。名曰长寿。受父大王之遗教。登位治化。将欲出家。复嘱太子善观。委以国政。展转相授未曾暂替。昔以父子相承。今以师徒相绍。昔尚不失有漏之教。况今当失至真妙法耶。故引自证明其必堪受遗典也。于法当念敬者。上偈中已判三藏四阿鋡。长行中复云。一偈中乃可具三藏诸法。况复增一而不具诸法乎。所以复有此一段偈说者。以诸天子心中生念。阿难不能作偈说法乎。何以复作此谩说耶。阿难知诸天子心中所念。语诸天子。正使八万四千象所载经。皆作偈颂者。我尽能作偈颂。况复阿难此少法而不能作耶。欲适诸天意故。复以偈颂诸法。劝喻诸天及利根众生。应闻偈得解者。法即上章。诸恶莫作诸善奉行自净其意是诸佛教法也。言此法能成三乘。断三恶趣。具诸果实。二世受报。以才有优劣故。设诱进之。颂云。上者持三藏。其次四阿含。或能受律藏。即是如来宝。所以云宝者。喻若王有宝藏不使外人知。唯有内臣与王同心者。乃使典掌耳。戒律亦如是。若能持二百五十及与五百事者。乃授其人。不可使外部清信士女所可瞻玩。故喻王宝也。设力不及二藏。但持阿毗昙者。便可降伏外道。九十六迳靡不归宗。何者。此无比妙慧。能决上微滞。使豁尔齐直。虽复五通住劫。未免四驶之所制。是故外学莫敢窥[門@俞]。阿难唱此十偈之妙劝者。正为此三万天人也。昔佛始成道在波罗奈鹿野苑中。为阿若拘邻等五人。转四谛法轮者。佛言。拘邻当知。苦谛苦习谛苦尽谛苦出要谛。直说此四谛。拘邻滞有来久。闻说智慧意犹不悟。便为说空。拘邻当知。四慧所滞。一切皆空。亦复无常。喻若幻化非真非有。拘邻即解得见道迹。四人未解。如来复观心本。二人病在想着更乐。思忆在家。五欲自恣。恋着不舍。应病投药。便说无想三昧。卿所想者。皆归灭尽。故为驰心放在所乐也。所想即解二复得道迹。余二人心常愿生梵天于梵作王。所滞不释复以为累。如来见心所在。复为说无愿。汝所愿求梵天王者。不能出要。皆归磨灭。无常存者可舍所求。出要为先。即复得解成于道迹。五人所滞。各异所解不同。所谓三转四谛者。空无相愿中皆有四谛。谛即观也。定则止也。止观双行共治阴持入中痴爱病也。十二者破十二因缘也。昔佛在世时。为四部说法。或说四谛。或说六度。随前众生所应闻者。各为敷演无有常量。或有国王长者梵志居士。或请供养。或来请问。诸可所说者。阿难问曰。云何名之。当言闻耶。当言见耶。佛告阿难。后在将来。四部说法时。当言闻不得言见。若言见者则为虚妄。何以故。闻已过去见者现在。如过去七佛正可言闻。不得言见也。汝于将来亦复如是。故曰闻如是也。我所以殷勤嘱累阿难者。过去诸佛虽有侍者。无如阿难知佛意趣。曩昔已曾供养。二十亿佛常为侍者不求尽漏。常愿得等智知佛意趣。以是故今获其报。睹目达意不失宜则。诸佛之中勇猛精进。无过释迦文者。兄弟之中弥勒应在前。今反在后何者。昔三十劫前时有三菩萨。共在山上游行。时见有饿虎欲食其子。一人念曰。此虎既为畜生。复食其子死有痛苦。母复不慈。我今身者。四大合成会当归死。便当以身救彼子命。二人不肯。方欲诣市买肉用代子命。一人思惟曰。若此往返子命不全。且当投身于山下济其子命耳。即从山上投身来下。趣彼虎口。身则安隐虎不敢食。所以尔者。夫入慈三昧者。物莫能害也。故以竹自刺使虎得食。曰是勇猛即超九劫。今在弥勒前。以是言之。道无前后意决为先。是故我今成佛。故以遗典委付阿难。汝于当来称闻如是。何以复言一时也。为是日月数。为是人名耶。答亦是时节数。亦是在人名。或曰。复有二名。或刹帝利。或婆罗门。复有二名。或长者种。或居士种。或在天上。或在人间。如是诸或非是一处。故曰一时也。婆伽婆者世尊之称也。结使都尽无能过者。故称为尊。三界诸天皆来师仰。八部鬼神亦所宗敬。故称世尊。能降伏魔即复是尊。如是所称不可计量。故号世尊也。祇树给孤独园。只陀太子者。波斯匿王之嫡子也。有园田八十顷。地平木茂多诸禽兽。日来相集。只心存佛。常欲上佛作精舍。未周之顷。须达长者复来请买。只少与长者亲善。每喜调戏。戏言许可。须达得决意甚欣悦。顾谓侍者。速严驾象载金布地。即负金出随集布地。须臾满四十顷。只曰。止止。我戏言相可。不须复布。须达即与太子共至王所。启白此意。王曰。法无二言。许决已定理无容悔。只曰。吾取树分。卿便取地。二人会可共立精舍。有七十二讲堂。千二百五十房舍。其中平正果木丰茂。流泉浴池寒温调适。四望清显冬夏不改。严治都讫共请世尊。世尊即与千二百五十比丘。游止其中。檀越供养四事无乏。阿难邠坻以是国臣故。高让在先。是故诸经每称只为首。以功德相连故名。亦不得相离故。常合以为称耳

佛告诸比丘者。何以不告清信士女。但告比丘者。于四部众比丘为元首。又复是破恶之主。以无漏法断诸有漏。以是故先告比丘。亦名沙门。沙门者。心得休息。息移有欲寂然无著。亦名除馑。世人饥馑于色欲。比丘者除此爱馑之饥想。世尊说法比丘能受。断除生死至涅槃门。是故告比丘耳。当修行一法者。谓念佛也。念佛何等事。佛身金刚无有诸漏。若行时足离地四寸。千辐相文迹现于地。足下诸虫蚁七日安隐。若其命终者。皆得生天上。昔有一恶比丘。本是外道。欲假服诽谤。逐如来行多杀飞虫着佛迹处。言蹈虫杀也。然虫虽死遇佛迹处寻还得活。若入城邑足蹈门阈。天地大动。百种音乐不鼓自鸣。诸聋盲喑哑癃残百疾自然除愈。三十二相八十种好。其有睹者随行得度。功德所济不可称计。慧明所照岂可訾哉。佛者诸法之主。总会万行。以载运为先。所谓念佛。其义如此。念法云何。法者谓无漏法无欲法道法无为法也。从欲至无欲也。佛者诸法之主。法者结使之主。或问曰。法为在先佛为在先。答法在先。何以知之。经曰。法出诸佛。法生佛道。以是言之。法为在先。又曰。若然者。何以不先念法。而先念佛耶。答曰。法虽微妙无能知者。犹若地中伏藏珍宝无处不有。而人贫困乏于资用。有神通人指示处所。得以自供济于穷乏。或问曰。宝为胜耶。人为胜耶。曰人胜也。何以言胜。伏藏虽多非神通不睹由人得资生。岂宝藏自贵于地中耶。法亦如是。理虽玄妙。非如来不辩。非世尊不畅。是以念佛在先。以法为次。云何念僧。僧者谓四双八辈。十二贤士。舍世贪诤开福导首。天人路通莫不由之则是众生良祐福田也。何以明众僧为良福田也。昔有薄福比丘。名梵摩达。在千二百五十众中。令众僧不得食。莫知谁咎。佛便分为二部。在一部中。复令一部不得食。复分此一部为半令从其半。复令此半不得食。如是展转分半。乃至二人。亦不得食。遂至独身乃知无福。所在行食。次至在钵。自然消化。佛愍其厄。自手授食在于钵中。神力所制不复化去。佛欲令现身得福故。令二灭尽比丘在左右。以食施此二灭尽比丘。凡灭尽三昧。皆即时得福。次复令入慈三昧比丘在左右。次以二悲。次以二喜。次以二护。各各遍代令终四等。时波斯匿王。闻此比丘薄福佛愍与食。我今亦当为其设福。即遣使人[米*乍]米。时有一乌飞来衔一粒米去。使人呵曰。王为梵摩达设福。汝何以持去耶。乌即持还本处。所以尔者。此比丘以蒙众僧福力。是以鸟兽所不能侵害也。用是证故。知众僧为良福田也。已既自度复能度人至三乘道。念众之法其义如此

次念戒者。其义云何。从五戒十戒二百五十。至五百戒。皆以禁制身口捡诸邪非。敛御六情断诸欲念。中表清净乃应戒性。昔有二比丘。共至佛所。路经广泽顿乏浆水。时有小池汪水众虫满中。一比丘深思禁律。以无犯为首。若饮此水杀生甚多。我宁全戒殒命没无以恨。于是命终即生天上。一比丘自念。宜当饮水全命可至佛所。焉知死后当生何趣。即饮虫水害虫大多。虽得见佛去教甚远。啼泣向佛自云。同伴命终。佛指上天曰。汝识此天不。此是汝伴。以全戒功即生天上。今来在此。卿虽见我去我大远。彼虽丧命常在我所。卿今来见我者。正可睹我肉形耳。岂识至真妙戒乎。以是言之。持戒不犯所愿者得。十念中戒在前。六度言之施在前。所以前却不等者。十念戒者声闻家戒也。弟子法以捡身为先。是以在前。大士法以惠施为重。何者。夫大士者。生天人中心存济益。济益之要非施不救。夫众生存命者。以衣食为先。故以财施先救其形。然后以法摄御其神。故大士以施为先。夫戒有二。有俗戒有道戒。五戒十善为俗戒。三三昧为道戒。二百五十戒至五百戒。亦是俗戒。四谛妙慧为道戒也。但行安戒不出三界。以慧御戒。使成无漏乃合道戒。声闻家戒。喻若膝上花动则解散。大士戒者。喻若头插花行止不动。何者。小乘捡形动则越仪。大士领心不拘外轨也。大小范异故。以形心为殊。内外虽殊俱至涅槃。故曰念戒也。念施所以得至涅槃者。以施有财施法施也。因财施得达法施。成檀度无极故。得至涅槃也。念天者。欲界色界至无色界天也。天有二种。有受福天。有道德天。欲界诸须陀洹天。永离三恶趣。进升道堂。色界空界八净居天。增修止观。进成无漏。即彼涅槃不还世间。凡夫天者。十善四禅四空。于彼受福。福尽还堕。流转不已。所谓念天者。念彼诸得道者。专心效彼慕其所行。意不驰散亦至涅槃。故曰念天也

念休息者。谓心意想息五欲不起。寂然永定故云息也。凡息亦有二种。外道梵志敛形求福。亦云息也。沙门四果众结永消。乃是真息。何以知其然。昔有比丘。名曰须罗陀。至舍卫城周行教化。时舍卫城西鸯掘魔可杀人处。其地平博多诸树木。时有一梵志。在树下坐禅。不食五谷但食果蓏。若无果便啖草菜以续精气。身着树叶衣。形体羸瘦。裁自支拄。时须罗陀行过逢见。谓是道士。坐禅试观其心知为定不。见其心本乃求作此国王。念曰。此乃是大贼耶。正欲舍去。恐后堕罪。正欲教化必不随我语。当设方便度此人耳。即便就一树下坐禅。相去不远。乃经七日不动不摇。过七日后起至梵志前。弹指觉曰。同伴体中何如也。梵志良久。徐乃举头答曰。贫俭无以相遗如何。比丘又曰。我今当遗君一物。即化作一鸡。君可杀此鸡啖。梵志惊曰。我尚不杀虮虱。况当杀鸡耶。比丘曰。汝本心乃欲杀无数人。可杀此鸡何足言。梵志复曰。我云何杀无数人耶。比丘曰。汝本在此坐禅时。乃欲求作此国王。王者治化日可杀几人。而言不杀也。此鸡即是汝心中识。鸡乃可得无为大道。何用国王为。即便思惟。此比丘乃知我心中所念。必是圣人耶。当从其教。重为说法即得道迹。此梵志身形虽静。心不休息也。自得杀识鸡已。乃可名为休息耳。故后解曰。心意想息也。念身者。观身三十六物恶露不净。谛念不乱。亦得涅槃。何以知之。昔有比丘作阿练若。常行乞食。于江水边食。食讫澡钵。时上流岸边冢间有新死女人风吹头发忽然堕钵中。比丘手执此发。谛视之甚妙好。心口独语。若是马尾此复太细。若是男子发。复太软细。若系不解者。必是女人发。即便系之不解。便生想念。此发如是人必妙好。面如桃花色。眼如明珠。鼻如截筒。口如含丹。眉如蚰蜓。作是分别已。便起欲心。顺水寻求。想见颜色追求不已。见一女人狐狼已啖其半。身形臭烂其发犹存。执发比之长短相似。向者欲想释然自解。复重观之分别惟察。此人生时形容严好。今者坏败令人得见。我向所起想者。但欲贪身爱欲。故而生斯念耳。彼身如是。我复何异。谛计我身四大合成。福尽缘离自然解散。睹变心悟即达道迹。以是言之。念身者获沙门果也。念死者。行人念。命逝不停诸根散坏。如腐败木。命根断绝。当念非常以自觉悟。昔有比丘名婆吉梨。坐禅行道经历年岁。而有漏不除。自患己身以为大累。每思自害。人所以不得至道者。正坐此身缠绵流转何时可息。即以手执刀将欲自刎。复重思惟。世尊有教诫。诸弟子不得自残。虽尔我今欲求涅槃。涅槃中无身。是故先除身取无为正尔。便举刀自刎。头亦堕心亦彻。即得阿罗汉。佛知已得道。敕诸比丘阇维其尸。是故念死亦得涅槃也。前十念佛总说。为利根众生。后更说者。为钝根众生。析解其义也。名誉者。后得转轮圣王。得大果报者。后得天帝释。诸善普至者。后获梵天报。得甘露味者。后得辟支佛。至无为处者。后获阿罗汉果。上说十念无此五句。今所以益诸报者。欲明念佛之义其理深妙。佛说。诸弟子般涅槃。皆以宿缘偿对因取涅槃。目连被打。身子下肠。如是五百弟子。各以宿缘取灭度。唯有阿难最善取涅槃。阿难将欲涅槃时。先现光瑞。有梵志从阿难学算术。见阿难颜色发明。告阿阇世王曰。阿难颜色异常。将欲取涅槃耶。王即遣人追寻阿难。阿难已将五百弟子。至中路恒水岸上。上船欲度。适至水半。王以至岸。毗舍离承阿难来。亦遣五百童子迎。欲适二国意故。以神力制船令住中流。时度弟子。一名摩禅提。二名摩呻提。告摩禅提。汝至羯宾兴显佛法。彼土未有佛法。好令流布。告摩呻提曰。汝至师子渚国兴隆佛法。嘱累讫作十八变。出火烧身。中分舍利。令二家各得供养。此由念佛之力。故得自在也

分别功德论卷第二分别功德论卷第三

        失译人名附后汉录

佛告诸比丘者。佛大慈欲令弟子具知念佛之义。犹父约诫语子孙欲令成就。无复已已专精念佛。观如来形目未曾离。犹如阿难观佛无厌。心念无已。时阿难背上生痈。佛命耆婆治阿难所患。耆婆白佛。不敢以手近阿难背。佛告耆婆。但治勿疑。我自当与阿难说法令其不觉痛。如来令阿难熟视佛相好。佛为说。如来身者金刚之数。不可败坏。三千二百福功德所成。阿难目视不惓。耳听不厌。心念不散。时耆婆于阿难背上。溃痈傅膏。佛问阿难。汝觉背上痛不。答曰。不觉。不觉痛者。由念佛故也。十力所成。四无所畏。昔有长者将奴礼偷婆云。南无十力世尊。奴在后礼云。南无十一力如来。长者曰。如来正有十力。云何有十一力耶。奴曰。十一力复何苦。但莫言九力。言十一力更益一力。有何过失。大家默然而归。问诸法师曰。如来为有几力耶。答曰。或有三力。或有十力。或云无数。以是言之。不限于十耶。长者即出家学道。免奴为家主。言四非为不足。言无数非为有余。适时应物无有常量也

念法者。从欲至无欲。从欲至道。从漏至无漏。从有为至无为也。何以知其然。昔者世尊。于忧填王国说法教化。时三十三天上。为母摩耶说法。九十日而还。于迦尸城北下。时优钵莲华比丘尼。心念欲独前见佛。时诸国王不见佛已九十日。皆有渴仰之情。并来云集。我为比丘尼。不宜在此众闹之中。当作方仪令得在先。即化作转轮圣王。将从如圣王法。诸小国王见圣王。各自驰散。比丘尼即还服本形。见佛礼拜问讯。诸王各来见佛。不复见圣王。乃知比丘尼所化。谓比丘尼曰。向者所见诳如此耶。时优钵莲华心念自谓。最先见佛。佛告优钵莲华曰。汝自呼最先见佛。复有先汝者。不审是谁。佛言。乃罗阅城东山中须菩提。在彼补衣。天语曰。佛来下已。须菩提曰。我为弟子。法当往礼问。覆自思惟。佛为所在。若金色是佛耶。金复何限。佛言。一切诸法空。无所有。若解十二因空。非造非作非人非士无命。非命者则为见法。见法无命。非命为见。我即叉手起唤曰。婆南正尔。还坐补衣。以是言之。须菩提为先汝见佛也。佛者诸法之主。解了法空即是念法。念众者。谓贤圣众也。凡众有若干种。外道九十五种。亦各各有众。或有和合者。或有不同者。亦以戒律自防。或行禅定。或以无想为尽妙。各信所事自以为真。但不得实圣八品道。是以不能至涅槃耳。虽复有五通住寿及无想延劫。皆不免于生死。唯有如来圣众四双八辈之士。不复为四驶所漂九止所索耳。故经云。九十六种僧。佛僧最为真。如来四部众皆同为释种。喻若四恒水各别有五百支。皆合入大海以等一味。众亦如是。或有刹帝利种。或婆罗门种。或长者种。或居士种。四姓中有出家学者。皆同释种为一姓。无有若干别名。以是所包弥远。其义弥深。众僧者。乃含受于三乘。罗汉僧亦出于中。缘一觉亦在其中。大乘僧亦在其中。是故名为良祐福田。三界之中济益众生。无过此良美之地。如来虽复成正觉常还向众僧。忏悔者。以僧地厚重。三世诸佛缘觉弟子。无不由僧而得灭度。犹梵摩达比丘。赖圣众以全济。念戒者。谓行净戒具诸律仪。犹若陶家调缮埴泥。俟诸求器大小方圆。各适所欲。戒亦如是。若愿生天。三界受福。若欲断结求道。所愿应意。犹吉祥瓶。随人所欲取即得之。以戒为本。兼行三十七品及诸三昧定。断七使九结。进成涅槃。喻埴成器。不可复坏也。

念施者。谓施有二事。或有主施。或无主施。复有二施。一名与。二名舍。复有二施。一财。二法。与者即有主施也。舍即无主施也。舍则舍结也。与则前人受财法。所以施至涅槃者。若与人财法时。心不望报不计彼已。以三事无碍。即同无为也。若能舍结亦是涅槃。舍与俱至涅槃者。犹象逐健儿进之与退。其于得肉进则破军。退则自丧食肉必矣。念天者。有三种天也。有举天。有生天。有清净天。云何举天。谓转轮圣王。为众人所举。所以名为天者。以圣王有十善教世。使人皆生天。在人之上故称为天。或有说曰。圣王胜佛。何以言之。圣王治世人。无堕三恶道者。佛出世时三恶不断。以是为胜也。或复说曰。佛胜圣王。所以言胜。圣王以十善教世。不过人天。佛出教世得至涅槃。以是为胜也。云何生天。从四天王至二十八天。诸受福者尽是生天。所以言生天。流转不息不离生死。故曰生天也。云何清净天。谓佛缘觉声闻三人。皆尽结使出于三界。清净无欲。故曰清净天也。八净居天者。过于生举。不及清净处。其中间。念天者之所慕也。因念生举。亦有至涅槃理。何者。舍卫城中。有清信士夫妇二人。无有子侄。二人精进心存三宝。时妇早亡。即生三十三天为天女。端政无双天中少比。女自念言。谁任我夫。以天眼观世间。见本夫以出家学道。年高闇短专信而已。常以扫除塔庙为行。见其精勤理应生天。必还为我夫。时处静室。夜坐思惟霍然见明。怪其有异举头仰视。见有天女问其所由。从何而来。天女答曰。我从三十三天上来。本是君妇。今为天女。天上无任我夫者。观君精进应还为我夫。是以故来白意。语讫忽然不见。还归天上。时老比丘自是以后倍加精进。兼更补缮故庙。晨夕不懈。积功遂多福德转胜。乃应生第四兜率天。天女复以天眼观之。见其乃应生第四天。复来语言。积精进已过我界。我不复得君为夫。语讫还去。比丘倍更精进胜于前时。昼则经行。夜则禅思。心意转明思惟四谛。如是不久遂得罗汉。所谓因念天得至涅槃者。念休息者谓得定也。休息有二。有俗休息。有道休息。俗休息者。犹行作疲极小住懈息。故名为俗休息。道休息者。谓定之人。何以知其然。昔有比丘。名曰等会。时近大道边坐禅定意。时有五百乘车过。声甚凶凶。寂然不闻。时复天雷霹雳。又顷复地大动。都无所闻。行过者众尘土坌衣。积有时节。有一人来。见此比丘端坐不动。尘土坌衣都无所觉耶。比丘定觉抖擞尘土。又问曰。向者眠耶。曰不也。又问。若不眠者。向有车过。及天雷地动。寂然不惊。何由如此。答曰。我时入休息三昧。是以都无所闻耳。以是言之。得休息定者。虽复天地覆坠不革其志。故名休息定也。念安般者。谓息诸坐驰也。趣道之径非唯一涂所悟之方。各有所在。何以知其然耶。身子昔曾供养十四亿佛。从佛闻法。未曾综习安般。至释迦文世。从马师比丘。始达空法。即见道迹。佛具演慧漏尽结解。今为智慧第一。不由安般得至涅槃也。目揵连昔三十劫中供养诸佛。修大乘行不能终讫。遭遇世尊退取尽漏。自昔暨今未曾习安般。迦叶比丘。昔亦曾供养三万如来。亦未曾习安般。应得辟支佛。今退为罗汉。马师比丘。昔日亦供养七佛。亦不习安般。今亦尽漏。阿难昔曾供养二万如来。所从诸佛咨受法教。亦不习安般。唯有罗云摩呵劫匹罗。曩昔以来常习安般。今亦至道。以是言之。趣道之径非唯一涂。安般者。知息长短。冷热迟疾。从粗至细。渐御乱想遂至微妙。或因息以悟。或分别解了。或头陀守节。或多闻强记。或神足识微。或揩或训悟。所谓殊途而同归也。念身者。谓分别四大也。解了五阴一同之幻梦。何以知之。念身得至涅槃耶。昔佛去世后。百岁时有阿育王。典主阎浮提。群臣夫人象马各有八万四千。时王巡行国界见阎罗王。有十八地狱。亦有臣吏。僻问罪囚。王问左右曰。此何等人。答曰。此死人王也。主分别善恶。王曰。死人王尚能作地狱治罪人。我是生人王。不能作地狱耶。问诸群臣。谁能造地狱。诸臣对曰。唯有极恶人能造地狱耳。王敕诸臣访觅恶人。臣即行觅。见有一人坐地织罽。旁有弓箭。兼有钓鱼钩。复以毒饭食雀。并织罽并钓鱼射鸟捕雀。臣还以状白王。恶人如是。王曰。此人极恶。必能办地狱事。王遣人唤曰。王欲见汝。恶人曰。我是小人无有识知。王用我为。曰王正欲得汝治地狱事。其人即归。家有老母。语母曰。王唤我。母语儿曰。王唤汝为。儿曰。王欲使我治地狱事。母曰。汝去我云何活。母即抱儿脚不放。儿意欲去。即拔刀斫母。杀而去至王所。王问曰。母不放汝。何由得来。曰杀母而来。王曰。真恶人也。必能办地狱事。即委此人作地狱城。设镬汤剑树。即拜此人为地狱王。与立臣佐。各有所典。如阎罗王。王约敕曰。若有人入此城者。不问贵贱得便治罪。王曰。正使我入中者亦莫听出。时有老比丘。名曰善觉。常行乞食。至此城门。外见好华香。谓内有人。即便入城。但见治罪人。惊怖欲还出。时狱卒不听出。欲将至镬汤。道人求曰。小宽我。至日中。又语顷。有男女二人坐犯淫。将来欲治罪。置碓臼中捣之。斯须变成为沫。道人见之。始念佛语。人身如聚沫。诚哉斯言。又顷复变为白色。复念人身如白灰聚。变易不一。如幻如化。谛计非真。即时意悟漏尽结解。狱卒复催入镬汤。时比丘笑。狱卒嗔恚。使四人侠两腋倒着镬中。即时汤冷。比丘即化作千叶莲华。于莲华中结加趺坐。狱卒惊怪。白阿育王曰。今狱中有奇怪事。愿王暂屈临视。王曰。我先有要。正使我入中。亦不听出。我今那得入耶。吏白王曰。但入无苦。王即随入。见道人在莲华上坐。问曰。汝是何人也。曰我是道人。道人语王。汝是痴人。王曰。何以名我为痴人也。道人曰。汝本作童子时。以一把土上佛。佛受咒愿言。汝后当王阎浮提作铁轮王名阿育。一日之中当起八万四千佛图。此狱是佛图耶。王意即悟。便前悔过。以善觉为师。于是罢狱兴福。起八万四千图庙。以是言之。念身得涅槃。此其义也

云何念死得至涅槃。昔阿育王奉法精进。常供养五百众僧。于宫内四事无乏。兼外给五百乞食。阿练若复送五百人饷。就供养之。复于四城门中给诸穷乏。供养遂久财宝转减。时弟名修伽妒路。不信三尊。大臣耶舍。夫人善容。亦同不信。三人同心患王。数数谏曰。供养道士空竭国财。何用是为。王曰。汝好护口。夫士处世。所以斩身。由其恶言也。修伽妒路白王曰。此诸道士并是年少。肴膳恣口情欲炽盛。而处深宫妇女之间。岂可信乎。王答曰。道士制刑以法自防。节身守禁。不为色欲所屈也。修伽妒路。后出行猎。见有鹿群。中有一人张围捕之得人。问曰。汝是何人。曰我年八岁时失父母。迸在山中为鹿所乳。遂至于今。复问曰。鹿无乳时何所啖食。曰我随鹿啖草叶以自济命。又问曰。颇有欲意不。曰有。遂便将归。以状白王曰。此敢草人身形羸瘦。尚有欲情。况诸道士饮食恣口身体肥盛。岂无欲情乎。王心念曰。当何方便化此弟乎。即设权谋诈欲出游。大集人兵。严政出外。王盗还入隐而不现。王先与诸臣议。若我出后便举为王。诸臣即劝试着王服。诈佯不肯。诸臣曰。但作我等当着。即着天冠王服。咸称万岁。左右侍立。如圣王法。阿育王见其已定。便从外来。曰何如大王。弟见王惭赧莫知所如。阿育王曰。我暂出游。卿等云何便作此事。我铁轮不在那。何乃如此纵横耶。我杀汝斯须间耳。即命诸臣。收捡桎梏。蜜遣信白道人。善念此意。当来救请。正欲杀汝。念汝作王日浅未得恣意。今且假汝七日作王。如我王法群臣侍从。宫人妓女。饮食进御。恣意七日当就极法。即如教施行。虽满七日无心自欢。道人来请。持钵执锡诣王宫门。王问曰。道人何所欲也。曰欲乞死人。王曰。此罪人应死。不得乞道人。道人重曰。但乞道人。当使学道。王曰。问此人能学道不。道人即问。今乞汝作沙弥。能不。答曰。正使作奴犹当不却。况复沙弥。王曰。作道人难为审能不。道人法当粗衣恶食趣支形命行道而已。汝串优乐。何能堪此苦行耶。答曰。尚当死岂不堪苦行耶。王曰。若堪者听。使七日乞食。王令宫内。修伽妒路来乞时。与极恶食余残秽臭者。即使着弊衣造诸房乞食。处处皆得恶食。以免死之情重。甘心食恶食。满七日已。王见其无悔恨。即听为道。汝常言。道人闲乐多情难信。汝所乞食故在我宫内。犹尚精细。道人乞食又甚于此。所食如是。岂可有情欲乎。即付善念为沙门。王遣使至石室城。于彼城中行诸禅观。或在冢间。或在树下。时在冢间观死尸。夜见有饿鬼打一死尸。问曰。何以打此死尸耶。曰坐此尸困我如是。是以打之耳。道人曰。何以不打汝心。打此死尸。当复何益也。须臾顷复有一天。以天文陀罗花散于死尸。道人复问曰。何以散此臭尸为。答曰。我由此尸得生天上。此尸即是我之善友。故来散华报往昔恩耳。道人曰。何以不散华于汝心中。乃散此臭尸花为。夫善恶之本。皆心所为。汝等乃复舍本取其末耶。时修伽妒路自念。我从死得活。由是因缘当得解脱。于是观身念死。思惟分别解了无常苦空非身。即得罗汉。以是言之。念死者亦至涅槃

分别功德论卷第三分别功德论卷第四

        失译人名附后汉录

如来所以广为四部各各说第一者。乃为将来末世遗法之中。或有四姓外学梵志。及四部弟子。共相是非。自称为尊。余人为卑。如是之辈不可称计。故豫防于未然。故开自足之路耳。今称拘邻为第一者。以其释种豪族。王简遣侍从劳苦功报。应叙是第一。又复初化受法。无能先者。亦是第一。善能劝导将养圣众。先受善来之称。复是第一。人中所归仰。遮加越为最。光明之中日为最。星宿中月为最。万川中海为最。四天王中提头赖为最。三十三天中释提桓为最。欲界六天中波旬以为最。色界十八天净居以为最。九十六部僧释僧以为最。九十六种道佛道为上最。拘邻比丘等五人中为最。以是言之。拘邻为第一

优陀夷比丘劝导以为最。比丘皆劝导所以称最者。佛将还度本国。先遣现神变。与王相酬酢。一一解释。人所度不可计。故称劝导最也。摩诃昙比丘。利根捷疾。余比丘皆漏尽成神通。此比丘漏未尽以成神通。故称第一

凡乘虚者皆以神足。此比丘能行空如履地。是善肘比丘之所能也。故称第一也

目连神足默往异刹。婆破比丘神足陵虚。声振遐迩。能摄伏外道。故称第一

牛脚比丘者。以二事不得居世间。何者。此比丘脚似牛甲。食饱则齝。以是二事不得居世。若外道梵志见其齝者。谓沙门食无时节。生诽谤心。是以佛遣上天。在善法讲堂坐禅定意。善觉比丘常为众僧。使至天上。佛涅槃后。迦叶鸣揵椎。大集众僧。命阿那律。遍观世界谁不来者。阿那律即观世界尽来。唯有桥洹比丘今在天上。即遣善觉命召使来。善觉到三十三天。见在善法讲堂入灭尽定。弹指觉之曰。世尊涅槃已十四日。迦叶集众。遣我相命。可下世间至众集所。桥洹答曰。世间已空。我去何为。不忍还世。欲取涅槃。即以衣钵付于善觉。还归众僧。便取涅槃。以是因缘。善处天上。故称第一

善胜比丘者。本是贵族之子。初生之时。有自然金屣着足而生。父母珍之。为起三时殿。妓女娱乐不去左右。时妇睡眠。睹其白齿。身形虽妙但是骨耳。具观恶露森然毛竖。顾视宫宅犹似冢墓。惊走出户。二神迎接。问二神曰。今者委厄谁能为救。二神答曰。唯有世尊善能救厄。曰今为所在。答曰。近在祇洹。可从启请。寻光至佛头面礼足。佛因本心为演妙法。即时心开漏尽结解。以是因缘。善胜比丘恶露观第一

优留毗迦叶所以称第一者。乃宿世以来弟兄三人。常有千弟子相随。今遇释迦文佛世。佛以十八变度迦叶千人。佛众得成。四事供养犹此而兴。以是言之。优留毗迦叶。能将护圣众供养第一也

江迦叶所以称第一者。佛为说法。一心听受。精谊入神。诸结消尽。德实内充。乃彻骨髓。故脂髓外流。状似汗出。以是言之。心意寂然能降诸结。故称第一

马师比丘者。从佛受学。方经七日。便备威仪。将入毗舍离乞食。于城门外遇优波坻舍。遥见马师威仪庠序法服整齐。中心欣悦。问曰。君是何等人。曰吾是沙门。曰君为自知为有师宗耶。曰有师。师名为谁。云何说法。答曰。吾师名释迦文。天中之天三界极尊。其所教诲以空无为主。息心达本。故号沙门。优波坻舍闻此妙语。即达道迹。坻舍同学本有要誓。先得甘露者。当相告示。即辞马师至拘律陀所。拘律陀见来颜色异常。疑获甘露。寻问得甘露那。曰得也。甘露云何。甘露者达诸法空无也。拘律寻思复得道迹。马师所以威仪第一者。以宿五百世为猕猴。今得为人性犹躁扰。出家七日即改本辙。学虽初浅善宣尊教。使前睹者悦颜达教。以威仪感悟故称第一。身子所以称智慧第一者。世尊又云。欲知身子智慧多少者。以须弥为砚子。四大海水为书水。以四天下竹木为笔。满中人为书师。欲写身子智慧者。犹尚不能尽。况凡夫五通而能测量耶。故称智慧为第一

目连所以称神足第一者。世尊亦说有证。昔日三灾流行。人民大饥。目连心念。此地下故有曩日地肥在中。今人民大饥。意欲反此地取下地肥以供民命。念已白佛。今欲以四神足。反地取下地肥以济民命。不审可尔以不。佛言。止止。目连。汝神足虽能反此无难。那中众生。可以一手执虫一手反地。佛言。不可。所以然者。后世比丘多无神足。设后有饥时。国王臣民命沙门反地。若不能者。谓非沙门。以是神足证故称目连为第一

二十亿耳比丘。所以称苦行第一者。昔占波国有大长者。生一子。端正姝妙。足下生毛长四寸。未曾蹑地。所以足下生毛者。昔迦叶佛时。为大长者。财宝无极。为众僧起精舍讲堂讫。以白[疊*毛]布地。令众僧蹈上。由是因缘故。得足下生毛。所以字二十亿耳者。生时自然耳中生宝珠。价直二十亿。即以为称。时瓶沙王闻其奇异。欲与相见。故命令来。计道里十五日行乘车而来。将欲下车。辄布[疊*毛]在地。然后行上。既到王所。王命令坐。劳问讫。闻能弹琴。即命使弹之。相娱乐讫。共至佛所。时佛与大众广说妙法。见佛欢喜头面礼足。佛命令坐。闻法欣悦即求出家。佛然其出家之志。即为沙门。勇猛精进经行不懈。肌肉细软足下伤破。经行之处血流成泥。积行遂久漏犹未除。疲懈心生欲还白衣。我家钱财自恣。广为福德且免三恶。佛知其念。忽然于前从地踊出。问比丘曰。汝本弹琴时。急缓众弦得成妙曲不。答曰。不成。若众弦尽缓复得成不。答曰。不成。若不缓不急弦柱相应得成妙音不。答曰。得成。佛言。行亦如是。不急不缓处其中适。和调得所。乃可成道耳。思惟佛语。心豁开解。便成罗汉。以是因缘故称苦行第一也

阿那律所以称天眼第一者。时佛为大会说法。阿那律在坐上睡眠。佛见其眠谓曰。今如来说法。汝何以眠耶。夫眠者心意闭塞与死何异。那律惭愧克心自誓。从今以后不敢复眠。不眠遂久眼便失明。所以然者。凡有六食。眼有二食。一视色。二睡眠。五情亦各有二食。得食者六根乃全。以眼失眠食故丧眼根。佛命耆域治之。曰不眠不可治。已失肉眼无所复睹。五百弟子各弃驰散。倩人贯针。扪摸补衣。线尽重贯。无人可倩。左右唱曰。谁欲求福者与我贯针。世尊忽然。到前取来。吾与汝贯。问曰。是谁。曰我是佛也。佛已福足。复欲求福耶。曰福德可厌耶。那律思惟。佛尚求福。况于凡人耶。心中感结。驰向佛视。以至心故忽得天眼。以得天眼。复重思惟便得罗汉。凡罗汉皆有三眼。肉眼天眼慧眼。那律正有二眼。慧眼天眼也。三眼视者乱肉天争功。精粗杂观故曰乱也。那律专用天眼。观大千世界。精粗悉睹。别形质中。有识无识。皆悉别知。天人所见。有净不净。极净观者。见世界中诸有形类。有识无识。见皆动摇。疑谓是虫而非虫也。不净观者。见饭粒动皆谓是虫。优劣之殊有自来矣。以是言之。天眼第一

离越比丘坐禅入定。所以称第一者。昔波斯匿王。请令坐禅在一树下。时王请入宫食。经历六年不他周旋。正欲移在他树。树神不听。以何为验。将欲移时。树神便散华供养。以是为验。知其不听。何以知其意无他念。时拘絺罗来至离越所曰。何不坐好树下。坐此枯树为。答曰。名仁四辩第一。能分别法义及以应辞。不审分别枯树。是何辩中耶。自我坐此已向六年。不别生枯。仁者方至而便分别耶。王请入宫日日供养。使诸夫人各自当直。六年以满布施发遣。当达嚫时不识主人字。王曰。六年受请不识人名。何定乃尔。答曰。我树下坐。尚不知树枯生。况识人字耶。供养禅福其德至淳。随王所愿可至涅槃。福田之良也。故称乐禅第一也

他罗婆摩比丘。劝率施立斋讲者。佛委僧事。分部所宜。契经契经一处。毗尼毗尼一处。大法大法一处。坐禅坐禅一处。高座高座一处。乞食乞食一处。教化教化一处。随事部分各使相从。若有檀越来请者。以次差遣不问高下。若有私请者。不听在此例。时檀越请尽。六群比丘。次值贫家怀恨而还。向佛怨言。摩罗见欺。自受好处。见遣贫家。岂是平等耶。佛命摩罗。卿实尔耶。答曰。不也。于时无食。日欲差中。便和牛屎饮以当斋。闻六群语。无以自明。即于佛前吐此粪浆。六群惭愧。二人感结漏尽。二人还为白衣。二人面孔出沸血。命终堕阿鼻也。斋讲者。斋集部众综习所宜。善能劝成故。称第一也

小陀罗婆者。主立房室。兴招提僧。共成其功。不复别称也

赖吒婆罗比丘。所以称豪贵者。是王者种。为人聪明博达。少好追学。闻佛出世开化愚蒙。即诣祇洹精舍。听采法言。闻教入神。思欲出家。归白父母。父母不听。心自惟曰。一切众生尽是父母。岂独二人是耶。念已便至佛所。求为沙门。佛问。父母听不。曰不听也。兄为国王。复白王求为道。王亦不听。心中思惟。要作方便出家为道。父母正有一子。不欲离目前斯须之间。索一独榻坐父母前。不饮不食经六日。父母惶怖。惧杀其子。若杀此儿者。用此死儿为。听当放之为道。与儿要曰。今放汝为道。当数还归。父母已许。便至佛所。问曰。听汝耶。曰已听。佛便命曰。善来比丘。手摩其头须发自落。如剃须发七日者。袈裟着身便成沙门。为说四谛便成罗汉。以本要故。寻还归家。着衣持钵在门而立。时婢淘米。将欲弃泔。舒钵索饮。婢举头视知是大家。便入白曰郎君在外。父母欣悦。审是儿者。放汝为良人。即出迎入为设肴膳。曰日时已过。法不应食。父母曰。今日已尔。明日早来。即还所止。还去之后父母约敕诸妇。儿明当来。汝等好自庄严。汝容服饰各尽妙技。能使我儿还为白衣者。于汝大佳。复敕藏吏出诸珍宝。金银七宝各各别聚。冀儿意动还染于俗。明日食时执钵而还。就座而坐讫。诸妇婇女各设姿态。或散华香。或拂衣捻草。婆罗曰。诸妹何足烦劳耶。诸妇念曰。持我等作妹者将无还理。语父母曰。用此宝物为。此但误人耳。由是致灾祸。何不弃之于山泽耶。父母谏曰。道德在心何必出家。质多长者。亦在家得道。曰未闻在家得漏尽者。质多所得。由有一生分在。何足为贵耶。虽复豪珍美玉弃之若遣。故称出家第一也

迦旃延所以称善分别义者。将欲撰法。心中惟曰。人间愦闹精思不专。故隐地中七日。撰集大法。已讫呈佛。称曰。善哉。圣所印可。以为一藏。此义微妙。降伏外道故称第一

又复称第一者。世尊至释翅国。坐一树下执一杖。释种咸来观佛。往弃我女相好胜前。今意复云何。答曰。意者不着世间不染于俗。梵志曰。善哉。受解还去。后诸比丘不解此语。问迦旃延。佛称仁者。辩才折理。解义第一。世尊所答。梵志不染不著者。其义云何。时迦旃延即为解说。比丘当知。眼缘色起痛。缘痛起想。缘想来往。生识分别起染着心。于此染着永已舍离。诸比丘闻说此语。意犹快然。迦旃延观诸比丘意不了。即引喻曰。有人于此。欲求牢固之物。反舍根本而取枝叶。为得牢固不。曰不得也君等亦如是。佛近住此。而反见问。岂非舍本取其末耶。诸比丘即往问佛。称迦旃延所解。如是不审理应尔不。佛答曰。如迦旃延所说。等无有异。以是因缘复称第一。君头波叹所以称行筹第一者。凡筹者记录人数知为诚实以不。答诚实。受筹则得其福。虚妄受者罪积弥大。汉言曰筹。天竺为舍罗。舍罗者亦名坏尽。福则罪尽。罪则福尽也。何以知其然耶。昔阿难邠坻女。外适尼揵国。问佛可尔不。佛言。宜知是时。往必有益。女既到遥请世尊。佛知其意即默然受请。敕阿难曰。明当受释摩男请。鸣揵集众行神通。舍罗时上座。君头未得神通。闻行筹请自鄙未得神通。顾惟形影在众座首。由老野狐在紫金山。进退惟虑。正欲受筹不在通例。正欲不受居为上座。八岁沙弥尚得神通。积年之功而无所获。计惟如此。何用存为。感结受筹。还授之间霍然漏尽。若以虚妄受筹者。人身有九十万毛孔。以此为数。不得受如此之数人身也。若以精诚受者。即可得漏尽之证。以此上座可为明证。所以复为上座者。以善能说法适可众人。众所推举故为上座。以是因缘故。称上座受筹第一

所以称宾头卢能降伏外道者。毗舍离城中。有质多长者。每患六师贡高自大言。瞿昙沙门。自称为尊。当与其捔技。若彼现一我当现二。如是转倍至三十二。时长者普请内外僧供养讫。立大幢高四丈九尺。置栴檀钵于上。唱言。其能引手取此钵者。便得第一。时宾头卢心自念曰。今当现神足令六师等默然降伏。又念曰。世尊常诫诸弟子。不得现神足。若今不现者。惧彼永以得罪。若现者惧违尊教。俯仰不已。便现神足。伸手取此旃檀钵。升在虚空。绕城七匝。还在座上。谓诸梵志曰。卿等复现其二也。六师默然。时大鬼将军名曰半师。谓六师曰。促现其二。时六师徒众莫知所凑。以是言之。知宾头卢降伏外道最为第一也。所以称谶比丘瞻病为第一者。时只陀精舍有一比丘。病疾困笃。久寝床褥。脊下虫出。呻号终日。佛与诸比丘按行房舍。见此比丘困笃如是。问曰。有人瞻视汝不。曰无也。又问曰汝先时颇瞻视他病不。答曰。不也。佛言。汝不视他病。云何欲望人看也。于是如来襞僧伽梨。自手摩扪。为其湔浣。时天帝释亦来佐助。世尊瞻视病人。于是病比丘蒙世尊恩。即得除愈。佛告诸比丘。自今已后。若有病者。当相胆视。时世尊顾谓诸比丘。谁能常胆视病者。唯有谶比丘耳。谶比丘常以五事胆视病者。云何为五。分别良药。亦不懈怠先起后。卧。恒喜言谈少于睡眠。以法供养不贪饮食。堪任与病人说法。是谓谶比丘以此五法胆视病人。未曾有不差者。所以者何。此比丘乃前世时。曾五百世为医善解方药。听声察色知病根源。兼以四事胆养病者。以是因缘。称谶比丘胆病第一也。所以称朋耆奢比丘能造偈颂者。此比丘前为长者子时。为人天才聪朗触物赞颂。时出行游。遇一技家女。形容端正世之希有。睹之情欣便欲纳之。归白父母。启以前见。愿父母为我娉索不。父母不悦。卿族姓子。如何改趣毁先人风。其子意猛。复重启曰。若不为我纳者。不能存世。父母见子言。重不忍呵制。便言。随汝非我所知。即自遣人与女家相闻。女家是技种唯技为先。便答来使曰。不贪君财。唯能众技兼备者。便持相与。朋耆闻之。即诣技工学于诸技。不经数旬众技兼备。复重遣信。所学已备便可相惠。主人答曰。若伎备者当诣王试。时在正节。王集众技普试艺术。若最胜者赐金千两。王亦闻此女妙。欲纳之宫里。试之技法缘幢为最。竖幢高四丈九尺。下置刀剑。刃皆上向。间趣容足。时朋耆缘幢于上空旋七匝便下投之空地。王惧失女。诈佯不视。人皆言妙。王言。不见。若审妙者更复为之。朋耆念曰。若不顺王教者。必失此女。规一果情。朋耆冒死复缘既至幢头。顾视女面。心自惟曰。何坐此人乃至斯困。心惧形栗恐不自全。女人虚妄何用此为。佛知此人。必可济度。若不救者当堕三涂。告目连曰。汝以神足救彼危厄。目连奉教即往现变。于虚空中结加趺坐。复于幢下现七宝阶。余人不见朋耆独睹。徐于梯间七匝而下。神力所接内安外危。王与众人甚为奇异。王手自牵女以付朋耆。朋耆曰。不用此虚诈之物。诳惑世人迷误清直。亡国破家莫不由之。即寻目连往诣世尊。世尊告曰。善来比丘。便成沙门。为说四谛。即得应真。喜情发中而形于言。便作颂偈。赞于世尊

  清净十五日　　五百比丘集
  已断诸结使　　仙人不受习
  犹如转轮王　　群臣普围绕
  四海及与地　　所典无有表
  降伏人如是　　导师无有上
  将护诸声闻　　三明坏结性
  一切世尊子　　无有尘垢秽
  已破爱欲网　　今礼星中月

以是因缘。称朋耆奢能造偈颂赞如来德为最第一

所以称拘絺罗为四辩第一者。凡声闻四辩不必具足。或有法辩而无义辩。或有义辩而无法辩。或有应辩而无辞辩。或有辞辩而无应辩。拘絺罗尽具此四辩。舍利弗迦旃延亦有四辩。所以不称为最者。身子自以智慧为主。迦旃延自以撰集为主。故各不称四辩耳。虽复四辩亦不及拘絺罗。拘絺罗但辩一句之义。七日不尽况复四辩。岂可计量乎。以此事故为四辩第一

所以称难提比丘乞食第一者。余比丘虽复乞食。或不具戒。或有贪心。或左右顾视。心不专一。或避寒暑。然此比丘当乞食时。都无此事。乞食既精。施者福多。今故引喻。以况大小。有人问射法。一人射百步玄毛。一人射地尘出。何者为难。答曰。玄毛为难。虽射而不着地。此不足言也。若施乞食。若施众僧。何者为大施真阿练。喻中玄毛施不得真。喻其射空。其事虽难有得有失。箭着地者。喻施众僧。射毛虽精有失者多。射地虽易未曾失地。福田地厚故无增减。阿练精粗故有得失。难提得精故称第一也

所以称施罗一坐一食者。此谓头陀一行也。夫阿练法。或乞食。或坐树下。或闲居独处。今此一坐一食者。从早起至日中。若檀越施食。不问多少。其于一处坐食而已。若食未饱坐未移者。可得更食。若已起者不得复食。常一处食而不舍离。故称施罗为第一。所以言金毗罗比丘者。常行七家乞食。不得过七。所以然者。立誓限七故也。乞食时欲福度众生。专心念道无有贪想。若得好恶不以增减。随次乞食不择贫富。若一家二家得食时。更有布施者。足则止。不足便受。若至七家不得食者。便还所止思惟行道。不念明日当至某家不至某家。都无分别之想。故名七家沙门也。还则静坐敛心在道。故称金毗罗于七家乞食为第一也

坚牢比丘者。以常居山泽闲静之处为行。难提比丘。常以乞食耐辱为行。金毗罗比丘。以七家乞食为行。施罗以一处食为行。十二头陀各居一行。浮弥比丘者。守持三衣不离食息。或曰。造三衣者。以三转法轮故。或云为三世。或云为三时故。故设三衣。冬则着重者。夏则着轻者。春秋着中者。为是三时故。便具三衣。重者五条。中者为七条。薄者十五条。若大寒时。重着三衣可以障之。或曰。亦为蚊虻蟆子故设三衣。以是缘故常持不忘。故云第一。所以称婆差比丘者。本在家时常以家为患。出家求道常在露坐。若入房室常苦气闭。如似掩口。是以常求露坐思惟行道。然后身体调和气息通畅。行道无阂。以是因缘。称婆差露坐第一

所以称狐疑离越常处树下者。在凡夫地。欲求禅定。处在树下。依倚计意。以除缚结。余比丘亦在树下坐禅。所以不称者。以其不能一闻而自专思。此比丘一闻佛教。即能履行专意不舍。六年尽结。前离越者。乐游禅定。行止不异。乐习事殊故各称第一

所以称陀多索比丘乐空者。此比丘入屋解内空。出屋解外空。内空喻识。外空喻身。入屋达识空。出屋解身空。已了内外空。诸法亦如是。此比丘闻说空教戢在心怀。入屋见空即达身识。余比丘者。结尽然后达空。空心难获。贵其先得故称第一

所以称尼婆比丘五纳为上者。此比丘观身秽漏三十六物。无可贪贵。厌贱此身故。以贱物自障。或说曰。夫衣有可亲近者不可亲近者。何者可亲近。着恶衣令人羞惭自愧。是可亲近。着好衣令人自大奇雅。是不可亲近。弊衣助行。是以着五纳。此比丘善能内外相况故称第一

所以称优多罗比丘常乐冢间者。此比丘阿难弟子也。先师得道心自念曰。此身流转无处不更。在天上时服御自然。今以舍弃。若在人中为转轮王。七宝导从。亦复过去。或在畜生恒食草棘。此亦过去若在饿鬼融铜为食。或在地狱。刀剑为对。诸此罪形。皆以过去。今得人身。齐此分毕。古今所贵。皆是弃物幻危之形。无一可贪。俱当弃捐。便止冢间。复念曰。正欲在树下山泽。皆生民所贪。唯有冢间人所不乐。是以居之。冢间所乐唯有鬼耳。兼有狐狼乌鸱之属。今当入慈三昧以济彼类。以是故复居冢间。以是因缘常乐冢间不处人中。故称第一

所以称卢醯宁比丘恒坐草蓐第一者。此比丘常坐草蓐除去爱心云何除爱。虽复金床玉机。都无爱着。或复说曰。若有人施妙座者。亦如施草座无异。爱心既尽诸结亦尽。便手执草向草作礼。有人问曰。何以向草作礼。答曰。我因此草荣饰心尽。得道由之即是我师。故向作礼耳。五百猕猴得生天上。亦以天文陀罗花散于故尸。由尸生天。故来散华。夫贵者必以贱为本。以是因缘称坐草蓐为第一

所以称优钳摩比丘不与人语视地而行第一者。此比丘常患口过。将欲改之。自思惟曰。正坐此口。生天人中三涂。地狱啾吟唤呼。因备五道更苦无量。我今当如慕魄太子结誓不言。四过三殃何由而生。既便不言端视而行。佛奇其能。尔每向诸比丘称美其德。语阿难曰。如此比丘。宜存识录。以率来薄。以是因缘称之第一

所以称一心比丘三昧第一者。此比丘昔曾习定。研粗至。精今定功既立。行若游尘。坐而忘想。忘想理足。其喻如何。犹如有人食百味食。意以饱满更无食想。虽复行步进止盖感。而后应白而后动耳。依定立字。故曰坐起行步入三昧第一也

所以称昙摩留支好远游第一者。其事有由。佛在世时有一长者。字昙摩留支。来至佛所。礼讫问讯佛言。昙摩留支别来大久。乃能相见。有人问佛。不审。何以言别来大久。世尊答曰。汝欲知之耶。答曰。欲知。佛言。我昔阿僧祇劫时。世有一佛。名曰定光。我时为梵志。字曰超述。时定光佛方欲入城。我即中路相逢。见佛光相晖布。即叹曰。世尊光相明踰日月。世尊德者乃隆二仪。世尊心者仁过慈母。顾惟形影无以供之。今正是时。福田良美可以殖根。见地少泥恐污佛足。即解发布泥上。令佛蹈而过。佛即记曰。汝勇猛乃尔。却后阿僧祇劫。汝当作佛字释迦文。时边亦有一梵志。却起恚心曰。此人与畜生无异。乃蹈他头发上过去也。从是以来阿僧祇劫常堕畜生中。复在大海中为魔竭鱼。身长七千由延时有五百贾客。乘船入海采宝。值此大鱼[榻-木+口]船。垂欲入口。五百人惶怖各称所事。时贾客主语众人言。今世有佛名释迦文。济人危厄无复是过。我等称名冀蒙得脱。即便齐声称唤。鱼闻佛名。本识由存。即自惟曰。释迦文佛已出世间。我身云何故在鱼中。即还没水。五百贾客安隐而归。时鱼即半身出沙坛上。不饮不食经二七日。命终生长者家作子。字昙摩留支。今方来得与吾相见。是以称之久远耳。留支闻此。本末。即向海边求故尸。见海边有大鱼骨皮肉已尽。便行胁骨上。思惟言。此是我故尸。即以华散故尸上。寻惟既往忽然道成。以是因缘称远游第一也

所以称迦渠比丘集众说法第一者。此比丘音辞朗达。声震遐迩。其闻音声。集众无数。即为演说法奥美之业。诸人当知。如来出世难可值遇。四谛甘露亦难得闻。诸人曼时。当思惟真谛。除去十二牵连之缚。可得涅槃。此比丘恒助佛扬化。常以此教未坠于地。以是因缘称集众说法音声第一也

所以称婆拘罗寿命极长者。以曩昔曾供养六万佛。于诸佛所常行慈心。蜎飞蠕动有形命类。恒加慈愍。无有毫厘杀害之想。由是慈福今获其报。佛告阿难。如我今日。皮身清净无过于我。犹如莲华不着泥水。正寿八十。不如婆拘罗寿百六十者。如来随世欲适众生。不现其异故寿八十。婆拘罗者受前宿世慈心之福。故得年寿加倍之报。或问。但以慈心便获如此之寿耶。复更有。余乎。曰有。昔毗婆尸如来出世。时有十六万八千比丘。游行教化。时有长者。居明贞修。禀性良谦不好饮酒。时岁节会少相劝勉。薄饮少多。辄以酒势行诣世尊礼拜问讯讫。便请佛及诸弟子。愿受我九十日请。比丘疾病者。皆诣我家而取医药。所须之物皆来取之。语讫还家约敕家内曰。我已请佛及诸弟子。四事供养皆当办具。约敕竟。便睡眠。眠久还觉。其妇白曰。君先约敕严办供具。而今默然所以得尔。长者惊曰。我向何所言说耶。妇曰。君未眠时无所说耶。曰我不省有所说。妇曰。君先言。我已请佛及诸弟子。供九十日所须短乏。不作是语耶。长者思惟曰。酒之误人乃至于斯已尔。惭愧便当即请。明日清旦于舍烧香。遥请世尊。有一比丘来索药。长者问曰。何所患苦。答曰。患头痛。长者曰。此必膈上有水仰攻其头。是以头痛耳。即施一呵梨勒果。但服此药足消此患。比丘服药病即除愈。缘是福报。九十一劫未曾病患。生长者家至年八十。出家学道经八十年。道俗之纪合百六十。在家时曾捔牛。斯须头痛寻即除愈。自尔常无疾患。以是之故。婆拘罗长寿第一。于百年寿中而加六十者。此人五浊寿命。最为奇特。其喻于臭秽之中而生莲花也。阿难问婆拘罗。何以不为人说法耶。为无四辩。为乏智慧。而不说法乎。答曰。我于四辩捷疾之智。非为不足。直自乐静不喜愦闹。故不说法耳。难曰。婆拘罗长寿者。何以不生三方耶。答曰。诸佛所以不生者。以其土人难化故。此土众生利根捷疾。极恶勇猛取道不难。是故往古诸佛皆生此中。婆拘罗应在此成道。故不生三方耳

所以称满愿子说法第一者。有三事得称第一余比丘亦说法。无有三事可记。故不言第一。满愿子说法时。先以辩才唱发妙音。使众座欢喜佥然倾仰。次以苦楚之言责切其心。使令内腐肃悚兴难遭之想。终以明慧空无之教。闻者结解使恬智交养。世尊演法初中竟善。满愿子亦然。三事俱善。自舍如来莫能先者。身子自誓。从旦至中。要度一人令至道迹。目连比丘亦誓度人。于四向之中课进一阶。然后乃食。其余比丘皆亦度人。比满愿子百不当一。满愿子从成道至涅槃。度九万九千人。于声闻之中度人最多。故称说法第一也

所以称优波离持律第一者。昔佛还本国。受父王请。所从比丘虽复心精。无表容貌。时王欲劝释种豪族子弟出家为比丘侍从世尊。即宣令诸释。其有兄弟二人者。皆当一人出家为道。若不从令者当重罚之。时有一释种子。名曰面王。释中最长。次应先下发。时佛命优波离。为其剃头。重告曰。此诸释种憍乐体软。汝好徐徐轻手与剃。优波离即轻手复太轻不着。时优波离复反刀刃。以脊用之。佛言。不可复用刀腹。亦曰。不可即以刀从顶上剃泯然除尽。五百释子皆悉如是。佛命优波离曰。善来比丘。即成沙门。佛即授戒得阿罗汉。次授五百释子戒。优波离为上座。以手摩五百人头为弟子。受戒讫。次当礼优波离。诸释先素憍豪。不能下屈。加复是己之子弟。各言。此是我家仆何缘礼之。佛言。不尔。法无贵贱。先达为兄。后者为弟。俯仰不已。制意为礼。即时天地大动。诸天于上赞曰。善哉善哉。今日诸释降伏贡高。此意难胜故地为动耳。当五百释为道时。亦有九万九千人出家为道。优波离自从佛受戒已来。未曾犯如毫厘。以是因缘故称第一。但以是更有余事耶。祇园精舍北有一比丘。得病经六年不差。时优波离往问比丘。何所患苦。若所须者便道。曰我所须者不可说。又问曰。汝欲须何物。若此无者当从四方求之。若世间无者上天求之。曰我所须者舍卫城中有。以违佛教故不可说耳。曰但说无苦。曰我唯思酒耳。得五升酒者病便愈。优波离曰。且住。我为汝问佛。还即问佛。比丘病须酒为药。不审。可得饮不。世尊曰。我所制法。除病者优波离即还索酒与病即愈。重与说法得罗汉道。佛赞优波离。汝乃问如来此事。使病比丘得蒙除差。又使得道。此比丘若不得度者。后当堕三涂作识无有出期。汝乃为将来比丘说禁法。使知轻重得济危厄。汝真能持律。以律藏付汝。勿令漏失。此藏诸藏之中。最在其内不可示沙弥及以白衣。以是缘故复称为第一也

所以称婆迦利比丘得信解脱者。此比丘久病着床。乃经六年。诸瞻视者皆悉舍去。比丘自念。疾病经久。瞻视疲倦甚可患厌。又复如来不见垂愍。且当自害以除患苦。即便索刀向刀说曰。但当杀我亦当断结耶。说讫以刀自刎。正至咽半已得漏尽。比至头断以取涅槃于时大地震动乃感波旬。波旬念曰。此何瑞应乃尔震动。即以天眼观见比丘自残。其形神为所趣。遍观诸天不见其神。复观人中亦不见之。复观三恶道中。亦复不见。时佛将诸比丘欲耶旬之。见尸火起。此波旬放火觅比丘神。都不知所在。所以觅者。欲知进趣坏令不成。诸比丘便耶旬之。佛叹此比丘得信解脱。或曰。夫至信者委命自然。尚不执杖何以自防况复自害耶。答曰。信所以执刀者。以刀为慧剑。欲拟断诸结。身即结本。根辟则支从。身断则结除。是以执刀者。不为妨阂也。执信刀断疑树故。下句云。意无犹豫。从信解脱至无疑解脱者。即转钝为利也。以是义故。称信解脱为第一也

分别功德论卷第四分别功德论卷第五

        失译人名附后汉录

所以称难陀比丘端政第一者。诸比丘各各有相。身子有七。目连有五。阿难有二十。独难陀有三十相。难陀金色。阿难银色。衣服光曜金镂履屣。执琉璃钵入城乞食。其有见者无不欣悦。自舍如来。余诸弟子无能及者。故称端政第一。亦云诸根寂静者。佛将诸弟子至毗舍离柰女精舍。时难陀在外经行。柰女闻佛来心中欣悦。欲设微供即行请佛。于外见难陀经行。爱乐情深。接足为礼以手摩足。虽睹美姿寂无情想。形形相感便失不净。甘味润体。体满则盈。不净之溢岂由心哉。柰女不达疑有欲想。佛知其意。告柰女曰。勿生疑心。难陀却后七日当得罗汉。以是言之。知心不变易也。所以称婆陀比丘解人疑滞者。三世诸佛。皆共八万四千。以为行法。众生得道不必遍行。众行随其所寤处以为宗。何者众生结使不同。病有多少。垢有厚薄。是故如来设教若干。或有一药治众病。或有众药治一病。犹六度相统。一行为主众行悉从。一行者不专常名随病所起对药应之。若计常起以无常对之。若计有心起以空心对之。当其无常领行。万行皆无常也。犹施造八万。八万皆为施。所谓略说者也。犹如来八音中。一音统八响。一响统百教。一教统百义。一一相领至千万亿。一音报万亿。其变如是。略说统行。其喻亦尔。此比丘专以略说为主。故称第一也。所以称斯尼比丘能广说法者。此比丘三十年。在凡夫地中。广为人说法分别义理。云何广说。或因一行而长众行。支流繁衍乃至无数。犹病有相因而生。是以设药相从而成。此比丘专以剖判为主。不以断漏为先。是以乃经三十年。方取道证。寂默忘言乃遗前踪。录其本绩故。称广说第一也

所以称天须菩提着好衣第一者。五百弟子中。有两须菩提。一王者种。一长者种。天须菩提出王者种。所以言天者。五百世中常上生化应声天。下生王者家。食福自然未曾匮乏。佛还本国时。真净王劝五百释种子。出家学道侍从世尊。此比丘在其例出家。时佛约敕诸比丘。夫为道者皆当约身守节。粗衣恶食草蓐为床。以大小便为药。此比丘闻佛切教。心自思惟。吾生豪贵衣食自然。宫殿屋舍雕文刻镂。金银床榻七宝食器。身着金缕织成服饰。足履金薄妙屣。然则犹不尽吾意。况当着五纳服耶。且当还家适我本意。念已欲还。时佛在舍卫精舍。受波斯匿王请。即往诣佛所辞退而还。时阿难语曰。君且住一宿。须菩提曰。道人屋舍床榻座席如何可止。且至白衣家寄止一宿。明当还归。阿难曰。但住。今当严办供具。即往至王所。种种坐具幡盖华香。及四灯油事事严饰。皆备具足。此比丘便于中止宿。以适本心意便得定。思惟四谛至于后夜即得罗汉。便飞腾虚空。阿难心念。此比丘傥舍屋去。所借王物恐人持去。便往看之屋内不见。仰视空中见飞在上。阿难白佛。天须菩提已得罗汉。今飞在虚空。佛语阿难。夫衣有二种。有可亲近。有不可亲近。何者可亲近。着好衣时益道心。此可亲近。着好衣时损道心者。此不可亲近也。是故阿难。或从好衣得道。或从五纳弊恶而得道者。所寤在心。不拘形服也。以是言之。天须菩提着好衣第一也。所以称难陀迦比丘教授第一者。舍利弗亦教授。普教授四部弟子。从旦至中。要使一人至于道迹。此比丘者专教授比丘。使得罗汉。譬如善射之人。以一发箭射于彼贼。即中要处便使不起。喻此比丘善诲要慧。闻者结除径至无为。不善射者。虽用多箭正可一发。喻于身子虽广演慧终成一阶。优劣之殊格然易见。故言教授后学最为第一也。须摩那比丘所以善诲比丘尼僧者。此比丘常以苦切之言。诫敕诸尼僧。夫女人者多诸情态。姿媚绮饰幻惑世人。身形秽漏九孔不净。三十六物无一可贪也。所以名须摩那者。即华名也。以其生时耳上自然有此华。即以华为称。时频婆娑罗王来至佛所。见此比丘耳上有华。怪而问佛。比丘法得着华耶。佛告王曰。王自[打-丁+勉]却。时王即以手捻去。续生如故。如是不止。遂成华聚。王怪益甚。问其所由。佛告王曰。乃昔毗婆尸如来出世时。此比丘为长者子。时岁节会共弹琴作倡戏讫。便至佛所。此长者见佛喜悦。即以耳上华。举着佛耳上。佛即以神足化此花。于虚空中变为四柱台。耳上如故。长者见变即发誓愿。愿使将来世世值佛。所生端政耳上生花。以昔福愿今获其报。王闻所说心即开解。前礼佛足辞退还宫。所以善诲比丘尼者。比丘尼等本是多情。人见比丘。端政兼耳上有花。心犹爱乐。缘此爱情诲约切教。由是苦言爱着即解。是故言善诲禁诫比丘尼僧最为第一也。所以称尸婆罗比丘福德第一者。尸婆罗初生时。手把无价摩尼珠出。堕地便言。世间颇有金银七宝可持布施不。我今欲大布施。作是言已。父母诸家皆大惊惧弃舍而走。或呼是罗刹鬼。或谓天神。夫小儿生要须日月满足乃当言。今堕地便言。是大可怪。母情不然。复还看之。语母曰。莫惧。我非鬼。我正是母儿耳。其父月光曰。今当抱儿至尼揵子所问其吉凶。即与妇抱儿至尼揵所。以状白师。师曰。此儿无福。后当致祸。长者曰。儿手中有摩尼珠。何以言无福耶。尼揵曰。至年八岁时。汝家财宝尽。当在此儿手中消灭[歹*斯]。由是皆当饿死。长者惧怖深惟疑惑。闻世有大沙门。傥能知吉凶。当往至其所问此可否。即往世尊所。中路复念。大沙门是王者种。生长深宫又不学问。婆罗门等少小博学。尚不能知吉凶。沙门岂得能知耶。即欲还家。天于虚空告长者曰。但当前进。何以复还耶。如来大圣无所不达。往必决疑。是非速往。即前至佛所。礼拜问讯讫。便启白。如向所说不审吉凶。佛告长者。吉无不利。乃生此福德之子。此儿年二十当出为道。常有五百童子共俱。当得罗汉还度父母。长者闻佛所说。欢喜踊跃不能自胜。即还归家。办具肴膳。请佛至舍。愿世尊赐小儿字。佛告长者。正欲为字为天。人所不解。正欲字为贤圣。凡夫所不解。迦叶佛时名鬼为尸婆罗。今正当字为尸婆罗。尸婆罗者。开通鬼神言语音声。是故字尸婆罗。阿难临般涅槃时。度二弟子。一名摩禅提。二名摩呻提利。摩呻提利者地王也。若不作道人者。当王此阎浮提及三天下。故名摩呻提利。阿难教此弟子。汝至师子渚国。兴显佛法。彼国人与罗刹通。要须文字然后交接。市易六十种书。书中有鬼书。名阿浮。人书音名阿罗。摩呻承教至彼显扬佛法。自是教迹今日现存。尸婆罗开通鬼神。其亦如是。故名尸婆罗。所以称尸婆罗福德者。生时两手中自然把摩尼珠出。乃昔毗婆尸如来时。此比丘为贾客。入海采宝。经过五难乃至宝所。得一宝珠还持上佛。愿所生处获报自然。以是因缘生即奇异。价二十亿。初生之时自然宝珠着耳而生。父集贾人访其价直。众贾铨曰。直二十亿。尸婆罗手珠无有限量。故曰无价计。其宝所润乃及七世。七世之中无所渴乏。故称福德第一也。至年二十出家学道。至世尊所。佛命善来。即成沙门。思惟四谛。便得罗汉。时有五百童子。亦出家为道。常侍从尸婆罗。尸婆罗供给此五百人衣食。所在适处供养无乏。所周旋处辄悉供养。至罗悦只。城南有大深山。山中饶诸毒虫虎狼罗刹。即自心念。欲于山中避隐一时。时天帝释以知所念。即于山中作五百房及僧伽蓝。种种供养复经一时。夏坐已讫心念。违远以久当还礼觐。天时大热念欲得凉。天帝知之即降云雨。少思浆饮即降甘露。所欲念者应意即至。故曰福德第一也。尸婆罗有叔父。事外道梵志。为人素悭不好布施。时有亲友。劝令作后世资。即请梵志数千。施百千两金。尸婆罗念。叔悭贪生不造福。设复施慧不值良田。我不度者永为弃捐。便往其家持钵乞食。叔曰。卿来何晚。我昨日大施。昨日来者可得僧竭支。曰我自有竭支。亦不须之。卿来何为。曰我欲乞食。时叔不与。便现身于虚空中。作十八变。身出水火。长者心念。此必嗔恚。傥烧我家。即呼使下来与座。坐曰。我欲得食。即与臭秽恶食。即便受之咒愿而食。食入钵中。福德所感变成甘露。有天于上叹曰。善哉长者。乃作是大施也。福德之施也。无能过者。长者心念。我先施梵志百千两金。而无叹我者。今施此少恶食。乃叹为善。将无妄语耶。天复告曰。所施虽少福田良美。故曰大施也。长者复念。天必真实重来告我。即以百千两金与尸婆罗。尸婆罗曰。我比丘法不应取金。寻往诣佛问其所以。答曰。可取随意转施。即受此金施诸同学。为叔父说法即得道迹。能变臭恶成为甘露。故称福德第一也。从生至涅槃未曾有乏。般涅槃时身上雨种种甘膳饮食。所以得尔己身足。复欲润及众生故也。以是故复称为第一也

所以称优波先比丘具足众行第一者。此比丘德行充足于内。形容端严于外表里相应。所适皆悦。难陀三十相。阿难二十相。表相虽多。于沙门威仪不能悉备。此比丘相虽十一。礼仪备举。以备造适无往不应。长中幼年睹莫不欢。所谓内充者。谓四谛如有八正真妙。充实灵府未曾虚耗。故称具足众行道品之法为最第一也

所以称婆陀先比丘所说和悦不伤人意者。此比丘常慎口。不犯四过。夫士处世斧在口中。所以斩身由其恶言。此比丘于是粗犷之言。永已除尽。常择言徐语思而后露。发言投意必令欢喜。若在长老中年幼稚。随其所好皆能可悦。所以称此比丘能善言者。有比丘已得罗汉。虽复漏尽。由有口过。因行渡江水渐欲深。便发恶言曰。弊婢淫种物。时江神女闻此恶言心念曰。此比丘乃发恶声如是。正欲推着水中。以是比丘故。且当问佛。即行问佛。有比丘渡江水小深。便骂詈言弊婢淫种。比丘法应骂耶。佛即遣一比丘。呼此骂比丘来。比丘即来。佛告比丘。汝为沙门何以骂耶。比丘对曰。弟子不骂。直言婢淫种耳。江神女曰。看此比丘已复骂欤。愿世尊说此本末。罗汉故有嗔恚在耶。何以骂耶。佛言。罗汉无复嗔恚。直以口串故耳。此比丘曾为婆罗门。婆罗门法喜骂詈。曰胎中奴。不必嗔骂。直自口惯习耳。又复前五百世为汝夫时常骂汝为婢。是以宿识不除故复骂耳。江女曰。虽复罗汉故有口过。我不用罗汉。愿我后求无上正真道。度脱一切如佛无异。佛语比丘。汝向此女人忏悔。比丘即悔。女亦向比丘忏悔作礼已各别去。虽复漏尽犹有粗言。况于凡夫而不慎言也。以是因缘知是比丘护口第一也

所以称摩诃迦延那比丘安般第一者。千二百弟子中。唯有此比丘及罗云。能行安般第一。何以知之。昔罗云从佛行。佛以善权故。现脚[跳-兆+專]使罗云见。罗云见已。心念曰。此老公持如此形貌。舍转轮王位。着道行乞耶。何以不羞。我不能复行乞且归去。我祖父真净王故在。何能作是勤苦为。佛即知罗云心中所念。告罗云曰。汝知不。天地尚无常。况汝转轮圣王。岂可得久。当解非常。有形皆苦。身非我有。皆当磨灭不得久停。罗云思四非常。意犹未寤。佛教行安般守意。安般者入出息也。息长亦知。息短亦知。短息者从心还。长息者谓从足跟中来。复知冷暖。入息为冷。出息为暖。所以知长短冷暖者。欲分别五阴所趣深浅。所从出入寻息本末。知病源由。若息入时不知所从来。若息出时不知去至何所。解无来往。病亦复然。如是思惟遂得罗汉。摩诃迦延那行安般者不同罗云也。于息自在。若欲从眼从耳。随意出入。复闭眼耳鼻口。便从九十万毛孔出。何以知其从毛孔出。此比丘本是王种。弟兄二人。其弟端政姝妙。时王崩亡。兄应绍继。弟自以为胜。密望人举。然国俗法不得越次。即举兄为王。弟心不伏。不肯称臣。自求出国。王即听之。求索兵众。王恣与之。即选八万牙象被钾鼻剑。严办已讫。念曰。何国最善。吾欲攻取。毗舍离国诸国最胜。当往攻取。以为己用。即引兵而趣。正至半道时。有五百贾客采宝而还。欲诣摩竭中路相逢。问贾人曰。天下人中形容姿貌颇有胜我者不。贾人便笑。王问。何以笑耶。答曰。我为自笑耳。复重问曰。笑要当有意。何以不说。答曰。王若不嗔者。便当说之。王曰。但说终不嗔汝。贾人曰。我闻有白净王子。名曰悉达。巨身丈六紫磨金色。有三十二相八十种好。时迦延那闻贾人语。心怀恐惧。悉达若知我来者。必当兴军逆来见伐。顿止中路不敢复前。时毗舍离人闻其兴军欲来攻伐。不能自宁。即往问佛。如何禳之。佛言。无苦。吾自化之。其夜世尊即往现变。于虚空中结加趺坐。晃若金山曜于大众。举头视曰。是何等人。答曰。我是贾客所道者。即曰。贾客诳我也。向者不道能飞。而今现飞。心中惶怖惧其为害。叉手问曰。不审至此。何所约敕。世尊答曰。勿怀恐惧。吾不害汝。我名为佛。济渡一切。甘露妙法汝欲闻不。答曰。愿欲闻。佛观其根应从安般而得度。即为说守出入息。知息长短。及知冷暖。闻佛所说。心即开解。得须陀洹道。便舍军众求为道人。佛即受之。善来比丘。便成沙门。重思安般分别四大三十六物恶露不净。寻达至妙逮无漏果。故称诸比丘中安般第一也

所以称优头槃比丘计我无常为第一者。此比丘宿行恭恪。若见长老师父事之。若见中年敬之如兄。于己小者爱之如弟。谦恪之至故受姝大之报。得为比丘侍佛左右。虽有高大之形。常不自恃。恒计非我身无常主。解达明慧。心亡是非。故能遗形。丧憍谦逊为首。何以知形体姝大也。佛始成道。度迦叶兄弟三人。有千比丘。游摩竭国。度洴沙王将还本国。先遣优陀夷告真净王。却后七日当来入化。时王闻之喜踊无量。即敕严驾。平治道路。扫洒烧香。以待如来。如来将千二百五十比丘来过释翅。如来心念。今父王必当来迎。不可使尊重屈体。当现神足。升虚而行与人头齐。欲使王手接如来足而已。所以尔者。佛虽德尊。不欲使父母屈体故也。时优头槃比丘在如来右。密迹力士在如来左。如来身正至此比丘肩。王问曰。佛左右者是何等人。乃尔高大耶。答曰。右者是优头槃比丘。左者是阅叉鬼金刚力士也。又曰。是何等国人。乃尔殊异。答曰。是摩竭国人。又问曰。为是神足身。为是遗体耶。答曰。是父母遗体身。非神足也。诸释念曰。如来神德不可思议。乃令罗刹恶鬼高大之人在其左右也。以是因缘。知是比丘身为延短也。此比丘侍佛左右。恒欲障曀如来。诸天世人以是为患。如来有二种身。一法身。二肉身。此比丘但爱金色肉身。不爱无漏法身。亲近弟子法当嘱累。惧遗法身阙于将来。以是二事故。如来发之以及阿难耳

所以称拘摩罗迦叶能杂种论者。此比丘常为人敷演四谛。时兼有赞颂引譬况。喻一谛一偈赞引一喻。乃至四谛亦皆如是。故称杂论第一也。拘摩罗者童也。迦叶者姓也。拘摩罗迦叶即是童女子。何以知其然。昔有长者。名曰善施。居富无量。家有未出门女。在家向火。暖气入身遂便有躯。父母惊怪诘其由状。其女实对不知所以尔。父母重问。加诸杖楚。其辞不改。遂上闻王。王复诘责。辞亦不异。许之以死。女即称怨曰。天下乃当有无道之王。抂杀无辜。我若不良自可保试。见抂如是。王即捡程如女所言。无他增减。王即语其父母。我欲取之。父母对曰。随意取之。用此死女为。王即内之宫里。随时瞻养。日月遂满产得一男。端正姝妙。年遂长大。出家学道。聪明博达。精进不久。得罗汉道。还度父母。时有国王。名曰波绁。信邪倒见。不知今世后世作善得福为恶受殃。谓死神灭不复受生。不信有佛。不识涅槃。以铁鍱腹畏智溢出。夸王独步自谓无比。时童迦叶往至其门。王见迦叶被服异常。行步庠序威仪整齐。王即与论议。王问道人。道人言。作善有福为恶受殃。王言。今我宗家有一人。为善至纯。临欲死时。我与诸人共至其边。语其人言。如君所行死应生天。若上天者来还语我。死来于久不来告我。我是以知作善无福耳。道人答王曰。夫智者以譬喻自解。譬如有一人。堕百斛圊厕中。有人挽出。洗浴讫着好衣服。以香熏身坐于高床。有人语此人曰。还入厕中去尔。此人肯入。以不。王曰。不肯。道人曰。生天者其喻如是。天上快乐五欲自恣。以甘露为食。食自消化无便利患。身体香洁。口气苾芬。下观世间犹猪处溷。正使欲来闻臭即还。以是言之。何由得相告耶。如是比譬喻数十条事。王意开解。信向三尊。以是因缘故。童迦叶能杂种论为第一也

所以称面王比丘着弊恶衣无所羞耻者。可名作十一头陀耶。或曰。非也。何以谓为第一也。比丘着一种衣。终身不改。何以知其然。此比丘本是释种子。初生之时有异神德。母始怀妊时。请梵志占相。梵志策曰。此儿头上有天冠相。其母闻之欢喜佯不乐。念曰。夫天冠者王者相。一国之中不可有两王。恐王害之。是以不乐。所以内喜者。若实是王者。自然当有护。何忧不济也。日月遂满产一男儿。头上有天冠影。复请梵志为作字。梵志曰。头上有王相。复不可离此相。当名为面王。即字为面王真净王闻之。心怀愁忧。此儿有王者相。后必夺我位。当如之何。正欲辄杀罪不应死。正欲置之惧必夺己。俯仰忧悒不能自宁。佛来还国时。王宣令诸释曰。若有兄弟二人者。遣一人出家为道侍从世尊。此儿复一已。不得使出家在五百人例。是以益怀愁悴。时面王年十岁。心自念曰。正使转轮圣王。亦复无常。又复不及诸释出家。人身难得。佛世难值。曼值佛世。宜当出家。即白其母。我欲出家学道。母曰。我正有汝一人。舍我者我便当死。面王即启真净曰。我欲出家。王当听不。真净欢喜曰。大可尔。面王曰。自惟一已。母无所付嘱。以此为恨耳。王曰。卿若能出家者。我便当以卿母为姊分半国相给。面王欢喜。即还家以状白母。母即听之。当出家时。被一张白[疊*毛]。至世尊所欲求为道。世尊曰。善来比丘。即成沙门。佛制比丘有三衣。此面王比丘直更染此白[疊*毛]。以为袈裟。都不用余衣。白佛。弟子正欲终身被此一衣。愿世尊听之。佛即默然可之。自是已往常被此一衣。故世尊曰。我弟子中着弊恶衣者。无过面王比丘也。此于八大人念中。少欲知足最为第一也

所以称罗云持戒不毁者。或曰。罗云喜妄语。云何言持戒也。或曰。罗云不妄语。直自嗔佛耳。何以嗔佛也。以佛不作转轮圣王故。若作圣王者。当有八万四千大臣。八万四千玉女。象马车乘事事有八万四千。舍如此之位而作沙门东西行乞。不可羞耶。计圣王之利。嫌如来故。作妄语耳。人问罗云如来所在。如来实在祇树精舍。而答云在昼闇园。实在昼暗园。而诈言在祇园。反覆妄语诳于来人。阿难白佛。罗云妄语。佛唤罗云来。卿实妄语耶。对曰。实尔。罗云。汝何以作妄语耶。我所以舍圣王位者。以圣王位不可恃怙。皆归无常无长存者。正使帝释梵王皆不可保。况复圣王而可恃赖耶。罗云。我前后舍此不可称计。而汝方恨也。佛语罗云。汝取水来。罗云即盛满钵水授如来。如来执钵水。谓罗云曰。汝见此水不。对曰。已见。佛言。此水满钵无所缺减者。喻持戒完具无所损落。复写半弃。谓罗云曰。汝见此水不。对曰。见之。佛言。此水以失半。喻戒不具足。复写水使尽。示罗云曰。见此空钵不。答曰。已见。佛言。犯戒都尽。喻如空钵。复以钵覆地示曰。汝见不。答曰见。佛言。已犯戒尽当堕地狱。喻钵口向地也。罗云自被约敕以后。未曾复犯如毫厘。故称第一持戒也。或曰。复更有事。身子将罗云。入舍卫城乞食。时有婆罗门。见罗云在后行。即兴恶意打罗云头。血流污面。罗云即生恶念。要当方便报此怨家耳。但言婆罗门者。皆当破灭终不置也。身子已知罗云心中所念。为其拭血。谓罗云曰。当忆汝父。昔为须念王时。人来索眼。即挑眼与。亦不悔恨。在园中坐禅时。王截手足。亦不悔惋。若为象时。以牙与人。亦不厌惓。汝今云何起此恶念。罗云闻师所说。即自克责。我今云何恶心向彼。即忍如地。不起害心如毛发许。时打罗云首者。堕无择地狱中。以是因缘知罗云持戒第一也

所以称般咃比丘能隐形不现者。般咃者道也。有双生儿弃之于路。有人收取养长令大。各出家为道。无人与作字。即字为道生。胡言般咃也。时摩竭国数天雷暴雨。五谷不登。王名频头[口*荼]罗。是阿阇世王祖。募四远曰。有能却暴雨者。大与财宝。时有婆罗门。名曰梵志。善知咒术。来应募曰。我能却雨。王即听使现术止雨。时阴阳和调五谷大熟。梵志白王索止雨功报。王虽口许竟不报惠。诸臣人民见王不与。各复许之。梵志家俭每从索之。其于不与遍索不得。梵志大恚誓作毒龙。灭人苗稼。若有种五谷者。苗稼成好。大震雹杀。使根茎不立。何况有叶耶。誓已命终。即生龙中。号名无叶。时摩竭国人民种作苗稼适生。龙即雹杀。如是经数年人民饥困死亡者众。佛愍伤之。欲化此龙。即将密迹阿难般咃。至俱持国诣龙所止。时龙见佛来恶心生。曰今当放雹杀此沙门。即雨山石佛右回视密迹。密迹知佛意。即以金刚杵拟之堕大石山。塞其龙渊。龙大嗔怒。眼中火出。佛右回视般咃比丘。般咃比丘即知佛意。欲使降龙。般咃即以神足隐形。以水灭龙眼火。龙复于耳鼻口出火。亦以水灭此。比丘复以神力。于龙眼耳鼻口中反覆出入。而龙不见。隐形在内现手于外。龙睹此变即便心伏。佛复与三人等于前往反经行。石上有四人迹。而三人现。龙即问佛一人所在。答曰。是汝师迹。又曰。师名为谁。今何不现。答曰。名曰般咃。佛欲使远现。即知佛意。百步现形。龙遥见之。欢喜为礼。佛即授之八关斋法。自是以往风雨和调。五谷丰熟人民安宁。以是因缘。知般咃隐形第一也

所以称祝利。般咃能化形体作若干变者。祝利者极闇也。此比丘精神疏钝。佛教使诵扫帚。得帚忘扫得扫忘帚。六年之中专心诵此。意遂解悟。而自惟曰。帚者彗。帚者除。彗者即喻八正道。粪者三毒垢也。以八正彗扫三毒垢。所谓扫帚义者。正谓此耶。深思此理心即开解得阿罗汉道。所谓化形体者。以四谛妙慧化五阴形也。正有此化。更复有余。曰有婆罗门。名曰梵天。亦名世典。所以名世典者。博览群籍图书秘谶。天文地理无不关练。故名世典也。自以德高命敌而行。谁能与我论者。闻释种比丘中最下者有祝利般咃。忧婆塞中最下者。有瞿蜜多罗。吾当与此二人共论。即来与般咃共论。谓般咃曰。能与我共论耶。般咃曰。我尚能与汝祖父梵天共论。何况汝盲无目人乎。梵志寻言即诘曰。盲与无目有何等异耶。般咃默然不对。心念曰。无以相詶。当以神足相答耳。即以神足飞腾虚空去地四丈九尺。结跏趺坐。梵志仰瞻见其神变。敬情内发冀其清詶时舍利弗在只桓经行。以天耳闻梵志与般咃论。知其辞匮现变相答。我若不往比丘受屈。梵志不度。即以神足作般咃形。使般咃本形不现。化形问梵志曰。汝为是天。是人乎。答曰。是人。又问。人为是男子不。曰是男子。又问。男子与人有何等异。答曰。不异。又问。人者统名。男子者据形言之。何得不异耶。向言盲者。谓不见今世后世。善恶之报无目者。谓无智慧之眼以断结使也。梵志心解。即得法眼净。以是因缘知祝利般咃变形第一也

所以称释王比丘豪族富贵天姓柔和者。凡姓有四。刹帝利。婆罗门。长者。居士也。所以言贵者。以作沙门同一释姓。是以称贵耳。喻如四恒水。牛口师子口马口象口。各有五百支。合入大海。共为一水。无若干味。故海得称大。致贵于百川也。释姓亦如是。故称为豪贵第一也

真净王有三弟。最小弟名误净。有小儿年四岁。时真净王在正殿上坐。会诸群臣。王自惟曰。我儿不出家者。我应当作圣王。我儿。既生应当为圣王。然复出家去。我何用是天冠为。即脱天冠着地。有应作者便作。诸臣愁悒各无欢心。时释王小儿在前游行。见地天冠。即举着头上坐地。以左手拄肩。右手摩捋髭须。王与诸臣惊怪。所以王曰。此小儿天使其然。或能作圣王。我儿圣王相尽在此儿许。故使其然耳。众臣佥然曰。或能如王所言。王念曰。悉达既出家。又见小儿之相。即自废王位。乃经八年。闻悉达以成佛。度三迦叶师徒得千比丘。并优波提舍。拘律陀。师徒二百五十人。合千二百五十比丘。从摩竭国。欲还至释翅舍。先遣优陀夷。白还消息。真净闻之欢喜踊跃。即还着天冠。平治道路。扫洒烧香。以待如来。如来既至。王见诸比丘。虽复心精无表容貌。当选诸释五百人姿容可者。出为沙门侍从世尊。释王比丘最在其先。时佛在精舍大众之中。告诸比丘。普论种姓所以豪贵意。时真净王来至众中。向释王比丘礼。诸众皆怪所以。佛知此意。欲解众疑。故问王曰。何以礼此比丘。答曰。所以礼者。以此比丘有二事胜我。夫天有三。一日举天。二日生天。三日清净天。我正有举天。此比丘有生天。有清净天。所以言生天。以年四岁时。举吾天冠。着己头上。自然生意。无有与者。故曰生天清净天者。今已漏尽结解无复尘垢。故曰清净天也。以是二事胜我故。为作礼耳。以是因缘。知释王比丘豪族第一也

分别功德论卷第五按此论丹藏为三卷。开元录云四卷。而注云或三卷或五卷者。但分卷有异耳。文无增减焉。录有注叙云。右此一论。释增一阿含经义。从初序品至弟子品过半。释王比丘即止。法上录云。竺法护译者不然。此中牒经。解释文句。并同本经。似与增一阿含同一人译。而余录并云失译。且依此定。僧祐录云。迦叶阿难撰者。此亦不然。如论第一卷中。引外国师及萨婆多说。故知非是二尊所撰


佛地经论

    No. 1530

佛地经论卷第一

        亲光菩萨等造

        大唐三藏法师玄奘奉　诏译

  稽首无上良福田　　三身二谛一乘众
  我今随力造此论　　为法久住济群生
  览诸师意我已净　　恐余劣智未能通
  为令彼净生胜德　　故我略释牟尼地

论曰。佛地经者。具一切智一切种智。离烦恼障及所知障。于一切法一切种相能自开觉亦能开觉一切有情。如睡梦觉如莲花开。故名为佛地。谓所依所行所摄。即当所说清净法界大圆镜智平等性智妙观察智成所作智受用和合一味事等。是佛所依所行所摄故名佛地。能贯能摄故名为经。以佛圣教贯穿摄持。所应说义所化生故。应知此中宣说佛地饶益有情。依所诠义名佛地经。如缘起经。如集宝论

略说此经所摄义者。谓显世尊佛土圆满功德圆满眷属圆满安立佛地五法总别受用和合一味事智。依净法界具诸功德三身差别。此则次第示现。如来居如是处。具如是德。如是众俱安立。如是地义差别。如是处者。谓佛净土即十八种圆满庄严广大宫殿。如是德者。谓佛世尊二十一种殊胜功德。如是众者。谓无数量诸大声闻摩诃萨众。成就种种微妙功德。地义别者。谓大觉地五法总别受用和合一味事等。后当广说

于此经中总有三分。一教起因缘分。二圣教所说分。三依教奉行分。总显己闻及教起时。别显教主及教起处。教所被机即是教起所因所缘故。名教起因缘分正显圣教所说法门品类差别故。名圣教所说分。显彼时众闻佛圣教欢喜奉行故。名依教奉行分

经曰。如是我闻一时薄伽梵

论曰。如是我闻者。谓总显己闻。传佛教者言。如是事我昔曾闻如是。总言依四义转。一依譬喻。二依教诲。三依问答。四依许可。依譬喻者。如有说言。如是富贵如毗沙门。依教诲者。如有说言汝当如是读诵经论。依问答者。如有说言如是我闻如是宣说。依许可者。如有说言我当为汝如是而思。如是而作。如是而说。或许可言。是事如是有义此中唯依许可。谓结集时诸菩萨众咸共请言。如汝所闻当如是说。传法菩萨便许彼言。如是当说如我所闻又如是言信可审定。谓如是法我昔曾闻此事如是。齐此当说定无有异。有义此中亦依问答。谓有问言汝当所说昔定闻耶故此答言如是我闻。有义此中通依四种。依譬喻者。谓当所说如是文句如我昔闻。依教诲者。谓告时众如是当听我昔所闻。余如前说。我谓诸蕴世俗假者。闻谓耳根发识听受。废别就总故说我闻。有义如来慈悲本愿增上缘力。闻者识上文义相生。此文义相虽亲依自善根力起。而就强缘名为佛说。由耳根力自心变现故名我闻。有义闻者。善根本愿增上缘力如来识上文义相生。此文义相是佛利他善根所起。名为佛说。闻者识心虽不取得。然似彼相分明显现故名我闻。应知说此如是我闻。意避增减异分过失。谓如是法我从佛闻。非他展转显示。闻者有所堪能。诸有所闻皆离增减异分过失。非如愚夫无所堪能。诸有所闻或不能离增减异分。结集法时传佛教者。依如来教初说此言。为令众生恭敬信受。言如是法我从佛闻文义决定无所增减。是故闻者应正闻已如理思惟当勤修学。言一时者。谓说听时。此就刹那相续无断。说听究竟总名一时。若不尔者。字名句等说听时异。云何言一。或能说者得陀罗尼。于一字中一刹那顷能持能说一切法门。或能听者。得净耳根一刹那顷闻一字时于余一切皆无障碍。悉能领受故名一时。或相会遇时分无别故名一时。即是说听共相会遇同一时义。时者。即是有为法上假立分位。或是心上分位。影像依色心等总假立故。是不相应行蕴所摄。何不别显如下处等。但说一时昼夜时分诸方不定不可别说。又义不定。或一刹那或复相续不可定说。是故总相但说一时

薄伽梵者。谓薄伽声依六义转。一自在义。二炽盛义。三端严义。四名称义。五吉祥义。六尊贵义。如有颂言

  自在炽盛与端严　　名称吉祥及尊贵
  如是六种义差别　　应知总名为薄伽

如是一切如来具有于一切种皆不相离。是故如来名薄伽梵其义云何。谓诸如来永不系属诸烦恼故。具自在义。焰猛智火所烧炼故。具炽盛义。妙三十二大士相等所庄饰故。具端严义。一切殊胜功德圆满无不知故。具名称义。一切世间亲近供养咸称赞故。具吉祥义。具一切德常起方便利益。安乐一切有情无懈废故。具尊贵义。或能破坏四魔怨故。名薄伽梵。四魔怨者。谓烦恼魔蕴魔死魔自在天魔。佛具十种功德名号。何故如来教传法者。一切经首但置如是薄伽梵名。谓此一名世咸尊重故。诸外道皆称本师名薄伽梵。又此一名总摄众德。余名不尔是故经首皆置此名。薄伽梵德后当广说

经曰。住最胜光曜七宝庄严。放大光明。普照一切无边世界。无量方所妙饰间列。周圆无际其量难测。超过三界所行之处。胜出世间善根所起。最极自在净识为相如来所都。诸大菩萨众所云集。无量天龙人非人等常所翼从。广大法味喜乐所持。作诸众生一切义利。灭诸烦恼灾横缠垢。远离众魔过诸庄严。如来庄严之所依处。大念慧行以为游路。大止妙观以为所乘。大空无相无愿解脱为所入门。无量功德众所庄严。大宝花王众所建立大宫殿中

论曰。此显如来住处圆满。谓佛净土如是。净土复由十八圆满事故。说名圆满。谓显色圆满形色圆满分量圆满方所圆满因圆满果圆满主圆满辅翼圆满眷属圆满住持圆满事业圆满摄益圆满无畏圆满住处圆满路圆满乘圆满门圆满依持圆满。由十九句如其次第显示如是十八圆满。即此圆满所严宫殿名佛净土。佛住如是大宫殿中说此契经

受用变化二佛土中。今此净土何土所摄。说此经佛为是何身。有义此土变化土摄。说此经佛是变化身。声闻等众住此土中。现对如来闻说是经。欢喜信受而奉行故。佛心所现故。出三界净识为相为说胜法。化此地前诸有情类。令其欣乐修行彼因故。暂化作清净佛土。殊妙化身神力加众令暂得见。若不尔者声闻等众应俱不见。有义此土受用土摄。说此经佛是受用身。此净土量无边际故。路乘门等是实德故。受用如是清净佛土。一向净妙一向安乐一向无罪一向自在余处说故。解深密说。三地已上乃得生故。说此经佛具后所说二十一种实功德故。说余经时不列如是佛功德故。若暂化作如是净土如是妙身。加众令见。应如余经分明显说。然不说故。是受用土及受用身。声闻等众是佛化作。或诸菩萨现作此身。庄严佛土说法会故。若尔此是地上菩萨所应见闻。何故于此化佛土中结集流布传法菩萨。为欲示现一切智者及所居处超过一切世间法故。如是示现欲令所化生欣乐故。为令发愿当生如是清净佛土。见如是佛闻如是法。修彼因故。为生广大胜解有情及诸菩萨胜欢喜故。欲令增上意乐胜解界坚牢故。结集流布。又是法胜于此宜闻。然处非胜化身相粗不可宣说。故受用身居受用土。为初地上诸菩萨说。令传法者结集流通。若尔何故不但说彼所说法耶。若不说处及能说者。不知此法何处谁说。一切生疑故须具说。如实义者。释迦牟尼说此经时。地前大众见变化身居此秽土为其说法。地上大众见受用身居佛净土为其说法。所闻虽同所见各别。虽俱欢喜信受奉行。解有浅深所行各异。而传法者为令众生闻胜悕愿勤修彼因。当生净土证佛功德。故就胜者所见结集。言薄伽梵住最胜等。乃至广说如来功德

最胜光曜七宝庄严者。谓大宫殿用最胜光曜七宝庄严。或大宫殿七宝庄严故最胜光曜。言七宝者。一金。二银。三吠琉璃。四牟婆洛揭婆。五遏湿摩揭婆。六赤真珠。谓赤虫所出名赤真珠。或珠体赤名赤真珠。七羯鸡怛诺迦。就此所重且说七宝。其实净土无量妙宝绮饰庄严。非世所识。放大光明普照一切无边世界者。谓大宫殿放大光明。普照一切无边世界。或大宫殿其体周遍无边界故。放大光明普照一切。由此二句显佛净土显色圆满。如是净土显色圆满。形量云何。无量方所妙饰间列。谓大宫殿妙饰间列无量方所。或大宫殿无量妙饰方所间列。言无量者。或数无量。或处无量。如慧为先安布间饰。是故说名妙饰间列。云何佛土净心为相。非外工具世匠所成而有。如是如慧为先安布间饰。谓佛世尊昔菩萨时发巧便慧。如是如是加行誓愿庄严佛土。由先加行誓愿势力。于果位中虽无如昔戏论觉慧。而佛净识如是变现亦令菩萨识如是变故不相违。余处亦应依此理说

如是净土形色圆满。分量云何。周圆无际其量难测。谓大宫殿其量周圆无际难测。或大宫殿其量无际周圆难测。又东方等分齐无故。长短等相难可测量。有义如来受用身土随所化生所宜而现。或大或小其量无定。虽现广大亦有边际。然就地前菩萨智等。说言无际其量难测。有义如来受用身土。三无数劫所修无边善根所感周遍法界。地上菩萨及诸如来。亦不能测其量边际。以无边故。如无始时。如实义者。受用身土略有二种。一自受用。谓诸如来三无数劫所修无边善根所感周遍法界。为自受用大法乐故。从初得佛尽未来际相续无变。如诸功德诸大菩萨亦不能见。但可得闻。如是净土以无量故。诸佛虽见亦不能测其量边际。二他受用。谓诸如来为令地上诸菩萨众受大法乐。进修胜行随宜而现。或胜或劣或大或小。改转不定如变化土。如是净土以有边故。地上菩萨及诸如来皆测其量。但就地前言不能测。由是二种差别故言。周圆无际其量难测。如是净土分量圆满。为三界处为不尔耶。超过三界所行之处。谓大宫殿处所方域。超过三界所行之处。非如三界自地诸爱执为己有。所缘相应二缚随增。是彼异熟及增上果。如是净土非三界爱所执受故。离二缚故。非彼异熟增上果故。如涅槃等超过三界异熟果地。若尔净土非三界摄。便是无漏。若是无漏有为所摄。即是道谛便是善性。云何得用色声香等为其体性。以十八界十五有漏八无记等余处说故。有义十八界通有漏无漏皆有善性。然据二乘境界粗相相似。说言十八界中十五有漏八无记等。有义净土定心所变。虽有色等似十界相非十界摄。非诸世间五识所得。如遍处等所缘青等。皆是自在所生色故。法界所摄。是故净土虽用色等为其体性。是无漏善亦不相违。若尔菩萨五识不缘受用土耶。虽依彼力自识变异。然相粗妙不相似故。非五境摄如来五识可不缘耶。佛缘事心作用相似。假名五识实非五识。恒在定故。余处宣说五识体是自性散乱。无有定故。若尔不从五根生耶。如来五根及色声等。相同根境假名五根。及色等境定心变故。实是法界自在生色。若尔四智应不同时。无有一时一类多识一身起故。许亦何失。如实义者。如来身土甚深微妙。非有非无非是有漏亦非无漏。非善非恶亦非无记。非蕴界等法门所摄但随所宜种种异说。余处说言。十八界中十五有漏八无记等。但就二乘异生等境粗相分别。不就诸佛诸大菩萨甚深境界故余处说如来非实蕴界处摄。所有善等皆是示现。乃至广说。如是净土为与三界同一处所为各别耶。有义各别。有处说在净居天上。有处说在西方等故。有义同处。净土周圆无有边际遍法界故。如实义者。实受用土周遍法界无处不有。不可说言离三界处。亦不可说即三界处。若随菩萨所宜现者。或在色界净居天上。或西方等处所不定

如是净土方所圆满。既超三界异熟果地。如涅槃等应无有因。若有因者应三界摄。若言净土超过三界。还有超过三界法因。此应当说其相。云何胜出世间善根所起。谓大宫殿用出世间无分别智后所得智善根为因而得生起。非是无因。非大自在天等为因。云何净土超过三界。而用出世无分别智后所得智。世间净法为异熟因。不说与彼为异熟因。然为余因彼得生起。如苦法智忍品世第一法为因。此用本来无分别智后得无漏善法种子。三无数劫修令增广。为此净土变现生因。无分别智名出世间。后得过前说名为胜用胜出世无漏善根为此生因。或诸声闻独觉圣道名出世间。如来善根过彼名胜。此佛净土如来识中无漏善根为因而生。有义但是增上缘生。以外法故。有义亦是因缘而生。亲能生故。若不尔者应无因缘。外法相望非因缘故。一切外法皆用内法熏习为因。若尔外法既是共有。云何有情各别种子。共为因缘合生一果。勿以小心测量大法。外物岂是极微合成实有体性多因共感。但是有情异识各变。同处相似不相障碍。如众灯明。如多所梦。因类是同果相相似。处所无别假名为共实各有异。诸佛净土亦复如是。各别识变皆遍法界。同处相似说名为共。如是净土因相圆满。果相云何。最极自在净识为相。谓大宫殿最极自在。佛无漏心以为体相。唯有识故。非离识外别有宝等。即佛净心如是变现似众宝等。如前已说。境界相故。如入青等遍处定者。识所现相此即如来大圆镜智相应净识。由昔所修自利无漏净土种子因缘力故。于一切时遍一切处。不待作意任运变现。众宝庄严受用佛土与自受用身作所依止处。利他无漏净土种子因缘力故。随他地上菩萨所宜变现净土。或小或大或劣或胜。与他受用身作所依止处。谓随初地菩萨所宜。现小现劣。如是展转乃至十地。最大最胜于地地中。初中后等亦复如是

如是净土果相圆满。其主云何。宫殿定有主依持故。如来所都谓大宫殿。诸佛世尊为主。非余以殊胜故。唯属世尊。或唯世尊住持摄受非余所能。自受用土虽遍法界。一一自变各自为主不相障碍。他受用土虽诸佛变。然一合相亦一相身。摄受为主不相障碍

如是净土主既圆满。应有辅翼。主必摄受辅翼者故。诸大菩萨众所云集。谓大宫殿常有无量大菩萨僧共所云集。谓来朝者必为辅翼。既有无数大菩萨僧。常来辅翼故无怨敌能为违害。诸声闻等无如是事。谓初地上诸菩萨众。虽不能集诸佛自利受用净土。而能集会诸佛利他受用净土。诸佛慈悲于自识上。随菩萨宜现粗妙土。菩萨随自善根愿力。于自识上似佛所生净土相现。虽是自心各别变现。而同一处形相相似。谓为一土共集其中。如是地上菩萨净土。为是有漏为是无漏。有义无漏。谓自心中后得无漏净土种子愿力资故。变生净土。于中受用大乘法乐。以初地上诸菩萨众证真如理。得真无漏处真法流。住真净土常见诸佛。故所变土是真无漏道谛所摄。有义有漏。谓自心中加行有漏净土种子愿力资故。变生净土。于中受用大乘法乐。以彼菩萨虽证真如得真无漏。而七地来烦恼现起。乃至十地犹有修断烦恼种子。及所知障。第八识体能持彼故。现受熏故。犹是有漏无记性摄。有为无漏道谛所摄。决定是善。若十地中第八识体是无漏善。应如佛地不能执持有漏种子。不应受熏。第八识体既是有漏无记性摄。所变净土云何无漏善性所摄。又一有情无二实身。其身尔时既是有漏。所依净土云何无漏。是故十地菩萨净土是妙有漏苦谛所摄。如实义者。十地菩萨自心所变净土有二。若第八识所变净土。是有漏识相分摄故。是有漏身所依处故。虽无漏善力所资熏其相净妙。而是有漏苦谛所摄。随加行等所现亦尔。若随后得无漏心变净土影像。是无漏识相分摄故。从无漏善种子生故。体是无漏道谛所摄

如是净土辅翼圆满。应有眷属。故次说言。无量天龙人非人等常所翼从。谓大宫殿唯有天等眷属围绕。无有余类等者。等取药叉揵达缚阿素洛揭路荼紧捺洛莫呼洛伽等。莫呼洛伽即摄大蟒。云何净土超过三界所行之处。而有天等以为眷属。天等皆是三界摄故。净识如是摄受变现。为严净土故不相违或为成熟所化有情。示现如是变化种类。如为调伏劫比拏王。现化无量转轮王众眷属围绕。或诸菩萨化作无量天龙等身住净土中。以供养佛。或自化身为天龙等。翼从如来故无有过

如是净土眷属圆满。于中止住。以何任持。广大法味喜乐所持。谓于此中大乘法味喜乐所持食能令住。是任持义。已说净土超过三界所行之处。云何有食。又无漏法不应名食。食能长养三有众生。此断有故应不名食。是任持因故亦名食。如汝宗中生色界等入无漏定亦应名食。非过去食应名为食。过去无故。此亦应尔。是任持因故说为食。如有漏法虽障无漏。然持有漏得名为食。无漏亦尔。虽断有漏然持无漏云何非食。此净土中诸佛菩萨后得无漏。能说能受大乘法味生大喜乐。又正体智受真如味生大喜乐。能任持身令不断坏。长养善法故名为食

如是净土任持圆满。作何事业。作诸众生一切义利。谓于此中自能现作一切有情一切义利。或令一切有情自作一切义利。现益名义当益名利。世间名义出世名利。离恶名义摄善名利。福德名义智慧名利。如是等别虽在寂定。由先所修加行愿力。任运能作一切有情一切义利

如是净土事业圆满。有何摄益。灭诸烦恼灾横缠垢。谓于此中远离一切烦恼缠垢。及诸灾横。即诸烦恼名为缠垢。如是即名诸灾横因。烦恼缠垢此中无故。所作灾横此中亦无。又烦恼者。谓一百二十八根本烦恼。缠者即是无惭愧等。垢者即是谄诳憍等。灾横即是彼所发业及所得果。若所知障或诸随眠名为烦恼。即彼现起说名缠垢。本惑名缠。随惑名垢。所知障等名为灾横。此中何法名为摄益。即离烦恼灾横缠垢名为摄益。如世封主虽不摄受但不为灾。封户亦言主摄益我。此亦如是。又现证得解脱烦恼灾横缠垢。殊胜福智故名摄益。如是净土离内灾横摄益圆满。亦应无有外怖畏因。故次示现无畏圆满。远离众魔。谓于此中远离一切烦恼蕴死及以天魔。或能令他远离四魔。如是四种是怖畏因。由是能生诸怖畏故。此中无彼故无怖畏。烦恼魔者。谓一百二十八烦恼。并随烦恼。蕴魔者。谓五取蕴。死魔者。谓有漏内法诸无常相。天魔者。谓欲界第六自在天子。如是四种皆能损害诸善法故。说名为魔。由是四魔生诸怖畏。如来永离四种魔故。无诸怖畏。初地已上诸大菩萨。在净土中离粗四魔无五怖畏。如是净土无畏圆满。其所住处亦应殊胜。故次复说住处圆满。过诸庄严如来庄严之所依处。谓于此中佛所住处。胜过一切菩萨及余庄严住处。唯是如来妙饰庄严为所住处。由胜一切庄严住处。是故说名住处圆满。如是净土住处圆满。有何道路于中往来。大念慧行以为游路。谓于此中大念大慧。及以大行为所行路。所游履故名为游路。是道异名。闻所成慧名为大念。闻已记持无倒义故。思所成慧名为大慧。依理审思得决定故。修所成慧名为大行。由修习力趣真理故。大者念等缘大乘法而生起故。是彼果故。彼所摄故。履三妙慧净土往还。故名游路。此说菩萨因三妙慧。得入净土故名游路。若诸如来大念即是无分别智。由念安住真如理故。大慧即是后所得智分别诸法真俗相故。此二皆有造作净土增上业用。故俱名行。由此二智通生净土。故名游路。或大念行是自利行。内摄记故。大慧行者是利他行。外分别故。如其次第通生如来二种净土。故名游路。如是净土路既圆满。应有所乘御彼所乘行此道路。故次说言。大止妙观以为所乘。止谓三摩地。观谓般罗若。大义如前。此二等运故名所乘。乘此止观随其所应。行前道路。路是总位。位中止观别名所乘

如是净土乘既圆满。应有入门。从彼入门御此乘入。故次说言。大空无相无愿解脱为所入门。谓大宫殿三解脱门为所入处。解脱即是出离涅槃。即大空等名解脱门。依从此门而入净土。遍计所执生法无我说名为空。缘此三摩地名空解脱门。相谓十相。一色。二声。三香。四味。五触。六男。七女。八生。九老。十死。即是涅槃无此等相。故名无相。缘此三摩地名无相解脱门。愿谓求愿。观三界苦无所求愿。故名无愿。缘此三摩地名无愿解脱门。由此空等三解脱门得入净土。故名为门。大如前说。此净土中亦应有事。路乘门等为令有情欣乐实德。故就行说

如是净土门既圆满。如余宫殿应有所依。故次复说依持圆满。无量功德众所庄严。大宝花王众所建立。谓如地等依风轮等。或如世间宫殿依地。如是净土无量德众所严。大宝红莲花王众所建立。谓红莲花大宝所成。如是大宝无量功德众善所起。于众宝中胜故名大。此宝红莲。于诸花中最为殊胜。故名花王。或此宝花望诸菩萨善根所起红莲花众胜故名大。佛是法王。是佛最胜善根所起。故名花王。又此宝花极难得故名为大。宝花中最胜故名花王。此花非一。或花叶多故名为众。世尊住此花众建立大宫殿中。说是契经。是故说言大宫殿中。若就如来实受用身所依净土。名大宫殿量同法界。于中一一佛受用身是能说本名说此经。若就如来随菩萨宜现受用身。所依净土名大宫殿其量不定。于中诸佛同现一身。正说此经故。此宫殿分量方所不可定说

佛地经论卷第一佛地经论卷第二

        亲光菩萨等造

        大唐三藏法师玄奘奉　诏译

经曰。是薄伽梵最清净觉。不二现行趣无相法。住于佛住逮得一切佛平等性。到无障处不可转法所行无碍其所成立不可思议。游于三世平等法性。其身流布一切世界。于一切法智无疑滞。于一切行成就大觉。于诸法智无有疑惑。凡所现身不可分别。一切菩萨正所求智。得佛无二住胜彼岸。不相间杂如来解脱。妙智究竟证无中边。佛地平等极于法界。尽虚空性穷未来际

论曰。次显诸佛异余大师。故说世尊功德殊胜。又为其余生净信故。显示世尊功德圆满。应知。此中二十一种殊胜功德。显薄伽梵最清净觉。谓佛世尊普于一切有为无为所应觉境正开觉故。又于一切所应觉境净妙圆满正开觉故。又于一切如所有性尽所有性正开觉故。名薄伽梵最清净觉。不二现行者。显示世尊一向无障殊胜功德。谓凡夫二乘现行二障世尊无故。以诸凡夫现行生死。起诸杂染住着生死。声闻独觉现行涅槃。一向弃背利乐他事住着涅槃。世尊无彼现行二障。是故说名不二现行。趣无相法者。显示世尊调化方便殊胜功德。谓无相法即是涅槃。佛善了知三乘有情。随彼堪能调化方便。如实为说令彼趣证无相法故。住于佛住者。显示世尊观所调化殊胜功德。谓住大悲昼夜六时观世间故。逮得一切佛平等性者。显示世尊得一切佛相似事业殊胜功德。谓证诸佛相似事业平等性故。到无障处者。显示世尊永断所治殊胜功德。谓已证得解脱一切烦恼所知二障智故。及已永断一切障故。不可转法者。显示世尊降伏外道殊胜功德。谓佛正法一切外道不能退转。降伏彼已显正道故。所行无碍者。显示世尊降伏魔怨殊胜功德。谓所行者。即色等境。此所行境。扰乱心故。障碍善故。说名魔怨。诸佛世尊心善安定极悦意境亦不能乱。所有功德极善成满。一切恶境不能为碍。以能摧伏一切境界。一切所行不能拘碍。是故说名所行无碍。其所成立不可思议者。显示世尊安立法教殊胜功德。谓佛安立一切法教。超过一切寻思境故。游于三世平等法性者。显示世尊记别三世殊胜功德。谓如现在记别过去未来世事皆无碍故。其身流布一切世界者。显示世尊现从睹史天宫来下殊胜功德。谓现化身普于一切世界洲渚。同时流下入母胎故。于一切法智无疑滞者。显示世尊断一切疑殊胜功德。谓于诸法已得能除一切疑惑决定智故。于一切行成就大觉者。显示世尊于一切乘所化有情能随所应。示现自身殊胜功德。谓遍了知一切有情性行差别。如其所应现自身故。于诸法智无有疑惑者。显示世尊妙善了达一切法智。能随所应恒正教诲殊胜功德。谓于诸法怀疑惑者。无有堪能随应教诲。唯佛世尊证见诸法智善决定。能随所应无倒教诲无休废故。凡所现身不可分别者。显示世尊能正摄受无染自身殊胜功德。谓诸佛身非是虚妄分别所起。无烦恼业生离染故。以如来身非是杂染分别起故。不可分别一切菩萨正所求智者。显示世尊成就佛种不断方便殊胜功德。谓诸菩萨为令佛种无断绝故。勤修加行非声闻等。是故佛智唯诸菩萨正所应求。得佛无二住胜彼岸者。显示世尊自性身分殊胜功德。谓佛法身无差别相故。名无二。佛无二住即是法身。真如为体无差别相。于中一切二相分别皆不现行。缘彼胜定常住其中。故名为住。即无二住名胜彼岸。佛已穷到故名为得。不相间杂如来解脱妙智究竟者。显示世尊受用身分殊胜功德。谓受用身不相间杂。一切如来受用身体各各别故。如来妙智能令一切众生解脱。故名如来解脱妙智。佛于此智已得究竟。如是即说如来妙智不相间杂。于净佛土现受用身亦不相杂。大集会中现种种身。与诸菩萨受用法乐亦不相杂。如来于此智所现身。亦到究竟证无中边。佛地平等者。显示世尊证真如相殊胜功德。谓真如相无有中边。远离一切有为无为中边相故。远离方处中边相故。如是真如即是佛地平等法性。证此佛地平等性故。遍知一切为无为等于中不染。极于法界者。显示世尊证得果相殊胜功德。谓得穷极清净法界。如是法界是修道果。次后二种殊胜功德。显示世尊功德无尽。尽虚空性穷未来际者。显示世尊自利利他二德无尽殊胜功德。谓如虚空经成坏劫性常无尽。如来一切真实功德亦复如是。常无断尽。如未来际无有尽期。利他功德亦复如是。穷未来际常作一切有情利益安乐事故

复次此中总别显示世尊殊胜功德。初句是总。由所余句开显其义。如是乃名善说法要。由二十一殊胜功德。是故说名最清净觉。不二现行者。显示世尊于所知境一切无障智转功德。谓声闻等于诸境界智有障碍。极远时方无边差别。诸佛法中无智转故。如来不尔。一切时方无边差别。诸佛法中一切种智无障碍转。于诸法相无知不知二种现行。是故说名不二现行。由此故名最清净觉。余句皆应如是配属。趣无相法者。显示世尊能入无二殊胜功德。谓自能入永离一切分别自相。解脱一切烦恼缠垢。离有无相清净真如亦令他入。住于佛住者。显示世尊任运佛事不休息住殊胜功德。谓无功用利有情事无有间断。安住圣天及梵住故。逮得一切佛平等性者。显示世尊于法身中所依意乐作业无别殊胜功德。谓一切佛真如净智。一切利益安乐意乐。受用变化二利他事无差别故。到无障处者。显示世尊已修一切障法对治殊胜功德。谓已修习一切烦恼及所知障对治圣道。已到解脱一切障处。所依所趣故名为处。不可转法者。显示世尊不为一切外道所伏殊胜功德。谓教证法皆不为他所退转故。所行无碍者。显示世尊虽生世间世法不碍殊胜功德。谓生世间利等八法不能碍故。其所成立不可思议者。显示世尊安立正法殊胜功德。谓十二分殊胜教法。出过一切寻思所行。非诸愚夫所能测度。宣说一切自相共相故名安立。游于三世平等法性者。显示世尊能正记别殊胜功德。谓于三世流转句义。曾现当生展转记别无颠倒故。记别去来皆如现在。分明无倒故名平等。其身流布一切世界者。显示世尊同时普于一切世界。示现受用及变化身殊胜功德。谓于一切无边世界。随所化宜现琉璃等妙色身故。于一切法智无疑滞者。显示世尊断一切疑殊胜功德。谓自决定乃能令他生决定故。于一切行成就大觉者。显示世尊入种种行殊胜功德。谓随所化有情所宜现同类身。令彼入故。于诸法智无有疑惑者。显示世尊了达当来法生妙智殊胜功德。谓于出过声闻等境。微细善种如瓦石中细金种子。如是等境无颠倒相皆遍知故。凡所现身不可分别者。显示世尊随其胜解如应示现殊胜功德。谓佛世尊虽无分别如末尼珠由诸如来增上力故。亦由自身胜解力故。见如来身如金色等。然诸如来无有分别。无异分别。广说如经。或同彼类。不可分别一切菩萨正所求智者。显示世尊无量所依所化有情调伏方便殊胜功德。谓由无量菩萨所依一切有情调伏方便。此由如来增上力故。得闻正法。思修次第获得妙智。异类菩萨摄受付嘱。展转相续无间而转。得佛无二住胜彼岸者。显示世尊平等法身波罗蜜多最极成满殊胜功德。谓于佛地无二法身。一切施等波罗蜜多平等圆满不相间杂。如来解脱妙智究竟者。显示世尊随其胜解示现无杂清净佛土殊胜功德。谓观有情胜解差别。示现种种不相间杂金等佛土。证无中边佛地平等者。显示世尊三身方处无有分限殊胜功德。谓证平等无初中后。诸佛三身于其佛地佛净土中。无有一切方处分限。极于法界者。显示世尊穷生死际。常现起作一切有情利益安乐殊胜功德。谓此法界善清净故。穷生死际。常起等流契经等法。为当来世所化有情。如应如时恒现起作利益安乐。尽虚空性穷未来际者。显示世尊无尽究竟殊胜功德。谓如虚空常无穷尽。诸佛法界所起功德亦复如是。无穷尽故。如未来际无有尽期。利乐一切有情加行无休息故。诸佛功德为性是常无尽。究竟为性无常相续不断。无尽究竟不可定说。以佛法身清净法界理性功德性是常故。受用变化二身功德。虽性无常无断尽故。无尽究竟。一切如来本发弘愿。为有情故求大菩提。若诸有情尽得灭度。尔时诸佛有为功德何不断灭。诸有情界无有一切尽灭度时。故佛功德无有断灭。所以者何。由法尔故。无始时来一切有情有五种性。一声闻种性。二独觉种性。三如来种性。四不定种性。五无有出世功德种性。如余经论广说其相。分别建立前四种性。虽无时限然有毕竟得灭度期。诸佛慈悲巧方便故。第五种性无有出世功德因故。毕竟无有得灭度期。诸佛但可为彼方便示现神通。说离恶趣生善趣法。彼虽依教勤修善因得生人趣。乃至非想非非想处。必还退下堕诸恶趣。诸佛方便复为现通说法教化。彼复修善得生善趣。后还退堕受诸苦恼。诸佛方便复更拔济。如是展转穷未来际。不能令其毕竟灭度。虽余经中宣说一切有情之类皆有佛性皆当作佛。然就真如法身佛性。或就少分一切有情方便而说。为令不定种性有情。决定速趣无上正等菩提果故。由此道理。诸佛利乐有情功德无有断尽。此利他德依自利德乃得无断。是故如来有为功德从因生故。虽念念灭而无断尽。由佛功德无尽究竟。是故成就最清净觉。其余诸句皆应如是一一配属。何故先说诸佛净土。后说世尊如是功德。为显如是诸佛功德依净土故。为显世尊依净佛土具如是德说此经故

次显世尊眷属圆满。谓大声闻及大菩萨。余经中说调顺调顺而为眷属。解脱解脱而为眷属。是名如来眷属圆满。此说无量大声闻众无量菩萨摩诃萨俱。一切调顺皆佛子等。皆住大乘游大乘等。如其次第声闻菩萨眷属圆满。何故此中先说声闻后说菩萨。为于大乘生疑惑者。除彼疑故。为引不定种性菩萨生定信故。为已清净诸大声闻舍于自身尊贵慢故。谓于众前大声闻众近对世尊亲受化故。又诸声闻常随佛故。形同佛故。内眷属故。又令菩萨于声闻众生恭敬故。如契经言。菩萨不应于声闻众不生恭敬。由是赞叹声闻功德。亦令其余于声闻众生净信故。于此会中亦有余众结集法者。略说二众以其胜故。如经后言。世间天人阿素洛等一切大众。闻佛所说皆大欢喜信受奉行。前说净土最极自在净识为相。云何会中有声闻等而不相违。有何相违。诸声闻等同菩萨见故成相违。若声闻等亦如是见可作是说。诸声闻等虽预此会。障见净妙业所碍故。犹如生盲不见。如是净妙境界不可难言。既不能见不应在众。以虽不见如是净妙而见秽土化身说故。虽同一会自业力故所见各异。如见真金谓为火等。如于一处四种众生各别见等。或复如来神力加被。令暂得见闻说妙法。此是如来不思议力不可难。以根地度等化亦无过。为欲庄严说法会故。或佛化作。或诸菩萨之所化作

经曰。与无量大声闻众俱。一切调顺皆是佛子。心善解脱慧善解脱。戒善清净趣求法乐。多闻闻持其闻积集。善思所思。善说所说。善作所作。捷慧速慧。利慧出慧。胜决择慧大慧广慧。及无等慧。慧宝成就具足三明。逮得第一现法乐住。大净福田威仪寂静。大忍柔和成就无减。已善奉行如来圣教

论曰。无量大声闻众者。其数甚多难可算计。故名无量。闻佛言音。而入圣道故名声闻。并出家僧故名为众。一切皆是最极利根波罗蜜多种性声闻故名为大。有义皆住无学果位故名为大。如实义者。皆是不定种性声闻。得小果已趣大菩提故名为大。或众数多故名为大。如今大众一切调顺者。有义有学离见所断一百一十二种分别粗重烦恼。不[怡-台+龍]悷故犹如良马名为调顺。有义无学离见修断一百二十八种烦恼不刚强故。犹如真金名为调顺。如实义者。皆是回向菩提种性。一切堪能发趣大果。随佛意转如聪慧象。故名调顺。由佛教力彼圣道生。故名佛子。如说皆从世尊口生。正法生故。有义皆是趣大声闻。能绍佛种令不断绝。故名佛子。心善解脱者。离三界贪故。如说离贪心得解脱。慧善解脱者。已离一切染污无明故。如说离于无明慧得解脱。戒善清净者。如契经说。具足六支名戒善净。谓住净尸罗善自防守。别解律仪轨则所行皆悉具足。于微细罪见大怖畏。受学学处。或复皆得无漏戒故。名善清净。如实义者。住无学位回向大乘。自分戒净修菩萨戒。故名善净。趣求法乐者。求正法时欲趣大乐。谓佛菩提不求余事。或求法时为令他乐无求过意。离恶威仪。如实义者。此大声闻专求法乐。不求名闻利养恭敬。无量经典初中后分皆能听受。故名多闻。随所闻义皆能忆持令不忘失。故名闻持。数习文义令其坚住。是故说名其闻积集。世间愚夫恶思所思。恶说所说。恶作所作。出世圣者。超过彼法与彼相违。是故说名善思所思善说所说善作所作。三业清净随智慧行。于佛所说法毗柰耶。速入其义。故名捷慧。即于此中多入其义。故名速慧。能多行者说名速故。入微细义故名利慧。得能出离生死妙慧故名出慧。此慧能为涅槃了因。是故说名胜决择慧。胜决择故名胜决择。即是涅槃。此慧能为彼了因故。依彼立名。问答决择无穷尽故。名为大慧。深广圆满善通达故。名为广慧。有本复说甚深妙慧。谓他不能穷其底故。于软根等诸声闻众。此慧胜故名无等慧。此慧能招最上义故。名为慧宝。是诸声闻具此慧宝。是故说名慧宝成就。具足三明者。谓得无学三种明故。云何名为无学三明。一宿住随念智证通明。二死生智证通明。三漏尽智证通明。无学利根所得三通。除染不染三际愚故。说有三明。有义明者以慧为性。慧能除闇故说为明。有义无痴善根为性翻无明故。逮得第一现法乐住者。证得不退胜静虑故。大净福田者。永离烦恼如世良田速能生长广大果故。威仪寂静者。一切威仪正知住故。大忍柔和成就无减者。于苦堪耐易共住故。已善奉行如来圣教者。诸有所作已圆满故。如来圣教本为有情出生死苦。是诸声闻位登无学皆出生死。故善奉行如来圣教。若尔何故复为说法。为令回向大菩提故。是诸声闻皆住无学。尽此一报必入永灭无余涅槃。寂静安乐与佛无异。如余论说。何故引彼趣大菩提长时受苦。变易位中无诸苦受。斯有何过。行苦有故。是为大过。虽经此苦。令得如来三身功德大喜大乐故无有过。一切大乐不过涅槃。彼已证得。复何所少更求菩提涅槃。虽有寂灭安乐而无受乐。三菩提乐断受乐等。无量功德何用行苦有为乐耶。有为无漏犹如涅槃。是无漏故。非行苦摄。又若成佛能化无量所化有情出生死故。已成佛者。无此能耶。无始时来众生法尔。能化所化种性相属。不相属者即无化能。是故如来种种方便。化诸有情令得佛果。化彼所化若尔声闻或除七生。或除一生。或除上界处处一生。余一切生得非择灭。或一切生皆非择灭。云何更经三无数劫修菩提因而得佛耶。虽诸烦恼所润分段得非择灭。而由愿力受变易生。三无数劫修菩提因无有过失。非择灭者。众缘不具。于此时中毕竟不生。非永不生。彼虽长时住在生死。由定愿力资感生因。令其功能多时生果。即此一身展转增胜乃至成佛。如延寿法更不受生。故论说言。问回向菩提声闻为住无余依涅槃界。发趣无上正等菩提。为住有余依涅槃界耶。答唯住有余依涅槃界中。可有此事。所以者何。以无余依涅槃界中。远离一切发起事业。一切功用皆悉止息。问若唯住有余依涅槃界中。发趣无上正等菩提者。云何但由一生便能证得无上正等菩提。所以者何。阿罗汉等尚当无有所余一生。何况当有多生相续。答由彼要当增诸寿行方能成办。世尊多分依此回向菩提声闻。密意说言。若有善修四神足已。能住一劫或余一劫。余一劫者。此中意说过于一劫。彼虽如是增益寿行。发趣无上正等菩提。而所修行极成迟钝乐涅槃故。不如初心始业菩萨。彼既如是增寿行已。留有根身别作化身。同法者前方便示现于无余依涅槃界中而般涅槃。由此因缘皆作是念。某名尊者于无余依涅槃界中已般涅槃。彼以所留有根实身。即于此界赡部洲中。随其所乐远离而住。一切诸天尚不能睹。何况其余众生能见。彼于涅槃多乐住故。于遍游行彼彼世界亲近供养佛菩萨中。及于修习菩提资粮诸圣道中。若放逸时诸佛菩萨数数觉悟。彼觉悟已。于所修行能不放逸。复次回向菩提声闻。或于学位即能弃舍求声闻愿。或无学位方能弃舍。由彼根性有差别故。所待众缘有差别故。如是若在无学位中。回向菩提由定愿力。数数资昔感现身因。令于长时生果相续。渐渐增胜。乃至成佛功能方尽。此报虽亲有漏因感。然由无漏定愿资助。名不思议变易生死。无漏定愿不思议故。若有学位回向菩提。或随烦恼感生势力。感彼生已。于最后生伏诸烦恼。起定愿力资后身因。如前道理乃至成佛。或回心已即伏烦恼。起定愿力资现身因。如前道理乃至成佛。诸用无漏定愿资助。非烦恼者。皆不思议变易身摄。若烦恼力所感异熟分段身摄。若说声闻是化所作。不须如是问答分别

经曰。复有无量菩萨摩诃萨。从诸佛土俱来集会。皆住大乘。游大乘法。于诸众生其心平等。离诸分别及不分别种种分别。摧诸魔怨。远离一切声闻独觉系念分别。广大法味喜乐所持。超五怖畏。一向趣入不退转位。息诸众生一切苦恼所逼迫地。而现在前。妙生菩萨。而为上首

论曰。所言菩萨摩诃萨者。谓诸萨埵求菩提故。此通三乘为简取大故。须复说摩诃萨言。又缘菩提萨埵为境故名菩萨。具足自利利他大愿。求大菩提利有情故。又萨埵者是勇猛义。精进勇猛求大菩提故名菩萨。此通诸位。今取地上诸大菩萨。是故复说摩诃萨言何故赞说菩萨功德。为舍众生轻慢心故。有作是言。赞声闻众久修梵行诸菩萨众应当敬礼。又令众生起净信故。菩萨尚有如是功德。何况如来。于此赞说菩萨德中。显诸菩萨有三大事名摩诃萨。一者数大。以无量故。二者德大。谓住大乘游大乘等。三者业大。谓息众生诸苦恼故。利乐有情是菩萨业。从诸佛土俱来集会者。谓从十方种种佛土。为听法故俱来集会。亦应有此索诃世界菩萨来集。而结集者但说他方菩萨来集。为欲对治懈怠憍慢不来集会求闻法故。如是菩萨从彼方来。自求闻法非他所引。一切皆具大威神力。尚从他界极远方来。何况其余而不来集。前声闻众不说来集。在此方故。今说他方俱来集会故。知亦有此方菩萨。但略不说。就德大中应知略说九种德大。一精进大。谓皆住大乘由精进力。安住大乘拔济有情令离生死。及自发趣无上菩提。二因大。谓游大乘法。即十地等。以闻思修等。渐次而游。三所缘大。谓于诸众生其心平等。即于一切有情得自他平等。以大慈等平等方便故。四时大。谓离诸分别及不分别种种分别。即于一切时犹如一念。平等而转。劫名分别。以于一切劫与非劫分别断故。以不分别劫与非劫故。能长时修行无厌。五无染大。谓摧诸魔怨以舍一切所摄受故。能伏魔怨。如说菩萨若于一切所摄受事。知不坚实心不贪求。即能摧伏一切魔怨。六作意大。谓远离一切声闻独觉系念分别。即是远分断除一切二乘作意。七任持大。谓广大法味喜乐所持。即用大乘法味喜乐为食。八清净大。谓超五怖畏。即三业清净出诸怖畏。无犯戒等诸恶趣等。怖畏因故。五怖畏者。一不活畏。二恶名畏。三死畏。四恶趣畏。五怯众畏。如是五畏证得清净意乐地时皆已远离。九证得大。谓一向趣入不退转位。即得一切智记别。地时一向不退。前七地中犹有加行功用运转。未得不退无功用道。其余诸地得无加行功用运转。一向趣入不退转地。以不退地无功用道一向趣入。是故说名一向趣入不退转地。就业大中。息诸众生一切苦恼所逼迫地。而现在前者。谓诸菩萨能息一切有情内外苦恼逼迫地位现前。此地中有大悲大慈。由此二种能息一切内病等苦。外贫等恼之所逼迫。此二多作有情利乐故。得此者名为业大。复次皆住大乘者。谓住初地证得遍满真法界时。初得真实大乘法故。名住大乘。游大乘法者。谓第二地修行菩萨三聚戒故。大乘行法即三聚戒。于诸众生其心平等者。谓第三地得诸胜定。发四无量平等利乐诸有情故。离诸分别等者。谓第四地得三十七菩提分法。离诸分别及不分别种种分别。诸分别者。即见所断分别我见。初地已离。不分别者。即修所断俱生我见。此地中离。即此二种相应诸法名种种分别。行解异故。虽前后离尽处。总说如第四定说离苦乐。如第三果离五下分。有义。此地第七识中俱生烦恼一切远离。有义。此地第六识中。俱生我见一切远离。非第七识。以七地来犹有微细烦恼现行。若无第七应无染依。应不似五。第七细惑若已远离。五六七地六识粗惑应不现行。即违瑜伽解深密说。又如二乘金刚喻定。第七识惑与六识中最细烦恼。一时俱断。云何此中先离第七微细烦恼。后离六识粗烦恼耶。是故四地得无我智灭意识中。俱生我见未离。第七微细烦恼。及六识中余修断惑。此说伏离非是永灭。至第十地金刚心时。方顿断灭。修断种故。摧诸魔怨者。谓第五地观四圣谛皆平等性。摧伏执取生死涅槃差别魔怨。远离一切声闻独觉系念分别者。谓第六地观十二支染净缘起。皆平等性。远离二乘厌患杂染欣乐清净系念分别。广大法味喜乐所持者。谓第七地证无相理。于空智中起有胜行。受大法乐。超五怖畏者。谓第八地一切烦恼不复现行。离五怖因名超五怖。五怖畏果初地已离。一向趣入不退转位者。谓第九地决定趣入第十菩萨众行圆满不退转位。息诸众生等者。谓第十地得大法身。起大悲云雨大法雨。息除一切众生苦恼所逼迫事。复次如是十句经文。十到彼岸十大愿等。亦应配释。以初地上一一地中。普摄一切诸地行故。妙生菩萨而为上首者。谓能发起圆满功德诸三摩地。名为妙生。菩萨得此三摩地故。立妙生号。以菩萨名多依法故。如慈氏等。于此众中妙生菩萨最第一故。名为上首。是故次下唯告妙生。发起所说此经略故。唯列一名。所余众会但举其数。结集法者意在略故

佛地经论卷第二佛地经论卷第三

        亲光菩萨等造

        大唐三藏法师玄奘奉　诏译

经曰。尔时世尊告妙生菩萨。妙生当知。有五种法摄大觉地。何等为五。所谓清净法界。大圆镜智。平等性智。妙观察智。成所作智

论曰。如是已说教起因缘分。次当显示圣教所说分。唯告妙生一菩萨者。由是最胜教所被故。何故不告声闻众耶。以诸菩萨专意悕求一切智故。闻如是法生胜解故。生胜解已能趣入故。既趣入已能正行故。正修行已速成办故。声闻不能求一切智。虽有能求闻如是法不生胜解。虽生胜解不能正行。虽能正行不速成办。故不告彼。若尔何故。说此经时预在众会。为显时众最高大故。化作此类。为令回向菩提声闻发趣大故。引令入众。或诸菩萨现作此名故不相违

略由四相安立佛地。一由数故。二由摄故。三由名故。四由决择差别义故。今于此中且说数摄及名差别

一由数者。谓有五种法。后说自相。其数自显。何故说数。为决定故。唯有五法不增不减。法者即是持自相义。非与可爱果异熟义。二由摄者。谓摄大觉地。大觉是佛。具三种身。一者自性。二者受用。三者变化。后当广说。地谓大觉所依所摄所行境界。安立自相所缘差别。以一切法为境界故。安立所缘言摄一切。安立自相唯摄自体合为一故。大觉地中无边功德。略有二种。一者有为。二者无为。无为功德净法界摄。净法界者。即是真如无为功德。皆是真如体相差别。有为功德。四智所摄。无漏位中智用强故。以智名显。一切种心心所有法。及彼品类。若就实义。一一智品具摄一切功德法门。若就粗相。妙观察智摄四念住。观察一切身等法故。平等性智摄四正断及四无量。以四正断虽用精进为其自性。而由如来平等性智所摄受故。无高下相。四无量者。平等行故。此智所摄。四如意足。以三摩地为自性故。观察智摄。任持一切陀罗尼门。三摩地门。下经说故。如是其余静虑解脱等持等至。陀罗尼门三摩地门。无诤愿智通无碍解。如来十八不共佛法力无畏等。多分摄在妙观察智。神境智通多分摄在成所作智。漏尽智通漏尽智力。若说漏尽相续中有四智所摄。若说彼缘漏尽涅槃。多分摄在大圆镜智平等性智。第七遍行行智力者。四智所摄。慧等诸根慧等诸力。多分摄在大圆镜智平等性智。觉支道支多分摄在平等性智。苦等十智真无漏者。多分摄在大圆镜智平等性智。无忘失法。多分摄在大圆镜智。永断一切习气相续。多分摄在清净法界大圆镜智。波罗蜜多。若是无漏若似有漏。多分摄在后二智中。诸相随好。多分摄在成所作智。其余佛法。如其所应随相应摄。如是四智具摄一切佛地。无漏心及心法。若俱有法。若所变现品类差别。清净法界摄真如上诸相功德。是故五法具摄一切佛地功德

三由名者。谓清净法界。广说乃至成所作智。清净法界者。谓离一切烦恼所知客尘障垢。一切有为无为等法无倒实性。一切圣法生长依因。一切如来真实自体。无始时来自性清净。具足种种过十方界极微尘数性相功德。无生无灭犹如虚空。遍一切法一切有情。平等共有。与一切法不一不异。非有非无。离一切相一切分别一切名言。皆不能得。唯是清净圣智所证。二空无我所显真如。为其自性。诸圣分证诸佛圆证。如是名为清净法界。大圆镜智者。谓离一切我我所执一切所取能取分别。所缘行相不可了知。不愚不忘。一切境界不分别知。境相差别一切时方无间无断。永离一切烦恼障垢有漏种子。一切清净无漏功德种子圆满。能现能生一切境界诸智影像。一切身土影像所依。任持一切佛地功德。穷未来际无有断尽。如是名为大圆镜智。平等性智者。谓观自他一切平等大慈大悲恒共相应。常无间断。建立佛地无住涅槃随诸有情所乐。示现受用身土种种影像。妙观察智不共所依。如是名为平等性智。妙观察智者。谓于一切境界差别。常观无碍摄藏一切陀罗尼门三摩地门诸妙定等。于大众会能现一切自在作用。断一切疑雨大法雨。如是名为妙观察智。成所作智者。谓能遍于一切世界。随所应化应熟有情。示现种种无量无数不可思议佛变化事。方便利乐一切有情常无间断。如是名为成所作智

复次建立如是五法。因故果故。果差别故。因者即是清净法界。是能生长圣法因故。果谓圣智缘彼生故。依止彼故。此圣智果差别有四。随起建立。谓缘法界任持一切。随闻法故。于诸有情证得自他平等性故。开示正法胜方便故。利他因故

复次建立如是五法。佛自体故。因故果故。佛自体者。清净真如为体相故。及缘此境无分别智为体相故。因谓无量常无间断。于诸有情平等性智。果谓饶益一切有情。二殊胜智观察可化不可化故。随其所宜成所作故。复次建立如是五法。谓于佛地果位差别。即智断果为佛地体。断果即是清净法界。于中一切障永断故。智有四种。大圆镜等。于佛果地诸心心法分位所现。诸功德中智最殊胜。以智为名。总摄一切有为德故

复次如是所说法门建立五法。总摄佛地一切佛法。总摄无为诸功德故。闻熏成熟任持一切佛地所摄诸功德故。于诸有情常现起佛利益安乐平等事故。陀罗尼门三摩地门。无边无量福智庄严所随逐故。能成一切利乐有情变化事故

复次如是所说四智。转何法得。摄大乘说。转识蕴得。何故转心而得心法。非得心法。四无漏心智相应故。假说名智故。论说言问正智。当言实有。当言假有。答当言俱有。此中智是实有。若智眷属诸心心法亦名为智。说之为假。故有二种。此中无漏心心法等智为主故。皆说名智。转识蕴依得四无漏智相应心。谓大圆镜心。广说乃至成所作心。转第八识得大圆镜智相应心。能持一切功德种子。能现能生一切身土智影像故。转第七识得平等性智相应心。远离二执自他差别。证得一切平等性故。转第六识得妙观察智相应心。能观一切皆无碍故。转五现识得成所作智相应心。能现成办外所作故。复有义者。转第六识得成所作。转五现识得妙观察。此不应尔。非次第故。说法除疑周遍观察非五用故。如是转去生死位中。四相应品心及心法。转得佛果四相应品心及心法。皆说名智

复次如是所说四智相应心品。为何所缘。大圆镜智相应心品。若一相说。唯缘真如无分别智。非后得智。所缘行相不可知故。若具相说。缘一切法。庄严论说。大圆镜智普于一切所知境界。不愚迷故。此经中说。如依圆镜众像影现。如是依止如来智镜。诸处境识众像影现。言诸处者。谓内六处。言诸境者。谓外六境。言诸识者。谓六种识。如是智上有十八界众像影现。故知此智缘一切法。由此镜智于一切时缘一切法。故说如来具一切智。若不尔者。余智不定知一切法。如来不应名一切智。如是镜智。内缘自体功德种子。外缘一切。若真若俗所知境界。现身土等一切影像。缘真义边名无分别智。缘俗义边名后得智。虽缘一切行相微细不可了知。如阿赖耶。虽缘三境。以微细故。亦言缘境。不可了知故。不应以不可了知证此镜智。唯缘真如无分别智。非后得智。诸心心法。体虽是一义用有多。随用差别。分为二智。亦无有过。要达真理方了事俗。故虽一心义说先后。或似后得名后得智。余亦如是。平等性智相应心品。有义。唯缘大圆镜智。如染污意。缘阿赖耶为境界故。有义。唯缘真如实际。缘平等性为境界故。如实义者。此智亦缘一切为境。普缘一切平等性故。庄严论说。平等性智缘一切有情。自他平等故。随诸有情胜解。示现佛影像故。此经中说。证得十相平等性故。此平等性通真及俗。故缘一切亦无过失。若不缘俗即不能随一切有情胜解示现诸佛影像。亦不应以染污末那类平等智。唯缘镜智。凡圣异故。违圣教故。余不类故。妙观察智相应心品。普观一切自相共相。皆无障碍故。缘一切所知境界。成所作智相应心品。有义。唯缘五种现境。庄严论说。如来五根一一皆于五境转故。如实义者。成所作智亦缘一切于一切境皆无障故。庄严论说。成所作智于一切界起种种化。无有数量不可思议。作诸有情一切义利。此经中说。成所作智起作三业诸变化事。决择众生八万四千心行差别。宣说对治作四记论。受领去来现在等义。若不普缘一切境界。无此功能。又说。佛心无障自在。一一皆能照一切境。但作意力。或缘一法。或缘一切。且说五根于五境转。不言唯尔故不成证。集量论说。诸心心法皆证自体。名为现量。若不尔者。如不曾见不应忆念。是故四智相应心品。一一亦能照知自体。云何不与世法相违。刀不自割指端不能触指端故。不见灯等能自照耶。云何得知灯等自照。现见无闇分明显现。若不自照应有闇障。应不现见。由此故知灯等自照。灯等非闇何须照耶。如瓶衣等。体虽非闇无灯等照边有闇障。不得现见。灯等照时除彼边闇。令得现见。说名为照。灯等亦尔。自体生时边闇障除。令现得见故名自照。诸心心法虽有胜劣皆能外缘。内证自体。犹如光明既能照他亦能自照。非如刀等诸法。法尔不可一类此就粗相诸心心法。各有相见二分而说。集量论中辩心心法皆有三分。一所取分。二能取分。三自证分。如是三分不一不异。第一所量。第二能量。第三量果。若细分别。要有四分。其义方成。三分如前。更有第四证自证分。初二是外。后二是内。初唯所知。余通二种。谓第二分唯知第一。或量非量或现或比。第三自证能证第二。及证第四。第四自证能证第三。第三第四皆现量摄。由此道理。虽是一体。多分合成。不即不离。内外并知无无穷过。是故经言

  众生心二性　　内外一切分
  所取能取缠　　见种种差别

此颂意言。众生心性二分合成。若内若外皆有所取能取缠绕。见有种种或量非量。或现或比多分差别。四智心品虽有多分。然皆无漏现量所摄。此义广如余处分别。义用分多非体有异。如一法上苦无常等。种种义别而体是一

复次如是所说四智相应心品。为有相分见分等耶。定有见分照所照境。有自证分通照见分证自证分。证自证分照自证分故。亦定有若无如是三分差别。应无所缘。应不名智。相分不定。有义。真实无漏心品无障碍故。亲照前境无逐心变似前境相。以无漏心说名无相无分别故。又说缘境不思议故。有义。真实无漏心品。亦有相分。诸心心法法尔似境显现名缘。非如钳等动作取物。非如灯等舒光照物。如明镜等现影照物。由似境现分明照了名无障碍。不执不计说名无相。亦无分别妙用难测名不思议。非不现影。若言无相则无相分。言无分别应无见分。都无相见应如虚空。或兔角等应不名智。无执计故。言无能取所取等相。非无似境缘照义用。若无漏心全无相分。诸佛不应现身土等种种影像。如是则违处处经论。转色蕴依不得色者。转四蕴依应无识等。则成大过。有义。无漏无分别智相应心品。无分别故。所缘真如不离体故。如照自体无别相分。若后得智相应心品有分别故。所缘境界。或离体故。如有漏心似境相现分明缘照。若无漏心缘离体境。无似彼相而得缘者。观所缘论不应说言五识上无似极微相故非所缘。如是境相同无漏心无漏种起虽有相似有漏法者然非有漏。如有漏心似无漏相非无漏故。且止广论。如是分别但就世俗言说道理。非就胜义。若就胜义离言绝虑。既无相见。不可言心及心法等。离诸戏论不可思议

复次如是所说四智相应心品。有几心法共相应耶。有二十一。谓五遍行五各别境。十一唯善。于一切处常遍行故。如来恒乐了所知境欲无减故。印境胜解常无减故。了曾受境念无减故。如来无有不定心故。恒决择故。极净信等常相应故。无染污故。无睡眠故。无恶作故。现证一切无寻伺故。有漏心品胜劣不定。所缘拘碍心法相应或多或少。无漏心品自在无碍。心法平等互不相障

复次如是所说四智相应心品。何位初得。何位现行无漏种性无始本有依异熟识生灭相续。发心已去由外熏习渐渐增长。大圆镜智相应心品。金刚喻定现在前时。转灭一切有漏种子异熟识等。尔时方得最初现行一切佛果无漏种子。圆满依附。尽未来际常无间断平等性智相应心品。菩萨初地初现观时最初现行。从此已去后后地中。修令增长清净圆满。无漏观等现在前时恒常现行。若有漏心现在前时。则便间断。如是展转乃至十地。最后心时自此已后尽未来际。常无间断。如有漏位阿赖耶识。恒与末那一识俱起。无漏位中大圆镜智。亦应常与平等性智一时而起故。平等智亦无间断。妙观察智相应心品亦在初地。初现观时最初现行。从此已后渐修增长。若有漏心正现前时。或无心时。则便间断。如是展转乃至佛果。若入灭定亦不现行。成所作智相应心品。有义。初地已上诸位皆得现行。堕法流故。如实义者。佛果方起。以十地中有异熟识所变五根非无漏故。能依五识亦非无漏。有漏五根发无漏识曾未见故。于佛果上此智亦不恒现在前。作意起故。数数间断

如是四智相应心品种子。本有无始法尔不从熏生。名本性住种性。发心已后外缘熏发渐渐增长。名习所成种性。初地已上随其所应乃得现起。数复熏习转增转胜。乃至证得金刚喻定。从此已后虽数现行不复熏习。更令增长功德圆满不可增故。持种净识既非无记不可熏故。前佛后佛功德多少成过失故。如是四智相应心品。一向是善。一向无漏道谛所摄。诸佛无有一切有漏种子法故。虽复现化作生死身业烦恼等似苦集谛。实是无漏道谛所摄。随世俗相名五十二十八蕴等。而实非是蕴处界摄。离戏论故。离诸相故。如是五法皆通假实。不待名言。此余根境皆实有故。若待名言。此余根境皆假有故。又净法界真如为体。是实有故。依真建立择灭等相。是假有故。诸心智等青黄色等。是实有故。不放逸等长短色等。是假有故。且止广论应释本文

四由决择差别义中。略有三分。一者决择五法差别。二者决择受用和合一味事智。三者总颂净法界相具诸功德。三身差别五法别中。如其次第一一决择

经曰。妙生当知。清净法界者。譬如虚空。虽遍诸色种种相中。而不可说有种种相。体唯一味。如是如来清净法界。虽复遍至种种相类所知境界。而不可说有种种相。体唯一味

论曰。次当显示净法界相。释难决择法界差别。谓有难言。若诸如来法界为性。法界则用。真如为体。真如即是诸法共相。诸法既有种种差别。法界随彼。云何无有种种差别。法界若有种种差别。云何清净。非颇胝迦种种依止共相应故无种种相。为释此难故说最初太虚空喻。譬如虚空虽遍诸色种种相中者。如世虚空虽遍一切有形碍色等不等类差别相中。品类差别故名种种。自体集在觉慧等上分明显现。故名为相。即是行相而不可说有种种相者。而此虚空不可宣说有诸形碍种种色相。由此虚空其性自尔不应说故名不可说。或不能说名不可说。谓此虚空其性如是。不可宣说有其种种能表色相。亦不可说有其种种所表色相。而见虚空有种种相。及可说有种种相者。此见空中种种色相。非见虚空。及假说有种种色相。如青黄等。或长短等。非实是有。非假说有则有实事。云何遍在一切色中。无种种相体唯一味者。非此虚空由与种种色相应故成种种相。不舍自性体唯有一无障碍味。无异相故。如是如来清净法界等者。如世虚空有体无体。虽遍一切形碍色中。而不随成形碍差别。亦不可说有诸色相。虽亦说有唯假非实。由此虚空不舍自相取他相故。如虽假说虚空虚空而虚空性实不可说。清净法界亦复如是。虽假说言真空真空。而真空性实不可说。由此虚空先所说因种种依止共相应故。如颇胝迦。法界应有种种别者。有不定过。现见虚空。虽与种种色相相应。而无诸色种种相故。如烟雾等共相应故。有时见空有种种相。由自虚妄分别力故。但见烟等有种种相。非见虚空。以虚空性不可见故。如是由自虚妄分别增益力故。但见色等有种种相。非净法界。净法界中虽无真实种种境界言说法教。而有种种境界法教差别相转。非由彼有种种相故。亦令法界有种种相。以净法界离名言故。一切名言皆用分别所起为境。然诸法教亦不唐捐。是证法界展转因故。如见字书解所说义。由此法教是诸如来大悲所流。能展转说离言说义。如以众彩彩画虚空甚为希有。若以言说说离言义。复过于彼。如说。海慧。譬如有人以种种色彩画无色无见无对无表虚空。如墙壁等。甚为希有。诸佛世尊证得甚深离言说法。能以言说为诸有情补特伽罗。宣说开示复难于彼。如是广说。又颇胝迦法界为性亦清净故。非同法喻。所立因义。随一不成或俱不成

经曰。又如虚空虽遍诸色不相舍离。而不为彼过所染污。如是如来清净法界。虽遍一切众生心性。由真实故不相舍离。而不为彼过所染污

论曰。复有难言。若净法界遍在一切所知境界。亦与贪等诸烦恼垢共相应故。云何不如所余有漏心心法品成不清净。为释此难故。说第二太虚空喻。又如虚空。虽遍诸色不相舍离者。无有别处。故名不相舍离。遍在内行不见出外故。既在内行不见出外。不可定言是一是异。若有别处。是则虚空应有形碍。应是无常。而不为色过所染污者。如太虚空虽遍一切形碍色内。而不为色过失所染。色过失者。谓是生长贪嗔等因。非青黄等种种异相。又于空中所有云雾黑影色等。能令太虚舍净相故。及能障碍净见生故。名色过失。又于心上所增境相名色过失。为顺他意故作前说。非太虚空为彼诸色过失所染。自性净故。如是如来清净法界虽遍一切众生心性由真实故不相舍离者。如佛自心真实清净。本性光洁本性净故。一切众生心性亦尔。本性真实本性清净。心本性者。即是真如。一切众生心平等性。如说由何说心平等。由空性故说心平等。如是广说。心本性者。即心法性遍在一切众生心性。是故说名心平等性。为辩如是心法性故。说由真实不相舍离。由是有情本净心性。虽本性净复由今时客尘障垢新远离故。安立如来其心清净。又诸有情心平等性。即是真实是圆成实自性摄故。由诸有情心平等性真实相故。表不舍离。诸众生心又是心性真实相故。表不舍离。一切有情心性而转。此意说言。由遍转故不相舍离。而不为彼过所染污者。本性清净故。过谓贪等。能令心相成过失故。成垢染故。虽为客尘分别所转。非彼体故。不可全舍。可令清净。依此密意说如是言。此心本性清净光洁心之法性。说名为心。非离心法性有异性净心。云何有情心有贪等。自分别力所任持故。心之颠倒未永断故。此由无明力所起故。此义意言。譬如虚空本性虽净。而为眩翳损肉眼故。颠倒相现似不清净。如是法界本性虽净。由自分别所起贪等众因缘力。无明眩翳损慧眼故。颠倒相现似不清净。若一切种清净慧眼恒不见秽。又净法界若无差别。一切种净则名一切如来法身。亦名如来真实体性。于一切时常无变故。由此法界一切有情心相续中平等有故。说如是言。一切有情是如来藏。一切有情皆有佛性。为引不定种性有情。令心决定趣大乘故。就有如来种性有情。说如是言。一切有情皆当作佛。如有说言。一切无常一切皆苦。如是皆说少分一切非全一切若不尔者。便违所说。五种种性诸佛功德。应当有尽。无所度故。则违所说。如来功德常无断尽。不应无益。常住世间本期度生求佛果故。此净法界虽遍一切平等皆有。而由自障力所持故。如世生盲不见日月。如有颂言

  众生罪不现　　如月于破器
  遍满诸世间　　由法光如日

由此道理。如先所说。亦与贪等诸烦恼垢共相应故。如余有漏心心法品。清净法界成不净者。有不定过。虚空虽与色垢相应。非不净故。心心法品虽与贪等烦恼相应。而用清净法界为性。非不净故。非同法喻。如说意乐不清净者。见心不净随彼亦说法界不净。由清净相不显现故。意乐净者。见与贪等垢相应心本性清净无垢秽故。法界常净。彼所立因如前不成。由是法界遍一切故。譬如虚空。非诸有情过所染污。此说法界遍一切者。所执法空普皆有故。不待成立

经曰。又如虚空含容一切身语意业。而此虚空无有起作。如是如来清净法界。含容一切智所变化利众生事。清净法界无有起作

论曰。复有难言。若诸如来清净法界真如为体。则无戏论亦无起作。云何得容利有情事因缘智生。若容智生则有起作。云何如来真如为相。为释此难故。说第三太虚空喻。又如虚空含容一切身语意业者。如太虚空。虽无作意而能容受有情三业。身语二业有形碍故。可须容受。意业云何。非无形质。有对碍故。须他容受。即以此事名为容受。谓彼生时不为障碍。有对碍物亦以生时无障碍故。说言虚空之所容受。此法亦尔。生时无障而得生故。亦得说言虚空容受。又有对物无对碍时。容受余物得往来故。依此法上假立虚空。意业亦尔。将欲灭时容受余物。令得生起。何为不得。依此法上假立虚空。若异此者实有虚空遍一切处。云何容受。若体实有不障碍故余法得生名容受者。一切无色实有体法皆无障碍。并能容受应名虚空。余处说言。唯色无故名虚空者。就世共知粗相而说。是故虚空容受三业亦无过失。而此虚空无有起作者。非此虚空如是分别。我容受此不容受彼。虽无作意而能容受。日月灯等所有光明亦复如是。虽无作意此彼分别。法尔生时能照诸色。如意宝珠亦复如是。虽无作意而能满足众生意愿。所余亦尔。且举虚空类显一切。如是如来清净法界含容一切智所变化利众生事者。谓诸如来清净法界任性而住。无有作意。安立一切利众生事。一切智者。圆镜智等。一切所变化者。身语意化。一切利众生事者。谓能成办一切有情胜利乐事。清净法界皆能含容。彼法生时为助因故。清净法界无有起作者。作意名起。能令其心舍余境界趣余缘故。心动名作。心虑动摇有所作故。谓净法界虽无作意。心虑动摇而能容受诸智变化利有情事。复次含容一切智所变化。利众生事者。谓净法界含容一切受用变化二身。所作利有情因无穷尽故。极广大故。无对碍故。虽无分别而增上力能生彼故。此总义言如虚空等容色生等作用转时。虽无有我我所作意戏论分别。而法尔力广作一切差别作用。如是如来住无漏界。虽无一切我我所等作意戏论种种分别。而先所修大愿力故。能起一切智所变化利众生事。如是如来第一难思安住法身。由先愿力所任持故。一切相好功德庄严。穷生死际劫量相续。虽无分别。而作一切智所变化利众生事。如来虽无如是分别。我于如是如是事业。当作不作。而本愿力一切能作。如先发愿。或入睡眠或入灭定。虽无作意随所要期觉悟出定。如海慧经作如是说。如诸苾刍要期钟声而入灭定。不闻钟声亦无分别。由要期力应时出定。如是广说

佛地经论卷第三佛地经论卷第四

        亲光菩萨等造

        大唐三藏法师玄奘奉　诏译

经曰。又如空中种种色相现生现灭。而此虚空无生无灭。如是如来净法界中。诸智变化利众生事。现生现灭。而净法界无生无灭

论曰。复有难言。若净法界遍在一切所知境界。不相舍离一向随转。是则法界应有生灭。若无生灭不应遍在所知境界不相舍离一向随转。为释此难故。说第四太虚空喻。又如空中种种色相现生现灭等者。此义意言。如太虚空遍在诸色。容受色相不相舍离一向随转。诸色虽复现生现灭。而虚空性无生无灭。如是如来清净法界遍一切境。含容一切智所变化利众生事。不相舍离一向随转。智等虽有现生现灭。而净法界无生无灭。就此密意。契经中说。曼殊室利不生不灭故名如来。乃至广说。就胜义谛。色等诸法亦无生灭。就世俗谛。施设生灭。是故言现。此意说言。就世俗相现有生灭。非胜义体实有生灭。净法界中诸智变化利众生事。亦复如是

经曰。又如空中种种色相现增现减。而此虚空无增无减。如是如来净法界中。显示如来甘露圣教有增有减。而净法界无增无减

论曰。复有难言。若净法界遍在一切不相舍离。如来圣教现见有增后当减灭。法界同彼应有增减。若尔法界应不清净。为释此难故。说第五太虚空喻。又如空中种种色相现增现减等者。如来圣教于诸外道一切世间邪劣教中。最为真实殊胜清净。犹如醍醐。亦如甘露。令得涅槃永不死故。如是圣教奉行证圣。得无学果。千载已前多分有故。说佛正法但经千载。非佛教法但住千岁。又声闻藏虽佛去世百年已后。即分多部。而菩萨藏千载已前。清净一味无有乖诤。千载已后乃兴空有二种异论。是故说言。如来正法但经千载。而净法界无增无减者。如来圣教就世俗理有增有减。非就胜义法界为性。无增减故。色等亦尔。法界为性无增无减。就胜义理犹如虚空。无增无减相。是故言现。谓就世俗识等变现似有增减。非就真性净法界中。色等诸法皆离戏论分别相故

经曰。又如空中十方色相无边无尽。是虚空界无边尽故。而此虚空无去无来无动无转。如是如来净法界中。建立十方一切众生利益安乐。种种作用无边无尽。清净法界无边尽故。而净法界无去无来无动无转

论曰。复有难言。若诸如来法界为体。如来施与一切有情利益安乐。或去或来。法界与彼不相离故。如所余法应有去来应有生等。若尔法界应不清净。法界若无去来等事。不应十方施诸有情利益安乐。为释此难故。说第六太虚空喻。又如空中十方色相无边无尽等者。如虚空界无边无尽。十方世界亦无边尽是故其中种种色相。亦无边尽。无一方边无诸方尽。成就时处。是故说名无边无尽。而此虚空无去无来无动无转者。以太虚空含容一切遍一切故。无作用故。如是如来净法界中。建立十方一切众生等者。利乐作用无边无尽。义如前说。清净法界无边尽故者。以净法界无边尽故。虽无行动。而增上力。能于十方无边世界无边有情利乐事转。而净法界无去无来等者。舍此就彼名去。舍彼就此名来。无动无转。初标后释。法界无者。无边际故。无形碍故。若有边际形碍诸法可说。异方去来动转非无边际形碍。法界如虚空等。得说去来动转作业。此总义言。清净法界是诸如来胜义自体。法界遍在一切有情相续中。有彼诸有情自善种子成熟力故。由净法界增上缘力。彼识生时如是作用变现。而转说名如来作诸众生利益安乐。除此作用。增上缘力更无如来法身能作有情利益安乐事用。如契经言。善男子。如来都无去来等事。而言如来去来等者。就受用身及变化身。无相违过

经曰。又如空中三千世界现坏现成。而虚空界无坏无成。如是如来净法界中。现无量相成等正觉。或复示现入大涅槃。而净法界非成等觉。非入寂灭

论曰。复有难言。若净法界离去来等。云何无有方所去来。而得正觉般涅槃等。若有去来还得前过。为释此难故。说第七太虚空喻。又如空中三千世界等者。此难不然。譬如世界现坏现成。而虚空界无成坏故。净法界中虽有诸佛现成正觉般涅槃等。而净法界真实无有成等正觉涅槃等事。若有此事。可为此故有去来等。如虚空中现诸世界灭坏生成。就世俗理非真实义。彼如太虚皆性空故。如是如来清净法界。现无量相成等正觉或复涅槃。亦由世俗非真实义。成正觉者。入涅槃者。皆无有故。缘生诸蕴非我性故。若净法界就真实义。有此二者应非真实。以真实法不舍自相取余相故。若许法界舍非正觉成等正觉。舍非涅槃得般涅槃。则非真实。若有意谓。即以此义名为真实等正觉者。曾无有时不等正觉般涅槃者。曾无有时不般涅槃。是故真实。若尔余事亦应如是。坏劫恒坏无时不坏。成劫恒成无时不成。瓶等无时不是瓶等。如是等事皆应真实。若尔不应修观行者。度炽火等遍满世界往余世界。应被其中火所烧等。获得增上胜解力者。于其地等应无自在转变作用。非得胜定自在力者。现等正觉非等正觉。现般涅槃非般涅槃。是故虽有先正觉位今涅槃位。而净真如不舍自相故。净法界非成等觉。非入涅槃。此中二种皆是增益为自相故。非真实有。作者作用。皆是遍计所执相故俱无所有。而言随觉一切法故名菩提者。此是出世无分别智成等正觉。此中亦以缘真如智二种分别。不现行故非等正觉非般涅槃。即依如是密意说言。天子当知。以一切法皆无生故。诸佛现生无得无证。乃至广说。遍计所执无所有故。生等分别亦无有故。由世俗理施设二故。由变化身示现二故。随顺所化有情意故。如来示现如是二事。且举二事类显一切

经曰。又如依空种种色相坏烂烧燥变异可得。而虚空界非彼所变。亦无劳弊。如是依止如来净界。众生界内种种学处身语意业毁犯可得。而净法界非彼变异。亦无劳弊

论曰。复有难言。若净法界遍在一切有情之类。云何有情得有毁犯。非法界中有诸毁犯。性清净故。制立学处亦应唐捐。以诸有情无毁犯故。若有毁犯应有劳弊。应同二乘非极清净。为释此难故。说第八太虚空喻。又如依空种种色相等者。此难不然。如虚空故。譬如依空诸草木等。种种色相坏等变异种种可得。而净虚空不为彼物之所变异。虽在其中而无变异。亦无劳弊。无有坏等苦所逼故。如是依止如来净界众生界内。虽有种种毁犯可得。而净法界无有变异。亦无劳弊。虽净界中现见有情自分别起身语意业二种毁犯。谓在家者害父母等。种种不善毁犯可得。诸出家者随其所应。亦有种种毁犯可得。及为遮止制立种种学处可得。此皆世俗有所违犯。而净法界非彼违犯之所变异。无异性故。亦无劳弊。无逼切故。若为苦逼不堪耐故。则有劳弊。如声闻等非净法界。不能堪耐一切苦逼。故无劳弊。犹如虚空。又如空中色等诸法。虽有坏等。但是世俗而非真实。如是如来净法界中。虽有毁犯制立学处。但假安立而非实有。所以者何。身等三业不善等性。皆由相应发起势力。假名建立。不由自性。非块石等。由发起力可实建立。为不善等身业亦尔。地等和合所成性故。语业亦如钟鼓声等。非不善等诸无表业。唯以不作为其性故。亦非实有。意业亦由相应势力立不善等。如余相应亦非实有。因既非实果亦应尔。故法界中若业若果。一切皆是分别所起。世俗识等变现而生。如变现相。如是建立皆非真实

经曰。又如依空大地大山光明水火帝释眷属。乃至日月。种种可得。而虚空界非彼诸相。如是依止如来净界。戒蕴定蕴慧蕴解脱解脱智见诸蕴可得。而净法界非彼诸相

论曰。复有难言。若净法界遍一切法。应无戒等无漏蕴相。不相离故。应如法界。亦非蕴性。为释此难故。说第九太虚空喻。又如依空大地大山光明水火等者。此难不然。如虚空故。譬如依空地等可得。非与地等共相应故。空成蕴性。如是依止如来净界。虽有戒等诸蕴可得。而净法界非戒等蕴。当知此中无漏净戒名为戒蕴。无漏定慧名定慧蕴。无学胜解名解脱蕴。无学正见名解脱智见蕴。前三是因后二是果。有义。一切皆是无学缘解脱慧名解脱智见。余慧名慧。有义。一切通学无学。学位分得。无学圆满。诸佛菩萨皆具五故。如是五蕴虽依法界。而净法界不同彼相。彼亦不失五蕴自相。此中亦应说五取蕴。戒等无漏同法界故。且略宣说净法界中。虽无戒等诸事功德。而有真理功德法门。彼增上缘生长一切有为功德。不同虚空法界真理功德法门。是无为故。非蕴所摄。依之生长一切功德。有为生灭是蕴所摄。无断尽故亦说名常。非永不灭生必归灭一向记故。蕴所摄故。非无为法。有缘虑等作用义故。以其胜故。且说五蕴法界实是一切三乘功德所依

经曰。又如空中种种因缘展转生起。三千大千无量世界周轮可得。而虚空界无所起作。如是如来净法界中具无量相。诸佛众会周轮可得。而净法界无所起作

论曰。复有难言。若一切佛法界为体。应无彼此受用差别。云何得有众会不同。若所受用有差别者。云何诸佛法界清净。为释此难故。说第十太虚空喻。又如空中种种因缘展转生起等者。此难不然。如虚空故。如虚空中。因缘生起。三千界等周匝风轮围绕可得。虚空虽无我所差别分别思虑。而能容受种种差别世界周轮。如是如来净法界中自业增上所起。种种众相圆满得一切智。灌顶菩萨同一集会周轮可得。别别因缘之所生起。非如一佛众会因缘。第二第三亦复如是。余契经中依此故。说诸佛净土种种可得。诸佛众会种种可得。而净法界无我我所受用差别。及以造作能取所取分别可得。此总义言。如来法身虽无差别戏论色像。而受用身及变化身。由本愿力自胜行力。生起种种众相圆满诸佛净土。诸佛众会差别可得。皆是净识如是变现。种种差别非真实有。如转轮王由宿愿力。亦为饶益诸有情故。造作胜行。生女宝等诸妙乐具种种差别。诸佛亦尔。为欲饶益诸有情故造作胜行。自业增上生起种种净国。众会受用法乐众具差别。但无分别与前有异

复次如是已说。法界诸相甚深。业用甚深。处所甚深。相甚深者。谓离十种不清净过。当知即是十清净相。不清净过有十种者。一差别过。二杂染过。三有行过。四有为过。五增减过。六行动过。七断常过。八劳弊过。九积聚过。十摄众过。十清净相者。谓无差别相。无杂染相。非有行相。非有为相。无增减相。无行动相。非断常相。无劳弊相。非积聚相。无我所相。如其次第业用甚深。当知即是变化等业。处所甚深当知即是无有行动众相圆满一切如来净土众会。于一切处皆以虚空为譬喻者。为显法界一切粗相同虚空故。如契经言。乃至所有施设譬喻。喻诸如来戒等功德。一切皆是谤诸如来。唯除一喻谓虚空喻。如来戒等无量功德同虚空故。乃至广说

经曰。复次妙生。大圆镜智者。如依圆镜众像影现。如是依止如来智镜。诸处境识众像影现。唯以圆镜为譬喻者。当知圆镜如来智镜平等平等。是故智镜名圆镜智

论曰。已建立断。当建立智。依此故言。复次妙生大圆镜等。应知。此中以喻显示大圆镜智。是能生现诸法影像平等因缘。谓诸如来第八净识。能现能生智等影像。如大圆镜能现世间一切影像。智相应故。假说名智。言诸处者。谓内六处。即是眼等。言诸境者。谓外六境。即是色等。此内六处外六境界。即十二处。缘此十二生三智品心及心法。识为主故总名诸识。即此诸识名众像影。种种行相差别现故。此后经言。大圆镜智于一切时依诸缘故。种种智影相貌生起。如是等文皆说。能为智影生因故名镜智。平等性智以缘生事圆镜智等为境界故。妙观察智以一切法自相共相为境界故。成所作智应知亦尔。如是三智相应心品。于内六处外六境界。一切所缘所取境上。变似一切自相共相。种种影像分明显现。如是影像皆因如来大圆镜智而得生起。分明显了故名为现。此唯如来智等所现。如来果位平等智等为自性故。智等生时如自所有行相差别皆能证知。唯有如来觉慧。分析说示其相。余无此能。大圆镜智说名能现。由此为缘生彼影像。犹如明镜现诸影故。又处境识三事各别。处谓六根。境谓六尘。识谓六识。即十八界众像影现。此众像影随其所应三智品现。观察智等尽所有性。如所有性皆能现故。如来镜智相应净识为缘。生此三智影像故名为现。亦唯如来智等所现。广说乃至唯有如来觉慧。分析说示其相。余如前说。又十八界皆在如来大圆镜智相应心品影像显现。以诸如来镜智生时。皆能照了一切境故。诸处境识犹如影像。在此智中分明显现。由此镜智摄受彼相。而生起故。镜智虽无所取能取一异分别。而有一切所知影现。如大圆镜。此智生时如是行相为自性故。如来虽无所取能取一异分别。而能现证自心所现。自相共相诸法影像。由证知故。能无颠倒说一切法自相共相。由此影像如来成就无忘失法。一切所知境界影像。于一切时镜智等上分明显现。无忘失故。若不尔者。云何如来名一切智。无镜智等不能恒时于一切法自相共相现证知故。若谓相续有堪能故名一切智。如有颂曰

  相续有堪能　　如火食一切
  如是一切智　　非顿知一切

此但虚言。他心智等取一事时。不取余事不知余故。非一切智。就其相续亦不能取知现在故。汝宗一念但知一分诸法共相。若尔如来应假名说为一切智。不可假说非一切智。为一切智即成真实一切智者。又以如来镜智为缘。余相续中世出世善诸处境识众像影现。以诸世间世出世善。若无镜智皆不得生。彼法生时皆由此力。亦能证知。此义意言。如来镜智增上缘力。一切世间世出世善。诸处境识皆得生起。如明镜中众像影现。虽诸有情各有因力。而由镜智为增上缘乃得生起。如虽有种若无地等芽等不生。如虽有质若无镜等众影不现。若尔世尊应同妄见。自在天等为世间因。立为世间一切果生平等因故。无此过失。以彼生时唯能为作增上缘故。非作者故。是无常故。于无量劫修集福智二种资粮。所生起故。一切众生善及善缘。由此得生。外道妄见自在天等。与诸世间为能作者。其性常住故不相似。若无实影圆镜中生云何为喻。有质有镜和合为缘。如是相现故得为喻。谓诸有情颠倒执着影像。熏习成熟力故。镜面为缘自识变异似面影现。由是世间起增上慢。谓我镜中见其面影。以无别影镜中生故。经但说言众像影现。不言生起。如是应知。一切境相皆是自识变异显现非别实有。以识胜故。但言唯识。非无心法。亦不说言唯有一识。以诸有情各有八识及心法故。一切色等虽各有种。皆是自识变异熏习识上。功能差别为性故。变现时还不离识。就世俗说别有心法。非真实义。以就胜义诸法皆无定别性故。乃至真如虽非识变。亦不离识。识实性故。识上二空无我共相所显示故。此唯识言。但遮愚夫横计一切心心法外定性色等遍计所执。不遣不离诸心心法色等诸法。依他起性圆成实性。非无有故。由平等故。此二平等。是故说言平等平等。世间圆镜如来智镜俱无分别。皆能现影无有差别。由是因缘名圆镜智

经曰。如大圆镜有乐福人悬高胜处无所动摇。诸有去来无量众生。于此观察自身得失。为欲存得舍诸失故。如是如来悬圆镜智处净法界无间断故。无所动摇。欲令无量无数众生观于染净。为欲取净舍诸染故

论曰。高胜处者所谓高幢。或余胜处。净法界者。无垢真如。处谓安处。或依或缘无间断故。无动摇者。由此镜智依缘法界穷生死际。恒常随逐相续无断故。无动摇。此义意言。大圆镜智永离一切分别动摇。一得已后尽未来际。相续无断。其余三智虽无妄计。而有无执作意分别。证得已后或行不行。非不动摇。有义。灭定平等性智亦不现行。论说灭定无第七故。又说亦灭一分恒行心心法故。若尔论说于三位中皆无第七。是则初地已上无漏现观行时。及如来地应无此智。即为大失。违经论故。然说无者意。说无有染污第七。非一切无。未得法空无我智来。法分别执常现依故。如未证得补特伽罗空无我智。彼执恒行。依此识故。决择分说阿赖耶识。定与末那一识俱转。若起意识定与二识一时俱转。若五识中随起一识。定与三识一时俱转。乃至一时若起五识。定与七识一时俱转故。知圣道灭定无学亦有。无染法分别执平等智俱第七识等行相细故。不违灭定。由此灭定是无漏道所引发故。体无漏故。与染污意我执相违。此一分灭非灭一切故平等智于佛果上。虽恒现行。而十地中证得已后。或起烦恼有漏心时。此智不起。有间断故。非不动摇。其余二智于佛果上。亦不常行故。非不动摇。何故安处大圆镜智。在净法界。为令无量无数众生观染净故。何故观彼为欲取净舍诸染故。染谓烦恼及业生相。舍谓伏断。由世间道及出世道。暂时毕竟伏断彼故。净谓诸善能令众生心清净故。取谓任持。安立长养成熟种子。随所愿求证解脱故。此中意说。一切如来昔菩萨位。为欲成办一切有情一切种相利乐事故。一切有情利益安乐意乐。常随依净法界。随所修集福智资粮回求相续。大圆镜智方便善巧勤修习故。证得此智依缘法界相续无动。虽无作意分别戏论。而相续转为增上缘。令诸有情随所求愿。安立长养成熟无量善根种子。得世间乐出世解脱。此由如来大圆镜智起。化生用为诸有情宣说法要。令知染净取净舍染。即是利乐有情根本

经曰。又如圆镜极善摩莹。鉴净无垢光明遍照。如是如来大圆镜智。于佛智上一切烦恼所知障垢。永出离故。极善摩莹为依止。定所摄持故。鉴净无垢作诸众生利乐事故。光明遍照

论曰。鉴谓自性极清净故。净谓差别离客尘故。言无垢者。总前二种周圆离垢极清净故。光者由鉴。明者由净。言遍照者。由无垢故。于佛智上等者。即烦恼障及所知障。俱名为垢。究竟断故名永出离。由有永出诸障垢义故。说镜智极善摩莹。又烦恼者。谓贪嗔等一切烦恼缠随眠位。若行不行皆有势力。障生圣道。障得涅槃。乱身心故名烦恼障。所知障者。于所知境不染无知障一切智。不障涅槃。虽有此障。见声闻等得涅槃故。即此二障亦名为垢碍。清净智令不生故。染净智故。由得对治客尘障垢。毕竟不生名永出离。由永离障大圆镜智恒时极净。是故说为极善摩莹。为依止定所摄持故者。是所依止故名依止。大圆镜智依此生故。依止即定名依止。定或智依。定名依止。定从此无间解脱道生。极清净故。此所依定。即是殊胜金刚喻定。由彼定力障永断故。此智为彼所依止。定力所摄持故名摄持。彼定无间此智生故。由彼定力最极清净。离诸分别无有分别。镜智生故。此智既为所依止。定所摄持故。鉴净无垢自体清净故。名为鉴。离烦恼障故名为净。离所知障故名无垢。作诸众生利乐事故。光明遍照者。此智为定所摄持故。亦能起作一切有情诸利乐事。由作此故光明遍照。自性清净鉴故名光。离烦恼障及所知障。如其次第名明遍照。此中意说。如大圆镜极善摩莹鉴净无垢。为令他见面之得失。为饶益事。是故说名光明遍照。大圆镜智自性清净。远离二障鉴净无垢。虽不可见而起受用及变化身。能生诸智成办众生诸饶益事。是故说名光明遍照

经曰。又如圆镜依缘本质。种种影像相貌生起。如是如来大圆镜智。于一切时依诸缘故。种种智影相貌生起

论曰。若圆镜智是诸有情一切智等影像生因。云何影像相有差别。云何此智体无差别。又一切时常能为因。何不恒时顿生。一切众生及自智等影像。释此难言。又如圆镜依缘本质种种影像相貌生起。非影异故镜体差别。亦非恒时顿生影像。待众缘故。如是镜智于一切时待众缘故。生智等影种种差别。非彼异故智成。青等种种体别。亦非恒时顿生一切众生及自圣智等影。待时待缘乃能生故。此中意说。大圆镜智相应净识有二种用。一因缘用。谓净识中具有一切能现能生身土境智净法种子。若遇外缘。即便变现身土境界种种影像。及能生起平等智等相应心品行相差别。二增上缘用。谓佛净识善根愿力所生起故。若诸众生自因缘具。尔时净识即便资助。令得无障生长成满。是故镜智体虽是一。能现能生诸法影像。待外缘故非顿现起

经曰。如圆镜上非一众多诸影像起。而圆镜上无诸影像。而此圆镜无动无作。如是如来圆镜智上。非一众多诸智影起。圆镜智上无诸智影。而此智镜无动无作

论曰。若诸智影于镜智上先已有体。云何镜智为缘而生。若先无体。云何能生诸智影像。而无动作。不见陶师无有动作。而能生起先无瓶等。释此难言。如圆镜上非一众多诸影像等。如大圆镜能起诸影。同类数多故名非一。异类无数故名众多。观待同类简一种故说言非一。观待异类显无数故说言众多。如是镜上虽先无影而起多影。而无思虑分别动作。镜智亦尔。虽先无有智等影像。而能生起智等种种诸法影像。观待同类说言非一。观待异类说言众多。虽生如是智等影像。而无思虑分别动作。此中意言。如大圆镜虽无分别。而能生起种种影像。镜智亦尔。虽无我执及我所执。所取能取作意分别。而能生起种种智等诸法影像

经曰。又如圆镜与众影像非合非离。不聚集故。现彼缘故。如是如来大圆镜智。与众智影非合非离。不聚集故。不散失故

论曰。若圆镜智与诸智等影像和合。云何不由彼差别故。此成差别。若不和合云何为因。不见种等与诸芽等果不和合。而能为因。非日光等与石灰等。不共和合而相显照。释此难言。又如圆镜与众影像非合离等。如世圆镜虽能为因起众影像。而不与彼影像和合。彼未生前由未有体不聚集故。非此与彼或俱不俱。可名和合。圆镜与影亦非别离。现彼缘故。即由此义非不和合。要由此有彼得有故。虽与影像为现生因。而非影像有差别故。镜成差别。大圆镜智亦复如是。虽能为因生智等影。而与智等非合非离。不聚集故。不散失故。言非合者。彼未生前由未有体。不聚集故。言非离者。要有镜智智等影生。无则不生。不散失故。离坏无有名为散失。与彼相违名不散失。摄生彼故或不忘失。所缘境相名不散失。由镜智中显现一切所知相故。三世智等及诸众生。若不遍知镜智不生。要知一切此智乃生。是故此智不忘一切所缘境相。名不散失。不散失故。所以非离。虽能为因起智等影。而不由彼有差别故此成差别。如大圆镜无差别转。此中意说。如世圆镜虽能为因起诸影像。而非合离差别所触。镜智亦尔。虽能为因起智等影。而非合离差别所触。种等虽能为芽等因。而亦合离俱不可说。光明细分亦非色等。共相和合以俱有故。令其识上似与色等和合相生。以世现见一切因果。虽非合离而能为因。是故无有因果。二相决定和合

佛地经论卷第四佛地经论卷第五

        亲光菩萨等造

        大唐三藏法师玄奘奉　诏译

经曰。又如圆镜周莹其面。于一切处为诸影像遍起依缘。如是如来大圆镜。智不断无量众行善莹。为诸智影遍起依缘。谓声闻乘诸智影像。独一觉乘诸智影像。无上大乘诸智影像。为欲令诸声闻乘人。依声闻乘而出离故。独一觉人依独觉乘而出离故。大乘之人依无上乘而出离故

论曰。云何一智于一切时。能生三乘一切智等诸法影像。释此难言。又如圆镜周莹面等。如世圆镜为遍于中现其面等一切影像。种种加行周莹其面前后两边。于一切处普能为缘现一切影。镜智亦尔。一切如来为菩萨时。虽有种性而为障覆。未能现起为遍于中生起三乘一切智等诸法影故。精勤修习不断无量众行善莹。金刚喻定现在前时。离一切障清净圆满。遍能生起三乘智等。一切影像不断。就方无分限故。无量就时无量时故。此言因位遍一切处。于无量时勤修众行。除障善莹大圆镜智。能生三乘智等影像。又即镜智遍处。恒时离诸垢秽。种种行德圆满。庄严极圆净故。一切处时能起诸影。如说殊胜金刚喻定断一切障。证得如来大圆镜智。种种功德圆满庄严于一切处。及无量时能起三乘一切影像。此中意说。各别善根成熟差别。胜道生时。大圆镜智或近或远。随其所应为作强缘。决定种性各依自乘。而得出离。不定种性或依大乘。或依余乘而得出离。言出离者。即是涅槃。诸三乘人用自种性以为因缘。如来镜智为增上缘。精勤方便修集资粮引生圣道。除烦恼障及所知障。随其所应各证涅槃。决定种性声闻独觉住无学位。乐寂灭故。发业润生诸烦恼障永灭除故。先业烦恼所感身心任运灭已。更不受生无所依故。一切有漏无漏有为诸行种子。皆随断灭。唯有转依无戏论相。离垢真如清净法界解脱身在。名无余依般涅槃界。常住安乐究竟寂灭。不堕众数不可思议。同诸如来。但无有为无漏功德所庄严故无有更起利益安乐有情事故。不同如来。不定种性声闻独觉住无学位。虽无烦恼乐菩提故。由定愿力留身相续修大乘行。乃至获得金刚喻定。一切障灭证佛三身。虽有有为无漏功德。而无有漏身心在故。证无余依大涅槃界。依谓三界有漏身心。若诸菩萨断二障尽得佛果时。即得说名证无余依大涅槃界。是故二乘先入有余依涅槃界。后入无余依涅槃界。菩萨初证如来地时。顿证二种大涅槃界。一切有漏身心尽故。名无余依。犹有变化似有漏相身心在故。名有余依。悲智无断所证得故。亦名无住大涅槃界。涅槃即是真如体上障永灭义。由无漏慧简择谛理。断诸杂染而证得故。亦名择灭。如是择灭于真如上假施设有。无别实物至究竟位说名涅槃。无所趣故。无臭秽故。离编织故。离稠林故。名为涅槃。声闻独觉有所知障习气未灭。云何证得究竟涅槃。所知障习是无知故。非染污故。障菩提果不障涅槃。非烦恼故。不能润生。若无愿力。回心趣大至无学位。尽其寿量必永寂灭

经曰。如圆镜中大影可得。所谓大地大山大树大宫舍影。而是圆镜不等彼量。如是如来圆镜智上。从极喜地乃至佛地智影可得。及与一切世出世法智影可得。而圆镜智非彼分量

论曰。若圆镜智能起智影。应同彼量差别可得。释此难言。如圆镜中大影可得。谓大地等如世圆镜。虽能为缘起地等影。而是圆镜不等彼量。一小镜中众多山等大影可得。一大镜中众多石等小影可得。虽有形碍而不同影大小数量。镜智亦尔。虽起诸地世出世间诸智影像无形碍故。而不同彼一切智影大小数量。由是因缘诸佛镜智名大智藏。世出世间智根本故。如说世尊成大智藏镜智。能生一切智故。应知此中以智名说一切功德。由是镜智相应净识。具足一切自利利他功德种子。能为因缘生自身中智等影像。为增上缘生他身中智等影像。由此镜智。能变现身生智说法。展转生他智等影故。或悲愿力熏修所成。任运为他智等善法增上缘故。令他身中智等善法易得生长。是故经言。一切众生所有善法。及殊胜果。皆是如来慈悲愿力增上所起

经曰。又如圆镜非处障质影像起缘。如是如来大圆镜智非恶友摄闻不正法。障碍众生智影起缘。彼非器故

论曰。若圆镜智为令三乘得出离故。生诸智影。又悲愿力熏修所成为增上缘。生世出世诸智影者。云何世间诸外道等正智不生。能生因缘常和合故。诸外道等应无颠倒。释此难言。又如圆镜非处障质影像缘等。如世圆镜虽能为缘现诸影像。而非处在壁障等质影像起缘。如来镜智亦复如是。虽能为缘生智影像。而非处在恶知识摄爱。乐听闻邪法障者。智影生缘以彼非是可加被器闻正法器。是故外道圣道不生常怀颠倒。善法种子被损伏故。恶法种子遇生缘故。一切众生无始时来。习善时少造恶时多。是故善法虽遇强缘亦难生长。恶法虽遇少小外缘则便炽盛

经曰。又如圆镜非处闇质影像起缘。如是如来大圆镜智。非处乐恶愚昧众生智影起缘。彼非器故

论曰。如外缘障智影不生。如是内缘宿习乐恶无明闇障智影不起。诸乐恶者。虽贪嗔等一切烦恼悉皆炽盛。而痴偏重。以不了知善恶因果胜劣事故。世间现有诸佛正法。利益安乐一切众生。三宝良田生长一切世出世间无量福聚。不欲听受不乐归依。而反听受无利无乐外道邪法。归依生长能感众苦。无量恶业种种邪神。岂非无明痴闇障力。是故障善无明最重。当勤修习智慧光明。无明重者非善器故

经曰。又如圆镜非处远质影像起缘。如是如来大圆镜智。非处不净感匮法业。不信众生智影起缘。彼非器故

论曰。如是内外二缘障力智影不生。一由先世感匮法业。令于多时不闻正法。谓于前生诽毁正法。由此业障经无量劫不闻佛法。即此不闻诸佛正法。是彼业果障。彼智影令不得生不闻正法。其体是无云何得名谤正法。果云何。能障可生智影。不即说彼不闻正法为果为障。然说由彼感匮法业所得。不能听受正法。不具根等愚钝身心为果为障。二由不信。谓无种性无涅槃法。不乐涅槃。无有出世圣道种子。于证真如有毕竟障。闻出世法都不信受。毕竟不得三乘涅槃。如是一切身心相续不清净故。非圣法器。暂时毕竟不生出世功德智影。如浊秽水不能发生月等影像。镜智亦尔。于彼不能生智影像

如是略说大圆镜智有九种相胜。所余智谓训词相。无分别相。障清净相。依止因缘生智影相。无有我所无摄受相。不忘一切所知境相。遍处恒时生智影相。能生一切智根本相。于非法器不能生相。此有三种非圣法器。一者亲近不善知识闻不正法。暂时有障非圣法器。二者烦恼痴障所障非圣法器。三者极重业障所障。及无出世圣道种子。久时毕竟非圣法器。如是三种总名第九于非法器不能生相

经曰。复次妙生平等性智者。由十种相圆满成就

论曰。平等性智由十种相圆满成就。应知即是十地修果。一一地中略说。各证一平等性。修习圆满成就佛地平等性智。是故说言。平等性智由十种相圆满成就。若广说者。一一地中各证无量平等法性。修习圆满成就佛地平等性智

经曰。证得诸相增上喜爱平等法性圆满成故

论曰。诸相者。谓诸大士相及诸随好相差别故。皆名为相。如是诸相远离遍计所执自性。说名平等故。契经言。诸大士相如来即说以为非相。是故说名诸大士相。增上者。谓富贵自在。色等诸蕴各别。皆非富贵自在。和合亦非富贵自在。即别性故。诸法合时不舍自性。离此无实补特伽罗。是故一切富贵自在。远离遍计所执自性。说名平等故。契经言。世尊我今解了。一切以无我故无贫无富。喜爱者。谓所有喜爱由遍计力。于顺彼法发生欢喜。于违彼法发生忧戚。遍计所执诸法无故。于彼一切遍计所执喜爱亦无。说名平等达解。如是所说诸相增上喜爱平等法性故。名证得初地。菩萨最初证得。后后地中渐渐方便修令增长。最后佛地圆满成就。从此已后更无增长。由此证得圆满成故。平等性智圆满成就应知。此中圆满成故。于第三处说第五转。一切应说由圆满成。义类相似言词便故作如是说

经曰。证得一切领受缘起平等法性圆满成故

论曰。缘起有二。谓内及外。内缘起者。谓无明等十二有支。外缘起者。谓种芽等一切外物。内者应以杂染清净二分行相顺逆观察。外者应以此有故彼有此生故彼生行相观察。谓种等有故种等生故。芽等得有芽等得生。此二缘起一切皆由因有故果有。因生故果生。无作用义是缘起义。空无我义。无补特伽罗义是缘起义。如是等义缘起自相。是所领受故名领受。或假有情能领受故。名为领受。缘起诸法是所领受。如是一切领受缘起。无作用故。空无我故。无补特伽罗故。远离遍计所执自性。说名平等达解。如是所说一切领受缘起平等法性故名证得。由此证得如前修习圆满成故。平等性智圆满成就。如是缘起平等法性。即一切法平等法性。如说梵志一切法性即是缘生缘起法性。悟解此故名为菩提。如佛所见。一切法性如此即是缘起法性。又契经言。不见少法离缘起性。此中缘起平等法性名缘起性。依此密意说如是言。若见缘起即见法性。若见法性即见诸佛。缘起实性即胜义法胜义佛故。平等法性于一切处。皆无差别故作是说

经曰。证得远离异相非相平等法性圆满成故

论曰。色等诸法变坏等相不相似故。名为异相。远离如是各别异相。即是共相。如是共相以何为相。非相为相。如契经言。一切法性唯有一相。所谓非相。非相即是平等法性。达解如是遍计所执。一切法性毕竟永无平等法性故名证得。由此证得如前修习圆满成故。平等性智圆满成就。复有义者。远离异相即无有相。远离非相即无无相。无有无无名平等性。余如前说

经曰。弘济大慈平等法性圆满成故

论曰。慈有三种。一有情缘。二者法缘。三者无缘。初发心位诸菩萨等。多分修习有情缘慈。多是有漏。以世俗有为境界故。修正行位诸菩萨等。多分修习法缘之慈。亦多有漏。大乘教法为境界故。得无生忍诸菩萨等。多分修习无缘之慈。虽有所缘缘法界故。譬如眼等异熟诸法无有分别。不作加行任运转故。说名无缘。平等性智相应大慈。或有义者。唯缘法界所缘分别永无有故。不缘有情及诸法故。名无缘慈。复有义者。亦缘诸法。如实义者。亦缘有情但无分别。平等行相了知一切假立。有情性平等故。缘生等法性平等故。无我真如性平等故。名平等智。此智相应就所缘境得具三慈。但无分别平等行故。说名无缘。如来地中平等性智相应大慈。众相成满恒常现行。如来既有无缘大慈。余二不说自然成就。如来由此三种慈故。平等救济一切有情。非但于彼少分与乐。普于一切有情诸法无我真如平等性转。恒常现行救度一切故名大慈。非如声闻及异生等。暂时少分与乐行转。不能救度一切有情。以胜一切声闻等故。救度一切诸有情故。长时积集福慧资粮所成满故。说名弘济。如是所说弘济大慈遍一切处。无差别转故名平等。即此平等说名法性。或即所说弘济大慈平等法性为所缘故。就境说名平等法性。由此大慈如前修习圆满成故。平等性智圆满成就

经曰。无待大悲平等法性圆满成故

论曰。声闻等悲不能拔济一切有情。唯缘欲界少分行相暂时而转。如来大悲普能拔济一切有情。通缘三界遍满行相恒时而转。言无待者。无所观待恒救不舍。谓无所待随其所应拔济三苦。所苦有情恒转不舍。犹如长者怜爱一子。于诸有情平等而转。以有情界无边际故。成熟有情时无暂废。成熟有情曾不过时。如来常与大悲相应。不可说言暂起暂转。如经言。善男子。不应说言诸佛世尊所有大悲。于诸有情暂起暂转。何以故恒常转故。诸佛世尊乃至大悲无根未立。终不证得无上菩提。如来证得大菩提已。恒作是念。我当安立一切有情诸善根本。若有未悟一切法者。我当开悟。如来如是于诸有情常起大悲。乃至广说。如契经说。如来昼夜恒于六时观察世间。云何今言大悲恒转。此说作用六时相续恒无间断故不相违。大慈大悲无嗔不害无痴善根。以为自性。与乐拔苦行相有异。俱有三种有情缘等。慈是无嗔悲是不害。慈缘无乐欲与其乐。悲缘有苦欲拔其苦。无待大悲无差别转故名平等。此即法性或缘平等法性为境。由此大悲如前修习圆满成故。平等性智圆满成就

经曰。随诸众生所乐。示现平等法性圆满成故

论曰。随诸有情乐见如来色身差别。如来示现如是色身。如来虽居无戏论位。由平等智增上力故。大圆镜智相应净识。现琉璃等微妙色身。令诸有情善根成熟。自心变似如是身根。谓自心外见如来身。如契经言。由诸如来慈善根力有所示现。令天人等自心变异见如来身。如金色等。又如经言。若所应化无量有情。宜见琉璃末尼宝色。如来即能无碍示现种种琉璃末尼宝色。令彼自心亦如是变。乃至广说。如是示现一切如来形相平等。如是平等即是法性。是故说名平等法性。谓诸如来随同所化有情乐见。色身形相即各示现。同处同时同类形相。令彼自心如是变现作利乐事。如诸有情阿赖耶识共相种熟各各变现世界等相。同处相似不相妨碍。此亦如是。如色身相余事亦尔。由此示现如前修习圆满成故。平等性智圆满成就

经曰。一切众生敬受所说。平等法性圆满成故

论曰。若有如是种类语业。能令有情善根成熟。闻生欢喜得净信乐。如来便现如是语业令彼得闻。如来虽无戏论分别由悲愿力如是示现。所化有情自胜解力如是变异。谓自心外闻佛音声。如来所出一切语言称机宜故。诸人天等皆无违逆故名敬受。若不称机则不示现故。说诸佛语不唐捐。虽有众生不顺佛语。此是化作或当有益。后必信受。就总为语故。言一切敬受所说。如是语言由前道理诸佛同现故名平等。如是平等即名法性。由此示现如前修习圆满成故。平等性智圆满成就

经曰。世间寂静皆同一味。平等法性圆满成故

论曰。有漏五蕴说名世间。念念对治二种坏故。即彼息灭名为寂静。由此于此而寂静故。即是圣道及以涅槃依他起性。世间寂静同归真如。圆成实性故名一味。又世间者。遍计所执此本性无说名寂静。如是寂静所显真如无差别故。名为一味。此即名为平等法性。由此一味如前修习圆满成故。平等性智圆满成就

经曰。世间诸法苦乐一味。平等法性圆满成故

论曰。世间诸法略有八种。一利二衰。三毁四誉。五称六讥。七苦八乐。得可意事名利。失可意事名衰。不现诽拨名毁。不现赞美名誉。现前赞美名称。现前诽拨名讥。逼恼身心名苦。适悦身心名乐。如是八种总有二品。四违名苦。四顺名乐。生欣戚故。或复此中略说。最后苦乐一对。圣者居中恒常一味。得利不高。遇衰不下。如是乃至乐而无爱苦而无恚。如契经言。圣处世间平等一味犹如虚空。凡愚在世计有差别。由彼远离遍计所执。世间八法于一切处皆同一味。即此说名平等法性。由此一味如前修习圆满成故。平等性智圆满成就

经曰。修殖无量功德。究竟平等法性圆满成故

论曰。功德即是菩提分等诸功德法。熏种长养成熟解脱说名修殖。平等性智虽无分别。由佛菩萨智增上力如如意珠。令异身中功德生长成熟解脱。言究竟者。能得三乘般涅槃故。既令解脱。令得世乐不说。自成如是智名平等法性。远离遍计所执性故。或诸菩萨修殖无量菩提分等殊胜功德。乃至究竟。即此名为平等法性。由此功德如前修习圆满成故。平等性智圆满成就

经曰。复次妙生妙观察智者

论曰。依十种因。应知。分别妙观察智十种因者。一建立因。二生起因。三欢喜因。四分别因。五受用因。六趣差别因。七界差别因。八雨大法雨因。九降伏怨敌因。十断一切疑因

经曰。譬如世界持众生界。如是如来妙观察智。任持一切陀罗尼门。三摩地门。无碍辩说诸佛妙法

论曰。此中显示建立因相。譬如世界持众生界者。如诸有情自心所变。下风轮等诸世界相。能持自心所变眼等诸有情界。如是如来妙观察智。能持一切陀罗尼门。广说乃至诸佛妙法。与彼相应及能引故。陀罗尼者。增上念慧能总任持无量佛法。令不忘失。于一法中持一切法。于一文中持一切文。于一义中持一切义。摄藏无量诸功德故名无尽藏。此陀罗尼略有四种。一法陀罗尼。二义陀罗尼。三咒陀罗尼。四能得菩萨忍陀罗尼。如瑜伽论广说其相。云何唯于一法等中。普能任持一切法等。谓佛菩萨增上念慧不思议力。自心相分一法相中。现一切法文义亦尔。又能示现无量无尽功德法门。见分自体亦具无边胜功能故。任持一切令不忘失。如是念慧不思议力。名陀罗尼。三摩地者。谓增上定即健行等诸三摩地。能胜一切世出世间诸三摩地。余不能胜故名健行。又佛菩萨健士所行故。名健行。唯第十地菩萨及佛得此定故。余三摩地随经所说应释其名。即陀罗尼及三摩地。俱说名门。如空无愿无相三门。以能通生无量同类异类德故。无碍辩说即四无碍。法义词辩。由此四种能为众生辩说妙法故名辩说。诸佛妙法即是如来力无畏等无量佛法一切之言一一应说。妙观察智转意识得作用宽广故。能任持一切功德。此智相应第六意识。普与一切功德相应。及能引发诸功德故说能任持

经曰。又如世界是诸众生。顿起一切种种无量相识因缘。如是如来妙观察智。能为顿起一切所知无碍妙智种种无量相识因缘

论曰。此中显示生起因相。妙观察智能作顿起一切所知相识因故。世界即是诸器世间。如器世间能为众生种种地上无量空中相识生因。如是如来妙观察智。一时顿于一切境界犹如虚空能了无碍。能为一切种种世间。无量出世所缘境界相识生因。此义意言。一切如来妙观察智。能顿了知一切境界。似所知境有众多相。如彩画色有种种相。见分智体能为如是相识生因。此能现彼说为生因。非亲生因。从种生故。此即缘因说名因缘。由见起相或体起用。虽无异体由不一故亦得为因。如从相分生见分等。此亦如是

经曰。又如世界种种可玩。园林池等之所庄严甚可爱乐。如是如来妙观察智种种可玩。波罗蜜多菩提分法十力无畏不共佛法之所庄严。甚可爱乐

论曰。此中显示欢喜因相。如器世间种种可玩。园林池等绮饰间列威光炽盛。令诸有情欢喜爱乐。如是如来妙观察智种种可玩波罗蜜多菩提分等。绮饰间列威光炽盛。令诸菩萨欢喜爱乐。波罗蜜多略有六种。谓布施等或开为十。更足方便善巧等四。或复开为八万四千。如经广说。若别分别其数无量。菩提分法略三十七。广亦无量。言十力者。谓处非处智力等。如来身中慧根所摄。及具知根。言无畏者。谓四无畏五根所摄。及具知根即信等五。不共佛法有十八种。如经广说。如是功德多分此智所摄。相应及能引发。是故一切庄严此智

经曰。又如世界洲渚日月四天王天三十三天。及夜摩天睹史多天乐变化天他化自在天梵身天等。妙饰间列。如是如来妙观察智。世及出世衰盛因果。声闻独觉菩萨圆证无余。观察妙饰间列

论曰。此中显示分别因相。如器世间无量洲等。妙饰间列不相杂乱。洲谓四大洲。则赡部洲等。渚谓八小渚。则遮末啰等。略举日月摄诸星宿。四天王天。谓妙高山第四层级四面各住。三十三天。谓此山顶四面各有八大天王帝释居中故有此数。夜摩天者。谓此天中随时受乐故名时分。睹史多天后身菩萨于中教化。多修喜足故名喜足。乐变化天。乐自变化作诸乐具。以自娱乐。他化自在。乐令他化作诸乐具。显己自在。梵身天者。离欲寂静故。名为梵。身者众也。等者等取此上诸天。如是如来妙观察智。普能观察世及出世衰盛因果。三乘圆证妙饰间列。不相杂乱。恶趣因果名世间衰。善趣因果名世间盛。又世间坏及世间成。如其次第名为衰盛。又损减名衰。增长名盛。二乘因果名出世衰。大乘因果名出世盛。又退名衰进名为盛。言圆证者。即是果位。前三乘名显其因位。又圆证者。唯说佛果。妙观察智观此诸法法相异故。智如其境。行相不杂分明显现。是故说名妙饰间列

佛地经论卷第五佛地经论卷第六

        亲光菩萨等造

        大唐三藏法师玄奘奉　诏译

经曰。又如世界为诸众生广大受用。如是如来妙观察智。示现一切诸佛众会雨大法雨。为令众生受大法乐

论曰。此中显示受用因相。如器世间随有情业增上力故。阿赖耶识共相种子。变生种种共相资具。为令有情广大受用。如是如来妙观察智。助平等智为增上缘。击发镜智相应净识。现受用身种种众会威德炽盛雨大法雨。为令地上诸大菩萨受大法乐。亦助如来成所作智为增上缘。击发镜智相应净识。现变化身种种众会威德炽盛雨正法雨。为令地前所化有情受用法乐

经曰。如世界中五趣可得。所谓地狱饿鬼傍生人趣天趣。如是如来观察智上。无边因果五趣差别具足显现

论曰。此中显示趣差别因相。如世界中随有情业增上力故。阿赖耶识不共相种。变生种种五趣因果差别可得。如是如来妙观察智。五趣因果为境界故。似其五趣因果二相差别显现。非生五趣诸阿素洛种类不定。或天或鬼。或复傍生故。不别说。五趣因者。谓中有身以与五趣为方便故。趣是所趣。中有能趣故。非趣摄。就生类别建立四生。是故中有亦生所摄。有义中有趣方便故。说在趣中。此言因者。业烦恼等。果即五趣

经曰。如世界中欲色无色诸界可得。如是如来观察智上。无边因果三界差别。具足显现

论曰。此中显示界差别因相。如世界中随有情业增上力故。阿赖耶识共不共相种子。变生三界因果差别可得。此中世界通情非情。谓有情世界及器世界。若不尔者。不应于中有无色界。以彼唯有定所生色。无业生色无方处故。于世界中。随其所应建立三界。谓器世界中但有欲色情非情界。有情界中具有三种。唯有情界以器世界通持有情及非情界。有情世界。唯能任持有情界故。如是如来妙观察智三界因果为境界故。似其三界因果二相差别显现。非生三界因果。同前二种分别。此中意说。妙观察智普能观察一切境故。遍似一切诸界趣生。烦恼业等所感。诸行成熟所摄心心法等因果相现。谓诸如来大圆镜智。增上所生妙观察智。虽无所取能取执着。远离一切烦恼所知二垢障故。观察一切因果等事。及能说故。如净圆镜现众影像。一切境相皆现其中。然无镜智无差别过。大圆镜智以于一切皆不愚故。虽能显现一切影像任运转故。而无分别。此智能现一切境相亦有分别。若无分别则不能观因果等事。及为众会说法断疑。此文定证。无漏心等亦有相分。如来智上五趣三界无边因果具足现故。有说。如来智明净故。一切境相虽现其中。而此境相非智所变。不清净故。但是众生心等所变诸法影像。此不应理。如是影像若是众生心等所变。云何在佛智上显现。不可他因生他心。相违正理故。如余心相。此亦应尔。然此境相如来无漏心所变现。如明镜中粪秽影像。虽似不净实非不净。心及心法缘境法尔若缘他境。非如钳灯。无动作故。但如明镜性本净故。变似境相而能缘虑。若诸境相非心上现。彼虽有力生心心所。如五根等不名所缘。如余处说。无分别智亦定尔耶。所缘真如不离智体不可定尔。后得俗智虽不离真有分别。故不证真体。但自变作真相而缘故。不可难。如诸异生心缘无漏心上所有无漏境相。虽似无漏实是有漏此亦应尔。唯识道理决定如是。心所变相虽相似有而实无体。若不尔者。应有色等。如心心法不成唯识。若彼实有但不离识。名唯识者心及心法亦不离彼色等诸相应。名唯境便成大过

经曰。如世界中苏迷卢等。大宝山王显现可得。如是如来观察智上。诸佛菩萨威神所引。广大甚深教法可得

论曰。此中显示雨大法雨因相。如器世间由诸众生业增上力起诸宝山。如是如来妙观察智。由诸有情感正法业增上力故。起佛菩萨威神所引深大教法。此教开示诸佛菩萨自在威神。亦能引发彼威神力。是故说名诸佛菩萨威神所引。此说如来妙观察智能发镜智相应识上教法影像。或自能现教法影像。由此为缘善根成熟。所化有情自心变现

经曰。如世界中广大甚深不可倾动大海可得。如是如来观察智上。一切天魔外道异论所不倾动。甚深法界教法可得

论曰。此中显示降伏怨敌因相。如器世间由诸众生业增上力起诸大海。不可倾动。如是如来妙观察智。由诸有情感正法业增上力故。起法界教不可倾动。法界则是空无相理。说法界理名法界教。诸外道等皆依诸见法界空理。对治诸见离诸见趣。是故空教彼不能测。不能倾动前威神教。威神高广故喻宝山。此法界教法界甚深故喻大海。妙观察智是能显照一切境因故。能起说一切法教。略说胜者。是故契经说。佛世尊名大智日。普能照了一切法故

经曰。又如世界大小轮山之所围绕。如是如来妙观察智不愚。一切自相共相之所围绕

论曰。此中显示断一切疑因相。如器世界一妙高山七大金山八大海水四大洲等。总于其外有小轮山周匝围绕。如是为一积数至千。复总于外有次轮山周匝围绕。名小千界。如是为一复数至千。更总于外有次轮山周匝围绕。名中千界。如是为一复数至千。总于其外有大轮山周匝围绕。有大风轮总持其下名一三千大千世界。如是名为大小轮山之所围绕。如是如来妙观察智。遍知一切自相共相。能断世间一切疑惑自共相愚。是疑惑因知自共相。无此愚故。自无疑惑能断他疑。大圆镜智永离二障不愚。一切自相共相能生此智。摄护此智故名围绕。镜智虽能知一切法自相共相。无分别故。不能为他说法断疑。此智能知有分别故。能为一切说法断疑。又此智体能知诸法自相共相。二种行相之所围绕。自相行相如小轮山。共相行相如大轮山。镜智能持如风持下。如来净智现量所摄。云何能知诸法共相。若共相境现量所知。云何二量依二相立。有义。二量在散心位依二相立。不说定位。若在定心缘一切相。皆现量摄。有义。定心唯缘自相。然由共相方便所引。缘诸共相。所显理者。就方便说名知共相。不如是者名知自相。由此道理。或说真如名空无我诸法共相。或说真如二空所显非是共相。如实义者。彼因明论立自共相。与此少异。彼说一切法上实义。皆名自相。以诸法上自相共相。各附己体不共他故。若分别心立一种类能诠所诠。通在诸法如缕贯花。名为共相。此要散心分别假立是比量境。一切定心离此分别。皆名现量。虽缘诸法若无常等。亦一一法各别有故。名为自相。真如虽是共相所显。以是诸法自实性故。自有相故。亦非共相。不可以其与一切法不一不异即名共相自相。亦与一切共相不一异故。是故彼论说诸法上所有实义。皆名自相。此经不尔故无相违

经曰。复次妙生成所作智者

论曰。成所作智。应知。成立如来化身。此复三种。一者身化。二者语化。三者意化。第一身化复有三种。一现神通化。二现受生化。三现业果化。第二语化亦有三种。一庆慰语化。二方便语化。三辩扬语化。第三意化复有四种。一决择意化。二造作意化。三发起意化。四受领意化。成所作智能起如是三业化用。此化三业即是化身。应知此中以用显体。非此三业即是智体。但是智上所现相分。成所作智增上缘力击发镜智相应净识。令现如是三业化用。自亦能现。当知四智一一能起一切作用。就强多分。说平等智起受用身。成所作智起变化身。妙观察智观察一切自相共相。陀罗尼门三摩地等。大圆镜智能现一切诸法影像。如一一根取一切境非无强用。此亦如是。此中经文定证。三业心心法等皆有变化。如来智上现此粗相心心法等一切功德。令诸下位能现了知。若不尔者。二乘异生云何能知。如来所有心心法等功德差别。云何如来久已成佛。复能现作具贪嗔等种种化身。余经亦说。化无量类皆令有心。又说化身亦名有心。亦名无心。有依他心无自依心故。谓化心等依实心现。但实心上相分似有缘虑等用。如镜中火无别自体。随众缘生。如余心等余处虽说无化心等以无实用。如实心等变化色等有实作用。如实色等故偏说有。由化心等粗相显现易了知故。乃至猿猴知如来心。若佛实心诸大菩萨亦不能了

经曰。如诸众生勤励身业。由是众生趣求种种殉利务农勤王等事。如是如来成所作智勤身化业。由是如来示现种种工巧等处。摧伏诸伎傲慢众生。以是善巧方便力故。引诸众生令入圣教成熟解脱

论曰。此中显示现神通化化身业相。令心勇悍故名勤励。于善性中兼取精进余但作意。由此发起勤励身业。就因为名。由此身业世间有情作三正事。等者等取其余杂事。成所作智精进相应起化身业。由此化业为菩萨时。示现种种陶师等类工巧等处。此是智上身业相现。为欲摧伏伎术傲慢故。现斯事善巧方便。即是悲慧平等运道先现神通。初令生信故名引生令入圣教。如现神通度迦叶等。次令调顺有所堪能故名成熟。引令长养诸善根故。后令解脱三界恶趣有性无性。如其次第故名解脱。由教化力。有种性者令生圣道解脱三界。无种性者。令修世善常生善趣。念彼善根为说正法。令脱三界。放光息苦安立善趣。又令彼生闻思修慧。次第三句。又令彼生顺解脱分顺决择分。及生圣道。次第三句。又令彼入见道修道及无学道。次第三句。如是等释应随相说。后亦如是

经曰。又如众生受用身业。由是众生受用种种色等境界。如是如来成所作智受身化业。由是如来往诸众生种种生处。示同类生而居尊位。由其示现同类生故。摄伏一切异类众生。以是善巧方便力故。引诸众生令入圣教成熟解脱

论曰。此中显示现受生化化身业相。世间有情于诸生处。诸根领纳色等境界故。名受用身。有运转故名身业。成所作智一切生处。同时现生受用境界。谓现化身于天人中一切生处。示同类生。居刹帝利婆罗门种。伏诸下类令得利乐。此亦智上身业相现。或击镜智。或自显现余例应尔

经曰。又如众生领受身业。由是众生领受所作善恶业果。如是如来成所作智领身化业。由是如来示现领受本事本生难修诸行。以是善巧方便力故。引诸众生令入圣教。成熟解脱

论曰。此中显示现业果化化身业相。身即是业故名身业。先业果故果说因名。或身领受先业果时。有运转用故名身业。由此身业领受先业爱非爱果。成所作智现似化身领受化业。由此业故示受一切。本事本生难修诸行。先世相应所有余事。名为本事。先世所受生类差别名为本生。如毗湿饭怛啰等一切本生事。依此本生。先所修行种种苦行。名难修行。或于今世依变化身。先修苦行后舍彼行。修处中行方得菩提。名难修行。谓诸众生计修苦行止恶起善方得菩提。为化彼故先示同彼。修诸苦行。为显非但持戒得净。要由定慧方得净故。现舍苦行修处中行方得菩提。有契经说。如来先世迦叶佛时作是骂言。何处沙门剃须发者。有大菩提无上菩提极难得故。由彼恶业今受如是难行苦果。此言亦是为止恶行现化所作。若不尔者。何有系属一生菩萨。已曾亲事无量如来殖诸善本。性忆宿命更起如是重语恶行。当知此言为欲化度。宜闻此言而得度者。令于佛所离此言故

经曰。又如众生庆慰语业。由是众生展转谈论递相庆慰。如是如来成所作智庆语化业。由是如来宣畅种种随所乐法。文义巧妙。小智众生初闻尚信。以是善巧方便力故。引诸众生令入圣教成熟解脱

论曰。此中显示庆慰语。化化语业相。庆慰即是喜悦差别语能生彼故名庆慰。闻此语言。展转发生大欢喜故。谓诸有情由发语心增上力故。各别识上语业相现为增上缘。令余识变似语业相。各谓闻他语言生喜。成所作智化作语业。应知亦尔。自现妙音令他心变。谓闻佛语生欢喜故。随所乐法者。随彼因力所应乐闻。人天三乘诸差别法。文巧妙者。字句显美令乐闻故。义巧妙者。理趣分明易解了故。小智众生初闻尚信者。谓佛言音具六十德。诸凡愚慧暂时得闻尚生信解。何况其余聪愍者。慧成所作智名庆慰者。能现化语宣说一切巧妙文义。生诸有情欢喜心故。亦能加被善现等辈。以佛言音宣说甚深难测量法。如是此智能加被他。一切论者。一切色类乃至虚空。亦能发起化语说法。当知此事不可思议

经曰。又如众生方便语业。由是众生展转指授务专所作。毁恶赞善更相召命。如是如来成所作智。所起方便语变化业。由是如来立正学处。毁诸放逸赞不放逸。又复建立随信行人随法行等。以是善巧方便力故。引诸众生令入圣教成熟解脱

论曰。此中显示方便语化化语业相。如诸世间方便语业更相教示。诸所应作不应作事。利益亲友。放逸众生加行起作故。名方便。如是如来由大悲故。为诸有情安立学处。令伏诸恶修世间善。安立圣道分位差别。令入正道出离三界。成所作智能发化语。成办斯事。谓息诸恶发起诸善是此语用

经曰。又如众生辩扬语业。由是众生展转开示所不了义。宣讽诸论。如是如来成所作智辩语化业。由是如来断诸众生无量疑惑。以是善巧方便力故。引诸众生令入圣教成熟解脱

论曰。此中显示辩扬语化化语业相。成所作智随诸众生意乐差别现化语业。说种种义断诸疑惑。谓发一音表一切义。令诸有情随类获益。如契经言。佛以一音演说诸法。众生随类各得开解。或有怖畏。或有欢喜。或生厌离。或复断疑。此是如来本愿所引不思议力所发化语。一音能断一切众疑。若作化身亦令众生一质异见利乐事成

经曰。又如众生决择意业。由是众生决择可作及不可作。如是如来成所作智。决意化业。由是如来决择众生八万四千心行差别。以是善巧方便力故。引诸众生令入圣教成熟解脱

论曰。此中显示决择意化化意业相。成所作智相应意业能起化故。名化意业。此能决择所化众生八万四千心行差别。或复此智相分中现变化意业似。能决择众生八万四千心行。令彼了知得胜义利。云何八万四千心行。谓诸有情八万四千诸垢尘劳心行差别。此能障碍八万四千波罗蜜多。陀罗尼门三摩地等。如贤劫经广说其相。所谓最初修习行法波罗蜜多。乃至最后分布佛体波罗蜜多。三百五十一一皆具六到彼岸。如是总有二千一百对治。贪嗔痴及等分有情心行八千四百。除四大种及六无义所生过失。十转合数八万四千。修习此故复得成就八万四千陀罗尼门三摩地等。此犹略说广则无量

经曰。又如众生造作意业。由是众生造作种种诸所起业。如是如来成所作智造意化业。由是如来观诸众生所行之行行与不行。若得若失为令取舍。造作对治。以是善巧方便力故。引诸众生令入圣教成熟解脱

论曰。此中显示造作意化化意业相。随所观察一切有情所行之行。若诸恶行不行有得。行即有失。若诸善行行即有得。不行有失。如是观察为欲令彼取得舍失。于德造作任持对治。于失造作远离对治。成所作智相应意业能起化故。名化意业。虽诸如来于一切事无有功用。而令众生心等变现似有造作。故名造作。或复此智相分中。现变化意业似。能观察一切有情诸行得失。令彼了知得胜义利

经曰。又如众生发起意业。由是众生发起诸业。如是如来成所作智发意化业。由是如来为欲宣说彼对治故。显彼所乐名句字身。以是善巧方便力故。引诸众生令入圣教成熟解脱

论曰。此中显示发起意化化意业相。成所作智相应意业。能发身语二种业故。就用说名发起意业。或此意业由智发起。是故说名发起意业。能起化故。或智相分现似彼故。此化意业为欲宣说彼对治者。为说有情诸行对治。此所说法名句字身以为自性。是故显示名句字身。如来随彼有情所乐说名身等。令起爱乐发生对治。是则如来成所作智相分中。现变化意业发名身等。宣说有情诸行对治。由此力故。令诸有情自心变似。佛所说法深生爱乐发起对治。是故说名发起意业

经曰。又如众生受领意业。由是众生受领苦乐。如是如来成所作智受意化业。由是如来于定不定反问置记为记别故随其所应受领去来现在等义。以是善巧方便力故。引诸众生令入圣教成熟解脱

论曰。此中显示受领意化化意业相。受相应思能动其心令受苦乐。是故说名受领意业。成所作智受相应思能起化故。名化意业成相分中现化意业。名化意业。于四记问为记别故。随其所应如实了知一切问已。领三世等无量法义如实了知。一一自体如实知已。随其所应一一记别无有颠倒。言四记者。一一向记。二分别记。三反问记。四默置记。一向记者如有问言。一切生者决定灭耶。佛法僧宝良福田耶。如是等问应一向记。此义决定。分别记者。如有问言。一切灭者定更生耶。佛法僧宝唯有一耶。如是等问应分别记。此义不定。反问记者。如有问言。菩萨十地为上为下。佛法僧宝为胜为劣。如是等问应反问记。汝望何问。默置记者。如有问言。实有性我为善为恶。石女儿色为黑为白。如是等问应默置记。不应记故。长戏论故

应知此中身语化业。或自身相应。或他身相应。或不相应意化业。唯自他相应。由此即释三种神变。谓神通教诫记说神变。此佛化业于一切种恒时随逐不可思议。作用数量国土差别不思议故。利有情用无休息转不思议故。一切如来三种化业。为欲成熟有情为先。说名第一方便善巧。是故契经说佛世尊名大智药。能除一切烦恼病故

经曰。尔时妙生菩萨摩诃萨白佛言。世尊。为独如来于净法界受用和合一味事智。而诸菩萨亦能如是。佛告妙生菩萨。亦能受用和合一味事智

论曰。今依受用和合一味事智为问。前辩佛地但说如来清净法界体唯一味。佛镜智等于中受用和合一味无动无作。妙生菩萨意疑此事。为唯如来亦通菩萨故作此问。或前但说有五种法摄大觉地。清净法界体唯一味。镜智依此缘此而生无分别故。亦唯一相。平等性智通缘真如离二分别。亦唯一相。其余二智为饶益他。亦依真如无异分别。亦唯一相。如是唯佛受用和合一味事智。应不通余。为欲审定故作此问。此中既言。于净法界受用和合一味事智证知于余无有受用和合一味智。能受用所应受用和合一味真如境界故名受用。共同一事故名为和。虽同一事或复离别。为显于中常不离别故。复言合所缘能缘。平等平等毕竟和合不离别故。味者坚实即所受用所缘法界真如一味。事谓事用。智者即是能受用智。正取镜智平等性智。兼取余二。多缘真故。或一味者。能受用智无分别故。事者是果。缘净法界而生起故。或能受用即是舍受。无苦无乐平等一类。故名一味。事者果也。即此相应圆镜智等。由彼力生故。名彼果。或是行舍无功用相。于一切处一味而转。能受用智说名事智。或智自能领受己体。故名受用。自他二种分别无故。说名一味。事者果也。从众因缘。远离二想恒时转故。菩萨亦能等者。此中意说。受用和合一味事智非独如来。若诸菩萨亦能如是。云何但言有五种法摄大觉地。此中意说。佛地唯是五法所摄。不说五法唯摄佛地。亦能摄诸菩萨地故

经曰。妙生菩萨复白佛言。何等菩萨受用和合一味事智。佛告妙生。证得无生法忍菩萨。由彼菩萨无生法中。得忍解时对治二想。由遣自他二种想故。得平等心。从此已上彼诸菩萨。自他异想不复现前。受用和合一味事智

论曰。为显示得大乘无生法忍菩萨。或住功用有加行道菩萨。未有受用和合一味事智故。复问言。何等菩萨受用和合一味事智。证得无生法忍菩萨。谓从初地已上菩萨。证得二空所显真如。观一切法遍计所执本性无生亦无有灭。本来寂静自性涅槃。受用和合一味事智。非如二乘见道现观但证生空所显真如。未证法空所显真理。未能现观诸法平等受用和合一味事智。地前菩萨亦未能证。未见真如。和合一味平等性智未现行故。有义初地已上菩萨复有三种。一初发心。谓在初地。已入见道正性离生。真无漏心创现行故。二已修行。谓上六地。已得修道。进修行故。三不退转。谓上三地。修道已满。离诸功用无加行道。任运现前一切烦恼毕竟不起。念念胜进无退转故。此中唯取八地已上。观一切法本来无生今亦不起。得上品忍一向清净。恒起无漏任运而转。由得此故说名证得无生法忍。如契经言。八地已上诸菩萨众。离法想故无我我所。观一切法非常无常无生无起。自他平等。乃至广说。由得任运二想对治。于一切处得平等心。从此已上离二想故。离诸功用及加行故。一向无漏极清净故。无分别智已得自在。任运转故。方得说名受用和合一味事智。初地菩萨虽已证得自他平等。而有功用加行作意。未清净故而未建立

经曰。妙生菩萨复白佛言。唯愿如来。广说譬喻。令诸菩萨悟甚深义。随所化缘广宣流布。令诸众生闻已疾悟无生法忍

论曰。妙生菩萨为令上义因譬喻门明了易见。诸菩萨等闻是法已。悟甚深义悟无生忍。故复请问

经曰。佛告妙生。譬如三十三天未入杂林终不能于若事若受无我我所和合受用。若入杂林。即无分别随意受用。由此杂林有如是德。能令诸天入此林者。天诸果报若事若受。无所思惟和合受用。如是菩萨若未证得无生法忍。终不能得平等之心平等之舍。乃与一切声闻独觉无有差别。有二想故。彼不能住受用和合一味事智。若已证得无生法忍。遣二想故得平等心。遂与声闻独觉差别。由平等心。而能住舍受用和合一味事智

论曰。三十三天有一杂林。诸天和合福力所感。令诸天众不在此林。宫殿等事业乐等受胜劣有异。有我我所差别受用。若在此林。若事若受都无胜劣。皆同上妙无我我所。和合受用能令平等。和合受用故名杂林。此由诸天各修平等和合福业增上力故。令彼诸天阿赖耶识变现此林。同处同时同一相状。由此杂林增上力故。令彼转识亦同变现。虽各受用而谓无别。如是地前菩萨二乘。未证二空所显真如无生法忍。有见道断差别执故。未离自他差别二想。未得无漏平等性智相应之心平等受舍。或复行舍。故不能住受用和合一味事智。有义七地已下菩萨。犹有功用有加行道。犹有微细烦恼现行。未清净故。未得任运无生法忍。妙观察智。相应平等。若心若舍。故不能住受用和合一味事智

经曰。复次妙生。譬如种种大小众流未入大海。各别所依异水少水。水有增减。随其水业所作各异。少分依持。水族生命。若入大海无别所依。水无差别。水无限量。水无增减。所作业一广大依持水族生命。如是菩萨若未证入如来清净法界大海。各别所依异智少智智有增减。随其智业所作各异。少分众生成熟善根之所依止。若已证入如来清净法界大海。无别所依。智无差别。智无限量。智无增减。受用和合一味事智。无量众生成熟善根之所依止

论曰。大众流者。谓殑伽等四种大河。小众流者。谓余小河。未入大海各别所依者。种种地方为所依故。异水者。清浊灰美水差别故少水者望大海故。水有增减者。少雨多雨时差别故。随其水业所作各异者。种种气味势力成熟有差别故。少分依持水族生命者。少数少量水族有情所依持故。若入大海无别所依等者。与前所说一切相违。应知。其相广大依持者。此依数广量大而说。如是菩萨未证如来法界大海者。未证诸佛清净法界各别所依者。别别如来为所依故。异智者。各别胜解所修成故。少智者。望佛智故。智有增减者。诸地相望有胜劣故。及定相望有胜劣故。随其智业所作各异者。诸菩萨定数量别故。所作各异。随诸菩萨胜解势力缘有情界。能有所作。过此不转。是故各异。少分众生等者。少数少量成熟善根所依止故。由诸菩萨增上力故。随分令他善根成熟。诸菩萨定望如来定。数量少故。化诸有情利乐亦少。若证如来法界大海者。已证诸佛清净法界无别所依者。清净真如为所依故。无漏界中不可建立诸佛有异。何况菩萨。智无差别者。圆镜智等皆相似故。无有自他分别异故。智无限量者。了达无边所知境故。智无增减者。等清净故。遍知境界无少多故。受用和合一味事智者。平等智等一切所作皆相似故。无量众生等者。若数若量皆无量故。福德智慧无尽资粮皆平等故。由得法身穷生死际。一切有情成熟善根所依止故

前后二喻有差别者有义前喻说诸菩萨未入已入。或欢喜地或不动地。后大海喻。说诸菩萨未入已入或不动地或如来地。有义二喻同说菩萨未得已得无生法忍。前说菩萨功德稠密喻如杂林。后说菩萨功德无尽喻如大海

佛地经论卷第六佛地经论卷第七

        亲光菩萨等造

        大唐三藏法师玄奘奉　诏译

经曰。尔时世尊而说颂曰

论曰。当说四颂总摄上义。略显佛地净法界相。如来地中一切有为无为功德。皆是清净法界摄持。皆是清净法界之相。所相能相俱名相故。于四颂中前三颂半别显其相。后半总结。别显相中。有义此中初半显示清净法界次半显示大圆镜智。次半显示平等性智。次半显示妙观察智。次半显示成所作智。次半显示四智所摄眷属功德。后半显示五法所成三身差别。复有义者。此中显示清净法界。有六种相。总摄一切佛地功德。谓自性相因相果相若作业相若相应相若差别相。如其次第初有一颂余各半颂

经曰。一切法真如　二障清净相

论曰。有义此显清净法界。谓一切法空无我性所显真如。永离二障本性清净。今复离染能为一切善法所依。是故说名清净法界。一切法者。谓世出世有漏无漏蕴界处等。真如即是诸法实性无颠倒性。与一切法不一不异。体唯一味。随相分多或说二种。谓生空无我法空无我。真如实非空无我性。离分别故。绝戏论故。但由修习空无我观。灭障真如我我所执而证得。故名空无我。或说三种。谓善不善无记。真如是此三法真实性故。或说四种。谓三界系不系。真如是此四法真实性故。或说五种。谓心真如广说乃至无为真如。亦是五法真实性故。或说六种。谓色真如广说乃至无为真如。五蕴无为真实性故。或说七种。一流转真如。谓一切行无始世来流转实性。二实相真如。谓一切法二空无我所显实性。三唯识真如。谓一切法唯识实性。四安立真如。谓有漏法苦谛实性。五邪行真如谓业烦恼集谛实性。六清净真如。谓善无为灭谛实性。七正行真如。谓诸有为无漏善法道谛实性。或说八种。谓不生不灭。不断不常。不一不异。不来不去。八遣相门所显真如。或说九种。谓九品道除九品障所显真如。或说十种。谓于十地除十无明所显真如。即十法界。如摄大乘广辩名相。如是增数乃至穷尽。一切法门皆是真如差别之相。而真如体非一非多。分别言说皆不能辩。由离一切虚妄颠倒。假名真如。能为一切善法所依。假名法界。离损减谤假名实有。离增益谤假名空无。分析推求诸法虚假。极至于此更不可度。唯此是真假名实际。是无分别最胜圣智所证境界。假名胜义。如是广说。言二障者。一烦恼障。二所知障。恼乱身心令不寂静。名烦恼障。覆所知境无颠倒性。令不显现。名所知障。烦恼障者。谓执实我萨迦耶见以为上首。百二十八根本烦恼。及随烦恼。若所发业若所得果。皆摄在中。皆以烦恼为根本故。所知障者。谓执遍计所执诸法萨迦耶见以为上首。所有无明法爱恚等诸心心法。及所发业并所得果。皆摄在中。皆以法执及无明等为根本故。有义法执及无明等。遍在一切善恶无记。有漏心品及与二乘无漏心品。皆不了达法无我故。皆似相分见分起故。有义唯在不善无记有漏心品。瑜伽师地。说诸无明但有二种。一者不善。二者无记。复有二种。一者染污。二不染污。不言有善。不可非善善心相应。性相违故。又善心品必与无痴善根相应。痴即无明不可一心痴无痴并如贪无贪嗔无嗔等。不相应故。不可法执不与痴俱。若无无明无倒执故。如执有我定无明俱。此亦应尔。又诸善心性无迷执。皆信等俱顺无我解。与二空观为前方便。不可法执导法空观。我执未曾见此事故。是故有漏无漏善心。决定不与二执无明爱等相应。违教理故。一切异熟无记心品亦无法执及无明等。分别力劣不能执故。若有倒执成法我见。有无明等阿赖耶识。不应唯与五法相应。见无明等慧等摄故。又若此识有法执者。无所熏故应念念失。不须对治则成大过。烦恼障中无此事故。又法空观初现前时。此识应断。障治相违不俱行故。若尔所余有漏种子应无所依。所修功德应无熏习。无所熏故。不可说言熏习镜智。相应净识非无记故。犹未得故。阿赖耶识既无法执。余转识中异熟果者。亦应如是性类同故。于五识中亦无法执。无有猛利分别用故。不推求故。摄大乘说。能遍计心唯是意识。故知五识不缘遍计所执自性。如无分别无推求见。不能计我。故亦不能计度诸法。然由意识计我计法起爱恚等。引五识中非见所摄爱恚等起。虽无有见而有爱恚无明等法二障所摄。是故二执分别推求。唯在第六第七意识。若爱恚等非见所摄。不推求者亦在五识。诸我执等烦恼障体。唯在不善有覆无记二心中有。若法执等所知障体。亦在无覆无记心中。二乘无学亦现行故。无学位中无有不善有覆无记。此就二乘名为无覆。若望菩萨是染污故。亦名有覆。故所知障亦名无覆。亦名有覆。一体二名所望别故。烦恼障中有所知障。是所依故。必执有法而计我故。体虽无二而用有别。如一识体取境用多。由此熏生一种子体亦有多用。起时虽俱而渐次断。圣道势力有分齐故。若所知障就二乘说无覆无记。四无记中何无记摄。异熟生摄。以从异熟识生起故。若尔何者非异熟生。如增上缘余所不摄皆此摄故。威仪等心不坚执故。非普遍故。无二障体。若善无覆无记心中无法执者。云何不能了达法空。亦无我执云何不能了达生空。此既由与第七识中我执俱故。不达生空。亦应由与第七识中法执俱故。不达法空。既似相分见分而起。云何不名法执所摄。诸佛菩萨无漏智等亦有二分。云何非执。是故缘生相分见分依他起摄。若于此上妄计心外。或定性有方名为执。故所知障在第七者。遍与六识三性心俱。非相应品且止广诤。应释本文。清净相者。谓此真如本性清净。二障所覆。如净虚空烟云等障相似不净。得出世间证真如道渐除二障所有种子。犹如大风吹烟云等。金刚喻定现在前时。灭离一切障种子尽。得净法界究竟转依。名清净相。如是已显前五法中清净法界。有义此显自性一分法界净相。即六相中自性一分文同前释

经曰。法智彼所缘　自在无尽相

论曰。有义此显大圆镜智法者。即是依他起性缘法镜智名为法智。大圆镜智亦缘世俗依他起性。现彼影故。不迷彼故。彼所缘者。彼谓真如非彼法智。虽复隔句义势相应。故无有过。法智用彼为所缘故。名彼所缘。非谓法智是彼所缘。大圆镜智亦缘胜义圆成实性。穷生死际内证彼故。此说镜智缘一切法自相共相。依他起性圆成实性俱为境故。遍计所执但是凡愚妄心所计非圣智境。故不说缘。如论中说遍计所执唯凡智境。圆成实性唯圣智境。依他起性亦凡智境。亦圣智境。遍计所执以无体故。非圣所证。若尔圣智不知一切。彼既是无智何所知。若知为有则成颠倒。若知为无则非遍计所执。自性心所现无依他起摄。真如理无圆成实摄。是故圣智虽知有无而不缘彼。遍计所执自性为境。言自在者。大圆镜智六到彼岸所修成故。具十自在妙用无碍。无尽相者。穷生死际。无间无断相续常故。相谓所相。或复能相。表自体故。如是总显前五法中大圆镜智。有义此显自性一分。佛果四智即六相中自性一分。有为功德法者即是大圆镜智。由对治力转去一切粗重所依阿赖耶识。转得清净依他起性。远离一切心虑分别。所缘能缘平等平等不可宣说。缘生法性不增不减。内证行相能现一切诸法影像。于一切境普能照了无分别故。总说名法智者。即是平等性智。由对治力转去执着众生及法第七末那。转得清净依他起性缘镜智等及净法界平等平等。内证行相故名为智。彼所缘者。即余二智。由对治力转去世间分别六识。转得清净依他起性。或出世间。或世出世。彼后所得缘上真如及法智等。依他起性以为境界。无执分别似所缘现。分别自内所证能证。用彼上说真如法智。为所缘故名彼所缘。如是四智妙用无碍。故名自在。穷生死际常用不息。故名无尽。大圆镜智平等性智。常无间断故名无尽。妙观察智成所作智。虽有间断。而暂作意即能现前。数起无穷亦名无尽。相谓体相皆从缘生。说名清净依他起性。皆无颠倒说名清净。圆成实性皆有内证。照境作用似境显现。说名为智。如是等义能表自体。故名为相

经曰。普遍真如智　修习证圆满

论曰。有义此显平等性智。谓初地中初现观时。得此平等无分别智。观真如等一切平等。于后诸地渐次修习转胜转净。乃至佛地证得圆满。究竟清净证法界等。一切理事皆悉平等。如是显示前五法中平等性智。有义此显六中因相。谓初地中无分别智。观初法界见道三心断见道断百一十二根本烦恼。及随烦恼。并灭见断不染无明分别法执最粗一分。显初法界智种增长。从此已后于一切地。修道位中无分别智。观余法界如如。于彼一切法门。闻思修等加行智等方便等位渐次修习。如是如是随其所应。渐伏修断十六烦恼。及随烦恼。并随所应渐灭修断不染无明俱生法执。所余诸分。显余法界智种增长。由此为因乃至佛地。证得法界四智圆满

经曰。安立众生二　诸种无尽果

论曰。有义此显妙观察智。谓此妙智能为众生说妙法等。安立众生利益安乐。故名为二。即此二种有多品类。故名诸种。如是二事穷生死际。常作不绝。故言无尽。此即名果。是智果故。如是显示前五法中妙观察智。有义此显六中果相。谓净法界及四妙智。皆能安立一切众生。利益安乐。令修善因。名为利益。令得乐果名为安乐。又令离恶名为利益。令其摄善名为安乐。又拔其苦名为利益。施与其乐名为安乐。此世他世世出世等。应知亦尔。品类众多故名诸种。穷未来际故名无尽。如是二事诸种无尽。是净法界及四智果。由此起故

经曰。身语及心化　善巧方便业

论曰。有义此显成所作智。谓智能起身语心化。称顺机宜故名善巧。加行不绝故名方便。此即名业。或复此智善巧方便。能起身语心三化业。如是显示前五法中成所作智。有义此显六中业相。谓净法界及四妙智。能起身语心三化业。及与善巧并方便业。成所作智起身语心三种化业。妙观察智起善巧业。观机宜等极巧便故。其余二智及净法界起方便业。以能任运与一切业为方便故。身化三种。一自身相应。谓化自身为轮王等种种形类。及现种种诸本生事。二他身相应。谓化魔王为佛身等。变舍利子为天女等。寄他身上示现种种变化形类。三非身相应。谓现大地为七宝等。或现无量佛化身等。或放光明照无边界。如是等类。离自他身别现化作。情非情色种种形类。动地放光风香等事。皆为利乐诸有情故。一切皆名佛化身业。如是语化亦有三种。一自身相应。谓佛自身化现梵音。遍告无边诸世界等。种种语业。二他身相应。谓令声闻大弟子等。以佛梵音宣说大乘甚深法等。是故声闻诸菩萨等说。非已分甚深妙法。皆是如来变化所作。非彼自力。三非身相应。谓化山海草木等类。乃至虚空。亦出音声说大法等。如是皆名变化语业。心化唯二。一自身相应。谓自心上化现种种。心及心法影像差别。二他身相应。谓令他心亦现种种。心及心法影像差别。此并相分似见分现。有义定力能令自心解非分法。名化自心。加被有情令愚昧者解深细法。令失念者得正忆念。名化他心。然心无化。无形质故。如论说言。心无形故不可变化。又说化身无心心法。此就二乘及诸异生定力而说。彼定力劣不能化现无形质法。诸佛菩萨不思议定。皆能化现。若不尔者。云何如来现贪嗔等。云何声闻及傍生等知如来心。云何经说化无量类皆令有心。云何上说诸化意业。云何经说有依他心。但诸化色同实色用。化根及心但有相现。不同实用。又就下类故作是说。若尔云何不化非情令心相现。非情已是心等相分。云何复令有心相现。若心相现则名有情。非非情摄。是故化心但说二种。如前已说。妙观察智能观自证陀罗尼门三摩地等。能观有情根欲性等。说妙法药名善巧业。其余二智及净法界。与诸功德为所依止。能起种种利有情事。名方便业

经曰。定及总持门　无边二成就

论曰。有义此显四智所摄眷属功德。有义此显六种相中相应之相。定门即是八万四千三摩地门。总持门者。八万四千陀罗尼门。如是二种通生一切有为功德。通显一切无为功德。通引一切神力作用利众生事。故名为门。无边二者。福德智慧二种庄严。于中差别有无量种。八万四千福德智慧。或无量劫修所成故。说名无边。前五波罗蜜多。名为福德。后五波罗蜜多名为智慧。或随所应自性眷属一一具二。如是二门二种庄严。四智品中一一具足。恒共相应。亦复依止清净法界。与净法界不相舍离。故名成就

经曰。自性法受用　变化差别转

论曰。有义此显五法所成。三身差别。有义此显六种相中差别之相。虽诸如来所依清净法界体性无有差别。而有三身种种相异转变不同。故名差别。自性法者。即是如来初自性身体常不变。故名自性。力无畏等诸功德法所依止故。亦名法身。受用即是次受用身。能令自他受用种种大法乐故。变化即是后变化身。为欲利益安乐众生。示现种种变化事故。体义依义众德聚义。总名为身。如是略释三身名义

又法身者。究竟转依真如为相。一切佛法平等所依。能起一切自在作用。一切白法增上所显。一切如来平等自性。微妙难测。灭诸分别绝诸戏论。故契经言。诸佛法身不应寻思。非寻思境。超过一切寻思戏论。受用身者。一切功德圆满为相。一切佛法共所集成。能起一切自在作用。一切白法增上所起。一切如来。各别自体微妙难测。居纯净土任运湛然。尽未来际自受法乐。现种种形说种种法。令大菩萨亦受法乐。变化身者。一切神变圆满为相。一切化用共所集成。示现一切自在作用。一切白法增上所引。一切如来各别化用微妙难测。居净秽土。现种种形说种种法。成熟下位菩萨二乘及异生众。令入大地。出离三界脱诸恶趣。如是略释三身相用

又前五法摄三身者。有义前二摄自性身。中间二种摄受用身。成所作智摄变化身。经说真如是法身故。论说转去阿赖耶识得自性身。大圆镜智转第八得。故知前二摄自性身。此经中说。成所作智起诸化业。庄严论说。成所作智。于一切界发起种种无量难思诸变化事。故知后一摄变化身。平等性智如余论说。能于净土随诸菩萨所乐。示现种种佛身。妙观察智亦如论说。于大集会能现一切自在作用说法断疑。又说转去诸转识故得受用身。故知中二摄受用身。又佛三身皆十义中智殊胜摄。故知三身皆得有智。有义初一摄自性身。四智自性相应共有。及为地上菩萨所现。一分细相摄受用身。若为地前诸菩萨等所现。一分粗相化用摄变化身。诸经皆说清净真如为法身故。赞佛论说。如来法身无生灭故。庄严论说。佛自性身本性常故。能断金刚般若论说。受持演说彼经功德。于佛法身为证得因。于余二身为生因故。诸经论说。究竟转依以为法身。转依即是清净真如。非对治道。故知法身唯净法界真如为性。庄严论说。大圆镜智是受用佛。摄大乘说。转诸转识得受用身。然说转去阿赖耶识得法身者。此说转去第八识中二障种子。显得清净转依法身。非说镜智。以说镜智是受用故。又受用身略有二种。一自受用。三无数劫修所成故。二他受用。为诸菩萨受法乐故。是故四智相应共有。及一分化为受用身。经论皆说。化身为化地前众生现种种相。既是地前众生境界。故知非是真实功德。但是化用。经论唯说成所作智能起化业非即化身。虽三种身智殊胜摄。法身是智所依证故。化身是智所起用故。似智现故假说为智。亦无有过。如是三身受用变化既有生灭。云何经说诸佛身常。由二所依法身常故。又受用身及变化身虽有生灭。以恒受用种种法乐无休废故。于十方界数数现化无断绝故。如常受乐。如常施食。故说名常。庄严论说。常有三种。一本性常。谓自性身。此身本来性常住故。二不断常。谓受用身。恒受法乐无间断故。三相续常。谓变化身。没已复现化无尽故。如是法身虽离一切分别戏论。而无生灭故说名常。二身虽有念念生灭。而依常身无间断故。恒相续故说名为常。经说如来色受等法。一切常住。依此道理非无生灭。无漏种子修习增长所生起故。生者皆灭一向记故。色心皆见是无常故。常住色心曾不见故

如是三身。云何形量。法身清净真如为体。真如即是诸法实性。法无边际。法身亦尔。遍一切法无处不有。犹如虚空。不可说其形量大小就相而言。遍一切处。受用身者。有色非色。非色诸法无形质故。亦不可说形量大小。若就依身及所知境。亦得说言遍一切处。色有二种。一者实色。二者化色。言实色者。三无数劫修感色身相好等业。转五根等有漏色身。得佛无漏五根等色。无量相好庄严。其身周遍法界称实净土。于生死中业有分限。阿赖耶识所变身形大小不定。且如此界。瞻部洲人善业最劣。所得色身极长四肘。东胜身洲善业次胜。身长八肘。如是善业渐渐增胜。所得色身形量渐大。乃至色界色究竟天。感色业中最殊胜故。所得色身一万六千瑜膳那量。十地菩萨无漏善根所资熏故。身形转大。如经广说。金刚喻定现在前时。灭一切障善根势力量无边故。所得色身充满法界遍实净土。大圆镜智相应净识。所变身土无限量故。诸佛识变同处同时。其相相似不相障碍。尽未来际无间无断。依此能令诸佛受用广大喜乐。是故说名受用身土。如是身土唯佛乃知。非诸菩萨五根所证。一一色根能证一切所受境界。无障碍故。是故诸佛无见顶相。无边法音。一切色根作用无限以遍满故。言化色者。由悲愿力。为入大地诸菩萨众。现种种身种种相好种。种言音依种种土。形量不定。变化身者。亦非愿力。为化地前诸有情故。现变化身。通色非色。非色即是变化意业。力无畏等诸功德相。无形质故无有形量。色者变化身语业等。随时随处随众所宜。所现身形其量不定。如经广说

如是三身。一切如来为有差别为无差别。法身实性一切如来皆共有故。无有差别。就能证因有差别故。假说差别。其余二身各别因感。各别自性实有差别。但无别执。同处相似利乐意乐事业平等说无差别。是故说言。一切诸佛由所依止意乐事业。于三种身如其次第说无差别。所依法界无差别故。利乐意乐无差别故。共作事业无差别故

如是三身为有各别诸功德不。如来法身清净真如转依为相真实善有本性清净。远离一切杂染法故。一切功德所依止故。一切功德真实性故。说名具足一切功德。无有色心差别功德。佛受用身具足一切色心等法真实功德。及为他现化相功德。佛变化身唯具一切现色心等化相功德。是故三身皆说具有过殑伽沙数量功德

一切如来所化有情为共不共。有义皆共。以一一佛皆能化度一切有情。福德智慧一切平等。三无数劫勤修行愿。同为拔济一切有情求菩提故。如说一佛所化有情即一切佛。有义不共。以佛所化诸有情类本相属故。是故如来底沙佛时。曾与慈氏同为弟子。佛观释迦所化有情善根先熟。慈氏所化善根后熟。又观慈氏因行先满释迦后满。遂于一处入火光定。令释迦见。七日七夜不下一足。一颂赞叹。令超慈氏在前成佛。又佛将欲入涅槃时。作如是言。我所应度皆已度讫。又契经说。佛涅槃时观一所化。现在非想非非想处。当生此间应受佛化。留一化身潜住此界。先所受身现入涅槃。彼从非想非非想没来生此间。佛所留化为说妙法成阿罗汉。尔时化身方没不现。又诸经中处处宣说。能化所化相属决定。是故诸佛所化不共。如实义者。有共不共。无始时来种性法尔更相系属。或多属一。或一属多。菩萨因时成熟有情亦不决定。或共不共。故成佛已或共化度。或别化度。若所化生一向共者。何须多佛。一佛能化一切生故。唯应一佛常住世间教化众生。余佛皆应入永寂灭。佛亦不应化余众生令趣大乘。以无用故。但应化彼令得三乘入永寂灭。以易得故。谁有智者舍易就难然灯助日。是故所化非一向共。若所化生一向不共菩萨不应发弘誓愿。历事诸佛修学大乘苏达那等。亦不应事多善知识诸佛。不应以己所化付嘱后佛。如是等事皆悉相违。是故不应一向不共。虽一一佛有化一切有情功能。然诸有情于无缘佛不肯受化。亦不见闻。虽一一佛尽未来际。常住世间教化无量诸有情类。而随所宜现种种化。或现等觉或现涅槃。或名释迦或慈氏等。随一化相所度有情言皆度讫。生非想者。宜见释迦化相得度。故留化待亦不相违。若诸如来同一所化。何佛现前而化彼耶。诸佛皆有悲愿力故。不可一化余皆止息。但有缘佛同处同时。后得智上各现一化。其状相似不相障碍。更相和杂为增上缘。令所化生识如是变。谓见一佛为现神通为说正法。如是等事不可思议。非唯识理不可解了。又自性身寂灭安乐。正属自利功德所摄。为增上缘益众生故。兼属利他。又与二身俱利功德为所依故。二利所摄。受用身者。具有二分。一自受法乐分。谓三无数劫修自利行满足所证色等实身。令自受用微妙喜乐。二他受法乐分。谓三无数劫修利他行。满足所证色等化身。为入大地诸菩萨众。现种种形说种种法。令诸菩萨受大法乐。由此二分。或说此身唯自利摄。或说此身唯利他摄。或说俱摄。皆不相违。变化身者。唯为利他现诸化相。故利他摄

如是三身有四分故。得为四句。一受用非变化。谓自利分实受用身。二变化非受用。谓变化身为化地前杂类生故。或粗或妙。或令欢喜或令怖畏。改转不定。但名变化不名受用。不必令受现法乐故。三亦受用亦变化。谓为地上菩萨所现种种化身。令诸菩萨受法乐故。随时改转不决定故。四非受用非变化谓自性身。或处说佛有二种身。一者生身。二者法身。若自性身若实受用。俱名法身。诸功德法所依止故。诸功德法所集成故。若变化身若他受用。俱名生身。随众所宜数现生故

又余经说。有十种佛。一现等觉佛。二弘誓愿佛。三业异熟佛。四住持佛。五变化佛。六法界佛。七心佛。八定佛。九本性佛。十随乐佛。前五世俗后五胜义。随其所应三身所摄。如是等类随相应知

经曰。如是净法界　诸佛之所说

论曰。如是如来清净法界诸佛同说。具足佛地五种功德三身差别。或自性等六句义相。由此四颂略说佛地一切功德。及前广说。应知总名圣教所说

经曰。时薄伽梵说是经已。妙生菩萨摩诃萨等。诸大声闻世间天人阿素洛等。一切大众闻佛所说。皆大欢喜信受奉行

论曰。此中显示闻法众会依教奉行。由佛净识悲愿所引。变似契经增上缘力。时众自心善根成熟。似彼相现。谓闻佛说皆生欢喜信受奉行。诸声闻等或现化作或是真实。受用变化二土同处。听法徒众所闻虽同所见各异不相障碍。上亦见下下不见上。各各利益安乐事成

  佛地甚深诸句义　　我今随分已略释
  功德普施诸群生　　愿速等成无上果
  诸有书写所生福　　后后胜善等流果
  愿此相续尽未来　　利益安乐诸含识

佛地经论卷第七


佛母般若波罗蜜多圆集要义论

    No. 1518 [cf. No. 1517]

佛母般若波罗蜜多圆集要义论

        大域龙菩萨造

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护等奉　诏译

归命妙吉祥童真菩萨摩诃萨等

  般若等成就　　无二智如来
  彼中义相应　　彼声教道二
  依止及作用　　事业同起修
  分别相及罪　　称赞如次说
  具信以为体　　师资互证说
  说时说处等　　得自量成就
  说法者应知　　世间时处二
  说者有同证　　然后得如量
  一切如是集　　我闻等所说
  和合如是义　　最上三十二
  分别十六相　　空如其次第
  八千颂中说　　了异方便说
  今此八千颂　　如说义无减
  随所乐颂略　　如是义如说
  菩萨我不见　　此说实寂默
  能受内诸事　　彼说即为空
  色及色自性　　此说亦复空
  此等外诸处　　所受分皆止
  色等相彼身　　安住及相离
  向义若彼见　　彼内即无实
  彼诸内空性　　自性亦复空
  所有识相种　　即起我悲智
  不生亦不灭　　有情此等明
  有情生死欲　　彼说即为空
  佛法不可见　　菩萨法亦然
  此等如所说　　空彼十力等
  别别所有法　　此说遍计性
  彼胜义非有　　诸法如是说
  彼我等见断　　大士毕竟作
  而彼人无我　　佛一切处说
  一切法不生　　此所说亦然
  宣说法无我　　一切处实说
  有罪及无罪　　不增亦不减
  诸有为无为　　所有诸善止
  诸善空性中　　彼出亦无尽
  此遍计分别　　彼普摄为空
  十种心散乱　　心散乱异处
  愚不得相应　　无二智不成
  彼止息互相　　为能所对治
  于般若教中　　彼圆集所说
  若有菩萨有　　此无相分别
  散乱止息师　　说彼世俗蕴
  此八千颂等　　从初语次第
  至了毕皆止　　说无相分别
  因言不如是　　此唯说事相
  梵网等经中　　知一切如理
  菩萨我不见　　而此等广大
  世尊此止遣　　有相分别乱
  若不见彼名　　境界行亦然
  彼蕴一切处　　皆不见菩萨
  此止遣遍计　　普摄此所说
  乘一切智因　　慧分别诸相
  般若波罗蜜　　说三种依止
  谓遍计依他　　及圆成实性
  无此等说句　　一切遍计止
  幻喻等见边　　此说依他性
  有四种清净　　说圆成实性
  般若波罗蜜　　佛无别异说
  十分别散乱　　对治如次说
  此三种知已　　若即若离说
  如初语圆成　　依他及遍计
  无相分别色　　彼散乱止遣
  彼佛亦菩提　　不见说者等
  至了毕此知　　止遣遍计性
  自性空彼色　　俱相何所有
  此别异语中　　了知已彼止
  此不空故空　　如是语所说
  诸毁谤分别　　一切说皆止
  如幻亦然佛　　彼如梦亦然
  如是如次知　　智语边决定
  诸同等所作　　此说佛如幻
  幻喻等言等　　此说依他性
  若诸异生智　　彼自性清净
  故说彼佛言　　菩萨亦如佛
  自性自色覆　　彼无明因作
  如幻别异现　　果如梦弃舍
  无二别异说　　果等定毁谤
  毁谤诸分别　　彼毁谤此说
  色空非和合　　彼互相违碍
  无色无空名　　色相自和合
  此一性分别　　对治种种性
  空不异彼色　　彼空何所有
  此无实所现　　彼无明所起
  此无实能表　　彼说无明故
  此如是说色　　般若波罗蜜
  无二二如是　　二分别对治
  如理言净性　　亦然不可得
  性无性违等　　种种性定见
  说此色唯名　　真实无自性
  彼自性分别　　容受即当止
  色及色自性　　空如先所说
  彼自性俱相　　分别此止遣
  不生不灭等　　所有诸法观
  佛言若散异　　彼差别分别
  虚假名言等　　彼法若分别
  声义二非合　　彼非自性意
  般若波罗蜜　　佛菩萨亦然
  此所说唯名　　离实义分别
  所有声义止　　此非事止遣
  如是余亦知　　语中义决定
  此无所得正　　一切名实知
  如义性如是　　不止遣彼声
  须菩提二离　　声声义如是
  菩萨无有名　　我见此有说
  般若波罗蜜　　语无决定生
  伺察唯智者　　此义微妙慧
  相续义除遣　　若别义分别
  般若波罗蜜　　彼言说如响
  总略如是义　　般若等依止
  如是义循环　　复别义依止
  般若波罗蜜　　正摄八千颂
  彼所得福蕴　　皆从般若生

佛母般若波罗蜜多圆集要义论


佛母般若波罗蜜多圆集要义释论

    No. 1517 [cf. No. 1518]

佛母般若波罗蜜多圆集要义释论卷第一

        三宝尊菩萨造大域龙菩萨造本论

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫沙门臣施护等奉　诏译

  归命般若波罗蜜　　出生一切诸佛母
  而彼般若胜所依　　毕竟无著涤诸垢
  为诸佛趣自性离　　令众生喜胜相应
  能取所取二俱亡　　此中常性不可立
  由彼二取解脱故　　断见常见悉遣除
  从一切智所出生　　稽首智能到彼岸

我今于彼大域龙菩萨所造。佛母般若波罗蜜多圆集要义中。略释行相为令诸小智者思念是义。可略知故。如彼颂言

  胜慧等成就　　无二智如来
  彼中义相应　　彼声教道二

此言胜慧等者。即慧彼岸到胜慧谓闻思等慧。岸者。边岸。到者。往而得到。谓由清净妙慧能到彼岸。此中应问。何人能到。答谓诸菩萨。彼何所成就邪。即般若波罗蜜多成就。成就者。成办义。如是果性增上意乐所成办故。如八千颂般若教等。开示演说。是谓般若波罗蜜多成就。非于般若波罗蜜多声中有所成故。若尔当以何义说彼成就。所以颂言。无二智无二者。无有二相名为无二。是智无二名无二智。如是所说。此中意者。般若波罗蜜多离能取所取。即无二智。菩萨成就如是智故。若或于彼色等境中着所取相。彼能取心。于无二智即有对碍。问若诸菩萨如是成就般若波罗蜜多。何故今此不言如来。谓以如来于一切处勤修诸行得成佛故。论自答言如来。如来者。谓彼如来。彼者。即是般若波罗蜜多。如来者如实而说故名如来。以彼如是普离一切分别网故。般若波罗蜜多即是如来。此中无二亦无分别。无二者。如来不离般若波罗蜜多。亦不即般若波罗蜜多。何名无分别。谓如灯光此如是义。是故应当如实了知。如诸智者。所说颂言

  非智离于空　　有少法可得
  此意言离者　　性离非远离
  彼二空异识　　无少法可着
  二无实可转　　二我性不立

由此证知。于如实相中。世尊如是说。是故能知所知若有性者。诸分别等有所依止。此应问云。若般若波罗蜜多成就无二智者。何故颂说教道二邪。颂自答言。彼中义相应彼声教道。二彼中者。于彼声中含教道。二义相应者。次第今说。谓彼所有教道二种。与般若波罗蜜多义和合相应。彼声教道二者。彼声之言如前已释。教道二者。即是般若波罗蜜多方便。于彼声中所含藏故。犹如种子。在含藏位其义亦然。如是当知。般若波罗蜜多声说二种义。一者胜上。二者种类。彼胜上者。谓无二智相。其种类者。有二种类。即教道自性。由是二种和合施设。当知乃有宣说表示。复由依止如是等故。此般若波罗蜜多中所有语义。开演三十二品无增无减。此中所说为遣。十种分别散乱。又复显示十六种空。复次颂曰

  依止及作用　　事业同起修
  分别相及罪　　称赞如次说

如彼颂中。有其六种。所谓依止作用事业相罪称赞等。此中云何次第今说

所言依止者。谓佛世尊最初说智。由彼如是所依止故。所有甚深法门而能相续演说。非须菩提等彼能说者。能为如是和合依止。问佛所说智其相云何。答如佛于八千颂般若经初作如是言。须菩提随汝乐说。诸菩萨摩诃萨般若波罗蜜多。应当发起如菩萨摩诃萨般若波罗蜜多。出生等为由如是佛威神力所建立故。彼须菩提。乃能如是宣说般若波罗蜜多而无障碍。此中如是所说诸义。说彼经中第一品故

所言作用者。即增上作用。谓佛说智为增上故。为说此法起说作用。即菩萨等众作用次第。由如是故。乃能发起宣说此法

所言事业者。谓即所作事业。如是发起由此般若波罗蜜多教。如是安住。是故勤勇起修。除遣十种分别散乱法。及次第分别十六种空。如是应知。所言相者。标表为义。又相即形相。此中云何。谓若菩萨于此般若波罗蜜多法门。若书时若读时。或有人等起疑心者。当知皆是魔事等相。若不退转。是菩萨相

所言罪者。谓于此法作障难事。及谤正法等。或于般若波罗蜜多而生毒想。此等皆是感招罪报

所言称赞者。谓称赞果如经云。若有人以满三千大千世界七宝持用布施。若人于此般若波罗蜜多受持等者。其福胜彼。此中复说何义而为依止。故有颂言

  具信以为体　　师资互证说
  说时说处等　　得自量成就

此中云何。所言具信等者。信谓信心清净。谓诸菩萨由彼信故。于甚深教能生胜解。彼信有故。名为具信。彼信具故。而能为体。体谓身体。譬如有身为因。乃能相续修作诸行信义亦然。所言师资互证说者。谓世尊大师宣说此法。菩萨等资亦各宣说。如是说已。如应表示。所言说时说处等者。时者。所谓和合所作表示说时。各别决定印持所得处义。应知问彼说法者。当得何义。颂自答言。得自量成就。其义云何。自者。己义。量谓自量自所得量无相违故成就者。成办义。谓说法者。诸所说事悉成办故。如彼颂言

  说法者应知　　世间时处二
  说者有同证　　然后得如量

此中云何。所言说法者。谓说法人世间时处。二者。谓于世间相中先当了知。说时说处。然后依智如理而说。问此何等说。颂自答言。说者。有同证。谓有同证和合说故。问云何得如量。答所谓得此真实言量。非今所说时处等义。此中复以何义印可三十二品。故有颂言

  一切如是集　　我闻等所说
  和合如是义　　最上三十二

此言一切如是等者。一切者。普尽义。何等普尽。谓如是聚集我闻等聚集。如是者。谓如是所作如是此法。所言我闻等者。我者。自相所成闻。谓听闻即听闻此法。此中总意。若如是若我若闻等总聚而成。故云如是我闻等。问所云等者。等取何义。答等者。等摄时处。所言说者。说谓说示。是故此中说彼如是我闻等。所言和合如是义者。谓彼说者。若作若非作。彼等和合从初次第宣说。如是最上义故。最上者。最极胜上。彼言说体者。谓言诠故。问此何所说。颂自答言。最上三十二。三十二者。数量决定。谓说如是数中义故。是故当知此中所说亦无减少。问十万颂般若波罗蜜多经中说多种空。此八千颂般若波罗蜜多经中。说十六空。与彼所说如何齐等。为有此疑。故颂止言

  分别十六相　　空如其次第
  八千颂中说　　了异方便说

此言分别等者。重重分类所区别故。名为分别。又分别者。即种类义。彼种类者。种种性义。此中何所分别。谓分别空分别何等空。即十六空。十六者。数之分限。此说十六空与彼十万颂般若经中所说义。自齐等。颂云。八千颂中说者。是即八千颂。般若经中所说。彼如何说。是故颂言。如其次第如次者。不过越义。何法不过越。谓说空之声。故下颂言。了异方便说。其义云何。异者。谓别异法。于彼别异法中取其方便。是故说者。异方便说。了者了知应当如是分别了知。所谓了知此异方便。分别说空。复次颂言

  今此八千颂　　如说义无减
  随所乐颂略　　如是义如说

此言今此八千颂者。指法应知言无减者。谓无缺减。何等无减。谓如说义。即如其所说义自圆满。或有问云。此中所说何故颂略。颂自答言。随所乐颂略今此但说八千颂者。为彼听者最胜意乐所宜闻故。是故颂略。略谓少略。所言如是义如说者。谓即如是所说之义。彼复云何。颂言如说如说者。谓如其言说。如是所说如理成就。非般若波罗蜜多法中义有差别。但为软中上品所有根性随欲摄受。是故世尊由此因故。少略说此般若波罗蜜多。如其次第以异方便说十六空。如是所说显明开示。复次颂言

  菩萨我不见　　此说实寂默
  能受内诸事　　彼说即为空

此言菩提萨埵等者。菩提及萨埵。此即是菩提萨埵。菩提者。谓无二智。萨埵即求菩提者。而此萨埵名菩提萨埵。即彼菩提萨埵我不可见亦不可得。我者己义。所言此说实寂默者此者如是义。说谓言说。实者真实即胜义谛。寂默者。即是世尊。谓佛世尊身语意业皆相应寂默故。如是等说由佛威神所加持故。令须菩提能于此中说是语义。所言彼说即为空等者。彼者。即彼世尊。说谓说示。谓佛世尊。说此为空。说何法为空。所以颂言能受内诸事等内诸事者。所谓眼等内六根处名内诸事。以彼愚夫执实。能受世尊说。彼内事皆空。又新发意菩萨于中分别有实自性。如是等言说内空竟。复次颂言

  色及色自性　　此说亦复空
  此等外诸处　　所受分皆止

此言色及色自性等者。谓色声等外六境处。又色者。即是色处。所言色自性者。色谓自色。如所有相彼相不生。以不生故即自性空。然彼自性亦不可坏。譬如人角其义应知。所言此说者。谓此如是说如是等言。复次此中世尊皆止止者。不作义。问止何法邪。颂自答言。此等外诸处此复云何。外诸处者。谓色等境。外诸分位皆悉无实。而彼异生执有如是实所受性。是故此中止此语义。如是等言说外空竟。复说后空。如彼颂言

  色等相彼身　　安住及相离
  向义若彼见　　彼内即无实

此言色等相彼身者。此中云何。是彼身。所谓内外二色处。是即彼身。所言安住者。即是器世间各别依止安住故。名安住。所言相者。谓三十二大士表相。所言离者。彼如上说皆悉离故。离即空义。所言向义者。向谓已往。已往之义名为向义。何等法是向义。如上颂言色等相。此复云何。谓若如是内外色处皆悉无相。即彼如是了知空义。如是声义。是故应知。今此颂中先说三种空。所谓内外空大空相空。次说空空。如颂所言。若彼见彼内即无实。若者即若所有义。谓所有空智。彼者即彼身等。见者知义。知即了知。此中意者谓知空智。了境空已。即此空智于内无实而无所有。何况余法有依止性。此句如是说空空竟。此中复说自性空。如彼颂言

  彼诸内空性　　自性亦复空
  所有识相种　　即起我悲智

此言彼诸内空性等者。谓即所有内诸处空性相续此说。所言自性亦复空者。自性者。种性义。由彼如是显明识相等。所言所有识相种者。所有谓若所有义。此中若识相若识性。彼等种性即我悲智生。悲者欲令他苦得离散故。智者即择法相。若悲等若智等。是谓悲智。我者自相义。即自所有悲智二种。此意总说内识处等自性空故。复次后说二种空义。如彼颂言

  不生亦不灭　　有情此等明
  有情生死欲　　彼说即为空

此言不生亦不灭等四句颂文。此中合释二种空义。所言不生者。彼八千颂般若经中说不生。言此止其生此中意者。谓本来不生性。生若无性灭亦无性。彼前性不生后性亦不灭。问此等云何。故颂答言。有情有情者。即五蕴身命。有谓有彼物性。情谓自所作性和合而言。故曰有情。明谓显明。此中意说。若有情若生死。彼二皆空。是义显明。而诸有情无有边际。死此生彼六趣循环。无有穷尽轮转生死。此生死者。即是轮回。如是行相。有情即生死释义应知。问此何人说邪。颂答言彼。彼者。即彼如来真实说故。彼何所说。所谓说空即有情生死。二种空故。然彼无性此中亦离如执。彼无性此亦不然。若尔何故颂言欲邪。欲者。乐欲义。谓即有情生死二欲。若如是所欲毕竟。彼如是真实。如是等言说二种空义。谓毕竟空无际空。问何名无际。无际者。谓无有初际及无初分。此无际说空故名无际空。如佛所言生死先际不可表示。故复说后空。如彼颂言

  佛法不可见　　菩萨法亦然
  此等如所说　　空彼十力等

此言佛法不可见等者。佛法者。即诸佛法。所谓十八不共十力等法。如是之法。以清净妙慧观不可见。亦不可得。彼如是故所有分别。而为对碍。所言菩萨法亦然者。即诸菩萨法。所谓布施等诸波罗蜜多种种行相。入真实智如理而观。亦无所见。所言此等如所说。空彼十力等者。此等者。谓此如是等教。如所说者。即如其所说。问此说何等法。颂自答言。彼十力等指上所明十力等法。所言等者。等摄十八不共法。又问。此法何所说邪。答所谓说空。空者自相离故。此中如是等说一切法空竟。复说后空。如彼颂言

  别别所有法　　此说遍计性
  彼胜义非有　　诸法如是说

此言别别所有法此说遍计性等者。此破遍计性。别别者。即各各义。谓此所有遍计性故。遍计者。取着义。取着何法。即色等法。此者如是义。说谓言说。此中总意。谓各别诸法胜义谛中。彼非有故。是故颂言。彼胜义非有诸法。如是说胜义非有者。即胜义谛中无自性故。问何法无自性。答谓色等诸法。如是说者。即此如是说。问何人如是说。答佛作如是说。观彼所有胜义相空。彼相即是遍计性。空非唯能取相。于胜义谛中说彼空故。如是等说胜义空竟

此如是说义自明显然。造释者。别说颂曰

  彼彼遍计性　　处处皆执着
  此如是遍计　　自性无所有

佛母般若波罗蜜多圆集要义释论卷第一佛母般若波罗蜜多圆集要义释论卷第二

        三宝尊菩萨造

        大域龙菩萨造本论

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫沙门臣施护等奉　诏译

复说后空如彼颂言

  彼我等见断　　大士毕竟作
  而彼人无我　　佛一切处说

此言我等见者。即说我等见断。我者。谓遍计所执。所有蕴等。等者。等摄人及众生寿者。此中行相等。谓所等是我所有等释义应知。见者谓取着之见。此中总意。于我等境。界中彼我等见断。断者坏义。作者谓毕竟作故。问何人作邪。答言。菩萨。又问。若菩萨者。何故言大士。答大士者。即大有情。此大有情普遍轮回相续而作此。即是菩萨若此中如是复何所说。所以颂言。而彼人无我佛一切处说。谓佛于一切处如是决定说人无我。如是等说无性空竟复说后空。如彼颂言

  一切法不生　　此所说亦然
  宣说法无我　　一切处实说

此言一切法不生等者。一切者。普尽义。法即是色等法。一切即法释义。应知彼一切法悉不生故。此言不生者。即止其生此中意者。即本来不生性。非如彼相聚集。所得有其实性。颂言此所说亦然者。此谓如是说者。表示义亦然者。亦复说故。颂言宣说法无我者。法谓色等诸法。无我即无自性。问若尔将何表示。颂自答言。一切处实说。一切处者。即遍一切种。实谓真实。即法无我真如说。谓了知了知者。遮防为义。此说真如遮余法故。又问。何人实说邪。答谓佛世尊。如是等说不同外道所说空故。如是等说无性自性空竟。复次后说二种空义。如彼颂言

  有罪及无罪　　不增亦不减
  诸有为无为　　所有诸善止

此言有罪及无罪等者。罪谓过失过随罪转故名有罪。离罪及过。即名无罪。若罪无罪所有诸法不增亦不减。此言不增者。虽有所得而无增长。亦不减者。谓得无尽法出生无减。是故菩萨如实知彼无尽法故。所言有为者。谓诸有所作故。名有为。行相云何。谓即因缘所生诸行。无为者。简非有为行相。云何谓择灭等。颂言所有诸善者。问而彼有为无为所有诸善。复云何说。答此中当知。有为诸善无为诸善。若如次修若不如次修悉得无增减。此中意者。但于胜义谛中无实取法。所言止者。止谓止遣。止彼所有无相之言。如是等说有为空无为空竟。复说后空。如彼颂言

  诸善空性中　　彼出亦无尽
  此遍计分别　　彼普摄为空

此言诸善空性等者。诸善者。即诸善法。谓空性中有诸善法而非无性。何以故。颂言。彼出亦无尽。彼谓于彼声中含诸善法故。出谓出生。亦者。相续说义。此中总意由诸善法如理出生性无尽故。彼即无减。诸菩萨事亦不间断。颂言此遍计分别者。谓智者应当如实了知。如是所说遣遍计性。颂言彼普摄为空者。普谓普尽。摄谓总摄。谓此八千颂般若经中分别广说诸空种类。此中如是相续所说。普遍圆集而总摄故。故名普摄。如是此中总摄空故。问如是空行相此云何和合。答此所说空但遣遍计所热法相。此如是言即毕竟义。于是言中理自和合总集。如是所说空已。后复无空语义可说。复次当知。此中如是所说诸空。但为止遣有情取着。分别非说实性。何以故。而彼实性中说二种空故。所谓人空一切法空。如是等说无散空竟。问何名无散。答散谓离散。此散不散故名无散。无散体者。谓诸菩萨所有善法乃至无余依涅槃界中。彼亦不散彼亦无尽故。名无散。如是总说十六空竟

如辩中边论慈氏菩萨说如是义。显明开示故。彼颂言

  内外受彼身　　安住物皆空
  彼等智如见　　所有义彼空
  获得二种善　　常利益有情
  处生死作利　　彼善法无尽
  种性等清净　　获得诸相好
  清净诸佛法　　菩萨亦成就
  人及一切法　　此中无性空
  无性中有性　　彼性亦复空

复次此中今说除遣十种分别散乱法。当知此即起修行相。问何等是彼十种分别散乱。复云何止。所以颂言

  十种心散乱　　心散乱异处
  愚不得相应　　无二智不成

此言十种心散乱等者。谓新发意菩萨等有十种分别散乱。所谓无相分别散乱。有相分别散乱。俱相分别散乱。毁谤分别散乱。一性分别散乱。种种性分别散乱。自性分别散乱。差别分别散乱。如名于义分别散乱。如义于名分别散乱。此如是等十种。分别令心散乱。此心心所散乱。异处散乱者。谓散异动乱故名散乱。所言异处者。谓别异处有分位等。动乱所引。是故彼心不得相应。问何人不得相应邪。颂自答言。愚不得相应。愚即愚夫。异生愚者。谓若损若益及真实法悉不知故。问不得何法相应。颂自答言。无二智。无二者。无有二相名为无二。不着二之智名无二智。成就者。所谓成办即决定成办。此中如是所有理义。如颂所言不成者。谓诸愚夫异生心有散乱。于彼色声香味触等诸境中。心生取着。是故于彼清净妙智不得成就。即不相应。问若无二智不相应者。此中复说何义。所以颂言

  彼止息互相　　为能所对治
  于般若教中　　彼圆集所说

此言彼止息等者。彼者即彼十种分别散乱。止息谓止遣。问何处止耶。颂自答言。般若教中。谓十万颂般若波罗蜜多等教中。一切皆说如是止言。问止彼何法。颂自答言。互相为能所对治。互相者。此彼更互义。能所对治者。谓有相无相互。为能所对治行相。云何谓如所有有相为能对治。即无相为所对治。若无相为能对治。即有相为所对治。此如是等是为行相。问彼般若教中当如何说。颂自答言。彼圆集所说。谓此佛母般若波罗蜜多教中。如是圆集总聚要略。摄此十种分别散乱。说谓言说。此如是说是即如来如是最上真实了知。圆集普摄。于佛母般若波罗蜜多中。如是宣说。问所说云何。是故颂言

  若有菩萨有　　此无相分别
  散乱止息师　　说彼世俗蕴

此言菩萨有此无相分别等者。菩提及萨埵是即菩提萨埵。有谓不无。此如是说谓即有此无相分别。无相分别者。谓色无相分别。彼如是散乱即痴所作性。问有此散乱。其复云何。颂答言止息。问何人能止邪。颂答言师。师者。谓如来大师。善能调伏诸烦恼冤。又能救度恶趣等怖。故名为师。颂言说彼世俗蕴者。世俗谓世间。其世俗蕴谓色受等。说彼蕴者。谓令了知。有此蕴故除遣无相分别散乱。如是所说意者。世尊悲愍新发意菩萨等。是故为说世俗诸蕴。使令了知为除断见。止彼无相分别非说实性。此八千颂般若波罗蜜多教中。说如是义。即诸般若波罗蜜多本母义理相应。复次颂言

  此八千颂等　　从初语次第
  至了毕皆止　　说无相分别

此言八千颂等者。此者如是义。如是八千颂本母所说故。等者等摄十万颂。所言从初语次等者。即初语所成。谓从经初所起语言行相云何。如经言。须菩提随汝乐说。诸菩萨摩诃萨般若波罗蜜多。应当发起如菩萨摩诃萨般若波罗蜜多出生等。颂言至了毕皆止者。谓从经初乃至经末。于中所说悉周竟故。颂言皆止者。止谓止遣。即于其中止彼无相分别毁谤之言。颂言说无相分别者。谓色无相分别。以彼分别色无相故。而堕于空。以断有色故。所言说者。其义云何。说谓依法而说。此依法说。说事相故。行相云何。谓由初语言而为发起。乃至了毕其中所说多种语言。于彼言中成立别异发起行相。谓诸菩萨及帝释天主上首等。此如是等当知皆是止其断见。问若此等所说语言分位有所发起者。复有何等道理。依法而说。遣除无相分别毁谤之言。故颂破言

  因言不如是　　此唯说事相
  梵网等经中　　知一切如理

此云因言不如是等者。因者道理义。不如是者。此道理言非成就言。何所以邪。颂自释言。此唯说事相。事者谓有所作事。有所修事。说谓言说。此中如是义唯说事相故。若尔即今和合道理义不成就。云何能令诸有智者于中观察生欢喜邪。故颂通言梵网等经中知一切如理。此中云何。即梵网等所有诸经。且言等者。等摄云轮等经。彼诸经中皆如理说。何人所说。谓佛世尊。于一切处依如实理。自如是说。如是说者。自义成就。所言知者。知谓了知。了知此说如理如量。若如是说真实语义。是决定义。此复云何。若如前言道理说者。虽能除遣无相分别。彼有相分别旋即生起。是故今当如应开示彼相违门。如其颂言

  菩萨我不见　　而此等广大
  世尊此止遣　　有相分别乱

此言菩萨我不见而此等广大者。谓由最初起遍计性。于菩萨相而生取着。彼所取相于实性中。我不可见亦不可得。我者己义。此等广大者。广大即包广义。此菩萨者。其义广大。是故菩萨我不可见亦不可得。般若波罗蜜多亦不可见不可得。如是等所说为令止遣有相分别散乱。颂言有相分别乱者。相谓色等相。乱即动乱。分别者。谓于色等相中有所分别。于不如义中取着如义性。此如是等疑惑动乱。于胜义谛中无有实性。问何人止遣邪。颂自答言。世尊。此止遣问何所止邪。所以颂言

  若不见彼名　　境界行亦然
  彼蕴一切处　　皆不见菩萨

此言若不见彼名等者。若谓若有不见即不可得。问何法不见邪。答此菩萨名而不可见。若说如是名彼说不可得。且止此说。颂言境界者。如实当知非唯菩萨名不可得。诸境界等亦不可得。境界者。谓所行境界。是诸菩萨所行般若波罗蜜多。如是道相行亦然者。行谓普遍。诸行即所修所行。而此诸行亦不可得。所言彼蕴一切处者。蕴谓色受等。一切处者。谓遍一切处及一切种。此中意者。如实当知。以清净妙慧于是一切处求菩萨相。了不可得。以是因故。菩萨不可见。是故颂言。皆不见菩萨。此中如是所说意者。但遣愚者。于佛世尊无染智中执有实名及境界等。彼不可得。非正了知而菩萨相。于圆成实性中亦不可舍离。若取舍离相者。彼无相分别还复生起。此义略说故有问言。若今如是于实性中无菩萨者。岂非前言有相违邪。颂自通言

  此止遣遍计　　普摄此所说
  乘一切智因　　慧分别诸相

此言止遣遍计等者。遍计者。谓诸有情所起颠倒之见。行相云何。谓于蕴处界中执有实性。今止彼故。不于清净妙智中而有所止。颂言普摄此所说者。此者如是义。普摄说者。即作者。普摄而说。此普摄说是胜意乐。当知此等般若波罗蜜多义。如是普摄而说是为决定。即彼如是获得究竟。问以何义故而作此说。颂自答言。乘一切智。因此如是义如理显示。乘谓乘驭。一切者普尽义。智因者。以了别智而为因故。问何人乘驭邪。颂答言慧。慧者。大慧即是佛故。问何所说邪。颂自答言。分别诸相。相者所谓普集作用。故名为相。是相无对碍。问是何等相。颂言分别。即分别显示诸行相故。非说实性。此如是等所说之义。如实观察。乃至无有极微尘量外义。自性可得成立。是故世尊乘彼智聚。开示分别所有一切作用行相。问得何义故。乃能如是。所以颂言

  般若波罗蜜　　说三种依止
  谓遍计依他　　及圆成实性

此言般若波罗蜜等者。当知般若波罗蜜多有二种法。一者胜上。二者所行。胜上者。谓离烦恼所知二障之智。所行者。谓名句文言说之相。彼胜上者。即般若波罗蜜多。自性所说。彼所行者。即说法言义。是自性作用。问其所作用。此中云何。颂自答言。说三种依止。三种依止者。此复云何。如颂所言。谓遍计依他及圆成实性。遍计者。谓诸愚夫于无二清净智中。遍计诸相执着对碍。此说名为遍计性。依他性者。谓无二智自性安住。无明种子二有对碍。而彼无明依他起故。此即说为依他起性。圆成实性者。谓即无二之智。即是圆成实性。问云何说为三种依止。所以颂言

  无此等说句　　一切遍计止
  幻喻等见边　　此说依他性

此言无此等说句一切遍计止等者。无谓无所有。此句者。谓如是等诸所说句。等谓等其说法者。彼止言无。问此中行相其复云何。故颂答言。一切遍计止。一切者即普尽义。遍计者。谓虚妄巧异执着造作。止谓止遣。此如是等所说意者。谓若有闻一切说者。说止遣言。智者应当毕竟了知。一切皆是止遣。遍计有相执着。颂言幻喻等见边此说依他性等者幻谓帝网。等者等摄乾闼婆城等诸幻法。幻者由他假法有所成故。今取彼幻喻此法故。乃名幻喻。见边者。谓由彼喻晓如是法故。名见边。此中意者。谓若有闻说幻喻等诸见边义。智者当知。此即是说依他起性。此中当知。由彼幻等已见边故。是故世尊有所宣说。问彼依他自性云何了知。圆成自性云何说事。所以颂言

  有四种清净　　说圆成实性
  般若波罗蜜　　佛无别异说

此言有四种清净说圆成实性等者。说谓表示。谓以四种清净表示所有圆成自性。四种者。即有四种类。清净者。无染义。谓由得彼四种净故。乃名清净

佛母般若波罗蜜多圆集要义释论卷第二佛母般若波罗蜜多圆集要义释论卷第三

        三宝尊菩萨造

        大域龙菩萨造本论

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫沙门臣施护等奉　诏译

所言四种清净者。一自性清净。二离垢清净。三所缘清净。四平等清净。初自性清净者。即是无差别无二之智。行相云何自性者。谓本性不虚假。即真我性。于自性中有如是相。如摩尼宝映现和合。如佛所言一切众生即如来藏。彼一切法与善逝等而无自性。此如是说即自性清净。二离垢清净者离垢者。即离诸垢染。清净之义。已如前释。行相云何。谓所行对治诸有。观力随生相应无二之智。此所作已所有世尊增上意乐事等。即彼实际真如法界。此如是说。即离垢清净。三所缘清净者。所缘者。谓即所有普尽般若波罗蜜多义等一切所缘境界作用。又彼所得性或所成性。亦是所缘。于是所缘中而得清净。清净之义已如前释。此如是说。即所缘清净。四平等清净者。平等者。齐等无差义。即是平等微妙清净法界大法光明。彼平等性乃名平等。于是平等中而得清净。清净之义已如前释。此如是说。即平等清净。如是总说四种清净。即圆成自性。是故说此般若波罗蜜多诸有行相。如是言义此如是等和合作已。离虚假法。所以颂言。般若波罗蜜。此中云何。谓即所有般若波罗蜜多诸有所说言义。自性谓佛世尊一切如是。当知皆依三种相说。非离依他等自性别有所成义。此中所说行相云何。谓若幻喻等见边说已。即是说彼依他起性。而无别异。若依他起性说者。即是幻喻等见边。何以故。无复有法故。如是余处亦然应知。复次此中若说止门所有行相。即是说彼遍计之性而无别异。若遍计性说者。即是所说止门。何以故。此法无故。间圆成实性中。云何可有彼言说门。以彼法中无有性故。如是随其所生分位。即彼如是所说分位而亦无实。所以颂言

  十分别散乱　　对治如次说
  此三种知已　　若即若离说

此言十分别散乱对治如次说等者。谓即所有十种分别散乱。今此次第说彼对治。即相违对治及能所对治。所言三种者。谓遍计依他圆成实性。如是三种如其次第知已者。谓了知已所言。若即若离说者。谓般若波罗蜜多教中。有即有离故。此中总意。若如是了知已。彼遍计依他等所有诸事相。或即或离。彼一一相如其所说。显明开示。问此中云何若即若离说遍计等。所以颂言

  如初语圆成　　依他及遍计
  无相分别色　　彼散乱止遣

此言如初语等者。如者指法。谓此如是八千颂般若教中最初语言。如彼经云。须菩提。随汝乐说诸菩萨摩诃萨般若波罗蜜多。应当发起如菩萨摩诃萨般若波罗蜜多出生等。此如是语。即最初语。此语依彼圆成依他遍计三性而说。如所说相即圆成性等自色相非无。若于如是自色相中。起色无相分别散乱者。世尊于此皆悉止遣。问复次此义云何了知。答如彼最初语中依三种义说。所有彼语今于此中略指其义。如彼经云。如菩萨摩诃萨般若波罗蜜多出生等。出者即出离义。又出生义。或得无上道义。以要言之。或为种种义界。此如是说。由此出生一切义故。此中复能出生称赞等事。谓佛菩萨等所有称赞。彼称赞相如前已说。又如经言。须菩提。随汝乐说诸菩萨摩诃萨般若波罗蜜多。应当发起诸境界事。所言乐说者。谓得乐说慧及得乐说光明。故名乐说。此如是等一段经文。即依他起性所说事相。若如彼经从须菩提乃至出生等全段经文。其中若有说彼实义。即是依彼遍计性说。又如经言。如菩萨摩诃萨般若波罗蜜多出生等。此一段经文。即圆成实性所说事相。此中总意由此因故。依三种义宣说般若波罗蜜多。是故所说有即有离。复次颂言

  彼佛亦菩提　　不见说者等
  至了毕此知　　止遣遍计性

此言彼者。谓即彼因。此中云何。谓诸愚者于般若波罗蜜多教中。取着句义执实。能知所知起诸遍计故此止遣。问何法能止邪。答止法应知。问何人是说者。颂自答言。彼佛亦菩提不见说者等。此中云何。谓如所应安立句义。能觉了者即是佛故。菩提者。谓离烦恼所知二障之智。等即等摄菩萨声闻。所言说者。即是佛等。谓若有于蕴等自性中。颠倒遍计者。佛为说彼止遣法故。此中如是即有彼说者。颂言不见者。如理应知。问而彼所说何等是其分限。颂自答言至了毕。谓此般若波罗蜜多教中。自初至末而悉周毕。是为分限。颂言止遣遍计性者。谓此所说佛及菩提不见等义。皆是止遣有相分别遍计性故。问云何此中但止遍计性。不止圆成邪。颂自通言

  自性空彼色　　俱相何所有
  此别异语中　　了知已彼止

此言自性等者。自性者。即本性义。空彼色者。谓色自性空。若彼智相见有色故。即有所取。如是一切计色有实彼为对碍。于俱相中而有增相。还成分别。所分别相其云何有所以。颂言。俱相何所有。俱相者。即二俱相。谓色自性于胜义谛中无所取分位。譬如人角。其义应知。是故但止遍计不止圆成。何以故。胜义谛中非有性故。颂言。此别异语中了知已彼止者。此者。因义。了知者。解了义。谓由于彼别异语中。善了知已。即能远离。所言彼止者。止谓止遣。谓即止彼所有遍计。此如是等当知。皆是止遣俱相分别散乱后。当止遣毁谤分别散乱。如彼颂言

  此不空故空　　如是语所说
  诸毁谤分别　　一切说皆止

所言此不空故空等者。谓佛世尊于般若波罗蜜多本母中。宣说如是不空故空。所言如是语所说者。谓即说此如是语故。所说云何。所谓不空故空。空性离故。所言诸毁谤分别者。若有于此不空故空中。取空自性者。是即毁谤分别。今悉止遣。所言一切说皆止者。一切者。谓一切处一切种类。说谓言说。谓佛世尊不但此中止遣遍计分别。于一切处执空之言。皆悉止遣。复次颂言

  如幻亦然佛　　彼如梦亦然
  如是如次知　　智语边决定

此言如幻亦然佛彼如梦亦然等者。当知此说亦是止遣毁谤分别。如幻者。以幻喻法故。名如幻何者如幻。谓即佛故。亦然者。相续说义。如梦亦然者。谓即彼佛亦复如梦。此中若有说佛之言。当知皆是说无二智。而彼自性与异生等相续有故。但为无明幻等之所覆故。而诸愚者乃于自相隐而不现。颂言如是如次知智语边决定者。谓如是所说如其次第如理而知。知谓了知。问何人能知。颂答言智。智即智者。问何等是语边决定。答所谓一切法如幻。问此中止遣毁谤分别。如是知已。后复云何有所开示。所以颂言

  诸同等所作　　此说佛如幻
  幻喻等言等　　此说依他性

此言诸同等所作此说佛如幻等者。同所作者。谓同其幻。此中意者。若一切处无二智中无所生者。彼诸同等所作说不相应。何所以邪。以诸幻等皆有性故。此中如是佛亦有性。是故颂言。说佛如幻。颂言。幻喻等言等此说依他性者。上言等者等摄梦等。复言等者。即是因义。说谓言说。若说幻喻等言即是说彼依他起性。此依他性佛所说故。依他者谓依属于他故。名依他。此依他者。即无明自体。此等分位有所依止。即此如幻说。佛亦然。是故应知非一切种一切无性。以自性清净故。彼等幻喻佛等所说。一切皆然。如是等说若有毁谤分别者。彼非如来藏一切众生非无二智。何以故。于一切有中毁谤分别故。由如是故。于所成义而悉不成。亦不和合。问若胜义谛中无二之智。即是如来者。云何此中说异生智邪。为破此疑。所以颂言

  若诸异生智　　彼自性清净
  故说彼佛言　　菩萨亦如佛

此言若诸异生智彼自性清净者。即诸异生本性清净体即自性清净之智。所云说彼佛言者。谓说彼佛如实无二智故。此说异生智。亦复同等。问若以所行相中如是说者。其复何如。颂自答言。菩萨亦如佛以无二智所生如是义故。是故菩萨亦即如佛。由此因故。佛及菩萨说无别异。问若异生若诸佛于如实智中有所生者。云何前言无所得邪。颂自通言

  自性自色覆　　彼无明因作
  如幻别异现　　果如梦弃舍

此言自性自色覆彼无明因作者。谓诸异生和合自识自性无二。由彼无明为因所作起我我所。我谓自性。我所谓自色。以自色覆故。别异所现故。起二相。是相无二亦无有实。此复何如。颂言。如幻。于是如幻无自性中。取实物性。而彼所取与无二智而为对碍。问若此无二智自性与异生智。自性平等说者。何故异生识中无所出现。答以能取所取颠倒之性所隐覆故。然如来识中于一切时。常所出现以清净性故。问若诸异生清净性中而无有果。真实出现者。即一切时无明坚着。其复云何。是故颂文破此疑言。果如梦弃舍。弃舍者。即不取着义。此中意者。所有自性清净智中非无果性。但为无明所隐覆故。如闻思等慧和合所作。其所得果而无实义。此中亦然。如梦中果觉无实义。无相可表。虽和合而作。似有所得得已弃舍。此说决定是为正理。复次颂言

  无二别异说　　果等定毁谤
  毁谤诸分别　　彼毁谤此说

此言无二别异说等者。谓诸愚夫于无二智中。别异所现起颠倒见。着于二种境界之相。颂言果等定毁谤者。果等者。谓于果等境界真如相中。决定毁谤。今此止遣。颂言毁谤诸分别等者。谓毁谤故起诸分别。而彼毁谤诸分别等今悉止遣。颂言此说者。为止遣故。今此说言不空故空为令弃舍彼虚假说。应知此中色即是空。复次此中一性分别有所起现。此复云何。谓般若波罗蜜多本母中说。若色空即非色。作此如是和合所说。为令止遣。一性分别决定语义。所以颂言

  色空非和合　　彼互相违碍
  无色无空名　　色相自和合

此言色空非和合者。谓色与空不和合故。不和合者。不相应义。问何故不和合。颂自答言。彼互相违碍。谓色空二互相害故。相违行相此中云何。颂言无色无空名。谓若无色即无空。以无自性故。譬如虚空莲华。其义应知。颂言名者。即印可义。印可此说无自性故。颂言色相自和合者。谓青黄赤白众色之相。而自和合。此中总意彼有自性及无自性。应知二种决定相违。复次颂言

  此一性分别　　对治种种性
  空不异彼色　　彼空何所有

所言此一性分别等者。此者。因义。由是因故。谓即表示对治止遣一性分别。是故此般若波罗蜜多教中所说。若色空即非色。此中如是为令止遣一性分别故。所以颂言。空不异彼色彼空何所有。如上颂言。对治种种性者。谓即止遣种种性中有所分别。是故此般若波罗蜜多本母中。作如是说。所谓空不异色。此如是语云何所作。以空碍色故。问何所止邪。答止遣种种性分别。此复何因。所谓彼空不异色蕴之相。色何所有。是故此说色即是空。离空无有少色可得。以无所有故。如是所说悉为止遣种种性分别散乱。问此复何因离空无色。所以颂言

  此无实所现　　彼无明所起
  此无实能表　　彼说无明故

所言此无实所现等者。无实者。谓无所有。此所出现而为对碍。颂言彼无明所起者。谓所有色彼色自性有所执着。无明所起。执著者。盖障义。若于如是不实所现中。取著有性者。是为盖障。是故此中增上意说。空不异色。问所有诸异生自性清净智。云何彼中说无明言。是故颂文破此疑言。此无实能表彼说无明故。无实者。谓不实句义。表即表了。能谓力能。为无实故。非所能表。此中总意说无明故非胜义谛。复次颂言

  此如是说色　　般若波罗蜜
  无二二如是　　二分别对治

所言此如是说色般若波罗蜜等者。谓此般若波罗蜜多所说色义。即自性清净智。而能遣除能取所取隐覆性故。般若中所说者。即慧力故。问若无明相分别起现。彼以何对治。颂自答言。无二二如是二分别对治。此中意者。若彼如是二有所现。即以胜义相中无二自性清净之智。而为对治。即对治彼有性无性二分别相。复由闻思修慧和合对治。如是对治彼二相已。此如是义是即真实如理对治。如旷野中见其阳焰妄生水想。其义应知。此中如是如来最上真实了知故。于般若波罗蜜多本母中。如实而说。复次当知。此般若波罗蜜多中所说十种分别散乱。皆以无分别智而为对治。问若如是者。何故总摄但说二种分别对治。岂非过失邪答此亦无过。谓即如是于此二中。而能隐摄。亦能止遣余诸分别。是故此意总摄二种。又问。若此二种已能隐摄余分别者。何故世尊复说多种分别散乱邪。答此中意者。但为众生意差别故。义自和合。且止斯论

佛母般若波罗蜜多圆集要义释论卷第三佛母般若波罗蜜多圆集要义释论卷第四

        三宝尊菩萨造

        大域龙菩萨造本论

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫沙门臣施护等奉　诏译

复次此中显示世尊所说正理。如彼颂言

  如理言净性　　亦然不可得
  性无性违等　　种种性定见

此云如理言等者。谓随染分别。以智对治诸有散乱。是故如理之言。世尊于般若波罗蜜多中正说。颂言净性者。谓即如理自性。清净光明。而能对治彼不清净诸有散乱。颂言亦然者。即聚集义。此一性等性所有聚集量不可得。如理之言即如量义。体即无二之智。彼能对治此为决定。问此复何等量不可得。答此说比量不可得故。所有自受非他相所增。如乐等自受。若言论安立。即如实智自性所得相违。他相有增自受不成对治量故。此中非彼所知青等相。一多性异有分别故。是故决定观察。自受成就所行悲愍。即非外门所照现性。不为他相有增动乱。何以故。所有青等诸相胜义谛中无实性故。此唯有智如实了知。此无过失。若于外事如其自受。以如是义有所安立。即不如义。此有过失。而非决定见边成就。何以故。以乐等受于外诸处无有性故。亦非异处有所伺察。此中乐等受。即乐等自性受。非乐等相受。此等所说即离能取所取二相之智。此非别异所有。问若今无彼能取所取识者。云何于后有彼识性。答此中但离能取所取相。彼后识相虽有而非语言表示。彼有之性真实表示。如理和合。是故此说彼一切识。若比量智而非此中和合所成。何以故以彼无二之相。非有二相领受所行。若有二相彼量不成。以彼二相而为对碍。如执兔角岂非过失。何以故非能取声中说有智相。以彼决定无有性故。然以彼识于外青等诸相而有对碍。彼一多伺察有堪任性。非真实意而亦非识离胜义谛有所取故。彼无性等乐取决定所有智相体性。此为能取。此为所取。此说无彼能取之相。以体及业互相乐取决定性故非智相。自受中说能取声。亦无智相。互相乐取决定自理。如是如所生性故。彼如是智相自受中而正安立。如其所说离能取所取之性。此说为无二即智相。自受现量成就。非一切真实显示和合。若复执彼决定无分位性。即无二智相中有所动乱。种子随生不随智相。无二对现所生。若执决定无二之相。此中还成执着分别。非此智相。同法之中而得成就。是故所有一切义中而成毁谤。当知世俗及胜义性。决定如是无所有义。此中显明义者。如佛所说智即是明。世俗即无明。若明若无明智。如实知别异种类。亦无所生。是故彼等如实不颠倒相。即智明相而为对治。当知决定。若彼胜义谛中决定无自性者。如虚空云彼非对治。以彼所有如理对治。真实所行得相应故。如热自性冷物对治。此不实义。表示无明亦然。以如实义说者。此无二智自性因中有其多种。若此中决定彼世俗相。计有性者。此不可说。于所行中即有二相。智实无二。问若如前言智即是明世俗即无明者。如是所说岂非此中自语相违邪。以明自性异世俗有性故。答明之无二相即是胜义性。此如是说正理成就。若世俗所欲领受。古师仙人于此语中亦有异义。如余处说此不复引。此中如后正理。颂言。性无性违等所言等者。即摄集义。非唯如前所说。正理离分别智。对治散乱。此有性无性相违。当知彼亦决定对治。谓如所有种种性等。无性自性离分别智。即是对治。当知此中若性若相。由智力能显示正义。彼复云何。胜义谛中。无有诸色。一性等生。若复无所有即种种性定见。所言定者。是决定义。即一性决定。以明力故作如是说。云何此中作如是说。所以颂言

  说此色唯名　　真实无自性
  彼自性分别　　容受即当止

此言唯名等者。谓即此般若波罗蜜多中。世尊所说此色唯名。唯名者。此即唯想。是故真实胜义谛中有所安立。然色蕴相无自性空。谓由如是因故。即自性分别。于此容受。所分别者。谓坚强性等境果自性。是故有此分别增相。乃起如是自性分别。如是所有自性分别容受多种故。此皆止止谓止遣。如是等说皆止自性分别散乱。此般若波罗蜜多本母中。复为前义遣除过失。故说颂言

  色及色自性　　空如先所说
  彼自性俱相　　分别此止遣

此言如先说等者。说谓言说。谓即如先所有。彼说何所说邪。故上颂言。色及色自性。此中空故。彼如是说遣彼自性俱相分别。上言色者。即是色之自共二相。此自共相及色自性是等皆空。于大种等俱相之中。起分别增相。彼自性俱相分别对治。问此与前第三止遣俱相分别行相云何。答若前所说俱相分别散乱者彼中色及色自性二俱有故。此中止遣俱相者。但为止其自共相故。行相云何。所谓此中坚强性等相差别而有。是谓此中俱相故此止遣。此亦非唯止遣。如是分别。余诸分别散乱亦复止遣。复次颂言

  不生不灭等　　所有诸法观
  佛言若散异　　彼差别分别

此言不生等者。谓即如是世尊于般若波罗蜜多中。作如是说。观于诸法不生不灭。是故如是言。若有散异安处。此即差别分别。若见色等差别生灭之相。即此如是色之自性差别分别。此中当离。是即止遣差别分别散乱。此如是说。亦复止遣后诸散乱。所以颂言

  虚假名言等　　彼法若分别
  声义二非合　　彼非自性意

此言虚假等者。即般若波罗蜜多本母教中。和合表示。谓虚假名即想分别说。如后般若波罗蜜多本母教中。和会别别。如是法此分别之声。所有语言法句义等。彼分别俱相。是故声义二种非自性和合。而非世尊最胜意乐。亦非他意乐。若于分别工巧造作。彼复外义取着。即诸愚者安立动乱。如是所行而非此中有少义可得。以外义执着非语义安立。开诸愚者动乱之门。此中止遣是相所行随转。即于声义无少可得。以彼如是如名分别不实有故。若于所说事相如名分别。即非意乐。由彼因故。此中一切如名如想分别和合不实。有彼所说事相故。非世尊最胜意乐。何以故。若如名于义分别。即于名义有所增广。于外事中无实能说所说性故。如是止遣如名于义分别散乱。问何等分别邪。答谓名分别。彼名亦复无有说者。是故颂言

  般若波罗蜜　　佛菩萨亦然
  此所说唯名　　离实义分别

此言般若波罗蜜等者。谓名离于义。如是名之实义。自性分别。世尊说言故此止遣。何所说邪。是故颂言。般若波罗蜜佛菩萨亦然。此既唯名般若波罗蜜多中。何处容说有实自性。谓由如来如是言故。说名之声亦无自性。此中所有各别表示佛菩萨名。当知于无二智中。非此止遣。此复何因。是故颂言

  所有声义止　　此非事止遣
  如是余亦知　　语中义决定

此言所有等者。谓即所有声义二种。此说止遣。颂言此非事止遣者。谓无二智不止此中事相作用。然彼无言之性不可说故。问今所说义是为正理。余处云何。颂自答言。如是余亦知如是者。谓即如是从初所说是义决定。余谓所余种类语中亦然。了知所谓了知此义决定。此中意者。谓于般若波罗蜜多中。如实宣说不颠倒义成就。真实了知一切名性。正不可得。以此语义施设表示。复次颂言

  此无所得正　　一切名实知
  如义性如是　　不止遣彼声

此言此无所得等者。谓如义之性。彼无所有不可得故。此说为正。此何所说邪。颂自指言。一切名。问何人能实知。答即一切智实者。不颠倒义。知谓了知。即真实知故。颂言不止遣彼声者。谓若声义二种。彼实义性说不可得。以是因故。不止彼声。谓以闻智所取之声不可止故。如是当知决定最胜意乐悲愍所行悉无障碍。如是止遣如义于名分别散乱。如是等义真实意乐说已如顺。有论颂言

  所有所有一切名　　彼彼诸法有所说
  而彼所说非实有　　即一切法同法性
  所有彼名名性空　　能名之名无所有
  而一切法本无名　　立以强名而表示
  一切唯名此当知　　一切想中假安立
  彼所聚名差别性　　当知彼名无所有

如尊者须菩提所问般若波罗蜜多中。决定止遣声义二邪。故颂释言

  须菩提二离　　声声义如是
  菩萨无有名　　我见此有说

此言须菩提等者。谓须菩提了知声义二种。离其安立。此中意者。声谓说者之声。声义谓所说之义。云何菩萨无有名。以菩萨名无所有不可见故。须菩提于般若波罗蜜多中。乃有所说。此中意者。决定二种分别性最胜意乐中。远离虚假声别异之性此中决定语言向义表示是故颂言

  般若波罗蜜　　语无决定生
  伺察唯智者　　此义微妙慧

此言般若波罗蜜等者。无谓无所有。即般若波罗蜜多中。彼和合语决定无所有。无所说无戏论。如是应知。一切语言中所说决定向义。云何是向义。谓即如前如所说义。彼解释门颂言伺察唯智者。此义微妙慧者。伺察者。谓细伺审察此义者。即三十二品诸有声中。总说决定。颂言智者。即智者之智。能知语义微妙慧者。即毕竟微妙清净之智。行相云何。谓即此智于一切境界中无著无坏。而般若波罗蜜多于响声中有所闻故。为表示此义。所以颂言

  若别义分别　　相续义除遣
  般若波罗蜜　　彼言说如响

此言相续义者。谓若往若现相续造作之义。除遣者。弃舍义。谓于如是义弃舍执着。何以故。以般若波罗蜜多若见若闻。彼有所说皆如响声又如金光对现色相。以是义故。若往若现相续造作。有所分别有所执着。皆应弃舍。由此般若波罗蜜多中。一切所说皆如响声。是义总略。复次为欲显明斯义。如有颂云

  所有诸教勿厌舍　　亦复不应生毁谤
  见如实已住真实　　以彼真实而表说

今此义中总略所成表示。颂言

  总略如是义　　般若等依止
  如是义循环　　复别义依止

此言总略如是等者。所有十万颂般若波罗蜜多总略一切如是等义。皆依止此般若波罗蜜多。相续三十二品总略摄故。如是当知。后无增广。颂言如是义循环者。谓于如是义一向重复循环研核。问研核何等义邪。颂自答言。别义依止。此中所说别义之言。即问难别义。问谓分别差别。问难有所依据。谓菩提分法佛功德蕴。于此法中。如是重复循环研核。若如是总略所说所成别义。有依据故。即三十二品各别自性收摄循环。今此所释八千颂般若波罗蜜多。一切文义普尽所释。所生福聚毕竟广大。悉用回向。故颂说言

  般若波罗蜜　　正摄八千颂
  彼所得福蕴　　皆从般若生

此言般若波罗蜜正摄八千颂者。谓此八千颂般若波罗蜜多中所说自性。八千者。此之数量普摄。如是数量中义总聚已释。颂言正者。不颠倒义。彼正教中何所生邪。颂自答言。彼所得福蕴。得者获义。如是清净所成福聚。皆从般若波罗蜜多出生。以般若波罗蜜多出生故。所得福聚甚深广大。以是所得深广福聚。普用回向一切世间。悉令获得般若波罗蜜多毕竟胜妙清净之智。于是无虚妄胜第一义诸正句中。如理伺察。我此所造解释之文。所生福聚今此说意者。普令一切世间悉得清净。颂曰

  释迦师子诸苾刍　　所有如是福高胜
  此所说意利世间　　由胜福故住真实

佛母般若波罗蜜多圆集要义释论卷第四


金刚般若波罗蜜经论

    No. 1511 [No. 1513; cf. Nos. 1512, 1514]

金刚般若波罗蜜经论卷上

        天亲菩萨造

        元魏天竺三藏菩提流支译

  法门句义及次第　　世间不解离明慧
  大智通达教我等　　归命无量功德身
  应当敬彼如是尊　　头面礼足而顶戴
  以能荷佛难胜事　　摄受众生利益故

如是我闻。一时婆伽婆。在舍婆提城祇树给孤独园。与大比丘众千二百五十人俱。尔时世尊。食时着衣持钵。入舍婆提大城乞食于其城中。次第乞食已。还至本处饭食讫。收衣钵洗足已。如常敷座结加趺坐。端身而住正念不动

尔时诸比丘来诣佛所。到已顶礼佛足。右绕三匝退坐一面

尔时慧命须菩提。在大众中即从坐起。偏袒右肩右膝着地。向佛合掌恭敬而立。白佛言。希有世尊。如来应供正遍知。善护念诸菩萨。善付嘱诸菩萨

论曰。善护念者。依根熟菩萨说。善付嘱者。依根未熟菩萨说。云何善护念诸菩萨。云何善付嘱诸菩萨。偈言

  巧护义应知　　加彼身同行
  不退得未得　　是名善付嘱

云何加彼身同行。谓于菩萨身中与智慧力。令成就佛法故。又彼菩萨摄取众生。与教化力。是名善护念应知。云何不退得未得。谓于得未得功德中。惧其退失付授智者。又得不退者。不舍大乘故。未得不退者。于大乘中欲令胜进故。是名善付嘱。应知

经曰。世尊云何菩萨大乘中。发阿耨多罗三藐三菩提心。应云何住。云何修行。云何降伏其心

尔时佛告须菩提。善哉善哉。须菩提。如汝所说。如来善护念诸菩萨。善付嘱诸菩萨。汝今谛听当为汝说。如菩萨大乘中发阿耨多罗三藐三菩提心。应如是住。如是修行。如是降伏其心。须菩提白佛言。世尊。如是愿乐欲闻。佛告须菩提。诸菩萨生如是心。所有一切众生众生所摄。若卵生。若胎生。若湿生。若化生。若有色若无色。若有想若无想。若非有想非无想。所有众生界众生所摄。我皆令入无余涅槃而灭度之。如是灭度无量无边众生。实无众生得灭度者。何以故。须菩提。若菩萨有众生相。即非菩萨。何以故非。须菩提。若菩萨起众生相人相寿者相。则不名菩萨

论曰。云何菩萨大乘中住。问答示现此义。偈言

  广大第一常　　其心不颠倒
  利益深心住　　此乘功德满

此偈说何等义。若菩萨有四种深利益菩提心。此是菩萨大乘住处。何以故。此深心功德满。足是故四种深利益摄取心生。能住大乘中

何等为四种心。一广二第一三常四不颠倒。云何广心利益。如经诸菩萨生如是心所有一切众生众生所摄。乃至所有众生界众生所摄故

云何第一心利益。如经我皆令住无余涅槃而灭度之故

云何常心利益。如经如是灭度无量无边众生实无众生得灭度者。何以故。须菩提。若菩萨有众生相即非菩萨故。此义云何。菩萨取一切众生犹如我身。以此义故。菩萨自身灭度。无异众生得灭度者。若菩萨于众生起众生想。不生我想者则不应得菩萨名。如是取众生如我身。常不舍离。是名常心利益

云何不颠倒心利益。如经。何以故非。须菩提。若菩萨起众生相人相寿者相。则不名菩萨故。此示现远离依止身见众生等相故

论曰。自此以下说菩萨如大乘中住修行。此事应知

经曰。复次须菩提。菩萨不住于事。行于布施。无所住行于布施。不住色布施。不住声香味触法布施。须菩提。菩萨应如是布施。不住于相想。何以故。若菩萨不住相布施。其福德聚不可思量。须菩提。于汝意云何。东方虚空可思量不。须菩提言。不也世尊。佛言如是。须菩提。南西北方四维上下虚空可思量不。须菩提言。不也世尊。佛言。如是如是。须菩提。菩萨无住相布施。福德聚亦复如是不可思量

佛复告须菩提。菩萨但应如是行于布施

论曰。偈言

  檀义摄于六　　资生无畏法
  此中一二三　　名为修行住

何故唯檀波罗蜜。名说六波罗蜜。一切波罗蜜檀波罗蜜相义示现故。一切波罗蜜檀相义者。谓资生无畏法檀波罗蜜应知。此义云何。资生者。即一檀波罗蜜体名故。无畏檀波罗蜜者有二。谓尸波罗蜜羼提波罗蜜。于已作未作恶不生怖畏故。法檀波罗蜜者有三。谓毗梨耶波罗蜜等不疲惓。善知心如实说法故此即是菩萨摩诃萨修行住。如向说三种檀摄六波罗蜜。是名菩萨摩诃萨修行住。云何菩萨不住于事行于布施。如是等偈言

  自身及报恩　　果报斯不着
  护存已不施　　防求于异事

不住于事者。谓不着自身。无所住者。谓不着报恩。报恩者。谓供养恭敬种种等门。如经无所住故。不住色等者。谓不着果报。何故如是不住行于布施。偈言。护存已不施防求于异事。若着自身不行布施。为护此事于身不着。若着报恩果报舍佛菩提。为异义行于布施。为防是行于事不着

自此以下说云何菩萨降伏其心。此事应知。云何降伏心。名之降伏。偈言

  调伏彼事中　　远离取相心
  及断种种疑　　亦防生成心

此文说何义。所谓不见施物受者及施者。偈言。调伏彼事中远离取相心故。如经须菩提菩萨应如是布施不住于相想故

次说布施利益。何以故。此中有疑。若离施等相想。云何能成施福。彼人如是布施。其福转多故

次说布施利益。如经。何以故。若菩萨不住相布施。其福德聚不可思量。须菩提。于意云何。东方虚空可思量不。须菩提言。不也世尊。如是等。何故说修行后。次显布施利益。以得降伏心故。是以次说布施利益。此义云何。不住相想行于布施。成就义故

自此以下一切修多罗。示现断生疑心。云何生疑。若不住于法行于布施。云何为佛菩提行于布施断彼疑心

经曰。须菩提。于意云何。可以相成就见如来不。须菩提言。不也世尊。不可以相成就得见如来。何以故。如来所说相即非相

佛告须菩提。凡所有相皆是妄语。若见诸相非相。则非妄语。如是诸相非相。则见如来

论曰。偈言

  分别有为体　　防彼成就得
  三相异体故　　离彼是如来

此义云何。若分别有为体。是如来以有为相为第一。以相成就见如来。为防彼相成就得如来身

如经。不可以相成就得见如来故。何以故。如来名无为法身故。如经。何以故。如来所说相即非相。偈言。三相异体故离彼是如来。彼相成就即非相成就。何以故。三相异如来体故

如经。佛告须菩提。凡所有相皆是妄语。若见诸相非相。则非妄语。如是诸相非相。则见如来。此句显有为虚妄故。偈言。离彼是如来。示现彼处三相无故。相非相相对故。彼处生住灭异体不可得故。此句明如来体非有为故。菩萨如是知如来为佛菩提行于布施。彼菩萨不住于法行于布施。成如是断疑故

自此以下。尊者须菩提生疑致问

经曰。须菩提白佛言。世尊。颇有众生。于未来世末世。得闻如是修多罗章句生实相不。佛告须菩提。莫作是说。颇有众生于未来世末世。得闻如是修多罗章句生实相不。佛复告须菩提。有未来世末世。有菩萨摩诃萨。法欲灭时有持戒修福德智慧者。于此修多罗章句。能生信心。以此为实

佛复告须菩提。当知彼菩萨摩诃萨非于一佛二佛三四五佛所修行供养。非于一佛二佛三四五佛所而种善根

佛复告须菩提。已于无量百千万诸佛所修行供养。无量百千万诸佛所种诸善根。闻是修多罗。乃至一念能生净信。须菩提。如来悉知是诸众生。如来悉见是诸众生。须菩提。是诸菩萨生如是无量福德聚。取如是无量福德。何以故。须菩提。是诸菩萨无复我相众生相人相寿者相。须菩提。是诸菩萨无法相亦非无法相。无相亦非无相。何以故。须菩提。是诸菩萨若取法相。则为着我人众生寿者。须菩提。若是菩萨有法相。即着我相人相众生相寿者相。何以故。须菩提。不应取法。非不取法。以是义故。如来常说筏喻法门。是法应舍。非舍法故

论曰。此义云何。向依波罗蜜说不住行于布施。说因深义。向依如来非有为体。说果深义。若尔未来恶世人不生信心。云何不空说。为断彼疑。佛答此义

如经。佛告须菩提。莫作是说。乃至非舍法故。此义云何。偈言

  说因果深义　　于彼恶世时
  不空以有实　　菩萨三德备

此义云何。彼恶世时。菩萨具足持戒功德智慧故。能生信心。以此义故名不空说。又偈言

  修戒于过去　　及种诸善根
  戒具于诸佛　　亦说功德满

如经。佛复告须菩提。当知彼菩萨摩诃萨非于一佛二佛三四五佛所修行供养。非于一佛二佛三四五佛所而种善根

佛告须菩提。已于无量百千万诸佛所修行供养。无量百千万诸佛所种诸善根故。此经文明于过去诸佛具足持戒供养彼佛。亦种诸善根。如是次第。彼持戒具足。功德具足故。又偈言

  彼寿者及法　　远离于取相
  亦说知彼相　　依八八义别

此义云何。复说般若义不断故。说何等义。明彼菩萨离于寿者相离于法相故。以对彼相故说此义。偈言。依八八义别故。此复云何。依四种寿者相。有四种义故。依四种法相有四种义故。是故依八相有八种义差别故。此义复云何。偈言

  差别相续体　　不断至命住
  复趣于异道　　是我相四种

此义云何。明寿者相义故。何者是四种。一者我相。二者众生相。三者命相。四者寿者相。我相者见五阴差别。一一阴是我。如是妄取是名我相。众生相者。见身相续不断。是名众生相。命相者。一报命根不断住故。是名命相。寿者相者。命根断灭复生六道。是名寿者相。如经。何以故。须菩提。是诸菩萨无复我相众生相人相寿者相故。云何及法。偈言

  一切空无物　　实有不可说
  依言辞而说　　是法相四种

何者是四种。一者法相。二者非法相。三者相。四者非相。此义云何。有可取能取一切法。无故言无法相。以无物故。彼法无我空实有故。言亦非无法相。彼空无物。而此不可说有无故言无相。依言辞而说故。言亦非无相。何以故。以于无言处依言相说。是故依八种差别义。离八种相。所谓离人相离法相。是故说有智慧

如经。须菩提。是诸菩萨无法相。亦非无法相。无相亦非无相故。有智慧便足。何故复说持戒功德。为示现生实相差别义故。云何示现。偈言

  彼人依信心　　恭敬生实相
  闻声不正取　　正说如是取

此义云何。彼人有持戒功德。依信心恭敬能生实相。是以说彼义故。次言闻说如是修多罗章句乃至一念生净信者。是故不但说般若。又有智慧者。不如声取义。随顺第一义智正说如是取。能生实相。是以说此义故。次言须菩提不应取法非不取法。不应取法者。不应如声取法。非不取法者。随顺第一义智正说如是取。彼菩萨闻说如是修多罗章句生实相故。又经复言。须菩提。如来悉知是诸众生。如来悉见是诸众生。如是等。此明何义。偈言

  佛非见果知　　愿智力现见
  求供养恭敬　　彼人不能说

此义云何。彼持戒等人。诸佛如来非见果比知。云何知。偈言。愿智力现见故。如来悉知是诸众生便足。何故复说。如来悉见是诸众生。若不说如来悉见是诸众生。或谓如来以比智知。恐生如是心故。若尔但言如来悉见是诸众生便足。何故复说如来悉知是诸众生。若不说如来悉知是诸众生。或谓如来以肉眼等见。为防是故。何故如是说。以有二语故。又何故如来如是说。偈言。求供养恭敬彼人不能说故。此义云何。若有人欲得供养恭敬。自叹有持戒等功德。彼人则不能说。是人自知故。诸佛如来善知彼何等人有何等行。是故彼人不能自说

又是诸菩萨生如是无量福德聚。取如是无量福德者。此义云何。生者能生因故。取者熏修自体果义故。又何以故。须菩提。是诸菩萨若取法相。则为着我人众生寿者。此义云何。但有无明使无现行粗烦恼。示无我见故。又经言。以是义故。如来常说筏喻法门。是法应舍非舍法者。有何次第。偈言

  彼不住随顺　　于法中证智
  如人舍船筏　　法中义亦然

此义云何。示修多罗等法中证智不住故。以得证智舍法故。如到彼岸舍筏故。随顺者。随顺彼证智法。彼法应取。如人未到彼岸取筏故

自此以下。说何等义。为遮异疑故。云何异疑。向说不可以相成就得见如来。何以故。如来非有为相得名故。若如是云何释迦牟尼佛。得阿耨多罗三藐三菩提。说名为佛。云何说法。是名异疑。为断此疑。云何断疑

经曰。复次佛告慧命须菩提。须菩提。于意云何。如来得阿耨多罗三藐三菩提耶。如来有所说法耶。须菩提言。如我解佛所说义。无有定法如来得阿耨多罗三藐三菩提。亦无有定法如来可说。何以故。如来所说法。皆不可取不可说。非法非非法。何以故。一切圣人皆以无为法得名

论曰。以是义故。释迦牟尼佛。非佛亦非说法。此义云何。偈言

  应化非真佛　　亦非说法者
  说法不二取　　无说离言相

此义云何。佛有三种。一者法身佛。二者报佛。三者化佛。又释迦牟尼名为佛者。此是化佛。此佛不证阿耨多罗三藐三菩提。亦不说法。如经无有定法如来得阿耨多罗三藐三菩提。亦无有定法如来可说。若尔何故经言。何以故。如来所说法皆不可取不可说。如是等。有人谤言。如来一向不说法。为遮此故。偈言。应化非真佛亦非说法者故。说法不二取无说离言相者。听者不取法不取非法故。说者亦不二说法非法故。何以故。彼法非法非非法。依何义说。依真如义说。非法者。一切法无体相故。非非法者。彼真如无我相实有故。何故唯言说不言证。有言说者。即成证义故。若不证者。则不能说。如经。何以故。一切圣人皆以无为法得名。此句明何义。彼法是说因故。何以故。一切圣人依真如法清净得名。以无为法得名故。以此义故。彼圣人说彼无为法。复以何义。如彼圣人所证法。不可如是说。何况如是取。何以故。彼法远离言语相。非可说事故。何故不但言佛。乃说一切圣人。以一切圣人依真如清净得名故。如是具足清净如分清净故

经曰。须菩提。于意云何。若满三千大千世界七宝。以用布施。须菩提。于意云何。是善男子善女人所得福德。宁为多不。须菩提言。甚多婆伽婆。甚多修伽陀。彼善男子善女人得福甚多。何以故。世尊。是福德聚即非福德聚。是故如来说福德聚福德聚

佛言。须菩提。若善男子善女人。以满三千大千世界七宝。持用布施。若复于此经中受持乃至四句偈等。为他人说。其福胜彼无量不可数。何以故。须菩提。一切诸佛阿耨多罗三藐三菩提法。皆从此经出。一切诸佛如来皆从此经生。须菩提。所谓佛法。佛法者即非佛法。是名佛法

论曰。此说胜福德譬喻校量。示现何义。法虽不可取不可说。而不空故。偈言

  受持法及说　　不空于福德
  福不趣菩提　　二能趣菩提

何故说言。世尊是福德聚即非福德聚者。偈言。福不趣菩提二能趣菩提故。此义云何。彼福德不趣大菩提。二能趣大菩提故。何者为二

一者受持。二者演说。如经受持乃至四句偈等。为他人说故。何故名福德聚。聚义有二种。一者积聚义。二者进趣义。如人担重说名为聚。如是彼福德聚以有积聚义故。说名为聚。于菩提不能进趣故。名为非福德聚。此二能趣大菩提。是故于彼福德中此福为胜。云何此二能得大菩提。如经何以故。须菩提一切诸佛阿耨多罗三藐三菩提法皆从此经出。一切诸佛如来皆从此经生故。云何说一切诸佛菩提法皆从此经出。云何说一切诸佛如来皆从此经生。偈言

  于实名了因　　亦为余生因
  唯独诸佛法　　福成第一体

此义云何。菩提者名为法身。彼体实无为。是故于彼法身。此二能作了因。不能作生因。余者受报相好庄严佛化身相好佛。于此为生因。以能作菩提因。是故名因。显彼福德中此福胜故。如经。何以故。须菩提乃至皆从此经生故。云何成此义。偈言。唯独诸佛法福成第一体故

须菩提所谓佛法佛法者即非佛法者。彼诸佛法余人不得。是故彼佛法名为佛法。是故言唯独诸佛法。第一不共义。以能作第一法因。是故彼福德中。此福为胜。如是成福德多故

经曰。须菩提。于意云何。须陀洹能作是念。我得须陀洹果不。须菩提言。不也世尊。何以故。实无有法名须陀洹。不入色声香味触法。是名须陀洹。佛言。须菩提。于意云何。斯陀含能作是念。我得斯陀含果不。须菩提言。不也世尊。何以故。实无有法名斯陀含。是名斯陀含。须菩提。于意云何。阿那含能作是念。我得阿那含果不。须菩提言。不也世尊。何以故。实无有法名阿那含是名阿那含。须菩提。于意云何。阿罗汉能作是念。我得阿罗汉不。须菩提言。不也世尊。何以故。实无有法名阿罗汉。世尊。若阿罗汉作是念。我得阿罗汉。即为着我人众生寿者。世尊。佛说我得无诤三昧最为第一。世尊。说我是离欲阿罗汉。世尊。我不作是念。我是离欲阿罗汉。世尊。我若作是念。我得阿罗汉。世尊。则不说我无诤行第一。以须菩提实无所行。而名须菩提无诤无诤行

论曰。向说圣人无为法得名。以是义故。彼法不可取不可说。若须陀洹等圣人取自果。云何言彼法不可取。既如证如说云何成不可说。自下经文为断此疑。成彼法不可取不可说故。偈言

  不可取及说　　自果不取故
  依彼善吉者　　说离二种障

此义云何。以圣人无为法得名。是故不取一法。不取者不取六尘境界。以是义故。名不取逆流者。如经不入色声香味触法。是名须陀洹故。乃至阿罗汉不取一法。以是义故。名为罗汉。然圣人非不取无为法。以取自果故。若圣人起如是心我能得果。即为着我等者。此义云何。以有使烦恼非行烦恼。何以故。彼于证时离取我等烦恼。是故无如是心我能得果。何故尊者须菩提。自叹身得受记。以自身证果。为于彼义中生信心故。何故唯说无诤行。为明胜功德故。为生深信故。何故言以须菩提实无所行。而名须菩提无诤无诤行者。偈言依彼善吉者说离二种障故。二种障者。一者烦恼障。二者三昧障。离彼二障故言无所行。以是义故。说名二种诤离彼二种障故。名为无诤无诤行

经曰。佛告须菩提。于意云何。如来昔在然灯佛所。得阿耨多罗三藐三菩提法不。须菩提言。不也世尊。如来在然灯佛所。于法实无所得阿耨多罗三藐三菩提

论曰。复有疑释迦如来昔在然灯佛所受法。彼佛为此佛说法。若如是云何彼法不可说不可取。为断此疑。说彼佛所无法可取。如经不也世尊如来在然灯佛所。于法实无所得阿耨多罗三藐三菩提故。何故如是说。偈言

  佛于然灯语　　不取理实智
  以是真实义　　成彼无取说

此义云何。释迦如来于然灯佛所。言语所说不取证法故。以是义故。显彼证智不可说不可取。偈言以是真实义成彼无取说故

又若圣人无为法得名。是法不可取不可说

云何诸菩萨取庄严净佛国土。云何受乐报佛取自法王身。云何余世间复取彼是法王身。自下经文为断此疑

经曰。佛告须菩提。若菩萨作是言。我庄严佛国土。彼菩萨不实语。何以故。须菩提。如来所说庄严佛土者。则非庄严是名庄严佛土。是故须菩提。诸菩萨摩诃萨。应如是生清净心。而无所住。不住色生心。不住声香味触法生心。应无所住而生其心

须菩提。譬如有人身如须弥山王。须菩提。于意云何。是身为大不。须菩提言。甚大世尊。何以故。佛说非身是名大身。彼身非身是名大身

论曰。此义如是应知。云何知。偈言

  智习唯识通　　如是取净土
  非形第一体　　非严庄严意

此义云何。诸佛无有庄严国土事。唯诸佛如来真实智慧习识通达。是故彼土不可取。若人取彼国土形相。作是言我成就清净佛土。彼不实说

如经。何以故。须菩提如来所说庄严佛土者。则非庄严是名庄严佛土故。何故如是说。偈言非形第一体非严庄严意故。庄严有二种。一者形相二者第一义相。是故说非严庄严。又非庄严佛土者。无有形相故非庄严。如是无庄严即是第一庄严。何以故。以一切功德成就庄严故。若人分别佛国土。是有为形相。而言我成就清净佛国土。彼菩萨住于色等境界中生如是心。为遮此故。如经是故须菩提。诸菩萨摩诃萨。应如是生清净心而无所住。不住色生心。不住声香味触法生心。应无所住而生其心故。前言云何受乐报佛取自法王身。云何余世间复取彼是法王身。为除此疑。说受乐报佛体同彼须弥山王镜像义故。此义云何偈言

  如山王无取　　受报亦复然
  远离于诸漏　　及有为法故

此义云何。如须弥山王势力高远故。名为大。而不取彼山王体我是山王。以无分别故。受乐报佛亦如是。以得无上法王体故名为大。而不取彼法王体我是法王。以无分别故。何故无分别。以无分别故

如经何以故。佛说非身是名大身。彼身非身是名大身故。何故如是说。偈言远离于诸漏及有为法故。彼受乐报佛体离于诸漏。若如是即无有物。若如是即名有物。以唯有清净身故。以远离有为法故。以是义故。实有我体以不依他缘住故

金刚般若波罗蜜经论卷上金刚般若波罗蜜经论卷中

        天亲菩萨造

        元魏天竺三藏菩提流支译

经曰。佛言须菩提。如恒河中所有沙数。如是沙等恒河。于意云何。是诸恒河沙宁为多不。须菩提言。甚多世尊。但诸恒河尚多无数。何况其沙。佛言。须菩提。我今实言告汝。若有善男子善女人。以七宝满尔所恒河沙数世界。以施诸佛如来。须菩提。于意云何。彼善男子善女人得福多不。须菩提言。甚多世尊。彼善男子善女人得福甚多。佛告须菩提。以七宝满尔所恒河沙世界持用布施。若善男子善女人。于此法门乃至受持四句偈等为他人说。而此福德胜前福德。无量阿僧祇

论曰。前已说多福德譬喻。何故此中复说。偈言

  说多义差别　　亦成胜挍量
  后福过于前　　故重说胜喻

此义云何。前说三千世界譬喻明福德多。今重说无量三千世界故。何故不先说此喻。为渐化众生令生信心上妙义故。又前未显以何等胜功德能得大菩提故。以此喻成彼功德。是故重说胜喻

经曰。复次须菩提。随所有处说是法门。乃至四句偈等。当知此处一切世间天人阿修罗皆应供养如佛塔庙。何况有人尽能受持读诵此经。须菩提。当知是人成就最上第一希有之法。若是经典所在之处。则为有佛。若尊重似佛。尔时须菩提白佛言。世尊。当何名此法门。我等云何奉持。佛告须菩提。是法门名为金刚般若波罗蜜。以是名字汝当奉持。何以故。须菩提佛说般若波罗蜜则非般若波罗蜜。须菩提。于意云何。如来有所说法不。须菩提言。世尊。如来无所说法。须菩提。于意云何。三千大千世界所有微尘是为多不。须菩提言。彼微尘甚多。世尊。何以故。须菩提。是诸微尘。如来说非微尘是名微尘。如来说世界非世界是名世界。佛言。须菩提。于意云何。可以三十二大人相见如来不。须菩提言。不也世尊。何以故。如来说三十二大人相即是非相。是名三十二大人相

论曰。云何成彼胜福。偈言

  尊重于二处　　因习证大体
  彼因习烦恼　　此降伏染福

此义云何。尊重于二处者。一者所说处。随何等处说此经。令生尊重奇特相故。二者能说人。随何等人能受持及说。以尊重经论故。非七宝等。随何处舍随何人能舍。如是生敬重故。此法门与一切诸佛如来证法作胜因故。如经须菩提言世尊如来无所说法故。此义云何。无有一法唯独如来说。余佛不说故。彼珍宝布施福德是染烦恼因。以能成就烦恼事故。此因示现远离烦恼因故。是故说地微尘喻如经须菩提是诸微尘。如来说非微尘是名微尘。如来说世界非世界是名世界故。何故如是说。彼微尘非贪等烦恼体。以是义故名为地微尘故。彼世界非烦恼染因界。是故说世界。此明何义。彼福德是烦恼尘染因。是故于外无记尘彼福德善根为近。何况此福德能成佛菩提故。及成就大丈夫相福德中胜故。是故受持演说此法门。能成佛菩提胜彼福德。何以故。彼相于佛菩提非相故。以彼非法身故。是故说大丈夫相。以彼相故。此受持及说福德能成佛菩提。是故彼非胜故。又彼福德能降伏珍宝等福。何况此福故能降伏是故。此福最近最胜。如是彼檀等福德中此福德最如是成已

经曰。佛言须菩提。若有善男子善女人。以恒河沙等身命布施。若复有人于此法门中。乃至受持四句偈等。为他人说其福甚多。无量阿僧祇。尔时须菩提。闻说是经深解义趣。涕泪悲泣扪泪而白佛言。希有婆伽婆。希有修伽陀。佛说如是甚深法门。我从昔来所得慧眼未曾得闻如是法门。何以故。须菩提。佛说般若波罗蜜。即非般若波罗蜜。世尊。若复有人得闻是经。信心清净则生实相。当知是人成就第一希有功德。世尊。是实相者则是非相。是故如来说名实相实相。世尊。我今得闻如是法门。信解受持不足为难。若当来世其有众生。得闻是法门信解受持。是人则为第一希有。何以故。此人无我相人相众生相寿者相。何以故。我相即是非相。人相众生相寿者相。即是非相。何以故。离一切诸相则名诸佛。佛告须菩提。如是如是。若复有人得闻是经。不惊不怖不畏。当知是人甚为希有。何以故。须菩提。如来说第一波罗蜜。非第一波罗蜜。如来说第一波罗蜜者。彼无量诸佛亦说波罗蜜。是名第一波罗蜜

论曰。自下经文重明彼福德中此福转胜。此义云何。偈言

  苦身胜于彼　　希有及上义
  彼智岸难量　　亦不同余法
  坚实解深义　　胜余修多罗
  大因及清净　　福中胜福德

此二偈说何义。捐舍身命重于舍资生珍宝等。彼如是舍无量身命。果报福德此福德胜彼福。何以故。彼舍身命苦身心故何况为法舍故。念彼身苦。慧命须菩提尊重法故。悲泣流泪。如经尔时须菩提闻说是经深解义趣涕泪悲泣故。此法门希有。何以故。尊者须菩提。虽有智眼昔来未曾得闻。是故希有如经我从昔来所得慧眼。未曾得闻如是法门故。又此法门第一。以说名般若波罗蜜故此云何成以上义故。如经何以故须菩提佛说般若波罗蜜。即非般若波罗蜜故。何故如是说彼智岸故。彼智岸无人能量。是故非波罗蜜又此法门不同。何以故。此中有实相故。余者非实相。除佛法余处无实故。以彼处未曾有未曾生信。以是义故。如经世尊若复有人得闻是经。信心清净则生实相。当知是人成就第一希有功德故。又此法门坚实深妙。何以故。受持此经思量修习。不起我等相故。又不起我等相者。示可取境界不倒相故。我等相即非相者。示能取境界不倒相故。此二明我空法空无我智故。如是次第如经何以故。此人无我相人相众生相寿者相。何以故。我相即是非相。人相众生相寿者相即是非相。何以故。离此一切诸相则名诸佛故。如来为须菩提说如是义。惊者谓非处生惧是故名惊。以可诃故。如非正道行故。怖者心体怖故。以起不能断疑心故。畏者一向怖故。其心毕竟惊怖堕故远离彼处。如经不惊不怖不畏故。又此法门胜余修多罗如经。何以故。须菩提如来说第一波罗蜜非第一波罗蜜故。又此法。门名为大因。如经如来说第一波罗蜜者故又此法门名为清净。以无量佛说故。如经彼无量诸佛亦说波罗蜜。是名第一波罗蜜故。彼珍宝檀等无如是功德。是故彼福德中此福为胜。如是成已

论曰。自下经文复为断疑。云何疑。向说彼身苦以彼舍身苦身果报而彼福是劣。若尔依此法门受持演说。诸菩萨行苦行。彼苦行亦是苦果。云何于此法门不成苦果。为断此疑故

经曰。须菩提如来说忍辱波罗蜜。即非忍辱波罗蜜。何以故。须菩提。如我昔为歌利王割截身体。我于尔时无我相无人相。无众生相无寿者相。无相亦非无相。何以故。须菩提。我于往昔节节支解时。若有我相人相众生相寿者相应生嗔恨。须菩提。又念过去。于五百世作忍辱仙人。于尔所世无我相无人相无众生相无寿者相。是故须菩提。菩萨应离一切相发阿耨多罗三藐三菩提心。何以故。若心有住则为非住。不应住色生心。不应住声香味触法生心。应生无所住心。是故佛说菩萨心不住色布施。须菩提。菩萨为利益一切众生。应如是布施。须菩提言。世尊。一切众生相即是非相。何以故。如来说一切众生即非众生

论曰。此示何义。偈言

  能忍于苦行　　以苦行有善
  彼福不可量　　如是最胜义
  离我及恚相　　实无于苦恼
  共乐有慈悲　　如是苦行果

此二偈说何义。虽此苦行同于苦果。而此苦行不疲惓。以有羼提波罗蜜名为第一故。彼岸有二种义。一者波罗蜜清净善根体。二者彼岸功德不可量。如经即非波罗蜜故。非波罗蜜者。无人知彼功德岸故。言非波罗蜜。是故为得第一法。此苦行胜彼舍身。何况离我相嗔恚相故。又此行无苦。不但无苦。及有乐以有慈悲故。如经我于尔时无我相。乃至无相亦非无相故。此明慈悲心相应故如是说。若有菩萨不离我相等。彼菩萨见苦行苦。亦欲舍菩提心。为彼故说如经。是故须菩提。菩萨应离一切相等。此明何义。未生第一菩提心者。有如是过。为防此过。偈言

  为不舍心起　　修行及坚固
  为忍波罗蜜　　习彼能学心

此义云何。为何等心起行相而修行。为何等心不舍相。偈言为忍波罗蜜习彼能学心故。又第一义心者。已入初地得羼提波罗蜜故。此名不住心。如经是故须菩提。菩萨应离一切相。发阿耨多罗三藐三菩提心故。何以故。示不住生心义故。若心住于色等法彼心不住佛菩提。此明不住心行于布施。此经文说不住心起行方便。以檀波罗蜜摄六波罗蜜故。云何为利益众生修行。而不名住于众生事。为断此疑。如经须菩提菩萨为利益一切众生。应如是布施故。此明何义。偈言

  修行利众生　　如是因当识
  众生及事相　　远离亦应知

此义云何。利益是因体故。彼修行利益众生。非取众生相事故。何者是众生事。偈言

  假名及阴事　　如来离彼相
  诸佛无彼二　　以见实法故

此说何义。名相众生及彼阴事故。云何彼修行远离众生事相。即彼名相相非相。以无彼实体故。以是义故。众生即非众生。以何等法。谓五阴名众生。彼五阴无众生体。以无实故。如是明法无我人无我。何以故。一切诸佛如来。远离一切相故。此句明彼二相不实。偈言如来离彼相诸佛无彼二以见实法故。此说何义。若彼二实有者。诸佛如来应有彼二相。何以故。诸佛如来实见故

经曰。须菩提。如来是真语者实语者。如语者不异语者。须菩提。如来所得法所说法。无实无妄语

论曰。此中有疑于证果中无道。云何彼于果能作因。为断此疑。如经须菩提如来是真语者实语者如语者不异语者故。此四句说何等义偈言

  果虽不住道　　而道能为因
  以诸佛实语　　彼智有四种

此义云何。彼境界有四种。是故如来有四种实语。云何四种。偈言

  实智及小乘　　说摩诃衍法
  及一切授记　　以不虚说故

此明何义。以如来实智不妄说。佛菩提及小乘大乘授记之事皆不妄说。以是四境故。次第说四语。如经须菩提如来是真语者实语者如语者不异语者故。不妄说小乘者。说小乘苦谛等唯是谛故。不妄说大乘者。说法无我真如故。真如者即是真如故。不妄说授记者。一切过去未来现在授记故。如彼义如是说不颠倒故。经复言须菩提如来所得法所说法无实无妄语者。何故如是说。偈言

  随顺彼实智　　说不实不虚
  如闻声取证　　对治如是说

此义云何。诸佛所说法。此法不能得彼法。而随顺义故。以所说法不能得彼证法。何以故。如所闻声无如是义故。是故无实。以此所说法随顺彼证法。是故无妄语。若尔何故说。如来所得法所说法。以依字句说故。何故如来前说如来是真语者。复言所说法无实无妄语。偈言如闻声取证对治如是说故

经曰须菩提。譬如有人入闇则无所见。若菩萨心住于事而行布施。亦复如是。须菩提。譬如人有目。夜分已尽日光明照见种种色。若菩萨不住于事。行于布施亦复如是

论曰。复有疑。若圣人以无为真如法得名。彼真如一切时一切处有。云何不住心。得佛菩提则非不住。若一切时一切处实有真如。何故有人能得有不得者。为断此疑故。说入闇等喻。此明何义。偈言

  时及处实有　　而不得真如
  无智以住法　　余者有智得

此义云何。一切时者。谓过现未来。一切处者。谓三世。众生实有真如法何故不得。偈言无智以住法故。彼无智以心住法故。此复何义。不清净故。以有智者心不住法。是故能得。以是义故。诸佛如来。清净真如得名。是故住心不得佛菩提。又此譬喻明于何义。偈言

  闇明愚无智　　明者如有智
  对治及对法　　得灭法如是

此义云何。彼闇明喻者。相似法故。闇者示现无智。日光明者。示现有智。有目者明何义。偈言对治及对法得灭法。如是故如是次第。又有目者。如能对治法故。夜分已尽者。如所治暗法尽故。日光明照者。如能治法现前故。如经须菩提譬如有人入暗则无所见如是等故

经曰。复次须菩提。若有善男子善女人。能于此法门受持读诵修行。则为如来以佛智慧悉知是人。悉见是人。悉觉是人。皆得成就无量无边功德聚。须菩提。若有善男子善女人。初日分以恒河沙等身布施。中日分复以恒河沙等身布施。后日分复以恒河沙等身布施。如是舍恒河沙等无量身。如是百千万亿那由他劫以身布施。若复有人闻此法门。信心不谤。其福胜彼无量阿僧祇。何况书写受持读诵修行为人广说

论曰。自下复说何义。偈言

  于何法修行　　得何等福德
  复成就何业　　如是说修行

于何法修行者。示现彼行。云何示现。偈言

  名字三种法　　受持闻广说
  修从他及内　　得闻是修智

此说何义。于彼名字得成闻慧。此有三种。一者受二者持三者读诵。此云何知。偈言受持闻广说故。受持修行依总持法故。读诵修行依闻慧广故。广多读习亦名闻慧。此是名字中三种修行。如经复次须菩提若有善男子善女人。能于此法门受持读诵故。彼修行云何得。偈言修从他及内得闻是修智故。此义云何。为修得相。于他及自身。云何于他及自身。谓闻及修如是次第。从他闻法内自思惟为得修行故。向说名字及以修行。此为自身。偈言

  此为自淳熟　　余者化众生
  以事及时大　　福中胜福德

此义云何。彼名字闻慧修行为自身淳熟故。余者化众生广说法故。得何等福德者。示现胜挍量福德故。偈言以事及时大福中胜福德故。此舍身福德胜于前舍身福德。云何胜以事胜故。以时大故。即一日时多舍身故。复多时故。如经须菩提若善男子善女人。初日分以恒河沙等身布施。乃至若复有人闻此法门信心不谤。其福胜彼无量阿僧祇。何况书写受持读诵修行。为人广说故

经曰。须菩提。以要言之。是经有不可思议不可称量无边功德。此法门如来为发大乘者说。为发最上乘者说。若有人能受持读诵修行此经广为人说。如来悉知是人悉见是人。皆成就不可思议不可称无有边无量功德聚。如是人等。则为荷担如来阿耨多罗三藐三菩提。何以故。须菩提。若乐小法者。则于此经不能受持读诵修行为人解说。若有我见众生见人见寿者见。于此法门能受持读诵修行为人解说者。无有是处。须菩提。在在处处若有此经。一切世间天人阿修罗所应供养。当知此处则为是塔。皆应恭敬作礼围绕。以诸花香而散其处。复次须菩提。若善男子善女人。受持读诵此经为人轻贱。何以故。是人先世罪业应堕恶道。以今世人轻贱故。先世罪业则为消灭。当得阿耨多罗三藐三菩提。须菩提。我念过去无量阿僧祇阿僧祇劫。于然灯佛前得值八十四亿那由他百千万诸佛。我皆亲承供养无空过者。须菩提。如是无量诸佛。我皆亲承供养无空过者。若复有人于后世末世。能受持读诵修行此经所得功德。我所供养诸佛功德。于彼百分不及一。千万亿分乃至算数譬喻所不能及。须菩提。若有善男子善女人。于后世末世。有受持读诵修行此经。所得功德若我具说者。或有人闻心则狂乱疑惑不信。须菩提。当知是法门不可思议。果报亦不可思议

论曰。复成就何业修行者。今显彼修行业。偈言

  非余者境界　　唯依大人说
  及希闻信法　　满足无上界
  受持真妙法　　尊重身得福
  及远离诸障　　复能速证法
  成种种势力　　得大妙果报
  如是等胜业　　于法修行知

此三行偈。说何等义。有不可思议者。示不可思议境界故。不可称量者。谓唯独大人不共声闻等。以为住第一大乘众生说故。此示依止大人故。又说大乘者。最妙大乘修行胜故。以信小乘等则不能闻此。示希闻而能信法故。如经以要言之。是经有不可思议不可称量无边功德。如来为发大乘者说。为发最上乘者说故。希闻者。谓不可思议等文句。得不可思议等福德显满足性故。以福德善根满足故。此说不可思议等文句。如经皆成就不可思议不可称无有边无量功德聚故。如是人等则。为荷担如来阿耨多罗三藐三菩提者。示现受持真妙法故。受持法者。即是荷担大菩提。如经如是人等则为荷担如来阿耨多罗三藐三菩提故。在在处处供养者。当知是人必定成就无量功德。如经在在处处若有此经一切世间天人阿修罗所应供养。当知此处则为是塔。皆应恭敬作礼。围绕以诸花香而散其处故。受持读诵此经为人轻贱者。示现远离一切诸障故。何故为人轻贱而离诸障。以有大功德故。如经是人先世罪业则为消灭故。于然灯佛前供养诸佛功德。于后末世受持此法门功德福多于彼者。此示速证菩提法故。以多福德庄严速疾满足故。如经若复有人于后世末世。能受持读诵修行此经所得功德。我所供养诸佛功德。于彼百分不及一。千万亿分乃至算数譬喻所不能及故。当知。是法门不可思议。果报亦不可思议者。此明何义。偈言。成种种势力。得大妙果报故。所谓摄受四天王释提桓因梵天王等。成就势力故。若闻此事其心迷乱者。以彼果报不可思议甚为胜妙。示非思量智境界故。住彼修行中成如是等功德。是故彼修行等业。应知。如经当知是法门不可思议。果报亦不可思议故

经曰。尔时须菩提白佛言。世尊。云何菩萨发阿耨多罗三藐三菩提心。云何住。云何修行。云何降伏其心。佛告须菩提。菩萨发阿耨多罗三藐三菩提心者。当生如是心。我应灭度一切众生。令入无余涅槃界。如是灭度一切众生已。而无一众生实灭度者。何以故须菩提。若菩萨有众生相人相寿者相。则非菩萨。何以故。须菩提。实无有法名为菩萨发阿耨多罗三藐三菩提心者故

论曰。何故前说三种修行。今复重说此有何胜。偈言

  于内心修行　　存我为菩萨
  此即障于心　　违于不住道

此义云何。若菩萨于自身三种修行。生如是心。我住于菩萨大乘。我如是修行。我如是降伏其心。菩萨生此分别。则障于菩提行。偈言。于内心修行存我为菩萨。此即障于心故。障何等心。偈言。违于不住道故。如经何以故。须菩提。实无有法名为菩萨发阿耨多罗三藐三菩提心者故

经曰。须菩提。于意云何。如来于然灯佛所。有法得阿耨多罗三藐三菩提不。须菩提白佛言。不也世尊。如我解佛所说义。佛于然灯佛所。无有法得阿耨多罗三藐三菩提。佛言。如是如是。须菩提。实无有法如来于然灯佛所。得阿耨多罗三藐三菩提。须菩提。若有法如来得阿耨多罗三藐三菩提者。然灯佛则不与我授记。汝于来世当得作佛。号释迦牟尼。以实无有法得阿耨多罗三藐三菩提。是故然灯佛与我授记。作如是言。摩那婆。汝于来世当得作佛。号释迦牟尼。何以故。须菩提言。如来者即实真如。须菩提。若有人言。如来得阿耨多罗三藐三菩提者。是人不实语。须菩提。实无有法佛得阿耨多罗三藐三菩提。须菩提如来所得阿耨多罗三藐三菩提。于是中不实不妄语。是故如来说一切法皆是佛法。须菩提。所言一切法一切法者。即非一切法。是故名一切法

论曰。此中有疑。若无菩萨云何释迦如来于然灯佛所。行菩萨行。为断此疑。如经须菩提。于意云何。如来于然灯佛所。有法得阿耨多罗三藐三菩提不。不也世尊。如是等。此明何义偈言

  以后时授记　　然灯行非上
  菩提彼行等　　非实有为相

此义云何。于然灯佛时。非第一菩萨行。何以故。我于彼时所修诸行。无有一法得阿耨多罗三藐三菩提。若我于彼佛所。已证菩提。则后时诸佛不授我记。是故我于彼时行未成佛故。偈言。以后时授记然灯行非上故。若无菩提即无诸佛如来。有如是谤。谓一向无诸佛。为断此疑。如经何以故。须菩提言。如来者即实真如故。实者非颠倒义故。真如者不异不变故。须菩提若有人言。如来得阿耨多罗三藐三菩提者。此示何义。偈言。菩提彼行等故。此义云何。彼菩萨行若人言有实者此则虚妄。如是如来得阿耨多罗三藐三菩提。若人言得者。此亦虚妄故。言菩提彼行等故。若如是有人谤言。如来不得阿耨多罗三藐三菩提。为断此疑。如经须菩提。如来所得阿耨多罗三藐三菩提法。不实不妄语故。此义云何。以如来得彼菩提故。偈言。非实有为相故。有为相者。谓五阴相。彼菩提法无色等相故。此复云何。偈言

  彼即非相相　　以不虚妄说
  是法诸佛法　　一切自体相

此义云何。彼即于色等非相。无色等相故。彼即菩提相故。是故偈言。彼即非相相。以不虚妄说故。是故如来说一切法佛法如是等。此义云何。以如来得如是法。偈言。是法诸佛法一切自体相故。自体相者。非体自体故。此明何义。一切法真如体故。彼法如来所证。是故言一切法佛法。彼处色等相不住故。彼一切色等诸法非法。如是诸法非法。即是诸法法以无彼法相。常不住持彼法相故

经曰。须菩提。譬如有人其身妙大。须菩提言。世尊。如来说人身妙大则非大身。是故如来说名大身

论曰。大身譬喻示现何义。偈言

  依彼法身佛　　故说大身喻
  身离一切障　　及遍一切境
  功德及大体　　故即说大身
  非身即是身　　是故说非身

此二偈示何义。毕竟远离烦恼障智障。毕竟具足法身故。此复云何有二种义。一者遍一切处。二者功德大。是故名大身。偈言。功德及大体故。遍一切处者。真如一切法不差别故。偈言。非身即是身是故说非身故。如经世尊如来说人身妙大。则非大身。是故如来说名大身故。此说何义。非身者无有诸相。是名非身大者。有真如体。如是即名妙大身。如经是名妙大身故

经曰。佛言。须菩提。菩萨亦如是。若作是言。我当灭度无量众生则非菩萨。佛言。须菩提。于意云何。颇有实法名为菩萨。须菩提言。不也世尊。实无有法名为菩萨。是故佛说一切法无我无众生无人无寿者。须菩提。若菩萨作是言。我庄严佛国土。是不名菩萨。何以故。如来说庄严佛土。庄严佛土者。即非庄严。是名庄严佛国土。须菩提。若菩萨通达无我无我法者。如来说名真是菩萨菩萨

论曰。此中有疑。若无菩萨者。诸佛亦不成大菩提。众生亦不入大涅槃。亦无清净佛国土。若如是为何义故。诸菩萨摩诃萨。发心欲令众生入涅槃。起心修行清净佛国土。自下经文为断此疑。云何断疑。偈言

  不达真法界　　起度众生意
  及清净国土　　生心即是倒

此义云何。若起如是心即是颠倒非菩萨者。起何等心名为菩萨。如经须菩提若菩萨通达无我无我法者。如来说名真是菩萨菩萨故。此示何义。偈言

  众生及菩萨　　知诸法无我
  非圣自智信　　及圣以有智

此明何义。知无我无我法者。谓众生及菩萨。何等众生何等菩萨。于彼法若能自智信。若世间智出世间智。所谓凡夫圣人。是人名为菩萨。此言摄世谛菩萨出世谛菩萨。是故重说菩萨菩萨。如经如来说名真是菩萨菩萨故

金刚般若波罗蜜经论卷中金刚般若波罗蜜经论卷下

        天亲菩萨造

        元魏天竺三藏菩提流支译

经曰。须菩提。于意云何。如来有肉眼不。须菩提言。如是世尊。如来有肉眼。佛言。须菩提。于意云何。如来有天眼不。须菩提言。如是世尊。如来有天眼。佛言。须菩提。于意云何。如来有慧眼不。须菩提言。如是世尊。如来有慧眼。佛言。须菩提。于意云何。如来有法眼不。须菩提言。如是世尊。如来有法眼。佛言。须菩提。于意云何。如来有佛眼不。须菩提言。如是世尊。如来有佛眼。佛言。须菩提。于意云何。如恒河中所有沙。佛说是沙不。须菩提言。如是世尊。如来说是沙。佛言。须菩提。于意云何。如一恒河中所有沙。有如是等恒河。是诸恒河所有沙数佛世界。如是世界宁为多不。须菩提言。彼世界甚多世尊。佛告须菩提。尔所世界中所有众生。若干种心住如来悉知。何以故。如来说诸心住皆为非心住。是名为心住。何以故。须菩提。过去心不可得。现在心不可得。未来心不可得。须菩提。于意云何。若有人以满三千大千世界七宝持用布施。是善男子善女人。以是因缘得福多不。须菩提言。如是世尊。此人以是因缘得福甚多。佛言。如是如是。须菩提。彼善男子善女人。以是因缘得福德聚多。须菩提。若福德聚有实。如来则不说福德聚福德聚

论曰。复有疑。前说菩萨不见彼是众生。不见我为菩萨。不见清净佛国土。何以故。以不见诸法名为诸佛如来。若如是或谓。诸佛如来不见诸法。自下经文为断此疑故。说五种眼。偈言

  虽不见诸法　　非无了境眼
  诸佛五种实　　以见彼颠倒

何故说彼非颠倒。为显断疑譬喻。是故说我知彼种种心住如是等。此示何义。彼非颠倒。以见颠倒故。何者是颠倒。偈言

  种种颠倒识　　以离于实念
  不住彼实智　　是故说颠倒

此义云何。种种颠倒者。彼种种心缘住。是名种种识。以六种识差别颠倒。何故彼心住名为颠倒。偈言。以离于实念不住彼实智。是故说颠倒故。如来说诸心住皆为非心住者。此句示现远离四念处故。此以何义。心住者住彼念处。以离彼念处故云不住。又住不动根本名异义一。若如是不住是故说心住。此明不住相续不断行因是故不住。示彼相续颠倒如经。何以故须菩提。过去心不可得。现在心不可得。未来心不可得。以过去未来故不可得。现在心虚妄分别故不可得。如是示彼心住颠倒。诸识虚妄以无三世观故。何故依福德重说譬喻。偈言

  佛智慧根本　　非颠倒功德
  以是福德相　　故重说譬喻

此说何义。复有疑。向说心住颠倒。若如是福德亦是颠倒。若是颠倒何名善法。为断此疑示现心住。虽颠倒福德非颠倒。何以故。偈言。佛智慧根本故。云何示现根本。如经。须菩提。若福德有实。如来则不说福德聚福德聚故。此义云何。明有漏福德聚是其颠倒。以此福德聚是有漏故。所以如来不说福德聚。又福德聚者。即福德聚。何以故。若非福德聚者。如来则不说为智慧根本。是故福德聚者。即福德聚

经曰。须菩提。于意云何。佛可以具足色身见不。须菩提言。不也世尊。如来不应以色身见。何以故。如来说具足色身。即非具足色身。是故如来说名具足色身。佛言。须菩提。于意云何。如来可以具足诸相见不。须菩提言。不也世尊。如来不应以具足诸相见。何以故。如来说诸相具足即非具足。是故如来说名诸相具足

论曰。复有疑。若诸佛以无为法得名。云何诸佛成就八十种好三十二相。而名为佛。为断此疑。是故说非成就色身。非成就诸相得见如来。又色身摄得八十种好三十二相。如经。何以故。如来说具足色身。即非具足色身。是故如来说名具足色身。何以故。如来说诸相具足即非具足。是故如来说名诸相具足故。何故如是说。偈言

  法身毕竟体　　非彼相好身
  以非相成就　　非彼法身故
  不离于法身　　彼二非不佛
  故重说成就　　亦无二及有

此二偈说何义。彼法身毕竟体。非色身成就。亦非诸相成就。以非彼身故。非彼身者。以非彼法身相故。此二非不佛。即彼如来身有故。何者是二。一者色身成就。二者诸相成就。以此二法不离于法身。是故彼如来身成就相好。亦得说有。云何说有。经言。色身成就诸相成就故。是故偈言。彼二非不佛故。是故此二亦得言无故。说非身成就非相成就。亦得言有故。说色身成就诸相成就故。偈言。亦无二及有故。何故如是说。以彼法身中无。即于是义说。如来色身成就。诸相成就。以不离彼身故。而法身不如是说。以法身非彼体故

经曰。佛言。须菩提。于意云何。汝谓如来作是念。我当有所说法耶。须菩提。莫作是念。何以故。若人言如来有所说法则为谤佛。不能解我所说故。何以故。须菩提。如来说法说法者。无法可说。是名说法

论曰。复有疑。若如来具足色身成就不可得见。若相成就不可得见。云何言如来说法。自下经文为断此疑。如经。若人言。如来有所说法。则为谤佛。不能解我所说故。此义云何。偈言

  如佛法亦然　　所说二差别
  不离于法界　　说法无自相

何故重言说法说法者。偈言。所说二差别故。何者是二。一者所说法。二者所有义。何故言无法可说是名说法者。偈言。不离于法界。说法无自相故。此以何义。所说法离于真法界。不可得自相见故

经曰。尔时慧命须菩提白佛言。世尊。颇有众生于未来世闻说是法生信心不。佛言。须菩提。彼非众生非不众生。何以故。须菩提。众生众生者。如来说非众生。是名众生

论曰。复有疑。若言诸佛说者。是无所说法不离于法身。亦是其无有何等人。能信如是甚深法界。自下经文为断此疑。偈言

  所说说者深　　非无能信者
  非众生众生　　非圣非不圣

何故言须菩提非众生非不众生者。偈言。非众生众生非圣非不圣故。此以何义。若有信此经。彼人非众生。非众生者。非无圣体。非无圣体者。非凡夫体故。非不众生者。以有圣体故。彼人非凡夫众生。非不是圣体众生。如经。何以故。须菩提众生众生者。如来说非众生。是名众生故。如来说非众生者。非凡夫众生。是故说众生众生。以圣人众生是故说非众生

经曰。佛言。须菩提。于意云何。如来得阿耨多罗三藐三菩提耶。须菩提言。不也世尊。世尊无有少法如来得阿耨多罗三藐三菩提。佛言。如是如是。须菩提。我于阿耨多罗三藐三菩提。乃至无有少法可得。是名阿耨多罗三藐三菩提。复次须菩提。是法平等无有高下。是名阿耨多罗三藐三菩提。以无众生无人无寿者。得平等阿耨多罗三藐三菩提。一切善法得阿耨多罗三藐三菩提。须菩提。所言善法善法者。如来说非善法。是名善法

论曰。复有疑。若如来不得一法名阿耨多罗三藐三菩提者。云何离于上上证。转转得阿耨多罗三藐三菩提。自下经文为断此疑。示现非证法名为得阿耨多罗三藐三菩提。此义云何。偈言

  彼处无少法　　知菩提无上
  法界不增减　　净平等自相
  有无上方便　　及离于漏法
  是故非净法　　即是清净法

此明何义。彼菩提处无有一法可证。名为阿耨多罗三藐三菩提。如经世尊无有少法如来得阿耨多罗三藐三菩提法故。彼复有何义。偈言。法界不增减。不增减者。是法平等。是故名无上。以更无上上故。如轻。复次须菩提是法平等无有高下。是名阿耨多罗三藐三菩提故。又诸佛如来清净法身。平等无差别。于彼处无有胜者。是故说无上。如经以无众生无人无寿者。得平等阿耨多罗三藐三菩提故。又彼法无我自体真实。更无上上故。名阿耨多罗三藐三菩提故。又彼法有无上方便。以一切善法满足故。说阿耨多罗三藐三菩提。余菩提者善法不满足。更有上方便。如经。一切善法得阿耨多罗三藐三菩提故。须菩提所言善法善法者。如来说非善法。是名善法者。何故如是说。偈言。及离于漏法是故彼漏非是净法此即是清净法故。此以何义。彼法无有漏法故。名非善法。以无有漏法故。是故名为善法。以决定无漏善法故

经曰。须菩提。三千大千世界中。所有诸须弥山王。如是等七宝聚。有人持用布施。若人以此般若波罗蜜经。乃至四句偈等。受持读诵为他人说。于前福德百分不及一。千分不及一。百千万分不及一。歌罗分不及一。数分不及一。优波尼沙陀分不及一。乃至算数譬喻所不能及

论曰。复有疑。若一切善法满足。得阿耨多罗三藐三菩提者。则所说法不能得大菩提。何以故。以所说法无记法故。为断此疑。重说胜福譬喻。示现何义。偈言

  虽言无记法　　而说是彼因
  是故一法宝　　胜无量珍宝

此义云何。虽言所说法是无记。而能得大菩提。何以故。以远离所说法不能得大菩提。以是义故。此法能为菩提因。又言无记者。此义不然。何以故。汝法是无记而我法是记。偈言。是故一法宝胜无量珍宝故。是故此所说法。胜彼阿僧祇须弥等珍宝故。如经。若人以此般若波罗蜜经。乃至一四句偈等。受持读诵为他人说。于前福德百分不及一如是等。此示何义。偈言

  数力无似胜　　无似因亦然
  一切世间法　　不可得为喻

此说何等义。示于前福德此福为胜。云何为胜。一者数胜。二者力胜。三者不相似胜。四者因胜。是故偈言。一切世间法不可得为喻故数胜者。如经百分不及一。乃至算数譬喻所不能及故。以数无限齐故。摄得余数应知力胜者。如经。不及一歌罗分故。无似胜者。此福德中数不相似。以此福德不可数故。如经数不能及故。因胜者。因果不相似。以此因果胜彼因果故。如经。乃至优波尼沙陀分不及一故。又此法最胜无有世间法可喻此法故。偈言。一切世间法不可得为喻故。如是此福德中彼福微少。是故无法可喻

经曰。须菩提。于意云何。汝谓如来作是念。我度众生耶。须菩提。莫作是见。何以故。实无有众生如来度者。佛言。须菩提。若有实众生如来度者。如来则有我人众生寿者相。须菩提。如来说有我者。则非有我。而毛道凡夫生者。以为有我。须菩提。毛道凡夫生者。如来说名非生。是故言毛道凡夫生

论曰。复有疑。若是法平等相无有高下者。云何如来名为度众生。自下经文为断此疑。云何断疑。偈言

  平等真法界　　佛不度众生
  以名共彼阴　　不离于法界

此义云何。众生假名与五阴共故。彼名共阴。不离于法界。偈言。不离于法界故。彼法界无差别故。偈言。平等真法界故。是故如来不度一众生。偈言。佛不度众生故。如经何以故。实无有众生如来度者故。佛言。须菩提。若有实众生如来度者。如来则有我人众生寿者相者。此明何义。偈言

  取我度为过　　以取彼法是
  取度众生故　　不取取应知

此义云何。若如来有如是心。五阴中有众生可度者。此是取相过。以着彼法故。偈言。取我度为过故。以取彼法是者。以取五阴中是众生故。取度众生故者。欲令众生得解脱。有如是相故。经复言须菩提如来说有我者。则非有我。而毛道凡夫生者。以为有我者。此义云何。偈言。不取取应知故。此以何义。以彼不实义。是故彼不取。以不取者即是毛道凡夫取而即是不取故。言不取取故。又须菩提毛道凡夫生者。如来说名非生者。不生圣人法故言非生

经曰。须菩提。于意云何。可以相成就得见如来不。须菩提言。如我解如来所说义。不以相成就得见如来。佛言。如是如是。须菩提。不以相成就得见如来。佛言。须菩提。若以相成就观如来者。转轮圣王应是如来。是故非以相成就得见如来

论曰。复有疑。虽相成就不可得见如来。以非彼体。以如来法身为体。而如来法身以见相成就。比知则知如来法身为福相成就。自下经文为断此疑。云何断疑。偈言

  非是色身相　　可比知如来
  诸佛唯法身　　转轮王非佛

此义云何。有人言。福德能成是相果报。以成是相故。则知福德力得大菩提。若如是如来则以相成就得阿耨多罗三藐三菩提。为遮此故。如经。若以相成就观如来者。转轮圣王应是如来。是故非以相成就得见如来故此义云何。偈言

  非相好果报　　依福德成就
  而得真法身　　方便异相故

此明何义。法身者。是智相身。福德者。是异相身故

经曰。尔时世尊而说偈言

  若以色见我　　以音声求我
  是人行邪道　　不能见如来
  彼如来妙体　　即法身诸佛
  法体不可见　　彼识不能知

论曰。此二偈说何义。偈言

  唯见色闻声　　是人不知佛
  以真如法身　　非是识境故

此示何义。如来法身不应如是见闻。不应如是见闻者。不应如是见色闻声。以何等人不能见。谓凡夫不能见故。偈言。唯见色闻声是人不知佛故。如经。是人行邪道不能见如来故。是人者。是凡夫人不能见真如法身。如经。彼如来妙体即法身诸佛。法体不可见彼识不能知故

经曰。须菩提。于意云何。如来可以相成就。得阿耨多罗三藐三菩提耶。须菩提。莫作是念。如来以相成就得阿耨多罗三藐三菩提。须菩提。汝若作是念。菩萨发阿耨多罗三藐三菩提心者。说诸法断灭相。须菩提。莫作是念。何以故。菩萨发阿耨多罗三藐三菩提心者。不说诸法断灭相故。须菩提。若善男子善女人。以满恒河沙等世界七宝持用布施。若有菩萨知一切法无我。得无生法忍。此功德胜前所得福德。须菩提。以诸菩萨不取福德故。须菩提白佛言。世尊。菩萨云何不取福德。佛言。须菩提。菩萨受福德不取福德。是故菩萨取福德

论曰。有人起如是心。若不依福德得大菩提。如是诸菩萨摩诃萨则失福德。及失果报。自下经文为断此疑。云何断疑。偈言

  不失功德因　　及彼胜果报
  得胜忍不失　　以得无垢果
  示胜福德相　　是故说譬喻
  是福德无报　　如是受不取

此义云何。虽不依福德得真菩提。而不失福德及彼果报。何以故。以能成就智慧庄严功德庄严故。何故依彼福德重说譬喻。偈言。得胜忍不失以得无垢果故。此义云何。有人起如是心。诸菩萨摩诃萨得无生法忍。以得出世间智。失彼福德及以果报。为遮此故。示现福德不失。而更得清净殊胜功德。是故不失。如经何以故菩萨发阿耨多罗三藐三菩提心者。于法不说断灭相故。若复有菩萨知一切法无我。得无生法忍者。有二种无我。不生二种无我相。是故受而不取。如经佛言。须菩提。菩萨受福德不取福德。是故菩萨取福德故。云何菩萨受福德不取福德。偈言。是福德无报。如是受不取故。此义云何。取者彼福德得有漏果报。以有漏果报故。彼福德可诃。如是取者名之为取。如取非道故。此福德无报。无报者。无彼有漏报。是故此福德受而不取

经曰。须菩提。若有人言。如来若去若来。若住若坐若卧。是人不解我所说义。何以故如来者无所至去无所从来。故名如来

论曰。若诸菩萨不受彼果报。云何诸菩萨福德众生受用。偈言

  是福德应报　　为化诸众生
  自然如是业　　诸佛现十方

此义云何。明诸佛化身有用。彼法身诸佛。不去不来故。偈言。自然如是业。诸佛现十方故。此复何义。偈言

  去来化身佛　　如来常不动
  于是法界处　　非一亦不异

此明不去不来义故。如经何以故如来者。无所至去无所从来故。此义云何。若如来有去来差别。即不得言常。如是住常如是住者。不变不异故

经曰。须菩提若善男子善女人。以三千大千世界微尘。复以尔许微尘世界碎为微尘阿僧祇。须菩提于意云何。是微尘众宁为多不。须菩提言。彼微尘众甚多。世尊。何以故。若是微尘众实有者。佛则不说是微尘众。何以故。佛说微尘众则非微尘众。是故佛说微尘众。世尊如来所说三千大千世界。则非世界。是故佛说三千大千世界。何以故。若世界实有者。则是一合相。如来说一合相则非一合相。是故佛说一合相。佛言。须菩提。一合相者。则是不可说。但凡夫之人贪着其事。何以故。须菩提若人如是言。佛说我见人见众生见寿者见。须菩提于意云何。是人所说为正语不。须菩提言。不也世尊。何以故。世尊如来说。我见人见众生见寿者见。即非我见人见众生见寿者见。是名我见人见众生见寿者见。须菩提菩萨发阿耨多罗三藐三菩提心者。于一切法应如是知。如是见如是信。如是不住法相。何以故。须菩提所言法相。法相者。如来说即非法相。是名法相。须菩提若有菩萨摩诃萨。以满无量阿僧祇世界七宝持用布施。若有善男子善女人。发菩萨心者。于此般若波罗蜜经乃至四句偈等。受持读诵为他人说。其福胜彼无量阿僧祇。云何为人演说。而不名说是名为说

论曰。碎微尘譬喻者。示现何义。偈言

  世界作微尘　　此喻示彼义
  微尘碎为末　　示现烦恼尽

此明何义。偈言于是法界处非一亦非异故。彼诸佛如来。于真如法界中。非一处住。亦非异处住。为示此义故。说世界碎微尘喻。此喻示现何义。偈言微尘碎为末示现烦恼尽故。此喻非聚集微尘众。示现非一喻。此义云何。偈言

  非聚集故集　　非唯是一喻
  聚集处非彼　　非是差别喻

此义云何。如微尘碎为末非一处住。以无有聚集物故。亦非异处差别。以聚集微尘差别不可得故。以差别不住故。如是诸佛如来。远离烦恼障。住彼法界中。非一处住亦非异处住。如是三千世界一合相喻。非聚集故。此以何义。如经如来说一合相则非一合相是故如来说一合相故。若实有一物聚集。如来则不说微尘聚集。如是若实有一世界。如来则不说三千大千世界。如经若世界实有者则是一合相故。但凡夫之人贪着其事者。以彼聚集无物可取。虚妄分别。是故凡夫妄取。若有实者即是正见故知妄取。何故凡夫无物而取物。如经佛言须菩提一合相者则是不可说但凡夫之人贪着其事如是等。此示何义。偈言

  但随于音声　　凡夫取颠倒
  非无二得道　　远离于我法

如经何以故。须菩提。若人如是言。佛说我见人见众生见寿者见。如是乃至是名我见人见众生见寿者见故。此复何义。偈言非无二得道远离于我法故。此义云何。非无我无法。离此二事而得菩提。云何得菩提。远离彼二见故得于菩提。偈言远离于我法故。此复何义。偈言

  见我即不见　　无实虚妄见
  此是微细障　　见真如远离

是故见即不见。无其实义以虚妄分别。以是无我。是故如来说彼我见即是不见。以其无实。无实者。即是无物。以是义故。说我见即是虚妄见。如是示现我见不见故。见法者亦是不见。如经须菩提菩萨发阿耨多罗三藐三菩提心于一切法应如是知如是见如是信如是不住法相故。此复何义。以见法相即不见相。如彼我见即非见故。何故此二见说名不见。偈言此是微细障见真如远离故。此复云何。彼见我见法。此是微细障。以不见彼二故。是以见法而得远离。偈言见真如远离故。又如是知如是见如是信者。此示何义。偈言

  二智及三昧　　如是得远离
  化身示现福　　非无无尽福

此义云何。示现世智第一义智。及依止三昧得远离彼障。是故重说胜福譬喻。此示何义。偈言化身示现福非无无尽福故。此复何义。虽诸佛自然化身作业。而彼诸佛化身说法。有无量无尽无漏功德故。云何为人演说而不名说是名为说者。何故如是说。偈言

  诸佛说法时　　不言是化身
  以不如是说　　是故彼说正

此义云何。若化身诸佛说法时。不言我是化身。是故彼所说是正说。若不如是说者。可化众生不生敬心。何以故。以不能利益众生。即彼说是不正说。是故不说我是化佛

经曰

  一切有为法　　如星翳灯幻
  露泡梦电云　　应作如是观

论曰。复有疑。若诸佛如来常为众生说法。云何言如来入涅槃为断此疑。是故如来说彼偈喻。此义云何。偈言

  非有为非离　　诸如来涅槃
  九种有为法　　妙智正观故

此义云何。诸佛涅槃非有为法。亦不离有为法。何以故。以诸佛得涅槃。化身说法示现世间行。为利益众生故。此明诸佛以不住涅槃以不住世间故。何故诸佛示现世间行。而不住有为法中。偈言九种有为法妙智正观故。此以何义。如星宿等相对法。九种正观故。此九种正观。于九种境界应知观何境界。偈言

  见相及于识　　器身受用事
  过去现在法　　亦观未来世

云何观九种法。譬如星宿为日所映有而不现。能见心法亦复如是。又如目有翳则见毛轮等色。观有为法亦复如是。以颠倒见故。又如灯识亦如是。依止贪爱法住故。又如幻所依住处亦如是。以器世间种种差别无一体实故。又如露身亦如是。以少时住故。又如泡所受用事亦如是。以受想因三法不定故。又如梦过去法亦如是。以唯念故。又如电现在法亦如是。以刹那不住故。又如云未来法亦如是。以于子时阿黎耶识。与一切法为种子根本故。观如是九种法。得何等功德成就何智。偈言

  观相及受用　　观于三世事
  于有为法中　　得无垢自在

此义云何。观有为法三种。一观有为法以观见相识。二者观受用。以观器世间等。以何处住。以何等身受用何等。三者观有为行。以何等法三世转差别。如是观一切法。于世间法。中得自在故。偈言于有为法中得无垢自在故

经曰。佛说是经已。长老须菩提。及诸比丘比丘尼。优婆塞优婆夷。菩萨摩诃萨。一切世间天人。阿修罗乾闼婆等。闻佛所说皆大欢喜信受奉行

  诸佛希有总持法　　不可称量深句义
  从尊者闻及广说　　回此福德施群生

金刚般若波罗蜜经论卷下


金刚般若波罗蜜经论(亦名金刚能断般若)

金刚般若波罗蜜经论卷上(亦名金刚能断般若)

        无著菩萨造

        隋南天竺三藏法师达摩岌多译

  出生佛法无与等　　显了法界最第一
  金刚难坏句义聚　　一切圣人不能入
  此小金刚波罗蜜　　以如是名显势力
  智者所说教及义　　闻已转为我等说
  归命彼类及此辈　　皆以正心而顶礼
  我应精勤立彼义　　解释相续为自他

论曰成立九种义句已。此般若波罗蜜即得成立。七义句者。一种性不断。二发起行相。三行所住处。四对治。五不失。六地。七立名。此等七义于般若波罗蜜经中成立故名义句。于中前六义句。显示菩萨所作究竟。第七义句。显示成立此法门故。应如是知。此般若波罗蜜为佛种不断故流行于世。为显此当得佛种不断义故。上座须菩提最初经云白佛言。希有世尊如来应供正遍知。善护念诸菩萨善付嘱诸菩萨如是等

二发起行相者。如经云何菩萨大乘中。发阿耨多罗三藐三菩提心如是等

三行所住处者。谓彼发起行相所住处也。此复有十八种应知

一发心。经言诸菩萨生如是心。所有一切众生如是等。二波罗蜜相应行。经言不住于事行于布施如是等。三欲得色身。经言须菩提于意云何。可以相成就见如来不如是等。四欲得法身。经言须菩提白佛言。世尊颇有众生于未来世如是等。五于修道得胜中无慢。经言须陀洹能作是念如是等。六不离佛出时。经言于意云何如来昔在然灯佛所如是等。七愿净佛土。经言须菩提若菩萨作是言。我庄严佛国土如是等。八成熟众生。经言须菩提譬如有人身如须弥山王如是等。九远离随顺外论散乱。经言须菩提于意云何。如恒河中所有沙数如是等。十色及众生身抟取中观破相应行。经言须菩提于意云何。三千大千世界所有微尘如是等。十一供养给侍如来。经言须菩提于意云何。可以三十二大人相见如来不如是等。十二远离利养及疲乏热恼故。不起精进及退失等。经言须菩提若善男子善女人以恒河沙等身如是等。十三忍苦。经言如来说忍波罗蜜如是等。十四离寂静味。经言须菩提若善男子善女人。能于此法门受持读诵修行如是等。十五于证道时远离喜动。经言世尊云何菩萨发阿耨多罗三藐三菩提心如是等。十六求教授。经言于意云何如来于然灯佛所有法得阿耨多罗三藐三菩提如是等。十七证道经言譬如有人其身妙大如是等。十八上求佛地。经言须菩提若菩萨作是言。我庄严佛国土是不名菩萨如是等

彼住处等。略为八种亦得满足。一摄住处。二波罗蜜净住处。三欲住处。四离障碍住处。五净心住处。六究竟住处。七广大住处。八甚深住处。于中摄住处者。谓发心。波罗蜜净住处者。谓波罗蜜相应行。欲住处者。谓欲得色身法身。离障碍住处者。谓余十二种。净心住处者。谓灯道。究竟住处者。谓上求佛地。广大及甚深住处者。通一切住处。于初住处中。若说菩萨应生如是心所有众生如是等。此为广大。又复说言。若菩萨有众生相如是等。此为甚深。于第二住处中。若说菩萨不住于事行于布施如是等。此为甚深。若复说言。彼所有福聚不可思量如是等。此为广大。如是于余住处中广大甚深等。随所相应应知。已说住处

四对治者。彼如是相应行相。行诸住处时。有二种对治应知。一邪行。二共见正行。此中见者谓分别也。于初住处中。若说菩萨应生如是心所有众生等。此是邪行对治。生如是心是菩萨邪行。若复说言。若菩萨有众生想等。此为共见正行对治。此分别执菩萨亦应断。谓我应灭度众生故。于第二住处中。若说应行布施此为邪行对治。非于布施是菩萨邪行。若复说言住于事等。此是共见正行对治。此分别执菩萨亦应断。谓应行布施故

五不失者。谓离二边云何二边。谓增益边损减边。若于如言辞法中。分别执有自性是增益边。若于法无我事中而执为无。是损减边。于中若说言。世尊若福聚非聚此遮增益边。以无彼福聚分别自性故。若复说言。是故如来说福聚此遮损减边。彼不如言辞有自性而有可说事。以如来说福聚故。此得显示如是须菩提佛法佛法者如来说非佛法者。此遮增益边。是名佛法者此遮损减边。于中如来说非佛法者。显示不失义。是名佛法者。显示相应义。何者是相应若佛法。如说有自性者。则如来不说佛法。以虽不说亦自知故。是故无有自性。为世谛故如来说名佛法。如是于一切处显示不共及相应义。应知复次佛法者。摄波罗蜜事及念处等菩提分。应知菩萨离此二边故于彼对治不复更失故名不失

六地者。此地有三种。谓信行地净心地如来地。于中前十六处显示信行地。证道住处是净心地。后上求佛地

七立名名金刚。能断者此名有二义相。应知如说入正见行入邪见行故。金刚者细牢故。细者智因故。牢者不可坏故。能断者。般若波罗蜜中闻思修所断。如金刚断处而断故。是名金刚能断。又如画金刚形。初后阔中则狭。如是般若波罗蜜中狭者。谓净心地。初后阔者。谓信行地如来地。此显示不共义也。彼五种义句上上依止。应知彼等皆依止地故说

经曰。如是我闻。一时婆伽婆在舍婆提城祇树给孤独园。与大比丘众千二百五十人俱。尔时世尊食时着衣持钵入舍婆提大城。乞食于其城中次第乞食已。还至本处饭食讫。收衣钵洗足已如常。敷坐结跏趺坐端身而住正念不动。尔时诸比丘来诣佛所。到已顶礼佛足。右绕三匝退坐一面。尔时慧命须菩提在大众中。即从坐起偏袒右肩。右膝着地向佛合掌恭敬而立。白佛言。希有世尊。如来应供正遍知。善护念诸菩萨善付嘱诸菩萨

论曰。修多罗身相续。此义句今当说。世尊何故以寂静者威仪而坐也。显示唯寂静者于法能觉能说故。经言。善摄第一菩萨摩诃萨者。谓已熟菩萨于佛证正觉转法轮时。以五种义中菩萨法而建立故。诸菩萨有七种大故。此大众生名摩诃萨埵。何者七种大。一法大。二心大。三信解大。四净心大。五资粮大。六时大。七果报大。如菩萨地持中说。于诸菩萨所。何者善摄。何者第一也。利乐相应为善摄。第一有六种应知。一时二差别三高大四牢固五普遍六异相。何者时。现见法及未来故。彼菩萨善摄中乐者是现见法利者是未来世。何者差别。于世间三摩钵帝。及出世圣者声闻独觉等。善摄中差别故。何者高大。此善摄无有上故。何者牢固。谓毕竟故。何者普遍。自然于自他身善摄。何者异相。于未净菩萨善摄中胜上故。经言第一付嘱者。彼已得善摄。菩萨等于佛般涅槃时。亦以彼五义如是建立故。何者第一付嘱。有六种因缘一入处二法尔得三转教四不失五悲六尊重。何者入处。于善友所善付嘱故。何者法尔。彼已得善摄菩萨于他所法尔善摄。何者转教。汝等于余菩萨应当善摄是名转教。此等三种如其次第即是不失。及悲尊重等应知。此善摄付嘱二种。显示种性不断

经曰。世尊云何菩萨大乘中。发阿耨多罗三藐三菩提心。应云何住。云何修行。云何降伏其心

尔时佛告须菩提。善哉善哉须菩提。如汝所说。如来善护念诸菩萨善付嘱诸菩萨。汝今谛听当为汝说。如菩萨大乘中发阿耨多罗三藐三菩提心。应如是住。如是修行。如是降伏其心。须菩提白佛言。世尊如是愿乐欲闻

论曰此下第二发起行相。何故上座须菩提问也。有六因缘。一为断疑故。二为起信解故。三为入甚深义故。四为不退转故。五为生喜故。六为正法久住故。亦即是般若波罗蜜令佛种不断。云何以此令佛种不断也。若有疑者得断故。有乐福德而心未成熟诸菩萨等。闻多福德于般若波罗蜜起信解故。已成熟心者入甚深义故。已得不轻贱者。由贪受持修行。有多功德不复退转故。已得顺摄及净心者。于法自入及见生欢喜故。能令未来世大乘教久住故者。若略说疑者令见故。乐福德及已成熟诸菩萨等摄受故。已得不轻贱者令精勤心故。已得净心者。令欢喜故。经言。应云何住者。谓欲愿故。应修行者。谓相应三摩钵帝故。应降伏心者。谓折伏散乱故。于中欲者正求也。愿者为所求故作心思念也。相应三摩钵帝者。无分别三摩提也。折伏散乱者。若彼三摩钵帝心散制令还住也。第一者显示摄道。第二者显示成就道。第三者显示不失道。何故唯问发行菩萨乘。为三种菩提差别故。以善问故。于上座须菩提所应称善哉

经曰。佛告须菩提。诸菩萨生如是心。所有一切众生众生所摄。若卵生若胎生若湿生若化生若有色若无色若有想若无想若非有想非无想。所有众生界众生所摄。我皆令入无余涅槃而灭度之。如是灭度无量无边众生。实无众生得灭度者。何以故。须菩提若菩萨有众生相即非菩萨。何以故。非须菩提若菩萨起众生相人相寿者相。则不名菩萨

论曰。自下第三行所住处。讫尽经末有十八门具如前说。此中第一初明发心。经言。所有众生众生所摄者。总相说也。卵生等者差别说也。又受生依止境界所摄差别应知卵生乃至化生者。受生别也。若有色若无色者。依止别也。若有想若无想若非有想非无想者。境界所摄别故。所有众生界众生所摄者。谓上种种想住众生界。佛施设说也。我皆令入无余涅槃者。何故愿此不可得义。生所摄故无过。以皆是生故。如所说卵生等生并入愿数故。彼卵生湿生无想及非有想非无想等则不能。云何能令一切众生入涅槃也。有三因缘故。一难处生者得时故。二非难处生未成熟者成熟之故。三已成熟者解脱之故。何故说无余涅槃界不直说涅槃。若如是便与世尊所说初禅等方便涅槃不别故。彼自以丈夫力故。无佛亦得。但非究竟。何故不说有余涅槃界。彼共果故。自以宿业。又值佛说而得果故。又非一向身苦有余故。如是涅槃及有余涅槃等。丈夫力果故。共果故。非究竟果故。非一向果故。是故说无余。如是无量众生入涅槃已者。显示卵生等生一一无量故。无有众生得涅槃者。此何义。如菩萨自得涅槃无别众生。何以故。若菩萨有众生相即非菩萨者。此何义。若菩萨于众生所。他想转非自体想不名菩萨故。何以故。若菩萨起众生想人想寿者想则不名菩萨者。此何义。若以烦恼取众生命人想转彼则有我想。及于众生中有众生想转。菩萨于彼不转已断我见故。得自行(行者谓五阴行)平等相故。信解自他平等。彼菩萨非众生命人取见者此是其义。复次经言。诸菩萨生如是心等者。显示菩萨应如是住中欲愿也。若菩萨有众生想即非菩萨者。显示应如是修行中相应三摩钵帝时也。若菩萨起众生相人相寿者相则不名菩萨者。显示应如是降伏心中摄散时也。如菩萨相应三摩钵帝散时。众生想亦不转。如彼尔焰相住故。是故无有众生得涅槃者。此得成就彼欲愿者。摄诸住处为最胜。彼相应行相行余住处时。依止欲愿决定得故。此欲愿义不复重释

经曰。复次须菩提不住于事行于布施。无所住行于布施。不住色布施。不住声香味触法布施。须菩提菩萨应如是布施不住于相想。何以故。若菩萨不住相布施。其福德聚不可思量。须菩提于汝意云何。东方虚空可思量不。须菩提言不也世尊。佛言如是。须菩提南西北方四维上下虚空可思量不。须菩提言。不也世尊。佛言如是如是。须菩提。菩萨无住相布施。福德聚亦复如是。不可思量。佛复告须菩提。菩萨但应如是行于布施

论曰。此下第二波罗蜜相应行。自此后余住处中。有五种随所相应。而解释应知

一依义二说相三摄持四安立五显现。住处对治为依义。即彼住处为说相。欲愿为摄持。住处第一义为安立。相应三摩提及摄散心为显现。于波罗蜜净住处中。经言。菩萨不住于事。行于布施。此为依义。显示对治住着故。经言应行施者。此为说相。六波罗蜜六摄一切檀那体性故。檀那有三种。一资生施者。谓檀那波罗蜜。二无畏施者。谓尸罗波罗蜜羼提波罗蜜。三法施者。谓毗梨耶波罗蜜禅耶波罗蜜般若波罗蜜等。若无精进于受法人所为说法时疲倦故。不能说法。若无禅定则贪于信敬供养。及不能忍寒热逼恼故。染心说法若无智慧。便颠倒说法多有过故。不离此三得成法施。彼诸波罗蜜有二种果。谓未来现在。未来果者。檀那波罗蜜得大福报。尸罗波罗蜜得自身具足。谓释梵等。羼提波罗蜜得大伴助大眷属。毗离耶波罗蜜得果报等不断绝。禅那波罗蜜得生身不可损坏。般若波罗蜜得诸根猛利。及多诸悦乐。于大人众中得自在等。现在果者。得一切信敬供养。及现法涅槃等。于中若菩萨求未来果故行施。为住事行施。如所施物还得彼物果。是故经言。不住于事行于布施。若求未来尸罗等果故行施。为有所住行施。是故经言。无所住应行布施。尸罗等果有众多。不可分别故。总名有所住。若求现在果信敬供养故行施。为住色声香味触行施故。经言。不住色等若求现法涅槃故行施。为住法行施故。经言。不住于法应行布施。又经言。应行布施者。即说摄持施之欲愿故。经言。不住行施者。即此不住为安立第一义故。于中以不住故。显示如所有事第一义不住物等是所有事。经言。菩萨应如是行施不住于相想者。此为显示。谓相应三昧及摄散心。于此二时不住相想。如是建立不住已。或有菩萨贪福德故。于此不堪。为令堪故。世尊显示不住。行施福聚甚多犹如虚空。有三因缘。一遍一切处。谓于住不住相中福生故。二宽广高大殊胜故。三无尽究竟不穷故

经曰。须菩提于意云何。可以相成就见如来不。须菩提。言不也世尊。不可以相成就得见如来。何以故。如来所说相即非相。佛告须菩提。凡所有相皆是妄语。若见诸相非相。则非妄语。如是诸相非相则见如来

论曰。此下第三欲得色身住处。经言。须菩提于意云何。可以相成就见如来不者。此为依义。应如显示对治如来色身慢故。经言相成就者。此为说相。显示如来色身故。上座须菩提言不也。为成满此义故。世尊说须菩提凡所有相皆是妄语。即显欲愿于如是义中应摄持故。及即是安立第一义。于第一义中相成就为虚妄。非相成就不虚妄。经言。如是诸相非相则见如来者。此为显现。谓相应三昧及摄乱心时。于彼相中非相见故

经曰。须菩提白佛言。世尊颇有众生。于未来世末世。得闻如是修多罗章句生实相不。佛告须菩提莫作是说。颇有众生于未来世末世。得闻如是修多罗章句生实相不。佛复告须菩提。有未来世末世。有菩萨摩诃萨法欲灭时。有持戒修福德智慧者。于此修多罗章句能生信心。以此为实。佛复告须菩提。当知彼菩萨摩诃萨。非于一佛二佛三四五佛所修行供养。非于一佛二佛三四五佛所而种善根。佛复告须菩提。已于无量千万诸佛所修行。供养无量百千万诸佛。所种诸善根闻是修多罗。乃至一念能生净信。须菩提如来悉知。是诸众生。如来悉见是诸众生。须菩提是诸菩萨生如是无量福德聚。取如是无量福德。何以故。须菩提是诸菩萨。无复我相众生相人相寿者相。须菩提是诸菩萨。无法相亦非无法相。无相亦非无相。何以故。须菩提是诸菩萨。若取法相则为着我人众生寿者。须菩提若是菩萨。有法相即着我相人相众生相寿者相。何以故。须菩提不应取法非不取法。以是义故。如来常说筏喻法。门是法应舍何况非法

论曰。此下第四为欲得法身住处。于中二种。一言说法身。二证得法身。为欲得此言说法身故。经言。世尊颇有众生。于未来世末世。得闻如是修多罗章句等。于中修多罗章句者。谓所有义应知。何者为句。如上所说七种义句。于不颠倒义想是谓实相。应知如言执义彼非实相。上座须菩提作是念。于未来世无有生实相者。为遮此故。世尊言有正法欲灭时者。谓修行渐灭时。应知次后世尊为如是义显示五种。一显示修行。二显示集因。三显示善友摄受。四显示摄福德相应。五显示实相中当得实想故。经言。有持戒修福德智慧者。此增上戒等三学。显示修行功德。少欲等功德为初。乃至三摩提等。经言。已得供养无量百千诸佛。乃至一心净信等。此显示集因。一心净信尚得如是何况生实想也。经言。如来悉知悉见是诸众生者。此显示善友所摄。知者知名身。见者见色身。谓一切行住所作中知其心。见其依止故。经言。生取无量福聚者。此显示摄福德。生者福正起时故。取者即彼灭时摄持种子故。经言。是诸菩萨无复我相众生相。乃至若是菩萨有法想。即着我相人相众生相寿者相者。此显示实想。对治五种邪取故。何者五邪取。一外道。二内法凡夫及声闻。三增上慢菩萨。四世间共想定。五无想定。第一者我等想转。第二法相转。第三者无净想转。此犹有法取。有法取者。谓取无法故。第四者有想转。第五者无想转。是诸菩萨于彼皆不转也。此中显了有戒。乃至当生无量福聚等。经言何以故者。此言是中邪取但法及非法想转。非我等想。以我想及依止不转故。然于我想中随眠不断故。则为有我取。是故经言。是诸菩萨若取法想则为着我等取。若无法想转。则为有我取等。此我等想转中。余义犹未说。经言。若是菩萨有法相即着我等者。于中取自体相续为我想。我所取为众生想。谓我乃至寿住取为命想。展转取余趣。取为人想。应知于中言当生实想者。此为依义。应知显示对治。不实想故。言于此修多罗章句说中者。此为说相显示言说法身故。即彼当生实想中言当生者。是故愿摄持故。是诸菩萨无复我想转等者。是安立第一义。须菩提不应取法非不取法者。是显了。谓相应三摩钵帝及散心时。不应取法者。于法体及法无我并不分别。又言说法身要义者。经言。以是义故如来常说筏喻法门。若解此者法尚应舍。何况非法故。法尚应舍实想生故。何况非法者。理不应故。略说显示菩萨欲得言说法身。不应作不实想故

经曰。复次佛告慧命须菩提。须菩提于意云何。如来得阿耨多罗三藐三菩提耶。如来有所说法耶。须菩提言。如我解佛所说义无有定法。如来得阿耨多罗三藐三菩提。亦无有定法如来可说。何以故。如来所说法皆不可取不可说。非法非非法。何以故。一切圣人皆以无为法得名

论曰。此下证得法身复有二种。一智相法身。二福相法身。为欲得智相至得法身住处故。经言。须菩提于意云何如来得阿耨多罗三藐三菩提耶。此为依义。显示翻于正觉菩提取故。说法者正觉所摄故。经言。有法可说阿耨多罗三藐三菩提者。是为说相。显示至得法身故。无有定法者。上座须菩提道佛意故。世谛故。有菩提及得。是为欲愿摄持以方便故。二俱为有。若如世尊意说者二俱无有。为显此故。经言。如我解世尊所说义等。又经言。何以故。如来所说法不可取不可说非法非非法者。是安立第一义。由说法故。知得菩提故。于说法中安立第一义。于中不可取者。谓正闻时。不可说者谓演说时。非法者分别性。非非法者法无我故。经言何以故。以无为故得名圣人者。无为者无分别义也。是故菩萨有学得名。无起无作中。如来转依名为清净。是故如来无学得名。于中初无为义者。三摩钵帝相应。及折伏散乱时显了故。第二无为唯第一义者。无上觉故。自此已后一切住处中。皆显以无为故得名圣人。应知前诸住处中未说无为得名。于此说阿耨多罗三藐三菩提中无为已竟

经曰。须菩提于意云何。若满三千大千世界七宝。以用布施。须菩提于意云何。是善男子善女人。所得福德宁为多不。须菩提言甚多。婆伽婆甚多。修伽陀彼善男子善女人得福甚多。何以故。世尊是福德聚即非福德聚。是故如来说福德聚。佛言须菩提。共善男子善女人。以满三千大千世界七宝。持用布施。若复于此经中受持。乃至四句偈等为他人说。其福胜彼无量不可数。何以故。须菩提一切诸佛阿耨多罗三藐三菩提法。皆从此经出。一切诸佛如来皆从此经生。须菩提所谓佛法者。即非佛法是名佛法

论曰。此下福相法身。为欲得福相至得法身住处故。经言于意云何。若人满三千大千世界七宝。以用布施等。云何显示即彼所有言说法身出生如来福相至得法身。于彼乃至说一四句偈生福甚多。况复如来所有福相至得法身。以何因缘于言说法身中。如是说一四句偈能生多福。为成就此义故。经言。何以故如来阿耨多罗三藐三菩提从此出者。于中普集十法行阿含故。诸佛世尊从此生者。世谛故言佛出生。以有菩提故。即此二并故名为佛法。以菩提及佛故。经言须菩提佛法者即非佛法

复次。经言其所生福胜彼无量阿僧祇者。此为依义。显示对治福不生故。于中其福者。此为说相。显示福相法身故。胜彼者。显示欲愿摄持故。经言。世尊是福聚即非福聚。是故如来说福聚。及言须菩提佛法佛法者即非佛法是名佛法者。以此福聚及佛法。为摄取如来福相。法身中安立第一义。为随顺无为得名故。相应三摩钵帝及折伏散乱不复显了言。甚多婆伽婆甚多修伽陀二语者。显示摄心持心。以摄自心故言受持。为他说者解释句味故。无量者过譬喻故。阿僧祇者显多故。已说欲住处竟

金刚般若波罗蜜经论卷上金刚般若波罗蜜经论卷中

        无著菩萨造

        隋南天竺三藏法师达摩岌多译

经曰。须菩提于意云何。须陀洹能作是念。我得须陀洹果不。须菩提言。不也世尊。何以故。实无有法名须陀洹。不入色声香味触法。是名须陀洹。佛言。须菩提于意云何。斯陀含能作是念。我得斯陀含果不。须菩提言。不也世尊。何以故。实无有法名斯陀含。是名斯陀含。须菩提于意云何。阿那含能作是念。我得阿那含果不。须菩提言。不也世尊。何以故。实无有法名阿那含是名阿那含。须菩提于意云何。阿罗汉能作是念。我得阿罗汉果不。须菩提言。不也世尊。何以故。实无有法名阿罗汉。世尊若阿罗汉作是念。我得阿罗汉即为着我人众生寿者。世尊佛说我得无诤三昧最为第一。世尊说我是离欲阿罗汉。世尊我不作是念。我是离欲阿罗汉。世尊我若作是念。我得阿罗汉。世尊则不记我无诤行第一。以须菩提实无所行。而名须菩提无诤无诤行

论曰。此下第五为修道得胜中无慢。如前略为八种住处。已下十二总名离障碍住处。对治应知。何者十二障碍。一慢二无慢而少闻。三多闻而小攀缘作念修道。四不小攀缘作念修道而舍众生。五不舍众生而乐随外论散动。六虽不散动。而破影像相中无巧便。七虽有巧便而福资粮不具。八虽具福资粮。而乐味懈怠及利养等。九虽离懈怠利养而不能忍苦。十虽能忍苦而智资粮不具。十一虽具智资粮。而不自摄。十二虽能自摄而无教授。此中为离慢故。经言。须陀洹能作是念。我得须陀洹果不等。此为依义。显示对治我得慢故。又复须陀洹能作是念者。即为说相。显示无慢故。亦即是欲愿摄持。经言。世尊实无有法不入色声香味触者。此为安立第一义。若须陀洹如是念。我得须陀洹果即为有我想。若有我想则为有慢。应知如是乃至阿罗汉亦尔。上座须菩提自显无诤行第一及离欲阿罗汉共有功德者。以己所证为令信故。以无有法得阿罗汉。及无所行故。说无诤无诤行。此中即为安立第一义

经曰。佛告须菩提于意云何。如来昔在然灯佛所得阿耨多罗三藐三菩提法不。须菩提言。不也世尊。如来在然灯佛所。于法实无所得阿耨多罗三藐三菩提

论曰。此下第六为不离佛出时。依离障碍十二种中为离少闻故。经言。如来昔在然灯佛所得阿耨多罗三藐三菩提法不等。谓彼佛出世承事供养时。有法可取离此分别故。依义等及对治等。随义相应应知

经曰。佛告须菩提。若菩萨作是言。我庄严佛国土。彼菩萨不实语。何以故。须菩提如来所说庄严佛土者。则非庄严是名庄严佛土。是故须菩提。诸菩萨摩诃萨。应如是生清净心。而无所住。不住色生心。不住声香味触法生心。应无所住而生其心

论曰。此下第七为愿净佛土。依离障碍。十二种中为离小攀缘作念修道故。经言。须菩提若菩萨作是言我庄严佛国土等。若念严净土者。则于色等事分别生味着。为离此故。经言。是故须菩提诸菩萨摩诃萨应如是生清净心。而无所住。不住色声香味触法等

经曰。须菩提譬如有人身如须弥山王。须菩提于意云何。是身为大不。须菩提言甚大。世尊。何以故。佛说非身是名大身。彼身非身是名大身

论曰。此下第八为成熟众生。依离障碍。十二种中为离舍众生故。经言。须菩提譬如有人身如须弥山王如是等。此何所显示。为成熟欲界众生故。彼罗睺阿修罗王等。一切大身量如须弥。尚不应见其自体。何况余者。经言。如来说为非体者。显示法无我故。彼体非体者。显示法体无生无作故。此即显示自性与相及差别故

经曰。佛言须菩提。如恒河中所有沙数。如是沙等恒河于意云何。是诸恒河沙宁为多不。须菩提言甚多。世尊。但诸恒河尚多无数。何况其沙。佛言。须菩提我今实言告汝。若有善男子善女人。以七宝满尔数恒沙数世界。以施诸佛如来。须菩提于意云何。彼善男子善女人。得福多不。须菩提言甚多。世尊彼善男子善女人得福甚多。佛言须菩提以七宝满尔数恒河沙世界。持用布施。若善男子善女人。于此法门乃至受持四句偈等。为他人说。而此福德胜前福德无量阿僧祇。复次须菩提随所有处。说是法门乃至四句偈等。当知此处一切世间天人阿修罗。皆应供养如佛塔庙。何况有人尽能受持读诵此经。须菩提当知。是人成就最上第一希有之法。若是经典所在之处。则为有佛。若尊重似佛。尔时须菩提白佛言。世尊当何名此法门。我等云何奉持。佛告须菩提。是法门名为金刚般若波罗蜜。以是名字汝当奉持。何以故。须菩提佛说般若波罗蜜。则非般若波罗蜜。须菩提于意云何。如来有所说法不。须菩提言。世尊如来无所说法

论曰。此下第九为远离随顺外论散乱。依离障碍。十二种中为离乐外。离散乱故。经说四种因缘。显示此法胜异也。一摄取福德。二天等供养。三难作。四起如来等念。经言。须菩提如恒河中所有沙数等者。是摄取福德。经言。须菩提随所有处说是法门等者。是天等供养。经言。须菩提当知是人成就最上第一希有等者。是难作。经言。若是经典所在之处等者。是起如来等念。于中说者为他直说故。授者教授他故。显示此乐外论散乱对治法胜异已。于如是法中。或起如言执义为对治彼未来罪故。经言。佛说般若波罗蜜则非般若波罗蜜故。如般若波罗蜜非波罗蜜。如是亦无有余法如来说者。为显此义故。经言。须菩提于意云何。如来有所说法不。此显示自相及平等相法门第一义也

经曰。须菩提于意云何。三千大千世界所有微尘是为多不。须菩提言。彼微尘甚多。世尊。须菩提是诸微尘如来说非微尘。是名微尘。如来说世界非世界。是名世界

论曰。此下第十明色及众生身抟取中观破相应行。依离障碍。十二种中为离于影像相。自在中无巧便故。经言。须菩提于意云何。三千大千世界所有微尘如是等彼不限量。攀缘作意菩萨恒于世界攀缘作意修习故。说三千大千世界。于中为破色身影像相故。显示二种方便。一细作方便。如三千大千世界所有微尘宁为多不等。二不念方便。如经是诸微尘如来说非微尘是名微尘故。为破众生身影像相故。经言。如来说世界非世界是名世界故。于中世界显众生世也。但以名身名为众生世。不念名身方便即是显示故。彼影像相不复说细作方便也

经曰。佛言须菩提。于意云何可以三十二大人相见如来不。须菩提言。不也世尊。何以故。如来说三十二大人相即是非相。是名三十二大人相

论曰。此下第十一明供养给侍如来。依离障碍。十二种中为离不具福资粮故。经言。于意云何可以三十二大人相见如来不者。显示为福资粮故。亲近供养如来时。不应以相成就见如来。云何见。应见第一义法身故

经曰。佛言须菩提。若善男子善女人。以恒河沙等身命布施。若复有人。于此法门中乃至受持四句偈等为他人说。其福甚多无量阿僧祇。尔时须菩提闻说是经深解义趣。涕泪悲泣扪泪而白佛言。希有婆伽婆希有修伽陀。佛说如是甚深法门。我从昔来所得慧眼未曾得闻如是法门。何以故。须菩提。佛说般若波罗蜜即非般若波罗蜜。世尊若复有人。得闻是经信心清净则生实相。当知是人成就第一希有功德。世尊是实相者。则是非相。是故如来说名实相。实相世尊我今得闻如是法门信解受持不足为难。若当来世其有众生。得闻是法门信解受持是人则为第一希有。何以故。此人无我相人相众生相寿者相。何以故。我相即是非相。人相众生相寿者相即是非相。何以故。离一切诸相则名诸佛。佛告须菩提如是如是。若复有人得闻是经。不惊不怖不畏。当知是人甚为希有。何以故。须菩提如来说第一波罗蜜非第一波罗蜜。如来说第一波罗蜜者。彼无量诸佛亦说波罗蜜。是名第一波罗蜜

论曰。此下第十二远离利养及疲乏热恼故。不起精进及退失等。依离障碍。十二种中为离懈怠利养等乐味故。经言。须菩提若有善男子善女人。以恒河沙等身命布施。如是等于中身有疲乏心有热恼。以此二种于彼精进。若退若不发。此何所显示。如此舍尔许身。自所有福不及此福。云何以一身着懈怠等故。而为障碍。何故此中上座须菩提流泪而言。我未曾闻如是等法门也。以闻此胜福甚多过于舍无量身。更不说余胜福故。若闻如是胜福故。发起精进已。若于此法中生如义想为离此过故。经言。若复有人得闻是经信心清净则生实相。当知。是人成就第一希有功德等。即于如是实相中。为离实相分别故。经言。是实相者即是非相。如是等经言。世尊。我今得闻如是法门。信解受持不足为难。若当来世其有众生。得闻是法门信解受持。是人则为第一希有。如是等此何义。为令味着利养过懈怠。诸菩萨生惭愧故。于未来正法灭时。尚有菩萨于此法门受持故。无人等取及法取。云何汝等于正法兴时。远离修行不生惭愧也。经言。此人无我相人相众生相寿者相者。显示无人取也。我相即非相等者。显示无法取也。经言。何以故。离一切诸相即名诸佛者。显示诸菩萨顺学相。诸佛世尊离一切相。是故我等亦应如是学。此等经文为离退精进故说。于中言。若分别若信解者。后句释前句也。受者受文字也。持者持义也。为离不发起精进故。经言。若复有人得闻是经不惊不怖不畏等者。以惊等故不发起精进也。于声闻乘中。世尊说有法及有空。于听闻此经时闻法无有故惊。闻空无有故怖。于思量时于二不有。理中不能相应故畏。更有别释为三种。无自性故。应知。谓相生第一义等无自性故。经言。何以故。须菩提如来说第一波罗蜜非第一波罗蜜者。此有何义。复说第二生惭愧处故。言此法如是胜上汝等不应放逸。于中以于余波罗蜜中胜故。名第一波罗蜜。又经言。如来说第一波罗蜜者。彼无量诸佛亦说波罗蜜者。此言显示一切诸佛同说第一是故名第一

经曰。须菩提。如来说忍辱波罗蜜。即非忍辱波罗蜜。何以故。须菩提。如我昔为歌利王割截身体。我于尔时。无我相无众生相无人相无寿者相。无相亦非无相。何以故。须菩提。我于往昔节节支解时。若有我相众生相人相寿者相。应生嗔恨。须菩提。又念。过去于五百世作忍辱仙人。于尔所世无我相无众生相无人相无寿者相。是故须菩提。菩萨应离一切相。发阿耨多罗三藐三菩提心。何以故。若心有住则为非住。不应住色生心。不应住声香味触法生心。应生无所住心。是故佛说菩萨心不住色布施。须菩提。菩萨为利益一切众生。应如是布施须菩提言。世尊。一切众生相即非相。何以故。如来说一切众生即非众生。须菩提。如来是真语者实语者如语者不异语者。须菩提。如来所得法所说法无实无妄语。须菩提。譬如有人入闇则无所见。若菩萨心住于事而行布施。亦复如是。须菩提。譬如人有目夜分已尽。日光明照见种种色。若菩萨不住于事行于布施。亦复如是

论曰。此下第十三明忍苦依离障碍。十二种中为离不能忍苦故。经言。须菩提。如来说忍辱波罗蜜等。于中有二。一能忍二离不能忍。能忍有三。一如所能忍。二忍相。三种类忍。于中如所能忍以何相生忍处。如忍差别显示对治。彼因缘故。何者能忍。谓达法无我故。云何得显示。如经言。如来说忍辱波罗蜜。即非忍辱波罗蜜故。云何应知忍相。若他于己起恶等时。由无有我等相故。不生嗔想。亦不于羼提波罗蜜中生有想。于非波罗蜜中生无想。此云何显示。经言。如我昔为歌利王割截身体。我于尔时无有我等相。及无相亦非无相等故。何者种类忍亦有二种。一极苦忍。二相续苦忍。此云何显示。经言。须菩提。我于往昔节节支解时。若有我相应生嗔恨等。云何相续苦忍。经言。须菩提。又念。过去于五百世作忍辱仙人等。不忍因缘者。有三种苦。一流转苦。二众生相违苦。三乏受用苦。于中经言。是故须菩提。菩萨应离一切相发阿耨多罗三藐三菩提心等。此为显示流转苦忍因缘对治。发菩提心者。以三种苦相故。则不欲发心故。说应离一切相等。此中一切相者。为显如是等三苦相也。若着色等则于流转苦中疲乏故。菩提心不生故。经言。不住色生心等如前说。不住非法者。谓非法无我也。于非法及法无我中。皆不住故为成就。彼诸不住故。说遮余事。经言。应生无所住心。何以故。若有心住即为非住等。经言。须菩提。菩萨为利益一切众生。应如是布施。乃至一切众生即非众生等。此显示对治众生相违苦忍。即为一切众生而行于舍。云何于彼应生嗔也。由不能无众生及众生想。以此因缘故。众生相违时。即生疲乏故。显示人无我法无我等。经言。须菩提。如来是真语者等。此何所显示。欲令信如来故能忍。于中真语者。为显世谛相故。实语者为显世谛修行有烦恼及清净相故。于中实者。此行烦恼此行清净故。如语者。为第一义谛相故。不异语者。为第一义谛修行有烦恼及清净相故。说此真语等。已于此中如言说性起执着。为遣此故。经言。须菩提。如来所得法所说法。无实无妄语故。无实者。如言说性非有故。无妄者。不如言说自性有故。经言。须菩提。譬如有人入闇。如是等显示乏受用苦忍因缘对治。若为果报布施。便着于事而行舍施。于彼喜于欲乐若受中不解出离。犹如入闇。不知我何所趣。彼喜欲乐亦尔。若不着于事而行布施。如有眼丈夫夜过。日出见种种色随意所趣。应如是见。彼无明夜过慧日出已种种尔焰如实见之。彼不知解出离欲乐苦受故。喜乐欲乐

经曰。复次须菩提。若有善男子善女人。能于此法门受持读诵修行。则为如来以佛智慧悉知是人。悉见是人。悉觉是人。皆得成就无量无边功德聚。须菩提。若有善男子善女人。初日分以恒河沙等身布施。中日分复以恒河沙等身布施。后日分复以恒河沙等身布施。如是舍恒河沙等无量身。如是百千万亿那由他劫以身布施。若复有人。闻此法门信心不谤。其福胜彼无量阿僧祇。何况书写受持读诵修行为人广说。须菩提以要言之。是经有不可思议不可称量无边功德。此法门如来为发大乘者说。为发最上乘者说。若有人能受持读诵修行此经。广为人说。如来悉知是人悉见是人。皆成就不可思议不可称无有边无量功德聚。如是人等。则为荷担如来阿耨多罗三藐三菩提。何以故。须菩提。若乐小法者。则于此经不能受持读诵修行为人解说。若有我见众生见人见寿者见。于此法门能受持读诵修行为人解说者。无有是处。须菩提。在在处处若有此经。一切世间天人阿修罗所应供养。当知。此处则为是塔。皆应恭敬作礼围绕。以诸华香而散其处。复次须菩提。若善男子善女人。受持读诵此经。为人轻贱。何以故。是人先世罪业应堕恶道。以今世人轻贱故。先世罪业则为消灭。当得阿耨多罗三藐三菩提。须菩提。我念过去无量阿僧祇阿僧祇劫。于然灯佛前得值八千四亿那由他百千万诸佛。我皆亲承供养无空过者。须菩提。如是无量诸佛。我皆亲承供养无空过者。若复有人于后世末世。能受持读诵修行此经所得功德。我所供养诸佛功德。于彼百分不及一。千万亿分乃至算数譬喻所不能及。须菩提。若有善男子善女人。于后世末世。有受持读诵修行此经。所得功德若我具说者。或有人闻心则狂乱疑惑不信。须菩提。当知。是法门不可思议。果报亦不可思议

论曰。此下第十四离寂静味。依离障碍十二种中。为离阙少智资粮故。经言。复次须菩提。若有善男子善女人。能于此法门受持读诵修行等。此中为离三摩提攀缘。显示与法相应。有五种胜功德。一如来忆念亲近。二摄福德。三赞叹法及修行。四天等供养。五灭罪。何者如来忆念亲近。经言。受持读诵等。如来以佛智知。彼如来以佛眼见彼等。于中受者习诵故。持者不妄故。若读若诵者。此说受持因故。为欲受故读。为欲持故诵。又复读者习诵故。持者总览义故。何者摄福德。经言。皆得成就无量无边功德聚等。何者赞叹法及修行。经言。须菩提。以要言之。是经有不可思议不可称量等。此为赞叹法。于中不可思者。唯自觉故。不可称者。无有等及胜故。经言。此法门如来为发大乘者说为发最上乘者说者。此成就不可称义。于中余乘不及故最上。烦恼障智障净故最胜。应知。经言。若有人能受持读诵修行此经广为人说等者。此为赞叹修行。于中如来知见成就无量功德聚者。是总说也。不可思不可称不可量者。解释故。如是人等则为荷担如来阿耨多罗三藐三菩提者。谓肩负菩萨重担故。经言。须菩提。若乐小法者。则于此经不能受持读诵修行为人解说者。谓声闻独觉乘者故。经言。若有我等见。乃至受持无有是处者。谓有人我见众生而自谓菩萨者故。何者天等供养。经言。须菩提。在在处处若有此经一切世间天人阿修罗所应供养等者。于中以华鬘烧香薰香涂香末香衣盖幢旛等。供养恭敬礼拜右绕故名支提。何者灭罪。经言。若善男子善女人。受持读诵此经为人轻贱等故者。此毁辱事有无量门。为显示此故说轻贱。经言。当得阿耨多罗三藐三菩提者。显示灭罪故。前所说以此因缘出生无量阿僧祇多福者。今当解释。彼无量阿僧祇义应知。威力者。成熟炽然故。多者具足故。于中经言。须菩提我念过去无量阿僧祇阿僧祇劫等者。此显示威力故。即是福聚威力。以彼所有福聚远绝高胜故。此中阿僧祇劫者。乃至然灯佛故。应知。过阿僧祇者更过前故。亲承者供养故。不空过者。常不离供养故。经言。须菩提。若有善男子善女人。于后末世有受持读诵修行此经。所得功德若我具说者。或有人闻心则狂乱。如是等此显示多故。或为狂因。或得乱心果。应知。此之彼威力及彼多等。何人能说。是故经言。须菩提当知。是法门不可思议。果报亦不可思议。此显示彼福体及果不可测量故

经曰。尔时须菩提白佛言。世尊。云何菩萨发阿耨多罗三藐三菩提心。云何住。云何修行。云何降伏其心。佛告须菩提。菩萨发阿耨多罗三藐三菩提心者。当生如是心。我应灭度一切众生令入无余涅槃界。如是灭度一切众生已。而无一众生实灭度者。何以故。须菩提。若菩萨有众生相人相寿者相。则非菩萨。何以故。须菩提。实无有法名为菩萨发阿耨多罗三藐三菩提心者

论曰。此下第十五于证道时远离喜动。依离障碍十二种中为远离自取故。经言。须菩提白佛言。世尊。云何菩萨发菩提心住修行等。何故复发起此初时问也。将入证道菩萨。自见得胜处。作是念。我如是住。如是修行。如是降伏心。我灭度众生。为对治此故。须菩提问。当于彼时如所应住。如所修行如所应降伏心。及世尊答当生如是心等。又经言。须菩提。若菩萨有众生等者。为显我执取。或随眠故。若言我正行菩萨乘。此为我取对治彼故。经言。须菩提。实无有法名为菩萨发阿耨多罗三藐三菩提心者

经曰。须菩提。于意云何。如来于然灯佛所。有法得阿耨多罗三藐三菩提不。须菩提白佛言。不也世尊。如我解佛所说义。佛于然灯佛所。无有法得阿耨多罗三藐三菩提。佛言。如是如是。须菩提。实无有法。如来于然灯佛所。得阿耨多罗三藐三菩提。须菩提。若有法如来得阿耨多罗三藐三菩提者。然灯佛则不与我授记。汝于来世当得作佛。号释迦牟尼。以实无有法得阿耨多罗三藐三菩提。是故然灯佛与我授记。作如是言。摩那婆汝于来世。当得作佛号释迦牟尼。何以故。须菩提。言如来者。即实真如。须菩提。若有人言。如来得阿耨多罗三藐三菩提者。是人不实语。须菩提。实无有法佛得阿耨多罗三藐三菩提。须菩提。如来所得阿耨多罗三藐三菩提。于是中不实不妄语。是故如来说一切法皆是佛法。须菩提。所言一切法一切法者即非一切法。是故名一切法

论曰。此下第十六求教授。依离障碍十二种中为离无教授故。经言。须菩提。于意云何。如来于然灯佛所。有法得阿耨多罗三藐三菩提不。如是等。又经言。须菩提。若有法如来得阿耨多罗三藐三菩提者。然灯佛则不与我授记。汝于来世当得作佛等。此有何意。若菩提法可说。如彼然灯如来所说者。我于彼时便得菩提。然灯如来则不授记言我得等。以彼法不可说故。我于彼时不得菩提。是故与我授记。此是其义应知。又何故彼法不可说。经言。须菩提。言如来者即实真如故。如清净故名为如来。以如不可说故作此说。清净如名为真如。犹如真金。或言。然灯如来所于法不得菩提。世尊后时自得菩提。为离此取故。经言。须菩提。若有人言。如来得阿耨多罗三藐三菩提者。是人不实语等故。又经言。须菩提。如来所得阿耨多罗三藐三菩提。于是中不实不妄语者。显示真如无二故。云何不实。谓言说故。不妄者。谓彼菩提不无世间言说故。经言。是故如来说一切法皆是佛法者。此何义。显一切法法如清净故。如者遍一切法故。此是其义。又彼一切法法体不成就。为安立第一义故。经言。须菩提。所言一切法一切法者。即非一切法是名一切法故

金刚般若波罗蜜经论卷中金刚般若波罗蜜经论卷下

        无著菩萨造

        隋南天竺三藏法师达摩岌多译

经曰。须菩提。譬如有人其身妙大。须菩提言。世尊。如来说人身妙大则非大身。是故如来说名大身。佛言。须菩提。菩萨亦如是。若作是言。我当灭度无量众生则非菩萨。佛言。须菩提。于意云何。颇有实法名为菩萨不。须菩提言。不也世尊。实无有法名为菩萨。是故佛说一切法无众生无人无寿者

论曰。此下第十七为入证道故。经言。须菩提。譬如有人其身妙大。如是等显示入证道时得智慧故离慢。云何得智。有二种智故。一摄种性智。二平等智。若得智已得生如来家。得决定绍佛种。此为摄种性智。得此已能得妙身。于中妙身者。谓至得身成就。身得毕竟转依故。大身者。一切众生身摄身故。若于此家长夜愿生。既得生已便得彼身。是名妙身平等智。复有五种平等因缘。一粗恶平等。二法无我平等。三断相应平等。四无希望心相应平等。五一切菩萨证道平等。得此等故。得为大身。摄一切众生大身故。于彼身中安立非自非他故。经言。世尊。如来说人身妙大则非大身。是故如来说名大身等者。于此妙身等中。安立第一义。如是等是为得智慧。云何离慢。经言。须菩提。菩萨亦如是。若作是言。我当灭度无量众生等。此云何可知。若作是念。我灭度众生。我是菩萨。应知。此是慢者非实义菩萨。为显示此故。经言。是故佛说一切法无众生等。若菩萨有众生念。则不得妙身大身故

经曰。须菩提。若菩萨作是言。我庄严佛国土是不名菩萨。何以故。如来说庄严佛土。庄严佛土者即非庄严。是名庄严佛国土。须菩提。若菩萨通达无我。无我法者。如来说名真是菩萨菩萨

论曰。此下第十八上求佛地。应知。彼地复有六种。具足摄转依。具足一国土净具足。二无上见智净具足。三福自在具足。四身具足。五语具足。六心具足。为国土净具足三摩钵帝故。经言。须菩提。若菩萨作是言。我庄严佛国土。是不名菩萨。如是等此义为于共见正行中转故。为断彼故。安立第一义。经言。即非庄严是名庄严国土等。又经言。须菩提。若菩萨通达无我无我法者。此言为二种无我故。谓人无我法无我。又经言。如来说名菩萨。菩萨者为于彼二种无我中二种正觉故。此等云何显示。若言我成就即为人我。取庄严国土者是法我取。此非菩萨

经曰。须菩提。于意云何。如来有肉眼不。须菩提言。如是世尊。如来有肉眼。佛言。须菩提。于意云何。如来有天眼不。须菩提言。如是世尊。如来有天眼。佛言。须菩提。于意云何。如来有慧眼不。须菩提言。如是世尊。如来有慧眼。佛言。须菩提。于意云何。如来有法眼不。须菩提言。如是世尊。如来有法眼。佛言。须菩提。于意云何。如来有佛眼不。须菩提言。如是世尊。如来有佛眼。佛言。须菩提。于意云何。如恒河中所有沙。佛说是沙不。须菩提言。如是世尊。如来说是沙。佛言。须菩提。于意云何。如一恒河中所有沙。有如是等恒河。是诸恒河所有沙数佛世界。如是世界宁为多不。须菩提言。彼世界甚多世尊。佛告须菩提。尔所世界中所有众生若干种心住如来悉知。何以故。如来说诸心住皆为非心住。是名为心住。何以故。须菩提。过去心不可得。现在心不可得。未来心不可得

论曰。此下第二为无上见智净具足故。经言。须菩提。于意云何。如来有肉眼不。如是等于中二种。一为见净。二为智净。如来不唯有慧眼。为令知见净胜故。显示有五种眼。若异此则唯求慧眼见净故于中略说有四种眼。谓色摄。第一义谛摄。世谛摄。一切种一切应知摄。色摄复有二种。谓法界修果。此为五眼粗境界。故是初色摄第一义智力故。世智不颠倒转。是故第一义谛摄在。先于中为人说法。若彼法为彼人施设。此智说名法眼。一切应知中一切种无功用智。说名佛眼。此等名为见净。如经须菩提。于意云何。如恒河中所有沙。如是等此为智净。于中心住者。谓三世心。若干种者。应知有二种。谓染及净。即是共欲心离欲心等。世者说过去等分。于此二中安立第一义故。经言。如来说诸心住皆为非心住。乃至过去心不可得等。于中过去心不可得者。已灭故。未来者未有故。现在者第一义故。为应知中证故安立见。为教彼彼众生寂静心故安立智。于此智净中。说心住即非心住。如是见净中。何故不说眼即非也。以一住处故。见智净后安立第一义故。初亦得成就

经曰。须菩提。于意云何。若有人以满三千大千世界七宝持用布施。是善男子善女人。以是因缘得福多不。须菩提言。如是世尊。此人以是因缘得福甚多。佛言。如是如是。须菩提。彼善男子善女人。人以是因缘得福德聚多。须菩提。若福德聚有实。如来则不说福德聚福德聚

论曰。此下第三为福自在具足故。经言。须菩提。于意云何。若有人以满三千大千世界等。于中亦安立第一义故。经言。须菩提。若福德聚有实等

经曰。须菩提。于意云何。佛可以具足色身见不。须菩提言。不也世尊。如来不应以色身见。何以故。如来说具足色身。即非具足色身。是故如来说名具足色身。佛言。须菩提。于意云何。如来可以具足诸相见不。须菩提言。不也世尊。如来不应以具足诸相见。何以故。如来说诸相具足即非具足。是故如来说名诸相具足

论曰。此下第四为身具足故。于中复有二种。一为好具足。二为相具足。为好具足故。经言须菩提于意云何。佛可以具足色身见不。如是等于中亦以安立第一义故。经言。如来说非具足等为相身具足故。经言。须菩提。于意云何。如来可以具足诸相见不。如是等

经曰。佛言。须菩提。于意云何。汝谓如来作是念。我当有所说法耶。须菩提。莫作是念。何以故。若人言如来有所说法。则为谤佛。不能解我所说故。何以故。须菩提。如来说法。说法者无法可说。是名说法

论曰。此下第五为语具足故。经言。须菩提。于意云何。汝谓如来作是念。我当有所说法耶。如是等于中安立第一义故。经言。如来说法说法者等

经曰。尔时慧命须菩提白佛言。世尊。颇有众生于未来世闻说是法生信心不。佛言。须菩提。彼非众生非不众生。何以故。须菩提。众生众生者如来说非众生。是名众生

论曰。此下第六心具足。于心具足中复有六种。一为念处。二为正觉。三为施设大利法。四为摄取法身。五为不住生死涅槃。六为行住净。应知。于心具足中为念处故。经言。世尊。颇有众生于未来世。闻说是法生信心不。如是等此处于诸众生中。显示如世尊念处故。彼非众生者。第一义故。非不众生者。世谛故。是人即为希有第一者。显示说第一义。是不共及相应故。此文如前说

经曰。佛言。须菩提。于意云何。如来得阿耨多罗三藐三菩提耶。须菩提言。不也世尊。世尊无有少法如来得阿耨多罗三藐三菩提。佛言。如是如是。须菩提。我于阿耨多罗三藐三菩提。乃至无有少法可得。是名阿耨多罗三藐三菩提。复次须菩提。是法平等无有高下。是名阿耨多罗三藐三菩提。以无众生无人无寿者。得平等阿耨多罗三藐三菩提。修一切善法。得阿耨多罗三藐三菩提。须菩提。所言善法善法者。如来说非善法。是名善法

论曰。此下第二于彼心具足中为正觉故。经言。须菩提。于意云何。如来得阿耨多罗三藐三菩提耶。如是等于中无有法者。为离有见过。已显示菩提及菩提道故。彼复显示菩提。有二种因缘。谓阿耨多罗语故。三藐三佛陀语故。于中经言。无有少法如来得阿耨多罗者。此为阿耨多罗语故。此显示菩提自相故。菩提解脱相故。彼中无微尘许法有体。是故亦不可得。亦无所有。应知。经言。复次须菩提是法平等者。为三藐三佛陀语故。显示菩提者人平等相。于中平等者。以菩提法故得知是佛。此中经言无有高下者。显示一切诸佛第一义中寿命等无高下故。经言。以无众生无人无寿者。得平等阿耨多罗三藐三菩提者。显示菩提。于生死法平等相故。经言。一切善法得阿耨多罗三藐三菩提者。显示菩提道故。经言。所言善法善法者。如来说非善法。是名善法等者。此安立第一义相故

经曰。须菩提。三千大千世界中所有诸须弥山王。如是等七宝聚。有人持用布施。若人以此般若波罗蜜经乃至四句偈等。受持读诵为他人说。于前福德百分不及一。千分不及一。百千万分不及一。欧罗分不及一。数分不及一。优波尼沙陀分不及一。乃至算数譬喻所不能及。须菩提。于意云何。汝谓如来作是念。我度众生耶。须菩提。莫作是见。何以故。实无有众生如来度者。佛言。须菩提。若有实众生如来度者。如来则有我人众生寿者相。须菩提。如来说有我者。则非有我。而毛道凡夫生者以为有我。须菩提。毛道凡夫生者。如来说名非生。是故言毛道凡夫生

论曰。此下第三于彼生具足中。为施设大利法故。经言。三千大千世界中。所有诸须弥山王。如是等于中为安立第一义教授故。经言。汝谓如来作是念。我度众生耶。如是等。又经言。如来则有我人众生寿者相等者。此有何义。如来如尔焰而知。是故若有众生如来则为有我取。若实无我而言有我取。为离此着故。经言。须菩提。如来说有我者。则非有我。如是等。是故但小儿凡夫有如是取故。经言。须菩提毛道凡夫生者。如来说名非生。是故言毛道凡夫生故

经曰须菩提。于意云何。可以相成就得见如来不。须菩提言。如我解如来所说义。不以相成就得见如来。佛言。如是如是。须菩提。不以相成就得见如来。佛言。须菩提。若以相成就观如来者。转轮圣王应是如来。是故非以相成就得见如来。尔时世尊而说偈言

  若以色见我　　以音声求我
  是人行邪道　　不能见如来
  彼如来妙体　　即法身诸佛
  法体不可见　　彼识不能知

须菩提。于意云何。如来可以相成就。得阿耨多罗三藐三菩提耶。须菩提。莫作是念。如来以相成就得阿耨多罗三藐三菩提

论曰。此下第四于彼心具足中为摄取法身故。经言。须菩提。于意云何。可以相成就得见如来不。如是等。于中初偈显示如所不应见不可见故。云何不可见。诸见世谛故。是人行邪静者。定名为静。以得禅者。说名寂静。说名寂静者故。又复禅名思惟修故。于中思者意所摄。修者识所摄。言寂静者。即说觉及识。此世谛所摄。应知。彼不能见者。谓彼世谛行者。第二偈显示如彼不应见。及不应因缘。谓初分次分于中偈言以法应见佛者。法者谓真如义也。此何因缘。偈言。导师法为身故。以如为缘故。出生诸佛净身此不可见但应见法故彼不应见。复何因缘故不可见。以彼法真如相故。非如言说而知唯自证知故。不如言说者非见实不能知故。为显示此义故。偈言。法体不可见。彼识不能知故。于此住处中得显示以法身应见如来。非以相具足故。若尔如来虽不应以相具足见。应相具足为因得阿耨多罗三藐三菩提。为离此着故。经言。须菩提。于意云何。如来可以相成就得阿耨多罗三藐三菩提。须菩提莫作是念等者。此义明相具足。体非菩提亦不以相具足为因也。以相是色自性故

经曰。须菩提。汝若作是念。菩萨发阿耨多罗三藐三菩提心者。说诸法断灭相。须菩提。莫作是念。菩萨发阿耨多罗三藐三菩提心。说诸法断灭相。何以故。菩萨发阿耨多罗三藐三菩提心者。于法不说断灭相。须菩提。若善男子善女人。以满恒河沙等世界七宝持用布施。若有菩萨知一切法无我得无生法忍。此功德胜前所得福德。须菩提。以诸菩萨不取福德故。须菩提白佛言。世尊。菩萨不取福德。佛言。须菩提。菩萨受福德不取福德。是故菩萨取福德

论曰。此下第五于彼心具足中。为不住生死涅槃故。于中有二。一为不住涅槃。二为不住生死。为不住涅槃故。须菩提。汝若作是念。菩萨发阿耨多罗三藐三菩提心者。说诸法断灭相。如是等。于中经言。于法不说断灭者。谓如所住法而通达。不断一切生死影像法。于涅槃自在行利益众生事。此中为遮一向寂静故。显示不住涅槃。若不住涅槃应受生死苦恼。为离此着显示不住流转故。经言。须菩提。若善男子善女人以满恒河沙等世界七宝持用布施。如是等。于中经言。无我无生法忍者何义。如来于有为法得自在故。无彼生死法我。又非业烦恼力生故。无生故名无我。无生者。此中云何得显示。如说摄取余福。尚于生死中不受苦恼。何况菩萨于无我无生法中得忍。已所生福德胜多于彼。经言。须菩提以诸菩萨不取福德者。此显示不住生死故。若住生死即受福聚。又经言。须菩提白佛言。世尊菩萨不取福德者。此有何义。以世尊于余处说应受福聚故。经言。佛言。须菩提。菩萨受福德不取福德。是故菩萨取福德者。此显示以方便应受而不应取故。受者说有故。取者修彼道故。如福聚及果中皆不应着

经曰。须菩提。若有人言。如来若去若来若住若坐若卧。是人不解我所说义何以故。如来者无所至去无所从来故名如来

论曰。此下第六于心具足中为行住净。于中复有三种。一威仪行住。二名色观破自在行住。三不染行住。应知。为威仪行住故。经言。须菩提。若有人言。如来若去若来等。于中行者谓去来。住者谓余威仪

经曰。须菩提。若善男子善女人。以三千大千世界微尘。复以尔许微尘世界。碎为微尘阿僧祇。须菩提。于意云何。是微尘众宁为多不。须菩提言。彼微尘众甚多世尊。何以故。若是微尘众实有者。佛则不说是微尘众。何以故。佛说微尘众则非微尘众。是故佛说微尘众世界。如来所说三千大千世界则非世界。是故佛说三千大千世界。何以故。若世界实有者。则是一合相。如来说一合相则非一合相。是故佛说一合相。佛言。须菩提。一合相者。则是不可说。但凡夫之人贪着其事。何以故。须菩提。若人如是言。佛说我见人见众生见寿者见。须菩提。于意云何。是人所说为正语不。须菩提言。不也世尊。何以故。世尊如来说我见人见众生见寿者见。即非我见人见众生见寿者见。是名我见人见众生见寿者见。须菩提。菩萨发阿耨多罗三藐三菩提心者。于一切法应如是知如是见如是信。如是不住法相。何以故。须菩提所言。法相法相者。如来说即非法相。是名法相

论曰。此下第二为破名色身自在行住故。经言。须菩提。若善男子善女人。以三千大千世界微尘。如是等。于中细末方便。乃无所见方便等。此破如前说。应知。经言。彼微尘众甚多世尊者。是细末方便。经言。若是微尘众实有者。佛则不说是微尘众等者。是为无所见方便。此说有何义。若微尘众第一义是有者。世尊则不说非聚。经言。佛说微尘众则非微尘众。是故佛说微尘众以此聚体不成故。若异此者虽不说亦自知是聚何义须说。经言。如来所说三千大千世界等者。此是无所见方便。此破名身亦如前说。应知。于中世界者。谓明众生世故。彼唯名身得名故。经言。若世界实有者。则是一合相者。于中为并说。若世界若微尘界故。有二种抟取。谓一抟取及差别抟取众生类。众生世界有者。此为一抟取。微尘有者。此为差别抟取。以取微尘众集故。经言。如来说一合相则非一合相等者。此上座须菩提安立第一义故。世尊为成就如是义故。经说一合相者。即是不可说等。此何所显示。世言说故有。彼抟取第一义故。彼法不可说。彼小儿凡夫如言说取。非第一义。已说无所见方便。破义未说。无所见中入相应三昧时不分别。谓如所不分别。及何人何法何方便。云何不分别。此后具说。经言。须菩提。若人如是言。佛说我见等。以等显示如所不分别。云何得显示。如外道说我。如来说为我见故。安置人无我。又为说有此我见故。安置法无我。若有彼我见是见所摄。如是观察菩萨入相应三昧时。不复分别。即此观察为入方便。经言。须菩提菩萨发阿耨多罗三藐三菩提心者。此显示无分别人。经言。于一切法者。此显示于何法不分别。经言。应如是知如是见如是信者。此显示增上心增上智故。于无分别中知见胜解。于中若智依止奢摩他故知。依止毗钵舍那故见。此二依止三摩提故。胜解以三摩提自在故。解内攀缘影像彼名胜解。经言。如是不住法相者。此正显示无分别。经言。所言法相法相者。如来说即非法相是名法相者。此显示法相中不共义及相应义。如前已说。如是一切住处中。相应三摩提方便亦尔。应知。欲愿及摄散二种如前所说。更无别义。是故不复说其方便

经曰。须菩提。若有菩萨摩诃萨。以满无量阿僧祇世界七宝持用布施。若有善男子善女人。发菩萨心者。于此般若波罗蜜经乃至四句偈等。受持读诵为他人说。其福德胜彼无量阿僧祇。云何为人演说。而不名说。是名为说

  一切有为法　　如星翳灯幻
  露泡梦电云　　应作如是观

论曰。此下第三为不染行住。于中二种。一为说法不染。二为流转不染。为说法不染故。经言。须菩提。若有菩萨摩诃萨。以满无量阿僧祇世界七宝如是等。此何所显示。以有如是大利益故。决定应演说。如是演说而无所染。经言。云何为人演说而不名说。是名为说者。此有何义。显示不可言说故。不演说彼法。有可说体应如是演说。若异此者。则为染说。以颠倒义故。又如是说时。不求信敬等。亦为无染说法。为流转无染故。经说。偈言。一切有为法如星翳灯幻等。此偈显示四种有为相。一自性相。二者所住味相。三随顺过失相。四随顺出离相。于中自性相者。共相见识此相如星。应如是见。何以故。无智闇中有彼光故。有智明中无彼光故。人法我见如翳。应如是见。何以故。以取无义故。识如灯。应如是见。何以故。渴爱润取缘故。炽然于中着。所住味相者。味着颠倒境界故。彼如幻。应如是见。何以故。以颠倒见故。于中随顺过失相者。无常等随顺故。彼露譬喻者。显示相体无有。以随顺无常故。彼泡譬喻者。显示随顺苦体。以受如泡故。若有受皆是苦。以三苦故。随有应知。彼苦生故。是苦。苦破灭故。是坏苦。不相离故。是行苦。复于第四禅及无色中。立不苦不乐受。以胜故。于中随顺出离相者。随顺人法无我。以攀缘故。得出离故。说无我以为出离也。随顺者。谓过去等行。以梦等譬喻。显示彼过去行。以所念处故如梦。现在者不久时住故如电。未来者彼粗恶种子似虚空引心出故如云。如是知三世行转生已。则通达无我。此显示随顺出离相故

经曰。佛说是经已。长老须菩提。及诸比丘比丘尼。优婆塞优婆夷。菩萨摩诃萨。一切世间天人。阿修罗乾闼婆等。闻佛所说。皆大欢喜。信受奉行

论曰偈言

  若闻如是义　　于大乘无觉
  我念过于石　　究竟无因故
  下人于深法　　不能觉及信
  世人多如此　　是故法荒废

金刚般若波罗蜜经论卷下


金刚般若波罗蜜经破取着不坏假名论

    No. 1515

金刚般若波罗蜜经破取着不坏假名论卷上

        功德施菩萨造

        唐中天竺国沙门地婆诃罗等奉　诏译

  稽首能悟真实法　　离诸分别及戏论
  欲令世间出淤泥　　无言说中言说者
  一切异道之所作　　不能坏于诸想见
  彼难坏见金刚断　　故我归心此法门
  诸句义中秘密义　　世间智慧莫能测
  开喻我等及群生　　彼菩萨众今敬礼

佛所说法咸归二谛。一者俗谛。二者真谛。俗谛者。谓诸凡夫声闻独觉菩萨如来。乃至名义智境业果相属。真谛者。谓即于此都无所得。如说第一义。非智之所行。何况文字。乃至无业无业果。是诸圣种性。是故此般若波罗蜜中说不住布施。一切法无相。不可取不可说。生法无我无所得。无能证无成就。无来无去等。此释真谛。又说内外世间出世间。一切法相及诸功德。此建立俗谛。如是应知

如是我闻者。显示此经是世尊现觉而演。非自所作。一时者。说此经时。余时复说无量经故。在舍卫城等说处也。辩处何义利益众生。云何利益。令知此地佛曾游止。心净尊崇种福因故。一切经首列众者。何示现。如来大威德故。又结集者证已所传无异说故。诸大乘经中广说。世尊菩萨功德。须菩提于彼已生净信。是故言希有等。此中世尊者。谓何能永蠲夷四魔畏故。善逝者。于第一义一切法皆无所得。自证知故。如来者。三无数劫福智圆满。如是而来成正觉故。应者。诸烦恼怨已永害故。正者。不颠倒义。等者遍及满义。故名正等觉。护念有二种。如来摄受令悟真实护念也。又令转化无量众生。第一护念也。已知护念。何故付嘱。为有未能见真实者。此亦有二。彼诸菩萨普于世间当成如来独尊体相。如是赞美付善知识俾其瞻护。令已生佛法住及增长付嘱也。为未生胜法付之令生。第一付嘱也。复以何因。舍见真者赞于未见。哀彼未得胜智善品。诱劝其心令勇进故。善男子善女人发菩萨乘等者。谓所护念付嘱菩萨趣向佛乘。应云何住等。云何住者。于何相果心住愿求。云何修行者。当修何行而得其果。云何降伏其心者。降何等心使因清净。诸法先因而后果。何故先说果先赞果德。令彼欣求而修因故。谛听者。心专一境。善者于如理义生信无疑。思念者。敬持不忘。应如是住等者。如其次第于如是果而住其心。修如是行克证彼果。降如是心即因清净

此中显示菩萨果四种利益相应之心。何者为四。一无边。二最上。三爱摄。四正智。云何无边心。经曰所有一切众生之类。如是等言众生类。谓禀息风含情觉者。此复云何。所谓卵生诸鸟等。胎生诸人等。湿生诸虫等。化生诸天等。如是四种各多族类。此诸众生住于何处以何为体。经曰若有色若无色。有色者。谓有形。无色者。无有形。三界众生此皆摄尽。有形者。谓欲界二十依止处。色界十七依止处。无形者。谓无色界。此复几种。经曰。若有想若无想。若非有想非无想。有想者。谓空无边处识无边处。起空想识想故。无想者。谓无所有处离少想故。名为无想。非有想非无想者。谓有顶所摄。众生之聚。如是一切我皆摄受。云何最上心。经曰。我皆令入无余涅槃而灭度之。无余涅槃者何义。谓了诸法无生性空。永息一切有患诸蕴。资用无边希有功德。清净色相圆满庄严。广利群生妙业无尽。云何爱摄心。经曰。如是灭度无量众生实无众生得灭度者。此义云何。菩萨慈爱一切众生同于己故。众生灭度即我非他。是名爱摄。若第一义入初地等。诸菩萨无众生想。以众生不可得。如预流人不起身见。非彼菩萨见一众生是我所度。云何正智心。经曰。若有众生想即不名菩萨等。名何等耶。所谓凡夫。何以故。以必迷于第一义。起我想众生想命想取者想故。若证真实第一义者。众生等想决定不生。此中以般若力证第一义。一切众生皆不可得。大悲心故恒逐众生。处于生死随宜诱度。如是四种利众生果。应以俗谛而住其心。此四种心圆满果因。次应显示。是故经言。复次须菩提。菩萨不住于事行于布施如是等。此布施名中具六波罗蜜。施有三种摄于六故。何等为三。一者资生施。二者无畏施。三者法施。此中资生施。摄檀那波罗蜜。无畏施摄尸罗羼提二波罗蜜。于未作已作恶不生怖畏故。法施摄余三波罗蜜。精勤不倦引诸神通。如无所得为人说故。或彼一切诸波罗蜜为他开演。皆成法施。事等是何。云何不住事者。自身此身常有苦乐等无边事故。不住者谓于是中心无爱着。无所住者不望报恩。不住色等者心不悕求可意诸境。复以何义不住彼耶。心存于己不能惠施故。若有悕求退失菩提故。复次不住于事者。依资生施说。谓惠施者于所施财不应爱着。爱而行施心必生苦。或复施已还追悔故。无所住者。依无畏施说。谓诸菩萨修戒忍时。不应生心求彼果报。不住色等者。依法施说。法施有二果。谓现生他生。于此二中不应贪着。现生果者。谓所资用色等五境。此复云何。说法之人众所瞻敬。以妙色等妓乐香花饮食衣服而供养故。他生果者。依法境说。云何此中而亦不住。若诸菩萨证真实时。乃至法身亦无得故。云何修行六波罗蜜因得清净。经曰。须菩提菩萨应如是布施不住于相想如是等。此义云何。谓诸菩萨第一义中。施者受者及以施物。名义智境诸想不生。是即伏心因以清净。或曰有施者等可生福聚。三事并妄福于何有祸哉斯言第一义故不住于想。俗谛故行施。如是福聚难可度量。如十方虚空广遍无尽。前因行处应赞其福。此说者何降伏于心。想不生故。不生于想施方净故。由清净因福无边故

自下一切修多罗问答遣疑。持正法福德威力。此威力成就一切法修行。修行任运果因清净相。一切众生如来藏性佛境界。见佛法身法界相。无住涅槃观察有为。世尊说已

圣者须菩提疑曰。若菩萨施时法亦不住。云何以相好故行于施耶。百福相等功德法聚名为世尊。若不住法云何得成诸佛体相。为遣此疑经曰须菩提于意云何。可以相成就见如来不不也世尊如是等。相成就者是无常故。如经凡所有相皆是虚妄。诸相非相即非虚妄。非虚妄者所谓真实。以真实故名曰如来。诸相若存是虚诳矣。如经应以诸相非相而见如来。即相征求无所得故。若能远离众果悕望。乃至法身亦无所得。然恒如是行不住施。即于佛身速致成满

须菩提复疑曰。若三种施皆无所得为清净因。了相空性为真实果。于后世中谁其信乐。将无空说同乎石女。是故问言。颇有众生于未来世。后五十岁。法欲灭时闻此等经生实想不。为遣此疑经曰须菩提莫作是说。如是等后五十岁者。人寿百龄开为二分。初分五十教力增强。后渐衰减。佛涅槃已名未来世。此中正法将灭之时教力渐微。是故说为后五十岁。菩萨摩诃萨其义云何。于菩提处有决定心菩萨也。于一切众生誓兴利益摩诃萨也。云何复名有尸罗者。过去生中见无量佛咸供养故。供养有三种。一者给侍左右。二者严办所须。三者询承法要。能守护故名曰尸罗。谓能善守六情根故。彼复有三。一能离尸罗。离于十不善业故。二能作尸罗。作于菩提分业故。三能趣尸罗。趣于第一义谛故云何复名有功德者。种无贪等三善根故。质直柔和及智悲等。是名功德。云何复名有智慧者。了知生法二无我故。如是了知离于八想生法。各有四种想故。离生想者。经曰是诸菩萨无我想无众生想无命想无取者想。此义云何。有主宰用名之为我。谛观诸蕴无彼体相故。无我想安住常性名曰众生。诸蕴无常相续流转。无有一法是安住性故。无众生想。如有经说。汝今刹那亦生亦老亦死故无命想。诸蕴循环受诸异趣名为取者。是中无人能取诸趣。舍于现蕴而受后蕴。如去故衣而着新衣。然依俗谛。譬如因质而现于像。质不至像而有像现。由前蕴故后蕴续生。前不至后而后相续。是故菩萨无取者想。此谓了知生无我性离法想者。经曰无法想亦无非法想。无想亦无非想。此复云何。第一义法本不生故无法想。以不生故亦无有灭故。无非法想。法非法分别离故无想。此言无想但显想无。非谓有法而名非想。复次虽第一义离一切想。而随世间言语想说。是故菩萨亦无非想。此谓了知法无我性。云何但说有尸罗等持戒种善。能起深信智慧见真生于实想。一切功德此俱摄故。复以何义言知见。彼令诸菩萨心勇励故。彼作是言。我今信解如来知见。应更专勤修诸善法。何故知见二俱说耶。为欲开显一切智故。此复云何。一切智者于诸境界朗然现觉。非如比智见烟知火。不能照了诸相差别。亦非如肉眼见粗近物。细障远处则不能知。但随说一或如彼故。若诸菩萨起我等想及法等想。有何过失。因此生于我等执故。云何我等想生我等执。若生此执有其想故。云何法等想生我等执。我我所蕴中起法非法想。非于无我土木等故。经曰不应取法不应取非法。此何义耶。舍二边故。法有性相尚不应取。何况非法本无性相。复次无分别者。善如法尚不取。况不善非法。或念言不善不应取。何故不取善。若善法亦不取者。佛何故三无数劫积集资粮。是故经言。以是义故如来常说如筏喻者。法尚应舍何况非法。此义云何。如欲济川先应取筏。至彼岸已舍而去之。世尊亦尔。欲度苦流假资粮筏。超一切果登涅槃岸。乐因尚离何况苦因。如象胁经说。若出生死证涅槃界。爱非爱果法非法因一切皆舍

复次疑曰。若证时法非法皆舍。何故世尊以一念相应正智。现觉诸法有所说耶。为遣此疑经曰须菩提于意云何。如来得阿耨多罗三藐三菩提耶。如来有所说法耶。如是等此明何义。显示世尊证于真实无法可取。言诸法者。顺俗名言非第一义。若法非法皆无所取。即依俗谛说名菩提非有实物。如说大梵诸佛如来证菩提者。谓无所得。若无所得。云何世尊有诸能事。如来本愿普利群生。我成正觉离诸分别不由作意。乃至众生生死未尽。随其种类欲乐不同。形相言音差别应现。于诸法性皆无所得。是得菩提亦名法身。菩提法身无所得故。虽无动念仍先誓力。无边色像以严其身。十方国土周行不碍。凡有见闻靡不蒙益。圣者须菩提。以菩提无生故。密意答言。无有少法如来所得。非于无生而不现证。如经如来所说法。皆不可取不可说。非法非非法。此义云何。无生者。非是法亦非非法。法非法分别境故。不可取不可说者。无能取说故。证无所得故。如经以无为相说名圣人。无为者。无所得义。无为相者。无所得自性义。圣人者。见真实义

须菩提复念言。有尸罗等于经深信其福几何。是故广明持法威力。经曰须菩提于意云何。若满三千大千世界七宝以用布施。乃至为他人说。如是等为他说者。谓于二谛有所得无所得。理善能开演不颠倒故。其福胜彼。无量阿僧祇者。非心所量无量也。六十位数所不能及阿僧祇也。福德聚即非福德聚者。财施虽多比持经福即为少故。持经福多二门成立。谓教及理。云何为教如有经言。施中最者所谓法施。今此宝施是财施摄。云何为理。财施虽获富饶之果。住于生死无常败坏。法施能成究竟功德。永断一切生死苦因。如经阿耨多罗三藐三菩提从此经出。诸佛如来从此经生。云何出生。依此法门心无所得。证无生理妙菩提故。又说诸法无生等义。是语律仪。从此生于众德身故。由身律仪相圆满业生化身故。复以何义。则施唯得大财位果。非诸佛因。经曰佛法者。即非佛法是名佛法。其义云何。诸法体性空无所有。此若开显是佛法身。见有性者于法未悟。依此密意说非佛法。若知法无性觉故名佛。此法佛有余人无。是名佛法。由持正法了法无性行于财施。不能如是法施福多。以斯义故

复次疑曰。若所证法无有性者四圣果云何得成。不见世间无物有果。为遣此疑。经曰须菩提于意云何。须陀洹能作是念。我得须陀洹果不。须菩提言不也世尊如是等。何故名为须陀洹。以预于无得流故。云何无得。于色等境皆无得故。十有五念为见道。乘此向果名彼果向。第十六念说为住果。人天二别极七返生。何故七生余七结故。七结者何。谓欲贪及嗔色无色爱掉慢无明。从此复断欲界中修所断惑。乃至五品名斯陀含向。是中复说二种家家。谓天及人。天家家者谓于天趣或于一天。或二三天。诸家流转而般涅槃。人家家者。谓于人趣或于此洲。或余洲中。诸家流转而般涅槃。尽第六品名住此果。更一来生此世间故。如是次第复断二品一生为间。当般涅槃。是即名阿那含向。九品永离名住此果。更不还生于欲界故。如是复断初禅地欲。乃至有顶第九品无间道时。一切说名阿罗汉向。此无间道亦名金刚喻定。以能永坏诸惑随眠。至解脱道名尽智。与漏尽得同时生故。如是名住阿罗汉果。应作自他利益事故。应为一切有贪著者所供养故。如是四人皆不作念我能得果。何以故。在证时无所得故。如经实无有法名须陀洹。乃至实无有法名阿罗汉。何故不欲得果念耶。若是念生有我等取。离身见者无彼取故。是故先说以无为相说名圣人。无为相者。空性相义。须菩提述己所得证无是念。曰如来说我无诤行第一我是离欲阿罗汉。我不作是念如是等。此义云何。若须菩提行于无诤不悟即空。何故如来赞言第一。言第一者悟即空故。如经以须菩提实无所行。诤者是何。所谓烦恼。离彼烦恼名无诤定。须菩提住于此定。障及诤皆不与俱故。随俗言无诤行无诤行也。复次疑曰。若预流等不得自果。云何世尊遇然灯佛获无生忍。为遣此疑。经曰须菩提于意云何。如来昔在然灯佛所。于法有所取不。须菩提言不也世尊如是等。此明何义。显示昔遇然灯佛时。以悟无生无法可取。言获忍者。以俗谛故。如说得菩提者谓无所得。复有经说。文殊师利我坐道场。无得而起金刚场。经又作是说。我所有法皆不可得。若声闻独觉及以如来。或曰。言语不能取于证法。非智不取。此说违经。经说第一义非智之所行。何况文字故。复次智所知境名所诠境。是二差别智之所证。名初不行。何义须说语不能取。斯或太简应具说。牙齿手足诸身分等不能取故。复次有余经中世尊自释。然灯佛所得无生智不取于法。如彼经言海慧当知。菩萨有四。所谓初发心菩萨。修行菩萨。不退转菩萨。一生补处菩萨。此中初发心菩萨见色相如来。修行菩萨见功德成就如来。不退转菩萨见法身如来。海慧一生补处菩萨。非色相见。非功德成就见。非法身见。何以故。彼菩萨以净慧眼而观察故。依净慧住依净慧行。净慧者无所行非戏论不复是见。何以故。见非见是二边远离二边。是即见佛。若见于佛即见自身。见身清净见佛清净。见佛清净者。见一切法。皆悉清净。是中见清净智亦复清净。是名见佛。海慧我如是见然灯如来。得无生忍。证无得无所得理。即于此时上升虚空高七多罗树。一切智智明了现前。断众见品超诸分别。异分别遍分别。不住一切识之境界。得六万三昧。然灯如来即授我记。汝于来世当得作佛号释迦牟尼。是授记声不至于耳。亦非余智之所能知。亦非我惛蒙都无所觉。然无所得亦无佛想。无我想无授记说授记想。乃至广说。言无想者。显是智证而无所取。想者心法非是语故。当知此中说智之境。是故言以净慧眼而观察故。复次无生忍者是心法。非语法故。复次证于无得无所得者。以法无性无能取得。此无得理有可得耶。都无所得岂智能取。复次断众见品。超诸分别见品分别智法非语。复次不住一切识之境界。不言不住一切语境故。无所取是智境界。云何余师固谓遮语

复次疑曰。若智亦不能取诸佛法。何故菩萨以智取佛土功德而兴誓愿。为遣此疑。经曰须菩提。若菩萨作是言。我成就庄严佛国土。是人不实语如是等。众妙珍绮悦可于心名为庄严。彼有体相色等性故。第一义中斯不可得。说非庄严也。而依俗谛以智成就是名庄严也。菩萨应如是不生。有住心者我作我成就。如是住心不应生故。不应住色等生心者。于色等果不应求故。应无所住而生其心者。以智成就而不住。彼如是心应生故。复次疑曰。若不取一切法。云何诸佛取遍满自在身耶。为遣此疑。经曰须菩提。譬如有人身如须弥山王如是等。此喻显示彼相似法自在之身。其义云何。如须弥山由共业力。虽无分别而生大体。如来亦尔。于无量劫修诸福行。虽获大身不由分别。如来何故。同须弥山无分别耶。第一义中山及色身无体性故。是形相者。皆有为故。如经何以故佛说非身是名为身。非谓有身名为大身

复次显示受持正法。其福甚多。是故此中重说譬喻。经曰如恒河中所有沙数如是沙等恒河。于意云何。是诸恒河沙宁为多不如是等此之胜喻何不先举。以诸凡夫未见真实。先为广说不生信解。渐次闻之乃生信故

复次受持福多。以十三种因而得成就。所谓处可恭敬故。人可尊崇故。一切胜因故。彼义无上故。越外内多故。胜佛色因故。超内施福故。同佛出现故。希能信解故。难有修行故。信修果大故。信解成就故。威力无上故。世尊何故。殷勤说此诸因相耶。以诸众生行资生施求财位果。不持正法断诸苦因。此中处可恭敬者。经曰复次须菩提。随所有处说是法门。乃至一四句颂。当知此处即是支提如是等。人可尊崇者。经曰当知是人成就最上希有之法如是等。一切胜因者。经曰当何名此法门。乃至名为般若波罗蜜如是等。此义云何。诸佛菩萨以般若波罗蜜。于世出世最胜了知。今此法门如是教故。云何知然。如经即非波罗蜜故。此复云何。智功德岸无能量者。复次非彼岸者。谓三界法智能称量知不坚固第一义本性无生。是故说言非波罗蜜。彼义无上者。即如是义无有上故。如经须菩提于意云何。如来有所说法不如是等。此义云何。以般若波罗蜜中无法可得。是故如来亦不能以文字而说。唯此分量说名菩提。如有经言空中鸟迹不可得。菩提性亦复如是。言菩萨者。于无得中能觉了故。越外多者。经曰三千大千世界所有微尘是为多不如是等。此中举大千界微尘数多。为欲对显受持之福。云何显耶。比持经福即非多故。如经是诸微尘如来说非微尘。非微尘者显非多义。若以非多名非微尘者。云何复说是名微尘。依自分限。是一大千微尘数故。越内多者。经曰所有世界如来说非世界等。此中世界者。谓众生界。大千界中一一众生。出息入息微尘刹那皆亦多故。非世界等如微尘说胜佛色因者。经曰可以三十二相见如来不如是等。此明何义。显示法身无相为体。如经三十二相即是非相非相者。非法身相是名相者。是佛色身丈夫之相。受持等福是法身因。非诸相因。是故此福最为殊胜。超内施福者。经曰若善男子善女人。以恒河沙等身布施。乃至其福胜彼无量阿僧祇。此何所因是财施故。舍身尚尔况外物耶。云何名为同佛出现。佛兴于世薄福难逢。此经亦然。预闻者少。如经尔时须菩提。闻此法门深生信解。悲泣雨泪扪泪而白佛言。希有世尊如是等。须菩提阿罗汉人。随佛觉悟于此正法。昔尚不闻。是故希有同于佛现。希能信解者。经曰若复有人。得闻此经生于实想。当知成就最上希有如是等。实想者。谓闻此法门是无边福因。以为实故。复次谓闻难得同于佛兴。以为实故。复次谓闻此说一切法无生无所得等。以为实故。若一切法无生。何故言当生实想。虽生实想不坏无生。如经实想者。即是非想。是故当知生实想者。依俗谛说第一义。即非实想。复次俗谛名实想者。俗谛之想。是人虽信诸法无生。而不舍俗谛法故。以是当得最上希有。难有修行者。经曰我今得闻如是法门信解受持不足为难如是等。信修果大者。经曰是诸众生无复我想众生想命想取者想如是等。此义云何。以于此经信及行故。了生无我性。不生我等想。何以故。有所取我是中乃生能取想故。彼能取想。随俗言说第一义即是非想。何以故。诸佛世尊证法无我。远离一切分别想故。诸佛体相名为大果。信解成就者。经曰若复有人。得闻是经不惊不怖不畏如是等。此中不惊者。谓于诸法无生之理。心不惊愕趣生道故。不怖者。谓于诸法无和合相心不怖惧。而于世俗和合相中。相续分别执为实故。不畏者。心不如是永决定故。复次不惊等者。如其次第。谓闻法时思惟时修习时心安不动。众生等想已远离故。威力无上者。经曰须菩提如来说第一波罗蜜。须菩提此第一波罗蜜。如来说彼无量诸佛亦如是说如是等。云何名第一。无与等者故。云何无与等一切佛法中威力最胜故。一切诸佛同演说故。以如是等十三种因。持经之福多于宝施。复次疑曰。若一切佛法中般若波罗蜜最为上者何用勤苦行余度耶。为遣此疑。示现般若摄持余度。经曰须菩提如来忍辱波罗蜜即非波罗蜜如是等。非波罗蜜者。远离此分别心故。云何无分别。经曰。如我昔为歌利王割截支体我于尔时无我想无众生想无命想无取者想。如是等此义云何。若有我等想。即见有自他。他来犯己必生嗔恨。若谓无分别想是愚痴心。痴心作因嗔念还起。于彼王所孰能不校。以不校故证知无想。亦非无想。无想者所谓无我等想。无自他想及嗔恨想。非无想者。谓非愚痴。何故愚痴名为无想。不能观察是应作是不应作故。复次无想亦非无想者。离于想无想染着分别故。此已说被虐害时摄持忍辱。复欲显示余时摄持。经曰。又念过去于五百世作忍辱仙人如是等。此显往昔未遇恶王。已于多生断我等想。皆由般若摄持力故。复欲显示摄持菩提。经曰。菩萨应离一切想发阿耨多罗三藐三菩提心。以离诸想得菩提故。如说坐于菩提座永断一切想。云何离想耶。经曰。不应住色生心。不应住声香味触法生心。应生无所住心。若生无所住心者。云何住菩提而发心耶。以住菩提故无所住。如经何以故如是住者。即为非住。此义云何。如是住者俗谛故。非住者第一义故。复次言住菩提即是非住。如有经说。菩提无住处是故非住。是住菩提之异名也。已说般若摄持忍辱。摄持余度其相云何经曰。是故佛说菩萨心不住色布施。不住声香味触法布施。三施摄六如前说故。五波罗蜜离于施物施者受者。三种分别。即是般若波罗蜜相故。持余度其义得成。如说五波罗蜜。若离般若如阙目者而无导师。为显示彼方便故。经曰。菩萨为利益一切众生应如是布施。或念言若不住法而行施者。云何为利益众生。是故经言。一切众生想即是非想为利益者。俗谛言说第一义即是非想。何以故。以众生想取诸众生。计与蕴异或不异等。第一义中皆不可得。如经是诸众生即非众生。此显远离智及所知二种分别。言非想者显智无性。非众生者。所知无性彼二无性。如来证了诸想永除。证无性故

金刚般若波罗蜜经破取着不坏假名论卷上金刚般若波罗蜜经破取着不坏假名论卷下

        功德施菩萨造

        唐中天竺国沙门地婆诃罗等奉　诏译

须菩提复念言。诸佛离一切想。证法无性。世间以何相故而信知耶。是故经言。如来是真语者实语者如语者不异如语者。何故但以如是四句。显示诸佛证实离想。以世间中求名利者。于上人法未证言证。佛异彼人故说真语。复有贪鄙情多矫妄。曾获神通自知已失。有人来问。但云先得远离是心说于实语。又有修得世间之定。心暂不生相同寂灭。而向人说我证涅槃。永除此谬故说如语。此言如取如是义。所随如字应可比知。必同行故。如说义时相同行相违。乃至广说。是中同行者。如母牛来子亦随至。如与如是应知亦然。此显如来断一切障。如彼明证如是而说。不同学得世间禅者。言证涅槃寻复退失。何为复说不异如语。以诸凡夫于乾闼婆城梦幻响像热时之焰旋火之轮。如其所对如是取著名为异如。诸佛不然。是故说不异如语。此复云何。诸凡夫人所取城等非城等。有名为异如。如来所证非虚妄。有不诳性故。名不异如。是故所言未尝虚妄。云何知然。佛已净除一切障故。有证及教可辨明故。云何为证。譬如说色是无常等。色法现是无常等故。云何为教。如有经言。童子我一切知一切见也。复次真等四谛之名。如来证知此四深理。是以能说。说而不知。无是处故。此中真语者。说于苦谛色等诸蕴。真是苦故。实语者说于集谛爱实苦因。非自在等能为因故。如语者。说于灭谛无为涅槃。有为虚妄无为反是。如说无为之法。非虚妄性名之为如。不异如语者。说于道谛。离八支道言得涅槃虚诳不实。此道能得实非妄故。或念言。若诸佛离一切想。云何于法现证。而说言八支道是实。入水火等为妄。说实妄故有分别想。是故经言。须菩提如来所得法。所说法无实无妄。此义云何。如来证第一义。一切法本性无生。无生故不曾是有。云何名实。既无生岂有灭。是故非妄。实妄二境皆不可得。于何而生彼分别想。所说之法是文字性。文字有为故非实依。而证实故非妄

复次疑曰。若所证法无生无性非实非妄。是即诸佛第一义身。从此为因二身成满。菩萨何故舍所证法。住于事等而行施耶。为遣此疑。经曰。须菩提。譬如有人入闇即无所见。若菩萨心住于事而行布施如是等。此闇明二喻。示有住无住过失功德。其义云何。如人闇中舍平坦路行于非道。颠坠艰险受诸苦难。于所乐处近而不达若诸菩萨住事行施舍无得性平疾之道。行于有得险难之路。于生死中受诸困厄。涅槃之所何时可至。如人有目者。得无生忍也。夜分已尽者。舍于果爱也。日光明照者。决定了知诸法无性。见种种色者。悟一切法不灭不生不断不常不一不异不来不出无所得等。菩萨如是行不住施。速成正觉得大涅槃

此一切法修行中有自他二利。自利复有教义修行。教修行者。谓受持读诵。义修行者。听闻思惟。利他者。谓为人演说。如经须菩提。若善男子善女人。于此法门受持读诵修习演说。如来悉知是人悉见是人。生如是无量福德聚。取如是无量福德。此中受者作心领纳故。持者温记不忘故。读诵者披讽其文故。修习者谓听闻及思惟故。无量福聚其相云何。经曰。若善男子善女人。初日分以恒河沙等身布施。乃至于此法门信心不谤如是等。此布施福转胜于前。以事与时二种大故。事大者。如经以恒河沙等身布施故。时大者。如经百千亿那由他劫故

修行任运果今说云何名为任运果。谓修行者从初乃至未成正觉。此生余生获诸功德。本所期者是佛果故。功德是何。所谓魔及异道不能沮乱。功德大故。殊胜无等坚牢福果。最上法器圆满资粮。能荷难胜深大信解福因之处。拔一切罪速疾证地。此中魔及异道不能沮乱者。经曰。此法门不可思议。其义云何。以法威力不思议故。斯人福慧超诸智境。是故邪徒莫能沮乱。功德大故。殊胜无等者。经曰。不可称量以能受持。不可量法功德威力余无与等。是故此人最为殊胜。坚牢福果者。经曰。无量果报邪莫能沮故。功德广大故。于天人中受诸胜福无能逼夺令其不受。最上法器者。经曰。此法门如来为发大乘者说。为发最上乘者说。法岂虚行授之以器。圆满资粮者。经曰。若有人受持读诵修习演说如是等。此中受持读诵为他说故。福德增长。听闻思惟故。智慧增长。示何增长。如经皆成就不可思不可称无有边无量功德聚。言无量者。显此功德非是一切心量之境。是故思所不能知不可取。而称无边际可得。能荷难胜者。经曰。如是人等。即为荷担如来阿耨多罗三藐三菩提。此义云何。如佛成就难思妙法。慱济群苦无复遗余。持经之人当如是故。广大甚深信解者。经曰。若乐小法者。即于此经不能受持读诵如是等。此中广大信解者。无小意乐故。甚深信解者。无我等见故。福因之处者。经曰。在在处处。若说此经如是等。集福舍罪故名支提。人能演法功与之等地。虽无思持说者。故拔一切罪者。经曰。若善男子善女人。受持读诵此经。为人轻贱如是等。受持此经方致成佛。反被轻贱。其故者何。经曰。是人先世罪业应堕恶道。以今世人轻贱故。先世罪业即为消灭。如来品说。若复有人受持此经。乃至演说。是人现世或作恶梦。或遭重疾。或被驱逼强使远行。骂辱鞭打乃至殒命。所有恶业咸得消除。复有颂言

  若人造恶业　　作已生怖畏
  自悔若向人　　永拔其根本

怖心悔过尚除根本。何况有人受持正法。此岂不与余教相违。如说

  业虽经百劫　　而终无失坏
  众缘会遇时　　要必生于果

非有相违。此复云何。且十不善恶趣之业。由持正法及悔先罪。恶趣果虽永不生。然于现身受诸苦报。现受诸苦岂失坏耶。不生恶趣非拔根耶。若有无间决定业者。命终之后定生彼故。应住劫受须臾出故。如阿阇王等。是故无违。速疾证地者。经曰。我念过去无量阿僧祇劫。乃至若复有人。于后末世能受持读诵此经。广为人说。我所供养诸佛功德。于此百分不及一如是等。此义云何。无边佛所供养之福。不证真实。持此法门速疾能证。是故受持功德威力。设为百分彼前福聚不及其一。如是千分百千分数分不及。取类应知。数者谓六十位。过斯已往数不能及歌罗。不及校计。不及者此依歌罗微细义说。谓受持福最微细性功德已多。非前所及。穷于校计终无与等。微细尚尔况一切耶。优波尼沙者因也。其义云何。此少分福于最胜果即成因性。总前福聚亦不成因。不能得真实果故。譬喻不及者。如有童女称为月面。女面岂能全类于月。以有光洁少分相同。彼前福聚即不如是。无少相似可为譬喻。此复云何。谓但受持文字之福。前福于此无相似性匪薄福人。而能听受此文字故。如经若我具说者。或有人闻心则迷惑而生轻贱。谓闻此功德威力思惟时不信时也。如经此法门不可思议。果报亦不可思议。二俱难思威力胜故

须菩提何故复言发菩萨乘。应云何住等。欲具显因清净相故。何者不具云何具显。谓所修因非但离于三事相想即名清净。要当远离我住我修我降伏心。如是诸想方得净故。如经应生如是心。乃至实无有法名为发菩萨乘者。此复云何。第一义无有众生得般涅槃。亦无有法名为菩萨。发心住果修行降伏。于无有中而起有想。是颠倒行非清净因。复次疑曰。若无菩萨发趣大乘。则无有因证于佛果成满四种利益之业。云何世尊然灯佛所。而得授记。汝于来世当得作佛。号释迦牟尼。能成四种利众生事。为遣此疑。经曰。须菩提。于意云何。如来昔在然灯佛所。颇有法得阿耨多罗三藐三菩提不如是等。此中意说。佛于往昔证真实义得授记时。不见少法而是无上菩提。因体以无所得得授尊记。此即证知一切法皆无所得。如经须菩提。言如来者以真如故。真如者无所得义。须菩提心念我于此说虽复无疑。然有人言。然灯佛所不见有法。能得菩提升于觉座。岂亦如是。是故经言。须菩提若有人言如来得阿耨多罗三藐三菩提。是人不实语。乃至如来所得法。是中无实无妄。此义云何。夫实妄者生于有得。有时言实坏时知妄。无所得中此二俱遣。复有念言。若如来但证无所得者。佛法即一非是无边。是故经言。如来说一切法皆是佛法。佛法谓何。即无所得。未曾一法有可得性。是故一切无非佛法。云何一切皆无所得。经曰。一切法者即非一切法。云何非耶。无生性故。若无生即无性。云何名一切法。于无性中假言说故。一切法无有性者。即是众生如来藏性。是故世尊垂次开显。经曰。须菩提。譬如有人其身妙大如是等。妙大身者。谓空性身。云何妙大。随于所在而不异故。一切众生咸共有故。如说此一众生空性。彼一切众生空性。如来有之。众生亦有。何故但说如来藏一切众生有。不说众生藏如来有耶。以诸众生未证空理。如来证故。如有经说。众生身内有如来藏具相庄严。岂不同于妄计神我。虽如是说。然了空性名为法身。法身为因乃生色相。非与外道所说我同。如楞伽经。大慧菩萨白佛言。世尊。修多罗中。说如来藏本性清净。具三十二相。在于一切众生身中常住不变。为贪嗔痴妄分别垢蕴界处衣之所缠裹。如无价宝垢衣所缠。世尊。此说云何。不同外道邪论。外道说我是常作者。体非求那周遍无尽。佛言。大慧。我所宣说如来藏义不同外道所说之我。如来藏者。即是空性实际涅槃。不生不灭无相无愿。如是等义。如来为欲止息愚人无我怖畏。说无分别无虚妄境如来藏门。大慧。现在未来诸菩萨摩诃萨。不应于此计着生于我见。乃至广说。须菩提为欲阐明妙身大身是空性义。经曰。如来说人身妙大即是非身。非身者。谓以色身依实义说。无生性故。说无生性为妙大身。非色身也

上所说因清净相义未圆满。为满足故。经曰。须菩提菩萨亦如是。若作是言。我当灭度无量众生。即非菩萨如是等。以要除能度所度一切分别。菩萨修因方得净故。复为成就无分别心。经曰。颇有法名为菩萨不。须菩提言。不也世尊。乃至佛说一切法无我无众生等。第一义无菩萨无凡夫故。我当庄严佛国土不名菩萨者。染着因故。于色等聚所成佛土。如是取故。即非庄严者。实义无生故。是名庄严者。俗谛言说故。通达无我法说名菩萨者。离一切想因清净故

复次疑曰。若清净因离诸想者。有境可得为无有耶。是故此中说佛境界。经曰。须菩提。于意云何。如来有肉眼不。须菩提言。如是世尊。如来有肉眼。乃至如来有佛眼不。须菩提言。如是世尊。如来有佛眼如是等。何故世尊说具五眼。示于境界无不了知。此中有众生数境非众生数境。如经所有众生若干种心住等。显示了知众生数境。恒河沙数世界等。显示了知非众生数境。若干种心者。欲乐不同故。住者相续而转故。或作是念。心若能住斯应有体。是故经言。如来说诸心住皆为非心住。非心住者第一义。无相续故。如经何以故须菩提过去心不可得。现在心不可得。未来心不可得。此复云何。过去心已灭故。未来心未生故。现在心不住故。无形故。宝积经言。迦叶。一切佛不见过去心。不见未来心。不见现在心。乃至广说。经曰。若福德聚有实如来即不说福德聚。此意云何。聚者蕴义。假名不实。实即非蕴。于何说聚。云何知假名不实。第一义无积聚故。俗谛中有言说故。如是五眼都无所得。是佛境界。以是应知。离想净因无境可得。是故大般若波罗蜜中如是言。须菩提。如来五眼。于第一义都无所得。若言有得愚人谤我

复次疑曰。若第一义佛境界是无所得。色相如来岂亦非有。为遣此疑。经曰。须菩提。于意云何。如来可以具足色身见不须菩提言不也。世尊如是等。此显示见佛法身。云何见耶。如经如来说具足色身即非具足色身等。此依实义。即于色相而见法身。非具足者。是法身故。如说无生性是常住如来乃至广说

复次疑曰。若第一义佛境界及色相身皆无有体。岂具足众德。言说相身亦复非有。遣此疑故。经曰。须菩提。于意云何。如来作是念。我有所说法耶如是等。欲使定除有说执故。经曰。若人言如来有所说法即为谤佛。乃至无法可说是名说法。此义云何。说无体故。不见内外漏无漏法少有真实而可说故

须菩提复欲显示于此所说信受者难。是故言。颇有众生于未来世。闻说是法生信心不。乃至彼非众生非不众生等。云何非众生。第一义即蕴异蕴。推求其体不可得故。如经说。非众生云何非不众生。以俗谛依于五蕴业果相应而施设故。如经是名众生。复次疑曰。若第一义佛境界色身言说身皆不可得。法身体性岂亦然耶。为遣此疑。经曰

须菩提。于意云何。颇有法如来得阿耨多罗三藐三菩提耶。须菩提言。不也世尊。如是等。此义云何。佛证真实不见少法是所得故。以无所得。是故说名阿耨多罗三藐三菩提。何故无所得。经曰。是法平等无有高下。何故平等。经曰。以无我无众生无命无取者。如生无我中平等故。无所得法无我亦如是。此无得理以何因证。经曰。一切善法云何善法有体可得。而能证无所得理法不相似岂得成因。经曰。善法者。如来说为非法。云何非法。第一义无生性故。当知此因即无所得。善法者。俗谛言说非真实义

何故复以须弥尘量宝施之福而校量耶。令修行者心勇进故

复次疑曰。若如来说非众生者。云何不与余教相违。如有经言。无量众生以得我为善知识故。生等诸苦并皆解脱。为遣此疑。经曰。须菩提于意云何。如来作是念我度众生耶。乃至实无有众生如来度者如是等。无众生者第一义故。复次以大悲心摄同己故。若实有众生异于如来是所度者。如来即有我等四取。何以故。若见有己能度众生。是我取故。何故不欲我等取耶。经曰。我取者。如来说为非取。非者何义。所谓不善。云何不善。缚诸众生住生死故。复次非者。无体性义。此复云何。以无所取我亦无能取故。若我等取无体可得。何用遣我言非取耶。以诸凡夫颠倒妄取。言非取者令彼解故。如经但无智凡夫生之所妄取如是等。未得圣者各封于我差别而生名凡夫生。彼即非生不善生故。如不善人说为非人。复次法从缘起。无我造作故名非生。是故说名凡夫生者随俗言故

以诸众生于佛色身多生取着。是故复说色身无性。经曰。须菩提于意云何。可以相成就见如来不。乃至转轮圣王应是如来如是等。佛欲令于色等身见法身义。受持时易。故说颂言

  若以色见我　　以音声求我
  是人行邪道　　不能见如来
  如来法为身　　但应观法性
  法性非所见　　彼亦不能知

以色见我等。其义云何。谓有见光明相好。言见于佛及有听受经等文字。言我随逐而得如来。彼作是言。于相好身及言说身。攀缘修习当断烦恼。为除此见。经曰。是人行邪道不能见如来。此义云何。色及文字性非真实。于中取着是邪道故。行于此道何能见佛。云何见耶。经曰。如来法为身但应观法性。法性者。所谓空性无自性无生性等。此即诸佛第一义身。若见于此名为见佛。如有经说。不生不灭是如来故。十万颂经复作是说。慈氏以见空性名见如来。萨遮经中又作是说。无取着见名为见佛。若无取著名见佛者。攀缘法性将非取着。以净智心了知法性。法性岂是所了知耶。是故经言。法性非所见。彼亦不能知法性之处。无有一物可名所知。由是彼智亦不能知。如有经言。大王。一切法性犹如虚空。等与众物为所依止。而其体性非是有物亦非无物。能于此中寂然无知名为了知。名为知者。随俗言说

复次疑曰。若智亦不能知法性者。云何诸佛具丈夫相而证菩提。以见具足丈夫相者。得菩提故。为遣此疑经曰。须菩提于意云何。如来诸相成就得阿耨多罗三藐三菩提耶如是等。此中显示法界相。其义云何。若相成就是真实有。此相灭时即名为断。无有菩萨见法断故。何以故。以生故即有断。一切法是无生性。所以远离常断二边远离二边是法界相。是故于此说能信解无生之福多于宝施。如经须菩提若善男子善女人。以恒河沙等世界七宝持用布施。若菩萨得无我无生法忍如是等。但于无生爱乐修习福多彼故。如有颂言

  若人持正法　　及发菩提心
  不如解于空　　十六分之一

或念言。若一切法无生者。云何而有福德生耶。是故经言。须菩提菩萨不应取福德如是等。不应取福者。非第一义中有福可取故。须菩提白佛言。世尊。菩萨不取福德者。菩萨于福应圆满故。佛言。须菩提菩萨应取者俗谛故。不应贪著者第一义谛故

复次疑曰。若第一义无福可取。何故余经作如是说。如来福智资粮圆满。坐菩提座趣于涅槃。为遣此疑。经曰。须菩提。若有人言。如来若去若来若住若坐若卧。是人不解我所说义如是等。涅槃无有真实处所。而至于彼。名之为去。生死亦无真实处所。而从彼出。名之为来。不去不来是如来义。此即显示无住涅槃。虽生死涅槃无有一异。而于三界牢狱引喻众生。尽未来际而为利益

复次疑曰。若生死涅槃不可得故无去来者。如来岂如须弥山等积聚一合而安住耶。为遣此中是一是常无分有分一合见故。经曰。须菩提。若善男子善女人。以三千大千世界碎为微尘。是微尘众宁为多不如是等。此中微尘众多者。遣无分一合见。非微尘众者。遣有分一合见。是名微尘众者。非有分物说之为众。复为遣积聚见故。经曰。如来说三千大千世界即非世界如是等。何故复说非世界耶。经曰。若世界实有即是一合见。何故不欲一合见耶。经曰。即为非见。云何非见。于非有中而妄见故。如经一合者即是不可说。但我见凡夫而取其事。此义云何。一合者。是俗谛相非真实有。何以故。第一义一切法本性无生。无生故不可得。不可得故离于言说。而我执凡夫于中妄取。若不欲我见与教相违。如有颂言

  我以己为依　　讵以他为依
  智者能调我　　生天受安乐

为遣此疑。经曰。须菩提若有人言如来说我见众生见命见取者见为正语不如是等。佛何故说见我耶。为诱摄信乐者故。此于五蕴随俗名言。非谓真实。是故诸佛所见我者是远离性。如经即非我见等。世尊以离生死涅槃我等合见。而得菩提。复愍诸含识欲令同证。是故言。须菩提发菩萨乘者。于一切法应如是知如是见如是信解。不生法想知见者。谓证时。信解者。修学时。信解之人法想尚不生。况非法想。此云法想非法想者。谓如法分别不如法分别法想。如法何故不生。经曰法想者。如来说为非想。此复云何。一切法无生性故。若无生即非有。于何知见。以俗谛故。如经曰。是名法想。何故复说受持之福。欲令众生毕竟信故。经曰。如无演说是名为说。此何谓耶。第一义无世出世。若法若物少有可说。能如实义如是说者。乃名为说。此无住涅槃观察有为然后方证。云何观察。经曰。尔时世尊。而说颂言

  一切有为法　　如星翳灯幻
  露泡梦电云　　应作如是观

今此颂中。观察有为九种体相。何谓为九。所谓观察自在。观察境物观察迁动。观察体性观察少盛。观察寿观察作者。观察心观察有无。此中观察自在如星。譬如星等着象于空随方运行。光色炽盛假令久住终随劫尽。如是人天受诸福报。丰财重位众所瞻仰。虽久自在会亦归空。观察境物如翳。譬如翳目于净空中见有毛轮飞花二月。无明翳识亦复如是。于真实理无物之处。而见内外世出世间种种诸法。观察迁动如灯。譬如灯焰即生处灭不至余处。然因此焰余处焰生。念念相续如有迁动。众生亦尔。前趣诸蕴即前趣灭不往余趣。然因前蕴后趣蕴。生以相续故。状如迁动。言诸凡夫数往余趣。观察体性如幻。如因幻力变作女人容貌可观体性非有。不了之者取为真实。一切法亦复如是。从妄缘生初无实体。未了实者生有体见。观察少盛如露。譬如朝露见日即晞。盛年容色亦复如是。一遇无常已从衰谢。观察寿如泡。譬如水泡或有始生未成体相。或才生已或暂停住即归散灭。寿亦如是。或始托生在于胎藏。正生生已从作婴儿。少年中年乃至衰老归于坏灭。观察作者如梦。譬如梦中随先见闻。忆念分别熏习住故。虽无作者种种境界分明现前。如是众生无始时来。有诸烦恼善不善业熏习而住。虽无有我是能作者。而现无涯生死等事。观察心如电。譬如电光生时即灭。心亦如是。刹那必谢。观察有无如云。如空中云。先无后有须臾复灭。有为诸法亦复如是。体性本空从妄缘有。有缘既散还复归无。复次先依俗谛。以星等九喻安立有为。后依中论第一义。一切法不灭不生不断不常不一不异不来不出。及般若波罗蜜中一切法非积住性。解释此颂其义云何。譬如星光自体常灭。有为亦尔。性恒迁谢。如人目翳。虽无作者病缘故生。有为亦然但从缘起。譬如灯焰念念恒断。有为如是刹那不住。如幻所作。不了之者取为实常。愚夫迷实取有为法亦复如是。譬如泫露在物虽繁体唯是一。所谓滋润有为内蕴生生。有别本性亦同咸资爱故。如因积水雨渧成泡。各别而生各别而灭。众生诸行亦复如是。八万四千别生别灭。如梦中境来无所从。而彼梦心妄见来处。有为亦尔来不可得无明梦识妄见为来。譬如奔电性非迁动。前处前灭后处后生。以相相似说之为去。有为诸法去亦如是。譬如空云非恒积住。有为之相类此应知。如是名为依俗谛故安立有为。如中论中成立真实不生等义。于有为法应如是知。此复云何。彼论中以自他共无因。观察诸法本无生义。如是似翳有为生法。应知不生。以不生故星光有灭违于道理。有为亦然应知不灭。复次不生故。彼灯自体。尚不可得。何有刹那而说为断。有为不断类此应知。复次不生故似幻所作。有为之法无有常义。应知不常。复次不生故似于朝露。有为诸法一义不成。爱能润生不契理故。应知不一。复次不生故似泡。差别有为之法异性不成。应知不异。复次不生故似梦中境。有为之法本无来义。应知不来。复次不生故似于电光。生灭之法以相似故说为去者。理不相应。应知不去。复次不生故。如云之法体尚非有。岂积住耶。如是应知颂曰

  我今功德施　　为破诸迷取
  开于中观门　　略述此经义
  愿诸众生类　　见闻若受持
  照真不坏俗　　明了心无碍

金刚般若波罗蜜经破取着不坏假名论卷下


金刚般若论

    No. 1510

金刚般若论卷上

        无著菩萨造

        隋南印度三藏达磨笈多译

  出生佛法无与等　　显了法界最第一
  金刚难坏句义聚　　一切圣人不能入
  此小金刚波罗蜜　　以如是名显势力
  智者所说教及义　　闻已转为我等说
  归命彼类及此辈　　皆以正心而顶礼
  我应精勤立彼义　　解释相续为自他

成立七种义句已。此般若波罗蜜即得成立。七义句者。一种性不断。二发起行相。三行所住处。四对治。五不失。六地。七立名。此等七义句。于般若波罗蜜经中成立。故名义句。于中前六义句。显示菩萨所作究竟。第七义句。显示成立此法门故。应如是知

此般若波罗蜜。为佛种不断故流行于世。为显此当得佛种不断义故。上座须菩提最初说言。希有世尊。云何如来以第一善摄摄受所有菩萨摩诃萨也。如是等。于中善摄者。谓已熟菩萨于佛证正觉转法轮时。以五种义中菩萨法而建立故。付嘱者。彼已得摄受菩萨等。于佛般涅槃时。亦以彼五义如是建立故。此善摄付嘱二种。显示种性不断

发起行相者。如经云何菩萨应住如是等。彼应住者谓欲愿故。应修行者。谓相应三摩钵帝故。应降伏心者。谓折伏散乱故。于中欲者正求也。愿者为所求故作心思念也。相应三摩钵帝者。无分别三摩提也。折伏散乱者。若彼三摩钵帝心散制令还住也。第一者显示摄道。第二者显示成就道。第三者显示不失道。行所住处者。谓彼发起行相所住处也。此复有十八种。应知所谓一发心。二波罗蜜相应行。三欲得色身。四欲得法身。五于修道得胜中无慢。六不离佛出时。七愿净佛土。八成熟众生。九远离随顺外论散乱。十色及众生身搏取中观破相应行。十一供养给侍如来。十二远离利养及疲乏热恼故。不起精进及退失等。十三忍苦。十四离寂静味。十五于证道时远离喜动。十六求教授。十七证道。十八上求佛地。是为十八种住处

于中菩萨应如是住。为灭度一切众生故。发心已于波罗蜜等中相应修行。为得如来色身及法身故。发生乐欲应远离证道中障碍心。既离慢等喜动等心已。为证道故应求教诫。然后得彼证道。自此已上皆求佛地。此等如是次第相续

于中为发心故。经言此菩萨应生如是心等

为波罗蜜相应行故。经言菩萨不住于物。应行布施等

为欲得色身故。经言须菩提于意云何。应以相具足见如来不如是等。法身复有二种。谓言说法身。证得法身。此证得法身亦有二种。谓智相福相

言说法身者。谓修多罗等。为欲得此法身故。经言世尊颇有众生于未来世如是等。于不颠倒义想是为实想。应知如言执义彼非实想

为欲得智相法身故。经言有法如来正觉阿耨多罗三藐三菩提耶如是等

为欲得福相法身故。经言若此三千大千世界如是等

为修道得胜中无慢故。经言须嚧多阿般那颇作是念如是等

为不离佛出时故。经言有法如来于然灯所如是等

为愿净佛土故。经言须菩提若有如是言。我成就庄严国土如是等

为成熟众生故。经言须菩提譬如有丈夫如是等

为远离随顺外论散乱故。经言须菩提于意云何。若恒伽河所有沙。复有尔许恒伽河如是等

为色及众生身搏取中观破相应行故。经言须菩提三千大千世界中所有地尘如是等

为供养给侍如来故。经言须菩提于意云何。应以三十二大丈夫相。见如来应正遍觉不如是等

为远离利养疲乏热恼。于精进若退若不发故。经言须菩提若女人若丈夫舍恒伽河沙等身如是等。于中身有疲乏心有热恼。以此二种于彼精进

若退若不发为忍苦故。经言若如来忍波罗蜜如是等

为离寂静味故。经言须菩提若女人若丈夫。于此法门受持如是等

为证道时远离喜动故。经言世尊云何菩萨应住如是等

为求教授故。经言有法如来于燃灯如来所。正觉阿耨多罗三藐三菩提如是等

为证道故。经言须菩提譬如丈夫妙身大身如是等。于中妙身者。谓至得身成就身得毕竟转依故。大身者一切众生身摄身故

自此已上皆求佛地。应知彼佛地复有六种具足。摄转依具足。所谓国土净具足。无上见智净具足。随形好身具足。相身具足。语具足。心具足。彼心具足中。复有念处有正觉。有施设大利法。有摄取法身。有不住生死涅槃。有行住净应知

此行住净中。复有威仪行住。有名色观自在行住。有不染行住应知

此不染中。复有说法不染流转不染应知

为国土净具足故。经言须菩提若菩萨如是言。我国土庄严成就如是等

为无上见智净具足故。经言须菩提于意云何。如来有肉眼不。乃至若此三千大千世界如是等

为随形好身具足故。经言须菩提于意云何。应以色身成就见如来不如是等

为相身具足故。经言须菩提于意云何。应以相具足见如来不如是等

为语具足故。经言须菩提于意云何。如来作是念我说法耶如是等

于心具足中为念处。故经言须菩提非众生非不众生如是等

为正觉故。经言须菩提于意云何。颇有法如来正觉阿耨多罗三藐三菩提不如是等

为施设大利法故。经言复次须菩提三千大千世界中。所有须弥山如是等

为摄取法身故。经言须菩提于意云何。应以相具足见如来不如是等。须菩提于意云何。如来可以相具足正觉阿耨多罗三藐三菩提。莫作是念者。此义明相具足体非菩提。亦不以相具足为因也。以相是色自性故

为不住涅槃故。经言须菩提如是念发行菩萨乘者。有法说断灭耶如是等

为不住流转故。经言须菩提菩萨于福聚。不应受不应取如是等。受者说有故。取者取彼道故。如福聚及果中皆不应者

于行住净中为威仪行住故。经言若有如是言。如来若去如是等

为名色观破自在行住故。经言须菩提若复善家子善家女。以所有三千大千世界中地尘如是等

于不染行住中。为说法不染故。经言须菩提若复菩萨。以无量无数世界如是等

为流转不染故说偈言。如星翳灯幻。露泡梦电云。于诸有为法。应当如是观。此偈显示四种有为相。所谓自性相。着所住味相。随顺过失相。随顺出离相

于中自性相者。共相见识此相如星应如是见。何以故无智闇中有彼光故。有智明中无彼光故。人法我见如翳应如是见。何以故以取无义故。识如灯应如是见。何以故。渴爱润取缘故炽然

于中着所住味相者。味着颠倒境界故。彼如幻应如是见。何以故。以颠倒见故

于中随顺过失相者。无常等随顺故。彼露譬喻者。显示相体无有。以随顺无常故。彼泡譬喻者。显示随顺苦体。以受如泡故若有受皆是苦故随有。应知彼苦生故是苦苦。破灭故是坏苦。不相离故是行苦。复于第四禅及无色中。立不苦不乐受以胜故

于中随顺出离相者。随顺人法无我以攀缘故。得出离故。说无我以为出离也。随顺者。谓过去等行。以梦等譬喻。显示彼过去行。以所念处故如梦。现在者不久时住故如电。未来者彼粗恶种子似虚空。引心出故如云。如是知三世行转生已。则通达无我。此显示随顺出离相。彼住处等略为八种亦得满足。所谓摄住处波罗蜜净住处。欲住处离障碍住处。净心住处究竟住处。广大住处甚深住处

于中摄住处者。谓发心。波罗蜜净住处者。谓波罗蜜相应行。欲住处者。谓欲得色身法身。离障碍住处者。谓余十二种。净心住处者。谓证道。究竟住处者。谓自此已上皆求佛地。广大及甚深住处者通一切处

于初住处中。若说菩萨应生如是心。所有众生如是等。此为广大。若复说言若菩萨众生想转如是等。此为甚深

于第二住处中。若说菩萨不住于事。应行布施如是等。此为甚深。若复说言彼所有福聚不可量取如是等。此为广大

如是于余住处中。广大甚深等随所相应应知

已说住处。何者对治。彼如是相应行相行诸住处时。有二种对治应知。谓邪行及共见正行。此中见者。谓分别也。于初住处中。若说菩萨应生如是心所有众生等。此是邪行对治。生如是心是菩萨邪行。若复说言若菩萨众生想转等。此为共见正行对治。此分别执菩萨亦应断。谓我应灭度众生故

于第二住处中。若说应行布施。此为邪行对治。非无布施是菩萨邪行。若复说言住于事等。是共见正行对治。此分别执菩萨亦应断。谓应行布施故。何者不失谓离二边。云何二边谓增益边损减边。若于如言辞法中。分别执有自性。是增益边。若于法无我事中。而执为无是损减边。于中若说言世尊若福聚非聚者。此遮增益边。以无彼福聚分别自性故。若复说言是故如来说福聚。此遮损减边。以彼虽不如言辞有自性而有可说事。以如来说福聚故。此得显示如是。须菩提佛法佛法者。如来说非佛法者。此遮增益边。是名佛法者。此遮损减边。于中如来说非佛法者。显示不共义。是名佛法者。显示相应义何者是相应。若佛法如说有自性者。则如来不说佛法。以虽不说亦自知故。是故无有自性为世谛故如来说名佛法。如是于一切处。显示不共及相应义应知。复次佛法者。摄波罗蜜事及念处等。菩提分应知。菩萨离此二边故。于彼对治不复更失故名不失

何者地。此地有三种。谓信行地净心地如来地。于中十六住处显示信行地。证道住处是净心地。究竟住处是如来地

云何立名名金刚能断者。此名有二义相应应知。如说入正见行入邪见行故。金刚者细牢故。细者智因故。牢者不可坏故。能断者般若波罗蜜中。闻思修所断。如金刚断处而断故是名金刚能断。又如画金刚形。初后阔中则狭。如是般若波罗蜜中狭者。谓净心地。初后阔者。谓信行地如来地。此显示不共义也。彼五种义句上上依止应知。彼等皆依止地故。说修多罗身相续。此义句今当说。世尊何故以寂静者。威仪而坐也。显示唯寂静者。于法能觉能说故

何故上座须菩提问也。有六因缘。为断疑故为起信解故。为入甚深义故为不退转故。为生欢喜故。为正法久住故。即是般若波罗蜜令佛种不断。云何以此令佛种不断也。若有疑者得断疑故。有乐福德而心未成熟。诸菩萨等闻多福德。于般若波罗蜜起信解故。已成熟心者。入甚深义故。已得不轻贱者。由贪受持修行。有多功德不复退转故。已得顺摄及净心者。于法自入及见生欢喜故。能令未来世大乘教久住者故。若略说疑者令见故。乐福德及心。已成熟诸菩萨等摄受故。已得不轻贱者令精勤心故。已净心者令欢喜故

诸菩萨有七种大。故此大众生名摩诃萨埵。何者七种大。谓法大心大。信解大净心大。资粮大时大果报大。如菩萨地持中说。经言善摄第一善摄者。于诸菩萨所何者善摄。何者第一也。利乐相应为善摄第一。有六种应知。一时二差别。三高大四牢固。五普遍六异相

何者时。现见法及未来故。彼菩萨善摄中乐者是现见法。利者是未来世

何者差别。于世间三摩钵帝及出世圣者。声闻独觉等善摄中差别故

何者高大。此善摄无有上故

何者牢固。谓毕竟故

何者普遍。自然于自他身善摄故

何者异相。于未净菩萨善摄中胜上故

经言第一付嘱者。何者第一付嘱。有六种因缘。一入处二法尔得。三转教四不失。五悲六尊重

何者入处。于善友所善付嘱故。何者法尔得。已得善摄。菩萨于他所法尔善摄故。何者转教。汝等于余菩萨应当善摄。是名转教。此等三种如其次第即是不失。及悲尊重等应知。何故唯问发行。菩萨乘为三种菩提差别故。以善问故。于上座须菩提所应称善哉。所有众生众生所摄者总相说也。卵生等者差别说也。又受生依止境界所摄差别应知。乃至化生等者受生别故。若有色若无色者。依止别故。若有想若无想若非有想非无想者。境界所摄别故。所有众生界施设住施设已者。谓上种种相住众生界佛施设说也。我皆令入涅槃者。何故愿此不可得义生所摄故。无过以皆是生故。如所说卵生等生并入愿数者。彼卵生湿生无想及非有想非无想等则不能。云何能令一切众生入涅槃也。有三因缘故。难处生者待时故。非难处生未成熟者成熟之故。已成熟者解脱之故。何故说无余涅槃界不直说涅槃。若如是便与世尊所说。初禅等方便涅槃不别故。彼自以丈夫力故。无佛亦得但非究竟。何故不说有余涅槃界。彼共果故自以宿业。又值佛说而得果故。又非一向身苦有余故。如是涅槃及有余涅槃等。丈夫力果故共果故。非究竟果故非一向果故。是故说无余。如是无量众生入涅槃已者。显示卵生等生一一无量故。无有众生得涅槃者。此何义。如菩萨自得涅槃无别众生。何以故。若菩萨众生想转。则不名菩萨者。此何义。若菩萨于众生。所他想转非自体想。不名菩萨故。何以故。若众生想命想人想转。不名菩萨者。此何义。若以烦恼心取众生命人想转。彼则有我想及于众生。中有众生想转。菩萨于彼不转。已断我见故得自行。(行者谓五阴行)平等相故信解自他平等。彼菩萨非众生命人取见者。此是其义。复次经言菩萨应生如是心者。显示菩萨应如是住中欲愿也。若菩萨我想转不名菩萨者。显示应如是修行中。相应三摩钵帝时也。若众生想命想人想转不名菩萨者。显示应如是降伏心中摄散时也。如菩萨相应三摩钵帝散时。众生想亦不转。如彼尔焰相住故。是故无有众生得涅槃者。此得成就彼欲愿者。摄诸住处为最胜彼相应行相行余住处时。依止欲愿决定得故。此欲愿义不复解释。自此后余住处中。有五种随所相应而解释应知。一依义二说相三摄持四安立五显现

住处对治为依义。即彼住处为说相。欲愿为摄持。住处第一义为安立。相应三摩提为显现

于波罗蜜净住处中。经言菩萨不住于物。应行布施等。此为依义。显示对治住着故。经言应行施者。此为说相。六波罗蜜初摄一切檀那体性故。檀那有三种。一资生施者谓檀那波罗蜜。二无畏施者谓尸罗波罗蜜羼提波罗蜜。三法施者谓毗梨耶波罗蜜禅那波罗蜜钵罗肾攘波罗蜜等。若无精进于受法人所为说法时。疲惓故不能说法。若无定则贪于信敬供养。及不能忍寒热等逼恼故染心说法。若无智慧便颠倒说法多有过故。不离此三得成法施。彼诸波罗蜜有二种果。谓未来现在。未来果者檀那波罗蜜得大福报。尸罗波罗蜜得自身具足。谓释梵等。羼提波罗蜜得大伴助大眷属。毗离耶波罗蜜得果报等不断绝。禅那波罗蜜得生身不可损坏。钵罗肾攘波罗蜜得诸根猛利及多诸悦乐。于大人众中得自在等。现在果者得一切信敬供养。及现法涅槃等。于中若菩萨求未来果故行施。为住物行施。如所施物还望得彼物果是故经言不住于物应行布施。若求未来尸罗等果故行施。为有所住行施。是故经言无所住应行布施。尸罗等果有众多。不可分别故总名有所往。若求现在果信敬供养等故行施。为住色声香味触行施。故经言不住色等。若求现法涅槃故行施。为住法行施。故经言不住于法应行布施

又经言应行布施者。即说摄持施之欲愿故

经言不住行施者。即此不住为安立第一义故。于中以不住故。显示如所有事第一义不住物等是所有事

经言菩萨应如是行。施不住于相想者。此为显示。谓相应三昧及摄散心。于此二时不住相想。如是建立不住已。或有菩萨贪福德故于此不堪。为令堪故世尊显示不住行施。福聚甚多犹如虚空。有三因缘。一遍一切处。谓于住不住相中福生故。二宽广高大殊胜故。三无尽究竟不穷故

为欲得色身住处故。经言须菩提于意云何。应以相具足见如来不。此为依义显示。对治如来色身慢故

经言相具足者此为说相。显示如来色身故。上座须菩提言不也。为成满此义故。世尊说须菩提所有相具足者。彼为虚妄此即显欲愿。于如是义中应摄持故。及即是安立第一义。于第一义中相具足为虚妄。非相具足为不虚妄

经言如是诸相非相应见如来者此为显现。谓相应三昧及摄散心时。于彼相中非相见故

为欲得言说法身住处故。经言颇有众生于未来世。于如是修多罗句说等。于中修多罗句说者。谓所有义应知。何者为句。如上所说七种义句。上座须菩提作是念。于未来世无有生实想者。为遮此故。世尊言有正法欲灭时者。谓修行渐灭时应知

次后世尊为如是显示修行。如是集因如是善友摄受。如是摄福德相应。如是实想中当得实想故

经言有戒有功德有智慧者。此增上戒等三学。显示修行功德者。少欲等功德为初。乃至三摩提等

经言已得供养无量百千诸佛。乃至一心净信等。此显示集因。一心净信尚得如是业。何况生实想也

经言如来悉知者知名身。如来悉见者见色身。谓于一切行住所作中。知其心见其依止故。此等显示善友所摄

经言生取无量福聚者。此显示摄福德。生者福正起时故。取者即彼灭时摄持种子故

经言是诸菩萨无复我想众生想转。乃至言若法想转。即为有我取者。此显示实想对治五种邪取故。何者五邪取。一外道。二内法凡夫及声闻。三增上慢菩萨。四世间共想定。五无想定。第一者我等想转。第二者法想转。第三者无法想转。此犹有法取。有法取者。谓取无法故。第四者有想转。第五者无想转。是诸菩萨于彼皆不转也。此中显了有戒乃至当生无量福聚等

经言何以故者。此言是中邪取但法。及非法想转。非我等想。以想及依止不转故。然于我想中随眠不断故。则为有我取。是故经言是诸菩萨。若起法想则为有我取等。若无法想转则为有我取等。此我等想转中。余义犹未说。经言则为有我取者。于中取自体相续为我想。我所取为众生想。谓我乃至寿住取为命想。展转趣余趣取为人想应知。于中言当生实想者。此为依义显示对治不实想故。言于此修多罗句说中者。此为说相显示言说法身故。即彼当生实想中。言当生者是欲愿。摄持者是诸菩萨无复我想。转等者是安立第一义。须菩提不应取法非法者是显了。谓相应三摩钵帝及摄散心时。不应取法非法者。于法体及法无我并不分别故。又言说法身要义者。经言以是义故。如来常说筏喻法门。若解此者法尚应舍。何况非法。故法尚应舍者。实想生故。何况非法者理不应故。略说显示菩萨。欲得言说法身。不应作不实想。为欲得智相。至得法身住处故。经言须菩提于意云何。有法如来于阿耨多罗三藐三菩提中正觉耶。此为依义显示。翻于正觉菩提耶故。说法者正觉所摄故。经言有法可说取阿耨多罗三藐三菩提者。是为说相显示至得法身故。无有定法者。上座须菩提导佛意故。世谛故有菩提及得。是为欲愿摄持。以方便故二俱为有。若如世尊意说者。二俱无有。为显此故言。如我解世尊所说义等。经言何以故如来所说法不可取不可说非法非非法者。是安立第一义。由说法故知得菩提故。于说法中安立第一义。于中不可取者谓正闻时。不可说者谓演说时。非法者分别性故。非非法者法无我故。经言何以故以无为故得名圣人者。无为者无分别义也。是故菩萨有学得名无起无作中如来转依名为清净。是故如来无学得名。于中初无为义者。三摩钵帝相应。及折伏散乱时显了故。第二无为唯第一义者无上觉故

自此已后一切住处中。皆显以无为故。得名圣人应知。前诸住处中未说无为得名。于此说阿耨多罗三藐三菩提中无为已竟

福相至得法身住处云何显示。即彼所有言说法身出生如来福相。至得法身于彼乃至说一四句偈生福甚多。况复如来所有福相。至得法身。以何因缘于言说法身中如是说一四句偈。能生多福为。成就此义故经。言何以故如来阿耨多罗三藐三菩提从此出者于中。普集十法行阿含故。诸佛世尊从此生者世谛故。言佛出生以有菩提故。即此二并故名为佛法以菩提及佛故。经言须菩提佛法佛法者即非佛法。复次经言其所生福胜彼无量阿僧祇者。此为依义显示对治福不生故。于中其福者。此为说相显示福相法身故。胜彼者显示欲愿摄持故。经言世尊是福聚即非福聚。是故如来说福聚及言须菩提佛法佛法者即非佛法是名佛法者。以此福聚及佛法。为摄取如来福相法身中安立第一义故。为随顺无为得名故。相应三摩钵帝及折伏散乱。不复显了言。甚多婆伽婆。甚多修伽陀。二语者显示摄心持心。以摄自心故言受持。为他说者解释句味故。无量者过譬喻故。阿僧祇者显多故

金刚般若论卷上金刚般若论卷下

        无著菩萨造

        隋南印度三藏达磨笈多译

已说欲住处竟。今说离障碍住处。有十二种障碍对治应知

何者十二障碍。一慢二无慢而少闻。三多闻而小攀缘作念修道。四不小攀缘作念修道而舍众生。五不舍众生而乐随外论散动。六虽不散动而破影像相中无巧便。七虽有巧便而福资粮不具。八虽具福资粮而乐未懈怠及利养等。九虽离懈怠利养而不能忍苦。十虽能忍苦而智资粮不具。十一虽具智资粮而不自摄。十二虽自摄而无教授

初中为离慢故。经言须陀洹颇作是念。我得须陀洹果等。此为依义显示对治我得慢故。又复须陀洹颇作是念者。即为说相显示无慢故。亦即是欲愿摄持。经言世尊无有所入不入色声香味触者。此为安立第一义。若须陀洹如是念。我得须陀洹果。即为有我想。若有我想则为有慢应知。如是乃至阿罗汉亦尔。上座须菩提自显无诤行第一。及阿罗汉共有功德者。以己所证为令信故。以无有法得阿罗汉。及无所行故。说无诤行。无诤行此中即为安立第一义。为离少闻故。经言如来于然灯如来应供正遍知所。有法可取耶等。谓彼佛出世承事供养时。有法可取离此分别故。依义等及对治等。随义相应应知

为离小攀缘作念修道故。经言须菩提若有菩萨如是言。我当成就严净佛土等。若念严净土者。则于色等事分别生味着。为离此故。经言是故须菩提。菩萨应生如是不住心无所住。不住色声香味触法等。为离舍众生故。经言须菩提譬如有人。身如须弥山王如是等。此何所显示。为成熟欲界众生故。彼罗睺阿修罗王等。一切大身量如须弥。尚不应见其自体。何况余者。经言如来说为非体者。显示法无我故。彼体非体者。显示法体无生无作故。此即显示自性与相及差别故

为离乐外论。散乱故。经说四种因缘。显示此法胜异也。一摄取福德二天等供养。三难作四起如来等念。经言以此因缘得福多彼者。是摄取福德。经言为他若说若授若解释。彼地分即是支提相者。是天等供养。经言当得具足最上希有者。是难作。经言此地分即为教师住处。及余可尊重者。是起如来等念。于中说者为他直说故。授者教授他故。显示此乐外论散乱对治法胜异已。于如是法中。或起如言执义为对治。彼未来罪故。经言如来所说般若波罗蜜即非般若波罗蜜故。如般若波罗蜜非波罗蜜。如是亦无有余法。如来说者为显此义故。经言颇有法如来可说不。此显示自相及平等相法门第一义也

为离于影像相自在中无巧便故。经言须菩提所有三千大千世界地尘如是等。彼不限量攀缘作意。菩萨恒于世界攀缘作意修习故。说三千大千世界

于中为破色身影像相故。显示二种方便。一细作方便。如经三千大千世界所有地尘宁为多不等。二不念方便。如经所有地尘如来说非尘。是名地尘故。为破众生名身影像相故。经言所有世界如来说非世界。是名世界故。于中世界者显众生世也。但以名身名为众生世。不念名身方便即是显示。破彼名身影像相。不复说细作方便也。为离不具福资粮故。经言须菩提于意云何。以三十二大丈夫相见如来耶者。显示为福资粮故。亲近供养如来时。不应以相成就见如来。云何见应见第一义法身故

为离懈怠利养等乐味故。经言须菩提若复妇女丈夫。舍恒河沙等自身如是等。此何所显示。如此舍尔许自身。所有福不及此福。云何以一身着懈怠等故而为障碍。何故此中上座须菩提流泪而言。我未曾闻如是等法门也。以闻此胜福甚多。过于舍无量身。更不说余胜福故。若闻如是胜福故。发起精进已。若于此法中生如义想。为离此过故。经言于说此修多罗中生实想者。当成第一希有等。即于如是实想中。为离实想分别故。经言彼所有实想即非实想如是等。经言世尊我于此法门。若分别若信解不为希有。若当来世其有众生。于此法门受持读摄为他解释。则为第一希有如是等。此何义。为令味着利养过懈怠诸菩萨生惭愧故。于未来正法灭时。尚有菩萨于此法门受持故。无人等取及法取。云何汝等于正法兴时。远离修行不生惭愧也。经言是诸菩萨。无复我等想转者。显示无人取也。所有我想即非我想者。显示无法取也

经言何以故诸佛世尊离一切想者。显示诸菩萨顺学相。诸佛世尊离一切想。是故我等亦应如是学。此等经文为离退精进故说。于中言若分别若信解者。后句释前句也。受者受文字也。摄者摄义也。为离不发起精进故。经言须菩提。若闻说此修多罗章句时不惊等者。以惊等故不发起精进也。于声闻乘中。世尊说有法及有空。于听闻此经时。闻法无有故惊。闻空无有故怖。于思量时于二不有理中。不能相应故畏。更有别释为三种无自性故应知。谓相生第一义等无自性故。经言何以故须菩提。如来说第一波罗蜜者。此有何义。复说第二生惭愧处故。言此法如是胜上。汝等不应放逸。于中以于余波罗蜜中胜故。名第一波罗蜜。经言如来说第一波罗蜜者。彼无量诸佛亦说波罗蜜者。此言显示一切诸佛同说第一。是故名第一。为离不能忍苦故。经言复次须菩提。如来说羼提波罗蜜等。于中如所能忍。以何相生忍处。如忍差别显示。对治彼因缘故。何者能忍谓达法无我故。云何得显示。如经言如来说羼提波罗蜜故。云何应知忍相。若他于己起恶等时。由无有我等想故不生嗔想。亦不于羼提波罗蜜中生有想。于非波罗蜜中生无想。此云何显示。如经如我昔为迦利王割截身分。我于尔时无有我想等及无想。亦非无想等。何者种类忍。谓极苦忍相续苦忍。此云何显示。如经如我昔为迦利王割截身分。及言我忆过去五百生中。作忍辱仙人等。不忍因缘者有三种苦。谓流转苦。众生相违苦。乏受用苦。于中如经。是故须菩提菩萨摩诃萨应离一切想。发阿耨多罗三藐三菩提心等。此为显示流转苦忍因缘对治。发菩提心者。以三种苦想故。则不欲发心故。说应离一切想等。此中一切想者。为显如是等三苦想也。若着色等则于流转苦中疲乏故。菩提心不生故。经言不应住色。生心等如前说。不住非法者。谓非法无我也。于非法及法无我中皆不住故。为成就彼诸不往故。说遮余事。如经应生无所住心。何以故。若心有住即为非住等

经言如是菩萨为利益一切众生。应如是布施。乃至言诸所有想即为非想等。此显示对治众生相违苦忍。既为一切众生而行于舍。云何于彼应生嗔也。由不能无众生想。以此因缘故。众生相违时即生疲乏故。显示人无我法无我等。须菩提如来是真语者等。此何所显示。欲令信如来故能忍。于中真语者为显世谛相故。实语者为显世谛修行。有烦恼及清净相故。于中实者。此行烦恼此行清净故。如语者为第一义谛相故。不异语者为第一义谛修行。有烦恼及清净相故。说此真语等已。于此中如言说性起执着。为遣此故。经言须菩提如来正觉法及说。于中无实无妄。无实者如言说性非有故。无妄者不如言说自性有故。须菩提譬如丈夫入闇。如是等显示乏受用苦忍因缘对治。若为果报布施。便着于事而行舍施。彼于异施欲乐苦受中不解出离。犹如入闇不知我何所趣。彼喜欲乐亦尔。若不着于事而行布施。如有眼丈夫夜过日出见种种色随意所趣。应如是见彼无明夜过。惠日出已。种种尔焰如实见之。彼不知解出离欲乐苦受故。喜乐欲乐

为离阙少智资粮故。经言须菩提若复善家子善家女。于此法门若受等。此中为离三摩提攀缘。显示与法相应。有五种胜功德。一如来忆念亲近。二摄福德。三赞叹法及修行。四天等供养。五灭罪。何者如来忆念亲近。如经受持读诵者。如来以佛智知彼。如来以佛眼见彼等。于中受者习诵故。持者不忘故。若读若摄者。此说受持因故。为欲受故读。为欲持故摄。又复读者习诵故。摄者总览义故。何者摄福德。如经是诸众生。生如是无量福德聚等。何者赞叹法及修行。如经复次须菩提。此法门不可思不可称等。此为赞叹法。于中不可思者唯自觉故。不可称者无有等及胜故。经言又此法门。如来为发最上乘者说。为发最胜乘者说者。此成就不可称义。于中余乘不及故。最上烦恼障智障净故。最胜应知。经言若于此法门受持。乃至如来悉知见等者。此为赞叹修行。于中是诸众生成就无量者。是总说。不可思不可称不可量者解释故。是等即为荷担我菩提者。谓肩负菩提重担故。经言须菩提下信解者。不能闻此法者。谓声闻独觉乘者故。经言若有我等见者。谓有人我见众生。而自谓菩萨者。何者天等供养。如经复次须菩提。随所地分解说此修多罗处。常应供养彼地分即为支提等。于中以华鬘烧香熏香涂香末香。衣盖幢幡等。供养恭敬礼拜右绕故名支提。何者灭罪。如经彼若为人轻贱。甚轻贱乃至当得菩提等故。此毁辱事有无量门。为显示此故复言甚轻贱。经言当得佛菩提者。显示罪灭故。前所说以此因缘出生无量阿僧祇多福者。今当解释彼无量阿僧祇义应知。威力者成熟炽然故。多者具足胜大故。于中如经须菩提。我忆阿僧祇过阿僧祇劫前如是等。此显示威力故。即是福聚威力。以彼所有福聚远绝高胜故。此中阿僧祇劫者。乃至燃灯佛故应知。过阿僧祇者更过前故。亲近者供养故。不空过者常不离供养故。若复经言须菩提。若善男子善女人所得福聚若我说者。若有人闻心则狂乱如是等。此显示多故。或为狂因或得乱心果应知。此之彼威力及彼多等何人能说。是故经言复次须菩提。此法门不可思议。果报亦不可思议。此显示彼福体及果不可测量故

为远离自取故。经言须菩提言。云何菩萨大乘中发心应住等。何故复发起此初时问也。将入证道菩萨。自见得胜处作是念。我如是住如是修行。如是降伏心我灭度众生。为对治此故须菩提问。当于彼时如所应住。如所应修行。如所应降伏其心。世尊答应生如是心等。又经言须菩提。若菩萨众生等想转者。为显我执取或随眠故。若言我正行菩萨乘此为我取。对治彼故。经言须菩提无有法发行菩萨乘者为离无教授。故经言须菩提有法如来于燃灯如来所等。又经言须菩提若有法如来得正觉者。燃灯如来则不授记汝当得等。此有何意。若正觉法可说。如彼燃灯如来所说者。我于彼时便得正觉。燃灯如来则不授记。言汝当得等。以彼法不可说故。我于彼时不得正觉。是故与我授记。此是其义应知。又何故彼法不可说。如经须菩提如来者。即是真如故。如清净故名为如来。以如不可说故。作此说。清净如名为真如。犹如真金。或言燃灯如来所。于法不得正觉。世尊后时自得正觉。为离此取故。经言须菩提若人如是言。如来正觉阿耨多罗三藐三菩提者等。又经言须菩提。如来所正觉法。于是中不实不妄者。显示真如无二故。云何不实谓言说故。不妄者谓彼正觉。不无世间言说故。经言是故如来说一切法即是佛法者。此何义显一切法法如清净故。如者遍一切法故。此是其义。又彼一切法法体不成就。为安立第一义故。经言须菩提。一切法者悉是非法。是名一切法故。为入证道故。经言须菩提譬如有人。妙身大身如是等。显示入证道时。得智慧故离慢。云何得智。有二种智故。谓摄种性智及平等智。若得智已得生如来家。得决定绍佛种。此为摄种性智。得此智已能得妙身。若于此家长夜愿生。既得生已便得彼身。是名妙身。平等智复有五种平等因缘。谓粗恶平等。法无我平等。断相应平等。无悕望心相应平等。一切菩萨证道平等。得此等故得为大身。摄一切众生大身故。于彼身中安立非自非他故。经言如来所说。有人妙身大身即非身。是故如来说名妙身大身等。此于妙身等中安立第一义。如是等是为得智慧。云何离慢。如经若菩萨作是言等。此云何可知。若作是念我灭度众生。我是菩萨应知。此是慢者非实义菩萨。为显示此故。经言是故如来说一切法无众生。若菩萨有众生念。则不得妙身大身故。彼上求佛地。中为净国土三摩钵帝故。经言须菩提若菩萨作是言。我当成就庄严国土。则非菩萨。此义为于共见正行中转故。为断彼故安立第一义。经言即非庄严如来。说名庄严国土等。又经言须菩提。若菩萨信解无我法。无我法者此言为二种无我故。谓人无我法无我。又经言如来说名菩萨。菩萨者为于彼二种无我中二种正觉故。此等云何显示。若言我成就即为人我取。庄严国土者。是法我取此非菩萨

为见智净具足故。经言须菩提于意云何。如来有肉眼不如是等。如来不唯有慧眼。为令知见净胜故。显示有五种眼。若异此则唯求慧眼见净故。于中略说有四种眼。谓色摄。第一义谛摄。世谛摄。一切种一切应知摄。色摄复有二种。谓法果修果此为五眼。粗境界故。是初色摄第一义智力故。世智不颠倒转。是故第一义谛摄在先。于中为人说法。若彼法为彼人施设。此智说名法眼。一切应知中一切种无功用智。说名佛眼。此等名为见净。如经说恒河等譬喻。所有若干种心住我悉知等。此为智净。于中心住者谓三世心。若干种者应知有二种。谓染及净。即是共欲心离欲心等。世者谓过去等分。于此二中安立第一义故。经言心住者即为非住。乃至过去心不可得等。于中过去心不可得者已灭故。未来者未有故。现在者第一义故。为应知中证故。安立见为教彼。彼众生寂静心故安立智。于此智净中。说心住即非心住。如是见净中。何故不说眼即非也。以一住处故。见智净后安立第一义故。初亦得成就

为福自在具足故。经言此三千大千世界等。于中亦安立第一义故。经言须菩提若福聚有实等

于身具足中为好具足故。经言须菩提于意云何。以色身成就见如来不如是等。于中亦以安立第一义故。经言如来说非成就等

为相身具足故。经言须菩提于意云何。可以相具足见如来不如是等。为语具足故。经言须菩提于意云何。汝谓如来作是念。我说法也如是等。于中安立第一义故。经言如来说法。说法者等于心具足中为念处故。经言世尊颇有众生于未来世闻说是法等。此处于诸众生中显示。如世尊念处故。彼非众生者第一义故。非不众生者世谛故。是人即为希有第一者。显示说第一义。是不共及相应故。此文如前说

于彼心具足中为正觉故。经言颇有法如来于阿耨多罗三藐三菩提得正觉也如是等。于中无有法者。为离有见过。已显示菩提及菩提道故。彼复显示菩提。有二种因缘。谓阿耨多罗语故。三藐三佛陀语故。于中经言微尘许法不可得不可有者。此为阿耨多罗语故。此显示菩提自相故菩提解脱相故。彼中无微尘许法有体。是故亦无可得亦无所有应知。经言复次须菩提是法平等者。为三藐三佛陀语故。显示菩提者人平等相。于中平等者以菩提法故。得知是佛。此中经言无有高下者。显示一切诸佛第一义中。寿命等无高下故。经言无寿者。无众生得彼平等阿耨多罗三藐三菩提者。显示菩提。于生死法平等相故。经言一切善法得正觉者。显示菩提道故。经言所言善法。善法者如来说非善法等。此安立第一义相故

于彼心具足中。为施设大利法故。经言三千大千世界中所有须弥如是等。于中为安立第一义教授故。经言如来颇作是念我度众生耶。如是等如来则有我等取者。此有何义。如来如尔焰而知是故。若有众生想。如来则为有我取。若实无我而言有我取。为离此着故。经言须菩提我取者即为非取是如等。是故但小儿凡夫有如是取故。经言须菩提凡夫。凡夫者如来说非凡夫是名凡夫故。于彼心具足中为摄法身故。经言须菩提于意云何。应以相成就见如来不如是等。于中初偈显示如所不应见不可见故。云何不可见诸见世谛故。是人行邪静者。定名为静。以得禅者说名寂静者故。又复禅名思惟修故。于中思者意所摄。修者识所摄。言寂静者即说意及识。此世谛所摄应知。彼不应见佛者。谓彼世谛行者。第二偈显示如彼不应见。及不应见因缘。谓初分次分。于中偈言以法应见佛者。法者谓真如义也。此何因缘。偈言导师法为身故。以如为缘故。出生诸佛净身。此不可见。但应见法故彼不应见。复何因缘故不可见。以彼法真如相故。非如言说而知。唯自证知故。不如言说者。非见实不能知故。为显示此义故。偈言法体不可知故。彼不能知。于此住处中得显示。以法身应见如来非以相具足故。若尔如来虽不应以相具足见。应以相具足为因。得阿耨多罗三藐三菩提。为离此着故。经言须菩提于意云何。如来可以相具足。于阿耨多罗三藐三菩提正觉也。如是等于彼心具足中。为不住生死涅槃。故经言须菩提汝作是念。发行菩萨乘者如是等。于中经言于法不说断灭者。谓如所住法而通达。不断一切生死影像法。于涅槃自在行利益众生事。此中为遮一向寂静故。显示不住涅槃。若不住涅槃应受生死苦恼。为离此着故。经言须菩提若善男子善女人。乃至是故菩萨取福德等。于中经言无我无生法忍者何义。如来于有为法得自在故。无彼生死法我。又非业烦恼力生故无生故名无我者。无生者此中云何得显示。如说摄取余福。尚于生死中不受苦恼。何况菩萨于无我无生法中。得忍已所生福德胜多于彼。经言须菩提菩萨不应受福聚者。此显示不住生死故。若住生死即受福聚。经言须菩提言不应受福聚耶者。此有何义。以世尊于余处说应受福聚故。经言世尊言受福聚。不取福聚是名受福。而不取者。此显示以方便应受而不应取。如前已说于行住心具足中。为威仪行住故。经言须菩提若有人言。如来若去若来等。于中行者谓去来。住者谓余威仪。为破名色身自在行住故。经言须菩提若善男子善女人。以三千大千世界所有微尘等。于中细末方便及无所见方便等。此破如前说应知。经言彼微尘聚甚多者。是细末方便。经言世尊若微尘聚有者。世尊则不说微尘聚等是为无所见方便。此说有何义。若微尘聚第一义中是有者。世尊则不说非聚。世尊说微尘聚非聚。是名微尘聚者。以此聚体不成就故。若异此者。虽不说亦自知。是聚何义须说。经言如来说即非世界者。此是无所见方便。此破名身亦如前说应知。于中世界者。为明众生世故。彼唯名身得名。经言世尊若世界是有者。即为有搏取者。于中为并说。若世界若微尘界故。有二种搏取。谓一搏取及差别搏取。众生类众生世界有者此为一搏取。微尘有者此为差别搏取。以取微尘聚集故。经言如来说搏取即非搏取者。此上座须菩提安立第一义故。世尊为成就如是义故说搏取者。即是不可以言说说等。此何所显示。世谛言说故。有彼搏取第一义故。彼法不可说。彼小儿凡夫如言说取非第一义。已说无所见方便。破义未说。无所见中入相应三昧时不分别。谓如所不分别。及何人何法何方便云何不分别。此后具说。经言须菩提若有人如是言如来说我见等。此等显示如所不分别。云何得显如外道说我如来说。为我见故安置人无我。又为说有此我见故。安置法无我。若有彼我见是见所摄。如是观察。菩萨入相应三昧时不复分别。即此观察。为入方便

经言须菩提菩萨乘发行者。此显示何人无分别。经言于一切法者。此显示于何法不分别。经言应如是知应如是见应如是胜解者。此显示增上心增上智故。于无分别中知见胜解。于中若智依止奢摩他故知。依止毗钵舍那故见。此二依止三摩提故。胜解以三摩提自在故。解内攀缘影像。彼名胜解。经言如是知解已。而不住法想者。此正显示无分别。经言法想。法想者即非法想。是名法想者。此显示法想中不共义及相应义。如前已说。如是一切住处中。相应三摩提方便亦尔应知。欲愿及摄散二种。如前所说更无别义。是故不复说。其方便于彼心具足中。为说法无染故。经言须菩提若有菩萨。以满无量阿僧祇世界七宝等。此何所显示。以有如是大利益故。决定实演说。如是演说而无所染。经言云何演说而不演说是名演说者。此有何义。显示不可言说故不演说。彼法有可说体。应如是演说。若异此者则为染说。以颠倒义故。又如是说时不求信敬等。亦为无染说法

于彼心具足中。为生死不染故。说星翳灯等偈。此义如前说

  若闻如是义　　于大乘无觉
  我念过有石　　究竟无因故
  下人于此深大法　　不能觉知及信向
  世间众人多如此　　是以此法成荒废

金刚断割般若波罗蜜论竟阿僧伽作

金刚般若论卷下


金刚仙论

    No. 1512 [cf. Nos. 1511, 1513, 1514]

金刚仙论卷第一

金刚般若波罗蜜者。总括八部之大宗。契众经之纲要。其所明也。唯论常果佛性及十地因。因满性显。则有感应应世。故说八部般若。以十种义。释对治十。其第一部十万偈(大品是)第二部二万五千偈(放光是)第三部一万八千偈(光赞是)第四部八千偈(道行是)第五部四十千偈(小品是)第六部二千五百偈(天王问是)第七部六百偈(文殊是)第八部三百偈(即此金刚般若是)

此是八部之名。前之七部遣相未尽但称般若。此第八部遣相最尽故别立金刚之名也。初第一部如来成道五年在王舍城说。次五部亦王舍城说。第七第八部舍婆提城说。此金刚般若。唯须菩提蒙加设问如来答也。十障者。一者无物相障。如般若中说。有为无为一切诸法乃至涅槃空。众生不解。起于断见。谓一切法无。此障对治。佛告须菩提。有菩萨摩诃萨。行檀波罗蜜乃至般若波罗蜜。如是等。此经中对治者谓第三分。经云。菩萨不住于事行于布施等。此遣断见也。二者有物相障。众生闻如来说有菩萨行六波罗蜜。众生计着起于常见。便谓一切法有。此障对治。佛告须菩提。菩萨不见我为菩萨及诸波罗蜜。如是等。此经中对治者。谓修行分。经说。若菩萨起众生相人相则非菩萨。此遣常见也。三者非有似有障者。如来说色等诸法是有。若是有者不应复更说言诸法空也。此障对治。佛告舍利弗。色等诸法体相空。如阳炎。非有似有。如是等。此经中对治者。谓但凡夫之人贫着其事等。遣实有见也。此第三何异第一。上第一总明有为无以一切法空。此第三偏明有为法空。但疑者云。若诸法空者。何故可见而有用以为异也。四者谤相障。上闻如来说色等诸法体相空如阳炎非有似有。众生不解便起谤意。谓佛性涅槃无为之法。亦同有为诸法性空无体之无。若尔则无修行得果之者。此彰对治。佛告舍利弗。非空空。如是等。此经中对治者。谓第六诸法空分中亦非无法相等。遣空见也。此第四障何异第一第二。第一明有为无为一切诸法空。第三偏明有为法空。此第四唯明无为之法妙有之体无万相故空。不同有为之法无性故空。以此为异也。五者一有相障。闻如来说色是空。而众生起心不异空更有色。此障对治。佛告舍利弗。空者非色。如是等。此经中对治者。谓一合相者即是不可说等。遣即见也。六者异有相障。如来上说空者非色。众生不解。谓异色别有空。此障对治。佛告舍利弗。不离空更有色。色即是空空即是色。如是等。此经中对治者。谓是故佛说一切法无我无人无众生等。遣异见也。七者实有相障。闻如来上说万法虚空体是空者。何故佛说色等诸法是有。此障对治。佛告舍利弗。色等诸法但有名用。如是等。此经中对治者。谓如来说微尘即非微尘。世界即非世界等。遣报教见。此第七何异上第一第三第四。此中明空不异。于上但难言方法。若是空者。如来何故说有。以此为异也。八者异异相障。闻如来说色等诸法体相空但有名用。众生心色等诸法。若是空者。不应有生住灭。若实有生住灭。则非是空。此障对治。佛告舍利弗。诸法不生不住不灭不净不染。如是等。此经中对治者。谓量分中第七分说。何以故离一切诸法即名诸佛如来等。此遣有相见

九者如名义相障。如来说色等诸法可见可触。众生起心。如名义亦如是可见可触。此障对治。佛告舍利弗。诸法有名假施设如是等。此经中对治者。谓实无有法名为菩萨等。此遣依名报义见

十者如义名相障。如来。上说色等法寂静空但有名假设。设若如是。众生起心。如义名亦如是。有义故有名。若无义者云何有名。此障对治。佛告须菩提。菩萨不见一切名。以不见一切名故。不着一切义。如是等。此经中对治者。谓第十一分中一切有为法如星医灯幻等。此遣依义执名见。对此十障故。说八部般若。究竟一切智满足。此十何故名障。已一一或体皆能碍于实解故通名为障也。言金刚者。从譬喻为名。取其坚实之义。如世间金刚。有二义。一其体坚实能破万物。二则万物不能坏于金刚。明此果头无为法身金刚般若及十地智惠。亦有二义。一能摧魔怨敌坏诸烦恼。二者诸魔烦恼不能俎坏。故名金刚。又凡夫二乘。于此理教不能解入。故亦名金刚也

般若者。乃是西国正音。此魏播云慧明。此金刚无相极理。体是西实。智慧能照达理原。了诸法相。显明常住佛果。故曰般若也

波罗蜜者。魏云到彼岸。明此经所诠之理是常住法身彼岸之体能令众生度生死河到涅槃彼岸。故名波罗蜜也

经者。旧人相传训之曰常。依西国正本。云修多罗。若播其名者。外国云修多罗。此方播之为本。此明理教皆有本义。理为本者。明所诠证法无为之理能与十二部经言教为本。故名理为本也。教为本者。明寻此言教能得证法故。名言教与证法为本。故以教为本也。故今言经者。非播名也。但此中人。义以经字。显修多罗处。故言经也

论者。如来灭度后之中。有高行大士。号曰婆薮槃豆。魏云天亲。此人实是大权菩萨。现形通化。遍见如来一代所说大小乘教意。以此金刚般若经文句甚略义富远博。世人不能解此深远妙义。为众生故作义释之为论也

所以论初设此二偈者。然论主天亲。将欲作论释此金刚般若深远妙义。若不檦显法体置于论初远冯佛僧在于经首者。则何以作论解释此经深远之义。然如来灭后声闻菩萨诸大论师。凡欲有所制远解佛正经者。莫不皆先归敬三宝假灵威然后作论。二偈之兴大意在此也

就此二偈之中。分为二段。初有一偈半六句。明致敬三宝。后半偈二句。释成致敬之意。就初六句中。前一句。明此金刚般若理教深妙即是法宝之体。第二句。明上法门理教既深世间愚人不能解悟。即是出不解之人。第三句。明诸佛菩萨俱能通达。此显佛僧二宝。即是出能解之者第四句。以诸佛菩萨能通达此理故教导。我等宜修吏教此障吏敬之或第五第六二句。重释致敬之意也。下半偈两句。偏释菩萨有可敬之德也

法者。以轨则为能。又法名自体不失己相。何者是法家自体相而言不失。明此金刚般若甚深妙法能防生死非法。不令众生堕三恶道。能令众生得人天二乘果。乃能令众生十地行满终得佛果至极之乐。故名为法也

门者。明此金刚般若理之与教皆能津通行人远诣佛果。故名为门也。句者。即此金刚般若能诠之教也。义者。是所诠证理。明此般若理教深妙非诸凡夫二乘心心意识之所能解。乃是如来八部之终隐覆之说所以得知。如下经云。如来说众生即非众生等。此即是句义理教难解。故言句义也。及次第者。明此法门十二段分数次第。从此一段。至此一段。生起法用。或时次第。或时超越。所以难知。下经文云何住者。生下住分。云何修行。云何降伏其心。生下如实修行分。此即是次第之意难识。故言及次第也。世间不解离明慧者。上句虽明般若。理教难法体未知。不解者谁。是以第二句明世间愚人不能解。世间者。众生世间也。不能解者。此凡夫之人未得闻思修等法出世间胜解断除惑障永尽生死。故不能穷达理原悟此深法也。应问。世间愚人何故不解。即答云。以离明慧。离明慧者。前愚人未得初地已上真无漏解断除痴闇。故言离明慧。以离此出世间明慧故。不能解此般若深法也。大智通达教我等者。上句虽明不解之人。犹未影能解之者。是以第三句明诸佛菩萨俱秉妙解能达斯理。此即并出佛僧二宝也。大智通达者。诸佛如来二障永尽。种智圆满。照穷此法门。理教斯尽。更无胜者。故言大智通达也。若据菩萨而论。亦渐除惑障。分有种智。片悟同佛。解此法门句义次第所以。亦得云大智通达也。第二意若此般若理教甚深难解者。论主何由得解作论解释。故答大智通达教我等也。教我等者。此明论主自云诸佛菩萨有大方便。于己所得无名相理。作名相说。训导于我并余论师及一切众生。故得解此般若深义。作论解释。功由大圣。非我自力能解。故言教我等也。归命无量功德身者。上虽辨所敬人法。未论致敬之意。是以第四显吏敬之。或此金刚般若甚深法门。乃是诸佛之母。能出生现果常住涅槃体偏无量功德。故所以归命。又诸佛菩萨各有十力四无所畏等无量大功德聚。能以前理教导。于我有莫大之恩。故亦言归命。此一句应遍在上第三句下皆言归命也。应当敬彼如是等者。此下两句重释第四句致敬之意。上虽云归命。犹未展敬仰之心。将欲更重以三业致敬故。以总举前所敬人法来。故应当敬我如是等也。头面礼足而顶戴者。上虽云致敬。未出致敬之所以。此句正辨恭敬之事也。头者一形之重。足者身之所轻。今以已所尊。礼彼佛僧之早。此乃方显处敬之至也。故言头面礼足而顶戴。亦应言意业尊重口业赞叹。但以偈使故略也此一句亦遍在上三宝之下。皆言顶礼也。以能荷佛难胜事者。此两句半偈。别释菩萨有可敬之德。论主此中假设疑意云。诸佛如来具三达明解。鉴尽万法超学地之表。无能过者。可名大智。理合致敬。菩萨既位居学地。处不足之境。理解未圆。断惑不尽。何得名为大智敬同佛也故偈释言以能荷佛难胜事何者。是佛家难胜事而云菩萨荷负也。今明佛家难胜事者。即此般若理教宗深致远。非是凡夫二乘图度之境。故不堪受持流通益物。然菩萨大士独秉妙解。负斯重任。于如来灭后像正法中。受持洪化。继轨先圣。此即是荷负佛难胜事。故功齐诸佛。故得名为大智通达致敬同佛也。此明菩萨有二种。一者初地已上菩萨。已积行僧祇。现见理原。断除烦恼。自证而说。故能荷负受持流通益物。二者地前信地菩萨。亦积行来久。一大僧祇欲满不满。虽未现见理原。以能仿佛见理相似解深伏烦恼。故亦能荷负受持流通益物也。摄受众生利益故者。今言菩萨在像正。流通般若胜法。为当自为悕于名利。为当为利于物。故偈下句言摄受众生利益故。明菩萨大士于佛灭后流通此经。乃为旷兼群生等润含识。故以法录物。令从已化。使获。出世无上菩提无尽之福。此明不为自利。故言摄受众生利益故也。此前二偈。是论主归敬三宝。申已造论之意也。如是已下讫于经末。正辨经体。序正流通义如常辨。于中随义曲分。凡有十二段。始从序分终讫流通。即其事也。十二段解名生起。如下次第广释。释可知也。然十二段中。所以初明序分者。然如来将欲说法故。以威神冥如。召集有缘。为兴发之由。故名为序。然诸经明序义次第发起。皆先放光动地召集有缘。广作由致。然后方说。此经所以异于众经者。以如来说法序义凡有多种。一放光动地召集有缘广现瑞相。然后说法。二不放光动地广现瑞相。如来知众生机感。自然说法不待请问。三众中有怯弱众生。内心怀疑。不放问佛。是故如来自唱我是一切智人。汝何故不问于我。汝若问我。我当为汝说法。四如来威神冥加。与其智力令其说法。五诸菩萨在余处说法。竟至如来所。印其所说。六有人生疑发问。如来为说。七如来直以己相貌。为说法之序。今此经序即是第四如来威神冥加故说此为序也。如十万偈般若。如来具足以三业加须菩提。如大品八千偈般若等。此六部中。但以口意二业加须菩提。此金刚般若。唯以意加不具身口也。若此经意加故说。何故经文不辨其事。以如来说八部般若。势分相续不断不绝故。更不别明也。经初五句众经通序。一如是。二我闻。三一时。四婆伽婆。五住处也。所以一切经初置斯五句者。有三种义。一为证成经理不虚未代生信。二为表异外道以阿忧为吉。三为息于诤论表已推宗有在也。等证生信所以先明如是者。欲使人识经达旨明金刚般若理教。正如是我之所说与佛昔说不异故。初明如是也。虽云今说般若理教与佛昔说不异。而未知闻者是谁。若无闻者未必可信是以第二次言我闻。此明闻之有人。非为传听所以可信也。须菩提虽云我闻。然说必有时。若说无时节。亦未必可信故第三次明一时也。虽出说经时节。然说必有人。未知说者是谁。若是天魔外道余人说者。未必可信。故第四次明能说之人是佛婆伽婆所说故所以可信也。虽云此般若理教是佛之所说。未知如来在何处说。若说无方所。亦未必可信。是故第五次明说经之处在舍婆提城给孤独园也。五句中何故初名如是者。若依世辨释名。如是之义乃有多途。略而言之凡有四种。一者发心如是。二者教他。三者譬喻。四者决定。发心如是者。自念我当如是发菩提心修诸善行等是名发心如是也。教他如是者。教前人言。汝当如是发菩提心修诸善行等也。譬喻如是者。又威德炽盛如日光明。智慧深广犹如大海。面貌端政喻如满月。勇健雄猛如师子王。是名譬喻如是也。决定如是者。我如是见闻等。是名决定如是也。今言如是者。但取第四决定如是。明须菩提自云我亲从如来。闻此金刚般若理之与教。我之所说如佛所说。不多不少不饰不谬。决定如是。无有传闻之失。故曰如是也。我闻者。如是之义闻必有人。故次云我闻。此中谁自称我而言我闻。解者多道。须菩提言我与千二百五十比丘同闻此经。故曰我闻。然理通而言亦得通。阿难云我闻别义则非也。三种阿难大小中乘传持三乘法藏。其义可知也。何以得知。须菩提云我闻非余人也。凡有二义验知也。一以经文下校量分中须菩提。问当何名此经。我等云何奉持。以此文来验。故知今言我闻者。是须菩提。虽复当时须菩提有如是问。后时言我闻者。何必是须菩提也。复更以何文验知是须菩提云我闻也。昔如来灭后。凡有三时结集法藏。初在王舍城因陀罗窟中。五百比丘结集法藏。舍利弗等诸罗汉比丘各自称言。某甲经如是我闻佛在某处说。后时为恶国王坏灭佛法。自此以后复有七百比丘。重结集法藏。皆云某甲经我从某甲比丘边闻。不云我从佛闻。此之再集并是小乘之人结集法藏。又复如来在铁围山外不至余世界。二界中闻。无量诸佛共集于彼。说佛话经讫。欲结集大乘法藏。复召集徒众。罗汉有八十亿那由他。菩萨众有无量无边恒河沙不可思议。皆集于彼。当于尔时。菩萨声闻皆云。如是我闻如来在某处说某甲经。须菩提云金刚般若经如是我闻佛在舍婆提城说。故知今言我闻者。是须菩提也。一时者。既曰我闻。说必有时。故次云一时。然时有多种。或有一念时。有日夜时。有百年时。有一劫时。有春秋冬夏时。今言一时者。非此等时。正是如来说此金刚般若经时。虽言一时。不云某年某月某日说。故不知何时也。如大华严世间净眼品。如来即成道日。在寂灭道场说十地品。第二七日。在他化自在天中说。如十万偈般若。如来成道五年说。经有成文。余七部般若但云一时。皆不知何年说也。如来藏经佛成道十年说。如大集宝幢。品佛成道一年。王舍城迦兰陀竹园。说陀罗尼自在王品。成道十六年在欲色二界中间说。经有明文者即便可知。经无明文者即不可知也。然说此经时虽不知几年。足知中后时说。何以得知。经云食时着衣持钵入城乞食。得食还园食讫。诸比丘方集说此经。故知中后说也。相传云。如来一代成道乃至涅槃。恒说摩诃般若华严大集。未曾断绝。此金刚般若。八部之中是最后说也。须菩提直道我闻一时。不云几年。是故但言一时也。上虽云如是般若理教我闻一时。未知从谁边闻。若余人边闻。则不可信。今言我从佛闻。明知是如来所说所以可信故。次言婆伽婆。然此名。乃是西国正音。魏无正名相播。故仍存胡本。义释云能破烦恼。或云具足功德智慧。亦言有大名称天人归敬。亦云能降伏天摩制诸外道。如是等义。乃众多非可具论。且云斯四耳。依西国正本。一切经首。皆言婆伽婆。此方经初多云佛在。时有安婆伽婆。亦有并存二名者。此第四明能说人也。前虽云从佛边闻。未知如来于何处说。若无方所。则不可信。故次云在舍婆提城也。然如来法身妙绝形相常在圣行梵行中住。故下经言。诸佛以不住道为处。如是身者。岂有顽域方处。而言在舍婆提者。明诸佛应现正欲赴众生感。众生既有方所。故圣亦同之。又欲令未来众生。知如来在此处说金刚般若。生敬重心。或时礼拜。或复赞叹。或时起塔香华供养尊重器世间生功德故。此舍婆提城者。昔劫初有仙兄弟二人。弟名舍婆。魏云幼小。兄阿婆提。魏云不可害。此二人住彼处求道。即因为名。弟略去婆。兄略去阿。二名双存。故曰舍婆提城。亦言舍卫城。如因拘尸那仙人名拘尸那城。因迦毗罗仙人名迦毗罗卫城。此皆因人为名也。唯阿踰阇城因事为名。魏云不可除伏城也。祇树给孤独园者。上虽云在舍婆提城。其处犹宽。是以第二指其别处也。只者外国音其国太子名只陀鸠摩罗。只陀者魏播云太子。鸠摩罗者魏播云童子。树者此方之名也。此园先属太子。须达长者后时以黄金布地。买得此园。广集贫穷孤老。于中养济。又复于中造立精舍。时人因名给孤独园。双举两主。并置胡汉之名。故曰祇树给孤独园也

与大比丘众者。前虽云我闻。主知与谁同闻。故列同闻之人。皆是罗汉众也。千二百五十人者。举现在大数也。若作六句。此同闻人应是第六句。若作五句。则我闻中摄也。依下流通分中。具列菩萨四众八部闻经欢喜。何故此中但云千二百五十比丘。而不具列诸众者。出以此经其义虽广而其文至略故。此序分中不广辨同闻之人。但出大比丘之数常随徒众。后则具列也。余经皆列名叹德辨数在先。所以此经阙不列名。不叹德者。亦以文略故也。大比丘者义乃多种。今但取断烦恼尽得罗汉者。以之为大比丘。此中不取白四羯磨等九种比丘。故曰大也。比丘者外国正音。此方义释或云乞士。或云破恶。或云怖魔。无正名相播。故仍存西本也

尔时世尊食时者。日中前时。表沙门少欲食必有时也。着衣持钵者。表出家人知足之相唯三衣钵更无余长。出入随身犹如飞鸟不舍二翼。去住随意情无系恋也。入舍婆提大城者。传云祇园在此城东从外而入也。大城者。此城宽博纵广十二由旬。居民凡有十八亿家。故曰大城也。如来所以入城者。为乞食故也。然如来法身金刚之体不假食而立。所言如来乞食者。如来现行乞食有多种利益。是故如来入城乞食。若具辨乞食利益。乃有多种。经中但云二十。今且论其十种。一者如来入城乞食。众生见如来三十二相八十种好妙相庄严如须弥山王发菩提心求如来身。二者聋盲喑痾诸苦众生见如来。暂时止苦发菩提心。三者诸豪贵长者自恃种性生于我慢。见如来威德严仪挺特异世。憍慢心息发菩提心。四为守护女人有三鉴。在家为父母所护。出嫁为夫主所护。老时为子所护。及懈怠者不能见佛。见如来入城。情怀欢喜发菩提心。五为释梵四王天龙八部导从如来。各各以天香华伎乐。赞叹供养如来。此中诸人见即生念。诸天尚舍天乐供养如来。我等何以不尔。便学诸天神祇广设供养发菩提心。六如来入城乞食。四天王各奉一钵。如来受已合。四钵为一佛现。如此不思议事。见者欢喜发菩提心。七为贫富二人施食。然富人饶食。欲多施如来。便见如来钵空故得多施。贪者食少。惧不敢施。便见如来钵满故得少施。令各称意。都此希有之事故发菩提心。八为如来钵中盛百味饮食皆不杂乱如异器盛。施一切众僧及诸众生。食之不增不减。见者欢喜发菩提心。九为未来弟子为俗人识呵。云汝师如来尚不乞食。汝何故乞食。是故如来现行乞食也。十者如来金刚之体。身内不空。又常在三昧。其实不食。唯有诸天知如来不食。为化众生入城乞食现行乞食。有此多益故入城乞食也

于其城中次第乞食者。西国法四性住城内。屠儿魁脍居城外。若入城时摇铃为拭。各自别行不相杂合。今言次第者。城内四姓中。不舍贫从富。又不弃贱从贵。故云次第乞食。若尔佛于众生则心不平等也。此明如来心非不等但随国法故也。然如来亦入下贱家乞食。如来设至下贱家者不令人见。若刹利婆罗门等见则便讥呵云。沙门不清净人。乃从下贱人乞食。遂不生敬重。若诸贵不生敬重。则佛法不立故。西国沙门多不从屠儿旃陀罗而行乞食。又亦不到恶象恶马恶狗等家而乞食也。唯有如来一人得次第乞食。其余比丘一向不得次第乞食也。还至本处者。乞食得已还至祇园也。饭食讫者。如来不食现食。所钵分为三分。一分置草叶上。施陆地众生。一分置水中。施水中众生。一分自食。然如来其实不食。唯有诸天知如来不食现食也。收衣钵者。叠僧伽梨洗钵已着常处也。洗足已者。然如来脚足犹如莲华尘水不着。诸佛常法受步行法。然如来行地。离地四指足不蹑地。下生莲华承如来足。岂有尘垢。而言洗足。示出家人威仪严净有可敬之相也。如常敷坐者。此非是人天八部所造弟子所敷。亦非如来念故方有。明诸佛如来殖因深厚自然报。有七宝堂阁众宝妙坐。不假施设。故云如常敷坐。佛欲坐则有。去已则无也结跏趺坐者。四威仪中坐威仪胜。若行住者则多疲惓。久而无患又随顺三昧。见者欢喜皆发菩意也。端身而住者。此明如来身业。表明如来离威仪浊。有三昧相俨然不动。如铸金像如木索人也。正念不动者。此明如来意业。专心一境得胜三昧。更无移躁故不动也。正念既是心法。何以可知。然正念虽是心法冥漠难恻。以形静验心。足知有定。如得定比丘。或一日不动。或七日不动。以身不动故。明知内心有定。自此前其序分

尔时诸比丘以下讫善付嘱诸菩萨。此是第二段经名为善护念分也。此所以名善护念者。须菩提既得如来冥加之力将欲禀如来。此冥加力故亲对如来。为诸菩萨。说金刚般若。欲问地上三种事发起下经故。初首叹言希有世尊如来善护念善付诸菩萨。此明如来善能教化根熟未熟二种菩萨。令世间解满速。入性地及初地大乘法中故。次明此第二分也。诸比丘者。此犹是如来常随徒众千二百五十比丘。而所以言来诣佛所。者此诸比丘常法。各在四面。离佛住处。或一百二百步外。随已所宜如法行道。不得近佛。若近佛者。则多妨丙。是故远住。如来乞食自持衣钵不将弟子。又诸比丘各自乞食不随如来。如来常法食后为四众八部如应说法。是故如来威力冥加。令诸比丘来诣佛所也。若如来不以意力加者。则诸比丘无由得来也

尔时惠命须菩提恭敬而立白佛言希有世尊者。一切声闻菩萨。于如来前。凡欲有所发问。若不蒙佛加被。则不敢发问。然须菩提若实是声闻。则要假佛加方能发问。设是方便菩萨权为声闻。亦假如来加被方能问也。如来向来始欲集众。而未有所说。须菩提有何因缘。于大众中。便叹如来言。希有世尊如来善护念善付属诸菩萨者。以须菩提先得如来冥加力故。智惠辨才与佛无异。将异诸菩萨说金刚般若波罗蜜经欲问如来地上三种事发起下经。是故叹言希有世尊也。此言希有者。非谓以时时有故为希有也。此音希有乃云为增亦言为能亦可云善也。此明如来快能护念付嘱二种菩萨应根授药不差机会不令失受道之时。故曰希有也。如来应正遍知者。略叹三号也。善护念诸菩萨善付属诸菩萨者。泛论菩萨有二种。一者初地以上出世间菩萨。二者地前世间菩萨。地前菩萨复有二种。一者外凡。二者内凡。就内凡菩萨复有二种。一根熟。二者根未熟。今言善护念者。叹如来善护地前姓种解行根熟菩萨。善付属者叹付属习种性中根未熟菩萨。此二种菩萨所以言护念付属者。若如来不护念付属者。此菩萨起心发行所观境界容有错谬退失。不能决定入于性地。乃至或时迳劫住世不能速入初地。故须如来护念付属也。根熟者。性种解行中。观三种二谛二种无我。一大僧祇欲满不满。欲证仿佛见理。无生法忍光明已现在前分中。具足功德智惠二种庄严等。八万四千诸波罗蜜决定能证。初地永不退失。故名根熟。而未得名为初地已上证无生法忍大力菩萨也。根未熟者。习种性中。然此习种性人。亦有二种。一者一往决定。二者不定。不定者虽习世间闻思修等功德智惠诸波罗蜜行。未能决定入于性地乃至初地。容有进退故。名此退人为根未熟也。如七种发菩提心人。前三种人多是不退。后四种人或退不退。若遇诸佛菩萨善知识。则不退转。若不遇善知识。退菩提心。转入外凡二乘之地。此是习种性人有退不退。或云性种菩萨犹退堕地狱。乐庄严经中道。性地菩萨决定不退。是以宝鬘论中。有人间龙树菩萨云。地持经中道。性地菩萨退堕阿鼻地狱此义云何。龙树菩萨答言。地持经虽云。性地菩萨堕于地狱。我不敢作如是说。何以故。不增不减经中明。性地菩萨毕竟不堕地狱。又乐庄严经中说。性地菩萨若一时杀阎浮提众生。虽有此罪犹不堕地狱。若四天下乃至三千大千世界众生亦不堕地狱。何以故。此人旷劫修行。多供诸佛。功德智惠善根纯熟。虽造重罪。以福德力大故。罪即消灭不堕地狱。如大热铁[金*敖]以一渧水投之于上即自消灭。以此验知。性地菩萨不堕地狱。若尔者二经相违云何会通。解云地持经中道言入者。催怖地前菩萨令其生惧速证初地。非谓实入阿鼻地狱。如十地经中七劝劝八地菩萨言。汝莫乐住寂灭定。然八地菩萨既位出功用。永绝识务。念念无生。运运自进。岂有乐住寂灭假劝方进也。欲令速入九地十地乃至佛地。是故如劝。非谓实乐住寂灭。何以知然。故经言亦莫舍此忍门。明知非实乐住也。此亦如是。实不堕地狱。言其堕者。欲令速证初地。非谓实堕也。故知性种以上一向不退也。所以言善护念者。唯依根熟菩萨。善付属但依根未熟者。明诸佛虽有自在之力。但能度于有缘众生。不度无缘。何者是有缘。如海龙王经说诸佛从因地来。以四摄六度等法所摄。于佛有缘者。如来自度故。就根熟众生明其护念。不为如来四摄等法所摄者。于佛无缘。付嘱诸菩萨有缘善知识。念于闻思修等。已得行中不退。未得行中其于上上证法胜进不失。然如来非不善护念根未熟者。亦非不善付嘱根熟之人。但出经者意不能烦文。且上举一边也。论曰善护念者。依根熟菩萨说等者。论主先分处二种菩萨也。又言云何善护念善付属者。将偈解释。故假设此问。问如来以何等心行作何方法与何念力名护念力。名护念付属二种菩萨。是故即以偈答。巧护义应知。然此论主凡作八十行偈。以释此经。前之二偈。论主将欲造论。先明归敬三宝申已造论之意。自下有七十七行偈。正释经文最后一偈。作论既竟赞叹回向也。此巧护一偈明何等义。正释前经中希有等经。然此希有叹如来快能念付嘱二种菩萨。故名为巧。即以此巧护为希有故。以此巧。释希有也。护者。通释善护念付属。此偈应云善护念付属。但以偈侠故单举护也。义应知者。理正如此劝问者令知也。然此一句释善护念付嘱已竟。第二句所以复言加彼身同行者。此为释上经中疑难。难云此经不应如是说。应言善护念诸众生善付属诸众生。所以然者。明如来慈悲平等被物无私应遍念六道不遗凡圣。若言护念一切众生。则义通凡圣。直云护念菩萨。但摄修行之人。则统收不尽。何故不云善护念诸众生。但云护念诸菩萨也。故答加彼身同行。言护念诸菩萨者。即是护念一切众生。加持彼身者。如来以智惠力。加二种菩萨。身令入性地。乃至初地证智也。若尔还复前疑。犹是如来唯护念菩萨不护念众生。故下二字云同行也。同行者。即是菩萨以四摄六度。摄取一切众生。以为伴侣。以为眷属也。若尔菩萨也修万行。而众生未修。云何言同行也。答意欲明大士睹真如佛性。于平等理中得相似解。亦得相似一体悲心。故不见众生异于我身我异众生我身。修行即一切众生修行。此明菩萨与众生同非异众生同于菩萨。故云加彼身同行也。明诸佛加菩萨化众生迭传相摄。即拘琐法门也。此一句。理而言之。通释二种菩萨。别而言之。唯释善护念也。不退得未得者。释经善付嘱得者已前修行也。未得者所未修行也。不退者。欲令习种性人于向已得行中坚固不失未得行中令胜进不退。故付善知识也。是名善付属者。结句应言是名善护念是名善付嘱。以偈侠故略也。云何加彼身同行者。论主提偈中第二句。依下答分为二问。一问云何加彼身。二问云何为同行也。下答亦有二。谓于菩萨身中与智惠力令成就佛法者。答第一加彼身。明菩萨蒙佛加故得胜智力亦成就初地佛法也。又彼菩萨摄取众生与教化力等者。答第二同行。明菩萨以佛加故得教化力能利益众生。即是同行也。云何不退得未得者。问偈中第三句云何为得主得中不退也。故答谓于得未得功德中惧其退失。欲令习种菩萨于二行中固解不退。故付智者。又得不退乃至付属应知者。虽云得未得中不退。未知何等法中不退。故出谓大乘法中不退大乘法中胜进也。不舍大乘者。令不舍因中菩提心慈悲无量等行及果头无为法身大乘法也

金刚仙论卷第一金刚仙论卷第二

世尊云何菩萨于大乘中发阿耨菩提心乃至则不名菩萨。此第三段经名为住分。亦名我心。所以名为住者。欲明菩萨既道登初地。现见真如法无我理。永断四住习气及无明粗品。出二十五有分段生死。离五怖畏。尔时过凡夫地。入菩萨位。生在佛家。种性尊贵。无可讥嫌。具足广等四种深心。毕竟利益一切众生。则能决定安住菩萨初地。所言住者。以不住道解为住。云何不住。谓观有为虚伪。断生死因尽。故不住世间。现见真如平等。得大慈悲。愿力成就。故不住涅槃。以此不住为住。故云住也。所以复名我心者。明初地菩萨既证圣位现见真如平等之理。由会此理。解知我之所有真如佛性无为法身众生所有真如佛性无为法身亦复如是一体平等无二无差别。于此理中。不自见我是菩萨修行之人有真如法身彼是众生不修行者无真如法身。解知一切众生即是我身。然凡圣虽异。而真如平等。故云我心亦得。云何一体悲心成就。彼此无二。故曰我心。此以解真如自在我为我心故。十地经云。于一切众生起我心也。此住分经文所以来者。上第二段中。既明如来善护念地前二种菩萨与其智力令证初地。然上既明地前相似无漏能入之行。未出证地之行。是故第三次正辨入初地已上真如无漏行也。问菩萨尔时以何等心观何境界。修何等行证何等法。而得住于初地大乘法中。住初地时有何相貌也。明菩萨尔时僧祇行满具足四种深心六度行成现见真如证无生法忍过凡夫地入菩萨位生在佛家。有如是心行相貌则得住于初地。名为大力菩萨。是故次明第三住分也

此一段经中须菩提有总别二。问云何菩萨于大乘中。发阿耨三菩提心者。此问中总句。然泛明大乘有二种。一者因中大乘。谓十地六波罗蜜。明十地菩萨乘六波罗蜜趣于极果。故曰因大乘也。二者果头大乘。谓无为法身佛果是也。今言于大乘中者。是因大乘。亦得义通因果也。大乘之义乃有无量。且略辨四种。一者体大。明大乘之体苞含万德出生五乘因果。故名体大也。二者大人所乘。明菩萨大士乘此地行趣于佛果也。三者大人所证。明唯诸佛如来穷会此法也。四者能成大义。明诸佛既证常果复能化益众生有大恩义。故曰能成大义也。具此四义。故名大乘也。发阿耨多罗三藐三菩提心者。菩提亦有二种。一者因菩提。谓十地万行也。二者果菩提。无为法身是也。通此因果二种。以为无上菩提也。今所言菩提心者。即是初地僧祇行满。现见真如所证无生法忍。以此为菩提心也。随分证用无为法身。即是果菩提也。发者亦言生成证得也。阿之言无。耨多罗言上。名为无上。亦云最胜最上。三之言正。藐言遍知。正者真如智即一切智也。遍智者有中一切种智也。又言三者亦是正也。菩提言道。此是如来果头无上最胜正遍知。离断常二边。知中道正理。初地菩萨证会此道故。言发阿耨三菩提心也。亦有解言。三藐者正也。明声闻道不正佛菩萨道正。此明不同声闻。后三言遍也。明缘觉之人观境起行不能周遍诸佛菩萨能遍观万境广修万行。此明不同缘觉也。云何住等。此三问中别句。一云何住者。即起此住分经也。二云何修行三云何降伏其心者。此二问即起下第四如实修行分也。如来所以赞言善哉善哉须菩提者。上第二段中。须菩提虽叹如来希有善护念付嘱地前根熟未熟二种菩萨复发初地以上总别四种问。然大众意谓须菩提乃是声闻之人。向前所叹如来善护念付属二种菩萨。及闻初地已上行。此乃诸佛菩萨境界非其所知。惧其此言未必契当于理称可圣心。有此疑念。今将明须菩提得如来冥加力故。说当于理。所叹所问合其圣心。真实不虚。非为谬说。是故如来赞以善哉。佛去时众疑心也

佛告须菩提菩萨生如是心以下一段经文。答初问云何住也。就此答初问中。明菩萨具足四种深心故住于初地。大乘法中生如是心者。初地菩萨缘三种众生决定证得四种深心也。所有一切众生所摄者等。论云广心所以名广心者。明初地菩萨现见佛性平等之理得一体慈悲。故能化度虚空法界一切众生情无限局。故曰广心也。然此心所化众生有总别二周经文

所有一切众生者。谓先总明虚空法界一切众生也。众生所摄者。明此所化者唯化有心众生不化摄无情之物也。此下别明广心所摄众生有三种差别。化生等四生名生依止差别也。有色无色等六名粗细差别也。所有众生界众生所摄者。二乘意生身差别。亦名憍慢差别也。此第三别明二乘人既道出三界前二生不摄。所以别明也。然二乘人有二种。一者发菩提心声闻。如法华中舍利弗等受记作佛者是。二者寂灭声闻。断三界惑尽。出分段生死生究竟想。起憍慢心。入寂灭定。迳千万亿劫。于此定中。而不勉变易生死微细行苦。后时定力既尽。从禅定出。更无所依故。还觅善知识。发菩提心。求无上道故。菩萨于此憍慢众生。亦兴悲救度。故须明也。亦得云十一种众生。生依止中有四。粗细中有六。意生身有一。合有十一也

我皆令入无余涅槃而灭度者。论云第一心也。前虽云广度湿生等一切众生。未知化此众生与何等乐。是以第二次明唯以常住佛果无余涅槃第一之乐与此众生。不以二乘中道所证灰身涅槃而以与之。况人天乐。故曰第一心也。此言无余者。有二种。一二障永尽。二万德圆满。备此二义。故曰无余。非谓以小乘身智亡处为无余也。涅槃者。此幡云寂灭也。如是灭度无量无边众生。实无众生得灭度者。论云常心也。常有二种。一就佛性法身凝然常住彼此平等。以明常。然佛性法身虽复平等。若就行者而言。一法身上有三种名。或覆法身全不净者。名为众生。修行断惑半净半不净。名为菩萨。十地行满断惑障尽具足清净者。名之为佛。若据真如等有法身彼此无二。故曰一体常心也。二就得慈悲一体常心。众生如自己身。常现在前心不舍离。故名常心。具此二义。故名常心也。依此论释一体悲义道。初地菩萨得一子地者。犹非尽理之言。何以得知。如有女人。唯有一子。爱之甚重。常言宁愍我身不愍我子。王即使人以大火炎此女人。此女人患热。推子遮火。护惜己身故。知言一子地者。非尽理之言。故引事来证此一体悲义也。然此众生所以护惜己身者。以无量世来计着虚妄我见习久故尔。如经中说。有人造五逆罪。迳五大劫在阿鼻地狱。偿罪将毕。有人谓曰。汝明日得出地狱。然虽复得出。而汝此身于即断灭。罪人闻之。即答云。我宁更尔许劫在地狱中。不用出已断灭。以此众生从无始世来。贪着妄我故护惜己身。非实有我也。此菩萨亦复如是。从一大阿僧祇来习此慈悲。证初地时。于一切众生得一体心成。冥然一体。不见二相二差别。故曰一体。以此为常心也。此常心者亦得二心。一真如自在我二一体悲心分也。如是灭度无量无边众生者。牒前菩萨所化众生令入涅槃者来也。实无众生得灭度者。明菩萨虽度向无量众生令入涅槃。而于真如平等理中不见我是菩萨有真如佛性。亦不见彼是众生异于我身无真如佛性而可度者。以真如平等理中泯然一观彼此无二。故曰实无众生得灭度也。又此菩萨得一体悲成故。取一切众生如自己身。冥然一体。不见彼此之异。故曰实无众生得灭度者

何以故若菩萨有众生相即非菩萨者。此释前实无众生得灭度者。云何释。明菩萨既广化法界众生令入涅槃而复言实无众生得灭度者。何以故。如此二言相违也。今将明菩萨由证此真如平等及一体悲成。绝分别之心。不见彼是众生我为菩萨。而起心度之令得解脱。故言实无众生得灭度者。非于妄想世谛缘用明道中亦无众生可度者。故此二言不相违也。若菩萨有众生想即非菩萨者。明若菩萨起心分别。谓离真如佛性平等利外。别有定实众生异于己身而可度者。故有众生等想。此未是初地解真如平等真我菩萨。故曰即非菩萨。此举有众生相不生不分别相者非菩萨故。明得我心无众生相者。此以是非相形答也。何以故知。如首楞严经中。坚意菩萨白佛。菩萨住何地中。得首楞严三昧。佛告坚意菩萨。非初地中得。乃至非九地中得。若尔竟何地得也。故答于第十地中得。又云若不得首楞严三昧者。则不名菩萨。若尔九地已下岂可一向非菩萨也。即答亦得如分力得此三昧。然此言即非菩萨者。明九地已还虽是菩萨而不得名为第十地中具足得首楞严三昧菩萨。然非不分得此三昧也。宝仿论中。有人问龙树菩萨。菩萨从何地来得首楞严三昧。答初地中得乃至第十地中得。又云菩萨不得此三昧者。则不名为菩萨。以是文验。足知九地已前亦名得此三昧。但遂胜处彰名。故云不得首楞严三昧者不名菩萨也。如涅槃经云。十地菩萨眼见佛性。九地已还名为闻见。然九地已下亦分有眼见。但以下形上。云九地为闻见。非是全不眼见。何以得知。又即云唯佛一人眼见佛性。十地已下皆名闻见。以此验知。亦得言初地以上眼见佛性。地前凡夫名为闻见。此皆就人有上下迭相形夺。优劣中语。非称实之谈。故今道则非菩萨者。则非初地解真如平等菩萨也

何以故非乃至不名菩萨。此论释云不颠倒心。何故明此众生有人生疑。菩萨住初地时。云何于一切众生得我心者。此以何义故名为我心。如外道凡夫。以颠倒见故。于众生五阴无我法中。横计神我。未知此菩萨我心者何。异外道凡夫横计神我。故言何以故也。为除此疑故。佛将欲答菩萨起于我心者非是横神我。故言何以故也。为除此疑故。佛将欲答菩萨起于我心者非是横计颠倒之我。故言非也。泛明我有二种。一者一切众生真如佛性一体平等自在之我。二者于众生五阴中横计即离等神我颠倒心也。然菩萨得真如平等自在我解故。便住初地。故此非横计颠倒我也。应直作此答。何故乃云有众生相等不名菩萨答也。将以未得二种无我平等解者。有众生等相非菩萨故。明知得二种无我平等解者。无众生相。是名菩萨。以未得者非故形得者为是。此转答也。若菩萨有众生相至寿者相等者。此明若菩萨犹有我人等相则不名住初地已上解真如平等得无我菩萨。故云则不名菩萨也

论曰。云何菩萨大乘中住等。此是论主将释前经故。设此论生起也。大乘中住者。取经中问答所明之义。为此一段经名也。问者须菩提问。答者如来答也。示现此义者。明此经辨具足四种深心永大乘中住义也。此一段经虽科为四句。论以一偈释尽。初广心者。别释卵生等三种众生。明菩萨发心教化卵生等色无色等尽众生界。情无限局。故名广心也。大者与广。义一名异。但为成偈故所以并置也。第一者。释经中我皆令入无余涅槃而灭度之。明菩萨乃以常住涅槃至极之乐度于众生。不以声闻缘觉中道所证而灭度之。况人天等乐。故名第一心也。常者释前经中实无众生得灭度者。常有二种。一明初地菩萨会真如佛性常住之理。然此常理妙有湛然古今一定。无有凡圣彼此之异。于此真如一体平等理中。何得见有众生异于己身而得灭度者。故言常心。二明菩萨得一体慈悲平等之解。我所修善根即是众生善根。教化众生如我自身。恒无休息。故名常心也。其心不颠倒者。释经中。若菩萨起众生相等则不名菩萨者。明道言我心者非妄计神我颠倒心也。利益深心住者。此是疾转义通前四种心。下皆云利益深心住。此言深心者。缘真如深理起此四心。故曰深。又复深起悲心。亦名深也。今言住者。具上四心故。初地大乘法中决定住也。此乘功德满者。明初地菩萨具前四心故初地僧祇大乘功德分中满足非究竟满也

此偈说何等义者。论主作偈释义讫竟。复以长行。论来释故。先假设问。其一偈所释之意说何等义也。既有此问。即答云若菩萨有四种深利益心。此是菩萨大乘住处讫未明。此下答意有二。初辨以有四种深心故。此菩萨能住初地大乘中。二从何等为四种心以下至未。广别提四心各举经结之也。若菩萨有四种心者。牒偈中上二句四种心也。深利益菩提心乃至大乘住处住者。释偈中第三句也何以故此深心功德满足者。举偈中第四句。以功德满足故。释成前第三句云何此四种心得住于初地大乘中也。明具四种功德满足故得住初地大乘中也。是故四种深利益摄取心生等者。结总释四心也。是故者。是四种深心满足故。便近摄取初地远生佛果也。何等为四种心者。将欲以一句经结一种心故问出四种心也。一广等数出四心也。云何广心利益如经等。自下别提偈中四种心各为问。各以一段经结之更不委释。即指经为解依论可知也。但第三常心其义犹隐故。论主偏作问云。此义云何。虽此一段明于常心犹未可解。不知此常心之义云何也。菩萨取一切众生犹如我身者。答于常心义。明菩萨得一体心成。是故取一切众生如我身。不见众生异于我也。以此义故者。以此菩萨取众生犹如我身义故也。令众生得涅槃灭度之者。即是我身涅槃故。异菩萨身外无别众生得灭度也。若菩萨于众生起众生相不生我想等。犹是经中举非形是也

论曰自此以下说菩萨如大乘中住修行者。此是论主。牒前住分生后修行分也。如大乘中住者。牒第三住分也。修行者。处分生后大段第四如实修行也。此正应直处分。如实修行分。何故通牒住分来者。明菩萨虽得四种深心住于初地犹行未究竟故须臾进修二地以上诸行故。通牒前第三分生起第四分也。复次须菩提不住于事行于布施等一段经。名为第四如实修行分也。云何名为如实修行。明二地已上修道菩萨。既会真如平等。现见佛性得一体慈悲故。能以无分别不取相心。而不为三事。亦不见三事相。行八万四千诸波罗蜜故。名如实修行也。此经所以来者。前第三段中。已明菩萨现见真如具足四种深利益心。则能永断四住。出分段生死。离五怖畏。生在佛家。住于初地大乘法中。然虽一大僧祇行满证初地无生见道之解并观三种二谛平等照万有。犹地行未圆。一切种智未满。观境未周。断惑未尽。大光明未具足。必须重修万行增习见道备精众德更迳二大阿僧祇。行满或尽。方能进趣证于佛果。是故菩萨若能始从二地终于远行。以不取心。行诸波罗蜜。遣功用相尽。乃得证于八地已上无功用位。备修十地。得一切种智。是故第四次辨如实修行分也。就此经中始未具明三道。何者是前之住分局在初地。即是见道此如实修行分。二地已上至于七地。即是修道。下断疑分中言违于不住道者。即是八地至十地无功用道也

不住于事行于布施者。论云不着自身事者。自五阴事也。以菩萨离不活畏故不着自身。所以教不着自身者。若着于身。则有二种过。一畏身不活一向不施。二说使布施着相心求不成彼岸义也。无所住者。论云不着。报恩报恩者。谓供养恭敬。供养有三。一奉施。二恭敬。三尊重。恭敬亦有三也。一给侍。二迎送。三礼拜也。菩萨得一体心成故。常作心念。我应供养一切众生。云何乃求他人供养。是故不着报恩也。不住色等者。论云不着果报。此明菩萨为求无上菩提行于布施不为三界人天中色声等五欲果报。故云不着果报也。此三句答于问中云何修行也。以能如是不住三事行于布施。方得名为如实修行也

有人乘此生疑。凡人所以行布施者。为自身报恩果报。若菩萨不为自身报恩果报者。云何而得行于布施。复布施之行云何得成。有如此疑故。佛答须菩提。应如是布施。此明虽不为三事。以此菩萨为求佛果。复得一体慈悲愍一切众生故所以能施。此是无相布施故彼岸义成。故言应如是布施。应如是布施者。应如上不为三事行无相布施也

虽言不着三事行无相布施。未知菩萨观何境界调伏其心。能如是不着三事行于布施。故下云不住于相想。此经答上问中。云何降伏其心。释成前云何修行中不着三事。明所以能于自身报恩果报不着。而修布施等行者。明此菩萨由证真如平等得胜三昧。柔伏其心。便不见我是施者彼是受者。既会平等不见彼此施主福田二相差别之异。不见财物但是我许非余人物。而用施前众生。又亦于平等理中。不见有菩提果报可求。明菩萨于真如理中得胜三昧。于此事中降伏其心。得柔软自在故。能不着三事而行布施。此三种事有二种。一外。二内。一不住相者。谓受者财物二种外相也。不住想者。谓施者内心想也若能如是不取内外法相。以无分别。能降伏心。而行布施。故成上不着自身等三事布施行也。云何而言若不住自身等相。何得布施。不施之行云何得成也。明真如平等理中不见三事而行布施者。乃真成无相檀。非谓性空中不见也

因何不着果报。更生一疑。若不着果报行布施者。无上菩提亦是果报。云何为佛菩提行于布施而不名著果报也。此中未答指下第五段。彼处明法身菩提是无为相。设使为此菩提行布施者。不名取相故。遥以此为答也。何以故。若不住相布施。其福德聚不可思量者。此乃为释。前疑者云若不见施者受者财物三种相者。未知此为有心故言不见为无心故而云不见也。若无心者。此何异郁单越人。彼处人无我所心。他来取物者劫无心吝惜。以无施心故。虽舍布施无福。此亦如是。若无心分别不成彼岸行也。若不见三事行布施者。此施为有福德。为无福德也。故答不住相布施。其福德聚多不可思量。明此布施得平等真如一体心成故。但于此三事中不生取着。名为不住。非无真如平等知慧解心而行布施。此明有心非是无心也。若取相布施。是有漏因。但感三界有为果报。其福有尽故少。不见三事行布施者。不取相是无漏之因。乃远招佛果。不感三有果报。故无相福德转多不可思量。此明无相心布施得佛果无量功德聚。故非无心无福也。故以此一。何以故等。双释二疑也。然此虽法说云福德不可思量。义犹未显。故复别虚空譬喻证成福德多也。然既行不取相因。必得无为法身大功德聚。此云功德。非凡夫二乘下情图度。故云不可思量。此因中说果。亦得道十地因行亦不可思量。所以须说十方虚空者。恐人谓东方世界虚空不可思量。余方世界虚空是可思量。复为彰施福多故。亦得云一一法门中功德不可思量如十方虚空也。然如来虽如是广释菩萨不住相布施之义其福德聚如十方虚空不可思量。而大众疑心犹故不尽。复云未知此之布施波罗蜜行为毕竟成得大菩提无量功德为不成就也。为除此疑。是故佛答但应如是行于布施。此明应如我上来所教。不住三事。不见三事。调伏其心。行于布施。必得无为法身大功德聚。但信我语勿复生疑

又复一解。疑云若不取相行布施者。然亦不应为佛菩提行于布施。若为佛菩提行于布施者。虽舍世间有为法中着。还于出世间法中取着。云何而言不住相布施得福多如虚空也。故佛答但应如是行于布施。明虽为佛菩提而行布施。然佛答菩提无为法身非有为相故。为无为佛菩提行于布施。非取相也。然下长行论中更不别释此疑。即指第五段中如来非有为相答也

此一段经。凡以三行偈释。初一偈真释。何故此经六度之中。独明檀度之疑。第二偈释经中不住于事等三种修行。第三偈释经中不住于相想等尽经也。初偈云释疑。何者是疑。疑云如来前七部般若中及以余经皆具说六波罗蜜。以摄万行。此中何故单明檀波罗蜜。不说余五也。若有此疑。还应有问。以此经多不作问答故。论主随顺经意。亦不作问答。故宜答言檀义摄于六。既有此答。即知有问。故不作问也。此偈言檀义摄于六者。此明如来说法有二种。一者总相法门。二者别相法门。此即是总相法门也。明以一檀之义摄取余五。以此五中皆有檀义。故得相摄。是故此经单说一檀之名。以通收于六。故不明余五也。虽言檀义摄六。未知此六云何皆有檀义。故下句行出云资生无畏法。资生者。谓以珍宝饮食衣服财帛等资生之具。惠施于人。故名为檀也。无畏者。摄戒忍二波罗蜜。亦名为檀。由持戒故。不报外恶。以有羼提波罗蜜故。能忍加毁。即以此二能施前人无畏。故名为无畏檀也。法者。摄精进等后三波罗蜜有于檀义。以此后三波罗蜜故。便能以胜法施人。故说此三说在法施檀。义释在长行论中也

又复一解。云何菩萨布施摄尸波罗蜜。菩萨布施时。受时不如法修行。菩萨尔时其心清净不生慊恨。是故布施摄尸波罗蜜。云何菩萨布施摄忍辱波罗蜜。菩萨布施时。受者嗔恚打骂菩萨。尔时忍不生嗔。是故布施摄羼提波罗蜜。云何菩萨布施摄精进波罗蜜。菩萨布施时。受者嗔恚慊物少恶。毁骂菩萨。菩萨转转精进。勤行布施不休不息。是故布施摄毗梨耶波罗蜜。云何菩萨布施摄禅波罗蜜。菩萨布施时。不求人天二乘果报。但求无上菩提。故布施摄禅波蜜。云何菩萨布施摄般若波罗蜜。菩萨布施时。不见施者受者财物。是故布施摄般若波罗蜜也。此中一二三者。前句明其六檀之体。此句还出上六檀之数。一若资生檀也。二者或忍二度无畏檀也。三者摄法中精进等后三檀也。此中非但唯檀波罗蜜摄于余六。下五度皆迭互有摄六之义也。名为修行住者结句。明以此一檀摄六波罗蜜。故得名为二地已上修道菩萨如实行住也。何故唯一檀波罗蜜名说六波罗蜜。乃至相义亦现。此中有一问答。释偈中初句。以一檀波罗蜜摄六之义也。一切波罗蜜檀相义者。自下论主将欲解第二句。六波罗蜜皆有檀义。故还牒前句也。谓资生无畏法等应知者。正出第二句。明资生无畏法摄。以六波罗蜜皆有檀义劝人知也。此义云何以下。一一别释句三摄六皆有檀义也。于已作未作恶不生怖畏者。此解戒忍二度作无畏檀义。已作者。前人已曾诽谤菩萨言。汝是破戒毁禁行恶之人。非持戒人。故云已作恶。未作恶者。前人虽起恶心欲诽谤菩萨。犹未诽谤。故言未作恶。又云已作恶者。众生已曾加毁打骂菩萨。名为已作恶。未作恶者。众生始起心。犹未打骂。故未作恶也。不生怖畏者。明菩萨于此二种已作未作恶人。若加报者则令前人恐惧。以菩萨持戒忍辱故。不报其恶。便施前人无畏。此解戒忍二波罗蜜有檀义。故言不生怖畏也。法檀波罗蜜不疲惓者。明菩萨以有精进波罗蜜故日夜精勤求五明论智。为一切众生说法教化无有休息也。善知心者。禅波罗蜜此云思惟。以得禅波罗蜜故。获他心智众生三乘根性利钝不同欲乐厚薄有贪心离贪心等。称机说法。或应与念而得度者。如禅默众生等是。或有乃是断命而得度者。如佛昔作仙预国王杀五百婆罗门等。或有应说颠倒法门者。为说颠倒法门。如持戒之人应因破戒而得度者。教破戒等是也。以因禅定故善识根机。故名禅波罗蜜为善知心也。如实说法故者。以般若波罗蜜故。善解二谛法药。称于法相。如实为众生说法也。此三解精进般若等有法施檀义也。此即是菩萨摩诃萨修行住者。近结别释。三檀摄六。以为二地已上如实修行住也。如向说三种檀摄六至是名修行住者。此句远结总别释。一波罗蜜摄六之义。皆为修道菩萨修行住义也

云何菩萨不住于事行于布施等者。此论主将欲作第二偈正释经中不住三事。故举此经文来问。故云云何也。第二偈释经中不住于事等三种修行经文自身及报恩果报斯不着。应云自身不着报恩不着果。报不着但以偈狭。先具列三事。后云不着也。自身者释经中不住于事行于布施。明菩萨证初地解时已离五怖畏。无有不活之畏。故能不着自身而行布施也。报恩者。释经中无所住行于布施。明菩萨行布施于不为供养恭敬衣服饮食种种恩惠之报也。果报者。释经中不住色布施等。世人布施为求未来人天中五欲果报。今明菩萨布施不为人天中色声等报。乃为远求佛果故。此三句下皆云不着。故曰斯也。下半偈二句。还释上二句。获存已不施者。释初句中自身。若存着己身。畏身不活。吝财不施。遮此着心。故言护存已不施也。防求于异事者。释上报恩果报。又虽布施。若为世间报恩果报。即是求于世间有为异事。不求出世无为佛菩提。为遮此事故。云防求异事也

不住于事者。论中提经也。谓不着自身者直以偈论属经也。无所住。谓不着报恩乃至如经无所住者。此亦经论相属。并释出报恩事。复以经结之也。不住色等谓不着果报者。亦是经论相属。何故如是不住行布施者。问上二句中不住三事所由。提下半偈为答。然后就偈中。次第释不住三事之所以也

第三偈调伏彼事中者。释经中应如是布施不住于相想也。菩萨既证真如之解得理中定。能除惑障。得喜乐意。心得柔软自在犹如良马。亦如真金。无取三事相刚矿。故云调伏也。彼事中者。虽云调伏。未知于何处调伏。明菩萨得佛性真如平等解一切众生即是我身故。不见我是能施前人是受施者。又复不见财物唯是我许非前人物以我财物施与前人。于此施受财物三法中调伏故。言彼事中也。上虽云三事中调伏。未知云何调伏。故次第二句远离取相心也。于三事之中。不生取着故。言远离也。此上半偈。唯释不住于相想经。第三句通释上下生疑也。及断种种疑者。此种种疑。即上经中三种疑。又亦通生下第五第六疑中断疑经文。故云及断种种疑也亦防生成心者。次前句释上下其义已竟。所以复作此一句者。但为偈故还重指出上疑。若不取三事相。云何布施。若不见三事而行布施者。为有心。为无心。若无心者。为有福德。为无福德。若有福德。为多为少。波罗蜜行为成不成。此是生疑也。遮此疑心令使不起。故云亦防生心也。成者即答布施行成有多福德。释云前疑斯一句中合有疑答也。又解上生疑。若菩萨不住三事相。复不见三事。为有心有福。为无心无福。彼岸功德成以不成。遮前人如此疑心。故言亦防生成心也。此文说何义者。问上不住于相想经文中。为说何等义也。故答所谓不见施物受者。及施者此列经中所明事。即指上半偈为解。复举经来结可知也。次说布施利益者。将以下半偈释菩萨不住相布施以下经故。作此一句。生起下疑答之意。如论可知也

何故说修行后。次显布施利益者。此中论主设难云。布施之行正是其因。所得利益乃是其果。夫说法之来应先说果在前。然后劝修其因。此是圣人说法之常式何故今者先说因于前。后方说其果也。故答以得降伏心故。后说布施利益。明若此菩萨未修行时。须先说果以示之劝修因行。今明此二地以上菩萨已能现真如。降伏其心。不着三事。布施等行久已成就。既有此因。直须次第为说因所得果也。此义云何等者。故释前问答之意也。自此以下一切修多罗示现断生疑心等。此一段论生起下经。凡作二意。初断生疑心。以前通生起第五段以下讫末经中疑也。云何生疑以下。次第别生疑意。然疑答之意。如后就经中生起。若以经答时。会须作疑。故不二处具作生疑意也。须菩提于意云何可以相成就见如来不者。此段经第五名如来非有为相分。何故此名非有为相者。明法身如来古今湛然万德圆满体是无为永绝生住灭等有为三相。故曰如来非有为相也。次何次第起者。上第四段中。明菩萨以不取相心行于布施。此辨无相之因。疑云若有无相之因。还应得无相之果。然今现见释迦如来。始生中住终灭。果头既有此三相。以果验因。明知因亦应是有相。故知无有无相之因也。那得上言不取相行于布施能得果头无为法身无量福德也。为断此疑故。佛应答。须菩提莫作是念。汝言果头如来有生住灭有为三相者。是方便身随感故有。非是无为法身。然无为法身。古今湛然万德圆满。体绝三相。故非有为。汝云何以方便身有三相故。谓即是无为法身名三相也。此中应作问答。所以不作问答者。此经始末多不问答。然须菩提既是法身菩萨现为声闻。又得如来冥如力故。善解如来意。故佛直问。须菩提于意云何。以相成就见如来不。明可以生住灭等有为三相成就见果头无为法身如来不也。故须菩提解如来意。即答不可以相成就见如来者。此明法佛如来无为法身体无三相故不可以有为三相而见也。又有二乘凡夫。即执丈六如来二种涅槃以为无为。亦是常住无为者。谓释迦如来从发心已来。三大阿僧祇劫。修十地行满。菩提树下证正觉时。始降伏天魔。及断烦恼魔。身智犹存。此名有余涅槃。不为烦恼所为。故名无为。无余涅槃者。身智尽时。不为生住灭等三相所为。故曰无为。有此二义。故名丈六为无为法身。名常住者。明丈六如来一入涅槃更不还来二十五有。故名丈六为常也

自此以下讫经。广解三佛一异之义。今此段中。唯明法佛者。就别相中论从此以下。明报应二佛。经文历然自广明之。此中乘生疑念。应佛既有三相。非无为法身佛者。此丈六身。为当是佛。为非佛也。又亦疑报佛妙色无量相好庄严身。既非法身。为是有为。为是无为也。为是有漏。为是无漏。为是常耶。为无常也。又复报佛依报净土。为是有为法。为是无为法。为当三界所摄。为非三界摄也。有如此疑。下经当自一一别释可知。何以故者。因前不可以相成就见如来。乘生疑难。若法身如来无三相者。何以故如来自说我三大阿僧祇劫修道。最后身生于释种白净王家。六年苦行。道场成佛。八十余年处世说法。自云我身无常。却后三月当般涅槃。于双林灭度。故云何以故。经答言。如来所说相即非相。云何所说相即非相。明从王宫生至双林灭相。此是应身方便之相。非即此相。是法身无为相也。此应佛随众生感见故有。无其实状。论其体也。则唯一法性寂灭湛然。亦无四大色香等相也。佛告须菩提。凡所有相皆是妄语者。此泛论世间心心意识虚妄分别。应佛所有为三相所成者。皆是虚妄不实。亦得云凡所有果头报佛万功德相别相义边非古今一定虚空法身。故言凡所有相皆是妄语也。若见诸相非相。即非妄语者。若见有为三相非是无为法身相者。非是虚妄也。若尔有人疑。如来正可无有为三相。诸佛果头万德相者可是无也。答如是诸相非相。则见如来。如是知有为三相非无为法身相者。此人能见真实法身如来也。此明法身如来有真如解脱相而不同生住灭等有为三相也

此一段经。以一偈论释。分别有为体者。明诸小菩萨二乘之人起心意识虚妄分别。谓有为三相所成者。即是第一法身如来更无别无为法身。道无为法身者。虽诣虚空以为法身。而不可见。明知无有无为法身也。此一句将欲释疑。先举惑者之计。故言分别有为体也。第二句云防彼成就得。防者。遮前人计勿取三相所成者。是第一法身如来也。故言防彼成就得。此一句释经中于意云何以下至不可以相成就得见如来以前经也。三相异体故者。此一句释经中何以故如来所说相即非相至是妄语。明应佛三相及报佛万功德相异法身如来体。以法身如来别相义边离于三相及报佛佛万相故也。离彼是如来者。此句释经中若见诸相非相以下经文。明无为法身湛然常住古今一定体相寂灭。自性离三相等相。非断故离也

此义云何者。一偈释经之义意云何也。自下答释云何之意也。答分别有为体等三句。指出偈中上句惑者计情也。为防彼相成就得如来身者。提偈中第二句。遮上计情。即释经中不以相成就得见如来故引经也。何以故者。何以故遮言不可以应佛三相见法身如来也。故释云如来名无为法身故。明此法身体无三相故是无为故不可以相见也。如经等者。并引经偈来证也。彼相成就即非相成就者。释于经偈也。彼相成就者。明应佛三相也。即非相成就。此应佛三相。即非无为法身相成就也。此经偈明法身无有为相故得为证也。何以故者。复欲将举下偈释于下经问。何以故应佛三相成就非是法身相成就。故云何以故也。三相异如来体故者。还举前偈为解。上已将此偈证所以。此中复牵为解者。以此一句通释两处经文。是故中重提偈来释下经也。此句显有为虚妄故者。此是论主属当凡所有相等经之与论也。偈言离彼是如来者。此偈何故别提者。上通牵证义未别释经文。故更提此偈来释。若见诸相非相等以下结也。此句明如来体非有为故者。此论主属当若见诸相非相等经论也。菩萨如是知如来已下以经释疑竟。结释疑答之意也

金刚仙论卷第二金刚仙论卷第三

自此以下。尊者须菩提生疑致问

须菩提白佛言。颇有众生。未来世于此修多罗生实相等者。自此以下有二段经。是大段第六名为我空法空分也。此亦名住放辨才段。所以名我空法空者。就对计我四句。明无我四句。以释我空。明能信菩萨于众生五阴中。解从本以来无定实神我众生寿命等四以之为我。又无定实五阴因缘以为我所。以不见定性。我所可以除荡。故名我空。法空者。就对法中四句。以明法空。上我空。直见生阴定性我无定性。所犹未空生阴因缘法体。今明此生阴非直无有定实神我。其体生灭因缘虚妄。本来寂静乃至假名亦无。故名法空。又知佛性真如古今一定体无方相。亦名法空也

亦名任放辨才段。所以名任放辨才者。明诸佛菩萨得不妄陀罗尼自在辨才。故能随问而答。超越解释前后任意。义不相违。故曰任放辨才。就此段中。有任放辨才义故。名任放辨才段也

亦得名有能信者分。以此段中明三种人能信此经故也。此经以何次第起。上第四段中。明不住相行于布施。说因深义。第五段中。辨如来非有为相。说果深义。有人生疑。如来说法非直为利现坐大众。乃亦被益未来像法众生。然现坐大众亲睹如来。复是久行大士。善根淳厚智慧深妙。是人于此深经。可容生信。未来世众生。善根微薄智慧鲜少。于此因果深经。不能生信。若尔则为如来空说无益。云何如来得言不空说法也。若空说无益。如来则非一切智人。如是因果二种甚深修多罗。未来末世为当有人能信。为无人能信也。有如此疑故。须菩提腾大众疑意。故白佛言。于如来灭后恶世之中。颇有众生。能信此经以之为实相不也。佛下答有人能信。明于未来恶世有持戒修福德智慧者三人。能信此经生于实相。故次明也

应问能信之人乃有其三何故单以我法二空。檦第六段名者。明持戒修福德二人。在于地前。仰习二空。闻中生信。有智慧人。乃是初地以上现见我法二空。证中生信。然前之二人。虽未现证。以其亦同观二空。仿佛见理故。俱列为能信之人。今明虽有三人能信。但遂三人所观胜境为名。故曰我空法空分也。然今将欲道有人能信。故先遮言莫作是说。明未来恶世中有人能信此经。不应问言颇有人能生信不也

须菩提既闻如来遮言莫作是说。即复生疑。我今不解佛意。为当一向无人能信直止我令默。为有人能信而止我令谛听也。故佛答有言。有者明有人能信也。虽云有人能信。未知何等人能信故。即云未来世有菩萨能信。又此菩萨有何等德行观何境界故。能信此经也。故次云有持戒修福德智慧也。此总明三种人有能信之德。所以名持戒者。明此人已久供诸佛。曾闻此金刚般若及以余大乘经。于中生信受持读诵如说修行。知一切众生皆有佛性。发菩提心。慎教修行者。乃名真实究竟持戒。非唯持律仪戒者为持戒也。福德者明此菩萨于诸佛所。广以珍财奉施。修波罗蜜行。名福德也。此之二人。在于地前。闻中仰信。智慧者。明此人已僧祇行满。道登初地。现见我法二空。自证而信。名有智慧也。明此三人于斯经能生实相之信也。此言实相者。明彼三种人。能信上不取相行是无相之因实能感无为法法身。亦信无为法身是无相之果真实不虚。能生实相之解。故言以此为实也。然上虽总出三人能信之德。明前二种人在于地前闻中生信。有智慧人地上证信。然此前二人。若在地前。此人为曾供养诸佛发菩提心已修行未故信。为当未修行来而能信此经也。若曾供养诸佛久修行来者。为当供养几许佛来也。故佛告须菩提。当知彼菩萨非于一佛二三四五佛所供养种善根来也。然就三人之中。先别明前二人非近修行来具能信之德也。此经正直尔泛明斯二人能信之德。不可定指在习种性性种道种性中。以其义通上下故也。一二三四五佛所修供养者。此别出持戒人。明彼菩萨能信此经。如此经如说修行称可圣心。名为第一供养。非谓香华等为供养也。又非一二三四五佛所种善根者。广以衣服珍宝财物等。奉施诸佛。修波罗蜜行。名为有福德人也。于无量诸佛所。修行供养种善根者。直云非一二三四五佛所修行供养种善根。未知几许佛所。今者明此人已于无量百千万乃至不可说不可说诸佛所。持戒修福德来。非是近行之人能生信也。乃至一念能生净信者。此并明二人。久供养诸佛殖因来远。于此深经能生信心。此是闻中仿佛信。非证信也。然此一念信决定不退。无有疑浊。尚得名为净信。况多时也。上如来虽答此二种人曾供诸佛能信此经。然大众犹有疑心言。何故此人供养诸佛乃多。而唯言生一念信。此则太少。尔未知此二人。为决定能信此经。为不能信。故佛答如来悉知见是诸众生。明如来自云我是一切种智人。凡有所说。此了了知终不虚说。汝等应信我语勿生疑也。今言悉知者。以现智知。悉见者。以佛眼见也。知之与见。乃理通三种人。今始明前二人。未明第三人。何故此中已明者。是任放辨才。前后随意明也。然诸佛菩萨得自在陀罗尼故。说则当理。前后随意。超越说法。而文义俱顺。不失次第亦不相违皆。不同凡夫二乘要次第诵设越诵则失也。亦得言但知见前二人不论第三人也。何以得知。义该三人。下论释时解三种人竟。然后方释悉知悉见故。知任放辨才者前后随意也

生如是无量福德聚等者。上虽明二种人具持戒福德二行故能信上二种深经。乃至生一念净信。未知此人以此能信功德。于未来世。为有所得。为无所得也。故答言生如是无量福德聚。取如是无量福德也。此明能信之人未来世更得多福非无所得也。生福德者。明二种菩萨能信之心。近与初地作因。远则毕竟能与无上佛果作其胜因。故云生福德聚也。取无量福德者。明此福德者非但唯能作因而已。复藉此信心。能决定修行。显出法界身。证于佛果无量福德。故云取也

何以故须菩提是诸菩萨无复我相等者。此别明第三有智慧人能信此经也。何以故者。上已别明前二人有持戒修福德能信之行。未别明第三人有能信之德。今疑者问意未知上第三有智慧人复有何义有何行何所解何所证。故名有智慧人能信此经。有如是问故。言何以故也。今欲出第三人能信之行。故答言是诸菩萨无复我相等。明此人以得初地已上我空法空之解自证而信故。名有智慧人能信此经。不同前二人从他闻法依教生信也

是诸菩萨无复我相等者。此四论释云我空。依四种所治我相。说四种能治无我相也。无复我相者。对治我相也。外道凡夫计。谓有一神我。与五阴一。与五阴异。不一。不异。若无我者。何由能府视眴行来进止觉苦觉乐。以此知有我也。以对此计故。言无我相。明众生五阴因缘法中无有定实神我及以我所故。曰无我相也。无众生相者。有外道横计。众生所以不断不绝相续住世者。以有神我众生故也。为对治此计故。言无众生相。明唯有虚假生阴相续生灭。不由有神我不断不灭故。言无众生相也。无人相者。对治人相。有外道横计。所以有一报之命不断绝者。由有神我。故命有长短之限。差品不同。为对治此计故。言无人相。此经云无人相者。下论中名为命相。明此命所以有长短者。以众生业有厚薄故命有修促。不由于我。而菩萨解虚假之命悉皆空寂。不见有神我之命。故云无人相也

无寿者相。对治寿者相也。有外道横计。以有神我故。死此生彼迳由六道受生。若无我者。谁受诸趣之报。对治此计故。云无寿者相。明神我是常何由六道受生。然今所以有生死者。皆由有无神我。而但假名行者。乘善恶等业。迳诸趣受报。若有我者。无受生义。菩萨解众生五阴虚妄不实无有神我寿者。以不见此相故。云无寿者相也。然依世辨论我与众生。有一百种名。不可一一具说。且对四种虚妄我相。辨此四法。以明无我空也

须菩提是诸菩萨无法相等者。此四论释云法空。依四种所治之法相故。说四种能治之法。无法相者对治法相也。何者是法相。凡夫人于十二入中。见有能取可取不同。故计谓实有。对治此心故。言无法相。明十二入能取六识可取六尘悉皆空寂本来不生故。大品经云。无有一法出法性者。乃至涅槃我亦说言如幻如化。亦非无法相者。对治非法相。疑者闻十二入一切法空。便谓真如佛性无为之法亦皆性空故。空同虚空龟毛兔角等无为。对治此疑故。答云亦非无。明相今言一切法空者。有为之法无体相故空。然真如佛性法。万德圆满。体是妙有湛然常住。非是空法直以体无万相故说为空。不同前有为诸法性空之无。又亦不同兔角等无。故言亦非无法相也

无相者。对治于相。疑者闻真如是有体相不空。便谓还同色等有为之有。又云。若有应同色香味触有为之有。若无应同性空兔角等无。此名为相。对此疑故。答云无相。明真如法体妙有妙无。语真妙。虽有不同前色等法有。虽无不同兔角等无。故云无相也。此就理教别义边明。真如证法一向不可以有无名相而说也。此第三何异第一。上第一明有为无为一切法空。此第三唯明真如法体。双绝有无二相以此为异也。亦非无相者。对治无相。何者是无相。疑者闻真证法并绝有无二相。便谓真如证法一向绝于言相。不复可藉诠得闻假教悟理。此名无相。为对此疑故。答亦非无相。明真如证法虽无名相可说。非不寻此名相言教。会于真如无名相理。明由证此真如无为法故。还说无为法。亦非无相。此明就理教一义边。真如非不有相可藉声。闻假教会也。此第四何异第二。上之第二。明真如法体虽空无万相。而体是妙有。今此第四。明真如法体绝字等有有为万相。而由诠悟理。因证有说。如此本末相推理无条然。故得言即真如证法中有名字声教可说。以此为异也。然此我法二空。下偈论中释之也

又何以故须菩提是诸菩萨若取法相则为着我等者。此第二何以故所以来者。闻上法空中第四句言亦非无相。还取证法同于名相。疑云。若此菩萨有智慧人。已得彼我法二空之解。断我法上或者。何故犹起心谓此证法同于名相。复言。我有智慧能观我法二空。我能修行断烦恼。我能教化众生。若尔此菩萨则断灭我相等或不尽。有如此疑。故言何以故也。又能解何以故者作难。或者闻法空中第四句释言。真如虽无名相。非不因此真如证法有于言说。此音声言教还诠证智。复藉此言教。得彼证智。若尔真如证法中便有名相。何以故言真如无名相不同有无也。故答是诸菩萨若取法。则为着我人等也。明初地菩萨虽得我法二空之解。但断初地所断一品粗惑。犹有二地以上四住根本无明住地善法封着微分别心功用烦恼。故言则为着我人等。非谓犹有四住粗惑取证法有名相也。上已云是菩萨无相。复云无法相。此已明菩萨得我法二空之解。此中复言若取法相则为着我人众生寿者。此之二文所以相违也。今者明斯之二文虽似相违。而其理冥顺。云何相顺。前明初地菩萨得我法二空能治之解。言无我相等者。但明初地所断四住粗惑。犹有二地以上修道中善法烦恼无明细闇根本之惑。如十地经中言。我能知法入定能化众生等。犹有微惑未尽。所以知然。下论释云。但有无明使。无现行粗烦恼。以此知也。若取法相者。明此菩萨虽得我法二空之解。故起分别。由我有智慧能解我法二空。此微分别。是我见家根本。从粗为言。故云着我人等。此释前我空也

若有法相者。亦分别言我有智慧故能解二种法空。此释前法空。亦得言先释法空也。然此二所以不定者。明同是善法中取着更无别境。故前后皆无妨也。若依次第。应先释我空后释法空。次第二明法空故。弃释法空。复方释我空也

又此若取法相二句。经中列之在先。不应取法非不取法者。依经列之在后。及下论释在二句之前。何以故。然此第三经文为释。须明三人有生信差别。义便故释在先也。此前二句所以复在悉知悉见后释者。为证成前二人能信之行。然后方释前之二句也

何以故者。此是第三何以故也。疑者闻前法空中第三第四句释。疑云。证法虽无名相。非不可依言辞而说。故言亦非无相。便执言若前证法可以名句诠说。此能诠名句则是证智中有。若尔证法便是有相。那得上言真如证法体无名相。然如来言自不定。我谓为有。如来说无。我适谓无。如来复为我说有。何以故。不为我定说。故言何以故也。为遣此执故。答言不应取法非不取法。此明中道之理不可定说有无。若定说有无。恐堕二边。若堕二边。则着我人众生等相。故不得定说也。不应取法者。明虽藉诠而说。而亦理非名相。不应取声教为证法谓是有相也。非不取法者。闻言不应取法。便证法一向无名相。不可假教而说。若无名相不可假教说者。则复谓音声言教令非是法。弃其能诠之义。为遣此疑故。言非不取法。此明无言之旨非不可寄名相而说藉诠而悟。言教非是一向非法。故言非不取法也。所以不得定说有无者。明此法亦有无义复有有义。而真如法体虽是妙有。而无名无相故。不得定说为有。恐人取同名相有。然此真如虽无名相。而不得定说为无。恐人取同兔角等无也。以是义故者。双释二句。以是不应取声教。即是真如证法无名相理故。以是非不藉言教而会证法。言教名相非是一向非法。不得舍义故。如来常说筏喻法门者。如人乘船亦舍亦取。下论委释。故不具辨也。是法应舍者。此合前筏喻也。又余经或云。法尚应舍何况非法。依小乘经。言法尚应舍者。明小乘罗汉入无余涅槃时。八正道十智三三昧等无漏善法。尚尚应舍。何况十恶等非法而不舍也。又楞伽经中。法尚应舍何况非法者。色等诸法是有犹尚应舍。何况龟毛兔角名字等法虚妄无实而不舍也。又余经亦同。此经云是法应舍非舍法故。是法应舍者。明虽寻诠会旨。得理法须亡诠故应舍教。成上不应取法也。非舍法者。明始行发菩提心乃至成佛。莫不皆因教悟理藉诠会旨。须此言教不得全舍。故言非舍法故。成上非不取法也

论曰此义云何者。论主问斯一段经来意云何也。向依以下。说因深果深者。将序生疑之意。牒前第四第五段经。出生疑之处。若尔以下至非舍法故。正作疑答法用。如经初次第生起中解释可知也。此义云何者。向未难牒前经设疑。即通举此一段经。答疑问之意。犹未广释。论主今欲设偈广解。故问此经。答疑问之意云何也。此一段经。凡以八行偈释。初一偈释经中。须菩提问如来答。明未来恶世时有三种人。具三种德故能信此经。第二偈别释前二人殖因来久故有能信之德。第三偈欲释第三智慧人有能信之德。故复总举我法二空能治所治。为下别释作论本。第四偈正释四种我空。第五偈正释四种法空。第六偈为答。但应明第三人。不须明前二人疑难。故复总举来释。明前三人能信有差别俱足信人。故须明三人也。第七偈释悉知悉见。第八偈释筏喻也。初一偈。上一句释须菩提问。后三句释如来答。须菩提未来世有菩萨信乃至以此为实也。说因果深义者。释前一经中闻说如是修多罗。双举第四第五因果经文来作问也。疑问意云何如来所说因果无相二种深义。于后末世人不能生信。云何如来常自道言。我是一切智人。善知众生机根。称机说法。说必有益。终不虚也。故偈答言。于彼恶世时不空以有实。正释经中佛答须菩提未来世有菩萨摩诃萨。明虽复恶世信者难得。有人能信。非为空说。何者是能信之人。下句指云菩萨三德备。此句正释经中有持戒修福德智慧者。此总出三种人能信之德。故知不空说也

第二偈别释前二种人能信之德。从佛告须菩提非于一佛二佛乃至能生一念净信也。修戒于过去及种诸善根者。此二句指出持戒修福德二种人。明此人曾供诸佛。闻大乘经。生信不谤。能发菩提心。如说修行。名为持戒。广以内外珍财。奉施诸佛及一切众生。修波罗蜜行。名种诸善根。正释经中非于一佛二佛三四五佛所修行供养而种善根也。问若此人已供养诸佛。为当供养几许佛来。故以下半偈答云。或具于诸佛亦说功德满。正释经中已于无量百千万诸佛所修行供养而种善根。明此二人非但于一二三四五佛所修行种善根。乃于无量佛所修行供养久积胜因。方能于此经中生净信也。此下半偈。重明上二人。所以复来。以经中有两重故。论主学经再举也。如经已下讫种诸善根。此是论主以偈释经已竟通举两段经结偈。此经文以下至功德具足故者。论主以经中解不能广释。故略申经偈所明之义也

第三偈以下有三偈。释经中第三有智慧人。依经中次第应释悉知悉见等经文。但此知见等义通前后随意。此乃依任放辨才故。经文先列。论中后释也。后寿者。乃举我相中四种。所以单言寿者。此中虽并明四计。莫不同计于我。且举一名。余三可知。及法者此举法相中四种。亦且举法相中一名也。应言法相。但以五言偈侠。直言及法也。此一句。总举八种所治法也。远离于取相者。正释经是诸菩萨无我相乃至亦非无相我空法空二段经文。明得此八种胜解能治前八种取相之惑故。言远离于取相也。亦说知彼相者。明所以牒我法二空能治所治法来者将欲更广释第三有智慧人义故。言亦说知彼智慧人义不断相也。复非但智慧人不断相。亦说知前二人不断相也。依八义别者。依八种所治。有八种能治之义。此一偈与下我空法空二偈为本。不别释经文也。此义云何也者。闻此一偈义意云何也。故答复说般若义不断故。此文先解第三句。然后复设问云。说何等义。问此说般若义不断者义云何。后方举上二句能治所治。略释能治所治之义也。虽略释能治所治。犹未列其数。故提偈第四句。结出其数也。此复云何以下能治所治迭互相属对也

此义复云何者。论主生下第四偈故设此问。前偈虽总解四种寿者相。还总解四种义。今一一别释者。义意复云何。故答差别相续体。此一偈释前经中无复我相等四句也。差别者明我相也。相续者众生相也。不断至命住者。人相也。复趣于异道者。寿者相也。是我相四种者。四种我相也。此一偈唯举所治四法也。此义云何以下。初列我中四种名。次解四种计我义。然后举经中四种能治无我解来。对四种计心

云何及法者。前偈以释寿者等四句。今次释法中句。故重举前论本偈上句下两字来作问。生起后偈故。言云何及法。故即以偈答。此第五偈释经中无法相等四句也。一切空无相者。正释经中是诸菩萨无法相。明外人计众生五阴法十二入六尘可取能取一切法是实有。此名法相。对治此计故。言一切空也。空者。此十二入有为诸法本来不生无体相故空。无为之法佛性涅槃无万相故空也。应问何故空即答以无物故。无物者。空无色等物也。实有者。正释经中亦非无法相。闻言有为无为一切法空。疑者谓涅槃佛性无为之法亦同有为无体之空。此名非法相。对治此计故。答言实有。明佛性涅槃体是妙有。以无万相故空。勿得闻诸法空便谓涅槃佛性同于有为之法虚妄分别无体故空。故言实有也。不可说者。正释经中无相。闻言万法皆空。疑者便谓真如无为法。同有为诸法无性之空。亦同龟毛兔角之无故。答言实有。既闻真如实有。疑者计谓真如同色香味触有为之有。闻无谓真如同色兔角等无。此二种计名之为相。对治此计故。答言不可说。此言不可说者。明真如法体妙有妙无而不同世谛色香之有性空等无。双遣有无二种计情故。言不可说也

依言辞而说者。正释经中亦非无相。闻言不可说。疑者便谓真如一向不可说。若尔真如令不可说者。云何依经教发心。凭诠修行。而得佛果也。此名为非相。对治此计故。答依言辞而说。明真如虽体绝言相。非不假于声教而得此理故。言依言辞而说也

是法相四种者。举所治四种相。结前三句中能治四种无法相也。而此一偈通举能治所治法也。何者是四种等者。上偈第四句中。虽云是法相四种。犹未出其名。今列出四名也。此义云何者。前偈中上三句并长行四种名列所治。而问此能治所治其义意云何也。有能取可取至以无物故。此解初对法相无法相能治所治也。彼法无我空实有故。言亦非无法相。此解第二对非法相。亦非无法相能治所治也。然云彼法者。彼真如证法也。无我空者。明彼真如法体非但空于我法。亦复空于无我无法也。实有者。恐或者闻言真如证法双绝有无名无我空。便谓证法一向空寂。故云实有非无体空也。彼空无物而此不可说有无故言无相者。此解第三对相无相能治所治也。依言辞而说至依言相说。此解第四对非相。亦非无相能治所治也。依八种差别义离八种相者。此既别释义我法二空竟。并举能治所治。双结二空也

是故说有智慧者。上问第三人复有何德行故能信此经。今既明此人能解我空法空。经论中具释意。所以举智慧来。通结其能信之德也。如经无法相等。别结法空中四也。有智慧便足者。难云若此第三人具二空之解能现信者。此人则为最胜。若然但说有智慧人则足。何须复明持戒修福德二种人也。答云为生实相差别义故。将欲便论主释其示现生实相差别所以故。问云何示现。然即偈答彼人依信心恭敬生实相。所以复明此一偈者。前长行论云。有智慧人证二空之解决定能信此经。不随他教。若尔此第三人则为最胜。唯应明此有智慧人。何须复说持戒功德二种人也。故设此偈。明信有多种义通三人。非唯有智慧者。由他前二人以持戒修福德仰信为因故。能得地上我法二空无漏智慧故。须明前二人。不得单明智慧人也。是故下长行论云不但说般若也。彼人依信心者。释持戒修福德二种人。是地前菩萨未能现见现原。从佛闻法凭信生解故。言依信心也。恭敬生实相者。明此二人恭敬如来。随慎佛语。能信此经。以之为实相也。故复超举前经来也

闻说如是修多罗能生净信者。结成须明前二种人。非唯独明智慧足也。闻声不止取者。此下半偈复明第三有智慧人依如前疑。正应但明上二种人有差别信。何故复举有智慧者。有二意。一为以智慧者是证信之人。上二人是其闻信。二为乘释经中不应取法非不取法故来也。闻声不正取者。明有智慧人得二空解故闻音声言教不取。即同所诠证义无名相理故。下论释云。又智慧者不如声取义也。正说如是取者。虽不取声教同于证义。然所诠之理非不藉声教而得。非是一向非法故。下论云随顺第一义智正说如是取也。言说家果所谓义也。因能随果。故云随慎也。此义云何者。此一偈所明之义云何也。而下释分为二。彼人有持戒功德。乃至不但说般若。释上半偈。明上二人恭敬如来。凭圣经教。能生净信。虽不同第三证而生信。亦能于经生决定解。故超举上净信经来结也。又有智慧以下释下半偈。明第三智慧人。不如声取证。现中生信。胜于前二。复越释下第三何以故不应取法等也。故次言须菩提不应取法者。如前下半偈所释也。如经次第。此经文次应在若取法相有法相则为着我众生等后。今所以在此释者。为欲证有智慧人能不如声取义以便。故越释之。是故论云次言者。义中次第。非经中次也

又经复言须菩提如来悉知悉见者。上来诸偈。皆先作偈释。举经结之。此中何故先列经于前。后方作偈论而释以上超释后两段经。此犹未解。所以先举也。然此论主解义多途或先举后释。或先释后结。而此依阐陀论法也。此所以超释后二经文今方在此释。悉知悉见者。前明三种信人势相属着。以此知见是任放辨才义通三人。列三人讫。明知见义显故方释之。此明何义者。论主欲释如来悉知悉见是诸众生义故。问此悉知悉见明何等义。即以偈答云。佛非见果知。此一偈。正释经中如来悉知悉见是诸众生。佛非见果知者。明如来以现智了了知此人决定能信名为持戒。非见有威仪相貌者。谓为能信。名持戒人。如此假相知者此为藉相。比知今明佛非以此相恳解故。云佛非见果知也。应问若非比智知者云何知。答曰愿智力现见。愿智者。如来百四十不共法中愿智力。亦云自在力也。非同小乘发愿后方有智也。求供养恭敬彼人不能说者。上半偈明引佛为证成前二种能信人也。此下半偈出破戒不信之。实不持戒为利养故。诈言持戒者。彼人不能自说我是持戒有功德能信之人。以如来力加也

此义云何以下。一段长行论。凡有二意。从初至不能自说已前。释上一偈。又是诸菩萨以下。释偈外两处经也。就初释偈中。复有二意。从持戒等至以有二语。释上半偈彼持戒等人至愿智力现见故释。前半偈中知见之义。如来悉知便足以下至次有二语故。论主设不须并明知见二法之难。即答须并明知见二法之义也。何故如是说者。论主设问何故作此不须知见之问答须知见之说故。云何故如是说也。即答以有二语故。明知有现智知有比智知有佛眼见肉眼等见以有此二语不同故。设此问答。欲使人识如来云知见者是现智知佛眼见非比智知肉眼见也

又何故如来如是说以下。明知见中第二意释下半偈。又何故如来如是说者。论主设问云。如来唯知二人有信。明于知之与见为当更余意也。故即引下半偈答。明如来不但知见此二人有能信之德。若有人实不信此经。实不持戒。为求供养恭敬。诈言持戒有信者。如来亦知见故。明下以论释求供养等半偈也。是诸菩萨生无量福德聚取无量福德者。生者此明前二人能信之福决定能作菩提因故云能生因也。取者论释云勋修自体果义者明此一念信心非但能与佛果作决定因义。由此一念信心为因。复能修行断惑显出法身无上佛果也。明此前二人决定能修行取佛果也

又何以故须菩提若取法相为着我等者。此一段经。在我法二空经文之后。所以解在于此余经文。其经在下。而在前释者。明余经共成有智慧人我法二空之解。义势相属。引之前释此经文。乃明二地已上修道中所断之惑。在下义便故遗之于此也。但有无明使者。此是功用之惑。善法烦恼。释经中若取法相则为着我等二句经也。无现行粗烦恼者。无三界四住我见等粗惑故。言无现行粗烦恼。以示无我我见。四住烦恼以我者为本。六十二见亦因而有。谈其无本足知亦无余惑也。彼不住随顺一偈。释经中筏喻。成上不应取法非不取法。此经论俱次先举后释。彼者。彼于十二部经。言教法也。不住者。彼经教法不住无名相证法中。正释经中是法应舍。明所诠之理绝于名相言教法故也。即有难云。所诠证理绝于言教名相者。能诠之教便一向非为法也。偈即答云。随顺虽能诠之教。非即是所证法。非不因于能诠得证法故。言随顺也。此二字释经中非舍法故由教得理不全舍也。于法中证智者。释上句彼不住也。直言不住。未知于何处不住。故出于所证智中音声言教法不住也。如人舍船筏。释经中筏喻也。法中义亦者。合喻也。此应云如人取船筏法中义亦然。所以偏云舍者。以偈狭故也

此义云何以下至以得证智舍法故。释偈上句中彼不住。第二句于法中证智。明能诠教法非证法故不取教法为证。即引筏喻来怗成也。随慎者以下。释偈初句中随慎二字。明言教虽非即所证法。非不随慎于法故。取言教为法。不得全舍。所以复引取筏喻怗结也。自此以下等。论主生下我空法空第二段经文。从初至非有为相得名。将出生异疑之处故。牒前第五段经来也。若如是以下。作生疑法。用正出疑体也。广释如经中生起无异也

佛告须菩提。于意云何。如来得三菩提也者。此经犹属我空法空段。成上有能信人也。以何次第起。上第五段中言。不可以相成就见如来者。明不可以三相所成丈六应见法佛如来。以法身如来无生住灭非有为相故。有人乘此。更生疑。若释迦如来。从王宫生。六年苦行。修道成佛。四十五年住世说法。后入涅槃。有此三相非是佛者。今此三相所成丈六如来。为当是佛。为一向非佛。若是佛者。不应言不可以相成就见如来。若非是佛。不应言我发菩提心修苦行道场成佛转法轮。此释迦如来为实发菩提心修苦行道场成佛有所证有所说。为不发菩提心不修苦行不成道无所证无所说也。有如此疑。故次答意。明释迦如来非法身佛。非不是应化佛。化佛以众生感见故有。无实众生体。亦无四大。无心意识。不从修成故。非是实佛。既非实佛。然不发菩提心修苦行道场成佛实有所证。既无实证亦不说法。为断此前疑。故次明此段经也。前第五段中已别相法身佛。今此经中亦别相中明应佛也。须菩提于意云何者。明须菩提怀疑在心即应有问。如来亦应有答。以此经文略义隐多不作问答故。直问须菩提于意云何也。欲使须菩提禀如来冥加力故自答此义也。须菩提解佛意故即答。世尊无有定法如来得三菩提也。明应佛以众生感见故有。道理而言。无有定法。应化如来。有实行者发心修行断烦恼证于菩提故。云无定法如来得三菩提。非谓一向无菩提可证亦无实修行证菩提人也。亦无定法如来可说者。凡以有证故有说。无证故无说。然应佛既不证果亦不因证而说也。何以故者。有人闻言应佛如来不修道证果。复不说法。更生疑谤。谓一向无菩提。亦无菩萨修道证果作佛。亦令不说法。若无佛无法者。何以故释迦如来云。我三阿僧祇修行满足。证大菩提。转法轮。便有证有说。云何而言。如来不得三菩提。亦不说法也。又若一向无佛无法者。云何诸菩萨发菩提心。修诸苦行。求于佛果。有如此疑问。故言何以故也。即答云。如来所说法答意明如来实有证说。但上言不证说者。此明应化佛不证不说。今言如来所说法者。明释佛如来非不有实行者发心修行断惑证果有所说法也。那得以应佛不实证说。便谓报佛亦一向不证不说也。若报佛说法者。法佛为说法以不。此中应有是疑。而此中不答。下断疑分中当释法佛有说不说。或者闻言。实有证说。者乘更生疑。若报佛如来实有证说者。则所证之法体。是名相可取说。云何上言真如证法体无名相。言语道断。心行处灭。不可取说也。故经答皆不可取不可说也。此答意言。报佛说法者。依世谛名相。道中。得言有行者修行证果为人说法。若据真如理中。泯然一相无有修得。亦无证说也。不可取不可说者。明真如证法体非名相。不为耳识所得故。言不可取。非音声性。难以言辨。故言不可说也。非法者。明上证法体非名相不可取说故。声教非证法。成上不可取不可说也。非非法者。若前证智法。非音声性故。不可取说者。则能诠经教条然离于所诠之理亦尔。经教则一向非法。为释此疑。故言非非法也。明能诠经教虽非即证法。非不由教得理故。不得云全一向非法亦是法。成上来所说法也。何以故。一切圣人皆以无为法得名者。何故明此上言非非法者。明能诠之教虽非证法。要因证能说。藉教得证。明知言教是法。非是一向非法。故引此一切圣人。以释成此义。何以故者。此言教何故是法非是非法。以是初地以上一切圣人证真如无为法。还说无为法故。知是法非是非法也。皆以无为法得名者。谓真如法名无为也。明初地菩萨并观三种二谛就现得二空故断除五住习气无明。离心意识。名为见道。乃至十地皆分有对治除断。此明由见真如正理能断烦恼。故曰圣人无为法得名也

论曰。以是义故者。论主未尝有释。何得直云以是义故。此即指前经文。如来设问。须菩提仰答。如来无有定法。如来有得有说。如前经中。二圣问答相解。我亦如是。解此经意。更不别释。即指经为解故。云以是义故。释迦牟尼佛非佛亦非说法者也。此义云何者。此一段经一行论释义意云何也。故即偈答云。应化非真佛。此一偈。释前一段经。应化非真佛者。正释经中无有定法如来得三菩提也。明释迦如来从感故有八相成道。言佛者。是应化佛。非真佛者。非是法报二种真佛也。亦非说法者。此释经中无有定法如来可说也。上云应佛不证菩提。此句云应佛既不证菩提亦不说也。说法不二取者。说法二字释经中

何以故如来所说法。明报佛如来实证菩提实说法也。不二取者。释经中皆不可取不可说也。云何不二取。听者不取所说言教以为证法。亦不取言教以为一向非法。而说者亦不取声教以为证法。不取声教以为一向非法。故云不二取也。无说离言相者。释经中非法非非法。还释成上不二取。非法者。云名相言教非真如证法也。明此证法从本际来自性清净体绝名相故。不应以所诠证法。同于声教。故云无说离言相。此还成上非非法。明言教是法非是非法。若证法无名相言教非是法者。便应一向绝于言说。不复可假教而说寻诠可会。有如此难故。正应答言不离言相。但以偈侠。直云离言相。明要假言证得于无言也。此义云何乃至亦非说法者故。通释偈中上二句。于中有二意。从初至无有定法如来可说。此出二句所明义意虽。并举三佛来。意欲但取应佛。明释迦如来既是应佛。故不实证三菩提。亦不说法。即举经结之也。若尔以下至亦非说法者故。闻上释言如来不得菩提。亦不说法。论主便执经中如来所说法等。假兴难意。即引疑者之难。以答其难。明遮人谤。故云报佛有证说非论应佛有证说也。复引偈来结。明应佛无实说也。说法不二取无说离言相者。乃至无我相实有故。此提偈中下二句。次第释之。听者说者皆不二取。释偈中第三句也。何以故者。将释偈中第四句故。问何以故。上听说二人于所说法中。皆不二取也。即释言彼法非法非非法。然此依次第。应释无说离言相。但此句本为释经中非非法。故引此经文。释于何以故闻即当解偈也

依何义说者。问此所说法言非非法者。依何义说也。即答依真如义说。言依真如义说者。明如来证真如法还为众生说彼真如法。而此佛教非法非非法也。非法者。一切法无体相故者。一切法谓十二部经声教法也。无体相者。此言教法中无所证智体相也。非非法者。彼真如无我相实有故者。明此真如法体虽双绝有无名为无我。而体备万德妙有湛然。故名为实有。而如来依此法故。有于言说。此言说还诠真如法故。言教是法故。云非非法也。自此已前。释偈已竟。从此以下。将释偈所不摄经故。先问上经中云。若依真如有说者。何故唯言如来所说法。不言如来所证法也。即答云。有言说者。即成证义等。明若不证者不能说故。明知今道如来所说法者。已知有证也。如经以下。即提所未释经来结成。结成竟然后次第释此经文也。此句明何义者。问此一句经明何等义得结成上有言说者已知证义也。即答彼法是说因故。明圣人由证真如故方有言说。故引此经证成上有说则有证也。何以故者。彼真如无为法。何以故得作言说家因。即云一切圣人依真如清净得名。明初地以上圣人皆证真如无为法故断除二障得圣人之名。即结云以无为法得名故也。以此义故者。以此圣人无为法得名义故。彼圣人还说无为。法是故得成证法。是言说因也。复以何义者。作难云。若圣人证无为法。还说无为法者。是则真如证法。有于名相。便应可取可说。复以何义故。云何真如证法无名无相不可取说也。即答云。彼圣人所证法。不可如是说。何况如是取。明彼证法体非声性故。尚不可以言说。何况以耳识往取。故云不可如是说。何况如是取也

故即释言。何以故。彼法远离言语相。非可说事故。明虽彼圣人证无为法。还说无为法。而此无为法离言语故。不可取说也。何故不但言佛。乃说一切圣人者。论主假设难云。若一切圣人以无为法得名者。唯佛一人会无为理尽。可以无为法得名。初地以上圣人见理未穷。不应以无为法得名。何故乃说一切圣人皆以无为法得名也。即答以一切圣人依真如清净得名故。明初地以上圣人皆现见真如处同。故得名为圣。是故不唯言佛也

乘即难云。若初地以上一切圣人皆现会真如。名为圣者。佛与菩萨。有何异也。故答如是具足清净如分清净。明如来万德圆满见真如理穷二障永尽。故名佛为圣人。具足清净也

初地以上十地以还。虽复见胜理未圆。断惑不尽。非不如分如力见理除惑。胜分解成故。名菩萨为圣人。如分清净也。若然佛与菩萨。便优劣不同。那得难言若初地以上一切圣人皆以无为法得名者佛与菩萨有何异也

金刚仙论卷第三竟金刚仙论卷第四

须菩提于意云何若满三千七宝布施以下。此中有九段经文。名为第七具足功德挍量分。云何名挍量分者。明以三千七宝布施得福虽多。取相心施是有漏因。但招三界人天有为果报。不如受持此经一四句偈乃与无上佛果具足功德作无漏胜因。如此比挍优劣上下胜如不同故。名具足功德挍量分也。有何次第起者。此有疑故也。此疑从何处生。从前第六段中如来所说法皆不可取说中生。第二疑云何生若所证法非是名相。不可取说。所说经教是名相可取可说者。则证说二法名相无名相条然有异。若尔寻此言教不能得证。若不能得证者。受持读诵此所说经教。应无福德。若无福德者。则因义不成。若因义不成。则为空说无有利益。若无利益。则无修道得果云。何余经中言如来不空说法也。若然受持此能诠言教。为有福德。为无福德有此疑也。故引三千世界等经文答之答。意云受持此经一四句偈所得功德胜前七宝施福。所以然者。明此一偈经教虽证法中无。而由得证故。方能说法故。此言教乃证中一分。要寻此言教。解无为法身。发闻思修慧等。然后得证。明知一偈经教能与佛果证法作因。胜七宝施福故。次明此挍量分也

三千大千世界者。百亿须弥。百亿四天下。百亿日月。上至有顶。下至风轮。名此为三千大千世界也。满中七宝持用布施得福多不者。如来将欲以受持经教一四句偈挍量胜如故。先引七宝施福。以问须菩提得福多不也。甚多婆伽婆甚多修伽陀者。今须菩提将明施者用宝既多得福亦多。敬答于佛。故仰并如来二号也。婆伽婆者。西国正音。义翻云一切种智人。修伽陀者。汉翻善逝。略举二德。答佛施福多也。何以故者问如来何以故。明此三千七宝布施得福甚多譬喻。故云何以故也。即答是福德聚即非福德聚。上言七宝布施得福甚多。今复云是福德聚即非福德聚。此二言何故前后相违。似须菩提失冥加力。谓此福甚多而似答不契。今须菩提申已不失冥加之力。又亦非说多不当理。我得冥加力故。玄知下如来以七宝施福虽多。是有漏福德不能远趣佛果。故挍量不及持经四句偈得出世无为法身无漏福多故。此采取下挍量之意也。是福德聚者。是七宝布施福德聚也。非福德聚者。明此福虽多是取相因。但感人天有漏果报。非是得出世间无漏福德聚也。是故如来说福德聚福德聚者。前既明七宝布施非福德聚者。恐人谓今无福名非福德。以如此义故。引如来说有二种福德聚。一是有漏福德聚。二是无漏福德聚。有漏若非福德者。但应有一。不应说二是故当知有世间福。但非出世福耳。故知不得闻非福德谓全无漏也。从佛言以下至七宝布施。将欲挍量。故还牒上譬喻来也。若复有人于此经中至不可数者。明有人受持此经四句偈福能得无为法身无量福德。胜前七宝施福不可算数也。此言一四句偈者。莫问偈及长行。但使表法身理足者。以为一四句偈。不取说因缘事等经文为一四句偈也

何以故须菩提一切诸佛菩提皆从此经出。诸佛如来皆从此经生者。此释前挍量中疑。何以故者。有人疑云。何故七宝布施是其了因。其功甚多。得福乃少受持一偈。亦是了因其功甚少。得福乃多。故云何以故也。答意明前布施是取相之福。唯获三界报不能得三种佛菩提。受持此经。获不取相福。能得三种佛菩提。是故受持一偈之福。胜七宝施福。所以然者。以此一偈经教用功虽少得福乃多。能出生佛果故。受持此经生闻乃至能得十地证智。终与法身作其了因。与报应二佛。以为生因。故所以胜也。此言阿耨菩提者。即无为法身无上正遍知正道也。明此法身古今一定湛然常住。体非作法。受持此经教。但能作其了因。不能作生因。故言皆从此经出。一切诸佛如来皆从此经生者。有受持此经言教。能与报佛如来。以为生因。以此报佛要因受持此经。发菩提心。始从习种终于解行。修世间功德智慧。迳一大阿僧祇。行道证初地。名为见道。迳三阿僧祇。十地行满金刚心谢。即本有之性显时。有二种庄严。用此詶往因。故名为报因。受持经教依而修行。报得佛果。用义说了为生。故言从此经生。非如世间法辨体为生也。若报佛为生因。所生为当是有为。为是无为。若是有为。则应无常故。下经引须弥山王喻释也。若应佛藉经教。从生因生者。应是实佛。若是实佛。何故上经云。无有定法应佛如来得三菩提也。若定非实佛。供养此佛。为有福德。为无福德。此疑下微尘喻经未当释也。既有报佛。必有应佛影像之用。故应佛亦言从此经生也。既闻法佛从此经出报应二佛从此经生。有人乘即生疑云。七宝施福用功乃多。得福亦应是多。受持一偈经教。用功甚少。得福亦应是少。而所以言受持此经一四句偈出生三种佛菩提。胜七宝施福。若然此三种佛菩提。为决定从此经出。从此经生。胜七宝施福。为不决定。有此疑念也。又云。此三种佛甚深法界若从此经出。从此经生。体是有者。我等应见应知。然此我今不知不见故。当知是无。若尔云何道法佛从此经出报应二佛从此经生也。知如来说此三佛其义甚深。乃云从一偈言教经生。为有人能信。为无人能信。此谓为疑也。故佛答须菩提所谓佛法佛法者即非佛法。明诸佛如来证三种佛菩提法故。说此经教。还诠彼三种佛菩提。是故若受持此经。即是受持三佛菩提故。得为因此三佛果头甚深法界。虽从此一偈经出生。而正可是佛家所得法。非凡夫二乘下人境界故。不知不解。而生疑云。此三种佛。为决定从此经出生。为不决定。如此劝信也。而此经所以重言佛法佛法者。牒前经法佛从此经出报佛应佛从此经生也。故云佛法佛法也。有言佛法佛法者。明此三种佛菩提法唯是佛家法。故重云佛法佛法也。即非佛法者。明即此佛所得法非余凡夫二乘所得。以彼二乘非佛法。故即云非佛法也。然此佛法非二乘境界。是故不见不得也。亦可福德多少之义。唯佛境界。非余人境界也。亦应言是名佛法。明唯是如来果头佛法。故但应生信。勿复疑也

论曰。此胜福德譬喻示现何义者。论主将欲以偈释此经故。先问于与喻挍量之意示现何义也。即答法虽不可取不可说。而不空故。疑者谓若法不可取说者。受持此经教。应无福德。今论主申此经来。意为欲释疑。明持经有福挍量胜七宝施福非为空也

此一段经凡二偈论释。初偈作问答意释经中三千世界七宝乃至无量不可数等挍量经文。第二偈释何以故须菩提一切诸佛皆从此经出乃至即非佛法也

受持法者。释经中受持一四句偈也。及说者。释经中为他人说也。不空于福德者。释经中其福胜彼无量不可数也。此偈上之二句经文在下。所以论主释之在先。此偈后之二句经文在上。所以释在后也。论主相上疑意以此受持法及说二句经虽在后。义乃在前。故引之初释。下二句经虽在先。义势在后。故列在后解也。虽言相上疑意。其义云何也。上云证法不同名相不可取不可说。惑者便谓。受持经教。空无利益。故以喻挍量。明持经有福不空。以义势在前。故先释也

福不趣菩提者。释经中三千七宝布施。初福德聚。明此有漏福德聚体是取相。故不能趣菩提也。二能趣菩提者。明受持经教及为人说是不取相福能趣佛菩提也

何故说言世尊是福德聚等者。将欲释此一偈。先举下半偈所释经来也。偈言以下。提下半偈来。与经相属当。此义云何以下。然后设问。通释此经偈也。然偈中上二句犹故未释。何故超提下半偈来。属当所释经者。但上二句为释挍量之意。以此意在前。故先作偈上二句。释下挍量经文。令长行论中欲从经初次第释之故。所以先提世尊是福德聚等经。超用下半偈。属当释之也。何者为二者。将欲释上半偈故。问第四句二能趣菩提者。为二也。即出其二云一者受持。二者演说。此就自他内外。为二。即举所释经来结也。何故名福德聚者。问此七宝施福。及持经福。何故皆名为聚也。即答聚义有二种。一者积聚义者。通解七宝施福持经之福等皆有积聚义。故俱得名为聚也。二者进趣义者。明此二种福德虽有聚义。而有进趣不进趣异。七宝施福。唯有聚义。而不能进趣。明提经之福有积聚义。复有进趣义也。如人担重说名为聚者。此遍喻持经之福。是聚而有进趣义也。如是彼福德聚等者。此解聚而不进趣者。明七宝施福得人天因果有积聚之义。故名为聚。但不能感得菩提故。名为非福德聚也。此二能趣大菩提者。此解受持演说能远得菩提。是聚而有进趣义也。是故于彼福德聚中此福为胜者。论主以偈及长行。释此经竟。结受持经福胜七宝布施福也。云何此二能得大菩提者。论主将欲作第二偈释于下经故。拘锁问上偈中二能趣菩提。此受持演说一偈经教于菩提。有何因义也。如经以下。即引经答有因义也。虽举此经于菩提有其因义。而未释作因义之所以。故复牒云何说诸佛菩提等经为问。以偈解释也

于实名了因者。此第二偈释经中一切诸佛阿耨菩提皆从此经出。明受持此经与法佛为了因非作生因也。故但言于实名了因也。实者。明无为法身古今湛然体绝有为虚伪颠倒。故曰为实也。亦为余生因者。释经中诸佛如来皆从此经生。明此经不但能与法化为了因。亦与报应二佛以为生因。明报佛为万行所克酬于往因。用义如起。竖此用义。得说了为生故。言亦为余生因。所以复与应佛为生因者。明应从真有。理条然故。亦得言生也

唯独诸佛法佛法者。释经中佛法者即非佛法也。唯独诸佛法者。唯是诸佛所得。非余凡夫二乘所能得也。第四句福成第一体者。结句明福者受持经福也。第一体者。成前生了二因所得法报及应三种无上佛果第一体故。非凡夫二乘所得法也。受持此经。能得三种佛菩提。则有福德。便为因义。成不空说法。那得道言。若不可取说。则为空说无益也。此义云何以下长行论作二意来。释向所引一段经。从初至皆从此经生故。释上半偈。解经中从此经出从此经生等也。菩提者。名无为法身。彼体宝无为者。释偈上句中于实二字。将欲解受持演说于法身为了因故。先明法身体非作法名无为也。是故于彼法身。此二能作了因也。不作生因者。明受持经福不能辨法身体。不作生因。但能显出法身故。作了因也。余者受报相好佛应化佛等假受持演说此经故。辨得二佛之用故。结于此为生因也。以能作菩提因。是故名因者。通解作生了因义也。显彼福德中此福胜者。解竟结其胜义也。如经以下举所释经来结也

云何成此义以下。此是论中第二意释偈中下二句。复解经中佛法佛法等也。云何成此义者。还提上经中疑问之意。问云何受持此一偈经教。能为三佛生了因义。我能生信。故言云何成此义也。故即提偈答。唯独诸佛法福成第一体。明三种佛菩提。从此一偈经出生作二因之义。是佛境界。非汝所知故。但应生信也。须菩提所谓佛法者等至第一不共义。复举下半偈所释经来。略解其经中义。提偈来结也。以能作第一法因者。以此持经之福与三种佛菩提第一法作因也。是故彼福中此福为胜者。论主以偈及长行。论释此一段经竟。通结持经有福胜七宝施福。故不空说也

须菩提。于意云何。须陀洹能作是念。我得果不者等此挍量分中第二段经文。所以来者。此有疑故也。此疑亦从第六段如来所说法不可取不可说圣人无为法得名中生第三疑。云何生疑。若一切圣人无为法得名是法不可取说者。须陀洹等亦是圣人。为是无为法得名。为当有为法得名。若有为法得名。则不应言离分段生死。若无为得名。此无为为可取可说。为不可取不可说。若不可取不可说。与上诸佛菩萨所得无为。为一为异。无为若异者。不应名圣。无为若一。应无有异。又须陀洹等证四沙门果。云何言不可取。复向人说。我得沙门果。云何言不可说。若尔证法便应是可取可说。云何言证法不可取说。有如此疑故。答意明此四沙门果亦是不可取不可说。故经言实无有法名须陀洹。乃至实无法名罗汉等。此四人当证果时。不见有一法可证为果。名须陀洹乃至罗汉故。此四沙门果亦不可取说也。此所以言实无有法名须陀洹等者。为答有可取说疑故偏论之。若泛解此四沙门果亦得言可取说。亦得言不可取说。亦得言有为。亦得言无为。四沙门果无漏智慧。体是无常不免生灭。是其有为。故亦得云有为也。以解生阴无定性。能断三结烦恼。无处无为之果。不受三涂报。乃至罗汉。断四住惑。不受三界报。此是无为乐故。亦得言无为。此二乘之人无我正理及灭结无为。故名为圣。未得因缘真如二种法空。未能尽无明变易生死究竟无为。故不如佛菩萨也。既所证有深浅不同。则条然有别。何得无为名同。便以二乘临佛菩萨也。此以圣无为名一故。须此经料简便异也。此四沙门果。言可取者。取无为果也。可说者。如已所证。依虚妄名字。向余人说也。言不可取者。证四沙门果时。得无我空解故。于众生五阴法中。无有一法名为须陀洹等。又复不取者。不取色等六尘境界也。不可说者。明所证法但可以心知。非可以言及。故言不可说也。四果人。但缘生空证果。尚不可取说。况诸佛菩萨。乃以真如清净得名。而可取说也。为除此疑。次来也。于意云何。须陀洹能作是念。我得须陀洹果不者。如来问须菩提。于汝意云何。须陀洹等。既得无我之解。断身见戒取疑。证圣果时。犹能作念分别。我能得须陀洹果不。故须菩提答言不也。即释云何以故不也。以实无有法名须陀洹。明须陀洹等于证果时得无我之解。于假名众生及五阴法。泯然一空无所分别。乃至六尘亦空。于此众生五阴内法中。不见一法定实可名须陀洹等。于六尘境界中。亦不见一法是可取故。不作是念我得须陀洹等果也。从须陀洹乃至无有一法名为罗汉。通举四果。明不可取说。以释前疑。类义可知也。因问阿罗汉不作是念言我得罗汉。生于疑难。若罗汉证果时。不生念言。我得果者。何故罗汉犹作云我得罗汉也。故答世尊若罗汉作是念。我得罗汉。则为着我人等也。答意明前言我不作念得罗汉者。谓证罗汉果时。断四住惑尽。故不作念。我能得果。此阿罗汉犹有习气无明之惑未断故。后更作念言。我能得果。非谓有四住我人寿者。等我见也。然依此经但偏论罗汉所未除习。或不论前三果所未断或。依下论释。则通辨前三人。明前二人始断我常二到未断二到故。有行烦恼。后之二人。乐净亦除故无行烦恼。唯有无明习气也

世尊我得无诤三昧等第一等者。如来常说恶事发露善法覆藏。此中须菩提何故自云。佛说我得无诤三昧第一也。然须菩提将欲引已所得。不作是念。我得无诤三昧离欲阿罗汉证。成第四果。不取之义有同不同。明其余罗汉言我不作念者。无四住粗。或犹未断习我。今须菩提言不作念者。习我亦无。以善伏故非为永断。所以道此。欲使人生信。如须菩提实证此法也。然须菩提言不作念者。恒作心防护。令习气我不起也。又复须菩提。是法身菩萨。现为声闻。永无习气故。不作念我得罗汉也。佛说我得无诤三昧最为第一者。此三昧所以名无诤三昧者。以须菩提能善作心防护习气。自于众生。不起贪嗔痴心。复不命众生于已起贪嗔痴心。故经中须菩提自云。若有人。嫌我坐者。我当终日立不移处。若有人。嫌我立者。我当终日坐等。故须菩提至于行乞。每以定心。观察众生前人于我不起障者。便入聚落。若起障者。则止不行乞。明须菩提于四威仪中常自善防护习气令使不起。以得此三昧。不与人竞。此烦恼障分尽故。名得无诤三昧也

如舍利弗等其余罗汉。不能善防习气故。与物竞。与物竞故。无有无诤三昧。若尔有人生难。如来尘习皆尽。何故犹为孙陀梨等之所谤毁。岂有习气未尽也。答意如来非以有习气故为人所谤。有二义故。如来知众生根机故。听人谤。一因此毁谤度彼众生。二欲为显佛功德故也。然如来五百大弟子皆得三昧乃多少不同。而各得第一之名。如舍利弗得十千三昧智慧第一。目连亦得十千三昧而神足第一。须菩提得六万三昧。于弟子中。无诤三昧最为第一。故如来于大众中。每叹其德。须菩提既得六万三昧等种种功德。何故唯叹此一。以此三昧六万三昧功德中胜故偏叹也

世尊说我是离欲罗汉等。此叹空行第一。离何等欲。五尘境界名之为欲。此明前境为欲。非谓贪欲烦恼名之为欲。以贪等烦恼久已断尽。明须菩提善得五尘境空。虽缘五尘。而此欲境不能阂其心。为谴此三昧障分尽于已所得三昧随分自在。故云离欲也

以须菩提实无所行者。明须菩提离二障故。不作念取我无诤三昧第一。我是离欲罗汉。故言实无所行也。而名须菩提无诤无诤行者。此双牒前无诤三昧离欲罗汉二句经来。明须菩提以无心念我无诤三昧第一我为罗汉。乃至习气不行故。离二种障。并立二无诤名也

何者二种障。一是烦恼障。二是三昧障。而须菩提善得空行故。当所除无知分尽。清净所得三昧明审。所未得者则不能知。已得者如实而知。无有错谬。此无知之或不能拘阂拥塞其心。故名无三昧障也。烦恼障者。谓贪嗔痴等习气烦恼。明须菩提得无我空解。先断四住执性惑尽。复善防护心。自于众生不起贪嗔痴习。亦令众生于已身上不起食欲等烦恼。不为此粗细二惑拘阂其心故。无烦恼障。以善伏习气故。离烦恼障。故能识人心。不与物诤。以善达前境空故。离三昧障。不为境界拥塞其心。不与境违。故云无诤无诤行也。其余罗汉。不能善达五尘体空。故所得三昧中多有错谬。如目连记其日当雨。尔时天竟不雨。以彼声闻人智慧微浅观心不彻。为前境所阂故。当分所得三昧中不清净故。有三昧障。又复不善防习气故。有烦恼障。以有此三段。无二无诤行也。然声闻人非但所得三昧不清净。有设使作神通变化。虽百千万。但能令一心一作。不能令多心多作。然菩萨则不尔。菩萨之人。解五尘虚妄本来空寂。复能现见真如平等之理。故万境不能拥阂其心。所得神通随意自在。遍周法界。多心异作。声闻非但一心一作。而所知复近不达久远。如有一人。至祇洹精舍。求欲出家。尔时五百罗汉。俱时入定。观此人根机。时出定已。语其人言。汝过无善根。设令入道。会不证果。故汝不得出家。此人烦恼便欲出去。至精舍门边渧泣。值如来从外而至。见此人。即问汝何故渧泣。彼人白佛。我欲出家。诸比丘不听。故渧哭欲去耳。佛知此人虽近无善根。曾过去久远有善。今欲得道。佛即告言。善来比丘。即成罗汉。衣钵具足。虽得罗汉。以新出家故。不解比丘威仪。如来将欲使其现神通力令诸弟子见而问之故。教言。汝洗钵盂莫着地上。亦不教置其钵床上若草叶上等。此比丘洗讫。置虚空中。以神通力故。而钵住空不堕。诸比丘见已怪问。此何比丘神力乃尔。佛即答言。向者白衣求欲出家。汝等皆言无善根者。此人是也。诸比丘既闻此已。深生惭愧。故知小乘罗汉所得三昧不但错谬。设令善得亦不知远事也。论曰向说圣人至不可说等。牒前第六段中生疑处经来也。若须陀洹等至云何成不可说。举四果来作难。难辞不异经中生起也。自下经文为断此疑。以下指前经中作释疑意。成不可取说义也。此一段经设一偈论释尽耶。偈上二句通释四果经文。下二句偏释须菩提独得无诤三昧以下经文也

不可取及说者。明行者证四果时以离身见或等故。于众生五阴中及以六尘。不见一法。名之为果。亦无心念我能得果。故不可取既。无一定法可证为果。亦无证法兆状可说示人故。言不可取及说也。何以故然下第二句云自果不取故也。此亦应言四果是可说。但为成上不可取说义故。阙不论也。依彼善吉者。正[番*及]须菩提名。说离二种障者。明须菩提得无诤三昧及离欲空行故离二障也

此义云何以下一段论。凡有二意。从初至我能得果。释偈中二句。解经中四果经文也。以圣人无为法得名至名罗汉解四果人证无为法得名为圣故。须陀洹乃至罗汉。释上疑。成不可取说也。然圣人非不取无为法以取自果。明此四果圣人虽当证时不取以成不可取说。然出证后还自谓得此无为果亦有可取说义也

若圣人起心。我能得果。则为着我人等者。此义云何。即释云。以有使烦恼非现行烦恼。使烦恼者。习气无明二烦恼也。非现烦恼者。后二果人无有示相不示相畜妻为世事粗惑行烦恼也。四果之中。前二果在家。须陀洹斯陀含虽断示相我。故有不示相我。犹畜妻妇行于世事。故有行烦恼。复有无明习气故。亦有使烦恼。后二果无有示相不示相。不行世事故。无行烦恼。有无明及习故。有使烦恼也。今言无烦恼者。此偏释那含罗汉也。亦应通云前二果也。有使烦恼。有行烦恼。但论主好略唯辨后之二人也

何以故彼于证时离取我等烦恼者。何故明此中论主欲显此义。假疑难。若在家二果犹有行烦恼者。何故言。须陀洹等二果离取我见等或。而名圣人也。故云何以故也。即答彼于证时。离取我等烦恼。此明前之二人。当证果时。得无我之解除身见等示相之惑。无取果之心。名为圣人。所以有现行烦恼者。出证更起不示相我见等或行于世事。故有行烦恼也。是故无如是心我能得果者。结前二果人证时不取之义也。故经中说。有一比丘。得须陀洹。自唱言。淫欲烦恼焚烧我心。遂即休道还家行世法。以此验知前之二人有行烦恼也

何故须菩提自叹身得受记以下。此段第二意释下半偈。解无诤三昧等经文故。先设问。如来常说恶事发覆善法覆藏。何故须菩提众中自叹身得受记。故释云以自身证果。明此无诤三昧唯须菩提得余人不得。显已功德故也

为于彼义中生信心故者。此答前疑难。疑意云。有人生念。如来虽道须菩提得无诤三昧是离欲罗汉。不知为得不得。以何验之。知须菩提得。生疑不信故。须菩提于大众中。叹云世尊说我得无诤三昧。拂去众疑。令其生信。成上不作是念我能得果。须菩提得故不作念也

又解云。须菩提何故显已功德。故答为于彼义中生信心故。明须菩提以已所得胜法。劝余二乘。令生信故也

何故唯说无诤行者。问云。须菩提所得三昧乃有六万。何故唯叹无诤三昧者。而不叹余德也。故答有二义故也。一为明胜功德。明声闻法中无诤三昧是最胜功德第一之法。独须菩提得。余者不得。设得不如。故偏叹之。二为生深信故。欲使余罗汉未得之流于此三昧生决定信求证此法。故曰深信也

何故言以须菩提至说离二种障故。此举经设问以偈来答也。二种障者至故言无所行。出偈中须菩提所离二障之名。释经中实无所行也

以是义故说名二种诤者以下。双释二诤二无诤名。以是义故者。此一句通释诤无诤二句。若不善护人心。为五欲境所阂。故有二种。以是有二障义故。与人物违境故。说为二种诤名也。离彼二种障故名无所行者。明须菩提善防人心不为欲境所雍故离二障。以是离二障义故。说名二种无诤行也

佛告须菩提如来昔在燃灯佛所受记者。此第七挍量分中第三段文说。此何以来。由前第六大分中明如来所说法皆不可取不可说。疑云。何如来昔为菩萨时。于燃灯佛所。受记作佛者。便是证法可取可说。若尔者。是证法有名相可取可说。云何言证法名相不可取说也。疑谓菩萨于尔时已得无生忍记故。为断此疑。答云。燃灯时言语授记。未得证智。故彼言语可取说也。及后证时。绝于名相。那得以言语授记难证法同名相可取说也。为断此疑。明如来昔在燃灯佛所得菩提不。释此是应佛如来。若是应佛者。则不修证果。何故乃引燃灯佛所授记。实菩萨证成此义。然应佛虽复不实。终不道言我是应化。以由真有应据本而谈故。引燃灯佛时实行菩萨为证也。此明非无菩萨以未有所证故言实无所得。成上不可取说义也。如来尔时犹是地前习种性中凡夫菩萨不现前授记。唯有言语。未有证法。故可取说。然复非不有实证菩萨。但难家据地前未证为问。故就问处答之。然实证菩萨者。下经中言。通达无我无我法离二无我者是名真是菩萨菩萨指此为正答也

此言燃灯者。凡有四种三时授记。一是习种性中。二性种性中不现前授记。三是初地中现前授记。四在佛地中无生忍授记。今言燃灯记者。释迦尔时犹是习种性菩萨。未得初地以上无生忍证法也。今明如来问须菩提。汝谓我尔时已证初地无生菩提记也。须菩提解答如来在燃灯所言语受记未得初地无生记也。故云燃灯所实无所得也。如婆伽罗经说。我昔在习种性时。于星宿劫中。供养七十亿那由他佛。一一佛住世。迳六十亿那由他劫。而彼佛皆不与我受记。何以故以未得无生忍地故

论曰复有疑。论主将欲设偈释此分第三经文。故序上不可取说中第四疑意。先举疑者。谬引过去佛所有取说。来难今说证法便同可取说也。为断此疑。以下论主取经答。意明菩萨于过去佛所未得证法。成不可取说。答有取说疑。如经者。总举释疑经结也。何故如是说者。疑者引燃灯佛来。作可取说难。还应答以不可取说意。何故乃云实无所得阿耨三菩提。作此不正答也

佛于燃灯语一偈。释此一段经也。此言佛者。今释迦佛也。于燃灯语者。于彼燃灯佛时。唯言语受记也。不取理实智者。明当受记时未得无生忍证法实智也。以是真实义者。有二种。一者成上第六段中不可取说。二者成上非法也。云何成上不可取说。前言证法绝名相故不可取说。难言乃引昔燃灯佛时授记为难。答者意明本燃灯授记唯有言语。言语是音声之性。故可取说。非是证法可取可说。故得成上不可取说也。二者若证法犹是无名相不可取说者。还复上第二疑言教一向非法故。答意明。证法虽无言。得证故能说。寻此言说。还能得证。故言教是法。非是非法也。故言以是真实义成彼无取说也。以是言语授记不得证智真实义故。犹得成彼证智不可取说也。二者直以证智之体无有名相故。亦不可取说真实义。故下句云成彼无取说也

此义云何以下长行论有二意。从初至无取说故。释上半偈及经释竟。以下半偈来结也。又若圣人以下。此是第二论主序疑者意。生下净土山王喻经也。从圣人至不可说。举上第六段中经文也。云何诸菩萨取净佛国土者。此一疑别生下净土经也。云何受乐报佛以下二疑。别生下山王喻经也

佛告须菩提若菩萨作是言我庄严佛土者。此挍量分中第四经文。何以故起。由第六段中皆不可取说。生第五疑。上疑云。若圣人无为法得名。是法不可取说者。诸佛菩萨所得依报净土。为是世谛。为是第一义也。若是第一义者。可是不可取说。若是有为世谛者则是可取可说也

疑者言。此净土若是有为者。诸菩萨既取此净土。云何言不可取说。若使依报净土是有为者。圣人犹受有报。云何言圣人无为法得名不可取说也。此疑谓出世净土同于有为土也。故下经中。佛答言。净土有二种。一是地前有为形相七宝庄严三界所摄。二是地上出世间净土第一义庄严非三界所摄。以初地以上圣人报出三界土也。汝那得以世间净土难于出世间净土。此真净土不同于世间净土可取说也。此近答第六段不可取说疑。亦远答第五段中疑也

譬如有人身如须弥山王者。犹释第六段不可取说中疑。若圣人无为法得名。是法不可取说者。报佛如来十地行满。华台受报佛职。得无量功德。自谓我是法王。复取庄严净土。若如是则证法可取说。若是可取说者。此报佛是有为所摄也。若有为摄者。则是无常。若无常者。则漏不尽。漏若不尽。不名为佛也。若是无为。与法佛为一。为异。如其一者。法佛无色相。报佛亦应无色相。若与法身异。此之报佛。则从生因生。若生因生。则本无今有已有还无。则是无常。云何言圣人无为法得名不可取说也

又论中生起言。云何余世间复取彼是法王身者此是因第六段不可取说中。生第七疑。疑云。十方诸佛及余世间。亦言某甲世界某甲菩萨十地行满受报佛职。亦道彼是法王。若报佛可为他取说者。云何言无为法得名不可取说也。故佛引须弥山王喻。以答此疑。明报佛体是无为不可取说非是有为可取说也。所以然者。以佛修行断惑因缘。即本有之性现用名为报佛。既有报佛正果。便有依报真实净土自在之用故。是无为非有为。亦非条然故常也。上所以说报佛如来从生因生者。望报用义边。是其始有故。义中说了为生。非报佛体从生因生是无常也。此近答第七段中疑。亦远答第五段中疑。故次明也

若菩萨言。我庄严佛国土。彼菩萨不实语。此是地前菩萨取相行。但得有为庄严众宝。无石沙荆棘之秽。以为真净土。不知别有出世真净土。但以已所得。为真实净土也。谓同莲华藏世界等。更无别真实无为净土。故言不实语也

何以故者。即生疑也。难云。若形相庄严非真净土者。何以故。如来说我所得净土胜相庄严如自在天宫。我净土中众生无欲。如梵似天也。又何故教众生言。我修净土因时平治道路除去荆棘运高就下等。以为净土。因得此净土之报。寻如来诚言。此净土似有形状。既有形相。则三界所摄。便可取说。云何言净土非形相庄严不可取说。若取形相庄严。则不实语。故云何以故也

故佛答言。如来所说庄严佛土者。将欲诱进始学故。以近况远。故说我所得净土如自在天宫等也。又随世间说。世人以此形相七宝琳琅者。为净土故。佛随俗说是净土。非谓第一义谛真实净土。故云如来说庄严佛土也。然非不是世间有为有漏形相庄严也。则非庄严者。此随世俗说。以为净土。非出世间第一义谛真实净土。故云则非也。是名庄严佛土者。如是非形相庄严者。即是真实第一义庄严也。亦得云形相庄严非庄严者是名非庄严也

然此言净土者。正是诸佛依报真实智慧第一义土。此土以真如法性为体。即莲华藏世界。此之净土与真报佛。语体则同。言用则异也。此土如来从发心以来。所修万行功德智慧二种庄严。出世无漏胜因所克故。十地经云。过一切世间境界。出世间善根所生也。不为地前取相漏因所得。体非有为形相庄严所摄故。大智度论云。诸佛净土。不为欲色无色三界所摄。云何言此真净土不为三界所摄。解云。不在地故非欲界摄。不在空故非色界摄。体是色故非无色界摄。虽三界不摄。而与之同处。然不相妨阂。设三灾起时世界焚烧。而彼净土湛然不变。故法华云。众生见劫尽大火所烧时。我此土安稳天人常充满。此即真常净土。故三灾不毁也。又诸佛净土平等清净无二无别故。十地经云。一佛土一切佛土。一切佛土。一佛土也。今解此净土云净秽同处者。异于昔来所辨一质异见之义。所以尔者。原净秽二土本无异处。非如娑婆安乐二土既殊条然有别也。若然何故有石沙铜铁七宝琳琅到伏等界无量差别。或有众生。以虚空为地。地为虚空。如斯不同。皆是众生业之垢净。智有明昧故。所见万差。非土有异。犹如恒河流水。有诸饿鬼共往趣饮。或见流火。或见脓血。或见灰炭。或见枯涸。或见鬼神守护不令得前。斯皆众生罪业因缘故。于此一河。所感各异。故见不同。非谓水一而见有殊也。如维摩说。螺髻身子所见不同。如二天共食饭色有异。此亦同也。故知处一土差。就见不同。非为一质而有异睹。其理焰然也。是故须菩提菩萨应如是生清净心等者。此经教劝新发意菩萨取真净土之方。是故者。以是行地前取相之行。唯得世间有为形相庄严净土。非是出世第一义庄严净土义。故诸菩萨摩诃萨。要须修行初地已上不取相波罗蜜行。乃可得于出世间无为真净土地勿以。取相之心所得世间有为形相之土。以为真实净土故。言应如是生清净心也。应如是生清净心者。应如上第四段于三事中不取着心也。而无所住者。谓不着自身。不乞住也色等着异。不着三界人天五欲果报应无所住者。谓不着报恩。此三即是前三事也(此明如来所得第一义土满足清净初地以上分中清净也)

金刚仙论卷第四金刚仙论卷第五

        魏天平二年菩提流支三藏于洛阳译

譬如有人身如须弥山王者。此举大身喻之报佛。同彼山王镜像譬相似义也。又此山胜出余山。名为王也。有人者。即说报佛为人也。亦得言有人者世间人也。如王者。引喻况之。明世间人身大如须弥山报佛亦然。十地行满金刚心后。显性本有。名法佛。万德智惠圆满名报佛。于众圣中王。名为大身。体是无为常住。而不同有为身。故借之为喻也。须菩提于意云何是身为大不者。明如来既引山王喻报佛身竟。问须菩提报佛身为大不也。须菩提解。即答甚大世尊。明报佛万德圆满众圣中王分同于山王故。曰甚大也。疑者闻报佛名为大身如山王。便谓报佛因山王有为形相之身。若形相身。则是无常生灭之身。有此义故。答佛说非身是名大身。答意明报佛大身不同世间有为形相之身。其体湛然无有有为有漏心意意识虚妄分别相也。以山王报佛分有相似故。引之为喻。语其实者。条然天绝。故言非身。而有无量功德智慧。湛然常住最高大身。是名大身。亦得云彼身非身是名大身者。此释彼报佛大身为非大身。以非有为有漏相之身。是名大身。即显本有之性现用。名报佛。妙相湛然。有无方大用。是名报佛真实大身也

论曰此义如是应知。指净土报佛之义。如经说。佛与须菩提。问答应知。论主未曾有释。云何言应知。明须菩提疑有在心未彰于口。即以偈答云。智习唯识通。此一偈释若菩提作是言。我庄严佛国土乃至而生其心。智者。真实智净土。以智慧为体。然此净土所以以智慧为体者。明如来果头依正两报。语体则一法性。论在用遍则身土两别。故依正虽殊。莫不以智慧为体也。习者。后智访于前智。名之为习。习前心为因。因能感后解。不不异而转精胜名习因。能显真性无壅。名通。通者。谓第八佛性识无壅。名之为通也。故偈言智习唯识通者。第八阿梨耶识。通明十地菩萨无漏真解佛果智慧方能通远。见此净土。得此土用故。下句劝云。如是取净土。上问净土之义云何。如今明净土因行体相。义正如是。如是行如是取。非颠倒。非妄取也。故曰如是取净土也

非行第一体。非形者。此真净土。非有为形相也。第一体者。此净土若非有为形相者。则应一向无形相同于虚空耶。今明此土虽非有为形相之形。非无出世无为之形。真谛庄严净土第一体也。非严者。即上句非世间形相庄严。后庄严者。即第一义谛庄严也。此句应言非庄严庄严。但以偈狭。直云非严也。意者取净土之义。意正如是也。此义云何者。问此一偈释净土之义云何也

即释诸佛无有庄严国土事至不实说。释偈中上二句。亦解经初若菩萨作是言至不实语也。诸佛无有庄严国土事者。明如来无有世间形相庄严国土事也。诸佛如来真实智慧习识通达者。明如来所得庄严佛土唯是出世间智慧第一义庄严之用也。此二句正出净土体也。是故彼土不可取者。结前经初释疑之意。是故者。此诸佛净土。非有为形相。是真实智慧第一义相。故不可取。何得疑云。菩萨所庄严佛土。谓可取可说。不应以无为法得名也。若人取彼国土形相等者。既明此净土体是第一义谛。非有为形相故。若人取此净土同有为形相者。是不实说也。如经等者。举下释疑经来。成上取有为形相为真净土者是不实说。故引此经来也。而此经明有为形相庄严者非真净土。故不应所为即真净土。何故如是说者将以下半偈释此前经故。先作问生起。问此经所明言庄严佛土。复言即非庄严。何故作如是相违之说也。即以偈答言。非形第一体非庄严庄严意也。庄严有二种者。释出偈中二种庄严也。又非庄严等者。上以经偈相属。出二种庄严名竟。方次第解释也。又非庄严至故非庄严者。释经中如来说庄严佛土即非庄严。解偈中非形非庄严。即是二种名中一者形相也。如是无庄严至成就庄严故。释经中是名庄严。解偈中第一体庄严意。二种庄严中二者第一义相也。若人分别佛国土至而生其心。此下将欲释应如是生清净心等不住三事经故。举住三事人不得真净土也。若有人起心分别。谓佛国土是有为形相。而修住三事取着行。自谓我如是取得真净土者。此人非修真净土因也。为遮此故。以下正出欲修净土因者应不住三事故。以经结之。可知也。前言受乐报佛者。将欲作第二偈释山王喻经故。还牒上二疑。举报佛山王少分相似。生起下偈也。此义云何者。此云法喻少分相似答疑之义云何也。即以偈答。如山王无所等。此一偈释经中譬如有人至是名大身。答后二疑也。如山王者。如须弥山王十山中最故名为王。无取者。须弥山王是无记物故。无心自取言我是山王胜余九山。故言如王无取也。受报亦复然者。此一句合山王喻。应言受乐报佛亦复然。以偈狭故略也。明受乐报佛得十力四无畏等无量功德。于法中自在。胜于众圣。故名为王。以无取相分别心故。亦不念言。我是法王故言受报亦复然也。此中论主设一难。山王无心故所以不取我是山王。报佛有心何故不取我是法王也。故下半偈答言。远离于诸漏及有为法故。远离诸漏者。明报佛二障永尽绝于分别离于有漏取相之因

及有为法者。明非但离取相之因。亦离取相有为之果也。以取相分别永尽。故不取已为法王。非谓同须弥山王无心。故不取也。此明报佛既体离有为生死因果故取。以湛然常住不为三相所为。故曰无为。亦名无漏也。此义云何等一段长行论。从初至以无分别故。释上半偈山王报佛法喻有相似之义竟也。如经已下。举释疑经来。结成报佛山王无分别义也。下便作问。还问此经。然后一一别释。何故如是说者。问此经中言。佛说非身名大身。何故作此二说不定也。即以下半偈答远离于诸漏及有为法故也。彼受乐报佛体离于诸漏者。此文释偈。明报佛离于二障诸漏。无取相分别心。故不取已为法王也。若如是。即无有物者。若报佛体。如是离二障诸漏。即无有为万相及虚妄我相之物也。故下句云。以远离有为法故。此释经佛说非身也。若如是即名有物者。若报佛体。如是具二种庄严。即有无为万德真我之物。亦得若如是无有虚妄我相者。即是真实报身物也。故下句云。以唯有清净身故。此释经是名大身也。以是义故。实有我体者。以是无有物之物。唯有清净身义。故实有报佛常住妙身具八自在真我之体也。以不依他缘住者。明报佛真我之体不从因缘而有也

佛告须菩提。如恒河中所有沙数者。此挍量分中第五经文。明外物布施挍量中第二譬喻。此第二喻所以来者。前虽已释云受持此经一偈功德胜三千世界七宝布施之福挍量已竟。而乘复生疑。如来上虽广释持经福多胜于七宝布施成上不可取说。然多义有差。亦或有过无量以之为多。又等中少胜。亦名为多。未知此为过二千三千少胜故多。为是过无量恒河沙世界不可穷尽故多也。若少胜故多。则仅胜此三千七宝施福。有其限齐。非是无穷无尽深胜福也。为除此疑故。佛答意明持经之福非但胜三千七宝施福。设以无量恒河沙世界满中七宝。持用布施。犹不如受持读诵此经一四句偈功德。何况不胜三千世界布施少许之福。故引此恒沙譬喻。以释彼疑。云何释疑。今云多者。明无量故多。非少胜故多也。又复受持一偈其文难少用功不多。乃与无上佛果。作其胜因。七宝等施。虽复物广功多。此取相之业。但感世间有为果报。故不如也。然此前三千七宝布施。但言持用布施。不出施何等人。今此无量恒河七宝布施。明施诸佛如来。物既是多。得福亦胜。犹不及持一偈之福。况三千珍宝布施物少。又不辩前由取得福德何得是多。故转显挍量胜也。恒河沙者。从清凉池出。入于东海。长八万四千由旬。广四十里。或有广十里处。以从沙山中过故。有流沙色白。水亦同白色。状如乳。出河即清。此河极深。若象马车乘入者皆没。此河中沙。一切凡夫二乘不能算计知其头数。唯有诸佛。知之了了。初地以上菩萨亦能数知头数多少。性地菩萨虽不能数知。以一大阿僧祇劫来不妄语故。不假思惟发言。即者。此河中沙既如是故。引之为喻。又天竺国人。皆见此河故。诸经多引之为喻也。此河中沙。一沙为一河。尔许恒河中沙等三千大千世界满中七宝。以施诸佛。犹不如受持一偈之福也

论曰前已说多福德譬最何故此中复说者。释云前说三千七宝布施挍量不如持经一四句偈。此中何故复说恒河沙譬也。有如此问故。偈答说多义差别。说多义差别者。论主作偈。释前疑问。欲明多名。虽曰乃有限无限异。故重以斯喻。譬此无限布施异于三千之福故。云说多义差别也。亦成胜挍量者。前虽以三千譬最挍量不如持一偈之福。犹未显胜挍量义成。今复以恒沙譬喻。挍量持经之福。明无量恒沙七宝施福虽多是取相福。得世间果报终必有尽。明持经之福乃得无上佛果无尽之报。方显持经福胜。故持一四句偈功德。胜前二种布施之福。闻说此已。复生疑云。然此经理既深重如此。未知为但受持此经一偈之功胜前二种施福。为更有胜事也。挍量之义为足未足。故答意明非但持经得福无量。若有人能但尊重说此经处。及恭敬供养能说之人。亦得功德无量无边。胜前三千恒沙二种施福。故劝供养。以此说经二处胜能舍财二处。由贵持经人说经处。故次明也

此一段经有六段文。一尊重说法处。二敬能说人。三问经名字受持方轨。四明三世诸佛同说此经非我一佛独说。五明微尘世界二种譬喻。以释前恒沙喻中疑。六明三十二相方便了因之福犹不如持经之福是其正因也。一重说法处者。从复次须菩提至如佛塔庙也。随所有处说是经者。随在何处。若在讲堂中聚落空泽旷野中。随有说金刚般若经处也。所以此中劝人天修罗供养说法处者。明人天修罗所以得此殊胜五欲乐报者。皆由依般若经修行五戒十善。克得此报故。劝其供养说法处也。如佛塔庙者。劝供养此经处如供养应佛遗形舍利住持塔想也。应劝言。供养说此经处。如供养经。故涅槃经云。当知此处即是金刚明在地则地贵也。此不应言如佛塔庙。取以然者。此经所诠明于法身。塔中舍利乃是应佛遗迹故不如也。是以大品经中。佛告帝释言。三千大千世界满中舍利作一分。此摩诃般若一匣经作一分。汝于此二。欲取何者。帝释白佛。我宁取此般若经也。然我非不敬重如来舍利。以由般若故。方有舍利。亦以般若勋修故。舍利得供养。故取经不取舍利。以不如故。不应供养说经处如塔庙想也。出经家以世人多尊敬塔庙舍利形像故。劝供养说法空地如塔庙想也。二敬能说人者。从何况有人乃至尊重似佛也。何况有人尽能受持读诵此经者。随凡夫圣人但能受持演说此经。若与供养者。当知是人成就是上第一希有功德。前明说四句偈处尚劝供养。得多福德。况有一人尽能受持读诵此经。若兴供养。当知此人得福转多无量也。最上希有功德者。明供养受持经人必近得初地已上报。远得佛果最上希有第一功德也。此最上第一希有有二种。一依世辩释名以后释前。又一种解。最者无有能胜也。上者。更无过也。第一者。不共下地有也。希有者。世间所无也。明尽受持人。经云得此最上等功德故。劝供养持经人也。若是经典所在之处者。明持经人即是经取住处也。则为有佛者。明劝供养持经人。莫问凡夫圣人。但能受持此经。劝供养者。当如佛想。所以然者。如来在世。亲说此经。以化悟众生。末世之中有人。随顺佛意受持经者。则为与佛无异故。此人虽是凡夫不名为佛。而流通大乘。说法化人。生解断或。证于圣果。分同于佛。故劝供养如佛也。故经言。是中诸人亦是金刚明处人则人尊也。又解此经所表即是真极法身故。亦云则为有佛也。若尊重似佛者。谓菩萨也。明菩萨大士至于智慧除惑。说法化物。自他利行。亦是分有种智。片悟同佛。故云似佛。明此持经人化物功齐菩萨故。劝供养持经人如供养菩萨。故云尊重似佛也。三问经名者。从尔时须菩提白佛。乃至则非般若波罗蜜也。此中所以问其经名者。须菩提心念。如来上虽叹经理重深劝受持供养说法处及恭敬持经人。然我今说欲受持流通末代化益群生。若不识经名。不知受持方法。无由得说化益群生。故问经名也。佛告须菩提。此法问名为金刚般若波罗蜜。以是名字汝当奉持者。此是答问经名也。金刚者贤实也。般若者。如来果头智慧照了一切法相也。波罗蜜者。到彼岸也。此如来智慧彼岸功德。其体坚实喻如金刚。故云金刚般若波罗蜜也。以是名字汝当奉持者。因理名经。亦名金刚般若波罗蜜故。敕须菩提。以此名字。受持化物。流通末代也。何以故者。此何以故取以而来向。须菩提既闻经名。便应问世尊。云何名此经作金刚般若波罗蜜。但有其念。而不作问。故真言何以故也。答云。佛说般若波罗蜜。即非般若波罗蜜等。此是如来以世辨释经名也。明此经诠说如来无为法身彼岸智慧。唯是如来果头所得坚固智慧彼岸功德故。云佛说般若波罗蜜。然此智慧彼岸。唯佛境界。非二乘凡夫所知。故云即非般若波罗蜜。以是如来境界。非余人所得故。名金刚般若耳。四十方三世诸佛同说此经者。从须菩提于意云何如来无所说法。此是一部经中第二无所说法也。上第六段中云无有定法如来可说者。明应佛不实证实说。故云不说法。今须菩提言世尊如来无所说法者。此二处经文乃同解意大果。次前经中言。何以故佛说波罗蜜即非波罗蜜。释云此金刚般若波罗蜜。唯是如来境界。非余人取得者。乘此生疑。为唯释迦如来独得独说而余佛不得不说。为十方诸佛同得同说也。余人语滥故须料简也。此中应有问答。而不作问答。直问须菩提于意云何如来有所说法不。须菩提解如来意。故答世尊如来无所说法。明此至与三世诸佛现果证法作胜因故。三世诸佛相与共说。我皆因受持金刚般若经故。得发菩提心。依此经故。修十地行。成三菩提。同得同说。不多不少。不增不减。非但我释迦独得而说。故云无所说法也。故大集经中佛自说言。吾从得道夜。至涅槃夜。非其中间而不说一字。然如来一代。说无量诸经。云何乃言不说一字者。明我今所说十二部与三世诸佛。同说不异。十方诸佛所说。我不别说一字也。又解。如来从得道夜。至涅槃。更不说一字者。明证法无名相言语道断心行处灭不可以名相往说。故言不说一字也

须菩提。于意云何。三千大千世界中所有微尘是为多不者。此挍量分中第三譬喻。释前第二恒沙譬喻。即通释前第一三千譬喻也。疑云。前二种喻。既取施甚多。何故得福使少。不如受持一偈之福。受持一偈经其功甚少。所以获福多于施福。无量无边。以有斯疑。引此喻。释持得多福。所以欲明施福虽多。因是有漏烦恼染尘。果是系缚三界之法。不能出离。所以不如。明受持一偈虽少乃能出离三界。远招佛果。因是无漏非烦恼染尘。果非系缚故。胜施福也。是故举微尘譬喻。释此疑也。欲挍量持经布施二种福德忧劣不同。何故乃引外无记尘为喻也。依世辩论。明微尘之名通记无记。直言微尘者。或名烦恼。或名为染。或名为缚。或名为界。亦名为性。亦名为垢。亦名为尘。亦名点污。有种种名也。泛云微尘者。亦是烦恼微尘。亦是地微尘。以此二名相似。又名义复同。是故引地微尘为喻也。明前二种七宝布施得福虽多。以取相心心施。与贪等烦恼合故。是染烦恼尘。体非出离故。所以不如也。持经一偈之福。因非取相。果是出离。所以是胜也。是为多不者。此如来问须菩提。三千世界中所有微尘为多不也。须菩提言。彼微尘甚多世尊。此是须菩提仰答如来。明微尘甚为多也。是诸微尘如来说非微尘者。明地无记微尘非染烦恼微尘也。非是性空故言非。亦非全无。但非染烦恼微尘故。言非也。是名微尘者。是名三千世界地无记微尘。亦得云是非烦恼染微尘也。第四所以复引世界喻者。前就细为言。此据粗而说。粗细虽异。名义名同。亦通记无记。不异尘喻也。复以世辩之名不同故也

须菩提于意云何可以三十二相见如来不者。此何故来。前明二种布施取相之福。但得三界天人有为果报故。不及持经福者。然未知报佛三十二大人相福方便之因。此十地万行。亦是出世无漏之福。复何如持经之福也。所以然者。经中明如来自云。我于过去。由以头顶礼敬父母师长。今得无见顶相。以见他为福随喜佐助故。手中得罗网相。从三大阿僧祇劫来。不曾妄语故。得广长舌相。然如是等相。亦皆是无漏胜因所招。此因为同持经之福。为不同。以有此疑故。佛问须菩提。可以三十二大人相见如来不。故答意明何但恒沙七宝布施取相之行不及持经一偈之福。设报佛三十二大人相福方便胜因。亦不如受持此经一偈之福也。又难然三十二大人相因。是其了因。受持此经亦是了因。既二俱了因。何故持经功德胜大人相福。故答。所以然者。明此经故从法身中来是其一分故。还诠法身。寻此能诠。证于法身。虽言受持经教。而意在所证诠理。故受持此经者。即受法身故。胜大人相福也。非谓所持经功德了因义遣也。于意云何。可以三十二大人相见如来不者。佛问须菩提。于汝内心所解。可以报佛三十二大人相见古今一定虚空法身如来不也。故言可以三十二大人相见如来不也。须菩提言不也者。明法报义殊修得不修得亦异故。不可以报佛相好见法身如来也。此如来名同故尔解释也

何以故者。有人乘生疑念。若不可以报佛三十二大人相见法身如来者。何故如来自说。我三大阿僧祇修行满足。金刚心后。显本有法身。以为报佛。尔时为法报二佛则体一无差。何故乃言。不可以报佛大丈夫相见法身佛。故云何以故也。故须菩提答。如来说三十二大人相。三十二大人相者。是报佛如来修得之相故。如来说为报佛三十二大人相也。即是非相者。明此报佛所得三十二大人相即非古今一定法身相也。何以故。法报二佛体一无差。而不可以报佛相见者。以古今一定虚空法身。若修十地行。亦不可得以色相而见。不修十地行。亦不可得以色相而见。以此三十二大人相非法身相故。言即是非相也。以此别相义故。不可以报佛修得之相见无为法身佛也。上来校量持经功德胜如不同。然法报二佛。体既不殊。无忧劣之别。所以乃云不可以报佛大丈夫相见法身如来者。此举果。以明因有胜如不同。非谓法报二佛其体是一而优劣有异。而不可以报佛丈夫相见法身佛也。有人乘生疑难。若是三十二大人相非法身佛者。此三十二大人相。则一向非相故。答是名三十二大人相。则是名报佛三十二大人相。相亦得是名非法身相也。此就法报二佛别相义边论。不道一义边故。是名报佛丈夫相也

论曰云何成彼胜福者。论主将欲设偈释此一段经。先作问生疑。问此一段经。云何成上持经之福胜七宝施福也。即以偈答。而此一段经。但以一偈论释。尊重于二处者。此一句释人处二经。一释尊重说法处。二释敬重能说人。此应云尊重于二处。因习证大体亦应言不尊重于二处。彼因习烦恼。一不尊重舍物处。二不敬重舍物人。但以偈狭故。阙不论也因习证大体者。释上尊重二处。所以但言尊重说法处人。不重舍物处人者。因受持修行此经一四句偈故。能证法身大体故。但言尊重说法人处。不言舍财处人也。又此偈中第二句。依下长行论。次第广应释问经名如来无所说法等二段经也。彼因习烦恼者。明七宝布施虽多取相之福是人天之因。是染缚之法故。言彼因习烦恼。不言重舍物处人也。此降伏染福者。明三十二相因胜前取相施福也。然三十二相福虽胜前施福。犹不如持经一偈功德也。明此持经功德非但胜有满之因。亦胜大人相方便因。故言此降伏染福也。此义云何等自下。释此一偈。次第解经也。尊重于二处者。提偈中上句。释经中第一第二与句经也。一者所说处。二者能说人等。上句云尊重处。今数出之也。以尊重经论故。举此人处。劝供养也。非七宝等者。以七宝施福是烦恼因故。不劝人供养。此舍财处人也。此法门。与一切证法作胜因故者。以释偈中第二句。解第三第四子句经文。明十方诸佛云我皆因受持此金刚般若经故解无为法身。证大菩提故同说也。如经以下至如来无所说法。举经来结。然后更释也。此义云何者。此经中言如来无所说法。论主乃释作十方诸佛证法以为胜因同说之义此竟云何也。即释云。无有一法唯独如来说余佛不说。故得释如来无所说法。经作十方诸佛胜因同说义也。彼珍宝等经烦恼尘染因。释偈中第三句。解经第五子句也。彼珍宝布施福德是染烦恼因者。出七宝施福作有漏因义也。以能成就烦恼事故者。明向因所得果是三界中人天五阴果事也。此因远离烦恼因故者。明持经之福非烦恼因也。是故者。是七宝施福是烦恼因。持经之福非烦恼因。故说此地微尘喻也。明此地尘是微尘而非染因故。证经七宝施福亦名微尘。而是染因故。不及持经福也。如经等。引微尘世界等经结也。何故如是说者。问向经何以言是诸微尘。复言如来说非微尘。何故如是相违说也。即释彼微尘非贪等烦恼体。明彼三千世界地微尘非贪嗔等烦恼染微尘。故言非微尘也。以是义故名为地微尘者。以是地无记微尘。非贪等尘义故。唯得说为地微尘也。世界之义亦同微尘也。此明何义者。向说地微尘非烦恼染者。此为明何等义故也。即释云。彼福德是烦恼染因。此正出喻所况事。为明七宝施福是烦恼染尘故。明此微尘世界二喻也。是故于外无记尘彼福德善根为近者。是七宝施福是烦恼染因。能感三界人天果报。故得为近。外无记尘非烦恼染因。不能感果。故不名为近也。何况此福能成佛菩提者。上七宝施福。但于世间果报。有其因义。形于外尘。尚得为近。何况持经之福。能显法身佛菩提。此最是近中之近也。及成就大丈夫相福德中胜故。明此持经之福于法身菩提有胜因之义。不但胜七宝于福人天之因。亦胜报佛大丈夫相因。是受持经福。胜丈夫相因。无漏福故。况复不胜七宝布施有漏之福。故云胜彼福也。何以故者。此持经之福。胜七宝布施有漏之福。事容可尔。而此丈夫相因。是无漏福。何以故复云不如持经福也。即释云。彼相于佛菩提非相故。然大丈夫相因。所以不如持经福者。明大丈夫相唯是报佛相非法身佛相。以此无漏福德。但能与报佛丈夫相为因。不能与法佛菩提为因。故受持经者。即是受持法佛菩提。是故持经之福。胜丈夫相因也。即结之。以非彼法身相故也。此中乘生疑难。若此丈夫相非法佛相菩提相者。何故如来说显本有之性。以为报佛。若令显本有之性为报佛者。便二佛一体。何故言丈夫相非法佛相也。即释云。是故说大丈夫相。明法报二佛。虽复体一。复有别相之义。是故我说大丈夫修修得之相。唯是报佛家相。非法身相。即结云。以彼相故也。明以彼丈夫相即报佛相故。上云。于佛菩提非相。非谓于报佛菩提亦非相也。此受持及说。能成佛菩提。是故彼非胜故者。唯结持经福胜丈夫相。无漏福也。又彼福德至最近最。初释偈中第四句降伏义。明凡夫相因是无漏福。能降伏七宝施福。尚不如持经福德。何况不胜珍宝布施有漏之福。此一句双结胜二种福也。如是彼檀至最胜成也。此通结舍外财二种譬喻挍量及丈夫相福中胜义成也

佛言须菩提。若善男子善女人。以恒河沙身命布施者。此挍量分中第七段经文。所以来者。上明三千恒沙二种布施。唯言舍于外财挍量不如持经福多。未足显持经之福胜中之胜。然菩萨大士。舍有二种。一者内舍。所谓身命。二者外舍。谓财宝等。今明何但舍外财布施不及持经之福。舍中之难。不过身命。假令舍恒沙身命。苦恼身心。亦不及持经一偈。之福故次明也。虽云此经明以舍身福德不及持经之福。未知何者为是。故就此经显出也。然此一段经。凡有八分明义。第一明若善男子善女人。舍恒河沙身命布施。不及于此经中受持四句偈为他人说者。论释云。苦身胜于彼。此明地前苦菩萨。取相心中设为菩提舍其身命。虽胜舍于外财。犹不及持经福也。云何名取相心。凡有二义也。众生于无量世来。于己身中。计我贪着。但求三界人天胜果。不知菩提妙绝世相。虽闻菩提胜妙。犹谓同于世间人天果报体是有为不免生灭。设为此菩提舍身。还招之界有为果报。故是取相。是取相故。所以不如也。又纵令初地以上舍身不取相福。亦不如持一偈之福也。明受持此经者。虽云受持一偈经教。而意在受持所诠法身。然言教虽是名相。而所诠者是无为法身之义边。无相故非取相也。既依经修行。知法身非同三界故。胜于恒河沙身所相福也。第二尔时须菩提闻说此经至未曾得闻如是法门。此论释云希有也。须菩提闻说是经。深解义趣者。明须菩提闻如来说此经故方解无为法身。名深解义趣也。然须菩提。若是菩萨权为声闻者。方便现言深解。若是实声闻。昔来实不闻不解。今日始闻方解深义也。悲泣流泪者。然须菩提悲泣。有二意。须菩提以念此经理深重昔来未闻故。所以悲泣。二以伤已所小乘果证不得此大乘法门。所以悲泣也。若权作声闻。应流泪也。扪泪而白佛言希有者。而此段论名希有者。偏提此两字。为第二段名也。希有有二种。一明此金刚般若果头无为法身甚深法界唯是如来所得。下地所无。故云希有。二明须菩提自云我虽得罗汉果具十知三三昧及八解脱。未曾得闻此甚深法门。以信者难得故言希有也。自如来成道。五年以来常说般若。不曾断绝。又上言十方三世诸佛亦恒说此法。何故须菩提言。昔来未曾得闻为希有也。然如来虽复常说此经。乃是大乘法轮。须菩提是小乘之人。从来未曾得闻。设闻不解。于须菩提。名为希有也。我从昔来所得慧眼。未曾得闻如是法门者。明须菩提自云我虽先得性空无我慧眼。未曾闻此无为法身甚深法门也。何故但云我所得慧眼。不言得法眼者。明小乘人。虽观有漏无漏示法解人无我空。未得因缘法体及真如法空故。但言所得慧眼。不论得法眼也

何以故须菩提佛说般若波罗蜜即非者。此第三章门。论释云。彼智岸难量。何以故者。难云。须菩提既得慧眼。何故不闻如是法门。故言何以故也。答意以此法如来果头彼岸功德第一上义。非二乘所测故。所以不闻。此一意成上希有也。佛说般若波罗蜜者。此是世辨释名。明此法门所证唯诸佛果头智慧彼岸境界。故云说波罗蜜也。即非波罗蜜者。明此智慧彼岸乃是如来所得法。非二乘所知境界。故云即非波罗蜜也。又此第二意以此即非般若波罗蜜至作第三彼智岸难量段也。世尊若复有人得闻是经信心清净即生实相。乃至说名实相。此第四段。论释云。亦不同余法。若复有人者。谓初地已前信相菩萨人也。得闻是经信心清净则生实相者。既闻此经。决定能信无为法身。生实相之解。无有疑浊。故清净也。当知是人成就最上第一希有功德者。若菩萨信此经所表无为法身。生信以为实相故。便能依经修行。证得果头无为法身希有功德。故曰成就也。明此无为法身三大僧祇方得此果。胜于小乘。故称第一。金刚以还之所未得。故曰希有也。世尊是实相者。谓即此经中。明如来如得无为法身实相法也。则是非相者。明此如来所得实相则非二乘法中所得实相也。是故如来说名实相实相者。解有二种解。明此无为法身实相之理。唯是如来所得实相。故重言实相宝相。又第二解意。有人疑。若佛大乘法中有实相。二乘法中无实相者。何故二乘法中亦自言有实相也。故答今言如来有实相余人无者。古今一定无为法身实相之理。故言无实相。非论二乘法中所明性空实相亦无也。是故如来说名实相实相者。一如来所得无为法身实相。二乘所得性空实相。故言实相实相也世尊我今得闻如是法门不足为难者。此第五章门。论释云。贤实解深义。此云闻是法门信解不足为难者。凡有四意。一意须菩提自言。我今生值佛世。复是出家之人。是有信者。得罗汉道。闻佛陀说。宁容不信。二者须菩提虽是小乘人。已曾发道意故。闻则能信。三者须菩提乃是法身菩萨。现为声闻。闻此法门。岂容不信也。四者须菩提得如来冥加力故。闻说必能解。有此四义故。云不足为难也。若当来世。其有众生。得闻是法。闻信解受持。是人则为第一希有者。须菩提自言。我值佛现在。具上四义。故生信解不以为难。如来灭后。既不值佛世。若能于此经生信。是人则为登初地已上第一希有人也。初地所得。胜地前二乘凡夫。故云第一也。希有者。一大阿僧祇行满始得。地前未阶。故云希有也。何以故。此人无我相。乃至当知是人甚为希有。此犹明当末世中生信者希有。然就此第五门中。有三。何以故。初明法空。后明我空。第三释疑。前三何以故。并释是人则为第一希有。此二何以故。若因释第一希有者。有何异也。初何以故者。明信解受持此经人何以故得为第一希有也。即答是人无我相示明以空得初地法空解故。能信此经。地前凡夫二乘未解法空。故不能信也。故知证而能信者第一希有也。第二何以故者。问云。为当唯得法空解故能信此经。为更有所得而能信也。即答。我示相即非相等。答意明非但得法空解故。能信解此经。亦得我空解。故然后能信也。故复明第二何以故也。第三何以故者。闻前无我相等明法空。复闻我所相即是非相。明我空。释能取所取皆空。即生疑念。今现见内六入是能取。外六尘是所取。何得言是空。若皆空者。不应有能取所取。故云何以故。故答以离一切相。则名诸佛故知空也。明诸佛见此能取所取我之与法虚诳不实。以皆是空。故所以离也。此明法空者。但论因缘法空。不明佛性法空也。佛告须菩提如是如是等者。上来须菩提虽说当来世人有能生信者是初地已上第一希有。恐人疑谓此言未必可信。故佛印之如是。如须菩提所说。莫生疑念。故重衣如是如是也。若复有人。得闻是经。不惊不怖不畏。当知是人甚为希有者。此犹成前第五段。明须菩提言所以不虚可信。正如是者。明此人已得初地无我之解。离五怖畏。无有疑浊。故闻经不惊怖畏。若依世辩解义。以后释前。何故不惊。以不怖。何故不怖。以不畏。如是次第也。又复不惊者。谓身相中待初地无我解。离五怖畏。闻诸法无我。身无惧相。故曰不惊。不怖者。在于心中。闻诸法无我。内心决定不疑。故曰不怖。不畏者。身心毕竟不谤也。又解明此人以得闻慧解故。初闻大乘无我教。一住情安于理。故曰不惊。得思慧解故。生深信不疑。故曰不怖。既生信已得修慧之解故。修不毁谤。故曰不畏也。当知是人甚为希有者。如来重举述成上文。不异前释也

何以故如来说第一波罗蜜非第一波罗蜜。明第六段。论释名胜余修多罗也。然此何以故者。总以下第六第七第八段。通释成前五章门义也。云何释。上释云。何以故舍恒河沙身命布施。不如受持此经一四句偈之福。复次须菩提既得慧眼。何以故未曾得闻此经。名为希有。又复此经。何以故。非凡夫二乘测量境界。又复何以故。受持此经。能生实相之解。二乘法中无也。又复何以故。要得我法二空解人。能信此经受持修行。得为第一希有。上五章门义。何以故如此等。故答。如来说第一波罗蜜等。以此经是如来果头第一彼岸功德胜余修多罗故。复以此经能与佛果作大因故。复非但与佛现果作其胜因。乃与十方诸佛作胜因。故得释成也。又复一解。直以第六章门。释前五章门也。如来说第一波罗蜜者。明佛果彼岸前胜功德。故云说第一波罗蜜也。泛明波罗蜜。有于三阶。一是地前相似波罗蜜。二是登地以上真实波罗蜜。斯二皆是因中之行也。今言第一波罗蜜者。乃是果头法身常住彼岸功德。故云第一也。依论释名胜余修多罗者。明理本胜于教本故。言教非无为法身。故云非第一波罗蜜。又复非者。非前二波罗蜜也。又复非者。非二乘境界。亦云为非也。如来说第一波罗蜜者。此第七段论名大因。大因者正因也。正因者。即清净法身广大理也。明释迦如来自云我由受持此经故。解无为法身。证得佛果彼岸功德。故云如来说第一波罗蜜者也。彼无量诸佛亦说波罗蜜者。此第八论名清净也。前云第一波罗蜜能与如来现果为大因。为当唯释迦如来受持此经独证独说以为大因。十方诸佛皆说我因受持此经故。证得佛果。因行因说以为大因也。故答云。彼无量诸佛亦说波罗蜜。明彼十方诸佛皆言我因受持此经。解无为法身。故说于佛果。非我独行独说名为大因也。是名第一波罗蜜者。通结上三句。为果头第一彼岸功德也。以此经中有上八种功德故。胜舍身福也

论曰自下经文重明彼福德中此福转胜者。论主将欲作偈释此一段经故。无略解经中所明持经福德转胜之义也。上以引三千恒沙无量珍宝布施挍量不如持经福德。明舍外财则易故。未是显胜中之上。今明舍于内财以身命布施则难。虽难而能舍。犹亦及持经之福。岂非显转胜之义也。此中以二偈作八章门。释此一段经也。苦身胜于彼者。释经中佛言须菩提以下至涕泪悲泣。明舍外财则易。舍内财则难。以众生多于己身爱恋情重。若舍则有大苦。以为法故。虽苦而能舍。是故舍身胜彼舍外财也。然虽胜舍舍外财。犹不如持一偈之福。故言胜于彼也

希有者。释经中扪泪而白佛至得闻如是法门。明此金刚般若果头甚深法界唯是如来所得。须菩提虽得罗汉具十智等功德。而未曾闻此甚深法门。故言为希有也。及上义者。其彼智[垢-口+ㄒ]难量。同释一经故。钩锁入第三分。复及成第二希有。上虽云须菩提未曾有闻。未知何故不闻。以此法是如来果头彼[垢-口+ㄒ]功德第一上义。非二乘境界。所以不闻。以不闻故。名为希有。故云及上义也

彼智[垢-口+ㄒ]难量者。正释经中第三佛说般若波罗蜜即非般若波罗蜜。此与上义。文同而意异故。别为第三段。彼智[垢-口+ㄒ]者。胡言般若波罗蜜。汉言智慧彼岸也。难量者。明此智岸是如来果头彼岸。而此绝于下地二乘图度境界。故云彼智[垢-口+ㄒ]难量也

亦不同金法者。释经若复有人信心清净至实相实相等。此经明如来法身常住实相之理。二乘外道法中所不明。小乘外道法中既所不明。亦不生信。故云亦不同余法也

坚实解深义者。释经世尊我今得闻至甚为希有。明我空法空经文。所以名坚实者。以此菩萨登于初地。现前得二空理中。真解不可岨坏。故云坚实。此解所以不可岨坏者。以解二种无我深义故也

胜余修多罗者。释经中何以故如来说第一波罗蜜者等。修多罗者。此是西域之名。汉翻为本。明此经所诠证理既胜故能诠之教亦胜。以胜于二乘理教故。云胜余修多罗也。又更有一解。泛明本义。理教俱有。以所诠法身无名相理。能与十二部经言教为本。亦云能生有善故名为本。能诠言教修多罗亦与诠法为本。诠于法身。能生万善。故名为本。以理本胜于教本故。云胜余修多罗也

大因及清净者。此一句通释前第七第八段经文。大因者。正释如来说第一波罗蜜者。明此经所诠无为法身佛性之理。能与诸佛妙果作其正因。胜于了因。故云大因也

及清净者。释经彼无量诸佛亦说波罗蜜等。明诸佛同说此法名字句义。不增不减。以共说故。说必当理。无有差理之共。故名清净。又复一解。彼无量诸佛皆说。我因此佛性平等自性清净之理。证于佛果。故云清净也

福中胜福德者。以此经所辨有如上功德故。持一偈之福。胜于舍身等福也。此二偈说何义。示一段长行诠一一提偈中章门次第解已。然后举经来结可知也。就中若文有隐者。则超释之也

何以故者。有疑难云。若舍恒沙身命者。得福甚多。何故不及持经一偈之福也。即释云。彼舍身命。苦身心故。明此人当舍身时。有取相心。故身心苦恼。后得果亦苦。以因果俱不清净。所以不如。明持经之福因不取相得果清净。故胜舍身也。何况为法舍者。明直世间果报舍身命者。不如持经之福。可小。何况。复为无上菩提法故。取相心舍。亦不及持经福也。又复纵令令初地已上为菩提法舍身。虽非取相。犹亦不及。故言何况为法舍也。经中但引舍身福德不如持经一偈之福。不云取相舍。故所以不如。以此义隐难解。论主释云以彼舍身若恼身心是取相故。虽多舍身命。而不如持经是不取相也。因此彼舍身苦身心故。乘出经中玄疑。发起下忍辱波罗蜜经。生疑法用。如下经中生起不异也。释第四章门中云。以是义故者。以是除佛法余处无实未曾有未曾生信义故。唯佛大乘法中。明此无为法身实相之理。小乘法中不辨有此实相之理。故云不同余法也。如来为须菩提说如是义者。此释如来述成经文。从佛告须菩提如是如是以下。说此段经未也。彼珍宝擅等已下。通结上来舍内外财挍量不如持经之福也。彼珍宝擅等。无如是功德者。明前内外二种施中无如上来经中所辨八种功德也。是故彼福德中。此福胜者。是内外舍中无此八种功德。依此经中有八种功德故。故此持经之福。胜向舍身财等福也

论曰自下经文复为断疑等者。此是论主生序疑者意。生起下经。但生疑法用。不异经中。故不委释也

金刚仙论卷第五金刚仙论卷第六

        魏天平二年菩提流支三藏于洛阳译

须菩提如来说忍辱波罗蜜者。此挍量分中第八经文。此所以来者。前段经。明以恒沙身命布施不如受持此经一四句偈为人演说其福不可教。应云彼人取初心中舍身命布施。是有漏之因故。所以不及持经之福。论主应如是释。而所以云彼舍身命苦身心故者。为欲生起此经故。作是说。序疑者意。云何疑者。彼人舍恒沙身命。是取相心故。因不清净。所得果报不出三界。亦不清净故。得福少者。诸菩萨等。依此经修行。舍身命者。因亦应不清净。若因不清净。所感果报亦不清净。同于苦果。如似忍辱仙人。为歌利王割截身体。尔时身心苦恼。引此为难。故以经答。明前舍恒沙身者。在于地前。是凡夫人。未得无我之解。未断身见等或。故有取相心。无忍波罗蜜。当舍身时。情生苦性。以此舍身难。以为法故。虽难能舍。复谓无为法身。因于人天有为果报。有此分别故。所得因果。俱不清净。今明忍辱仙人乃是初地菩萨。解法身是为。已得无生忍度。成就离取相心。舍身命时。心无烦恼。故不以为难。以是义故。因是清净。果亦清净。此之二人。既凡圣位殊。何得以凡夫舍身有苦。难于圣人。依经修行舍身者。亦使有苦。为除此疑故。故次明也

如来说忍辱波罗蜜者。明如来说依经修行。谓菩萨等已证初地。出生忍波罗蜜故。无有取相之心。舍身之时无故。言如来说忍辱波罗蜜也。即非忍辱波罗蜜者。明此初地所得忍波罗蜜。非地前凡夫二乘所境界。故言即悲忍辱波罗蜜。此明地前凡夫未得初地忍波罗蜜真无我解。犹有取相之舍。身有苦。不得以此比类引之为难也。何以故知。如我往昔为歌利王割截身体。应生嗔恨。明忍辱仙人得初地无生。会真无我解。离二种烦恼。何者为二。一者无始妄想我见俱生烦恼。既有此我见故。便成就三不善根及三善根性。后时遇缘则起也。二者嗔恨等堕烦恼也。此言何以故　　释上何以得知。我于尔时。已证初地忍波罗蜜。波[垢-口+ㄒ]功德。非是地前凡夫。故言何以故也。故引如我昔为歌利王。以答之。歌利王者。此幡恶王也。明如来因地时曾现作外通仙人。在山学通。为王射猎问鹿因缘。仙人说语答。王不正敬。即为割截身体。节节分解。不生嗔恨者。以得初地无生真无我解一体平等心。不见彼是恶王我为能忍。故不生嗔恨。以是故知。忍波罗蜜唯在初地上法也。不得以地前舍身有苦是其不如。难于忍波罗蜜亦使是劣也。我于尔时无我相等者。明仙人离于我见俱生烦恼也。此我相等四句释不异上第六段中。故不更释也。无相者。明此菩萨既证初地真如无我一体心成故。不见彼是恶人能割之者我为菩萨是受割之人。彼此隹夷氓然平观。故言无相也。得云无相者。何但无有我相。乃至亦无无我相也。又复解云。以此菩萨既道证初地。得一体悲心成故。冥然无分别。不见有彼以。义异恶人恶人异我。故言无相也。乘此复生疑难。此云菩萨不见能割所割二乘之异名无相者。为有心故言不见。为无心故不见。若无心故不见者。菩萨云何而得修行利益众生故。答亦非无相。明此菩萨解彼此无二时非是念无心。正是初地以上转胜真解无漏之心。既此解。难不见众生与己身有异。而能以慈悲心。广度众生。但利众生。不自利益也。如十地经说。一切动心忆想皆悉尽灭者。无有障法想。非无治法想。此亦如是。无有障想。故言无想。非无治想故。言亦非无相也。故不应难言菩萨得一体平等解无心修行度众生也

何以故我于往昔节节支解时。若有我等相。应生嗔恨者。释无我人一。何以得知。我于往昔。彼歌利生割截身时。离我等根本烦恼也。即释云。我于尔时。若有我等者。应生嗔恨故。以离我见之惑。得无我解。此以离嗔恨。故证无我见根本或也。又念遇者五百世作忍辱仙人至无寿者相。何故复引此来也。欲明忍波罗蜜有二种。一者地前。二者地上。非但今者初地中得忍波罗蜜成就能离二种障烦恼。于往昔五世作忍辱仙人。在于地前性地中时。此以得相似忍。深伏烦恼。为王割截身体已。不生嗔恨。况复今日在初地中。得真无我。忍行成就。而复生于嗔恨。故引此仙人为证也

是故须菩提菩萨离一切相发菩提心。此文所以复来。明是故者。以是初地以上得真如实智平等无我之解。忍波罗蜜成就。能忍苦行。于天上菩提。不生退转故。以是地前未得无生忍波罗蜜成就。见苦行若。于无上菩提。喜生退转故。是故劝励地前诸小菩萨。应当离一切法中所相之菩发三菩提心也。言发三菩提心者。劝地前人。发初地以上三菩提也也

何以故者。问何以故。劝地前人。发初地不取相真无我解三菩提心。故答若心有住则为非住。明若心于色等有为五欲法中。有取相心。住者之倒者。则住世间有为法中。非住出世间无为法中也。则为非住者。明既住世间法中。则为非住于初地不住道真无漏解出世间法也。不应住色等生心者。不着果报。应生无所住心者。不应报恩阙不论。不着自身也。是故佛说菩萨心不住色布施者。是故怀取相心者。住于世间。不能住于出世不住道中。故上第四如实修行分中。佛说不着三事行于布施。故云心不住色布施也

因前不住世间不见三事。乘生疑难。若菩萨得出世无我平等解故。不住三事。复不见施者等三。若尔菩萨出于世间。众生没在世间。复言不见众生。若尔菩萨云何有施能利益众生也。故答云。菩萨为利益一切众生故。应如是布施。明若取相心施。尚不能自利。况能利他也。安以不取相心行施。故能利益一切众生。如我上说。如是不取相心而行布施。得福德无量也

覆生疑难。若言为利益众生行布施者。则还是取众生相。云何上言菩萨于平等理中。不见我为菩萨彼是众生相也。故答世尊一切众生相即是非相。此明一切众生相者五阴所成假名名字虚妄众生但有名用也。即是非相者。明此虚妄众生及以五阴中本来空寂。求定实神我众生及以定实我所不可得。故言即是非相。此明人无我空也

乘复有疑。若一切众生。本来无我我所。空故不可得。即是非相者。如来。何故于处处经中。说有众生。如此经中说卯生等众生。以此来验。故知实有众生。那得道言众生即非众生也。若尔正可无定实神我众生可度。故言一切众生即是非相。然非无五阴所成虚假众生。何故不度也。故答如来说一切众生即非众生。明如来依世谛道中说有众生。非谓有定实众生。此正以五阴法来成彼虚假众生。此五阴法。自体本来空寂故。此五阴所成假名众生亦空。故云即非众生也。此明五阴因缘法体空乃至假名亦无也。故亦无虚假众生可度也

此一段经。凡以五偈释。能忍于苦行一偈。作上问答意释疑也。能忍于苦行者。初二句释经中忍辱波罗蜜。此明初地菩萨忍有二种。一能忍打骂割截之恼。二得无生忍。能忍说法生灭之患。故云能忍于苦行也。何故能忍。故下句云。以苦行有善。有善者。得忍波罗蜜等无漏功德真如证智理之解。故言以苦行有善也。彼福不可量者。释经即非波罗蜜。明初地所得忍波罗蜜非二乘凡夫之所恻度。故云不可量也。如是最胜义者。成上不可量。明初地菩萨得忍波罗蜜会二无我第一之法。于住前凡夫二乘所不能及。故言最胜义也

第二偈释经仙人为歌利王所割无二种烦恼忍不生嗔也。离我及急相者。此一句明菩萨昔曾为仙人被歌利王割截身体虽二种烦恼。一离我见俱生烦恼。二离嗔恨等容尘烦恼。离我者。离我人见等根本惑也。及恚相者。离嗔恨等容尘烦恼惑也。此明初地菩萨永断四住及习气皆尽也。实无于苦恼者。释经中无相。苦本由于着我我所。菩萨既离我我所。何恼之有。故云实无于苦恼也。苦乐有慈悲悲者。释经中亦非无相。共乐者此明菩萨从发心以来。恒在心念。我何时当得慈悲成就。身如地水火风。能实益众生。是故菩萨既会初地无生。得一体心成。故能以慈悲实益称本愿心。故共乐也。明何故无苦。以有忍波罗蜜第一之乐。何故得此第一之乐。以得一体慈悲心相应故也。如是苦行果者。如是慈悲第一之乐。是初地所得。苦行果者。不因地前故。成上持经之福胜也。此二行偈说何义以下。此一段长行论中有。二从初至慈悲心相应故如是说。释前二偈也。虽此苦行同于苦果。而此苦行不疲惓者。论主将正答疑家所引舍身无苦。先略领疑意故。言虽此苦行同于苦果也。明忍辱仙人为歌利王割截身时。此苦行虽似同前舍身。而此苦行不疲惓。以仙人被割截时不以苦行为苦故。于此舍身苦行。情无厌惓。于无上菩提。心不退转也。以有羼提波罗蜜名为第一者。明仙人所以能于舍身无惓。于菩提不退者。以得此初地羼提波罗蜜成就故。不生苦恼。不同地前人舍身生苦。那得之为难。此释偈中初句也。彼[垢-口+ㄒ]有二种义者。释偈中第二句以苦行有善。解经中波罗蜜义。一者波罗蜜清净善根体者。初地真如证智清净善根万德之体。二者彼[垢-口+ㄒ]功德不可量者。明即此证智体上有万功德之用也。此万德用非二乘凡夫恻量境界。故言不可量也。此句解波罗蜜义竟。乘作非波罗蜜义也。如经即非波罗蜜者。即乘举第二句经来结。然后解作非波罗蜜义也。是故为得第一法者。是初地忍辱波罗蜜。非地前凡夫二乘恻量境界义故。说地前人未得无我之解。但为得初地忍波罗蜜第一法故。此苦行尚胜彼舍身。何况仙人已证初地。离于我相及嗔恚相。而当不胜前舍身也。此句结胜前舍身。即释第二偈上句离我及嗔恚相也。又此行无苦者。释偈中实无于苦恼也。不但无苦。及有乐以有慈悲故者。释偈中其乐有慈悲也。如经结也。此明慈悲心相应故如是说者。论主自言。我何故作偈云实无于苦恼共乐有慈悲。释此经中无相亦非无相也。以得一体慈悲相应故。舍身时无苦而有乐故。得说偈中二句为释故。云如是说也

若有菩萨不离我相等者。此长行论中第二将欲作第三偈。释经中菩萨应离一切相主心不住色有施故。先玄举凡夫菩萨未得无我解于苦行生厌。复欲退菩提心。为劝此人。令修不取相不退之行。故作此生起。如经等。举所劝经结也。此明何义者。此问向论主生起举经结中为明何义也。即释云。未生第一菩提心者有如是过。明未证初地第一菩提心者。喜见苦行若有退菩提心过也。为防此过者。为防退转过故。即作第三偈。释经中防过之意云。为不舍心起。此第三偈。明为初地不舍菩提心故。起地前不取相行。释经中是故菩萨应离一切相发阿耨菩提心等。不舍心者。谓初地不舍菩提心也。明地前菩萨未发初地无我心者。见苦行苦。苦有退失。今言为者。教地前菩萨为初地不舍菩提心故。起地前方便不取相行。趣于地上真无生忍坚固解故。之为不舍心起也。修行及坚固者。上句云起。此言修也。明初地无生之解永不退转不可组坏。名为坚固。所以修地前方便行者。为证初地无生坚固之解。故云修行及坚固。上句云为不舍心起。此言修行及坚固。义一名也。为忍波罗蜜者。释前二句。然前二句。释义已尽。所以有此四句綩转相释名为成偈故也。此第三句还释成初句明初地所以得不舍菩提心者。以其得忍波罗蜜成就故。不见苦行苦。不舍菩提心也。忍波罗蜜犹是初地无生之解也。习彼能学心者。此第四句。释上第二句。习者修习也。彼着。彼于初地无生坚固解也。能学心者。是初地前方便行也。明为彼初地平等无上坚固解故。习地前方便能学心也。此能学心即是修行故。言习彼能学心也。此义云何等。一段长行论。略有二意。从初至摄六波罗蜜故。此释前偈也。为何等心起行相而修行者。问偈中第二句也。为何等心不舍相者。问偈中初句也。若作次第。从初句问亦得。此作二问竟。以下半偈答云。为忍波罗蜜习彼能学心也。又第一义心者。提偈前生起中第一心来也。已入初地得羼提波罗蜜者。属当下半偈中忍波罗蜜。以为已入初地第一义心也。答向二问竟也。此名不住心者。此忍波罗蜜。是初地不住道心也。如经以下。重举经结也。何以故者。问此经中何故云应离一切相发三菩提心。故言何以故也。即释云。亦不住生心义故。示于色等法中不取著者。能证初地菩提心义故。此释经中何以故若心有住则为非住也。若心住于色等法彼心不住佛菩提者。此明于色等法中取著者。不能证初地菩提心也。此释经中不住色生心乃至心不住色布施也。此明不住心行于布施者。此结次前所释二句经也。此经文说不住心起行方便者。此向来经文明若能起此不着心者。便得与初地为方便因也。以揎波罗蜜摄六故者。如上第四如实修行分中以一摄六。义可知也

云何为利益众生而不名住于众生者。此是偈中第二意。论主将作第四偈释经故。先作生疑之意。即举断疑经来结。后方以偈释之也。此第四偈。明离众生相及五阴事也。释经中菩萨为利益一切众生应如是布施等一段经。修行利众生者。此一句偏释为利益一切众生应如是布施。此中有疑。若不见三事。不取众生相。云何行施。因义得成也。故答云。修行利众生。明菩萨虽不见三事不取众生相。然非不为利益众生行于布施。因义得成故。下句云。如是因当识。如是因者。初地檀波罗蜜即走了因行也。因义既成。劝人识知也

乘复生疑者。为利益众生行布施者。即走取众生相。故下半偈答云。众生及事相远离亦应知。此释经中一切众生相即是非相。远离者不取众生相也。亦应知者。明非但离众生。亦远离五阴事相也。以此即知。初地菩萨利众生行诸度者。非取相行也。利益是因体者。释上半偈。彼修行利众生非取众生相事者。释下半偈。何者是众生事者。作问生起第五偈。此第五偈还成前第四偈。释经中何以故如来说一切众生即非众生。云何成第四偈。上直云远离众生及事定实之相。未知此众生五阴何故无有定实所以而离。故此偈正出也。假名者。假名名字众生也。及阴事者。五阴相事也

又复生疑。上云离众生相者。正可无定实众生可度。非无虚妄众生。何故不度。故答云。如来离彼相。此五阴所成众生。其性不实犹如幻炎。本来寂静故。亦无五阴所成虚妄众生而可度也。诸佛无彼二者。不异前第二句。然阐陀论法。一句两句乃至三句。释义虽尽。要须成偈。故重举来也。以见实法故者。明如来何故离假实二种相者。以见真如实法第一义谛证于佛果。无此二相。故知众生及与五阴。体是虚妄。本来寂静。以不实故。如来远离。若是实者诸佛应取也

此说何义等。一段长行论。从初至人无我。释偈中初句。成前第四偈也。名相众生及彼事者。谓初句中假名五阴事也。云何彼修行离众生事相者。问前第四偈中言菩萨修行利益众生时云远离众生相及五阴事相之义竟云何也。故释云。即彼名相想非相。明假名众生即体虚妄。故云非相也。以无彼实体故者。此假名众生所以空者。明假名法中求实众生体不可得也。以是义故众生即非众生者。举经来结也。以何等法者。以何等法来成此众生。而言众生体空也。即答谓五阴法名众生。明以五阴和合即此法上假得众生名也。若五阴和合得众生名者。便有众生。何故言空也。释云。彼五阴无众生体。明此众生虽为五阴众生。而此五阴中从本以来无实众生可得也。自前论释人无我空也。以无实故者。明因缘法无我也。所以五阴中无众生体者。以此五阴如幼如化即体自空。此明能成五阴体空故所成众生亦不实也。如是明法无我人无我者。结二无我名也。何以故者。何以得知此众生五阴体空不实也。释云。一切诸佛离一切相等。明诸佛离故证众生五阴体空也。此句明彼二相不实者。此句论向语佛所离二句。明以二相不实故如来离也。即以偈中下三句结成也。此说何义者。问此偈下三句说何等义也。即释云。若彼二实有者。诸佛如来应有彼二相。明若彼众生五阴实有不空者即是第一义谛诸佛如来应有此二相。而诸佛离故。明知此二不实也。复精释何以故若此二是实便如来万德中应有。以诸佛如来是见真如实谛之人。而不见此二人。又复离之。故证众生五阴假实俱空也

须菩提。如来是真语者等。此一段经。是校量分中第九经文。此所以来者。犹远释第六段圣人无为法得名。是法不可取说者。受持此经言教。则无福德中疑也。然挍量分初以来已广释云。假令三千恒沙七宝及舍身命施人福德虽多。犹不如受持此经一偈之福。虽复如是挍量如是广释。大众生疑心犹故未尽。复因前舍恒沙身命不如受持一四句偈。更复生疑。如是上虽广解所证法身之体绝于名相言诠所不及。又云十二部经言教法中无所诠证法。若然此能诠之教犹与所诠法身。条然有别。而此言教则还为非法。何得受持一偈言教能得法身。胜于舍无量身命之福。直尔生疑不信也。既有此疑。如来亦应更引喻挍量。而所以不更挍量者。因此言上。恐复生疑。疑终不尽。然假使如来无量劫住。广引舍内外身财挍量。亦复不及持一偈之福。故如来置答。直劝其言。但信我语。勿复生疑。我是一切智人。终不诳汝。故经答云如来是真语者乃至不异语者。明赞如来说四法等。皆悉不虚。劝人信我诚言。故次明也。须菩提如来是真语者。明如来是一切智人。证得果头十力无畏诸功德等。如已所证。还为人说。如实不虚。故云真语者也。如来为小乘人。说四谛法。此声闻人。观四谛理。断三界结。得小乘果证。然虽非究竟之实。当其分有观境除得不谬。故云实语也。如语者。明如来为诸菩萨。设真如佛性。是其大乘自说而说如理不谬。故名如语也。不异语者。明如来说三世之事。称法虚实。终无差错。故云不异语也

须菩提如来所得法所说法者。如来自说。我亦因受持此经言教法故。证果头无为法身。既证还为人说。终不虚妄。汝等应当生信。句复疑也。所得法者。谓证法也。所说法者。谓言教法也。既闻此说。复乘生疑难。若如来言我证得此法。还为人说。劝我生信者。此所证法即是可取可说。因于名相。若尔还后同我前疑。上言证法无名相不可取说者。此言则坏也。有如此疑难。以答言无实。明今言所得所说者。依世谛名相道中。言有得有说。非真如理中有名相故可说也。然真如之理。从本以来。言语道断。心行处灭。故无得无说也。何得闻言有得有说便使证法同于名相可取说也。证法既非名相。若谓证法同于名相可得可说者。此则不实也。覆生疑难。若证法一向无名相。何故如来前言。我是真语实语者等。劝使受持能诠经教。今复云。前说无实。此二言相违。若尔还同前第二疑。条然离于证法。有能诠言教。此言教则是非法。设受持读诵。无所利益。上云言教是法有其因义。此语则坏也。故云无妄语。明如来实证真如。还说真如法。此言教从证法中来。是彼一分故。不云一向非法。而此言教既说真如。故受持此经教。还能证真如。有此大利益事。故不妄语也。论曰此中有疑等。论主将作偈释经。先略序生疑之意。复举经略申断疑之义也。凡有三行偈。释此一段经。初偈作问答意。释疑。总举四语。以劝信。上二句释前疑问。下二句释。举四语来。劝信之意也。果虽不住道。而道能为因者。果谓证法果。道者言教道也。此一句应云言教之道不住证法果中也。而此教道。还能与证法作因。言教显出证果。故为因也。上难云。证法无名相。言教是名相。此名相法。云何能与无名相法作因邪。故答以诸佛实语。此明诸佛是一切智人具四种实语。说心当理。但信勿疑也

有人乘生疑难。如来所智境界。有无量无边。何故唯说四语。故答彼智有四种。此明依于四境但云四语。然此四境虽名狭。而义广论。法虽无量。不出佛果小乘大乘及三世有为法等。以此四名。摄法皆尽故。略明斯四也。此本偈两句。与下第二偈。为章门别释。备文在于下偈也。此义云何至有四种实但。释下本偈为乘生第二偈也。第二偈正释四种智境也。实智及小乘者。此一句合释二语。实智者释经真语也。小乘者。释经实语也。说摩诃衍法者。此是胡音。汉翻名大乘。释经如经也。及一切授记者。释经不异语也。以不虚说故者。是疾转义。遍上四句之下。皆言以不虚说故也。明如来既有四种实语。凡有所说。皆不虚妄海。汝等大众于我言不说持经功德。但生深信。勿是怀疑。故明四种语是实以成不虚也说

此明何业等。一段长行论。大意有二。从初至不颠倒。次第释偈。以经结之。复言设难已。又次第广解具难也。以如来实智不妄说佛菩提至次第说四语。并解偈中四偈也。如经以下。并以经来结四语也。不妄说小乘等者。所以提此句来。论主假设难云。如来所说大乘。理是真实。果是究竟。可名实语。为小乘人。说于四谛。理非究竟。虽证罗汉。果未满足。然诸大乘经中复广破小乘云非是真实。云何而言。说于四谛。名为实语也。释云。说小乘苦谛等唯是谛故。明如来说四谛等法。小乘人依教修行。得性空人无我解。断四住烦恼。证罗汉果。但于小乘为实。故言唯是谛故也。不妄说授记者。复假设一难云。此三世之法。流动不实。体是虚妄。云何言。说三世事者。名不异语也。释云。一切过去未来现在授记故如彼义如是说不颠倒故。如彼义者。如彼三世法。虚则如虚而说。实则依实而记。故不颠倒也

经复言须菩提如来所得法所说法等者。此是长行论中第二意。将欲作下第三偈释故。先举此经来。作问生起云何。故如是说也。第三偈随须彼实智说不实不虚者。释经中所得法所得说法无实也。随须彼实智者。释经中如来所得法所说法无妄语。明如来难以音声言教。说于证法。而证法恒无名。故能诠言教非即证法。然言教虽非证法。非不因证有说假教得证。以此言教能与证法作因故。言随须彼实智也。既不实不虚者。释经中无实无妄语也。明真如证法绝于名相。若取音声名相。同于证法。此言虚妄。故云说不实也。然虽声教非证。非不同。证有说。还假教会理。言教是法。故言说不虚也。如闻声取证对治如是说者。问前经中如来自言。我是真语者等四种实语。复言取得法所说法无实无妄语。此之二经何故相违。故即以下半偈答。如闻声取证对治如是说也。答意恐畏众生寻声取证。谓真如法即同声教。是其名相。作如此意。对治此取着。故教言莫如所闻声取证法也。对治如是说者。对治如声取证故。或是不实。或说不虚也

此义云何等。一段长行论释有二意。从初至依字句说故。释上半偈。解经中所得法以下经文也。诸佛所说法乃至不能得彼证法。释偈中初句也。何以故至是故无妄语。释偈第二句也。若尔何故说如来所得法所说法者。作难。若如所闻声取于证智。是不实者则证法一句不可说。何故如来自云我所得法所说法也。即释云。以依字句说故。明证法无名相。不可得说。然非不依于言教玄谈前理也。何故如来前说是真语者。复言所说法无实无虚妄语者此是长行论中第二意难。执如来经中相违之言。设难。举下半偈来。释解问答意。不异偈中也

须菩提譬如有人入闇则无所见等。有二段经文。此是大段中第八分。明一切众生有真如佛性。此段中明一切众生有真如性。即因以为名也。以何次第起。因上第六段中一切圣人皆以真如无为法得名。生第八疑。乃至第七段中广释一切圣人皆以无为法得名。疑者云。应言一切众生皆以真如无为法得名。何故但言一切圣人以无为法得名也。所以应然者。如上第三段经常心中言。者菩萨有众生想。即非菩萨。明者菩萨于一切众生不起我心者。不名解真如菩萨。要解一切众生平等有真如佛性我者。乃名菩萨。然此菩萨证初地时。解一切众生如我身。以一切众生真如佛性。我身所有真如佛性。平等无二无差别故。取众生如我身。又处处经中道。一切众生皆有佛性。若一切众生与圣人真如理同者。何故一切众生有取着心者。不以真如清净得名。独诸佛菩萨无取着心者。以真如清净得名也。故知圣人以真如法得名者。可有佛性。一切众生不以真如得名。则无佛性。若众生本无佛性。圣人修行因缘。后时始得。无佛性则是本无今有便是无常

又复若真如佛性一切众生平等有之。何故有人得见。有人不见也。有如此疑故。引入闇等喻来答。答意云。真如佛性虽复一切众生有之平等。明诸佛菩萨修行断惑故能见性。一切众生未能修行断惑故。所以不见也。然见惟断惑者。以真如清净得名。若不见性未断惑者。以不真如清净得名也。明凡圣二人虽复有之平等。以见不见差故。不应以一切众生等共有之。设使皆以真如清净得名。为除此疑。故次明也。如人入闇则无所见。此一故经有二种喻。喻愚智二人。明有修行断惑者。能见佛性。以无为法得名。不修行未断惑者。则不能见性。以不能见性故。不以无为法得名也。譬如人入闇则无所见者。作喻也。若菩萨心住于事。亦复如是等者。合喻也。喻凡夫二乘诸小菩萨。有四住习气无明之闇。行取相之行。不能见真如佛性也。二乘人既证真无漏解。所以亦名取相者。然二乘人虽不取有为法相。而取无为涅槃相也。如人有目见诸色等者。作喻也。若菩萨不住于事亦复如是等。今喻也。譬初地以上。断四住习气。稍遣无明。行不取相。明智得真无漏。能见佛性等常无常理也。论曰复有疑等。此中论主将欲偈释于此经。略书疑者之意。生起下偈也。者圣人以无为法得名者。提前第六段中生疑处经也。彼真如一切时一切处有者。执第三段经为难也。并举此两经。然后下设二难。云何不住心得佛菩提。则非不住者。君三世众生等有真如佛性者。一切众生应皆以无为法得名。云何唯诸佛菩萨有不住心者得佛菩提。有不住心者。得佛菩提。以无为法得名。而一切众生有住者心无不住心者。不得佛菩提。不以无为法得名也

若一切时一切处有真如。何故有人能得有不得者。此重牒经故。设第二得见不见难。依下论可知也。为断此二疑难故。略引入闇喻经。申断疑意。下作偈释也。凡此二偈释斯一段经。初一偈作问答意释疑。上既有疑问于前。故偈答言。时及处实有。时者。谓三世时。佛性之体乃无三世。众生有三世。故逐众生。云三世也。处者。三世中一切众生处。此表异木石无情物也。实有者。此三世众生实有此佛性。如疑者意不异也。而不得真如者。明疑难云若时处众生实有真佛性者。何故不得也。故第三句云。无智以住法。无智者明二乘凡夫未得初地无漏智也。何故无智。以心住法故。住法者。明地前凡夫二障在怀。故有取着之心也。以凡夫二乘取着行故。不能见真如佛性也。余者有智得者。明入地以上菩萨及诸佛如来得出世胜解。能见此佛性也

长行论云。此义云何以下至是故能得。论主此中凡作三问答。释前一偈。依论可知也。以是义故。诸佛如来清净得名。是故住心不得佛菩提者。并诘得名不得名之由也。第二偈通释经中闇明二喻并。合也

闇明愚无智者。闇明两字。双举二喻。以为章门。下次第合喻。愚者单合上闇字。即释何故名愚。以其无智故。此一句中。下三字释。合闇喻竟。明者如有智者。明者。还牒上句中明字喻。合有智者故。言如有智也。对法及对治等。自下半偈。释第二喻经。对法者。举初入闇法。喻所治法也。及对治者。举喻中明合中智法喻二也。得灭法如是者。得者。得明智能治法。灭者。灭愚闇所治法。如有日光明对治能灭于闇也。以不取相布施之解。对治心住于事取相愚心故。言对治法及对治得灭法如是也

此义云何彼闇明喻者相似法故者。闇明愚智法喻义有相似。故以况也。闇者示现无智。日光明者示现有智等。一一别合二喻。此释上半偈也。有目者。明何义者。向虽通解闇明二喻。犹未出喻来之意。今将以下半偈。释第二喻经。结作能治取治之义。故提经来。问曰有目者明何义也。即答得言对治及对治得灭法如是也。如是次第者。光明对法及后明对治也。又有目者以下。次第提经。解脱治。后以经结也

复次须菩提若有善男子善女人能于此法门受持读诵修行者。此是第八段中第二经文。此经所以来者。前段经。明一切众生皆有真如佛性。引闇明二喻。譬修行者见不修行者则不能见。难云。修行者见。未知依何等法门修行。以何方便。以何为因。而得见真如佛性也。有如此问。故引经答。明依此金刚般若及诸大乘经受持读诵三种修行成就胜业。以此方便万行为因。能见佛性。故次明也

就此一段经中有二。一明三种修行。二明校量功德复拘锁入下第九利益段中。何者三种修行。一者受修行。谓从他边受也。二者持修行。内自诵持不令妄失。三读诵修行。更广读众经。亦名修行。此三种修行皆摄在闻慧。不通思修二慧。故经言若善男子善女人能于此法门受持读诵修行也

因前三种修行。乘复生疑。如来虽说受持读诵修行能见佛性。未知此依经修行人。为决定能见。为当不见也。故答则为如来悉知悉见悉觉是人也。悉知者。以佛智知。悉见者。以佛眼见。悉觉者。以一切种智了了觉也。明如来自云。我是一切智人了了知见。依此法门三种修行。得见佛性。决定无疑也。因此复生疑。上虽明三种修行者能见佛性。未知见此性时。得几许功德。为多为少。有如此疑问。故答言。皆成就无量无边功德聚。明修行见性成道证无为法身时。果头所得功德不可限量。非算数所知。何得疑云得几许功德为多为少也。此是因中说果也

须菩提若善男子善女人初日分以恒河沙等身布施主为人广说。举此舍身喻来。挍量持经功德。上第七段中。以广明挍量功德。所以此中复明挍量功德者。上疑云。受持读诵修行此经。能见佛性。未知见佛性时所得功德。为多为少。前以法说。明得无量无边功德聚。虽有此答。犹未显多福之义。故复引世间少分譬喻。挍量以答此义。明依经修行见性功德。非算数法。不可限量。舍身福德是有为取相数量法故。虽多不如。此明多分无量。非少分经

前挍量分中。以明舍身譬喻。有何胜。故此中复明。凡有二种胜。一以所舍身。二时劫长远。有此二胜故重明也。若复有人。闻此法门。信心不谤等。明直尔闻经信心不谤。尚胜舍身福德。无量阿僧祇。何况有能书写读诵如说修行为他演说者。其福转多无量阿僧祇也。此一段经。凡以三偈论释。初一偈与前后二段经论中五偈为本。上一句生此一段中第二偈。第二句生中此一段。第三句义生下利益分经。正与下利益分论中三偈为本。第四句通结上三句二本以为修行也。于何法修行者。问依何法门修行。能见佛性也。覆问修行见性得何等福德也。复成就何等者。又问为直以受持此经故能见佛性。复成就何等胜行。能断惑见性也。如是说修行者。上问。云何修行能见佛性。名为修行。故云如是说修行也

此初一偈。总生两段经。与五偈为本也。于何法修行者。提偈中初句问来也。示现修行者。答上问。明示现依此经教受持读诵三种修行。生下第二偈也。此第二偈。答前偈上句于何法修行。正释经中三种修行受持读诵等经文也。名字三种法者。犹是经中三种修行。故第二句指出其事。谓受持读闻广说。即是名字中三种闻慧也。上虽云三种闻慧体。未知修之方法竟复云何。故下半偈云。修从他及内得闻是修智。修从他者。从他诸佛菩萨善知识边闻法。即受修行也。及内者。既受他受得内自诵持不令妄失。即是持修行也。依西国。诵法有三种。一大声。二小声。三默诵也。得闻者。明闻不但受诵。名为闻慧。但能转读众经。亦名闻慧。此是读诵修行也。是修智者。以此三种闻慧智通。结为三种修行闻慧智也。此说何义至受持读诵故。释上半偈。以也结也。彼修行云何得以下至为得修行故。作问生起以下半偈来答。然后次第解释也。向说名字及以修行等。牒前生后偈也。第三偈答初偈第二句得何等福德。释经中挍量经文。此为自淳熟者。此牒前三种修行。明三种闻慧成已自行之德也。余者化众生者。明广为他说成利他之行也。前已明。此何故复重举来也。将欲以喻挍量故举。前自行外化持经见性之时得几许福也。今明见性会无为法身时。得无量无边功德。不可限量。虽不可限量。且引三时舍恒沙身。比持经功德。犹不及少分。故重来也。以事及事大者。事谓所舍身事也。时谓劫数多也。明于多时中舍无量身故。云以事及时大也。福中胜福德者。明舍身持经二种福德也。此二种福中。持经之福胜舍身之福劣。故云福中胜福德也。此义云何至广说法故。上半偈也。得何等福德以下说未问挍量义。以下半偈答次第解释。然后以经结之。依论可知也

金刚仙论卷第六金刚仙论卷第七

须菩提。以要言之。此经有不可思议不可称量无边功德者。此是大段中第九名为利益分。此经所以来者。前第八段中。明一切众生虽皆有真如佛性平等无差。要修行者见。不修行者则不能见。上已明依此经受持读诵三种修行能见佛性。然犹非究竟胜行。未知为直依此经三种修行得见佛性。为复更成就何等胜行。有何等利益。能见佛性。见佛性时。得何等果报。故今明不但依此经三种修行能见佛性。要更依经发思修二慧。复广修万行。现在能灭往罪。未来断除二障。得此现在未来现多种利益。方能见于佛性。终克常果也。然前段初偈中。言成就何业。今此中正出业体有多种。故次来也。上来已广明持此经者。得多福德。皆是利益。何故不障利益之名。所以此段独得利益之称者。然上来虽明依此经修行有多利益。未若此段明由持经因缘。发生思修二慧。能转过去重业。现世轻受未来复得世间出世间二种果报。以有如此多种利益。故偏名利益分也

然依此经修行。乃有无量利益。且依此一段作九种章门。或作十种。以利益之义。故经初言以要言之。即是略列九种章门。以明利益也。何者为九。一者。此经有不可思议不可称量无边功德者。论云。非余者境界。明此经理深重有无边功德。故先举如来所说法也。不可思议者。明此经所诠无为法身。是诸佛境界故。二乘凡夫不能恻也。不可称量者。明经有大功德。不可以算数。称量诸佛大人境界。故下句云无量功德也

二者。此法门。如来为发大乘者说。为发最上乘者说。论名唯依大人说。此出所为人。明经理既深。小根之人所不能受。唯为菩萨大根者说。为发大乘者说。此是地前菩萨始发心人。为最上乘者。此明不但为始发心人说。亦为如实修行者说也

三者。依下偈论释。初偈第三句云及希闻信法。明此经希有信者难得。准偈中。应别有第三段经。但能信之人及所信法。不异前二段经故。义有文无。应举不信之人。形出能信之者。但以此不信之人义通前后。故不别出。即指下第五经文中二乘外道不信者是也。四者若有人受持读诵修行此经至无量功德聚。论名满足无上界。此明由受持此经故能生思修二慧。乃至修二种庄严。显满足法身也。如来悉知悉见是人者。上第六第八段中已明此义。今何故重明也。解云。为渐化众生令生信心故。处处明也。不可思议不可称量无边功德聚者。此明持经因缘得彼无为法身无边功德聚也

五者。如是人等则为荷担如来阿耨三菩提者。论名受持真妙法。明此持经之人既受持此经。则是能荷担法身如来大菩提也。何以故者。难云。何以故如来唯为大乘人说此法门不为小乘外道说也。故释云。须菩提。若乐小法者至无有是处。明此二乘诸见外道各执已解故。所以不能于此经生信。既不生信。亦不为人说也。此一段经。皆明持经利益。何故乃举乐小法人及以我见外道等在此中也。欲明斯二人于此经中不能生信。既不生信。则亦不能受持读诵如说修行。既不能受持。何能荷担也。上第三段指不信之人。在于第五。即此文所明二乘外道人是也。若乐小法者。明二乘之人心小意侠志无远悕。闻佛道长远久受勤苦乃可得成。便生怯弱退转之心。但欲一生三生乃至六十劫。劬劬行道。速出三界。尽分段生死。证罗汉果。取灰身之乐。故不能信也。若有我见人见等者。此明外道之人恃已我见为是。更无所求。不能信也

六者。须菩提在在处处若有此经者。斯一段经。论名尊重身得福。敬重。有此经处。劝人天阿修罗等。广设供养。生功德也。然此起塔劝供养处。与上劝供养处。文同而义异。上劝起塔供养者。明众生所以得人天修罗五欲乐果者。由依此经修行。五戒十善而得。故所以劝起塔供养其处。以酬往。恩此中复劝于此处供养者。明依此经修行。毕竟能得无为法身无上菩提。故劝供养如塔庙想也

七者。复次须菩提。若善男子善女人。受持读诵此经。为人轻贱者。论名及远离诸障。此一段经。出经之威力。明持经功德有二世利益。一由受持此经。发思修二慧。能转过去三涂重业。现世轻受。二因思修二慧故。十地行满。未来远离二障。必得无上菩提也。明此人先世非但有罪。亦有福德。以过去福德因缘。今得闻此经。既闻经已。复能受持。为人演说。得灭罪业。非但灭过去罪业。复能断除二障。得大菩提也。为人轻贱者。明持经功德能转三涂重业为轻。使现在为人轻贱。乃至头痛即灭。非谓由持经故招人。轻贱报也。乘生疑难。若此经有大威力。能转重业为轻。罪即消灭者。既威力如是。何故不能使罪业永尽。乃令轻报而已。答意明此经威力实非不能令永灭。但为行恶不信众生亦有善恶业报也然不差故。但令轻受不永尽

八者。论名复能速证法。从须菩提我念过去无量阿僧祇等至所不能及。此一段经。明释迦如来自引往昔初燃灯已前。未入习种性时。供养八十四亿那由他佛。虽复亲永尔许诸佛。四事供养。听受胜法。三业利益。无空过者。故挍量不如末世持经功德百千万分。不相比类。以不能速证佛果故也。有三义故所以不如。何者。一以如来在世修行供养不以为难。二所行经供养功德是取相心。三此取相之行既不能正感菩提。但能作其远因。有此三义故。不速证无上菩提。不如持经福也

九者。论名成种种势力得大妙果报。若作十章门。分此两句。为二。从须菩提若善男子善女人于后末世有受持修行此经所得功德若我具说或有人闻心则狂乱等。自此以下二段经。明持经因缘。能得世间出世间二种果报。此文明持经功德。非但正感佛果。亦兼得世间人王天王五欲果报也。若我具说或有人闻心则狂乱疑惑不信者。若我具说持经所得世间出世间二种果报者。众生闻则疑惑故。但说得出世不可思议功德。不说得世间果报也。上明行取相行者。得三界果报。受持此经。唯得无为法身至极之果。此中复言得世间出世间二种果报。斯言何故前后相违不定。若得无为法身。不应复得世间天王果报。既得人王天王报。不应复得法身果也以此世人现都荣位。情重王报。于中取着。便用持经功德。求于世报。不求佛果。故心狂乱也。既狂乱。则犹豫不信。不知受持此经为决定能得佛果为不得。如此犹豫故曰疑也。此疑心迷理更起烦恼。故曰或也。然上言依此经行无相檀波罗蜜等。能得无为法身。不得世间果报。今此中。何故云受持此经。得世间出世间人王天王等尊位势力果报者。明受持此经实自远得无为法身大妙果报。所以得世间诸王果报者。以行者修行未满。未成佛中间。自然得此人天傍报。如人种谷但求果实。不悕蒿草自然得之。菩萨虽受此世王之果。而不染着。勿谓此果同于世间取相所得实果也

论曰复成就何业修行者。牒上第八段三种修行初论本偈中第三句也。显彼修行业者。生此利益分。明此一段经。所以经文在此。而章门在上者。以前明三种闻慧。是其修行。今辨得多种利益思修二慧。亦是修行。以三慧义势相属。复修行名通。义有拘琐故。章门在上。经释在此。以斯经解释方彰。修行之义足。故言显彼修行业也。此一段经。凡以三行偈。作九种章门。或作十章门。释此一段经。初一偈释前四章门。第二偈释中四章门。第三偈上二句释后一章门。亦得分释二章门。下半偈通结三偈。劝人令知也。非余者境界者。释经中第一段。明此经理深。非凡夫二乘闻思修慧心意识所恻。故非余者境界也。唯依大人说者。释第二段经。明经理既深。小根之人不能勘受。故但为菩萨大人说也。然如来非能为菩萨说。不为小乘人说。但菩萨机根大故。所以为说。小乘之人器小心狭。不勘闻大。所以不为说之。非情不平等鄙于二乘不为说也。如日初出。光照高山。后照于下。非曰有高下之心故然也。及希闻信法。者此是释第三段。明此经希有信者难得。经中更无别文可释。即指前二段经中人法。以为能信所信人法也。希闻者。明凡夫二乘不闻此经。设闻不能生信。唯菩萨能闻能信。信者难得。故云希闻信法也。满足无上界者。释第四段经。明持经因缘。能显无为法身法身满足性也。此明满足性。有二二十二地菩萨。分中显满足性。二显如来果头具足现用满足性也。受持真妙法者。释经中第五段。若受持此经。不能寻诠会理得理亡诠。不名受持真妙法要受持此经。能亡诠会旨。解无为法身。方名受持真妙法故。明受持经者。即是荷担如来真妙法身也。尊重身得福者。释经中第六段。明非但持经多得功德。敬重说此经处。广设供养。亦得多福。以此处说金刚般若。辨无为法身。供养此处。即供养法身故。云尊重也。身时得福者。说供养人。身得世间出世间二种果报也。及远离诸障者。释经中第七段。以持经功德威力。侠三恶罪业现世轻受。即为消灭。亦离智障烦恼障也。复能速证法者。释经中第八段。明佛自引过去虽供养诸佛。当尔时。怀取相心。不能疾得菩提。若能受持此经者。不近期三界有为果报故。能速证无上菩提法也。成种种势力者。释经中第九段。明持经功德能得世间人天中王种种势力果也。得大妙果报者。此二句。释经中此法门不可思议果报亦不可思议。此明非但直得世间种种势力果报。乃远感出世间极大妙果也

此三行偈。说何等义者。论主将以长行释偈中九章门故。作此问生起也。有不可思议至不共声闻等。释偈中初句也。以为住第一大乘者至修行胜故。释偈中第二句也。以信小乘等则不能闻此示希闻而能信法故。释偈中第三句也。并释三章门竟。如经以下通举经来结也

希闻者谓不可思议等文句者。前二章门经中有文。即此二章门经。上作第三章门。经无别文。恐人不识故。还指上章门。谓不可思议等文句也。得不可思议等福德至无量功德聚故。解偈中第四句。举经来结也。下释二偈五章门一一略提经解释。还广举经。依论可知也

尔时须菩提白佛言。云何菩萨发三菩提心云何降伏其心等。以下凡有十六段经文。此是大段。中第十名为断疑分。此所以名断疑者。上从第三段来。已广辨断疑。何故不与断疑之名。此段所以独得断疑之称也。然众生到侧。或取着心。多闻如来说法。于一法上。起种种疑。从第三段来至第九段。此一周说法。于菩萨众生佛净土等四法上。次第一遍断疑。然各逐所明。事义不同。别立名字。虽复断疑。而不名断疑分。自此以下。还提上经。其文略同。而疑有异。答意亦异。故独得断疑之名也。以何次第起。此第十段十。将欲释上所未断疑故。次第重举前七段经来。以释众疑故。次明此断疑分经也

尔时须菩提白佛至则非菩萨。重牒前第三住分经文。然此住义。前已广释。所以重举来者。就此文上。有疑未尽。为欲取下何以故须菩提实无有法名为菩萨。以释上疑故。通举来也。此言何以故者。以作难云。上第三段经中。已明此三种修行。何以故。此中复重明。有何胜也。故释实无有法名为菩萨。发三菩提心者。明于前三种修行上。疑未遣。为以此实无有法名为菩萨。释疑故。重来也。疑意。云何上第三段中。明菩萨证得初地无生二种无我见道之解。具足四种深心。永断三界四住习气无明粗品。离五怖畏。住于初地。平等理中。不见被是众生我为菩萨。于此理中。柔伏其心。复得二地以上修道之解。以得此解故。存我能具足四种深心。住于初地。我能不着三事修行。我能不见三事。降伏其心。我能断烦恼。我能化人。有此分别之心。以有此心故。有人疑云。若菩萨以证见道修无我之解。何故犹云我能证平等理。不见众生异于菩萨。乃至我能修行等。既自得无我解。今言不见。谁云不见。菩萨言我能不见。即难。者是菩萨。何者是我。而菩萨言我能不见也。若尔。疑者还谓。即众生五阴是菩萨。更无别菩萨。若众生五阴非菩萨者。何故。菩萨自言我能。以此验之。故知即而众生五阴是实菩萨也。为除此疑故。言实无有法名为菩萨发三菩提心者也。今明实无有法名为菩萨者。假名名字众生体虚妄不实。五阴因缘灭法体本来空寂。于众生五阴有为法中。无有一法是实可名为菩萨。若众生五阴中。无有一法是实名为菩萨者。云何而言我是菩萨。然今言。我是菩萨。我能见修。我能修行等者。非谓菩萨发初地已。犹存众生五阴。以之为我。有身见等粗惑未尽也。所以尚言我能者。明见道修道二种菩萨。虽现见真性断除四住不善烦恼等一品粗惑。犹有无明住地根本烦恼细惑。于善法中。有微分别心未断尽故。有此功用之惑。于七地以还非患。乃障八地以上无功用不住道解。因断此疑。即励诸菩萨。遣存我分别之心故。言实无有法名为菩萨发三菩提心也。此乃隐覆之答。非是正答。若欲正答。亦应更问。若起此分别。非真实菩萨者。何者是真实菩萨。应答有实菩萨。何者是。要得无生忍。会二种无我解者。是真实菩萨。而不正答者。以引释在下第四经中。但此义势未尽。故合答也

此一段经。以一行偈释。于内心修行存我为菩萨者。初地以上七地以还。菩萨虽得无我之解。于内心中。修行之时。自谓我是菩萨。我能不见三事。此之分别等。即是根本无明。于善法中。分别之惑也。应问此见道修道三种修行胜解为实不实也。亦应答是实。次难。若是实者。自言我能修行。此有何妨。即答此即障于心也。明如此分别云我能修行等。善法无明功用之惑。障八地以上心。应问障八地以上何等心。故下句云。违于不住道。明七地以还。善法分别功用之惑。障八地以上无功用心不住道解也。此言不住者。不住功用心。不住无功用心。故名不住道也。此义云何至降伏其心。释偈初句。菩萨生此分别者。释偈中第二句。障于菩提行者。释偈中第三句。下并以三句偈来经结也。障何等心者。提第三句作问也。即答偈言违于不住道者。此以第四句为答也。如经以下。举释疑经来结也。须菩提。如来于燃灯佛所。有法得菩提不。此断疑分中第二经文。何故复来。以前疑实无有法名菩萨。疑者谓一向无菩萨者。何故如来云我。昔在燃灯佛所行菩萨行得菩提记。以此验之。应有菩萨。行何故言无。佛语须菩提。我于燃灯佛所。有法得菩提不。须菩提解答佛言。佛于燃灯佛所。无有法得菩提记。明菩萨犹在习种性中。于燃灯佛所。唯言语受记。未有所证。故言无法得菩提也。明未得初地真实无生忍三菩提也。而非无地前假名名字菩萨言语受菩提记也。前疑问于应有菩提。何故今者答以不得菩提也。此名真如所证法。为菩提。明众生修行证菩提者。名为菩萨。尔时既未登菩提。明非是实也。佛言如是。须菩提。实无有法如来于燃灯佛所得三菩提者。此如来印可须菩提所说不虚。拂去众疑也。须菩提。若有法如来得菩提者。燃灯佛则不与我授记。汝于来世当得作佛。号释迦牟尼者。如来自云。若我在习种中。燃灯佛时。已得初地无生三菩提记者。则后时无量诸佛乃至初地中。燃灯等则更不与我授无生忍记也。以实未得无生忍三菩提记。是故后燃灯佛等。复与我授记。摩那婆。汝于来世。当得作佛。号释迦者。此明正。以我于彼时实未得初地真无生忍三菩提记故。后明时燃灯佛更与我授记。汝当作佛也。又第三燃灯佛所。尔时始证真无生忍记

何以故者。此有疑难云。如上所说。应有菩提。今何故。言实无有法如来得菩提。若实无有法如来得菩提者。则谤谓一向无菩提。亦无诸佛得菩提者。若尔既无菩提可得。何故菩萨三大阿僧祇劫。修苦行菩提也。答言。如来者即实真如也。上所以云无有一法。名得菩提者。明尔时但言语授记。未有证法是实而得名为菩提。非谓理中一向无菩提故。今言即实真如者。明实有无为法身菩提。古今一定。体不变不异。无生住灭相故。名即实真如。指此真如无为法身。是菩提体。以有实菩提故。明知亦有菩萨。复有修行得佛。何得谤言一向无菩提亦无菩萨修行证果成佛者也。然今虽答有菩提之体。犹未是正答。下大身喻中。别当正答也。乘此答言。如来者即实真如。复更生疑。若言真如菩提是实有者。此有犹同世间色等有为万相之有。生此疑心故。答言。若有人言。如来得三菩提者。是人不实语。此明法身菩提体绝万相。妙有故有。非是有为虚妄之有。那得闻有便取同色等万相虚妄之有。既是妙有。谓同虚妄有者。即是妄说。故言不实语也。下经。即成何取此菩提同有为者是其不实语。以实无有法佛得三菩提故也。此中应引上菩萨证成此义。上实无有法名为菩萨者。明众生五阴非实菩萨。而言此众生五阴法中实不有一法名菩萨者。是不实语。今言实无有法如来得三菩提明菩提之体。无色等万相可得。而言有得菩提者。亦是虚妄。此明如菩萨佛亦如是。以菩萨不实故。菩提亦不实也。或者闻言有菩提。便谓菩提同有为色等万相可得故。答以不得菩萨。此明不得者菩提之体无有为万相一法可得。故言不得菩提。非谓理中无得。那得以菩提无有为万相可得。难理中亦使不得也。乘实无有法佛得三菩提。覆生疑谤。若言实无有法佛得三菩提者。便一向无有得菩提人。既无得菩提者。故知亦无菩提可得也。故答言。须菩提。如来所得阿耨三菩提。此佛引已所得菩提。证成有得之义也。言如来所得者。明我亲自修行迳三大阿僧祇。十地行满。证得菩提。何得谤言一向无有得菩提者也。于是中不实者。结成上实无有法佛得菩提。明菩提之体无色等万相。而取同有为万相可得者。此是不实也。不妄语者。结成前如来所得阿耨三菩提明菩提之体。虽无色等万相可得。非不实有真如菩提万德具足为如来所证。故云不妄语也。此双结上。有得无得二种经文也。是故如来说一切法皆是佛法者。偏成上。是故所得阿耨菩提理中。不有妄得语义故。如来所说一切果头万德之法。皆是诸佛法身妙有之法。亦应言。是故如来说一切法非佛法。明色等有为万相一切法。皆非果头万德一切法。以不作此说故。大众乘如来说一切法皆是佛法。复更生疑。若言一切法皆是佛法者。而一切名滥。有有为一切有无为一切。此二种一切。可皆是佛法耶。若皆是佛法者。那得上言法身菩提无万相可得。真如无为法中实有菩提也。故经答言。所言一切法。一切法者。即非一切法也。上一切法者。名有为一切法。下一切法者。是无为一切。即非一切法者。明上有为一切非无为一切。亦得言无为一切即非有为一切法。是故名一切法者。此句双结二种一切法。是故名有为一切法。是故名无为一切法也。虽复一切名同。有为一切法。体是虚妄。故非菩提。无为一切法。体是真实。故是菩提。勿得以一切名同。便谓有为一切亦是果头一切万德佛法也

论曰此中有疑以下。论主先生起疑意。举经来。结作两偈。释此一段经。初偈释经中须菩提于意云何至不实不妄语也。以后时授记者。此还释前断疑经。作疑不异于上。若作正答。应云实无有法得菩提者。明我于燃灯佛时未有所证故。云无法得菩提。既无所证菩提。成上亦无实证菩萨。言有菩萨者。要现得无生法忍出世间解。名真菩萨。今偈但答言以后时授记。义中已知实有菩萨。若无菩萨者。何得言后时授记。所以此中不正答者。以斯义势未尽故。拘琐在下以下经文中有正释故。此因后时授记。以明于有也。燃灯行非上者。我于前燃灯佛时。在习种性中。未得初地无生法忍第一上行故。云燃灯行非上也。故上句云。以后时授记。后性地中。第二燃灯佛。悬授初地八地无生忍记。后三十心满。复有第三燃灯佛。与我授无生忍后时记。此谓道种之未初地之前。此燃灯佛与我授记。以验知前燃灯佛边未证无生三菩提现道记也。此上二句。释摩那婆汝于来世作佛号释迦牟尼以前经也。菩提彼行等者。经中。先言众生五阴非菩萨。后云色等有为非菩提。依此作偈。应言彼行等菩提。而言菩提彼行者。明证菩提者是实菩萨。既未证菩提。故知亦无明证菩萨。不实义同。反覆相成故也。又复一释。应言彼行随等菩提。但依阐陀论作偈法。用逐语便上下意也。此明如菩萨佛亦如是。故下句云。非实有为相。此明以众生五阴有为万相而得菩萨菩提者此是虚妄。故云非实。何故非实。以取有为为实相故也。此后二句。释何以故已下经也。此解直明菩萨菩提不可以有为相得。未明无为法中有实菩萨行。及菩提可得义中。应作第二道义言菩提彼行等是实无为相。以正偈侠故。更作第二偈。虽作第二偈。以经中未明有实菩萨故。但明有实菩提也。此义云何至无有一法得菩提。此释偈中第二句也。若我于彼佛所。已证菩提。则后时诸佛不授我记者。此释偈中上句也。是故我于彼时行未成佛故者。还以上句。结下第二句也。此中应解上句。何故先释第二句者。但下句所释。经文在于前故。此长行论。依经次第。先解第二句也。偈言以下释竟双引上半偈结也。若无菩提。即无诸佛如来等者。先作生疑谤意也。如经等者。举释疑经结。然后以论释经也。若有人言以下。先举经作问。以偈中第三句来答也。此义云何者。以此偈言菩提彼行等者此义意云何也。彼菩萨行等者。提彼前经中菩萨发菩提心行。释偈中彼行也。如是如来至此亦虚妄者。提此经中若人言如来得菩提不实语释偈中菩提也。故言菩提彼行等者结句也。若有人取众生五阴色等有为法。以为菩萨菩提者。此是不实故言等也。若如是有人谤言。如来不得菩提者。此出疑谤之意也。为断此疑。如经以下。即释引疑经结也。此义云何者。设问。前言实无有法如来得菩提。此中复言如来所得阿耨三菩提。此言相反其义云何也。即释云以如来得彼菩提故。此句释后经如来所得三菩提。明理而言之。如来实修行证得菩提也。若如来实得菩提。何故前言不得也。故即举偈释言。非实有为相故。此句解前如来不得三菩提经也。有为相者谓五阴相者。片出偈中有为相名也。彼菩提法无色等相故者。明菩提体无色等五阴相可得。故云非实有为相也。此复云何者。前偈下二句。且解经中菩提无色等万相故不可得。若取菩提同色等相者。此则非实。然犹未解实有真如菩提。亦未解有证菩提者。经文今将欲作第二偈。以释此义故。先设问生起云。若言菩提无色等相者。经云言如来者即实真如。又云如来所得阿耨三菩提。此义复云何也。故即以偈答。彼即非相相。此第二偈。释经中是故如来说一切法佛法记经。彼即非相相。彼者。彼于法身菩提。非色等有为万法相也。如是无有相者。是无为法身。决定万德相也。以不虚说故者。明上法身菩提虽无有为万相。而非不有真如无为万德之相故。经云如来所得阿耨三菩提者。非为妄说故。言以不虚说故也。又问何故不虚说也。故下第三句云。是法诸佛法是法者是无为一切法也。诸佛法者。是佛所证果头无为法身万德一切法相也。故第四句云。一切自体相明此万德是真真如法身自体相。非是有为万相所成也。此义云何以下至以不虚说故。解偈中初句竟。通以上半偈来结也。是故如来说一切法佛法如是等者。提结为问云。如来说一切法佛法。此义云何也。故即答。以如来得如是法。明如来躬自修行证得如是果头万德一切法也。故复以下半偈来结释已。然后先解第四句。后释第三句也。彼处色等相不住等故。明菩提万德一切法。所以唯以真如为体。不以色等为体者。以菩提体是真如无为故。但住持万德一切法。不住持色等一切法。故以为体也

须菩提。譬如有人其身妙大等。此断疑分中第三经文。前喻明报身佛。今明法身佛。上已广释法身无万相而是妙有。又次前经中两句。明法身菩提万德圆满。故有菩提可得。然疑者犹谓全无法身。何以故尔。若法身万德满足。应有万相可见。若无万相可见者。便应一向无法身。所以得知法身是无。前段经中。如来或言有菩提可得。或言无菩提可得。若法身定有者。应答我有得。若法身定无。应答言无得。今答既不定。复不可见。故知法身是无也。有如此疑。故经答譬如有人其身妙大等也。答意明理而言之。菩提之体。虽无万相可得。然实有真如法身菩提可得。但不得定答。所以然者。明此法身。乃是非有非无。妙有妙无。中道之理。我若定答。汝等便生邪见。闻菩提是有。取同色等有为之有。则成常见。闻无。谓一向同于虚空菟角无体之无。则成断见。故不得定答也。又此法身具足功德智慧二种庄严。体是妙有。故有法身可得。远离二障。体非有为。故无法身可得。有此二义故。上不得定答。那得难言何故作此不定答也。为断此疑故。引大身喻。明有法身体。不应言无法身也。此喻释成前言如来者即实真如也。譬如有人者。如来引大身喻。喻法身人也。其身妙大者。如来自合喻。则法身体相圆满。古今湛然。毕竟达离二障。具足二种庄严。妙者智慧庄严。大者功德庄严也。此其身妙大。成上章未如来所得阿耨三菩提。明实有无为法身菩提可得也。前二段经。明众生五阴非实菩萨故。有为万相亦非实菩提。此下二段经。明法身菩提是妙有故菩萨无生忍行亦是实有也。上第五段中云。不可以相成就见如来者。明无为法身体无三相也。第六段中言如来不得菩提。亦不说法者。此名应化佛不得不说也。第七分山王大身喻中。谓报佛体无取相分别也。此中大身譬喻。亦明法身佛。此之三佛别相中论也。须菩提言。世尊如来说人身妙大则非大身者。须菩提若不作此说。有二种失。一不解如来意。二不解无为法身。故作此说也。或者闻言法身是有。疑谓还同有为万相之有。故释云则非大身也。此明古今一定法身体。毕竟远离二障。不同有为有漏万相大身也。此两句。成上实无有法如来得阿耨三菩提。明色等有为法非实菩提体也。是故如来说名大身者。说名古今一定体无万相妙有湛然真极法佛大身也。亦得是故如来说名非大身也。此一句双结上其身妙大即非妙大二句经也

此一段经。以二偈释。初偈。作问答意释疑。依彼法身佛。故说大身喻者。此出喻意明与喻之来。为显法身故也。身离一切障者。明法身古今湛然自性永无二障非断故方离也。及遍一切境者。明此法身体是妙有。复永绝二障无障无碍故。能遍入一切有心众生之境。然下长行论中。先释功德及大体。后方释及遍一切境。所以然者。要先有法身之体。然后障遍一切处。明有体故遍。故释在后也。功德及大体者。此第二偈。正释经中其身妙大。功德者。正释经大字。及大体者。正释经妙字。大者功德庄严。妙者智慧庄严也。前列经先举妙。后明大。此偈中先释大。后解妙。此偈以语便故即也。故说大身者。以法身具二庄严。结作大身义也。非身即是身者。释经人身妙大则非大身。非身者。明法身体无万相。不同有为有漏之身。故言非身也。即是身者。明如是非有为身者即是真如。具二庄严。妙有法身也。下长行论中故引此非身即是身。结成及遍一切境。明有相之身故不遍一切。无为法身体非形相。能遍一切故。以非身即是身。成遍一切处也是故说非身者。释经中是故如来说名大身。以无为法身非有为身。故名非身。非谓无有无为法身。故言是故说非身也。此二偈说何义等。论主欲作长行论释偈故。先设问生起。然后解释。毕竟远离烦恼障智毕竟具足法身故者。释偈中第三句身离一切障。此复云何者。此毕竟远离二障。具足法身义复云何也。故释有二种义。一者遍一切处者。明法身离二种障故能遍一切有心之境。即见初偈第四句。二者功德大。明法身非但体离二障故遍。复以备二庄严。万德具足故。能遍于一切有心之境。是故名大身者。结作大身义故。即举第二偈上句功德及大体来成也。遍一切处者。真如一切法不差别故者。此解一切处义。明就行者而言。则有诸佛菩萨及以众生三时之异。论真如法身。其体满足。古今平等。无有差别也。自此以前。释初一偈半经中其身妙大也。偈言非身即是身是故说非身者。明此半偈义有拘琐释上之义。复欲乘释经偈。故举此半偈。成上以释经结也。此说何义者。方次第解释也

佛言。须菩提。菩萨亦如是等。此一段经。是断疑分中第四经文。所以来者。此有疑故也。云何疑。上言实无有法名为菩萨。若无菩萨。则亦无修行得菩提者。又若无修行得菩提者。则亦无人教化众生。亦无众生入涅槃。若言我庄严佛土非菩萨者。则亦无依报净土。若此等四法皆是无者。何故诸菩萨发心。度众生修净土行。求无上菩提。有如此疑。依如上释。此疑应已遣。但或者偏执以兴难也。故经答菩萨亦如是等答意云。上言无菩萨等者。据众生五阴有为法中无也。非谓理中亦无。然非不实有菩萨会无生理修行得佛菩提。既有诸佛证果之人。然诸佛菩萨。本不独善。复化物同得故。发心修行。度众生令入涅槃。修净土行。但知不离真如法界。外有为法中。别有实菩萨是能度者。有实众生是可度者。有真净土可修故。下经言通达无我无我法者。是名菩萨。上言无者。道众生五阴有为法中无实菩萨。若尔非一向无菩萨。那得闻言实无有法名为菩萨便全无菩萨。为断此疑。故次明也

佛言菩萨亦如是者。上辨如菩萨佛亦复如是。此明如佛菩萨亦如是。云何亦如是。即此断疑分第一段中。明实无有法名为菩萨。次第二段中。明实无有法如来得菩提。此二段经。先明众生五阴有为虚妄法非实菩萨故。次明若谓菩提同有为万相可得者是不实说故。上论偈言菩提彼行等。此即是如菩萨佛亦复如是也。又次前段经。明有为万相非是菩提。而真如无为万德之法是实菩提。此段明众生五阴有为虚妄非实菩萨。然非不有会真如无生理者是真菩萨。此二段经。明理中实有菩提是何证。故亦有菩萨实证之人。此明如佛菩萨亦如是。今言亦如是如者。明有为虚妄非菩萨。会无生忍者是真菩萨。义同有为万相。非实菩提。真如无为是实菩提相故。言菩萨亦如是。前二段经。但就菩萨菩提不实义同故。言亦如是。此二段。并明菩萨菩提实义边同亦如是不实义同亦如是也。若作是言。我当灭度无量众生则非菩萨者。明若作心谓离真如法界。外别有行者。发菩提心。修诸波罗蜜行。以慈悲四无量四摄等法。教化众生令得涅槃。是真菩萨者。此未会平等。非是初地以上解真如平等菩萨也。佛言须菩提。颇有实法名为菩萨者。因前经乘更生疑。若发心修行。教化众生。非真菩萨者。还同前疑。正众生五阴是实菩萨。有如此疑。故佛问须菩提。众生五阴有为法中。颇有一法是实名为菩萨不。故须菩提答不也世尊。实无有法名为菩萨。此答意明众生五阴有为之法。本来空寂。无有一法是实可名菩萨故。不应取众生五阴以为真实菩萨也。一切法无众生。无人。无寿者等。引佛语为证也。此就因缘法空中。以解无菩萨。明有为法中本来空寂。无有一法是实可名菩萨是能度者。故亦知无实众生是可度者也。所以经中但言无众生等三。不言无我者。以此经始未明真如之我。若言无我。恐众生谓佛性真我亦无。故不言无我。以名相滥故也

须菩提。若菩萨作是言。我庄严佛国土。至是名庄严佛国土。此明若起心分别。谓异于真法界外。别有出世庄严净土。为无漏胜因所得是真实者。不名解真如平等菩萨也。所以重言庄严者。明修行因缘显真如法性。有真庄严净土用。非谓异法性。别有为波罗蜜行所得庄严净土。故重庄严。是名庄严者。即是第一义谛庄严也。此一段经。明有实菩萨。何故乃云。作是言。我度众生。我庄严净土者。非真菩萨也。为明举非以形是故重牒来也。更有一意。明众生菩萨佛净土此四。虽名用有异。而同一法界中名。若不会真法界者。谓此四法。离真法界。别体相异故。不名真菩萨。若会真如平等之解者。知此法虽时异用别。语其所归。无有异相。离于真法界。条然有也。故胜鬘经云。依如来藏。建立一切法。又如不增不减经中明。就佛性法身体上有众生菩萨佛。故知凡圣虽殊。而同依佛性。若同一法界。所以有斯四法差别者。明未修行不断惑者名为众生。修行之中分别断惑者或为菩萨。全修行满足除二惑永尽故名为佛也。既得圆报法身。必有所依之土。即此圆报法有上品世间依报用异。故有净土。此明佛与净土二。法体一就用异也

有人生疑。若起如此心非菩萨者。起何等心。名真菩萨。故答须菩提。若菩萨通达无我无我法者。名为真是菩萨。菩萨者解意。上来明未得二无我解者。不名为真实菩萨。遥指正答在此。今言通达无我无我法。正出解二无我法者名真菩萨也。无我无我法者。有二种无我。一人无我。二法无我。人无我者。解众生五阴中从本以来无定实神我及众生等。故曰人无我也。法无我有二种。一观因缘法体本来空寂。二观佛性法体无万相故空。若能通达三空二无我者。是真菩萨。故曰通达无我无我法也。所以重言菩萨菩萨者。明菩萨有二种。一者地前菩萨。闻信二种无我。二者地上菩萨。现见二种无我。若直云菩萨。恐失地前菩萨仿佛观理深伏烦恼者。故重言菩萨菩萨也。论曰此中有疑等者。论主将欲以偈释前经文。故作此生起也。若无菩萨至清净佛国土。以牒所疑事也。若如是以下。序生疑之意。指经为释。如经中生起也。凡以二偈释斯一段经文。初偈。作问答意。释经中菩萨亦如是至不名菩萨也。第二偈。释经若菩萨通达无我无我法尽经也。不达真法界起度众生意及清净国土者。明菩萨所以起心度众生及庄严佛国土者。正以不达真如法界平等理故。不知凡圣一如依正同体。谓离此真法界外于三界有为法中。别有菩萨是能度者。有实众生是可度者。有真净土可修。此不名解平等真实菩萨故。下句云。生心即是倒也。故经中明文殊师利向佛忏悔。我从昔来。由不达真法界理故。以取相心。化众生。修十地行。净佛国土。有如此罪。今向佛忏悔。以起心取此不实为故名倒也。此义云何若起如是心等。一段长行论。先举偈为问。后以经答也。此示何义。将作偈释经故。问此经云通达无我无我法者。示何等义也。所以偈答云。众生及菩萨等。此第二偈。众生及菩萨。众生者。凡夫菩萨也。及菩萨者。谓初地以上菩萨也。知诸法无我者。明此二种菩萨得三空二无我解也。此明地前菩萨仿佛解二无我。登地以上现见二无我也。故下半偈云。非圣自智信及圣以有智。非圣者。明也前菩萨未现得真如无我解故名非圣。非不得相似之解。闻中生决定信故。言自智信也。及圣以有智者。明初地以上菩萨现会三空二无我理故名为圣。何故名圣。以有真如无漏智。故言及圣以有智也。长行论云。此明何义智无我无我法者。先释偈中第二句出菩萨所观二种我境也。谓众生及菩萨者。释偈中初句出二种菩萨能观人也。何等众生何等菩萨者。将释下半偈。故作问生起。问此二种菩萨既俱观二种无我理。有何忧劣。而有众生菩萨二名不同也。即释云。于彼法。若能自智信。总出二种菩萨。于彼三空理。以智信也。世间智者。正释偈中下半偈。明此二菩萨虽同信三空而忧劣有别也。所谓凡夫圣人以下。两对结得二菩萨名不同也。如经以下引经结也

金刚仙论卷第七金刚仙论卷第八

须菩提。于意云何。如来有肉眼不等。此是断疑分中第五段经文。此所以来者。有疑故来也。云何疑。上第三段经云。菩萨不见彼是众生我为菩萨。即此断疑分中前第四经言。菩萨不见众生。亦不见清净国土又挍量分中。亦云以不见众生等法。名诸佛如来。而此菩萨众生佛净土等四。前已了了解释。明此四名虽异。皆依真如故有。若离真如法界。于有为虚妄法中。谓更有此四法可见者。非是菩萨。若解不异真如。而见此四者。名真菩萨也。虽尔了了解释有无之义。然众生复乘无生。或更起异疑云。若不见诸法名为诸佛者。或谓诸佛法身是。以依身故有五眼。若无法身。便应无五眼。若无五眼。则不见诸法。未知今言不见者。为有五眼故不见。为无五眼故不见也。若有五眼者。为当前法是无故所以不见。为当前境实有而言不见也。为断此疑故。以此五眼经答也。答意明如来具足五眼。有无斯照。随法虚实。皆如实智知。今言不见者。有眼故云不见。非无眼言不见也。若有眼者。何故言不见有。但前境虚妄无法可见也。不见有二种。一真如平等理中不见众生等四条然有异。故言不见。二众生五阴虚妄法体本来不生古今空寂故无法可见。此二明理中绝相故。圣人无有取相分别之见。故云不见也。所以得言见者。如来具二谛智。如虚妄而知。如实而见也。此就诸法空寂义边故言不见。非谓眼境并无令不见也。若尔那得闻言不见便谓诸佛菩萨一向无眼不见诸法。次明也

如来有肉眼者。何者是肉眼所知境界。而言如来有肉眼。明凡夫之人肉眼。但见因缘和合虚妄境界。见上不见下。然众生造业既殊。报得肉眼亦差品不同。或但见障内。不见障外。或内外俱见。或昼见夜不见。或夜见昼不见。或昼夜俱见。此等诸眼。皆是父母所生眼。如弗婆提人。以父母所生眼。能见障外色。前后俱见。如来同凡夫见此虚妄之色故。云如来有肉眼也。如来有天眼者。天眼有二种。一者修得。二者报得。何者是天眼所知境界。天眼亦照因缘和合虚妄境界。皆见障外之色。亦有见下不见上者。有见前不见后。若因他力。见上见下。见前见后。有四方俱见。明如来所见亦同凡夫颠倒取境。如来称前境虚实而缘。以此为异。故言如来有天眼也。然世间人。有报得肉眼。有报得天眼。亦有修得天眼者。此皆三界中法。明诸佛菩萨道超世表。久已无此二眼。何故道言如来有此二眼者。以见同二眼故。言如来有天眼也

如来有慧眼者。何者是慧眼所缘境。明慧眼知一切有为法无为法有漏无漏善恶无记等法。而不作念我知此法。明如来亦同二乘所缘法故。言如来有慧眼也

如来有法眼者。何者是法眼所缘境界。明法眼能知三乘圣人当证果时。乘何等心。证于道果。如此法眼所缘证法差别。如来亦同见之。故言如来有法眼也。如来有佛眼者。然上之四眼。见境不周。知法不尽故。设所知见。不能明了。明佛眼所见。真俗并照。臣细斯鉴。一切万法了了通达。无境不周。无法不尽。故名佛眼。此眼如来有五眼故有境之见。既有此眼。故知佛有身有眼言不见。非无身无眼言不见故。次明此五眼经文也。乘五眼经文。复更生疑。疑云。十方世界无量无边。直三千世界中所有种种诸法尚不可知尽。况无边世界中。亦有种种诸法。何故但明此五眼。若正有此五眼。是为如来。则知法不尽。见境不周。故引恒河沙喻。以答此疑。欲明如来虽但有五眼而照所知之境。莫不皆尽。然知境虽尽。不可俱障于文。且境中微细难知者不过心法故。举恒沙世界中众生。一众生身中。有善心不善心无记心有漏无漏三三等心数。不可限量。一众生有若干种心。恒沙世界众生。各有尔许心数差别不同。如来以三达灵知。于一念中朗照故。不应难云若如来但有五眼则知境不尽也。此明眼虽有五。而知境斯尽也

佛言须菩提。于意云何。如恒河中所有沙。佛说是沙不者。前举五眼。明佛肉具能见之智。然智不孤起。必知境。今将明五眼所知之境。故佛问须菩提。汝意地思惟筹量。谓如来知此恒河中沙头数多少不也。应如是问。所以乃言如来说是沙不者。明理而言之。要先知后说。今言如来说者。明知如来知故方说故云佛说是沙不也。须菩提言。如是世尊。如来说是沙者。明须菩提得冥加力故。解如来意。故仰述如来所说言。如是世尊。如来实了了知此恒河中沙头数多少。故说非为不知也

此喻意。明以一恒河。为一众生。此一众生。有善不善无记等心数法。多少如恒河中沙。复以此沙数恒河。为一众生。一众生亦有尔许数心数法。复以此沙数佛世界。尔许世界中。复有无量恒沙。复以一河。为一众生。尔许众生心数法。皆了了知。况余非心心法也

乘此。更生疑念。如地前菩萨。以信解力故。亦知一三千世界中众生心数法。未知今言如来知恒沙众生心数法者。为同地前菩萨但知一佛三千世界中恒沙众生心数法。为遍知十方无量恒河沙世界中众生心数法也。将释此疑故。佛重问须菩提。于意云何。如一恒河中所有沙数佛世界至如是佛世界宁为多不。此欲明如来非但知一三千世界中恒沙众生心心数法也。乃遍知十方世界中无量恒河沙众生心数法也。须菩提言彼世界甚多世尊者。明须菩提仰答。如来如上所说十方恒沙世界实多无量也

佛告须菩提。尔许世界中众生。若干种心住如来悉知者。上来问答虽有重数。正答意在此文。明如来乃是一切智人。但以五明了了遍知十方恒河沙世界中众生色心等法。无不皆尽。今且举知心法。明知色亦无遗也。然就此所知法中。有种种差别。忧劣不同。如人中果报。比于诸天。优劣上下。不得为喻。况诸佛菩萨。出世胜报。比于人天之果。俱然悬绝不可算数。如来了达无余。故言悉知也。何以故者。因向若干种心住如来悉知。复生疑念。上云众生五阴六尘六识体是虚妄。若取此众生五阴等妄法者。即非菩萨。又云离一切诸相。则名诸佛。若尔何以故。今复言若干种心住如来悉知。若如来知见此法。则应是实非为虚妄。未知此言心住者。为四念处真如境中住。为余法中住。若是真实。上不应言虚妄道如来不见。若是虚妄。不应复言若干种心住如来悉知。故言何以故也。即答如来说诸心住皆为非心住。此言诸心住者。凡夫六识。于虚妄法中。颠倒而住。皆为非心住者。非于四念处中无颠倒真实住也。此明上言离者。虚妄故离。今所以言知者。如来五眼照境斯尽。虚实俱了。故云知。非为真实也。是名为心住者。结虚妄缘中颠倒住。亦得结上皆为非心住。是名为非四念处境中真实住也。何以故过去心不可得等者。释上。何以知。此言心住者。是六识颠倒虚妄缘中住故。释云过去心等不可得。明以三世等心不住为住。故曰虚妄也。过去心法已谢于往。空故不可得。未来心未至。空故不可得。现在心念念生灭不住。即体是空。故不可得也

因三世虚妄诸心颠倒。复更生疑。若心住是虚妄颠倒者。便谓凡夫圣人心皆是虚妄颠倒。若尔则初地以上诸菩萨心。亦是虚妄颠倒。以心虚妄颠倒故。所有布施等福德智慧了因之行。亦应是颠倒。故非菩提因。不成彼岸无漏功德也。为断此疑故。答言以三千世界七宝布施德福甚多。此明初地以上得真无漏解不取相不住心行布施故。福德非颠倒。以非颠倒故。成波罗蜜行。不同地前凡夫六识心是虚妄取相颠倒故福德亦是颠倒。然此福德虽非颠倒。而要以地前取相颠倒福德为因故。非条然也。得福甚多者。明此无相布施。乃感常住佛果无尽之福。故言得福甚多也

即复生疑。若此三千七宝布施。实有福德。是无漏非颠倒者。何故上三千七宝布施。言非福德聚也。为断此疑故。答言须菩提。若福德聚相有实者。如来则不说福德聚福德聚。然上明二种福德聚。一是取相有漏福德聚。二是不取相无漏福德聚。我言非福德聚者。明有漏福德聚非趣菩提无漏福德聚。不言无漏福德亦非福德聚也。那得以彼三千世界七宝布施取相福德是颠倒故。难我此中初地以上不取相布施无漏福德亦使是颠倒也

论曰复有疑等。此先牒前所疑事也。若如是以下序生疑意。指经为释也。此一段经。以三偈行释。初偈正释五眼经文。作问答意断疑。第二偈释恒沙世界譬喻中一段经文。第三偈释三千世界七宝布施福多经文。初偈云虽不见诸法者。上疑云不见诸法。未知为有眼而不见。为无眼故不见也。故偈释明诸佛菩萨虽不同凡夫于众生五阴色等有为法上有取相之见。非不有五眼如法相虚实而见。非令无眼故不见也。故第二句云非无了境眼。此明虽云诸佛不见诸法。非无五眼照境之用也。何以得知。故次下句言。诸佛五种实。此明诸佛有五眼具足也。若尔即复生疑。此五种眼。还同于凡夫颠倒之见故。即答以见彼颠。明诸佛菩萨实有五眼。称于颠倒境界而见。而见非颠倒故。不同凡夫也。此半偈虽解经意。犹未释经文。故拘琐作第二偈也。长行论云。何故说彼非颠倒者。论主将释此偈答之意故。设问云。若诸佛实有五眼。见前境界者。前境是虚妄。故缘之智则应是颠倒何故说彼五眼为非颠倒也。即答为显断疑譬喻。是故说我知彼种种心住如是等也。明为释若但有五眼。则知多境不尽之疑。故引恒沙譬喻。是故言道若干种心住如来悉知。非同凡夫颠倒之知也。故下问云。此示何义。即答彼非颠倒。以见颠倒故也。何者是颠倒者。问若佛五眼非颠倒者。何者是颠倒眼也。即答偈言种种颠倒识以离于实念也。明六识非一故。云种种。妄取六尘。以不实为实。此憣境之心故云颠倒识也。何以得知六识是颠倒。次下句云。以离于实念。实念者四念处观也。观我此身常此身无常乃至法亦如是也。以六识不住四念处中。乃取虚妄六尘。故名颠倒也。不住彼实智是故说颠倒者。此二句成上二句也。明六识不住彼四念处实智境中。是故我说为颠倒也。此义云何至差别颠倒。释偈中初句也。何故彼心住名为颠倒者。何故此六种心住名为颠倒也。即以偈下三句答。明其六识但缘六尘虚妄境界。不能住四念处境中。是故说颠倒也

如来说诸心住皆为非心住者。提此一偈所释经来也。此句示现远离四念处者。释向六识心住离四念处境故说为非心住也。此以何义者。此以义故六识离四念处名为非心住也。即答心住者住彼念处也。明若心住于四念境中者。可名为住。而此六识以离彼四念处。取虚妄境界。故云不住也。又住不动根本名异义一者。释上心住彼念处者有于住义也。依世杂论解。以后释前。何故名住。以其不动。何故不动。以根本也。又解。何名住。明菩萨以四念处解。栖心真如理中。故名为住。既心住真。不为五欲所坏。故曰不动。亦得云不为二乘所坏。故曰不动。此真如解。既不为五欲所动。便能与菩提为基。故名根本也。若如是不住是故说心住者。若不能如是于四念处境中住者。是故便说为虚妄境中住也。此明不住相续不断行因者。双释住不住义也。此不住者。释前句也若如是不住相续不断行因者。释是故说心住也。是故不住者。结虚妄住者为非实住也。示彼相续颠倒。明虚妄境中相续住者是颠倒识也。结答上问何故彼心住名为颠倒也。如经过去心以下。举释虚妄住非心住经。结成颠倒义也。以过去未来以下。释三世心住经。可知也

何故依福德重说譬喻者。作问生起第三偈也。第三偈佛智慧根本者。上难云。以心颠倒故此福德亦应是颠倒。今言佛智慧根本。明此初地以上不取相布施是无漏福德。乃与佛果种智以为胜因。故曰佛智慧根本也。又第二句云非颠倒功德。明知此菩萨布施福德。非取相颠倒心也。以是福德根者。以是佛智慧根本福德根也。故重说譬喻者。重说三千世界施福。明虽同是布施但取相心布施者福德是颠倒。不取相心。施名虽同而福非颠倒也。然取相心施虽是颠。非不因此地前取相有漏施福。以此为因。然后得入初地无漏。有慎理之义故。地前取相福德。亦得相从为不颠倒福德也。此说何义至何名善法者。此序经中生疑之意也。为断此疑以下至福非颠倒。释答疑之意也。何以故者。释此七宝施福何以故得为非颠倒也。即提偈上句来。答以佛智慧根本故非颠倒也。云何示现根本者。问云何示现此七宝施福是佛智慧根本也。如经须菩提等。举经为取第二福德聚。答佛智慧根本义也。此义云何以下。释经中第二福德聚是其无漏故非颠倒。以无漏故得为佛智慧根本也

须菩提。于意云何。佛可以色身见不等。此一段经。是断疑分中第六段经文。此经所以来者。有疑故。上已三处。明可以相成就见如来不。此中第四何故复言佛可以具足色相身成就见不也。初一边。明法身上无应佛生住灭三相。第二边。明法身上无报佛大丈夫相。第三边。明法身上无色等法有为万相。此三处就别相中。以明法身佛古今湛然如虚空身非修行故。得不可以色相而见。须弥山王喻中。明报身佛由行者修行因缘。万德圆满。以色相庄严体非有为有漏。湛然常住。此就别相。明报佛。第六段中。无有定法得菩提者。明应佛从感故有。非修行可得。毕无色无心。此就别相。明应佛。此三佛历然不同也。法身佛非报应二佛。报身佛非法身应身佛。应身佛非法报二佛。此就三种佛别相义边。不得为一也。有人生疑。若此三佛差别不同。则皆是不实。何以故应身佛非修行所得。无色无心则是虚妄。既离法身。有报佛。报佛则是本无今有已有还无。亦是不实。若法身佛如虚空不可得见。体亦不实。此是一种疑。又上第六段中云。圣人以无为法得名。复云由行者修行因缘。成就相好。名之为佛。若然为当即法身上有此报应二佛色相之身冥然是一。为条然异于法身有此二色相身也。若冥然是一。则不应有三佛用差。若条然异有。则皆是虚妄。无有一义。有如此疑。故佛问须菩提。佛可以具足色身见不等。此答意云。汝不应作是难。所以然者。则此三佛。亦有一义。亦有异义。故语一则如终一法性无有二相。论异则三佛体用有别历然不同。此三种佛。理而言之。恒一恒三。恒三恒一。言三不伤其一体。论一废其三用。故不应难言此三种佛为冥然作一为条然有异。为释此疑。故次明也

于意云何。佛可以具足色身见不者。此佛问须菩提。明虚空法身古今湛然体无色相。可以报应二佛具足色身见不也。故须菩提答不也世尊。如来不应以色身见。此明三佛别相异义边。明法身如来古今湛然犹如虚空。不可以报应二佛具足色身而见故。不得说即法身上有报应二佛具足色身。此一句慎上经中三佛别相法身义边不可以二佛具足色身见也。何以故者。有人乘此生疑。若法身如来古今无相犹如虚空。不可以报应二佛具足色身见者。法身便一向无色。若尔则异于法身。别有报应二佛具足之色。则还同前疑。三佛条然别相。何以故复作如是说也。故即答如来说具足色身。此明三佛一义边。即法身上有功德智慧二种庄严。真如解脱色万德圆满无所缺少。以修行因缘。显本有法身。以为报佛故。即法身上。有此具足色身也。若法身中无具足色者。则不应有报应二佛具足色身。以斯义故。得道即法身上有报应二佛色身。此明三佛不异义也。是故上言一切法皆是佛法。覆复生疑。若即疑若即法身上有报应二种色身者。便法身中有色上不应言报佛三十二丈夫相及应佛相非法身相也。又亦不应云法身古今一定如虚空也。故答言即非具足色身。明向者就三佛一义边得云即法身上有具足色身。若据异义边。明法身古今一定无有二佛色身之用故。上初句云不应以具足色身见故。言即非具足色身也。此成上经三十二大人相即是非相也。若法身上无报应色者。还同前疑。若法身佛就体无色身可见者。此之色身则条然异于法身。那得道言即法身佛上有具足色身也。故答言。是故如来说名具足身明法身中虽即无报应之色可见。然正显法身作报佛色身之用。由有报应故。不离法身有报应之色。故言如来说名具足色身也。此成上第二句一义边一切法皆是佛法也。又复就理而言。亦得云是故如来说名不具足色身。所以得云不具足身者。就异义边论。明即法身佛上无二佛色身之用故。亦得云不具足色身。此句双结三佛一异有色之义。但以答难故。直云是故如来说名具足色身。此成上异义也

又问。此中但就色身。明具足之义则足。何故复明诸具足也。有人乘无生疑。若法身佛上无具足色身。此法身佛。为有三十二相。为无三十二相。为一为异也。有如此疑问。以故诸相经答。明因色身故则有三十二相。上已了了解释即法身佛上有具足色身。即法身上无具足色身。何得难言若法身无色为有诸相为无诸相也。诸相四句经文不异前具足色身中义。故不别释也

论曰复有疑若诸佛以无为法得名者。牒上第六段中经来也。论主略申生疑所以。云何诸佛成就八十种好三十二相。而名为佛者。序作难之辞。云若法身佛无为法得名如虚空者。与报二佛色相之身。为一为异等也。广作疑问。不异经相也。生起为断此疑是故说非成就色身非成就诸相者。略举经中色相二处三佛异义经文答其不异之难。又色摄得八十种好三十二相。复举上二处三佛一义经意。答其异疑也。如经以下。举二处一异经来结也

此一段文。以二行偈释。初释经中法身佛不可以具足色身见不可以具足诸相见。第二偈上三句。释经中如来说具足色身具足相身。下一句释经中即非具足色身即非具足相身是故如来说具足色身具足相身等经也。何故如是说者。将欲偈释故。先问何故不定。答乃作如此不定之说。或言法身有色相。或言法身无色相也。故即偈答法身毕竟体非彼相好身。此二偈明就三佛异义边不得言有色相。一义边得言有色相也。法身毕竟体者。以初二偈释二处经中佛问须菩提答乃至如来不应以色身见不应以相身见等。明虚空法身毕竟无有报应色相之用可见故。云法身毕竟体也。何以故。以报应色相之身修行方得故。色相之身显用于报应。真如法身虽万德圆满。但据体而论。故无色相之用也。如冬树无果以时未至故。非一向无也。若一向无者。应时至亦无。以此喻验之。法身非不有色相。以时未至故不可见也。非彼相好身者。明法身非报应相好身也。以非相成就者。所以言法身非相好身者。以法身不为现用相好所成故也。法身何故不为相所成。故下句云。非彼法身故。明相好之身。非古今一定法身之体。故言非彼法身故。此明法身佛异义也

第二偈上句。释经中何以故如来说具足色身具足相身二处经文也。明法身上虽无色相之用可见。然不离于法身。以修行因缘。则有报应色相之用。毕竟不从余处来也。故云不离于法身彼二非不佛也。彼二者。彼色之与相。非不是法身佛故。第三句云故重说成就。下一句并释法身中亦得言有色。亦无二者。此明虚空法身中毕竟无报应色相。故言亦无二。释经中即非具足色身相身也。虽法身上无。亦得道即法身中有。故云及有二。此明不离法身报应色相之身也。释经中是故说具足色身具足相身也。此二偈说何义至以非彼法身相故。释初偈。明法身异义边无色相也。此二非不彼乃至偈言彼二非不佛故。释第二偈上二句。引所释经证。举偈第二句。结明一义边法身有色相也。是故此二乃至以不离法身故。释第二偈中下句。明法身中亦得说无教应色相。二亦得说有色相二也。所以此中再边。释此一异之义者。但经中为释难故。有其两重故。论主亦重释也。是故此二。亦得言无故说非身成就非相成就。此是释法身无色相义。经论相属也。亦得言有故说色身成就诸相成就者。此解法身有色相义。经论相属也。偈言亦无二及有者。释竟以偈结之也。何故如是说者。设问也。以彼法身中无即于是义者。答法身中无色相所以也。说如来色身成就诸相成就。以不离彼身故者。答法身有色相所由也。而法身不如是说者。明虽不离法身有色相之身。而法身义边古今一定毕竟无此色相。为生下疑故作此句。欲使乘无生难因言长理故后章得显也

佛言须菩提。于意云何。汝谓如来有所说法耶等。此断疑分中第七段经文。已三遍来此所以来有疑故也。上来广辨法身之体毕竟无有有为万相。又此前段经。复明虚空法身异义边。体无报应色相。若法身无色相。则亦无眼等诸根。既无诸根。亦无口业。云何言如来说此法。问法身佛为说法。为不说法也。若法身佛不说法者。报应二佛亦应一向不说法。又疑若使如来说法者。为即此证智法身有言教可说。为离此证智法身别有此言教可说也。为断此疑故。答于意云何汝谓如来有所说法耶。此答意明法身之体无名无相毕竟无色相可见无言教可说。又虽无色相诸根。然要显法身。为报佛由。法身现时为报故。得言因法身有色相诸根。有口业。有言教说法。故上论云圣人证无为法。还说无为法。若以此文验者。虽即证法无言教可说。亦不得离此所证法身。别有教法可说也。于意云何者。此应有问答。而不作问答。故如来直问须菩提于意云何。欲使冥解而答也

如谓如来作是念如来有所说法不者。问须菩提。汝谓如来作念谓于无名相证法中有名相可说不。汝谓如来作是念离于所证法更言教法可说不也。莫作是念者。遮须菩提此念。汝若谓如来于证法无名相理取同名相可说者。此是不正念。若谓如来离于证智更有教法可说者。此亦是不正念。故言莫作是念也。何以故。须菩提。若人言如来有所说法。则为谤佛。不能解我所说义者。此释前何以故汝向所说是不正说。若人言如来有所说法。则为谤佛。明实不作是说。道言如来作此说。即诬圣言。故言谤佛。此人所以生谤者。以不解如来所说理教一异之义故。云何不解。闻言证法无名相。便谓离于证法条然更有言教可说。不知证智无名相无法可说。故曰不解义。不知因寻教得理由证有说。故不解义也。何以故者。此世辨释名。何以故道言如来有所说法。则是谤佛也。故下即云。如来说法说法者无法可说。明说法有二。一是所诠证义。二能证言教。然此理教虽殊。而本末相由。理无条然。若谓证法有名相可说者。此不解圣意。名为谤佛。闻言证法无名相。便谓离此证法别有言教可说。复是不解圣意。亦为谤佛也。无法可说者。明证法无言教可说。离于证法。亦无言教可说也。是名说法者。如是解证法无名相可说。不离证法有教法可说者。方名正解方名正说。故言是名说法也。亦应言是名非说法。明若不如是解证中无名相可说因证有名相可说者。故非说法也

论曰复有疑乃至若相成就不可得见者。牒次前无色无相经也。云何言如来说法者作难。自下经文以下。引经申断疑之意也

此经以一行偈释。如佛法亦然者。释经中乃至不能解我所说故。如佛者。如前经中明法身佛上有色相无色相三佛一异离即之义也。法亦然者。佛既如此。理教法一异义亦同也。明能证言教所诠证义。依此而论。亦得言有差别故。次第二句云所说所二差别。此释经中说法说法者二差别者。理教殊也。此明能诠所诠异义边亦然也。亦得言无差别故。下二句云。不离于法界。说法无自相。此释经中无法可说是名说法也。不离于法界者。明圣人证于真如法界。还说此真如。故知此所诠证义能诠声教不得相离。此明一义边亦然也。说法无自相者。既如证如说。离于真如法界。更无言教自相可说。即证智体无有名相故。亦无言教自相可说也。长行论初。何故言说法说法者。提经为问也。即指揭答言所说二差别故。何者是二乃至所有义。此出经中。重言说法说法者。偈中二也。何故言无法可说者。若有言教能说。复有所说。义便应是有说。何故言无法可说也。即以下半偈答言不离于法界说法无自相故也。此以何义以下。有一问答释偈也

尔时慧命须菩提白佛言世尊颇有众生于未来世间说此经法生信心不等。此一段经。是断疑分中第八段经文。复所以来。此亦有疑故来也。前段经。或明法身体无报应色相之身。或云即法身上有报应色相。今疑者偏报无边生难。若一义边。即法身上有报应色相者。法身佛既体如虚空。不可以色相而见。此报应二佛。与法身一故。则应是无。又次前经。明真如法界体绝名相。与言教有异。复云不离真如法界。有言教可说。若尔此真法界体亦如虚空。无有声教。此声教既与证智体一。应亦是其无。以证法无名相故也。此之两处。或明法身法界无色相言教。而复言不离法身法界有此色相言教。斯二段经一异之义。至深难解。为但现坐能信。为未来世中亦有人能信。为一向无人能信也。又若有人能信者。有何等人。能生信心。为是凡夫。为是圣人也。有如此疑。故须菩提问颇有众生闻说此法生信心不。佛即答彼非众生非不众生。此答意明经理虽甚深难信。然非但道益当时现坐生信。明未来世中亦有人能信。何人能信。明要地前地上二种菩萨。久供诸佛。殖因深远。具足二种无我解者。能信此经也。经言彼非众生非不众生者。此出有能信人也。应直答言菩萨有智慧人能信此经。何故乃言彼此众生非不众生也。然此圣人相解。其言虽隐。而能于此言取悟也。彼非众生者。明彼能信人非无智慧不修行不曾供养诸佛闻此经未生信众生也。非不众生者。非不是能信圣人众生。明此人已曾供养过去诸佛。修行来久。闻此深经。则能生信无疑。是故彼非无智不信众生。是有智慧能信众生。故次明也。何以故者。此世辨释前。应问何以故名此能信人。作彼非众生。何故复名为非不众生也。我未解此义。唯愿如来为我解说。即答言须菩提。众生众生者。此重牒前彼非众生非不众生。然后释也。如来说非众生是名众生者。明此能信人非是底下愚痴凡夫信众生也。是名菩萨摩诃萨能信圣人快众生也

论曰复有疑。若言诸佛说者。是无所说法不离于法界。亦是其无者。牒前有色相无色相有说法无说法二处深经也。有何等人。能信此甚深法界者。作疑问之意也。自下经文者。指经为释也。所说说者深者。以此一偈。释斯一段经。依经次第。应言说者所说深。但以阐陀论法随逐语便故。言所说说者深。亦以乘势明义故也。正释经中闻说此经也。所说者。牒前经中如来所说理之与教。说者。牒前不可以色相成就见法身如来等。经中所明三种佛能说人也。深者。明前所牒二经一异理深。即举疑。斯之二经。佛说太深。于未来世。为有人能信。为当无人能信也。故下句云。非无能信者。此句明有人能信也。应问何者是能信人。故下句即指出其人非众生众生。释经中彼非众生非不众生。非众生者。明非无信众生也。众生者。是有信众生也。非圣者。此世辨释名。非众生者。非是不圣。正是圣也。故即云非不圣也。此是出其能信之人也。何故言须菩提非众生非不众生者。提经为问也。偈言以下。指下半偈为释也。此以何义者。此生偈以何义故。得释彼非众生非不众生经为能信人也。即释若有信此经至非凡夫体故。解经偈中彼非众生也。若有信此经彼人非众生者。取偈上二句中能信义也。非众生者。提偈第三句中非众生来也。非无圣体者以偈。下句中非圣两字。释前非众生也。非无圣体者非凡夫体故者。此是论主结能信者是圣人非凡夫体也。非不众生者。提经来也。以有圣体故者。以偈第四句中非不圣释之也。彼人非凡夫众生非不是圣体众生者。结此能信为非凡夫是圣人也。如经何以故至是名众生故。引如来成释为证也。如来说非众生者。非凡夫众生。我论主释经。是故说众生者。结为能信圣人众生也。众生者。以圣人众生。是故说非众生者。以是能信圣众生故。结为非凡夫众生也

佛言须菩提。于意云何。如来得阿耨三菩提也。此等是断疑分中第九段经文。此已五遍来。文虽相似。而义有殊。故非重也。此所以来者。为释疑故也。此疑从何处生。上来已广明法身古今体满非修得法文。即此断疑分初第二段。经中言无有实法如来得阿耨三菩提。明法身菩提非有为法故不可以有为相得。即复言如来所得阿耨三菩提。明菩提之体是无为法故有菩提可得。复以大身譬喻释成。明法身本来圆满具二庄严。离于二障。非修行得。即生疑云。若言如来得三菩提者。为修行故得。为不修行故得。若法身菩提古今一定犹如虚空。万德圆满。非修行因缘然后可得者。云何言行者一阿僧祇修行满足。证于初地。转得七地二阿僧祇满乃至上上转胜。三阿僧祇后。证佛果菩提也。以此验知。法身便由修行因缘可得。后方圆足。那得道法身如来犹如虚空万德圆满非修得法也。若由修行得者。云何乃离于上上证所得报佛。而说别有法身如来。此执一难异也。又次前第六段经。明法身犹如虚空体无诸相非修行得法。故不可以具足色相而见。乘生疑念。若法身非修得法。无色相可见者。云何菩萨修行因缘。转转证得阿耨三菩提也。此疑既起之在先。所以令方断者。以中闻更乘生异疑。遣之未尽故。今方释也。此谓为疑故。经中答意。明佛有二种。一法身佛。古今湛然体性圆满。非修得法。此即性净涅槃。二者报佛。藉十地方便修行因缘。本有之性显用之时名为报佛。即方便涅槃。不可以报身方便修涅槃行得故。便使法佛性净涅槃亦修行而得。为释此疑故次明也。然就斯一段经。凡有四子句。前三句。明法身佛性净涅槃。体相圆满非修得法。后一句。明报佛方便涅槃。亦万德圆满。而有无方大用。是可修得法也

无有少法得三菩提者。此是第一子句。明法身如来万德圆满无所缺减。虽在烦恼染法。于万德中。不少一法。非以修行因缘后方满足故。得名为无上菩提。故云无少法得三菩提也。此就法体满足。以明法身非修得法也。复次须菩提。是法平等无有高下。是名三菩提者。此是第二子句。释初句。法身所以万德本圆。非修行方满者。以法身古今一定。非以由人修行因缘故在圣人心中万德增名为高。非以人不修行因缘故在阐提心中万德减名为下。此就行者。以明法佛体无增减非修得行也。以无众生无人无寿者得平等三菩提者。此是第三子句。释前第二句。法身所以平等无有高下者。明一切众生法身体相万德皆等。无此功德多彼功德少。本来寂灭。自性离障。一切平等。无有我人等或。不如金刚以还因中行者。行有深浅。断惑有多少故。胜如不同。有忧劣之别。故起慢心。自谓我功德多。遣惑亦多。彼劣于我。所以有此分别慢者。以其先有烦恼。遣之未尽。故有我人等见。明一切众生法身佛性无有忧劣。从本以来。清净体无惑染故。言无我人平等得三菩提故。胜鬘经。刹那善心非烦恼所染。刹那不善心亦非烦恼所染。依西国。刹那有十种名。此言刹那者。憣为空也。明空善心非烦恼取染。不空善心亦非烦恼所染。空善心者。明古今一定法身如来藏体空。无二十五有生死万相。故言空也。不空善心者。明法身自性体备万德妙有湛然不空也。故即上经言空如来藏也。前二子句。明法身妙有即不空如来藏。此一句。明法身妙无即空如来藏也。此就无鄣清净。以障法佛平等满足非修得也。此前三句。宛转释法佛性净涅槃义竟也

时众闻言法身古今圆满非修得法。乘即生疑。若尔何故诸菩萨发菩提心。三大阿僧祇。修十地行竟何所为。故答一切善法得三菩提。此是第四句。明报佛方便涅槃有修得也。所以据报佛。明有修得者。然报佛要就行者修得现用时语。既就行者论之。便有修行因。缘万善满足。则有法可得。前但据性体本有为言。而不辨其用。今就行者会时而语。佛性有用。以有用不用异故。得云有增减也。复就行者断惑。有多少故。有忧劣不同凡圣两别。据行者显报有于修得故。言一切善法得三菩提也。乘兹即生疑念。若一切善法得三菩提者。疑谓一切名滥。有漏无漏世间出世间善法。俱是一切。可皆得菩提也。若皆得者。何故上论偈言福不趣菩提也。以断此疑故。答言须菩提所言善法善法者。如来说非善法。是名善法者。此明善法有二。一有漏善法。二无漏善法。如来说非善法者。明向一切善法是一切无漏善法。非是不趣菩提有漏善法也。故下句云。是名善法。此明是名无漏善法。亦得言是名非善法。明无漏非有漏故也

论曰复有疑。若如来不得一法得三菩提者。举所疑经来也。云何离于上上证转转得三菩提者。作难也。自下经文为断此疑。示现非证法名为得三菩提者。论主略引经中断疑意也。此以二偈。释兹一段。初偈释前三句。明法身无修得。下一偈释后一句明报佛有修得也

彼处无少法知菩提无上。此二句释初子句。知菩提无上者。以知彼法身处体相满足无所缺少故。得名为无上最胜菩提也。法界不增减者。释第二子句。明此法身。非修得方满名为增。亦非不修行故少名为减也净平等自相者。释第三子句。明法佛体上古今清净。从本以来无我人等或。故言净也。第二句知菩提无上。依下长行论。释此一句。义通前三故。上三句下。皆应言知菩提无上也。第二偈有无上方便者。释第四子句。明报佛是修得。就现用义边得名为增。未用义边得名为减也。及离于漏法等下三句。释第四子下须菩提所言善法善法者等释疑经文也。及离于漏法者。明报佛方便之因。无漏善法。体离诸漏。非有漏善法也。是故非净法者。明有漏善法非是无漏清净善法也。即是清净法者。如是非有漏善法故。即是出世无漏清净善法方便因也。何得以有漏善法于菩提无方便因。难无漏善法亦使非方便因也。此明何义以下。至经一切善法得三菩提。释二偈中上五子句。解经中四子句也。先次解释。后以经结之也。余菩提善法不满足者。谓因中方便菩提。亦谓二乘菩提。体未满足。须更修习故。言余菩提者善法不满足也。须菩提所言善法者如来说非善法等。何故如是说者。先提下答疑经为问。即牒后偈下三句为释。此以何义以下。复设问也。彼法无有漏法故。名非善法者。此解无漏善法。非是有漏善法故。如来说名为非善法也。以无有漏法。是故名善法者。解无漏善法为善法也。以决定善法者。结无漏善法也

金刚仙论卷第八金刚仙论卷第九

        魏天平二年菩提流支三藏于洛阳译

须菩提三千大千世界中所有须弥山王等。此是断疑分中第十段经文。此三千譬喻已四遍来。何故数来。而非重者。此乃文句相似。而义有别。故非重也。此复所以来者。有疑故来也。云何为疑。前段经中答疑四句。初有三句。明法身菩提性净涅槃。本体圆满非修得法后一句。明报佛方便涅槃。由修一切善法方便因满。法身有用。是修得法。难意。若法性法身非修得者。身有报佛亦不听是修行得得也。何以故。上挍量分中。明受持读诵此经能诠言教。依而修行。善法满足故得三菩提。然此经教音声之性证法中无。念念生灭。无有习因增长之义。体是无记。非为善法故。受持经教不能发生三慧之善。不生三慧善故。无有因义。既无因义。则不证菩提。那得道言一切善法得阿耨三菩提也。故干须弥七宝布施胜福譬喻。以答此疑。明此般若一偈经教从证法中来。非是无记而能诠于法身。若依经修行因缘。能显性证果。得大菩提。胜于三千须弥珍宝布施之福。不可算数故。不应难言经教是无记故受持修行不能得大菩提。为除此疑。次明此一段经也

百分不及一等者。论云算类胜。此明有漏福德是有尽法故数亦有限。明无漏善法是无尽之法数亦无限。所以胜也歌罗分不及一者。论云力胜。歌罗者。西国正音如折一毛以为百分一分。名一歌罗。此义憣为力胜。以无漏善法功德势力胜于有漏善法故。名为力胜也。数分不及一者。论云不相似胜。犹是其数数中。转微转细。乃至少许犹不及一故。名不相似胜也。明此无漏善法若有形色者虚空法界所不容受。以有为有尽法。形无为无尽法故。假令乃至少许亦不相似。如分芥子以为万分。拟须弥山。唐失其身。终不相类也。优波尼沙陀分者。论中义憣云因胜。明因果不相似。珍宝有漏善法。但得三界报。因果俱是不如。无漏善法乃远得佛果。因果俱胜故。名因果不相似也

论曰复有疑以下至不能得大菩提。执经作难。何以故。以所说法是无记法。释成难意。为断此疑以下略申答意。生于下偈也。凡以二偈。释兹一段经。初一偈。解持经功德胜布施之福经教是无记非因之疑也。第二偈。释四种胜。从百分不及一乃至所不能及也。虽言无记法者。举疑意。前疑言。经教是音声性无记之法。依此无记法。受持修行。则无善。则无因义。何得言以一切善法得三菩提也。故答云虽言无记法。此句慎疑者意故。云虽言无记然。音声言教虽是无记之法。而能诠于佛性涅槃之理。依而修行。发生三慧胜解。能使行者终克常果。有诠理益初咸果之能。此明言教虽是无记而有因义。故次下句云。而说是彼因。若尔那得难言以无记故无有因义则无修行得菩提者也。此释上半偈也。又一解经非是无记。何以故。以此经教从真如证法中来。是其一分为此真如证法所勋故。言教非是无记。有其因义。如以须摩那华及薝卜华。勋胡麻子。后押得油。名须摩那油及薝卜油。此言教亦如是。为证法所勋。非是无记故。受持读诵此能诠言教。发生闻慧。从闻生思。从思生修。次第修行。乃至证得无上菩提。胜于三千须弥七宝施福。以三千须弥七宝有漏施福不能得大菩提。是故不如。故下半偈言。是故一法宝胜无量珍宝。一法宝者。此般若经一行偈。名为法宝。是故者。是故经教非是无记。有其因义故。便胜无量珍宝布施有相之福也

此义云何虽言所说法乃至能为菩提因。释上半偈。论主且顺疑者意。明经教虽是无记而有因义也。又言无记者此义不然者至胜无量珍宝故。此解下半偈。即举偈结也。此违疑者意。正解经教非是无记法也。汝法是无记而我法是记者。汝小乘法中胃声教为无记。今依我大乘中。明音声经教从佛法身记法中来故是记法非是无记。又行者身口意业有所起作。皆有招感之能。亦有慎理益物之义故。诸佛说所经教。音声之性。是口业善。能慎理益物非无记也。是故此所说法胜彼阿僧祇须弥珍宝故者。结受持经教福德胜珍宝施福也。如经以下以经结论也

此示何义者。此一段向如经者。通引持经福。结作胜珍宝施福义。然未知释胜有几种故设问。问此百分不及一等此示何义也。即作第二偈。答数力无似胜也。此一句中。合释三种胜。谓数胜力胜无似胜也。无似因亦然者。此明第四因胜。为成句故。通引无似来也。一切世间法不可得为喻者。无漏善法。能与佛果作无尽之因。一切世间有漏法中。无可为比者。故云不可得喻故也

此说何示于前福德此福为胜者。此一问答。通解一偈所明胜义也。云何为胜。一者数胜等。数出上半偈中。四种胜也。是故偈言等。举下半偈。结作胜也。数胜者以下。一一别提四种胜名。略释名。举经属当可知也。又此法最胜无有世法可喻。此法者。释下半偈。即引偈结也。如是此福德中以下。结受持福胜也。须菩提。于意云何汝谓。如来作是念。我度众生耶等。此是断疑分中第十一段经文。所以来者。斯有疑故来也。云何疑。上第九段经中。前三句。明法身平等。本来满足。无所缺少。不由修行而得。复无高下。亦无我人众生寿者相。平等得三菩提。此明就佛性法身平等理中古今湛然无有彼此凡圣两别也。难者云。若法身平等。无有凡圣差别者。则亦无修道得果之人。若无修道得果。云何经中言。如来度众生。若佛度众生。则知如来修行断惑可有满足法身。众生未修行断惑则无满足法身。若然便由修行断惑因缘。得大菩提。非有古今圆满法身不由修得。明矣。上第三住分及此断疑分第四经中。并言菩萨若作是念。我度众生。则非菩萨。此二处。明菩萨于真如平等理中不见众生真如法身异于己身真如法身而可度者。然菩萨位在学地。处不定之境。断惑不尽。见理未圆。于平等理中。若见众生真如法身不满。异于己身真如法身。起心度者。尚非菩萨。况如来行满惑尽。位居无学。云何而言佛度众生也。此明佛与众生法身平等无有增减亦无高下。故离真如法身。无别众生可度。若言佛度众生。则法身是修得法。非本净平等凡圣共有。以此验知。诸佛修行得果可有法身。众生未修则无法身。若众生无法身。则不得言法身平等体无增减无所缺少。亦不得言法身本净无我人等也。以有此疑故。经答言。汝谓如来作是念。我度众生耶。此佛问须菩提。汝谓如来起心分别。我由修行因缘断灭尽故。有满足法身。众生未修行断惑故。无满足法身。谓异真如来法界。外别有众生。而欲起心度之。令得解脱也

莫作是见者。遮其见心也。何以故者释。前明我何以故止汝莫作是见也。即答实无众生如来度者。然佛与众生。虽凡圣有异。而满足法身平等无差。此明即真如来平等理上有此众生名字。更无别定实众生异于真法界而为如来度也

如文殊般若经说。假使十方一切诸佛。一一佛住世。若一劫。若过一劫。昼夜说法。心不暂息。各各度于无量恒河沙众生。皆入涅槃。而众生界亦不增不减。何以故。离真如法界外。众生定相不可得故。是故众生界不增不减。又华严经云。不增众生界。不减众生界。此就平等法身真实法界理中。明无增减也。又小品般若中说。一切众生本来清净。假令诸佛。于百千万劫。唱言众生众生。而无一定实众生可得也。若以此等文验。于平等理中。无有众生异于诸佛而可度也。又若佛度众生。则是佛自度佛。法界还度法界。以此故知即法身上有此众生名字。不离法界外别有众生可度也。故不增不减经言。惑覆法身名为众生也。即复有疑。正可无定实众生可度。非无五阴所成虚假众生。如来何故不度。故经答云。须菩提。若实有众生。如来度者。如来则有我人相等见。此明非但无有定实众生可度。乃至亦无虚假众生可度。何以故。正五阴法上。名为众生。然此五阴无众生体。非但无众生体。复不异佛性土有是众生五阴虚妄名字故。亦不可度。若如来起心。谓异于真如法界有五阴所成虚假众生可度者。则犹有我相等惑不尽也

乘复有疑。若如来无有我相等惑者。如来何故自云。我过去曾作转轮圣王帝释梵王等。以此验之。明知如来有我相未尽。不应言如来无有我相也。故答言。须菩提。如来说有我者非则有我。明如来随世俗语故。言有我。非谓有我人等相未尽故也

乘复生疑。应有神我。若实无有神我。何故一切人皆云。有我。我过去从天道中来。人道中来也。故答而毛道凡夫生者以为有我。明毛通凡夫。怀取相之心。于无我法中。计有神我。从过去中来。不灭至于现在。故妄言有我。非谓理中实有我也。毛道者。此义释云。愚痴闇冥无有智慧。名为毛道。此中须菩提应问。世尊。云何名为毛道凡夫。我未解此义。愿如来为我解释。故佛答须菩提。毛道凡夫生者。如来说名非生。此云生者。生之言。起毛道凡夫。起于我见。故言生也。此生西域云禅那。依世辨论。无正名相憣故。且就义解。作名云毛道凡夫生也。说名非生者。明毛道凡夫但能起于我见等。或不能生彼出世无漏圣解。故言非生也。是故言毛道凡夫生者。是但能起于我见。不生圣人法故。结名为毛道凡夫生也。论曰复有疑若是法平等相无高下者。牒此段第九生疑处前三子句经也。云何如来名为度众生者。设疑难意也。自下经文为断此疑者。申此经来意。为断此疑也。此一段经以二偈释。初偈作问答意。释前二疑经。义势未尽。拘琐入下第二偈上三句也。第四句释后二疑经也

平等真法界佛不度众生者。明真如理中佛与众生法身平等无凡圣两异。何得谓于真如法界外更有一定实众生与佛有异而可度也。释经中何以故实无众生如来度者以前经文也。即难若真如平等理中无众生可度者。非无虚假众生。何故不度也。故下半偈云。以名共彼阴不离于法界。此明假名众生为五阴所成。此五阴法体。亦是虚妄。依真如有故。无别虚妄众生可度也

此义云何以下至偈言不离于法界故。先释下半偈众生假名与五阴共故。解偈第三句也。彼名共阴不离法界者。释作名阴共义也。即引第四句。证不离也。论主何故先释下半偈者。疑者谓众生无法身。此下半偈。明众生五阴即是法界中名。当知等有法身故。先解下半偈。然后释上半偈。平等中佛不度众生便故也。自下解上半偈也。彼法界无差别者。正解初句。即提所释偈言平等真法界故也。是故如来不度一众生者。是法界平等凡圣无异。故佛尚不度一众生。何况多也。即以偈第二句。结佛不度众生故也。如经何以故实无众生如来度者。结上半偈也

佛言须菩提以下。结后半偈。复拘琐生下第二偈也。第二偈取我度为过以取彼法是取度众生故。此三句共前偈下二句同。释经中若实有生如来度者如来则有我人众生寿者相等。此句为明如来无有取众生相。而欲度之。令言若度。则是取相过者。此举有过。以明无过。故知异法界外无别有五阴所成虚假众生为如来度者也。取我度为过者。明如来若专念见有五阴所成虚假众生异真法界而取度之者。即有取相之过。云何是过。答以取彼法是。以取五阴等法虚妄有为。以为众生。欲度之令得解脱故为过也。上虽言以取彼法是。未知作何等意取。故第三句云取度众生故。若如来自谓已是佛无烦恼人。见众生是凡夫具足烦恼。无有法身。令拔之令离此或。此是取相过也。不取取应知者。释经中如来说有我者则非有我而毛道凡夫生者以为有我也。答第三何故说我疑也。不取者。明如来解生阴本来虚妄无实众生可度。故云不取。取者。毛道众生不解生阴体虚。谓为定实有我。故言为取。应知者。此凡圣二人取不取义。劝人知也

此义云何至取我度为过故。释偈初句。即举偈来结也。以取彼法是至有如是相故。此中间二句。先提偈于前。然后解释也。经复言须菩提如来说有我者等此义云何者。此提第四句所释经。为问也。偈言不取取应知者。提偈与经相属当也。此以何义以下。释偈中取不取义。明如来不取凡夫取也。又须菩提毛道凡夫生者。如来说非生者。以此经偈中未释故别提来也。不生圣人法故名非生者。此是弥勒世尊释明所以言毛道凡夫生为不生者。由不能生圣人法故名非生也

须菩提。于意云何。可以相成就得见如来不者。此断疑分中第十二段经文。已六遍来。所以复来者。有疑故来也。谓虽复上来广为我解法身如来无有色相可见。若不了见便应是无。然复言虽不可见而是妙有。若有应是可见。然今道有而不可见者。明知无别无为法身非修得法也。正修方便万善。三十二相因。缘福德业。所得佛果。无量相好身时。即有法身。那得离此之外别有法身也。若由修行因缘。得相好身时。即有法身者。便以修福德因缘。得真法身。如经中明。佛修三十二相业时。以头顶礼拜三宝师长父母故。得无见顶相。助他为善故。手中得罗网相等。以此报相既为因得。类知法身亦应是可修得。若可修得。前经中不应。以初三句。明法身无修得。后一句一切善法得三菩提。明报身有修得。以此比知。由修福德行。见报佛色相者。即法身。故知法身是可修得法。不应别有古今一定法身是非修德法也。有如此疑。故答意明不可以报佛色相为因所得是可见故。如此比类。亦谓法身是可见。亦为福田所得也。须菩提于意云何。可以相成就见如来不者。佛问须菩提。于汝意地。以智慧思惟筹量。可以福德业所得大夫相身。见法身如来不也。故须菩提即答。如我解如来所说义意。不可以报佛福德业所得成就相身见法身如来也

佛言如是者。如来印可须菩提所说当理。佛去大众疑心。明实如汝所说。不可以福德相成就身比知见法身如来也。佛言须菩提。若以相成就观如来者。转轮圣王应是如来者。明若以报佛有色相身。为修因所得。谓法身佛亦为因得。由修行因缘。后方有者。世间轮王。亦有三十二相八十种好。岂可亦是法身佛也。此中乃难法报二佛。何故引轮王来。反质者。然此二种佛。义有一异。别相难分。引轮王非况类。释使疑者解拨理虽一。就体用义殊故。所以二佛异相历然可见也

论曰复有疑。虽相成就不可得见如来至法身为体。此惑者诡顺如来上来所释法身之义。然虽似领解。而犹有疑心未尽。意欲更作疑难。故牒来也。而如来法身以见相成就比智。则知如来法身为福相成就者。此是作难之辞也。而如来法身者。疑者云。如来难作此解。而我意犹谓无别无为法身不可以相见不为因得也。以见相成就者。疑者谓以见报佛福相成就身时。即有法身。非本有也。比智则知如来法身为福相成就者。明报佛既为福得因所得。可以相见故。比智类知法身如来亦应为因所得可以相见。宁别有无为法身古今一定。不为因得不可以相见也

自下经文。为断此疑者。申经之来意也。此一段经。以二偈释。初偈释经答疑。非是色身相可比知如来者。明非以福德业方便因所得色相之身是可见故。谓以比此知法身如来同于色相亦是可见。更无别无相法身故。下半偈云。诸佛唯法身。转轮王非佛。诸佛唯法身者。明法身佛虽不同报佛色相可见是修得法。而有二种庄严。真如解脱。具足色相也。若以报佛有色相。即谓是法身者。轮王有三十二相。应是法身。然轮王有相非法身者。报佛有相。亦非即法身佛也。此义云何。有人言。福德能成是相。至阿耨三菩提。此是论主重引疑者之辞也。为遮此故以下。还举释疑经来为解也。是故非以相成就得见如来故者。是轮王有相非法身义。故非以报佛可以相见为因得故。亦令古今一定无为法身同使为因得可以相见也。而此长行论。直举疑意。指经为解疑答义尽。不释于偈也。然以上一偈。释经答疑俱尽。何故复作第二偈者。上偈就别相义边。一向明色相非法身佛。惧畏众生以报身色相全异法身。即弃舍报佛之义故。作下偈。明虽法身不可以报佛色相比类而取。就一义边。然即此法身显用名为报佛故。不应全弃也。此偈上之三句。犹释法身体非色相不为因得。不异于上。所以重来。但取下句方便异相故。为欲成偈。所以重来也。方便异相者。明如来有二种身。一者智相身。二者异相身。智相者。是法身如来真如解脱相。方便异相身者。谓报佛福德相好庄严之身。为方便同所得。与法身义殊故。名异相身也。而此相好报身。正是法身显用。故名报相语其体也。本无殊技。那得闻言就异义边。辨法身无相好。便谓离法身之外条然有报佛色相可得。弃其所以一义也

尔时世尊说二行偈者。是断疑分中第十三经文。所以来者。次前段经。解法身古今湛然犹如虚空。不可以福德业所得报佛大丈夫相见。将欲释成此义故。说两偈也。初偈上二句。明法身体绝色声。不可以视听而取。下二句。明若以因见闻而取法身者是人行耶道。不能见法身如来也。第二偈上两句。正出法身体。有真解脱色声。古今湛然。非一向无色声也。下半偈。明此法身虽体有真实色声。而非识相之境。故所以不知若以色见我。以音声求我者。若语当时发声说偈者。是应佛口业。亦道报佛口业。若就理而言之。是法身佛说也。明不可以报应二佛所得色声见闻于我也。此明就释迦法身不可以色声见闻。类一切众生法身如来亦不可以色声见闻也。若谓法身同此色声可见闻者。是不正见故。第三句云。是人行耶道也。不能见如来者。如是取法身。同于色声。不能见彼法身如来也

有人乘此生疑。若法身如来。不可以色声而见闻者。一向无法身。又法身一向无色声。此之色声则条然异于法身故。第二偈答彼如来妙体。明彼法身虽不可以色声见闻。而向者色声。即此法身妙有体上有彼色声故。上经云。不离法身有色相可见。不离证智有声教可说。又十地经七地中言。知诸佛法身自性无身。而起色身相好庄严行。知诸佛音声无声。本来寂灭不可说相。而随一切众生差别。庄严音声行也。以此文验。故知法身虽无色声。不离法身有此色声故。第二句云。即法身诸佛。明法身之体具足万德故。有色声性也。或者闻即法身上有色声之性。便谓法身有色声可用凡夫虚妄分别心意意识而得见闻故。第三句云。法体不可见。明法身虽有色声之性。不可以凡夫视听而见闻也。虽云法身不可见。未知不见者谁。故第四句云。彼识不能知。明彼法身虽体有色声。而无色声之用。又不闻下地色声故。凡夫六识不能见闻也。非但凡夫不能见闻。二乘圣智亦所不见闻也

此二偈经。论主但以一偈释。初二句。释前一偈。明若以法身同于二佛色声而可见闻者是人不知法身佛也。下半偈两句。释后一偈。明真实法身虽有色声之性非六识境界。故不可见闻也。此示何义如来法身至不应如是见闻。论主释偈论初句。解经中前偈上二句。以何等人不能见谓凡夫不能见者。释偈论第二句。解经中前偈下二句也。解已举论中上半偈。释经中前偈下两句结也。是人者。凡夫人等。牒前所引是人不能见法身如来也。即拘琐释论中下半偈。解经中第二偈。即具引所释经结也

须菩提。于意云何。如来可以相成就得三菩提耶。此一段经。是断疑分中第十四段经文。此经已七边来。所以复来者。上已广解无为法身古今一定妙有湛然体无诸相不为修行所得。又次前二段经。明法身体自满足非修福德业所得相好色声而可见闻。或者执谓正以菩萨始从发菩提心。三大阿僧祇劫修。十地行满。金刚心谢。证种智时。名为报佛。有无量相好者。即是法身。故谓法身是修得。亦可见闻。今闻别有无为法身不为因得。复不可以色声见闻。乘生疑难。若法身体无诸相。不可见闻。非修福德业可得者。诸菩萨摩诃萨。三大阿僧祇。所修功德智慧十地胜因。为当定有所得。定无所得也。若定无所得者。则因果俱失。同于小乘断灭之见。无菩提可得。前言一切善法得三菩提。此言则坏。若尔既无菩提可得。诸菩萨。何为三大阿僧祇徒自劳苦而无所克获。所修福德胜因既不感。果向何处去也。有如是疑。将释此疑故。佛问须菩提。于意云何。如来可以相成就得三菩提不耶。此佛还以前人所疑。问须菩提也。莫作是念者。遮其所见。汝莫作是念。谓法身佛同于报佛修福相可得。此未是正答也。汝若作是念。菩萨发三菩提。说诸法断灭相者。明须菩提疑云若不可以相成就得三菩提者。菩萨则所修功德智慧之因。果毕竟无有菩提果可得。若无菩提可得。则因无所招。便失福因。亦失果报。故云说断灭相也。所以此中乃言菩萨发三菩提心者。说诸法断灭相也。然小乘之人。以自身所证灰身涅槃毕竟灭故。即以已所得。准于菩萨谓亦闻其所得。故起断灭相。此小乘人。于菩萨法中。齐何处来作断灭意。有昙无德弥沙塞人。此二家小乘。计得初地无生忍解时。舍一切地前所修功德。亦不受果报。何故如此。小乘人断三界烦恼尽分段生死。灰身灭智。入无余涅槃。善恶因果一切俱舍。既见初地菩萨断四住烦恼出于分段生死。意谓闻已灭于身智。亦舍因中万行。及失果报。故言说诸法断灭相。复有一家。小乘昙无德人。计谓至五地六地。作十四谛观。善学五明。及十种逆慎观十二因缘。方得无生忍。断三界烦恼。出分段生死。灰身尽智。无余涅槃。尔时同小乘断灭。因果俱失。后有一家。萨婆多中日出道人。计第七地中始得无生忍。方尽三界烦恼。出分段生死。同已小乘舍于身智。亦无依报净土。复有一家小乘。计至八地中。得大无生忍无功用解。尔时方出三界。舍于身智。一切皆失。最后一家萨婆多人。计十地中始得阿那含。断三界烦恼尽。金刚心后。出分段生死。得阿罗汉。即名为佛。入无余涅槃。舍诸功德。灭于身智。故说断灭相也

须菩提。莫作是念。乃至说诸法断灭相者。此且止其见情。明非断灭。未是正答。依下论中。应有一行半。经言。何以故菩萨发阿耨多罗三藐三菩提心者于法不说断灭相者。此是正答。释上我何以故止汝莫作是念者。明古今湛然无为法身。虽复不可以修福德相成就所得。而菩萨证初地无生法忍阿耨三菩提心。乃至无上佛果阿耨三菩提心。非是断灭。此无生忍三菩提心。所以名为不断灭者。明菩萨由一大阿僧祇所修功德智慧八万四千波罗蜜行因缘。得初地无生法忍。了出佛性无为法身。以此一大阿僧祇功德智慧。即与法身理冥。泯然一观。不可分别。故不失因。既得无生法忍。便分有出世间实报真如法性身上二种涅槃无方圆用故。果亦不失。乃至第二第三阿僧祇。因果皆如是不失。故言于法不就断灭相也。今者如来。将明菩萨于初地中得无生法忍。乃至十地无漏功德。及果头圆报。悉皆不失。不闻小乘舍于身智失无漏果报。若尔得无漏功德。可容不失地前有漏功德。是世间法。得出世解时。应舍此功德。未知地前因行为失不失。故即答世间功德亦不失。何以故尔。要世间善满。得出世间善转。地前有漏功德。作彼地上无漏功德。转转增胜。菩萨。尔时境智双夷。泯然一观。不见有世间出世间及能照所照之异。唯有真如一味等味。如万川归海同一碱味。无有诸河味别故。亦不失地前功德也。初地既尔。不失功德。乃至十地无漏功德。及以果报皆不失也。此中就三大阿僧祇劫。三时辨因果。若以地前为因。初地无生法忍见道为果。若七地已还修道胜行为因。八地中大无生忍无功用道为果。若金以还无功用行为因。佛地功德为果。如今广解。地地相望。皆有因果。乘生疑问。若得初地无生忍。乃至十地。不失功德。非断灭者。可得几许功德。为多为少。应有此疑问故。引恒沙七宝施福挍量。明得福甚多。用比初地无生忍无漏功德乃至一念。百千万亿不及一分。明此有漏功德甚为多也。纵使七宝施福是无漏甚多。虽多。比于无生忍一念功德。亦百千万亿恒河沙倍不可为喻也。若菩萨知一切法无我。得无生忍。胜前所得福德者。出初地无生忍功德。胜前七宝施福也。知一切法无我者。于一切众生五阴有为法中。解知从本以来无有神我人及以寿者。故言知一切法无我也。得无生忍者。是因缘真如二种法无我。明因缘法体本来不生名为无生。真如法体本来寂绝我无我相。名为无生。亦得云无于三相。就初地为言。故云无生法忍。以此菩萨得真如无我无生忍解故。不起二种无相也。又疑问。若有漏无漏二种福德悉皆不失者。此菩萨便是取有漏福德。若取有漏福德因。使受三界果报故。如来答以诸菩萨不取福德故。此且据偏而答。明菩萨于初地中不取世间有漏福德。然须菩提亦就偏领解。言以诸菩萨不取福德如佛所说也

佛言须菩提。菩萨受福德不取福德。上须菩提似谬解佛意。闻言菩萨不取福德。疑谓有漏无漏悉皆不取。故佛答须菩提。菩萨受福德不取福德。不取福德。明非是全不取不受有漏无漏一切福德。止不取有漏福德。非不受无漏福德。然菩萨若得云受福德。亦得言取福德。若使得云不取福德。亦得言不受福德。何故言菩萨受福德。此明直绮互彰名也。又解。何故但言受。不言取福德者。恐即滥于取相之取故。单言受福德。不言取也。是故菩萨取福德者。明取出世间无漏福德也。亦得言是故菩萨不取福德。然此中得云取福德者。明知须菩提言不取者。是偏语耳。故知亦得言取受不取不受也

论曰有人起如是心等。作生疑答之意。不异经中也。此一段经。凡以二偈释。初一偈。作问答意释疑。明菩萨得无生忍时不失因果非是断灭。第二偈。释引喻挍量不及无漏福德也。上经中有疑。今问云何断疑。即作偈答。不失功德因及彼胜果报。此二句。释莫作是念说诸法断灭相已前经也。明菩萨得初地无生忍。不失地前一阿僧祇所修万行。此辨乃藉地前功德为因。方得初地真无漏解。故不失因也。然初地以上。出世间无生法忍。无漏胜福。不同二乘灰身尽灭故。亦不失果报。虽言不失因不失果。未知何时不失。故第三句答云。得胜忍不失。自下半偈超释经中若有菩萨得无生忍胜前福德等。明菩萨证初地无生胜忍。乃至十地行满得佛时。亦不失因果也。得胜忍时。何故不失。第四句云。以得无垢果故。明初地断除二障。得出世无漏法性报身真实净土无垢果时。转胜增明。故不失也。亦胜福德相故。重说胜喻者。此二句。释前恒沙世界七宝施等经。明所以引此恒沙譬喻来者为欲挍量显示无漏胜福德故。即是证成不失无漏福德也。是福德也无报者下半偈。释以诸菩萨不取福德以下经也。是福德者是初地。无漏胜福德也。无报者。明此无漏胜福德无世间有漏报也。如是受不取者。如是受无漏胜福德。如是不取有漏福德。受取不受不取义闻于前也。此义云何虽不依福德至功德庄严。释前偈上二句。作答疑难云意。明不断灭也。何故依彼福德重说譬喻者。问后偈上二句喻来之意也。即以初偈下二句答。偈言得胜忍不失以得无垢果。明譬喻所况得无生忍时。不失因果。非断灭义也。此义云何者。问引此珍宝施福校量。云菩萨得无生忍时。获多福德。非是断灭之义。云何也。有人起如是心以下至是故不失。提疑人失因果之疑。为遮断此疑故。引喻挍量。明得无生忍时不失因果不断灭也。如经何以至不说断灭相。举经来结。然此经文。前憣经漏阙。依此论引来。明知应有也

若复有菩萨。知一切法无我。得无生法忍者。将释此经故提来也。有二种无我。不生二种无我相者。即解前知一切法无我经也。是故受而不取者。是菩萨得无生忍时。有二种无我解。而不生二种无我相故。但受地上无生忍功德。不取地前有漏福德也。此句有成上生下义也。如经以下举经来结也。云何菩萨受福德不取福德者。论主问向所结经。若菩萨受福德者。即是其取。何故言受。而复云不取也。即指偈言是福德无报如是受不取。以此为释也。此义云何以下。论主释向半偈也。须菩提。若有人言。如来若去若来若行住坐卧。是人不解我所说义者。此是断疑分中第十五段经文。所以来者。前广解。法身如来。古今一定。体绝万相。湛然常住。非修行所得。次前段明菩萨得出世间解。受无漏福德。不取世间有漏福德。有人乘此生疑。菩萨本因地时。发心许度一切众生。我所修善根。与一切众生共之。疑云。若诸菩萨。得真法身。出于世间。受无漏果报。不受三界有漏果报。众生在世间。受无漏果。不受无漏果报。然人天果报。闻是三界中法。人尚不得受天报。况无漏福德出世果报。得众生受用也。若尔世间出世间条然有别。云何诸菩萨所修善根令众生受用得其利益。以此验之。菩萨虽出三界得真法身。犹有去来。化物受三界报。不条然方外不去不来也。若不去不来者。菩萨福德。众生不得受用。则菩萨虚发此愿无所利益。为断此疑故。答明诸佛菩萨真实法身虽无去无来。而应身从咸去来化物。众生用之益。真实不虚。如此则菩萨善根。众生用之。本愿不虚。非谓法身有去来坐卧四种威仪教化众生。故次明也

须菩萨。若有人言如来若去若来等。是人不解我所说义者。有人见应佛来去从感说法益物。谓即是真佛。有四威仪去来。从感受三界报。处世化物。故言是人不解我所说义也。明此人不解如来所说三佛一异义也。乘此生二种疑。下论偈生起序其疑意。微尘喻中释也。何以故如来者无所至去无所从来。此释前经何以故谓如来有去来坐卧者。不解我所说义者。以见应身去来从感化物。谓法身亦然。故曰不解。明应身如来有去有来法身无去无来也。若就报应二佛。得云如来。据法身佛而论。不应言如来。正应云如住。所以然者。语报佛也。得道始从菩提心。修十地行。乘因向果。以果望因。得云如来既有真报。必有影像。故应佛从真。亦得道乘因向果。名为如来。然法身佛。古今湛然。体性圆满。非修得法。不可得言乘因向果故。正得云如住。不得言如来故。言何故如来者无所至去无所从来也。法身如来不从此至彼入涅槃故。言无所至去。不从彼至此。来在世间。教化众生。故曰无所从来。故曰如来者。依胡本。名多陀阿伽度。汉憣为如住。此应言如住。但以依昔什公所释。还存如来之号也。此一段经。以二偈释。初偈释疑。解经中若去来坐卧等至不解我所说义。第二偈。释经中何以故以下也。序经中二疑。生下微尘喻经。初句言是福德应报者。上疑云。菩萨得真法身。离于世间。不受三界报。无去来者。众生云何。而得受用菩萨福德。故以偈答。是福德应报。为化诸众生福德者。菩萨所修善根也。应报者。为化众生。现入三界。三业教化。令众生得益。如此则是菩萨福德。与众生共受。非谓法身有来去也。难者言上来广解法报二佛湛然常住无去无来。既无心去来。何由有此应化去来化物。若尔诸佛如求。为有心去来。为无心去来也。故下半偈答。自然如是业诸佛现十方。明诸佛既成道已。本愿力故。随众生感。自然应身遍十方界。教化众生。不待作意方有去来也

此义云何明诸佛化身有用等。释上半偈。作答疑意。明虽法身无去来用而化身去来益物也

偈言以下。用下半偈。释成上半偈也第二偈。上二句言去来化身佛者。牒前偈。明应佛有去来。如来常不动者。正释经何以故如来者无所至去无所从来等。复欲乘作疑意。生下微尘喻未无量七宝挍量经文。明供养应佛及持应佛所说与真佛无异。下半偈正生微尘喻。明三佛不一异也。何故作此上半偈。以生于下七宝施福挍量经文。有人因前经。生第一疑。若法身佛不去不来。应佛有去来。随感处于世间。为众生供养得福。即是菩萨因地福德。众生受用者。是义不然。何故不然。以此应佛化身去来无有实体故也。又上第五段经中。明应佛有生住灭三相故非佛。次第六段经中。明应佛不发心修行证果说法。此便应一向非佛。以此三处经验。丈六如来应非是佛。若非佛者。云何供养应佛。即是众生受用菩萨福德也。又若供养应佛得福者。与供养真佛。有何异也。有如此疑故。论主设此半偈发起疑意也。此明应身有去来法报湛然无去来等故。云常不动。因即生第二疑。疑云。若应化佛有去来。法报二佛无去来者。此之三佛为一处住如众僧在堂。为冥然念作一不可分别。为条然异处住如东方阿閦西方无量寿等也。若合作一者。不应有去来不去不来别。若条然异者。则三佛有别体此云何也。故下半偈答云。于是法界处。非一亦非异。此明三佛于真如法界中不可定说冥然合作一一处聚集住。亦不可说条然有差别也。又时一解于是法界处非一亦非异者。此论主假作问答。为欲生下微尘譬喻。云何生下。上广释法报二佛不一不异。亦通应佛不一不异。又此段经中。明法报二佛无去无来应佛有去来。因此生疑。若法报二佛。无有去来。则是常住。应佛有去来。便是无常。若然此之三佛为一为异。又乘疑十方诸佛。断或证果之时。于真法界中。为一处聚集住。为冥然合作一。为条然异处住。及一切众生所有真如佛性。为一为异。为多为少。有如此疑故。于此二句中。具引向所疑一异之义。假作问答。拘琐向下。于是法界处。是问问意。此三佛断烦恼尽时。于真如法界中。为一处住。为异处住也。故下句答云。非一亦非异。答意明诸佛成道断烦恼时。此之三佛。于真如法界中。不可说言一处住异处住也。此明不去不来至无所至去无所从来故。释偈第二句。以经结也。此义云何以下。问答释经解如来为如住义也

金刚仙论卷第九金刚仙论卷第十

须菩提。若善男子善女人。以三千大千世界微尘等。此一段经。是断疑分中第十六经文。所以来者。为答上疑问故也。疑云若应佛有去来。法报二佛无去来者。此之三佛。及十方诸佛。断烦恼尽。成道之时。于真如法界中。为一住处。为异住处。为合作一切众生真如性。为一为异。为多为少。此犹是前经中。所疑问事。前论偈中。作生此经之端略。兴问答云。于是法界处。非一亦非异。而此经将具释彼疑一异多少之义故。引三千世界微尘喻经。以答之也。此明碎三千世界极细微尘。为无色香味触之尘。然今窗中因日光见者。此是粗尘。折此为三百分。方谓微尘。此微尘非凡夫二乘所见。复未此细尘。令作无色味等尘。此微尘无色味形状。亦无四方上下。头数虽多。而不可言一处住异处住合作一。以况三佛及十方诸佛亦多无量也。然此诸佛虽多。断烦恼尽时。于真如法界中。不可说言一异。亦不可说言一处住异处住。众生佛性性净解脱。据众生虽多。而真如理中古今平等。亦不可说言异多少。为释此疑。故次明也

以三千世界微尘者。此举三千世界极细微尘也。复以尔许微尘世界者。此名细微尘。为世界。界之言性故。此一尘依世辨论。亦名世界。亦名微尘也。碎为微尘者。复碎此极细微尘。为无色香味触微尘也。阿僧祇者。明非但碎三千世界为微尘。亦碎阿僧祇世界。以为微尘。亦得言无色味微尘。不可算数故。言阿僧祇也。须菩提。于意云何。是微尘众宁为多不者。明所碎世界既广。故佛问须菩提。于汝意地。思唯筹量。谓此微尘为多不也。故须菩提。解如来意。答言。彼微尘众甚多世尊。此明如来向者所说彼尘众多。虽多。以无色香味触形状方所。无妨无碍故。不可说一处住异处住合作一。以喻十方诸佛亦甚多无量。此十方诸佛。若据行者而言。一行者自作一佛。行者既多。故佛亦多也。诸佛据行者既多。不可说一。二障永尽法身平等无有差别。不可说异。然此微尘碎为无色味之尘。虽多。无有形状故。无色味等。亦无六方故。不可说一处喻十方诸佛断除二部会真如法界时。无有形碍。亦无方所故。不可说言一处住异处住也须菩提解佛意故。仰答如上。众中有人。因生疑念。前既言碎微尘作虚空。无有六方形状。复云微尘众甚多。此二言何故相违。故言何以故也。即答若是微尘众实有者。佛则不说微尘众。此明若使微尘众实有六方形状色香味触不空者。佛则不假设说碎细微尘以为无色味微尘也。复疑云。若此微尘。体空无色味。是不实者。何故如来说为微尘。以如来说为微尘故。明知微尘是实不空故。言何以故即答佛说微尘众则非微尘众。此明如来依世谛道中。说虚妄微尘故。言佛说微尘众也。此微尘众虚妄不实。本来空寂。故言则非微尘众。此之微尘。既是虚妄。宁有实尘而可说也。是故佛说微尘众者。以是故。如来上说无色香味触无形状之尘故。说于无尘为尘也。亦得道是故佛说非微尘众。此因事无。以明因缘法体空也

世尊如来说三千大千世界则非世界者。向明微尘喻。据极细而言。此言三千世界。就尘为语。然复有疑。上佛说细微尘。其体不实故。所以是无。然要以细微尘。成粗世界。若细微尘无实者。何故有此三千世界等粗物。然此粗世界。既为细尘所成。若细尘无者。何故眼见三千世界等粗物是有。以粗物有故。明知细尘亦有也。故答如来说三千大千世界则非世界。明如来说假三千成一世界。若有一世界不为他成。可有世界是实。然无一世界不为他成。是故无实。以其无实故。言如来说三千世界则非世界也。然此细尘既无。明知三千粗界亦虚假不实也。是故佛说三千世界者。欲明若有一世界是实非虚妄者佛则不虚说言三千世界。佛既说揽三千为一世界。故知虚假不实

何以故者。有人乘生疑念。若微尘世界。二俱不实者。如来何说微尘集故世界成散故世界怀。以此圣言诚验。故知微尘是实。何故言空。故云何以故也。即答。若世界实有者。则是一合相。此言世界者。名微尘为世界。明何故三千世界是不实若微尘世界是实者四方微尘来则冥然一合。作一世界。不可分别。不应有三千之名。既有三千之名。故知能成微尘世界。是虚妄不实也。以此微尘虚妄不实故。即体是空。空无形状故。往来无障。乃至铁围山。亦不相妨碍故理而言之。东方微尘来无障无碍。西方乃至南北上下六方微尘来。皆无障无碍。此微尘既不相障碍。亦无聚集之相。泯然空无有形状。乃至须弥山。亦不可见。以此验知。有为世界。莫问粗细。皆是虚妄不实。本来空寂。依世人妄情。说有世界。此明因缘法体本来空也

乘有疑难。若一合相是相实者。何故如来说合三千世界为一合相也。故答云。如来说一合相者。依世谛名。用虚妄法中。说一合相也。则非一合相者。究理而言。无有一世界冥然一合。不假三千成故。言则非一合相也。佛言须菩提。一合相者则是不可说者。明有为虚妄不实故。无有一世界冥然一合相是实而可说。故言则是不可说也

乘此生疑。若使世界一合相无实者。而众生不应见。复不应用之。然今现见有此世界屋宅衣服器世间等用。既有此用。明知粗世界是实。粗世界既实。细微尘亦实。何得言粗细微尘世界皆虚妄不实也。故经答云。但凡夫之人贪着其事也。明凡夫之人以取相颠倒因缘故。于虚事之中。计以为实。非谓粗世界是性实也。然所成粗世界既不实故。明知细尘亦是虚也。何以故者。因前凡夫贪着其事。乘复生疑。若凡夫人颠倒在心故。取微尘世界粗细有为虚事。忘谓为实者。如来无有取相颠倒之心。何说有微尘世界。如来何故复言。我见微尘及世界等。若如来说言我见所见我我所别内外之异。又如来何故复说本有我人众生等见。后观我法体空故。得二种无我解。方断我人等惑。名为得道。如来既作如是说。以此验之。明知此微尘世界粗细等法。是其实有。非虚妄故空也。以有此疑故。言何以故也。佛今将答此义。故问须菩提。若人如是言。佛说我人众生寿者见。须菩提于意云何。是人所说为正语不也。此明佛问须菩提若有人以如前所疑疑。谓佛作是说。本实有我法。后观此我法得无我法之解。遣我法二见。得无我无法。名为得道。此人所说当理此正语不也。故须菩提答言不也世尊。明向者疑人所说言不当理不合佛意。故云不也。何以故世尊如来说。我人众生寿者见。即非我人众生寿者见者。释何故此人所说言不当理是不正语也。明二乘之人谓本实有我人众生寿者等。我我所见。后观此我所二种空故。能断此我人等见。而云我得无我之解。以此为真解。若谓如来亦作是说。以此为真实者。此说非正说也。然诸佛如来。解一切法本来空寂。尚无我法可除。况有我法二空之见可存也。故云即非我人等见也。此无我等见。于声闻为解。于菩萨为障。今明佛说要观我法从本来空毕竟寂灭。无有我法可空。乃至烦恼亦本来寂静。故无烦恼可断。不同二乘见本有我有法今解二空方断此惑名得道也。是名非我见人见等者。双结我法二空也。二乘人见我无。得无我人等解。以为真实。故曰是名非我人见。亦得导是名我人众生寿者见者。明如上所说。而解知我之与法古今湛然本来不生。现见真如平等。证初地无生忍菩提。乃至佛果无上菩提。不同小乘取无我无法见以为真道。佛作是说。故曰是名佛说虚妄不实我人众生等见也。明是名无我人等虚妄见也

乘更疑问。若存有无我无法见。非得道者。观何等法。起何等心。证何等法。名为得道也。故答须菩提。菩萨发菩提心者。于一切法。应如是知等。此以初地证智。为菩提心。明于何义劝人。若欲得初地以上真实道者。于粗细有为我法无我无法虚妄物中。应如是生知见信也。如是知者。明住前人以世间闻慧五明论智仿佛而知。如是见者。明住上人以出世第一义智见。如是信者。明前二人前并依三昧无量功德力信。此明之人。以用此二智三昧故。见真如佛性。除一切法上有无之患也。如是不住法相者。既有为虚妄无我无法中生知见信解故。便不取着也。何以故者。或者闻言菩萨不住法相。疑谓菩萨于世间法出世间法中悉皆不住故。言何以故也。故佛答须菩提。所言法相法相者。如来说即非法相也。上言法相者。是世间色等有为法有无之相。下言法相。是出世真如无为法相。如来说即非法相者。明如来说即非法相者明如来说世间有无法相。非出世间无为真如法相。出世间真如法相。即非世间有无虚妄法相也。是名法相者。如是非世间有为有漏法相。即是出世间真如无为法相。亦得云是名世间有无法相也。上言不住法相者。但不住世间有为法有无之相。非不住出世间无为法相。那得闻言不住法相便谓世间出世间有为无为法相中皆不住也。自此已上经释前偈中于是法界处非一亦非异疑也

须菩提。若有菩萨。以满无量阿僧祇世界七宝。用布施者。此上有疑。上来微尘喻中。明三佛不一不异。虽明三佛。准上经文唯应有二。不应有三。何者上第六段中云。释迦牟尼非佛。亦非说法者。又次前经复云。化佛有去来。教化众生。供之得福。此前后相违。今疑未知应身为定是佛为非佛也。若是佛者。供养此应佛。所有福德。与二佛同。为有差降。化佛所说经法。为是正法。为非正法。若受应佛所说法。所得利益。为与受持报佛所说法功德同。为复有差降也。恶心毁谤损害之者。罪复云何。故欲答应佛是佛。所说经教是正法。供养受持得福。闻前二佛。恶心毁谤得罪。亦然故。引此喻。以阿僧祇世界七宝。持用布施。挍量不如有人于应佛边发菩萨心。受应佛所说般若经一四句偈。乃至为人演说。其福胜彼无量阿僧祇。上疑通疑应佛。今经中何以但言持应佛所说经福多。不云供养应佛得福多。持应佛所说经法。此法能是应佛所说。但言受持应佛所说得福无量。则知供养应佛得福亦多。故不别出供养应佛也。疑者云。若供养应佛所说经教与真佛无异者。云何此应佛处世教化说法。而得不名应佛说法也。故经问言。云何为人演说。而不名说。明应佛说法时。自云我从无量阿僧祇劫来。广修万行。今方成佛果。具足相好及诸功德。而不言我是化佛。若自言我是化佛。众生便谓是幻化人。此何等鬼神。遂不生敬信。不受其所说。心既不信。不受其教。即无所利益。以不言是化佛故。有多利益也。是名为说者。此应佛从真处来。而不云是应化故。供养受持。所得利益。与真佛无差。是名即应佛所说是正说也

此一段经。凡以六偈来释。初一偈。举微尘喻。作问答意。释前经中疑。第二偈。明微尘无色味形状故不一不异。诸佛亦然烦恼尽故不一不异也。第三偈上二句。明凡夫不解有为法空随名取着也。下二句。琐入第四偈。有一偈半。通明诸佛菩萨不但得无我无法解故名为得道也。第五偈上二句。出二种菩萨能解之智。下半偈。明供养化佛与真佛无异。第六偈。明应佛所说法是其正说也。初偈云世界作微尘等一偈。释经中善男子善女人以下乃至阿僧祇世界。若依世辨论中。名此微尘为世界。非谓三千等世界也。此明破有色味微尘为无色味微尘。此微尘无色香味触。亦无方所。故名微尘。此愈示彼义者。明借此微尘喻。释上疑问于是法界处不一亦不异义。故云示彼义也。微尘碎为末者。重举上喻碎于微尘为无色味尘。喻诸佛如来成道之时永无二障。故下句言示现烦恼尽也。此明何义者。问此一偈引喻之意。为明何义也。偈言于是法界处非一亦非异者。论主引前偈论。略答微尘喻所况事也。彼诸佛如来。于真如法界中等。还解所引偈。明诸佛虽多。于真如法界中。非一处住。亦非异处住也。为示此义故。说世界碎微尘喻者。释诸佛不一处不异处住竟。提喻来治也。此喻示何义者。问此微尘喻。况诸佛于真如法界中非一处住异处住者。未知此喻有何相似。得以此喻示况也。即以下半偈。答言微尘碎为末示现烦恼尽故。明若不碎世界。则有彼此之殊。既碎为微尘。使无此彼之[阿-可+(可/(可*可))]。喻诸佛如来断二障尽时。于真如法界中。无彼此障碍。一处异处。有如此相似。故以况之也。此喻非聚集微尘众者。将作偈释经故。先举经中所明。喻意言微尘众者。非实有微尘聚集名为众也。示现非一喻者。为示现诸佛甚多。假设以无色味尘。为微尘众也。第二偈。释经中于意云何是微尘众宁为多不是故佛说一合相一段经也。非聚集者。上经言。微尘众甚多。似如实有微尘。此明以无色味尘为尘。非是实有微尘聚集而言微尘众多。故言非聚集也故集者。疑云。若无实微尘聚集。何故言微尘众多。故答道言聚集者。依世谛名字假设。无集中说集。非谓实有微尘众聚集而言多故云故集也。非唯是一喻者。若实无微尘聚集。何故假设言甚多也。明以微尘微既多。况十方诸佛亦是甚多。不可说一故也。微尘既是无体。不可说言定有微尘聚集。以喻如来断烦恼尽体无障碍。不可说言一处集。故云非唯是一喻也。聚集处非彼者。明微尘虽多以体空故。聚集处无实尘可得。一处无故。亦不从异处而来。以异处无实微尘可得故。云聚集处非彼也。非是差别喻者。明如微尘无碍一处聚集相不可得故。异处差别来相亦不可得。况诸佛亦然。清净法身体既无碍。非一处住故。亦非条然异处差别。如东方阿閦等。亦不可得。故云非是差别喻也。此义云何。如微尘至无聚集物故。释上半偈也。亦非异处差别至以差别不住故。释下半偈也。如是诸佛如来至亦非异处住。上解偈中喻意。此义释合喻之意也。如是三千世界合相喻非聚集故者。前释微尘不一异义。今此辨世界粗物中不一异义亦然。故云如是乃至非聚集也。此以何义者。问上三千世界合相喻复言非聚集故。此以何义故如是说也

如经以下。举如来成说为答也。若实有一物聚集。如来则不说一物聚集者。上已解微尘世界二喻。并合喻竟。此文何故复来者。上虽明微尘世界虚妄不实非一处聚集非异处差别以况诸佛。而未解微尘世界所以是空。今正释二法空义。明若实有一微尘物不空而聚集者。如来则不假说无尘为尘为聚集众也。若实有一世界等者。此解世界空如微尘无异也。如经以下。举经来结也。但凡夫之人贪着其事者。此文前偈中无。何故别提来者。明凡夫妄聚前境。于虚事生贪。以不实为实。成上微尘二法体空故。引此释也。如经以下通举前经结也。第三偈。但随于音声。上二句。释经中但凡夫之人贪着其事。明凡夫之人既无如实之解。但有虚妄分别。随声取著闻说色是可见可触。便谓为实义亦如是可见可触。故云但随于音声也。凡夫取颠倒者。闻说色等可见可触。凡夫便谓色等实有可见可触。取不实为实。故云凡夫取颠倒也。非无二得道。此下半偈。通第四偈上三句。共释经中何以故若人如是言至是名我见等也。非无二得道者。明诸佛如来非是但得无我无法二空之解名为得道也。明二乘虽得此三空之解。犹为习惑覆心无明障解故不名得道。应问若存此二空。不名得道者。见何等法。以何等行。能得道也。故第四句云。远离于我法。明要见真如平等究竟深重。解我之以法本来空寂。离于无我无法二空虚妄分别见时。乃名得道也。应言远离无我无法见。以偈侠故。但言离我法也。明若谓有我法可空。复自言我能得此二空之解。有此着空之心者。则障于真如菩提。不名得道。明菩萨大士。解生阴法体从本以来性相空寂。非假观无方。既无我法可空。亦无二空之见可存。名得道也。此第三偈下长行论中。唯释下半。不释上半。所以然者。上长行论中。已释其义故此中不解也。如经何以故等。举下半偈所释经来。结偈中解意也。此复何义者。将欲释偈。问此所引经中。明于何义。乃以斯下半偈释也。即以偈答。非无二得道远离于我法故也。此义云何者。此偈释经之义云何。下释可知也。此复何义者。此无我无法二种见。上虽云离二见而得菩提然问此二见。应是正解。复以何义。远离此见。故以第四偈答也。第四偈。释成前半偈。上虽云非无二得道远离于我法。而未释所以。其义犹隐故。更作此偈。上三句释也。见我即不见者。明见有我而可空。道言我见无我者。此非正见究竟深解。故云见我即不见也。亦应言见法即不见。宜以偈侠故。单言见我。不云见法也。何故见我。名为不见者。故第二句云无实。若无实者。何故见有。明以虚妄见故。言无实虚妄见也。此上二句。释前偈非无二得道也。此是微细障者。明著有之心名为尘惑。存无之心名之为细。此存我法二空之见。无明之惑体。非四住粗或以碍于真如胜解故。云微细障也。见真如远离者。此一句。释经中菩萨发三菩提心。明此细惑要证初地解时。现见真如究竟深理。遣此虚妄分别。尔时乃尽故。言见真如远离也。此二句释远离于我法也。是故见即不见至见法亦是不见。此释上半偈也。是故见即不见。释初句也。无其实义以虚妄分别。释第二句也。以是无我者。结句也。是故如来说彼我见即是不见者。引佛成言为证也。以其无实至我见不见故。论主解如来证也。见法者亦是不见者。偈中无文故。别提类释也。如经菩萨发三菩提心以下。此为经前偈第四句明菩萨得真如解。不存无我无法。以之为正见故。复为形前存无我无法为不正见。故引来也。此复何义者。此何故引菩萨见法相经。形前二见名为不见也。即答以见法相即不见相。明以存得无法相见者即是不见法相也。如彼我见即非见者存无我见为正见者。亦非见也。何故此二见说名不见者。将欲释下半偈故。作问生起。问此无我无法二见。应是正解。何故说为不见也。即以下半偈答。此是微细障。见真如远离也。此复云何者。问此偈中。以此二见为微细障。云见真如远离。此复云何也。即释彼见我见法。此是细障者。结二见为障名。以不见彼二故者。释作障义也。是以见法以为得远离者。此二见。于声闻无妨。于菩萨为患。故见真如远离也。又如是知等。上已引结前偈。何故此中复牒来也。前偈中。但释得此知见信者皆离无我无法细障。犹未解知见信义。今将作偈释故。更举来耳。第五偈二智及三昧如是得远离者。此上二句。释经中菩萨发阿耨三菩提心应如是知见信等也。所以明此者。上云存二空之人有细障在心。故不名得是。明见真如者皆远离细障。名为得道。未知何等人。能见真如。远离细障。今辨出二种菩萨具足功德智慧。见真如深理。能离细障所明也。二智者。地前世智。地上第一义智。此是二智。世智者。释经中如是知也。第一义智。释经中如是见也。及三昧者。离垢等无量三昧。释经中如是信也。故云二智及三昧也。如是得远离者。明具智慧三昧二种功德之人。得理究竟。能离细障也。化身示现福者。前经中。有人生疑。化佛既不修行断惑。不证菩提。亦不说法。有生灭去来。非是实佛。供养之者。为有福德。为无福德也。若得福德。与供养真佛。为有差降。为无差降。恶心毁害其罪云何。故答化身示现福。非无无尽福。明化佛虽不修行证果。然由真身为本。而众生有感。圣则赴感垂应。以此应佛从真处来。与彼二佛。有其一义。复不言我是化佛。故供养化佛所得功德。与真佛不异。示现有福。非无无尽之福。有无量无边功德故。经引七宝施福虽多而不如供养化佛。亦不及受化佛所说经教得福多也。然经中。但辨受持化佛所说经尚胜七宝布施之福。明知供养化佛。亦胜七宝施福也。此二句。释经中若有发菩提心者至无量阿僧祇也。此义云何示现世智至远离彼障。释偈上二句也

是故重说胜福譬喻者。释下半偈。是故者。是上有人疑供养应佛及受持应佛所说。为有福德。为无福德。故我引胜福德譬喻。释彼疑也。云何为人演说而不名为说等何故如是说者。将欲设偈释此经文故。提来为问。问此经。为若人演说。应名为说。何故乃云不名为说。故云何故如是说。第六说诸佛说法时一偈。释经中云何为人演说而不名说等经文也。经中疑云。以化佛不实故。所说经教。亦应是不正说。以有此疑故。偈释云。诸佛说法时不言是化佛也。说法时者。众生有感。无有八难。受道时也。明应佛赴众生感。说法之时。虽化身不实。而所说言教。是其正说。所以尔者。下句云。不言是化身。明化身佛为众生说法时。不道我是化佛。若言我是化佛。可化众生不生敬心。既不敬信。则虽化无益。故不云我是化佛。以不言是化佛故。所说经教。众生信受。有多利益。即是正说。故下半偈云。以不如是说是故彼说正也

一切有为法如星翳灯等者。此一偈。是第十一段经。名为不住道分。此经何故名为不住道者。明诸佛如来以出世妙智。观九种有为即是涅槃故。不同凡夫乐着世间。复不同二乘乐住涅槃。不住此二道故。曰不住道也。此所以来者。为释疑故也。前段微尘喻经。明诸佛如来成正觉时。断二障尽故。于真法界中。非一处住。不异处住。便生疑云。诸佛如来。为如彼微尘体空毕竟无身。为实有身也。若有身者。身应有住处。何故言非一处住非异处住也。若有住处者。为世间中住。为涅槃中住也。若世间中住。何故前段经云。如来入涅槃去。若涅槃中住。复何故言如来来在世间。常为众生说法。为释此疑故。引九种有为法譬喻答之。明诸佛如来。有十力无畏无量功德真实妙身。此身以不住道为住处。云何不住道。谓不住世间。不住涅槃。明诸佛如来。解九种有为法体是虚伪本来空寂。悟真如平等。知世间实性即是涅槃。断生死因尽。是故不住世间不同凡夫不解世间有为诸法本来空寂起取着之行故住于世间也。既见真如平等故。解世间实性即是涅槃。世间涅槃无二无别。又具慈悲大愿故。常处生死。教化众生。是故不住涅槃。不同二乘不知一切众生皆有真如佛性平等无二故。见涅槃异世间。厌背世间。忻乐涅槃中道取证故住于涅槃。诸佛如来。以此不住道为住处。故次明也。一切有为法如星翳灯幻等。此一偈经。是如来所说。非论主所造。一切有为法者。将欲引九种喻。喻九种有为法故。总举一切有为法也。如星翳灯。此三喻偈。论合云见相识。幻露泡中三喻偈。论合云器身受用。梦电云下三喻偈。论合云过现未来。明上六种有为三世中转也。前微尘喻。直说六尘境中。以明有为法体空也。此九种譬喻。据能缘内心。以明法体空。问此九种。若明内心体空。何故亦有世界身等外无记法。答意虽通明外色等法。大意举境。明心空也。如星者。喻内能见心。所以内能见心喻之以星。外道凡夫。多计日月星辰是常故实。亦计内心是常是实。是故就其情计以破之。明日月星辰迭相形夺迁转不定故。所以不实心法亦然。少分相似故。喻之如天上星宿。日未出时。处空显现。有昭物之用。日既出已。光明悉灭。虽有不现。以大小相夺故。能见心法亦复如是。未有出世证智无漏圣解起时。妄想心法有取境之用。圣解既起。妄想心法殄灭无余。以其不实故也。如是观时。解能见六识本来空寂皆何等法也。二如翳者。亦喻能见心。此第二意。何异于初。有小乘人计云。何以得知心心法是实。以其能见前境能取六尘故。是如实故。喻之如翳。以小乘人取谓翳揵闼婆城等是虚妄不实能见六识及所见六尘是实故。如来。就其所解。引以喻之。破其所执也。如人目上有翳。于虚空中。妄见毛轮等色。以之为实。观有为法心亦复如是。于色等有为虚妄法中。谓不实为实。以心倒取境故也。三如灯者。亦喻能见心。此第三何异前二也。解云。二乘外道。皆见皆知水流灯炎迁转不亭。故就其所识。以晓之。故以灯喻之内识也。如世人燃灯。要以清油净炷及以灯炉。三法相假。后方得燃。识法亦尔。要叚根尘和合。因贪爱等或。识法得起。有取境之用。证智起时。此识寂然。无取境之用。以其即体不实虚妄故也。此能见心。既不实如是。背何等法。趣何等法也

四如幻者。如世间幻师。幻作四兵及男女等。种种随意。自在悉见。而无真实。器世间亦如是。以诸众生造善恶业种种不同。随彼众生善恶之业。感得净秽等土。亦有万品差别。斯由业见有殊。非是实有也。如似有人以虚空为地。以地为虚空。有人以水为火用。火为水用。知何者为实。如婆罗堕婆罗门。以火为食。虚空中眠。斯即其事也。五如露者。如草上朝露。见日则落。阴身亦然。生已即灭。念念迁谢。暂时不住。以体虚不实无常故也。六如泡者。如因天上雨渧。击地上水。则成泡沫。愚痴小儿。谓流离珠。心生爱着。须臾即灭。不得久立。三受亦尔。从根尘识三和后起苦乐等受。暂有不亭。速于泡沫。此世界身苦乐等受。不实若此。背何等法。趣何等法

七如梦者。前六种有为虚妄之法。已谢于住。如人梦受五欲。及见种种色物。寤已则无。唯可念知。不可重睹。过去迁灭。如梦寤不异也。八如电者。如电光暂现。理无久住。六种有为。现在峻转疾。极于电。故以为喻也。九如云者。如虚空中清净无云。以众生不可思议业。有龙为本故。于虚空中。未现云现现已还灭。六种有为未起之法亦复如是。由有无始阿梨耶识根本种子无明住地勋故。能令未现法现现已即谢。以其不实故。喻之如云。然此六种有为法。既为三世所转。妄情谓有。其体无实。如九喻无别。若然背何等法。趣何等法也。应如是观者。九种有为。如九种喻。作不实而观。应云一切有为法如星。应作如是观。乃至如云。皆如是说。此有为法既不实如此。则本来寂灭。本来寂灭。则唯一真如。真如寂灭。即是涅槃。是故诸佛如来。见世间即涅槃故。不同二乘厌背生死乐住涅槃化众生。见涅槃即世间故。不同凡夫众生死而无厌不求出世涅槃解脱之果也

论曰复有疑等。此一段长行论。论主略作疑答意。若诸佛如来。常为众生说法者。此应是住世间。复言如来入涅槃。即是住涅槃。云何上论中。言不一处住不异处住也。为断此疑故。如来即说偈喻者。此为略答疑者。申九喻来意也。此一偈经。论主凡以三行偈释。第一偈。作问答释疑。明不住道也。第二偈。出所观九种有为境界。第三偈。重举九种有为法。答难明观之有所得也。非有为非离者。言非有者。明诸佛所得常住涅槃出世间法体。绝生灭起动。无始终之相。故非有为。若非有为者。可条然异处。不住有为法中。故言非离。明有为实性即是涅槃。不离有为之外更有涅槃。故下句云诸如来涅槃。明证大涅槃时。不住有为法中。亦不离有为法也。若不离有为。则是住世间。若非有为。则是住涅槃。云何言诸佛不住涅槃不住世间也。故下半偈答云。九种有为法妙智正观故。明诸佛如来。得出世正观。见有为法本来寂灭即是涅槃性。不同声闻见世间异涅槃故厌舍有为而取涅槃。今言有为即涅槃者。是佛性妙有常住涅槃。明诸佛如来。观有为法即是性净涅槃。既见性净涅槃。断二障永尽。得此妙智正观时。能即得彼现果方便涅槃故。不舍有为而住涅槃也。此义云何诸佛涅槃者。此提偈中第二句也。非有为法。亦不离有为法者。释偈中上句也。何以故者。此释前诸佛涅槃何故非有为法而复云不离有为法也。即释以诸佛得涅槃。出离生死故。非有为也。化身说法至为利益众生故。明诸佛以应身常在世化物故。不离有为也。此明诸佛以不住涅槃者结初句。以不住世间者。结后句也。何故诸佛示现世间行。而不住有为法中者。将释下半偈。门前示现世间行。何故诸佛应身化物。示有生老病死。而不名住有为法中也。以下半偈答。九种有为法。妙智正观故。虽同世间有老病死。而非有为法也。此以何义者。问此偈所明正观者。作何法用而观。得名为正观虽示有生死等世间行。而不名住有为法也。即释云如星宿等。相对九种正观故。明诸佛观九种有为法虚妄不实。如观星宿等九种法虚妄不实便能于有为法中。以正观力故。终日示世间行。而能不住有为法也。此九种正观。于九种境界应知者。出正观之境。劝人识之。第二偈上句云见相者。直云心见相。摄能见三尽。但为成偈故。言及于识也。此句有三。明能见心。释经中星翳灯三喻也。器身受用事者。此三明所受用事。释经中幻露泡三喻也。过去现在法亦观未来世者。明前六种有为法在三世中转。释经中梦电云也。此明六义有为已谢于往。名为过去。六种有为萌兆未起。名未来。六种有为。起于今辰。念念生灭。名为现在。故云三世转也。第三偈。观相及受用者。言观相。牒前偈中上见相识。及受用者。牒前偈中三器身受用事。观于三世事者。牒前偈中后三过现未来三世法也。所以重举此九种法者。难云。观此九种有为法。得何等功德。成就何智。故以下半偈答云。于有为法中。得无垢自在。明观此九种有为法时。能得初地以上无漏无垢之果。无生之智不住道解自在功德也

佛说是经已至信受奉行。此是第十二流通分经。所以次明流通者。上来说法。正辨经体。信悟者众。今将明如来说法非但直欲通益当时。亦欲泽被遐劫故。令流通未来。使异世间津。故明也。以此中具列四众八部及诸大菩萨故。明知序中引同闻时。亦应具有。以经略故阙也。闻佛所说。时会所以皆大欢喜信受奉行流通此经者。凡有三义故也。一说者清净。明诸佛如来乃是一切智人二障永尽。具足十力四无畏十八不共法等无量功德。如证而说。必当理故。曰说者清净也。二所说清净。此明所说音声章句阿含经教从无烦恼人边来。说同诸佛。不多不少。不增不减与理相应故。曰所说清净也三受者清净。时会大众。一心专听。无见诤过。不言我法是彼法非。心无疑浊故。曰清净也。一切大众。庆睹天尊。得深法味。除疑遣障。获道度世。故大欢喜信受奉行也。诸佛希有总持法等。此一偈。是论主所制第八十偈赞叹回向诸佛者。十方三世诸佛也。明此金刚般若波罗蜜经是十方三世诸佛智母。三世诸佛同说此法。非独释迦如来。故言诸佛也。希有者。此非旷世所无。时时而有故。名为希有。又诸佛如来。常为众生说之。何故名为希有也。明此般若。理深旨远。唯是诸佛境界。非余人所知故。凡夫二乘小行根小行之人。所不能受以信者难得故。曰希有也。总持法者。明此经其文虽略。明义乃广。旨明常住因果境智之理。牧罗皆尽故。曰总持法也。又复一义。一切诸大乘经。其文虽广。至于所明。不出众生菩萨佛净土。然此虽略。至于所明。亦尽斯四也。故言总持法。不可称量者。明此经理深非二乘小智所能图度也。深句义者。谓此经文句。及次第深义也。乘此生疑难。若此金刚般若句义次第难解非图度境者。论主何由得解。而造论解释也。故云从尊者闻。明论主自云此金刚般若甚深法门义释。非自智力解。乃近从尊者。胡名阿僧呿汉云无障碍。比丘边闻。复远从弥勒世尊边闻。明仰推功有在。非是谬传故。言从尊者闻也。及广说者。明无障碍比丘乃是性地菩萨。多闻强记。能流通大乘。折伏外道故。弥勒世尊。愍此阎浮提人。作金刚般若经义释并地持论。赍付无障碍比丘。令其流通。然弥勒世尊。但作长行释。论主天亲既从无障碍比丘边学得。复寻此经论之意。更作偈论。广兴疑问。以释此经。凡有八十偈。及作长行论释。复以此论。转教金刚仙论师等。此金刚仙。转教无尽意。无尽意复转教圣济。圣济转教菩提留支。迭相传授。以至于今。始二百年许。未曾断绝故。言及广说也。回此福德。施群生者。然菩萨大士。每日事兴愿故。论主自申已所有造论传训功德。不专独善。乃回与法界众生。同向无上菩提心也

金刚仙论卷第十


弥勒菩萨所问经论

    No. 1525

弥勒菩萨所问经论卷第一

        后魏天竺三藏菩提流支译

如是我闻。一时婆伽婆住王舍城耆阇崛山中。与大比丘众千二百五十人俱。并诸菩萨摩诃萨十千人等。尔时弥勒菩萨摩诃萨即从坐起。偏袒右肩右膝着地。合掌向佛白佛言。世尊。我今欲以少法问于如来应正遍知。不审世尊。听许以不。尔时世尊告弥勒菩萨摩诃萨言。弥勒。随汝心念问于如来应正遍知。我当为汝分别解说令汝心喜。尔时弥勒菩萨摩诃萨白佛言。世尊。如是愿乐欲闻。世尊。诸菩萨摩诃萨毕竟成就几法。不退阿耨多罗三藐三菩提。于胜进法中不退不转。行菩萨行时降伏一切诸魔怨敌。如实知一切法自体相。于诸世间心不疲惓。以心不疲惓故不依他智。速疾成就阿耨多罗三藐三菩提。尔时世尊告弥勒菩萨摩诃萨言。善哉善哉。弥勒。汝今乃能问于如来如是深义佛复告弥勒菩萨摩诃萨言。汝今应当一心谛听。吾当为汝分别解说如是深义。即时弥勒菩萨摩诃萨白佛言。世尊。如是愿乐欲闻。佛复告弥勒菩萨摩诃萨言。弥勒。若诸菩萨摩诃萨毕竟成就八法。不退阿耨多罗三藐三菩提。于胜进法中不退不转。行菩萨行时降伏一切诸魔怨敌。如实知一切法自体相。于诸世间心不疲惓。以心不疲惓故不依他智。速疾成就阿耨多罗三藐三菩提。何等为八。弥勒。所谓诸菩萨摩诃萨成就深心。成就行心。成就舍心。成就善知回向方便心。成就大慈心。成就大悲心。成就善知方便。成就般若波罗蜜。弥勒。云何诸菩萨摩诃萨成就深心弥勒。若诸菩萨摩诃萨闻赞叹佛及毁呰佛。其心毕竟于阿耨多罗三藐三菩提坚固不动。闻赞叹法及毁呰法。其心毕竟于阿耨多罗三藐三菩提坚固不动闻赞叹僧及毁呰僧。其心毕竟于阿耨多罗三藐三菩提坚固不动。弥勒。如是诸菩萨摩诃萨毕竟成就深心。弥勒。云何诸菩萨摩诃萨成就行心。弥勒。若诸菩萨摩诃萨远离杀生。远离偷盗。远离邪淫。远离妄语。远离两舌。远离恶口。远离绮语。弥勒。如是诸菩萨摩诃萨毕竟成就行心。弥勒。云何诸菩萨摩诃萨成就舍心。弥勒。若诸菩萨摩诃萨是能舍主。是能施主。施诸沙门及婆罗门贫穷乞丐下贱人等。衣食卧具随病汤药所须之物。弥勒。如是诸菩萨摩诃萨毕竟成就舍心。弥勒。云何诸菩萨摩诃萨成就善知回向方便心。弥勒。若诸菩萨摩诃萨所修善根。谓身口意业。皆悉回向阿耨多罗三藐三菩提。弥勒。如是诸菩萨摩诃萨毕竟成就。善知回向方便心。弥勒。云何诸菩萨摩诃萨成就大慈心。弥勒。若诸菩萨摩诃萨毕竟成就大慈身业。毕竟成就大慈口业。毕竟成就大慈意业。弥勒。如是诸菩萨摩诃萨毕竟成就大慈心。弥勒。云何诸菩萨摩诃萨成就大悲心。弥勒。若诸菩萨摩诃萨毕竟成就不可讥呵身业。毕竟成就不可讥呵口业。毕竟成就不可讥呵意业。弥勒。如是诸菩萨摩诃萨毕竟成就大悲心。弥勒。云何诸菩萨摩诃萨成就善知方便。弥勒。若诸菩萨摩诃萨善知世谛。善知第一义谛。善知二谛。弥勒。如是诸菩萨摩诃萨毕竟成就善知方便

弥勒。云何诸菩萨摩诃萨成就般若波罗蜜。弥勒。若诸菩萨摩诃萨如是觉知。依此法有此法。依此法生此法。所谓无明缘行。行缘识。识缘名色。名色缘六入。六入缘触。触缘受。受缘爱。爱缘取。取缘有。有缘生。生缘老死忧悲苦恼。如是唯有大苦聚集。弥勒。此法无故此法无。此法灭故此法灭。所谓无明灭则行灭。行灭则识灭。识灭则名色灭。名色灭则六入灭。六入灭则触灭。触灭则受灭。受灭则爱灭。爱灭则取灭。取灭则有灭。有灭则生灭。生灭则老死忧悲苦恼灭。如是唯有大苦聚集灭。弥勒。如是诸菩萨摩诃萨毕竟成就般若波罗蜜。弥勒。是名诸菩萨摩诃萨毕竟成就八法。不退阿耨多罗三藐三菩提。于胜进法中不退不转。行菩萨行时降伏一切诸魔怨敌。如实知一切法自体相。于诸世间心不疲惓。以心不疲惓故不依他智。速疾成就阿耨多罗三藐三菩提

佛说此经已。弥勒菩萨摩诃萨。及余诸菩萨摩诃萨。比丘比丘尼。优婆塞优婆夷。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。一切大众闻佛所说。皆大欢喜。信受奉行

弥勒菩萨摩诃萨所问经论卷第一

归命弥勒世尊。问曰。何故如来说此修多罗。答曰。舍等四句示现施戒修行相三种功德。是菩萨外道声闻辟支佛共法。深心等四句示现即彼四法唯菩萨行。不与外道声闻辟支佛共。是故如来说此修多罗。布施示现施功德。远离杀生等示现戒功德。慈悲等二句示现修行功德。此义云何有外道凡夫离善知识不闻正法不善思惟不如说行故。妄执常见等能集业因。诸结使等相依有力增长世间因故。坚着妄执决定成就世间因故。离实谛见故无利益他心故。贪着世乐故。彼诸外道虽有施等善根种子。以疑悔故。爱水润识。住五取阴地。无明土覆时节和合能生识牙。次第增长成世间果。又声闻辟支佛人亲近善知识。从已度生死海欲度生死海人。闻说世间过患复自少见。厌世间苦乐涅槃乐。欲舍世间追求出道。虽不取施等功德。而亦不离施等功德。能伏烦恼得上胜法。以是义故。虽复修集施等善法。以无四法故。不得大菩提。又菩萨人毕竟具足成就八法建立大事。荷负重担亲近真善知识。深见世间过患。知涅槃寂静。为众生故不厌世间苦。初发菩提心不失因故。深心成就。舍自身乐为利益众生故。修行施等功德回向大菩提。依方便力增长微少施等功德。能护自身不堕声闻辟支佛地。以究竟成就般若波罗蜜故。能清净施等功德。令住菩萨道。示现深心等四句。能摄取施等四句。为菩萨不同法能得一切种智。是故如来说此修多罗

问曰。复以何义如来说此修多罗。答曰。为遮无因颠倒因随顺正因果。是故如来说此修多罗。此义云何。言不退阿耨多罗三藐三菩提者。以深心成就故。此明何义。以诸菩萨摩诃萨见法界时即得永离菩提心障。谓身见等一切烦恼。出过声闻辟支佛地入菩萨位。起于初地菩提之心不失因故。证得深心。是故名为不退。阿耨多罗三藐三菩提。又言不转者。以证胜法故。此明何义。以成就施行故。此复何义。以起无损害心根本业道。摄取上上胜行。是故不转离根本业道修行施等行一切处不退。以是义故名为不转。又言行菩萨行时降伏一切诸魔怨敌者。以善知回向方便心成就故。此明何义。略说四魔。谓烦恼魔阴魔死魔及以天魔。唯烦恼魔以为根本。依烦恼魔有余三魔。何以故。以诸凡夫烦恼缠心依此烦恼所缠之心。乐于世间求彼处乐。布施等法回向天道。以此义故为彼阴魔死魔所缠系属天魔。是故菩萨断身见等一切烦恼。复能远离不活等畏。舍自身乐为欲利益诸众生故。修集慈悲布施等行善根功德。皆悉回向萨婆若智。远离一切诸魔恶道。是故名为行菩萨行时降伏一切诸魔怨敌。又言于诸世间心不疲惓者。以大慈大悲心成就故。此明何义。以诸菩萨摩诃萨常为世间一切众生愚箭所射心受苦恼。以大慈大悲心成就故。见众生利即是己利。是故大慈大悲心生。则能利益一切众生。是故名为于诸世间心不疲惓。又言如实知一切法自体相者。以方便成就故。此明何义。以知诸法自相同相故。此复何义。以诸菩萨善知世谛善知第一义谛方便。是故不著有无二边。此明何义。菩萨虽见识境界事。而先已观察识境界事。何以故。以常不舍第一义谛深心力故。是故不堕著有边见。虽常不舍第一义谛而常善知世谛之事。何以故。以常明见诸有为行不舍世间心念言说故。是故不堕着无边见。以能善知此二种义是故名为如实知一切法自体相。又言以心不疲惓故不依他智速疾成就阿耨多罗三藐三菩提者。以般若波罗蜜成就故。此明何义。以诸菩萨摩诃萨般若观察有为法故。此复何义。菩萨观察诸有为行。无人无众生无主无自在。迭共相因增长有力。依于本业造一切业。犹如幻师所作幻人。往来跳踯种种技术无疲惓者。是故名为以心不疲惓故。又心不疲惓者。以离众生相故。此明何义。有为诸行一切无实。唯有种种诸业使行他力相依故。能成就有为诸行。是故菩萨知有为法实无神我。而不依他智随所修行。皆以毗离耶波罗蜜增长成办。速疾成就阿耨多罗三藐三菩提。以诸菩萨摩诃萨求萨婆若。示现远离无因颠倒因。随顺正因果。是故如来说此修多罗。问曰。复以何义如来说此修多罗。答曰。依不定聚菩萨求定聚故。成就何等行。得入正定聚。示现彼菩萨入正定聚修正因行。是故如来说此修多罗。此义云何。菩萨未证初地正位。虽无量劫习集善根。而未能得不退转位。未得毕竟无怖畏处。心未安隐。常为世间苦恼所逼。未得菩提心根本慈悲心力。未得增上力故。以世间道智观察十二因缘。如实观有为行以依世间道。观寂静法界求大涅槃无方便智故。堕声闻辟支佛地。若堕声闻辟支佛地有三种失。何等为三。一者退失一切大乘善根种子。二者退失能与一切众生乐因。三者退失萨婆若智。以是义故如来经中说言。迦叶。譬如一切世间天人。虽复修治伪琉璃珠。而彼伪珠终不能作真琉璃宝。如是迦叶。一切声闻修戒定慧。及头陀等一切功德。终不能得坐于道场成阿耨多罗三藐三菩提。迦叶。譬如修治大毗琉璃。随意能得无量百千万亿珍宝。如是迦叶。修菩萨行故能出生一切声闻辟支佛等及以人天。依此义故如来宝积经中说。菩萨有四种非善知识。何等为四。一者求声闻人但欲自度。二者求缘觉人喜乐小事。三者读外经典路伽耶等。四者习学一切文辞严饰。所有亲近此四种者。但增世利不增法利

复有经中大德迦叶白文殊师利。有五逆人能发阿耨多罗三藐三菩提心。修诸功德证大菩提。而罗汉不能。譬如根败之人于五欲境界无所能为无所增益。如是声闻辟支佛人离诸结使。于一切佛法无所能为无所增益。无如是观察佛法力。是故文殊师利。一切凡夫报如来恩非声闻也。何以故。凡夫之人闻佛功德。为不断绝三宝种故。能发阿耨多罗三藐三菩提心。声闻之人虽复终身闻诸佛法十力四无畏等。而不能发阿耨多罗三藐三菩提心。又般若波罗蜜经中说。诸天子。未发阿耨多罗三藐三菩提心者。彼人应发大菩提心。已入声闻辟支佛位。不能复发阿耨多罗三藐三菩提心。何以故。一切声闻辟支佛等断生死流。不能数数受生世间。发阿耨多罗三藐三菩提心诸菩萨摩诃萨。于初地中见实谛故。发阿耨多罗三藐三菩提心。不失因故摄得深心。以般若波罗蜜如实摄取修戒行等。不着身命唯为利益众生。修行彼时名为不退转菩萨。应知。是故如来十地修多罗中说。菩萨生如是心。即时过凡夫地入菩萨位。生在佛家种姓尊贵。无可讥嫌过一切世间道。善住菩萨法中。善住菩萨正处。入三世平等真如法中。如来种中毕定究竟阿耨多罗三藐三菩提。菩萨住如是法。名住菩萨欢喜地。以不动法故过五怖畏。所谓不活畏。恶名畏。死畏堕恶道畏。大众威德畏。彼皆远离。何以故。是诸菩萨离我等相故。过凡夫地者彼过有九种。应知。入菩萨位者位过。初成出世间心如始住胎相似法故。生在佛家者家过。以依方便般若生家生相似法故。种姓尊贵无可讥嫌者种姓过。以大乘行生子相似法故。过一切世间道者出过。以世间道不能摄取出道生相似法故。入出世间道者入过。以出世间道摄取入道生相似法故。善住菩萨法中者身过。以大悲为体。于作他事即是己事。自身体相似法故。善住菩萨正处者处过。不舍世间方便不染善巧正住生住处相似法故。入三世平等真如法中者业过。顺空圣智生命相似法故。如来种中决定究竟阿耨多罗三藐三菩提者毕竟过。佛种不断究竟涅槃道成就相似法故。如是示现凡夫生菩萨生入胎不相似。以有染无染故。如是次第家不相似。种姓不相似。出不相似。入不相似。身不相似。处不相似。生业不相似。成就不相似。如是尊者婆薮槃豆说毕竟成就心。有余论师更异法释。偈言

  菩萨摩诃萨　　以生何等心
  见世间虚妄　　佛说彼初心

此明何义。见世间虚妄者。以一切世间唯因缘生无有实体。如尊者龙树菩萨偈言

  因缘和合生　　彼法无实体
  若无实体者　　云何名有法

圣者无尽意菩萨摩诃萨无尽经中说。观察因缘方便智。知一切法依因依缘和合而生。若一切法依因依缘依和合生。彼法不依我人众生寿命。若法非我非人寿命。彼法不可数为过去现在未来。菩萨若能如是观察。是名菩萨摩诃萨观察因缘和合方便智。不依我者。此义云何。以依种种因缘法生。不依我生。以无实我体故。如众缘生火。火体有热。热无实体。而因缘和合名火有热。如是不离身根知外更有实我。以无实体故。无实体者。为同虚空。为同有为。若同虚空即是无物。若同有为即是无常。我人众生寿命等者。为可化众生种种名说非有实我。又如经中。大海慧菩萨为圣者大悲思梵。说成就一切佛。法问答品中偈言

  诸法因缘生　　彼法无实体
  法若实无体　　彼法实不生
  菩萨知众生　　如是无实际
  依彼实际智　　知诸法虚实

以是义故。菩萨知一切法因缘和合而生。众生无其实体。若如是者。一切世间心识皆是虚妄分别。彼菩萨心于一切法实际平等无碍智行即是初心。是故名为初发阿耨多罗三藐三菩提心。是故偈言

  彼不见凡地　　以彼体空故
  是故诸佛说　　过彼凡夫地
  远离圣人法　　染着身见等
  住五欲资生　　故名凡夫人

此明何义。地者彼处生凡人。是名凡夫地。此是三界中烦恼所缚处。依止烦恼生。是名凡夫地。是故彼初心见三界皆空。不起一法相。以其不起一法相故。则不愿乐一切处生。除慈悲心为欲教化诸众生故。而常观察寂静法体。以是义故。说彼菩萨过凡夫地。是故偈言

  法体无故空　　空故无所作
  离一切相故　　智者无所求

入菩萨位者。偈言

  即空名菩提　　佛说烦恼病
  堕辟支佛地　　及取声闻位

即空名菩提者。如实觉知众生虚空名为菩提。是故圣者无尽意菩萨四念处说。诸菩萨摩诃萨修法观时。若见一切法离空无相无愿无行无生无起。及离十二因缘者。不名如实觉。若不见少法离空无相无愿无行无生无起。及离十二因缘。菩萨若能如是觉知一切众生无其实体。是名如实觉。是故偈言。即空名菩提故。若初地菩萨觉知一切诸众生。空弃舍利益一切众生。而取声闻辟支佛位。是则名为初地菩萨所治烦恼。是故偈言。佛说烦恼病堕辟支佛地及取声闻位故。又复偈言

  知空离二边　　无二染涅槃
  以无涅槃染　　佛说菩萨位

知空离二边者。此义云何。如如来法印经中说。舍利弗言。无差别法者。即名为空。舍利弗言。世尊。所言空者此言何谓。佛告舍利弗。所言空者非可说非不可说。若非可说非不可说彼不可表。若不可表彼非世间非出世间。以非世间非出世间故说名为空。若能如是了知空者名离二边。菩萨若离彼二边者。不堕烦恼不取声闻辟支佛等二种涅槃。佛说烦恼病者取异地相故。取异地相者。谓取声闻辟支佛等异地相故。亦名弃舍利益众生。以取无为涅槃乐故。又以妨于佛菩提故。复有异义。无烦恼病者。离烦恼病故。以其不取二乘涅槃。依本愿力不舍利益诸众生故。若如是者无二乘病无烦恼病。如实修行一切法空。是名诸菩萨摩诃萨入菩萨位。以能远离一切烦恼远离一切对治法故。如是菩萨以无二行依本愿力不舍利益诸众生故。不堕声闻辟支佛地。不为世间烦恼所染。此是菩萨摩诃萨等最难胜事。以虽不见一切众生而为众生修行诸行。如是之事不可思议。一切世间不能觉知。第一希有一切声闻辟支佛等所不能见。以此义故。龙树菩萨摩诃萨集菩提功德论中说偈言

  此最希有事　　第一不思议
  菩萨为行行　　而不见众生

如来亦说为欲赞叹诸菩萨摩诃萨如实希有功德。如经中说。菩萨摩诃萨有四种真实功德。何等为四。一者能信解空亦信因果。二者知一切法无有吾我。而于众生起大悲心。三者深乐涅槃而游生死。四者所作施行皆为众生不求果报若如是者即生在佛家。是故偈言

  菩萨摩诃萨　　以离诸烦恼
  则证菩萨位　　是故生佛家

此明何义。又佛家者行何等法生如来家。谓离烦恼故。解空行故。知自位故。又作利益众生行故。不迷失行故。得如是法名为菩萨摩诃萨生在佛家。此明何义。偈言

  佛说如来家　　谓方便般若
  菩萨生是家　　是故不可嫌

此义云何。言方便者略说不舍一切众生。言般若者。所谓不取一切诸法。此二种法是诸佛家。是故菩萨摩诃萨依方便般若生。以为方便般若二法之所摄故。菩萨摩诃萨为欲利益一切众生生在世间。而实不依烦恼业生。若如是者。菩萨摩诃萨不可讥嫌。一切天等可呵之法皆悉远离。生佛胜家。以是义故。种姓尊贵不可讥嫌。是故如来修多罗中。为婆罗门而说偈言

  天人乾闼婆　　龙夜叉众鸟
  如是等诸业　　皆悉已灭尽
  彼漏散灭尽　　如莲华不染
  若能如是知　　不染着诸欲

如是菩萨摩诃萨是名真佛子。非天等异子。是故偈言

  菩萨知实际　　及修波罗蜜
  以得无漏道　　故出过世间

菩萨知实际者。此明何义。明一切法皆悉寂静。是故如来而说偈言

  一切法无体　　以实无诸事
  不生不灭故　　得名为实际

如是般若波罗蜜知一切诸法无体真实际。以般若波罗蜜知断道行。五波罗蜜知方便功德道。如是菩萨摩诃萨以此功德智慧能成佛菩提。能尽诸烦恼。能利益众生。又修诸波罗蜜亦知如实际。云何知。不见施者受者财物三种法故。修行清净诸波罗蜜。菩萨如是修行实际。是故无漏。以无漏故出过一切诸世间道。是故偈言

  分别世间行　　烦恼稠林中
  取出世间位　　是入出世道

分别世间行者。略有二种分别。一者实分别。谓色是可见相。如是等。二者胜分别。即彼色中青黄赤白等。世间者。即五阴烦恼。稠林者。深崄黑闇恐怖可畏。不可观察难见难知。如是菩萨摩诃萨观察自体分别胜分别五阴分别。如向所说事中不着。作是思惟。我当云何令众生解。是故偈言

  如实知诸法　　实胜阴一二
  不见众生事　　云何化众生
  菩萨摩诃萨　　修行无漏智
  及以功德行　　趣于出世道

是故菩萨入出世间道。问曰。云何善住菩萨法中。答曰。偈言

  入菩萨诸地　　安住己法中
  依通及自在　　化一切众生

入菩萨诸地者。如下经言。善知地地转行故。化一切众生者。如下经言。得百三昧乃至无量百千万亿那由他劫不可数知故。得自在者。如说种种功德何等时何等法何等自在何等成就事何等行。得诸自在不退一切佛法种子义成就一切佛法故。言善住菩萨法中。问曰。云何善住菩萨正处。答曰。偈言

  一时诸佛边　　闻持思修说
  行解义成就　　正觉供养等
  菩萨摩诃萨　　修行如是法
  是名为安住　　菩萨正处中

是故经言善住菩萨正处。问曰。云何入三世平等真如法中。答曰。偈言

  知诸佛菩提　　及佛菩萨行
  知佛三世空　　是名善意入

此义云何。谓知一切三世诸佛法身平等。又复能知一切诸佛依色身故。修行一切佛菩萨行。及知一切过去未来现在诸法。皆从因缘和合而生无其实体。善意入者。如向所说三世诸法平等无二。如实而知一味等味不破坏入。是故经言。入三世平等真如法中。问曰。云何如来种中毕定究竟阿耨多罗三藐三菩提。答曰。偈言

  菩萨净烦恼　　及净众生心
  具足大慈悲　　毕定成菩提

菩萨净烦恼者。此义云何以初地所治身见等烦恼。于见道时中皆悉远离故。彼见道中远离烦恼。如向所说。见一切法三世平等。如实中说。及净众生心者如下经言于一念顷教化百众生。乃至若以愿力自在胜上。如是等。依教化力清净诸烦恼故。得故下经言。是故我当先住善法。亦令他人住于善法。何以故。若人自不行善不具善行。为他说法令住善法。无有是处以得大慈大悲心故。是故上经言。是心以大悲为首。是故菩萨自净烦恼净众生心具大慈悲。名为毕竟得阿耨多罗三藐三菩提。以毕定进趣大菩提故。偈言

  佛子金刚藏　　说十法初心
  即名佛菩提　　毕成佛道故

此义云何。以圣者金刚藏菩萨摩诃萨。说此十种法为菩萨初地无漏菩提心。即此十种心名为佛菩提故。言毕竟阿耨多罗三藐三菩提。又偈言

  譬如好种子　　能生茎叶等
  如是菩提心　　不异诸佛法

此义云何。以初证法心于一切佛法以为种子。以初地法与一切佛法。以为因故。又偈言

  初地心增长　　佛说为诸地
  最妙胜菩萨　　说初月为喻

此明何义。如文殊师利问菩提经中。说偈言

  譬如月初生　　增长即满月
  如是欢喜地　　增长即是佛

如是十句义。余论师异释应知。是故如来为不定聚菩萨求定聚故。说此修多罗

弥勒菩萨所问经论卷第一弥勒菩萨所问经论卷第二

        后魏天竺三藏菩提流支译

问曰。以何义故名不退转。答曰。以诸菩萨证得初地毕定因故。乃至未得成佛以来。常以深心如实修行。次第增长菩提之心。彼所治法不能障故名不退转。问曰。复以何义。名不退转阿耨多罗三藐三菩提。答曰。以得成就不退转因。谓深心等八种法故。又不退转心相违之法。身见贪等一切烦恼。以见道力悉远离故。又身见等一切烦恼。无始世来随无智生不能远离。取我乐等因离方便般若。为诸世间苦恼所逼。弃舍利益一切众生取于涅槃。是故菩萨得慈悲深心。远离取着我乐等因。有方便般若。虽为世间苦恼所逼。而不放舍利益众生所作之事。断身见等烦恼根本。彼时得不退转阿耨多罗三藐三菩提。是故圣者无尽意说言。彼心离一切烦恼生。如是等

问曰。若离身见等烦恼名不退转因者。菩萨及须陀洹。俱离身见等烦恼。何故菩萨不退转阿耨多罗三藐三菩提。而须陀洹等退转。答曰。以心行差别故。此明何义。菩萨声闻发心以来。心行等相一切差别故。云何差别。声闻之人不能修学利益他因。是故弃舍利益众生自求涅槃。见三界中贪等烦恼火之所烧无常所逼。厌离三界如身衣火燃。观无常等五阴有为行。乃至离三界结。然后除贪等烦恼。渐渐微薄出过三界。菩萨之人得深心故。常乐利益一切世间。为诸众生作利益行。虽为世间苦恼所逼。以成就方便智慧力故。虽能如实修行声闻道。而不证声闻道。以先断所障取声闻位法故。何者是取声闻位法。谓舍大悲心。不能增长大悲等行。若诸菩萨得深心等修行菩提心眷属等法。能作证菩提位因。彼时菩萨见一切法故。能增长菩提心力。方便推求利益一切众生之事。彼时即见如实法界。见法界故即时远离见道所治一切烦恼。即得毕竟大菩提心。如十地经说。菩萨摩诃萨生如是心。是心以大悲为首。如是等。彼菩萨如是证见道已。方便推求利益一切诸众生。因善学大悲深心等法。离我乐等不为烦恼火之所烧。因不相似故。菩萨摩诃萨常以深心为利益他而修行故。即见道时断三界中一切烦恼。而声闻等先不修集慈悲方便。是故无有利益他行。渐断烦恼后得罗汉。以是义故。大海慧菩萨经中说。菩萨先已修集善根相应烦恼。所谓大悲波罗蜜等。此诸善法名为烦恼。非余烦恼。依彼烦恼为化众生住于世间。以其所求未究竟故。以是义故。虽复俱离彼身见等一切烦恼。而菩萨不退转阿耨多罗三藐三菩提。声闻退转。如阿耨大池圣者龙王经中。佛告龙王。菩萨摩诃萨所证之位。是出世间法。而不离世间。龙王。有方便般若圣智三昧。是名菩萨摩诃萨出世间位。龙王。譬如声闻入声闻位。名须陀洹不堕恶道。龙王。菩萨亦尔。入菩萨位名为不退转菩萨不堕恶道。龙王。声闻之人。不断烦恼取声闻位。以其未过不自在法得初果故龙王。菩萨摩诃萨过声闻位证菩萨位。是故不取声闻小果。乃取道场大菩提果。以是义故。声闻有量。菩萨无量。龙王。如有二人俱堕高山。其一人者勇健多力。先已习学种种技能。以方便智还上山顶。其第二人身力微少。先不习学种种技能。无方便智。堕彼山下不能还上。龙王。如是菩萨摩诃萨观察一切法空无相无愿无为。依般若力观察众生。住于一切种智山顶。复有经说。大德须菩提。菩萨摩诃萨断身见等无量烦恼。而不取彼声闻小果。乃取诸佛大菩提果。观察一切佛法。以大慈悲心怜愍一切众生。修菩萨行。断身见等一切烦恼。是故不取声闻小果。乃取诸佛大菩提果。须菩提白文殊师利言。文殊师利。此事希有。此大方便菩萨之人。断身见等一切烦恼。而能不取声闻小果。文殊师利言。大德须菩提。菩萨摩诃萨有大方便所摄智性。是故菩萨虽如实知彼身见等一切烦恼。而能不取声闻小果。大德须菩提。如大力士持薄利刀斩断娑罗树。彼娑罗树即住不倒。大德须菩提。菩萨摩诃萨亦复如是。有大方便般若智性。是故菩萨断身见等一切烦恼。而能不取声闻小果。大德须菩提。彼娑罗树复于异时值天雨润。即便还生枝叶华果。具足如本众生受用。大德须菩提。菩萨摩诃萨亦复如是。得大慈悲心雨所润。虽断身见等诸烦恼。还入三界方便示现生世间家。随顺一切众生受用。大德须菩提。复于后时彼娑罗树大风吹动。即便倒地更不复生。大德须菩提。菩萨摩诃萨亦复如是。为大智慧猛风所吹。在道场地永灭不生。是故菩萨摩诃萨发心已来。一切心行不同声闻辟支佛等。以诸菩萨摩诃萨心行等法本来不同故。若一切同者。应声闻作菩萨。菩萨作声闻

问曰。如声闻人先断见道烦恼。然后渐断修道烦恼。菩萨何故不同声闻。先断见道烦恼。然后乃断修道烦恼。又问。如菩萨取无量世住。修集无量善根。须陀洹等何故不取无量世住。亦不修集无量善根。答曰。须陀洹等常有乐断烦恼心故。以得无漏对治明故。转转怖畏诸世间故。生如是心。何时当得离一切苦入无余涅槃。故修道中余残烦恼自然渐尽。以是义故。声闻不取无量世住。亦不修集无量善根。菩萨之人无量世来。为诸众生作利益因。为诸众生作利益事。得如是等毕竟之心。复见真如甘露法界。观察一切诸众生身。而实不异我所求处。是故菩萨见修道中一切烦恼。能障利益众生行故。即见道中一时俱断。又以观察利益一切诸众生乐胜涅槃乐。是故菩萨取无量世住于世间修一切行。谓萨婆若智故能明见。修集无量菩提善根。得大菩提利。是故修集无量善根

问曰。菩萨若见修道烦恼能障利益诸众生行。以是义故。于见道中即断除者。以何义故。即见道中不以世间智伏修道烦恼。答曰。远离一切烦恼名不退转因。若离无漏道见法。离无漏道断一切烦恼者。可如是难。何故世间道不伏修道烦恼。若世间道同世间道。无如是力。是故不得言不退转。而此菩萨即见道时永断一切所治之法。得大悲等生毕竟菩提心。名不退转菩萨。应知是故菩萨如实见法成就方便。不取声闻辟支佛地。如实知见一切世间种种过患。为欲利益一切众生行世间行。不舍世间。不为世间过患所染。是故圣者文殊师利告天子言。诸天子。菩萨摩诃萨不住有为不住无为。是故菩萨名为福田。何以故。菩萨离有为法不住无为法。知有为有过。知无为无过。知一切过故。不住有为。知无为法。不住无为。诸天子。如大力士仰射虚空。而彼射箭于虚空中无所依住。而不堕地。诸天子。此事为难。更有难者。天子白文殊师利言。如是之事希有最难。更无难者。文殊师利告天子言。菩萨摩诃萨所作难事复过于此。以菩萨摩诃萨不舍有为而证无为不堕有为而能教化堕有为者

问曰。毕竟定者。如来经说。若毕竟定声闻之人远离三结得须陀洹不堕恶道。人天七反永离诸苦。毕竟证得阿罗汉道。菩萨亦尔断三结等。以何义故。不同声闻。而无量世住。答曰。此义不然。何以故。言毕竟定者。依声闻乘修多罗说。菩萨摩诃萨依无量行依求一切种智。清净出世间道能净萨婆若。大乘修多罗中说。以是义故。菩萨摄取无量世住。问曰。此义不然。何以故。若初地菩萨摩诃萨远离一切对治之法。得毕竟不退转阿耨多罗三藐三菩提者。以何义故。文殊师利问菩提经中说。初发心能过声闻地。第二行发心能过辟支佛地。第三不退发心过不定地。第四一生补处发心安住定地。答曰。彼经中依证胜进地依远中远离所治。法依上上地说过不定地。是故此说不违彼经。此义云何。如初禅对治法。此明何义。如小乘人未来禅中断不定因欲界修道烦恼。乃至第四禅中亦说断修道烦恼。以远中远胜对治法而不相违。何以故。以对治因等故。菩萨摩诃萨亦复如是。于初地中断菩提心相违退因。谓身见等一切烦恼。以得成就深心等修行。毕竟远离退菩提心因故。乃至八地中得胜进远中远胜对治法。名为过不定地。安住定地。以对治法等故。以定因故。言过不定地义不相违。又言过不定地者。求佛菩提大涅槃心未断绝故。所起诸行功用疲惓名不定因。是故八地以上始言过不定地。此义云何。如彼处过苦等。此明何义。如小乘中厌过欲界苦。虽厌过欲界苦。而初禅地未过识等苦因。以未过所治法。是故如来经中说。第二禅中过苦。如经中说。忧根何处灭。佛言。初禅中灭。又问。苦根何处灭。佛言。二禅中灭。又问。喜根何处灭。佛言。三禅中灭。又问。乐根何处灭。佛言。四禅中灭。如是过一切色相等。厌初禅时即过一切色等诸相。而第四禅中厌过因故。说第四禅过。菩萨摩诃萨亦复如是。于初地中已过不定地。二地已上乃至七地以来。求佛菩提大涅槃心未断绝故。所起因行疲惓功用名不定地。是故为彼未满足心不定因故。八地中说过不定地。言不相违。又得毕竟菩提心因缘具足和合故。言初发心过声闻地。如法印经。中如来说言。弥勒。发菩提心有七种因。何等为七。一者诸佛教化发菩提心。二者见法欲灭发菩提心。三者于诸众生起大慈悲发菩提心。四者菩萨教化发菩提心。五者因布施故发菩提心。六者学他发菩提心。七者闻说如来三十二相八十种好。发菩提心。弥勒。诸佛教化发菩提心。见法欲灭发菩提心。于诸众生起大慈悲发菩提心。此三发心能护正法。速疾成就阿耨多罗三藐三菩提。余四发心非真菩萨。不能护持诸佛正法速疾成就阿耨多罗三藐三菩提。此明何义。若菩萨成就深心毕竟不退。得大悲心大勇猛力。为诸世间一切众生过箭所射。而观众生起大慈悲。摄诸善根聚集增长故言初发心时过声闻地。第二发心过辟支佛地者。辟支佛人胜声闻人。毕竟不为他身。毕竟自为身求寂灭涅槃。若菩萨初观察法性上上观无生法忍时。未得过不定道。所有生心皆悉能过声闻辟支佛地故。言第二发心过辟支佛地。第三发心过不定地者。于初地中离不定因得定因故。所有生心过不定地故。言第三发心过不定地。第四发心安住定地者。二地已上远离一切所治之法。是故安住毕竟定地故。言第四发心安住定地

又不退转阿耨多罗三藐三菩提者。所谓菩萨得离发菩提心相违法时。名不退转菩萨。如宝女经中说。宝女。菩萨摩诃萨有三十二挂碍堑路发菩提心相违之法。何等三十二。一者求声闻乘。二者求辟支佛乘。三者求释梵处。四者倚着所生净修梵行。五者专一德本言是我所。六者若得财宝悭贪爱吝。七者以偏党心而施众生。八者轻易戒禁。九者不念道心专精之行。十者嗔恚之事以为名闻。十一者其心放逸。十二者驰骋。十三者不求博闻。十四者不察所造。十五者贡高自大。十六者不能清净身口心行。十七者不护正法。十八者背舍师恩。十九者不弃舍恩。二十者离坚要法。二十一者习诸恶友。二十二者随诸阴种。二十三者不勤助道。二十四者念不善本。二十五者所发道意无权方便。二十六者不以殷勤咨嗟三宝。二十七者憎诸菩萨。二十八者所未闻法闻之诽谤。二十九者不觉事。三十者习持俗典。三十一者不肯劝化众生类。三十二者厌于生死

又复所以不退不转。以诸菩萨毕竟受持不退转法故。如娑伽罗龙王经中说。龙王。菩萨摩诃萨毕竟成就八种法故。得名为入不退不转菩萨之数。何等为八。所谓如说修行。一者观察自过不观他过。二者乃至不为自身命故施恶于人。三者若得利养其心不高。若失利养心亦不下。四者于诸众生起福田想。不生恶心。五者所有财物悉与一切众生共之。六者于诸法中不欲独解令他不知。七者见他得乐生欢喜心。不由自乐生欢喜心。八者于爱不爱其心平等。菩萨具此八种法故。不退不转阿耨多罗三藐三菩提

问曰。应说不转相。云何不转相。答曰。我正欲说而汝复问。菩萨成就不转相者。如来处处修多罗中广说应知。如智印三昧修多罗中说言。弥勒。有五种法名为菩萨毕竟不转阿耨多罗三藐三菩提相。何等为五。一者于诸众生起平等心。二者于他利养不生嫉心。三者乃至自为身命。不说法师比丘诸恶过失。四者终不贪着供养恭敬赞叹等事。五者毕竟得甚深法智忍。弥勒。更有五法故。得名为不转菩萨。何等为五。一者不见自身。二者不见他身。三者心不分别妄说法界。四者不见菩提。五者不以相见如来。如是等。又般若波罗蜜经中广说不转之相。如彼经说应知

问曰。云何得异法菩提心。不退转菩提心因。于异佛菩提名不退转阿耨多罗三藐三菩提心。答曰。以得决定因故。此明何义。以初地菩萨成就毕竟因。以依此因毕竟证大菩提。是故言得不退转阿耨多罗三藐三菩提。言阿耨多罗者。谓胜一切有为法故。言三藐三菩提者。谓离一切诸不善法烦恼习气故。于一切处无障碍故。一切种一切法如实正知故。是故言三藐三菩提

问曰。应说不退不转功德。云何不退不转功德。答曰。不退不转功德者。如来处处经中广说应知。如十地经说。诸佛子。若有众生厚集善根故。善集诸善行故。善集诸功德行故。善供养诸佛故。善集清白法故。善知识善护故。善清净心故。入深广心故。毕竟信乐大法故。现大慈悲故。如是众生乃能发阿耨多罗三藐三菩提心。厚集善根者。菩萨从初发心已来能过声闻辟支佛性。是故能与不退不转菩萨之位。以为种子。贪等善根非正种子。久修无量诸功德行故。言厚集善根故。善集诸善行者。菩萨正修诸行。名修诸善行。行修生起名异义一。又言行者。清净身口意业正命自活。以诸菩萨离损害心。为起成就利益一切诸众生行。一切声闻辟支佛等不能得度智慧大海。而菩萨能渡故。言善集诸善行故。善集诸功德者。以布施忍辱不放逸等。四摄四家化众生因。诸法种子增长正集故。言善集诸功德故。善供养诸佛者。为增长他利益因力。即是己事正快无量。种种供养种种恭敬。闻正法等生生供养恭敬诸佛故。言善供养诸佛故。善集清白法者。以诸菩萨无量门。集布施等行修诸白法。为取大菩提成就一味心正回向故。能成就不退转法故。言善集清白法故。善知识善护者。唯佛如来为善知识。能护菩萨令发心增长。安住不退不转法中故。言善知识善护故。善清净心者。以不求自乐专一味心为他利益。长夜不为自爱等门烦恼所染故。言善清净心故。入深广心者。大乘法中专念广胜毕竟因成就故。言入深广心故。毕竟信乐大法者。以起大心不怯弱故。不畏世间一切诸苦。见求小乘诸众生等起大悲心。欲与一切众生乐故。知一切种智处。以方便力令众生得故。言毕竟信乐大法故。现大慈悲者。以见生死种种诸苦逼恼众生。无舍无洲无有救者。为彼众生灭诸苦恼。行舍大舍极难舍等。以方便力入大苦中故现慈悲。又言慈者。初发心菩萨以少力故。但愿怜愍一切众生。是故名慈。又言悲者。如是如是为于一切众生修行。如是如是于胜法中起上上心。是故名悲故。言现大慈悲故

又不退转者。菩萨摩诃萨有八种法。能成不退转地。何等为八。一者大悲。二者心安住。三者智慧。四者方便。五者不放逸。六者发精进。七者善住念。八者值善知识。初发心菩萨应速修行此八种法。如救头然后方修集。菩萨其余不退转法。依此八法修集。其余不退不转一切功德。彼不退转一切功德。处处经中广说应知

问曰。但说不退阿耨多罗三藐三菩提便足。何故复言不转。以得不退者即是不转故。答曰。以得不退因毕竟成就深心故名不退。言不转者。依不退深心。起余心行上上胜进故名不转。问曰。若尔不退不转更无异义。云何不转于不退为胜。答曰。言不退者。依不损害心根本业道。起利益他行。证上上胜义故。言不转者。修行成故。又不退者。永断一切。得胜法障身见等烦恼根本尽故。言不转者。于修道中断灭根本无明故又不退者。善集具足功德故。言不转者。善集具足智慧故。又不退者。成就方便故。言不转者。成就般若故。又不退者。过声闻辟支佛地因故。言不转者。善集得菩提诸善根故。又不退者。成就大力故。言不转者。成就修行故。又不退者。具足成就十力因故。言不转者。具足成就四无畏因故。又不退者。依檀等白法为利益众生故。言不转者。檀等善根为众生故回向大菩提。常乐利益诸众生故。又不退者。以得初地不失菩提心因。深心等成就故。言不转者。二地已上起心十善业道所摄。异十善业道修行檀等。数数增长故

问曰。胜进法者其义云何

答曰。以诸菩萨心行增长。于先所得白净法中上上胜进。以是义故。名胜进法

降伏一切诸魔怨敌者。以降伏魔降伏怨降伏敌对。是故说言降伏一切诸魔怨敌。此义云何。菩萨降伏烦恼魔故。天魔伺求不得少过故。言降伏一切诸魔。以得闻思修慧力故。利益众生相违怨等所不能障故。言降伏一切诸怨。一切外道诸论师等不能折伏故。言降伏一切敌对。是故说言。降伏一切诸魔怨敌。又以般若力故。断烦恼魔故。言降伏一切诸魔。以方便力故能修集菩提善根。过二乘所证涅槃怨敌。是故说言。降伏一切诸魔怨敌。又复成就深心等法。过魔道因故。言降伏一切诸魔。求一切智地心未断绝。伏所敌对疲惓等法。求一切智地心已断绝。断所敌对疲惓等法故。言降伏一切敌对。又得菩萨十种自在故。能降伏阴等四魔故。言降伏一切诸魔。以住正定聚过菩萨怨敌声闻辟支佛地。是故名为降伏怨敌。又能善知诸魔业事故。言降伏一切诸魔。得诸菩萨善净诸业。能过一切诸恶道因故。言降伏一切怨敌。又能善护所治等法诸魔怨敌。是故名为降伏一切诸魔怨敌。如经中佛说。龙王。菩萨摩诃萨成就八法故。能降伏诸魔怨敌。何等为八。所谓一者知五阴法如幻化故。二者离身见等一切烦恼。如实知空故。三者如实知一切有为行不生而生诸世间故。四者常教化众生。常不舍离菩提心故。五者心常坚固修行精进。而常怖畏三界故。六者入不应入者而常求上智为众生故。七者常修集功德。而信无常相故。八者常修集智慧功德。而不求声闻辟支佛智故

问曰。应说菩萨行。云何菩萨行。答曰。菩萨行者。菩萨深见世间过患涅槃利益。发起智慧方便所摄大慈悲心。常为利益众生修行。是故名为行菩萨行

如实知一切法自体相者。知一切法如彼法相如实知故。又自体相名为相。如彼一切法自体相相。如是如实知

问曰。应如是说知一切法相。不应说知一切法自体相。答曰。为明可见能见法不二故。是故说如实知一切法自体相。此义云何。为明诸法自体相不离诸法更有相故。问曰。若尔应如是说知诸法体。不应说知相。答曰不然。若如是说。不离向所说过。此明何义。如诸法相离诸法更有体。恐如是取。为护彼过故二种说。此明何义。即自体相离体更无相。自体与相名异义一。是故说如实知一切法自体相。不如向难所说

问曰。何故名为自体相。答曰。若如实知一切诸法因缘。而有无实体相。此明何义。以诸菩萨随顺出世间智慧。能如实知彼诸法体。能如实知诸法体者。以见一切有为诸行依他因缘不常不断。以是义故。不着断常虚妄执着。有无不二成就中道。如实知见诸有为行虚妄不实。以得清净心知有为行虚妄分别故。远离破戒等垢因。清净戒具足。乃至未成佛来修集善根。与一切众生乐因。令得一切种智

弥勒菩萨所问经论卷第二弥勒菩萨所问经论卷第三

        后魏天竺三藏菩提流支译

问曰。云何于诸世间心不疲惓。答曰。于见道时离身见等疲惓因故。此明何义。以诸凡夫取我相故。为生死等种种诸苦之所逼恼。于世间中生疲惓心。诸菩萨等见法体时。皆悉远离着我相等。是故菩萨于诸世间心不疲惓。又复所以于诸世间心不疲惓。以得远离五怖畏故。此明何义。以世间众生未离不活等五怖畏故。于诸世间生疲惓心。菩萨离不活等五种怖畏。以离我相等故。具足修集功德智慧。是故菩萨于诸世间心不疲惓。又得一味利他心故心不疲惓。此明何义。以诸菩萨依慈悲心起利他行。深心善修。犹如大海同一碱味。菩萨亦尔。为利益他一味心故。以诸菩萨利益他行即是自利。为利众生修集诸行。是故菩萨于诸世间心不疲惓。又以菩萨得安住心故。于诸世间心不疲惓。此明何义。以诸菩萨乃至恶道。所谓活地狱。黑绳地狱。合地狱。叫唤地狱。多波那地狱。波多波那地狱。阿鼻地狱。究究罗地狱。死尸地狱。刀林地狱。剑林地狱。劈裂地狱。安浮陀地狱。阿波波地狱。阿吒吒地狱。忧钵罗地狱。拘勿头地狱。香地狱。分陀利地狱。波头摩地狱。种种寒热受诸苦恼。及泥犁中畜生饿鬼修罗人天互相杀害。共相食啖牵挽追求。或生或退。起于我慢嫉妒嗔恨。恩爱别离怨憎合会。老病死等忧悲苦恼。如是种种诸苦恼相。见闻爱离利益众生。其心一向不退不转。毕竟安住大菩提心。是名菩萨于诸世间心不疲惓。又不疲惓者。以愿坚固故。此明何义。以诸菩萨依大慈悲等起利益众生行。毕竟得深心根本诸行。善知坚固心故。随顺诸愿作利益行。是故菩萨于诸世间心不疲惓。问曰。何者名为菩萨摩诃萨坚固之愿。答曰。有五种法。名为菩萨坚固之愿。何等为五。一者声闻乘不能动转。二者辟支佛乘不能动转。三者诸外道论不能动转。四者一切诸魔不能动转。五者不以无因无缘自然动转。是故菩萨于诸世间心不疲惓。复有五法。于诸世间心不疲惓。何等为五。一者若见衰损利益。心无忧喜。二者所作已办如实知道故。三者如实知道果故。四者自身得寂静故。五者拔诸众生苦恼心故。是故菩萨于诸世间心不疲惓。又不疲惓者。以得大慈大悲心故。此明何义。以诸菩萨得大悲心。见诸众生没溺生等极苦淤泥。无明所盲贪爱所缚无所归依。菩萨以得慈悲心力。智慧为首勤行精进。拔众生苦。为诸众生于世间中受苦恼业。是故菩萨于诸世间心不疲惓。复有五法。知菩萨有大慈悲心。何等为五。一者为与众生安隐乐故。不惜一切资生之物。二者不惜自身。三者不护惜命。四者修一切行不待多时。五者怨亲等悲。是故菩萨于诸世间心不疲惓。又不疲惓者。能忍一切诸苦恼故。此明何义。以诸菩萨得依缘力。其心勇猛过无数劫能受苦恼。以能忍受一切苦恼。是故菩萨于诸世间心不疲惓。有五种法。于诸世间能受苦恼。何等为五。一者信诸法无我。二者信诸法空。三者观世间法。四者观诸业报。五者观察诸业已尽。为诸众生于无量劫而受苦恼。又不疲惓者。深心常求佛菩提故。此明何义。以诸菩萨常以深心乐于涅槃求佛菩提。以坚固增长为一切众生种菩提因缘善根种子行世间行。是故菩萨于诸世间心不疲惓。复有五法。菩萨常求无上菩提。何等为五。一者不同余乘智胜余乘故。二者世间最上首故。三者自度身故。四者度他人故。五者具足一切功德藏故。又不疲惓者。以为教化诸众生故。此明何义。菩萨长夜为诸世间可化众生随顺教化。为断众生世间苦恼。虽为种种苦箭所射。而于世间心不疲惓。又教化众生者。观众生心随诸众生于五乘法应受化者。而授与之。何等为五。一者应正遍知乘。二者辟支佛乘。三者声闻乘。四者天乘。五者人乘。又不疲惓者。勇健无畏故。此明何义。以诸菩萨依大智慧力故。依勇猛无畏力故。虽为世间苦箭所射。而于世间不生疲惓。有五种法。得知菩萨勇猛无畏。何等为五。一者衰损败坏其心不忧。二者成就一切诸利益法其心不喜。三者受诸苦恼其心不戚。四者得诸胜乐其心不欣。五者嗔喜二相不可测知。是名菩萨勇健无畏。应知。又不疲惓者。不着身命故。此明何义。以世间人着身命故。常为生死苦箭所射。厌背世间生疲惓心。是故菩萨乐作利益诸众生事。如实知身命故。弃而不着。为欲利益一切众生。是故菩萨于诸世间心不疲惓。菩萨能知五种法故。不着自身。何等为五。一者知身不从过去世来。二者知身不向未来世去。三者知身非坚固法。四者知身无实神我。五者知身无实我所。是故菩萨不着自身。菩萨能知五种法故。不贪着命。何等为五。一者依智慧活不依邪命。二者怖畏一切诸不善法。三者观无始世来未曾不死。四者等共一切诸众生有。五者不可常保

又不疲惓者。不着自乐故。此明何义。以诸众生着自身乐。受种种苦生疲惓心。菩萨舍自身乐拔众生苦。是故菩萨于诸世间心不疲惓。菩萨如实知五种法不求自乐。何等为五。一者知乐如水泡。二者知乐败坏时苦。三者得世间方便。以诸菩萨依善知识听闻正法。系念思惟以为根本。得身及众生出世方便。四者不依他智。五者依自智力

又不疲惓者。现见一切诸白法故。此明何义。以诸菩萨依丈夫力得果报故。以诸白法依丈夫力故。无量劫事现见如梦。于未来世不依他力。依自丈夫力修集诸白法。作是思惟。一切种智非他能与。依自力得。是故菩萨知不依他。自发精进修集诸行。速得阿耨多罗三藐三菩提。如佛告阿难。唯精进波罗蜜能得大菩提。是故菩萨于诸世间心不疲惓。又不疲惓者。以证自然智故。此明何义。以诸菩萨过疲惓因。是故成就不疲惓心。善知一切诸因缘法。依法生法次第增长犹如梯橙依般若根本成就精进。是故速证阿耨多罗三藐三菩提

又不退不转等诸句。余一切修多罗中广说应知。又复有义。言不退者。以得成就深心法故。又不退者。以得成就行心舍心故。言不转者。以得成就深心法故。降伏一切诸魔怨敌者。以得成就善知回向方便心故。如实知一切法自体相者。以得成就善知方便故。于诸世间心不疲惓者。以得成就大慈大悲心故。以心不疲惓故不依他智速疾成就阿耨多罗三藐三菩提者。以得成就般若波罗蜜故。是故佛告弥勒菩萨摩诃萨言。菩萨摩诃萨毕竟成就八法。不退阿耨多罗三藐三菩提。如是等

问曰。何故如来唯说八法不多不少答曰。此非正问。何以故。若多若少俱致问故。然佛世尊非无因缘说此八法。以此八法具足成就菩提因故。此明何义。成就深心乃至般若波罗蜜。毕竟成就此八种法。具足菩萨功德智慧。速疾成就一切种智。以此八法具足成就佛菩提因。是故如来唯说八法不多不少。又复所以唯说八法。以摄菩萨道故。此明何义。略说菩萨有二种道。一者方便差别道。二者慧道。成就深心乃至方便等诸句。示现方便差别道。成就般若波罗蜜者。示现慧道。是故文殊师利问菩提经中。圣者文殊师利言。诸天子。菩萨摩诃萨略道有二。以是略道速得阿耨多罗三藐三菩提。何等为二。一者方便道。二者慧道。方便道者。知摄善法。智慧道者。如实知诸法智。又方便者观诸众生。智慧者离诸法智。又方便者知诸法相应。智慧者知诸法不相应智。又方便者观因道。智慧者灭因道智。又方便者知诸法差别。智慧者知诸法无差别智。又方便者庄严佛土。智慧者庄严佛土平等无差别智。又方便者入众生诸根行。智慧者不见众生智。又方便者得至道场。智慧者能证一切佛菩提法智。以是义故。但说八法不多不少。又复所以但说八法。以摄助道断道故。此明何义。即彼修多罗中说。复次天子。诸菩萨摩诃萨复有二种略道。诸菩萨摩诃萨以是二道疾得阿耨多罗三藐三菩提。何等为二。一者助道。二者断道。助道者五波罗蜜。断道者般若波罗蜜。又从深心乃至方便。以为助道摄五波罗蜜。成就舍心摄檀波罗蜜。成就行心摄尸波罗蜜。成就深心摄羼提波罗蜜。成就善知回向方便心成就善知方便。摄毗离耶波罗蜜。成就大慈心成就大悲心。摄禅波罗蜜。成就般若波罗蜜摄断道。如是有碍道无碍道有漏无漏等。皆可类解应知。又摄有量无量道故。如彼经中说。复有二种略道。何等为二。一者有量道。二者无量道。有量道者取相分别。无量道者不取相分别。又从深心乃至方便等七句。取相分别摄有量道。应知。如是成就般若波罗蜜。不取相分别摄无量道。应知。如是四家四摄四无量三十七品。诸菩萨摩诃萨一切功德随义相应八法皆摄应知

问曰。应说深心义。云何深心义。答曰。深心义者。心实不住非心相应。慢使异相五阴相应起业修行增长因果深心因相违涅槃果相违修行善根非心相应。行属阴聚体随顺涅槃果。如因闻慧生余慧等。是名深心。又深心者。心少时住离心相应。善根行体依行起行。犹如流水次第生法是名深心。又深心者。依种子生。犹如乳等一切白法随顺因缘修行善法是名深心。又深心者。如久卷物虽暂牵舒放还依本。深心亦尔。随本因作法还续如本。不可说一不可说异。是名深心。又深心者。修学白法名为深心。又深心者。修行一切诸善根法。成就不失不增不减大涅槃法名为深心

问曰。如毗摩罗吉利致所说经说。菩萨摩诃萨修无量行有无量心。此深心者。为起何行。答曰。此深心者。悉能发起求佛菩提。一切诸行是名深心。何以故。以此深心发生一切菩提因故。悉能增长诸功德力。譬如尸罗。此明何义。如持戒人得善根尸罗。一切善法无量差别悉名尸罗。而身口意三业成就名为尸罗。何以故。身口意业与诸善法为根本故。深心亦尔。与佛菩提因一切善行以为根本故。是故伽耶山顶经中。月净光德天子问文殊师利言。诸菩萨摩诃萨深净心。以何为本。文殊师利答言。天子。诸菩萨摩诃萨深净心。以阿耨多罗三藐三菩提心为本。以是义故。此修多罗中所说深心。菩提心为本。如金刚密迹经中说。诸菩萨摩诃萨深心功德不诳世间。以是故说为菩提因。应知

问曰。以何义故。得言菩萨成就深心。答曰。以一切所治法不能动转故。此明何义。以种种苦恼不能动转。一切菩萨求菩提心。彼时菩萨名为成就深心。应知。又诸菩萨他身乐心有力降伏自身乐心故。此明何义。以彼菩萨自求乐心。为与他乐深心降伏。彼时菩萨名为成就。深心。应知。又成就深心者。以至究竟故。此明何义。以依深心下中上法次第增长。乃至毕竟坚固名为成就深心应知。又成就深心者。以起难舍能舍心故。此明何义。若诸菩萨修行檀等难行布施。深心发起修行等心。彼时菩萨名为成就深心应知。如圣者无尽意经中说。以头施等难舍能舍。名为成就深心应知。又成就深心者。以能降伏悭嫉等心故。此明何义。以诸菩萨得毕竟成就深心。能降伏悭嫉等菩提道相违法。彼时菩萨名为成就深心应知。如圣者无尽意经中说。大德舍利弗。诸菩萨深心者。降伏嫉妒教化悭嫉众生故。如是等名为成就深心应知。又成就深心者。以因果不尽故。此明何义。以诸菩萨深心因果无尽。彼时名为柔软菩萨应知。因不尽者。修行广大无量无边故。果不尽者。一切佛法无量无边。以不断绝三宝因故。又无尽意经中说。菩萨深心修行施等。以其能舍一切物故。是名菩萨成就修行。如是等。又言。大德舍利弗。诸佛如来十力四无所畏十八不共法。略说乃至一切佛法皆不可尽。是故深心亦不可尽。以修行果不可尽故。故言菩萨成就深心。又成就深心者。依此经说应知。以此经中说。弥勒。若菩萨摩诃萨闻赞叹佛及毁呰佛。其心毕竟于阿耨多罗三藐三菩提坚固不动。如是若闻赞叹法僧毁呰法僧亦复如是。菩萨如是如实见知十二因缘。即知诸佛如来法身。于三宝中成坚固心。以得无漏智毕竟深心故。一切外道诸魔怨敌不能退转。是故菩萨成就深心

问曰。以何义故。先说深心次说修行。答曰。以彼修行是证智因故。此明何义。以修行心能与深心作证因故。以起大慈大悲心故。此心即是护持佛果。应知。而彼深心不可得见。以依深心故。眼耳等识于境界中不能发起损害等心。为利益他离杀等行。示现彼心。以是义故说深心后次说修行。应知。又复示现次第义故。此明何义。一切诸法应当如是次第生故。先说深心后说修行

问曰。云何修行义。答曰。为利益他起不损害深心身口意业。摄自利行及利他行。是名修行。问曰。云何菩萨成就修行。答曰。以不共外道声闻辟支佛故。此明何义。以诸外道求世间乐修善业道。贪着世间乐果报故。所修诸行成世间果。以其成就世间果故。彼不能得成就修行。又以声闻辟支佛等求涅槃乐。修善业道离大悲心。成就小乘涅槃果故。彼声闻人于菩萨果不得名为成就修行。菩萨过于一切世间。见诸世间种种过失。乃至不着转轮圣王乐果报等。虽复能证小乘涅槃。依大慈悲勇猛心故。舍涅槃乐求佛菩提。修行十善业。为救一切诸众生故。摄大胜愿。其心唯以一切种智以为究竟。是故菩萨不同一切外道声闻辟支佛等修行十善业道。是故名为成就修行

又成就修行者。受持增上十善业道故。此明何义。以菩萨修行过于声闻辟支佛等十善业道。是故名为成就修行。诸菩萨摩诃萨有五种法。胜于声闻十善业道。何等为五。一者专心修行故。二者常修行故。三者为安隐自身故。四者为安隐他身故五者善清净。故专心修行者。毕竟不离一味心故。常修行者不断不绝。不休息故。为安隐自身者。为自身取人天安隐及大菩提故。为安隐他身者。为与一切众生安隐。毕竟回向大菩提故。以救过于无数众生故。善清净者。不破故。不点故。不污故。无所属故。善究竟故。不食故。智者赞叹故。破者。少分修治少分不修治故名为破。是故菩萨具足修治名为不破。点者。自不修行教他修行故名为点。是故菩萨自身修行教他修行名为不点。污者。自不修行不教他修。见他修行而心随喜故名为污。是故菩萨具足修行名为不污。属者。要依他智而能修行故。名为属。是故菩萨不依他智而能修行名无所属。善究竟者。专念毕竟欲心。专念毕竟爱心。专念毕竟恭敬心。专念毕竟信心。专念毕竟畏心。专念毕竟无常心。以是义故名善究竟。食者回向于有取。有资生故名为食。是故菩萨不取于有名为不食。智者不赞叹者。声闻辟支佛乘中回向世间。大乘中回向声闻辟支佛乘故。名智者所不赞叹。是故菩萨声闻辟支佛乘中不回向世间。大乘中不回向声闻辟支佛乘。是故名为智者赞叹。又成就修行者。出过一切诸世间故。此明何义。以诸菩萨修行十善业道胜诸世间。是故名为成就修行。应知。菩萨有五种法。修行十善业道。能过一切世间。何等为五。一者愿二者安隐三者深心四者善清净五者方便。愿者菩萨摩诃萨凡所发愿。一切凡夫声闻辟支佛无如是愿。是故菩萨依愿修行十善业道。则能出过一切世间。如摩诃衍修多罗中。无垢德女所说经言。尊者目连诸菩萨摩诃萨。从初发心乃至道场。常为一切世间天人而作福田。胜诸声闻辟支佛故。安隐者。以诸菩萨虽为一切世间极深重苦之所逼恼不能回转。取阿耨多罗三藐三菩提心。为阿耨多罗三藐三菩提故。专心修行十善业道。是故菩萨依安隐心。修行十善业道。则能出过一切世间。深心者。以最胜修行故。以诸菩萨最深爱心。修行十善业道。是故菩萨依深心故。修行十善业道。则能出过一切世间。清净者。除二地已上清净菩萨。何以故。以诸菩萨摩诃萨等。有三种清净修行十善业道。是故菩萨依清净修行十善业道。则能出过一切世间。方便者。菩萨于何等法中。以何等方便修行十善业道。余世间众生无如是方便。是故菩萨依方便力修行十善业道。则能出过一切世间。又成就修行者。以时等无量故。此明何义。以诸菩萨于无量世修行十善业道无量行等。是故菩萨成就修行。又诸菩萨得五种法故。修行无量十善业道。何等为五。一者无量世。二者无量善法。三者无量观。四者无量尽。五者无量回向。无量世者。以诸菩萨过无量世修行十善业道。是故菩萨于无量时修行十善业道。无量善法者。以诸菩萨修行无量善法。以彼善法无量。是故菩萨起无量善业道修行。如如来清净毗尼大乘修多罗中说。迦叶如四大海满中生酥。一切众生之所受用。菩萨摩诃萨修集一切有为善根亦复如是。以诸菩萨回向取彼无漏智故。能与一切众生受用。无量观者。以为无量众生观故。以诸菩萨非为有量众生修行十善业道。不作是念。我为若干众生修集善根。不为若干众生修集善根。以诸菩萨观一切众生修集善根。是故菩萨。善业无量。无尽者。如如来清净毗尼修多罗中说。诸天子。譬如长者财富无量。是大舍者。行大慈者。行大悲者。大商主者。怜愍一切诸众生故而修行者不退心者起如是心。我能与彼一切众生无量无边安隐之乐。诸天子菩萨摩诃萨亦复如是。以住深心为诸众生住安隐心起大精进心。作是思惟。我当教化无量无边苦恼众生。皆悉安置涅槃乐中。是故菩萨修行无尽。无量回向者。如初地中起无量愿行十尽句等。菩萨以彼十尽无量修行善业道亦复无量。以依先回向无量故。菩萨摩诃萨修行一切善业道。果亦复无量。是名无量回向

又成就修行者。以真实故。此明何义。以诸菩萨摩诃萨真实希有修行十善业道。是故菩萨成就修行。菩萨有五种法成就希有。何等为五。一者起大勇猛心。二者精进。三者坚固。四者慧。五者果。起大勇猛心者。发心能取阿耨多罗三藐三菩提。假使有人。若以指钳或一指节。能举三千大千世界无量劫住。此事非难。发心能取阿耨多罗三藐三菩提是事为难。是故菩萨修行善业道成就希有。精进者。菩萨作是思惟。众生能发大勇猛心。无量无边勤精进者少不足言。若能精进求菩提者是最希有。是故菩萨若欲求于第一希有无量功德。依大精进修善业道。是故菩萨修行善业道成就希有。坚固者。以诸菩萨发大精进修行善业道。住第一希有坚固力中故。能进趣究竟精进。是故菩萨修行善业道成就希有。慧者。菩萨作是思惟。勇猛精进坚固等法。皆依般若根本而有。是故般若希有之法。何以故。以依般若得有勇猛精进坚固。是故菩萨作是思惟。依于般若希有之法修行善业道。是故菩萨成就般若。果者。以依修行善业道等故能生果。证得无量无边一切佛法。是故成就希有之法

又成就修行者。方便摄取故。此明何义。以诸菩萨依方便力摄取。修行善业道故。不同声闻辟支佛等。是故菩萨成就修行。菩萨有五种法摄取方便应知。何等为五。一者时处智。二者回转入智。三者合智。四者得意智。五者次第智。时处智者。以何等时应说如是法。以何等处应说如是法。随何等时应如是化众生。随何等处应如是化众生。彼一切如实知。以依如是如是时处智。如是如是教化众生。是名时处智。回转入智者。菩萨如实知诸众生。于外道法中应如是回转。如实知于佛法中应如是入。如实知如是回转。如实知置安乐中。如实知如是置佛法中不复回转。取外道法。彼处非十二因缘观。是回转观是名回转入智。合智者。随诸众生以何等何等门相合善。知彼彼门依彼彼门合彼彼众生。如信如力如分教化是名合智。得意智者。知众生意。知众生信。知众生求。如是知菩萨入彼修行入信入求入于言语。随顺彼故起可化事。如是起不回转。是名合智。次第智者。知众生业次第觉展转觉。所谓声闻乘中说布施持戒人天果报。说诸欲过。说在家染过。说出家利益。又说苦集灭道。次说须陀洹斯陀含阿那含阿罗汉果。次说不可坏解脱。次说无碍。于辟支佛乘中。说贮积过散用利益。说在家过出家利益。说戏论过静默利益。说聚落过阿兰若利益。说多欲不知足过少欲知足利益。说护诸根门于食知量。初夜后夜精勤修行。说观中念想过乐空闲处。说戒重三昧重般若重。不被讥呵赞叹自利益。赞叹深法非他知。如是等于大乘中次第忧波提舍布施持戒忍辱精进禅定智慧。次说实舍灭慧。是名次第智。又成就修行者。发菩提心。十句愿十句尽。十句远离退转法。修行不退转法。赞叹坚固精进。赞叹坚固心。赞叹安住智。是名菩萨成就修行。又成就修行者。赞叹住地法。赞叹一向毕竟地法。说染退地法。赞叹清净地法。赞叹能进趣地法。赞叹住地中间可得法。说地退法赞叹地果法。赞叹地习气果法。是名菩萨成就修行。又成就修行者说诸地所谓欢喜地离垢地明地焰地难胜地现前地远行地不动地善慧地法云地。是名菩萨成就修行

又成就修行者。以诸菩萨深心摄取胜妙法故。此明何义。菩萨深心摄取妙法。为不断绝三宝。为教化众生行菩提行。为一切种智修善业道。是故菩萨成就修行善业道。菩萨有五种法摄取妙法。何等为五。一者为欲报诸佛恩。二者为自身故令妙法常住。三者供养佛故。四者为欲利益无量众生。五者难得妙法故。彼法复有五种法故。名为摄取妙法。何等为五。一者自如实修行。二者教他如实修行。三者降伏诸魔恶刺。四者舍黑阿波提舍。五者摄取大阿波提舍。诸比丘是名菩萨成就修行

又成就修行者。以所作业无可讥呵故。此明何义。以诸菩萨一切所作住持修行善业道等。皆不可讥呵。是名菩萨成就修行。有五种法。诸业成就不可讥呵。何等为五。一者有所为作一切能成。二者能得大果。三者不违善法。四者随顺清净法。五者德称名闻。是名菩萨成就修行

弥勒菩萨所问经论卷第三弥勒菩萨所问经论卷第四

        后魏天竺三藏菩提流支译

又成就修行者。以起一切种修行清净故。此明何义。以诸菩萨起一切种清净十善业道。是名菩萨成就修行。如十地修多罗中说。是菩萨复深思惟。行十不善业道集因缘故。则堕地狱畜生饿鬼。行十善业道集因缘故。则生人中乃至生有顶处。又是上十善业道与智慧观和合修行其心狭劣故。心厌畏三界故。远离大悲故。从他闻声而通达故。闻声意解成声闻乘。又是上十善清净业道不从他闻故。自正觉故。不能具足大悲方便故。而能通达深因缘法。成辟支佛乘。又是上上十善业道清净具足。其心广大无量故。为诸众生起悲愍故。方便所摄故。善起大愿故。不舍一切众生故。观佛智广大故。菩萨地清净波罗蜜清净入深广行成。又是上上十善业道。一切种清净十力。力故集一切佛法令成就故。是故我应等行十善业道。修行一切种令清净具足故。是名菩萨成就修行

又成就修行者。以为利益一切众生。修行十善业道故。此明何义。以诸菩萨不着自乐。修行十善业道。为利益众生见我能利益众生。以慈悲心非直自利能自利已。复能令他住十善业道。是故菩萨成就修行。以是义故。十地修多罗中说。是故我当先住善法。亦令他人住于善法。是故成就修行。又如十地修多罗中说。是菩萨复于一切众生中。生安隐心柔软心慈心悲心怜愍心利益心守护心我心平等心师心世尊心。又菩萨复作此念。是诸众生堕于邪见。恶意恶心行恶道稠林。我应令彼众生行真实道住正见道如实法中如是。等是故名为成就修行

又成就修行者。修行善业道毕竟无尽故。此明何义。以诸菩萨为不断绝三宝。修行不断绝。常修行善业道无尽。是故名为成就修行。如无尽意修多罗中说。大德舍利弗。诸菩萨摩诃萨尸波罗蜜无尽。以常修行故。何以故。凡夫戒者。在所受生是故有尽。人中十善尽故有尽。欲界诸天福报功德尽故有尽色界诸天以禅无量尽故有尽。无色界天取入诸定尽故有尽。外道仙人所有诸戒退失神通尽故有尽。一切声闻学无学戒入涅槃际尽故有尽。辟支佛戒无大悲心尽故有尽舍利弗。菩萨净戒皆无有尽。何以故于是戒中出一切戒。如种无尽果亦无尽。是菩提种不可尽故。如来戒禁亦无有尽

又成就修行者。远离身见烦恼垢故。此明何义。以诸菩萨十善业道离我见等垢。彼时名为清净业道。是故菩萨成就修行。即彼修多罗中说。清净戒者。所谓不着我相戏论。如是等是故名为成就修行

又成就修行者。以成就一切种清净故。此明何义。以诸菩萨修行善业道一切种一切眷属清净。彼时菩萨名善业道成就修行应知。如彼修多罗中说。无尽意言。唯舍利弗菩萨戒众六十六事清净。修治亦不可尽。何等名为六十六事。一者于他众生不起恼苦。二者于他财物不生窃盗。三者于他妇女终不邪视。四者于诸众生无有欺诳。五者初不两舌于自眷属知止足故。六者无有恶口忍粗犷故。七者无有绮语常善说故。八者于他乐事不贪嫉故。九者初无嗔恚忍恶言故。十者正见不邪贱余道故。十一者深信于佛心不浊故。十二者信顺于法善法法故。十三者信敬于僧尊重圣众故。十四者五体投地志念佛故。十五者五体投地思惟法故。十六者五体投地宗敬僧故。十七者坚持禁戒一切无犯。乃至小禁不放舍故。十八者持不缺戒不依余乘故。十九者持不穿戒离恶处生故。二十者持不荒戒不杂诸结故。二十一者持不污戒专长白法故。二十二者持是深戒随意回向得自在故。二十三者持赞叹戒智者不呵故。二十四者持纯善戒正念知故。二十五者持不呵戒一切戒不散故。二十六者持善坚戒防护诸根故。二十七者持名闻戒诸佛所念故。二十八者持知足戒无不厌故。二十九者持少欲戒断贪惜故。三十者持性净戒身心寂灭故。三十一者持阿兰若戒离愦闹故。三十二者持圣种戒不求他意故。三十三者持威仪戒一切善根得自在故。三十四者持如说戒人无不欢喜故。三十五者持慈心戒护众生故。三十六者持悲心戒能忍诸苦故。三十七者持喜心戒不懈怠故。三十八者持舍心戒离爱恚故。三十九者持自省戒心善分别故。四十者持不求短缺戒护他心故。四十一者持善摄戒善守护故。四十二者持慧施戒教化众生故。四十三者持忍辱戒心无恚碍故。四十四者持精进戒不退还故。四十五者持禅定戒长诸禅支故。四十六者持智慧戒多闻善根无厌足故。四十七者持多闻戒博学坚牢故。四十八者持亲近善知识戒助成菩提故。四十九者持远离恶知识戒舍远离恶道故。五十者持不惜身戒观无常相故。五十一者持不惜命戒勤行善根故。五十二者持不悔戒心清净故。五十三者持不邪命戒心行清净故。五十四者持不焦戒毕竟清净故。五十五者持不烧戒修善行业故。五十六者持无慢戒心下不憍故。五十七者持不掉戒远离诸欲故。五十八者持不高戒心平直故。五十九者持柔和戒心无抵突故。六十者持调伏戒无恼害故。六十一者持寂灭戒心无垢秽故。六十二者持顺语戒如说行故。六十三者持化众生戒不离摄法故。六十四者持护正法戒不违如实故。六十五者持如颂成就戒于诸众生心平等故。六十六者持亲近佛戒。入佛三昧具足一切诸佛法故。是故名为成就修行

又成就修行者。以成不共果故。此明何义。以诸菩萨成就修行十善业道摄取菩提心。以是义故得菩提时成不共果。是故名为成就修行应知。如圣者娑伽罗龙王经中说。龙王。离杀生人得十种清净法。远离杀生。一切善根回向阿耨多罗三藐三菩提。彼人得菩提时心自在故。寿命无量如是等

问曰。应说业道义。云何业道义。答曰次说。云何说。以造作故名为业相。即业名道能趣地狱故名业道。又身口七业即自体相名为业道。余三者意相应心。又即彼业能作道故名业道。此明何义。唯心是业彼心七业共起名道。余三共相应名为业道。问曰。若即业名道。皆悉能趣地狱等者。何故余三非是业道。答曰。如彼七业此三能作彼根本故。以相应故。不能如彼业故。不名业道。问曰。一切美味饮酒食肉卷手掴打一切戏笑。如是等恶行。一切礼拜供养恭敬远离饮酒等。如是等善行。何故不说以为业道。答曰。远离饮酒等。唯是心业能起七业。非身口业。是故非业道。若作与心相应亦是业道

问曰。若即彼业能作道名为业道。如是相解业道者。一切法于心皆应名业道。若尔何故但说十种业道。不说无量业道。答曰。以胜重故。此明何义。以诸恶行及善行中十业道重。余非重故不说无量。问曰。此义不然。何以故。以业不定故。此明何义。或有近远方便为重正业为轻。是故不应但说十业以为业道。不说无量。答曰不然。何以故。十业多重近远方便多轻。又世间众生多畏十业。不畏近远方便。又十业道能作深重逼恼。余者不能。是故汝说业不定者是义已答。又汝向言。一切法于心皆应名业道者。此义不然。何以故。七业一向极重。意三亦轻亦重。饮酒等不尔。以是义故。但说彼十名为业道。不说余者名为业道。问曰。远离杀生者。杀生等相应说。答曰。杀生有八种。一者故心二者他三者定不定众生相四者疑心五者起舍命方便六者作七者不作相八者无作相。是等名为杀生身业。身口意业名为杀生。故心者。问曰。有人言不作心杀成杀生罪。譬如触火。此明何义。如火能烧。若故心触不故心触皆能烧人。杀生亦尔。若故心杀不故心杀。悉皆应得杀生罪报。答曰不然。何以故。若无心杀得罪报者。则阿罗汉不得涅槃。此明何义。以阿罗汉断世间因。有不作心而杀众生。如是亦应还生世间。而实不然。以是义故。不故心杀不得罪报。又言如火者。此义不然。何以故。以恶业中无恶心隔故。所明何义。犹如彼火。薪炭等隔触而不烧。如是彼恶业中无恶心隔。虽复杀生不能与报。是故火喻义不相应。问曰。云何死者受苦。而杀生者不得罪报。答曰。以心不坏故。又此义不然。何以故。离逼恼众生有罪离利益众生有福。如断善根慈悲无诤灭尽定等。得罪得福

问曰。何故名他。答曰。非自命故。问曰。以何义故自断命者不得罪报。答曰。以无可杀杀者故。此明何义。若有他人是可杀者。能杀生人得杀生罪。以自杀者无可杀境即更无杀者。以无杀者故。自断命不得恶报。又过去阴不续杀生等阴。是故自杀不得杀罪。问曰。自杀身者。起于杀心断人命根。破坏五阴舍离人趣杀业成就。何故不得杀生罪报。答曰。若尔阿罗汉人应得杀罪。此明何义。以死相罗汉自害其身断己命故。彼阿罗汉亦应获得断命之罪。而彼无罪。何以故。以离嗔心等故。是故自杀不得杀罪

又定不定众生相者。定众生相不定众生相。彼众生相名为定不定众生相。又定众生相者。有百千人作心于中定杀某人。是名为定。若杀彼人得成杀罪。若杀余人不得杀罪。不定者。以舍一切故随杀得罪。以彼处不离众生相故。疑者。疑心杀生亦得杀罪。以彼是众生既舍众生。其心虽疑以舍慈悲心杀众生故得杀生罪。起舍命方便者。此明何义。若杀者于彼事中起不善心。必欲断彼众生命根。非慈悲心无护罪心。舍众生心作杀方便是名为起

又作不作相无作相者。作者所作事。不作者所不作事。彼作事共起。虽作业灭而善无记法相续不断。问曰。云何不作而名为业。答曰。以能与作事作因与作果事作因。此明何义。处处亦有因中。说果果中说因。如如来经中说。可见可触名无作色。以作不可见不可触而作名为可见可触。以彼不作说名可见可触。如是彼处若身所依身事刀杖等杀生。名为作不作。得名身业。又如自在人口敕令杀仙人。嗔心欲杀众生。受敕使者。依自在人口敕而杀信仙夜叉。依仙嗔心而杀众生。彼自在人及仙人等作杀生因。使人夜叉身业成时。彼自在人及以仙人。俱得成就不作身业。又如受戒人。临受戒时身动口说。及受戒时默然而住。身口不动。师羯磨已。彼人成就无作身业。此亦如是又如口业事。而口不言但动头眴目奋眉举手如是等相表前事者。亦得成就不作口业。又应身作业。而身不动口说种种身业方便。彼事成时亦得成就不作身业。有人言。口意亦得成就杀生。此杀生业是口意业非是身业。虽有此言是义不然。何以故。若即口说心念之时成杀生者。可是口业可是意业。此明何义。若口与意是杀业体。自在人敕杀某众生。仙人心念杀某众生。即敕念时彼命应断。而此事不然。以彼使人信仙夜叉身业成时成杀生事。若不如是。彼自在人口言杀时。及彼仙人起嗔心时。应即成杀而实不成。又复有过。彼自在人口敕杀生使人未杀。彼自在人得证见道。受敕使者后方杀生。若口敕杀已成杀者。证见道已然后杀生。而此义不然。以得远离彼杀生因破戒等恶心。是故不以口意二业为杀生体。何以故。以业无差别故。此明何义。以善不善无记等业相各异故。以无差别相。如是身口意业则无差别。而远近方便身口意等成杀生业。此则不遮

问曰。口言杀者。为毕竟成为不成耶。答曰。不成。何以故。以过时等故。此明何义。以何等时以何等方便以何等处。彼人杀时过自在人说时处等。杀者得罪教者无罪。身业者依身作业名为身业。此明何义。依身作业随身所作名为身业

问曰。无命可杀。云何断命得杀生罪。答曰。虽无实命断和合体名为杀生。如断树林灭灯炷等。若有神我神我是常无杀生义。问曰。害何等阴名之为杀。为害过去为害未来为害现在。若害过去过去已灭。若害未来未来未到。若害现在刹那不住。答曰。有人说言。住现在世坏未来世和合阴体。复有人言。坏未来现在。此明何义。以现在阴中刀杖能到能作害事。复有人言。五阴自灭非因缘灭。复有人言。现在阴中唯坏色阴。以刀杖等能割能触。余四阴者不可割触故。复有人言。杀害五阴。自余四阴虽不可触而依色阴住。色阴坏故彼亦随坏。如破瓶故水乳亦失。复有人言。唯害无记阴。以无记阴中刀杖能触。以无触阴有其二种一切业有三种。如向所说应知。问曰。如来修多罗中说有二种业。一者起业。二者作业。此二种业广说有三。谓身口意业。此三种业云何差别。为从依说。为从体说。为从起说。若从依说即是一业。以一切业依止身故。若从体说即是一业。以一切业唯口业故。若从起说即是一业。以一切业从心起故。答曰。依三次第有三种业。此明何义。由心思惟即是心业。依彼心业起身口业。以依心故起身口业。如是次第应知。彼作无作应知。彼身口业差别应知。又身业作者依身威仪。依止身作彼彼形相。是名身作业

问曰。以身去来动转名为身业。不去不来不名为业。答曰。若言去来是身业者。此事不然。何以故。一切有为法刹那不住故。刹那不住者随何处灭。不去不来云何而言去来动转。名为身业。问曰。此义不然。何以故。若一切法刹那不住。可如是说。亦见有法刹那间住非是不住。云何而言无去无来。答曰。此义不然。何以故。以有为法毕竟不住。此明何义。以彼一切有为诸法。无因无缘自然而灭故。此复何义。以可作法是有因缘而灭。法者即是无物。若无物者彼法不作。以有为法无因无缘自然灭故。若法即生时不灭后亦不应灭。若不灭者应是定实。若是定实不应变异。若如是者。不应从彼灭因缘灭。问曰。我见有法从因缘灭。如薪等法从彼火等因缘而灭。一切量中现见量胜。以是义故。一切法灭从于因缘。答曰。云何知薪等法依于火等因缘而灭。我言无因自然而灭。此义应思。为因火等薪等法灭故不见耶。为无因缘自然而灭故不见耶。此义云何。本相续因缘灭余更不生。是故不见。非因缘灭。如风灭灯手灭铃声。如是等知是比智知。答曰。已说非可作事故。此明何义。若有一法从因缘灭。应一切法皆因缘灭。不应有法非因缘灭。犹如生法一切皆悉从因缘生。无有法生不从因缘。如心声焰非因缘灭。以彼不待因缘灭故。问曰。此义不然。何以故。以后心生前心灭。后声生前声灭。以彼先法待后法故。是故得知从因缘灭。答曰。此义不然。何以故。以彼心声不相待故。此明何义。以有疑知决定知故。二法不俱苦乐贪恚等皆亦如是。又以前心声疾后心声迟。云何不疾心声而能害彼疾心疾声。是故法灭不从因缘。问曰。虽灯与焰念念不住。以无因住而有灭法及灭非法。依彼灭法灭于灯焰。是故应依因缘而灭。答曰。此义不然。何以故。以无物法云何能作灭因。又生因灭法非法刹那不住。刹那心刹那心中终不能作生因灭因。如是一切有为诸法不从因灭应知。又。答若依火等能作薪等灭因。如是生因即是灭因。此明何义。依何等火焰生何等色。即彼火焰能作熟胜熟胜灭因。以是故即生因是灭因。更无异因。而此义不如是。云何此一法能令法生能令法灭。又异异火焰中如是因差别虚妄分别。如因灰汁苦酒雪日地水谷米能生熟异熟异等色彼处云何分别。问曰。不然。何以故。以火煎水水由火尽火为灭因。答曰。如向解释。云何得知水因火灭非自然灭。问曰。若尔火何所作。答曰。火界增上依彼火力水力渐微。乃至后时水相续体断绝不起。是火所作非火所灭。是故一切有为之法自然而灭。无因缘灭。以彼灭法刹那不住是故即灭。如是成就诸法刹那不住刹那不住。是故此法不彼处去。问曰。我于余处犹见此法。若法不去。云何而得于余处见于余处识。答曰。如草火焰是故不去。是故身威仪名身作法。此义已成非谓异身别有实法。如一方生色名为长色。依彼长色更见余色名为短色。依四方故见四方色。依圆物故名为圆色。如是长短方圆高下诸色。譬如挑火。一厢直去不断不绝。相续而见名为长火。周匝四厢不断不绝名为圆火。随种种转见种种火。如是离火更无别有实形相法。若离火外有形相法。应为二根所伺。眼根见长身根触短。以一色入非二根见。如触法长短等。如是色中应知。触法唯心非是现根可捉可知。如见火色触中生念知。如嗅华香色中生念。此法应如是。依余法念余法而无一触法。于威仪中实有依触法得余法。是故无实身威仪法。问曰。此义不然。何以故。若于闇夜远见土墙等色。或长或短此应是实。答曰。但见色不了虚妄分别长短等色。如不异蚁子等见行见围。此亦如是。异身威仪更无实法。唯身威仪名为作法。不离身外别有作法。向说心思惟者。心中分别我如是如是作。能生身口业名为心业。若身所作名为身业。若口所作名为口业。不异三业别有实法

问曰。异身口业实有别法。何以故。以有三种无垢色。增长不作业道等故。此明何义。以如来修多罗中说色摄三种。何者为三。一者有色可见可碍。二者有色不可见可碍。三者有色不可见不可碍。无垢色者。谓无漏色。何者无漏色。无漏色者。谓无漏法。何者无漏法。谓于过去未来现在色中不生嗔爱。乃至识中不生嗔爱。以是义故名无漏法。若如是者。离无作法何处有色不可见不可碍。是无漏故。知应有无作法离身口意业增长者。如来修多罗中说。有信者。善男子善女人修行七种功德。行住睡寤等日夜常生功德增长功德。若离身口业更无无作。云何异心法而得增长。是故当知。离身口业有无作法。又自不作业使他作业。若无无作此云何成。又复非但使人作业即得名为成就业道。以彼业未成。复更有过。虽作业未有实体成就。以如来经中说。诸比丘外入十一入不摄不可见不可碍。而不说非色。此为何义故如是说。以如来见法入中摄无作色故如是说。又复作难。若无无作法亦应无八圣道。以定中无正语正业及以正命。当知决定有无作法。又复有难。若无无作法。离波罗提木叉亦应无无作戒。以受戒竟后即无故。以在睡眠及颠狂等诸失心者。亦名比丘比丘尼故。当知决定有无作法。复有修多罗中如来说言离破戒桥梁。若无无作法。云何说言离破戒桥梁。是故当知有无作法

答曰。此难极繁。虽有种种众多言说而义皆不然。何以故。汝向虽引如来修多罗中说色三种。而汝不解如来经意。此义云何。一切圣人禅定力。见三昧境界色。依三昧力而生彼色。彼色非是眼根境界故不可见。余一切物所不能障故不可碍。问曰。若言非是眼根境界不可障碍。云何名色。答曰。汝离心意有无作色。云何得名为无作色。又答。此色乃是无漏境界圣智三昧色。不同世间有漏之色。又言无漏色者。即是依彼三昧禅定力色名为无垢。圣人于无漏三昧中说无漏法。又有人言。阿罗汉色及以外色名为无漏。以离有漏法故。我不受此义。又增长功德者。此义云何。法如是故。如是如是施主施物数数受用。如是如是数数受用者。依受用人功德力故。虽施主异心而依本心念。修相续体细细转胜。以转胜故。于未来世而得成就多福德果。依此义故。如来说言多生功德增长功德。非离心离色有无作法。问曰。云何异身心依异身心。异身心中相续转细增长福德。答曰。云何异身心依异身心。异身心中有无作法。又答。而此义不然。我依于心身业口业有善恶功德。依本心作不失本心有相续体癫狂睡等。常得增长不作者已自不作使他人作。云何而得成于业道。此明何义。以依使者于他众生起于害法。是故使者细相续体转转生粗。以是义故未来世中能生多过。亦复不但使人作恶。自作恶者作恶事竟。未来世中亦生多过。是故于彼未来身体相续转生名为业道。以于因中明果义故。离破戒桥梁者。汝今为有狂癫病耶。而作是说。若狂癫者速觅陈酥服令除愈。不应种种非法言说

问曰。何故增我有无作法。而汝自立从心起于细相续体有增长法。答曰。我不增汝有无作法。而汝所说法无如是义。此明何义。以依心故身口行事。行事讫竟成就业道。汝所有法离心身口。于佛法中无如是义。是尼干子微尘世性时方等法离心而有。无心善恶如是等法智者不受。是故不立离于色心。身心之外有无作法

弥勒菩萨所问经论卷第四弥勒菩萨所问经论卷第五

        后魏天竺三藏菩提流支译

远离偷盗者。偷盗有九种。一者他护。二者彼想。三者疑心四者知不随。五者欲夺。六者知他物起我心。七者作。八者不作相。九者无作相。是等名为偷盗身业。他护者。此明取他护物。彼想者。若不生自想。不言是我物。名为彼想。疑心者。若心有疑。为是我物为是他物。而彼物他物。知不随者。知他物生心他随我想。欲夺者。起损害心。知他物起我心者。若不异见若闇地取。若疾疾取若取余物。若取他物取自物想。作不作相无作相者。如前杀生中说。成业道不成业道。随义相应解释应知。远离邪淫者。邪淫有八种。一者护女人。二者彼想。三者疑心。四者道非道。五者不护。六者非时。七者作。八者无作相。是等名为邪淫身业。护女人者。所谓父护母护如是等。彼想者。若知彼女是父母等所护女想。非不护想。疑心者。若生疑心为自女为他女。为父母护为不护为我女为他女。而彼女人为父母护。于彼父母所护等女一一邪淫。道非道者。道者所有道。非道者谓非道。彼护女非道非时者亦名邪淫。又非护者。自护女不护女彼非道邪淫。又非护女者。一切不护女等邪淫。作无作相者。如前杀生中说应知。不作相者。邪淫中无如是不作法。以要自作成故。如病人服药。因服药故远离于病生于无病。病者得差。药师病不差。远离妄语者。妄语有七种。一者见等事。二者颠倒非颠倒事。三者疑心。四者起覆藏想。五者作。六者不作相。七者无作相。是等名为妄语口业。见等事者。谓见闻觉知于颠倒非颠倒事中。又颠倒事者。如闻如彼事。非颠倒者。谓如彼事。疑心者生疑。为如是为不如是。为一向如是为一向不如是。起覆藏想者。覆藏实事。异相事中住异相说。作不作相无作相者。如前杀生中说。有人言。身相及布萨中默然而住。皆有妄语不作相。成身意业以为妄语。虽有此言而义不如是。何以故。以业异相故。异相者以身口意业异相故。是故口业非身意业体。而依本口业世间用事。而口业事身业示现。名为不作口业而口业得名。若布萨中比丘不说而成口业。何以故。以依口业立制故。以先受是语。我于佛法中不作如是法作如是法。而彼人先有要心而后时不说。默然而住。彼人退本要心所受。是故得成妄语口业

远离两舌者。两舌有七种。一者起不善意。二者实虚妄。三者破坏心。四者先破不和合意。五者作。六者不作相。七者无作相。是等名为两舌口业。不善意者。不善业烦恼心相应。实虚妄者。知他他心坏若实若妄语坏他心破他心。以先破者无和合心。以起恶意起自身不善法。是名两舌。作不作相无作相者。如前杀生中说。有一人言。破坏无作业两舌中。无如为破僧两舌。而说于如来边不能破坏。是则不成破僧恶业。如是不破坏不两舌业远离恶口者。恶口有七种。一者依不善意。二者起恼乱心。三者依乱心。四者恶言说他。五者作。六者不作相。七者无作相。是等名为恶口口业。依不善意者。口说恶言令他闻者能生苦恼。起恼乱心者。但起恼乱心不起安隐心。若为安隐心。虽恶口说无恼乱罪。依乱心者。起如是心随他闻时乱。以不乱作恶心说。作不作相无作相者。如前杀生中说

远离绮语者。绮语有七种。一者依不善意。二者无义。三者非时。四者恶法相应。五者作。六者不作相。七者无作相。遍一切恶口。是等名为绮语口业。依不善意者。依欲界修道烦恼心相应。说名为绮语。无义者。离实义故。非时者。语虽有义而非时说。亦成绮语。又有时说。于大众中为自在人说亦成绮语。恶法相应者。谓一切戏话非法歌舞等。一切不与善法相应者皆是绮语。作不作相无作相者。如前杀生中说

贪者为爱心所缠。欲得他人钱财。为爱心贪心之所坚缚求他人自在。是名贪相应知。嗔者于他众生起于恶心。欲打害等。大慈悲心相违是名为嗔。众生者离非众生事故。他者离自身事故。言他众生嗔者。于他众生起于恶心。害者无慈心。打者无悲心。以欲断命故。又打者。以鞭杖土石等能生苦恼皆名为打。慈悲相违者。欲断他命慈心相违。打者悲心相违。如是等是名嗔相。应知

邪见者。于施等中见无施等。此明何义。于施中见无施。于与中见无与。于舍中见无舍。如是等见名为邪见。问曰。云何如是名为邪见。又施与舍三句有何差别。答曰。施者正心施与福田非福田。与者亦正心施与福田非福田。舍者但正心施与福田。又言。见无施者。见所施不清净故。又言见无与者。谤无施主功德故。又言见无舍者。谤无受者功德故。如是不正见皆悭人相。以见富人悭惜贫者能舍。此人起如是心。若实有施者。悭人不应富。何以故。以其先世习悭来久故。复生疑心。此能施主不应贫穷。何以故。以其先世习施来久故。彼人虽生如是邪见。而义不如是。问曰。若尔此义云何。答曰。彼人过去虽久习悭。而忽值遇清净福田。于彼田中少行布施。是故获得今身富报。以习成性悭犹不舍。贫能施者。此复云何。彼人过去于非福田无信心故。不至心故。为名称故。为求事故。求尊重故。彼人能施。以是义故不得富报。习施来故今犹能舍。无善行恶行者。此依自身见常无常起于过相。无善恶行业果报者。彼人见有行善者受苦。行恶者受乐。是故彼人生如是心。苦乐果报自然而有非从因缘。无此世他世者。彼人心见即此世灭。以不见更生故。此人起心言无后世。彼人复生是心。实无有我。若有我者。世间则无化生众生。以不观察十二因缘故。复生疑心。一切男女为自乐故而行淫欲。不为生我。我依自业于此中生。如湿生众生依湿地生。湿地非是众生父母我亦如是。又见罗汉求冷求热求饮食等。便谓世间无阿罗汉。何以故。以阿罗汉有爱心故。彼人自无修行等力。是故不能断诸烦恼。便谓世间无阿罗汉

问曰。应说离杀生义。以何义故得名为离。为有可杀事故得名为离。为无可杀事故而名为离。若有可杀事故名为离者。离义不成。何以故。以作习果成故。云何而言离于杀生。若无可杀事故名为离者。则无离杀生福。如无兔角可以割截。则亦无有离割截义。又言离杀生者。名为不杀生事。不舍摄众生事。答曰。以受不杀生法。依本受心有力故。不作彼杀生恶事。以受离杀生法。以起善法是故离杀生。不离摄取众生

问曰。为于可杀众生边离杀生。为于不可杀众生边离杀生。为于可杀不可杀众生边离杀生。答曰。于可杀不可杀众生边离杀生。何以故。以起恶心不休息故。是故名为离于杀生。此明何义。若于可杀众生边离杀生。不可杀众生边不离杀生者。离义不成。此复何义。以离可杀众生边罪。成不可杀众生边福。以是义故。于可杀众生边于不可杀众生边成离杀生福。若不如是不得言离杀生事。不成舍杀生事。不受杀生事。应得离杀生事。若不如是。不受应是离。受应是不离。问曰。要依现在阴界入边得离杀生。非过去未来。答曰。若如向问答者。不成离杀生义

问曰。应说离杀生等有几种离。答曰。有三种离。一者成二者依三者起。依者成者。杀生恶口依众生以嗔心成。偷盗邪淫依资生以贪心成。妄语两舌绮语依名字以贪心成。邪见依色以痴心成

起者十不善业道一切皆从贪嗔痴起。依贪心故起杀生者。贪心杀生或为皮肉筋骨齿角钱财等故。断众生命。或为自身为所爱者。一一具足三事。依嗔心故起杀生者。以嗔心故杀害怨家及杀怨所爱人。是名依嗔心故起于杀生。依痴心故起杀生者。如有人言杀蛇蝎等虽杀无罪。何以故。以生众生诸苦恼故。又有人言。若杀獐鹿水牛羊等。无有罪报。何以故。以是众生业所感故。又波罗斯等言。杀老父母及重病者则无罪报。如是等名依痴心故起于杀生。依贪心故起偷盗者。以须如是如是物故。取如是如是物。或为自身或为他身或为饮食。是名依贪心故起于偷盗。依嗔心故起偷盗者。于嗔人边及嗔人所爱偷盗彼物。是名依嗔心故起于偷盗。依痴心故起偷盗者。如婆罗门言。一切大地诸所有物唯是我有。何以故。以彼国王先施我故。以我无力故为余姓夺我受用。是故我取即是自物不名偷盗。而彼痴人生是心故有是偷盗。是名依痴心故起于偷盗。依贪心故起邪淫者。谓于众生起贪染心不如实修行。是名依贪心故起于邪淫。依嗔心故起邪淫者。于他守护若自护若他护资生。依嗔心故起不如实修行。如怨家妻边及怨所爱人妻边。是名依嗔心故起于邪淫。依痴心故起邪淫者。如有人言。譬如碓臼熟华熟果饮食河水及道路等女人。如是邪淫无罪。又如波罗斯等邪淫母等。是名依痴心故起于邪淫。妄语贪心生者。依贪心起嗔心生者。依嗔心起痴心生者。依痴心起如是两舌恶口绮语皆亦如是。应知贪依贪心起者。依贪结生次第二心。现前。如是名为依贪心起。依嗔结生名为依嗔心起。依痴结生名为依痴心起。如贪嗔与邪见。皆亦如是应知

问曰。何故不说作不作相无作相。决定何业中有何业中无。答曰。唯除邪淫。余六业道中悉皆不定。此义云何。若自作者成就作业及无作业。若使他作唯有不作不得有作。于邪淫中决定有作。不得有不作何以故。以此邪淫毕竟自作。无使他作。是故经言。颇有非身作业。而得成就杀生罪不。答言。有口使人作成就杀罪。又问颇有非口业作。而得成就妄语罪不。答言有。以身业作。成就口业妄语之罪。又问。颇有非身业作非口业作。而得成就身口业不。答言有。以依仙人嗔心故。以唯欲界色身善业道中毕竟有作及以无作。禅无漏戒无无。作戒。何以故。以依心故。中间禅不定。若深厚心毕竟恭敬心作身口业。成就作业及无作业。若深厚结使心起身口业亦成就作业及无作业。若非深厚心。非毕竟恭敬心造身口业。唯有作业无无作业。若非深厚结使心发身口业。亦唯有作业无无作业。而方便作业心还悔者。唯有作业无无作业。问曰。于业道中何者是前眷属。何者。是后眷属答曰。若起杀生方便。如屠儿捉羊。或以物买将诣屠所。始下一刀或二三刀。羊命未断所有恶业名前眷属。随下何刀断其命根。即彼念时所有作业及无作业。是等皆名根本业道。次后所作身行作业。是名杀生后眷属业。乃至绮语皆亦如是应知。自余贪嗔邪见等中无前眷属。以初起心即时成就根本业道故。又身口意十不善业道。一切皆有前后眷属。此义云何。如人起心欲断此众生命因。复更断余众生命。如欲祭天杀害众生。即夺他物欲杀彼人复淫其妻。生如是心还使彼妻自杀夫主。复以种种斗乱言说破彼亲属。无时非实于彼物中生于贪心。即于彼人复生嗔心。为杀彼人故生如是邪见。增长邪见以断彼命。复欲杀其妻男女等。如是次第具足十种不善业道。如是等业名前眷属。一切十不善业道皆亦如是应知。又离善业道。非方便修行善业道。是方便以远离根本故。及远离方便故。言方便者。如彼沙弥欲受大戒。将诣戒场礼众僧足。即请和上受持三衣。始作一白作第二白。如是悉皆名前眷属。从第三白至羯磨竟所起作业。及彼念时起无作业。是等皆名根本业道。次说四依乃至不舍所受善行。身口作业及无作业。如是悉皆名后眷属

问曰。应说不善业道。于五道中何道具足何道不具足。何道中多何道中少。答曰。地狱有五不善业道。两舌绮语贪嗔邪见。此义云何。不杀害他故无杀生。无他护心是故无盗。无护女人故无邪淫。以无正心故无妄语。以常无有正念相故。无破坏心故无恶口。以常破坏故。依苦恼逼故。有两舌。有非时说故有绮语。贪嗔邪见以毕竟有故名为有。非是现有。以是义故。一处说有一处说无。如北郁单越无前六种有后四种。以命定故无有杀生。以无守护故无偷盗。无护女人故无邪淫。彼人欲受淫。欲乐时即捉女人将至树下。若树曲枝覆彼人者则行淫。欲受淫欲乐若树不覆彼人。惭愧即放而去。无诳他心故无妄语。以常定心故无两舌。常柔软语故无恶口。以有歌舞故有绮语。余意业者以毕竟有非是现有。又除郁单越余三天下受十业道。北郁单越亦离不善业道。畜生饿鬼欲界天中亦离受十业道。欲界中天离无受戒不善业道。虽天不杀天而天亦杀余道众生。又有人言。天中亦有截手足等即时还生。若断其头若中间断绝即死不生。亦有杀他盗他物等不善业道。色无色天中无不善业道

问曰。不善业道于诸道中各有几种。答曰。地狱北郁单越无贪无嗔亦无邪见。以毕竟有非是现有。余三天下及欲界天离受法有受法。又欲界天有善无漏受法应知。畜生饿鬼亦无受法。色界天中有受法。现前受善法摄取故。又彼处所有圣人生者。有依无漏善业道。无色界中唯有心业道。以成就业非是现有。色界天中虽复成就非是现有。彼处所有圣人生者一切现有。以依无漏持戒力故

问曰。应说十不善业道果及随顺因。答曰。有三种果。一果报果。二习气果。三增上果。一一业道皆有三种。此义云何。具足十不善业道下中上生地狱中。是名果报果。习气果者。从地狱退生于人中。依杀生故有断命果。依偷盗故无资生果。依邪淫故不能护妻。依妄语故有他谤果。依两舌故眷属破坏。依恶口故不闻好声。依绮语故为人不信。依本贪故贪心增上。依本嗔故嗔心增上。依邪见故痴心增上。如是一切名习气果。增上果者。依彼十种不善业道。一切外物无有气势。所谓土地高下雀鼠雹棘尘土臭气多有蛇蝎。少谷细谷少果细果及以苦果。如是一切名增上果。复有相似果。杀者故与所害众生种种诸苦。因彼苦故生地狱中受种种苦。以断他命后生人中。得短命报断他暖触。是故一切外物资生无有气量。如是一切十业道中。随义相应解释应知。劫夺他物邪淫他妻。虽不生他重逼恼苦而破坏心。是故受罪。虽不破坏不嗔不恶口。而由恶心是故得罪

问曰。故心起作一切恶行为决定成就不善恶业。决定受彼恶道苦果。为不决定成就恶业。不决定受恶道苦果。若诸恶业决定受者。恶道罪业不可得过。此明何义。以毕竟成就恶道罪业堕恶道等。除五逆业。从无始世来所习作业取恶道罪。毕竟定者一切恶道不可得过。又空修梵行。又与修多罗相违。如如来修多罗中说。有人修习不善业道。所得罪报应地狱受。彼人即于现身中受。如是等若彼五逆罪等果报。毕竟在于地狱中受。何故说言恶道罪业可得回转。云何而言恶道等罪现身中受。又复有过。若地狱等恶道罪业现身中受。若如是者因果杂乱。何以故。以时果轻重悉不定故

答曰。有人言。现身中受地狱罪者。此人见实谛故。于现身中受少罪果。而此义不然。何以故。以业无自在故。此明何义。一切所作罪业福业无自在力。而随何等因缘和合。依彼因缘应现身中受果罪业后身中受。应后身受果报罪业现在身受。而有胜义。若业应受乐果报者则受乐果。应受苦果则受苦果。是以依不定业故。如是说。又依不定相似业故。作如是说。亦非依定果。何以故。以无得解脱果故。以阿罗汉受波罗提木叉戒禅定戒无漏戒业。乃至命未尽来常有不断波罗提木叉戒等。若有果报则不得解脱。是故现受不定业果

问曰。若如是者诸业不定。亦与修多罗相违。何以故。以如来修多罗中说故。作习业不受果报无有是处。而彼习业若现身中若后身中毕竟定受。答曰。此义不然。何以故。以诸因缘未和合故未受果报。此义云何习作诸业虽实能受现身果报。而现不受。何以故。以诸因缘未和合故犹如种子。此明何义。犹如种子依于地等因缘和合能生芽等。此亦如是。依于识住因缘和合业不净识种子能生名色芽等。此明何义。若依如实修行随顺如实般若。如实知有为行断诸烦恼时。依圣道力故。修集诸功德能生善根芽。彼时虽有受后生业以其无有烦恼伴侣。是故不能受后生果。以断烦恼故。虽复不受后身果报。而犹依彼不善业道。于现身中少受习果故。不毕竟。恶道中受。如修多罗中如来说言。应如是受。应如是受者。此明何义。虽少受喜乐虽少受忧恼。而善不善业即时受尽乃至少受头痛等苦。此受少罪彼相似果。向言修多罗相违者。此义不然。何以故。以依不定果报依未治所治业。修多罗中作如是说。若毕竟定心作业不受果报无有是处。此明何义。阿罗汉人断生后报罪福等业。于现身中受报因缘不复和合。若如是者。彼阿罗汉依此业道可不入涅槃。以是义故知。汝不解如来所说修多罗意

问曰。应说清净不清净戒。云何清净戒。云何不清净戒。答曰。有同戒清净。声闻辟支佛菩萨同修五种清净戒法应知。何等为五。一者根本清净。二者眷属清净。三者觉观不乱。四者摄取念。五者回向涅槃。根本清净者。远离根本业道罪故。眷属清净者。远离杀生等方便行故。觉观不乱者。远离欲害嗔恚等觉所有恶行故。摄取念者。摄取念佛念法念僧等诸念故。回向涅槃者。为涅槃护戒不为世间资生故。此是少分同戒。诸菩萨摩诃萨胜戒者。依初发菩提不损害心。所起戒聚乃至八地无量时修一切戒聚。以利益他心回向萨婆若智。离一切习气得大涅槃。是诸菩萨摩诃萨一切戒善清净应知。自余依师教持戒等皆不清净

问曰。持戒有几种。答曰。略说则有一种持戒。依不损害心不颠倒心起身口业。又有二种。一者受戒二者法戒。又有三种。谓学无学非学非无学。又有四种。一者受波罗提木叉戒。二者禅定戒。三者无漏戒。四者远离烦恼戒。波罗提木叉戒者。所谓受世教戒。如七众所受戒。禅定戒者。谓有漏所转戒。无漏所转戒。无漏戒者。谓学无学戒。远离烦恼戒者。所谓依厌欲事中间道所转。彼戒破戒及彼能起破戒因缘烦恼对治。又言有漏者。依禅定戒说。言无漏者。依无漏定戒说。又有五种。欲界色界无色界作不作无漏不作。复有六种不贪等。作戒三种差别。无作三种差别。复有七种。谓离杀生乃至绮语即此七种依作无作差别。有十四种。即此七种依不贪等起有二十一种。即此七种依作无作差别有四十种。依刹那展转差别有无量种

问曰。何者是戒果。答曰。有漏定戒无漏定戒。彼属界依属界。即是相应果应知。无漏戒者。以离烦恼有二种果。诸菩萨摩诃萨为萨婆若持戒。取佛菩提果。离杀生等十善业道胜果。诸修多罗中如来广说。如彼一切修多罗中应知。如娑伽罗龙王所问经中。如来说言。龙王离杀善男子善女人。获得十种离烦恼热清凉之法。何等为十。所谓一者施与。一切众生无畏二者安住大慈念中。三者断诸烦恼过患习气。四者取无病果。五者种长寿种子。六者诸非人等常所守护。七者睡寤安隐。八者不见恶梦离怨恨心。九者不畏一切外道。十者退生天中。是名十种离烦恼热清凉之法。龙王若不杀善根回向阿耨多罗三藐三菩提者。彼人得菩提时心得自在。是故寿命无量。乃至正见道中皆应广说。如一切修多罗中应知

弥勒菩萨所问经论卷第五弥勒菩萨所问经论卷第六

        后魏天竺三藏菩提流支译

成就舍心者。问曰。以何义故。说持戒后次说成就舍心。答曰。以见作他利益力故。此明何义。以菩萨持戒依持戒故得生善道。虽成就舍心而无具足资生。若尔不能作他利益。又复不能成就诸余一切功德。何以故。为他利益摄取世间。而彼菩萨利益他时离舍财物。不能成就。以是义故。依他利益说持戒。后次说成就舍心。又复有义。持戒舍心迭共相依互为利益。以彼持戒能益舍心。舍心亦能利益持戒。以是义故。次持戒后说成就舍心。又离持戒故生恶道中。舍心不能受于果报。如相应果则不能得具足现前。而持戒人生善道中。舍心则能受于果报。如相应果具足现前。以是义故。持戒于舍能作利益。舍心亦能利益持戒。以持戒人生善道处。无资生故。则为贫穷苦恼所逼。虽生善道即名恶道。成就舍心生善道处。于作自利及他利因。是故施能利益持戒。又以修行次第义故。此明何义。菩萨为欲利益众生修行义故。如是次第欲自取勘等口言功德先住持戒。次后依于不损害心起大慈悲心。为他作利益法施资生施。如彼众生可化摄取。又施等法能庄严戒故。此明何义。菩萨摩诃萨以施等法庄严持戒故。能成就种种胜果。如如来娑伽罗龙王所问经中说。龙王。菩萨摩诃萨离杀生故。能起布施则得成就大富资生不可破坏得长寿命。行菩萨行过诸世间所恼恶事。如是等龙王。十善业道亦复如是。布施庄严十善业道。成就大利益。持戒庄严十善业道。成就一切佛法愿。忍辱庄严十善业道。成就三十二相八十种好佛妙音声。精进庄严十善业道。成就佛法降伏一切诸魔怨敌。思惟庄严十善业道。成就闻慧思慧修慧坚固清净。般若庄严十善业道。成就离诸邪见。慈心庄严十善业道。成就不害一切众生心。悲心庄严十善业道。成就不舍一切众生心。喜心庄严十善业道。成就修行佛法不怯弱心。舍心庄严十善业道。成就远离爱心憎心。四摄庄严十善业道。成就教化一切众生心。问曰。舍义云何。答曰。对治贪着五阴及以资生。起慈悲心为摄受彼利益他行。不着因果等法。住持修行名为舍义。问曰。应说舍成就义。云何菩萨舍成就。答曰。菩萨远离自取乐行名舍成就。此义云何。又外道人求自取乐行于布施。彼外道人为自身舍虽广行施而爱境界心之所缠故。果报微薄。又声闻辟支佛人虽不求世间乐果报事。而心毕竟取于涅槃。舍利众生但取涅槃乐。是故施等业道功德。虽少为他而毕竟自为。毕竟专念成就自身利益果报。又菩萨摩诃萨出过一切世间。大士为利益他发起坚固大力之心。起大悲柔软所施最胜毕竟成就

又成就舍者。有六种因。何等为六。一者舍自身乐。二者观无众生。三者求无量佛法。四者摄取无量世住。五者修集无量种种善根。六者不断三宝以能成就无量果报。是名菩萨舍成就义应知。又为他利益一味心故。此明何义。世间众生多为自身弃舍利益一切众生。为求自乐为现受报为未来果施与他物。若诸菩萨摩诃萨等。为利益他专心一味见诸众生。贫无资财般若等法。以是义故。不着因果依法施财施。于现在世及未来世能与众生大利益事。是故菩萨摩诃萨舍成就。又复以舍随顺义故。此明何义。布施等事随顺摄取众生行故。则能摄取一切众生。作大利益事。虽为利益他事。而外道声闻辟支佛等。弃舍利益一切众生。唯为成就自身利益。菩萨摩诃萨依大慈悲心起乐利益他众生行。如菩萨所求如是成就。以是义故。名舍成就。又以依于取佛菩提起心义故。此明何义。以菩萨摩诃萨为与一切众生乐故。自求佛菩提起于舍心。见诸众生堕坠恶趣。我于现在及未来世。令诸众生离苦恼事。是故菩萨其心日夜转转为欲利益众生名舍成就。又以能摄取种种果故。此明何义。以诸菩萨为欲利益一切众生种种布施。于现在世及未来世。为欲摄取一切众生取种种果。是名菩萨舍成就。如无尽意修多罗中说。求饮食者施与饮食。为命为乐为辩为色。及以为力如是等。皆悉施与又为远离邪命自活求资生故。此明何义。以诸菩萨布施波罗蜜相违之法贪求资生。邪命自活等皆悉远离。如无尽意修多罗中说。菩萨摩诃萨无颠倒邪命追求资生等布施

问曰。应说清净不清净舍。云何清净云何不清净。答曰。菩萨摩诃萨依自心清净布施清净。如如来修多罗中说。有四种清净布施。何等为四。谓有布施从施主清净非是受者。如是等于彼四种清净施中。所谓施主清净非是受者。是名菩萨摩诃萨清净施。又从施者受者清净。亦名菩萨清净之施。何以故。以诸菩萨施与他物不求果报。即能施与一切众生。又求布施果报者。彼人于受者边求清净。而菩萨离果报故。一切时自身心清净。以心清净故施清净。又以远离忽然施等。此明何义。以如来修多罗中说有九种施。一者植施。二者畏惧施。三者报恩施。四者求恩施。五者学父母施。六者为生天施。七者为名称施。八者为庄严心施。九者眷属法施。为修行功德为得上义施。植布施者。谓得植福田求多果报故。又植施者。谓近眷属名植布施。畏惧施者。见一切物无常败坏宁用布施故。报恩施者。谓报恩相施。彼先施我我应还施。求报恩施者。谓求后时报恩故。施学父母施者。谓着过去修行起如是心。我父母精进常行布施。我亦如是行于布施故。为生天施者。谓求天中五欲境界故。为名称施者。为令四方沙门婆罗门等知而施故。如是七种施为智者所呵。以不清净故。又声闻辟支佛人。离世间乐求涅槃乐。如是布施亦非清净。又菩萨摩诃萨不着自乐。唯求诸佛菩提心施于诸施中最胜清净。是名菩萨施清净。又以如实知有为行体故此明何义。以诸凡夫取着虚妄戏论我相心颠倒故。唯求五欲乐境界事。以离慧眼以为爱等烦恼诸垢之所染污舍不清净。菩萨摩诃萨如实知见有为行体虚妄不实。是故远离我见等相。及能远离五怖畏故。无有内外可施之物。不能舍者以为求他利益所缚。及能远离自求乐等垢污之法。以是义故名舍清净。又以空观观所起故。此明何义。以诸菩萨空观等观观施等法。以是义故名舍清净。如无尽意修多罗中如来说言。以观空观观起布施。以是义故。施不可尽如是等

问曰。应说布施差别之相。答曰。略说则有一种布施。谓不贪心。相应心施。复有二种。一见受者。二不见受者。不见受者者如置物火中及恒河中。又见施主者有施有布施。彼亦有二种。谓染不染。染者谓家法余食及淫女人庄严具施。是名染施。不染施者。谓施贫穷孤独人等是不染施。复有二种施。谓法施资生施。法施者。谓离供养恭敬等心。于法中法想远离爱心及颠倒心。说修多罗等是名法施。复有三种施。即此二种加无畏施。无畏施者。作如是言。汝莫怖畏汝莫怖畏。又无畏施者。见诸众生种种怖畏施与无畏。此义云何。谓见他畏起。与现世及未来世无怖畏心。而口说言。汝莫怖畏汝莫怖畏。我为汝作如是如是方便。随何等方便与汝毕竟无畏之处。名无畏施。彼怖畏者如贫穷人受于苦恼。此怖畏者亦复如是。以与无畏对治法故。复有四种施。即向三种。复有大施。言大施者。谓受持五戒。此是如来所说大施。以能摄取无量众生故。成就无量众生乐故。资生饮食用布施者。不能广作利益众生。受持五戒能作利益。以能尽形受持五戒。念念增长种种功德。以依止彼根本心故。诸功德聚乃至命根不断绝住。复有四种施。此四种施略有二种。一者不净。二者净。不净中有二种差别。何等为二。一者怖畏施。二者求报恩施。以何义故。名为不净。如世间田以为荆蕀恶草等覆故名不净。此亦如是。以怖畏故求报恩故名不净施。净中亦有二种差别。何等为二。一者敬重心施。二者慈悲心施。除此四种更有上上胜施。如偈言

  下求有资生　　下下怖畏施
  智者敬重施　　胜智慈悲施

复有四种施。何等为四。一者自利益施非他利益。二者他利益施非自利益。三者俱利益施。四者俱无利益施。自利益施非他利益者。谓凡夫圣人伏离烦恼。或有非是伏离烦恼。或时施与诸佛如来。或时施与形像塔庙。是名自利益施非他利益。他利益施非自利益者。谓阿罗汉阿那含等。除为现果施与众生。是名他利益施非自利益。俱利益施者。谓施伏离烦恼凡夫。或未伏离烦恼凡夫。是名俱利益施。俱无利益施者。除为现果。谓阿罗汉阿那含等为塔庙施。是名俱无利益施。又复略说。诸菩萨摩诃萨有四种施。悉能摄取一切善根。何等为四。一者平等心施。二者对治施。三者回向大菩提施。四者依寂灭施。如是诸菩萨摩诃萨为满足檀波罗蜜故。如是布施应知。问曰。应说布施果。云何布施果。答曰。略说布施。有一种果。所谓受用。复有二种果。所谓现在受果未来受果。复有三种果。即此二种复加般若。复有四种果。何谓四种。一者有果而无用。二者有用而无果。三者有果亦有用。四者无果亦无用。有果而无用者。谓不至心施不自手施轻心布施。彼如是施虽得无量种种果报而不能受用。如舍卫天主。虽得无量种种珍宝。而不能受用。有用而无果者。谓自不施见他行施起随喜心。以是义故。虽得受用而自无果。如天子物一切沙门婆罗门等。虽得衣食及以受用而自无果。又如转轮圣王四兵。虽得衣食而不得果。有果亦有用者。谓至心施不轻心施。如树提伽诸长者等。无果亦无用者。谓布施已因即灭尽。或为出世圣道障故。犹如远离烦恼圣人。复有五种果。谓得命色力乐辩等。如如来修多罗中说。因食得命是故施食即是施命。以是因缘后得长命。如是施色施力施乐施辩才等。皆亦如是。复有五种胜果。所谓施与父母病人法师菩萨。得胜果报。父母恩养生长身命。是故施者得胜果报。又病人者。孤独可愍。以是义故。起慈悲心施病人者得胜果报。又说法者。能生法身增长法身。示导善恶平正非平正颠倒非颠倒。是故施者得胜果报。又诸菩萨等悉能摄取利益众生故。以快心故。以无因缘而能发起慈悲心故。以摄取三宝不断绝因故。以是义故。施菩萨者。得胜果报

复有五种果。即现身得。何等为五。一者入慈三昧。二者入无诤三昧。三者入灭尽定。四者见道。五者阿罗汉果。若布施者即得果报。入大慈定者。能发心与无量众生安隐之乐。以与无量众生乐故名为慈心。以是慈心熏修自体。是故初起慈心三昧。即布施者得现果报。又入无诤三昧者。悉能防护一切众生诸烦恼心。以广摄取利益众生熏修自体。是故初起无诤三昧。即布施者得现果报。又入灭尽定者。则能摄取无量功德。以取无量功德熏修自体。以此三昧似于涅槃。是故初起灭尽三昧即布施者得现果报。又见道者离见道烦恼。以圣道力熏修自体。以是义故。初起见道即布施者得现果报。又阿罗汉果者。远离修道一切烦恼心得自在。是故初起阿罗汉果。即布施者得现果报。又菩萨摩诃萨布施果者。如无尽意修多罗中。及余一切修多罗中广说应知。而诸菩萨摩诃萨等。修行布施胜余人施。离自取乐为欲利益他众生故。而行布施。又复略说。菩萨求于二种法故。而行布施。一者求于大富资生故。二者求得成就波罗蜜故

又复菩萨起如是心。我若无有多资生者。虽有施心而无财物可以布施。是故起心为欲成就资生大富施与众生。依此施故怨亲平等摄取利益。是故菩萨见依布施故。得成就无量福德。一者能摄取怨。二者恒常给济一切众生衣食等物。三者心不怯弱。四者余亲不欺。五者常为众人敬信尊重。六者一切眷属信受其语。七者入大众时心无怖畏。八者一切怨敌不能伤害。九者亲属欢喜。十者现果资生常有不空。十一者常为他求。十二者所作已办。十三者情所爱敬常自围绕。十四者所不爱敬皆悉远离。十五者所有成就世间出世间利益胜事。常为一切亲属所庆。十六者若无利益一切诸亲则怀忧恼。十七者护一切恶。十八者自令安住诸善法中。十九者见他神通心不欣尚。二十者恒常赞叹一切功德。二十一者覆藏诸过。二十二者弃舍一切非丈夫相。二十三者成就一切大丈夫相。二十四者无有贫穷下贱乞人看施主眼。二十五者一切求心称事满足。是故菩萨摩诃萨。深见布施有如是等无量功德为欲利益一切众生。自能成办如是力故。信喜布施以依信喜行布施故。则能满足檀波罗蜜

问曰。为从胜心成就清净布施果报。从胜福田成就清净布施果报。答曰。有人言。从胜心故。成就清净布施果报。何以故。现见施事是一而果报差别。犹如种子。此义云何。犹如种子地等是一。而依种子见有胜果。如是施物是一。而依胜心乃至施畜生等。以心力故得人天果。转轮圣王声闻辟支佛佛菩提果。以是义故。依于胜心得胜果报。是故得知胜心为重。此复何义。若施事是重。依施事故成就清净施果报者。离重施事以慈悲心施与畜生施与福田如布施佛不应成就清净施果。又若离快胜尊重心等布施如来。应得成就清净施果而实不成。以是义故。成就清净布施果报。心为胜因。而施事福田能生胜心。依此义故。如来经中赞叹福田。复有人言。依胜福田依重施事成清净果。何以故。以闻布施不知福田得胜果报。此明何义。不识佛等功德福田布施佛等得胜果报。如有猕猴施如来蜜。及婆私咤加尸迦等。又如女人爱念心故。以诸幡盖及华鬘等本心实欲供养儿塔。而实供养辟支佛塔。谓是儿塔。从辟支佛得无量福。不从本心儿边得福。如是等以是义故。从胜福田及以重事得胜果报。不从心得。故知福田施事为重。又有人言。不知福田无福田事。不得成就清净施果。如有一人施尼干子生罗汉想。而不成就清净果报。又有人言。心以福田及施事等三种和合。此明何义。若布施者。从所尊重起布施心。知福田等无量功德。值遇诸佛如来福田。或时值遇如来弟子。从尊重心起布施心。所可施物是难舍事能舍布施。三种和合方得成就清净果报而心为重。以是义故。此三种中唯心一种为重为胜。是能舍主能施主者。问舍主施主有何差别答曰。有乞求者持他物施是能施主。持自物施是能舍主。又有人来乞。持自物施是能施主若人发心求贵重物。而口不言。知心即施是能舍主。又布施物时悭心数数中间隔起是能施主。若无悭心数数起者。是能舍主。又虽施他物以悭心故自求果报。是能施主。若施他物不以悭心专求自果。是能舍主。又离喜等心而行布施。是能施主。共欢喜心于三时中不悔心施。是能舍主。又若求未来胜果报者。是能施主。离世间报求涅槃果是能舍主。又若施求于现在未来及涅槃果。是能施主。若发心求大菩提果。唯大悲心施与众生是能舍主。成就善知回向方便者。问曰。何故说戒施后次说善知回向方便。答曰。为欲示现异道功德故。此义云何。外道人等求自乐故。修戒施等回向三有。又声闻人辟支佛等。亦自为身求涅槃乐。修戒施等回向涅槃。诸菩萨摩诃萨为利益他求大涅槃。以慈悲心一味等。心与众生。乐修戒施等回向无上大菩提果。以戒施等同彼外道声闻辟支佛。是故如来示现回向胜道功德说戒施后。次说善知回向方便。又修戒施等贪着世间乐果报心难可防护。是故如来说施戒后次说善知回向方便。此明何义。以戒施等非三昧行。唯取欲界天人之中净妙色等境界果报。而彼净妙色等境界。虽作心护贪等烦恼不可得离。何以故。以于过去无始世来习贪爱等染着境界以心取彼色等境界难防护故。而诸菩萨彼时修行地方便法。即于彼时虽复未离贪等烦恼。而修戒施贪等烦恼不能染心。又为断疑。是故如来说戒施后。次说善知回向方便。此示现何义。世间有人。疑于菩萨不离烦恼修戒施等。以利根故观有为法。一切皆悉苦空无常。修戒施时贪等烦恼为染菩萨不染菩萨。为断彼疑。菩萨尔时为欲利益一切众生。舍自利益乃至不求转轮王处乐果报事。唯为一切众生乐故。求佛菩提。所有善根回向涅槃。以是义故。菩萨虽复未离世间。一切世间所有过患不染菩萨。又依清净戒回向清净故。此明何义。以依清净持戒之力。是故能舍以舍力故。诸所求法皆悉成就。是故如来说戒施后。次说回向方便。是故如来修多罗中说。持戒人所愿所作皆悉成就。何以故。戒清净故

弥勒菩萨所问经论卷第六弥勒菩萨所问经论卷第七

        后魏天竺三藏菩提流支译

问曰。应说回向义及说方便义。云何回向义。云何方便义。答曰。若回余处善根功德向佛菩提。是名回向。又依佛菩提起修行心。无量种门于一切时于一切处集诸善根。为欲证得一切种智。依于世谛境界般若。回向方便普令转来故。此明何义。以诸菩萨依于世谛境界般若知因似果。修有量因深心成就菩萨不共道功德等。增长胜法置于无量果报之中。是故名为回向方便

又以同胜回向故。此明何义。以略说菩萨摩诃萨有二种回向。何等为二。一者同回向。二者胜回向。同回向者。一切善根皆悉回向萨婆若智。胜回向者。如无尽意修多罗布施果中说。须食与食具足命辩色力乐故。须饮与饮离渴爱故。如是施衣得色施乘得乐施灯得眼。施音乐者得净天耳。如是乃至施髓脑者得金刚身坚固不坏如是等。又同回向者。为与一切众生乐故。胜回向者。未生信心者令生信心故。若有破戒者。令得持戒故。若无闻慧者令得闻慧故。若有懈怠者令得精进故。若有喜忘者令得忆持故。若心散乱者令得禅定故。若无智慧者令得智慧故。若有悭惜者令成就舍故。如是等。又同回向者。为满六波罗蜜故。胜回向者谓舍外事故。为令一切众生具足大富资生故。舍手脚等一切肢节。及以诸根为令一切众生具足诸根手足等故。如是等回向一切修多罗中广说。应知。又为欲清净诸佛国土。是故回向。此义云何。菩萨为欲清净四种义故。檀等诸白法回向佛菩提。何谓四种。一者为欲清净诸佛国土。二者为欲清净菩提之心。三者为欲教化淳熟清净众生之心。四者为欲清净一切佛法。而菩萨不为得世间位故回向。不为求于自身乐故回向。不为取声闻辟支佛地故回向。又施等布施远离尽因回向。以诸菩萨取一切种智因。是故菩萨善知回向方便。又菩萨有四种事施等功德尽。何等为四。一者不回向阿耨多罗三藐三菩提。二者求于世间人天生处。三者无回向方便。四者亲近恶知识。如是菩萨一切施等善根尽灭。若菩萨行布施等。若三种法常现前者。菩萨尔时施等功德远离尽因能成一切种智。何等为三。一者正遍知菩提心。二者怜愍众生。三者不违如来言教

又以摄受方便故。此明何义。以诸菩萨乃至摄取微少善根能成就广果。以即彼布施等世间众生取天人果报。即彼布施等诸菩萨摩诃萨取佛菩提。是故菩萨成就回向方便。如如来方便修多罗中说。又善男子。菩萨摩诃萨以方便智乃至舍一口食施与一人。则能遍满一切众生。何以故。以菩萨有方便智慧故。以一口食乃至施与畜生。而心常共一切众生。以彼善根皆愿回向一切种智。菩萨布施为二种事。是故施与一切众生。一者求一切智地。二者回向大菩提。复次善男子。菩萨摩诃萨以方便力施布施时六波罗蜜皆悉满足。何以故。以诸菩萨摩诃萨见乞索人时。摄伏悭嫉心增长大舍心故。即得成就檀波罗蜜。又诸菩萨以自身持戒布施持戒人所有破戒人令成就持戒。是名菩萨摩诃萨尸波罗蜜

又诸菩萨慈心不嗔心定心布施。是名菩萨摩诃萨羼提波罗蜜。又诸菩萨布施佉陀尼蒲阇尼等。种种饮食身口意业去来进止。是名菩萨摩诃萨毗离耶波罗蜜。又诸菩萨施布施时。专心一念欢喜不散乱不求余事。是名菩萨摩诃萨禅波罗蜜。又诸菩萨施布施时。观察法相。谁是能舍谁是能受。谁受果报。是菩萨如是观察不见一法。以不见一法谁是能舍谁是能受谁能受果。是名菩萨摩诃萨般若波罗蜜。如是等方便修多罗中所明回向方便。应知

问曰。应说净不净回向。如布施中有净不净。此回向中亦应如是有净不净。云何净云何不净。答曰。因修行果如余一切修多罗中广说。应知。成就慈心者。问曰。何故如来说善知回向方便后。次说成就慈心。答曰。持戒布施是散乱心。修道功德决定感于欲界果报。菩萨以回向方便摄取决定欲界果报。转求大菩提示现彼果。不定示现善能修习菩萨道故。又持戒布施是三昧心修道功德。决定感于禅地果报。菩萨以回向方便摄取决定禅地果报。转求大菩提示现彼果。不定示现善能修习菩萨道故。是故如来说回向方便。复次说成就慈心。此明何义。以诸凡夫不如实知真实法界。无始世来修习无智。以无智故不能远离我我所法。以其妄执我我所故。为色境界。爱心所缠。是故心常求世间果作极恶行。自然成就世间果报。修行戒施决定成就同界果报。而菩萨心见诸世间所有一切种种过患。见于涅槃安乐利益。善能觉知真实法界。善知因缘有为诸行。其心唯为无上菩提修戒施等。为欲救度世间所有堕坠崄难放逸众生。持戒布施虽不取彼世间果报。而为众生修一切行。不为自身取于果报。增长所修大功德力。心能摄受回向方便。随顺成就求处果报

问曰。应说四无量。云何菩萨成就四无量。云何行云何世辩云何体云何相云何地差别。依止何处观何境界观何法。云何相应云何得云何成就义。答曰。云何菩萨成就四无量者。以其不同外道等故。此明何义。诸外道辈虽复修行四无量行。以为爱心之所润着。是故成就色界果报。又声闻人辟支佛等。一切善根皆为自身。其心常为自身乐故取于涅槃。畏烦恼热为伏诸结。修行无量非为众生。若诸菩萨摩诃萨等。其心常为一切众生修行诸行。皆悉转施一切众生。以慈悲心起戒施等。为欲利益一切众生虽为世间极恶过患之所逼恼。以为不舍诸众生故。为灭一一众生苦恼。毕竟寂灭一切苦恼。观察无量诸众生身。一一身有无量种种苦恼差别。复如实知一一方便。救彼无量苦恼众生。以无量时虽见涅槃界观无量众生。能得成就无量佛法。以是义故。名为菩萨成就无量

又以遍取果故。此明何义。以诸菩萨摩诃萨等修行无量无边行故。慈等无量。是故菩萨成就无量如无尽意修多罗中。圣者无尽意告舍利弗言。大德舍利弗。菩萨修慈亦不可尽。何以故。菩萨之慈无量无边。是修慈者无有限齐等众生界。菩萨修慈发心普覆。舍利弗。譬如虚空无不普覆。是菩萨慈亦复如是。一切众生无不普覆。舍利弗。如众生界无量无边不可穷尽。菩萨修慈亦复如是。无量无边不可穷尽。虚空无尽故众生界无尽。众生无尽故菩萨修慈亦不可尽。如是等。又为安隐他与功德故。起心修行。此明何义。菩萨摩诃萨修四无量不为自身。为一切众生。为毕竟安隐一切众生。与功德心是故成就。如无尽意修多罗中。无尽意菩萨告舍利弗言。大德舍利弗。是慈能自拥护己身。是慈亦能利益他人。是慈无诤。是慈能断一切嗔恚嫌恨如是等

云何行者谓有所厌。此明何义。依厌所得四无量者。彼初禅地所有无量厌欲界得。如是乃至第四禅中所有无量厌三禅得。而后时作方便后时现前。问曰。何等名为无量故修行方便。答曰。慈依亲起。此明何义。菩萨若欲修四无量。彼时心于一切众生三种分别。一者亲分。二者怨分。三者非亲非怨分。于亲分中复为三分。作三分已。彼三分中于上亲所起与上亲安隐乐心。所谓父母及余尊重诸师僧。等以无始来习极恶。心难可平等。是故如是分别报恩。于亲分中不能平等转转修习

又乃平等。若心如彼增上亲中。若怨分中心住平等。如与父母乐心无异。尔时名为成就慈心。悲喜舍心亦复如是。应知。而舍无量从于非怨非亲分中起乃成就

又诸菩萨摩诃萨等。不离烦恼修集禅地方便无量。若断烦恼摄取初禅无量。如是四无量次第成就。应知

又四无量说有三种。一者众生观。二者法观。三者无观。初发菩提心菩萨未知众生相。同于外道声闻辟支佛观无量。是名众生观无量

又诸菩萨即彼众生观无量。次第渐渐增长胜上。如实知众生相修菩萨行。未知一切有为法相。依假名众生有为诸行起众生相戏论。即取此有为行以为众生。名为法观无量

又诸菩萨能如实知有为行相。得无生法忍。从慈心后次生平等观般若。说名慈心。名为无观无量。如共慈心相应觉分。此明何义。如慈心后次生择法觉分而说名慈。如是慈无量后次得平等观般若。说名慈无量。是名无观无量

又诸菩萨摩诃萨等。为与他乐从慈心故起一切行。此明何义。以诸菩萨摩诃萨等所起诸行。一切皆从慈心而生。以为利益他众生故。以为安隐他众生故。以得无生法忍。菩萨摩诃萨般若从慈心起。与一切众生安隐之乐。似于慈心说名为慈

又世谛境界法。第一义谛境界法。迭共相依增长有力。能广修行成就无观。说名善清净说名慈心。云何名为世谛境界为般若因。以诸菩萨见诸法体。依慈悲心观察众生。所作之事不堕声闻辟支佛地。以是义故。不舍众生所作之事。是则名为世谛境界。慈悲等法为般若因。云何名为第一义谛境界。般若为世谛境界慈悲等因。以诸菩萨欲清净世谛慈悲等法。以知依止众生行相起诸烦恼观察烦恼深众生行相。以如实知烦恼从众生行相起。是故菩萨远离慈等不清净因一切烦恼。是名般若能为世谛境界法因。诸菩萨等。如是修行般若方便广修诸行。是故成就无生法忍。彼时无观不舍众生所作事因。清净究竟慈心名字慈心。说名慈心是名无观。云何世辩者。释彼无量名以能观察无边众生。故名无量。云何体者。慈悲心体者不嗔善根是。何以故。以对治嗔法故。又对治可嗔处是名为慈。对治不可嗔处是名为悲。又对治起舍众生心是名为慈。对治打众生心是名为悲。是以求功德故能生无量。非求过故能生无量。何以故。以诸菩萨乃至断善根人。若求功德见净业果乃至阿罗汉边若觅过失见恶业果。何以故。以见罗汉现身中受不善业果。不见过去余业不尽。谓阿罗汉今身造恶。以是义故。于阿罗汉不能发起慈悲无量。喜心体者。谓喜根是。舍心体者不贪善根是。问曰。若如是者。则非贪欲及害根等对治之法。答曰。不然。以不嗔善根相应法故。故如是说。问曰。若舍心能对治贪法。不净观亦对治贪法。答曰。汝知何等贪法舍能对治。何等贪法不净对治。问曰。不知。答曰。汝听色贪不净能断淫贪舍心能断。此四无量共心展转五阴为体

云何相者。与众生乐相安隐众生。是名慈相。拔众生苦相灭相寂静相怜愍众生。是名悲相。离不乐心相嫉妒对治法是名喜相。舍爱不爱相利益一切众生事因相违之法。自然纵任是名舍相

云何地差别者。除喜无量余三无量在六地中。应知。何等为六。谓未来禅及中间禅四根本禅是名六地。初禅二禅有喜无量。余三无量遍四禅中。以喜无量喜根为体故

依止何处者。依止欲界。以欲界中现起四无量。非是余处何以故。以欲界众生多苦恼故。见众生苦起与乐心。见众生苦起拔苦心。以色无色界无苦恼故。又是恼害等对治法故。此明何义。以四无量对治害等法故。以是义故。经中说言。修行慈心下中上成就离害心。修行悲心下中上成就离嗔心。修行喜心下中上成就离不乐心。修行舍心下中上成就离贪欲害等心。色无色界贪欲害等皆悉无有。以是义故。在欲界中非色无色。虽在欲界唯三天下。非郁单越

观何境界者。谓慈观乐悲观拔苦喜观喜境界舍观舍境界

观何法者。谓观欲界众生五阴之身。或观二阴。又若共心同类彼则五阴。不共心同类彼则二阴。或观无心众生。或观一阴众生。或观二阴众生

问曰。有经中说。慈悲喜舍普遍一方虚空法界。如是乃至遍覆十方世界。此中唯说观于众生。其义云何。答曰。遍十方者。谓观一切依世界住所有众生故。言遍覆十方世界。非谓遍覆彼器世间。言普遍者。示现依彼器世界住所有众生

又初禅地无量观欲界众生。二禅地无量观欲界及初禅。如是乃至四禅地无量。观欲界乃至第三禅。又初禅地无量观欲界及初禅。如是乃至四禅地无量。观欲界乃至第四禅。又慈观欲界乃至三禅何以故。以慈心观乐境界故。又乐根从欲界乃至第三禅故。悲观欲界至初禅。何以故。以悲心观苦境界故。以欲界众生多苦恼故。又苦根从欲界至初禅故。喜观欲界乃至第二禅。何以故。以彼喜心勇悦相故。又喜根从欲界乃至第二禅故。舍观欲界乃至四禅。何以故。以舍舍相观故。又舍根从欲界乃至第四禅故。又有人言。一切无量唯观欲界众生。云何相应者初禅二禅地喜根舍根相应。第三禅地乐根舍根相应。未来禅中间禅第四禅地舍根相应。云何得者。若生第三第四禅者。得三无量除喜无量。何以故。三禅已上无喜根故。又欲界生离烦恼者。及在初禅二禅生者得四无量。如如来修多罗中说。慈无量者至遍净处以为边畔。悲无量者至虚空处以为边畔。喜无量者上至识处以为边畔。舍无量者。无所有处以为边畔。何以故。以根本初禅所摄故。此明何义。以无量从无边虚空处以为边畔。故如是说。又有人言。彼处圣道以无量名说。何以故。以可化众生有如是根。闻无量名来入圣道故。复有人言。依彼对治觉分菩提分说。此明何义。以第三禅对治觉分。即彼觉分以慈名说。如是乃至无所有处依彼对治以舍名说。复有人言。彼相似法。此明何义。以慈观乐而乐受。乃至第三禅中以悲观苦。而无边虚空处共色相违。以喜观无乐而无边识处。识喜住故。以舍观舍而无所有处。舍无所舍说名为舍。复有余修多罗中说。大德舍利弗。初发心菩萨以四无量观于众生。名众生观。菩萨摩诃萨行菩萨行。观己行故名为法观。菩萨摩诃萨得甚深无生法忍。名为无观

问曰。四无量者观于众生。云何复言观法观无。答曰。为他利益一切行等。以慈相似法故。此明何义。菩萨摩诃萨为诸众生修一切行。皆以般若为本。是故般若以慈名说。以彼慈能乐他相故。如是菩萨舍自身乐。般若波罗蜜与他乐相。是故般若以慈名说。是故观法观无皆是慈悲般若。复有人言。无观慈心以慈名说。此明何义。以诸菩萨观察众生。复为自身推求远离烦恼方便观有为行。得甚深无量心时。即得毕竟般若力。作是思惟。此诸众生无智所覆不能如实知见法界。我当令彼诸众生等。渐渐次第得入正道

复有余修多罗中。佛告诸比丘过去七年修行慈心。世界成坏经由七返不来生此。乃至无量百千万劫作转轮王等。问曰。若四无量所得果报非欲界者。云何如来经中说言。修行无量所得果报。乃至无量百千万劫作转轮王。答曰。彼经中依三地无量作是说。此义云何。有欲界地果报无量作转轮王。有初禅地果报无量作梵天王。有二禅地果报无量生少光天。又欲界起心三摩跋提。所有果报作帝释王及转轮王。根本地禅所有果报。作梵天王生少光天

复有余修多罗中。佛告比丘。过去世时有外道师名善眼。世尊彼外道师善眼。世尊获得神通离欲界烦恼。诸比丘彼外道师善眼。世尊多有无量声闻弟子。有无量百有无量千有无量万有无量百千万。诸比丘彼外道师善眼。世尊所有声闻。具足持戒。彼外道人修四梵行。离欲界烦恼修四梵行生梵世间。诸比丘。彼外道师善眼。世尊所有弟子。不能具足修四梵行。彼弟子中或生他化自在天者。乃至人中如是等。尔时外道师善眼世尊生如是心。我今不是云何乃与弟子一处去一处生。作是思惟。我依慈心修第二禅生少光天。诸比丘彼时外道师善眼。世尊修上大慈入第二禅生第二禅如是等

问曰。若诸菩萨摩诃萨等。为利益他于诸众生起平等心。何故自生胜心慈心。修第二禅生少光天。而不为弟子说生少光天法。又复有难。彼外道师善眼。世尊有所说法胜于佛法。何以故。以彼皆生上善道故。而如来声闻亦有入恶道者。答曰。此无过失。何以故。菩萨观机而说法故。此明何义。以彼外道婆罗门等长夜思惟。初梵天处是究竟处。随顺乐心而生彼处。不能修行生第二禅四无量行。以是义故。菩萨善知彼弟子心故。不为说生第二禅四无量行。又以无力故。此明何义。有人说言。除佛出世。无有外道能具修行二禅无量生第二禅。唯除大力诸菩萨等。又言外道法胜佛法者。此义不然。何以故。以外道取世间果故

又以时节故。此明何义。有如是时。多有众生生善道处。何况复有无量众生修行无量。又言。如来弟子入恶道者非如来过

复有余修多罗中说。有三种行。梵行天行圣行。梵行者。谓四无量。天行者所谓四禅。圣行者谓三十七菩提分法。以何义故。说四无量名为梵行。答曰。以四无量梵天因故。又以修行者身中可得故。又以对治非梵行故

问曰。何故色界诸善根中。唯说无量以为福事。答曰。以为起他利益行故。此明何义。世人多于他利益中生功德相。余利益中不多生故

问曰。复有余修多罗中说。有四种人能生梵功德。何等为四。一者器世间地未有塔处于中立塔。二者种植园林施。四方僧。三者和合先破坏僧。四者能生四无量心。问曰。若修四无量得梵天果。得言成就梵天果者。立塔等三得梵天果。此义云何。答曰。依梵行说是故无过。此明何义。非立塔等成就梵果。若有人依梵如来立舍利塔。彼人能生梵行功德。又依修梵行者施与园林。如是施者得成就梵福。又依圣道修习梵行和合破僧得梵天果。又以彼相似故。此明何义。立塔等三成就梵天果报。功德非一向同。四无量果而彼少分相似义故。如人成就四无量心。彼人则为摄受众生成就无量利益功德。此亦如是。若人于彼器世间中。未有塔处立舍利塔。施僧园林和合破僧。彼能成就无量福德。以是故言修四无量立塔等三有相似义

问曰。梵行功德其量几何。答曰。有人说言。随何等业得转轮王。王四天下势力自在。梵行功德其量如是。复有人言。随何等业得帝释王势力自在。梵行功德其量如是。复有人言。随何等业得作魔王。于欲界中势力自在。梵行功德其量如是。复有人言。随何等业得生梵天。梵行功德其量如是。复有人言。梵天请佛转于法轮随所得福。梵行功德其量如是

问曰。复有其余修多罗中如来说言。若有人能成就慈心。彼人功德火不能烧。水不能漂刀不能割。毒不能害命不中夭。为何义故作如是说。答曰。诸佛如来所有境界不可思议。一切禅定不可思议。一切诸业不可思议如是等。复有人言。若人能与无量众生无量安隐。以是故说。彼外因缘不能伤害

又彼人忆念色界四大。此明何义。以彼修习慈心之人。入慈心故依于色界成就色界四大之身。以是义故。外诸因缘不能伤害

问曰。以何义故。此修多罗中唯说修行慈心悲心得多功德。不言喜舍。答曰。以利益他多修行故。此明何义。修慈悲心与乐拔苦。依慈悲故起心修行。舍布施等得无量福。而喜舍等不能如是。此义云何。以彼喜心见他众生。自修善业自得受乐。彼人生喜。以是故喜舍亦如是。以他众生自心分别嗔心爱心及无害心。故名为舍。以是义故。喜舍福少慈悲福多。以慈悲心成就与他无量利乐。非是喜心舍心成就。以对治嗔名为慈心。不嗔善根以为体故。以最胜义对治于嗔。何以故。以嗔心故舍诸众生。与一切众生利益事相违。是故菩萨为欲利益一切众生。对不利益众生事。因此经中说修行对治慈悲心等

又发菩提心修诸善行。皆慈悲心以为根本。此明何义。即此修多罗中说不退转心。成就发菩提心因。彼发菩提心初始欲生。依慈悲心以为根本。则能修集无量功德非喜舍等。以是义故。此修多罗中唯说慈悲多生功德。不言喜舍。是故十地修多罗中说。彼菩萨发菩提心。是心以大悲为本。如是等以毕竟成就大慈大悲身口意业故

又是三昧身口意业依慈悲心起。与乐相应说名慈心。以见世间因中说果。譬如世间木作画作因中说果。成就无害身口意业。以悲对害心不生他恼乱身口意业故

弥勒菩萨所问经论卷第七弥勒菩萨所问经论卷第八

        后魏天竺三藏菩提流支译

成就善知方便。问曰。以何义故。说无量后次说成就善知方便。答曰。为欲示现以方便力摄取所修四无量行。随顺自心受果报故。如说四大随顺。此明何义。略说菩萨二种善巧利益方便。以外道等一切无有第一义谛巧方便故。修行无量为爱所润成色界果。又诸声闻辟支佛人。为取涅槃心取以为究竟。善根弃舍利益一切众生。弃舍世谛所作诸业。其心专为利益自身。不能如实修四无量。不能究竟断诸烦恼。唯能折伏一切烦恼。若诸菩萨摩诃萨等。能如实知二种之法有为无为。观察众生不舍有为。虽如实知寂静无为。以为成就一切佛法不堕有为。以诸所修为利益他。以如实知自相同相。以不能得随心自在定得色界清净果报。四无量行以彼爱心所不能润。而随顺心成就果报。如随顺四大。此明何义。如四大相非是成就第一义谛。如禅定人随顺心力而能舍离四大自相。此亦如是。虽复成就有为法相。以诸菩萨清净持戒诸功德众。修四无量随顺心力成就果报。而不随顺四无量心。以是义故。圣者思益梵天所问修多罗中。如来说言。若诸菩萨摩诃萨等。成就四法修行四禅生于欲界。何等四法。一者得心自在。二者具足诸善根力。三者观察一切众生。四者修行方便般若。是故示现方便摄取无量修行随心受果。说无量后次说方便

问曰。应说方便义。云何方便义。答曰。次说方便义。有二种。一者求异义。二者不舍二义。心修诸行智慧观察名为方便。此明何义。求异义者。诸菩萨等非为现前证圣道果。亦非为厌世间苦恼舍于世间心。为利益一切众生。及为自身取大菩提。方便为教众生菩提方便。及欲清净大悲等行取菩提法。出过声闻辟支佛等所证之位。道功德等所对治法。菩萨所证圣道现前。名求异义。不舍二义者。谓菩萨心不舍世谛第一义谛故。此明何义。以诸菩萨实见一切有为诸法皆悉无常。观察众生不舍一切有为诸法。不离有为法。不舍无为法。如是菩萨摩诃萨般若行不退转因。说名方便。如圣者文殊师利于经中说。天子。菩萨摩诃萨般若智。知菩萨摩诃萨非行有为智不堕无为智。如是菩萨摩诃萨。名为无畏菩萨。复次天子。若诸菩萨观察众生不舍有为行。观察诸佛法不堕无为行。如是菩萨摩诃萨名为无畏菩萨。如是等又随顺心所求之义。称心所求能成就行。名为方便。又以毕竟具足智故。名为方便。问曰。善知世谛者。如是等句说何等义。答曰。善知世谛者。善知自相故。善知第一义谛者。善知同相故。善知二义者。善知自相同相故。问曰。但说善知世谛善知第一义谛便足。何故复说善知二义。答曰。为欲示现菩萨胜义知方便故。是故复说善知二义。此明何义。外道远离如实般若智。唯有世智无出世智。声闻辟支佛舍世间智。但有涅槃智无世间智。菩萨摩诃萨为欲利益一切众生求妙法故。于世谛中及第一义谛中。修行方便智如来为欲示现菩萨胜方便智。是故复说善知二义

成就般若波罗蜜。问曰。何故如来说方便后。次说成就般若波罗蜜。答曰。示现方便摄取般若故。又以示现诸菩萨等所证位义。是故如来说方便后。次说成就般若波罗蜜。此明何义。以观能成菩提分法清净善根。菩萨欲见真如法体。而未能见真如实智。于先观察出过声闻辟支佛位所对治法。观察大慈悲等。成就根本大慈悲等。然后得见彼真如法。以是义故。见真如法不堕声闻辟支佛地。是故如来示现修行次第义故。先说方便次说成就般若波罗蜜

问曰。成就般若波罗蜜者。应说般若义。如实知见名为般若。能观所观境界名为般若。如实知深浅数量名为般若。是义应说。答曰。到彼岸故名波罗蜜义。又诸佛如来已到彼岸名波罗蜜。初地菩萨以其毕竟到彼岸故名波罗蜜。以诸菩萨毕竟得彼岸行名波罗蜜。是故如来经中说言。随顺彼行名波罗蜜。以彼处未决定彼岸义故。是故如来于无尽意所问经中说。满足行菩萨行名波罗蜜义。快深智满足名波罗蜜义。如是等

问曰。应说般若波罗蜜义。云何般若波罗蜜义。答曰。求佛菩提大慈悲心。摄取所起方便智慧。能如实知一切诸法同相别相胜义。名为般若波罗蜜义

问曰。应说成就义。云何成就义。答曰。究竟义成就义。远离一切凡夫名为般若波罗蜜究竟义。依般若波罗蜜远离世间得究竟义。名为般若波罗蜜成就。此明何义。依般若波罗蜜。得究竟无畏处。问曰。若如是者。证初地时即得名为究竟。成就般若波罗蜜。答曰。彼依如分次第应知。此明何义。从初地来得佛菩提。以得对治法现前。以得对治法故。又初地方便摄取方便般若。离一切恶道及离声闻辟支佛地。如是余地随分相应分处。应知。菩萨若能如是知者。随顺如实智般若观有为行。他力相依无有自体

问曰。依此法有此法。依此法生此法。而重说者有何胜义。答曰。为欲示现二种因义故二种说。此明何义。有为行生因有二种。何者为二。一者先生因。二者共生因。先生因者。如眼识等欲生之时先生意识。相似随顺前心不灭不容后心。要前心灭后心得生。前心虽灭与后为因。名先生因。共生因者。诸识相应谓受等法及心不相应法。共彼法生。眼等诸法能作因缘。依止彼法能生彼法。彼法生时能与作因。名共生因。又依此法者说先生因。生此法者说共生因。问曰。说依此法生此法者。此义不然。何以故。共生之法无定因故。无因果差别故。此明何义。共生之法此法是因此法是果。无有如是定因差别。以不可说此法是因此法是果故。无定因因果差别。答曰。以见故说。此明何义。亦见世间共生之法。一法是因一法非因。犹如灯炷共照俱生。而此灯炷能作照因。照不能与灯炷作因。何以故。以此照法随顺灯炷。此明何义。以见照法随顺灯炷。而非灯炷随顺于照。以见灯炷有增有减。照亦如是有增有减。以灯炷灭照亦随灭。又以灯炷异处去时照亦随去。如是共生眼识等法。依眼身等因身眼等生眼识等。非因眼识等生眼身等。又依此法者。诸菩萨等如是观察。先时生法无有作者。唯共因缘和合而生。以有此法生此法故。又诸菩萨生如是心。因既无常云何而得生于此法。是故菩萨生如是心。依此法故而生此法。非先有法于后时生法。若先有后时生者即是常法。以是义故。即法生时因缘和合。无有一法是定实者。无有定实眼识境界照了等法。以是义故。此法生时决定不从彼处而来。又以即共因缘而灭。若法即共因缘灭者。离诸因缘念时不住。以是义故。此法灭时不离此处而余处去。又依此法生此法者。谓依彼彼因缘和合。生彼彼法见彼彼法。示现彼法因缘而生非无因缘。又依此法生此法者。因观念故。又依此法生此法者。示现过去无明行分。此明何义。以依过去无明等二。得有现在识等八分。示现现在有分故。又依此法生此法者。示现现在有分。此明何义。依现在有分示现速有生老死分。又依此法生此法者。以无明爱取示现烦恼道。依此烦恼道生行有业道。又依此法生此法者。依于业道生余有支。谓苦道等。又依此法生此法者。依无明行及爱取有集谛因故。生余七分名为苦谛。又依此法生此法者。即依七分苦谛法故。生无明等五分集谛。又依此法生此法者。如来修多罗中说。依无明行而生识等。复有修多罗中说。依行因缘生于无明。此明何义。以生相时无明等法共心相应。及心不相应法身业口业皆悉共生。非后时生。又依此法生此法者。即生念时无明闇智共同时生。非先时生

问曰。说无明因缘以为初因缘。若如是者。十二因缘则为有始。何以故。以无明前更不说有余因缘故。于诸世间有为法中。以彼无明为最初故。答曰。以生烦恼业迭共因缘故。此义云何。从生生烦恼。从烦恼生业。从业生生。如是无始轮生以是义故。世间无始。问曰。自在天等所作。此明何义。从自在天及微尘等而生世间。以是义故。世间有始。答曰。此义不然。何以故。常法不能生世间故。不见一法从自在天微尘等生。见从无常因缘中生。以不见从常法中生。见从无常因缘中生。而汝法中自在天等皆悉是常。以是义故。自在天等不能生法。又以现见异异因中生种种果。何以故。以见象马牛羊驴驼至人天等。有差别故。以是故。非自在等作。问曰。非从因缘生一切法。何以故。以见棘刺及孔雀等异异不同故。知不从无明因缘有世间生。此明何义。以无因缘有世间生。何以故。我见棘刺及孔雀等。非从因缘而有差别。如是世间非无明生。答曰。此义不然。何以故。我以现见果从因生非无因生。犹如种子地水时熟和合生芽。非离此等种种因缘而有芽生。若离于因无因而有万物生者。此义不然。何以故。见异异法于异异法。以比智知世间亦尔。未曾见有离因无因而有法生。以是义故。从因生果。是故世间一切诸法非无因生。又有过咎。若尔不应生种种果。从种种因生种种果。不离种种因生种种果。而汝说果无因而有。若如是者。万物应等世间不应生种种果。以我现见从。种种因生种种果以是义故。非无因生。又复有答。若一切物无因生者。应一物中一切法生。不尔便应一切物中一一各有一切物生。而此义不然。以是义故。非无因果。又复有答应无变异。此义云何。若一切物不从因生应不变异犹如虚空。而此义不然何以故。以变异故。云何变异。先无后有已有还无异生异灭。无因法中不见如是果法转变。是故诸法从因而生。非无因生。又复有过一切所作诸业空故。此明何义。若无因生一切物者。诸所作业空无利益。而实不见有如此事。以是故非无因有果

问曰。我见从智生智。此明何义。现见外物有为法中种子为因非过去因。如是现见内有为法。因赤白等和合而生。非过去因。答曰。此义不然。何以故。以现在智从过去智而得生故。此明何义。以见智生从于过去智因而有。非无智生。若智不从前智生者。应从土块木石等生。亦非从于异相续生。何以故。若异相续生于智者。父母亦应能生儿智。以是故。我知彼胎等诸众生智从相续生。此明何义。以胎等智前更有智。彼胎等智不离先智相续而生。是故知有过去世因问曰。此义不然。何以故。如从攒燧人功牛粪众缘和合。先无有火而能生火。智亦如是。先无有智因缘和合而能生智。答曰。此义不然。何以故。以见余法比智知故。此明何义。以见何等法中生法彼法相似。能生于法。非无相似异生中见。如见从稻生稻。虽不见稻而见从稻还生于稻。是故种稻。火亦如是。以见从于攒燧牛粪等中生火。虽不见火而从攒燧等中求火。如是以见从智生智。虽不见智而知智从过去智生。是以汝说如先无火而能生火。先无有智而能生智。说一切物唯从现在因生。不从过去因生者。是义不然。以是义故。从烦恼业生世间法。此云何知。以圣人论世间人说此义云何以离烦恼一切圣人诸佛如来。及佛弟子声闻人等。彼如是说从烦恼业因而生世间。作如是言。若人着贪身作恶行口作恶行意作恶行。彼人依于恶行因缘。此身坏已生恶道中。一切诸论亦如是。说从业有生。是故经言。从明入明从闇入闇。世间之人亦如是说。从业有生作如是言。以畏一切不乐生处。远离一切种种恶行。以求一切可乐生处。修行一切种种善行。以是义故。依诸圣人依一切论依世间人。我如是知从业因故而生世间。非无因生

问曰。因念不住何能生果。此以何义。诸烦恼业刹那不住。以烦恼业刹那即灭。是故非从诸业烦恼而生世间。答曰。我见因灭而能生果。此以何义。以见因灭依彼灭因而能生果。如于摩多隆伽果中见有酢味。而于彼子芽茎枝叶及华等中悉皆不见。而依彼子芽茎枝等相续。后时于果中见。而彼摩多隆伽果中所有酢味非即彼因亦非异因。如是见外因果和合生。如是法如是比智知。因灭已依彼灭因有世间生。非无因生亦非异因。问曰。若非无因非颠倒因生于世间。而依业烦恼有世间者。此云何知。答曰。不知生过为作业行。此明何义。诸世间人不知生过。彼人则着五欲境界一切种种无利益事。为生世间一切种种无利益事。是故修行为得世间果报。作业非为除断烦恼作业。此以何义。一切世间愚痴凡夫无智慧故。不能观察。以无明闇智于无量百千种种苦恼中见有功德生。求未来世受乐果故。行功德行修戒施等诸功德行。又复有人心颠倒故。着现在世五欲境界见未来世无有福德。是故修行无福德行杀生等业。又复有人。着三昧乐爱禅见禅慢禅疑禅增上禅等。修行一切诸通等行。是故于彼三界中生不断不绝从生复起一切烦恼。从烦恼故起一切业。如是世间无始以来不断不绝

问曰。若从一切烦恼而生世间行者。如来于此修多罗中何故唯说从于无明而生世间。答曰。虽说无明摄得贪等一切烦恼。此明何义。虽说无明而摄贪等一切诸过。此云何知。以愚痴人起于贪等。以无智故起于贪等一切烦恼非无过起。如经中说。无明因缘起于贪过起于嗔过起于闇过。是故说彼无明根本摄得其余烦恼诸过。犹如世间王来王去诸臣兵众亦来亦去

问曰。以何义故。过去分中唯说无明而不说爱。未来分中而但说爱不说无明。答曰。大境界故。此明何义。以无明遍一切境界爱不如是。此以何义。以彼无明遍一切处爱不遍故。又以缘于有为无为。此以何义。以彼无明缘有为法及无为法。爱不如是唯缘有为。又以缘于同不同地。此以何义。以无明缘同不同地。爱不如是唯缘同地。又以一切烦恼相应。此以何义。以彼无明一切烦恼皆共相应。爱不如是。唯愚人起非智者起。又一切苦不断绝因。此以何义。以无明于一切苦聚以为根本。以是义故。于初分中唯说无明。依彼第二烦恼门中唯示现爱。是故于彼未来分中唯说于爱不说无明

问曰。以何义故。过去世中所摄诸业随何烦恼能与作因。彼诸烦恼以无明名说。现在世中所摄诸业随何烦恼能与作因。彼诸烦恼以爱取名说。答曰。以非现见以现见故。此以何义。过去世中所有烦恼。以是远故不可现见。是故彼中烦恼差别不可示现。以彼闇相不可得说。是故皆以无明名说。现在世生所摄烦恼可现见故。彼诸烦恼差别可说。可得示现此是爱取此是欲取此是见取如是等。是故现在所有烦恼以爱取名说

问曰。此说是妙说。以因烦恼业有世间生死。非自在天微尘等故。而无明等十二有支其义云何。答曰。不如实知三世中事名为无明。无明转起取后有因。福业罪业不动业等是名为行。依行因有生分染意是名为识。为彼识住名为名色。彼清净识之所依止名为六入。根识境界三事和合。对意地法是名为触。依触而生爱不爱。二颠倒念受是名为受。见着受等集乐名爱。依止于爱求有断有。取我依止乐诸烦恼随顺烦恼是名为取。取能转起取后生因身口意业。是名为有。依止行有取后世身是名为生。依止生身增长熟变是名为老。先得身坏是名为死。远离不离爱不爱事求供养等从意地生。焚烧自心是名为忧。依怀忧心说爱功德。内心愁缚种种悲言名为啼哭。依色识身共意相应。非爱乐受是名为苦。唯意识身意地相应是名为愁。于爱不爱二种境界。或有求有或不求有求资生故受种种苦。其心逼恼是名为极

问曰。无明缘行云何名行。答曰。依止容受伴侣观起随顺共生名为行义。问曰。应释因缘名云何名因缘。答曰。能成就果是名为因。依此法故能显彼法。因此法故能生彼法。是名为缘。问曰。何故但说无明缘行。而不说言无明因行。答曰。为摄一切诸因缘故。若说无明因于行者。但摄因因缘不摄因缘。是故不说无明因行。以四因缘无明等共能因缘行。是故唯依因缘名说。以能摄取四因缘故。问曰。行亦能作无明因缘。若如是者。何故但说无明缘行。而不说言行缘无明。答曰。以有二义定不定故。此以何义。以无明因定缘于行。而非业行定缘无明。何以知之。以阿罗汉虽复有业而无无明。是故非业定缘无明。是故不说行缘无明。又依无明因缘有业。以是义故依彼无明因缘有业。若如是者。唯依无明因缘有业。不应远离无明有业。而实远离无明有业。是故说依无明缘行。不说依行缘于无明。问曰。以何义故已受果业。以行名说。未受果业以有名说。答曰。未受果业但有有为分。是故说有。以毕竟有故。以未来世毕竟得果。业体虽灭而毕竟有。以必能与未来世果。是故名有。以有名说。已受果业已受有为分。是故说行以得受果。是故名有以有名说。又复有义。何故名有。以依此法能生名有。此以何义。随何等业能毕竟生未来世果。以有名说。随何等业非是毕竟未来世有。如鸯瞿离魔罗等业未曾有故以行名说。是故经中行缘业果以识名说非生名说。何以故。以彼行业非是毕竟生有支故。此以何义。以现身中受果报业。彼业行缘能生识支而不能生彼生支故。又以见有力无力故此以何义。何故名行能办事故。过去世生所作诸业见彼有力以能成果。是故彼业以行名说。现在世生所作诸业未见彼力以未成果彼业果报在未来故。是故彼业不得名行以有名说

问曰。以何义故名为不动。答曰。异地不能与果报故。名为不动。此以何义。如欲界业于异地中能与果报。随以何等善根业道应生人中。即彼善业依愿求心。乃至生于他化自在。如如来依功德生修多罗说。又随何等恶不善业应生地狱。受果报者即依彼业人中受苦。如如来依盐喻经说。色无色业不得如是。此以何义。初禅地业不生二禅。二禅地业不生初禅。如是余地皆亦如是。应知。是故佛说色无色业名为不动。又诸盖障所不能动故名不动如密室灯

弥勒菩萨所问经论卷第八弥勒菩萨所问经论卷第九

        后魏天竺三藏菩提流支译

问曰。行以名色二因缘识而重说者。此有何胜。答曰。初托胎识行为因缘以彼能作种子义故。已种种子名色为因缘以能和合成就事故。以二因缘住持成就依止。能取境界观故。又行因缘而业得名。是故经中说诸业因为能生因。名色因缘而爱得名。是故经中说彼爱缘为能生缘。以二因缘于境界中依境界住。又行因缘初生心得名。名色因缘已生。六入未成就六入得名。又行因缘依一门行。此以何义。彼行因缘唯意门行。名色因缘依二门行。此以何义。名色依于身根意根二门而行。以二因缘依六门行。又行因缘唯恶道中以依罪业能摄住故。如经中说。彼诸众生于恶道中乃至恶业未尽不死。业尽乃死。如是等名色因缘人及天道欲色界中以彼处有名色二事。无色界中无二因缘

问曰。如来于彼城喻经中。大因缘等修多罗中说。依名色因缘于识。何故于此修多罗中而说依识因缘名色。答曰。名色因缘依识而有。此以何义。以实有识。名色与识迭共相因。而依识有有名色有如依所依。是故有依。此以何义。如王及臣迭共相依而王为胜。以王去时臣亦随去。此亦如是。识与名色迭共相依。而识为胜。是故依识而有名色。若识因缘不托母胎。诸心数法则不得有。以识托胎诸心数法皆亦随从。又因根本心成歌罗逻。以赤白等和合则能成歌罗逻。为成众生。彼处识心为根本因。如大因缘法门中说。佛告阿难若彼识心不托母胎。彼歌罗逻及名色等亦不成就。是故识为诸苦种子。为欲示现根本义故。是故唯说识缘名色。不说名色因缘于识

问曰。有人说言。十二因缘有于时节。彼人依识因缘名色义则不成。何以故。无因缘故。此以何义。为识灭已然后能作名色因缘。为识不灭能作因缘。若识灭已作名色因缘。此义不成。何以故。以灭种子不能与芽作生因缘故

又复有过。中间断绝众生体故。若识不灭能与名色作因缘者。一众生身于一念中。并有二识。以是义故。识不能作名色因缘。答曰。相续不断不绝。因缘如灯焰体相续不断。此以何义。如焰相续不断不绝。而能有用。非先焰灭而后焰生。若先焰灭从焰生者。是则灭已后时更生。又复有过。后焰生时无因而生又复有过。若无因生则应常生。又亦非是先生焰住后余焰生。若先焰住后焰生者。先焰便应第二念住。而佛法中无如是义。又复有过。先生之焰无因而生。又复有过。焰应增长。又复有过。应多焰生。又亦非即先焰住时更生余焰。何以故。不容受故。此以何义。随先生焰。以何等处何等因缘。即彼生处即彼因缘即先生焰即时俱谢。是故得容余焰余因缘。又复有过。前灯焰灭后灯焰生。不从无火因缘而生。此义不然。何以灯炷焰。前后次第不断不绝相续而生。如是识名色等。次第生灭能成因果应知。以是义故。依识因缘能生名色。因果义成。问曰。名色因缘有六入者。以何等因。答曰。以彼因故。何以故。以色清净因缘五入。以名清净因缘意入故。说名色因缘六入

问曰。若以名色缘六入者。此义不成。何以故。以虽有彼而无彼故。此以何义。歌罗逻等时虽有名色无六入等。以是义故。此义不成。又复所以此义不成。以众生有盲聋等故。此以何义。若名色能作六入因者。则不应有盲聋众生。一切悉应具足诸根。答曰。此义不然。何以故。不离彼有成犹如云雨。此以何义。如汝天雨若先有云后时雨者。非离云雨亦有。有云而无有雨。如是六入若有名色有六入者。非离名色复有名色而无六入

问曰。以何义故。有彼名色而无六入。答曰。以诸因缘不具足故。此以何义。犹如眼识如实有眼。以诸因缘不具足故不成眼识。又复犹如实有种子。以诸因缘不和合故不能成芽。此亦如是。歌罗逻等时中因缘不具足故。眼等诸入亦不具足

问曰。彼诸因缘云何具足。答曰。以烦恼业名色和合淳熟故成

问曰。云何得知烦恼亦是六入因缘。答曰。以阿罗汉不复生故。此以何义。以阿罗汉虽复有业而无烦恼。是故不生。以不生故无有六入。是故得知。烦恼亦是六入远因业。亦是彼六入因缘。何以故。以成盲等故。是故虽复实有烦恼随种类生。具六种业有盲聋等。是故知业亦六入因。又以十二入有种种故。此以何义。以入种种迭共不同。但一众生一身体中种种不同。何况种种众生身中诸业不同。家力色命皆悉不同。如是等以诸众生家力色等一切差别此皆依业。以是义故。彼业亦是六入因缘。名色亦是六入因缘。以彼六入依种子故。此以何义。以虽复有烦恼业等。名色种子生于六入。不离名色能生六入。如不离子而能生芽。是故得知近因名色生于六入。亦依彼业生于六入。何以故。以虽有彼而无彼故。此以何义。以虽复有烦恼业等。而彼名色不具成就。如歌罗逻等时中。无眼等入而依彼故。成就六入。如始结子终能成果。是故得知烦恼业等名色淳熟而能作彼六入因缘

问曰。汝说因缘犹不具足。何以故。是中不说外因缘故。此以何义。唯除声入名色等缘共六入生。若如是者。但说六入因缘不具足说名色因缘。此是过失。答曰。彼不须说。何以故。以二处见故。此以何义。以彼外入二处见故。以依众生摄依非众生摄。此以何义。此中但依众生次第说。彼十二因缘而不依彼非众生说十二因缘。是故但依众生所摄入说。不依非众生说。以是义故。此中但依众生所摄内因缘说。而非依彼外因缘说

问曰。若尔不应说于名色。此以何义。若如是者。名色有支中不应说名色。以色二处见故。答曰。实如所难。虽然若于彼处不说名色。但言以名缘六入者。如是不说五种色入。彼六入中色亦清净。非但名色入清净。此以何义。应说可见色等入缘。是故彼处亦说色名。以是故。说识因缘名名缘意入如是等。如是三时无有分别。是故如来于此中说。是名正说

问曰。何故不说外入因缘。答曰。说眼等者。是即成说。此以何义。此修多罗中具足成就说众生体。此复何义。随何等处眼等诸入彼处必有色等外入。何以故。以不远离色等境界有眼识等。以是义故。说眼等入则已摄得外色等入。是故不别说外入等。又以依内入得名字故。此以何义。依内入故得众生名非依外入。以是义故。唯说内入不说外入

问曰。何故名触。答曰。对到名触。问曰。此以何义。答曰。于念境界中识相对法故。以眼识等于彼色等诸境界中彼此相对。是名为触。复有触者近对和合到一处等名异义。一又和合生意地法故名为触

问曰。说触因缘犹不满足。以三种法和合因缘而生触故。此以何义。以有三法和合生触。佛如是说。此中唯说六入因缘而生于触。是故此中不具足说生触因缘。此是过咎。答曰。以说内因缘摄得外故如彼鼓声。此以何义。如人鼓桴和合生声唯说鼓声。如是三法和合生触。虽依内说而摄得外。是故无过。又不同义如种子芽。此以何义。如虽有时及地水等和合能作生芽因缘而说种子名为胜因。子能生芽是芽胜因。此是稻芽此是麦芽不说共因。触亦如是有不同义虽有三法和合故。生唯说内入不说共因。又以胜因故。此以何义。虽有三事和合生触。以依根能生而说内因。以彼胜故以依根故诸识能生。以盲聋等无识等故。以色等法识境界故。是故依根三法和合能生彼法。虽三法生而根是胜是故如来唯说胜法如说六入。又虽说六入而摄得三法和合成触。以说入名即说六识。以彼相随以说眼等入即摄色等入。何以故。不离色等入有眼等入。以是义故。如说六入此亦如是

问曰。六入缘触此是何因。答曰。以盲等人无眼等触余者有故。此以何义。以有眼等根有眼等触。离眼等根无眼等触。如盲等人唯有意识。此亦如是六入缘触

问曰。依触缘受此是何因。答曰。以乐受等境界和合有乐受等。此以何义。如人患热依热逼恼。求于雪冷摩尼珠等及以荫凉。又如有人依寒逼恼。求火求衣求温水等一切暖触

问曰。触缘受者。此义不然。何以故。共触生故。此以何义。触共受生。以是义故触缘受者此义不成。如两角共生右角不作左角因缘。左角不作右角因缘此亦如是。是故应依余因缘生非触因缘。又若共生而触能作受因缘者。以何义故。受不能与触为因缘。以受触生相应因故。答曰。虽复共生而一是因一非是因。此以何义。有二种法。虽复共生而有一法能作彼因。非第二法作彼法因。如明与焰虽复共生。焰是明因明非焰因。又如日与光二法共生。而日能与光明作因。光明不能与日作因。又如芽共生芽作影因影非芽因触亦如是。虽共受生触为受因受非触因。是疑已断。复有异义我此法中非触共生次第因缘。此以何义。我此法中非受与触一时俱生云何而生。依过去时即与后时受法作因次第缘生。此云何知以说一因。此以何义。以说依触因缘生受。不说依受因缘生触。此以何义。若此二法共俱生者。应说迭因。以是义故。说次第缘不说一时

问曰。依受缘爱此是何因。答曰。以受为因欲取乐故。而生于爱

问曰。若如是者苦不应生。答曰。以求离故。问曰。求乐受者见乐故求。不应求苦以不用故。答曰。虽不求苦而亦有爱。以不欲得彼苦受故。求欲离苦彼即是爱。是故苦受亦爱因缘。又乐受者欲爱因缘。苦受远离有爱因缘。此以何义。如人有苦依苦逼恼。不知无力为杀害身。以不求苦以不求乐而爱因缘。又依无明盲故取苦。如彼渴人闇夜饮于粪和合水。此亦如是。问曰。色等境界皆是爱缘。何故但说受为爱缘。答曰。为乐受故求彼色等。此以何义。乐受之生必有伴侣。以是义故。于色等法皆生爱心。受为胜因非色香等。是故但说受为爱因不说色等

问曰。取有何义。答曰。取近染着皆名为取。求于有支及资生等一切染着。以得染着不相舍离名之为取。此有四种。何者为四。欲取见取戒取我取。又欲取者贪于五欲境界功德。戒取触者。谓以持戒取三种见。见取身见及以我见。又执着我名为我取。彼人着我为我求乐。是故求彼五欲境界求诸天乐。或取欲见诸天苦行如是等法是名见取。若已求得五欲境界贪着彼法是名欲取。着未来世欲境界因不能远离五欲境界。如是持戒是名戒取。又着己身随顺二边是名见取。此义云何。若堕断边即便坚着五欲境界是名欲取。若堕常边贪着五欲为胜生处。如是持戒是名戒取。问曰。爱缘取者此是何因。答曰。不足爱故更求增长。如饮碱水转增长渴。又依爱故有四种取。此以何义。依爱缘故求于现在五欲境界。如经中说依爱因缘求于诸欲是名欲取。又依爱故求未来世五欲境界。为彼爱故起于持戒是名戒取。以彼但求五欲境界。若以求得五欲境界。不欲舍离求诸天故。好日祭祀是我所欲。如是着我名为我取。是名依爱因缘于取。问曰。以何等爱缘何等取。答曰。欲爱欲取有爱能取戒取我取离有支。爱能取见取。又复众生我爱见取生爱戒取受爱欲取。于一切取贪着见取。又四取中欲取戒取二取是爱余二以为无明根本

问曰。有义云何。答曰。此能生故。依此能生此能勤修依此法故能生余法。是故名有

问曰。依有缘生此是何因。答曰。依业有生如向前说。依行有识此中亦尔应具足说

问曰。烦恼亦是生支因缘。如经中说爱因能生。何故唯说有因缘生不说取缘。答曰。依胜生因故如是说。此以何义。此中唯说生法胜因。云何为胜。此是地狱此是人此是天。如是等此种种身业为近因而非烦恼。彼种种因复有已生。同类生中各有差别。谓家力色长寿短寿有病无病受用资生一切差别。此中亦尔业种种。故知是近因非烦恼也。是以说有因缘有生非取因缘

问曰。若有能作生因缘者。何以故。说有因缘生。而不说生因缘于有。答曰。以有定不定故。此以何义。以有有支必有生支。有生支者不必有有。犹如依彼第二谛故必有初谛。而不必因有初谛故有第二谛。若不尔者毕竟无有解脱因缘。是故说依有支因缘必有生支非生缘有

问曰。老者何义。答曰。消皱力减名之为老。有人说言。所谓老者以变异故。此义不成。何以故。以不住故。以有为行刹那不住。若有为行念念不住者。云何而言变异名老。又复有过。法若变者便应第二刹那中住。法若第二刹那住者非佛法义。又复有过。言变异者舍于实体。若即前法有变异者。彼法便应即舍本体。又若彼法不变异者。则不得言有变有异。若法不舍彼本体者。亦不得言变异名老。是故不得言有转变名为老也。先说老相彼是老义

问曰。心心数法云何知老。答曰。以见心法依止法异。所谓诸根四大损减思惟念薄忘失。所有诸法门等闻声不了见境界难见。如是等知心有老。问曰。死有何义。答曰。死者舍命终亡谢灭。异世去等是名为死。如是此死及先说老此二合故名老死支。又复有言。根四大等后时损减微细难别。是名为老破坏名死如柯渐尽。又四大破坏是名为老散尽名死。如朽故车破坏散尽。又于五阴随顺灭故是名为老灭名为死如故舍坏

问曰。生缘老死此有何义。答曰。坏彼法故得有此法。若无彼法亦无此法。此以何义。如初作瓶后时朽故。又先作瓶后时破坏。此亦如是有众生生后有老死。非是不生是故说依生缘老死。问曰。若生念中即时死者。彼中云何生缘老死。答曰。命灭。此以何义。彼处有命损现前命五阴灭故是名为老。犹如彼雨有云故雨。无云无雨。亦有有云而无有雨彼处亦尔

问曰。何故有为三相法中一处唯说生为生支。一处说老以为老支。答曰。随顺义故法欲生时生能随顺。法欲灭时老支随顺。又老死支随顺坏法。生支与彼老死相违。老死二法迭共随顺。言随顺者随顺破坏故名为老。死亦如是。是故老死合为一支。生者别支

问曰。何故不说忧等为支。答曰。不遍一切诸众生故。此以何义。忧等诸法不遍三界。以是义故不说为支

问曰。无明灭则行灭者有何次第。答曰。如来次第说。无明等十二因缘能生于有。以诸众生不能识知十二因缘堕断见故。如来次第说无明灭余亦皆灭。以诸众生不能见知无明因缘堕常见故。又如先说云何世间有以不见知十二因缘堕于无边。以是义故如来说。云何世间灭。以不见知何等法故堕于有边。以是义故。如来次说。如如来迦旃延经中说。又已说身见集谛道谛。未说身见苦谛灭谛是故欲说。又已说染谛未说净谛。又已说缚谛未说解脱谛。今欲说故是故说言无明灭行亦灭如是等

问曰。此诸因缘有于几种。答曰。略说四种。何者为四。一者有时十二因缘。二者刹那。三者次第。四者不断绝。时者到时名因缘时。此以何义。无明时者。谓过去时。生烦恼者是无明时。言行时者。过去时业是名行时。言识时者。谓托生心共眷属生是名识时。名色时者。未和合成即歌罗逻安浮陀枇尼坚支等。如是时中未生眼等五情诸根。六入未满彼时生体是名名色时。六入时者。以生眼等诸根满足。六入诸根未能有力。作彼心心数法依止。是名六入时。言触时者。随何等时诸根于彼心心数法能作依止。而不能作分别苦乐。亦不能作好恶诸事。未有胜行是名触时。言受时者。谓受苦乐分别苦乐。摄好恶事爱食非爱欲。资生等未有取力是名受时。言爱时者。爱欲资生行非分别有无是名爱时。言取时者。知有无分别求如是起是名取时。言有时者。求于此世未来世中五欲境界。追求推觅为未来生起种种业是名有时。言生时者。此生已退即次后生所托生处是名生时。老死时者。自此以后破坏诸根名老死时。言刹那者。名色等支名为刹那。以一念中具足一切十二有支。此义云何如人依止贪心杀生。彼处所有迷愚痴等名为无明。彼处所有相应思心是名为行。彼处所有相应意法是名为识。彼处所有共识生法相等。四大及依四大所生四尘如是等法名为名色。彼处所有依入作业而非离入名为六入。彼处所有相应对法是名为触。彼处所有相应觉者是名为受。彼处所有相应贪心是名为爱。彼处所有不舍爱心是名为取。彼处所有身口意业是名为有。彼处所有如是等法所起之法是名为生。彼处所有诸法变异是名为老。彼处所有诸法散灭是名为死。有次第者无始义故。此以何义。以彼因果不断绝故。以是义故不知其始。不断绝者。以彼因因不断绝故。此以何义远来义故。又复非但十二有支能生因缘。以彼一切有为诸法名为因缘

问曰。深心等法有何次第。答曰。以成就一切胜功德故。以一切法中不失菩提心以为根本故。此以何义。于诸菩萨摩诃萨修行功德中。说彼深心以为根本。以诸菩萨成就深心。以为不失菩提心因。如深心诸行亦尔。自然为欲利益一切众生修行。是以如来为欲示现如实修行次第义故。说深心后次说行心

又以菩萨成就深心成就行心。然后于他利益修行。为欲示现如是胜义。说修行后次说成就舍心。又以菩萨持戒布施等如实修行相回向胜法。依如是义示现修行助菩萨道。是故次说成就回向。又从持戒乃至回向非定善根。次欲示现胜三昧法。欲令众生住慈悲等诸善根中。以是义故。说回向后次说成就大慈悲等。已置定法妙乐善根为欲离彼贪着心故。说慈悲后次说方便。以有方便故有智慧明见诸法。以是义故不堕声闻辟支佛地入菩萨位。是故如来说方便后次说成就般若波罗蜜

又复略说成就深心乃至方便。示现成就助道功德。究竟成就般若波罗蜜者。示现成就助道智慧

又成就深心乃至方便示现成就菩提功德道。究竟成就般若波罗蜜示现成就菩提智慧道

又成就深心乃至回向。示现成就戒身。慈悲二法示现成就定身。方便般若示现成就慧身

又成就深心即是示现成就直心。自余七句示现成就修行

又成就深心成就行心示现戒家。成就舍心成就回向。示现施家。成就大慈成就大悲。示现灭家。成就方便成就般若波罗蜜。示现智家。如是有碍无碍等一切诸法。诸余一切修多罗中广说应知。此修多罗依诸菩萨摩诃萨学戒义说。如是诸菩萨摩诃萨八万四千无量无边诸法门等。皆应类知

弥勒菩萨所问经论卷第九此经旧为六卷。开元录作五卷。子注或七卷。或十卷。据此今开初卷为二总为七卷。即释大宝积经第四十一会是也


妙法莲华经论优波提舍

    No. 1520 [No. 1519]

妙法莲华经论优波提舍

        婆薮般豆菩萨造

        元魏中天竺三藏勒那摩提共僧朗等译

如是我闻。一时佛住王舍城耆阇崛山中。与大比丘众万二千人俱。皆是阿罗汉。诸漏已尽无复烦恼。心得自在善得心解脱善得慧解脱。心善调伏人中大龙。应作者作所作已办离诸重担。逮得己利尽诸有结。善得正智心解脱一切。心得自在到第一彼岸。菩萨摩诃萨八万人。皆于阿耨多罗三藐三菩提不退转。皆得陀罗尼大辩才乐说。转不退法轮。供养无量百千诸佛。于诸佛所种诸善根。常为诸佛之所称叹。以大慈悲而修身心。善入佛慧通达大智到于彼岸。名称普闻无量世界。能度无数百千众生。此法门中初第一品明七种功德成就。何等为七。一者序分成就。二者众成就。三者如来欲说法时至成就。四者所依说法随顺威仪住成就。五者依止说因成就。六者大众现前欲闻法成就七者文殊师利答成就。又序分成就者。此法门示现二种义成就。何等为二。一者示现一切诸法门中最胜成就故。二者示现自在功德成就故。如王舍城。胜余一切城舍故。耆阇崛山胜余诸山故。如经如是我闻一时佛住王舍城耆阇崛山中故。众成就者。有四种义成就。何等为四。一者数成就。二者行成就。三者摄功德成就。四者威仪如法住成就。数成就者。谓大众无数故。行成就者有四种。一者诸声闻修小乘行。二者诸菩萨修大乘行。三者诸菩萨随时示现能行大乘。如颰陀婆罗等十六人。具足菩萨不可思议事。而能示现种种形相。优婆塞优婆夷比丘比丘尼等故。四者出家人威仪一定。不同菩萨故。皆是阿罗汉等者十六句。示现声闻功德成就故。皆不退转阿耨多罗三藐三菩提等者十三句。示现菩萨功德成就故。阿罗汉功德成就者。彼十六句示现三种门摄义应知。何等三门。一者上上起门。二者总别相门。三者摄取事门。上上起门者。谓诸漏已尽故名为罗汉。以心得自在故名诸漏已尽。诸漏已尽故名为阿罗汉。以心无烦恼故。名心得自在。以善得心解脱善得慧解脱故。名心得自在。以远离能见所见故。名无复烦恼。已善得心解脱慧解脱故。名心善调伏。人中大龙者。行诸恶道如平坦路无所拘碍。应行者已行。应到处已到故。应作者已作。人中大龙已尽对治。降伏烦恼怨敌故。所作已办者。更不后生。如相应事已成故。离诸重担者已应作者作。所作已办。后生重担已舍故。逮得己利者。已舍重担证涅槃故。尽诸有结者。已逮得己利断诸烦恼因故。善得正智心解脱者。诸漏已尽故。一切心得自在者。善知见道修道智故。到第一彼岸者。善得正智心得解脱善得神通无诤三昧等诸功德故。大罗汉等者。心得自在。到彼岸故。众所知识者。诸王王子大臣帝释梵天王等皆识知故。复声闻菩萨佛等。是胜智。彼胜智者。皆善知故。名众所知识。总别门者。皆是罗汉等十六句。初句总余句别故。皆是罗汉者。彼罗汉名有十五种义应知。一者应受饮食卧具供养恭敬等故。二者应将大众教化一切故。三者应入聚落城邑等故。四者应降伏诸外道等故。五者应以智慧速观察法故。六者应不疾不迟说法。如法相应不疲惓故。七者应静坐空闲处。饮食衣服一切资生。不积不聚少欲知足故。八者应一向行善行不着诸禅故。九者应行空圣行故。十者应行无相圣行故。十一者应行无愿圣行故。十二者应降伏世间禅净心故。十三者应起诸通胜功德故。十四者应证第一义功德故。十五者应如实知同生众得诸功德。为利益一切众生故。摄取事门者。此十五句。摄取十种功德。示现可说果不可说果故。一者摄取得功德二句示现。如经诸漏已尽无复烦恼故。二者三句摄取诸功德。一句降伏世间功德。如经心得自在故。二句降伏出世间学人功德。如经善得心解脱善得慧解脱故。三者摄取不违功德。随顺如来教行故。如经心善调伏故。四者摄取胜功德。如经人中大龙故。五者摄取所应作胜功德。所应作者。依法供养恭敬尊重如来故。如经应作者作故。六者摄取满足功德满足学地故。如经所作已办故。七者三句摄取过功德。一者过受故。二者过求命供养恭敬故。三者过上下界已过学地故。如经离诸重担。逮得己利尽诸有结故。八者摄取上上功德。如经善得正智心解脱故。九者摄取应作利益众生功德。如经一切心得自在故。十者摄取上首功德。如经到第一彼岸故彼诸菩萨十三句功德二门摄应知。一者上支下支门。二者摄取事门。上支下支门者。所谓总相别相应知。皆于阿耨多罗三藐三菩提不退转者。是总相。余者是别相。彼不退转有十种示现。一者住闻法不退转。如经皆得陀罗尼故。二者乐说不退转。如经大辩才乐说故。三者说不退转。如经转不退法轮故。四者依止善知识不退转。以身心业依色身摄取故。如经供养无量百千诸佛故。于诸佛所种诸善根故。五者断一切疑不退转。如经常为诸佛之所称叹故。六者为何等何等事说法。入彼彼法不退转。如经以大慈悲而修身心故。七者入一切智如实境界不退转。如经善入佛慧故。八者依我空法空不退转。如经通达大智故。九者入如实境界不退转。如经到于彼岸故。十者应作所作住持不退转。如经能度无量百千众生故

摄取事门者。示现诸菩萨住。何等清净地中。因何等方便何等境界中。应作所作故。地清净者。八地已上三地无相行寂静清净故。方便者有四种。一者摄取妙法方便住持妙法。以乐说力为人说故。二者摄取善知识方便。以依善知识所作应作故。三者摄取众生方便。以不舍众生故。四者摄取智方便。以教化众生令入彼智故。境界者易解。复有摄取事门。示现诸地。摄取胜功德。不同二乘功德故。八地者。无功用智不同下上故。不同下者。下功用行不能动故。不同上者。上无相行不能动自然而行故。于九地中。得胜进陀罗尼门具足四无碍自在故。于第十地中不退转法轮得佛受位。如转轮王子故。以得同摄功德故。摄功德成就者。示现依何处依何心依何智依何境界行依何等能办故。依何处者。依善知识故。依何心者。我依众生心教化。毕竟利益一切众生故。依何智者。依三种智。一者授记密智。二者诸通智。三者真实智。依何等境界行依何等能办者。即三种智摄应知。威仪如法住成就者。有四种示现。何等为四。一者四众围绕。二者前后。三者供养恭敬。四者尊重赞叹。如经尔时世尊四众围绕供养恭敬尊重赞叹故。如来欲说法时至成就者。为诸菩萨说大乘经故。此大乘修多罗有十七种名。显示甚深功德应知。一名无量义经者。成就字义故。以此法门说彼甚深妙境界法故。甚深妙境界者。诸佛如来最胜境界故。二名最胜修多罗者。三藏中最妙胜藏成就故。三名大方广者。无量大乘门随众生根住持成就故。四名教菩萨法者。为教化根熟菩萨。随器法成就故。五名佛所护念者。依佛如来有此法故。六名一切诸佛秘密法者。此法甚深如来知故。七名一切佛藏者。如来功德三昧之藏在此经故。八名一切诸佛密处者。根未熟众生非法器不与故。九名能生一切诸佛者。闻此法门能成佛菩提故。十名一切诸佛道场者。闻此法门能成阿耨多罗三藐三菩提。非余修多罗故。十一名一切诸佛所转法轮者。此法门能破一切诸障故。十二名一切诸佛。坚固舍利者。谓如来真如法身。于此修多罗不坏故。十三名一切诸佛大巧方便经者。依此法门成大菩提。已为众生说天人声闻辟支佛等法故。十四名说一乘经者。此法门显示如来阿耨多罗三藐三菩提究竟之体。二乘非究竟故。十五名第一义住者。此法门即是如来法身究竟住处故。十六名妙法莲华者。有二种义。何等二种。一者出水义。不可尽出离。小乘泥浊水故。复有义。莲华出泥水。喻诸声闻入如来大众中坐。如诸菩萨坐莲华上。闻说无上智慧清净境界。证如来密藏故。二华开者。众于大乘中心怯弱不能生信故。开示如来净妙法身。令生信心故。十七名法门者。摄成就故。摄成就者。摄取无量。名句字身。频婆罗阿閦婆等偈故。此十七句法门者是总。余句是别故。如经为诸菩萨说大乘经名无量义。如是等所依说法随顺威仪住成就者。示现依何等法说法。依三种法故。一依三昧成就故。以三昧成就二种示现。何等为二。一者成就自在力身心不动故。二者离一切诸障。随自在力故。此自在力有二种。一者为随顺众生示现对治摄取觉菩提分法故。二者为对治无量世来坚执烦恼故。如经说此经已结跏趺坐入于无量义处三昧等。二依器世间。三依众生世间。震动世界及知过去无量劫事等故。如经是时天雨曼陀罗华乃至欢喜合掌一心观佛故

依止说因成就者。彼诸大众现见异相不可思议事。如来应为我说。渴仰欲闻生希有心。名依止说因成就。是故放大光明。示现诸世界中种种事故。先示现外事六种震动等。次示现此法门内证深密法故。又依器世间众生世间数种种量种种具足烦恼差别具足清净差别佛法弟子差别。示现三宝故。复乘差别。有世界有佛有世界无佛。令众生见修行者。未得果得道者已得果。如经诸修行得道者故。数种种者。示现种种观故。略说四种观。一者食。二者闻法。三者明修行。四者乐。如经尔时佛放眉间白毫相光乃至以佛舍利起七宝塔故。行菩萨道者。教化众生依四摄法方便摄取应知。如经中说当推取

自此以下示现大众。现前欲闻法成就问一人多人欲闻生希有心。是故唯问文殊师利。如是示现世尊弟子随顺法不相违故。今佛世尊现神变相者。为何等义。为现大相因故。为大相者。为说妙法莲华经故现大瑞相。为说所得妙法不可思议等文句故。有二种法故推文殊师利。一者现见诸法。二者离诸因缘。自心成就彼法故。示现种种瑞相者。示现彼彼事如彼事现没住灭应知。以文殊师利能记彼事故。以文殊师利所作成就因果成就。现见彼法故。所作成就者有二种。一者功德成就。二者智慧成就。因成就者一切智成就。因缘者相也。果者说大法。种种佛国土者。示现彼国土中种种差别应知。净妙国土者。无烦恼众生住处故。如经照于东方万八千世界乃至悉见彼佛国界庄严故。如来为上首者。诸菩萨等。依如来住故。以如来于彼国土一切大众中得自在故。如经又见彼土现在诸佛如是等故

自此以下明圣者。文殊师利菩萨。以宿命智现见过去因果相。成就十种事如现在前。是故能答弥勒。现见过去因相者。自见己身于彼诸佛国土中修种种行事故。现见过去果相者。文殊师利自见己身。是过去妙光菩萨。于彼佛所闻此法门为众生说故。成就十种事者。何等为十。一者现见大义因成就。二者现见世间文字章句甚深意因成就。三者现见希有因成就。四者现见胜妙因成就。五者现见受用大因成就。六者现见摄取一切诸佛法轮因成就。七者现见善坚实如来法轮因成就。八者现见能进入因成就。九者现见忆念因成就。十者现见自身所经事因成就。大义因成就者。八句示现应知。一者欲转大法轮。二者欲雨大法雨。三者欲击大法鼓。四者欲建大法幢。五者欲然大法灯。六者欲吹大法蠡。七者欲不断大法鼓。八者欲说大法。此八句示现如来欲说大法等故。何等为八种大义。谓疑者断疑故。已断疑者增长淳熟智身故。根熟者为说二种密境界。谓声闻密境界。菩萨密境界。大法鼓二句示现以远闻故。入密境界者。令进取上上清净义故。取上上清净义者。进取一切智现见故。取一切智现见者。为一切法建立名字章句义故。建立名字章句义者。令入不可说证智转法轮故。现见世间名字章句意甚深因成就故。如经我于过去诸佛曾见此瑞乃至故。现斯瑞故。现见希有因成就者。无量时不可得故不可思议不可称不可量者。示现过彼阿僧祇劫不可得故。复示现五种劫。一者夜。二者昼。三者月。四者时。五者年。示现彼无量无边劫故。如经如过去无量无边不可思议阿僧祇劫。尔时有佛号日月灯明。乃至得阿耨多罗三藐三菩提。成一切种智故现见胜妙因成就者。以诸佛菩萨自受用示现故。如经次复有佛亦名日月灯明。乃至所可说法初中后善故。现见受用大因成就者。是时王子受胜妙乐各舍出家。复彼大众于尔许时。不生疲惓心故。如经其最后佛未出家时乃至佛授记已便于中夜入无余涅槃故。现见摄取一切诸佛转法轮因成就者。法轮不断故。如经佛灭度后妙光菩萨持妙法莲华经。满八十小劫为人演说故。现见坚实如来法轮因成就者。佛灭度后无量时说法故。如经日月灯明佛八子皆师妙光乃至皆令其坚固阿耨多罗三藐三菩提故。现见进入因成就者。彼诸王子得大菩提故。如经是诸王子乃至皆成佛道故。现见忆念因成就者。为他说法利益他故。如经其最后成佛者名曰然灯。乃至尊重赞叹故。现见自身所经事因成就者。以自身受胜妙乐故。如经弥勒当知。乃至佛所护念故。汝号求名者示现。知过去事故。复示现得彼法具足故

    方便品第二

尔时世尊入甚深三昧正念不动。以如实智观。从三昧安详而起。起已告舍利弗。诸佛智慧甚深无量。其智慧门难见难觉难知难解难入如来所证一切声闻辟支佛所不能知。何以故。舍利弗。如来应正遍知。已曾亲近供养无量百千万亿那由他佛。于诸佛所。尽行诸佛所修阿耨多罗三藐三菩提法。舍利弗。如来已于无量百千亿那由他劫。勇猛精进所作成就名称普闻。舍利弗。如来毕竟成就希有之法。舍利弗。难解之法如来能知。舍利弗。难解法者。诸佛如来随宜所说意趣难解。一切声闻辟支佛所不能知。何以故。舍利弗。诸佛如来。自在说因成就故。舍利弗。如来成就种种方便种种知见种种念观种种言辞。舍利弗。吾从成佛已来。于彼彼处广演言教。无数方便引导众生。于诸着处令得解脱。舍利弗。如来知见方便到于彼岸。舍利弗。如来知见广大深远。无障无碍力无畏。不共法根力菩提分禅定解脱三昧三摩跋提皆已具足。舍利弗。诸佛如来深入无际。成就一切未曾有法。舍利弗。如来能种种分别巧说诸法言辞柔软悦可众心。止舍利弗。不须复说舍利弗。佛所成就第一希有难解之法。舍利弗。唯佛与佛说法。诸佛如来能知彼法究竟实相。舍利弗。唯佛如来知一切法。舍利弗。唯佛如来能说一切法。何等法云何法何似法何相法何体法。何等云何何似何相何体。如是等一切法。如来现见非不现见

论曰。自此已下。示现所说法因果相应知。如经尔时世尊入甚深三昧正念不动以如实智观从三昧安详而起。起已告舍利弗者。示现如来得自在力故。如来入定无能惊寤故。何故告舍利弗。不告余声闻等。随深智慧与如来相应故。何故不告诸菩萨。有五种义。一者为诸声闻所作事故。二者为令声闻回趣大菩提故。三者护诸声闻恐怯弱故。四者为令余人善思念故。五者为诸声闻不起所作已办心故。诸佛智慧甚深无量者。为诸大众生尊重心。毕竟欲闻如来说故。甚深者显示二种甚深义应知。何等为二。一者证甚深。谓诸佛智慧甚深无量故。二者阿含甚深。谓智慧门故。甚深者是总余者是别。证甚深者有五种一者义甚深依何等义甚深故。二者实体甚深。三者内证甚深。四者依止甚深。五者无上甚深。甚深者。谓大菩提故。大菩提者。如来所证阿耨多罗三藐三菩提故。又甚深者。一切声闻辟支佛所不能知故。智慧者。谓一切种一切智智义故。如经诸佛智慧甚深无量其智慧门难见难觉难知难解难入一切声闻辟支佛所不能知故。智慧门者。谓说

阿含义甚深者。示现有八种。一者受持读诵甚深。如经舍利弗如来应正遍知已曾亲近供养无量百千万亿那由他佛故。二者修行甚深。如经于诸佛所。尽行诸佛所修阿耨多罗三藐三菩提法故。三者果行甚深。如经舍利弗如来已于无量百千亿劫勇猛精进所作成就故。四者增长功德心甚深。如经名称普闻故。五者快妙事甚深。如经成就希有法故。六者无上甚深。如经舍利弗难解之法如来能知故。七者入甚深。入甚深者。名字章句意难得。自在住持不同外道。说因缘法名为甚深。如经舍利弗难解法者。诸佛如来随宜所说意趣难解故。八者不共声闻辟支佛所作住持甚深。如经一切声闻辟支佛所不能知故

如是说妙法功德。已次说如来法师功德成就应知。如经何以故。诸佛如来自在说因成就故。如来成就四种功德故能度众生。何等为四。一者往成就。如经。如来成就种种方便故。种种方便者。从兜率天退乃至示现入涅槃故。二者教化成就。如经种种知见故。种种知见者。示现染净诸因故。三者功德毕竟成就。如经种种念观故。种种念观者。以说彼法成就因缘如法相应故。四者说成就。如经种种言辞故。种种言辞者。以四无碍。依何等何等名字章句。随何等何等众生。能受为说故。复有义种种方便者。示现外道邪法。如是如是种种过失故。示现诸佛正法。如是如是种种功德故。如经吾从成佛已来广演言教无数方便引导众生于诸着处令得解脱故。复无数方便者。方便令入诸善法故。复方便者断诸疑故。复方便者。令入增上胜智故。复方便者。依四摄法摄取众生令得解脱故。诸著者彼处处着。或着界或着诸地或着分或着乘故。着界者。着欲色无色界故。着地者。着戒取三昧初禅定地乃至非非想及灭尽定地故。着分者。着在家出家分故。着在家分者。着已同类作种种业邪见等故。着出家分者。著名闻利养种种诸觉烦恼等故。着乘者。着声闻乘菩萨乘故。着声闻乘者。乐持小乘戒。求须陀洹斯陀含阿那含阿罗汉等故。着大乘者。着利养供养恭敬等。着分别观种种法相乃至佛地故复种种知见者。自身成就不可思议境界。与声闻菩萨故。如经舍利弗如来知见方便到于彼岸故。到彼岸者。胜余一切诸菩萨故。复种种念观者。如经舍利弗如来知见广大深远无障无碍力无畏不共法根力菩提分禅定解脱三昧三摩跋提皆已具足故。又第一成就可化众生。依止善知识成就故。第二成就根熟众生。令得解脱故。第三成就力家得自在净降伏故。第四说成就者有七种。一者种种成就。如经舍利弗诸佛如来深入无际成就一切未曾有法故。二者言成就。得五种美妙音声说法。如经如来能种种分别巧说诸法言辞柔软悦可众心故。三者相成就。如经止舍利弗不须复说故。有法器众生心已满足故。四者堪成就。一切可化众生。知如来成就第一希有功德能说法故。如经舍利弗佛所成就第一希有难解之法故。五者无量种成就说不可尽。如经舍利弗唯佛与佛说法诸佛如来能知彼法究竟实相故。实相者。谓如来藏法身之体不变故。六者觉体成就。如来所说一切诸法。如来自证得故。如经舍利弗唯佛如来知一切法故。七者随顺众生意。为说修行法成就彼法何等如是等。如经舍利弗唯佛如来能说一切法故。第一种种法门摄取众生故。第二令不散乱住故。第三令取故。第四令得解脱故。第五令彼修行成就得对治法故。第六能令修行进趣成就故。第七令得修行不失故。此七种法为诸众生。自身所作成就故。又与教化成就者。依证法故。又说成就者。依说法故。此二种法如向前说。依此二种法有何次第而得修行。即彼前文句再说应知

又依证法有五种。一者何等法。二者云何法。三者何似法。四者何相法。五者何体法故。何等法者。声闻法辟支佛法佛法故。云何法者。起种种事说故。何似法者。依三种门得清净故。何相法者。三种义一相法故。何体法者。无二体故。无二体者。无量乘唯一佛乘无二乘故。复有义。何等法者。谓有为法无为法。云何法者。谓因缘法非因缘法等。何似法者。谓常法无常法如是等。何相法者。生等三相法不生等三相法。何体法者。谓五阴体非五阴体。又何似法者。谓无常法有为法因缘法。又何相法者。谓可见相等法。又何体法者。谓五阴能取可取。五阴是苦集体故。五阴者是道谛体。复有依说法。何等法者。谓名句字身故。云何法者。依如来所说法故。何似法者。能教化可化众生故。何相法者。依音声取故。以依音声取彼法故。何体法者假名体法相故

自此以下依三种义示现。一者决定义。二者疑义。三者依何事疑义。决定义者。有声闻方便证得深法作决定心。于声闻道中。得方便涅槃证故。如是三种证法示现有为无为法故。如经尔时大众中有诸声闻漏尽阿罗汉乃至亦得此法到于涅槃故。疑义者。谓声闻辟支佛不能知故。是故生疑。如经而今不知是义所趣故。依何事疑者。如来说声闻解脱与我解脱不异。是故生疑。生疑者生因中疑。此云何云何如来数数说甚深境界。前说甚深后说甚深不同声闻。如是等是故生疑。如经尔时舍利弗知四众心疑乃至而说偈言故。自此已下依四种事说。一者决定心。二者因受记。三者取受记。四者与授记应知。云何决定心。已生惊怖者令断惊怖。为利益二种人故。如来有决定心。此惊怖有五种应知。一者损惊怖。如所闻声取以为实。谤无大乘而作是言。如来说言阿罗汉究竟涅槃。我毕竟取如是涅槃。是故罗汉不入涅槃故。二者多事惊怖。以大乘众生生如是心。我无量无边劫行菩萨行。生惊怖心起取异乘心故。三者颠倒惊怖。分别我我所身见不善法故。四者悔惊怖。悔惊怖者。谓大德舍利弗等我不应证如是小乘法自止。即此悔心名为惊怖应知。五者诳惊怖。谓增上慢声闻作如是心。云何如来诳于我等故。因授记者。如经止止舍利弗不须复说若说是事一切世间诸天人等皆生惊怖故。因授记生惊怖者。有三种义。一者欲令彼大众推觅甚深境界故。二者欲令大众生尊重心。毕竟欲闻故。三者为令增上慢声闻离法座而去故。第二请示现过去无量佛教化众生。如经是会无数乃至闻佛所说则能敬信故。第三请示现现在佛教化众生。如经今此会中如我等比乃至长夜安隐多所饶益故。取授记者。以舍利弗等欲得授记。如经告舍利弗汝以三请岂得不说汝今谛听如是等故。与授记者。有六种应知。一者未闻令闻。二者说。三者依何等义。四者令住。五者依法。六者遮未闻令闻者。如经舍利弗如是妙法诸佛如来时乃说之如优昙华如是等。说者。如经舍利弗我以无数方便种种因缘譬喻言辞演说诸法如是等。种种因缘者。谓三乘。彼三乘者。唯名字章句说非有实义故。以彼实义不可说故

依何等义者。如经舍利弗诸佛世尊唯以一大事因缘故出现于世如是等故。彼一大事者。依四种义应知。何者为四。一者无上义。除一切智智更无余事。如经欲开佛知见令众生知得清净故出现于世。佛知见者如来能证如实知彼义故。二者同义。以声闻辟支佛佛法身平等故。如经欲示众生佛知见故出现于世故。法身平等者。佛性法身更无差别故。三者不知义。以一切声闻辟支佛不知彼真实处故。不知真实处者。不知究竟唯一佛乘故。如经欲令众生悟佛。知见故出现于世。四者为令证不退转地示现与无量智业故。如经欲令众生入佛知见道故出现于世。又示者。为诸菩萨有疑者。令知如实修行故。又悟入者。未发菩提心者令发心故。已发心者令入法故。复悟者令外道众生生觉悟故。复入者。令得声闻果者入大菩提故。令住者。如经舍利弗如来但以一佛乘故。为众生说法。依法者。如经舍利弗过去诸佛以无量无数方便种种譬喻因缘念观方便说法是法皆为一佛乘故。如是等譬喻者。如依牛有乳酪生酥熟酥醍醐。醍醐为第一。小乘如乳。大乘如醍醐故。此譬唯明大乘无上。诸声闻等亦同大乘无上故。声闻同者。示诸佛如来法身之性同。诸凡夫声闻辟支佛等。法身平等无差别故。此譬喻示现因缘如向说。念观者。于小乘谛中人无我等。于大乘谛中真如法界实际。人无我法无我等观故。方便者。小乘中观阴界入。厌苦离苦得解脱故。于大乘中修诸波罗蜜。四摄法摄取自身他身利益对治法故。遮者。如经舍利弗十方世界中尚无二乘何况有三如是等故。无二乘者。无二乘涅槃。唯佛如来证大菩提。究竟满足一切智慧。名大涅槃。非诸声闻辟支佛等有涅槃法。唯一佛乘故。一佛乘者。依四种义说应知。如来依此六种授记。是故前说何等法云何法何似法何相法何体法如是示现何等法者。谓未曾闻故。云何法者。谓种种言语譬喻说故。何似法者。唯为一大事故。何相法者。为随众生器说佛法故。何体法者。唯一乘体故。一乘体者。谓诸佛如来平等法身。声闻辟支佛乘。非彼平等法身之体。以因果行观不同故

自此已下说法为断四种疑应知。何等四种。一者何时说。二者云何知增上慢。三者云何堪说。四者云何不成妄语。何时说者。诸佛如来于何等时。起种种方便说法为断彼疑。如经佛告舍利弗诸佛出于五浊恶世所谓劫浊等故。云何知增上慢者。如来不为增上慢人说法。云何知彼是增上慢为断彼疑。如经若有比丘实得阿罗汉者若不信是法无有是处等故。云何堪说者。从佛闻法而起谤心。云何如来不成不堪说法人为断此疑。如经除佛灭度后现前无佛如是等故。云何不成妄语者。如来先说法异今说法异。云何如来不成妄语为断此疑故。如经舍利弗汝等当一心信解受持佛语诸佛如来言无虚妄无有余乘唯一佛乘故。乃至童子戏聚沙为佛塔如是诸人等皆已成佛道者。谓发菩提心行菩萨行者。所作善根能证菩提。非诸凡夫及决定声闻未发菩提心者之所能得故。如是乃至小低头等。亦如是

    譬喻品第三

舍利弗说偈

  金色三十二　　十力诸解脱
  同共一法中　　而不得此事
  八十种妙好　　十八不共法
  如是等功德　　而我皆已失

此偈示现何义。舍利弗自呵责身。我不见诸佛不往佛所。闻法不供养恭敬诸佛。无利益众生事。未得法退。是故舍利弗呵责自身。不见者。不见诸佛如来大人相生恭敬供养心故。往者。示现教化众生力故。放金色光明者。见佛自身异身得无量功德故。闻者。能作利益一切众生故。力者。众生有疑。依十力断疑故。供养者。示现教化众生力故。十八不共法者。远离诸障碍故。恭敬者。生无量福德。依如来教得解脱故。人无我法无我。一切法平等故。是故舍利弗自呵责身。我未得如是法。于未得中退故。自此已下。为七种具足烦恼性众生。说七譬喻。对治七种增上慢应知。又三种染无烦恼人三昧解脱见等染慢。对治此故说三平等应知。何者七种具足烦恼性人。一者求势力人。二者求声闻解脱人。三者求大乘人。四者有定人。五者无定人。六者集功德人。七者不集功德人。七种增上慢者。颠倒求功德增上慢。以世间诸烦恼炽然。而求天人妙境果报。对治此故。说火宅譬喻应知。声闻人一向增上慢。我乘与如来乘无差别。如是颠倒取。对治此故说穷子譬喻应知。大乘人一向增上慢。无别声闻辟支佛乘。颠倒取。对治此故说雨譬喻应知。实无而有。增上慢人。以有世间三昧三摩跋提。实无涅槃而生涅槃想。对治此故说化城譬喻应知。散乱心实无有定过去。有大乘善根而不觉知。彼不求大乘。于狭劣心中生虚妄解。以为第一乘。对治此故说系宝珠譬喻应知。有功德人说大乘法而取非大乘。对治此故说王解髻中明珠与之譬喻应知。无功德人于第一乘不集诸善根。说第一乘不取为第一。对治此故说医师譬喻应知。第一人者。以世间种种善根三昧功德方便令戏后令入涅槃故。第二人者。以三为一令入大乘故。第三人者。令知种种乘诸佛如来平等说法。随众生善根种子生芽故。第四人者。方便令入涅槃城故。涅槃城者。诸禅三昧城。过彼城已令入大涅槃城故。第五人者。示过去善根令忆念。教入三昧故。第六人者。说大乘法。以此法门。同十地行满。诸佛如来密与授记故。第七人者。根未熟为令熟故。示现涅槃量。为是义故。如来说此七种譬喻。何者三种无烦恼人。染慢颠倒信故。一者信种种乘异。二者信世间涅槃异。三者信彼此身异。为对治此三种染。说三种平等应知。一者乘平等与声闻授记。唯有大乘无二乘故。二者世间涅槃平等。以多宝如来入涅槃。世间涅槃平等故。三者身平等。多宝如来已入涅槃。复示现身自身他身法身平等无差别故。是无烦恼人。染慢见彼此身所作差别。以不知彼此佛性法身平等故。即彼人我证此法彼人不得。对治此故。与诸声闻授记应知。彼声闻等为实成佛故与授记。为不成佛与授记也。若实成佛者。菩萨何故于无量劫。修集无量功德。若不成佛者。云何虚妄授记。彼声闻授记者。得决定心非成就法性故。如来依三平等。说一乘法故。以如来法身与彼声闻法身无异故与授记。非即具足修行功德故。是故菩萨功德具足。诸声闻人功未具足。言授记者有六处示现。五者如来记。一者菩萨记。如来记者。舍利弗摩诃迦叶等众所知识故。名号不同故与别记。富楼那等五百人千二百人等。同一名故俱时与记。学无学等俱同一号。非众所知识故一时与记。与提婆达多记者。示现如来无怨故。与比丘尼及诸天女记者。示现女人在家出家修菩萨行者皆证佛果故。菩萨授记者。如不轻菩萨品示现。礼拜赞叹言。我不轻汝。汝等皆当作佛者。示诸众生皆有佛性故。言声闻授记者。声闻有四种。一者决定声闻。二者增上慢声闻。三者退菩提心声闻。四者应化声闻。二种声闻如来与授记。谓应化声闻。退已还发菩提心者。决定增上慢二种声闻根未熟故。如来不与授记。菩萨与授记。菩萨授记者。方便令发心故

又依何义故。如来说三乘名为一乘。依同义故与诸声闻授记。同义者。以如来法身声闻法身平等无差别故。以声闻辟支佛异乘故。有差别。以彼非大乘故。如来说言不离我身是无上义。一切声闻辟支佛法中不说此义。以不能解故。是故诸菩萨行菩萨行非为虚妄。无上义者。余残修多罗明无上义。无上义有十种应知。一者示现种子无上故。说雨譬喻。汝等所行是菩萨道者。谓发菩提心退已还发者。前所修行善根不灭。同后得果故。二者示现行无上故。说大通智胜如来本事等故。三者示现增长力无上故。说商主譬喻。四者示现令解无上故。说系宝珠譬喻。五者示现清净国土无上故。示现多宝如来塔。六者示现说无上故。说髻中明珠譬喻。七者示现教化众生无上故。地中踊出无量菩萨摩诃萨等故。八者示现成大菩提无上者。示现三种佛菩提。一者应化佛菩提。随所应见而为示现故。如经皆谓如来出释氏宫去伽耶城不远坐于道场得阿耨多罗三藐三菩提故。二者报佛菩提。十地行满足得常涅槃证故。如经善男子我实成佛已来无量无边百千万亿那由他劫故。三者法佛菩提。谓如来藏性净涅槃常恒清凉不变故。如经如来如实知见三界之相乃至不如三界见于三界故。三界相者。谓众生界即涅槃界。不离众生界有如来藏故。无有生死若退若出者。谓常恒清凉不变故。亦无在世及灭度者。谓如来藏真如之体。不即众生界不离众生界故。非实非虚非如非异者。谓离四种相故。有四种相者是无常故。不如三界见三界者。如来能见能证真如法身。凡夫不见故。是故经言如来明见无有错谬故。我本行菩萨道今犹未满者。以本愿故。众生界未尽愿非究竟故。言未满者。非谓菩提不满足故。所成寿命复倍上数者。示现如来常命方便显多数过上数量不可数知故。我净土不毁而众见烧尽者。报佛如来真实净土第一义谛摄故。九者示现涅槃无上故。说医师譬喻。十者示现胜妙力无上故。说余残修多罗应知。多宝如来塔。显示一切佛土清净者。示现诸佛实相境界中种种间错庄严故。塔者。示现如来舍利住持故。量者。方便示现一切佛国土清净。出世间无漏善根所生。非是世间有漏。善所生故。略者。多宝如来身一体。示现摄取一切佛法身故。住持者。示现诸佛如来法身自在身力故。示现无量佛者。示现彼此所作业无差别故。远离秽不净者。示现一切佛国土平等清净故。言多宝者。示现一切佛土同宝性故。同一塔坐者。示现化佛非化佛法佛报佛等皆为成大事故。自此已下示现法力持力修行力应知。法力者。五种门示现。一者证。二者信。三者供养。四者闻法。五者读诵持说。四种门弥勒品中示现。一法门常精进菩萨品示现。弥勒品中四种门者。一者证。如经我说是如来寿命长远时六百八十万亿那由他恒河沙众生得无生法忍故。此言无生法忍者。谓初地证智应知。八生乃至一生得阿耨多罗三藐三菩提者。谓证初地菩提故。八生乃至一生者。谓诸凡夫决定能证初地。随力随分。八生乃至一生证初地故。言阿耨多罗三藐三菩提者。以离三界中分段生死。随分能见真如佛性。名得菩提。非谓究竟满足。如来方便涅槃故。信者。如经复有八世界微尘众生皆发阿耨多罗三藐三菩提心故。供养者。如经是诸菩萨摩诃萨得大法利时于虚空中雨曼陀罗华如是等故。闻法者。如随喜品说应知。一法门。常精进菩萨品示现者。谓读诵解说书写等。得六根清净故。如经若善男子善女人受持法华经若读若诵若解说若书写是人当得八百眼功德乃至千二百意功德故。此得六根清净者。谓凡夫人以经力故。得胜根用。未入初地菩萨位应知。如经以父母所生清净肉眼见于三千大千世界如是等。又六根清净者。于一一根中。悉能具足见色闻声知香味触法等用应知。眼见者闻香能知。如经释提桓因在胜殿上五欲娱乐乃至说法闻香知者。此是智境鼻根知故。持力者。有三种法门示现。如法师品安乐行品劝持品等。广说法力应知。其心决定知水必近者。受持此经得佛性水。成阿耨多罗三藐三菩提故。修行力者五门示现。一者说力。二者行苦行力。三者护众生诸难力。四者功德胜力。五者护法力。说力者有三种法门。神力品中示现。一出广长舌者忆念故。二[口*磬]咳声者。说偈令闻故。闻声已如实修行不放逸故。三弹指令觉悟者。令修行者觉悟故。行苦行力者。药王菩萨品示现教化众生。行苦行者妙音菩萨品示现教化众生。护众生难。观世音品陀罗尼品示现。功德胜力者。妙庄严王品示现。依过去功德。彼童子有如是力故。护法力者。普贤品及后品中示现。又说言受持观世音菩萨名及受持六十二恒河沙诸佛名彼福德平等者。有二种义。一者信力故。二者毕竟知故。信力者有二种。一者求我身如观世音毕竟信故。二者生恭敬心。如彼功德我亦毕竟得故。毕竟知者。决定知法界故。法界者名法性。彼法性入初地菩萨。能证入一切诸佛菩萨平等身故。平等身者。谓真如法身。是故受持六十二恒河沙佛名。受持观世音菩萨名。功德无差别

第一序品示现七种功德成就

第二方便品有五分示现破二明一。余品如向处分易解

妙法莲华经论优婆提舍


妙法莲华经忧波提舍

    No. 1519 [No. 1520]

妙法莲华经忧波提舍卷上

        大乘论师婆薮槃豆释

        后魏北天竺三藏菩提留支共沙门昙林等译

  顶礼正觉海　　净法无为僧
  为深利智者　　开示毗伽典
  只虔牟尼尊　　及菩萨声闻
  令法自他利　　略出勒伽辩
  归命过未世　　现在佛菩萨
  弘慈降神力　　愿施我无畏
  大悲止四魔　　护菩提增长

    妙法莲华经序品第一

如是我闻一时佛住王舍城耆阇崛山中。与大比丘众万二千人俱。皆是阿罗汉。诸漏已尽无复烦恼。心得自在善得心解脱善得慧解脱。心善调伏。人中大龙。应作者作。所作已办。离诸重担。逮得己利。尽诸有结。善得正智心解脱。一切心得自在到第一彼岸。菩萨摩诃萨八万人。皆于阿耨多罗三藐三菩提不退转。皆得陀罗尼大辩才乐说。转不退转法轮。供养无量百千诸佛。于诸佛所种诸善根。常为诸佛之所称叹。以大慈悲而修身心。善入佛慧通达大智到于彼岸。名称普闻无量世界。能度无数百千众生

释曰。此经法门。初第一品示现七种功德成就。此义应知。何等为七。一者序分成就。二者众成就。三者如来欲说法时至成就。四者依所说法威仪随顺住成就。五者依止说因成就。六者大众现前欲闻法成就。七者文殊师利菩萨答成就

序分成就者。此法门中示现二种胜义成就。此义应知。何等为二。一者示现诸法门中最胜义成就。二者示现自在功德义成就。如王舍城。胜于一切诸余城舍。耆阇崛山胜余诸山。显此法门最胜义故。如经婆伽婆住王舍城耆阇崛山中故

众成就者。有四种义故。成就示现应知。何等为四。一者数成就。二者行成就。三者摄功德成就。四者威仪如法住成就

数成就者。诸大众无数故。行成就者有四种。一者谓诸声闻修小乘行。二者谓诸菩萨修大乘行。三者谓诸菩萨神通自在随时示现。能修行大乘。如颰陀波罗菩萨等十六大贤士。具足菩萨不可思议事。而常示现种种形相。谓优婆塞优婆夷比丘比丘尼等。四者谓出家声闻威仪一定不同菩萨故

皆是阿罗汉等有十六句。示现声闻功德成就

皆于阿耨多罗三藐三菩提不退转等有十三句。示现菩萨功德成就

声闻功德成就者。彼十六句三门摄义示现应知。何等三门。一者上上起门。二者总别相门。三者摄取事门

上上起门者。谓诸漏已尽故名为阿罗汉。以心得自在故名为诸漏已尽。以无复烦恼故名为心得自在。以善得心解脱善得慧解脱故名为心得自在。以远离能见所见故名为无复烦恼。以善得心解脱善得慧解脱故名为心善调伏。人中大龙者。行诸恶道如平坦路无所拘碍。应行者已行。应到处已到故。应作者作。人中大龙已得对治降伏烦恼之怨敌故。所作已办者。更不后生如相应事已成就故。离诸重担者。以应作者作所作已办后生重担已舍离故

逮得己利者。已舍重担证涅槃故。尽诸有结者。以逮得己利断诸烦恼因故。善得正智心解脱者。诸漏已尽故。一切心得自在者。善知见道修道智故。到第一彼岸者。善得正智心解脱善得神通无诤三昧等诸功德故。大阿罗汉等者。心得自在到彼岸故。众所知识者。诸王王子大臣人民帝释天王梵天王等皆识知故。又复声闻菩萨佛等是胜智者。彼胜智者皆悉善知。是故名为众所知识

总别相门者。皆是阿罗汉等十六句。初句是总。余句别故。彼阿罗汉名之为应。有十五种应义应知。何等十五。一者应受饮食卧具供养恭敬等故。二者应将大众教化一切故。三者应入聚落城邑等故。四者应降伏诸外道等故。五者应以智慧速观察法故。六者应不疾不迟说法如法相应不疲惓故。七者应静坐空闲处。饮食衣服一切资生不积不聚少欲知足故。八者应一向行善行不着诸禅故。九者应行空圣行故。十者应行无相圣行故。十一者应行无愿圣行故。十二者应降伏世间禅净心故。十三者应起诸通胜功德故。十四者应证第一义胜功德故。十五者应如实知同生诸众得诸功德为利益一切诸众生故。摄取事门者。此十五句。摄取十种功德。应知。示现可说果不可说果故。何等为十。一者摄取德功德二句示现。如经诸漏已尽无复烦恼故。二者三句摄取诸功德。一句降伏世间功德。如经心得自在故。二句降伏出世间学人功德。如经善得心解脱善得慧解脱故。三者摄取不违功德。随顺如来教作故。如经心善调伏故。四者摄取胜功德。如经人中大龙故。五者摄取所应作胜功德。所应作者。谓能依法供养恭敬尊重如来。如经应作者作故。六者摄取满足功德。满足学地故。如经所作已办故。七者三句摄取过功德。一者过爱。二者过求命供养恭敬。三者过上下界。已过学地故。如经离诸重担故。逮得己利故。尽诸有结故。八者摄取上上功德。如经善得正智心解脱故。九者摄取应作利益众生功德。如经一切心得自在故。十者摄取上首功德。如经到第一彼岸故

菩萨功德成就者。彼十三句二门摄义示现应知。何等二门。一者上支下支门。二者摄取事门

上支下支门者。所谓总相别相此义应知。皆于阿耨多罗三藐三菩提不退转者是总相。余者是别相。彼不退转十种示现此义应知。何等为十。一者住闻法不退转。如经皆得陀罗尼故。二者乐说不退转。如经大辩才乐说故。三者说不退转。如经转不退转法轮故。四者依止善知识不退转。以身心业依色身摄取故。如经供养无量百千诸佛故。于诸佛所种诸善根故。五者断一切疑不退转。如经常为诸佛之所称叹故。六者为何等何等事说法入彼彼法不退转。如经以大慈悲而修身心故。七者入一切智如实境界不退转。如经善入佛慧故。八者依我空法空不退转。如经通达大智故。九者入如实境界不退转。如经到于彼岸故。十者作所应作不退转。如经能度无数百千众生故

摄取事门者。示现诸菩萨住何等清净地中。以何等方便。于何等境界中。作所应作故。地清净者。八地已上三地无相行寂静清净故。方便者有四种。一者摄取妙法方便。住持妙法以乐说力为人说故。二者摄取善知识方便。以依善知识作所应作故。三者摄取众生方便。以不舍众生故。四者摄取智方便。以教化众生令入彼智故

又复更有摄取事门示现诸地摄取胜功德不同二乘诸功德故。谓第八地中无功用智不同下上故。不同下者。下功用行不能动故。不同上者。上无相行不能动自然而行故。第九地中得胜进陀罗尼门具足四无碍自在智故。第十地中不退转法轮得受佛位如转轮王之太子故。以得同摄功德义故

摄功德成就者。示现依何处依何心依何智依何等境界行依何等能办故。依何处者。依善知识故。依何心者。依教化众生心毕竟利益一切众生故。依何智者。依三种智。一者授记密智。二者诸通智。三者真实智。依何等境界行依何等能办者。即三种智所摄应知。威仪如法住成就者。四种示现。何等为四。一者众围绕。二者前后。三者供养恭敬。四者尊重赞叹。如经尔时世尊四众围绕供养恭敬尊重赞叹故

如来欲说法时至成就者。为诸菩萨说大乘经故。此大乘修多罗有十七种名。显示甚深功德应知。何等十七。云何显示。一名无量义经者。成就字义故。以此法门说彼甚深法妙境界故。彼甚深法妙境界者。诸佛如来最胜境界故。二名最胜修多罗者。于三藏中最胜妙藏。此法门中善成就故。三名大方广经者。无量大乘门中善成就故。随顺众生根住持成就故。四名教菩萨法者。以为教化根熟菩萨随顺法器善成就故。五名佛所护念者。以依如来有此法故。六名一切诸佛秘密法者。此法甚深唯佛知故。七名一切诸佛之藏者。如来功德三昧之藏在此经故。八名一切诸佛秘密处者。以根未熟众生等非受法器不授与故。九名能生一切诸佛经者。闻此法门能成诸佛大菩提故。十名一切诸佛之道场者。以此法门能成诸佛阿耨多罗三藐三菩提非余修多罗故。十一名一切诸佛所转法轮者。以此法门能破一切诸障碍故。十二名一切诸佛坚固舍利者。谓如来真实法身于此修多罗不败坏故。十三名一切诸佛大巧方便经者。依此法门成大菩提已为众生说天人声闻辟支佛等诸善法故。十四名说一乘经者。以此法门显示如来阿耨多罗三藐三菩提究竟之体。彼二乘道非究竟故。十五名第一义住者。以此法门即是诸佛如来法身究竟住处故。十六名妙法莲华经者。有二种义。何等二种。一者出水义。以不可尽出离小乘泥浊水故。又复有义。如彼莲华出于泥水喻。诸声闻得入如来大众中坐。如诸菩萨坐莲华上。闻说如来无上智慧清净境界。得证如来深密藏故。二华开义。以诸众生于大乘中其心怯弱不能生信。是故开示诸佛如来净妙法身令生信心故。十七名最上法门者。摄成就故。摄成就者。摄取无量名句字身。有频婆罗阿閦婆等舒卢迦故。此十七句法门是总。余句是别。如经为诸菩萨说大乘经。名无量义如是等故

依所说法威仪随顺住成就者。示现依何等何等法说法。依三种法故。一者依三昧成就。三昧成就二种示现。一者成就自在力。身心不动故。二者离一切障。随自在力故。此自在力复有二种。一为随顺众生不见对治摄取觉菩提分法故。二为对治无量世来坚执烦恼故。如经佛说此经已结加趺坐。入于无量义处三昧身心不动。如是等故。二者依器世间。三者依众生世间。震动世界及知过去无量劫事。如是等故。如经是时天雨曼陀罗花次第乃至欢喜合掌一心观佛故

依止说因成就者。为诸大众示现异相不思议事。大众见已生希有心。渴仰欲闻生如是念。如来今者应为我说。故名依止说因成就。是故如来放大光明。示现他方诸世界中种种诸事故。先为大众示现外事六种震动等。次为示现此法门中内证甚深微密之法。又依器世间众生世间数种种量种种具足烦恼差别具足清净差别佛法弟子差别。示现三宝故。复乘差别。有世界有佛。有世界无佛。令众生见修行者未得果得道者已得果。如经诸修行得道者故。数种种者示现种种观故。略说四种观。一者食。二者闻法。三者修行。四者乐。如经尔时佛放眉间白毫相光。次第乃至以佛舍利起七宝塔故。行菩萨道者。教化众生依四摄法方便摄取。此义应知。如经所说当自推取

自此以下。示现大众欲闻现前成就。问一人者多人欲闻生希有心。是故唯问文殊师利。如是示现世尊弟子随顺于法不相违故。今佛世尊现神变相者为何等义。为说大法故。现大相以为说因。现大相者。为说妙法莲华经故现大瑞相。为说如来所得妙法不可思议等文字章句故。有二种义。是故仰推文殊师利。何等为二。一者现见诸法故。二者离诸因缘唯自内心成就彼法故。示现种种诸瑞相者。以为示现彼彼事故。如彼事相现没住灭应当善知。以文殊师利能记彼事故。以文殊师利所作成就因果成就现见彼法故。所作成就者。此有二种。一者功德成就。二者智慧成就。因成就者。一切智成就故。又复有因谓缘因故。缘因成就者。众相具足故。果成就者。说大法故。种种异异佛国土者。为此示现彼国土中种种异异差别应知。净妙国土者。谓无烦恼众生住处。如经照于东方万八千世界次第乃至悉见彼佛国界庄严故。如来为上首者。诸菩萨等依如来住故。以彼如来于彼国土诸大众中得自在故。如经又见彼土现在诸佛如是等故

自此以下次明圣者。文殊师利以宿命智现见过去因相果相成就十事如现在前。是故能答弥勒菩萨。云何现见过去因相。谓文殊师利自见己身。曾于彼彼诸国土中处处。修行种种行事故。云何现见过去果相。谓文殊师利自见己身。是过去世妙光菩萨于彼佛所闻此法门。为众生说故。何等名为成就十事。一者现见大义因成就。二者现见世间文字章句意甚深因成就。三者现见希有因成就。四者现见胜妙因成就。五者现见受用大因成就。六者现见摄取一切诸佛转法轮因成就。七者现见善坚实如来法轮因成就。八者现见能进入因成就。九者现见忆念因成就。十者现见自身所经事因成就

大义因成就者。八句示现此义应知。何等为八。一者欲论大法。二者欲雨大法雨。三者欲击大法鼓。四者欲建大法幢。五者欲然大法灯。六者欲吹大法蠡。七者欲不断大法鼓。八者欲说大法。此八句欲示现如来欲论大法等故

何等名为八种大义。谓有疑者为断疑故。已断疑者。增长淳熟彼智身故。根淳熟者。为说二种微密境界。一者声闻微密境界。二者菩萨微密境界。大法鼓者二句示现以远闻故。入密境界者。令彼进取上上清净义故。进取上上清净义者。令彼进取一切种智得现见故。令彼进取一切种智得现见者。为一切法建立名字章句义故。建立名字章句义者。令入不可说证智转法轮故

现见世间名字章句意甚深因成就者。如经我于过去诸佛曾见此瑞次第乃至故现斯瑞故

现见希有因成就者。以无量时不可得故。不可思议不可称不可量者。示现过彼阿僧祇劫不可得故。又复示现五种劫故。所谓一夜二昼三月四时五年。示现无量无边诸法故。如经如过去无量无边不可思议阿僧祇劫尔时有佛号日月灯明次第乃至令得阿耨多罗三藐三菩提成一切种智故

现见胜妙因成就者。示现诸佛及诸菩萨自受用故。如经次复有佛亦名日月灯明次第乃至所可说法初中后善故

现见受用大因成就者。是时王子受胜妙乐各舍出家。复彼大众于尔许时心不疲倦故。如经其最后佛未出家时次第乃至佛授记已便于中夜入无余涅槃故

现见摄取一切诸佛转法轮因成就者。法轮不断故。如经佛灭度后妙光菩萨持妙法莲华经满八十小劫为人演说故

现见善坚实如来法轮因成就者。佛灭度后无量时说故。如经日月灯明佛八子皆师妙光次第乃至皆令坚固阿耨多罗三藐三菩提心故

现见能进入因成就者。彼诸王子得大菩提故。如经是诸王子次第乃至皆成佛道故

现见忆念因成就者。为他说法利益他故。如经其最后成佛者名曰然灯次第乃至尊重赞叹故

现见自身所经事因成就者。以自身受胜妙乐故。如经弥勒当知次第乃至佛所护念故。汝号求名者示现知彼过去事故。又复示现今得彼法皆具足故又依义摄三故一与说故。如经今佛世尊欲说大法等故。二成如实说故。如经我于过去曾见等故。三令待说故。如经诸人今当知等故。自此已下示现所说法因果相应知

    方便品第二

经曰。尔时世尊入甚深三昧正念不动。以如实智观。从三昧安详而起。起已即告尊者舍利弗言。舍利弗。诸佛智慧甚深无量。其智慧门难见难觉难知难解难入。如来所证一切声闻辟支佛等所不能知。何以故。舍利弗。如来应正遍知已曾亲近供养无量百千万亿无数诸佛。于百千亿那由他佛所。尽行诸佛所修阿耨多罗三藐三菩提法。舍利弗。如来已于无量百千亿那由他劫勇猛精进所作成就名称普闻。舍利弗。如来毕竟成就希有之法。舍利弗。难解之法如来能知。舍利弗难解法者。诸佛如来随宜所说意趣难解。一切声闻辟支佛等所不能知。何以故。舍利弗。诸佛如来自在说因成就故。舍利弗。如来成就种种方便种种知见种种念观种种言辞。舍利弗。吾从成佛已来。于彼彼处广演言教。无数方便引导众生。于诸着处令得解脱。舍利弗。如来知见方便到于彼岸。舍利弗。如来知见广大深远。无障无碍力无所畏。不共法根力。菩提分禅定解脱三昧三摩跋提皆已具足。舍利弗。诸佛如来深入无际成就一切未曾有法。舍利弗。如来能种种分别巧说诸法言辞柔软悦可众心。止舍利弗不须复说。舍利弗。佛所成就第一希有难解之法。舍利弗。唯佛与佛说法。诸佛如来能知彼法究竟实相。舍利弗。唯佛如来知一切法。舍利弗。唯佛如来能说一切法。何等法云何法何似法何相法何体法何等云何何似何相何体。如是等一切法如来现见非不现见

释曰。尔时世尊入甚深三昧正念不动以如实智观从三昧安详而起起已即告舍利弗者。示现如来得自在力故。如来入定无能惊寤故。何故唯告尊者舍利弗不告其余声闻等者。随深智慧与如来相应故。何故不告诸菩萨者。有五种义。一者为诸声闻所应事故。二者为诸声闻回心趣向大菩提故。三者护诸声闻恐怯弱故。四者为令余人善思念故。五者为诸声闻不起所作已办心故

诸佛智慧甚深无量者。为诸大众生尊重心。毕竟欲闻如来说故。言甚深者。显示二种甚深之义应如是知。何等为二。一者证甚深。谓诸佛智慧甚深无量故。二者阿含甚深。谓智慧门甚深无量故。言甚深者此是总相。余别相。证甚深者五种示现。一者义甚深。谓依何等义甚深故。二者实体甚深。三者内证甚深。四者依止甚深。五者无上甚深。何者甚深。谓大菩提。大菩提者。如来所证阿耨多罗三藐三菩提故。云何甚深。一切声闻辟支佛等所不能知故名甚深。言智慧者。谓一切种一切智义故。如经诸佛智慧甚深无量其智慧门难见难觉难知难解难入一切声闻辟支佛等所不能知故。阿含甚深者八种示现。一者受持读诵甚深。如经已曾亲近供养无量百千万亿无数诸佛故。二者修行甚深。如经于百千万亿那由他佛所尽行诸佛所修阿耨多罗三藐三菩提法故。三者果行甚深。如经舍利弗如来已于无量百千亿那由他劫勇猛精进所作成就故。四者增长功德心甚深。如经名称普闻故。五者快妙事心甚深。如经舍利弗如来毕竟成就希有之法故。六者无上甚深。如经舍利弗难解之法如来能知故。七者入甚深。入甚深者。名字章句意难得故。自以住持不同外道说因缘法名为甚深。如经舍利弗难解法者诸佛如来随宜说法意趣难解故。八者不共声闻辟支佛所作住持甚深。如经一切声闻辟支佛等所不能知故

妙法莲华经忧波提舍卷上妙法莲华经忧波提舍卷下

        大乘论师婆薮槃豆释

        后魏北天竺三藏菩提留支共沙门昙林等译

    方便品之余

如是已说妙法功德具足。次说如来法师功德成就应知。如经何以故舍利弗诸佛如来自在说因成就故。如来成就四种功德故能度众生。何等为四。一者住成就。如经舍利弗如来成就种种方便故。种种方便者。谓从兜率天中退没乃至示现入涅槃故。二者教化成就。如经种种知见故。种种知见者。示现染净诸因故。三者功德毕竟成就。如经种种念观故。种种念观者。以说彼法成就因缘。如法相应故。四者说成就。如经种种言辞故。种种言辞者。以四无碍智依何等何等名字章句随何等何等众生能受而为说故

又复有义。种种方便者。种种方便示现外道所有邪法。如是如是种种过失故。种种方便示现诸佛所有正法。如是如是种种功德故。如经舍利弗吾从成佛已来广演言教无数方便引导众生于诸着处令得解脱故。又无数方便者。方便令入诸善法故。又方便者断诸疑故。又方便者令入增上胜智中故。又方便者依四摄法摄取众生令得解脱故。诸着处者。彼处处着。或着诸界或着诸地或着诸分或着诸乘着诸界者。谓着欲色无色界故。着诸地者谓着界故。依于三昧取禅定地。谓初禅地乃至非想非非想地。及取灭尽定地等故。着诸分者。谓着在家出家分故。着在家分者。着己同类作种种业邪见等故。着出家分者。著名闻利养种种觉烦恼等故。着诸乘者。着声闻乘菩萨乘故。着声闻乘者。乐持小乘戒。求须陀洹斯陀含阿那含阿罗汉等故。着大乘者。谓着利养供养恭敬等故。着分别观种种法相乃至佛地故

又复种种知见者。自身成就不可思议胜妙境界。与诸声闻菩萨等故。如经舍利弗如来知见方便到于彼岸故。到彼岸者。胜余一切诸菩萨故

又复种种念观者。如经舍利弗如来知见广大深远无障无碍力无所畏不共法根力菩提分禅定解脱三昧三摩跋提皆已具足故。又第一成就可化众生。依善知识而成就故。第二成就根熟众生令得解脱故。第三成就力家自在净降伏故。第四成就复有七种。一者种种成就。如经舍利弗诸佛如来深入无际。成就一切未曾有法故。二者言语成就。谓得五种美妙音声言语说法。如经如来能种种分别巧说诸法言辞柔软悦可众心故。三者相成就。如经止舍利弗不须复说故。有法器众生心已满足故。四者堪成就。所有一切可化众生。皆知如来成就希有胜功德能说法故。如经舍利弗佛所成就第一希有难解之法故。五者无量种成就说不可尽。如经舍利弗唯佛与佛说法诸佛如来能知彼法究竟实相故。言实相者。谓如来藏法身之体不变义故。六者觉体成就。如来所说一切诸法唯佛如来自证得故。如经舍利弗唯佛如来知一切法故。七者随顺众生意。为说修行法成就。彼法何等如是等故。如经舍利弗唯佛如来能说一切法故。第一种种法门摄取众生故。第二令不散乱住故。第三令取故。第四令得解脱故。第五令彼修行成就得对治法故。第六令彼修行进趣成就故。第七令得修行不退失故。此七种法为诸众生自身所作善成就故。又与教化令成就者。与二种法令彼成就。何等为二。一与证法。二与说法。一与证法令成就者。谓依证法而授与故。二与说法令成就者。谓依说法而说与故。此二种法如向前说。依此二法有何次第而得修行。即彼前文重说应知

又依证法复有五种。一者何等法。二者云何法。三者何似法。四者何相法。五者何体法故。何等法者。谓声闻法辟支佛法诸佛法故。云何法者。谓起种种诸事说故。何似法者。依三种门得清净故。何相法者。谓三种义一相法故。何体法者无二体故。无二体者。谓无量乘唯一佛乘无二乘故

又复有义。何等法者。所谓有为无为法等。云何法者。谓因缘法非因缘法等。何似法者。所谓常法无常法等。何相法者谓生等三相法不生等三相法。何体法者。谓五阴体非五阴体故。又何似法者。谓无常法有为法因缘法。又何相法者。谓可见相等法。又何体法者。所谓五阴能取可取。以五阴是苦集体故。又五阴者。是道谛体故。复有异义依说法说。何等法者。所谓名句字身等故。云何法者。谓依如来所说法故。何似法者。谓能教化可化者故。何相法者依音声取。以依音声取彼法故。何体法者。谓假名体法相义故

自此已下次依示现三种义说。一者决定义。二者疑义。三者依何事疑义应当善知

决定义者。有声闻方便得证深法作决定心。于声闻道中得方便涅槃证故。如是二种证法。示现有为无为法故。如经尔时大众中有诸声闻漏尽阿罗汉次第乃至亦得此法到于涅槃故。言疑义者。谓诸声闻辟支佛等不能得知。是故生疑。如经而今不知是义所趣故。依何事疑义者。闻如来说声闻解脱与我解脱不异不别是故生疑。谓生疑者生因中疑。此事云何此事云何。此以如来数数为说甚深境界。前说甚深后说甚深不同声闻。以如是故生疑。如经尔时舍利弗知四众心疑次第乃至而说偈言

自此以下次依示现四种事说。一者决定心。二者因授记。三者取授记。四者与授记应当善知。云何决定心。已生惊怖者令断惊怖。以为利益二种人故。是故如来有决定心。此惊怖者五种应知

一者损惊怖。谓小乘众生如所闻声取以为实。谤无大乘起如是心。如来说言阿罗汉果究竟涅槃。我毕竟取如是涅槃。是故罗汉不入涅槃如是惊怖

二者多事惊怖。谓大乘众生闻菩萨道劫数长远种种苦行起如是心。佛道长远。我于无量无边劫中行菩萨行久受勤苦。如是念故生惊怖心。以是故起取异乘心如是惊怖

三者颠倒惊怖。谓心分别有我我所种种身。见诸不善法如是惊怖

四者心悔惊怖。谓大德舍利弗等起如是心言。我不应修证如是小乘之法。如是悔已心即自止。即此心悔名为惊怖。此义应知

五者诳惊怖。谓增上慢声闻之人起如是心。云何如来诳于我等如是惊怖

因授记者。如经止止舍利弗不须复说。若说是事一切世间诸天人等皆生惊怖故。此因授记皆生惊怖者有三种义。一者欲令彼诸大众推求甚深妙境界故。二者欲令彼诸大众生尊重心。毕竟欲闻如来说故。三者欲令诸增上慢声闻之人舍离法座而起去故。第二请者。示现过去无量诸佛教化众生。如经是会无数次第乃至闻佛所说则生敬信故。第三请者。示现今佛教化众生。如经今此会中如我等比次第乃至长夜安隐多所饶益故。取授记者。以舍利弗等欲得授记。如经佛告舍利弗汝已三请岂得不说汝今谛听如是等故

与授记者六种应知。一者未闻令闻。二者说。三者依何等义。四者令住。五者依法。六者遮。未闻者令闻。如经舍利弗如是妙法诸佛如来时乃说之如优昙钵华如是等故

说者。如经舍利弗我以无数方便种种因缘譬喻言辞演说诸法如是等故。种种因缘者。所谓三乘。彼三乘者唯有名字章句言说非有实义。以彼实义不可说故

依何等义者。如经舍利弗诸佛世尊唯以一大事因缘故出现于世如是等故。一大事者。依四种义应当善知。何等为四。一者无上义。唯除如来一切智。知更无余事。如经欲开佛知见令众生知得清净故出现于世故。佛知见者。如来能证以如实知彼深义故。二者同义谓诸声闻辟支佛佛法身平等。如经欲示众生佛知见故出现于世故。法身平等者。佛性法身无差别故。三者不知义。谓诸声闻辟支佛等不能知彼真实处故。此言不知真实处者。不知究竟唯一佛乘故。如经欲令众生悟佛知见故出现于世故。四者令证不退转地。示现欲与无量智业故。如经欲令众生入佛知见故出现于世故。又复示者。为诸菩萨有疑心者。令知如实修行故。又悟入者。未发心者令发心故已发心者令入法故。又复悟者。令外道众生生觉悟故。又复入者。令得声闻小乘果者入菩提故

令住者。如经舍利弗但以一佛乘故为众生说法故

依法者。如经舍利弗过去诸佛以无量无数方便种种譬喻因缘念观方便说法是法皆为一佛乘故如是等故。言譬喻者如依牛故。得有乳酪生酥熟酥及以醍醐。此五味中醍醐第一。小乘不如其犹如乳。大乘为最犹如醍醐。此喻所明大乘无上。诸声闻等亦同大乘无上义故。声闻同者。此中示现诸佛如来法身之性同。诸凡夫声闻之人辟支佛等。法身平等无差别故。此义皆是譬喻示现因缘之义如前所说。言念观者。小乘谛中人无我等。大乘谛中真如实际法界法性。及人无我法无我等种种观故。言方便者。于小乘中观阴界入。厌苦离苦得解脱故。于大乘中诸波罗蜜。以四摄法摄取自身他身。利益对治法故。遮者如经舍利弗十方世界中尚无二乘何况有三如是等故。无二乘者。谓无二乘所得涅槃。唯有如来证大菩提。究竟满足一切智慧名大涅槃。非诸声闻辟支佛等有涅槃法。唯一佛乘故。一佛乘者。依四种义说应当善知。如来依此六种授记。是故前说何等法云何法何似法何相法何体法如是示现。何等法者。谓未曾闻故。云何法者。谓种种言辞譬喻显说故。何似法者。所谓唯为一大事故。何相法者。为随众生器说诸佛法故。何体法者。所谓唯有一乘体故。一乘体者。所谓诸佛如来平等法身。彼诸声闻辟支佛乘非彼平等法身之体。以因果行观不同故

自此以下如来说法。为断四种疑心应知。何等四疑。一疑何时说。二疑云何知是增上慢人。三疑云何堪说。四疑云何如来不成妄语。何时说者。诸佛如来于何等时起种种方便说法为断此疑。如经舍利弗诸佛出于五浊恶世所谓劫浊如是等故。云何知是增上慢人者。如来不为增上慢人而说诸法。云何知彼是增上慢为断此疑。如经若有比丘实得阿罗汉者若不信是法无有是处如是等故。云何堪说者。从佛闻法而起谤心。如来应是不堪说人云何不成不堪说人为断此疑。如经除佛灭度后现前无佛如是等故。云何如来不成妄语者。此以如来先说法异今说法异。云何如来不成妄语为断此疑。如经舍利弗汝等应当一心信解受持佛语诸佛如来言无虚妄无有余乘唯一佛乘故

乃至童子戏聚沙为佛塔。如是诸人等皆已成佛道者。谓发菩提心行菩萨行者。所作善根能证菩提。非诸凡夫及决定声闻本来未发菩提心者之所能得。如是乃至小低头等皆亦如是

    譬喻品第三

尊者舍利弗所说偈言

  金色三十二　　十力诸解脱
  同共一法中　　而不得此事
  八十种妙好　　十八不共法
  如是等功德　　而我皆已失

释曰。此偈示现何义。尊者舍利弗自呵责身言。我不见诸佛不往诸佛所及闻佛说法。不供养恭敬诸佛。无利益众生事。于未得法退。尊者舍利弗作如是等呵责自身。不见佛者。示现不见诸佛如来大人之相。不生恭敬供养心故。往佛所者。示现教化众生力故。放金色光明者。示现见佛自身异身获得无量诸功德故。闻说法者。示现能作一切众生之利益故。力者。示现众生有疑依十种力断彼疑故。供养者。示现能教化众生力故。十八不共法者。示现远离诸障碍故。恭敬者。示现出生无量福德。依如来教得解脱故。以人无我及法无我。一切诸法悉皆平等。是故尊者舍利弗自呵责身言。我未得如是法故。于未得中退故

自此以下。次为七种具足烦恼染性众生。说七种喻。对治七种增上慢心。此义应知

又复次为三种染慢无烦恼人三昧解脱身等染慢。对治此故说三种平等。此义应知。(身下丹本有见字)

何者七种具足烦恼染性众生。一者求势力人。二者求声闻解脱人。三者大乘人。四者有定人。五者无定人。六者集功德人。七者不集功德人

何等七种增上慢心。云何七种譬喻对治。一者颠倒求诸功德增上慢心。谓世间中诸烦恼染炽然增上。而求天人胜妙境界有漏果报。对治此故为说火宅譬喻应知

二者声闻一向决定增上慢心。自言我乘与如来乘等无差别。如是倒取。对治此故为说穷子譬喻应知

三者大乘一向决定增上慢心。起如是意无别声闻辟支佛乘。如是倒取。对治此故为说云雨譬喻应知

四者实无谓有增上慢心。以有世间三昧三摩跋提。实无涅槃生涅槃想。如是倒取。对治此故为说化城譬喻应知

五者散乱增上慢心。实无有定。过去虽有大乘善根而不觉知。不觉知故不求大乘。狭劣心中生虚妄解。谓第一乘。如是倒取。对治此故为说系宝珠譬喻应知

六者实有功德增上慢心。闻大乘法取非大乘。如是倒取。对治此故为说轮王解自髻中明珠与之譬喻应知

七者实无功德增上慢心。于第一乘不曾修集诸善根本闻第一乘心中不取以为第一。如是倒取。对治此故为说医师譬喻应知。第一人者。示世间中种种善根三昧功德方便令喜。然后令入大涅槃故。第二人者。以三为一令入大乘故。第三人者。令知种种乘诸佛如来平等说法。随诸众生善根种子而生芽故。第四人者。方便令入涅槃城故。涅槃城者。所谓诸禅三昧城故。过彼城已。然后令入大涅槃城故。第五人者。示其过去所有善根。令忆念已。然后教令入三昧故。第六人者。说大乘法。以此法门同十地行满。诸佛如来密与授记故。第七人者。根未淳熟为令熟故。如是示现得涅槃量。为是义故。如来说七种譬喻。何者三种无烦恼人三种染慢。所谓三种颠倒信故。何等为三。一者信种种乘异。二者信世间涅槃异。三者信彼此身异。为对治此三种染慢故。说三种平等应知

何者名为三种平等。云何对治。一者乘平等。谓与声闻授菩提记。唯一大乘无二乘故。是乘平等无差别故。二者世间涅槃平等。以多宝如来入于涅槃。世间涅槃彼此平等无差别故。三者身平等。多宝如来已入涅槃。复示现身自身他身法身平等无差别故。如是三种无烦恼人染慢之心见彼此身所作差别。不知彼此佛性法身悉平等故。谓即此人我证此法故。彼人不得此对治故。与诸声闻授记应知

问曰。彼声闻等。为实成佛故与授记。为不成佛与授记耶。若实成佛。菩萨何故于无量劫修集无量种种功德。若不成佛云何与之虚妄授记。答曰。彼声闻等得授记者。得决定心非谓声闻。成就法性如来。依彼三种平等说一乘法。以佛法身声闻法身平等无异故与授记。非即具足修行功德。是故菩萨功德具足。诸声闻人功德未足

言授记者六处示现。五是佛记一菩萨记。如来记者。谓舍利弗大迦叶等众所知识。名号不同故别与记。富楼那等五百人千二百等同一名故。俱时与记。学无学等皆同一号。又复非是众所知识故同与记。如来与彼提婆达多授别记者。示现如来无怨恶故。与比丘尼及诸天女授佛记者。示现女人在家出家修菩萨行皆证佛果故与授记。菩萨记者。如下不轻菩萨品中示现应知。礼拜赞叹作如是言。我不轻汝。汝等皆当得作佛者。示现众生皆有佛性故

言声闻人得授记者。声闻有四种。一者决定声闻。二者增上慢声闻。三者退菩提心声闻。四者应化声闻。二种声闻如来授记。谓应化者。退已还发菩提心者。若决定者增上慢者二种声闻。根未熟故不与授记。菩萨与授记者。方便令发菩提心故

又依何义。佛说三乘名为一乘。依同义故。授诸声闻大菩提记。言同义者。以佛法身声闻法身彼此平等无差别故。以诸声闻辟支佛等乘不同故有差别。以彼二乘非大乘故。如来说言不离我身是无上义。一切声闻辟支佛等二乘法中不说此义。以其不能如实解故。以是义故。诸菩萨等行菩萨行非为虚妄。无上义者。自余经文明无上义。无上义者。略有十种此义应知。何等为十。一者示现种子无上故说雨譬喻。汝等所行是菩萨道者。谓发菩提心退已还发者。前所修行善根不灭同后得果故。二者示现行无上故说大通智胜如来本事等。三者示现增长力无上故说商主譬喻。四者示现令解无上故说系宝珠譬喻。五者示现清净国土无上故示现多宝如来塔。六者示现说无上故说解髻中明珠譬喻。七者示现教化众生无上故地中踊出无量菩萨摩诃萨等。八者示现成大菩提无上故。示现三种佛菩提故。一者示现应佛菩提。随所应见而为示现。如经皆谓如来出释氏宫去伽耶城不远坐于道场得成阿耨多罗三藐三菩提故。二者示现报佛菩提。十地行满足得常涅槃证故。如经善男子我实成佛已来无量无边百千万亿那由他劫故。三者示现法佛菩提。谓如来藏性净涅槃常恒清凉不变等义。如经如来如实知见三界之相次第乃至不如三界见于三界故。三界相者。谓众生界即涅槃界。不离众生界有如来藏故。无有生死若退若出者。谓常恒清凉不变义故。亦无在世及灭度者。谓如来藏真如之体。不即众生界。不离众生界故。非实非虚非如非异者。谓离四种相。有四种相者。是无常故。不如三界见于三界者。谓佛如来能见能证真如法身。凡夫不见故。是故经言如来明见无有错谬故。我本行菩萨道今犹未满者。以本愿故。众生界未尽愿非究竟故。言未满非谓菩提不满足也。所成寿命复倍上数者。此文示现如来命常善巧方便显多数故。过上数量不可数知。我净土不毁而众见烧尽者。报佛如来真实净土。第一义谛之所摄故。九者示现涅槃无上故说医师譬喻。十者示现胜妙力无上故。自余经文示现应知。多宝如来塔示现一切佛土清净者。示现诸佛实相境界中种种诸宝间错庄严故。示现有八。一者塔二者量三者略四者住持五者示现无量佛六者离秽七者多宝八者同一塔坐。塔者。示现如来舍利住持故。量者。方便示现一切佛土清净庄严。是出世间清净。无漏善根所生。非是世间有漏善根之所生也。略者。示现多宝佛身一体摄取一切诸佛真法身故。住持者。示现诸佛如来法身自在力故。示现无量佛者。示现彼此所作诸业无差别故。远离秽者。示现一切诸佛国土平等清净故。多宝者。示现一切诸佛国土同实性故。同一塔坐者。示现化佛非化佛法佛报佛等皆为成大事故

自此已下示现法力持力修行力应知

法力者。五门示现。一者证门。二者信门。三者供养门。四者闻法门。五者读诵持说门

弥勒菩萨品中示现四门。常精进菩萨品中示现一门。弥勒菩萨品中四法门者。一是证门。如经我说是如来寿命长远时六百八十万亿那由他恒河沙等众生得无生法忍故。此言无生法忍者。所谓初地证智应知。八生乃至一生得阿耨多罗三藐三菩提者谓证初地菩提法故。八生一生者。谓诸凡夫决定能证初地故。随力随分。八生乃至一生皆证初地故。此言阿耨多罗三藐三菩提者。以离三界分段生死。随分能见真如法性名得菩提。非谓究竟满足如来方便涅槃也

二是信门。如经复有八世界微尘数众生皆发阿耨多罗三藐三菩提心故。三供养门。如经是诸菩萨摩诃萨得大法利时于虚空中雨曼陀罗华如是等故。四闻法门。如随喜品所说应知

常精进菩萨品中。一法门者。谓读诵解说书写等。得六根清净。如经若善男子善女人受持法华经若读若诵若解说若书写。是人当得八百眼功德次第乃至得千二百意功德故。此得六根清净者。谓诸凡夫以经力故得胜根用。未入初地菩萨正位此义应知。如经以父母所生清净肉眼见于三千大千世界如是等故。又六根清净者。于一一根中悉能具足。见色闻声辨香别味觉触知法。诸根互用此义应知。眼所见者闻香能知。如经释提桓因在胜殿上五欲娱乐乃至说法故。闻香知者。此是知境以鼻根知故。持力者。有三法门示现持力如法师品安乐行品等广说。法力如经应知。其心决定知水必近者受持此经得佛性水成阿耨多罗三藐三菩提故。修行力者。五门示现。一者说力。二者行苦行力。三者护众生诸难力。四者功德胜力。五者护法力。说力者。有三法门。神力品示现。一者出广长舌令忆念故。二者谓謦欬声说偈令闻故。令闻声已如实修行不放逸故。三者弹指觉悟众生。令修行者得觉悟故。行苦行力者。药王菩萨品示现

又行苦行力者。妙音菩萨品示现教化众生故。护众生诸难力者。观世自在菩萨品陀罗尼品示现。功德胜力者。妙庄严王品示现。二童子依过去世功德善根。有如是力故。护法力者。普贤菩萨品及后品示现

又言受持观世自在菩萨名号。若人受持六十二亿恒河沙等诸佛名号福德等者。有二种义。一者信力故。二者毕竟知故。信力者有二种。一者我身如彼观世自在无异毕竟信故。二者谓于彼生恭敬心。如彼功德我亦如是毕竟得故。毕竟知者。谓能决定知法界故。言法界者名为法性。彼法性者。名为一切诸佛菩萨平等法身。平等身者真如法身。初地菩萨乃能证入。是故受持六十二亿恒河沙等诸佛名号。有能受持观世自在菩萨名号。所得功德无差别

第一序品示现七种功德成就。第二方便品有五分示现破二明一。余品如向处分易解

妙法莲华经忧波提舍卷下


摩诃般若波罗蜜经释论

    No. 1509 [cf. No. 223]

    摩诃般若波罗蜜经释论序

        长安释僧睿述

夫万有本于生生而生。生者无生。变化兆于物始而始。始者无始。然则无生无始物之性也。生始不动于性。而万有陈于外。悔吝生于内者。其唯邪思乎。正觉有以见邪思之自起故。阿含为之作。知滞有之由惑故。般若为之照。然而照本希夷。津涯浩汗。理超文表。趣绝思境。以言求之则乖其深。以智测之则失其旨。二乘所以颠沛于三藏。杂学所以曝鳞于龙门者。不其然乎。是以马鸣起于正法之余。龙树生于像法之末。正余易弘。故直振其遗风莹拂而已。像末多端故。乃寄迹凡夫。示悟物以渐。又假照龙宫。以朗搜玄之慧。托闻幽秘。以穷微言之妙。尔乃宪章智典。作兹释论。其开夷路也。则令大乘之驾方轨而直入。其辩实相也。则使妄见之惑不远而自复。其为论也。初辞拟之。必标众异以尽美。卒成之终则举无执以尽善。释所不尽。则立论以明之。论其未辩。则寄折中以定之。使灵篇无难喻之章。千载悟作者之旨。信若人之功矣。有鸠摩罗耆婆法师者。少播聪慧之闻。长集奇拔之誉。才举则亢标万里。言发则英辩荣枯。常杖兹论焉。渊镜凭高。致以明宗。以秦弘始三年岁次星纪。十二月二十日。自姑臧至长安。秦王虚襟既已蕴在。昔见之心岂徒则悦而已。晤言相对。则淹留终日。研微造尽。则穷年忘倦。又以晤言之功虽深。而恨独符之心不旷。造尽之要虽玄。而惜津梁之势未普。遂以莫逆之怀。相与弘兼忘之慧。乃集京师义业沙门。命公卿赏契之士。五百余人集于渭滨逍遥园堂。銮舆伫驾于洪涘。禁御息警于林间。躬览玄章。考正名于梵本。咨通津要。坦夷路于来践。经本既定。乃出此释论。论之略本有十万偈。偈有三十二字。并三百二十万言。梵夏既乖。又有烦简之异。三分除二。得此百卷。于大智三十万言。玄章婉旨朗然可见归途直达。无复惑趣之疑。以文求之。无间然矣。故天竺传云。像正之末。微马鸣龙树。道学之门。其沦胥溺丧矣。其故何耶。寔由二未[契-大+廾]微。邪法用盛。虚言与实教并兴。崄径与夷路争辙。始进者化之而流离。向道者惑之而播越。非二匠其孰与正之。是以天竺诸国。为之立庙。宗之若佛。又称而咏之曰。智慧日已颓。斯人令再曜。世昏寝已久。斯人悟令觉。若然者真可谓功格十地。道侔补处者矣。传而称之。不亦宜乎。幸哉此中鄙之外。忽得全有此论。梵文委曲。皆如初品。法师以秦人好简故。裁而略之。若备译其文。将近千有余卷。法师于秦语大格。唯译一往。方言殊好。犹隔而未通。苟言不相喻。则情无由比。不比之情。则不可以托悟怀于文表。不喻之言。亦何得委殊涂于一致。理固然矣。进欲停笔争是。则交竞终日。卒无所成。退欲简而便之。则负伤于穿凿之讥。以二三唯案译而书。都不备饰。幸冀明悟之贤。略其文而挹其玄也

大智度初序品中缘起义释论第一(卷第一)

        龙树菩萨造

        后秦龟兹国三藏法师鸠摩罗什奉　诏译

  智度大道佛从来　　智度大海佛穷尽
  智度相义佛无碍　　稽首智度无等佛
  有无二见灭无余　　诸法实相佛所说
  常住不坏净烦恼　　稽首佛所尊重法
  圣众大海行福田　　学无学人以庄严
  后有爱种永已尽　　我所既灭根亦除
  已舍世间诸事业　　种种功德所住处
  一切众中最为上　　稽首真净大德僧
  一心恭敬三宝已　　及诸救世弥勒等
  智慧第一舍利弗　　无诤空行须菩提
  我今如力欲演说　　大智彼岸实相义
  愿诸大德圣智人　　一心善顺听我说

问曰。佛以何因缘故。说摩诃般若波罗蜜经。诸佛法不以无事及小因缘而自发言。譬如须弥山王不以无事及小因缘而动。今有何等大因缘故。佛说摩诃般若波罗蜜经。答曰。佛于三藏中广引种种诸喻。为声闻说法不说菩萨道。唯中阿含本末经中。佛记弥勒菩萨。汝当来世当得作佛号字弥勒。亦不说种种菩萨行。佛今欲为弥勒等广说诸菩萨行。是故说摩诃般若波罗蜜经

复次有菩萨修念佛三昧。佛为彼等欲令于此三昧。得增益故。说般若波罗蜜经。如般若波罗蜜初品中说。佛现神足放金色光明。遍照十方恒河沙等世界。示现大身清净光明种种妙色满虚空中。佛在众中端正殊妙无能及者。譬如须弥山王处于大海。诸菩萨见佛神变。于念佛三昧倍复增益。以是事故。说摩诃般若波罗蜜经。复次菩萨初生时。放大光明普遍十方。行至七步四顾观察。作师子吼。而说偈言

  我生胎分尽　　是最末后身
  我已得解脱　　当复度众生

作是誓已身渐长大。欲舍亲属出家修无上道。中夜起观见诸伎直后妃婇女状若臭尸。即命车匿令被白马。夜半踰城行十二由旬。到跋伽婆仙人所住林中。以刀剃发。以上妙宝衣贸粗布僧伽梨。于泥连禅河侧六年苦行。日食一麻或食一米等。而自念言。是处非道。尔时菩萨舍苦行处。到菩提树下坐金刚处。魔王将十八亿万众来坏菩萨。菩萨以智慧功德力故。降魔众已。即得阿耨多罗三藐三菩提。是时三千大千世界主梵天王名式弃。及色界诸天等。释提桓因。及欲界诸天等。并四天王。皆诣佛所劝请世尊初转法轮。亦是菩萨念本所愿及大慈大悲故。受请说法。诸法甚深者般若波罗蜜是。以是故佛说摩诃般若波罗蜜经。复次有人。疑佛不得一切智。所以者何。诸法无量无数。云何一人能知一切法。佛住般若波罗蜜。实相清净如虚空。无量无数法中。自发诚言。我是一切智人欲断一切众生疑。以是故说摩诃般若波罗蜜经。复次有众生应得度者。以佛大功德智慧无量难知难解故。为恶师所惑。心没邪法不入正道。为是辈人起大慈心。以大悲手授之令入佛道。是故自现最妙功德。出大神力。如般若波罗蜜初品中说。佛入三昧王三昧。从三昧起。以天眼观十方世界。举身毛孔皆笑。从其足下千辐轮相。放六百千万亿种种色光明。从足指上至肉髻。处处各放六百千万亿种种色光明。普照十方无量无数如恒沙等诸佛世界。皆令大明。佛从三昧起欲宣示一切诸法实相断一切众生疑结故。说般若波罗蜜经。复次有恶邪人怀嫉妒意诽谤言。佛智慧不出于人。但以幻术惑世。断彼贡高邪慢意故。现无量神力无量智慧力。于般若波罗蜜中自说。我神德无量三界特尊。为一切覆护。若一发恶念获罪无量。一发净信受人天乐。必得涅槃果。复次欲令人信受法故。言我是大师。有十力四无所畏。安立圣主住处心得自在。能师子吼转妙法轮。于一切世界最尊最上。复次佛世尊欲令众生欢喜故。说是般若波罗蜜经言。汝等应生大喜。何以故。一切众生入邪见网。为异学恶师所惑。我于一切恶师邪网中得出。十力大师难可值见。汝今已遇。我随时开发三十七品等诸深法藏。恣汝采取。复次一切众生为结使病所烦恼。无始生死已来。无人能治此病者。常为外道恶师所误。我今出世为大医王集诸法药。汝等当服。是故佛说摩诃般若波罗蜜经。复次有人念言。佛与人同亦有生死。实受饥渴寒热老病苦。佛欲断彼意故。说是摩诃般若波罗蜜经。示言。我身不可思议。梵天王等诸天祖父。于恒河沙等劫中。欲思量我身寻究我声不能测度。况我智慧三昧。如偈说

  诸法实相中　　诸梵天王等
  一切天地主　　迷惑不能了
  此法甚深妙　　无能测量者
  佛出悉开解　　其明如日照

又如佛初转法轮时。应时菩萨从他方来欲量佛身。上过虚空无量佛刹。至华上佛世界。见佛身如故。菩萨说言

  虚空无有边　　佛功德亦尔
  设欲量其身　　唐劳不能尽
  上过虚空界　　无量诸佛土
  见释师子身　　如故而不异
  佛身如金山　　演出大光明
  相好自庄严　　犹如春华敷

如佛身无量。光明音响亦复无量。戒定慧等诸佛功德皆悉无量。如密迹经中三密。此中应广说。复次佛初生时堕地行七步。口自发言。言竟便默。如诸婴孩不行不语。乳餔三岁。诸母养育渐次长大。然佛身无数过诸世间。为众生故现如凡人。凡人生时身分诸根及其意识未成就故。身四威仪坐卧行住言谈语默。种种人法皆悉未了。日月岁过渐渐习学能具人法。今佛云何生。便能语能行。后更不能以此致怪。但为此故以方便力现行人法如人威仪。令诸众生信于深法。若菩萨生时便能行能语。世人当作是念。今见此人世未曾有。必是天龙鬼神。其所学法必非我等所及。何以故。我等生死肉身为结使业所牵不得自在。如此深法谁能及之。以此自绝不得成贤圣法器。为是人故。于岚毗尼园中生。虽即能至菩提树下成佛。以方便力故。而现作孩童幼小年少成人。于诸时中次第而受嬉戏术艺服御五欲。具足人法。后渐见老病死苦生厌患心。于夜中半踰城出家。到郁特伽阿罗洛仙人所。现作弟子而不行其法。虽常用神通自念宿命。迦叶佛时持戒行道。而今现修苦行六年求道。菩萨虽主三千大千世界而现破魔军成无上道。随顺世法故现是众变。今于般若波罗蜜中。现大神通智慧力故。诸人当知。佛身无数过诸世间。复次有人应可度者。或堕二边。或以无智故。但求身乐。或有为道故修着苦行。如是人等于第一义中失涅槃正道。佛欲拔此二边令入中道故。说摩诃般若波罗蜜经。复次分别生身法身供养果报故。说摩诃般若波罗蜜经。如舍利塔品中说。复次欲说阿鞞跋致阿鞞跋致相故说。又为魔幻魔事故说。复次为当来世人供养般若波罗蜜因缘故。又欲授三乘记别故。说是般若波罗蜜经。如佛告阿难。我涅槃后。此般若波罗蜜。当至南方。从南方至西方。后五百岁中当至北方。是中多有信法善男子善女人。种种华香璎珞幢幡伎乐灯明珍宝以财物供养。若自书若教人书。若读诵听说。正忆念修行。以法供养。是人以是因缘故。受种种世间乐。末后得三乘入无余涅槃。如是等观诸品中因缘事故。说般若波罗蜜经。复次佛欲说第一义悉檀相故。说是般若波罗蜜经。有四种悉檀。一者世界悉檀。二者各各为人悉檀。三者对治悉檀。四者第一义悉檀。四悉檀中一切十二部经。八万四千法藏。皆是实无相违背。佛法中有。以世界悉檀故实有。以各各为人悉檀故实有。以对治悉檀故实有。以第一义悉檀故实有。世界者有法从因缘和合故有无别性。譬如车辕轴辐辋等和合故有无别车。人亦如是。五众和合故有无别人。若无世界悉檀者。佛是实语人。云何言我以清净天眼见诸众生随善恶业死此生彼受果报。善业者生天人中。恶业者堕三恶道。复次经言。一人出世多人蒙庆福乐饶益。佛世尊也如法句中说。神自能救神。他人安能救神。自行善智是最能自救。如瓶沙王迎经中佛说。凡人不闻法。凡人着于我。又佛二夜经中说。佛初得道夜至般涅槃夜。是二夜中间所说经教。一切皆实不颠倒。若实无人者。佛云何言我天眼见众生。是故当知有人者。世界悉檀故。非是第一义悉檀。问曰。第一悉檀是真实。实故名第一。余者不应实。答曰。不然。是四悉檀各各有实。如如法性实际世界悉檀故无。第一义悉檀故有。人等亦如是。世界悉檀故有。第一义悉檀故无。所以者何。人五众因缘有故有是人等譬如乳色香味触因缘有故有是乳若乳实无。乳因缘亦应无。今乳因缘实有故。乳亦应有。非如一人第二头第三手无因缘而有假名。如是等相名为世界悉檀。云何各各为人悉檀者。观人心行而为说法。于一事中或听或不听。如经中所说。杂报业故。杂生世间得杂触杂受。更有破群那经中说。无人得触无人得受。问曰。此二经云何通。答曰。以有人疑后世不信罪福。作不善行堕断灭见。欲断彼疑舍彼恶行。欲拔彼断见。是故说杂生世间杂触杂受。是破群那计有我有神。堕计常中。破群那问佛言。大德谁受。若佛说某甲某甲受。便堕计常中。其人我见倍复牢固不可移转。以是故不说有受者触者。如是等相是名各各为人悉檀。对治悉檀者。有法对治则有。实性则无。譬如重热腻酢碱药草饮食等。于风病中。名为药。于余病非药。若轻冷甘苦涩药草饮食等。于热病名为药。于余病非药。若轻辛苦涩热药草饮食等。于冷病中名为药。于余病非药。佛法中治心病亦如是。不净观思惟。于贪欲病中名为善对治法。于嗔恚病中不名为善。非对治法。所以者何。观身过失名不净观。若嗔恚人观过失者。则增益嗔恚火故。思惟慈心于嗔恚病中名为善对治法。于贪欲病中不名为善。非对治法。所以者何。慈心于众生中。求好事观功德。若贪欲人求好事观功德者。则增益贪欲故。因缘观法于愚痴病中名为善对治法。于贪欲嗔恚病中不名为善。非对治法。所以者何。先邪观故生邪见。邪见即是愚痴。问曰。如佛法中说十二因缘。甚深如说。佛告阿难。是因缘法甚深难见难解难觉难观。细心巧慧人乃能解。愚痴人于浅近法犹尚难解。何况甚深因缘。今云何言愚痴人应观因缘法。答曰。愚痴人者。非谓如牛羊等愚痴。是人欲求实道。邪心观故生种种邪见。如是愚痴人当观因缘。是名为善对治法。若行嗔恚淫欲人欲求乐欲恼他。于此人中非善非对治法。不净慈心思惟。是二人中是善是对治法。何以故。是二观能拔嗔恚贪欲毒刺故。复次着常颠倒众生。不知诸法相似相续。有如是人观无常。是对治悉檀。非第一义。何以故。一切诸法自性空故。如说偈言

  无常见有常　　是名为颠倒
  空中无无常　　何处见有常

问曰。一切有为法皆无常相。应是第一义。云何言无常非实。所以者何。一切有为法生住灭相。前生次住后灭故。云何言无常非实。答曰。有为法不应有三相。何以故。三相不实故。若诸法生住灭。是有为相者。今生中亦应有三相。生是有为相故。如是一一处亦应有三相。是则无穷。住灭亦如是。若诸生住灭。各更无有生住灭者。不应名有为法。何以故。有为法相无故。以是故。诸法无常非第一义。复次若一切实性无常则无行业报。何以故。无常名生灭。失故。譬如腐种子不生果。如是则无行业。无行业云何有果报。今一切贤圣法有果报。善智之人所可信受。不应言无。以是故。诸法非无常性。如是等无量因缘。说不得言诸法无常性。一切有为法无常。苦无我等亦如是。如是等相名为对治悉檀。第一义悉檀者。一切法性一切论议语言。一切是法非法。一一可分别破散。诸佛辟支佛阿罗汉所行真实法。不可破不可散。上于三悉檀中所不通者。此中皆通。问曰。云何通。答曰。所谓通者。离一切过失。不可变易不可胜。何以故。除第一义悉檀。诸余论议诸余悉檀皆可破故。如众义经中所说偈

  各各自依见　　戏论起诤竞
  若能知彼非　　是为知正见
  不肯受他法　　是名愚痴人
  作是论议者　　真是愚痴人
  若依自是见　　而生诸戏论
  若此是净智　　无非净智者

此三偈中。佛说第一义悉檀相。所谓世间众生。自依见自依法自依论议。而生诤竞。戏论即诤竞本。戏论依诸见生。如说偈言

  有受法故有诸论　　若无有受何所论
  有受无受诸见等　　是人于此悉已除

行者能如实知此者。于一切法一切戏论。不受不着不见。是实不共诤竞。能知佛法甘露味。若不尔者则谤法。若不受他法不知不取。是无智人。若尔者应一切论议人皆无智。何以故。各各不相受法故。所谓有人自谓。法第一义净。余人妄语不净。譬如世间治法。故治法者刑罚杀戮种种不净。世间人信受行之。以为真净。于余出家善圣人中。是最为不净。外道出家人法。五热中一脚立拔发等。尼犍子辈以为妙慧。余人说此为痴法。如是等种种外道出家白衣婆罗门法。各各自以为好。余皆妄语。是佛法中亦有犊子比丘说。如四大和合有眼法。如是五众和合有人法。犊子阿毗昙中说。五众不离人。人不离五众。不可说五众是人离五众是人。人是第五不可说法藏中所摄。说一切有道人辈言。神人一切种一切时一切法门中。求不可得。譬如兔角龟毛常无。复次十八界十二入五众实有。而此中无人。更有佛法中方广道人言。一切法不生不灭。空无所有。譬如兔角龟毛常无。如是等一切论议师辈。自守其法不受余法。此是实余者妄语。若自受其法自法供养自法修行他法不受不供养为作过失。若以是为清净。得第一义利者。则一切无非清净。何以故。彼一切皆自爱法故。问曰。若诸见皆有过失。第一义悉檀。何者是。答曰。过一切语言道心行处灭遍无所依不示诸法。诸法实相无初无中无后不尽不坏。是名第一义悉檀。如摩诃衍义偈中说

  语言尽竟　　心行亦讫　　不生不灭
  法如涅槃　　说诸行处　　名世界法
  说不行处　　名第一义

  一切实一切非实　　及一切实亦非实
  一切非实非不实　　是名诸法之实相

如是等处处经中说。第一义悉檀。是义甚深难见难解。佛欲说是义故。说摩诃般若波罗蜜经。复次欲令长爪梵志等大论议师。于佛法中生信故。说是摩诃般若波罗蜜经。有梵志号名长爪。更有名先尼婆蹉衢多罗。更有名萨遮迦摩揵提等。是等阎浮提大论议师辈言。一切论可破。一切语可坏。一切执可转。故无有实法可信可恭敬者。如舍利弗本末经中说。舍利弗舅摩诃俱絺罗。与姊舍利论议不如。俱絺罗思惟念言。非姊力也。必怀智人寄言母口。未生乃尔。及生长大当如之何。思惟已生憍慢心。为广论议故出家作梵志。入南天竺国始读经书。诸人问言。汝志何求。学习何经。长爪答言。十八种大经尽欲读之。诸人语言。尽汝寿命犹不能知一。何况能尽。长爪自念。昔作憍慢为姊所胜。今此诸人复见轻辱。为是二事故。自作誓言我不剪爪。要读十八种经书尽。人见爪长因号为长爪梵志。是人以种种经书智慧力。种种讥刺是法是非法是应是不应是实是不实是有是无。破他论议。譬如大力狂象唐突蹴踏无能制者。如是长爪梵志以论议力。摧伏诸论师已。还至摩伽陀国王舍城那罗聚落。至本生处问人言。我姊生子今在何处。有人语言。汝姊子者适生八岁。读一切经书尽。至年十六论议胜一切人。有释种道人姓瞿昙。与作弟子。长爪闻之即起憍慢。生不信心而作是言。如我姊子聪明如是。彼以何术诱诳剃头作弟子。说是语已直向佛所。尔时舍利弗初受戒半月。佛边侍立以扇扇佛。长爪梵志见佛问讯讫。一面坐作是念。一切论可破一切语可坏。一切执可转。是中何者是诸法实相。何者是第一义。何者性。何者相。不颠倒。如是思惟。譬如大海水中欲尽其涯底。求之既久不得一法实可以入心者。彼以何论议道。而得我姊子。作是思惟已而语佛言。瞿昙。我一切法不受。佛问长爪。汝一切法不受。是见受不。佛所质义。汝已饮邪见毒。今出是毒气。言一切法不受。是见汝受不。尔时长爪梵志如好马见鞭影即觉便着正道。长爪梵志亦如是。得佛语鞭影入心。即弃捐贡高惭愧低头。如是思惟。佛置我着二处负门中。若我说是见我受。是负处门粗。故多人知。云何自言一切法不受。今受是见。此是现前妄语。是粗负处门多人所知。第二负处门细。我欲受之。以不多人知故。作是念已。答佛言。瞿昙。一切法不受。是见亦不受。佛语梵志。汝不受一切法。是见亦不受。则无所受。与众人无异。何用自高而生憍慢如是。长爪梵志不能得答。自知堕负处。即于佛一切智中起恭敬生信心。自思惟。我堕负处。世尊不彰我负。不言是非。不以为意。佛心柔濡。第一清净。一切语论处灭。得大甚深法。是可恭敬处。心净第一。佛说法断其邪见故。即于坐处得远尘离垢。诸法中得法眼净。时舍利弗闻是语得阿罗汉。是长爪梵志出家作沙门。得大力阿罗汉。若长爪梵志。不闻般若波罗蜜气分离四句第一义相应法。小信尚不得。何况得出家道果。佛欲导引如是等大论议师利根人故。说是般若波罗蜜经。复次诸佛有二种说法。一者观人心随可度者。二者观诸法相。今佛欲说诸法实相故。说是摩诃般若波罗蜜经。如说相不相品中。诸天子问佛。是般若波罗蜜甚深。云何作相。佛告诸天子。空则是相无相无作相无生灭相无行之相常不生如性相寂灭相等。复次有二种说法。一者诤处。二者不诤处。诤处如余经中说。今欲明无诤处故。说是般若波罗蜜经。有相无相有物无物有依无依有对无对有上无上世界非世界亦如是。问曰。佛大慈悲心但应说无诤法。何以说诤法。答曰。无诤法。皆是无相常寂灭不可说。今说布施等及无常苦空等诸法。皆为寂灭无戏论故说。利根者知佛意不起诤。钝根者不知佛意。取相着心故起诤此般若波罗蜜。诸法毕竟空故无诤处。若毕竟空可得可诤者。不名毕竟空。是故般若波罗蜜经名无诤处。有无二事皆寂灭故。复次余经中多以三种门说诸法。所谓善门不善门无记门。今欲说非善门非不善门非无记门诸法相故。说摩诃般若波罗蜜经。学法无学法非学非无学法。见谛断法思惟断法无断法。可见有对不可见有对不可见无对。上中下法小大无量法。如是等三法门亦如是。复次余经中说四念处随声闻法门。于是比丘观内身三十六物。除欲贪病。如是观外身观内外身。今于四念处欲以异门说般若波罗蜜。如所说菩萨观内身。于身不生觉观不得身。以无所得故。如是观外身观内外身。于身不生觉观不得身。以无所得故。于身念处中。观身而不生身觉观是事甚难。三念处亦如是。四正勤四如意足四禅四谛等。种种四法门亦如是。复次余经中佛说五众无常苦空无我相。今于是五众欲说异法门故。说般若波罗蜜经。如佛告须菩提。菩萨若观色是常行不行般若波罗蜜。受想行识是常行。不行般若波罗蜜。色无常行不行般若波罗蜜。受想行识无常行不行般若波罗蜜。五受众五道。如是等种种五法门亦如是。余六七八等。乃至无量法门亦如是。如摩诃般若波罗蜜无量无边。说般若波罗蜜因缘亦无量无边。是事广故。今略说摩诃般若波罗蜜因缘起法竟

    摩诃般若波罗蜜初品如是我闻一时释论第二

【经】如是我闻一时

【论】问曰。诸佛经何以故初称如是语。答曰。佛法大海信为能入。智为能度。如是义者即是信。若人心中有信清净。是人能入佛法。若无信是人不能入佛法。不信者言是事不如是。是不信相。信者言是事如是。譬如牛皮未柔不可屈折。无信人亦如是。譬如牛皮已柔随用可作。有信人亦如是。复次经中说信如手。如人有手入宝山中自在取宝。有信亦如是。入佛法无漏根力觉道禅定宝山中。自在所取。无信如无手。无手人入宝山中。则不能有所取。无信亦如是。入佛法宝山。都无所得。佛言。若人有信。是人能入我大法海中。能得沙门果不空。剃头染袈裟。若无信是人不能入我法海中。如枯树不生华实。不得沙门果。虽剃头染衣读种种经能难能答。于佛法中空无所得。以是故。如是义在佛法初。善信相故。复次佛法深远更有佛乃能知。人有信者虽未作佛。以信力故能入佛法。如梵天王请佛初转法轮以偈请佛

  阎浮提先出　　多诸不净法
  愿开甘露门　　当说清净道

佛以偈答

  我法甚难得　　能断诸结使
  三有爱着心　　是人不能解

梵天王白佛。大德。世界中智有上中下。善濡直心者。易可得度。是人若不闻法者。退堕诸恶难中。譬如水中莲华。有生有熟。有水中未出者若不得日光则不能开。佛亦如是。佛以大慈悲怜愍众生故为说法。佛念过去未来现在三世诸佛法。皆度众生为说法。我亦应尔。如是思惟竟。受梵天王等诸天请说法。尔时世尊以偈答曰

  我今开甘露味门　　若有信者得欢喜
  于诸人中说妙法　　非恼他故而为说

佛此偈中不说布施人得欢喜。亦不说多闻持戒忍辱精进禅定智慧人得欢喜。独说信人。佛意如是。我第一甚深法微妙无量无数不可思议不动不猗不着无所得法。非一切智人则不能解。是故佛法中信力为初。信力能入。非布施持戒禅定智慧等能初入佛法。如说偈言

  世间人心动　　爱好福果报
  而不好福因　　求有不求灭
  先闻邪见法　　心着而深入
  我此甚深法　　无信云何解

如提婆达大弟子俱迦梨等。无信法故堕恶道中。是人无信于佛法。自以智慧求不能得。何以故。佛法甚深故。如梵天王教俱迦梨说偈

  欲量无量法　　智者所不量
  无量法欲量　　此人自覆没

复次如是义者。若人心善直信。是人可听法。若无是相则不解如所说偈

  听者端视如渴饮　　一心入于语议中
  踊跃闻法心悲喜　　如是之人应为说

复次如是义在佛法初。现世利后世利涅槃利。诸利根本信为大力。复次一切诸外道出家心念。我法微妙第一清净。如是人自叹所行法毁他人法。是故现世相打斗诤。后世堕地狱。受种种无量苦。如说偈

  自法爱染故　　呰毁他人法
  虽持戒行人　　不脱地狱苦

是佛法中。弃舍一切爱一切见。一切吾我憍慢。悉断不着。如筏喻经言。汝曹若解我筏喻法。是时善法应弃舍。何况不善法。佛自于般若波罗蜜不念不猗。何况余法有猗著者。以是故佛法初头称如是。佛意如是。我弟子无爱法无染法无朋党。但求离苦解脱不戏论诸法相。如说阿他婆耆经。摩犍提难偈言

  决定诸法中　　横生种种想
  悉舍内外故　　云何当得道

佛答言

  非见闻知觉　　亦非持戒得
  非不见闻等　　非不持戒得
  如是论悉舍　　亦舍我我所
  不取诸法相　　如是可得道

摩犍提问曰

  若不见闻等　　亦非持戒得
  非不见闻等　　非不持戒得
  如我心观察　　持哑法得道

佛答言

  汝依邪见门　　我知汝痴道
  汝不见妄想　　尔时自当哑

复次我法真实余法妄语。我法第一余法不实。是为斗诤本。今如是义示人无诤法。闻他所说说人无咎。以是故诸佛经初称如是。略说如是义竟

我者今当说。问曰。若佛法中言一切法空一切无有吾我。云何佛经初头言如是我闻。答曰。佛弟子辈虽知无我。随俗法说。我非实我也。譬如以金钱买铜钱人无笑者。何以故。卖买法应尔。言我者亦如是。于无我法中而说我。随世俗故不应难。如天问经中偈说

  有罗汉比丘　　诸漏已永尽
  于最后边身　　能言吾我不

佛答言

  有罗汉比丘　　诸漏已永尽
  于最后边身　　能言有吾我

世界法中说我非第一实义中说。以是故诸法空无我。世界法故虽说我无咎。复次世界语言有三根本一者邪见。二者慢。三者名字。是中二种不净一种净。一切凡人三种语邪慢名字。见道学人二种语。慢名字。诸圣人一种语名字。内心虽不违实法。而随世界人故共传是语。除世界邪见。故随俗无诤。以是故除二种不净语本。随世故用一种语。佛弟子随俗故说我无有咎。复次若人着无吾我相。言是实余妄语。是人应难。汝一切法实相无我。云何言如是我闻。今诸佛弟子一切法空无所有。是中心不着。亦不言着诸法实相。何况无我法中心着。以是故不应难言何以说我。如中论中偈说

  若有所不空　　应当有所空
  不空尚不得　　何况得于空
  凡人见不空　　亦复见于空
  不见见无见　　是实名涅槃
  非二安隐门　　能破诸邪见
  诸佛所行处　　是名无我法

略说我义竟

闻者今当说。问曰。闻者云何。闻用耳根闻耶。用耳识闻。用意识闻耶。若耳根闻。耳根无觉知故不应闻。若耳识闻。耳识一念故不能分别。不应闻。若意识闻。意识亦不能闻。何以故。先五识识五尘。然后意识识。意识不能识现在五尘。唯识过去未来五尘。若意识能识现在五尘者。盲聋人亦应识声色。何以故。意识不破故。答曰。非耳根能闻声。亦非耳识亦非意识能闻声事从多因缘和合故得闻声。不得言一法能闻声。何以故。耳根无觉故不应闻声。识无色无对无处故。亦不应闻声。声无觉亦无根故不能知声。尔时耳根不破。声至可闻处。意欲闻情尘意和合故耳识生。随耳识即生意识。能分别种种因缘得闻声。以是故不应作是难。谁闻声。佛法中亦无有一法能作能见能知。如说偈

  有业亦有果　　无作业果者
  此第一甚深　　是法佛能见
  虽空亦不断　　相续亦不常
  罪福亦不失　　如是法佛说

略说闻竟

一者今当说。问曰。佛法中数时等法实无。阴入持所不摄故。何以言一时。答曰。随世俗故有一时无有咎。若画泥木等作天像。念天故礼拜无咎。说一时亦如是。虽实无一时随俗说一时无咎。问曰不应无一时。佛自说言。一人出世间多人得乐。是者何人。佛世尊也。亦如说偈

  我行无师保　　志一无等侣
  积一行得佛　　自然通圣道

如是等佛处处说一。应当有一。复次一法和合故物名为一。若实无一法。何以故。一物中一心生非二非三。二物中二心生非一非三。三物中三心生非二非一。若实无诸数。一物中应二心生。二物中应一心生。如是等三四五六皆尔。以是故。定知一物中有一法。是法和合故。一物中一心生。答曰。若一与物一。若一与物异。二俱有过。问曰。若一有何过。答曰。若一瓶是一义。如因提梨释迦。亦是一义。若尔者在在有一者应皆是瓶。譬如在在有因提梨。亦处处有释迦。今衣等诸物皆应是瓶一。瓶一故如是处处一皆应是瓶。如瓶衣等。悉是一物无有分别。复次一是数法。瓶亦应是数法。瓶体有五法。一亦应有五法。瓶有色有对。一亦应有色有对。若在在一不名为瓶。今不应瓶一。一若说一不摄瓶。若说瓶亦不摄一。瓶一不异故。又复欲说一应说瓶。欲说瓶应说一。如是则错乱。问曰。一中过如是。异中有何咎。答曰。若一与瓶异。瓶则非一。若瓶与一异。一则非瓶。若瓶与一合。瓶名一者。今一与瓶合。何以不名一为瓶。是故不得言瓶异一。问虽一数合故瓶为一。然一不作瓶。答曰。诸数初一。一与瓶异。以是故瓶不作一。一无故多亦无。何以故。先一后多故。如是异中一亦不可得。以是故二门中求一法不可得。不可得故。云何阴持入摄。但佛弟子随俗语言名为一心。实不着知数法名字有。以是故。佛法中言一人一师一时不堕邪见咎。略说一竟

时者今当说。问曰。天竺说时名有二种。一名迦罗二名三摩耶。佛何以不言迦罗而言三摩耶。答曰。若言迦罗俱亦有疑

问曰。轻易说故应言迦罗。迦罗二字三摩耶三字。重语难故。答曰。除邪见故。说三摩耶。不言迦罗。复次有人言。一切天地好丑皆以时为因。如时经中偈说

  时来众生熟　　时至则催促
  时能觉悟人　　是故时为因
  世界如车轮　　时变如转轮
  人亦如车轮　　或上而或下

更有人言。虽天地好丑一切物非时所作。然时是不变。因是实有。时法细故。不可见不可知。以华果等果故。可知有时。往年今年久近迟疾见此相。虽不见时可知有时。何以故见果知有因故。以是故有时法。时法不坏故常。答曰。如泥丸是现在时。土尘是过去时。瓶是未来时。时相常故。过去时不作未来时。汝经书法。时是一物。以是故过去世。不作未来世。亦不作现在世。杂过故。过去世中亦无未来世。以是故无未来世。现在世亦如是

问曰。汝受过去土尘时。若有过去时。必应有未来时。以是故实有时法。答曰。汝不闻我先说。未来世瓶。过去世土尘。未来世不作过去世。堕未来世相中。是未来世相时。云何名过去时。以是故过去时亦无

问曰。何以无时。必应有时。现在有现在相。过去有过去相。未来有未来相。答曰。若令一切三世时有自相。应尽是现在世。无过去未来时。若今有未来不名未来应当名现在。以是故是语不然

问曰。过去时未来时。非现在相中行。过去时过去世中行。未来世未来时中行。以是故各各法相有时。答曰。若过去复过去。则破过去相。若过去不过去。则无过去相。何以故自相舍故。未来世亦如是。以是故时法无实。云何能生天地好丑及华果等诸物。如是等种种除邪见故。不说迦罗时。说三摩耶。见阴界入生灭。假名为时无别时。所谓方时离合一异长短等名字出。凡人心着。谓是实有法。以是故。除弃世界名字语言法

问曰。若无时。云何听时食遮非时食是戒。答曰。我先已说世界名字法。有时非实法。汝不应难。亦是毗尼中结戒法。是世界中实。非第一实法相。吾我法相实不可得故。亦为众人嗔呵故。亦欲护佛法使久存定弟子礼法故。诸三界世尊结诸戒。是中不应求有何实。有何名字等。何者相应。何者不相应。何者是法如是相。何者是法不如是相。以是故是事不应难

问曰。若非时食时药时衣皆是柯逻。何以不说三摩耶。答曰。此毗尼中说白衣不得闻。外道何由得闻。而生邪见。余经通皆得闻是故。说三摩耶令其不生邪见。三摩耶诡名。时亦是假名称。又佛法中多说三摩耶。少说柯逻。少故不应难。如是我闻一时五语各各义略说竟

大智度论卷第一大智度初品总说如是我闻释论第三(卷第二)

        龙树菩萨造

        后秦龟兹国三藏法师鸠摩罗什奉　诏译

如是我闻一时今当总说。问曰。若诸佛一切智人。自然无师不随他教不受他法。不用他道不从他闻而说法。何以言如是我闻。答曰。如汝所言。佛一切智人自然无师。不应从他闻法而说。佛法非但佛口说者。是一切世间真实善语。微妙好语皆出佛法中。如佛毗尼中说。何者是佛法。佛法有五种人说。一者佛自口说。二者佛弟子说。三者仙人说。四者诸天说。五者化人说。复次如释提桓因得道经。佛告憍尸迦。世间真实善语微妙好语皆出我法中。如赞佛偈中说

  诸世善语　　皆出佛法　　善说无失
  无过佛语　　余处虽有　　善无过语
  一切皆是　　佛法之余　　诸外道中
  设有好语　　如虫食木　　偶得成字
  初中下法　　自共相破　　如铁出金
  谁当信者　　如伊兰中　　牛头栴檀
  如苦种中　　甘善美果　　设能信者
  是人则信　　外经书中　　自出好语
  诸好实语　　皆从佛出　　如栴檀香
  出摩梨山　　除摩梨山　　无出栴檀
  如是除佛　　无出实语

复次如是我闻。是阿难等佛大弟子辈说。入佛法相故名为佛法。如佛般涅槃时。于俱夷那竭国萨罗双树间。北首卧将入涅槃。尔时阿难亲属爱未除未离欲故。心没忧海不能自出。尔时长老阿泥卢豆语阿难。汝守佛法藏人。不应如凡人自没忧海。一切有为法是无常相。汝莫愁忧。又佛手付汝法。汝今愁闷失所受事。汝当问佛。佛般涅槃后我曹云何行道。谁当作师。恶口车匿云何共住。佛经初作何等语。如是种种未来事应问佛。阿难闻是事。闷心小醒得念道力。助于佛末后卧床边。以此事问佛。佛告阿难。若今现前。若我过去后自依止法依止不余依止。云何比丘自依止法依止不余依止。于是比丘内观身。常当一心智慧勤修精进。除世间贪忧。外身内外身观亦如是。受心法念处亦复如是。是名比丘自依止法依止不余依止。从今日解脱戒经即是大师。如解脱戒经说。身业口业应如是行。车匿比丘我涅槃后。如梵法治。若心濡伏者。应教删陀迦旃延经。即可得道。复次我三阿僧祇劫所集法宝藏。是藏初应作是说。如是我闻一时佛在某方某国土某处树林中。何以故。过去诸佛经初。皆称是语。未来诸佛经初。亦称是语。现在诸佛末后般涅槃时。亦教称是语。今我般涅槃后。经初亦应称如是我闻一时。是故当知是佛所教非佛自言如是我闻。佛一切智人自然无师故。不应言我闻。若佛自说如是我闻。有所不知者。可有此难。阿难问佛。佛教是语。是弟子所言。如是我闻。无有咎。复次欲令佛法久住世间故。长老摩诃迦叶等诸阿罗汉问阿难。佛初何处说法。说何等法。阿难答如是我闻一时佛在波罗捺国仙人鹿林中。为五比丘说是苦圣谛。我本不从他闻。法中正忆念得眼智明觉。是经是中应广说。如集法经中广说。佛入涅槃时。地六种动诸河反流。疾风暴发黑云四起。恶雷掣电雹雨骤堕处处星流师子恶兽哮吼唤呼。诸天世人皆大号啕。诸天人等皆发是言。佛取涅槃一何疾哉。世间眼灭。当是时间。一切草木药树华叶一时剖裂。诸须弥山王尽皆倾摇。海水波扬地大震动山崖崩落。诸树摧折四面烟起。甚大可畏。陂池江河尽皆娆浊。彗星昼出。诸人啼哭诸天忧愁。诸天女等郁伊哽咽涕泪交流。诸学人等默然不乐。诸无学人。念有为诸法一切无常。如是天人夜叉罗刹犍闼婆甄陀罗摩睺罗伽及诸龙等。皆大忧愁。诸阿罗汉度老病死海。心念言

  已渡凡夫恩爱河　　老病死券已裂破
  见身箧中四大蛇　　今入无余灭涅槃

诸大阿罗汉。各各随意于诸山林流泉溪谷处处舍身而般涅槃。更有诸阿罗汉。于虚空中飞腾而去。譬如雁王。现种种神力。令众人心信清净。然后般涅槃。六欲天乃至遍净天等。见诸阿罗汉皆取灭度。各心念言。佛日既没种种禅定解脱智慧弟子光亦灭。是诸众生有种种淫怒痴病。是法药师辈今疾灭度谁当治者。无量智慧大海中生。弟子莲华今已干枯。法树摧折法云散灭。大智象王既逝象子亦随去。法商人过去。从谁求法宝。如偈说

  佛已永寂入涅槃　　诸灭结众亦过去
  世界如是空无智　　痴冥遂增智灯灭

尔时诸天礼摩诃迦叶足。说偈言

  耆年欲恚慢已除　　其形譬如紫金柱
  上下端严妙无比　　目明清净如莲华

如是赞已。白大迦叶言。大德迦叶。仁者知不。法船欲破法城欲颓。法海欲竭法幢欲倒。法灯欲灭说法人欲去。行道人渐少。恶人力转盛。当以大慈建立佛法

尔时大迦叶心如大海澄静不动。良久而答。汝等善说实如所言。世间不久无智盲冥。于是大迦叶默然受请。尔时诸天礼大迦叶足。忽然不现各自还去。是时大迦叶思惟。我今云何使是三阿僧祇劫难得佛法而得久住。如是思惟竟。我知是法可使久住。应当结集修妒路阿毗昙毗尼作三法藏。如是佛法可得久住。未来世人可得受行。所以者何。佛世世勤苦慈愍众生故。学得是法为人演说。我曹亦应承用佛教宣扬开化。是时大迦叶作是语竟。住须弥山顶。挝铜揵稚。说此偈言

  佛诸弟子　　若念于佛　　当报佛恩
  莫入涅槃

是揵稚音大迦叶语声。遍至三千大千世界。皆悉闻知。诸有弟子得神力者。皆来集会大迦叶所。尔时大迦叶告诸会者。佛法欲灭。佛从三阿僧祇劫。种种勤苦慈愍众生学得是法。佛般涅槃已。诸弟子知法持法诵法者皆亦随佛灭度。法今欲灭。未来众生甚可怜愍。失智慧眼愚痴盲冥。佛大慈悲愍伤众生。我曹应当承用佛教。须待结集经藏竟。随意灭度。诸来众会皆受教住。尔时大迦叶选得千人。除善阿难。尽皆阿罗汉得六神通。得共解脱无碍解脱。悉得三明禅定自在。能逆顺行诸三昧皆悉无碍。诵读三藏知内外经书。诸外道家十八种大经尽亦读知。皆能论议降伏异学。问曰。是时有如是等无数阿罗汉。何以故正选取千人不多取耶。答曰。频婆娑罗王得道。八万四千官属亦各得道。是时王教敕宫中。常设饭食供养千人。阿阇贳王不断是法。尔时大迦叶思惟言。若我等常乞食者。当有外道强来难问废阙法事。今王舍城。常设饭食供给千人。是中可住结集经藏。以是故选取千人。不得多取。是时大迦叶与千人俱到王舍城耆阇崛山中。告语阿阇世王。给我等食日日送来。今我曹等结集经藏不得他行。是中夏安居三月初十五日说戒时。集和合僧。大迦叶入禅定。以天眼观今是众中谁有烦恼未尽。应逐出者。唯有阿难一人不尽。余九百九十九人。诸漏已尽清净无垢。大迦叶从禅定起。众中手牵阿难出言。今清净众中结集经藏。汝结未尽不应住此。是时阿难惭耻悲泣而自念言。我二十五年。随侍世尊供给左右。未曾得如是苦恼。佛实大德慈悲含忍。念已白大迦叶言。我能有力久可得道。但诸佛法阿罗汉者。不得供给左右使令。以是故我留残结不尽断耳。大迦叶言。汝更有罪。佛意不欲听女人出家。汝殷勤劝请佛听为道。以是故佛之正法五百岁而衰微。是汝突吉罗罪。阿难言。我怜愍瞿昙弥。又三世诸佛法皆有四部众。我释迦文佛云何独无。大迦叶复言。佛欲涅槃时。近俱夷那竭城脊痛。四叠沤多罗僧敷卧。语汝言。我须水。汝不供给。是汝突吉罗罪。阿难答言。是时五百乘车截流而渡令水浑浊。以是故不取。大迦叶复言。正使水浊佛有大神力能令大海浊水清净。汝何以不与。是汝之罪。汝去作突吉罗忏悔。大迦叶复言。佛问汝。若有人四神足好修。可住寿一劫若减一劫。佛四神足好修。欲住寿一劫若减一劫。汝默然不答。问汝至三。汝故默然。汝若答佛佛四神足好修。应住一劫若减一劫。由汝故。令佛世尊早入涅槃。是汝突吉罗罪。阿难言。魔蔽我心。是故无言。我非恶心而不答佛。大迦叶复言。汝与佛叠僧伽梨衣以足蹈上。是汝突吉罗罪。阿难言。尔时有大风起无人助。我捉衣时风吹来堕我脚下。非不恭敬故蹈佛衣。大迦叶复言。佛阴藏相般涅槃后以示女人。是何可耻。是汝突吉罗罪。阿难言。尔时我思惟。若诸女人见佛阴藏相者。便自羞耻女人形。欲得男子身修行佛相种福德根。以是故我示女人。不为无耻而故破戒。大迦叶言。汝有六种突吉罗罪。尽应僧中悔过。阿难言诺。随长老大迦叶及僧所教。是时阿难长跪合手。偏袒右肩脱革屣。六种突吉罗罪忏悔。大迦叶于僧中手牵阿难出。语阿难言。断汝漏尽然后来入。残结未尽汝勿来也。如是语竟便自闭门。尔时。诸阿罗汉议言。谁能结集毗尼法藏者。长老阿泥卢豆言。舍利弗是第二佛有好弟子。字憍梵波提(秦言牛齝)柔软和雅常处闲居。住心寂燕能知毗尼法藏。今在天上尸利沙树园中住。遣使请来。大迦叶语下坐比丘。汝次应僧使。下坐比丘言。僧有何使。大迦叶言。僧使汝至天上尸利沙树园中憍梵波提阿罗汉住处。是比丘欢喜踊跃受僧敕命。白大迦叶言。我到憍梵波提阿罗汉所陈说何事。大迦叶言。到已语憍梵钵提。大迦叶等漏尽阿罗汉。皆会阎浮提。僧有大法事。汝可疾来是。下坐比丘头面礼僧右绕三匝。如金翅鸟飞腾虚空。往到憍梵波提所。头面作礼。语憍梵波提言。软善大德少欲知足常在禅定。大迦叶问讯有语。今僧有大法事。可疾下来观众宝聚。是时憍梵波提心觉生疑。语是比丘言。僧将无斗诤事唤我来耶。无有破僧者不。佛日灭度耶。是比丘言。实如所言。大师佛已灭度。憍梵波提言。佛灭度大疾。世间眼灭。能逐佛转法轮将我和上舍利弗今在何所。答曰。先入涅槃。憍梵波提言。大师法将各自别离。当可奈何。摩诃目伽连今在何所。是比丘言。是亦灭度。憍梵波提言。佛法欲散大人过去众生可愍。问长老阿难今何所作。是比丘言。长老阿难佛灭度后。忧愁啼哭迷闷不能自喻。憍梵波提言。阿难懊恼由有爱结别离生苦。罗睺罗复云何。答言。罗睺罗得阿罗汉故无忧无愁。但观诸法无常相。憍梵波提言。难断爱已断无忧愁。憍梵波提言。我失离欲大师。于是尸利沙树园中住。亦何所为。我和上大师皆已灭度。我今不能复下阎浮提。住此般涅槃。说是言已入禅定中。踊在虚空。身放光明。又出水火。手摩日月现种种神变。自心出火烧身。身中出水四道流下。至大迦叶所。水中有声。说此偈言

  憍梵钵提稽首礼　　妙众第一大德僧
  闻佛灭度我随去　　如大象去象子随

尔时下坐比丘。持衣钵还僧。是时中间阿难思惟诸法求尽残漏。其夜坐禅经行殷勤求道。是阿难智慧多定力少。是故不即得道。定智等者乃可速得。后夜欲过疲极偃息。却卧就枕头未至枕。廓然得悟。如电光出闇者见道。阿难如是入金刚定。破一切诸烦恼山。得三明六神通共解脱。作大力阿罗汉。即夜到僧堂门敲门而唤。大迦叶问言。敲门者谁。答言。我是阿难。大迦叶言。汝何以来。阿难言。我今夜得尽诸漏。大迦叶言。不与汝开门。汝从门钥孔中来。阿难答言。可尔。即以神力从门钥孔中入。礼拜僧足忏悔。大迦叶莫复见责。大迦叶手摩阿难头言。我故为汝使汝得道。汝无嫌恨。我亦如是以汝自证。譬如手画虚空无所染着。阿罗汉心亦如是。一切法中得无所著。复汝本坐。是时僧复议言。憍梵波提已取灭度。更有谁能结集法藏。长老阿泥卢豆言。是长老阿难。于佛弟子常侍近佛。闻经能持佛常叹誉。是阿难能结集经藏。是时长老大迦叶摩阿难头言。佛嘱累汝令持法藏。汝应报佛恩。佛在何处最初说法。佛诸大弟子能守护法藏者皆以灭度。唯汝一人在。汝今应随佛心怜愍众生。故集佛法藏。是时阿难礼僧已坐师子床。时大迦叶说此偈言

  佛圣师子王　　阿难是佛子
  师子座处坐　　观众无有佛
  如是大德众　　无佛失威神
  如空无月时　　有宿而不严
  汝大智人说　　汝佛子当演
  何处佛初说　　今汝当布现

是时长老阿难一心合手。向佛涅槃方。如是说言

  佛初说法时　　尔时我不见
  如是展转闻　　佛在波罗柰
  佛为五比丘　　初开甘露门
  说四真谛法　　苦集灭道谛
  阿若憍陈如　　最初得见道
  八万诸天众　　皆亦入道迹

是千阿罗汉闻是语已。上升虚空高七多罗树。皆言咄无常力大。如我等眼见佛说法。今乃言我闻。便说偈言

  我见佛身相　　犹如紫金山
  妙相众德灭　　唯有名独存
  是故当方便　　求出于三界
  勤集诸善根　　涅槃最为乐

尔时长老阿泥卢豆。说偈言

  咄世间无常　　如水月芭蕉
  功德满三界　　无常风所坏

尔时大迦叶。复说此偈

  无常力甚大　　愚智贫富贵
  得道及未得　　一切无能免
  非巧言妙宝　　非欺诳力诤
  如火烧万物　　无常相法尔

大迦叶语阿难。从转法轮经至大般涅槃。集作四阿含。增一阿含中阿含长阿含相应阿含。是名修妒路法藏。诸阿罗汉更问。谁能明了集毗尼法藏。皆言。长老忧婆离于五百阿罗汉中持律第一。我等今请。即请言。起就师子座处坐说。佛在何处初说毗尼结戒。忧婆离受僧教。师子座处坐说。如是我闻一时佛在毗舍离。尔时须提那迦兰陀长者子初作淫欲。以是因缘故结初大罪。二百五十戒义作三部七法八法比丘尼毗尼增一。忧婆利问杂部善部。如是等八十部作毗尼藏。诸阿罗汉复更思惟。谁能明了集阿毗昙藏。念言。长老阿难于五百阿罗汉中。解修妒路义第一。我等今请。即请言。起就师子座处坐。佛在何处初说阿毗昙。阿难受僧教师子座处坐说。如是我闻一时佛在舍婆提城。尔时佛告诸比丘。诸有五怖五罪五怨不除不灭。是因缘故此生中身心受无量苦。复后世堕恶道中。诸有无此五怖五罪五怨。是因缘故于今生种种身心受乐。后世生天上乐处。何等五怖应远。一者杀二者盗三者邪淫四者妄语五者饮酒。如是等名阿毗昙藏。三法藏集竟。诸天鬼神诸龙天女种种供养。雨天华香幡盖天衣。供养法故。于是说偈

  怜愍世界故　　集结三藏法
  十力一切智　　说智无明灯

问曰。八犍度阿毗昙六分阿毗昙等。从何处出。答曰。佛在世时法无违错。佛灭度后初集法时亦如佛在。后百年阿输迦王。作般阇于瑟大会。诸大法师论议异故。有别部名字。从是以来展转。至姓迦旃延婆罗门道人。智慧利根尽读三藏内外经书。欲解佛语故。作发智经八犍度。初品是世间第一法。后诸弟子等。为后人不能尽解八犍度故。作鞞婆娑。有人言。六分阿毗昙中。第三分八品之名分别世处分。(此是楼炭经作六分中第三分)是目犍连作。六分中初分八品四品。是婆须蜜菩萨作。四品是罽宾阿罗汉作。余五分诸论议师所作。有人言。佛在时舍利弗解佛语故。作阿毗昙。后犊子道人等读诵。乃至今名为舍利弗阿毗昙。摩诃迦旃延佛在时。解佛语作昆勒。(昆勒秦言箧藏)乃至今行于南天竺。皆是广解佛语故。如说五戒。几有色几无色。几可见几不可见。几有对几无对。几有漏几无漏。几有为几无为。几有报几无报。几有善几不善。几有记几无记。如是等是名阿毗昙。复次七使。欲染使嗔恚使。有爱使憍慢使。无明使见使疑使。是七使。几欲界系几色界系几无色界系。几见谛断几思惟断。几见苦断几见集断。几见尽断几见道断。几遍使几不遍使。十智法智比智世智他心智。苦智集智灭智道智。尽智无生智。是十智。几有漏几无漏。几有为几无为。几有漏缘几无漏缘。几有为缘几无为缘。几欲界缘几色界缘几无色界缘。几不系缘。几无碍道中修。几解脱道中修。四果得时几得几失。如是等分别一切法。亦名阿毗昙。为阿毗昙三种。一者阿毗昙身及义。略说三十二万言。二者六分。略说三十六万言。三者昆勒。略说三十二万言。昆勒广比诸事以类相从。非阿毗昙。略说如是我闻一时总义竟

    大智度初品中婆伽婆释论第四

【经】婆伽婆

【论】今当说。释曰。云何名婆伽婆。婆伽婆者。婆伽言德。婆言有。是名有德。复次婆伽名分别。婆名巧。巧分别诸法总相别相故。名婆伽婆。复次婆伽名名声。婆名有。是名有名声。无有得名声如佛者。转轮圣王释梵护世者。无有及佛。何况诸余凡庶。所以者何。转轮圣王与结相应。佛已离结。转轮圣王没在生老病死泥中。佛已得渡。转轮圣王为恩爱奴仆。佛已永离。转轮圣王处在世间旷野灾患。佛已得离。转轮圣王处在无明闇中。佛处第一明中。转轮圣王若极多领四天下。佛领无量诸世界。转轮圣王财自在。佛心自在。转轮圣王贪求天乐。佛乃至有顶乐亦不贪着。转轮圣王从他求乐。佛内心自乐。以是因缘佛胜转轮圣王。诸余释梵护世者亦复如是。但于转轮圣王小胜。复次婆伽名破。婆名能。是人能破淫怒痴故。称为婆伽婆。问曰。如阿罗汉辟支佛。亦破淫怒痴与佛何异。答曰。阿罗汉辟支佛虽破三毒。气分不尽。譬如香在器中香虽出余气故在。又如草木薪火烧烟出炭灰不尽。火力薄故。佛三毒永尽无余。譬如劫尽火烧须弥山一切地都尽无烟无炭。如舍利弗嗔恚气残。难陀淫欲气残。必陵伽婆磋慢气残。譬如人被锁初脱时行犹不便。时佛从禅起经行。罗睺罗从佛经行。佛问罗睺罗。何以羸瘦。罗睺罗说偈答佛

  若人食油则得力　　若食酥者得好色
  食麻滓菜无色力　　大德世尊自当知

佛问罗睺罗。是众中谁为上座。罗睺罗答。和上舍利弗。佛言。舍利弗食不净食。尔时舍利弗转闻是语。即时吐食自作誓言。从今日不复受人请。是时波斯匿王长者须达多等。来诣舍利弗所。语舍利弗。佛不以无事而受人请。大德舍利弗复不受请。我等白衣云何当得大信清净。舍利弗言。我大师佛言。舍利弗食不净食。今不得受人请。于是波斯匿等至佛所白佛言。佛不常受人请。舍利弗复不受请。我等云何心得大信。愿佛敕舍利弗还受人请。佛言。此人心坚不可移转。佛尔时引本生因缘。昔有一国王。为毒蛇所啮。王时欲死呼诸良医令治蛇毒。时诸医言。还令蛇嗽毒气乃尽。是时诸医各设咒术。所啮王蛇即来王所。诸医积薪燃火敕蛇。还嗽汝毒。若不尔者当入此火。毒蛇思惟。我既吐毒云何还嗽。此事剧死。思惟心定即时入火。尔时毒蛇舍利弗是。世世心坚不可动也。复次长老必陵伽婆蹉常患眼痛。是人乞食常渡恒水。到恒水边弹指言。小婢住莫流水。即两断得过乞食。是恒神到佛所白佛。佛弟子必陵伽婆蹉。常骂我言小婢住莫流水。佛告必陵伽婆蹉。忏谢恒神。必陵伽婆蹉即时合手语恒神言。小婢莫嗔今忏谢汝。是时大众笑之。云何忏谢而复骂耶。佛语恒神。汝见毕陵伽婆蹉合手忏谢不。忏谢无慢而有此言。当知非恶。此人五百世来常生婆罗门家。常自憍贵轻贱余人。本来所习口言而已。心无憍也。如是诸阿罗汉。虽断结使犹有残气。如诸佛世尊。若人以刀割一臂。若人以栴檀香泥一臂。如左右眼心无憎爱。是以永无残气。栴阇婆罗门女。木杅谤佛于大众中言。汝使我有娠。何以不忧与我衣食。为尔无羞诳惑余人。是时五百婆罗门师等。皆举手唱言是是。我曹知此事。是时佛无异色亦无惭色。此事即时彰露地为大动。诸天供养散众名华。赞叹佛德佛无喜色。复次佛食马麦亦无忧戚。天王献食百味具足。不以为悦。一心无二。如是等种种饮食衣被卧具。赞呵轻敬等种种事中心无异也。譬如真金烧锻打磨都无增损。以是故阿罗汉虽断结得道。犹有残气不得称婆伽婆。问曰。婆伽婆正有此一名更有余名。答曰。佛功德无量。名号亦无量。此名取其大者。以人多识故。复有异名。名多陀阿伽陀等。云何名多陀阿伽陀。如法相解如法相说。如诸佛安隐道来。佛亦如是来更不去后有中。是故名多陀阿伽陀。复名阿罗呵。云何名阿罗呵。阿罗名贼。呵名杀。是名杀贼。如偈说

  佛以忍为铠　　精进为刚甲
  持戒为大马　　禅定为良弓
  智慧为好箭　　外破魔王军
  内灭烦恼贼　　是名阿罗呵

复次阿名不。罗呵名生。是名不生。佛心种子后世田中不生。无明糠脱故。复次阿罗呵名应受供养。佛诸结使除尽得一切智慧故。应受一切天地众生供养。以是故佛名阿罗呵。复名三藐三佛陀。云何名三藐三佛陀。三藐名正。三名遍。佛名知。是名正遍知一切法。问曰。云何正遍知。答曰

  知苦如苦相　　知集如集相
  知灭如灭相　　知道如道相

是名三藐三佛陀。复次知一切诸法实不坏相不增不减。云何名不坏相。心行处灭言语道断。过诸法如涅槃相不动。以是故名三藐三佛陀。复次一切十方诸世界名号。六道所摄众生名号。众生先世因缘未来世生处。一切十方众生心相。诸结使诸善根诸出要。如是等一切诸法悉知。是名三藐三佛陀。复名鞞侈遮罗那三般那。秦言明行具足。云何名明行具足。宿命天眼漏尽。名为三明。问曰。神通明有何等异。答曰。直知过去宿命事。是名通。知过去因缘行业。是名明。直知死此生彼。是名通。知行因缘际会不失。是名明。直尽结使不知更生不生。是名通。若知漏尽更不复生。是名明。是三明大阿罗汉大辟支佛所得。问曰。若尔者与佛有何等异。答曰。彼虽得三明明不满足。佛悉满足。是为异。问曰。云何不满。云何满。答曰。诸阿罗汉辟支佛宿命智。知自身及他人亦不能遍。有阿罗汉知一世或二世三世十百千万劫乃至八万劫。过是以往不能复知。是故不满天眼明。未来世亦如是。佛一念中生住灭时。诸结使分生时。如是住时。如是灭时。如是苦法忍苦法智中所断结使悉觉了。知如是结使解脱。得尔所有为法解脱。得尔所无为法解脱。乃至道比忍。见谛道十五心中。诸声闻辟支佛所不觉知。时少疾故。如是知过去众生因缘漏尽。未来现在亦如是。是故名佛明行具足。行名身口业。唯佛身口业具足。余皆有失。是名明行具足。复名修伽陀。修秦言好。伽陀或言去。或言说。是名好去好说。好去者。于种种诸深三摩提无量诸大智慧中去。如偈说

  佛一切智为大车　　八正道行入涅槃

是名好去。好说者。如诸法实相说。不着法爱说。观弟子智慧力。是人正使一切方便神通智力化之。亦无如之何。是人可度是疾是迟。是人应是处度。是人应说布施。或说戒或说涅槃。是人应说五众十二因缘四谛等诸法能入道。如是等种种。知弟子智力。而为说法。是名好说。复名路迦惫。路迦秦言世。惫名知。是名知世间。问曰。云何知世间。答曰。知二种世间。一众生二非众生及如实相。知世间世间因知世间灭出世间道。复次知世间。非如世俗知。亦非外道知。知世间无常故苦。苦故无我。复次知世间相非有常非无常。非有边非无边。非去非不去。如是相亦不着。清净常不坏相如虚空。是名知世间。复名阿耨多罗。秦言无上。云何无上。涅槃法无上。佛自知是涅槃不从他闻。亦将导众生令至涅槃。如诸法中涅槃无上。众生中佛亦无上。复次持戒禅定智慧。教化众生。一切无有与等者。何况能过。故言无上。复次阿名无。耨多罗名答。一切外道法可答可破。非实非清净故。佛法不可答不可破。出一切语言道。亦实清净故。以是故名无答。复名富楼沙昙藐婆罗提。富楼沙。秦言丈夫。昙藐言可化。婆罗提言调御师。是名可化丈夫调御师。佛以大慈大悲大智故。有时软美语。有时苦切语。有时杂语。以此调御令不失道。如偈说

  佛法为车弟子马　　实法宝主佛调御
  若马出道失正辙　　如是当治令调伏
  若小不调轻法治　　好善成立为上道
  若不可治便弃舍　　以是调御为无上

复次调御师有五种。初父母兄姊亲里中官法下师法。今世三种法治。后世阎罗王治。佛以今世乐后世乐及涅槃乐利益故。名师上。四种法治人不久毕坏。不能常实成就。佛成人以三种道。常随道不失。如火自相不舍乃至灭。佛令人得善法亦如是。至死不舍。以是故。佛名可化丈夫调御师。问曰。女人佛亦化令得道。何以独言丈夫。答曰。男尊女卑故。女从男故。男为事业主故。复次女人有五碍。不得作转轮王释天王魔天王梵天王。佛以是故不说。复次若言佛为女人调御师。为不尊重。若说丈夫一切都摄。譬如王来不应独来。必有侍从。如是说丈夫。二根无根及女尽摄。以是故说丈夫。用是因缘故。佛名可化丈夫调御师。复名舍多提婆魔[少/(兔-、)]舍喃。舍多秦言教师。提婆言天。魔[少/(兔-、)]舍喃言人。是名天人教师。云何名天人教师。佛示导是应作是不应作。是善是不善。是人随教行不舍道法。得烦恼解脱报。是名天人师。问曰。佛能度龙鬼神等堕余道中生者。何以独言天人师。答曰。度余道中生者少。度天人中生者多。如白色人虽有黑黡子不名黑人。黑少故。复次人中结使薄厌心易得。天中智慧利。以是故。二处易得道。余道中不尔。复次言天则摄一切天。言人则摄一切地上生者。何以故。天上则天大。地上则人大。是故说天则天上尽摄。说人则地上尽摄。复次人中得受戒律仪见谛道思惟道及诸道果。或有人言。余道中不得。或有人言。多少得。天人中易得多得。以是故佛为天人师。复次人中行乐因多。天中乐报多。善法是乐因。乐是善法报。余道中善因报少。以是故佛为天人师。复名佛陀。(秦言知者)知何等法。知过去未来现在众生数非众生数有常无常等一切诸法。菩提树下了了觉知故。名为佛陀。问曰。余人亦知一切诸法。如摩醯首罗天。(秦言大自在)八臂三眼骑白牛。如韦纽天(秦言遍闷)四臂捉贝持轮骑金翅鸟。如鸠摩罗天。(秦言童子)是天擎鸡持铃。捉赤幡骑孔雀。皆是诸天大将。如是等诸天各各言大。皆称一切智。有人作弟子学其经书。亦受其法。言是一切智。答曰。此不应一切智。何以故。嗔恚憍慢心着故。如偈说

  若彩画像及泥像　　闻经中天及赞天
  如是四种诸天等　　各各手执诸兵杖
  若力不如畏怖他　　若心不善恐怖他
  此天定必若怖他　　若少力故畏怖他
  是天一切常怖畏　　不能除却诸衰苦
  有人奉事恭敬者　　现世不免没忧海
  有人不敬不供养　　现世不妨受富乐
  当知虚诳无实事　　是故智人不属天
  若世间中诸众生　　业因缘故如循环
  福德缘故生天上　　杂业因缘故人中
  世间行业属因缘　　是故智者不依天

复次是三天爱之则欲令得一切愿。恶之则欲令七世灭。佛不尔。菩萨时若怨家贼来欲杀。尚自以身肉头目髓脑而供养之。何况得佛。不惜身时。以是故独佛应当受佛名号。应当归命佛。以佛为师不应事天。复次佛有二事。一者大功德神通力。二者第一净心诸结使灭。诸天虽有福德神力。诸结使不灭故心不清净。心不清净故神力亦少。声闻辟支佛虽结使灭心清净。福德薄故力势少。佛二法满足故称胜一切人。余人不胜一切人。婆伽婆名有德。先已说。复名阿婆磨。(秦言无等)复名阿婆摩婆摩(秦言无等等)复名路迦那他(秦言世尊)复名波罗伽(秦言度彼岸)复名婆檀陀(秦言大德)复名尸梨伽那(秦言厚德)如是等无量名号。父母名字悉达陀(秦言成利)得道时知一切诸法故。是名为佛。应受诸天世人供养。如是等得名大德厚德。如是种种随德立名。问曰。汝爱刹利种。净饭王子字悉达多。以是故而大称赞言一切智。一切智人无也。答曰。不尔。汝恶邪故妒嗔佛作妄语。实有一切智人。何以故。佛一切众生中身色颜貌端正无比。相德明具胜一切人。小人见佛身相。亦知是一切智人。何况大人。如放牛譬喻经中说。摩伽陀国王频婆娑罗请佛三月。及五百弟子。王须新乳酪酥供养佛及比丘僧。语诸放牛人来近处住。日日送新乳酪酥。竟三月。王怜愍此放牛人语言。汝往见佛还出放牛。诸放牛人往诣佛所。于道中自共论言。我等闻人说。佛是一切智人。我等是下劣小人。何能别知实有一切智人。诸婆罗门喜好酥酪故。常来往诸放牛人所作亲厚。放牛人由是闻婆罗门种种经书名字故。言四违陀经中治病法斗战法星宿法祠天法歌舞论议难问法。如是等六十四种世间伎艺。净饭王子广学多闻。若知此事不足为难。其从生已来不放牛。我等以放牛秘法问之。若能解者实是一切智人。作是论已前入竹园。见佛光明照于林间。进前觅佛见坐树下状似金山如酥投火其炎大明。有似融金散竹林间上紫金光色。视之无厌。心大欢喜。自相谓言

  今此释师子　　一切智有无
  见之无不喜　　此事亦已足
  光明第一照　　颜貌甚贵重
  身相威德备　　与佛名相称
  相相皆分明　　威神亦满足
  福德自缠络　　见者无不爱
  圆光身处中　　观者无厌足
  若有一切智　　必有是功德
  一切诸彩画　　宝饰庄严像
  欲比此妙身　　不可以为喻
  能满诸观者　　令得第一乐
  见之发净信　　必是一切智

如是思惟已礼佛而坐。问佛言。放牛人有几法成就。能令牛群番息。有几法不成就。令牛群不增不得安隐。佛答言。有十一法。放牛人能令牛群番息。何等十一。知色知相知刮刷知覆疮知作烟知好道知牛所宜处知好度济知安隐处知留乳知养牛主。若放牛人知此十一法。能令牛群番息。比丘亦如是。知十一法能增长善法。云何知色。知黑白杂色。比丘亦如是。知一切色皆是四大四大造。云何知相。知牛吉不吉相。与他群合因相则识。比丘亦如是。见善业相知是智人。见恶业相知是愚人。云何刮刷。为诸虫饮血则增长诸疮。刮刷则除害。比丘亦如是。恶邪觉观虫饮善根血增长心疮。除则安隐。云何覆疮。若衣若草叶以防蚊虻恶刺。比丘亦如是。念正观法覆六情疮。不令烦恼贪欲嗔恚恶虫刺蕀所伤。云何知作烟除诸蚊虻。牛遥见烟则来趣向屋舍。比丘亦如是。如所闻而说除诸结使蚊虻。以说法烟引众生。入于无我实相空舍中。云何知道。知牛所行来去好恶道。比丘亦如是。知八圣道能至涅槃。离断常恶道。云何知牛所宜处。能令牛番息少病。比丘亦如是。说佛法时得清净法喜。诸善根增盛。云何知济。知易入易度无波浪恶虫处。比丘亦如是。能至多闻比丘所问法。说法者知前人心利钝烦恼轻重。令入好济安隐得度。云何知安隐处。知所住处无虎狼师子恶虫毒兽。比丘亦如是。知四念处安隐无烦恼恶魔毒兽。比丘入此则安隐无患。云何留乳。犊母爱念犊子故与乳。以留残乳故。犊母欢喜则犊子不竭。牛主及放牛人。日日有益。比丘亦如是。居士白衣给施衣食。当知节量不令罄竭。则檀越欢喜信心不绝。受者无乏。云何知养。牛主诸大特牛能守牛群。故应养护不令羸瘦。饮以麻油。饰以璎珞。标以铁角摩刷赞誉称等。比丘亦如是。众僧中有威德大人。护益佛法摧伏外道。能令八众得种诸善根。随其所宜恭敬供养等。放牛人闻此语已如是思惟。我等所知不过三四事。放牛师辈远不过五六事。今闻此说叹未曾有。若知此事余亦皆尔。实是一切智人。无复疑也。是经此中应广说。以是故知有一切智人。问曰。世间不应有一切智人。何以故。无见一切智人者。答曰。不尔。不见有二种。不可以不见故便言无。一者事实有。以因缘覆故不见。譬如人姓族初及雪山斤两恒河边沙数。有而不可知。二者实无无故不见。譬如第二头第三手。无因缘覆而不见。如是一切智人因缘覆故汝不见。非无一切智人。何等是覆因缘。未得四信心着恶邪。汝以是因缘覆故。不见一切智人。问曰。所知处无量故。无一切智人。诸法无量无边。多人和合尚不能知。何况一人。以是故无一切智人。答曰。如诸法无量。智慧亦无量无数无边。如函大盖亦大。函小盖亦小。问曰。佛自说佛法不说余经若药方星宿算经世典。如是等法若是一切智人。何以不说。以是故知非一切智人。答曰。虽知一切法。用故说。不用故不说。有人问故说。不问故不说。复次一切法略说有三种。一者有为法。二者无为法。三者不可说法。此已摄一切法。问曰。十四难不答。故知非一切智人。何等十四难。世界及我常世界及我无常。世界及我亦有常亦无常。世界及我亦非有常亦非无常。世界及我有边。无边。亦有边亦无边。亦非有边亦非无边。死后有神去后世。无神去后世。亦有神去亦无神去。死后亦非有神去。亦非无神去后世。是身是神。身异神异。若佛一切智人。此十四难何以不答。答曰。此事无实故不答。诸法有常无此理。诸法断亦无此理。以是故佛不答。譬如人问构牛角得几升乳。是为非问。不应答。复次世界无穷如车轮。无初无后。复次答此。无利有失堕恶邪中。佛知十四难常覆四谛诸法实相。如渡处有恶虫水不应将人渡。安隐无患处。可示人令渡。复次有人言。是事非一切智人不能解。以人不能知故佛不答

复次若人无言有。有言无。是名非一切智人。一切智人。有言有。无言无。佛有不言无。无不言有。但说诸法实相。云何不名一切智人。譬如日不作高下亦不作平地等一而照。佛亦如是。非令有作无。非令无作有。常说实智慧光照诸法如一道。人问佛言。大德十二因缘佛作耶。他作耶。佛言。我不作十二因缘。余人亦不作。有佛无佛生因缘老死。是法常定住。佛能说是生因缘老死乃至无明因缘诸行。复次十四难中若答有过罪。若人问。石女黄门儿长短好丑何类。此不应答。以无儿故。复次此十四难是邪见非真实。佛常以真实。以是故置不答。复次置不答。是为答。有四种答。一决了答。如佛第一涅槃安隐。二解义答。三反问答。四置答。此中佛以置答。汝言无一切智人。有是言而无义。是大妄语。实有一切智人。何以故。得十力故。知处非处故。知因缘业报故。知诸禅定解脱故。知众生根善恶故。知种种欲解故。知种种世间无量性故。知一切至处道故。先世行处忆念知故。天眼分明得故。知一切漏尽故。净不净分明知故。说一切世界中上法故。得甘露味故。得中道故。知一切法若有为若无为实相故。永离三界欲故。如是种种因缘故。佛为一切智人。问曰。有一切智人。何等人是。答曰。是第一大人三界尊名曰佛。如赞佛偈说

  顶生转轮王　　如日月灯明
  释迦贵种族　　净饭王太子
  生时动三千　　须弥山海水
  为破老病死　　哀愍故生世
  生时行七步　　光明满十方
  四观发大音　　我生胎分尽
  成佛说妙法　　大音振法鼓
  以此觉众生　　世间无明睡
  如是等种种　　希有事已现
  诸天及世人　　见之皆欢喜
  佛相庄严身　　大光满月面
  一切诸男女　　视之无厌足
  生身乳餔力　　胜万亿香象
  神足力无上　　智慧力无量
  佛身大光明　　照曜佛身表
  佛在光明中　　如月在光里
  种种恶毁佛　　佛亦无恶想
  种种称誉佛　　佛亦无喜想
  大慈视一切　　怨亲等无异
  一切有识类　　咸皆知此事
  忍辱慈悲力　　故能胜一切
  为度众生故　　世世受勤苦
  其心常一定　　为众作利益
  智慧力有十　　无畏力有四
  不共有十八　　无量功德藏
  如是等无数　　希有功德力
  如师子无畏　　破诸外道法
  转无上梵轮　　度脱诸三界

是名为婆伽婆。婆伽婆义无量。若广说则废余事。以是故略说

大智度论卷第二大智度初品中住王舍城释论第五(卷第三)

        龙树菩萨造

        后秦龟兹国三藏法师鸠摩罗什奉　诏译

【经】住王舍城

【论】今当说。问曰。何以不直说般若波罗蜜法。而说佛住王舍城。答曰。说方时人。令人心生信故。云何名住。四种身仪坐卧。行住是名住。又以怖魔军众。自令弟子欢喜入种种诸禅定故。在是中住。复次三种住。天住梵住圣住。六种欲天住法。是为天住。梵天等乃至非有想非无想天住法。是名梵住。诸佛辟支佛阿罗汉住法。是名圣住。于是三住法中住圣住法。怜愍众生故。住王舍城。复次布施持戒善心三事故名天住。慈悲喜舍四无量心故名梵住。空无相无作。是三三昧名圣住。圣住法佛于中住。复次四种住。天住．梵住．圣住．佛住。三住如前说。佛住者。首楞严等。诸佛无量三昧十力四无所畏十八不共法一切智等种种诸慧。及八万四千法藏度人门。如是等种种诸佛功德。是佛所住处。佛于中住。略说住竟。王舍城者。问曰。如舍婆提迦毗罗婆波罗奈大城。皆有诸王舍。何以故独名此城为王舍。答曰。有人言。是摩伽陀国王有子。一头两面四臂。时人以为不祥。王即裂其身首弃之旷野。罗刹女鬼。名梨罗。还合其身而乳养之。后大成人力能并兼诸国王。有天下取诸国王万八千人。置此五山中。以大力势治阎浮提。阎浮提人因名此山。为王舍城。复次有人言。摩伽陀王先所住城。城中失火一烧一作。如是至七。国人疲役王大忧怖。集诸智人问其意故。有言宜应易处。王即更求住处。见此五山周匝如城。即作宫殿于中止住。以是故名王舍城。复次往古世时。此国有王。名婆薮。心厌世法出家作仙人。是时居家婆罗门。与诸出家仙人共论议。居家婆罗门言。经书云。天祀中应杀生啖肉。诸出家仙人言。不应天祀中杀生啖肉。共诤云云。诸出家婆罗门言。此有大王出家作仙人。汝等信不。诸居家婆罗门言信。诸出家仙人言。我以此人为证。后日当问。诸居家婆罗门。即以其夜。先到婆薮仙人所。种种问已。语婆薮仙人。明日论议汝当助我。如是明旦论时。诸出家仙人问婆薮仙人。天祀中应杀生啖肉不。婆薮仙人言。婆罗门法天祀中应杀生啖肉。诸出家仙人言。于汝实心云何。应杀生啖肉不。婆薮仙人言。为天祀故应杀生啖肉。此生在天祀中死故得生天上。诸出家仙人言。汝大不是。汝大妄语。即唾之言。罪人灭去。是时婆薮仙人寻陷入地没踝。是初开大罪门故。诸出家仙人言。汝应实语。若故妄语者。汝身当陷入地中。婆薮仙人言。我知为天故杀羊啖肉无罪。即复陷入地至膝。如是渐渐稍没至腰至颈。诸出家仙人言。汝今妄语得现世报。更以实语者。虽入地下。我能出汝令得免罪。尔时婆薮仙人自思惟言。我贵重人不应两种语。又婆罗门四围陀法中。种种因缘赞祀天法。我一人死当何足计。一心言。应天祀中杀生啖肉无罪。诸出家仙人言。汝重罪人。催去不用见汝。于是举身没地中。从是以来乃至今日。常用婆薮仙人王法。于天祀中杀羊。当下刀时言婆薮杀汝。婆薮之子。名曰广车。嗣位为王。后亦厌世法而复不能出家。如是思惟。我父先王出家生入地中。若治天下复作大罪。我今当何以自处。如是思惟时闻空中声言。汝若行见难值希有处。汝应是中作舍住。作是语已便不复闻声。未经几时王出田猎。见有一鹿走疾如风。王便逐之而不可及。遂逐不止。百官侍从无能及者。转前见有五山周匝峻固。其地平正生草细软好华遍地。种种林木华果茂盛。温泉凉池皆悉清净其地庄严。处处有散天华天香闻天伎乐。尔时乾闼婆伎。适见王来各自还去。是处希有未曾所见。今我正当在是中作舍住。如是思惟已。群臣百官寻迹而到。王告诸臣。我前所闻空中声言。汝行若见希有难值之处。汝应是中作舍住。我今见此希有之处。我应是中作舍住即舍本城于此山中住。是王初始在是中住。从是已后次第止住。是王元起造立宫舍故。名王舍城。略说王舍城本起竟

【经】耆阇崛山中

【论】耆阇名鹫。崛名头。问曰。何以名鹫头山。答曰。是山顶似鹫。王舍城人见其似鹫。故共传言鹫头山。因名之为鹫头山。复次王舍城南尸陀林中多诸死人。诸鹫常来啖之。还在山头。时人遂名鹫头山。是山于五山中最高大。多好林水圣人住处。问曰。已知耆阇崛山义。佛何以故住王舍城。诸佛法普慈一切。如日照万物无不蒙明。如沤只尼大城富楼那跋檀大城阿蓝车多罗大城弗迦罗婆多大城。如是等大城多人丰乐而不住。何故多住王舍城舍婆提大城。波罗柰迦毗罗婆瞻婆婆翅多拘睒鞞鸠楼城等。虽有住时而多住王舍城舍婆提。云何知多住二处。见佛诸经多在二城说。少在余城。答曰。佛虽大慈等及。以沤只尼等诸大城是边国故不住。又弥离车弊恶人多。善根未熟故。如偈说

  如日光等照　　华熟则时开
  若华未应敷　　则亦不强开
  佛亦复如是　　等心而说法
  善根熟则敷　　未熟则不开
  以是故世尊　　住三种人中
  利智善根熟　　结使烦恼薄

复次知恩故。多住王舍城舍婆提城。问曰。云何知恩故。多住二城。答曰。憍萨罗国是佛所生地。如佛答频婆娑罗王偈说

  有好妙国土　　在于雪山边
  丰乐多异宝　　名曰憍萨罗
  日种诸释子　　我在是中生
  心厌老病死　　出家求佛道

又是憍萨罗国主波斯匿王。住舍婆提大城中。佛为法王亦住此城。二主应住一处故。复次是憍萨罗国佛生身地。知恩故多住舍婆提。问曰。若知恩故多住舍婆提者。迦毗罗婆城近佛生处。何不多住。答曰。佛诸结尽无复余习。近诸亲属亦无异想。然释种弟子多未离欲。若近亲属则染着心生。问曰。何以不护舍婆提弟子。而多住舍婆提。答曰。迦毗罗婆弟子多。佛初还国。迦叶兄弟千比丘。本修婆罗门法。苦行山间形容憔悴。父王见之。以此诸比丘不足光饰。世尊即选诸释贵人子弟兼人少壮。户遣一人强令出家。其中有善心乐道。有不乐者。此诸释比丘不应令还本生处。舍婆提弟子辈不尔。以是故佛多住舍婆提。不多住迦毗罗婆。复次出家法应不近亲属。亲属心着如火如蛇。居家婆罗门子为学问故。尚不应在生处。何况出家沙门。复次如舍婆提城大。迦毗罗婆不尔。舍婆提城九亿家。是中若少时住者。不得度多人。以是故多住。复次迦毗罗婆城中佛生处。是中人已久习行善根熟利智慧。是中佛少时住说法。不须久住度已而去。舍婆提人。或初习行。或久习行。或善根熟。或善根未熟。或利根。或不利根。多学种种经书故研心令利。入种种邪见网中。事种种师。属种种天。杂行人多。以是故佛住此久。如治痈师知痈已熟。破出脓与药而去。若痈未熟是则久住涂慰。佛亦如是。若弟子善根熟教化已更至余处。若可度弟子善根未熟则须久住。佛出世间。正为欲度众生着涅槃境界安隐乐处故。是故多住舍婆提。不多住迦毗罗婆。佛于摩伽陀国尼连禅河侧沤楼频螺聚落得阿耨多罗三藐三菩提。成就法身故多住王舍城。问曰。已知多住王舍城舍婆提因缘。于此二城。何以多住王舍城。答曰。以报生地恩故。多住舍婆提。一切众生皆念生地。如偈说

  一切论议师　　自爱所知法
  如人念生地　　虽出家犹诤

以报法身地恩故。多住王舍城。诸佛皆爱法身故。如偈说

  过去未来　　现在诸佛　　供养法身
  师敬尊重

法身于生身胜故。二城中多住王舍城。复次以坐禅精舍多故。余处无有。如竹园鞞婆罗跋恕萨多般那求呵因陀世罗求阿萨簸恕魂直迦钵婆罗王舍城。有五精舍。竹园在平地。余国无此多精舍。舍婆提一处。祇洹精舍更有一处。摩伽罗母堂更无第三处。婆罗奈斯国一处。鹿林中精舍名梨师槃陀那。毗耶离二处。一名摩呵槃。二名弥猴池岸精舍。鸠睒弥一处。名劬师罗园。如是诸国。或一处有精舍。或空树林。以王舍城多精舍坐禅人所宜其处安隐故多住此。复次是中有富那罗等六师。自言。我是一切智人。与佛为对。及长爪梵志婆蹉姓拘迦那大等。皆外道大论议师。及长者尸利崛多提婆达多阿阇贳等。是谋欲害佛不信佛法各怀嫉妒。有是人辈故佛多住此。譬如毒草生处近边必有良药。如偈说

  譬如师子　　百兽之王　　为小虫吼
  为众所笑　　若在虎狼　　猛兽之中
  奋迅大吼　　智人所可

  诸论议师如猛虎　　在此众中无所畏
  大智慧人多见闻　　在此众中最第一

以是大智多闻人皆在王舍城故。佛多住王舍城。复次频婆娑罗王。到伽耶祀舍中。迎佛及余结发千阿罗汉。是时佛为王说法。得须陀洹道。即请佛言。愿佛及僧就我王舍城。尽形寿受我衣被饮食卧具医药。给所当得。佛即受请。是故多住王舍城。复次阎浮提四方中。东方为始。日初出故。次第南方西方北方。东方中摩伽陀国最胜。摩伽陀国中王舍城最胜。是中有十二亿家。佛涅槃后。阿阇贳王以人民转少故。舍王舍大城。其边更作一小城。广长一由旬。名波罗利弗多罗。犹尚于诸城中最大。何况本王舍城。复次是中人多聪明皆广学多识。余国无此。复次有人应得道者。待时待处待人。佛豫知释提桓因及八万诸天。应在摩伽陀国石室中得道。是故佛多住王舍城。复次其国丰乐乞食易得。余国不如。又以三因缘故。一者频婆娑罗王约敕。宫中常作千比丘食。二者树提伽。虽人中生常受天富乐。又多富贵诸优婆塞。三者阿波罗逻龙王。善心受化作佛弟子。除世饥馑故常降好雨。是故国丰。如佛涅槃后。长老摩呵迦叶欲集法思惟。何国丰乐乞食易得疾得集法。如是思已。忆王舍城中频婆娑罗王约敕常设千比丘食。频婆娑罗王虽死此法不断。是中食易得易可集法。余处无如是常供。若行乞食时诸外道来共论议。若共论议集法事废。若不共论便言诸沙门不如我。如是思惟。择取最上千阿罗汉。将就耆阇崛山集结经藏。以是三因缘。故知摩伽陀国乞食易得。如阿含及毗尼中说言。毗耶离国时时有饥饿。如降难陀婆难陀龙王兄弟经中说。舍婆提国饥饿。余诸国亦时时有饥饿。摩伽陀国中无是事。以是故知。摩伽陀国丰乐乞食易得

复次王舍城在山中闲静。余国精舍平地故。多杂人入出来往易故不闲静。又此山中多精舍。诸坐禅人诸圣人皆乐闲静多得住中。佛是圣人坐禅人主。是故多住王舍城。如是等种种因缘故多住王舍城。问曰。若住王舍城可尔。何以不多住竹园而多住耆阇崛山。答曰。我已答。圣人坐禅人乐闲静处。问曰。余更有四山。鞞婆罗跋恕等。何以不多住。而多住耆阇崛山。答曰。耆阇崛山于五山中最胜故。云何胜。耆阇崛山精舍近城而山难上。以是故杂人不来。近城故乞食不疲。以是故佛多在耆阇崛山中。不在余处。复次长老摩诃迦叶。于耆阇崛山。集三法藏。可度众生。度竟欲随佛入涅槃。清朝着衣持钵入王舍城乞食已。上耆阇崛山语诸弟子。我今日入无余涅槃。如是语已入房结加趺坐。诸无漏禅定自熏身。摩诃迦叶诸弟子。入王舍城语诸贵人。知不。尊者摩诃迦叶今日入无余涅槃。诸贵人闻是语皆大愁忧言。佛已灭度。摩诃迦叶持护佛法。今日复欲入无余涅槃。诸贵人诸比丘。晡时皆共集耆阇崛山。长老摩诃迦叶。晡时从禅定起入众中坐。赞说无常。诸一切有为法因缘生故无常。本无今有已有还无故无常。因缘生故无常。无常故苦。苦故无我。无我故有智者不应着我我所。若着我我所。得无量忧愁苦恼一切世间中。心应厌求离欲。如是种种说世界中苦。开导其心令入涅槃。说此语竟着从佛所得僧伽梨。持衣钵捉杖。如金翅鸟现上升虚空。四种身仪坐卧行住。一身现无量身。满东方世界。于无量身还为一身。身上出火身下出水。身上出水身下出火。南西北方亦如是。众心厌世皆欢喜已。于耆阇崛山头。与衣钵俱作是愿言。令我身不坏。弥勒成佛。我是骨身还出。以此因缘度众生。如是思惟已。直入山头石内。如入软埿。入已山还合。后人寿八万四千岁。身长八十尺。时弥勒佛出。佛身长百六十尺。佛面二十四尺。圆光十里。是时众生闻弥勒佛出世。无量人随佛出家。佛在大众中。初说法时九十九亿人得阿罗汉道。六通具足。第二大会九十六亿人得阿罗汉道。第三大会九十三亿人得阿罗汉道。自是已后度无数人。尔时人民久后懈厌。弥勒佛见众人如是。以足指扣开耆阇崛山。是时长老摩诃迦叶骨身。着僧伽梨而出礼弥勒足。上升虚空现变如前。即于空中灭身而般涅槃。尔时弥勒佛诸弟子怪而问言。此是何人。似人而小。身着法衣能作变化。弥勒佛言。此人是过去释迦文尼佛弟子。名摩诃迦叶。行阿兰若少欲知足。行头陀比丘中第一。得六神通共解脱大阿罗汉。彼时人寿百年少出多减。以是小身。能办如是大事。汝等大身利根。云何不作如是功德。是时诸弟子皆惭愧发大厌心。弥勒佛随众心。为说种种法。有人得阿罗汉阿那含斯陀含须陀洹。有种辟支佛善根。有得无生法忍不退菩萨。有得生天人中受种种福乐。以是故知。是耆阇崛山福德吉处。诸圣人喜住处。佛为诸圣人主。是故佛多住耆阇崛山。复次耆阇崛山。是过去未来现在诸佛住处。如富楼那弥帝隶耶尼子经中说。佛语富楼那。若使三千大千世界劫烧若更生。我常在此山中住。一切众生以结使缠缚。不作见佛功德。以是故不见我。复次耆阇崛山清净鲜洁。受三世佛及诸菩萨。更无如是处。是故多住耆阇崛山。复次诸摩诃衍经。多在耆阇崛山中说。余处说少。何以故。是中净洁有福德闲静故。一切三世诸佛住处。十方诸菩萨。亦赞叹恭敬此处。诸天龙夜叉阿修罗伽留罗乾闼婆甄陀罗摩睺罗伽等大力众神。守护供养恭敬是处。如偈说

  是耆阇崛山　　诸佛所住处
  圣人所止息　　覆荫一切故
  众苦得解脱　　唯有真法存

复次是中十方无量智慧福德大力菩萨。常来见释迦牟尼佛。礼拜恭敬听法。故佛说诸摩诃衍经。多在耆阇崛山。诸摩诃衍经般若为最大。今欲说故云何不住耆阇崛山。略说住耆阇崛山因缘竟

    大智度共摩诃比丘僧释论第六

【经】共摩诃比丘僧

【论】共名一处一时一心一戒一见一道一解脱。是名为共。摩诃秦言大。或多或胜。云何大。一切众中最上故。一切障碍断故。天王等大人恭敬故。是名为大。云何多。数至五千故名多。云何胜。一切九十六种道论议能破。故名胜。云何名比丘。比丘名乞士。清净活命故名为乞士。如经中说。舍利弗入城乞食。得已。向壁坐食。是时有梵志女名净目。来见舍利弗。问舍利弗言。沙门汝食耶。答言食。净目言。汝沙门下口食耶。答言不姊。仰口食耶。不。方口食耶。不。四维口食耶。不。净目言。食法有四种。我问汝。汝言不。我不解。汝当说。舍利弗言。有出家人合药种谷殖树等不净活命者。是名下口食。有出家人观视星宿日月风雨雷电霹雳不净活命者。是名仰口食。有出家人曲媚豪势通使四方巧言多求不净活命者。是名方口食。有出家人学种种咒术卜筮吉凶如是等种种不净活命者。是名四维口食。姊。我不堕是四不净食中。我用清净乞食活命。是时净目闻说清净法食。欢喜信解。舍利弗因为说法得须陀洹道。如是清净乞食活命故名乞士。复次比名破。丘名烦恼。能破烦恼故名比丘。复次出家人名比丘。譬如胡汉羌虏各有名字。复次受戒时自言。我某甲比丘尽形寿持戒。故名比丘。复次比名怖。丘名能。能怖魔王及魔人民。当出家剃头着染衣受戒。是时魔怖。何以故怖。魔王言是人必得入涅槃。如佛说。有人能剃头着染衣一心受戒。是人渐渐断结离苦入涅槃云何名僧伽。僧伽秦言众。多比丘一处和合是名僧伽。譬如大树丛聚是名为林。一一树不名为林。除一一树亦无林。如是一一比丘不名为僧。除一一比丘亦无僧。诸比丘和合故僧名生。是僧四种。有羞僧。无羞僧。哑羊僧。实僧。云何名有羞僧。持戒不破。身口清净。能别好丑。未得道。是名有羞僧。云何名无羞僧。破戒。身口不净。无恶不作。是名无羞僧。云何名哑羊僧。虽不破戒。钝根无慧。不别好丑。不知轻重。不知有罪无罪。若有僧事。二人共诤。不能断决。默然无言。譬如白羊乃至人杀不能作声。是名哑羊僧。云何名实僧。若学人若无学人。住四果中。行四向道。是名实僧。是中二种僧可共。百一羯磨说戒受岁种种得作。是中实声闻僧六千五百。菩萨僧二种。有羞僧实僧。以是实僧故余皆得名僧。以是故名比丘僧

【经】大数五千分

【论】云何名大数。少过少减。是名为大数。云何名分。多众边取一分。是名分。是诸比丘千万众中。取一分。五千人以是故名五千分

【经】皆是阿罗汉

【论】问曰。云何名阿罗汉。阿罗名贼。汉名破。一切烦恼贼破是名阿罗汉。复次阿罗汉一切漏尽故。应得一切世间诸天人供养。复次阿名不。罗汉名生。后世中更不生。是名阿罗汉

【经】诸漏已尽

【论】三界中三种漏已尽无余。故言漏尽也

【经】无复烦恼

【论】一切结使流受扼缚盖见缠等断除故。名无烦恼也

【经】心得好解脱慧得好解脱

【论】问曰。何以说心得好解脱慧得好解脱。答曰。外道离欲人。一处一道心得解脱。非于一切障法得解脱。以是故。阿罗汉名心得好解脱慧得好解脱。复次诸阿罗汉。二道心得解脱。见谛道思惟道。以是故名心得好解脱。学人心虽得解脱。非好解脱。何以故。有残结使故。复次诸外道等。助道法不满。若行一功德若行二功德求道不能得。如人但布施求清净。如人祀天。言能脱忧衰。能得常乐国中生。亦更有言八清净道。一自觉二闻三读经四畏内苦五畏大众生苦六畏天苦七得好师八大布施。但说第八名清净道。复次有外道。但布施持戒说清净。有但布施禅定说清净。有但布施求智慧说清净。如是等种种道不具足。若无功德若少功德。说清净。是人虽一处心得解脱。不名好解脱。涅槃道不满足故。如偈说

  无功德人不能渡　　生老病死之大海
  少功德人亦不渡　　善行道法佛所说

是中应说须跋陀梵志经。须跋陀梵志年百二十岁。得五神通。阿那跋达多池边住。夜梦见一切人失眼裸形冥中立。日堕地破大海水竭。大风起吹须弥山破散。觉已恐怖。思惟言。何以故尔。我命欲尽。若天地主欲堕。犹豫不能自了。以有此恶梦故。先世有善知识天。从上来下语须跋陀言。汝莫恐怖。有一切智人名佛。后夜半当入无余涅槃。是故汝梦。不为汝身。是时须跋陀。明日到拘夷那竭国树林中。见阿难经行。语阿难言。我闻汝师说新涅槃道。今日夜半当取灭度。我心有疑。请欲见佛决我所疑。阿难答言。世尊身极。汝若难问劳扰世尊。须跋陀如是重请至三。阿难答如初。佛遥闻之敕语阿难。听须跋陀梵志来前自在难问。是吾末后共谈。最后得道弟子。是时须跋陀得前见佛。问讯世尊已。于一面坐。如是念。诸外道辈舍恩爱财宝出家皆不得道。独瞿昙沙门得道如是念竟。即问佛言。是阎浮提地。六师辈各自称言。我是一切智人。是语实不。尔时世尊以偈答曰

  我年一十九　　出家学佛道
  我出家已来　　已过五十岁
  净戒禅智慧　　外道无一分
  少分尚无有　　何况一切智

若无八正道。是中无第一果第二第三第四果。若有八正道。是中有第一果第二第三第四果。须跋陀是我法中有八正道。是中有第一道果第二第三第四道果。余外道法皆空。无道无果无沙门无婆罗门。如是我大众中。实作师子吼。须跋陀梵志闻是法得阿罗汉道。思惟言。我不应佛后般涅槃。如是思惟竟。在佛前结加趺坐。自以神力身中出火烧身而取灭度。以是故。佛言无功德少功德。是助道法不满。皆不得度。佛说一切功德具足故。能度弟子。譬如小药师以一种药二种药不具足故不能差重病。大药师辈具足众药。能差诸病。问曰。若一切三界烦恼离故。心得解脱。何以故。佛言染爱离心得解脱。答曰。爱能系闭心有大力以是故说。不说余烦恼。爱断余则断。复次若人言王来知必有将从。染爱亦如是。又如捉巾一头余则尽随。爱染亦如是。爱断则知余烦恼皆已断。复次诸结使皆属爱见。属爱烦恼覆心。属见烦恼覆慧。如是爱离故。属爱结使亦离得心解脱。如是无明离故。属见结使亦离得慧解脱。复次是五千阿罗汉。应不退法得无生智。以是故。言心得好解脱慧得好解脱。不退故。退法阿罗汉。得时解脱如劬提迦等。虽得解脱非好解脱。以退法故

【经】心调柔软

【论】若有恭敬供养嗔恚骂詈挝打者。心等无异。若得珍宝瓦石视之一等。若有持刀斫截手足。有持栴檀涂身者。亦等无异。复次淫欲嗔恚憍慢疑见。根本已断故。是谓心调柔软。复次是诸阿罗汉。欲染处不染。应嗔处不嗔。应痴处不痴。守护六情。以是故名心调柔软。如偈说

  人守护六情　　如好马善调
  如是实智人　　诸天所敬视

诸余凡人辈不能守护六情。欲嗔慢痴疑见不断故。不调柔如恶弊马。以是故。诸阿罗汉名心调柔软

【经】摩诃那伽

【论】摩诃言大。那名不。伽名罪。诸阿罗汉诸烦恼断。以是故名不罪。复次那伽或名龙或名象。是五千阿罗汉。诸无数阿罗汉中最大力。是以故言如龙如象。水行中龙力大。陆行中象力大。复次如善调象王。能破大军直入不回。不畏刀杖不难水火。不走不退死至不避。诸阿罗汉亦复如是。修禅定智慧。故能破魔军及诸结使贼。骂詈挝打不悔不恚。老死水火不畏不难。复次如大龙王。从大海出起于大云遍覆虚空。放大电光明照天地。澍大洪雨润泽万物。诸阿罗汉亦复如是。从禅定智慧大海水中出。起慈悲云润及可度。现大光明种种变化。说实法相雨弟子心令生善牙。

【经】所作已办

【论】问曰。云何名所作。云何名已办。答曰。信戒舍定等诸善法得故。名为所作。智慧精进解脱等。诸善法得故。是名已办。二法具足满故。名所作已办。复次诸烦恼有二种。一种属爱。一种属见。属爱烦恼断故名所作。属见烦恼断故名已办。复次色法善见故名所作。无色法善见故名已办。可见不可见有对无对等二法亦如是。复次不善无记法断故名所作。善法思惟故名已办。闻思慧成就故名所作。修慧成就故名已办。种种三法亦如是。复次暖法顶法忍法世间第一法得故名所作。苦法忍等诸无漏善根得故名已办。见谛道得故名所作。思惟道得故名已办。成学道故名所作。无学道得故名已办。心解脱得故名所作。慧解脱得故名已办。漏尽故名所作。得共解脱故名已办。一切结使除故名所作。得非时解脱故名已办。自利益竟故名所作。利益他人故名已办。如是等所作已办义自在说

【经】弃担能担

【论】五众粗重常恼故名为担。如佛所说。何谓担。五众是担。诸阿罗汉此担已除。以是故言弃担。能担者。是佛法中二种功德担应担。一者自益利。二者他益利。一切诸漏尽。不悔解脱等诸功德。是名自利益。信戒舍定慧等诸功德能与他人。是名利益他。是诸阿罗汉。自担他担能担故名能担。复次譬如大牛壮力能服重载。此诸阿罗汉亦如是。得无漏根力觉道。能担佛法大事担。以是故诸阿罗汉名能担

【经】逮得己利

【论】云何名己利。云何非己利。行诸善法是名己利。诸余非法是名非己利。复次信戒舍定慧等诸功德。一切财宝胜故。今世后世常得乐故。能到甘露城故。以是三因缘故。名己利。如信品中偈说

  若人得信慧　　是宝最第一
  诸余世财利　　不及是法宝

复次若人今世得乐。后世得乐及涅槃常乐。是名己利余非己利。如偈说

  世知种种无道法　　与诸禽兽等无异
  当求正智要道法　　得脱老死入涅槃

复次八正道及沙门果。是名诸阿罗汉己利。是五千阿罗汉得道及果。二事俱得故名己利。以是故言逮得己利

【经】尽诸有结

【论】三种有。欲有色有无色有。云何欲有。欲界系业取因缘。后世能生亦是业报。是名欲有。色有无色有亦如是。是名为有。结尽者结有九结。爱结恚结慢结痴结疑结见结取结悭结嫉结。是结使尽及有。是有尽及结使。以是故名有结尽。问曰。诸阿罗汉结使应永尽。得一切烦恼离故。有不应尽。何以故。阿罗汉未灭度时。眼根等五众十二入十八持。诸有成就故。答曰。无所妨。是果中说因。如佛语檀越。施食时与五事。命色力乐[目*善]。食不能必与五事。有人大得饮食而死。有人得少许食而活。食为五事因。是故佛言施食得五事。如偈说

  断食死无疑　　食者死未定
  以是故佛说　　施食得五事

亦如人食百斤金。金不可食。金是食因故言食金。佛言女人为戒垢。女人非戒垢。是戒垢因故。言女人为戒垢。如人从高处堕未至地言此人死。虽未死知必死故。言此人死。如是诸阿罗汉结使已尽。知有必当尽故。言有结尽

【经】正智已得解脱

【论】如摩犍提梵志弟子举其尸着床上。舆行城市中多人处唱言。若有眼见摩犍提尸者。是人皆得清净道。何况礼拜供养者。多有人信其言。诸比丘闻是语。白佛言。世尊。是事云何。佛说偈言

  小人眼见求清净　　如是无智无实道
  诸结烦恼满心中　　云何眼见得净道
  若有眼见得清净　　何用智慧功德宝
  智慧功德乃为净　　眼见求净无是事

以是故言正智得解脱。问曰。诸阿罗汉所作已办。更不求进。何以故常在佛边。不余处度众生。答曰。一切十方众生虽尽应供养佛。阿罗汉受恩重故。应倍供养。所以者何。是阿罗汉从佛得成受无量功德。知结使断信心转多。是故诸大德阿罗汉。佛边受功德乐味供养恭敬报佛恩故。在佛边住。诸阿罗汉围绕佛故。佛德益尊。如梵天人绕梵天王。如三十三天绕释提桓因。如诸鬼神绕毗沙门王。如诸小王绕转轮圣王。如病人病愈住大医边。如是诸阿罗汉住在佛边。诸阿罗汉围绕供养故。佛德益尊。问曰。若诸阿罗汉。所作已办逮得己利不须听法。何以故说般若波罗蜜时。共五千阿罗汉。答曰。诸阿罗汉虽所作已办。佛欲以甚深智慧法试。如佛问舍利弗。如波罗延经阿耆陀难中偈说

  种种诸学人　　及诸数法人
  是人所行法　　愿为如实说

是中云何学人。云何数法人。尔时舍利弗默然。如是三问三默。佛示义端告舍利弗。有生不。舍利弗答。世尊有生。有生者欲为灭。有为生法故名学人。以智慧得无生法故。名数法人。是经此中应广说。复次若有漏若无漏诸禅定未得故欲得。已得欲令坚深。故诸阿罗汉佛边听法。复次现前乐故。如难陀迦经中说。以今世乐故听法。复次诸阿罗汉在佛边听法心无厌足。如昆卢提迦经中说。舍利弗语昆卢提迦。我法中听法无厌。复次如佛大师。自一心从弟子边听法。不应难言阿罗汉所作已办何以听法。譬如饱满人得好食犹尚更食。云何饥渴人而言不应食。以是故。诸阿罗汉虽所作已办。常在佛边听法。复次佛住解脱法中。诸阿罗汉亦住解脱法中。住法相应眷属庄严。如栴檀譬喻经中言。有栴檀林伊兰围之。有伊兰林栴檀围之。有栴檀栴檀以为丛林。有伊兰伊兰自相围绕。佛诸阿罗汉亦复如是。佛住善法解脱中。诸阿罗汉亦住善法解脱中。住法相应眷属庄严。佛以大众围绕。如须弥山王十宝山围绕。如白香象王白香象围绕。如师子王师子众围绕。佛亦如是。佛为世间无上福田。与诸弟子围绕共住

【经】唯除阿难在学地得须陀洹

【论】问曰。何以言唯除阿难。答曰。上所赞诸阿罗汉。阿难不在其数。何以故。以在学地未离欲故。问曰。大德阿难。第三师大众法将。种涅槃种已无量劫。常近佛持法藏。大德利根何以至今未离欲作学人。答曰。大德阿难本愿如是。我于多闻众中最第一。亦以诸佛法阿罗汉所作已办。不应作供给供养人。以其于佛法中能办大事烦恼贼破。共佛在解脱床上坐故。复次长老阿难。种种诸经听持诵利观故。智慧多摄心少。二功德等者。可得漏尽道。以是故。长老阿难是学人须陀洹。复次贪供给世尊故。是阿难为佛作供给人。如是念。若我早取漏尽道。便远世尊不得作供给人。以是故。阿难虽能得阿罗汉道。自制不取。复次处时人未合故。何等处能集法。千阿罗汉未在耆阇崛山。是为处。世尊过去时未到。长老婆耆子不在。以是故。长老阿难漏不尽。要在世尊过去。集法众合婆耆子说法劝谏。三事合故得漏尽道。复次大德阿难。厌世法少不如余人。是阿难世世王者种。端正无比福德无量。世尊近亲常侍从佛。必有此念。我佛近侍知法宝藏。漏尽道法我不畏失。以是事故不大殷勤。问曰。大德阿难名。以何因缘。是先世因缘。是父母作字。是依因缘立名。答曰。是先世因缘亦父母作名亦依因缘立字。问曰。云何先世因缘。答曰。释迦文佛先世作瓦师。名大光明。尔时有佛名释迦文。弟子名舍利弗目干连阿难。佛与弟子俱到瓦师舍一宿。尔时瓦师。布施草坐灯明石蜜浆三事。供养佛及比丘僧。便发愿言。我于当来老病死恼五恶之世作佛。如今佛名释迦文。我佛弟子名亦如今佛弟子名。以佛愿故得字阿难。复次阿难世世立愿。我在释迦文佛弟子多闻众中。愿最第一字阿难。复次阿难世世忍辱除嗔。以是因缘故。生便端正。父母以其端正见者皆欢喜故字阿难。(阿难者秦言欢喜)是为先世因缘字。云何父母作字。昔有日种王。名师子颊。其王有四子。第一名净饭。二名白饭。三名斛饭。四名甘露饭。有一女名甘露味。净饭王有二子佛难陀。白饭王有二子跋提提沙。斛饭王有二子提婆达多阿难。甘露饭王有二子摩诃男阿泥卢豆。甘露味女有一子名施婆罗。是中悉达陀菩萨。渐渐长大弃转轮圣王位。夜半出家。至沤楼鞞罗国中尼连禅河边。六年苦行。是时净饭王爱念子故。常遣使问讯欲知消息。我子得道不。若病若死。使来白王。菩萨唯有皮骨筋相连持耳。命甚微弱。若今日若明日不复久也。王闻其言甚大愁念没忧恼海。我子既不作转轮王。又不得作佛。一何衰苦无所得而死。如是忧恼荒迷愦塞。是时菩萨弃苦行处。食百味乳糜身体充满。于尼连禅水中洗浴已。至菩提树下坐金刚座。而自誓言。要不破此结加趺坐成一切智。不得一切智终不起也。是时魔王将十八亿众到菩萨所。敢与菩萨决其得失。菩萨智慧力故大破魔军。魔不如而退自念。菩萨叵胜当恼其父。至净饭王所诡言。汝子今日后夜已了。王闻此语惊怖堕床。如热沙中鱼。王时悲哭而说偈言

  阿夷陀虚言　　瑞应亦无验
  得利之吉名　　一切无所获

是时菩提树神大欢喜。持天曼陀罗华。至净饭王所说偈言

  汝子已得道　　魔众已破散
  光明如日出　　普照十方土

王言。前有天来言。汝子已了。汝今来言坏魔得道。二语相违谁可信者。树神又言。实不妄语。前来天者诡言已了。是魔怀嫉故来相恼。今日诸天龙神华香供养空中悬缯。汝子身出光明遍照天地。王闻其言于一切苦恼心得解脱。王言我子虽舍转轮圣王。今得法转轮王定得大利无所失也。王心大欢喜。是时斛饭王家使来白净饭王。言。贵弟生男。王心欢喜言。今日大吉是欢喜日。语来使言。是儿当字为阿难。是为父母作字。云何依因缘立名。阿难端正清净如好明镜。老少好丑容貌颜状。皆于身中现。其身明净。女人见之欲心即动。是故佛听阿难着覆肩衣。是阿难能令他人见者心眼欢喜故名阿难。于是造论者赞言

  面如净满月　　眼若青莲华
  佛法大海水　　流入阿难心
  能令人心眼　　见者大欢喜
  诸来求见佛　　通现不失宜

如是阿难虽能得阿罗汉道。以供给供养佛故自不尽漏。以此大功德故。虽非无学在无学数中。虽未离欲在离欲数中。以是故共数五千中。以实未是阿罗汉故。言唯除阿难

    大智度初品中四众义释论第七

【经】复有五百比丘尼优婆塞优婆夷。皆见圣谛

【论】问曰。何以诸比丘五千。余三众各五百。答曰。女人多短智慧烦恼垢重。但求喜乐爱行多故。少能断结使得解脱证。如佛说。是因缘起法第一甚深难得。一切烦恼尽离欲得涅槃倍复难见。以是故女人不能多得不如比丘。优婆塞优婆夷有居家故。心不净不能尽漏止可得四圣谛作学人。如偈说

  孔雀虽有色严身　　不如鸿雁能远飞
  白衣虽有富贵力　　不如出家功德胜

以是故诸比丘尼。虽出家弃世业智慧短。是故有五百阿罗汉比丘尼。白衣二众居家事懅故。得道亦各五百。问曰。如五千阿罗汉皆赞三众何以不赞。答曰。大众已赞则知余亦赞。复次若别赞。外道辈当呵言。何以赞比丘尼。生诽谤故。若赞白衣当言为供养故。以是故不赞。问曰。诸余摩诃衍经。佛与大比丘众俱。或八千人或六万十万人俱。是摩诃般若波罗蜜经诸经中第一。大如嘱累品中说。余经悉忘失其罪少少。失般若波罗蜜一句其罪大多。以是故知般若波罗蜜经第一大。是第一经中当第一大会。何以故声闻众数少。止有比丘五千。比丘尼优婆塞优婆夷各五百。答曰。以是大经甚深难解故。声闻众少。譬如王有真宝不示凡人。示大人信爱者。如王谋议时。与诸大臣信爱智人共论。诸余小臣则不得入。复次是六千五百人尽得道。虽不尽解甚深般若波罗蜜。皆能信得无漏四信故。余经声闻众。虽大多杂不尽得道。复次是中先赞千万阿罗汉中。择取最胜五千人。比丘尼优婆塞优婆夷亦尔。胜者难得故不多

大智度论卷第三大智度初品中菩萨释论第八(卷第四)

        龙树菩萨造

        后秦龟兹国三藏法师鸠摩罗什奉　诏译

【经】复有菩萨摩诃萨

【论】问曰。若从上数。应先菩萨次第比丘比丘尼优婆塞优婆夷。菩萨次佛故。若从下数。应先优婆夷次第优婆塞比丘尼比丘菩萨。今何以先说比丘。次三众。后说菩萨。答曰。菩萨虽应次佛。以诸烦恼未尽故。先说阿罗汉。诸阿罗汉智慧虽少而已成熟。诸菩萨智慧虽多而烦恼未尽。是故先说阿罗汉。佛法有二种。一秘密二现示。现示中佛辟支佛阿罗汉皆是福田。以其烦恼尽无余故。秘密中说诸菩萨得无生法忍。烦恼已断具六神通利益众生。以现示法故。前说阿罗汉。后说菩萨。复次菩萨以方便力。现入五道受五欲引导众生。若在阿罗汉上。诸天世人当生疑怪。是故后说。问曰。在阿罗汉后可尔。何以乃在优婆塞优婆夷后。答曰。四众虽漏未尽。尽在不久故。通名声闻众。若于四众中间。说菩萨者则不便。如比丘尼得无量律仪故。应次比丘后在沙弥前。佛以仪法不便故。在沙弥后。此诸菩萨亦如是。虽应在学人三众上。以不便故在后说。复次有人言。菩萨功德智慧。超殊阿罗汉辟支佛。是故别说。问曰。声闻经中但说四众。此中何以别说菩萨众。答曰。有二种道。一声闻道。二菩提萨埵道。比丘比丘尼优婆塞优婆夷四众。是声闻道。菩萨摩诃萨是菩提萨埵道。以是故。声闻法中经初。无佛在某处某处住尔所菩萨俱。但言佛某处某处住与尔所比丘俱。如说佛在波罗柰与五比丘俱。佛在伽耶国中与千比丘俱。佛在舍婆提与五百比丘俱。如是种种经初。不说与菩萨若干人俱。问曰。诸菩萨二种。若出家若在家。在家菩萨总说在优婆塞优婆夷中。出家菩萨总在比丘比丘尼中。今何以故别说。答曰。虽总在四众中。应当别说何以故。是菩萨必堕四众中。有四众不堕菩萨中。何者是。有声闻人辟支佛人。有求生天人。有求乐自活人。此四种人不堕菩萨中。何以故。是人不发心言我当作佛故。复次菩萨得无生法忍故。一切名字生死相断出三界。不堕众生数中。何以故。声闻人得阿罗汉道灭度已。尚不堕众生数中。何况菩萨。如波罗延优波尸难中偈说

  已灭无处更出不　　若已永灭不出不
  既入涅槃常住不　　惟愿大智说其实

佛答曰

  灭者即是不可量　　破坏因缘及名相
  一切言语道已过　　一时都尽如火灭

如阿罗汉。一切名字尚断。何况菩萨能破一切诸法。知实相得法身而不断耶。以是故。摩诃衍四众中。别说菩萨。问曰。何以故。大乘经初。菩萨众声闻众两说。声闻经初独说比丘众。不说菩萨众。答曰。欲辩二乘义故。佛乘及声闻乘。声闻乘陜小。佛乘广大。声闻乘自利自为。佛乘益一切。复次声闻乘多说众生空。佛乘说众生空法空。如是等种种分别说是二道故。摩诃衍经声闻众菩萨众两说。如赞摩诃衍偈中说

  得此大乘人　　能与一切乐
  利益以实法　　令得无上道
  得此大乘人　　慈悲一切故
  头目以布施　　舍之如草木
  得此大乘人　　护持清净戒
  如牦牛爱尾　　不惜身寿命
  得此大乘人　　能得无上忍
  若有割截身　　视之如断草
  得此大乘人　　精进无厌惓
  力行不休息　　如抒大海者
  得此大乘人　　广修无量定
  神通圣道力　　清净得自在
  得此大乘人　　分别诸法相
  无坏实智慧　　是中已具得
  不可思议智　　无量悲心力
  不入二法中　　等观一切法
  驴马驼象乘　　虽同不相比
  菩萨及声闻　　大小亦如是
  大慈悲为轴　　智慧为两轮
  精进为驶马　　戒定以为衔
  忍辱心为铠　　总持为辔勒
  摩诃衍人乘　　能度于一切

问曰。如声闻经初但说比丘众。摩诃衍经初。何以不但说菩萨众。答曰。摩诃衍广大。诸乘诸道皆入摩诃衍。声闻乘陜小不受摩诃衍。譬如恒河不受大海。以其陜小故。大海能受众流。以其广大故。摩诃衍法亦如是如偈说

  摩诃衍如海　　小乘牛迹水
  小故不受大　　其喻亦如是

问曰。何等名菩提。何等名萨埵。答曰。菩提名诸佛道。萨埵名或众生或大心。是人诸佛道功德。尽欲得其心。不可断不可破。如金刚山。是名大心。如偈说

  一切诸佛法　　智慧及戒定
  能利益一切　　是名为菩提
  其心不可动　　能忍成道事
  不断亦不破　　是心名萨埵

复次称赞好法名为萨。好法体相名为埵。菩萨心自利利他故。度一切众生故。知一切法实性故。行阿耨多罗三藐三菩提道故。为一切贤圣之所称赞故。是名菩提萨埵。所以者何。一切诸法中佛法第一。是人欲取是法故。为贤圣所赞叹。复次如是人为一切众生。脱生老死故索佛道。是名菩提萨埵。复次三种道皆是菩提。一者佛道二者声闻道三者辟支佛道。辟支佛道声闻道。虽得菩提。而不称为菩提。佛功德中菩提称为菩提。是名菩提萨埵。问曰。齐何来名菩提萨埵。答曰。有大誓愿心不可动。精进不退。以是三事名为菩提萨埵。复次有人言。初发心作愿。我当作佛度一切众生。从是已来名菩提萨埵。如偈说

  若初发心时　　誓愿当作佛
  已过诸世间　　应受世供养

从初发心到第九无碍。入金刚三昧中。是中间名为菩提萨埵。是菩提萨埵有两种。有鞞跋致有阿鞞跋致。如退法不退法阿罗汉。阿鞞跋致菩提萨埵。是名实菩萨。以是实菩萨故。诸余退转菩萨皆名菩萨。譬如得四道人。是名实僧。以实僧故。诸未得道者。皆得名僧。问曰。云何知是菩萨鞞跋致阿鞞跋致。答曰。般若波罗蜜阿鞞跋致品中。佛自说阿鞞跋致相。如是相是退转。如是相是不退转。复次若菩萨一法。得好修好念。是名阿鞞跋致菩萨。何等一法。常一心集诸善法如说。诸佛一心集诸善法故。得阿耨多罗三藐三菩提。复次有菩萨得一法。是阿鞞跋致相。何等一法。正直精进。如佛问阿难。阿难汝说精进如是世尊。阿难汝赞精进如是善逝。阿难常行常修常念。精进乃至令人得阿耨多罗三藐三菩提。如经广说。复次若得二法。是时是阿鞞跋致相。何等二法。一切法实知空。亦念不舍一切众生。如是人名为阿鞞跋致菩萨。复次得三法。一者若一心作愿欲成佛道。如金刚不可动不可破。二者于一切众生悲心彻骨入髓。三者得般舟三昧。能见现在诸佛。是时名阿鞞跋致。复次阿毗昙中。迦旃延尼子弟子辈言。何名菩萨。自觉复能觉他。是名菩萨。必当作佛。是名菩萨。菩提名漏尽人智慧。是人从智慧生。智慧人所护智慧人所养故。是名菩萨。又言发阿鞞跋致心。从是已后名菩萨。又言若离五法得五法。是名菩萨。何谓五法。离三恶道常生天上人间。离贫穷下贱常得尊贵。离非男法常得男子身。离诸形残缺陋诸根具足。离舍喜忘常忆宿命。得是宿命智慧。常离一切恶法。远离恶人。常求道法摄取弟子。如是名为菩萨。又言从种三十二相业已来。是名菩萨。问曰。何时种三十二相业因缘。答曰。过三阿僧祇劫。然后种三十二相业因缘。问曰。几时名阿僧祇。答曰。天人中能知算数者。极数不复能知。是名一阿僧祇。如一一名二。二二名四。三三名九。十十名百。十百名千。十千名万。千万名亿。千万亿名那由他。千万那由他名频婆。千万频婆名迦他。过迦他名阿僧祇。如是数三阿僧祇。若行一阿僧祇满行第二阿僧祇。第二阿僧祇满行第三阿僧祇。譬如算数法。算一乃至算百百算竟还至一。如是菩萨一阿僧祇过还从一起。初阿僧祇中。心不自知我当作佛不作佛。二阿僧祇中。心虽能知我必作佛。而口不称我当作佛。三阿僧祇中。心了了自知得作佛。口自发言无所畏难。我于来世当作佛。释迦文佛。从过去释迦文佛到剌那尸弃佛为初阿僧祇。是中菩萨永离女人身。从剌那尸弃佛至燃灯佛为二阿僧祇。是中菩萨七枚青莲华。供养燃灯佛。敷鹿皮衣布发掩泥。是时燃灯佛。便授其记。汝当来世作佛名释迦牟尼。从燃灯佛至毗婆尸佛为第三阿僧祇。若过三阿僧祇劫。是时菩萨种三十二相业因缘。问曰。三十二相业何处可种。答曰。欲界中。非色无色界。于欲界五道在人道中种。于四天下阎浮提中种。于男子身种非女人。佛出世时种。佛不出世不得种。缘佛身种。缘余不得种。问曰。是三十二相业因缘。于身业口业意业何业种。答曰。意业种非身口业。何以故是意业利故。问曰。意业有六识。是三十二相业。为是意识种。是五识种

答曰。是意识非五识。何以故。五识不能分别。以是故意识种。问曰。何相初种。答曰。有人言。足安立相先种。何以故先安立然后能种余相。有人言。绀青眼相初种。得此眼相大慈观众生。此两语虽有是语不必尔也。若相因缘和合时便是初种。何必安立足为初。问曰。一思种。为多思种。答曰。三十二思种三十二相。一一思种一一相。一一相百福德庄严。问曰。几许名一福德。答曰。有人言。有业报转轮圣王。于四天下受福乐得自在。是名一福德。如是百福成一相。复有人言。作释提桓因。于二天中得自在。是名一福德。复有人言。作他化自在天王。于欲界中得自在。是名一福。复有人言。除补处菩萨余一切众生所得福报。是名一福。复有人言。天地劫尽一切众生共福德故。三千大千世界报立。是名一福。复有人言。是福不可量不可以譬喻知。如三千大千世界一切众生皆盲无目。有一人能治令差。是为一福。一切人皆被毒药。一人能治令差。一切人应死。一人能捄之令脱。一切人破戒破正见。一人能教令得净戒正见。如是等为一福。复有人言。是福不可量不可譬喻。是菩萨入第三阿僧祇中。心思大行。种是三十二相因缘。以是故。是福无能量。唯佛能知。问曰。菩萨几时能种三十二相。答曰。极迟百劫。极疾九十一劫。释迦牟尼菩萨。九十一大劫行办三十二相。如经中言。过去久远有佛名弗沙。时有二菩萨。一名释迦牟尼。一名弥勒。弗沙佛。欲观释迦牟尼菩萨心纯淑未。即观见之。知其心未纯淑。而诸弟子心皆纯淑。又弥勒菩萨心已纯淑。而弟子未纯淑。是时弗沙佛。如是思惟。一人之心易可速化。众人之心难可疾治。如是思惟竟。弗沙佛。欲使释迦牟尼菩萨疾得成佛。上雪山上。于宝窟中入火定。是时释迦牟尼菩萨。作外道仙人。上山采药。见弗沙佛坐宝窟中入火定放光明。见已心欢喜。信敬翘一脚立。叉手向佛一心而观。目未曾眴七日七夜。以一偈赞佛

  天上天下无如佛　　十方世界亦无比
  世界所有我尽见　　一切无有如佛者

七日七夜谛观世尊目未曾眴。超越九劫于九十一劫中。得阿耨多罗三藐三菩提。问曰。若释迦牟尼菩萨。聪明多识能作种种好偈。何以故。七日七夜一偈赞佛。答曰。释迦牟尼菩萨。贵其心思不贵多言。若更以余偈赞佛心或散乱。是故七日七夜以一偈赞佛。问曰。释迦牟尼菩萨。何以心未纯淑。而弟子纯淑。弥勒菩萨自心纯淑。而弟子未纯淑。答曰。释迦牟尼菩萨。饶益众生心多。自为身少故。弥勒菩萨。多为己身少为众生故。从鞞婆尸佛。至迦叶佛。于其中间九十一大劫。种三十二相业因缘集竟。六波罗蜜满。何等六。檀波罗蜜．尸罗波罗蜜．羼提波罗蜜．毗梨耶波罗蜜．禅波罗蜜．般若波罗蜜。问曰。檀波罗蜜云何满。答曰。一切能施无所遮碍。乃至以身施时。心无所惜。譬如尸毗王以身施鸽。释迦牟尼佛本身作王。名尸毗。是王得归命救护陀罗尼。大精进有慈悲心。视一切众生如母爱子。时世无佛。释提桓因命尽欲堕。自念言。何处有佛一切智人。处处问难不能断疑。知尽非佛。即还天上愁忧而坐。巧变化师毗首羯磨天。问曰。天主何以愁忧。答曰。我求一切智人不可得。以是故愁忧。毗首羯磨言。有大菩萨。布施持戒禅定智慧具足。不久当作佛。帝释以偈答曰

  菩萨发大心　　鱼子庵树华
  三事因时多　　成果时甚少

毗首羯磨。答曰。是优尸那种尸毗王。持戒精进大慈大悲禅定智慧不久作佛。释提桓因。语毗首羯磨。当往试之。知有菩萨相不。汝作鸽我作鹰。汝便佯怖入王腋下。我当逐汝。毗首羯磨言。此大菩萨云何以此事恼。释提桓因说偈言

  我亦非恶心　　如真金应试
  以此试菩萨　　知其心定不

说此偈竟。毗首羯磨。即自变身作一赤眼赤足鸽。释提桓因。自变身作一鹰。急飞逐鸽。鸽直来入王掖底。举身战怖动眼促声

  是时众多人　　相与而语曰
  是王大慈仁　　一切宜保信
  如是鸽小鸟　　归之如入舍
  菩萨相如是　　作佛必不久

是时鹰在近树上。语尸毗王。还与我鸽此我所受。王时语鹰。我前受此非是汝受。我初发意时。受此一切众生皆欲度之。鹰言。王欲度一切众生。我非一切耶。何以独不见愍。而夺我今日食。王答言。汝须何食。我作誓愿其有众生。来归我者必救护之。汝须何食亦当相给。鹰言。我须新杀热肉。王念言。如此难得。自非杀生无由得也。我当云何杀一与一。思惟心定即自说偈

  是我此身肉　　恒属老病死
  不久当臭烂　　彼须我当与

如是思惟已。呼人持刀自割股肉与鹰。鹰语王言。王虽以热肉与我。当用道理令肉轻重得与鸽等勿见欺也。王言持称来。以肉对鸽。鸽身转重王肉转轻。王令人割二股亦轻不足。次割两[跳-兆+專]两臗两乳项脊。举身肉尽。鸽身犹重。王肉故轻。是时近臣内戚。安施帐幔。却诸看人。王今如此无可观也。尸毗王言。勿遮诸人听令入看。而说偈言

  天人阿修罗　　一切来观我
  大心无上志　　以求成佛道
  若有求佛道　　当忍此大苦
  不能坚固心　　则当息其意

是时菩萨。以血涂手攀称欲上。定心以身尽以对鸽。鹰言。大王此事难办。何用如此以鸽还我。王言鸽来归我终不与汝。我丧身无量于物无益。今欲以身求易佛道。以手攀称。尔时菩萨。肉尽筋断不能自制。欲上而堕自责心言。汝当自坚勿得迷闷。一切众生堕忧苦大海。汝一人立誓欲度一切。何以怠闷。此苦甚少地狱苦多。以此相比于十六分犹不及一。我今有智慧精进持戒禅定。犹患此苦。何况地狱中人无智慧者。是时菩萨。一心欲上复更攀称。语人扶我。是时菩萨。心定无悔。诸天龙王阿修罗鬼神人民皆大赞言。为一小鸟乃尔。是事希有。即时大地为六种振动。大海波扬枯树生华。天降香雨及散名华。天女歌赞必得成佛。是时念我四方神仙皆来赞言。是真菩萨必早成佛。鹰语鸽言。终试如此不惜身命。是真菩萨。即说偈言

  慈悲地中生　　一切智树牙
  我曹当供养　　不应施忧恼

毗首羯磨。语释提桓因言。天主汝有神力。可令此王身得平复。释提桓因言。不须我也。此王自作誓愿大心欢喜。不惜身命感发一切令求佛道。帝释语人王言。汝割肉辛苦心不恼没耶。王言。我心欢喜不恼不没。帝释言。谁当信汝心不没者。是时菩萨作实誓愿。我割肉血流不嗔不恼。一心不闷以求佛道者。我身当即平复如故。即出语时身复如本。人天见之皆大悲喜叹未曾有。此大菩萨必当作佛。我曹应当尽心供养。愿令早成佛道。当念我等。是时释提桓因毗首羯磨各还天上。如是等种种相。是檀波罗蜜满。问曰。尸罗波罗蜜云何满。答曰。不惜身命护持净戒。如须陀须摩王。以劫磨沙波陀大王故。乃至舍命不犯禁戒。昔有须陀须摩王。是王精进持戒常依实语。晨朝乘车将诸婇女入园游戏。出城门时有一婆罗门来乞语王言。王是大福德人我身贫穷。当见愍念赐丐少多。王言诺。敬如来告当相布施须我出还。作此语已入园澡浴嬉戏。时有两翅王名曰鹿足空中飞来。于婇女中捉王将去。譬如金翅鸟海中取龙。诸女啼哭号恸。一园惊城内外搔扰悲惶。鹿足负王腾跃虚空至所住止。置九十九诸王中。须陀须摩王涕零如雨。鹿足王语言。大刹利王汝何以啼如小儿。人生有死合会有离。须陀须摩王答言。我不畏死甚畏失信。我从生已来初不妄语。今日晨朝出门时有一婆罗门来从我乞。我时许言还当布施。不虑无常辜负彼心自招欺罪。是故啼耳。鹿足王言。汝意欲尔畏此妄语。听汝还去七日布施婆罗门讫便来还。若过七日不还我有两翅力取汝不难。须陀须摩王得还本国恣意布施。立太子为王。大会人民忏谢之言。我智不周物治不如法当见忠恕。如我今日身非已有正尔还去。举国人民及诸亲戚叩头留之。愿王留意慈荫此国。勿以鹿足鬼王为虑也。当设铁舍奇兵。鹿足虽神不畏之也。王言不得尔也。而说偈言

  实语第一戒　　实语升天梯
  实语小而大　　妄语入地狱
  我今守实语　　宁弃身寿命
  心无有悔恨

如是思惟已。王即发去到鹿足王所。鹿足遥见欢喜而言。汝是实语人不失信要。一切人皆惜身命。汝从死得脱还来赴信汝是大人。尔时须陀须摩王赞实语。实语是为人非实语非人。如是种种赞实语呵妄语。粗足闻之信心清净。语须陀须摩王言。汝好说此今相放舍汝既得脱。九十九王亦布施汝。随意各还本国。如是语已百王各得还去。如是等种种本生中相是为尸罗波罗蜜满。问曰。羼提波罗蜜云何满。答曰。若人来骂挝捶割剥支解夺命心不起嗔。如羼提比丘。为迦梨王截其手足耳鼻心坚不动。问曰。毗梨耶波罗蜜云何满。答曰。若有大心勤力。如大施菩萨。为一切故以此一身。誓抒大海令其干尽定心不懈。亦如赞弗沙佛七日七夜翘一脚目不眴。问曰。禅波罗蜜云何满。答曰。如一切外道禅定中得自在。又如尚阇梨仙人坐禅时无出入息。鸟于螺髻中生子不动不摇。乃至鸟子飞去。问曰。般若波罗蜜云何满。答曰。菩萨大心思惟分别。如劬嫔陀婆罗门大臣。分阎浮提大地作七分。若干大城小城聚落村民尽作七分。般若波罗蜜如是。是菩萨六波罗蜜满。在迦叶佛所。作弟子。持净戒行功德生兜率天上。问曰。菩萨何以生兜率天上。而不在上生不在下生。是大有福德应自在生。答曰。有人言。因缘业熟应在是中生。复次下地中结使厚浊。上地中结使利。兜率天上结使不厚不利。智慧安隐故。复次不欲过佛出世时故。若于下地生命短寿终。时佛未出世。若于上地生命长寿未尽。复过佛出时。兜率天寿与佛出时会故。复次佛常居中道故。兜率天于六天及梵之中。上三下三。于彼天下必生中国。中夜降神。中夜出迦毗罗婆国行中道。得阿耨多罗三藐三菩提。中道为人说法。中夜入无余涅槃。好中法故中天上生。如是菩萨兜率天上生竟。以四种观人间。一者观时二者观土地三者观种姓四者观生处。云何观时。时有八种佛出其中。第一人长寿八万四千岁时。第二人寿七万岁。第三人寿六万岁。第四人寿五万岁。第五人寿四万岁。第六人寿三万岁。第七人寿二万岁。第八人寿一百余岁。菩萨如是念。人寿百岁佛出时到。是名观时。云何观土地。诸佛常在中国生。多金银宝物饮食丰美其土清净。云何观种姓。佛生二种姓中。若刹利。若婆罗门。刹利种势力大故。婆罗门种姓智慧大故。随时所贵者。佛于中生。云何观生处。何等母人能怀那罗延力菩萨。亦能自护净戒。如是观竟。唯中国迦毗罗婆净饭王后。能怀菩萨。如是思惟已。于兜率天下。不失正慧入于母胎。问曰。何以故。一切菩萨末后身从天上来。不从人中来。答曰。乘上道故。六道之中天道最上复次天上下时种种瑞应未曾所有。若从人道。人道不能有此。复次人敬重天故。问曰。一切人以垢心有相续入母胎。一切邪慧相应。云何名菩萨正慧入母胎。答曰。有人言。有相续时一切众生邪慧心入母胎。菩萨忆念不失故。名正慧入母胎。中阴中住则知中阴住。入胎时知入胎。歌罗罗时知住歌罗罗。(受胎七日赤白精和合时也)頞浮陀(二七日时如玺胞状也)时知住頞浮陀。伽那时知住伽那。(三七日时如凝酪也)五疱时知住五疱。出生时知出生。是中忆念不失。是名正慧入母胎。复次余人在中阴住时。若男于母生欲染心。此女人与我从事。于父生嗔恚。若女于父生染欲心。此男子与我从事。于母生嗔恚。如是嗔恚心染欲心菩萨无此。菩萨先已了知是父是母。是父是母能长养我身。我依父母生身得阿耨多罗三藐三菩提。是净心念父母。相续入胎。是名正慧入母胎。是菩萨满十月正慧不失念。出胎行七步。发口言。是我末后身。乃至将示相师。汝观我子实有三十二大人相不。若有三十二相具足者。是应有二法。若在家当为转轮圣王。若出家当成佛。诸相师言。地天太子实有三十二大人相。若在家者当作转轮王。若出家者当成佛。王言。何等三十二相。相师答言。一者足下安平立相。足下一切着地间无所受。不容一针。二者足下二轮相千辐辋毂三事具足。自然成就不待人工。诸天工师毗首羯磨不能化作如是妙相。问曰。何以故不能。答曰。是毗首羯磨。诸天工师不隐没智慧。是轮相善业报。是天工师生报得智慧。是轮相行善根智慧得。是毗首羯磨一世得。是智慧。是轮相从无量劫智慧生。以是故毗首羯磨不能化作。何况余工师。三者长指相。指纤长端直。次第佣好指节参差。四者足跟广平相。五者手足指缦网相。如雁王张指则现不张则不现。六者手足柔软相。如细劫波毳胜余身分。七者足趺高满相。以足蹈地不广不狭。足下色如赤莲华。足指间网及足边色如真珊瑚。指爪如净赤铜。足趺上真金色。足趺上毛青毗琉璃色。其足严好。譬如杂宝屐种种庄饰。八者伊泥延膊相。如伊泥延鹿膊随次佣纤。九者正立手摩膝相。不俯不仰以掌摩膝。十者阴藏相。譬如调善象宝马宝。问曰。若菩萨得阿耨多罗三藐三菩提。时诸弟子何因缘见阴藏相。答曰。为度众人决众疑故示阴藏相。复有人言。佛化作马宝象宝示诸弟子言。我阴藏相亦如是。十一者身广长等相。如尼拘卢陀树。菩萨身齐为中四边量等。十二者毛上向相。身有诸毛生。皆上向而稚。十三者一一孔一毛生相。毛不乱青琉璃色。毛右靡上向。十四者金色相。问曰何等金色。答曰。若铁在金边则不现。今现在金比佛在时金则不现。佛在时金比阎浮那金则不现。阎浮那金比大海中转轮圣王道中金沙则不现。金沙比金山则不现。金山比须弥山则不现。须弥山金比三十三诸天璎珞金则不现。三十三诸天璎珞金比焰摩天金则不现。焰摩天金比兜率陀天金则不现。兜率陀天金比化自在天金则不现。化自在天金比他化自在天金则不现。他化自在天金比菩萨身色则不现。如是色是名金色相。十五者丈光相。四边皆有一丈光。佛在是光中端严第一。如诸天诸王宝光明净。十六者细薄皮相。尘土不着身。如莲华叶不受尘水。若菩萨在干土山中经行。土不着足。随蓝风来吹破土山。令散为尘乃至一尘不着佛身。十七者七处隆满相。两手两足两肩项中七处。皆隆满端正色净胜余身体。十八者两腋下隆满相。不高不深。十九者上身如师子相。二十者大直身相。于一切人中身最大而直。二十一者肩圆好相。一切治肩无如是者。二十二者四十齿相。不多不少余人三十二齿。身三百余骨。头骨有九。菩萨四十齿。头有一骨。菩萨齿骨多头骨少。余人齿骨少头骨多。以是故异于余人身。二十三者齿齐相。诸齿等无粗无细不出不入。齿密相人不知者谓为一齿。齿间不容一毫。二十四者牙白相。乃至胜雪山王光。二十五者师子颊相。如师子兽中王平广颊。二十六者味中得上味相。有人言。佛以食着口中。是一切食皆作最上味。何以故。是一切食中有最上味因故。无是相人不能发其因故。不得最上味。复有人言。若菩萨举食着口中。是时咽喉边两处。流注甘露和合诸味。是味清净故。名味中得上味。二十七者大舌相。是菩萨大舌从口中出覆一切面分。乃至发际。若还入口口亦不满。二十八者梵声相。如梵天王五种声从口出。其一深如雷。二清彻远闻闻者悦乐。三入心敬爱。四谛了易解。五听者无厌。菩萨音声亦如是。五种声从口中出。迦陵毗伽声相。如迦陵毗伽鸟声可爱。鼓声相。如大鼓音深远。二十九者真青眼相。如好青莲华。三十者牛眼睫相。如牛王眼睫长好不乱。三十一者顶髻相。菩萨有骨髻如拳等在顶上。三十二者白毛相。白毛眉间生不高不下。白净右旋舒长五尺。相师言。地天太子三十二大人相如是。菩萨具有此相。问曰。转轮圣王有三十二相。菩萨亦有三十二相。有何差别。答曰。菩萨相者有七事胜转轮圣王相。菩萨相者。一净好。二分明。三不失处。四具足。五深入。六随智慧行不随世间。七随远离。转轮圣王相不尔。问曰。云何名相。答曰。易知故名相。如水异火以相故知。问曰。菩萨何以故三十二相不多不少。答曰。有人言。佛以三十二相庄严身者。端正不乱故。若少者身不端正。若多者佛身相乱。是三十二相端正不乱不可益不可减。犹如佛法不可增不可减。身相亦如是。问曰。菩萨何以故以相严身。答曰。有人见佛身相心得信净。以是故以相严身。复次诸佛以一切事胜故。身色威力种姓家属智慧禅定解脱众事皆胜。若佛不庄严身相是事便少。复次有人言。阿耨多罗三藐三菩提住是身中若身相不严。阿耨多罗三藐三菩提不住此身中。譬如人欲娶豪贵家女。其女遣使语彼人言。若欲娶我者。当先庄严房室除却污秽涂治香熏安施床榻被褥綩綖帏帐幄慢幡盖华香必令严饰。然后我当到汝舍。阿耨多罗三藐三菩提亦复如是。遣智慧使未来世中到菩萨所言。若欲得我先修相好以自庄严。然后我当住汝身中。若不庄严身者我不住也。以是故菩萨修三十二相。自庄严身为得阿耨多罗三藐三菩提故。是时菩萨渐渐长大。见老病死苦厌患心生。夜半出家。六年苦行。食难陀婆罗门女益身十六功德石蜜乳糜。食竟。菩提树下破万八千亿鬼兵魔众已。得阿耨多罗三藐三菩提。问曰。得何功德故名为佛。答曰。得尽智无生智故。名为佛。复次有人言。得佛十力四无所畏十八不共法三达无碍三意止。一者受教敬重佛无喜。二者不受教不敬重佛无忧。三者敬重不敬重心无异。大慈大悲三十七道品一切诸法总相别相悉知故故名为佛。问曰。何以故。未得佛道名为菩萨。得佛道不名为菩萨。答曰。未得佛道心爱着。求欲取阿耨多罗三藐三菩提。以是故名为菩萨。已成佛道更得佛种种异大功德故。更有异名名为佛。譬如王子未作王名为王子。已作王不复名王子。既为王虽是王子不名王子。菩萨亦如是。未得佛道名为菩萨。已得佛道名为佛。声闻法中摩诃迦旃延尼子弟子辈。说菩萨相义如是。摩诃衍人言。是迦旃延尼子弟子辈。是生死人。不诵不读摩诃衍经。非大菩萨。不知诸法实相。自以利根智慧。于佛法中作论议。诸结使智定根等于中作义。尚处处有失。何况欲作菩萨论议。譬如少力人跳小渠尚不能过。何况大河。于大河中则知没失。问曰。云何失。答曰。如上言三阿僧祇劫过名为菩萨。三阿僧祇中头目髓脑布施心无有悔。是阿罗汉辟支佛所不能及。如昔菩萨为大萨陀婆。渡大海水恶风坏船。语众贾人捉我头发手足。当渡汝等。众人捉已以刀自杀。大海水法不停死尸。即时疾风吹至岸边。大慈如是。而言非者谁。是菩萨第二阿僧祇劫行满。未入第三阿僧祇。时于燃灯佛所受记为佛。即时上升虚空见十方佛。于虚空中立赞然灯佛。然灯佛言。汝过一阿僧祇劫。当得作佛名释迦牟尼。得记如是。而言尔时未是菩萨岂非大失。迦旃延尼子弟子辈言。三阿僧祇劫中未有佛相。亦无种佛相因缘。云何当知。是菩萨一切法先有相。然后可知其实。若无相则不知。摩诃衍人言。受记为佛。上升虚空见十方佛。此非大相耶。为佛所记当得作佛。得作佛者此是大相。舍此大相而取三十二相。三十二相转轮圣王亦有。诸天魔王亦能化作此相。难陀提婆达等皆有三十相。婆跋隶婆罗门有三相。摩诃迦叶妇有金色相。乃至今世人亦各各有一相二相。若青眼长臂上身如师子。如是等种种或多或少。汝何以重此相。何经中言三阿僧祇劫中菩萨不种相因缘。如难陀澡浴鞞婆尸佛愿得清净端正。于一辟支佛塔青黛涂壁。作辟支佛像因而作愿。愿我恒得金色身相。又作迦叶佛塔中级。以此三福因缘。世世受乐处处所生恒得端严。是福之余。生迦毗罗婆释种中。为佛弟子得三十大人相。清净端正。出家得阿罗汉道。佛说于五百弟子中。难陀比丘端正第一。此相易得。云何言于九十一大劫中种余一生中得。是为大失。汝言初阿僧祇劫中。不知当作佛不作佛。二阿僧祇劫中知当作佛。不自称说。三阿僧祇劫中知得作佛能为人说。佛何处说是语。何经中有是语。若声闻法三藏中说。若摩诃衍中说。迦旃延尼子弟子辈言。虽佛口三藏中不说。义理应尔。阿毗昙鞞婆沙菩萨品中。如是说。答曰摩诃衍中说初发心。是时知我当作佛。如阿遮罗菩萨。于长手佛边。初发心时乃至金刚座处成佛道。于其中间颠倒不净心不生。如首楞严三昧中四种菩萨。四种受记。有未发心而授记。有适发心而授记。有于前授记他人尽知己身不知。有于前授记他人己身尽知。汝云何言于二阿僧祇劫知受记而不自称说。复次佛言无量阿僧祇劫作功德欲度众生何以故言三阿僧祇劫。三阿僧祇劫有量有限。问曰。摩诃衍中虽有此语我亦不能都信。答曰。是为大失。是佛真法佛口所说。汝无反。复汝从摩诃衍中出生。云何言我不能都信。复次摩诃衍论议此中应广说。复次说是三十二相业因缘。欲界中种非色无色界中种。无色界中以无身无色。是三十二相是身庄严故。于中不得种可尔。色界中何以不得种。色界中大有诸梵王。常请佛初转法轮。是智慧清净能求佛道。何以言不得种三十二相因缘。又言人中得种非余道。如娑伽度龙王十住菩萨。阿那婆达多龙王七住菩萨。罗睺阿修罗王亦是大菩萨。复何以言余道不得种三十二相因缘。汝言人中阎浮提种。郁怛罗曰不可种。有义彼中人无吾我。着乐不利根故。劬陀尼弗婆提二处。福德智慧寿命胜阎浮提。何以不得种。复次汝言一思种一相。是心弹指顷六十生灭。一心中不住不能分别。云何能种大人相。此大人相不应不了心得种。以是故多思和合能种一相。如重物一人不能担。必须多人力。如是种相。要得大心多思和合尔乃得种。以是故名百福相。百大心思种福德是名百福相。不应一思种一相。余事尚不得一思种一事。何况百福相。何以故言释迦文尼菩萨心未纯淑。弟子心纯淑。弥勒菩萨心纯淑。弟子心未纯淑。是语何处说。三藏中摩诃衍中无是事。此言自出汝心。汝但见释迦文尼菩萨。于宝窟中见弗沙佛七日七夜以一偈赞。弥勒菩萨。亦种种赞弗沙佛。但阿波陀那经中不说。汝所不知无因缘故。汝便谓弥勒弟子心未纯淑。如是皆为违失。汝言菩萨一切物能施无所爱惜。如尸毗王为鸽故。割肉与鹰心不悔恨如以财宝布施。是名下布施。以身布施是名中布施。种种施中心不着。是为上布施。汝何以赞中布施。为檀波罗蜜满。此施心虽大多慈悲。有知智慧。有不知智慧。如人为父母亲属不惜身。或为主不惜身。以是故知为鸽不惜身是中布施。问曰菩萨为一切众生为父母为主者。为一切人故。以是故。非直不惜身为檀波罗蜜满。答曰。虽为一切众生。是心不清净。不知己身无吾我。不知取者无人无主。不知所施物实性不可说一不可说异。于是三事心着是为不清净。于世界中得福德报。不能直至佛道。如说般若波罗蜜中。三事不可得亦不着。是为具足檀波罗蜜满。如是乃至般若波罗蜜能分别大地城郭聚落作七分。是为般若波罗蜜满。是般若波罗蜜无量无边如大海水。诸天圣人阿罗汉辟支佛乃至初行菩萨。尚不能知其边涯。十地住菩萨乃能知。云何汝言能分大地城郭聚落作七分。是名般若波罗蜜满。是事是算数法能分地。是世俗般若波罗蜜中少许分。譬如大海水中一渧两渧。实般若波罗蜜名三世诸佛母。能示一切法实相。是般若波罗蜜无来处无去处。一切处求不可得。如幻如响如水中月见便失。诸圣人怜愍故。虽一相以种种名字说是般若波罗蜜诸佛智慧宝藏。汝言大失。汝言四种观。观时观土地观种族观生处。人寿八万岁佛出世。七六五四三二万岁中佛出世。人寿百岁是佛出世时。若诸佛常怜愍众生。何以正八种时中出世。余时不出。佛法不待时。如好药服时便差病。佛法亦如是不待时。问曰。虽菩萨怜愍众生诸佛不待时。过八万岁人长寿多乐。染爱等结使厚。根钝非可化时。若百岁后时人短寿苦多嗔恚等诸结使更厚。此乐时苦。时非得道时以是故佛不出世。答曰。诸天寿出千万岁。有先世因缘。虽多乐染爱厚能得道。何况人中不大乐。三十六种不净易可教化。以是故人寿过八万岁佛应出世。是中人无病心乐故。人皆利根福德。福德利根故应易得道。复次师子鼓音王佛时。人寿十万岁。明王佛时。人寿七百阿僧祇劫。阿弥陀佛时人寿无量阿僧祇劫。汝云何言过八万岁佛不出世。问曰。摩诃衍经有此事。我法中无十方佛。唯过去释迦文尼拘陈若等一百佛。未来弥勒等五百佛。答曰。摩诃衍论中种种因缘。说三世十方佛。何以故。十方世界有老病死淫怒痴等诸苦恼。以是故佛应出其国。如经中说。无老病死烦恼者诸佛则不出世。复次多病人应有多药师。汝等声闻法。长阿含中。毗沙门王以偈白佛

稽首去来现在诸佛。亦复归命释迦文佛

汝经说过去未来现在诸佛言稽首。释迦文尼佛言归命。以此故知。现在有余佛。若无余国佛。何以故。前稽首三世佛。后别归命释迦文尼佛。此王未离欲在释迦文尼所得道敬爱心重故归命。于余佛所直稽首。问曰。佛口说。一世间无一时二佛出。亦不得一时二转轮王出。以是故。不应现在有余佛。答曰。虽有此言汝不解其义。佛说一三千大千世界中。无一时二佛出。非谓十方世界无现在佛也。如四天下世界中。无一时二转轮圣王出。此大福德人无怨敌共世故。以是故。四天下一转轮圣王。佛亦如是。于三千大千世界中亦无二佛出。佛及转轮圣王经说一种。汝何以信余四天下。更有转轮圣王。而不信余三千大千世界中更有佛。复次一佛不能得度一切众生。若一佛能度一切众生者。可不须余佛。但一佛出。如诸佛法度可度众生已而灭。如烛尽火灭。有为法无常性空故。以是故。现在应更有余佛。复次众生无量苦亦无量。是故应有大心菩萨出。亦应有无量佛。出世度诸众生。问曰。如经中说无量岁中佛时时出。譬如沤昙婆罗树华时时一出。若十方佛充满。佛便易出易得不名为难值。答曰不尔。为一大千世界中佛无量岁时时出。不言一切十方世界中难。亦为罪人不知恭敬不勤精进求道。以是故语言佛无量岁时时一出。又此众生众罪报故。堕恶道中无量劫尚不闻佛名。何况见佛。以是人故言佛出世难。问曰。若现在十方多有诸佛菩萨。今一切众生罪恶苦恼。何以不来度之。答曰。众生无量阿僧祇劫罪垢深厚。虽有种种余福。无见佛功德故不见佛。如偈说

  好福报未近　　衰罪未除却
  现在不能见　　大德有力人
  大德诸圣人　　心亦无分别
  慈悲一切人　　一时令欲度
  众生福德熟　　智慧根亦利
  若为现度缘　　即时得解脱
  譬如大龙王　　随愿雨众雨
  罪福随本行　　各各如所受

问曰。若自有福德自有智慧。如是人佛能度。若无福德智慧佛不度。若尔者自有福德智慧不待佛度。答曰。此福德智慧从佛因缘出。若佛不出世。诸菩萨以十善因缘四无量意。后世罪福报种种因缘教道。若无菩萨。有种种经中说。人得此法行福德因缘。复次人虽有福德智慧。若佛不出世。是世界中受报不能得道。若佛出世乃能得道。是为大益。譬如人虽有目日不出时不能有所见。要须日明得有所见。不得言我有眼何用日为。如佛说二因二缘能生正见。一从他闻法。二内自如法思惟福德事故。能生善心利根智慧故。能如法思惟。以是故知从佛得度。如是等种种多有违错。欲作般若波罗蜜论议故。不能复广论余事

大智度论卷第四大智度初品中摩诃萨埵释论第九(卷第五)

        龙树菩萨造

        后秦龟兹国三藏法师鸠摩罗什奉　诏译

【经】摩诃萨埵

【论】问曰。云何名摩诃萨埵。答曰。摩诃者大萨埵名众生。或名勇心。此人心能为大事不退不还大勇心故名为摩诃萨埵。复次摩诃萨埵者。于多众生中最为上首故。名为摩诃萨埵。复次多众生中起大慈大悲成立大乘。能行大道得最大处故。名摩诃萨埵。复次大人相成就故。名摩诃萨埵。摩诃萨埵相者。如赞佛偈中说

  唯佛一人独第一　　三界父母一切智
  于一切等无与等　　稽首世尊希有比
  凡人行惠为己利　　求报以财而给施
  佛大慈仁无此事　　怨亲憎爱以等利

复次必能说法。破一切众生及己身大邪见大爱慢大我心等诸烦恼故。名为摩诃萨埵。复次众生如大海无初无中无后。有明智算师。于无量岁计算不能尽竟。如佛语无尽意菩萨。譬如十方一切世界乃至虚空边际。合为一水。令无数无量众生。共持一发取一渧而去。更有无央数众生。如前共持一发取一渧而去。如是令彼大水悉尽无余。众生故不尽。以是众生等。无边无量不可数不可思议。尽能救济令离苦恼着于无为安隐乐中。有此大心欲度多众生故。名摩诃萨埵。如不可思议经中沤舍那优婆夷语须达那菩萨言。诸菩萨摩诃萨辈不为度一人故。发阿耨多罗三藐三菩提心。亦非为二三乃至十人故。非百非千非万非十万非百万。非一亿十百千万乃至亿亿。非为阿由他亿众生故发心。非那由他亿非阿耶陀众生故。非频婆罗。非歌歌罗。非阿歌罗。非簸婆罗。非摩波罗非波陀。非多婆。非鞞婆呵。非怖摩非念摩。非阿婆迦。非摩伽婆。非毗罗伽。非僧伽摩。非毗萨罗。非谓阎婆。非鞞阇迦。非鞞卢呵。非鞞跋帝。非鞞伽多非兜罗。非阿婆罗那。非他婆罗。非鞞婆耶婆。非藐写非钝那耶写。非[酉*益]婆罗。非鞞婆罗。非菩遮多。非阿跋伽陀。非鞞施他。非泥婆罗。非[酉*益]犁浮陀。非波摩陀夜。非比初婆。非阿犁浮陀。非阿犁萨写。非[酉*益]云迦。非度于多。非呵楼那。非摩楼陀非叉夜。非乌罗多。非末殊夜摩。非三摩陀。非毗摩陀。非波摩陀。非阿满陀罗。非婆满多罗。非摩多罗。非[酉*益]兜末多罗。非鞞摩多罗。非波罗多罗。非尸婆多罗。非[酉*益]罗。非为罗。非提罗。非枝罗。非翅罗。[酉*益]尼罗。非斯罗。非波罗。非弥罗。非婆罗罗。非迷楼。非企卢。非摩屠罗。非三牟罗。非阿婆夜。非剑摩罗。非摩摩罗。非阿达多。非[酉*益]楼。非鞞楼婆。非迦罗跋。非呵婆跋。非鞞婆跋。非婆婆。非阿罗婆。非娑罗婆罗。非迷罗浮罗。非摩遮罗。非陀摩罗。非波摩陀。非尼伽摩。非阿跋多。非泥提舍。非阿叉夜。非三浮陀。非婆摩摩。非阿婆陀。非沤波罗。非波头摩。非僧佉非伽提。非沤波伽摩。非阿僧祇非阿僧祇阿僧祇。非无量非无量无量。非无边非无边无边。非无等非无等无等。非无数非无数无数。非不可计非不可计不可计。非不可思议非不可思议不可思议。非不可说非不可说不可说。非为一国土微尘等众生故发心。非为二三至十百千万亿千万亿阿由陀那由他乃至不可说不可说国土微尘等众生故发心。非为一阎浮提微尘等众生故发心。非为拘陀尼郁怛罗曰弗婆提微尘等众生故发心。非为小千世界中千世界大千世界微尘等众生故发心。非为二三至十百千万亿阿由他那由陀乃至不可说不可说三千大千世界微尘等众生故发心。非为供养供给一佛故发心。乃至非为供养供给不可说不可说诸佛故发心。非为供养供给一国土微尘等诸佛故发心。乃至非为供养供给不可说不可说三千大千世界微尘等诸佛故发心。非为净一佛土故发心。乃至非为净不可说不可说三千大千世界微尘等佛土故发心。非为受持一佛法故发心。乃至非为受持不可说不可说三千大千世界微尘等佛法故发心。非为令一三千大千世界中佛种不断故发心。乃至非为令不可说不可说三千大千世界微尘等三千大千世界中佛种不断故发心。非为分别知一佛愿故发心。乃至非为分别知不可说不可说三千大千世界微尘等佛愿故发心。非为庄严一佛土故发心。乃至非为庄严不可说不可说三千大千世界微尘等佛土故发心。非为分别知一佛会弟子众故发心。乃至非为分别知不可说不可说三千大千世界微尘等佛会弟子众故发心。非为持一佛法轮故发心。乃至非为持不可说不可说三千大千世界微尘等佛法轮故发心。非为知一人诸心故。非为知一人诸根故。非为知一三千大千世界中诸劫次第相续故。非为分别断一人诸烦恼故发心。乃至非为分别断不可说不可说三千大千世界微尘等人诸烦恼故发心。是诸菩萨摩诃萨愿言。尽教化一切十方众生。尽供养供给一切十方诸佛。愿令一切十方诸佛土清净。心坚受持一切十方诸佛法。分别知一切诸佛土故。尽知一切诸佛弟子众故。分别知一切众生诸心故。知断一切众生诸烦恼故。尽知一切众生诸根故。诸菩萨发心作阿耨多罗三藐三菩提。如是等十门为首。乃至百千万亿阿僧祇门是为道法门。菩萨应知应入略说如是。诸菩萨实道。一切诸法皆入皆知。智慧知故一切佛土菩萨道中庄严故。沤舍那言。善男子我愿如是自有世界已来。一切众生尽清净。一切烦恼悉断。须达那言。是何解脱。沤舍那答言。是名无忧安隐幢。我知此一解脱门。不知诸菩萨大心如大海水。一切诸佛法能持能受。诸菩萨心不动如须弥山。诸菩萨如药王能除一切诸烦恼。诸菩萨如日能照除一切闇。诸菩萨如地能含受一切众生。诸菩萨如风能益一切众生。诸菩萨如火能烧一切外道诸烦恼。诸菩萨如云能雨法水。诸菩萨如月福德光明能照一切。诸菩萨如释提桓因守护一切众生。是菩萨道法甚深。我云何能尽知。以是诸菩萨生大愿欲得大事欲至大处故。名摩诃萨埵。复次是般若波罗蜜经中。摩诃萨埵相。佛自说如是。如是相是摩诃萨埵相。舍利弗须菩提富楼那等诸大弟子。各各说彼品。此中应广说

    大智度初品中菩萨功德释论第十

【经】皆得陀罗尼及诸三昧行空无相无作已得等忍

【论】问曰。何以故。以此三事次第赞菩萨摩诃萨。答曰。欲出诸菩萨实功德故。应赞则赞应信则信。以一切众生所不能信甚深清净法。赞菩萨。复次先说菩萨摩诃萨名字。未说所以为菩萨摩诃萨。以得诸陀罗尼三昧及忍等诸功德故。名为菩萨摩诃萨。问曰。已知次第义。何以故名陀罗尼。云何陀罗尼。答曰。陀罗尼秦言能持。或言能遮。能持者。集种种善法。能持令不散不失。譬如完器盛水水不漏散。能遮者。恶不善根心生。能遮令不生。若欲作恶罪。持令不作。是名陀罗尼。是陀罗尼或心相应。或心不相应。或有漏或无漏。无色不可见无对一持一入一阴摄。法持法入行阴九智知(丹注云除尽智)一识识(丹注云一意识)阿毗昙法。陀罗尼义如是。复次得陀罗尼菩萨。一切所闻法以念力故。能持不失。复次是陀罗尼法常逐菩萨。譬如间日疟病。是陀罗尼不离菩萨。譬如鬼着。是陀罗尼常随菩萨。如善不善律仪。复次是陀罗尼。持菩萨不令堕二地坑。譬如慈父爱子。子欲堕坑。持令不堕。复次菩萨得陀罗尼力故。一切魔王魔民魔人。无能动无能破无能胜。譬如须弥山凡人口吹不能令动。问曰。是陀罗尼有几种。答曰。是陀罗尼多种。一名闻持陀罗尼。得是陀罗尼者。一切语言诸法耳所闻者皆不忘失。是名闻持陀邻尼。复有分别知陀罗尼。得是陀罗尼者。诸众生诸法大小好丑分别悉知。如偈说

  诸象马金　　木石诸衣　　男女及水
  种种不同　　诸物名一　　贵贱理殊
  得此总持　　悉能分别

复有入音声陀罗尼。菩萨得此陀罗尼者。闻一切语言音。不喜不嗔。一切众生如恒河沙等劫。恶言骂詈心不憎恨。问曰。菩萨诸漏未尽。云何能如恒河沙等劫。忍此诸恶。答曰。我先言得此陀罗尼力故能尔。复次是菩萨虽未尽漏。大智利根能思惟。除遣嗔心作是念。若耳根不到声边。恶声着谁。又如骂声闻便直过。若不分别谁当嗔者。凡人心着吾我。分别是非而生恚恨。复次若人能知诸言随生随灭前后不俱则无嗔恚。亦知诸法内无有主。谁骂谁嗔。若有人闻殊方异语。此言为好彼以为恶。好恶无定虽骂不嗔。若有人知语声无定则无嗔喜。如亲爱骂之。虽骂不恨。非亲恶言闻则生恚。如遭风雨则入舍持盖。如地有刺则着靴鞋。大寒燃火热时求水。如是诸患但求遮法而不嗔之。骂詈诸恶亦复如是。但以慈悲息此诸恶不生嗔心。复次菩萨知诸法不生不灭其性皆空。若人嗔恚骂詈。若打若杀如梦如化。谁嗔谁骂。复次若有人如恒河沙等劫。众生赞叹。供养衣食卧具医药华香璎珞。得忍菩萨其心不动不喜不着。问曰。已知菩萨种种不嗔因缘。未知实赞功德而亦不喜。答曰。知种种供养恭敬是皆无常。今有因缘故来赞叹供养。后更有异因缘则嗔恚。若打若杀。是故不喜。复次菩萨作是念以我有功德智慧故来赞叹供养。是为赞叹功德非赞我也。我何以喜。复次是人自求果报故。于我所作因缘。供养我作功德。譬如人种谷。溉灌修理地亦不喜

复次若人供养我。我若喜受者。我福德则薄他人得福亦少。以是故不喜。复次菩萨观一切法如梦如响。谁赞谁喜。我于三界中未得脱。诸漏未尽未得佛道。云何得赞而喜。若应喜者唯佛一人。何以故。一切功德都已满故。是故菩萨得种种赞叹供养供给心不生喜。如是等相名为入音声陀罗尼。复有名寂灭陀罗尼无边旋陀罗尼随地观陀罗尼威德陀罗尼华严陀罗尼音净陀罗尼虚空藏陀罗尼海藏陀罗尼分别诸法地陀罗尼明诸法义陀罗尼。如是等略说五百陀罗尼门。若广说则无量。以是故言诸菩萨皆得陀罗尼。诸三昧者。三三昧空无作无相。有人言。观五阴无我无我所。是名为空。住是空三昧。不为后世故起三毒。是名无作。缘离十相故。五尘男女生住灭故。是名无相。有人言。住是三昧中知一切诸法实相。所谓毕竟空。是名空三昧。知是空已无作。云何无作。不观诸法若空若不空若有若无等。如佛说法句中偈

  见有则恐怖　　见无亦恐怖
  是故不著有　　亦复不着无

是名无作三昧。云何无相三昧。一切法无有相。一切法不受不着。是名无相三昧。如偈说

  言语已息　　心行亦灭　　不生不灭
  如涅槃相

复次十八空是名空三昧。种种(丹注云五道生有本有死有中有业)有中心不求。是名无作三昧。一切诸相破坏不忆念。是名无相三昧。问曰。有种种禅定法。何以故。独称此三三昧。答曰。是三三昧中思惟近涅槃故。令人心不高不下平等不动。余处不尔。以是故独称是三三昧。余定中或爱多或慢多或见多。是三三昧中。第一实义实利能得涅槃门。以是故。诸禅定法中。以是三空法为三解脱门。亦名为三三昧。是三三昧实三昧故。余定亦得名定。复次除四根本禅。从未到地乃至有顶地。名为定。亦名三昧。非禅四禅亦名定亦名禅亦名三昧。诸余定亦名定亦名三昧。如四无量四空定四辩六通八背舍八胜处九次第定十一切处等诸定法。复有人言。一切三昧法有二十三种。有言六十五种。有言五百种。摩诃衍最大故无量三昧。所谓遍法性庄严三昧。能照一切三世法三昧。不分别知观法性底三昧。入无底佛法三昧。如虚空无底无边照三昧。如来力行观三昧。佛无畏庄严力嚬呻三昧。法性门旋藏三昧。一切世界无碍庄严遍月三昧。遍庄严法云光三昧。菩萨得如是等无量诸三昧。复次般若波罗蜜摩诃衍义品中。略说则有一百八三昧。初名首楞严三昧乃至虚空不着不染三昧。广说则无量三昧。以是故说。诸菩萨得诸三昧行空无相无作者。问曰前言菩萨得诸三昧。何以故。复言行空无相无作。答曰。前说三昧名未说相。今欲说相。是故言行空无作无相。若有人行空无相无作。是名得实相三昧。如偈说

  若持戒清净　　是名实比丘
  若有能观空　　是名得三昧
  若有能精进　　是名行道人
  若有得涅槃　　是名为实乐

已得等忍者。问曰。云何等云何忍。答曰。有二种等。众生等法等。忍亦二种众生忍法忍。云何众生等。一切众生中等心等念等爱等利。是名众生等。问曰。慈悲力故于一切众生中。应等念。不应等观。何以故。菩萨行实道不颠倒如法相。云何于善人不善人大人小人人及畜生。一等观。不善人中实有不善相。善人中实有善相。大人小人人及畜生亦尔。如牛相牛中住。马相马中住。牛相非马中。马相非牛中。马不作牛故。众生各各相。云何一等观而不堕颠倒。答曰。若善相不善相是实。菩萨应堕颠倒。何以故破诸法相故以诸法非实。善相非实不善相非多相非少相。非人非畜生非一非异。以是故汝难非也。如说诸法相偈

  不生不灭　　不断不常　　不一不异
  不去不来　　因缘生法　　灭诸戏论
  佛能说是　　我今当礼

复次一切众生中。不着种种相。众生相空相一等无异。如是观。是名众生等。若人是中心等无碍。直入不退。是名得等忍。得等忍菩萨。于一切众生不嗔不恼如慈母爱子。如偈说

  观声如呼响　　身行如镜像
  如此得观人　　云何而不忍

是名众生等忍。云何名法等忍。善法不善法有漏无漏有为无为等法。如是诸法入不二入法门。入实法相门。如是入竟。是中深入诸法实相时。心忍直入无诤无碍。是名法等忍。如偈说

  诸法不生不灭　　非不生非不灭
  亦不生灭非不生灭　　亦非不生灭
  非非不生灭

已得解脱(丹注云于邪见得离故言解脱也)空非空(丹注云于空不取故言非也)是等悉舍灭诸戏论言语道断。深入佛法心通无碍不动不退。名无生忍。是助佛道初门以是故说已得等忍

【经】得无碍陀罗尼

【论】问曰。前已说诸菩萨得陀罗尼。今何以复说得无碍陀罗尼。答曰。无碍陀罗尼最大故。如一切三昧中三昧王三昧最大。如人中之王。如诸解脱中无碍解脱。大(丹注云得佛得道时所得也)如是一切诸陀罗尼中。无碍陀罗尼大。以是故重说。复次先说诸菩萨得陀罗尼。不知是何等陀罗尼。有小陀罗尼如转轮圣王仙人等所得闻持陀罗尼分别众生陀罗尼归命救护不舍陀罗尼。如是等小陀罗尼余人亦有。是无碍陀罗尼。外道声闻辟支佛新学菩萨皆悉不得。唯无量福德智慧大力诸菩萨。独有是陀罗尼。以是故别说。复次是菩萨辈。自利已具足。但欲益彼说法教化无尽。以无碍陀罗尼为根本。以是故诸菩萨。常行无碍陀罗尼

【经】悉是五通

【论】如意天眼天耳他心智自识宿命。云何如意。如意有三种。能到转变圣如意。能到有四种。一者身能飞行如鸟无碍。二者移远令近不往而到。三者此没彼出。四者一念能至。转变者。大能作小小能作大一能作多多能作一。种种诸物皆能转变。外道辈转变极久不过七日。诸佛及弟子转变自在无有久近。圣如意者。外六尘中不可爱不净物。能观令净。可爱净物。能观令不净。是圣如意法唯佛独有。是如意通从修四如意足生。是如意足通等。色缘故。次第生。不可一时得。天眼通者。于眼。得色界四大造清净色。是名天眼。天眼所见。自地及下地六道中众生诸物。若近若远若覆若细诸色无不能照。见天眼有二种。一者从报得。二者从修得。是五通中天眼从修得非报得。何以故。常忆念种种光明得故。复次有人言。是诸菩萨辈得无生法忍力故。六道中不摄。但为教化众生故。以法身现于十方。三界中未得法身菩萨。或修得或报得。问曰。是诸菩萨功德。胜阿罗汉辟支佛。何以故。赞凡夫所共小功德天眼。不赞诸菩萨慧眼法眼佛眼。答曰有三种天。一假号天二生天三清净天。转轮圣王诸余大王等。是名假号天。从四天王天乃至有顶生处。是名生天。诸佛法身菩萨辟支佛阿罗汉。是名清净天。是清净天修得天眼。是谓天眼通。佛法身菩萨清净天眼。一切离欲五通凡夫所不能得。声闻辟支佛亦所不得。所以者何。小阿罗汉小用心。见一千世界。大用心见二千世界。大阿罗汉小用心。见二千世界。大用心见三千大千世界。辟支佛亦尔。是名天眼通。云何名天耳通。于耳。得色界四大造清净色。能闻一切声天声人声三恶道声。云何得天耳通。修得常忆念种种声。是名天耳通。云何识宿命通。本事常忆念日月年岁至胎中。乃至过去世中。一世十世百世千万亿世。乃至大阿罗汉辟支佛。知八万大劫。诸大菩萨及佛知无量劫。是名识宿命通。云何名知他心通。知他心若有垢若无垢。自观心生住灭时。常忆念故得。复次观他人喜相嗔相怖相畏相。见此相已然后知心。是为他心智初门。是五通略说竟

【经】言必信受

【论】天人龙阿修罗等。及一切大人。皆信受其语。是不绮语报故。诸绮语报者。虽有实语一切人皆不信受如偈说

  有堕饿鬼中　　火炎从口出
  四向发大声　　是为口过报
  虽复多闻见　　在大众说法
  以不诚信业　　人皆不信受
  若欲广多闻　　为人所信受
  是故当至诚　　不应作绮语

【经】无复懈怠

【论】懈怠法破在家人财利福利。破出家人生天乐涅槃乐。在家出家名声俱灭。大失大贼无过懈怠。如偈说

  懈怠没善心　　痴闇破智明
  妙愿皆为灭　　大业亦已失

以是故说无复懈怠

【经】已舍利养名闻

【论】是利养法如贼坏功德本。譬如天雹伤害五谷。利养名闻亦复如是。坏功德苗令不增长。如佛说譬喻。如毛绳缚人断肤截骨。贪利养人断功德本亦复如是。如偈说

  得入栴檀林　　而但取其叶
  既入七宝山　　而更取水精
  有人入佛法　　不求涅槃乐
  反求利供养　　是辈为自欺
  是故佛弟子　　欲得甘露味
  当弃舍杂毒　　勤求涅槃乐
  譬如恶雹雨　　伤害于五谷
  若着利供养　　破惭愧头陀
  今世烧善根　　后世堕地狱
  如提婆达多　　为利养自没

以是故言已舍利养名闻

【经】说法无所悕望

【论】大慈怜愍为众说法。不为衣食名声势力故说大慈悲故。心清净故。得无生法忍故。如偈说

  多闻辩慧巧言语　　美说诸法转人心
  自不如法行不正　　譬如云雷而不雨
  博学多闻有智慧　　讷口拙言无巧便
  不能显发法宝藏　　譬如无雷而小雨
  不广学问无智慧　　不能说法无好行
  是弊法师无惭愧　　譬如小云无雷雨
  多闻广智美言语　　巧说诸法转人心
  行法心正无所畏　　如大云雷澍洪雨
  法之大将持法镜　　照明佛法智慧藏
  持诵广宣振法铃　　如海中船渡一切
  亦如蜂王集诸味　　说如佛言随佛意
  助佛明法度众生　　如是法师甚难值

【经】度甚深法忍

【论】云何甚深法。十二因缘是名甚深法。如佛告阿难。是十二因缘法甚深难解难知。复次依过去未来世生六十二邪见网永离。是名甚深法。如佛语比丘。凡夫无闻若欲赞佛所赞甚小。所谓若赞戒清净。若赞离诸欲。若能赞是甚深难解难知法。是为实赞佛。是中梵网经应广说。复次三解脱门。是名甚深法。如佛说般若波罗蜜中诸天赞言。世尊是法甚深。佛言甚深法者空则是义。无作无相则是义。复次解一切诸法相。实不可破不可动。是名甚深法。复次除内心想智力。但定心诸法清净实相中住。譬如热气盛非黄见黄。心想智力故。于诸法转观。是名浅法。譬如人眼清净无热气。如实见黄是黄。如是除内心想智力。慧眼清净见诸法实相。譬如真水精黄物着中则随作黄色。青赤白色皆随色变。心亦如是凡夫人内心想智力故。见诸法异相。观诸法实相非空非不空不有非不有。是法中深入不转无所挂碍。是名度深法忍。度名得甚深法。具足满无所碍。得度彼岸。是名为度

【经】得无畏力

【论】诸菩萨四无所畏力成就。问曰。如菩萨所作未办。未得一切智。何以故。说得四无所畏。答曰。无所畏有二种。菩萨无所畏佛无所畏。是诸菩萨虽未得佛无所畏。得菩萨无所畏。是故名为得无畏力。问曰。何等为菩萨四无所畏。答曰。一者一切闻能持故。得诸陀罗尼故。常忆念不忘故。众中说法无所畏故。二者知一切众生欲解脱因缘诸根利钝。随其所应而为说法故。菩萨在大众中说法无所畏。三者不见若东方南西北方四维上下有来难问令我不能如法答者。不见如是少许相故。于众中说法无所畏。四者一切众生听受问难。随意如法答。能巧断一切众生疑故。菩萨在大众中说法无所畏

【经】过诸魔事

【论】魔有四种。一者烦恼魔。二者阴魔。三者死魔。四者他化自在天子魔。是诸菩萨得菩萨道故。破烦恼魔得法身故。破阴魔得道得法性身故。破死魔常一心故。一切处心不着故。入不动三昧故。破他化自在天子魔。以是故说过诸魔事。复次是般若波罗蜜觉魔品中。佛自说魔业魔事。是魔业魔事尽已过故。是名已过魔事。复次除诸法实相。余残一切法尽名为魔。如诸烦恼结使欲缚取缠阴界入魔王魔民魔人。如是等尽名为魔。问曰。何处说欲缚等诸结使名为魔。答曰。杂法藏经中。佛说偈语魔王

  欲是汝初军　　忧愁军第二
  饥渴军第三　　爱军为第四
  第五眠睡军　　怖畏军第六
  疑为第七军　　含毒军第八
  第九军利养　　着虚妄名闻
  第十军自高　　轻慢于他人
  汝军等如是　　一切世间人
  及诸一切天　　无能破之者
  我以智慧箭　　修定智慧力
  摧破汝魔军　　如坏瓶没水
  一心修智慧　　以度于一切
  我弟子精进　　常念修智慧
  随顺如法行　　必得至涅槃
  汝虽不欲放　　到汝不到处
  是时魔王闻　　愁忧即灭去
  是魔恶部党　　亦复没不现

是名诸结使魔。问曰。五众十八界十二入何处说是魔。答曰。莫拘罗山中。佛教弟子罗陀。色众是魔。受想行识亦如是。复次若欲作未来世色身。是为动处。若欲作无色身。是亦为动处。若欲作有想无想非有想非无想身。是为一切动处。动是魔缚不动则不缚从恶得脱。此中说众界入是魔。自在天子魔。魔民魔人即是魔。不须说。问曰。何以名魔。答曰。夺慧命坏道法功德善本。是故名为魔。诸外道人辈言是名欲主。亦名华箭亦名五箭。(丹本注云五欲箭也)破种种善事故。佛法中名为魔罗。是业是事名为魔事。是何等魔事。如觉魔品中说。复次人展转世间受苦乐结使因缘。亦魔王力因缘。是魔名诸佛怨仇一切圣人贼。破一切逆流人事不喜涅槃。是名魔。是魔有三事。戏笑语言歌舞邪视。如是等从爱生。缚打鞭拷刺割斫截。如是等从嗔生。炙身自冻拔发自饿入火赴渊投岩。如是等从愚痴生。又大过失不净染着世间皆是魔事。憎恶利益不用涅槃及涅槃道亦是魔事。没大苦海不自觉知。如是等无量皆是魔事。已弃已舍是为过诸魔事

【经】一切业障悉得解脱

【论】一切恶业得解脱。是名业障得解脱。问曰。若三种障。烦恼障业障报障。何以舍二障但说业障。答曰。三障中业力最大故。积集诸业乃至百千万劫中。不失不烧不坏。与果报时不亡。是诸业能久住和合时。与果报。如谷草子在地中得时节而生不失不坏。是诸佛一切智第一尊重。如须弥山王尚不能转是诸业。何况凡人。如偈说

  生死轮载人　　诸烦恼结使
  大力自在转　　无人能禁止
  先世业自作　　转为种种形
  业力最为大　　世间中无比
  先世业自在　　将人受果报
  业力故轮转　　生死海中回
  大海水干竭　　须弥山地尽
  先世因缘业　　不烧亦不尽
  诸业久和集　　造者自逐去
  譬如责物主　　追逐人不置
  是诸业果报　　无有能转者
  亦无逃避处　　非求哀可免
  三界中众生　　追之不暂离
  如珂梨罗刹　　是业佛所说
  如风不入实　　水流不仰行
  虚空不受害　　无业亦如是
  诸业无量力　　不逐非造者
  果报时节来　　不亡亦不失
  从地飞上天　　从天入雪山
  从雪山入海　　一切处不离
  常恒随逐我　　无一时相舍
  直至无失时　　如星流趣月

以是故说一切诸业障悉得解脱

【经】巧说因缘法

【论】十二因缘生法。种种法门能巧说。烦恼业事法次第展转相续生。是名十二因缘。是中无明爱取三事名烦恼。行有二事名为业。余七分名为体事。是十二因缘。初二过去世摄。后二未来世摄。中八现前世摄。是略说三事。烦恼业苦。是三事展转更互为因缘。是烦恼业因缘。业苦因缘。苦苦因缘。苦烦恼因缘。烦恼业因缘。业苦因缘。苦苦因缘。是名展转更互为因缘。过去世一切烦恼是名无明。从无明生业。能作世界果故。名为行。从行生垢心。初身因如犊子识母。自相识故名为识。是识共生无色四阴及是所住色。是名名色。是名色中生眼等六情。是名六入。情尘识合是名为触。从触生受。受中心着。是名渴爱。渴爱因缘求是名取。从取后世因缘业。是名有。从有还受后世五众。是名生。从生五众熟坏。是名老死。老死生忧悲哭泣种种愁恼。众苦和合集。若一心观诸法实相清净则无明尽。无明尽故行尽。乃至众苦和合集皆尽。是十二因缘相。如是能方便不着邪见为人演说。是名为巧。复次是十二因缘观中。断法爱心不着。知实相是名为巧。如彼般若波罗蜜不可尽品中。佛告须菩提。痴如虚空不可尽。行如虚空不可尽。乃至众苦和合集。如虚空不可尽。菩萨当作是知。作是知者。为舍痴际应无所入。作是观十二因缘起者。则为坐道场得萨婆若

【经】从阿僧祇劫已来发大誓愿

【论】阿僧祇义。菩萨义品中已说。劫义佛譬喻说。四千里石山有长寿人。百岁过持细软衣一来拂拭。令是大石山尽。劫故未尽。四千里大城。满中芥子。不概令平。有长寿人百岁过一来取一芥子去。芥子尽。劫故不尽。菩萨如是无数劫。发大正愿度脱众生愿名大心要誓。必度一切众生断诸结使。成阿耨多罗三藐三菩提。是名为愿

【经】颜色和悦常先问讯所语不粗

【论】嗔恚本拔故。嫉妒除故。常修大慈大悲大喜故。四种邪语断故。得颜色和悦。如偈说

  若见乞道人　　能以四种待
  初见好眼视　　迎逆敬问讯
  床座好供养　　充满施所欲
  布施心如是　　佛道如在掌
  若能除四种　　口过妄语毒
  两舌恶绮语　　得大美果报
  善软人求道　　欲度诸众生
  除四邪口业　　譬如马有辔

【经】于大众中得无所畏

【论】大德故。坚实功德智慧故。得最上辩陀罗尼故。于大众中得无所畏。如偈说

  内心智德薄　　外善以美言
  譬如竹无内　　但示有其外
  内心智德厚　　外善以法言
  譬如妙金刚　　中外力具足

复次无畏法成就故。端正贵族大力。持戒禅定智慧语议等皆成就。是故无所畏。以是故于大众中无所畏。如偈说

  少德无智慧　　不应处高座
  如豺见师子　　窜伏不敢出
  大智无所畏　　应处师子座
  譬如师子吼　　众兽皆怖畏

无量无边智慧福德力集故。无所畏如偈说

  若人灭众恶　　乃至无小罪
  如是大德人　　无愿而不满
  是人大智慧　　世界中无恼
  是故如此人　　生死涅槃一

复次独得菩萨无所畏故。如毗那婆那王经中说。菩萨独得四无所畏。如先说

【经】无数亿劫说法巧出

【论】不放逸等诸善根自身好修。是诸菩萨非一世二三四世乃至无量阿僧祇劫集功德智慧。如偈说

  为众生故发大心　　若有不敬生慢者
  其罪甚大不可说　　何况而复加恶心

复次是菩萨。无数无量劫中。修身修戒修心修慧。生灭缚解逆顺中自了了。知诸法实相有三种解。闻解义解得解。种种说法门中无所挂碍。皆得说法方便智慧波罗蜜。是诸菩萨所说如圣人说皆应信受。如偈说

  有慧无多闻　　是不知实相
  譬如大闇中　　有目无所见
  多闻无智慧　　亦不知实义
  譬如大明中　　有灯而无目
  多闻利智慧　　是所说应受
  无慧亦无明　　是名人身牛

问曰。应言无数亿劫巧说法。复何以言出。答曰。于无智人中及弟子中说法易。若多闻利智善论议人中说法难。若小智法师是中退缩。若大学多闻。问难中大胆欣豫。一切众中有大威德。如天会经中偈说

  面目齿光明　　普照于大会
  映夺诸天光　　种种皆不现

以是故名为无数亿劫巧说法中能得出

大智度论卷第五大智度初品中十喻释论第十一(第六卷)

        龙树菩萨造

        后秦龟兹国三藏法师鸠摩罗什奉　诏译

【经】解了诸法如幻如焰如水中月如虚空如响如犍闼婆城如梦如影如镜中像如化

【论】是十喻为解空法故。问曰。若一切诸法空如幻。何以故。诸法有可见可闻可嗅可尝可触可识者。若实无所有不应有可见乃至可识。复次若无而妄见者。何以不见声闻色。若皆一等空无所有。何以有可见不可见者。以诸法空故如一指第一甲无第二甲亦无。何以不见第二甲。独见第一甲。以是故知。第一甲实有故可见。第二甲实无故不可见。答曰。诸法相虽空。亦有分别可见不可见。譬如幻化象马及种种诸物。虽知无实。然色可见声可闻。与六情相对不相错乱。诸法亦如是。虽空而可见可闻不相错乱。如德女经说。德女白佛言。世尊。如无明内有不。佛言不。外有不。佛言不。内外有不。佛言不。世尊。是无明从先世来不。佛言不。从此世至后世不。佛言不。是无明有生者灭者不。佛言不。有一法定实性是名无明不。佛言不。尔时德女复白佛言。若无明无内无外亦无内外。不从先世至今世今世至后世。亦无真实性者。云何从无明缘行。乃至众苦集。世尊。譬如有树若无根者。云何得生茎节枝叶华果。佛言诸法相虽空。凡夫无闻无智故。而于中生种种烦恼。烦恼因缘作身口意业。业因缘作后身。身因缘受苦受乐。是中无有实作烦恼。亦无身口意业。亦无有受苦乐者。譬如幻师幻作种种事。于汝意云何。是幻所作内有不。答言不。外有不。答言不。内外有不。答言不。从先世至今世今世至后世不。答言不。幻所作有生者灭者不。答言不。实有一法是幻所作不。答言不。佛言汝颇见颇闻幻所作妓乐不。答言。我亦闻亦见。佛问德女。若幻空欺诳无实。云何从幻能作伎乐。德女白佛。世尊。是幻相尔虽无根本而可闻见。佛言。无明亦如是。虽不内有不外有。不内外有。不先世至今世今世至后世。亦无实性。无有生者灭者。而无明因缘诸行生。乃至众苦阴集。如幻息幻所作亦息无明亦尔。无明尽行亦尽。乃至众苦集皆尽。复次是幻譬喻。示众生一切有为法空不坚固。如说一切诸行如幻欺诳小儿。属因缘不自在不久住。是故说诸菩萨知诸法如幻。如炎者。炎以日光风动尘故。旷野中见如野马。无智人初见谓之为水。男相女相亦如是。结使烦恼日光。热诸行尘邪忆念风。生死旷野中转。无智慧者谓为一相为男为女。是名如炎。复次若远见炎想为水。近则无水想。无智人亦如是。若远圣法不知无我。不知诸法空。于阴界入性空法中。生人相男相女相。近圣法则知诸法实相。是时虚诳种种妄想尽除。以是故说。诸菩萨知诸法如炎。如水中月者。月实在虚空中影现于水。实法相月。在如法性实际虚空中。而凡天人心水中。有我我所相现。以是故名如水中月。复次如小儿见水中月欢喜欲取。大人见之则笑。无智人亦如是。身见故见有吾我。无实智故见种种法。见已欢喜欲取诸相男相女相等。诸得道圣人笑之。如偈说

  如水中月炎中水　　梦中得财死求生
  有人于此实欲得　　是人痴惑圣所笑

复次譬如静水中见月影。搅水则不见。无明心静水中。见吾我憍慢诸结使影。实智慧杖搅心水。则不见吾我等诸结使影。以是故说。诸菩萨知诸法如水中月。如虚空者。但有名而无实法。虚空非可见法。远视故眼光转见缥色。诸法亦如是空无所有。人远无漏实智慧故。弃实相见彼我男女屋舍城郭等种种杂物。心着如小儿仰视青天谓有实色。有人飞上极远而无所见。以远视故谓为青色。诸法亦如是。以是故说如虚空。复次如虚空性常清净。人谓阴曀为不净。诸法亦如是。性常清净淫欲嗔恚等曀故。人谓为不净。如偈说

  如夏月天雷电雨　　阴云覆曀不清净
  凡夫无智亦如是　　种种烦恼常覆心
  如冬天日时一出　　常为昏气云荫曀
  虽得初果第二道　　犹为欲染之所蔽
  若如春天日欲出　　时为阴云所覆曀
  虽离欲染第三果　　余残痴慢犹覆心
  若如秋日无云曀　　亦如大海水清净
  所作已办无漏心　　罗汉如是得清净

复次虚空无初无中无后。诸法亦如是。复次如摩诃衍中佛语须菩提。虚空无前世亦无中世亦无后世。诸法亦如是。彼经此中应广说。是故说诸法如虚空。问曰。虚空实有法。何以故。若虚空无实法者。若举若下若来若往若屈若申若出若入等有所作。应无有以无动处故。答曰。若虚空法实有。虚空应有住处。何以故。无住处则无法。若虚空在孔穴中住。是为虚空在虚空中住。以是故不应孔中住。若在实中住是实非空则不得住无所受故。复次汝言住处是虚空。如石壁实中无有住处。若无住处则无虚空。以虚空无住处故无虚空。复次无相故无虚空。诸法各各有相。相有故知有法。如地坚相水湿相火热相风动相识识相慧解相世间生灭相涅槃永灭相。是虚空无相故无。问曰。虚空有相汝不知故言无。无色处是虚空相。答曰。不尔。无色是名破色。更无异法如灯灭更无法。以是故无有虚空相。复次是虚空法无。何以故。汝因色故。以无色处是虚空相。若尔者色未生时。则无虚空相。复次汝谓色是无常法虚空是有常法。色未有时应先有虚空法。以有常故。若色未有则无无色处。若无无色处则无虚空相。若无相则无法。以是故虚空但有名而无实。如虚空诸法亦如是。但有假名而无实。以是故诸菩萨知诸法如虚空。如响者。若深山狭谷中。若深绝涧中。若空大舍中。若语声。若打声从声有声名为响。无智人。谓为有人语声。智者心念。是声无人作。但以声触故更有声名为响。响事空能诳耳根。如人欲语时。口中风名忧陀那。还入至脐触脐响出。响出时触七处退。是名语言。如偈说

  风名忧檀那　　触脐而上去
  是风七处触　　项及龂齿唇
  舌咽及以胸　　是中语言生
  愚人不解此　　惑着起嗔痴
  中人有智慧　　不嗔亦不着
  亦复不愚痴　　但随诸法相
  曲直及屈申　　去来现语言
  都无有作者　　是事是幻耶
  为机关木人　　为是梦中事
  我为热气闷　　有是为无是
  是事谁能知　　是骨人筋缠
  能作是语声　　如融金投水

以是故言诸菩萨知诸法如响。如犍闼婆城者。日初出时见城门楼橹宫殿行人出入。日转高转灭。此城但可眼见而无有实。是名揵闼婆城。有人初不见揵闼婆城。晨朝东向见之。意谓实乐疾行趣之。转近转失日高转灭。饥渴闷极见热气如野马。谓之为水疾走趣之转近转灭。疲极困厄至穷山狭谷中。大唤啼哭闻有响应。谓有居民求之疲极而无所见。思惟自悟渴愿心息。无智人亦如是。空阴界入中见吾我及诸法。淫嗔心着。四方狂走求乐自满。颠倒欺诳穷极懊恼。若以智慧知无我无实法者。是时颠倒愿息。复次揵闼婆城非城。人心想为城。凡夫亦如是非身想为身非心想为心。问曰。一事可知何以多喻。答曰。我先已答。是摩诃衍如大海水。一切法尽摄。摩诃衍多因缘故。多譬喻无咎。复次是菩萨甚深利智故。种种法门种种因缘种种喻坏诸法。为人解故应多引喻。复次一切声闻法中无揵闼婆城喻。有种种余无常喻。色如聚沫受如泡想如野马。行如芭蕉识如幻及幻网。经中空譬喻。以是揵闼婆城喻异故。此中说。问曰。声闻法中以城喻身。此中何以说揵闼婆城喻。答曰。声闻法中城喻众缘实有。但城是假名。揵闼婆城众缘亦无。如旋火轮但惑人目。声闻法中为破吾我故以城为喻。此中菩萨利根深入诸法空中故。以揵闼婆城为喻。以是故。说如揵闼婆城。如梦者。如梦中无实事谓之有实。觉已知无而还自笑。人亦如是。诸结使眠中实无而着。得道觉时乃知无实亦复自笑。以是故言如梦。复次梦者眠力故无法而见。人亦如是。无明眠力故。种种无而见有。所谓我我所男女等。复次如梦中无喜事而喜。无嗔事而嗔。无怖事而怖。三界众生亦如是。无明眠故不应嗔而嗔。不应喜而喜。不应怖而怖。复次梦有五种。若身中不调。若热气多则多梦见火见黄见赤。若冷气多则多见水见白。若风气多则多见飞见黑。又复所闻见事。多思惟念故则梦见。或天与梦欲令知未来事故。是五种梦皆无实事而妄见。人亦如是。五道中众生。身见力因缘故。见四种我。色阴是我。色是我所。我中色色中我。如色受想行识亦如是。四五二十。得道实智慧觉已知无实。问曰。不应言梦无实。何以故识心得因缘。便生梦中识。有种种缘。若无此缘云何生识。答曰。无也不应见而见。梦中见人头有角。或梦见身飞虚空。人实无角身亦不飞。是故无实。问曰。实有人头余处亦实有角。以心惑故见人头有角。实有虚空亦实有飞者。以心惑故自见身飞非无实也。答曰。虽实有人头虽实有角。但人头生角者是妄见。问曰。世界广大先世因缘种种不同。或有余国人头生角。或一手一足有一尺人有九头人人有角何所怪。答曰。若余国人有角可尔。但梦见此国所识人有角则不可得。复次若人梦见虚空边方边时边。是事云何有实。何处无虚空无方无时。以是故梦中无而见有。汝先言无缘云何生识。虽无五尘缘。自思惟念力转故。法缘生。若人言有二头因语生想。梦中无而见有亦复如是。诸法亦尔。诸法虽无而可见可闻可知。如偈说

  如梦如幻　　如揵闼婆　　一切诸法
  亦复如是

以是故说诸菩萨知诸法如梦。如影者。影但可见而不可捉。诸法亦如是。眼情等见闻觉知实不可得。如偈说

  是实知慧　　四边叵捉　　如大火聚
  亦不可触　　法不可受　　亦不应受

复次如影映光则现不映则无。诸结烦恼遮正见光。则有我相法相影。复次如影人去则去人动则动人住则住。善恶业影亦如是。后世去时亦去。今世住时亦住。报不断故罪福熟时则出。如偈说

  空中亦逐去　　山石中亦逐
  地底亦随去　　海水中亦入
  处处常随逐　　业影不相离

以是故说诸法如影。复次如影空无。求实不可得。一切法亦如是空无有实。问曰。影空无有实是事不然。何以故。阿毗昙说。云何名色入。青黄赤白黑缥紫光明影等。及身业三种作色。是名可见色入。汝云何言无。复次实有影有因缘故。因为树缘为明。是二事合有影生。云何言无。若无影。余法因缘有者亦皆应无。复次是影色可见。长短大小粗细曲直形动影亦动。是事皆可见。以是故应有。答曰影实空无。汝言阿毗昙中说者。是释阿毗昙义人所作说。一种法门人不体其意。执以为实。如鞞婆沙中说。微尘至细不可破不可烧。是则常有。复有三世中法。未来中出至现在。从现在入过去。无所失。是则为常。又言诸有为法新新生灭不住。若尔者是则为断灭相。何以故。先有今无故。如是等种种异说违背佛语。不可以此为证影今异于色法。色法生必有香味触等。影则不尔是为非有。如瓶二根知眼根身根。影若有亦应二根知。而无是事以是故影非有实物。但是诳眼法。如捉火[火*曹]疾转成轮非实。影非有物若影是有物。应可破可灭。若形不灭影终不坏。以是故空。复次影属形不自在故空。虽空而心生眼见。以是故说诸法如影。如镜中像者。如镜中像非镜作非面作。非执镜者作。亦非自然作。亦非无因缘。何以非镜作。若面未到镜则无像。以是故非镜作。何以非面作。无镜则无像。何以非执镜者作。无镜无面则无像。何以非自然作。若未有镜未有面则无像。像待镜待面然后有。以是故非自然作。何以非无因缘。若无因缘应常有。若常有。若除镜除面亦应自出。以是故非无因缘。诸法亦如是非自作非彼作非共作非无因缘。云何非自作我不可得故。一切因生法不自在故。诸法属因缘故。是以非自作。亦非他作者。自无故他亦无。若他作则失罪福力。他作有二种。若善若不善。若善应与一切乐。若不善应与一切苦。若苦乐杂以何因缘故与乐。以何因缘故与苦。若共有二过故。自过他过。若无因缘生苦乐。人应常乐离一切苦。若无因缘。人不应作乐因除苦因。一切诸法必有因缘。愚痴故不知。譬如人从木求火从地求水从扇求风。如是等种种各有因缘。是苦乐和合因缘是苦乐和合因缘。生先世业因今世若好行若邪行缘。从是得苦乐。是苦乐种种因缘。以实求之无人作无人受。空五众作空五众受。无智人得乐淫心爱着。得苦生嗔恚。是乐灭时更求欲得。如小儿见镜中像心乐爱着爱着失已破镜求索。智人笑之。失乐更求亦复如是。亦为得道圣人所笑。以是故说诸法如镜中像。复次如镜中像。实空不生不灭诳惑凡人眼。一切诸法亦复如是。空无实不生不灭。诳惑凡夫人眼。问曰。镜中像从因缘生。有面有镜有持镜人有明。是事和合故像生。因是像生忧喜亦作因亦作果。云何言实空不生不灭。答曰。从因缘生不自在故空。若法实有。是亦不应从因缘生。何以故若因缘中。先有因缘则无所用。若因缘中。先无因缘亦无所用。譬如乳中若先有酪是乳非酪因。酪先有故。若先无酪如水中无酪。是乳亦非因。若无因而有酪者。水中何以不生酪。若乳是酪因缘。乳亦不自在。乳亦从因缘生乳从牛有。牛从水草生。如是无边皆有因缘。以是故因缘中。果不得言有。不得言无。不得言有无。不得言非有非无。诸法从因缘生无自性如镜中像。如偈说

  若法因缘生　　是法性实空
  若此法不空　　不从因缘有
  譬如镜中像　　非镜亦非面
  亦非持镜人　　非自非无因
  非有亦非无　　亦复非有无
  此语亦不受　　如是名中道

以是故说诸法如镜中像。如化者。十四变化心。初禅二欲界初禅。二禅三欲界初禅。二禅三禅四欲界初禅二禅三禅。四禅五欲界初禅二禅三禅四禅。是十四变化心。作八种变化。一者能作小乃至微尘。二者能作大乃至满虚空。三者能作轻乃至如鸿毛。四者能作自在能以大为小以长为短如是种种。五者能有主力。(有大力人无所下故言有主力)六者能远到。七者能动地。八者随意所欲尽能得。一身能作多身多身能作一。石壁皆过履水蹈虚手扪日月能转四大。地作水水作地火作风风作火石作金金作石是变化。复有四种。欲界药物宝物幻术能变化诸物。诸神通人神力故能变化诸物。天龙鬼神辈得生报力故。能变化诸物。色界生报修定力故。能变化诸物。如化人无生老病死。无苦无乐异于人生。以是故空无实。一切诸法亦如是皆无生住灭。以是故说诸法如化。复次化生无定物。但以心生便有所作皆无有实。人身亦如是本无所因。但从先世心生今世身。皆无有实。以是故说诸法如化。如变化心灭则化灭。诸法亦如是因缘灭果亦灭。不自在如化事。虽实空能令众生生忧苦嗔恚喜乐痴惑。诸法亦如是。虽空无实能令众生起欢喜嗔恚忧怖等。以是故。说诸法如化。复次如变化生法。无初无中无后。诸法亦如是。如变化生时无所从来。灭亦无所去。诸法亦如是。复次如变化相清净如虚空无所染着。不为罪福所污。诸法亦如是。如法性如如。如真际自然常净。譬如阎浮提四大河。一河有五百小河属。是水种种不净。入大海水中皆清净。问曰。不应言变化事空。何以故。变化心亦从修定得。从此心作种种变化。若人若法是化有因有果云何空。答曰。如影中已答。今当更答。此因缘虽有变化果空。如口言无所有。虽心生口言。不可以心口有故。所言无所有。便是有。若言有第二头第三手。虽从心口生。不可言有头有手。如佛说。观无生从有生得脱。依无为从有为得脱。虽观无生法无。而可作因缘。无为亦尔。变化虽空亦能生心因缘。譬如幻焰等九譬喻。虽无能生种种心。复次是化事于六因四缘中求不可得。是中六因四缘不相应故空。复次空不以不见为空。以其无实用故言空。以是故言诸法如化。问曰。若诸法十譬喻皆空无异者。何以但以十事为喻。不以山河石壁等为喻。答曰。诸法虽空而有分别。有难解空。有易解空。今以易解空喻难解空。复次诸法有二种。有心着处有心不着处。以心不着处解心着处。问曰。此十譬喻。何以是心不着处。答曰。是十事不久住易生易灭故。以是故是心不着处。复次有人知十喻诳惑耳目法。不知诸法空故。以此喻诸法。若有人于十譬喻中。心着不解种种难论以此为有。是十譬喻不为其用。应更为说余法门。问曰。若诸法都空不生不灭。是十譬喻等种种譬喻种种因缘论议。我已悉知为空。若诸法都空不应说是喻。若说是喻是为不空。答曰。我说空破诸法有。今所说者若说有先已破。若说无不应难。譬如执事比丘。高声举手唱言众皆寂静。是为以声遮声非求声也。以是故虽说诸法空不生不灭。愍念众生故。虽说非有也。以是故说诸法如化

【经】得无碍无所畏

【论】种种众界入因缘中。心无碍无尽无灭。是为无碍无所畏。问曰。如先说诸菩萨于无量众中无所畏。今何以更说无碍无所畏。答曰。先说无所畏因。今说无所畏果。于诸大众乃至菩萨众中。说法无尽论议无减心无疑难。已得无碍无所畏故。复次如先说于无量众中无所畏。不知以何等力故无畏。以是故更说无所畏以得无碍力故。问曰。若诸菩萨。亦有无碍无所畏。佛与菩萨有何等异。答曰。如我先说。诸菩萨自有无所畏力故。于诸法中无所畏。非佛无所畏。复次无碍法有二种。一者一切处二者非一切处。非一切处名如入一经书乃至百千经书中无碍。若入一众若入百千众中无所畏。诸菩萨亦如是。自智慧中无碍非佛智慧。如佛放钵时五百阿罗汉及弥勒等诸菩萨皆不能取。诸菩萨亦如是。自力中无碍。佛智慧力中有碍。以是故说诸菩萨得无碍无所畏

【经】悉知众生心行所趣。以微妙慧而度脱之。【论】问曰。云何悉知众生心行。答曰。知众生心种种法中处处行。如日光遍照。菩萨悉知众生心行有所趣向。而教之言。一切众生趣有二种。一者心常求乐。二者智慧分别能知好恶。汝莫随着心。当随智慧当自责心。汝无数劫来集诸杂业而无厌足。而但驰逐世乐不觉为苦。汝不见世间贪乐致患五道受生。皆心所为谁使尔者。汝如狂象蹈藉残害无所拘制。谁调汝者。若得善调则离世患。当知处胎不净。苦厄犹如地狱。既生在世老病死苦忧悲万端。若生天上。当复堕落三界无安。汝何以乐着。如是种种呵责其心誓不随。汝是为菩萨知众生心行。问曰。云何名以微妙慧而度脱之。是中云何名微妙慧。云何名粗智慧。答曰。世界巧慧是名粗智慧行。施戒定是名微妙慧。复次布施智是为粗慧。戒定智是名微妙慧。复次戒定智是为粗慧。禅定智是名微妙慧。复次禅定智是为粗慧。无猗禅定是名微妙慧。复次取诸法相是为粗慧。于诸法相不取不舍。是名微妙慧。复次破无明等诸烦恼。得诸法相。是名粗慧。入如法相者。譬如真金不损不失。亦如金刚不破不坏。又如虚空无染无著。是名微妙慧。如是等无量微妙慧。菩萨自得复教众生。以是故说诸菩萨悉知众生心行所趣。以微妙慧而度脱之

    大智度初品中意无碍释论第十二

【经】意无挂碍

【论】云何名意无挂碍。菩萨于一切怨亲非怨非亲人中等心无有碍。复次一切世界众生中。若来侵害心不恚恨。若种种恭敬亦不喜悦。如偈说

  诸佛菩萨　　心不爱着　　外道恶人
  心不憎恚

如是清净名为意无挂碍。复次于诸法中心无碍。问曰。是菩萨未得佛道。未得一切智。云何于诸法中心无碍。答曰。是菩萨得无量清净智慧故。于诸法中心无碍。问曰。诸菩萨未得佛道故。不应有无量智。有残结故。不应有清净智。答曰。是诸菩萨非三界中结业肉身。皆得法身自在过老病死。怜愍众生故。在世界中行为庄严佛土教化众生。已得自在欲成佛能成。问曰。如法身菩萨则与佛无异。何以名为菩萨。何以礼佛听法。若与佛异。云何有无量清净智。答曰。是菩萨虽为法身无老病死。与佛小异。譬如月十四日。众人生疑若满若不满。菩萨如是虽能作佛能说法。然未实成佛。佛如月十五日满足无疑。复次无量清净有二种。一者实有量。于不能量者。谓之无量。譬如海水如恒河沙等。人不能量名为无量。于诸佛菩萨非为无量。菩萨无量清净智亦复如是。于诸天人及声闻辟支佛所不能量。名为无量智。菩萨得无生道时诸结使断故。得清净智。问曰。若尔时已断诸结。成佛时复何所断。答曰。是清净有二种。一者得佛时除结都尽得实清净。二者菩萨舍肉身得法身时。断诸结清净。譬如一灯能除闇得有所作更有大灯倍复明了。佛及菩萨断诸结使亦复如是。菩萨所断虽曰已断。于佛所断犹为未尽。是名得无量清净智。故于诸法中意无挂碍

【经】大忍成就

【论】问曰。先已说等忍法忍。今何以故复说大忍成就。答曰。此二忍增长名为大忍。复次等忍在众生中一切能忍。柔顺法忍于深法中忍。此二忍增长。作证得无生忍。最后肉身悉见十方诸佛化现在前于空中坐。是名大忍成就。譬如声闻法中暖法增长名为顶法顶法增长名为忍法。更无异法增长为异。等忍大忍亦复如是。复次有二种忍。生忍法忍。生忍名众生中忍。如恒河沙劫等。众生种种加恶心不嗔恚。种种恭敬供养心不欢喜。复次观众生无初。若有初则无因缘。若有因缘则无初若无初亦应无后。何以故初后相待故。若无初后中亦应无。如是观时不堕常断二边。用安隐道观众生不生邪见。是名生忍。甚深法中心无挂碍是名法忍。问曰。何等甚深法。答曰。如先甚深法忍中说。复次甚深法者。于十二因缘中展转生果。因中非有果亦非无果。从是中出。是名甚深法。复次入三解脱门空无相无作。则得涅槃常乐故。是名甚深法。复次观一切法非空非不空非有相非无相非有作非无作。如是观中心亦不着。是名甚深法。如偈说

  因缘生法　　是名空相　　亦名假名
  亦名中道　　若法实有　　不应还无
  今无先有　　是名为断　　不常不断
  亦不有无　　心识处灭　　言说亦尽

于此深法信心无碍不悔不没。是名大忍成就

【经】如实巧度

【论】有外道法。虽度众生不如实度。何以故。种种邪见结使残故二乘虽有所度。不如所应度。何以故。无一切智方便心薄故。唯有菩萨能如实巧度。譬如渡师一人以浮囊草筏渡之。一人以方舟而渡。二渡之中相降悬殊。菩萨巧渡众生亦如是。复次譬如治病苦药针炙痛而得差。如有妙药名苏陀扇陀。病人眼见众病皆愈。除病虽同优劣法异。声闻菩萨教化度人亦复如是。苦行头陀初中后夜勤心坐禅。观苦而得道声闻教也。观诸法相无缚无解心得清净菩萨教也。如文殊师利本缘。文殊师利白佛。大德。昔我先世过无量阿僧祇劫。尔时有佛名师子音王。佛及众生寿十万亿那由他岁。佛以三乘而度众生。国名千光明。其国中诸树皆七宝成。树出无量清净法音空无相无作不生不灭无所有之音。众生闻之心解得道。时师子音王佛。初会说法九十九亿人得阿罗汉道。菩萨众亦复如是。是诸菩萨一切皆得无生法忍。入种种法门。见无量诸佛。恭敬供养能度无量无数众生。得无量陀罗尼门。能得无量种种三昧。初发心新入道门菩萨不可称数。是佛土无量庄严说不可尽。时佛教化已讫。入无余涅槃。法住六万岁。诸树法音亦不复出。尔时有二菩萨比丘。一名喜根二名胜意。是喜根法师。容仪质直不舍世法。亦不分别善恶。喜根弟子聪明乐法好闻深义。其师不赞少欲知足。不赞戒行头陀。但说诸法实相清净。语诸弟子一切诸法淫欲相嗔恚相愚痴相。此诸法相即是诸法实相无所挂碍。以是方便教诸弟子入一相智。时诸弟子于诸人中无嗔无悔心不悔故得生忍。得生忍故则得法忍。于实法中不动如山。胜意法师持戒清净。行十二头陀。得四禅四无色定。胜意诸弟子钝根。多求分别是净是不净。心即动转。胜意异时入聚落中。至喜根弟子家于坐处坐。赞说持戒少欲知足行头陀行闲处禅寂。訾毁喜根言。是人说法教人入邪见中。是说淫欲嗔恚愚痴无所挂碍相。是杂行人非纯清净。是弟子利根得法忍。问胜意言。大德。是淫欲法名何等相。答言。淫欲是烦恼相。问言。是淫欲烦恼在内耶在外耶。答言。是淫欲烦恼不在内不在外。若在内不应待外因缘生。若在外于我无事不应恼我。居士言。若淫欲非内非外非东西南北四维上下来。遍求实相不可得。是法即不生不灭。若无生灭相。空无所有。云何能作恼。胜意闻是语已。其心不悦不能加答。从座而起说如是言。喜根多诳众人着邪道中。是胜意菩萨未学音声陀罗尼。闻佛所说便欢喜。闻外道语便嗔恚。闻三不善则不欢悦。闻三善则大欢喜。闻说生死则忧闻涅槃则喜。从居士家至林树间入精舍中。语诸比丘。当知。喜根菩萨是人虚诳多令人入恶邪中。何以故。其言淫恚痴相。及一切诸法皆无碍相。是时喜根作是念。此人大嗔为恶业所覆当堕大罪。我今当为说甚深法。虽今无所得。为作后世佛道因缘。是时喜根集僧。一心说偈

  淫欲即是道　　恚痴亦如是
  如此三事中　　无量诸佛道
  若有人分别　　淫怒痴及道
  是人去佛远　　譬如天与地
  道及淫怒痴　　是一法平等
  若人闻怖畏　　去佛道甚远
  淫法不生灭　　不能令心恼
  若人计吾我　　淫将入恶道
  见有无法异　　是不离有无
  若知有无等　　超胜成佛道

说如是等七十余偈。时三万诸天子得无生法忍。万八千声闻人。不着一切法故。皆得解脱。是时胜意菩萨。身即陷入地狱受无量千万亿岁苦。出生人中七十四万世常被诽谤。无量劫中不闻佛名。是罪渐薄得闻佛法。出家为道而复舍戒。如是六万三千世常舍戒。无量世中作沙门。虽不舍戒诸根闇钝。是喜根菩萨于今东方。过十万亿佛土作佛。其土号宝严。佛号光踰日明王。文殊师利言。尔时胜意比丘我身是也。我观尔时受是无量苦。文殊师利复白佛。若有人求三乘道。不欲受诸苦者。不应破诸法相而怀嗔恚。佛问文殊师利。汝闻诸偈得何等利。答曰。我闻此偈得毕众苦。世世得利根智慧。能解深法巧说深义。于诸菩萨中最为第一。如是等名巧说诸法相。是名如实巧度

大智度论卷第六大智度初品中佛土愿释论第十三(卷第七)

        龙树菩萨造

        后秦龟兹国三藏法师鸠摩罗什奉　诏译

【经】愿受无量诸佛世界

【论】诸菩萨见诸佛世界无量严净发种种愿。有佛世界都无众苦。乃至无三恶之名者。菩萨见已自发愿言。我作佛时世界无众苦。乃至无三恶之名亦当如是。有佛世界七宝庄严。昼夜常有清净光明无有日月。便发愿言。我作佛时世界常有严净光明亦当如是。有佛世界一切众生皆行十善有大智慧。衣被饮食应念而至。便发愿言。我作佛时世界中众生衣被饮食亦当如是。有佛世界纯诸菩萨如佛色身三十二相光明彻照。乃至无有声闻辟支佛名亦无女人。一切皆行深妙佛道。游至十方教化一切。便发愿言。我作佛时世界中众生亦当如是。如是等无量佛世界种种严净愿皆得之。以是故名愿受无量诸佛世界。问曰。诸菩萨行业清净自得净报。何以要须立愿然后得之。譬如田家得谷岂复待愿。答曰。作福无愿无所摽。立愿为导御能有所成。譬如销金随师所作金无定也。如佛所说有人修少施福修少戒福不知禅法。闻人中有富乐人心常念着。愿乐不舍。命终之后生富乐人中。复有人修少施福修少戒福不知禅法。闻有四天王天处三十三天夜摩天兜率陀天化乐天(专念色欲化来从己)他化自在天。(此天他化色欲与之行欲展转如是故名他化自在)心常愿乐命终之后各生其中。此皆愿力所得。菩萨亦如是。修净世界愿然后得之。以是故知因愿受胜果。复次庄严佛世界事大。独行功德不能成故要须愿力。譬如牛力虽能挽车。要须御者能有所至。净世界愿亦复如是。福德如牛愿如御者。问曰。若不作愿不得福耶。答曰。虽得不如有愿。愿能助福常念所行福德增长。问曰。若作愿得报。如人作十恶不愿地狱。亦不应得地狱报。答曰。罪福虽有定报。但作愿者修少福有愿力故得大果报。如先说罪中报苦。一切众生皆愿得乐无愿苦者。是故不愿地狱。以是故福有无量报。罪报有量。有人言。最大罪在阿鼻地狱。一劫受报。最大福在非有想非无想处。受八万大劫报。诸菩萨净世界愿。亦无量劫入道得涅槃。是为常乐。问曰。如泥黎品中谤般若波罗蜜罪。此间劫尽复至他方泥黎中。何以言最大罪受地狱中一劫报。答曰。佛法为众生故有二道教化。一者佛道二者声闻道。声闻道中作五逆罪人。佛说受地狱一劫。菩萨道中破佛法人。说此间劫尽复至他方受无量罪。声闻法最第一福。受八万劫。菩萨道中大福。受无量阿僧祇劫。以是故福德要须愿。是名愿受无量诸佛世界

【经】念无量佛土诸佛三昧常现在前

【论】无量佛土名十方诸佛土。念佛三昧名十方三世诸佛。常以心眼见如现在前。问曰。云何为念佛三昧。答曰。念佛三昧有二种。一者声闻法中。于一佛身心眼见满十方。二者菩萨道于无量佛土中。念三世十方诸佛。以是故言念无量佛土诸佛三昧常现在前。问曰。如菩萨三昧种种无量。何以故。但赞是菩萨念佛三昧常现在前。答曰。是菩萨念佛故。得入佛道中。以是故念佛三昧常现在前。复次念佛三昧。能除种种烦恼及先世罪。余诸三昧有能除淫。不能除嗔有能除嗔不能除淫。有能除痴不能除淫恚。有能除三毒。不能除先世罪。是念佛三昧能除种种烦恼种种罪。复次念佛三昧有大福德能度众生。是诸菩萨欲度众生。诸余三昧无如此念佛三昧福德能速灭诸罪者。如说。昔有五百估客入海采宝。值摩伽罗鱼王开口。海水入中船去駃疾。船师问楼上人。汝见何等。答言。见三日出白山罗列。水流奔趣如入大坑。船师言。是摩伽罗鱼王开口。一是实日两日是鱼眼。白山是鱼齿。水流奔趣。是入其口。我曹了矣。各各求诸天神以自救济。是时诸人各各求其所事都无所益。中有五戒优婆塞语众人言。吾等当共称南无佛。佛为无上能救苦厄。众人一心同声称南无佛。是鱼先世是佛破戒弟子。得宿命智。闻称佛声心自悔悟。即便合口。船人得脱。以念佛故。能除重罪济诸苦厄。何况念佛三昧

复次佛为法王菩萨为法将。所尊所重唯佛世尊。是故应常念佛。复次常念佛得种种功德利。譬如大臣特蒙恩宠常念其主。菩萨亦如是。知种种功德无量智慧皆从佛得。知恩重故常念佛。汝言云何常念佛不行余三昧者。今言常念亦不言不行余三昧。行念佛三昧多故言常念。复次先虽说空无相无作三昧。未说念佛三昧。是故今说

【经】能请无量诸佛

【论】请有二种。一者佛初成道。菩萨夜三昼三六时礼请。偏袒右肩合掌言。十方佛土无量诸佛初成道时未转法轮。我某甲请一切诸佛。为众生转法轮度脱一切。二者诸佛欲舍无量寿命入涅槃时。菩萨亦夜三时昼三时。偏袒右肩合掌言。十方佛土无量诸佛。我某甲请令久住世间无央数劫。度脱一切利益众生。是名能请无量诸佛。问曰。诸佛之法法应说法广度众生。请与不请法自应尔。何以须请。若于自前面请诸佛则可。今十方无量佛土诸佛亦不自见。云何可请。答曰。诸佛虽必应说法不待人请。请者亦应得福。如大国王虽多美膳有人请者必得恩福。录其心故。又如慈心念诸众生令得快乐。众生虽无所得。念者大得其福。请佛说法亦复如是。复次有诸佛无人请者。便入涅槃而不说法。如法华经中多宝世尊。无人请故便入涅槃。后化佛身及七宝塔。证说法华经故。一时出现。亦如须扇多佛。弟子本行未熟便舍入涅槃。留化佛一劫以度众生。今是释迦文尼佛。得道后五十七日寂不说法。自言我法甚深难解难知。一切众生缚着世法无能解者。不如默然入涅槃乐。是时诸菩萨及释提桓因梵天王诸天合掌敬礼。请佛为诸众生初转法轮。佛时默然受请。后到波罗奈鹿林中转法轮。如是云何言请无所益。复次佛法等观众生。无贵无贱无轻无重。有人请者。为其请故便为说法。虽众生不面请佛。佛常见其心亦闻彼请。假令诸佛不闻不见。请佛亦有福德。何况佛悉闻见而无所益。问曰。既知请佛有益。何以正以二事请。答曰。余不须请。此二事要必须请。若不请而说。有外道辈言。体道常定何以着法多言多事。以是故须请而说。若有人言若知诸法相不应贪寿。久住世间而不早入涅槃。以是故须请。若不请而说。人当谓佛爱着于法欲令人知。以是故要待人请而转法轮。诸外道辈自着于法。若请若不请而自为人说。佛于诸法不着不爱。为怜愍众生故。有请佛说者佛便为说。诸佛不以无请而初转法轮。如偈说

  诸佛说何实　　何者是不实
  实之与不实　　二事不可得
  如是真实相　　不戏于诸法
  怜愍众生故　　方便转法轮

复次佛若无请而自说法者。是为自显自执法。应必答十四难。今诸天请佛说法。但为断老病死无戏论处。是故不答十四难无咎。以是因缘故须请而转法轮。复次佛在人中生。用大人法故。虽有大悲不请不说。若不请而说。外道所讥。以是故初要须请。又复外道宗事梵天。梵天自请则外道心伏。复次菩萨法。昼三时夜三时常行三事。一者清旦偏袒右肩合掌礼十方佛言。我某甲。若今世若过世无量劫。身口意恶业罪。于十方现在佛前忏悔。愿令灭除不复更作。中暮夜三亦如是。二者念十方三世诸佛所行功德及弟子众所有功德。随喜劝助。三者劝请现在十方诸佛初转法轮。及请诸佛久住世间无量劫度脱一切。菩萨行此三事功德无量转近得佛。以是故须请

【经】能断种种见缠及诸烦恼

【论】见有二种。一者常二者断。常见者见五众常心忍乐。断见者见五众灭心忍乐。一切众生多堕此二见中。菩萨自断此二。亦能除一切众生二见令处中道。复有二种见。有见无见。复有三种见。一切法忍一切法不忍一切法亦忍亦不忍。复有四种见。世间常世间无常世间亦常亦无常世间亦非常亦非无常。我及世间有边无边亦如是。有死后如去。有死后不如去。有死后如去不如去。有死后亦不如去亦不不如去。复有五种见。身见边见邪见见取戒取。如是等种种诸见。乃至六十二见断。如是诸见种种因缘生。种种智门观。种种师边闻。如是种种相能为种种结使作因。能与众生种种苦。是名种种见。见义后当广说。缠者十缠。嗔缠覆罪缠睡缠眠缠戏缠掉缠无惭缠无愧缠悭缠嫉缠。复次一切烦恼结绕心故。尽名为缠。烦恼者能令心烦能作恼故。名为烦恼。烦恼有二种。内着外着。内著者五见疑慢等。外著者淫嗔等。无明内外共。复有二种结。一属爱二属见。复有三种属淫属嗔属痴。是名烦恼。缠者有人言十缠。有人言五百缠。烦恼名一切结使。结有九结。使有七。合为九十八结。如迦旃延子阿毗昙义中说。十缠九十八结为百八烦恼。犊子儿阿毗昙中结使亦同。缠有五百。如是诸烦恼。菩萨能种种方便自断。亦能巧方便断他人诸烦恼。如佛在时三人。为伯仲季。闻毗耶离国淫女人。名庵罗婆利。舍婆提有淫女人。名须曼那。王舍城淫女人。名优钵罗槃那。有三人各各闻人赞三女人端正无比。昼夜专念心着不舍。便于梦中梦与从事。觉已心念。彼女不来我亦不往而淫事得办。因是而悟。一切诸法皆如是耶。于是往到颰陀婆罗菩萨所问是事。颰陀婆罗答言。诸法实尔。皆从念生。如是种种。为此三人方便巧说诸法空。是时三人即得阿鞞跋致。是诸菩萨亦复如是。为诸众生种种巧说法。断诸见缠烦恼。是名能断种种见缠及诸烦恼

【经】游戏出生百千三昧

【论】诸菩萨禅定心调。清净智慧方便力故。能生种种诸三昧何等为三昧。善心一处住不动。是名三昧。复有三种三昧。有觉有观无觉有观无觉无观三昧。复有四种三昧。欲界系三昧色界系三昧无色界系三昧不系三昧。是中所用菩萨三昧如先说。于佛三昧中未满。勤行勤修故。言能出生。问曰。诸菩萨何以故。出生游戏是百千种三昧。答曰。众生无量心行不同有利有钝。于诸结使有厚有薄。是故菩萨行百千种三昧。断其尘劳。譬如为诸贫人欲令大富。当备种种财物。一切备具。然后乃能济诸贫者。又复如人欲广治诸病。当备种种众药。然后能治。菩萨亦如是。欲广度众生故。行种种百千三昧。问曰。但当出生此三昧。何以故复游戏其中。答曰。菩萨心生诸三昧。欣乐出入自在。名之为戏。非结爱戏也。戏名自在。如师子在鹿中自在无畏。故名为戏。是诸菩萨于诸三昧有自在力能出能入亦能如是。余人于三昧中能自在入。不能自在住自在出。有自在住。不能自在入自在出。有自在出。不能自在住自在入。有自在入自在住。不能自在出。有自在住自在出。不能自在入。是诸菩萨能三种自在故。言游戏出生百千三昧

【经】诸菩萨如是等无量功德成就

【论】是诸菩萨共佛住。欲赞其功德无量亿劫不可得尽。以是故言无量功德成就

【经】其名曰颰陀婆罗菩萨。(秦言善守)剌那伽罗菩萨。(秦言宝积)导师菩萨。那罗达菩萨。星得菩萨。水天菩萨。主天菩萨。大意菩萨。益意菩萨。增意菩萨。不虚见菩萨。善进菩萨。势胜菩萨。常勤菩萨。不舍精进菩萨。日藏菩萨。不缺意菩萨。观世音菩萨。文殊尸利菩萨。(秦言妙德)执宝印菩萨。常举手菩萨。弥勒菩萨。如是等无量千万亿那由他诸菩萨摩诃萨。皆是补处绍尊位者

【论】如是等诸菩萨。共佛住王舍城耆阇崛山中。问曰。如是菩萨众多。何以独说二十二菩萨名。答曰。诸菩萨无量千万亿说不可尽。若都说者。文字所不能载。复次是中二种菩萨。居家出家。善守等十六菩萨。是居家菩萨。颰陀婆罗居士菩萨。是王舍城旧人。宝积王子菩萨。是毗耶离国人。星得长者子菩萨。是瞻波国人。导师居士菩萨。是舍婆提国人。那罗达婆罗门菩萨。是弥梯罗国人。水天优婆塞菩萨慈氏妙德菩萨等。是出家菩萨。观世音菩萨等从他方佛土来。若说居家。摄一切居家菩萨。出家他方亦如是。问曰。善守菩萨有何殊胜。最在前说。若最大在前。应说遍吉观世音得大势菩萨等。若最小在前。应说肉身初发意菩萨等。答曰。不以大不以小。以善守菩萨是王舍城旧人。白衣菩萨中最大。佛在王舍城。欲说般若波罗蜜。以是故最在前说。复次是善守菩萨。无量种种功德。如般舟三昧中。佛自现前赞其功德。问曰。若弥勒菩萨应称补处。诸余菩萨何以复言绍尊位者。答曰。是诸菩萨。于十方佛土皆补佛处

    大智度初品中放光释论第十四

【经】尔时世尊自敷师子座。结加趺坐。直身系念在前。入三昧王三昧。一切三昧悉入其中

【论】问曰。佛有侍者及诸菩萨。何以故自敷师子座。答曰。此是佛所化成。欲以可适大众。以是故阿难不能得敷。复次佛心化作。故言自敷。问曰。何以名师子座。为佛化作师子。为实师子来。为金银木石作师子耶。又师子非善兽故。佛所不须。亦无因缘故不应来。答曰。是号名师子非实师子也。佛为人中师子。佛所坐处若床若地皆名师子座。譬如今者国王坐处亦名师子座。复次王呼健人。亦名人师子。人称国王亦名人师子。又如师子四足兽中独步无畏。能伏一切。佛亦如是。于九十六种道中。一切降伏无畏故。名人师子。问曰。多有坐法。佛何以故唯用结加趺坐。答曰。诸坐法中结加趺坐最安隐不疲极。此是坐禅人坐法。摄持手足心亦不散。又于一切四种身仪中最安隐。此是禅坐取道法坐。魔王见之其心忧怖。如是坐者出家人法。在林树下结加趺坐。众人见之皆大欢喜。知此道人必当取道。如偈说

  若结加趺坐　　身安入三昧
  威德人敬仰　　如日照天下
  除睡懒覆心　　身轻不疲懈
  觉悟亦轻便　　安坐如龙蟠
  见画加趺坐　　魔王亦愁怖
  何况入道人　　安坐不倾动

以是故结加趺坐。复次佛教弟子。应如是坐。有外道辈。或常翘足求道。或常立。或荷足。如是狂狷心没邪海形不安隐。以是故佛教弟子。结加趺直身坐。何以故。直身心易正故。其身直坐则心不懒。端心正意系念在前。若心驰散摄之令还。欲入三昧故。种种驰念皆亦摄之。如此系念入三昧王三昧。云何名三昧王三昧。是三昧于诸三昧中最第一自在能缘无量诸法。如诸人中王第一。王中转轮圣王第一。一切天上天下佛第一。此三昧亦如是。于诸三昧中最第一。问曰。若以佛力故。一切三昧皆应第一。何以故独称三昧王为第一。答曰。虽应以佛神力故佛所行诸三昧皆第一。然诸法中应有差降。如转轮圣王众宝。虽胜一切诸王宝。然此珍宝中自有差别贵贱悬殊。是三昧王三昧。何定摄何等相。有人言。三昧王三昧名为自在相。善五众摄。在第四禅中。何以故。一切诸佛于第四禅中。行见谛道得阿那含。即时十八心中得佛道。在第四禅中舍寿。于第四禅中起入无余涅槃。第四禅中有八生住处背舍胜处。一切入多在第四禅中。第四禅名不动。无遮禅定法。欲界中诸欲遮禅定心。初禅中觉观心动。二禅中大喜动。三禅中大乐动。四禅中无动。复次初禅火所烧。二禅水所及。三禅风所至。四禅无此三患。无出入息舍念清净。以是故三昧王三昧。应在第四禅中。如好宝物置之好藏。更有人言。佛三昧谁能知其相。一切诸佛法。一相无相无量无数不可思议。诸余三昧尚不可量不可数不可思议。何况三昧王三昧。如此三昧唯佛能知。如佛神足持戒尚不可知。何况三昧王三昧。复次三昧王三昧诸一切三昧皆入其中。故名三昧王三昧。譬如阎浮提众川万流皆入大海。亦如一切民人皆属国王。问曰。佛一切智无所不知。何以故入此三昧王三昧。然后能知。答曰。欲明智慧从因缘生故。止外道六师辈言我等智慧一切时常有常知故。以是故言佛入三昧王三昧故知。不入则不知。问曰。若如是者佛力减劣。答曰。入是三昧王三昧时不以为难。应念即得。非如声闻辟支佛诸小菩萨方便求入。复次入是三昧王三昧中。令六神通通彻十方无限无量。复次佛入三昧王三昧。种种变化现大神力。若不入三昧王三昧而现神力者。有人心念。佛用幻力咒术力。或是大力龙神力。或是天非是人。何以故。一身出无量身。种种光明变化故。谓为非人。断此疑故佛入三昧王三昧。复次佛若入余三昧中。诸天声闻辟支佛或能测知。虽言佛神力大而犹可知。敬心不重。以是故入三昧王三昧中。一切诸众圣乃至十住菩萨不能测知。不知佛心何所依何所缘。以是故佛入三昧王三昧。复次佛有时放大光明现大神力。如生时得道时初转法轮时诸天圣人大集会时若破外道时。皆放大光明。今欲现其殊特故。放大光明令十方一切天人众生及诸阿罗汉辟支佛菩萨皆得见知以是故入三昧王三昧。复次光明神力有下中上。咒术幻术能作光明变化下也。诸天龙神报得光明神力中也。入诸三昧。以今世功德心力。放大光明现大神力上也。以是故佛入三昧王三昧。问曰。如诸三昧各各相。云何一切三昧悉入其中。答曰。得是三昧王三昧时。一切三昧悉得故。言悉入其中。是三昧力故。一切诸三昧皆得无量无数不可思议。以是故名为入。复次入是三昧王三昧中。一切三昧欲入即入。复次入是三昧王三昧。能观一切三昧相。如山上观下。复次佛入是三昧王三昧中。能观一切十方世界。亦能观一切众生。以是故入三昧王三昧

【经】尔时世尊从三昧安庠而起。以天眼观视世界举身微笑

【论】问曰。云何世尊入三昧王三昧。无所施作而从定起观视世界。答曰。佛入是三昧王三昧。一切佛法宝藏悉开悉看。是三昧王三昧中观已自念。我此法藏无量无数不可思议。然后从三昧安庠而起。以天眼观众生。知众生贫苦。此法藏者从因缘得。一切众生皆亦可得。但坐痴冥不求不索。以是故举身微笑。问曰。佛有佛眼慧眼法眼胜于天眼。何以用天眼观视世界。答曰。肉眼所见不遍故。慧眼知诸法实相。法眼见是人以何方便行何法得道。佛眼名一切法现前了了知。今天眼缘世界及众生无障无碍。余眼不尔。慧眼法眼佛眼虽胜。非见众生法。欲见众生唯以二眼。肉眼天眼。以肉眼不遍有所障故。用天眼观。问曰。今是眼在佛。何以名为天眼。答曰。此眼多在天中。天眼所见不碍山壁树木。若人精进持戒禅定行力得。非是生分。以是故名为天眼。复次人多贵天以天为主。佛随人心。以是故名为天眼。复次天有三种。名天生天净天。名天天王天子是也。生天释梵诸天是也。净天佛辟支佛阿罗汉是也。净天中尊者是佛。今言天眼亦无咎也。天眼观视世界者。以世界众生常求安乐而更得苦心着吾我。是中实无吾我。众生常畏苦而常行苦。如盲人求好道反堕深坑。如是等种种观已举身微笑。问曰。笑从口生或时眼笑。今云何言一切身笑。答曰。佛世界中尊得自在。能令一切身如口如眼故。皆能笑。复次一切毛孔皆开故名为笑。由口笑欢喜故。一切毛孔皆开。问曰。佛至尊重何以故笑。答曰。如大地不以无事及小因缘而动。佛亦如是。若无事及小因缘则不笑。今大因缘故一切身笑。云何为大。佛欲说摩诃般若波罗蜜。无央数众生当续佛种。是为大因缘。复次佛言。我世世曾作小虫恶人。渐渐集诸善本。得大智慧。今自致作佛。神力无量最上最大。一切众生亦可得尔。云何空受勤苦而堕小处。以是故笑。复次有小因大果小缘大报。如求佛道赞一偈一称南无佛烧一捻香。必得作佛。何况闻知诸法实不生不灭不不生不不灭。而行因缘业亦不失。以是事故笑。复次般若波罗蜜相清净如虚空。不可与不可取。佛种种方便光明神德。欲教化一切众生令心调柔。然后能信受般若波罗蜜。以是故因笑放光。笑有种种因缘。有人欢喜而笑。有人嗔恚而笑。有轻人而笑。有见异事而笑。有见可羞耻事而笑。有见殊方异俗而笑。有见希有难事而笑。今是第一希有难事。诸法相不生不灭。真空无字无名无言无说。而欲作名立字为众生说令得解脱。是第一难事。譬如百由旬大火聚有人负干草入火中过不烧一叶。是甚为难。佛亦如是。持八万法众名字草。入诸法实相中。不为染着火所烧。直过无碍。是为甚难。以是难事故笑。如是种种希有难事故。举身微笑

【经】从足下千辐相轮中放六百万亿光明

【论】问曰。佛何以故先放身光。答曰。上笑因缘中已答。今当更说。有人见佛无量身放大光明。心信清净恭敬故。知非常人。复次佛欲现智慧。光明神相故。先出身光。众生知佛身光既现。智慧光明亦应当出。复次一切众生常着欲乐。五欲中第一者色。见此妙光心必爱着。舍本所乐令其心渐离欲。然后为说智慧。问曰。其余天人亦能放光。佛放光明有何等异。答曰。诸天人虽能放光有限有量。日月所照唯四天下。佛放光明满三千大千世界。三千大千世界中出。遍至下方。余人光明唯能令人欢喜而已。佛放光明能令一切闻法得度。以是为异。问曰。如一身中。头为最上。何以故先从足下放光。答曰。身得住处皆由于足。复次一身中虽头贵而足贱。佛不自贵光不为利养。以是故于贱处放光。复次诸龙大蛇鬼神从口中出光。毒害前物。若佛口放光明众生怖畏。是何大光。复恐被害。是故从足下放光。问曰。足下六百万亿光明。乃至肉髻是皆可数。三千大千世界尚不可满。何况十方。答曰。此身光是诸光之本。从本枝流无量无数。譬如迦罗求罗虫。其身微细得风转大。乃至能吞食一切。光明亦如是。得可度众生转增无限

【经】足十指两踝两[跳-兆+尃]两膝两髀腰脊腹背脐心胸德字肩臂手十指项口四十齿鼻两孔两眼两耳白毫相肉髻。各各放六百万亿光明

【论】问曰。足下光明。能照三千大千及十方世界。何用身分各各放六百万亿光明。答曰。我先言足下光明照下方余方不满。是故更放身分光明。有人言。一切身分足为立处故最大。余不尔。是故佛初放足下六百万亿光明以示众生。如三十二相中初种足下安住相。一切身分皆有神力。问曰。依何三昧。依何神通。何禅定中。放此光明。答曰。三昧王三昧中放此光明。六通中如意通。四禅中第四禅。放此光明。第四禅中火胜处火。一切入此中放光明。复次佛初生时初成佛时初转法轮时。皆放无量光明满十方。何况说摩诃般若波罗蜜时而不放光。譬如转轮圣王珠宝。常有光明照王军众四边各一由旬。佛亦如是。众生缘故。若不入三昧恒放常光。何以故。佛众法宝成故

【经】从是诸光出大光明。遍照三千大千世界。从三千大千世界遍照东方如恒河沙等诸世界。南西北方四维上下亦复如是。若有众生遇斯光者。必得阿耨多罗三藐三菩提。【论】问曰。如火相上焰水相下润风相傍行。是光明火气应当上去。云何遍满三千大千世界及十方世界。答曰。光明有二种。一者火气。二者水气。日珠火气月珠水气。火相虽焰上。而人身中火上下遍到。日火亦尔。是故夏月地水尽热。以是故知火不皆上。复次是光明佛力故。遍至十方。譬如强弓遣箭随所向至。问曰。何以先照东方。南西北后。答曰。以日出东方为上故。佛随众生意先照东方。复次俱有一难。若先照南方。当言何以不先照东西北方。若先照西方北方亦尔。问曰。光明几时当灭。答曰。佛用神力欲住便住。舍神力便灭。佛光如灯神力如脂。若佛不舍神力光不灭也

【经】光明出过东方如恒河沙等世界。乃至十方亦复如是

【论】问曰。云何为三千大千世界。答曰。佛杂阿含中分别说。千日千月千阎浮提千衢陀尼千郁怛罗越千弗婆提千须弥山千四天王天处千三十三天千夜摩天千兜率陀天千化自在天千他化自在天千梵世天千大梵天。是名小千世界。名周利。以周利千世界为一。一数至千名二千中世界。以二千中世界为一。一数至千名三千大千世界。初千小二千中第三名大千。千千重数故名大千。二过复千故言三千。是合集名百亿日月乃至百亿大梵天。是名三千大千世界。是一时生一时灭。有人言。住时一劫灭时一劫还生时一劫。是三千大千世界。大劫亦三种破。水火风。小劫亦三种破。刀病饥。此三千大千世界。在虚空中。风上水水上地地上人。须弥山有二天处。四天处三十三天处。余残夜摩天等。福德因缘七宝地。风举空中乃至大梵天皆七宝地皆在风上。是三千大千世界光明遍照。照竟余光过出。照东方如恒河沙等诸世界南西北方四维上下亦复如是。问曰。是光远照云何不灭。答曰。光明以佛神力为本。本在故不灭。譬如龙泉。龙力故水不竭。是诸光明以佛心力故。遍照十方中间不灭。问曰。如阎浮提中种种大河。亦有过恒河者。何以常言恒河沙等。答曰。恒河沙多。余河不尔。复次是恒河是佛生处游行处。弟子眼见故以为喻。复次佛出阎浮提。阎浮提四大河北边出。入四方大海中。北边雪山中。有阿那婆达多池。是池中有金色七宝莲华。大如车盖。阿那婆达多龙王。是七住大菩萨。是池四边有四流水。东方象头南方牛头西方马头北方师子头。东方象头出恒河。底有金沙。南方牛头出辛头河。底亦有金沙。西方马头出婆叉河。底亦有金沙。北方师子头出私陀河。底亦有金沙。是四河皆出北山。恒河出北山入东海。辛头河出北山入南海。婆叉河出北山入西海。私陀河出北山入北海。是四河中恒河最大。四远诸人经书。皆以恒河为福德吉河。若入中洗者诸罪垢恶皆悉除尽。以人敬事此河皆共识知故以恒河沙为喻。复次余河名字喜转。此恒河世世不转。以是故以恒河沙为喻。不取余河。问曰。恒河中沙为有几许。答曰。一切算数所不能知。唯有佛及法身菩萨能知其数。佛及法身菩萨。一切阎浮提中。微尘生灭多少皆能数知。何况恒河沙。如佛在只桓外林中树下坐。有一婆罗门来到佛所。问佛。此树林有几叶。佛即时便答有若干数。婆罗门心疑谁证知者。婆罗门去至一树边。取一树上少叶藏。还问佛。此树林定有几叶。即答今少若干叶。如其所取语之。婆罗门知已心大敬信。求佛出家后得阿罗汉道。以是故知。佛能知恒河沙数。问曰。有几许人。值佛光明必得阿耨多罗三藐三菩提。若值光明便得道者。佛有大慈。何以不常放光明令一切得道。何须持戒禅定智慧。然后得道。答曰。众生种种因缘得度不同。有禅定得度者。有持戒说法得度者。有光明触身而得度者。譬如城有多门。入处各各至处不异。有人光明触身而得度者。有若见光明若触身不得度者

【经】尔时世尊举身毛孔皆亦微笑。而放光明遍照三千大千世界。复至十方如恒河沙等世界。若有众生遇斯光者。必得阿耨多罗三藐三菩提

【论】问曰。上已举身微笑。今何以故复一切毛孔皆笑。答曰。举身微笑是粗分。今一切毛孔皆笑是细分。复次先举身微笑光明有数。今一切毛孔皆笑。有光明而无数。复次先举身光明。所未度者。今值毛孔光明。即便得度。譬如摇树取果。熟者前堕。若未熟者。更须后摇。又如捕鱼前网不尽后网乃得。笑因缘如上说

大智度论卷第七大智度初品中放光释论第十四之余(卷第八)

        龙树菩萨造

        后秦龟兹国三藏法师鸠摩罗什奉　诏译

【经】尔时世尊以常光明遍照三千大千世界。亦至东方如恒河沙等诸佛世界。乃至十方亦复如是。若有众生遇斯光者必得阿耨多罗三藐三菩提

【论】问曰。上已举身微笑及放毛孔光明。今何以复放常光而照十方。答曰。有人见异光明谓非佛光。见佛常光转大心则欢喜。此实佛光。便毕至阿耨多罗三藐三菩提。问曰。云何为常光。答曰。佛身四边各一丈光明。菩萨生便有此。是三十二相之一。名为丈光相。问曰。佛何以故光常一丈而不多。答曰。一切诸佛常光无量。常照十方世界。释迦牟尼佛神通身光无量。或一丈百丈千万亿。乃至满三千大千世界。乃至十方。如诸佛常法。但于五浊世为众生少德少智故。受一丈光明。若受多光。今众生薄福钝根。目不堪其明。如人见天身眼则失明。以光盛眼微故。若众生利根福重。佛则为之现无量光明。复次有人见佛常光欢喜得度。譬如国王以常食之余。赐诸群下。得者大喜。佛亦如是有人见佛种种余光心不欢喜。见佛常光必至阿耨多罗三藐三菩提

【经】尔时世尊出广长舌相。遍覆三千大千世界。熙怡而笑。从其舌根出无量千万亿光是一一光化成千叶金色宝华。是诸华上皆有化佛结加趺坐。说六波罗蜜。众生闻者必得阿耨多罗三藐三菩提。复至十方如恒河沙等诸佛世界皆亦如是

【论】问曰。如佛世尊大德尊重。何以故。出广长舌似如轻相。答曰。上三种放光。照十方众生令得度脱。今欲口说摩诃般若波罗蜜。摩诃般若波罗蜜甚深难解难知难可信受。是故出广长舌为证。舌相如是语必真实。如昔一时佛于舍婆提国受岁竟。阿难从佛游行诸国。欲到婆罗门城。婆罗门城王。知佛神德能化众人感动群心。今来到此谁复乐我便作制限若有与佛食听佛语者。输五百金钱。作制限后佛到其国。将阿难持钵入城乞食。城中众人皆闭门不应。佛空钵而出。是时一家有一老使人。持破瓦器盛臭[泳-永+(米*番)]淀出门弃之。见佛世尊空钵而来。老使人见佛相好金色白毛肉髻丈光钵空无食。见已思惟。如此神人应食天厨。今自降身持钵行乞。必是大慈愍一切故。信心清净欲好供养无由如愿。惭愧白佛。思欲设供更不能得。今此弊食佛须者可取。佛知其心信敬清净。伸手以钵受其施食。佛时即笑出五色光普照天地。还从眉间相入。阿难合掌长跪白佛。唯然世尊。今笑因缘愿闻其意

佛告阿难。汝见老女人信心施佛食不。阿难言见。佛言。是老女人施佛食故。十五劫中天上人间受福快乐不堕恶道。后得男子身出家学道。成辟支佛入无余涅槃。尔时佛边有一婆罗门。立说偈言

  汝是日种刹利姓　　净饭国王之太子
  而以食故大妄语　　如此臭食报何重

是时佛出广长舌覆面上至发际。语婆罗门言。汝见经书。颇有如此舌人而作妄语不。婆罗门言。若人舌能覆鼻言无虚妄。何况乃至发际。我心信佛必不妄语。不解小施报多如是。佛告婆罗门。汝颇曾见世所希有难见事不。婆罗门言见。我曾共婆罗门道中行。见一尼拘卢陀树荫覆贾客五百乘车。荫犹不尽。是谓希有难见事也。佛言。此树种子其形大小。答言。大如芥子三分之一。佛言。谁当信汝言者。树大乃尔而种子甚小。婆罗门言。实尔世尊。我眼见之非虚妄也。佛言。我亦如是。见老女人净信心施佛得大果报亦如此。树因少报多。又是如来福田良美之所致也。婆罗门心开意解。五体投地悔过向佛。我心无状愚不信佛。佛为种种说法。得初道果。即时举手大发声言。一切众人甘露门开如何不出。城中一切诸婆罗门。皆送五百金钱。与王迎佛供养。皆言得甘露味。谁当惜此五百金钱。众人皆去制限法破。是婆罗门王。亦共臣民归命佛法。城人一切皆得净信。如是佛出广长舌相。为不信者故。问曰。如为婆罗门出舌相覆面。今舌相光明。何以乃至三千大千世界。答曰。覆面发际。为小信故。今为般若波罗蜜大事兴故。广长舌相覆三千大千世界。问曰。是一城中人。尽得见此覆面舌相犹尚为难。何况今说摩诃般若波罗蜜。一切大会此及他方无量众集而得尽见。又以人目所睹不过数里。今言遍三千大千世界。无乃大而难信。答曰。佛以方便借其神力。能令一切皆见舌相覆此三千大千世界。若不加神力。虽复十住亦不知佛心。若加神力乃至畜生能知佛心。如般若波罗蜜后品中说。一切众人皆见阿閦佛会。与眼作对。亦如佛说阿弥陀佛世界种种严净。阿难言。唯愿欲见。佛时即令一切众会皆见无量寿佛世界严净。见佛舌相亦复如是。佛以广长舌相。遍覆三千大千世界已。然后便笑。笑因缘如上说。问曰。前已出舌相光明。今何以故舌根复放光明。答曰。欲令一切得重信故。又以舌相色如珊瑚金光明净共相发起故。复放光。复次是诸光明变成千叶金色宝华。从舌相出此千叶金色宝华。光明彻照如日初出。问曰。何以故。光明中变化作此宝华。答曰。佛欲坐故。问曰。诸床可坐何必莲华。答曰。床为世界白衣坐法。又以莲华软净。欲现神力能坐其上令花不坏故。又以庄严妙法座故。又以诸华皆小。无如此华香净大者。人中莲华大不过尺。漫陀耆尼池。及阿那婆达多池中莲华。大如车盖。天上宝莲华复大于此。是则可容结加趺坐。佛所坐华复胜于此百千万倍。又如此华华台。严净香妙可坐。复次劫尽烧时一切皆空。众生福德因缘力故。十方风至相对相触能持大水。水上有一千头人二千手足。名为韦纽。是人脐中出千叶金色妙宝莲花。其光大明如万日俱照。华中有人结加趺坐。此人复有无量光明。名曰梵天王。此梵天王心生八子。八子生天地人民。是梵天王于诸淫嗔已尽无余。以是故言。若有人修禅净行断除淫欲。名为行梵道。佛转法轮或名法轮或名梵轮。是梵天王坐莲华上。是故诸佛随世俗故。于宝华上结加趺坐。说六波罗蜜。闻此法者毕至阿耨多罗三藐三菩提。问曰。释迦文尼佛。化作无量千万亿诸佛。云何一时能说法耶。如阿毗昙说。一时无二心。若化佛语时化主应默。化主语时化亦应默。云何一时皆说六波罗蜜。答曰。如此说者外道及声闻变化法耳。如佛变化无量三昧力不可思议。是故佛自语时。无量千万亿化佛亦一时皆语。又诸外道及声闻化不能作化。如佛世尊化复作化。诸外道及声闻。灭后不能留化。如佛世尊自身灭度后。复能留化如佛无异。复次阿毗昙中。一时无二心今佛亦如是。当化语时亦不有心。佛心念化欲令化语即便皆语。问曰。佛今欲说般若波罗蜜。何以令化佛说六波罗蜜。答曰。是六波罗蜜。及般若波罗蜜。一法无异。是五波罗蜜不得般若波罗蜜。不名波罗蜜。如檀波罗蜜。不得般若波罗蜜。没在世界有尽法中。或得阿罗汉辟支佛道般涅槃。若得般若波罗蜜。共合是名波罗蜜。能至佛道。以是故般若波罗蜜。与六波罗蜜一法无异。般若波罗蜜有二种。一者庄严。二者未庄严。如人着好璎珞庄严其身。有人不著名未庄严。亦如国王将诸官从。是名王来。若无官从是名独身。如是东方如恒河沙等世界。乃至十方亦尔。问曰。若佛有如是大神力。无数千万亿化佛。乃至十方说六波罗蜜。度脱一切应尽得度不应有残。答曰。有三障。三恶道中众生不能解知。人中天上若大小若大老若大病。及上无色无想天。皆不能闻不能知

问曰。诸能闻能知者。何以不皆得道。答曰。是亦不应尽得道。何以故。结使业障故。有人于结使重常为结使覆心。以是故不尽得道。问曰。当令十方诸佛。亦应遣化说六波罗蜜。我等亦无三障。何以不闻。答曰。当今众生生在恶世。则入三障中。生在佛后。不善业报。或有世界恶罪业障。或有厚重结使障。堕在佛后。人多为厚重结使所障。或淫欲薄而嗔恚厚。嗔恚薄而淫欲厚。淫欲薄而愚痴厚。愚痴薄而嗔恚厚。如是等展转互有厚薄。是结使障故。不闻不知化佛说法。不见诸佛光明。何况得道。譬如日出盲人不见。便谓世间无有日月。日有何咎。又如雷电震地聋人不闻。声有何过。今十方诸佛常说经法。常遣化佛至十方世界。说六波罗蜜。罪业盲聋故不闻法声。以是故不尽闻见。虽复圣人有大慈心。不能令皆闻皆见。若罪欲灭福将生者。是时乃得见佛闻法

【经】尔时世尊故在师子座。入师子游戏三昧。以神通力感动三千大千世界。六种震动

【论】问曰。此三昧何以名师子游戏。答曰。譬如师子搏鹿自在戏乐。佛亦如是。入此三昧能种种回转此地。令六反震动。复次师子游戏。譬如师子戏日诸兽安隐。佛亦如是。入是三昧时。震动三千大千世界。能令三恶众生一时得息皆得安隐

复次佛名人师子。师子游戏三昧是佛戏三昧也。入此三昧时。令此大地六种震动。一切地狱恶道众生。皆蒙解脱得生天上。是名为戏。问曰。佛何以故入此三昧。答曰。欲动三千大千世界。出三恶道众生着二道中故

复次上三种变化出自佛身。人或信心不深。今动大地欲令众生知佛神力无量。能令外物皆动。信净心喜皆得离苦。问曰。有诸阿罗汉及诸天亦能动地。何以独言是佛神力。答曰。诸阿罗汉及诸天。不能具足动。唯佛世尊。能令大地六种震动。问曰。佛何以故震动三千大千世界。答曰。欲令众生知一切皆空无常故。有诸人言大地及日月须弥大海是皆有常。是以世尊六种动地示此因缘令知无常。复次如人欲染衣先去尘土。佛亦如是。先令三千世界众生。见佛神力敬心柔软然后说法。是故六种动地。云何六种动

【经】东涌西没西涌东没。南涌北没北涌南没。边涌中没中涌边没

【论】问曰。何以故正有六种动。答曰。地动有上中下。下者二种动。或东涌西没。或南涌北没或边中。中者有四。或东西南北或东西边中或南北边中。上者六种动。有种种因缘令地大动。如佛告阿难。八因八缘令地震动如别说。复次有人言四种地动。火动龙动金翅鸟动天王动。二十八宿月月一周绕。若月至昴宿张宿氐宿娄宿室宿胃宿。是六种宿中。尔时地动若崩。是动属火神。是时无雨江河枯竭年不宜麦。天子凶大臣受殃。若柳宿尾宿箕宿壁宿奎宿危宿。是六种宿中。尔时地动若崩。是动属龙神。是时无雨江河枯竭年不宜麦。天子凶大臣受殃。若参宿鬼宿星宿轸宿亢宿翼宿。是六种宿中。尔时若地动若崩。是动属金翅鸟。是时无雨江河枯竭年不宜麦。天子凶大臣受殃。若心宿角宿房宿女宿虚宿井宿毕宿觜宿斗宿。是九种宿中。尔时地动若崩。是动属天帝。是时安隐丰雨宜五谷。天子吉大臣受福万民安隐。复次地动因缘有小有大。有动一阎浮提。有动四天下一千二千三千大千世界。小动以小因缘故。若福德人若生若死一国地动。是为小动。大动大因缘故。如佛初生时初成佛时将灭度时。三千大千世界皆为震动。是为大动。今佛欲大集众生故。令此地六种震动。复次般若波罗蜜中。授诸菩萨记当得作佛。佛为天地大主。是时地神大喜。我今得主。是故地动。譬如国主初立臣民喜庆皆称万岁踊跃歌舞。复次三千大千世界众生福德因缘故。有此大地山河树木一切众物。而众生不知无常。是故佛以福德智慧大力。动此世界。众生福德令知微薄一切磨灭皆归无常

【经】地皆柔软令众生和悦

【论】问曰。地动云何能令众生心得和悦。答曰。心随身故。身得乐事心则欣悦。悦者共住之人。及便身之具能令心悦。今以是三千大千世界。杂恶众生其心粗犷无有善事。是故世尊动此大地。令皆柔软心得利益。譬如三十三天王欢乐园中。诸天入者心皆柔软。欢乐和悦粗心不生。若阿修罗起兵来时都无斗心。是时释提婆那民。将诸天众入粗涩园中。以此园中树木华实气不和悦粗涩恶故。诸天人众斗心即生。佛亦如是。以此大地粗涩弊恶故变令柔软。使一切众生心得喜悦。又如咒术药草熏人鼻时。恚心便生即时斗诤。复有咒术药草。能令人心和悦欢喜敬心相向。咒术草药尚能如此。何况三千大千世界地皆柔软

【经】是三千大千世界中地狱饿鬼畜生及八难处。即时解脱得生天上。从四天王天处乃至他化自在天处

【论】问曰。若佛入师子游戏三昧。能令地狱饿鬼畜生及余八难皆得解脱。生四天处乃至他化自在天者。复何用修福行善乃得果报。答曰。此如上说。福德多者见光得度。罪垢深者地动乃悟。譬如日出照莲华池。熟者先开生者未敷。佛亦如是。先放光明。福熟智利先得解脱。其福未熟智心不利是故未得。佛大慈悲等度一切无憎爱也。亦如树果人动其树熟者先堕。佛亦如是。是三千大千世界如树。动之者佛。先度者果熟。未度者果生。问曰。何以故。善心因缘。生欲界天不生色界及无色界。答曰。佛欲度此众生令得道证。无色界中以无身故。不可为说法。色界中则无厌心难可得道。禅乐多故慧心则钝。复次佛以神通感动。令此三千大千世界地皆柔软。众生心信得欢喜故生欲界天。不行四禅及四空定故。不得生色无色界。问曰。五众无常空无我。云何生天人中。谁死谁生者。答曰。是事赞菩萨品中已广说。今当略答。汝言五众无常空无我者。是般若波罗蜜中五众。无有常无常有空无空有我无我。若如外道求索实我。是不可得但有假名。种种因缘和合而有。有此名字。譬如幻人相杀人见其死。幻术令起人见其生。生死名字有而无实。世界法中实有生死。实相法中无有生死。复次生死人有生死。不生死人无生死。何以故。不生死人以大智慧能破生相。如说偈言

  佛法相虽空　　亦复不断灭
  虽生亦非常　　诸行业不失
  诸法如芭蕉　　一切从心生
  若知法无实　　是心亦复空
  若有人念空　　是则非道行
  诸法不生灭　　念有故失相
  有念堕魔网　　无念则得出
  心动故非道　　不动是法印

【经】是诸天人自识宿命皆大欢喜。来诣佛所头面礼佛足。却住一面

【论】问曰。诸天生时有三事自知。知所从来处。知所修福田处。知本所作福德。是人生时。无此三事。云何识宿命。答曰。人道不定或有识者有不识者。复次假佛神力则识宿命。问曰。诸天有报五神通。自识宿命能到佛所。人虽蒙佛神力得知宿命。所住处远。云何能至佛所。答曰。或有人生报得神通。如转轮王圣人等。或有人假佛神力。问曰。人生十月三年乳餔十岁后能自出。今蒙佛威神三恶八难皆得解脱。生天人中即至佛所。天则可尔。人法未成。云何得来。答曰。五道生法各各不同。诸天地狱皆化生。饿鬼二种生。若胎若化生。人道畜生四种生。卵生湿生化生胎生。卵生者如毗舍佉弥伽罗母三十二子(毗舍佉母生三十二卵。卵剖生三十二男。皆为力士。弥伽罗大儿字也。此母人得三道果)如是等名卵生。湿生者如揜罗婆利(揜乌甘反)淫女顶生转轮圣王。如是等名湿生。化生者。如佛与四众游行。比丘尼众中有比丘尼。名阿罗婆。地中化生。及劫初生时人皆化生。如是等名为化生。胎生者。如常人生。化生人即时长大能到佛所。有人报得神通故能到佛所。复次佛借神通力故。能到佛所

【经】如是十方如恒河沙等世界地皆六种震动。一切地狱饿鬼畜生及余八难处。即得解脱得生天上。齐第六天

【论】问曰。三千大千世界无量无数众生甚多。何以复及十方。如恒河沙等世界众生。答曰。佛力无量。虽度三千大千世界众生。犹以为少。以是故复及十方。问曰。若释迦文尼佛以大神力广度十方。复何须余佛。答曰。众生无量。不一时熟故。又众生因缘各各不同。如声闻法中说。舍利弗因缘弟子。除舍利弗。诸佛尚不能度。何况余人。复次今但说东方一恒河沙等。不说若二三四乃至千万亿恒河沙等诸世界。又以世界无边无量。若有边有量众生可尽。以是故十方无量世界诸佛应度

【经】尔时三千大千世界众生。盲者得视。聋者得听。哑者能言。狂者得正。乱者得定。裸者得衣。饥渴者得饱满。病者得愈。形残者得具足

【论】问曰。众生苦患有百千种。若佛神力何以不遍令得解脱。答曰。一切皆救。今但略说粗者。如种种结使略说为三毒。问曰。但言盲者得视则足。何以故言生盲。答曰。生盲者先世重罪故。重罪者犹尚能令得视。何况轻者。问曰。云何先世重罪而令生盲。答曰。若破众生眼若出众生眼。若破正见眼言无罪福。是人死堕地狱。罪毕为人从生而盲。若复盗佛塔中火珠及诸灯明。若阿罗汉辟支佛塔珠及灯明。若余福田中夺取光明。如是等种种先世业因缘故失明。今世若病若打故失明。是今世因缘。复次九十六种眼病。阇那迦药王所不能治者。唯佛世尊能令得视。复次先令得视。后令得智慧眼。聋者得听亦如是。问曰。若有生盲何以不说生聋。答曰。多有生盲生聋者少。是故不说。问曰。以何因缘故聋。答曰。聋者是先世因缘。师父教训不受不行而反嗔恚。以是罪故聋。从次截众生耳若破众生耳。若盗佛塔僧塔诸善人福田中揵稚铃贝及鼓。故得此罪。如是等种种先世业因缘。今世因缘若病若打。如是等是今世因缘得聋。问曰。哑者不能言。作何等罪故哑。答曰。先世截他舌或塞其口。或与恶药令不得语。或闻师教父母教敕。断其语非其教。或作恶邪人不信罪福破正语。地狱罪出生世为人哑不能言。如是种种因缘故哑。问曰。狂者得正云何为狂。答曰。先世作罪。破他坐禅破坐禅舍。以诸咒术咒人。令嗔斗诤淫欲。今世诸结使厚重。如婆罗门失其福田。其妇复死。即时狂发裸形而走。又如翅舍伽憍昙比丘尼。本白衣时七子皆死。大忧愁故失心发狂。有人大嗔不能自制成大痴狂。有愚痴人恶邪故。以灰涂身拔发裸形狂痴食粪。有人若风病若热病病重成狂。有人恶鬼所著。或有人痴饮雨水而狂。如是失心如是种种名为狂。得见佛故狂即得正。问曰。乱者得定狂则是乱。以何事别。答曰。有人不狂而心多散乱。志如猕猴不能专住是名乱心。复有剧务匆匆心着众事。则失心力不堪受道。问曰。乱心有何因缘。答曰。善心转薄随逐不善。是名心乱。复次是人不观无常。不观死相不观世空。爱着寿命计念事务种种驰散。是故心乱。复次不得佛法中内乐。外求乐事随逐乐因。是故心乱。如是乱人得见佛故其心得定。问曰。先言狂者得正。今言裸者得衣。除狂云何更有裸。答曰。狂有二种。一者人皆知狂。二者恶邪故自裸人不知狂。如说南天竺国中有法师。高坐说五戒义。是众中多有外道来听。是时国王难曰。若如所说。有人施酒及自饮酒得狂愚报。当今世人应狂者多正者少。而今狂者更少不狂者多。何以故尔。是时诸外道辈言善哉。斯难甚深。是秃高坐必不能答。以王利智故。是时法师以指指诸外道。而更说余事。王时即解。诸外道语王言。王难甚深是不知答。耻所不知而但举指更说余事。王语外道。高坐法师指答已讫。将护汝故不以言说。向者指汝言。汝等是狂狂不少也。汝等以灰涂身裸形无耻。以人髑髅盛粪而食。拔头发卧刺上倒悬熏鼻。冬则入水夏则火炙。如是种种所行非道皆是狂相。复次汝等法以卖肉卖盐即时失婆罗门法。于天祠中得牛布施。即时卖之自言得法。牛则是肉。是诳惑人岂非失耶。又言入吉河水中罪垢皆除。是为罪福无因无缘。卖肉卖盐此有何罪。入吉河水中言能除罪。若能除罪亦能除福。谁有吉者。如此诸事无因无缘。强为因缘。是则为狂。如是种种狂相。皆是汝等法师将护汝故指而不说。是名为裸形狂。复次有人贫穷无衣。或弊衣蓝缕以佛力故令其得衣。问曰。饥者得饱渴者得饮。云何饥渴。答曰。福德薄故。先世无因今世无缘。是故饥渴。复次是人先世夺佛阿罗汉辟支佛食及父母所亲食。虽值佛世犹故饥渴。以罪重故。问曰。今有恶世生人得好饮食。值佛世生而更饥渴。若罪人不应生值佛世。若福人不应生恶世。何以故尔。答曰。业报因缘各各不同。或有人有见佛因缘。无饮食因缘。或有饮食因缘。无见佛因缘。譬如黑蛇。而抱摩尼珠卧。有阿罗汉人乞食不得。又如迦叶佛时。有兄弟二人出家求道。一人持戒诵经坐禅。一人广求檀越修诸福业。至释迦文佛出世。一人生长者家。一人作大白象。力能破贼。长者子出家学道。得六神通阿罗汉。而以薄福乞食难得。他日持钵入城乞食遍不能得。到白象厩中。见王供象种种丰足。语此象言。我之与汝俱有罪过。象即感结三日不食。守象人怖求觅道人。见而问言。汝作何咒令王白象病不能食。答言。此象是我先身时弟。共于迦叶佛时出家学道。我但持戒诵经坐禅不行布施。弟但广求檀越作诸布施。不持戒不学问。以其不持戒诵经坐禅故今作此象。大修布施故饮食备具种种丰足。我但行道不修布施故。今虽得道乞食不能得。以是事故因缘不同。虽值佛世犹故饥渴。问曰。此诸众生云何饱满。答曰。有人言。佛以神力变作食令得饱满。复有人言。佛光触身令不饥渴。譬如如意摩尼珠。有人心念则不饥渴。何况值佛。病者得愈。病有二种。先世行业报故。得种种病。今世冷热风发故。亦得种种病。今世病有二种。一者内病。五藏不调结坚宿疹。二者外病。奔车逸马堆压坠落。兵刃刀杖种种诸病。问曰。以何因缘得病。答曰。先世好行鞭杖拷掠闭系种种恼故。今世得病。现世病不知将身。饮食不节卧起无常。以是事故得种种诸病。如是有四百四病。以佛神力故。令病者得愈。如说。佛在舍婆提国有一居士。请佛及僧于舍饭食。佛住精舍迎食有五因缘。一者欲入定。二者欲为诸天说法。三者欲游行观诸比丘房。四者看诸病比丘。五者若未结戒欲为诸比丘结戒。是时佛手持户排入诸比丘房。见一比丘。病苦无人瞻视。卧大小便。不能起居。佛问比丘。汝何所苦独无人看。比丘答言。大德。我性懒。他人有病。初不看视。是故我病他亦不看。佛言。善男子我当看汝。时释提婆那民盥水。佛以手摩其身。摩其身时。一切苦痛即皆除愈身心安隐。是时世尊安徐扶此病比丘起。将出房澡洗着衣。安徐将入更与敷褥令坐。佛语病比丘。汝久来不勤求。未得事令得。未到时令到。未识事令识。受诸苦患如是。方当更有大苦。比丘闻已心自思念。佛恩无量神力无数。以手摩我苦痛即除身心快乐。以是故佛以神力令病者得愈。形残者得具足。云何名形残者。若有人先世破他身截其头斩其手足。破种种身分。或破坏佛像毁佛像鼻及诸贤圣形像。或破父母形像。以是罪故受形多不具足

复次不善法报受身丑陋。若今世被贼或被刑戮。种种因缘以致残毁。或风寒热病身生恶疮体分烂坏。是名形残。蒙佛大恩皆得具足。譬如祇洹中奴。字犍抵。(揵抵秦言续也)是波斯匿王兄子。端正勇健心性和善。王大夫人见之心着。即微呼之欲令从己。犍抵不从。夫人大怒向王谗之反被其罪。王闻即节节解之弃于冢间。命未绝顷其夜虎狼罗刹来欲食之。是时佛到其边光明照之。身即平复其心大喜。佛为说法即得三道。佛牵其手将至祇洹。是人言我身已破已弃。佛续我身今当尽此形寿以身布施佛及比丘僧。明日波斯匿王闻如是事来至祇洹语犍抵言。向汝悔过。汝实无罪枉相刑害。今当与汝分国半治。犍抵言我已厌矣。王亦无罪。我宿世殃咎罪报应尔。我今以身施佛及僧不复还也。如是若有众生形残不具足者。蒙佛光明即时平复。是故言乃至形残皆得具足。蒙佛光明即时平复

【经】一切众生皆得等心相视。如父如母如兄如弟如姊如妹。亦如亲亲及善知识。是时众生等行十善业道净修梵行。无诸瑕秽惔然快乐。譬如比丘入第三禅。皆得好慧持戒自守不娆众生

【论】问曰。是诸众生未离欲无禅定。不得四无量心。云何得等心。答曰。是等非禅中等。是于一切众生中。无怨无恚。以此等故善心相视。复次等心者。经中有言。云何等心相视如父母是名等心。问曰。视一切众生便是父母兄弟姊妹不。答曰。不也。见老者如父母。长者如兄。少者如弟。姊妹亦尔。等心力故皆如亲亲。问曰。云何非父母言父母。乃至非亲亲言亲亲。不堕妄语耶。答曰。一切众生无量世中。无非父母兄弟姊妹亲亲者

复次实法相中无父母兄弟。人着吾我颠倒计故。名为父母兄弟。今以善心力故相视如父如母非妄语也。复次如人以义相亲非父事之为父。非母事之为母。兄弟儿子亦复如是。如人有子行恶黜而弃之。他姓善行养以为子。如是相视则为等心。如说偈

  视他妇如母　　见他财如火
  一切如亲亲　　如是名等见

是时众生等行十善业道者。身业道三种。不杀不盗不邪淫。口业道四种。不妄语不两舌不恶口不绮语。意业道三种不贪不恼害不邪见。自不杀生不教他杀。赞不杀者。见人不杀。代其欢喜。乃至邪见亦有四种。问曰。后三业道非业。前七业道亦业。云何言十善业道。答曰。没少从多故通名业道。后三虽非业能起业。又复为业故生。是故总名业道。净修梵行无诸瑕秽者。问曰。上说行十善业道。此理已足。今何以复言净修梵行。答曰。有人行十善业道不断淫。今更赞此行梵天行。断除淫欲故。言净修梵行。无诸瑕秽者。行淫之人身恶名臭。以是故赞断淫人言无诸瑕秽。惔然快乐者。问曰。此何等乐。答曰。是乐二种。内乐涅槃乐。是乐不从五尘生。譬如石泉水自中出不从外来。心乐亦如是。行等心修梵行。得十善业道清净无秽。是名内乐。问曰。此乐何界系。欲界系色界系无色界系耶。答曰。是乐欲界系亦不系。非色无色界系。今言譬如比丘入第三禅。若是色界系不应言。譬如。以是事故知。非色界系。此欲界心生喜乐一切满身。譬如暖苏渍身柔软和乐。不系者得般若波罗蜜相观诸法不生不灭。得实智慧心无所著。无相之乐是为不系。问曰。佛言涅槃第一乐。何以言第三禅乐。答曰。有二种乐。有受乐有受尽乐。受尽乐一切五众尽更不生。是无余涅槃乐。能除忧愁烦恼心中欢喜。是名乐受。如是乐受满足在第三禅中。以是故言譬如第三禅乐。问曰。初禅二禅亦有乐受。何以故但言第三禅。答曰。乐有上中下。下者初禅。中者二禅。上者三禅。初禅有二种。乐根喜根。五识相应乐根。意识相应喜根。二禅中意识相应喜根。三禅意识相应乐根。一切三界中。除三禅更无意识相应乐根。是五识不能分别。不知名字相。眼识生如弹指顷。意识已生。以是故五识相应乐根。不能满足乐。意识相应乐根。能满足乐。以是故三禅中。诸功德少乐多故。无背舍胜处一切入。过是三禅更无乐。以是故言譬如比丘入第三禅。一切众生皆得好慧。持戒自守不娆众生者。问曰。何以故。次乐后言皆得好慧。答曰。人未得乐能作功德。既得乐已心着乐多故。不作功德。是故乐后次第心得好慧。好慧者。持戒自守不娆众生。问曰。持戒是名自守亦名不娆众生。何以故。复言自守不娆众生耶。答曰。身口善是名持戒。捡心就善是名自守。亦名不娆众生。一切诸功德。皆戒身定身慧身所摄。言好持戒是戒身摄。好自守者是定身摄。不娆众生禅中慈等诸功德。是慧身摄。问曰。亦无有人言不好持戒者。今何以言好持戒。答曰。有如婆罗门着世界法者。言舍家好持戒。是为断种人。又以自力得财广作功德如是有福。出家乞食自身不给。何能作诸功德。如是为呵好持戒。亦有着世界治法道人。呵好自守者言。人当以法治世。赏善罚恶法不可犯。不舍尊亲立法济世所益者大。何用独善其身自守无事。世乱而不理人急而不救。如是名为呵好自守。亦有人呵好不娆众生者言。有怨不能报有贼不能系。恶人不能治。有罪无以肃。不能却患救难。默然无益何用此为。如是为呵好不娆众生。如说

  人而无勇健　　何用生世间
  亲难而不救　　如木人在地

如是等种种不善语。名为呵不娆众生。是诸天人皆得好慧持戒自守不娆众生。行是善法身心安隐无所畏难。无热无恼。有好名善誉。人所爱敬。是为向涅槃门。命欲终时见福德。心喜无忧无悔。若未得涅槃。生诸佛世界若生天上。以是故言得好慧持戒自守不娆众生

大智度论卷第八大智度初品中放光释论之余(卷第九)

        龙树菩萨造

        后秦龟兹国三藏法师鸠摩罗什奉　诏译

【经】尔时世尊在师子座上坐。于三千大千世界中其德特尊。光明色像威德巍巍。遍至十方如恒河沙等诸佛世界。譬如须弥山王光色殊特众山无能及者

【论】问曰。佛以何力故。于一切众生中其德特尊光明威德巍巍乃如是耶。如转轮圣王诸天圣人。亦有大力光明威德。何以独言佛德特尊。答曰。此诸贤圣虽有光明威德有量有限。譬如众星日光既出则没不现。佛从无量阿僧祇劫集大功德。一切具足因缘大故果报亦大。余人无此。复次佛世世修诸苦行无量无数。头目髓脑常施众生。岂唯国财妻子而已。一切种种戒种种忍种种精进种种禅定。及无比清净不可坏不可尽智慧。世世修行已具足满。此果力故得不可称量殊特威神。以是故言因缘大故果报亦大。问曰。若佛神力无量威德巍巍不可称说。何以故受九罪报。一者梵志女孙陀利谤。五百阿罗汉亦被谤。二者旃遮婆罗门女。系木盂作腹谤佛。三者提婆达推山压佛伤足大指。四者迸木刺脚。五者毗楼璃王兴兵杀诸释子佛时头痛。六者受阿耆达多婆罗门请而食马麦。七者冷风动故脊痛。八者六年苦行。九者入婆罗门聚落乞食不得空钵而还。复有冬至前后八夜寒风破竹索三衣御寒。又复患热阿难在后扇佛。如是等世界小事佛皆受之。若佛神力无量。三千大千世界。乃至东方恒河沙等诸佛世界。南西北方四维上下。光明色像威德巍巍。何以故受诸罪报。答曰。佛在人中生人父母。受人身力一指节力胜千万亿那由他白象力。神通力无量无数不可思议。是净饭王子厌老病死苦。出家得佛道。是人岂受罪报为寒热等所困。如佛神力不可思议。不可思议法中。何有寒热诸患。复次佛有二种身。一者法性身。二者父母生身。是法性身满十方虚空无量无边。色像端正相好庄严。无量光明无量音声。听法众亦满虚空。(此众亦是法性身非生死人所得见也)常出种种身种种名号种种生处种种方便度众生。常度一切无须臾息时。如是法性身佛。能度十方世界众生。受诸罪报者是生身佛。生身佛次第说法如人法。以有二种佛故受诸罪无咎。复次佛即得道时。一切不善法尽断。一切善法皆成就。云何今实有不善法报可受。但怜愍未来世众生故。现方便受此诸罪。复次如阿泥卢豆。与一辟支佛食故。受无量世乐。心念饮食应意即得。何况佛世世割肉出髓以施众生。而乞食不得空钵而还。以是事故知佛方便。为度众生故受此诸罪。云何方便怜愍未来世五众佛弟子施福薄故。乞种种自活之具不能得。诸白衣言。汝衣食不能得。有病不能除。何能得道以益于人。是五众当答。我等虽无活身小事。有行道福德。我等今日众苦。是先身罪报。今之功德利在将来。我等大师佛入婆罗门聚落乞食。尚亦不得空钵而还。佛亦有诸病。释子毕罪时佛亦头痛。何况我等薄福下人。诸白衣闻已嗔心则息。便以四种供养供给比丘。身得安隐坐禅得道。是为方便故非实受罪。如毗摩罗诘经中说。佛在毗耶离国。是时佛语阿难。我身中热风气发。当用牛乳。汝持我钵乞牛乳来。阿难持佛钵。晨朝入毗耶离。至一居士门立。是时毗摩罗诘在是中行。见阿难持钵而立。问阿难。汝何以晨朝持钵立此。阿难答言。佛身小疾当用牛乳。故我到此。毗摩罗诘言。止止阿难。勿谤如来。佛为世尊已过一切诸不善法。当有何疾。勿使外道闻此粗语。彼当轻佛便言。佛自疾不能救安能救人。阿难言。此非我意。面受佛敕当须牛乳。毗摩罗诘言。此虽佛敕是为方便。以今五恶之世故。以是像度脱一切。若未来世有诸病比丘。当从白衣求诸汤药。白衣言。汝自疾不能救。安能救余人。诸比丘言。我等大师。犹尚有病。况我等身如草芥能不病耶。以是事故诸白衣等。以诸汤药供给比丘。使得安隐坐禅行道。有外道仙人。能以药草咒术除他人病。何况如来一切智德。自身有病而不能除。汝且默然持钵取乳。勿令余人异学得闻知也。以是故知佛为方便非实病也。诸罪因缘皆亦如是。以是故言佛其德特尊光明色像威德巍巍

【经】尔时世尊以常身示此三千大千世界一切众生。是时首陀会天梵众天他化自在天化自乐天兜率陀天夜磨天三十三天四天王天。及三千大千世界人与非人。以诸天华天璎珞天泽香天末香天青莲华赤莲华白莲华红莲华天树叶香持诣佛所

【论】问曰。佛何以故。以常身示此三千大千世界中一切众生。答曰。佛欲说摩诃般若波罗蜜。入三昧王三昧。从足下相轮光明上至肉髻光焰大明。譬如劫尽烧时诸须弥山王随次燃尽。是光明遍满三千大千世界。乃至十方恒河沙等诸佛世界。皆悉大明。众生见者毕至阿耨多罗三藐三菩提。是佛欲说般若波罗蜜。初神力。第二一切毛孔皆悉微笑。第三放常光明面各一丈。第四舌相遍覆三千大千世界而笑。第五入师子游戏三昧。三千大千世界六反震动。第六佛坐师子座。现最胜身光明色像。威德巍巍。以此神力感动众生。其有信者皆至阿耨多罗三藐三菩提。其中疑者示常身便得信解。而各说言。今所见者是佛真身。以佛力故此三千大千世界中人。见佛常身远近无碍。是时三千大千世界众生皆大欢喜言。此真是佛身。佛初生时初成佛时初转法轮时。皆以此身如是思惟。此真是佛身。问曰。何以故。名为净居天梵世天。答曰。第四禅有八种。五种是阿那含住处。是名净居。三种凡夫圣人共住。过是八处。有十住菩萨住处。亦名净居。号大自在天王。梵世天者生处有三种。一者梵众天。诸小梵生处。二者梵辅天。贵梵生处。三者大梵天。是名中间禅生处。问曰。离欲是同。何以故有贵贱异处。答曰。初禅三种。下中上。若修下禅生梵众。若修中禅生梵辅。若修上禅生大梵。慈行亦如是。如妙眼师念言。我为众人说法皆生梵天中。我今不应与弟子同处。当修上慈。修上慈故生大梵天中。复次第一清净心故。生大梵天中。问曰。何以故于四禅中。但说初后不说中间。答曰。初门离欲难故。最后微妙难得故。中间易入故不说。复次言梵世已摄色界。以第四禅第一妙故别说。复次以人多识梵天不识余天。是故但说梵天。以净居天常怜愍众生常劝请佛故。复次佛说法声至梵天。佛得道时诸天展转唱告乃至净居天。以是故说初后不说中间。复次梵天近欲界故应闻。净居天是色界主。是故应闻。譬如守门人识客。客至其主主则识之。中间无事故不说。复次二禅大喜三禅大乐。喜乐放逸是故不说。问曰。何以名他化自在。答曰。此天夺他所化而自娱乐。故言他化自在。化自乐者。自化五尘而自娱乐故。言化自乐。兜率名知足天。夜摩名善分天。第二名三十三天。最下天是四天王诸天。须弥山高八万四千由旬。上有三十三天城。须弥山边有山。名由揵陀罗。高四万二千由旬。此山有四头。头各有城。四天王各居一城。夜摩等诸天七宝地。在虚空中有风持之令住。乃至净居亦复如是。如是诸天见佛身清净大光明。净持诸供具水陆诸华。陆地生华须漫提为第一。水中生华青莲华为第一。若树生华若蔓生华。是诸名华种种异色种种香熏。各持天华来诣佛所。以此诸华色好多香柔软细滑。是故以此为供养具。云何为天华。天华芬熏香气逆风。诸天璎珞悬在佛上。天泽香以涂佛地。天末香以散佛上。天莲华青赤红白。何以无黄。黄属火。火非水华所宣故。天宝莲华琉璃为茎。金刚为台。阎浮那陀金为叶。柔软且香。并天树叶香持诣佛所。问曰。若诸天供养应持天华。人及非人云何得天华。答曰。佛以神足放大光明地六种震动。诸天雨种种妙华。满三千大千世界。以供养佛。是人非人或取此华而以供养。复次天竺国法名诸好物皆名天物。是人华非人华。虽非天上华。以其妙好故名为天华。是故言人非人持诸天华。是则无咎

【经】是诸天华乃至天树叶香以散佛上

【论】问曰。何以以华散佛身上。答曰。恭敬供养故。又佛光照皆遥见佛。心大欢喜供养佛故。皆以诸华而散佛上。复次佛于三界第一福田。以是故华散佛上

【经】所散宝华于此三千大千世界上在虚空中化成大台

【论】问曰。何以化作此台在虚空中。答曰。所散华少而化为大台。以示众生因少果多。问曰。何以故台在虚空中住而不堕落。答曰。佛以神力。欲示众生令知佛为福田得报不失。乃至成佛其福不灭

【经】是华台边垂诸璎珞杂色华盖五色缤纷。是诸华盖璎珞遍满三千大千世界

【论】问曰。若佛自有神力。何以因所散华而变为台。答曰。欲令人心信清净故。是人见所供养变成此台心大欢喜。因欢喜故得大福德

【经】以是华盖璎珞严饰故。此三千大千世界皆作金色。及十方如恒河沙等诸佛世界皆亦如是

【论】有人言。转轮圣王四世界主。梵天王千世界主。佛三千大千世界主。是语非实。以是故佛所变化乃至十方恒河沙等诸佛世界

【经】尔时三千大千世界。及十方众生各各自念。佛独为我说法不为余人

【论】问曰。佛以一身示三千大千世界及十方。今诸众生何以各各见佛在前说法。答曰。佛有二种神力。一者一处坐说法。令诸众生远处皆见远处皆闻。二者佛在一处说法。能令一一众生各自见佛在前说法。譬如日出影现众水。复次众生不同。有人见佛身遍三千大千世界而得净信。有人各各见佛在前说法。得心清净信乐欢喜。以是故佛今各各在前而为说法

【经】尔时世尊在师子座熙怡而笑。光从口出遍照三千大千世界。以此光故。此间三千大千世界中众生。皆见东方恒河沙诸佛及僧。彼间恒河沙等世界中众生。亦见此间三千大千世界中释迦牟尼佛及诸大众。南西北方四维上下亦复如是

【论】问曰。佛上已多放光明。今以何故复放斯光。答曰。先放光明各各有事如先说。今以彼此众会两未相见故。以光明神力。令彼此世界一切大会两得相见。问曰。如弟子中天眼第一大阿罗汉长老阿泥卢豆。暂观见小千世界。谛观见二千世界。大辟支佛暂观见二千世界。谛观见三千大千世界。今一切人云何能见东方恒河沙等诸佛世界。答曰。是佛神力令彼得见。非众生力也。设阿罗汉及辟支佛等。亦以佛力故所见无限。譬如转轮圣王飞行。一切营从及诸象马众畜皆亦随去。今佛神力故。众生虽在远处亦得相见。又如般舟三昧力故。虽不得天眼而见十方。佛眼耳无碍。亦如劫尽烧时一切众生自然皆得禅定得天眼天耳。佛以神力故。令一切众生皆得远见亦复如是。尔时世尊在师子座而笑。笑如先说。余未说者今当说。问曰。此间众生。远见彼方是佛神力。彼间众生亦见此方是谁力耶。答曰。是释迦牟尼佛力。令彼得见此间三千大千世界。及见释迦牟尼佛并一切众会。南西北方四维上下。亦复如是

    大智度初品中十方诸菩萨来释论第十五

【经】是时东方过如恒河沙等诸佛世界。其世界最在边世界名多宝佛号宝积。今现在为诸菩萨摩诃萨说般若波罗蜜

【论】问曰。如佛所说一切世界无量无边。云何言其世界最在边。最在边者是堕有边相。若世界有边众生应尽。何以故。无量诸佛一一佛度无量阿僧祇众生。令入无余涅槃。更无新众生故者应尽。答曰。佛经虽言世界无量。此方便说非是实教。如实无神方便故说言有神。此十四难。世界有边无边俱为邪见。若无边佛不应有一切智。何以故。智慧普知无物不尽。是名一切智。若世界无边是有所不尽。若有边如先说咎。此二俱邪见。何以故。依无边以破有边故。是多宝世界非一切世界边。是释迦牟尼佛。因缘众生可应度者最在边。譬如一国中最在边。不言一阎浮提最在边。若无边佛不应一切智者。如上佛义中答。佛智无量故应知。譬如函大故盖亦大。问曰。世界名多宝。宝有二种。财宝法宝。何等宝多名为多宝世界。答曰。二种皆有。又多菩萨照法性等诸宝。(言此宝大菩萨所有以为宝冠。宝冠中皆见诸佛。又了达一切诸法之性)多故。名为多宝。是中有佛名宝积。以无漏根力觉道等法宝集故。名为宝积。问曰。若尔者一切佛皆应号宝积。何以独称彼佛为宝积。答曰。虽一切诸佛皆有此宝。但彼佛即以此宝为名。如弥勒名为慈氏。诸佛虽皆有慈。但弥勒即以慈为名。复次如宝华佛。生时一切身边有种种华色光明故。名宝华太子。如燃灯佛。生时一切身边如灯故。名燃灯太子。作佛亦名燃灯。(丹注云旧名定光佛也)宝积佛亦如是。应当初生时亦多诸宝物生。或地生。或天雨种种宝集故。名为宝积。问曰。唯有释迦牟尼一佛无十方佛。何以故。是释迦文尼佛无量威力无量神通。能度一切众生。更无余佛。如说阿难一心思惟过去诸佛宝华燃灯等。皆生好世寿命极长。能度一切众生。今释迦牟尼佛。恶世生寿命短。将无不能度一切弟子耶。如是心疑。佛时即知阿难心之所念。即以日出时入日出三昧。尔时佛身一切毛孔出诸光明。亦如日边出诸光明。其光遍照阎浮提内。其明满已照四天下。照四天下满已照三千大千世界。照三千大千世界。满已照十方无量世界。尔时世尊从脐边出诸宝莲华。如偈说

  青光琉璃茎　　千叶黄金色
  金刚为华台　　琥珀为华饰
  茎软不粗曲　　其高十余丈
  真青琉璃色　　在佛脐中立
  其叶广而长　　白光间妙色
  无量宝庄严　　其华有千叶
  妙华色如是　　从佛脐中出
  是四华台上　　宝座曜天日
  座各有坐佛　　如金山四首
  光曜等如一　　从四佛脐中
  各出妙宝华　　华上有宝座
  其座各有佛　　从是佛脐中
  展转出宝华　　华华皆有座
  座座各有佛　　如是展转化
  乃至净居天　　若欲知近远
  当以譬喻说　　有一大方石
  纵广如太山　　从上放令下
  直过无所碍　　万八千三百
  八十有三岁　　如是年岁数
  尔乃得到地　　于是两中间
  化佛满其中　　其光大盛明
  踰于火日月　　有佛身出水
  亦有身出火　　或复现经行
  有时静默坐　　有佛行乞食
  以此福众生　　或复说经行
  有时放光明　　或到三恶趣
  冰闇火地狱　　和气济寒冰
  光明照闇狱　　热处施凉风
  随事救其害　　安之以无患
  度之以法乐

如是种种方便。一时顿能度十方无量众生。度众生已还入本处住佛脐中。尔时世尊。从日出三昧起问阿难言。汝见此三昧神通力不。阿难白佛。唯然已见。重白佛言。若佛住世一日之中所度弟子可满虚空。何况在世八十余年。以是故言一佛功德神力无量现化十方无异佛也。复次如佛所言。女人不得作转轮圣王。不得作天帝释魔天王梵天王。不得作佛。转轮圣王不得一处并治。十力世尊亦无一世二佛。又佛说言。佛言不虚世无二佛一法难值是佛世尊也。无量亿劫时。时一有。是九十一劫中三劫有佛。贤劫之前九十一劫初有佛名鞞婆尸。(秦言种种见)第三十一劫中有二佛。一名尸弃。(秦言火)二名鞞恕婆附(秦言一切胜)是贤劫中有四佛。一名迦罗鸠餐陀。二名迦那伽牟尼(秦言金仙人也)三名迦叶。四名释迦牟尼。除此余劫皆空无佛甚可怜愍。若有十方佛。何以故言余劫无佛甚可怜愍。答曰。虽释迦文尼佛有无量神力能变化作佛在十方说法放光明度众生。亦不能尽度一切众生。堕有边故。则无未来世佛故。然众生不尽。以是故应更有余佛

复次汝言。佛自说女人不得作五事。二转轮圣王不得同时出世。佛亦如是。同时一世亦无二佛。汝不解此义。佛经有二义。有易了义。有深远难解义。如佛欲入涅槃时。语诸比丘从今日应依法不依人。应依义不依语。应依智不依识。应依了义经不依未了义。依法者法有十二部应随此法。不应随人。依义者。义中无诤好恶罪福虚实故。语以得义义非语也。如人以指指月以示惑者。惑者视指而不视月。人语之言。我以指指月令汝知之。汝何看指而不视月。此亦如是。语为义指。语非义也。是以故不应依语。依智者。智能筹量分别善恶。识常求乐不入正要。是故言不应依识。依了义经者。有一切智人佛第一。一切诸经书中佛法第一。一切众生中比丘僧第一。布施得大富。持戒得生天。如是等是了义经。如说法师。说法有五种利。一者大富。二者人所爱。三者端正。四者名声。五者后得涅槃。是为未了义。云何未了。施得大富是为了。了可解。说法无财施而言得富。得富者说法人种种赞施。破人悭心亦自除悭。以是因缘得富。是故言未了。是多持经方便说非实义。是经中佛虽言世无二佛俱出。不言一切十方世界。虽言世无二转轮圣王。亦不言一切三千大千世界无。但言四天下世界中。无二转轮圣王。作福清净故独王一世无诸怨敌。若有二王不名清净。虽佛无嫉妒心。然以行业世世清净故。亦不一世界有二佛出。百亿须弥山。百亿日月。名为三千大千世界。如是十方恒河沙等三千大千世界。是名为一佛世界。是中更无余佛。实一释迦牟尼佛。是一佛世界中。常化作诸佛种种法门种种身种种因缘种种方便。以度众生。以是故。多持经中。一时一世界无二佛。不言十方无佛。复次如汝言。佛言一事难值是佛世尊。又言九十一劫。三劫有佛余劫皆空无佛甚可怜愍。佛为此重罪不种见佛善根人说言。佛世难值如优昙波罗树华时时一有。如是罪人轮转三恶道。或在人天中佛出世时。其人不见如说。舍卫城中九亿家。三亿家眼见佛。三亿家耳闻有佛而眼不见。三亿家不闻不见。佛在舍卫国二十五年。而此众生不闻不见。何况远者。复次佛与阿难入舍卫城乞食。是时有一贫老母立在道头。阿难白佛。此人可愍佛应当度。佛语阿难。是人无因缘。阿难言。佛往近之。此人见佛相好光明。发欢喜心为作因缘。佛往近之回身背佛。佛从四边往。便四向背佛仰面上向。佛从上来低头下向。佛从地出两手覆眼不肯视佛。佛语阿难复欲作何因缘。有如是人无度因缘。不得见佛。以是故佛言。佛难得值如优昙波罗树华。譬如水雨虽多处处易得。饿鬼常渴不能得饮。汝言九十一劫。三劫有佛。为一佛世界故。不为一切余诸世界。是处劫空无有佛出甚可怜愍者。亦是此间一佛世界。非为一切余诸世界也。以是故知有十方佛。复次声闻法中有十方佛。汝自不解。如杂阿含经中说。譬如大雨连注。渧渧无间不可知数。诸世界亦如是。我见东方无量世界。有成有住有坏。其数甚多不可分别。如是乃至十方。是十方世界中。无量众生有三种身苦老病死。三种心苦淫嗔痴。三种后世苦地狱饿鬼畜生。一切世界皆有三种人。下中上。下人着现世乐。中人求后世乐。上人求道有慈悲心怜愍众生。有因缘云何无果报。佛言。若无老病死。佛不出世。是人见老病死苦恼众生。心中作愿我当作佛。以度脱之拔其心病济后世苦。如是十方世界。皆有佛出因缘。何以故。独言此间有佛余处无耶。譬如有人言。有木无火有湿地而无水是不可信。佛亦如是。众生身有老病死苦。心有淫嗔痴病。佛为断此三苦令得三乘故。出世一切世界中。皆有此苦云何无佛。复次盲人无量。而言唯须一医。此亦不然。以是故应更有十方佛。复次长阿含中。有经言。有鬼神王守北方。与众多百千万鬼神。后夜到佛所头面礼佛足。一面住放清净光。普照只桓皆令大明。合掌赞佛说此二偈

  大精进人我归命　　佛二足中尊最上
  智慧眼人能知见　　诸天不解此慧事
  过去未来今诸佛　　一切我皆稽首礼
  如是我今归命佛　　亦如恭敬三世尊

如是偈中有十方佛。鬼神王稽首三世佛。然后别归命释迦牟尼佛。若无十方现在佛。当应但归命释迦文尼佛。不应言过去未来现在诸佛。是故知有十方佛。复次过去世有无量佛。未来世亦有无量佛。以是故现在亦应有无量佛。复次若佛于声闻法中。言有十方无数无量佛。众生当言佛易可遇不勤求脱。若不值此佛当遇彼佛。如是懈怠不勤求度。譬如鹿未被箭时不知怖畏。既被箭已踔围而出。人亦如是。有老病死苦。闻唯有一佛甚难可遇。心便怖畏勤行精进疾得度苦。以是故佛于声闻法中。不言有十方佛。亦不言无。若有十方佛。汝言无得无限罪。若无十方佛。而我言有。生无量佛想得恭敬福。所以者何。善心因缘福德力大故。譬如慈心三昧力。观一切众生皆见受乐。虽无实益以慈观故。是人得无量福。十方佛想亦复如是。若实有十方佛而言无。得破十方佛无量重罪。何以故。破实事故。肉眼人虽俱不知。但心信言有。其福无量。若实有而意谓无。其罪甚重。人自用心尚应信有。何况佛自说摩诃衍中。言实有十方佛而不信耶。问曰。若有十方无量诸佛及诸菩萨。今此众生多堕三恶道中。何以不来。答曰。众生罪重故。诸佛菩萨虽来不见。又法身佛常放光明。常说法。而以罪故不见不闻。譬如日出盲者不见。雷霆振地聋者不闻。如是法身常放光明常说法。众生有无量劫罪垢厚重不见不闻。如明镜净水照面则见。垢翳不净则无所见。如是众生心清净则见佛。若心不净则不见佛。今虽实有十方佛及诸菩萨来度众生。而不得见。复次如释迦牟尼佛。在阎浮提中生。在迦毗罗国。多游行东天竺六大城。有时飞到南天竺亿耳居士舍受供养。有时暂来北天竺月氏国。降阿波罗龙王。又至月氏国西。降女罗刹。佛在彼石窟中一宿。于今佛影犹在。有人就内看之则不见。出孔遥观光相。如佛有时。暂飞至罽宾隶跋陀仙人山上。住虚空中降此仙人。仙人言。我乐住此中。愿佛与我佛发佛爪。起塔供养。塔于今现存。(此山下有离越寺离越应云隶跋陀)人与佛同国而生犹不遍见。何况异处。以是故不可以不见十方佛故。而言无也。复次弥勒菩萨有大慈悲。而在天宫不来此间。可以不来故便谓无弥勒耶。弥勒近而不来不以为怪。十方佛远何足怪也。复次十方佛不来者。以众生罪垢深重不种见佛功德。是故不来。复次佛知一切众生善根熟结使薄。然后来度。如说

  诸佛先观知有人　　一切方便不可度
  或有难度或易化　　或复有迟或有疾
  或以光明或神足　　种种因缘度众生
  有欲作逆佛愍除　　或欲作逆佛不遮
  刚强难化用粗言　　心柔易度用软言
  虽有慈悲平等心　　知时智慧用方便

以是故十方佛虽不来不应言无。复次佛智慧力方便神通。舍利弗等大阿罗汉。大菩萨弥勒等。尚不能知。何况凡人。复次诸佛大菩萨。有时众生恐惧急难一心念。或时来度之。如大月氏西佛肉髻住处国。一佛图中有人癞风病。来至遍吉菩萨像边。一心自归念遍吉菩萨功德。愿除此病。是时遍吉菩萨像。即以右手宝磲光明。摩其身病即除愈。复一国中有一阿兰若比丘。大读摩诃衍。其国王常布发令蹈上而过。有一比丘语王言。此人摩诃罗不多读经。何以大供养如是。王言我一日夜半欲见此比丘。即往到其住处。见此比丘在窟中读法华经。见一金色光明人骑白象合手供养。我转近便灭。我即问大德以我来故。金色光明人灭。比丘言。此即遍吉菩萨。遍吉菩萨自言。若有人诵读法华经者。我当乘白象来教导之。我诵法华经故遍吉自来。(遍吉法华经名为普贤)复有一国有一比丘。诵阿弥陀佛经及摩诃般若波罗蜜。是人欲死时语弟子言。阿弥陀佛与彼大众俱来。即时动身自归。须臾命终。命终之后弟子积薪烧之。明日。灰中见舌不烧。诵阿弥陀佛经故。见佛自来。诵般若波罗蜜故。舌不可烧。此皆今世现事。如经中说。诸佛菩萨来者甚多。如是处处有人罪垢结薄。一心念佛信净不疑必得见佛。终不虚也。以是诸因缘故。知实有十方佛

【经】尔时彼世界有菩萨。名曰普明

【论】菩萨义如赞菩萨品中已说。问曰。云何名普明。答曰。其明常照一切世界。是故名普明

【经】见此大光见地大动。又见佛身到宝积佛所。白佛言。世尊。今何因缘有此光明照于世间。地大震动。又见佛身

【论】地动佛身光明如先说。问曰。是普明菩萨于诸菩萨中最尊第一。应自知因缘。何以问佛。答曰。是普明菩萨虽大。不能知诸佛智慧神力。譬如月光虽大日出则灭。以是故问佛。复次菩萨常欲见佛心无厌足。无因缘尚欲见佛。何况有大因缘。复次是事不应疑。譬如犊子随母未足怪也。又如小王朝宗大王法应尔故。诸大菩萨亦如是。得利大故常欲随佛。是菩萨见是事。心即觉知是必大事。见无数无量世界。皆得相见。以是故问。复次有人言。是菩萨自有神力能知。亦是释迦牟尼佛力令知。但为诸小菩萨不知故问佛。诸小菩萨怖难未除不能问佛。是故为之发问。是普明菩萨发其世界与诸小男子小女人俱。以是故知不能问佛。譬如大象能劈大树。令诸小象得食枝叶。是故问佛。大德何因何缘。有此大光明地大震动又见佛身

大智度论卷第九大智度初品中十方菩萨来释论第十五之余(卷第十)

        龙树菩萨造

        后秦龟兹国三藏法师鸠摩罗什奉　诏译

【经】宝积佛报普明言。善男子。西方度如恒河沙等世界。有世界名娑婆。是中有佛。号释迦牟尼。今现在欲为诸菩萨摩诃萨说般若波罗蜜。是其神力。【论】问曰。佛譬如须弥山不为大海水波所动。今何以答普明。是则动相摄心则无语。散心则有说。说法从觉观生。觉观粗事。佛不应有此粗事

答曰。佛虽入深禅定。不为世事所动。今以大慈悲心怜愍众生。为之说法断疑。如须弥山王小风则不能动。若随蓝风至则大动散。佛亦如是有大慈悲风来怜愍心动。散身无数入五道教化众生。或作天身乃至畜生。复次佛实不动常入禅定。先世福德因缘故。身边出声应物如响。如天伎乐自然发声。又如摩尼珠随人所欲种种与之。若欲衣被饮食音乐。自恣所须自然皆得。佛亦如是。从其身边诸毛孔中。自然有声随心说法。是中佛无忆想亦无分别。如说密迹金刚经中。佛有三密。身密语密意密。一切诸天人皆不解不知。有一会众生。或见佛身黄金色白银色诸杂宝色。有人见佛身一丈六尺。或见一里十里百千万亿乃至无边无量遍虚空中。如是等名身密。语密者。有人闻佛声一里。有闻十里百千万亿无数无量遍虚空中。有一会中或闻说布施。或有闻说持戒。或闻说忍辱精进禅定智慧。如是乃至十二部经。八万法聚。各各随心所闻是名语密。是时目连心念。欲知佛声近远。即时以己神足力。至无量千万亿佛世界而息。闻佛音声如近不异。所息世界其佛与大众方食。彼土人大。目连立其钵缘。彼佛弟子问其佛言。此人头虫从何所来。着沙门被服而行。其佛报言。勿轻此人。此是东方过无量佛土。有佛名释迦牟尼。此是彼佛神足弟子。彼佛问目度伽略子。汝何以来此。目连答言。我寻佛音声故来至此。彼佛告目连。汝寻佛声过无量亿劫。不能得其边际。复次佛出世为断众生疑故为说法。此不应难。如不应问曰何以除闇。佛亦如是。不应问佛何以故答。问曰。诸佛等故名为等觉。今何以称言是彼神力。答曰。示无吾我彼此灭嫉慢故。复次世界有天。常求尊胜憍慢法故。自言天地人物是我化作。如梵天王。谓诸梵言我作汝等。毗纽天言。世间有大富贵名闻人。皆是我身威德力分。我能成就世间。亦能破坏世间。世间成坏皆是我作。有如是天破因缘法相。诸佛实语不破因缘法相故。言是彼佛神力

【经】是时普明菩萨白宝积佛言。世尊。我今当往见释迦牟尼佛礼拜供养。及见彼诸菩萨摩诃萨绍尊位者。皆得陀罗尼及诸三昧。于诸三昧而得自在

【论】问曰。若诸佛持戒禅定智慧度人皆等。是普明菩萨何以欲来见释迦牟尼佛。答曰。诸菩萨常欲见佛无厌足。听法无厌足。见诸菩萨僧无厌足。诸菩萨于世间法皆以厌患。于上三事心无厌足。如手居士。从净居天来欲见佛。其身微细没失。譬如消苏不得立地。佛语手居士。汝化作粗身观此地相。居士即如佛言。化作粗身观念此地相。头面礼佛足一面立。佛问居士。汝几事无厌生净居天。答言。我三事无厌生净居天。一见诸佛供养无厌。二听法无厌。三供给僧无厌。如佛在阎浮提。四部众常随逐佛听法问法。是我净居诸天。亦常从我听法问法。声闻犹尚听法无厌足。何况法性身菩萨。以是故普明菩萨。来见释迦牟尼佛。及见此间诸菩萨摩诃萨绍尊位者。皆得陀罗尼及诸三昧。如先赞菩萨品中说。于诸三昧而得自在者。问曰。如佛一人一切三昧中得自在。何以言菩萨亦一切三昧中得自在。答曰。有二种三昧。一者佛三昧。二者菩萨三昧。是诸菩萨于菩萨三昧中得自在。非佛三昧中。如说诸佛要集经中。文殊尸利欲见佛集。不能得到。诸佛各还本处。文殊尸利到诸佛集处。有一女人近彼佛坐入三昧。文殊尸利入礼佛足已。白佛言。云何此女人得近佛坐而我不得。佛告文殊尸利。汝觉此女人令从三昧起。汝自问之。文殊尸利即弹指觉之。而不可觉。以大声唤亦不可觉。捉手牵亦不可觉。又以神足动三千大千世界。犹亦不觉。文殊尸利白佛言。世尊。我不能令觉。是时佛放大光明照下方世界。是中有一菩萨。名弃诸盖。即时从下方出。来到佛所头面礼佛足一面立。佛告弃诸盖菩萨。汝觉此女人。即时弹指此女从三昧起。文殊尸利白佛言。以何因缘。我动三千大千世界。不能令此女起。弃诸盖菩萨一弹指便从三昧起。佛告文殊尸利。汝因此女人。初发阿耨多罗三藐三菩提意。是女人因弃诸盖菩萨。初发阿耨多罗三藐三菩提意。以是故汝不能令觉。汝于诸佛三昧中功德未满。是诸菩萨三昧中得自在。佛三昧中少多入而未得自在故耳

【经】佛告普明。欲往随意宜知是时。尔时宝积佛以千叶金色莲华与普明菩萨。而告之曰。善男子。汝以此华散释迦牟尼佛上。生彼娑婆世界诸菩萨难胜难及。汝当一心游彼世界

【论】问曰。佛何以言欲往随意宜知是时。答曰。佛于弟子爱断故。于弟子中心不着故。复次是菩萨未得一切智。未得佛眼故。心中少多有疑。谓释迦牟尼佛功德大所益或胜。是故语言欲往随意。复次是菩萨遥见释迦牟尼佛身小。心生小慢言。彼佛不如是。故佛语。汝往莫观佛身勿念世界。但听佛说法。复次是世界离娑婆世界极远最在东边。是诸菩萨闻释迦牟尼佛所说诸法相。与宝积佛说诸法相正同。便言世界虽远法相不异。增益大信心转坚固。复次先世因缘故。虽远处生应来听法。譬如绳系雀脚虽复远飞摄之则还。复次是娑婆世界中菩萨。见普明远来听法。便作是念。彼从远来。况我生此世界中而不听法。如是种种因缘。是故佛言欲往随意宜知是时。问曰。诸佛力等更不求福。何故以华为信。答曰。随世间法行故。如二国王力势虽同亦相赠遗。复次示善软心故以华为信。世间法中使从远来必应有信。佛随世法是故致信。复次诸佛恭敬法故供养于法。以法为师。何以故。三世诸佛皆以诸法实相为师。问曰。何以不自供养身中法。而供养他法。答曰。随世间法。如比丘欲供养法宝。不自供养身中法。而供养余持法知法解法者。佛亦如是虽身中有法。而供养余佛法。问曰。如佛不求福德。何以故供养。答曰。佛从无量阿僧祇劫中。修诸功德常行诸善。不但求报敬功德故而作供养。如佛在时有一盲比丘。眼无所见而以手缝衣时针纴脱。便言。谁爱福德为我纴针。是时佛到其所语比丘。我是爱福德人。为汝纴针来。是比丘识佛声。疾起着衣礼佛足白佛言。佛功德已满。云何言爱福德。佛报言。我虽功德已满。我深知功德恩功德果报功德力。令我于一切众生中得最第一。由此功德。是故我爱。佛为此比丘赞功德已。次为随意说法。是比丘得法眼净肉眼更明。复次佛虽功德已满更无所须。为教化弟子故。语之言。我尚作功德汝云何不作。如伎家百岁老翁而舞。有人呵之言。老翁年已百岁何用是舞。翁答。我不须舞。但欲教子孙故耳。佛亦如是。功德虽满。为教弟子作功德故。而作供养。问曰。若尔者佛何以不自遥散释迦牟尼佛上。而遣人供养。答曰。为此间诸菩萨信普明故。复次佛所遣使。水火兵毒百千种害终不能伤。道里悬远欲令安隐故。问曰。何故不以好宝深经若佛菩萨宝(言此宝诸天所不见能出种种妙物如摩尼珠宝故曰名佛宝)为信。而以莲华莲华小物何足为信。答曰。佛不须物。佛宝天宝尚亦不须。何况人宝。以不须故不遣。亦以佛自等有故不遣。深经亦尔。复次诸经于佛则无甚深。甚深之称出自凡人。凡人所疑于佛无碍。凡人所难佛皆易之。复次华香清妙宜为供养。如人献赠必以异物。问曰。何故正以莲华不以余物。答曰。供养唯以华香幡盖。华有二事有色有香。问曰。余华亦有香有色。何故唯以莲华供养。答曰。如华手经中说。十方佛皆以华供养释迦文佛。复次莲华有三种。一者人华二者天华三者菩萨华。人华大莲华十余叶。天华百叶。菩萨华千叶。彼世界中多有金色光明千叶莲华。娑婆世界中。唯有化华千叶。无水生者。以是故遣是莲华千叶金色。如上舌相中说。问曰。佛何以令普明以华散佛上。答曰。供养法华香幡盖。幡盖应上干香应烧。湿香应涂地。末香及华应散。问曰。何以不供奉而已而自散上。答曰。手自供养是身业。软言问讯是口业。能起身口业是意业。是三业得功德牢固。与佛道作因缘。问曰。何以言汝当一心敬慎。娑婆世界中诸菩萨难及难胜。答曰。佛辟支佛阿罗汉一切诸贤圣。皆一心敬慎。魔若魔民及内身结使。种种先世罪报皆是贼。近此诸贼故应一心敬慎。譬如入贼中行不自慎护为贼所得。以是故言一心敬慎以游彼界。复次以人心多散如狂如醉。一心敬慎则是诸功德初门。摄心得禅。便得实智慧。得实智慧便得解脱。得解脱便得尽苦。如是事皆从一心得。如佛般涅槃后一百岁有一比丘。名优波鞠。得六神通阿罗汉。当尔时世为阎浮提大导师。彼时有一比丘尼。年百二十岁。此比丘尼年小时见佛。优波鞠来入其舍。欲问佛容仪。先遣弟子。弟子语比丘尼。我大师优波鞠。欲来见汝问佛容仪。是时比丘尼。以钵盛满麻油着户扇下试之。知其威仪详审以不。优波鞠入徐排户扇麻油小弃。坐已问比丘尼。汝见佛不。容仪何似。为我说之。比丘尼答。我尔时年小见佛来入聚落。众人言佛来。我亦随众人出见光明便礼。头上金钗堕地在大闇林下。佛光明照之幽隐皆见即时得钗。我自是后乃作比丘尼。优波鞠更问。佛在世时比丘威仪礼法何如。答曰。佛在时六群比丘无羞无耻最是弊恶。威仪法则胜汝。今日何以知之。六群比丘入户不令油弃。此虽弊恶知比丘仪法。行住坐卧不失法则。汝虽是六神通阿罗汉不如彼也。优波鞠闻是语大自惭愧。以是故言一心敬慎。一心敬慎善人相也。复次何以故言一心敬慎。是菩萨难胜难及难破难近。譬如大师子王难胜难破。亦如白象王及龙王。如大火焰。皆难可近。是菩萨大福德智慧力故。若人欲胜欲破是不可得正可自破。是故言难近。问曰。一切大菩萨皆大功德智慧利根一切难近。何以独言娑婆世界中菩萨难近。答曰。实如所言。但以多宝世界中菩萨远来。见此世界不如石沙秽恶。菩萨身小。一切众事皆亦不如。必生轻慢。是故佛言一心敬慎。彼诸菩萨难近。复次乐处生人。多不勇猛不聪明少智慧。如郁怛罗卫人。以大乐故无出家无受戒。诸天中亦尔。是娑婆世界中是乐因缘少。有三恶道老病死。土地自活法难。以是故易得厌心。见老病死至心大厌患。见贫穷人知先世因缘所致心生大厌。以是故智慧根利。彼间菩萨七宝世界种种宝树。心念饮食应意即得。如是生厌心难。是故智慧不能大利。譬如利刀着好饮食中。刀便生垢。饮食虽好而与刀不相宜。若以石磨之脂灰莹治垢除刀利。是菩萨亦如是。生杂世界中利智难近。如人少小勤苦多有所能。亦多有所堪。又如养马不乘则无所任。复次是娑婆世界中菩萨。多方便故难近。余处不尔。如佛说我自忆念宿世。一日施人千命度众生故。虽诸功德六波罗蜜一切佛事具足。而不作佛。恒以方便度脱众生以是事故。是娑婆世界中菩萨难近

【经】尔时普明菩萨从宝积佛受千叶金色莲花。与无数出家在家菩萨及诸童男童女。俱共发引

【论】问曰。是普明菩萨大力神通故应能来。是出家在家菩萨。及童男童女云何自致。多宝世界最在东边道里悠远。是自用力行为宝积佛力。是普明菩萨力耶。为释迦牟尼佛力。答曰。尽是四种人力。是出家居家菩萨。或是不退五通成就菩萨。四如意足好修先世释迦牟尼佛因缘。亦自用己力。亦是普明菩萨力。何以故。是中力势薄者。是普明菩萨力故得来。如转轮圣王飞上天。时四种兵及诸宫观畜兽一切皆飞。转轮圣王功德大故。能令一切随而飞从。此亦如是。力势薄者以普明菩萨力故皆亦得来。亦是宝积佛力。及释迦牟尼光明照之。若自无力但释迦牟尼佛光明照之。亦应能来。何况有三。问曰。是普明菩萨何不独来。而多将众人。答曰。翼从所宜故。譬如国王出时必有营从。复次是普明菩萨。及释迦牟尼佛因缘人故。所以者何。彼大众中二众共来。是故知有因缘者来。无因缘者住。问曰。是菩萨何以故。与诸在家出家童男童女俱来。答曰。佛弟子七众。比丘比丘尼学戒尼沙弥沙弥尼优婆塞优婆夷。优婆塞优婆夷是居家。余五众是出家。出家在家中更有二种。若大若小。小者童男童女。余者为大。问曰。大者应行。小者何以能来。答曰。在功德不在大小。若失功德利行不善法虽老而小。若有功德利行善法虽小而大。复次此小者远来。人见则叹。小而能尔为法远来。亦显佛法小大皆得奉行。外道法中婆罗门得行其法。非婆罗门不得行。佛法无大无小无内无外。一切皆得修行。譬如服药以除病为主。不择贵贱大小

【经】皆供养恭敬尊重赞叹东方诸佛

【论】问曰。若皆供养东方诸佛诸佛甚多。何时当讫得来此间。答曰。是诸菩萨非作人天法供养。自行菩萨供养法。菩萨供养法。身入禅定其身直进。从其身边出无量身。化作种种供养之物满诸佛世界。譬如龙王行时从身出水普雨天下。问曰。此诸菩萨欲诣释迦牟尼佛。何以中道供养诸佛。答曰。诸佛第一福田。若供养者得大果报。譬如人广修田业为多得谷故。诸菩萨见诸佛供养得佛果报。是故供养。复次菩萨常敬重于佛。如人敬重父母。诸菩萨蒙佛说法。得种种三昧种种陀罗尼种种神力。知恩故广供养。如法华经中药王菩萨。从佛得一切变现色身三昧。作是思惟我当云何供养佛及法华三昧。即时飞到天上。以三昧力雨七宝华香幡盖供养于佛。出三昧已意犹不足。于千二百岁。服食众香饮诸香油。然后以天白叠缠身而烧。自作誓言。使我身光明照八十恒河沙等佛世界。是八十恒河沙等世界中。诸佛赞言。善哉善哉善男子。以身供养是为第一胜。以国城妻子供养百千万倍。不可以譬喻为比。于千二百岁身然不灭。复次是供养佛。得无量名闻福德利益。诸不善事皆悉灭除。诸善根得增长。今世后世常得供养报。久后得作佛。如是供养佛得种种无量利。以是故诸菩萨供养佛

【经】持诸华香。璎珞。末香泽香烧香涂香。衣服幢盖。向释迦牟尼佛所。到已头面礼佛足一面立。【论】问曰。应言礼。何以名头面礼足。答曰。人身中第一贵者头。五情所著而最在上故。足第一贱。履不净处最在下故。是故以所贵礼所贱。贵重供养故。复次有下中上礼。下者揖。中者跪。上者稽首。头面礼足是上供养。以是故佛毗尼中。下坐比丘两手捉上坐两足。以头面礼。问曰。四种身仪若坐若立若行若卧。何以故一面立。答曰。为来故不应行。为恭敬供养故不应卧。此事易明何足问耶。应问或坐或立。坐者于供养不重。立者恭敬供养法。复次佛法中。诸外道出家及一切白衣来到佛所皆坐。外道他法轻佛故坐。白衣如客是故坐。一切五众身心属佛。是故立。若得道诸阿罗汉。如舍利弗目连须菩提等所作已办。是故听坐。余虽得三道亦不听坐。大事未办。结贼未破故。譬如王臣大有功勋故得坐。是诸菩萨中。虽有白衣以从远来供养佛故立

【经】白佛言。宝积如来致问世尊。少恼少患兴居轻利气力安乐不。又以此千叶金色莲华供养世尊

【论】问曰。宝积佛一切智。何以方问讯释迦牟尼佛。少恼少患兴居轻利气力安乐不。答曰。诸佛法尔。知而故问。如毗尼中。达贰迦比丘作赤色瓦窟。佛见已知而问阿难。此作何物。阿难白佛。是陶家子出家。字达贰迦。作小草舍常为放牛人所坏。三作三破。是故作此瓦舍。佛语阿难。破此瓦窟。何以故。外道辈当言。佛大师在时漏处法出。如是等处处知而故问。复次佛虽一切智。随世界法。世人问讯佛亦问讯。佛人中生受人法。寒热生死与人等。问讯法亦应等。复次世界中大贵大贱不应相问讯。佛等力故应相问讯。复次是多宝世界清净庄严。佛身色像光明亦大。若不问讯人谓轻慢。又复欲示佛世界身色光明种种虽胜。智慧神力俱等无异。是故问讯。问曰。何以问少病少恼不。答曰。有二种病。一者外因缘病。二者内因缘病。外者寒热饥渴兵刃刀杖坠落堆压。如是等种种外患名为恼。内者饮食不节卧起无常四百四病。如是等种种名为内病。如此二病有身皆苦。是故问少恼少患不。问曰。何以不问无恼无病。而问少恼少患。答曰。圣人实知身为苦本无不病时。何以故。是四大合而为身。地水火风性不相宜。各各相害。譬如疽疮无不痛时。若以药涂可得少差。而不可愈。人身亦如是。常病常治。治故得活。不治则死。以是故不得问无恼无病。外患常有风雨寒热为恼故。复有身四威仪坐卧行住。久坐则极恼。久卧久住久行皆恼。以是故问少恼少患。问曰。问少恼少患则足。何以复言兴居轻利。答曰。人虽病差未得平复。以是故问兴居轻利。问曰。何以故言气力安乐不。答曰。有人病差虽能行步坐起。气力未足不能造事施为携轻举重故。问气力。有人虽病得差能举重携轻。而未受安乐。是故问安乐不。问曰。若无病有力。何以未受安乐。答曰。有人贫穷恐怖忧愁。不得安乐。以是故问得安乐不。复次有二种问讯法。问讯身问讯心。若言少恼少病兴居轻利及气力。是问讯身。若言安乐不。是问讯心。种种内外诸病名为身病。淫欲嗔恚嫉妒悭贪忧愁怖畏等。种种烦恼九十八结五百缠。种种欲愿等。名为心病。是一一病问讯故。言少恼少病兴居轻利气力安乐不。问曰。人问讯则应尔。诸天尚不应如此问讯。何况于佛。答曰。佛身二种。一神通变化身。二父母生身。父母生身受人法故不如天。是故应如人法问讯。问曰。一切贤圣心无所著。不贪身不惜寿不恶死不悦生。若如是者何用问讯。答曰。随世界法故。受人法问讯。遣问讯亦以人法。千叶金色莲华如上说

【经】尔时释迦牟尼佛受是千叶金色莲华已。散东方恒河沙等世界中佛

【论】问曰。佛无胜如今何以故。向东方诸佛散华供养。如佛初得道时。自念人无所尊则事业不成。今十方天地谁可尊事者。我欲师而事之。是时梵天王等诸天白佛。佛为无上。无过佛者。佛亦自以天眼观三世十方天地中无胜佛者。心自念言。我行摩诃般若波罗蜜。今自致作佛。是我所尊即是我师。我当恭敬供养尊事是法。譬如有树名为好坚。是树在地中百岁枝叶具足。一日出生高百丈。是树出已欲求大树以荫其身。是时林中有神语好坚树言。世中无大汝者。诸树皆当在汝荫中。佛亦如是。无量阿僧祇劫在菩萨地中。生一日于菩提树下金刚座处坐。实知一切诸法相得成佛道。是时自念。谁可尊事以为师者。我当承事恭敬供养。时梵天王等诸天白佛言。佛为无上。无过佛者。今何以故复供养东方诸佛。答曰。佛虽无上三世十方天地中无过佛者。而行供养。供养有上中下。下于己者而供养之是下供养。供养胜己是上供养。供养与己等者是中供养。诸佛供养是中供养。如大爱道比丘尼。与五百阿罗汉比丘尼等。一日中一时入涅槃。是时诸得三道优婆塞举五百床。四天王举佛乳母大爱道床。佛自在前擎香炉烧香供养。佛语比丘。汝等助我供养乳母身。尔时诸阿罗汉比丘。各各以神足力。到摩梨山上。取牛头栴檀香薪。助佛作[卄/積]。是为下供养。以是故虽不求果。而行等供养。复次唯佛应供养佛。余人不知佛德。如偈说

  智人能敬智　　智论则智喜
  智人能知智　　如蛇知蛇足

以是故诸佛一切智。能供养一切智。复次是十方佛世世劝助释迦牟尼佛。如七住菩萨。观诸法空无所有不生不灭。如是观已于一切世界中心不着。欲放舍六波罗蜜入涅槃。譬如人梦中作筏渡大河水。手足疲劳生患厌想。在中流中梦觉已自念言。何许有河而可渡者。是时勤心都放。菩萨亦如是立七住中得无生法忍。心行皆止欲入涅槃。尔时十方诸佛。皆放光明照菩萨身。以右手摩其头语言。善男子勿生此心。汝当念汝本愿欲度众生。汝虽知空众生不解。汝当集诸功德教化众生共入涅槃。汝未得金色身三十二相八十种随形好无量光明三十二业。汝今始得一无生法门。莫便大喜。是时菩萨闻诸佛教诲。还生本心行六波罗蜜以度众生。如是等初得佛道时得是佐助。又佛初得道时心自思惟。是法甚深众生愚蒙薄福。我亦五恶世生。今当云何念已我当于一法中作三分。分为三乘以度众生。作是思惟时。十方诸佛皆现光明赞言善哉善哉。我等亦在五恶世中。分一法作三分以度众生。是时佛闻十方诸佛语声即大欢喜。称言南无佛。如是十方佛处处劝助为作大利。知恩重故。以华供养十方佛。最上福德无过此德。何以故是华宝积佛功德力所生。非是水生华。普明是十住法身菩萨。送此华来上释迦牟尼佛。释迦牟尼佛知十方佛是第一福田故以供养。是福倍多。何以故。佛自供养佛故。佛法中有四种布施。一施者清净受者不净。二施者不净受者清净。三施者清净受者亦净。四施者不净受者不净。今施东方诸佛。是为二俱清净。是福最大。以是故佛自供养十方佛。问曰。一切圣人不受报果。后更不生。云何言是施福最大。答曰。是福虽无人受其相自大。若有人受者其报无量。诸圣人知有为法皆无常空故。舍入涅槃是福亦舍。譬如烧金丸。虽眼见其好不可以手触。烧人手故。复次如人有疮则须药涂。若无疮者药无所施。人有身亦如是。常为饥渴寒热所逼。亦如疮发。以衣被饮食温暖将适。如药涂疮。如愚痴人。为贪药故不用除疮。若其无疮药亦无用。诸佛以身为疮。舍放身疮故亦不受报药。以是故虽有大福亦不受报

【经】所散莲华满东方如恒河沙等诸佛世界【论】问曰。华少而世界多云何满。答曰。佛神通力故。如上八种。自恣变化法大能令小小能令大。轻能令重重能令轻。自在无碍随意所到。能动大地所愿能办。诸大圣人皆得是八种自在。是故佛能以小华满东方如恒河沙等世界。又复以示众生。未来福报。如此少华满东方世界。又劝东方菩萨言。殖福于佛田中。所得果报亦如此华弥满无量土。汝虽远来应当欢喜。遇此大福田果报无量

【经】一一华上皆有菩萨。结加趺坐说六波罗蜜。闻此法者毕至阿耨多罗三藐三菩提

【论】问曰。上佛以舌相光明。化作千叶宝华。一一华上皆有坐佛。今何以故一一华上皆有坐菩萨。答曰上是佛所化华故有坐佛。此是普明菩萨所供养华。是故有坐菩萨。复次上诸众生。应见坐佛得度。今此众生应见坐菩萨得度。结加趺坐说六波罗蜜。闻此法者毕至阿耨多罗三藐三菩提。如先说

【经】诸出家在家菩萨及诸童男童女头面礼释迦牟尼佛足。各以供养具供养恭敬尊重赞叹释迦牟尼佛。是诸出家在家菩萨及诸童男童女。各各以善根福德力故。得供养释迦牟尼佛多陀阿伽度阿罗呵三藐三佛陀

【论】如说偈

  诸圣所来道　　佛亦如是来
  实相及所去　　佛亦尔无异
  诸圣如实语　　佛亦如实说
  以是故名佛　　多陀阿伽度
  忍铠心坚固　　精进弓力强
  智慧利劲箭　　破憍慢诸贼
  应受天世人　　一切诸供养
  以是故名佛　　以为阿罗诃
  正知苦实相　　亦实知苦集
  知苦灭实相　　亦知苦灭道
  真正解四谛　　定实不可变
  是故十方中　　号三藐三佛
  得微妙三明　　清净行亦具
  是故号世尊　　鞞阇遮罗那
  解知一切法　　自得妙道去
  或时方便说　　愍念一切故
  灭除老病死　　令到安隐处
  以是故名佛　　以为修伽陀
  知世所从来　　亦知世灭道
  以是故名佛　　为路迦鞞陀
  禅戒智等眼　　无及况出上
  以是故名佛　　为阿耨多罗
  大悲度众生　　软善教调御
  以是故名佛　　富楼沙昙藐
  智慧无烦恼　　说最上解脱
  以是故名佛　　提婆摩[少/(兔-、)]舍
  三世动不动　　尽及不尽法
  道树下悉知　　是故名为佛

【经】南方度如恒河沙等诸佛世界。其土最在边。世界名离一切忧。佛号无忧德。菩萨名离忧。西方度如恒河沙等诸佛世界。其世界最在边。世界名灭恶。佛号宝山。菩萨名仪意。北方度如恒河沙等诸佛世界。其世界最在边。世界名胜。佛号胜王。菩萨名得胜。下方度如恒河沙等诸佛世界。其世界最在边。世界名善。佛号善德。菩萨名华上。上方度如恒河沙等诸佛世界。其世界最在边世界名喜。佛号喜德。菩萨名得喜。如是一切皆如东方

【论】问曰。如佛法中。实无诸方名。何以故。诸五众十二入十八界中所不摄。四法藏中亦无说方。是实法因缘求亦不可得。今何以故。此中说十方诸佛十方菩萨来。答曰。随世俗法所传故说方。求方实不可得。问曰。何以言无方。汝四法藏中不说。我六法藏中说。汝众入界中不摄。我陀罗骠中摄。是方法常相故。有相故。亦有亦常。如经中说。日出处是东方。日没处是西方。日行处是南方日不行处是北方。日有三分合。若前合若今合若后合。随方日分。初合是东方。南方西方亦如是。日不行处是无分。彼间此间彼此是方相。若无方无彼此。彼此是方相。而非方。答曰。不然。须弥山在四域之中。日绕须弥照四天下。郁怛罗越日中。是弗婆提日出。于弗婆提人是东方。弗婆提日中。是阎浮提日出。于阎浮提人是东方。是实无初。何以故。一切方皆东方。皆南方。皆西方。皆北方。汝言日出处是东方。日行处是南方。日没处是西方。日不行处是北方。是事不然。复次有处日不合。是为非方。无方相故。问曰。我说一国中方相。汝以四国为难。以是故东方非无初。答曰。若一国中日与东方合。是为有边。有边故无常。无常故是不遍。以是故。方但有名而无实

【经】尔时是三千大千世界变成为宝华。遍覆地悬缯幡盖。香树华树皆悉庄严

【论】问曰。此谁神力令地为宝。答曰。是佛无量神力变化所为。有人咒术幻法。及诸鬼神龙王诸天等。能变化少物。令三千大千世界皆为珍宝。余人及梵天王皆所不能。佛入四禅中十四变化心。能令三千大千世界华香树木一切土地皆悉庄严。一切众生皆悉和同心转为善。何以故。庄严此世界。为说般若波罗蜜故。亦为十方诸菩萨客来及诸天世人故庄严。如人请贵客。若一家请则庄严一家。一国主则庄严一国。转轮圣王则庄严四天下。梵天王则庄严三千大千世界。佛为十方无量恒河沙等诸世界中主。是诸他方菩萨及诸天世人客来故。亦为此彼众人见此变化庄严。则生大心生清净欢喜心。从大心发大业。从大业得大报。受大报时更生大心。如是展转增长。得成阿耨多罗三藐三菩提。以是故变此世界皆悉为宝。云何名宝。宝有四种。金银毗琉璃颇梨。更有七种宝金银毗琉璃颇梨车磲马瑙赤真珠。(此珠极贵非是珊瑚)更复有宝。摩罗伽陀(此珠金翅鸟口边出绿色能辟一切毒)因陀尼罗(天青珠)摩诃尼啰(大青珠)钵摩罗伽(赤光珠)越阇(金刚)龙珠如意珠玉贝珊瑚琥珀等种种名为宝。是宝有三种。有人宝天宝菩萨宝。人宝力少唯有清净光色。除毒除鬼除闇。亦除饥渴寒热种种苦事。天宝亦大亦胜常随逐天身。可使令可共语。轻而不重。菩萨宝胜于天宝。能兼有人宝天宝事。又能令一切众生知死此生彼因缘本末。譬如明镜见其面像。复次菩萨宝胜能出种种法音。若为首饰宝冠。则雨十方无量世界诸佛上幢幡华盖种种供养之具。以供养佛。又雨衣被卧具生活之物。种种众事随众生所须。皆悉雨之给施众生。如是等种种众宝。以除众生贫穷苦厄。问曰。是诸珍宝从何处出。答曰。金出山石沙赤铜中。真珠出鱼腹中竹中蛇脑中。龙珠出龙脑中。珊瑚出海中石树。生贝出虫甲中。银出烧石。余琉璃颇梨等皆出山窟中。如意珠出自佛舍利。若法没尽时。诸舍利皆变为如意珠。譬如过千岁冰化为颇梨珠。如是等诸宝是人中常宝。佛所庄严一切世界是最殊胜。诸天所不能得。何以故。是从大功德所生。种种华幡如先说。香树者名阿伽楼(蜜香树)多伽楼(木香树)栴檀。如是等种种香树。华树名占匍(黄华树)阿输迦(无忧花树)婆呵迦罗(赤华树)如是等种种华树

【经】譬如华积世界普华世界。妙德菩萨善住意菩萨。及余大威神诸菩萨。皆在彼住

【论】问曰。何以言譬如华积世界。答曰。彼世界常有净华。此世界变化一时故。以喻也。譬喻法以小喻大。如人面好譬如满月。问曰。更有十方诸清净世界。如阿弥陀佛安乐世界等。何以故。但以普华世界为喻。答曰。阿弥陀佛世界不如华积世界。何以故。法积比丘佛虽将至十方观清净世界。功德力薄不能得见上妙清净世界。以是故世界不如。复次当佛变化此世界时。正与华积世界相似。以是故言譬如华积世界。问曰。更有余大菩萨。如毗摩罗诘观世音遍吉菩萨等。何以不言此诸菩萨在彼住。而但言文殊尸利善住意菩萨。答曰。是遍吉菩萨一一毛孔常出诸佛世界及诸佛菩萨。遍满十方。以化众生无适住处。文殊尸利分身变化入五道中。或作声闻或作缘觉或作佛身。如首楞严三昧经中说。文殊师利菩萨。过去世作龙种尊佛。七十二亿世作辟支迦佛。是可言可说。遍吉菩萨。不可量不可说住处不可知。若住应在一切世界中住。是故不说。复次及诸大威神菩萨者。亦应总说遍吉等诸大菩萨

【经】尔时佛知一切世界若天世界若魔世界若梵世界。若沙门若婆罗门及天。若揵闼婆人阿修罗等。及诸菩萨摩诃萨。绍尊位者一切皆集

【论】问曰。佛神力无量。一切十方众生。若尽来在会者。一切世界应空。若不来者。佛无量神力有所不能。答曰。不应尽来。何以故。诸佛世界无边无量。若尽来者便为有边。又复十方各各有佛。亦说般若波罗蜜。如彼般若波罗蜜四十三品中。十方面各千佛现皆说般若波罗蜜。以是故不应尽来。问曰。若有十方诸佛皆说般若波罗蜜。十方诸菩萨何以故来。答曰。如普明菩萨来章中已说。与释迦牟尼佛因缘故来。复次是诸菩萨本愿故。若有说般若波罗蜜处。我当听受供养。是以远来欲以身力积功德故。亦以示诸众生我从远来供养法故。云何汝在此世界而不供养。问曰。佛于法不着。何以故。七现神力而令众生大集。答曰。是般若波罗蜜。甚深难知难解不可思议。是故广集诸大菩萨。令新发意者心得信乐。譬如小人所语不为人信。贵重大人人必信受。问曰。何以故言若天世界若魔世界若梵世界。但应言天世界人世界则足。何以故。十号中言天人师。以是故应言天人而已。答曰。诸天有天眼天耳利根智慧多自知来。以是故言天世界。问曰。若天世界已摄魔梵。何以故别说若魔若梵。答曰。天中有三大主。释提婆那民二处天主。魔王六欲天主。梵世界中大梵天王为主。问曰。如夜魔天兜率陀天化乐天皆有主。何以但有三主。答曰。释提婆那民依地住。佛亦在地住。常来佛所大有名称人多识故。魔王常来娆佛。又是一切欲界中主。夜摩天兜率陀天化乐天皆属魔王。复次天世界则三界天皆摄是天中。一切欲界魔为主。是故别说。复次魔常娆佛。今来听般若波罗蜜。余人增益信故。问曰。色界中大有天。何以但言梵世界集。答曰。上诸天无觉观不喜散心。又难闻故。梵世界有四识易闻故。又梵世界近故。复次梵名离欲清净。今言梵世界。已总说色界诸天。复次余天未有人民。劫初生时梵天王独在梵宫寂漠无人。其心不悦而自生念。此间何以不生人民。是时光音天命尽者应念来生。梵王便自生念。此诸天先无随我念故生。我能生此诸天。诸天是时亦各自念。我从梵王生。梵王是我父也。以是故但说梵世界。复次二禅三禅四禅天。于欲界见佛听法。若劝助菩萨。眼识耳识身识皆在梵世界中取。以是故别说梵世界。问曰。何以故独说诸沙门婆罗门。不说国王及长者诸余人众。答曰。智慧人有二分。沙门婆罗门。出家名沙门。在家名婆罗门。余人心存世乐。是故不说。婆罗门多学智慧求福。出家人一切求道。是故但说沙门婆罗门。在家中七世清净。生满六岁皆受戒名婆罗门。是沙门婆罗门中。有道德智慧。以是故说。问曰。先已说天世界。今何以复说天。答曰。天世界是四天王忉利天。魔是他化自在天。梵是色界。今说天是欲界中夜摩兜率陀化乐爱身天等。爱身在六天上。形色绝妙故言爱身。问曰。何以但说揵闼婆。不说诸余鬼神及龙王。答曰。是揵闼婆是诸天伎人随逐诸天。其心柔软福德力小减诸天诸鬼神。鬼神道中摄。龙王畜生道中摄。甄陀罗亦是天伎皆属天。与天同住共坐饮食。伎乐皆与天同。是揵闼婆王名童笼磨。(秦言树)是揵闼婆甄陀罗恒在二处住。常所居止在十宝山间。有时天上为诸天作乐。此二种常番休上下。人在四天下生。生有四种。极长寿乃至无量岁。极短寿乃至十岁。阿修罗恶心斗诤。而不破戒大修施福。生在大海边住。亦有城郭宫殿。是阿修罗王。名毗摩质多婆梨罗睺罗。如是等名阿修罗王。如说一时罗睺罗阿修罗王欲啖月。月天子怖疾到佛所。说偈言

  大智成就佛世尊　　我今归命稽首礼
  是罗睺罗恼乱我　　愿佛怜愍见救护

佛与罗睺罗而说偈言

  月能照闇而清凉　　是虚空中大灯明
  其色白净有千光　　汝莫吞月疾放去

是时罗睺罗怖懅流汗即疾放月。婆梨阿修罗王见罗睺罗惶怖放月。说偈问曰

  汝罗睺罗何以故　　惶怖战栗疾放月
  汝身流汗如病人　　心怖不安乃如是

罗睺罗尔时说偈答曰

  世尊以偈而敕我　　我不放月头七分
  设得生活不安隐　　以故我今放此月

婆梨阿修罗王说偈

  诸佛甚难值　　久远乃出世
  说此清净偈　　罗睺即放月

问曰。何以不说地狱畜生饿鬼。答曰。地狱大苦心乱不能受法。畜生愚痴覆心不能受化。饿鬼为饥渴火烧身故不得受法。复次畜生饿鬼中。少多有来听法者。生福德心而已不堪受道。是故不说。问曰。若尔者揵闼婆阿修罗亦不应说。何以故。鬼神道中已摄故。答曰。佛不说摄。今何以言摄。此是迦旃延子等说。如阿修罗力与天等。或时战斗胜天。揵闼婆是诸天伎。与天同受福乐。有智慧能别好丑。何以不得受道法。如杂阿含天品中说。富那婆薮鬼神母。佛游行宿其处。尔时世尊说上妙法甘露。女男二人啼泣。母为说偈止之

  汝郁怛罗勿作声　　富那婆薮亦莫啼
  我今闻法得道证　　汝亦当得必如我

以是事故知。鬼神中有得道者。复次摩诃衍中。密迹金刚力士于诸菩萨中胜。何况余人。如屯仑摩甄陀罗王揵闼婆王。至佛所弹琴赞佛。三千世界皆为震动。乃至摩诃迦叶不安其坐。如此人等云何不能得道。如诸阿修罗王龙王。皆到佛所问佛深法。佛随其问而答深义何以言不能得道。问曰。于五道众生中。佛是天人师不说三恶道。以其无福无受道分故。是诸龙鬼皆堕恶道中。答曰。佛亦不分明说五道。说五道者是一切有部僧所说。婆蹉弗妒路部僧说有六道。复次应有六道。何以故。三恶道一向是罪处。若福多罪少。是名阿修罗揵闼婆等生处应别。以是故应言六道。复次三恶道亦有受道。福少故言无。及诸菩萨绍尊位者如先说

大智度论卷第十大智度论释初品中舍利弗因缘第十六(卷第十一)

        龙树菩萨造

        后秦龟兹国三藏鸠摩罗什奉　诏译

【经】佛告舍利弗

【论】问曰。般若波罗蜜是菩萨摩诃萨法。佛何以故告舍利弗而不告菩萨。答曰。舍利弗于一切弟子中智慧最第一。如佛偈说

  一切众生智　　唯除佛世尊
  欲比舍利弗　　智慧及多闻
  于十六分中　　犹尚不及一

复次舍利弗智慧多闻有大功德。年始八岁诵十八部经。通解一切经书义理。是时摩伽陀国有龙王兄弟。一名姞利二名阿伽罗。降雨以时国无荒年。人民感之。常以仲春之月一切大集至龙住处。为设大会作乐谈义终此一日。自古及今斯集未替。遂以龙名以名此会。此日常法敷四高座。一为国王。二为太子。三为大臣。四为论士。尔时舍利弗以八岁之身。问众人言。此四高座为谁敷之。众人答言。为国王太子大臣论士。是时舍利弗观察时人婆罗门等。神情瞻向无胜己者。便升论床结跏趺坐。众人疑怪。或谓愚小无知。或谓智量过人。虽复嘉其神异。而犹各怀自矜。耻其年小不自与语。皆遣年少弟子传言问之。其答酬旨趣辞理超绝。时诸论师叹未曾有。愚智大小一切皆伏。王大欢喜即命有司。封一聚落常以给之。王乘象舆振铃告告宣示一切十六大国六大城中无不庆悦。是时告占师子名拘律陀。姓大目揵连。舍利弗友而亲之。舍利弗才明见重。目揵连豪爽最贵。此二人者才智相比德行互同。行则俱游住则同止。少长缱绻结要终始。后俱厌世出家学道作梵志弟子。情求道门久而无征。以问于师。师名删阇耶。而答之言。自我求道弥历年岁。不知为有道果无耶。我非其人耶而亦不得。他日其师寝疾。舍利弗在头边立。大目连在足边立。喘喘然其命将终。乃愍尔而笑。二人同心俱问笑意。师答之言。世俗无眼为恩爱所侵。我见金地国王死。其大夫人自投火[卄/積]求同一处。而此二人行报各异生处殊绝。是时二人笔受师语。欲以验其虚实。后有金地商人。远来摩伽陀国。二人以疏验之果如师语。乃怃然叹曰。我等非其人耶。为是师隐我耶。二人相与誓曰。若先得甘露要毕同味。是时佛度迦叶兄弟千人。次游诸国到王舍城顿止竹园。二梵志师闻佛出世。俱入王舍城欲知消息。尔时有一比丘。名阿说示。(五人之一)着衣持钵入城乞食。舍利弗见其仪服异容诸根静默。就而问言。汝谁弟子师是何人。答言。释种太子厌老病死苦出家。学道得阿耨多罗三藐三菩提。是我师也。舍利弗言。汝师教授为我说之。即答偈曰

  我年既幼稚　　学日又初浅
  岂能宣至真　　广说如来义

舍利弗言。略说其要。尔时阿说示比丘。说此偈言

  诸法因缘生　　是法说因缘
  是法因缘尽　　大师如是说

舍利弗闻此偈已即得初道。还报目连。目连见其颜色和悦迎谓之言。汝得甘露味耶。为我说之。舍利弗即为其说向所闻偈。目连言。更为重说。即复为说。亦得初道。二师与二百五十弟子俱到佛所。佛遥见二人与弟子俱来。告诸比丘。汝等见此二人在诸梵志前者不。诸比丘言。已见。佛言。是二人者。是我弟子中智慧第一神足第一。弟子大众俱来以渐近佛。既到稽首在一面立俱白佛言。世尊。我等于佛法中欲出家受戒。佛言。善来比丘。即时须发自落法服着身。衣钵具足受成就戒。过半月后佛为长爪梵志说法。时舍利弗得阿罗汉道。所以半月后得道者。是人当作逐佛转法轮师。应在学地现前自入诸法种种具知。是故半月后得阿罗汉道。如是等种种功德甚多。是故舍利弗虽是阿罗汉。佛以是般若波罗蜜甚深法。为舍利弗说。问曰。若尔者何以初少为舍利弗说。后多为须菩提说。若以智慧第一故应为多说。复何以为须菩提说。答曰。舍利弗佛弟子中智慧第一。须菩提于弟子中。得无诤三昧最第一。无诤三昧相常观众生不令心恼多行怜愍。诸菩萨者弘大誓愿以度众生怜愍相同。是故命说

复次是须菩提好行空三昧。如佛在忉利天夏安居受岁已还下阎浮提。尔时须菩提于石窟中住自思惟。佛从忉利天来下。我当至佛所耶。不至佛所耶。又念言。佛常说。若人以智慧眼观佛法身。则为见佛中最。是时以佛从忉利天下故。阎浮提中四部众集。诸天见人人亦见天。座中有佛及转轮圣王诸天大众。众会庄严先未曾有。须菩提心念。今此大众虽复殊特势不久停。磨灭之法皆归无常。因此无常观之初门。悉知诸法空无有实。作是观时即得道证。尔时一切众人。皆欲求先见佛礼敬供养。有华色比丘尼。欲除女名之恶。便化为转轮圣王及七宝千子。众人见之皆避坐起去。化王到佛所已还复本身为比丘尼。最初礼佛。是时佛告比丘尼非汝初礼。须菩提最初礼我。所以者何。须菩提观诸法空是为见佛法身。得真供养供养中最。非以致敬生身为供养也。以是故言须菩提常行空三昧。与般若波罗蜜空相相应。以是故佛命令说般若波罗蜜

复次佛以众生信敬阿罗汉诸漏已尽。命之为说。众得净信故。诸菩萨漏未尽。若以为证诸人不信。以是故与舍利弗须菩提共说般若波罗蜜。问曰。何以名舍利弗为是父母所作字。为是依行功德立名。答曰。是父母所作名字。于阎浮提中。第一安乐有摩伽陀国。是中有大城名王舍。王名频婆娑罗。有婆罗门论议师。名摩陀罗。王以其人善能论故。赐封一邑去城不远。是摩陀罗遂有居家妇生一女。眼似舍利鸟眼。即名此女为舍利。次生一男。膝骨粗大名拘郗罗。拘郗罗(秦言大膝也)是婆罗门既有居家畜养男女。所学经书皆已废忘又不业新。是时南天竺有一婆罗门大论议师字提舍。于十八种大经皆悉通利。是人入王舍城。头上戴火以铜鍱腹。人问其故。便言我所学经书甚多恐腹破裂。是故鍱之。又问。头上何以戴火。答言。以大闇故。众人言。日出照明何以言闇。答言。闇有二种。一者日光不照。二者愚痴闇蔽。今虽有日明而愚痴犹黑。众人言。汝但未见婆罗门摩陀罗。汝若见者腹当缩明当闇。是婆罗门迳至鼓边打论议鼓。国王闻之问是何人。众臣答言。南天竺有一婆罗门名提舍大论议师。欲求论处故打论鼓。王大欢喜即集众人而告之曰。有能难者与之论议。摩陀罗闻之自疑。我以废忘又不业新。不知我今能与论不。僶俯而来。于道中见二特牛方相抵触。心中作想。此牛是我彼牛是彼。以此为占知谁得胜。此牛不如便大愁忧而自念言。如此相者我将不如。欲入众时见有母人挟一瓶水正在其前躄地破瓶。复作是念。是亦不吉甚大不乐。既入众中见彼论师。颜貌意色胜相具足。自知不如。事不获已与共论议。论议既交便堕负处。王大欢喜。大智明人远入我国。复欲为之封一聚落。诸臣议言。一聪明人来便封一邑。功臣不赏但宠语论。恐非安国全家之道。今摩陀罗论议不如。应夺其封以与胜者。若更有胜人复以与之。王用其言即夺与后人。是时摩陀罗语提舍言。汝是聪明人。我以女妻汝。男儿相累今欲远出他国以求本志。提舍纳其女为妇。其妇怀妊梦见一人。身被甲胄手执金刚。摧破诸山而在大山边立。觉已白其夫言。我梦如是。提舍言。汝当生男。摧伏一切诸论议师。唯不胜一人当与作弟子。舍利怀妊。以其子故。母亦聪明大能论议。其弟拘郗罗与姊谈论每屈不如。知所怀子必大智慧。未生如是何况出生。即舍家学问至南天竺不剪指爪。读十八种经书皆令通利。是故时人号为长爪梵志。姊子既生七日之后。裹以白叠以示其父。其父思惟我名提舍。逐我名字字为忧波提舍。(忧波秦言逐提舍星名)是为父母作字。众人以其舍利所生。皆共名之为舍利弗。(弗秦言子)复次舍利弗世世本愿。于释迦文尼佛所作智慧第一弟子。字舍利弗。是为本愿因缘名字。以是故名舍利弗。问曰。若尔者何以不言忧波提舍。而但言舍利弗。答曰。时人贵重其母。于众女人中聪明第一。以是因缘故称舍利弗

【经】菩萨摩诃萨欲以一切种知一切法。当习行般若波罗蜜

【论】菩萨摩诃萨义。如先赞菩萨品中说。问曰。云何名一切种。云何名一切法。答曰。智慧门名为种。有人以一智慧门观有以二三十百千万乃至恒河沙等阿僧祇智慧门观诸法。今以一切智慧门。入一切种观一切法。是名一切种。如凡夫人三种观。欲求离欲离色故。观欲色界粗恶诳惑浊重。佛弟子八种观。无常苦空无我。如病如痈如箭入体恼患。是八种观入四圣谛中。为十六行之四。十六者。观苦四种。无常苦空无我。观苦因四种。集因缘生。观苦尽四种。尽灭妙出。观道四种道正行迹。出入息中复有十六行。一观入息。二观出息。三观息长息短。四观息遍身。五除诸身行。六受喜。七受乐。八者受诸心行。九无作喜。十心作摄。十一心作解脱。十二观无常。十三观散坏。十四观离欲。十五观灭。十六观弃舍。复有六种念。念佛者。佛是多陀阿伽陀阿罗呵三藐三佛陀。如是等十号。五念如后说。世智出世智阿罗汉辟支佛菩萨佛智。如是等智慧知诸法。名为一切种。一切法者。识所缘法是一切法。所谓眼识缘色耳识缘声鼻识缘香舌识缘味身识缘触意识缘法。缘眼缘色缘眼识耳声鼻香舌味身触亦如是。乃至缘意缘法缘意识。是名一切法。是为识所缘法。复次智所缘法是一切法。所谓苦智知苦集智知集尽智知尽道智知道世智知苦集尽道及虚空非数缘灭。是为智所缘法。复次二法摄一切法。色法无色法。可见法不可见法。有对法无对法。有漏无漏有为无为。心相应心不相应。业相应业不相应。(丹注云心法中除思余尽相应业即是思故除)近法远法等。如是种种二法摄一切法。(丹注云现在及无为是名近法未来过去是名远法)复次三种法摄一切法。善不善无记。学无学非学非无学。见谛断思惟断不断。复有三种法。五众十二入十八界持如是等种种三法。尽摄一切法。复有四种法。过去未来现在法。非过去未来现在法。欲界系法色界系法无色界系法不系法。因善法因不善法因无记法非因善不善无记。法缘缘法缘不缘法缘缘不缘缘法亦非缘缘非不缘缘法。如是等四种法摄一切法。有五种法。色心心相应心不相应无为法。如是等种种五法摄一切法。有六种法。见苦断法见习尽道断法思惟断法不断法。如是等种种六法。乃至无量法摄一切法。是为一切法。问曰。诸法甚深微妙不可思议。若一切众生尚不能得知。何况一人欲尽知一切法。譬如有人欲量大地及数大海水渧欲称须弥山欲知虚空边际。如是等事皆不可知。云何欲以一切种知一切法。答曰。愚痴闇蔽甚大苦。智慧光明最为乐。一切众生皆不用苦。但欲求乐。是故菩萨求一切第一大智慧。一切种观欲知一切法。是菩萨发大心。普为一切众生求大智慧。是故欲以一切种一切法。如医为一人二人。用一种二种药则足。若欲治一切众生病者。当须一切种药。菩萨亦如是。欲度一切众生故。欲知一切种一切法。如诸法甚深微妙无量。菩萨智慧亦甚深微妙无量。先答破一切智人中已广说。如函大盖亦大。复次若不以理求一切法则不可得。若以理求之则无不得。譬如钻火以木则火可得。析薪求火火不可得。如大地有边际。自非一切智人无大神力则不能知。若神通力大则知此三千大千世界地边际。今此大地在金刚上。三千大千世界四边则虚空。是为知地边际。欲称须弥山亦如是。欲量虚空非不能量。虚空无法故不可量

【经】舍利弗。白佛言。世尊。菩萨摩诃萨云何欲以一切种知一切法。当习行般若波罗蜜【论】问曰。佛欲说般若波罗蜜故。种种现神变。现已即应便说。何以故令舍利弗问而后说。答曰。问而后说。佛法应尔。复次舍利弗知般若波罗蜜甚深微妙无相之法难解难知。自以智力种种思惟。若观诸法无常。是般若波罗蜜耶。不是耶。不能自了。以是故问。复次舍利弗非一切智。于佛智慧中。譬如小儿。如说阿婆檀那经中。佛在祇洹住晡时经行。舍利弗从佛经行。是时有鹰逐鸽。鸽飞来佛边住。佛经行过之影覆鸽上。鸽身安隐怖畏即除不复作声。后舍利弗影到鸽。便作声战怖如初。舍利弗白佛言。佛及我身俱无三毒。以何因缘佛影覆鸽。鸽便无声不复恐怖。我影覆上鸽便作声战栗如故。佛言。汝三毒习气未尽。以是故汝影覆时恐怖不除。汝观此鸽宿世因缘几世作鸽。舍利弗即时入宿命智三昧。观见此鸽从鸽中来。如是一二三世乃至八万大劫常作鸽身。过是已往不能复见。舍利弗从三昧起白佛言。是鸽八万大劫中常作鸽身。过是已前不能复知。佛言。汝若不能尽知过去世。试观未来世此鸽何时当脱。舍利弗即入愿智三昧。观见此鸽一二三世乃至八万大劫未脱鸽身。过是已往亦不能知。从三昧起白佛言。我见此鸽从一世二世乃至八万大劫未免鸽身。过此已往不复能知。我不知过去未来齐限。不审此鸽何时当脱。佛告舍利弗。此鸽除诸声闻辟支佛所知齐限。复于恒河沙等大劫中常作鸽身。罪讫得出。轮转五道中后得为人。经五百世中乃得利根。是时有佛度无量阿僧祇众生。然后入无余涅槃。遗法在世是人作五戒优婆塞。从比丘闻赞佛功德。于是初发心愿欲作佛。然后于三阿僧祇劫。行六波罗蜜。十地具足得作佛。度无量众生已而入无余涅槃。是时舍利弗向佛忏悔白佛言。我于一鸟尚不能知其本末。何况诸法。我若知佛智慧如是者。为佛智慧故。宁入阿鼻地狱。受无量劫苦不以为难。如是等于诸法中不了故问

    大智度论释初品中檀波罗蜜义第十七

【经】佛告舍利弗。菩萨摩诃萨以不住法住般若波罗蜜中。以无所舍法具足檀波罗蜜。施者受者及财物不可得故

【论】问曰。般若波罗蜜是何等法。答曰。有人言。无漏慧根。是般若波罗蜜相。何以故。一切慧中第一慧。是名般若波罗蜜。无漏慧根是第一。以是故无漏慧根。名般若波罗蜜。问曰。若菩萨未断结。云何得行无漏慧。答曰。菩萨虽未断结。行相似无漏般若波罗蜜。是故得名行无漏般若波罗蜜。譬如声闻人。行暖法顶法忍法世间第一法。先行相似无漏法。后易得生苦法智忍。复有人言菩萨有二种。有断结使清净。有未断结使不清净。断结使清净。菩萨能行无漏般若波罗蜜。问曰。若菩萨断结清净。复何以行般若波罗蜜。答曰。虽断结使。十地未满未庄严佛土未教化众生。是故行般若波罗蜜。复次断结有二种。一者断三毒。心不着人天中五欲。二者虽不着人天中五欲。于菩萨功德果报五欲。未能舍离。如是菩萨应行般若波罗蜜。譬如长老阿泥卢豆。在林中坐禅时。净爱天女等。以净妙之身来试阿泥卢豆。阿泥卢豆言。诸姊作青色来不用杂色。欲观不净不能得观。黄赤白色亦复如是。时阿泥卢豆。闭目不视。语言。诸姊远去。是时天女即灭不现。天福报形犹尚如是。何况菩萨无量功德果报五欲。又如甄陀罗王。与八万四千甄陀罗。来到佛所弹琴歌颂以供养佛。尔时须弥山王及诸山树木。人民禽兽一切皆舞。佛边大众乃至大迦叶。皆于座上不能自安。是时天须菩萨。问长老大迦叶。耆年旧宿行十二头陀法之第一。何以在座不能自安。大迦叶言。三界五欲不能动我。是菩萨神通功德果报力故。令我如是。非我有心不能自安也。譬如须弥山四边风起不能令动。至大劫尽时毗蓝风起如吹烂草。以是事故知。二种结中一种未断。如是菩萨等应行般若波罗蜜。是阿毗昙中。如是说。复有人言。般若波罗蜜是有漏慧。何以故。菩萨至道树下乃断结。先虽有大智慧有无量功德。而诸烦恼未断。是故言菩萨般若波罗蜜是有漏智慧。复有人言。从初发意乃至道树下。于其中间所有智慧。是名般若波罗蜜。成佛时是般若波罗蜜。转名萨婆若。复有人言。菩萨有漏无漏智慧。总名般若波罗蜜。何以故。菩萨观涅槃行佛道。以是事故。菩萨智慧应是无漏。以未断结使事未成办故。应名有漏。复有人言。菩萨般若波罗蜜。无漏无为不可见无对。复有人言。是般若波罗蜜不可得相。若有若无若常若无常若空若实。是般若波罗蜜。非阴界入所摄。非有为非无为非法非非法。无取无舍不生不灭。出有无四句。适无所著。譬如火焰四边不可触以烧手故。般若波罗蜜相亦如是。不可触以邪见火烧故。问曰。上种种人说般若波罗蜜。何者为实。答曰。有人言各各有理皆是实。如经说。五百比丘各各说二边及中道义。佛言。皆有道理。有人言。末后答者为实。所以者何。不可破不可坏故。若有法如毫牦许有者。皆有过失可破。若言无亦可破。此般若中有亦无无亦无非有非无亦无。如是言说亦无。是名寂灭无量无戏论法。是故不可破不可坏。是名真实般若波罗蜜。最胜无过者。如转轮圣王降伏诸敌而不自高。般若波罗蜜亦如是。能破一切语言戏论。亦不有所破。复次从此已后品品中种种义门。说般若波罗蜜。皆是实相。以不住法住般若波罗蜜中。能具足六波罗蜜。问曰。云何名不住法住般若波罗蜜中能具足六波罗蜜。答曰。如是菩萨观一切法非常非无常。非苦非乐非空非实。非我非无我。非生灭非不生灭。如是住甚深般若波罗蜜中。于般若波罗蜜相亦不取。是名不住法住。若取般若波罗蜜相。是为住法住

问曰。若不取般若波罗蜜相。心无所著。如佛所言一切诸法欲为其本。若不取者。云何得具足六波罗蜜。答曰。菩萨怜愍众生故。先立誓愿我必当度脱一切众生。以精进波罗蜜力故。虽知诸法不生不灭如涅槃相。复行诸功德。具足六波罗蜜。所以者何。以不住法住般若波罗蜜中故。是名不住法住般若波罗蜜中

    大智度论释初品中赞檀波罗蜜义第十八

问曰。檀有何等利益故。菩萨住般若波罗蜜中。檀波罗蜜具足满。答曰。檀有种种利益。檀为宝藏常随逐人。檀为破苦能与人乐。檀为善御开示天道。檀为善府摄诸善人。(施摄善人与为因缘故言摄)檀为安隐临命终时心不怖畏。檀为慈相能济一切。檀为集乐能破苦贼。檀为大将能伏悭敌。檀为妙果天人所爱。檀为净道贤圣所游。檀为积善福德之门。檀为立事聚众之缘。檀为善行爱果之种。檀为福业善人之相。檀破贫穷断三恶道。檀能全护福乐之果。檀为涅槃之初缘。入善人聚中之要法。称誉赞叹之渊府。入众无难之功德。心不悔恨之窟宅。善法道行之根本。种种欢乐之林薮。富贵安隐之福田。得道涅槃之津梁。圣人大士智者之所行。余人俭德寡识之所效。复次譬如失火之家。黠慧之人明识形势。及火未至急出财物。舍虽烧尽财物悉在。更修室宅。好施之人亦复如是。知身危脆财物无常修福及时。如火中出物后世受乐。亦如彼人更修宅业福庆自慰。愚惑之人但知惜屋匆匆营救。狂愚失智不量火势猛风绝焰土石为焦。翕响之间荡然夷灭。屋既不救财物亦尽。饥寒冻饿忧苦毕世。悭惜之人亦复如是。不知身命无常须臾叵保。而更聚敛守护爱惜。死至无期忽焉逝没。形与土木同流。财与委物俱弃。亦如愚人忧苦失计。复次大慧之人有心之士。乃能觉悟知身如幻财不可保。万物无常唯福可恃。将人出苦津通大道。复次大人大心能大布施。能自利己。小人小心不能益他。亦不自厚。复次譬如勇士见敌必期吞灭。智人慧心深得悟理。悭贼虽强亦能挫之必令如意。遇良福田值好时节(时应施之时也遇而不施是名失时)觉事应心能大布施。复次好施之人为人所敬。如月初出无不爱者。好名善誉周闻天下人所归仰一切皆信。好施之人贵人所念贱人所敬。命欲终时其心不怖。如是果报今世所得。譬如树华大果无量。后世福也。生死轮转往来五道无亲可恃。唯有布施若生天上人中得清净果皆由布施。象马畜生得好枥养。亦是布施之所得也。布施之德富贵欢乐。持戒之人得生天上。禅智心净无所染着得涅槃道。布施之福是涅槃道之资粮也。念施故欢喜。欢喜故一心。一心观生灭无常观生灭无常故得道。如人求荫故种树。或求华或求果故种树。布施求报亦复如是。今世后世乐如求荫。声闻辟支佛道如华。成佛如果。是为檀种种功德

    大智度论释初品中檀相义第十九

问曰。云何名檀。答曰。檀名布施心相应善思。是名为檀。有人言。从善思起身口业。亦名为檀。有人言。有信有福田有财物三事和合时。心生舍法能破悭贪。是名为檀。譬如慈法观众生乐而心生慈。布施心数法亦复如是。三事和合心生舍法能破悭贪。檀有三种。或欲界系或色界系或不系。(丹本注云圣人行施故名不系)心相应法随心行共心生。非色法能作缘。非业业相应随业行共业生。非先世业报生。二种修行修得修。二种证身证慧证。若思惟断。若不断。二见断欲界色界尽见断。有觉有观法凡夫圣人共行。如是等阿毗昙中广分别说。复次施有二种。有净有不净。不净施者直施无所为。或有为求财故施。或愧人故施。或为嫌责故施。或畏惧故施。或欲取他意故施。或畏死故施。或狂人令喜故施。或自以富贵故应施。或诤胜故施。或妒嗔故施。或憍慢自高故施。或为名誉故施。或为咒愿故施。或解除衰求吉故施。或为聚众故施。或轻贱不敬施。如是等种种名为不净施。净施者。与上相违名为净施。复次为道故施。清净心生无诸结使。不求今世后世报。恭敬怜愍故。是为净施。净施是趣涅槃道之资粮。是故言为道故施。若未得涅槃时施。是人天报乐之因。净施者如华璎珞初成未坏香洁鲜明。为涅槃净施得果报香亦复如是。如佛说。世有二人为难得。一者出家中非时解脱比丘。二者在家白衣能清净布施。是净施相乃至无量世。世世不失。譬如券要终无失时。是布施果因缘和合时便有。譬如树得时节会。便有华叶果实若时节未至有因而无果。是布施法。若以求道能与人道。何以故结使灭名涅槃。当布施时。诸烦恼薄故。能助涅槃。于所施物中不惜故。除悭敬念受者故。除嫉妒直心布施故。除谄曲。一心布施故。除调深思惟施故。除悔。观受者功德故。除不恭敬。自摄心故。除不惭。知人好功德故。除不愧。不着财物故。除爱。慈愍受者故。除嗔。恭敬受者故。除憍慢。知行善法故。除无明。信有果报故。除邪见。知决定有报故除疑。如是等种种不善诸烦恼。布施时悉皆薄。种种善法悉皆得。布施时六根清净善欲心生。善欲心生故。内心清净。观果报功德故。信心生。身心柔软故。喜乐生。喜乐生故。得一心。得一心故。实智慧生。如是等诸善法悉皆得。复次布施时。心生相似八正道。信布施果故。得正见。正见中思惟不乱故。得正思惟。清净说故得正语。净身行故。得正业。不求报故。得正命。勤心施故。得正方便。念施不废故。得正念。心住不散故。得正定。如是等相似三十七品善法心中生。复次有人言。布施是得三十二相因缘。所以者何。施时与心坚固。得足下安立相。布施时。五事围绕受者。是眷属业因缘故。得足下轮相。大勇猛力施故。得足跟广平相。施摄人故。得手足缦网相。美味饮食施故。得手足柔软七处满相。施以益命故。得长指身不曲大直相。施时言我当相与。施心转增故。得足趺高毛上向相。施时受者求之一心好听。殷勤约敕令必疾得故。得伊泥延[跳-兆+專]相。不嗔不轻求者故。得臂长过膝相。如求者意施不待言故。得阴藏相。好衣服卧具金银珍宝施故。得金色身相薄皮相。布施令受者独得自在用。故。得一一孔一毛生眉间白毫相。求者求之即言。当与以是业故。得上身如师子肩圆相。病者施药饥渴者与饮食故。得两腋下满最上味相。施时劝人行施而安慰之。开布施道故。得肉髻相。身圆如尼拘卢相。有乞求者意欲与时。柔软实语必与不虚故。得广长舌相梵音声相如迦陵毗伽鸟声相。施时如实语利益语故。得师子颊相。施时恭敬受者心清净故。得牙白齿齐相。施时实语和合语故。得齿密相四十齿相。施时不嗔不着等心视彼故。得青眼相眼睫如牛王相。是为种三十二相因缘。复次以七宝人民车乘金银灯烛房舍香华布施故。得作转轮王七宝具足。复次施得时故。报亦增多。如佛说。施远行人远来人。病人看病人。风寒众难时施。是为时施。复次布施时随土地所须施故。得报增多。复次旷路中施故。得福增多。常施不废故。得报增多。如求者所欲施故。得福增多。施物重故。得福增多。如以精舍园林浴池等若施善人故。得报增多。若施僧故。得报增多。若施者受者俱有德故。(丹注云如菩萨及佛慈心布施是为施者若施佛及菩萨阿罗汉辟支佛是为受者故)得报增多。种种将迎恭敬受者故。得福增多。难得物施故。得福增多。随所有物尽能布施故。得福增多。譬如大月氏弗迦罗城中有一画师。名千那。到东方多刹陀罗国。客画十二年得三十两金。持还本国于弗迦罗城中。闻打鼓作大会声。往见众僧。信心清净即问维那。此众中几许物。得作一日食。维那答曰。三十两金足得一日食。即以所有三十两金付维那。为我作一日食。我明日当来。空手而归。其妇问曰。十二年作得何等物。答言。我得三十两金。即问三十两金今在何所。答言。已在福田中种。妇言。何等福田。答言施与众僧。妇便缚其夫送官治罪断事。大官问。以何事故。妇言我夫狂痴。十二年客作得三十两金。不怜愍妇儿尽以与他人。依如官制辄缚送来。大官问其夫。汝何以不供给妇儿。乃以与他。答言。我先世不行功德。今世贫穷受诸辛苦。今世遭遇福田。若不种福后世复贫。贫贫相续无得脱时。我今欲顿舍贫穷。以是故尽以金施众僧。大官是优婆塞信佛清净。闻是语已赞言。是为甚难。勤苦得此少物尽以施僧。汝是善人。即脱身璎珞及所乘马并一聚落以施贫人。而语之言。汝始施众僧。众僧未食是为谷子未种。牙已得生。大果方在后身以是故言。难得之物尽用布施其福最多。复次有世间檀。有出世间檀。有圣人所称誉檀。有圣人所不称誉檀。有佛菩萨檀。有声闻檀。何等世间檀。凡夫人布施。亦圣人作有漏心布施。是名世间檀。复次有人言。凡夫人布施。是为世间檀。圣人虽有漏心布施。以结使断故。名出世间檀。何以故。是圣人得无作三昧故。复次世间檀者不净。出世间檀者清净。二种结使。一种属爱一种属见。为二种结使所使。是为世间檀。无此二种结使。是为出世间檀。若三碍系心是为世间檀。何以故。因缘诸法实无吾我。而言我与彼取。是故名世间檀。复次我无定处。我以为我彼以为非。彼以为我我以为非。以是不定故无实我也。所施财者从因缘和合有。无有一法独可得者。如绢如布。众缘合故成。除丝除缕则无绢布。诸法亦如是。一相无相相常自空。人作想念计以为有。颠倒不实是为世间檀。心无三碍实知法相心不颠倒。是为出世间檀。出世间檀为圣人所称誉。世间檀圣人所不称誉。复次清净檀。不杂结垢如诸法实相。是圣人所称誉。不清净杂结使颠倒心着。是圣人所不称誉。复次实相智慧和合布施。是圣人所称誉。若不尔者圣人所不称誉。复次不为众生。亦不为知诸法实相故施。但求脱生老病死。是为声闻檀。为一切众生故施。亦为知诸法实相故施。是为诸佛菩萨檀。于诸功德不能具足。但欲得少许分。是为声闻檀。一切诸功德欲具足满。是为诸佛菩萨檀。畏老病死故施。是为声闻檀。为助佛道为化众生不畏老病死。是为诸佛菩萨檀。是中应说菩萨本生经。如说阿婆陀那经中。昔阎浮提中有王。名婆萨婆。尔时有婆罗门菩萨。名韦罗摩。是国王师。教王作转轮圣王法。韦罗摩财富无量珍宝具足。作是思惟。人谓我为贵人财富无量。饶益众生今正是时应当大施。富贵虽乐一切无常。五家所共令人心散轻泆不定。譬如猕猴不能暂住。人命逝速疾于电灭。人身无常众苦之薮。以是之故应行布施。如是思惟已自作手疏。普告阎浮提诸婆罗门及一切出家人。愿各屈德来集我舍。欲设大施满十二岁。饭汁行船以酪为池。米面为山苏油为渠。衣服饮食卧具汤药。皆令极妙过十二岁。欲以布施。八万四千白象犀甲金饰珞。以名宝建大金幢。四宝庄严。八万四千马。亦以犀甲金饰。四宝交络。八万四千车。皆以金银琉璃颇梨宝饰。覆以师子虎豹之皮。若白剑婆罗宝[車*憲]杂饰以为庄严。八万四千四宝床。杂色綩綖种种茵蓐柔软细滑以为挍饰。丹枕锦被置床两头。妙衣盛服皆亦备有。八万四千金钵盛满银粟。银钵盛金粟。琉璃钵盛颇梨粟。颇梨钵盛琉璃粟。八万四千乳牛。牛出乳一斛。金饰其[跳-兆+甲]角衣以白叠。八万四千美女端正福德。皆以白珠名宝璎珞其身。略举其要如是。种种不可胜记。尔时婆罗婆王及八万四千诸小国王。并诸臣民豪杰长者。各以十万旧金钱赠遗劝助。设此法祠具足施已。释提婆那民来语韦罗摩菩萨。说此偈言

  天地难得物　　能喜悦一切
  汝今皆以得　　为佛道布施

尔时净居诸天现身而赞。说此偈言

  开门大布施　　汝所为者是
  怜愍众生故　　为之求佛道

是时诸天作是思惟。我当闭其金瓶令水不下。所以者何。有施者无福田故。是时魔王语净居天。此诸婆罗门。皆出家持戒清净入道。何以故乃言无有福田。净居天言。是菩萨为佛道故布施。今此诸人皆是邪见。是故我言无有福田。魔王语天言。云何知是人为佛道故布施。是时净居天化作婆罗门身。持金瓶执金杖。至韦罗摩菩萨所语言。汝大布施难舍能舍欲求何等。欲作转轮圣王七宝千子王四天下耶。菩萨答言。不求此事。汝求释提婆那民。为八千那由他天女主耶。答言不。汝求六欲天主耶。答言不。汝求梵天王主三千大千世界为众生祖父耶。答言不。汝欲何所求。是时菩萨。说此偈言

  我求无欲处　　离生老病死
  欲度诸众生　　求如是佛道

化婆罗门言。布施主。佛道难得当大辛苦。汝心软串乐。必不能求成办此道。如我先语。转轮圣王释提婆那民六欲天王梵天王是易可得。不如求此。菩萨答言。汝听我一心誓

  假令热铁轮　　在我头上转
  一心求佛道　　终不怀悔恨
  若使三恶道　　人中无量苦
  一心求佛道　　终不为此转

化婆罗门言。布施主。善哉善哉求佛如是。便赞偈言

  汝精进力大　　慈愍于一切
  智慧无挂碍　　成佛在不久

是时天雨众华供养菩萨。诸净居天闭瓶水者即隐不现。菩萨是时至婆罗门上座前。以金瓶行水。水闭不下众人疑怪。此种种大施一切具足。布施主人功德亦大。今何以故瓶水不下。菩萨自念。此非他事。将无我心不清净耶。得无施物不具足乎。何以致此。自观祠经十六种书清净无瑕。是时诸天语菩萨言。汝莫疑悔。汝无不办。是诸婆罗门恶邪不净故也。即说偈言

  是人邪见网　　烦恼破正智
  离诸清净戒　　唐苦堕异道

以是故水闭不下。如是语已忽然不现。尔时六欲天放种种光明照诸众会。语菩萨而说偈言

  邪恶海中行　　不顺汝正道
  诸受施人中　　无有如汝者

说是语已忽然不现。是时菩萨闻说此偈自念。会中实自无有与我等者。水闭不下其将为此乎。即说偈言

  若有十方天地中　　诸有好人清净者
  我今归命稽首礼　　右手执瓶灌左手
  而自立愿我一人　　应受如是大布施

是时瓶水踊在虚空从上来下而灌其左手。是时婆萨婆王。见是感应心生恭敬。而说偈言

  大婆罗门主　　清琉璃色水
  从上流注下　　来堕汝手中

是时大婆罗门众恭敬心生。合手作礼归命菩萨。菩萨是时说此偈言

  今我所布施　　不求三界福
  为诸众生故　　以用求佛道

说此偈已。一切大地山川树木皆六返震动。韦罗摩本谓此众应受供养故与。既知此众无堪受者。今以怜愍故。以所受物施之。如是种种檀本生因缘。是中应广说。是为外布施。云何名内布施。不惜身命施诸众生。如本生因缘说。释迦文佛本为菩萨为大国王时。世无佛无法无比丘僧。是王四出求索佛法。了不能得。时有一婆罗门言。我知佛偈。供养我者当以与汝。王即问言。索何等供养。答言。汝能就汝身上。破肉为灯炷供养我者。当以与汝。王心念言。今我此身危脆不净。世世受苦不可复数。未曾为法今始得用甚不惜也。如是念已唤旃陀罗。遍割身上以作灯炷。而以白叠缠肉酥油灌之。一时遍烧举身。火燃。乃与一偈。又复释迦文佛本作一鸽在雪山中。时大雨雪。有一人失道穷厄辛苦。饥寒并至命在须臾。鸽见此人即飞求火。为其聚薪然之。又复以身投火施此饥人。如是等头目髓脑给施众生。种种本生因缘经此中应广说。如是等种种是名内布施。如是内外布施无量。是名檀相

    大智度论释初品中檀波罗蜜法施义第二十

问曰。云何名法布施。答曰。有人言。常以好语有所利益。是为法施。复次有人言。以诸佛语妙善之法。为人演说。是为法施。复次有人言。以三种法教人。一修妒路二毗尼三阿毗昙。是为法施。复次有人言。以四种法藏教人。一修妒路藏二毗尼藏三阿毗昙藏四杂藏。是为法施。复次有人言。略说以二种法教人。一声闻法二摩诃衍法。是为法施。问曰。如提婆达呵多等。亦以三藏四藏声闻法摩诃衍法教人。而身入地狱是事云何。答曰。提婆达邪见罪多。呵多妄语罪多。非是为道清净法施。但求名利恭敬供养。恶心罪故提婆达生入地狱。呵多死堕恶道。复次非但言说名为法施。常以净心善思。以教一切是名法施。譬如财施不以善心不名福德法施亦尔。不以净心善思则非法施。复次说法者。能以净心善思赞叹三宝。开罪福门示四真谛。教化众生令入佛道。是为真净法施。复次略说法有二种。一者不恼众生善心慈愍。是为佛道因缘。二者观知诸法真空。是为涅槃道因缘。在大众中兴愍哀心说此二法。不为名闻利养恭敬。是为清净佛道法施。如说。阿输伽王一日作八万佛图。虽未见道于佛法中少有信乐。日日请诸比丘入宫供养。日日次第留法师说法。有一三藏年少法师。聪明端正次应说法。在王边坐。口有异香。王甚疑怪谓为不端。欲以香气动王宫人。语比丘言。口中何等开口看之。即为开口了无所有。与水令漱香气如故。王问。大德新有此香旧有之耶。比丘答言。如此久有非适今也。又问有此久如。比丘以偈答言

  迦叶佛时　　集此香法　　如是久久
  常若新出

王言。大德略说未解。为我广演。答言。王当一心善听我说。我昔于迦叶佛法中作说法比丘。常在大众之中欢喜演说。迦叶世尊无量功德诸法实相。无量法门殷勤赞叹教诲一切。自是以来常有妙香从口中出。世世不绝恒如今日。而说此偈

  草木诸华香　　此香气超绝
  能悦一切心　　世世常不灭

于时国王愧喜交集。白比丘言。未曾有也。说法功德大果乃尔。比丘言。此名为华。未是果也。王言其果云何愿为演说。答言。果略说有十。王谛听之。即为说偈言

  大名闻端政　　得乐及恭敬
  威光如日月　　为一切所爱
  辩才有大智　　能尽一切结
  苦灭得涅槃　　如是名为十

王言。大德。赞佛功德云何而得如是果报。尔时比丘以偈答曰

  赞佛诸功德　　令一切普闻
  以此果报故　　而得大名誉
  赞佛实功德　　令一切欢喜
  以此功德故　　世世常端正
  为人说罪福　　令得安乐所
  以此之功德　　受乐常欢豫
  赞佛功德力　　令一切心伏
  以此功德故　　常获恭敬报
  显现说法灯　　照悟诸众生
  以此之功德　　威光如日曜
  种种赞佛德　　能悦于一切
  以此功德故　　常为人所爱
  巧言赞佛德　　无量无穷已
  以此功德故　　辩才不可尽
  赞佛诸妙法　　一切无过者
  以此功德故　　大智慧清净
  赞佛功德时　　令人烦恼薄
  以此功德故　　结尽诸垢灭
  二种结尽故　　涅槃身已证
  譬如澍大雨　　火尽无余热

重告王言。若有未悟今是问时。当以智箭破汝疑军。王白法师。我心悦悟无所疑也。大德福人善能赞佛。如是等种种因缘说法度人。名为法施。问曰。财施法施何者为胜。答曰。如佛所言二施之中法施为胜。所以者何。财施果报在欲界中。法施果报或在三界。或出三界。复次口说清净深得理中。心亦得之故出三界。复次财施有量。法施无量。财施有尽。法施无尽。譬如以薪益火其明转多。复次财施之报净少垢多。法施之报垢少净多。复次若作大施必待众力。法施出心不待他也。复次财施能令四大诸根增长。法施能令无漏根力觉道具足。复次财施之法。有佛无佛世间常有。如法施者唯有佛世乃当有耳。是故当知法施甚难。云何为难。乃至有相辟支佛不能说法。直行乞食飞腾变化而以度人。复次从法施中能出生财施。及诸声闻辟支佛菩萨及佛。复次法施能分别诸法。有漏无漏法。色法无色法。有为无为法。善不善无记法。常法无常法。有法无法。一切诸法实相清净不可破不可坏。如是等法略说则八万四千法藏。广说则无量。如是等种种。皆从法施分别了知。以是故法施为胜。是二施和合名之为檀。行是二施愿求作佛。则能令人得至佛道。何况其余。问曰。四种舍名为檀。所谓财舍法舍无畏舍烦恼舍。此中何以不说二种舍。答曰。无畏舍与尸罗无别故不说。有般若故不说烦恼舍。若不说六波罗蜜。则应具说四舍

大智度论卷第十一大智度论释初品中檀波罗蜜法施之余(卷第十二)

        龙树菩萨造

        后秦龟兹国三藏鸠摩罗什奉　诏译

【论】问曰。云何名檀波罗蜜满。答曰。檀义如上说。波罗(秦言彼岸)蜜(秦言到)是名渡布施河得到彼岸。问曰。云何名不到彼岸。答曰。譬如渡河未到而还。名为不到彼岸。如舍利弗。于六十劫中行菩萨道。欲渡布施河。时有乞人来乞其眼。舍利弗言。眼无所任。何以索之。若须我身及财物者当以相与。答言。不须汝身及以财物。唯欲得眼。若汝实行檀者以眼见与。尔时舍利弗。出一眼与之。乞者得眼。于舍利弗前嗅之。嫌臭唾而弃地。又以脚蹋。舍利弗思惟言。如此弊人等难可度也。眼实无用而强索之。既得而弃又以脚蹋。何弊之甚。如此人辈不可度也。不如自调早脱生死。思惟是已。于菩萨道退回向小乘。是名不到彼岸。若能直进不退。成办佛道。名到彼岸。复次于事成办亦名到彼岸。(天竺俗法凡造事成办皆言到彼岸)复次此岸名悭贪檀名河中。彼岸名佛道。复次有无见名此岸。破有无见智慧名彼岸。勤修布施是名河中。复次檀有二种。一者魔檀二者佛檀。若为结使贼所夺忧恼怖畏。是为魔檀。名曰此岸。若有清净布施。无结使贼无所怖畏得至佛道。是为佛檀。名曰到彼岸。是为波罗蜜。如佛说毒蛇喻经中。有人得罪于王。王令掌护一箧。箧中有四毒蛇。王敕罪人令看视养育。此人思惟。四蛇难近。近则害人。一犹叵养。而况于四。便弃箧而走。王令五人拔刀追之。复有一人口言附顺。心欲中伤而语之言。养之以理此亦无苦。其人觉之驰走逃命。至一空聚有一善人方便语之。此聚虽空是贼所止处。汝今住此必为贼害慎勿住也。于是复去至一大河。河之彼岸即是异国。其国安乐坦然清净无诸患难。于是集众草木缚以为筏进。以手足竭力求渡。既到彼岸安乐无患。王者魔王。箧者人身。四毒蛇者四大。五拔刀贼者五众。一人口善心恶者。是染着空聚是六情。贼是六尘。一人愍而语之是为善师。大河是爱。筏是八正道。手足勤渡是精进。此岸是世间。彼岸是涅槃。度者漏尽阿罗汉。菩萨法中亦如是。若施有三碍。我与彼受所施者财。是为堕魔境界未离众难。如菩萨布施三种清净无此三碍得到彼岸。为诸佛所赞。是名檀波罗蜜。以是故名到彼岸。此六波罗蜜能令人渡悭贪等烦恼染着大海到于彼岸。以是故名波罗蜜。问曰。阿罗汉辟支佛亦能到彼岸。何以不名波罗蜜。答曰。阿罗汉辟支佛渡彼岸。与佛渡彼岸。名同而实异。彼以生死为此岸。涅槃为彼岸。而不能渡檀之彼岸。所以者何。不能以一切物一切时一切种布施。设能布施亦无大心。或以无记心或有漏善心。或无漏心施无大悲心。不能为一切众生施。菩萨施者知布施不生不灭无漏无为。如涅槃相。为一切众生故施。是名檀波罗蜜。复次有人言。一切物一切种内外物尽以布施不求果报。如是布施名檀波罗蜜。复次不可尽故名檀波罗蜜。所以者何。知所施物毕竟空如涅槃相。以是心施众生。是故施报不可尽。名檀波罗蜜。如五通仙人。以好宝物藏着石中。欲护此宝磨金刚涂之。令不可破。菩萨布施亦复如是。以涅槃实相智慧磨涂之布施。令不可尽。复次菩萨为一切众生故布施。众生数不可尽故。布施亦不可尽。复次菩萨为佛法布施。佛法无量无边。布施亦无量无边。以是故阿罗汉辟支佛虽到彼岸。不名波罗蜜。问曰。云何名具足满。答曰。如先说。菩萨能一切布施内外大小多少粗细着不着用不用。如是等种种物一切能舍。心无所惜。等与一切众生。不作是观大人应与小人不应与。出家人应与不出家人不应与。人应与禽兽不应与。于一切众生平等心施。施不求报。又得施实相。是名具足满。亦不观时无昼无夜无冬无夏无吉无衰。一切时常等施心无悔惜。乃至头目髓脑施而无吝。是为具足满

复次有人言。菩萨从初发心乃至菩提树下三十四心。于是中间名为布施具足满。复次七住菩萨得一切诸法实相智慧。是时庄严佛土教化众生。供养诸佛得大神通。能分一身作无数身。一一身皆雨七宝华香幡盖化作大灯。如须弥山。供养十方佛及菩萨僧。复以妙音赞颂佛德。礼拜供养恭敬将迎。复次是菩萨。于一切十方无量饿鬼国中雨种种饮食衣被令其充满。得满足已。皆发阿耨多罗三藐三菩提心。复至畜生道中。令其自善无相害意。除其畏怖随其所须各令充足。得满足已。皆发阿耨多罗三藐三菩提心。于地狱无量苦中。能令地狱火灭汤冷。罪息心善除其饥渴。得生天上人中。以此因缘故皆发阿耨多罗三藐三菩提心。若十方人贫穷者给之以财。富贵者施以异味异色令其欢喜。以此因缘故。皆发阿耨多罗三藐三菩提心。若至欲天中令其除却天上欲乐。施以妙宝法乐令其欢喜。以此因缘故。皆发阿耨多罗三藐三菩提心。若至色天中除其乐着。以菩萨禅法而娱乐之。以此因缘故。皆发阿耨多罗三藐三菩提心。如是乃至十住是名檀波罗蜜具足满。复次菩萨有二种身。一者结业生身。二者法身。是二种身中檀波罗蜜满。是名具足檀波罗蜜。问曰。云何名结业生身檀波罗蜜满。答曰。未得法身结使未尽。能以一切宝物头目髓脑国财妻子内外所有。尽以布施心不动转。如须提拏太子(秦言好爱)以其二子布施婆罗门。次以妻施其心不转。又如萨婆达王(秦言一切施)为敌国所灭。身窜穷林。见有远国婆罗门来欲从己乞。自以国破家亡一身藏窜。愍其辛苦故。从远来而无所得。语婆罗门言。我是萨婆达王。新王募人求我甚重。即时自缚以身施之。送与新王大得财物。亦如月光太子出行游观。癞人见之要车白言。我身重病辛苦懊恼。太子嬉游独自欢耶。大慈愍念愿见救疗。太子闻之以问诸医。医言当须从生长大无嗔之人血髓。涂而饮之。如是可愈。太子念言。设有此人贪生惜寿何可得耶。自除我身无可得处。即命旃陀罗。令除身肉破骨出髓以涂病人以血饮之。如是等种种身。及妻子施而无吝如弃草木。观所施物知从缘有。推求其实都无所得。一切清净如涅槃相。乃至得无生法忍。是为结业生身行檀波罗蜜满。云何法身菩萨行檀波罗蜜满。菩萨末后肉身得无生法忍。舍肉身得法身。于十方六道中。变身应适以化众生。种种珍宝衣服饮食给施一切。又以头目髓脑国财妻子内外所有尽以布施。譬如释迦文佛。曾为六牙白象。猎者伺便以毒箭射之。诸象竞至欲来蹈杀猎者。白象以身捍之。拥护其人愍之如子。谕遣群象徐问猎人。何故射我。答曰。我须汝牙。即时以六牙内石孔中血肉俱出。以鼻举牙授与猎者。虽曰象身用心如是。当知此象非畜生行报。阿罗汉法中都无此心。当知此为法身菩萨。有时阎浮提人不知礼敬。耆旧有德。以言化之未可得度。是时菩萨自变其身。作迦频阇罗鸟。是鸟有二亲友。一者大象二者猕猴。共在必钵罗树下住。自相问言。我等不知谁应为长。象言。我昔见此树在我腹下。今大如是以此推之我应为长。猕猴言。我曾蹲地手挽树头以是推之我应为长。鸟言。我于必钵罗林中食此树果。子随粪出此树得生。以是推之我应最长。鸟复说言先生宿旧礼应供养。即时大象背负猕猴。鸟在猴上。周游而行。一切禽兽见而问之。何以如此。答曰。以此恭敬供养长老。禽兽受化皆行礼敬。不侵民田不害物命。众人疑怪一切禽兽不复为害。猎者入林见象负猕猴猕猴戴鸟。行敬化物物皆修善传告国人。人各庆曰。时将太平鸟兽而仁。人亦效之。皆行礼敬。自古及今化流万世。当知是为法身菩萨。复次法身菩萨一时之顷。化作无央数身。供养十方诸佛。一时能化无量财宝给足众生。能随一切上中下声一时之顷。普为说法。乃至坐佛树下。如是等种种名为法身菩萨行檀波罗蜜满。复次檀有三种一者物施二者供养恭敬施。三者法施。云何物施。珍宝衣食头目髓脑。如是等一切内外所有尽以布施。是名物施。恭敬施者。信心清净恭敬礼拜。将送迎逆赞绕供养。如是等种种名为恭敬施。法施者为道德故。语言论议诵读讲说除疑问答授人五戒。如是等种种为佛道故施。是名法施。是三种施满。是名檀波罗蜜满。复次三事因缘生檀。一者信心清净。二者财物。三者福田。心有三种。若怜愍。若恭敬。若怜愍恭敬。施贫穷下贱及诸畜生。是为怜愍施。施佛及诸法身菩萨等。是为恭敬施。若施诸老病贫乏阿罗汉辟支佛。是为恭敬怜愍施。施物清净非盗非劫以时而施。不求名誉不求利养。或时从心大得福德。或从福田大得功德。或从妙物大得功德。第一从心如四等心念佛三昧。以身施虎如是名为从心大得功德。福田有二种。一者怜愍福田二者恭敬福田。怜愍福田能生怜愍心。恭敬福田能生恭敬心。如阿输伽(秦言无忧)王以土上佛。复次物施中。如一女人酒醉没心误以七宝璎珞布施迦叶佛塔。以福德故生三十三天。如是种种名为物施。问曰。檀名舍财。何以言具足无所舍法。答曰。檀有二种。一者出世间。二者不出世间。今说出世间檀无相。无相故无所舍。是故言具足无所舍法。复次财物不可得故。名为无所舍。是物未来过去空。现在分别无一定法。以是故言无所舍。复次以行者舍财时心念。此施大有功德。倚是而生憍慢爱结等。以是故言无所舍。以无所舍故无憍慢。无憍慢故爱结等不生。复次施者有二种。一者世间人二者出世间人。世间人能舍财不能舍施。出世间人能舍财能舍施。何以故。以财物施心俱不可得故。以是故言具足无所舍法。复次檀波罗蜜中。言财施受者三事不可得。问曰。三事和合故名为檀。今言三事不可得。云何名檀波罗蜜具足满。今有财有施有受者。云何三事不可得。如所施叠实有。何以故。叠有名则有叠法。若无叠法亦无叠名。以有名故应实有叠。复次叠有长有短粗细白黑黄赤。有因有缘有作有破有果报随法生心。十尺为长五尺为短。缕大为粗缕小为细。随染有色有缕为因。织具为缘。是因缘和合故为叠。人功为作人毁为破。御寒暑弊身体名果报。人得之大喜失之大忧。以之施故得福助道。若盗若劫戮之都市。死入地狱。如是等种种因缘。故知有此叠是名叠法。云何言施物不可得。答曰。汝言有名故有是事。不然。何以知之。名有二种有实有不实。不实名。如有一草名朱利。(朱利秦言贼也)草亦不盗不劫实非贼而名为贼。又如兔角龟毛。亦但有名而无实叠虽不如兔角龟毛无。然因缘会故有。因缘散故无。如林如军是皆有名而无实。譬如木人虽有人名不应求其人法。叠中虽有名亦不应求叠真实。叠能生人心念因缘。得之便喜失之便忧。是为念因缘。心生有二因缘。有从实而生。有从不实而生。如梦中所见如水中月。如夜见杌树谓为人。如是名从不实中能令心生。是缘不定。不应言心生有故便是有。若心生因缘故有。更不应求实有。如眼见水中月。心生谓是月。若从心生便是月者则无复真月。复次有有三种。一者相待有。二者假名有。三者法有。相待者如长短彼此等。实无长短亦无彼此。以相待故有名。长因短有短亦因长。彼亦因此此亦因彼。若在物东则以为西。在西则以为东。一物未异而有东西之别。此皆有名而无实也。如是等名为相待有。是中无实法。不如色香味触等。假名有者。如酪有色香味触四事。因缘合故假名为酪。虽有不同因缘法有。虽无亦不如兔角龟毛无。但以因缘合故假名有。酪叠亦如是。复次有极微色香味触故。有毛分。毛分因缘故有毛。毛因缘故有毳。毳因缘故有缕。缕因缘故有叠。叠因缘故有衣。若无极微色香味触因缘。亦无毛分。毛分无故亦无毛。毛无故亦无毳。毳无故亦无缕。缕无故亦无叠。叠无故亦无衣。问曰。亦不必一切物皆从因缘和合故有。如微尘至细故无分。无分故无和合。叠粗故可破。微尘中无分。云何可破。答曰。至微无实强为之名。何以故粗细相待。因粗故有细。是细复应有细。复次若有极微色。则有十方分。若有十方分是不名为极微。若无十方分则不名为色。复次若有极微则应有虚空分齐。若有分者则不名极微。复次若有极微。是中有色香味触作分。色香味触作分。是不名极微。以是推求微尘则不可得。如经言。色若粗若细若内若外。总而观之无常无我。不言有微尘。是名分破空。复有观空。是叠随心有。如坐禅人。观叠或作地或作水或作火或作风。或青或黄或白或赤或都空。如十一切入观。如佛在耆阇崛山中。与比丘僧俱入王舍城。道中见大水。佛于水上敷尼师坛坐。告诸比丘。若比丘入禅心得自在。能令大水作地即成实地。何以故。是水中有地分故。如是水火风。金银种种宝物即皆成实。何以故。是水中皆有其分。复次如一美色。淫人见之以为净妙心生染着。不净观人视之种种恶露无一净处。等妇见之妒嗔憎恶目不欲见以为不净。淫人观之为乐。妒人观之为苦。行人观之得道。无豫之人观之无所适莫。如见土木。若此美色实净。四种人观皆应见净。若实不净。四种人观皆应不净。以是故知。好丑在心。外无定也。观空亦如是。复次是叠中有十八空相故观之便空。空故不可得。如是种种因缘财物空。决定不可得。云何施人不可得。如叠因缘。和合故有。分分推之叠不可得。施者亦如是。四大围虚空名为身。是身识动作来往坐起。假名为人。分分求之亦不可得。复次一切众界入中我不可得。我不可得故施人不可得。何以故。我有种种名字。人天男女施人受人受苦人受乐人畜生等。是但有名而实法不可得。问曰。若施者不可得。云何有菩萨行檀波罗蜜。答曰。因缘和合故有名字。如屋如车实法不可得。问曰。云何我不可得。答曰。如上我闻一时中已说。今当更说。佛说六识。眼识及眼识相应法共缘色。不缘屋舍城郭种种诸名。耳鼻舌身识亦如是。意识及意识相应法。知眼知色知眼识。乃至知意知法知意识。是识所缘法皆空无我生灭故。不自在故。无为法中亦不计我。苦乐不受故。是中若强有我法。应当有第七识识我。而今不尔。以是故知无我。问曰。何以识无我。一切人各于自身中生计我。不于他身中生我。若自身中无我。而妄见为我者。他身中无我亦应于他身而妄见为我。复次若内无我。色识念念生灭。云何分别知是色青黄赤白。复次若无我今现在人识。渐渐生灭。身命断时亦尽诸行罪福。谁随谁受。谁受苦乐谁解脱者。如是种种内缘故。知有我。答曰。此俱有难。若于他身生计我者。复当言。何以不自身中生计我。复次五众因缘生故空无我。从无明因缘生二十身见。是我见自于五阴相续生。以从此五众缘生故。即计此五众为我。不在他身以其习故。复次若有神者可有彼我。汝神有无未了而问彼我。其犹人问兔角。答似马角。马角若实有可以证兔角。马角犹尚未了。而欲以证兔角。复次自于身生我故便自谓有神。汝言神遍亦应计他身为我以是故不应言自身中生计我心于他身不生。故知有神。复次有人于他物中我心生。如外道坐禅人。用地一切入观时。见地则是我我则是地。水火风空亦如是。颠倒故于他身中亦计我。复次有时于他身生我。如有一人受使远行。独宿空舍。夜中有鬼担一死人来着其前。复有一鬼逐来嗔骂前鬼。是死人是我物。汝何以担来。先鬼言是我物我自持来。后鬼言是死人实我担来。二鬼各捉一手争之。前鬼言此有人可问。后鬼即问。是死人谁担来。是人思惟。此二鬼力大。若实语亦当死。若妄语亦当死。俱不免死何为妄语。语言。前鬼担来。后鬼大嗔。捉人手拔出着地。前鬼取死人一臂拊之即着。如是两臂两脚头胁举身皆易。于是二鬼共食所易人身拭口而去。其人思惟。我人母生身眼见二鬼食尽。今我此身尽是他肉。我今定有身耶。为无身耶。若以为有尽是他身。若以为无今现有身。如是思惟。其心迷闷。譬如狂人。明朝寻路而去。到前国土见有佛塔众僧。不论余事但问己身为有为无。诸比丘问。汝是何人。答言。我亦不自知是人非人。即为众僧广说上事。诸比丘言。此人自知无我易可得度。而语之言。汝身从本已来恒自无我。非适今也。但以四大和合故计为我身。如汝本身与今无异。诸比丘度之为道断诸烦恼。即得阿罗汉是为有时他身亦计为我。不可以有彼此故谓有我。复次是我实性决定不可得。若常相非常相自在相不自在相作相不作相色相非色相。如是等种种皆不可得。若有相则有法。无相则无法。我今无相则知无我。若我是常不应有杀罪。何以故身可杀非常故。我不可杀。常故。问曰。我虽常故不可杀。但杀身则有杀罪。答曰。若杀身有杀罪者。毗尼中言。自杀无杀罪。罪福从恼他益他生。非自供养身自杀身故有罪有福。以是故毗尼中言。自杀身无杀罪。有愚痴贪欲嗔恚之咎。若神常者不应死不应生。何以故汝等法神常。一切遍满五道中。云何有死生。死名此处失。生名彼处出。以是故不得言神常。若神常者亦应不受苦乐。何以故苦来则忧乐至则喜。若为忧喜所变者则非常也。若常应如虚空雨不能湿热不能干。亦无今世后世。若神常者示不应有后世生今世死。若神常者则常有我见。不应得涅槃。若神常者则无起无灭。不应有妄失。以其无神识无常故。有忘有失。是故神非常也。如是等种种因缘可知神非常相。若神无常相者亦无罪无福。若身无常神亦无常。二事俱灭则堕断灭边。堕断灭则无到后世受罪福者。若断灭则得涅槃。不须断结亦不用后世罪福因缘。如是等种种因缘可知神非无常。若神自在相作相者。则应随所欲得皆得。今所欲更不得。非所欲更得。若神自在。亦不应有作恶行堕畜生恶道中。复次一切众生皆不乐苦。谁当好乐而更得苦。以是故知神不自在。亦不作。又如人畏罪故自强行善。若自在者。何以畏罪而自强修福。又诸众生不得如意。常为烦恼爱缚所牵。如是等种种因缘。知神不自在不自作。若神不自在不自作者。是为无神相。言我者即是六识更无异事。复次若不作者。云何阎罗王问罪人。谁使汝作此罪者。罪人答言。是我自作。以是故知非不自作。若神色相者是事不然。何以故。一切色无常故。问曰。人云何言色是我相。答曰。有人言。神在心中微细如芥子。清净名为净色身。更有人言如麦。有言如豆。有言半寸。有言一寸。初受身时最在前受。譬如像骨及其成身如像已庄。有言大小随人身。死坏时此亦前出。如此事皆不尔也。何以故。一切色四大所造。因缘生故无常。若神是色色无常神亦无常。若无常者如上所说。问曰。身有二种。粗身及细身。粗身无常细身是神。世世常去入五道中。答曰。此细身不可得。若有细身应有处所可得。如五藏四体。一一处中求皆不可得。问曰。此细身微细。初死时已去。若活时则不可求得汝云何能见。又此细身非五情能见能知。唯有神通圣人乃能得见。答曰。若尔者与无无异。如人死时。舍此生阴入中阴中。是时今世身灭受中阴身。此无前后灭时即生。譬如蜡印印泥。泥中受印印即时坏。成坏一时亦无前后。是时受中阴中有。舍此中阴受生阴有。汝言细身即此中阴。中阴身无出无入。譬如然灯生灭相续不常不断。佛言一切色众。若过去未来现在。若内若外若粗若细皆悉无常。汝神微细色者。亦应无常断灭。如是等种种因缘可知非色相。神非无色相。无色者四众及无为。四众无常故。不自在故。属因缘故。不应是神。三无为中不计有神。无所受故。如是等种种因缘。知神非无色相。如是天地间若内若外。三世十方求我不可得。但十二入和合生六识。三事和合名触。触生受想思等心数法。是法中无明力故身见生。身见生故谓有神。是身见见苦谛苦法智及苦比智则断。断时则不见有神。汝先言若内无神色。识念念生灭。云何分别知色青黄赤白。汝若有神亦不能独知。要依眼识故能知。若尔者神无用也。眼识知色色生灭。相似生相似灭。然后心中有法生名为念。是念相有为法。虽灭过去是念能知。如圣人智慧力。能知未来世事。念念亦如是。能知过去法。若前眼识灭生后眼识。后眼识转利有力。色虽暂有不住。以念力利故能知。以是事故虽念念生灭无常。能分别知色。又汝言今现在人识新新生灭。身命断时亦尽。诸行罪福谁随谁受。谁受苦乐谁解脱者。今当答汝。今未得实道。是人诸烦恼覆心。作生因缘业。死时从此五阴相续生五阴。譬如一灯更然一灯。又如谷生。有三因缘地水种子。后世身生亦如是。有身有有漏业有结使。三事故后身生。是中身业因缘不可断不可破。但诸结使可断。结使断时虽有残身残业可得解脱。如有谷子有地无水故不生。如是虽有身有业。无爱结水润则不生。是名虽无神亦名得解脱。无明故缚。智慧故解。则我无所用。复次是名色和合假名为人。是人为诸结所系。得无漏智慧爪解此诸结。是时名人得解脱。如绳结绳解。绳即是结。结无异法。世界中说结绳解绳。名色亦如是。名色二法和合假名为人。是结使与名色不异。但名为名色结。名色解受罪福亦如是。虽无一法为人实。名色故受罪福果。而人得名。譬如车载物。一一推之竟无车实。然车受载物之名。人受罪福亦如是。名色受罪福而人受其名。受苦乐亦如是。如是种种因缘神不可得。神即是施者。受者亦如是。汝以神为人。以是故施人不可得。受人不可得。亦如是如是种种因缘。是名财物施人受人不可得。问曰。若施于诸法是如实相无所破无所灭无所生无所作。何以故。言三事破析不可得。答曰。如凡夫人。见施者见受者见财物。是为颠倒妄见。生世间受乐福尽转还。是故佛欲令菩萨行实道得实果报。实果报则是佛道。佛为破妄见故。言三事不可得。实无所破。何以故。诸法从本已来毕竟空故。如是等种种无量因缘不可得。故名为檀波罗蜜具足满。复次若菩萨行檀波罗蜜。能生六波罗蜜。是时名为檀波罗蜜具足满。云何布施生檀波罗蜜。檀有下中上。从下生中从中生上。若以饮食粗物软心布施。是名为下。习施转增能以衣服宝物布施。是为从下生中。施心转增无所爱惜。能以头目血肉国财妻子尽用布施。是为从中生上。如释迦牟尼佛初发心时。作大国王名曰光明。求索佛道少多布施。转受后身作陶师。能以澡浴之具及石蜜浆。布施异释迦牟尼佛及比丘僧。其后转身作大长者女。以灯供养憍陈若佛。如是等种种名为菩萨下布施。如释迦文尼佛。本身作长者子。以衣布施大音声佛。佛灭度后起九十塔。后更转身作大国王。以七宝盖供养师子佛。后复受身作大长者。供养妙目佛上好房舍及七宝妙华。如是等种种名为菩萨中布施。如释迦牟尼佛本身。作仙人见憍陈若佛端政殊妙便从高山上自投佛前。其身安隐在一面立。又如众生喜见菩萨。以身为灯供养日月光德佛。如是等种种不惜身命供养诸佛。是为菩萨上布施。是名菩萨三种布施。若有初发佛心布施众生亦复如是。初以饮食布施。施心转增能以身肉与之。先以种种好浆布施。后心转增能以身血与之。先以纸墨经书布施。及以衣服饮食四种供养供养法师。后得法身为无量众生。说种种法而为法施。如是等种种从檀波罗蜜中。生檀波罗蜜。云何菩萨布施生尸罗波罗蜜。菩萨思惟众生不布施故。后世贫穷。以贫穷故劫盗心生。以劫盗故而有杀害。以贫穷故不足于色。色不足故而行邪淫。又以贫穷故为人下贱。下贱畏怖而生妄语。如是等贫穷因缘故。行十不善道。若行布施生有财物。有财物故不为非法。何以故五尘充足无所乏短故。如提婆达。本生曾为一蛇。与一虾蟆一龟在一池中共结亲友。其后池水竭尽。饥穷困乏无所控告。时蛇遣龟以呼虾蟆。虾蟆说偈以遣龟言

  若遭贫穷失本心　　不惟本义食为先
  汝持我声以语蛇　　虾蟆终不到汝边

若修布施后生有福无所短乏。则能持戒无此众恶。是为布施能生尸罗波罗蜜。复次布施时能令破戒诸结使薄。益持戒心令得坚固。是为布施因缘增益于戒。复次菩萨布施。常于受者生慈悲心。不着于财自物不惜。何况劫盗。慈悲受者何有杀意。如是等能遮破戒。是为施生戒。若能布施以破悭心。然后持戒忍辱等易可得行。如文殊师利。在昔过去久远劫时。曾为比丘入城乞食。得满钵百味欢喜丸。城中一小儿追而从乞不即与之。乃至佛图手捉二丸而要之言。汝若能自食一丸。以一丸施僧者当以施汝。即相然可。以一欢喜丸布施众僧。然后于文殊师利许受戒发心作佛。如是布施能令受戒发心作佛。是为布施生尸罗波罗蜜。复次布施之报得四事供养好国善师无所乏少。故能持戒。又布施之报其心调柔。心调柔故能生持戒。能生持戒故从不善法中能自制心。如是种种因缘。从布施生尸罗波罗蜜。云何布施生羼提波罗蜜。菩萨布施时受者逆骂。若大求索若不时索。或不应索而索。是时菩萨自思惟言。我今布施欲求佛道。亦无有人使我布施。我自为故云何生嗔。如是思惟已而行忍辱。是名布施生羼提波罗蜜。复次菩萨布施时。若受者嗔恼。便自思惟。我今布施内外财物。难舍能舍。何况空声而不能忍。若我不忍所可布施则为不净。譬如白象入池澡浴。出已还复以土坌身。布施不忍亦复如是。如是思惟已行于忍辱。如是等种种布施因缘生羼提波罗蜜。云何布施生毗梨耶波罗蜜。菩萨布施时常行精进。何以故。菩萨初发心时功德未大。尔时欲行二施充满一切众生之愿。以物不足故。勤求财法以给足之。如释迦文尼佛本身。作大医王疗一切病不求名利。为怜愍众生故。病者甚多力不周救。忧念一切而不从心。懊恼而死即生忉利天上。自思惟言。我今生天。但食福报无所长益。即自方便自取灭身。舍此天寿生婆迦陀龙王宫中为龙太子。其身长大父母爱重。欲自取死就金翅鸟王。鸟即取此龙子。于舍摩利树上吞之。父母嗥啕啼哭懊恼。龙子既死生阎浮提中。为大国王太子。名曰能施。生而能言。问诸左右。今此国中有何等物。尽皆持来以用布施。众人怪畏皆舍之走。其母怜爱独自守之。语其母言。我非罗刹众人何以故走。我本宿命常好布施。我为一切人之檀越。母闻其言以语众人。众人即还母好养育。及年长大自身所有尽以施尽。至父王所索物布施。父与其分复以施尽。见阎浮提人贫穷辛苦。思欲给施而财物不足。便自啼泣问诸人言。作何方便当令一切满足于财。诸宿人言。我等曾闻有如意宝珠。若得此珠则能随心所索无不必得。菩萨闻是语已白其父母。欲入大海求龙王头上如意宝珠。父母报言。我唯有汝一儿耳。若入大海众难难度。一旦失汝我等亦当何用活为。不须去也。我今藏中犹亦有物当以给汝。儿言。藏中有限。我意无量。我欲以财充满一切令无乏短。愿见听许。得遂本心使阎浮提人一切充足。父母知其志大。不敢制之。遂放令去。是时五百贾客。以其福德大。人皆乐随从。知其行日集海道口。菩萨先闻婆伽陀龙王头上有如意宝珠。问众人言。谁知水道至彼龙宫。有一盲人名陀舍。曾以七反入大海中具知海道。菩萨即命共行。答曰。我年既老两目失明。曾虽数入今不能去。菩萨语言。我今此行不自为身。普为一切求如意宝珠。欲给足众生令身无乏。次以道法因缘而教化之。汝是智人何得辞耶。我愿得成岂非汝力。陀舍闻其要言。欣然同怀语菩萨言。我今共汝俱入大海我必不全。汝当安我尸骸着大海之中金沙洲上。行事都集断第七绳。船去如驼到众宝渚。众贾竞取七宝各各已足。语菩萨言。何以不取。菩萨报言。我所求者如意宝珠。此有尽物我不须也。汝等各当知足知量无令船重不自免也。是时众贾白菩萨言。大德。为我咒愿令得安隐。于是辞去。陀舍是时语菩萨言。别留艇舟当随是别道而去。待风七日。博海南岸至一险处。当有绝崖枣林枝皆覆水。大风吹船船当摧覆。汝当仰板枣枝可以自济。我身无目于此当死。过此隘岸当有金沙洲。可以我身置此沙中。金沙清净是我愿也。即如其言。风至而去。既到绝崖。如陀舍语。菩萨仰板枣枝得以自免。置陀舍尸安厝金地。于是独去如其先教。深水中浮七日。至垒咽水中行七日。垒腰水中行七日。垒膝水中行七日。泥中行七日。见好莲华鲜洁柔软。自思惟言。此华软脆当入虚空三昧。自轻其身行莲华上七日。见诸毒蛇念言。含毒之虫甚可畏也。即入慈心三昧。行毒蛇头上七日。蛇皆擎头授与菩萨令蹈上而过。过此难已见有七重宝城。有七重堑。堑中皆满毒蛇有三大龙守门。龙见菩萨形容端政相好严仪。能度众难得来至此念言。此非凡夫必是菩萨大功德人。即听令前迳得入宫。龙王夫妇丧儿未久犹故哀泣。见菩萨来龙王妇有神通。知是其子。两乳汁流出。命之令坐。而问之言。汝是我子。舍我命终生在何处。菩萨亦自识宿命。知是父母而答母言。我生阎浮提上。为大国王太子。怜愍贫人饥寒勤苦不得自在故。来至此欲求如意宝珠。母言。汝父头上有此宝珠以为首饰。难可得也。必当将汝入诸宝藏。随汝所欲必欲与汝。汝当报言。其余杂宝我不须也。唯欲大王头上宝珠。若见怜愍愿以与我。如此可得。即往见父。父大悲喜欢庆无量。愍念其子远涉艰难乃来至此。指示妙宝随意与汝须者取之。菩萨言。我从远来愿见大王。求王头上如意宝珠。若见怜愍当以与我。若不见与不须余物。龙王报言。我唯有此一珠常为首饰。阎浮提人薄福下贱不应见也。菩萨白言。我以此故。远涉艰难冒死远来。为阎浮提人薄福贫贱。欲以如意宝珠济其所愿。然后以佛道因缘而教化之。龙王与珠而要之言。今以此珠与汝。汝既去世当以还我。答曰。敬如王言。菩萨得珠飞腾虚空。如屈伸臂顷到阎浮提。人王父母见儿吉还。欢悦踊跃抱而问言。汝得何物。答言。得如意宝珠。问言。今在何许。白言。在此衣角里中。父母言。何其泰小。白言。在其神德不在大也。白父母言。当敕城中内外扫洒烧香。悬缯幡盖持斋受戒。明日清旦以长木为表以珠着上。菩萨是时自立誓愿。若我当成佛道度脱一切者。珠当如我意愿出一切宝物。随人所须尽皆备有。是时阴云普遍雨种种宝物。衣服饮食卧具汤药。人之所须一切具足。至其命尽常尔不绝。如是等名为菩萨布施生精进波罗蜜。云何菩萨布施生禅波罗蜜。菩萨布施时能除悭贪。除悭贪已因此布施而行一心渐除五盖。能除五盖是名为禅。复次心依布施入于初禅。乃至灭定禅。云何为依。若施行禅人时心自念言。我以此人行禅定故。净心供养。我今何为自替于禅。即自敛心思惟行禅。若施贫人念此宿命。作诸不善不求一心不修福业今世贫穷。以是自勉修善一心以入禅定。如说。喜见转轮圣王八万四千小王来朝。皆持七宝妙物来献。王言我不须也。汝等各可自以修福。诸王自念。大王虽不肯取。我等亦复不宜自用。即共造工立七宝殿。殖七宝行树作七宝浴池。于大殿中造八万四千七宝楼。楼中皆有七宝床座。杂色被枕置床两头。悬缯幡盖香熏涂地。众事备已。白大王言。愿受法殿宝树浴池。王默然受之。而自念言。我今不应先处新殿以自娱乐。当求善人诸沙门婆罗门等先入供养。然后我当处之。即集善人先入宝殿。种种供养微妙具足。诸人出已王入宝殿登金楼坐银床。念布施除五盖摄六情却六尘受喜乐入初禅。次登银楼坐金床入二禅。次登毗琉璃楼坐颇梨宝床入三禅。次登颇梨宝楼坐毗琉璃床入四禅。独坐思惟终竟三月。玉女宝后与八万四千诸侍女俱。皆以白珠名宝璎珞其身。来白大王。久违亲觐。敢来问讯。王告诸妹。汝等各当端心。当为知识勿为我怨。玉女宝后垂泪而言。大王何为谓我为妹。必有异心愿闻其意。云何见敕当为知识勿为我怨。王告之言。汝若以我为世因缘。共行欲事以为欢乐。是为我怨。若能觉悟非常知身如幻。修福行善绝去欲情。是为知识。诸玉女言敬如王敕。说此语已各遣令还。诸女出已王登金楼坐银床行慈三昧。登银楼坐金床行悲三昧。登毗琉璃楼坐颇梨床行喜三昧。登颇梨宝楼坐毗琉璃床行舍三昧。是为菩萨布施生禅波罗蜜。云何菩萨布施生般若波罗蜜。菩萨布施时。知此布施必有果报而不疑惑。能破邪见无明。是为布施生般若波罗蜜。复次菩萨布施时能分别知。不持戒人若鞭打拷掠闭系。枉法得财而作布施。生象马牛中。虽受畜生形负重鞭策羁靽乘骑。而常得好屋好食。为人所重以人供给。又知恶人多怀嗔恚。心曲不端而行布施当堕龙中。得七宝宫殿妙食好色。又知憍人多慢嗔心布施。堕金翅鸟中。常得自在。有如意宝珠以为璎珞。种种所须皆得自恣无不如意。变化万端无事不办。又知宰官之人。枉滥人民不顺治法而取财物。以用布施堕鬼神中。作鸠槃茶鬼。能种种变化五尘自娱。又知多嗔佷戾嗜好酒肉之人。而行布施堕地夜叉鬼中。常得种种欢乐音乐饮食。又知有人刚愎强梁。而能布施车马代步。堕虚空夜叉中。而有大力所至如风。又知有人妒心好诤。而能以好房舍卧具衣服饮食布施故。生宫观飞行夜叉中。有种种娱乐便身之物。如是种种当布施时能分别知。是为菩萨布施生般若。复次布施饮食得力色命乐瞻。若布施衣服得生知惭愧。威德端正身心安乐。若施房舍则得种种七宝宫观。自然而有五欲自娱。若施井池泉水种种好浆。所生则得无饥无渴五欲备有。若施桥船及诸履屣。生有种种车马具足。若施园林则得豪尊。为一切依止。受身端政心乐无忧。如是等种种。人中因缘布施所得。若人布施修作福德。不好有为作业生活。则得生四天王处。若人布施。加以供养父母及诸伯叔兄弟姊妹。无嗔无恨不好诤讼。又不喜见诤讼之人。得生忉利天上焰摩兜术化自在他化自在。如是种种分别布施。是为菩萨布施生般若。若人布施心不染着。厌患世间求涅槃乐。是为阿罗汉辟支佛布施。若人布施为佛道为众生故。是为菩萨布施。如是等种种布施中分别知。是为布施生般若波罗蜜。复次菩萨布施时。思惟三事实相。如上说。如是能知是为布施生般若波罗蜜。复次一切智慧功德因缘。皆由布施。如千佛始发意时。种种财物布施诸佛。或以华香或以衣服。或以杨枝布施而以发意。如是等种种布施。是为菩萨布施生般若波罗蜜

大智度论卷第十二大智度论释初品中尸罗波罗蜜义第二十一(卷第十三)

        龙树菩萨造

        后秦龟兹国三藏鸠摩罗什奉　诏译

【经】罪不罪不可得故。应具足尸罗波罗蜜

【论】尸罗(秦言性善)好行善道不自放逸。是名尸罗。或受戒行善或不受戒行善。皆名尸罗。尸罗者。略说身口律仪有八种。不恼害不劫盗不邪淫不妄语不两舌不恶口不绮语不饮酒及净命。是名戒相。若不护放舍。是名破戒。破此戒者堕三恶道中。若下持戒生人中。中持戒生六欲天中。上持戒又行四禅四空定。生色无色界清净天中。上持戒有三种。下清净持戒得阿罗汉。中清净持戒得辟支佛。上清净持戒得佛道。不着不猗不破不缺圣所赞爱。如是名为上清净持戒。若慈愍众生故。为度众生故。亦知戒实相故心不猗着。如此持戒将来令人至佛道。如是名为得无上佛道戒。若人求大善利。当坚持戒如惜重宝。如护身命。何以故譬如大地一切万物有形之类。皆依地而住。戒亦如是戒为一切善法住处。复次譬如无足欲行无翅欲飞无船欲渡。是不可得。若无戒欲得好果亦复如是。若人弃舍此戒。虽山居苦行食果服药。与禽兽无异。或有人但服水为戒。或服乳或服气或剃发或长发。或顶上留少许发。或着袈裟或着白衣或着草衣或木皮衣。或冬入水或夏火炙。若自坠高岩若于恒河中洗。若日三浴再供养火。种种祠祀种种咒愿受行苦行。以无此戒空无所得。若有人虽处高堂大殿好衣美食。而能行此戒者得生好处。及得道果。若贵若贱若小若大。能行此净戒皆得大利。若破此戒无贵无贱无大无小。皆不得随意生善处。复次破戒之人。譬如清凉池而有毒蛇不中澡浴。亦如好华果树而多逆刺。若人虽在贵家生身体端政广学多闻。而不乐持戒无慈愍心。亦复如是如偈说

  贵而无智则为衰　　智而憍慢亦为衰
  持戒之人而毁戒　　今世后世一切衰

人虽贫贱。而能持戒胜于富贵。而破戒者华香木香不能远闻。持戒之香周遍十方。持戒之人具足安乐。名声远闻天人敬爱。现世常得种种快乐。若欲天上人中富贵长寿。取之不难。持戒清净所愿皆得。复次持戒之人。见破戒人刑狱考掠种种苦恼。自知永离此事以为欣庆。若持戒之人。见善人得誉名闻快乐。心自念言。如彼得誉。我亦有分。持戒之人寿终之时刀风解身筋脉断绝。自知持戒清净心不怖畏。如偈说

  大恶病中　　戒为良药　　大恐怖中
  戒为守护　　死闇冥中　　戒为明灯
  于恶道中　　戒为桥梁　　死海水中
  戒为大船

复次持戒之人。常得今世人所敬养心乐不悔。衣食无乏。死得生天后得佛道。持戒之人无事不得。破戒之人一切皆失。譬如有人常供养天。其人贫穷一心供养满十二岁求索富贵。天愍此人自现其身而问之曰。汝求何等。答言。我求富贵。欲令心之所愿一切皆得。天与一器名曰德瓶。而语之言。所须之物从此瓶出。其人得已应意所欲无所不得。得如意已具作好舍象马车乘。七宝具足。供给宾客事事无乏。客问之言。汝先贫穷。今日所由得如此富。答言。我得天瓶。瓶能出此种种众物故富如是。客言。出瓶见示并所出物。即为出瓶。瓶中引出种种众物。其人憍泆立瓶上舞。瓶即破坏。一切众物亦一时灭。持戒之人亦复如是。种种妙乐无愿不得。若人破戒憍泆自恣亦如彼人破瓶失物。复次持戒之人名称之香。今世后世周满天上及在人中。复次持戒之人。人所乐施不惜财物。不修世利而无所乏得生天上。十方佛前入三乘道而得解脱。唯种种邪见。持戒后无所得。复次若人虽不出家。但能修行戒法。亦得生天。若人持戒清净行禅智慧。欲求度脱老病死苦此愿必得。持戒之人虽无兵仗众恶不加。持戒之财无能夺者。持戒亲亲虽死不离。持戒庄严胜于七宝。以是之故。当护于戒如护身命如爱宝物。破戒之人受苦万端。如向贫人破瓶失物。以是之故应持净戒。复次持戒之人。观破戒人罪应自勉励一心持戒。云何名为破戒人罪。破戒之人人所不敬。其家如冢人所不到。破戒之人失诸功德。譬如枯树人不爱乐。破戒之人如霜莲花人不喜见。破戒之人恶心可畏譬如罗刹。破戒之人人不归向。譬如渴人不向枯井。破戒之人心常疑悔。譬如犯事之人常畏罪至。破戒之人如田被雹不可依仰。破戒之人譬如苦苽。虽形似甘种而不可食。破戒之人如贼聚落不可依止。破戒之人譬如大病人不欲近。破戒之人不得免苦。譬如恶道难可得过。破戒之人不可共止。譬如恶贼难可亲近。破戒之人譬如大坑行者避之。破戒之人难可共住譬如毒蛇。破戒之人不可近触譬如大火。破戒之人譬如破船不可乘渡。破戒之人譬如吐食不可更啖。破戒之人在好众中。譬如恶马在善马群。破戒之人与善人异。如驴在牛群。破戒之人在精进众。譬如儜儿在健人中。破戒之人虽似比丘。譬如死尸在眠人中。破戒之人譬如伪珠在真珠中。破戒之人譬如伊兰在栴檀林。破戒之人虽形似善人内无善法。虽复剃头染衣次第捉筹名为比丘。实非比丘。破戒之人若着法衣。则是热铜铁鍱以缠其身。若持钵盂则是盛洋铜器。若所啖食则是吞烧铁丸。饮热洋铜。若受人供养供给。则是地狱狱鬼守之。若入精舍则是入大地狱。若坐众僧床榻。是为坐热铁床上。复次破戒之人。常怀怖懅如重病人常畏死至。亦如五逆罪人。心常自念我为佛贼。藏覆避隈如贼畏人。岁月日过常不安隐。破戒之人虽得供养利乐是乐不净。譬如愚人供养庄严死尸。智者闻之恶不欲见。如是种种无量。破戒之罪不可称说。行者应当一心持戒

    大智度论释初品中戒相义第二十二之一

问曰。已知如是种种功德果报。云何名为戒相。答曰。恶止不更作。若心生若口言若从他受。息身口恶是为戒相。云何名为恶。若实是众生。知是众生发心欲杀而夺其命。生身业有作色。是名杀生罪。其余系闭鞭打等。是助杀法。复次杀他得杀罪。非自杀身心知众生而杀。是名杀罪。不如夜中见人谓为杌树而杀者。故杀生得杀罪。非不故也。快心杀生得杀罪非狂痴。命根断是杀罪。非作疮身业是杀罪。非但口教敕口教是杀罪。非但心生如是等名杀罪。不作是罪名为戒。若人受戒心生口言。我从今日不复杀生。若身不动口不言。而独心生自誓。我从今日不复杀生。是名不杀生戒。有人言。是不杀生戒或善或无记。问曰。如阿毗昙中说。一切戒律仪皆善。今何以言无记。答曰。如迦栴延子阿毗昙中言一切善。如余阿毗昙中言。不杀戒或善或无记。何以故。若不杀戒常善者。持此戒人应如得道人常不堕恶道。以是故或时应无记。无记无果报故。不生天上人中。问曰。不以戒无记故堕地狱。更有恶心生故堕地狱。答曰。不杀生得无量善法。作无作福常日夜生故。若作少罪有限有量。何以故。随有量而不随无量。以是故知。不杀戒中或有无记。复次有人不从师受戒。而但心生自誓。我从今日不复杀生。如是不杀或时无记。问曰。是不杀戒何界系。答曰。如迦栴延子阿毗昙中言一切受戒律仪。皆欲界系。余阿毗昙中言。或欲界系或不系。以实言之应有三种。或欲界系或色界系或无漏。杀生法虽欲界。不杀戒应随杀在欲界。但色界不杀。无漏不杀远遮故。是真不杀戒。复次有人不受戒。而从生已来不好杀生。或善或无记是名无记。是不杀生法非心非心数法亦非心相应。或共心生或不共心生。迦栴延子阿毗昙中言。不杀生是身口业。或作色或无作色。或时随心行或不随心行。(丹注云随心行定共戒不随心意五戒)非先世业报。二种修应修。二种证应证。(丹注云身证慧证)思惟断一切欲界最后得见断时断。凡夫圣人所得是色法。或可见或不可见法。或有对法或无对法。有报法有果法。有漏法有为法有上法。(丹注云非极故有上)非相应因。如是等分别是名不杀戒。问曰。八直道中戒亦不杀生。何以独言不杀生戒有报有漏。答曰。此中但说受戒律仪法。不说无漏戒律仪。复次余阿毗昙中言。不杀法常不逐心行。非身口业。不随心业行。或有报或无报非心相应法或有漏或无漏。是为异法。余者皆同。复有言。诸佛贤圣不戏论诸法。(丹注云种种异说名为戏也)现前众生各各惜命。是故佛言。莫夺他命。夺他命世世受诸苦痛。众生有无后当说。问曰。人能以力胜人并国杀怨。或田猎皮肉所济处大。令不杀生得何等利。答曰。得无所畏安乐无怖。我以无害于彼故。彼亦无害于我。以是故无怖无畏。好杀之人虽复位极人王。亦不自安。如持戒之人。单行独游无所畏难。复次好杀之人。有命之属皆不喜见。若不好杀。一切众生皆乐依附。复次持戒之人。命欲终时其心安乐无疑无悔。若生天上若在人中常得长寿。是为得道因缘。乃至得佛住寿无量。复次杀生之人。今世后世受种种身心苦痛。不杀之人无此众难。是为大利。复次行者思惟。我自惜命爱身。彼亦如是与我何异。以是之故不应杀生。复次若人杀生者。为善人所诃怨家所嫉。负他命故常有怖畏为彼所憎。死时心悔当堕地狱若畜生中。若出为人常当短命。复次假令后世无罪。不为善人所诃怨家所嫉。尚不应故夺他命。何以故。善相之人所不应行。何况两世有罪弊恶果报。复次杀为罪中之重。何以故人有死急不惜重宝。但以活命为先。譬如贾客入海采宝。垂出大海其船卒坏珍宝失尽。而自喜庆举手而言。几失大宝。众人怪言。汝失财物裸形得脱。云何喜言几失大宝。答言。一切宝中人命第一。人为命故求财。不为财故求命。以是故。佛说十不善道中杀罪最在初。五戒中亦最在初。若人种种修诸福德。而无不杀生戒则无所益。何以故。虽在富贵处生势力豪强。而无寿命谁受此乐。以是故知。诸余罪中杀罪最重。诸功德中不杀第一。世间中惜命为第一。何以知之。一切世人甘受刑罚刑残考掠以护寿命。复次若有人受戒心生。从今日不杀一切众生。是于无量众生中。已以所爱重物施与。所得功德亦复无量。如佛说有五大施。何等五。一者不杀生是为最大施。不盗不邪淫不妄语不饮酒亦复如是。复次行慈三昧其福无量。水火不害刀兵不伤。一切恶毒所不能中。以五大施故所得如是。复次三世十方中尊佛为第一。如佛语难提迦优婆塞。杀生有十罪。何等为十。一者心常怀毒世世不绝。二者众生憎恶眼不喜见。三者常怀恶念思惟恶事。四者众生畏之如见蛇虎。五者睡时心怖觉亦不安。六者常有恶梦。七者命终之时狂怖恶死。八者种短命业因缘。九者身坏命终堕泥梨中。十者若出为人常当短命。复次行者心念。一切有命乃至昆虫皆自惜身。云何以衣服饮食。自为身故而杀众生。复次行者当学大人法。一切大人中佛为最大。何以故。一切智慧成就十力具足。能度众生常行慈愍。持不杀戒自致得佛。亦教弟子行此慈愍。行者欲学大人行故亦当不杀。问曰。不侵我者杀心可息。若为侵害强夺逼迫。是当云何。答曰。应当量其轻重。若人杀己先自思惟。全戒利重全身为重。破戒为失丧身为失。如是思惟已。知持戒为重全身为轻。若苟免全身身何所得。是身名为老病死薮。必当坏败。若为持戒失身其利甚重。又复思惟。我前后失身世世无数。或作恶贼禽兽之身。但为财利诸不善事。今乃得为持净戒故。不惜此身舍命持戒。胜于毁禁全身。百千万倍不可为喻。如是定心应当舍身。以护净戒。如一须陀洹人。生屠杀家年向成人。应当修其家业而不肯杀生。父母与刀并一口羊闭着屋中。而语之言。若不杀羊。不令汝出得见日月生活饮食。儿自思惟言。我若杀此一羊。便当终为此业。岂以身故为此大罪。便以刀自杀。父母开户见。羊在一面立儿已命绝。当自杀时即生天上。若如此者是为不惜寿命全护净戒。如是等义是名不杀生戒。不与取者。知他物生盗心。取物去离本处物属我。是名盗。若不作是名不盗。其余方便计挍。乃至手捉未离地者名助盗法。财物有二种。有属他有不属他。取属他物是为盗罪。属他物亦有二种。一者聚落中二者空地。此二处物。盗心取得盗罪若物在空地当捡挍。知是物近谁国。是物应当有属不应取。如毗尼中说种种不盗。是名不盗相。问曰。不盗有何等利。答曰。人命有二种。一者内。二者外。若夺财物是为夺外命。何以故。命依饮食衣被等故活。若劫若夺是名夺外命。如偈说

  一切诸众生　　衣食以自活
  若夺若劫取　　是名劫夺命

以是事故有智之人不应劫夺。复次当自思惟。劫夺得物以自供养。虽身充足会亦当死。死入地狱。家室亲属虽共受乐。独自受罪。亦不能救。已得此观应当不盗。复次是不与取有二种。一者偷。二者劫。此二共名不与取。于不与取中盗为最重。何以故。一切人以财自活。而或穿踰盗取是最不净。何以故。无力胜人畏死。盗取故。劫夺之中盗为罪重。如偈说

  饥饿身羸瘦　　受罪大苦剧
  他物不可触　　譬如大火聚
  若盗取他物　　其主泣懊恼
  假使天王等　　犹亦以为苦

杀生人罪虽重。然于所杀者是贼。偷盗人于一切有物人中贼。若犯余戒。于异国中有不以为罪者。若偷盗人。一切诸国无不治罪。问曰。劫夺之人。今世有人赞美其健。于此劫夺何以不作。答曰。不与而盗是不善相。劫盗之中虽有差降俱为不善。譬如美食杂毒恶食杂毒。美恶虽殊杂毒不异。亦如明闇蹈火昼夜虽异烧足一也。今世愚人不识罪福二世果报。无仁慈心。见人能以力相侵强夺他财。赞以为强。诸佛贤圣慈愍一切。了达三世殃祸不朽。所不称誉。以是故知劫盗之罪俱为不善。善人行者之所不为。如佛说。不与取有十罪。何等为十。一者物主常嗔。二者重疑(丹注云重罪人疑)三者非行时不筹量。四者朋党恶人远离贤善。五者破善相。六者得罪于官。七者财物没入。八者种贫穷业因缘。九者死入地狱。十者若出为人勤苦求财。五家所共若王若贼若火若水若不爱子用。乃至藏埋亦失。邪淫者。若女人为父母兄弟姊妹夫主儿子世间法王法守护。若犯者是名邪淫。若有虽不守护以法为守。云何法守。一切出家女人在家。受一日戒。是名法守。若以力若以财若诳诱若自有妻受戒有娠乳儿非道。如是犯者名为邪淫。如是种种乃至以华鬘与淫女为要。如是犯者名为邪淫。如是种种不作。名为不邪淫。问曰。人守人嗔法守破法应名邪淫。人自有妻何以为邪。答曰。既听受一日戒。堕于法中。本虽是妇今不自在。过受戒时则非法守。有娠妇人以其身重。厌本所习。又为伤娠。乳儿时淫其母乳则竭。又以心着淫欲不复护儿。非道之处则非女根女心不乐。强以非理故名邪淫。是事不作名为不邪淫。问曰。若夫主不知不见不恼。他有何罪。答曰。以其邪故既名为邪。是为不正。是故有罪。复次此有种种罪过。夫妻之情异身同体。夺他所爱破其本心。是名为贼。复有重罪。恶名丑声为人所憎少乐多畏。或畏刑戮又畏夫主傍人所知多怀妄语。圣人所呵罪中之罪(丹注云淫罪邪淫破戒故名罪中之罪)复次淫劮之人当自思惟。我妇他妻同为女人。骨肉情态彼此无异。而我何为横生惑心随逐邪意邪淫之人。破失今世后世之乐。(好名善誉身心安乐今世得也。生天得道涅槃之利后世得也)复次回己易处以自制心。若彼侵我妻我则忿恚。我若侵彼彼亦何异。恕己自制故应不作。复次如佛所说。邪淫之人后堕剑树地狱众苦备受。得出为人。家道不穆。常值淫妇邪僻残贼邪淫为患。譬如蝮蛇亦如大火。不急避之祸害将及。如佛所说。邪淫有十罪。一者常为所淫夫主欲危害之。二者夫妇不穆常共斗诤。三者诸不善法日日增长。于诸善法日日损减。四者不守护身妻子孤寡。五者财产日耗。六者有诸恶事常为人所疑。七者亲属知识所不爱喜。八者种怨家业因缘。九者身坏命终死入地狱。十者若出为女人多人共夫。若为男子妇不贞洁。如是等种种因缘不作。是名不邪淫。妄语者。不净心欲诳他。覆隐实出异语生口业。是名妄语。妄语之罪从言声相解生。若不相解虽不实语。无妄语罪。是妄语。知言不知不知言知。见言不见不见言见。闻言不闻不闻言闻。是名妄语。若不作是名不妄语。问曰。妄语有何等罪。答曰。妄语之人。先自诳身然后诳人。以实为虚以虚为实。虚实颠倒不受善法。譬如覆瓶水不得入。妄语之人心无惭愧。闭塞天道涅槃之门。观知此罪。是故不作。复次观知实语其利甚广。实语之利自从己出甚为易得。是为一切出家人力。如是功德居家出家人共有此利。善人之相。复次实语之人其心端直。其心端直易得免苦。譬如稠林曳木直者易出。问曰。若妄语有如是罪。人何以故妄语。答曰。有人愚痴少智。遭事苦厄妄语求脱不知事发。今世得罪不知后世有大罪报。复有人虽知妄语罪。悭贪嗔恚愚痴多故而作妄语。复有人虽不贪恚。而妄证人罪心谓实尔。死堕地狱如提婆达多弟子俱伽离。常求舍利弗目揵连过失。是时二人夏安居竟。游行诸国值天大雨。到陶作家宿盛陶器舍。此舍中先有一女人在闇中宿。二人不知。此女人其夜梦失不净。晨朝趣水澡洗。是时俱伽离偶行见之。俱伽离能相知人交会情状。而不知梦与不梦。是时俱伽离顾语弟子。此女人昨夜与人情通。即问女人汝在何处卧。答言。我在陶师屋中寄宿。又问共谁。答言。二比丘。是时二人从屋中出。俱伽离见已。又以相验之。意谓二人必为不净。先怀嫉妒既见此事。遍诸城邑聚落告之。次到祇洹唱此恶声。于是中间梵天王来欲见佛。佛入静室寂然三昧。诸比丘众亦各闭房三昧。皆不可觉。即自思惟。我故来见佛。佛入三昧且欲还去。即复念言。佛从定起亦将不久。于是小住。到俱伽离房前。扣其户而言。俱伽离俱伽离。舍利弗目揵连心净柔软。汝莫谤之而长夜受苦。俱伽离问言。汝是何人。答言。我是梵天王。问言。佛说汝得阿那含道。汝何以故来。梵王心念而说偈言

  无量法欲量　　不应以相取
  无量法欲量　　是野人覆没

说此偈已。到佛所具说其事。佛言。善哉善哉。快说此偈。尔时世尊复说此偈

  无量法欲量　　不应以相取
  无量法欲量　　是野人覆没

梵天王听佛说已。忽然不现即还天上。尔时俱迦离到佛所。头面礼佛足却住一面。佛告俱伽离。舍利弗目揵连心净柔软。汝莫谤之而长夜受苦。俱伽离白佛言。我于佛语不敢不信。但自目见了了。定知二人实行不净。佛如是三呵。俱伽离亦三不受。即从坐起而去。还其房中举身生疮。始如芥子渐大如豆如枣如奈。转大如苽。翕然烂坏如大火烧。叫唤嗥哭其夜即死。入大莲华地狱。有一梵天夜来白佛。俱伽离已死复有一梵天言。堕大莲华地狱。其夜过已佛命僧集而告之言。汝等欲知俱伽离所堕地狱寿命长短不。诸比丘言。愿乐欲闻。佛言。有六十斛胡麻。有人过百岁取一胡麻。如是至尽。阿浮陀地狱中寿故未尽。二十阿浮陀地狱中寿。为一尼罗浮陀地狱中寿。如二十尼罗浮陀地狱中寿为一阿罗逻地狱中寿。二十阿罗逻地狱中寿。为一阿婆婆地狱中寿。二十阿婆婆地狱中寿。为一休休地狱中寿。二十休休地狱中寿。为一沤波罗地狱中寿。二十沤波罗地狱中寿。为一分陀梨迦地狱中寿。二十分陀梨迦地狱中寿。为一摩呵波头摩地狱中寿。俱伽离堕是摩呵波头摩地狱中。出其大舌以百钉钉之。五百具犁耕之。尔时世尊说此偈言

  夫士之生　　斧在口中　　所以斩身
  由其恶言　　应呵而赞　　应赞而呵
  口集诸恶　　终不见乐
  心口业生恶　　堕尼罗浮狱
  具满百千世　　受诸毒苦痛
  若生阿浮陀　　具满三十六
  别更有五世　　皆受诸苦毒
  心依邪见　　破贤圣语　　如竹生实
  自毁其形

如是等心生疑谤。遂至决定亦是妄语。妄语人乃至佛语而不信受。受罪如是。以是故不应妄语。复次如佛子罗睺罗。其年幼稚未知慎口。人来问之。世尊在不。诡言不在。若不在时。人问罗睺罗。世尊在不。诡言佛在。有人语佛。佛语罗睺罗。澡槃取水与吾洗足。洗足已。语罗睺罗。覆此澡槃。如敕即覆。佛言。以水注之。注已问言。水入中不。答言。不入。佛告罗睺罗。无惭愧人妄语覆心道法不入。亦复如是。如佛说。妄语有十罪。何等为十。一者口气臭。二者善神远之非人得便。三者虽有实语人不信受。四者智人语议常不参豫。五者常被诽谤。丑恶之声周闻天下。六者人所不敬。虽有教敕人不承用。七者常多忧愁。八者种诽谤业因缘。九者身坏命终当堕地狱。十者若出为人常被诽谤。如是种种不作。是为不妄语。名口善律仪。不饮酒者。酒有三种。一者谷酒。二者果酒。三者药草酒。果酒者。蒱桃阿梨咤树果。如是等种种名为果酒。药草酒者。种种药草。合和米麴甘蔗汁中。能变成酒。同蹄畜乳酒。一切乳热者可中作酒。略说。若干若湿若清若浊。如是等能令人心动放逸。是名为酒。一切不应饮。是名不饮酒。问曰。酒能破冷益身令心欢喜。何以不饮。答曰。益身甚少所损甚多。是故不应饮。譬如美饮其中杂毒。是何等毒。如佛语难提迦优婆塞。酒有三十五失。何等三十五。一者现世财物虚竭。何以故。人饮酒醉心无节限。用费无度故。二者众病之门。三者斗诤之本。四者裸露无耻。五者丑名恶声人所不敬。六者覆没智慧。七者应所得物而不得。已所得物而散失。八者伏匿之事尽向人说。九者种种事业废不成办。十者醉为愁本。何以故。醉中多失。醒已惭愧忧愁。十一者身力转少。十二者身色坏。十三者不知敬父。十四者不知敬母。十五者不敬沙门。十六者不敬婆罗门。十七者不敬伯叔及尊长。何以故。醉闷恍惚无所别故。十八者不尊敬佛。十九者不敬法。二十者不敬僧。二十一者朋党恶人。二十二者疏远贤善。二十三者作破戒人。二十四者无惭无愧。二十五者不守六情。二十六者纵色放逸。二十七者人所憎恶不喜见之。二十八者贵重亲属及诸知识所共摈弃。二十九者行不善法。三十者弃舍善法。三十一者明人智士所不信用。何以故。酒放逸故。三十二者远离涅槃。三十三者种狂痴因缘。三十四者身坏命终堕恶道泥梨中。三十五者若得为人所生之处常当狂騃。如是等种种过失。是故不饮。如偈说

  酒失觉知相　　身色浊而恶
  智心动而乱　　惭愧已被劫
  失念增嗔心　　失欢毁宗族
  如是虽名饮　　实为饮死毒
  不应嗔而嗔　　不应笑而笑
  不应哭而哭　　不应打而打
  不应语而语　　与狂人无异
  夺诸善功德　　知愧者不饮

如是四罪不作。是身善律仪。妄语不作是口善律仪。名为优婆塞五戒律仪。问曰。若八种律仪。及净命是名为戒。何以故优婆塞。于口律仪中。无三律仪及净命。答曰。白衣居家。受世间乐兼修福德。不能尽行戒法。是故佛令持五戒。复次四种口业中妄语最重。复次妄语心生故作。余者或故作或不故作。复次但说妄语已摄三事。复次诸善法中实为最大。若说实语四种正语皆已摄得。复次白衣处世。当官理务家业作使。是故难持不恶口法。妄语故作事重故不应作。是五戒有五种受。名五种优婆塞。一者一分行优婆塞。二者少分行优婆塞。三者多分行优婆塞。四者满行优婆塞。五者断淫优婆塞。一分行者。于五戒中受一戒。不能受持四戒。少分行者。若受二戒若受三戒。多分行者。受四戒。满行者。尽持五戒。断淫者。受五戒已师前更作自誓言。我于自妇不复行淫。是名五戒。如佛偈说

  不杀亦不盗　　亦不有邪淫
  实语不饮酒　　正命以净心
  若能行此者　　二世忧畏除
  戒福恒随身　　常与天人俱
  世间六时华　　荣曜色相发
  以此一岁华　　天上一日具
  天树自然生　　花鬘及璎珞
  丹葩如灯照　　众色相间错
  天衣无央数　　其色若干种
  鲜白映天日　　轻密无间垄
  金色映绣文　　斐亹如云气
  如是上妙服　　悉从天树出
  明珠天耳珰　　宝磲曜手足
  随心所好爱　　亦从天树出
  金华琉璃茎　　金刚为华须
  柔软香芬熏　　悉从宝池出
  琴瑟筝箜篌　　七宝为挍饰
  器妙故音清　　皆亦从树出
  波[(匕/示)*(入/米)]质妒树　　天上树中王
  在彼欢喜园　　一切无有比
  持戒为耕田　　天树从中出
  天厨甘露味　　饮食除饥渴
  天女无监碍　　亦无妊身难
  嬉怡纵逸乐　　食无便利患
  持戒常摄心　　得生自恣地
  无事亦无难　　常得肆乐志
  诸天得自在　　忧苦不复生
  所欲应念至　　身光照幽冥
  如是种种乐　　皆由施与戒
  若欲得此报　　当勤自勉励

问曰。今说尸罗波罗蜜当以成佛。何以故乃赞天福。答曰。佛言。三事必得报果不虚。布施得大富。持戒生好处。修定得解脱。若单行尸罗得生好处。若修定智慧慈悲和合得三乘道。今但赞持戒。现世功德名闻安乐。后世得报。如偈所赞。譬如小儿蜜涂苦药然后能服。今先赞戒福然后人能持戒。能持戒已立大誓愿得至佛道。是为尸罗生尸罗波罗蜜。又以一切人皆着乐世间之乐天上为最。若闻天上种种快乐。便能受行尸罗。后闻天上无常。厌患心生能求解脱。更闻佛无量功德。若慈悲心生。依尸罗波罗蜜。得至佛道。以是故虽说尸罗报无咎。问曰。白衣居家唯此五戒。更有余法耶。答曰。有一日戒六斋日持功德无量。若十二月一日至十五日。受持此戒其福甚多。问曰。云何受一日戒。答曰。受一日戒法长跪合掌应如是言。我某甲今一日一夜。归依佛归依法归依僧。如是二如是三归依。我某甲归依佛竟。归依法竟。归依僧竟。如是二如是三归依竟。我某甲若身业不善。若口业不善。若意业不善。贪欲嗔恚愚痴故。若今世若过世有如是罪。今日诚心忏悔。身清净口清净心清净。受行八戒是则布萨。秦言共住。如诸佛尽寿不杀生。我某甲一日一夜。不杀生亦如是。如诸佛尽寿不盗。我某甲一日一夜。不盗亦如是。如诸佛尽寿不淫。我某甲一日一夜不淫亦如是。如诸佛尽寿不妄语。我某甲一日一夜不妄语亦如是。如诸佛尽寿不饮酒。我某甲一日一夜不饮酒亦如是。如诸佛尽寿不坐高大床上。我某甲一日一夜。不坐高大床上亦如是。如诸佛尽寿不着花璎珞。不香涂身不着香熏衣。我某甲一日一夜。不着花璎珞不香涂身不着香熏衣亦如是。如诸佛尽寿不自歌舞作乐亦不往观听。我某甲一日一夜。不自歌舞作乐不往观听亦如是。已受八戒。如诸佛尽寿不过中食。我某甲一日一夜。不过中食亦如是。我某甲受行八戒随学诸佛法。名为布萨。愿持是布萨福报。愿生生不堕三恶八难。我亦不求转轮圣王梵释天王世界之乐。愿诸烦恼尽逮得萨婆若成就佛道。问曰。云何受五戒。答曰。受五戒法。长跪合掌言。我某甲归依佛归依法归依僧。如是二如是三。我某甲归依佛竟。归依法竟。归依僧竟。如是二如是三。我是释迦牟尼佛优婆塞证知我。我某甲从今日尽寿归依。戒师应言。汝优婆塞听。是多陀阿伽度阿罗呵三藐三佛陀知人见人。为优婆塞说五戒如是。是汝尽寿持。何等五。尽寿不杀生是优婆塞戒。是中尽寿不应故杀生。是事若能当言诺。尽寿不盗。是优婆塞戒。是中尽寿不应盗。是事若能当言诺。尽寿不邪淫。是优婆塞戒。是中尽寿不应邪淫。是事若能当言诺。尽寿不妄语。是优婆塞戒。是中尽寿不应妄语。是事若能当言诺。尽寿不饮酒。是优婆塞戒。是中尽寿不应饮酒。是事若能当言诺。是优婆塞五戒尽寿受持。当供养三宝佛宝法宝比丘僧宝勤修福业以来佛道。问曰。何以故。六斋日受八戒修福德。答曰。是日恶鬼逐人欲夺人命。疾病凶衰令人不吉。是故劫初圣人。教人持斋修善作福以避凶衰。是时斋法不受八戒。直以一日不食为斋。后佛出世教语之言。汝当一日一夜如诸佛持八戒过中不食。是功德将人至涅槃。如四天王经中佛说。月六斋日使者太子及四天王。自下观察众生布施持戒孝顺父母。少者便上忉利以启帝释。帝释诸天心皆不悦言。阿修罗种多诸天种少。若布施持戒孝顺父母多者。诸天帝释心皆欢喜说言。增益天众减损阿修罗。是时释提婆那民见诸天欢喜。说此偈言

  六日神足月　　受持清净戒
  是人寿终后　　功德必如我

佛告诸比丘。释提桓因不应说如是偈。所以者何。释提桓因三衰三毒未除。云何妄言持一日戒功德福报必得如我。若受持此戒心应如佛。是则实说。诸大尊天欢喜因缘故。得福增多。复次此六斋日。恶鬼害人恼乱一切。若所在丘聚郡县国邑。有持斋受戒行善人者。以此因缘恶鬼远去。住处安隐。以是故六日持斋受戒得福增多。问曰。何以故诸恶鬼神辈。以此六日恼害于人。答曰。天地本起经说。劫初成时有异梵天王子。诸鬼神父。修梵志苦行。满天上十二岁。于此六日。割肉出血以着火中。以是故诸恶鬼神。于此六日辄有势力。问曰。诸鬼神父。何以于此六日割身肉血以着火中。答曰。诸神中摩醯首罗神最大第一。诸神皆有日分。摩醯首罗。一月有四日分。八日二十三日十四日二十九日。余神一月有二日分。月一日十六日月二日十七日。其十五日三十日属一切神。摩醯首罗为诸神主。又得日多故数其四日为斋。二日是一切诸神日。亦数以为斋。是故诸鬼神。于此六日辄有力势

复次诸鬼神父于此六日割肉出血以着火中。过十二岁已。天王来下语其子言。汝求何愿。答言。我求有子。天王言。仙人供养法。以烧香甘果诸清净事。汝云何以肉血着火中。如罪恶法。汝破善法乐为恶事。令汝生恶子啖肉饮血。当说。是时火中有八大鬼出。身黑如墨发黄眼赤有大光明。一切鬼神皆从此八鬼生。以是故。于此六日割身肉血以着火中而得势力。如佛法中日无好恶。随世恶日因缘故。教持斋受八戒。问曰。五戒一日戒何者为胜。答曰。有因缘故二戒俱等。但五戒终身持。八戒一日持。又五戒常持时多而戒少。一日戒时少而戒多。复次若无大心虽复终身持戒。不如有大心人一日持戒也。譬如软夫为将。虽复将兵终身。智勇不足卒无功名。若如英雄奋发祸乱立定。一日之勋功盖天下。是二种戒。名居家优婆塞法。居家持戒凡有四种。有下中上。有上上。下人持戒为今世乐故。或为怖畏称誉名闻故。或为家法曲随他意故。或避苦役求离危难故。如是种种是下人持戒。中人持戒。为人中富贵欢娱适意。或期后世福乐。克己自勉为苦。日少所得甚多。如是思惟坚固持戒。譬如商人远出深入得利必多。持戒之福令人受后世福乐亦复如是。上人持戒为涅槃故。知诸法一切无常故。欲求离苦常乐无为故。复次持戒之人其心不悔。心不悔故得喜乐。得喜乐故得一心。得一心故得实智。得实智故得厌心。得厌心故得离欲。得离欲故得解脱。得解脱故得涅槃。如是持戒为诸善法根本。复次持戒为八正道初门入道初门必至涅槃

    大智度论释初品中赞尸罗波罗蜜义第二十三

问曰。如八正道。正语正业在中。正见正行在初。今何以言戒为八正道初门。答曰。以数言之大者为始。正见最大。是故在初。复次行道故以见为先。诸法次第故戒在前。譬如作屋栋梁虽大以地为先。上上人持戒怜愍众生。为佛道故。以知诸法求实相故。不畏恶道不求乐故。如是种种。是上上人持戒。是四总名优婆塞戒。出家戒亦有四种。一者沙弥沙弥尼戒。二者式叉摩那戒。三者比丘尼戒。四者比丘僧戒。问曰。若居家戒得生天上。得菩萨道亦得至涅槃。复何用出家戒。答曰。虽俱得度然有难易。居家生业种种事务。若欲专心道法家业则废。若欲专修家业道事则废。不取不舍乃应行法。是名为难。若出家离俗绝诸纷乱。一向专心行道为易

复次居家愦闹多事多务。结使之根众恶之府。是为甚难。若出家者。譬如有人出在空野无人之处而一其心。无思无虑内想既除。外事亦去。如偈说

  闲坐林树间　　寂然灭众恶
  恬澹得一心　　斯乐非天乐
  人求富贵利　　名衣好床褥
  斯乐非安隐　　求利无厌足
  纳衣行乞食　　动止心常一
  自以智慧眼　　观知诸法实
  种种法门中　　皆以等观入
  解慧心寂然　　三界无能及

以是故知出家修戒行道为易。复次出家修戒。得无量善律仪。一切具足满。以是故白衣等应当出家受具足戒。复次佛法中出家法第一难修。如阎浮呿提梵志问舍利弗。于佛法中何者最难。舍利弗答曰。出家为难。又问。出家有何等难。答曰。出家乐法为难。既得乐法复何者为难。修诸善法难。以是故应出家。复次若人出家时。魔王惊愁言。此人诸结使欲薄。必得涅槃堕僧宝数中。复次佛法中出家人。虽破戒堕罪。罪毕得解脱。如优钵罗华比丘尼本生经中说。佛在世时。此比丘尼得六神通阿罗汉。入贵人舍常赞出家法。语诸贵人妇女言。姊妹可出家。诸贵妇女言。我等少壮容色盛美持戒为难。或当破戒。比丘尼言。但出家破戒便破。问言。破戒当堕地狱。云何可破。答言。堕地狱便堕。诸贵妇女笑之言。地狱受罪云何可堕。比丘尼言。我自忆念本宿命。时作戏女着种种衣服而说旧语。或时着比丘尼衣以为戏笑。以是因缘故。迦叶佛时作比丘尼。自恃贵姓端政。心生憍慢而破禁戒。破戒罪故堕地狱受种种罪。受罪毕竟值释迦牟尼佛。出家得六神通阿罗汉道。以是故知。出家受戒。虽复破戒以戒因缘故。得阿罗汉道。若但作恶无戒因缘不得道也。我乃昔时世世堕地狱。地狱出为恶人。恶人死还入地狱都无所得。今以此证知出家受戒。虽复破戒以是因缘可得道果。复次如佛在祇洹。有一醉婆罗门。来到佛所求作比丘。佛敕阿难与剃头着法衣。醉酒既醒惊怪己身忽为比丘即便走去。诸比丘问佛。何以听此醉婆罗门作比丘。佛言。此婆罗门无量劫中初无出家心。今因醉故暂发微心。以是因缘故后当出家得道。如是种种因缘。出家之利功德无量。以是故白衣虽有五戒不如出家。是出家律仪有四种。沙弥沙弥尼式叉摩那比丘尼比丘。云何沙弥沙弥尼。出家受戒法。白衣来欲求出家。应求二师。一和上。一阿阇梨。和上如父阿阇梨如母。以弃本生父母。当求出家父母。着袈裟剃除须发。应两手捉和上两足。何以捉足。天竺法以捉足。为第一恭敬供养。阿阇梨应教十戒。如受戒法。沙弥尼亦如是。唯以比丘尼为和上。式叉摩那受六法二岁。问曰。沙弥十戒便受具足戒。比丘尼法中。何以有式叉摩那。然后得受具足戒。答曰。佛在世时。有一长者妇。不觉怀妊出家受具足戒。其后身大转现。诸长者讥嫌比丘。因此制。有二岁学戒受六法。然后受具足戒。问曰。若为讥嫌。式叉摩那岂不致讥。答曰。式叉摩那未受具足戒。譬如小儿亦如给使。虽有罪秽人不讥嫌。是名式叉摩那受六法。是式叉摩那有二种。一者十八岁童女受六法。二者夫家十岁得受六法。若欲受具足戒应二部僧中。用五衣钵盂。比丘尼。为和上及教师。比丘为戒师。余如受戒法。略说则五百戒。广说则八万戒。第三羯磨讫。即得无量律仪。成就比丘尼。比丘则有三衣钵盂。三师十僧如受戒法。略说二百五十。广说则八万。第三羯磨讫。即得无量律仪法。是总名为戒。是为尸罗

大智度论卷第十三大智度论释初品中尸罗波罗蜜义之余(卷第十四)

        龙树菩萨造

        后秦龟兹国三藏鸠摩罗什奉　诏译

问曰。已知尸罗相。云何为尸罗波罗蜜。答曰。有人言。菩萨持戒宁自失身不毁小戒。是为尸罗波罗蜜。如上苏陀苏摩王经中说。不惜身命以全禁戒。如菩萨本身曾作大力毒龙。若众生在前。身力弱者眼视便死。身力强者气往而死。是龙受一日戒。出家求静入林树间。思惟坐久疲懈而睡。龙法睡时形状如蛇。身有文章七宝杂色。猎者见之惊喜言曰。以此希有难得之皮。献上国王以为服饰不亦宜乎。便以杖按其头以刀剥其皮。龙自念言。我力如意。倾覆此国其如反掌。此人小物岂能困我。我今以持戒故不计此身当从佛语。于是自忍眠目不视。闭气不息怜愍此人。为持戒故一心受剥不生悔意。既以失皮赤肉在地。时日大热宛转土中欲趣大水。见诸小虫来食其身。为持戒故不复敢动。自思惟言。今我此身以施诸虫。为佛道故今以肉施以充其身。后成佛时当以法施以益其心。如是誓已身乾命绝。即生第二忉利天上。尔时毒龙释迦文佛是。是时猎者提婆达等六师是也。诸小虫辈。释迦文佛初转法轮八万诸天得道者是。菩萨护戒不惜身命。决定不悔。其事如是。是名尸罗波罗蜜。复次菩萨持戒。为佛道故作大要誓。必度众生不求今世后世之乐。不为名闻虚誉法故。亦不自为早求涅槃。但为众生没在长流。恩爱所欺愚惑所误。我当度之令到彼岸。一心持戒为生善处。生善处故见善人。见善人故生智慧。生智慧故得行六波罗蜜。得行六波罗蜜故得佛道。如是持戒名为尸罗波罗蜜。复次菩萨持戒心乐善清净。不为畏恶道。亦不为生天。但求善净以戒熏心令心乐善。是为尸罗波罗蜜。复次菩萨以大悲心持戒得至佛道。是名尸罗波罗蜜。复次菩萨持戒。能生六波罗蜜。是则名为尸罗波罗蜜。云何持戒能生戒。因五戒得沙弥戒。因沙弥戒得律仪戒。因律仪戒得禅定戒因禅定戒得无漏戒。是为戒生戒。云何持戒能生于檀。檀有三种。一者财施。二者法施。三者无畏施。持戒自捡不侵一切众生财物。是名财施。众生见者慕其所行。又为说法令其开悟。又自思惟。我当坚持净戒。与一切众生作供养福田。令诸众生得无量福。如是种种名为法施。一切众生皆畏于死。持戒不害。是则无畏施。复次菩萨自念。我当持戒以此戒报。为诸众生作转轮圣王。或作阎浮提王。若作天王令诸众生。满足于财无所乏短。然后坐佛树下。降伏魔王破诸魔军。成无上道。为诸众生说清净法。令无量众生度老病死海。是为持戒因缘生檀波罗蜜。云何持戒生忍辱。持戒之人心自念言。我今持戒为持心故。若持戒无忍当堕地狱。虽不破戒以无忍故不免恶道。何可纵忿不自制心。但以心故入三恶趣。是故应当好自勉强勤修忍辱。复次行者欲令戒德坚强。当修忍辱。所以者何。忍为大力。能牢固戒令不动摇。复自思惟。我今出家形与俗别。岂可纵心如世人法。宜自勉励以忍调心以身口忍心亦得忍。若心不忍身口亦尔。是故行者当令身口心忍绝诸忿恨。复次是戒略说则有八万。广说则无量。我当云何能具持此无量戒法。唯当忍辱众戒自得。譬如有人得罪于王。王以罪人载之刀车。六边利刃间不容间。奔逸驰走行不择路。若能持身不为刀伤。是则杀而不死。持戒之人亦复如是。戒为利刀忍为持身。若忍心不固戒亦伤人。又复譬如老人夜行无杖则蹶。忍为戒杖扶人至道。福乐因缘不能动摇。如是种种。名为持戒生羼提波罗蜜。云何持戒而生精进。持戒之人除去放逸。自力勤修习无上法。舍世间乐入于善道。志求涅槃以度一切。大心不懈以求佛为本。是为持戒能生精进。复次持戒之人疲厌世苦老病死患。心生精进必求自脱。亦以度人。譬如野干在林树间。依随师子及诸虎豹。求其残肉以自存活。有时空乏夜半踰城深入人舍。求肉不得屏处睡息不觉夜竟惶怖无计。走则虑不自免。住则惧畏死痛。便自定心诈死在地众人来见有一人言。我须野干耳即便截取。野干自念。截耳虽痛但令身在。次有一人言。我须野干尾便复截去。野干复念。截尾虽痛犹是小事。次有一人言。我须野干牙。野干心念。取者转多傥取我头则无活路。即从地起奋其智力。绝踊间关径得自济。行者之心求脱苦难亦复如是。若老至时犹故自宽。不能殷勤决断精进。病亦如是。以有差期未能决计。死欲至时自知无冀。便能自勉果敢殷勤大修精进。从死地中毕至涅槃。复次持戒之法。譬如人射。先得平地地平然后心安。心安然后挽满。挽满然后陷深。戒为平地定意为弓。挽满为精进箭为智慧。贼是无明。若能如是展力精进。必至大道以度众生。复次持戒之人能以精进自制五情不受五欲。若心已去能摄令还。是为持戒能护诸根。护诸根则生禅定。生禅定则生智慧。生智慧得至佛道。是为持戒生毗梨耶波罗蜜。云何持戒生禅。人有三业作诸善。若身口业善。意业自然入善。譬如曲草生于麻中不扶自直。持戒之力能羸诸结使。云何能羸。若不持戒。嗔恚事来杀心即生。若欲事至淫心即成。若持戒者虽有微嗔不生杀心。虽有淫念淫事不成。是为持戒能令诸结使羸。诸结使羸禅定易得。譬如老病失力死事易得。结使羸故禅定易得。复次人心未息常求逸乐。行者持戒弃舍世福心不放逸。是故易得禅定。复次持戒之人得生人中。次生六欲天上。次至色界。若破色相生无色界。持戒清净。断诸结使得阿罗汉道。大心持戒愍念众生是为菩萨。复次戒为捡粗禅为摄细。复次戒摄身口。禅止乱心。如人上屋非梯不升。不得戒梯禅亦不立。复次破戒之人。结使风强散乱其心。其心散乱则禅不可得。持戒之人。烦恼风软心不大散。禅定易得。如是等种种因缘。是为持戒生禅波罗蜜。云何持戒能生智慧。持戒之人观此戒相从何而有。知从众罪而生。若无众罪。则亦无戒。戒相如是。从因缘有。何故生着。譬如莲华出自污泥。色虽鲜好出处不净。以是悟心不令生着。是为持戒生般若波罗蜜。复次持戒之人心自思惟。若我以持戒贵而可取。破戒贱而可舍者。若有此心不应般若。以智慧筹量心不着戒无取无舍。是为持戒生般若波罗蜜。复次不持戒人虽有利智以营世务。种种欲求生业之事。慧根渐钝。譬如利刀以割泥土遂成钝器。若出家持戒不营世业。常观诸法实相无相。先虽钝根以渐转利。如是等种种因缘。名为持戒生般若波罗蜜。如是名为尸罗波罗蜜生六波罗蜜。复次菩萨持戒不以畏故。亦非愚痴非疑非惑。亦不自为涅槃故。持戒但为一切众生故。为得佛道故。为得一切佛法故。如是相名为尸罗波罗蜜。复次若菩萨于罪不罪不可得故。是时名为尸罗波罗蜜。问曰。若舍恶行善是为持戒。云何言罪不罪不可得。答曰。非谓邪见粗心言不可得也。若深入诸法相。行空三昧。慧眼观故罪不可得。罪无故不罪亦不可得。复次众生不可得故。杀罪亦不可得。罪不可得故戒亦不可得。何以故。以有杀罪故则有戒。若无杀罪则亦无戒。问曰。今众生现有。云何言众生不可得。答曰。肉眼所见是为非见。若以慧眼观则不得众生。如上檀中说。无施者无受者。无财物此亦如是。复次若有众生是五众耶离五众耶。若是五众五众有五众生为一。如是者五可为一一可为五。譬如市易物。直五匹以一匹取之则不可得。何以故。一不得作五故。以是故知五众不得作一众生。复次五众生灭无常相众生法从先世来至后世。受罪福于三界。若五众是众生。譬如草木自生自灭。如是则无罪缚亦无解脱。以是故知非五众是众生。若离五众有众生。如先说神常遍中已破。复次离五众则我见心不生。若离五众有众生。是为堕常。若堕常者是则无生无死。何以故。生名先无今有。死名已生便灭。若众生常者。应遍满五道中。先已常有云何今复来生。若不有生则无有死。问曰。定有众生。何以故言无。五众因缘有众生法。譬如五指因缘拳法生。答曰。此言非也。若五众因缘有众生法者。除五众则别有众生法然不可得。眼自见色耳自闻声鼻嗅香舌知味身知触意知法空无我法。离此六事更无众生。诸外道辈倒见故。言眼能见色是为众生。乃至意能知法是为众生。又能忆念能受苦乐是为众生。但作是见不知众生实。譬如一长老大德比丘。人谓是阿罗汉多致供养。其后病死。诸弟子惧失供养故。夜盗出之。于其卧处安施被枕。令如师在其状如卧。人来问疾师在何许。诸弟子言。汝不见床上被枕耶。愚者不审察之。谓师病卧大送供养而去。如是非一。复有智人来而问之。诸弟子亦如是答。智人言。我不问被枕床褥。我自求人发被求之竟无人可得。除六事相更无我人。知者见者亦复如是。复次若众生于五众因缘有者。五众无常众生亦应无常。何以故。因果相似故。若众生无常则不至后世。复次若如汝言。众生从本已来常有。若尔者众生应生五众。五众不应生众生。今五众因缘生众生名字。无智之人逐名求实。以是故众生实无。若无众生亦无杀罪。无杀罪故亦无持戒。复次是五众深入观之。分别知空如梦所见如镜中像。若杀梦中所见及镜中像无有杀罪。杀五阴空相众生亦复如是。复次若人不乐罪贪着无罪。是人见破戒罪人则轻慢。见持戒善人则爱敬。如是持戒则是起罪因缘。以是故言于罪不罪不可得故。应具足尸罗波罗蜜

    大智度论释初品中羼提波罗蜜义第二十四

【经】心不动故。应具足羼提波罗蜜

【论】问曰。云何名羼提。答曰。羼提秦言忍辱。忍辱有二种。生忍法忍。菩萨行生忍得无量福德。行法忍得无量智慧。福德智慧二事具足故。得如所愿。譬如人有目有足随意能到。菩萨若遇恶口骂詈。若刀杖所加。思惟知罪福业因缘。诸法内外毕竟空无我无我所。以三法印。印诸法故。力虽能报不生恶心不起恶口业。尔时心数法生名为忍。得是忍法故忍智牢固。譬如画彩得胶则坚着。有人言。善心有二种有粗有细。粗名忍辱细名禅定。未得禅定心乐能遮众恶。是名忍辱。心得禅定乐不为众恶。是名禅定。是忍是心数法与心相应随心行。非业非业报随业行。有人言。二界系。有人言。但欲界系。或不系。色界无外恶可忍故。亦有漏亦无漏。凡夫圣人俱得故。障己心他心不善法故。名为善。善故。或思惟断或不断。如是等种种阿毗昙广分别。问曰。云何名生忍。答曰。有二种众生来向菩萨。一者恭敬供养。二者嗔骂打害。尔时菩萨其心能忍。不爱敬养众生不嗔加恶众生。是名生忍。问曰。云何恭敬供养。名之为忍。答曰。有二种结使。一者属爱结使。二者属恚结使。恭敬供养虽不生恚令心爱着。是名软贼。是故于此应当自忍不着不爱。云何能忍。观其无常是结使生处。如佛所说利养疮深。譬如断皮至肉断肉至骨断骨至髓。人着利养则破持戒皮。断禅定肉。破智慧骨。失微妙善心髓。如佛初游迦毗罗婆国。与千二百五十比丘俱。悉是梵志之身。供养火故。形容憔悴。绝食苦行故。肤体瘦黑。净饭王心念言。我子侍从虽复心净清洁并无容貌。我当择取累重多子孙者。家出一人为佛弟子。如是思惟已。敕下国中。简择诸释贵戚子弟。应书之身皆令出家。是时斛饭王子提婆达多。出家学道诵六万法聚。精进修行满十二年。其后为供养利故来至佛所。求学神通。佛告憍昙。汝观五阴无常可以得道。亦得神通。而不为说取通之法。出求舍利弗目揵连乃至五百阿罗汉。皆不为说言。汝当观五阴无常。可以得道可以得通。不得所求涕泣不乐。到阿难所求学神通。是时阿难未得他心智。敬其兄故如佛所言以授提婆达多。受学通法入山不久便得五神通。得五神通已自念。谁当与我作檀越者。如王子阿阇世。有大王相。欲与为亲厚。到天上取天食。还到郁旦罗越。取自然粳米。至阎浮林中取阎浮果。与王子阿阇世。或时自变其身。作象宝马宝以惑其心。或作婴孩坐其膝上。王子抱之呜唼与唾。时时自说己名令太子知之。种种变态以动其心。王子意惑。于奈园中大立精舍。四种供养并种种杂供无物不备。以给提婆达多。日日率诸大臣。自为送五百釜羹饭。提婆达多大得供养而徒众鲜少。自念。我有三十相减佛未几。直以弟子未集。若大众围绕与佛何异。如是思惟已生心破僧得五百弟子。舍利弗目犍连说法教化。僧还和合。尔时提婆达多便生恶心推山压佛。金刚力士以金刚杵而遥掷之。碎石迸来伤佛足指。华色比丘尼呵之。复以拳打尼。尼即时眼出而死。作三逆罪。与恶邪师富兰那外道等为亲厚。断诸善根心无愧悔。复以恶毒着指爪中。欲因礼佛以中伤佛。欲去未到王舍城中。地自然破裂火车来迎生入地狱。提婆达多身有三十相。而不能忍伏其心。为供养利故而作大罪。生入地狱。以是故言利养疮深破皮至髓应当除却爱供养人心。是为菩萨忍心不爱着供养恭敬人。复次供养有三种。一者先世因缘福德故。二者今世功德修戒禅定智慧故为人敬养。三者虚妄欺惑内无实德外如清白。以诳时人而得供养。于此三种供养中。心自思惟。若先世因缘勤修福德今得供养。是为勤身作之而自得耳。何为于此而生贡高。譬如春种秋获。自以力得何足自憍。如是思惟已。忍伏其心不着不憍。若今世故功德而得供养当自思惟。我以智慧。若知诸法实相。若能断结。以此功德故。是人供养于我无事。如是思惟已。自伏其心不自憍高。此实爱乐功德不爱我也。譬如罽宾三藏比丘。行阿兰若法至一王寺。寺设大会。守门人见其衣服粗弊遮门不前。如是数数以衣服弊故每不得前。便作方便假借好衣而来。门家见之听前不禁。既至会坐得种种好食。先以与衣。众人问言。何以尔也。答言。我比数来每不得入。今以衣故得在此坐得种种好食。实是衣故得之。故以与衣。行者以修行功德持戒智慧故而得供养。自念此为功德非为我也。如是思惟能自伏心是名为忍。若虚妄欺伪而得供养。是为自害不可近也。当自思惟。若我以此虚妄而得供养。与恶贼劫盗得食无异。是为堕欺妄罪。如是于三种供养人中心不爱着亦不自高。是名生忍。问曰。人未得道衣食为急。云何方便能得忍。心不着不爱给施之人。答曰。以智慧力观无常相苦相无我相心常厌患。譬如罪人临当受戮。虽复美味在前家至劝喻。以忧死故。虽饮食肴膳不觉滋味。行者亦尔。常观无常相苦相。虽得供养心亦不着。又如獐鹿为虎搏逐追之不舍。虽得好草美水饮食心无染着。行者亦尔。常为无常虎逐不舍须臾思惟厌患。虽得美味亦不染着。是故行者于供养人中心得自忍。复次若有女人来欲娱乐诳惑菩萨。菩萨是时当自伏心忍不令起。如释迦文尼佛在菩提树下。魔王忧愁遣三玉女。一名乐见。二名悦彼。三名渴爱。来现其身作种种姿态欲坏菩萨。菩萨是时心不倾动目不暂视。三女念言。人心不同好爱各异。或有好少或爱中年或好长好短好黑好白。如是众好各有所爱。是时三女各各化作五百美女。一一化女作无量变态从林中出。譬如黑云电光暂现。或扬眉顿睫嫈嫇细视。作众伎乐种种姿媚。来近菩萨欲以态身触逼菩萨。尔时密迹金刚力士嗔目叱之。此是何人而汝妖媚敢来触娆。尔时密迹说偈呵之

  汝不知天命　　失好而黄髯
  大海水清美　　今日尽苦碱
  汝不知日减　　婆薮诸天堕
  火本为天口　　而今一切啖

汝不知此事。敢轻此圣人。是时众女逡巡小退。语菩萨言。今此众女端严无比可自娱意。端坐何为。菩萨言。汝等不净臭秽可恶去勿妄谈。菩萨是时即说偈言

  是身为秽薮　　不净物腐积
  是实为行厕　　何足以乐意

女闻此偈自念。此人不知我等清净天身而说此偈。即自变身还复本形。光曜昱烁照林树间作天伎乐。语菩萨言。我身如是有何可呵。菩萨答言。时至自知。问曰。此言何谓。以偈答言

  诸天园林中　　七宝莲华池
  天人相娱乐　　失时汝自知
  是时见无常　　天人乐皆苦
  汝当厌欲乐　　爱乐正真道

女闻偈已心念。此人大智无量。天乐清净犹知其恶不可当也。即时灭去。菩萨如是观淫欲乐。能自制心忍不倾动。复次菩萨观欲种种不净。于诸衰中女衰最重。刀火雷电霹雳怨家毒蛇之属犹可暂近。女人悭妒嗔谄妖秽斗诤贪嫉不可亲近。何以故。女子小人心浅智薄唯欲是视。不观富贵智德名闻。专行欲恶破人善根。桎梏枷锁闭系囹圄。虽曰难解是犹易开。女锁系人染固根深。无智没之难可得脱。众病之中女病最重。如佛偈言

  宁以赤铁　　宛转眼中　　不以散心
  邪视女色　　含笑作姿　　憍慢羞耻
  回面摄眼　　美言妒嗔　　行步妖秽
  以惑于人　　淫罗弥网　　人皆没身
  坐卧行立　　回眄巧媚　　薄智愚人
  为之心醉　　执剑向敌　　是犹可胜
  女贼害人　　是不可禁　　蚖蛇含毒
  犹可手捉　　女情惑人　　是不可触
  有智之人　　所应不视　　若欲观之
  当如母姊　　谛视观之　　不净填积
  淫火不除　　为之烧灭

复次女人相者。若得敬待则令夫心高。若敬待情舍则令夫心怖。女人如是恒以烦恼忧怖与人。云何可近。亲好乖离女人之罪。巧察人要女人之智。大火烧人是犹可近。清风无形是亦可捉。蚖蛇含毒犹亦可触。女人之心不可得实。何以故女人之相。不观富贵端政名闻智德族姓技艺辩言亲厚爱重。都不在心唯欲是视。譬如蛟龙不择好丑唯欲杀人。又复女人不瞻视忧苦憔悴。给养敬待憍奢叵制。复次若在善人之中。则自畜心高。无智人中视之如怨。富贵人中追之敬爱。贫贱人中视之如狗。常随欲心不随功德。如说国王有女名曰拘牟头。有捕鱼师名述婆伽。随道而行。遥见王女在高楼上窗中见面。想像染着心不暂舍。弥历日月不能饮食。母问其故以情答母。我见王女心不能忘。母谕儿言。汝是小人。王女尊贵不可得也。儿言。我心愿乐不能暂忘。若不如意不能活也。母为子故入王宫中。常送肥鱼美肉以遗王女而不取价。王女怪而问之欲求何愿。母白王女。愿却左右当以情告。我唯有一子敬慕王女情结成病。命不云远。愿垂愍念赐其生命。王女言。汝去月十五日于某甲天祠中住天像后。母还语子。汝愿已得告之如上。沐浴新衣在天像后住。王女至时白其父王。我有不吉须至天祠以求吉福。王言大善。即严车五百乘出至天祠。既到敕诸从者。齐门而止独入天祠。天神思惟。此不应尔。王为世主不可令此小人毁辱王女。即厌此人令睡不觉。王女既入见其睡。重推之不悟。即以璎珞直十万两金遗之而去。去后此人得觉见有璎珞。又问众人知王女来。情愿不遂忧恨懊恼。淫火内发自烧而死。以是证故知。女人之心不择贵贱唯欲是从。复次昔有国王女。逐旃陀罗共为不净。又有仙人女随逐师子。如是等种种女人之心无所选择。以是种种因缘。于女人中除去情欲忍不爱着。云何嗔恼人中而得忍辱。当自思惟。一切众生有罪因缘更相侵害。我今受恼亦本行因缘。虽非今世所作。是我先世恶报。我今偿之。应当甘受何可逆也。譬如负债。债主索之应当欢喜偿债不可嗔也。复次行者常行慈心。虽有恼乱逼身必能忍受。譬如羼提仙人。在大林中修忍行慈。时迦利王将诸婇女入林游戏。饮食既讫王小睡息。诸婇女辈游花林间。见此仙人加敬礼拜在一面立。仙人尔时为诸婇女赞说慈忍。其言美妙听者无厌。久而不去。迦利王觉不见婇女拔剑追踪。见在仙人前立。憍妒隆盛。嗔目奋剑而问仙人。汝作何物。仙人答言。我今在此修忍行慈。王言。我今试汝。当以利剑截汝耳鼻斩汝手足。若不嗔者知汝修忍。仙人言任意。王即拔剑截其耳鼻斩其手足。而问之言。汝心动不。答言。我修慈忍心不动也。王言。汝一身在此无有势力。虽口言不动谁当信者。是时仙人即作誓言。若我实修慈忍血当为乳。即时血变为乳。王大惊喜。将诸婇女而去。是时林中龙神为此仙人雷电霹雳。王被毒害没不还宫。以是故言于恼乱中能行忍辱。复次菩萨修行悲心。一切众生常有众苦。处胎迫隘受诸苦痛。生时迫迮骨肉如破。冷风触身甚于剑戟。是故佛言。一切苦中生苦最重。如是老病死苦种种困厄。云何行人复加其苦。是为疮中复加刀破。复次菩萨自念。我不应如诸余人常随生死水流。我当逆流以求尽源入泥洹道。一切凡人侵至则嗔。益至则喜。怖处则畏。我为菩萨不可如彼。虽未断结当自抑制修行忍辱恼害不嗔敬养不喜。众苦艰难不应怖畏。当为众生兴大悲心。复次菩萨若见众生来为恼乱。当自念言。是为我之亲厚亦是我师。益加亲爱敬心待之。何以故。彼若不加众恼恼我则我不成忍辱。以是故言。是我亲厚亦是我师。复次菩萨心知如佛所说。众生无始世界无际。往来五道轮转无量。我亦曾为众生父母兄弟。众生亦皆曾为我父母兄弟。当来亦尔。以是推之不应恶心而怀嗔害。复次思惟。众生之中佛种甚多。若我嗔意向之则为嗔佛。若我嗔佛则为已了。如说鸽鸟当得作佛。今虽是鸟不可轻也。复次诸烦恼中嗔为最重。不善报中嗔报最大。余结无此重罪。如释提婆那民问佛。偈言

  何物杀安隐　　何物杀不悔
  何物毒之根　　吞灭一切善
  何物杀而赞　　何物杀无忧

佛答偈言

  杀嗔心安隐　　杀嗔心不悔
  嗔为毒之根　　嗔灭一切善
  杀嗔诸佛赞　　杀嗔则无忧

菩萨思惟。我今行悲。欲令众生得乐。嗔为吞灭诸善毒害一切。我当云何行此重罪。若有嗔恚自失乐利。云何能令众生得乐。复次诸佛菩萨以大悲为本。从悲而出嗔为灭悲之毒。特不相宜。若坏悲本何名菩萨。菩萨从何而出。以是之故应修忍辱。若众生加诸嗔恼当念其功德。今此众生虽有一罪。更自别有诸妙功德。以其功德故不应嗔。复次此人若骂若打是为治我。譬如金师炼金垢随火去真金独在。此亦如是。若我有罪是从先世因缘。今当偿之不应嗔也。当修忍辱。复次菩萨慈念众生犹如赤子。阎浮提人多诸忧愁少有欢日。若来骂詈或加谗贼。心得欢乐此乐难得恣汝骂之。何以故。我本发心欲令众生得欢喜故。复次世间众生常为众病所恼。又为死贼。常随伺之。譬如怨家恒伺人便。云何善人而不慈愍。复欲加苦苦未及彼先自受害。如是思惟不应嗔彼当修忍辱。复次当观嗔恚其咎最深。三毒之中无重此者。九十八使中此为最坚。诸心病中第一难治。嗔恚之人不知善不知非善。不观罪福不知利害不自忆念。当堕恶道善言忘失。不惜名称不知他恼。亦不自计身心疲恼。嗔覆慧眼专行恼他。如一五通仙人。以嗔恚故虽修净行杀害一国如旃陀罗。复次嗔恚之人。譬如虎狼难可共止。又如恶疮易发易坏。嗔恚之人譬如毒蛇人不喜见。积嗔之人。恶心渐大至不可至。杀父杀君恶意向佛。如拘睒弥国比丘。以小因缘嗔心转大分为二部。若欲断当终竟三月犹不可了。佛来在众举相轮手遮而告言

  汝诸比丘　　勿起斗诤　　恶心相续
  苦报甚重

  汝求涅槃　　弃舍世利　　在善法中
  云何嗔诤　　世人忿诤　　是犹可恕
  出家之人　　何可诤斗　　出家心中
  怀毒自害　　如冷云中　　火出烧身

诸比丘白佛言。佛为法王愿小默然。是辈侵我不可不答。佛念是人不可度也。于众僧中凌虚而去。入林树间寂然三昧。嗔罪如是乃至不受佛语。以是之故应当除嗔修行忍辱。复次能修忍辱慈悲易得。得慈悲者则至佛道。问曰。忍辱法皆好。而有一事不可。小人轻慢谓为怖畏。以是之故不应皆忍。答曰。若以小人轻慢谓为怖畏。而欲不忍。不忍之罪甚于此也。何以故。不忍之人贤圣善人之所轻贱。忍辱之人为小人所慢。二轻之中。宁为无智所慢。不为贤圣所贱。何以故。无智之人轻所不轻。贤圣之人贱所可贱。以是之故当修忍辱。复次忍辱之人。虽不行布施禅定。而常得微妙功德生天上人中。后得佛道。何以故。心柔软故。复次菩萨思惟。若人今世恼我毁辱夺利。轻骂系缚且当含忍。若我不忍。当堕地狱铁垣热地受无量苦。烧炙燔煮不可具说。以是故知。小人无智虽轻而贵。不忍用威虽快而贱。是故菩萨应当忍辱。复次菩萨思惟。我初发心誓为众生治其心病。今此众生为嗔恚结使所病。我当治之。云何而复以之自病应当忍辱。譬如药师疗治众病。若鬼狂病拔刀骂詈不识好丑。医知鬼病但为治之而不嗔恚。菩萨若为众生嗔恼骂詈。知其为嗔恚者烦恼所病狂心所使。方便治之无所嫌责亦复如是。复次菩萨育养一切爱之如子。若众生嗔恼菩萨。菩萨愍之不嗔不责。譬如慈父抚育子孙。子孙幼稚未有所识。或时骂詈打掷不敬不畏。其父愍其愚小爱之愈至。虽有过罪不嗔不恚。菩萨忍辱亦复如是。复次菩萨思惟。若众生嗔恼加我我当忍辱。若我不忍今世心悔。后入地狱受苦无量。若在畜生。作毒龙恶蛇师子虎狼。若为饿鬼火从口出。譬如人被火烧。烧时痛轻后痛转重。复次菩萨思惟。我为菩萨欲为众生益利。若我不能忍辱。不名菩萨名为恶人。复次菩萨思惟。世有二种。一者众生数。二者非众生数。我初发心誓为一切众生。若有非众生数山石树木风寒冷热水雨侵害。但求[衝-重+素]之初不嗔恚。今此众生是我所为。加恶于我。我当受之。云何而嗔。复次菩萨知从久远已来。因缘和合假名为人无实人法。谁可嗔者。是中但有骨血皮肉。譬如累墼又如木人机关动作有去有来。知其如此不应有嗔。若我嗔者是则愚痴自受罪苦。以是之故应修忍辱。复次菩萨思惟。过去无量恒河沙等诸佛。本行菩萨道时。皆先行生忍然后修行法忍。我今求学佛道。当如诸佛法。不应起嗔恚如魔界法。以是故应当忍辱。如是等种种无量因缘故能忍。是名生忍

大智度论卷第十四大智度论释初品中羼提波罗蜜法忍义第二十五(卷第十五)

        龙树菩萨造

        后秦龟兹国三藏鸠摩罗什奉　诏译

云何名法忍。忍诸恭敬供养众生及诸嗔恼淫欲之人。是名生忍。忍其供养恭敬法及嗔恼淫欲法。是为法忍。复次法忍者。于内六情不着。于外六尘不受。能于此二不作分别。何以故。内相如外外相如内。二相俱不可得故。一相故。因缘合故。其实空故。一切法相常清净故。如真际法性相故。不二入故。虽无二亦不一。如是观诸法心信不转。是名法忍。如毗摩罗鞊经中。法住菩萨说生灭为二不生不灭是不二入法门。乃至文殊尸利说。无闻无见一切心灭无说无语。是不二入法门。毗摩罗鞊默然无言。诸菩萨赞言。善哉善哉。是真不二入法门。复次一切法有二种。一者众生。二者诸法。菩萨于众生中忍如先说。今说法中忍。法有二种。心法非心法。非心法中有内有外。外有寒热风雨等。内有饥渴老病死等。如是等种种名为非心法。心法中有二种。一者嗔恚忧愁疑等。二者淫欲憍慢等。是二名为心法。菩萨于此二法能忍不动。是名法忍。问曰。于众生中若嗔恼害命得罪。怜愍得福。寒热风雨无有增损。云何而忍。答曰。虽无增损而自生恼乱忧苦害菩萨道。以是故应当忍。复次非但杀恼众生故得罪。为恶心作因缘故有罪。所以者何。虽杀众生而无记心是便无罪。慈念众生虽无所与而大得福。以是故寒热风雨虽无增损。然以能生恶意故得罪。以是故应当忍。复次菩萨。自知宿罪因缘生此苦处。此我自作我应自受。如是思惟是故能忍。复次菩萨思惟。国土有二种。有净有不净。菩萨若生不净国中。受此辛苦饥寒众恼。自发净愿。我成佛时国中无此众苦。此虽不净乃是我利。复次菩萨思惟。世间八法贤圣所不能免。何况于我。以是故应当忍。复次菩萨思惟。知此人身无牢无强。为老病死所逐。虽复天身清净无老无病。耽着天乐。譬如醉人。不得修行道福出家离欲。以是故。于此人身自忍修福利益众生。复次菩萨思惟我受此四大五众身。应有种种苦分。无有受身而不苦者。富贵贫贱出家在家。愚智明闇无得免者。何以故。富贵之人常有畏怖守护财物。譬如肥羊早就屠机。如乌衔肉众乌逐之。贫贱之人有饥寒之苦。出家之人今世虽苦后世受福得道。在家之人今世虽乐。后世受苦。愚人先求今世乐。无常对至后则受苦。智人思惟无常苦。后则受乐得道。如是等受身之人无不有苦。是故菩萨应当行忍。复次菩萨思惟一切世间皆苦我当云何于中而欲求乐。复次菩萨思惟。我于无量劫中常受众苦无所利益未曾为法。今日为众生求佛道。虽受此苦当得大利。是故外内诸苦悉当忍受。复次菩萨大心誓愿。若阿鼻泥犁苦我当忍之。何况小苦而不能忍。若小不忍何能忍大。如是种种外法中忍名曰法忍。问曰。云何内心法中能忍。答曰。菩萨思惟。我虽未得道诸结未断。若当不忍与凡人不异。非为菩萨。复自思惟。若我得道断诸结使则无法可忍。复次。饥渴寒热。是外魔军。结使烦恼。是内魔贼。我当破此二军。以成佛道。若不尔者。佛道不成。如说。佛苦行六年。魔王来言。刹利贵人。汝千分生中正有一分活耳。速起还国布施修福。可得今世后世人中天上之乐道。不可得汝唐勤苦。汝若不受软言守迷不起。我当将大军众来击破汝。菩萨言。我今当破汝大力内军。何况外军。魔言。何等是我内军。答曰

  欲是汝初军　　忧愁为第二
  饥渴第三军　　渴爱为第四
  睡眠第五军　　怖畏为第六
  疑悔第七军　　嗔恚为第八
  利养虚称九　　自高蔑人十
  如是等军众　　厌没出家人
  我以禅智力　　破汝此诸军
  得成佛道已　　度脱一切人

菩萨于此诸军虽未能破。着忍辱铠捉智慧剑执禅定楯。遮诸烦恼箭。是名内忍。复次菩萨于诸烦恼中。应当修忍不应断结。何以故。若断结者所失甚多。堕阿罗汉道中。与根败无异。是故遮而不断。以修忍辱不随结使。问曰。云何结使未断而能不随。答曰。正思惟故。虽有烦恼而能不随。复次思惟。观空无常相故。虽有妙好五欲不生诸结。譬如国王。有一大臣。自覆藏罪。人所不知。王言。取无脂肥羊来。汝若不得者当与汝罪。大臣有智。系一大羊以草谷好养。日三以狼而畏怖之。羊虽得养肥而无脂。牵羊与王。王遣人杀之肥而无脂。王问云何得尔。答以上事。菩萨亦如是。见无常苦空狼。令诸结使脂消诸功德肉肥。复次菩萨功德福报无量故。其心柔软诸结使薄易修忍辱。譬如师子王在林中吼。有人见之叩头求哀则放令去。虎豹小物不能尔也。何以故。师子王贵兽有智分别故。虎豹贱虫不知分别故。又如坏军得值大将则活值遇小兵则死。复次菩萨智慧力。观嗔恚有种种诸恶。观忍辱有种种功德。是故能忍结使。复次菩萨心有智力能断结使。为众生故。久住世间知结使是贼。是故忍而不随。菩萨系此结贼。不令纵逸而行功德。譬如有贼以因缘故不杀。坚闭一处而自修事业。复次菩萨实知诸法相故。不以诸结使为恶。不以功德为妙。是故于结不嗔功德不爱。以此智力故。能修忍辱。如偈说

  菩萨断除诸不善　　乃至极微灭无余
  大功德福无有量　　所造事业无不办
  菩萨大智慧力故　　于诸结使不能恼
  是故能知诸法相　　生死涅槃一无二

如是种种因缘虽未得道。于诸烦恼法中能忍。是名法忍。复次菩萨。于一切法。知一相无二。一切法可识相故言一。眼识识色。乃至意识识法。是可识相法。故言一。复次一切法可知相故言一。苦法智苦比智。知苦谛。集法智集比智。知集谛。灭法智灭比智。知灭谛。道法智道比智。知道谛。及善世智亦知苦集灭道虚空非智缘灭。是可知相法故言一。复次一切法可缘相故言一。眼识及眼识相应法缘色。耳识鼻识舌识身识亦如是。意识及意识相应法。亦缘眼亦缘色亦缘眼识。乃至缘意缘法缘意识。一切法可缘相故言一。复次有人言一切法各皆一。一复有一名为二。三一名为三。如是乃至千万皆是一。而假名为千万。复次一切法中有相故言一。一相故名为一。一切物名为法。法相故名为一。如是等无量一门。破异相不着一。是名法忍

复次菩萨观一切为二。何等二。二名内外相。内外相故内非外相。外非内相。复次一切法有无相故为二。空不空常非常我非我色非色可见不可见有对非有对有漏无漏有为无为心法非心法心数法非心数法心相应法非心相应法。如是无量二门破一不着二。是名为法忍。复次菩萨或观一切法为三。何等为三。下中上善不善无记有无非有非无。见谛断思惟断无断学无学非学非无学报有报非报非有报。如是无量三门破一不着异。是名为法忍。复次菩萨虽未得无漏道结使未断。能信无漏圣法及三种法印。一者一切有为生法无常等印。二者一切法无我印。三者涅槃实法印。得道贤圣人自得自知。菩萨虽未得道。能信能受是名法忍。复次于十四难不答法中。有常无常等。观察无碍不失中道。是法能忍是为法忍。如一比丘。于此十四难思惟观察。不能通达心不能忍。持衣钵至佛所白佛言。佛能为我解此十四难。使我意了者当作弟子。若不能解我当更求余道。佛告痴人汝本共我要誓。若答十四难汝作我弟子耶。比丘言不也。佛言。汝痴人今何以言。若不答我不作弟子。我为老病死人说法济度。此十四难是斗诤法。于法无益但是戏论。何用问为。若为汝答汝心不了。至死不解不能得脱生老病死。譬如有人身被毒箭。亲属呼医欲为出箭涂药。便言未可出箭。我先当知汝姓字亲里父母年岁。次欲知箭出在何山何木何羽。作箭镞者为是何人是何等铁。复欲知弓何山木何虫角。复欲知药是何处生是何种名。如是等事尽了了知之。然后听汝出箭涂药。佛问比丘此人可得知此众事然后出箭不。比丘言。不可得知。若待尽知此则已死。佛言。汝亦如是。为邪见箭爱毒涂已入汝心。欲拔此箭作我弟子。而不欲出箭。方欲求尽世间常无常边无边等。求之未得则失慧命。与畜生同死。自投黑闇。比丘惭愧深识佛语。即得阿罗汉道。复次菩萨。欲作一切智人。应推求一切法。知其实相。于十四难中不滞不碍。知其是心重病。能出能忍。是名法忍。复次佛法甚深清净微妙。演畅种种无量法门。能一心信受不疑不悔。是名法忍。如佛所言。诸法虽空。亦不断亦不灭。诸法因缘相续生亦非常。诸法虽无神亦不失罪福。一心念顷。身诸法诸根诸慧转灭不停。不至后念。新新生灭。亦不失无量世中因缘业。诸众界入中皆空无神。而众生轮转五道中受生死。如是等种种甚深微妙法。虽未得佛道。能信能受不疑不悔。是为法忍。复次阿罗汉辟支佛。畏恶生死早求入涅槃。菩萨未得成佛。而欲求一切智。欲怜愍众生。欲了了分别知诸法实相。是中能忍是名法忍。问曰。云何观诸法实相。答曰。观知诸法无有瑕隙。不可破不可坏是为实相。问曰。一切语皆可答可破可坏。云何言不可破坏是为实相。答曰。以诸法不可破故。佛法中一切言语道过。心行处灭常不生不灭。如涅槃相。何以故。若诸法相实有不应无。若诸法先有今无。则是断灭。复次诸法不应是常。何以故。若常则无罪无福无所伤杀。亦无施命亦无修行利益亦无缚无解。世间则是涅槃。如是等因缘故。诸法不应常。若诸法无常。则是断灭亦无罪无福亦无增损。功德业因缘果报亦失。如是等因缘故。诸法不应无常。问曰。汝言佛法中常亦不实无常亦不实。是事不然。何以故。佛法中常亦实无常亦实。常者数缘尽非数缘尽。虚空不生不住不灭故。是常相。无常者。五众生住灭故无常相。汝何以言常无常皆不实。答曰。圣人有二种语。一者方便语。二者直语。方便语者。为人为因缘故。为人者为众生说。是常是无常。如对治悉檀中说。若说无常。欲拔众生三界着乐。佛思惟。以何令众生得离欲。是故说无常法。如偈说

  若观无生法　　于生法得离
  若观无为法　　于有为得离

云何生生名因缘和合。无常不自在属因缘。有老病死相欺诳相破坏相。是名生生。则是有为法。如对治悉檀说。常无常非实相。二俱过故。若诸法非有常非无常。是为愚痴论。所以者何。若非有则破无。若非无则破有。若破此二事更有何法可说。问曰。佛法常空相中。非有非无。空以除有空。空遮无。是为非有非无。何以言愚痴论。答曰。佛法实相不受不着。汝非有非无受着故。是为痴论。若言非有非无。是则可说可破。是心生处是斗诤处。佛法则不然。虽因缘故说非有非无。不生着。不生着则不可坏不可破。诸法若有边若无边若有无边若非有无边。若死后有去若死后无去若死后有去无去若死后非有去非无去。是身是神身异神异亦如是皆不实。于六十二见中。观诸法亦皆不实。如是一切除却。信佛法清净不坏相。心不悔不转。是名法忍。复次有无二边。观诸法生时住时则为有见相。观诸法老时坏时则为无见相。三界众生多着此二见相。是二种法虚诳不实。若实有相则不应无。何以故。今无先有则堕断中。若断是则不然。复次一切诸法。名字和合故谓之为有。以是故。名字和合所生法不可得。问曰。名字所生法虽不可得。则有名字和合。答曰。若无法。名字为谁而和合。是则无名字。复次若诸法实有。不应以心识故知有。若以心识故知有。是则非有。如地坚相。以身根身识知故有。若无身根身识知则无坚相。问曰。身根身识若知若不知。而地常是坚相。答曰。若先自知有坚相。若从他闻则知有坚相。若先不知不闻则无坚相。复次地若常是坚相。不应舍其相。如凝酥蜡蜜树胶。融则舍其坚相堕湿相中。金银铜铁等亦尔。如水为湿相。寒则转为坚相。如是等种种悉皆舍相。复次诸论议师辈。有能令无。无能令有。诸贤圣人坐禅人。能令地作水水作地。如是等诸法皆可转。如十一切入中说。复次是有见。为贪欲嗔恚愚痴结缚斗诤故生。若有生此欲恚等处。是非佛法。何以故。佛法相善净故。以是故非实。复次一切法有二种。色法无色法。色法分析乃至微尘散灭无余。如檀波罗蜜品破施物中说。无色法五情所不知故。意情生住灭时观故。知心有分。有分故无常。无常故空。空故非有。弹指顷有六十时。一一时中心有生灭。相续生故。知是贪心是嗔心是痴心是信心清净智慧禅定心。行者观心生灭。如流水灯焰。此名入空智门。何以故。若一时生余时中灭者。此心应常。何以故。此极少时中无灭故。若一时中无灭者。应终始无灭。复次佛说有为法皆有三相。若极少时中生而无灭者是为非有为法若极少时中心生住灭者。何以但先生而后灭。不先灭而后生。复次若先有心后有生。则心不待生。何以故。先已有心故。若先有生则生无所生。又生灭性相违。生则不应有灭。灭时不应有生。以是故一时不可得。异亦不可得。是即无生。若无生则无住灭。若无生住灭则无心数法。无心数法则无心不相应。诸行色无色法无故。无为法亦无。何以故因有为故有无为。若无有为则亦无无为。复次见作法无常故。知不作法常。若然者。今见作法是有法。不作法应是无法。以是故常法不可得。复次外道及佛弟子。说常法有同有异。同者虚空涅槃。外道有神时方微尘冥初。如是等名为异。又佛弟子说非数缘灭是常。又复言灭因缘法常。因缘生法无常。摩诃衍中。常法法性如真际。如是等种种。名为常法虚空涅槃。如先赞菩萨品中说。神及时方微尘亦如上说。以是故不应言诸法有。若诸法无者。有二种。一者常无。二者断灭故无。若先有今无若今有后无是则断灭。若然者则无因缘。无因缘者应一物中出一切物。亦应一切物中都无所出。后世中亦如是。若断罪福因缘。则不应有贫富贵贱之异及堕恶道畜生中。若言常无则无苦集灭道。若无四谛则无法宝。若无法宝则无八贤圣道。若无法宝僧宝则无佛宝。若如是者则破三宝。复次若一切法实空者。则无罪福亦无父母亦无世间礼法亦无善无恶。然则善恶同门是非一贯。一切物尽无。如梦中所见。若言实无有如是失。此言谁当信者。若言颠倒故见有者。当见一人时。何以不见二三。以其实无而颠倒见故。若不堕此有无见。得中道实相。云何知实。如过去恒河沙等诸佛菩萨所知所说。未来恒河沙等诸佛菩萨所知所说。现在恒河沙等诸佛菩萨所知所说。信心大故不疑不悔。信力大故能持能受。是名法忍。复次禅定力故。心柔软清净闻诸法实相应心与会。信着深入无疑无悔。所以者何。疑悔是欲界系法。粗恶故。不入柔软心中。是名法忍。复次智慧力故。于一切诸法中。种种观无有一法可得者。是法能忍能受不疑不悔。是名法忍。复次菩萨思惟。凡夫人以无明毒故。于一切诸法中作转相。非常作常想苦作乐想。无我有我想空谓有实。非有为有有为非有。如是等种种法中作转相。得圣实智慧破无明毒。知诸法实相。得无常苦空无我智慧。弃舍不着。是法能忍是名法忍。复次观一切诸法。从本已来常空今世亦空。是法能信能受是为法忍。问曰。若从本已来常空今世亦空。是为恶邪。云何言法忍。答曰。若观诸法毕竟空。取相心着是为恶邪见。若观空不着不生邪见。是为法忍。如偈说

  诸法性常空　　心亦不着空
  如是法能忍　　是佛道初相

如是等种种入智慧门。观诸法实相心不退不悔不随诸观。亦无所忧。能得自利利他。是名法忍。是法忍有三种。行清净不见忍辱法。不见己身。不见骂辱人。不戏诸法。是时名清净法忍。以是事故说菩萨住般若波罗蜜中能具足羼提波罗蜜。不动不退故。云何名不动不退。嗔恚不生不出恶言。身不加恶心无所疑。菩萨知般若波罗蜜实相。不见诸法心无所著故。若人来骂若加楚毒杀害。一切能忍。以是故说住般若波罗蜜中。能具足羼提波罗蜜

    大智度论释初品中毗梨耶波罗蜜义第二十六

【经】身心精进不懈息故应具足毗梨耶波罗蜜

【论】毗梨耶(秦言精进)问曰。如精进。是一切善法本。应最在初。今何以故第四。答曰。布施持戒忍辱世间常有。如客主之义法应供给。乃至畜生亦知布施。或有人种种因缘故能布施。若为今世若为后世。若为道故布施。不须精进。如持戒者。见为恶之人王法治罪。便自畏惧不敢为非。或有性善不作诸恶。有人闻今世作恶后世受罪。而以怖畏故能持戒。有人闻持戒因缘故得离生老病死。是中心生口言。我从今日不复杀生。如是等即是戒。岂须精进波罗蜜而能行耶。如忍辱中。若骂若打若杀。或畏故不报。或少力或畏罪或修善人法或为求道故默然不报。皆不必须精进波罗蜜乃能忍也。今欲得知诸法实相。行般若波罗蜜故修行禅定。禅定是实智慧之门。是中应勤修精进一心行禅。复次布施持戒忍辱。是大福德安隐快乐。有好名誉。所欲者得。既得知此福利之味。今欲增进更得妙胜禅定智慧。譬如穿井已见湿泥。转加增进必望得水。又如钻火已得见烟。倍复力励必望得火。欲成佛道凡有二门。一者福德。二者智慧。行施戒忍是为福德门。知一切诸法实相摩诃般若波罗蜜。是为智慧门。菩萨入福德门。除一切罪所愿皆得。若不得愿者。以罪垢遮故。入智慧门则不厌生死。不乐涅槃。二事一故。今欲出生摩诃般若波罗蜜。般若波罗蜜。要因禅定门。禅定门必须大精进力。何以故散乱心。不能得见诸法实相。譬如风中然灯不能照物。灯在密屋明必能照。是禅定智慧。不可以福愿求。亦非粗观能得。要须身心精勤急着不懈尔乃成办。如佛所说。血肉脂髓皆使竭尽。但令皮骨筋在不舍精进。如是乃能得禅定智慧。得是二事则众事皆办。以是故精进第四。名为禅定实智慧之根。上三中虽有精进少故不说。问曰。有人言。但行布施持戒忍辱故得大福德。福德力故所愿皆得。禅定智慧自然而至。复何用精进波罗蜜为。答曰。佛道甚深难得。虽有布施持戒忍辱力。要须精进。得甚深禅定实智慧及无量诸佛法。若不行精进则不生禅定。禅定不生则不得生梵天王处。何况欲求佛道。复次有人。如民大居士等欲得无量宝物则应意皆得。如顶生王王四天下。天雨七宝及所须之物。释提婆那民分座与坐。虽有是福然不能得道。如罗频珠比丘。虽得阿罗汉道乞食七日不得空钵而还。后以禅定火自烧其身而般涅槃。以是故知。非但福德力故得道。欲成佛道要须勤大精进。问曰。菩萨观精进有何利益。而勤修不懈。答曰。一切今世后世道德利益皆由精进得。复次若人欲自度身。尚当勤急精进。何况菩萨誓愿欲度一切。如赞精进偈中说

  有人不惜身　　智慧心决定
  如法行精进　　所求事无难
  如农失勤修　　所收必丰实
  亦如涉远路　　勤则必能达
  若得生天上　　及得涅槃乐
  如是之因缘　　皆由精进力
  非天非无因　　自作故自得
  谁有智慧人　　而不自勉励
  三界火炽然　　譬如大炎火
  有智决断人　　乃能得免离
  以是故佛告　　阿难正精进
  如是不懈怠　　直至于佛道
  勉强而勤修　　穿地能通泉
  精进亦如是　　无求而不得
  能如行道法　　精进不懈者
  无量果必得　　此报终不失

复次精进法。是一切诸善法之根本。能出生一切诸道法乃至阿耨多罗三藐三菩提。何况于小利。如毗尼中说。一切诸善法乃至阿耨多罗三藐三菩提。皆从精进不放逸生。复次精进能动发先世福德。如雨润种能令必生此亦如是。虽有先世福德因缘。若无精进则不能生。乃至今世利尚不能得。何况佛道。复次诸大菩萨荷负众生。受一切苦乃至阿鼻泥犁中苦。心亦不懈。是为精进。复次一切众事。若无精进则不能成。譬如下药以巴豆为主。若除巴豆则无下力。如是意止神足根力觉道必待精进。若无精进则众事不办。如戒唯在八道不在余处。信在根力余处则无。如精进者无处不有。既总众法而别自有门。譬如无明使遍在一切诸使中。而别有不共无明。问曰。菩萨欲得一切佛法。欲度一切众生。欲灭一切烦恼。皆得如意。云何增益。精进而能得佛。譬如小火不能烧大林。火势增益能烧一切。答曰。菩萨从初发心作誓愿。当令一切众生得欢乐。常为一切不自惜身。若惜身者于诸善法不能成办。以是故增益精进。复次菩萨种种因缘呵懈怠心。令乐着精进。懈怠黑云覆诸明慧。吞灭功德增长不善。懈怠之人。初虽小乐后则大苦。譬如毒食。初虽香美久则杀人。懈怠之心烧诸功德譬如大火烧诸林野。懈怠之人失诸功德。譬如被贼无复遗余。如偈说

  应得而不得　　已得而复失
  既自轻其身　　众人亦不敬
  常处大闇中　　无有诸威德
  尊贵智慧法　　此事永以失
  闻诸妙道法　　不能以益身
  如是之过失　　皆由懈怠心
  虽闻增益法　　不能得上及
  如是之过罪　　皆由懈怠心
  生业不修理　　不入于道法
  如是之过失　　皆由懈怠心
  上智所弃远　　中人时复近
  下愚为之没　　如猪乐在溷
  若为世中人　　三事皆废失
  欲乐及财利　　福德亦复没
  若为出家人　　则不得二事
  生天及涅槃　　名誉二俱失
  如是诸废失　　欲知其所由
  一切诸贼中　　无过懈怠贼
  以是众罪故　　懒心不应作
  马井二比丘　　懈怠坠恶道
  虽见佛闻法　　犹亦不自免

如是等种种。观懈怠之罪精进增长。复次观精进之益。今世后世佛道涅槃之利皆由精进。复次菩萨知一切诸法皆空无所有。而不证涅槃。怜愍众生集诸善法。是精进波罗蜜力。复次菩萨一人独无等侣。以精进福德力故。能破魔军及结使贼得成佛道。既得佛道。于一切诸法一相无相其实皆空。而为众生说诸法种种名字种种方便。度脱众生老病死苦。将灭度时以法身。与弥勒菩萨摩诃萨迦叶阿难等。然后入金刚三昧。自碎身骨令如芥子。以度众生而不舍精进力。复次如阿难。为诸比丘说七觉意。至精进觉意。佛问阿难。汝说精进觉意耶。阿难言说精进觉意。如是三问三答。佛即从坐起告阿难。人能爱乐修行精进。无事不得得至佛道终不虚也。如是种种因缘。观精进利而得增益。如是精进。佛有时说为欲。或时说精进。有时说不放逸。譬如人欲远行。初欲去时是名为欲。发行不住是为精进。能自劝励不令行事稽留。是为不放逸。以是故知欲生精进。精进生故不放逸。不放逸故能生诸法。乃至得成佛道。复次菩萨欲脱生老病死亦欲度脱众生。常应精进一心不放逸。如人擎油钵行大众中。现前一心不放逸故大得名利。又如偏阁崄道若悬绳若乘山羊。此诸恶道以一心不放逸故。身得安隐。今世大得名利。求道精进亦复如是。若一心不放逸所愿皆得。复次譬如水流能决大石。不放逸心亦复如是。专修方便。常行不废。能破烦恼诸结使山。复次菩萨有三种思惟。若我不作不得果报。若我不自作不从他来。若我作者终不失。如是思惟当必精进。为佛道故勤修专精而不放逸。如一小阿兰若。独在林中坐禅而生懈怠。林中有神是佛弟子。入一死尸骨中。歌舞而来。说此偈言

  林中小比丘　　何以生懈废
  昼来若不畏　　夜复如是来

是比丘惊怖起坐内自思惟。中夜复睡。是神复现十头口中出火牙爪如剑眼赤如炎。顾语将从捉此懈怠比丘。此处不应懈怠。何以故尔。是比丘大怖即起思惟。专精念法得阿罗汉道。是名自强精进不放逸力能得道果。复次是精进不自惜身而惜果报。于身四仪坐卧行住常勤精进。宁自失身不废道业。譬如失火以瓶水投之。唯存灭火而不惜瓶。如仙人师教弟子说偈言

  决定心悦豫　　如获大果报
  如愿事得时　　乃知此最妙

如是种种因缘。观精进之利。能令精进增益。复次菩萨修诸苦行。若有人来求索头目髓脑尽能与之。而自念言。我有忍辱精进智慧方便之力受之尚苦。何况愚騃三涂众生。我当为此众生故。勤修精进早成佛道而度脱之

大智度论卷第十五大智度论释初品中毗梨耶波罗蜜义第二十七(卷第十六)

        龙树菩萨造

        后秦龟兹国三藏鸠摩罗什奉　诏译

问曰。云何名精进相。答曰。于事必能起发无难。志意坚强心无疲惓所作究竟。以此五事为精进相。复次如佛所说。精进相者。身心不息故。譬如释迦牟尼佛。先世曾作贾客主。将诸贾人入崄难处。是中有罗刹鬼。以手遮之言。汝住莫动不听汝去。贾客主即以右拳击之。拳即着鬼挽不可离。复以左拳击之亦不可离。以右足蹴之足复粘着。复以左足蹴之亦复如是。以头冲之头即复着。鬼问言。汝今如是欲作何等心休息未。答言。虽复五事被系。我心终不为汝息也。当以精进力。与汝相击要不懈退。鬼时欢喜心念。此人胆力极大。即语人言。汝精进力大。必不休息放汝令去。行者如是。于善法中初夜中夜后夜诵经坐禅求诸法实相。不为诸结使所覆身心不懈。是名精进相。是精进名心数法勤行不住相。随心行共心生。或有觉有观或无觉有观或无觉无观。如阿毗昙法广说。于一切善法中勤修不懈。是名精进相。于五根中名精进根。根增长名精进力。心能开悟名精进觉。能到佛道涅槃城。是名正精进。四念处中能勤系心。是精进分。四正勤是精进门。四如意足中。欲精进即是精进。六波罗蜜中名精进波罗蜜。问曰。汝先赞精进。今说精进相。是名何精进。答曰。是一切善法精进中相。问曰。今说摩诃般若波罗蜜论议中。应说精进波罗蜜。何以故。说一切善法中精进。答曰。初发心菩萨于一切善法中精进。渐渐次第得精进波罗蜜。问曰。一切善法中精进多。今说精进波罗蜜。已入一切善法精进中。答曰。为佛道精进名为波罗蜜。诸余善法中精进。但名精进。不名波罗蜜。问曰。一切善法中勤何以不名精进波罗蜜。而独名菩萨精进为波罗蜜。答曰。波罗蜜名到彼岸。世间人及声闻辟支佛。不能具足行诸波罗蜜。是故不名为精进波罗蜜。复次是人无大慈大悲。弃舍众生不求十力四无所畏十八不共法一切智及无碍解脱无量身无量光明无量音声无量持戒禅定智慧。以是故是人精进不名波罗蜜。复次菩萨精进不休不息一心求佛道。如是行者名为精进波罗蜜。如好施菩萨。求如意珠抒大海水。正使筋骨枯尽终不懈废。得如意珠以给众生济其身苦。菩萨如是难为能为。是为菩萨精进波罗蜜。复次菩萨以精进力为首。行五波罗蜜。是时名为菩萨精进波罗蜜。譬如众药和合能治重病。菩萨精进亦如是。但行精进不能行五波罗蜜。是不名菩萨精进波罗蜜。复次菩萨精进。不为财利富贵力势。亦不为身不为生天转轮王梵释天王。亦不自为以求涅槃。但为佛道利益众生。如是相名为菩萨精进波罗蜜。复次菩萨精进。修行一切善法大悲为首。如慈父爱子。唯有一子而得重病。一心求药救疗其病。菩萨精进以慈为首亦复如是。救疗一切心无暂舍。复次菩萨精进。以实相智慧为首。行六波罗蜜。是名菩萨精进波罗蜜。问曰。诸法实相无为无作。精进有为有作相。云何以实相为首。答曰。虽知诸法实相无为无作。以本愿大悲欲度众生故。于无作中以精进力度脱一切。复次若诸法实相无为无作如涅槃相。无一无二。汝云何言实相与精进相异耶。汝即不解诸法相。复次尔时菩萨观三界五道众生各失所乐。无色界天乐定心着。不觉命尽。堕在欲界中受禽兽形。色界诸天亦复如是。从清净处堕。还受淫欲在不净中。欲界六天乐着五欲。还堕地狱受诸苦痛。见人道中。以十善福贸得人身。人身多苦少乐寿尽多堕恶趣中。见诸畜生受诸苦恼。鞭杖驱驰负重涉远。项领穿坏热铁烧烁。此人宿行因缘。以系缚众生鞭杖苦恼。如是等种种因缘故。受象马牛羊獐鹿畜兽之形。淫欲情重无明偏多。受鹅鸭孔雀鸳鸯鸠鸽鸡鹥鹦鹉百舌之属。受此众鸟种类百千。淫行罪故。身生毛羽隔诸细滑。嘴[口*(甚-其+庚)]粗[革*卬]不别触味。嗔恚偏多。受毒蛇蝮蝎蚑蜂百足含毒之虫。愚痴多故。受蚓蛾蜣螂蚁蝼鸺鹥角鸱之属诸騃虫鸟。憍慢嗔恚多故。受师子虎豹诸猛兽身。邪慢缘故。受生驴猪骆驼之中。悭贪嫉妒轻躁短促故。受猕猴[狂-王+哥]玃熊罴之形。邪贪憎嫉业因缘故。受猫狸土虎诸兽之身。无愧无惭饕餐因缘故。受乌鹊鸱鹫诸鸟之形。轻慢善人故。受鸡狗野干等身。大作布施嗔恚曲心。以此因缘故受诸龙身。大修布施心高陵疟苦恼众生。受金翅鸟形。如是等种种结使业因缘故。受诸畜生禽兽之苦。菩萨得天眼观众生轮转五道回旋其中。天中死人中生。人中死天中生。天中死生地狱中。地狱中死生天上。天上死生饿鬼中。饿鬼中死还生天上。天上死生畜生中。畜生中死生天上。天上死还生天上地狱饿鬼畜生亦如是欲界中死色界中生。色界中死欲界中生。欲界中死无色界中生。无色界中死欲界中生。欲界中死欲界中生。色界无色界亦如是。活地狱中死黑绳地狱中生。黑绳地狱中死活地狱中生。活地狱中死还生活地狱中。合会地狱乃至阿鼻地狱亦如是。炭坑地狱中死。沸屎地狱中生。沸屎地狱中死。炭坑地狱中生。炭坑地狱中死。还生炭坑地狱中。烧林地狱乃至摩诃波头摩地狱亦如是。展转生其中。卵生中死胎生中生。胎生中死卵生中生。卵生中死还生卵生中。胎生湿生化生亦如是。阎浮提中死弗婆提中生。弗婆提中死阎浮提中生。阎浮提中死还生阎浮提中。劬陀尼郁怛罗越亦如是。四天处死三十三天中生。三十三天中死四天处生。四天处死还生四天处。三十三天乃至他化自在天亦如是。梵众天中死梵辅天中生。梵辅天中死梵众天中生。梵众天中死还生梵众天中。梵辅天少光天无量光光音少净无量净遍净何那跋罗伽得生。大果虚空处。识处。无所有处。非有想非无想处。亦如是。非有想非无想天中死阿鼻地狱中生。如是展转生五道中。菩萨见是已生大悲心。我于众生为无所益。虽与世乐乐极则苦。当以佛道涅槃常乐益于一切。云何而益。当勤大精进乃得实智慧。得实智慧知诸法实相。以余波罗蜜助成以益众生。是为菩萨精进波罗蜜。见饿鬼中饥渴故两眼陷毛发长。东西驰走若欲趣水。护水诸鬼以铁杖逆打。设无守鬼水自然竭。或时天雨雨化为炭。或有饿鬼常被火烧。如劫尽时诸山火出。或有饿鬼羸瘦狂走。毛发蓬乱以覆其身。或有饿鬼常食屎尿涕唾欧吐荡涤余汁。或时至厕溷边立伺求不净汁。或有饿鬼常求产妇藏血饮之。形如烧树咽如针孔。若与其水千岁不足或有饿鬼。自破其头以手取脑而舐。或有饿鬼形如黑山铁锁锁颈叩头求哀归命狱卒。或有饿鬼先世恶口。好以粗语加彼众生。众生憎恶见之如仇。以此罪故堕饿鬼中。如是等种种罪故。堕饿鬼趣中受无量苦痛。见八大地狱苦毒万端。活大地狱中诸受罪人各各共斗。恶心嗔诤手捉利刀互相割剥。以槊相刺。铁叉相叉。铁棒相棒。铁杖相捶。铁铲相贯。而以利刀互相切脍。又以铁爪而相爴裂。各以身血而相涂漫。痛毒逼切闷无所觉。宿业因缘冷风来吹。狱卒唤之咄诸罪人还活。以是故名活地狱。即时平复复受苦毒。此中众生以宿行因缘好杀物命。牛羊禽兽。为田业舍宅奴婢妻子国土钱财故而相杀害。如是等种种杀业报故。受此剧罪。见黑绳大地狱中罪人。为恶罗刹狱卒鬼匠。常以黑热铁绳。拼度罪人。以狱中铁斧煞之斫之。长者令短短者令长。方者使圆圆者使方。斩截四肢却其耳鼻落其手足。以大铁锯解析揣截。破其肉分脔脔称之。此人宿行因缘谗贼忠良。妄语恶口两舌无义语枉杀无辜。或作姧吏酷暴侵害。如是等种种恶口谗贼故受此罪。见合会大地狱中。恶罗刹狱卒作种种形。牛马猪羊獐鹿狐狗虎狼师子六驳大鸟雕鹫鹑鸟。作此种种诸鸟兽头。而来吞啖咬啮[齒*齊]掣罪人。两山相合大热铁轮轹诸罪人令身破碎。热铁臼中捣之令碎。如笮蒲桃亦如压油。譬如蹂场聚肉成[卄/積]。积头如山。血流成池。雕鹫虎狼各来诤掣。此人宿业因缘多杀牛马猪羊獐鹿狐兔虎狼师子六驳大鸟众鸟。如是等种种鸟兽多残贼故还为此众鸟兽头来害罪人。又以力势相陵枉压羸弱。受两山相合罪。悭贪嗔恚愚痴怖畏故。断事轻重不以正理。或破正道转易正法。受热铁轮轹热铁臼捣。第四第五名叫唤大叫唤。此大地狱其中罪人罗刹狱卒头黄如金。眼中火出着赤色衣。身肉坚劲走疾如风。手足长大口出恶声。捉三股叉箭。堕如雨刺射罪人。罪人狂怖叩头求哀。小见放舍小见怜愍。即时将入热铁地狱纵广百由旬。驱打驰走足皆焦然。脂髓流出如笮苏油。铁棒棒头头破脑出如破酪瓶。斫剉割剥身体糜烂。而复将入铁阁。屋间黑烟来熏。互相推压更相怨毒。皆言何以压我才欲求出其门以闭。大声嗥呼音常不绝。此人宿行因缘。皆由斗秤欺诳非法断事。受寄不还。侵陵下劣。恼诸穷贫令其号哭。破他城郭坏人聚落伤害劫剥。室家怨毒举城叫唤。有时谲诈欺诳诱之。令出而复害之。如是等种种因缘故。受如此罪。大叫唤地狱中人。皆坐熏杀穴居之类。幽闭囹圄或闇烟窟中而熏杀之。或投井中劫夺他财。如是等种种因缘。受大叫唤地狱罪。第六第七热大热地狱。中有二大铜镬。一名难陀二名跋难陀(秦言喜大喜也)碱沸水满中。罗刹鬼狱卒以罪人投中。如厨士烹肉。人在镬中脚上头下。譬如煮豆熟烂。骨节解散皮肉相离。知其已烂以叉叉出。行业因缘冷风吹活。复投炭坑中。或着沸屎中。譬如鱼出于水而着热沙中。又以浓血而自煎熬。从炭坑中出。投之焰床强驱令坐。眼耳鼻口及诸毛孔一切火出。此人宿世恼乱父母师长沙门婆罗门。于诸好人福田中恼令心热。以此罪故受热地狱罪。或有宿世煮生茧。或生炙猪羊。或以木贯人而生炙之。或焚烧山野及诸聚落佛图精舍。及天神等。或推众生着火坑中。如是等种种因缘。生此地狱中。见阿鼻地狱。纵广四千里周回铁壁。于七地狱其处最深。狱卒罗刹以大铁椎椎诸罪人。如锻师打铁。从头剥皮乃至其足。以五百钉钉挓其身如挓牛皮。互相掣挽应手破裂。热铁火车以轹其身驱入火坑。令抱炭出热沸屎河驱令入中。有铁嘴毒虫。从鼻中入脚底出。从足下入口中出。竖剑道中驱令驰走。足下破碎如厨脍肉。利刀剑槊飞入身中。譬如霜树落叶随风乱坠。罪人手足耳鼻支节。皆被斫剥割截在地流血成池。二大恶狗一名赊摩二名赊婆罗。铁口猛毅破人筋骨。力踰虎豹猛如师子。有大刺林驱逼罪人强令上树。罪人上时刺便下向。下时刺便上向。大身毒蛇蝮蝎恶虫竞来啮之。大鸟长嘴破头啖脑。入碱河中随流上下。出则蹈热铁地行铁刺上。或坐铁杙杙从下入。以钳开口灌以洋铜。吞热铁丸入口。口焦入咽咽烂入腹。腹然五藏皆焦直过堕地。但见恶色恒闻臭气常触粗涩遭诸苦痛迷闷委顿。或狂逸唐突或藏窜投掷或颠匐堕落。此人宿行多造大恶五逆重罪。断诸善根法言非法非法言法。破因破果憎嫉善人。以是罪故入此地狱受罪最剧。如是等种种八大地狱周围其外复有十六小地狱为眷属。八寒冰八炎火。其中罪毒不可见闻。八炎火地狱者。一名炭坑二名沸屎三名烧林四名剑林五名刀道六名铁刺林七名碱河八名铜橛。是为八。八寒冰地狱者。一名頞浮陀(少多有孔)二名尼罗浮陀(无孔)三名阿罗罗(寒战声也)四名阿婆婆(亦患寒声)五名睺睺(亦是患寒声)六名沤波罗(此地狱外壁似青莲花也)七名波头摩(红莲花罪人生中受苦也)八名摩诃波头摩。是为八。若破清净戒出家法。令白衣轻贱佛道。或排众生着火坑中。或众生命未尽顷于火上炙之。如是等种种因缘。堕炭坑地狱中。大火炎炭至膝烧罪人身。若沙门婆罗门福田食。以不净手触。或先啖或以不净物着中。或以热沸屎灌他身破净命。以邪命自活。如是等种种因缘。堕沸屎地狱中。沸屎深广如大海水。中有虫以铁为嘴破罪人头啖脑破骨食髓。若焚烧草木伤害诸虫。或烧林大猎为害弥广。如是等种种因缘。堕烧林地狱中。草木火然以烧罪人。若执持刀剑斗诤伤杀。若斫树压人以报宿怨。若人以忠信诚告而密相中陷。如是等种种因缘。堕剑林地狱中。此地狱罪人入中。风吹剑叶割截手足耳鼻皆令堕落。是时林中有乌鹫恶狗来食其肉。若以利刀刺人。若橛若枪伤人。若断截道路拨彻桥梁。破正法道示以非法道。如是等种种因缘。堕利刀道地狱中。利刀道地狱者。于绝壁狭道中。竖利刀令罪人行上而过。若犯邪淫侵他妇女贪受乐触。如是等种种因缘。堕铁刺林地狱中。刺树高一由旬。上有大毒蛇化作美女身。唤此罪人上来共汝作乐。狱卒驱之令上。刺皆下向贯刺罪人。身被刺害入骨彻髓。既至林上化女还复蛇身。破头入腹处处穿穴皆悉破烂。忽复还活身体平复。化女复在树下唤之狱卒以箭仰射呼之令下刺复仰刺。既得到地化女身复毒蛇破罪人身。如是久久从热铁刺林出。遥见河水清凉快乐。走往趣之入中变成热沸碱水。罪人在中须臾之顷。皮肉离散骨立水中。狱卒罗刹以叉钩出之。持着岸上。此人宿行因缘。伤杀水性鱼鳖之属。或时排人及诸众生令没水中。或投之沸汤或投之冰水。如是等种种恶业因缘故受此罪。若在铜橛地狱。狱卒罗刹问诸罪人。汝何处来。答言。我苦闷不知来处。但患饥渴若言渴。是时狱卒即驱逐罪人令坐热铜橛上。以铁钳开口灌以洋铜。若言饥坐之铜橛吞以铁丸入口。口焦入咽咽烂入腹。腹然五藏烂坏直过堕地。此人宿行因缘劫盗他财以自供口。诸出家人或时诈病多求酥油石蜜。或无戒无禅无有智慧。而多受人施或恶口伤人。如是等种种宿业因缘。堕铜橛地狱。若人堕頞浮陀地狱中。其处积冰毒风来吹。令诸罪人皮毛裂落筋肉断绝骨破髓出。即复完坚受罪如初。此人宿业因缘。寒月剥人或劫盗冻人薪火。或作恶龙嗔毒忿恚。放大雹雨冰冻害人。或轻贱谤毁若佛及佛弟子持戒之人。或口四业作众重罪。如是等种种因缘。堕頞浮陀地狱中。尼罗浮陀亦如是。頞浮陀少多有孔时得出入。尼罗波绝无孔罅无出入处。呵婆婆呵罗罗睺睺此三地狱。寒风噤战口不能开。因其呼声而以名狱。沤波罗狱中。冻冰浃渫有似青莲花。波头摩状。如此间赤莲花。摩呵波头摩。是中拘迦离住处。有智之人闻是惊言。咄以此无明恚爱法故。乃受此苦。出而复入无穷无已。菩萨见此如是思惟。此苦业因缘皆是无明诸烦恼所作。我当精进勤修六度集诸功德。断除众生五道中苦。兴发大哀增益精进。如见父母幽闭囹圄拷掠搒笞忧毒万端。方便求救心不暂舍。菩萨见诸众生受五道苦念之如父亦复如是。复次菩萨精进世世勤修。求诸财宝给施众生心无懈废。自有财物能尽施与心亦不懈。复次精进持戒。若大若小一切能受。一切能持不毁不犯。大如毛发。设有违失即时发露初不覆藏。复次勤修忍辱。若人刀杖打害骂詈毁辱及恭敬供养。一切能忍不受不着。于深法中其心不没亦不疑悔。复次专精一心修诸禅定。能住能守得五神通及四等心胜处背舍十一切处。具诸功德得四念处及诸菩萨见佛三昧。复次菩萨精进求法不懈。身心勤力供养法师。种种恭敬供给给使。初不违失亦不废退。不惜身命以为法故。诵读问答。初中后夜思惟忆念筹量分别。求其因缘选择同异。欲知实相一切诸法自相异相总相别相一相有相无相如实相。诸佛菩萨无量智慧心不没不退。是名菩萨精进。如是等种种因缘。能生能办种种善法。是故名为精进波罗蜜。波罗蜜义如先说。复次菩萨精进。名为精进波罗蜜。余人精进不名波罗蜜。问曰。云何为精进满足。答曰。菩萨生身法性身能具功德。是为精进波罗蜜满足。满足义如上说。身心精进。不废息故。问曰。精进是心数法。经何以名身精进。答曰。精进虽是心数法。从身力出故名为身精进。如受是心数法。而有五识相应受。是名身受有意识相应受是为心受。精进亦如是。身力勤修若手布施。口诵法言。若讲说法。如是等名为身口精进。复次行布施持戒。是为身精进。忍辱禅定智慧是名心精进。复次外事勤修是为身精进。内自专精是为心精进。粗精进名为身。细精进名为心。为福德精进名为身。为智慧精进是为心。若菩萨初发心乃至得无生忍。于是中间名身精进。生身未舍故得无生忍。舍肉身得法性身。乃至成佛。是为心精进。复次菩萨初发心时功德未足故。种三福因缘。布施持戒善心渐得福报。以施众生。众生未足。更广修福发大悲心。一切众生不足于财多作众恶。我以少财不能满足其意。其意不满不能勤受教诲。不受道教不能得脱生老病死。我当作大方便给足于财令其充满。便入大海求诸异宝。登山履危以求妙药。入深石窟求诸异物石汁珍宝以给众生。或作萨陀婆冒涉崄道。劫贼师子虎狼恶兽。为布施众生故。勤求财宝不以为难。药草咒术能令铜变为金。如是种种变化致诸财物。及四方无主物以给众生。是为身精进。得五神通能自变化作诸美味。或至天上取自然食。如是等名为心精进。能集财宝以用布施。是为身精进。以是布施之德。得至佛道。是为心精进。生身菩萨行六波罗蜜。是为身精进。法性身菩萨行六波罗蜜。是为心精进(未得法身心则随身。已得法身则心不随身。身不累心也)

复次一切法中皆能成办不惜身命。是为身精进。求一切禅定智慧时心不懈惓。是为心精进。复次身精进者。受诸勤苦终不懈废。如说。波罗柰国梵摩达王。游猎于野林中见二鹿群。群各有主。一主有五百群鹿。一主身七宝色。是释迦牟尼菩萨。一主是提婆达多。菩萨鹿王见人王大众杀其部党。起大悲心迳到王前。王人竞射飞矢如雨。王见此鹿直进趣已无所忌惮。敕诸从人摄汝弓矢无得断其来意。鹿王既至跪白人王。君以嬉游逸乐小事故。群鹿一时皆受死苦。若以供膳辄当差次日送一鹿以供王厨。王善其言听如其意。于是二鹿群主大集差次各当一日送应次者。是时提婆达多鹿群中。有一鹿怀子来白其主。我身今日当应送死。而我怀子子非次也。乞垂料理使死者得次生者不滥。鹿王怒之言。谁不惜命。次来但去何得辞也。鹿母思惟。我王不仁不以理恕不察我辞。横见嗔怒不足告也。即至菩萨王所以情具白。王问此鹿。汝主何言。鹿曰。我主不仁。不见料理而见嗔怒。大王仁及一切故来归命。如我今日天地虽旷无所控告。菩萨思惟。此甚可愍。若我不理抂杀其子。若非次更差次未及之。如何可遣。唯有我当代之思。之既定。即自送身遣鹿母还。我今代汝汝勿忧也。鹿王迳到王门。众人见之怪其自来以事白王。王亦怪之而命令前问言。诸鹿尽耶。汝何以来。鹿王言。大王仁及群鹿人无犯者。但有滋茂何有尽时。我以异部群中有一鹿怀子。以子垂产身当殂割子亦并命。归告于我我以愍之。非分更差是亦不可。若归而不救无异木石。是身不久必不免死。慈救苦厄功德无量。若人无慈与虎狼无异。王闻是言即从坐起。而说偈言

  我实是畜兽　　名曰人头鹿
  汝虽是鹿身　　名为鹿头人
  以理而言之　　非以形为人
  若能有慈惠　　虽兽实是人
  我从今日始　　不食一切肉
  我以无畏施　　且可安汝意

诸鹿得安王得仁信。复次如爱法梵志。十二岁遍阎浮提。求知圣法而不能得。时世无佛佛法亦尽。有一婆罗门言。我有圣法一偈若实爱法当以与汝。答言。实爱法。婆罗门言。若实爱法当以汝皮为纸以身骨为笔以血书之。当以与汝。即如其言破骨剥皮以血写偈

  如法应修行　　非法不应受
  今世亦后世　　行法者安隐

复次昔野火烧林。林中有一雉勤身自力。飞入水中渍其毛羽来灭大火。火大水少往来疲乏不以为苦。是时天帝释来问之言。汝作何等。答言。我救此林愍众生故。此林荫育处广清凉快乐。我诸种类及诸宗亲并诸众生皆依仰此。我有身力云何懈怠而不救之。天帝问言。汝乃精勤当至几时。雉言。以死为期。天帝言。汝心虽尔谁证知者。即自立誓。我心至诚信不虚者火即当灭。是时净居天。知菩萨弘誓。即为灭火。自古及今唯有此林。常独蔚茂不为火烧。如是等种种。宿世所行难为能为。不惜身命国财妻子象马七珍头目骨髓勤施不惓。如说。菩萨为诸众生。一日之中千死千生如檀尸忍禅。般若波罗蜜中所行如是。菩萨本生经中种种因缘相。是为身精进。于诸善法修行。信乐不生疑悔而不懈怠。从一切贤圣。下至凡人求法无厌。如海吞流。是为菩萨心精进。问曰。心无厌足是事不然。所以者何。若所求事办所愿已成是则应足。若理不可求事不可办。亦应舍废。云何恒无厌足。如人穿井求泉。用功转多。转无水相。则应止息。亦如行道。已到所在不应复行。云何恒无厌足。答曰。菩萨精进。不可以世间譬喻为比。如穿井力少则不能得水。非无水也。若此处无水余处必有如有所至。必求至佛至佛无厌诲人不惓。故言无厌。复次菩萨精进志愿弘旷。誓度一切而众生无尽。是故精进亦不可尽。汝言事办应止是事不然。虽得至佛众生未尽不应休息。譬如火相若不灭终不冷。菩萨精进亦复如是。未入灭度终不休息。以是故十八不共法中。欲及精进二事常修。复次菩萨不住法住般若波罗蜜中不废精进。是菩萨精进非佛精进。复次菩萨未得菩萨道。生死身以好事施众生。众生反更以不善事加之。或有众生。菩萨赞美反更毁辱。菩萨恭敬而反轻慢。菩萨慈念反求其过。谋欲中伤。此众生等无有力势来恼菩萨。菩萨于此众生发弘誓愿。我得佛道要当度此恶中之恶诸众生辈。于此恶中其心不懈生大悲心。譬如慈母怜其子病忧念不舍如是相是为菩萨精进。复次行布施波罗蜜时。十方种种乞儿来欲求索。不应索者皆来索之。及所爱重难舍之物。语菩萨言。与我两眼。与我头脑骨髓爱重妻子及诸贵价珍宝。如是等难舍之物。乞者强索。其心不动悭嗔不起。见疑心不生。一心为佛道故布施。譬如须弥山四方风吹所不能动。如是种种相。是名精进波罗蜜。复次菩萨精进。遍行五波罗蜜。是为精进波罗蜜。问曰。若行戒波罗蜜时。若有人来乞三衣钵盂。若与之则毁戒。何以故佛不听故。若不与则破檀波罗蜜。精进云何遍行五事。答曰。若新行菩萨。则不能一世一时遍行五波罗蜜。如菩萨行檀波罗蜜时。见饿虎饥急欲食其子。菩萨是时兴大悲心即以身施。菩萨父母以失子故。忧愁懊恼两目失明。虎杀菩萨亦应得罪而不筹量。父母忧苦虎得杀罪。但欲满檀自得福德。又如持戒比丘。随事轻重摈。诸犯法。被摈之人愁苦懊恼。但欲持戒不愍其苦。或时行世俗般若息慈悲心。如释迦牟尼菩萨。宿世为大国王太子。父王有梵志师不食五谷。众人敬信以为奇特。太子思惟人有四体必资五谷。而此人不食必是曲取人心非真法也。父母告子此人精进不食五谷是世希有。汝何愚甚而不敬之。太子答言。愿小留意。此人不久证验自出。是时太子求其住处至林树间。问林中牧牛人。此人何所食啖。牧牛者答言。此人夜中少多服酥以自全命。太子知已还宫欲出其证验。即以种种诸下药草熏青莲华。清旦梵志入宫坐王边。太子手执此花来供养之拜已授与。梵志欢喜自念。王及夫人内外大小皆服事我。唯太子不见敬信。今日以好华供养甚善无量。得此好华敬所来处。举以向鼻嗅之。华中药气入腹。须臾腹内药作欲求下处。太子言。梵志不食何缘向厕。急捉之须臾便吐王边。吐中纯酥。证验现已。王与夫人乃知其诈。太子言。此人真贼求名故以诳一国。如是行世俗般若。但求满智。寝怜愍心不畏人嗔。或时菩萨行出世间般若。于持戒布施心不染着。何以故施者受者所施财物。于罪不罪于嗔不嗔。于进于怠摄心散心不可得故。复次菩萨行精进波罗蜜。于一切法不生不灭非常非无常非苦非乐非空非实非我非无我非一非异非有非无。尽知一切诸法因缘和合。但有名字实相不可得。菩萨作如是观。知一切有为皆是虚诳心息无为。欲灭其心唯以寂灭为安隐。尔时念本愿怜愍众生故。还行菩萨法集诸功德。菩萨自念我虽知诸法虚诳。众生不知是事。于五道中受诸苦痛。我今当具足行六波罗蜜。菩萨报得神通。亦得佛道三十二相八十种好。一切智慧大慈大悲无碍解脱。十力四无所畏十八不共法三达等无量诸佛法。得是法时一切众生皆得信净。皆能受行爱乐佛法能办是事。皆是精进波罗蜜力。是为精进波罗蜜。如佛所说。尔时菩萨精进不见身不见心。身无所作心无所念。身心一等而无分别。所求佛道以度众生。不见众生为此岸。佛道为彼岸。一切身心所作放舍。如梦所为觉无所作。是名寂灭。诸精进故名为波罗蜜。所以者何。知一切精进皆是邪伪故。以一切作法皆是虚妄不实。如梦如幻。诸法平等是为真实。平等法中不应有所求索。是故知一切精进皆是虚妄。虽知精进虚妄。而常成就不退。是名菩萨真实精进。如佛言。我于无量劫中。头目髓脑以施众生令其愿满。持戒忍辱禅定时。在山林中身体干枯。或持斋节食。或绝诸色味或忍骂辱刀杖之患。是故身体焦枯。又常坐禅曝露勤苦以求智慧。诵读思惟问难讲说。一切诸法以智分别好恶粗细虚实多少。供养无量诸佛。殷勤精进求此功德。欲具足五波罗蜜。我是时无所得。不得檀尸羼精进禅智慧波罗蜜。见然灯佛以五华散佛。布发泥中。得无生法忍。即时六波罗蜜满。于空中立偈赞然灯佛。见十方无量诸佛。是时得实精进身。精进平等故得心平等。心平等故得一切诸法平等。如是种种因缘相。名为精进波罗蜜

大智度论卷第十六大智度论释初品中禅波罗蜜第二十八(卷第十七)

        龙树菩萨造

        后秦龟兹国三藏鸠摩罗什奉　诏译

【经】不乱不味故。应具足禅波罗蜜

【论】问曰。菩萨法以度一切众生为事。何以故。闲坐林泽静默山间。独善其身弃舍众生。答曰。菩萨身虽远离众生心常不舍。静处求定得实智慧以度一切。譬如服药将身权息家务。气力平健则修业如故。菩萨宴寂亦复如是。以禅定力故服智慧药。得神通力还在众生。或作父母妻子。或作师徒宗长。或天或人下至畜生。种种语言方便开导。复次菩萨行布施持戒忍辱是三事。名为福德门。于无量世中。作天王释提桓因转轮圣王阎浮提王。常施众生七宝衣服。五情所欲今世后世皆令具足。如经中说。转轮圣王以十善教民。后世皆生天上。世世利益众生令得快乐。此乐无常还复受苦。菩萨因此发大悲心。欲以常乐涅槃利益众生。此常乐涅槃。从实智慧生实智慧从一心禅定生。譬如然灯。灯虽能照在大风中不能为用。若置之密宇其用乃全。散心中智慧亦如是。若无禅定静室。虽有智慧其用不全。得禅定则实智慧生。以是故菩萨虽离众生远在静处求得禅定。以禅定清净故智慧亦净。譬如油炷净故其明亦净。以是故欲得净智慧者。行此禅定。复次若求世间近事。不能专心则事业不成。何况甚深佛道而不用禅定。禅定名摄诸乱心。乱心轻飘甚于鸿毛。驰散不停驶过疾风。不可制止剧于猕猴。暂现转灭甚于掣电。心相如是不可禁止。若欲制之非禅不定。如偈说

  禅为守智藏　　功德之福田
  禅为清净水　　能洗诸欲尘
  禅为金刚铠　　能遮烦恼箭
  虽未得无余　　涅槃分已得
  得金刚三昧　　摧碎结使山
  得六神通力　　能度无量人
  嚣尘蔽天日　　大雨能淹之
  觉观风散心　　禅定能灭之

复次禅定难得。行者一心专求不废乃当得之。诸天及神仙犹尚不能得。何况凡夫懈怠心者。如佛在尼拘卢树下坐禅。魔王三女。说偈问言

  独坐林树间　　六根常寂默
  有若失重宝　　无援愁苦毒
  容颜世无比　　而常闭目坐
  我等心有疑　　何求而在此

尔时世尊。以偈答曰

  我得涅槃味　　不乐处染爱
  内外贼已除　　汝父亦灭退
  我得甘露味　　安乐坐林间
  恩爱之众生　　为之起慈心

是时三女。心生惭愧而自说言。此人离欲不可动也。即灭去不现。问曰。行何方便得禅波罗蜜。答曰。却五事(五尘)除五法(五盖)行五行。云何却五事当呵责五欲。哀哉众生常为五欲所恼而犹求之不已。此五欲者得之转剧。如火炙疥。五欲无益如狗咬骨。五欲增诤如鸟竞肉。五欲烧人如逆风执炬。五欲害人如践恶蛇。五欲无实如梦所得。五欲不久如假借须臾。世人愚惑贪着五欲至死不舍。为之后世受无量苦。譬如愚人贪着好果。上树食之不肯时下。人伐其树树倾乃堕身首毁坏痛恼而死。又此五欲得时须臾。乐失时为大苦。如蜜涂刀舐者。贪甜不知伤舌。五欲法者与畜生共。有智者识之能自远离。如说。有一优婆塞。与众估客远出治生。是时寒雪夜行失伴。在一石窟中住。时山神变为一女。来欲试之。说此偈言

  白雪覆山地　　鸟兽皆隐藏
  我独无所恃　　惟愿见愍伤

优婆塞两手掩耳。而答偈言

  无羞弊恶人　　说此不净言
  水漂火烧去　　不欲闻汝声
  有妇心不欲　　何况造邪淫
  诸欲乐甚浅　　大苦患甚深
  诸欲得无厌　　失之为大苦
  未得愿欲得　　得之为所恼
  诸欲乐甚少　　忧苦毒甚多
  为之失身命　　如蛾赴灯火

山神闻此偈已。即擎此人送至伴中。是为智者呵欲不可。着五欲者。名为妙色声香味触。欲求禅定皆应弃之。云何弃色。观色之患。若人着色诸结使火。尽皆炽然烧害人身。如火烧金银。煮沸热蜜虽有色味烧身烂口。急应舍之。若人染着妙色美味亦复如是。复次好恶在人色无定也。何以知之。如遥见所爱之人即生喜爱心。若遥见怨家恶人即生怒害心。若见中人则无怒无喜。若欲弃此喜怒。当除邪念及色一时俱舍。譬如洋金烧身。若欲除之。不得但欲弃火而留金。要当金火俱弃。如频婆娑罗王。以色故身入敌国。独在淫女阿梵婆罗房中。忧填王以色染故。截五百仙人手足。如是等种种因缘。是名呵色欲。云何呵声。声相不停暂闻即灭。愚痴之人不解声相无常变失故。于音声中妄生好乐。于已过之声念而生着。如五百仙人在山中住。甄陀罗女于雪山池中浴。闻其歌声即失禅定。心醉狂逸不能自持。譬如大风吹诸林树。闻此细妙歌声柔软清净。生邪念想。是故不觉心狂。今世失诸功德。后世当堕恶道。有智之人观声。念念生灭前后不俱。无相及者。作如是知则不生染着。若斯人者诸天音乐尚不能乱。何况人声。如是等种种因缘。是名呵声欲。云何呵香。人谓着香少罪。染爱于香开结使门虽复百岁持戒能一时坏之。如一阿罗汉。常入龙宫食已以钵授与沙弥令洗。钵中有残饭数粒。沙弥嗅之大香。食之甚美。便作方便入师绳床下。两手捉绳床脚。其师至时与绳床俱入龙宫。龙言。此未得道何以将来。师言。不觉。沙弥得饭食之。又见龙女身体端正香妙无比心大染着。即作要愿。我当作福夺此龙处居其宫殿。龙言。后莫将此沙弥来。沙弥还已一心布施持戒。专求所愿。愿早作龙。是时绕寺足下水出。自知必得作龙。径至师本入处大池边。以袈裟覆头而入。即死变为大龙。福德大故即杀彼龙举池尽赤。未尔之前诸师及僧呵之。沙弥言。我心已定心相已出。时师将诸众僧就池观之。如是因缘由着香故。复次有一比丘。在林中莲华池边经行。闻莲华香其心悦乐过而心爱。池神语之言。汝何以故舍彼林下禅净坐处而偷我香。以着香故诸结使卧者皆起。时更有一人来入池中。多取其花掘挽根茎狼籍而去。池神默无所言。比丘言。此人破汝池取汝花。汝都无言。我但池岸边行。便见呵骂言偷我香池神言。世间恶人常在罪垢粪中不净没头。我不共语也。汝是禅行好人。而着此香破汝好事。是故呵汝。譬如白叠鲜净。而有黑物点污众人皆见。彼恶人者。譬如黑衣点墨人所不见。谁问之者。如是等种种因缘。是名呵香欲。云何呵味。当自觉悟。我但以贪着美味故当受众苦。洋铜灌口啖烧铁丸。若不观食法嗜心坚着。堕不净虫中。如一沙弥心常爱酪。诸檀越饷僧酪。时沙弥每得残分。心中爱着乐喜不离。命终之后生此残酪瓶中。沙弥师得阿罗汉道。僧分酪时语言。徐徐莫伤此爱酪沙弥。诸人言。此是虫何以言爱酪沙弥。答言。此虫本是我沙弥但坐贪爱残酪故生此瓶中。师得酪分虫在中来。师言。爱酪人汝何以来。即以酪与之。复次如一国王名月分王。有太子爱着美味。王守园者日送好果。园中有一大树。树上有鸟养子。常飞至香山中。取好香果以养其子。众子争之一果堕地。守园人晨朝见之。奇其非常即送与王。王珍此果香色殊异。太子见之便索。王爱其子即以与之。太子食果得其气味。染心深着日日欲得。王即召园人问其所由。守园人言。此果无种从地得之。不知所由来也。太子啼哭不食。王催责园人仰汝得之。园人至得果处。见有鸟巢知鸟衔来。翳身树上伺欲取之。鸟母来时即夺得果送。日日如是。鸟母怒之于香山中取毒果。其香味色全似前者。园人夺得输王。王与太子。食之未久身肉烂坏而死。着味如是有失身之苦。如是等种种因缘。是名呵着味欲。云何呵触。此触是生诸结使之火因。系缚心之根本。何以故。余四情则各当其分。此则遍满身识。生处广故多生染着。此着难离。何以知之。如人着色。观身不净三十六种则生厌心。若于触中生着虽知不净。贪其细软观不净无所益。是故难离。复次以其难舍故。为之常作重罪。若堕地狱。地狱有二部。一名寒冰二名焰火。此二狱中皆以身触受罪苦毒万端。此触名为大黑闇处。危难之险道也。复次如罗睺罗母本生经中说。释迦文菩萨有二夫人。一名劬毗耶。二名耶输陀罗。耶输陀罗罗睺罗母也。劬毗耶是宝女故不孕子。耶输陀罗以菩萨出家夜。自觉妊身。菩萨出家六年苦行。耶输陀罗亦六年怀妊不产。诸释诘之。菩萨出家何由有此。耶输陀罗言。我无他罪。我所怀子实是太子体胤。诸释言。何以久而不产。答言。非我所知。诸释集议。闻王欲如法治罪。劬毗耶白王。愿宽恕之。我常与耶输陀罗共住。我为其证知其无罪。待其子生知似父不治之无晚。王即宽置。佛六年苦行既满。初成佛时其夜生罗睺罗。王见其似父爱乐忘忧。语群臣言。我儿虽去今得其子。与儿在无异。耶输陀罗。虽免罪黜恶声满国。耶输陀罗欲除恶名。佛成道已。还迦毗罗婆度诸释子。时净饭王及耶输陀罗。常请佛入宫食。是时耶输陀罗持一钵百味欢喜丸。与罗睺罗令持上佛。是时佛以神力。变五百阿罗汉。皆如佛身无有别异。罗睺罗以七岁身持欢喜丸。径至佛前奉进世尊。是时佛摄神力。诸比丘身复如故。皆空钵而坐。唯佛钵中盛满欢喜丸。耶输陀罗即白王言。以此证验我无罪也。耶输陀罗即问佛言。我有何因缘怀妊六年佛言。汝子罗睺罗。过去久远世时曾作国王。时有一五通仙人来入王国。语王言。王法治贼请治我罪。王言。汝有何罪。答言。我入王国犯不与取。辄饮王水用王杨枝。王言。我以相与何罪之有。我初登王位。皆以水及杨枝施于一切。仙人言。王虽已施我心疑悔罪不除也。愿今见治无令后罪。王言。若必欲尔。小停待我入还。王入宫中六日不出。此仙人在王园中六日饥渴。仙人思惟。此王正以此治我。王过六日而出辞谢仙人。我便相忘莫见咎也。以是因缘故。受五百世三恶道罪。五百世常六年在母胎中。以是证故。耶输陀罗无有罪也。是时世尊。食已出去。耶输陀罗心生悔恨。如此好人世所希有。我得遭遇而今永失。世尊坐时谛视不眴。世尊出时寻后观之远没乃止。心大懊恨。每一思至躄地气绝。傍人以水洒之乃得苏息。常独思惟。天下谁能善为咒术。能转其心令复本意欢乐如初。即以七宝名珠着金槃上以持募人。有一梵志应之言。我能咒之令其意转。当作百味欢喜丸。以药草和之。以咒语禁之。其心便转必来无疑。耶输陀罗受其教法。遣人请佛。愿与圣众俱屈威神。佛入王宫。耶输陀罗即遣百味欢喜丸着佛钵中。佛既食之。耶输陀罗冀想如愿欢娱如初。佛食无异心目澄静。耶输陀罗言。今不动者药力未行故耳。药势发时必如我愿。佛饭食讫而咒愿已从座起去。耶输陀罗冀药力晡时日入当发必还宫中。佛食如常身心无异。诸比丘明日食时。着衣持钵入城乞食。具闻此事增益恭敬。佛力无量神心难测不可思议。耶输陀罗药欢喜丸其力甚大。而世尊食之身心无异。诸比丘食已出城。以是事具白世尊。佛告诸比丘。此耶输陀罗。非但今世以欢喜丸惑我。乃往过去世时。亦以欢喜丸惑我。尔时世尊。为诸比丘说本生因缘。过去久远世时。婆罗奈国山中有仙人。以仲春之月于澡槃中小便。见鹿麚麀合会。淫心即动精流槃中。麀鹿饮之即时有娠。满月生子形类如人。唯头有一角其足似鹿。鹿当产时至仙人庵边而产。见子是人。以付仙人而去。仙人出时见此鹿子。自念本缘。知是己儿取已养育。及其年大勤教学问。通十八种大经。又学坐禅行四无量心即得五神通。一时上山值大雨。泥滑其足不便。躄地破其鍕持。又伤其足。便大嗔恚。以鍕持盛水咒令不雨。仙人福德诸龙鬼神皆为不雨。不雨故五谷五果尽皆不生。人民穷乏无复生路。婆罗奈国王忧愁懊恼。命诸大官集议雨事。明者议言。我曾传闻。仙人山中有一角仙人。以足不便故。上山躄地伤足。嗔咒此雨令十二年不堕。王思惟言。若十二年不雨我国了矣。无复人民。王即开募。其有能令仙人失五通。属我为民者。当与分国半治。是婆罗奈国有淫女。名曰扇陀。端正无双。来应王募问诸人言。此是人非人。众人言。是人耳。仙人所生。淫女言。若是人者我能坏之。作是语已取金槃盛好宝物。语国王言。我当骑此仙人项来。淫女即时求五百乘车载五百美女。五百鹿车载种种欢喜丸。皆以众药和之。以众彩画之令似杂果及持种种大力美酒色味如水。服树皮衣草衣。行林树间以像仙人。于仙人庵边作草庵而住。一角仙人游行见之。诸女皆出迎逆。好华好香供养仙人。仙人大喜。诸女皆以美言敬辞问讯仙人。将入房中坐好床蓐。与好净酒以为净水。与欢喜丸以为果蓏。食饮饱已语诸女言。我从生已来初未得如此好果好水。诸女言。我以一心行善故天与我。愿得此好果好水。仙人问诸女。汝何以故肤色肥盛。答言。我曹食此好果。饮此美水故肥盛如此。女白仙人言。汝何以不在此间住。答曰。亦可住耳。女言。可共澡洗即亦可之。女手柔软触之心动。便复与诸美女更互相洗。欲心转生遂成淫事。即失神通天为大雨七日七夜。令得欢喜饮食。七日已后酒果皆尽。继以山水木果。其味不美更索前者。答言。已尽今当共行。去此不远有可得处。仙人言。随意。即便共出。媱女知去城不远。女便在道中卧言。我极不能复行。仙人言。汝不能行者。骑我项上当项汝去。女先遣信白王。王可观我智能。王敕严驾出而观之。问言。何由得尔。女白王言。我以方便力故今已如此。无所复能。令住城中好供养恭敬之。足五所欲。拜为大臣住城少日。身转羸瘦。念禅定心乐厌此世欲。王问仙人。汝何不乐身转羸瘦。仙人答王。我虽得五欲。常自忆念林间闲静诸仙游处不能去心。王自思惟。若我强违其志。违志为苦苦极则死。本以求除旱患。今已得之。当复何缘强夺其志。即发遣之。既还山中精进不久还得五通。佛告诸比丘。一角仙人我身是也。淫女者耶输陀罗是。尔时以欢喜丸惑我。我未断结为之所惑。今复欲以药欢喜丸惑我不可得也。以是事故知。细软触法能动仙人。何况愚夫。如是种种因缘。是名呵细滑欲。如是呵五欲除五盖者。复次贪欲之人去道甚远。所以者何。欲为种种恼乱住处。若心着贪欲无由近道。如除欲盖偈所说

  入道惭愧人　　持钵福众生
  云何纵尘欲　　沉没于五情
  着铠持刀杖　　见敌而退走
  如是怯弱人　　举世所轻笑
  比丘为乞士　　除发着袈裟
  五情马所制　　取笑亦如是
  又如豪贵人　　盛服以严身
  而行乞衣食　　取笑于众人
  比丘除饰好　　毁形以摄心
  而更求欲乐　　取笑亦如是
  已舍五欲乐　　弃之而不顾
  如何还欲得　　如愚自食吐
  如是贪欲人　　不知观本愿
  亦不识好丑　　狂醉于渴爱
  惭愧尊重法　　一切皆已弃
  贤智所不亲　　愚騃所爱近
  诸欲求时苦　　得之多怖畏
  失时怀热恼　　一切无乐时
  诸欲患如是　　以何当舍之
  得诸禅定乐　　则不为所欺
  欲乐着无厌　　以何能灭除
  若得不净观　　此心自然无
  着欲不自觉　　以何悟其心
  当观老病死　　尔乃出四渊
  诸欲难放舍　　何以能远之
  若能乐善法　　此欲自然息
  诸欲难可解　　何以能释之
  观身得实相　　则不为所缚
  如是诸观法　　能灭诸欲火
  譬如大澍雨　　野火无在者

如是等种种因缘。灭除欲盖。嗔恚盖者。失诸善法之本。堕诸恶道之因。诸乐之怨家。善心之大贼。种种恶口之府藏。如佛教嗔弟子偈言

  汝当知思惟　　受身及处胎
  秽恶之幽苦　　既生之艰难
  既思得此意　　而复不灭嗔
  则当知此辈　　则是无心人
  若无罪报果　　亦无诸呵责
  犹当应慈忍　　何况苦果剧
  当观老病死　　一切无免者
  当起慈悲心　　云何恶加物
  众生相怨贼　　斫刺受苦毒
  云何修善人　　而复加恼害
  常当行慈悲　　定心修诸善
  不当怀恶意　　侵害于一切
  若勤修道法　　恼害则不行
  善恶势不并　　如水火相背
  嗔恚来覆心　　不知别好丑
  亦不识利害　　不知畏恶道
  不计他苦恼　　不觉身心疲
  先自受苦因　　然后及他人
  若欲灭嗔恚　　当思惟慈心
  独处自清闲　　息事灭因缘
  当畏老病死　　九种嗔恼除
  如是思惟慈　　则得灭嗔毒

如是等种种因缘。除嗔恚盖。睡眠盖者。能破今世三事欲乐利乐福德。能破今世后世究竟乐。与死无异。唯有气息。如一菩萨以偈呵眠睡弟子言

  汝起勿抱臭身卧　　种种不净假名人
  如得重病箭入体　　诸苦痛集安可眠
  一切世间死火烧　　汝当求出安可眠
  如人被缚将去杀　　灾害垂至安可眠
  结贼不灭害未除　　如共毒蛇同室宿
  亦如临阵白刃间　　尔时安可而睡眠
  眠为大闇无所见　　日日侵诳夺人明
  以眠覆心无所识　　如是大失安可眠

如是等种种因缘。呵睡眠盖。掉悔盖者。掉之为法破出家心。如人摄心犹不能住。何况掉散。掉散之人如无钩醉象决鼻骆驼。不可禁制。如偈说

  汝已剃头着染衣　　执持瓦钵行乞食
  云何乐着戏掉法　　既无法利失世乐

悔法者。如犯大罪人常怀畏怖。悔箭入心坚不可拔。如偈说

  不应作而作　　应作而不作
  悔恼火所烧　　后世堕恶道
  若人罪能悔　　已悔则放舍
  如是心安乐　　不应常念着
  若有二种悔　　不作若已作
  以是悔着心　　是则愚人相
  不以心悔故　　不作而能作
  诸恶事已作　　不能令不作

如是等种种因缘。呵掉悔盖。疑盖者。以疑覆心故。于诸法中不得定心。定心无故。于佛法中空无所得。譬如人入宝山。若无手者无所能取。如说疑义偈言

  如人在岐道　　疑惑无所趣
  诸法实相中　　疑亦复如是
  疑故不勤求　　诸法之实相
  是疑从痴生　　恶中之弊恶
  善不善法中　　生死及涅槃
  定实真有法　　于中莫生疑
  汝若生疑心　　死王狱吏缚
  如师子搏鹿　　不能得解脱
  在世虽有疑　　当随妙善法
  譬如观岐道　　利好者应逐

如是等种种因缘故。应舍疑盖。弃是五盖。譬如负债得脱。重病得差。饥饿之地得至丰国。如从狱得出。如于恶贼中得自免济安隐无患。行者亦如是。除却五盖其心安隐清净快乐。譬如日月以五事覆曀。烟云尘雾罗睺。阿修罗手障则不能明照。人心亦如是。为五盖所覆自不能利。亦不能益人。若能呵五欲除五盖。行五法。欲精进念巧慧一心。行此五法得五支成就。初禅欲名欲。于欲界中出欲。得初禅精进。名离家持戒。初夜后夜专精不懈。节食摄心不令驰散念。名念初禅乐。知欲界不净狂惑可贱。初禅为尊重可贵。巧慧名观察筹量欲界乐。初禅乐轻重得失一心。名常系心缘中不令分散。复次专求初禅放舍欲乐。譬如患怨常欲灭除。则不为怨之所害也。如佛为着欲婆罗门说。我本观欲。欲为怖畏忧苦因缘。欲为少乐其苦甚多。欲为魔网缠绵难出。欲为烧热干竭诸乐。譬如树林四边火起。欲为如临火坑甚可怖畏。如逼毒蛇。如怨贼拔刀。如恶罗刹。如恶毒入口。如吞销铜。如三流狂象。如临大深坑。如师子断道。如摩竭鱼开口。诸欲亦如是甚可怖畏。若着诸欲令人恼苦。着欲之人亦如狱囚。如鹿在围。如鸟入网。如鱼吞钩。如豺搏狗。如乌在鸱群。如蛇值野猪。如鼠在猫中。如群盲人临坑。如蝇着热油。如[病-丙+寧]人在阵。如躄人遭火。如入沸碱河。如舐蜜涂刀。如四衢脔肉。如薄覆刀林。如华覆不净。如蜜涂毒瓮。如毒蛇箧。如梦虚诳。如假借当归。如幻诳小儿。如焰无实。如没大水。如船入摩竭鱼口。如雹害谷。如霹雳临人。诸欲亦如是。虚诳无实无牢无强。乐少苦多。欲为魔军破诸善功德。常为劫害众生故。出如是等种种诸喻。呵五欲除五盖行五法。得至初禅。问曰。八背舍八胜处十一切入四无量心诸定三昧。如是等种种定。不名波罗蜜。何以但言禅波罗蜜。答曰。此诸定功德。都是思惟修。禅秦言思惟修。言禅波罗蜜一切皆摄。复次禅最大如王。说禅则摄一切。说余定则不摄。何以故。是四禅中智定等而乐。未到地中间地智多而定少。无色界定多而智少。是处非乐。譬如车一轮强一轮弱则不安隐。智定不等亦如是。复次是四禅处有四等心。五神通背舍胜处。一切处无诤三昧。愿智顶禅自在定练禅。十四变化心般舟般。诸菩萨三昧首楞严等。略说则百二十。诸佛三昧不动等。略说则百八。及佛得道舍寿。如是等种种功德妙定皆在禅中。以是故禅名波罗蜜。余定不名波罗蜜。问曰。汝先言呵五欲除五盖。行五法得初禅。修何事依何道能得初禅。答曰。依不净观安那般那念等诸定门。如禅经禅义偈中说

  离欲及恶法　　有觉并有观
  离生得喜乐　　是人入初禅
  已得离淫火　　则获清凉定
  如人大热闷　　入冷池则乐
  如贫得宝藏　　大喜觉动心
  分别则为观　　入初禅亦然
  知二法乱心　　虽善而应离
  如大水澄静　　波荡亦无见
  譬如人大极　　安隐睡卧时
  若有唤呼声　　其心大恼乱
  摄心入禅时　　以觉观为恼
  是故除觉观　　得入一识处
  内心清净故　　定生得喜乐
  得入此二禅　　喜勇心大悦
  摄心第一定　　寂然无所念
  患喜欲弃之　　亦如舍觉观
  由受故有喜　　失喜则生忧
  离喜乐身受　　舍念及方便
  圣人得能舍　　余人舍为难
  若能知乐患　　见不动大安
  忧喜先已除　　苦乐今亦断
  舍念清净心　　入第四禅中
  第三禅中乐　　无常动故苦
  欲界中断忧　　初二禅除喜
  是故佛世尊　　第四禅中说
  先已断忧喜　　今则除苦乐

复次持戒清净闲居独处。守摄诸根初夜后夜专精思惟。弃舍外乐以禅自娱。离诸欲不善法。依未到地得初禅。初禅如阿毗昙说。禅有四种。一味相应。二净三无漏。四初禅所摄报得五众。是中行者入净无漏。二禅三禅四禅亦如是。如佛所说。若有比丘离诸欲及恶不善法。有觉有观。离生喜乐入初禅。诸欲者。所爱着色等五欲。思惟分别呵欲如先说。恶不善法者。贪欲等五盖。离此内外二事故得初禅。初禅相有觉有观喜乐一心。有觉有观者。得初禅中未曾所得善法功德故。心大惊悟常为欲火所烧。得初禅时如入清凉池。又如贫人卒得宝藏。行者思惟分别欲界过罪。知初禅利益功德甚多。心大欢喜。是名有觉有观。问曰。有觉有观为一法是二法耶。答曰。二法。粗心初念是名为觉。细心分别是名为观。譬如撞钟初声大时名为觉。后声微细名为观。问曰。如阿毗昙说。欲界乃至初禅。一心中觉观相应。今云何言粗心初念名为觉细心分别名为观。答曰。二法虽在一心二相不俱。觉时观不明了。观时觉不明了。譬如日出众星不现。一切心心数法随时受名。亦复如是。如佛说若断一法我证汝得阿那含。一法者。所谓悭贪。实应说五下分结尽得阿那含。云何言但断一法。以是人悭贪偏多。诸余结使皆从而生。是故悭尽余结亦断。觉观随时受名。亦复如是。行者知是觉观虽是善法而娆乱定心。心欲离故呵是觉观作是念。觉观娆动禅心。譬如清水波荡则无所见。又如疲极之人得息欲睡。傍人唤呼种种恼乱。摄心内定觉观娆动。亦复如是。如是等种种因缘呵觉观。觉观灭内清净系心一处。无觉无观定生喜乐入二禅。既得二禅。得二禅中未曾所得无比喜乐。觉观灭者。知觉观过罪故灭。内清净者。入深禅定。信舍初禅觉观所得利重所失甚少所获大多。系心一缘故。名内清净。行者观喜之过亦如觉观。随所喜处多喜多忧。所以者何。如贫人得宝欢喜无量。一旦失之其忧亦深。喜即转而成忧。是故当舍离此喜。故行舍念智受身乐。是乐圣人能得能舍。一心在乐入第三禅。舍者舍喜心不复悔。念智者既得三禅中乐。不令于乐生患。受身乐者。是三禅乐遍身皆受。圣人能得能舍者。此乐世间第一能生心着。凡夫少能舍者。以是故佛说。行慈果报遍净地中第一。行者观乐之失。亦如观喜。知心不动处最为第一。若有动处是则有苦。行者以第三禅乐动故求不动处。以断苦乐先灭忧喜。故不苦不乐舍念清净入第四禅。是四禅中无苦无乐。但有不动智慧。以是故说第四禅舍念清净。第三禅乐动故说苦。是故第四禅中说断苦乐。如佛说。过一切色相不念别相。灭有对相得入无边虚空处。行者作是念。若无色则无饥渴寒热之苦。是身色粗重弊恶虚诳非实。先世因缘和合报得此身。种种苦恼之所住处。云何当得免此身患。当观此身中虚空。常观身空如笼如甑。常念不舍则得度色不复见身。如内身空外色亦尔。是时能观无量无边空。得此观已无苦无乐其心转增。如鸟闭着瓶中瓶破得出。是名空处定。是空无量无边。以识缘之缘多则散能破于定。行者观虚空。缘受想行识。如病如痈如疮如刺。无常苦空无我。欺诳和合则有非是实也。如是念已。舍虚空缘但缘识。云何而缘现前识。缘过去未来无量无边识。是识无量无边。如虚空无量无边。是名识处定。是识无量无边。以识缘之识多则散能破于定。行者观是缘识。受想行识如病如痈如疮如刺。无常苦空无我。欺诳和合而有非实有也。如是观已则破识相。是呵识处赞无所有处。破诸识相系心在无所有中。是名无所有处定。无所有处缘受想行识。如病如痈如疮如刺。无常苦空无我。欺诳和合而有非实有也。如是思惟。无想处如痈。有想处如病如痈如疮如刺。第一妙处是非有想非无想处。问曰。非有想非无想处。有受想行识。云何言非有想非无想。答曰。是中有想微细难觉故。谓为非有想。有想故非无想。凡夫心谓得诸法实相。是为涅槃。佛法中虽知有想。因其本名。名为非有想非无想处。问曰。云何是无想。答曰。无想有三种。一无想定。二灭受定。三无想天。凡夫人欲灭心入无想定。佛弟子欲灭心入灭受定。是诸禅定有二种。若有漏若无漏。有漏即是凡夫所行如上说。无漏是十六圣行。若有漏道。依上地边离下地欲。若无漏道。离自地欲及上地。以是故凡夫于有顶处不得离欲。更无上地边故。若佛弟子欲离欲界欲欲界烦恼。思惟断九种上中下。上上．上中．上下．中上．中中．中下．下上．下中．下下。断此九种故。佛弟子若依有漏道欲得初禅。是时于未到地。九无碍道八解脱道中。现在修有漏道。未来修有漏无漏道。第九解脱道中。于未到地现在修有漏道。未来修未到地有漏无漏道及初禅边地有漏。若无漏道欲得初禅亦如是。若依有漏道离初禅欲。于第二禅边地。九无碍道八解脱道中。现在修二禅边地有漏。未来修二禅边地有漏道。亦修无漏初禅及眷属。第九解脱道中。于第二禅边地。现在修二禅边地有漏道。未来修二禅边地初禅无漏及眷属二禅净无漏。若无漏道离初禅欲。九无碍道八解脱道中。现在修自地无漏道。未来修初禅及眷属有漏无漏道。第九解脱道中。现在修自地无漏道。未来修初禅及眷属有漏无漏道。及修二禅净无漏乃至无所有处离欲时亦如是。非有想非无想处离欲时。九无碍道八解脱道中。但修一切无漏道。第九解脱道中。修三界善根及无漏道。除无心定。修有二种。一得修二行修。得修名本所不得而今得。未来世修自事亦修余事。行修名曾得于现前修。未来亦尔不修余。如是等种种诸禅定中修。复次禅定相略说有二十三种。八味八净七无漏。复有六因。相应因．共因．相似因．遍因．报因．名因。一一无漏。七无漏因是相似因。自地中增相应因共有因初味定初味定因乃至后味定后味定因。净亦如是。四缘因缘．次第缘．缘缘．增上缘。因缘者如上说。初禅无漏定次第生六种定。一初禅净二无漏。二禅三禅亦如是。二禅无漏定次第生八种定。自地净无漏初禅净无漏。三禅四禅亦如是。三禅无漏定次第生十种。自地二下地四上地四。第四禅空处亦如是。识处无漏定次第生九种。自地二下地四上地三。无所有处无漏定次第生七种。自地二下地四上地一。非有想非无想处净次第生六心。自地二下地四。诸净地亦如是。又皆益自地味。初禅味次第二种味净。乃至非想非非想处味亦如是。净无漏禅一切处缘味禅。缘自地中味。亦缘净爱。无无漏缘故不缘无漏。净无漏根本无色定。不缘下地有漏。名因增上缘。通一切四无量心三背舍八胜处。八一切处皆缘欲界五神通。缘欲色界。余各随所缘。灭受想定无所缘。一切四禅中有练法。以无漏练有漏故。得四禅心自在。能以无漏第四禅。练有漏第四禅。然后第三第二第一禅。皆以自地无漏练自地有漏。问曰。何以名练禅。答曰。诸圣人乐无漏定不乐有漏。离欲时净有漏不乐。而自得今欲除其滓秽故。以无漏练之。譬如炼金去其秽无漏练有漏亦复如是。从无漏禅起入净禅。如是数数。是名为炼。复次诸禅中有顶禅。何以故名顶有二种。阿罗汉坏法不坏法。不坏法阿罗汉。于一切深禅定得自在。能起顶禅。得是顶禅能转寿为富转富为寿。复有愿智四辩无诤三昧。愿智者。愿欲知三世事。随所愿则知。此愿智二处摄。欲界第四禅四辩者。法辩辞辩二处摄。欲界初禅。余二辩九地摄。欲界四禅四无色定。无诤三昧者。令他心不起诤。五处摄。欲界及四禅。问曰。得诸禅更有余法耶。答曰。味定生亦得退亦得。净禅生时得。离欲时得无漏。离欲时得。退时得九地无漏定。四禅三无色定未到地禅中间能断结使。未到地禅中间舍根相应。若人成就禅下地变化心亦成就。如初禅成就。有二种变化心。一者初禅。二者欲界。二禅三种三禅四种四禅五种。若二禅三禅四禅中。欲闻见触时皆用梵世识。识灭时则止。四无量意五神通八背舍八胜处十一切入九次第定九相十想三三昧三解脱门三无漏根三十七品。如是等诸功德。皆禅波罗蜜中生。是中应广说。问曰。应说禅波罗蜜。何以但说禅。答曰。禅是波罗蜜之本。得是禅已怜愍众生。内心中有种种禅定妙乐而不知求。乃在外法不净苦中求乐。如是观已生大悲心立弘誓愿。我当令众生皆得禅定内乐离不净乐。依此禅乐已。次令得佛道乐。是时禅定得名波罗蜜。复次于此禅中。不受味不求报不随报生。为调心故入禅。以智慧方便还生欲界。度脱一切众生。是时禅名为波罗蜜。复次菩萨入深禅定。一切天人不能知其心。所依所缘见闻觉知法中心不动。如毗摩罗鞊经中。为舍利弗说宴坐法。不依身不依心不依三界。于三界中不得身心。是为宴坐。复次若人闻禅定乐胜于人天乐。便舍欲乐求禅定。是为自求乐利不足奇也。菩萨则不然。但为众生欲令慈悲心净。不舍众生菩萨禅。禅中皆发大悲心。禅有极妙内乐。而众生舍之而求外乐。譬如大富盲人。多有伏藏不知不见而行乞求。智者愍其自有妙物不能知见而从他乞。众生亦如是。心中自有种种禅定乐。而不知发反求外乐。复次菩萨知诸法实相故。入禅中心安隐不着味。诸余外道虽入禅定心不安隐。不知诸法实故着禅味。问曰。阿罗汉辟支佛俱不着味。何以不得禅波罗蜜。答曰。阿罗汉辟支佛虽不着味。无大悲心故不名禅波罗蜜。又复不能尽行诸禅。菩萨尽行诸禅。粗细大小深浅内缘外缘一切尽行。以是故菩萨心中名禅波罗蜜。余人但名禅。复次外道声闻菩萨皆得禅定。而外道禅中有三种患。或味着或邪见或憍慢。声闻禅中慈悲薄。于诸法中不以利智贯达诸法实相。独善其身断诸佛种。菩萨禅中无此事。欲集一切诸佛法故。于诸禅中不忘众生。乃至昆虫常加慈念。如释迦文尼佛。本为螺髻仙人。名尚阇利。常行第四禅。出入息断在一树下坐兀然不动。鸟见如此谓之为木。即于髻中生卵。是菩萨从禅觉知头上有鸟卵。即自思惟。若我起动鸟母必不复来。鸟母不来鸟卵必坏。即还入禅。至鸟子飞去尔乃起。复次除菩萨。余人欲界心不得次第入禅。菩萨行禅波罗蜜。于欲界心次第入禅。何以故。菩萨世世修诸功德。结使心薄心柔软故。复次余人得总相智慧。能离欲如无常观苦观不净观。菩萨于一切法中能别相分别离欲。如五百仙人飞行时。闻甄陀罗女歌声。心着狂醉皆失神足一时堕地。如声闻闻紧陀罗王屯仑摩弹琴歌声以诸法实相赞佛。是时须弥山及诸树木皆动。大迦叶等诸大弟子皆于座上不能自安。天须菩萨问大迦叶。汝最耆年行头陀第一。今何故不能制心自安。大迦叶答曰。我于人天诸欲心不倾动。是菩萨无量功德报声。又复以智慧变化作声。所不能忍。若八方风起。不能令须弥山动。劫尽时毗蓝风至。吹须弥山令如腐草。以是故知。菩萨于一切法中。别相观得离诸欲。诸余人等但得禅之名字。不得波罗蜜。复次余人知菩萨入出禅心。不能知住禅心所缘所到知诸法深浅。阿罗汉辟支佛尚不能知。何况余人。譬如象王渡水。入时出时足迹可见。在水中时不可得知。若得初禅同得初禅人能知。而不能知菩萨入初禅。有人得二禅。观知得初禅心了了知。不能知菩萨入初禅心。乃至非有想非无想处亦如是。复次超越三昧中。从初禅起入第三禅。第三禅中起入虚空处。虚空处起入无所有处。二乘唯能超一不能超二。菩萨自在超。从初禅起或入三禅如常法。或时入第四禅。或入空处识处无所有处或非有想非无想处。或入灭受想定。灭受想定起或入无所有处或识处空处四禅乃至初禅。或时超一或时超二。乃至超九。声闻不能超二。何以故。智慧功德禅定力薄故。譬如二种师子。一黄师子。二白发师子。黄师子虽亦能超。不如白发师子王。如是等种种因缘分别禅波罗蜜。复次尔时菩萨常入禅定。摄心不动不生觉观。亦能为十方一切众生以无量音声说法而度脱之。是名禅波罗蜜。问曰。如经中说。先有觉观思惟然后能说法。入禅定中无语觉观。不应得说法。汝今云何言常在禅定中不生觉观而为众生说法。答曰。生死人法入禅定。先以语觉观然后说法。法身菩萨离生死身。知一切诸法。常住如禅定相。不见有乱。法身菩萨变化无量身。为众生说法。而菩萨心无所分别。如何修罗琴。常自出声随意而作无人弹者。此亦无散心亦无摄心。是福德报生故。随人意出声。法身菩萨亦如是。无所分别亦无散心。亦无说法相。是无量福德禅定智慧因缘故。是法身菩萨。种种法音随应而出。悭贪心多闻说布施之声。破戒嗔恚懈怠乱心愚痴之人。各各闻说持戒忍辱禅定智慧之声。闻是法已各各思惟。渐以三乘而得度脱。复次菩萨观一切法。若乱若定皆是不二相。余人除乱求定。何以故。以乱法中起嗔想。于定法中生着想。如郁陀罗伽仙人。得五通日日飞到国王宫中食。王大夫人如其国法捉足而礼。夫人手触即失神通。从王求车乘驾而出。还其本处入林树间。更求五通一心专至。垂当得时有鸟在树上。急鸣以乱其意。舍树至水边求定。复闻鱼斗动水之声。此人求禅不得。即生嗔恚。我当尽杀鱼鸟。此人久后思惟得定。生非有想非无想处。于彼寿尽下生作飞狸。杀诸鱼鸟作无量罪堕三恶道。是为禅定中着心因缘。外道如此。佛弟子中亦有一比丘。得四禅生增上慢谓得四道。得初禅时谓是须陀洹。第二禅时谓是斯陀含。第三禅时谓是阿那含。第四禅时谓得阿罗汉。恃是而止不复求进。命欲尽时见有四禅中阴相来。便生邪见。谓无涅槃佛为欺我。恶邪生故失四禅中阴。便见阿鼻泥犁中阴相。命终即生阿鼻地狱。诸比丘问佛。某甲比丘阿兰若命终生何处。佛言。是人生阿鼻泥犁中。诸比丘皆大惊怪。此人坐禅持戒所由尔耶。佛言。此人增上慢。得四禅时谓得四道故。临命终时见四禅中阴相。便生邪见谓无涅槃。我是阿罗汉今还复生。佛为虚诳。是时即见阿鼻泥犁中阴相。命终即生阿鼻地狱中。是时佛说偈言

  多闻持戒禅　　未得无漏法
  虽有此功德　　此事不可信

是比丘受是恶道苦。是故知。取乱相能生嗔等烦恼。取定相能生着。菩萨不取乱相。亦不取禅定相。乱定相一故是名禅波罗蜜。如初禅相。离欲除盖摄心一处。是菩萨利根智慧观故。于五盖无所舍。于禅定相无所取。诸法相空故。云何于五盖无所舍。贪欲盖非内非外亦不两中间。何以故。若内法有不应待外生。若外法有于我亦无患。若两中间有两间则无处。亦不从先世来。何以故。一切法无来故。如童子无有欲。若先世有者小亦应有。以是故知先世不来。亦不至后世。不从诸方来。亦不常自有。不一分中。非遍身中。二亦不从五尘来。亦不从五情出。无所从生无所从灭。是贪欲若先生若后生若一时生。是事不然。何以故。若先有生后有贪欲。是中不应贪欲生。未有贪欲故。若后有生先有贪欲。则生无所生。若一时生则无生者无生处。生者生处无分别故。复次是贪欲贪欲者不一不异。何以故。离贪欲贪欲者不可得。离贪欲者贪欲不可得。是但从和合因缘生。和合因缘生法即是自性空。如是贪欲贪欲者异不可得。若一贪欲贪欲者则无分别。如是等种种因缘贪欲生不可得。若法无生是法亦无灭。不生不灭故则无定无乱。如是观贪欲盖。则与禅为一。余盖亦如是。若得诸法实相观五盖则无所有。是时便知五盖实相即是禅实相。禅实相即是五盖。菩萨如是能知五欲及五盖禅定及支一相无所依入禅定。是为禅波罗蜜。复次若菩萨行禅波罗蜜时。五波罗蜜和合助成。是名禅波罗蜜。复次菩萨以禅波罗蜜力得神通。一念之顷不起于定。能供养十方诸佛。华香珍宝种种供养。复次菩萨以禅波罗蜜力变身无数。遍入五道以三乘法教化众生。复次菩萨入禅波罗蜜中。除诸恶不善法。入初禅乃至非有想非无想定。其心调柔一一禅中行大慈大悲。以慈悲因缘。拔无量劫中罪。得诸法实相智故。为十方诸佛及大菩萨所念。复次菩萨入禅波罗蜜中。以天眼观十方五道中众生。见生色界中者受禅定乐味。还堕禽兽中受种种苦。复见欲界诸天七宝池中华香自娱。后堕碱沸屎地狱中。见人中多闻世智辩聪。不得道故。还堕猪羊畜兽中无所别知。如是等种种。失大乐得大苦。失大利得大衰。失尊贵得卑贱。于此众生生悲心。渐渐增广得成大悲不惜身命。为众生故勤行精进以求佛道。复次不乱不味故。名禅波罗蜜。如佛告舍利弗。菩萨般若波罗蜜中住。具足禅波罗蜜。不乱不味故。问曰。云何名乱。乱有二种。一者微二者粗微者有三种。一爱多二慢多三见多。云何爱多。得禅定乐其心乐着爱味。云何慢多。得禅定时自谓难事已得而以自高。云何见多。以我见等入禅定。分别取相。是实余妄语。是三名为微细乱。从是因缘于禅定退起三毒。是为粗乱。味者初得禅定一心爱着是为味。问曰。一切烦恼皆能染着。何以故但名爱为味。答曰。爱与禅相似。何以故。禅则摄心坚住爱亦专著难舍。又初求禅时。心专欲得。爱之为性欲乐专求。欲与禅定不相违故。既得禅定深着不舍则坏禅定。譬如施人物。必望现报则无福德。于禅受味爱着于禅。亦复如是。是故但以爱名味。不以余结为味

大智度论卷第十七大智度论释初品中般若波罗蜜第二十九(卷第十八)

        龙树菩萨造

        后秦龟兹国三藏鸠摩罗什奉　诏译

【经】于一切法不着故。应具足般若波罗蜜

【论】问曰。云何名般若波罗蜜。答曰。诸菩萨从初发心。求一切种智。于其中间知诸法实相慧是般若波罗蜜。问曰。若尔者不应名为波罗蜜。何以故。未到智慧边故。答曰。佛所得智慧是实波罗蜜。因是波罗蜜故。菩萨所行亦名波罗蜜。因中说果故。是般若波罗蜜在佛心中变名为一切种智。菩萨行智慧求度彼岸故。名波罗蜜。佛已度彼岸故。名一切种智。问曰。佛一切诸烦恼及习已断智慧眼净。应如实得诸法实相。诸法实相即是般若波罗蜜。菩萨未尽诸漏慧眼未净。云何能得诸法实相。答曰。此义后品中当广说。今但略说。如人入海。有始入者。有尽其源底者。深浅虽异俱名为入。佛菩萨亦如是。佛则穷尽其底。菩萨未断诸烦恼习。势力少故不能深入如后品中说。譬喻如人于闇室然灯。照诸器物皆悉分了。更有大灯益复明审。则知后灯所破之闇。与前灯合住。前灯虽与闇共住而亦能照物。若前灯无闇则后灯无所增益。诸佛菩萨智慧亦如是。菩萨智慧虽与烦恼习合而能得诸法实相。亦如前灯亦能照物。佛智慧尽诸烦恼习。亦得诸法实相。如后灯倍复明了。问曰。云何是诸法实相。答曰。众人各各说诸法实相自以为实。此中实相者。不可破坏。常住不异无能作者。如后品中。佛语须菩提。若菩萨观一切法。非常非无常。非苦非乐。非我非无我。非有非无等。亦不作是观。是名菩萨行般若波罗蜜。是义舍一切观。灭一切言语离诸心行。从本已来不生不灭如涅槃相。一切诸法相亦如是。是名诸法实相。如赞般若波罗蜜偈说

  般若波罗蜜　　实法不颠倒
  念想观已除　　言语法亦灭
  无量众罪除　　清净心常一
  如是尊妙人　　则能见般若
  如虚空无染　　无戏无文字
  若能如是观　　是即为见佛
  若如法观佛　　般若及涅槃
  是三则一相　　其实无有异
  诸佛及菩萨　　能利益一切
  般若为之母　　能出生养育
  佛为众生父　　般若能生佛
  是则为一切　　众生之祖母
  般若是一法　　佛说种种名
  随诸众生力　　为之立异字
  若人得般若　　议论心皆灭
  譬如日出时　　朝露一时失
  般若之威德　　能动二种人
  无智者恐怖　　有智者欢喜
  若人得般若　　则为般若主
  般若中不着　　何况于余法
  般若无所来　　亦复无所去
  智者一切处　　求之不能得
  若不见般若　　是则为被缚
  若人见般若　　是亦名被缚
  若人见般若　　是则得解脱
  若不见般若　　是亦得解脱
  是事为希有　　甚深有大名
  譬如幻化物　　见而不可见
  诸佛及菩萨　　声闻辟支佛
  解脱涅槃道　　皆从般若得
  言说为世俗　　怜愍一切故
  假名说诸法　　虽说而不说
  般若波罗蜜　　譬如大火焰
  四边不可取　　无取亦不取
  一切取已舍　　是名不可取
  不可取而取　　是即名为取
  般若无坏相　　过一切言语
  适无所依止　　谁能赞其德
  般若虽叵赞　　我今能得赞
  虽未脱死地　　则为已得出

    大智度论释般若相义第三十

问曰。何以独称般若波罗蜜为摩诃。而不称五波罗蜜。答曰。摩诃秦言大。般若言慧。波罗蜜言到彼岸。以其能到智慧大海彼岸。到诸一切智慧边穷尽其极故。名到彼岸。一切世间中十方三世诸佛第一大。次有菩萨辟支佛声闻。是四大人皆从般若波罗蜜中生。是故名为大。复次能与众生大果报。无量无尽常不变异。所谓涅槃。余五波罗蜜不能尔。布施等离般若波罗蜜。但能与世间果报。是故不得名大。问曰。何者是智慧。答曰。般若波罗蜜摄一切智慧。所以者何。菩萨求佛道。应当学一切法得一切智慧。所谓声闻辟支佛佛智慧。是智慧有三种。学无学非学非无学。非学非无学。智者如干慧地不净安那般那欲界系四念处暖法顶法忍法世间第一法等。学智者苦法智忍慧乃至向阿罗汉第九无碍道中金刚三昧慧。无学智者阿罗汉第九解脱智。从是已后一切无学智。如尽智无生智等。是为无学智求辟支佛道智慧亦如是。问曰。若辟支佛道亦如是者。云何分别声闻辟支佛。答曰。道虽一种而用智有异。若诸佛不出佛法已灭。是人先世因缘故。独出智慧不从他闻。自以智慧得道。如一国王出在园中游戏。清朝见林树华果蔚茂甚可爱乐。王食已而卧。王诸夫人婇女。皆共取华毁折林树。王觉已见林毁坏而自觉悟。一切世间无常变坏皆亦如是。思惟是已无漏道心生断诸结使得辟支佛道。具六神通即飞到闲静林间。如是等因缘。先世福德愿行果报。今世见少因缘。成辟支佛道如是为异。复次辟支佛有二种。一名独觉。二名因缘觉。因缘觉如上说。独觉者。是人今世成道。自觉不从他闻。是名独觉辟支迦佛。独觉辟支迦佛有二种。一本是学人在人中生。是时无佛佛法灭。是须陀洹已满七生。不应第八生自得成道。是人不名佛。不名阿罗汉。名为小辟支迦佛。与阿罗汉无异。或有不如舍利弗等大阿罗汉者。大辟支佛亦于一百劫中。作功德增长智慧。得三十二相分。或有三十一相或三十二十九相乃至一相。于九种阿罗汉中。智慧利胜于诸深法中总相别相。能入久修习定。常乐独处。如是相名为大辟支迦佛。以是为异。求佛道者从初发心作愿。愿我作佛度脱众生。得一切佛法行六波罗蜜。破魔军众及诸烦恼。得一切智成佛道。乃至入无余涅槃。随本愿行。从是中间所有智慧总相别相一切尽知。是名佛道智慧。是三种智慧尽能知尽到其边。以是故言到智慧边。问曰。若如所说一切智慧。尽应入若世间若出世间。何以但言三乘智慧尽到其边不说余智。答曰。三乘是实智慧。余者皆是虚妄。菩萨虽知而不专行。如除摩梨山一切无出栴檀木。若余处或有好语。皆从佛法中得自非佛法。初闻似好久则不妙。譬如牛乳驴乳。其色虽同牛乳攒则成酥。驴乳攒则成尿。佛法语及外道语。不杀不盗慈愍众生摄心离欲观空虽同。然外道语初虽似妙。穷尽所归则为虚诳。一切外道皆着我见。若实有我应堕二种。若坏相若不坏相。若坏相应如牛皮。若不坏相应如虚空。此二处无杀罪无不杀福。若如虚空雨露不能润。风热不能干。是则堕常相。若常者苦不能恼乐不能悦。若不受苦乐。不应避祸就福。若如牛皮则为风雨所坏若坏则堕无常。若无常则无罪福。外道语若实如是。何有不杀为福杀生为罪。问曰。外道戒福所失如是。其禅定智慧复云何。答曰。外道以我心逐禅故。多爱见慢故。不舍一切法故。无有实智慧。问曰。汝言外道观空。观空则舍一切法。云何言不舍一切法故。无有实智慧。答曰。外道虽观空。而取空相。虽知诸法空。而不自知我空。爱着观空智慧故。问曰。外道有无想定。心心数法都灭。都灭故无有取相爱着智慧咎。答曰。无想定力强令心灭。非实智慧力。又于此中生涅槃想。不知是和合作法。以是故堕颠倒中。是中心虽暂灭。得因缘还生。譬如人无梦睡时心想不行悟则还有。问曰无想定其失如是。更有非有想非无想定。是中无一切妄想。亦不如强作无想定灭想。是中以智慧力故无想。答曰。是中有想细微故不觉若无想佛弟子。复何缘更求实智慧。佛法中是非有想非无想中识。依四众住。是四众属因缘故无常。无常故苦。无常苦故空。空故无我。空无我故可舍。汝等爱着智慧故不得涅槃。譬如尺蠖屈安后足然后进前足。所缘尽无复进处而还。外道依止初禅舍下地欲。乃至依非有想非无想处。舍无所有处。上无所复依。故不能舍非有想非无想处。以更无依处恐惧失我。畏堕无所得中故。复次外道经中。有听杀盗淫妄语饮酒言。为天祠咒杀无罪。为行道故。若遭急难欲自全身。而杀小人无罪。又有急难为行道故。除金余者得盗取以自全济。后当除此殃罪。除师妇国王夫人善知识妻童女。余者逼迫急难得邪淫。为师及父母为身为牛为媒故。听妄语。寒乡听饮石蜜酒。天祠中或听尝一渧二渧酒。佛法中则不然。于一切众生慈心等视。乃至蚁子亦不夺命。何况杀人。一针一缕不取。何况多物无主。淫女不以指触何况人之妇女。戏笑不得妄语。何况故作妄语。一切酒一切时常不得饮。何况寒乡天祠。汝等外道与佛法悬殊有若天地。汝等外道法。是生诸烦恼处。佛法则是灭诸烦恼处。是为大异。诸佛法无量有若大海。随众生意故种种说法。或说有或说无或说常或说无常或说苦或说乐或说我或说无我或说勤行三业摄诸善法或说一切诸法无作相。如是等种种异说。无智闻之谓为乖错。智者入三种法门。观一切佛语。皆是实法不相违背。何等是三门。一者昆勒门。二者阿毗昙门。三者空门。问曰。云何名昆勒。云何名阿毗昙。云何名空门。答曰。昆勒有三百二十万言。佛在世时大迦栴延之所造。佛灭度后人寿转减。忆识力少不能广诵。诸得道人撰为三十八万四千言。若人入昆勒门论议则无穷。其中有随相门对治门等种种诸门。随相门者。如佛说偈

  诸恶莫作　　诸善奉行　　自净其意
  是诸佛教

是中心数法尽应说。今但说自净其意。则知诸心数法已说。何以故。同相同缘故。如佛说四念处。是中不离四正勤四如意足五根五力。何以故。四念处中四种精进则是四正勤四种定是为四如意足。五种善法是为五根五力。佛虽不说余门但说四念处。当知已说余门。如佛于四谛中或说一谛或二或三。如马星比丘为舍利弗说偈

  诸法从缘生　　是法缘及尽
  我师大圣王　　是义如是说

此偈但说三谛。当知道谛已在中不相离故。譬如一人犯事举家受罪。如是等名为随相门。对治门者。如佛但说四颠倒。常颠倒乐颠倒我颠倒净颠倒。是中虽不说四念处。当知已有四念处义。譬如说药已知其病说病则知其药。若说四念处则知已说四倒。四倒则是邪相。若说四倒则已说诸结。所以者何。说其根本则知枝条皆得。如佛说一切世间有三毒。说三毒当知已说三分八正道。若说三毒当知已说一切诸烦恼毒。十五种爱是贪欲毒。十五种嗔是嗔恚毒。十五种无明是愚痴毒。诸邪见憍慢疑属无明。如是一切结使皆入三毒。以何灭之。三分八正道。若说三分八正道。当知已说一切三十七品。如是等种种相名为对治门。如是等诸法名为昆勒门。云何名阿毗昙门。或佛自说诸法义。或佛自说诸法名。诸弟子种种集述解其义。如佛说。若有比丘于诸有为法不能正忆念。欲得世间第一法无有是处。若不得世间第一法。欲入正位中无有是处。若不入正位。欲得须陀洹斯陀含阿那含阿罗汉无有是处。有比丘于诸有为法。正忆念得世间第一法斯有是处。若得世间第一法入正位。入正位得须陀洹斯陀含阿那含阿罗汉必有是处。如佛直说。世间第一法不说相义。何界系何因何缘何果报。从世间第一法。种种声闻所行法乃至无余涅槃。一一分别相义。如是等是名阿毗昙门。空门者生空法空。如频婆娑罗王迎经中。佛告大王。色生时但空生。色灭时但空灭。诸行生时但空生。灭时但空灭。是中无吾我。无人无神。无人从今世至后世。除因缘和合名字等众生。凡夫愚人逐名求实。如是等经中佛说生空。法空者。如佛说大空经中。十二因缘无明乃至老死。若有人言是老死。若言谁老死皆是邪见。生有取爱受触六入名色识行无明亦如是。若有人言身即是神。若言身异于神。是二虽异同为邪见。佛言。身即是神。如是邪见非我弟子。身异于神亦是邪见。非我弟子。是经中佛说法空。若说谁老死。当知是虚妄是名生空。若说是老死当知是虚妄是名法空。乃至无明亦如是。复次佛说梵网经中六十二见。若有人言。神常世间亦常。是为邪见。若言神无常世间无常是亦邪见。神及世间常亦无常。神及世间非常亦非非常。皆是邪见。以是故知诸法皆空是为实。问曰。若言神常应是邪见。何以故。神性无故。若言世间常亦应是邪见。何以故。世间实皆无常。颠倒故言有常。若言神无常亦应是邪见。何以故。神性无故。不应言无常。若言世间无常不应是邪见。何以故。一切有为法性实皆无常。答曰。若一切法实皆无常。佛云何说世间无常是名邪见。是故可知非实是无常。问曰。佛处处说观有为法无常苦空无我令人得道。云何言无常堕邪见。答曰。佛处处说无常。处处说不灭。如摩诃男释王来至佛所白佛言。是迦毗罗人众殷多。我或值奔车逸马狂象斗人时。便失念佛心。是时自念。我今若死当生何处。佛告摩诃男。汝勿怖勿畏。汝是时不生恶趣必至善处。譬如树常东向曲。若有斫者必当东倒。善人亦如是。若身坏死时。善心意识长夜以信戒闻施慧熏心故。必得利益上生天上。若一切法念念生灭无常。佛云何言诸功德熏心故必得上生。以是故知非无常性。问曰。若无常不实。佛何以说无常。答曰。佛随众生所应而说法。破常颠倒故说无常。以人不知不信后世故。说心去后世上生天上。罪福业因缘百千万劫不失。是对治悉檀。非第一义悉檀。诸法实相非常非无常。佛亦处处说诸法空。诸法空中亦无无常。以是故说世间无常是邪见。是故名为法空。复次毗耶离梵志名论力。诸梨昌等大雇其宝物令与佛论。取其雇已。即以其夜思撰五百难。明旦与诸梨昌至佛所。问佛言。一究竟道为众多究竟道。佛言。一究竟道无众多也。梵志言。佛说一道。诸外道师各各有究竟道。是为众多非一。佛言。是虽各有众多皆非实道。何以故。一切皆以邪见着故。不名究竟道。佛问梵志。鹿头梵志得道不。答言。一切得道中是为第一。是时长老鹿头梵志比丘在佛后扇佛。佛问梵志。汝识是比丘不。梵志识之惭愧低头。是时佛说义品偈

  各各谓究竟　　而各自爱着
  各自是非彼　　是皆非究竟
  是人入论众　　辩明义理时
  各各相是非　　胜负怀忧喜
  胜者堕憍坑　　负者堕忧狱
  是故有智者　　不随此二法
  论力汝当知　　我诸弟子法
  无虚亦无实　　汝欲何所求
  汝欲坏我论　　终已无此处
  一切智难胜　　适足自毁坏

如是等处处声闻经中说诸法空。摩诃衍空门者。一切诸法性常自空。不以智慧方便观故空。如佛为须菩提说色。色自空受想行识识自空。十二入十八界十二因缘三十七品十力四无所畏十八不共法大慈大悲萨婆若乃至阿耨多罗三藐三菩提皆自空。问曰。若一切诸法性常自空真空无所有者。云何不堕邪见。邪见名无罪无福无今世后世与此无异。答曰。无罪无福人。不言无今世。但言无后世。如草木之类自生自灭。或人生或人杀。止于现在更无后世生。而不知观身内外所有自相皆空以是为异。复次邪见人多行众恶断诸善事。观空人善法尚不欲作。何况作恶。问曰。邪见有二种。有破因破果。有破果不破因。如汝所说破果不破因。破果破因者。言无因无缘无罪无福则是破因。无今世后世罪福报是则破果。观空人言皆空。则罪福因果皆无。与此有何等异。答曰。邪见人于诸法断灭令空。摩诃衍人知诸法真空不破不坏。问曰。是邪见三种。一者破罪福报不破罪福。破因缘果报不破因缘。破后世不破今世。二者破罪福报亦破罪福。破因缘果报亦破因缘。破后世亦破今世。不破一切法。三者破一切法皆令无所有。观空人亦言真空无所有。与第三邪见有何等异。答曰。邪见破诸法令空。观空人知诸法真空不破不坏。复次邪见人言诸法皆空无所有。取诸法空相戏论。观空人知诸法空不取相不戏论。复次邪见人虽口说一切空。然于爱处生爱。嗔处生嗔。慢处生慢。痴处生痴。自诳其身。如佛弟子实知空心不动。一切结使生处不复生。譬如虚空烟火不能染大雨不能湿。如是观空。种种烦恼不复着其心。复次邪见人言无所有。不从爱因缘出。真空名从爱因缘生是为异。四无量心诸清净法。以所缘不实故。犹尚不与真空智慧等。何况此邪见。复次是见名为邪见。真空见名为正见。行邪见人今世为弊恶人。后世当入地狱。行真空智慧人今世致誉后世得作佛。譬如水火之异。亦如甘露毒药天食须陀以比臭粪。复次真空中有空空三昧。邪见空虽有空而无空空三昧。复次观真空人。先有无量布施持戒禅定。其心柔软。诸结使薄。然后得真空。邪见中无此事。但欲以忆想分别邪心取空。譬如田舍人。初不识盐。见贵人以盐着种种肉菜中而食。问言。何以故尔。语言此盐能令诸物味美故。此人便念此盐能令诸物美自味必多。便空抄盐满口食之碱苦伤口。而问言。汝何以言盐能作美。贵人言。痴人。此当筹量多少和之令美。云何纯食盐。无智人闻空解脱门不行诸功德。但欲得空。是为邪见断诸善根。如是等义名为空门。若人入此三门则知佛法义不相违背。能知是事即是般若波罗蜜力。于一切法无所挂碍。若不得般若波罗蜜法。入阿毗昙门则堕有中。若入空门则堕无中。若入昆勒门则堕有无中。复次菩萨摩诃萨。行般若波罗蜜。虽知诸法一相亦能知一切法种种相。虽知诸法种种相亦能知一切法一相。菩萨如是智慧名为般若波罗蜜。问曰。菩萨摩诃萨。云何知一切法种种相。云何知一切法一相。答曰。菩萨观诸法相。所谓有相。因是有诸法中有心生。如是等一切有。问曰。无法中云何有心生。答曰。若言无是事即是有法。复次菩萨观一切法一相。所谓无相。如牛中无羊相羊中无牛相。如是等诸法中各各无他相。如先言因有故有心生。是法异于有。异故应无。若有法是牛羊亦应是牛。何以故。有法不异故。若异则无。如是等一切皆无。复次菩萨观一切法一因。是一法诸法中一心生诸法各各有一相。合众一故名为二名为三。一为实。二三为虚。复次菩萨观诸法有所因故有。如人身无常。何以故。生灭相故。一切法皆如是有所因故有。复次一切诸法无所因故有。如人身无常生灭故。因生灭故知无常。此因复应有因。如是则无穷。若无穷则无因。若是因更无因是无常。因亦非因。如是等一切无因。复次菩萨观一切法有相。无有法无相者。如地坚重相水冷湿相火热照相风轻动相虚空容受相。分别觉知是为识相。有此有彼是为方相。有久有近是为时相。浊恶心恼众生是为罪相。净善心愍众生是为福相。着诸法是为缚相。不着诸法是为解脱相。现前知一切法无碍是为佛相。如是等一切各有相。复次菩萨观一切法皆无相。是诸相从因缘和合生。无自性故无。如地色香味触四法和合故名地。不但色故名地。亦不但香但味但触故名为地。何以故。若但色是地。余三则不应是地。地则无香味触。香味触亦如是。复次是四法云何为一法。一法云何为四法。以是故不得以四为地。亦不得离四为地。问曰。我不以四为地。但因四法故地法生。此地在四法中住。答曰。若从四法生地。地与四法异。如父母生子子则异父母。若尔者今眼见色鼻知香舌知味身知触。地若异此四法者。应更有异根异识知。若更无异根异识知则无有地。问曰。若上说地相有失。应如阿毗昙说地相。地名四大造色。但地种是坚相。地是可见色。答曰。若地但是色先已说失。又地为坚相。但眼见色如水中月镜中像草木影。则无坚相。坚则身根触知故。复次若眼见色是地坚相。是地种眼见色。亦是水火湿热相。是水火种。若尔者风风种亦应分别而不分别如说何等是风风种。何等风种风。若是一物不应作二种。答若是不异者。地及地种不应异。问曰。是四大各各不相离。地中有四种。水火风各有四种但地中地多故。以地为名。水火风亦尔。答曰。不然。何以故。若火中有四大应都是热。无不热火故。若三大在火中。不热则不名为火。若热则舍自性皆名为火。若谓细故不可知则与无无异。若有粗可得则知有细。若无粗亦无细。如是种种因缘地相不可得。若地相不可得。一切法相亦不可得。是故一切法皆一相。问曰。不应言无相。何以故。于诸法无相即是相。若无无相则不可破一切法相。何以故。无无相故。若有是无相则不应言一切法无相。答曰。以无相破诸法相。若有无相相则堕诸法相中。若不入诸法相中则不应难无相。皆破诸法相亦自灭相。譬如前火木然诸薪已亦复自然。是故圣人行无相。无相三昧破无相故。复次菩萨。观一切法不合不散无色无形无对无示无说一相。所谓无相。如是等诸法一相。云何观种种相。一切法摄入二法中。所谓名色色无色可见不可见有对无对有漏无漏有为无为等。二百二法门如千难品中说。复次有二法。忍辱柔和。又二法亲敬供养。二施财施法施。二力慧分别力修道力。二具足戒具足正见具足。二相质直相柔软相。二法定智。二法明解说。二法世间法第一义法。二法念巧慧。二谛世谛第一义谛。二解脱待时解脱不坏心解脱。二种涅槃有余涅槃无余涅槃。二究竟事究竟愿究竟。二见知见断见。二具足义具足语具足。二法少欲知足。二法易养易满。二法法随法行。二智尽智无生智。如是等分别无量二法门。复次知三道。见道修道无学道。三性断性离性灭性。三修戒修定修慧修。三菩提佛菩提辟支迦佛菩提声闻菩提。(更不复学智满足之名也)三乘佛乘辟支迦佛乘声闻乘。三归依佛法僧。三住梵住天住圣住。三增上自增上他增上法增上。诸佛三不护身业不护口业不护意业不护。三福处布施持戒善心。三器杖闻器杖离欲器杖慧器杖。三轮变化轮示他心轮教化轮。三解脱门空解脱门无相解脱门无作解脱门。如是等无量三法门。复知四法。四念处四正勤四如意足四圣谛四圣种四沙门果四知四信四道四摄法四依四通达善根四道四天人轮四坚法四无所畏四无量心。如是等无量四法门。复知五无学众五出性五解脱处五根五力五大施五智五阿那含五净居天处五治道五智三昧五圣分支三昧五如法语道。如是等无量五法门。复知六舍法六爱敬法六神通六种阿罗汉六地见谛道六随顺念六三昧六定六波罗蜜。如是等无量六法门。复知七觉意七财七依止七想定七妙法七知七善人去处七净七财福七非财福七助定法。如是等无量七法门。复知八圣道分八背舍八胜处八大人念八种精进八丈夫八阿罗汉力。如是等无量八法门。复知九次第定九名色等减(从名色至生死为九)九无漏智得尽智故除等智也。九无漏地六禅三无色九地思惟道

如是等无量九法门。复知十无学法十想十智十一切入十善大地佛十力。如是等无量十法门。复知十一助圣道法。复知十二因缘法。复知十三出法。十四变化心。十五心见谛道。十六安那般那行。十七圣行。十八不共法。十九离地思惟道中一百六十二道。能破烦恼贼。一百七十八沙门果。八十九有为果。八十九无为果。如是等种种无量异相法。生灭增减得失垢净悉能知之。菩萨摩诃萨知是诸法已。能令诸法入自性空而于诸法无所著。过声闻辟支佛地。入菩萨位中。入菩萨位中已。以大悲怜愍故。以方便力分别诸法种种名字。度众生令得三乘。譬如工巧之人。以药力故。能令银变为金金变为银。问曰。若诸法性真空。云何分别诸法种种名字。何以不但说真空性。答曰。菩萨摩诃萨。不说空是可得可着。若可得可着。不应说诸法种种异相。不可得空者无所挂碍。若有挂碍是为可得。非不可得空。若菩萨摩诃萨。知不可得空。还能分别诸法。怜愍度脱众生。是为般若波罗蜜力。取要言之诸法实相。是般若波罗蜜。问曰。一切世俗经书。及九十六种出家经中。皆说有诸法实相。又声闻法三藏中。亦有诸法实相。何以不名为般若波罗蜜。而此经中诸法实相。独名般若波罗蜜。答曰。世俗经书中。为安国全家身命寿乐故非实。外道出家堕邪见法中。心爱着故是亦非实。声闻法中虽有四谛。以无常苦空无我观诸法实相。以智慧不具足不利。不能为一切众生。不为得佛法故。虽有实智慧。不名般若波罗蜜。如说佛入出诸三昧。舍利弗等乃至不闻其名。何况能知。何以故。诸阿罗汉辟支佛初发心时。无大愿无大慈大悲。不求一切诸功德。不供养一切三世十方佛。不审谛求知诸法实相。但欲求脱老病死苦故。诸菩萨从初发心弘大誓愿有大慈悲。求一切诸功德。供养一切三世十方诸佛。有大利智求诸法实相。除种种诸观。所谓净观不净观常观无常观乐观苦观空观实观我观无我观。舍如是等妄见心力诸观。但观外缘中实相。非净非不净非常非非常非乐非苦非空非实非我非无我。如是等诸观不着不得世俗法故。非第一义周遍清净不破不坏。诸圣人行处。是名般若波罗蜜。问曰。已知般若体相是无相无得法。行者云何能得是法。答曰。佛以方便说法。行者如所说行则得。譬如绝崖崄道假梯能上。又如深水因船得渡。初发心菩萨。若从佛闻若从弟子闻若于经中闻。一切法毕竟空。无有决定性可取可着。第一实法灭诸戏论。涅槃相是最安隐。我欲度脱一切众生。云何独取涅槃。我今福德智慧神通力未具足故。不能引导众生。当具足是诸因缘。行布施等五波罗蜜。财施因缘故得大富。法施因缘故得大智慧。能以此二施引导贫穷众生令入三乘道。以持戒因缘故。生人天尊贵。自脱三恶道。亦令众生免三恶道。以忍辱因缘故。障嗔恚毒得身色端政威德第一。见者欢喜敬信心伏。况复说法。以精进因缘故。能破今世后世福德道法懈怠。得金刚身不动心。以是身心破凡夫憍慢。令得涅槃。以禅定因缘故。破散乱心离五欲罪。乐能为众生说离欲法。禅是般若波罗蜜依止处。依是禅般若波罗蜜自然而生。如经中说。比丘一心专定能观诸法实相。复次知欲界中多以悭贪罪业闭诸善门。行檀波罗蜜时。破是二事开诸善门。欲令常开故。行十善道。尸罗波罗蜜未得禅定智慧。未离欲故。破尸罗波罗蜜。以是故行忍辱。知上三事能开福门。又知是福德果报无常。天人中受乐还复堕苦。厌是无常福德故。求实相般若波罗蜜。是云何当得。必以一心乃当可得。如贯龙王宝珠。一心观察能不触龙。则得价直阎浮提。一心禅定除却五欲五盖。欲得心乐大用精进。是故次忍辱说精进波罗蜜。如经中说。行者端身直坐系念在前。专精求定正使肌骨枯朽终不懈退。是故精进修禅。若有财而施不足为难。畏堕恶道恐失好名。持戒忍辱亦不为难。以是故上三度中不说精进。今为般若波罗蜜实相从心求定。是事难故应须精进。如是行能得般若波罗蜜。问曰。要行五波罗蜜然后得般若波罗蜜。亦有行一二波罗蜜。得般若波罗蜜耶。答曰。诸波罗蜜有二种。一者一波罗蜜中相应随行。具诸波罗蜜。二者随时别行波罗蜜。多者受名。譬如四大共合虽不相离以多者为名。相应随行者。一波罗蜜中具五波罗蜜是不离五波罗蜜。得般若波罗蜜。随时得名者。或因一因一得般若波罗蜜。若人发阿耨多罗三藐三菩提心布施。是时求布施相。不一不异非常非无常非有非无等。如破布施中说。因布施实相解。一切法亦如是。是名因布施得般若波罗蜜。或有持戒不恼众生心无有悔。若取相生着则起诤竞。是人虽先不嗔众生。于法有憎爱心故而嗔众生。是故若欲不恼众生。当行诸法平等。若分别是罪是无罪则非行尸罗波罗蜜。何以故。憎罪爱不罪。心则自高还堕恼众生道中。是故菩萨。观罪者不罪者心无憎爱。如是观者。是为但行尸罗波罗蜜。得般若波罗蜜。菩萨作是念若不得法忍则不能常忍。一切众生未有逼迫能忍。苦来切已则不能忍。譬如囚畏杖楚而就死苦。以是因缘故。当生法忍。无有打者骂者亦无受者。但从先世颠倒果报因缘故。名为受。是时不分别是忍事忍。法者深入毕竟空故。是名法忍。得是法忍。常不复嗔恼众生。法忍相应慧。是般若波罗蜜。精进常在一切善法中。能成就一切善法。若智慧筹量分别诸法。通达法性。是时精进助成智慧。又知精进实相离身心如实不动。如是精进能生般若波罗蜜。余精进如幻如梦。虚诳非实是故不说。若深心摄念。能如实见诸法实相。诸法实相者。不可以见闻念知能得。何以故。六情六尘皆是虚诳因缘果报。是中所知所见皆亦虚诳。是虚诳知都不可信。所可信者。唯有诸佛于阿僧祇劫所得实相智慧。以是智慧依禅定一心观诸法实相。是名禅定中生般若波罗蜜。或有离五波罗蜜。但闻读诵思惟筹量。通达诸法实相。是方便智中。生般若波罗蜜。或从二或三四波罗蜜。生般若波罗蜜。如闻说一谛而成道果。或闻二三四谛而得道果。有人于苦谛多惑故。为说苦谛而得道。余三谛亦如是。或有都惑四谛故。为说四谛而得道。如佛语比丘。汝若能断贪欲。我保汝得阿那含道。若断贪欲当知恚痴亦断。六波罗蜜中亦如是。为破多悭贪故。说布施法。当知余恶亦破。为破杂恶故具为说六。是故或一一行。或合行普为一切人故。说六波罗蜜。非为一人。复次若菩萨不行一切法不得一切法故得般若波罗蜜。所以者何。诸行皆虚妄不实。或近有过或远有过。如不善法近有过罪。善法久后变异时。著者能生忧苦。是远有过罪。譬如美食恶食俱有杂毒。食恶食即时不悦。食美食即时甘悦。久后俱夺命故。二不应食。善恶诸行亦复如是。问曰。若尔者佛何以说三行梵行天行圣行。答曰。行无行故名为圣行。何以故。一切圣行中。不离三解脱门故。梵行天行中因取众生相故生。虽行时无过后皆有失。又即今求实皆是虚妄。若贤圣以无著心行此二行则无咎。若能如是行无行法皆无所得。颠倒虚妄烦恼毕竟不生。如虚空清净故。得诸法实相。以无所得为得。如无所得般若中说。色等法。非以空故空从本已来常自空。色等法。不以智慧不及故无所得。从本已来常自无所得。是故不应问行几波罗蜜得般若波罗蜜。诸佛怜愍众生随俗故。说行非第一义。问曰。若无所得无所行。行者何以求之。答曰。无所得有二种。一者世间欲。有所求不如意。是无所得。二者诸法实相中。受决定相。不可得故。名无所得。非无有福德智慧增益善根。如凡夫人分别世间法故有所得。诸善功德亦如是。随世间心故说有所得。诸佛心中则无所得。是略说般若波罗蜜义。后当广说

大智度论卷第十八大智度论释初品中三十七品义第三十一(卷第十九)

        龙树菩萨造

        后秦龟兹国三藏鸠摩罗什奉　诏译

【经】菩萨摩诃萨以不住法。住般若波罗蜜中。不生故应具足四念处四正勤四如意足五根五力七觉分八圣道分。【论】问曰。三十七品。是声闻辟支佛道。六波罗蜜是菩萨摩诃萨道。何以故于菩萨道中说声闻法。答曰。菩萨摩诃萨。应学一切善法一切道。如佛告须菩提。菩萨摩诃萨行般若波罗蜜。悉学一切善法一切道。所谓干慧地乃至佛地。是九地应学而不取证。佛地亦学亦证。复次何处说三十七品。但是声闻辟支佛法。非菩萨道。是般若波罗蜜摩诃衍品中。佛说四念处乃至八圣道分。是摩诃衍三藏中。亦不说三十七品独是小乘法。佛以大慈故。说三十七品涅槃道。随众生愿随众生因缘各得其道。欲求声闻人。得声闻道。种辟支佛善根人。得辟支佛道。求佛道者得佛道。随其本愿诸根利钝。有大悲无大悲。譬如龙王降雨普雨天下。雨无差别。大树大草根大故多受。小树小草根小故少受。问曰。三十七品虽无处说独是声闻辟支佛道非菩萨道。以义推之可知。菩萨久住生死往来五道。不疾取涅槃。是三十七品但说涅槃法。不说波罗蜜。亦不说大悲。以是故知非菩萨道。答曰。菩萨虽久住生死中。亦应知实道非实道是世间是涅槃。知是已立大愿。众生可愍。我当拔出着无为处。以是实法行诸波罗蜜能到佛道。菩萨虽学虽知是法。未具足六波罗蜜故不取证。如佛说。譬如仰射空中箭箭相柱不令落地。菩萨摩诃萨亦如是。以般若波罗蜜箭。射三解脱门空中。复以方便箭射般若箭。令不堕涅槃地。复次若如汝所说。菩萨久住生死中。应受种种身心苦恼。若不得实智。云何能忍是事。以是故菩萨摩诃萨求是道品实智时。以般若波罗蜜力故。能转世间为道果涅槃。何以故。三界世间。皆从和合生。和合生者无有自性。无自性故是则为空。空故不可取。不可取相是涅槃。以是故说菩萨摩诃萨。不住法住般若波罗蜜中。不生故应具足四念处。复次声闻辟支佛法中。不说世间即是涅槃。何以故。智慧不深入诸法故。菩萨法中说世间即是涅槃。智慧深入诸法故。如佛告须菩提。色即是空空即是色。受想行识即是空。空即是受想行识。空即是涅槃。涅槃即是空。中论中亦说

  涅槃不异世间　　世间不异涅槃
  涅槃际世间际　　一际无有异故

菩萨摩诃萨得是实相故。不厌世间不乐涅槃。三十七品是实智之地。问曰。四念处则能具足得道何以说三十七。若汝以略说故四念处。广说故三十七。此则不然。何以故。若广应无量。答曰。四念处虽具足能得道。亦应说四正勤等诸法。何以故众生心种种不同。结使亦种种。所乐所解法亦种种。佛法虽一实一相。为众生故。于十二部经八万四千法聚。作是分别说。若不尔初转法轮。说四谛则足。不须余法。以有众生厌苦着乐。为是众生故。说四谛身心等诸法皆是苦无有乐。是苦因缘由爱等诸烦恼。是苦所尽处名涅槃。方便至涅槃。是为道。有众生多念乱心颠倒故。着此身受心法中。作邪行。为是人故说四念处。如是等诸道法。各各为众生说。譬如药师不得以一药治众病。众病不同药亦不一。佛亦如是随众生心病种种。以众药治之。或说一法度众生。如佛告一比丘。非汝物莫取。比丘言。知已世尊。佛言。云何知。比丘言。诸法非我物不应取。或以二法度众生。定及慧。或以三法戒定慧。或以四法四念处。是故四念处虽可得道。余法行异分别多少异观亦异。以是故应说四正勤等诸余法。复次诸菩萨摩诃萨信力大故。为度一切众生故。是中佛为一时说三十七品。若说异法道门十想等。皆摄在三十七品中。是三十七品众药和合。足疗一切众生病。是故不用多说。如佛虽有无量力但说十力。于度众生事足。是三十七品。十法为根本。何等十。信戒思惟精进念定慧除喜舍。信者信根信力。戒者正语正业正命。精进者四正勤精进根精进力精进觉正精进。念者念根念力念觉正念。定者四如意足定根定力定觉正定。慧者四念处慧根慧力择法觉正见。是诸法念随顺智慧缘中止住。是时名念处。破邪法正道中行故。名正勤。摄心安隐于缘中故。名如意足。软智心得故名根利。智心得故名力。修道用故名觉。见道用故名道。问曰。应先说道。何以故行道然后得诸善法。譬如人先行道然后得所至处。今何以颠倒先说四念处。后说八正道。答曰。不颠倒也。三十七品是初欲入道时名字。如行者到师所听道法时。先用念持是法。是时名念处。持已从法中求果故。精进行。是时名正勤。多精进故心散乱。摄心调柔故名如意足。心调柔已生五根。诸法实相甚深难解。信根故能信是名信根。不惜身命一心求道。是名精进根。常念佛道不念余事是名念根。常摄心在道是名定根。观四谛实相是名慧根。是五根增长能遮烦恼。如大树力能遮水。是五根增长时能转入深法。是名为力。得力已分别道法有三分。择法觉精进觉喜觉。此三法行道时。若心没能令起除觉定觉舍觉。此三法若行道时。心动散能摄令定念觉在二处。能集善法能遮恶法。如守门人有利者令入。无益者除却。若心没时念三法起。若心散时念三法。摄无觉实觉。此七事能到故名为分。得是法安隐具足已。欲入涅槃无为城故行是诸法。是时名为道。问曰。何等是四念处。答曰。身念处受心法念处。是为四念处观四法四种。观身不净。观受是苦。观心无常。观法无我。是四法虽各有四种。身应多观不净受多观苦心多观无常法多观无我。何以故。凡夫人未入道时。是四法中邪行起四颠倒。诸不净法中净颠倒。苦中乐颠倒。无常中常颠倒。无我中我颠倒。破是四颠倒故。说是四念处。破净倒故说身念处。破乐倒故说受念处。破常倒故说心念处。破我倒故说法念处。以是故说四不少不多。问曰。云何得是四念处。答曰。行者依净戒住。一心行精进。观身五种不净相。何等五。一者生处不净。二者种子不净。三者自性不净。四者自相不净。五者究竟不净。云何名生处不净。头足腹脊胁肋。诸不净物和合名为女身。内有生藏熟藏屎尿不净。外有烦恼业因缘风。吹识种令入二藏中间。若八月若九月如在屎尿坑中。如说

  是身为臭秽　　不从花间生
  亦不从瞻卜　　又不出宝山

是名生处不净。种子不净者。父母以妄想邪忆念风吹淫欲火故。血髓膏流热变为精。宿业行因缘识种子。在赤白精中住。是名身种子。如说

  是身种不净　　非余妙宝物
  不由净白生　　但从尿道出

是名种子不净。自性不净者。从足至顶四边薄皮。其中所有不净充满。饰以衣服澡浴花香。食以上馔众味肴膳。经宿之间皆为不净。假令衣以天衣。食以天食。以身性故亦为不净。何况人衣食。如说

  地水火风质　　能变除不净
  倾海洗此身　　不能令香洁

是名自性不净。自相不净者。是身九孔常流不净。眼流眵泪耳出结聍鼻中涕流口出涎吐。厕道水道常出屎尿。及诸毛孔汗流不净。如说

  种种不净物　　充满于身内
  常流出不止　　如漏囊盛物

是名自相不净。究竟不净者。是身若投火则为灰。若虫食则为屎。在地则腐坏为土。在水则膖胀烂坏。或为水虫所食。一切死尸中人身最不净。不净法九相中当广说。如说

  审谛观此身　　终必归死处
  难御无反复　　背恩如小人

是名究竟不净。复次是身生时死时。所近身物所安身处皆为不净。如香美净水随百川流既入大海变成碱苦。身所食啖种种美味好色好香细滑上馔。入腹海中变成不净。是身如是从生至终。常有不净甚可患厌。行者思惟是身虽复不净。若少有常者。犹差而复无常。虽复不净无常。有少乐者。犹差而复大苦。是身是众苦生处。如水从地生风从空出火因木有。是身如是内外诸苦皆从身出。内苦名老病死等。外苦名刀杖寒热饥渴等。有此身故有是苦。问曰。身非但是苦性。亦从身有乐。若令无身随意。五欲谁当受者。答曰。四圣谛苦。圣人知实是苦。愚夫谓之为乐。圣实可依愚惑宜弃。是身实苦以止大苦故。以小苦为乐。譬如应死之人得刑罚代命甚大欢喜。罚实为苦以代死故谓之为乐。复次新苦为乐故苦为苦。如初坐时乐久则生苦。初行立卧亦乐久亦为苦。屈申俯仰视眴喘息苦常随身。从初受胎出生至死无有乐时。若汝以受淫欲为乐。淫病重故求外女色。得之愈多患至愈重。如患疥病向火。揩炙当时小乐大痛转深。如是小乐亦是病因缘故有。非是实乐无病。观之为生慈愍。离欲之人观淫欲者亦复如是。愍此狂惑为欲火所烧多受多苦。如是等种种因缘。知身苦相苦因。行者知身但是不净无常苦物。不得已而养育之。譬如父母生子。子复弊暴以从己生故。要当养育成就。身实无我。何以故。不自在故。譬如病风之人不能俯仰行来。病咽塞者不能语言。以是故知身不自在。如人有物随意取用。身不得尔。不自在。故审知无我。行者思惟是身如是。不净无常苦空无我。有如是等无量过恶。如是等种种观身。是名身念处。得是身念处观已复思惟。众生以何因缘故。贪着此身。乐受故。所以者何。从内六情外六尘和合故。生六种识。六种识中生三种受。苦受乐受不苦不乐受。是乐受一切众生所欲苦受一切众生所不欲。不苦不乐受不取不弃如说

  若作恶人及出家　　诸天世人及蠕动
  一切十方五道中　　无不好乐而恶苦
  狂惑颠倒无智故　　不知涅槃常乐处

行者观是乐受。以实知之无有乐也。但有众苦。何以故。乐名实乐无有颠倒。一切世间乐受。皆从颠倒生无有实者。复次是乐受。虽欲求乐能得大苦。如说

  若人入海遭恶风　　海浪崛起如黑山
  若入大阵斗战中　　经大险道恶山间
  豪贵长者降屈身　　亲近小人为色欲
  如是种种大苦事　　皆为着乐贪心故

以是故知乐受能生种种苦。复次虽佛说三种受有乐受。乐少故名为苦。如一斗蜜投之大河则失气味。问曰。若世间乐颠倒因缘故苦。诸圣人禅定生无漏乐。应是实乐。何以故。此乐不从愚痴颠倒有故。此云何是苦。答曰。非是苦也。虽佛说无常即是苦。为有漏法故说苦。何以故。凡夫人于有漏法中心着。以有漏法无常失坏故生苦。无漏法心不着故。虽无常不能生忧悲苦恼等故。不名为苦。亦诸使不使故。复次若无漏乐。是苦者。佛不别说道谛。苦谛摄故。问曰有二种乐。有漏乐无漏乐。有漏乐下贱弊恶。无漏乐上妙。何以故。于下贱乐中生着。上妙乐中而不生着。上妙乐中生着应多。如金银宝物贪着应重。岂同草木。答曰。无漏乐上妙。而智慧多。智慧多故能离此着。有漏乐中爱等结使多。爱为着本。实智慧能离。以是故不着。复次无漏智慧。常观一切无常。观无常故。不生爱等诸结使。譬如羊近于虎。虽得好草美水而不能肥。如是诸圣人虽受无漏乐。无常空观故。不生染着脂。复次无漏乐。不离三三昧十六圣行。常无众生相。若有众生相则生着心。以是故无漏乐。虽复上妙而不生着。如是种种因缘。观世间乐受是苦。观苦受如箭。不苦不乐受。观无常坏败相。如是则乐受中不生欲着。苦受中不生恚。不苦不乐受中不生愚痴。是名受念处。行者思惟以乐故贪身谁受是乐。思惟已知从心受。众生心狂颠倒故。而受此乐。当观是心无常生灭相一念不住。无可受乐。人以颠倒故。谓得受乐。何以故。初欲受乐时心生异。乐生时心异。各各不相及。云何言心受乐。过去心已灭故不受乐。未来心不生故不受乐。现在心一念住疾故不觉受乐。问曰。过去未来不应受乐。现在心一念住时应受乐。云何言不受。答曰。我已说去疾故不觉受乐。复次诸法无常相故无住时。若心一念住。第二念时亦应住。是为常住无有灭相。如佛说。一切有为法三相住中。亦有灭相。若无灭者不应是有为相。复次若法后有灭。当知初已有灭。譬如人着新衣。初着日若不故第二日亦不应故。如是乃至十岁应常新不应故。而实已故。当知与新俱有。微故不觉。故事已成方乃觉知。以是故知诸法无有住时。云何心住时得受乐。若无住而受乐是事不然。以是故知无有实受乐者。但世俗法。以诸心相续故。谓为一相受乐。问曰。云何当知一切有为法无常。答曰。我先已说今当更答。是有为法一切属因缘故无常。先无今有故今有后无故无常。复次无常相。常随逐有为法故。有为法无有增损故。一切有为法相侵克故无常。复次有为法有二种老常随逐故。一者将老二者坏老。有二种死常随逐故。一者自死二者他杀。以是故知一切有为法皆无常。于有为法中心无常最易得。如佛说凡夫人或时知身无常。而不能知心无常。若凡夫言身有常。犹差以心为常是大惑。何以故。身住或十岁二十岁。是心日月时顷须臾过去。生灭各异念念不停。欲生异生欲灭异灭。如幻事实相不可得。如是无量因缘故知心无常。是名心念处。行者思惟是心属谁。谁使是心观已不见有主。一切法因缘和合故不自在。不自在故无自性。无自性故无我。若无我谁当使是心。问曰。应有我。何以故。心能使身。亦应有我能使心。譬如国主使将将使兵。如是应有我使心有心使身。为受五欲乐故。复次各各有我心故知实有我。若但有身心颠倒故计我者。何以故。不他身中起我。以是相故知各各有我。答曰。若心使身有我使心。应更有使我者。若更有使我者是则无穷。又更有使我者则有两神。若更无我但我能使心。亦应但心能使身。若汝以心属神除心则神无所知。若无所知云何能使心。若神有知相复何用心为。以是故知但心是识相故。自能使身不待神也。如火性能烧物不假于人。问曰。火虽有烧力。非人不用心虽有识相非神不使。答曰。诸法有相故有。是神无相故无。汝虽欲以气息出入苦乐等为神相。是事不然。何以故。出入息等是身相。受苦乐等是心相。云何以身心为神相。复次或时火自能烧不待于人。但以名故名为人烧。汝论堕负处。何以故神则是人。不应以人喻人。又复汝言各各有我心故。知实有我。若但有身心颠倒故。计我者。何以不他身中起我。汝于有我无我未了而问。何以不他身中起我。自身他身皆从我有。我亦不可得。若色相若无色相若常无常有边无边。有去者不去者。有知者不知者。有作者无作者。有自在者不自在者。如是等我相皆不可得。如上我闻品中说。如是等种种因缘。观诸法和合因缘生无有实法有我。是名法念处。是四念处有三种。性念处共念处缘念处。云何为性念处。观身智慧是身念处。观诸受智慧是名受念处。观诸心智慧是名心念处。观诸法智慧是名法念处。是为性念处。云何名共念处。观身为首因缘生道。若有漏若无漏是身念处。观受观心观法为首因缘生道。若有漏若无漏。是名受心法念处。是为共念处。云何为缘念处。一切色法。所谓十入及法入少分是名身念处。六种受眼触生受。耳鼻舌身意触生受。是名受念处。六种识眼识耳鼻舌身意识。是名心念处。想众行众及三无为。是名法念处。是名缘念处。是性念处智慧性故。无色不可见无对。或有漏或无漏。有漏有报无漏无报。皆有为因缘生。三世摄名摄外入摄。以慧知有漏是断。知无漏非断。知有漏是可断无漏非可断。是修法是无垢。是果亦有果。一切非受法非四大造。有上法有漏念处。是有无漏念处。是非有皆是相应因。四念处摄六种善中一种行众善分。行众善分摄四念处。不善无记漏中不相摄。或有四念处非有漏。或有漏非四念处。或有四念处亦有漏。或非四念处亦非有漏。有四念处非有漏者。是无漏性四念处。有漏非四念处者。除有漏性四念处。余残有漏分。四念处亦有漏法者。有漏性四念处。非四念处非有漏法者。除无漏性四念处。余残无漏法。无漏四句亦如是。共念处是共念处中。身业口业是为色。余残非色。一切不可见皆无对。或有漏或无漏皆有为。有漏念处有报。无漏念处无报。因缘生三世摄。身口业色摄。余残名摄。心意识内入摄。余残外入摄。以慧知有漏是断。知无漏非断。知有漏可断无漏非可断。皆修法皆无垢。是果亦有果。一切非受法。身口业是四大造。余残非四大造。皆有上法有漏念处。是有无漏念处。是非有身口业及心不相应诸行。是非相应因。余残是相应因。五善分摄四念处。四念处亦摄五善分。余残不相摄。不善无记漏法不摄。或有四念处非有漏。或有漏非四念处。或有四念处亦有漏。或非四念处亦非有漏。有四念处非有漏者。无漏四念处。有漏非四念处者。除有漏四念处。余残有漏法有四念处亦有漏者。有漏四念处。非四念处非有漏者。虚空数缘尽。非数缘尽。或有四念处非无漏。或有无漏非四念处。或有四念处亦无漏。或非四念处非无漏。有四念处非无漏者。有漏四念处。有无漏非四念处者。三无为法。有四念处亦无漏者。无漏四念处。非四念处非无漏者。除有漏四念处。余残有漏法。是缘念处。缘念处中一念处是色。三念处非色。三不可见。一当分别。身念处有可见有不可见。可见者一入。不可见者九入。及一入少分。三无对一当分别。身念处有对。十入无对。一入少分。身念处有漏十入及一入少分。无漏一入少分。受念处有漏。意相应是有漏。无漏意相应是无漏。心念处亦如是。法念处有漏。想众行众是有漏。无漏想众行众及无为法是无漏。三是有为一当分别。法念处想众行众是有为。三无为法是无为。不善身念处及善有漏身念处是有报。无记身念处及无漏是无报。受念处心念处法念处亦如是。三从因缘生一当分别。法念处有为从因缘生。无为不从因缘生。三三世摄。一当分别。法念处有为是三世摄。无为非三世摄。一念处摄色。三摄名。一念处内入摄。受念处法念处外入摄。一当分别。身念处或内入摄。或外入摄。五内入是内入摄。五外入及一入少分是外入摄。以慧知有漏者是断见。无漏者非断见。有漏者可断。无漏者非可断。修当分别。身念处善应修不善及无记不应修受心念处。亦如是。法念处有为善法应修。不善及无记及数缘尽不应修。垢当分别。身念处隐没是垢。不隐没非垢。受心法念处亦如是。三念处是果亦有果。一当分别。法念处或果非有果。或果亦有果或非果非有果。数缘尽是果非有果。有为法念处是果亦有果。虚空非数缘尽。是非果非有果三不受一当分别。身念处堕身数是受。不堕身数非受。三非四大造一当分别。身念处九入及二入少分四大造。一入少分非四大造。三念处有上一当分别。法念处有为及虚空非数缘尽是有上。涅槃是无上。四念处若有漏是有。若无漏是非有。二念处相应因一念处不相应因一当分别。受念处心念处相应因。身念处不相应因。法念处想众及相应行众是相应因。余残是不相应因。四念处分摄六善法。六善法亦摄四念处分。不善分无记分亦如是。随种相摄。三漏摄一念处分。一念处分亦摄三漏。有漏摄四念处分。四念处分亦摄有漏。无漏摄四念处分。四念处分亦摄无漏。如是等义千难中广说。问曰。何等为内身。何等为外身。如内身外身皆已摄尽。何以复说内外身观。答曰。内名自身外名他身。自身有二种。一者身内不净。二者身外皮毛爪发等。复次行者观死尸膖胀烂坏。取是相。自观身亦如是相如是事。我未离此法。死尸是外身行者身是内身。如行者或时见端政女人心着。即时观其身不净。是为外。自知我身亦尔。是为内。复次眼等五情为内身。色等五尘为外身。四大为内身。四大造色为外身。觉苦乐处为内身。不觉苦乐处为外身。自身及眼等诸根是为内身。妻子财宝田宅所用之物。是为外身。所以者何。一切色法尽是身念处故。行者求是内身有净常乐我。审悉求之都不可得。如先说观法。内观不得外或当有耶。何以故。外物是一切众生着处。外身观时亦不可得。复作是念。我内观不得。外或有耶。外观亦复不得。自念我或误错。今当总观内外。观内观外是为别相。一时俱观是为总相。总观别观了不可得。所观已竟。问曰。身念处可得内外。诸受是外入摄。云何分别有内受外受。答曰。佛说有二种受。身受心受。身受是外心受是内。复有五识相应受是外。意识相应受是内。十二入因缘故。诸受生。内六入分生受。是为内。外六入分生受。是为外。粗受是为外细受是为内。二种苦。内苦外苦。内苦有二种身苦心苦。身苦者身痛头痛等。四百四种病是为身苦。心苦者忧愁嗔怖嫉妒疑如是等。是为心苦。二苦和合是为内苦。外苦有二种。一者王者胜己恶贼师子虎狼蚖蛇等逼害。二者风雨寒热雷电霹雳等。是二种苦名为外受。乐受不苦不乐受亦如是。复次缘内法是为内受。缘外法是为外受。复次一百八受是为内受。余残是外受。问曰。心是内入摄。云何言观外心。答曰。心虽内入摄缘外法故。名为外心缘内法故是为内心。意识是内心五识是外心。摄心入禅是内心。散乱心是外心。内五盖内七觉相应心。是为内心。外五盖外七觉相应心。是为外心。如是等种种分别内外。是为内外心。问曰。法念处是外入摄。云何言观内法。答曰。除受余心数法。能缘内法心数法是内法。缘外法心数法及无为心不相应行是为外法。复次意识所缘法。是名为法。如佛所说。依缘生意识。是中除受余心数法。是为内法。余心不相应行及无为法。是为外法。四正勤有二种。一者性正勤。二者共正勤。性正勤者。为道故四种精进。遮二种不善法。集二种善法。四念处观时。若有懈怠心。五盖等诸烦恼覆心。离五种信等善根时。不善法若已生为断故。未生不令生故。勤精进。信等善根未生为生故。已生为增长故。勤精进。精进法于四念处多故。得名正勤。问曰。何以故。于七种法中此四名正勤。后八名正道。余者不名正。答曰。四种精进心勇发动畏错误故。言正勤。行道趣法故。畏堕邪法故。言正道。性者四种精进性。共者四种精进性为首。因缘生道若有漏若无漏。若有色若无色如上说。行四正勤时心小散故。以定摄心故。名如意足。譬如美食少盐则无味。得盐则味足如意。又如人有二足。复得好马好车如意所至。行者如是得四念处实智慧四正勤中正精进。精进故智慧增多。定力小弱。得四种定摄心故。智定力等所愿皆得故。名如意足。问曰。四念处四正勤中已有定。何以故不名如意足。答曰。彼虽有定。智慧精进力多定力弱故。行者不得如意愿。四种定者。欲为主得定。精进为主得定。定因缘生道。若有漏若无漏心为主得定。思惟为主得定。定因缘生道。若有漏若无漏。共善五众名为共如意。欲主等四种定。名为性如意。四正勤四如意足。如性念处共念处中广分别说。五根者。信道及助道善法。是名信根。行者行是道助道法时。勤求不息是名精进根。念道及助道法。更无他念是名念根。一心念不散是名定根。为道及助道法。观无常等十六行。是名慧根。是五根增长不为烦恼所坏。是名为力。如五根中说。是五根五力行众中摄。常共相应。随心行心数法。共心生共心住共心灭。若有是法心堕正定。若无是法心堕邪定。七觉如先说义。问曰。先虽说义。非以阿毗昙法说。答曰。今当更说。如四念处义是七觉分。无色不可见无对无漏有为因缘生。三世摄名摄外入摄。慧知非断见不可断。修法无垢法。是果亦有果。非受法非四大造。有上法非有相应因。二善分摄七觉分。七觉分摄二善分。不善无记漏有漏法不相摄。无漏二分摄七觉分。七觉分摄无漏二分。如是等种种。如千难中广说。八圣道分如先说。正见是智慧。如四念处慧根慧力择法觉中说。正思惟观四谛时。无漏心相应。思惟动发觉知筹量。正方便如四正勤精进根精进力精进觉中说。正念如念根念力念觉中说。正定如如意足定根定力定觉中说。正语正业正命今当说。除四种邪命摄口业。以无漏智慧除舍。离余口邪业。是名正语。正业亦如是。五种邪命以无漏智慧除舍。离是为正命。问曰。何等是五种邪命。答曰。一者若行者为利养故诈现异相奇特。二者为利养故自说功德。三者为利养故占相吉凶为人说。四者为利养故高声现威令人畏敬。五者为利养故称说所得供养以动人心。邪因缘活命故。是为邪命。是八正道有三分。三种为戒分。三种为定分。二种为慧分。慧分定分分别如先说。戒分今当说。戒分是色性不可见。无对无漏有为无报因缘生。三世摄色摄。非名摄外入摄。慧知非断见不可断。修法无垢法。是果亦有果。非受法四大造有上法非有法。相应因。一善分摄三正。三正摄一善分。不善无记漏有漏不相摄。无漏一法摄三正。三正亦摄无漏一法。如是等种种分别。如阿毗昙广说。是三十七品。初禅地具有。未到地中三十六。除喜觉。第二禅中亦三十六。除正行禅中间第三第四禅三十五。除喜觉除正行。三无色定中三十二。除喜觉正行正语正业正命。有顶中二十二。除七觉分八圣道分。欲界中二十二亦如是。是为声闻法中分别义。问曰摩诃衍所说。三十七品义云何。答曰菩萨摩诃萨。行四念处观是内身无常苦如病如痈。焰聚败坏不净充满九孔流出。是为行厕。如是观身恶露无一净处。骨干肉涂筋缠皮裹。先世受有漏业因缘。今世沐浴华香衣服饮食卧具医药等所成。如车有两轮牛力牵故能有所至。二世因缘以成身车。识牛所牵周旋往反。是身四大和合造。如水沫聚虚无坚固。是身无常久必破坏。是身相身中不可得。亦不在外亦不在中间。身不自觉无知无作如墙壁瓦石。是身中无定身相。无有作是身者。亦无使作者。是身先际后际中际皆不可得。八万户虫无量诸病。及诸饥渴寒热刑残等常恼此身。菩萨摩诃萨观身如是。知非我身亦非他有。不得自在有作及所不作是身。身相空从虚妄因缘生。是身假有属本业因缘。菩萨自念我不应惜身命。何以故。是身相不合不散不来不去不生不灭不依猗。循身观。是身无我无我所故空。空故无男女等诸相。无相故不作愿。如是观者得入无作智门。知身无作。无作者。但从诸法因缘和合生。是诸因缘作是身者。亦从虚妄颠倒故有。是因缘中亦无因缘相。是因缘生亦无生相。如是思惟知是身从本以来无有生相。知是身无相无可取。无生故无相。无相故无生。但诳凡夫故名为身。菩萨如是观身实相时。离诸染欲着心。常系念在身循身观。如是名为菩萨身念处。观外身观内外身亦如是。菩萨云何观诸受。观内受是受有三种。若苦若乐若不苦不乐。是诸受无所从来。灭无所至。但从虚诳颠倒妄想生。是报果属先世业因缘。是菩萨如是求诸受。不在过去不在未来不在现在。知是诸受空无我无我所。无常破坏法。观是三世诸受空无相无作入解脱门。亦观诸受生灭。亦知诸受不合不散不生不灭。如是入不生门。知诸受不生故无相。无相故不生。如是知已系心缘中。若有苦乐不苦不乐来。心不受不着不作依止。如是等因缘观诸受。是名受念处。观外受观内外受亦如是。菩萨云何观心念处。菩萨观内心。是内心有三相。生住灭。作是念是心无所从来。灭亦无所至。但从内外因缘和合生。是心无有定实相。亦无实生住灭。亦不在过去未来现在世中。是心不在内不在外不在中间。是心亦无性无相。亦无生者无使生者。外有种种杂六尘因缘。内有颠倒心相。生灭相续故强名为心。如是心中实心相不可得。是心性不生不灭。常是净相客烦恼相着故。名为不净心。心不自知。何以故是心心相空故。是心本末无有实法。是心与诸法无合无散。亦无前际后际中际。无色无形无对。但颠倒虚诳生。是心空无我。无我所无常无实。是名随顺心观。知心相无生。入无生法中。何以故。是心无生无性无相。智者能知。智者虽观是心生灭相。亦不得实生灭法。不分别垢净。而得心清净。以是心清净故。不为客烦恼所染。如是等观内心观外心。观内外心亦如是。菩萨云何观法念处。观一切法不在内不在外。不在中间。不过去未来。现在世中但从因缘和合妄见生无有实定。无有是法是谁法。诸法中法相不可得。亦无法若合若散。一切法无所有。如虚空。一切法虚诳如幻。诸法性净不相污染。诸法无所受。诸受无所有故。诸法无所知。心心数法虚诳故。如是观时不见有法若一相若异相。观一切法空无我。是时作是念。一切诸法因缘生故无有自性。是为实空。实空故无有相。无有相故无作。无作故不见法若生若灭住。是智慧中入无生法忍门。尔时虽观诸法生灭。亦入无相门。何以故一切法离诸相。智者之所解。如是观时系心缘中。随顺诸法相。不念身受心法。知是四法无处所。是为内法念处。外法念处内外法念处亦如是。四正勤四如意足。亦如是应分别观空无处所。云何为菩萨所行五根。菩萨摩诃萨。观五根修五根。信根者。信一切法从因缘生颠倒妄见心生如旋火轮如梦如幻。信诸法不净无常苦无我如病如痈如刺灾变败坏。信诸法无所有如空拳诳小儿。信诸法不在过去不在未来不在现在。无所从来灭无所至。信诸法空无相无作不生不灭。无信相无相而信持戒禅定智慧解脱解脱知见。得是信根故不复退转。以信根为首。善住持戒。住持戒已信心不动不转。一心信。依业果报离诸邪见更不信余语。但受佛法信众僧。住实道中直心柔软能忍。通达无碍不动不坏得力自在。是名信根。精进根者。昼夜常行精进。除却五盖摄护五根。诸深经法欲得欲知欲行欲诵欲读乃至欲闻。若诸不善恶法起令疾灭。未生者令不生。未生诸善法令生。已生令增广。亦不恶不善法亦不爱。善法得等精进。直进不转得正精进。定心故名为精进根。念根者。菩萨常一心念。欲具足布施持戒禅定智慧解脱。欲净身口意业。诸法生灭住异。智中常一心念。一心念苦集尽道。一心念分别根力觉道禅定解脱生灭入出。一心念诸法不生不灭无作无说。为得无生智慧具足诸佛法故。一心念不令声闻辟支佛心得入。常念不忘。如是诸法甚深清净观行得故。得如是自在念。是名念根。定根者菩萨善取定相。能生种种禅定。了了知定门。善知入定善知住定善知出定。于定不着不味不作依止。善知所缘善知坏缘。自在游戏诸禅定。亦知无缘定不随他语。不专随禅定。行自在出入无碍。是名为定根。慧根者。菩萨为尽苦圣智慧成就。是智慧为离诸法为涅槃。以智慧观一切三界无常。为三衰三毒火所烧观已于三界中。智慧亦不着。一切三界。转为空无相无作解脱门。一心为求佛法如救头然。是菩萨智慧无能坏者。于三界无所依。于随意五欲中心常离之。慧根力故。积聚无量功德。于诸法实相。利入无疑无难。于世间无忧。于涅槃无喜。得自在智慧。故名为慧根。菩萨得是五根。善知众生诸根相。知染欲众生根。知离欲众生根。知嗔恚众生根。亦知离嗔恚众生根。知愚痴众生根。亦知离愚痴众生根。知欲堕恶道众生根。知欲生人中众生根。知欲生天上众生根。知钝众生根。知利众生根。知上中下众生根。知罪众生根。知无罪众生根。知逆顺众生根。知常生欲界色界无色界众生根知厚善根薄善根众生根。知正定邪定不定众生根。知轻躁众生根。知持重众生根。知悭贪众生根。知能舍众生根。知恭敬众生根。知不恭敬众生根。知净戒不净戒众生根。知嗔恚忍辱众生根。知精进懈怠众生根。知乱心摄心愚痴智慧众生根。知无畏有畏众生根。知增上慢不增上慢众生根。知正道邪道众生根。知守根不守根众生根。知求声闻众生根。知求辟支佛众生根。知求佛道众生根。于知众生根中。得自在方便力故。名为知根。菩萨行是五根增长。能破烦恼度众生得无生法忍。是名五力。复次天魔外道不能沮坏。是名为力。七觉分者。菩萨于一切法不忆不念。是名念觉分。一切法中求索善法不善法无记法不可得。是名择法觉分。不入三界破坏诸界相。是名精进觉分。于一切作法不生着乐。忧喜相坏故是名喜觉分。于一切法中。除心缘不可得故。是名除觉分。知一切法常定相不乱不定。是名定觉分。于一切法不着不依止。亦不见。是舍心是名舍觉分。菩萨观七觉分空如是。问曰。此七觉分何以略说。答曰。七觉分中。念慧精进定。上已广说。三觉今当说。菩萨行喜觉分。观是喜非实。何以故。是喜从因缘生。作法有法无常法可着法。若生着是无常相。变坏则生忧。凡夫人以颠倒故心着。若知诸法实空。是时心悔我则受虚诳。如人闇中饥渴所逼食不净物。昼日观知乃觉其非。若如是观。于实智慧中生喜是为真喜。得是真喜先除身粗。次除心粗。然后除一切法相。得快乐遍身心中。是为除觉分。既得喜除舍诸观行。所谓无常观苦观空无我观生灭观不生不灭观有观无观非有非无观。如是等戏论尽舍。何以故。无相无缘无作无戏论常寂灭。是实法相。若不行舍便有诸诤。若以有为实则以无为虚。若以无为实则以有为虚。若以非有非无为实。则以有无为虚。于实爱着于虚恚憎。生忧喜处云何不舍。得如是喜除舍。七觉分则具足满。八圣道分者。正见正方便正念正定上已说。正思惟今当说。菩萨于诸法空无所得住。如是正见中。观正思惟相。知一切思惟皆是邪思惟。乃至思惟涅槃思惟佛皆亦如是。何以故。断一切思惟分别。是名正思惟。诸思惟分别。皆从不实虚诳颠倒故有分别。思惟相皆无。菩萨住如是正思惟中。不见是正是邪。过诸思惟分别。是为正思惟。一切思惟分别皆悉平等。悉平等故心不着。如是等名为菩萨正思惟相。正语者。菩萨知一切语皆从虚妄不实颠倒取相分别生是时菩萨作是念。语中无语相。一切口业灭知诸语实相。是为正语。是诸语皆无所从来。灭亦无所去。是菩萨行正语法。诸有所语皆住实相中说。以是故诸经说。菩萨住正语中能作清净口业。知一切语言真相。虽有所说不堕邪语。正业者。菩萨知一切业邪相虚妄无实皆无作相。何以故无有一业可得定相。问曰。若一切业皆空。云何佛说布施等是善业。杀害等是不善业。余事动作是无记业

答曰。诸业中尚无有一。何况有三。何以故。如行时已过则无去业。未至亦无去业。现在去时亦无去业。以是故无去业。问曰。已过处则应无。未至处亦应无。今去处应是有去。答曰。今去处亦无去。何以故。除去业今去处不可得。若除去业今去处可得者。是中应有去而不然。除今去处则无去业。除去业则无今去处。是相与共缘故。不得但言今去处有去。复次若今去处有去业。离去业应当有今去处。离今去处应当有去业。问曰。若尔者有何咎。答曰。一时有二去业故。若有二去业。则有二去者。何以故。除去者则无去。若除去者今去处不可得。无今去处故亦无去者。复次不去者亦不去故无去业。若除去者不去者。更无第三去者。问曰。不去者不去应尔。去者何以故言不去。答曰。除去业去者不可得。除去者去业不可得。如是等一切业空。是名正业。诸菩萨入一切诸业平等。不以邪业为恶。不以正业为善。无所作不作正业不作邪业。是名实智慧。即是正业。复次诸法等中无正无邪。如实知诸业。如实知已不造不休。如是智人常有正业无邪业。是名为菩萨正业。正命者。一切资生活命之具悉正不邪。住不戏论智中不取正命不舍邪命。亦不住正法中。亦不住邪法中。常住清净智中。入平等正命不见命不见非命。行如是实智慧。以是故名正命。若菩萨摩诃萨。能观是三十七品。得过声闻辟支佛地。入菩萨位中。渐渐得成一切种智

大智度论卷第十九大智度论释初品中三三昧义第三十二(卷第二十)

        龙树菩萨造

        后秦龟兹国三藏鸠摩罗什奉　诏译

【经】空三昧无相三昧无作三昧。四禅四无量心四无色定。八背舍八胜处九次第定十一切处

【论】问曰。何以故次三十七品。后说八种法。答曰。三十七品是趣涅槃道。行是道已得到涅槃城。涅槃城有三门。所谓空无相无作。已说道次应说到处门。四禅等是助开门法。复次三十七品是上妙法。欲界心散乱。行者依何地何方便得。当依色界无色界诸禅定。于四无量心八背舍八胜处九次第定十一切处中试心知得柔软自在随意不。譬如御者试马曲折随意然后入阵。十一切处亦如是。观取小许青色。视一切物皆能使青。一切黄一切赤一切白皆如是。复次于八胜处缘中自在。初二背舍观身不净。第三背舍观身还使净。四无量心慈观众生皆乐。悲观众生皆苦。喜观众生皆喜。舍是三心但观众生无有憎爱。复次有二种观。一者得解观二者实观。实观者。是三十七品。以实观难得故。次第说得解观。得解观中心柔软易得实观。用实观得入三涅槃门。问曰。何等空涅槃门。答曰。观诸法无我我所空。诸法从因缘和合生。无有作者无有受者。是名空门。复次空门。如忍智品中说。知是无我我所已。众生云何于诸法中心着。行者思惟作是念。诸法从因缘生无有实法。但有相。而诸众生取是相着我我所我今当观是相有实可得不。审谛观之都不可得。若男相女相一异相等。是相实皆不可得。何以故。诸法无我我所故空。空故无男无女。一异等法我我所中名字。是一是异。以是故男女一异法实不可得。复次四大及造色。围虚空故名为身。是中内外入因缘和合。生识种身。得是种和合。作种种事言语坐起去来。于空六种和合中强名为男。强名为女。若六种是男应有六男。不可以一作六六作一。亦于地种中无男女相。乃至识种亦无男女相。若各各中无。和合中亦无。如六狗。各各不能生。师子和合亦不能生。无性故。问曰。何以故无男女。虽神无有别。即身分别有男女之异。是身不得离身分。身分亦不得离身。如见身分足。知有有分法名为身。足等身分异身。身即是男女相。答曰。神已先破身相亦坏。今当重说。若有是有分名身。为各各分中具足有为身分。分在诸分中。若诸分中具足有身者。头中应有脚。何以故。头中具足有身故。若身分分在诸分中。是身与分无有异。有分者随诸分故。问曰。若足等身分与有分异。是有咎。今足等身分与有分身法不异故无咎。答曰。若足等身分。与有分不异。头即是足。何以故。二事是身不异故。又身分多有分一。不应多作一一作多。复次因无故果无。非果无故因无。身分与有分不异。应果无故因无。何以故。因果一故。若一若异中求身不可得。身无故何处有男女。若有男女为即是身为异身。身则无可得。若在余法余法非色故。无男女之别。但二世因缘和合。以颠倒心故。谓为男女。如说

  俯仰屈申立去来　　视瞻言语中无实
  风依识故有所作　　是识灭相念念无
  彼此男女有我心　　无智慧故妄见有
  骨锁相连皮肉覆　　机关动作如木人
  内虽无实外似人　　譬如洋金投水中
  亦如野火焚竹林　　因缘合故有声出

如是等诸相如先所说。此中应广说。是名无相门。无作者既知无相。都无所作。是名无作门。问曰。是三种以智慧观空观无相观无作。是智慧何以故名三昧。答曰。是三种智慧若不住定中则是狂慧。多堕邪疑无所能作。若住定中则能破诸烦恼。得诸法实相。复次是道异一切世间。与世间相违。诸圣人在定中得实相说。非是狂心语。复次诸禅定中无此三法。不名为三昧。何以故。还退失堕生死故。如佛说

  能持净戒名比丘　　能观空名行定人
  一心常勤精进者　　是名真实行道人
  于诸乐中第一者　　断诸渴爱灭狂法
  舍五众身及道法　　是为常乐得涅槃

以是故三解脱门。佛说名为三昧。问曰。今何以故名解脱门。答曰。行是法时。得解脱到无余涅槃。以是故名解脱门。无余涅槃是真解脱。于身心苦得脱。有余涅槃为作门。此三法虽非涅槃。涅槃因故名为涅槃。世间有因中说果果中说因。是空无相无作是定性。是定相应心心数法。随行身业口业。此中起心不相应。诸行和合皆名为三昧。譬如王来必有大臣营从。三昧如王智慧如大臣余法如营从。余法名虽不说必应有。何以故。定力不独生。不能独有所作故。是诸法共生共住共灭共成事互相利益。是空三昧二行。一者观五受众一相异相无故空。二者观我我所法不可得故无我。无相三昧四行。观涅槃种种苦尽故名为尽。三毒等诸烦恼火灭故名为灭。一切法中第一故名为妙。离世间故名为出。无作三昧二行。观五受众因缘生故无常。身心恼故苦。观五受众因四行。烦恼有漏业和合能生苦果故名为集。以六因生苦果故名为因。四缘生苦果故名为缘。不多不少等因缘生果故名为生。观五不受众四行。是八圣道分能到涅槃故道不颠倒故正。一切圣人去处故迹。爱见烦恼不遮故必到。是三解脱门在九地中。四禅未到地禅中间三无色。无漏性故。或有说者。三解脱门一向无漏。三三昧或有漏或无漏。以是故三昧解脱有二名。如是说者在十一地。六地三无色欲界及有顶地。若有漏者系在十一地。无漏者不系。喜根乐根舍根相应。初学在欲界中。成就在色无色界中。如是等成就不成就修不修。如阿毗昙中广说。复次有二种空义。观一切法空。所谓众生空法空。众生空如上说。法空者诸法自相空。如佛告须菩提。色色相空受想行识识相空。问曰。众生空法不空是可信。法自相空是不可信。何以故。若法自相空则无生无灭。无生无灭故无罪无福。无罪无福故何用学道。答曰。有法空故有罪福。若无法空不应有罪福。何以故。若诸法实有自性则无可坏。性相不从因缘生。若从因缘生便是作法。若法性是作法则可破。若言法性可作可破。是事不然。性名不作法。不待因缘有。诸法自性有。自性有则无生者性先有故。若无生则无灭。生灭无故无罪福。无罪福故何用学道。若众生有真性者。则无能害无能利。自性定故。如是等人则不知恩义破业果报。法空中亦无法空相。汝得法空心着故而生是难。是法空诸佛以怜愍心。为断爱结除邪见故说。复次诸法实相能灭诸苦。是诸圣人真实行处。若是法空有性者。说一切法空时。云何亦自空。若无法空性汝何所难。以是二空能观诸法空。心得离诸法知世间虚诳如幻。如是观空。若取是诸法空相。从是因缘生憍慢等诸结使言。我能知诸法实相。是时应学无相门。以灭取空相故。若于无相中生戏论。欲分别有所作着是无相。是时复自思惟。我为谬错。诸法空无相中。云何得相取相作戏论。是时应随空无相行身口意。不应有所作。应观无作相灭三毒。不应起身口意业。不应求三界中生身。如是思惟时。还入无作解脱门。是三解脱门。摩诃衍中是一法。以行因缘故。说有三种。观诸法空是名空。于空中不可取相。是时空转名无相。无相中不应有所作为三界生。是时无相转名无作。譬如城有三门。一人身不得一时从三门入。若入则从一门。诸法实相是涅槃城。城有三门。空无相无作。若人入空门不得是空。亦不取相。是人直入事办故不须二门。若入是空门取相得是空。于是人不名为门。通涂更塞。若除空相是时从无相门入。若于无相相。心着生戏论。是时除取无相相。入无作门。阿毗昙义中。是空解脱门。缘苦谛摄五众。无相解脱门缘一法。所谓数缘尽。无作解脱门。缘三谛摄五众。摩诃衍义中。是三解脱门。缘诸法实相。以是三解脱门观世间即是涅槃。何以故。涅槃空无相无作。世间亦如是。问曰。如经说涅槃一门。今何以说三。答曰。先已说。法虽一而义有三。复次应度者有三种。爱多者见多者爱见等者。见多者为说空解脱门。见一切诸法从因缘生无有自性。无有自性故空。空故诸见灭。爱多者为说无作解脱门。见一切法无常苦从因缘生。见已心厌离爱即得入道。爱见等者为说无相解脱门。闻是男女等相无故断爱。一异等相无故断见。佛或一时说二门。或一时说三门。菩萨应遍学知一切道。故说三门。更欲说余事故。三解脱门义略说。四禅有二种。一者净禅。二者无漏禅。云何名净禅。有漏善五众是。云何名无漏。无漏五众。是四禅中所摄身口业是色法。余残非色法一切不可见无对。或有漏或无漏。有漏者善有漏五众。无漏者无漏五众。皆是有为。有漏者色界系。无漏者不系。禅摄身业口业及心不相应。诸行是非心非心数法非心相应。禅摄受众想众及相应行众。是心数法亦心相应。禅摄心意识但心。四禅或有随心行。非受相应。或受相应非随心行。或随心行亦受相应。或非随心行非受相应。随心行非受相应者。四禅摄身业口业随心行心不相应诸行及受。受相应非随心行者。四禅摄心意识。随心行亦受相应者。四禅摄想众及相应行众。非随心行亦非受相应者。除四禅中摄随心行心不相应诸行。余残心不相应。诸行想行相应亦如是。是四禅中三禅非随觉行。亦非观相应。初禅或有随觉行。非观相应。或观相应非随觉行。或有随觉行亦观相应。或有非随觉行非观相应。随觉行非观相应者。初禅摄身业口业及随觉行心不相应诸行及观。观相应非随觉行者。谓觉随觉行。亦观相应者。觉观相应诸心心数法。非随觉行亦非观相应者。除随觉行心不相应诸行。余残心不相应诸行。四禅皆有因缘亦与因缘。四禅中初禅。或次第非与次第缘。或次第亦与次第缘。或非次第亦非与次第缘。次第非与次第缘者。未来世中欲生心心数法。次第亦与次第缘者。过去现在心心数法。非次第亦不与次第缘者。除未来世欲生心心数法。余残未来世中心心数法。身业口业及心不相应诸行。第二第三禅亦如是。第四禅次第不与次第缘者。未来世中欲生心心数法。及无想定若生若欲生。次第亦与次第缘者。过去现在心心数法。非次第亦非与次第缘者。除未来世中欲生心心数法。余残未来世心心数法。除心次第心不相应诸行。余残心不相应诸行。及身业口业。四禅中摄身业口业及心不相应诸行与缘非缘余残亦缘亦与缘。是四禅亦增上缘。亦与增上缘。如是等阿毗昙分中广分别。菩萨得禅方便及禅相禅支禅波罗蜜中已广说。问曰。是般若波罗蜜论议中。但说诸法相空。菩萨云何于空法中能起禅定。答曰。菩萨知诸五欲及五盖从因缘生无自性空无所有。舍之甚易。众生颠倒因缘故。着此少弊乐。而离禅中深妙乐。菩萨为是众生故。起大悲心修行禅定系心缘中离五欲除五盖入大喜初禅。灭觉观摄心。深入内清净得微妙喜。入第二禅。以深喜散定故。离一切喜得遍满乐入第三禅。离一切苦乐。除一切忧喜及出入息。以清净微妙舍而自庄严。入第四禅。是菩萨虽知诸法空无相。以众生不知故。以禅相教化众生。若实有诸法空。是不名为空。亦不应舍五欲而得禅。无舍无得故。今诸法空相亦不可得。不应作是难言。若诸法空云何能得禅。复次是菩萨不以取相爱着故。行禅如人服药欲以除病不以美也。为戒清净智慧成就故行禅。菩萨于一一禅中。行大慈观空。于禅无所依止。以五欲粗诳颠倒故。以细微妙虚妄法治。譬如有毒能治诸毒

    大智度论释初品中四无量义第三十三

四无量心者。慈悲喜舍。慈名爱念众生。常求安隐乐事以饶益之。悲名愍念众生。受五道中种种身苦心苦。喜名欲令众生。从乐得欢喜。舍名舍三种心。但念众生不憎不爱。修慈心为除众生中嗔觉故。修悲心为除众生中恼觉故。修喜心为除不悦乐故。修舍心为除众生中爱憎故。问曰。四禅中已有四无量心乃至十一切处。今何以故别说。答曰。虽四禅中皆有。是法若不别说名字。则不知其功德。譬如囊中宝物。不开出则人不知。若欲得大福德者。为说四无量心。患厌色如在牢狱。为说四无色定。于缘中不能得自在随意观所缘。为说八胜处。若有遮道不得通达为说八背舍。心不调柔不能从禅起次第入禅。为说九次第定。不能得一切缘遍照随意得解。为说十一切处。若念十方众生。令得乐时心数法中生法名为慈。是慈相应受想行识众。是法起身业口业及心不相应诸行。是法和合皆名为慈名为慈故。是法生以慈为主。是故慈得名。譬如一切心心数法。虽皆是后世业因缘。而但思得名。于作业中思最有力故。悲喜舍亦如是。是慈在色界。或有漏或无漏。或可断或不可断。亦在根本禅中亦禅中间。三根相应除苦根忧根。如是等阿毗昙分别说。取众生相故有漏。取相已入诸法实相故无漏。以是故无尽意菩萨问中说。慈有三种。一者众生缘二者法缘三者无缘。问曰。是四无量心云何行。答曰。如佛处处经中说。有比丘以慈相应心。无恚无恨无怨无恼。广大无量善修慈心得解遍满。东方世界众生慈心得解遍满。南西北方四维上下十方世界众生。以悲喜舍相应心亦如是。慈相应心者。慈名心数法。能除心中愦浊。所谓嗔恨悭贪等烦恼。譬如净水珠着浊水中水即清。无恚恨者。于众生中若有因缘若无因缘而嗔。若欲恶口骂詈杀害劫夺是名嗔。待时节得处所有势力当加害是名恨。以慈除此二事故。名无嗔恨无怨无恼。恨即是怨。初嫌为恨。恨久成怨身口业加害。是名恼。复次初生嗔结名为嗔。嗔增长筹量持着。心中未决了是名恨。亦名怨。若心已定无所畏忌。是名恼。以慈心力除舍离此三事。是名无嗔无恨无怨无恼。此无嗔无恨无怨无恼佛以是赞叹慈心。一切众生皆畏于苦贪着于乐。嗔为苦因缘慈是乐因缘。众生闻是慈三昧。能除苦能与乐故。一心勤精进行是三昧。以是故无嗔无恨无怨无恼。广大无量者。一大心分别有三名。广名一方大名高远无量名下方及九方。复次下名广中名大上名无量。复次缘四方众生心。是名广。缘四维众生心。是名大。缘上下方众生心。是名无量。复次破嗔恨心是名广。破怨心是名大。破恼心是名无量。复次一切烦恼心小人所行生小事故名为小。复小于此故名嗔恨怨恼。破是小中之小。是名广大无量。所以者何。大因缘常能破小事故。广心者。畏罪畏堕地狱故除心中恶法大心者。信乐福德果报故除恶心。无量心者。为欲得涅槃故除恶心。复次行者持戒清净故是心广。禅定具足故是心大。智慧成就故是心无量。以是慈心念得道圣人。是名无量心。用无量法分别圣人故。念诸天及人尊贵处故。名为大心。念诸余下贱众生及三恶道。是名广心。于所爱众生中。以慈念广于念已故。名为广心。以慈念中人是名大心。以慈念怨憎其功德多故。名无量心。复次为狭缘心故名为广。为小缘心故名为大。为有量心故名为无量。如是等分别义。善修者是慈心牢固初得慈心不名为修。非但爱念众生中。非但好众生中。非但益己众生中。非但一方众生中。名为善修。久行得深。爱乐爱憎及中三种众生正等无异。十方五道众生中。以一慈心视之。如父如母如兄弟姊妹子侄知识。常求好事。欲令得利益安隐。如是心遍满十方众生中。如是慈心名众生缘。多在凡夫人行处或有学人未漏尽者。行法缘者。诸漏尽阿罗汉辟支佛诸佛。是诸圣人破吾我相。灭一异相故。但观从因缘相续生诸欲。以慈念众生时。从和合因缘相续生但空。五众即是众生。念是五众以慈念。众生不知是法空。而常一心欲得乐。圣人愍之令随意得乐。为世俗法故。名为法缘。无缘者是慈但诸佛有。何以故。诸佛心不住有为无为性中。不依止过去世未来现在世知诸缘不实颠倒虚诳故。心无所缘。佛以众生不知是诸法实相。往来五道心着诸法分别取舍。以是诸法实相智慧。令众生得之。是名无缘。譬如给赐贫人。或与财物或与金银宝物。或与如意真珠。众生缘法缘无缘亦复如是。是为略说慈心义。悲心义亦如是。以怜愍心遍观十方众生苦。作是念众生可愍莫令受是种种苦。无嗔无恨无怨无恼心乃至十方亦如是。问曰。有三种众生。有受乐如诸天及人少分。有受苦如三恶道及人中少分。有受不苦不乐五道中少分。云何行慈者观一切众生皆受乐。行悲者观一切众生皆受苦。答曰。行者欲学是慈无量心时。先作愿。愿诸众生受种种乐。取受乐人相。摄心入禅。是相渐渐增广。即见众生皆受乐。譬如钻火先以软草干牛屎。火势转大能烧大湿木。慈三昧亦如是。初生慈愿时唯及诸亲族知识。慈心转广怨亲同等皆见得乐。是慈禅定增长成就故。悲喜舍心亦如是。问曰。悲心中取受苦人相。喜心中取受喜人相。舍心中取何等相。答曰。取受不苦不乐人相。行者以是心渐渐增广。尽见一切受不苦不乐。问曰。是三种心中应有福德。是舍心于众生不苦不乐。有何等饶益。答曰。行者作是念。一切众生离乐时得苦。苦时即是苦。得不苦不乐则安隐。以是饶益。行者行慈喜心。或时贪着心生行悲心。或时忧愁心生。以是贪忧故。心乱。入是舍心除此贪忧。贪忧除故名为舍心。问曰。悲心舍心可知有别。慈心令众生乐。喜心令众生喜。乐与喜有何等异。答曰。身乐名乐心乐名喜。五识相应乐名乐。意识相应乐名喜。五尘中生乐名乐。法尘中生乐名喜。先求乐愿令众生得从乐。因令众生得喜。如人怜愍贫人。先施宝物是名乐。后教令卖买得受五欲乐。是名喜。复次欲界乐愿令众生得是名乐。色界乐愿令众生得是名喜。复次欲界中五识相应乐。初禅中三识相应乐。三禅中一切乐。是名乐。欲界及初禅意识相应乐。二禅中一切乐。是名喜。粗乐名乐细乐名喜。因时名乐果时名喜。初得乐时是名乐。欢心内发乐相。外现歌舞踊跃是名喜。譬如初服药时是名乐。药发遍身时是名喜。问曰。若尔者何以不和合二心作一无量。而分别为二法。答曰。行者初心未摄。未能深爱众生故。但与乐。摄心深爱众生故与喜。以是故先乐而后喜。问曰。若尔者何以不慈喜次第。答曰。行慈心时。爱众生如儿子。愿与乐出慈三昧故。见众生受种种苦。发深爱心怜愍众生。令得深乐。譬如父母虽常爱子。若得病急是时爱心转重。菩萨亦如是。入悲心观众生苦怜愍心生便与深乐。以是故悲心在中。问曰。若如是深爱众生复何以行舍心。答曰。行者如是观。常不舍众生。但念舍是三种心。何以故。妨废余法故。亦以是慈心。欲令众生乐。而不能令得乐。悲心欲令众生离苦。亦不能令得离苦。行喜心时亦不能令众生得大喜。此但忆想未有实事。欲令众生得实事。当发心作佛。行六波罗蜜具足佛法。令众生得是实乐。以是故舍是三心入是舍心。复次如慈悲喜。心爱深故舍众生难。入是舍心故易得出离。问曰。菩萨行六波罗蜜。乃至成佛亦不能令一切众生离苦得乐。何以故。但言是三心忆想心生无有实事。答曰。是菩萨作佛时。虽不能令一切众生得乐。但菩萨发大誓愿。从是大愿得大福德果报。得大报故能大饶益凡夫。声闻行是四无量。为自调自利故。亦但空念众生。诸菩萨行是慈心。欲令众生离苦得乐。从此慈心因缘。亦自作福德。亦教他作福德。受果报时或作转轮圣王多所饶益。菩萨或时出家行禅。引导众生教令行禅。得生清净界受无量心乐。若作佛时共无量阿僧祇众生。入无余涅槃。比于空心愿益是为大利。乃至舍利余法多所饶益。复次若一佛尽度一切众生。余佛则无所复度。是则无未来佛为断佛种。有如是等过。以是故一佛不度一切众生。复次是众生性从痴而有。非实定法。三世十方诸佛。求众生实不可得。云何尽度一切。问曰。若空不可得尽度者少亦俱空。何以度少。答曰。我言三世十方佛求一切众生不可得故无所度。汝难言何以不尽度。是为堕负处。汝于负处不能自拔。而难言无众生中多少一种何以度少。是为重堕负处。复次诸法实相第一义中则无众生。亦无度。但以世俗法故说言有度。汝于世俗中。求第一义。是事不可得。譬如瓦石中求珍宝不可得。复次诸佛从初发心。乃至法尽。于其中间所有功德。皆是作法有限有量有初有后故。所度众生亦应有量。不应以随因缘果报有量法尽度无量众生。如大力士弓势虽大箭远必堕。亦如劫尽大火烧三千世界明照无量虽久必灭。菩萨成佛亦如是。从初发意执精进弓用智慧箭。深入佛法大作佛事亦必当灭。菩萨得一切种智时。身出光明照无量世界。一一光明变化作无量身。度十方无量众生。涅槃后八万四千法聚。舍利化度众生。如劫尽火照久亦复灭。问曰。汝自言光明变化作无量身。度十方无量众生。今何以言有量因缘故。所度亦应有量。答曰。无量有二种。一者实无量。诸圣人所不能量。譬如虚空涅槃众生性是不可量。二者有法可量。但力劣者不能量。譬如须弥山大海水斤两渧数多少。诸佛菩萨能知。诸天世人所不能知。佛度众生亦如是。诸佛能知。但非汝等所及故言无量。复次诸法因缘和合生故无有自性。自性无故常空。常空中众生不可得。如佛说

  我坐道场时　　智慧不可得
  空拳诳小儿　　以度于一切
  诸法之实相　　则是众生相
  若取众生相　　则远离实道
  常念常空相　　是人非行道
  不生灭法中　　而作分别相
  若分别忆想　　则是魔罗网
  不动不依止　　是则为法印

问曰。若乐有二分。慈心喜心。悲心观苦何以不作二分。答曰。乐是一切众生所爱重故作二分。是苦不爱不念故不作二分。又受乐时心软。受苦时心坚。如阿育王弟违陀输。七日作阎浮提王。得上妙自恣五欲。过七日已。阿育王问言。阎浮提主受乐欢畅不。答言。我不见不闻不觉。何以故。旃陀罗日日振铃高声唱。七日中已尔许日过。过七日已汝当死。我闻是声虽作阎浮提王上妙五欲。忧苦深故不闻不见。以是故知苦力多乐力弱。若人遍身受乐。得一处针刺众乐皆失但觉刺苦。乐力弱故。二分乃强苦力多故一处足明。问曰。行是四无量心。得何等果报。答曰。佛说入是慈三昧。现在得五功德。入火不烧。中毒不死。兵刃不伤。终不横死。善神拥护。以利益无量众生故。得是无量福德。以是有漏无量心。缘众生故生清净处。所谓色界。问曰。何以故。佛说慈报生梵天上。答曰。以梵天众生所尊贵。皆闻皆识故。佛在天竺国。天竺国常多婆罗门。婆罗门法所有福德尽愿生梵天。若众生闻行慈生梵天。皆多信向行慈法。以是故说行慈生梵天。复次断淫欲天皆名为梵。说梵皆摄色界。以是故断淫欲法名为梵行。离欲亦名梵。若说梵则摄四禅四无色定。复次觉观难灭故。不说上地名。譬如五戒中口律仪。但说一种不妄语则摄三事。问曰。慈有五功德。悲喜舍何以不说有功德。答曰。如上譬喻。说一则摄三事此亦如是。若说慈则已说悲喜舍。复次慈是真无量。慈为如王余三随从如人民。所以者何。先以慈心欲令众生得乐。见有不得乐者故生悲心。欲令众生离苦心得法乐故生喜心。于三事中。无憎无爱无贪无忧故生舍心。复次慈以乐与众生故。增一阿含中说有五功德悲心。于摩诃衍经处处说其功德。如明网菩萨经中说。菩萨处众生中。行三十二种悲。渐渐增广转成大悲。大悲是一切诸佛菩萨功德之根本。是般若波罗蜜之母。诸佛之祖母。菩萨以大悲心故。得般若波罗蜜。得般若波罗蜜故得作佛。如是等种种赞大悲。喜舍心余处亦有赞。慈悲二事遍大故。佛赞其功德。慈以功德难有故。悲以能成大业故。问曰。佛说四无量功德。慈心好修善修福极遍净天。悲心好修善修福极虚空处。喜心好修善修福极识处。舍心好修善修福极无所有处。云何言慈果报应生梵天上。答曰。诸佛法不可思议。随众生应度者如是说。复次从慈定起。回向第三禅易。从悲定起向虚空处。从喜定起入识处。从舍定起。入无所有处易故。复次慈心愿令众生得乐。此果报自应受乐。三界中遍净最为乐故。言福极遍净。悲心观众生老病残害苦行者怜愍心生。云何令得离苦。若为除内苦外苦复来。若为除外苦内苦复来。行者思惟有身必有苦。唯有无身乃得无苦。虚空能破色。是故福极虚空处。喜心欲与众生心识乐。心识乐者。心得离身如鸟出笼。虚空处心虽得出身。犹系心虚空识处无量。于一切法中皆有心识。识得自在无边。以是故喜福极在识处。舍心者。舍众生中苦乐。苦乐舍故得真舍法。所谓无所有处。以是故舍心福。极无所有处。如是四无量。但圣人所得非凡夫。复次佛知未来世诸弟子钝根故。分别着诸法。错说四无量相。是四无量心。众生缘故但是有漏。但缘欲界故。无色界中无。何以故。无色界不缘欲界故。为断如是人妄见故。说四无量心无色界中。佛以四无量心。普缘十方众生故。亦应缘无色界中。如无尽意菩萨问中说。慈有三种。众生缘法缘无缘。论者言。众生缘是有漏无缘是无漏。法缘或有漏或无漏。如是种种略说四无量心。四无色定者。虚空处识处无所有处非有想非无想处。是四无色有三种。一者有垢。二者生得。三者行得。有垢者。无色中摄三十一结。及此结使中起心相应行。生得者。行是四无色定业报因缘故。生无色界得不隐没无记四众。行得者。观是色粗恶重苦老病杀害等种种苦恼因缘。如重病如痈疮如毒刺。皆是虚诳妄语应当除却。如是思惟已。过一切色相。灭一切有对相。不念一切异相。入无边虚空处定。问曰。云何能灭是三种相。答曰。是三种相。皆从因缘和合生故无自性。自性无故。是三种虚诳无实易可得灭。复次是色分别分分破散后皆无。以是故若后无今亦无。众生颠倒故。于和合色中。取一相异相心着色相。我今不应随愚人学。当求实事。实事中无是一相异相。复次行者作是念。我若除却离诸法得利为深。我先舍财物妻子。出家得清净持戒。心安隐不怖不畏。离诸欲诸恶不善法。离生喜乐得初禅。离觉观内清净故。得第二禅中大喜乐。离喜在第三禅地。于诸乐中最第一。舍是乐得念舍清净第四禅。今舍是四禅。应更得妙定。以是故过是色相。灭有对相不念异相。佛说三种色。有色可见有对。有色不可见有对。有色不可见无对。过色相者。是可见有对色。灭有对相者。是不可见有对色。不念异相者。是不可见无对色。复次眼见色坏故名过色。耳声鼻香舌味身触坏故过有对相。于二种余色及无教色种种分别故名异相。如是观离色界中染。得无边虚空处。得三无色。因缘方便如禅波罗蜜品中说。是四无色一常有漏三当分别。虚空处或有漏或无漏。有漏者。虚空处摄有漏四众。无漏者虚空处摄无漏四众。识处无所有处亦如是。一切皆有为善。有漏虚空处是有报无记。及无漏虚空处是无报。识处无所有处亦如是。善非有想非无想处是有报无记。非有想非无想处是无报。善四无色定是可修无记。四无色定非可修。隐没者是有垢。不隐没者是无垢。一有三中。有漏者是有。无漏者是非有。四无色定摄。心心数法是相应因。心不相应诸行是非相应因。有善法非四无色中。有四无色中非善法。有亦善法亦四无色中。有非善法亦非四无色中。有善法非四无色者。一切善色众。及四无色不摄四众及智缘尽。有四无色中非善法者。无记四无色。有亦善法亦四无色者。善四无色。有非善法亦非四无色者。一切不善五众。及无记色众。及四无色不摄无记四众虚空。及非智缘尽。不善法中不相摄。有无记法非四无色。有四无色非无记法。有亦无记法亦四无色。有非无记亦非四无色。有无记法非四无色者。无记色众及四无色不摄无记四众虚空及非智缘尽。有四无色中非无记法者。善四无色。亦无记法亦四无色者。无记四无色。亦非无记法亦非四无色者。不善五众善色众无色不摄善四众及智缘尽。或漏非四无色或四无色非漏。或漏亦四无色或非漏亦非四无色。漏非四无色者。一漏及二漏少分。四无色非漏者。漏不摄四无色。亦漏亦四无色者。二漏少分非漏非四无色者。色众及漏无色不摄四众及无为法。或有漏非四无色。或四无色非有漏。或有漏亦四无色。或非有漏非四无色。有漏非四无色者。有漏色众。及无色不摄有漏四众。四无色非有漏者。三无色少分。亦有漏亦四无色者。一无色及三无色少分。亦非有漏非四无色者。无漏色众无色不摄无漏四众及三无为。或无漏非四无色。或四无色非无漏。或无漏亦四无色。或非无漏亦非四无色。无漏非四无色者。无漏色众及无色不摄无漏四众。及三无为。四无色非无漏者。一无色及三无色少分。亦无漏亦四无色者。三无色少分。非无漏非四无色者。有漏色众及无色不摄有漏四众。虚空处或见谛断或思惟断或不断。见谛断者。信行法行人。用见谛忍断。何者是二十八使。及二十八使相应。虚空处及此起心不相应诸行。思惟断者。学见道用思惟断。何者是思惟所断。三使及此相应虚空处。及此起心不相应诸行。及无垢有漏虚空处。不断者。无漏虚空处。识处无所有处亦如是。非有想非无想处。或见谛断或思惟断。见谛断者信行法行人。用见谛忍断。何者是二十八使。及此相应非有想非无想处。及此起心不相应诸行。思惟断者。学见道用思惟断。何者是思惟所断。三使及此相应非有想非无想处。及此起心不相应诸行。及无垢非有想非无想处。四无色中摄心不相应诸行。是非心非心数法非心相应。受众想众及此相应行众是心数法。亦心相应心意识独心四无色。或有随心行非受相应。或受相应非随心行。或随心行亦受相应。或非随心行非受相应。随心行非受相应者。随心行心不相应诸行及受。受相应不随心行者心是。随心行亦受相应者。想众及此相应行众。非随心行非受相应者。除随心行心不相应诸行。余残心不相应诸行想相应行相应。亦应如是说。虚空处或从身见因不还与身见作因。或从身见因亦还与身见作因。或不从身见因。亦不还与身见作因。从身见因不还与身见作因者。除过去现在见苦断诸使及此相应虚空处。亦除过去现在见集断诸边结及此相应虚空处。亦除未来世中身见及相应虚空处。亦除身见生老住灭。余残有垢虚空处。从身见因亦还与身见作因者。上所除者是。亦不从身见因亦不还与身见作因者。无垢虚空处。识处无所有处非有想非无想处亦如是。四无色定一切有因缘亦与因缘。虚空处或次第不与次第缘。或次第亦与次第缘。或非次第亦不与次第缘。次第不与次第缘者未来世中欲生。心心数法虚空处及阿罗汉。过去现在最后灭时。心心数虚空处。次第亦与次第缘者。除过去现在阿罗汉最后灭时。心心数虚空处。余残过去现在心心数法虚空处。非次第。亦不与次第缘者。除未来世中。欲生心心数虚空处。余残未来世中心心数虚空处。及心不相应诸行。识处无所有处亦如是。非有想非无想处。或次第不与次第缘。或次第亦与次第缘。或非次第亦不与次第缘。次第不与次第缘者。未来世中欲生心心数法非有想非无想处。及阿罗汉。过去现在最后灭时心心数法非有想非无想处及灭受想。若生若欲生。次第亦与次第缘者。除过去现在阿罗汉最后灭时心心数非有想非无想处。余残过去现在心心数非有想非无想处。非次第亦非与次第缘者。除未来世中欲生心心数非有想非无想处。余残未来世中心心数非有想非无想处。除心次第心不相应诸行。余残心不相应诸行。四无色中摄诸心心数法有缘亦与缘缘。四无色摄心不相应诸行非缘与缘缘。四无色皆是增上。亦与增上缘。如是等种种分别四无色。如阿毗昙分中说。此中应广说。问曰。摩诃衍中。四无色云何。答曰。与诸法实相共智慧行。是摩诃衍中四无色。问曰。何等是诸法实相。答曰。诸法诸法自性空。问曰。色法和合分别因缘故空。此无色中云何空。答曰。色是眼见耳闻粗事能令空。何况不可见无有对。不觉苦乐而不空。复次色法分别。乃至微尘皆散灭归空。是心心数法。在日月时节须臾顷乃至一念中不可得。是名四无色定义。如是等种种。略说四无色

大智度论卷第二十大智度论释初品中八背舍义第三十四(卷二十一)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

八背舍者。内有色外亦观色是初背舍。内无色外观色是第二背舍。净背舍身作证第三背舍。四无色定及灭受想定。是五。合为八背舍。背是净洁五欲。离是着心故名背舍。不坏内外色。不内外灭色相。以是不净心观色。是名初背舍。坏内色灭内色相。不坏外色不灭外色相。以是不净心观外色。是第二背舍。是二皆观不净。一者观内观外。二者不见内但见外。何以故。众生有二分行。爱行见行。爱多者着乐多缚在外诸结使行。见多者多着身见等行。为内结使缚。以是故爱多者观外色不净。见多者观自身不净坏败故。复次行者初心未细摄系心一处难。故内外观渐习调柔。能内坏色相但观外。问曰。若无内色相谁当观外。答曰。是为得解道。非实道。行者念未来死及火烧虫啖埋着土中皆磨灭。若现在观亦分别是身。乃至微尘皆无。是名内无色相外观色。问曰。二胜处见内外色。六胜处但见外色。一背舍见内外色二背舍但见外色。何以故但内有坏色相。外色不能坏。答曰。行者眼见是身有死相。取是未来死相以况今身。外四大不见灭相故。难可观无故。不说外色坏。复次离色界时。是时亦不见外色。净背舍身作证者。不净中净观。如八胜处说。前八一切处。观清净地水火风及青黄赤白。观青色如青莲华。如金精山。如优摩伽华。如真青婆罗捺衣。观黄赤白各随色亦复如是。总名净背舍。问曰。若总是净背舍。不应说一切处。答曰。背舍是初行者。胜处是中行。一切处是久行。不净观有二种。一者不净二者净。不净观中二背舍四胜处。净观中一背舍四胜处。八一切处。问曰。行者以不净为净名为颠倒。净背舍观云何不颠倒。答曰。女色不净妄见为净。是名颠倒。净背舍观。一切实青色广大故不颠倒。复次为调心故。净观以久习。不净观心厌。以是故习净观非颠倒。亦是中不着故。复次行者先观身不净。随身法所有内外不净系心观中。是时生厌淫恚痴薄即自惊悟。我为无目此身如是。云何生着。摄心实观无令复错。心既调柔想身皮肉血髓不净除却。唯有白骨系心骨人。若外驰散摄之令还。深摄心故见白骨流光。如珂如贝能照内外诸物。是为净背舍初门。然后观骨人散灭。但见骨光取外净洁色相。复次若金刚真珠金银宝物。若清净地若净水。如无烟无薪净洁火。若清风无尘。诸青色如金精山。诸黄色如瞻卜花。诸赤色如赤莲华。诸白色如白雪等。取是相系心净观随是诸色。各有清净光曜。是时行者得受喜乐遍满身中。是名净背舍。缘净故名为净背舍。遍身受乐故名为身证。得是心乐背舍五欲不复喜乐。是名背舍。未漏尽故。中间或结使心生随着净色。复勤精进断此着故。如是净观从心想生。譬如幻主观所幻物。知从己出心不生着能不随所缘。是时背舍变名胜处。于净观虽胜未能广大。是时行者还取净相。用背舍力及胜处力故。取是净地相。渐渐遍满十方虚空。水火风亦尔。取青相渐令广大亦遍十方虚空。黄赤白亦如是。是时胜处复变为一切处。是三事一义转变有三名。问曰。是三背舍八胜处十一切处。是实观。是得解观。若实观。身有皮肉何以但见白骨。又三十六物合为身法。何以分别散观。四大各自有相。何以灭三大。但观一地大。四色非尽是青。何以都作青观。答曰。有实观亦有得解观。身相实是不净。是为实观。外法中有净相种种色相。是为实净观。净不净是为实观。以此少许净。广观一切皆是净。取是一水遍观一切皆是水。取是少许青相。遍一切皆是青。如是等是为得解观非实。四无色背舍。如四无色定中观。欲得背舍先入无色定。无色定是背舍之初门。背舍色缘无量虚空处。问曰。无色定亦尔有何等异。答曰。凡夫人得是无色定是为无色。圣人深心得无色定一向不回。是名背舍。余残识处无所有处非有想非无想处亦如是。背灭受想诸心心数法。是名灭受想背舍。问曰。无想定何以不名背舍。答曰。邪见者不审诸法过失。直入定中谓是涅槃。从定起时还生悔心堕在邪见。是故非背舍。灭受想患厌散乱心故。入定休息似涅槃法。着身中得故名身证。八胜处者。内有色相外观色少。若好若丑是色胜知胜观。是名初胜处。内有色相外观色多。若好若丑是色胜知胜观。是名第二胜处。第三第四亦如是。但以内无色相外观色为异。内亦无色相。外观诸色青黄赤白。是为八胜处。内有色相外观色者。内身不坏见外缘少者。缘少故名少。观道未增长故观少因缘。观多畏难摄故。譬如鹿游未调不中远放。若好若丑者。初学系心缘中。若眉间若额上若鼻端。内身不净相内身中不净相。观外诸色善业报故名好。不善业报故名丑

复次行者如从师所受观外缘种种不净。是名丑色。行者或时忆念忘故。生净相观净色是名好色。复次行者自身中系心一处。观欲界中色二种。一者能生淫欲。二者能生嗔恚。能生淫欲者。是净色名为好。能生嗔恚者。是不净色名为丑。于缘中自在胜知胜见。行者于能生淫欲端正色中不生淫欲。于能生嗔恚恶色中不生嗔恚。但观色四大因缘和合生。如水沫不坚固。是名若好若丑。胜处者行者住是不净门中。淫欲嗔恚等诸结使来能不随是名胜处。胜是不净中净颠倒等诸烦恼贼故。问曰。行者云何内色相外观色。答曰。是八胜处。深入定心调柔者可得。行者或时见内身不净。亦见外色不净。不净观有二种。一者三十六物等种种不净。二者除内外皮肉五藏。但观白骨如珂如雪。三十六物等观是名丑。如珂如雪观是名好。行者内外观时心散乱难入禅。除自身相但观外色。如阿毗昙中说。行者以得解脱观见是身死。死已举出冢间。若火烧若虫啖皆已灭尽。是时但见虫火不见身。是名内无色相外观色。行者如教受观身是骨人。若心外散还摄骨人缘中。何以故。是人初习行。未能观细缘故。是名少色。行者观道转深增长。以此一骨人。遍观阎浮提皆是骨人。是名为多。还复摄念观一骨人。以是故名胜知胜见。复次随意五欲中。男女相净洁相。能胜故名为胜处。譬如健人乘马系贼。能破是名为胜。又能制御其马。是亦名胜。行者亦如是。能自于不净观中。少能多多能少。是为胜处。亦能破五欲贼亦名胜处。内未能坏身外观色。若多若少若好若丑。是初第二胜处。内坏身无色相观外色。若多若少若好若丑。是第三第四胜处。摄心深入定中坏内身。观外净缘青青色黄赤白白色。是为后四胜处。问曰。是后四胜处。十一切处中青等四处。有何等异。答曰。青一切处。能普缘一切令青是胜处若多若少随意观。不令异心夺。观胜是缘名为胜处。譬如转轮圣王。遍胜四天下。阎浮提王胜一天下而已。一切处普遍胜一切缘。胜处但观少色能胜。不能遍一切缘。如是等略说八胜处。十一切处者。背舍胜处已说。此以遍满缘故名一切处。问曰。何以无所有处非有想非无想处。不名一切处。答曰。是得解之心。安隐快乐广大无量无边虚空处。是佛所说。一切处中皆有识。能疾缘一切法故。一切法中皆见有识。以是故二处立一切处。无所有中无物可广。亦不得快乐佛亦不说是无所有无边无量。非有想非无想处。心钝难得取相令广大。复次虚空处近色界。亦能缘色。识处能缘缘色。又识处起能超入第四禅。第四禅起超入识处。无所有处非有想非无想处。远无色因缘故非一切处。是三种法皆行得胜处。一切处是有漏。初三背舍第七第八背舍是有漏。余残或有漏或无漏。初二背舍初四胜处。初禅二禅中摄。净背舍后四胜处八一切处。第四禅中摄。二一切处即名说空处。空处摄识处。识处摄前三背舍八胜处八一切处。皆缘欲界。后四背舍缘无色界及无漏法诸妙功德。在根本中。若无色根本不缘下地故。灭受想定非心心数法故无缘。非有想非无想处背舍。但缘无色四阴及无漏法。九次第定者。从初禅心起。次第入第二禅。不令余心得入。若善若垢如是乃至灭受想定。问曰。余者亦有次第。何以但称九次第定。答曰。余功德皆有异心间生故非次第此中深心智慧利行者自试其心。从一禅心起次入二禅。不令异念得入。于此功德心柔软善断法爱故。能心心相次。是次第二是有漏七或有漏或无漏禅。中间未到地不牢固。又是圣人所得。又此大功德不在边地。是故无次第。八背舍八胜处十一切处九次第定声闻法中略说

    大智度论释初品中九相义第三十五

【经】九相胀相坏相血涂相脓烂相青相啖相散相骨相烧相

【论】问曰。应当先习九相离欲然后得诸禅。何以故诸禅定后方说九相。答曰。先说果报。令行者心乐。九相虽是不净。人贪其果报故必习行。问曰。行者云何观是胀相等九事。答曰。行者先持戒清净令心不悔故。易受观法。能破淫欲诸烦恼贼。观人初死之日。辞诀言语息出不反奄忽已死。室家惊恸号哭呼天言说方尔。奄便那去气灭身冷无所觉识。此为大畏无可免处。譬如劫尽火烧无有遗脱。如说

  死至无贫富　　无勤修善恶
  无贵亦无贱　　老少无免者
  无祈请可救　　亦无欺诳离
  无捍挌得脱　　一切无免处

死法名为永离恩爱之处。一切有生之所恶者。虽甚恶之无得脱者。我身不久必当如是同于木石无所别知。我今不应贪着五欲不觉死至同于牛羊。牛羊禽兽虽见死者。跳腾哮吼不自觉悟。我既得人身识别好丑。当求甘露不死之法如说

  六情身完具　　智鉴亦明利
  而不求道法　　唐受身智慧
  禽兽亦皆知　　欲乐以自恣
  而不知方便　　为道修善事
  既已得人身　　而但自放恣
  不知修善行　　与彼亦何异
  三恶道众生　　不得修道业
  已得此人身　　当勉自益利

行者到死尸边。见死尸膖胀。如韦囊盛风。异于本相心生厌畏。我身亦当如是未脱此法。身中主识役御此身。视听言语作罪作福。以此自贵为何所趣。而今但见空舍在此。是身好相细腰姝媚长眼直鼻平额高眉。如是等好令人心惑。今但见膖胀好在何处。男女之相亦不可识。作此观已呵着欲心。此臭屎囊膖胀可恶何足贪着。死尸风热转大裂坏在地。五藏屎尿脓血流出恶露已现。行者取是坏相以况己身。我亦如是皆有是物与此何异。我为甚惑为此屎囊薄皮所诳。如灯蛾投火。但贪明色不知烧身。已见裂坏男女相灭。我所著者亦皆如是。死尸已坏肉血涂漫。或见杖楚死者青瘀黄赤。或日曝瘀黑。具取是相观。所著者若赤白之色净洁端正与此何异。既见青瘀黄赤鸟兽不食。不埋不藏不久脓烂种种虫生。行者见已念此死尸本有好色。好香涂身衣以上服饰以华彩。今但臭坏脓烂涂染。此是其实分。先所饰彩皆是假借。若不烧不埋弃之旷野。为鸟兽所食。乌挑其眼狗分手脚。虎狼刳腹分掣[國*瓜]裂。残藉在地有尽不尽。行者见已心生厌想。思惟此尸未坏之时人所著处。而今坏败无复本相但见残藉。鸟兽食处甚可恶畏。鸟兽已去风日飘曝。筋断骨离各各异处。行者思惟本见身法和合而有身相。男女皆可分别。今已离散各在异处。和合法灭身相亦无皆异于本。所可爱着今在何处。身既离散处处白骨。鸟兽食已唯有骨在。观是骨人是为骨相。骨相有二种。一者骨人筋骨相连。二者骨节分离。筋骨相连破男女长短好色细滑之相。骨节分离破众生根本实相。复有二种。一者净二者不净。净者久骨白净无血无腻色如白雪。不净者余血涂染腻膏未尽。行者到尸林中。或见积多草木焚烧死尸。腹破眼出皮色燋黑甚可恶畏。须臾之间变为灰烬。行者取是烧相思惟。此身未死之前。沐浴香华五欲自恣。今为火烧甚于兵刃。此尸初死形犹似人。火烧须臾本相都失。一切有身皆归无常我亦如是。是九相断诸烦恼。于灭淫欲最胜。为灭淫欲故说是九相。问曰。无常等十想为灭何事故说。答曰。亦为灭淫欲等三毒。问曰。若尔者二相有何等异。答曰。九相为遮未得禅定为淫欲所覆故。十想能除灭淫欲等三毒。九相如缚贼十想如斩杀。九相为初学。十想为成就。复次是十想中。不净想摄九相。有人言。十想中不净想食不净想世间不可乐想。摄九相。复有人言。十想九相同为离欲俱为涅槃。所以者何。初死相动转言语须臾之间忽然已死。身体膖胀烂坏分散各各变异是则无常。若着此法无常坏时是即为苦。若无常苦无得自在者。是则无我。不净无常苦无我则不可乐。观身如是。食虽在口脑涎流下与唾和合成味。而咽与吐无异下入腹中即是食不净想。以此九相观身无常变异。念念皆灭即是死想。以是九相厌世间乐。知烦恼断则安隐寂灭即是断相。以是九相遮诸烦恼即是离想。以是九相厌世间故。知此五众灭。更不复生是处安隐。即是尽想。复次九相为因。十想为果。是故先九相后十想。复次九相为外门。十想为内门。是故经言。二为甘露门。一者不净门。二者安那般那门。是九相除人七种染着。或有人染着色。若赤若白若赤白若黄若黑。或有人不着色但染着形容。细肤纤指修目高眉。或有人不着容色但染着威仪。进止坐起行住礼拜俯仰扬眉顿睫亲近按摩。或有人不着容色威仪。但染着言语。软声美辞随时而说。应意承旨能动人心。或有人不着容色威仪软声。但染着细滑柔肤软肌。热时身凉寒时体温。或有人皆着五事。或有人都不着五事但染着人相。若男若女虽得上六种欲。不得所著之人犹无所解。舍世所重五种欲乐而随其死。死相多除威仪语言爱。膖胀相坏相啖相散相多除形容爱。血涂相青瘀相脓烂相。多除色爱。骨相烧相多除细滑爱。九相除杂爱及所著人爱。啖相散相骨相偏除人爱。啖残离散白骨中不见有人可着。以是九相观离爱心。嗔痴亦微薄。不净中净颠倒。痴故着是身。今以是九相披析身内。见是身相痴心薄。痴心薄则贪欲薄。贪欲薄则嗔亦薄。所以者何。人以贪身故生嗔。今观身不净心厌故不复贪身。不贪身故不复生嗔。三毒薄故一切九十八使山皆动。渐渐增进其道。以金刚三昧摧碎结山。九相虽是不净观。依是能成大事。譬如大海中臭尸溺人依以得渡。问曰。是九相有何性何所缘何处摄。答曰。取相性缘。欲界身色相阴摄。亦身念处少分。或欲界摄。或初禅二禅四禅摄。未离欲散心人得欲界系。离欲人心得色界系。膖胀等八相。欲界初禅二禅中摄。净骨相欲界初禅二禅四禅中摄。三禅中多乐故无是相。是九相是开身念处门。身念处开三念处门。是四念处开三十七品门三十七品开涅槃城门。入涅槃离一切忧恼诸苦。灭五阴因缘生故。受涅槃常乐。问曰。声闻人如是观心厌离。欲疾入涅槃。菩萨怜愍一切众生。集一切佛法度一切众生。不求疾入涅槃故观是九相。云何不堕二乘证。答曰。菩萨于众生心生怜愍。知众生以三毒因缘故。受今世后世身生苦痛。是三毒终不自灭。亦不可以余理得灭。但观所著内外身相。然后可除。以是故菩萨欲灭是淫欲毒故。观是九相。如人怜愍病者。合和诸药以疗之。菩萨亦如是。为着色众生。说是青瘀相等。随其所著分别诸相如先说。是为菩萨行九相观

复次菩萨。以大慈悲心行是九相作如是念。我未具足一切佛法不入涅槃。是为一法门。我不应住此一门。我当学一切法门。以是故菩萨行九相无所妨。菩萨行是九相。或时厌患心起。如是不净身可恶可患。欲疾取涅槃。尔时菩萨作是念。十方诸佛说一切法相空。空中无无常。何况有不净。但为破净颠倒故习此不净。是不净皆从因缘和合生。无有自性皆归空相。我今不应取是因缘和合生。无自性不净法。欲疾入涅槃。经中亦有是说。若色中无味相。众生不应着色。以色中有味故众生起着。若色无过罪。众生亦无厌色者。以色实有过恶故观色则厌。若色中无出相。众生亦不能于色得脱。以色有出相故。众生于色得解脱。味是净相因缘故。以是故菩萨不于不净中没早取涅槃。九相义分别竟

    大智度论释初品中八念义第三十六之一

【经】念佛念法念僧念戒念舍念天念入出息念死

【论】问曰。何以故九相次第有八念。答曰。佛弟子于阿兰若处空舍冢间山林旷野。善修九相内外不净观。厌患其身而作是念。我云何担是底下不净屎尿囊。自随懎然惊怖。及为恶魔作种种恶事来恐怖之欲令其退。以是故佛次第为说八念。如经中说。佛告诸比丘。若于阿兰若处空舍冢间山林旷野。在中思惟。若有怖畏衣毛为竖。尔时当念佛。佛是多陀阿伽度阿罗呵三藐三佛陀乃至婆伽婆。恐怖则灭。若不念佛当疾念法。佛法清净巧出善说。得今世报指示开发。有智之人心力能解。如是念法怖畏则除。若不念法则当念僧。佛弟子众修正道随法行。僧中有阿罗汉向阿罗汉乃至须陀洹向须陀洹四双八辈。是佛弟子众。应供养合手恭敬礼拜迎送。世间无上福田。作如是念僧恐怖即灭

佛告诸比丘。释提桓因与阿修罗斗在大阵中。时告诸天众汝与阿修罗斗时。设有恐怖当念我七宝幢恐怖即灭。若不念我幢当念伊舍那天子(帝释左面天王也)宝幢恐怖即除。若不念伊舍那宝幢。当念婆楼那天子(右面天子)宝幢恐怖即除。以是故知为除恐怖因缘故。次第说八念。问曰。经中说三念因缘除恐怖。五念复云何能除恐怖。答曰。是比丘自念布施持戒功德。怖畏亦除。所以者何。若破戒心畏堕地狱。若悭贪心畏堕饿鬼及贫穷中。自念我有是净戒布施。若念净戒若念布施。心则欢喜作是言。若我命未尽当更增进功德。若当命终不畏堕恶道。以是故念戒施。亦能令怖畏不生。念上诸天皆是布施持戒果报。此诸天以福德因缘故生彼。我亦有是福德。以是故念天。亦能令怖畏不生。十六行念安那般那时细觉尚灭。何况恐怖粗觉念。死者念五众身念念生灭。从生已来常与死俱。今何以畏死。是五念佛虽不说。亦当除恐怖。所以者何。念他功德以除恐怖则难。自念己事以除恐怖则易。以是故佛不说。问曰。云何是念佛。答曰。行者一心念佛。得如实智慧。大慈大悲成就。是故言无错谬。粗细多少深浅皆无不实。皆是实故名为多陀阿伽度。亦如过去未来现在十方诸佛。于众生中起大悲心。行六波罗蜜得诸法相。来至阿耨多罗三藐三菩提中。此佛亦如是。是名多陀阿伽度。如三世十方诸佛身。放大光明遍照十方破诸黑闇。心出智慧光明。破众生无明闇冥。功德名闻亦遍满十方。去至涅槃中。此佛亦如是去。以是故亦名多陀阿伽度。有如是功德故。应受一切诸天世人最上供养。是故名阿罗呵。若有人言。何以故。但佛如实说。如来如去故。应受最上供养。以佛得正遍智慧故。正名诸法不动不坏相。遍名不为一法二法。故以悉知一切法无余不尽。是名三藐三佛陀。是正遍智慧。不从无因而得。亦不从无缘得。是中依智慧持戒具足故。得正遍智慧。智慧名菩萨从初发意乃至金刚三昧相应智慧。持戒名菩萨从初发意乃至金刚三昧身业口业清净随意行已。是故名鞞阇遮罗那三般那若。行是二行得善去。如车有两轮善去者。如先佛所去处。佛亦如是去。故名修伽陀。若有言。佛自修其法不知我等事。以是故知世间知世间因知世间尽知世间尽道。故名为路迦惫。知世间已调御众生。于种种师中最为无上。以是故名阿耨多罗富楼沙昙藐婆罗提。能以三种道灭三毒。令众生行三乘道。以是故名贳多提婆魔[少/兔]舍。若有言。以何事故能自利益无量。复能利益他人无量。佛一切智慧成就故。过去未来现在。尽不尽动不动。一切世间了了悉知。故名为佛陀。得是九种名号。有大名称遍满十方。以是故名为婆伽婆。经中佛自说。如是名号应当作是念佛。复次一切种种功德。尽在于佛。佛是劫初转轮圣王摩诃三磨陀等种。阎浮提中智慧威德。诸释子中生贵性憍昙氏。生时光明遍照三千大千世界。梵天王持宝盖。释提桓因以天宝衣承接。阿那婆蹋多龙王婆伽多龙王。以妙香汤澡浴。生时地六种动。行至七步安详如象王。观视四方作师子吼。我是末后身。当度一切众生。阿私陀仙人相之告净饭王。是人足下千辐轮相指合缦网。当自于法中安平立。无能动无能坏者。手中德字缦网庄严。当以此手安慰众生令无所畏。如是乃至肉骨髻相。如青珠山顶。青色光明从四边出。头中顶相无能见上。若天若人无有胜者。白毫眉间跱。白光踰颇梨。净眼长广其色绀青。鼻高直好甚可爱乐。口四十齿白净利好。四牙上白其光最胜。唇上下等不大不小不长不短。舌薄而大软赤红色如天莲华。梵声深远闻者悦乐听无厌足。身色好妙胜阎浮檀金。大光周身种种杂色妙好无比。如是等三十二相具足。是人不久出家得一切智成佛。佛身功德如是应当念佛。复次佛身功德身力。胜于十万白香象宝。是为父母遗体力。若神通功德力无量无限。佛身以三十二相八十随形好庄严。内有无量佛法功德故视之无厌。见佛身者忘世五欲万事不忆。若见佛身。一处爱乐无厌不能移观佛身功德如是。应当念佛

复次佛持戒具足清净。从初发心修戒增积无量。与怜愍心俱不求果报。不向声闻辟支佛道。不杂诸结使。但为自心清净不恼众生故。世世持戒。以是故得佛道时戒得具足。应如是念佛戒众。复次佛定众具足。问曰。持戒以身口业清净故可知。智慧以分别说法能除众生疑故可知。定者余人修定尚不可知。何况于佛云何得知。答曰。大智慧具足故当知禅定必具足。譬如见莲华大必知池亦深大。又如灯明大者必知苏油亦多。亦以佛神通变化力无量无比故。知禅定力亦具足。亦如见果大故知因亦必大。复次有时佛自为人说。我禅定相甚深。如经中说。佛在阿头摩国林树下坐入禅定。是时大雨雷电霹雳。有四特牛耕者二人。闻声怖死。须臾便晴。佛起经行。有一居士礼佛足已。随从佛后白佛言。世尊。向者雷电霹雳。有四特牛耕者二人闻声怖死。世尊闻不。佛言。不闻。居士言。佛时睡耶。佛言不睡。问曰。入无心想定耶。佛言。不也。我有心想但入定耳。居士言。未曾有也。诸佛禅定大为甚深。有心想在禅定。如是大声觉而不闻。如余经中。佛告诸比丘。佛入出诸定。舍利弗目揵连尚不闻其名。何况能知何者是。如三昧王三昧师子游戏三昧等。佛入其中能令十方世界六种震动。放大光明化为无量诸佛遍满十方。如阿难一时心生念。过去然灯佛时。时世好人寿长易化度。今释迦牟尼佛时世恶人寿短难教化。佛事未讫而入涅槃耶。清旦以是事白佛。已日出。佛时入日出三昧。如日出光明照阎浮提。佛身如是毛孔普出光明。遍照十方恒河沙等世界。一一光中出七宝千叶莲华。一一华上皆有坐佛。一一诸佛皆放无量光明。一一光中皆出七宝千叶莲华。一一华上皆有坐佛。是诸佛等遍满十方恒河沙等世界教化众生。或有说法或有默然或以经行。或神通变化身出水火。如是等种种方便。度脱十方五道众生。阿难承佛威神悉见是事。佛摄神足从三昧起。告阿难。见是事不。闻是事不。阿难言。蒙佛威神已见已闻。佛言。佛有如是力能究竟佛事不。阿难言。世尊。若众生满十方恒河沙等世界中。佛寿一日用如是力必能究竟施作佛事。阿难叹言。未曾有也。世尊。诸佛法无量不可思议。以是故知佛禅定具足。复次佛慧众具足。从初发心于阿僧祇劫中无法不行。世世集诸功德。一心专精不惜身命以求智慧。如萨陀波仑菩萨。复次以善修大悲智慧故具足慧众。余人无是大悲。虽有智慧不得具足大悲。欲度众生求种种智慧故。及断法爱灭六十二邪见不堕二边。若受五欲乐若修身苦道。若断灭若计常若有若无等。如是诸法边。复次佛慧无上彻鉴无比。从甚深禅定中生故。诸粗细烦恼所不能动故。善修三十七品四禅四无量心四无色定八背舍九次第定等诸功德故。有十力四无所畏四无碍智十八不共法。得无碍不可思议解脱故。佛慧众具足。复次能降伏外道大论议师。所谓忧楼频蠡迦叶摩诃迦叶舍利弗目揵连萨遮尼揵子婆蹉首罗长爪等。大论议师辈皆降伏。是故知佛慧众具足。复次佛三藏十二部经。八万四千法聚。见是语言多故。知智慧亦大。譬如一居士清朝见大雨处语众人言。昨夜雨龙其力甚大。众人言。汝何以知之。答言。我见地湿泥多山崩树折杀诸鸟兽。以此故知龙力为大。佛亦如是。甚深智慧虽非眼见。雨大法雨诸大论议师及释梵天王皆以降伏。以是可知佛智慧多。复次诸佛得无碍解脱故。于一切法中智慧无碍。复次佛此智慧皆清净出诸观上。不观诸法常相无常相有边相无边相有去相无去相有相无相有漏相无漏相有为相无为相生灭相不生灭相空相不空相。常清净无量如虚空。以是故无碍。若观生灭者。不得观不生灭。观不生灭者。不得观生灭。若不生灭实生灭不实。若生灭实不生灭不实。如是等诸观皆尔。得无碍智故。知佛慧众具足。复次念佛解脱众具足。佛解脱诸烦恼及习。根本拔故。解脱真不可坏。一切智慧成就故。名为无碍解脱。成就八解脱。甚深遍得故。名为具足解脱。复次离时解脱及慧解脱故。便具足成就共解脱。成就如是等解脱故。名具足解脱众。复次破魔军故得解脱。离烦恼故得解脱。离遮诸禅法故得解脱。于诸禅定入出自在无碍故。复次菩萨于见谛道中。得深十六解脱。一苦法智相应有为解脱。二苦谛断十结尽得无为解脱。如是乃至道比智。思惟道中得十八解脱。一或比智或法智相应有为解脱。二断无色界三思惟结故得无为解脱。如是乃至第十八。尽智相应有为解脱及一切结使尽得无为解脱。如是诸解脱和合。名为解脱众具足。复次念佛解脱知见众具足。解脱知见众有二种。一者佛于解脱诸烦恼中。用尽智自证知。知苦已断集已尽证已修道已。是为尽智解脱知见众。知苦已不复更知。乃至修道已不复更修。是为无生智解脱知见众。二者佛知是人入空门得解脱。是人无相门得解脱。是人无作门得解脱。是人无方便可令解脱。是人久久可得解脱。是人不久可得解脱。是人即时得解脱。是人软语得解脱。是人苦教得解脱。是人杂语得解脱。是人见神通力得解脱。是人说法得解脱。是人淫欲多。为增淫欲得解脱。是人嗔恚多。为增嗔恚得解脱。如难陀沤楼频螺龙是。如是等种种因缘得解脱。如法眼中说。于是诸解脱中了了知见。是名解脱知见众具足。复次念佛一切智一切知见大慈大悲十力四无所畏四无碍智十八不共法等。念如佛所知无量不可思议诸功德。是名念佛。是念在七地中。或有漏或无漏。有漏者有报。无漏者无报。三根相应乐喜舍根。行得亦果报得。行得者如此间国中学念佛三昧。果报得者如无量寿佛国。人生便自然能念佛。如是等如阿毗昙中广分别

大智度论卷第二十一大智度论释初品中八念义第三十六之余(卷二十二)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

念法者。如佛演说。行者应念。是法巧出得今世果无执恼。不待时能到善处通达无碍。巧出者。二谛不相违故。所谓世谛第一义谛是。智者不能坏。愚者不起诤故。是法亦离二边。所谓若受五欲乐若受苦行。复离二边。若常若断若我若无我若有若无。如是等二边不着是名巧出。诸外道辈自贵其法。毁贱他法故不能巧出。得今世果者。离爱因缘世间种种苦。离邪见因缘种种论议斗诤。身心得安乐。如佛说

  持戒者安乐　　身心不热恼
  卧安觉亦安　　名觉亦远闻

复次此佛法中因缘展转生果。所谓持戒清净故心不悔。心不悔故生法欢喜。法欢喜故身心快乐。身心快乐故能摄心。摄心故如实知。如实知故得厌。得厌故离欲。离欲故得解脱得解脱果报得涅槃。是名得今世果。外道法空行苦无所得。如阎浮阿罗汉得道时自说

  我昔作外道　　五十有五年
  但食干牛屎　　裸形卧棘上

我受如是辛苦。竟无所得。不如今得见佛闻法。出家三日所作事办得阿罗汉。以是故知。佛法得今世果。问曰。若佛法得今世果。何以故。佛诸弟子有无所得者。答曰。行者能如佛所说。次第修行无不得报。如病人随良医教。将和治法病无不差。若不随佛教。不次第行。破戒乱心故无所得。非法不良也。复次诸未得道者。今世虽不得涅槃。后世得受福乐。渐次当得涅槃终不虚也。如佛所说。其有出家为涅槃者。若迟若疾皆当得涅槃。如是等能得今世果。无热恼者。热恼有二种。身恼心恼。身恼者。系缚牢狱拷掠刑戮等。心恼者。淫欲嗔恚悭贪嫉妒因缘故。生忧愁怖畏等。此佛法中持戒清净故。身无是系缚牢狱拷掠刑戮等恼。心离五欲除五盖得实道故。无是淫欲嗔恚悭贪嫉妒邪疑等恼。无恼故无热。复次无漏禅定。生喜乐遍身受故诸热则除。譬如人大热闷得入清凉池中。冷然清了无复热恼。复次诸烦恼。若属见若属爱是名热。佛法中无此故名无热恼。不待时者。佛法不待时而行。亦不待时与果。外道法日未出时受法。日出时不受法。或有日出时受。日未出不受。有昼受夜不受。有夜受昼不受。佛法中无受待时。随修八圣道时便得涅槃。譬如火得薪便然。无漏智慧生时。便能烧诸烦恼不待时也。问曰。如佛说。有时药时衣时食。若人善根未熟待时当得。何以言无时。答曰。此时者随世俗法。为佛法久住故。结时戒。若为修道。得涅槃及诸禅定智慧微妙法不待时也。诸外道法皆待时节。佛法但待因缘具足。若虽持戒禅定。而智慧未成就不能成道。若持戒禅定智慧皆成就便得果。不复待时。复次久久得果名为时。即得不名时。譬如好染一入便成。心净人亦如是。闻法即染得法眼净。是名不待时。能到善处者。是三十七无漏道法。能将人到涅槃。譬如入恒河必得至大海。诸余外道法。非一切智人所说。邪见杂故将至恶处。或时将至天上还堕受苦。皆无常故不名善处。问曰。无有将去者。云何得将至善处。答曰。虽无将去者。但诸法能将诸法去。无漏善五众断。五众中强名众生。将去入涅槃。如风吹尘如水漂草。虽无将去者而可有去。复次因缘和合无有作。亦无有将去者。而果报属因缘不得自在。是即名为去。通达无碍者。得佛法印故通达无碍。如得王印则无所留离。问曰。何等是佛法印。答曰。佛法印有三种。一者一切有为法。念念生灭皆无常。二者一切法无我。三者寂灭涅槃。行者知三界皆是有为生灭。作法先有今无今有后无。念念生灭相续相似生故。可得见知。如流水灯焰长风相似相续。故人以为一众生于无常法中常颠倒故。谓去者是常住。是名一切作法无常印。一切法无我。诸法内无主无作者。无知无见无生者无造业者。一切法皆属因缘。属因缘故不自在。不自在故无我我相不可得故。如破我品中说。是名无我印。问曰。何以故。但作法无常一切法无我。答曰。不作法无因无缘故。不生不灭。不生不灭故。不名为无常。复次不作法中。不生心着颠倒。以是故不说是无常。可说言无我。有人说。神是常遍知相。以是故说一切法中无我。寂灭者是涅槃。三毒三衰火灭故名寂灭印。问曰。寂灭印中何以但一法不多说。答曰。初印中说五众。二印中说一切法皆无我。第三印中说二印果。是名寂灭印。一切作法无常。则破我所外五欲等。若说无我破内我法。我我所破故。是名寂灭涅槃。行者观作法无常。便生厌厌世苦。既知厌苦存着观主。谓能作是观。以是故有第二法印。知一切无我。于五众十二入十八界十二因缘中。内外分别推求观主不可得。不可得故是一切法无我作如是知已不作戏论。无所依止但归于灭。以是故说寂灭涅槃印。问曰。摩诃衍中说诸法不生不灭一相所谓无相。此中云何说一切有为作法无常名为法印。二法云何不相违。答曰。观无常即是观空因缘。如观色念念无常。即知为空。过去色灭坏不可见故无色相。未来色不生无作无用不可见故无色相。现在色亦无住不可见不可分别知故无色相。无色相即是空。空即是无生无灭。无生无灭及生灭其实是一。说有广略

问曰。过去未来色不可见故无色相。现在色住时可见。云何言无色相。答曰。现在色亦无住时。如四念处中说。若法后见坏相当知初生时坏相。以随逐微细故不识。如人着屐。若初日新而无有故。后应常新不应有故。若无故应是常。常故无罪无福。无罪无福故。则道俗法乱。复次生灭相常随作法无有住时。若有住时则无生灭。以是故现在色无有住。住中亦无有生灭。是一念中住。亦是有为法故。是名通达无碍。如是应念法。复次法有二种。一者佛所演说三藏十二部八万四千法聚。二者佛所说法义。所谓持戒禅定智慧八圣道。及解脱果涅槃等。行者先当念佛所演说。次当念法义。念佛所演说者。佛语美妙皆真实有大饶益。佛所演说亦深亦浅。观实相故深。巧说故浅。重语无失各各有义故。佛所演说。住四处有四种功德庄严。一慧处二谛处三舍处四灭处。有四种答故不可坏。一定答二解答三反问答四置答。佛所演说或时听而遮。或时遮而听。或听而不遮。或遮而不听。此四皆顺从无违。佛说得诸法相故无戏论。有义理说故破有无论。佛演说随顺第一义。虽说世间法亦无咎。与二谛不相违故。随顺利益。说于清净人中为美妙。于不净人中为苦恶。于美语苦语中亦无过罪。佛语皆随善法。亦不着善法。虽是垢法怨家亦不以为高。虽种种有所诃。亦无有诃罪。虽种种赞法亦无所依止。佛言说中亦无增无减。或略或广。佛语初善久久研求亦善。佛语虽多义味不薄。虽种种杂语义亦不乱。虽能引人心亦不令人生爱着。虽殊异高显。亦不令人畏难。虽遍有所到。凡小人亦不能解。佛语如是有种种希有事。能令人衣毛为竖。流汗气满身体战惧。亦能令诸天心厌声满十方六种动地。亦能令人于无始世界所坚著者能令舍。所不坚著者能令乐。佛语罪恶人闻之自有罪故忧怖热恼。善一心精进入道。人闻如服甘露味。初亦好中亦好后亦好。复次多会众中。各各欲有所闻。佛以一言答。各各得解。各各自见佛独为我说。于大众中虽有远近。闻者声无增减。满三千大千世界乃至十方无量世界。应度者闻。不应度者不闻。譬如雷霆振地。聋者不闻。听者得悟。如是种种念佛言语。何等是法义信戒舍闻定慧等为道。诸善法及三法印。如通达中说。一切有为法无常。一切法无我。寂灭涅槃。是名佛法义。是三印。一切论议师所不能坏。虽种种多有所说。亦无能转诸法性者。如冷相无能转令热。诸法性不可坏。假使人能伤虚空。是诸法印如法不可坏。圣人知是三种法相。于一切依止邪见各各斗诤处得离。譬如有目人。见群盲诤种种色相。愍而笑之不与共诤。问曰。佛说声闻法有四种实。摩诃衍中有一实。今何以故说三实。答曰。佛说三种实法印。广说则四种。略说则一种。无常即是苦谛集谛道谛说。无我则一切法说。寂灭涅槃即是尽谛。复次有为法无常。念念生灭故。皆属因缘无有自在。无有自在故无我。无常无我无相故心不着。无相不着故。即是寂灭涅槃。以是故摩诃衍法中。虽说一切法不生不灭一相所谓无相。无相即寂灭涅槃。是念法三昧缘智缘尽。诸菩萨及辟支佛功德。问曰。何以故念佛。但缘佛身中无学诸功德。念僧三昧缘佛弟子身中诸学无学法。余残善无漏法。皆念法三昧所缘。答曰。迦栴延尼子如是说。摩诃衍人说。三世十方诸佛及诸佛。从初发意乃至法尽。于其中间所作功德神力。皆是念佛三昧所缘。如佛所说及所说法义经。从一句一偈。乃至八万四千法聚。信戒舍闻定智慧等诸善法。乃至无余涅槃。皆是念法三昧所缘。诸菩萨辟支佛及声闻众。除佛余残一切圣众及诸功德。是念僧三昧所缘。念僧者是佛弟子众。戒众具足禅定众智慧众解脱众解脱知见众具足。四双八辈应受供养恭敬礼事。是世间无上福田。行者应念如佛所赞僧。若声闻僧若辟支佛僧若菩萨僧功德是圣僧。五众具足如上说。问曰。先已以五众赞佛。云何复以五众赞僧。答曰。随弟子所得五众而赞具足。具足有二种。一者实具足。二者名具足。如佛弟子所可应得者尽得而赞。是名名具足。如佛所得而赞是名实具足。复次为欲异于外道出家众在家众故。作如是赞。外道在家众赞其富贵豪尊势力。出家众赞其邪见苦行染着智慧执论诤竞。念僧众中。或有持戒禅定智慧等少不足称。以是故佛自赞弟子众一切功德根本住处戒众具足乃至解脱知见众具足。住是戒众中不倾动。引禅定弓放智慧箭。破诸烦恼贼得解脱。于是解脱中生知见。譬如健人先安足挽弓放箭能破怨敌。得出二怖免罪于王拔难于阵决了知见贼已破灭心生欢喜。是故以五众赞。应供养者五众功德具足故。如富贵豪势之人人所宗敬。佛弟子众亦如是。有净戒禅定智慧财富解脱解脱知见势力故。应供养恭敬合掌礼事。世间无上福田者。施主有二种。贫者富者。贫者礼事恭敬迎送而得果报。富者亦能恭敬礼事迎送。又以财物供养而得果报。是故名为世间无上福田。譬如良田耕治调柔以时下种。溉灌丰渥所获必多。众僧福田亦复如是。以智慧犁耕出结使根。以四无量心磨治调柔。诸檀越下信施谷子。溉以念施恭敬清净心水。若今世若后世。得无量世间乐。及得三乘果。如薄拘罗比丘。鞞婆尸佛时。以一呵梨勒果供养众僧。九十一劫天上人中受福乐果常无疾病。今值释迦牟尼佛出家漏尽得阿罗汉。如沙门二十亿。鞞婆尸佛时。作一房舍以物覆地供养众僧。九十一劫天上人中受福乐果。足不蹈地。生时足下毛长二寸柔软净好。父见欢喜与二十亿两金。见佛闻法得阿罗汉。于诸弟子中精进第一。如是等少施得大果报。是故名世间无上福田。僧中有四双八辈者。佛所以说世间无上福田。以有此八辈圣人故。名无上福田。问曰如佛告给孤独居士。世间福田应供养者有二种。若学人若无学人。学人十八无学人有九。今此中何以故但说八。答曰。彼广说故十八及九。今此略说故八。彼二十七圣人此八皆摄。信行法行或向须陀洹摄。或向斯陀含摄。或向阿那含摄。家家向斯陀含摄。一种向阿那含摄。五种阿那含向阿罗汉摄。信行法行入思惟道。名信解脱见得。是信解脱见得十五学人摄。九种福田阿罗汉摄。复次行者应念僧。僧是我趣涅槃之真伴。一戒一见如是。应欢喜一心恭敬顺从无违。我先伴种种众恶妻子奴婢人民等。是入三恶道伴。今得圣人伴安隐至涅槃。佛如医王法如良药僧如瞻病人。我当清净持戒正忆念。如佛所说法药我当顺从。僧是我断诸结病中一因缘。所谓瞻病人。是故当念僧。复次僧有无量戒禅定智慧等具足。其德不可测量。如一富贵长者信乐僧。白僧执事。我次第请僧于舍食。日日次请乃至沙弥。执事不听沙弥受请。诸沙弥言。以何意故不听沙弥。答言。以檀越不喜请年少故。便说偈言

  须发白如雪　　齿落皮肉皱
  偻步形体羸　　乐请如是辈

诸沙弥等皆是大阿罗汉。如打师子头欻然从坐起。而说偈言

  檀越无智人　　见形不取德
  舍是少年相　　但取老瘦黑

上尊耆年相者。如佛说偈

  所谓长老相　　不必以年耆
  形瘦须发白　　空老内无德
  能舍罪福果　　精进行梵行
  已离一切法　　是名为长老

是时诸沙弥复作是念。我等不应坐观。此檀越品量僧好恶。即复说偈

  赞叹呵骂中　　我等心虽一
  是人毁佛法　　不应不教诲
  当疾到其舍　　以法教语之
  我等不度者　　是则为弃物

即时诸沙弥自变其身皆成老年。须发白如雪秀眉垂覆眼。皮皱如波浪。其脊曲如弓。两手负杖行。次第而受请。举身皆振掉。行止不自安。譬如白杨树随风而动摇。檀越见此辈欢喜迎入坐。坐已须臾顷还复年少形。檀越惊怖言

  如是耆老相　　还变成少身
  如服还年药　　是事何由然

诸沙弥言。汝莫生疑畏。我等非非人。汝欲平量僧。是事甚可伤。我等相怜愍故现如是化。汝当深识之圣众不可量。如说

  譬如以蚊嘴　　犹可测海底
  一切天与人　　无能量僧者
  僧以功德贵　　犹尚不分别
  而汝以年岁　　称量诸大德
  大小生于智　　不在于老少
  有智勤精进　　虽少而是老
  懈怠无智慧　　虽老而是少

汝今平量僧是则为大失。如欲以一指测知大海底。为智者之所笑。汝不闻佛说四事虽小而不可轻。太子虽小当为国王。是不可轻。蛇子虽小毒能杀人。亦不可轻。小火虽微能烧山野。又不可轻也。沙弥虽小得圣神通最不可轻。又有四种人。如庵罗果。生而似熟熟而似生。生而似生熟而似熟。佛弟子亦如是。有圣功德成就。而威仪语言不似善人。有威仪语言似善人。而圣功德不成就。有威仪语言不似善人。圣功德未成就。有威仪语言似善人。而圣功德成就。汝云何不念是言。而欲称量于僧。汝若欲毁僧是则为自毁。汝为大失。己过事不可追。方来善心除去诸疑悔。听我所说

  圣众不可量　　难以威仪知
  不可以族姓　　亦不以多闻
  亦不以威德　　又不以耆年
  亦不以严容　　复不以辩言
  圣众大海水　　功德故甚深
  佛以百事赞是僧　　施之虽少得报多
  是第三宝声远闻　　以是故应供养僧
  不应分别是老少　　多知少闻及明闇
  如人观林不分别　　伊兰瞻卜及萨罗
  汝欲念僧当如是　　不应以愚分别圣
  摩诃迦叶出家时　　纳衣价直十万金
  欲作乞人下贱服　　更求粗弊不能得
  圣众僧中亦如是　　求索最下小福田
  能报施者十万倍　　更求不如不可得
  众僧大海水　　结戒为畔际
  若有破戒者　　终不在僧数
  譬如大海水　　不共死尸宿

檀越闻是事。见是神通力身惊毛竖。合掌白诸沙弥言。诸圣人。我今忏悔。我是凡夫人心常怀罪。我有少疑今欲请问。而说偈言

  大德已过疑　　我今得遭遇
  若复不咨问　　则是愚中愚

诸沙弥言。汝欲问者便问。我当以所闻答檀越问言。于佛宝中信心清净。于僧宝中信心清净。何者福胜。答曰。我等初不见僧宝佛宝有增减。何以故。佛一时舍婆提乞食。有一婆罗门姓婆罗埵逝。佛数数到其家乞食。心作是念。是沙门何以来数数如负其债。佛时说偈

  时雨数数堕　　五谷数数成
  数数修福业　　数数受果报
  数数受生法　　故受数数死
  圣法数数成　　谁数数生死

婆罗门闻是偈已。作是念。佛大圣人具知我心。惭愧取钵入舍盛满美食以奉上佛。佛不受作是言。我为说偈故得此食我不食也。婆罗门言。是食当与谁。佛言。我不见天及人能消是食者。汝持去置少草地若无虫水中。即如佛教持食着无虫水中。水即大沸烟火俱出。如投大热铁。婆罗门见已惊怖言未曾有也。乃至食中神力如是。还到佛所头面礼佛足。忏悔乞出家受戒。佛言善来。即时须发自堕便成沙门。渐渐断结得阿罗汉道。复有摩诃憍昙弥。以金色上下宝衣奉佛。佛知众僧堪能受用告憍昙弥。以此上下衣与众僧。以是故知佛宝僧宝福无多少。檀越言。若为佛布施。僧能消能受。何以故。婆罗埵逝婆罗门食佛不教令僧食。诸沙弥答言。为显僧大力故。若不见食在水中有大神力者。无以知僧力为大。若为佛施物而僧得受。便知僧力为大。譬如药师欲试毒药。先以与鸡鸡即时死然后自服。乃知药师威力为大。是故檀越当知

  若人爱敬佛　　亦当爱敬僧
  不当有分别　　同皆为宝故

尔时檀越闻说是事欢喜言。我某甲从今日若有入僧数中。若小若大一心信敬不敢分别。诸沙弥言。汝心信敬无上福田。不久当得道。何以故

  多闻及持戒　　智慧禅定者
  皆入僧数中　　如万川归海
  譬如众药草　　依止于雪山
  百谷诸草木　　皆依止于地
  一切诸善人　　皆在僧数中

复次汝等曾闻佛为长鬼神将军赞三善男子阿泥卢陀难提迦翅弥罗不。佛言。若一切世间天及人。一心念三善男子长夜得无量利益。以是事故倍当信敬僧。是三人不名僧。佛说念三人有如是果报。何况一心清净念僧。是故檀越当任力念僧名。如说偈

  是诸圣人众　　则为雄猛军
  摧灭魔王贼　　是伴至涅槃

诸沙弥为檀越。种种说僧圣功德。檀越闻已举家大小皆见四谛得须陀洹道。以是因缘故。应当一心念僧。念戒者。戒有二种有漏戒无漏戒。有漏复有二种一者律仪戒二者定共戒。行者初学念是三种戒。学三种已但念无漏戒。是律仪戒能令诸恶不得自在。枯朽折减。禅定戒能遮诸烦恼。何以故。得内乐故。不求世间乐。无漏戒能拔诸恶烦恼根本故。问曰。云何念戒。答曰。如先说念僧中。佛如医王法如良药僧如胆病人。戒如服药禁忌。行者自念我若不随禁忌。三宝于我为无所益。又如导师指示好道。行者不用导师无咎。以是故我应念戒

复次是戒一切善法之所住处。譬如百谷药木依地而生。持戒清净能生长诸深禅定实相智慧。亦是出家人之初门。一切出家人之所依仗。到涅槃之初因缘。如说持戒故心不悔。乃至得解脱涅槃。行者念清净戒不缺戒不破戒不穿戒不杂戒自在戒不着戒。智者所赞戒无诸瑕隙名为清净戒。云何名不缺戒。五众戒中除四重戒。犯诸余重者。是名缺犯。余罪是为破。复次身罪名缺口罪名破。复次大罪名缺小罪名破。善心回向涅槃。不令结使种种恶觉观得入。是名不穿。为涅槃为世间向二处。是名为杂随戒。不随外缘如自在人无所系属。持是净戒不为爱结所拘。是为自在戒。于戒不生爱慢等诸结使知戒实相。亦不取是戒。若取是戒譬如人在囹圄桎梏所拘虽得蒙赦。而复为金锁所系。人为恩爱烦恼所系。如在牢狱。虽得出家爱着禁戒如着金锁。行者若知戒是无漏因缘。而不生着是则解脱。无所系缚是名不着戒。诸佛菩萨辟支佛及声闻所赞戒。若行是戒用是戒。是名智所赞戒。外道戒者。牛戒鹿戒狗戒罗刹鬼戒哑戒聋戒。如是等戒智所不赞。唐苦无善报。复次智所赞者。于三种戒中无漏戒。不破不坏依此戒得实智慧。是圣所赞戒。无漏戒有三种。如佛说正语正业正命是三业。义如八圣道中说。是中应广说。问曰。若持戒是禅定因缘。禅定是智慧因缘。八圣道中何以慧在前。戒在中定在后。答曰。行路之法应先以眼见道而后行。行时当精勤。精勤行时常念如导师所教。念已一心进路不顺非道。正见亦如是。先以正智慧观五受众皆苦。是名苦。苦从爱等诸结使和合生。是名集。爱等结使灭是名涅槃。如是等观八分。名为道。是名正见。行者是时心定知世间虚妄可舍。涅槃实法可取。快定是事是名正见。知见是事心力未大未能发行。思惟筹量发动正见令得力。是名正思惟。智慧既发欲以言宣故次正语。正业正命。戒行时精进不懈。不令住色无色定中。是名正方便。用是正见观四谛。常念不忘念。一切烦恼是贼应当舍。正见等是我真伴应当随。是名正念。于四谛中摄心不散。不令向色无色定中。一心向涅槃。是名正定。是初得善有漏。名为暖法顶法忍法中义。次第增进初中后心入无漏心中。疾一心中具。无有前后分别次第。正见相应正思惟正方便正念正定。三种戒随是分分行。正见分别好丑利益为事。正思惟发动正见为事。正语等持是智慧诸功德不令散失。正方便驱策令速进不息。正念七事所应行者忆而不忘。正定令心清净不浊不乱。令正见七分得成。如无风房中灯则照明了了。如是无漏戒在八圣道中。亦为智者所赞。问曰。无漏戒应为智者所赞。有漏戒何以赞。答曰。有漏戒似无漏。随无漏同行因缘。是故智者合赞。如贼中有人叛来归我。彼虽是贼今来向我。我当内之可以破贼何可不念。诸烦恼贼在三界城中住。有漏戒善根。若暖法顶法忍法世间第一法。与余有漏法异故。行者受用。以是因缘故破诸结使贼。得苦法忍无漏法财。以是故智者所赞。是名念戒。念舍者有二种舍。一者施二者舍诸烦恼。施舍有二种。一者财施。二者法施。三种舍和合名为舍。财施是一切善法根本故。行者作是念。上四念因缘故。得差烦恼病。今以何因缘故得是四念。则是先世今世。于三宝中少有布施因缘故。所以者何。众生于无始世界中。不知于三宝中布施故福皆尽灭。是三宝有无量法。是故施亦不尽必得涅槃。复次过去诸佛初发心时。皆以少多布施为因缘。如佛说是布施是初助道因缘。复次人命无常财物如电。若人不乞犹尚应与。何况乞而不施。以是应施作助道因缘。复次财物是种种烦恼罪业因缘。若持戒禅定智慧种种善法。是涅槃因缘。以是故财物尚应自弃。何况好福田中而不布施。譬如有兄弟二人。各担十斤金行道中更无余伴。兄作是念我何以不杀弟取金。此旷路中人无知者。弟复生念欲杀兄取金。兄弟各有恶心。语言视瞻皆异。兄弟即自悟还生悔心。我等非人与禽兽何异。同生兄弟而为少金故而生恶心。兄弟共至深水边。兄以金投着水中。弟言。善哉善哉。弟寻复弃金水中。兄复言。善哉善哉。兄弟更互相问。何以故言善哉。各相答言。我以此金故。生不善心欲相危害今得弃之故言善哉。二辞各尔。以是故知财为恶心因缘常应自舍。何况施得大福而不施。如说

  施名行宝藏　　亦为善亲友
  终始相利益　　无有能坏者
  施为好密盖　　能遮饥渴雨
  施为坚牢船　　能度贫穷海
  悭为凶衰相　　为之生忧畏
  洗之以施水　　则为生福利
  悭惜不衣食　　终身无欢乐
  虽云有财物　　与贫困无异
  悭人之室宅　　譬如丘冢墓
  求者远避之　　终无有向者
  如是悭贪人　　智者所摈弃
  命气虽未尽　　与死等无异
  悭人无福慧　　于施无坚要
  临当堕死坑　　恋惜生懊恨
  涕泣当独去　　忧悔火烧身
  好施者安乐　　终无有是苦
  人修布施者　　名闻满十方
  智者所爱敬　　入众无所畏
  命终生天上　　久必得涅槃

如是等种种诃悭贪赞布施。是名念财施。云何念法施。行者作是念。法施利益甚大。法施因缘故一切佛弟子等得道。复次佛说二种施中法施为第一。何以故。财施果报有量。法施果报无量。财施欲界报。法施三界报。亦出三界报。若不求名闻财利力势。但为学佛道弘大慈悲。度众生生老病死苦。是名清净法施。若不尔者为如市易法。复次财施施多财物减少。法施施多法更增益。财施是无量世中旧法。法施圣法初来未得。名为新法。财施但能救诸饥渴寒热等病。法施能除九十八诸烦恼等病。如是等种种因缘。分别财施法施。行者应念法施。问曰。何等是法施。答曰。佛所说十二部经。清净心为福德与他说。是名法施。复有以神通力令人得道。亦名法施。如网明菩萨经中说。有人见佛光明。得道者生天者。如是等口虽不说令他得法故。亦名法施。是法施应观众生心性烦恼多少智慧利钝。应随所利益而为说法。譬如随病服药则有益。有淫欲重有嗔恚重有愚痴重。有两两杂三三杂。淫重者为说不净观。嗔重者为说慈心。痴重者为说深因缘。两杂者说两观。三杂者说三观。若人不知病相。错投药者病则为增。若着众生相者。为说但有五众此中无我。若言无众生相者。即为说五众相续有。不令堕断灭故。求富乐者为说布施。欲生天者为说持戒。人中多所贫乏者。为说天上事。恼患居家者。为说出家法。着钱财居家者。为说在家五戒法。若不乐世间。为说三法印。无常无我涅槃。依随经法自演作义理。譬喻庄严法施为众生说。如是等种种利益。故当念法施。舍烦恼者。三结乃至九十八使等皆断除却。是名为舍。念舍是法如舍毒蛇如舍桎梏。得安隐欢喜。复次念舍烦恼亦入念法中。问曰。若入念法中。今何以更说。答曰。舍诸烦恼。是法微妙难得无上无量。是故更别说。复次念法与念舍异。念法念佛法微妙诸法中第一。念舍念诸烦恼罪恶舍之为快。行相别。是为异。如是等种种因缘。行者当念舍。念舍者是初学禅智。中畏生增上慢。念天者有四天王天乃至他化自在天。问曰。佛弟子应一心念佛及佛法。何以念天。答曰。知布施业因缘果报故。受天上富乐。以是因缘故念天。复次是八念佛自说因缘。念天者。应作是念有四天王天。是天五善法因缘故生彼中。信罪福受持戒闻善法修布施学智慧。我亦有是五法。以是故欢喜。言天以是五法故生富乐处。我亦有是我欲生彼亦可得生。我以天福无常故不受。乃至他化自在天亦如是。问曰。三界中清净天多。何以故但念欲天。答曰。声闻法中说念欲界天。摩诃衍中。说念一切三界天。行者未得道时。或心着人间五欲。以是故佛说念天。若能断淫欲。则生上二界天中。若不能断淫欲。即生六欲天中。是中有妙细清净五欲。佛虽不欲令人更生受五欲。有众生不任入涅槃。为是众生故。说念天。如国王子在高危处立不可救护。欲自投地。王使人敷厚绵褥堕则不死差于堕地故。复次有四种天。名天生天净天生净天。名天者。如今国王名天子。生天者。从四天王乃至非有想非无想天。净天者。人中生诸圣人。生净天者。三界天中生诸圣人。所谓须陀洹家家。斯陀含一种。或于天上得阿那含阿罗汉道。生净天。色界中有五种阿那含。不还是间。即于彼得阿罗汉。无色界中一种阿那含。离色界生无色界。是中修无漏道。得阿罗汉入涅槃。念是二种天生天生净天。如是等天是名念天。念安那般那者。如禅经中说。念死者。有二种死。一者自死二者他因缘死。是二种死行者常念。是身若他不杀必当自死。如是有为法中。不应弹指顷生信不死心。是身一切时中皆有死不待老。不应恃是种种忧恼凶衰身。生心望安隐不死。是心痴人所生。身中四大各各相害。如人持毒蛇箧。云何智人以为安隐。若出气保当还入入息保出。睡眠保复得还觉。是皆难必。何以故。是身内外多怨故。如说

  或有胎中死　　或有生时死
  或年壮时死　　或老至时死
  亦如果熟时　　种种因缘堕
  当求免离此　　死怨之恶贼
  是贼难可信　　时舍则安隐
  假使大智人　　威德力无上
  无前亦无后　　于今无脱者
  亦无巧辞谢　　无请求得脱
  亦无捍挌处　　可以得免者
  亦非持净戒　　精进可以脱
  死贼无怜愍　　来时无避处

是故行者不应于无常危脆命中而信望活。如佛为比丘说死相义。有一比丘偏袒白佛。我能修是死相。佛言。汝云何修。比丘言。我不望过七岁活。佛言。汝为放逸修死相。有比丘言。我不望过七月活。有比丘言七日。有言六五四三二一日活。佛言。汝等皆是放逸修死相。有言从旦至食时。有言一食顷。佛言。汝等亦是放逸修死相。一比丘偏袒白佛。我于出气不望入。于入气不望出。佛言。是真修死相为不放逸。比丘。一切有为法念念生灭。住时甚少其犹如幻。欺诳无智行者。如是等种种因缘念死相。问曰。法是三世诸佛师。何以故念佛在前。是八念云何有次第。答曰。是法虽是十方三世诸佛师。佛能演出是法其功大故。譬如雪山中有宝山。宝山顶有如意宝珠种种宝物多。有人欲上或有半道还者。有近而还者。有一大德国王。怜愍众生为作大梯。人民大小乃至七岁小儿。皆得上山随意取如意珠等种种宝物。佛亦如是世间诸法实相宝山。九十六种异道皆不能得。乃至梵天王求诸法实相亦不能得。何况余人。佛以大慈悲怜愍众生故。具足六波罗蜜。得一切智慧方便。说十二部经八万四千法聚梯。阿若憍陈如舍利弗目揵连摩诃迦叶。乃至七岁沙弥苏摩等。皆得诸无漏法根力觉道实相。实相虽微妙。一切众生皆蒙佛恩故得。以是故念佛在前。次第念法次第念僧。僧随佛语能解法故第三。余人不能解僧能得解。以是故称为宝。人中宝者是佛。九十六种道法中宝者是佛法。一切众中宝者是僧。复次以佛因缘故。法出世间。以法因缘故有僧。行者念我云何当得法宝。得在僧数中。当除却一切粗细身口恶业。是故次第说持戒。复次云何分别有七众。以有戒故欲除心恶。破悭贪故念舍。欲令受者得乐故破嗔恚。信福得果报故破邪见。住持戒布施法中。则为住十善道中离十不善道。十善道有二种果。若上行者得净天中生。中行得生天。以是故戒施次第念天。行禅定故得二种天。灭诸恶觉但集善法摄心一处。是故念天。次第念安那般那。念安那般那。能灭诸恶觉如雨淹尘。见息出入知身危脆。由息入出身得存立。是故念入出息次第念死。复次行者或时恃有七念。着此功德懈怠心生。是时当念死死事常在前。云何当懈怠着此法爱。如阿那律佛灭度时说

  有为法如云　　智者不应信
  无常金刚来　　破圣主山王

是名八念次第。问曰。是说声闻八念。菩萨八念有何差别。答曰。声闻为身故。菩萨为一切众生故。声闻但为脱老病死故。菩萨为遍具一切智功德故。是为差别。复次佛是中亦说告舍利弗。菩萨摩诃萨以不住法。住般若波罗蜜中。应具足檀波罗蜜。乃至应具足八念不可得故。初有不住后有不可得。以此二印以是故异。不住不可得义如先说(丹注云八念竟)

大智度论卷第二十二大智度论初品中十想释论第三十七(卷二十三)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】十想无常想苦想无我想食不净想一切世间不可乐想死想不净想断想离欲想尽想

【论】问曰。是一切行法。何以故。或时名为智或时名为念或时名为想。答曰。初习善法为不失故但名念。能转相转心故名为想。决定知无所疑故名为智。观一切有为法无常。智慧相应相。是名无常想。一切有为法无常者。新新生灭故属因缘故不增积故。复次生时无来处。灭亦无去处。是故名无常。复次二种世间无常故说无常。一者众生无常。二者世界无常。如说

  大地草木皆磨灭　　须弥巨海亦崩竭
  诸天住处皆烧尽　　尔时世界何物常
  十力世尊身光具　　智慧明照亦无量
  度脱一切诸众生　　名闻普遍满十方
  今日廓然悉安在　　何有智者不感伤

如是舍利弗目犍连须菩提等诸圣人。转轮圣王诸国王常乐天王及诸天圣德尊贵皆亦尽。大火焰明忽然灭。世间转坏如风中灯。如险岸树。如漏器盛水不久空竭。如是一切众生。及众生住处。皆无常故名为无常。问曰。菩萨何以故行是无常想。答曰。以众生着常颠倒受众苦不得免生死行者得是无常想教化众生。言诸法皆无常。汝莫着常颠倒失行道时。诸佛上妙法。所谓四真谛。四谛中苦谛为初。苦四行中无常行为初。以是故菩萨行无常想。问曰。有人见无常事至转更坚着。如国王夫人宝女从地中生。为十头罗刹将度大海王大忧愁。智臣谏言王智力具足。夫人还在不久何以怀忧。答言。我所以忧者不虑。我妇叵得但恐壮时易过。亦如人好华好果见时欲过便大生着。如是知无常乃更生诸结使。云何言无常能令心厌破诸结使。答曰。如是见无常是知无常少分为不具足。与禽兽见无常无异。以是故。佛告舍利弗。当具足修无常想。问曰。何等是具足无常想。答曰。观有为法念念生灭。如风吹尘。如山上水流。如火焰随灭。一切有为法无牢无强。不可取不可着。为如幻化诳惑凡夫。因是无常得入空门。是空中一切法不可得故。无常亦不可得。所以者何。一念中生住灭相不可得。生时不得有住灭。住时不得有生灭。灭时不得有生住。生住灭相性相违故无。是无故无常亦无。问曰。若无无常。佛何以苦谛中说无常。答曰。凡夫人生邪见故。谓世间是常。为灭除是常见故说无常。不为无常是实故说。复次佛未出世。凡夫人但用世俗道遮诸烦恼。今欲拔诸烦恼根本故说是无常。复次诸外道法。但以形离五欲。谓是解脱。佛说邪相因缘故缚。观无常正相故解脱。复有二种观无常相。一者有余二者无余。如佛说一切人物灭尽唯有名在。是名有余。若人物灭尽名亦灭。是名无余。复有二种观无常相。一者身死尽灭。二者新新生灭。复次有言持戒为重。所以者何。依戒因缘故。次第得漏尽。有言多闻为重。所以者何。依智慧故能有所得。有言禅定为重。如佛所说定能得道。有言以十二头陀为重。所以者何。能净戒行故。如是各各以所行为贵。更不复勤求涅槃。佛言是诸功德。皆是趣涅槃分。若观诸法无常。是为真涅槃道。如是等种种因缘故。诸法虽空而说是无常想。复次无常想。即是圣道别名。佛种种异名说道。或言四念处。或言四谛。或言无常想。如经中说。善修无常想。能断一切欲爱色爱无色爱掉慢。无明尽。能除三界结使。以是故即名为道。是无常想或有漏或无漏。正得无常是无漏。初学无常是有漏。摩诃衍中诸菩萨心广大。种种教化一切众生故。是无常想。亦有漏亦无漏。若无漏在九地。若有漏在十一地。缘三界五受众。四根相应除苦根。凡夫圣人得如是等种种因缘。说无常想功德。苦想者。行者作是念。一切有为法无常故苦。问曰。若有为法无常故苦者。诸贤圣人有为无漏法亦应当苦。答曰。诸法虽无常。爱著者生苦。无所著者无苦。问曰。有诸圣人。虽无所著亦皆有苦。如舍利弗风热病苦。毕陵伽婆蹉眼痛苦。罗婆那跋提(音声第一也)痔病苦。云何言无苦。答曰。有二种苦。一者身苦。二者心苦。是诸圣人以智慧力故。无复忧愁嫉妒嗔恚等心苦。已受先世业因缘四大造身。有老病饥渴寒热等身苦。于身苦中亦复薄少。如人了了知负他债偿之不以为苦。若人不忆负债债主强夺嗔恼生苦。问曰。苦受是心心数法。身如草木离心则无所觉。云何言圣人但受身苦。答曰。凡夫人受苦时。心生愁恼。为嗔使所使。心但向五欲。如佛所说。凡夫人除五欲。不知更有出苦法。于乐受中贪欲使所使。不苦不乐受中。无明使所使。凡夫人受苦时。内受三毒苦。外受寒热鞭杖等。如人内热盛外热亦盛。如经说。凡夫人失所爱物。身心俱受苦。如二箭双射。诸贤圣人无忧愁苦。但有身苦更无余苦。复次五识相应苦。及外因缘杖楚寒热等苦。是名身苦。余残名心苦。复次我言有为无漏法。不着故非苦。圣人身是有漏。有漏法则苦有何咎。是末后身所受苦亦微少。问曰。若无常即是苦者。道亦是苦。云何以苦离苦。答曰。无常即是苦。为五受众故说。道虽作法故无常不名为苦。所以者何。是能灭苦不生诸着。与空无我等诸智和合故。但是无常而非苦。如诸阿罗汉得道时说偈言

  我等不贪生　　亦复不乐死
  一心及智慧　　待时至而去

佛取涅槃时。阿难等诸未离欲人。未善修八圣道故皆涕泣忧愁。诸离欲阿那含皆惊愕。诸漏尽阿罗汉其心不变。但言世间眼灭。疾以得道力故。虽从佛得大利益。知重佛无量功德而不生苦。以是故知道虽无常。非苦因缘故不名为苦。但五受众是苦。何以故。爱着故无常。败坏故如受念处中。苦义此中应广说。复次苦者有身常是苦。痴覆故不觉。如说

  骑乘疲极故　　求索住立处
  住立疲极故　　求索坐息处
  坐久疲极故　　求索安卧处
  众极由作生　　初乐后则苦
  视眴息出入　　屈伸坐卧起
  行立及去来　　此事无不苦

问曰。是五受众为一切皆苦。为苦想观故苦。若一切皆苦。佛云何说有三种受苦受乐受不苦不乐受。若以苦想故苦。云何说苦谛为实苦。答曰。五受众一切皆苦。凡夫人四颠倒因缘。为欲所逼以五欲为乐。如人涂疮大痛息故以为乐疮非乐也。佛说三种受为世间故。于实法中非是乐也若五受众中实有乐。何以故佛说灭五受众名为乐。复次随其所嗜乐心则生乐无定也。乐若实定不待心着。如火实热不待着而热也。以乐无定故名为苦。复次世间颠倒乐能得今世后世无量苦果报故名为苦。譬如大河水中着少毒。不能令水异。世间颠倒毒药。于一切大苦水中。则不现如说

  从天下生地狱时　　忆本天上欢乐事
  宫观婇女满目前　　园苑浴池以娱志
  又见狱火来烧身　　似如大火焚竹林
  是时虽见天上乐　　徒自感结无所益

是苦想摄缘如无常想。如是等种种分别苦。名为苦想。无我想者。苦则是无我。所以者何。五受众中尽皆是苦相。无有自在。若无自在是则无我。若有我自在者。不应令身有苦。如所说

  诸有无智人　　身心计是我
  渐近坚着故　　不知无常法
  是身无作者　　亦无有受者
  是身为无生　　而作种种事
  六情尘因缘　　六种识得生
  从三事和合　　因缘触法生
  从触法因缘　　受念业法生
  如珠日草薪　　和合故火生
  情尘识和合　　所作事业成
  相续相似有　　如种有牙茎

复次我相不可得故无我。一切法有相故则知有。如见烟觉热故知有火。于五尘中各各别异。故知有情种种思惟筹量诸法故知有。心心数法此我无相故知无我。问曰。有出入气则是我相。视眴寿命心苦乐爱憎精勤等是我相。若无我谁有是出入息视眴寿命心苦乐爱憎精勤等。当知有我在内动发故。寿命心亦是我法。若无我如牛无御。有我故能制心入法不为放逸。若无我者谁制御心。受苦乐者是我。若无我者。为如树木则不应别苦乐。爱憎精勤亦如是。我虽微细不可以五情知。因是相故可知为有。答曰。是诸相皆是识相。有识则有入出息视眴寿命等。若识离身则无。汝等我常遍故。死人亦应有视眴入出息寿命等。复次出入息等是色法。随心风力故动发。此是识相非我相。寿命是心不相应行。亦是识相。问曰。若入无心定中。或眠无梦时息亦出入有寿命。何以故。言皆是识相。答曰。无心定等识虽暂无。不久必还生识不舍身故。有识时多无识时少。是故名识相。如人出行不得言其家无主。苦乐憎爱精勤等。是心相应共缘随心行。心有故便有。心无故便无。以是故是识相非我相。复次若有我者。我有二种。若常若无常。如说

  若我是常　　则无后身
  常不生故　　亦无解脱
  亦无妄无作　　以是故当知
  无作罪福者　　亦无有受者
  舍我及我所　　然后得涅槃
  若实有我者　　不应舍我心
  若我无常者　　则应随身灭
  如大岸堕水　　亦无有罪福

如是我及知者不知者作者不作者。如檀波罗蜜中说。不得是我相故。知一切法中无我。若知一切法中无我。则不应生我心。若无我亦无我所心。我我所离故则无有缚。若无缚则是涅槃。是故行者应行无我想。问曰。是无常苦无我。为一事为三事。若是一事不应说三。若是三事。佛何以故说无常即是苦。苦即是无我。答曰。是一事。所谓受有漏法。观门分别故。有三种异无常行相应是无常想。苦行相应是苦想。无我行相应是无我想。无常不令入三界。苦令知三界罪过。无我则舍世间。复次无常生厌心。苦生畏怖。无我出拔令解脱。无常者佛说五受众是无常。苦者佛说无常则是苦。无我者佛说苦即是无我。无常者佛示五受众尽灭相。苦者佛示如箭入心。无我者佛示舍离相。无常者示断爱。苦者示断我习慢。无我者示断邪见。无常者遮常见。苦者遮今世涅槃乐见。无我者遮着处。无常者世间所可着常法是。苦者世间计乐处是。无我者世间所可计我牢固者是。是为三相分别想。无我想缘摄种种。如苦想中说。食厌想者。观是食从不净因缘生。如肉从精血水道生。是为脓虫住处。如酥乳酪血变所成与烂脓无异。厨人污垢种种不净。若着口中恼有烂涎。二道流下与唾和合。然后成味。其状如吐从腹门入。地持水烂风动火煮如釜熟糜。滓浊下沉清者在上。譬如酿酒滓浊为屎清者为尿。腰有三孔风吹腻汁散入百脉。与先血和合凝变为肉。从新肉生脂骨髓。从是中生身根。从新旧肉合。生五情根。从五根生五识。五识次第生意识。分别取相筹量好丑。然后生我我所心等诸烦恼及诸罪业。观食如是本末因缘种种不净。知内四大与外四大无异。但以我见故强为我有。复次思惟此食垦植耘除收获蹂治。舂磨洮汰炊煮乃成用功甚重。计一钵之饭。作夫流汗集合。量之食少汗多。此食作之功重辛苦如是。入口食之即成不净。无所一直宿昔之间变为屎尿。本是美味人之所嗜变成不净恶不欲见。行者自思如此弊食。我若贪着当堕地狱啖烧铁丸。从地狱出当作畜生牛羊骆驼偿其宿债。或作猪狗常啖粪除。如是观食则生厌想。因食厌故于五欲中皆厌。譬如一婆罗门修净洁法。有事缘故到不净国。自思我当云何得免此不净。唯当干食可得清净。见一老母卖白髓饼而语之言。我有因缘住此百日。常作此饼送来当多与价。老母日日作饼送之。婆罗门贪着饱食欢喜。老母作饼初时白净。后转无色无味。即问老母何缘尔耶。母言痈疮差故。婆罗门问。此言何谓。母言。我大家夫人隐处生痈。以面酥甘草拊之。痈熟脓出和合酥饼。日日如是。以此作饼与汝。是以饼好。今夫人痈差。我当何处更得。婆罗门闻之两拳打头捶胸吁呕。我当云何破此净法我为了矣。弃舍缘事驰还本国。行者亦如是。着是饮食欢喜乐啖。见其好色细滑香美可口不观不净。后受苦报悔将何及。若能观食本末如是生恶厌心。因离食欲四欲皆舍。于欲界中乐悉皆舍离断此五欲。于五下分结亦断。如是等种种因缘恶罪不复乐着。是名食厌想。问曰。无常苦无我想。与无漏智慧相应。食厌等四想与有漏智慧相应。次第法应在前。今何以后说。答曰。佛法有二种道见道修道。见道中用是三想。破诸邪见等得圣果犹未离欲。为离欲故三想次第说是食厌等四想。得离淫欲等诸烦恼。初三想示见谛道。中四想为示学修道。后三想示无学道。初习身念处中。虽有食厌想功用少故佛不说。今为须陀洹斯陀含度欲故无我想次第说食厌等四想。一切世间不可乐想者。若念世间色欲滋味车乘服饰卢观园宅种种乐事则生乐想。若念世间众恶罪事。则心生厌想。何等恶事。恶事有二种。一者众生。二者土地。众生有八苦之患。生老病死恩爱别离怨憎同处所求不得。略而言之五受众苦众生之罪。淫欲多故不别好丑。不随父母师长教诲。无有惭愧与禽兽无异。嗔恚多故不别轻重。嗔毒狂发乃至不受佛语。不欲闻法。不畏恶道。杖楚横加不知他苦。入大闇中都无所见。愚痴多故所求不以道。不识事缘。如构角求乳。无明覆故。虽蒙日照永无所见。悭贪多故其舍如冢人不向之。憍慢多故不敬贤圣不孝父母。憍逸自坏永无所直。邪见多故不信今世后世不信罪福不可共处。如是等诸烦恼多故。弊败为无所直。恶业多故造无间罪。或杀父母或伤害贤圣或要时荣贵谗贼忠贞残害亲戚。复次世间众生善好者少。弊恶者多。或时虽有善行贫贱鄙陋。或虽富贵端政而所行不善。或虽好布施而贫乏无财。或虽富有财宝。而悭惜贪着不肯布施。或见人有所思默无所说。便谓憍高自畜不下接物。或见好下接物恩惠普润。便谓欺诳谄饰。或见能语善论。便谓恃是小智以为憍慢。或见质直好人。便共欺诳调捉引挽陵易。或见善心柔濡。便共轻陵踏蹴不以理遇。若见持戒清净者。便谓所行矫异轻贱不数。如是等众生弊恶无一可乐土地。恶者一切土地多衰无吉。寒热饥渴疾病恶疫毒气侵害老病死畏无处不有。身所去处众苦随之无处得免。虽有好国丰乐安隐。多为诸烦恼所恼则不名乐土。一切皆有二种苦。身苦心苦。无国不有如说

  有国土多寒　　或有国多热
  有国无救护　　或有国多恶
  有国常饥饿　　或有国多病
  有国不修福　　如是无乐处

众生土地有如是恶。思惟世间无一可乐。欲界恶事如是。上二界死时退时。大生懊恼甚于下界。譬如极高处堕摧碎烂坏。问曰。无常想苦想无我想一切世间不可乐想。有何等异而别说。答曰。有二种观。总观别观。前为总观此中别观。复有二种观。法观众生观。前为呵一切法观。此中观众生罪恶不同。复次前者无漏道。此中有漏道。前见谛道今思惟道。如是等种种差别。一切地中摄缘三界法。是名一切世间不可乐想。死想者如死念中说。不净想者如身念处中说。断想离想尽想者缘涅槃相。断诸结使故名断想。离结使故名离想。尽诸结使故名尽想。问曰。若尔者一想便足。何以说三。答曰。如前一法三种说。无常即是苦。苦即是无我。此亦如是一切世间罪恶深重故三种呵。如伐大树不可以一下断。涅槃微妙法。昔所未得。是故种种赞。名为断想离想尽想。复次断三毒故名为断。离爱故名为离。灭一切苦更不生故名为尽。复次行者于暖法顶法忍法世间第一法正智慧观。远诸烦恼是名离想。得无漏道断诸结使。是名断想。入涅槃时灭五受众不复相续。是名尽想。断想有余涅槃。尽想无余涅槃。离想二涅槃方便门。是三想有漏无漏故。一切地中摄(十想竟)

    大智度初品中十一智释论第三十八(丹云三三昧义三根义合)

【经】十一智法智比智他心智世智苦智集智灭智道智尽智无生智如实智

【论】法智者。欲界系法中无漏智。欲界系因中无漏智。欲界系法灭中无漏智。为断欲界系法道中无漏智。及法智品中无漏智。比智者。于色无色界中无漏智亦如是。他心智者。知欲界色界系现在他心心数法及无漏心心数法少分。世智者诸有漏智慧。苦智者五受众无常苦空无我观时。得无漏智。集智者。有漏法因。因集生缘观时无漏智。灭智者。灭止妙出观时无漏智。道智者。道正行达观时无漏智。尽智者。我见苦已断集已尽证已修道已。如是念时无漏智慧见明觉。无生智者。我见苦已不复更见。断集已不复更断。尽证已不复更证。修道已不复更修。如是念时无漏智慧见明觉。如实智者。一切法总相别相。如实正知无有挂碍。是法智缘欲界系法及欲界系法因欲界系法灭。为断欲界系法道比智亦如是。世智缘一切法。他心智缘他心有漏无漏心心数法。苦智集智缘五受众灭智缘尽。道智缘无漏五众。尽智无生智俱缘四谛。十智一有漏八无漏一当分别。他心智缘有漏心。是有漏缘无漏心。是无漏法智。摄法智及他心智苦智集智灭智道智尽智无生智少分。比智亦如是。世智摄世智及他心智少分。他心智摄他心智及法智比智世智道智尽智无生智少分。苦智摄苦智及法智比智尽智无生智少分。集智灭智亦如是。道智摄道智及法智比智他心智尽智无生智少分。尽智摄尽智及法智比智他心智苦智集智灭智道智少分。无生智亦如是。九智八根相应。除慧根忧根苦根。世智十根相应除慧根。法智比智苦智。空三昧相应。法智比智灭智尽智无生智。无相三昧相应。法智比智他心智苦智集智道智尽智无生智。无作三昧相应。法智比智世智苦智尽智无生智。无常想苦想无我想相应。世智中四想相应。法智比智灭智尽智无生智。后三想相应。有人言。世智或与离想相应。法智缘九智除比智。比智亦如是。世智他心智尽智无生智缘十智。苦智集智缘世智及有漏他心智。灭智不缘智道智。缘九智除世智。法智比智十六相。他心智四相。苦集灭道各各四相。尽智无生智俱十四相。除空相无我相。暖法顶法忍法中世智十六相。世间第一法中世智四相除无相。(转相观相也旧言十六圣行)初入无漏心成就一世智。第二心增苦智法智。第四心增比智。第六心增集智。第十心增灭智。第十四心增道智。若离欲者增他心智。无学道增尽智。得不坏解脱增无生智。初无漏心中不修智。第二心中现在未来修二智。第四心中现在修二智未来修三智。第六心中现在未来修二智。第八心中现在修二智。未来修三智。第十心中现在未来修二智。第十二心中现在修二智。未来修三智。第十四心中现在未来修二智第十六心中现在修二智。未来修六智。若离欲修七智。须陀洹欲离欲界结使。十七心中修七智。除他心智尽智无生智。第九解脱心中修八智。除尽智无生智。信解脱人转作见得。双道中修六智。除他心智世智尽智无生智。离七地欲时。无碍道中修七智除他心智尽智无生智。解脱道中修八智除尽智无生智。离有顶欲时无碍道中修六智。除他心智世智尽智无生智。八解脱道中修七智。除世智尽智无生智。无学初心第九解脱不时解脱人修十智及一切有漏无漏善根。若时解脱人修九智及一切有漏无漏善根。如是等种种以阿毗昙门广分别。如实智分别相。此般若波罗蜜后品广说。复次有人言。法智者知欲界五众无常苦空无我。知诸法因缘和合生。所谓无明因缘诸行乃至生因缘老死。如佛为须尸摩梵志说。先用法智分别诸法。后用涅槃智。比智者知现在五受众无常苦空无我。过去未来及色无色界中五受众。无常苦空无我亦如是。譬如见现在火热能烧。以此比知过去未来及余国火。亦如是。他心智者。知他众生心心数法。问曰。若知他心心数法。何以故。但名知他心。答曰。心是主故但名知他心。若说心当知已说心数法。世智者名为假智。圣人于实法中知凡夫人。但假名中知。以是故名假智。如栋梁椽壁名为屋。但知是事不知实义。是名世智。苦智者。用苦慧呵五受众。问曰。五受众亦无常亦苦亦空亦无我。何以故。但说苦智不说无常空无我智。答曰。为苦谛故说苦智。集谛故说集智。灭谛故说灭智。道谛故说道智。问曰。五受众有种种恶。何以故。但说苦谛不说无常谛空无我谛。答曰。若说无常空无我谛。亦不坏法相。以众生多着乐畏苦故。佛呵世间一切皆是苦。欲令舍离故。无常空无我中。众生不大畏故不说。复次佛说法中五受众有异名名为苦。以是故但说苦智。是苦智或有漏或无漏。若在暖法顶法忍法世间第一法是有漏。若入见谛道是无漏。何以故。从暖法。至世间第一法中。四种观苦故。集智灭智道智亦如是。复次苦智名知苦相。实不生集智。名知一切法离无有和合。灭智名知诸法常寂灭如涅槃。道智名知一切法常清净无正无邪。尽智名知一切法无所有。无生智名知一切生法不实不定故不生。如实智者。十种智所不能知。以如实智故。能知十智各各相各各缘各各别异各各有观法。是如实智中。无相无缘无别。灭诸观法亦不有观。十智中有法眼慧眼。如实智中唯有佛眼。十智阿罗汉辟支佛菩萨共有。如实智唯独佛有。所以者何。独佛有不诳法。以是故知。如实智独佛有。复次是十智入如实智中。失本名字唯有一实智。譬如十方诸流水皆入大海舍本名字但名大海。如是等种种分别十一智义。此中略说(丹云十一智竟)

【经】三三昧有觉有观三昧。无觉有观三昧。无觉无观三昧

【论】一切禅定摄心。皆名为三摩提。秦言正心行处。是心从无始世界来常曲不端。得是正心行处心则端直。譬如蛇行常曲入竹筒中则直。是三昧三种。欲界未到地。初禅与觉观相应故。名有觉有观。二禅中间但观相应故。名无觉有观。从第二禅乃至有顶地。非觉观相应故。名无觉无观。问曰三昧相应心数法乃至二十。何以故但说觉观。答曰。是觉观娆乱三昧。以是故说是二事。虽善而是三昧贼难可舍离。有人言。心有觉观者无三昧。以是故佛说有觉有观三昧但不牢固觉观力小微。是时可得有三昧。是觉观能生三昧亦能坏三昧。譬如风能生雨亦能坏雨。三种善觉观能生初禅。得初禅时发大欢喜觉观故心散还失。以是故但说觉观。问曰。觉观有何差别。答曰。粗心相名觉。细心相名观。初缘中心发相名觉。后分别筹量好丑名观。有三种粗觉。欲觉嗔觉恼觉。有三种善觉。出要觉无嗔觉无恼觉。有三种细觉。亲里觉国土觉不死觉。六种觉妨三昧。三种善觉能开三昧门。若觉观过多还失三昧。如风能使船风过则坏船。如是种种分别觉观。问曰。经说三种法。有觉有观法。无觉有观法。无觉无观法。有觉有观地。无觉有观地。无觉无观地。今何以但说三种三昧。答曰。妙而可用者取。有觉有观法者。欲界未到地初禅中觉观相应法。若善若不善若无记。无觉有观法者。禅中间观相应法。若善若无记。无觉无观法者。离觉观法一切色心不相应行及无为法。有觉有观地者。欲界未到地梵世。无觉有观地者。禅中间善修是地作大梵王。无觉无观地者。一切光音一切遍净一切广果一切无色地。于中上妙者是三昧。何等是三昧从空等三三昧。乃至金刚及阿罗汉辟支佛诸三昧。观十方佛三昧乃至首楞严三昧。从断一切疑三昧。乃至三昧王等诸佛三昧。如是等种种分别。略说三三昧义竟

【经】三根未知欲知根知根知已根

【论】未知欲知根者无漏九根和合。信行法行人。于见谛道中名未知欲知根。所谓信等五根。喜乐舍根意根。信解见得人。思惟道中是九根转名知根。无学道中。是九根名知已根。问曰。何以故。于二十二根中。但取是三根。答曰。利解了了自在相。是名为根。余十九根根相不具足故不取。是三根利能直入至涅槃。诸有为法中主故。得自在能胜诸根。复次十根但有漏自得。无所利益故九根不定。或有漏或无漏故不说。菩萨应具足。问曰。十想亦有漏亦无漏。何以故。说应具足。答曰。十想皆是助道求涅槃法。信等五根虽是善法不尽求涅槃。如阿毗昙中说。谁成就信等五根。不断善根者。复次若五根清净变为无漏。三根中已摄。是三根中必有意根。三受中必有一受。以是故但说三根。复次二十二根。有善有不善有无记杂。是故不说应具足。是三根受众行众识众摄。未知欲知根在六地。知根知已根在九地。三根缘四谛六想相应。未知欲知根三根因。知根二根因。知已根但知已根因。未知欲知根。次第生二根。知根次第或生有漏根。或生知根或生知已根。知已根或生有漏根或生知已根。如是等以阿毗昙门广分别说。复次未知欲知根。名诸法实相。未知欲知故生信等五根。是五根力故。能得诸法实相。如人初入胎中得二根身根命根。尔时如段肉未具。诸根不能有所别知。五根成就能知五尘。菩萨亦如是。初发心欲作佛。未具足是五根。虽有愿欲知诸法实相不能得知。菩萨生是信等五根。则能知诸法实相。如眼四大及四大造色和合名为眼。先虽有四大。四大造色未清净故。不名眼根。不断善根人虽有信未清净故。不名为根。若菩萨得是信等五根。是时能信诸法实相不生不灭不垢不净非有非无非取非舍常寂灭真净如虚空。不可示不可说。一切语言道过出一切心心数法所行如涅槃。是则佛法。菩萨以信根力故。能受精进根力故。勤行不退不转。念根力故不令不善法入摄诸善法。定根力故心散五欲中。能摄实相中慧根力故。于佛智慧中少多得义味不可坏。五根所依意根必与受具。若喜若乐若舍。依是根入菩萨位乃至未得无生法忍果。是名未知欲知根。此中知诸法实相。了了故名知根。从是得无生法忍果。住阿鞞跋致地得受记。乃至满十地。坐道场得金刚三昧。于其中间名为知根。断一切烦恼习。得阿耨多罗三藐三菩提。一切可知法。智慧遍满故。名为知已根(丹云三根竟)

大智度论卷第二十三大智度论初品十力释论第三十九(卷二十四)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】舍利弗。菩萨摩诃萨欲遍知佛十力四无所畏四无碍智十八不共法大慈大悲。当习行般若波罗蜜

【论】问曰。是十力四无所畏等。是佛无上法。应当前说。何以故。先说九相八念等。答曰。六波罗蜜是菩萨所应用先已说。三十七品乃至三无漏根是声闻法。菩萨行是六波罗蜜得力故。欲过声闻辟支佛地。亦欲教化向声闻辟支佛人令入佛道。是故呵是小乘法舍一切众生无所利益。若诸声闻人言。汝是凡夫人未断结使。不能行是法是故空呵。以是故佛言菩萨应具足三十七品等。诸声闻法不可得故。虽行是诸法以不可得故。为众生行邪行故。行此正行常不舍是诸法不可得空。亦不疾取涅槃证。若菩萨不解不行是小乘。而但呵者谁当肯信。譬如释迦牟尼佛。若先不行六年苦行。而呵言非道者无人信受。以是故自行苦行过于余人。成佛道时呵是苦行道人皆信受。是故六波罗蜜后次第行声闻法

复次此非但是声闻法。是法中和合不舍众生意具足一切佛法。以不可得空智故。名菩萨法。问曰。若菩萨具足三十七品诸法者。云何不入声闻法位。答曰。具足者具足观知而不取证。了了观知故名具足如佛说

  一切畏杖痛　　莫不惜寿命
  恕已可为喻　　杖不加群生

虽言一切畏杖痛。无色界众生无身。色界虽有身而无鞭杖。欲界中诸佛转轮圣王夜摩天已上皆不畏杖楚。为畏得杖处者故言一切。具足亦如是。不为求证着法故言具足。复次我先说。不舍众生以不可得空智和合故。不堕声闻地。问曰。从六波罗蜜。至三无漏根。但言应具足。自此以后何以故。皆言欲得欲知是事。当习行般若波罗蜜。答曰。声闻法有量有限故。言应具足。自此已下是诸佛法甚深无量。菩萨未得故言欲得是事当学般若波罗蜜。复次声闻法易解易知故言具足。菩萨法佛法难解难知故言当学。复次声闻法总相。但知苦知苦因知苦尽知尽苦道。譬如二种医。一者但知病知病因知差病知差病药。而不知一切病不知一切病因不知一切病差。不知一切差病药。若复但知治人病不知治畜生病。或能治一国土。不能治余国土。有能治数十种病。不悉知四百四种病病因病差差病药亦如是。二者于四种中悉皆遍知。遍知药遍知病。声闻人如小医不能遍知。菩萨摩诃萨如大医。无病不知无药不识。以是故声闻法应具足。菩萨法应当学

佛有十力者。是处不是处如实知一力也。知众生过去未来现在诸业诸受。知造业处知因缘知报二力也。知诸禅解脱三昧定垢净分别相如实知三力也。知他众生诸根上下相如实知四力也。知他众生种种欲五力也。知世间种种无数性六力也。知一切道至处相七力也。知种种宿命。共相共因缘一世二世乃至百千世劫初劫尽。我在彼众生中如是姓名。饮食苦乐寿命长短。彼中死是间生是间死还生是间。此间生名姓饮食苦乐。寿命长短亦如是八力也。佛天眼净过诸天人眼见众生死时生时端正丑陋。若大若小若堕恶道若堕善道。如是业因缘受报。是诸众生恶身业成就。恶口业成就。恶意业成就。谤毁圣人邪见邪见业成就。是因缘故身坏死时入恶道。生地狱中。是诸众生善身业成就。善口业成就。善意业成就不谤圣人正见正见业成就。是因缘故身坏死时入善道生天上九力也。佛诸漏尽故。无漏心解脱。无漏智慧解脱。现在法中自识知我生已尽持戒已作后有尽。如实知十力也。问曰。是十力菩萨未得。声闻辟支佛所不能得。今何以说。答曰。声闻人虽不能得。若闻是十力功德。作是念佛有如是大功德。自庆言我等善利蒙益不少。得信心清净入尽苦道。诸菩萨者闻之。勤修菩萨道。当得如是十力等大功德果。复次有声闻人及菩萨。修念佛三昧。非但念佛身。当念佛种种功德法身。应作是念佛一切种一切法能解故名一切智人。一切法如实善分别说故。名一切见人。一切法现前知故。名一切知见无碍人。等心一切众生故。名大慈悲人。有大慈悲故。名为世救。如实道来故。名为如来。应受一切世间供养故。名为应供人。成就不颠倒智慧故。名正遍知。戒定慧智成就故。名明行。成不复还故。名善逝。知世间总相别相故。名世间解。善说出世间安隐道故。名无上调御师。以三种教法度众生故。名天人师。一切世间烦恼睡能自觉亦能觉人故。名为觉人。一切所愿具足故。名有德。十力成就故。名坚誓。得四无畏故。名人师子。得无量甚深智故。名大功德海。一切记说无碍故。名如风。一切好丑无憎爱故。名如地。烧一切结使薪故。名如火。善断一切烦恼习故。名具足解脱。最上处住故。名为世尊。佛有如是等诸功德故应念佛。以是故菩萨摩诃萨。欲得佛十力四无所畏十八不共法。当学般若波罗蜜。复次佛在王舍城耆阇崛山中。说是般若波罗蜜时。佛四部众及诸外道在家出家。诸天龙鬼神等种种大众集会。佛入三昧王三昧。放大光明遍照恒河沙等世界。地六种震动。说是般若波罗蜜六波罗蜜乃至三无漏根。是中有众生疑。有何等力有几种力故。能作如是不可思议感动利益。佛知众生心有如是疑故言。我有诸法实相智力。是力有十种用。是十种智故。能作如是感动变化。亦能过是所作。以是故言欲得十力当学般若波罗蜜。复次佛弟子世世殖善根。以少罪缘故堕外道。诸外道常言。佛非实有功德力。是幻术力诳惑人心。佛弟子堕外道者。心疑若尔者佛非大人。欲灭是恶谤故言。我实有十力四无所畏故度众生。非是幻诳也。复次诸菩萨修菩萨道。苦行事难办难成故欲懈息。是故佛言。行是十力当得无量果报。譬如估客主慰喻商人言。汝等慎勿疲惓。精勤努力得至宝山。当得七宝如意宝珠。佛亦如是安慰诸菩萨言。无得疲厌当勤精进修菩萨道。行是十力当得无量果报。如是等种种利益因缘故。说十力等。问曰。佛有无量力。何以故但说十力。答曰。诸佛虽有无量力。度人因缘故。说十力足成办其事。以是处不是处智力。分别筹量众生是可度是不可度。以业报智力。分别筹量是人业障是人报障是人无障。以禅定解脱三昧智力。分别筹量是人着味是人不着味。以上下根智力。分别筹量众生智力多少。以种种欲智力。分别筹量众生所乐。以种种性智力。分别筹量众生深心所趣。以一切至处道智力。分别筹量众生解脱门。以宿命智力。分别众生先所从来。以生死智力。分别众生生处好丑。以漏尽智力分别筹量众生得涅槃。佛用是十种力度脱众生。审谛不错皆得具足。以是故佛虽有无量力但说此十力。复次是处不是处力定。知从是因缘出是果报。是中总摄九力。为欲度众生故。于初力中分别有九种。何以故。是世间众生现前见谷从种出。而不能知。何况心心数法因缘果报。佛于内外因缘果报。了了遍知故名为力。佛知是众生业烦恼因缘故缚。净禅定三昧解脱因缘故解。是一切众生三世三种诸业诸烦恼轻重深浅粗细。佛悉遍知故名力。一切众生诸禅定解脱三昧大小深浅解脱因缘。佛悉遍知故名力。众生钝根为后身故。作罪福业因缘。利根人为不生故集诸业。佛悉知此上下根好丑相故名力。知一切众生二种欲。作上下根因缘。二种欲善恶种种别异。佛悉遍知故名力。二种欲由二种性因缘故。遍知众生深心所趣故名力。一切众生种种性因缘故行二种道。所谓善道恶道种种门所至处。佛悉遍知故名力。过去未来世中因缘果报智慧无碍。是名宿命生死智力。知过去未来因果。已悉知方便坏因缘果报相续。是名漏尽力。佛知三世中二种因缘。分别筹量众生根欲性。为尽漏故说法。是漏尽力。问曰。何等为是处不是处力。答曰。佛知一切诸法因缘果报定相。从是因缘生如是果报。从是因缘不生如是果报。所以者何。如多性经中说。是处不是处相。女身作转轮圣王无是处。何以故。一切女人皆属男子。不得自在故。女人尚不得作转轮圣王何况作佛。若女人得解脱涅槃。亦因男子得。无有自然得道。二转轮圣王。一时出世无是处。何以故无怨业成就故。二转轮圣王尚不同世何况二佛。恶业得受乐报无是处。恶业尚不能得世间乐。何况出世乐。若恶行生天无是处。恶行尚不能得生天何况涅槃。五盖覆心散乱。离修七觉而得涅槃无是处。五盖覆心离修七觉。尚不能得声闻道何况佛道。心无覆盖佛道可得。何况声闻道。如是等是处不是处。多性经中佛口自说。诸论议师辈。依是佛语更广说是处不是处。若言佛有阙失罪过。若诸贤圣求外道师。若诸贤圣自言我是佛。若诸贤圣堕恶道。若见谛所断结使更生。若诸贤圣覆藏罪。若须陀洹二十五有皆无是处。如贤圣分别中广说。五逆人五种黄门堕四恶道。众生郁多罗越人魔眷属三障所遮。若言得道皆无是处。经说法者轻法自轻破戒愚痴。若言得具足法喜亦无是处。自言我是佛。此身口恶不悔欲见佛。若破僧罪不悔欲见佛。邪定入正定。正定入邪定。正定入不定。除佛法别有真得道人应得道身若死皆无是处。除因缘生识出名色更有法无是处。佛遣使事未讫。若遮碍无是处。入慈三昧若他因缘死入灭尽定。在见谛道中若死皆无是处。若害佛及佛母无是处。转轮圣王女宝象马主藏臣主兵臣。若在胎中死母子夭丧皆无是处。郁多罗越人女宝佛母。命终次身入恶道皆无是处。有为常涅槃无常。凡夫人能断非有想非无想结使。一切取相禅定中修圣道。无漏道有漏因。若地湿相水坚相火冷相风住相皆无是处。无明不能生诸行。乃至生不能生老死无有是处。二心一时生五识众。能分别取相。若着若离若眼能起身业口业。若眼能入禅定无有是处。但五识相续生不生意识但五识众中著有相续。但五识众能缘名能缘相。能缘无色法。能缘过去未来。能缘离三世法。但五识众中有增触明触修禅定。若受善律仪不善律仪。若忧喜若有无觉无观。若增益诸根皆无是处。鼻识舌识有隐没无记凡夫人第六识离我行无是处。如是等无量无是处。是处亦如是。佛知是处无是处。分别筹量可度者为说法。不可度者为作因缘。譬如良医知病可治不可治。声闻辟支佛所知少少故或不应度者欲度。如首罗应度而不度。如舍利弗所不度者。是佛无是事。无能坏无能胜。悉遍知故是名初力。业报智力者。身口所作业。及此生无作业所受戒业亦恶业。日夜随生业用生罪福业。是业佛略说三处摄。是名一切业相。佛知一切众生有业过去报亦过去。有业过去报在现在。有业过去报在未来。有业过去报在过去现在。有业过去报在过去未来。有业过去报在现在未来。有业过去报在过去未来现在。现在业亦如是。复次善心中。受善不善无记业报。不善心无记心亦如是。复次乐业因缘故受乐报。苦业因缘故受苦报。不苦不乐业因缘故。受不苦不乐报。现报业因缘故。受现报。生报业因缘故受生报。后报业因缘故受后报。不净业因缘故受恼报。净业因缘故受无恼报。杂业因缘故受杂报。复次二种业。必受报业不必受报业。必受报业不可得离。或待时待人待处受报。如人应共转轮圣王受福。待转轮圣王好世。出是时。乃受是为待时。待人者。人即是转轮圣王。待处者转轮圣王所出处。复次是必受报业。不待技能功勋。若好若丑不求自来。如天上生人福乐自至地狱中人罪苦自追。不待因缘此业深重故。复次必受报业。如毗琉璃军杀七万二千诸得道人及无量五戒优婆塞。如目连等大神通人所不能救。如薄拘罗后母投着火中汤中水中而不死。如佛游诸国。虽出家行乞不须膳供。而五百乘车载王所食。叶中生粳米。随饭百味羹。如是等善恶业必受。余者不必受。欲界受三种业报处。乐受业苦受业不苦不乐受业。色界受二种业报处。乐受业不苦不乐受业。无色界受一种业报处。不苦不乐受业。或待事者依是事得受业报。如弗迦罗婆王。池中生千叶金色莲华大如车轮。因是大会快乐。多人出家得道。佛知一切众生造诸业处。或欲界色界无色界。欲界在何道中。若天道在何天中。若人中在何天下。若阎浮提在何国。若是国在何城何聚落。何精舍何土地若是城在何里何巷。何舍在何处。知是业何等时作。过去一世二世乃至百千万世。是业果报几已受几未受几必受几不必受。知善不善所用事物。所谓刀杖教敕杀等。自杀遣人杀。诸余恶业亦如是。善业亦如是。知如是布施持戒修善。施中所施何等土地。房舍衣服饮食医药卧具七宝财物。戒中受戒自然戒心生戒口言戒一行戒少分戒多分戒满分戒一日戒七善道戒十戒具足戒定共戒。善福中修初禅二三四禅慈心悲喜舍心。如是等善业因缘。若悭贪若嗔恚若怖畏若邪见若恶知识等。种种恶业因缘福业因缘。若信若怜愍若恭敬若禅定若智慧若善知识等。种种善业因缘。是诸业自在。一切天及人。是诸业相无能转者。于亿千万世。常随逐众生不舍。如债主随人。得因缘具足便与果报。如地中种子。得因缘时节和合便生。是业能令众生六道中受生驶疾于箭。一切众生皆有诸业报分。如父母遗财。诸子皆应得分。是业果报时到不可遮止。如劫尽火随众生应生处处处安置。如大国王随其所应而与官职。人命终时是业来荫覆其心。如大山映物。是业能与种种身。如工画师作种种像。若人以正行业则与好报。若以邪行业则与恶报。如人事王随事得报。如是等分别诸业相果报。复次如分别业经中。佛告阿难。行恶人好处生。行善人恶处生。阿难言。是事云何。佛言。恶人今世罪业未熟。宿世善业已熟。以是因缘故。今虽为恶而生好处。或临死时善心心数法生。是因缘故亦生好处。行善人生恶处者。今世善未熟。过世恶已熟。以是因缘故。今虽为善而生恶处。或临死时不善心心数法生。是因缘故亦生恶处。问曰。熟不熟义可尔。临死时少许时心。云何能胜终身行力。答曰。是心虽时顷少而心力猛利。如火如毒虽少能成大事。是垂死时心决定猛健故。胜百岁行力。是后心名为大心。以舍身及诸根事急故。如人入阵不惜身命名为健。如阿罗汉。舍是身着故得阿罗汉道。如是等种种罪福业报。转报亦应如是。知声闻人但知恶业罪报善业福报。不能如是细分别。佛悉遍知是业及业报。智慧势力无碍无尽无能坏故。是名第二力。禅定解脱三昧净垢分别智力者。禅名四禅。佛知是禅佐助道法名相义分次第熏修有漏无漏学无学净垢味不味深浅分别等。八解脱如禅中分别相说。禅摄一切色界定。说解脱。摄一切定禅波罗蜜。即是诸解脱禅定三昧解脱禅三昧皆名为定。定名为心不散乱。垢名爱见慢等诸烦恼。净名真禅定。不杂爱见慢等烦恼如真金。分别名诸定中有一心行不一心行。常行不常行。难入易入。难出易出。别取相。总取相。转治不转治。转治如淫欲中慈心。嗔人不净观。愚痴人思惟边无边。掉戏心中用智慧分别诸法。没心中欲摄心。若不尔者名不转治。是定中应分别时及住处。若身瘦羸是非行定时。如菩萨苦行时。作是念。我今不能生禅定。若多人处亦非行定处。复次佛知是禅定失。是禅住是禅增益是禅到涅槃。复次佛知是人难入定难出定易入易出易入难出难入易出。佛知是人应得如是禅。知是人失禅受五欲。知是人受五欲已还得禅。依是禅得阿罗汉。如是等一切诸禅定解脱即是三昧是禅定。佛以甚深智慧尽知无能坏无能胜。是名第三力。知众生上下根智力者。佛知众生是利根钝根中根。利智名为上。钝智名为下。佛用是上下根智力。分别一切众生。是利根是中根是钝根。是人如是根。今世但能得初果。更不能得余。是人但能得第二第三第四果。是人但能得初禅。是人但能得第二第三第四禅。乃至灭尽定亦如是。是人当作时解脱证。是人当作不时解脱证。是人能得于声闻中第一。是人能得于辟支佛中第一。是人具足六波罗蜜。能得阿耨多罗三藐三菩提。如是知已。或为略说得度。或为广说得度。或为略广说得度。或以软语教或以苦语教或以软苦语教。佛亦分别。是人有余根。应令增生信根。是人应令生精进念定慧根。是人用信根入正位。是人用慧根入正位。是人利根为结使所遮。如鸯群梨摩罗等。是人利根不为结使所遮。如舍利弗目连等。知根虽钝而无遮。如周利般陀伽。有根钝而遮者。知是人见谛所断根钝思惟所断根利。思惟所断钝见谛所断利。是人一切根同钝同利。是人一切根不同钝不同利。是人先因力大。是人今缘力大。是人欲缚而得解。是人欲解而得缚。譬如鸯群梨摩罗。欲杀母害佛而得解脱。如一比丘。得四禅增上慢故还入地狱。知是人必堕恶道。是人难出是人易出。是人疾出是人久久乃出。如是等一切众生上下根相皆悉遍知。无能坏无能胜。是名第四力。知众生种种欲智力者。欲名信喜好乐。好五欲如孙陀罗难陀等。好名闻如提婆达等。好世间财利如须弥刹多罗等。好出家如耶舍等。好信如跋迦利等。好持戒如罗睺罗等。好施如施跋罗(丹注云佛姑甘露女所生)好头陀远离如摩诃迦叶。好坐禅如隶跋多等。好智慧如舍利弗等。好多闻如阿难等。好知毗尼如优婆离等。如是佛弟子各各有所好。凡夫人亦各各有所喜。或有喜淫欲或有喜嗔恚。复次佛知是人多欲多嗔多痴。问曰。何等是多欲多嗔多痴相。答曰。如禅经中说。三毒相是中应广说。知如是相已。多淫欲人不净法门治。多嗔人慈心法门治。多愚痴人因缘法门治。如是随所欲说法。所谓善欲随心为说。如船顺流。恶欲以苦切语教。如以榍出榍。是欲智中佛悉遍知。无能坏无能胜。是名第五力。性智力者。佛知世间种种别异性。性名积习。相从性生。欲随性作行。或时从欲为性。习欲成性。性名深心为事。欲名随缘起。是为欲性分别。世间种种别异者。各各性多。性无量不可数。是名世间别异。有二种世间。世界世间。众生世间。此中但说众生世间。佛知众生如是性如是欲从是处来。若成就善根不善根。可度不可度。定不定。必不必。行何行生何处在何地。复次佛知是众生种种性相。所谓随所趣向。如是处偏多。如是贵。如是深心事。如是欲。如是业。如是行。如是烦恼。如是礼法。如是定。如是威仪。如是知。如是见。如是忆想分别。尔所结使生。尔所结使未生。随所著生欲。随欲染心。随染心趣向。随向贵重。随贵重常觉观。随觉观为戏论。随戏论常念。随念发行。随发行作业。随作业果报。复次佛用是种种性智力。知是众生可度是不可度。是今世可度是后世可度。是即时可度。是异时可度。是现前可度。是眼不见可度。是人佛能度。是人声闻能度。是人共可度。是人必可度。是人必不可度。是人略说可度。是人广说可度。是人略广说可度。是人赞叹可度。是人折伏可度。是人将迎可度。是人弃舍可度。是人细法可度。是人粗法可度。是人苦切可度。是人软语可度。是人苦软可度。是邪见是正见。是着过去是着未来。是着断灭是着常。是著有见是着无见。是欲生是厌生。是求富贵乐。是着厚邪见。是说无因无缘。是说邪因缘。是说正因缘。是说无作业。是说邪作业。是说正作业。是说不求。是说邪求。是说正求。是贵我。是贵五欲。是贵得利。是贵饮食。是贵说戏乐事。是乐众。是乐愦闹是乐远离。是多行爱。是多行见。是好信。是好慧。是应守护是应舍。是贵持戒。是贵禅定。是贵智慧。是易悟。是讲说乃悟。是可引导。是句句解。是利根是钝根是中根。是易出易拔。是难出难拔。是畏罪。是重罪。是畏生死。是不畏生死。是多欲是多嗔是多痴。是多欲嗔。是多欲痴。是多嗔痴。是多欲嗔痴。是薄烦恼是厚烦恼。是少垢是多垢。是覆慧是衣裓慧是广慧。是人善知五众相十二入十八界十二因缘。是处非是处。苦集灭道。善知入定出定住定。复次佛知是欲界众生是色界是无色界众生。是地狱畜生饿鬼人天。是卵生胎生湿生化生。是有色是无色是有想是无想。是短命是长命。是但凡夫人未离欲。是凡夫人离下地欲未离禅欲。如是乃至非有想非无想。是向道是得果。是辟支佛。是诸佛无碍解脱。如是等种种分别。五道四生三聚假名障众入界。善根不善根。诸结使地业果。是可度是不可度灭智分别。以如是等分别。知世间种种别异性。得无碍解脱。如是等种种别异佛悉遍知。无能坏无能胜。是名第六力。一切至处道智力者。有人言业即是道。所以者何。业因缘故遍行五道有业。能断业能有所至。所谓三圣道分及无漏思。以是故诸业是一切至处道。复次有人言。五别五智三昧(丹云无漏三昧禅五支)住一切处利益事办。复有人言第四禅即是。何以故。第四禅一切诸定至处。如诸经中说。是善心定心不乱心摄心。皆入第四禅中。复次有人言。如身念处。即是至处道。是诸道利益之本。复有人言。一切圣道是用是圣道得随意利益。复有论者言。一切善道一切恶道一切圣道。各各知诸道至处。如毛竖经中说。佛悉遍知无能坏无能胜。是名第七力。宿命智力者。宿命有三种。有通有明有力。凡夫人但有通。声闻人亦通亦明。佛亦通亦明亦力。所以者何。凡夫人但知宿命所经。不知业因缘相续。以是故。凡夫人但有通无有明。声闻人知集谛故。了了知业因缘相续生。以是故。声闻人亦有通亦有明。若佛弟子先凡夫人时。得宿命智。入见谛道中知集因缘。第八无漏心得断见故。通变为明。所以者何。明名见根本。若佛弟子先得圣道。后宿命智生。亦知集因缘力故通变为明。问曰。若佛本为菩萨时。先得宿命智。诸菩萨离无所有处烦恼。后入圣道故。云何佛说我初夜得初明。答曰。是时非明。若佛在众中说我彼时得是明。示众人言是明初夜得。譬如国王未作王时生子。后作王时人问王子何时生。答言。王子某时生。是生时未作王。以今是王故以彼为王子。言王子彼时生。佛亦如是。宿命智生尔时未是明。但名通。后夜时知集因缘故。通变为明。后在众中说言。我初夜时得是明。问曰。通明义。如是云何为力。答曰。佛用是明。知己身及众生无量无边世中宿命因缘所更种种悉遍知。是为力。是名第八力。生死智力者。佛用天眼见众生生死处。凡夫人用是天眼。极多见四天下。声闻人极多傍见小千世界上下亦遍见。问曰。大梵王亦能见千世界有何等异。答曰。大梵王自于千世界中立则遍见。若在边立则不见余处。声闻人则不尔。在所住处常见千世界。辟支佛见百千世界。诸佛见无量无边诸世界。凡夫人天眼智。是通而非明亦如是。但见所有事。不能见随业因缘受生。如宿命中说。复次得天眼人中最第一者阿泥卢豆。色界四大造色半头清净是天眼。佛天眼四大造色遍头清净。是为差别。复次声闻人所住于三昧中得天眼。即所住三昧中能见。若有觉有观三昧。若无觉有观三昧。若无觉无观三昧。佛随所入三昧中住欲见尽见。若依无觉无观三昧中得天眼。入有觉有观三昧。若无觉有观三昧中。亦能见。复次声闻人用是天眼见时。所住三昧中心入余三昧天眼则灭。佛则不尔。心虽入余三昧天眼不灭。是智慧遍知一切众生生死所趣。无能坏无能胜。是名第九力。漏尽智力者。问曰。九力智慧分别有差别。漏尽则同。一切声闻辟支佛有何等异。答曰。虽漏尽是同。智慧分别大差别。声闻极大力思惟所断结生分住分灭分三时断。佛则不尔。一生分时尽断。声闻人见谛所断结使生时断。思惟所断三时灭。佛则见谛所断思惟所断无异。声闻人初入圣道时。入时与达时异。佛则一心中亦入亦达。一心中得一切智。一心中坏一切障。一心中得一切佛法。复次诸声闻人。有二种解脱。烦恼解脱法障解脱。佛有一切烦恼解脱。亦有一切法障解脱。佛自然得智慧。诸声闻人随教道行得。复有人言。若佛以智慧断一切众生烦恼。其智亦不钝不减。譬如热铁丸着少绵上。虽烧此绵而火热势不减。佛智慧亦如是。烧一切烦恼智力亦不减。复次声闻但知自尽漏。诸佛自知尽漏亦知尽他人漏。如净经中说。复次佛独知众生心中分别有九十八使一百九十六缠。除佛无有知者。佛亦独知苦法智苦比智中断尔所结使性。乃至道比智亦如是。思惟所断九解脱道中亦尔。佛悉遍知一切众生如是事声闻若少知少说皆随佛语。佛如是漏尽智慧力势。无能坏无能胜。是名第十力。问曰。是十力何者最胜。答曰。各各于自事中。大如水能渍火能烧。各自有力。有人言初力为大。能摄十力故。或言漏尽力大。事办得涅槃故。论者言是十力皆以无碍解脱为根本。无碍解脱为增上。问曰。若是十力独是佛事。弟子今世无人能得。佛何以故说。答曰。断人十力中疑故。无智人令心决定坚牢故。令四众欢喜。言我等大师独有如是力。不与一切众生共。又诸外道辈言。憍昙氏沙门常寂静处住。智慧缩没。以是故发至诚言。我十种智力四无所畏安立具足。在大众中说具足智慧教化众生。如师子吼转梵轮。一切外道及天世人无能转者。为止是谤故说是十力。问曰。好人法一事。智慧尚不应自赞。何况无我无所著人而自赞十力。如说

  自赞自毁　　赞他毁他　　如是四种
  智者不行

答曰。佛虽无我无所著。有无量力。大悲为度众生故。但说十力不为自赞。譬如好贾客导师。见诸恶贼诳诸贾客示以非道。导师愍念故语诸贾客。我是实语人。汝莫随诳惑者。又如诸弊医等诳诸病人。良医愍之语众病者。我有良药能除汝病。莫信欺诳以自苦困。复次佛功德深远。若佛不自说无有知者。为众生少说所益甚多。以是故佛自说是十力。复次有可度者必应为说。所应说中次第应说十力。若不说彼不得度。是故自说。譬如日月出时。不作是念。我照天下当有名称。日月既出必自有名。佛亦如是。不自念为有名称故自说功德。佛清净语言说法。光明破众生愚闇。自然有大名称。以是故佛自说十力等诸功德无有失。力名能有所办。用是十种力增益智慧故。能破论议师。用是十种力增益智慧故能好说法。用是十种力增益智慧故。能摧伏不顺。用是十种力增益智慧故。于诸法中得自在。如大国主于臣民大众中得自在。是为以声闻法略说十力义

大智度论卷第二十四大智度论释初品中四无畏义第四十(卷二十五)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

四无所畏者。佛作诚言。我是一切正智人。若有沙门婆罗门若天若魔若梵若复余众。如实言是法不知。乃至不见是微畏相。以是故我得安隐得无所畏安住圣主处。如牛王在大众中师子吼能转梵轮。诸沙门婆罗门若天若魔若梵若复余众实不能转。一无畏也。佛作诚言。我一切漏尽。若有沙门婆罗门若天若魔若梵若复余众。如实言是漏不尽。乃至不见是微畏相。以是故我得安隐得无所畏安住圣主处。如牛王在大众中师子吼能转梵轮。诸沙门婆罗门若天若魔若梵若复余众实不能转。二无畏也。佛作诚言我说障法。若有沙门婆罗门若天若魔若梵若复余众。如实言受是障法不障道。乃至不见是微畏相。以是故我得安隐得无所畏安住圣主处。如牛王在大众中师子吼能转梵轮。诸沙门婆罗门若天若魔若梵若复余众实不能转。三无畏也。佛作诚言。我所说圣道能出世间。随是道能尽诸苦。若有沙门婆罗门若天若魔若梵若复余众。如实言行是道不能出世间。不能尽苦。乃至不见是微畏相。以是故我得安隐得无所畏安住圣主处。如牛王在大众中师子吼能转梵轮。诸沙门婆罗门若天若魔若梵若复余众实不能转。四无畏也。问曰。以何事故说四无所畏。答曰。有人言。佛自称一切智一切见。世间一切经书技术智巧方便甚多无量。若一切众生共知一切事犹尚难。况佛一人而有一切智。或有是事有是难。佛将无有畏而欲断是疑妄。断是难故佛说四无所畏。复次若佛未出世间。外道等种种因缘。欺诳求道求福人。或食种种果。或食种种菜。或食种种草根。或食牛屎。或日一食稊稗。或二日或十日。一月二月一食。或噏风饮水或食水衣。如是等种种食。或衣树皮树叶草衣鹿皮。或衣板木。或在地卧。或卧杵上枝上灰上棘上。或寒时入水。或热时五热自炙。或入水死入火死投岩死断食死。如是等种种苦行法中。求天上求涅槃。亦教弟子令不舍是法。如是引致少智众生以得供养。譬如萤火虫日未出时少多能照。若日出时千光明照。月及众星皆无有明岂况萤火。若佛未出世。诸外道辈小明照世得供养。佛出世时以大智光明。灭诸外道及其弟子皆不复得供养。以失供养利故。便妄语谤佛及佛弟子。如孙陀利经中说。自杀孙陀利而谤佛。语众人言。世间弊人尚不为是。是人世间礼法尚不能知。何况涅槃。佛欲灭如是等诽谤故。自说实功德四无所畏言我独是一切智人。无有能如实言佛不能知。我不畏是事。我独一切诸漏及习尽。无有能如实言佛漏未尽。我不畏是事。我说遮涅槃道法。无有能如实言。是法不能遮涅槃。佛不畏是事。佛说苦尽道达到涅槃。无有能如实言。是道不能到涅槃。佛不畏是事。略说是四无所畏体。一者正知一切法。二者尽一切漏及习。三者说一切障道法。四者说尽苦道。是四法中若有如实言不能尽遍知。佛不畏是事。何以故。正遍知了了故。初二无畏为自功德具足故。后二无畏为具足利益众生故。复次初第三第四无畏中说智。第二无畏中说断。智断具足故。所为事毕。问曰。十力皆名智。四无所畏亦是智。有何等异。答曰。广说佛诸功德是力。略说是无畏。复次能有所作是力。无所疑难是无畏。智慧集故名力。散诸无明故名无畏。集诸善法故名力。灭诸不善法故名无畏。自有智慧故名力。无能坏者故名无畏。智慧猛健是力。堪受问难是无畏。集诸智慧是名力。智慧外用是无畏。譬如转轮圣王七宝成就是力。得是七宝已。周四天下无不降伏。是名无畏。又如良医善知药方是名力。合和诸药与人是名无畏。自利益是名力。利益他是无畏。自除烦恼是名力。除他烦恼是无畏。无能沮坏是名力。不难不退是无畏。自成己善是名力。能成他善是无畏。巧便智是名力。用巧智是无畏。一切智一切种智是名力。一切智一切种智显发是无畏。十八不共法是名力。十八不共法显发于外是无畏。遍通达法性是名力。若有种种问难不复思惟。即时能答是无畏。得佛眼是名力。佛眼见已可度者为说法是无畏。得三无碍智是名力。得应辩无碍是无畏。无碍智是名力。乐说无碍智是无畏。一切智自在是名力。种种譬喻种种因缘庄严语言说法是无畏。破魔众是名力。破诸外道论议师是无畏。如是等种种因缘。分别力无畏。问曰。何等名无所畏。答曰。得无所疑无所忌难。智慧不却不没衣毛不竖。在在法中如说即作是无畏。问曰。云何当知佛无所畏。答曰。若有所畏不能将御大众。能摄能舍能苦切治或软语教。如佛一时驱遣舍利弗目连等。还复怜愍心受。若有所忌难者。诸论议师辈住憍慢山顶。以外智慧心狂醉。皆言天下唯有我一人更无余人。自于经书决定知故。破他经书。论议以恶口訾毁。如狂象无所护惜。如是狂人庵跋咤长爪萨遮只尼揵昆卢坻等。诸大论议师皆降伏。若有所畏则不能尔。及憍陈如等五出家人。沤楼频螺迦叶等千结发仙人。舍利弗目揵连摩诃迦叶等。于佛法中出家。及百千释子。并诸阎浮提大王。波斯尼示王。频婆娑罗王。旃陀波殊提王。优填王。弗迦罗婆利王。梵摩达王等。皆为弟子。诸在家婆罗门皆度。一切世间智慧。为大国王所师仰。梵摩喻弗迦罗婆利鸠罗檀陀等。皆为弟子。有得初道有得第二第三第四道。诸大鬼神阿罗婆迦鞞沙迦等。诸大龙王阿波罗罗伊罗钵多罗等。鸯群梨摩罗诸恶人等。皆降化归伏。若有所畏不能独在树下师子座处坐。欲得阿耨多罗三藐三菩提时。魔王军众化作师子虎狼熊罴之首。或一眼或多眼或一耳或多耳。担山吐火四边围绕。佛以手指按地。眴息之顷即皆消灭。诸天阿修罗鞞摩质帝隶释提婆那民梵天王等。引导其心皆为弟子。若有所畏不能在此大众中说法。以无所畏故。能为如是诸天鬼神大众中说法故。名无所畏。复次佛于一切众生。最尊最上尽到一切法彼岸。得大名闻故。自说无所畏。复次且置是佛功德。佛一切世间功德亦无能及者。所畏法一切已拔根本故。所畏法者。弊家生弊生处恶色无威仪粗恶语等。弊家生者。如首陀罗。所谓担死人除粪养鸡猪。捕猎屠杀酤酒兵伍等。卑贱小家。若在大众中则多怖畏。佛从本已来常生转轮圣王种中。所谓顶生王快见王娑竭王摩诃提婆王。如是等名日王种家中生。亦以是故无所畏。弊生处者。安陀罗舍婆罗(裸国也)兜呿罗(小月氏)修利安息大秦国等。在此边国中生。若在大众中则多怖畏。佛在迦毗罗婆中国生故无所畏。恶色者。有人身色枯干羸瘦人不喜见。若在大众则亦有畏。佛金色光润如火照赤金山。有如是色故无所畏。无威仪者。进止行步坐起无有人仪。则有怖畏。佛无是事。粗恶语者。有人恶音声蹇吃重语无有次第。人所不喜则多怖畏。佛无是畏。所以者何。佛语真实柔软次第易了。不疾不迟不少不多不没不垢不调戏。胜于迦陵毗伽鸟音。辞义分明不中伤物。离欲故无染。灭嗔故无碍。除愚故易解。法喜增长故可爱。遮罪故安隐。随他心随解脱义深语妙。有因缘故言有理。譬喻故善显示。事讫故善会事。观种种众生心故杂说。久久皆入涅槃故一味。如是等种种无量庄严语故。佛于语中无所畏。佛但以如是等世间法尚无所畏。何况出世间法。以是故说佛有四无所畏。问曰。佛十力中有无所畏不。若有无所畏不应但言四。若有所畏云何言无畏成就。答曰。一智在十处名为佛。成就十力。如一人知十事随事受名。是十力四处出用。是无所畏。是处不是处力。漏尽力。即是初二无畏。八力虽广。说是第三第四无畏。以是故十力中虽有无畏。别说亦无失。正遍知者。知一切法不颠倒正不邪。如余过去诸佛。是名三藐三佛陀。如佛告阿难。一切世间天及人所不能知。佛能遍知故。名三藐三佛陀。若有人言是法不知。问曰。是何人。答曰。是中佛说。若沙门婆罗门若天若魔若梵。乃至欲与佛论者。论何等法。有人言。佛所不说外诸经书弊迦兰那僧佉韦陀等。十八种大经书。有人言。须弥山斤两大地深浅一切草木头数。有人言。是常无常有边无边十四难佛不能答。有人言。是法色法无色法可见不可见有对无对有漏无漏有为无为等。佛但知一种道事因缘。是异法种种因缘。佛或不悉知。沙门者说出家人。婆罗门者。说在家有智人。天者说地天虚空天。魔者说六欲天。梵者说梵天王为首。及一切色界。余者除此更有余人。如实者。若以现事若以因缘难。乃至不见是微畏相者。相名因缘。我不见小小因缘。如法能来破我者。以不见故至诚言安立阿梨沙(秦言圣主)住处。佛至诚言。我一切漏尽。若有人言。是漏不尽者无有畏也。何等是漏。漏名三漏。欲漏有漏无明漏。复次漏名六情中出垢心相应心数法。复次如一切漏障经中分别说七漏障道法。名诸有漏业及一切烦恼恶道报障。为世间故。布施持戒修十善道受诸味禅。略说若能障涅槃。若善若不善若无记。是名障道法。有人言。道名二法。圣定圣慧是二事等达到涅槃。有人言。三聚道无漏戒定慧。有人言。四法所谓四圣谛。有人言。出世间五根。有言六出性。有言七觉意。有言八圣道达到涅槃。论议师等言。一切无漏道达到涅槃。是中若有沙门婆罗门等来。如实言是事不尔。乃至不见微畏相。以不见故至诚言安立阿梨沙住处。问曰。何以故佛至诚言安立阿梨沙住处。答曰。自功德具足。亦令众生得安乐利益。若佛自得安乐住处。不能利益众生。不名阿梨沙住处。若但利益众生。不自具足功德。亦不名阿梨沙住处。若自有功德亦利益众生。以是故至诚言我安立阿梨沙住处。复次佛自灭恶。亦灭众生恶。灭二恶故第一清净。妙说法故安立阿梨沙住处。复次四圣谛三转十二行。能转能分别显示敷演故。至诚言我安立阿梨沙住处。复次一切疑悔邪见能除却故。一切甚深问难悉能解释。故名安立阿梨沙住处。(阿梨沙第一最上极高。不退不却不没。具足功德无所减小。是名阿梨沙住处)如是等因缘功德力故。至诚言我安立阿梨沙住处。众中师子吼者。众名八众。沙门众婆罗门众刹利众。天众四天王众。三十三天众。魔众梵众。众生于此八众悕望智慧。是故经中但说是八众。此中佛师子吼亦在一切众中。以是故此经中言。若复余众。何以故。闻佛音声者。尽皆是众。复次有人言。佛独屏处说法。以是故说在众中作是至诚言。我有十力四无所畏。是名众中师子吼。复次佛示我是至诚言。我为一切世间师一切智人。诸有疑不信者悉来我当解释。以是故言众中师子吼。师子吼者。如师子王。清净种中生。深山大谷中住。方颊大骨身肉肥满。头大眼长光泽明净。眉高而广牙利白净。口鼻方大厚实坚满。齿密齐利吐赤白舌。双耳高上髦发光润。上身广大肤肉坚着。修脊细腰其腹不现。长尾利爪其足安立。巨身大力从住处出偃脊频伸。以口扣地现大威势。食不过时显晨朝相。表师子王力。以威獐鹿熊罴虎豹野猪之属。觉诸久睡降伏高强。有力势者自开行路而大哮吼。如是吼时。其有闻者或喜或怖。穴处者隐缩。水居者深入。山藏者潜伏。厩象振锁狂逸而去。鸟飞空中高翔远逝。佛师子亦如是。从六波罗蜜古四圣种大姓中生。寂灭大山深浚禅定谷中住。得一切种智头。集诸善根颊。无漏正见修目光泽。定慧等行高广眉。四无所畏牙白利。无碍解脱具足口。四正勤坚满颐。三十七品齿密齐利。修不净观吐赤白舌。念慧耳高上。十八不共法髦发光润鲜白。三解脱门上身肉坚着。三示现修脊。明行具足腹不现。忍辱腰纤细。远离行尾长。四如意足安立。无学五根爪利。十种力势无量。无漏法众具足身。诸佛三昧王等住处出。四无碍智频申。诸法地中着无碍解脱口。依是十力广度众生。时不过。示一切世间天及人晨朝相。显诸法王德。威诸外道论议师党邪见之属。觉诸众生四谛中睡。降伏吾我着五众者憍慢力。开异学论议诸邪见道。行邪者怖畏。信正者欢喜。钝者令利安慰弟子破坏外道。长寿诸天久受天乐则知无常。如是众生闻四谛师子吼皆生厌心。厌心故得离。得离故入涅槃。是名众中如师子吼。复次佛师子吼及师子吼有差别。师子吼者众兽惊怖。若死若近死苦。佛师子吼得免死畏。师子吼怖世世死苦。佛师子吼但今世死更无后苦。师子吼者其声粗恶物不喜闻。生死怖畏。佛师子吼其声柔软。闻者无厌心皆深乐。普遍远闻能与二种乐。生天乐涅槃乐。是为差别。问曰。佛师子吼亦令闻者生怖。与师子吼有何等异。答曰。闻佛师子吼。当时小怖后大利益。着吾我心者渴爱世间乐。人常颠倒所缚邪见心者生怖畏。如经中言。佛说四谛乃至上诸天悉皆怖畏作是念。我等无常相苦相无我相空相。何以故。为颠倒心故着常乐相。是为差别。复次闻师子吼者。除离欲人余者皆怖畏。佛师子吼求涅槃。离欲人皆怖。师子吼者善人不善人皆怖。佛师子吼者但善人怖。复次师子吼一切时怖畏。佛师子吼虽小怖畏。众生示世间恶罪。令不乐世间生。观涅槃功德利益。能除世间种种怖畏。闭恶趣开善道。能令人到涅槃城。复次二十事故。佛语名师子吼。所谓依止十力故。不缩故。不展故。梵音故。未曾有故。能引大众故。恶魔惊怖故。扰乱魔民故。诸天欢喜故。得出魔网故。断魔缚故。破魔钩故。过魔界故。自法增长故。减损他法故。果报不诳故。说法不空故。凡夫人入圣道故。入圣道者得具足漏尽故。随所应得三乘故。以是故佛语名师子吼。是名师子吼总相别相义。转梵轮者清净故名梵。佛智慧及智慧相应法是名轮。佛之所说。受者随法行是名转。是轮以具足四念处为毂。五根五力为辐。四如意足为坚牢辋。而正勤为密合轮。三解脱为榍。禅定智慧为调适。无漏戒为涂轮香。七觉意为杂华璎珞。正见为随右转轮。信心清净为可爱喜。正精进为疾去。无畏师子吼为妙声能怖魔轮破十二因缘节解轮。坏生死轮离烦恼轮。断业轮障世间轮破苦轮。能令行者欢喜天人敬慕。是轮无能转者。是轮持佛法。以是故名转梵轮。复次佛转法轮。如转轮圣王转宝轮。问曰。佛与转轮圣王有何相似。答曰。如王清净不杂种中生。随姓家业成就。众相庄严身。王德具足能转宝轮。香汤灌顶受王位。于四天下之首。坏除一切贼法令无敢违。宝藏丰溢军容七宝以为校饰。以四摄法摄取众生。善用王法委任贵姓。主兵大臣以治国政。妙上珍宝乐以布施。有所知念终始无异。佛法王亦如是。释迦牟尼然灯宝华等佛诸佛清净姓中生。先佛威仪行业。具足三十二相以自庄严。圣主威德备具转真法轮。智慧甘露味灌智首。于三界中尊。破坏一切烦恼贼。学无学众欢喜。所结禁戒无敢违者。无量法宝藏具足。七觉分宝庄严。八万四千法聚军。出世间四摄法以摄众生。知方便说四圣谛法为法王仪。舍利弗弥勒等大将善治佛国法。诸无漏根力觉。种种妙宝乐以布施。深求一切众生善事。为所念坚固。是为相似。复次佛于转轮圣王有殊胜。转轮圣王不离诸烦恼。佛已永离诸烦恼。转轮圣王没在老死泥。佛已出离。转轮圣王为恩爱仆。佛已过出。转轮圣王行生死险道中。佛已过度。转轮圣王在愚痴闇中。佛住第一光明中。转轮圣王极自在四天下。佛自在无量无边世界。转轮圣王财宝自在。佛心宝自在。转轮圣王渴乐天乐。佛乃至有顶乐已离。转轮圣王从他求乐。佛自心生乐。以是故佛于转轮圣王为最殊胜。复次转轮圣王手转宝轮空中无碍。佛转法轮一切世间天及人中无碍无遮。其见宝轮者众毒皆灭。遇佛法轮一切烦恼毒皆灭。见宝轮者诸灾恶害皆灭。遇佛法轮一切邪见疑悔灾害皆悉消灭。王以是轮治四天下。佛以法轮治一切世间天及人。令得法自在。是为相似。复次法轮于宝轮大有殊胜。宝轮欺诳法轮坚实。宝轮长三毒火。法轮灭三毒火。宝轮有漏。法轮无漏。宝轮乐五欲乐法轮乐法乐。宝轮结使处。法轮非结使处。宝轮有量处行。法轮无量国行。宝轮以一心清净布施故世世可得。法轮无量阿僧祇劫。集一切善业因缘及智慧故得。宝轮王死后更不转。佛灭度后法轮犹转。宝轮在一人。法轮在一切可度者。复次梵名广。佛转法轮十方无不遍故名广。复次四梵行心说故名梵轮。复次佛初得道时。梵天王请转法轮故名梵轮。复次佛在波罗柰转法轮。阿若憍陈如。得道声彻梵天故名梵轮。复次有人贵梵天。欲令欢喜故名梵轮。以是故名梵轮。问曰。佛或时名法轮。或时名梵轮。有何等异。答曰。说梵轮法轮无异。复次有人言说梵轮者。现四无量心。说法轮者示四谛法。复次梵轮因四无量心得道。是名梵轮。依余法得道是名法轮。梵轮示四禅。法轮示三十七品。梵轮示修禅定圣道。法轮示修智慧圣道。如是等分别梵轮法轮差别。问曰。何法是无畏性。答曰。佛初得道时。得一切佛法十力四无所畏等。此中未来世。得四无所畏智相应法。名无所畏。如布施时心中思相应舍法生。又如四无量心相应名慈法门。问曰。是四无所畏中有何次第。答曰。初无畏中示人知一切法。知一切法故我漏尽。漏尽故知障漏尽法。断是障法故说道。复次初无畏。如示药师一切药草。第二示一切病灭。第三知禁忌第四示所应食。复次初无畏中。说一切种智。第二无畏中。说无一切烦恼习。第三无畏中。说法无谬失。第四无畏中。所说事办得至涅槃。问曰。如般若波罗蜜中说。五众乃至十力四无所畏十八不共法皆空。今云何分别说其相。答曰。佛法中不可得空。于诸法无所碍。因是不可得空。说一切佛法十二部经。譬如虚空无所有而一切物皆依以长成。复次是十力四无所畏。不以取相着心分别故。但为度众生。知众生从是因缘得解脱。譬如药草但为差病。不为求药草相。如中论中说

  若信诸法空　　是则顺于理
  若不信法空　　一切皆违失
  若以无是空　　无所应造作
  未作已有业　　不作有作者
  如是诸法相　　谁能思量者
  唯有净直心　　所说无依止
  离于有无见　　心自然内灭

问曰。声闻法。说十力四无所畏如是。摩诃衍分别十力四无所畏复云何。答曰。是十力四无所畏中尽知遍知。是摩诃衍中说十力四无所畏。问曰。声闻法中亦说尽知遍知。云何言摩诃衍中说尽知遍知。答曰。诸论议师说。佛尽知遍知非佛自说。今说摩诃衍中十力四无所畏故。佛自说我尽知遍知。复次为声闻人。说十力四无所畏。合说四谛十二因缘等。诸声闻法皆为到涅槃今说摩诃衍中十力四无所畏合大悲诸法实相不生不灭说。问曰。佛有十力四无所畏。菩萨有不。答曰有。何者是。一者发一切智心坚深牢固力。二者具足大慈故不舍一切众生力。三者不须一切供养恭敬利故具足大悲力。四者信一切佛法具足生一切佛法及心不厌故大精进力。五者一心惠行威仪不坏故。禅定力。六者除二边故。随十二因缘行故。断一切邪见故。灭一切忆想分别戏论故。具足智慧力。七者成就一切众生故。受无量生死故。集诸善根无厌足故。知一切世间如梦故。不厌生死力。八者观诸法实相故。知无吾我无众生故。信解诸法不出不生故。无生法忍力。九者入空无相无作解脱门观故。知见声闻辟支佛解脱故。得解脱方。十者深法自在故。知一切众生心行所趣故。具足无碍智力。是为菩萨十力。何等为菩萨四无所畏。一者一切闻持故。诸陀罗尼得故。忆念不忘故。在众说法无所畏。二者一切法中得解脱故。一切法药分别知用故。知一切众生根故。在大众中随应说法无所畏。三者菩萨常离一切众畏。不作是念十方有来难我者我不能答。不见是相在大众中说法无所畏。四者恣一切人来问难者。一一皆答能断疑惑。在大众中说法无所畏。是为菩萨四无所畏。四无碍智者。义无碍智法无碍智辞无碍智乐说无碍智。义无碍智者。用名字言语所说事。各各诸法相。所谓坚相。此中地坚相是义。地名字是法。以言语说地是辞。于三种智中乐说自在是乐说。于此四事中。通达无滞是名无碍智。湿相水。热相火。动相风。心思相五众无常相。五受众无常苦空相。一切法无我相。如是等总相别相。分别诸法亦如是。是名义无碍智。法无碍智者。知是义名字。坚相名为地。如是等一切名字分别中无滞。是名为法无碍智。所以者何。离名字义不可得。知义必由于名。以是故次义有法。问曰。义之与名为合耶。为离耶。若合名。说火时应烧口。若离。说火时应得水。答曰。亦不合亦不离。古人假为立名以名诸法。后人因是名字识是事。如是各各有名字。是为法。是名字及义。云何令众生得解。当以言辞分别庄严能令人解通达无滞。是名辞无碍智。说有道理开演无尽。亦于诸禅定中得自在无滞。是名乐说无碍智。第一第四无碍智在九地中。第二第三无碍智。在欲界及梵天上。第二第三无碍世智。第一十智第四九智。是无碍三种上中下。上诸佛中大菩萨下大阿罗汉。问曰。力无所畏无碍皆是智慧。内有力外无所畏则具足。何以复说无碍。答曰。力无畏已分别。有人虽无所畏在大众中说法而有碍。以是故说四无碍智。得是无碍智庄严四无所畏。四无所畏庄严十力。复次说无所畏。或有疑者言。云何一人于大众中得无所畏。佛以前有十力。后有四无碍智。是故在大众中说法无所畏。如是等分别四无碍智。问曰。摩诃衍中。有菩萨四无碍智不。答曰有。何者是。义无碍智者。义名诸法实相不可言说。义名字语言不别异。前后中亦如是。是名义不应离名字语言别有义。三事等故名为义。复次一切诸法义。了了知通达无滞。是名义无碍智。法无碍智者。法名一切义。名字为知义故。复次菩萨入是法无碍智中。常信法不信人。常依法不依非法。依法者无非法事。何以故是人一切诸名字。及语言知自相离故。复次以是法无碍智分别三乘。虽分别三乘而不坏法性。所以者何。法性一相所谓无相。是菩萨用是语言说法知语言空。如响相所说法示众生。令信知同法性。所说名字言语通达无滞。是名法无碍智。辞无碍智者。以语言说名字义。种种庄严语言。随其所应能令得解。所谓天语龙夜叉揵闼婆阿修罗迦楼罗摩睺罗伽等非人语。释梵四天王等世主语人语。一语二语多语略语广语女语男语过去未来现在语。如是等语言能令各各得解。自语他语无所毁誉。所以者何。是一切法不在语中语是非实义。若语是实义。不可以善语说不善。但为入涅槃故。说令解莫着语言。复次用是语言。能令众生随法义行。所以者何。言语皆入诸法实相中。是名辞无碍智。乐说无碍智者。菩萨于一字中。能说一切字。一语中能说一切语。一法中能说一切法。于是中所说皆是法皆是实皆是真。皆随可度者而有所益。所谓乐修妒路者。为说修妒路。乐祇夜者为说祇夜。乐弊迦兰陀者为说弊迦兰陀。乐伽陀优陀那阿波陀那一筑多阇陀为头离頞浮陀达摩优波提舍。皆为说是经。随一切众生根乐说。若好信者为说信根。好精进者为说精进根。好勤念者为说念根。好摄心者为说定根。好智慧者为说慧根。如五根等一切善根亦如是。复次二万一千淫欲人根。为是根故。佛说八万四千治法根。随是诸根。乐说治法次第。菩萨乐说二万一千嗔恚人根。为是根故。佛说八万四千治法根。随是诸根。乐说治法次第。菩萨乐说二万一千愚痴人根。为是根故。佛说八万四千治法根。随是诸根。乐说治法次第。菩萨乐说二万一千等分人根。为是根故。佛说八万四千治法根。随是诸根。乐说治法次第。菩萨乐说是名乐说无碍智。复次菩萨用是无碍智。若一劫若半劫。各各庄严说法。亦不坏诸法性相。是菩萨或隐身不现。而为众生用一切毛孔说法。随其所应不失本行。是菩萨智慧无量。一切论议师不能穷尽亦不能坏。是菩萨得是无碍智转身受生时。一切五通仙人所有经书咒术智慧技能自然悉知。所谓四韦陀六鸯伽咒术。知日月五星经原梦经地动鬼语鸟语兽语四足兽鬼着人语国王相占丰俭日月五星斗相医药章算数卜歌舞伎乐。如是等工巧技术诸经尽知明达。过一切人及诸外道。亦不自高亦不恼他。知是俗事不为涅槃。是菩萨成就四无碍智故。色力光明殊于诸梵。诸梵恭敬爱乐尊重心无所著。为如是等一切诸天所尊重恭敬亦无所著。但生无常苦空无我心。亦以神通发起诸天令心渴仰而为说法无尽无坏。断除疑悔令住阿耨多罗三藐三菩提。是名摩诃衍中菩萨四无碍智力能度众生。是名四无碍智义

大智度论卷第二十五大智度论初品中十八不共法释论第四十一(卷第二十六)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

十八不共法者。一者诸佛身无失。二者口无失。三者念无失。四者无异想。五者无不定心。六者无不知已舍。七者欲无减。八者精进无减。九者念无减。十者慧无减。十一者解脱无减。十二者解脱知见无减。十三者一切身业随智慧行。十四者一切口业随智慧行。十五者一切意业随智慧行。十六者智慧知过去世无碍。十七者智慧知未来世无碍。十八者智慧知现在世无碍。问曰。是三十六法皆是佛法。何以故。独以十八为不共。答曰。前十八中声闻辟支佛有分。于后十八中无分。如舍利弗能分别诸法畅演一句通达无碍。佛赞言善通法性。阿泥卢豆天眼第一。如是等诸声闻。皆有分于四无所畏。有分者如佛说。弟子中能师子吼。第一宾徒罗叵罗埵逝。舍利弗亦自誓言。我七日七夜能演畅一义。令无穷尽四分别慧。诸阿罗汉舍利弗目揵连富楼那阿难迦栴延等亦知是义。名字语言乐说。以是故前十八不名不共。问曰。何以故佛无身失无口失。答曰。佛于无量阿僧祇劫来。持戒清净故身口业无失。余诸阿罗汉。如舍利弗等。极多六十劫。不久习戒故有失。佛无量阿僧祇劫。集诸清净戒成就故。常行甚深禅定故。得一切微妙智慧故。善修大悲心故无有失。复次佛拔诸罪根因缘故无有失。罪根本因缘有四种。一者贪欲因缘。二者嗔恚因缘。三者怖畏因缘。四者愚痴因缘。是罪根因缘及习皆已拔。阿罗汉辟支佛。虽拔罪因缘习不尽故。或时有失。佛于一切法中。遍满智慧常成就故。若不知故有失。如舍利弗。与五百比丘游行。至一空寺宿。是时说戒日。不知内界外界事。白佛。佛言。住处乃至一宿弃舍则无界。又异时舍利弗目揵连。将五百比丘还时。高声大声故。佛驱遣令出。是为口失。又如舍利弗。不知等食法。佛言。食不净食。如是等身口有失。佛诸烦恼习尽故无如是失。复次佛一切身口业随智慧行故。身无失口无失。如是等种种因缘故。身无失口无失。念无失者。四念处心长夜善修故。善修甚深禅定。心不散乱故。善断欲爱及法爱。诸法中心无著故。得第一心安隐处故。若心懅匆匆念有忘失。佛心无得失。以是故无失。复次佛宿命通明力三种庄严念故。念则成就无失。念多在过去用故。复次念根力无边无尽故念无失。复次佛一切意业随智慧行故念无失。一一念随意行故。如是等名为念无失。如天问经中说

  何人无过失　　何人不失念
  何人常一心　　应作者能作
  正知一切法　　一切障得脱
  诸功德成就　　唯有佛一人

无异想者。佛于一切众生。无分别无远近异想。是贵可为说。是贱不可为说。如日出普照万物。佛大悲光明一切怜愍等度。恭敬者不恭敬者。怨亲贵贱一切悉等。如客除粪人名尼陀。佛化度之得大阿罗汉。亦如德护居士火坑毒饭欲以害佛。即以其日除其三毒灭邪见火。如是等无有异想。复次佛于舍利弗弥勒菩萨等顺佛法行亦不爱。提婆达多富罗那外道六师邪见等亦不憎。是为佛于无量阿僧祇劫修熏心故。是众生中宝。如真金不可令异。复次佛以佛眼。一日一夜各三时观一切众生。谁可度者无令失时。等观众生故无有异想。复次佛种种因缘赞善法。种种因缘呵不善法。亦于善于恶心无增减。但为度众生故有是分别。是为无有异想。复次如一切不行经中说。佛观一切众生如己身。所作已办。无始无中无终。是名无异想。复次佛观一切众生及诸法。从本已来至不生不灭常清净如涅槃。是名无异想。复次不二入法门。是诸法实相门。异相即是二法。二法即是邪道。佛是无诳法人。不应行诳法。常行不二入法门。诳法即是异相。如是等名无异想。无不定心者。定名一心不乱。乱心中不能得见实事。如水波荡不得见面。如风中灯不得好照。以是故说佛无不定心。问曰。定名从未到地乃至灭尽定。入此定中不能起身业口业。佛若常定无不定心者。云何得游行诸国。具四威仪。为大众种种因缘譬喻说法。如是事欲界系心及梵世。不入定可有是事。答曰。无不定心者。有种种义。定名常摄心善法中住。佛于诸法实相中。定不退失。是名无不定心。复次欲界中有定。入是定中可说法。以是故阿毗昙中。说欲界系四圣种四念处四正勤四如意足五根五力无诤三昧愿智四无碍智。有如是等妙功德。佛入欲界中定故。名无不定心。诸声闻辟支佛从定起。若入无记心若入善。或退入垢心。佛从定起入欲界定。初无散乱心时。以是故名无不定心。复次如声闻法。化人说法化主不说。化主说化人不说。佛则不尔。化人化主俱能说法。定心亦应异。声闻入定则无说。佛在定亦能说法亦能游行。如密迹经心密中说。诸佛心常在定中。心亦应说法。复次散乱心法诸结使疑悔等佛皆无。阿罗汉虽无四谛中疑。一切法中处处有疑。佛于一切法中常定无疑。无不定智慧故。复次声闻有诸烦恼习气故。有退法故散乱。佛于一切智处中。智满故无乱。如瓶中水满则无声无动。复次唯佛一人名不诳法。三坚固人中最上。苦乐心不异。一相异相生灭相断常相来去相。如是等诸法相。皆是诳法。虚妄和合作法故。佛安立于诸法实相中故心无不定。无不定故心不异。复次五种不可思议法中。佛最不可思议。是十八不共法。是佛甚深藏。谁能思议者。以是故佛无不定心事必当尔。佛虽常入定无觉观粗心。有不可思议智慧故亦能说法。譬如天乐随天所好种种声。应是亦无心亦无识法。以诸天福德因缘故。有是如天乐无心无识而能应物。何况佛有心而不说法。以是故说佛无不定心。无不知已舍者。众生有三种受。苦受乐受不苦不乐受。苦受生嗔乐受生爱不苦不乐受生愚痴。是三种受。苦受生苦住苦灭乐。乐受生乐住乐灭苦。不苦不乐受。不知为苦不知为乐。余人钝根故。多觉苦受乐受。于不苦不乐受中。不觉不知而有舍心。是为痴使所使。佛于不苦不乐受中。知觉生时觉住时觉灭时。以是故言佛无不知已舍心。问曰。此中何等为舍。不苦不乐即是舍耶。为七觉中舍。四无量心中舍名为舍。答曰。不苦不乐即是舍二处舍亦是舍。何以故。余人于不苦不乐受中。不觉念念中生时住时灭时久远乃觉。佛念念中尽皆了知。七觉中舍若心正等。不没不掉是时应舍。若没时行精进想。若掉时行摄心想。诸声闻辟支佛。或时错摄心掉心。未平等便舍。佛于念念心中粗细深浅无不悉知。知已而舍。问曰。若尔者佛何以为难陀说告诸比丘。难陀诸受生时觉住时觉灭时觉。诸想诸觉亦如是。答曰。觉有二种。一者觉心中。苦受生知苦受生。苦受住知苦受住。苦受灭知苦受灭。乐受生知乐受生。乐受住知乐受住。乐受灭知乐受灭。不苦不乐受亦如是。但能知是总相。不能别相知。二者念念中苦乐。不苦不乐受中悉觉悉知。念念中心数法。无不知而过。以是故说佛无不知已舍。复次佛或时舍众生。入甚深禅定一月二月。有人疑佛为度众生故出世。何以故常入定。佛言。我种种因缘知故舍。非是无知已舍。问曰。何等是知已舍因缘。答曰。于大众中疲厌故小息。复次佛世世常爱远离行。若菩萨在母胎。母亦乐远离行。去城四十里。岚鞞尼林中生。得道时沤楼频螺林中独在树下成佛。初转法轮时。亦在仙人住处鹿林中。入涅槃时在娑罗林双树下。长夜乐行远离。以是故佛入禅定。复次佛常舍心成就故入禅定。复次佛远离愦闹及杂语处。亦自观诸佛功德藏。亦受第一清净乐故入禅定。复次佛说法已常教诸比丘。当坐禅无令后悔。口之所说身亦自行故入禅定。复次厌恶供养故。知众生应得度者。入禅定作化人往度。复次有众生定少慧多者。身示行禅以教化之。复次有人常见佛生厌想故。小远离令其饥虚故。复次佛欲为诸天说法故在闲静处。复次佛为后世作法故坐禅。又佛自转法轮已。以事付弟子故入禅定。复次现二种道摄众生故。一者禅定二者智慧。佛在大众说法为现智慧。静处摄心为现禅定。复次众生于六尘中三种行。见好色生喜乐。见恶色生忧苦。见不苦不乐色生舍心。乃至法亦如是。佛于六尘中自在。于喜乐苦处能生舍心。如圣如意中说。如是等种种因缘故入禅定。非不知已舍。欲无减者。佛知善法恩故。常欲集诸善法故。欲无减。修习诸善法。心无厌足故欲无减。譬如一长老比丘。目闇自缝僧伽梨。针纴脱。语诸人言。谁乐欲福德者为我纴针。尔时佛现其前语言。我是乐欲福德无厌足人。持汝针来。是比丘斐亹见佛光明。又识佛音声。白佛言。佛无量功德海皆尽其边底。云何无厌足。佛告比丘。功德果报甚深。无有如我知恩分者。我虽复尽其边底。我本以欲心无厌足故得佛。是故今犹不息。虽更无功德可得。我欲心亦不休。诸天世人惊悟。佛于功德尚无厌足。何况余人。佛为比丘说法。是时肉眼即明慧眼成就。问曰。如佛尝断一切善法中欲。今云何言欲无减。答曰。言断一切善法中欲者。是未得欲得。得已欲增。佛无如是欲。佛一切功德具足。无不得者亦无增益。今言欲者。如先说。佛虽具得一切功德。欲心犹不息。譬如马宝虽到至处去心不息至死不已。佛宝亦如是。又如劫尽大火。烧三千大千世界悉尽。火势故不息。佛智慧火亦如是。烧一切烦恼。照诸法已智慧相应欲亦不尽。复次佛虽一切善法功德满足。众生未尽故欲度不息。问曰。若佛欲度众生未息。何以入涅槃。答曰。度众生有二种。或有现前得度。或有灭后得度。如法华经中说。药师为诸子合药与之而舍。是故入涅槃。复次有众生钝根德薄故。不能成大事。但可种福德因缘。是故入涅槃。问曰。佛灭度后。亦有得阿罗汉者。何以言但可种福德因缘。答曰。虽有得阿罗汉者少不足言。如佛一说法时。十方无量阿僧祇众生得道。佛灭度后不尔。譬如大国。征伐虽少有所得不名为得。以是故虽众生未尽而入涅槃。复次摩诃衍首楞严经中说。佛于庄严世界。寿七百阿僧祇劫度脱众生。以是故说佛欲无减。精进无减者。如欲中说欲义即是精进。问曰。若尔者无有十八不共法。复次欲以精进。心数法中各别。云何言欲即是精进。答曰。欲为初行。欲增长名精进。如佛说。一切法欲为根本。欲如人渴欲得饮。精进如因缘方便求饮。欲为心欲得。精进为成其事。欲属意业精进属三业。欲为内精进为外。如是等差别。复次是精进诸佛所乐。如释迦牟尼佛。精进力故超越九劫。疾得阿耨多罗三藐三菩提。复次如说一时佛告阿难。汝为诸比丘说法。我背痛小息。尔时世尊。四襞郁多罗僧敷下。以僧伽梨枕头而卧。是时阿难说七觉义。至精进觉佛惊起坐。告阿难。汝赞精进义。阿难言赞。如是至三。佛言。善哉善哉。善修精进。乃至得阿耨多罗三藐三菩提。何况余道。以是义故佛精进无减。病时犹尚不息。何况不病。复次佛为度众生故。舍甚深禅定乐。种种身种种语言种种方便力度脱众生。或时遇恶险道。或时食恶食或时受寒热。或时值诸邪难闻恶口骂詈忍受不厌。佛世尊虽于诸法中自在而行是事。不生懈怠。如佛度众生已。于萨罗林中双树下卧。梵志须跋陀语阿难。我闻一切智人今夜当灭度。我欲见佛。阿难止之言。佛为众人广说法疲极。佛遥闻之告阿难。听须跋陀入。是我末后弟子。须跋陀得入问佛所疑。佛随意说法断疑得道。先佛入无余涅槃。诸比丘白佛言。世尊。甚为希有。乃至末后怜愍外道梵志而共语言。佛言。我非但今世末后度。先世未得道时亦末后度。乃往过去无量阿僧祇劫。有大林树多诸禽兽。野火来烧三边俱起。唯有一边而隔一水。众兽穷逼逃命无地。我尔时为大身多力鹿。以前脚跨一岸。以后脚。距一岸。令众兽蹈背上而渡。皮肉尽坏以慈愍力忍之至死。最后一兔来。气力已竭自强努力忍令得过。过已背折堕水而死。如是久有非但今也。前得度者今诸弟子。最后一兔须跋陀是。佛世世乐行精进今犹不息。是故言精进无减。念无减者。于三世诸法。一切智慧相应故念满足无减。问曰。先已说念无失。今复说念无减。念无失念无减为一为异。若一今何以重说。若异有何差别。答曰。失念名误错。减名不及。失念名威仪俯仰去来法中失念。无减名住禅定神通念。过去现在世通达无碍。问曰。何以故。念无减独是佛法。答曰。声闻辟支佛善修四念处故念牢固。念虽牢固犹亦减少碍不通达。如宿命智力中说。声闻辟支佛念宿命。极多八万劫。于广有减。亦于见谛道中。不能念念分别。佛于念念中皆分别三相。佛心无有一法而不念者。以是故独佛有念无减。复次宿命智力随念知。佛于是中有力。声闻辟支佛尚无是念力何况余人。复次佛以一切智无碍解脱守护念。是故无减。如是等因缘故。佛念无减。慧无减者。佛得一切智慧故慧无减。三世智慧无碍故慧无减。复次十力四无所畏四无碍智成就故。慧无减。复次譬如酥油丰饶灯炷清净光明亦盛。佛亦如是。三昧王等诸三昧。禅定油念无减清净炷。是因缘故慧光明无量无减。复次从初发心。无量阿僧祇劫。集一切智慧故。深心为法故。头目髓脑悉舍。内外所有而布施。入火投山剥皮钉身。如是等无苦不受一心为集智慧故慧无减。复次佛智慧。以一切功德持戒禅定等助成故慧无减。复次世世求一切经书。世俗法佛法粗细善不善。悉皆学知故慧无减。复次从十方无量诸佛所闻法读诵思惟修习问难故慧无减。复次为一切众生故。为增益一切善法故。破一切处无明故慧无减。复次是智慧实知诸法相不生不灭不净不垢无作无行。不分别是智非智知诸法一等清净如虚空无染无著。不以二法故得不二入法相。不二入法相无量无边。以是故慧无减。如是等种种因缘慧无减。解脱无减者。解脱有二种。有为解脱无为解脱。有为解脱名无漏智慧相应解脱。无为解脱名一切烦恼习都尽无余。佛于二解脱无减。何以故。声闻辟支佛智慧不大利故。烦恼不悉尽故智慧有减。佛智慧第一利故烦恼习永尽无余故解脱无减。复次如漏尽力中说。佛与声闻解脱有差别。佛得漏尽力故解脱无减。二乘无力故有减。解脱知见无减者。佛于诸解脱中。智慧无量无边清净故。名解脱知见无减。问曰。佛一切法中无减。何以故。但六事中无减。答曰。一切自利他利中四事能具足。欲求一切善法之根本。精进能行念能守护。如守门人善者听入恶者遮。慧照一切法门。断一切烦恼。用是四法事得成办。是四法果报有二种。一者解脱二者解脱知见。解脱义如先说。解脱知见者。固是解脱知见。知是二种解脱相。有为无为解脱知诸解脱相。所谓时解脱不时解脱慧解脱俱解脱坏解脱不坏解脱八解脱不可思议解脱无碍解脱等。分别诸解脱相牢固不牢固。是名解脱知见无减。如念佛中佛成就五无学众。解脱知见众此中应广说。问曰。解脱知见者但言知。何以复言见。答曰。言知言见事得牢固。譬如绳二合为一则牢固。复次若但说知则不摄一切慧。如阿毗昙所说。慧有三种。有知非见有见非知有亦知亦见。有知非见者。尽智无生智五识相应智。有见非知者。八忍世间正见五邪见。有亦知亦见者。余残诸慧。若说知则不摄见。若说见则不摄知。是故说知见则具足。复次如从人诵读分别筹量是名知。自身得证是名见。譬如耳闻其事犹尚有疑是名知。亲自目睹了了无疑是名见。解脱中知见亦如是差别。复次有人言。阿罗汉自于解脱中疑不能自了。是阿罗汉非阿罗汉。以是故佛为破如是邪见故。说诸圣人于解脱中亦知亦见。诸阿罗汉虽得解脱知见。解脱知见有减。不得一切智故。上上智慧根不成就故。诸法念念生灭时。不知别相分别故。佛上上智慧根成就。知诸法念念别相生灭故。解脱知见无减。复次法眼清净具足成就故。如法眼义中说。知是众生空解脱门入涅槃。是众生无相解脱门入涅槃。是众生无作解脱门入涅槃。知是众生观五众门十二入十八界。如是种种法门得解脱。佛于解脱知见尽知遍知。是故说佛解脱知见无减。一切身业一切口业一切意业。随智慧行者。佛一切身口意业先知。然后随智慧行。诸佛身口意业一切行。无不利益众生故。名先知然后随智慧行。如经中说。诸佛乃至出息入息利益众生。何况身口意业故作而不利益。诸怨恶众生闻佛出入息气香。皆得信心清净爱乐于佛。诸天闻佛气息香。亦皆舍五欲发心修善。以是故言身口意业随智慧行。声闻辟支佛无是事。心故作善然后身口业善。意业或时无记不随智慧而自生。何况余人。如憍梵波提比丘。虽得阿罗汉。自食吐而更食。是业不随智慧。又如摩头波斯咤比丘阿罗汉。跳上梁棚或壁上树上。又如毕陵伽婆蹉。骂恒神言小婢。如是等身口业。先无智慧亦不随智慧行。佛无是事。问曰。若尔者佛或时身口业。亦似不随智慧行。何以故。入外道众中说法。都无信受者。又复一时在大众中说法。现胸臆示尼揵子。又复为人疑不见二相故。在大众中现舌相阴藏相。又复骂诸弟子汝狂愚人。骂提婆达。汝是狂人死人嗽唾人。佛结戒八种钵不应畜。听比丘用二种钵。若瓦若铁。而自用石钵。有时外道难问。佛默然不答。又佛处处说有我。处处说无我。处处说诸法有。处处说诸法无。如是等身口业。似不随智慧行。身口业不离意业。意业亦应有不随智慧行。云何言常随智慧行。答曰。是事不然。于是诸事皆先有智慧。然后诸业随智慧行。何以故。佛入外道众中。虽知今世不信不受。以种后世大因缘故。又复为止外道谤言佛自高憍。以是故自往入其众中。又外道言。佛自言有大悲普济一切。而但自为四众说法。我等亦是出家求道。而不为说。又如此经。佛往外道众中说法。不言不信受。佛遥见外道大会高声论议。欲至余处回往趣之。论议师辈遥见佛来自语其众。汝等皆默佛。是乐寂静人。见汝等静默或能来此。众即默然。佛入其众说婆罗门三谛。外道众皆默然。佛作是念。狂人辈皆为恶魔所覆。是法微妙乃至无有一人试作弟子者。作是念已从坐而去。是人魔蔽得离便自念。我等得闻妙法。云何不以自利即皆往诣佛所。为佛弟子得道离苦。复次外道弟子难其师故。不敢到佛所。是故佛自入其众中。众得闻法信受坚固。不复难师得为弟子或得道迹。如是等有种种智慧因缘。是故往入外道众。复次萨遮只尼揵子铜鍱络腹自誓言。无有人得我难而不流汗破坏者。大象乃至树木瓦石闻我难声亦皆流汗。作是誓已来至佛所与佛论议。佛质问之皆不能得答。汗流淹地举体如渍。佛告尼揵。汝先誓言。无有闻我难者而不流汗。汝今汗流淹地。汝试观佛见有汗相不。佛时脱郁多罗僧。示之言。汗在何处。复次有人言。或有头汗身不汗者。佛头虽不汗身必有汗。以是故佛脱郁多罗僧示其身。因是外道大得信向皆入佛法中。是智慧因缘身业随行。佛现舌相阴藏相者。有人疑佛身二相。而是人应得道疑故不得。以是故现二相。出舌覆面舌虽大还入口中而亦无妨。见者疑断。有人见出舌相。若生轻慢心。出舌如小儿相见还入口说法无妨。便起恭敬叹未曾有。有人疑佛阴藏不现。尔时世尊化作宝象宝马指示之言。阴藏相不现正如是。有人言佛出阴藏相。但示一人断其疑故。论议师辈言佛大慈悲心。若有人见佛阴藏相能集善根。发阿耨多罗三藐三菩提心。及能大欢喜信敬心生者。皆令得见断其疑心。除是皆不得见。佛以大悲为度众生故。从三种覆出暂现如电光。是众生见已。信佛有大悲心。实于戒法不取不着。如是等因缘故现二相。非戏非无羞。佛苦切语。诸比丘汝狂愚人者。苦切语有二种。一者垢心嗔骂。二者怜愍众生欲教化故。离欲人无有垢心嗔骂何况佛。佛怜愍教化故有苦切语。有众生软语善教不入道。检要须苦切粗教乃得入法。如良马见鞭影便去。钝驴得痛手乃行。亦如有疮得软药唾咒便差。有疮刀破出其恶肉涂以恶药乃愈者。复次苦切语有五种。一者但绮语。二者恶口亦绮语。三者恶口亦绮语妄语。四者恶口亦绮语妄语两舌。五者无烦恼心苦切语。为教弟子分别善不善法故。拔众生于苦难地故。具四种恶语者其罪重。三二一转转轻微。佛弟子白衣。得初道若二道。使令奴婢故。有恶口非不善道。摄律仪有二种。若绮语若恶口绮语。阿那含阿罗汉无烦恼起恶口。但以净心须恶言教化故恶口绮语。阿那含阿罗汉。尚无烦恼所起恶口。何况佛。复次佛若有苦切语不应疑不应难。谓佛恶心起苦切语。所以者何。佛恶心久已灭。但以深心念众生如慈父教子。虽有苦言为成就子故非是恶心。佛为菩萨时三毒未尽。作仙人名羼提。被恶王截其耳鼻手足。而不生恶心不出恶言。尔时未得道尚无恶心。何况得阿耨多罗三藐三菩提。三毒已尽于一切众生大慈悲具足。云何疑佛有恶心苦切语。复次佛若言狂愚人。是软语实语。所以者何。三毒发故名为狂愚。亦以善事利益。而不肯受不解佛心不受佛语。是为狂愚。复次佛内常行无我智慧。外常观诸法空。如是者云何有恶口。是众生不解佛心故求佛语短。若众生解佛以深心怜愍者。假令教入大火。即时欢乐而入。如人热闷时入清凉池。何况但语而不受。众生为恶魔覆故。不知佛以深心念之。是故不受佛语。以是故佛言汝是狂愚人。复次有人得苦切语便欢喜言。亲爱我故如是言。以是故佛言狂愚人。佛语提婆达。汝狂人死人嗽唾人。狂人者以提婆达罪重。当入阿鼻地狱故三种苦切语。死人者似人而不能集诸善法故。亦以提婆达剃头法服似如圣人内无慧命故名死人。如死人种种庄严。转转烂坏终不可令活。提婆达亦如是。佛日日种种教化。恶心转剧恶不善法日日转增。乃至作三逆罪。以是故名为死人。嗽唾人者。提婆达贪利养故。化作天身小儿。在阿阇贳王抱中。王呜其口与唾令嗽。以是故名嗽唾人。问曰。提婆达得禅定已离欲。云何复嗽他唾。答曰。是人恶心亦深其根亦利。离欲故能变化。嗽唾时便失利根故求时便得。以是故名嗽唾人。狂义如先说。复次以提婆达白佛佛已老矣。常乐闲静可入林中以禅自娱。僧可付我。佛言。舍利弗目揵连等。有大智慧善软清净人。尚不令僧属。何况汝狂人死人嗽唾人。如是等因缘故。佛于诸法虽无所著。而为教化故现苦切语。佛不听比丘用八种钵者。金银等宝钵。以宝物人贪故。难得故。贪着故。不听畜此宝物。乃至不得手举名宝亦不得畜。若作净施得用价不贵故。木钵受垢腻不净故不听畜。三种钵无如是事。问曰。瓦铁钵皆亦受垢腻。与木钵无异。何以听畜。答曰。瓦铁钵不熏亦不听。以熏不受垢腻故。石有粗细。细者亦不受垢腻故。世尊自畜。所以不听比丘畜者以其重故。佛乳哺力胜一万白香象。是故不以为重。慈愍诸比丘故不听。问曰。侍者罗陀弥喜迦须那利罗多那伽娑婆罗阿难等。常侍从世尊执持应器。何以不怜愍。答曰。侍者虽执持佛钵。以佛威德力故。又恭敬尊重佛故不觉为重。又阿难身力亦大故。复次以细石钵难得故。粗者受垢腻故不听用。佛钵四天王四山头自然生故。余人无此自然钵。若求作甚难多所妨废。是故不听。又欲令佛与弟子异故佛用石钵。又如国王人所尊重食器亦异。有人见佛钵异倍加尊重。供养信心清净。问曰。若钵应异衣何以同。答曰。佛衣亦异。佛初成道时。知迦叶衣应佛所著。迦叶衣价直十万两金。次后耆域上佛深摩根羯簸衣。价亦直十万两金。佛敕阿难持此衣去。割截作僧伽梨。作已佛受着是为异。问曰。佛因是告诸比丘。从今日若有比丘。一心求涅槃背舍世间者若欲着。听着价直十万两金衣。亦听食百味食。衣异而后听钵独不听。答曰。我先已说石钵因缘今当更说。佛钵不从人受。佛初得道欲食时须器。四天王知佛心念。持四钵上佛。三世诸佛法皆应四天王上钵。尔时未有众僧。云何言听。后若听无人与石钵。又阎浮提不好石钵故无人与。复次佛说比丘常应覆功德。若受石钵人谓从天龙边得。若令人作其工既难。又恐人言此比丘欲与佛齐功所以听。衣者若有人言。佛在僧中受檀越好衣独着。而不听比丘。是故佛听着比丘。亦自无著者。以施者难有著者难得故。若不清净比丘人所不与。清净比丘少欲知足故不着。佛断人疑故听着衣。钵中无望是故不听。问曰。如经中说。佛金刚身不恃仰食。何以畜钵。答曰。佛法有二道。一者声闻道。二者佛道。声闻法中佛随人法有所食啖。摩诃衍法中。方便为人故现有所啖。其实不食。问曰。云何是方便。答曰。佛欲度人示行人法。若不尔者人以佛非人。我等云何能行其法。复次有人因布施得度。为是人故佛受其食。便作是念我食得助益佛身心大欢喜。以欢喜故信受佛语。如大国主臣下请食。王虽不须为摄彼人故多少为食令其欢喜。如是等因缘佛现受食。问曰。若佛不食。所受者在何处。答曰。佛事不可思议。不应致问。复次有人得佛食而度者。有闻声见色触身闻香而得度。须食得度者佛以食与之。如密迹金刚经说。佛以食着口中。有天求佛道者。持至十方施之。问曰。若尔者今僧中。说佛食无有众生能食者。此义云何。答曰。佛不与者无有能食。今佛施之是故得食。何以知之。佛食马麦时以食与阿难。又沙门二十亿耳以好羹上佛。佛以残羹与频婆娑罗王。以是故知佛受已与则得食。不与则不能消。复次为佛设食。佛未食者人不能消。已食残者佛与能消。以是故虽实不食。为度人故现受食畜钵。佛不答十四难者。佛有四种答。一者定答。二者分别义答。三者反问答。四者置答。此十四难法应置答。又复若有所利益事则答。外道所问不为涅槃。增长疑惑故以置答。知必有所益者分别为答。必无所益置而不答。以是因缘故知。佛是一切智人。复次若佛说三种法。有为法无为法不可说法。则为已说一切法竟。复次是诸外道。依止常见依止灭见故。问以常灭。实相无故佛不答。如外道所见。常相无常相无是事。何以故。外道取相着。是常灭故。佛虽说常无常相。但为治用故。复次若人说。无者为有有者为无。如是人则是过罪。佛不答则无咎。如日照天下。不能令高者下下者高。但以显现而已。佛亦如是于诸法无所作。诸法有者说有。无者说无。如说生因缘老死。乃至无明因缘诸行。有佛无佛是因缘法相续常在世间。诸佛出世为众生显示此法。复次若答常灭则为有咎。如问石女黄门儿修短黑白何类。此问则不应答。十四难亦如是。但以常灭为本故问。无常灭故佛不答。如是等种种因缘故。佛不答十四难无咎。佛处处说有我。处处说无我者。若人解佛法义。知假名者说言有我。若人不解佛法义。不知假名者说无我。复次佛为众生欲堕断灭见者。说言有我受后世罪福。若人欲堕常见者。为说言无无作我者受者。离是五众假名。更无一法自在者。问曰。若尔者何等为实。答曰。无我是实。如法印中说。一切作法无常。一切法无我。寂灭是安隐。涅槃法印名为诸法实相。若人善根未熟智慧不利。佛不为说是深无我法。若为说众生即堕断灭见中。问曰。若尔者如迦叶问中佛说。我是一边无我是一边。离此二边名为中道。今云何言无我是实有我为方便说。答曰。说无我有二种。一者取无我相着无我。二者破我不取无我亦不着。无我自然舍离。如先说无我则是边。后说无我是中道。复次佛说有我无我。有二因缘。一者用世俗说故有我。二者用第一实相说故无我。如是等说有我无我无咎。佛处处说诸法有。处处说诸法无者。问曰。不应别说有无。有即是有我。无即是无我。何以更说。答曰。不然佛法有二种空。一者众生空。二者法空。说无我示众生空。说无有法示法空。说有我示知假名相不着我者说有我于五众中着我相者。为破是着我故说。但有五众。无常苦空无我寂灭涅槃是名有。复次有二种断见。一者无后世受罪福苦乐者。为说有我。从今世至后世受罪福果报。一者一切法皆空无著是邪见。为是众生故。说有一切法。所谓有为无为法。复次不大利根众生。为说无我。利根深智众生说诸法本末空。何以故。若无我则舍诸法。如说

  若了知无我　　有如是人者
  闻有法不喜　　无法亦不忧

说我者。一切法所依止处。若说无我者。一切法无所依止。复次佛法二种说。若了了说则言一切诸法空。若方便说则言无我。是二种说法皆入般若波罗蜜相中。以是故佛经中说趣涅槃道皆同一向无有异道。复次有我有法。多为在家者说。有父母罪福大小业报。所以者何。在家人多不求涅槃故。着于后世果报。为出家人多说无我无法。所以者何。出家人多向涅槃故。求涅槃者不受一切法故。自然灭是涅槃。复次有人信等诸根未成就故。先求有所得然后能舍。为是人故佛说诸善法舍诸恶法。有人信等诸根成就故。于诸法不求有所得。但求远离生死道。为是人故佛说诸法空无所有。此二皆实。如无名指亦长亦短观中指则短观小指则长。长短皆实。有说无说亦如是。说有或时是世俗或时是第一义。说无或时是世俗或时是第一义。佛说是有我无我皆是实。问曰。若是二事皆实。佛何以故多赞叹空而毁訾有。答曰。空无所有。是十方诸佛一切贤圣法藏。如般若波罗蜜嘱累品中说。般若波罗蜜。是三世十方诸佛法藏。般若波罗蜜。即是无所有空。佛或时说有法。为教化众生故。久后皆当入无所有法藏中。问曰。若尔者云何般若波罗蜜言若观五众空无所有非是道。答曰。是般若波罗蜜中说有无皆无。如长爪梵志经中说。三种邪见。一者一切有二者一切无三者半有半无。佛告长爪梵志。是一切有见。为欲染为嗔恚愚痴所缚。一切无见。为不染不嗔不痴故所不缚。半有半无。有者同上有缚。无者同上无缚。于三种见中。圣弟子作是念。若我受一切有见。则与二人共诤。所谓一切无者。半有半无者。若我受一切无见。亦与二人共诤。所谓一切有者。半有半无者诤。若我受半有半无者。亦与二人共诤。所谓一切无者。一切有者。斗诤故相谤。相谤故致恼见。是诤谤恼故。舍是无见余见亦不受。不受故即入道。若不着一切诸法空心不起诤。但除结使是名为实智。若取诸法空相。起诤不灭诸结使。依止是智慧。是为非实智。如佛所说为度众生故有所说。无不是实。但众生于中有着不着故有实不实。如是种种因缘故。佛身口意业无有过失。是故说佛身口意先知然后随智慧行。问曰。初说身无失口无失念无失。今复说身口意业随智慧行。义有何差别。答曰。先三种无失不说因缘。今说因缘随智慧行故不失。若先不筹量而起身口意业则有失。佛先以智慧起身口意业故无失。复次佛成就三种净业三种寂静业三不护业。有人疑言。佛何因缘成就如是业。以是故佛言。我一切身口意业先以智慧。然后随智慧行。佛以智慧。知过去未来现在世。通达无碍者。此三种智慧于三世。通达无碍故。三业随智慧行。问曰。过去诸法。已灭已尽无所复有。未来世诸法。今不来不生未和合。现在乃至一念中无住时。云何能知三世通达无碍。答曰。佛说过去未来现在通达无碍。此言岂虚。复次若无过去未来。但有现在一念顷。佛亦不得成就无量功德。如十种智。是十力是时亦不得一心有十智。若尔者佛亦不得具足十力。以是因缘故。知有过去未来。问曰。若过去未来现在皆有者。何等是无。佛说四谛。苦谛观无常等相。无常名生灭败坏不可得。若过去法今实有。不名为无常败坏不可得。复次若过去未来现在皆有者便堕常。何以故。是法在未来世中定有转来现在。从现在转入过去。如人从一房入一房不名失人。答曰。若不失有何咎。问曰。若无无常无罪无福无生无死无缚无解。罪名杀等十不善道。若无无常无杀等罪。如分别邪见中说。刀在身七分中过无所恼害。福名不杀等十善道。无常名分别生死。若无无常亦无生死。亦无缚亦无解。如是等无量过咎。答曰。诸法三世各各有相。过去法有过去相。未来法有未来相。现在法有现在相。若过去未来有现在相者。应有是难。而今过去未来现在各自有相。复次若实无过去未来。亦无出家律仪。所以者何。若现在恶心中住。过去复无戒。是为非比丘。又贤圣人心在世俗中。是时应当是凡夫。无过去未来现在道故。如是亦无五逆等诸罪。所以者何。是五逆罪业。已过去及死时入地狱。是五逆罪未来无业故无报。现在身不为逆罪。若无过去则无逆罪。若无逆罪何有余罪。福亦如是。若无罪福是为邪见。与禽兽无异。复次我不说过去未来如现在相有。我说过去虽灭可生忆想能生心心数法。如昨日火灭今日可生忆想念。不可以忆想念故火便有。若见积薪知当然火。亦生心想念。明日火如过去火。不可以今心念火火便有。未来世事亦如是。现在心虽一念时不住相续生故。能知诸法内以现在意为因。外以诸法为缘。是因缘中生意识用。意识自在知过去未来现在法。但不自知现在心心数法余者悉知。问曰。般若波罗蜜如相品中。三世一相所谓无相。云何言佛智慧知三世通达无碍。答曰。诸佛有二种说法。先分别诸法。后说毕竟空。若说三世诸法通达无碍是分别说。若说三世一相无相。是说毕竟空。复次非一切智人。于三世中智慧有碍。乃至观世音文殊师利弥勒舍利弗等诸贤圣。于三世中智慧皆有碍。以是因缘故。说佛智慧于三世中通达无碍。不为空事故说。复次有人于三世中生邪见。谓过去法及众生有初无初。若有初则有新众生。诸法亦无因无缘而生。若无初亦无后。若无初无后中。亦无初名有中有后。无前后名有初有中。无后中名有初有后。若众生及诸法。无初亦无中无后。若无三世则都无所有。复次若无初。云何有一切智人。破如是等邪见故。说三世诸法一相所谓无相。不为破三世佛智慧。问曰。无相是为有边。答曰。若无相即是无边。不可说不可难法。云何言有边。若无相中取相。非是无相。是无相名为不可得空。是中无相亦不可得。空亦不可得。是故名不可得空。复次佛有二种道。一者福德道。有人闻佛十力四无所畏四无碍智十八不共法等。生恭敬信乐心。二者智慧道。有人闻说诸法因缘和合生故无有自性。便舍离诸法。于空中心不着。如月能润物日能熟物。二事因缘故万物成就。福德道智慧道亦如是。福德道能生诸功德。智慧道能于福德道中离诸邪见着。以是故佛虽说诸法毕竟空。亦说三世通达无碍而无咎。如是等略说佛十八不共法义。问曰。若尔者迦栴延尼子。何以言十力四无所畏大悲三不共意止名为十八不共法。若前说十八不共法是真义者。迦栴延尼子何以故如是说。答曰。以是故名迦旃延尼子。若释子则不作是说。释子说者是真不共法。佛法无量。是三十六法。于佛法中如大海一渧。法亦不少何以重数为十八。复次诸阿罗汉辟支佛菩萨。亦能知是处不是处。分别三世业果报及诸禅定乃至漏尽智等。云何言不共法。问曰。声闻辟支佛菩萨。不能尽知遍知。但有通明无有力。独佛能尽遍知故言不共。如十力中说。答曰。佛说十力义。不言尽知遍知。直言知是处不是处。言尽知遍知者。是诸论议师说。问曰。汝先自言摩诃衍经中说。佛为菩萨故。自说尽知遍知。答曰。摩诃衍经中说。何益于汝。汝不信摩诃衍。不应以为证。汝自当说声闻法为证。复次十力佛虽尽知遍知。而声闻辟支佛有少分。十八不共法中。始终都无分。以是故名真不共法。问曰。十八不共法。二乘亦应有分。但佛身口念常无失。二乘身口念亦有无失。如是等皆应有分。答曰。不然。所以者何。常无失故名为不共。不以不失为不共。声闻辟支佛。于常无失中无分。复次诸阿罗汉说有力无有处。说有不共法。汝不信摩诃衍故。不受真十八不共法。而更重数十力等是事不可。如汝所信八十种好。而三藏中无。何以不更说。问曰。我等分别十八不共法不重数也。何等十八。一者知诸法实相故。名一切智。二者佛诸功德相难解故。功德无量。三者深心爱念众生故名大悲。四者得无比智故。智慧中自在。五者善解心相故。定中自在。六者得度众生方便故。变化自在。七者善知诸法因缘故。记别无量。八者说诸法实相故。记别不虚。九者分别筹量说故。言无失。十者得十力成就智慧无减。十一者一切有为法中。但观法聚无我故。常施舍行。十二者善知时不时。安立于三乘。常观众生故。十三者常一心故不失念。十四者无量阿僧祇劫深善心故。无烦恼习。十五者得真净智故。无有能如法出其失。十六者世世敬重所尊故。无能见顶。十七者修大慈悲心故。安庠下足足下柔软。众生遇者即时得乐。十八者得神通波罗蜜故。转众生心令欢喜得度故。如入城时现神变力。答曰。如是十八不共法。非三藏中说。亦诸余经所不说。以有人求索是法故。诸声闻论议师辈。处处撰集赞佛功德。如言无失慧无减念不失。皆于摩诃衍十八不共法中。取已作论议。虽有无见顶足下柔软如是甚多。不应在十八不共法中。不共法皆以智慧为义。佛身力如十万白香象力。及神通力等皆不说。以是故当知。十八不共法中。但说智慧功德等。不说自然果报法。复次是十八不共法。阿毗昙分别。五众摄。身口无失身口随智慧行是色众摄。无异想是想众摄。无不定心是识众摄。余者行众摄。皆在四禅中。佛四禅中得道得涅槃故。有人言四色不共法。色界欲界中摄。余九地中摄。皆是善皆是无漏法。四色法二缘生因缘增上缘。余残四缘生四无缘十四有缘。四随心行不与心相应。十三与心相应。亦随心行一不与心相应。亦不随心行。如是等种种阿毗昙分别说。初如是分别入般若波罗蜜诸法实相中。尽皆一相所谓无相。入佛心皆一寂灭相

大智度论卷第二十六大智度论释初品大慈大悲义第四十二(卷二十七)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】大慈大悲。当习行般若波罗密

【论】大慈大悲者。四无量心中已分别。今当更略说。大慈与一切众生乐。大悲拔一切众生苦。大慈以喜乐因缘与众生。大悲以离苦因缘与众生。譬如有人诸子系在牢狱当受大罪。其父慈恻以若干方便。令得免苦。是大悲得离苦已。以五所欲给与诸子是大慈。如是等种种差别。问曰。大慈大悲如是。何等是小慈小悲。因此小而名为大。答曰。四无量心中慈悲名为小。此中十八不共法。次第说大慈悲名为大。复次诸佛心中慈悲名为大。余人心中名为小。问曰。若尔者何以言菩萨行大慈大悲。答曰。菩萨大慈者于佛为小。于二乘为大。此是假名为大。佛大慈大悲真实最大。复次小慈但心念与众生乐实无乐事。小悲名观众生种种身苦心苦。怜愍而已不能令脱。大慈者念令众生得乐亦与乐事。大悲怜愍众生苦亦能令脱苦。复次凡夫人声闻辟支佛菩萨慈悲名为小。诸佛慈悲乃名为大。复次大慈从大人心中生。十力四无所畏四无碍智。十八不共法大法中出。能破三恶道大苦。能与三种大乐。天乐人乐涅槃乐。复次是大慈。遍满十方三世众生乃至昆虫。慈彻骨髓心不舍离。若三千大千世界众生堕三恶道。若人一一皆代受其苦得脱苦已。以五所欲乐禅定乐世间最上乐。自恣与之皆令满足。比佛慈悲千万分中不及一分。何以故。世间乐欺诳不实不离生死故。问曰。法在佛心中一切皆大。何以故。但说慈悲为大。答曰。佛所有功德法应皆大故。问曰。若尔者何以但说慈悲为大。答曰。慈悲是佛道之根本。所以者何。菩萨见众生老病死苦身苦心苦今世后世苦等诸苦所恼。生大慈悲救如是苦。然后发心求阿耨多罗三藐三菩提。亦以大慈悲力故。于无量阿僧祇世生死中心不厌没。以大慈悲力故。久应得涅槃而不取证。以是故。一切诸佛法中慈悲为大。若无大慈大悲。便早入涅槃。复次得佛道时。成就无量甚深禅定解脱诸三昧。生清净乐弃舍不受。入聚落城邑中。种种譬喻因缘说法。变化其身无量音声将迎一切。忍诸众生骂詈诽谤。乃至自作伎乐。皆是大慈大悲力。复次大慈大悲大名。非佛所作众生名之。譬如师子大力。不自言力大。皆是众兽名之。众生闻佛种种妙法。知佛为祐利众生故。于无量阿僧祇劫难行能行。众生闻见是事。而名此法为大慈大悲。譬如一人有二亲友。以罪事因缘故系之囹圄。一人供给所须一人代死。众人言能代死者。是为大慈悲。佛亦如是。世世为一切众生。头目髓脑尽以布施。众生闻见是事。即共名之为大慈大悲。如尸毗王。为救鸽故尽以身肉代之。犹不与鸽等。复以手攀称欲以身代之。是时地为六种震动海水波荡。诸天香华供养于王。众生称言为一小鸟所感乃尔。真是大慈大悲。佛因众生所名故。言大慈大悲如是等无量本生是中悉应广说。问曰。禅定等诸余功德。人不知故不名为大。智慧说法等能令人得道。何以不称言大。答曰。佛智慧所能无有遍知者。大慈大悲故。世世不惜身命。舍禅定乐救护众生人皆知之。于佛智慧可比类知。不能了了知。慈悲心眼见耳闻。处处变化大师子吼。是故可知。复次佛智慧细妙。诸菩萨舍利弗等。尚不能知何况余人。慈悲相可眼见耳闻故人能信受。智慧深妙不可测知。复次是大慈大悲。一切众生所爱乐。譬如美药人所乐服。智慧如服苦药人多不乐。人多乐故称慈悲为大。复次智慧者。得道人乃能信受。大慈悲相一切杂类皆能生信。如见像若闻说。皆能信受。多所饶益故。名为大慈大悲。复次大智慧。名舍相远离相。大慈大悲为怜愍利益相。是怜愍利益法。一切众生所爱乐。以是故名为大。是大慈大悲。如持心经中说。大慈大悲有三十二种。于众生中行。是大慈大悲摄相缘。如四无量心说。复次佛大慈大悲等功德不应一切。如迦旃延法中。分别求其相。上诸论议师。虽用迦旃延法。分别显示不应尽信受。所以者何。迦旃延说大慈大悲一切智慧。是有漏法系法世间法。是事不尔。何以故。大慈大悲名为一切佛法之根本。云何言是有漏法系法世间法。问曰。大慈悲虽是佛法根本故是有漏。如淤泥中生莲华。不得言泥亦应妙。大慈大悲亦如是。虽是佛法根本不应是无漏。答曰。菩萨未得佛时大慈悲。若言有漏其失犹可。今佛得无碍解脱智故。一切诸法皆清净。一切烦恼及习尽。声闻辟支佛。不得无碍解脱智故烦恼习不尽。处处中疑不断故心应有漏。诸佛无是事。何以故。说佛大慈悲应是有漏。问曰。我不敢不敬。佛以慈悲心。为众生故生应是有漏。答曰。诸佛力势不可思议。诸声闻辟支佛。不能离众生想而生慈悲。诸佛能离众生想而生慈悲。所以者何。如诸阿罗汉辟支佛。十方众生相不可得。而取众生相生慈悲。今诸佛十方求众生不可得。亦不取众生相。而能生慈悲。如无尽意经中说。有三种慈悲。众生缘法缘无缘。复次一切众生中。唯佛尽行不诳法。若佛于众生中。取相而行慈悲心。不名行不诳法。何以故。众生毕竟不可得故。声闻辟支佛。不名为尽行不诳法。故声闻辟支佛。于众生于法。若取相若不取相。不应难不悉行不诳法故。一切智能断一切诸漏。能从一切有漏法中出。能作无漏因缘。是法云何自是有漏。问曰。无漏智各各有所缘。无有能悉缘一切法者。唯有世俗智。能缘一切法。以是故说一切智是有漏相。答曰。汝法中有是说。非佛法中所说。如人自持斗入市。不与官斗相应。无人用者。汝亦如是。自用汝法。不与佛法相应无人用者。无漏智慧。何以故。不能缘一切法。有漏智是假名虚诳势力少故。不应真实缘一切法。汝法中自说能缘一切法。复次是声闻法中十智。摩诃衍法中有十一智。名为如实相智。是十智入是如实智中。都为一智。所谓无漏智。如十方水入大海水中都为一味。是大慈大悲。佛三昧王三昧师子游戏三昧所摄。如是略说大慈大悲义

【经】菩萨摩诃萨欲得道慧。当习行般若波罗蜜。菩萨摩诃萨欲以道慧具足道种慧。当习行般若波罗蜜

【论】道名一道。一向趣涅槃。于善法中一心不放逸。道随身念。道复有二道。恶道善道。世间道出世间道。定道慧道。有漏道无漏道。见道修道。学道无学道。信行道法行道。向道果道。无碍道解脱道。信解道见得道。慧解脱道俱解脱道。如是无量二道门。复有三道。地狱道畜生道饿鬼道。三种地狱热地狱寒地狱黑闇地狱。三种畜生道。地行水行空行。三种鬼道饿鬼食不净鬼神鬼。三种善道。人道天道涅槃道。人有三种。作罪者作福者求涅槃者。复有三种人。受欲行恶者。受欲不行恶者。不受欲不行恶者。天有三种。欲天色天无色天。涅槃道有三种。声闻道辟支佛道佛道。声闻道有三种。学道无学道非学非无学道。辟支佛道亦如是。佛道有三种。波罗蜜道方便道净世界道。佛复有三道。初发意道。行诸善道。成就众生道。复有三道。戒道定道慧道。如是等无量三道门。复有四种道。凡夫道声闻道辟支佛道佛道。复有四种道。声闻道辟支佛道菩萨道佛道。声闻道有四种。苦道集道灭道道道。复有四沙门果道。复有四种道。观身实相道。观受心法实相道。复有四种道。为断未生恶不善令不生道。为断已生恶令疾灭道。为未生善法令生道。为已生善法令增长道。复有四种道。欲增上道精进增上道心增上道慧增上道。复有四圣种道。不择衣食卧具医药乐断苦修定。复有四行道。苦难道苦易道乐难道乐易道。复有四修道。一为今世乐修道。二生死智修道。三为漏尽故修道。四分别慧修道。复有四天道所谓四禅。复有四种道。天道梵道圣道佛道。如是等无量四道门。复有五种道。地狱道畜生饿鬼人天道。复有五无学众道无学戒众道乃至无学解脱知见众道。复有五种净居天道。复有五治道。复有五如法语道。复有五非法语道。复有五道凡夫道声闻道辟支佛道菩萨道佛道。复有五道。分别色法道分别心法道分别心数道分别心不相应行道分别无为法道。复有五种道。苦谛所断道集谛所断道灭谛所断道道谛所断道思惟所断道。如是等无量五法道门。复有六种道。地狱道畜生饿鬼人天阿修罗道。复有舍六尘道。复有六和合(旧云六种)道六神通道六种阿罗汉道六地修道六定道六波罗蜜道。一一波罗蜜各各有六道。如是等无量六道门。复有七道。七觉意道七地无漏道七想定道七净道七善人道七财福道七法福道七助定道。如是等无量七道门。复有八道。八正道八解脱道八背舍道。如是等无量八道门。复有九道。九次第道九地无漏道九见断道九阿罗汉道九菩萨道。所谓六波罗蜜。方便成就众生净佛世界。如是等无量九道门。复有十道。所谓十无学道十想道十智道十一切处道十不善道十善道乃至一百六十二道。如是等无量道门。如是诸道尽知遍知。是为道种慧。问曰。般若波罗蜜。是菩萨第一道。一相所谓无相。何以说是种种道。答曰。是道皆入一道中。所谓诸法实相。初学有种种别。后皆同一无有差别。譬如劫尽烧时。一切所有皆同虚空。复次为引导众生故。菩萨分别说是种种道。所谓世间道出世间道等。问曰。云何菩萨住一相无相中。而分别是世间道是出世间道。答曰。世间名。但从颠倒忆想虚诳二法生。如幻如梦如转火轮。凡夫人强以为世间。是世间皆从虚妄中来。今亦虚妄本亦虚妄。其实无生无作。但从内外六情六尘和合因缘生。随凡夫所著故为说世间。是世间种种邪见。罗网如乱系相着。常往来生死中。如是知世间。何等是出世间道。如实知世间。即是出世间道。所以者何。智者求世间出世间。二事不可得。若不可得。当知假名为世间出世间。但为破世间故。说出世间。世间相即是出世间。更无所复有。所以者何。世间相不可得。是出世间是世间相常空。世间法定相不可得故。如是行者不得世间。亦不着出世间。若不得世间。亦不着出世间。爱慢破故不共世间诤。何以故。行者久知世间空无所有虚诳故。不作忆想分别。世间名五众。五众相假令十方诸佛求之。亦不可得。无来处无住处。亦无去处。若不得五众来住去相。即是出世间。行者尔时观是世间出世间实不可见。不见世间与出世间合。亦不见出世间与世间合。离世间亦不见出世间。离出世间亦不见世间。如是则不生二识。所谓世间出世间。若舍世间不受出世间。是名出世间。若菩萨能如是知。则能为众生。分别世间出世间道。有漏无漏一切诸道。亦如是入一相。是名道种慧

【经】欲以道种慧具足一切智。当习行般若波罗蜜。欲以一切智具足一切种智。当习行般若波罗蜜

【论】问曰。一切智一切种智。有何差别。答曰。有人言无差别。或时言一切智。或时言一切种智。有人言总相是一切智。别相是一切种智。因是一切智。果是一切种智。略说一切智。广说一切种智。一切智者。总破一切法中无明闇。一切种智者。观种种法门破诸无明。一切智譬如说四谛。一切种智譬如说四谛义。一切智者。如说苦谛。一切种智者。如说八苦相。一切智者。如说生苦。一切种智者。如说种种众生处处受生。复次一切法名眼色乃至意法。是诸阿罗汉辟支佛。亦能总相知无常苦空无我等。知是十二入故。名为一切智。声闻辟支佛尚不能尽别相知一众生生处好丑事业多少。未来现在世亦如是。何况一切众生。如一阎浮提中金名字。尚不能知。何况三千大千世界。于一物中种种名字若天语若龙语。如是等种种语言名金尚不能知。何况能知金因缘生处好恶贵贱因而得福因而得罪因而得道。如是现事尚不能知。何况心心数法。所谓禅定智慧等诸法。佛尽知诸法总相别相故。名为一切种智。复次后品中佛自说一切智是声闻辟支佛事。道智是诸菩萨事。一切种智是佛事。声闻辟支佛。但有总一切智。无有一切种智。复次声闻辟支佛。虽于别相有分。而不能尽知故。总相。受名佛一切智一切种智皆是真实。声闻辟支佛但有名字。一切智譬如昼灯。但有灯名无有灯用。如声闻辟支佛。若有人问难。或时不能悉答不能断疑。如佛三问舍利弗而不能答。若有一切智云何不能答。以是故但有一切智名胜于凡夫。无有实也。是故佛是实一切智一切种智。有如是无量名字。或时名佛为一切智人。或时名为一切种智人。如是等略说一切智一切种智种种差别。问曰。如经中说。行六波罗蜜三十七品十力四无所畏等诸法得一切智。何以故。此中说但用道种智得一切智。答曰。汝所说六波罗蜜等即是道。知是道行是道。得一切智何所疑。复次初发心。乃至坐道场。于其中间一切善法。尽名为道。此道中分别思惟而行。是名道智。如此经后说道智是菩萨事。问曰。佛道事已备故不名道智。阿罗汉辟支佛诸功德未备。何以不名道智。答曰。阿罗汉辟支佛道。自于所行亦办。是故不名道智道是行相故。复次此经中说声闻辟支佛。声闻中不摄三道故。此中不说佛道大故名为道智。声闻辟支佛道小故不名道智。复次菩萨摩诃萨。自行道亦示众生各各所行道。以是故说名菩萨行道智得一切智。问曰。何等是一切智所知一切法。答曰。如佛告诸比丘。为汝说一切法。何等是一切法。所谓眼色耳声鼻香舌味身触意法。是十二入名一切法。复有一切法。所谓名色如佛说利众经中偈

  若欲求真观　　但有名与色
  若欲审实知　　亦当知名色
  虽痴心多想　　分别于诸法
  更无有异事　　出于名色者

复次一切法。所谓色无色法。可见不可见。有对无对。有漏无漏。有为无为。心非心。心相应非心相应。共心生不共心生。随心行不随心行。从心因不从心因。如是等无量二法门摄一切法。如阿毗昙摄法品中说。复次一切法。所谓善法不善法无记法。见谛所断思惟所断不断法。有报法无报法。非有报非无报法。如是等无量三法门摄一切法。复次一切法。所谓过去法未来法现在法。非过去未来现在法。欲界系法色界系法无色界系法不系法。从善因法。从不善因法从无记因法。从非善非不善非无记因法。有缘缘法无缘缘法。有缘缘亦无缘缘法。非有缘缘非无缘缘法。如是等无量四法门摄一切法。复次一切法。所谓色法心法心数法。心不相应诸行法。无为法四谛及无记无为。如是等无量五法门摄一切法。复次一切法。所谓五众及无为苦谛所断法。集谛灭谛道谛思惟所断法不断法。如是等无量六法门摄一切法。七八九十等诸法门。是阿毗昙分别义。复次一切法。所谓有法无法。空法实法。所缘法能缘法。聚法散法等。复次一切法。所谓有法无法。亦有亦无法。空法实法。非空非实法。所缘法能缘法。非所缘非能缘法。复次一切法。所谓有法无法。亦有亦无法。非有非无法。空法不空法。空不空法非空非不空法。生法灭法生灭法。非生非灭法。不生不灭法。非不生非不灭法。不生不灭亦非不生非不灭法。非不生非不灭亦非不不生亦非不不灭法。复次一切法。所谓有法无法有无法非有非无法舍是四句。法空不空生灭不生不灭五句皆亦如是。如是等种种无量阿僧祇法门所摄诸法。以是无碍智慧。尽遍知上诸法。名为一切智一切种智。问曰。一切众生皆求智慧。云何独佛一人得一切智。答曰。佛于一切众生中第一故。独得一切智。如佛所说。无足二足四足多足。有色无色有想无想非有想非无想等。一切众生中佛最第一。譬如须弥山于众山中自然最第一。如四大中火最有力能照能烧。佛亦如是。于一切众生中。最第一故得一切智。问曰。佛何以故于一切众生中独最第一。答曰。如先答得一切智故。今当更说。佛自利益亦利益他故。于众生中最第一。如一切照中日为第一。一切人中转轮圣王最第一。一切莲华中青莲华为第一。一切陆生华须曼色第一。一切木香中牛头栴檀为第一。一切珠中如意珠为第一。一切诸戒中圣戒为第一。一切解脱中不坏解脱为最第一。一切清净中解脱为第一。一切诸谛中空观为第一。一切诸法中涅槃为第一。如是等无量各各第一。佛亦如是。于一切众生中最为第一故。独得一切智。复次佛从初发意。以大誓庄严一切衰没众生。欲拯济故尽遍行诸善道。无善不集无苦不行。皆集一切诸佛功德。如是等种种无量因缘故。佛于一切众生中。独第一。问曰。三世十方诸佛亦有是功德。何以故。言佛独第一。答曰。除诸佛为余众生故。言佛独第一。诸佛第一功德。复次萨婆若多者。萨婆秦言一切若秦言智多秦言相一切如先说。名色等诸法。佛知是一切法一相异相漏相非漏相作相非作相等一切法。各各相各各力各各因缘各各果报各各性各各得各各失。一切智慧力故。一切世一切种尽遍解知。以是故说欲以道种智具足得一切智。当习行般若波罗蜜。欲以一切智具足一切种智。当习行般若波罗蜜。问曰。如佛得佛道时。以道智得具足一切智一切种智。今何以言以一切智得具足一切种智。答曰。佛得道时。以道智虽具足得一切智得具足一切种智。而未用一切种智。如大国王得位时境土宝藏皆已得。但未开用

【经】欲以一切种智断烦恼习。当习行般若波罗蜜。舍利弗。菩萨摩诃萨应如是学般若波罗蜜。【论】问曰。一心中得一切智一切种智。断一切烦恼习。今云何言以一切智具足得一切种智。以一切种智断烦恼习。答曰。实一切一时得。此中为令人信般若波罗蜜故。次第差品说。欲令众生得清净心。是故如是说。复次虽一心中得。亦有初中后次第。如一心有三相。生因缘住住因缘灭。又如心心数法不相应诸行及身业口业。以道智具足一切智。以一切智具足一切种智。以一切种智断烦恼习亦如是。先说一切种智。即是一切智。道智名金刚三昧。佛初心即是一切智一切种智。是时烦恼习断。一切智一切种智相先已说。断一切烦恼习者。烦恼名略说则三毒。广说则三界九十八使是名烦恼。烦恼习名烦恼残气。若身业口业不随智慧。似从烦恼起。不知他心者。见其所起生不净心。是非实烦恼久习烦恼故。起如是业。譬如久锁脚人卒得解脱。行时虽无有锁犹有习在。如乳母衣久故垢着。虽以淳灰净浣。虽无有垢垢气犹在衣。如圣人心垢。如诸烦恼。虽以智慧水浣。烦恼垢气犹在。如是诸余贤圣。虽能断烦恼不能断习。如难陀淫欲习故。虽得阿罗汉道。于男女大众中坐。眼先视女众而与言语说法。如舍利弗嗔习故。闻佛言舍利弗食不净食。即便吐食终不复受请。又舍利弗自说偈言

  覆罪妄念人　　无智而懈怠
  终不欲令此　　妄来近我住

如摩诃迦叶嗔习故。佛灭度后集法时。敕令阿难六突吉罗忏悔。而复自牵阿难手出。不共汝漏未尽不净人集法。如毕陵迦婆蹉。常骂恒神为小婢。如摩头婆和吒跳戏习故。或时从衣枷踔上梁。从梁至枰从枰至阁。如憍梵钵提牛业习故。常吐食而齝。如是等诸圣人。虽漏尽而有烦恼习。如火焚薪已灰炭犹在火力薄故不能令尽。若劫尽时火烧三千大千世界无复遗余火力大故。佛一切智火亦如是。烧诸烦恼无复残习。如一婆罗门。以五百种恶口众中骂佛。佛无异色亦无异心。此婆罗门心伏。还以五百种语赞佛。佛无喜色亦无悦心。于此毁誉心色无变。又复旃遮婆罗门女。带杅谤佛。佛无惭色事情既露佛无悦色。转法轮时赞美之声。满于十方心亦不高。孙陀利死恶声流布心亦不下。阿罗毗国土风寒又多蒺[卄/梨]。佛于中坐卧不以为苦。又在天上欢喜园中。夏安居时坐剑婆石。柔软清洁如天綩綖。亦不以为乐受。大天王跽奉天食不以为美。毗兰若国食马麦不以为恶。诸大国王供奉上馔不以为得。入萨罗聚落空钵而出不以为失。提婆达多于耆阇崛山。推石压佛佛亦不憎。是时罗睺罗。敬心赞佛佛亦不爱。阿阇贳纵诸醉象。欲令害佛佛亦不畏降伏狂象。王舍城人益加恭敬。持香华缨络出供养佛佛亦不喜。九十六种外道。一时和合议言。我等亦皆是一切智人。从舍婆提来欲共佛论议。尔时佛以神足从脐放光。光中皆有化佛。国王波斯匿。亦命之令来于其坐上尚不能得动。何况能得与佛论议。佛见一切外道贼来。心亦无退破是外道。诸天世人倍益恭敬供养心亦不进。如是等种种因缘来。欲毁佛佛不可动。譬如真阎浮檀金。火烧不异捶打磨斫不败不异。佛亦如是经诸毁辱诽谤论议不动不异。以是故知佛诸烦恼习都尽无余。问曰。诸阿罗汉辟支佛。同用无漏智断诸烦恼习。何以有尽不尽。答曰。先已说智慧力薄如世间火。诸佛力大如劫尽火。今当更答。声闻辟支佛集诸功德智慧不久。或一世二世三世。佛智慧功德。于无量阿僧祇劫。广修广习善法久熏故。于烦恼习无复余气。复次佛于一切诸功德。皆已摄尽故。乃至诸烦恼习气永尽无余。何以故。诸善法功德。消诸烦恼故。诸阿罗汉于此功德不尽得故。但断世间爱直入涅槃。复次佛断结使智慧力甚利。用十力为大刀。以无碍智直过故断诸结使尽。无复遗余。譬如人有重罪国王大嗔诛其七世根本令无遗余。佛亦如是于烦恼重贼诛拔根本令无遗余。以是故说欲以一切种智断一切烦恼习。当习行般若波罗蜜。问曰。但断习亦除烦恼。答曰。有人言。断烦恼及习俱尽。如先说习尽无余。阿罗汉辟支佛。但断烦恼不能断习。菩萨断一切烦恼及习。令尽无余。有人言。佛久已远欲。如佛说我见定光佛已来已离欲。以方便力故。现有生死妻子眷属。有人言。从得无生法忍来。得诸法实相故。一切烦恼及习尽。有人言。佛从初发意来有烦恼。至坐道场于后夜时。断一切烦恼及习。问曰。如是种种说何者为实。答曰。皆是佛口所说故无有不实。声闻法中。佛以方便力故现受人法。有生老病寒热饥渴等。无人生而无烦恼者。是故佛亦应随人法有烦恼。于树王下外先破魔军。内灭结使贼。破外内贼故。成阿耨多罗三藐三菩提。人皆信受是人能为是事。我等亦当学习是事。若言久来无烦恼若从然灯佛得无生法忍来断烦恼尽。是亦方便说。令诸菩萨欢喜故。若菩萨久已断一切烦恼。成佛时复何所为。问曰。佛有种种事。断结使是一事。余有净佛国土成就众生等未具。以具足众事故名为佛。答曰。若尔者佛言断结使是末后身。人若都无结使云何得生。问曰。从得无生法忍已来。常得法性生身变化不。答曰。化法要有化主然后能化。若得无生法忍断一切结使。死时舍是肉身无有实身谁为变化。以是故知得无生已来。不应尽结使。复次声闻人言。菩萨不断结使乃至坐道场然后断。是为大错。何以故汝法中说。菩萨已满三阿僧祇劫。后更有百劫中。常得宿命智自忆迦叶佛时。作比丘名郁多罗修行佛法。云何今六年苦行修邪道法。日食一麻一米。后身菩萨一日尚不应谬。何况六年。嗔亦如是从久远世时作毒蛇。猎者生剥其皮犹尚不嗔。云何最后身而嗔五人。以是故知声闻人受佛义为错。佛以方便力。欲破外道故。现六年苦行。汝言嗔五人者是为方便。亦是嗔习非烦恼也。今当如实说。菩萨得无生法忍。烦恼已尽习气未除故因习气受。及法性生身能自在化生。有大慈悲为众生故。亦为满本愿故。还来世间。具足成就余残佛法故。十地满坐道场。以无碍解脱力故。得一切智一切种智断烦恼习。摩诃衍人言。得无生法忍菩萨一切烦恼及习都尽。亦是错若都尽与佛无异。亦不应受法性生身。以是故菩萨得无生法忍。舍生身得法性生身。若言至坐道场一切烦恼及习俱断。是语亦非。所以者何。若菩萨具有三毒者。云何能集无量佛法。譬如毒瓶虽着甘露皆不中食。菩萨集诸纯净功德乃得作佛。若杂三毒。云何能具足清净佛法。问曰。观诸法实相。及修悲心故。能令三毒薄故。能集清净功德。答曰。薄三毒。可得转轮圣王诸天王身。欲得佛功德身无有是事。三毒断习未尽。可得集诸功德。复次薄名如离欲人。断下地结犹有上地烦恼。又如须陀洹。见谛所断结尽。思惟所断未尽。是名为薄。如佛说断三结薄淫怒痴。名为斯陀含。汝若言薄应当是断。以是故得无生法忍时断烦恼。得佛时断烦恼习。是则实说

【经】复次舍利弗。菩萨摩诃萨欲上菩萨位。当学般若波罗蜜

【论】菩萨位者。无生法忍是。得此法忍观一切世间空心无所著。住诸法实相中。不复染世间。复次般舟般三昧是菩萨位。得是般舟般三昧。悉见现在十方诸佛。从诸佛闻法断诸疑网。是时菩萨心不动摇。是名菩萨位。复次菩萨位者。具足六波罗蜜生方便智。于诸法实相亦不住。自知自证不随他语。若魔作佛形来心亦不惑。复次入菩萨法位力故。得名阿鞞跋致菩萨。复次菩萨摩诃萨。入是法位中。不复堕凡夫数。名为得道人。一切世间事。欲坏其心不能令动。闭三恶趣门。堕诸菩萨数中。初生菩萨家。智慧清净成熟。复次住顶不堕。是名菩萨法位。如学品中说。上位菩萨不堕恶趣。不生下贱家。不堕声闻辟支佛地。亦不从顶堕。问曰云何为顶堕。答曰如须菩提语舍利弗。若菩萨摩诃萨。无方便心行六波罗蜜。入空无相无作中。不能上菩萨位。亦不堕声闻辟支佛地。爱着诸功德法。于五众无常苦空无我取相心着。言是道是非道是应行是不应行。如是等取相分别。是菩萨顶堕。何等是住顶如上所说。诸法爱断于爱断法亦复不取。如住顶义中说。若菩萨摩诃萨。行般若波罗蜜时。内空中不见外空。外空中不见内空。外空中不见内外空内外空中不见外空。乃至无法有法空亦如是。复次上位菩萨。得无等等心亦不自高。知心相真空。诸有无等戏论灭。问曰。何以故声闻法中名为正位。此菩萨法中位但名位。答曰。若言正位亦无咎。所以者何。若言菩萨法位是则为正。声闻法中但言位。不言声闻位。以是故言正位。复次学声闻人。无大慈悲心。智慧不利故未生厌心。多求诸法生种种邪见疑悔。菩萨摩诃萨。大慈愍一切故。多求度脱众生老病死苦。不求分别种种戏论。譬如长者有一子爱之甚重。其子得病但求良药能差病者。不求分别诸药名字。取之时节合和分数。以是故诸菩萨。从果观十二因缘。不从因观。见多者从因观。爱多者从果观。诸声闻人因即位故有正位。菩萨邪位薄故。但名菩萨位。问曰。声闻法中。从苦法忍乃至道比忍。名为正位。如经中说。三恶道中不可得三事。所谓正位圣果漏尽。破戒邪见五逆罪等亦如是。从得何法名为菩萨位。答曰。发意修行大悲。方便具足行是四法。得入菩萨位。如声闻法中先具说四种善根。暖法顶法忍法世间第一法。然后入苦法忍正位。问曰。修行皆摄四法。何以故差别为四。答曰。初发意虽有修行。不久修故不名修行如在家。虽终日不住不名为行。复次发意时但有意愿。行时造作以财与人受持禁戒。如是等行六波罗蜜。是名修行。修行已以般若波罗蜜。知诸法实相。以大悲心愍念众生。不知是诸法实相。染着世间虚诳法。受种种身苦心苦。是更受大悲名故。不名修行方便者。具足般若波罗蜜故知诸法空。大悲心故怜愍众生。于是二法以方便力不生染着。虽知诸法空方便力故亦不舍众生。虽不舍众生。亦知诸法实空。若于是二事等即得入菩萨位。如声闻人。于定慧二法等故。是时即得入正位。是法虽有行更有余名字不名修行。从初发意乃至坐道场。于其中间所行皆名修行。小小差别有异。名字为易解故。譬如有人初发阿耨多罗三藐三菩提意。欲度脱一切众生老病死等身心诸苦。作大誓庄严功德慧明二事因缘故所愿皆满。是二事有六分修行。名为六波罗蜜。布施持戒忍辱是功德分。精进禅定智慧是慧明分。修行六波罗蜜。知是诸法相。甚深微妙难解难知。作是念众生。着三界诸法。以何因缘令众生得是诸法相。当以具足诸功德清净智慧成就。佛身三十二相八十随形好。光明具足神通无量。以十力四无所畏十八不共法四无碍智。观应可度者说法开化。譬如金翅鸟王普观诸龙命应尽者。以翅抟海令水两辟取而食之。佛亦如是。以佛眼观十方世界五道众生。谁应得度。初现神足次为示其心趣。以此二事除三障碍而为说法拔三界众生。得佛力无量神通。假令虚妄犹尚可信。何况实说是名方便。复次菩萨以般若波罗蜜。知诸法相念其本愿。欲度众生作是思惟。诸法实相中众生不可得当云何度。复作是念。诸法实相中众生虽不可得。而众生不知是诸法相故。欲令知是实相。复次是实法相。亦不碍众生。实法相者名为无所除坏。亦无所作是名方便。具足是四法得入菩萨位

【经】欲过声闻辟支佛地住阿鞞跋致地。当学般若波罗蜜

【论】问曰。菩萨入法位时。即已过声闻辟支佛地。住阿鞞跋致地。何以故复说。答曰。虽三事一时。诸法各各相应当次第赞。如一心中一时得无漏五根而各各分别说其相。菩萨入法位时。断若干结使。得若干功德。过是地住是地唯佛能知。亦欲引导诸菩萨故。佛种种赞说。如此经始佛在耆阇崛山。与五千比丘俱。皆是阿罗汉。诸漏已尽所作已办等。阿罗汉即是漏尽。漏尽者即是所作已办等。亦为引导余人。令心清净故。种种赞说无咎。此亦如是入法位即是过阿罗汉辟支佛地。住阿鞞跋致地。复次因入法位故。得过阿罗汉辟支佛地。住阿鞞跋致地。问曰。入法位中过老病死。及断诸结使。破三恶道等如先说。何以但说过声闻辟支佛地。亦住种种功德。何以故。但说住阿鞞跋致地。答曰。舍诸恶事得诸功德。后当次第说及所住功德。诸法当须次第。不可一时顿说。复次菩萨初发意时所可怖畏无过声闻辟支佛地。正使堕地狱无如是怖畏。不永破大乘道故。阿罗汉辟支佛。于此大乘以为永灭。譬如空地有树名舍摩梨。觚枝广大众鸟集宿。一鸽后至住一枝上。其枝及觚即时压折。泽神问树神。大鸟雕鹫皆能任持。何至小鸟便不自胜。树神答言。此鸟从我怨家尼俱卢树上来。食彼树果来栖我上。必当放粪子堕地者恶树复生为害必大。以是故于此一鸽大怀忧畏。宁舍一枝所全者大。菩萨摩诃萨亦如是。于诸外道魔众及诸结使恶业无如是畏。如阿罗汉辟支佛。何以故。声闻辟支佛。于菩萨边亦如彼鸽。坏败大乘心永灭佛业。以是故但说过声闻辟支佛地。住阿鞞跋致地者。从初发意已来。常喜乐住阿鞞跋致地。闻诸菩萨多退转故。发意时作愿。何时当得过声闻辟支佛地住阿鞞跋致地。以是故说住阿鞞跋致地。问曰。何等是阿鞞跋致地。答曰。若菩萨能观一切法不生不灭不不生不不灭不共非不共。如是观诸法。于三界得脱。不以空不以非空。一心信忍十方诸佛所用实相智慧。无能坏无能动者。是名无生忍法。无生忍法即是阿鞞跋致地。复次入菩萨位是阿鞞跋致地。过声闻辟支佛地。亦名阿鞞跋致地。复次住阿鞞跋致地。世世常得果报神通不失不退。若菩萨得此二法。虽得诸法实相。而以大悲不舍一切众生。复有二法。一者清净智慧。二者方便慧。复有二法。一者深心念涅槃。二者所作不离世间。譬如大龙。尾在大海头在虚空。震电雷霆而降大雨。复次阿鞞跋致菩萨。得是诸法实相智慧。世世不失终不暂离。于诸佛深经。终不疑亦不作碍。何以故。我未得一切智慧故。不知何方便何因缘故。如是说。阿鞞跋致菩萨。常以深心终不生恶。阿鞞跋致以深心集诸善。浅心作诸不善。问曰。若阿鞞跋致相。得无生法忍。云何以浅心作诸不善。答曰。有二种阿鞞跋致。一者得无生忍法。二者虽未得无生忍法。佛知其过去未来所作因缘。必得作佛。为利益傍人故为其授记。是菩萨生死肉身结使未断。于诸凡夫中为最第一。是亦名阿鞞跋致相。若得无生忍法断诸结使此则清净。末后肉身尽得法性生身。结使所不碍不须教诫。如大恒河中船不须将御自至大海。复次有初发意生大心。断诸烦恼知诸法实相。便得阿鞞跋致。有但行檀波罗蜜。便具足六波罗蜜。乃至般若波罗蜜亦如是。有行六波罗蜜。未得阿鞞跋致。于众生中生大悲心。是时便得阿鞞跋致。有得悲心而作是念。若诸法皆空则无众生谁可度者。是时悲心便弱。或时以众生可愍。于诸法空观弱。若得方便力于此二法等无偏党。大悲心不妨诸法实相。得诸法实相不妨大悲。生如是方便。是时便得入菩萨法位。住阿鞞跋致地。如往生品中说。复次阿鞞跋致相。如后阿鞞跋致二品中说

大智度论卷第二十七大智度论初品中欲住六神通释论第四十三(卷二十八)

        圣者龙树造

        后秦龟兹国鸠摩罗什译

【经】菩萨摩诃萨欲住六神通。当学般若波罗蜜

【论】问曰。如赞菩萨品中。言诸菩萨皆得五神通。今何以言欲住六神通。答曰。五通是菩萨所得。今欲住六神通是佛所得。若菩萨得六神通可如来难。问曰。往生品中说。菩萨住六神通至诸佛国。云何言菩萨皆得五通。答曰。第六漏尽神通有二种。一者漏习俱尽。二者漏尽而习不尽。习不尽故言皆得五通。漏尽故言住六神通。问曰。若菩萨漏尽。云何复生云何受生。一切受生皆由爱相续故有。譬如米虽得良田时泽终不能生。诸圣人爱糠已脱故。虽有有漏业生因缘不应得生。答曰。先已说菩萨入法位。住阿鞞跋致地。末后肉身尽得法性生身。虽断诸烦恼。有烦恼习因缘故。受法性生身非三界生也。问曰。阿罗汉烦恼已尽习亦未尽。何以不生。答曰。阿罗汉无大慈悲。无本誓愿度一切众生。又以实际作证已离生死故

复次先已答有二种漏尽。此中不说菩萨得漏尽通。自言欲得六神通者。当学般若波罗蜜。六神通义如后品中佛所说。上赞菩萨品。亦已说菩萨五神通义。问曰。神通有何次第。答曰。菩萨离五欲得诸禅有慈悲故。为众生取神通。现诸希有奇特之事。令众生心清净。何以故。若无希有事。不能令多众生得度。菩萨摩诃萨。作是念已系心身中虚空。灭粗重色相。常取空轻相。发大欲精进心。智慧筹量心力能举身。未筹量已。自知心力大能举其身譬如学趠。常坏色粗重相。常修轻空相。是时便能飞。二者亦能变化诸物。令地作水水作地风作火火作风。如是诸大皆令转易。令金作瓦砾瓦砾作金。如是诸物各能令化。变地为水相。常修念水令多不复忆念地相。是时地相如念即作水。如是等诸物皆能变化。问曰。若尔与一切入有何等异。答曰。一切入是神通初道。先已一切入背舍胜处柔伏其心。然后易入神通。复次一切入中。一身自见地变为水余人不见。神通则不然。自见实是水他人亦见实水。问曰。一切入亦是大定。何以不能令是实水己身他人皆见。答曰。一切入观处广。但能令一切是水相。而不能令实是水。神通不能遍一切。而能令地转为水便是实水。以是故二定力各别。问曰。二定变化事为实为虚。若实云何石作金地作水。若虚云何圣人而行不实。答曰。皆实圣人无虚也。三毒已拔故。以一切法各各无定相故。可转地或作水相。如酥胶蜡是地类。得火则消为水则成湿相。水得寒则结成冰而为坚相。石汁作金金败为铜或还为石。众生亦如是。恶可为善善可为恶。以是故知一切法无定相故。用神通力变化实而不诳。若本各各定相则不可变三者诸贤圣神通。于六尘中随意自在。见好能生厌想。见丑能生乐想。亦能离好丑想行舍心。是名三种神通。此自在神通唯佛具足。菩萨得是神通。游诸佛国于诸异国语言不同。及在远微细众生不闻故。求天耳通常忆念种种多众大声取相修行。常修习故。耳得色界四大造清净色。得已便得远闻。于天人音声粗细远近通达无碍。问曰。如禅经中说。先得天眼见众生而不闻其声故。求天耳通既得天眼天耳。见知众生身形音声。而不解语言种种忧喜苦乐之辞故。求辞无碍智。但知其辞而不知其心故。求知他心智。知其心已。未知本所从来故。求宿命通。既知所来欲治其心病故。求漏尽通。得具足五通已。不能变化故所度未广。不能降化邪见大福德人。是故求如意神通。应如是次第。何以故。先求如意神通。答曰。众生粗者多细者少。是故先以如意神通。如意神通能兼粗细度人多故是以先说。复次诸神通。得法异数法异。得法者多先求天眼以易得故。行者用日月星宿珠火。取是等光明相。常勤精进善修习故昼夜无异。若上若下若前若后。等一明彻无所挂碍。是时初得天眼神通。余次第得如先说。复次佛如所自得。为人说次第。佛初夜分得一通一明。所谓如意通宿命明。中夜分得天耳通天眼明。后夜分得知他心智通漏尽明。求明用功重故在后说。通明次第得如四沙门果。大者在后。问曰。若天眼易得故在前。菩萨何以不先得天眼。答曰。菩萨于诸法皆易无难。余人钝根故有难有易。复次初夜时魔王来欲与佛战。菩萨以神通力种种变化令魔兵器皆为璎珞。降魔已续念神通。欲令具足。生心即入便得。具足神通降魔已。自念一身云何得大力。便求宿命明自知世世积福德力故。中夜时魔即还去寂寞无声。慈愍一切故。念魔众声。生天耳神通及天眼明。用是天耳闻十方五道众生苦乐声。闻声已欲见其形。而以障蔽不见故求天眼后夜时既见众生形。欲知其心故求他心智知众生心。皆欲离苦求乐。是故菩萨求漏尽神通。于诸乐中漏尽最胜。令众生得之。问曰。菩萨已得无生法忍。世世常得果报神通。今何以自疑既见众生而不知其心。答曰。有二种菩萨。一者法性生身菩萨。二者为度众生故。方便受人法。身生净饭王家。出四城门。问老病死人。是菩萨坐树王下具六神通。复次菩萨神通先有而未具足。今于三夜所得。是佛神通行人法故。自疑无咎。问曰。六神通次第。常初天眼后漏尽通。亦有不尔时耶。答曰。多先天眼后漏尽智。或时随所好修。或先天耳或先神足。有人言。初禅天耳易得。有觉观四心故。二禅天眼易得。眼识无故心摄不散故。三禅如意通易得。身受快乐故。四禅诸通皆易得。一切安隐处故。宿命等三神通义。如十力中说

【经】欲知一切众生意所趣向。当学般若波罗蜜

【论】问曰。六通中已说知他心通。今何以重说。答曰。知他心通境界少。但知欲界色界现在众生心心数法。不知过去未来及无色界众生心心数法。凡夫通于上四禅地随所得通处已下。遍知四天下众生心心数法。声闻通于上四禅地随所得通处已下遍知千世界众生心心数法。辟支佛通于上四禅地随所得通处已下遍知百千世界众生心心数法。上地钝根者。不能知下地利根者心心数法。凡夫不知声闻心心数法。声闻不知辟支佛心心数法。辟支佛不知佛心心数法。以是故说欲知一切众生心所趣向当学般若波罗蜜。问曰。以何智能知一切众生心心数法。答曰。诸佛有无碍解脱。入是解脱中。能知一切众生心心数法。诸大菩萨得相似无碍解脱。亦能知一切众生心心数法。新学菩萨欲得是大菩萨无碍解脱及佛无碍解脱。以此无碍解脱知一切众生心心数法。大菩萨欲得佛无碍解脱。以是故虽已说知他心通。更说欲知一切众生心所趣向当学般若波罗蜜。问曰。心所趣向。心为去为不去。若去此则无心犹若死人。若不去云何能知。如佛言依意缘法意识生意。若不去则无和合。答曰。心不去不住而能知。如般若波罗蜜中说。一切法无来无去相。云何言心有来去。又言诸法生时无所从来。灭时无所去。若有来去即堕常见。诸法无有定相。以是故但以内六情外六尘和合生六识。及生六受六想六思。以是故心如幻化。能知一切众生心心数法。无有知者无有见者。如叹摩诃衍品中言。若一切众生心心数法。性实有不虚诳者。佛不能知一切众生心心数法。以一切众生心心数法性实虚诳无来无去故。佛知一切众生心心数法。譬如比丘贪求者不得供养。无所贪求则无所乏短。心亦如是。若分别取相则不得实法。不得实法故不能通达知一切众生心心数法。若不取相无所分别则得实法。得实法故能通达。知一切众生心心数法无所挂碍。问曰。一切众生诸心可得悉知不。若悉知则众生有边。若不知何以故说欲知一切众生心所趣向。云何佛有一切种智。答曰。一切众生心心数法可得悉知。何以故如经中说。一切实语中佛最第一。若不能悉知一切众生心得其边际者。佛何以言悉知。亦不名一切智人。而佛语皆实。必应实有一切智人。复次众生虽无边。一切种智亦无边。譬如函大盖亦大。若智慧有边众生无边者应有是难。今智慧及众生俱无边故。汝难非也。复次若言有边无边。此二于佛法中是置答。是十四事虚妄无实无益故。不应以为难。问曰。若有边无边二俱不实。而佛处处说无边。如众生有痴爱已来。无始无边十方亦无边际。答曰众生无边。佛智慧无边。是为实。若人着无边取相戏论故。佛说是邪见。譬如世间常无常二俱颠倒入十四难中。而佛多以无常度众生少用有常。若着无常取相戏论。佛说是邪见虚妄。若不着无常。知无常即是苦苦即是无我无我即是空。能如是依无常观。入诸法空便是实。以是故知无常入真谛中。是实十四难中。以着因缘故说是邪见。是故说无常以明无边。无边故众生生厌生死长久。譬如波梨国四十比丘。俱行十二净行来至佛所。佛为说厌行。佛问比丘五恒河伽蓝牟那萨罗由阿脂罗婆提摩醯。从所来处流入大海。其中间水为多少。比丘言。甚多。佛言。但一人一劫中作畜生时。屠割剥刺。或时犯罪截其手足。斩其身首。如是等血多于此水。如是无边大劫中。受身出血不可称数。啼哭流泪及饮母乳亦如是。计一劫中一人积骨。过于鞞浮罗大山。(丹注云此山天竺以人常见易信故说也)如是无量劫中受生死苦。诸比丘闻是已。厌患世间即时得道。复次闻十方众生无边故。心生欢喜受不杀戒。得无边福德。以是因缘故。初发意菩萨一切世间众生皆应供养。何以故。为度无边世界众生故。功德亦无边。有如是等益故说无边。以是故说悉知一切众生心所趣向。如日照天下一时俱至无不遍明

【经】菩萨摩诃萨欲胜一切声闻辟支佛智慧。当学般若波罗蜜

【论】问曰。何等是声闻辟支佛智慧。答曰。以总相别相。观诸法实相。是声闻智慧。如经中说。初以分别诸法智慧。后用涅槃智慧。分别诸法智慧是别相。涅槃智慧是总相。复次知是法为解是法为缚。是流转是来还是生是灭是味是患是逆是顺是此岸是彼岸是世间是出世间。如是等分别二门诸法。名为声闻智慧。复次三种智慧知五受众。如是集如是散如是出是味是患是离。三解脱门相应智。如是等分别三门诸法。复次四种智慧。四念处智法智比智他心智世智。苦智集智灭智道智。不净智无常智苦智无我智。无常智苦智空智无我智。法智比智尽智无生智。如是等分别四门诸法。复次从苦法智忍慧。乃至空空三昧无相无相三昧。无作无作三昧智。于其中间所有智慧。尽是声闻智慧略说厌世间。念涅槃离三界。断诸烦恼得最上法所谓涅槃是名声闻智慧。复次如般若波罗蜜义品中说。菩萨智慧相与声闻智慧是一智慧。但无方便无大誓庄严无大慈大悲。不求一切佛法不求一切种智知一切法。但厌老病死。断诸爱系直趣涅槃为异。问曰。声闻如是。辟支佛智慧云何。答曰。声闻智慧即是辟支佛智慧。但时节利根福德有差别。时名佛不在世亦无佛法。以少因缘出家得道。名辟支佛。利根名异法相是同。但智慧深入得辟支佛道。福德名有相。或一相二相。乃至三十一相。若先佛法中得圣法。法灭后成阿罗汉。名为辟支佛。身无有相。有辟支佛第一疾者四世行。久者乃至百劫行。如声闻疾者三世。久者六十劫。此义先已广说。问曰。如佛说有四种沙门果。四种圣人须陀洹乃至阿罗汉。五种佛子须陀洹乃至辟支佛。三种菩提阿罗汉菩提辟支佛菩提佛菩提。果中圣中佛子中菩提中皆无菩萨。云何言菩萨胜一切声闻辟支佛智慧。答曰。佛法有二种。一者声闻辟支佛法。二者摩诃衍法。声闻法小故。但赞声闻事不说菩萨事。摩诃衍广大故。说诸菩萨摩诃萨事。发心修行十地入位。净佛世界成就众生得佛道。此法中说菩萨次佛。应如供养佛。能如是观诸法相是为福田。能胜声闻辟支佛如是。摩诃衍经中。处处赞菩萨摩诃萨智慧胜声闻辟支佛。如宝顶经中说。转轮圣王少一不满千子。虽有大力诸天世人所不贵重。有真转轮圣王种。处在胎中。初受七日便为诸天所贵重。所以者何。九百九十九人。不能嗣转轮圣王种令世人得二世乐。是虽在胎必能绍胄圣王。是故恭敬。诸阿罗汉辟支佛。虽得根力觉意六神通诸禅智慧力于实际得证为众生福田。十方诸佛所不贵重。菩萨虽在诸结使烦恼欲缚三毒胎中。初发无上道意。未能有所作。而为诸佛所贵。以其渐渐当行六波罗蜜。得方便力入菩萨位。乃至得一切种智。度无量众生。不断佛种法种僧种。不断天上世间净乐因缘故。又如迦罗频伽鸟。在[穀-禾+卵]中未出。发声微妙胜于余鸟。菩萨摩诃萨亦如是。虽未出无明[穀-禾+卵]。说法议论之音。胜于声闻辟支佛及诸外道。如明网经中说。慧命舍利弗白佛言。世尊。是诸菩萨所说若能解者大得功德。何以故。是诸菩萨乃至得闻其名字得大利益。何况闻其所说。世尊。譬如人种树。不依于地而欲得其根茎枝叶成其果实。是难可得。诸菩萨行相亦如是。不住一切法。而现住生死。在诸佛世界。于中自恣乐说智慧法。谁有闻是大智慧。游戏自恣乐说法。而不发阿耨多罗三藐三菩提意者。尔时会中有普华菩萨。语舍利弗。佛说耆年于诸弟子中智慧第一。今耆年于诸法法性不得耶。何以不以大智慧自恣乐说法。舍利弗言。诸佛弟子如其境界则能有说。普华菩萨复问。法性有境界不。舍利弗言。无也。若法性无境界。云何耆年言如其境界则能有说。舍利弗言。随所得而说。普华又问。耆年。以无量相法性为证耶。舍利弗言尔。普华言。今云何言随所得而说。如所得法性无量。说亦应无量。法性无量非量相。舍利弗语普华言。法性非得相。普华言。若法性非得相。汝离法性得解脱不。舍利弗言。不也。何以故。法性不坏相故。普华言。汝所得圣智亦如法性耶。舍利弗言。我欲闻法非说时也。普华言。一切法定在法性中。有闻者说者不。舍利弗言。无也。普华言。汝何以言我欲闻法非说时。舍利弗言。佛说二人得福无量。一心说者。一心听者。普华言。汝入灭尽定中能听法不。舍利弗言。善男子。灭尽定中无听法也。普华言。汝信受一切法常灭相不。舍利弗言。信是事。普华言。法性常灭无听法也。何以故。诸法常灭相故。舍利弗言。汝能不起于定而说法不。普华言。无有法非定相者。舍利弗言。若尔者今一切凡夫皆是禅定。普华言尔。一切凡夫皆是禅定。舍利弗言。以何等禅定故。一切凡夫皆是。普华言。以不坏法性三昧故。一切凡夫皆是禅定。舍利弗言。若尔者凡夫圣人无有差别。普华言。我亦不欲令凡夫圣人有差别。何以故。诸圣人无有灭法。凡夫人亦无生法。是二皆不出法性等相。舍利弗言。善男子。何等是法性等相。答言。耆年得道时所知见者是。又问。生圣法耶。不也。灭凡夫法耶。不也。得圣法耶。不也。见知凡夫人法耶。不也。耆年以何知见故得圣道。舍利弗言。凡夫人如。比丘得解脱如。比丘入无余涅槃如。是如一如如无别。普华言。舍利弗。是名法性相如不坏如用是如。当知一切法皆如。舍利弗白佛言。世尊。譬如大火聚无物不烧。是诸上人所说亦如是。一切法皆入法性。又如毗摩罗诘经中说。舍利弗等诸声闻皆自说言。我不堪任诣彼问疾。各各自说。昔为毗摩罗诘所呵。如是等处处经中说菩萨智慧胜于声闻辟支佛。问曰。何因缘故。菩萨智慧胜声闻辟支佛。答曰。如一本生经中说。菩萨智慧于无量阿僧祇劫已来合集众智。于无量劫中无苦不行无难不为。为求法故。赴火投岩受剥皮苦。出骨为笔以血为墨以皮为纸书受经法。如是等为法故受无量苦。以智慧故世世供养其师视之如佛。一切所有经书悉皆诵读解说。于无量阿僧祇劫常思惟筹量。寻求诸法好丑深浅善不善漏不漏常不常有无等。思惟分别问难。为智慧故供养诸佛及菩萨声闻。听法问难信受正忆念如法行。如是智慧因缘具足故。云何不胜阿罗汉辟支佛

复次菩萨智慧五波罗蜜佐助庄严。有方便力于一切众生有慈悲心故。不为邪见所妨。住十地中故。智慧势力深大。大故胜于声闻辟支佛。以大因故小者自坏。阿罗汉辟支佛无是事。以是故言欲胜声闻辟支佛智慧当学般若波罗蜜

【经】欲得诸陀罗尼门诸三昧门。当学般若波罗蜜

【论】陀罗尼如赞菩萨品中说。门者得陀罗尼方便诸法是。如三三昧名解脱门。何者是方便。若人欲得所闻皆持。应当一心忆念令念增长。先当作意于相似事系心令知所不见事。如周利槃陀迦。系心拭革屣物中。令忆禅定除心垢法。如是名初学闻持陀怜尼。三闻能得心根转利。再闻能得成者。一闻能得得而不忘。是为闻持陀怜尼初方便。或时菩萨入禅定中。得不忘解脱。不忘解脱力故。一切语言说法。乃至一句一字皆能不忘。是为第二方便。或时神咒力故。得闻持陀怜尼。或时先世行业因缘受生。所闻皆持不忘。如是等名闻持陀罗尼门。复次菩萨闻一切音声语言。分别本末观其实相。知音声语言。念念生灭。音声已灭而众生忆念取相。念是已灭之语作是念言。是人骂我而生嗔恚。称赞亦如是。是菩萨能如是观众生。虽复百千劫骂詈不生嗔心。若百千劫称赞亦不欢喜。知音声生灭如响相。又如鼓声无有作者。若无作者是无住处。毕竟空故但诳愚夫之耳。是名入音声陀罗尼。复次有陀罗尼。以是四十二字。摄一切语言名字。何者是四十二字。阿罗波遮那等阿提秦言初阿耨波柰秦言不生行陀罗尼菩萨闻是阿字即时入一切法初不生。如是等字字随所闻。皆入一切诸法实相中。是名字入门陀罗尼。如摩诃衍品中说诸字门。复次菩萨得是一切三世无碍明等诸三昧。于一一三昧中。得无量阿僧祇陀罗尼。如是等和合。名为五百陀罗尼门。是为菩萨善法功德藏。如是名为陀罗尼门。诸三昧门者。三昧有二种。声闻法中三昧。摩诃衍法中三昧。声闻法中三昧者。所谓三三昧。复次三三昧。空空三昧无相无相三昧无作无作三昧。复有三三昧。有觉有观无觉有观无觉无观。复有五支三昧。五智三昧等是名诸三昧。复次一切禅定亦名定亦名三昧。四禅亦名禅亦名定亦名三昧。除四禅诸余定亦名定。亦名三昧不名为禅。十地中定名为三昧。有人言欲界地亦有三昧。何以故。欲界中有二十二道品故。知有三昧。若无三昧不应得是深妙功德。复次千问中亦有是问。四圣种几欲界系几色界系几无色界系几不系。答曰。一切当分别四圣种。或欲界系或色界系或无色界系或不系。四念处四正勤四如意足亦如是。以是义故。当知欲界有三昧。若散乱心云何得此上妙法。以是故是三昧在十一地中。如是等诸三昧。阿毗昙中广分别。摩诃衍三昧者。从首楞严三昧乃至虚空际无所著解脱三昧。又如见一切佛三昧乃至一切如来解脱修观师子频伸等。无量阿僧祇菩萨三昧。如有三昧名无量净。菩萨得是三昧者。能示现一切清净身。有三昧名威相。菩萨得是三昧。能夺日月威德。有三昧名焰山。菩萨得是三昧。夺诸释梵威德。有三昧名出尘。菩萨得是三昧灭一切大众三毒。有三昧名无碍光。菩萨得是三昧。能照一切佛国。有三昧名不忘一切法。菩萨得是三昧。一切诸佛所说法皆能忆持。复为他人讲说佛语。有三昧名声如雷音。菩萨得是三昧。能以梵声满十方佛国。有三昧名能娱乐一切众生。菩萨得是三昧能令一切深心欢喜。有三昧名喜见无厌。菩萨得是三昧。一切众生见闻喜乐无有厌足。有三昧名功德报不可思议一缘中乐。菩萨得是三昧。成就一切神通。有三昧名知一切音声语言。菩萨得是三昧。能说一切音声语言。于一字中说一切字。于一切字中说一字。有三昧名集一切福富乐果报。若菩萨得是三昧。常默然入禅定。而能令一切众生闻佛法众闻声闻辟支佛六波罗蜜之声。而是菩萨实无一言。有三昧名出高一切陀罗尼王。菩萨得是三昧。得入无量无边诸陀罗尼。有三昧名一切乐说。菩萨得是三昧。乐说一切字一切音声语言譬喻因缘。如是等无量力势三昧。问曰。是三昧即是三昧门不。答曰。三昧即是三昧门。问曰。若尔者何以不但说三昧。而复说三昧门。答曰。佛诸三昧无量无数。如虚空无边。菩萨云何尽得。菩萨闻是心则退没。以是故佛说三昧门。入一门中摄无量三昧。如牵衣一角举衣皆得。亦如得蜜蜂王余蜂尽摄。复次展转为门。如持戒清净。一心精进初夜后夜勤修思惟离五欲乐。系心一处行是方便得是三昧。是名三昧门。复次欲界系三昧是未到地三昧门。未到地三昧是初禅门。初禅及二禅边地三昧是二禅三昧门。乃至非有想非无想处三昧亦如是。暖法定是顶法三昧门。顶法是忍法三昧门。忍法是世间第一法三昧门。世间第一法。是苦法忍三昧门。苦法忍乃至金刚三昧门。略说一切三昧有三相。入住出相是。出相入相名为门。住相是三昧体。如是等法是声闻法中三昧门。摩诃衍法中三昧门。如禅波罗蜜义中诸三昧分别广说。复次尸罗波罗蜜是三昧门。何以故。三支是佛道。所谓戒支定支慧支。清净戒支。是定支门能生是定。定支能生慧支。是三支能断烦恼能与涅槃。以是故尸罗波罗蜜及智慧名三昧近门。余三波罗蜜。虽是门义名远门。如布施因缘得福德。福德故所愿皆得。如所愿故心柔软。慈悲心故知畏罪念众生。观世间空无常故。摄心行忍辱。忍辱亦是三昧门。精进者于五欲中制心除五盖摄心不乱。心去则摄不令驰散。亦是三昧门。复次初地是二地三昧门。如是展转乃至九地是十地三昧门。十地是无量诸佛三昧门。如是等名为诸三昧门。问曰。陀罗尼门三昧门为同为异。若同何以重说。若异有何义。答曰。先已说三昧门陀罗尼门异。今当更说。三昧但是心相应法。陀罗尼亦是心相应亦是心不相应。问曰。云何知陀罗尼是心不相应。答曰。如人得闻持陀罗尼。虽心嗔恚亦不失。常随人行如影随形。是三昧修行。习久后能成陀罗尼。如众生久习欲便成其性。是诸三昧共诸法实相智慧。能生陀罗尼。如坏瓶得火烧。熟能持水不失。亦能令人得度河。禅定无智慧亦如坏瓶。若得实相智慧。如坏瓶得火烧成熟。能持菩萨二世无量功德。菩萨亦因之而度得至佛。如是等三昧陀罗尼种种差别。问曰。声闻法中何以无是陀罗尼名但大乘中有。答曰。小法中无大汝不应致问。大法中无小者则可问。如小家无金银不应问也。复次声闻不大殷勤集诸功德。但以智慧求脱老病死苦。以是故声闻人。不用陀罗尼持诸功德。譬如人渴得一掬水则足。不须瓶器持水。若供大众人民。则须瓶瓮持水。菩萨为一切众生故。须陀罗尼持诸功德。复次声闻法中。多说诸法生灭无常相故。诸论议师言。诸法无常若无常相则不须陀罗尼。何以故。诸法无常相则无所持。唯过去行业因缘不失。如未来果报虽无必生。过去行因缘亦如是。摩诃衍法生灭相不实。不生不灭相亦不实。诸观诸相皆灭是为实。若持过去法则无咎以持过去善法。善根诸功德故。须陀罗尼。陀罗尼世世常随。菩萨诸三昧不尔。或时易身则失。如是等种种。分别陀罗尼诸三昧。以是故言欲得诸陀罗尼诸三昧门当学般若波罗蜜

    大智度论释布施随喜心过上第四十四

【经】一切求声闻辟支佛人布施时。欲以随喜心过其上者。当学般若波罗蜜。一切求声闻辟支佛人持戒时。欲以随喜心过其上者。当学般若波罗蜜。一切求声闻辟支佛人持戒时。欲以随喜心过其上者。当学般若波罗蜜。一切求声闻辟支佛人三昧智慧解脱解脱知见。欲以随喜心过其上者。当学般若波罗蜜

【论】随喜心者。如随喜品中说。复次随喜名有人作功德。见者心随欢喜赞言善哉。在无常世界中。为痴闇所蔽。能弘大心建此福德。譬如种种妙香一人卖一人买。傍人在边亦得香气。于香无损二主无失。如是有人行施有人受者。有人在边随喜功德。俱得二主不失。如是相名为随喜。以是故菩萨但以随喜心。过于求二乘人上。何况自行。问曰。菩萨云何能以随喜心过声闻辟支佛人以财布施上。答曰。声闻辟支佛行是布施。菩萨于傍见之。一心念随喜赞言善哉。以此随喜福德。回向阿耨多罗三藐三菩提。为度一切众生故。以此为得无量佛法故。以二种功德。过求声闻辟支佛人所行布施上。复次以诸法实相智慧心随喜故。过求声闻辟支佛人布施上。复次菩萨以随喜心。生福德果报回向。供养三世十方诸佛。过声闻辟支佛布施上。譬如人以少物献上国王得报甚多。又如吹贝用气甚少其音甚大。复次菩萨以随喜功德和合无量诸余功德乃至法灭亦不尽。譬如少水置大海中穷劫乃尽。持戒三昧智慧解脱解脱知见亦如是。问曰。若诸佛次第有菩萨。菩萨次第有声闻辟支佛。今言菩萨欲过求声闻辟支佛人布施等。有何奇特。答曰。不以声闻辟支佛布施持戒等福德比菩萨功德。但以随喜心能胜。何况菩萨自行功德。求声闻辟支佛人。勤身作功德疲劳。菩萨默然随喜智慧力福德过其上。譬如工匠。但以智心指授而去。执斤斧者疲苦。终日计功受赏匠者三倍。又如征伐斗者冒死主将受功。问言。若随喜心故。胜于布施持戒者。何以但说菩萨随喜胜。答曰。凡夫人烦恼覆心。吾我未断着世间乐。云何能胜求声闻辟支佛者。声闻辟支佛利虽胜钝。同在声闻地故不说。问曰。声闻辟支佛功德法甚多。何以故。但说六事。答曰。此六事法中摄一切声闻辟支佛法。若说布施已说信闻等功德。何以故。先闻已能信信已布施。是施有二种财施法施。持戒摄三种戒。律仪戒禅戒无漏戒。定摄诸禅定解脱三昧等。慧摄诸闻慧思慧修慧。解脱摄二种解脱。有为解脱无为解脱。解脱知见摄尽智。自知漏已尽于三界得解脱。于是中了了知见。是中助道法圣道法已说。复次若不向涅槃功德。是中不说过上。以其功德薄故。问曰。胜名力势相夺。今菩萨不与声闻辟支佛竞。云何言胜。答曰。胜名但于一事中。以智慧方便心力故得福多。譬如人于一华中但取色香。蜂但取味以成蜜。亦如取水器大者得多器小得少。如是等喻可知。以随喜心深利智慧相应。胜声闻辟支佛布施等诸功德。是六法初布施。如檀波罗蜜义中分别声闻辟支佛法说。持戒如尸罗波罗蜜义品中分别声闻辟支佛法说。三昧智慧解脱解脱知见。如念佛义中分别声闻辟支佛法说

大智度论卷第二十八大智度论初品中布施随喜心过上释论第四十四之余(卷二十九)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】一切求声闻辟支佛人诸禅定解脱三昧。欲以随喜心过其上者。当学般若波罗蜜

【论】禅定者。四禅九次第定。解脱三昧者。八背舍三解脱门。慧解脱共解脱。时解脱不时解脱。有为解脱无为解脱等。有觉有观三昧。无觉有观三昧。无觉无观三昧。空三昧无相三昧无作三昧。如是等诸三昧。问曰。上六事中三昧即是禅定解脱三昧。今何以复说。答曰。有二种三昧。一种慧解脱分。二种共解脱分。前者慧解脱分。不能入禅定。但说未到地中三昧。此中说共解脱分。具有禅定解脱三昧。彼是略说此则广说。彼但说名此中分别义。复次前胜三昧者。有人谓一二三昧非深三昧。今此中具说禅定解脱甚深三昧。复次禅定解脱三昧有二种。一者离欲时得。二者求而得。离欲得者前已说。求而得者此中说。复次禅定解脱三昧得之甚难。精勤求之乃得。菩萨但持随喜心便得过其上。是为未尝有法。是故重说。问曰。彼中三昧智慧解脱解脱知见亦难得。何以言此为难得。答曰。先以说。是慧解脱分。不尽甚深义。共解脱阿罗汉三明阿罗汉难得故更说。复次是三昧智慧解脱解脱知见。虽难得而不广周悉。直为涅槃。此间明阿罗汉欲得现世禅定乐。所谓灭尽定顶际禅愿智无诤三昧等。如是事非直为涅槃。以是故更广说。何以故。如前者直为涅槃。彼中说解脱解脱知见相次故。当知一向直为涅槃。问曰。若以禅定解脱三昧难得故重说者。智慧于一切法中最难微妙。何以不重说。答曰。上言欲过声闻辟支佛慧。当学般若波罗蜜中已说。此禅定未说故重说禅定智慧二法最妙。有此二行所愿皆得。如鸟有两翼能有所至。解脱从此二法得。解脱知见即是智慧。布施持戒是身口业。粗行易得故不重说。问曰。菩萨以随喜心胜于声闻辟支佛布施持戒智慧可尔。所以者何。布施持戒眼见耳闻。智慧亦是闻法。可得生随喜心。如禅定解脱三昧。是不可见闻法。云何随喜。答曰。菩萨以知他心智而随喜。问曰。知他心智法。有漏知他心智知他有漏心。无漏知他心智知他无漏心。菩萨未成佛。云何知声闻辟支佛无漏心。答曰。汝声闻法中尔。摩诃衍法中。菩萨得无生忍法断诸结使。世世常不失六神通。以有漏他心智。能知无漏心。何况以无漏知他心智。复有人言。初发意菩萨。未得法性生身。若见若闻声闻辟支佛布施持戒。皆知当得阿罗汉随喜心。言此人得诸法实相离三界。我所欲度一切众生生老病死。彼已得脱则是我事。如是等种种因缘随喜。以是故随喜无咎

    大智度论初品中回向释论第四十五

【经】菩萨摩诃萨行少施少戒少忍少进少禅少智。欲以方便力回向故而得无量无边功德者。当学般若波罗蜜

【论】问曰。前已说六波罗蜜。今何以复说。答曰。上总相说。此欲别相说。彼说因缘此说果报。问曰。不尔。彼中说六波罗蜜广普具足。此言少施乃至少智。似不同上六波罗蜜义。答曰。不然。即是六波罗蜜。何以故。六波罗蜜义在心不在事多少。菩萨行若多若少。皆是波罗蜜。如贤劫经说。八万四千诸波罗蜜。此经中亦说。有世间檀波罗蜜。有出世间檀波罗蜜。乃至般若波罗蜜。亦有世间出世间。问曰。菩萨何以故少施。答曰。有种种因缘故少施。或有菩萨。初发意福德未集贫故少施。或有菩萨闻施无多少功德在心。以是故不求多物布施。但求好心。或有菩萨作是念。若我求多集财物。破戒失善心心散乱多恼众生。若恼众生以供养佛。佛所不许破法求财故。若施凡人夺彼与此非平等法。如菩萨法等心一切皆如儿子。以是故少施。复次菩萨有二种。一者败坏菩萨。二者成就菩萨。败坏菩萨者。本发阿耨多罗三藐三菩提心。不遇善缘五盖覆心。行杂行转身受大富贵。或作国王或大鬼神王龙王等。以本造身口意恶业不清净故。不得生诸佛前及天上人中无罪处。是名为败坏菩萨。如是人虽失菩萨心。先世因缘故犹好布施。多恼众生劫夺非法取财以用作福。成就菩萨者。不失阿耨多罗三藐三菩提心慈愍众生。或有在家受五戒者。有出家受戒者。在家菩萨。虽行业成就。有先世因缘贫穷。闻佛法有二种施。法施财施。出家人多应法施。在家者多应财施。我今以先世因缘故不生富家。见败菩萨辈作罪布施心不喜乐。闻佛不赞多财布施。但美心清净施。以是故随所有物而施。又出家菩萨守护戒故不畜财物。又自思惟戒之功德胜于布施。以是因缘故。随所有而施。复次菩萨闻佛法中本生因缘。少施得果报多。如薄拘罗阿罗汉。以一诃梨勒果药布施。九十一劫不堕恶道。受天人福乐身常不病。末后身得阿罗汉道。又如沙门二十亿耳。于鞞婆尸佛法中作一房舍给比丘僧。布一羊皮令僧蹈上。以是因缘故。九十一劫中足不蹈地。受人天中无量福乐。末后身生大长者家。受身端政足下生毛长二寸色如青琉璃右旋。初生时父与二十亿两金。后厌世五欲出家得道。佛说精进比丘第一。又如须蔓耳比丘。先世见鞞婆尸佛塔。以耳上须蔓华布施。以是因缘故。九十一劫中常不堕恶道。受天上人中乐。末后身生时。须蔓在耳香满一室故。字为须蔓耳。后厌世出家得阿罗汉道。菩萨如是等本生因缘少施得大报。便随所有多少而布施。复次菩萨亦不一定。常少物布施。随所有多则多施少则少施。复次佛欲赞般若波罗蜜功德大故。言少施得大果功德无量。问曰。如薄拘罗阿罗汉等。亦少施而得大报。何用般若波罗蜜。答曰。薄拘罗等。虽得果报有劫数限量。得小道入涅槃。菩萨以般若波罗蜜方便回向故。少施福德无量无边阿僧祇。问曰。何等是方便回向。以少布施而得无量无边功德。答曰。虽少布施。皆回向阿耨多罗三藐三菩提。菩萨作是念。我以是福德因缘不求人天中王及世间之乐。但求阿耨多罗三藐三菩提。如阿耨多罗三藐三菩提无量无边。是福德亦无量无边。又以是福德。为度一切众生。如众生无量无边故。是福德亦无量无边。复次是福德用大慈悲。大慈悲无量无边故。是福德亦无量无边。复次菩萨福德诸法实相和合故三分清净。受者与者财物不可得故。如般若波罗蜜。初为舍利弗说菩萨布施时。与者受者财物不可得故。具足般若波罗蜜。用是实相智慧布施故。得无量无边福德。复次菩萨皆念所有福德。如相法性相实际相故。以如法性实际无量无边故。是福德亦无量无边。问曰。若菩萨摩诃萨。观诸法实相。知如法性实际。是无为灭相。云何更生心而作福德。答曰。菩萨久习大悲心故。大悲心尔时发起。众生不知是诸法实相。当令得是实相。以精进波罗蜜力故。还行福德业因缘。以精进波罗蜜助大悲心。譬如火欲灭遇得风薪火则然炽。复次念本愿故。亦十方佛来语言。汝念初发心时。又汝始得是一法门。如是有无量法门。汝未皆得当还集诸功德。如惭备经七地中说。问曰。施多少可尔。戒中有五戒一日戒十戒少多亦可知。色法可得分别故。余四波罗蜜云何知其多少。答曰。是皆可知。如忍有二种。一者身忍。二者心忍。身忍者虽身口不动。而心不能令不起。少忍故不能制心。心忍者身心俱忍犹如枯木。复次少忍者。若人挝骂不还报。大忍者不分别骂者忍者忍法。复次众生中忍是为少忍。法忍是为大忍。如是等分别少忍。少进者有二。身进心进。身进为少心进为大。外进为少内进为大。身口进为少意进为大。如佛说意业大力故。如大仙人嗔时。能令大国磨灭。复次身口作五逆罪大果报。一劫在阿鼻泥犁中。意业力大。得生非有想非无想。寿八万大劫。亦在十方佛国寿命无量。以是故知。身口精进为少。意精进为大。复次如经说。若身口意业寂灭不动是为大精进。动者为少精进。如是等名为少精进。少禅者欲界定未到地。不离欲故名为少。亦观二禅初禅则少。乃至灭尽定。有漏为少无漏为大。未得阿鞞跋致未得无生忍法禅是为少。得阿鞞跋致得无生法忍禅是为大。乃至坐道场十六解脱相应定为少十七金刚三昧为大。复次若菩萨观一切法常定。无散乱者无依止无分别是为大。余者皆为少。慧有二种。一者世间。二者出世间。世间慧为少。出世间慧为大。净慧杂慧相慧无相慧分别慧不分别慧随法慧破法慧为生死慧为涅槃慧为自益慧为益一切众生慧等亦如是。复次闻慧为少思慧为大。思慧为少修慧为大。有漏慧为少无漏慧为大。发阿耨多罗三藐三菩提心慧为少。修行六度慧为大。修慧为少方便慧为大。诸地中方便展转有大少乃至十地。如是等分别多少。佛叹菩萨奇特。于少事中得无量无边功德。岂况大事。余人多舍财。身口意勤苦得福少。持戒忍辱精进禅定智慧等亦如是。不及菩萨少而报大。如先说。譬如口气出声声则不远。声入角中声则能远。如是布施等同少。余人行是所得福报则少。菩萨摩诃萨以般若波罗蜜方便力回向故。得无量无边福。以是故说欲行少施少戒少忍少进少禅少智

【经】菩萨摩诃萨欲行檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜。当学般若波罗蜜

【论】诸波罗蜜义如先说。问曰。五波罗蜜相。即是般若波罗蜜相不。若是般若波罗蜜相。不应五名差别。若异何以故言欲行檀波罗蜜当学般若波罗蜜。答曰。亦同亦异。异者般若波罗蜜名。观诸法实相故。不受不着一切法。檀名舍内外一切所有。以般若波罗蜜心行施。是时檀得名波罗蜜。复次五波罗蜜。殖诸功德。般若波罗蜜。除其着心邪见。如一人种谷一人芸除众秽令得增长果实。成就余四波罗蜜亦如是。问曰。今云何欲行檀波罗蜜。当学般若波罗蜜。答曰。檀有二种。一者净二者不净。不净者憍慢故施。作是念。劣者尚与我岂不能。嫉妒故施。作是念。我之怨憎施故得名。如是胜我。今当广施要必胜彼。贪报故施。作是念。我施少物千万倍报。是故布施。为名故施。作是念。我今好施为人所信。好人数中为摄人故施。作是念。我今施之人必归我。如是等种种杂结行施。是名不净。净施者无是杂事。但以净心信因缘果报。敬愍受者不求今利。但为后世功德。复有净施。不求后世利益。但以修心助求涅槃。复有净施。生大悲心为众生故。不求自利早得涅槃。但为阿耨多罗三藐三菩提是名净施。以般若波罗蜜心故。能如是净施。以是故说欲行檀波罗蜜当学般若波罗蜜。复次般若波罗蜜力故。舍诸法着心。何况我心而不舍。舍吾我心故。身及妻子视如草土。无所恋惜尽以布施。以是故说欲行檀波罗蜜当学般若波罗蜜。余波罗蜜亦皆如是。以般若波罗蜜心助成故。复次诸余波罗蜜。不得般若波罗蜜。不得波罗蜜名字亦不牢固。如后品中说。五波罗蜜。不得般若波罗蜜。无波罗蜜名字。又如转轮圣王。无轮宝者不名转轮圣王。不以余宝为名。亦如群盲无导不能有所至。般若波罗蜜亦如是。导五波罗蜜。令至萨婆若。譬如大军无健将不能成办其事。又如人身余根虽具。若无眼者不能有所至。又如人无命根则余根皆灭。有命根故余根有用。般若波罗蜜亦如是。五波罗蜜。不得般若波罗蜜。则不得增长。得般若波罗蜜故。余波罗蜜得增益具足。以是故佛言欲行檀波罗蜜当学般若波罗蜜

【经】菩萨摩诃萨欲使世世身体与佛相似。欲具足三十二相八十随形好。当学般若波罗蜜【论】问曰。声闻经中说。菩萨过三阿僧祇劫。后百劫中种三十二相因缘。今云何说世世与佛身体相似有三十二相八十随形好。答曰。迦栴延子阿毗昙鞞婆沙中有如是说。非三藏中所说。何以故。三十二相余人亦有何足为贵。如难陀先世时一浴众僧。因作愿言。使我世世端政净洁。又于异世值辟支佛塔。饰以彩画庄严辟支佛像。作愿言。使我世世色相严身。以是因缘故世世得身相庄严。乃至后身出家作沙门。众僧遥见谓其是佛悉皆起迎。难陀小乘种少功德尚得此报。岂况菩萨于无量阿僧祇劫中修立功德。世世形体而不似佛。又如弥勒菩萨。白衣时师名跋婆犁。有三相。一眉间白毛相。二舌覆面相。三阴藏相。如是等非是菩萨亦皆有相。菩萨岂当三阿僧祇劫后乃种相好。复次是摩诃衍中。有菩萨从初发心乃至阿耨多罗三藐三菩提。初不生恶心。世世报得五通身体似佛。问曰。菩萨未得佛道。何得身相如佛。答曰。菩萨为度众生故。或作转轮圣王身。或作帝释身。或作梵王身。或作声闻身辟支佛身。菩萨身佛身。如首楞严经中。文殊师利自说。七十二亿反作一缘觉而般涅槃。又现作佛号龙种尊。时世未应有佛而众生见佛身欢喜心伏受化。问曰。菩萨若能作佛身说法度众生者。与佛有何差别。答曰。菩萨有大神力住十住地。具足佛法而住世间。广度众生故不取涅槃。亦如幻师自变化身。为人说法非真佛身。虽尔度脱众生有量有限。佛所度者无量无限。菩萨虽作佛身。不能遍满十方世界。佛身者普能遍满无量世界。所可度者皆现佛身。亦如十四日月。虽有光明犹不如十五日。有如是差别。或有菩萨得无生法忍法性生身。在七住地住五神通。变身如佛教化众生。或初发意菩萨。行六波罗蜜。行业因缘得身相似佛教化众生。问曰。三十二相布施等果报。般若波罗蜜无所有如虚空。云何说欲得相好当学般若波罗蜜。答曰。三十二相有二种。一者具足如佛。二者不具足如转轮圣王难陀等。般若波罗蜜。与布施和合故。能具足相好如佛。余人但行布施等。相不具足。问曰。云何布施等得三十二相。答曰。如檀越布施时。受者得色力等五事益身故。施者具手足轮相。如檀波罗蜜中广说。戒忍等亦如是。各各具三十二相。何等是三十二相。一者足下安立相。余如赞菩萨品中说。问曰。以何因缘得足下安立相。答曰。佛世世一心坚固持戒。亦不令他败戒以是业因缘故得是初相。初相者自于法中无能动者。若作转轮圣王。自于国土无能侵者。以如法养护人民及出家沙门等。以是业因缘故。得千辐轮相。是转法轮初相。若作转轮圣王。得转轮宝。离杀生业因缘故得长指相。离不与取业因缘故。得足跟满相。以四摄法摄众生业因缘故。得手足缦网相。以上妙衣服饮食卧具。供养尊长业因缘故。得手足柔软相。修福转增业因缘故。得足趺高相一一孔一毛生相毛上向相。如法遣使为福和合因缘。及速疾诲人故。得妙踹相如伊泥延鹿王。如法净物布施。不恼受者故。得平立手过膝相方身相如尼拘卢陀树。多修惭愧及断邪淫。以房舍衣服覆盖之物。用布施故。得阴藏相如马王。修慈三昧信净心多。及以好色饮食衣服卧具布施故。得金色相大光相。常好问义供给所尊及善人故。得肌皮细软相。如法断事不自专执。委以执政故。得上身。如师子相腋下满相肩圆相。恭敬尊长迎逆侍送故。得身体直广相。布施具足充满故。得七处满相。一切舍施无所遗惜故。得方颊车相。离两舌故。得四十齿相齿齐相齿密相。常修行慈好思惟故。得白牙无喻相。离妄语故。得舌广薄相。美食布施不恼受者故。得味中最上味相。离恶口故。得梵声相。善心好眼视众生故。得眼睫绀青相眼睫如牛王相。礼敬所尊及自持戒。以戒教人故。得肉髻相。所应赞叹者而赞叹故。得眉间白毛相。是为用声闻法三十二相业因缘。摩诃衍中三十二相业因缘者。问曰。十方诸佛。及三世诸法皆无相相。今何以故说三十二相。一相尚不实。何况三十二。答曰。佛法有二种。一者世谛二者第一义谛。世谛故说三十二相。第一义谛故说无相。有二种道。一者令众生修福道。二者慧道。福道故说三十二相。慧道故说无相。为生身故说三十二相。为法身故说无相。佛身以三十二相八十随形好。而自庄严法身。以十力四无所畏四无碍智十八不共法诸功德庄严众生。有二种因缘。一者福德因缘。二者智慧因缘。欲引导福德因缘众生故用三十二相身。欲以智慧因缘引导众生故用法身。有二种众生。一者知诸法假名。二者著名字。为著名众生故说无相。为知诸法假名众生故。说三十二相。问曰。是十力四无所畏功德。亦各有别相。云何说法身无相。答曰。一切无漏法十六行三三昧相处故皆名无相。佛欲令众生解故。种种分别说。说一切诸佛法以空无相无作印故皆入如法性实际。而为见色欢喜发道心者现三十二相庄严身

复次为一切众生中显最胜故。现三十二相。而不破无相法。如菩萨初生七日之中。裹以白[疊*毛]示诸相师。相师以古圣相书占之。以答王曰。我谶记法。若人有三十二相者。在家当为转轮圣王。出家当得作佛。唯此二处无有三处。诸相师出已菩萨寝息。复有仙人名阿私陀。白净饭王言。我以天耳闻诸天鬼神说。净饭王生子。有佛身相故来请见。王大欢喜。此人仙圣。故从远来欲见我子。敕诸侍人将太子出。侍人答王。太子小睡。是时阿私陀言。圣王常请一切。施以甘露不应睡也。即从坐起诣太子所。抱着臂上上下相之。相已涕零不能自胜。王大不悦问相师曰。有何不祥涕泣如是。仙人答言。假使天雨金刚大山。不能动其一毛。岂有不祥。太子必当作佛。我今年已晚暮。当生无色天上。不得见佛不闻其法故自悲伤耳。王言。诸相师说不定一事。若在家者当作转轮圣王。若出家者当得作佛。阿私陀言。诸相师者。以世俗比知。非天眼知诸圣相书又不具足遍知。于相总观不能明审。是故或言在家当为转轮圣王。出家当为佛。今太子三十二相。正满明彻甚深净洁具足必当作佛。非转轮王也。以是故知。三十二相。于一切众生中最为殊胜。言无相法者。为破常净乐相我相男女生死等相故如是说。以是故佛法虽无相相。而现三十二相。引导众生。令知佛第一生净信故。说三十二相无咎。问曰。何以故说三十二相不多不少。答曰。若说多若说少俱当有难。复次佛身丈六。若说少相。则不周遍不具庄严。若过三十二相则复杂乱。譬如严身之具。虽复富有珠玑。不可重着璎珞。是故三十二相不多不少正得其中。复次若少不端严。则留八十随形好处过则杂乱。问曰。若须八十随形好。何不皆名为相而别为好。答曰。相大严身。若说大者则已摄小。复次相粗而好细。众生见佛则见其相。好则难见故。又相者余人共得。好者或共或不共。以是故相好别说。问曰。佛毕竟断众生相吾我相。具足空法相。何以故以相庄严。如取相者法。答曰。若佛但以妙法庄严其心身。无相好者。或有可度众生心生轻慢。谓佛身相不具。不能一心乐受佛法。譬如以不净器盛诸美食人所不喜。如臭皮囊盛诸宝物取者不乐。以是故。佛以三十二相庄严其身。复次佛常于大众中作师子吼言。我于众生中。一切功德最为第一。若佛生身不以相好庄严。或有人言。身形丑陋。何所能知。佛以三十二相八十随形好。庄严其身。众生犹有不信。何况不以相好庄严。复次佛法甚深。常寂灭相故。狂愚众生不信不受。谓身灭尽无所一取。以是故。佛以广长舌梵音声身放大光。为种种因缘譬喻说上妙法。众生见佛身相威德。又闻音声皆欢喜信乐。复次庄严物有内外。禅定智慧诸功德等是内庄严。身相威德持戒具足是外庄严。佛内外具足。复次佛愍念一切众生。出兴于世。以智慧等诸功德饶益利根众生。身相庄严饶益钝根众生。心庄严开涅槃门。身庄严开天人乐门。身庄严故置众生于三福处。心庄严故置众生入三解脱门。身庄严故拔众生于三恶道。心庄严故拔众生于三界狱。如是等无量利益因缘故。以相好庄严生身

【经】欲生菩萨家。欲得鸠摩罗伽地。欲得不离诸佛。当学般若波罗蜜

【论】菩萨家者。若于众生中。发甚深大悲心。是为生菩萨家。如生王家无敢轻者。亦不畏饥渴寒热等。入菩萨道中生菩萨家亦如是。以佛子故。诸天龙鬼神诸圣人等。无敢轻者益加恭敬。不畏恶道人天贱处。不畏声闻辟支佛人外道论师来沮其心。复次菩萨初发意一心作愿。从今日不复随诸恶心。但欲度脱一切众生。当得阿耨多罗三藐三菩提。复次菩萨。若能知诸法实相不生不灭。得无生法忍。从是以往常住菩萨道。如前所说持心经中。我见锭光佛时得诸法无生忍。初具足六波罗蜜。自尔之前都无布施持戒等。复次若菩萨作是念。如恒河沙等劫。为一日一夜。用是日夜三十日为月。十二月为岁。如是岁数过百千万亿劫乃有一佛。于是佛所供养持戒集诸功德。如是恒河沙等诸佛。然后受记作佛。菩萨心不懈怠。不没不厌悉皆乐行。复次菩萨于诸邪定五逆众生及断善根人中。而生慈悲令入正道不求恩报。复次菩萨初发心以来。不为诸烦恼所覆所坏。复次菩萨虽观诸法实相。于诸观心亦不生着。复次菩萨自然口常实言。乃至梦中亦不妄语。复次菩萨有所见色皆是佛色。念佛三昧力故于色亦不着。复次菩萨见一切众生流转生死苦中一切乐中心亦不着。但作愿言。我及众生何时当度。复次菩萨于一切珍宝心不生着。唯乐三宝。复次菩萨常断淫欲。乃至不生念想。况有实事。复次众生眼见菩萨者。即得慈三昧。复次菩萨能令一切法悉为佛法。无有声闻辟支佛法凡夫之法种种差别。复次菩萨分别一切法。于一切法中亦不生法相。亦不生非法相。如是等无量因缘。是名生菩萨家。问曰。从发心已来。已生菩萨家。今云何欲生菩萨家当学般若波罗蜜。答曰。有二种菩萨家。有退转家不退转家名字家实家净家杂家有信坚固家不坚固家。为不退转家乃至信坚固家。欲得如是等家故。言欲生菩萨家当学般若波罗蜜。欲得鸠摩罗伽地者。或有菩萨从初发心断淫欲。乃至阿耨多罗三藐三菩提。常行菩萨道。是名鸠摩罗伽地。复次或有菩萨作愿。世世童男出家行道。不受世间爱欲。是名为鸠摩罗伽地。复次又如王子名鸠摩罗伽。佛为法王。菩萨入法正位乃至十地故。悉名王子。皆任为佛。如文殊师利。十力四无所畏等悉具佛事故。住鸠摩罗伽地广度众生。复次又如童子过四岁以上未满二十。名为鸠摩罗伽。若菩萨初生菩萨家者如婴儿。得无生法忍乃至十住地离诸恶事。名为鸠摩罗伽地。欲得如是地。当学般若波罗蜜。常欲不离诸佛者。菩萨世世所生常值诸佛。问曰。菩萨当化众生。何故常欲值佛。答曰。有菩萨未入菩萨位。未得阿鞞跋致受记别故。若远离诸佛。便坏诸善根没在烦恼。自不能度安能度人。如人乘船中流坏败。欲度他人反自没水。又如少汤投大冰池。虽消少处反更成冰。菩萨未入法位。若远离诸佛以少功德无方便力欲化众生。虽少利益反更坠落。以是故新学菩萨。不应远离诸佛。问曰。若尔者何以不说不离声闻辟支佛。声闻辟支佛亦能利益菩萨。答曰。菩萨大心。声闻辟支佛虽有涅槃利益。无一切智故。不能教导菩萨。诸佛一切种智故。能教导菩萨。如象没泥非象不能出。菩萨亦如是。若入非道中唯佛能救同大道故。以是故说菩萨常欲不离诸佛。复次菩萨作是念。我未得佛眼故如盲无异。若不为佛所引导。则无所趣错入余道。设闻佛法异处行者未知教化时节行法多少。复次菩萨。见佛得种种利益。或眼见心清净。若闻所说心则乐法得大智慧。随法修行而得解脱。如是等值佛无量利益。岂不一心求欲见佛。譬如婴儿不应离母。又如行道不离粮食。如大热时不离凉风冷水。如大寒时不欲离火。如度深水不应离船。譬如病人不离良医。菩萨不离诸佛过于上事。何以故。父母亲属知识人天王等。皆不能如佛利益。佛利益诸菩萨离诸苦处。住世尊之地。以是因缘故。菩萨常不离佛。问曰。有为之法欺诳不真皆不可信。云何得如愿不离诸佛。答曰。福德智慧具足故乃应得佛。何况不离诸佛。以众生有无量劫罪因缘故。不得如愿。虽行福德而智慧薄少。虽行智慧而福德薄少。故所愿不成。菩萨求佛道故。要行二忍。生忍法忍。行生忍故。一切众生中发慈悲心。灭无量劫罪。得无量福德。行法忍故。破诸法无明。得无量智慧。二行和合故何愿不得。以是故。菩萨世世常不离诸佛。复次菩萨常爱乐念佛故。舍身受身恒得值佛。譬如众生习欲心重受淫鸟身。所谓孔雀鸳鸯等。习嗔恚偏多生毒虫中。所谓恶龙罗刹蜈蚣毒蛇等。是菩萨心不贵转轮圣王人天福乐但念诸佛。是故随心所重而受身形。复次菩萨常善修念佛三昧因缘故。所生常值诸佛。如般舟三昧中说。菩萨入是三昧。即见阿弥陀佛。便问其佛何业因缘故得生彼国。佛即答言。善男子。以常修念佛三昧忆念不废故得生我国。问曰。何者是念佛三昧得生彼国。答曰。念佛者。念佛三十二相八十随形好金色身。身出光明遍满十方。如融阎浮檀金其色明净。又如须弥山王在大海中。日光照时其色发明。行者是时都无余色想。所谓山地树木等。但见虚空中诸佛身相。如真琉璃中赤金外现。亦如比丘入不净观。但见身体膖胀烂坏。乃至但见骨人。是骨人无有作者亦无来去。以忆想故见。菩萨摩诃萨入念佛三昧。悉见诸佛亦复如是。以摄心故。心清净故。譬如人庄严其身。照净水镜无不悉见。此水镜中亦无形相。以明净故见其身像。诸法从本以来常自清净。菩萨以善修净心。随意悉见诸佛问其所疑。佛答所问。闻佛所说心大欢喜。从三昧起作是念言。佛从何所来。我身亦不去。即时便知诸佛无所从来。我亦无所去。复作是念。三界所有皆心所作。何以故。随心所念悉皆得见。以心见佛以心作佛。心即是佛心即我身。心不自知亦不自见。若取心相悉皆无智。心亦虚诳皆从无明出。因是心相即入诸法实相。所谓常空。得如是三昧智慧已。二行力故随意所愿不离诸佛。如金翅鸟王。二翅具足故于虚空中自在所至。菩萨得是三昧智慧力故。或今身随意供养诸佛。命终亦复值遇诸佛。以是故说菩萨常不离诸佛者当学般若波罗蜜

大智度论卷第二十九大智度论释初品中善根供养义第四十六(卷第三十)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】欲以诸善根供养诸佛恭敬尊重赞叹随意成就者。当学般若波罗蜜。【论】菩萨既得不离诸佛当应供养。若得值佛而无供具甚为不悦。如须摩提菩萨。秦言妙意。见然灯佛无供养具。周旋求索见卖华女。以五百金钱买得五茎青莲华以供养佛。又萨陀波仑菩萨。为供养师故。卖身血肉。如是等菩萨既得见佛。心欲供养若无供具其心有碍。譬如庶民遇见君长。不持礼贶则为不敬。是故诸菩萨求供养具供养诸佛。佛虽不须菩萨心得具足。譬如农夫遇好良田。而无种子虽欲加功。无以肆力心大愁忧。菩萨亦如是。得遇诸佛而无供具。设有余物不称其意心便有碍。诸善根者。所谓善根果报华香璎珞衣服幡盖种种珍宝等。所以者何。或时以因说果。如言一月食千两金。金不可食。因金得食故言食金。或时以果说因。如见好画言是好手。手非是画见画妙故说言手好。善根果报亦如是。以善根业因缘故。得供养之具。名为善根。问曰。若尔者何不即说华香等而说其因。答曰。供养具有二种。一者财供养。二者法供养。若但说华香等供养。则不摄法供养。今说善根供养。当知则财法俱摄。供养者若见若闻诸佛功德。心敬尊重迎逆侍送。旋绕礼拜曲躬合手而住避坐安处。劝进饮食华香珍宝等。种种称赞持戒禅定智慧诸功德。有所说法信受教诲。如是善身口意业是为供养。尊重者。知一切众生中德无过上故言尊。敬畏之心过于父母师长君王利益重故故言重。恭敬者。谦逊畏难故言恭。推其智德故言敬。赞叹者。美其功德为赞。赞之不足又称扬之故言叹。随意成就者。若须华供养如意即至。或求得或不求而得。有自然出者。或变化生乃至伎乐供养之具悉皆如是。问曰。菩萨遇得便以供养。何以随意求索。答曰。福德从心于所爱重。持用供养得福增多。如阿育王小儿时。以所重土持用奉佛。得阎浮提王。一日之中起八万塔。若大人虽以多土投钵而无所得非所重故。有人偏贵重华。以其所贵持供养佛得福增多。乃至宝物亦如是。复次随时所宜。若寒时应以薪火上衣温室被褥及以饮食。热时应以冰水扇盖凉室。生薄之服上妙之食。风雨之时就送供具。如是等随时供养。又随土地所宜。随受者所须。皆持供养。复次随意供养者。有菩萨知佛无所须。又知诸物虚诳如幻一相所谓无相。为教化众生故。随众生国土所重引导故供养。复有菩萨得甚深禅定。生菩萨神通。以神通力故。飞到十方佛前。或于佛国若须遍雨天华。即满三千世界持供养佛。或雨天栴檀。或雨真珠光明鲜发。或雨七宝。或雨如意珠大如须弥。或雨妓乐音声清妙。或以身如须弥。以为灯炷供养诸佛。如是等名为财供养。又菩萨行六波罗蜜。以法供养诸佛。或有菩萨。行一地法供养诸佛。乃至十地行法供养。或时菩萨得无生法忍。自除烦恼及众生烦恼。是法供养。或时菩萨住于十地。以神力故令地狱火灭。于饿鬼道皆得饱满。令畜生得离恐怖。令生人天渐住阿惟越致地。如是等大功德力故。名为法供养以是故说欲得善根成就当学般若波罗蜜

【经】欲满一切众生所愿衣服饮食卧具涂香车乘房舍床榻灯烛等。当学般若波罗蜜

【论】问曰。有何次第。欲满一切众生愿。答曰。菩萨业有二种。一为供养诸佛。二为度脱众生。以供养诸佛。得无量福德。持是福德利益众生。所谓满众生愿。如贾客主入海采宝安隐得出利益所亲及知识等。菩萨如是入诸佛法海。得无量功德之宝利益众生。如小王供养大王能令欢喜。与其所愿职位财帛。还其本国利益人物除却怨贼。菩萨供养诸佛法王故得受记别。以无量善根珍宝得无尽智力。来入众生善人供养贫者。随其所须而给与之。魔民邪见外道之属悉皆破坏。是为供养诸佛。次满众生所愿。问曰。菩萨实能满一切众生愿不。若悉满众生愿。余佛菩萨何所利益。若不悉满是中。何故说欲满一切众生愿当学般若波罗蜜。答曰。有二种愿。一者可得愿。二者不可得愿。不可得愿者。有人欲筹量虚空尽其边际。及求时方边际。如小儿求水中月镜中像。如是等愿皆不可得。可得愿者。钻木求火穿地得水。修福得人天中生。及得阿罗汉辟支佛果。乃至得诸佛法王。如是等名皆可得愿。可得愿有二种。一谓世间二谓出世间。是中世间愿故。满众生愿。云何得知。以饮食床卧具乃至灯烛所须之物皆给与之。问曰。菩萨何以故与众生易得愿。不与难者。答曰。愿有下中上。下愿令致今世乐因缘。中愿与后世乐因缘。上愿与涅槃因缘。是故先与下愿。次及中愿然后上愿。复次众生多着今乐少求后乐。涅槃乐者转复少也。若说多者少亦摄之。复次此经前后。多说后世涅槃道。少说今世利事。菩萨法者。常与众生种种利益不应有舍。所以者何。初心但欲令诸众生行大乘法。以不堪受化。次与声闻辟支佛道。若复不能当与十善四梵行等令修福德。若众生都不乐者。如是众生不应遗舍。当与今世利益。所谓饮食等也。复次凡夫虽能与人饮食等。满彼愿者皆有因缘。若今世事若后世事。声闻辟支佛。虽无因缘满众生愿而所益甚少。菩萨摩诃萨。行檀波罗蜜业因缘故。得为国王或为大长者财富无量。四方众生若来求者尽满足之。如频头居士为大檀越。坐七宝大床金刚为脚敷以天褥。以赤真珠上为帐幔。左右立侍各八万四千。皆庄严琦妙开四大门。恣所求者昼夜六时鸣鼓又放光明。十方无量众生。有闻鼓声光明触身者无不悉来。欲得种种饮食者。长者见其大集。即时默然仰视虚空。于时空中雨种种百味之食随意皆得。若众生不自取者。左右给使分布与之。足满乃止。须饮食衣被卧具宝物等。皆亦如是。恣众生所欲已然后说法。令离四食皆住阿鞞跋致地。如是等菩萨神通力故。能满众生愿。问曰。佛在时众生尚有饥饿。天不降雨众生困弊。佛犹不能满一切众生之愿。云何菩萨能满其愿。答曰。菩萨住于十地。入首楞严三昧。于三千大千世界。或时现初发意行六波罗蜜。或现阿鞞跋致。或现一生补处。于兜率天上为诸天说法。或从兜率天上来下。生净饭王宫。或现出家成佛。或现大众中转法轮度无量众生。或现入涅槃起七宝塔。遍诸国土令众生供养舍利。或时法都灭尽。菩萨利益如是。何况于佛。而佛身有二种。一者真身二者化身。众生见佛真身。无愿不满。佛真身者。遍于虚空光明遍昭十方。说法音声亦遍十方无量恒河沙等世界。满中大众皆共听法说法不息。一时之顷各随所闻而得解悟。如劫尽已。众生行业因缘故。大雨澍下间无断绝。三大所不能制。惟有劫尽十方风起。更互相对能持此水。如是法性身佛有所说法。除十住菩萨。三乘之人皆不能持。惟有十住菩萨不可思议方便智力悉能听受。众生其有见法身佛。无有三毒及众烦恼寒热诸苦。一切皆灭无愿不满。如如意珠尚令众生随愿皆得。岂况于佛。珠与一切世间之愿。佛与一切出世间愿。若言佛不能悉满众生所愿。是语不然。复次释迦文尼佛王宫受身现受人法。有寒热饥渴睡眠。受诸诽谤老病死等。内心智慧神德。真佛正觉无有异也。欲满众生所愿悉皆能满。而不满者以无数世来常满众生衣食之愿而不免苦。今但以涅槃无为常乐益之。如人怜愍所亲。不与杂毒美食。如是世间愿者生诸结使。又复离时心生大苦。是故不以为要。复次有人言。释迦牟尼佛。已满众生所愿。而众生自不能得。如毗摩罗诘经说。佛以足指案地。即时国土七宝庄严。我佛国如是。为多怒害者现佛国异。又如龙王等心降雨。在人为水。饿鬼身上皆为炭火。问曰。若能满一切众生愿者。则众生有边无有受诸饥寒苦者。何以故。一切众生皆满所愿。愿离苦得乐故。答曰。满一切者名字一切。非实一切。如法句偈说

  一切皆惧死　　莫不畏杖痛
  恕己可为譬　　勿杀勿行杖

虽言一切畏杖痛。如无色众生。无身故则无杖痛。色界众生。虽可有身亦无杖痛。欲界众生亦有不受杖痛。而言一切。谓应得杖者说言一切。非实一切。以是故菩萨满一切众生所愿。谓应可得者。然菩萨心无齐限。福德果报亦无有量。但众生无量阿僧祇劫罪厚障故而不能得。如舍利弗弟子罗频周比丘。持戒精进乞食。六日而不能得。乃至七日命在不久。有同道者乞食持与。鸟即持去。时舍利弗语目揵连。汝大神力守护此食令彼得之。即时目连持食往与。始欲向口变成为泥。又舍利弗乞食持与而口自合。最后佛来持食与之。以佛福德无量因缘故令彼得食。是比丘食已。心生欢喜倍加信敬。佛告比丘。有为之法皆是苦相为说四谛。即时比丘漏尽意解。得阿罗汉道。有薄福众生罪甚此者佛不能救。又知众生不可得故。深达法性故。诸佛无有忆想分别。是可度是不可度。心常寂灭意无增减。以是故。菩萨欲满一切众生愿。彼以罪故而不能得。菩萨无咎。饮食者略说粗细二种。饼饭等百味之食。经虽说四食众生久住。而此但说揣食。余者无色不可相与。若施揣食则与三食。何以故因揣食故增益三食。如经所说。檀越施食则与受者五事利益。饮总说二种。一者草木酒。所谓蒲桃甘蔗等及诸谷酒。二者草木浆。甘蔗浆蒲桃浆石蜜浆安石榴浆梨奈浆波卢沙果浆等及诸谷浆。如是和合人中饮食及天饮食。所谓修陀甘露味天果食等。摩头摩陀婆浆等。众生各各所食。或食谷者或食肉者或食净者不净者来皆饱满。衣服者。衣有二种。或从众生生。所谓绵绢毛毳皮韦等。或从草木生。所谓布[疊*毛]树皮等。有诸天衣无有经纬。自然树出光色轻软。卧具者。床榻被褥帏帐枕等。涂香者。有二种。一者栴檀木等摩以涂身。二者种种杂香捣以为末以涂其身。及熏衣服并涂地壁。乘者。所谓象马车舆等。房舍者。所谓土木宝物所成楼阁殿堂宫观等。以障寒热风雨贼盗之属。灯烛者。所谓脂膏苏油漆蜡明珠等。诸物者。是一切众生所须之物。不可具说故略言诸物。问曰。此中何以不说烧香妙华等。答曰。说诸物者皆已摄之。问曰。若尔者但应略说三种。饮食衣服庄严之具。答曰。此诸物是所须要者。若慈念众生以饮食为先。次以衣服以身垢臭须以涂香。次以卧具寒雨须房舍。黑闇须灯烛。问曰。华香亦能除臭。何故不说。答曰。华非常有亦速萎烂。利益少故是故不说。烧香者。寒则所须。热时为患。涂香寒热通用。寒时杂以沉水。热时杂以栴檀以涂其身。是故但说涂香。问曰。若行檀波罗蜜。得无量果报。能满一切众生所愿。何故言欲满众生愿当学般若波罗蜜。答曰。先已说以般若波罗蜜和合故。得名檀波罗蜜。今当更说。所可满众生愿者。非谓一国土一阎浮提。都欲满十方世界六趣众生所愿。非但布施所能办故。以般若波罗蜜。破近远相。破一切众生相非一切众生相。除诸碍故弹指之顷化无量身。遍至十方能满一切众生所愿。如是神通利益要从般若出生。以是故。菩萨欲满一切众生愿。当学般若波罗蜜

【经】复次舍利弗。菩萨摩诃萨欲使如恒河沙等世界众生。立于檀波罗蜜。立于尸罗羼提毗梨耶禅般若波罗蜜。当学般若波罗蜜

【论】问曰。是义次第有何因缘。答曰。利有三种。今世利后世利毕竟利。复有三种乐。今世后世出世乐。前说今世利乐。此说后世出世利乐。以是故。令众生住六波罗蜜。菩萨愍念众生。过于父母念子。慈悲之心彻于骨髓。先以饮食充足其身除饥渴苦。次以衣服庄严其身。令得受乐。菩萨心不满足。复作是念众生已得今世乐。复更思惟令得后世乐。若以世间六波罗蜜教之。则得人天中乐。久后还来轮转生死。当复以出世间六波罗蜜。令得无为常乐。复次先以衣服华香等庄严其身。今以功德庄严其心。若有三种庄严则为具足无有过者。一者衣服七宝等。二者福德。三者道法。菩萨欲具足三种庄严众生故。先说功德果报。今说功德因缘。复次前说虽有大施而众生罪故不能悉得。如饿鬼经说。虽与其食而不得啖。变成炭火不净之物。又菩萨不舍一切。当作方便令众生得衣食利益。是故教修福业自行自得。菩萨善知因缘。不可强得教令得之。以是故次第教众生住六波罗蜜。问曰。菩萨志愿。令十方一切众生住六波罗蜜。何故但说如恒河沙世界众生。答曰。为听法者闻恒河沙故。又于新发意菩萨。以无边无量为多多则致乱。若大菩萨。不以恒河沙为数。复次说如恒河沙者。是无边无量数。如后品中说。复次如恒河沙者。已说十方诸世界。此中亦不言一恒河沙。不应为难。以是故。说如恒河沙世界无咎。恒河沙世界义如先说。众生者。于五众十八界十二入六种十二因缘等众多法中。假名众生。是天是人是牛是马。众生有二种。动者静者。动者生身口业。静者不能。有色众生无色众生。无足二足四足多足众生。世间出世间众生。大者小者贤圣凡夫。邪定正定不定众生苦乐不苦不乐众生。上中下众生。学无学非学非无学众生。有想无想非有想非无想众生。欲界色界无色界众生。欲界众生者有三种。以善根有上中下故。上者六欲天。中者人中富贵。下者人中卑贱。以面类不同故。四天下别异。不善亦有三品。上者地狱。中者畜生。下者饿鬼。复次欲界众生有十种。三恶道人及六天。地狱有三种。热地狱寒地狱黑闇地狱。畜生有三种。空行陆行水行昼行夜行昼夜行。如是等差别。鬼有二种。弊鬼饿鬼。弊鬼如天受乐。但与饿鬼同住即为其主。饿鬼腹如山谷咽如针身。惟有三事黑皮筋骨。无数百岁不闻饮食之名何况得见。复有鬼火从口出飞蛾投火以为饮食。有食粪涕唾脓血洗器遗余。或得祭祀或食产生不净。如是等种种饿鬼。六欲天者。四王天等。于六天中间别复有天。所谓持璎珞天戏忘天心恚天鸟足天乐见天。此诸天等皆六天所摄。有人言欲界众生。应有十一种。先说五道今益阿修罗道。问曰。阿修罗即为五道所摄。是阿修罗非天非人。地狱苦多畜生形异。如是应鬼道所摄。答曰。不然。阿修罗力与三十三天等。何以故。或为诸天所破。或时能破诸天。如经中说。释提桓因为阿修罗所破。四种兵众入藕根孔以自藏翳。受五欲乐与天相似。为佛弟子。如是威力。何得饿鬼所摄。以是故应有六道。复次如阿修罗甄陀罗干沓婆鸠槃茶夜叉罗刹浮陀等大神。是天阿修罗。民众受乐小减诸天。威德变化随意所作。是故人疑言。是修罗非修罗。修罗秦言大也。说者言。是阿修罗非修罗。阿修罗道初得名。余者皆同一道。问曰。经说有五道。云何言六道。答曰。佛去久经流远。法传五百年后。多有别异部部不同。或言五道或言六道。若说五者。于佛经回文说五。若说六者。于佛经回文说六。又摩诃衍中法华经说有六趣众生。观诸义旨应有六道。复次分别善恶故有六道。善有上中下故。有三善道。天人阿修罗。恶有上中下故。地狱畜生饿鬼道。若不尔者恶有三果报。而善有二果。是事相违。若有六道于义无违。问曰。善法亦有三果。下者为人中者为天上者涅槃。答曰。是中不应说涅槃。但应分别众生果报住处。涅槃非报故。善法有二种。一者三十七品能至涅槃。二者能生后世乐。今但说受身善法。不说至涅槃善法。世间善有三品。上分因缘故天道果报。中分因缘故人道果报。下分因缘故阿修罗道果报。问曰。汝自说阿修罗。与天等力受乐与天不异。云何今说善下分。为阿修罗果报。答曰。人中可得出家受戒以至于道。阿修罗道。结使覆心得道甚难。诸天虽随结使心直信道。阿修罗众心多邪曲不时近道。以是故阿修罗。虽与天相似。以其近道难故故在人下。如龙王金翅鸟。力势虽大亦能变化故。在畜生道中。阿修罗道亦如是。问曰。若龙王金翅鸟。力势虽大犹为畜生道摄。阿修罗亦应饿鬼道摄。何以更作六道。答曰。是龙王金翅鸟虽复受乐。傍行形同畜生故畜生道摄。地狱饿鬼形虽似人。以其大苦故不入人道。阿修罗力势既大。形似人天故。别立六道是为略说。欲界众生色无色界众生。如后品中说。立檀波罗蜜者。菩萨语诸众生。当行布施。贫为大苦无以贫故。作诸恶行堕三恶道。作诸恶行堕三恶道则不可救。众生闻已舍悭贪心行檀波罗蜜。如后品中广说。复次菩萨于众生前。种种因缘种种譬喻。而为说法毁呰悭贪。夫悭贪者自身所须惜不能用。见告求者心浊色变。即于现身声色丑恶。种后世恶业故受形丑陋。先不种布施因缘故今身贫贱。悭着财物多求不息。开诸罪门专造恶事故堕恶道中。复次生死轮转利益之业无过布施。今世后世随意。便身之事悉从施得。施为善导能开三乐。天上人中涅槃之乐。所以者何。好施之人声誉流布。八方信乐无不爱敬。处大众中无所畏难死时无悔。其人自念我以财物殖良福田。人天中乐涅槃之门我必得之。所以者何。施破悭结慈念受者。灭除嗔恼嫉妒心息。恭敬受者则除憍慢。决定心施疑网自裂。知施果报则除邪见及灭无明。如是等诸烦恼破则涅槃门开。复次非但开三乐而已。乃能开无量佛道世尊之处。所以者何六波罗蜜。是佛道檀为初门。余行皆悉随从。如是等布施有无量功德。以是因缘故。令众生立檀波罗蜜。檀波罗蜜义如先檀中说。立尸罗者。菩萨于众生前赞说戒行。汝诸众生当学持戒。持戒之德拔三恶趣及人中下贱。令得天人尊贵乃至佛道。戒为一切众生众乐根本。譬如大藏出诸珍宝。戒为大护能灭众怖。譬如大军破贼。戒为庄严如着璎珞。戒为大船能度生死巨海。戒为大乘能致重宝至涅槃城。戒为良药能破结病。戒为善知识。世世随逐不相远离令心安隐。譬如穿井已见湿泥。喜庆自欢无复忧患。戒能成就利益诸行。譬如父母长育众子。戒为智梯能入无漏。戒能惊怖诸结。譬如师子能令群兽摄伏。戒为一切诸德之根出家之要。修净戒者所愿随意。譬如如意珠应念时得。如是等种种赞戒之德。令众生欢喜发心住尸罗波罗蜜。住羼提者。于众生前赞叹忍辱。忍为一切出家之力。能伏诸恶能于众中现奇特事。忍能守护令施戒不毁。忍为大铠众兵不加。忍为良药能除恶毒。忍为善胜。于生死险道安隐无患。忍为大藏。施贫苦人无极大宝。忍为大舟。能渡生死此岸到涅槃彼岸。忍为磫[石*瞿]能莹明诸德。若人加恶如猪揩金山。益发其明。求佛道度众生之利器。忍为最妙。行者当作是念。我若以嗔报彼则为自害。又我先世自有是罪不得如意要必当偿。若于此人不受余亦害我俱不得免云何起嗔

复次众生为烦恼所牵。起诸恶事不得自在。譬如人为非人所持而骂辱良医。良医是时但为除鬼不嫌其骂。行者亦如是。众生加恶向己。不嫌其嗔但为除结。复次行忍之人。视前骂辱者。如父母视婴孩。见其嗔骂益加慈念爱之踰深。又复自念彼人加恶于我。是业因缘前世自造今当受之若以嗔报更造后苦何时解已。若今忍之永得离苦。是故不应起嗔。如是种种因缘。诃嗔恚生慈悲入众生忍中。入众生忍中已作是念。十方诸佛所说法。皆无有我亦无我所。但诸法和合假名众生。如机关木人。虽能动作内无有主身亦如是。但皮骨相持随心风转。念念生灭无常空寂无有作者。无骂者亦无受者。本末毕竟空故。但颠倒虚诳故。凡夫心着。如是思惟已则无众生。无众生已法无所属。但因缘和合无有自性。如众生和合强名众生。法亦如是即得法忍。得是众生忍法忍故。能得阿耨多罗三藐三菩提。何况诸余利益。众生闻是已住羼提波罗蜜。立毗梨耶者。教众生言汝莫懈怠。若能精进诸善功德悉皆易得。若懈怠者见木有火而不能得何况余事。是故劝令精进。若人随方便精进无愿不得。凡得胜法非无因缘。皆从精进生。精进有二相。一能进生诸善法。二能除诸恶法。复有三相。一欲造事。二精进作。三不休息。复有四相。已生恶法断之令灭。未生恶法能令不生。未生善法能令发生。已生善法能令增长。如是等名精进相。精进故能助成一切善法。譬如火得风助其然乃炽。又如世间勇健之人能越山渡海。道法精进乃至能得佛道何况余事。众生闻已皆立精进波罗蜜。复次菩萨见有未发阿耨多罗三藐三菩提者。为赞叹阿耨多罗三藐三菩提法。于一切诸法中。最为第一极为尊贵。能饶益一切令得诸法实相不诳之法有大慈悲。具一切智金色身相第一微妙三十二相八十随形好无量光明无量戒定智慧解脱解脱知见三达无碍。于一切法无碍解脱。得如是者一切众生中最为上尊。应受一切世间供养。若人但心念佛。尚得无量无尽福德。何况精进布施持戒供养承事礼拜者。语众生言佛事如是。汝等当发无上道心。勤修精进行如法者得之不难。众生闻是已。便发无上道心。若发心者不可但空尔。而得当行檀波罗蜜。行檀波罗蜜。次行尸罗波罗蜜羼提波罗蜜禅波罗蜜般若波罗蜜。行五波罗蜜。则是毗梨耶波罗蜜。若不发大乘心者。当教辟支佛道。若无辟支佛道者。教行声闻道。若无声闻道者。教令离色受无色定寂灭安乐。若无无色定者。教令离欲受色界种种禅定乐。若无禅者。教令修十善道人天中受种种乐。莫自懈怠空无所得。贫穷下贱种种勤苦甚为可患。懈怠法者最为弊恶。破坏今世后世利益善道。众生闻已集诸善法勤行精进。立禅者。菩萨于众生前。赞叹禅定清净乐内乐自在乐离罪乐今世后世乐圣所受乐梵天王乐遍身受乐深厚妙乐。汝诸众生何以着五欲不净乐。与畜生同受诸罪垢乐而舍是妙乐。若汝能舍小乐则得大乐。汝不见田夫弃少种子后获大果。如人献王少物而得大报。如少钩饵而得大鱼。所舍甚少而所获大多。智者亦如是。能弃世间之乐。得甚深禅定快乐。既得此乐反观欲乐甚为不净。如从狱出如病疹得差更不求药复次禅定名实智初门。令智慧澄静能照诸法。如灯在密室其明得用。若依禅定得四无量背舍胜处神通辩才等诸甚深功德悉皆具得。能令瓦石变成如意宝珠何况余事。随意所为无不能作。入地如水履水如地。手捉日月身不焦冷。化为种种禽兽之身。而不受其法。或时变身充满虚空。或时身若微尘。或轻如鸿毛。或重若太山。或时以足指按地。天地大动如动草叶。如是等神通变化力皆从禅得。众生闻是已。立于禅波罗蜜。立般若波罗蜜者。菩萨教诸众生当学智慧。智慧者其明第一名为慧眼。若无慧眼虽有肉眼犹故是盲。虽云有眼与畜生无异。若有智慧自别好丑不随他教。若无智慧随人东西。如牛骆驼穿鼻随人。一切有为法中智慧为上。圣所亲爱能破有为法故。如经中说。于诸宝中智慧宝为最。一切利器中慧刀利为最。住智慧山顶无有忧患。观诸苦恼众生无不悉见。智慧刀能断无始烦恼生死连锁。智慧力故能具六波罗蜜。得不可思议无量佛道成一切智。何况声闻辟支佛及世间胜事。是智慧增长清净不可沮坏。名为波罗蜜。众生闻已住般若波罗蜜。复次菩萨或时不以口教。或现神足光明。令众生住六波罗蜜。或现种种余缘。乃至梦中为作因缘使其觉悟。令众生住六波罗蜜。是故经言欲令众生住六波罗蜜。当学般若波罗蜜

【经】欲殖一善根于佛福田中。至得阿耨多罗三藐三菩提不尽者。当学般若波罗蜜

【论】善根者三善根。无贪善根无嗔善根无痴善根。一切诸善法。皆从三善根生。增长如药树草木因有根故得生成增长。以是故名为诸善根。今言善根者。善根因缘供养之具。所谓花香灯明。及法供养持戒诵经等。因中说果。何以故香华不定。以善心供养故名为善根布施非即是福。但能破悭贪开善法门善根名为福。如针导綖缝衣缝非针也。一者若华若香若灯明若礼敬。若诵经持戒。若禅定若智慧等。一一供养及法供养。殖于诸佛田中。佛田者。十方三世诸佛。若佛在世若形像若舍利若但念佛。殖者专心坚着。问曰。经言种种福田。今何以独言殖于佛田。答曰。虽有种种福田佛为第一福田。以十力四无所畏十八不共法。如是等无量佛法具足。是故独说殖于佛田。法宝虽为佛师。若佛不说法为无用。如虽有好药若无良医药则无用。以是故法宝虽上。而前说佛宝何况僧宝。复次佛田能获无量果报。余者虽言无量而有差降。以是故佛田第一。不尽者诸佛成就无量功德故。于中殖福福亦无尽。复次佛功德无量无边无数无等故。殖福者福亦不尽。复次佛为菩萨时。缘一切众生。如众生无量无边故福亦无尽。复次佛田清净。拔爱等诸烦恼秽草。净戒为平地。大慈悲为良美。除诸恶邪碱土。三十七品为沟港。十力四无所畏四无碍智等为垣墙。能出生三乘涅槃果报。殖种于此无上无比田者其福无尽。问曰。一切有为法无常相故皆归于尽。福从因缘生何得不尽。答曰。亦不言常不尽。自言乃至得佛中间不尽。复次一切有为法。虽念念生灭。相续不断果报不失故名为不尽。如灯虽焰焰生灭不名灭。脂尽炷灭乃可称灭。福亦如是深心种于良田故。乃至法尽而亦不尽。复次菩萨知诸法实相。如涅槃不尽。福德入诸法实相故而亦不尽。问曰。若尔者涅槃不尽。福德亦应常不尽。云何言乃至佛中间不尽。答曰。是福德者。以智慧力故。令是功德如涅槃。毕竟空不生不灭。以是故喻如涅槃非即涅槃。若是涅槃不应为喻。若是涅槃云何果报成佛而不尽。譬如三解脱门。空无相无作。如解脱毕竟空相是空解脱门。观世间亦毕竟空。如解脱无相相。是无相解脱门。观世间亦无相相。如解脱无作相。是无作解脱门。观世间亦无作相。以是故说欲殖一善根。于佛福田乃至阿耨多罗三藐三菩提而不尽者当学般若波罗蜜

    大智度论初品中诸佛称赞其命释论第四十七

【经】复次舍利弗。菩萨摩诃萨欲令十方诸佛称赞其名。当学般若波罗蜜

【论】问曰。菩萨若观诸法毕竟空。内无吾我已破憍慢。云何欲令诸佛称赞其名。又菩萨法应供养诸佛。云何反求诸佛供养。答曰。佛法有二门。一为第一义门。二为世俗法门。以世俗门故。欲令诸佛赞叹。虽为诸佛所赞叹。而不见我不取众生相。世间假名故说。汝言云何反求佛供养者。如后品中。佛所赞叹菩萨。毕竟阿鞞跋致阿耨多罗三藐三菩提。今是菩萨欲得决定知是阿鞞跋致以不。以是故求佛赞叹。非求供养。复次余人余众生。贪欲嗔恚愚痴覆心故。不能如实赞叹。何以故。若偏有所爱。不见实过但见功德。若偏有所嗔。但见其过不见其德。若愚痴多不能如实见其好丑。诸天世人虽有智慧三毒薄者。亦不能得如实赞犹有谬失。无一切智故。结使不尽故。声闻辟支佛。三毒虽尽亦不能如实赞。犹有余气未尽。又智慧不具足故。唯佛一人三毒及气永尽。成就一切智故。能如实赞不增不减。以是故行者欲得诸佛所赞。知其实德。不求余人称赞。问曰。若诸佛出于三界不着世间。无有我及我所。视于外道恶人大菩萨阿罗汉一等无异。云何赞叹菩萨。答曰。佛虽无吾我无有憎爱于一切法心无所著。怜愍众生以大慈悲心引导一切故。分别善人而有所赞。亦欲破坏恶魔。所愿以佛赞叹故。无量众生爱乐菩萨恭敬供养。后皆成就佛道。以是故诸佛赞叹菩萨。问曰。云何赞叹。答曰。如佛于大众中说法。欲令众生入甚深法赞是菩萨。如萨陀波仑等。复次佛赞叹菩萨言。是菩萨能观诸法毕竟空。亦能于众生有大慈悲能行生忍。亦不见众生。虽行法忍于一切法而不生着。虽观宿命事不堕始见。虽观众生入无余涅槃而不堕边见。虽知涅槃是无上实法。亦能起身口意善业。虽行生死中。而深心爱乐涅槃。虽住三解脱门观于涅槃。亦不断本愿及善行。如是等种种奇特功德甚为难有。复次若菩萨未得无生忍。未得五神通。生死肉身有大慈悲心。能为众生故。内外所有所贵惜者悉能施与。外谓所著妻子上妙五欲。如意珠最上宝安乐国土等。内谓身体肌肉皮肤骨血头目髓脑耳鼻手足。如是等施甚为难有。是故诸佛赞叹其德。若菩萨入法位。得神通行苦行不足为难。以是菩萨生身肉眼志愿弘旷。有大悲心爱乐佛道。行如是事甚为希有。复次若菩萨持戒清净具足无所分别。持戒破戒于一切诸法。毕竟不生常空法忍精进不休不息不着不厌精进懈怠一相不异。无量无边无数劫勤修精进。都欲受行甚深禅定无所依止。定乱不异不起于定而能变。身无量遍至十方说法度人。行深智慧观一切法不生不灭非不生非不灭亦非不生亦非不灭非非不生非非不灭。过诸语言心行处灭。不可坏不可破不可受不可着。诸圣行处净如涅槃。亦不着是观意亦不没。能以智慧而自饶益。如是菩萨诸佛赞叹。复次菩萨未得受记。未得无生法忍。生不值佛不见贤圣。以正思惟故。能观诸法实相。虽观实相心亦不着。如是菩萨十方诸佛皆共赞叹。复次菩萨闻甚深无量无边不可思议佛法。虽自未得智慧未及。而能定心信乐不生疑悔。若魔作佛来诡说其意。意无增减。如是菩萨诸佛所赞。复次有诸菩萨。一时发心中有疾成佛者佛则赞叹。有大精进力故。如释迦文尼佛与弥勒等诸菩萨同时发心。释迦文尼佛精进力故超越九劫。复次若有菩萨。具足菩萨事。所谓十地六波罗蜜十力四无所畏四无碍智十八不共法等无量清净佛法。为众生故久住生死。不取阿耨多罗三藐三菩提。而广度众生。如是菩萨诸佛赞叹。何者是如文殊师利毗摩罗诘观世音大势至遍吉等。诸菩萨之上首出于三界。变化无央数身。入于生死教化众生故。如是希有事。皆从甚深般若波罗蜜生。以是故说欲得诸佛称叹其名当学般若波罗蜜

【经】复次舍利弗。菩萨摩诃萨欲一发意至十方如恒河沙等世界。当学般若波罗蜜

【论】菩萨得身通变化力。作十方恒河沙等身。于十方恒河沙等世界一时能到。问曰。如经说。一弹指顷有六十念。若一念中能至一方恒河沙等世界尚不可信何况十方恒河沙等世界时少而所到处多。答曰。经说五事不可思议。所谓众生多少业果报坐禅人力诸龙力诸佛力。于五不可思议中。佛力最不可思议。菩萨入深禅定。生不可思议神通故。一念中悉到十方诸佛世界。如说四种神通中。唯佛菩萨有如意疾遍神通。若金翅鸟子始从[穀-禾+卵]出。从一须弥至一须弥。诸菩萨亦如是。以无生忍力故。破诸烦恼无明[穀-禾+卵]。即时一念中作无量身遍至十方。复次菩萨一切无量世罪悉已消灭。以智慧力故。能转一切诸法。所谓小能作大大能作小。能以千万无量劫为一日。又能以一日为千万劫。是菩萨世间之主所欲自在何愿不满。如毗摩罗诘经所说。以七夜为劫寿。以是因缘故。菩萨乘神通力。能速疾超越十方世界。问曰。前五不可思议中无有菩萨。今何以说菩萨不可思议。答曰。或时因中说果。如日食百斤金。金不可食因金得食故言食金。是为因中说果。或时果中说因。如见好画言是好手。是为果中说因。诸菩萨亦如是。菩萨为因诸佛为果。若说佛力不可思议。当知已说菩萨。以是故。言欲一发意到十方恒河沙世界者当学般若波罗蜜

【经】复次舍利弗。菩萨摩诃萨欲发一音使十方如恒河沙等世界闻声。当学般若波罗蜜【论】菩萨得六神通。增长梵声相。过三千大千世界。至十方恒河沙等诸世界。问曰。若尔者与佛音声何异。答曰。菩萨音声有恒河沙等之数。佛音声所到无有限数。如密迹经中所说。目连试佛音声极至西方。犹闻佛音若如对面。问曰。若尔者佛常在国土聚落说法教化。而阎浮提内人不至佛边则不得闻。何以知之。多有从远方来欲听法者故。答曰。佛音声有二种。一为密中音声二为不密音声。密音声先已说。不密音声至佛边乃闻。是亦有二种弟子。一为出世圣人。二为世间凡夫。出世圣人如目揵连等。能闻微密音声。凡夫人随其所近乃闻。复次诸菩萨得入正位离生死身得法性真形。能见十方无量佛身及遍昭光明。亦能得闻诸佛六十种极远无量音声。诸大菩萨虽未具足如佛音声。于佛音声中普得其分。是佛菩萨音声有三种。一者先世种善音声因缘故。咽喉中得微妙四大。能出种种妙好远近音声。所谓一里二里三里十里百里千里乃至三千大千世界音声遍满。二者神通力故。咽喉四大出声。遍满三千大千世界及十方恒河沙世界。三者佛音声常能遍满十方虚空。问曰。若佛音声常能遍满。今众生何以不得常闻。答曰。众生无量劫以来。所作恶业覆。是故不闻。譬如雷电霹雳。聋者不闻雷声无减。佛亦如是。常为众生说法。如龙震大雷声。众生罪故自不得闻。如今世人精进持戒者。于念佛三昧。心得定时罪垢不障。即得见佛闻佛说法音声清了。菩萨于三种音声中。欲得二种。是二种音声甚难希有故。如业果音声自然可得故。以是故。说菩萨摩诃萨欲以一音使十方恒河沙等世界闻声者当学般若波罗蜜

【经】复次舍利弗。菩萨摩诃萨欲使诸佛世界不断者。当学般若波罗蜜

【论】佛世界不断者。菩萨欲令国国相次皆使众生发心作佛问曰。言次第者。为一国前后相次。为十方世界次第。若一国相次者。大悲普覆一切众生。何以不及余国。若十方一切世界次第者。余佛菩萨何所利益。答曰。菩萨心愿欲令一切世界皆悉作佛。大心旷远无有齐限。以是心集诸智慧无量福德神通力故。又随众生种作佛因缘者。是菩萨皆悉令作。若一切世界皆种作佛因缘者。余佛菩萨不应有益。但是事不然。复次十方世界无量无边。不应一菩萨尽得遍诸世界令佛种不断。诸余菩萨各随因缘皆有其分。以慈悲大故愿亦无量。利益之心无有齐限。众生种无量故。非一佛一菩萨所可尽度。问曰。若事不称心。何故作愿耶。答曰。欲令心愿旷大清净故。如行慈三昧。虽不能令众生离苦。但自欲令心旷大清净。成利益愿故。如诸佛大菩萨力。皆能度一切众生。而众生福缘未集。未有智慧因缘不会故而不得度。如大海水一切众生取用水不穷竭。但众生不能得用。如饿鬼众生。自罪因缘不得见水。设得见之即时干竭。或为洋铜或成脓血。佛亦如是有大慈悲智慧无量无边悉能满足众生。而众生罪业因缘故而不值佛。设得值佛如余人无异。或生嗔恚或起诽谤。以是因缘故。不见佛威相神力。虽得值佛而无利益。复次二因二缘发于正见。所谓内因外缘。佛外因缘具足。有三十二相八十随形好无量光明庄严其身。种种神力种种音声。随意说法断一切疑。但众生内因缘不具足。先不种见佛善根。而不信敬不精进持戒。钝根深厚着于世乐。以是故无有利益。非为佛咎。佛化度众生神器利用悉皆备足。譬如日出有目则睹盲者不见。设使有目而无日者则无所睹。是故日无咎也。佛明亦如是。问曰。云何佛世界因缘不断。答曰。菩萨于众生中。种种因缘赞叹佛道。令众生发阿耨多罗三藐三菩提心。渐渐行六波罗蜜。然后于诸世界各各作佛。若于一国次第作佛。或于异国各自作佛。是名不断佛国。复次菩萨疾集智慧具足作佛。度无量众生欲入涅槃。时为菩萨受记。我灭度后汝次作佛。展转皆悉如是令不断绝。若佛不记菩萨者则断佛国。譬如王立太子。展转如是国祚不断。问曰。何以贵有佛世界贱无佛国。答曰。是事不应致问。佛是庄严十方世界主。何况一国。若离有佛国者。虽受人天乐。而不知是佛恩力之所致。与畜生无异。若一切诸佛不出世者。则无三乘涅槃之道。常闭在三界狱永无出期。若世有佛众生得出三界牢狱。譬如二国之间。无日之处。是中众生从冥中生从冥中死。若佛生时光明暂昭。各各相见乃见日月。所昭众生知彼为大福。我等有罪如是。或时佛以光明遍昭诸佛国。有佛国众生见佛光明。则大欢喜念言。我等黑闇彼为大明。复次有佛之国众生知有罪福。人受三归五戒八斋。及出家五众等种种甚深禅定智慧四沙门果有余无余涅槃等。如是种种善法。以是因缘故佛国为贵。若佛国众生虽不见佛值遇经法。修善持戒布施礼敬等。种涅槃因缘。乃至畜生皆能种福德因缘。若无佛之国乃至天人不能修善。以是故菩萨生愿。欲使佛世界不断

大智度论卷第三十大智度论释初品中十八空义第四十八(卷三十一)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】复次舍利弗。菩萨摩诃萨。欲住内空外空内外空空空大空第一义空有为空无为空毕竟空无始空散空性空自相空诸法空不可得空无法空有法空无法有法空。当学般若波罗蜜

【论】内空者内法。内法空。内法者。所谓内六入眼耳鼻舌身意。眼空无我无我所无眼法。耳鼻舌身意亦如是。外空者外法。外法空。外法者。所谓外六入色声香味触法。色空者无我无我所无色法。声香味触法亦如是。内外空者内外法。内外法空。内外法者。所谓内外十二入。十二入中无我无我所。无内外法。问曰。诸法无量空随法故则亦无量。何以但说十八。若略说应一空。所谓一切法空。若广说随一一法空。所谓眼空色空等甚多。何以但说十八空。答曰。若略说则事不周。若广说则事繁。譬如服药。少则病不除。多则增其患。应病投药令不增减则能愈病。空亦如是。若佛但说一空。则不能破种种邪见及诸烦恼。若随种种邪见说空空则过多。人爱着空相堕在断灭。说十八空正得其中。复次若说十若说十五俱亦有疑此非问也。复次善恶之法皆有定数。若四念处四正勤三十七品十力四无所畏四无碍智十八不共法五众十二入十八界十二因缘三毒三结四流五盖等。诸法如是各有定数。以十八种法中破着故说有十八空。问曰。般若波罗蜜空十八空为异为一。若异者离十八空以何为般若空。又如佛说。何等是般若波罗蜜。所谓色空受想行识空。乃至一切种智空。若不异者。云何言欲住十八空当学般若波罗蜜。答曰。有因缘故言异。有因缘故言一。异者般若波罗蜜名诸法实相。灭一切观法。十八空则十八种观令诸法空。菩萨学是诸法实相。能生十八种空。是名异。一者十八空是空无所有相。般若波罗蜜亦空无所有相。十八空是舍离相。般若波罗蜜一切法中亦舍离相。是十八空不着相。般若波罗蜜亦不着相。以是故学般若波罗蜜则是学十八空。不异故般若波罗蜜有二分。有小有大。欲得大者先当学小方便门。欲得大智慧当学十八空。住是小智慧方便门能得十八空。何者是方便门。所谓般若波罗蜜经读诵正忆念思惟如说修行。譬如人欲得种种好宝当入大海。若人欲得内空等三昧智慧宝。当入般若波罗蜜大海。问曰。行者云何学般若波罗蜜时住内空外空内外空。答曰。世间有四颠倒。不净中有净颠倒。苦中有乐颠倒。无常中有常颠倒。无我中有我颠倒。行者为破四颠倒故。修四念处十二种观。所谓初观内身三十六种不净充满九孔常流甚可厌患。净相不可得。净相不可得故名内空。行者既知内身不净。观外所著亦复如是。俱实不净。愚夫狂惑为淫欲覆心故谓之为净。观所著色亦如我身净相不可得。是为外空。行者若观己身不净或谓外色为净。若观外不净或谓己身为净。今俱观内外我身不净外亦如是。外身不净我亦如是。一等无异净不可得。是名内外空。行者思惟知内外身俱实不净。而惑者爱着。爱着深故由以受身。身为大苦。而愚以为乐。问曰。三受皆外入所摄。云何言观内受。答曰。六尘初与六情和合生乐。是名外乐。后贪着深入生乐。是名内乐。复次内法缘乐是名内乐。外法缘乐。是名外乐。复次五识相应乐。是名外乐。意识相应乐。是名内乐。粗乐名为外乐。细乐名为内乐。如是等分别内外乐。苦受不苦不乐受亦如是。复次行者思惟观是内乐实可得。不即分别知实不可得。但为是苦强名为乐。何以故。是乐从苦因缘生。亦生苦果报。乐无厌足故苦。复次如人患疥。搔之向火疥虽小乐后转伤身则为大苦。愚人谓之为乐。智者但见其苦。如是世间乐颠倒病故着五欲乐。烦恼转多。以是故行者不见乐但见苦。如病如痈如疮如刺。复次乐少苦多少乐不现故名为苦。如大河水投一合盐则失盐相不名为碱

复次乐不定故或此以为乐彼以为苦。彼以为乐此以为苦。著者为乐失者为苦。愚以为乐智以为苦。见乐患为苦不见乐过者为乐。不见乐无常相为乐。见乐无常相为苦。未离欲人以为乐。离欲人以为苦。如是等观乐为苦。观苦如箭入身。观不苦不乐无常变异相。如是等观三种受心则舍离。是名观内受空。观外受内外受亦如是。行者作是念。若乐即是苦。谁受是苦。念已则知心受。然后观心为实为虚。观心无常生住灭相。苦受心乐受心不苦不乐受心各各异念。觉乐心灭而苦心生。苦心尔所时住。住已还灭次生不苦不乐心。知尔所时不苦不乐心住。住已还灭。灭已还生乐心。三受无常故心亦无常。复次知染心无染心嗔心无嗔心痴心不痴心散心摄心缚心解脱心。如是等心各各异相。故知心无常无一定心常住。受苦受乐等心从和合因缘生。因缘离散心亦随灭。如是等观内心外心内外心无常相。问曰。心是内入摄。云何为外心。答曰。观内身名为内心。观外身名为外心。复次缘内法为内心。缘外法为外心。复次五识常缘外法不能分别故名为外心。意识能缘内法亦分别好丑故名为内心。复次意识初生未能分别决定。是为外心。意识转深能分别取相。是名内心。如是等分别内外心。行者心意转异知身为不净相。知受为苦相。知心不住为无常相。结使未断故或生吾我。如是思惟若心无常。谁知是心心为属谁。谁为心主而受苦乐。一切诸物谁之所有。即分别知无有别主。但于五众取相故计有人相而生我心。以我心故生我所。我所心生故有利益我者生贪欲。违逆我者而生嗔恚。此结使不从智生从狂惑生故。是名为痴。三毒为一切烦恼之根本亦由吾我。故作福德为我后当得亦修助道法我当得解脱。初取相故名为想众。因吾我起结使及诸善行。是名行众。是二众则是法念处。于想行众法中求我不可得。何以故。是诸法皆从因缘生。悉是作法而不牢固无实我法行。如芭蕉叶叶求之中无有坚相。如远见野马无水有水想。但诳惑于眼。如是等观内法外法内外法。问曰。法是外入摄。云何为内法。答曰。内法名为内心相应想众行众。外法名为外心相应想众行众及心不相应诸行及无为法。一时等观名为内外法。复次内法名为六情。外法名为六尘。复次身受心及想众行众总观为法念处。何以故。行者既于想众行众及无为法中求我不可得。还于身受心中求亦不可得。如是一切法中若色若非色。若可见若不可见。若有对若无对。若有漏若无漏。若有为若无为。若远若近。若粗若细。其中求我皆不可得。但五众和合故强名为众生。众生即是我。我不可得故亦无我所。我所不可得故一切诸烦恼皆为衰薄。复次身念处名一切色法。行者观内色无常苦空无我。观外色观内外色亦如是。受心法亦尔。四念处内观相应空三昧名内空。四念处外观相应空三昧名外空。四念处内外观相应空三昧名内外空。问曰。是空为是三昧力故空为是法自空。答曰。名为三昧力故空。如经说。三三昧三解脱门。空无相无作。是空三昧缘身受心法不得我我所故名为空。问曰。四念处空法皆应观无常苦空无我。何以故。身观不净受观苦心观无常法观无我。答曰。虽四法皆观无常苦空无我。而众生身中多着净颠倒。受中多着乐颠倒。心中多着常颠倒。法中多着我颠倒。以是故行者观身不净观受苦观心无常观法无我。复次内外空者。无有内外定法互相因待故。谓为内外。彼以为外我以为内。我以为外彼以为内。随人所系内法为内。随人所著外法为外。如人自舍为内他舍为外。行者观是内外法无定相故空

复次是内外法无有自性。何以故。和合生故。是内外法亦不在和合因缘中。若因缘中无者。余处亦无。内外法因缘亦无。因果无故内外法空。问曰。内外法定有。云何言无。如手足等和合故有身法生。是名内法。如梁椽壁等和合故有屋法生。是名为外。是身法虽有别名亦不异足等。所以者何。若离足等身不可得故。屋亦如是。答曰。若足不异身者。头应是足。足与身不异故。若头是足者。甚为可笑。问曰。若足与身不异者。有如是过。今应足等和合故更有法生名为身。身虽异于足等应当依于足住。如众缕和合而能生[疊*毛]。是[疊*毛]依缕而住。答曰。是身法为足等分中具有为分有。若具有头中应有足。何以故。身法具有故。若分有与足分无异。又身是一法所因者多。一不为多多不为一。复次若除足等分别有身者。与一切世间皆相违背。以是故身不得言即是诸分。亦不得言异于诸分。以是故则无身。身无故足等亦无。如是等名为内空。房舍等外法亦如是空。名为外空。问曰。破身舍等是为破一破异。破一破异是破外道经。佛经中实有内外法。所谓内六情外六尘。此云何无。答曰。是内外法和合假有名字。亦如身如舍。复次略说有二种空。众生空法空。小乘弟子钝根故为说众生空。我我所无故则不着余法。大乘弟子利根故为说法空。即时知世间常空如涅槃。声闻论议师说内空。于内法中无我无我所。无常无作者无知者无受者。是名内空。外空亦如是。不说内法相外法相即是空。大乘说内法中无内法相。外法中无外法相。如般若波罗蜜中说。色色相空。受想行识识相空。眼眼相空。耳鼻舌身意意相空。色色相空。声香味触法法相空。如是等一切诸法自法空。问曰。此二种说内外空。何者是实。答曰。二皆是实。但为小智钝根故先说众生空。为大智利根者说法空。如人闭狱破坏桎梏伤杀狱卒随意得去。又有怖畏盗穿墙壁亦得免出。声闻者但破吾我因缘生诸烦恼离诸法爱。畏怖老病死恶道之苦。不复欲本末推求了了坏破诸法。但以得脱为事。大乘者破三界狱降伏魔众断诸结使及灭习气。了知一切诸法本末通达无碍破散诸法。令世间如涅槃同寂灭相。得阿耨多罗三藐三菩提。将一切众生令出三界。问曰。大乘有何方便能破坏诸法。答曰。佛说色从种种因缘生无有坚实。如水波浪而成泡沫暂见即灭。色亦如是。今世四大先世行业因缘和合故而得成色。因缘灭故色亦俱灭。行无常道转入空门。所以者何。诸法生灭无有住时。若无住时则无可取。复次有为相故生时有灭灭时有生。若已生生无所用。若未生生无所生。法与生亦不应有异。何以故。生若生法应有生生。如是复应有生是则无穷。若生生更无生者生不应有生。若生无有生者法亦不应有生。如是生不可得。灭亦如是。以是故诸法空不生不灭。是为实。复次诸法若有者终归于无。若后无者初亦应无。如人着屐。初已有故微细不觉。若初无故则应常新。若后有故相初亦有故。法亦如是。后有无故初亦有无。以是故一切法应空。以众生颠倒着内六情故。行者破是颠倒。名为内空。外空内外空亦如是。空空者。以空破内空外空内外空。破是三空故。名为空空。复次先以法空破内外法。复以此空破是三空。是名空空。复次空三昧观五众空。得八圣道。断诸烦恼得有余涅槃。先世业因缘身命尽时欲放舍八道故生空空三昧。是名空空。问曰。空与空空有何等异。答曰。空破五受众。空空破空。问曰。空若是法空为已破。空若非法空何所破。答曰。空破一切法唯有空在。空破一切法已空亦应舍。以是故须是空空。复次空缘一切法。空空但缘空。如一健儿破一切贼复更有人能破此健人。空空亦如是。又如服药。药能破病。病已得破药亦应出。若药不出则复是病。以空灭诸烦恼病。恐空复为患。是故以空舍空。是名空空。复次以空破十七空故名为空空。大空者声闻法中法空为大空。如杂阿含大空经说生因缘老死。若有人言是老死是人老死二俱邪见。是人老死则众生空。是老死是法空。摩诃衍经说十方。十方相空。是为大空。问曰。十方空何以名为大空。答曰。东方无边故名为大。亦一切处有故名为大。遍一切色故名为大。常有故名为大。益世间故名为大。令众生不迷闷故名为大。如是大方能破故名为大空。余空破因缘生法。作法粗法易破故不名为大。是方非因缘生法。非作法微细法难破故名为大空。问曰。若佛法中无方。三无为虚空智缘尽非智缘尽亦所不摄。何以言有方。亦是常是无为法非因缘生法。非作法微细法。答曰。是方法声闻论议中无。摩诃衍法中以世俗谛故有。第一义中一切法不可得。何况方。如五众和合假名众生。方亦如是。四大造色和合中。分别此间彼间等。假名为方。日出处是则东方。日没处是则西方。如是等是方相。是方自然常有故非因缘生。亦不先无今有今有后无故。非作法非现前知故。是微细法。问曰。方若如是云何可破。答曰。汝不闻。我先说。以世俗谛故有。第一义故破。以俗谛有故不堕断灭中。第一义破故不堕常中。是名略说大空义。问曰。第一义空亦能破无作法无因缘法细微法。何以不言大空。答曰。前已得大名故不名为大。今第一义名虽异义实为大。出世间以涅槃为大。世间以方为大。以是故第一义空亦是大空。复次破大邪见故。名为大空。如行者以慈心缘东方一国土众生。复缘一国土众生。如是展转缘时。若谓尽缘东方国土则堕边见。若谓未尽则堕无边见。生是二见故即失慈心。若以方空破是东方则灭有边无边见。若不以方空破东方者则随东方心。随心不已慈心则灭邪心则生。譬如大海潮时至其常限水则旋还。鱼若不还则漂在露地有诸苦患。若鱼有智则随水还永得安隐。行者如是。若随心不还则漂在邪见。若随心还不失慈心。如是破大邪见故。名为大空。第一义空者。第一义名诸法实相。不破不坏故。是诸法实相亦空。何以故。无受无著故。若诸法实相有者应受应着。以无实故不受不着。若受著者即是虚诳。复次诸法中第一法名为涅槃。如阿毗昙中说。云何有上法一切有为法及虚空非智缘尽。云何无上法智缘尽。智缘尽是即涅槃。涅槃中亦无涅槃相。涅槃空是第一义空。问曰。若涅槃空无相。云何圣人乘三种乘入涅槃。又一切佛法皆为涅槃故说。譬如众流皆入于海。答曰。有涅槃是第一宝无上法。是有二种。一者有余涅槃。二无余涅槃。爱等诸烦恼断。是名有余涅槃。圣人今世所受五众尽更不复受。是名无余涅槃。不得言涅槃无。以众生闻涅槃名生邪见着涅槃音声而作戏论。若有若无。以破着故说涅槃空。若人著有是着世间。若着无则着涅槃。破是凡人所著涅槃。不破圣人所得。何以故。圣人于一切法中不取相故。复次爱等诸烦恼假名为缚。若修道解是缚得解脱。即名涅槃。更无有法名为涅槃。如人被械得脱而作戏论。是械是脚何者是解脱。是人可怪于脚械外更求解脱。众生亦如是。离五众械更求解脱法。复次一切法不离第一义。第一义不离诸法实相。能使诸法实相空。是名为第一义空。如是等种种名为第一义空

有为空无为空者。有为法名因缘和合生。所谓五众十二入十八界等。无为法名无因缘。常不生不灭如虚空。今有为法二因缘故空。一者无我无我所及常相不变异不可得故空。二者有为法有为法相空不生不灭无所有故。问曰。我我所及常相不可得故应空。云何言有为法有为法相空。答曰。若无众生法无所依。又无常故无住时。无住时故不可得。知是故法亦空。问曰。有为法中常相不可得。不可得者。为是众生空为是法空。答曰。有人言。我心颠倒故计我为常。是常空则入众生空。有人言。以心为常如梵天王说是四大。四大造色悉皆无常。心意识是常。是常空则入法空。或有人言。五众即是常。如色众虽有变化而亦不灭。余众如心。说五众空即是法空。是故常空亦入法空中。复次有为法无为法空者。行者观有为法无为法实相无有作者。因缘和合故有。皆是虚妄。从忆想分别生。不在内不在外不在两中间。凡夫颠倒见故有。智者于有为法不得其相知但假名。以此假名导引凡夫。知其虚诳无实无生无作心无所著。复次诸贤圣人不缘有为法而得道果。以观有为法空故。于有为法心不系着故。复次离有为则无无为。所以者何。有为法实相即是无为。无为相者则非有为但为众生颠倒故分别说。有为相者生灭住异。无为相者不生不灭不住不异。是为入佛法之初门。若无为法有相者则是有为。有为法生相者则是集谛。灭相者则是尽谛。若不集则不作。若不作则不灭。是名无为法如实相。若得是诸法实相。则不复堕生灭住异相中。是时不见有为法与无为法。合不见无为法与有为法。合于有为法无为法不取相。是为无为法。所以者何。若分别有为法无为法。则于有为无为而有碍。若断诸忆想分别灭诸缘。以无缘实智不堕生数中。则得安隐常乐涅槃。问曰。前五空皆别说。今有为无为空何以合说。答曰。有为无为法相待而有。若除有为则无无为。若除无为则无有为。是二法摄一切法。行者观有为法无常苦空等过。知无为法所益处广。是故二事合说。问曰。有为法因缘和合生。无自性故空。此则可尔。无为法非因缘生法。无破无坏常若虚空。云何空。答曰。如先说若除有为则无无为。有为实相即是无为。如有为空无为亦空。以二事不异故。复次有人闻有为法过罪而着无为法。以着故生诸结使。如阿毗昙中说。八十九有为法缘六无为法缘三当分别。欲界系尽谛所断无明使。或有为缘或无为缘。何者有为缘。尽谛所断有为法缘使相应无明使。何者无为缘。尽谛所断有为法缘使不相应无明使。色无色界无明亦如是。以此结使故能起不善业。不善业故堕三恶道。是故言无为法空。无为法缘使。疑邪见无明。疑者于涅槃法中有耶无耶。邪见者若生心言定无涅槃。是邪疑相应无明。及独无明合为无明使。问曰。若云无为法空与邪见何异。答曰邪见人不信涅槃。然后生心言定无涅槃法。无为空者破取涅槃相是为异。复次若人舍有为着无为。以着故无为即成有为。以是故虽破无为而非邪见。是名有为无为空。毕竟空者。以有为空无为空破诸法令无有遗余。是名毕竟空如漏尽阿罗汉名毕竟清净。阿那含乃至离无所有处欲不名毕竟清净。此亦如是。内空外空内外空十方空第一义空有为空无为空。更无有余不空法。是名毕竟空。复次若人七世百千万亿无量世贵族是名毕竟贵。不以一世二三世贵族为真贵也。毕竟空亦如是。从本已来无有定实不空者。有人言。今虽空最初不空。如天造物始及冥初微尘。是等皆空。何以故。果无常因亦无常。如虚空不作果亦不作因。天及微尘等亦应如是。若是常不应生无常。若过去无定相未来现在世亦如是。于三世中无有一法定实不空者。是名毕竟空。问曰。若三世都空。乃至微尘及一念无所有者。则是大可畏处。诸智慧人以禅定乐故舍世间乐。以涅槃乐故舍禅定乐。今毕竟空中乃至无有涅槃。依止何法得舍涅槃。答曰。有着吾我人以一异相分别诸法。如是之人则以为畏。如佛说凡夫人大惊怖处。所谓无我无我所。复次有为法有三世。以有漏法故生着处。涅槃名一切爱着断。云何于涅槃而求舍离。复次如比丘破四重禁。是名毕竟破戒。不任得道。又如作五逆罪。毕竟闭三善道。若取声闻证者毕竟不得作佛。毕竟空亦如是。于一切法毕竟空无复有余。问曰。一切法毕竟空是事不然。何以故。三世十方诸法乃至法相法住必应有实。以有一法实故余法为虚妄。若无一法实者亦不应有诸虚妄法是毕竟空。答曰。无有乃至一法实者。何以故。若有乃至一法实者。是法应有若有为若无为。若是有为有为空中已破。若是无为无为空中亦破。如是世间出世间。若世间内空外空内外空大空已破。若出世间第一义空已破。色法无色法有漏无漏法等亦如是。复次一切法皆毕竟空。是毕竟空亦空。空无有法故亦无虚实相待。复次毕竟空者破一切法令无遗余故名毕竟空。若小有遗余不名毕竟。若言相待故应有是事不然。问曰。诸法不尽空。何以故。因缘所生法空。而因缘不空。譬如梁椽因缘和合故名舍。舍空而梁椽不应空。答曰。因缘亦空因缘不定故。譬如父子。父生故名为子。生子故名为父。复次最后因缘无所依止故。如山河树木众生之类皆依止地。地依止水。水依止风。风依止虚空。虚空无所依止。若本无所依止末亦无所依止。以是故当知一切法毕竟空。问曰。不然。诸法应有根本。如神通有所变化所化虽虚而化主不空。答曰。凡夫人见所化物不久故谓之为空。化主久故谓之为实。圣人见化主复从前世业因缘和合生。今世复集诸善法。得神通力故能作化。如般若波罗蜜后品中说。有三种变化。烦恼变化业变化法变化(法法身也)是故知化主亦空。问曰。诸不牢固者不实故应空。诸牢固物及实法不应空。如大地须弥山大海水日月金刚等色实法牢固故不应空。所以者何。地及须弥常住竟劫故。众川有竭海则常满。日月周天无有穷极。又如凡人所见虚妄不真故应空。圣人所得如及法性真际涅槃相应是实法。云何言毕竟皆空。复次有为法因缘生故不实。无为法不从因缘生故应实。复云何言毕竟空。答曰。坚固不坚固不定故皆空所以者何。有人以此为坚固。有人以此为不坚固。如人以金刚为牢固。帝释手执如人捉杖不以为牢固。又不知破金刚因缘故以为牢固。若知着龟甲上以山羊角打破则知不牢固。如七尺之身以大海为深。罗睺阿修罗王。立大海中膝出水上。以两手隐须弥顶。下向观忉利天喜见城。此则以海水为浅。若短寿人以地为常久牢固。长寿者见地无常不牢固。如佛说七日喻经。佛告诸比丘。一切有为法无常变异皆归磨灭。劫欲尽时大旱积久。药草树木皆悉焦枯。有第二日出诸小流水皆悉干竭。第三日出大河流水亦都涸尽。第四日出阎浮提中四大河。及阿那婆达多池皆亦空竭。第五日出大海干涸。第六日出大地须弥山等皆悉烟出如窑烧器。第七日出悉皆炽然无复烟气。地及须弥乃至梵天火皆然满。尔时新生光音天者见火怖畏言。既烧梵宫将无至此。先生诸天慰喻后生天言。曾已有此正烧梵宫。于彼而灭不来至此。烧三千大千世界已无复灰炭。佛语比丘如此大事谁信之者。唯有眼见乃能信耳。又比丘过去时。须涅多罗外道师离欲行四梵行。无量弟子亦得离欲。须涅多罗作是念我不应与弟子同生一处。今当深修慈心。此人以深思慈故生光音天。佛言须涅多罗者我身是也。我是时眼见此事以是故当知牢固实物皆悉归灭。问曰。汝说毕竟空何以说无常事。毕竟空今即是空。无常今有后空。答曰。无常则是空之初门。若谛了无常诸法则空。以是故。圣人初以四行观世间无常。若见所著物无常。无常则能生苦。以苦故心生厌离。若无常空相则不可取。如幻如化是名为空。外物既空内主亦空是名无我。复次毕竟空是为真空有二种众生。一多习爱二多习见。爱多者喜生着。以所著无常故生忧苦。为是人说。汝所著物无常坏故。汝则为之生苦。若此所著物生苦者不应生着。是名说无作解脱门。见多者为分别诸法以不知实故而着邪见。为是人故直说诸法毕竟空。复次若有所说皆是可破可破故空。所见既空见主亦空。是名毕竟空。汝言圣人所得法应实者。以圣人法能灭三毒。非颠倒虚诳能令众生离老病死苦得至涅槃。是虽名实皆从因缘和合生故。先无今有今有后无故。不可受不可着故亦空非实。如佛说筏喻经。善法尚应舍何况不善。复次圣人有为无漏法从有漏法缘生。有漏法虚妄不实缘所生法。云何为实离有为法无无为法如先说。有为法实相即是无为法。以是故。一切法毕竟不可得故名为毕竟空。无始空者世间若众生若法皆无有始。如今生从前世因缘有。前世复从前世有。如是展转无有众生始。法亦如是。何以故。若先生后死则不从死故生。生亦无死。若先死后有生则无因无缘。亦不生而有死。以是故。一切法则无有始如经中说。佛语诸比丘众生无有始。无明覆爱所系往来生死始不可得。破是无始法故名为无始空。问曰。无始是实不应破。何以故。若众生及法有始者。即堕边见亦堕无因见。远离如是等过故。应说众生及法无始。今以无始空破是无始则还堕有始见。答曰。今以无始空为破无始见。又不堕有始见。譬如救人于火不应着深水中。今破是无始亦不应著有始中。是则行于中道。问曰。云何破无始。答曰。以无穷故。若无穷则无后。无穷无后则亦无中。若无始则为破一切智人。所以者何。若世间无穷则不知其始。不知始故则无一切智人。若有一切智人不名无始。复次若取众生相又取诸法一相异相。以此一异相从今世推前世从前世复推前世。如是展转众生及法。始不可得则生无始见。是见虚妄以一异为本。是故应破。如有为空破有为法。是有为空即复为患。复以无为空破无为法。今以无始破有始无始即复为患。复以无始空破是无始。是名无始空。问曰。若尔者。佛何以说众生往来生死本际不可得。答曰。欲令众生知久远已来往来生死为大苦。生厌患心。如经说。一人在世间计一劫中受身被害时。聚集诸血多于海水。啼泣出泪及饮母乳皆亦如是。积集身骨过于毗浮罗山。譬喻斩天下草木为二寸筹。数其父祖曾祖犹不能尽。又如尽以地为泥丸。数其母及曾祖母犹亦不尽。如是等无量劫中。受生死苦恼。初始不可得故。心生怖畏断诸结使。如无常虽为边。而佛以是无常而度众生。无始亦如是。虽为是边亦以是无始而度众生。为度众生令生厌心故说有无始非为实有。所以者何。若有无始不应说无始空。问曰。若无始非实法云何以度人。答曰。实法中无度人诸可说法。语言度人皆是有为虚诳法。佛以方便力故说是无始。以无著心说故受者亦得无著。无著故则生厌离。复次以宿命智见众生。生死相续无穷。是时为实。若以慧眼则见众生及法毕竟空。以是故说无始空。如般若波罗蜜中说。常观不实。无常观亦不实。苦观不实。乐观亦不实。而佛说常乐为倒无常苦为谛。以众生多着常乐不着无常苦。是故以无常苦谛破是常乐倒。以是故说无常苦为谛。若众生着无常苦者说无常苦亦空。有始无始亦如是。无始能破着始倒。若着无始复以无始为空。是名无始空。问曰。有始法亦是邪见应当破。何以但说破无始。答曰。有始是大惑。所以者何。若有始者。初身则无罪福因缘而生善恶处。若从罪福因缘而生不名为初身。何以故。若有罪福则从前身受后身。故若世间无始无如是咎。是故菩萨先已舍是粗恶邪见。菩萨常习用无始念众生故说无始。常行因缘法故言法无始。未得一切智故或于无始中错谬。是故说无始空。复次无始已破有始不须空破有始。今欲破无始故说无始空。问曰。若无始破有始者有始亦能破无始。汝何以言但以空破无始。答曰。是二虽皆邪见而有差别。有始起诸烦恼邪见因缘。无始起慈悲及正见因缘。所以者何。念众生受无始世苦恼而生悲心。知从身次第生身相续不断。便知罪福果报而生正见。若人不着无始即是助道善法。若取相生着即是邪见。如常无常见。有始见虽破无始见不能毕竟破无始。无始能毕竟破有始是故无始为胜。如善破不善不善破善。虽互相破而善能毕竟破恶。如得贤圣道永不作恶。恶法则不然。势力微薄故。如人虽起五逆罪断善根堕地狱久不过一劫因缘得脱地狱终成道果。无始有始优劣不同亦如是。以无始力大故能破有始。是故不说有始空

散空者散名别离相。如诸法和合故有。如车以辐辋辕毂众合为车。若离散各在一处则失车名。五众和合因缘故名为人。若别离五众人不可得。问曰。若如是说但破假名而不破色。亦如离散辐辋可破车名不破辐辋。散空亦如是。但离散五众可破人而不破色等五众。答曰。色等亦是假名破。所以者何。和合微尘假名为色故。问曰。我不受微尘。今以可见者为色。是实为有云何散而为空。答曰。若除微尘。四大和合因缘生出可见色亦是假名。如四方风和合扇水则生沫聚。四大和合成色亦如是。若离散四大则无有色。复次是色以香味触及四大和合故有色可见。除诸香味触等更无别色。以智分别各各离散色不可得。若色实有舍此诸法应别有色。而更无别色。是故经言所有色皆从四大和合有。和合有故皆是假名。假名故可散。问曰。色假名故可散。四众无色云何可散。答曰。四阴亦是假名。生老住无常观故散而为空。所以者何。生时异老时异住时异无常时异故。复次三世中观是四众皆亦散灭。复次心随所缘缘灭则灭。缘破则破。复次此四众不定随缘生故。譬如火随所烧处为名。若离烧处火不可得。因眼缘色生眼识。若离所缘识不可得。余情识亦如是。如经中说佛告罗陀。此色众破坏散灭令无所有。余众亦如是。是名散空。复次譬如小儿聚土为台殿城郭闾里宫舍。或名为米或名为面爱着守护。日暮将归其心舍离蹋坏散灭。凡夫人亦如是。未离欲故于诸法中生爱着心。若得离欲见诸法皆散坏弃舍是名散空。复次诸法合集故各有名字。凡夫人随逐名字生颠倒染着。佛为说法当观其实莫逐名字。有无皆空。如迦旃延经说。观集谛则无无见观灭谛则无有见。如是种种因缘是名散空。性空者诸法性常空假业相续故似若不空。譬如水性自冷假火故热。止火停久水则还冷。诸法性亦如是。未生时空无所有如水性常冷。诸法众缘和合故有。如水得火成热。众缘若少若无则无有法。如火灭汤冷。如经说。眼空无我无我所。何以故性自尔。耳鼻舌身意色乃至法等亦复如是。问曰。此经说我我所空是为众生空。不说法空云何证性空。答曰。此中但说性空不说众生空及法空。性空有二种。一者于十二入中无我无我所。二者十二入相自空无我无我所。是声闻论中说。摩诃衍法说。十二入我我所无故空。十二入性无故空。复次若无我无我所自然得法空。以人多着我及我所故。佛但说无我无我所。如是应当知一切法空。若我我所法尚不着。何况余法。以是故。众生空法空终归一义是名性空。复次性名自有不待因缘。若待因缘则是作法不名为性。诸法中皆无性。何以故。一切有为法皆从因缘生。从因缘生则是作法。若不从因缘和合则是无法。如是一切诸法性不可得故名为性空。问曰。毕竟空无所有则是性空。今何以重说。答曰。毕竟空者名为无有遗余。性空者名为本来常尔。如水性冷假火故热止火则还冷。毕竟空如虚空常不生不灭不垢不净。云何言同。复次诸法毕竟空。何以故。性不可得故。诸法性空。何以故。毕竟空故。复次性空多是菩萨所行。毕竟空多是诸佛所行。何以故。性空中但有因缘和合无有实性。毕竟空三世清净有如是等差别。复次一切诸法性有二种。一者总性。二者别性。总性者。无常苦空无我无生无灭无来无去无入无出等。别性者。如火热性水湿性心为识性。如人喜作诸恶故名为恶性。好集善事故名为善性。如十力经中说。佛知世间种种性。如是诸性皆空是名性空。何以故。若无常性是实应失业果报。所以者何。生灭过去不住故。六情亦不受尘亦不积习因缘。若无积习则无诵经坐禅等。以是故知无常性不可得。无常尚不可得。何况常相。复次苦性亦不可得。若实有是苦则不应生染着心。若人厌畏苦痛于诸乐中亦应厌畏。佛亦不应说三受苦受乐受不苦不乐受。亦不应苦中生嗔乐中生爱不苦不乐中生痴。若一相者乐中应生嗔苦中应生爱。但是事不然。如是等苦性何不可得。何况乐性虚妄而可得。复次空相亦不可得。所以者何若有空相则无罪福。无罪福故亦无今世后世。复次诸法相待有。所以者何。若有空应当有实。若有实应当有空。空性尚无。何况有实。复次若无我者则无缚无解。亦无从今世至后世受罪福。亦无业因缘果报。如是等因缘知无我性尚不可得。何况我性。复次无生无灭性亦不实。何以故。若实则堕常见。若一切法常则无罪无福。若有者常有。无者常无。若无者不生。有者不失。如不生不灭性不可得。何况生灭性。无来无去无入无出等诸总性亦如是。复次诸法别性是亦不然。何以故。如火能烧造色能昭。二法和合故名为火。若离是二法有火者应别有火用而无别用。以是故知火是假名亦无有实。若实无火法云何言热是火性。复次热性从众缘生。内有身根外有色触。和合生身识觉知有热。若未和合时则无热性。以是故知无定热为火性。复次若火实有热性云何有人入火不烧。及人身中火而不烧身。空中火水不能灭。以火无有定热性故。神通力故火不能烧身。业因缘五藏不热。神龙力故水不能灭。复次若热性与火异火则非热。若热与火一云何言热是火性。余性亦如是。是总性别性无故名为性空。复次性空者从本已来空。如世间人谓虚妄不久者是空。如须弥金刚等物。及圣人所知以为真实不空。欲断此疑故佛说是虽坚固相续久住皆亦性空。圣人智慧虽度众生。破诸烦恼性不可得故是亦为空。又人谓五众十二入十八界皆空。但如法性实际。是其实性。佛欲断此疑故。但分别说五众如法性实际皆亦是空是名性空。复次有为性三相生住灭。无为性亦三相不生不住不灭。有为性尚空。何况有为法。无为性尚空。何况无为法。以是种种因缘性不可得名为性空

自相空者一切法有二种相总相别相。是二相空故名为相空。问曰。何等是总相何等是别相。答曰。总相者如无常等。别相者诸法虽皆无常而各有别相。如地为坚相火为热相。问曰。先已说性今说相。性相有何等异。答曰。有人言。其实无异名有差别。说性则为说相说相则为说性。譬如说火性即是热相。说热相即是火性。有人言。性相小有差别。性言其体相言可识。如释子受持禁戒是其性。剃发割截染衣是其相。梵志自受其法是其性。顶有周罗执三奇杖是其相。如火热是其性。烟是其相。近为性远为相。相不定从身出。性则言其实。如见黄色为金相而内是铜火烧石磨知非金性。如人恭敬供养时似是善人是为相骂詈毁辱忿然嗔恚便是其性。性相内外远近初后等有如是差别。是诸相皆空名为相空。如说一切有为法皆是无常相。所以者何。生灭不住故。先无今有已有还无故。属诸因缘故。虚诳不真故。无常因缘生故。众合因缘起故。如是等因缘故。一切有为法是无常相能生身心恼故名为苦身。四威仪无不苦故。苦圣谛故。圣人舍不受故。无时不恼故。无常故。如是等因缘名为苦相。离我所故空。因缘和合生故空。无常苦空无我故名为空。始终不可得故空。诳心故名为空。贤圣一切法不着故名为空。以无相无作解脱门故名为空。诸法实相无量无数故名为空。断一切语言道故名为空。灭一切心行故名为空。诸佛辟支佛阿罗汉入而不出故名为空。如是等因缘故是名为空。无常苦空故无我。不自在故无我。无主故名为无我。诸法无不从因缘生从因缘生故无我。无相无作故无我。假名字故无我。身见颠倒故无我。断我心得道故无我。以是种种名为无我。如是等名为总相。别相者地坚相火热相水湿相风动相。眼识衣处名眼相。耳鼻舌身亦如是。识觉相智慧相慧智相。舍为施相。不悔不恼为持戒相。心不变异为忍相。发勤为精进相。摄心为禅相。无所著为智慧相能成事为方便相。识作生灭为世间相。无识为涅槃相。如是等诸法各有别相。当知是诸相皆空是名自相空。余义如性空中说性相义同故。问曰。何以不但说相空而说自相空。答曰。若说相空不说法体空。说自相空即法体空。复次众法和合故一法生是一法空。如是等一一法皆空。今和合因缘法展转皆亦空。一切法各各自相空。以是故名为自相空。问曰。若一切法各各自相空。云何复有所说。答曰。众生颠倒故。以一相异相总相别相等而着诸法。为断是故而有所说。如是等因缘名为自相空。一切法空者。一切法名五众十二入十八界等。是诸法皆入种种门。所谓一切法有相。知相识相缘相增上相因相果相总相别相依相。问曰。云何一切法有相。答曰。一切法有好有丑有内有外。一切法有心生故名为有。问曰。无法中云何言有相。答曰。若无法不名为法。但以遮有故名为无法。若实有无法则名为有。是故说一切法有相。知相者苦法智苦比智能知苦谛。集法智集比智能知集谛。灭法智灭比智能知灭谛。道法智道比智能知道谛。及世俗善智能知苦能知集能知灭能知道。亦能知虚空非智缘灭是名一切法知相。知相故摄一切法。识相者眼识能知色耳识能知声鼻识能知香舌识能知味身识能知触意识能知法。能知眼能知色能知眼识。能知耳能知声能知耳识。能知鼻能知香能知鼻识。能知舌能知味能知舌识。能知身能知触能知身识。能知意能知法能知意识是名识相。缘相者眼识及眼识相应诸法能缘色。耳识及耳识相应诸法能缘声。鼻识及鼻识相应诸法能缘香。舌识及舌识相应诸法能缘味。身识及身识相应诸法能缘触。意识及意识相应诸法能缘法。能缘眼能缘色能缘眼识。能缘耳能缘声能缘耳识。能缘鼻能缘香能缘鼻识。能缘舌能缘味能缘舌识。能缘身能缘触能缘身识。能缘意能缘法能缘意识是名缘相。增上相者一切有为法各各增上。无为法亦于有为法有增上。是名增上相。因果相者一切法各各为因各各为果是名因果相。总相别相者一切法中各各有总相别相。如马是总相白是别相。如人是总相若失一耳则是别相。如是各各展转皆有总相别相。是为总相别相。依相者诸法各共相依止。如草木山河依止于地地依止水。如是一切各各相依。是名依止相。依止相摄一切法。知是等一法门相摄一切法。复次二法门摄一切法。所谓色无色法。可见不可见法。有对无对法。有漏无漏法。有为无为法。内法外法。观法缘法。有法无法。如是等种种二法门相。三四五六乃至无量法门相摄一切法。是诸法皆空如上说。名一切法空。问曰。若皆空者何以说一切法种种名字。答曰。凡夫人于空法中无明颠倒取相故生爱等诸烦恼。因烦恼故起种种业。起种种业故入种种道。入种种道故受种种身。受种种身故受种种苦乐。如蚕出丝无所因自从己出而自缠裹受烧煮苦。圣人清净智慧力故分别一切法本末皆空。欲度众生故说其着处。所谓五众十二入十八界等。汝但以无明故而生五众等自作自着。若圣人但说空者不能得道。以无所因无所厌故。问曰。汝言一切法空是事不然。何以故。一切法各各自相摄故。如地坚相水湿相火热相风动相心为识相慧为知相。如是一切法各自住其相云何言空。答曰。性空自相空中已破。今当更说。相不定故不应是相。如酥蜜胶蜡等皆是地相。与火合故自舍其相转成湿相。金银铜铁与火合故亦自舍其相变为水相。如水得寒成冰转为地相。如人醉睡入无心定冻冰中鱼皆无心识。舍其心相无所觉知。如慧为知相入诸法实相则无所觉知自舍知相。是故诸法无有定相。复次若谓诸法定相是亦不然。所以者何。如未来法相不应来至现在。若至现在则舍未来相。若不舍未来相入现在者未来则是现在为无未来果报。若现在入过去则舍现在相。若不舍现在相入过去过去则是现在如是等过。则知诸法无有定相。复次若谓无为法定有者应别自有相。如火自有热相不因他作相。是故当知无为法无相故实无。复次汝以未来世中非智缘灭法是有为法而无有为相。若汝谓以非智缘尽是灭相是亦不然。所以者何。无常灭故是名灭相。非以非智缘灭故名为灭相。如是等种种无有定相。若有定相可使不空而无定相而不空者是事不然。问曰。应实有法不空。所以者何。凡夫圣人所知各异。凡夫所知是虚妄。圣人所知是实。依实圣智故舍虚妄法。不可依虚妄舍虚妄。答曰。为破凡夫所知故名为圣智。若无凡夫法则无圣法。如无病则无药。是故经言。离凡夫法更无圣法。凡夫法实性即是圣法。复次圣人于诸法不取相亦不着。是故圣法为真实。凡夫于诸法取相亦着。故以凡夫人法为虚妄。圣人虽用而不取相。不取相故则无定相。如是不应为难。于凡夫地着法分别是圣法是凡夫法。若于贤圣地则无所分别。为断众生病故言是虚是实。如说佛语非虚非实非缚非解不一不异。是故无所分别清净如虚空。复次若法不悉空不应说不戏论为智人相亦不应说。不受不着无所依止。空无相无作名为真法。问曰。若一切法空即亦是实。云何言无实。答曰。若一切法空假令有法已入一切法中破。若无法不应致难。问曰。若一切法空是真实者。佛三藏中何以多说无常苦空无我法。如经说。佛告诸比丘。为汝说法名为第一义空。何等是第一义空。眼生无所从来灭亦无所去。但有业有业果报。作者不可得。耳鼻舌身意亦复如是。是中若说生无所从来灭亦无所去是常常法不可得故无常。但有业及业果报而作者不可得。是为声闻法中第一义空。云何言一切法空。答曰。我是一切诸烦恼根本。先着五众为我。然后着外物为我所。我所缚故而生贪恚。贪恚因缘故起诸业。如佛说无作者则破一切法中我。若说眼无所从来灭亦无所去则说眼无常。若无常即是苦。苦即是非我我所。我我所无故于一切法中心无所著。心无所著故则不生结使。不生结使何用说空。以是故三藏中多说无常苦空无我。不多说一切法空。复次众生虽闻佛说无常苦空无我。而戏论诸法。为是人故说诸法空。若无我亦无我所。若无我无我所是即入空义。问曰。佛何以说有业有果报。若有业有果报是则不空。答曰。佛说法有二种。一者无我一者无法。为着见神有常者故为说无作者。为着断灭见者故为说有业有业果报。若人闻说无作者转堕断灭见中。为说有业有业果报。此五众能起业而不至后世。此五众因缘生五众。受业果报相续故。说受业果报。如母子。身虽异而因缘相续故。如母服药儿病得差。如是今世后世五众虽异而罪福业因缘相续故。从今世五众因缘受后世五众果报。复次有人求诸法相着一法。若有若无若常若无常等以着法故自法生爱他法生恚而起恶业。为是人故说诸法空。诸法空则无有法。所以者何。所可爱法能生结使。能生结使则是无明因缘。若生无明云何是实是为法空。复次众生有二种。一者着世间二者求出世间。求出世间有上中下。上者利根大心求佛道。中者中根求辟支佛道。下者钝根求声闻道。为求佛道者说六波罗蜜及法空。为求辟支佛者说十二因缘及独行法。为求声闻者说众生空及四真谛法。声闻畏恶生死。闻众生空及四真谛无常苦空无我不戏论诸法。如围中有鹿既被毒箭一向求脱更无他念。辟支佛虽厌老病死。犹能少观甚深因缘。亦能少度众生。譬如犀在围中虽被毒箭。犹能顾恋其子。菩萨虽厌老病死。能观诸法实相究尽深入十二因缘。通达法空入无量法性。譬如白香象王在猎围中虽被箭射顾视猎者心无所畏。及将营从安步而去。以是故三藏中不多说法空。或有利根梵志求诸法实相不厌老病死。着种种法相为是故说法空。所谓先尼梵志不说五众即是实。亦不说离五众是实。复有强论梵志佛答我法中不受有无。汝何所论有无是戏论法结使生处。及杂阿含中大空经说二种空。众生空法空。罗陀经中说色众破裂分散令无所有。筏喻经中说。法尚应舍何况非法。波罗延经利众经中说。智者于一切法不受不着。若受着法则生戏论。若无所依止则无所论。诸得道圣人于诸法无取无舍。若无取舍能离一切诸见。如是等三藏中处处说法空。如是等名为一切法空

不可得空者。有人言。于众界入中我法常法不可得故。名为不可得空。有人言。诸因缘中求法不可得。如五指中拳不可得故名为不可得空。有人言。一切法及因缘毕竟不可得故名为不可得空。问曰。何以故。名不可得空。为智力少故不可得为实无故不可得。答曰。诸法实无故不可得。非智力少也。问曰。若尔者与毕竟空自相空无异。今何以故。更说不可得空。答曰。若人闻上诸空都无所有心怀怖畏生疑。今说所以空因缘以求索不可得故。为说不可得空断是疑怖故佛说不可得空。所以者何。佛言。我从初发心乃至成佛及十力佛。于诸法中求实不可得。是名不可得空。问曰。何事不可得。答曰。一切法乃至无余涅槃不可得故名为不可得空。复次行者得是不可得空。不得三毒四流四缚五盖六爱七使八邪九结十恶诸弊恶垢结等。都不可得故名为不可得空。问曰。若尔者行是不可得空得何等法利。答曰。得戒定慧。得四沙门果五根五无学众六舍法七觉分八圣道分九次第定十无学法。得如是等是声闻法。若得般若波罗蜜。则具足六波罗蜜及十地诸功德。问曰。上言一切法乃至涅槃不可得。今何以言得戒定慧乃至十无学法。答曰。是法虽得皆助不可得空故亦名不可得。又复无受无著故是名不可得。为无为法故名不可得。圣谛故名不可得。第一义谛故名不可得。圣人虽得诸功德入无余涅槃故不以为得。凡夫人以为大得。如师子虽有所作不自以为奇。余众生见以为希有。如是等义名为不可得空。无法空有法空无法有法空。无法空者。有人言。无法名法已灭。是灭无故名无法空。有法空者诸法因缘和合生故无有法。有法无故名有法空。无法有法空者。取无法有法相不可得。是为无法有法空。复次观无法有法空故名无法有法空。复次行者观诸法生灭。若有门若无门。生门生喜灭门生忧。行者观生法空则灭喜心。观灭法空则灭忧心。所以者何。生无所得。灭无所失。除世间贪忧故是名无法有法空。复次十八空中初三空破一切法。后三空亦破一切法。有法空破一切法生时住时。无法空破一切法灭时。无法有法空生灭一时俱破。复次有人言。过去未来法空是名无法空。现在及无为法空是名有法空。何以故。过去法灭失变异归无。未来法因缘未和合。未生未有未出未起。以是故名无法。观知现在法及无为法。现有是名有法。是二俱空故名为无法有法空。复次有人言。无为法无生住灭。是名无法。有为法生住灭。是名有法。如是等空名为无法有法空。是为菩萨欲住内空乃至无法有法空。当学般若波罗蜜

大智度论卷第三十一大智度论释初品中四缘义第四十九(卷三十二)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】菩萨摩诃萨。欲知诸法因缘次第缘缘缘增上缘。当学般若波罗蜜

【论】一切有为法皆从四缘生。所谓因缘次第缘缘缘增上缘。因缘者。相应因共生因自种因遍因报因。是五因名为因缘。复次一切有为法亦名因缘。次第缘者除阿罗汉过去现在末后心心数法。诸余过去现在心心数法。能与次第是名次第缘。缘缘增上缘者一切法。复次菩萨欲知四缘自相共相。当学般若波罗蜜。问曰。如般若波罗蜜中四缘皆不可得。所以者何。若因中先有果是事不然。因中先无亦不然。若先有则无因。若先无以何为因。若先无而有者亦可从无因而生。复次见果从因生故名之为因。若先无果云何名因

复次若果从因生果则属因。因不自在更属余因。若因不自在者云何言果。旦从此因生。如是种种则知无因缘。又过去心心数法都灭无所能作。云何能为次第缘。现在有心则无次第。若与未来欲生心次第者。未来则未有云何与次第。如是等则无次第缘。如是一切法无相无缘。云何言缘缘。若一切法无所属无所依皆平等。云何言增上缘。如是四缘不可得。云何说欲知四缘当学般若波罗蜜。答曰。汝不知般若波罗蜜相。以是故说般若波罗蜜中四缘皆不可得。般若波罗蜜于一切法无所舍无所破。毕竟清净无诸戏论。如佛说有四缘。但以少智之人着于四缘而生邪论。为破着故说言诸法实空无所破。如心法从内外处因缘和合生。是心如幻如梦虚诳无有定性。心数法亦如是。是心共生心数法。所谓受想思等是心数法。同相同缘故名为相应。心以心数法相应为因。心数法以心相应为因。是名相应因。相应因者。譬如亲友知识和合成事。共生因者。一切有为法各有共生因。以共生故更相佐助。譬如兄弟同生故互相成济。自种因者。过去善种现在未来善法因。过去现在善种未来善法因。不善无记亦如是。如是一切法各有自种因。遍因者。苦谛集谛所断结使。一切垢法因是名遍因。报因者。行业因缘故得善恶果报是为报因。是五因名为因缘。心心数法次第相续无间故名为次第缘。心心数法缘尘故生是名缘缘。诸法生时不相障碍是为无障。复次心心数法从四缘生。无想灭尽定从三缘生。除缘缘诸余心不相应诸行及色从二缘生。除次第缘缘缘有为法。性羸故无有从一缘生。报生心心数法从五因生。不隐没无记非垢法故除遍因。诸烦恼亦从五因生。除报因。何以故。诸烦恼是隐没。报是不隐没故除报因。报生色及心不相应诸行从四因生。色非心心数法故除相应因。不隐没无记法故除遍因。染污色及心不相应诸行亦从四因生。非心心数法故除相应因。垢故除报因。诸余心心数法除初无漏心皆从四因生。除报因遍因。所以者何。非无记故除报因。非垢故除遍因。诸余不相应法所谓色心不相应诸行。若有自种因则从三因生。除相应因报因遍因。若无自种因则从二因生。共生因无障因。初无漏心心数法从三因生。相应因共生因无障因。是初无漏心中色及心不相应诸行从二因生。共生因无障因。无有法从一因生。若六因生是名四缘。菩萨行般若波罗蜜。如是观四缘心无所著。虽分别是法而知其空皆如幻化。幻化中虽有种种别异。智者观之知无有实。但诳于眼为分别。知凡夫人法皆是颠倒虚诳而无有实故有四缘。如是云何为实。贤圣法因从凡夫法生故亦是不实。如先十八空中说。菩萨于般若波罗蜜中。无有一法定性可取故则不可破。以众生着因缘空法故名为可破。譬如小儿见水中月心生爱着。欲取而不能得心怀忧恼。智者教言虽可眼见不可手捉。但破可取不破可见。菩萨观知诸法从四缘生。而不取四缘中定相。四缘和合生如水中月。虽为虚诳无所有要从水月因缘生不从余缘。有诸法亦如是。各自从因缘生亦无定实。以是故说菩萨欲如实知因缘次第缘缘缘增上缘相。当学般若波罗蜜。问曰。若欲广知四缘义应学阿毗昙。云何此中欲知四缘义当学般若波罗蜜。答曰。阿毗昙四缘义初学如得其实。求之转深入于邪见。如汝上破四缘义中说

复次诸法所因因于四缘四缘复何所因。若有因则无穷若无穷则无始若无始则无因。若然者一切法皆应无因。若有始始则无所因。若无所因而有则不待因缘。若然者一切诸法亦不待因缘而有。复次诸法从因缘生有二种。若因缘中先有则不待因缘而生则非因缘。若因缘中先无则无各各因缘。以戏论四缘故。有如是等过。如般若波罗蜜中不可得空无如是等失。如世间人耳目所睹生老病死是则为有。细求其相则不可得。以是故般若波罗蜜中但除邪见而不破四缘。是故言欲知四缘相当学般若波罗蜜

【经】复次舍利弗。菩萨摩诃萨欲知一切诸法如法性实际。当学般若波罗蜜。舍利弗。菩萨摩诃萨应如是住般若波罗蜜

【论】诸法如有二种。一者各各相二者实相。各各相者。如地坚相水湿相火热相风动相。如是等分别诸法各自有相。实相者。于各各相中分别求实不可得不可破。无诸过失如自相空中说。地若实是坚相者。何以故胶蜡等与火会时舍其自性。有神通人入地如水又分散木石则失坚相。又破地以为微尘以方破尘终归于空亦失坚相。如是推求地相则不可得。若不可得其实皆空空则是地之实相。一切别相皆亦如是。是名为如。法性者如前说各各法空。空有差品是为如。同为一空是为法性。是法性亦有二种。一者用无著心分别诸法各自有性故。二者名无量法。所谓诸法实相。如持心经说。法性无量。声闻人虽得法性。以智慧有量故不能无量说。如人虽到大海以器小故不能取无量水是为法性。实际者。以法性为实证故为际。如阿罗汉名为住于实际。问曰。如法性实际是三事为一为异。若一云何说三。若三今应当分别说。答曰。是三皆是诸法实相异名。所以者何。凡夫无智于一切法作邪观。所谓常乐净实我等。佛弟子如法本相观。是时不见常是名无常。不见乐是名苦。不见净是名不净。不见实是名空。不见我是名无我。若不见常而见无常者是则妄见。见苦空无我不净亦如是。是名为如。如者如本无能败坏。以是故佛说三法为法印。所谓一切有为法无常印。一切法无我印。涅槃寂灭印。问曰。是三法印般若波罗蜜中悉皆破坏。如佛告须菩提。若菩萨摩诃萨观色常不行般若波罗蜜。观色无常不行般若波罗蜜。苦乐我无我寂灭非寂灭亦如是。如是云何名法印。答曰。二经皆是佛说。如般若波罗蜜经中了了说诸法实相。有人着常颠倒故舍常见。不着无常相是名法印。非谓舍常着无常者以为法印。我乃至寂灭亦如是。般若波罗蜜中破着无常等见。非谓破不受不着。得是诸法如已。则入法性中灭诸观不生异信性自尔故。譬如小儿见水中月入水求之不得便愁。智者语言性自尔莫生忧恼。善入法性是为实际。问曰。声闻法中何以不说是如法性实际。而摩诃衍法中处处说。答曰。声闻法中亦有说处但少耳。如杂阿含中说。有一比丘问佛十二因缘法。为是佛作为是余人作。佛告比丘。我不作十二因缘亦非余人作。有佛无佛诸法如法相法位常有。所谓是事有故是事有。是事生故是事生。如无明因缘故诸行。诸行因缘故识。乃至老死因缘故有忧悲苦恼。是事无故是事无。是事灭故是事灭。如无明灭故诸行灭。诸行灭故识灭。乃至老死灭故忧悲苦恼灭。如是生灭法有佛无佛常尔。是处说如。如杂阿含舍利弗师子吼经中说。佛问舍利弗一句义。三问三不能答。佛少开示。舍利弗已入于静室。舍利弗集诸比丘语诸比丘言。佛未示我事端未即能答。今我于此法七日七夜演说其事而不穷尽。复有一比丘白佛。佛入静室后。舍利弗作师子吼而自赞叹。佛语比丘。舍利弗语实不虚。所以者何。舍利弗善通达法性故。声闻法中观诸法生灭相是为如。灭一切诸观得诸法实相。是处说法性。问曰。是处但说如法性何处复说实际。答曰。此二事有因缘故说实际。无因缘故不说实际。问曰。实际即是涅槃。为涅槃故佛说十二部经。云何言无因缘。答曰。涅槃种种名字说。或名为离或名为妙或名为出。如是等则为说实际。但不说名字故言无因缘。复次诸法如者如诸法未生时生时亦如是。生已过去现在亦如是。诸法三世平等是名为如。问曰。若未生法名为未有生法。现在则有法可用因。现在法有事用相故追忆过事是名过去。三世各异不应如实为一。云何言三世平等是名为如。答曰。诸法实相中三世等一无异。如般若波罗蜜如品中说。过去如未来如现在如如来如一如无有异。复次先论议中已破生法。若无生法者未来现在亦无生云何不等。又复过去世无始未来世无后现在世无住。以是故三世平等名为如。行是如已入无量法性中。法性者法名涅槃。不可坏不可戏论。法性名为本分种。如黄石中有金性白石中有银性。如是一切世间法中皆有涅槃性。诸佛贤圣以智慧方便持戒禅定。教化引导令得是涅槃法性。利根者即知是诸法皆是法性。譬如神通人能变瓦石皆使为金。钝根者方便分别求之乃得法性。譬如大冶鼓石然后得金。复次如水性下流故会归于海合为一味。诸法亦如是。一切总相别相皆归法性同为一相是名法性。如金刚在山顶渐渐穿下至金刚地际到自性乃止。诸法亦如是。智慧分别推求已到如中从如入自性。如本末生灭诸戏论是名为法性。又如犊子周慞呜呼得母乃止。诸法亦如是。种种别异取舍不同。得到自性乃止。无复过处是名法性。实际者如先说法性名为实。入处名为际。复次一一法有九种。一者有体。二者各各有法。如眼耳虽同四大造而眼独能见。耳无见功。又如火以热为法而不能润。三者诸法各有力。如火以烧为力水以润为力。四者诸法各自有因。五者诸法各自有缘。六者诸法各自有果。七者诸法各自有性。八者诸法各有限碍。九者诸法各各有开通方便。诸法生时体及余法凡有九事。知此法各各有体法具足是名世间下如。知此九法终归变异尽灭是名中如。譬如此身生从不净出。虽复澡浴严饰终归不净。是法非有非无非生非灭。灭诸观法究竟清净。是名上如。复次有人言。是九事中有法者是名如。譬如地法坚重水法冷湿火法热照风法轻动心法识解。如是等法名为如。如经中说。有佛无佛如法相法位常住世间。所谓无明因缘诸行常如本法。法性者是九法中性。实际者九法中得果证。复次诸法实相常住不动。众生以无明等诸烦恼故。于实相中转异邪曲。诸佛贤圣种种方便说法。破无明等诸烦恼。令众生还得实性。如本不异是名为如。实性与无明合故变异则不清净。若除却无明等得其真性。是名法性清净实际名入法性中。知法性无量无边最为微妙。更无有法胜于法性出法性者。心则满足更不余求则便作证。譬如行道日日发引而不止息。到所至处无复去心。行者住于实际亦复如是。如罗汉辟支佛住于实际。纵复恒沙诸佛为其说法亦不能更有增进。又不复生三界。若菩萨入是法性中悬知实际。若未具足六波罗蜜教化众生。尔时若证妨成佛道。是时菩萨以大悲精进力故还修诸行。复次知诸法实相中无有常法。无有乐法无有我法无有实法。亦舍是观法。如是等一切观法皆灭。是为诸法实如涅槃不生不灭如本末生。譬如水是冷相假火故热。若火灭热尽还冷如本。用诸观法如水得火。若灭诸观法如火灭水冷。是名为如如实常住。何以故诸法性自尔。譬如一切色法皆有空分。诸法中皆有涅槃性是名法性。得涅槃种种方便法中皆有涅槃性。若得证时如法性则是实际。复次法性者。无量无边非心心数法所量是名法性。妙极于此是名真际

【经】复次舍利弗。菩萨摩诃萨欲数知三千大千世界中大地诸山微尘。当学般若波罗蜜。菩萨摩诃萨欲析一毛为百分。欲以一分毛尽举三千大千世界中大海江河池泉诸水而不扰水性者。当学般若波罗蜜。三千大千世界中诸火一时皆然。譬如劫尽烧时。菩萨摩诃萨欲一吹令灭者。当学般若波罗蜜。三千大千世界中诸大风起。欲吹破三千大千世界及诸须弥山如摧腐草。菩萨摩诃萨欲以一指障其风力令不起者。当学般若波罗蜜

【论】问曰。佛何以不赞叹诸菩萨六度等诸功德。而赞叹此大力。答曰。众生有二种。一者乐善法。二者乐善法果报。为乐善法者赞叹诸功德。为乐善法果报者赞叹大神力。复次有人言。四大之名其实亦无边无尽。常在世故无能悉动量其多少人。虽造作城廓台殿所用甚少。地之广大载育万物最为牢固。为是故佛说。三千大千世界中地。及须弥诸山微尘。皆欲尽知其数及一一微尘中众生业因缘各各有分。欲知其多少当学般若波罗蜜。问曰。一石土之微尘尚难可数。何况三千大千世界地及诸山微尘之数。是不可信。答曰。声闻辟支佛智慧尚不能知。何况凡夫。是事诸佛及大菩萨所知。如法华经说。譬喻三千大千世界地及诸山末以为尘。东方过千世界下一尘。如是过千世界复下一尘。如是尽三千世界诸尘。佛告比丘是微尘数世界算数筹量可得知不。诸比丘言。不可得知。佛言。所可着微尘不着微尘诸国。尽皆末以为尘。大通慧佛出世已来劫数如是。如是无量恒河沙等世界微尘。佛大菩萨皆悉能知。何况一恒河沙等世界。复次无量者随人心说。如大海水名为无量而深八万由旬。如大身罗睺阿修罗王量其多少不以为难。问曰。云何行般若波罗蜜得是智慧。答曰。有人行般若波罗蜜。灭诸烦恼及邪见戏论。入菩萨甚深禅定。念智清净增广故。则能分别一切诸色微尘知其量数。复次诸佛及大菩萨。得无碍解脱故。过于是事尚不以为难。何况于此。复次有人为地为坚牢心无形质皆是虚妄。以是故佛说心力为大。行般若波罗蜜故散此大地以为微尘。以地有色香味触重故自无所作。水少香故动作胜地。火少香味故势胜于水。风少色香味故动作胜火。心无四事故所为力大。又以心多烦恼结使系缚故令心力微少。有漏善心虽无烦恼。以心取诸法相故其力亦少。二乘无漏心虽不取相。以智慧有量及出无漏道时。六情随俗分别取诸法相故不尽心力。诸佛及大菩萨智慧无量无边常处禅定。于世间涅槃无所分别。诸法实相其实不异。但智有优劣。行般若波罗蜜者毕竟清净无所挂碍。一念中能数十方一切如恒河沙等。三千大千世界大地诸山微尘。何况十方各一恒河沙世界。复次若离般若波罗蜜虽得神通则不能如上所知。以是故说欲得是大神力当学般若波罗蜜。复有人言。一切诸物中水为最大。所以者何。大地上下四边无不有水。若护世天主不节量天龙雨。又无消水珠者则天地漂没。又以水因缘故。世间众生数非众生数皆得生长。以是可知水为最大。是故佛说菩萨欲知水渧多少渧渧分散令无力者。当学般若波罗蜜。复有人言。火为最大。所以者何。除香味故。又以水出处甚多而火能灭之。大火之力能烧万物能照诸闇。以是故知火为最大。是故佛说菩萨欲吹灭大火者。当学般若波罗蜜。问曰。火因于风乃得然炽云何相灭。答曰。虽复相因过则相灭。问曰。若尔者火多无量口风甚少何能灭之。答曰。菩萨行般若波罗蜜。因禅定得神通能变身令大。口风亦大故能灭之。又以神力小风能灭。譬如小金刚能摧破大山。以是故诸天世人见此神力皆悉宗伏。复次菩萨以火为害处广怜愍众生故以神力灭之。又以三千世界成立甚难菩萨福德智慧故力能制之复有人言。于四大中风力最大。无色香味故动相最大。所以者何。如虚空无边风亦无边。一切生育成败皆由于风。大风之势摧碎三千大千世界诸山。以是故佛说能以一指障其风力。当学般若波罗蜜。所以者何。般若波罗蜜实相无量无边。能令指力如是

【经】菩萨摩诃萨欲一结加趺坐遍满三千大千世界中虚空者。当学般若波罗蜜

【论】问曰。菩萨以何因缘故如是结加趺坐。答曰。以梵天王主三千世界。生邪见心自以为大。见菩萨结加趺坐遍满虚空则憍慢心息。又于神通力中巧方便故。一能为多多能为一。小能作大大能作小。亦为欲现希有难事故坐遍虚空。亦为遮诸鬼神龙王恼乱众生故坐满虚空。令众生安隐。如难陀婆难陀龙王兄弟。欲破舍婆提城。雨诸兵杖毒蛇之属。是时目连端坐遍满虚空。变诸害物皆成华香璎珞。以是故说菩萨摩诃萨欲一结加趺坐。遍满三千大千世界虚空。当学般若波罗蜜

【经】复次菩萨摩诃萨。欲以一毛举三千大千世界中诸须弥山王。掷过他方无量阿僧祇诸佛世界不扰众生者。当学般若波罗蜜

【论】问曰。菩萨何以故。举须弥山及诸山。过着他方无量世界。答曰。不必有举者此明菩萨力能举之耳。复次诸菩萨为佛当说法故。先庄严三千大千世界。除诸山令地平整。如法华经中说。佛欲集诸化佛故先平治地。亦欲现希有事令众生见故。所以者何。一须弥山高八万四千由旬。若举此一山已为希有。何况三千大千世界百亿须弥山。若以一毛举三千大千世界百亿须弥山尚难。何况以一毛头掷百亿须弥山过无量阿僧祇世界。众生见菩萨希有事。皆发阿耨多罗三藐三菩提心。作是念言。是菩萨未成佛道神力乃尔。何况成佛。以是故如是说

【经】欲以一食供养十方各如恒河沙等诸佛及僧。当学般若波罗蜜。欲以一衣华香璎珞末香涂香烧香灯烛幢幡华盖等。供养诸佛及僧。当学般若波罗蜜

【论】问曰。菩萨若以一食供养一佛及僧尚是难事。何况十方如恒河沙等诸佛及僧。答曰。供养功德在心不在事也。若菩萨以一食大心悉供养十方诸佛及僧。亦不以远近为碍。是故诸佛皆见皆受。问曰。诸佛有一切智故皆见皆受。僧无一切智云何得见云何得受。答曰。僧虽不见不知而其供养施者得福。譬如有人遣使供养彼人。彼人虽不得而此人已获施福。如慈三昧于众生虽无所施。而行者功德无量。复次诸菩萨无量无尽功德成就。以一食供养十方诸佛及僧。皆悉充足而亦不尽。譬如涌泉出而不竭。如文殊尸利以一钵欢喜丸供养八万四千僧。皆悉充足而亦不尽。复次菩萨于此以一钵食供养十方诸佛。而十方佛前饮食之具具足而出。譬如鬼神得人一口之食而千万倍出。复次菩萨行般若波罗蜜。得无量禅定门及得无量智慧方便门。以是故无所不能。以般若波罗蜜无碍故。是菩萨心所作亦无碍。是菩萨能供养十方千万恒河沙等诸佛及僧。何况各如一恒河沙。衣服华香璎珞末香涂香烧香灯烛幢幡华盖等亦如是

【经】复次舍利弗。菩萨摩诃萨欲使十方各如恒河沙等世界中众生。悉具于戒三昧智慧解脱解脱知见。令得须陀洹果斯陀含果阿那含果阿罗汉果。乃至令得无余涅槃。当学般若波罗蜜

【论】五众义如先说。须陀洹果有二种。一者佛说三结断得无为果。又如阿毗昙说。八十八结断得无为须陀洹果。二者信行法行人。住道比智中。得须陀洹果证者是。复次须陀洹名流。即是八圣道分。般那名入。入是八圣道分。流入涅槃是名初观诸法实相。得入无量法性分堕圣人数中。息忌名一伽弥名来。是人从此死生天上天上一来得尽众苦。阿那名不伽弥名来。是名不来相。是人欲界中死生色界无色界中。于彼漏尽不复来生。问曰。今世灭阿那伽弥中阴灭阿那伽弥。此亦不生色无色界。何以名为阿那伽弥。答曰。阿那伽弥。多生色无色界中现在灭者少以少从多故。中间灭者亦欲生色界见后身可患即取涅槃。以是故因多得名。阿罗汉尽一切烦恼故。应受一切天龙鬼神供养。是阿罗汉有九种。退法不退法死法护法住法胜进法不坏法慧解脱共解脱。九种义如先说。及八背舍八胜处十一切处。灭尽定无诤三昧愿智等。阿罗汉诸妙功德。及得无余涅槃无余涅槃名阿罗汉。舍此五众更不复相续受后。五众身心苦皆悉永灭。后三道果如初道说

【经】复次舍利弗。菩萨摩诃萨行般若波罗蜜布施时应作如是分别。如是布施得大果报。如是布施得生刹利大姓婆罗门大姓居士大家。如是布施得生四天王天处三十三天夜摩天兜率陀天化乐天他化自在天。因是布施得入初禅二禅三禅四禅无边空处无边识处无所有处非有想非无想处。因是布施能生八圣道分。因是布施能得须陀洹道乃至佛道。当学般若波罗蜜

【论】菩萨摩诃萨知诸法实相。无取无舍无所破坏。行不可得般若波罗蜜。以大悲心还修福行。福行初门先行布施。菩萨行般若波罗蜜。智慧明利能分别施福。施物虽同福德多少随心优劣。如舍利弗以一钵饭上佛。佛即回施狗而问舍利弗。汝以饭施我我以饭施狗谁得福多。舍利弗言。如我解佛法义。佛施狗得福多。舍利弗者于一切人中智慧最上。而佛福田最为第一。不如佛施狗恶田得福极多。以是故知大福从心生不在田也。如舍利弗千万亿倍不及佛心。问曰。如汝说福田妙故得福多。而舍利弗施佛不得大福。答曰。良田虽复得福多而不如心。所以者何。心为内主田是外事故。或时布施之福在于福田。如亿耳阿罗汉。昔以一华施于佛塔。九十一劫人天中受乐。余福德力得阿罗汉。又如阿输迦王。小儿时以土施佛王阎浮提。起八万塔最后得道。施物至贱小儿心簿。但以福田妙故得大果报。当知大福从良田生。若大中之上三事都具。心物福田三事皆妙。如般若波罗蜜初品中说。佛以好华散十方佛。复次又如以般若波罗蜜心布施。无所著故得大果报。复次为涅槃故施亦得大报。以大悲心为度一切众生故布施亦得大报。复次大果报者。如是中说生刹利家乃至得佛者是。问曰。云何布施得生刹利家。乃至得佛。答曰。若有人布施及持戒故。得人天中富贵。如有人至心布施持戒故生刹利家。刹利者王及大臣。若着于智慧经书而不恼众生。布施持戒故生婆罗门家。若布施持戒减少而乐着世乐生居士大家。居士者小人而巨富。若布施持戒清净小胜厌患家业。好乐听法供养善人生四天王处。所以者何。在彼有所须欲心生皆得常见。此间贤圣善人心生供养以近修福处故。若布施持戒清净。供养父母及其所尊心欲求胜。生三十三天。若布施持戒清净。而好学问其心柔和。生夜摩天。若布施持戒清净令二事转胜。好乐多闻分别好丑。爱乐涅槃心着功德生兜率天。若布施深心持戒多闻好乐学问自力生活生化乐天。若布施时清净持戒转深好乐多闻。自贵情多不能自苦从他求乐生他化自在天。他所思惟勤心方便。化作女色五欲夺而自在。譬如庶民苦身自业强力夺之。复次布施时以愿因缘故生天上。如经说。有人少行布施持戒不知禅定。是人闻有四天王天心常志愿。佛言。是人命终生四天上必有是处。乃至他化自在天亦如是。复次有人布施持戒修布施时其心得乐。若施多乐亦多。如是思惟舍五欲除五盖入初禅乃至非有想非无想天如是。四禅四无色定义如上说。复次有人布施佛及佛弟子从其闻说道法。是人因此布施故心得柔软。智慧明利即生八圣道分。断三结得须陀洹果。乃至佛道亦如是。因是布施闻其说法。便发阿耨多罗三藐三菩提心。复次未离欲布施生人中富贵及六欲天中。若离欲心布施生梵世天上乃至广果天。若离色心布施生无色天中。离三界布施为涅槃故得声闻道。布施时恶厌愦闹好乐闲静喜深智慧得辟支佛。布施时起大悲心欲度一切。为第一甚深毕竟清净智慧得成佛道

【经】复次舍利弗。菩萨摩诃萨行般若波罗蜜布施时。以慧方便力故能具足檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。舍利弗白佛言。世尊。菩萨摩诃萨云何布施时以慧方便力故。具足檀波罗蜜乃至般若波罗蜜。佛告舍利弗。施人受人财物不可得故。能具足檀波罗蜜。罪不罪不可得故。具足尸罗波罗蜜。心不动故具足羼提波罗蜜。身心精进不懈息故。具足毗梨耶波罗蜜。不乱不味故。具足禅波罗蜜。知一切法不可得故。具足般若波罗蜜

【论】具足义先已广说。慧方便今此中说。所谓三事不可得者是。问曰。慧方便者。能成就其事无所破坏更无所作。今破此三事应堕断灭云何言慧方便。答曰。有二种不可得。一者得不可得。二者不得不可得。得不可得者。堕于断灭。若不得不可得者。是为慧方便不堕断灭。若无慧方便布施者取三事相。若以三事空则取无相。有慧方便者从本以来不见三事相。以是故慧方便者不堕有无中。复次布施时坏诸烦恼是名慧方便。复次于一切众生起大悲心布施。是名慧方便。复次过去未来无量世所修福德布施。回向阿耨多罗三藐三菩提。亦名慧方便。复次于一切十方三世诸佛及弟子所有功德。忆念随喜布施。回向阿耨多罗三藐三菩提。是名慧方便。如是等种种力是为慧方便义。乃至般若波罗蜜慧方便亦如是

【经】复次舍利弗。菩萨摩诃萨欲得过去未来现在诸佛功德者。当学般若波罗蜜

【论】问曰。过去佛功德已灭。未来佛功德未有。现在佛功德不可得。又三世中佛功德皆不可得。云何言欲得三世佛功德当学般若波罗蜜。答曰。不言欲得三世佛功德自欲得。如三世佛功德无所减少耳。所以者何。一切佛功德皆等无多无少。问曰。若尔者何以言阿弥陀佛寿命无量光明千万亿由旬。无量劫度众生。答曰。诸佛世界种种有净不净有杂。如三十三天品经说。佛在三十三天安居自恣时。至四众久不见佛愁思不乐。遣目连白佛言。世尊。云何舍此众生住彼天上。时佛告目连。汝观三千世界。目连以佛力故观。或见诸佛为大众说法。或见坐禅或见乞食。如是种种施作佛事。目连即时五体投地。是时须弥山王跛[跳-兆+我]大动。诸天皆大惊怖。目连涕泣稽首白佛。佛有大悲不舍一切作如是种种化度众生。佛告目连。汝所见甚少。过汝所见东方有国纯以黄金为地。彼佛弟子皆是阿罗汉六通无碍。复过是东方有国纯以白银为地。彼佛弟子皆学辟支佛道。复过是东方有国纯以七宝为地。其地常有无量光明。彼佛所化弟子纯诸菩萨。皆得陀罗尼诸三昧门。住阿毗跋致地。目连当知。彼诸佛者皆是我身。如是等东方恒河沙等无量世界。有庄严者不庄严者。皆是我身而作佛事。如东方南西北方四维上下亦复如是。以是故当知。释迦文佛更有清净世界如阿弥陀国。阿弥陀佛亦有严净不严净世界如释迦文佛国。诸佛大悲彻于骨髓不以世界好丑。随应度者而教化之。如慈母爱子子虽没在厕溷。勤求拯拔不以为恶

大智度论卷第三十二大智度论释初品中到彼岸义第五十(卷三十三)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】复次舍利弗。菩萨摩诃萨欲到有为无为法彼岸者。当学般若波罗蜜

【论】彼岸者。于有为无为法尽到其边。云何是彼岸以大智慧悉知悉尽。有为法总相别相种种悉解。无为法中从须陀洹至佛悉皆了知。有为无为法相义如先说

【经】菩萨摩诃萨欲知过去未来现在诸法如诸法法相无生际者。当学般若波罗蜜

【论】问曰。上已说如。今何以更说。答曰。上直言诸法如今言三世皆如。上略说此广说。上说一此说三。法相即是法性。无生际即是实际。过去法如即是过去法相。未来现在亦如是。复次过去法如即是未来现在法如。现在法如即是过去未来法如。未来法如即是过去现在法如。所以者何。如相非一非异故。复次如先说二种如。一者世间如。二者出世间如。用是世间如三世各各异。用是出世间如三世为一

复次法相名诸法业诸法所作力因缘果报。如火为热相水为湿相。如是诸法中分别因缘果报各各别相。如是处非处力中说。是名世间法相。若是诸法相推求寻究。入无生法中更无过是者是名无生际。问曰。如法相可分别有三世。无生际是未来法云何有过去现在。如阿毗昙说。生法者过去现在。是无生法者未来及无为法。是云何欲令过去现在有无生。答曰。如先种种说破生法。一切法皆无生。何但未来无生。如一时义中已破三世。三世一相所谓无相。如是则无生相。复次无生名为涅槃。以涅槃不生不灭故。涅槃者末后究竟不复更生。而一切法即是涅槃。以是故佛说一切法皆是无生际

【经】复次舍利弗。菩萨摩诃萨欲在一切声闻辟支佛前。欲给侍诸佛。欲为诸佛内眷属。欲得大眷属。欲得菩萨眷属。欲得净报大施。当学般若波罗蜜

【论】问曰。若菩萨未得漏尽云何在漏尽圣人前。答曰。菩萨初发意时已在一切众生前。何况积劫修行。是菩萨功德智慧大故。世世常大能利益声闻辟支佛。众生知菩萨恩故。推崇敬重乃至畜生中亦为尊重。如菩萨昔作鹿其色如金其角七宝。五百鹿随逐宗事。若在人中好世作转轮圣王。恶世恒作大王护持佛法利益众生。若出家值有佛法则为世作大度师兴显佛法。若无佛法则为外道大师行四无量。阿罗汉辟支佛虽有无漏利益事少。譬如一升酥虽精不如大海水酪。菩萨虽有漏智慧及其成熟利益无量。复次罗汉辟支佛四事供养助道之具。多由菩萨得。如首楞严经说。文殊师利七十二亿作辟支佛。化辟支佛人令其成道。以是故在声闻辟支佛前。欲为诸佛给使者。如释迦文佛未出家时。车匿给使优陀耶戏笑。瞿毗耶耶输陀等诸婇女为内眷属。出家六年苦行时五人给侍。得道时弥喜罗陀须那刹多罗阿难密迹力士等是名内眷属。大眷属者。舍利弗目揵连摩诃迦叶须菩提迦旃延富楼那阿泥卢豆等诸圣人。及弥勒文殊师利颰陀婆罗诸阿毗跋致一生补处菩萨等。是名大眷属。复次佛有二种身。一者法性生身。二者随世间身。世间身眷属如先说。法性生身者。有无量无数阿僧祇一生补处菩萨侍从。所以者何。如不可思议解脱经说。佛欲生时八万四千一生补处菩萨在前导。菩萨从后而出。譬如阴云笼月。又如法华经说。从地踊出菩萨等皆是内眷属大眷属。菩萨眷属者。有佛纯以菩萨为眷属。有佛纯以声闻为眷属。有佛菩萨声闻杂为眷属。是故言但欲得菩萨为眷属者。当学般若波罗蜜。眷属有三上中下。下者纯声闻。中者杂。上者但菩萨。净报大施者。有人言。菩萨多集福德未除烦恼。受人信施未能净报。佛言菩萨行般若波罗蜜。诸法皆空不可得。何况诸结使。菩萨入法性中故不证真际。是故能净报施福。复次菩萨功德广大。从发心已来欲代一一众生受一切苦。欲以一切功德与一切众生。然后当自求佛道。但是事不可得故。而自成佛度一切众生。又菩萨志愿不以阿僧祇为拘。如世间及如法性实际虚空等久住菩萨心住世间利益众生故。亦如是久住无有穷已。是人不能净报施福者谁能净毕。如父母虽有结使诸恶。以一世利益子故。受其供养令子得大福。何况菩萨无诸结使。而住无边世中利益众生而不净毕。又复菩萨但有悲心而无般若尚能利益。何况行般若波罗蜜。问曰。若菩萨无结使云何世间受生。答曰。先已答。菩萨得无生法忍得法性生身处处变化以度众生庄严世界。是功德因缘故虽未得佛能净报施福

【经】复次舍利弗。菩萨摩诃萨欲不起悭心破戒心嗔恚心懈怠心乱心痴心者。当学般若波罗蜜

【论】是六种心恶故。能障蔽六波罗蜜门。如菩萨行布施时。若有悭心起令布施不清净。所谓不能以好物施。若与好物不能多与。若与外物则不能内施。若能内施不能尽与。若由悭心故。菩萨行般若波罗蜜。知一切法无我无我所。诸法皆空如梦如幻。以身头目骨髓布施如施草木。是菩萨虽未得道。欲常不起是悭心。当学般若波罗蜜。诸余人离欲得道故不生破戒心。菩萨行般若波罗蜜故不见破戒事。所以者何。戒为一切诸善功德住处。譬如地为一切万物所依止处。破戒尚不得余道。何况阿耨多罗三藐三菩提。以是故不生破戒心。复作是念。菩萨法者安乐众生。若破戒者恼乱一切。以是故菩萨不生破戒心。何况破戒。小乘及诸凡夫尚不应生嗔恚心。何况菩萨发阿耨多罗三藐三菩提意。身为苦器法自受恼。譬如犯罪之人自致刑戮自作自受不应怨人。但当自护其心不令起恶。譬如人遭恶风雨寒热亦无所嗔。复作是念。菩萨求佛以大悲为本。若怀嗔恚则丧志愿。嗔恚之人尚不得世间乐何况道乐。嗔恚之人自不得乐。何能以乐与人。懈怠之人世间胜事尚不能成。何况阿耨多罗三藐三菩提。譬如钻火数息无得火期。散乱之心譬如风中然灯。虽有光明不能照物。乱心中智慧亦复如是。智慧是一切善法根本。若欲成就是智先当摄心然后可成。譬如狂醉之人自利他利好丑之事都不觉知。散乱之心亦如是。世间好事尚不能善知。何况出世间法。愚痴人心一切成败事皆不能及。何况微妙深义。譬如无目之人或坠沟坑或入非道。无智之人亦复如是。无智慧眼故受着邪法不受正见。如是之人世间近事尚不能成。何况阿耨多罗三藐三菩提。菩萨行般若波罗蜜力故。能障是六蔽净六波罗蜜。以是故说若欲不起六蔽。当学般若波罗蜜

【经】复次舍利弗。菩萨摩诃萨欲使一切众生立于布施福处持戒福处修定福处劝导福处。欲令众生立于财福法福处。当学般若波罗蜜

【论】问曰。云何名为福处。答曰。阿毗昙言。福者善有漏身口意业。复有人言。不隐没无记是。所以者何。善有漏业因缘果报故。得是不隐没无记。福是果报亦名为福。如世间人说能成大事多所成办是名福德人。是福略说三种。布施持戒修定。何等是布施。有人以衣服卧具饮食花香璎珞等与人。是名布施。问曰。饮食等物便是布施。为更有布施。答曰。饮食等物非布施。以饮食等物与时。心中生法名舍。与悭心相违。是名布施。福德是或有漏或无漏。常是善心数法心相应随心行共心生。无色无形能作缘业相应随业行业共生。非先业果报得。修行修慧证身证凡夫人得亦圣人得。有人言。是舍法相应思是名布施福德。所以者何。业能生果报故。思即是业。身口不名为业。从思生故得名业。此布施有二种。一者净二者不净。不净者直施而已。或畏失财故与。或恶诃骂故与。或无用故与。或亲爱故与。或为求势故与。以施故多致势援。或死急故与。或求善名誉故与。或求与贵胜齐名故与。或妒嫉故与。或憍慢故与。小人愚贱尚施我为贵重大人云何不与。或为咒愿福德故与。或求吉除凶故与。或求入伴傥故与。或不一心不恭敬轻贱受者而与。如是种种因缘。为今世事故施。与净相违名为不净。净施者如经中说。治心故施。庄严意故施为得第一利故施。生清净心能分别为助涅槃故施。譬如新花未萎色好且香。净心布施亦复如是。如说诸天不净心布施者宫殿光明薄少。若净心布施者宫殿光明增广。此布施业虽过去乃至千万世中不失。譬如券要。问曰。此布施福云何增长。答曰。应时施故得福增长。如经说。饥饿时施得福增多。或远行来时若旷路险道中施。若常施不断。或时常念施故施福增广。如六念中念舍说。若大施故得福多。若施好人若施佛若施者受者清净故。若决定心施。若自以力致财施。若随所有多少能尽施。若交以物施。若以园田使人等施。如是布施唯有菩萨能以深心行之。如韦罗摩菩萨。十二年布施已庄饰乳牛七宝钵及婇女各有八万四千。及诸余物饮食之属不可胜数。又如须帝[(匕/示)*(入/米)]拏菩萨。下善胜白象施与怨家。入在深山以所爱二子施十二丑婆罗门。复以妻及眼施化婆罗门。尔时地为大动天为雷震。空中雨花。又如萨婆达多王。自缚其身施婆罗门。如尸毗王。为一鸽故自持其身以代鸽肉。又如菩萨曾为兔身自炙其肉施与仙人。如是等菩萨本生经中所说。复有声闻人布施。如须弥陀比丘尼。与二同学为迦那伽牟尼佛作精舍。于无数千万世受转轮圣王及天王福。如施婆罗门。持一瓶酪施僧世世受乐。今得阿罗汉诸受乐中受乐第一。如末利夫人。供养须菩提故得今世果报。为波斯尼示王后。如尸婆供养迦栴延故得今世果报。为栴陀波周陀王后。如郁伽陀居士。供养舍利弗等五百阿罗汉故。即日得果报。五百贾客得其余食。人人以珠璎珞与之卒得大富。遂号卒伽陀。如是等布施得今世果报。当知布施论议说不可尽。持戒福处者。佛说五戒福者是。问曰。云何杀罪相。答曰。知是众生故夺命得杀罪。非不故安隐快心得杀罪。非散乱狂心夺命得杀罪。非作疮死已得杀罪。非未死身业是杀罪。非口杀身作是杀罪。非但心生如是等罪止不作。是初戒善相。或有人言。谓是不隐没无记。或欲界系或不系。是非心非心数法非心相应非随心行。或共心生或不共心生。非业相应非随业行。或共业生或不共业生。非先业果报得。修行修身证慧证或思惟断或不断。离欲界欲时得断。知凡夫圣人共有是名说不杀生戒相。余戒亦如是。随义分别诸戒赞叹论议。如尸罗波罗蜜中说。修定福处者。虽经中说修慈是修定福。亦说有漏禅定能生果报者总名修定福。以欲界多嗔多乱故先说慈心为修定福得。慈方便愿与众生乐。后实见受乐是心相应法名为慈法。是法或色界系或不系是为真慈。是方便慈欲界系。常随心行随心生无形无对能缘法非业。业相应而随业行共业生。非先业果报得。修行修身证慧证。或思惟断或不断。离色界欲时得断。知有觉有观亦无觉有观亦无觉无观。或有喜或无喜或有息或无息亦凡夫人亦圣人。或乐受相应或不苦不乐受相应。先缘得解相后缘实义。根本四禅中亦过四禅依止四禅。得者牢固有力。慈应言亲爱无怨无诤故名为亲爱。能缘无量众生故名为无量能利益众生。能离欲故名为梵行。慈心余论议如四无量中说。问曰。修定福中。佛何以但说慈心不说余。答曰。四无量中慈心能生大福德。悲心忧愁故舍福德。喜心自念功德故福德不深。舍心放舍故福亦少。复次佛说慈心有五利不说余。何等五。一者刀不伤。二者毒不害。三者火不烧。四者水不没。五者于一切嗔怒恶害众生中见皆欢喜。悲心等三事不尔。以是故说修定福为慈。余者随从及诸能生果报有漏定。劝导福处者。若比丘不能坐禅不能诵经。教化劝导修立福德。或有比丘能坐禅诵经。见诸比丘衣食乏少。力能引致亦行劝导。及诸菩萨怜愍众生故以福德因缘劝化之。又出家人若自求财于戒有失。是故劝导以为因缘。财福者。衣服饮食卧具医药金银车马田宅等。问曰。上言布施福处此言财福有何等异。答曰。布施者。总摄一切施财施法施俗施道施。今欲分别法施财施。法施者如佛以大慈故初转法轮无量众生得道。后舍利弗逐佛转法轮。余诸圣人虽非转法轮亦为众生说法得道。亦名法施。复有遍吉菩萨观世音得大势文殊师利弥勒菩萨等。以二种神通力。果报神通修得神通住是中以福德方便力光明神足等种种因缘开度众生亦名法施。诸辟支佛飞腾虚空而说一偈。引导众生令殖善根亦名法施。又佛弟子未得圣道者坐禅诵经。不坏诸法相教化弟子皆名法施。如是等种种名为法施相。以是故说菩萨欲立众生于六种施福者。当学般若波罗蜜

【经】复次舍利弗。菩萨摩诃萨欲得五眼者。当学般若波罗蜜

【论】何等五。肉眼天眼慧眼法眼佛眼。肉眼见近不见远见前不见后见外不见内见昼不见夜见上不见下。以此碍故求天眼。得是天眼远近皆见。前后内外昼夜上下悉皆无碍。是天眼见和合因缘生假名之物不见实相。所谓空无相无作无生无灭。如前中后亦尔。为实相故求慧眼。得慧眼不见众生。尽灭一异相舍离诸着不受一切法。智慧自内灭是名慧眼。但慧眼不能度众生。所以者何。无所分别故。以是故求法眼。法眼令是人行是法得是道。知一切众生各各方便门令得道证。法眼不能遍知度众生方便道。以是故求佛眼。佛眼无事不知。覆障虽密无不见知。于余人极远于佛至近。于余幽闇于佛显明。于余为疑于佛决定。于余微细于佛为粗。于余甚深于佛甚浅。是佛眼无事不闻无事不见。无事不知无事为难。无所思惟一切法中佛眼常照。后品五眼义中当广说

【经】菩萨摩诃萨。欲以天眼见十方如恒河沙等世界中诸佛。欲以天耳闻十方诸佛所说法。欲知诸佛心。当学般若波罗蜜

【论】天眼法所见不过三千大千世界。今以般若波罗蜜力故见十方恒河沙等国中诸佛。所以者何。般若波罗蜜中。无近无远无所挂碍故。问曰。如般舟经说。以般舟三昧力故虽未得天眼而能见十方现在诸佛。此菩萨以天眼故见十方诸佛有何等异。答曰。此天眼不隐没无记。般舟三昧离欲人未离欲人俱得。天眼但是离欲人得。般舟三昧忆想分别常修常习故见。天眼修神通得。色界四大造色眼四边得遍明相是为差别。天眼功易譬如日出见色不难。三昧功难如夜然灯见色不易。天耳亦如是。知诸佛心者。问曰。如上地钝根不能知下地利根心。菩萨一佛心尚不应知。何况恒河沙等十方诸佛心。答曰。以佛神力故令菩萨知。如经说。一切众生无知佛心者。若佛以神力令知。乃至昆虫亦能知。以是故佛以神力故令菩萨知佛心。复次般若波罗蜜无碍相粗细深浅愚圣都无差别。诸佛心如菩萨心如一如无异。菩萨随是如故能知诸佛心。复次希有难事不应知而知。以是故言欲得是者。当学般若波罗蜜

【经】欲闻十方诸佛所说法。闻已乃至阿耨多罗三藐三菩提不忘者。当学般若波罗蜜

【论】问曰。一佛所说犹尚难持。何况无量诸佛所说欲忆而不忘。答曰。菩萨以闻持陀罗尼力故。能受坚忆念。陀罗尼力故不忘。复次此中说以般若波罗蜜力毕竟清净无所著。譬如大海含受众流。菩萨从十方诸佛所闻法。以般若波罗蜜器大故。能受无量法持而不忘。复次是般若波罗蜜不可譬喻如虚空。如劫烧尽已大雨弥满。是雨除虚空更无处能受。十方诸佛说法雨从佛口出。除行般若波罗蜜菩萨更无能受者。以是故言欲闻十方诸佛说法。当学般若波罗蜜

    大智度论释初品中见一切佛世界义第五十一之一

【经】复次舍利弗。菩萨摩诃萨欲见过去未来诸佛世界。及见现在十方诸佛世界。当学般若波罗蜜

【论】问曰。若见十方佛则已见世界。今何以复说欲见世界。答曰。菩萨未深入禅定。若见十方世界山河草木。心则散乱故但观诸佛。如念佛义中说。行者但观诸佛不观土地山河树木。得禅定力已随意广观。复次诸清净佛国难见故。言欲见诸佛国。当学般若波罗蜜。又一佛有无量百千种世界如先说。有严净有不严净。有杂有毕竟清净世界。难见故以般若波罗蜜力乃能得见。譬如天子听正殿则外人可见。内殿深宫无能见者。问曰。十方现在世界可见。过去未来诸佛世界云何得见。答曰。菩萨有见过去未来三昧。入是三昧已见过去未来事如梦中所见。复次菩萨有不灭际三昧。入是三昧已不见诸佛有灭者。问曰。此二法非眼云何能见。答曰。此是智慧假名为眼。如转法轮中于四谛中得眼智明觉。复次菩萨见十方现在佛世界。定知过去未来诸佛世界亦尔。所以者何。一切诸佛功德同故。是事如先说。复次是般若波罗蜜中。如现在过去未来等无异。一如一法性故。以是故不应难

【经】复次舍利弗。菩萨摩诃萨欲闻十方诸佛所说十二部经修多罗．祇夜．受记经．伽陀．优陀那．因缘经．阿波陀那．如是语经．本生经．广经．未曾有经．论议经。诸声闻等闻与不闻尽欲诵受持者。当学般若波罗蜜

【论】先说尽欲闻十方诸佛所说法者。当学般若波罗蜜。所说法者即此十二部经。诸经中直说者名修多罗。所谓四阿含诸摩诃衍经。及二百五十戒经。出三藏外亦有诸经。皆名修多罗。诸经中偈名祇夜。众生九道中受记。所谓三乘道六趣道。此人经尔所阿僧祇劫当作佛。若记尔所岁当作佛。记声闻人今世后世得道。记辟支佛但后世得道。记余六道亦皆后世受报。诸佛法欲与众生受记。先皆微笑无量种光从四牙中出。所谓青黄赤白缥紫等。从上二牙出者光照三恶道。从其光明演无量法。说一切作法无常一切法无我安隐涅槃。众生得遇斯光闻说法者。身心安乐得生人中天上。从是因缘皆得毕苦。从下二牙出者上照人天乃至有顶禅。若聋盲喑哑狂病皆得除愈。六欲天人及阿修罗受五欲乐。遇佛光明闻说法声。皆厌患欲乐身心安隐。色界诸天受禅定乐时。遇佛光明闻说法声。亦生厌患来诣佛所。此诸光明复至十方遍照六道。作佛事已还绕身七匝。若记地狱光从足下入。若记畜生光从[跳-兆+尃]入。若记饿鬼光从髀入。若记人道光从齐入。若记天道光从胸入。若记声闻光从口入。若记辟支佛光从眉间相入。若记得佛光从顶入。若欲受记先现此相。然后阿难等诸弟子发问。一切偈名祇夜。六句三句五句。句多少不定亦名祇夜亦名伽陀。优陀那者名有法。佛必应说而无有问者。佛略开问端如佛在舍婆提毗舍佉堂上阴地经行。自说优陀那。所谓无我无我所是事善哉。尔时一比丘合掌白佛言。世尊。云何无我无我所是事善哉。佛告比丘。凡夫人未得无漏道。颠倒覆心故于无我无我所心大惊怖。若佛及佛弟子闻好法者欢喜奉行。无颠倒故不复更作。如是等杂阿含中广说。又如般若波罗蜜品中。诸天子赞须菩提所说。善哉善哉希有世尊。难有世尊。是名优陀那。又如佛涅槃后诸弟子抄集要偈诸无常偈等作无常品。乃至婆罗门偈等作婆罗门品。亦名优陀那。诸有集众妙事。皆名优陀那。如是等名优陀那经相。尼陀那者说诸佛法本起因缘。佛何因缘说此事。修多罗中有人问故为说是事。毗尼中有人犯是事故结是戒。一切佛语缘起事皆名尼陀那。阿波陀那者与世间相似柔软浅语。如中阿含中长阿波陀那经。长阿含中大阿波陀那。毗尼中亿耳阿波陀那。二十亿阿波陀那解。二百五十戒经中欲阿波陀那一部。菩萨阿波陀那出一部。如是等无量阿波陀那。如是语经者有二种。一者结句言我先许说者今已说竟。二者三藏摩诃衍外更有经名一目多迦。有人言目多迦。目多迦名出三藏及摩诃衍。何等是。如佛说。净饭王强令出家作佛弟子者佛选择五百人堪任得道者。将至舍婆提。所以者何。以其未离欲。若近亲里恐其破戒故将至舍婆提。令舍利弗目干连等教化之。初夜后夜专精不睡。勤修精进故得道。得道已佛还将至本生国。一切诸佛法还本国时与大会诸天众俱住迦毗罗婆仙人林中。此林去迦毗罗婆城五十里。是诸释游戏园。此诸释子比丘处舍婆提。时初夜后夜专精不睡故。以夜为长从林中来。入城乞食。觉道里长远。尔时佛知其心有一师子来礼佛足在一面住。佛以是三因缘故说偈

  不寐夜长　　疲惓道长　　愚生死长
  莫知正法

佛告比丘。汝未出家时其心放逸多睡眠故不觉夜长。今初夜后夜专精求道减省睡眠故觉夜大长。此迦毗罗婆林。汝本驾乘游戏不觉为远。今着衣持钵步行疲极故觉道长。是师子鞞婆尸佛时作婆罗门师。见佛说法来至佛所。尔时大众以听法故无共语者。即生恶念发恶骂言。此诸秃辈与畜生何异。不别好人不知言语。以是恶口业故。从鞞婆尸佛乃至今日。九十一劫常堕畜生中。此人尔时即应得道。以愚痴故自作生死长久。今于佛所心清净故当得解脱。如是等经名为出因缘。于何处出。于三藏摩诃衍中出故名为出。云何名因缘。是三事之本名为因缘经。本生经者。昔者菩萨曾为师子在林中住。与一猕猴共为亲友。猕猴以二子寄于师子。时有鹫鸟饥行求食。值师子睡故取猴子而去住于树上。师子觉已求猴子不得。见鹫持在树上而告鹫言。我受猕猴寄托二子护之不谨。令汝得去。孤负言信请从汝索。我为兽中之王。汝为鸟中之主。贵势同等宜以相还。鹫言汝不知时吾今饥乏何论同异。师子知其叵得自以利爪掴其胁肉以贸猴子。又过去世时人民多病黄白痿热。菩萨尔时身为赤鱼。自以其肉施诸病人以救其疾。又昔菩萨作一鸟身在林中住。见有一人入于深水非人行处。为水神所罥水神罥法着不可解。鸟知解法至香山中取一药草着其罥上。绳即烂坏人得脱去。如是等无量本生多有所济。是名本生经。广经者名摩诃衍。所谓般若波罗蜜经六波罗蜜经华首经法华经佛本起因缘经云经法云经大云经。如是等无量阿僧祇诸经。为得阿耨多罗三藐三菩提故说毗佛略(吕夜反秦言未曾有)经。如佛现种种神力众生怪未曾有。所谓佛生时身放大光明。照三千大千世界及幽闇之处。复照十方无量诸佛三千大千世界。是时于佛母前有清净好池以浴菩萨。梵王执盖帝释洗身二龙吐水。又生时不须扶持而行七步。足迹之处皆有莲华。而发是言。我是度一切众生老病死者。地大震动天雨众花树出音声作天伎乐。如是等无量希有事是名未曾有经。论议经者。答诸问者释其所以。又复广说诸义。如佛说四谛。何等是四。所谓四圣谛。何等是四。所谓苦集灭道圣谛是名论议。何等为苦圣谛。所谓生苦等八种苦。何等是生苦。所谓诸众生各各生处是中受苦。如是等问答广解其义。是名优波提舍。如摩诃衍中佛说六波罗蜜。何等六。所谓檀波罗蜜乃至般若波罗蜜。何等是檀波罗蜜。檀波罗蜜有二种。一者具足。二者不具足。何等是具足。与般若波罗蜜和合。乃至十住菩萨所得是名具足。不具足者。初发菩萨心未得无生忍。法未与般若波罗蜜和合是名不具足。乃至禅波罗蜜亦如是。般若波罗蜜具足者有方便力。未具足者无方便力。复次佛所说论议经。及摩诃迦栴延所解修多罗。乃至像法凡夫人如法说者亦名优波提舍。声闻所不闻者。佛独与菩萨说法。无诸声闻听者。又佛以神通力变身无数。遍至十方一乘世界说法。又复佛为欲天色天说法。无诸弟子故不得闻。问曰。诸六通阿罗汉。若佛说时虽不在坐以天耳天眼可得见闻。若以宿命通并知过去事何以不闻。答曰。诸声闻神通力所不及处。是故不闻。复次佛为诸大菩萨说不可思议解脱经。舍利弗目连在佛左右而不得闻。以不种是闻大乘行法因缘故。譬如坐禅人入一切处定中。能使一切皆水皆火而余人不见。如不可思议解脱经中广说。尽欲受持者闻而奉行为受。久久不失为持

大智度论卷第三十三大智度论释初品中见一切佛世界义第五十一之余(卷三十四)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】复次舍利弗。菩萨摩诃萨十方如恒河沙等世界中诸佛所说法。已说今说当说。闻已欲一切信持自行亦为人说者。当学般若波罗蜜

【论】问曰。上已说十方诸佛所说欲忆持不忘当学般若。今何以复说信持三世佛法。答曰。上说欲忆持十方诸佛法未知是何法故。说十二部经是佛法。及声闻所不闻者。上但言恒河沙等世界诸佛。今言恒河沙三世诸佛法。又上但说受持不忘不说受持利益。今言自为亦为他人说是故复说

【经】复次舍利弗。菩萨摩诃萨过去诸佛说已。未来诸佛当说。欲闻闻已自利亦利他人。当学般若波罗蜜

【论】问曰。十方现在佛所说法可受可持。过去已灭未来未有云何可闻。答曰。此义先已答。今当更说。菩萨有三昧名观三世诸佛三昧。菩萨入是三昧中。悉见三世诸佛闻其说法。譬如外道神仙。于未来世事未有形兆未有言说。以智慧力故亦见亦闻。复次诸菩萨力不可思议。未来世虽未有形未有言说而能见能闻。或以陀罗尼力。或以今事比知过去未来诸事。以是故言欲得是者当学般若波罗蜜

【经】十方如恒河沙等诸世界中间闇处日月所不照。欲持光明普照者。当学般若波罗蜜

【论】菩萨从兜率天上欲降神母胎。尔时身放光明遍照一切世界及世间幽冥之处。次后生时光明遍照亦复如是。初成道时转法轮时般涅槃时放大光明皆亦如是。及于余时现大神通放大光明。如欲说般若波罗蜜时。现大神通以大光明遍照世间幽冥之处。如是比处处经中说神通光明。问曰。此是佛力何以故说菩萨。答曰。今言菩萨欲得是者当学般若波罗蜜。诸大菩萨能有是力。如遍吉菩萨观世音得大势明网无量光菩萨等能有是力。身出无量光明能照十方如恒河沙等世界。又如阿弥陀佛世界中诸菩萨。身出常光照十万由旬。问曰。菩萨身光如是本以何业因缘得。答曰。身业清净故身得庄严。如经说。有一鬼头似猪臭虫从口出身有金色光明。是鬼宿世作比丘恶口骂詈客比丘。身持净戒故身有光明。口有恶言故臭虫从口出。如经说。心清净优劣故光有上中下。少光大光光音欲界诸天心清净布施持戒故身有光明。复次有人怜愍众生故于闇处然灯。亦为供养尊像塔寺故。亦以明珠户向明镜等明净物布施故身有光明。复次常修慈心遍念众生心清净故。又常修念佛三昧念诸佛光明神德故得身光明。复次行者常修火一切入。又以智慧光明教化愚闇邪见众生以是业因缘故。得心中智慧明身亦有光。如是等业因缘得身光清净

【经】十方如恒河沙等世界中无有佛名法名僧名。欲使一切众生皆得正见闻三宝音者。当学般若波罗蜜

【论】菩萨于先无佛法塔寺处。于中起塔。以是业因缘后身得力成就。于无佛法众处赞叹三宝。令众生入于正见。如经说。有人于先无佛塔国土中修立塔庙得梵福德梵名无量福德。以是因缘疾得禅定。得禅定故得无量神通。神通力故能到十方赞叹三宝正见者。若先不识三宝功德。因菩萨故得信三宝。信三宝故信业因缘罪福。信业因缘故信世间是缚涅槃是解。赞叹三宝义如八念中说

【经】菩萨摩诃萨欲令十方如恒河沙等世界中众生。以我力故盲者得视聋者得听狂者得念裸者得衣饥渴者得饱满者。当学般若波罗蜜

【论】菩萨行无碍般若波罗蜜。若得无碍解脱成佛。若作法性生身菩萨。如文殊师利等。在十住地有种种功德具足。众生见者皆得如愿。譬如如意珠所欲皆得。法性生身佛及法性生身菩萨。人有见者皆得所愿亦复如是。复次菩萨从初发意已来。于无量劫中治一切众生九十六种眼病。又于无量世中自以眼布施众生。又智慧光明破邪见黑闇。又以大悲欲令众生所愿皆得。如是业因缘云何令众生见菩萨身而不得眼。余事亦如是。此诸义如放光中说

【经】复次舍利弗。菩萨摩诃萨若欲令十方如恒沙等世界中众生诸在三恶趣者。以我力故皆得人身者。当学般若波罗蜜

【论】问曰。自以善业因缘故得人身。云何菩萨言以我力因缘故。令三恶道中众生皆得人身。答曰。不言以菩萨业因缘令众生得人身。但言菩萨恩力因缘故得。菩萨以神通变化说法力故。令众生修善得人身。如经中说。二因缘发起正见。一者外闻正法。二者内有正念。又如草木内有种子外有雨泽然后得生。若无菩萨众生虽有业因缘无由发起。以是故知诸佛菩萨所益甚多。问曰。云何能令三恶道中众生皆得解脱。佛尚不能何况菩萨。答曰。菩萨心愿欲尔则无过咎。又多得解脱故言一切。如诸佛及大菩萨身遍出无量光明。从是光明出无量化身。遍入十方三恶道中。令地狱火灭汤冷。其中众生心清净故生天上人中。令饿鬼道饥渴饱满。开发善心得生天人中。令畜生道随意得食。离诸恐怖开发善心亦得生天人中。如是名为一切三恶道得解脱。问曰。如余经说生天人中。此何以但说皆得人身。答曰。于人中得修大功德亦受福乐。天上多着乐故不能修道。以是故愿令皆得人身。复次菩萨不愿众生但受福乐。欲令得解脱常乐涅槃。以是故不说生天上

【经】欲令十方如恒河沙等世界中众生。以我力故立于戒三昧智慧解脱解脱知见。令得须陀洹果乃至阿耨多罗三藐三菩提者。当学般若波罗蜜

【论】问曰。先已说此五众道果。今何以更说。答曰。上说但是声闻法从须陀洹乃至无余涅槃。今杂说三乘声闻辟支佛。乃至阿耨多罗三藐三菩提

【经】复次舍利弗。菩萨摩诃萨欲学诸佛威仪者。当学般若波罗蜜

【论】问曰。何等是诸佛威仪。答曰。威仪名身四动止。譬如象王回身而观行时足离地。四指虽不蹈地而轮迹现。不迟不疾身不倾动。常举右手安慰众生。结加趺坐其身正直。常偃右胁累膝而卧。所敷草蓐齐整不乱。食不着味美恶等。一若受人请默然无违。言辞柔渜方便利益不失时节。复次法身佛威仪者。过东方如恒河沙等世界以为一步。梵音说法亦复如是。法身佛相义如先说

【经】复次菩萨摩诃萨欲得如象王视观者。当学般若波罗蜜。菩萨作是愿。使我行时离地四指足不蹈地。我当共四天王天乃至阿迦尼吒天无量千万亿诸天众围绕恭敬至菩提树下者。当学般若波罗蜜

【论】如象王视者。若欲回身观时举身俱转。大人相者。身心专一。是故若有所观身心俱回。譬如师子有所搏撮。不以小物故而改其壮势。佛亦如是。若有所观若有所说。身与心俱常不分散。所以者何。从无数劫来集一心法。以是业因缘故顶骨与身为一无有分解。又以世世破憍慢故不轻众生观则俱转。如尼陀阿波陀那中说。舍婆提国除粪人。而佛以手摩头教令出家犹不轻之。足离地四指者。佛若常飞。众生疑怪谓佛非是人类则不归附。若足到地则众生以为与常人不异不生敬心。是故虽为行地四指不到而轮迹现。问曰。如佛常放丈光足不到地。众生何以故不尽敬附。答曰。众生无量劫中积罪甚重。无明垢深于佛生疑。谓是幻师以术诳人。或言足不蹈地生性自尔。如鸟能飞有何奇特。或有众生。罪重因缘故不见佛相。直谓大威德沙门而已。譬如人重病欲死名药美食皆谓臭秽。是故不尽敬附。共四天王乃至阿迦尼吒无量千万亿诸天众恭敬围绕至菩提树下者。是诸佛常法。佛为世尊。至菩提树下欲破二种魔。一者结使魔。二者自在天子魔。欲成一切智。是诸天众云何不恭敬侍送。又诸天世世佐助拥护菩萨。乃至出家时令诸宫人婇女淳惛而卧。捧马足踰城出。今日事办。我等当共侍送至菩提树下。问曰。何以不说刹利婆罗门等无量人侍送。而但说诸天。答曰。佛独于深林中求菩提树。非是人行处。是故不说。又以人无天眼他心智故。不知佛当成道。是故不说。复次诸天贵于人故但说天。复次诸佛常乐闲静处。诸天能隐身不现不妨闲静。是故但说诸天从。复次菩萨见五比丘舍菩萨而去。而菩萨独至树下。是故作是愿

【经】我当于菩提树下坐。四天王天乃至阿迦尼吒天以天衣为座者。当学般若波罗蜜

【论】问曰。如经说佛敷草树下坐而成佛道。今云何愿言以天衣为座。答曰。声闻经中说敷草。摩诃衍经中随众生所见。或有见敷草树下。或见敷天綩綖。随其福德多少所见不同。复次生身佛把草树下。法性生身佛以天衣为座。或胜天衣。复次佛于深林树下成佛。林中人见则奉佛草。若贵人见者当以所贵衣服为座。但林中无贵人故。时诸龙神天各以妙衣为座。四天王衣重二两。忉利天衣重一两。夜摩天衣重十八铢。兜率天衣重十二铢。化乐天衣重六铢。他化自在天衣重三铢。色界天衣无重相。欲界天衣从树边生无缕无织。譬如薄冰光曜明净有种种色。色界天衣纯金色光明不可称知。如是等宝衣敷座。菩萨坐上成阿耨多罗三藐三菩提。问曰。何以但说诸天敷衣。不说十方诸大菩萨为佛敷座。诸菩萨等佛将成道时皆为佛敷座。或广长一由旬十百千万亿乃至无量由旬高亦如是。此诸宝座是菩萨无漏福德生故。是诸天目所不见何况手触。十方三世诸佛降魔得道庄严佛事皆悉照见譬如明镜。如是妙座何以不说。答曰。般若波罗蜜有二种。一者与声闻菩萨诸天共说。二者但与十住具足菩萨说。是般若波罗蜜中应说菩萨为佛敷座。所以者何。诸天知佛恩不及一生二生诸大菩萨。如是菩萨云何不以神通力而供养佛。是中合声闻说。是故不说

【经】我得阿耨多罗三藐三菩提时。行住坐卧处欲使悉为金刚者。当学般若波罗蜜

【论】问曰。何以故佛四威仪中地悉为金刚。答曰。有人言。菩萨至菩提树下时。于此处坐得阿耨多罗三藐三菩提。尔时菩萨入诸法实相中。无有地能举是菩萨。所以者何。地皆是众生虚诳业因缘报故有。是故不能举菩萨欲成佛时实相智慧身。是时坐处变为金刚。有人言。土在金轮上。金轮在金刚上从金刚际出如莲花台直上持菩萨坐处令不陷没。以是故此道场坐处名为金刚。有人言成佛道已四种威仪处悉变成金刚。问曰。金刚亦是众生虚诳业因缘有。云何能举佛。答曰。金刚虽是虚诳所成。于地最为牢固更无胜者。金刚下水诸大龙王以此坚固物奉献于佛。亦是佛宿世业因缘故得此安立处。又复佛变金刚及四大令为虚空。虚空不诳。佛智慧亦不诳。二事既同。是故能举

【经】复次舍利弗。菩萨摩诃萨欲出家日即成阿耨多罗三藐三菩提。即是日转法轮。转法轮时无量阿僧祇众生远尘离垢。诸法中得法眼净。无量阿僧祇众生一切法不受故。诸漏心得解脱。无量阿僧祇众生于阿耨多罗三藐三菩提得不退转者。当学般若波罗蜜

【论】或有菩萨于恶世邪见众生中。为除众生邪见故。自行勤苦甚难之行。如释迦文佛。于沤楼频螺树林中。食一麻一米。诸外道言。我等先师虽修苦行。不能如是六年勤苦。又复有人谓佛先世恶业今受苦报。有菩萨谓佛为实受是苦。是故发心我当即以出家日成佛。又有菩萨于好世出家。如大通惠求佛道结加趺坐。经十小劫乃得成佛。菩萨闻是已发心言。愿我以出家日即得成佛。有菩萨成佛已不即转法轮。如然灯佛。成佛已十二年但放光明。人无识者而不说法。又如须扇多佛成佛已无受化者。作化佛留住一劫说法度人自身灭度。又如释迦文佛。成佛已五十七日不说法。菩萨闻是已。愿我成佛已即转法轮。有佛度众生有限数。如释迦文佛转法轮时。憍陈如一人得初道。八万诸天诸法中得法眼净。菩萨闻是已作是愿。我转法轮时令无量阿僧祇人远尘离垢。诸法中得法眼净。以释迦文佛初转法轮时。一比丘及诸天皆得初道。而无一人得阿罗汉及菩萨道者。是故菩萨愿言我作佛时当使无量阿僧祇众生。一切法不受故诸漏心得解脱。及无量阿僧祇众生。于阿耨多罗三藐三菩提得不退转。问曰。若一切佛神力功德度众生皆等。此菩萨何以作此愿。答曰。一佛能变作无量阿僧祇身而度众生。而世界有严净者有不严净者。菩萨若见若闻。是诸佛有苦行难得佛者。有不即转法轮者。有如释迦牟尼佛六年苦行成道。又闻初转法轮时。未有得阿罗汉道者。何况得菩萨道。是故菩萨未闻诸佛力等故作是愿。然诸佛神力功德平等无异

【经】我得阿耨多罗三藐三菩提时。以无量阿僧祇声闻为僧。我一说法时便于座上尽得阿罗汉者。当学般若波罗蜜

【论】有佛以声闻为僧有数有限。如释迦文尼佛千二百五十比丘为僧。弥勒佛初会僧九十九亿。第二会九十六亿。第三会九十三亿。如是等诸佛僧各各有限有数不同。以是故菩萨愿言我当以无量阿僧祇声闻为僧。有佛为众生说法。一说法得初道。异时更说得二道三道第四道。如释迦文尼佛为五比丘说法得初道。异日得阿罗汉道。如舍利弗得初道。经半月然后得阿罗汉道。摩诃迦叶见佛得初道。过八日已得阿罗汉。如阿难得须陀洹道。二十五岁供养佛已。佛般涅槃后得阿罗汉。如是等诸阿罗汉不一时得四道。以是故菩萨愿言我一说法时便于座上尽得阿罗汉

【经】我当以无量阿僧祇菩萨摩诃萨为僧。我一说法时无量阿僧祇菩萨皆得阿鞞跋致

【论】菩萨所以作此愿者。诸佛多以声闻为僧无别菩萨僧。如弥勒菩萨文殊师利菩萨等。以释迦文佛无别菩萨僧故。入声闻僧中次第坐。有佛为一乘说法纯以菩萨为僧。有佛声闻菩萨杂以为僧。如阿弥陀佛国菩萨僧多声闻僧少。以是故愿以无量菩萨为僧。有佛初转法轮时无有人得阿鞞跋致。以是故菩萨愿言我一说法无量阿僧祇人得阿鞞跋致

【经】欲得寿命无量光明具足者。当学般若波罗蜜

【论】诸佛寿命有长有短。如鞞婆尸佛寿八万四千岁。如拘楼餐陀佛寿六万岁。迦那伽牟尼佛寿三万岁。迦叶佛寿二万岁。释迦文佛寿百岁。少有过者。弥勒佛寿八万四千岁。如释迦文佛常光一丈。弥勒佛常光十里。诸佛寿命光明各有二种。一者隐藏。二者显现。一者真实。二者为众生故隐藏。真实者无量显现。为众生者有限有量。实佛寿不应短。所以者何。诸佛长寿业因缘具足故。如婆伽梵宿世救一聚落人命故得无量阿僧祇寿命。梵世中寿法不过半劫。而此梵天寿独无量。以是故生邪见言唯我常住。佛到其所破其邪见说其本缘。救一聚落其寿乃尔。何况佛世世救无量阿僧祇众生。或以财物救济。或以身命代死。云何寿限不过百岁。又不杀生戒是长寿业因缘。佛以大慈众生爱彻骨髓。常能为众生故死。何况杀生。又以诸法实相智慧真实不诳故。亦是长寿因缘。菩萨以般若波罗蜜和合持戒诸功德故。得寿命无量。何况佛世世具足此诸无量功德。而寿命有限。复次如一切色中佛身第一。一切心中佛心第一。以是故一切寿命中佛寿亦应第一。如世俗人言。人生于世以寿为贵。佛为人中之上寿亦应长。问曰。佛虽有长寿业因缘生于恶世故寿命便短。以此短寿能具佛事。何用长为。又佛以神通力故一日之中能具佛事。何况百岁。答曰。此间阎浮提恶故佛寿应短。余处好故佛寿应长。问曰。若然者菩萨于此阎浮提净饭王宫生。出家成道是实佛。余处皆是神通力变化作佛以度众生。答曰。此言非也。所以者何。余处阎浮提亦各各言我国是实佛。余处为变化。何以知之。若余处国土自知是化佛。则不肯信受教戒。又如余国土人寿命一劫。若佛寿百岁于彼裁无一日。众生则起轻慢不肯受教。彼则以一劫为实。佛以此为变化化。如首楞严经说。神通遍照佛寿七百千阿僧祇劫。佛告文殊尸利。彼佛则是我身。彼佛亦言释迦文佛则是我身。以是故知诸佛寿命实皆无量。为度人故现有长短。汝言释迦文佛以神通力故。所度众生与人寿不异者。则不须百岁。一日之中可具足佛事。如阿难一时心生是念。如然灯世尊一切胜佛鞞婆尸佛。出于好世寿命极多能具佛事。我释迦文佛出生恶世寿命极短。将无世尊不能具足佛事耶。尔时世尊入日出三昧。从身变化出无量诸佛。及无量光明普至十方。一一化佛在诸世界各作佛事。或有说法。或现神通。或现三昧。或现饭食。如是之比种种因缘施作佛事而度众生。从三昧起告阿难曰。汝悉见闻是事不。阿难言。唯然已见。佛告阿难。佛以如是神力能具佛事不。阿难言。假令佛寿一日。大地草木悉为可度。众生则能度尽。何况百岁。以是故知。诸佛寿命皆悉无量。为度人故现有长短。譬如日出影现于水随水大小水大则影久水小则速灭。若照琉璃颇梨珠山影则久住。又如火烧草木然少则速灭然多则久住。不可以灭处无火故谓多然处亦无。光明长短义亦如是

    大智度论释初品中信持无三毒义第五十二

【经】我成阿耨多罗三藐三菩提时。世界中无有淫欲嗔恚愚痴。亦无三毒之名。一切众生成就如是智慧善施善戒善定善梵行善不娆众生者。当学般若波罗蜜

【论】问曰。若世界无三毒亦无三毒名者。佛为何等故出生其国。答曰。贪欲嗔恚愚痴名为三不善根。是欲界系法。佛若说贪欲嗔恚愚痴是欲界系不善。若说染爱无明是则通三界。有佛世界纯诸欲人。为是众生故菩萨愿言我成佛时国无三毒及三毒之名。复有清净佛国。纯阿鞞跋致法性生身菩萨。无诸烦恼。唯有余习。是故言无三毒之名。若有人言。如菩萨愿言。我当度一切众生。而众生实不尽度。此亦如是。欲令世界无三毒之名。亦应实有三毒不尽。若无三毒何用佛为。如地无大闇则不须日照。如经所说若无三法则佛不出世。若三法不断则不得离老病死。三法者则是三毒。如三法经此中应广说。复次有世界。众生分别诸法是善是不善是缚是解等。于一相寂灭法中而生戏论。菩萨以是故愿言令我世界中众生不生三毒。知三毒实相即是涅槃。问曰。一切众生得如是智慧是何等智慧。答曰。智慧是世间正见。世间正见中。说有布施有罪福有今世后世有阿罗汉。信罪福故能善布施。信有阿罗汉故能善持戒善禅定善梵行。得正见力故能善不娆众生。世间正见是无漏智慧根本。以是故说国中无三毒之名。贪欲有二种。一者邪贪欲。二者贪欲。嗔恚有二种。一者邪嗔恚。二者嗔恚。愚痴有二种。一者邪见愚痴。二者愚痴。是三种邪毒众生难可化度。余三易度。无三毒名者。无邪三毒之名。善布施等五事如上放光品中说

【经】使我般涅槃后法无灭尽。亦无灭尽之名。当学般若波罗蜜

【论】问曰。佛为法王尚自灭度。云何言法无灭尽。答曰。如上说。是菩萨愿事不必实。一切有为法。从因缘和合生。云何常住而不灭。佛如日明法如日没余光。云何日没而余光不灭。但久住故无能见灭者故名不灭。复次是菩萨见诸佛法住有多有少。如迦叶佛法住七日。如释迦牟尼佛法住千岁。是故菩萨发是愿言。法虽有为愿令相续不灭如火得薪相传不绝。复次诸法实相名为佛法。是实法相不生不灭不断不常不一不异不来不去不受不动不着不依无所有。如涅槃相。法相如是。云何有灭。问曰。法相如是者。一切佛法皆应不灭。答曰。如所言诸法实相无有灭者有人忆想分别取诸法相坏实法相。用二法说是故有灭。实相法中无有灭也。复次行般若波罗蜜无碍法集无量功德故。随其本愿法法相续无有见其灭者。譬如仰射虚空箭去极远人虽不见要必当堕

【经】我得阿耨多罗三藐三菩提时。十方如恒河沙等世界中众生闻我名者。必得阿耨多罗三藐三菩提。欲得如是等功德者。当学般若波罗蜜

【论】问曰。有人生值佛世在佛法中。或堕地狱者如提婆达俱迦利诃多释子等。三不善法覆心故堕地狱。此中云何言去佛如恒河沙等世界。但闻佛名便得道耶。答曰。上已说有二种佛。一者法性生身佛。二者随众生优劣现化佛。为法性生身佛故。说乃至闻名得度。为随众生现身佛故。说虽共佛住随业因缘有堕地狱者。法性生身佛者。无事不济。无愿不满。所以者何。于无量阿僧祇劫积集一切善本功德。一切智慧无碍具足。为众圣主诸天及大菩萨希能见者。譬如如意宝珠难见难得。若有见者所愿必果。如喜见药。其有见者众患悉除。如转轮圣王。人有见者无不富足。如释提桓因。有人见者随愿悉得。如梵天王众生依附恐怖悉除。如人念观世音菩萨名者悉脱厄难。是事尚尔。何况诸佛法性生身。问曰。释迦文佛亦是法性生身分无有异体。何以故。佛在世时有作五逆罪人饥饿贼盗如是等恶。答曰。释迦文佛本誓。我出恶世欲以道法度脱众生。不为富贵世乐故出。若佛以力与之则无事不能。又亦是众生福德力薄罪垢深重故。不得随意度脱。又今佛但说清净涅槃。而众生讥论诽谤言。何以多畜弟子化导人民。此亦是系缚法。但以涅槃法化犹尚讥谤。何况杂以世乐。如提婆达欲令足下有千辐相轮故。以铁作模烧而烁之。烁已足坏身恼大呼。尔时阿难闻已涕泣白佛。我兄欲死愿佛哀救佛即伸手就摩其身发至诚言。我看罗睺罗与提婆达等者彼痛当灭。是时提婆达众痛即除。执手观之知是佛手便作是言。净饭王子以此医术足自生活。佛告阿难。汝观提婆达不。用心如是云何可度。若好世人则无是咎。如是众生若以世乐不得度也。是事种种因缘上已广说。以是故说闻佛名有得道者有不得者。复次佛身无量阿僧祇种种不同。有佛为众生说法令得道者。有佛放无量光明众生遇之而得道者。有以神通变化指示其心而得道者。有佛但现色身而得道者。有佛遍身毛孔出众妙香众生闻之而得道者。有佛以食与众生令得道者。有佛众生但念而得道者。有佛能以一切草木之声而作佛事令众生得道者。有佛众生闻名而得道者。为是佛故说言我作佛时其闻名者皆令得度。复次闻名不但以名便得道也。闻已修道然后得度。如须达长者。初闻佛名内心惊喜。诣佛听法而能得道。又如贳夷罗婆罗门。从鸡泥耶结发梵志所。初闻佛名心即惊喜。直诣佛所闻法得道。是但说闻名闻名为得道因缘非得道也问曰。此经言闻诸佛名即时得道。不言闻名已修道乃得。答曰。今言即时不言一心中。但言更无异事闻之故言即时。譬如经中说。修慈心时即修七觉意。难者言。慈三昧有漏是缘众生法。云何得即时修七觉。答者言。从慈起已即修七觉。更无余法故言即时。即时有二种。一者同时。二者虽久更无异法。即是心而得修七觉亦名即时。复次有众生福德淳熟结使心薄应当得道。若闻佛名即时得道。又复以佛威力故闻即得度。譬如熟痈若无治者得小因缘而便自溃。亦如熟果。若人无取微风因缘便自随落。譬如新净白[疊*毛]易为受色。为是人故说若闻佛名。即时得道。譬如鬼神着人闻仙人咒名即时舍去。问曰。过如恒河沙等世界谁传此名令彼得闻。答曰。佛以神力举身毛孔放无量光明。一一光上皆有宝华。一一华上皆有坐佛。一一诸佛各说妙法以度众生。又说诸佛名字。以是故闻。如放光中说。复次诸大菩萨以本愿欲至无佛法处称扬佛名。如此品中说者是故得闻。复有大功德人从虚空中闻佛名号。如萨陀波仑菩萨。又有从诸天闻。或从树木音声中闻。或从梦中。复次诸佛有不可思议力故自往语。或以声告。又如菩萨作愿誓度一切众生。以是故说我成佛时过如恒河沙等世界众生闻我名皆得成佛欲得是者当学般若波罗蜜

问曰。上欲得诸功德及诸所愿。是诸事皆是众行和合所成。何以故。但说当学般若波罗蜜。答曰。是经名般若波罗蜜。佛欲解说其事。是故品品中皆赞般若波罗蜜。复次般若波罗蜜是诸佛母。父母之中母功最重。是故佛以般若为母。般舟三昧为父。三昧唯能摄持乱心令智慧得成。而不能观诸法实相。般若波罗蜜。能遍观诸法分别实相。无事不达。无事不成。功德大故。名之为母以是故行者虽行六波罗蜜及种种功德和合能具众愿。而但说当学般若波罗蜜。复次如般若后品中说。若无般若波罗蜜余五事不名波罗蜜。虽普修众行亦不能满具诸愿。如种种画彩若无胶者亦不中用。众生从无始世界中来。虽修布施持戒忍辱精进一心智慧。受世间果报已而复还尽。所以者何。离般若波罗蜜故。今以佛恩以般若波罗蜜修行六事故得名波罗蜜。成就佛道使佛佛相续而无穷尽。复次菩萨行般若波罗蜜时。普观诸法皆空。空亦复空。灭诸观得无碍般若波罗蜜。以大悲方便力还起诸功德业。此清净业因缘故无愿不得。余功德离般若波罗蜜无有无碍智慧。云何言欲得诸愿当学檀波罗蜜等。复次又以五波罗蜜离般若不得波罗蜜名字。五波罗蜜如盲。般若波罗蜜如眼。五波罗蜜如坏瓶盛水。般若波罗蜜如盛熟瓶。五波罗蜜如鸟无两翼。般若波罗蜜如有翼之鸟。如是等种种因缘故般若波罗蜜能成大事。以是故言欲得诸功德及愿当学般若波罗蜜

大智度论卷第三十四大智度论释报应品第二(卷三十五)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】佛告舍利弗。若菩萨摩诃萨行般若波罗蜜能作是功德。是时四天王皆大欢喜意念言。我等当以四钵奉上菩萨。如前天王奉先佛钵

【论】问曰。前品说已具。今何以重说。答曰。前虽叹般若波罗蜜事未具足。闻者无厌。是故复说。复次初品但赞般若波罗蜜力。今赞行者能作是功德。四天王等欢喜奉钵。复次以菩萨能具诸愿行故。佛安慰劝进言。有此果报终不虚也。复次般若波罗蜜有二种果。一者成佛度众生。二者虽未成佛受世间果报。转轮圣王释梵天王主三千世界。世间福乐供养之事悉皆备足。今以世间果报以示众生故说是事。复次世间欲成大业多有坏乱者。菩萨则不然。内心既定外事亦应。如是等因缘故说此品。问曰。菩萨增益六波罗蜜时。诸天世人何因缘故喜。答曰。诸天皆因十善四禅四无量故生是诸功德。皆由诸佛菩萨故有。若佛出世增益诸天众减损阿修罗种。若佛不在世阿修罗种多诸天减少。以种杂福不清净故。若诸佛出世能断诸天疑网能成大事。如释提桓因命欲终时心怀怖畏。求佛自救遍不知处。虽见出家之人山泽闲处所供养者。皆亦不能断其疑网。尔时毗首羯磨天白释提桓因言。尸毗王苦行奇特世所希有。诸智人言。是人不久当得作佛。释提桓因言。是事难办。何以知之。如鱼子庵罗树华发心菩萨。是三事因时虽多成果甚少。今当试之。帝释自化为鹰。毗首羯磨化作鸽。鸽投于王。王自割身肉。乃至举身上称以代鸽命。地为震动。是时释提桓因等心大欢喜。散众天华叹未曾有。如是决定大心成佛不久。复次凡夫人肉眼无有智慧。苦身求财以自生活。闻菩萨增益六波罗蜜成佛不久犹尚欢喜。何况诸天。问曰。四天王天三十三天有阿修罗难上诸天等无有此患。何以欢喜。答曰。上诸天虽无阿修罗患。若佛不出世生其天上者少。设有生者五欲不妙。所以者何。但修不净福故。色界诸天宫殿光明寿命亦复如是。复次诸天中有智慧者。能知禅味五欲悉皆无常。唯佛出世能令得常乐涅槃。以世间乐涅槃乐皆由佛菩萨得。是故欢喜。譬如甘美果树茂盛成就人大欢喜。以树有种种利益。有庇其荫者。有用其华食其果实。菩萨亦如是。能以离不善法荫遮三恶苦热。能与人天富乐之华。令诸贤圣得三乘之果。是故欢喜。问曰。诸天供养事多。何以奉钵。答曰。四天王奉钵。余天供养诸天供养。各有定法。如佛初生时。释提桓因以天衣奉承佛身。梵天王躬自执盖。四天王四边防护。净居诸天欲令菩萨生厌离心故。化作老病死人及沙门身。又出家时。四天王敕使者捧举马足。自四边侍护菩萨。天帝释取发于其天上城东门外立发塔。又持菩萨宝衣于城南门外立衣塔。佛至树下时奉上好草。执金刚菩萨常执金刚卫护菩萨。梵天王请佛转法轮。如是等各有常法。以是故四天王奉钵。四钵义如先说。问曰。佛一身何以受四钵。答曰。四王力等不可偏受。又令见佛神力合四钵为一。心喜信净作是念。我等从菩萨初生至今成佛所修供养功德不虚。问曰。四天王寿命五百岁。菩萨过无量阿僧祇劫然后成佛。今之四天非是后天。何以故喜。答曰。同一姓故。譬如贵姓胤流百世不以远故为异。或时行者见菩萨增益六波罗蜜时。心作是愿。是菩萨成佛时我当奉钵。是故得生。复次四天王寿五百岁。人间五十岁。为四天王处一日一夜。亦三十日为一月。十二月为一岁。以此岁寿五百岁。为人间九百万岁。菩萨能作是功德者。或近成佛初生四天王足可得值。问曰。如摩诃衍经中说。有佛以喜为食不食揣食。如天王佛衣服仪容与白衣无异不须钵食。何以言四天王定应奉钵。答曰。定者为用钵者故不说不用。复次用钵诸佛多不用钵者少。是故以多为定

【经】三十三天乃至他化自在天。亦皆欢喜意念言。我等当给侍供养菩萨。减损阿修罗种增益诸天众。三千大千世界四天王天乃至阿迦尼吒天。皆大欢喜意念言。我等当请是菩萨转法轮

【论】释曰。是诸天等。以华香璎珞礼拜恭敬听法赞叹等供养。亦作是念。人修净福阿修罗种减增益三十三天。我诸天亦得增益。问曰。上六种天已说。何以故。更说三千大千世界中。乃至阿迦尼吒天欢喜供养。答曰。先说一须弥山上六天。此说三千大千世界诸天。先但说欲界。今此说欲界色界诸天请佛转法轮。上虽说净居诸天种种供养劝助。今请转法轮事大故。问曰。三藏中但说梵天请转法轮。今何以说四天王乃至阿迦尼吒天。答曰。欲界天近故前来。色界都名为梵。若说梵王请佛已说余天。又梵为色界初门。说初故后亦说

复次众生有佛无佛常识梵天。以梵天为世间祖父。为世人故说梵天。法轮相如先说

【经】舍利弗。是菩萨摩诃萨行般若波罗蜜。增益六波罗蜜时。诸善男子善女人各各欢喜意念言。我等当为是人作父母妻子亲族知识

【论】问曰。前已说能作是功德今何以复说增益六波罗蜜。答曰。先说总相今说别相。复次前所说功德中(前品中功德也)种种无量闻者厌惓。今但略说六波罗蜜则尽摄诸功德。复次为天说故能作诸功德。为人说故增益六波罗蜜。何以知之。如后说善男子善女人。以是故知。问曰。四天王天乃至阿迦尼吒天。何以不说善天而但人中说善男子善女人。答曰。诸天皆有天眼天耳他心智知供养菩萨故不别说其善。人以肉眼见无知。善者能知供养。以少故别说善者。善者从佛闻法。或从弟子菩萨闻。或闻受记当作佛。又闻佛赞叹其名者故知修善。问曰。何以但说男子女人善。不说二根无根者善。答曰。无根所谓无得道相。是故不说。如毗尼中不得出家。以其失男女相故其心不定。以小因缘故便嗔。结使多故着于世事。多怀疑网不乐道法。虽能少修福事。智慧浅薄不能深入本性转易。是故不说。声闻法如是说。摩诃衍中譬如大海无所不容。是无根人或时修善。但以少故不说。所谓少者于男女中是人最少。是人修善者少。譬如白人虽复须发黡子黑不名黑人。二根人结使多。杂亦行男事亦行女事。其心邪曲难可勉济。譬如稠林曳木曲者难出。又如阿修罗其心不端故常疑于佛谓佛助天。佛为说五众。谓有六众不为说一。若说四谛谓有五谛不说一事。二根人亦如是。心多邪曲故不任得道。以是故但说男子女人中善者。善相者有慈悲心能忍恶骂。如法句骂品中说

能忍恶骂人是名人中上。譬如好良马可中为王乘。复次以五种邪语及鞭杖打害缚系等。不能毁坏其心。是名为善相。复次三业无失乐于善人不毁他善。不显己德。随顺众人不说他过。不着世乐不求名誉。信乐道德之乐。自业清净不恼众生。心贵实法轻贱世事。唯好直信不随他诳。为一切众生得乐故自舍己乐。令一切众生得离苦故以身代之。如是等无量名为善人相。是相多在男女故说善男子善女人。问曰。善男子善女人何因能作是愿。答曰。善男子善女人自知福薄智慧鲜少。习近菩萨欲求过度。譬如沈石虽重依船得度。又善男子善女人。闻菩萨不从一世二世而得成道。无央数世往来生死。便作是念。我当与为因缘。复次菩萨积德厚故在所生处。众生皆来敬仰菩萨。以蒙利益重故。若见菩萨舍寿则生是愿。我当与菩萨作父母妻子眷属。所以者何。知习近善人增益功德故。譬如积集众香香气转多。如菩萨先世为国王太子。见阎浮提人贫穷。欲求如意珠入于大海至龙王宫。龙见太子威德殊妙即起迎逆延前供养。而问之言。何能远来。太子答曰。我怜阎浮提众生故。欲求如意宝珠以饶益之。龙言。能住我宫受供一月当以相与。太子即住一月为龙王赞叹多闻。龙即与珠。是如意珠能雨一由旬。龙言。太子有相不久作佛。我当作多闻第一弟子。时太子复至一龙宫得珠雨二由旬。二月赞叹神通力。龙言。太子作佛不久。我当作神足第一弟子。复至一龙宫得珠雨三由旬。三月赞叹智慧。龙言。太子作佛不久。我当作智慧第一弟子。诸龙与珠已言。尽汝寿命珠当还我。菩萨许之。太子得珠至阎浮提。一珠能雨饮食。一珠能雨衣服。一珠能雨七宝利益众生。又如须摩提菩萨。见燃灯佛从须罗娑女买五茎花不肯与之。即以五百金钱得五茎花女犹不与。而要之言。愿我世世常为君妻当以相与。菩萨以供养佛故即便许之。又妙光菩萨。长者女见其身有二十八相。生爱敬心住在门下。菩萨既到。女即解颈琉璃珠着菩萨钵中。心作是愿。我当世世为此人妇。此女二百五十劫中集诸功德。后生喜见淫女园莲花中。喜见养育为女。至年十四。女工世智皆悉备足。尔时有阎浮提王。名为财主。太子名德主。有大悲心。时出城入园游观。诸淫女等导引歌赞德主太子。散诸宝物衣服饮食。譬如龙雨无不周遍。喜德女见太子。自造歌偈而赞太子爱眼视之。目未曾眴而自发言。世间之事我悉知之。以我此身奉给太子。太子问言。汝为属谁。若有所属此非我宜。尔时喜见淫女答太子言。我女生年日月时节皆与太子同。此女非我腹生。我晨朝入园见莲花中有此女生。我因养育畜以为女。无以我故而轻此女。此女六十四能无不悉备。女工技术经书医方皆悉了达。常怀惭愧内心忠直无有嫉妒无邪淫想。我女德仪如是。太子必应纳之。德主太子答语女言。姊我发阿耨多罗三藐三菩提心。修菩萨道无所爱惜。国财妻子象马七珍。有所求索不逆人意。若汝生男女及以汝身。有人求者当以施之莫生忧悔。或时舍汝出家为佛弟子净居山薮汝亦勿愁。喜德女答言。假令地狱火来烧灭我身终亦不悔。我亦不为淫欲戏乐故而以相好。我为劝助阿耨多罗三藐三菩提故奉事正士。女又白太子言。我昨夜梦见妙日身佛坐道树下可往观之。太子见女端正又闻佛出。以此二因缘故共载一车俱诣佛所。佛为说法。太子得无量陀罗尼门。女得调伏心志。太子尔时以五百宝花供养于佛。以求阿耨多罗三藐三菩提。太子白父王言。我得见妙日身佛大得善利。父王闻已。舍所爱重之物以与太子。与其官属国内人民俱诣佛所。佛为说法。王得一切法无闇灯陀罗尼。时王思惟。不可以白衣法摄治国土。受于五欲而可得道。作是思惟已。立德主太子为王。出家求道。是时太子于月十五日六宝来应。喜德妻变为宝女。如不可思议经中广说。如是等因缘故知。善男子善女人。世世愿为菩萨父母妻子眷属

【经】尔时四天王乃至阿迦尼吒天。皆大欢喜各自念言。我等当作方便令是菩萨离于淫欲。从初发意常作童真。莫使与色欲共会。若受五欲障生梵天。何况阿耨多罗三藐三菩提。以是故舍利弗。菩萨摩诃萨断淫欲出家者。应得阿耨多罗三藐三菩提。非不断欲

【论】问曰。诸天何以作是愿。答曰。世间中有五欲第一无不爱乐。于五欲中触为第一能系人心。如人堕在深泥难可拯济。以是故诸天方便令菩萨远离淫欲。复次若受余欲犹不失智慧。淫欲会时身心慌迷。无所省觉深着自没。以是故诸天令菩萨离之。问曰。云何令离。答曰。如释迦文菩萨。在净饭王宫欲出城游观。净居诸天化为老病死人令其心厌。又令夜半见诸宫人妓直。恶露不净涕唾流涎屎尿涂漫。菩萨见已即便秽厌。或时诸天令女人恶心妒忌不识恩德。恶口欺诳无所省察。菩萨见已即生念言。身虽似人其心可恶即便舍之。欲使菩萨从初发心常作童真行。不与色欲共会。何以故。淫欲为诸结之本。佛言宁以利刀割截身体。不与女人共会。刀截虽苦不堕恶趣。淫欲因缘于无量劫数受地狱苦。人受五欲尚不生梵世。何况阿耨多罗三藐三菩提。或有人言。菩萨虽受五欲心不着故不妨于道。以是故经言受五欲尚不生梵世。梵世无始众生皆得生中。受五欲者尚所应得而不得之。何况阿耨多罗三藐三菩提。本所不得而欲得之。以是故菩萨应作童真。修行梵行当得阿耨多罗三藐三菩提。梵行菩萨不着世间故速成菩萨道。若淫欲者譬如胶漆难可得离。所以者何。身受欲乐淫欲根深。是故出家法中淫戒在初。又亦为重

【经】舍利弗白佛言。世尊。菩萨摩诃萨要当有父母妻子亲族知识耶。佛告舍利弗。或有菩萨有父母妻子亲族知识。或有菩萨从初发意断淫欲。修童真行。乃至得阿耨多罗三藐三菩提不犯色欲。或有菩萨方便力故受五欲已。出家得阿耨多罗三藐三菩提

【论】释曰。是三种菩萨。初者如世间人受五欲。后舍离出家得菩提道。二者大功德牢固。初发心时断于淫欲乃至成佛道。是菩萨或法身或肉身。或离欲或未离欲。三者清净法身菩萨得无生法忍住六神通。为教化众生故与众生同事而摄取之。或作转轮圣王。或作阎浮提王长者刹利。随其所须而利益之

【经】譬如幻师若幻弟子。善知幻法幻作五欲。于中共相娱乐于汝意云何。是人于此五欲颇实受不。舍利弗言。不也世尊。佛告舍利弗。菩萨摩诃萨以方便力故化作五欲。于中受乐成就众生。亦复如是。是菩萨摩诃萨不染于欲。种种因缘毁訾五欲。欲为炽然。欲为秽恶。欲为毁坏。欲为如怨。是故舍利弗。当知菩萨为众生故受五欲

【论】问曰。三种菩萨中。何以独为一种菩萨作譬喻。答曰。一者如人法不断淫欲。二者常断淫欲修于净行。三者亦修净行现受淫欲。以人不了故为作譬喻。问曰。何以不以梦化等为喻。答曰。梦非五情所知。但内心忆想故生。人以五情所见变失无常可以得解。化虽五情所知而见者甚少。佛为度可度众生。幻是众人所信。是故为喻。如幻师以幻术故于众人中现希有事令人欢喜。菩萨幻师亦如是。以五神通术故。于众生中化作五欲。共相娱乐化度众生。众生有二种。在家出家。为度出家众生故。现作声闻辟支佛佛及诸出家外道师。在家众生或有见出家者得度。或有见在家同受五欲而可化度。菩萨常以种种因缘毁訾五欲。欲为炽然者。若未失时三毒火然。若其失时无常火然。二火然故名为炽然。都无乐时。欲为秽恶者。诸佛菩萨阿罗汉等诸离欲者皆所秽贱。譬如人见狗食粪贱而愍之。不得好食而啖不净。受欲之人亦复如是。不得内心离欲之乐。而于色欲不净求乐。欲为毁坏者。着五欲因缘故。天王人王诸富贵者。亡国危身无不由之。欲如怨者。失人善利亦如刺客外如亲善内心怀害。五欲如是。丧失善心夺人慧命。五欲之生正为破坏众善毁败德业故出。又知五欲。如钩贼鱼。如弶害鹿。如灯焚蛾。是故说欲如怨。怨家之害不过一世。着五欲因缘堕三恶道。无量世受诸苦毒

【经】舍利弗白佛言。菩萨摩诃萨云何应行般若波罗蜜。佛告舍利弗。菩萨摩诃萨行般若波罗蜜时。不见菩萨。不见菩萨字。不见般若波罗蜜。亦不见我行般若波罗蜜。亦不见我不行般若波罗蜜。何以故。菩萨菩萨字性空。空中无色无受想行识。离色亦无空。离受想行识亦无空。空即是色色即是空。空即是受想行识。受想行识即是空。何以故。舍利弗。但有名字故谓为菩提。但有名字故谓为菩萨。但有名字故谓为空。所以者何。诸法实性无生无灭无垢无净故。菩萨摩诃萨如是行。亦不见生亦不见灭。亦不见垢亦不见净。何以故。名字是因缘和合作法。但以分别忆想假名说。是故菩萨摩诃萨行般若波罗蜜时。不见一切名字。不见故不着

【论】问曰。是事舍利弗上已问。今何以重问。答曰。先因佛说欲以一切种知一切法。当学般若波罗蜜故问。非自意问。复次今舍利弗闻上种种赞般若功德。心欢喜尊重般若故问云何应行。如病人闻叹良药便问云何应服。问曰。先已问住不住法行檀波罗蜜。施者受者财物不可得故。如是等为行般若。今何以复问行。答曰。上总问诸波罗蜜。此但问般若。上广赞叹般若为主。此直问行般若。复次上虽广叹般若波罗蜜。时会渴仰欲得。是故舍利弗为众人故问行般若波罗蜜。般若波罗蜜功德无量无尽。佛智慧亦无量无尽。若舍利弗不发问。则佛赞叹无穷已。若舍利弗不问者。则无因缘故则不应止。问曰。般若功德尊重。若佛广赞有何不可。答曰。赞叹般若闻者欢喜尊重则增其福德。若闻说般若则增其智慧。不但以福德因缘故可成佛道。要须智慧得成。是故不须但赞叹。人闻赞叹心已清净。渴仰欲得般若。如为渴人广赞叹美饮不解于渴即便应与之。如是等因缘故舍利弗今问行般若。问曰。如人有眼见方知所趣处然后能行。菩萨亦如是。先念佛道知般若见己身然后应行。今何以言不见菩萨及般若。若不见云何得行。答曰。此中不言常不见。但明入般若观时。不见菩萨及般若波罗蜜。般若波罗蜜为令众生知实法故出。此菩萨名字众缘和合假称。如后品中广说。般若波罗蜜名字亦如是。众法和合故假名为般若波罗蜜。般若波罗蜜虽是假名而能破诸戏论。以自性无故说言不可见。如火从众缘和合假名为火。虽无实事而能烧物。问曰。若入般若中不见。出则便见何者可信。答曰。上言般若为实法故出。是则可信。出般若波罗蜜不实故不可信。问曰。若入般若中不见出则见者。当知非法常空以般若力故空。答曰。世俗法故言行言入般若波罗蜜。诸观戏论灭故无出无入。若诸贤圣不以名字说则不得以教化凡夫。当取说意莫着语言。问曰。若般若中贵一切法空。此中何以先说众生空破我。答曰。初闻般若不得便说一切法空。我不可以五情求得。但忆想分别生我想无而谓有。又意情中无有定缘。但忆想分别颠倒因缘故。于空五众中而生我想。若闻无我则易可解。色等诸法现眼所见。若初言空无则难可信。今先破我次破我所法。破我我所法故则一切法尽空。如是离欲名为得道。复次般若波罗蜜无一定法。故不见我行般若。不见不行者。如凡夫不得般若故名不行。菩萨则不然。但行空般若故说不见不行。复次佛为法王。观余菩萨其智甚少。杂诸结使不名为行。譬如国王虽得少物不名为得。佛亦如是。教诸菩萨虽有少行不名为行。复次行般若波罗蜜者生憍慢。言我有般若波罗蜜取是相。若不行者心自懈没而怀忧悴。是故言不见我行与不行。复次不见我行般若波罗蜜者。破著有见。不见我不行般若波罗蜜者。破着无见。复次不见我行般若波罗蜜者。止诸法戏调。不见我不行者。止懈怠心故。譬如乘马疾则制之。迟则鞭之。如是等分别行不行。复次佛自说因缘。所谓菩萨菩萨字性空。是中虽但说菩萨字空而五众亦空。空中无色离色亦无空者。空名法空。法空中乃无一毫法。何况粗色。空亦不离色。所以者何。破色故有空。云何言离色。受想行识亦如是。何以故佛自更说因缘。所谓但有名字谓为菩提。但有名字谓为菩萨。但有名字谓为空。问曰。先已说此事。今何以重说。答曰。先说不见菩萨。不见菩萨字。不见般若波罗蜜。今说不见因缘。所谓但有名谓为菩提。但有名谓为菩萨。但有名谓为空。上菩萨此菩萨义同。菩萨字即如菩萨中说。般若波罗蜜分为二分。成就者名为菩提。未成就者名为空。生相实不可得故名为无生。所以者何。若先生后法。若先法后生。若生法一时。皆不可得。如先说无生故无灭。若法不生不灭如虚空。云何有垢有净。譬如虚空万岁。雨亦不湿大火烧不热烟亦不着。所以者何。本自无生故。菩萨能如是观不见离是不生不灭法。有生有灭有垢有净。何以故。佛自说因缘。一切法皆忆想分别因缘和合故强以名说。不可说者是实义。可说者皆是名字。菩萨行般若波罗蜜不见一切名字者。先略说名字。所谓菩萨菩萨字般若波罗蜜菩提字。今广说一切名字皆不可见。不见故不着。不著者不可得故。如诸眼中慧眼第一。菩萨以慧眼遍求不见。乃至不见细微一法。是故不着。问曰。若菩萨一切法中不着。何得不入涅槃。答曰。是事处处已说。今此中略说。大悲心故。十方佛念故。本愿未满故。精进波罗蜜力故。般若波罗蜜方便二事和合故。所谓不着于不着故。如是等种种因缘故。说菩萨虽不着诸法而不入涅槃

    大智度论释习相应品第三之一

【经】佛告舍利弗。菩萨摩诃萨行般若波罗蜜时。应如是思惟。菩萨但有字。佛亦但有字。般若波罗蜜亦但有字。色但有字。受想行识亦但有字。舍利弗。如我但有字。一切我常不可得。众生寿者命者生者养育众数人作者使作者起者使起者受者使受者知者见者。是一切皆不可得。不可得空故。但以名字说。菩萨摩诃萨亦如是行般若波罗蜜。不见我不见众生。乃至不见知者见者。所说名字亦不可见

【论】问曰。第二品末已说空。今何以重说。答曰。上多说法空。今杂说法空众生空。行者观外法尽空无所有。而谓能知空者不空。是故复说。观者亦空。是众生空。声闻法中多说。一切佛弟子皆知诸法中无我。佛灭后五百岁分为二分。有信法空。有但信众生空。言五众是定有法但受五众者空。以是故佛说众生空以况法空。复次我空易知法空难见。所以者何。我以五情求之不可得。但以身见力故忆想分别为我。法空者色可眼见声可耳闻。是故难知其空。是二事般若波罗蜜中皆空。如十八空义中说。问曰。如我乃至知者见者为是一事为各各异。答曰。皆是一我。但以随事为异。于五众中我我所心起故名为我。五众和合中生故名为众生。命根成就故名为寿者命者。能起众事如父生子名为生者。乳哺衣食因缘得长是名养育。五众十二入十八界等诸法因缘是众法有数故名众数。行人法故名为人。手足能有所作名为作者。力能役他故名使作者。能造后世罪福业故名能起者。令他起后世罪福业故名使起者。后身受罪福果报故名受者。令他受苦乐是名使受者。目睹色名为见者。五识知名为知者。复次用眼见色以五邪见观五众。用世间出世间正见观诸法是名见者。所谓眼根五邪见世间正见无漏见是名见者。余四根所知及意识所知通名为知者。如是诸法皆说是神。此神十方三世诸佛及诸贤圣求之不可得。但忆想分别强为其名。诸法亦如是。皆空无实但假为其名。问曰。是神但有十六名字。更有余名。答曰。略说则十六。广说则无量。随事起名如官号差别工能智功。出家得道种种诸名。皆是因缘和合生故无自性。无自性故毕竟空。生空故法空。法空故生亦空

【经】菩萨摩诃萨作如是行般若波罗蜜。除佛智慧过一切声闻辟支佛上。用不可得空故。所以者何。是菩萨摩诃萨诸名字法名字所著处亦不可得故。舍利弗。菩萨摩诃萨能如是行。为行般若波罗蜜。譬如满阎浮提竹麻稻茅。诸比丘其数如是。智慧如舍利弗目连等。欲比菩萨行般若波罗蜜智慧。百分不及一。千分百千分乃至算数譬喻所不能及。何以故。菩萨摩诃萨用智慧度脱一切众生故

【论】释曰。有二因缘故。菩萨智慧胜声闻辟支佛。一者以空知一切法空亦不见是空。空以不空等一不异。二者以此智慧为欲度脱一切众生令得涅槃。声闻辟支佛智慧但观诸法空。不能观世间涅槃为一。譬如人出狱。有但穿墙而出自脱身者。有破狱坏锁既自脱身兼济众人者。复次菩萨智慧入二法中故胜。一者大悲。二者般若波罗蜜。复有二法。一者般舟三昧。二者方便。复有二法。一者常住禅定。二者能通达法性。复有二法。一者能代一切众生受苦。二者自舍一切乐。复有二法。一者慈心无怨无恚。二者乃至诸佛功德心亦不着。如是等种种功德庄严智慧故胜声闻辟支佛。问曰。诸钝根者可以为喻。舍利弗智慧利根何以为喻。答曰。不必以钝根为譬喻。譬喻为庄严论议。令人信着故。以五情所见以喻意识。令其得悟。譬如登楼得梯则易上。复次一切众生着世间乐。闻道得涅槃则不信不乐。以是故以眼见事喻所不见。譬如苦药服之甚难。假之以蜜服之则易。复次舍利弗于声闻中智慧第一。比诸佛菩萨未有现焉。如阎浮提者。阎浮树名其林茂盛。此树于林中最大。提名为洲此洲上有此树林。林中有河底有金沙。名为阎浮檀金。以阎浮树故名为阎浮洲。此洲有五百小洲围绕通名阎浮提。问曰。诸弟子甚多。何以故说舍利弗目揵连等。满阎浮提中如竹麻稻茅。答曰。一切佛弟子中。智慧第一者舍利弗。神足第一者目揵连。此二人于佛法中大。于外法中亦大。富楼那．迦郗那．阿那律等。于佛法中虽大。于外法中不如。又此二人常在大众助佛扬化破诸外道。富楼那等比丘无是功德。是故不说。复次若说舍利弗则摄一切智慧人。若说目揵连则摄一切禅定人。譬喻有二种。一者假以为喻。二者实事为喻。今此名为假喻。所以不以余物为喻者。以此四物丛生稠致种类又多故。舍利弗目连等比丘满阎浮提。如是诸阿罗汉智慧和合不及菩萨智慧百分之一。乃至算数譬喻所不能及。问曰。何以不但说算数譬喻所不能及。而说百分千分不及一。答曰。算数譬喻所不能及者是其极语。譬如人有重罪先以打缚楚毒然后乃杀。如声闻法中常以十六不及一为喻。大乘法中则以乃至算数譬喻所不能及

【经】舍利弗。置阎浮提满中如舍利弗目连等。若满三千大千世界。如舍利弗目连等。复置是事。若满十方如恒河沙等世界。如舍利弗目连等智慧。欲比菩萨行般若波罗蜜智慧。百分不及一。千分百千分乃至算数譬喻所不能及

【论】释曰。此义同上阎浮提。但以多为异。问曰。舍利弗目连等虽多智慧无异。何以以多为喻。答曰。有人谓少无力多则有力。譬如水少其力亦少。又如绝健之人少众力寡不能制之。大军攻之则伏。有人谓一舍利弗智慧少则不及菩萨多或能及。佛言虽多不及故以多为喻。如一切草木力不如火一切诸明势不及日。亦如十方世界诸山不如一金刚珠。所以者何。菩萨智慧是一切诸佛法本。能令一切众生离苦得乐。如迦陵毗伽鸟子虽未出[聲-耳+卵]其音胜于众鸟。何况出[聲-耳+卵]。菩萨智慧亦如是。虽未出无明[聲-耳+卵]胜一切声闻辟支佛。何况成佛。又如转轮圣王太子。虽未成就福祚威德胜于一切诸王。何况作转轮圣王。菩萨亦如是。虽未成佛无量阿僧祇劫集无量智慧福德故。胜于声闻辟支佛。何况成佛

【经】复次舍利弗。菩萨摩诃萨行般若波罗蜜一日修智慧。出过一切声闻辟支佛上

【论】问曰。先已说除佛智慧过一切声闻辟支佛上。今何以复重说。答曰。非重说也。上总相说。今别相说。先言一切声闻辟支佛不及菩萨智慧。今但明不及一日智慧。何况千万岁

【经】舍利弗白佛言。世尊。声闻所有智慧。若须陀洹斯陀含阿那含阿罗汉辟支佛智慧佛智慧。是诸众智无有差别。不相违背无生性空。若法不相违背无生性空。是法无有别异。云何世尊言。菩萨摩诃萨行般若波罗蜜一日修智慧。出过声闻辟支佛上

【论】问曰。上佛已说菩萨摩诃萨修智慧出过声闻辟支佛上。今舍利弗何以故问。答曰。不问智慧势力能度众生。今但问佛及六子智慧。体性法中无有差别者。以诸贤圣智慧皆是诸法实相慧。皆是四谛及三十七品慧。皆是出三界入三脱门成三乘果慧。以是故说无有差别。复次如须陀洹以无漏智灭结得果。乃至佛亦如是。如须陀洹用二种解脱果。有为解脱无为解脱。乃至佛亦如是。如佛入涅槃。须陀洹极迟不过七世。皆同事同缘同行同果报。以是故言无相违背。所以者何。不生性空故。问曰。破无明集诸善法故生智慧。是智慧心相应心共生随心行。是中云何说智慧无生性空无有别异。答曰。智慧缘灭谛是不生。因缘和合故无有自性。是名性空。无所分别智慧随缘得名。如眼缘色生眼识。或名眼识或名色识。智慧虽因缘和合作法。以缘无生性空故名为无生性空。问曰。诸贤圣智慧皆缘四谛生。何以但说灭谛。答曰。四谛中灭谛为上。所以者何。是三谛皆属灭谛故。譬如人请天子并食群臣亦名供养天子。复次灭谛故说无生。三谛故说性空。复次有人言是诸智慧性自然不生性自空。所以者何。一切法皆因缘和合故无自性。无自性故不生。问曰。若尔者智慧愚痴无有别异。答曰。诸法如入法性中无有别异。如火各各不同而灭相无异。譬如众川万流各各异色异味。入于大海同为一味一名。如是愚痴智慧入于般若波罗蜜中。皆同一味无有差别。如五色近须弥山自失其色皆同金色。如是内外诸法入般若波罗蜜中皆为一味。何以故。般若波罗蜜相毕竟清净故。复次愚痴实相即是智慧。若分别着此智慧即是愚痴。如是愚痴智慧有何别异。初入佛法是痴是慧。转后深入痴慧无异。以是故是诸众智无有别异。不相违背。不生性空故无咎

【经】佛告舍利弗。于汝意云何。菩萨摩诃萨行般若波罗蜜一日修智慧。心念我行道慧益一切众生。当以一切种智知一切法度一切众生。诸声闻辟支佛智慧为有是事不。舍利弗言。不也世尊

【论】释曰。有四种论。一者必定论。二者分别论。三者反问论。四者置论。必定论者。如众生中世尊为第一。一切法中无我世间不可乐。涅槃为安隐寂灭业因缘不失。如是等名为必定论。分别论者。如无畏太子问佛。佛能说是语令他人嗔不。佛言。是事当分别答。太子言。诸尼健子辈了矣。佛或时无怜愍心故出众生于罪中。而众生嗔。然众生后当得利。尔时无畏之子坐其膝上。佛问无畏。汝子或时吞诸瓦石草木汝听咽不。答言。不听。先教令吐。若不肯吐左手捉耳右手擿口。纵令血出亦不置之。佛言。汝不愍之耶。答言。愍之深故为出瓦石。虽当时痛后得安隐。佛言。我亦如是。若众生欲作重罪。善教不从以苦言谏之。虽起嗔恚后得安隐。又如五比丘问佛受乐得道耶。佛言。不必定。有受苦得罪受苦得乐。有受乐得罪受乐得福。如是等名为分别论。反问论者。还以所问答之。如佛告比丘。于汝意云何。是色常耶无常耶。比丘言。无常。若无常是苦不。答言苦。若法是无常苦闻法圣弟子着是法。言是法是我是我所不。答曰。不也世尊。佛告比丘。从今已后所有色。若过去若未来若现在。若内若外。若好若丑。是色非我所。我非此色所。如是应以正实智慧知。受想行识亦如是。如是等名反问论。置论者。如十四难。世间有常世间无常。世间有边世间无边。如是等是名为置论。今佛以反问论答舍利弗。以舍利弗智于事未悟。佛反问事端令其得解。菩萨度众生智慧名为道慧。如后品中说。萨婆若慧是声闻辟支佛事。一切种智慧是诸佛事。道种慧是菩萨事。复次八圣道分为实道。令众生种种因缘入道。是名道慧。令众生住于道中。是为利益。声闻种辟支佛种佛种。又复一切智慧无所不得。是名一切种。若有为若无为用一切种智知。得佛道已应度一切众生利益一切众生。或大乘或声闻乘或辟支佛乘。若不入三乘道教修福德受天上人中富乐。若不能修福以今世利益之事衣食卧具等。若复不得当以慈悲心利益。是名度一切众生。问曰。若佛知一切声闻辟支佛不能为众生。何以故问。答曰。佛意如是。欲令舍利弗口自说诸声闻辟支佛不如菩萨。是故佛问。舍利弗言。不也世尊。所以者何。声闻辟支佛虽有慈心。本不发心愿度一切众生。亦不回善根向阿耨多罗三藐三菩提。以是故菩萨一日修智慧。过声闻辟支佛上

【经】舍利弗。于汝意云何。诸声闻辟支佛颇有是念我等当得阿耨多罗三藐三菩提度一切众生令得无余涅槃不。舍利弗言。不也世尊。佛告舍利弗。以是因缘故。当知诸声闻辟支佛智慧。欲比菩萨摩诃萨智慧。百分不及一。乃至算数譬喻所不能及

【论】问曰。上已反问舍利弗事已定。今何以复问。答曰。以舍利弗欲以须陀洹同得解脱故与诸佛菩萨等。而佛不听。譬如有人欲以毛孔之空与虚空等。以是故佛重质其事。复次虽同一事义门各异。先言智慧。为一切众生故。今言颇有是念。我等当得阿耨多罗三藐三菩提。令一切众生得无余涅槃。无余涅槃者义如先说。复次一声闻辟支佛尚不作是念。何况一切声闻辟支佛

【经】舍利弗。于汝意云何。诸声闻辟支佛颇有是念。我行六波罗蜜成就众生庄严世界具佛十力四无所畏四无碍智十八不共法度脱无量阿僧祇众生令得涅槃不。舍利弗言。不也世尊

【论】释曰。先略说我当得阿耨多罗三藐三菩提。今广说得阿耨多罗三藐三菩提因缘。所谓六波罗蜜乃至十八不共法。六波罗蜜义如先说。教化众生净佛世界后当说。余十力等如先说

【经】佛告舍利弗。菩萨摩诃萨能作是念。我当行六波罗蜜乃至十八不共法。成阿耨多罗三藐三菩提。度脱无量阿僧祇众生令得涅槃。譬如萤火虫。不作是念。我力能照一阎浮提普令大明。诸阿罗汉辟支佛亦如是。不作是念。我等行六波罗蜜乃至十八不共法。得阿耨多罗三藐三菩提。度脱无量阿僧祇众生令得涅槃

【论】释曰。所以十方恒河沙舍利弗目连不如一菩萨者。譬如萤火虫虽众多各有所照不及于日。萤火虫亦不作是念。我光明能照一阎浮提。诸声闻辟支佛不作是念。我智慧能照无量无边众生。如萤火虫夜能有所照日出则不能。诸声闻辟支佛亦如是。未有大菩萨时。能师子吼说法教化。有菩萨出不能有所作

【经】舍利弗。譬如日出时光明遍照阎浮提无不蒙明者。菩萨摩诃萨亦如是。行六波罗蜜乃至十八不共法。得阿耨多罗三藐三菩提。度脱无量阿僧祇众生令得涅槃

【论】释曰。如日天子怜愍众生故与七宝宫殿俱绕四天下。从初至终常不懈息。为众生除诸冷湿照诸闇冥。令各得所。菩萨亦如是。从初发心常行六波罗蜜乃至十八不共法。为度众生无有懈息。除不善冷干竭五欲泥。破愚痴无明教导修善业令各得所。又日明普照无憎无爱。随其高下深浅悉照。菩萨亦如是。出于世间住五神通。处于虚空放智慧火。照明诸罪福业及诸果报。菩萨以智慧光明灭众生邪见戏论。譬如朝露见日则消

大智度论卷第三十五(释第二品讫第三品上)大智度论释习相应品第三之余(卷三十六)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】舍利弗白佛言。云何菩萨摩诃萨过声闻辟支佛地。住阿鞞跋致地净佛道

【论】问曰。舍利弗何因作是问。答曰。舍利弗上问众智无异。佛既种种譬喻明菩萨智胜。意既已解。今问。云何能过二乘住阿毗跋致地净佛道。问曰。小乘不住成佛。何以故问净佛道事。答曰。舍利弗者是随佛转法轮。将虽自无益为利益求佛道众生故问。又以菩萨大悲多所利益。是故问菩萨事以益众生。复次舍利弗蒙佛恩故破诸邪见得成道果。欲报恩故问菩萨事。又舍利弗于声闻地中究尽边际。所未了者唯菩萨事。是故复问。又以菩萨法甚深微妙虽不能得爱乐故问。譬如见人妙宝已虽自无爱乐故问

【经】佛告舍利弗。菩萨摩诃萨从初发意行六波罗蜜。住空无相无作法。能过一切声闻辟支佛地。住阿毗跋致地净佛道

【论】问曰。是三事后品中各有因缘。佛今何以并说。答曰。是中略说。后当广说三事因缘。又今但说空无相无作因缘。后当说种种功德故合说三事。问曰。入三解脱门则到涅槃。今云何以空无相无作。能过声闻辟支佛地。答曰。无方便力故入三解脱门直取涅槃。若有方便力住三解脱门见涅槃。以慈悲心故能转心还起。如后品中说。譬如仰射虚空箭箭相拄不令堕地。菩萨如是。以智慧箭仰射三解脱虚空。以方便后箭射前箭不令堕涅槃之地。是菩萨虽见涅槃直过不住更期大事。所谓阿耨多罗三藐三菩提。今是观时非是证时。如是等应广说。若过是二地知诸法不生不灭。即是阿毗跋致地。住阿毗跋致地中教化众生净佛世界。是为能净佛道。复次菩萨住三解脱门观四谛。知是声闻辟支佛法直过四谛入一谛。所谓一切法不生不灭不垢不净不来不去等。入是一谛中是名阿毗跋致地。住是阿毗跋致地净佛道地。灭除身口意粗恶之业。及灭诸法中从初已来所失之事。是名净佛道地

【经】舍利弗白佛言。菩萨摩诃萨住何等地能为诸声闻辟支佛作福田

【论】释曰。舍利弗深心恭敬菩萨。故今问。菩萨漏结未尽。住何功德能为诸声闻辟支佛作福田

【经】佛告舍利弗。菩萨摩诃萨从初发意行六波罗蜜。乃至坐道场。于其中间常为诸声闻辟支佛作福田

【论】释曰。佛以是义示舍利弗。虽三解脱门涅槃事同。而菩萨有大慈悲声闻辟支佛无。菩萨从初发心行六波罗蜜乃至十八不共法。欲度一切众生具一切佛法故胜

【经】何以故。以有菩萨摩诃萨因缘故。世间诸善法生

【论】释曰。佛先已以一因缘益行众行故。为诸声闻辟支佛作福田。今说菩萨外益因缘故。世间有一切诸善法。所以者何。菩萨发心虽未成佛。令可度众生住三乘道。不得三乘者令住十善道。何况成佛。问曰。声闻辟支佛因缘故亦使世间得善法。何以但说菩萨能令世间有善法。答曰。因声闻辟支佛世间有善法者。亦皆由菩萨故有。若菩萨不发心者世间尚无佛道。何况声闻辟支佛。佛道是声闻辟支佛根本故。复次虽因声闻辟支佛有善法少。以少故不说。尚不说声闻辟支佛。何况外道诸师

【经】何等是善法。所谓十善道五戒八分成就斋。四禅四无量心四无色定。四念处四正勤四如意足五根五力七觉分八圣道分。尽现于世。以菩萨因缘故。六波罗蜜十八空佛十力四无所畏四无碍智十八不共法大慈大悲一切种智。尽现于世。以菩萨因缘故。有刹利大姓婆罗门大姓居士大家四天王天乃至非有想非无想天。皆现于世。以菩萨因缘故。有须陀洹斯陀含阿那含阿罗汉辟支佛佛。皆现于世

【论】问曰。以菩萨因缘故有善法于世可尔。刹利大姓婆罗门大姓居士大家。若世无菩萨亦有此贵姓。云何言皆从菩萨生。答曰。以菩萨因缘故。世间有五戒十善八斋等。是法有上中下。上者得道。中者生天。下者为人。故有刹利大姓婆罗门大姓居士大家。问曰。若世无菩萨。世间亦有五戒十善八斋刹利等大姓。答曰。菩萨受身种种。或时受业因缘身。或受变化身。于世间教化。说诸善法及世界法王法世俗法出家法在家法种类法居家法。怜愍众生护持世界。虽无菩萨法常行世法。以是因缘故皆从菩萨有。问曰。菩萨清净行大慈悲。云何说世俗诸杂法。答曰。有二种菩萨。一者行慈悲直入菩萨道。二者败坏菩萨。亦有悲心治以国法无所贪利。虽有所恼所安者多。治一恶人以成一家。如是立法。人虽不名为清净菩萨。得名败坏菩萨。以是因缘故皆由菩萨有。世间诸富贵皆从二乘道有。二乘道从佛有。佛因菩萨有。若无菩萨说善法者。世间无有天道人道阿修罗道。无有乐受不苦不乐受。但有苦受常有地狱啼哭之声。菩萨如是大利益故。云何不名为世间作福田。舍利弗闻是菩萨有大功德应当供养。心念烦恼未尽。虽有大福不能消其供养。如人虽啖好食以内有病故不能消化。以是故

【经】舍利弗白佛言。菩萨摩诃萨净毕施福不。佛言。不也。何以故。本以净毕故

【论】释曰以菩萨从初发心时便为一切众生供养之上首。所以者何。以决定为无量无边阿僧祇众生代受勤苦。又利益无量阿僧祇众生令得度脱。欲取一切诸佛法大智慧力故。能令世间即是涅槃。如是种种因缘故言本已净毕。复次佛重说消施因缘故

【经】舍利弗。菩萨摩诃萨为大施主施何等施诸善法。何等善法。十善道五戒乃至十八不共法一切种智。以是施与

【论】释曰。先说由菩萨因缘世间有善法今说菩萨施善法之主。是为差别

【经】舍利弗白佛言。世尊。菩萨摩诃萨云何习应般若波罗蜜。与般若波罗蜜相应

【论】释曰。上说一日修般若波罗蜜胜声闻辟支佛。从是因缘来佛种种赞叹菩萨。如是大功德皆从般若波罗蜜生。是故今问。云何菩萨习行是般若波罗蜜。与般若波罗蜜相应。复次舍利弗知般若波罗蜜难行难得。如幻如化难可受持。恐行者违错。故问习应

【经】佛告舍利弗。菩萨摩诃萨习应色空。是名与般若波罗蜜相应。习应受想行识空。是名与般若波罗蜜相应。复次舍利弗。菩萨摩诃萨习应眼空。是名与般若波罗蜜相应。习应耳鼻舌身心空。是名与般若波罗蜜相应。习应色空。是名与般若波罗蜜相应。习应声香味触法空。是名与般若波罗蜜相应。习应眼界空色界空眼识界空。是名与般若波罗蜜相应。习应耳声识界鼻香识界舌味识界身触识界意法识界空。是名与般若波罗蜜相应。习应苦空。是名与般若波罗蜜相应。习应集灭道空。是名与般若波罗蜜相应。习应无明空。是名与般若波罗蜜相应。习应行识名色六处触受爱取有生老死空。是名与般若波罗蜜相应。习应一切诸法空若有为若无为空。是名与般若波罗蜜相应

【论】释曰。五众者色受想行识。色众者是可见法。是色因缘故亦有不可见。有对。有对虽不可见亦名为色。如得道者名为道人。余出家未得道者亦名为道人。何等是可见。一处是可见有对色。小分一入摄余九处及无作业名不可见色。有对者十处。无对者唯无作色。有漏无漏等分别亦如是。如经说。色有三种。有色可见有对。有色不可见有对。有色不可见无对。是故当知非但眼见故。是色内外十处能起五识者皆名色。因是色分故生无作色。复有四种色。内有受不受。外有受不受。复有五种色所谓五尘。复有一种色如经说恼坏相。众生身色名为恼坏相。非众生色亦名恼坏相。恼相因缘故亦名恼。譬如有身则有饥渴寒热老病刀杖等苦。复有二种色。所谓四大四大造色。内色外色。受色不受色。系色不系色。有色能生罪有色能生福。业色非业色。业色果色。业色报色。果色报色。隐没无记色。不隐没无记色。可见色不可见色。有对色无对色。有漏色无漏色。如是等二种分别色。复有三种色如上可见有对中说。复有三种色。善色不善色无记色。学色无学色非学非无学色。从见谛所断生色从思惟所断生色从无断生色。复有三种色。欲界系色色界系色不系色。有色能生贪欲有色能生嗔恚有色能生愚痴。三结三漏等亦如是。有色能生不贪善根不嗔善根不愚痴善根。如是等诸三善根应广说。有色能生隐没无记法能生不隐没无记法。不隐没无记有二种。有报生有非报生者。如是等二种无记。复有四种色如上受不受中说。四大及造色三种善不善无记。身业作无作色口业作无作色。受色(受戒时得律仪色)止色(恶不善禁止也)用色(如众僧受用檀越所施之物)不用色。(余无用之色)如是等四种色。复有五种色。身作无作色口作无作色及非业色五情五尘。粗色动色影色像色诳色。粗色者可见可闻可嗅可味可触如土石等。动色者有二种。一者众生动作二者非众生动作。如水火风动作。地依他故动。下有大风动水水动地。风之动树。如酒自沸动。如磁石吸铁。如真珠玉车渠马瑙夜能自行。皆是众生先世福德业因缘不可思议。问曰。影色像色不应别说。何以故。眼光明对清净镜故反自照见。影亦如是遮光故影现无更有法。答曰。是事不然。如油中见像黑则非本色。如五尺刀中横观则面像广纵观则面像长则非本面。如大秦水精中玷。玷中皆有面像则非一面像。以是因缘故非还见本像。复次有镜有人有持者有光明。众缘和合故有像生。若众缘不具则像不生。是像亦非无因缘。亦不在因缘中。如是别自有法非是面也。此微色生法如是不同粗色。如因火有烟火灭烟在。问曰。若尔者不应别说影。同是细色故。答曰。镜中像有种种色影则一色是故不同。是二虽待形俱动形质各异。影从遮明而现。像则从种种因缘生。虽同细色各各差别。诳色者如炎如幻如化如乾闼婆城等。远诳人眼近无所有。如是等种种无量色总名色众。受众者如经说。因眼缘色生眼识。三事和合故生触。是触即时三众共生。所谓受想行。问曰。眼识亦与三众作因。何以但说触。答曰。眼识少时住见色便灭。次生意识能分别色好丑。是故不说眼识。因眼色识三事和合故生触。触生心数法。眼识因缘远故不说。问曰。一切识皆有触。何以但触因缘生心数法。答曰。心有二种一者念念生灭心。二者次第相续心。触亦如是。次第相续触粗故说因触生心数法。念念触微细亦共生心数法不了故不说。若情尘识三事和合能受苦乐。尔时触法了了。以是故说因触生心数法。如色法从因缘和合生。心数法亦如是。从触法和合生。如色法从和合生。无和合则不生。心数法亦如是。有触则生无触则不生。此受众一种所谓受相。复有二种受。身受心受内受外受。粗细远近净不净等。复有三种受。苦乐不苦不乐。善不善无记。学无学非学非无学。见谛所断思惟所断不断。因见谛所断生受。因思惟所断生受。因不断生受。或因身见生。不还与身见作因。或因身见生。还与身见作因。或不因身见生。不还与身见作因。复有三种受。欲界系色界系无色界系。如是等三种受。复有四种受。内身受外身受内心受外心受。四正勤四如意足等相应受。及四流四缚等相应受。是名四种受。复有五种受。乐根苦根忧根喜根舍根。见苦所断相应受。乃至思惟所断相应受。五盖五结诸烦恼相应受亦如是。复有六受众。六识相应受。复有意识分别为十八受。所谓眼见色思惟分别心生喜。眼见色思惟分别心生忧。眼见色思惟分别心生舍。乃至意识亦如是。是十八受中有净有垢为三十六。三世各有三十六为百八。如是等种种因缘分别受义无量名为受众。想众相应行众识众亦如是分别。何以故。与受众相应故。复次佛说有四种想。有小想大想无量想无所有想。小想者觉知小法。如说小法者。小欲小信小色小缘相名为小想。复次欲界系想名为小。色界系想名为大。三无色天系想名为无量。无所有处系想是名无所有想

复次烦恼相应想名为小想。烦恼覆故。有漏无垢想名为大想。诸法实相想名为无所有想。无漏想名为无量想。为涅槃无量法故。复次佛说有六想。眼触相应生想。乃至意触相应生想。如是等名为想众。行众者。佛或时说一切有为法名为行。或说三行。身行口行意行。身行者出入息。所以者何。息属身故。口行者觉观。所以者何。先觉观然后语言。意行者受想。所以者何。受苦乐取相心发。是名意行。心数法有二种。一者属见。二者属爱。属爱主名为受。属见主名为想。以是故说是二法为意行。佛或说十二因缘中三行。福行罪行无动行。福行者欲界系善业。罪行者不善业。无动行者色无色界系业。阿毗昙除受想余心数法。及无想定灭尽定等心不相应法。是名为行众。识众者内外六入和合故生六觉名为识。以内缘力大故名为眼识。乃至名为意识。问曰。意即是识。云何意缘力故生意识。答曰。意生灭相故。多因前意故。缘法生意识。问曰。前意已灭云何能生后识。答曰。意有二种。一者念念灭。二者心次第相续名为一。为是相续心故。诸心名为一意。是故依意而生识无咎。意识难解故。九十六种外道不说依意故生识。但以依神为本。此五众四念处中广说。所以者何。身念处说色众。受念处说受众。心念处说识众。法念处说想众行众。问曰。不应有五众。但应有色众识众。识众随时分别故有异名。名为受想行。如不净识名为烦恼。净识名为善法。答曰。不然。所以者何。若名异故实亦异。若无异法名不应异。若唯有心而无心法者。心不应有垢有净。譬如清净池水。狂象入中令其混浊。若清水珠入水即清净。不得言水外无象无珠。心亦如是。烦恼入故能令心浊。诸慈悲等善法入心令心清净。以是故不得言烦恼慈悲等法即是心。问曰。汝不闻我先说。垢心即是烦恼。净心即是善法。答曰。若垢心次第云何能生净心。净心次第云何当生垢心。以是故是事不然。汝但知粗现之事。不知心数法。不可以不知故便谓为无。当知必有五众。问曰。若有者何以不多不少但说五。答曰。诸法各有定限。如手法五指不得求其多少。复次有为法虽复无量。佛分判为五分则尽。问曰。若尔者何以故复说十二入十八界。答曰。众义应尔。入界义异。佛为法王。为众生故或时略说或时广说。有众生于色识中不大邪惑。于心数法中多有错谬故说五众。有众生心心数法中不生邪惑。但惑于色。为是众生故说色为十处。心心数法总说二处。或有众生于心数法中少生邪惑。而多不了色心。为是众生故说心数法为一界。色心为十七界。或有众生不知世间苦法生灭。不知离苦道。为是众生故说四谛。世间及身皆为是苦。爱等烦恼是苦因。烦恼灭是苦灭。灭烦恼方便法是名道。或有众生着吾我故。于诸法中邪见生一异相。或言世间无因无缘。或堕邪因缘。为是众生故说十二因缘有人说常法。或说神常。或说一切法常。但灭时隐藏微细非是无也。若得因缘会还出更无异法。为是人故说一切有为法皆是作法无有常定。譬如木人。种种机关。木楔和合故能动作。无有实事。是名有为法。问曰。是中说五众有何次第。答曰。行者初习观法先观粗法。知身不净无常苦空无我等身患。如是众生所以着此身者。以能生乐故。谛观此乐有无量苦常随逐之。此乐亦无常空无我等。六尘中有无量苦。众生何因缘生着。以众生取相故着。如人身一种偏有所著。能没命随死取相。受苦乐发动生思等诸行。心行发动时识知离苦得乐方便是为识。复次众生五欲因缘故受苦乐。取相因缘故深着是乐。以深着乐故。或起三毒若三善根。是名为行。识为其主受用上事。五欲即是色。色是根本故初说色众。余次第有名。余入界诸法等皆由五众次第。有唯法入法界中增无为法。四谛中增智缘灭入界乃至有为无为法如上说。今五众等诸法皆是空。何以故。圣主说故。圣有三种下中上。佛为其主如星宿月中日为其最。光明大故。佛得一切智慧故名为圣主。圣主所说故应当是实。复次以有十八空故一切法空。若但以性空能空一切法。何况十八。若以内空外空能空一切法。何况十八。复次若有法不空应当有二种。色法非色法。是色法分别破裂乃至微尘。分别微尘亦不可得。终卒皆空无色法。乃至念念生灭故皆空。如四念处中说。复次诸法性空但名字。因缘和合故有。如山河草木土地人民州郡城邑名之为国。巷里市陌庐馆宫殿名之为都。梁柱椽栋瓦竹壁石名之为殿。上中下分和合名之为柱。片片和合故有分名。众札和合故有片名。众微和合故有札名。是微尘有大有中有小。大者游尘可见。中者诸天所见。小者上圣人天眼所见。慧眼观之则无所见。所以者何。性实无故。若微尘实有即是常。不可分裂不可毁坏。火不能烧水不能没。复次若微尘有形无形二俱有过。若无形云何是色。若微尘有形则与虚空作分。亦有十方分。若有十方分则不名为微。佛法中色无有远近粗细是常者。复次离是因缘名字则无有法。今除山河土地因缘名字更无国名。除庐里道陌因缘名字则无都名。除梁椽竹瓦因缘名字更无殿名。除三分因缘名字更无柱名。除片因缘名字则无分名。除札因缘名字则无片名。除众微因缘名字则无札名。除中微尘名字则无大微尘名。除小微尘名字则无中微尘名。除天眼妄见则无小微尘名。如是等种种因缘义故知诸法毕竟空。问曰。若法毕竟空何以有名字。答曰。名字若是有与法俱破。若无则不应难。名字与法俱无有异。以是故知一切法空。复次一切法实空。所以者何。无有一法定故。皆从多法和合生。若无有一亦无有多。譬如树根茎枝叶和合故有假名树。若无树法根茎枝叶为谁和合。若无和合则无一法。若无一法则亦无多。初一后多故。复次一切诸观语言戏论皆无实者。若世间常亦不然。世间无常亦不然。有众生无众生。有边无边有我无我诸法实诸法空皆不然。如先种种论议门中说。若是诸观戏论皆无者云何不空。问曰。汝言诸法实诸法空皆不然者。今云何复言诸法空。答曰。有二种空。一者说名字空但破著有而不破空。二者以空破有亦无有空。如小劫尽时刀兵疾疫饥饿犹有人物鸟兽山河。大劫烧时山河树木。乃至金刚地下大水亦尽。劫火既灭持水之风亦灭。一切廓然无有遗余。空亦如是。破诸法皆空。唯有空在。而取相着之。大空者破一切法空亦复空。以是故汝不应作是难。若灭诸戏论云何不空。如是等种种因缘处处说空。当知一切法空。习者随般若波罗蜜修习行观不息不休。是名为习。譬如弟子随顺师教不违师意是名相应。如般若波罗蜜相。菩萨亦随是相。以智慧观能得能成就不增不减。是名相应。譬如函盖大小相称。虽般若波罗蜜灭诸观法。而智慧力故。名为无所不能无所不观。能如是知不堕二边。是为与般若相应

【经】复次舍利弗。菩萨摩诃萨习应性空。是名与般若波罗蜜相应。如是舍利弗。菩萨摩诃萨行般若波罗蜜习应七空。所谓性空自相空诸法空不可得空无法空有法空无法有法空。是名与般若波罗蜜相应

【论】问曰。何以不说住十八空。但说住七空。名与般若波罗蜜相应。答曰。佛法中广说则十八空。略说则七空。如广说助道法。则有三十七品。略说则七觉分。复次是七空多用利益众生故。如大空无始空。或时有众生起是邪见。为是故说。性空者。一切诸法性本末尚自空。何况现在。因缘尚空何况果报。自相空者。诸法总相别相尽观其空心则远离。用是二空诸法皆空。是名诸法空。从性空故有相相空故诸法皆空。诸法空故更无所得。是名不可得空。用是四种空破一切有法。若以有法有相为过者取于无法。是故说无法空。若以无法为非还欲取有法。是故说有法空。先说四空虽破有法。行者心则离有而存于无是则说无法空。若说无法为非。心无所寄还欲存有。是故略说有法空。以存有心薄故。无法有法空者。行者以无法空为非心还疑有。若心观有还疑无法。是故有无俱观其空。如内外空观。以是故但说七空。问曰。汝言知一切法空灭诸观。是名与般若波罗蜜相应。如是观是名相应。不如是观则不相应。分别是非故。即亦是观。云何言灭。答曰。以是故

【经】佛告舍利弗。菩萨摩诃萨习应七空时。不见色若相应若不相应。不见受想行识若相应若不相应。不见色若生相若灭相。不见受想行识若生相若灭相不见色若垢相若净相。不见受想行识若垢相若净相

【论】释曰。不见色若生相若灭相者。不见五众有生有灭。若五众有生灭相即堕断灭中。堕断灭故则无罪无福。无罪无福故与禽兽无异。不见色若垢若净。不见五众有缚有解。若五众是缚性。无有得解脱者。若五众是净性者。则无有学道法

【经】不见色与受合。不见受与想合。不见想与行合。不见行与识合。何以故。无有法与法合者。其性空故

【论】释曰。心心数法无形。无形故则无住处。以是故色不与受合。如四大及四大所造色二触和合。心心数法中无触法。故不得和合。问曰。若尔者何以说受想行识不共和合。答曰。佛此中自说无有法与法合者。何以故。一切法性常空故。若无法与法合亦无有离。复次佛自说因缘

【经】舍利弗。色空中无有色受想行识。空中无有识

【论】释曰。何以故。色与空相违。若空来则灭色。云何色空中有色。譬如水中无火火中无水。性相违故。复次有人言色非实空。行者入空三昧中见色为空。以是故言色空中都无有色。受想行识亦如是

【经】舍利弗。色空故无恼坏相。受空故无受相。想空故无知相。行空故无作相。识空故无觉相

【论】问曰。此义有何次第。答曰。先说五众空中无五众。今是中说其因缘。五众各各自相不可得故。故言五众空中无五众

【经】何以故。舍利弗。非色异空非空异色。色即是空空即是色。受想行识亦如是

【论】释曰。佛重说因缘。若五众与空异。空中应有五众。今五众不异空。空不异五众。五众即是空。空即是五众。以是故空不破五众。所以者何。是中佛自说因缘

【经】舍利弗。是诸法空相不生不灭不垢不净不增不减。是空法非过去非未来非现在。是故空中无色无受想行识。无眼耳鼻舌身意。无色声香味触法。无眼界。乃至无意识界。无无明亦无无明尽。乃至无老死亦无老死尽。无苦集灭道。亦无智亦无得。无须陀洹无须陀洹果。无斯陀含。无斯陀含果。无阿那含无阿那含果。无阿罗汉无阿罗汉果。无辟支佛无辟支佛道。无佛亦无佛道。舍利弗。菩萨摩诃萨如是习应。是名与般若波罗蜜相应

【论】问曰。人皆知空中无所有。不生不灭不垢不净不增不减无一切法。佛何以分别说五众等诸法各各空。答曰。有人虽复习空。而想空中犹有诸法。如行慈人。虽无众生而想众生得乐。自得无量福故。以是故佛说诸法性常自空。非空三昧故令法空。如水冷相火令其热。若言以空三昧故令法空者。是事不然。智者是无漏八智。得者初得圣道须陀洹果乃至佛道。是义先已广说

【经】舍利弗。是菩萨摩诃萨行般若波罗蜜。不见般若波罗蜜若相应若不相应。不见檀波罗蜜尸波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜若相应若不相应。亦不见色若相应若不相应。不见受想行识若相应若不相应。不见眼乃至意色乃至法眼色识界乃至意法识界若相应若不相应。不见四念处乃至八圣道分佛十力乃至一切种智若相应若不相应。如是舍利弗。当知菩萨摩诃萨与般若波罗蜜相应

【论】释曰。菩萨得诸法实相入般若波罗蜜。即于般若波罗蜜不见定相若相应若不相应。何况见有余法。云何不见般若相应不相应。不见如是行为应般若波罗蜜。不见不如是行为不应般若波罗蜜。如常乐我行不应般若波罗蜜。无常苦无我行为应般若波罗蜜。若行实不应般若波罗蜜。若行空为应般若波罗蜜。如有无行为不应般若波罗蜜。如非有非无行为应般若波罗蜜。般若波罗蜜中皆无是事。般若波罗蜜相毕竟清净故。五波罗蜜五众。乃至一切种智亦如是。问曰。般若波罗蜜毕竟清净应尔。五波罗蜜及余法云何清净。答曰。先说五事离般若波罗蜜不名波罗蜜。与般若波罗蜜和合故名波罗蜜。如般若波罗蜜初品中说。云何名檀波罗蜜。不见施者不见受者无财物故。五众法是菩萨观处。与般若波罗蜜和合故。毕竟清净故。不见相应不相应。十二入十八界十二因缘亦如是。是诸法无有定性无有定法。以是故不见若相应若不相应。十八空四念处乃至大慈大悲一切种智。不见若相应若不相应。问曰。是菩萨非声闻辟支佛。云何有三十七品。未得佛道云何有十力四无所畏。答曰。是菩萨虽非声闻辟支佛。亦观声闻辟支佛法。欲以声闻辟支佛道度众生故。复有人言。行声闻辟支佛道但不取证。如后品中说。入空无相无作三昧。菩萨住是三解脱门作是念言。今是观时非是证时。或有新发意菩萨。闻有声闻辟支佛三十七品法。读诵正忆念分别。以是故说菩萨有三十七品。佛十力等亦如是。菩萨自于菩萨十力四无所畏十八不共法中住。住是法中若闻若忆想分别。佛十力四无所畏十八不共法等。甚深微妙亦是我分。复次是菩萨无量阿僧祇劫来。修习佛十力四无所畏等。坐佛树下时得无碍解脱故增益清净。譬如勋劳既立然后受其功赏。菩萨亦如是。有是功德乃受其名。是功德皆是般若波罗蜜势力合故。不见若相应若不相应。此诸法义从六波罗蜜乃至一切智先已说

【经】复次舍利弗。菩萨摩诃萨行般若波罗蜜时。空不与空合。无相不与无相合。无作不与无作合。何以故。空无相无作无有合与不合。舍利弗。菩萨摩诃萨如是习应。是名与般若波罗蜜相应

【论】问曰。一心中无有二空。云何说空不与空合。答曰。空有二种。一者空三昧。二者法空。空三昧不与法空合。何以故。若以空三昧力合法空者。是法非自性空。又空者性自空。不从因缘生。若从因缘生则不名性空。行者若入时见空出时不见空。当知是虚妄。复次佛自说因缘。空中无合无不合。无相无作亦如是。舍利弗。菩萨如是习应。是名与般若波罗蜜相应。问曰。但一处说。不见与般若波罗蜜相应不相应便足。何以故复更种种说相应不相应因缘。若一处应余则皆应。若一处不应余亦不应。譬如一盲无见千盲俱尔。答曰。不然。若欲以戏论求胜。应如是难。诸法相虽不可说。佛以大慈大悲故种种方便说。又佛说法为一种众生得道。为未悟者重说。又复一说为断见谛结使。二说为断思惟结使。复更说为诸余结使分分皆断。又一说有人得声闻道。一说种辟支佛道因缘。更一说发阿耨多罗三藐三菩提心。更一说行六波罗蜜。更一说行方便得无生忍。更一说得初住地。更一说乃至十住地。更一说为人故。更一说为天故。复次是般若波罗蜜相甚深难解难知。佛知众生心根有利钝。钝根者少智为其重说。若利根者一说二说便悟。不须种种重说。譬如驶马下一鞭便走驽马多鞭乃去。如是等种种因缘故。经中重说无咎

【经】复次舍利弗。菩萨摩诃萨行般若波罗蜜时。入诸法自相空。入已色不作合不作不合。受想行识不作合不作不合。色不与前际合。何以故。不见前际故。色不与后际合。何以故。不见后际故。色不与现在合。何以故。不见现在故。受想行识亦如是

【论】释曰。先说空无相无作无合无不合。今更说因缘入自相空故。五众不作合不作不合。若一切法自相空。是中无有合不合。合者诸法如其相。如地坚相识知相。如是等自相不在异法。是名为合。不合者自相不在自法中。略说诸法相不增不减。色不与前际合。何以故。前际空无所有但有名字。若色入过去则灭无所有。云何与前际合。后际者未有未生。色不应与后际合。现在色生灭不住故不可取相。色不应与现在合。复次佛自说因缘。色不与前际合。非不合。何以故。前际不可见故。色不与后际合非不合。何以故。后际不可见故。色不与现在合。非不合。何以故。现在不可见故。受想行识亦如是

【经】复次舍利弗。菩萨摩诃萨行般若波罗蜜。前际不与后际合。后际不与前际合。现在不与前际后际合。前际后际亦不与现在合。三际名空故。舍利弗。菩萨摩诃萨如是习应者。是名与般若波罗蜜相应

【论】问曰。云何前际后际合。答曰。有人说三世诸法皆是有。未来法转为现在。现在转为过去。如泥揣现在瓶为未来土为过去。若成瓶时瓶为现在泥揣为过去。瓶破为未来。如是者是为合。若有三世相是事不然。以多过故是为不合。复次三世合者。如过去法与过去未来现在世作因。现在法与现在未来世作因。未来世法与未来世作因。又过去心心数法缘三世法。未来现在心心数法亦如是。断心心数法能缘不断法。不断心心数法能缘可断法。如是等三世诸法因缘果报共相和合。是名为合。菩萨不作是合。何以故。如先说过去已灭云何能为因能为缘。未来未有云何为因缘。现在乃至一念中不住云何为因缘。是名不合。复次佛自说因缘。三世及名字空故。云何言合

大智度论卷第三十六大智度论释习相应品第三之余(卷三十七)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】复次舍利弗。菩萨摩诃萨行般若波罗蜜。萨婆若不与过去世合。何以故。过去世不可见。何况萨婆若与过去世合。萨婆若不与未来世合。何以故。未来世不可见。何况萨婆若与未来世合。萨婆若不与现在世合。何以故。现在世不可见。何况萨婆若与现在世合。舍利弗。菩萨摩诃萨如是习应。是名与般若波罗蜜相应

【论】释曰。菩萨行般若波罗蜜。不观萨婆若与过去世同。何以故。过去世是虚妄。萨婆若是实法。过去世是生灭相。萨婆若非生灭相。过去世及法求觅不可得。何况萨婆若与过去世合。复次佛自说因缘。菩萨摩诃萨行般若波罗蜜。不见过去世。何况萨婆若与过去世合。未来现在世亦如是。未来世除生灭相其余义同。复次以时故说有三世。过去未来现在。时义如一时中说。复次萨婆若是十方三世诸佛真实智慧。三世者从凡夫虚妄生。云何与萨婆若合。譬如真金不与弊铁同相。问曰。如随喜品中说。菩萨摩诃萨念过去现在诸佛萨婆若智慧等诸功德。回向阿耨多罗三藐三菩提。云何言过去现在世不与萨婆若合。答曰。若以着心取相念萨婆若者。不名回向阿耨多罗三藐三菩提。譬如杂毒食初虽香美后不便身。若菩萨分别过去现在诸佛萨婆若者。应与三世合。今不取相故则无有合。问曰。菩萨亦念未来世当成佛。萨婆若亦自念我当得萨婆若。是名与未来世萨婆若合。云何言不合。答曰。萨婆若过三界出三世。毕竟清净相。行者但以忆想分别我当得是萨婆若。如世间法忆想当有所得。而是事未生未有。时节未至因缘未会都无处所。云何当与合。如明当服苏今已忆臭。又如迦栴延弟子辈言未来世中菩提。语菩萨言。若能修相好身者。我当来处之。如贵家女自恣无难。遣使语贫家子言。汝好庄严房舍帏帐种种备具。我当来处汝家中。如是说者是不如法。以是故不得以萨婆若与三世合。问曰。余法甚多。何以但说萨婆若。答曰。是萨婆若菩萨所归趣。深心欲得。于三世中求索故。问曰。何以不于有为无为法中求。答曰。后当说一切法中求

【经】复次舍利弗。菩萨摩诃萨行般若波罗蜜。色不与萨婆若合。色不可见故。受想行识亦如是。眼不与萨婆若合。眼不可见故。耳鼻舌身意亦如是。色不与萨婆若合。色不可见故。声香味触法亦如是。舍利弗。菩萨摩诃萨如是习应名与般若波罗蜜相应

【论】问曰。何以但说五众十二入。不说十八界十二因缘。答曰。应当说。或时诵者忘失。何以知之。佛所说五众十二入十八界十二因缘事垢净。五众十八界十二入十二因缘名为事。不定是垢不定是净。是中或有结使生。或有善法生。如田定能生物随种皆生。众界入十二因缘是为事。六波罗蜜乃至一切种智是为净种。所以不说垢者。是菩萨结使已薄不以自恼。是故不说。又菩萨智慧深入解诸法空。无诸烦恼但集诸功德。以是故应说十八界十二因缘。如色等事中不应有萨婆若合。所以者何。是萨婆若三世中不可得故。色等事中亦不可得。是皆世间因缘和合无有定性

【经】复次舍利弗。菩萨摩诃萨行般若波罗蜜。檀波罗蜜不与萨婆若合。檀波罗蜜不可见故。乃至般若波罗蜜亦如是。四念处不与萨婆若合。四念处不可见故。乃至八圣道分亦如是

【论】问曰。五众等是世间法。可不与萨婆若合。六波罗蜜云何不与合。答曰。六波罗蜜有二种。一者世间。二者出世间。为世间檀波罗蜜故说不与合。出世间檀波罗蜜应与合。复次菩萨行六波罗蜜。漏结未尽。不得与佛萨婆若合。复次佛说六波罗蜜空尚不可见。何况与萨婆若合。三十七品亦如是。问曰。是六波罗蜜杂有道俗故。三十七品趣涅槃道云何不合。答曰。三十七品是二乘法但为涅槃。菩萨为佛道。是故不合。问曰。摩诃衍品中有三十七品。亦是菩萨道。云何不与萨婆若合。答曰。有菩萨以着心故。行三十七品多回向涅槃。是故佛说不合

【经】佛十力乃至十八不共法不与萨婆若合。佛十力乃至十八不共法不可见故。舍利弗。菩萨摩诃萨如是习应。是名与般若波罗蜜相应

【论】释曰。是十力乃至十八不共法。虽是妙法为萨婆若故行。以菩萨漏结未尽故。不应与萨婆若合。复次佛十力等法有三种。一者菩萨所行虽未得佛道渐渐修习。二者佛所得而菩萨忆想分别求之。三者佛心所得。上二种不应与合。下一种虽可合而菩萨未得。是故不合。复次空故不可见。不可见故不合。是以皆言不可见故

【经】复次舍利弗。菩萨摩诃萨行般若波罗蜜。佛不与萨婆若合。萨婆若不与佛合。菩提不与萨婆若合。萨婆若不与菩提合

【论】问曰。菩萨及菩萨法。可不与萨婆若合。云何佛及菩提复不与合。答曰。佛是人。萨婆若是法。人是假名。法是因缘。众生乃至知者见者无故佛亦无。众生中尊上第一是名为佛。是故不合。复次得萨婆若故名为佛。若佛得萨婆若。先以是佛不须萨婆若。若非佛得萨婆若者。何以言佛得萨婆若。以是故和合因缘生不得言先后。复次离佛无萨婆若离萨婆若无佛。得萨婆若故名佛。佛所有故名萨婆若。问曰。佛是人故可不与合。菩提是无上道云何不合。答曰。菩提名为佛智慧。萨婆若名为佛一切智慧。十力智为菩提。第十一如实智名为萨婆若。二智不得一心中生。复次是十力等诸佛法及佛菩提。皆是菩萨忆想分别非实。唯佛所得萨婆若是实。今此菩提是菩萨菩提。是心中虚妄未实。云何与萨婆若合。复次此经中佛自说不合因缘

【经】何以故。佛即是萨婆若。萨婆若即是佛。菩提即是萨婆若。萨婆若即是菩提。舍利弗。菩萨摩诃萨行般若波罗蜜。如是习应。是名与般若波罗蜜相应。复次舍利弗。菩萨摩诃萨行般若波罗蜜。不习色有不习色无。受想行识亦如是。不习色有常不习色无常。受想行识亦如是。不习色苦不习色乐。受想行识亦如是。不习色我不习色非我。受想行识亦如是。不习色寂灭不习色非寂灭。受想行识亦如是。不习色空不习色非空。受想行识亦如是。不习色有相不习色无相。受想行识亦如是。不习色有作不习色无作。受想行识亦如是。是菩萨摩诃萨行般若波罗蜜时。不作是念。我行般若波罗蜜。不行般若波罗蜜。非行非不行般若波罗蜜。舍利弗。菩萨摩诃萨如是习应。是名与般若波罗蜜相应

【论】释曰。若菩萨观五众非有非无。于是亦不着。尔时与般若波罗蜜相应。所以者何。一切世间着二见。若有若无。顺生死流者多著有。逆生死流者多着无。我见多者著有。邪见多者着无。复次四见多者著有。邪见多者着无。二毒多者著有。无明多者着无。不知五众因缘集生著有。不知集者着无。近恶知识及邪见外书故堕断灭无罪福。中无见者着无。余者著有。或有众生。谓一切皆空心着是空。着是空故名为无见。或有众生。谓一切六根所知法皆有。是为有见。爱多者著有见见多者着无见。如是等众生著有见无见。是二种见虚妄非实破中道。譬如人行狭道一边深水一边大火二边俱死。著有着无二事俱失。所以者何。若诸法定实有则无因缘。若从因缘和合生。是法无自性。若无自性即是空。若无法是实则无罪福。无缚无解亦无诸法种种之异。复次有见者与无见者相违。相违故有是非。是非故共诤。有诤故起诸结使。结使故生业。生业故开恶道门。实相中无有相违是非斗诤。复次著有者事若无常则生忧恼。若着无者作诸罪业死堕地狱受苦。不著有无者无有如是等种种过失。应舍是则得实。复次是五众若常若无常是事不然。所以者何。若五众常则无生无灭。无生无灭故则无罪福。无罪福故则无善恶果报。世间如涅槃不坏相。如是妄语谁当信者。现见死亡啼哭。是则众生无常。如草木雕落华果磨灭。是则外物无常。大劫尽时一切都灭。是为大无常。如是等种种因缘。如是五众常不可得。复次无常破常。不应以无常为是。所以着何。若诸法无常相念念皆灭。则六情不能取六尘。所以者何。内心外尘。俱无住故。不应得缘不应得知。亦无修习因缘果报。因缘多故果报亦多。此事不应得。又以有常见与无常见共诤。如是等种种因缘。五众无常则不可得苦乐。我非我若空若实。有相无相。有作无作。此义如先处处说。五众寂灭者。因缘生故无性。无性故寂灭。寂灭故如涅槃。三毒炽然故不寂灭。无常火然故不寂灭。不着三毒。实相故不寂灭。三毒各各分别相故不寂灭。此义先未说故今是中说。若菩萨摩诃萨。能如是离二边行中道。行般若波罗蜜亦不着。所以者何。菩萨不可得。般若波罗蜜亦不可得。故不行般若波罗蜜亦不着。所以者何。余诸凡夫不能如菩萨观诸法实相。云何当言我不行般若波罗蜜。行不行亦不着。二俱过故。是名与般若波罗蜜相应相

【经】复次舍利弗。菩萨摩诃萨不为般若波罗蜜故行般若波罗蜜。不为檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜故行般若波罗蜜。不为阿鞞跋致地故行般若波罗蜜。不为成就众生故行般若波罗蜜。不为净佛世界故行般若波罗蜜。不为佛十力四无所畏四无碍智十八不共法故行般若波罗蜜。不为内空故行般若波罗蜜不为外空内外空空空大空第一义空有为空无为空毕竟空无始空散空性空诸法空自相空不可得空无法空有法空无法有法空故行般若波罗蜜。不为如法性实际故行般若波罗蜜。何以故。是菩萨摩诃萨行般若波罗蜜时。不坏诸法相故。如是习应。是名与般若波罗蜜相应

【论】问曰。六波罗蜜乃至如法性实际此是佛法。菩萨若不为是佛法故行般若波罗蜜。更有何法可为行般若波罗蜜。答曰。如佛此中自说诸法无有破坏者。不坏诸法相故。亦不分别是檀是悭乃至是三界是实际。复次有菩萨。于此善法深心系着。以系着故能生罪。为是人故说是六波罗蜜。乃至实际皆空无有自性。如梦如幻汝莫生着。真菩萨不为是故行。有菩萨心无所著。行六波罗蜜乃至实际。为是人故说为是事故行般若波罗蜜。如后品中说。为具足六波罗蜜。乃至为教化众生。净佛世界故行般若波罗蜜

【经】复次舍利弗。菩萨摩诃萨行般若波罗蜜。不为如意神通故行般若波罗蜜。不为天耳故。不为他心智故。不为宿命智故。不为天眼故。不为漏尽神通故。行般若波罗蜜。何以故。菩萨摩诃萨行般若波罗蜜。尚不见般若波罗蜜。何况见菩萨神通。舍利弗。菩萨摩诃萨如是行。是名与般若波罗蜜相应

【论】问曰。先说禅波罗蜜中已具说五神通。今何以复重说。答曰。彼中总相说不列名字。此中别相说。复次功德果报。所谓五神通菩萨得是五神通。广能利益众生。复次虽有慈悲般若波罗蜜。无五神通者如鸟无两翼不能高翔。如健人无诸器杖而入敌阵。如树无华果无所饶益。如枯渠无水无所润及。以是故重说五神通。及余无量佛法中别说无咎。问曰。若尔者。佛何以言莫为五神通故行般若波罗蜜。答曰。多有无方便菩萨。得五神通轻余菩萨心生憍高。为是故说。所以者何。菩萨于般若波罗蜜诸佛之母尚不着。何况五神通

【经】复次舍利弗。菩萨摩诃萨行般若波罗蜜。不作是念。我以如意神通飞到东方。供养恭敬如恒河沙等诸佛。南西北方四维上下亦如是。复次舍利弗。菩萨摩诃萨行般若波罗蜜。不作是念。我以天耳闻十方诸佛所说法。不作是念。我以他心智当知十方众生心所念。不作是念。我以宿命通知十方众生宿命所作。不作是念。我以天眼见十方众生死此生彼。舍利弗。菩萨摩诃萨如是行。是名与般若波罗蜜相应。亦能度无量阿僧祇众生

【论】释曰。先虽说五神通名。今此中说其功用。问曰。菩萨何以故不作是念。我以如意神通飞到十方。供养恭敬如恒河沙等诸佛。答曰。已拔我见根本故。已摧破憍慢山故。善修三解脱门三三昧故。佛身虽妙亦入三解脱门。如热金丸虽见色妙不可手触。又诸法如幻如化无来无去无近无远无有定相。如幻化人谁去谁来。不取神通国土此彼近远相故无咎。若能在佛前住于禅定。变为无量身至十方供养诸佛无所分别。已断法爱故。余通亦如是。菩萨得是五神通。为供养诸佛故。变无量身显大神力。于十方世界三恶趣中度无量众生。如往生品中说

【经】舍利弗。菩萨摩诃萨能如是行般若波罗蜜。恶魔不能得其便。世间众事所欲随意。十方各如恒河沙等诸佛。皆悉拥护是菩萨。令不堕声闻辟支佛地。四天王天乃至阿迦尼吒天。皆亦拥护是菩萨不令有碍。是菩萨所有重罪现世轻受。何以故。是菩萨摩诃萨用普慈加众生故。舍利弗。是菩萨摩诃萨如是行。是名与般若波罗蜜相应

【论】释曰。今赞是菩萨。如上行般若波罗蜜得大功德是名菩萨。智慧功力果报得此五利。问曰。魔是欲界主。菩萨是人肉眼不得自在。云何不能得其便。答曰。如此中佛自说。诸佛诸大天拥护故。复次是菩萨行毕竟不可得自相空故。于一切法中皆不着。不着故无违错。无违错故魔不能得其便。譬如人身不疮虽卧毒屑中毒亦不入。若有小疮则死无疑。又是菩萨于诸佛中心不着。于诸魔中心不嗔。是故魔不得便。复次菩萨深入忍波罗蜜慈三昧故。一切外恶不能中伤。所谓水火刀兵等。世间众事者资生所须。所谓治生谐偶。种莳果树旷路作井安立客舍如法理事皆得如意。若欲造立塔寺作大福德。若作大施。若欲说法教度众生皆得如意。如是等世间众事若大若小皆得如法随意。所以者何。是菩萨世世集无量福德智慧因缘故。复次是菩萨行般若波罗蜜。于一切法中心不着。心不着故结使薄。结使薄故能生深厚善根。深厚善根生故所愿如意。复次是菩萨行般若波罗蜜故。诸大天皆敬念是菩萨赞叹称扬其名。诸龙鬼等闻诸天称说。亦来助成其事。是故世间众事皆得如意。复次是菩萨为诸佛所念。威德所加皆得如意。问曰。十方诸佛心等。何以偏念是菩萨。答曰。是菩萨智慧功德大故。诸佛心虽平等。法应念是菩萨以劝进余人。又是菩萨得佛智慧气分故。别知善恶赏念好人无过于佛。是故佛念。复次佛念不欲令堕声闻辟支佛故。所以者何。入空无相无作。以佛念故而不堕落。譬如鱼子母念故得生不念则坏。诸大天拥护者。不欲令失其所行。诸天效佛念故又诸天以菩萨行般若波罗蜜。都无所著不乐世乐。但欲教化众生故住于世间。知其尊贵故念。所有重罪者。先世重罪应入地狱。以行般若波罗蜜故现世轻受。譬如重囚应死有势力者护则受鞭杖而已。又如王子虽作重罪以轻罚除之。以是王种中生故。菩萨亦如是。能行是般若波罗蜜得实智慧故。即入佛种中生。佛种中生故虽有重罪云何重受。复次譬如铁器中空故在水能浮中实则没。菩萨亦如是。行般若波罗蜜智慧心虚故不没重罪。凡人无智慧故沉没重罪。复次佛此中自说因缘所以得五功德者。用普慈加众生故。问曰。先言行般若波罗蜜故具五功德。今何以言用普慈加众生故。答曰。能生无量福无过于慈。是慈因般若波罗蜜生。得无量利益。复次恶魔不得便。诸佛所念重罪今世轻受。是般若波罗蜜力。世间众事所欲随意诸天拥护是大慈力。复次有二种缘。一者众生。二者法。是菩萨若缘众生则是慈心。若缘法则是行般若波罗蜜。是慈从般若波罗蜜生。随顺般若波罗蜜教。是故说慈无咎

【经】复次舍利弗。菩萨摩诃萨行般若波罗蜜时。疾得诸陀罗尼门诸三昧门。在所生处常值诸佛。乃至得阿耨多罗三藐三菩提。初不离见佛。舍利弗。菩萨摩诃萨如是习应。是名与般若波罗蜜相应

【论】释曰。陀罗尼三昧门如先说。疾得者。福德因缘故心柔软。行深般若波罗蜜故智慧心利。以是故疾得。如上说五功德故疾得。所生处常值诸佛者。是菩萨除诸佛母般若波罗蜜。其余一切众事皆不爱着。是以在所生处常值诸佛。如人常喜斗诤生还活地狱。复执刀杖共相加害。淫欲多故常受胞胎又作淫鸟。嗔恚多故还生毒兽蛇虺之属。愚痴多者如灯蛾赴火地中隐虫等。是诸菩萨爱敬于佛及实相般若波罗蜜。及修念佛三昧业故。所生处常值诸佛。复次如先菩萨愿见诸佛中说。终不离见佛者。又人虽一世见佛更不复值。如毗婆尸佛时。王师婆罗门虽得见佛及僧。而恶口毁呰言。此人等如畜生不别好人见我不起。以是罪故经九十一劫堕畜生中。复次深念佛故终不离佛。世世善修念佛三昧故。不失菩萨心故。作不离佛愿。愿生在佛世故。种值佛业缘常相续不断故。乃至阿耨多罗三藐三菩提。终不离见佛。问曰。此是果报事。云何说与般若波罗蜜相应。答曰。般若波罗蜜相应故值佛。或时果中说因故。相应有二种。一者心相应。二者应菩萨行。所谓生好处值遇诸佛。常闻法正忆念。是名相应

【经】复次舍利弗。菩萨摩诃萨行般若波罗蜜时。不作是念。有法与法若合若不合。若等若不等。何以故。是菩萨摩诃萨不见是法与余法若合若不合若等若不等。舍利弗。菩萨摩诃萨如是习应。是名与般若波罗蜜相应

【论】释曰。一切法无有法与法共合者。何以故。诸法无少分合故。譬如二指有四方。其一方合三方不合。不合多故。何以不名为不合。问曰。以有合处故名为合。云何言不合。答曰。合处不为指是指分。但是指分更无指法。以二指相近故。假名为合更无合法。复次色香味触总名为指。但触有合力余三无合。以是故不得言指合。复次如异类同处不名为合相。各异故。诸法亦尔。地相地中水相水中火相火中。如是性异不名为合。以是故言无有法与法合。若合若不合等者。一切法一相故名等。以皆是有相皆是无常相。皆是苦相。皆是空无我相。皆是不生不灭相。事无异故名为等。不等者。各各别相故。如色相无色相坚相湿相。如是等各异不同。是名不等。菩萨不见等与不等。何以故。一切法无故。自性空故无法。无法故不可见。不可见故无等不等。等与合是习相应。不合不等是不相应。问曰。何以不说相应竟然后赞叹。答曰。听者厌懈是故佛赞叹果报功德。闻者心得悦乐故

【经】复次舍利弗。菩萨摩诃萨行般若波罗蜜。不作是念。我当疾得法性若不得。何以故。法性非得相故。舍利弗。菩萨摩诃萨如是习应。是名与般若波罗蜜相应

【论】释曰。法性者诸法实相。除心中无明诸结使。以清净实观得诸法本性。名为法性。性名真实。以众生邪观故缚正观故解。菩萨不作是念。我疾得法性。何以故。法性无相无有远近。亦不言我久久当得。何以故。法性无迟无久。法性义如如法性实际义中说

【经】复次舍利弗。菩萨摩诃萨行般若波罗蜜时。不见有法出法性者。如是习应。是名与般若波罗蜜相应

【论】释曰。无明等诸烦恼。入一切法中故。失诸法自性。自性失故皆邪曲不正。圣人除却无明等。诸法实性还得明显。譬如阴云覆虚空清净性。除阴云则虚空清净性现。若有法无明不入者。是则出于法性。但是事不然。无有法出无明者。是故菩萨不见是法出法性者。譬如众流皆归于海。如粟散小王皆属转轮圣王。如众小明皆属于日

【经】复次舍利弗。菩萨摩诃萨行般若波罗蜜时。不作是念。法性分别诸法。如是习应。是名与般若波罗蜜相应

【论】问曰。何以故不作是念。法性分别诸法。答曰。为着法性贵于法性。以是因缘生诸结使。是故不作是念。问曰。若法性空一相无相。云何分别诸法。答曰。得是法性灭无明等诸烦恼。破诸法实相者。然后心清净智慧明了知诸法实。随法性者为善。不随法性者为不善。如婆蹉梵志问佛。世尊。天地间有善恶好丑不。佛言有。婆蹉言。我久归命佛。愿为我善说。佛言。有三种恶三种善。十种恶十种善。所谓贪欲是恶。除贪是善。嗔恚愚痴是恶。除恚痴是善。杀生是恶。除杀生是善。乃至邪见是恶。除邪见是善。能如实分别善恶。是我弟子入于法性。名为得道

【经】复次舍利弗。菩萨摩诃萨行般若波罗蜜时。不作是念。是法能得法性若不得。何以故。是菩萨不见用是法能得法性若不得。舍利弗。菩萨摩诃萨如是习应。是名与般若波罗蜜相应

【论】释曰。云何得法性行八圣道分得诸法实相。所谓涅槃是名得法性。复次性名诸法实相。法名般若波罗蜜。菩萨不作是念。行般若波罗蜜得是诸法性。何以故。般若波罗蜜及诸法性。是二法无有异。皆毕竟空故。云何以般若波罗蜜得达法性

【经】复次舍利弗。菩萨摩诃萨行般若波罗蜜时。法性不与空合。空不与法性合。如是习应。是名与般若波罗蜜相应

【论】释曰。菩萨不观法性是空。不观空是法性。行空得法性。缘法性得空。以是故无异。所以者何。是二毕竟空故

【经】复次舍利弗。菩萨摩诃萨行般若波罗蜜时。眼界不与空合。空不与眼界合。色界不与空合。空不与色界合。眼识界不与空合。空不与眼识界合。乃至意界不与空合。空不与意界合。法界不与空合。空不与法界合。意识界不与空合。空不与意识界合。是故舍利弗。是空相应名为第一相应

【论】释曰。眼界不与空合空不与眼界合者。眼是有。空是无。空有云何合。复次菩萨种种因缘分别。散灭是眼眼则空。空无眼名因本故有。眼空空亦无。分别是眼空是非眼空。是则眼不与空合。又空不从眼因缘生。何以故。是二法本自空故。乃至意识界亦如是。问曰。此中何以不说五众等诸法但说十八界。答曰。应说或时诵写者忘失。复有人言。若说十八界则摄一切法。有众生于心色中错。心法中不错。应闻十八界得度。是故但说十八界。问曰。何以名为第一相应。答曰。空是十方诸佛深奥之藏。唯一涅槃门更无余门。能破诸邪见戏论。是相应不可坏不可破。是故名为第一。复次佛自说第一因缘。所谓

【经】舍利弗。空行菩萨摩诃萨不堕声闻辟支佛地。能净佛土成就众生。疾得阿耨多罗三藐三菩提。舍利弗。诸相应中般若波罗蜜相应为最第一。最尊最胜最妙为无有上。何以故。是菩萨摩诃萨行般若波罗蜜相应。所谓空无相无作。当知是菩萨如受记无异。若近受记。舍利弗。菩萨摩诃萨如是相应者。能为无量阿僧祇众生作益厚。是菩萨摩诃萨亦不作是念。我与般若波罗蜜相应。诸佛当授我记。我当近受记。我当净佛土我得阿耨多罗三藐三菩提。当转法轮。何以故。是菩萨摩诃萨不见有法出法性。亦不见有法行般若波罗蜜。亦不见有法诸佛授记。亦不见有法得阿耨多罗三藐三菩提。何以故。菩萨摩诃萨行般若波罗蜜时。不生我相众生相乃至知者见者相。何以故。众生毕竟不生不灭故。众生无有生无有灭。若法无有生相灭相。云何是法当行般若波罗蜜。如是舍利弗。菩萨摩诃萨不见众生故。为行般若波罗蜜。众生不受故。众生空故。众生不可得故。众生离故。为行般若波罗蜜。舍利弗。菩萨摩诃萨于诸相应中为最第一相应。所谓空相应。是空相应胜余相应。菩萨摩诃萨如是习空。能生大慈大悲。菩萨摩诃萨习是相应。不生悭心。不生犯戒心。不生嗔心。不生懈怠心。不生乱心。不生无智心

【论】释曰。不堕声闻辟支佛地者。空相应有二种。一者但空。二者不可得空。但行空堕声闻辟支佛地。行不可得空空亦不可得。则无处可堕。复有二种空。一者无方便空堕二地。二者有方便空则无所堕。直至阿耨多罗三藐三菩提。复次本有深悲心入空则不堕。无大悲心则堕。如是等因缘不堕二地。能净佛世界成就众生者。菩萨住是空相应中无所复碍。教化众生令行十善道及诸善法以众生行善法因缘故佛土清净。以不杀生故寿命长。以不劫不盗故。佛土丰乐应念即至。如是等众生行善法则佛土庄严。问曰。教化众生则佛土净。何以别说。答曰。众生虽行善。要须菩萨行愿回向方便力因缘故。佛土清净。如牛力挽车要须御者乃得到所至处。以是故别说。疾得者行是空相应无有障碍。则能疾得阿耨多罗三藐三菩提。问曰。先说空相应。今说般若波罗蜜相应。后说无相无作相应。有何差别。答曰。有二种空。一者般若空。二者非般若空。先言空相应。听者疑谓一切空。故说是般若波罗蜜空。复有人疑。但言空第一。无相无作非第一耶。是故说空无相无作相应亦是第一。何以故。空则是无相。若无相则是无作。如是为一名字为别。最上故言尊。破有故言胜。得是相应不复乐余。是为最妙。如一切众生中佛为无上。一切法中涅槃无上。一切有为法中善法习相应为无上。余义如赞般若品中说。问曰。若能行如是空相应便应受记。云何言如受记无异若近受记。答曰。是菩萨新行道肉身未得无生法忍。未得般舟三昧。但以智慧力故。能如是分别深入空。佛赞其入空功德故。言如受记无异。有三种菩萨得受记者。如受记者近受记者得受记者。如阿毗跋致品中说。三种如此中说。问曰。如此说相应第一无上。云何不与受记。答曰。余功德方便禅定等未集但有智慧。是故未与受记。复次是菩萨虽复利根智慧。余功德未熟故。闻现前受记或生憍慢。是故未与受记。所以赞叹者。欲以劝进其心。利根者行是空相应。如受记无异。钝根者行是空相应。若近受记。令众生常安隐得涅槃。是名利益。复有二种利益。一者离苦。二者与乐。复有二种。灭众生身苦心苦。复有三种。天乐人乐涅槃乐。复有三种。离三界入三乘。如是菩萨摩诃萨无量阿僧祇利益众生。众生义如先说。世人有大功勋则生憍心求其报赏。以求报故则为不净。菩萨则不然。虽与般若波罗蜜相应利益无量众生。无我心无憍慢故不求功报。如地虽利物功重不求其报。以是故说。是菩萨不作是念。我与般若相应。诸佛当受我记若近受记。我当净佛土得无上道转法轮。转法轮义如先说。问曰。何等法出法性。答曰。此中佛说。所谓行般若波罗蜜者。行般若波罗蜜者即是菩萨。知者见者即是众生。法性中众生变为法性以是故菩萨自不生高心。不从众生求恩分。不见诸佛与受记。如菩萨空佛亦如是。如行者空得阿耨多罗三藐三菩提者亦空。何以故。佛自说菩萨摩诃萨行般若波罗蜜。不生众生相乃至知者见者相。菩萨行般若波罗蜜。尚不生法相。何况众生相。何以故。佛自说因缘。是众生毕竟不生。不生故不灭。若法不生不灭即是法性相。法性即是般若波罗蜜。云何般若波罗蜜行般若波罗蜜。菩萨不受众生者不受神但有虚妄计我。众生空者。众生法无所有故。众生不可得者。以实智求索不可得故。众生离者。一切法自相离故。一切离自相者。如火离热相等。如相空中广说。第一相应胜余相应如上说。菩萨行是众生空法空深入空相应。忆本愿度众生。见众生狂惑颠倒于空事中种种生着。即生大悲心。我虽知是事余者不知。以教化故生大慈大悲。亦能常不生破六波罗蜜法。所以者何。初发心菩萨行六波罗蜜。以六恶杂行故六波罗蜜不增长。不增长故不疾得道。今知诸法相拔是六恶法根本。所以者何。菩萨知布施为善。悭心不善。能堕饿鬼贫穷中知悭贪。如是自惜其身着世间乐故还生悭心。是菩萨轻物能施重物不能。外物能内物不能。以着我着受者以取相着财物。以是故破檀波罗蜜。虽有所施而不清净。是菩萨行空相应故不见我。亦不见世间乐。云何生着而破檀波罗蜜。问曰。若不见我不见世间乐。故不破亦应不见檀。云何行布施。答曰。是菩萨虽不见布施。以清净空心布施作是念。是布施空无所有。众生须故施与。如小儿以土为金银。长者则不见是金银。便随意与竟无所与。余五法亦如是。以是故虽同空破悭而不破檀。舍利弗。菩萨摩诃萨住是空相应中。能常不生是六恶心

大智度论卷第三十七大智度论释往生品第四之上(卷三十八)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】舍利弗白佛言。世尊菩萨摩诃萨行般若波罗蜜。能如是习相应者。从何处终来生此间。从此间终当生何处。佛告舍利弗。是菩萨摩诃萨行般若波罗蜜。能如是习相应者。或从他方佛国来生此间。或从兜率天上来生此间。或从人道中来生此间。舍利弗。从他方佛国来者。疾与般若波罗蜜相应。与般若波罗蜜相应故。舍身来生此间。诸深法要皆现在前。后还与般若波罗蜜相应。在所生处常值诸佛。舍利弗。有一生补处菩萨。兜率天上终来生是间。是菩萨不失六波罗蜜。随所生处一切陀罗尼门。诸三昧门疾现在前。舍利弗。有菩萨人中命终还生人中者。除阿毗跋致。是菩萨根钝不能疾与般若波罗蜜相应。诸陀罗尼门三昧门不能疾现在前

【论】问曰。是般若波罗蜜中众生毕竟不可得。如上品说。舍利弗如一切众生不可得。寿者命者乃至知者见者等。众生诸异名字皆空无实。此中何以问从何所来去至何所上。众生异名即是菩萨。众生无故菩萨亦无。又此经中说。菩萨但有名字无有实法。今舍利弗何以作此问。答曰。佛法中有二谛。一者世谛。二者第一义谛。为世谛故说有众生。为第一义谛故说众生无所有。复有二种。有知名字相。有不知名字相。譬如军立密号有知者有不知者。复有二种。有初习行。有久习行。有著者。有不著者。有知他意者。有不知他意者。(虽有言辞知其寄言以宣理)为不知名字相初习行着不知他意者。故说无众生。为知名字相久习行不着知他意者。故说言有众生。舍利弗以天眼明见六道众生生死善恶。于此无疑。但不知从他方无量阿僧祇世界诸菩萨来者故问。有诸大菩萨。从此间终生他方无量阿僧祇佛国。舍利弗天眼所不见故问。复次有声闻人。见菩萨行六波罗蜜。久住生死中漏未尽故。集种种智慧内外经书。而不证实际未免生老病死。愍而轻之言。此等命终以三毒未尽故当堕何处。如佛说诸凡夫人常开三恶道门。于三善道为客。于三恶处为家。三毒力强。过去世无量劫罪业积集而不取涅槃。将受众苦甚可惑之。如是等小乘人轻愍是菩萨。舍利弗于一切声闻中为第一大法将。知有是事。欲令众生起敬心于菩萨故问。佛以三事答。一从他方佛国来生。二从兜率天上来。三从人道中来。问曰。如从他方佛国来者。以远故舍利弗不知。兜率天上人道中来者何以不知。答曰。舍利弗不知他方佛国来者故问。佛为如所应分别答有三处来。问曰。世间有六道。何以故。于天中别说兜率天来。人道中不分别处所。他方佛国来者。亦不分别天道人道。答曰。六趣中三是恶道。恶道中来受苦因缘。心钝故不任得道。是故不说。问曰。三恶道中来亦有得道者。如舍利弗大弟子牛足比丘。五百世牛中生。末后得人身足犹似牛。而得阿罗汉道。复有摩偷婆尸他比丘。五百世生猕猴中。末后得人身得三明六神通阿罗汉犹好跳踯。以有余习故。如是等皆得道。何以言不任。答曰。虽有得者少不足言。又此人先世深种涅槃善根。小有谬错故堕恶道中。偿罪既毕涅槃善根熟故得成道果。此中不说声闻道。但为得阿耨多罗三藐三菩提。前身后身次第。譬如从垢心起不得次第入无漏。中间必有善有漏心。以无漏心贵故。言于三恶道出不任次第得阿耨多罗三藐三菩提心。天人阿修罗则不然。下三天结使利而深。上二天结使深而不利。兜率天结使不深不利。所以者何。常有菩萨说法故。是故不说余处。或有少故不说。色界诸天得道者不复来下。未得道者乐着禅味故不下。以着味故智慧亦钝。是故不说。阿修罗同下二天故不说。他方佛国来者。从诸佛前来生是间诸根猛利。所以者何。除无量阿僧祇劫罪故。又遇诸佛随心教导故。如刀得好石则利。又常闻诵正忆念般若波罗蜜故利。如是等因缘则菩萨心利。人中来者此间佛弟子。听般若波罗蜜集诸功德。舍身还生是间。或于异国土虽无有佛值遇佛法。听受书写正忆念。随力多少修福德智慧。是人诸根虽钝堪受般若波罗蜜。以不见现在佛故心钝。他方佛国来者利根故。修行般若波罗蜜疾得相应。以相应故常值诸佛。值佛因缘如先说。问曰。兜率天上。何以但说一生补处。不说二生三生。答曰。人身罪结烦恼处所。唯大菩萨处之则无染累。如鹅入水水不令湿。如是菩萨一切世间法所不能着。所以者何。佛自说因缘。不失六波罗蜜诸陀罗尼门诸三昧门。疾现在前。是菩萨于是世界应利益众生。其余菩萨分布十方。譬如大智慧人已在一处。其余大智则至异处。是故不说。复次有人言。但说大者不限于小。复次余天中来生者余处当广说。人中死人中生者。不如上二处。何以故。以人身地大多故。身重心钝。以心心数法随身强弱故。又诸业结使因缘生故。彼二处来者是法身菩萨。变身无量以度众生。故来生是间。人道中者皆是肉身。问曰。阿毗跋致菩萨不以结业受身。何以故人道中说。答曰。来生此间得阿毗跋致。未舍肉身故。以钝根故。诸陀罗尼三昧门不疾现在前不疾现在前故不疾与般若相应

【经】舍利弗。汝所问菩萨摩诃萨与般若波罗蜜相应。从此间终当生何处者。舍利弗。此菩萨摩诃萨从一佛国至一佛国。常值诸佛终不离佛。舍利弗。有菩萨摩诃萨。不以方便入初禅乃至第四禅。亦行六波罗蜜。是菩萨摩诃萨得禅故生长寿天。随彼寿终来生是间。得人身值诸佛。是菩萨诸根不利。舍利弗。有菩萨摩诃萨。入初禅乃至第四禅。亦行般若波罗蜜。不以方便故舍诸禅生欲界。是菩萨诸根亦钝。舍利弗。有菩萨摩诃萨。入初禅乃至第四禅。入慈心乃至舍。入虚空处乃至非有想非无想处。修四念处乃至八圣道分。行十力乃至大慈大悲。是菩萨用方便力不随禅生。不随无量心生。不随四无色定生。在所有佛处于中生。常不离般若波罗蜜行。如是菩萨贤劫中当得阿耨多罗三藐三菩提

【论】问曰。舍利弗今问前世后世。佛何以故前世中三种答。后世中广分别。答曰。人以肉眼不见过去未来故。而生邪疑。虽疑二处而未来世当受故广分别。譬如已灭之火不复求救。但多方便防未来火。又如治病已灭之病不复加治。但治将生之病。复次佛无量辩才自恣。舍利弗所问虽少佛广为其说。如问与般若波罗蜜相应一事。而佛种种分别。如贫者从大富好施者乞。所乞虽少所与甚多。佛亦如是。有无量无漏佛法具足之富。以大慈悲好行施惠。因舍利弗少问故。佛为大众广分别说。复次是般若波罗蜜中种种因缘譬喻多说空法。有新发意者。取空相着是空法。于生死业因缘中生疑。若一切法毕竟空。无来无去无出无入相。云何死而有生。现在眼见法尚不应有。何况死后余处生。不可见而有。如是等种种邪疑颠倒心为断。是故佛种种因缘广说有死有生。问曰。无有死生因缘。何以故。人死归灭。灭有三种。一者火烧为灰。二者虫食为粪。三者终归于土。今但见其灭。不见更有出者受于后身。以不见故则知为无。答曰。若汝谓身灭便无者。云何有众生先世所习忧喜怖畏等。如小儿生时或啼或笑。先习忧喜故。今无人教而忧喜续生。又如犊子生知趣乳。猪羊之属其生未几。便知有牝牡之合。子同父母好丑贫富聪明闇钝各各不同。若无先世因缘者不应有异。如是等种种因缘知有后世。又汝先言不见别有去者。人身中非独眼根能见。身中六情各有所知。有法可闻可嗅可味可触可知者。可闻法尚不可见。何况可知者。有生有死法亦可见亦可知。汝肉眼故不见。天眼者了了能见。如是人从一房出入一房。舍此身至后身亦如是。若肉眼能见者。何用求天眼。若尔者天眼肉眼愚圣无异。汝以畜生同见。何能见后世可知者。如人死生。虽无来去者而烦恼不尽故。于身情意相续更生身情意。身情意造业亦不至后世。而从是因缘更生受后世果报。譬如乳中着毒。乳变为酪。酪变为酥。乳非酪酥。酪酥非乳。乳酪虽变而皆有毒。此身亦如是。今世五众因缘故更生后世。五众行业相续不异故而受果报。又如冬木。虽未有花叶果实。得时节会则次等而出。如是因缘故知有死生。复次现世有知宿命者。如人行疲极睡卧觉已忆所经由。又一切圣人内外经书皆说后世。复次现世不善法动发过重。生嗔恚嫉妒疑悔。内恼故身则枯悴颜色不悦。恶不善法受害如是。何况起身业口业。若生善法净信业因缘。心清净得如实智慧。心则欢悦身得轻软颜色和适。以有苦乐因缘故有善不善。今定有善不善故。当知必有后世。但众生肉眼不见。智慧薄故而生邪疑。虽修福事所作浅薄。譬如药师为王疗病。王密为起宅而药师不知。既归见之乃悔不加意尽力治王。复次圣人说今现在事实可信故。说后世事亦皆可信。如人夜行崄道导师授手。知可信故则便随逐。比智。及圣人语可知定有后世。汝以肉眼重罪比智薄故又无天眼。既自无智又不信圣人语。云何得知后世。复次佛法中诸法毕竟空。而亦不断灭。生死虽相续亦不是常。无量阿僧祇劫业因缘虽过去。亦能生果报而不灭。是为微妙难知。若诸法都空者。此品中不应说往生。何有智者前后相违。若死生相实有。云何言诸法毕竟空。但为除诸法中爱着邪见颠倒故。说毕竟空。不为破后世故说。汝无天眼明故疑后世。欲自陷罪恶。遮是罪业因缘故。说种种往生。佛法不著有不着无。有无亦不着。非有非无亦不着。不着亦不着。如是人则不容难。譬如以刀斫空终无所伤。为众生故。随缘说法自无所著。以是故中论中说

  一切诸法实　　一切法虚妄
  诸法实亦虚　　非实亦非虚
  涅槃际为真　　世间际亦真
  涅槃世无别　　小异不可得

是为毕竟空相。毕竟空不遮生死业因缘。是故说往生。问曰。若般若波罗蜜一相所谓无相。云何与般若相应。从一佛国至一佛国常值诸佛。答曰。般若波罗蜜摄一切法。譬如大海。以是故不应作难。复次汝自说般若波罗蜜一相无相。若无相云何有难。汝则无相中取相。是事不然。复次因般若波罗蜜故。行念佛三昧等诸善法生值诸佛。复次行般若波罗蜜者。深入大悲如慈父见子。为无所直物故死。父甚愍之。此儿但为虚诳故死。诸佛亦如是。知诸法毕竟空不可得。而众生不知。众生不知故于空法中深着。着因缘故堕大地狱。是故深入大悲。以大慈悲因缘故得无量福德。得无量福德故生值诸佛。从一佛国至一佛国。是菩萨从此间死彼间生。彼间死复至彼间生。如是乃至得佛终不离佛譬如有福之人从一大会至一大会。或有是间死彼间生。于彼以五神通力故。从一佛国至一佛国。供养诸佛度脱众生。是初菩萨。佛国者。十方如恒河沙等诸三千大千世界。是名一佛土。诸佛神力虽能普遍自在无碍。众生度者有局。诸佛现在者。佛现在其佛国土中者。第二菩萨无方便入初禅。乃至行六波罗蜜。无方便者入初禅时不念众生。住时起时亦不念众生。但着禅味不能与初禅和合行般若波罗蜜。是菩萨慈悲心薄故功德薄少。功德薄少故为初禅果报所牵生长寿天。复次不能以初禅福德与众生共回向阿耨多罗三藐三菩提。如是等无量无方便义。长寿天者。非有想非无想处。寿八万大劫。或有人言。一切无色定通名长寿天。以无形不可化故。不任得道。常是凡夫处故。或说无想天名为长寿。亦不任得道故。或说从初禅至四禅。除净居天皆名长寿。以着味邪见不能受道者还生人间。值佛者。以本发阿耨多罗三藐三菩提心故。或于禅中集诸福德。所以者何。彼间着味善心难生故。如经中说。如佛问比丘甲头土多地上土多。诸比丘言。地土甚多不可为喻。佛言。天上命终还生人中者如甲头土。堕地狱者如地土。问曰。钝根者二十二根中何者是。答曰。有人言慧根能观诸法。以久受着禅味故钝。有人言信等五根皆助成道法。以受报着味故钝。有人言。菩萨清净福德智慧因缘故。十八根皆利。罪故则钝。眼等六根如法华经说。命根不为老病贫穷等所恼。安隐受乐是为命根利。喜乐等五根了了觉知故言利。复次受乐时知乐无常等过随逐不生贪欲故利。余受亦如是。信根牢坚深固。难事能信故言利。余亦应如是随相分别。男根净者。得阴藏相。不着细滑故。知欲为过是为利。复次三善根利故名为利。菩萨或时于三无漏根不证实际故利。与利相违故钝。问曰。第三菩萨若能舍禅。云何言无方便。答曰。是菩萨命终时。入不善心舍诸禅定方便。菩萨若入欲界系善心若无记心。而舍诸禅入慈悲心。怜愍众生作是念。我若随禅定生。不能广利益众生。生欲界者有十处。四天下人六欲天。三恶道菩萨所不生。钝根者如第二菩萨说。第四菩萨入位得菩萨道。修三十七品。能住十八空乃至大慈大悲。此名方便。上二菩萨但有禅定直行六波罗蜜。以是故无方便。第四菩萨方便力故不随禅定无量心生。所以者何。行四念处乃至大慈大悲故。命终时怜愍众生。愿生他方现在佛国。续与般若波罗蜜相应。所以者何。爱乐随顺般若波罗蜜故。问曰。此是何等菩萨。答曰。佛自说跋陀劫中菩萨。或有非跋陀劫中菩萨。但取其大者。问曰。云何名跋陀。云何名劫。答曰。如经说有一比丘问佛言。世尊几许名劫。佛告比丘。我虽能说汝不能知。当以譬喻可解。有方百由旬城溢满芥子。有长寿人过百岁持一芥子去。芥子都尽劫犹不澌。又如方百由旬石。有人百岁持迦尸轻软叠衣一来拂之石尽劫犹不澌。时中最小者六十念中之一念。大时名劫。劫有二种。一为大劫。二为小劫。大劫者如上譬喻。劫欲尽时众生自然心乐远离。乐远离故除五盖入初禅。是人离生喜乐。从是起已。举声大唱言。诸众生甚可恶者是五欲第一。安隐者是初禅。众生闻是唱已。一切众生心皆自然远离五欲入于初禅。自然灭觉观入第二禅。亦如是唱。或离二禅三禅亦如是。三恶道众生自然得善心。命终皆生人中。若重罪者生他方地狱。如泥犁品中说。是时三千大千世界无一众生在者。尔时二日出乃至七日出。三千大千世界地尽皆烧尽。如十八空中广说劫生灭相。复有人言。四大中三大有所动作故。有三种劫。或时火劫起烧三千大千世界。乃至初禅四处。或时水劫起漂坏三千大千世界。乃至二禅八处。或时风劫起吹坏三千大千世界。乃至三禅十二住处。是名大劫。小劫亦三种。外三大发故世界灭。内三毒发故众生灭。所谓饥饿刀兵疾病。复有人言。时节岁数名为小劫。如法华经中说。舍利弗作佛时正法住世二十小劫。像法住世二十小劫。佛从三昧起。于六十小劫中说法华经。是众小劫和合名为大劫。劫簸秦言分别时节。跋陀者秦言善。有千万劫过去空无有佛。是一劫中有千佛兴。诸净居天欢喜故名为善劫。净居天何以知此劫当有千佛。前劫尽已廓然都空。后有大水。水底涌出有千枚七宝光明莲华。是千佛之相。净居诸天因是知有千佛。以是故说是菩萨于此劫中得阿耨多罗三藐三菩提

【经】舍利弗。有菩萨摩诃萨。入初禅乃至第四禅。入慈心乃至舍。入空处乃至非有想非无想处。以方便力故不随禅生。还生欲界若刹利大姓婆罗门大姓居士大家。成就众生故

【论】问曰。菩萨有二种。一者随业生。二者得法性身。为度众生故。种种变化身生三界。具佛功德度脱众生故。二者之中今是何者。答曰。是菩萨是业因缘生身。所以者何。入诸禅方便力故不随禅生。法身菩萨变化自在则不大须方便。入禅方便义先已说。问曰。若不随禅定。何以生于欲界不生他方清净世界。答曰。诸菩萨行各不同。或有菩萨。于禅转心生他方佛国。菩萨回心生欲界亦如是。问曰。生他方佛国者。为是欲界非欲界。答曰。他方佛国杂恶不净者。则名欲界。若清净者则无三恶道三毒。乃至无三毒之名。亦无二乘之名。亦无女人。一切人皆有三十二相。无量光明常照世间。一念之顷作无量身。到无量如恒河沙等世界。度无量阿僧祇众生。还来本处。如是世界在地上故不名色界。无欲故不名欲界。有形色故不名无色界。诸大菩萨福德清净业因缘故。别得清净世界出于三界。或有以大慈大悲心怜愍众生故生此欲界。问曰。若命终时舍此禅定。初何以求学。答曰。欲界心狂不定。为柔软摄心故入禅。命终时为度众生起欲界心。问曰。若生人中。何以故正生刹利等大家不生余处。答曰。生刹利为有势力。生婆罗门家为有智慧。生居士家为大富故。能利益众生。贫穷中自不能利何能益人生欲界天次当说

【经】舍利弗。复有菩萨摩诃萨。入初禅乃至第四禅。入慈心乃至舍。入空处乃至非有想非无想处。以方便力故不随禅生。或生四天王天处。或生三十三天夜摩天兜率陀天化乐天地化自在天。于是中成就众生。亦净佛世界常值诸佛

【论】是义同上生天为异。问曰。欲界诸天情着五欲难可化度。菩萨何以生彼而不生人中。答曰。诸天着心虽大。菩萨方便力亦大。如说三十三天上有须浮摩树林。天中圣天厌舍五欲。在中止住化度诸天。兜率天上恒有一生补处诸菩萨。常得闻法。密迹金刚力士亦在四天王天上。如是等教化诸天

【经】复次舍利弗。有菩萨摩诃萨。行般若波罗蜜。以方便力入初禅。此间命终生梵天处作大梵天王。从梵天处游一佛国至一佛国。在所有诸佛得阿耨多罗三藐三菩提。未转法轮者劝请令转

【论】问曰。若随初禅生有何方便。答曰。虽生而不着味。念佛道忆本愿。入慈心。念佛三昧时与禅和合故。名为方便。问曰。何以故作梵王。答曰。菩萨集福德因缘大故。世世常为物主。乃至生鹿中亦为其王。复次是菩萨本愿欲请佛转法轮。不应作散天。或时此中三千大千世界。无佛。从一佛国至一佛国。求见初成佛未转法轮者。所以者何。梵天王法。常应劝请诸佛转法轮故

【经】舍利弗。有菩萨摩诃萨。三生补处行般若波罗蜜。以方便力入初禅乃至第四禅。入慈心乃至舍。入空处乃至非有想非无想处。修四念处乃至八圣道分。入空三昧无相无作三昧不随禅生。生有佛处修梵行。若生兜率天上。随其寿终具足善根不失正念。与无数百千亿万诸天围绕恭敬。来生此间得阿耨多罗三藐三菩提

【论】问曰。是三生菩萨在十住地已具足诸功德。今何以修习诸行。答曰。心未入涅槃要有所行。所谓四禅乃至三三昧。复次是菩萨于天人中示行人法修行求道。复次是菩萨虽在十住地犹有烦恼习在。又于诸法犹有所不知。是故修道。复次是菩萨虽行深行。三十七品三解脱门等犹未取证。今为证故更修诸行。复次虽是大菩萨于佛犹小。譬如大聚火虽有能照于日则不现。如放钵经中。弥勒菩萨语文殊尸利。如我后身作佛。如恒河沙等文殊尸利。不知我举足下足事。以是故虽在十住犹应修行。问曰。三生菩萨何以不广度众生而要生佛前。答曰。是菩萨所度已多。今垂欲成佛应在佛前。所以者何。非但度众生得成佛。诸佛深法应当听闻故。问曰。若为咨问佛事故在佛前者。何以故。释迦文佛作菩萨时。在迦叶佛前恶口毁呰。答曰。是事先已说。法身菩萨种种变化身以度众生。或时行人法。有饥渴寒热老病憎爱嗔喜赞叹呵骂等。除诸重罪余者皆行。是释迦文菩萨尔时为迦叶佛弟名郁多罗。兄智慧熟不好多语。弟智慧未备故多好论议。时人谓弟为胜。兄后出家得成佛道号名迦叶。弟为阎浮提王讫梨机师。有五百弟子以婆罗门书教授诸婆罗门。诸婆罗门等不好佛法。尔时有一陶师名难陀婆罗。迦叶佛五戒弟子得三道。与王师郁多罗为善友。以其心善净信故。尔时郁多罗乘金车驾四白马。与弟子俱出城门。难提婆罗于路相逢郁多罗问言。从何所来。答言。汝兄得阿耨多罗三藐三菩提。我供养还。汝可共行觐见于佛。故来相迎。郁多罗作是念。若我径到佛所。我诸弟子当生疑怪。汝本论议智慧恒胜。今往供养将是亲属爱故必不随我。恐破其见佛因缘故。住诸法实相智中入无上方便慧度众弟子。故口出恶言。此秃头人何能得菩提道。尔时难提婆罗善友。为如嗔状捉头挽言。汝不得止。郁多罗语弟子言。其事如是吾不得止。即时师徒俱行诣佛。见佛光相心即清净。前礼佛足在一面坐。佛为随意说法。郁多罗得无量陀罗尼门。诸三昧门皆开。五百弟子还发阿耨多罗三藐三菩提心。郁多罗从坐起白佛言。愿佛听我出家作比丘。佛言善来。即成沙门。以是方便故现出恶言非是实也。虚空可破。水可作火。火可作水。三生菩萨于凡夫中嗔心叵得。何况于佛。问曰。若尔者佛何以受第八罪报六年苦行。答曰。小乘法与大乘法异。若无异者不应有大小。小乘法中。不说法身菩萨秘奥深法无量不可思议神力。多说断结使直取涅槃法。复次若佛不受是第八罪报。有诸天神仙龙鬼诸长寿者。见有此恶业而不受罪报。谓为无业报因缘。以是故虽现在无恶业亦受罪报。又有今世因缘。诸外道等信着苦行。若佛不六年苦行则人不信。言是王子串乐不能苦行。以是故佛六年苦行。有外道苦行者。或三月半岁一岁。无能六年日食一麻一米者。诸外道谓此为苦行之极。是人若言无道真无道也。于是信受皆入正道。以是二因缘故六年苦行非实罪也。何以故诸佛断一切不善法。成就一切善法故。佛若实受罪报不得言成一切善法断一切不善法。复次小乘法中佛为小心众生故说。二生菩萨犹恶口毁佛。二生菩萨尚不骂小儿。云何实毁佛。皆是方便为众生故。何以知之。是释迦文佛。毗婆尸佛时作大婆罗门。见佛众僧食疾而发是言。如是人辈应食马麦。因此罪故堕黑绳等地狱。受无量世苦已。余罪因缘。虽成佛道而三月食马麦。又声闻法中说。佛过三阿僧祇劫常为男子。常生贵处常不失诸根。常识宿命常不堕三恶道中。从毗婆尸佛来。九十一劫如汝法。九十劫中不应堕恶道。何况末后一劫。以是故知非是实也。方便故说。问曰。佛二罪毗尼杂藏中说。是可信受。三阿僧祇后百劫不堕恶道者。从初阿僧祇亦不应堕恶道。若不堕者何以但说百劫。佛无是说。但是阿毗昙鞞婆沙论议师说。答曰。阿毗昙是佛说。汝声闻人随阿毗昙论议。是名鞞婆沙不应有错又如薄拘卢以一诃梨勒果施僧。于九十一劫中不堕恶道。何况菩萨无量世来。以身布施修诸功德。而以小罪因缘堕在地狱。如是事鞞婆沙不应错。以是故小乘人不知菩萨方便。复次听汝鞞婆沙不错。佛自说菩萨本起。菩萨初生时行七步。口自说言。我所以生者为度众生故。言已默然。乳餔三年不行不语。渐次长大行语如法。一切婴孩小时未能行语。渐次长大能具人法。今云何菩萨初生能行能语。后便不能。当知是方便力故。若受是方便。一切佛语悉皆得通。若不受者一实一虚。如是种种因缘。知为度众生故现行恶口。问曰。三生菩萨何以但生兜率天上不生余处。答曰。若在他方世界来者诸长寿天龙鬼神。求其来处不能知。则生疑心谓为幻化。若在人中死人中生然后作佛者。人起轻慢天则不信。法应天来化人。不应人化天也。是故天上来生。则是从天为人。人则敬信。无色界中无形。不得说法故不在中生。色界中虽有色身可为说法。而深着禅味不能大利益众生故。是故不在中生。下三欲天深厚结使粗心错乱。上二天结使既厚心软不利。兜率天上结使薄心软利。常是菩萨住处。譬如太子将登王位。先于静室七日斋洁。然后登正殿受王位。补处菩萨亦如是。兜率天上如斋处。于彼末后受天乐。寿终来下末后受人乐。便成阿毗三佛。无量百千万亿诸天围绕来生是间。以菩萨先常于无始生死中。往反天上人间。今是末后天身不复更来生天。是故咸皆侍送。菩萨于彼寿尽当下作佛。诸天寿有尽者不尽者。作愿下生为菩萨檀越。复次诸天下者欲常侍卫菩萨。以有百亿魔怨恐来恼乱菩萨。故此菩萨生人中厌老病死。出家得阿耨多罗三藐三菩提。如菩萨本起经中说

【经】复次舍利弗。有菩萨摩诃萨。得六神通不生欲界色界无色界。从一佛国至一佛国。供养恭敬尊重赞叹诸佛。舍利弗。有菩萨摩诃萨。游戏神通从一佛国至一佛国。所至到处无有声闻辟支佛乘。乃至无二乘之名。舍利弗。有菩萨摩诃萨。游戏神通从一佛国至一佛国。所至到处其寿无量。舍利弗。有菩萨摩诃萨。游戏神通从一佛国至一佛国。所至到处有无佛法僧处赞佛法僧功德。诸众生等以闻佛名法名僧名故。于此命终生诸佛前

【论】释曰菩萨有二种。一者生身菩萨。二者法身菩萨。一者断结使。二者不断结使。法身菩萨断结使得六神通。生身菩萨不断结使。或离欲得五神通。得六神通者。不生三界。游诸世界供养十方诸佛。游戏神通者。到十方世界度众生雨七宝。所至世界皆一乘清净。寿无量阿僧祇劫。问曰。菩萨法应度众生。何以但至清净无量寿佛世界中。答曰。菩萨有二种。一者有慈悲心多为众生。二者多集诸佛功德。乐多集诸佛功德者。至一乘清净无量寿世界。好多为众生者至无佛法众处。赞叹三宝之音。如后章说

【经】舍利弗。有菩萨摩诃萨。初发意时得初禅乃至第四禅。得四无量心。得四无色定。修四念处乃至十八不共法。是菩萨不生欲界色界无色界中。常生有益众生之处

【论】释曰。此菩萨或生无佛世界。或生有佛世界。世界不净有三恶道贫穷下劣。或生清净世界。至无佛世界。以十善道四禅乃至四无色定。利益众生令信向三宝。称说五戒及出家戒。令得禅定智慧功德。不清净世界有二种。有现在佛及佛灭度后。佛灭度后或时出家或时在家。以财施法施种种利益众生。若佛在世作种种因缘。引导众生令至佛所。清净世界者。众生未具功德者令其满足。是名在所生处利益众生

【经】舍利弗。有菩萨摩诃萨。初发意时行六波罗蜜。上菩萨位得阿毗跋致地。舍利弗。有菩萨摩诃萨。初发心时便得阿耨多罗三藐三菩提转法轮。与无量阿僧祇众生作益厚已入无余涅槃。是佛般涅槃后余法。若住一劫若减一劫。舍利弗。有菩萨摩诃萨。初发意时与般若波罗蜜相应。与无数百千亿菩萨。从一佛国至一佛国。为净佛世界故

【论】释曰。有三种菩萨。利根心坚未发心。前久来集诸无量福德智慧。是人遇佛闻是大乘法。发阿耨多罗三藐三菩提心。即时行六波罗蜜。入菩萨位得阿鞞跋致地。所以者何。先集无量福德。利根心坚从佛闻法故。譬如远行。或有乘羊而去。或有乘马而去。或有神通去者。乘羊者久久乃到。乘马者差速。乘神通者发意顷便到。如是不得言发意间云何得到。神通相尔不应生疑。菩萨亦如是。发阿耨多罗三藐三菩提时即入菩萨位。有菩萨初发意初虽心好后杂诸恶。时时生念我求佛道。以诸功德回向阿耨多罗三藐三菩提。是人久久无量阿僧祇劫。或至或不至。先世福德因缘薄而复钝根。心不坚固如乘羊者。有人前世少有福德利根发心。渐渐行六波罗蜜。若三若十若百阿僧祇劫。得阿耨多罗三藐三菩提。如乘马者必有所到第三乘神通者如上说。是三种发心。一者罪多福少。二者福多罪少。三者但行清净福德。清净有二种。一者初发心时即得菩萨道。二者小住供养十方诸佛。通达菩萨道故入菩萨位。即是阿鞞跋致地。阿鞞跋致地菩萨义如先说。次后菩萨大厌世间。世世已来常好真实恶于欺诳。是菩萨亦利根坚心。久集无量福德智慧。初发心时便得阿耨多罗三藐三菩提。即转法轮度无量众生。入无余涅槃。法住若一劫若减一劫。留化佛度众生。佛有二种神通力。一者现在时。二者灭后。劫义如上说。劫中所度众生亦复不少。次后菩萨亦利根心坚久集福德。发心即与般若波罗蜜相应得六神通。与无量众生共观十方清净世界而自庄严其国。如阿弥陀佛先世时作法藏比丘。佛将导遍至十方示清净国。令选择净妙之国。以自庄严其国

大智度论卷第三十八大智度论释往生品第四之中(卷三十九)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】舍利弗。有菩萨摩诃萨。行般若波罗蜜时。得四禅四无量心四无色定。游戏其中入初禅。从初禅起入灭尽定。从灭尽定起乃至入四禅。从四禅起入灭尽定。从灭尽定起入虚空处。从虚空处起入灭尽定。从灭尽定起乃至入非有想非无想处。从非有想非无想处起入灭尽定。知是舍利弗。菩萨摩诃萨行般若波罗蜜。以方便力故入超越定

【论】问曰。若凡夫人不能入灭尽定。云何菩萨从初禅起入灭尽定。答曰。阿毗昙鞞婆沙中小乘如是说。非佛三藏说。又是菩萨圣人尚不及。何况当是凡夫。譬如六牙白象。虽被毒箭犹怜愍怨贼。如是慈悲心阿罗汉所无。畜生中犹尚如是。何况作人身。离欲入禅而不得灭尽定。问曰。若菩萨得灭尽定可尔。超越定法不能过二。若言从初禅起乃至入灭尽定无有是法。答曰。余人虽有定法。力少故不能远超。菩萨无量福德智慧力深入禅定。心亦不着故能远超。譬如人中力士趠不过三四丈。若天中力士无复限数。小乘法中超一者是定法。菩萨禅定力大心无所著故远近随意。问曰。若尔者超越者是大。次第定不应为大。答曰。二俱为大。所以者何。从初禅起至二禅。更无余心一念得入。乃至灭尽定皆尔。超越者从初禅起入第三禅。亦不令余心杂。乃至灭尽定逆顺皆尔。有人言超越定胜。所以者何。但无余心杂而能超越故。譬如槃马回转随意

【经】舍利弗。有菩萨摩诃萨。行般若波罗蜜时。修四念处乃至十八不共法。不取须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道。以方便力为度众生故。起八圣道分。以是八道令得须陀洹果乃至辟支佛道。佛告舍利弗。一切阿罗汉辟支佛果及智。是菩萨摩诃萨无生法忍。舍利弗当知。是菩萨摩诃萨行般若波罗蜜在阿鞞跋致地中住

【论】问曰。何以不说是菩萨行六波罗蜜。而但说得四念处。答曰。若说若不说。当知是菩萨皆行六波罗蜜。于三十七品或行或不行。不证声闻辟支佛道者。有大慈大悲深入方便力等如先说。问曰。自不得诸道果。云何能以化人。答曰。佛自说因缘。所谓声闻辟支佛果及智。皆是菩萨法忍。但不受诸道果名字。果及智皆入无生法忍中。复次唯不取证。余者皆行。得菩萨道故。名为阿鞞跋致

【经】舍利弗。有菩萨摩诃萨。住六波罗蜜净兜率天道。当知是贤劫中菩萨

【论】释曰。菩萨有各各道各各行各各愿。是菩萨修业因缘生兜率天上。入千菩萨会中次第作佛。如是相当知是贤劫中菩萨

【经】舍利弗。有菩萨摩诃萨。修四禅乃至十八不共法未证四谛。当知是菩萨一生补处

【论】问曰。是一生补处菩萨应生兜率天。云何说得四禅等。答曰。是菩萨生兜率天上。离欲得四禅等。复次是补处菩萨离欲来久具足佛法。以方便力随补处法生兜率天。未证四谛者故留不证。若取证者成辟支佛。欲成佛故不证

【经】舍利弗。有菩萨摩诃萨。无量阿僧祇劫修行。得阿耨多罗三藐三菩提

【论】释曰。是菩萨虽种善根求阿耨多罗三藐三菩提。以钝根杂行故久乃得之。以深种善根故必得

【经】舍利弗。有菩萨摩诃萨。住六波罗蜜。常勤精进利益众生。不说无益之事

【论】释曰。是菩萨先有恶口故。发菩萨心愿言。我永离口四过行是道。复次此菩萨知是般若波罗蜜中诸法无有定相不可着不可说相故。如是知能利益者皆是佛法。若不能利益。虽种种好语非是佛法。譬如种种好药不能破病不名为药。趣得土泥等能差病者是名为药。以是故恐其谬错故。不说无益之事

【经】舍利弗。有菩萨摩诃萨。行六波罗蜜。常勤精进利益众生。从一佛国至一佛国。断众生三恶道

【论】释曰。是菩萨住六神通到十方世界。遮上中下三种不善道

【经】舍利弗。有菩萨摩诃萨。住六波罗蜜以檀为首。安乐一切众生。须饮食与饮食。衣服卧具璎珞花香房舍灯烛。随其所须皆给与之

【论】释曰。菩萨有二种。一者能令众生离苦。二者能与乐。复有二种。一者怜愍三恶道众生。二者怜愍人。是菩萨与众生乐。怜愍人故。随所须皆与之

【经】舍利弗。有菩萨摩诃萨。行般若波罗蜜时。变身如佛。为地狱中众生说法。为畜生饿鬼中众生说法

【论】问曰。是菩萨何以故变作佛身。似不尊重佛。答曰。有众生见佛身得度者。或有见转轮圣王等余身得度者。以是故变身作佛。复次世间称佛名字是大悲是世尊。若以佛身入地狱者。则阎罗王诸鬼神不遮碍。是我所尊者师云何可遮。问曰。若地狱中火烧常有苦痛。心常散乱不得受法。云何可化。答曰。是菩萨以不可思议神通力。破镬灭火禁制狱卒。放光照之众生心乐。乃为说法闻则受持。问曰。若尔者地狱众生有得道者不。答曰。虽不得道种得道善根因缘。所以者何。以重罪故不应得道。畜生道中当分别。或得者或不得者。如阿那婆达多龙王沙竭龙王等得菩萨道。鬼神道中如夜叉密迹金刚鬼子母等有得见道。是大菩萨

【经】舍利弗。有菩萨摩诃萨。行六波罗蜜时。变身如佛遍至十方如恒河沙等诸佛世界。为众生说法。亦供养诸佛及净佛世界。闻诸佛说法。观采十方净妙国土相。而已自起殊胜世界。其中菩萨摩诃萨皆是一生补处

【论】释曰。是菩萨遍为六道说法。以佛身为十方众生说法。若众生闻弟子教者不能信受。若闻佛独尊自在者说法信受其语。是菩萨二事因缘故供养诸佛。庄严世界闻庄严世界法。到十方佛国取清净世界相。行业因缘转复殊胜光明亦多。所以者何。此国土中皆一生补处菩萨。问曰。若先己说兜率天上一生补处菩萨。今云何说他方世界菩萨皆一生补处。答曰。兜率天上一生补处者。是三千世界常法。余处不定。所谓第一清净者。转身成佛故

【经】舍利弗。有菩萨摩诃萨。行六波罗蜜时。成就三十二相诸根净利。诸根净利故众人爱敬。以爱敬故渐以三乘法而度脱之。如是舍利弗。菩萨摩诃萨行般若波罗蜜时。应学身清净口清净

【论】释曰。是菩萨欲令众生眼见其身得度故。以三十二相庄严身。诸根净利者。眼等诸根明利出过余人。信慧根诸心数根等利净第一。见者叹其希有。我无此事。爱敬是菩萨信受其语。世世具足道法。以三乘道入涅槃。是三十二相眼等诸根。皆从身口业因缘清净得。以是故佛说。菩萨应当净身口业

【经】舍利弗。有菩萨摩诃萨。行六波罗蜜时得诸根净。以是净根而不自高亦不下他

【论】释曰。是菩萨常深净行六波罗蜜故。得眼等诸根净利人皆爱敬。慧等诸心数法根净利无比。为度众生故。世间常法若得殊异心则自高。轻诸余人。作是念。汝无此事我独有此。以是因缘故还失佛道。如经中说。菩萨轻余菩萨。念念一劫远于佛道。经尔所劫更修佛道。以是故而不自高亦不下他

【经】舍利弗。有菩萨摩诃萨。从初发心住檀波罗蜜尸罗波罗蜜。乃至阿鞞跋致地。终不堕恶道

【论】释曰。是菩萨从初已来性畏恶道。所作功德愿不坠堕。乃至阿鞞跋致地者。以未到中间畏堕恶道故作愿。菩萨作是念。若我堕三恶道者。自不能度何能度人。又受三恶道苦恼时。以嗔恼故结使增长。还起恶业复受苦报。如是无穷。何时当得修行佛道。问曰。若持戒果报不堕恶道者。何以复说布施。答曰。持戒是不堕恶道根本。布施亦能不堕

复次菩萨持戒虽不堕恶道中。生人中贫穷。不能自利又不益人。以是故行布施。余波罗蜜各有其事

【经】舍利弗。有菩萨摩诃萨。从初发心乃至阿鞞跋致地。常不舍十善行

【论】释曰。佛说持戒故不堕恶道布施随逐。今不知云何行尸罗波罗蜜。乃至阿鞞跋致地。是故复说常行十善。复次先菩萨持戒不牢固布施随助。今说但持戒牢固不舍十善不堕三恶道

【经】舍利弗。有菩萨摩诃萨。住檀波罗蜜尸罗波罗蜜中。作转轮圣王安立众生。于十善道亦以财物布施众生

【论】释曰。是檀尸波罗蜜因缘故。作转轮圣王。行尸罗波罗蜜故。能令众生信受十善。行檀波罗蜜故。以财宝给施众生亦不可尽。问曰。一切菩萨皆行是二波罗蜜。作转轮圣王不。答曰。不必然也。何以故。如此品中。诸菩萨种种法入佛道。有菩萨闻转轮圣王仪法。在此处能利益众生故作是愿。或有菩萨种转轮圣王因缘。虽不作愿亦得转轮圣王报。自行二波罗蜜故。作转轮圣王。亦教一切众生行十善道。亦自行布施。闻者生疑。为一世作为世世作。以是故

【经】佛告舍利弗。有菩萨摩诃萨。住檀波罗蜜尸罗波罗蜜。无量千万世作转轮圣王。值遇无量百千诸佛。供养恭敬尊重赞叹

【论】释曰。若菩萨知作转轮圣王大益众生者。便作转轮圣王。若自知余身益大亦作余身。复次欲以世间法大供养佛故。作转轮圣王

【经】舍利弗。有菩萨摩诃萨。常为众生以法照明亦以自照。乃至阿耨多罗三藐三菩提终不离照明。舍利弗。是菩萨摩诃萨于佛法中已得尊重。舍利弗。以是故菩萨摩诃萨行般若波罗蜜时。身口意不净不令妄起

【论】释曰。上菩萨行檀尸波罗蜜作转轮圣王。是菩萨但分别诸经。读诵忆念思惟分别诸法以求佛道。以是智慧光明自利益。亦能利益众生。如人闇道中然灯。亦能自益亦能益人。终不离者。是因缘故终不离智慧光明乃至阿耨多罗三藐三菩提。复次是菩萨清净法施不求名利供养恭敬。不贪弟子不恃智慧。亦不自高轻于余人。亦不讥刺。但念十方诸佛慈心念众生。我亦如是。学佛道说法。无所依止适无所著。但为众生令知诸法实相。如是清净说法。世世不失智慧光明。乃至阿耨多罗三藐三菩提。已得尊重者。上诸菩萨能如是者。于诸众生皆为尊重。身口意不净不令妄起者。能以清净法施者。不应杂起身口意恶业。所以者何。若起身口意恶者。闻者或不信受。若意业不净智慧不明。智慧不明不能善行菩萨道。复次不但此一菩萨。上来菩萨能行此法者。皆名尊重佛教。若菩萨欲行菩萨道。皆不应杂罪行。一切恶罪业不令妄起。杂行者于行道则难。不能疾成佛道。罪业因缘坏诸福德故

【经】舍利弗白佛言。世尊。云何菩萨身业不净口业不净意业不净

【论】问曰。舍利弗智慧第一。何以故。不识身口意恶业。答曰。舍利弗。于声闻法中则知。菩萨事异故不知。如说若菩萨生声闻辟支佛心。是为菩萨破戒。以是故舍利弗疑。不知何者是菩萨罪非罪。复次舍利弗。知身三不善道口四不善道意三不善道。是为身口意罪。此中佛答。若菩萨取身口意相。是则为菩萨身口意罪。如是等因缘故。舍利弗问

【经】佛告舍利弗。若菩萨摩诃萨作是念。是身是口是意如是取相作缘。舍利弗。是名菩萨身口意罪。舍利弗。菩萨摩诃萨行般若波罗蜜时。不得身不得口不得意。舍利弗。菩萨摩诃萨行般若波罗蜜时。若得身得口得意。用是得身口意故。能生悭心犯戒心嗔心懈怠心乱心痴心。当知是菩萨行六波罗蜜时。不能除身口意粗业

【论】释曰。佛示舍利弗。法空中菩萨不见是三业。是为无罪。若见是三业是为罪。声闻法中十不善道。是为罪业。摩诃衍中见有身口意所作是为罪。所以者何。有作有见。作者见者皆是虚诳故。粗人则粗罪细人则细罪。如离欲界欲时五欲五盖为恶罪。初禅摄善觉观为无罪。离初禅入二禅时觉观为罪。二禅所摄义喜为无罪。乃至非有想非无想处亦如是。入诸法实相中。一切诸观诸见诸法皆名为罪。小乘人畏三恶道故。以十不善业为罪。大乘人以一切能生着心取相法与三解脱门相违者名为罪。以是事异故名为大乘。若见有是三业虽不起恶。亦不名牢固。不见是身口意是三业根本。是为牢固。是菩萨法空故不见是三事。用是三事起悭贪相犯戒相嗔恚相懈怠相散乱相愚痴相。因无故果亦无。如无树则无荫。若能如是观者。则能除身口意粗业。问曰。先说罪业今何以故言粗业。答曰。粗业罪业无异。罪即是粗不名为细。复次声闻人以身口不善业名为粗。意不善业名为细。嗔恚邪见等诸结使名为粗罪。爱慢等结使名为细罪。三恶觉所谓欲觉嗔觉恼觉名为粗。亲里觉国土觉不死觉名为细。但善觉名为微细。于摩诃衍中尽皆为粗以是故此说粗罪

【经】舍利弗白佛言。世尊。菩萨摩诃萨云何除身口意粗业。佛告舍利弗。若菩萨摩诃萨不得身不得口不得意。如是菩萨摩诃萨能除身口意粗业。复次舍利弗。菩萨摩诃萨从初发意行十善道。不生声闻心不生辟支佛心。如是菩萨摩诃萨能除身口意粗业

【论】问曰。何等身口意细业与相违者为粗。答曰。如前所说者是。复次凡夫人业于声闻业为粗。声闻业于大乘为粗。复次垢业为粗。非垢业为细。能生苦受因缘业为粗。不生苦受因缘业为细。有觉有观业为粗无觉无观业为细。复次见我乃至知者见者为粗。若不见我乃至知者见者。但见三业处五众十二入十八界为细。复次有所见者名为粗。无所见者名为细。以是故佛告舍利弗。若菩萨不得身口意。是时则除三粗业。复次初发意住毕竟空中一切法不可得。而常行十善道。不起声闻辟支佛心。以不取相心。一切诸善根。皆回向阿耨多罗三藐三菩提。是名菩萨除身口意粗业罪名为清净

【经】舍利弗。有菩萨摩诃萨。行般若波罗蜜净佛道时。行檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜。是名菩萨摩诃萨除身口意粗业。舍利弗白佛言。世尊。何等是菩萨摩诃萨佛道。佛告舍利弗。佛道者。若菩萨摩诃萨不得身不得口不得意。不得檀波罗蜜。乃至不得般若波罗蜜。不得声闻辟支佛。不得菩萨不得佛。舍利弗。是名菩萨摩诃萨佛道。所谓一切诸法不可得故

【论】释曰。是菩萨依六波罗蜜总相净佛道。问曰。舍利弗从佛闻除三恶三粗。即是净佛道。今何以更问。答曰。先说三业清净相。今说一切法清净相。先略说今说别相。先但不得三业。今不得六波罗蜜诸贤圣菩萨及佛。是名净佛道。一切法皆不可得故。不得身。乃至不得般若波罗蜜。是名法空。不得声闻乃至佛。是名众生空。菩萨住是二空中渐得一切不可得空。不可得空即是诸法实相。是不可得空义如先十八空中说

【经】舍利弗。有菩萨摩诃萨。行六波罗蜜时无能坏者。舍利弗白佛言。世尊。云何菩萨摩诃萨行六波罗蜜时无能坏者。佛告舍利弗。若菩萨摩诃萨行六波罗蜜时。不念有色乃至识。不念有眼乃至意。不念有色乃至法。不念有眼界乃至法界。不念有四念处乃至八圣道分。不念有檀波罗蜜乃至般若波罗蜜。不念有十力乃至十八不共法。不念有须陀洹果乃至阿罗汉果。不念有辟支佛乃至阿耨多罗三藐三菩提。舍利弗。菩萨摩诃萨如是行增益六波罗蜜无能坏者

【论】释曰。佛为舍利弗种种分别诸菩萨。次为说有菩萨发心时无有能坏者。舍利弗惊喜恭敬诸菩萨。是故问。菩萨结使未断未于实相法作证。何因缘故不可破坏。佛答。若菩萨不念有色。乃至不念有阿耨多罗三藐三菩提。得是法空故亦得众生空。若是法空观空者亦空。住是无碍般若波罗蜜中无有能坏者

【经】舍利弗。有菩萨摩诃萨。住般若波罗蜜中具足智慧。以是智慧常不堕恶道。不生弊恶人中。不作贫穷人。所受身体不为人天阿修罗所憎恶

【论】释曰。此菩萨先世来。爱乐智慧学一切经书。观察思惟听采诸法。自以智力推求一切法中实相。得是一切法实相故。为诸佛深心爱念。是无量智慧福德因缘故。身心具足常受富乐无诸不可

【经】舍利弗白佛言。世尊。何等是菩萨摩诃萨智慧。佛告舍利弗。菩萨摩诃萨用是智慧成就见十方如恒河沙等诸佛。听法见僧亦见严净佛土。菩萨摩诃萨以是智慧不作佛想。不作菩萨想。不作声闻辟支佛想。不作我想。不作佛国想。用是智慧行檀波罗蜜亦不得檀波罗蜜。乃至行般若波罗蜜亦不得般若波罗蜜。行四念处亦不得四念处。乃至行十八不共法亦不得十八不共法。舍利弗。是名菩萨摩诃萨智慧。用是智慧能具足一切法。亦不得一切法

【论】释曰。是中佛说二种智慧。一者分别破坏诸法而不取相。二者不着心不取相见十方诸佛听法。问曰。云何行檀波罗蜜而不得檀。答曰。不得檀中若一若异若实若空是檀从和合因缘生。于是檀中令众生得富乐及劝助佛道。以是故行檀亦不得檀。不得义如上说。乃至十八不共法亦如是。是名菩萨智慧能具足一切法而不得诸法

【经】舍利弗。有菩萨摩诃萨。行般若波罗蜜时。净于五眼肉眼天眼慧眼法眼佛眼。舍利弗白佛言。世尊。云何菩萨摩诃萨肉眼净。佛告舍利弗。有菩萨肉眼见百由旬。有菩萨肉眼见二百由旬。有菩萨肉眼见一阎浮提。有菩萨肉眼见二天下三天下四天下。有菩萨肉眼见小千世界。有菩萨肉眼见中千世界。有菩萨肉眼见三千大千世界。舍利弗。是为菩萨摩诃萨肉眼净

【论】问曰。佛何以不说行般若波罗蜜生五眼。而说净五眼。答曰。菩萨先有肉眼亦有四眼分。以诸罪结使覆故不清净。如镜性有照明垢故不见。若除垢则照明如本。菩萨行六波罗蜜。灭诸垢法故眼得清净。肉眼业因缘故清净。天眼禅定及业因缘故清净。余三眼修无量智慧福德因缘故清净。最大菩萨肉眼最胜见三千大千世界。问曰。若三千大千世界中。百亿须弥山诸山铁围山阜树木等。是事障碍。云何得遍见。若能得见何用天眼。若不能见。此中云何说见三千大千世界。答曰。不以障碍故见。若无障碍得见三千世界如观掌无异。复次有人言。菩萨天眼有二种。一者从禅定力得。二者先世行业果报得。业报生天眼常在肉眼中。以是故三千世界所有之物不能为碍。因天眼开障肉眼得见。是故肉眼得名果报生天眼。常现在前不待摄心。问曰。佛为世尊力皆周遍。何以但见一三千大千世界不能见多。答曰。若肉眼能过三千大千世界。复有所见者。何用天眼。以肉眼不能及故修学天眼。复次三千大千世界。劫初一时生劫尽一时灭。世界之外无央数由旬皆是虚空。空中常有风。肉眼与风相违。以相违故不能得过见异世界。或有菩萨住三千世界境上计其道数亦应见他方近世界。问曰。菩萨及佛。何以不集无量清净福德令肉眼远有所见。答曰。是肉眼因缘虚诳不净。天眼因缘清净。若无天眼当修肉眼强令远见。复次如经中说极远见三千世界。佛法不可思议经法甚多。或能远见。但此中不说小远见佛道。菩萨见二千中世界。不能种清净业因缘故。小复不如者见小千世界。复不如者见四天下一须弥山一日月处。又见三天下二天下一天下千由旬乃至百由旬。是名最小肉眼净。问曰。何以不说九十八十等由旬以为小。答曰。转轮圣王所见过于余人。又人先世然灯等因缘故。得坚固眼根。能远有所见。虽远终不能见百由旬。以是故菩萨小者见百由旬。问曰。日月在上去地四万二千由旬人皆能见。何以不能见百由旬。见百由旬何足称。答曰。日月虽远自有光明。还照其形人得见之。余色不然。又日月远故虽见而颠倒。所以者何。日月方圆五百由旬。而今所见不过如扇。大而见小颠倒非实。菩萨肉眼则不然。问曰。菩萨既得肉眼能见何事。答曰。见可见色。色义色众中广说

【经】舍利弗白佛言。世尊。云何菩萨摩诃萨天眼净。佛告舍利弗。菩萨摩诃萨天眼见一切四天王天所见。见三十三天夜摩天兜率陀天化乐天他化自在天所见。见梵天王所见乃至阿迦尼吒天所见。菩萨天眼所见者。四天王天乃至阿迦尼吒天所不知不见。舍利弗。是菩萨摩诃萨天眼。见十方如恒河沙等诸佛世界中众生死此生彼。舍利弗。是为菩萨摩诃萨天眼净

【论】释曰。菩萨天眼有二种。一者果报得。二者修禅得。果报得者。常与肉眼合用。唯夜闇天眼独用。诸人得果报天眼见四天下。欲界诸天见下不见上。菩萨所得果报天眼。见三千大千世界。禅定离欲天眼所见。如先十力天眼明中说。菩萨用是天眼。见十方如恒河沙等世界中众生。生死善恶好丑及善恶业因缘。无所障碍一切皆见。四天王天乃至阿迦尼吒天所见。又能过之。是诸天不能知菩萨天眼所见。何以故。是菩萨出三界得法性生身。得菩萨十力故。如是等因缘菩萨天眼净。余菩萨天眼论议如赞菩萨五神通中说

【经】舍利弗白佛言。世尊。云何菩萨摩诃萨慧眼净。佛告舍利弗。慧眼菩萨不作是念。有法若有为若无为若世间若出世间若有漏若无漏。是慧眼菩萨无法不见无法不闻无法不知无法不识。舍利弗。是为菩萨摩诃萨慧眼净

【论】释曰。肉眼不能见障外事。又不能远见。是故求天眼。天眼虽复能见。亦是虚诳见一异相。取男女相取树木等诸物相。见众物和合虚诳法。以是故求慧眼。慧眼中无如是过。问曰。若尔者何等是慧眼相。答曰。有人言。八圣道中正见是慧眼相。能见五受众实相。破诸颠倒故。有人言。能缘涅槃慧名为慧眼。所缘不可破坏故。是智慧非虚妄。有人言。三解脱门相应慧是名慧眼。何以故。是慧能开涅槃门故。有人言。智慧现前能观实际。了了深入通达悉知。是名慧眼。有人言。能通达法性直过无碍。有人言。定心知诸法相。如是名慧眼有人言。法空是名慧眼。有人言。不可得空中亦无法空。是名慧眼。有人言。十八空皆是慧眼有人言。痴慧非一非异。世间法不异出世间。出世间法不异世间。世间法即是出世间。出世间法即是世间。所以者何。异不可得故。诸观灭诸心行转还无所去。灭一切语言世间法相。如涅槃不异。如是智慧是名慧眼。复次此中佛自说慧眼。菩萨一切法中。不念有为若无为若世间若出世间若有漏若无漏等。是名慧眼若菩萨见有为世间有漏。即堕有见中。若见无为出世间无漏。即堕无见中。是有无二见舍以不戏论。慧行于中道。是名慧眼。得是慧眼无法不见无法不闻无法不知无法不识。所以者何。得是慧眼破邪曲。诸法无明诸法总相别相各皆如是。问曰。阿罗汉辟支佛亦得慧眼。何以不说无法不见无法不闻无法不知无法不识。答曰。慧眼有二种。一者总相。二者别相。声闻辟支佛见诸法总相。所谓无常苦空等。佛以总相别相慧观诸法。声闻辟支佛虽有慧眼有量有限。复次声闻辟支佛慧眼虽见诸法实相。因缘少故慧眼亦少。不能遍照法性。譬如灯油炷虽净小故不能广照。诸佛慧眼照诸法实性尽其边底。以是故无法不见无法不闻无法不知无法不识。譬如劫尽火烧三千世界明无不照。复次若声闻辟支佛慧眼无法不知者。与一切智人有何等异。菩萨世世集福德智慧苦行何所施用。问曰。佛用佛眼无法不知非是慧眼。今云何言慧眼无法不知。答曰。慧眼成佛时变名佛眼。无明等诸烦恼及习灭故。一切法中皆悉明了。如佛眼中说无法不见闻知识。以是故肉眼天眼慧眼法眼。成佛时失其本名但名佛眼。譬如阎浮提四大河入大海中则失其本名。何以故。肉眼诸烦恼有漏业生故虚诳不实。唯佛眼无诳法。天眼亦从禅定因缘和合生故。虚诳不能如实见事。慧眼法眼烦恼习未尽故。不毕竟清净故舍。佛眼中无有谬错尽其边极。以是故阿罗汉辟支佛慧眼。不能毕竟清净。故不能无法不见。问曰。佛现得果报肉眼能见色是事云何。答曰。肉眼虽生眼识。而佛不随其用不以为实。如圣自在神通中说。佛告阿难。所见好色中生厌恶心。眼见恶色生不恶厌心。或时见色不生污秽不污秽但生舍心。如是则肉眼无所施用。复次有人言。得圣道时五情清净异本。复次诸法毕竟空及诸法通达无碍。是二总为慧眼。

大智度论卷第三十九大智度论释往生品第四之下(卷四十)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】舍利弗白言。世尊。云何菩萨摩诃萨法眼净。佛告舍利弗。菩萨摩诃萨以法眼知是人随信行。是人随法行。是人无相行。是人行空解脱门。是人行无相解脱门。是人行无作解脱门得五根。得五根故得无间三昧。得无间三昧故得解脱智。得解脱智故断三结。有众见疑斋戒取。是人名为须陀洹。是人得思惟道。薄淫恚痴当得斯陀含增进思惟道。断淫恚得阿那含增进思惟道。断色染无色染无明慢掉得阿罗汉。是人行空无相无作解脱门得五根。得五根故得无间三昧。得无间三昧故得解脱智。得解脱智故知所有集法皆是灭法。作辟支佛。是为菩萨法眼净。复次舍利弗。菩萨摩诃萨知是菩萨初发意行檀波罗蜜。乃至行般若波罗蜜。成就信根精进根。善根纯厚用方便力故。为众生受身。若生刹利大姓。若生婆罗门大姓。若生居士大家。若生四天王天处乃至他化自在天处。是菩萨于其中住成就众生。随其所乐皆给施之。亦净佛世界。值遇诸佛供养恭敬尊重赞叹。乃至阿耨多罗三藐三菩提。亦不堕声闻辟支佛地。是为菩萨摩诃萨法眼净。复次舍利弗。菩萨摩诃萨如是知是菩萨于阿耨多罗三藐三菩提退。知是菩萨于阿耨多罗三藐三菩提不退。知是菩萨受阿耨多罗三藐三菩提记。知是菩萨未受阿耨多罗三藐三菩提记。知是菩萨到阿鞞跋致地。知是菩萨未到阿鞞跋致地。知是菩萨具足神通。知是菩萨未具足神通。知是菩萨已具足神通飞到十方如恒河沙等世界。见诸佛供养恭敬尊重赞叹。知是菩萨未得神通当得神通。知是菩萨当净佛世界未净佛世界。是菩萨成就众生未成就众生。是菩萨为诸佛所称誉所不称誉。是菩萨亲近诸佛不亲近佛。是菩萨寿命有量寿命无量。是菩萨得佛时比丘众有量比丘众无量。是菩萨得阿耨多罗三藐三菩提时。以菩萨为僧不以菩萨为僧。是菩萨当修苦行难行不修苦行难行。是菩萨一生补处未一生补处。是菩萨受最后身未受最后身。是菩萨能坐道场不能坐道场。是菩萨有魔无魔。如是舍利弗。是为菩萨摩诃萨法眼净

【论】释曰。菩萨摩诃萨初发心时。以肉眼见世界众生受诸苦患。心生慈愍。学诸禅定修得五通。以天眼遍见六道中众生受种种身心苦。益加怜愍故。求慧眼以救济之。得是慧眼已。见众生心相种种不同。云何令众生得是实法。故求法眼引导众生令入法中故名法眼。所谓是人随信行是人随法行。初入无漏道钝根者名随信行。是人初依信力故得道。名为随信行。利根者名随法行。是人分别诸法故得道。是名随法行。是二人十五心中亦名为无相行。过是已往或名须陀洹。或名斯陀含。或名阿那含。十五心中疾速无人能取其相者。故名无相。有人无始世界来性常质直好乐实事者。有人好行舍离者。有人世世常好善寂者。好实者。用空解脱门得道。以诸实中空为第一故。好行舍者。行无作解脱门得道。好善寂者。行无相解脱门得道。问曰。何以说得五根。答曰。有人言。一切圣道名为五根。五根成立故。八根虽皆是善。而三无漏根无有别异。以是故但说五根。取果时相应三昧名无间三昧。得是三昧已得解脱智。以是解脱智断三结得果证。有众见者。于五受众中生我若我所。疑者于三宝四谛中不信。斋戒取者。九十六种外道法中。取是法望得苦解脱

问曰。见谛所断十结得须陀洹果。何以故但说三不说七。答曰。若说有众见已说一切见结。如经说有众见为六十二见根本故。若人着我复思惟我。为是常为是无常。若谓无常堕断灭中。而生邪见无有罪福。若谓为常堕常见中。而生斋戒取计望得道。或修后世福德。乐欲得此二事故。取戒求苦乐因缘故。谓天所作便生见取。若说有众见则摄是二见边见邪见。若说斋戒取已说见取。余四结未拔根本故。不说是十结。于三界四谛所断分别。有八十八须陀洹乃至辟支佛。分别声闻辟支佛道如先说。菩萨法眼有二种。一者分别知声闻辟支佛方便得道门。二者知菩萨方便行道门。声闻辟支佛事先已处处说。今当分别菩萨法。若菩萨知是菩萨深行六波罗蜜。薄诸烦恼故。用信根精进根。及方便为度众生故受身。是菩萨生死肉身未得法性神通法身。以是故不说三根。未离欲故。今世行布施。功德信根精进根。后世生刹利大姓乃至他化自在天。先知因后知果。复次是菩萨不退者如先说。不退转相亦如后阿鞞跋致品中说。与此相违名为退。不退菩萨有二种。一者受记。二者未受记。如首楞严三昧四种受记中说。具足神通者。于十方恒河沙世界中。一时能变化无量身供养诸佛。听法说法度众生。如是等除佛无能及者。是为末后身菩萨。与此相违者名不具足。复次各各自地中无所少。名为具足。各各地中未成就是不具足。得神通有二种。有用者有不用者。未得神通者。有菩萨新发意故未得神通。或未离欲故。懈怠心故。行余法故。是为未得。与上相违是为得。净佛世界未净世界如先说。成就众生者有二种。有先自成功德然后度众生者。有先成就众生后自成功德者。如宝华佛欲涅槃时观二菩萨心。所谓弥勒释迦文菩萨。弥勒菩萨自功德成就弟子未成就。释迦文菩萨弟子成就自身未成就。成就多人难自成则易。作是念已。入雪山谷宝窟中身放光明。是时释迦文菩萨见佛。其心清净一足立七日七夜以一偈赞佛。以是因缘故超越九劫。如是等知成就众生不成就众生者。诸佛称誉如先说。与此相违名为不称誉。亲近诸佛无量寿命无量比丘僧纯菩萨为僧不修苦行如初品末说。一生补处者。或以相知者。如阿私陀仙人观其身相知今世成佛。珊若婆罗门见乳糜知今日成佛者应食如遍吉菩萨观世音菩萨文殊师利菩萨等。见是菩萨如诸佛相知当成佛。如是等坐道场者。有菩萨见菩萨行处。地下有金刚地持是菩萨。又见天龙鬼神持种种供养具送至道场。如是等知坐道场。有魔者宿世遮他行道及种种求佛道因缘。不喜行慈好行空等余法。如是等因缘以宿世破他行道故有魔破坏。问曰。云何末后身菩萨受恶业报为魔来坏。答曰。菩萨以种种门入佛道。或从悲门或从精进智慧门入佛道。是菩萨行精进智慧门不行悲心。好行精进智慧故。譬如贵人虽有种种好衣或时着一余者不着。菩萨亦如是。修种种行以求佛道。或行精进智慧道。息慈悲心。破行道者。增上慢故。诸长寿天龙鬼神不识方便者。见作恶行因缘若不受报生断灭见。是故佛现受报。是故虽无罪因缘实魔来。以方便力故现有魔。如是等一切声闻辟支佛诸菩萨种种方便门令众生入道。是名法眼净

【经】舍利弗。白佛言。世尊。云何菩萨摩诃萨佛眼净。佛告舍利弗。有菩萨摩诃萨。求佛道心次第入如金刚三昧。得一切种智。尔时成就十力四无所畏四无碍智十八不共法大慈大悲。是菩萨摩诃萨用一切种。一切法中无法不见无法不闻无法不知无法不识。舍利弗。是为菩萨摩诃萨得阿耨多罗三藐三菩提时佛眼净。如是舍利弗。菩萨摩诃萨欲得五眼。当学六波罗蜜。何以故。舍利弗。是六波罗蜜中摄一切善法。若声闻法辟支佛法菩萨法佛法。舍利弗。若有实语能摄一切善法者。般若波罗蜜是。舍利弗。般若波罗蜜能生五眼。菩萨学五眼者。得阿耨多罗三藐三菩提

【论】释曰。菩萨住十地中。具足六波罗蜜乃至一切种智。菩萨入如金刚三昧破诸烦恼习。即时得诸佛无碍解脱即生佛眼。所谓一切种智十力四无所畏四无碍智。乃至大慈大悲等诸功德是名佛眼。问曰。智慧见物是眼相。云何大慈悲等名为眼。答曰。诸功德皆与慧眼相应故通名为眼。复次慈悲心有三种。众生缘法缘无缘。凡夫人众生缘。声闻辟支佛及菩萨初众生缘后法缘。诸佛善修行毕竟空故名为无缘。是故慈悲亦名佛眼。已说佛眼。今说佛眼所用。是眼无法不见不闻不知不识。复次有人谓十住菩萨与佛无有差别。如遍吉文殊师利观世音等。具足佛十力功德等而不作佛。为广度众生故。是故生疑。以是故说佛眼相。十方众生及诸法中无不见无不闻。是诸菩萨于余菩萨为大。比于佛不能遍知。如月光明虽大于日则不现。问曰。眼为见相云何说闻。答曰。众生智慧从六情生知六尘。人谓佛有所不闻。如外经书中言。或有所不闻。是故佛智慧无所不闻。又耳识因缘生智慧。智慧所知言无法不闻。问曰。何以故三识所知合为一。三识所知别为三。眼名为见。耳名为闻。意知名为识。鼻舌身识名为觉。答曰。是三识助道法多。是故别说。余三识不尔。是故合说。是三识但知世间事。是故合为一。余三亦知世间亦知出世间。是故别说。复次是三识但缘无记法。余三识或缘善或缘不善或缘无记。复次是三识能生三乘因缘。如眼见佛及佛弟子。耳闻法心筹量正忆念。如是等种种差别。以是故六识所知事分为四分。一切种智者。如人眼见近不见远。见内不见外。见粗不见细。见东不见西。见此不见彼。见和合不见散。见生时不见灭。肉眼见天眼不见。眼根成就未离欲凡夫人故无天眼。天眼见慧眼不见。凡夫人得天眼神通故无慧眼。慧眼见法眼不见。未离欲声闻圣人。不知种种度众生道故无法眼。法眼见佛眼不见。菩萨得道种智知种种度众生道。未成佛故无佛眼。复次肉眼天眼见慧眼法眼佛眼不见。凡夫人眼根成就。得天眼神通故。无慧眼法眼佛眼。肉眼慧眼见法眼佛眼不见。眼根成就声闻圣人。不知种种度众生道故无法眼。声闻人故无佛眼。肉眼法眼见佛眼不见。初得无生忍。未受法性生身菩萨。得道种智未成佛故无佛眼。天眼慧眼见法眼佛眼不见。离欲声闻圣人得天眼神通。非菩萨故无道种智。无道种智故无法眼。声闻人故无佛眼。天眼法眼见佛眼不见。得菩萨神通知种种度众生道。未成佛故无佛眼。慧眼法眼见佛眼不见。菩萨得无生法忍。得无生法忍已能观一切众生得道因缘。以种种道而度脱之。未成佛故无佛眼。复次肉眼天眼慧眼见法眼佛眼不见。眼根成就声闻圣人得天眼神通。无道种智故无法眼。声闻人故无佛眼。天眼慧眼法眼见佛眼不见。法性生身菩萨具六神通以种种道度众生。未成佛故无佛眼。复次肉眼天眼慧眼法眼见佛眼不见。初得无生法忍菩萨未舍肉身。得菩萨神通无生法忍。道种智具足未成佛故无佛眼。如是等不名无法不见闻觉识。若以佛眼观诸法。是名无所不见无所不闻无所不觉无所不识。五尘随义分别亦如是。三乘等诸善法。是五眼因缘诸善法。皆六波罗蜜摄。是六波罗蜜般若波罗蜜为本。以是故说般若波罗蜜能生五眼。菩萨渐渐学是五眼不久当作佛

【经】舍利弗。有菩萨摩诃萨。行般若波罗蜜时。修神通波罗蜜。以是神通波罗蜜受种种如意事。能动大地。变一身为无数身。无数身还为一身。隐显自在。山壁树木皆过无碍如行空中。履水如地凌虚如鸟。出没地中如出入水。身出烟炎如大火聚。身中出水如雪山水流。日月大德威力难当而能摩扪。乃至梵天身得自在亦不着是如意神通。神通事及己身皆不可得。自性空故。自性离故。自性无生故。不作是念。我得如意神通除为萨婆若心。如是舍利弗。菩萨摩诃萨行般若波罗蜜时。得如意神通智证。是菩萨以天耳净过于人耳。闻二种声。天声人声。亦不着是天耳神通。天耳与声及己身皆不可得。自性空故。自性离故。自性无生故。不作是念。我有是天耳。除为萨婆若心。如是舍利弗。菩萨摩诃萨行般若波罗蜜时。得天耳神通智证。是菩萨如实知他众生心。若欲心如实知欲心。离欲心如实知离欲心。嗔心如实知嗔心。离嗔心。如实知离嗔心。痴心如实知痴心。离痴心如实知离痴心。渴爱心如实知渴爱心。无渴爱心如实知无渴爱心。有受心如实知有受心。无受心如实知无受心。摄心如实知摄心。散心如实知散心。小心如实知小心。大心如实知大心。定心如实知定心。乱心如实知乱心。解脱心如实知解脱心。不解脱心如实知不解脱心。有上心如实知有上心。无上心如实知无上心。亦不着是心。何以故是心非心相不可思议故。自性空故。自性离故。自性无生故。不作是念。我得他心智证除为萨婆若心。如是舍利弗。菩萨摩诃萨。行般若波罗蜜时。得他心神通智证。是菩萨以宿命智证通。念一心乃至百心。念一日乃至百日。念一月乃至百月。念一岁乃至百岁。念一劫乃至百劫无数百劫无数千劫无数百千劫。乃至无数百千万亿劫世。我是处如是姓如是名如是生如是食。如是久住如是寿限如是长寿如是受苦乐。我是中死生彼处。彼处死生是处。有相有因缘。亦不着是宿命神通。宿命神通事及己身皆不可得。自性空故。自性离故。自性无生故。不作是念。我有是宿命神通。除为萨婆若心。如是舍利弗。菩萨摩诃萨行般若波罗蜜时。得宿命神通智证。是菩萨以天眼见众生死时生时。端政丑陋恶处好处。若大若小。知众生随业因缘。是诸众生身恶业成就口恶业成就意恶业成就。故谤毁圣人。受邪见因缘。故身坏命终堕恶道生地狱中。是诸众生身善业成就口善业成就意善业成就。不谤毁圣人。受正见因缘故。命终入善道生天上。亦不着是天眼神通。天眼神通事及己身皆不可得。自性空故。自性离故。自性无生故。不作是念。我有是天眼神通。除为萨婆若心。如是舍利弗。菩萨摩诃萨行般若波罗蜜时。得天眼神通智证。亦见十方如恒河沙等世界中众生生死乃至生天上。四神通亦如是。是菩萨摩诃萨漏尽神通虽得漏尽神通。不堕声闻辟支佛地。乃至阿耨多罗三藐三菩提。亦不依异法。亦不着是漏尽神通。漏尽神通事及己身皆不可得。自性空故。自性离故。自性无生故。不作是念。我得漏尽神通。除为萨婆若心。如是舍利弗。菩萨摩诃萨行般若波罗蜜时。得漏尽神通智证。如是舍利弗。菩萨摩诃萨行般若波罗蜜时。具足神通波罗蜜。具足神通波罗蜜已。增益阿耨多罗三藐三菩提

【论】释曰。如大海中有种种宝珠。有能杀毒。有能遮鬼。有能破病。有能除寒热饥渴。有能随人所愿皆能与者。如是等无量无数宝珠。大乘海中亦如是。有种种菩萨宝。有菩萨能破三恶道。有能开三善门。有能生五眼。有能修行神通波罗蜜。是故诸菩萨能为奇特希有之事。所谓取空相多地相少。则能随意动地。一身能多。多身能一。虚空中常有微尘满中。是人离欲福德因缘故。集诸微尘以为诸身令皆相似。有人言。诸非人恭敬。是离欲菩萨入其身中。随其意所欲变化则皆能化。转轮圣王未离欲。少有福德因缘故。诸鬼神尚为其使。何况离欲行无量心人。复次是心相无有住处若内若外若大若小。以禅定力故。其心调柔疾遍诸身还复亦速。譬如千头龙。眼耳各有二千。及有千口。心一时用。龙是粗身尚尔。何况菩萨。有人言。坐禅人事所有力势不可思议故。一身为无量身。无量身为一身。石壁无碍者取石壁虚空相。微尘开辟如撅入土。履水者取地相多故履水如地。取水相多故入地如水。取火相多故身出烟火。扪摸日月者。神通不可思议力故。令手及日月入火定故。月不能令冷。入水定故日不能令热。问曰。是神通力乃至四禅中。此何以言但至梵世身得自在。答曰。此先已说。梵是初门故言梵世。则摄一切色界。又世人皆贵梵王以为世界主故。又是菩萨不欲于欲界散乱心现其自在。是故乃至离欲人中能有所作。如是神通相无量无数。为易解故少说譬喻。诸外道于此神通有二事错。一者起吾我心。我能起此事而生憍慢。二者着是神通。譬如贪人着宝。以是故外道神通不及圣人神通。菩萨于是神通力。知一切法自性不生故不着。但念一切种智。为度众生故。余五神通亦如是。如其法分别先说其相后皆说空。六神通余义如赞菩萨品中五神通义说。以是六神通广利益众生。故说具足得。如是神通增益阿耨多罗三藐三菩提

【经】舍利弗。有菩萨摩诃萨行般若波罗蜜时。住檀波罗蜜净萨婆若道毕竟空。不生悭心故。舍利弗。有菩萨摩诃萨。行般若波罗蜜时。住尸罗波罗蜜净萨婆若道毕竟空。罪不罪不着故。舍利弗。有菩萨摩诃萨。行般若波罗蜜时。住羼提波罗蜜净萨婆若道毕竟空。不嗔故。舍利弗。有菩萨摩诃萨。行般若波罗蜜时。住毗梨耶波罗蜜净萨婆若道毕竟空。身心精进不懈息故。舍利弗。有菩萨摩诃萨。行般若波罗蜜时。住禅波罗蜜净萨婆若道毕竟空。不乱不昧故。舍利弗。有菩萨摩诃萨。行般若波罗蜜时。住般若波罗蜜净萨婆若道毕竟空。不生痴心故。如是舍利弗。菩萨摩诃萨行般若波罗蜜时。住六波罗蜜净萨婆若道毕竟空故。不来不去故。不施不受故。非戒非犯故。非忍非嗔故。不进不怠故。不定不乱故。不智不愚故。尔时菩萨摩诃萨。不分别布施不布施持戒犯戒忍辱嗔恚精进懈怠定心乱心智慧愚痴。不分别毁害轻慢恭敬。何以故。舍利弗。无生法中无有受毁者。无有受害者。无有受轻慢恭敬者。舍利弗。菩萨摩诃萨行般若波罗蜜。得如是诸功德。声闻辟支佛所无有得。是功德具足成就众生。净佛世界得一切种智

【论】释曰。是菩萨初发意行般若波罗蜜。渐行余功德。所谓檀波罗蜜等。菩萨住檀波罗蜜修治萨婆若道。观一切法毕竟空。不生悭贪心。以是二事故开萨婆若道。所以者何。毕竟空中无有悭贪。悭贪根本断故。具足檀波罗蜜。具足檀波罗蜜故。庄严般若波罗蜜。乃至般若波罗蜜毕竟空故。常不生痴心。所以者何。此中佛自说。一切法不来不去无施无受故。乃至不智不愚故。问曰。若能如是观行六波罗蜜。得何等利益。答曰。此中佛自说。此菩萨不念有所施与无所施与。若念有施入虚妄法中。又着布施心生憍慢。若念无所施即堕邪见中。是布施论议是佛法中初门。云何言无乃至不念有痴有慧。是人如金刚山四面风起不能令动。是菩萨尔时若有骂詈赞叹心无有异。何以故。此中佛自说。无生法中无有骂者无有害者无恭敬者。声闻辟支佛有加害者。不能深有慈悲心。若默然若远离。菩萨则不然。能深加慈心。爱之如子方便度之。是故胜一切声闻辟支佛。而能教化一切众生。忍辱慈悲方便深故。随愿清净业因缘故。能净佛世界。是法具足故。不久当得一切种智

【经】复次舍利弗。菩萨摩诃萨行般若波罗蜜时。一切众生中生等心。一切众生中生等心已。得一切诸法等。得一切诸法等已。立一切众生于诸法等中。是菩萨摩诃萨现世为十方诸佛所念。亦为一切菩萨一切声闻辟支佛所念。是菩萨在所生处眼终不见不爱色。乃至意不觉不爱法。如是舍利弗。菩萨摩诃萨行般若波罗蜜。不减于阿耨多罗三藐三菩提

【论】释曰。佛若广说诸菩萨相。则穷劫不尽。今佛此品末略说其相。是相足为诸菩萨所通行。所谓大慈悲故。初发度一切众生心故。学诸佛等心观众生故。一切法自性空故。如是等因缘故。于一切众生中生等心。得是等心已。得一切诸法等。一切法等者。如先说众生等法等义。今当更说。慈愍四生众生。一心欲利益名众生等。观四念处亦不见身名为法等。四正勤等诸四法亦如是。复次念五道中众生。皆没无常老病死。是名众生等。行是信等五根。若五神通。一心欲度是众生是名法等。复次众生中行忍辱慈悲等福功德无量。功德无量故心柔软。心柔软故疾得禅定。修禅定故心如意调柔。心如意调柔故。破世间长短男女白黑等。入一相法所谓无相。得是法等已。令一切众生得是法等。是菩萨得是二等。成就无量福德智慧故。得现世果报。为诸佛所念余人所念。爱着生念者皆是虚妄。唯诸佛念是为实念。不爱着故。是人诸佛尚念。何况声闻辟支佛菩萨。声闻辟支佛断结者。犹尚爱念。何况凡夫未离欲者。以菩萨福德因缘生故。得如是等无量今世果报。后世所生处。眼终不见恶色。恶色者。所谓能生苦受声香味触法。乃至能生忧心者。如六欲天六情所对净妙五欲随意欢喜。众生种少福德生天上如是。何况菩萨福德实智慧无量无边。为十方诸佛诸余贤圣所念

【经】说是般若波罗蜜品时。三百比丘从坐起以所著衣上佛。发阿耨多罗三藐三菩提心。佛尔时微笑种种色光从口中出。尔时慧命阿难从坐起整衣服。合掌右膝着地白佛言。佛何因缘微笑。佛告阿难。是三百比丘。从是已后六十一劫。当得作佛皆号名大相。是三百比丘舍此身已当生阿閦佛国。及六万欲天子皆发阿耨多罗三藐三菩提心。于弥勒佛法中出家行佛道。是时佛之威神故。此间四部众见十方面各千佛。是十方世界严净。此娑婆世界所不能及。尔时十千人作愿言。我等修净愿行。以净愿行故当生彼佛世界。尔时佛知是善男子深心而复微笑。种种色光从口中出。阿难整衣服合掌白佛。佛何因缘微笑。佛告阿难。汝见是十千人不。阿难言见。佛言。是十千人于此寿终当生彼世界。终不离诸佛。后当作佛皆号庄严王

【论】问曰。如佛结戒。比丘三衣不应少。是诸比丘何以故破尸罗波罗蜜作檀波罗蜜。答曰。有人言。佛过十二岁然后结戒。是比丘施衣时未结戒。有人言。是比丘有净施衣心生当受。以是故施。有人言。是诸比丘多知多识。即能更得事不经宿。复次有人言。是诸比丘闻佛说诸菩萨行檀波罗蜜诸功德力势无量故。得与般若波罗蜜相应。心大踊跃即以衣施。无复他念不故破戒。复次诸比丘知佛法毕竟空无所著断法爱。为世谛故结戒非第一义。是比丘从佛闻第一义及布施等六波罗蜜。闻诸菩萨种种大威力愍念众生。为诸烦恼所覆。不能得是菩萨功德。是故生大悲心。为众生故发阿耨多罗三藐三菩提意。以是故以衣布施。若人以贪欲嗔恚怖畏邪见不恭敬心。轻佛语而不持戒。是名为破戒。是诸比丘都无此心。是故无破戒罪。问曰。佛何以故微笑。答曰。笑有种种。有人见妓乐事而笑。有人内怀嗔恚而笑。有人憍慢故笑。有人轻物故笑。有人事办欢喜故笑。有人见不应作而作故笑。有人怀诈扬善故笑。有人见希有事故笑。佛今见比丘以一袈裟施故。未来世中。成办佛事是为希有。以是故笑。问曰。阿难何以常问佛笑。而余比丘不问。答曰。是诸比丘不亲近佛。又敬难心多故不敢自问。阿难善知人相知诸比丘意。又见佛笑疑故作是念。佛无众生相无有法相。知三界如梦如幻。今有何事能令佛笑。佛如须弥山王大地大海。不以小因缘故动。以是故问笑因缘。佛告阿难。业因缘果报相续不可思议。是三百比丘却后六十一劫。当得作佛号名大相。(施以手举物显示为相故因以为名)六十一劫中是人利根值佛说法。与般若波罗蜜相应故。是诸人疾得作佛。是诸比丘未得天眼故。自疑不知生何处。恐不能得集诸功德不得至道。是故佛言舍是身当生阿閦佛世界。六万欲天子必是宿世共福德因缘故。与三百比丘俱。发阿耨多罗三藐三菩提心。是弥勒所应度。是故佛说弥勒时当出家。今佛记诸比丘生阿閦佛世界故。诸人咸欲见诸佛清净世界。是故佛令大众见十方面各千佛。是四众见是清净庄严佛世界。见诸佛身大于须弥山者。一生补处菩萨大众围绕。以梵音声彻无量无边世界。各自鄙薄其身。怜愍众生故。为求无量佛法。作愿生彼佛世界。如清净世界行愿中说。笑因缘如先说。是十千人于此寿终当生彼国。随生彼国行业因缘具足故。此间集深厚无量福德故。终不离诸佛见诸庄严佛世界。发心故皆号庄严王佛

    大智度论释叹度品第五

【经】尔时慧命舍利弗。慧命目犍连。慧命须菩提。慧命摩诃迦叶。如是等诸多知识比丘。及诸菩萨摩诃萨。诸优婆塞优婆夷。从坐起合掌白佛言。世尊。摩诃波罗蜜是菩萨摩诃萨般若波罗蜜。尊波罗蜜第一波罗蜜胜波罗蜜妙波罗蜜无上波罗蜜无等波罗蜜无等等波罗蜜如虚空波罗蜜。是菩萨摩诃萨般若波罗蜜。世尊。自相空波罗蜜。是菩萨摩诃萨般若波罗蜜。世尊。自性空波罗蜜。是菩萨摩诃萨般若波罗蜜。诸法空波罗蜜。无法有法空波罗蜜。开一切功德波罗蜜。成就一切功德波罗蜜。不可坏波罗蜜。是诸菩萨摩诃萨般若波罗蜜。诸菩萨摩诃萨行是般若波罗蜜无等等布施。具足无等等檀波罗蜜。得无等等身。得无等等法。所谓阿耨多罗三藐三菩提。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜亦如是。世尊。本亦复行此般若波罗蜜。具足无等等六波罗蜜。得无等等法。得无等等色无等等受想行识。佛转无等等法轮。过去佛亦如是。行此般若波罗蜜。具足无等等布施。乃至转无等等法轮。未来世佛亦行此般若波罗蜜。当作无等等布施。乃至当转无等等法轮。以是故世尊。菩萨摩诃萨欲度一切法彼岸。当习行般若波罗蜜。唯世尊。是行般若波罗蜜菩萨摩诃萨。一切世间天及人阿修罗。应当体敬供养。佛告众弟子及诸菩萨摩诃萨。如是如是诸善男子。行是般若波罗蜜者。一切世间天及人阿修罗。应当礼敬供养。何以故。因菩萨来故。出生人道天道刹利大姓婆罗门大姓居士大家。转轮圣王四天王天。乃至阿迦尼吒天。出生须陀洹乃至阿罗汉辟支佛诸佛。因菩萨来故。世间便有饮食衣服卧具房舍灯烛摩尼真珠毗琉璃珊瑚金银等诸宝物生。舍利弗。世间所有乐具。若人中若天上若离欲乐。是一切乐具皆由菩萨有。何以故。舍利弗。菩萨摩诃萨行菩萨道时。住六波罗蜜。自行布施亦以布施成就众生。乃至自行般若波罗蜜。亦以般若波罗蜜成就众生。舍利弗。是故菩萨摩诃萨为安乐一切众生故。出现于世

【论】问曰。五千比丘中上有千余上座。所谓沤楼频螺迦叶等。何以止说此四人名。答曰。是四比丘是现世无量福田。舍利弗是佛右面弟子。目揵连是佛左面弟子。须菩提修无诤定行空第一。摩诃迦叶行十二头陀第一。世尊施衣分坐常深心怜愍众生。佛在世时若有人欲求今世果报者。供养是四人辄得如愿。是故是多知多识比丘及四众赞般若波罗蜜。问曰。是阿罗汉最后身所作已办。何以复赞叹般若波罗蜜。答曰。人皆知阿罗汉得无漏道。以菩萨智慧虽大结使未断故不贵。又以是阿罗汉有慈悲心助佛扬化故。以之为证。佛道于世间中最大。是般若能与此事故。名为大波罗蜜。一切法中智慧第一故。言尊波罗蜜。能正导五度故。名第一波罗蜜。五度不及故。名为胜波罗蜜。如五情不及意能自利利人故。名为妙波罗蜜。一切法中无有过者故。名无上波罗蜜。无有法与同者故。名无等波罗蜜。诸佛名无等从般若波罗蜜生故。名无等等波罗蜜。是般若波罗蜜毕竟清净。不可以戏论破坏故。名如虚空波罗蜜。般若波罗蜜中。一切法自相不可得故。名为自相空波罗蜜。此波罗蜜中一切法自性空故。诸法因缘和合生。无有自性故。名为自性空波罗蜜。诸法中无有自法故。名为诸法空波罗蜜。以此众生空法空故。破诸法令无所有。无所有亦无所有。是名无法有法空波罗蜜。菩萨行是般若波罗蜜。无有功德而不摄者。如日出时华无不敷故。名开一切功德波罗蜜。是菩萨心中般若波罗蜜日出。成就一切诸功德皆令清净。般若波罗蜜。是一切善法之本。是故名为成就一切功德波罗蜜。世间无有法能倾动者故。名不可破坏波罗蜜。是诸阿罗汉赞叹因缘。所谓三世佛皆从般若波罗蜜生。所谓无比布施乃至无比智慧。世间中无有与等者故言无比。是六波罗蜜毕竟清净无有过失。故名为无比。无比即是无等等。复次无等等诸佛名无等。与诸佛等故名为无等等。问曰。三世诸佛中已有释迦文佛。何以别说。答曰。今座上众皆由释迦文佛得度。感恩重故别说。如舍利弗说。我师不出者我等永为盲冥。诸阿罗汉知三世诸佛皆从般若波罗蜜中出。以是故。诸阿罗汉说。世尊诸菩萨摩诃萨。欲遍知一切法。当习般若波罗蜜。阿罗汉赞叹菩萨时心生恭敬。是故说礼敬供养。天人阿修罗者。说三善道。三恶道无所别知故不说。佛闻罗汉赞叹已。佛印可言。如是如是。应当礼敬供养行般若波罗蜜者。汝虽无一切智慧。而说不错故。重言如是如是。何以故。此中佛自说。因菩萨故出生人道天道。乃至一切诸菩萨。为安乐一切众生故。说刹利大姓乃至阿迦尼吒。须陀洹乃至诸佛皆如先说。问曰。若因菩萨有饮食等及诸宝物。人何以力作求生受诸辛苦乃得。答曰。饥饿劫时人虽设其功力亦无所得。以众生罪重故。菩萨世世赞叹布施持戒善心。是三福因缘故。有上中下。上者念便即得。中者人中尊重供养自至。下者施功力乃得。以是故说因菩萨得实而不虚。乐因缘甚多不可称计。今佛略说天乐人乐涅槃乐皆由菩萨得。此中佛自说。菩萨住六波罗蜜自行布施。亦教众生行布施。虽众生自行布施。无菩萨教导则不能行。问曰。除解脱乐此二种乐。是众生生结使处。贪欲因缘故生恚。菩萨何以教导此结使因缘。答曰。菩萨无咎。所以者何。菩萨慈悲清净心。与众生乐因缘教修福事。若众生不能清净行福德者。于菩萨何咎。如人好心作井。盲人堕中而死。作者无罪。如人设好食施人。不知量者多食致患。施者无罪。复次若诸佛菩萨。不教众生作福德因缘。则无天无人无阿修罗。但长三恶道。无从罪得出者。复次众生乐因缘故生贪。贪因缘故生恚。恚因缘故生苦。苦因缘故生罪。今欲免众生于第五罪中。是故与乐。复次非定乐因缘生贪欲。或正忆念故。乐为善福因缘。邪忆念故生贪欲。今为正忆念乐故。令生福德因缘。复次唯佛一人无错无失。是菩萨未成就佛道。未得佛眼故。以三种乐故。教化可度众生。诸佛但以解脱乐教化众生

    大智度论释舌相品第六

【经】尔时世尊出舌相。遍覆三千大千世界。从其舌相出无数无量色。光明普照十方如恒河沙等诸佛世界。是时东方如恒河沙等世界中。无量无数诸菩萨。见是大光明各各白其佛言。世尊。是谁神力故。有是大光明普照诸佛世界。诸佛告诸菩萨言。诸善男子。西方有世界名娑婆。是中有佛名释迦牟尼。是其舌相出大光明。普照东方如恒河沙等诸佛世界。南西北方四维上下亦复如是。为诸菩萨摩诃萨说般若波罗蜜故。是时诸菩萨各白其佛言。我欲往供养释迦牟尼佛。及诸菩萨摩诃萨。并欲听般若波罗蜜。诸佛告诸菩萨。善男子。汝自知时。是时诸菩萨摩诃萨。持诸供养具无量华盖幢幡璎珞众香金银宝花。向娑婆世界。诣释迦牟尼佛所。尔时四天王诸天。乃至阿迦尼吒诸天。各持天上天香末香泽香天树香叶香。天种种莲华青赤红白。向释迦牟尼佛所。是诸菩萨摩诃萨及诸天。所散诸华于三千大千世界虚空中。化成四柱大宝台。种种异色庄严分明。是时释迦牟尼佛众中有十万亿人。皆从坐起合掌白佛言。世尊。我等于未来世中亦当得如是法。如今释迦牟尼佛弟子侍从大众说法亦尔。是时佛知善男子至心。于一切诸法不生不灭不出不作得是法忍。佛便微笑。种种色光从口中出。阿难白佛言。世尊。何因缘故微笑。佛告阿难。是众中十万亿人。于诸法中得无生忍。是诸人于未来世过六十八亿劫。当得作佛。劫名华积。佛皆号觉花

【论】问曰。初品中佛已出舌相。今何以重出。答曰。是事非一日一坐说。前出舌相为和合大会度一切众生。舍利弗问佛答。今此异时更为余人。须菩提巧说空故。佛命令更说。是故出舌相光明。问曰。舍利弗智慧第一。竟何所少而复命须菩提。答曰。佛弟子众多一人说已次命一人。譬如王者群臣众多次第共语。问曰。若尔者目连迦叶等甚多。何以不次第皆与语。答曰。此经名智慧。舍利弗智慧第一。是故问。须菩提虽有种种因缘。以二因缘大故。一者好行无诤定常慈悲众生。虽不能广度众生。而常助菩萨。以菩萨事问佛。二者好深行空法。是般若中多说空法。是故命须菩提说是舌相光明。诸菩萨来往义。乃至华台供养义。如先说。尔时众生见是大神通力。所谓十方如恒河沙等世界中诸佛。以诸佛及释迦文佛出无量光明故。众生蒙佛神力。见舌相覆三千大千世界。及闻见诸佛在大众中说法。即得无生法忍。作是愿言。我等未来世神通变化亦当如今佛。佛知众生得无生法忍故微笑。笑义佛答如先说。是人过六十八亿劫作佛。是人见十方诸菩萨持七宝华来供养变成七宝花台。因见是已其心清净得无生法忍。是故作佛。时劫名华积。佛皆号觉华

大智度论卷第四十大智度论释三假品第七(卷第四十一)

        龙树菩萨造

        后秦龟兹国鸠摩罗什奉　诏译

【经】尔时佛告慧命须菩提。汝当教诸菩萨摩诃萨般若波罗蜜。如诸菩萨摩诃萨所应成就般若波罗蜜。即时诸菩萨摩诃萨及声闻大弟子诸天等作是念。慧命须菩提。自以智慧力。当为诸菩萨摩诃萨说般若波罗蜜耶。为是佛力。慧命须菩提知诸菩萨摩诃萨大弟子诸天心所念。语慧命舍利弗。敢佛弟子所说法所教授皆是佛力。佛所说法。法相不相违背。是善男子学是法得证此法。佛说如灯。舍利弗。一切声闻辟支佛。实无力。能为菩萨摩诃萨说般若波罗蜜

尔时慧命须菩提白佛言。世尊。所说菩萨。菩萨字何等法名菩萨。世尊。我等不见是法名菩萨。云何教菩萨般若波罗蜜。佛告须菩提。般若波罗蜜亦但有名字。名为般若波罗蜜。菩萨菩萨字亦但有名字。是名字不在内不在外不在中间。须菩提。譬如说我名和合故有。是我名不生不灭。但以世间名字故说。如众生寿命。生者养育者。众数人。作者使作者。起者使起者受者使受者。知者见者等。和合法故有。是诸名不生不灭。但以世间名字故说。般若波罗蜜菩萨菩萨字亦如是。皆和合故有。是亦不生不灭。但以世间名字故说。须菩提。譬如身和合故有。是亦不生不灭。但以世间名字故说。须菩提。譬如色受想行识亦和合故有。是亦不生不灭。但以世间名字故说。须菩提。般若波罗蜜。菩萨菩萨字亦如是。皆是和合故有。是亦不生不灭。但以世间名字故说。须菩提。譬如眼和合故有。是亦不生不灭。但以世间名字故说。是眼不在内不在外不在中间。耳鼻舌身意和合故有。是亦不生不灭。但以世间名字故说。色乃至法亦如是。眼界和合故有。是亦不生不灭。但以世间名字故说。乃至意识界亦如是。须菩提。般若波罗蜜。菩萨菩萨字亦如是。皆和合故有。是亦不生不灭。但以名字故说。是名字亦不在内不在外不在中间。须菩提。譬如内身名为头但有名字。项肩臂脊肋髀[跳-兆+尃]脚是和合故有。是法及名字亦不生不灭。但以名字故说。是名字亦不在内不在外不在中间。须菩提。般若波罗蜜。菩萨菩萨字亦如是。皆和合故有。但以名字故说。是亦不生不灭。不在内不在外不在中间须菩提。譬如外物草木枝叶茎节。如是一切但以名字故说。是法及名字亦不生不灭。非内非外非中间住。须菩提。般若波罗蜜。菩萨菩萨字亦如是。皆和合故有。是法及名字亦不生不灭。非内非外非中间住。须菩提。譬如过去诸佛。名字和合故有。是亦不生不灭。但以名字故说。是亦非内非外非中间住。般若波罗蜜菩萨菩萨字亦如是。须菩提。譬如梦响影幻炎。佛所化皆是和合故有。但以名字说。是法及名字不生不灭。非内非外非中间住。般若波罗蜜菩萨菩萨字亦如是。如是须菩提。菩萨摩诃萨行般若波罗蜜。名假施设。受假施设。法假施设。如是应当学

【论】问曰。佛既不自说。诸菩萨摩诃萨福德智慧利根胜诸声闻。何以故。命须菩提令说。答曰。先舌相中已有二因缘故。使须菩提说。复次佛威德尊重畏敬心故不敢问佛畏不自尽。复次佛知众中心所疑众人敬难佛故不敢发问。所以者何。众生见佛身过须弥山。舌覆三千大千世界。身出种种无量光明。是时众会心皆惊怖不敢发问。各各自念。我当云何从佛闻法。以是故佛命须菩提。令为众人说法。言汝所说者皆是佛力。如经中说。复次般若波罗蜜有二种。一者共声闻菩萨合说。二者但与诸法身菩萨说。为杂说故命须菩提为首。及弥勒舍利弗释提桓因。尔时众会闻佛命须菩提令说。心皆惊疑。须菩提知众人心。告舍利弗等言。一切声闻所说所知皆是佛力。我等当承佛威神为众人说。譬如传语人。所以者何。佛所说法法相不相违背。是弟子等。学是法作证敢有所说皆是佛力。我等所说即是佛说。所以者何。现在佛前说。我等虽有智慧眼。不值佛法则无所见。譬如夜行险道无人执灯必不得过。佛亦如是。若不以智慧灯照我等者则无所见。又告舍利弗。一切声闻辟支佛。实无力能为诸菩萨说般若波罗蜜。况我一人。所以者何。菩萨智慧甚深问答玄远。诸余浅近法于菩萨边说犹难。何况深法。如人能食一斛饭从有一斗者索。欲以除饥是不能除。以是故说。声闻辟支佛无力能为菩萨说般若。须菩提大明。菩萨尊贵佛亦然可令须菩提欲于实相法中说。是故言一切法中求菩萨不可得。菩萨不可得故字亦不可得。菩萨菩萨字不可得故。般若波罗蜜亦不可得。是三事不可得故。我云何当教菩萨般若波罗蜜。问曰。佛命须菩提为诸菩萨说般若。而须菩提言无菩萨。与佛相反佛何以同之。答曰。有二种说。一者着心说。二者不着心说。今须菩提以不着心说空。佛不诃之。复次须菩提常行空三昧。知诸法空故。佛告须菩提。为诸菩萨说般若波罗蜜。而菩萨毕竟空。是故须菩提惊言。云何名菩萨。佛即述成。菩萨如是从发心已来乃至佛道。皆毕竟空故不可得。若如是教者。是即教菩萨般若波罗蜜。复次凡有二法。一者名字。二者名字义。如火能照能烧是其义。照是造色烧是火大。是二法和合名为火。若离是二法有火。更应有第三用。除烧除照更无第三业。以是故知。二法和合假名为火。是火名不在二法内。何以故。是法二火是一。一不为二二不为一。义以名二法不相合。所以者何。若二法合说火时应烧口。若离索火应得水。如是等因缘知不在内。若火在二法外。闻火名不应二法中生火想。若在两中间则无依止处。一切有为法无有依止处。若在中间则不可知。以是故火不在三处。但有假名。菩萨亦如是。二法和合名菩萨。所谓名色。色事异。名事异。若定有菩萨应更有第三事。而无有事则知假名。是菩萨菩萨名亦如是。不在内不在外不在两中间。是中佛说譬喻。如五众和合故名为我。实我不可得。众生乃至知者见者。皆是五众因缘和合生假名法。是诸法实不生不灭。世间但用名字说。菩萨菩萨字。般若波罗蜜亦如是。皆是因缘和合假名法。是中佛更说譬喻。有人言但五众和合有众生。而众生空但有五众法。佛言。众生空五众亦和合故。假名字有。十二处十八界亦如是。复次菩萨有二种。一者坐禅。二者诵经。坐禅者。常观身骨等诸分和合故名为身。即以所观为譬喻言。头骨分和合故名为头。脚骨分和合故名为脚。头脚骨等和合故名为身。一一推寻皆无根本。所以者何。此是常习常观故以为譬喻。不坐禅者。以草木枝叶华实为喻。如过去诸佛亦但有名字。用是名字可说十譬喻。亦但有名字。菩萨义亦如是。十喻义如先说。菩萨应如是学三种波罗聂提。五众等法是名法波罗聂提。五众因缘和合故名为众生。诸骨和合故名为头骨。如根茎枝叶和合故名为树。是名受波罗聂提。用是名字取二法相。说是二种是为名字波罗聂提。复次众微尘法和合故有粗法生。如微尘和合故有粗色。是名法波罗聂提。从法有法故。是粗法和合有名字生。如能照能烧有火名字生。名色有故为人。名色是法。人是假名。是为受波罗聂提。取色取名故名为受多名字边。更有名字如梁椽瓦等名字边。更有屋名字生。如树枝树。叶名字边有树名生。是为名字波罗聂提。行者先坏名字波罗聂提到受波罗聂提。次破受波罗聂提到法波罗聂提。破法波罗聂提到诸法实相中。诸法实相即是诸法。及名字空般若波罗蜜

【经】复次须菩提。菩萨摩诃萨行般若波罗蜜时。不见色名字是常。不见受想行识名字是常。不见色名字无常。不见受想行识名字无常。不见色名字乐。不见色名字苦。不见色名字我。不见色名字无我。不见色名字空。不见色名字无相。不见色名字无作。不见色名字寂灭。不见色名字垢。不见色名字净。不见色名字生。不见色名字灭。不见色名字内。不见色名字外。不见色名字中间住。受想行识亦如是。眼色眼识眼触。眼触因缘生诸受。乃至意法意识意触。意触因缘生诸受亦如是。何以故。菩萨摩诃萨行般若波罗蜜。般若波罗蜜字菩萨菩萨字。有为性中亦不见。无为性中亦不见。菩萨摩诃萨行般若波罗蜜。是法皆不作分别。是菩萨行般若波罗蜜。住不坏法中修四念处时。不见般若波罗蜜。不见般若波罗蜜字。不见菩萨不见菩萨字。乃至修十八不共法时。不见般若波罗蜜。不见般若波罗蜜字。不见菩萨不见菩萨字。菩萨摩诃萨如是行般若波罗蜜时。但知诸法实相。诸法实相者无垢无净。如是须菩提。菩萨摩诃萨行般若波罗蜜时。当作是知名字假施设。知假名字已。不着色不着受想行识。不着眼乃至意。不着色乃至法。不着眼识乃至不着意识。不着眼触乃至不着意触。不着眼触因缘生受若苦若乐若不苦不乐。乃至不着意触因缘生受若苦若乐若不苦不乐。不著有为性不着无为性。不着檀波罗蜜。尸罗波罗蜜。羼提波罗蜜。毗梨耶波罗蜜。禅波罗蜜。般若波罗蜜。不着三十二相。不着菩萨身。不着菩萨肉眼。乃至不着佛眼。不着智波罗蜜。不着神通波罗蜜。不着内空。乃至不着无法有法空。不着成就众生。不着净佛世界。不着方便法。何以故。是诸法无著者。无著法。无著处。皆无故。如是须菩提。菩萨摩诃萨行般若波罗蜜时。不着一切法。便增益檀波罗蜜。尸罗波罗蜜。羼提波罗蜜。毗梨耶波罗蜜。禅波罗蜜。般若波罗蜜。入菩萨位。得阿鞞跋致地。具足菩萨神通。游一佛国。至一佛国。成就众生。恭敬尊重赞叹诸佛。为净佛世界。为见诸佛供养。供养之具。善根成就故随意悉得。亦闻诸佛所说法。闻已乃至阿耨多罗三藐三菩提。终不忘失。得诸陀罗尼门诸三昧门。如是须菩提。菩萨摩诃萨。行般若波罗蜜时。当知诸法名假施设。须菩提。于汝意云何。色是菩萨不。受想行识是菩萨不。不也世尊。眼耳鼻舌身意是菩萨不。不也世尊。色声香味触法是菩萨不。不也世尊。眼识乃至意识是菩萨不。不也世尊。须菩提。于汝意云何。地种是菩萨不。不也世尊。水火风空识种是菩萨不。不也世尊。于须菩提意云何。无明是菩萨不。不也世尊。乃至老死是菩萨不。不也世尊。于须菩提意云何。离色是菩萨不。不也世尊。乃至离老死是菩萨不。不也世尊。须菩提。于汝意云何。色如相是菩萨不。不也世尊。乃至老死如相是菩萨不。不也世尊。离色如相乃至离老死如相是菩萨不。不也世尊。佛告须菩提。汝观何等义。言色非菩萨乃至老死非菩萨。离色非菩萨乃至离老死非菩萨。色如相非菩萨乃至老死如相非菩萨。离色如相非菩萨。乃至离老死如相非菩萨。须菩提言。世尊。众生毕竟不可得。何况当是菩萨色不可得。何况色离色。色如离色如。是菩萨。乃至老死不可得。何况老死离老死。老死如离老死如。是菩萨。佛告须菩提。善哉善哉。如是须菩提。菩萨摩诃萨众生不可得故。般若波罗蜜亦不可得。当作是学。于须菩提意云何。色是菩萨义不。不也世尊。受想行识是菩萨义不。不也世尊。于须菩提意云何。色常是菩萨义不。不也世尊。受想行识常是菩萨义不。不也世尊。色无常是菩萨义不。不也世尊。受想行识无常是菩萨义不。不也世尊。色乐是菩萨义不。不也世尊。受想行识乐是菩萨义不。不也世尊。色苦是菩萨义不。不也世尊。受想行识苦是菩萨义不。不也世尊。色我是菩萨义不。不也世尊。受想行识我是菩萨义不。不也世尊。色非我是菩萨义不。不也世尊。受想行识非我是菩萨义不。不也世尊。于须菩提意云何。色空是菩萨义不。不也世尊。受想行识空是菩萨义不。不也世尊。色非空是菩萨义不。不也世尊。受想行识非空是菩萨义不。不也世尊。色相是菩萨义不。不也世尊。受想行识相是菩萨义不。不也世尊。色无相是菩萨义不。不也世尊。受想行识无相是菩萨义不。不也世尊。色作是菩萨义不。不也世尊。受想行识作是菩萨义不。不也世尊。色无作是菩萨义不。不也世尊。受想行识无作是菩萨义不。不也世尊。乃至老死亦如是。佛告须菩提。汝观何等义。言色非菩萨义受想行识非菩萨义。乃至色受想行识无作非菩萨义。乃至老死亦如是。须菩提白佛言。世尊。色毕竟不可得。何况无色是菩萨义。受想行识亦如是。世尊色常毕竟不可得。何况色无常是菩萨义。乃至识亦如是。世尊。色乐毕竟不可得。何况色苦是菩萨义。乃至识亦如是。世尊。色我毕竟不可得。何况色非我是菩萨义。乃至识亦如是。世尊。色有毕竟不可得。何况色空是菩萨义。乃至识亦如是。世尊。色相毕竟不可得。何况色无相是菩萨义。乃至识亦如是。世尊色作毕竟不可得。何况色无作是菩萨义。乃至识亦如是。佛告须菩提。善哉善哉。如是须菩提。菩萨摩诃萨行般若波罗蜜。色义不可得。受想行识义不可得。乃至无作义不可得。当作是学般若波罗蜜。须菩提。汝言我不见是法名菩萨。须菩提。诸法不见诸法。诸法不见法性。法性不见诸法。法性不见地种。地种不见法性。乃至识种不见法性。法性不见识种。法性不见眼色眼识性。眼色眼识性不见法性。乃至法性不见意法意识性。意法意识性不见法性。须菩提。有为性不见无为性。无为性不见有为性。何以故。离有为不可说无为。离无为不可说有为。如是须菩提。菩萨摩诃萨行般若波罗蜜。于诸法无所见。是时不惊不畏不怖。心亦不没不悔。何以故。是菩萨摩诃萨不见色受想行识故。不见眼乃至意。不见色乃至法。法不见淫怒痴。不见无明乃至老死。不见我乃至知者见者。不见欲界色界无色界。不见声闻心辟支佛心。不见菩萨不见菩萨法。不见佛。不见佛法。不见佛道。是菩萨一切法不见故。不惊不畏不怖不没不悔。须菩提白佛言。世尊。何因缘故。是菩萨心不怖不没不悔。佛告须菩提。菩萨摩诃萨一切心心数法不可得不可见。以是故菩萨摩诃萨心不怖不没不悔。世尊。云何菩萨心不惊不畏不怖。佛告须菩提。是菩萨意及意界不可得不可见。以是故不惊不畏不怖。如是须菩提。菩萨摩诃萨一切法不可得故。应行般若波罗蜜。须菩提。菩萨摩诃萨一切行处不得般若波罗蜜。不得菩萨名。亦不得菩萨心。即是教菩萨摩诃萨

【论】释曰。菩萨行般若波罗蜜。观色法名字。非常非无常。乃至有为无为性中。不见有菩萨菩萨字如先说。一切法中不作忆想分别。菩萨住不坏法中。行六波罗蜜乃至十八不共法。以诸法实相智慧。于诸法中求不见一定法。所谓般若波罗蜜亦不见般若波罗蜜名字。又不见菩萨及菩萨名字。用是智慧故破无明等诸烦恼。用是不见亦不见智慧故。破着般若波罗蜜般若波罗蜜名字。菩萨菩萨名字。诸法实相清净通达无碍。菩萨得如是智慧。若见若闻若念皆如幻化。若闻见念皆是虚诳以是故不着色等。住是无碍智慧中。增益六波罗蜜入菩萨位。得如是等利益。是一章佛自教菩萨作如是观。次后章人谓佛多说法空故反问须菩提。若诸法不空颇有一法定是菩萨不。所谓色是菩萨不。乃至如是菩萨不。须菩提作是念。诸法和合故有菩萨。我云何言一法定是菩萨。以是故言。不也世尊。须菩提善得众生空故。佛言善哉善哉。菩萨知众生空不可得故。应行般若波罗蜜。色是菩萨义。乃至无作毕竟空亦如是。须菩提入诸法深空中不疑故。能益诸菩萨故。佛赞言。善哉善哉。菩萨法应如是学一切法不可得空般若波罗蜜。如须菩提说。我不见是法名为菩萨。佛言。非但菩萨独不可见。都无有法见法者。法性无量不可见故。是故诸法。不见法性。诸法因缘和合生。无有自性毕竟空故。法性不见诸法色性不见法性。法性不见色性乃至识性亦如是。五众性与法性同名故名为性。十二处十八界有为法无为法亦如是。略说因缘。离有为性不得说无为性。离无为性不得说有为性。是二法中摄一切法故。是菩萨虽不见一切法亦不怖畏。何以故。有所见有所不见则有恐畏。若都无所见则无所畏。所谓五众乃至十八不共法。问曰。若佛已说不恐畏因缘。须菩提何以故重问。答曰。须菩提若谓法都空无所有恐堕邪见。所以者何。佛弟子得正见故名为行道人。云何言都不可见。佛知须菩提意故。说言一切心心数法不可得不可见故无畏。凡夫人欲入空中。见心心数法可得外法不可得故恐怖。菩萨以心心数法虚妄不实颠倒果报。不能示人实事故不恐怖。以是异义故重问。问曰。若尔者何以复有第三问。答曰。心心数法意识中。可见意及意识。是心心数法根本。所以者何。意识中多分别故生恐怖。五识时顷促故无所分别。欲破怖畏根本。以是故重问无咎。若菩萨能行如是般若波罗蜜。虽不见四种事菩萨菩萨字。般若波罗蜜般若波罗蜜字。能三种因缘不畏。即是教菩萨般若波罗蜜。若但了菩萨般若波罗蜜相。是为行般若波罗蜜。不从十方求亦无与者。亦非如金银宝物力求而得

    大智度论释劝学品第八

【经】尔时须菩提白佛言。世尊。菩萨摩诃萨欲具足檀波罗蜜。当学般若波罗蜜。欲具足尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。当学般若波罗蜜。菩萨摩诃萨欲知色。当学般若波罗蜜。乃至欲知识。当学般若波罗蜜。欲知眼乃至意。欲知色乃至法。欲知眼识乃至意识。欲知眼触乃至意触。欲知眼触因缘生受乃至意触因缘生受。当学般若波罗蜜。欲断淫嗔痴。当学般若波罗蜜。菩萨摩诃萨欲断身见戒取疑淫欲嗔恚。色爱无色爱掉慢无明等一切结使及缠等。当学般若波罗蜜。欲断四缚四结四颠倒。当学般若波罗蜜。欲知十善道。欲知四禅。欲知四无量心四无色定四念处。乃至十八不共法。当学般若波罗蜜。菩萨摩诃萨欲入觉意三昧。当学般若波罗蜜。欲入六神通九次第定超越三昧。当学般若波罗蜜。欲得师子游戏三昧。当学般若波罗蜜。欲得师子奋迅三昧。欲得一切陀罗尼门。当学般若波罗蜜。菩萨摩诃萨欲得首楞严三昧。宝印三昧。妙月三昧。月幢相三昧。一切法印三昧。观印三昧。毕法性三昧。毕住相三昧。如金刚三昧。入一切法门三昧。三昧王三昧。王印三昧。净力三昧。高出三昧。毕入一切辩才三昧。入诸法名三昧。观十方三昧。诸陀罗尼门印三昧。一切法不忘三昧。摄一切法聚印三昧。虚空住三昧。三分清净三昧。不退神通三昧。出钵三昧。诸三昧幢相三昧。欲得如是等诸三昧门。当学般若波罗蜜。复次世尊菩萨摩诃萨欲满一切众生愿。当学般若波罗蜜

【论】问曰。初品中言种种欲有所得当学般若波罗蜜。今何以重说。答曰。先但赞叹欲得是诸功德。当行般若波罗蜜。未说般若波罗蜜。今已闻般若波罗蜜味。因欲得余功德。所谓六波罗蜜等。当学般若波罗蜜。复次上种种因缘说诸法空。有人谓佛法断灭无所复作。为断是人疑故言。欲得布施等种种功德。当行般若波罗蜜。若般若波罗蜜实空无所有断灭者。不应说应行布施等功德。有智者说何缘初后相违。复次前广说此略说。彼是佛说。此是须菩提说。复次般若波罗蜜深妙故重说。譬如赞德之美故言善哉善哉。六波罗蜜义如先说。知五众者见无常苦空总相别相等。六情六尘六识六触六受亦如是。一切世间系缚受为主。以受故生诸结使。乐受生贪欲。苦受生嗔恚。不苦不乐受生愚痴。三毒起诸烦恼及业因缘。以是故但说受。余心数法不说。所谓想忆念等。三毒十结诸使缠。乃至十八不共法如先说。觉意三昧超越三昧师子游戏三昧。是菩萨诸三昧后当说。欲满一切众生愿先已说

【经】欲得具足如是善根常不堕恶趣。欲得不生卑贱之家。欲得不住声闻辟支佛地中。欲得不堕菩萨顶者。当学般若波罗蜜。尔时慧命舍利弗问须菩提。云何为菩萨摩诃萨堕顶。须菩提言。舍利弗。若菩萨摩诃萨不以方便行六波罗蜜。入空无相无作三昧。不堕声闻辟支佛地。亦不入菩萨位。是名菩萨摩诃萨法生故堕顶。舍利弗问须菩提。云何名菩萨生。须菩提答舍利弗言。生名爱法。舍利弗言。何等法爱。须菩提言。菩萨摩诃萨行般若波罗蜜。色是空受念着。受想行识是空受念着。舍利弗。是名菩萨摩诃萨顺道法爱生。复次舍利弗。菩萨摩诃萨色是无相受念着。受想行识无相受念着。色是无作受念着。受想行识无作受念着。色是寂灭受念着。受想行识寂灭受念着。色是无常乃至识。色是苦乃至识。色是无我乃至识受念着。是为菩萨顺道法爱生。是苦应知集应断尽应证道应修。是垢法是净法。是应近是不应近。是菩萨所应行是非菩萨所应行。是菩萨道是非菩萨道。是菩萨学是非菩萨学。是菩萨檀波罗蜜乃至般若波罗蜜。是非菩萨檀波罗蜜乃至般若波罗蜜。是菩萨方便。是非菩萨方便。是菩萨熟是非菩萨熟。舍利弗。菩萨摩诃萨行般若波罗蜜是诸法受念着。是为菩萨摩诃萨顺道法爱生

【论】问曰。何等善根故。不堕恶道贫贱及声闻辟支佛。亦不堕顶。答曰。有人言行不贪善根故。爱等诸结使衰薄。深入禅定。行不嗔善根故。嗔等诸结使薄。深入慈悲心。行不痴善根故。无明等诸结使薄。深入般若波罗蜜。如是禅定慈悲般若波罗蜜力故无事不得。何况四事。问曰。何以四事中但问堕顶。答曰三事先已说。堕顶未说故问。问曰。顶者是法位此义先已说。今何以重说。答曰。虽说其义名字各异。无方便入三解脱门。及有方便先已说。法爱于无生法忍中无有利益故名曰生。譬如多食不消。若不疗治于身为患。菩萨亦如是。初发心时贪受法食。所谓无方便行诸善法。深心系着于无生法忍。是则为生为病。以着法爱故于不生不灭亦爱。譬如必死之人虽加诸药药反成病。是菩萨于毕竟空不生不灭法忍中。而生爱着反为其患。法爱于人天中为妙。于无生法忍为累。一切法中忆想分别诸观是非。随法而爱。是名为生。不任盛诸法实相水与生相违。是名菩萨熟。问曰。是一事何以故。名为顶名为位名为不生。答曰。于柔顺忍无生忍中间。所有法名为顶。住是顶上直趣佛道不复畏堕。譬如声闻法中暖忍中间名为顶法。问曰。若得顶不堕今云何言顶堕。答曰。垂近应得而失者名为堕。得顶者智慧安隐则不畏堕。譬如上山既得到顶则不畏堕。未到之间倾危畏堕。顶增长坚固名为菩萨位。入是位中一切结使一切魔民不能动摇。亦名无生法忍。所以者何。异于生故。爱等结使杂诸善法名为生。复次无诸法实相智慧火故名为生。有诸法实相智慧火故名为熟。是人能信受诸佛实相智慧故名为熟。譬如熟瓶能盛受水生则烂坏。复次依止生灭智慧故得离颠倒。离生灭智慧故不生不灭。是名无生法。能信能受能持故名为忍。复次位者拔一切无常等诸观法故名为位。若不如是是为顺道法爱生

【经】舍利弗问须菩提。云何名菩萨摩诃萨无生。须菩提言菩萨摩诃萨行般若波罗蜜时。内空中不见外空。外空中不见内空。外空中不见内外空。内外空中不见外空。内外空中不见空空。空空中不见内外空。空空中不见大空。大空中不见空空。大空中不见第一义空。第一义空中不见大空。第一义空中不见有为空。有为空中不见第一义空。有为空中不见无为空。无为空中不见有为空。无为空中不见毕竟空。毕竟空中不见无为空。毕竟空中不见无始空。无始空中不见毕竟空。无始空中不见散空。散空中不见无始空。散空中不见性空。性空中不见散空。性空中不见诸法空。诸法空中不见性空。诸法空中不见自相空。自相空中不见诸法空。自相空中不见不可得空。不可得空中不见自相空。不可得空中不见无法空。无法空中不见不可得空。无法空中不见有法空。有法空中不见无法空。有法空中不见无法有法空。无法有法空中不见有法空。舍利弗。菩萨摩诃萨行般若波罗蜜得入菩萨位。复次舍利弗。菩萨摩诃萨欲学般若波罗蜜应如是学。不念色受想行识。不念眼乃至意。不念色乃至法。不念檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。乃至十八不共法。如是舍利弗。菩萨摩诃萨行般若波罗蜜。得是心不应念不应高。无等等心不应念不应高。大心不应念不应高。何以故。是心非心心相常净故。舍利弗语须菩提。云何名心相常净。须菩提言。若菩萨知是心相。与淫怒痴不合不离。诸缠流缚等诸结使。一切烦恼不合不离。声闻辟支佛心不合不离。舍利弗。是名菩萨心相常净。舍利弗语须菩提。有是无心相心不。须菩提报舍利弗言。无心相中有心相无心相可得不。舍利弗言。不可得。须菩提言。若不可得不应问有是无心相心不。舍利弗复问。何等是无心相。须菩提言。诸法不坏不分别。是名无心相。舍利弗问须菩提。但是心不坏不分别。色亦不坏不分别。乃至佛道亦不坏不分别耶。须菩提言。若能知心相不坏不分别。是菩萨亦能知色乃至佛道不坏不分别。尔时慧命舍利弗赞须菩提。善哉善哉。汝真是佛子。从佛口生从见法生从法化生。取法分不取财分。法中自信身得证。如佛所说。得无诤三昧中汝最第一。实如佛所举。须菩提。菩萨摩诃萨应如是学般若波罗蜜。是中亦当分别知。菩萨如汝所说行。则不离般若波罗蜜。须菩提。善男子善女人欲学声闻地。亦当应闻般若波罗蜜持读诵正忆念如说行。欲学辟支佛地。亦当应闻般若波罗蜜持读诵正忆念如说行。欲学菩萨地。亦当应闻般若波罗蜜持读诵正忆念如说行。何以故。是般若波罗蜜中广说三乘。是中菩萨摩诃萨声闻辟支佛当学

【论】释曰。内空中不见外空。外空中不见内空。有人言。外四大饮食入其身中故名为内。若身死还为外。一切法无来去相故。外空不在内空中。余十七空亦如是。不生不灭无异相。无来去故各各中不住。复次菩萨位相不念一切色为有。乃至十八不共法亦不念是有。不念有义如先说。问曰。菩提心无等等心大心有何差别。答曰。菩萨初发心缘无上道。我当作佛是名菩提心。无等名为佛。所以者何。一切众生一切法无与等者。是菩提心与佛相似。所以者何。因似果故。是名无等等心。是心无事不行。不求恩惠深固决定。复次檀尸波罗蜜是名菩提心。所以者何。檀波罗蜜因缘故。得大富无所乏少。尸波罗蜜因缘故。出三恶道人天中尊贵住。二波罗蜜果报力故。安立能成大事。是名菩提心。羼提毗梨耶波罗蜜相。于众生中现奇特事。所谓人来割肉出髓如截树木。而慈念怨家血化为乳。是心似如佛心。于十方六道中。一一众生皆以深心济度。又知诸法毕竟空。而以大悲能行诸行。是为奇特。譬如人欲空中种树。是为希有。如是等精进波罗蜜力势与无等相似。是名无等等。入禅定行四无量心。遍满十方与大悲方便合。故拔一切众生苦。又诸法实相灭一切观。诸语言断而不堕断灭中。是名大心。复次初发心名菩提心。行六波罗蜜名无等等心。入方便心中是名大心。如是等各有差别。复次菩萨得如是大智心亦不高心。相常清净故。如虚空相常清净。烟云尘雾假来故覆蔽不净。心亦如是常自清净。无明等诸烦恼客来覆蔽故以为不净。除去烦恼如本清净。行者功夫微薄。此清净非汝所作。不应自高不应念。何以故。毕竟空故。问曰。舍利弗知心相常净何以故问。答曰。以菩萨发阿耨多罗三藐三菩提心。深入深着故。虽闻心毕竟空常清净。犹忆想分别取是无心相。以是故问。是无心相心为有为无。若有云何言无心相。若无何以赞叹是无等等心当成佛道。须菩提答曰。是无心相中毕竟清净。有无不可得不应难。舍利弗复问。何等是无心相。须菩提答曰。毕竟空一切诸法无分别。是名无心相。舍利弗复问。但心相不坏不分别。余法亦如是。须菩提答言。诸法亦如是。若尔者阿耨多罗三藐三菩提。亦如虚空无坏无分别。诸菩萨深着阿耨多罗三藐三菩提故。作是念。诸凡夫法可言虚诳。以不真实故。菩萨漏未尽故。亦可言不清净。云何阿耨多罗三藐三菩提亦复虚诳。是时心惊不悦。须菩提知其心已。思惟筹量。我今应为说实相法不思惟已自念。今在佛前当以实相答。若我有失佛自当说。重思惟竟。以是故说阿耨多罗三藐三菩提。虽是第一。亦从虚诳法边生故。亦是空不坏不分别相。以是故行者当随阿耨多罗三藐三菩提相行。不应取相自高。尔时舍利弗赞须菩提言。善哉善哉。佛时默然听须菩提所答。亦可舍利弗所叹。从佛口生者。有人言婆罗门从梵天王口边生故。于四姓中第一。以是故舍利弗赞言。汝真从佛口生。所以者何。见法知法故。有未得道者亦依佛故得供养。是名取财分。又如弊恶子不随父教但取财分。取法分者。取诸禅定根力觉道种种善法。是名取法分。得四信故名为法中自信。得诸神通灭尽定等。着身中故是名身得证。如舍利弗于智慧中第一。目揵连神足第一。摩诃迦叶头陀第一。须菩提得无诤三昧中第一。得无诤定阿罗汉者。常观人心不令人起诤。是三昧根本四禅中摄。亦欲界中用。问曰。般若波罗蜜是菩萨事。何以言欲得三乘者皆当习学。答曰。般若波罗蜜中说诸法实相。即是无余涅槃。三乘人皆为无余涅槃故精进习行。复次般若波罗蜜中种种因缘说空解脱门义。如经中说。若离空解脱门无道无涅槃。以是故三乘人皆应学般若。复次舍利弗自说因缘。于般若波罗蜜中广说三乘相。是中三乘人应学成

大智度论卷第四十一(释第七品讫第八品)大智度论释集散品第九(卷第四十二)

        龙树菩萨造

        后秦龟兹国鸠摩罗什奉　诏译

【经】尔时慧命须菩提白佛言。世尊。我不觉不得是菩萨行般若波罗蜜。当为谁说般若波罗蜜。世尊。我不得一切诸法集散。若我为菩萨作字言菩萨。或当有悔。世尊。是字不住亦不不住。何以故。是字无所有故。以是故是字不住亦不不住。世尊。我不得色集散乃至识集散。若不可得云何当作名字。世尊。以是因缘故。是字不住亦不不住。何以故。是名字无所有故。世尊。我亦不得眼集散乃至意集散。若不可得云何当作名字言是菩萨。世尊。是眼名字乃至意名字不住亦不不住。何以故。是名字无所有故。以是故是字不住亦不不住。世尊。我不得色集散乃至法集散。若不可得云何当作名字言是菩萨。世尊。是色字乃至法字不住亦不不住。何以故。是字无所有故。以是故是字不住亦不不住。眼识乃至意识。眼触乃至意触。眼触因缘生受乃至意触因缘生受亦如是。世尊。我不得无明集散乃至不得老死集散。世尊。我不得无明尽集散。乃至不得老死尽集散。世尊。我不得淫怒痴集散。诸邪见集散皆亦如是。世尊。我不得六波罗蜜集散。四念处集散。乃至八圣道分集散。空无相无作集散。四禅四无量心四无色定集散。念佛念法念僧念戒念舍念天念善念入出息念身念死集散。我亦不得佛十力乃至十八不共法集散。世尊。我若不得六波罗蜜乃至十八不共法集散。云何当作字言是菩萨。世尊。是字不住亦不不住。何以故。是字无所有故。以是故是字不住亦不不住。世尊。我不得如梦五阴集散。我不得如响如影如焰如化五阴集散亦如上说。世尊。我不得离集散。我不得寂灭不生不灭不示不垢不净集散。世尊。我不得如法性实际法相法位集散亦如上说。我不得诸善不善法集散。我不得有为无为法有漏无漏法集散。过去未来现在法集散。不过去不未来不现在法集散。何等是不过去不未来不现在。所谓无为法。世尊。我亦不得无为法集散。世尊。我亦不得佛集散。世尊。我亦不得十方如恒河沙等世界诸佛及菩萨声闻僧集散世尊。我若不得诸佛集散。云何当教菩萨摩诃萨般若波罗蜜。世尊。是菩萨字不住亦不不住。何以故。是字无所有故。以是故是字不住亦不不住。世尊。我亦不得是诸法实相集散。云何当与菩萨作字言是菩萨。世尊。是诸法实相名字不住亦不不住。何以故。是名字无所有故。以是故是名字不住亦不不住

【论】问曰。先品中已说不见菩萨菩萨字般若波罗蜜。一切诸法不内不外不中间等。今何以重说。答曰。有四种爱。欲爱有爱非有爱法爱。欲爱易见其过不净等。有爱无不净等小难遣。非有爱破有似智慧故难遣。法爱者爱诸善法利益道者。法爱中过患难见故重说。譬如小草加功少易除大树功重难除。复次上法与此法有同有异。彼闻说菩萨字不见。此中说菩萨字不觉不得。以不觉不得故不见。非是智慧力少故不见。问曰。未行般若波罗蜜时为有菩萨耶。今何以故言不见菩萨行般若波罗蜜。答曰。从无始已来众生不可得。非行般若波罗蜜故不可得。但以虚诳颠倒。凡夫人随是假名故谓为有。今行般若波罗蜜灭虚诳颠倒。了知其无非本有今无。本有今无则堕断灭。复次须菩提心悔畏破妄语戒。所以者何。佛法中一切诸法决定无我。而我说言有菩萨为说般若波罗蜜。则堕妄语罪。是故心悔。复次有心悔因缘。一切法以不可得空故皆空。所以者何。无集无散故。譬如眼色因缘生眼识。三事和合故生眼触。眼触因缘中即生受想思等心数法。是中邪忆念故。生诸烦恼罪业。正忆念故生诸善法善恶业受六道果报。从是身边。复种善恶业。如是展转无穷。是名为集。余情亦如是。散者是眼识等诸法念念灭故。诸因缘离故。是眼识等法生时无来处。非如田上谷运致聚集。若灭时无去处。非如散谷与民。是名略说诸法集散相。生时无所从来。散时无所去。是诸法皆如幻化但诳惑于眼。问曰。若尔有集散相。须菩提何以言不觉不得。答曰。无来处故集不可得。无去处故散不可得。复次生无故集不可得。灭无故散不可得。毕竟空故集不可得。业因缘不失故散不可得。复次观世间灭谛故集不可得。观世间集谛故散不可得。如是等义。当知集散不可得云何当作菩萨字。若强为名。是名亦无住亦无不住。问曰。是名字何以故不住。答曰。名字在法中住。法空故名字无住处。如车轮辋辐毂等和合故有车名。若散是和合则失车名。是车名非轮等中住。亦不离轮等中住。车名字一异中求皆不得。失车名字故。名字无住处。因缘散时尚无。何况因缘灭。众生亦如是。色等五众和合故有众生字。若五众离散名字无住处。五众离散时尚无。何况无五众。问曰。若散时名字不可得。和合未散时则有名字。何以言不可得。答曰。是菩萨名字一。五众则有五。一不作五五不作一。若五作一如五匹物不得为一匹用。若一作五如一匹物不得为五匹用。以是故一菩萨字不得五众中住。非不住者。若名字因缘和合无。则世俗语言众事都灭。世谛无故第一义谛亦无。二谛无故诸法错乱。复次若因缘中有名字者。如说火则烧口。说有则塞口。若名字不在法中者。说火不应生火想。求火亦可得水。从久远已来共传名字故。因名则识事。以是故说名字义非住非不住。复次是中须菩提自说。因缘无所有故。是名字非住非不住。如菩萨名字五众十二入十八界等诸法亦如是。问曰。如上来说。五众诸法集散不可得。今何以复说五众。答曰。上直说五众。今说五众如梦如幻。复次有人谓。凡夫人五众虚诳不实如梦。圣人五众非是虚诳。以是故须菩提说。如梦如幻同皆不住。问曰。十譬喻中何以但说五事。答曰。若说十事无在。但以随众生心。说五喻事辩故不尽说。或以五众故说五喻。余法亦如是。离有二种。一者身离。二者心离。身离者。舍家恩爱世事等闲居静处。心离者。于诸结使悉皆远离。复有二种离。一者诸法离名字。二者诸法各各离自相。此中说后二种离。所以者何。此中破名字故余处自相离。小乘法中多说前二离。寂灭亦有二种。一者淳善相寂灭恶事。二者如涅槃寂灭相。观世间诸法亦如是。此中但说后寂灭。不生亦有二种。一者未来无为法名不生。二者一切法实无生相。生不可得故此中但说后不生。不灭有三种。智缘灭非智缘灭无常灭。此中说无常灭。与此相违故名不灭。不示者一切诸观灭。语言道断故无法可示。是法如。是相若有若无若常若无常等。不垢不净。如法性实际法相法位义如先说。问曰。五众法有集散。与此相违故言不集不散。如法性实际等无相违故。云何言不集不散。答曰。行者得如法性等故名为集。失故名为散。如虚空虽无集无散。凿户牖名为集。塞故名为散。善不善乃至十方如恒河沙等诸佛义如先说。是诸佛法及佛名字无所依止故。皆空不住非不住

【经】世尊。诸法因缘和合假名施设。所谓菩萨是名字于五受阴中不可说。十二入十八界乃至十八不共法中不可说。于和合法中亦不可说。世尊。譬如梦于诸法中不可说。响影焰化于诸法中亦不可说。譬如名虚空。亦无法中可说。世尊。如地水火风名。亦无法中可说。戒三昧智慧解脱解脱知见名。亦无法中可说。如须陀洹名字。乃至阿罗汉辟支佛名字。亦无法中可说。如佛名法名。亦无法中可说。所谓若善若不善若常若无常。若苦若乐若我若无我。若寂灭若离若有若无。世尊。我以是义故心悔。一切诸法集散相不可得。若为菩萨作字言是菩萨。世尊。是字不住亦不不住。何以故。是字无所有故。以是故是字不住亦不不住。若菩萨摩诃萨闻作是说般若波罗蜜如是相如是义。心不没不悔不惊不畏不怖。当知是菩萨必住阿鞞跋致性中。住不住法故

【论】释曰。上来非住非不住门。破菩萨名字及诸法。今以异门破菩萨名字。无法可说为菩萨。何以故。菩萨非是五众。五众非是菩萨。五众中无菩萨。菩萨中无五众。五众不属菩萨。菩萨不属五众离五众无菩萨。离菩萨无五众。如是菩萨名字不可得。当知是空乃至十八不共法亦如是。譬如梦中有所见。皆是虚妄不可说。此梦中无有定法相。所谓五众十二入十八界。但有诳心。余影响焰化亦如是但诳耳目。如虚空一切法中不可说。无相故。虚空与色相违故不得说名为色。色尽处亦非虚空。更无别法故。若谓入出为虚空相。是事不然。是身业非虚空相。若无相则无法。以是故虚空但有名字。菩萨名字亦如是。问曰。如梦虚空等可但有名字。云何地水火风实法亦但有名字。答曰。无智人谓地等诸物以为实。圣人慧眼观之。皆是虚诳。譬如小儿见镜中像以为实。欢喜欲取谓为真实。大人观之但诳惑人眼。诸凡夫人见微尘和合成地谓为实地。余有天眼者散此地但见微尘。慧眼分别破散此地都不可得。复次初品论中种种破身相。如身破地亦破。复次若地是实。云何一切火观时皆是火。若以禅定观为实。佛说一切法空为虚妄。但是事不然。水火风亦如是。如四大为身本犹尚尔。何况身所作持戒等诸业而不空。如戒等粗业尚空。何况禅定智慧解脱解脱知见等而不空。若戒等五众空者。何况是因缘得诸圣道果而不空。若圣道果空者。何况须陀洹人乃至佛而不空。以是故菩萨名字虽善法乃至有无法中。出不名为善。乃至不名为有无集散不可得故。须菩提知空相如是。云何说名菩萨为说般若波罗蜜。若菩萨闻是不恐不畏。则是阿鞞跋致性中住。以如不住法住故。阿鞞跋致性者。是菩萨未得无生法忍。未从诸佛授记。但福德智慧力故。能信乐诸法毕竟空。是名阿鞞跋致性中住得阿鞞跋致气分故。如小儿在贵性中生。虽未成事以姓贵故便贵

【经】复次世尊。菩萨摩诃萨欲行般若波罗蜜。色中不应住。受想行识中不应住。眼耳鼻舌身意中不应住。色声香味触法中不应住。眼识乃至意识中不应住。眼触乃至意触中不应住。眼触因缘生受乃至意触因缘生受中不应住。地种水火风空识种中不应住。无明乃至老死中不应住。何以故。世尊。色色相空。受想行识识相空。世尊。色空不名为色。离空亦无色。色即是空空即是色。受想行识空不名为识。离空亦无识。识即是空空即是识。乃至老死老死相空。世尊老死空不名为老死。离空亦无老死。老死即是空空即是老死。世尊。以是因缘故。菩萨摩诃萨欲行般若波罗蜜。不应色中住。乃至老死中亦不应住。复次世尊。菩萨摩诃萨欲行般若波罗蜜。四念处中不应住。何以故。四念处四念处相空。世尊。四念处空不名为四念处。离空亦无四念处。四念处即是空空即是四念处。乃至十八不共法亦如是。世尊以是因缘故。菩萨摩诃萨欲行般若波罗蜜。四念处乃至十八不共法中不应住。复次世尊。菩萨摩诃萨欲行般若波罗蜜。檀波罗蜜中不应住。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜中不应住。何以故。檀波罗蜜檀波罗蜜相空。乃至般若波罗蜜般若波罗蜜相空。世尊。檀波罗蜜空不名为檀波罗蜜。离空亦无檀波罗蜜。檀波罗蜜即是空空即是檀波罗蜜。乃至般若波罗蜜亦如是。世尊。以是因缘故。菩萨摩诃萨欲行般若波罗蜜不应六波罗蜜中住

【论】释曰。上须菩提以谦让门说般若。虽言不说而实为诸菩萨说般若波罗蜜。今须菩提以不住门直为菩萨说般若波罗蜜。般若波罗蜜有种种名字。观修相应合入习住等。是皆名修行般若波罗蜜。但种种名字说闻者欢喜。复次小有差别行。名听闻诵读书写正忆念说思惟筹量分别修习等。乃至阿耨多罗三藐三菩提总名为行。是行中分别故初者名观。如初始见物。日日渐学是名习。与般若波罗蜜相可是名合。随顺般若波罗蜜名相应。通彻般若波罗蜜是名为入。分别取相有是事名为念。常行不息令与相似是名为学。学已巧方便观知是非得失名为思惟。以禅定心共行名为修。得是般若波罗蜜道不失是名住。与住相违名不住。问曰。先说诸法空即是不住。今何以说诸法中不应住。答曰。先虽说着法爱心难遣故今更说。复次有无相三昧。入此三昧于一切法不取相。而不入灭定。菩萨智慧不可思议。虽不取一切法相而能行道。如鸟于虚空中无所依而能高飞。菩萨亦如是。于诸法中不住而能行菩萨道。问曰。人心得缘便起。云何菩萨于一切法不住而不入灭定中。答曰。此中须菩提自说。所谓色色相自空。色空为非色亦不离空有色。色即是空空即是色。是义第二品中已说。乃至不应六波罗蜜中住。亦如是。以空故无所住

【经】复次世尊。菩萨摩诃萨欲行般若波罗蜜。文字中不应住。一字门二字门。如是种种字门中不应住。何以故。诸字诸字相空故亦如上说

复次世尊。菩萨摩诃萨欲行般若波罗蜜。诸神通中不应住。何以故。诸神通诸神通相空。神通空不名为神通。离空亦无神通。神通即是空空即是神通。世尊。以是因缘故。菩萨摩诃萨欲行般若波罗蜜。诸神通中不应住

【论】释曰。有二种菩萨。一者习禅定。二者学读。坐禅者生神通。学读者知分别文字。一字门者。一字一语如地名浮。二字门者。二字一语如水名阇蓝。三字门者。如水名波尸蓝。如是等种种字门。复次菩萨闻一字。即入一切诸法实相中。如闻阿字即知诸法从本已来无生。如是等如闻头佉。一切法中苦相生。即时生大悲心。如闻阿尼吒知一切法无常相。即时入道圣行。余如文字陀罗尼中广说。神通义先已说。是二事毕竟空故。菩萨不于中住

【经】复次世尊。菩萨摩诃萨欲行般若波罗蜜。色是无常不应住。受想行识是无常不应住。何以故。无常无常相空。世尊。无常空不名无常。离空亦无无常。无常即是空空即是无常。世尊。以是因缘故。菩萨摩诃萨欲行般若波罗蜜。色是无常不应住。受想行识是无常不应住。色是苦不应住。受想行识是苦不应住。色是无我不应住。受想行识是无我不应住。色是空不应住。受想行识是空不应住。色是寂灭不应住。受想行识是寂灭不应住。色是离不应住。受想行识是离不应住亦如上说

复次世尊。菩萨摩诃萨欲行般若波罗蜜。如相中不应住。何以故。如相如相空。世尊。如相空不名为如。离空亦无如。如即是空空即是如。世尊。菩萨摩诃萨欲行般若波罗蜜。法性法相法位实际中不应住。何以故。实际空。世尊。实际空不名为实际。离空亦无实际。实际即是空空即是实际

复次世尊。菩萨摩诃萨欲行般若波罗蜜。一切陀罗尼门中不应住。一切三昧门中不应住。何以故。陀罗尼门陀罗尼门相空。三昧门三昧门相空。世尊。陀罗尼门三昧门空不名为陀罗尼门三昧门。离空亦无陀罗尼三昧门。陀罗尼三昧门即是空。空即是陀罗尼三昧门。世尊。以是因缘故。菩萨摩诃萨欲行般若波罗蜜。乃至陀罗尼三昧门中不应住。世尊。如菩萨摩诃萨欲行般若波罗蜜。无方便故以吾我心于色中住。是菩萨作色行。以吾我心于受想行识中住。是菩萨作识行。若菩萨作行者不受般若波罗蜜。亦不具足般若波罗蜜。不具足般若波罗蜜故。不能得成就萨婆若。世尊。如是菩萨摩诃萨欲行般若波罗蜜。无方便故以吾我心于十二入乃至陀罗尼三昧门中住。是菩萨作十二入。乃至作陀罗尼三昧门行。若菩萨作行者。不受般若波罗蜜。亦不具足般若波罗蜜。不具足般若波罗蜜故。不能得成就萨婆若。何以故。色是不受。受想行识是不受。色不受则非色。性空故。受想行识不受则非识。性空故。十二入是不受。乃至陀罗尼三昧门是不受。十二入不受则非十二入。乃至陀罗尼三昧门不受。则非陀罗尼三昧门。性空故。般若波罗蜜亦不受。般若波罗蜜不受。则非般若波罗蜜。性空故。如是菩萨摩诃萨欲行般若波罗蜜。应观诸法性空。如是观心无行处。是名菩萨摩诃萨不受三昧。广大之用不与声闻辟支佛共。是萨婆若慧亦不受。内空故。外空内外空空空大空第一义空有为空无为空毕竟空无始空散空性空自相空诸法空不可得空无法空有法空无法有法空故。何以故。是萨婆若不可以相行得。相行有垢故。何等是垢相。色相乃至诸陀罗尼三昧门相。是名垢相。是相若受若修可得萨婆若者

【论】释曰。无常等圣行。及如法性实际陀罗尼三昧门先已说。问曰。垢法中不应住。以罪故。善无记法中何故不应住。答曰。是虽非罪而生罪因缘。如佛此中说。有菩萨以吾我心行般若波罗蜜。住色中着色。为生色故作诸业。受想行识亦如是。为起五众故行。是为不取般若波罗蜜。是人虽言我行般若波罗蜜。是为世间行。不具足般若波罗蜜故。不能至一切智。乃至陀罗尼三昧门亦如是。此中须菩提自说不住因缘。所谓色是不受。若色不受则非色。性常空故。问曰。是色无常苦空等过罪故不受。譬如热金丸虽有金可贪但以热故知不可取。如是者有何咎而强破五众法。答曰。有二种着。一者欲着。二者见着。有人观是无常苦等。破欲着得解脱。或有人虽观无常等。犹着法生见。为是人故分别色相空。如是则离见着。乃至陀罗尼三昧门亦如是。问曰。声闻辟支佛一切法不受故漏尽。此中云何说不受三昧不与二乘共。答曰。彼虽有不受三昧。无有广大之用。不利不深亦不坚固。复次声闻辟支佛漏尽时得诸法不受。菩萨久来知一切法不受。皆如无余涅槃毕竟空。是故说不与二乘共。复次二乘有习气有碍有障故。虽有无受三昧不清净。如摩诃迦叶闻菩萨伎乐。于坐处不能自安。诸菩萨问言。汝头陀第一。何故欲起似舞。迦叶答言。我于人天五欲中永离不动。此是大菩萨福德业因缘变化力我未能忍。如须弥山王四面风起皆能堪忍。若随岚风至不能自安。声闻辟支佛习气于菩萨为烦恼。复次此无受三昧惟佛遍知。菩萨求佛道故。虽不能遍而胜于二乘。以是故说不与二乘共。以人贵重是不受三昧而生着心。是故须菩提说不但是三昧不受。色乃至一切种智皆不受。所以者何。须菩提自说因缘。所谓十八空故不受。问曰。何以故。用是十八空观诸法皆空。答曰。此中须菩提自说因缘。取相着故生诸结使相者。色乃至陀罗尼门诸三昧门相。皆是烦恼根本。若佛法中乃至无有法微相可取者

【经】先尼梵志于一切智中终不生信。云何为信信般若波罗蜜。分别解知称量思惟。不以相法不以无相法。如是先尼梵志不取相住信行中。用性空智入诸法相。不受色不受受想行识。何以故。诸法自相空故。不可得受。是先尼梵志非内观得故见是智慧。非外观得故见是智慧。非内非外观得故见是智慧。亦不无智慧观得故见是智慧。何以故。梵志不见是法知者知法知处故。此梵志非内色中见是智慧。非内受想行识中见是智慧。非外色中见是智慧。非外受想行识中见是智慧。非内外色中见是智慧。非内外受想行识中见是智慧。亦不离色受想行识中见是智慧。内外空故。先尼梵志此中心得信解于一切智。以是故梵志信诸法实相。一切法不可得故。如是信解已无法可受。诸法无相无忆念故。是梵志于诸法亦无所得。若取若舍。取舍不可得故。是梵志智慧亦不念。诸法相不念故。世尊。是名菩萨摩诃萨般若波罗蜜。此彼岸不度故。是菩萨色受想行识不受。一切法不受故。乃至诸陀罗尼三昧门亦不受。一切法不受故是菩萨于是中亦不取涅槃。未具足四念处乃至八圣道分。未具足十力乃至十八不共法。何以故。是四念处非四念处。乃至十八不共法非十八不共法。是诸法非法亦不非法。是名菩萨摩诃萨般若波罗蜜。色不受乃至十八不共法不受

【论】问曰。此中何因缘说先尼梵志。答曰。此经种种因缘说法空。乃至无微相可取。人心疑怪不信。是理难见。以毕竟无相故。以是故须菩提引证小乘中尚有法空。何况行大乘法者而不信法空。复次如删若婆婆罗门。善知一切智人相。见菩萨食乳糜。知今日当成佛。先尼是其舅也。耆年智德有大名闻。出家广读一切经书。修心坐禅学道。时时欲求智慧故往诣论议堂。诸梵志言。六师皆自称一切智。不兰迦叶有大名闻。是大众师。其弟子死若小若大皆不说其生处。余五师弟子死若小若大皆说其生处。佛亦是大师有大名闻。其弟子死小者说其生处。大者不说其生处。先尼闻已异时诣佛所问讯已一面坐。问佛言。佛听当问。佛言恣汝所问。先尼言。昔我一时曾到论堂与诸人论议。如昔所闻具向佛说。是时我作是念。佛法说弟子小者更生大者不生。何者为定。佛告先尼。我法甚深微妙难解。汝等长夜着诸异见异欲异法。汝于我法不能自见。先尼梵志。白佛言。我心敬佛愿加愍念为说妙法。令我于坐得眼无令空起。佛问梵志。于汝意云何。汝见是色如去不。答言。不也。受想行识如去不。答言。不也。色中如去不。答言。不也。受想行识中如去不。答言。不也。离色如去不。答言。不也。离受想行识如去不。答言。不也。汝更见无色无受想行识如去者不。答曰。不也。若汝种种门不见如去者。应生疑言。佛法何者为定。答曰。不应。佛告先尼。若我弟子是法中不了了知者说有后生。本来有我慢等残故。若我弟子了了解知是义者不说其生处。本来我慢等无残故。先尼闻是已即时得道。得道已从坐起。白佛言。愿得出家为道。即时鬓发自堕便成沙门。不久得阿罗汉。从佛得眼不虚故。是经论议先尼信者。信佛能令我得道。是名初信。然后闻佛破吾我从本已来常自无我。无我故诸法无所属。如幻如梦虚诳不实不可得。取得是信力已入诸法实相。不受色是如去乃至识是如去。问曰。梵志何以答佛皆言不也。答曰。梵志本总相为我。佛今一一别问。以是故答佛言不也。复次梵志闻人二种说我。或有说五众即是我。或有说离五众别有我。若五众即是我则无别我所以者何。我是一众是五。一不作五五不作一。复次五众无常生灭相。五众是我亦应生灭。若生灭者则失罪福。是五众从因缘和合生不自在。我若尔者何用我为。不自在故。如是等过罪故不得说言。色如去受想行识如去。离五众亦不应有我无相故。若知见受等是皆五众相非是我相。智者云何说离五众而有我。以是故言不也。若有言别更有我无五众。是亦不然。皆是颠倒妄见分别。如是种种因缘知无我。我即是如去诸法亦尔皆同如去。以无主故法无所属。复次梵志推求得道智慧。于四处求之皆无定相。所谓观自身五众名为内。外观他身名为外。彼此名为内外是三种智慧不得道。无智慧亦不得道。复次内者内六入。外者外六入。复次内名能观智慧。外名所观处。是先尼知诸观皆有过罪。何以故。内以智慧力故。谓外诸法是常无常有无等。非外法有定相。若有定相则无智用。又此智慧从外法因缘生。外法相不定故智慧亦不定。如称为物故。物为称故。二事相待。若离物无称离称无物。无量教智名得道。方便得名得圣道果。复次略说实智慧义。所谓不见内五众中。不见外五众中。亦不见内外五众中。亦不见离五众中。见是智慧为实。以无常智慧观五众无常。是智慧从因缘和合故有不实。着观者邪见。不著者得道。若无常相是实者。何故着而不得道。以是故一切内外不见定智慧。若离是无常等观得道者。一切凡人亦应得道。以是故说。离是智慧。亦无所得。尔时梵志。以是智慧。于一切法中心得远离。于智慧亦复远离。一切我见等取相邪见一切皆灭。亦不从无智得。尔时梵志。欢喜观无量法性相佛真为大师。不舍者。诸法中皆有助道力故。不受者。诸法实相毕竟空无所得故不受。复次诸结使烦恼颠倒虚妄故无所舍。但知诸法如实相无相无忆念故。是名菩萨不受不舍波罗蜜。名为般若波罗蜜。此彼岸不度故世间即是涅槃相。涅槃相即是世间相。一相所谓无相。若如是知应当灭。以未具足诸功德故不灭。大慈慈本愿力故不灭。虽求佛道于此法中亦无好丑相及受舍相。以是故非法亦非非法。是名菩萨般若波罗蜜一切相不受

大智度论卷第四十二大智度论释集散品第九下(卷第四十三)

        龙树菩萨造

        后秦龟兹国三藏鸠摩罗什译

【经】复次世尊。菩萨摩诃萨欲行般若波罗蜜应如是思惟。何者是般若波罗蜜。何以故。名般若波罗蜜。是谁般若波罗蜜。若菩萨摩诃萨行般若波罗蜜。如是念。若法无所有不可得是般若波罗蜜。尔时舍利弗。问须菩提。何等法无所有不可得。须菩提言。般若波罗蜜是法无所有不可得。禅波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀波罗蜜是法无所有不可得。内空故。外空内外空空空大空第一义空有为空无为空毕竟空无始空散空性空自相空诸法空不可得空无法空有法空无法有法空故。舍利弗。色法无所有不可得。受想行识法无所有不可得。内空法无所有不可得。乃至无法有法空。法无所有不可得。舍利弗。四念处法无所有不可得。乃至十八不共法无所有不可得。舍利弗。诸神通法无所有不可得。如相法无所有不可得。法性法相法住法位实际法无所有不可得。舍利弗。佛无所有不可得。萨婆若法无所有不可得。一切种智法无所有不可得。内空乃至无法有法空故。舍利弗。若菩萨摩诃萨如是思惟如是观时。心不没不悔不惊不畏不怖。当知是菩萨不离般若波罗蜜行。舍利弗。问须菩提。何因缘故。当知菩萨。不离般若波罗蜜行。须菩提言。色离色性。受想行识离识性。六波罗蜜离六波罗蜜性。乃至实际离实际性。舍利弗。复问须菩提。云何是色性。云何是受想行识性。云何乃至实际性。须菩提言。无所有是色性。无所有是受想行识性。乃至无所有是实际性。舍利弗。以是因缘故。当知色离色性。受想行识离识性。乃至实际离实际性。舍利弗。色亦离色相。受想行识亦离识相。乃至实际亦离实际相。相亦离相。性亦离性。舍利弗。问须菩提。菩萨摩诃萨若如是学。得成就萨婆若。须菩提言。如是如是。舍利弗。若菩萨摩诃萨如是学得成就萨婆若。何以故。以诸法不生不成就故。舍利弗。问须菩提。何因缘故诸法不生不成就。须菩提言。色色空是色生成就不可得。受想行识识空是识生成就不可得。乃至实际实际空是实际生成就不可得。舍利弗。菩萨摩诃萨如是学渐近萨婆若。渐得身清净心清净相清净。渐得身清净心清净相清净故。是菩萨不生染心不生嗔心不生痴心。不生憍慢心不生悭贪心不生邪见心。是菩萨不生染心乃至不生邪见心故。终不生母人腹中。常得化生。从一佛国至一佛国。成就众生净佛世界。乃至阿耨多罗三藐三菩提。终不离诸佛。舍利弗。菩萨摩诃萨当作是行般若波罗蜜。当作是学般若波罗蜜

【论】问曰。上来广说般若波罗蜜。今须菩提何以作是言。菩萨摩诃萨应如是思惟。何者是般若波罗蜜。答曰。须菩提上来谦让门说。次不住门说。今明般若波罗蜜体。何等是般若波罗蜜。般若波罗蜜者。是一切诸法实相不可破不可坏。若有佛若无佛常住诸法相法位。非佛非辟支佛非菩萨非声闻非天人所作。何况其余小众生。复次常是一边。断灭是一边。离是二边行中道。是为般若波罗蜜。又复常无常苦乐空实我无我等亦如是。色法是一边无色法是一边。可见法不可见法。有对无对有为无为有漏无漏。世间出世间等诸二法亦如是。复次无明是一边无明尽是一边。乃至老死是一边老死尽是一边。诸法有是一边诸法无是一边。离是二边行中道。是为般若波罗蜜。菩萨是一边六波罗蜜是一边。佛是一边菩提是一边。离是二边行中道。是为般若波罗蜜。略说内六情是一边。外六尘是一边。离是二边行中道。是名般若波罗蜜。此般若波罗蜜是一边此非般若波罗蜜是一边。离是二边行中道。是名般若波罗蜜。如是等二门广说无量般若波罗蜜相。复次离有离无离非有非无不堕愚痴。而能行善道。是为般若波罗蜜。如是等三门是般若波罗蜜相。复次须菩提此中自说。是法无所有不可得。是般若波罗蜜空故无所有。常无常等诸观求觅无定相故不可得。复次无所有者。此中须菩提自说。般若波罗蜜乃至五波罗蜜法。无所有不可取不可受不可着故。复次十八空故。是六波罗蜜无所有不可得。譬如大风能破散诸云。亦如大火烧干草木。如金刚宝摧破大山。诸空亦如是能破诸法。何以故。名般若波罗蜜者。般若者(秦言智慧)一切诸智慧中最为第一。无上无比无等。更无胜者穷尽到边。如一切众生中佛为第一。一切诸法中涅槃为第一。一切众中比丘僧为第一。问曰。汝先说诸法实相是般若波罗蜜。所谓法位法住有佛无佛常住不异。今何以说诸智慧中般若波罗蜜第一。譬如诸法中涅槃为第一。答曰。世间法或时因中说果。或时果中说因无咎。如人日食数匹布。布不可食。从布因缘得食。是名因中说果。如见好画而言好手。是名果中说因。因诸法实相生智慧。是则果中说因。复次是菩萨入不二入法门。是时能直行此般若波罗蜜。不分别是因是果是缘是知是内是外是此是彼等。所谓一相无相。以是故不应难。复次世间三种智慧。一者世俗巧便博识文艺仁智礼敬等。二者离生智慧。所谓离欲界乃至无所有处。三者出世间智慧。所谓离我及我所。诸漏尽声闻辟支佛智慧。般若波罗蜜为最殊胜。毕竟清净无所著故。为饶益一切众生故。声闻辟支佛智慧虽漏尽故清净。无大慈悲不能饶益一切故不如。何况世俗罪垢不净欺诳智慧。三种智慧不及是智慧故。名为般若波罗蜜。复次是智慧为度一切众生故。为得佛道故。是智慧相应受想行识。及从智慧起。身业口业及生住等心不相应诸行。是诸法和合名为波罗蜜。是诸波罗蜜中智慧多故。名为般若波罗蜜。念定等多故。名为禅波罗蜜。余波罗蜜义亦如是。如是等种种无量因缘故。名为般若波罗蜜。是谁般若波罗蜜者。第一义中无知者见者得者。一切法无我无我所相。诸法但空。因缘和合相续生。若尔般若波罗蜜当属谁。佛法有二种。一者世谛。二者第一义谛。为世谛故般若波罗蜜属菩萨。凡夫人法种种过罪不清净故则不属凡夫人。般若波罗蜜毕竟清净。凡夫所不乐。如蝇乐处不净不好莲花。凡夫人虽复离欲。有吾我心着离欲法故。不乐般若波罗蜜。声闻辟支佛虽欲乐般若波罗蜜。无深慈悲故。大厌世间一心向涅槃。是故不能具足得般若波罗蜜。是般若波罗蜜菩萨成佛时转名一切种智。以是故般若不属佛。不属声闻辟支佛。不属凡夫。但属菩萨。问曰。此经中常说。五众在前一切种智在后。今何以先说六波罗蜜。答曰。舍利弗。问须菩提。无所有义解。五众种种因缘观。强令无所有难解。般若波罗蜜即是无所有易解。譬如水中月易明其空天上月难令无所有。五波罗蜜与般若波罗蜜同名同事。是故续说五波罗蜜。然后续说五众乃至一切种智无所有不可得。菩萨入是门观诸法实相不恐不怖者。当知是菩萨不离般若波罗蜜。不离者常行般若波罗蜜。不虚必有果报。此中须菩提自说不离因缘。所谓色离色性。色中无色相。虚诳无所有菩萨能如是知不离。实智慧。乃至实际亦如是。菩萨能行是无障碍道得至萨婆若。一切法不生不出故。舍利弗问须菩提。云何一切法不生。须菩提答。色色相空故。色无生无成就。乃至实际亦如是。若菩萨能如是行。是清净第一无上无比故渐近萨婆若。渐近萨婆若故。心不生邪见烦恼戏论。即时得心清净。心清净果报故得身清净。三十二相八十随形好庄严其身。得三种清净故。破诸虚诳取相之法。受法性生身。所谓常得化生不处胞胎。问曰。若有力如此何用化生。贪着其身而不取涅槃。答曰。有二事因缘故。以诸佛是众生中宝。欲供养无厌故。有本愿度众生净佛世界未满故。是菩萨福德方便力故。常不离诸佛

    大智度论释行相品第十

【经】尔时须菩提白佛言。世尊。若菩萨摩诃萨无方便。欲行般若波罗蜜。若行色为行相。若行受想行识为行相。若色是常行为行相。若受想行识是常行为行相。若色是无常行为行相。若受想行识是无常行为行相。若色是乐行为行相。若受想行识是乐行为行相。若色是苦行为行相。若受想行识是苦行为行相。若色是有行为行相。若受想行识是有行为行相。若色是空行为行相。若受想行识是空行为行相。若色是我行为行相。若受想行识是我行为行相。若色是无我行为行相。若受想行识是无我行为行相。若色是离行为行相。若受想行识是离行为行相。若色是寂灭行为行相。若受想行识是寂灭行为行相。世尊。若菩萨摩诃萨无方便。行四念处为行相。乃至十八不共法为行相。世尊。若菩萨摩诃萨行般若波罗蜜时作是念。我行般若波罗蜜有所得行。亦是行相。世尊。若菩萨摩诃萨作是念。能如是行是修行般若波罗蜜。亦是行相。当知是菩萨摩诃萨行般若波罗蜜无方便。须菩提。语舍利弗。若菩萨摩诃萨行般若波罗蜜时色受念妄解。若色受念妄解为色故作行。若为色作行。不得离生老病死忧悲苦恼及后世苦。若菩萨摩诃萨行般若波罗蜜时无方便。眼受念妄解乃至意。色乃至法。眼识界乃至意识界。眼触乃至意触。眼触因缘生受。乃至意触因缘生受。四念处乃至十八不共法受念妄解。为十八不共法故作行。若为作行。是菩萨不能得离生老病死忧悲苦恼及后世苦。如是菩萨尚不能得声闻辟支佛地证。何况得阿耨多罗三藐三菩提。无有是处。舍利弗当知。是菩萨摩诃萨行般若波罗蜜无方便。舍利弗。问须菩提。云何当知。是菩萨摩诃萨行般若波罗蜜有方便。须菩提。语舍利弗。若菩萨摩诃萨欲行般若波罗蜜时。不行色不行受想行识。不行色相不行受想行识相。不行色受想行识常。不行色受想行识无常。不行色受想行识乐。不行色受想行识苦。不行色受想行识我。不行色受想行识无我。不行色受想行识空。不行色受想行识无相。不行色受想行识无作。不行色受想行识离。不行色受想行识寂灭。何以故。舍利弗。是色空为非色。离空无色离色无空。色即是空空即是色。受想行识空为非识。离空无识离识无空。空即是识识即是空。乃至十八不共法空为非十八不共法。离空无十八不共法。离十八不共法无空。空即是十八不共法。十八不共法即是空。如是舍利弗当知。是菩萨摩诃萨行般若波罗蜜有方便。是菩萨摩诃萨如是行般若波罗蜜。能得阿耨多罗三藐三菩提。是菩萨摩诃萨行般若波罗蜜时。行亦不受不行亦不受。行不行亦不受。非行非不行亦不受。不受亦不受。舍利弗。语须菩提。菩萨摩诃萨行般若波罗蜜时。何因缘故不受。须菩提言。是行般若波罗蜜自性不可得故不受。何以故。无所有性是般若波罗蜜。舍利弗。以是故菩萨摩诃萨行般若波罗蜜。行亦不受不行亦不受。行不行亦不受。非行非不行亦不受。不受亦不受。何以故。一切法性无所有。不随诸法行不受诸法相故。是名菩萨摩诃萨诸法无所受三昧广大之用。不与声闻辟支佛共。是菩萨摩诃萨行。是三昧不离疾得阿耨多罗三藐三菩提

【论】释曰。前品用空门破诸法。此品欲以无相门破诸法。若菩萨无方便观色则堕相中。堕相中故失般若波罗蜜行。所以者何。以一切法空故无相可取。问曰。人知善恶果报。取果报相已分别善恶。善者取恶者舍。是故行道。云何说诸法无相相。答曰。取相者为初学者说。无相者为行道住解脱门者说。不应以粗事为难。今行者取善相破不善相。所谓取男女等相生诸烦恼因缘。后以无相相破善法相。若破不善而不破善相者。善即为患。生诸着故。以无相相破善法。无相亦自破。所以者何。无相善法所摄故。譬如雹堕害谷雹自消灭

复次一切法无相相为实。譬如身不净充满。九孔常流。无有净相。而人无明故强以为净。生烦恼作诸罪。如小儿于不净物中取净相以为乐。长者观之而笑知为虚妄。如是等种种取相皆为虚妄。如颇梨珠随前色变自无定色。诸法亦如是。无有定相随心为异。若常无常等相。如以嗔心见此人为弊。若嗔心休息。淫欲心生见此人还复为好。若以憍慢心生见此人以为卑贱。闻其有德还生敬心。如是等有理而憎爱。无理而憎爱。皆是虚妄忆想。若除虚诳相。亦无空相无相相无作相。无所破故。是色从种种因缘和合而有。譬如水沫如幻如梦。若菩萨于色中取一相。即失般若波罗蜜。色性是无相相故。受是色相已。见色散坏磨灭谓是无常。若见和合少许时住谓为常有。常有二种。一者若住百岁千万亿岁。若一劫若八万劫然后归灭。二者常住不坏。菩萨。若边邪灭故。亦不复观真实常。若观常知是久住故常非是真实。若不灭边邪观色为真实。常作是念。草木零落还归为土。但离合有时是故说是菩萨无方便。菩萨或观色无常。无常亦有二种。一者念念灭。一切有为法不过一念住。二者相续法坏故名为无常。如人命尽。若火烧草木。如煎水消尽。若初发心菩萨行是相续断粗无常心厌故。若久行菩萨能观诸法念念生灭无常。是二菩萨皆堕取相中。所以者何。是色常无常相不可得。如先说。受想行识亦如是。苦乐我非我亦尔。问曰。是五众可作常无常等观。云何言五众是寂灭远离相。答曰。行者不见五众常无常相。故知是五众离自相。若知五众离自相。即是寂灭如涅槃。问曰。若尔者初自无相。云何说言无方便。堕相中。答曰。是菩萨根钝不自觉心离五众着。转复着远离寂灭。于无相中而生着。三十七品乃至十八不共法。亦应如是随义分别。若菩萨观外诸法皆无相。言我能作是观。以有我心残故亦堕相中。若菩萨能离此着相非道。行真净无相智慧作是念。能如是内外清净行。是为修行般若波罗蜜。是人亦堕相中。所以者何。不可着而着。不可取而取故。是菩萨名为无方便。依止爱见着善法故。是菩萨虽有福德。亦不得离老病死忧悲苦恼杂行道。故尚不能得小乘。何况大乘。与上相违名为有方便。于一切法不受不着。诸法和合因缘生无自性故。问曰。前说无受三昧。此说不受三昧有何等异。答曰。前者为空故。此为无相故。不远离者。常行不息不休。以大慈悲心故。疾得佛道者。入是三昧无障碍故。所行智慧与佛相似。若无量阿僧祇劫应得。或时超一阿僧祇劫百劫乃至六十一劫。如弗沙佛。赞叹释迦文佛超越九劫

【经】舍利弗言。但不离是三昧。令菩萨摩诃萨疾得阿耨多罗三藐三菩提。更有诸余三昧。须菩提。语舍利弗言。更有诸余三昧。菩萨摩诃萨行是三昧。疾得阿耨多罗三藐三菩提。舍利弗言。何等三昧。菩萨摩诃萨行是疾得阿耨多罗三藐三菩提。须菩提言。诸菩萨摩诃萨有三昧名首楞严。行是三昧令菩萨摩诃萨。疾得阿耨多罗三藐三菩提。有名宝印三昧。师子游戏三昧。妙月三昧。月幢相三昧。诸法印三昧。观顶三昧。毕法性三昧。毕幢相三昧。金刚三昧。入法印三昧。三昧王安立三昧。放光三昧。力进三昧。出生三昧。必入辩才三昧。入名字三昧。观方三昧。陀罗尼印三昧。不妄三昧。摄诸法海印三昧。遍覆虚空三昧。金刚轮三昧。宝断三昧。普照三昧。不求三昧。无处住三昧。无心三昧。净灯三昧。无边明三昧。能作明三昧。普遍明三昧。坚净诸三昧。三昧无垢明三昧。作乐三昧。电光三昧。无尽三昧。威德三昧。离尽三昧。不动三昧。庄严三昧。日光三昧。月净三昧。净明三昧。能作明三昧。作行三昧。知相三昧。如金刚三昧。心住三昧。遍照三昧。安立三昧。宝顶三昧。妙法印三昧。法等三昧。生喜三昧。到法顶三昧。能散三昧。坏诸法处三昧。字等相三昧。离字三昧。断缘三昧。不坏三昧。无种相三昧。无处行三昧。离闇三昧。无去三昧。不动三昧。度缘三昧。集诸功德三昧。住无心三昧。妙净华三昧。觉意三昧。无量辩三昧。无等等三昧。度诸法三昧。分别诸法三昧。散疑三昧。无住处三昧。一相三昧。一性三昧。生行三昧。一行三昧。不一行三昧。妙行三昧。达一切有底散三昧。入言语三昧。离音声字语三昧。然炬三昧。净相三昧。破相三昧。一切种妙足三昧。不喜苦乐三昧。不尽行三昧。多陀罗尼三昧。摄诸邪正相三昧。灭憎爱三昧。逆顺三昧。净光三昧。坚固三昧。满月净光三昧。大庄严三昧。能照一切世三昧。三昧等三昧。无诤行三昧。无住处乐三昧。如住定三昧。坏身衰三昧。坏语如虚空三昧。离着如虚空不染三昧。舍利弗。是菩萨摩诃萨行是诸三昧。疾得阿耨多罗三藐三菩提。复有无量阿僧祇三昧门陀罗尼门。菩萨摩诃萨学是三昧门陀罗尼门。疾得阿耨多罗三藐三菩提。慧命须菩提随佛心言。当知是菩萨摩诃萨行是诸三昧者。以为过去佛诸所授记。今现在十方诸佛亦授是菩萨记。是菩萨不见是诸三昧。亦不念是三昧。亦不念我当入是三昧。我今入是三昧。我已入是三昧。是菩萨摩诃萨都无分别念。舍利弗问须菩提。菩萨摩诃萨住是诸三昧已。从过去佛授记耶。须菩提报言。不也。舍利弗。何以故。般若波罗蜜不异诸三昧。诸三昧不异般若波罗蜜。菩萨不异般若波罗蜜及三昧。般若波罗蜜及三昧。不异菩萨。般若波罗蜜即是三昧。三昧即是般若波罗蜜。菩萨即是般若波罗蜜及三昧。般若波罗蜜及三昧即是菩萨。舍利弗语须菩提。若三昧不异菩萨。菩萨不异三昧。三昧即是菩萨。菩萨即是三昧。菩萨云何知一切诸法等三昧。须菩提言。若菩萨入是三昧。是时不作是念。我以是法入是三昧。以是因缘故。舍利弗。是菩萨于诸三昧不知不念。舍利弗言。何以故不知不念。须菩提言。诸三昧无所有故。是故菩萨不知不念。尔时佛赞言。善哉善哉。须菩提。如我说汝行无诤三昧第一。与此义相应。菩萨摩诃萨应如是学般若波罗蜜。禅波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀波罗蜜。四念处乃至十八不共法。亦应如是学

【论】问曰。如佛说涅槃一道。所谓空无相无作。舍利弗何以更问有余三昧令菩萨疾得佛不。答曰。未近涅槃时多有余道。近涅槃时惟有一道。空无相无作。诸余三昧皆入此三解脱门。譬如大城多有诸门皆得入城。又如众川万流皆归于海。何等余三昧。所谓首楞严三昧等诸三昧。摩诃衍品中佛自说。有深难解者彼中当说。若菩萨能行是百八三昧等诸陀罗尼门。十方诸佛皆与授记。所以者何。是菩萨虽得是诸三昧。实无诸忆想分别我心故。亦不作是念。我当入是三昧今入已入。我当住是三昧是我三昧。以是心清净微妙法不着。故诸佛授记。尔时舍利弗还以空智慧难须菩提言。菩萨住是三昧取是三昧相得授记耶。须菩提言。不也。何以故。三事不异故。般若不异三昧。三昧不异般若。般若不异菩萨三昧。菩萨三昧不异般若。般若三昧即是菩萨。菩萨即是般若三昧。若三昧菩萨异者。诸佛授其记。不异故无授记。舍利弗复问。若尔者三昧及一切法平等不异。须菩提言。诸菩萨有诸法等三昧。入是三昧中诸法无异。复次如先说。于诸三昧不作忆想分别觉与不觉。诸三昧自性无所有故。菩萨不知不念。佛以须菩提自未得是三昧。而善说菩萨微妙三昧陀罗尼。般若波罗蜜中不念不着。是故赞言善哉。我说汝得无诤三昧第一。如我所赞不虚

【经】舍利弗白佛言。世尊。菩萨摩诃萨如是学为学般若波罗蜜耶。佛告舍利弗。菩萨摩诃萨如是学为学般若波罗蜜。是法不可得故。乃至学檀波罗蜜。是法亦不可得故。学四念处乃至学十八不共法。是法不可得故。舍利弗白佛言。世尊。如是菩萨摩诃萨学般若波罗蜜。是法不可得耶。佛言如是。菩萨摩诃萨学般若波罗蜜是法不可得。舍利弗言。世尊。何等法不可得。佛言。我不可得。乃至知者见者不可得。毕竟净故。五阴不可得。十二入不可得。十八界不可得。毕竟净故。无明不可得。毕竟净故。乃至老死不可得。毕竟净故。苦谛不可得。毕竟净故。集灭道谛不可得。毕竟净故。欲界不可得。毕竟净故。色界无色界不可得。毕竟净故。四念处不可得。毕竟净故。乃至十八不共法不可得。毕竟净故。六波罗蜜不可得。毕竟净故。须陀洹不可得。毕竟净故。斯陀含阿那含阿罗汉辟支佛不可得。毕竟净故。菩萨不可得。毕竟净故。佛不可得。毕竟净故。舍利弗白佛言。世尊。何等是毕竟净。佛言。不出不生无得无作。是名毕竟净。舍利弗白佛言。世尊。菩萨摩诃萨若如是学为学何等法。佛告舍利弗。菩萨摩诃萨如是学。于诸法无所学。何以故。舍利弗。诸法相不如凡夫所著。舍利弗白佛言。世尊。诸法实相云何有。佛言。诸法无所有。如是有如是无所有。是事不知名为无明。舍利弗白佛言。世尊。何等无所有是事不知名为无明。佛告舍利弗。色受想行识无所有。内空乃至无法有法空故。四念处乃至十八不共法无所有。内空乃至无法有法空故。是中凡夫以无明力渴爱故。妄见分别说是无明。是凡夫为二边所缚。是人不知不见诸法无所有。而忆想分别着色乃至十八不共法。是人着故。于无所有法而作识知见。是凡夫不知不见。何等不知不见。不知不见色。乃至十八不共法。亦不知不见。以是故堕凡夫数如小儿。是人不出。于何不出。不出欲界不出色界不出无色界声闻辟支佛法中不出。是人亦不信。不信何等。不信色空。乃至不信十八不共法空。是人不住。不住何等。不住檀波罗蜜。乃至不住般若波罗蜜。不住阿毗跋致地。乃至不住十八不共法。以是因缘故。名为凡夫如小儿。亦名著者。何等为着。着色乃至识。着眼入乃至意入。着眼界乃至意识界。着淫怒痴。着诸邪见。着四念处。乃至着佛道。舍利弗白佛言。世尊。若菩萨摩诃萨作如是学。亦不学般若波罗蜜。不得萨婆若。佛语舍利弗。菩萨摩诃萨作如是学。亦不学般若波罗蜜。不得萨婆若。舍利弗白佛言。世尊。何以故。菩萨摩诃萨亦不学般若波罗蜜。不得萨婆若。佛告舍利弗。菩萨摩诃萨无方便故。想念分别着般若波罗蜜。着禅波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀波罗蜜。乃至十八不共法一切种智随念分别着。以是因缘故。菩萨摩诃萨如是学。亦不学般若波罗蜜。不得萨婆若。舍利弗白佛言。世尊。若菩萨摩诃萨如是学。亦不学般若波罗蜜。不得萨婆若。佛告舍利弗。菩萨摩诃萨如是学不学般若波罗蜜。不得萨婆若。舍利弗白佛言。世尊。菩萨摩诃萨今云何应学般若波罗蜜得萨婆若。佛告舍利弗言。若菩萨摩诃萨学般若波罗蜜时。不见般若波罗蜜。舍利弗。菩萨摩诃萨如是学。学般若波罗蜜得萨婆若。以不可得故。舍利弗白佛言。世尊。云何名不可得。佛言。诸法内空乃至无法有法空故

【论】释曰。舍利弗上问。但无受三昧疾得佛。更有余三昧。须菩提说更有余三昧疾得佛。是菩萨不念不着是三昧。过去现在诸佛授记。佛赞言善哉。菩萨摩诃萨应如是学般若波罗蜜乃至一切佛法。是时舍利弗作是念。般若波罗蜜是空相。诸三昧种种分别相。云何学诸三昧。是为学般若波罗蜜是故问。佛答舍利弗。如是学般若波罗蜜。皆以不可得故。以般若波罗蜜气分相。皆在诸三昧中。能如是学。是为学般若波罗蜜乃至十八不共法。佛即可之。舍利弗复问。何等法不可得。佛此中自说。众生空故。毕竟清净故。我不可得。乃至知者见者。须陀洹乃至佛不可得。法空故。毕竟清净故。五众不可得。乃至十八不共法不可得。毕竟清净者。不出不生不得不作等。因边不起故名为不出。缘边不起故名为不生。定生相不可得故名为不出不生。不出不生故名不可得。不可得故名无作无起。是起作法皆是虚诳离如是相名毕竟清净。舍利弗问佛。菩萨能如是行毕竟真净道。为学何法为得何法。佛答。能如是学为无所学无所得。问曰。菩萨用是毕竟空。学六波罗蜜乃至十八不共法。云何言无法可学。答曰。此中佛自说诸法。不如凡夫所著。凡夫人心有无明邪见等结使。所闻所见所知皆异法相。乃至闻佛说法。于圣道中果报中皆着污染于道。舍利弗白佛言。若凡夫人所见皆是不实。今是诸法云何有。佛言诸法无所有。凡夫人于无所有处亦以为有。所以者何。是凡夫人离无明邪见不能有所观。以是故说着无所有故名为无明。譬如空拳以诳小儿。小儿着故谓以为有。舍利弗问佛。何等法无所有着故名无明。佛答。色乃至十八不共法。是中无明爱故。忆想分别是明是无明。堕有边无边失智慧明。失智慧明故。不见不知色毕竟空无所有相。自生忆想分别。而着乃至识众十二入十八界十二因缘。或闻善法。所谓六波罗蜜乃至十八不共法。亦如世间法忆想分别着圣法亦如是。以是故名堕凡夫数如小儿为人轻笑。如人以指示月。愚者但看指不看月。智者轻笑言。汝何不得示者意。指为知月因缘。而更看指不知月。诸佛贤圣为凡夫人说法。而凡夫着音声语言。不取圣人意不得实义。不得实义故。还于实中生着。佛今说凡夫所失故。言不能过三界。亦不能离二乘。不得圣人意故。闻说诸法空而不信。不信故不行。不住六波罗蜜乃至十八不共法。以失如是功德故。名为凡夫小儿。是小儿着五众十二入十八界三毒诸烦恼。乃至六波罗蜜十八不共法。阿耨多罗三藐三菩提皆着。是故名为著者。舍利弗问。若菩萨如是行是名不行般若波罗蜜。不行般若波罗蜜不得萨婆若。佛可舍利弗言如是如是。即为说因缘。所谓新行菩萨无方便力。闻是般若波罗蜜。忆想分别寻求欲取。作是念。我舍世间乐复不能得般若波罗蜜。是为两失。专求欲得。或谓说空是般若波罗蜜。或说空亦空是般若波罗蜜。或说诸法如实相是般若波罗蜜。如是用六十二见九十八使烦恼心。着是般若波罗蜜。乃至一切种智亦如是。以是着心学诸法不能得萨婆若。与此相违者能行般若波罗蜜。亦能得萨婆若。所谓不见般若波罗蜜。不见行者不见缘法。不见亦不见。舍利弗更问不见因缘。佛答。是菩萨入十八空故不见。非以无智故不见。

大智度论卷第四十三大智度论释幻人无作品第十一(卷第四十四)

        龙树菩萨造

        后秦龟兹国鸠摩罗什奉　诏译

【经】尔时慧命须菩提白佛言。世尊。若当有人问言。幻人学般若波罗蜜当得萨婆若不。幻人学禅波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀波罗蜜。学四念处乃至十八不共法及一切种智。得萨婆若不。我当云何答

佛告须菩提。我还问汝。随汝意答我。须菩提。于汝意云何。色与幻有异不。受想行识与幻有异不。须菩提言。不也世尊。佛言。于汝意云何。眼与幻有异不。乃至意与幻有异不。色乃至法与幻有异不。眼界乃至意识界与幻有异不。眼触乃至意触。眼触因缘生受乃至意触因缘生受与幻有异不。须菩提言。不也世尊。于汝意云何。四念处与幻有异不。乃至八圣道分与幻有异不。不也世尊。于汝意云何。空无相无作与幻有异不。不也世尊。须菩提。于汝意云何。檀波罗蜜与幻有异不。乃至十八不共法与幻有异不。不也世尊。须菩提。于汝意云何。阿耨多罗三藐三菩提与幻有异不。不也世尊。何以故。色不异幻幻不异色。色即是幻幻即是色。世尊。受想行识不异幻。幻不异受想行识。识即是幻幻即是识。世尊。眼不异幻幻不异眼。眼即是幻幻即是眼。眼触因缘生受乃至意触因缘生受亦如是。世尊。四念处不异幻幻不异四念处。四念处即是幻幻即是四念处。乃至阿耨多罗三藐三菩提不异幻。幻不异阿耨多罗三藐三菩提。阿耨多罗三藐三菩提即是幻。幻即是阿耨多罗三藐三菩提。佛告须菩提。于汝意云何。幻有垢有净不。不也世尊。须菩提。于汝意云何。幻有生有灭不。不也世尊。若法不生不灭。是法能学般若波罗蜜当得萨婆若不。不也世尊。于汝意云何。五受阴假名是菩萨不。如是世尊。于汝意云何。五受阴假名有生灭垢净不。不也世尊。于汝意云何。若法但有名字非身非身业。非口非口业。非意非意业。不生不灭不垢不净。如是法能学般若波罗蜜得萨婆若不。不也世尊。菩萨摩诃萨若能如是学般若波罗蜜。当得萨婆若。以无所得故。须菩提白佛言。世尊。菩萨摩诃萨应如是学般若波罗蜜。得阿耨多罗三藐三菩提如幻人学。何以故。世尊。当知五阴即是幻人。幻人即是五阴。佛告须菩提。于汝意云何。是五阴学般若波罗蜜当得萨婆若不。不也世尊。何以故。是五阴性无所有。无所有性亦不可得。佛告须菩提。于汝意云何。如梦五阴学般若波罗蜜。当得萨婆若不。不也世尊。何以故。梦性无所有。无所有性亦不可得。于汝意云何。如响如影如焰如化。五众学般若波罗蜜当得萨婆若不。不也世尊。何以故。响影焰化性无所有。无所有性亦不可得。六情亦如是。世尊。识即是六情。六情即是五众。是法皆内空故不可得。乃至无法有法空故不可得

【论】问曰。须菩提何以故以是事问佛。若人问幻人学般若波罗蜜得作佛不。应答言不得。幻人虚诳无有本末。是事易答。何以故问佛。答曰。上品佛答舍利弗甚深空义。须菩提作是念。诸法一相无分别。若尔者幻人及实菩萨无异。而菩萨行诸功德得作佛。幻人无实但诳人眼不能作佛。问曰。幻人不能行功德。以无心识云何言行。答曰。虽实不行人见似行故名为行。如幻人以饮食财物七宝布施出家。持戒忍辱精进坐禅说法等。无智人谓是为行不知是幻。须菩提作是念。若如佛说诸法一相无所有但是虚诳。幻人及实菩萨乃至佛等无有异。如幻人亦幻作佛行六波罗蜜。降魔兵坐道场。成佛道放光明说法度人。实菩萨行实道得作佛度众生有何差别。佛言我还问汝随汝意答我。问曰。佛何以不直答。而还问令随意答。答曰。须菩提以空智慧观三界五众皆空。心生厌离诸烦恼习故。虽能总相知诸佛法空。犹有所贵。不能观佛法如幻无所有。以是故方喻说。如汝以五众空为证。诸佛法亦尔。汝观世间五众为空。我观佛法亦尔。是故问须菩提于汝意云何。色与幻有异不。幻与色有异不。乃至受想行识亦如是。若异者汝应问。若不异不应作是问。须菩提言不异。问曰。若色不异幻可尔。幻人有色故云何言受想行识如幻不异。答曰。幻人有喜乐忧苦相。无智人见谓为有受想行识。复次佛譬喻欲令人知五受众虚诳如幻。五受众虽与幻无异。佛欲令解故为作譬喻。众生谓幻是虚诳五受众虽有与幻无异。是故须菩提一心筹量知五众与幻无异。所以者何。如幻人色诳肉眼能令生忧喜苦乐。五受众亦能诳慧眼。令生贪欲嗔恼诸烦恼等。如幻因少许咒术物事语言为本。能现种种事城郭庐观等。五受众亦以先世少许无明术因缘。有诸行识名色等种种。以是故说不异。如人见幻事生着心。废其生业。幻灭时生悔。五受众亦如是。先业因缘幻生今五众。受五欲生贪嗔。无常坏时心乃生悔。我云何着是幻五众失诸法实相。佛问须菩提乐说门故答言幻与色不异。若不异是色法即是空入不生不灭法中。法若不生不灭。云何行般若波罗蜜得作佛。须菩提作是念。若尔者菩萨何以故。种种行道。求阿耨多罗三藐三菩提。佛知其念即答。五众虚诳但以假名故号为菩萨。是假名中无业无业因缘。无心无心数法。无垢无净毕竟空故。佛言。菩萨应如幻人行般若波罗蜜。五众即是幻人无异。从先世业因缘幻业出故。是五众亦不能得成就佛。何以故。性无所有故。余梦化影响等亦如是。问曰。何以故说识即是六情六情即是五众。答曰。是识十二因缘中第三事。是中亦有色亦有心数法未熟故受识名。从识生六入。是二时俱有五众。色成故名五情。名成故名意情。六情不离五众。以是故说识即是六情。问曰。若尔者十二因缘中处处皆有五众。何以但说六情有五众。答曰。是识今身之本。众生于现在法中多错。名色未熟未有所能故不说。六情受苦乐能生罪福故说。其余十一因缘故说五众。复次佛知五百岁后学者分别诸法相各异。离色法说识。离识法说色。欲破是诸见令入毕竟空故。识中虽无五情。而说识即是六情。六情中虽不具五众。而说六情即是五众。复次先世但有心住六情。作种种忆想分别故。生今世六情五众身。从今世身起种种结使。造后世六情五众。如是等展转。是故说识即是六情六情即是五众。是法内空中不可得。乃至无法有法空中不可得

【经】须菩提白佛言。世尊。新发大乘意菩萨闻说般若波罗蜜。将无惊怖畏。佛告须菩提。若新发大乘意菩萨。于般若波罗蜜无方便。亦不得善知识。是菩萨或惊或怖或畏。须菩提白佛言。世尊。何等是方便。菩萨行是方便不惊不畏不怖。佛告须菩提。有菩萨摩诃萨。行般若波罗蜜应萨婆若心。观色无常相是亦不可得。观受想行识无常相是亦不可得。须菩提。是名菩萨摩诃萨行般若波罗蜜中方便。复次须菩提。菩萨摩诃萨应萨婆若心。观色苦相是亦不可得。受想行识亦如是。应萨婆若心。观色无我相是亦不可得。受想行识亦如是。复次须菩提。菩萨摩诃萨应萨婆若心。观色空相是亦不可得。受想行识亦如是。观色无相相是亦不可得。受想行识亦如是。观色无作相是亦不可得。受想行识亦如是。观色寂灭相是亦不可得。乃至识亦如是。观色离相是亦不可得。乃至识亦如是。是名菩萨摩诃萨行般若波罗蜜中方便。复次须菩提。菩萨摩诃萨行般若波罗蜜。观色无常相是亦不可得。观色苦相无我相空相无相相无作相寂灭相离相。是亦不可得。受想行识亦如是。是时菩萨作是念。我当为一切众生说是无常法是亦不可得。当为一切众生说苦相无我相空相无相相无作相寂灭相离相。是亦不可得。是名菩萨摩诃萨檀波罗蜜。复次须菩提。菩萨摩诃萨不以声闻辟支佛心观色无常亦不可得。不以声闻辟支佛心观识无常亦不可得。不以声闻辟支佛心观色苦无我空无相无作寂灭离亦不可得。受想行识亦如是。是名菩萨摩诃萨尸罗波罗蜜。复次须菩提。菩萨摩诃萨行般若波罗蜜。是诸法无常相乃至离想忍欲乐。是名菩萨摩诃萨羼提波罗蜜。复次须菩提。菩萨摩诃萨行般若波罗蜜。应萨婆若心。观色无常相亦不可得。乃至离相亦不可得。受想行识亦如是。应萨婆若心不舍不息。是名菩萨摩诃萨毗梨耶波罗蜜。复次须菩提。菩萨摩诃萨行般若波罗蜜。不起声闻辟支佛意及余不善心。是名菩萨摩诃萨禅波罗蜜。复次须菩提。菩萨摩诃萨行般若波罗蜜。如是思惟。不以空色故色空。色即是空空即是色。受想行识亦如是。不以空眼故眼空。眼即是空空即是眼。乃至意触因缘生受。不以空受故受空。受即是空空即是受。不以空四念处故四念处空。四念处即是空。空即是四念处。乃至不以空十八不共法故十八不共法空。十八不共法即是空。空即是十八不共法。如是须菩提。菩萨摩诃萨行般若波罗蜜。不惊不畏不怖。须菩提白佛言。世尊。何等是菩萨摩诃萨善知识守护故。闻说是般若波罗蜜。不惊不畏不怖。佛告须菩提。菩萨摩诃萨善知识者。说色无常亦不可得。持是善根不向声闻辟支佛道。但向一切智。是名菩萨摩诃萨善知识。说受想行识无常亦不可得。持是善根不向声闻辟支佛道。但向一切智。是名菩萨摩诃萨善知识。须菩提。菩萨摩诃萨复有善知识。说色苦亦不可得。说受想行识苦亦不可得。说色无我亦不可得。受想行识无我亦不可得。说色空无相无作寂灭离亦不可得。受想行识空无相无作寂灭离亦不可得。持是善根不向声闻辟支佛道。但向一切智。须菩提。是名菩萨摩诃萨善知识。须菩提。菩萨摩诃萨复有善知识。说眼无常乃至离亦不可得。乃至意触因缘生受。说无常乃至离亦不可得。持是善根不向声闻辟支佛道。但向一切智。是名菩萨摩诃萨善知识。须菩提。菩萨摩诃萨复有善知识。说修四念处法乃至离亦不可得。持是善根不向声闻辟支佛道。但向一切智。须菩提。是名菩萨摩诃萨善知识。乃至说修十八不共法修一切智亦不可得。持是善根不向声闻辟支佛道。但向一切智。是名菩萨摩诃萨善知识

【论】问曰。须菩提何以生此疑问。佛言。新发意菩萨闻是将无恐怖。答曰。闻无有菩萨行般若波罗蜜者。但空五众法。亦不能行般若波罗蜜。以是故生疑。谁当行般若波罗蜜。是故问佛。佛言若菩萨内外因缘不具足当有恐怖。内因缘者。无正忆念无利智慧。于众生中无深悲心。内无如是等方便。外因缘者。不生中国土。不得闻般若波罗蜜。不得善知识能断疑者。无如是等外因缘。内外因缘不和合故生惊怖畏。今须菩提问是方便。佛答。一切种智相应心观诸法亦不得诸法。问曰。方便有观色无常等种种相故不怖畏。今何以但说萨婆若相应心观诸法故不恐不怖。答曰。菩萨先来但观诸法空。心粗故生着。今忆想分别观如佛意。于众生中起大悲不着一切法。于智慧无所碍。但欲度众生。以无常空等种种观诸法。亦不得是法。如是观诸法已作是念。我以是法度众生令离颠倒。以是故心不着。不见定实有一法。譬如药师和合诸药。冷病者与热药。于热病中为非药。二施中法施大故。是名檀波罗蜜。五波罗蜜亦如是随义分别。复次菩萨方便者。非十八空故令色空。何以故。不以是空相强令空故。色即是空。是色从本已来常自空。色相空故。空即是色。乃至诸佛法亦如是。善知识者。教人令以是智慧回向阿耨多罗三藐三菩提。菩萨先知无常空等诸观。今惟说回向为异

【经】须菩提白佛言。世尊。云何菩萨摩诃萨行般若波罗蜜无方便。随恶知识闻说是般若波罗蜜惊怖畏。佛告须菩提。菩萨摩诃萨离一切智心。修般若波罗蜜。得是般若波罗蜜。念是般若波罗蜜。禅波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀波罗蜜。皆得皆念。复次须菩提。菩萨摩诃萨离萨婆若心。观色内空乃至无法有法空。观受想行识内空乃至无法有法空。观眼内空乃至无法有法空。乃至观意触因缘生受内空乃至无法有法空。于诸法空有所念有所得。复次须菩提。菩萨摩诃萨行般若波罗蜜。离萨婆若心修四念处亦念亦得。乃至修十八不共法亦念亦得。如是须菩提。菩萨摩诃萨行般若波罗蜜。以无方便故。闻是般若波罗蜜惊怖畏。须菩提白佛言。世尊。云何菩萨摩诃萨随恶知识闻般若波罗蜜惊怖畏。佛告须菩提。菩萨摩诃萨恶知识教离般若波罗蜜。离禅波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀波罗蜜。须菩提。是名菩萨摩诃萨恶知识。须菩提。菩萨摩诃萨复有恶知识。不说魔事不说魔罪。不作是言。恶魔作佛形像来教菩萨离六波罗蜜。语菩萨言。善男子。用修般若波罗蜜为。用修禅波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀波罗蜜为。当知是菩萨摩诃萨恶知识。复次须菩提。恶魔复作佛形像。到菩萨所为说声闻经。若修妒路乃至优波提舍。教诏分别演说如是经。终不为说魔事魔罪。当知是菩萨摩诃萨恶知识。复次须菩提。恶魔作佛形像到菩萨所作是语。善男子。汝无真菩萨心。亦非阿毗跋致地。汝亦不能得阿耨多罗三藐三菩提。不为说如是魔事魔罪。当知是菩萨恶知识。复次须菩提。恶魔作佛形像到菩萨所语菩萨言。善男子。色空无我无我所。受想行识空无我无我所。眼空无我无我所。乃至意触因缘生受空无我无我所。檀波罗蜜空乃至般若波罗蜜空。四念处空乃至十八不共法空。汝用阿耨多罗三藐三菩提为。如是魔事魔罪不说不教。当知是菩萨恶知识。复次须菩提。恶魔作辟支佛身。到菩萨所语菩萨言。善男子。十方皆空是中无佛无菩萨无声闻。如是魔事魔罪不说不教。当知是菩萨摩诃萨恶知识。复次须菩提。恶魔作和尚阿阇梨身。到菩萨所。教离菩萨道。教离一切种智。教离四念处乃至八圣道分。教离檀波罗蜜。乃至教离十八不共法。教入空无相无作。作是言。善男子。汝修念是诸法得声闻证。用阿耨多罗三藐三菩提为。如是魔事魔罪不说不教。当知是菩萨恶知识。复次须菩提。恶魔作父母形像。到菩萨所语菩萨言。子汝为须陀洹果证故勤精进。乃至阿罗汉果证故勤精进。汝用阿耨多罗三藐三菩提为。求阿耨多罗三藐三菩提。当受无量阿僧祇劫生死截手截脚受诸苦痛。如是魔事魔罪不说不教。当知是菩萨恶知识。复次须菩提。恶魔作比丘形像。到菩萨所语菩萨言。眼无常可得法乃至意无常可得法。眼苦眼无我眼空无相无作寂灭离说可得法。乃至意亦如是。用有所得法说四念处。乃至用有所得法说佛十八不共法。须菩提。如是魔事魔罪不教不说。当知是菩萨恶知识。知已当远离之

【论】释曰。先略说无方便。今欲广说无方便。所谓离一切种智相应心。行般若波罗蜜。取是般若波罗蜜定相。五波罗蜜乃至诸佛法亦如是。是自无方便又得恶知识教故。复次恶知识大失利益种种坏人。是大恶因缘故。佛更种种因缘说恶知识相。恶知识者教人远离六波罗蜜。或不信罪福报故教远离。或着般若波罗蜜故言诸法毕竟空。汝何所行。或赞叹小乘。汝但自免老病死苦。众生何豫汝事。如是等种种因缘教令远离。是名恶知识。复次恶知识者。不教弟子令觉知魔是佛贼。魔者欲界主有大力势常憎行道者。佛威力大故魔无所能。但能坏小菩萨。乃至作佛形像来坏菩萨行六波罗蜜。或赞叹开解论说。随声闻所应学经法。或作佛身来语之言。汝不任得佛。或说眼等一切诸法空。何用是阿耨多罗三藐三菩提为。或作辟支佛身。或说十方世界中三乘人空。求佛道者但有空名。汝云何欲作佛。或教令远离菩萨三十七品。令入声闻三解脱门中。汝入是三门实际作证得尽众苦。汝勤精进汝为得四果故。何用阿耨多罗三藐三菩提为。或作和尚阿阇梨父母来教令远离佛道。空当受是截手脚耳鼻等以与求者。若不与则破求佛意。若与则受是辛苦。或时作阿罗汉比丘被服来为说。眼是定无常相苦空无我相无作寂灭离。乃至诸佛法亦如是用有所得取相忆念分别说。如是等种种无量魔事不教令觉知。是为恶知识。远离者以其无利益。如软语贼转来亲近近则害人。恶知识复过于是。所以者何。是贼但能害今世一身。恶知识则世世害人。贼但能害命夺财。恶知识则害慧念命根夺佛法无量宝。知已急当身心远离

    大智度论释句义品第十二

【经】尔时须菩提白佛言。世尊。云何为菩萨句义。佛告须菩提。无句义是菩萨句义。何以故。阿耨多罗三藐三菩提中。无有义处亦无我。以是故无句义是菩萨句义。须菩提。譬如鸟飞虚空无有足迹。菩萨句义无所有亦如是。须菩提。譬如梦中所见无处所。菩萨句义无所有亦如是。须菩提。譬如幻无有实义。如焰如响如影如佛所化无有实义。菩萨句义无所有亦如是。须菩提。譬如如法性法相法位实际无有义。菩萨句义无所有亦如是。须菩提。譬如幻人色无有义。幻人受想行识无有义。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。如幻人眼无有义。乃至意无有义。须菩提。如幻人色无有义。乃至法无有义。眼触乃至意触因缘生受无有义。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。如幻人行内空时无有义。乃至行无法有法空无有义。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。如幻人行四念处。乃至十八不共法无有义。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。如多陀阿伽度阿罗诃三藐三佛陀色无有义。是色无有故。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。如多陀阿伽度阿罗诃三藐三佛陀受想行识无有义。是识无有故。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。如佛眼无处所。乃至意无处所。色乃至法无处所。眼触乃至意触因缘生受无处所。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。如佛内空无处所。乃至无法有法空无处所。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。如佛四念处无处所。乃至十八不共法无处所。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。如有为性中无无为性义。无为性中无有为性义。菩萨摩诃萨。行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。如不生不灭义无处所。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。如不作不出不得不垢不净无处所。菩萨句义无所有亦如是。须菩提白佛言。何法不生不灭故无处所。何法不作不出不得不垢不净故无处所。佛告须菩提。色不生不灭故无处所。受想行识不生不灭故无处所。乃至不垢不净亦如是。入界不生不灭故无处所。乃至不垢不净亦如是。四念处不生不灭故无处所。乃至不垢不净亦如是。乃至十八不共法不生不灭故无处所。乃至不垢不净亦如是。须菩提。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。如四念处净义毕竟不可得。须菩提。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。如四正勤乃至十八不共法净义毕竟不可得。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。如净中我不可得。我无所有故。乃至净中知者见者不可得。知见无所有故。须菩提。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。譬如日出时无有黑闇。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。譬如劫烧时无一切物。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。佛戒中无破戒。须菩提。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。如佛定中无乱心。佛慧中无有愚痴。佛解脱中无不解脱解脱知见中无不解脱知见。须菩提。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。须菩提。譬如佛光中日月光不现。佛光中四天王天三十三天夜磨天兜率陀天化乐天他化自在天。梵众天乃至阿迦尼吒天光不现。须菩提。菩萨摩诃萨行般若波罗蜜时。菩萨句义无所有亦如是。何以故。是阿耨多罗三藐三菩提菩萨菩萨句义。是一切法皆不合不散。无色无形无对一相。所谓无相。如是须菩提。菩萨摩诃萨一切法无碍相中。应当学亦应当知

【论】问曰。上来佛与须菩提种种因缘破菩萨字。今何以问菩萨句义。答曰须菩提破菩萨字佛不破。言菩萨字从本已来毕竟空。但五众中数假名菩萨。而众生以假名为实。佛言假名无实但从诸法数和合为名。复次诸佛法无量无边不可思议。须菩提因菩萨字空说般若波罗蜜相。今欲闻佛说菩萨字义。因是说般若波罗蜜。复次应问因缘无量无边。所谓佛音声有六十种庄严。能令诸天专听。何况人。但音声令人乐闻。何况说大利益义。须菩提从佛闻是事。未发意人当发阿耨多罗三藐三菩提。发意者未行六波罗蜜当令行。行者不清净当令清净。清净行者当令住阿鞞跋致地。成就众生具足佛法。乃至一生补处。如是等种种无量因缘利益故。佛以须菩提为问主。语一切十方世界在会众生。佛告须菩提。无句义是菩萨句义。阿耨多罗三藐三菩提。无处所亦无我无名。于是中无依止处即是法空。无我名者无得道者。佛谓须菩提若汝知无我无我所。得阿罗汉者。菩萨亦如是。于阿耨多罗三藐三菩提中无我无我所。譬如鸟飞虚空无有足迹。菩萨句义亦如是。行诸法虚空中无依止着处。以是故言无菩萨句义。问曰。何等是菩萨句义。答曰。天竺语法众字和合成语。众语和合成句。如菩为一字提为一字。是二不合则无语。若和合名为菩提。秦言无上智慧。萨埵或名众生。或是大心。为无上智慧故出大心名为菩提萨埵。愿欲令众生行无上道。是名菩提萨埵。复次此品佛及佛弟子。种种因缘说菩萨摩诃萨义。菩提一语萨埵一语。二语和合故名为义。若说名字语句皆同一事无所在。今须菩提问以何定相法为菩萨句义。天竺言波陀。秦言句。是波陀有种种义。如后譬喻中说。问曰。但以鸟飞虚空足明句义。何以种种广说。答曰。众生听受种种不同。有好义者。有好譬喻者。譬喻可以解义。因譬喻心则乐着。如人从生端政加以严饰益其光荣。此譬喻中多以譬喻明义如后所说。所谓如梦如影如响如佛所化。是事虚诳如先说菩萨义亦如是。但可耳闻虚诳无实。以是故菩萨不应自高。如法性法相实际等句无有定义。如幻人无五众乃至诸佛法。如佛无五众乃至一切法。如有为法中无无为法。如无为法中无有为法。无为法不生不灭等。诸法中无不生不灭相亦无异相。如三十七品无清净相。何以故。有人着是三十七品法。即是结使。如我乃至知者见者净相不可得。问曰。我乃至知者见者等云何净。答曰。种种求觅我相不可得。是名我净第一义中无净无不净。譬如洗臭死狗乃至皮毛血肉骨髓都尽。是时非狗非猪。不得言净不得言不净。我乃至知者见者亦如是。以无我空智慧求我相不可得是时非有我非无我。如日出无闇劫尽时无一切物。如佛五众戒中破戒不可得。如日月星宿真珠等诸天鬼神龙王光。于佛光中则不现。从大福德神通力生故。菩萨句义亦如是。入是般若波罗蜜智慧光中则不现。因是譬喻教诸菩萨当学一切法不取相。无所得故

【经】须菩提白佛言。世尊。何等是一切法。云何一切法中无碍相应学应知。佛告须菩提。一切法者。善法不善法记法无记法世间法出世间法有漏法无漏法有为法无为法共法不共法。须菩提。是名为一切法。菩萨摩诃萨是一切法无碍相中应学应知。须菩提白佛言。世尊。何等名世间善法。佛告须菩提。世间善法者。孝顺父母。供养沙门婆罗门。敬事尊长。布施福处。持戒福处。修定福处。劝导福事。方便生福德。世间十善道。九相。胀相血相坏相脓烂相青相啖相散相骨相烧相。四禅四无量心四无色定。念佛念法念僧念戒念舍念天念善念安般念身念死。是名世间善法。何等不善法。夺他命。不与取。邪淫。妄语。两舌。恶口。非时语。贪欲。恼害。邪见。是十不善道等。是名不善法。何等记法。若善法若不善法。是名记法。何等无记法。无记身业口业意业。无记四大。无记五众十二入十八界。无记报。是名无记法。何等名世间法。世间法者。五众十二入十八界十善道。四禅四无量心四无色定。是名世间法。何等名出世间法。四念处四正勤四如意足五根五力七觉分八圣道分。空解脱门无相解脱门无作解脱门。三无漏根。未知欲知根。知根。知已根。三三昧有觉有观三昧无觉有观三昧无觉无观三昧。明解脱念慧正忆八背舍。何等八。色观色。是初背舍。内无色相外观色。是二背舍。净背舍身作证。是三背舍。过一切色相故。灭有对相故。一切异相不念故。入无边虚空处。是四背舍。过一切无边虚空处入一切无边识处。是五背舍。过一切无边识处入无所有处。是六背舍。过一切无所有处入非有想非无想处。是七背舍。过一切非有想非无想处入灭受想定。是八背舍。九次第定。何等九。离欲离恶不善法。有觉有观离生喜乐入初禅。灭诸觉观内清净故。一心无觉无观定生喜乐入第二禅。离喜故行舍受身乐圣人能说能舍念行乐入第三禅。断苦乐故先灭忧喜故。不苦不乐舍念净入第四禅。过一切色相故。灭有对相故。一切异相不念故。入无边虚空处。过一切无边虚空处入一切无边识处。过一切无边识处入无所有处。过一切无所有处入非有想非无想处。过一切非有想非无想处入灭受想定。复有出世间法。内空乃至无法有法空。佛十力四无所畏四无碍智十八不共法一切智。是名出世间法。何等为有漏法。五受众十二入十八界六种六触六受四禅乃至四无色定。是名有漏法。何等为无漏法。四念处乃至十八不共法。及一切种智。是名无漏法。何等为有为法。若法生住灭。欲界色界无色界。五众乃至意触因缘生受。四念处乃至十八不共法及一切智。是名有为法。何等为无为法。不生不住不灭。若染尽嗔尽痴尽如不异。法相法性法住实际。是名无为法。何等为共法。四禅四无量心四无色定。如是等是名共法。何等为不共法。四念处乃至十八不共法。是名不共法。菩萨摩诃萨于是自相空法中不应着。不动故。菩萨亦应知一切法不二相。不动故。是名菩萨义

【论】问曰。须菩提何以故。先问世间善法。后问出世间法。答曰。先问粗后当问细。先知世间相后则能知出世间相。世间善法者。知有罪有福果报有今世后世。有世间有涅槃。有佛等诸贤圣今世后世及诸法实相证。所谓孝顺父母等。乃至十念如法得物。供养供给沙门婆罗门。沙门名为出家求道人。婆罗门名为在家学问人。是二人于世间难为能为。利益众生故应当供养。尊长者叔伯姊兄等。恭敬供养。是一切修家法。布施持戒修定劝导如初品中说。方便生福德。如忏悔随喜请佛久住不涅槃转法轮。如虽行空不着空还修行诸善。如是等方便生诸福德。十善道乃至四无色如先说。十念中八事如先说。善念者。思惟分别善业因缘制伏其心。复次涅槃是真善法。常系心念涅槃。是善念身念即是身念处。与善法相违是名不善法。无记法者。所谓威仪心。工巧心。变化心。及是起身业口业除善不善五众。余五众及虚空非数缘灭等。世间法者。五众或善或不善或无记。十二入八无记四三种。十八界八无记十三种。十善道四禅四无量心四无色定。是善法。凡夫人能得能成就故。又自不能出世间故名为世间法。出世间法者。三十七品三解脱门三无漏根三三昧如先说。明解脱。明者三明。解脱者有为解脱无为解脱。念者十念。慧者十一智慧。正忆者。随诸法实相观。如随身法观一切善法之本。复次八背舍九次第定十八空。十力四无所畏十八不共法。如先义中广说。是四念处等一心为道故。又八背舍九次第定等。凡夫人所不得。名为出世间。念慧正忆虽有二种世间出世间。此中说出世间有漏法者。五众等四禅四无量四无色定。无漏法者。非世间。是四念处乃至十八不共法。有为法略说三相。所谓生住灭。三界系乃至四念处乃至十八不共法。虽为无为法。以作法故是为有为法。与有为相违。是为无为法。复次灭三毒等诸烦恼。五众等不次第相续。如法相法性法住实际等。是名无为法。问曰。色如色不离如如不离色。色是有为云何是无为。答曰。色有二种。一者凡夫肉眼忆想分别色。二者圣人心所知色。实相如涅槃。凡夫人所知色名为色。是色入如中更不生不灭。如有为虽是五众。而有种种名字。所谓十二入十八界因缘等。无为法虽有三种。亦种种分别名字。所谓如法相法住实际等。共法者。凡夫圣人生处入定处共故。名为共法。不共法者。四念处乃至十八不共法。菩萨分别知此诸法各各相。是法皆从因缘和合生故无性。无性故自性空。菩萨住是无障碍法中不动。以不二入法门。入一切法不动故

大智度论卷第四十四大智度论释摩诃萨品第十三(卷四十五)

        龙树菩萨造

        后秦龟兹国三藏鸠摩罗什译

【经】尔时须菩提白佛言。世尊。何以故。名为摩诃萨。佛告须菩提。是菩萨于毕定众中为上首。是故名为摩诃萨。须菩提白佛言。世尊。何等为毕定众。是菩萨摩诃萨而为上首。佛告须菩提。毕定众者。性地人八人。须陀洹斯陀含阿那含阿罗汉辟支佛。初发心菩萨乃至阿鞞跋致地菩萨。须菩提。是为毕定众。菩萨为上首。菩萨摩诃萨于是中生大心。不可坏如金刚。当为毕定众作上首。须菩提白佛言。世尊。何等是菩萨摩诃萨生大心不可坏如金刚。佛告须菩提。菩萨摩诃萨应生如是心。我当于无量生死中大誓。庄严。我应当舍一切所有。我应当等心于一切众生。我应当以三乘度脱一切众生令入无余涅槃。我度一切众生已。无有乃至一人入涅槃者。我应当解一切诸法不生相。我应当纯以萨婆若心行六波罗蜜。我应当学智慧了达一切法。我应当了达诸法一相智门。我应当了达乃至无量相智门。须菩提是名菩萨摩诃萨生大心不可坏如金刚。是菩萨摩诃萨住是心中。于诸毕定众中而为上首。是法用无所得故。须菩提。菩萨摩诃萨应生如是心。我当代十方一切众生若地狱众生若畜生众生若饿鬼众生受诸苦痛。为一一众生。无量百千亿劫代受地狱中苦。乃至是众生入无余涅槃。以是法故。为是众生受诸勤苦。是众生入无余涅槃已。然后自种善根。无量百千万亿阿僧祇劫。当得阿耨多罗三藐三菩提。须菩提。是为菩萨摩诃萨大心不可坏如金刚。住是心中为毕定众作上首。复次须菩提。菩萨摩诃萨生大快心。住是大快心中为毕定众作上首。须菩提白佛言。世尊。何等是菩萨摩诃萨大快心。佛言。菩萨摩诃萨从初发意。乃至阿耨多罗三藐三菩提。不生染心嗔恚心愚痴心。不生恼心。不生声闻辟支佛心。是名菩萨摩诃萨大快心。住是心中为毕定众作上首。亦不念有是心。复次须菩提。菩萨摩诃萨应生不动心。须菩提白佛言。云何名不动心。佛言。常念一切种智心。亦不念有是心。是名菩萨摩诃萨不动心。复次须菩提。菩萨摩诃萨于一切众生中。应生利益安乐心。云何名利益安乐心。救济一切众生不舍一切众生。是事亦不念有是心。是名菩萨摩诃萨于一切众生中生利益安乐心。如是须菩提。是菩萨摩诃萨行般若波罗蜜。于毕定众中最为上首。复次须菩提。菩萨摩诃萨应当行欲法喜法乐法心。何等是法。所谓不破诸法实相。是名为法何等名欲法喜法。信法忍法受法。是名欲法喜法。何等名乐法。常修行是法。是名乐法。如是须菩提。菩萨摩诃萨行般若波罗蜜于毕定众中能为上首。是法用无所得故。复次须菩提。菩萨摩诃萨行般若波罗蜜时。住内空乃至无法有法空。能为毕定众作上首。是法用无所得故。复次须菩提。菩萨摩诃萨行般若波罗蜜时。住四念处中。乃至住十八不共法中。能为毕定众作上首。是法用无所得故。复次须菩提。菩萨摩诃萨行般若波罗蜜时。住如金刚三昧乃至离着虚空不染三昧中。住于毕定众作上首。是法用无所得故。如是须菩提。菩萨摩诃萨住是诸法中。能为毕定众作上首。以是因缘故名为摩诃萨

【论】释曰须菩提已从佛闻菩萨义。今问摩诃萨义。摩诃者秦言大。萨埵秦言心。或言众生。是众生于世间诸众生中第一最上。故名为大。又以大心知一切法欲度一切众生。是名为大。复次菩萨故名摩诃萨。摩诃萨故名菩萨。以发心为无上道故。复次如赞菩萨摩诃萨义品中。此中应广说。复次佛此中自说摩诃萨义。众生有三分。一者正定必入涅槃。二者邪定必入恶道。三者不定。于正定众生中当最大故名摩诃萨。大众者。除佛余一切贤圣。所谓性地人是圣人性中生。故名为性。如小儿在贵家生。虽小未有所能。后必望成大事。是地从暖法乃至世间第一法八人。名见谛道。十五心中行。问曰。是十五心中何以名为八人。答曰。思惟道中用智多。见谛道中多用见。忍智随于忍。所以者何。忍功大故。复次忍智二事能断能证八忍中住。故名为八人。须陀洹斯陀含阿那含阿罗汉辟支佛义如先说。初发意菩萨者。有人言。初发意者。得无生法忍。随阿耨多罗三藐三菩提相发心。是名初发意名真发心。了了知诸法实相。及知心相破诸烦恼故。随阿耨多罗三藐三菩提心。不破故不颠倒故。此心名为初发心。有人言。诸凡夫人虽住诸结使。闻佛功德发大悲心怜愍众生。我当作佛。此心虽在烦恼中。心尊贵故天人所敬。如转轮圣王太子初受胎时胜于诸子。诸天鬼神皆共尊贵。菩萨心亦如是。虽在结使中胜诸天神通圣人。复次菩萨。初发心乃至未得阿耨多罗三藐三菩提。有授记入法位得无生法忍者。名阿鞞跋致。阿鞞跋致相后当广说。如是等大众当作上首故名摩诃萨。是菩萨欲为一切圣人主故。发大心受一切苦。心坚如金刚不动故。金刚心者。一切结使烦恼所不能动。譬如金刚山不为风所倾摇。诸恶众生魔人来。不随意行不信受其语。嗔骂谤毁打击闭系斫刺割截心不变异。有来乞索头目髓脑手足皮肉尽能与之。求者意犹无厌足。更嗔恚骂詈。尔时心忍不动。譬如牢固金刚山人来斸凿毁坏。诸虫来啮无所亏损。是名金刚心。复次佛自说金刚心相。所谓菩萨应作是念。我不应一月一岁一世二世乃至千万劫世大誓庄严。我应无量无数无边世生死中。利益度脱一切众生。二者我应舍一切内外所有贵重之物。三者一切众生中等心无憎爱。四者我当以三乘如应度脱一切众生。五者度如是众生已实无所度。而无其功此中心亦不悔不没。六者我应知一切法。不生不灭不来不去不垢不净等诸相。七者我应当以清净无杂心行六波罗蜜。回向萨婆若。八者我应当善知一切世间所作之事。及出世间所应知事皆悉通达了知。九者我应当解了诸法一相智门。所谓一切诸法毕竟空观一切诸法。如无余涅槃相。离诸忆想分别。十者我应当知诸法二相三相乃至无量相门通达明了。二相者。一切法有二种。若有若无若生若灭若作若不作若色若无色等。三门者。若一若二若多。从三以上皆名为多。若有若无若非有非无。若上若中若下。若过去若未来若现在。三界三法善不善无记等三门四门五门。如是等无量法门皆通达无碍。是中心不悔不怯不疑。信受通达无碍常行不息。灭诸烦恼。及其果报及诸障碍之事。皆令败坏如金刚宝能摧破诸山。住是金刚心中当于大众而作上首。以不可得空故。不可得空者。若菩萨生如是大心如金刚。而生憍慢者罪过凡夫。以是故说。用无所得。诸法无定相如幻如化。复次心如金刚者。堕三恶道所有众生我当代受勤苦。为一一众生故代受地狱苦。乃至是众生从三恶道出。集诸善本至无余涅槃已。复救一切众生。如是展转一切众生尽度已。后当自为集诸功德。无量阿僧祇劫乃当作佛。是中心不悔不缩。能如是代众生受勤苦自作诸功德。久住生死心不悔不没。如金刚地能持三千大千世界。令不动摇。是心坚牢故名为如金刚。大快心者。虽有牢固心未是大快。如马虽有大力而未大快。于众生中得二种等心。故不生欲染心。若有偏爱则为是贼。破我等心。为佛道之本常行慈悲心。故无有嗔心。常观诸法因缘和合生。无有自性故则无痴心。爱念众生过于赤子故无有恼心。不舍众生贵佛道故。不生声闻辟支佛心。问曰。若心牢固如金刚即是不动。今何以更说不动心。答曰。或时虽复牢固心犹有增减。如树虽牢固犹可动摇。动有二种。一者外因缘动如先说。二者内因缘动。诸邪见疑等。若常忆念一切智慧佛道。我当得是果报故心不动。复次菩萨应种种因缘利益众生。饮食乃至佛乐以利众生。常不舍众生欲令离苦。是名安乐心。亦不念有是心。复次菩萨乐法名为上首。法者不破坏诸法相。不破坏诸法相者。无法可着无法可受故。所谓不可得。是不可得空即是涅槃。常信受忍是名为欲法喜法。常行三解脱门名为乐法。复次菩萨住是十八空中。不随十八意行故不起罪业。住四念处乃至十八不共法。灭诸烦恼集诸善法。故能为上首。复次菩萨入金刚三昧。等心受快乐。厌于世乐增长善根。智慧方便故于大圣众而为上首。若能为大者作上首。何况小者。是故名为摩诃萨

    大智度论释断见品第十四

【经】尔时慧命舍利弗白佛言。世尊。我亦欲说所以为摩诃萨。佛告舍利弗。便说。舍利弗言。我见众生见寿见命见生见养育见众数见人见作见使作见起见使起见受见使受见知者见见者见断见常见有见无见阴见入见界见谛见因缘见四念处见乃至十八不共法见佛道见成就众生见净佛世界见佛见转法轮见。为断如是诸见故而为说法。是名摩诃萨。须菩提语舍利弗言。何因缘故。色见是妄见。何因缘故受想行识乃至转法轮见。是名妄见。舍利弗语须菩提。菩萨摩诃萨行般若波罗蜜时。无方便故于色生见。用有所得故。于受想行识乃至转法轮生见。用有所得故。是中菩萨摩诃萨行般若波罗蜜。以方便力断诸见故而为说法。用无所得故

【论】问曰。佛将五百大阿罗汉。至阿那婆达多龙王池。受远离乐。欲说自身及弟子本业因缘。而舍利弗不在。佛令目连命之。时目连以神通力到祇洹。时舍利弗缝衣语目连言。小住待缝衣讫当去。目连催促疾去。时目连以手摩衣衣即成竟。舍利弗见目连贵其神通。即以腰带掷地语言。汝举此带去。目连以两手举此带不能离地。即入诸深定举之。地为大动带犹着地。时憍陈如问佛。以何因缘故地大震动。佛言。目连入甚深禅定作大神力。欲举舍利弗带而不能举。佛告诸比丘。舍利弗所入出禅定。目连乃至不识其名。佛所入禅定。舍利弗乃至不识其名。如舍利弗智慧与佛悬殊。何以言我亦乐说。答曰。舍利弗非欲于大众中显其智慧高心故说。舍利弗逐佛转法轮人。广益众生。是摩诃萨义所益甚广。是故佛说已。舍利弗次说。复次多人信乐舍利弗语。所以者何。以宿世因缘故。多发菩萨心。佛以大慈悲心故。吾我心及习根本已拔。又法爱已断故。如是种种因缘故听。舍利弗言。我见及知者见者。佛见菩萨见诸众生见等。及有无断常等邪见。五众乃至诸佛法转法轮等诸法见。是菩萨能断是三种见。故当于大众中说法。是三种见无始世界来习着入于骨髓。须菩提作是念。佛说五众等乃至诸佛法是菩萨行。何以为断诸见故说法。作是念已问舍利弗。舍利弗答。无方便菩萨欲行般若波罗蜜。观色求定相。取色一切相生色见。与此相违名为有方便。是菩萨虽观色不生妄见。而能断诸见

【经】尔时须菩提白佛言。世尊。我亦欲说所以为摩诃萨。佛言。便说。须菩提言。世尊。是阿耨多罗三藐三菩提心无等等心。不共声闻辟支佛心。何以故。是一切智心无漏不系故。是一切智心无漏不系中亦不着。以是因缘故名摩诃萨。舍利弗语须菩提。何等为菩萨摩诃萨无等等心。不共声闻辟支佛心。须菩提言。菩萨摩诃萨从初发意已来。不见法有生有灭有增有减有垢有净。舍利弗。若法无生无灭。乃至无垢无净。是中无声闻心无辟支佛心。无阿耨多罗三藐三菩提心无佛心。舍利弗。是名菩萨摩诃萨无等等心。不共声闻辟支佛心。舍利弗语须菩提。如须菩提说。一切智心无漏心不系心中不着。须菩提。色亦不着。受想行识亦不着。四念处亦不着。乃至十八不共法亦不着。何以故但说是心不着。须菩提言。如是如是。舍利弗色亦不着。乃至十八不共法亦不着。舍利弗语须菩提。凡夫人心亦无漏不系。性空故。诸声闻辟支佛心诸佛心亦无漏不系。性空故。须菩提言。如是舍利弗。舍利弗言。须菩提。若色亦无漏不系。性空故。受想行识无漏不系。性空故。乃至意触因缘生受无漏不系。性空故。须菩提言尔。舍利弗言。四念处亦无漏不系。性空故。乃至十八不共法亦无漏不系性空故。须菩提言尔。如舍利弗所言。凡夫人心亦无漏不系。性空故。乃至十八不共法亦无漏不系。性空故。舍利弗语须菩提。如须菩提所说。空无心故不着是心。须菩提。色无故不着色。受想行识乃至意触因缘生受无故不着受。四念处无故不着四念处。乃至十八不共法无故不着十八不共法。须菩提言。如是舍利弗。色无故色中不着。乃至十八不共法无故十八不共法中不着。如是舍利弗。菩萨摩诃萨行般若波罗蜜时。以阿耨多罗三藐三菩提心无等等心不共声闻辟支佛心。不念有是心。亦不着是心。以一切法无所得故。以是故名摩诃萨

【论】释曰。须菩提说。摩诃萨无等等心于是心亦不着。不著者。是菩萨从初发心已来。不见有法定相。若生若灭若增若减若垢若净。是心毕竟空。是中无有心相非心相。诸相毕竟清净故。以是故无声闻心辟支佛心菩萨心佛心。须菩提称贵。菩萨如是心亦美。菩萨不着是心亦为尊贵。舍利弗欲难须菩提。作是言。非但一切智心无漏不系。菩萨不应自高。所以者何。凡夫人心亦无漏不系。性常空故。如声闻辟支佛佛心无漏不系。是凡夫人心实相性空。实相性空清净不着。如先说。阴云翳日月不能污日月。又诸烦恼实相与常性空心相无异。但住凡夫地中是垢是净。住圣人地中。修无相智慧故无所分别。但怜愍众生故。虽复有说心无所著。非独凡夫人心无漏不系。五众乃至十八不共法亦如是。须菩提然可。又舍利弗言。是心无心。心相空故。不着色中色相无故。亦不着乃至诸佛法亦如是。须菩提言如是。以是故菩萨能观诸法性常空不可得空毕竟清净。以是故说阿耨多罗三藐三菩提心无等等心不共声闻辟支佛心。不念有是心亦不着是心。能疾至阿耨多罗三藐三菩提。(释第十四品竟)

    大智度论释大庄严品第十五

【经】尔时富楼那弥多罗尼子白佛言。世尊。我亦乐说所以为摩诃萨。佛言。便说。富楼那弥多罗尼子言。是菩萨大庄严。是菩萨发趣大乘。是菩萨乘于大乘。以是故是菩萨名摩诃萨。舍利弗语富楼那言。云何名菩萨摩诃萨大庄严。富楼那语舍利弗。菩萨摩诃萨不分别为尔所人故住檀波罗蜜行檀波罗蜜。为一切众生故。住檀波罗蜜行檀波罗蜜不为尔所人故住尸罗波罗蜜。行尸罗波罗蜜。羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。为一切众生故。住般若波罗蜜行般若波罗蜜。菩萨摩诃萨大庄严。不齐限众生。我当度若干人不度余人。不言我令若干人至阿耨多罗三藐三菩提余人不至。是菩萨摩诃萨普为一切众生故大庄严。复作是念。我当自具足檀波罗蜜。亦令一切众生行檀波罗蜜。自具足尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜。自具足般若波罗蜜。亦令一切众生行般若波罗蜜。复次舍利弗。菩萨摩诃萨行檀波罗蜜时。所有布施应萨婆若心。共一切众生回向阿耨多罗三藐三菩提。舍利弗。是名菩萨摩诃萨行檀波罗蜜时檀波罗蜜大庄严。复次舍利弗。菩萨摩诃萨行檀波罗蜜时。应萨婆若心布施。不向声闻辟支佛地。舍利弗。是名菩萨摩诃萨行檀波罗蜜时尸罗波罗蜜大庄严。复次舍利弗。菩萨摩诃萨行檀波罗蜜时。应萨婆若心布施。是诸施法信忍欲。是名行檀波罗蜜时羼提波罗蜜大庄严。复次舍利弗。菩萨摩诃萨行檀波罗蜜时。应萨婆若心布施勤修不息。是名行檀波罗蜜时毗梨耶波罗蜜大庄严。复次舍利弗。菩萨摩诃萨行檀波罗蜜时。应萨婆若心布施。摄心不起声闻辟支佛意。是名行檀波罗蜜时禅波罗蜜大庄严。复次舍利弗。菩萨摩诃萨行檀波罗蜜时。应萨婆若心布施。观诸法如幻。不得施者不得所施物不得受者。是名行檀波罗蜜时般若波罗蜜大庄严。如是舍利弗。若菩萨摩诃萨应萨婆若心。不取不得诸波罗蜜相。当知是菩萨摩诃萨大庄严。复次舍利弗。菩萨摩诃萨行尸罗波罗蜜时。应萨婆若心布施。共一切众生回向阿耨多罗三藐三菩提。是名菩萨摩诃萨行尸罗波罗蜜时檀波罗蜜。复次舍利弗。菩萨摩诃萨行尸罗波罗蜜时诸法信忍欲。是名菩萨摩诃萨行尸罗波罗蜜时羼提波罗蜜。复次舍利弗。菩萨摩诃萨行尸罗波罗蜜时勤修不息。是名菩萨摩诃萨行尸罗波罗蜜时毗梨耶波罗蜜。复次舍利弗。菩萨摩诃萨行尸罗波罗蜜时。不受声闻辟支佛心。是名菩萨摩诃萨行尸罗波罗蜜时禅波罗蜜。复次舍利弗。菩萨摩诃萨行尸罗波罗蜜时。观一切法如幻。亦不念有是戒。用无所得故。是名菩萨摩诃萨行尸罗波罗蜜时般若波罗蜜。如是舍利弗。菩萨摩诃萨行尸罗波罗蜜时摄诸波罗蜜。以是故名大庄严。复次舍利弗。菩萨摩诃萨行羼提波罗蜜时。应萨婆若心布施。共一切众生回向阿耨多罗三藐三菩提。是为菩萨摩诃萨行羼提波罗蜜时檀波罗蜜。复次舍利弗。菩萨摩诃萨行羼提波罗蜜时。不受声闻辟支佛心。但受萨婆若心。是名菩萨摩诃萨行羼提波罗蜜时尸罗波罗蜜。复次舍利弗。菩萨摩诃萨行羼提波罗蜜时。应萨婆若心。身心精进不休不息。是名菩萨摩诃萨行羼提波罗蜜持毗梨耶波罗蜜。复次舍利弗。菩萨摩诃萨行羼提波罗蜜时。摄心一处虽有苦事心不散乱。是名菩萨摩诃萨行羼提波罗蜜时禅波罗蜜。复次舍利弗。菩萨摩诃萨行羼提波罗蜜时。应萨婆若心观诸法空。无作者无受者。若有呵骂割截者心如幻梦。是名菩萨摩诃萨行羼提波罗蜜时般若波罗蜜。复次舍利弗。菩萨摩诃萨行毗梨耶波罗蜜时。应萨婆若心布施时。不令身心懈怠。是名菩萨摩诃萨行毗梨耶波罗蜜时檀波罗蜜。复次舍利弗。菩萨摩诃萨行毗梨耶波罗蜜时。应萨婆若心。始终具足清净持戒。是名菩萨摩诃萨行毗梨耶波罗蜜时尸罗波罗蜜。复次舍利弗。菩萨摩诃萨行毗梨耶波罗蜜时。应萨婆若心修行忍辱。是名菩萨摩诃萨行毗梨耶波罗蜜时羼提波罗蜜。复次舍利弗。菩萨摩诃萨行毗梨耶波罗蜜时。应萨婆若心。摄心离欲入诸禅定。是名菩萨摩诃萨行毗梨耶波罗蜜时禅波罗蜜。复次舍利弗。菩萨摩诃萨行毗梨耶波罗蜜时。应萨婆若心。不取一切诸法相。于不取相亦不着。是名菩萨摩诃萨行毗梨耶波罗蜜时般若波罗蜜。如是舍利弗。菩萨摩诃萨行毗梨耶波罗蜜时摄诸波罗蜜。复次舍利弗。菩萨摩诃萨行禅波罗蜜时。应萨婆若心。定心布施不令心乱。是名菩萨摩诃萨行禅那波罗蜜时檀波罗蜜。复次舍利弗。菩萨摩诃萨行禅波罗蜜时。应萨婆若心持戒。禅定力故破戒诸法不令得入。是名菩萨摩诃萨行禅波罗蜜时尸罗波罗蜜。复次舍利弗。菩萨摩诃萨行禅波罗蜜时。应萨婆若心。慈悲定故忍诸恼害。是名菩萨摩诃萨行禅波罗蜜时羼提波罗蜜。复次舍利弗。菩萨摩诃萨行禅波罗蜜时。应萨婆若心。于禅不味不着。常求增进从一禅至一禅。是名菩萨摩诃萨行禅波罗蜜时毗梨耶波罗蜜。复次舍利弗。菩萨摩诃萨行禅波罗蜜时。应萨婆若心于一切法无所依止。亦不随禅生。是名菩萨摩诃萨行禅波罗蜜时般若波罗蜜。如是舍利弗。菩萨摩诃萨行禅波罗蜜时摄诸波罗蜜。复次舍利弗。菩萨摩诃萨行般若波罗蜜时。应萨婆若心布施。内外所有无所爱惜。不见与者受者及以财物。是名菩萨摩诃萨行般若波罗蜜时檀波罗蜜。复次舍利弗。菩萨摩诃萨行般若波罗蜜时。应萨婆若心。持戒破戒二事不见故。是名菩萨摩诃萨行般若波罗蜜时尸罗波罗蜜。复次舍利弗。菩萨摩诃萨行般若波罗蜜时。应萨婆若心。不见诃者骂者打者。杀者亦不见用是空能忍辱。是名菩萨摩诃萨行般若波罗蜜时羼提波罗蜜。复次舍利弗。菩萨摩诃萨行般若波罗蜜时。应萨婆若心。观诸法毕竟空。以大悲心故行诸善法。是名菩萨摩诃萨行般若波罗蜜时毗梨耶波罗蜜。复次舍利弗。菩萨摩诃萨行般若波罗蜜时。应萨婆若心入禅定。观诸禅离相空相无相相无作相。是名菩萨摩诃萨行般若波罗蜜时禅波罗蜜。如是舍利弗。菩萨摩诃萨行般若波罗蜜时摄诸波罗蜜。舍利弗。如是名为菩萨摩诃萨大庄严。是大庄严菩萨。十方诸佛欢喜。于大众中称名赞叹。某世界某菩萨摩诃萨大庄严。成就众生净佛世界。【论】释曰。富楼那闻上二大弟子说摩诃萨义而佛可言善哉。又富楼那佛大众中赞叹法师之上。复欲说摩诃萨义。白佛言。我亦乐说。佛即听许。问曰。须菩提说般若波罗蜜主。舍利弗应问须菩提。今何以故乃问富楼那。答曰。此二人同是婆罗门。俱以母字为名。此二人佛法中俱大。舍利弗智慧中大。富楼那说法种种庄严牵引众情说法中大。是故二人等等。故于佛前共论。又富楼那先已共舍利弗论议善能相答。如七车譬喻经中说。已共为亲厚好共论理。须菩提无是因缘。又富楼那说摩诃萨义。是故应问。云何乃问须菩提所说摩诃萨义者。所谓是人大庄严。如人远行重有资粮。又如破贼备诸器仗。是菩萨亦如是。欲破魔入烦恼贼故。行六波罗蜜以自庄严。是人无量劫来久住生死。集诸福德智慧以为资粮。三种乘中为趣大乘故。发心行六波罗蜜乘是大乘。舍利弗问富楼那。声闻辟支佛亦趣道。何以不名大庄严。而但说菩萨大庄严。富楼那答言。声闻辟支佛虽行布施等六事。有量有限。自为度身及余众生可度者度。是故不名大庄严。菩萨所度不分别不齐限。为若干众生故。布施乃至智慧。不作是念。我度若干人令得三乘。不能度若干人。令若干人得阿耨多罗三藐三菩提。若干人不能度。菩萨作是庄严。令一切众生尽入大乘作佛。菩萨行大庄严。自行檀波罗蜜。亦令一切众生行檀波罗蜜。乃至般若波罗蜜亦如是。问曰。云何名大庄严。答曰。为度众生故。为阿耨多罗三藐三菩提故。行诸善福功德者。略说是六波罗蜜。如富楼那次第说。若菩萨为一切智慧故行檀波罗蜜。是福德共一切众生。共者此布施福德我及众生共等。我以此回向阿耨多罗三藐三菩提。回向者。于此福德不求人王天王世间禅定乐。为众生乃至涅槃乐。亦不求持此果报。尽为度众生故求佛法。如是等相是名檀波罗蜜大庄严。是菩萨行布施时。若见诸辟支佛阿罗汉。现大神通得漏尽入涅槃。于中不贪不着一心修佛道。是名檀波罗蜜生尸罗波罗蜜。布施时有人恶口骂詈刀杖毁害。所不应乞者而强乞不嗔不悔。入诸法相中。所谓毕竟空。是名檀波罗蜜生羼提波罗蜜。行布施时和合财物守护施彼。身心不懈不息。是名檀波罗蜜生毗梨耶波罗蜜。布施时一心念佛念诸佛法。不令声闻辟支佛心入。因是布施即入禅定。是名檀波罗蜜生禅波罗蜜。布施时菩萨作是念。施者受者财物因缘和合生故无自性。无自性故空如幻如梦。众生空故无受者无施者。法空故无财物。是名檀波罗蜜生般若波罗蜜。若菩萨为一切智故。不取诸波罗蜜相。而能行诸波罗蜜。是名菩萨大庄严。此中一波罗蜜备生诸波罗蜜。此经中自分别其义。古今语异义不了故。助分别说开论议门。余五波罗蜜亦应如是随义说。问曰。何以但檀波罗蜜中说生六波罗蜜。余波罗蜜中但说生五。答曰。若后五波罗蜜中。各各生六亦无咎。六波罗蜜非一时非一念法。无量劫中集六种功德。和合名为六波罗蜜。先生小后生中大有何咎。一切诸法皆初小后大。以是故诸余波罗蜜各各应生六。复次一切诸佛说法时。檀波罗蜜为初门。如经中说。佛常初为众生说布施说持戒说生天说五欲味。先说世间苦恼道德利益。后为说四谛。以是故初说檀。问曰。佛何以故说檀为初门。答曰。摄众生法无过于檀。大小贵贱乃至畜生檀皆摄之。乃至怨家得施则为中人。中人得施则成亲善。诸佛三十二相八十随形好。诸功德具足所愿如意。皆从布施得。如宝掌菩萨等。七宝从手中出给施众生。亦能令众生欢喜。柔软可任得涅槃。如是等义故檀波罗蜜为初。问曰。富楼那何以故。说一波罗蜜中生诸波罗蜜为大庄严。答曰。是波罗蜜各各别行力势少。譬如兵人未集则无战力。若大军都集庄严执持器仗则能破敌。菩萨亦如是。六波罗蜜一时庄严。能破诸烦恼魔人贼。疾得阿耨多罗三藐三菩提。以是故说一波罗蜜中具诸波罗蜜。十方诸佛称名赞叹。成就众生净佛世界如先说

【经】慧命舍利弗问富楼那弥多罗尼子云何菩萨摩诃萨发趣大乘。富楼那语舍利弗。菩萨摩诃萨行六波罗蜜时。离诸欲离诸恶不善法。有觉有观离生喜乐入初禅。乃至入第四禅中。以慈广大无二无量无怨无恨无恼心行遍满。一方二三四方四维上下遍一切世间。悲喜舍心亦如是。是菩萨入禅时起时。诸禅无量心及支。共一切众生回向萨婆若。是名菩萨摩诃萨禅波罗蜜发趣大乘。是菩萨摩诃萨住禅无量心作是念。我当得一切种智。为断一切众生烦恼故当说法。是名菩萨摩诃萨行禅波罗蜜时檀波罗蜜。若菩萨摩诃萨应萨婆若心。修初禅住初禅。二三四禅亦如是不受余心。所谓声闻辟支佛心。是名菩萨摩诃萨行禅波罗蜜时尸罗波罗蜜。若菩萨摩诃萨。应萨婆若心。入诸禅作是念。我为断一切众生烦恼故当说法。是诸心欲乐忍。是名菩萨摩诃萨行禅波罗蜜时羼提波罗蜜。若菩萨摩诃萨应萨婆若心入诸禅。诸善根皆回向萨婆若。勤修不息。是名菩萨摩诃萨行禅波罗蜜时毗梨耶波罗蜜。若菩萨摩诃萨应萨婆若心入四禅及支。观无常相苦相无我相空相无相相无作相。共一切众生回向萨婆若。是名菩萨摩诃萨行禅波罗蜜时般若波罗蜜。舍利弗。是名菩萨摩诃萨发趣大乘。复次菩萨摩诃萨行慈心作是念。我当安乐一切众生入悲心。我当救济一切众生入喜心。我当度一切众生入舍心。我当令一切众生得诸漏尽。是名菩萨摩诃萨行无量心时檀波罗蜜。复次菩萨摩诃萨是诸禅无量心不向声闻辟支佛地。但回向萨婆若。是名菩萨摩诃萨行无量心时尸罗波罗蜜。复次舍利弗。菩萨摩诃萨行四无量心。不贪声闻辟支佛地。但忍乐欲萨婆若。是名菩萨摩诃萨行无量心时羼提波罗蜜。若菩萨摩诃萨应萨婆若心。行四无量心但行清净行。是名菩萨摩诃萨行无量心时毗梨耶波罗蜜。复次菩萨摩诃萨入禅入无量心时。亦不随禅无量心生。是名菩萨摩诃萨行无量心时方便般若波罗蜜。舍利弗。是名菩萨摩诃萨发趣大乘。复次舍利弗。菩萨摩诃萨发趣大乘。一切种修四念处。乃至一切种修八圣道分。一切种修三解脱门乃至十八不共法。是名菩萨摩诃萨发趣大乘。复次舍利弗。菩萨摩诃萨内空中智慧。用无所得故。乃至无法有法空中智慧。用无所得故。是名菩萨摩诃萨发趣大乘。复次舍利弗。菩萨摩诃萨一切法中不乱不定智慧。是名菩萨摩诃萨发趣大乘。复次舍利弗。菩萨摩诃萨发趣大乘非常非无常智慧。非乐非苦非实非虚非我非无我智慧。是名菩萨摩诃萨发趣大乘。用无所得故。复次舍利弗。菩萨摩诃萨智。不行过去世不行未来世不行现在世。亦非不知三世。是名菩萨摩诃萨发趣大乘。用无所得故。复次菩萨摩诃萨发趣大乘智。不行欲界不行色界不行无色界。亦非不知欲界色界无色界。用无所得故。是名菩萨摩诃萨发趣大乘。复次菩萨摩诃萨发趣大乘智。不行世间法不行出世间法。不行有为法不行无为法。不行有漏法不行无漏法。亦非不知世间法出世间法有为无为有漏无漏法。用无所得故。舍利弗。是名菩萨摩诃萨发趣大乘

【论】问曰。六波罗蜜中若逆说。则应说般若波罗蜜次说禅。若顺应先说檀波罗蜜。今何以乃说禅波罗蜜为首。答曰。发大庄严无有众生能破坏者。若菩萨无禅定心未离欲。虽行余波罗蜜则易坏。行禅波罗蜜能入慈无量。是时无能坏。如说行慈三昧者刀不能伤水火不害。亦有神通力种种变化能发大庄严。如佛说。鸟无两翼不能飞翔。菩萨无神通力。不能发大庄严。入禅波罗蜜中能生慈无量。五神通故物无能伤。以是故今此说禅波罗蜜为首。问曰。四禅中有种种功德。皆可行六波罗蜜。今何以但说四无量心中行六波罗蜜。答曰。四无量心取众生相缘众生。菩萨常为众生故行道。是四无量等中有慈悲心能利益众生余八背舍九次第等无如是利益。问曰。菩萨住五神通能广利益众生。何以故不说。答曰。大悲是菩萨根本。又五神通先已说。后当说四无量心。未说故。今说。若菩萨但行四无量心。不名发趣大乘。六波罗蜜相合故。名为发趣大乘。四无量心生六波罗蜜。富楼那此中自说因缘。问曰。云何一切种修四念处乃至十八不共法。答曰。有二种。信行性法行性。信行性观无常苦。或但观无常。或但观苦。法行性人观空无我。或但观空。或但观无我。菩萨度众生故。一切门皆修皆学。复次发大乘者。以十八空破十八种法。亦舍是十八种空智慧。复次若菩萨观诸法常定。亦不取定相。是名不定不乱智慧。复次畏堕常乐颠倒故。不观诸法常乐等。畏堕断灭故不观无常等。复次若菩萨三世三界中智慧。不观不行不取相。知皆虚妄而不堕无明。复次世间出世间中亦非智非不智。非智者。空故无空相故毕竟清净故。非不智者。观无常苦空等入般若波罗蜜中故。非不行智。不行者。遮见断法爱。离依止故。无非智者。是中无愚痴。异于凡夫故。又行者持戒修禅定习诸观云何言非智如佛利众生经中说

  行者舍诸法　　亦不依止慧
  亦无所分别　　是为决定智(释第十五品竟)

大智度论卷第四十五大智度论释乘乘品第十六(卷第四十六)

        龙树菩萨造

        后秦龟兹国三藏鸠摩罗什译

【经】尔时慧命舍利弗问富楼那。云何名菩萨摩诃萨乘于大乘。富楼那答舍利弗言。菩萨摩诃萨行般若波罗蜜时。乘檀波罗蜜亦不得檀波罗蜜。亦不得菩萨亦不得受者。用无所得故。是名菩萨摩诃萨乘檀波罗蜜。菩萨摩诃萨行般若波罗蜜时。乘尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜。乘般若波罗蜜。亦不得般若波罗蜜。亦不得菩萨。用无所得故。是为菩萨摩诃萨乘于般若波罗蜜。如是舍利弗。是为菩萨摩诃萨乘于大乘。复次舍利弗。菩萨摩诃萨摩诃衍一心应萨婆若修四念处。法坏故乃至一心应萨婆若。修十八不共法。法坏故是亦不可得。如是舍利弗。是名菩萨摩诃萨乘于大乘。复次舍利弗。菩萨摩诃萨作是念。菩萨但有名字。众生不可得故。是名菩萨摩诃萨乘于大乘。复次舍利弗。若菩萨摩诃萨作是念。色但有名字。色不可得故。受想行识但有名字。识不可得故。眼但有名字。眼不可得故。乃至意亦如是。四念处但有名字。四念处不可得故。乃至八圣道分但有名字。八圣道分不可得故。内空但有名字。内空不可得故。乃至无法有法空但有名字。无法有法空不可得故。乃至十八不共法但有名字。十八不共法不可得故。诸法如但有名字。如不可得故。法相法性法住实际但有名字。实际不可得故。阿耨多罗三藐三菩提及佛但有名字。佛不可得故如是舍利弗。是名菩萨摩诃萨乘于大乘。复次舍利弗。若菩萨摩诃萨从初发意已来。具足菩萨神通。成就众生。从一佛国至一佛国。恭敬供养尊重赞叹诸佛。从诸佛听受法教。所谓菩萨大乘。是菩萨乘此大乘。从一佛国至一佛国。净佛世界成就众生。初无佛国想。亦无众生想。此人住不二法中。为众生受身随其所应。自变其形而教化之。乃至一切智终不离菩萨乘。是菩萨得一切种智已转法轮。声闻辟支佛及天龙鬼神阿修罗世间人民所不能转。尔时十方如恒河沙等诸佛。皆欢喜称名赞叹作是言。某方某国某菩萨摩诃萨。乘于大乘得一切种智转法轮。舍利弗。是名菩萨摩诃萨乘于大乘

【论】释曰。富楼那以三事明摩诃萨。上已说二事。今问第三事乘于大乘。富楼那答。有人言。菩萨直布施内外物。不能破吾我相。是名大庄严。若能破吾我相。入众生空未入法空。是名发大庄严。因众生空入法空中。行檀波罗蜜。不见三事施者受者财物。能如是者。是名乘于大乘。余波罗蜜亦如是。是菩萨以不杂心。离诸烦恼及二乘意。为萨婆若。故修行四念处。修相亦不可得。毕竟清净故。是名乘于大乘。乃至十八不共法亦如是。复次若菩萨知一切法假名字。于名字和合中复有名字。一切世间若出世间皆是假名。是名乘于大乘。复次菩萨发大庄严。具足菩萨神通。具足菩萨神通故成就众生。从一佛国至一佛国。所经诸国雨七宝莲华供养诸佛。拔三恶道众生。变身无数。各各至诸佛前。听受大乘法。化从诸佛前趣大乘相。乘此大乘从一佛国至一佛国。成就众生净佛世界。不生众生相不取佛国相。住不二入地中。随诸众生所应度者而化度之。为众生故受身。常乘大乘初无休息。是菩萨乘于大乘得成佛转法轮。诸声闻辟支佛所不能转。何况余小凡夫。十方如恒河沙等世界诸佛赞叹是菩萨。某方某国某甲菩萨。乘于大乘成佛转法轮。如是相名为乘于大乘。复次大乘名毕竟清净六波罗蜜。菩萨摩诃萨乘大乘时。以五神通而自庄严。菩萨住是乘中。一时变身无数。至十方世界。供养诸佛度脱众生。是菩萨常不离诸佛。乃至得佛道常乘此大乘

    大智度论释无缚无脱品第十七

【经】尔时须菩提白佛言。世尊。菩萨摩诃萨大庄严。何等是大庄严。何等菩萨能大庄严。佛语须菩提。菩萨摩诃萨摩诃衍大庄严。所谓檀波罗蜜。乃至般若波罗蜜庄严。四念处庄严。乃至八圣道分内空庄严。乃至无法有法空十力。乃至十八不共法及一切种智庄严。变身如佛庄严。光明遍照三千大千世界。亦照东方如恒河沙等世界。南西北方四维上下亦复如是。三千大千世界六种振动。亦动东方如恒河沙等诸世界。南西北方四维上下亦复如是。是菩萨摩诃萨住檀波罗蜜摩诃衍大庄严。是三千大千世界变为琉璃。化作转轮圣王。随众生所欲。须食与食须饮与饮。衣服卧具花香缨珞捣香泽香房舍灯烛医药种种所须尽给与之。与已而为说法。所谓应六波罗蜜法。众生闻是法者。终不离六波罗蜜。乃至阿耨多罗三藐三菩提。如是须菩提。是名菩萨摩诃萨摩诃衍大庄严。须菩提。譬如工幻师若幻师弟子。于四衢道中化作大众。于前须食与食须饮与饮。乃至种种所须尽给与之。于须菩提意云何。是幻师实有众生有给与不。须菩提言。不也。世尊。须菩提。菩萨摩诃萨亦如是。化作转轮圣王。种种具足。须食与食须饮与饮。乃至种种所须尽给与之。虽有所施实无所与。何以故。须菩提。诸法相如幻故。复次须菩提。菩萨摩诃萨住尸罗波罗蜜。现生转轮圣王家。以十善道教化众生。又以四禅四无量心四无色定四念处乃至十八不共法教化众生。闻是法者。至阿耨多罗三藐三菩提。终不离是法。譬如幻师若幻师弟子。于四衢道中化作大众。以十善道教化令行。又以四禅四无量心四无色定四念处乃至十八不共法教化令行。须菩提。于汝意云何。是幻师实有众生教化令行十善道乃至十八不共法不。须菩提言。不也。世尊。须菩提。菩萨摩诃萨亦如是。以十善道教化众生令行。乃至十八不共法。实无众生行十善道乃至十八不共法。何以故。诸法相如幻故。须菩提。是名菩萨摩诃萨大庄严。复次须菩提。菩萨摩诃萨住羼提波罗蜜。教化众生忍辱。须菩提。云何菩萨摩诃萨住羼提波罗蜜。教化众生着忍辱波罗蜜中。须菩提。菩萨摩诃萨从初发意已来。如是大庄严。若一切众生来骂詈刀杖伤害。菩萨摩诃萨于此中不起一念。亦教一切众生行此忍辱。譬如幻师若幻师弟子。于四衢道中化作大众。令行忍辱。余如上说。须菩提。是名菩萨摩诃萨大庄严。复次须菩提。菩萨摩诃萨住毗梨耶波罗蜜。教化一切众生令行毗梨耶波罗蜜。须菩提。云何菩萨摩诃萨住毗梨耶波罗蜜。教一切众生令行毗梨耶波罗蜜。须菩提。菩萨摩诃萨应萨婆若心。身心精进教化众生。譬如幻师若幻师弟子。于四衢道中化作大众。教令行身心精进。余如上说。是名菩萨摩诃萨大庄严。复次须菩提。菩萨摩诃萨住禅波罗蜜。教一切众生令行禅波罗蜜。须菩提。云何菩萨摩诃萨住禅波罗蜜。教一切众生令行禅波罗蜜。须菩提。菩萨摩诃萨住诸法等中。不见法若乱若定。如是须菩提。菩萨摩诃萨住禅波罗蜜。教一切众生令行禅波罗蜜。乃至阿耨多罗三藐三菩提。终不离禅波罗蜜。譬如工幻师若幻师弟子。于四衢道中化作大众。教令行禅波罗蜜。余如上说。须菩提。是名菩萨摩诃萨大庄严。复次须菩提。菩萨摩诃萨住般若波罗蜜。教一切众生令行般若波罗蜜。须菩提。云何菩萨摩诃萨住般若波罗蜜。教一切众生令行般若波罗蜜。须菩提。菩萨摩诃萨行般若波罗蜜时。无有法得此岸彼岸。如是菩萨摩诃萨住般若波罗蜜中。教一切众生令行般若波罗蜜。譬如幻师若幻师弟子。于四衢道中化作大众。教令行般若波罗蜜。须菩提。是名菩萨摩诃萨大庄严。复次须菩提。菩萨摩诃萨大庄严。十方如恒河沙等世界中。随其所应自变其身。住檀波罗蜜乃至般若波罗蜜。亦教众生令行檀波罗蜜乃至般若波罗蜜。是众生行是法。乃至阿耨多罗三藐三菩提。终不离是法。须菩提。譬如幻师若幻师弟子。于四衢道中化作众生。教令行六波罗蜜。余如上说。如是须菩提。是名菩萨摩诃萨大庄严。复次须菩提。菩萨摩诃萨大庄严。应萨婆若心不生是念。我教若干人住檀波罗蜜。不教若干人住檀波罗蜜。乃至般若波罗蜜亦如是。不生是念。我教若干人住四念处。不教若干人住四念处。乃至十八不共法亦如是。亦不生是念。我教若干人令得须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道一切种智。亦不教若干人令得须陀洹果乃至一切种智。我当令无量无边阿僧祇众生住檀波罗蜜乃至般若波罗蜜。立众生于四念处乃至十八不共法。令无量无边阿僧祇众生得须陀洹果乃至一切种智。譬如工幻师若幻师弟子。于四衢道中化作大众。教令住六波罗蜜乃至得一切种智。余如上说。须菩提。是名菩萨摩诃萨大庄严

【论】释曰。上富楼那说大庄严及发大誓庄严相。今须菩提作是念。富楼那未得一切智。虽说大庄严或当有错。是故问佛取定。佛为须菩提说檀波罗蜜大庄严乃至一切智。是诸善法果报故。得菩萨大神通力。为出家好道众生故。化作佛身放大光明。照十方世界震动大地。令众生发心行善法。随其所应而为说法令得三乘。为在家好乐众生。作转轮圣王。变三千世界悉为琉璃。为不障碍故乘七宝车。身放光明雨诸宝物。随众生所须皆令充足。然后为说菩萨法。菩萨住大乘中。以二施利益众生。所谓财施法施。众生闻已行六波罗蜜乃至十八不共法。至阿耨多罗三藐三菩提。终不离是法。菩萨虽住是变化中。亦不于诸法中生着相。亦不自高。须菩提作是念。菩萨能作如是大事。又诸漏未尽故。云何于诸法得不着。亦不生高心。是中佛自说譬喻。若幻师于四衢道中化作种种物。随人所须悉能与之。于须菩提意云何。是幻师实有所与不。有受者有用者不。须菩提言。是但虚诳实无所有。佛言。菩萨亦如是。虽作佛身转轮圣王以财法施众生。亦如幻师实无所与。何以故。诸法相毕竟空如幻。余五波罗蜜亦如是。随义分别。复次檀波罗蜜尸罗波罗蜜因缘故。人中富贵作转轮圣王。余波罗蜜或作梵王。或作法身菩萨。问曰。六波罗蜜外更有何法可庄严。答曰。诸功德皆六波罗蜜中摄。有人言。别有智波罗蜜及方便等。于十方如恒河沙等世界中。随所应度作种种因缘。说法令众生住六波罗蜜。复次决定誓愿名为大庄严。所谓菩萨不作是念。我度若干人令住檀波罗蜜。不能度余人。乃至十八不共法亦如是。亦不作是念。我令若干人得须陀洹果。不能令若干人得须陀洹果。乃至佛道亦如是。我当悉令无量阿僧祇众生住诸功德中。檀波罗蜜乃至一切种智自立。如幻师如先说。是名发大庄严

【经】尔时须菩提。白佛言。世尊。如我从佛所闻义。菩萨摩诃萨无大庄严为大庄严。诸法自相空故。所谓色色相空。受想行识识相空。眼眼相空。乃至意意相空。色色相空。乃至法法相空。眼识眼识相空。乃至意识意识相空。眼触眼触相空。乃至意触意触相空。眼触因缘生受受相空。乃至意触因缘生受受相空。世尊。檀波罗蜜檀波罗蜜相空。乃至般若波罗蜜般若波罗蜜相空。内空内空空相空。乃至无法有法空无法有法空相空。四念处四念处相空。乃至十八不共法十八不共法相空。菩萨菩萨相空。世尊。以是因缘故。当知菩萨摩诃萨无大庄严为大庄严。佛告须菩提。如是如是如汝所说。须菩提。萨婆若非作法。众生亦非作法。菩萨为是众生大庄严。须菩提。白佛言。世尊。何因缘故。萨婆若非作法是众生亦非作法。菩萨为是众生大庄严。佛语须菩提。作者不可得故。萨婆若非作非起法。是诸众生亦非作非起法。何以故。须菩提。色非作非不作。受想行识非作非不作。眼非作非不作。乃至意非作非不作。色乃至法。眼识乃至意识眼触乃至意触。眼触因缘生受。乃至意触因缘生受。非作非不作。须菩提。我非作非不作。乃至知者见者非作非不作。何以故。是诸法毕竟不可得故。须菩提。梦非作非不作。何以故。毕竟不可得故。幻向影焰化非作非不作何以故。毕竟不可得故。须菩提。内空非作非不作。毕竟不可得故。乃至无法有法空非作非不作。毕竟不可得故。须菩提。四念处非作非不作。毕竟不可得故。乃至十八不共法非作非不作。何以故。是法皆毕竟不可得故。须菩提。诸法如法相法性法住法位实际非作非不作。毕竟不可得故。须菩提。菩提非作非不作。毕竟不可得故。萨婆若及一切种智非作非不作。毕竟不可得故。以是因缘故。须菩提。萨婆若非作非起法。是众生亦非作非起法。菩萨为是众生大庄严。尔时须菩提。白佛言。如我观佛所说义。世尊。色无缚无脱。受想行识无缚无脱

尔时富楼那弥多罗尼子语须菩提。色是无缚无脱。受想行识是无缚无脱。须菩提言。如是如是。色是无缚无脱。受想行识是无缚无脱。富楼那弥多罗尼子。问须菩提。何等色无缚无脱。何等受想行识无缚无脱。须菩提言。如梦色无缚无脱。如梦受想行识无缚无脱。如向如影如幻如焰如化色受想行识无缚无脱。富楼那弥多罗尼子。过去色无缚无脱。过去受想行识无缚无脱。未来色无缚无脱。未来受想行识无缚无脱。现在色无缚无脱。现在受想行识无缚无脱。何以故无缚无脱。是色无所有故无缚无脱。受想行识无所有故无缚无脱。离故寂灭故不生故无缚无脱。富楼那。善色受想行识无缚无脱。不善色受想行识无缚无脱。无记色无缚无脱。无记受想行识无缚无脱。世间出世间有漏无漏色无缚无脱。受想行识亦无缚无脱。何以故。无所有故离故寂灭故不生故无缚无脱。富楼那。一切法亦无缚无脱。无所有故离故寂灭故不生故。富楼那。檀波罗蜜无缚无脱。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜无缚无脱。无所有故离故寂灭故不生故无缚无脱。富楼那。内空亦无缚无脱。乃至无法有法空亦无缚无脱。四念处无缚无脱。乃至十八不共法无缚无脱。无所有故离故寂灭故不生故无缚无脱。阿耨多罗三藐三菩提无缚无脱。一切智一切种智无缚无脱。菩萨无缚无脱。佛亦无缚无脱。无所有故离故寂灭故不生故无缚无脱。富楼那。诸法如法相法性法住法位实际无为法无缚无脱。无所有故离故寂灭故不生故无缚无脱。富楼那。是名菩萨摩诃萨无缚无脱。檀波罗蜜乃至般若波罗蜜。四念处乃至一切种智无缚无脱。是菩萨摩诃萨住无缚无脱檀波罗蜜中。乃至住无缚无脱般若波罗蜜。住无缚无脱四念处。乃至住无缚无脱一切种智。无缚无脱成就众生。无缚无脱净佛世界。无缚无脱诸佛当供养。无缚无脱当听法。无缚无脱诸佛终不离。无缚无脱诸神通终不离。无缚无脱五眼终不离。无缚无脱陀罗尼门终不离。无缚无脱诸三昧终不离。无缚无脱当生道种智。无缚无脱当得一切种智。无缚无脱法轮转。无缚无脱众生安立三乘。如是富楼那。菩萨摩诃萨行无缚无脱六波罗蜜。当知一切法无缚无脱。无所有故离故寂灭故不生故。富楼那。是名菩萨摩诃萨无缚无脱大庄严

【论】释曰。须菩提言。如我闻佛义。无大庄严为大庄严。何以故。自相空故。问曰。须菩提何以故如是说。答曰。佛说发大庄严义甚深难得难解。会中众生闻是事心或退没。如是庄严毕竟空。亦以神通力故。一时能遍至十方如恒河沙世界。可适众生。言此是圣王事。我等云何能知。以是故。须菩提说。发大庄严非深非难。非但发大庄严自相空易行易得。色色中定相不可得。乃至十八不共法亦尔。若菩萨能如是知诸法空寂灭相。而不舍本愿精进。是故名发大庄严非是难得。佛证须菩提所说。故言如是。作法皆是虚诳故言萨婆若无作法。众生毕竟空故亦无作法。佛说作者不可得故一切智非作相。众生不可得故作者不可得。作者不可得故萨婆若非作非起相。复次色亦无所能作。法空故。乃至诸佛法亦如是。须菩提等谓。诸法中无有定作相。如幻虽无实事而有来去相。以是故佛说。如幻如焰等无作相毕竟不可得故。是时听者作是念。十八空能破一切法。则是有用是则为实。谓言有作。是以佛言。内空无所作。乃至无法有法空。至十八不共法亦无所作。若谓今十八空有为虚诳无实故可无作。如法性实际是真实法应当有作。何以故。一切有为法各各共因无为法。亦与有为法作因故。佛言。如法性实际法住法位亦无作。又谓菩萨佛一切种智是实法能有所作。以是故佛言。是法亦毕竟空故。亦无所作。作相因缘生故。行者念言。佛法甚难甚为希有。诸法都无作无缚无解者。我等云何当从苦得脱。是故须菩提。白佛言。如我知佛所说义。五众无缚无解。若毕竟空无有作者。谁缚谁解。凡夫人法虚诳不可得故非缚。圣人法毕竟空不可得故非解。如梦等五众。及三世五众。善不善等五众。一切法亦如是。乃至实际等亦复如是。无所有故离故不生。故无缚无解。是名菩萨摩诃萨不缚不解。菩萨道住是道中。诸烦恼不牵堕凡夫中故言不缚。不以诸无漏法破烦恼故言不解。教化众生净佛世界。乃至五神通五眼诸陀罗尼三昧门。终不离佛及安立众生。于三乘亦无缚无解。所以者何。诸法无所有故离故寂灭故不生故毕竟空故。如是等因缘是名菩萨摩诃萨发大庄严相。所谓不缚不解

    大智度论释摩诃衍品第十八

【经】尔时须菩提。白佛言世尊。何等是菩萨摩诃萨摩诃衍。云何当知。菩萨摩诃萨发趣大乘。是乘发何处是乘至何处。当住何处谁当乘是乘出者。佛告须菩提。汝问何等是菩萨摩诃萨摩诃衍。须菩提。六波罗蜜是菩萨摩诃萨摩诃衍。何等六。檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。云何名檀波罗蜜。须菩提。菩萨摩诃萨以应萨婆若心。内外所有布施共一切众生。回向阿耨多罗三藐三菩提。用无所得故。须菩提。是名菩萨摩诃萨檀波罗蜜。云何名尸罗波罗蜜。须菩提。菩萨摩诃萨以应萨婆若心。自行十善道亦教他行十善道。用无所得故。是名菩萨摩诃萨不着尸罗波罗蜜。云何名羼提波罗蜜。须菩提。菩萨摩诃萨以应萨婆若心。自具足忍辱亦教他行忍辱。用无所得故。是名菩萨摩诃萨羼提波罗蜜。云何名毗梨耶波罗蜜。须菩提。菩萨摩诃萨以应萨婆若心。行五波罗蜜勤修不息。亦安立一切众生于五波罗蜜。用无所得故。是名菩萨摩诃萨毗梨耶波罗蜜。云何名禅波罗蜜。须菩提菩萨摩诃萨以应萨婆若心。自以方便入诸禅不随禅生。亦教他令入诸禅。用无所得故。是名菩萨摩诃萨禅波罗蜜。云何名般若波罗蜜。须菩提。菩萨摩诃萨以应萨婆若心。不着一切法。亦观一切法性。用无所得故。亦教他不着一切法亦观一切法性。用无所得故。是名菩萨摩诃萨般若波罗蜜。须菩提。是为菩萨摩诃萨摩诃衍。复次须菩提。菩萨摩诃萨复有摩诃衍。所谓内空外空内外空空空大空第一义空有为空无为空毕竟空无始空散空性空自相空诸法空不可得空无法空有法空无法有法空。须菩提白佛言。何等为内空。佛言。内法名眼耳鼻舌身意。眼眼空非常非灭故。何以故。性自尔。耳耳空鼻鼻空舌舌空身身空意意空非常非灭故。何以故。性自尔。是名内空。何等为外空。外法名色。声香味触法。色色空非常非灭故。何以故性自尔。声声空香香空味味空触触空法法空非常非灭故。何以故。性自尔。是名外空。何等为内外空。内外法名内六入外六入。内法内法空非常非灭故。何以故。性自尔。外法外法空非常非灭故。何以故。性自尔。是名内外空。何等为空空。一切法空。是空亦空。非常非灭故。何以故。性自尔。是名空空。何等为大空。东方东方空非常非灭故。何以故。性自尔。南西北方四维上下南西北方四维上下空非常非灭故。何以故。性自尔。是名大空。何等为第一义空。第一义名涅槃。涅槃涅槃空非常非灭故。何以故。性自尔。是名第一义空。何等为有为空。有为法名欲界色界无色界。欲界欲界空色界色界空无色界无色界空非常非灭故。何以故。性自尔。是名有为空。何等为无为空。无为法名为无生相无住相无灭相。无为法无为法空非常非灭故。何以故。性自尔。是名无为空。何等为毕竟空。毕竟名诸法至竟不可得。非常非灭故。何以故。性自尔。是名毕竟空。何等为无始空。若法初来处不可得。非常非灭故。何以故。性自尔。是名无始空何等为散空。散名诸法无灭。非常非灭故。何以故。性自尔。是名散空。何等为性空。一切法性若有为法性若无为法性。是性非声闻辟支佛所作。非佛所作亦非余人所作。是性性空非常非灭故。何以故。性自尔。是名性空。何等为自相空自相名色坏相受受相想取相行作相识识相。如是等有为法无为法各各自相空。非常非灭故。何以故。性自尔。是名自相空。何等为诸法空。诸法名色受想行识眼耳鼻舌身意色声香味触法眼界色界眼识界乃至意界法界意识界。是诸法诸法空非常非灭故。何以故。性自尔。是为诸法空。何等为不可得空。求诸法不可得。是不可得空非常非灭故。何以故。性自尔。是名不可得空。何等为无法空。若法无是亦空。非常非灭故。何以故。性自尔。是名无法空。何等为有法空。有法名诸法和合中有自性相。是有法空非常非灭故。何以故。性自尔。是名有法空。何等为无法有法空。诸法中无法。诸法和合中有自性相。是无法有法空。非常非灭故。何以故。性自尔。是名无法有法空

复次须菩提。法法相空。无法无法相空。自法自法相空。他法他法相空。何等名法法相空。法名五众五众空。是名法法相空。何等名无法无法相空。无法名无为法是名无法无法相空。何等名自法自法空。诸法自法空。是空非智作非见作。是名自法自法空。何等名他法他法空。若佛出若佛未出。法住法相法位法性如实际过此诸法空。是名他法他法空。是名菩萨摩诃萨摩诃衍

【论】问曰。是经名为般若波罗蜜。又佛命须菩提。为菩萨说般若波罗蜜。须菩提应问般若波罗蜜。佛亦应答般若波罗蜜。今须菩提。何以乃问摩诃衍。佛亦答摩诃衍。答曰。般若波罗蜜摩诃衍一义但名字异。若说般若波罗蜜。说摩诃衍无咎。摩诃衍名佛道行。是法得至佛。所谓六波罗蜜。六波罗蜜中第一。大者般若波罗蜜。如后品佛种种说大因缘。若说般若波罗蜜则摄六波罗蜜。若说六波罗蜜则具说菩萨道。所谓从初发意乃至得佛。譬如王来必有营从。虽不说从者当知必有。摩诃衍亦如是。菩萨初发意所行。为求佛道故。所修集善法随可度众生所说种种法。所谓本起经。断一切众生疑经。华手经。法华经。云经。大云经。法云经弥勒问经。六波罗蜜经。摩诃般若波罗蜜经。如是等无量无边阿僧祇经。或佛说或化佛说。或大菩萨说或声闻说。或诸得道天说。是事和合皆名摩诃衍。此诸经中般若波罗蜜最大故。说摩诃衍。即知已说般若波罗蜜。诸余助道法无般若波罗蜜和合。则不能至佛。以是故。一切助道法皆是般若波罗蜜。如后品中。佛语须菩提。汝说摩诃衍不异般若波罗蜜。问曰。若尔者初何以不先说摩诃衍。答曰。我上说般若波罗蜜最大故应先说。又佛意欲说摩诃般若波罗蜜。放大光明。十方诸菩萨各自问佛。今何以有是光明。诸佛各答言。娑婆世界有佛。名释迦牟尼。欲说般若波罗蜜。彼诸菩萨及诸天人和合而来。舍利弗问佛。世尊。云何菩萨摩诃萨欲知一切法习行般若波罗蜜。又佛初品中种种赞般若波罗蜜功德。若欲得是者当学般若波罗蜜。有如是等因缘故。应初说般若波罗蜜。佛命须菩提。汝为诸菩萨说般若波罗蜜。须菩提谦言。菩萨空但有名。后言。能如是解了知菩萨相。即是行般若波罗蜜。既知是已。问菩萨句义。次有摩诃萨义。摩诃萨义中有大庄严摩诃衍。如勇夫虽有种种器杖庄严不乘驶马则无能为。是大乘天竺语名摩诃衍。诸佛断法爱故。又明般若波罗蜜义无异故佛不诃。以是故。须菩提更作异名问摩诃衍。问曰。如摩诃衍序中说。从初发心乃至佛道。为佛道故集一切善法。皆名摩诃衍。今何以但说六波罗蜜为摩诃衍。答曰。如先说般若波罗蜜则说六波罗蜜。说六波罗蜜则摄一切善法。以是故不应作是问。诸善法多。何以但说六波罗蜜。复次摩诃衍初发心作愿。乃至后方便等六波罗蜜。是诸法虽不名为波罗蜜。然义皆在六波罗蜜中。如初发心作愿。大悲等心力大故。名毗梨耶波罗蜜。舍小利取大乘名般若波罗蜜。方便即是智慧。智慧淳净故变名方便。教化众生净佛世界等皆在六波罗蜜中。随义相摄。问曰。若尔者后何以更说十八空百八三昧等名摩诃衍。答曰。六波罗蜜是摩诃衍体。但后广分别其义。如十八空四十二字等是般若波罗蜜义。百八三昧等是禅波罗蜜义。以是故初说六波罗蜜。问曰。何以故正说六波罗蜜不多不少。答曰。佛为法王。随众生可度。或时略说一二三四。或时广说。如贤劫经八万四千波罗蜜。复次六道众生皆受身心苦恼。如地狱众生拷掠苦。畜生中相残害苦。饿鬼中饥饿苦。人中求欲苦。天上离所爱欲时苦。阿修罗道斗诤苦。菩萨生大悲心。欲灭六道众生苦故。生六波罗蜜。以是故说六波罗蜜不多不少。问曰。檀波罗蜜有种种相。此中佛何以但说五相。所谓用萨婆若相应心舍内外物。是福共一切众生。回向阿耨多罗三藐三菩提。用无所得故。何以不说大慈悲心供养诸佛及神通布施等。答曰。是五种相中摄一切布施。相应萨婆若心布施者。此缘佛道依佛道。舍内外者。则舍一切诸烦恼。共众生者。则是大悲心。回向者。以此布施但求佛道不求余报。用无所得故者。得诸法实相般若波罗蜜气分故。檀波罗蜜非诳非倒亦无穷尽。问曰。若尔者则不须五种相。但说萨婆若相应心则足。答曰。此事可尔。但以众生不知云何应萨婆若心布施义故。是故以四事分别其义。应萨婆若心者。以菩萨心求佛萨婆若。作缘作念系心持是布施。欲得萨婆若果。不求今世因缘名闻恩分等。亦不求后世转轮圣王天王富贵处。为度众生故不求涅槃。但欲具一切智等诸佛法。为尽一切众生苦故。是名应萨婆若心。内外物者。内名头脑骨髓血肉等难舍故在初说。外物者国土妻子七宝饮食等。共一切众生者。是布施福德果报。与一切众生共用。譬如大家种谷与人共食。菩萨福德果报一切众生皆来依附。譬如好果树众鸟归集。回向者。是福德边不求余报。但求阿耨多罗三藐三菩提。问曰。先言应萨婆若心。后言回向。有何等异。答曰。应萨婆若心为起诸福德因缘。回向者不求余报但求佛道。复次萨婆若相应心。为应阿耨多罗三藐三菩提故。施如先义说。萨婆若为主。一切功德皆为萨婆若。赞佛智慧有二种。一者无上正智名阿耨多罗三藐三菩提。二者一切种智名萨婆若。用无所得者。以般若波罗蜜心布施。顺诸法实相而不虚诳。如是等说檀波罗蜜义。问曰。尸罗波罗蜜则总一切戒法。譬如大海总摄众流。所谓不饮酒。不过中食。不杖加众生等。是事十善中不摄。何以但说十善。答曰。佛总相说六波罗蜜。十善为总相戒。别相有无量戒。不饮酒不过中食入不贪中。杖不加众生等入不嗔中。余道随义相从。戒名身业口业。七善道所摄。十善道及初后。如发心欲杀。是时作方便。恶口鞭打系缚斫刺乃至垂死皆属于初。死后剥皮食啖割截欢喜皆名后。夺命是本体。此三事和合总名杀不善道。以是故知。说十善道则摄一切戒。复次是菩萨生慈悲心。发阿耨多罗三藐三菩提。布施利益众生。随其所须皆给与之。持戒不恼众生。不加诸苦常施无畏。十善业道为根本。余者是不恼众生远因缘。戒律为今世取涅槃故。淫欲虽不恼众生。心系缚故为大罪。以是故戒律中淫欲为初。白衣不杀戒在前。为求福德故。菩萨不求今世涅槃。于无量世中往返生死修诸功德。十善道为旧戒。余律仪为客。复次若佛出好世则无此戒律。如释迦文佛。虽在恶世十二年中亦无此戒。以是故知是客。复次有二种戒。有佛时或有或无。十善有佛无佛常有。复次戒律中戒虽复细微忏则清净。犯十善戒虽复忏悔。三恶道罪不除。如比丘杀畜生。虽复得悔罪报犹不除。如是等种种因缘故。但说十善业道。亦自行亦教他人。名为尸罗波罗蜜。十善道七事是戒。三为守护故。通名为尸罗波罗蜜。余波罗蜜亦如是。随义分别。如初品中六波罗蜜论议广说。是经名般若波罗蜜。般若波罗蜜名舍离相。以是故。一切法中皆用无所得故。问曰若用有所得集诸善法。犹尚为难。何况用无所得。答曰。若得是无所得智慧。是时能妨善行或生邪疑。若不得是无所得智慧。是时无所妨。亦不生邪疑。佛亦不称著心取相行诸善道。何以故。虚诳住世间终归于尽。若着心修善破者则易。若着空生悔还失是道。譬如火起草中得水则灭。若水中生火则无物能灭。初习行着心取相菩萨修福德。如草生火易可得灭。若体得实相菩萨以大悲心行众行难可得破。如水中生火无能灭者。以是故。虽用无所得心行众行。心亦不弱不生疑悔。是名略说六波罗蜜义。广说如初品中。一一波罗蜜皆具足十八空者。六波罗蜜中说般若波罗蜜义不着诸法。所以者何以十八空故。十八空论议如初品中。佛告舍利弗。菩萨摩诃萨欲住十八空。当学般若波罗蜜。彼义应此中广说。问曰。十八空内空等后皆言非常非灭故。此义云何。答曰。若人不习此空必堕二边。若常若灭。所以者何。若诸法实有则无灭义堕常中。如人出一舍入一舍。眼虽不见不名为无。诸法亦尔。从未来世入现在世。现在世入过去世。如是则不灭。行者以有为患用空破有。心复贵空。着于空者则堕断灭。以是故。行是空以破有。亦不着空。离是二边以中道行。是十八空以大悲心为度众生。是故十八空后皆言非常非灭。是名摩诃衍。若异此者则是戏论狂人。于佛法中空无所得。如人于珍宝聚中取水精珠。眼见虽好价无所直。问曰。若十八空已摄诸空。何以更说四空。答曰。十八空中现空尽摄诸佛有二种说法。或初略后广。或初广后略。初略后广为解义故。初广后略为易持故。或为后会众生略说其要。或以偈颂。今佛前广说十八空。后略说四空相。法法相空者。一切法中法相不可得。如色中色相不可得。复次法中不生法故。名为法法空。无法无法空者。无为法名无法。何以故。相不可得故。问曰。佛以三相说无为法。云何言无相。答曰不然。破生故言无生。破住故言无住。破灭故言无灭。皆从生住灭边有此名。更无别。无生无灭法是名无法无法空。是义如无为空中说。自法自法空者。自法名诸法自性。自性有二种。一者如世间法地坚性等。二者圣人知如法性实际。此法空。所以者何。不由智见知故有二性空。如先说。问曰。如法性实际无为法中已摄。何以复更说。答曰。观时分别说五众实相法性如实际。又非空智慧观。故令空性自尔。问曰。如色是自法识为他法。此中何以说如法性实际有佛无佛常住过是名为他法空。答曰。有人未善断见结故处处生着。是人闻是如法性实际。谓过是已更有余法。以是故说过如法性实际亦空

大智度论卷第四十六大智度论释摩诃衍品第十八之余(卷四十七)

        龙树菩萨造

        后秦龟兹国三藏鸠摩罗什译

【经】复次须菩提。菩萨摩诃萨摩诃衍。所谓名首楞严三昧。宝印三昧。师子游戏三昧。妙月三昧。月幢相三昧。出诸法三昧。观顶三昧。毕法性三昧。毕幢相三昧。金刚三昧。入法印三昧。三昧王安立三昧。放光三昧。力进三昧。高出三昧。必入辩才三昧。释名字三昧。观方三昧。陀罗尼印三昧。无诳三昧。摄诸法海三昧。遍覆虚空三昧。金刚轮三昧。断宝三昧。能照三昧。不求三昧。无住三昧。无心三昧。净灯三昧。无边明三昧。能作明三昧。普照明三昧。坚净诸三昧三昧。无垢明三昧。欢喜三昧。电光三昧。无尽三昧。威德三昧。离尽三昧。不动三昧。不退三昧。日灯三昧。月净三昧。净明三昧。能作明三昧。作行三昧。知相三昧。如金刚三昧。心住三昧。普明三昧。安立三昧。宝聚三昧。妙法印三昧。法等三昧。断喜三昧。到法顶三昧。能散三昧。分别诸法句三昧。字等相三昧。离字三昧。断缘三昧。不坏三昧。无种相三昧。无处行三昧。离曚昧三昧。无去三昧。不变异三昧。度缘三昧。集诸功德三昧。住无心三昧。妙净华三昧。觉意三昧。无量辩三昧。无等等三昧。度诸法三昧。分别诸法三昧。散疑三昧。无住处三昧。一庄严三昧。生行三昧。一行三昧。不一行三昧。妙行三昧。达一切有底散三昧。入名语三昧。离音声字语三昧。然炬三昧。净相三昧。破相三昧。一切种妙足三昧。不喜苦乐三昧。无尽相三昧。陀罗尼三昧。摄诸邪正相三昧。灭憎爱三昧。逆顺三昧。净光三昧。坚固三昧。满月净光三昧。大庄严三昧。能照一切世三昧。三昧等三昧。摄一切有诤无诤三昧。不乐一切住处三昧。如住定三昧。坏身衰三昧。坏语如虚空三昧。离着虚空不染三昧。云何名首楞严三昧。知诸三昧行处。是名首楞严三昧。云何名宝印三昧。住是三昧能印诸三昧。是名宝印三昧。云何名师子游戏三昧。住是三昧能游戏诸三昧中如师子。是名师子游戏三昧。云何名妙月三昧。住是三昧能照诸三昧如净月。是名妙月三昧。云何名月幢相三昧。住是三昧能持诸三昧相。是名月幢相三昧。云何名出诸法三昧。住是三昧能出生诸三昧。是名出诸法三昧。云何名观顶三昧。住是三昧能观诸三昧顶。是名观顶三昧。云何名毕法性三昧。住是三昧决定知法性。是名毕法性三昧。云何名毕幢相三昧。住是三昧能持诸三昧幢。是名毕幢相三昧。云何名金刚三昧。住是三昧能破诸三昧。是名金刚三昧。云何名入法印三昧。住是三昧入诸法印。是名入法印三昧。云何名三昧王安立三昧。住是三昧一切诸三昧中安立住如王。是名三昧王安立三昧。云何名放光三昧。住是三昧。能放光照诸三昧。是名放光三昧。云何名力进三昧。住是三昧于诸三昧能作力势。是名力进三昧。云何名高出三昧。住是三昧能增长诸三昧。是名高出三昧。云何名必入辩才三昧。住是三昧能辩说诸三昧。是名必入辩才三昧。云何名释名字三昧。住是三昧。能释诸三昧名字。是名释名字三昧。云何名观方三昧。住是三昧能观诸三昧方。是名观方三昧。云何名陀罗尼印三昧。住是三昧持诸三昧印。是名陀罗尼印三昧。云何名无诳三昧。住是三昧于诸三昧不欺诳。是名无诳三昧。云何名摄诸法海三昧。住是三昧能摄诸三昧如大海水。是名摄诸法海三昧。云何名遍覆虚空三昧。住是三昧遍覆诸三昧如虚空。是名遍覆虚空三昧。云何名金刚轮三昧。住是三昧能持诸三昧。分是名金刚轮三昧。云何名断宝三昧。住是三昧断诸三昧烦恼垢。是名断宝三昧。云何名能照三昧。住是三昧能以光明显照诸三昧。是名能照三昧。云何名不求三昧。住是三昧无法可求。是名不求三昧。云何名无住三昧。住是三昧一切三昧中不见法住。是名无住三昧。云何名无心三昧。住是三昧心心数法不行。是名无心三昧。云何名净灯三昧。住是三昧于诸三昧中作明如灯。是名净灯三昧。云何名无边明三昧。住是三昧与诸三昧作无边明。是名无边明三昧。云何名能作明三昧。住是三昧即时能为诸三昧作明。是名能作明三昧。云何名普照明三昧。住是三昧即能照诸三昧。门是名普照明三昧。云何名坚净诸三昧三昧。住是三昧能坚净诸三昧相。是名坚净诸三昧三昧。云何名无垢明三昧。住是三昧能除诸三昧垢。亦能照一切三昧。是名无垢明三昧。云何名欢喜三昧。住是三昧能受诸三昧喜。是名欢喜三昧。云何名电光三昧。住是三昧照诸三昧如电光。是名电光三昧。云何名无尽三昧。住是三昧于诸三昧不见尽。是名无尽三昧。云何名威德三昧。住是三昧于诸三昧威德照然。是名威德三昧。云何名离尽三昧。住是三昧不见诸三昧尽。是名离尽三昧。云何名不动三昧。住是三昧令诸三昧不动不戏。是名不动三昧。云何名不退三昧。住是三昧能不见诸三昧退。是名不退三昧。云何名日灯三昧。住是三昧放光照诸三昧门。是名日灯三昧。云何名月净三昧。住是三昧能除诸三昧闇。是名月净三昧。云何名净明三昧。住是三昧于诸三昧得四无碍智。是名净明三昧。云何名能作明三昧。住是三昧于诸三昧门能作明。是名能作明三昧。云何名作行三昧。住是三昧能令诸三昧各有所作。是名作行三昧。云何名知相三昧。住是三昧见诸三昧知相。是名知相三昧。云何名如金刚三昧。住是三昧能贯达诸法亦不见达。是名如金刚三昧。云何名心住三昧。住是三昧心不动不转不恼。亦不念有是心。是名心住三昧。云何名普明三昧。住是三昧普见诸三昧明。是名普明三昧。云何名安立三昧。住是三昧于诸三昧安立不动。是名安立三昧。云何名宝聚三昧。住是三昧普见诸三昧如见宝聚。是名宝聚三昧。云何名妙法印三昧。住是三昧能印诸三昧。以无印印故。是名妙法印三昧。云何名法等三昧。住是三昧观诸法等无法不等。是名法等三昧。云何名断喜三昧。住是三昧断一切法中喜。是名断喜三昧。云何名到法顶三昧。住是三昧灭诸法闇。亦在诸三昧上。是名到法顶三昧。云何名能散三昧。住是三昧中能破散诸法。是名能散三昧。云何名分别诸法句三昧。住是三昧能分别诸三昧诸法句。是名分别诸法句三昧。云何名字等相三昧。住是三昧得诸三昧字等。是名字等相三昧。云何名离字三昧。住是三昧诸三昧中乃至不见一字。是名离字三昧。云何名断缘三昧。住是三昧断诸三昧缘。是名断缘三昧。云何名不坏三昧。住是三昧不得诸法变异。是名不坏三昧。云何名无种相三昧。住是三昧不见诸法种种。是名无种相三昧。云何名无处行三昧。住是三昧不见诸三昧处。是名无处行三昧。云何名离曚昧三昧。住是三昧离诸三昧微闇。是名离蒙昧三昧。云何名无去三昧。住是三昧不见一切三昧去相。是名无去三昧。云何名不变异三昧。住是三昧不见诸三昧变异相。是名不变异三昧。云何名度缘三昧。住是三昧度一切三昧缘境界。是名度缘三昧。云何名集诸功德三昧。住是三昧集诸三昧功德。是名集诸功德三昧。云何名住无心三昧。住是三昧于诸三昧心不入。是名住无心三昧。云何名净妙华三昧。住是三昧令诸三昧得净妙如华。是名净妙华三昧。云何名觉意三昧。住是三昧诸三昧中得七觉分。是名觉意三昧。云何名无量辩三昧。住是三昧于诸法中得无量辩。是名无量辩三昧。云何名无等等三昧。住是三昧诸三昧中得无等等相。是名无等等三昧。云何名度诸法三昧。住是三昧度一切三昧。是名度诸法三昧。云何名分别诸法三昧。住是三昧诸三昧及诸法分别见。是名分别诸法三昧。云何名散疑三昧。住是三昧得散诸法疑。是名散疑三昧。云何名无住处三昧。住是三昧不见诸法住处。是名无住处三昧。云何名一庄严三昧。住是三昧终不见诸法二相。是名一庄严三昧。云何名生行三昧。住是三昧不见诸行生。是名生行三昧。云何名一行三昧。住是三昧不见诸三昧此岸彼岸。是名一行三昧。云何名不一行三昧。住是三昧不见诸三昧一相。是名不一行三昧。云何名妙行三昧。住是三昧不见诸三昧二相。是名妙行三昧。云何名达一切有底散三昧。住是三昧入一切有一切三昧。智慧通达亦无所达。是名达一切有底散三昧。云何名入名语三昧。住是三昧入一切三昧名语。是名入名语三昧。云何名离音声字语三昧。住是三昧不见诸三昧音声字语。是名离音声字语三昧。云何名然炬三昧。住是三昧威德照明如炬。是名然炬三昧。云何名净相三昧。住是三昧净诸三昧相。是名净相三昧。云何名破相三昧。住是三昧不见诸三昧相。是名破相三昧。云何名一切种妙足三昧。住是三昧一切诸三昧种皆具足。是名一切种妙足三昧。云何名不喜苦乐三昧。住是三昧不见诸三昧苦乐。是名不喜苦乐三昧。云何名无尽相三昧。住是三昧不见诸三昧尽。是名无尽相三昧。云何名陀罗尼三昧。住是三昧能持诸三昧。是名陀罗尼三昧。云何名摄诸邪正相三昧。住是三昧于诸三昧不见邪正相。是名摄诸邪正相三昧。云何名灭憎爱三昧。住是三昧不见诸三昧憎爱。是名灭憎爱三昧。云何名逆顺三昧。住是三昧不见诸法诸三昧逆顺。是名逆顺三昧。云何名净光三昧。住是三昧不得诸三昧明垢。是名净光三昧。云何名坚固三昧。住是三昧不得诸三昧不坚固。是名坚固三昧。云何名满月净光三昧。住是三昧诸三昧满足如月十五日。是名满月净光三昧。云何名大庄严三昧。住是三昧大庄严成就诸三昧。是名大庄严三昧。云何名能照一切世三昧。住是三昧诸三昧及一切法能照。是名能照一切世三昧。云何名三昧等三昧。住是三昧于诸三昧不得定乱相。是名三昧等三昧。云何名摄一切有诤无诤三昧。住是三昧能使诸三昧不分别有诤无诤。是名摄一切有诤无诤三昧。云何名不乐一切住处三昧。住是三昧不见诸三昧依处。是名不乐一切住处三昧。云何名如住定三昧。住是三昧不过诸三昧如相。是名如住定三昧。云何名坏身衰三昧。住是三昧不得身相。是名坏身衰三昧。云何名坏语如虚空三昧。住是三昧不见诸三昧语业如虚空。是名坏语如虚空三昧。云何名离着虚空不染三昧。住是三昧见诸法如虚空无碍亦不染。是名离着虚空不染三昧。须菩提。是名菩萨摩诃萨摩诃衍

【论】释曰。上以十八空释般若波罗蜜。今以百八三昧释禅波罗蜜。百八三昧佛自说其义是时人利根故皆得信解。今则不然。论者重释其义令得易解

首楞严三昧者。秦言健相。分别知诸三昧行相多少深浅。如大将知诸兵力多少。复次菩萨得是三昧。诸烦恼魔及魔人无能坏者。譬如转轮圣王主兵宝将所往至处无不降伏。宝印三昧者。能印诸三昧。于诸宝中法宝是实宝。今世后世乃至涅槃能为利益。如经中说。佛语比丘。为汝说法。所说法者。所谓法印。法印即是宝印。宝印即是三解脱门。复次有人言。三法印名为宝印三昧。一切法无我。一切作法无常。寂灭涅槃。是三法印一切人天无能如法坏者。入是三昧能三种观诸法。是名宝印。复次般若波罗蜜是宝。是相应三昧名印。是名宝印。师子游戏三昧者。菩萨得是三昧。于一切三昧中出入迟速皆得自在。譬如众兽戏时若见师子率皆怖慑。师子戏时自在无所畏难。复次师子戏时于诸群兽强者则杀伏者则放。菩萨亦如是。得是三昧于诸外道强者破之信者度之。复次师子游戏者。如初品中说。菩萨入是三昧中。地为六反震动。令一切十方世界地狱汤冷盲者得视聋者得听等。妙月三昧者。如月满清净无诸翳障能除夜闇。此三昧亦如是。菩萨入是三昧。能除诸法邪见无明闇蔽等。月幢相三昧者。如大军将幢以宝作月像。见此幢相人皆随从。菩萨入是三昧中。诸法通达无碍皆悉随从。出诸法三昧者。菩萨得是三昧。令诸三昧增长。譬如时雨林木茂盛。观顶三昧者。入是三昧中能遍见诸三昧。如住山顶悉见众物。毕法性三昧者。法性无量无二难可执持。入是三昧必能得定相。譬如虚空无能住者。得神足力则能处之。毕幢相三昧者。入是三昧则于诸三昧最为尊长。譬如军将得幢表其大相。金刚三昧者。譬如金刚无物不陷。此三昧亦如是。于诸法无不通达。令诸三昧各得其用。如车磲玛瑙琉璃唯金刚能穿。入法印三昧者。如人入安隐国有印得入无印不得入。菩萨得是三昧。能入诸法实相中。所谓诸法毕竟空。三昧王安立三昧者。譬如大王安住正殿召诸群臣皆悉从命。菩萨入三昧王。放大光明请召十方无不悉集。又遣化佛遍至十方。安立者。譬如国王安处正殿身心坦然无所畏惧。放光三昧者。常修火一切入故生神通力。随意放种种色光。随众生所乐。若热若冷若不热不冷。照诸三昧者。光明有二种。一者色光。二者智慧光。住是三昧中照诸三昧。无有邪见无明等。力进三昧者。先于诸法中得信等五种力。然后于诸三昧中得自在力。又虽住三昧而常能神通变化度诸众生。高出三昧者。菩萨入是三昧。所有福德智慧皆悉增长。诸三昧性从心而出。必入辩才三昧者。四无碍中辞辩相应三昧。菩萨得是三昧。悉知众生语言次第。及经书名字等悉能分别无碍。释名字三昧者。诸法虽空以名字辩诸法义令人得解。观方三昧者。于十方众生以慈悲怜愍平等心观。复次方者。循道理名为得方。是三昧力故。于诸三昧得其道理。出入自在无碍。陀罗尼印三昧者。得是三昧者。能得分别诸三昧皆有陀罗尼。无诳三昧者。有三昧生爱恚无明邪见等。是三昧于诸三昧都无迷闷之事。摄诸法海三昧者。如一切众流皆归于海。三乘法皆入是三昧中亦如是。又诸余三昧皆入是三昧中。如四禅四无色中摄诸解脱九次第等皆入其中。遍覆虚空三昧者。是虚空无量无边。是三昧力悉能遍覆虚空。或结加趺坐。或放光明。或以音声充满其中。金刚轮三昧者。如真金刚轮所往无碍。得是三昧者。于诸法中所至无碍。复次能分别诸三昧分界故名轮。轮分界也。断宝三昧者。如有宝能净治诸宝。是三昧亦如是。能除诸三昧烦恼垢。五欲垢易遣。诸三昧垢难却。能照三昧者。得是三昧能以十种智慧照了诸法。譬如日出照阎浮提事皆显了。不求三昧者。观诸法如幻化。三界爱断故都无所求。无住三昧者。是三昧名无住三昧。住是三昧中观诸法。念念无常无有住时。无心三昧者。即是灭尽定或无想定。何以故。佛自说因缘。入是三昧中诸心心数法不行。净灯三昧者。灯名智慧灯。诸烦恼名垢。离是垢慧则清净。无边明三昧者。无边名无量无数。明有二种。一者度众生故身放光明。二者分别诸法总相别相故智慧光明。得是三昧。能照十方无边世界及无边诸法。能作明三昧者。于诸法能为作明。如闇中然炬。普照明三昧者。如转轮圣王宝珠于军众外四边各照一由旬。菩萨得是三昧。普照诸法种种门。坚净诸三昧三昧者。菩萨得是三昧力故。令诸三昧清净坚牢。无垢明三昧者。三解脱门相应三昧。得是三昧。离一切三昧垢。离一切无明爱等。亦能照一切诸三昧。欢喜三昧者。得是三昧于诸法生欢喜乐。何者是。有人言。初禅是如佛说有四修定。一者修是三昧得现在欢喜乐。二者修定得知见。见众生生死。三者修定得智慧分别。四者修定得漏尽。复次得是三昧。生无量无边法欢喜乐。电光三昧者。如电暂现行者得路。得是三昧者无始世界来失道还得。无尽三昧者。得是三昧灭诸法无常等相。即入不生不灭。威德三昧者。菩萨得是三昧威德庄严。离尽三昧者。菩萨得是三昧。无量阿僧祇劫善本功德必得果报不失故。不动三昧者。有人言。第四禅是不动。欲界中五欲故动。初禅中觉观故动。二禅中喜多故动。三禅中乐多故动。四禅离出入息无诸动相故不动。有人言。四无色定是不动。离诸色故。有人言。灭尽定是不动。离心心数法故。有人言。知诸法实相毕竟空智慧相应三昧故不动。得是三昧已。于一切三昧一切法都不戏论。不退三昧者。住是三昧不见诸三昧退。论者言。菩萨住是三昧常不退转。即是阿鞞跋致智慧相应三昧。不退者不堕顶。如不堕顶义中说。日灯三昧者。得是三昧。能照一切诸法种种门及诸三昧。譬如日出能照一切阎浮提。月净三昧者。如月从十六日渐减至三十日都尽。凡夫人亦如是。诸善功德渐渐减尽堕三恶道。如月从一日渐渐增长至十五日光明清净。菩萨亦如是。得是三昧。从发心来世世渐增善根。乃至得无生法忍授记。智慧清净利益众生。又能破诸三昧中无明。净明三昧者。明名慧垢为碍。得是三昧者于诸法无障碍。以是故佛于此说住是三昧中得四无碍智。问曰。佛何以独于此中说四无碍智。答曰。于三昧中无觉观心。所可乐说与定相违。是事为难。此三昧力故得四无碍智。四无碍智义如先说。能作明三昧者。明即是智慧。诸智慧中般若智慧最第一。是般若相应三昧。能作明作行三昧者。得是三昧力。能发起先所得诸三昧。知相三昧者。得是三昧见一切诸三昧中有实智慧相。如金刚三昧者。得是三昧以智慧能通达一切诸法。亦不见通达。用无所得故。问曰。三种三昧何以皆言金刚。答曰。初言金刚。中言金刚轮。后言如金刚。如金刚三昧。佛说能贯穿一切诸法亦不见。是金刚三昧能通达诸三昧。金刚轮三昧者。得是三昧即能持诸三昧轮。是皆佛自说义。论者言。如金刚三昧者。能破一切诸烦恼结使无有遗余。譬如释提桓因手执金刚破阿修罗军。即是学人末后心。从是心次第得三种菩提。声闻菩提辟支佛菩提佛无上菩提。金刚三昧者。能破一切诸法。入无余涅槃更不受有。譬如真金刚能破诸山令灭尽无余。金刚轮者。此三昧能破一切诸法无遮无碍。譬如金刚轮转时无所不破无所障碍。复次初金刚。二金刚轮。三如金刚。名字分别佛说其义亦异。论者释其因缘亦异。不应致难。心住三昧者。心相轻疾远逝无形。难制难持常是动相。如猕猴子。又如掣电。亦如蛇舌。得是三昧故能摄令住。乃至天欲心不动转。何况人欲普明三昧者。得是三昧于一切法见光明相无黑闇相。如昼所见夜亦如是。如见前见后亦尔。如见上见下亦尔。心中无碍。修是三昧故得天眼通。普见光明了了无碍。善修是神通故得成慧眼。普照诸法所见无碍。安立三昧者。得是三昧者一切诸功德善法中安立牢固。如须弥山在大海安立不动。宝聚三昧者。得是三昧所有国土悉成七宝。问曰。此是肉眼所见。禅定所见。答曰。天眼肉眼皆能见。何以故。外六尘不定故。行者常修习禅定。是故能转本相。妙法印三昧者。妙法名诸佛菩萨深功德智慧。得是三昧得诸深妙功德智慧。法等三昧者。等有二种。众生等法等。法等相应三昧名为法等。断喜三昧者。得是三昧观诸法无常苦空无我不净等。心生厌离。十想中一切世间不可乐想相应三昧是到法顶三昧者。法名菩萨法。所谓六波罗蜜。到般若波罗蜜中得方便力到法山顶。得是三昧能住是法山顶。诸无明烦恼不能动摇。能散三昧者。得是三昧能破散诸法。散空相应三昧是。分别诸法句三昧者。得是三昧能分别一切诸法语言字句。为众生说辞无滞碍。乐说相应三昧是。字等相三昧者。得是三昧观诸字诸语皆悉平等。呵詈赞叹无有憎爱。离字三昧者。得是三昧不见字在义中。亦不见义在字中。断缘三昧者。得是三昧。若内若外。乐中不生喜。苦中不生嗔。不苦不乐中不生舍心。于此三受远离不着。心则归灭。心若灭缘亦断。不坏三昧者。缘法性毕竟空相应三昧戏论不能破。无常不能转。先已坏故。无种三昧者。得是三昧不见诸法种种相。但见一相。所谓无相。无处行三昧者。得是三昧知三毒火然三界故心不依止。涅槃毕竟空故亦不依止。离曚昧三昧者。得是三昧于诸三昧中微翳无明等悉皆除尽。无去三昧者。得是三昧不见一切法来去相。不变异三昧者。得是三昧观一切诸法。因不变为果。如乳不变作酪。诸法皆住自相不动故。度缘三昧者。得是三昧于六尘中诸烦恼尽灭。度六尘大海。亦能过一切三昧缘生智慧。集诸功德三昧者。得是三昧集诸功德。从信至智慧。初夜后夜修习不息。如日月运转初不休息。住无心三昧者。入是三昧中不随心但随智慧。至诸法实相中住。净妙华三昧者。如树华敷开令树严饰。得是三昧诸三昧中开诸功德华以自庄严。觉意三昧者。得是三昧令诸三昧变成无漏与七觉相应。譬如石汁一斤能变千斤铜为金。无量辩三昧者。即是乐说辩。得是三昧力故。乃至乐说一句无量劫而不穷尽。无等等三昧者。得是三昧观一切众生皆如佛。观一切法皆同佛法无等等。般若波罗蜜相应是。度诸法三昧者。得是三昧入三解脱门。过出三界度三乘众生。分别诸法三昧者。即是分别慧相应三昧。得是三昧分别诸法善不善有漏无漏有为无为等相。散疑三昧者。有人言。即是见谛道中无相三昧疑结。见谛智相应三昧断故。有人言。菩萨无生法忍相应三昧是。时一切法中疑网悉断。见十方诸佛。得一切诸法实相。有人言。无碍解脱相应三昧。是诸佛得是三昧已。于诸法中无疑无近无远皆如观掌中。无住处三昧者。即是无受智慧相应三昧。得是三昧不见一切诸法定有住处。一庄严三昧者。得是三昧。观诸法皆一。或一切法有相故一。或一切法无故一。或一切法空故一。如是等无量皆一。以一相智慧庄严是三昧。故言一庄严。生行三昧者。行名观。得是三昧。能观种种行相入相住相出相。又是行皆空。亦不可见。一行三昧者。是三昧常一行。毕竟空相应三昧中更无余行次第。如无常行中次有苦行苦行中次有无我行。又菩萨于是三昧不见此岸不见彼岸。诸三昧入相为此岸。出相为彼岸。初得相为此岸。灭相为彼岸。不一行三昧者。与上一行相违者是。所谓诸余观行。妙行三昧者。即是毕竟空相应三昧。乃至不见不二相。一切戏论不能破。达一切有底散三昧者。有名三有。底者非有想非无想。以难到故名底。达者以无漏智慧。乃至离非有想非无想。入无余涅槃。三界五众散灭。复次菩萨得是不生不灭智慧。一切诸有通达散坏皆无所有。入名语三昧者。得是三昧识一切众生一切物一切法名字。亦能以此名字语化人。一切语言无不解了。皆有次第。离音声字语三昧者。得是三昧观一切诸法。皆无音声语言常寂灭相。然炬三昧者。如捉炬夜行不堕险处。菩萨得是三昧。以智慧炬于诸法中无错无著。净相三昧者。得是三昧能清净具足庄严三十二相。又能如法观诸法总相别相。亦能观诸法无相清净。所谓空无相无作。如相品是中广说。破相三昧者。得是三昧不见一切法相。何况诸三昧相。得是无相三昧。一切种妙足三昧者。得是三昧以诸功德具足庄严。所谓好姓好家好身好眷属禅定智慧皆悉具足清净。不喜苦乐三昧者。得是三昧观世间乐。多过多患虚妄颠倒非可爱乐。观世间苦如病。如箭入身心不喜乐。以一切法虚诳故不求其乐。何以故。异时变为苦。乐尚不喜。何况于苦。无尽相三昧者。得是三昧观一切法无坏无尽。问曰。若尔者云何不堕常边。答曰。如菩萨虽观无常不堕灭中。若观不尽不堕常中。此二相于诸法中皆不可得。有因缘故修行。所谓为罪福不失故。言常离着故言无常。陀罗尼三昧者。得是三昧力故。闻持等诸陀罗尼皆自然得。摄诸邪正相三昧者。得是三昧不见三聚众生。所谓正定邪定不定。都无所弃一心摄取。又于诸法不见定正相定邪相。诸法无定相故。灭憎爱三昧者。得是三昧可喜法中不生爱。可憎法中不生嗔。逆顺三昧者。得是三昧于诸法中逆顺自在。能破诸邪逆众生。能顺可化众生。又离着故破一切法。善根增长故成一切法。亦不见诸法逆顺。是事亦不见。以无所有故。净光三昧者。得是三昧一切法中诸烦恼垢不可得。不可得故诸三昧皆清净。坚固三昧者。有人言。金刚三昧是。坚固不坏故。有人言。金刚非。所以者何。金刚亦易破故。是诸法实相智相应三昧。不可破如虚空。以是故言牢固。满月净光三昧者。得是三昧所言清净无诸错谬。如秋时虚空清净月满光明凉乐可乐无诸可恶。菩萨亦如是。修诸功德故。如月满破无明闇故。净智光明具足灭爱恚等火故。清凉功德具足大利益众生故可乐。大庄严三昧者。见十方如恒河沙等世界。以七宝华香庄严佛处。其中如是等清净庄严。得是三昧故。一时庄严诸功德。又观此庄严空无所有。心无所著。能照一切世间三昧者。得是三昧故。能照三种世间。众生世间住处世间五众世间。三昧等三昧者。得是三昧观诸三昧皆一等。所谓摄心相。是三昧皆得因缘生。有为作法无深浅。得是三昧皆悉平等。是名为等。与余法亦等无异。以是故义中说。一切法中定乱相不可得。摄一切有诤无诤三昧者。得是三昧不见是法如是相是法不如是相。不分别诸法有诤无诤。于一切法中通达无碍。于众生中亦无好丑诤论。但随众生心行而度脱之。得是三昧故。于诸三昧皆随顺不逆不乐。一切住处三昧者。得是三昧不乐住世间。不乐住非世间。以世间无常过故不乐。非世间中无一切法。是大可畏处不应生乐。如住定三昧者。得是三昧故。知一切法如实相。不见有法过是如者。如义如先说。坏身衰三昧者。血肉筋骨等和合故名为身。是身多患。常与饥寒冷热等诤。是名身衰。得是三昧故。以智慧力分分破坏身衰相。乃至不见不可得相。坏语如虚空三昧者。语名内。有风发触七处故有声。依声故有语。观如是语言因缘故。能坏语言。不生我相及以爱憎。有人言。二禅无觉观。是坏语三昧。贤圣默然故。有人言。无色定三昧。彼中无身离一切色故。有人言。但是诸菩萨三昧。能破先世结业因缘不净身而受法身。随可度众生种种现形。离着虚空不染三昧者。菩萨行般若波罗蜜。观诸法毕竟空。不生不灭如虚空无物可喻。钝根菩萨着此虚空。得此三昧故。离着虚空等诸法。亦不染着是三昧。如人没在泥中有人挽出锁脚为奴。如有三昧能离着虚空。而复着此三昧亦如是。今是三昧能离着虚空。亦自离着。问曰。佛多说诸三昧。汝何以但说诸法。答曰。佛多说果报。论者合因缘果报说。譬如人观身不净得不净三昧。身是因缘。三昧是果。又如人观五众无常苦空等。得七觉意三昧。能生八圣道四沙门果。复次佛应适众生故但说一法。论者广说分别诸事。譬如一切有漏皆是苦因。而佛但说爱。一切烦恼灭名灭谛。佛但说爱尽。是菩萨于诸观行中必不疑于诸三昧。未了故。佛但说三昧。论者说诸法。一切三昧皆已在中。是诸三昧末后。皆应言用无所得。以同般若故。如是等无量无边三昧和合。名为摩诃衍

大智度论卷第四十七大智度论释四念处品第十九(卷四十八)

        龙树菩萨造

        后秦龟兹国三藏鸠摩罗什译

【经】佛告须菩提。菩萨摩诃萨摩诃衍。所谓四念处。何等四。须菩提。菩萨摩诃萨内身中循身观亦无身觉。以不可得故。外身中内外身中循身观亦无身觉。以不可得故。勤精进一心除世间贪忧。内受内心内法。外受外心外法。内外受内外心内外法。循法观亦无法觉。以不可得故。勤精进一心除世间贪忧。须菩提。菩萨摩诃萨云何内身中循身观。须菩提。若菩萨摩诃萨行时知行住时知住。坐时知坐。卧时知卧。如身所行如是知。须菩提。菩萨摩诃萨如是内身中循身观。勤精进一心除世间贪忧。以不可得故。复次须菩提。菩萨摩诃萨若来若去视瞻一心。屈申俯仰服僧伽梨执持衣钵。饮食卧息坐立睡觉语默入禅出禅亦常一心。如是须菩提。菩萨摩诃萨行般若波罗蜜。内身中循身观。以不可得故。复次须菩提。菩萨摩诃萨内身中循身观时一心念。入息时知入息。出息时知出息。入息长时知入息长。出息长时知出息长。入息短时知入息短。出息短时知出息短。譬如旋师若旋师弟子。绳长知长绳短知短。菩萨摩诃萨亦如是。一心念入息时知入息。出息时知出息。入息长时知入息长。出息长时知出息长。入息短时知入息短。出息短时知出息短。如是须菩提。菩萨摩诃萨内身中循身观。勤精进一心除世间贪忧。以不可得故。复次须菩提。菩萨摩诃萨观身四大作是念。身中有地大水大火大风大。譬如屠牛师若屠牛弟子。以刀杀牛分作四分。作四分已若立若坐观此四分。菩萨摩诃萨亦如是行般若波罗蜜时。种种观身四大。地大水大火大风大。如是须菩提。菩萨摩诃萨内身中循身观。以不可得故。复次须菩提。菩萨摩诃萨观内身。从足至顶周匝薄皮。种种不净充满身中。作是念。身中有发毛爪齿薄皮厚皮筋肉骨髓脾肾心肝肺小肠大肠胃胞屎尿垢汗目泪涕唾脓血黄白痰阴肪[月*冊]脑膜。譬如田夫仓中隔盛杂谷。种种充满稻麻黍粟豆麦。明眼之人开仓即知。是麻是黍是稻是粟是麦是豆。分别悉知。菩萨摩诃萨亦如是观是身。从足至顶周匝薄皮。种种不净充满身中。发毛爪齿乃至脑膜。如是须菩提。菩萨摩诃萨观内身。勤精进一心除世间贪忧。以不可得故。复次须菩提。菩萨摩诃萨若见弃死人身。一日二日至于五日膖胀青瘀脓汁流出。自念我身亦如是相如是法。未脱此法。如是须菩提。菩萨摩诃萨内身中循身观。勤精进一心除世间贪忧。以不可得故。复次须菩提。菩萨摩诃萨若见弃死人身。若六日若七日乌鸱雕鹫豺狼狐狗。如是等种种禽兽[國*瓜]裂食之。自念我身如是相如是法。未脱此法。如是须菩提。菩萨摩诃萨内身中循身观。勤精进一心除世间贪忧。以不可得故。复次须菩提。菩萨摩诃萨若见弃死人身。禽兽食已不净烂臭。自念我身如是相如是法。未脱此法。乃至除世间贪忧。复次须菩提。菩萨摩诃萨若见弃死人身骨锁。血肉涂染筋骨相连。自念我身如是相如是法。未脱此法。乃至除世间贪忧。复次须菩提。菩萨摩诃萨若见弃死人身骨琐血肉已离筋骨相连。自念我身如是相如是法。未脱此法。乃至除世间贪忧。复次须菩提。菩萨摩诃萨若见弃死人身骨琐已散在地。自念我身如是相如是法。未脱此法。如是须菩提。菩萨摩诃萨观内身。乃至除世间贪忧。复次须菩提。菩萨摩诃萨若见弃死人身。骨散在地脚骨异处。膞骨髀骨腰骨肋骨脊骨手骨项骨髑髅各各异处。自念我身如是相如是法。未脱此法。如是须菩提。菩萨摩诃萨观内身。乃至除世间贪忧。复次须菩提。菩萨摩诃萨见是弃死人骨在地岁久风吹日曝色白如贝自念我身如是相如是法。未脱此法。如是须菩提。菩萨摩诃萨观内身。乃至除世间贪忧。以不可得故

【论】问曰。四念处中有种种观。何以但说十二种观。所谓若内若外若内外。复次何等是内何等是外。内外观已何以复别说内外。复次四念处中一念处是内。内法中摄。所谓心。二念处是外。外法中摄。所谓受与法。一念处是内外。内外法中摄。所谓身。何以说四法。都是内都是外都是内外。何以不但言观身而言循身观。云何观身而不生身觉。何以言勤精进一心。三十七品皆应言一心。何以但此中言一心。此中若修行四念处时。一切五盖应除。何以独言除贪。世间喜亦能妨道。何以但言除忧。观身法种种门。无常苦空无我等。今何以但言不净。若但观不净。何以复念身四威仪等。此事易知何足问。答曰。是十二种观行者从此得定心。先来三种邪行。若内若外若内外。破三种邪行。是故有三种正行。有人着内情多着外情少。如人为身故能舍妻子亲属宝物。有人着外情多着内情少。如人贪财丧身为欲没命。有人着内外情多。是故说三种正行。复次自身名内身。他身名外身。九受入名为内身。九不受入名为外身。眼等五情名为内身。色等五尘名为外身。如是等分别内外。行者先以不净无常苦空无我等智慧观内身。不得是身好相。若净相若常相若乐若我若实内既不得。复观外身求净常我乐。实亦不可得。若不得便生疑。我观内时于外或错。观外时于内或错。今内外一时俱观亦不可得。是时心得正定。知是身不净无常苦空无我。如病如痈如疮九孔流秽。是为行厕。不久破坏离散尽灭死相。常有饥渴寒热鞭杖系闭骂詈毁呰老病等诸苦。常围绕不得自在。内空无主亦无知者见者作者受者。但空诸法因缘和合而有。自生自灭无所系属。犹如草木。是故内外俱观。余内外义如十八空中说。循身观者。寻随观察知其不净。衰老病死烂坏臭处骨节腐败摩灭归土。如我此身覆以薄皮。令人狂惑忧畏万端。以是故如身相。内外随逐本末观察。又如佛说。循身观法不生身觉者。不取身一异相而生戏论。众生于是身中起种种觉。有生净觉。有生不净觉。有生嗔觉。念他过罪。有人观此身。身为何法。诸身分边为一为异。不生如是种种觉。所以者何。无所利益。妨涅槃道故。复次余凡夫声闻人取身相能观身。菩萨不取身相而能观身。勤精进一心者。余世事巧便从无始世界来常习常作。如离别常人易。离别知识难。离别知识易。离别父子难。离别父子易。自离其身难。自离其身易。离其心者难。自不一心勤精进此不可得。譬如攒燧求火。一心勤着不休不息乃可得火。是故说一心勤精进。除世间贪忧者。贪除则五盖尽去犹如破竹初节既破余节皆去。复次行者远离五欲出家学道。既舍世乐未得定乐。或时心生忧念。如鱼乐水。心相如是常求乐事。还念本所欲。行者多生是二心。是故佛说。当除贪忧。说贪即是说世间。喜以相应故。初观不净者。人身不净薄皮覆故。先生净相后生余倒。以是故初说不净观。复次众生多着贪欲取净相。嗔恚邪见不尔故。是以先治贪欲观不净。念身四威仪等者。先欲破身贼。得一心人所为之事皆能成办。以是故先寻绎其身所为所行。来去卧觉坐禅观身所作。常一心安详不错不乱。作如是观察以不净三昧易得。身虽安详。内有种种恶觉观破乱其心。以是故说安那波那十六分。以防觉观。安那般那义如先说。身既安详心无错乱。然后行不净观安隐牢固。若先行不净观狂心错乱。故不净反作净相。佛法中此二法名甘露初门。不净观者。所谓菩萨摩诃萨观身如草木瓦石无异。是身外四大变为饮食充实内身。坚者是地。湿者是水。热者是火。动者是风。是四事入内即是身。是四分中各各无我无我所。随逐自相不随人意。苦空等亦如是说。若坐若立者。卧则懈怠。身不动故心亦不动。行则心乱。身不静故心亦不静。欲以眼见事况所不见。故说譬喻。牛即是行者身。屠儿即是行者。刀是利智慧。夺牛命即是破身一相。四分即是四大。屠者观牛四分更无别牛亦非是牛。行者观身四大亦如是。是四大不名为身。所以者何。此四身一故。又四大是总相。身是别相。若外四大不名为身。入身中假名为身。我不在四大中。四大不在我中。我去四大远。但以颠倒妄计为身。用是散空智慧。分别四大及造色。然后入三念处得入道。又此身从足至发。从发至足周匝薄皮。反覆思惟无一净处。发毛等乃至脑膜略说则三十六。广说则众多。谷仓是身。农夫是行者。田种谷。是行者身业因缘。结实入仓。是行者因缘熟得身。稻麻黍粟等。是身中种种不净。农夫开仓即知麻黍麦豆种种别异。是行者不净观。以慧眼开见是身仓。知此身中不净充满必当败坏。若他来害若当自死。此身中但有屎尿不净种种恶露等。已观内身不净。今观外身败坏。是故说二种不净。一者已坏。二者未坏。先观己身未坏有识。若结使薄利根人即生患厌。钝根结厚者观死人已坏可畏可恶。若死一日至五日。亲里犹尚守护。是时禽兽未食。青瘀膖胀脓血流出。腹胀破裂五藏烂坏。屎尿臭处甚可恶厌。行者心念。此色先好。行来言语妖蛊姿则惑乱人情淫者爱着。今者观之好色安在。如佛所说。真是幻法。但诳无智之眼。今此实事露现。行者即念。我身与彼等无有异。未脱此法。云何自着着彼。又亦何为自重轻他。如是观已。心则调伏可以求道。能除世间贪忧。又复思惟。此尸初死之时鸟兽见之。谓非死人不敢来近。以是故说。过六七日亲戚既去。乌鹫野干之属竞来食之。皮肉既尽日日变异。以是故说。但有骨人。见其如此更生厌心。念言是心肝皮肉实无有我。但因是身合。集罪福因缘。受苦无量。即复自念。我身不久会当如是。未离此法。或时行者见骨人在地雨水浇浸日曝风吹但有白骨。或见久骨筋断节解分散异处其色如鸽。或腐朽烂坏与土同色。初观三十六物死尸膖胀。一日至五日。是不净观。鸟兽来食乃至与土同色。是无常观。是中求我我所不可得。如先说。因缘生不自在故。是非我观。观身相如此无一可乐。若有著者则生忧苦。是名苦观。以四圣行观外身。自知己身亦复如是。然后内外俱观。若心散乱。当念老病死三恶道苦身命无常佛法欲灭。如是等鞭心令伏。还系不净观中。是名勤精进。一心勤精进故能除贪忧。贪忧二贼劫我法宝。行者作是念。是身无常不净可恶如此。众生何故贪着此身。起种种罪因缘。如是思惟已。知是身中有五情外有五欲。和合故生世间颠倒乐。人心求乐初无住时当观此乐为实为虚。身为坚固犹尚散灭。何况此乐。此乐亦无住处。未来未有。过去已灭。现在不住。念念皆灭。以遮苦故名乐。无有实乐。譬如饮食。除饥渴苦故暂以为乐。过度则复生苦。如先破乐中说。则知世间乐皆从苦因缘生。亦能生苦果。诳人须臾后苦无量。譬如美食杂毒食虽香美毒则害人。世间乐亦如是。淫欲烦恼等毒故。夺智慧命心则狂惑。舍利取衰谁受此乐。唯有心识。谛观此心念念生灭相续有故可得取相。譬如水波灯焰。受苦心非乐心。受乐心非苦心。受不苦不乐心非苦乐心。时相各异。以是故心无常。无常故不自在。不自在故无我。想思忆念等亦如是。余三念处内外相如先说。行是四圣行破四颠倒。破四颠倒故开实相门。开实相门已愧本所习。譬人夜食不净。地了知非羞愧其事。观是四法。不净无常等。是名苦谛。是苦因爱等诸烦恼是集谛。爱等诸烦恼断是灭谛。断爱等诸烦恼方便是道谛。如是观四谛信涅槃道。心住快乐似如无漏。是名暖法。如人攒火并有暖气必望得火。信此法已。心爱乐佛是法如佛所说。如服好药差病知师为妙诸服药病差者人中第一。是则信僧。如是信三宝。暖法增进罪福停等故。名为顶法。如人上山至顶两边道里俱等。从顶至忍乃至阿罗汉。是一边道。从暖至顶是一边道。声闻法中观四念处。所得果报如是。菩萨法者。于是观中不忘本愿不舍大悲。先用不可得空调伏心地。住是地中。虽有烦恼心常不堕。如人虽未杀贼系闭一处。菩萨顶法如先法位中说。忍法世间第一法。则是菩萨柔顺法忍。须陀洹道乃至阿罗汉辟支佛道。即是菩萨无生法忍。如佛后品自说。须陀洹若智若果。皆是菩萨无生法忍。四正勤四如意足虽各各别。位皆在四念处中。慧多故名四念处。精进多故名四正勤。定多故名四如意足。问曰。若尔者何以不说智处而说念处。答曰。初习行时未及有智。念为初门常念其事。是智慧随念。故以念为名。四念处实体是智慧。所以者何。观内外身即是智慧。念持智慧在缘中不令散乱。故名念处。与九十六种邪行求道相违。故名正勤。诸外道等舍五欲自苦身。不能舍恶不善。不能集诸善法。佛有两种断恶不善法。已来者除却。未来者防使不生。善法亦有二种。未生善法令生。已生善法令增长。是名正勤。智慧火得正勤风无所不烧。正勤若过。心则散乱智火微弱。如火得风过者或灭或微不能烧照。是故须定以制过。精进风则可得定。定有四种。欲定精进定心定思惟定。制四念处中过智慧。是时定慧道得精进故所欲如意。后得如意事办故名如意足。足者名如意因缘。亦名分。是十二法钝根人中名为根。如树有根未有力。若利根人中名为力。是事了了能疾有所办。如利刀截物。故名有力。事未办故名为道。事办思惟修行故名为觉。三十七品论议如先说。问曰。若菩萨修此三十七品。云何不取涅槃。答曰。本愿牢故。大悲心深入故。了了知诸法实相故。十方诸佛护念故。如经说。菩萨到七住地。外观诸法空。内观无我。如人梦中缚筏渡河中流而觉作是念。我空自疲苦。无河无筏我何所渡。菩萨尔时亦如是心则悔厌。我何所度何所灭。且欲自灭倒心。是时十方佛伸手摩头。善哉佛子。莫生悔心念汝本愿。汝虽知此众生未悟。汝当以此空法教化众生。汝所得者始是一门。诸佛无量身无量音声无量法门。一切智慧等汝皆未得。汝观诸法空故着是涅槃。诸法空中无有灭处无有着处。若实有灭汝先来已灭。汝未具足六波罗蜜乃至十八不供法。汝当具足此法坐于道场如诸佛法。复次三三昧十一智三无漏根觉观三昧十念四禅四无量心四无色定八背舍九次第定如先说。复次佛十力四无所畏四无碍智十八不共法如初品中说。是诸法后皆用无所得故。以般若波罗蜜毕竟空和合故。名除世间贪忧。以不可得故

【经】复次须菩提。菩萨摩诃萨见是弃死人骨在地岁久其色如鸽。腐朽烂坏与土共合。自念。我身如是法如是相未脱此法。如是须菩提。菩萨摩诃萨内身中循身观。勤精进一心除世间贪忧。以不可得故。外身内外身亦如是。受念处心念处法念处亦应如是广说须菩提。是名菩萨摩诃萨摩诃衍。复次须菩提。菩萨摩诃萨摩诃衍。所谓四正勤。何等四。须菩提。菩萨摩诃萨未生诸恶不善法为不生故。欲生勤精进摄心行道。已生诸恶不善法为断故。欲生勤精进摄心行道。未生诸善法为生故。欲生勤精进摄心行道。已生诸善法为住不失。修满增广故。欲生勤精进摄心行道。以不可得故。须菩提。是名菩萨摩诃萨摩诃衍。复次须菩提。菩萨摩诃萨摩诃衍。所谓四如意分。何等四。欲定断行成就修如意分。心定断行成就修如意分。精进定断行成就修如意分。思惟定断行成就修如意分。以不可得故。须菩提。是名菩萨摩诃萨摩诃衍。复次须菩提。菩萨摩诃萨摩诃衍。所谓五根。何等五。信根精进根念根定根慧根。是名菩萨摩诃萨摩诃衍。以不可得故。复次须菩提。菩萨摩诃萨摩诃衍。所谓五力。何等五。信力精进力念力定力慧力。是名菩萨摩诃萨摩诃衍。以不可得故。复次须菩提。菩萨摩诃萨摩诃衍。所谓七觉分。何等七。菩萨摩诃萨修念觉分。依离依无染向涅槃。择法觉分精进觉分喜觉分除觉分定觉分舍觉分。依离依无染向涅槃。以不可得故。是名菩萨摩诃萨摩诃衍。复次须菩提。菩萨摩诃萨摩诃衍。所谓八圣道分。何等八。正见正思惟正语正业正命正精进正念正定。是名菩萨摩诃萨摩诃衍。以不可得故。复次须菩提。菩萨摩诃萨摩诃衍。所谓三三昧。何等三。空无相无作三昧。空三昧名诸法自相空。是为空解脱门。无相名坏诸法相不忆不念。是为无相解脱门。无作名诸法中不作愿。是为无作解脱门。是名菩萨摩诃萨摩诃衍。以不可得故。复次须菩提。菩萨摩诃萨摩诃衍。所谓苦智集智灭智道智尽智无生智法智比智世智他心智如实智。云何名苦智。知苦不生。是名苦智。云何名集智。知集应断。是名集智。云何名灭智。知苦灭。是名灭智。云何名道智。知八圣道分。是名道智。云何名尽智。知诸淫怒痴尽。是名尽智。云何名无生智。知诸有中无生。是名无生智。云何名法智。知五众本事分别知无。是名法智。云何名比智。知眼无常乃至意触因缘生受无常。是名比智。云何名世智。知因缘名字。是名世智。云何名他心智。知他众生心。是名他心智。云何名如实智。知诸佛一切种智。是名如实智。须菩提。是名菩萨摩诃萨摩诃衍。以不可得故。复次须菩提。菩萨摩诃萨摩诃衍。所谓三根。未知欲知根知根知者根。云何名未知欲知根。诸学人未得果。信根精进根念根定根慧根。是名未知欲知根。云何名知根。诸学人得果。信根乃至慧根。是名知根。云何名知者根。诸无学人若阿罗汉若辟支佛诸佛。信根乃至慧根。是名知者根。须菩提。是名菩萨摩诃萨摩诃衍。以不可得故。复次须菩提。菩萨摩诃萨摩诃衍。所谓三三昧。何等三。有觉有观三昧。无觉有观三昧。无觉无观三昧。云何名有觉有观三昧。离诸欲离恶不善法。有觉有观离生喜乐入初禅。是名有觉有观三昧。云何名无觉有观三昧。初禅二禅中间。是名无觉有观三昧。云何名无觉无观三昧。从二禅乃至非有想非无想定。是名无觉无观三昧。是名菩萨摩诃萨摩诃衍。以不可得故。复次须菩提。菩萨摩诃萨摩诃衍。所谓十念。何等十。念佛念法念僧念戒念舍念天念灭念出入息念身念死。须菩提。是名菩萨摩诃萨摩诃衍。以不可得故。复次须菩提。菩萨摩诃萨摩诃衍。所谓四禅四无量心四无色定八背舍九次第定。须菩提。是名菩萨摩诃萨摩诃衍。以不可得故。复次须菩提。菩萨摩诃萨摩诃衍。所谓佛十力。何等十。佛如实知一切法是处不是处相。一力也。如实知他众生过去未来现在诸业诸受法。知造业处知因缘知报。二力也。如实知诸禅解脱三昧定垢净分别相。三力也。如实知他众生诸根上下相。四力也。如实知他众生种种欲解。五力也。如实知世间种种无数性。六力也。如实知一切至处道。七力也。知种种宿命有相有因缘。一世二世乃至百千世劫初劫尽。我在彼众生中生。如是姓如是名如是饮食苦乐寿命长短。彼中死是间生。是间死还生是间。此间生姓名饮食苦乐寿命长短。亦如是。八力也佛天眼净过诸天眼。见众生死时生时端正丑陋。若大若小。若堕恶道若堕善道。如是业因缘受报。是诸众生恶身业成就。恶口业成就。恶意业成就。谤毁圣人。受邪见业因缘故。身坏死时入恶道生地狱中。是诸众生善身业成就。善口业成就。善意业成就。不谤毁圣人。受正见业因缘故。身就坏时入善道生天上。九力也。佛如实知诸漏尽故。无漏心解脱无漏慧解脱。现在法中自证知入是法。所谓我生已尽梵行已作。从今世不复见后世。十力也。须菩提。是名菩萨摩诃萨摩诃衍。以不可得故。复次须菩提。菩萨摩诃萨摩诃衍。所谓四无所畏。何等四。佛作诚言。我是一切正智人。若有沙门婆罗门。若天若魔若梵若复余众如实难言。是法不知乃至不见是微畏相。以是故我得安隐。得无所畏。安住圣主处。在大众中师子吼能转梵轮。诸沙门婆罗门若天若魔若梵若复余众实不能转。一无畏也。佛作诚言。我一切漏尽。若有沙门婆罗门。若天若魔若梵若复余众如实难言。是漏不尽乃至不见是微畏相。以是故我得安隐。得无所畏。安住圣主处。在大众中师子吼能转梵轮。诸沙门婆罗门若天若魔若梵若复余众。实不能转。二无畏也。佛作诚言。我说障法。若有沙门婆罗门。若天若魔若梵若复余众如实难言。受是法不障道。乃至不见是微畏相。以是故我得安隐。得无所畏。安住圣主处。在大众中师子吼能转梵轮诸沙门婆罗门若天若魔若梵若复余众实不能转。三无畏也。佛作诚言。我所说圣道能出世间。随是行能尽苦。若有沙门婆罗门。若天若魔若梵若复余众如实难言。行是道不能出世间不能尽苦。乃至不见是微畏相。以是故我得安隐。得无所畏。安住圣主。处在大众中师子吼能转梵轮。诸沙门婆罗门若天若魔若梵若复余众实不能转。四无畏也。须菩提。是名菩萨摩诃萨摩诃衍。以不可得故。复次须菩提。菩萨摩诃萨摩诃衍。所谓四无碍智。何等四。义无碍法无碍辞无碍乐说无碍。义无碍者。知诸法实相义。法无碍者。知诸法名。辞无碍者。言辞中无碍。乐说无碍者。审谛言无尽。须菩提。是名菩萨摩诃萨摩诃衍。以不可得故。复次须菩提。菩萨摩诃萨摩诃衍。所谓十八不共法。何等十八。一诸佛身无失。二口无失。三念无失。四无异想。五无不定心。六无不知已舍心。七欲无减。八精进无减。九念无减。十慧无减。十一解脱无减。十二解脱知见无减。十三一切身业随智慧行。十四一切口业随智慧行。十五一切意业随智慧行。十六智慧知见过去世无碍无障。十七智慧知见未来世无碍无障。十八智慧知见现在世无碍无障。须菩提。是名菩萨摩诃萨摩诃衍。以不可得故。复次须菩提。菩萨摩诃萨摩诃衍。所谓字等语等诸字入门。何等为字等语等诸字入门。阿字门一切法初不生故。罗字门一切法离垢故。波字门一切法第一义故。遮字门一切法终不可得故。诸法不终不生故。那字门诸法离名性相不得不失故。逻字门诸法度世间故。亦爱枝因缘灭故。陀字门诸法善心生故。亦施相故。婆字门诸法婆字离故。荼字门诸法荼字净故。沙字门诸法六自在王性清净故。和字门入诸法语言道断故。多字门入诸法如相不动故。夜字门入诸法如实不生故。吒字门入诸法制伏不可得故。迦字门入诸法作者不可得故。婆字门入诸法时不可得故。诸法时来转故。磨字门入诸法我所不可得故。伽字门入诸法去者不可得故。他字门入诸法处不可得故。阇字门入诸法生不可得故。簸字门入诸法簸字不可得故。[馬*犬]字门入诸法性不可得故。赊字门入诸法定不可得故。呿字门入诸法虚空不可得故。叉字门入诸法尽不可得故。哆字门入诸法有不可得故。若字门入诸法智不可得故。拖字门入诸法拖字不可得故。婆字门入诸法破坏不可得故。车字门入诸法欲不可得故。如影五众亦不可得故。魔字门入诸法魔字不可得故。火字门入诸法唤不可得故。蹉字门入诸法蹉字不可得故。伽字门入诸法厚不可得故。咃字门入诸法处不可得故。拏字门入诸法不来不去不立不坐不卧故。颇字门入诸法边不可得故。歌字门入诸法聚不可得故。醝字门入诸法醝字不可得故。遮字门入诸法行不可得故。咤字门入诸法躯不可得故。荼字门入诸法边竟处不可得故。不终不生故。过荼无字可得。何以故。更无字故。诸字无碍无名亦不灭。亦不可说不可示不可见不可书。须菩提当知。一切诸法如虚空。须菩提。是名陀罗尼门。所谓阿字义。若菩萨摩诃萨是诸字门印阿字印。若闻若受若诵若读若持若为他说。如是知当得二十功德。何等二十。得强识念。得惭愧。得坚固心。得经旨趣。得智慧。得乐说无碍。易得诸陀罗尼门。得无疑悔心。得闻善不喜闻恶不怒。得不高不下住心得无增减。得善巧知众生语。得巧分别五众十二入十八界十二因缘四缘四谛。得巧分别众生诸根利钝。得巧知他心。得巧分别日月岁节。得巧分别天耳通。得巧分别宿命通。得巧分别生死通。得能巧说是处非处。得巧知往来坐起等身威仪。须菩提。是陀罗尼门阿字门等。是名菩萨摩诃萨摩诃衍

【论】释曰。字等语等者。是陀罗尼于诸字平等无有爱憎。又此诸字因缘未会时。亦无终归亦无现在亦无所有。但住吾我心中。忆想分别觉观心说。是散乱心说不见实事。如风动水则无所见。等者与毕竟空涅槃同等。菩萨以此陀罗尼。于一切诸法通达无碍。是名字等语等。问曰。若略说则五百陀罗尼门。若广说则无量陀罗尼门。今何以说是字等陀罗尼。名为诸陀罗尼门。答曰。先说一大者。则知余者皆说。此是诸陀罗尼初门。说初余亦说。复次诸陀罗尼法。皆从分别字语生。四十二字是一切字根本。因字有语因语有名因名有义。菩萨若闻字因字。乃至能了其义。是字初阿后荼。中有四十。得是字陀罗尼。菩萨若一切语中闻阿字即时随义。所谓一切法从初来不生相。阿提秦言初。阿耨波陀秦言不生。若闻罗字即随义知一切法离垢相。罗阇秦言垢。若闻波字即时知一切法入第一义中。波罗木陀秦言第一义。若闻遮字即时知一切诸行皆非行。遮梨夜秦言行。若闻那字即知一切法不得不失不来不去。那秦言不。若闻逻字即知一切法离轻重相。逻求秦言轻。若闻陀字即知一切法善相。陀摩秦言善。若闻婆字即知一切法无缚无解。婆陀秦言缚。若闻荼字即知诸法不热相。南天竺荼阇他秦言不热。若闻沙字即知人身六种相。沙秦言六。若闻和字即知一切诸法离语言相。和(于波反)波他秦言语言。若闻多字即知诸法在如中不动。多他秦言如。若闻夜字即知诸法入实相中不生不灭。夜他跋秦言实。若闻吒字即知一切法无障碍相。吒婆秦言障碍。若闻迦字即知诸法中无有作者。迦罗迦秦言作者。若闻婆字即知一切法一切种不可得。萨婆秦言一切。若闻摩字即知一切法离我所。魔迦罗秦言我所。若闻伽字即知一切法底不可得。伽陀秦言底。若闻陀字即知四句如去不可得。多陀阿伽陀秦言如去。若闻阇(社音)字即知诸法生老不可得。阇提阇罗秦言生老。若闻湿波字即知一切法不可得。如湿波字不可得。湿簸字无义故不释。若闻[馬*犬]字即知一切法中法性不可得。[馬*犬]摩秦言法。若闻赊字即知诸法寂灭相。赊多(都饿反)秦言寂灭。若闻呿字即知一切法虚空不可得。呿伽秦言虚空。若闻叉字即知一切法尽不可得。叉耶秦言尽。若闻哆字即知诸法边不可得。阿利迦哆度求那秦言是事边得何利。若闻若字即知一切法中无智相。若那秦言智。若闻他字即知一切法义不可得。阿他秦言义。若闻婆字即知一切法不可破相。婆伽秦言破。若闻车字即知一切法无所去。伽车提秦言去。若闻湿么字即知诸法牢坚如金刚石。阿湿么秦言石。若闻火字即知一切法无音声相。火夜秦言唤来。若闻蹉字即知一切法无悭无施相。末蹉罗秦言悭。若闻伽字即知诸法不厚不薄。伽那秦言厚。若闻他(上荼反)字即知诸法无住处。南天竺他那秦言处。若闻拏字即知一切法及众生不来不去不坐不卧不立不起。众生空法空故。南天竺拏秦言不。若闻颇字。即知一切法因果空故。颇罗秦言果。若闻歌字即知一切法五众不可得。歌大秦言众。若闻醝字即知醝字空诸法亦尔。若闻遮字即知一切法不动相。遮罗地秦言动。若闻吒字即知一切法此彼岸不可得。吒罗秦言岸。若闻茶字即知一切法必不可得。波茶秦言必。茶外更无字。若更有者是四十二字枝派。是字常在世间相似相续故。入一切语故无碍。如国国不同无一定名。故言无名。闻已便尽故言灭。诸法入法性皆不可得。而况字可说。诸法无忆想分别故不可示。先意业分别故有口业。口业因缘故身业作字。字是色法。或眼见或耳闻。众生强作名字。无因缘。以是故不可见不可书。诸法常空如虚空相。何况字。说已便灭。是文字陀罗尼。是诸陀罗尼门。问曰。知是陀罗尼门因缘者。应得无量无边功德。何以但说二十。答曰。佛亦能说诸余无量无边功德。但以废说般若波罗蜜故。但略说二十。得强识念者。菩萨得是陀罗尼。常观诸字相。修习忆念故得强识念。得惭愧者。集诸善法厌诸恶法故。生大惭愧心。得坚固者。集诸福德智慧故。心得坚固如金刚。乃至阿鼻地狱事尚不退阿耨多罗三藐三菩提。何况余苦。得经旨趣者。知佛五种方便说法。故名为得经旨趣。一者知作种种门说法。二者知为何事故说。三者知以方便故说。四者知示理趣故说。五者知以大悲心故说。得智慧者。菩萨因是陀罗尼。分别破散诸字言语亦空。言语空故名亦空。名空故义亦空。得毕竟空即是般若波罗蜜智慧。乐说者。既得如是毕竟清净无碍智慧。以本愿大悲心度众生。故乐说易。得陀罗尼者。譬如破竹初节既破余者皆易。菩萨亦如是。得是文字陀罗尼。诸陀罗尼自然而得。无疑悔心者。入诸法实相中。虽未得一切智慧。于一切深法中无疑无悔。闻善不喜闻恶不嗔者。各各分别诸字。无赞叹无毁呰故。闻善不喜闻恶不嗔。不高不下者。憎爱断故。善巧知众生语者。得解一切众生言语三昧故。巧分别五众十二入十八界十二因缘四缘四谛者。五众等义如先说。巧分别众生诸根利钝。知他心天耳宿命。巧说是处非处者。如十力中说。巧知往来坐起等者。如阿鞞跋致品中所说。日月岁节者。日名从旦至旦。初分中分后分。夜亦三分。一日一夜有三十时。春秋分时十五时属昼。十五时属夜。余时增减。五月至昼十八时夜十二时。十一月至夜十八时昼十二时。一月或三十日或三十日半。或二十九日或二十七日半。有四种月。一者日月。二者世间月。三者月月。四者星宿月。日月者。三十日半。世间月者。三十日。月月者。二十九日。加六十二分之三十。星宿月者。二十七日。加六十七分之二十一。闰月者。从日月世间月二事中出。是名十三月。或十二月或十三月名一岁。是岁三百六十六日。周而复始。菩萨知日中分时。前分已过后分未生。中分中无住处。无相可取。日分空无所有。到三十日时二十九日已灭。云何和合成月。月无故。云何和合而为岁。以是故。佛言。世间法如幻如梦。但是诳心法。菩萨能知世间日月岁和合。能知破散无所有。是名巧分别。如是等种种分别。是名菩萨摩诃萨摩诃衍

大智度论卷第四十八(释第十九品)大智度论释发趣品第二十(卷四十九)

        龙树菩萨造

        后秦龟兹国三藏鸠摩罗什译

【经】佛告须菩提。汝问云何菩萨摩诃萨大乘发趣。若菩萨摩诃萨行六波罗蜜时。从一地至一地。是名菩萨摩诃萨大乘发趣。须菩提白佛言。世尊。云何菩萨摩诃萨从一地至一地。佛言。菩萨摩诃萨知一切法无来去相亦无有法。若来若去若至若不至诸法相不灭故。菩萨摩诃萨于诸地不念不思惟。而修治地业亦不见地。何等菩萨摩诃萨治地业。菩萨摩诃萨住初地时行十事。一者深心坚固。是不可得故。二者于一切众生中等心。众生不可得故。三者布施。与人受人不可得故。四者亲近善知识亦不自高。五者求法。一切法不可得故。六者常出家。家不可得故。七者爱乐佛身。相好不可得故。八者演出法教。诸法分别不可得故。九者破憍慢。法生慧不可得故。十者实语。诸语不可得故。菩萨摩诃萨如是初地中住。修治十事治地业。复次须菩提。菩萨摩诃萨住二地中常念八法。何等八。一者戒清净。二者知恩报恩。三者住忍辱。四者受欢喜。五者不舍一切众生。六者入大悲心。七者信师恭敬咨受。八者勤求诸波罗蜜。须菩提。是名菩萨摩诃萨住二地中应满足八法。复次须菩提。菩萨摩诃萨住三地中行五法。何等五。一者多学问无厌足。二者净法施亦不自高。三者庄严佛国土亦不自高。四者受世间无量勤苦不以为厌。五者住惭愧处。须菩提。是名菩萨摩诃萨住三地中应满足五法。复次须菩提。菩萨摩诃萨住四地中应受行不舍十法。何等十。一者不舍阿练若住处。二者少欲。三者知足。四者不舍头陀功德。五者不舍戒。六者秽恶诸欲。七者厌世间心。八者舍一切所有。九者心不没。十者不惜一切物。须菩提是名菩萨摩诃萨住第四地中不舍十法。复次须菩提。菩萨摩诃萨住五地中远离十二法。何等十二。一者远离亲白衣。二者远离比丘尼。三者远离悭惜他家。四者远离无益谈处。五者远离嗔恚。六者远离自大。七者远离蔑人。八者远离十不善道。九者远离大慢。十者远离自用。十一者远离颠倒。十二者远离淫怒痴。须菩提。是为菩萨摩诃萨住五地中远离十二事。复次须菩提菩萨摩诃萨住六地中当具足六法。何等六。所谓六波罗蜜。复有六法所不应为。何等六。一者不作声闻辟支佛意。二者布施不应生忧心。三者见有所索心不没。四者所有物布施。五者布施之后心不悔。六者不疑深法。须菩提。是名菩萨摩诃萨住六地中应满具六法远离六法

复次须菩提。菩萨摩诃萨住七地中二十法所不应着。何等二十。一者不着我。二者不着众生。三者不着寿命。四者不着众数乃至知者见者五者不着断见。六者不着常见。七者不应作相。八者不应作因见。九者不著名色。十者不着五众。十一者不着十八界。十二者不着十二入。十三者不着三界。十四者不作着处。十五者不作所期处。十六者不作依处。十七者不着依佛见。十八者不着依法见。十九者不着依僧见。二十者不着依戒见。是二十法所不应着。复有二十法应具足满。何等二十。一者具足空。二者无相证。三者知无作。四者三分清净。五者一切众生中具足慈悲智。六者不念一切众生。七者一切法等观。是中亦不着。八者知诸法实相。是事亦不念。九者无生法忍。十者无生智。十一者说诸法一相。十二者破分别相。十三者转忆想。十四者转见。十五者转烦恼。十六者等定慧地。十七者调意。十八者心寂灭。十九者无碍智。二十者不染爱。须菩提。是名菩萨摩诃萨住。七地中应具足二十法

复次须菩提。菩萨摩诃萨住八地中应具足五法。何等五。顺入众生心。游戏诸神通。观诸佛国。如所见佛国自庄严其国。如实观佛身自庄严佛身。是名五法具足满。复次须菩提。菩萨摩诃萨住八地中复具足五法。何等五。知上下诸根。净佛世界。入如幻三昧。常入三昧。随众生所应善根受身。须菩提。是为菩萨摩诃萨住八地中具足五法。复次须菩提。菩萨摩诃萨住九地中应具足十二法。何等十二。受无边世界所度之分。菩萨得如是愿。知诸天龙夜叉犍闼婆语而为说法。处胎成就家成就所生成就姓成就眷属成就出生成就出家成就庄严佛树成就。一切诸善功德成满具足。须菩提。是名菩萨摩诃萨住九地中应具足十二法。须菩提。十地菩萨当知如佛。尔时慧命须菩提白佛言。世尊。云何菩萨摩诃萨深心治地业。佛言。菩萨摩诃萨应萨婆若心集诸善根。是名菩萨摩诃萨深心治地业。云何菩萨于一切众生中等心。佛言。若菩萨摩诃萨应萨婆若心生四无量心。所谓慈悲喜舍。是名于一切众生中等心。云何菩萨修布施。佛言。菩萨施与一切众生无所分别。是名修布施。云何菩萨亲近善知识。佛言。能教入萨婆若中住。如是善知识亲近咨受恭敬供养。是名亲近善知识。云何菩萨求法。佛言。若菩萨应萨婆若心求法。不堕声闻辟支佛地。是名求法。云何菩萨常出家治地业。佛言。菩萨世世不杂心。佛法中出家无能障碍者。是名常出家治地业。云何菩萨爱乐佛身治地业。佛言。若菩萨见佛身相乃至阿耨多罗三藐三菩提。终不离念佛。是名爱乐佛身治地业。云何菩萨演出法教治地业。佛言。菩萨若佛现在若佛灭度后。为众生说法。初中后善妙义好语净洁纯具。所谓修妒路乃至优婆提舍。是名演出法教治地业。云何菩萨破于憍慢治地业。佛言菩萨破是憍慢故。终不生下贱家。是名破于憍慢治地业。云何菩萨实语治地业。佛言。菩萨如所说随说行。是名实语治地业。是为菩萨摩诃萨住初地中修行十事治地业

【论】释曰。须菩提上问摩诃衍。佛种种答摩诃衍相。上又问发趣大乘者。今答发趣大乘相。菩萨摩诃萨乘是乘。知一切法从本已来不来不去无动无发法性常住故。又以大悲心故。精进波罗蜜故。方便力故。还修诸善法。更求胜地而不取地相。亦不见此地。问曰应答发趣大乘。何以说发趣地。答曰。大乘即是地。地有十分。从初地至二地。是名发趣。譬如乘马趣象舍马乘象乘象趣龙舍象乘龙。问曰。此中是何等十地。答曰。地有二种。一者但菩萨地。二者共地。共地者。所谓干慧地乃至佛地。但菩萨地者。欢喜地离垢地有光地增曜地难胜地现在地深入地不动地善根地法云地。此地相如十地经中广说。入初地菩萨应行十法深心乃至实语。须菩提虽知。为断众生疑故问世尊。云何是深心。佛答。应萨婆若心集诸善根。萨婆若心者。菩萨摩诃萨初发阿耨多罗三藐三菩提意。作是愿。我于未来世当作佛。是阿耨多罗三藐三菩提意。即是应萨婆若心。应者系心愿我当作佛。若菩萨利根大集福德。诸烦恼薄过去罪业少。发意即得深心。深心者。深乐佛道世世于世间心薄。是名应萨婆若心。所作一切功德若布施若持戒若修定等。不求今世后世福乐寿命安隐。但为萨婆若。譬如悭贪人无因缘乃至一钱不施。贪惜积聚但望增长。菩萨亦如是。福德若多若少不向余事。但爱惜积集向萨婆若。问曰。是菩萨未知萨婆若不得其味。云何能得深心。答曰。我先已说。此人若利根诸烦恼薄。福德纯厚不乐世间。虽未闻赞叹大乘。犹不乐世间。何况已闻。如摩诃迦叶。娶金色女为妻。心不爱乐弃舍出家。又如耶舍长者子。中夜见众婇女皆如死状。舍直十万两金宝屐。于水岸边直渡趣佛。如是等诸贵人国王厌舍五欲者无数。何况菩萨闻说佛道种种功德因缘。而不即时发心深入。如后萨陀波仑品中。长者女闻赞叹佛功德。即时舍家诣昙无竭所复次信等五根成就纯熟。故能得是深心。譬如小儿。眼等五情根未成就故。不别五尘不识好丑。信等五根未成就亦复如是。不识善恶不知缚解。爱乐五欲没于邪见。信等五根成就者。乃能识别善恶。十善道声闻法犹尚爱乐。况无上道而不深念。初发无上道心。已于世间最上。何况成就。复次菩萨始得般若波罗蜜气味故。能生深心。如人闭在幽闇微隙见光。心则踊跃作是念言众人。独得见如是光明。欣悦爱乐即生深心。念是光明方便求出。菩萨亦如是。宿业因缘故。闭在十二入无明黑闇狱中。所有知见皆是虚妄。闻般若波罗蜜。少得气味深念萨婆若我当云何于此六情狱得出。如诸佛圣人。复次发阿耨多罗三藐三菩提心。随愿所行。以是故生深心。深心者一切诸法中爱无如爱萨婆若。一切众生中爱无如爱佛。又深入悲心利益众生。如是等名深心相。初地菩萨应常行是心。于一切众生等心者。菩萨得是深心已。等心于一切众生。众生常情爱其所亲恶其所憎。菩萨得深心故。怨亲平等视之无二。此中佛自说。等心者四无量心。是菩萨见众生受乐。则生慈喜心作是愿。我当令一切众生皆得佛乐。若见众生受苦。则生悲心愍之作是愿。我当拔一切众生苦。若见不苦不乐众生。则生舍心作是愿。我当令众生舍爱憎心。四无量心余义如先说。舍心者舍有二种。一者舍财行施。二者舍结得道。此以除悭为舍。与第二舍结作因缘。至七地中乃能舍结。问曰。舍相有种种。内外轻重财施法施世间出世间等。佛何以故。但说无分别忆想出世间施。答曰布施虽有种种相。但说大者不取相。复次佛于一切法不着。亦以此教菩萨布施。令如佛法不着。此中应广说无分别布施。余布施相处处已种种说。近善知识义如先说。求法者法有三种。一者诸法中无上。所谓涅槃。二者得涅槃方便八圣道。三者一切善语实语。助八圣道者。所谓八万四千法众十二部经四藏。所谓阿含阿毗昙毗尼杂藏摩诃般若波罗蜜等。诸摩诃衍经皆名为法。此中求法者。书写诵读正忆念。如是等治众生心病故。集诸法药不惜身命。如释迦文佛本为菩萨时。名曰乐法。时世无佛不闻善语。四方求法精勤不懈。了不能得。尔时魔变作婆罗门而语之言。我有佛所说一偈。汝能以皮为纸以骨为笔以血为墨书写此偈。当以与汝。乐法即时自念。我世世丧身无数不得是利。即自剥皮曝之令干欲书其偈。魔便灭身。是时佛知其至心。即从下方踊出为说深法。即得无生法忍。又如萨陀波仑苦行求法。如释迦文菩萨五百钉钉身。为求法故。又如金坚王。割身五百处。为灯炷投岩入火。如是等种种苦行难行为众生求法。复次佛自说求法相。为萨婆若。不堕声闻辟支佛地。常出家者。菩萨知在家有种种罪因缘。我若在家自不能得行清净行。何能令人得诸净行。若随在家法。则有鞭杖等苦恼众生。若随善法行。则破居家法。筹量二事。我今不出家者。死时俱亦当舍。今自远离福德为大。复次菩萨作是念。一切国王及诸贵人力势如天。求乐未已死强夺之。我今为众生故。舍家持清净戒。求佛道具足尸罗波罗蜜因缘。此中佛自说。菩萨世世不杂心。出家不杂心者。不于九十六种道中出家。但于佛道中出家。所以者何。佛道中有二种。正见世间正见出世间。正见故爱乐佛身者。闻种种赞佛功德十力四无所畏大慈大悲一切智慧。又见佛身三十二相八十种随形好。放大光明。天人供养无有厌足。自知我当来世亦当如是。假令无得佛因缘犹尚爱乐。何况当得而不爱乐。得是深心爱乐佛故。世世常得值佛。演出法教者。菩萨如上求法已为众生演说。菩萨在家者多以财施。出家者爱佛情重常以法施。若佛在世若不在世。善住持戒不求名利。等心一切众生而为说法。赞叹檀义故。名为初善。分别赞叹持戒。名为中善。是二法果报。若生诸佛国若作大天。名为后善。复次见三界五受众身多苦恼。则生厌离心名为初善。弃舍居家为身离故名为中善。为心离烦恼故名为后善。解说声闻乘名为初善。说辟支佛乘名为中善。宣畅大乘名为后善。妙义好语者。三种语虽复辞妙而义味浅薄。虽义理深妙而辞不具足。以是故说妙义好语。离三毒垢故。但说正法不杂非法。是名清净。八圣道分六波罗蜜备故。名为具足。修多罗十二部经如先说。破憍慢者。是菩萨出家持戒说法能断众疑。或时自恃而生憍慢。是时应作是念。我剃头着染衣持钵乞食。此是破憍慢法。我云何于中生憍慢。又此憍慢在人心中。则覆没功德。人所不爱恶声流布。后身常生弊恶畜生中。若生人中卑鄙下贱。知是憍慢有如是无量过罪。破是憍慢。为求阿耨多罗三藐三菩提故。如人求财。犹尚谦逊下意。何况求无上道。以破憍慢故常生尊贵。终不在下贱家生。实语者。是诸善之本生天因缘。人所信受。行是实语者。不假布施持戒学问。但修实语得无量福。实语者如说随行。问曰。口业有四种。何以但说实语。答曰。佛法中贵实故说实。余皆摄四谛。实故得涅槃。复次菩萨与众生共事恶口绮语两舌。或时有妄语罪重故。初地应舍。是菩萨行。初地未能具足。行此四业故但说实语。第二地中则能具足。问曰。初地中何以但说十事。答曰。佛为法王诸法中得自在。知是十法能成初地。譬如良医善知药草种数。若五若十足能破病。是中不应难其多少(初地竟)

【经】云何菩萨戒清净。若菩萨摩诃萨不念声闻辟支佛心及诸破戒障佛道法。是名戒清净。云何菩萨知恩报恩。若菩萨摩诃萨行菩萨道。乃至小恩尚不忘。何况多。是名知恩报恩。云何菩萨住忍辱力。若菩萨于一切众生无嗔无恼。是名住忍辱力。云何菩萨受欢喜。所谓成就众生以此为喜。是名受欢喜。云何菩萨不舍一切众生。若菩萨念欲救一切众生故。是名不舍一切众生。云何菩萨入大悲心。若菩萨如是念。我为一一众生故。如恒河沙等劫地狱中受勤苦。乃至是人得佛道入涅槃。如是名为为一切十方众生忍苦。是名入大悲心。云何菩萨信师恭敬咨受。若菩萨于诸师如世尊想是名信师恭敬咨受。云何菩萨勤求诸波罗蜜。若菩萨一心求诸波罗蜜无异事。是名勤求诸波罗蜜。是为菩萨摩诃萨住二地中满足八法。云何菩萨摩诃萨多学问无厌足诸佛所说法。若是此间世界若十方世界诸佛所说尽欲闻持。是名多学问无厌足。云何菩萨净法施。有所法施乃至不求阿耨多罗三藐三菩提。何况余事。是名不求名利法施。云何菩萨净佛世界。以诸善根回向净佛世界。是名净佛世界。云何菩萨受世间无量勤苦不以为厌。诸善根备具故。能成就众生亦庄严佛界。乃至具足萨婆若终不疲厌。是名受无量勤苦不以为厌。云何菩萨住惭愧处。耻诸声闻辟支佛意。是名住惭愧处。是为菩萨摩诃萨住三地中满足五法。云何菩萨不舍阿兰若住处。能过声闻辟支佛地。是名不舍阿兰若住处。云何菩萨少欲。乃至阿耨多罗三藐三菩提尚不欲。何况余欲。是名少欲。云何菩萨知足。得一切种智。是名知足。云何菩萨不舍头陀功德。观诸深法忍。是名不舍头陀功德。云何菩萨不舍戒。不取戒相。是名不舍戒。云何菩萨秽恶诸欲。欲心不生故。是名秽恶诸欲。云何菩萨厌世间心。知一切法不作故。是名厌世间心。云何菩萨舍一切所有。不惜内外诸法故。是名舍一切所有。云何菩萨心不没。二种识处心不生故。是名心不没。云何菩萨不惜一切物。于一切物不着不念。是名不惜一切物。是为菩萨于四地中不舍十法。云何菩萨远离亲白衣。菩萨出家所生从一佛界至一佛界。常出家剃头着染衣。是名远离亲白衣。云何菩萨远离比丘尼。不共比丘尼住。乃至弹指顷亦不生念。是名远离比丘尼。云何菩萨远离悭惜他家。菩萨如是思惟。我应安乐众生。他今助我安乐云何生悭。是名远离悭惜他家。云何菩萨远离无益谈处。若有谈处。或生声闻辟支佛心我当远离。是名远离无益谈处。云何菩萨远离嗔恚。不令嗔心恼心斗心得入。是名远离嗔恚。云何菩萨远离自大。所谓不见内法故。是名远离自大。云何菩萨远离蔑人。所谓不见外法故。是名远离蔑人。云何菩萨远离十不善道。是十不善道能障八圣道。何况阿耨多罗三藐三菩提。是名远离十不善道。云何菩萨远离大慢。是菩萨不见法可作大慢者。是名远离大慢。云何菩萨远离自用。是菩萨不见是法可自用者。是名远离自用。云何菩萨远离颠倒颠倒处不可得故。是名远离颠倒。云何菩萨远离淫怒痴。淫怒痴处不可见故。是名远离淫怒痴处。是为菩萨住五地中远离十二法。云何菩萨住六地中具足六法。所谓六波罗蜜。诸佛及声闻辟支佛。住六波罗蜜中能度彼岸是名具足六法。云何菩萨不作声闻辟支佛意。作是念。声闻辟支佛意。非阿耨多罗三藐三菩提道云何菩萨布施不生忧心。作是念。此非阿耨多罗三藐三菩提道。云何菩萨见有所索心不没。作是念。此非阿耨多罗三藐三菩提道。云何菩萨所有物布施。菩萨初发心时布施。不言是可与是不可与。云何菩萨布施之后心不悔。慈悲力故。云何菩萨不疑深法。信功德力故。是为菩萨住六地中远离六法

【论】者言。戒清净者。初地中多行布施。次知持戒胜于布施。所以者何。持戒则摄一切众生。布施则不能普周一切。持戒遍满无量。如不杀生戒则施一切众生命。如众生无量无边。福德亦无量无边。略说诸能破佛道事。此中皆名破戒。离是破戒垢皆名清净。乃至声闻辟支佛心尚是戒垢何况余恶。知恩报恩者有人言。我宿世福德因缘应得。或言。我自然尊贵汝有何恩。堕是邪见。是故佛说。菩萨当知恩。众生虽有宿世乐因。今世事不和合则无由得乐。譬如谷种在地无雨则不生。不可以地能生谷故言雨无恩。虽所受之物是宿世所种。供奉之人敬爱好心岂非恩分。复次知恩者。是大悲之本开善业初门。人所爱敬名誉远闻。死则生天终成佛道。不知恩人甚于畜生。如佛说本生经。有人入山伐木迷惑失道。时值暴雨日暮饥寒。恶虫毒兽欲来侵害。是人入一石窟。窟中有一大熊。见之恐怖而出。熊语之言。汝勿恐怖。此舍温暖可于中宿。时连雨七日。常以甘果美水供给此人。七日雨止。熊将此人示其道迳。熊语人言。我是罪身多有怨家。若有问者莫言见我。人答言尔。此人前行见诸猎者。猎者问言。汝从何来。见有众兽不。答言。我见一大熊。此熊于我有恩不得示汝。猎者言。汝是人当以人类相亲。何以惜熊。今一失道何时复来。汝示我者与汝多分。此人心变即将猎者示熊处所。猎者杀熊即以多分与之。此人展手取肉二肘俱堕。猎者言。汝有何罪。答言。是熊看我如父视子。我今背恩。将是此罪。猎者恐怖不敢食肉。持施众僧。尔时上座六通阿罗汉语诸下座。此是菩萨。未来世当得作佛。莫食此肉。即时起塔供养。王闻此事敕下国内。不知恩人无令住此。又以种种因缘赞知恩者。知恩之义遍阎浮提人皆信行。复次菩萨作是念。若人有恶事于我。我犹尚应度。何况于我有恩。住忍辱力者。如忍波罗蜜中广说。问曰。种种因缘是忍辱相。此中何以但说不嗔不恼。答曰。此是忍辱体。先起嗔心然后身口恼他。是菩萨初行故。但说众生忍不说法忍。受欢喜者。菩萨见是持戒故身口清净。知恩忍辱故心清净。三业清净故。则自然生欢喜。譬如人香汤沐浴着好新衣。璎珞庄严镜中自观心生欢喜。菩萨亦如是。得是善法自庄严。戒是禅定智慧根本。我今得是净戒。无量无边福德皆应易得。以是自喜。菩萨住是戒忍中教化众生。令得生他方佛前及生天上人中受乐。或令得声闻辟支佛乘。佛乘者。观众生乐着。如长者观小儿共戏亦与之同戏。更以少异物与之令舍前所好。菩萨亦如是。教化众生令得人天福乐。渐渐诱进令得三乘。以是故言受欢喜乐。不舍一切众生者。善修集大悲心。誓度众生故。发心牢固故。不为诸佛贤圣所轻笑故。恐负一切众生故不舍。譬如先许人物后若不与则是虚妄罪人。以是因缘故不舍众生。入大悲心者。如先说。此中佛自说。本愿大心为众生故。所谓为一一人故。于无量劫代受地狱苦。乃至令是人集行功德作佛入无余涅槃。问曰。无有代受罪者。何以作是愿。答曰。是菩萨弘大之心深爱众生。若有代理必代不疑。复次菩萨见人间有天祠。用人肉血五藏祀罗刹鬼。有人代者则听。菩萨作是念。地狱中若当有如是代理我必当代。众人闻菩萨大心如是。则贵敬尊重之。所以者何。是菩萨深念众生踰于慈母故。信师恭敬咨受者。菩萨因师得阿耨多罗三藐三菩提。云何不信恭敬供养师。虽智德高明。若不恭敬供养。则不能得大利。譬如深井美水若无绠者无由得水。若破憍慢高心。宗重敬伏则功德大利归之。又如雨堕不住山顶必归下处。若人憍心自高则法水不入。若恭敬善师则功德归之。复次佛说。依止善师。持戒禅定智慧解脱皆得增长。譬如众树依于雪山。根茎枝叶华果皆得茂盛以是故。佛说于诸师宗敬之如佛。问曰。恶师云何得供养信受。善师不能视之如佛。何况恶师。佛何以故。此中说于诸师尊如世尊想。答曰。菩萨不应顺世间法。顺世间法者。善者心着恶者远离。菩萨则不然。若有能开释深义解散疑结。于我有益则尽心敬之不念余恶。如弊囊盛宝不得以囊恶故不取其宝。又如夜行崄道弊人执炬。不得以人恶故不取其照。菩萨亦如是。于师得智慧光明不计其恶。复次弟子应作是念。师行般若波罗蜜无量方便力。不知以何因缘故有此恶事。如萨陀波仑。闻空中十方佛教。汝于法师莫念其短常生敬畏。复次菩萨作是念。法师好恶非是我事。我所求者唯欲闻法以自利益。如泥像木像无实功德。因发佛想故得无量福德。何况是人智慧方便能为人说。以是故。法师有过于我无咎。如世尊想者。我先说。菩萨异于世人。世人分别好丑。好者爱着犹不如佛。恶者轻慢了不比数。菩萨则不然。观诸法毕竟空。从本已来皆如无余涅槃相。观一切众生视之如佛。何况法师。有智慧利益。以能作佛事故视之如佛。勤求诸波罗蜜者。菩萨作是念。是六波罗蜜是无上正真道因缘。我当一心行是因缘。譬如商人农夫。随所适国土。所须之物地之所宜种子。勤修求办事无不成。又如今世行布施后得大富。持戒后得尊贵。修禅定智慧得道。菩萨亦如是。行六波罗蜜则得成佛。勤求道者。常一心勤求六波罗蜜。所以者何。若软心渐进。则为烦恼所覆魔人所坏。以是故佛说。于二地中勤求莫懈。(二地竟)多学问无厌足者。菩萨知多学问是智慧因缘。得智慧则能分别行道。如人有眼所至无碍。是故菩萨作是愿十方诸佛有所说法我尽受持。闻持陀罗尼力故。得清净天耳力故。得不忘陀罗尼力故。譬如大海能受持一切十方诸水。菩萨亦如是。能受持十方诸佛所说之法。净法施者。如苗中生草除秽则茂。菩萨亦如是。法施时不求名利后世果报。乃至为众生故。不求小乘涅槃。但以大悲于众生。随佛转法轮法施相庄严佛国相。受世间无量勤苦住惭愧处。不舍阿兰若住处。少欲知足如先说。问曰。种种因缘在生死中不厌。何以故。但二因缘说不厌。答曰。是善根备具故。在生死中苦恼薄少。譬人有疮良药涂之其痛差少。菩萨得善根清净故。今世忧愁嫉妒恶心等悉皆止息。若更受身得善根果报。自受福乐。亦种种因缘利益众生。随其所愿自净世界。世界严净胜于天宫视之无厌。能慰释大菩萨心。何况凡夫。以是故。虽有多因缘。但说二事无厌。惭愧虽有种种。此中大者声闻辟支佛心。菩萨发心欲广度一切众生。得少苦恼便欲独取涅槃。是可惭愧。譬如有人大设肴膳请呼众人。悭吝心起便自独食。甚可惭愧。(三地竟)不舍阿兰若住处者。离众独住。若过声闻辟支佛心。是名离众。一切法以无所得空故。不取不着相。乃至阿耨多罗三藐三菩提亦不取。用无有着心故。菩萨常集诸功德无厌足。得无上道则足。更无胜法故。饮食衣服卧具知足者。是善法因缘。不以为要故不说。不舍头陀功德者。如后觉魔品中说无生法忍。此中以无生法忍为头陀。菩萨住于顺忍观无生法忍。是十二头陀为持戒清净故。持戒清净为禅定故。禅定为智慧故。无生忍法即是真智慧。无生法忍是头陀果报。果中说因故。不舍戒不取戒相者。是菩萨知诸法实相故。尚不见持戒。何况破戒。虽种种因缘不破戒。此最为大入空解脱门故。污秽诸欲者。如先说。此中佛说。知是心相虚诳不实故。乃至不生欲心。何况受欲。厌世间心者。如世间不可乐相中说。此中佛说厌心。果报所谓无作解脱门。舍一切所有者。如先说。不没心者。先已种种因缘说。菩萨闻是不没不畏相不生二识处者。二识处所谓眼色中不生眼识。乃至意法中不生意识。菩萨住是不二门中。观六识所知皆是虚诳无实。作大誓愿。令一切众生住不二法中离是六识。不惜一切物者。不惜一切物中虽有种种因缘。此因缘最大。所谓菩萨知一切法毕竟空。不忆念灭一切取相。是故于受者不求恩。惠施中无高心。如是具清净檀波罗蜜。(四地竟)远离亲白衣者。行者以妨道故出家。若复习近白衣。则与本无异。以是故。行者先求自度然后度人。若未能自度而欲度人者。如不知浮人欲救于溺相与俱没。是菩萨远离亲白衣。则能集诸清净功德。深念佛故。变身至诸佛国。出家剃头着染衣。所以者何。常乐出家法。不乐习近白衣故。远离比丘尼者。如初品中说。问曰。菩萨等心视一切众生。云何不得共住。答曰。是菩萨未得阿鞞跋致。未断诸漏集诸功德人所乐着。以是故不得共住。又为离人诽谤。若诽谤者堕地狱故。远离悭惜他家者。菩萨作是念。我自舍家尚不贪不惜。云何贪惜他家。菩萨法欲令一切众生得乐。彼人助我与众生乐。云何悭惜。众生先世福德因缘。今世少有功夫故得供养我。何以悭嫉。远离无益谈说者。此即是绮语。为自心他心解愁事。说王法事贼事大海山林药草宝物诸方国土如是等事。无益于福无益于道。菩萨愍念一切众生没在无常苦火。我当救济。云何安坐空说无益之事。如人失火四边俱起。云何安处其内语说余事。此中佛说。若说声闻辟支佛事。犹为无益之言。何况余事。远离嗔恚者。心中初生名嗔心。以未定故。嗔心增长事定打斫杀害。是名恼心。恶口谗谤。是名讼心。若杀害打缚等。是名斗心。菩萨大慈悲众生故。则不生是心。常防此恶心不令得入。远离自大蔑人者。不见内外法。所谓受五众不受五众。远离十不善道者。菩萨观十不善道中过罪种种因缘。如先说。此中佛说十不善道破小乘。何况大乘。远离大慢者。菩萨行十八空。不见诸法定有大小相。远离自用者。拔七种憍慢根本故。又深乐善法故。远离颠倒者。一切法中常乐净我不可得故。远离三毒者。三毒义如先说。又此三毒所缘无有定相。(五地竟)六波罗蜜者如先说。此中佛说。三乘之人皆以此六波罗蜜得到彼岸。问曰。此是菩萨地。何以故说声闻辟支佛得到彼岸。答曰。佛今说六波罗蜜多有所能。大乘法中则能含受小乘。小乘则不能。是菩萨住六地中。具足六波罗蜜。观一切诸法空。未得方便力。畏堕声闻辟支佛地。佛将护故说不应生声闻辟支佛心。菩萨深念众生故。大悲心故。知一切诸法毕竟空故。施时无所惜。见有求者不嗔不忧。布施之后心亦不悔。福德大故信力亦大。深清净信敬诸佛。具足六波罗蜜。虽未得方便。无生法忍般舟三昧。于深法中亦无所疑。作是念。一切论议皆有过罪。唯佛智慧灭诸戏论。无有阙失故。而能以方便修诸善法。是故不疑(六地竟)

大智度论卷第四十九大智度论释发趣品第二十之余(卷五十)

        龙树菩萨造

        后秦龟兹国三藏鸠摩罗什译

【经】云何菩萨不着我。毕竟无我故。云何菩萨不着众生。不着寿命。不着众数乃至知者见者。是诸法毕竟不可得故。云何菩萨不着断见。无有法断。诸法毕竟不生故。云何菩萨不着常见。若法不生是不作常。云何菩萨不应取相。无诸烦恼故。云何菩萨不应作因见。诸见不可得故。云何菩萨不著名色。名色处相无故。云何菩萨不着五众。不着十八界。不着十二入。是诸法性无故。云何菩萨不着三界。三界性无故。云何菩萨不应作着心。云何菩萨不应作愿。云何菩萨不应作依止。是诸法性无故。云何菩萨不着依佛见。作依见不见佛故。云何菩萨不着依法见。法不可见故。云何菩萨不着依僧见。僧相无为不可依故。云何菩萨不着依戒见。罪无罪不着故。是为菩萨住七地中二十法所不应。着云何菩萨应具足空。具足诸法。自相空故。云何菩萨无相证。不念诸相故。云何菩萨知无作。于三界中不作故。云何菩萨三分清净十善道具足故。云何菩萨一切众生中慈悲智具足。得大悲故。云何菩萨不念一切众生。净佛世界具足故。云何菩萨一切法等观。于诸法不损益故。云何菩萨知诸法实相。诸法实相无知故。云何菩萨无生忍。为诸法不生不灭不作故。云何菩萨无生智。知名色不生故。云何菩萨说诸法一相。心不行二相故。云何菩萨破分别相。一切法不分别故。云何菩萨转忆想。小大无量想转故。云何菩萨转见。于声闻辟支佛地见转故。云何菩萨转烦恼断。诸烦恼故。云何菩萨等定慧地。所谓得一切种智故。云何菩萨调意。于三界不动故。云何菩萨心寂灭。制六根故。云何菩萨无碍智。得佛眼故。云何菩萨不染爱。舍六尘故。是为菩萨住七地中具足二十法

云何菩萨顺入众生心。菩萨以一心知一切众生心及心数法。云何菩萨游戏诸神通。以是神通从一佛国至一佛国。亦不作佛国想。云何菩萨观诸佛国。自住其国见无量诸佛国。亦无佛国想。云何菩萨如所见佛国自庄严其国。住转轮圣王地。遍至三千大千世界以自庄严。云何菩萨如实观佛身。如实观法身故。是为菩萨住八地中具足四法。云何菩萨知上下诸根。菩萨住佛十力。知一切众生上下诸根。云何菩萨净佛世界。净众生故。云何菩萨如幻三昧。住是三昧能成办一切事。亦不生心相。云何菩萨常入三昧。菩萨得报生三昧故云何菩萨随众生所应善根受身。菩萨知众生所应生善根。而为受身成就众生故。是为菩萨住八地中具足五法。云何菩萨受无边世界所度之分。十方无量世界中众生。如诸佛法所应度者而度脱之。云何菩萨得如所愿。六波罗蜜具足故。云何菩萨知诸天龙夜叉犍闼婆。诸辞辩力故。云何菩萨胎生成就。菩萨世世常化生故。云何菩萨家成就。常在大家生故。云何菩萨所生成就。若刹利家生若婆罗门家生故。云何菩萨性成就。如过去菩萨所生姓。从此中生故。云何菩萨眷属成就。纯诸菩萨摩诃萨为眷属故。云何菩萨出生成就。生时光明遍照无量无边世界。亦不取相故。云何菩萨出家成就。出家时无量百千亿诸天侍从出家。是一切众生必至三乘

云何菩萨庄严佛树成就。是菩提树以黄金为根。七宝为茎节枝叶。茎节枝叶。光明遍照十方阿僧祇三千大千世界。云何菩萨一切诸善功德成满具足。菩萨得众生清净佛国亦净。是为菩萨。住九地中具足十二法。云何菩萨住十地中当知如佛。若菩萨摩诃萨具足六波罗蜜四念处乃至十八不共法一切种智。具足满断一切烦恼及习。是为菩萨摩诃萨住十地中当知如佛。须菩提。菩萨摩诃萨住是十地中。以方便力故行六波罗蜜。行四念处乃至十八不共法。过干慧地性地八忍地见地薄地离欲地已作地辟支佛地菩萨地。过是九地住于佛地。是为菩萨十地。如是须菩提。是名菩萨摩诃萨大乘发趣

【论】者言。我等二十法不可得故不着。不可得因缘如先种种说。我见乃至知者见者佛见僧见。是入众生空故。是见不应着。余断常乃至戒见。是法空故不应着。问曰。余者可知。因见云何。答曰。一切有为法展转为因果。是法中着心取相生见。是名因见。所谓非因说因。或因果一异等。具足空者。若菩萨能尽行十八空。是名具足空。复次能行二种空。众生空法空。是名具足空。复次若菩萨能行毕竟空于中不着。是名具足空。问曰。若尔者佛此中何以但说自相空。答曰。此三种空皆是自相空。以住六地菩萨福德故利根。利根故分别诸法取相。以是故。七地中以相空为具足空。佛或时说有为空无为空名具足空。或时说不可得空名具足空。无相证者。无相即是涅槃。可证不可修。不可修故不得言知。无量无边不可分别。故不得言具足。知无作者。三事虽通是知。二事更义立其名。无作但有知名。三分清净者。所谓十善道身三口四意三。是名三分。上以说三解脱门故。此中不复说。三分清净者。或有人身业清净口业不清净。口业清净身业不清净。或身口业清净意业不清净。或有世间三业清净。而未能离着。是菩萨三业清净及离着故。是名三分清净。一切众生中具足慈悲智者。悲有三种。众生缘法缘无缘。此中说无缘大悲名具足。所谓法性空乃至实相亦空。是名无缘大悲。菩萨深入实相。然后悲念众生。譬如人有一子。得好宝物则深心爱念欲以与之。不念一切众生者。所谓净世界具足故。问曰。若不念众生者。云何能净佛世界。答曰。菩萨令众生住十善道。为庄严佛国。虽庄严未得无碍庄严。今菩萨教化众生不取众生相。诸善根福德清净。诸善根福德清净故。是无碍庄严。一切法等观者。如法等忍中说。此中佛自说。于诸法不增损。知诸法实相者。如先种种因缘广说。无生法忍者。于无生灭诸法实相中。信受通达无碍不退。是名无生忍。无生智者。初名忍后名智。粗者忍细者智。佛自说。知名色不生故。说诸法一相者。菩萨知内外十二入。皆是魔网虚诳不实。于此中生六种识。亦是魔网虚诳。何者是实唯不二法。无眼无色乃至无意无法等是名实。令众生离十二入故。常以种种因缘说是不二法。破分别相者。菩萨住是不二法中。破所缘男女长短大小等。分别诸法。转忆想者。破内心忆想分别诸法等。转见者。是菩萨先转我见边见等邪见。然后入道。今转法见涅槃见。以诸法无定相。转涅槃者。转声闻辟支佛见直趣佛道。转烦恼者。菩萨以福德持戒力故。折伏粗烦恼安隐行道。唯有爱见慢等微细者在。今亦离细烦恼。复次菩萨用实智慧观是烦恼即是实相。譬如神通人能转不净为净等定慧地者。菩萨于初三地慧多定少。未能摄心故。后三地定多慧少。以是故不得入菩萨位。今众生空法空定慧等故。能安隐行菩萨道。从阿鞞跋致地。渐渐得一切种智。慧地调意者。是菩萨先忆念老病死三恶道。慈愍众生故调伏心意。今知诸法实相故不着三界。不着三界故调伏。心寂灭者。菩萨为涅槃故。先于五欲中折伏五情。意情难折伏故。今住七地意情寂灭。无碍智者。菩萨得般若波罗蜜。于一切实不实法中无碍。得是道慧将一切众生令入实法。得无碍解脱得佛眼。于一切法中无碍。问曰。是七地中何以说得佛眼。答曰。是中应学佛眼。于诸法无碍似如佛眼。不染爱者。是菩萨虽于七地得智慧力。犹有先世因缘有此肉身。入禅定不着。出禅定时有着气随此肉眼所见。见好人亲爱。或爱是七地智慧实法。是故佛说。于六尘中行舍心不取好恶相。(七地竟)顺入众生心者。菩萨住是八地中。顺观一切众生心之所趣。动发思惟深念顺观。以智慧分别。知是众生永无得度因缘。是众生过无量阿僧祇劫然后可度。是众生或一劫二劫乃至十劫可度。是众生或一世二世乃至今世可度。是众生或即时可度者。是熟是未熟。是人可以声闻乘度。是人可以辟支佛乘度。譬如良医诊病知差久近可治不可治者。游戏诸神通者。先得诸神通。今得自在游戏。能至无量无边世界。菩萨住七地中时欲取涅槃。尔时有种种因缘。及十方诸佛拥护。还生心欲度众生。好庄严神通随意自在。乃至无量无边世界中无所挂碍。见诸佛国亦不取佛国相。观诸佛国者。有菩萨以神通力飞到十方。观诸清净世界。取相欲自庄严其国。有菩萨佛将至十方。示清净世界。取净国相自作愿行。如世自在王佛。将法积比丘至十方。示清净世界。或有菩萨自住本国。用天眼见十方清净世界。初取净相后得不着心故还舍。如所见佛国自庄严其国者。如先说。是八地名转轮地。如转轮王宝轮至处无碍无障无诸怨敌。菩萨住是地中。能雨法宝满众生愿无能障碍。亦能取所见净国相而自庄严其国。如实观佛身者。观诸佛身如幻如化。非五众十二入十八界所摄。若长若短若干种色。随众生先世业因缘所见。此中佛自说。见法身者。是为见佛。法身者。不可得法空。不可得法空者。诸因缘边生。法无有自性。知上下诸根者。如十力中说。菩萨先知一切众生心所行。谁钝谁利谁布施多谁智慧多。因其多者而度脱之。净佛世界者。有二种净。一者菩萨自净其身。二者净众生心令行清净道。以彼我因缘清净故。随所愿得清净世界。入如幻三昧者。如幻人一处住所作幻事遍满世界。所谓四种兵众宫殿城郭。饮食歌舞杀活忧苦等。菩萨亦如是。住是三昧中。能于十方世界变化遍满其中。先行布施等充满众生。次说法教化破坏三恶道。然后安立众生。于三乘一切所可利益之事无不成就。是菩萨心不动。亦不取心相。常入三昧者。菩萨得如幻等三昧。所役心能有所作。今转身得报生三昧。如人见色不用心力。住是三昧中。度众生安隐胜于如幻三昧。自然成事无所役用。如人求财。有役力得者有自然得者。随众生所应善根受身者。菩萨得二种三昧二种神通行得报得。知以何身以何语以何因缘以何事以何道以何方便。而为受身。乃至受畜生身而化度之(八地竟)受无边世界所度之分者。无量阿僧祇十方世界六道中众生。是菩萨教化所应度者而度之。是世界有三种有净不净有杂。是三种世界中众生。所可应度有利益者。皆摄取之。譬如然灯为有目之人不为盲者。菩萨亦如是。或先有因缘者。或始作因缘者。复次三千大千世界名一世界。一时起一时灭。如是等十方如恒河沙等世界是一佛世界。如是一佛世界数。如恒河沙等世界是一佛世界海。如是佛世界海数。如十方恒河沙世界是佛世界种。如是世界种十方无量。是名一佛世界。于一切世界中取如是分。是名一佛所度之分。得如所愿者。是菩萨福德智慧具足故。无愿不得。听者闻无量无边世界所度之分。疑不可得。以是故次说所愿如意。此中佛自说六波罗蜜具足。五度则福德具足。般若则智慧具足。知诸天龙夜叉犍闼婆语者。我上说福德智慧具足所愿如意。知他人种种语。即是所愿事。复次菩萨得宿命智清净故。知处处生一切语。复次得愿智故。知立名者心强作种种名字语言。复次菩萨得解众生语言三昧故。通一切语无碍。复次自得四无碍智。又复学佛四无碍智。以是故知众生语言音声。处胎成就者。有人言。菩萨乘白象与无量兜率诸天围绕恭敬供养。侍从入母胎。有人言。菩萨母得如幻三昧力故。令腹广大无量。一切三千大千世界菩萨及天龙鬼神皆得入出胎中。有宫殿台观。先庄严床座。悬缯幡盖散花烧香。皆是菩萨福德业因缘所感。然后菩萨来下处之。亦以三昧力故下入母胎。于兜率天上如故。生成就者。菩萨欲生时。诸天龙鬼神庄严三千大千世界。是时有七宝莲花座自然而有。从母胎中有无量菩萨先出坐莲华上。叉手赞叹俟待。菩萨及诸天龙鬼神仙圣诸玉女等。皆合手一心欲见菩萨生。然后菩萨从母右胁出。如满月从云中出。放大光明照无量世界。是时有大名声遍满十方世界。唱言某国菩萨末后身生。或有菩萨化生莲华。于四生中菩萨胎生化生。于四种人中菩萨生刹利婆罗门二姓中。生此二种姓人所贵故。家成就者。婆罗门家有智慧。刹利家有力势。婆罗门利益后世。刹利利益今世。是二种于世有益。是故菩萨在此中生。复次诸功德法家。所谓不退转生。是名家生。姓成就者。菩萨兜率天上观世间。何姓为贵能摄众生。即于是姓中生。如七佛中初三佛。憍陈如姓中生。次三佛迦叶姓中生。释迦文尼佛憍昙姓中生。复次菩萨初深心牢固。是名诸佛姓。有人言。得无生法忍是诸佛姓。是时得佛一切种智气分故。如声闻法中姓地人。眷属成就者。皆是智人善人世世集功德。此中佛自说。纯以菩萨为眷属。如不可思议经中说。瞿毗耶是大菩萨。一切眷属皆是住阿毗跋致地。菩萨以方便三昧变化力。为男为女共为眷属。如转轮圣王居士宝。是夜叉鬼神现作人身与人共事。出家成就者。如释迦文菩萨。夜于宫殿见诸婇女皆如死状。十方诸天鬼神赍持幡华供养之具。奉迎将出。是时车匿虽先受净饭王敕。而随菩萨意自牵马至。四天王使者接捧马足踰城而出。为破诸烦恼及魔人示一切众人在家之秽。如此大功德贵重之人犹尚出家。况诸凡细。如是等因缘名出家成就。庄严佛树成就者。庄严菩提树如先说。佛此中自说。是菩提树以黄金为根。七宝为茎节枝叶。茎节枝叶光明遍照十方无数阿僧祇诸佛世界。或有佛以菩萨七宝庄严佛树。或有不如是者。所以者何。诸佛神力不可思议。为众生故现种种庄严。一切诸善功德成满具足者。菩萨住七地中。破诸烦恼自利具足。住八地九地利益他人。所谓教化众生净佛世界。自利利他深大故。一切功德具足。如阿罗汉辟支佛。自利虽重利他轻故不名具足。诸天及小菩萨虽能利益他。而自未除烦恼故亦不具足。是名功德具足。(九地竟)当知如佛者。菩萨坐如是树下入第十地。名为法云地。譬如大云澍雨连下无间。心自然生无量无边清净诸佛法念念无量。尔时菩萨作是念。欲界魔王心未降伏。放眉间光令百亿魔宫闇蔽不现。魔即嗔恼集其兵众来逼菩萨。菩萨降魔已。十方诸佛庆其功勋。皆放眉间光从菩萨顶入。是时十地所得功德变为佛法。断一切烦恼习。得无碍解脱。具十力四无所畏四无碍智十八不共法大慈大悲等无量无边诸佛法。是时地为六种震动。天雨华香。诸菩萨天人皆合手赞叹。是时放大光明遍照十方无量世界。十方诸佛菩萨天人大声唱言。某方某国某甲菩萨。坐于道场成具佛事。是其光明。是名十地当知如佛。复次佛此中更说第十地相。所谓菩萨行六波罗蜜。以方便力故。过干慧地乃至菩萨地住于佛地。佛地即是第十地。菩萨能如是行十地。是名发趣大乘

    大智度论释出到品第二十一

【经】佛告须菩提。汝所问是乘何处出至何处住者。佛言。是乘从三界中出。至萨婆若中住。以不二法故。何以故。摩诃衍萨婆若是二法。共不合不散无色无形无对一相所谓无相。若人欲使实际出。是人为欲使无相法出。若人欲使如法性不可思议性出。是人为欲使无相法出。若人欲使色空出。是人为欲使无相法出。若人欲使受想行识空出。是人为欲使无相法出。何以故。须菩提。色空相不出三界。亦不住萨婆若。受想行识空相不出三界。亦不住萨婆若。所以者何。色色相空。受想行识识相空故。若人欲使眼空出。是人为欲使无相法出。若人欲使耳鼻舌身意空出。是人为欲使无相法出。若人欲使乃至意触因缘生受空出。是人为欲使无相法出。何以故。须菩提。眼空不出三界。亦不住萨婆若。乃至意触因缘生受空不出三界。亦不住萨婆若。所以者何。眼眼相空。乃至意触因缘生受意触因缘生受相空故。若人欲使梦出。是人为欲使无相法出。若人欲使幻焰响影化出。是人为欲使无相法出。何以故。须菩提。梦相不出三界。亦不住萨婆若。幻焰响影化相亦不出三界。亦不住萨婆若。须菩提。若人欲使檀波罗蜜出。是人为欲使无相法出。若人欲使尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜出。是人为欲使无相法出。何以故。檀波罗蜜相不出三界。亦不住萨婆若。尸罗波罗蜜乃至般若波罗蜜不出三界。亦不住萨婆若。所以者何。檀波罗蜜檀波罗蜜相空。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜般若波罗蜜相空故。若人欲使内空出。乃至无法有法空出。是人为欲使无相法出。何以故。须菩提。内空相乃至无法有法空相不出三界。亦不住萨婆若。所以者何。内空内空性空。乃至无法有法空无法有法空性空故。若人欲使四念处出。是人为欲使无相法出。何以故。四念处性不出三界。亦不住萨婆若。所以者何。四念处四念处性空故。若人欲使四正勤四如意足五根五力七觉分八圣道分出。是人为欲使无相法出。何以故。八圣道分性不出三界。亦不住萨婆若。所以者何。八圣道分八圣道分性空故。乃至十八不共法亦如是。须菩提。若人欲使阿罗汉出生处。是人为欲使无相法出。若人欲使辟支佛出生处。是人为欲使无相法出。若人欲使多陀阿伽度阿罗诃三藐三佛陀出生处。是人为欲使无相法出。何以故。须菩提。阿罗汉性辟支佛性佛性不出三界。亦不住萨婆若。所以者何。阿罗汉阿罗汉性空。辟支佛辟支佛性空。佛佛性空故。若人欲使须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道佛道一切种智出。是人为欲使无相法出。如上说。若人欲使名字假名施设相但有语言出。是人为欲使无相法出。何以故。名字空不出三界。亦不住萨婆若。所以者何。名字相名字相空故。乃至施设亦如是。若人欲使不生不灭法不垢不净无作法出。是人为欲使无相法出。何以故。不生乃至无作法性不出三界。亦不住萨婆若。所以者何。不生性乃至无作性性空故。须菩提。以是因缘故。摩诃衍从三界中出。至萨婆若中住。不动法故

【论】问曰。佛已知须菩提所问。今何以更称而答。答曰。是摩诃般若波罗蜜有十万偈三百二十万言。与四阿含等。此非一坐说尽。又上须菩提所问已答。二事异时异日故。称第三问而答。复次有人言。声闻法中无有不可思议事。不得一日一坐中说尽。佛有无碍解脱。菩萨有不可思议三昧。能令多时作少时。少时作多时。亦能以大色入小。小色作大。又如六十小劫说法华经人谓从日至食。问曰。色有形可见。时无形但有名。云何得以近为远以远为近。答曰。以是故说。以不可思议神通力。如人梦中梦有所见自以为觉。梦中复梦。如是展转故是一夜。以是故更称其问而答。是乘何处出至何处住者。佛答。是乘从三界中出。至萨婆若中住。问曰。是乘为是佛法。为是菩萨法。若是佛法云何从三界出。若是菩萨法云何萨婆若中住。答曰。是乘是菩萨法乃至金刚三昧。是诸功德清净变为佛法。是乘有大力。能有所去直以至佛。更无胜处可去故言住。譬如劫尽火烧三千世界势力甚大。更无所烧故便自灭。摩诃衍亦如是。断一切烦恼。集诸功德尽其边际。更无所断。更无所知。更无所集故。便自归灭。不二法者。断诸菩萨着故说。此中佛自说。大乘萨婆若是二法不一故不合。不异故不散。六情所知尽虚妄故。无色无形无对一相。问曰。先言不一故不合。今何以言一相。答曰。此中言一相。所谓无相。无相则无有出至佛道。为引导凡夫人故。说言一相。实际者。是诸法末后。实相无出无入。若有狂人欲使实际出至佛道者。此人则欲使无相法出。如法性法相如先说。不可思议性者。有人言。即是如法性实际无量无边心心数法灭。故言不可思议。复有人言。过实际涅槃更求诸法实。若有若无。是名不可思议。复次一切诸佛法无有能思惟筹量者。故名不可思议。复有人言。一切诸法分别思惟皆同涅槃相。是不可思议。若人欲使空中出。此人则欲使无相法中出。此中佛自说。五众空相不能出三界。不能至萨婆若。五众中五众相空故。十二入乃至意触因缘生受空亦如是。梦等空譬喻亦如是。自相空故无出无至。若人欲使六波罗蜜出。此人则为欲使无相法出。何以故。六波罗蜜因缘和合故无自性。自性无故空。菩萨着六波罗蜜。堕邪道故为说空。十八空乃至一切种智亦如是。问曰。六波罗蜜有道俗。俗可着故可说空。出世间六波罗蜜三十七品。乃至十八不共法无所著故。何以说空。答曰。诸菩萨漏未尽。以福德智慧力故行是法。或取相爱着故。凡夫法虚妄颠倒。此法从凡夫法边生。云何是实。以是故佛说是亦空。以喻无相法。是大乘即是无相。无相云何有出有至。诸法皆空但有名字相假名语言。今名字等亦空。以喻无相。第一义中不可得。世俗法中有相。名字等假名相义如先说。用如是法从三界出至萨婆若中住。非是实法。亦无所动

【经】须菩提。汝所问是乘何处住者。须菩提。是大乘无住处。何以故。一切法无住相故。是乘若住不住法住。须菩提。譬如法性。不生不灭不垢不净。无起无作非住非不住。须菩提。是乘亦如是。非住非不住。何以故。法性相乃至无作相。非住非不住。所以者何。法性相性空故。乃至无作性无作性性空故。诸余法亦如是。须菩提。以是因缘故。是乘无住处。以不住法不动法故

【论】问曰。上言是乘到萨婆若更无胜法可去。今何以复说是乘无住处。答曰。先说以空不二法故言住。如幻如梦。虽有坐卧行住非实是住。菩萨亦如是。虽言到萨婆若住。亦无定住。佛此中自说。一切法从本已来无住相云何独大乘有住。若有所住以毕竟空法住。譬如如法性法相实际非住非不住不生不灭不垢不净不起不作。不住者。自相中不住。非不住者。异相中不住。不住者。说空破有。非不住者。说世谛方便有住。不住者。说无常破常相。非不住者。破灭相。此中佛自说。法性法性相空。何以故。自相空故。乃至无起无作。诸余法亦如是

【经】须菩提。汝所问谁当乘是乘出者。无有人乘是乘出者。何以故。是乘及出者所用法及出时。是一切法皆无所有。若一切法无所有。用何等法当出。何以故。我不可得乃至知者见者不可得。毕竟净故。不可思议性不可得。毕竟净故。众入界不可得。毕竟净故。檀波罗蜜不可得。毕竟净故。乃至般若波罗蜜不可得。毕竟净故。内空不可得。毕竟净故。乃至无法有法空不可得。毕竟净故。四念处不可得。乃至十八不共法不可得。毕竟净故。须陀洹不可得。乃至阿罗汉辟支佛菩萨佛不可得。毕竟净故。须陀洹果乃至阿罗汉果辟支佛道佛道一切种智不可得。毕竟净故。不生不灭不垢不净无起无作不可得毕竟净故。过去世未来世现在世生住灭不可得。毕竟净故。增减不可得毕竟净故。何法不可得故不可得。法性不可得故不可得。如实际不可思议性法性法相法位檀波罗蜜不可得故不可得。乃至般若波罗蜜不可得故不可得。内空不可得故不可得。乃至无法有法空不可得故不可得。四念处不可得故不可得。乃至十八不共法不可得故不可得。须陀洹不可得故不可得。乃至佛不可得故不可得。须陀洹果不可得故不可得。乃至佛道不可得故不可得。不生不灭乃至不起不作不可得故不可得。复次须菩提。初地不可得故不可得。乃至第十地不可得故不可得。毕竟净故。云何为初地乃至十地。所谓干慧地性地八人地见地薄地离欲地已作地辟支佛地菩萨地佛地。内空中初地不可得。乃至无法有法空中初地不可得。内空乃至无法有法空中第二第三第四第五第六第七第八第九第十地不可得。何以故。须菩提。初地非得非不得。乃至十地非得非不得。毕竟净故。内空乃至无法有法空中成就众生不可得。毕竟净故。内空乃至无法有法空中净佛世界不可得。毕竟净故。内空乃至无法有法空中五眼不可得。毕竟净故。如是须菩提。菩萨摩诃萨以一切诸法不可得故乘是摩诃衍出萨婆若

【论】者言。出者行是乘到佛道边出。又复以成就故名出。以是乘成就萨婆若。是名为出。此中佛自说空因缘。乘者是六波罗蜜所用。法者是慈悲方便等诸法六波罗蜜所不摄。出者是菩萨。是三法皆空。此中佛复说因缘。我不可得乃至知者见者不可得。毕竟空故。五众十二入十八界檀波罗蜜。乃至十八不共法须陀洹乃至萨婆若。不生不灭不垢不净。乃至三世三相增减等。是名法空。我乃至知者见者。须陀洹乃至佛。是名众生空。问曰。有二种不可得。一者有法智慧少故不能得。二者有大智慧推求不能得。此云何不可得。答曰。是法无故不可得。问曰。一切法本末不可得。于人有何利益。答曰。此中佛自说。毕竟清净故。毕竟者。若行者依无而破有。于有得清净。于无未清净。以依止故。此中佛自说不可得因缘。一切众生不可得一切法不可得。譬如如法性实际等乃至不作不起不可得。复次十八空故。法性不可得。乃至不起不作十八空中。无初地乃至十地。无成就众生。无净佛世界。无五眼。以十八空故空。毕竟清净故不可得。菩萨用不可得法。乘是乘出萨婆若

大智度论卷第五十(释第十九品讫第二十品)大智度论释胜出品第二十二(卷五十一)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】慧命须菩提白佛言。世尊。摩诃衍摩诃衍者。胜出一切世间及诸天人阿修罗。世尊。是摩诃衍与虚空等。如虚空受无量无边阿僧祇众生。摩诃衍亦如是。受无量无边阿僧祇众生。世尊。是摩诃衍不见来处不见去处不见住处。是摩诃衍前际不可得后际不可得中际不可得。三世等是摩诃衍。世尊。以是故是乘名摩诃衍。佛告须菩提。如是如是。菩萨摩诃萨摩诃衍。所谓六波罗蜜。檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。是名菩萨摩诃萨摩诃衍。复次须菩提。菩萨摩诃萨摩诃衍所谓一切陀罗尼门一切三昧门所谓首楞严三昧。乃至离着虚空不染三昧。是名菩萨摩诃萨摩诃衍。复次须菩提。菩萨摩诃萨摩诃衍。所谓内空乃至无法有法空。是名菩萨摩诃萨摩诃衍。复次须菩提。菩萨摩诃萨摩诃衍。所谓四念处乃至十八不共法。是名菩萨摩诃萨摩诃衍。如须菩提所言。是摩诃衍胜出一切世间及诸天人阿修罗。须菩提。若欲界当有实不虚妄不异谛不颠倒。有常不坏相非无法者。是摩诃衍不能胜出一切世间及诸天人阿修罗。须菩提。以欲界虚妄忆想分别和合名字等有一切无常相无法。以是故摩诃衍胜出一切世间及诸天人阿修罗。须菩提。色界无色界若当实有不虚妄不异谛不颠倒。有常不坏相非无法者。是摩诃衍不能胜出一切世间及诸天人阿修罗。须菩提。以色界无色界虚妄忆想分别和合名字等有一切无常破坏相无法。以是故摩诃衍胜出一切世间及诸天人阿修罗。须菩提。若色当实有不虚妄不异谛不颠倒有常不坏相非无法者。是摩诃衍不能胜出一切世间及诸天人阿修罗。须菩提。以色虚妄忆想分别和合名字等有一切无常破坏相无法。以是故是摩诃衍胜出一切世间及诸天人阿修罗。受想行识亦如是。须菩提。若眼乃至意。色乃至法。眼识乃至意识。眼触乃至意触。眼触因缘生受乃至意触因缘生受。若当实有不虚妄不异谛不颠倒有常不坏相非无法者。是摩诃衍不能胜出一切世间及诸天人阿修罗。须菩提。以眼乃至意触因缘生受虚妄忆想分别和合名字等有一切无常破坏相无法。以是故摩诃衍胜出一切世间及诸天人阿修罗。须菩提。若法性是有法非无法者。是摩诃衍不能胜出一切世间及诸天人阿修罗。须菩提。以法性无法非法。以是故摩诃衍胜出一切世间及诸天人阿修罗。须菩提。若如实际不可思议性是有法非无法者。是摩诃衍不能胜出一切世间及诸天人阿修罗。须菩提。以如实际不可思议性无法非法。以是故摩诃衍胜出一切世间及诸天人阿修罗。须菩提。若檀波罗蜜是有法非无法者。是摩诃衍不能胜出一切世间及诸天人阿修罗。以檀波罗蜜。无法非法。以是故摩诃衍胜出一切世间及诸天人阿修罗。若尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。是有法非无法者。是摩诃衍不能胜出一切世间及诸天人阿修罗。以尸罗波罗蜜乃至般若波罗蜜无法非法。以是故摩诃衍胜出一切世间及诸天人阿修罗。须菩提。若内空乃至无法有法空。是有法非无法者。是摩诃衍不能胜出一切世间及诸天人阿修罗。以内空乃至无法有法空无法非法。以是故摩诃衍胜出一切世间及诸天人阿修罗。须菩提。若四念处乃至十八不共法。是有法非无法者。是摩诃衍不能胜出一切世间及诸天人阿修罗。以四念处乃至十八不共法无法非法。以是故摩诃衍胜出一切世间及诸天人阿修罗。须菩提。若性人法是有法非无法者。是摩诃衍不能胜出一切世间及诸天人阿修罗。以性人法无法非法。以是故摩诃衍胜出一切世间及诸天人阿修罗。须菩提。若八人法须陀洹法斯陀含法阿那含法阿罗汉法辟支佛法佛法。是有法非无法者。是摩诃衍不能胜出一切世间及诸天人阿修罗。以八人法乃至佛法无法非法。以是故摩诃衍胜出一切世间及诸天人阿修罗。须菩提。若性人是有法非无法者。是摩诃衍不能胜出一切世间及诸天人阿修罗。以性人无法非法。以是故摩诃衍胜出一切世间及诸天人阿修罗。须菩提。若八人须陀洹乃至佛是有法非无法者。是摩诃衍不能胜出一切世间及诸天人阿修罗。以八人乃至佛无法非法。以是故摩诃衍胜出一切世间及诸天人阿修罗。须菩提。若一切世间及诸天人阿修罗。是有法非无法者。是摩诃衍不能胜出一切世间及诸天人阿修罗。以一切世间及诸天人阿修罗无法非法。以是故。摩诃衍胜出一切世间及诸天人阿修罗。须菩提。若菩萨摩诃萨从初发心乃至道场。于其中间诸心。若当是有法非无法者。是摩诃衍不能胜出一切世间及诸天人阿修罗。以菩萨从初发心乃至道场诸心无法非法。以是故摩诃衍胜出一切世间及诸天人阿修罗。须菩提。若菩萨摩诃萨如金刚慧。若是有法非无法者。是菩萨摩诃萨。不能知一切结使及习无法非法得一切种智。须菩提。以菩萨摩诃萨如金刚慧无法非法。是故菩萨知一切结使及习无法非法。得一切种智。以是故摩诃衍胜出一切世间及诸天人阿修罗。须菩提。若诸佛三十二相。是有法非无法者。诸佛威德不能照然胜出一切世间及诸天人阿修罗。须菩提。以诸佛三十二相无法非法。以是故诸佛威德照然胜出一切世间及诸天人阿修罗。须菩提。若诸佛光明是有法非无法者。诸佛光明不能普照恒河沙等世界。须菩提。以诸佛光明无法非法。以是故诸佛能以光明普照恒河沙等世界。须菩提。若诸佛六十种庄严音声。是有法非无法者。诸佛不能以六十种庄严音声遍至十方无量阿僧祇世界。须菩提。以诸佛六十种庄严音声无法非法。以是故诸佛能以六十种庄严音声。遍至十方无量阿僧祇世界。须菩提。诸佛法轮若是有法非无法者。诸佛不能转法轮。诸沙门婆罗门若天若魔若梵及世间。余众所不能如法转者。须菩提。以诸佛法轮无法非法。以是故诸佛转法轮。诸沙门婆罗门若天若魔若梵及世间。余众所不能如法转者。须菩提。诸佛为众生转法轮。是众生若实有法非无法者。不能令是众生于无余涅槃而般涅槃。须菩提。以诸佛为众生转法轮是众生无法非法。以是故。众生于无余涅槃中已灭今灭当灭

【论】者言。须菩提上以五事问摩诃衍。佛已答竟。须菩提欢喜赞叹作是言。世尊。是摩诃衍有大力势。破坏人天世间。已能于中胜出。譬如三人度恶道。一者于夜逃遁独脱其身。二者以钱求免。三者如大王将大军众摧破寇贼。举军全济无所畏难。三乘亦如是。如阿罗汉。不能知一切总相别相。亦不能破魔王。又不能降伏外道。厌老病死直趣涅槃。如辟支佛入诸法实相深于声闻少有悲心以神通力化度众生。能破烦恼不能破魔人及外道。如菩萨从初发心于一切众生起大慈悲。虽未得佛。于其中间利益无量众生。决定知诸法实相。具足六波罗蜜故。破诸魔王及坏外道。断烦恼习。具足一切种智。总相别相悉知悉了。成阿耨多罗三藐三菩提。三人虽俱免生死。然方便道各异。是故须菩提赞叹。摩诃衍摧破一切世间胜出人天阿修罗上譬如虚空含受一切国土而虚空故不尽。摩诃衍亦如是。含受三世诸佛及诸弟子。摩诃衍亦不满。又如虚空常相故无入相无出相无住相。是乘亦如是。无未来世入处。无过去世出处。无现在世住处。破三时故三世等名摩诃衍。问曰。佛应赞须菩提所叹言善哉。何以更说摩诃衍。答曰。佛将欲顺须菩提所叹而赞说。以上说摩诃衍远故。今略说摩诃衍相然后广述。须菩提所赞摩诃衍者。所谓六波罗蜜诸陀罗尼门。三昧门。十八空四念处乃至十八不共法等。如须菩提所说摩诃衍。破坏一切世间。胜出人天阿修罗上者。是事实尔。何以故。是三界虚诳如幻如梦。无明虚妄因缘故。有因果无有定实。一切无常破坏磨灭皆是空相。以摩诃衍与三界相违故能摧破胜出。若三界定实常不虚妄。是摩诃衍不能摧破胜出。何以故。力等故。五众十二入十八界六触生诸受亦如是。若法性是有法非无法者。摩诃衍不能破世间得胜出。须菩提以法性非有故。摩诃衍能得胜出世间。问曰。有为法因缘和合虚诳故言无。如法性实际不思议性是无为。实法名为实际。云何言无。答曰。无为空故言无。复次佛说离有为无为法不可得。有为法实相即是无为法。复次观是有为法虚诳如如法性实际。是实以人于法性取相起诤故言无法性。或说有或说无。各有因缘故无咎。如实际不可思议性亦如是。世间檀波罗蜜着故有。出世间檀波罗蜜无故空。为破悭贪故言有檀波罗蜜。破邪见故言檀波罗蜜无。为度初学者说言有。若圣人心中说言无。如檀波罗蜜。乃至若众生实有非是无法。不应令强灭入无余涅槃。问曰。从三十二相已后何以不说言摩诃衍胜出。答曰。应当说直文烦故不说。复次三十二相乃至为众生转法轮。亦是摩诃衍。但名字异耳。复次上总相说摩诃衍胜出。不知云何胜出。今别相说。所谓佛三十二相庄严身故。胜一切众生。佛光明胜日月诸天一切光明。佛音声胜一切音乐世界妙声诸天梵音。佛法轮胜转轮圣王宝轮及诸外道一切法轮。无障无碍。余法轮所利益微浅。或一世二世极至千万世。佛法轮能令永入无余涅槃不复还入生死。复次若众生实有者。佛不应令众生入涅槃永拔其根。此过于杀一身有如是大咎。以众生颠倒心见我故。佛欲破其颠倒。说言涅槃无众生可灭故无咎。有如是功德故。摩诃衍能胜出一切世间。问曰。一切世间者十方六道众生。何以独说胜出诸天人阿修罗。答曰。六道中三是善道。三是恶道。摩诃衍尚能破三善道胜出。何况恶道。问曰。龙王经中说。龙得菩萨道。何以说是恶道。答曰。众生无量无边。龙得道者少。复次有人言。大菩萨变化身教化故作龙王身

    大智度论释含受品第二十三

【经】佛告须菩提汝所言衍与空等。如是如是。须菩提。摩诃衍与空等。须菩提。如虚空无东方无南方西方北方四维上下。须菩提。摩诃衍亦如是。无东方无南方西方北方四维上下。须菩提。如虚空非长非短非方非圆。须菩提。摩诃衍亦如是。非长非短非方非圆。须菩提。如虚空非青非黄非赤非白非黑。摩诃衍亦如是。非青非黄非赤非白。非黑以是故说摩诃衍与空等。须菩提。如虚空非过去非未来非现在。摩诃衍亦如是。非过去非未来非现在。以是故说摩诃衍与空等。须菩提。如虚空不增不减。摩诃衍亦如是。不增不减。须菩提。如虚空无垢无净。摩诃衍亦如是。无垢无净。须菩提。如虚空无生无灭无住无异。摩诃衍亦如是。无生无灭无住无异。须菩提。如虚空非善非不善非记非无记。摩诃衍亦如是。非善非不善非记非无记。以是故说摩诃衍与空等。如虚空无见无闻无知无识。摩诃衍亦如是。无见无闻无知无识。如虚空不可知不可识不可见不可断不可证不可修。摩诃衍亦如是。不可知不可识不可见不可断不可证不可修。以是故说摩诃衍与空等。如虚空非染相非离相。摩诃衍亦如是。非染相非离相。如虚空不系欲界不系色界不系无色界。摩诃衍亦如是。不系欲界不系色界不系无色界。如虚空无初发心亦无二三四五六七八九第十心。摩诃衍亦如是。无初发心乃至无第十心。如虚空无干慧地姓地八人地见地薄地离欲地已办地。摩诃衍亦如是。无干慧地乃至已作地。如虚空无须陀洹果无斯陀含果无阿那含果无阿罗汉果。摩诃衍亦如是。无须陀洹果乃至无阿罗汉果。如虚空无声闻地无辟支佛地无佛地。摩诃衍亦如是。无声闻地乃至无佛地。以是故说摩诃衍与空等。如虚空非色非无色。非可见非不可见。非有对非无对非合非散。摩诃衍亦如是。非色非无色非可见非不可见。非有对非无对非合非散。以是故说摩诃衍与空等。须菩提。如虚空非常非无常非乐非苦非我非无我。摩诃衍亦如是非常非无常非乐非苦非我非无我。以是故说摩诃衍与空等。须菩提。如虚空非空非不空非相非无相非作非无作。摩诃衍亦如是。非空非不空非相非无相非作非无作。以是故说摩诃衍与空等。须菩提。如虚空非寂灭非不寂灭非离非不离。摩诃衍亦如是。非寂灭非不寂灭非离非不离。以是故说摩诃衍与空等。须菩提。如虚空非闇非明。摩诃衍亦如是。非闇非明。以是故说摩诃衍与空等。须菩提。如虚空非可得非不可得。摩诃衍亦如是。非可得非不可得。以是故说摩诃衍与空等。须菩提。如虚空非可说非不可说。摩诃衍亦如是。非可说非不可说。以是故说摩诃衍与空等。须菩提。以是诸因缘故。说摩诃衍与空等

【论】者言。须菩提赞衍如虚空。佛即广述成其事。如虚空无十方。是摩诃衍亦无十方。无长短方圆青黄赤白等。是摩诃衍亦如是。问曰。虚空应尔。是无为法无色无方。摩诃衍是有为法是色法。所谓布施持戒等。云何言与虚空等。答曰。六波罗蜜有二种。世间出世间。世间者是有为法色法不同虚空。出世间者与如法性实际智慧和合故似如虚空。从得无生忍已后无所分别如虚空。复次如佛以无碍智观实相如虚空。余人则不然。智慧未毕竟清净故。复次佛前后说诸法毕竟空。如无余涅槃相如虚空不应致疑。余法亦如是。乃至如虚空非说非不说亦如是。问曰。如虚空言无所有便足。何以说无种种相。答曰。初发心菩萨于内外种种因缘法中着心。以是故佛说如虚空无是种种相。摩诃衍亦如是

【经】须菩提。如汝所言。如虚空受无量无边阿僧祇众生。摩诃衍亦受无量无边阿僧祇众生。如是如是须菩提。众生无所有故。当知虚空无所有。虚空无所有故。当知摩诃衍亦无所有。以是因缘故摩诃衍受无量无边阿僧祇众生。何以故是众生虚空摩诃衍。是法皆不可得故。复次须菩提。摩诃衍无所有故。当知阿僧祇无所有。阿僧祇无所有故。当知无量无所有。无量无所有故。当知无边无所有。无边无所有故。当知一切诸法无所有。以是因缘故。须菩提。是摩诃衍受无量无边阿僧祇众生。何以故。是众生虚空摩诃衍阿僧祇无量无边。是一切法不可得故。复次须菩提。我无所有。乃至知者见者无所有故。当知如法性实际无所有。如法性实际无所有故当知乃至无量无边阿僧祇无所有。无量无边阿僧祇无所有故当知一切法无所有。以是因缘故。须菩提。摩诃衍受无量无边阿僧祇众生。何以故。是众生乃至知者见者。实际乃至无量无边阿僧祇。是一切法不可得故。复次须菩提。我无所有。乃至知者见者无所有故。当知不可思议性无所有。不可思议性无所有故。当知色受想行识无所有。色受想行识无所有故。当知虚空无所有。虚空无所有故。当知摩诃衍无所有。摩诃衍无所有故。当知阿僧祇无所有。阿僧祇无所有故。当知无量无所有。无量无所有故。当知无边无所有。无边无所有故。当知一切诸法无所有。以是因缘故。须菩提。当知摩诃衍受无量无边阿僧祇众生。何以故。须菩提。我乃至知者见者等。一切法皆不可得故。复次须菩提。我无所有。乃至知者见者无所有故。当知眼无所有。耳鼻舌身意无所有。眼乃至意无所有故当知虚空无所有。虚空无所有故当知摩诃衍无所有。摩诃衍无所有故。当知阿僧祇无所有。阿僧祇无所有故。当知无量无所有。无量无所有故。当知无边无所有。无边无所有故当知一切诸法无所有。以是因缘故。须菩提。摩诃衍受无量无边阿僧祇众生。何以故。须菩提。我乃至一切诸法皆不可得故。复次须菩提。我无所有乃至知者见者无所有故。当知檀波罗蜜无所有。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜无所有。般若波罗蜜无所有故。当知虚空无所有。虚空无所有故。当知摩诃衍无所有。摩诃衍无所有故。当知无量无边阿僧祇无所有。无量无边阿僧祇无所有故。当知一切诸法无所有。以是因缘故。须菩提。摩诃衍受无量无边阿僧祇众生。何以故。我众生乃至一切诸法皆不可得故。复次须菩提。我无所有。乃至知者见者无所有故。当知内空无所有。乃至无法有法空无所有。无法有法空无所有故。当知虚空无所有。虚空无所有故。当知摩诃衍无所有。摩诃衍无所有故。当知阿僧祇无量无边无所有。阿僧祇无量无边无所有故。当知一切诸法无所有。以是因缘故。须菩提。摩诃衍受无量无边阿僧祇众生。何以故。我众生乃至一切诸法皆不可得故。复次须菩提。我众生乃至知者见者无所有故。当知四念处无所有。四念处无所有故。乃至十八不共法无所有。十八不共法无所有故。当知虚空无所有。虚空无所有故。当知摩诃衍无所有。摩诃衍无所有故。当知阿僧祇无量无边无所有。阿僧祇无量无边无所有故。当知一切诸法无所有。以是因缘故。须菩提。是摩诃衍受无量无边阿僧祇众生。何以故。我众生乃至一切诸法皆不可得故。复次须菩提。我众生无所有。乃至知者见者无所有故。当知性地无所有。乃至已作地无所有。已作地无所有故。当知虚空无所有。虚空无所有故。当知摩诃衍无所有。摩诃衍无所有故。当知阿僧祇无量无边无所有。阿僧祇无量无边无所有故。当知一切诸法无所有。以是因缘故。是摩诃衍受无量无边阿僧祇众生。何以故。我众生乃至一切诸法皆不可得故。复次须菩提。我众生乃至知者见者无所有故。当知须陀洹无所有。须陀洹无所有故。当知斯陀含无所有。斯陀含无所有故。当知阿那含无所有。阿那含无所有故。当知阿罗汉无所有。阿罗汉无所有故。当知乃至一切诸法。无所有。以是因缘故。须菩提摩诃衍受无量无边阿僧祇众生。何以故须菩提。我乃至一切诸法皆不可得故。复次须菩提。我乃至知者见者无所有故。当知声闻乘无所有。声闻乘无所有故。当知辟支佛乘无所有。辟支佛乘无所有故。当知佛乘无所有。佛乘无所有故。当知声闻人无所有。声闻人无所有故。当知须陀洹无所有。须陀洹无所有故。乃至佛无所有。佛无所有故。当知一切种智无所有。一切种智无所有故。当知虚空无所有。虚空无所有故。当知摩诃衍无所有。摩诃衍无所有故。当知乃至一切诸法无所有。以是因缘故。摩诃衍受无量无边阿僧祇众生。何以故。我乃至一切诸法皆不可得故。譬如须菩提涅槃性中受无量无边阿僧祇众生。是摩诃衍亦受无量无边阿僧祇众生。以是因缘故。须菩提。如虚空受无量无边阿僧祇众生。是摩诃衍亦如是。受无量无边阿僧祇众生

【论】问曰。何以不说虚空广大无边故受一切物。而言虚空无所有故能受一切物众生。摩诃衍亦无所有。答曰。现见虚空无所有。一切万物皆在其中。以无所有故能受。问曰。心心数法亦无形质。何以不受一切物。答曰。心心数法觉知相。非是受相又无住处。若内若外若近若远。但以分别相故知有心形。色法有住处。因色处故知有虚空。以色不受物故。则知虚空受物。色与虚空相违。色若不受则知虚空是受。如以无明故知有明。以苦故知有乐。因色无故说有虚空。更无别相。复次心心数法更有不受义。如邪见心不受正见。正见心不受邪见。虚空则不然。一切皆受故。又心心数法生灭相是可断法。虚空则不然。心心数法虚空但无色无形。同不得言都不异。以是故诸法中说虚空能受一切。问曰。我先问意不然。何以不言虚空无量无边能受一切物。而言无所有受一切物。答曰。我说虚空。无自相待色相说虚空。若无自相则无虚空。云何言无量无边。问曰。汝言受相则是虚空。云何言无。答曰。受相即是无色相。色不到处名为虚空。以是故无虚空。若实有虚空。未有色时应有虚空。若未有色有虚空。虚空则无相。何以故。以未有色故。因色故知有虚空。有色故便有无色。若先有色后有虚空。虚空则是作法。作法不名为常。若有无相法是不可得。以是故无虚空。问曰。若常有虚空。因色故虚空相现。然后相在虚空。答曰。若虚空先无相。后相亦无所住。若虚空先有相相无所相。若先无相相亦无所住。若离相无相。已相无住处。若相无住处。所相处亦无。所相处无故相亦无。离相及相处更无有法。以是故虚空不名为相。不名为所相。不名为法。不名为非法。不名为有。不名为无。断诸语言寂灭如无余涅槃。余一切法亦如是。问曰。若一切法如是者。即是虚空。何以复以虚空为喻。答曰。诸法因果皆是虚诳。因无明故有诳众生心。众生于是法中生着。而不于虚空生着。六尘法诳众生心。虚空虽复诳则不尔。以是故以虚空为喻。以粗现事破微细事。如虚空因色故但有假名无有定法。众生亦如是。因五众和合故。但有假名亦无定法。摩诃衍亦如是。以众生空无佛无菩萨。以有众生故有佛有菩萨。若无佛无菩萨则无摩诃衍。以是故摩诃衍能受无量无边阿僧祇众生。若是有法不能受无量诸佛及弟子。问曰。若实无虚空。云何能受无量无边阿僧祇众生。答曰。以是故佛说。摩诃衍无故阿僧祇无。阿僧祇无故无量亦无。无量无故无边亦无。无边无故一切法亦无。以是故能受。阿僧祇者。僧祇秦言数。阿秦言无。众生诸法各各不可得边故名无数。数虚空十方远近不可得边故名无数。分别数六波罗蜜。种种布施种种持戒等无有数。数几众生已上乘当上乘今上乘不可数。是名无数。复次有人言。初数为一。但有一一一故言二。如是等皆一。更无余数法。若皆是一则无数。有人言。一切法和合故有名字。如轮辋辐毂和合故名为车。无有定实法。一法无故多亦无。先一后多故。复次以系数事数事无故数亦无。无量者。如以斗称量物。以智慧量诸法亦如是。诸法空故无数。无数故无量无边。无有实智云何能得诸法定相。无量故无边量名总相。边名别相。量为初始边名终竟。复次我乃至知者见者无故实际亦无。实际无故无数亦无。无数无故无量亦无。无量无故无边亦无。无边无故一切法亦无。以是故一切法无。毕竟清净。是摩诃衍能含受一切众生及法。二事相因。若无众生则无法。若无法则无众生。先总相说一切法空。后一一别说诸法空。实际是末后妙法。此若无者何况余法。从不可思议性乃至如涅槃性亦如是

【经】须菩提。汝所言是摩诃衍。不见来处不见去处不见住处。如是如是。须菩提。是摩诃衍不见来处不见去处不见住处。何以故。须菩提。一切诸法不动相故。是法无来处无去处无住处。何以故。须菩提。色无所从来亦无所去亦无所住。受想行识无所从来亦无所去亦无所住。须菩提。色法无所从来亦无所去亦无所住。受想行识法无所从来亦无所去亦无所住。须菩提。色如无所从来亦无所去亦无所住。受想行识如无所从来亦无所去亦无所住。须菩提。色性无所从来亦无所去亦无所住。受想行识性无所从来亦无所去亦无所住。须菩提。色相无所从来亦无所去亦无所住。受想行识相无所从来亦无所去亦无所住。须菩提。眼眼法眼如眼性眼相。无所从来亦无所去亦无所住。耳鼻舌身意意法意如意性意相。无所从来亦无所去亦无所住。色声香味触法亦如是。须菩提。地种地种法地种如地种性地种相。无所从来亦无所去亦无所住。水火风空识种识种法识种如识种性识种相亦如是。须菩提。如如法如如如性如相。无所从来亦无所去亦无所住。须菩提。实际实际法实际如实际性。实际相无所从来亦无所去亦无所住。须菩提。不可思议不可思议法不可思议如不可思议性不可思议相。无所从来亦无所去亦无所住。须菩提。檀波罗蜜檀波罗蜜法檀波罗蜜如檀波罗蜜性檀波罗蜜相无所从来。亦无所去亦无所住。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。般若波罗蜜法般若波罗蜜如般若波罗蜜性般若波罗蜜相。无所从来亦无所去亦无所住。须菩提。四念处四念处法四念处如四念处性四念处相。无所从来亦无所去亦无所住。乃至十八不共法亦如是。须菩提。菩萨菩萨法菩萨如菩萨性菩萨相。无所从来亦无所。去亦无所住佛佛法佛如佛性佛相。无所从来亦无所去亦无所住。阿耨多罗三藐三菩提阿耨多罗三藐三菩提。法如性相。无所从来亦无所去亦无所住。须菩提。有为法有为法法有为法如有为法性有为法相。无所从来亦无所去亦无所住。须菩提。无为法无为法法无为法如无为法性无为法相。无所从来亦无所去亦无所住。以是因缘故。须菩提。是摩诃衍不见来处不见去处不见住处

【论】者言佛谓须菩提。汝何以但赞摩诃衍无来无去无住。一切法亦如是。无来无去无住。一切法实相不动故。问曰。诸法现有来去可见。云何言不动相无来无去。答曰。来去相先已破。今当更说。一切佛法中无我无众生乃至无知者见者。故来者去者无。来者去者无故。来去相亦应无。复次三世中求去相不可得。所以者何。已去中无去。未去中亦无去。离已去未去去时亦无去。问曰。有身动处是名为去。已去未去中无身动。以是故。去时身动即应有去。答曰。不然。离去相去时不可得。离去时去相不可得。云何言去时去。复次若去时有去相。应离去相有去时。何以故。汝说去时有去故。复次若去时去应有二去。一者知去时。二者知去时去。问曰。若尔有何咎。答曰。若尔有二去者。何以故。离去者无去相。若离去者无去相。离去相无去者。是故去者不去。不去者亦不去。离去不去亦无有去。来者住者亦如是。以是故佛说。凡夫人法虚诳无实。虽复肉眼所见。与畜生无异。是不可信。是故说诸法无来无去无住处亦无动。何者是。所谓色色法色如色性色相。色名眼见事。未分别好丑实不实自相他相。色法名无常生灭不净等。色如名色和合有。如水沫不牢固离散则无。虚伪无实但诳人眼。色现在如是。过去未来亦尔。如现在火热。比知过去未来亦如是。复次如诸佛观色相毕竟清净空。菩萨亦应如是观。色眼法色如何因缘不如凡夫人所见。性自尔故。此性深妙。云何可知。以色相力故可知。如火以烟为相见烟则知有火。今见眼色无常破坏苦恼粗涩相。知其性尔。此五法不去不来不住如先说。乃至无为无为法如性相。不来不去不住亦如是

【经】须菩提。汝所言是摩诃衍。前际不可得后际不可得中际不可得。是衍名三世等。以是故说名摩诃衍。如是如是。须菩提。是摩诃衍前际不可得后际不可得中际不可得。是衍名三世等。以是故说名摩诃衍。何以故。须菩提。过去世过去世空。未来世未来世空。现在世现在世空。三世等三世等空。摩诃衍摩诃衍空。菩萨菩萨空。何以故。须菩提。是空非一非二非三非四非五非异。以是故说名三世等。是菩萨摩诃萨摩诃衍。是衍中等不等相不可得故。染不染不可得。嗔不嗔不可得。痴不痴不可得。慢不慢不可得。乃至一切善法不善法不可得。是衍中常不可得。无常不可得。乐不可得。苦不可得。实不可得。空不可得。我不可得。无我不可得。欲界不可得。色界不可得。无色界不可得。度欲界不可得。度色界不可得。度无色界不可得。何以故。是摩诃衍自法不可得故。须菩提。过去色。过去色空。未来现在色。未来现在色空。过去受想行识。过去受想行识空。未来现在受想行识。未来现在受想行识空。空中过去色不可得。何以故。空中空亦不可得。何况空中过去色可得。空中未来现在色不可得。何以故。空中空亦不可得。何况空中未来现在色可得。空中过去受想行识不可得。何以故。空中空亦不可得。何况空中过去受想行识可得。空中未来现在受想行识不可得。何以故。空中空亦不可得。何况空中未来现在受想行识可得。须菩提。过去檀波罗蜜不可得。未来檀波罗蜜不可得。现在檀波罗蜜不可得。三世等中檀波罗蜜亦不可得。何以故。等中过去世不可得。未来世不可得。现在世不可得。等中等亦不可得。何况等中过去世未来世现在世可得。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜亦如是。复次须菩提。过去世中四念处不可得。乃至过去世中十八不共法不可得。未来世现在世亦如是。复次须菩提。三世等中四念处不可得。三世等中乃至十八不共法亦不可得。何以故。等中过去世四念处不可得。等中未来世四念处不可得。等中现在世四念处不可得。等中等亦不可得。何况等中过去世四念处未来现在世四念处可得。等中等亦不可得。何况等中过去乃至十八不共法可得。未来现在世亦如是。复次须菩提。过去世中凡夫人不可得。未来世现在世中凡夫人不可得。三世等中凡夫人亦不可得。何以故。众生不可得。乃至知者见者不可得故。过去世中声闻辟支佛菩萨佛不可得。未来现在世中声闻辟支佛菩萨佛不可得。三世等中声闻辟支佛菩萨佛不可得。何以故。众生不可得乃至知者见者不可得故。如是须菩提。菩萨摩诃萨。住般若波罗蜜中学三世等相。当具足一切种智。是名菩萨摩诃萨摩诃衍。所谓三世等相。菩萨摩诃萨住是衍中。胜出一切世间及诸天人阿修罗。成就萨婆若。尔时须菩提白佛言。世尊。善哉善哉。是菩萨摩诃萨摩诃衍。何以故。过去诸菩萨是衍中学得一切种智。未来世诸菩萨摩诃萨。亦是衍中学当得一切种智。世尊。今十方无量阿僧祇世界中。诸菩萨摩诃萨。亦是衍中学得一切种智。以是故。世尊。是衍实是菩萨摩诃萨摩诃衍。佛告须菩提如是如是。过去未来现在诸佛。是摩诃衍中学已得一切种智。当得今得

【论】者言。须菩提略赞说是摩诃衍。前际后际中际俱不可得。三世等故名摩诃衍。今佛广演须菩提所赞。是三世云何不可得。所谓过去世过去世空。未来世未来世空。现在世现在世空故不可得。三世等等者空。摩诃衍摩诃衍自空。菩萨菩萨自空。是三世中三世相空。空义如先说。此中佛自说空因缘。所谓空空相非一非二非三非四非五。等不异不合不散无有分别。是故三世等空相无所有故。是等亦空。菩萨能如是解诸法三世等。不以无始世来为疲厌。不以未来世无边故为难。是为菩萨三世等名摩诃衍。是摩诃衍中等相不可得。不等相亦不可得。得是三世等三昧破是不等相。不等相待故有。等不等毕竟无故等亦无。欲不欲乃至三界度三界。是相待法亦如是。此中佛自说。是诸法皆从因缘和合故无自性。自性无故空。复次过去色过去色相空。未来现在亦如是。如色余四众亦如是。所以者何。空中空相不可得。何况空中有三世五众相。菩萨观五众空。断贪欲入道行。所谓檀波罗蜜等亦如是。五众三世中不可得。三世等故等即是空。是等中檀波罗蜜不可得。问曰。何以故。三世及三世等中檀波罗蜜不可得。答曰。诸法等中无三世等。等中等相亦不可得。何况三世六波罗蜜。乃至十八不共法亦如是。复次三世中凡夫相不可得。声闻乃至佛亦不可得。以众生空故。菩萨住般若波罗蜜。能如是学三世等空。集诸善功德。便具足一切种智。佛说菩萨能如是三世等中住。则能胜出一切世间及诸天人阿修罗。是时须菩提赞言。世尊。善哉善哉。是摩诃衍利益诸菩萨。所以者何。过去诸菩萨学是摩诃衍得一切种智。未得今得亦如是。有人言得清净无因缘染垢秽。亦无因缘大小好丑缚解。皆无主所与。有人言好丑缚解至时节自得。有人言福德成就故得佛道。有人言但得清净实智慧得佛道。如是等说皆是非因缘少因缘。须菩提所不赞叹。今佛舍非因缘。亦舍不具足因缘。说是具足因缘。所谓六波罗蜜。三世菩萨学是乘。具足得成佛道。佛亦可须菩提所叹。言如是如是

大智度论卷第五十一大智度论释会宗品第二十四(卷五十二)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】尔时慧命富楼那弥多罗尼子白佛言。世尊。佛使须菩提为诸菩萨摩诃萨说般若波罗蜜。今乃说摩诃衍为。须菩提白佛言。世尊。我说摩诃衍。将无离般若波罗蜜。佛言。不也。须菩提。汝说摩诃衍。随般若波罗蜜。不离般若波罗蜜。何以故。一切所有善法助道法。若声闻法若辟支佛法若菩萨法若佛法。是一切法皆摄入般若波罗蜜中。须菩提白佛言。世尊。何等诸善法助道法。声闻法辟支佛法菩萨法佛法。皆摄入般若波罗蜜中。佛告须菩提。所谓檀波罗蜜。尸罗波罗蜜。羼提波罗蜜。毗梨耶波罗蜜。禅波罗蜜。般若波罗蜜。四念处四正勤四如意足。五根五力七觉分八圣道分。空无相无作解脱门。佛十力四无所畏四无碍智。大慈大悲十八不共法。无错谬相常舍行。须菩提。是诸余善法助道法。若声闻法若辟支佛法若菩萨法若佛法。皆摄入般若波罗蜜中。须菩提。若摩诃衍。若般若波罗蜜。禅波罗蜜。毗梨耶波罗蜜。羼提波罗蜜。尸罗波罗蜜。檀波罗蜜。若色受想行识。眼色眼识眼触眼触因缘生诸受。乃至意法意识意触意触因缘生诸受。地种乃至识种。四念处乃至八圣道分。空无相无作解脱门。及诸善法。若有漏若无漏。若有为若无为。若苦谛集谛灭谛道谛。若欲界若色界若无色界。若内空乃至无法有法空。诸三昧门诸陀罗尼门。佛十力乃至十八不共法。若佛佛法法性如实际不可思议性涅槃。是一切诸法皆不合不散。无色无形。无对一相。所谓无相。须菩提。以是因缘故。汝所说摩诃衍。随顺般若波罗蜜。何以故。须菩提。摩诃衍不异般若波罗蜜。般若波罗蜜不异摩诃衍。般若波罗蜜摩诃衍无二无别。檀波罗蜜不异摩诃衍。摩诃衍。不异檀波罗蜜。檀波罗蜜摩诃衍无二无别。乃至禅波罗蜜亦如是。须菩提。四念处不异摩诃衍。摩诃衍不异四念处。四念处摩诃衍无二无别。乃至十八不共法不异摩诃衍。摩诃衍不异十八不共法。十八不共法摩诃衍无二无别以是因缘故。须菩提。汝说摩诃衍。即是说般若波罗蜜

【论】者言。富楼那虽自无疑。为新学钝根者不解义一而名字异故发问。须菩提即以其事白佛。佛法甚深。我所说者将无有失。佛答汝说摩诃衍。随顺般若。无有违错。此义初已论之。今佛为说随顺因缘。所谓三乘所摄一切善法。皆合聚在般若波罗蜜中。所以者何。一切三乘善法。皆为涅槃故。涅槃门有三种。一切法皆入空门无相无作门。如持戒能生禅定。禅定能生实智慧。不着世间故。何等三乘助道法。摄在般若中。所谓六波罗蜜三十七品。三脱门佛十力四无所畏四无碍智。大慈大悲十八不共法。无错谬相常舍行此中三十七品三脱门。是三乘共法。六波罗蜜是菩萨法。十力乃至常舍行是佛法。有人言。六波罗蜜有具足有不具足。不具足者共二乘法。具足者独菩萨法。复次摩诃衍空。般若波罗蜜亦空。空义一故。须菩提随顺无错。如般若波罗蜜空。五波罗蜜。乃至如法性实际不可思议性。涅槃亦如是。复次从般若波罗蜜乃至涅槃。皆是不合不散无色无形。无对一相所谓无相。是同相故。说摩诃衍则是般若波罗蜜。摩诃衍般若波罗蜜无二无别故

    大智度论释十无品第二十五

【经】慧命须菩提白佛言。世尊。菩萨摩诃萨前际不可得。后际不可得。中际不可得。色无边故。当知菩萨摩诃萨亦无边。受想行识无边故。当知菩萨摩诃萨亦无边。色是菩萨摩诃萨。是亦不可得。受想行识。是菩萨摩诃萨。是亦不可得。如是世尊。于一切种一切处。求菩萨不可得。世尊。我当教何等菩萨摩诃萨般若波罗蜜。世尊。菩萨摩诃萨但有名字。如说我名字。我毕竟不生。如我诸法亦如是无自性。何等色毕竟不生。何等受想行识毕竟不生。世尊。是毕竟不生。不名为色。是毕竟不生。不名为受想行识。世尊。若毕竟不生法。当教谁是般若波罗蜜耶。离毕竟不生。亦无菩萨行阿耨多罗三藐三菩提。若菩萨闻作是说。心不没不悔不惊不怖不畏。当知是菩萨摩诃萨。能行般若波罗蜜。舍利弗问须菩提。何因缘故。言菩萨摩诃萨前际不可得后际不可得中际不可得。须菩提。何因缘故。言色无边故当知菩萨亦无边。受想行识无边故当知菩萨亦无边。须菩提。何因缘故。言色是菩萨是亦不可得。受想行识是菩萨是亦不可得。须菩提。何因缘故。言于一切种一切处菩萨不可得。当教何等菩萨般若波罗蜜。须菩提。何因缘故。言菩萨摩诃萨但有名字。须菩提。何因缘故。言如说我名字我毕竟不生。如我诸法亦如是无自性。何等色毕竟不生。何等受想行识毕竟不生。须菩提。何因缘故。言毕竟不生不名为色。毕竟不生不名为受想行识。须菩提。何因缘故。言若毕竟不生法当教谁是般若波罗蜜耶。须菩提。何因缘故。言离毕竟不生亦无菩萨行阿耨多罗三藐三菩提。须菩提。何因缘故。言若菩萨闻作是说。心不没不悔不惊不怖不畏。若能如是行。是名菩萨摩诃萨行般若波罗蜜。尔时须菩提报舍利弗言。众生无所有故。菩萨前际不可得。众生空故。菩萨前际不可得。众生离故。菩萨前际不可得。舍利弗。色无有故。菩萨前际不可得。受想行识无有故。菩萨前际不可得。色空故。菩萨前际不可得。受想行识空故。菩萨前际不可得。色离故菩萨前际不可得。受想行识离故。菩萨前际不可得。舍利弗。色性无故。菩萨前际不可得。受想行识性无故。菩萨前际不可得。舍利弗。檀波罗蜜无有故。菩萨前际不可得。尸罗波罗蜜。羼提波罗蜜。毗梨耶波罗蜜。禅波罗蜜。般若波罗蜜。无有故菩萨前际不可得。何以故。舍利弗。空中前际不可得。后际不可得。中际不可得。空不异菩萨。菩萨不异前际。舍利弗。空菩萨前际。是诸法无二无别。以是因缘故。舍利弗。菩萨前际不可得。舍利弗。檀波罗蜜空故。檀波罗蜜离故。檀波罗蜜性无故。菩萨前际不可得。尸罗波罗蜜。羼提波罗蜜。毗梨耶波罗蜜。禅波罗蜜。般若波罗蜜空故。般若波罗蜜离故。般若波罗蜜性无故。菩萨前际不可得。何以故。舍利弗。空中前际不可得。后际不可得。中际不可得。空不异菩萨。菩萨亦不异前际。舍利弗。空菩萨前际是诸法无二无别。以是因缘故。舍利弗。菩萨前际不可得。复次舍利弗。内空无所有故。菩萨前际不可得。乃至无法有法空无所有故。菩萨前际不可得。内空空故。内空离故。内空性无故。乃至无法有法空空故。离故性无故。菩萨前际不可得。余如上说。复次舍利弗。四念处无所有故。菩萨前际不可得。四念处空故离故性无故。菩萨前际不可得。乃至十八不共法无所有故。菩萨前际不可得。十八不共法空故。离故性无故。菩萨前际不可得。余如上说。以是因缘故。舍利弗。菩萨前际不可得。复次舍利弗。一切三昧门一切陀罗尼门无有故。菩萨前际不可得。三昧门陀罗尼门。空故离故性无故。菩萨前际不可得。余如上说。复次舍利弗。法性无有故。菩萨前际不可得。法性空故离故性无故。菩萨前际不可得。余如上说。复次舍利弗。如无有故。空故离故性无故。实际无有故。空故离故性无故。不可思议性无有故。空故离故性无故。菩萨前际不可得。余如上说。复次舍利弗。声闻无有故。菩萨前际不可得。声闻空故离故性无故。菩萨前际不可得。辟支佛无有故。空故离故性无故。菩萨前际不可得。佛无有故。空故离故性无故。菩萨前际不可得。阿耨多罗三藐三菩提无有故。乃至性无故。菩萨前际不可得。复次一切种智无有故。乃至性无故。菩萨前际不可得。何以故。舍利弗。空前际不可得。后际不可得。中际不可得。菩萨不可得。舍利弗。空不异菩萨。亦不异前际。空菩萨前际。是诸法无二无别。以是因缘故。舍利弗。菩萨前际不可得。后际中际亦如是

【论】问曰。上已说菩萨菩萨字不可得。为谁说般若波罗蜜。今何以更说。答曰。不应作是问。须菩提空行第一常乐说空。若有所说常以空门利益众生。复次上略说。是中十种。广分别菩萨不可得。行者若观诸法空。随顺无相无作。以无作心故。不欲有所作。尚不能自作利益。何况利益人。若人住我心中。能分别诸法善不善相。集诸善法舍不善法。今佛说般若波罗蜜中。不应计我心。不应分别诸法。但行众善是事为难。行者作是念。若无我者为谁修善。先有我今以般若波罗蜜故。无心生忧戚。是故须菩提更重说。我从本已来无非先有今无。行者如是如是本来自无今无所失故无所忧。譬如深根大树不可以一斫能办。多用斧力乃能断。菩萨空亦如是。不可一说便得。以是故广分别。须菩提问佛时作是念。若定有菩萨法。应三世通有。今前世中无有菩萨。何以故。前世无初故。未来世亦如是。未有因缘故。前后相待故有中间。若无前后则无中间。若谓五众是菩萨。五众无边如先种种因缘说。五众毕竟空故无量无边。无量无边故。同无为法。若菩萨无边者。是事不然。以此因缘故。菩萨不可得。当为谁说。常一切处一切种一切时。求菩萨不可得。当为谁说。如我毕竟不生空无所有。五众亦如是。毕竟不生无所有。既无众生及五众法。云何有菩萨。问曰。众生及五众法毕竟不生。解是法者即是菩萨。答曰。毕竟不生不名为色。不名为受想行识。何以故。五众是生相。毕竟不生中无是分别。五众毕竟不生。不可以教化。离毕竟不生。亦无菩萨行道。当教谁。菩萨闻是不怖不畏。是为能行菩萨道。问曰。我与菩萨是一物。云何以我喻菩萨。答曰。是般若波罗蜜中一切法空。初学不得便为说空。先当分别罪福。舍罪修福德福德果报无常。无常故生苦。是故舍福厌世间。求道入涅槃。尔时应作是念。因我故生诸烦恼。是我于六识中求不可得。但以颠倒故着我。是故解无我易易可受化。若言色空则难解。虽耳闻说空。眼常见实。是故先破恶罪中我。后破一切诸法。一切佛弟子得道者。自知自证无我。未得道者信余法空。不能如信无我。是故以无我为喻。此中须菩提说。一切法空推无菩萨。用无我为喻。以小喻大如石蜜喻甘露。问曰。舍利弗知空无我义。何以故事事致问。答曰。须菩提声闻人德不如菩萨。而于佛前说深般若。新学菩萨心或生疑。上佛虽言汝说摩诃衍随顺般若。犹谓佛将顺须菩提。舍利弗欲断此疑故发问。复次佛欲共须菩提说般若乃至终竟。是故舍利弗事事质问。令须菩提善分别深义。使众人敬信。以是故问。过去世中菩萨不可得。乃至不恐不怖。须菩提答义。我众生人即是一物。未得道时各凡夫人。初入道乃至阿罗汉名声闻人。观因缘法悟空小深。小愍众生名辟支佛人。深入空法行六波罗蜜大慈大悲。是名菩萨人。功德别异故名字亦异。如我众生人。一事以眼见事故名见者。意得故名知者。受苦乐故名受者。是我众生人等。先已说种种因缘无故。菩萨亦应无。是故须菩提语舍利弗。众生无故三世中无菩萨。问曰。五众和合有菩萨。菩萨应无五众应有。答曰。为破是事故。言无众生无我。无我故则五众无所属。无所属故空。空故无菩萨。问曰。若五众空者。空即是菩萨。答曰。五众空亦非菩萨。空无所有无分别故。五众离五众。无性。亦无菩萨。若说无菩萨。则三世皆无。观是五众等世间法六波罗蜜等道法。是名菩萨。是法空故菩萨亦空。此中佛自说因缘。诸法空不异菩萨。菩萨不异空。菩萨空三世空无二无别。从六波罗蜜乃至一切种智。行是诸法故名为菩萨。是诸法空故菩萨亦空。此中法空。声闻辟支佛得是空故。名声闻辟支佛人。声闻辟支佛人空故。菩萨亦如是

【经】如舍利弗言。色无边故。当知菩萨亦无边。受想行识无边故。当知菩萨亦无边。舍利弗。色如虚空。受想行识如虚空。何以故。舍利弗。如虚空边不可得。中不可得。无边无中故。但说名虚空。如是舍利弗。色边不可得。中不可得。是色空故空中亦无边亦无中。受想行识边不可得。中不可得。识空故空中亦无边亦无中。以是因缘故。舍利弗色无边故。当知菩萨亦无边。受想行识无边故。当知菩萨亦无边。乃至十八不共法亦如是。如舍利弗言。色是菩萨是亦不可得。受想行识是菩萨。是亦不可得。舍利弗。色色相空。受想行识识相空。檀波罗蜜檀波罗蜜相空。乃至般若波罗蜜亦如是。内空内空相空。乃至无法有法空。无法有法空相空。四念处四念处相空。乃至十八不共法。十八不共法相空。如法性实际不可思议性不可思议性相空。三昧门三昧门相空。陀罗尼门陀罗尼门相空。一切智一切智相空。道种智道种智相空。一切种智一切种智相空声闻乘声闻乘相空。辟支佛乘辟支佛乘相空。佛乘佛乘相空。声闻人声闻人相空。辟支佛辟支佛相空。佛佛相空。空中色不可得。受想行识不可得。以是因缘故。舍利弗。色是菩萨。是亦不可得。受想行识是菩萨。是亦不可得。如舍利弗言。何因缘故。于一切种。一切处。菩萨不可得。当教何等菩萨般若波罗蜜。舍利弗。色色中不可得。色受中不可得。受受中不可得。受色中不可得。受想中不可得。想想中不可得。想色受中不可得。想行中不可得。行行中不可得。行色受想中不可得。行识中不可得。识识中不可得。识色受想行中不可得。舍利弗。眼眼中不可得。眼耳中不可得。耳耳中不可得。耳眼中不可得。耳鼻中不可得。鼻鼻中不可得。鼻眼耳中不可得。鼻舌中不可得。舌舌中不可得。舌眼耳鼻中不可得。舌身中不可得。身身中不可得。身眼耳鼻舌中不可得。身意中不可得。意意中不可得。意眼耳鼻舌身中不可得。六入六识六触六触因缘生受亦如是。檀波罗蜜乃至般若波罗蜜。内空乃至无法有法空。四念处乃至十八不共法。一切三昧门。一切陀罗尼门性法。乃至辟支佛法。初地乃至十地。一切智道种智。一切种智亦如是。须陀洹乃至阿罗汉辟支佛菩萨佛亦如是。菩萨菩萨中不可得。菩萨般若波罗蜜中不可得。般若波罗蜜般若波罗蜜中不可得。般若波罗蜜菩萨中不可得。般若波罗蜜中教化无所有不可得。教化中教化无所有不可得。教化中菩萨及般若波罗蜜无所有不可得。舍利弗。如是一切法无所有不可得。以是因缘故。一切种一切处菩萨不可得。当教何等菩萨般若波罗蜜。如舍利弗言。何因缘故说菩萨摩诃萨但有假名。舍利弗。色是假名。受想行识是假名。色名非色受。想行识名非识。何以故。名名相空。若空则非菩萨。以是因缘故。舍利弗。菩萨但有假名。复次舍利弗。檀波罗蜜但有名字。名字中非有檀波罗蜜。檀波罗蜜中非有名字。以是因缘故。菩萨但有假名。尸罗波罗蜜。羼提波罗蜜。毗梨耶波罗蜜。禅波罗蜜。般若波罗蜜。但有名字。名字中无有般若波罗蜜。般若波罗蜜中无有名字。以是因缘故菩萨但有假名。舍利弗。内空但有名字。乃至无法有法空但有名字。名字中无内空。内空中无名字。何以故。名字内空俱不可得。乃至无法有法空亦如是。以是因缘故。舍利弗。菩萨但有假名。舍利弗。四念处但有名字。乃至十八不共法但有名字。一切三昧门。一切陀罗尼门。乃至一切种智亦如是。以是因缘故。舍利弗。我说菩萨但有假名。如舍利弗言。何因缘故。说我名字毕竟不生。舍利弗。我毕竟不可得。云何当有生。乃至知者见者毕竟不可得。云何当有生。舍利弗色毕竟不可得。云何当有生。受想行识毕竟不可得。云何当有生。眼毕竟不可得。乃至意触因缘生受毕竟不可得。云何当有生。檀波罗蜜毕竟不可得。乃至般若波罗蜜毕竟不可得。云何当有生。内空毕竟不可得。乃至无法有法。空毕竟不可得。云何当有生。四念处毕竟不可得。乃至十八不共法毕竟不可得。云何当有生。诸三昧门。诸陀罗尼门毕竟不可得。云何当有生。声闻乃至佛毕竟不可得。云何当有生。以是因缘故。舍利弗。我说如我名字。我亦毕竟不生

【论】问曰。心心数法无形不可见故可无边。色是有形可见云何无边。答曰。无处不有色。不可得筹量远近轻重。如佛说四大。无处不有故名为大。不可以五情得其限。不可以斗称量其多少轻重。是故言色无边。复次是色过去时初始不可得。未来时中无有恒河沙劫数限。色当有尽。是故无后边。初边后边无故中亦无。复次边名色相。是色分别破散。边不可得无有本相。复次无为法不生不灭故。无数无量无边。以法空观观色皆空。与虚空及无为同相。无量无数无边法中。乃至微尘不可得。何况菩萨。是故说五众无边。菩萨亦无边。如色无边乃至十八不共法亦如是。随相分别如先说。是五众无量无数无边故。不得言色是菩萨。四众亦如是。复次色若离心心数法。如草木瓦石。云何名菩萨。若心心数法。离色则无依止处亦无所能为。云何名菩萨。复次六波罗蜜。十八空三十七品十力乃至十八不共法。如法性实际不可思议性。三解脱门陀罗尼门诸三昧门萨婆若道智一切种智三乘三乘人。是法若修若观是名菩萨。是法皆以自相空故空。所谓檀波罗蜜。檀波罗蜜相空。乃至佛佛相空。一切处者。五众十二入十八界乃至一切种智。一切种智。者十八空三解脱门。般若波罗蜜观。若常若无常等。入一门二门乃至无量门等。是名一切种智。求索菩萨不可得。又以自法中无自法。亦无他法。如此中说。色色中不可得。色受中不可得。受受中不可得。受色中不可得。乃至般若波罗蜜。般若波罗蜜中不可得。乃至教化中教化不可得。但有名字者。是五众破坏散灭。如虚空无异。是菩萨但有名字。如幻化人。假名字中更为立名。须菩提语舍利弗。不但菩萨假名字。五众皆亦假名字。假名字中假名字相不可得。皆入第一义中。若如是空者则非菩萨。复次六波罗蜜。乃至一切种智。行是法故名为菩萨。是法亦假名字。菩萨亦假名字。空无所有。是诸法等强为作名。因缘和合故有。亦无其实。我名字毕竟不生者。如此品初已说。此中须菩提。亦如众生空法空破我。所谓我毕竟不可得。乃至知者见者不可得。云何当有生。五众毕竟不可得。云何有五众生。乃至意触因缘生受毕竟不可得。云何当有生。六波罗蜜毕竟不可得。乃至诸陀罗尼门三昧门。声闻辟支佛佛毕竟不可得。云何当有生。若法先有然后可问生。法体先无云何有生

【经】如舍利弗所言。如我诸法亦如是无自性。舍利弗。诸法和合生故无自性。舍利弗。何等和合生无自性舍利弗。色和合生无自性。受想行识和合生无自性。眼和合生无自性。乃至意和合生无自性。色乃至法眼界。乃至法界地种。乃至识种眼触。乃至意触眼触因缘生受。乃至意触因缘生受和合生无自性。檀波罗蜜乃至般若波罗蜜和合生无自性。四念处乃至十八不共法和合生无自性。复次舍利弗。一切法无常亦不失。舍利弗问须菩提何等法无常亦不失。须菩提言。色无常亦不失。受想行识无常亦不失。何以故。若法无常即是动相即是空相。以是因缘故。舍利弗。一切有为法无常亦不失。若有漏法若无漏法。若有记法若无记法。无常亦不失。何以故。若法无常即是动相即是空相。以是因缘故。舍利弗。一切作法无常亦不失。复次舍利弗。一切法非常非灭。舍利弗言。何等法非常非灭。须菩提言。色非常非灭。何以故。性自尔。受想行识非常非灭。何以故。性自尔。乃至意识因缘生受非常非灭。何以故。性自尔。以是因缘故。舍利弗。诸法和合生无自性。如舍利弗所言。何因缘故色毕竟不生。受想行识毕竟不生。须菩提言。色非作法。受想行识非作法。何以故。作者不可得故。舍利弗。眼非作法。何以故。作者不可得故。乃至意亦如是。眼界乃至意触因缘生受亦如是。复次舍利弗。一切诸法皆非起非作。何以故。作者不可得故。以是因缘故。舍利弗。色毕竟不生。受想行识毕竟不生。如舍利弗所言。何因缘故毕竟不生。是不名为色毕竟不生。是不名为受想行识。须菩提言。色性空。是空无生无灭无住异。受想行识性空。是空无生无灭无住异。眼乃至一切有为法性空。是空无生无灭无住异。以是因缘故。舍利弗。毕竟不生是不名色。毕竟不生是不名受想行识。如舍利弗所言。何因缘故毕竟不生法。当教是般若波罗蜜耶。须菩提言。毕竟不生即是般若波罗蜜。般若波罗蜜即是毕竟不生。般若波罗蜜毕竟不生无二无别。以是因缘故。舍利弗。我说毕竟不生。当教是般若波罗蜜耶如舍利弗所言。何因缘故离毕竟不生。无菩萨行阿耨多罗三藐三菩提。须菩提言。菩萨摩诃萨行般若波罗蜜时。不见毕竟不生异般若波罗蜜。亦不见毕竟不生异菩萨。毕竟不生及菩萨无二无别。不见毕竟不生异色。何以故。是毕竟不生及色无二无别。不见毕竟不生异受想行识。何以故。毕竟不生受想行识无二无别。乃至一切种智亦如是。以是因缘故。舍利弗。离毕竟不生。无菩萨行阿耨多罗三藐三菩提。如舍利弗所言。何因缘故。菩萨闻作是说。心不没不悔不惊不怖不畏是名菩萨行般若波罗蜜。须菩提言。菩萨摩诃萨。不见诸法有觉知相。见一切诸法。如梦如幻如炎如影如化。舍利弗。以是因缘故。菩萨闻作是说。心不没不悔不惊不怖不畏

【论】者言。诸法无有自性者。以性空破诸法各各性。此中须菩提自说。诸法和合生无有自性。如和合五众等法及六波罗蜜等善法。从是出菩萨名字。是菩萨从作法。众缘和合生故。非一法所成。以是故言假名。是众法亦从和合边生。譬如有眼有色有明有空有欲见心等诸因缘和合生眼识。是中不得言眼是见者若识是见者若色是见者若明是见者。若是眼色识等。各各不得有所见。和合中亦不应有见。以是故。见法毕竟空。如幻如梦。一切诸法亦如是。复次一切法无常亦不失。无常破常倒。不失破断灭倒。是无常不失法。即是入实相门。是故须菩提语舍利弗。无常即是动相。即是空相。一切法亦如是。复次一切法非常非失者。如十八空后义说。色毕竟不生者。五众作者生者起者不可得故。复次生相不可得者。如先破生中说。一切法亦如是。何以故。说若色不生为非色非受想行识者。此中须菩提自说。色从因缘生无有自性常空相。若法常空相。是法无生相无灭相。无住异相。受想行识亦如是。故不生相法即是无为非有为相。余法亦如是毕竟不生。当教谁般若者。毕竟不生即是诸法实相。诸法实相即是般若波罗蜜。云何以般若波罗蜜。教般若波罗蜜。若离是毕竟不生有菩萨者。应当教般若波罗蜜。是菩萨般若波罗蜜。毕竟不生无二无别。云何当教。离毕竟不生行道者。上说中已合解。菩萨闻是不没不悔者。菩萨于一切法中。不见我众生乃至知者见者。亦无说者亦无听者。无邪说无正说。亦无无说者。知一切法因缘和合故生。诸缘离故灭。无有起者无有灭者。故不畏不怖不没不悔。菩萨知一切法虚诳无实无定。若死急时若堕阿鼻泥犁心犹不动。况闻虚声而有恐怖。如人梦中见怖畏事觉已则无恐心。知梦法能诳心无有实事。菩萨亦如是。入世间心梦中见有恐畏。得诸法实相。觉时则无所畏。知诸法但是虚诳无有真实。复次譬如幻事。智者虽见心无所惑知是诳法。菩萨亦如是。知一切法如幻能诳人心是中无实。以是故不怖畏。如炎如影如化亦如是

【经】须菩提白佛言。世尊。菩萨摩诃萨。行般若波罗蜜。如是观诸法。是时菩萨摩诃萨。不受色不视色不住色不着色不言是色。受想行识亦不受不视不住不着。亦不言是受想行识。眼不受不视不住不着。亦不言是眼耳鼻舌身意。亦不受不视不住不着。亦不言是意。檀波罗蜜不受不视不住不着。亦不言是檀波罗蜜。尸罗波罗蜜。羼提波罗蜜。毗梨耶波罗蜜。禅波罗蜜。般若波罗蜜。不受不示不住不着。亦不言是般若波罗蜜。内空不受不示不住不着。亦不言是内空。乃至无法有法空亦如是复次世尊。菩萨摩诃萨行般若波罗蜜时。四念处不受不示不住不着。亦不言是四念处。乃至十八不共法不受不示不住不着。亦不言是十八不共法。一切三昧门。一切陀罗尼门。乃至一切种智不受不示不住不着。亦不言是一切种智。复次世尊。菩萨摩诃萨行般若波罗蜜时。不见色乃至不见一切种智。何以故。色不生是非色。受想行识不生是非识。眼不生是非眼。耳鼻舌身意不生是非意。檀波罗蜜不生。是非檀波罗蜜。乃至般若波罗蜜不生。是非般若波罗蜜。何以故。色不生不二不别。乃至般若波罗蜜不生不二不别。内空不生是非内空。乃至无法有法空不生。是非无法有法空。何以故。内空乃至无法有法空不生不二不别。世尊。四念处不生非四念处。何以故。四念处不生不二不别。何以故。世尊。是不生法非一非二非三非异。以是故。四念处不生不二不别。乃至十八不共法不生。非十八不共法。何以故。十八不共法不生不二不别。何以故。世尊是不生法非一非二非三非异。以是故。十八不共法不生。非十八不共法。世尊。如不生是非如。乃至不可思议性不生。是非不可思议性。世尊。是阿耨多罗三藐三菩提不生一切智一切种智不生。是非一切种智。何以故。是阿耨多罗三藐三菩提乃至一切种智。不生不二不别。何以故。世尊。是不生法非一非二非三非异。以是故。乃至一切种智不生。非一切种智。世尊。色不灭相是非色。何以故。色及不灭相。不二不别。何以故。世尊。是不灭法。非一非二非三非异。以是故。色不灭相是非色。受想行识不灭。相是非识。何以故。识及不灭不二不别。何以故。世尊。是不灭法。非一非二非三非异。以是故。识不灭相是非识。檀波罗蜜乃至般若波罗蜜。内空乃至无法有法空。四念处乃至十八不共法亦如是。世尊。以是故。色入无二法数。受想行识入无二法数。乃至一切种智入无二法数

【论】者言。须菩提白佛。菩萨能如是观诸法。于五众中有五种正观行。所谓不受。以五众中有无常火能烧心故。不视者。不取相非但观无常等过。观是五众空不取相故。不住者。不依止五众。畏诸烦恼贼来故不敢久住。譬如空聚落贼所止处。智者不应久住。不著者。五众若有一罪犹不应着。何况身有饥渴寒热老病死等。心有忧愁恐怖妒嫉嗔恚等。后世堕三恶道。一切无常苦空无我不得自在。如是等无量无边过罪云何可着。不言是色者。不以邪见说色若常若无常等。不言五众如是定相。乃至一切种智亦如是。何以故。色中行五种正行。是五众。皆无生相皆一相。一相则无相。若无相则非有五众。乃至一切种智亦如是。若一切法无生相。般若波罗蜜不二不别。得是无生心。即是般若波罗蜜。得般若波罗蜜。即知诸法不生不灭。以是故。般若波罗蜜。即是不生不二不别。复次须菩提自说因缘。所谓是无生法不一相不二相不三不异。何以故。诸法无生一相故。乃至一切种智亦如是。如无生无灭亦如是。问曰。末后何以故说色乃至一切种智入无二法数。答曰。菩萨若未破色则生爱等结使着是色等。破色已则生邪见着是色空等。今色等用空智慧故皆空不二相。是诸法虚诳不实。内外入所摄故名为二。色等乃至一切种智。离是二名不二。今须菩提怜愍众生。利益诸菩萨故。说是诸法不二入无二法数中

大智度论卷第五十二大智度论释无生品第二十六(卷五十三)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】尔时慧命舍利弗语须菩提。菩萨摩诃萨行般若波罗蜜观诸法。何等是菩萨。何等是般若波罗蜜。何等是观。须菩提语舍利弗。如汝所问。何等是菩萨。为阿耨多罗三藐三菩提。是人发大心。以是故名为菩萨。亦知一切法一切种相。是中亦不着。知色相不着。乃至知十八不共法亦不着。舍利弗问须菩提。何等为一切法相。须菩提言。若以名字因缘和合等知诸法。是色是声香味触法。是内是外。是有为法是无为法。以是名字相语言知诸法。是名知诸法相。如舍利弗所问。何等是般若波罗蜜。远离故名般若波罗蜜。何等法远离。远离众界入。远离檀波罗蜜乃至禅波罗蜜。远离内空乃至无法有法空。以是故。远离名般若波罗蜜。复次远离四念处。乃至远离十八不共法。远离一切智。以是因缘故。远离名般若波罗蜜。如舍利弗所问。何等是观。舍利弗。菩萨摩诃萨行般若波罗蜜时。观色非常非无常非乐非苦非我非无我非空非不空非相非无相非作非无作非寂灭非不寂灭非离非不离。受想行识亦如是。檀波罗蜜乃至般若波罗蜜。内空乃至无法有法空。四念处乃至十八不共法。一切三昧门。一切陀罗尼门。乃至一切种智。观非常非无常非乐非苦非我非无我非空非不空非相非无相非作非无作非寂灭非不寂灭非离非不离。舍利弗。是名菩萨摩诃萨行般若波罗蜜时观诸法

【论】问曰。所谓菩萨义。般若波罗蜜义。诸观义上已问。今何以更问。答曰。先已答大树喻非一斫可断。是事难故更问。复次是般若波罗蜜有无量义。如昙无竭品中说。般若波罗蜜如大海水无量。如须弥山种种严饰。是故问。又此问虽同。答义种种异。复次诸佛断法爱不立经书。亦不庄严言语。但为拯济众生随应度者说。如大清凉美池无量众生前后来饮各饱而去。听者亦如是。佛先说菩萨般若及观。前来者有得解悟而去。后来者未闻。是故重问。菩萨者菩提有三种。有阿罗汉菩提。有辟支佛菩提。有佛菩提。无学智慧清净无垢故名为菩提。菩萨虽有大智慧。诸烦恼习未尽故不名菩提。此中但说一种。所谓佛菩提也。萨埵秦言众生。是众生为无上道故发心修行。复次萨埵名大心。是人发大心求无上菩提而未得。以是故名为菩提萨埵。佛已得是菩提。不名为菩提萨埵。大心满足故。菩萨余义如先广说。复次佛此中自说因缘。是人为佛道故修行。知一切诸法相亦不着。诸法相者。可以知诸法门是色是声等。略说菩萨义。先知诸法各各相如地坚相。然后知毕竟空相。于是二种智慧中亦不着。但欲度众生故。菩萨得如是智慧。一切别相法中皆得远离。如色中离色。离色即是自相空。远离者是空之别名。菩萨得般若波罗蜜。于一切法心皆远离。所以者何。见一切诸法罪过故。阿罗蜜秦言远离。波罗蜜秦言度彼岸。此二音相近义相会故。以阿罗蜜释波罗蜜。远离何等法。所谓众界入乃至一切智。以远离是诸法故。名般若波罗蜜。如禅波罗蜜。能调伏人心。般若波罗蜜。能令人远离诸法。观者不观诸法常无常等。如先说

【经】舍利弗问须菩提。何因缘故。色不生是非色。受想行识不生是非识。乃至一切种智不生是非一切种智。须菩提言。色色相空。色空中无色无生。以是因缘故。色不生是非色。受想行识识相空。识空中无识无生。以是因缘故。受想行识不生是非受想行识。舍利弗。檀波罗蜜。檀波罗蜜相空。檀波罗蜜空中无檀波罗蜜无生。尸罗波罗蜜。羼提波罗蜜。毗梨耶波罗蜜。禅波罗蜜。般若波罗蜜。般若波罗蜜相空。般若波罗蜜空中无般若波罗蜜无生。以是因缘故。舍利弗。般若波罗蜜不生是非般若波罗蜜。内空乃至无法有法空。四念处乃至十八不共法。一切种智亦如是。以是因缘故。内空不生是非内空。乃至一切种智不生是非一切种智。舍利弗问须菩提。汝何因缘故。言色不二是非色。受想行识不二是非识。乃至一切种智不二。是非一切种智。须菩提答言。所有色所有不二。所有受想行识所有不二。是一切法皆不合不散无色无形。无对一相。所谓无相眼乃至一切种智亦如是。以是因缘故。舍利弗。色不二是非色。受想行识不二是非识。乃至一切种智不二。是非一切种智。舍利弗问须菩提。何因缘故。言是色入无二法数。受想行识入无二法数。乃至一切种智入无二法数。须菩提答言。色不异无生。无生不异色。色即是无生。无生即是色。受想行识不异无生。无生不异识。识即是无生。无生即是识。以是因缘故。舍利弗。色入无二法数。受想行识入无二法数。乃至一切种智亦如是

【论】问曰。上品竟。便应问不生。何以此中方问。答曰。三种大法易解。利益多众生故先问。何因缘故。色不生为非色。乃至一切种智不生。为非一切种智。须菩提答。色是空色中无色相。行者以是无生智慧。令色无生。若能得是无生。心作是念。今即得色实相。是故言色无生为非色。色性常自无生。非今智慧力故使无生。如有人破色令空犹存本色想。譬如除厕作舍今虽无厕犹有不净想。若能知厕本无幻化所作则无厕想。行者如是。若能知色从本已来初自无生者。则不复存色想。是故言色无生为非色。乃至一切种智亦如是。问曰。汝先自说无生即是无二。今何以更问。答曰。义虽一所入观门异。上言破因中先有果若无果。是生法一异等是生若初生若后生。破如是等生。名无生。今破眼色有无等诸二故。是名不二。行者或先入无生观门。后入不二。或先入不二。后入无生。观义虽一行者分别。破色二故言不二。破色生故言无生。上说无生因缘。谓自相空。今说不二因缘。所谓不合不散一相。所谓无相等。义虽同一空。上自相空此是散空。色入无二法数者。行者观色不生不灭相。是时分别色。今变为无生。是故说色无生即是不二。何以故。色破散即是无生。如先分别诸法时。离色不得更有生。今色破散即是无生。不得更有无生。以是故色即是入无二法数。是二阿罗汉。于佛前共论竟。须菩提白佛而更说是义。欲使佛证知故

【经】尔时须菩提白佛言。世尊。若菩萨摩诃萨。行般若波罗蜜。如是观诸法。是时见色无生毕竟净故。见受想行识无生毕竟净故。见我无生乃至知者见者无生毕竟净故。见檀波罗蜜无生。乃至般若波罗蜜无生毕竟净故。见内空无生。乃至无法有法空无生毕竟净故。见四念处无生。乃至十八不共法无生毕竟净故。见一切三昧一切陀罗尼无生毕竟净故。乃至见一切种智无生毕竟净故。见凡夫凡夫法无生毕竟净故。见须陀洹须陀洹法。斯陀含斯陀含法。阿那含阿那含法。阿罗汉阿罗汉法。辟支佛辟支佛法。菩萨菩萨法。佛佛法无生毕竟净故。舍利弗语须菩提。如我闻须菩提所说义。色是不生。受想行识是不生。乃至佛佛法是不生。若尔者不应得须陀洹须陀洹果斯陀含斯陀含果阿那含阿那含果阿罗汉阿罗汉果辟支佛辟支佛道。不应得菩萨摩诃萨一切种智。亦无六道别异。亦不得菩萨摩诃萨五种菩提。须菩提。若一切法不生相。何以故。须陀洹为断三结故修道。斯陀含为薄淫恚痴故修道。阿那含为断五下分结故修道。阿罗汉为断五上分结故修道。辟支佛为辟支佛法故修道。何以故。菩萨摩诃萨作难行。为众生受种种苦。何以故。佛得阿耨多罗三藐三菩提。何以故。佛转法轮。须菩提语舍利弗。我不欲令无生法有所得。我亦不欲令无生法中得须陀洹须陀洹果。乃至不欲令无生法中得阿罗汉阿罗汉果辟支佛辟支佛道。我亦不欲令无生法中菩萨作难行为众生受种种苦。菩萨亦不以难行心行道。何以故。舍利弗。生难心苦心。不能利益无量阿僧祇众生。舍利弗。今菩萨怜愍众生。于众生如父母兄弟想。如儿子及己身想。如是能利益无量阿僧祇众生。是用无所得故。所以者何。菩萨摩诃萨应生如是心。如我一切处一切种不可得。内外法亦如是。若生如是想。则无难心苦心。何以故。是菩萨于一切种一切处一切法不受故。舍利弗。我亦不欲令无生法中佛得阿耨多罗三藐三菩提。亦不欲令无生法中转法轮。亦不欲令以无生法得道

【论】者言。无生观有二种。一者柔顺忍观。二者无生忍观。前说无生是柔顺忍观不毕竟净。渐习柔顺观。得无生忍则毕竟净。问曰。菩萨未尽结。未得佛道。智慧未淳净。云何言毕竟清净。答曰。是菩萨得无生忍时。灭诸烦恼得菩萨道入菩萨位。虽有烦恼气。坐道场时乃尽。无所妨故毕竟净。复次毕竟清净者。于柔顺道毕竟清净非为佛道。以众生空法空故。从见色无生毕竟净。乃至佛及佛法无生毕竟清净。须菩提。种种因缘说诸法相决定无生。因此事舍利弗作是难。贤圣中最小者。须陀洹须陀洹法。最大者佛佛法。若尔者圣人无大无小。圣法亦无优劣。亦无六道别异。此略难。后问断三结修道者为广难。问曰。云何是五种菩提。答曰。一者柔顺忍。二者无生忍。及三种菩提。于三菩提中过二而住第三菩提。复有五种菩提。一者名发心菩提。于无量生死中发心为阿耨多罗三藐三菩提故。名为菩提。此因中说果二者名伏心菩提。折诸烦恼降伏其心。行诸波罗蜜。三者名明菩提。观三世诸法。本末总相别相分别筹量。得诸法实相毕竟清净。所谓般若波罗蜜相。四者名出到菩提。于般若波罗蜜中得方便力故。亦不着般若波罗蜜。灭一切烦恼。见一切十方诸佛。得无生法忍。出三界到萨婆若。五者名无上菩提。坐道场断烦恼习。得阿耨多罗三藐三菩提。如是等五菩提义。余诸贤圣断结义如先说。问曰。声闻道广说断结义。何以不说辟支佛行。菩萨有种种行。答曰。辟支佛于声闻无复异道。但福德利根小深入诸法实相为异。菩萨道虽有种种众行。但难行苦行为希有事。众生见已欢喜言。菩萨为我等作此行。余行虽深妙人所不知。不能感物故不说。复次如舍利弗难意。若诸法都是无生空寂者。一切众生皆着乐。菩萨何以故独受苦行。复次诸佛常乐远离寂灭断法爱。决定知诸法不转不还。何以故。与众生转法轮。须菩提于佛前说无生法。佛不呵折得快心乐说无难力故答。舍利弗我亦都不欲令无生法中有六种圣人。除菩萨故言六。及六道别异。何以故。以得无生法证故谓为圣法。圣人有差别。于无生法中都无所有。复次于无生法中有二种失。粗失者。杀盗等罪。故有三恶道。细失者。用着心布施持戒等福。故有三善道。若菩萨生难心苦心。则不能度一切众生。如世间小事心难以为苦犹尚不成。何况成佛道。成因缘者。所谓大慈大悲心。于众生如父母儿子己身想。何以故。父母儿子己身自然生爱。非推而爱也。菩萨善修大悲心故。于一切众生乃至怨仇同意爱念。是大悲果报。利益之具都无所惜。于内外所有尽与众生。此中说不惜因缘。所谓一切处一切种一切法不可得故。若行者初入佛法。用众生空知诸法无我。今用法空知诸法亦空。以此大悲心及诸法空二因缘故。能不惜内外所有利益众生。不起难行想苦行想。一心精进欢喜。如人为自身及为父母妻子勤身修业不以为苦。若为他作则无欢心苦行难行。如后品本生因缘变化现受畜生形中说。一切诸法毕竟空不可思议相故。一切法还而不转故。不名为转。但为破虚妄颠倒故。名为转法轮

【经】舍利弗语须菩提。今欲令以生法得道以无生法得道。须菩提语舍利弗。我不欲令以生法得道。舍利弗言。今须菩提。欲令以无生法得道。须菩提言。我亦不欲令以无生法得道。舍利弗言。如须菩提所说无知无得。须菩提言。有知有得不以二法。今以世间名字故有知有得。世间名字故。有须陀洹乃至阿罗汉辟支佛诸佛。第一实义中无知无得。无须陀洹乃至无诸佛。须菩提。若世间名字故。有知有得。六道别异亦世间名字故有。非以第一实义耶。须菩提言。如是如是。舍利弗。如世间名字故有知有得。六道别异亦世间名字故有。非以第一实义。何以故。舍利弗。第一实义中。无业无报无生无灭无净无垢。舍利弗语须菩提。不生法生生法生。须菩提言。我不欲令不生法生。亦不欲令生法生。舍利弗言。何等不生法不欲令生。须菩提言。色是不生法自性空不欲令生。受想行识不生法自性空不欲令生。乃至阿耨多罗三藐三菩提。不生法自性空不欲令生。舍利弗语须菩提。生生不生生。须菩提言。非生生亦非不生生。何以故。舍利弗。生不生是二法不合不散无色无形。无对一相所谓无相。舍利弗。以是因缘故。非生生亦非不生生。尔时舍利弗语须菩提。须菩提。乐说无生法及无生相。须菩提语舍利弗。我乐说无生法。亦乐说无生相。何以故。诸无生法及无生相乐说及语言。是一切法皆不合不散无色无形。无对一相所谓无相。舍利弗语须菩提。汝乐说不生法。亦乐说不生相。是乐说语言亦不生。须菩提言。如是如是。舍利弗。何以故。舍利弗。色不生受想行识不生。眼不生乃至意不生。地种不生乃至识种不生。身行不生口行不生意行不生。檀波罗蜜不生。乃至一切种智不生。以是因缘故。舍利弗。我乐说不生法。亦乐说不生相。是乐说语言亦不生

【论】者言。尔时舍利弗。知须菩提乐说无难而问言。若一切法无生相。此无生相云何证。用是生法得证。为用不生法得证。若用生法得证。生法虚诳。汝已种种因缘破。又不可以生法得脱生法。若以无生法得证。无生未有法相。不可以证。云何得证。须菩提。二法皆不受俱有过故。如先说。舍利弗作是念。佛经说二法摄一切法。若有为若无为。生者有为。无生者无为。今须菩提离此二法。云何当说得道事。作是念已。问须菩提。无有得道事耶。须菩提是大阿罗汉。行无诤三昧第一。但为菩萨故说是无生。汝云何当作邪见说无得道者。是故言有知有得。知得者即是得道果之别名。须菩提恐违前语故。言不以二法故。但为世俗故。说有须陀洹乃至佛。何以故。一切诸法实无我相。今用我分别须陀洹乃至佛。是世俗法。复次未得法空故。言是善是不善是有为是无为等。第一义中无众生故。无须陀洹乃至佛。法空故。无须陀洹果乃至佛道。圣人圣法犹尚虚诳无定实。何况凡人六道业及果报。问曰。须菩提已种种因缘。定说不生法。今舍利弗。何以更问不生法生生法生。答曰。须菩提上说得道因缘故。舍利弗得须菩提意。虽说不生法破一切法。为因缘故说。而心不着无生法。是故更问。又以此法甚深。欲令听者了了得解。故更问。上问得道行法。今总问一切法云何生。用慧眼知一切法皆不生。今现见诸法生。是故问云何生。须菩提答二事皆非。若生生生法已生不应更生。若不生生生法未有故不应生。若谓生时半生半不生是亦不生。若生分则已生竟。若未生分则无生。是故须菩提不用是肉眼见。以不通达故。二法皆不受。但说是生如幻如梦从虚诳法生。应离应不取相。舍利弗问。何等法二俱不受。须菩提以世谛故。说色乃至一切种智。毕竟不生自然空相。不欲令实中有生。若世谛虚诳可有生。生如幻化。此中说不生因缘。所谓不合不散。有人言。生与法异。谓生是常所可生法无常。是故更问。答者以生法不异。若说生法已说生相。生不生如上说。舍利弗闻须菩提所说。知须菩提心爱乐无生法故。语须菩提。汝实爱乐说无生法。须菩提即受其问心亦无愧。何以故。是论议不可破无有过罪。何以知之。须菩提自说无法可合。无法可散。无色无形空一相。所谓无相。空相尚不受何况余相。舍利弗重赞。汝乐说无生法及语言皆无生。是实清净若当乐说及语言非无生。但说外物无生者则非清净。须菩提即复受其赞答舍利弗。非但乐说语言是无生。色乃至一切种智亦无所生

【经】尔时舍利弗语须菩提。须菩提。于说法人中应最在上。何以故。须菩提。随所问皆能答。须菩提言。诸法无所依故。舍利弗语须菩提。云何诸法无所依。须菩提言。色性常空不依内不依外。不依两中间。受想行识性常空。不依内不依外。不依两中间。眼耳鼻舌身意性常空。不依内不依外。不依两中间。色性常空乃至法性常空。不依内不依外。不依两中间。檀波罗蜜性常空。乃至般若波罗蜜性常空。不依内不依外。不依两中间。内空性常空。乃至无法有法空性常空。不依内不依外。不依两中间。舍利弗。四念处性常空。乃至一切种智性常空。不依内不依外。不依两中间。以是因缘故。舍利弗。一切诸法无所依。性常空故。如是舍利弗。菩萨摩诃萨行六波罗蜜时。应净色受想行识。乃至应净一切种智。舍利弗问须菩提。菩萨摩诃萨。云何行六波罗蜜时净菩萨道。须菩提言。有世间檀波罗蜜。有出世间檀波罗蜜。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。有世间有出世间。舍利弗问须菩提。云何世间檀波罗蜜。云何出世间檀波罗蜜。须菩提言。若菩萨摩诃萨作施主。能施沙门婆罗门贫穷乞人。须食与食须饮与饮。须衣与衣。卧具床榻房舍香华璎珞医药。种种所须资生之物。若妻子国土头目手足支节。内外之物尽以给施。施时作是念。我与彼取我不悭贪。我为施主我能舍一切。我随佛教施。我行檀波罗蜜。作是施已用得法。与一切众生共之。回向阿耨多罗三藐三菩提。念言。是布施因缘。令众生得今世乐。后当令得入涅槃。是人布施有三碍。何等三。我相他相施相。着是三相布施。是名世间檀波罗蜜。何因缘故名世间。于世间中不动不出。是名世间檀波罗蜜。云何名出世间檀波罗蜜。所谓三分清净。何等三。菩萨摩诃萨布施时我不可得。不见受者。施物不可得亦不望报。是名菩萨摩诃萨三分清净檀波罗蜜。复次舍利弗。菩萨摩诃萨布施时。施与一切众生。众生亦不可得。以此布施。回向阿耨多罗三藐三菩提。乃至不见微细法相。舍利弗。是名出世间檀波罗蜜。何以故名为出世间。于世间中能动能出。是故名出世间檀波罗蜜。尸罗波罗蜜有所依。是为世间尸罗波罗蜜。无所依是为出世间尸罗波罗蜜。余如檀波罗蜜说。羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜有所依。是名世间。无所依是名出世间。余亦如檀中说。如是舍利弗。菩萨摩诃萨行六波罗蜜时净菩萨道。舍利弗问须菩提。云何菩萨摩诃萨。为阿耨多罗三藐三菩提道。须菩提言。四念处是菩萨摩诃萨。为阿耨多罗三藐三菩提道。乃至八圣道分。空解脱门无相解脱门无作解脱门。内空乃至无法有法空。一切三昧门一切陀罗尼门。佛十力四无所畏四无碍智十八不共法。大慈。大悲舍利弗是名菩萨摩诃萨为阿耨多罗三藐三菩提道

【论】问曰。五百阿罗汉。佛各说其第一。如舍利弗智慧第一。目揵连神足第一。摩诃迦叶行头陀中第一。须菩提得无诤三昧第一。摩诃迦旃延分别修多罗第一。富楼那说法人中第一。今舍利弗何以故赞须菩提。于说法人中应最第一。答曰。佛以佛眼。观一切众生利根钝根。筹量一切法总相别相。随其所得法。各记第一无错。富楼那于四众中。用十二部经种种法门种种因缘譬喻说法。能利益众生第一。须菩提常行无诤三昧。与菩萨同事。巧便乐说一种空相法门。胜富楼那。譬如巧师多有所能。所能多故普不精悉。如有人偏能一事则必尽其美。富楼那虽多能。不如须菩提常乐行空故。能巧说空。是故舍利弗闻须菩提巧说空义。便赞言。汝于说法人中应作第一。舍利弗见须菩提随所问皆能答。如风行空中无所挂碍。尔时须菩提不谦不受。何以故。安立平实好人相故。好人相者不自赞不自毁。于他亦不赞不毁。若自赞身非大人相。不为人所赞而便自美。若自毁是姣输人。若毁他是谗贼人。若赞他是谄媚人。须菩提说无生法故。舍利弗虽赞而非谄。须菩提以舍利弗实赞故不谦。又以断法爱故心不高。亦不爱着。但答无碍无障因缘。所谓一切法无所依止无所依止故无障无碍。无所依止义如先说。此中须菩提自说。内法空故。色不依止内。外法空故。色不依止外。中间无所有故色不依止中间。如色乃至一切种智亦如是。若菩萨知一切三界无常空故。不中依止。尔时烦恼折能净菩萨道。是故须菩提说。菩萨行六波罗蜜。应净色乃至一切种智。问曰。净色乃至净一切种智。即是净菩萨道。何以故更问。答曰。菩萨能令色毕竟空。是名清净。是事深妙不可顿得。是故舍利弗问。新学菩萨云何修是初方便道。须菩提答。若菩萨能行二种波罗蜜。六波罗蜜是初开菩萨道。能用无所得空行三十七品是开佛道。净者名为开如去道中荆棘名为开道。何等是二种波罗蜜。一者世间。二者出世间。世间者须菩提自说义。所谓须食与食等。是义如初品中说。若施时有所依止。譬如老病人依恃他力能行能立。施者离实智慧。心力薄少故依止。依止者。己身财物。受者是法中取相心着。生憍慢等诸烦恼。是名世间不动不出。动者柔顺忍。出者无生法忍。声闻法中动者学人。出者无学。余者五波罗蜜亦如是。是名初开菩萨道。问曰。菩萨道即是阿耨多罗三藐三菩提道。何以故更问。答曰。菩萨时有道。佛已到不须道。是道为得阿耨多罗三藐三菩提。故名为菩提道。菩萨行是道故名菩萨道。此中佛说远道。所谓六波罗蜜菩萨道也。近道所谓三十七品菩提道也。六波罗蜜中。布施持戒等杂故远。三十七品但有禅定智慧故近。六波罗蜜有世间出世间杂故远。三十七品三解脱门等。乃至大慈大悲毕竟清净故近。复次阿耨多罗三藐三菩提道者。从初发意乃至金刚三昧。其中为菩提菩萨行。皆是菩提道

【经】尔时舍利弗赞须菩提言。善哉善哉。何等波罗蜜力。须菩提言。是般若波罗蜜力。所以者何。般若波罗蜜。能生一切诸善法。若声闻法辟支佛法菩萨法佛法。舍利弗。般若波罗蜜能受一切诸善法。声闻法辟支佛法菩萨法佛法。舍利弗。过去诸佛行般若波罗蜜。得阿耨多罗三藐三菩提。未来诸佛亦行般若波罗蜜。当得阿耨多罗三藐三菩提。舍利弗。今现在十方诸国界中诸佛。亦行是般若波罗蜜。得阿耨多罗三藐三菩提。舍利弗。若菩萨摩诃萨闻说般若波罗蜜时不疑不难。当知是菩萨摩诃萨行菩提道。菩萨道者。救一切众生故。心不舍一切众生。以无所得故。是菩萨常应不离是念。所谓大悲念。舍利弗复问。欲使菩萨摩诃萨常不离是念。所谓大悲念。若菩萨摩诃萨常不离大悲念。令一切众生皆当作菩萨。何以故。须菩提。一切众生亦不离诸念故。须菩提言。善哉善哉。舍利弗。汝欲难我而成我义。何以故。众生无故念亦无。众生性无故念亦性无。众生法无故念亦法无。众生离故念亦离。众生空故念亦空。众生不可知故念亦不可知。舍利弗。色无故念亦无。色性无故念亦性无。色法无故念亦法无。色离故念亦离。色空故念亦空。色不可知故念亦不可知。受想行识亦如是。眼乃至意。色乃至法。地种乃至识种。檀波罗蜜乃至般若波罗蜜。内空乃至无法有法空。四念处乃至十八不共法。一切三昧门。一切陀罗尼门。一切智一切种智。乃至阿耨多罗三藐三菩提无故念亦无。乃至阿耨多罗三藐三菩提。不可知故念亦不可知。舍利弗。菩萨摩诃萨行是道。我欲使不离是念。所谓大悲念。尔时佛赞须菩提言。善哉善哉。是菩萨摩诃萨般若波罗蜜。其有说者亦当如是说。如汝所说般若波罗蜜。皆是承佛意故。菩萨摩诃萨学般若波罗蜜应当如汝所说学。须菩提说是般若波罗蜜品时。三千大千世界六种振动。东涌西没西涌东没。南涌北没化涌南没。中涌边没边涌中没。尔时佛微笑。须菩提白佛言。何因何缘故微笑。佛告须菩提。如我于此世界说般若波罗蜜。东方无量阿僧祇世界诸佛。亦为诸菩萨摩诃萨。说般若波罗蜜。南西北方四维上下。亦说是般若波罗蜜。说是般若波罗蜜品时。十二那由他诸天人。得无生法忍。十方诸佛说是般若波罗蜜时。无量阿僧祇众生。亦发阿耨多罗三藐三菩提心

【论】者言。舍利弗作是念。须菩提所说。分别六波罗蜜世间出世间及菩提道。大利益众生故。欢喜赞言。善哉善哉。再言之者善之至也。问是何波罗蜜力。须菩提作是思惟。一切心数法中除智慧。无能如是分别断疑开道。诸波罗蜜中离般若波罗蜜。自体不能成就。何况能分别开道如是思惟已。答舍利弗。是般若波罗蜜力。如先说。诸法中无我无知者无见者。今以此证知。是般若波罗蜜力。非佛力。非须菩提力。何以故。须菩提说因缘。所谓般若波罗蜜。离断常有无二边等故。能生一切善法。所谓三乘法定相坚牢不坏相。又般若波罗蜜无量无边故。能受一切善法。如大海能受众川万流。三乘善法者。所谓六波罗蜜。乃至十八不共法。十方三世诸佛。行般若波罗蜜故。皆得阿耨多罗三藐三菩提。虽行余波罗蜜。般若波罗蜜最尊大。有分别通达力。譬如和合下药巴豆最有力。般若波罗蜜亦如是。虽与余波罗蜜合而破诸烦恼拔邪见舍戏论。般若波罗蜜力最胜。以是故说皆是般若波罗蜜力。问曰。种种赞此般若波罗蜜微妙甚深。谁能随顺应般若波罗蜜行。答曰。有菩萨无量世集诸福德利根。诸烦恼折薄。虽未到阿鞞跋致地。闻般若波罗蜜。即时信受深入通达。如是相者则能行般若波罗蜜道。所谓救度一切众生。令离世间忧恼。大悲心故不离一切众生。菩萨常不应离大悲及毕竟空。念毕竟空。破世间诸烦恼示涅槃。而大悲引之令还入善法中。以利益众生。尔时舍利弗难须菩提。若菩萨不离是大悲念。及毕竟空念者。一切众生皆当作菩萨。何以故。是毕竟空无相无所分别。不应菩萨有而众生无。若有一切众生应共有。若无菩萨亦应无。须菩提答。汝欲难我而助成我义。何以故。诸法相毕竟空故。众生亦空。众生空故。毕竟空念亦空。若诸法毕竟空。何有众生实空。而难我言。众生不离是念。皆当为菩萨。是故说。众生无所有故。毕竟空念亦无所有。众生无性众生离众生空众生不可知。毕竟空念亦毕竟空。色乃至阿耨多罗三藐三菩提亦如是

问曰。此中念是不离大悲念。何以说不离毕竟空念。答曰。菩萨不离是念心。不舍众生。用无所得故。无所得空毕竟空。名异而义一。不可得空在初。毕竟空在后。以毕竟空大故。生悲亦大。大悲如阿差末经中说。有三种悲。众生缘法缘无缘。无缘悲从毕竟空生。以是解舍利弗所难。佛证其说故。赞言善哉。若欲解说般若波罗蜜者。当如汝所说。尔时众中天人菩萨作是念。般若波罗蜜甚深。三世诸佛皆从中生。须菩提小乘人。云何佛赞欲说般若波罗蜜。当如汝所说是故次言。须菩提所说皆承佛意。正使弥勒等诸菩萨梵天王等不承佛意。尚不能得问。何况须菩提在佛前自恣乐说。诸菩萨欲学般若波罗蜜。亦当如汝所说学。说是品时。三千大千世界地六种振动者。是时会中多有菩萨。发阿耨多罗三藐三菩提心。皆当作佛。佛是天地大主。地神欢喜我主今生。故使地大动。复次人心信深般若波罗蜜者。难得希有故。是人以福德因缘。感大风以动水。水动故地动。复次地下大龙王。欲来听般若波罗蜜。从水出故水动。水动故地动。复次佛神力故令地动。般若波罗蜜难见难知。欲引导众人令益信乐故。余地动因缘如先说。此中佛自说因缘。所谓我说般若波罗蜜。十方诸佛亦说是般若波罗蜜。十二那由陀天人。得阿鞞跋致地入法位。是故地动。又十方世界众生等。亦发无上道意。是故地动。尔时诸天亦有散种种莲华。及种种杂香天衣天盖千万种天妓乐。诸龙王等从四大海水中涌出。及诸夜叉罗刹等。皆生慈心合手赞佛。又佛笑时无量光明。遍覆十方如恒河沙等世界。有尔所等希有事。取要言之。地动皆由说诸法实相。所谓般若波罗蜜

大智度论卷第五十三大智度论释天主品第二十七(卷五十四)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】尔时三千大千世界诸四天王天等。各与无数百千亿诸天俱来在会中。三千大千世界诸释提桓因等。诸忉利天须夜魔天王等。诸夜魔天删兜率陀天王等。诸兜率陀天须涅蜜陀天王等。诸妙化天。婆舍跋提天王等。诸自在行天。各与无数百千亿诸天俱来在会中。三千大千世界诸梵天王。乃至首陀婆诸天等。各与无数百千亿诸天俱来在会中。是诸四天王天乃至首陀婆诸天。业报生身光明。于佛常光百分千分万亿分不能及一。乃至不可以算数譬喻为比。世尊光明最胜最妙最上第一。诸天业报光明在佛常光边不照不现。譬如焦炷比阎浮檀金。尔时释提桓因白大德须菩提。是三千大千世界诸四天王天。乃至首陀婆诸天。一切和合欲听须菩提说般若波罗蜜义。须菩提。菩萨摩诃萨云何应住般若波罗蜜中。何等是菩萨摩诃萨般若波罗蜜云何菩萨摩诃萨。应行般若波罗蜜。须菩提语释提桓因言。憍尸迦。我今当承顺佛意。承佛神力为诸菩萨摩诃萨说。般若波罗蜜。如菩萨摩诃萨。所应住般若波罗蜜中。诸天子今未发阿耨多罗三藐三菩提心者。应当发。诸天子。若入声闻正位。是人不能发阿耨多罗三藐三菩提心。何以故。与生死作障隔故。是人若发阿耨多罗三藐三菩提心者。我亦随喜。所以者何。上人应更求上法。我终不断其功德。憍尸迦。何等是般若波罗蜜。菩萨摩诃萨应萨婆若心。念色无常念色苦念色空念色无我。念色如病如疽痈疮。如箭入身痛恼衰坏忧畏不安。以无所得故。受想行识亦如是。眼耳鼻舌身意。地种水火风空识种。观无常乃至忧畏不安。是亦无所得故。观色寂灭离不生不灭不垢不净。受想行识亦如是。观地种乃至识种寂灭离不生不灭不垢不净。亦无所得故。复次憍尸迦。菩萨摩诃萨应萨婆若心。观无明缘诸行乃至老死因缘大苦聚集。亦无所得故。观无明灭故诸行灭。乃至生灭故老死灭。老死灭故忧悲愁恼大苦聚灭。以无所得故。复次憍尸迦。菩萨摩诃萨应萨婆若心修四念处。以无所得故。乃至修佛十力十八不共法。以无所得故。复次憍尸迦。菩萨摩诃萨应萨婆若心。行檀波罗蜜。以无所得故。行尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜。以无所得故。复次憍尸迦。菩萨摩诃萨行般若波罗蜜时作是观。但诸法诸法共相因缘润益增长分别校计。是中无我无我所。菩萨回向心。不在阿耨多罗三藐三菩提心中。阿耨多罗三藐三菩提心。不在回向心中。回向心于阿耨多罗三藐三菩提心中不可得。阿耨多罗三藐三菩提心。于回向心中亦不可得。菩萨虽观一切法。亦无法可得。是名菩萨摩诃萨般若波罗蜜。释提桓因问大德须菩提。云何菩萨回向心。不在阿耨多罗三藐三菩提心中。云何阿耨多罗三藐三菩提心。不在回向心中。云何回向心。于阿耨多罗三藐三菩提心中不可得。云何阿耨多罗三藐三菩提心。于回向心中不可得。须菩提语释提桓因言。憍尸迦。回向心阿耨多罗三藐三菩提心。非心是非心相。非心相中不可回向。是非心相常非心相。不可思议相。常不可思议相。是名菩萨摩诃萨般若波罗蜜。尔时佛赞须菩提言。善哉善哉。须菩提。汝为诸菩萨摩诃萨。说般若波罗蜜。安慰诸菩萨摩诃萨心。须菩提白佛言。世尊。我应报恩。不应不报恩。过去诸佛及诸弟子。为诸菩萨说六波罗蜜示教利喜。世尊尔时亦在中学。得阿耨多罗三藐三菩提。我今亦当为诸菩萨说六波罗蜜示教利喜。令得阿耨多罗三藐三菩提

【论】问曰。初品中佛放殊胜光明。诸天大集此间。何以更说。答曰。有人言。此是后会。有人言。即是前会天。以须菩提善能说深般若波罗蜜诸天欢喜。以是故佛微笑。常光益更发明。诸天光明不复现。如日出时星月灯烛无复光明。譬如焦炷在阎浮檀金边。四天王天者。东方名提多罗吒。(秦言治国)主乾闼婆及毗舍阇。南方名毗流离。(秦言增长)主拘槃茶及薜荔多。西方名毗流波叉。(秦言杂语)主诸龙王及富多那。北方名鞞沙门。(秦言多闻)主夜叉及罗刹。释提桓因。释迦秦言能。提婆秦言天。因提秦言主。合而言之释提婆那民。须夜磨夜摩天王名也。秦言妙善。删兜率陀兜率陀天王名也。秦言妙足。须涅蜜陀秦言化乐。婆舍跋提。秦言他化自在天。此间一梵天王名尸弃。秦言火。从梵天乃至首陀婆天。秦言净居天。业报生身光者。欲界天以灯烛明珠等施。及布施持戒禅定等清净故。身常光明不须日月。色界天行禅离欲。修习火三昧故。身常出妙光。胜于日月及欲界报光明离欲天。取要言之。是诸天光明皆由心清净故得。佛常光明者。面各一丈。诸天光明大者。虽无量由旬。于佛光边蔽而不现。释提桓因见佛神力光明作是念。佛光明能蔽诸天光。智慧之明亦当能破我等愚闇。又以佛命须菩提说般若。是故言一切诸天皆大集会欲听须菩提说般若义。今大福德诸天皆集。欲闻般若义。云何是般若波罗蜜者。是问般若波罗蜜体。云何行者。是问初入方便行。云何住者。问深入究竟住。须菩提受其语作是答。若人饥渴给足饮食感恩则深。菩萨亦如是。发心求佛道。为是人说般若则大得利益。感恩亦深。是故说般若。未发心者当发。已入圣道者则不堪任。以漏尽无有后生故。如是等因缘故言不任。问曰。若是人不任者。何以故。言是人若发心者。我亦随喜。不障其功德。上人应更求上法。答曰。须菩提虽是小乘。常习行空故不着声闻道。以是故。假设言。若发心有何咎。此中须菩提自说二因缘。一者不障其福德心。二者上人应更求上法。以是故。上人求阿耨多罗三藐三菩提无咎。若上人求小法是可耻。以中间傍及余事故。更称问。何等是般若波罗蜜者。所谓应萨婆若心。观色无常苦空无我。如先说。观五众。能生诸恼故。言如病。有人闻五众如病。谓为轻微故。言如痈疽有人以痈疽虽难愈犹或可差故。言如箭镝入体不可得出。有人以箭镝在体虽沉深难拔。良方妙术犹可令出故。言常痛恼。如人着衰常有不吉。五众亦如是。若人随逐则无安隐。以有衰故常怀忧怖。是五众如与师子虎狼共住常怀忧畏。是五众无常虚诳等过故。常不安隐。问曰。五众但有此十五种恶。更有余事。答曰。略说则十五。广说则无量无边。如杂阿含中呵五众有百种罪过。问曰。何以常说无常苦空无我。或时说八事如病如痈疽等。余七事少有说处。答曰。人有上中下。为利根故说四。即入苦谛。中根者说四。则不能生厌心。说如病如痈等八事则生厌心。钝根人闻是八事犹不生厌。更为说痛恼等七事然后乃厌。利根易度故。常多说四事。钝根人时有可度者故。希说余事。上八事名为圣行。余七事凡夫圣人共行。初四入十六圣行故。般若中常说。又说般若为菩萨利根故多说圣行。今问云何是初行法。故此中都说十二入。乃至六种等亦应如是。呵十八界等亦应具说。诵者忘失。所以者何。此十八界等诸法。皆是五众别名故不应不说。若行者观五众等寂灭远离。不生不灭不垢不净。此但为般若波罗蜜故。不合上十五说十五事。三乘共故。声闻人智力薄故。初始不能观五众若远离若寂灭等。但能观无常等入第三谛。乃能观寂灭。菩萨利根故初观五众。便得寂灭相。用无所得者。常用无所得空慧观诸法相

复次释提桓因问般若波罗蜜相。不问五众患厌事。但说般若相。般若相者。不离五众有涅槃。不离涅槃有五众。五众实相即是涅槃。是故初发心钝根者。先用无常等观。然后观五众寂灭等。十二因缘亦如是。复次修四念处乃至八圣道分。是共法应萨婆若心。以无所得者。是名般若波罗蜜相。六波罗蜜乃至十八不共法。独是大乘法。问曰。应说般若波罗蜜相行。何以故。中间说诸法。诸法更相因缘润益增长。答曰。须菩提上先说诸法无常等过。后说诸法远离寂灭无所得空。然后说诸法虽空从因缘和合故有。次说四念处乃至十八不共法行佛道。听者作是念。上说远离寂灭空故知非常。说十二因缘故知不灭。而无知者见者。谁修行是诸法得佛。是故说菩萨作是念。诸法空无我无众生。而从因缘故有。四大六识是十法各各有力。能生能起能有所作。如地能持水能烂火能消风能回转。识能分别是十法各有所作。众生颠倒故。谓是人作我作。如皮骨和合故有语声。或者谓人语。如火烧干竹林出大音声。此中无有作者。又如木人幻人化人虽能动作无有作者。此十法亦如是。前生法后生法因缘。或共生因缘。或相应因缘。或报因缘等。常修常集因缘。令果报增长。如春殖果树随时溉灌华果繁茂。以智慧分别。知一切诸法无有作者。菩萨初发意回向。与佛心作因缘。而初发意回向时未有佛心。佛心中无初回向心。虽无而能作因缘。问曰若初发心回向时。无菩提心者。何所回向。答曰。般若波罗蜜实相中。诸法非常相非无常相。非有相非无相故不应难言。回向心已灭无所有。云何与菩提作因。若诸法不生不灭。非不生非不灭。云何以不生不灭作难。无菩提心何所回向。复次佛自说。菩提相非过去非未来非现在。云何难言。未来无菩提故何所回向。复次如如品中说。过去世不离未来世。未来世不离过去世。过去世如未来世如一如无二。云何说菩提心不在回向心中回向心不在菩提心中。但菩萨闻是赞叹佛法发心爱乐。我所有功德。皆回向佛道。从发心已来乃至佛道。修是功德不休不息。用如幻如梦无所得故。是名菩萨般若波罗蜜。能知诸法因缘生果报。而无有定相。释提桓因难。何以故。回向心不在菩提心中可得。菩提心不在回向心中可得。须菩提不以世谛如幻如梦说。但以第一义谛说是二心。皆空非心相。何以故。诸法毕竟空中。无是心非心。如是法云何可有回向。若有二法可有回向。譬如乘车西行。南有止宿处故回车趣向。车与回向处异故。可有回向。不得但有车而言回向无异故。非心相常非心相者。须菩提意谓。是心相如常住不生不灭不垢不净。以非心相故非心。亦无是非心。是故说不可思议。不可思议亦常不可思议。不可筹量思惟取相。以是因缘故。阿耨多罗三藐三菩提所因心。似果不似则不能生。若初心不净。后不能发净心。如炼铁不能成金。佛以须菩提深入因缘般若波罗蜜中。此是般若波罗蜜名也。以能深得诸法因缘故。即以为名。无有违错故。于大众中。赞言善哉善哉。汝是小乘人。而能善说深般若波罗蜜。安慰诸菩萨心者。以般若波罗蜜教诸菩萨。汝莫自以烦恼未尽未成佛道故而自懈废。诸法无碍初心后心无有异相。但勤精进则成佛道。我应报恩者。须菩提作是念。我行此诸法实相。得脱老病死苦。我云何不念是法大恩。以是故常乐说法。复次佛有大悲心。乐说法度众生。我以佛恩故得道。我亦助佛说法度众生。是为报恩。又知今世尊。因过去诸佛得成佛道。是故我亦爱敬过去佛。如子爱敬父故。亦爱重于祖。又亦爱敬过去诸菩萨及弟子。能说法教示故。今世尊亦因此得成。须菩提深心信三宝故说。我知今世尊及法过去诸佛及弟子恩。法即是法宝。今佛过佛即是佛宝。诸菩萨及弟子即是僧宝。六波罗蜜如先说。示者示人好丑善不善应行不应行。生死为丑。涅槃安隐为好。分别三乘分别六波罗蜜。如是等名示。教者教言汝舍恶行善是名教。利者未得善法味故心则退没。为说法引导令出。汝莫于因时求果。汝今虽勤苦。果报出时大得利益。令其心利故名利。喜者随其所行而赞叹之令其心喜。若乐布施者赞布施。则喜故名喜。以此四事庄严说法

【经】尔时须菩提语释提桓因言。憍尸迦。汝今当听。菩萨摩诃萨般若波罗蜜中如所应住所不应住。憍尸迦。色色空。受想行识识空。菩萨菩萨空。是色空菩萨空不二不别。受想行识空菩萨空不二不别。憍尸迦。菩萨摩诃萨般若波罗蜜中应如是住。复次眼眼空。乃至意意空。菩萨菩萨空。眼空乃至菩萨空不二不别。六尘亦如是。地种地种空。乃至识种识种空。菩萨菩萨空。憍尸迦。地种空乃至识种空菩萨空不二不别。憍尸迦。菩萨摩诃萨般若波罗蜜中应如是住。无明无明空。乃至老死老死空。无明灭无明灭空。乃至老死灭老死灭空。菩萨菩萨空。憍尸迦。无明空乃至老死空。无明灭空乃至老死灭空菩萨空不二不别。憍尸迦。菩萨摩诃萨般若波罗蜜中应如是住。檀波罗蜜乃至般若波罗蜜。内空乃至无法有法空。四念处乃至十八不共法。一切三昧门。一切陀罗尼门。声闻乘辟支佛乘佛乘。声闻辟支佛菩萨佛亦如是。一切种智一切种智空。菩萨菩萨空。一切种智空菩萨空不二不别。憍尸迦。菩萨摩诃萨般若波罗蜜中应如是住。尔时释提桓因问须菩提。云何菩萨般若波罗蜜中所不应住。须菩提言。憍尸迦。菩萨摩诃萨不应色中住。以有所得故。不应受想行识中住。以有所得故。不应眼中住。乃至不应意中住。不应色中住。乃至不应法中住。眼识乃至意识。眼触乃至意触。眼触因缘生受。乃至意触因缘生受中不应住。以有所得故。地种乃至识种中不应住。以有所得故。檀波罗蜜乃至般若波罗蜜四念处。乃至十八不共法中不应住。以有所得故。须陀洹果中不应住。以有所得故。乃至阿罗汉果辟支佛道菩萨道佛道一切种智不应住。以有所得故。复次憍尸迦。菩萨摩诃萨。色是常不应住。色是无常不应住。受想行识亦如是。色若乐若苦若净若不净若我若无我若空若不空。若寂灭若不寂灭。若离若不离不应住。以有所得故。受想行识亦如是。复次憍尸迦。菩萨摩诃萨。须陀洹果无为相。斯陀含果无为相。阿那含果无为相。阿罗汉果无为相不应住。辟支佛道无为相。佛道无为相不应住。须陀洹福田不应住。斯陀含阿那含阿罗汉辟支佛佛福田不应住。复次憍尸迦。菩萨摩诃萨初地中不应住。以有所得故。乃至第十地中不应住。以有所得故。复次菩萨摩诃萨。住初发心中。我当具足檀波罗蜜不应住。乃至我当具足般若波罗蜜不应住。具足六波罗蜜当入菩萨位不应住。入菩萨位已当住阿鞞跋致地不应住。菩萨当具足五神通不应住。以有所得故。菩萨住五神通已。我当游无量阿僧祇佛界。礼敬供养诸佛听法。听法已为他人说。菩萨摩诃萨如是不应住。以有所得故。如诸佛世界严净。我亦当庄严世界不应住。以有所得故。成就众生令入佛道不应住。到无量阿僧祇世界诸佛所。尊重爱敬供养。以香华璎珞泽香捣香幢幡华盖百千亿种宝衣供养诸佛不应住。以有所得故。我当令无量阿僧祇众生发阿耨多罗三藐三菩提心。如是菩萨不应住。我当生五眼。肉眼天眼慧眼法眼佛眼不应住。我当生一切三昧门不应住。随所欲游戏诸三昧不应住。我当生一切陀罗尼门不应住。我当得佛十力不应住。我当得四无所畏四无碍智十八不共法不应住。我当具足大慈大悲不应住。我当具足三十二相不应住。我当具足八十随形好不应住。以有所得故。是八人是信行人是法行人如是不应住。须陀洹极七世生不应住。家家不应住。须陀洹命终垢尽不应住。须陀洹中间入涅槃不应住。是人向斯陀含果证不应住。是人斯陀含一往来入涅槃不应住。是人向阿那含果证不应住。斯陀含一种不应住。是人阿那含彼间入涅槃不应住。是人向阿罗汉果证不应住。是人阿罗汉今世入无余涅槃不应住。是辟支佛不应住。过声闻辟支佛地我当住菩萨地不应住。道种智中不应住。以有所得故。一切种一切法。知已断诸烦恼及习不应住。佛得阿耨多罗三藐三菩提。当转法轮不应住。作佛事度无量阿僧祇众生入涅槃不应住。四如意足中不应住。入是三昧住。如恒河沙等劫寿不应住。我当得寿命无殃数劫不应住。三十二相一一相百福庄严不应住。我一世界如十方恒河沙等世界不应住。我三千大千世界纯是金钢不应住。使我菩提树当出如是香。众生闻者无有淫欲嗔恚愚痴。亦无声闻辟支佛心。是一切人必当得阿耨多罗三藐三菩提。若众生闻是香者。身病意病皆悉除尽不应住。当使我世界中无有色受想行识名字不应住。当使我世界中无有檀波罗蜜名字。乃至无有般若波罗蜜名字。当使我世界中无有四念处名字。乃至无有十八不共法名字。亦无须陀洹名字。乃至无有佛名字不应住。以有所得故。何以故。诸佛得阿耨多罗三藐三菩提时。一切诸法无所得故。如是憍尸迦。菩萨于般若波罗蜜中不应住。以无所得故。尔时舍利弗心念。菩萨今云何应住般若波罗蜜中。须菩提知舍利弗心所念。语舍利弗言。于汝意云何。诸佛何所住。舍利弗语须菩提。诸佛无有住处。诸佛不色中住。不受想行识中住。不有为性中住。不无为性中住。不四念处中住。乃至不十八不共法中住。不一切种智中住。舍利弗。菩萨摩诃萨。般若波罗蜜中。应如是住。如诸佛住于诸法中。非住非不住。舍利弗。菩萨摩诃萨般若波罗蜜中应如是学。我当住不住法故

【论】者言。般若波罗蜜中住者。所谓五众五众相空。五众相空者。以十八空观故。复次般若波罗蜜经中说空义。五众相空。但凡夫颠倒故。取五众相。五众和合中取菩萨相。般若波罗蜜中。以众生空除众生。即是无菩萨相。以法空除五众。则无五众相。二空无有别异故言五众空菩萨空无二无别。如栴檀火灭粪草木火灭。灭法无异。取未灭时相于灭时说故有别异。于灭中则无异。乃至一切种智亦如是。不应住者。所谓五众中不应住。问曰。应说如住义。何以故说不住。答曰。若能于五众中心离不住则是住义。是故说以有所得故不应住。乃至一切种智亦如是。先说五众中不应住。不知以何门不应住。今说常无常等门中不应住乃至远离不应住。问曰。须陀洹果等无为相不应住有何次第。答曰。菩萨先观诸法空无所有。心退没欲取涅槃。涅槃即是无为相。是故今说须陀洹果等无为相不应住。若是须陀洹果无为相则无法可着。何所爱何所取。若是有为相。有为相则虚诳无实亦不应住。是故说须陀洹果无为相不应住。乃至佛无为相不应住亦如是。如菩萨欲行佛道。初行檀波罗蜜应求福田。所以者何。福田因缘功德故所愿得满。如种良田则所收益多。如佛说余田果报有量。贤圣田无量。果报亦无量。菩萨闻是须陀洹等福田果报无量故。便欲作须陀洹。以是故。说须陀洹福田不应住。乃至辟支佛亦如是。问曰。二乘小故应过不住。佛福田何故不住。答曰。菩萨法于诸法应平等。若以佛为大众生为小。则破等法相。复次空故一切处不应住。复次菩萨应等心布施。若分别福田则破大悲。亦破三分清净布施。初地中不应住者。若不舍初地则不得二地。求大益故应舍小利。复次以着心取相故不应住。乃至第十地亦如是。问曰。若菩萨摩诃萨法。从初发心应行六波罗蜜。行六波罗蜜故入法位。入法位故应住阿鞞跋致地。住阿鞞跋致地已。应起五神通。供养十方诸佛。如后广说。今何以故皆言不应住。答曰。不破清净住。但破计我邪见取相心住。譬如治田去其秽草。复次为断法爱故不应住。不欲违诸佛说毕竟空智慧故不应住。若以方便不着心。怜愍众生故虽住无咎。乃至八十种随形好亦如是。八人者。所谓见谛道中。信行法行须陀洹极久七世生。有须陀洹今世烦恼尽得阿罗汉。有家家须陀洹三世生三世生已入涅槃。有中间须陀洹除第三余中间入涅槃。住六无碍五解脱中者。皆是须陀洹向。斯陀含断欲界六种结生天上。从天上来生人间入涅槃名斯陀含。断欲界第七分结名向阿那含。断第八分结亦名向阿那含。又名一种子。斯陀含此间死彼间生入涅槃。能断欲界一切结使名阿那含。此间死生色无色界入涅槃。更不复来生。有今世灭阿那含。有中阴灭阿那含。有即生时入涅槃阿那含。有生已修起诸行入涅槃阿那含。有不勤求诸行入涅槃阿那含。有上行乃至阿迦贰吒阿那含。有生无色界入涅槃阿那含。有得身证入涅槃阿那含。是名阿那含。亦名向阿罗汉。阿罗汉有九种。漏尽舍身时。名入无余涅槃。过声闻辟支佛地。住菩萨地。道种智一切种智。知一切法。断一切烦恼及习。成佛转法轮。三十二相庄严。世界度无量众生无量寿命。皆如先论议中说。声闻人善修四如意足。得是三昧力。能住寿若一劫若减一劫。菩萨善修四如意三昧。若欲如恒河沙劫寿亦得如意。三千大千世界纯是金刚者。余世界虽底有金刚及佛所行所坐处有金刚。而余处皆无。是菩萨所愿世界皆是金刚。菩提树香度众生者。如先义中说。问曰。此中事虽希有皆可信。无有色受想行识名字。无檀波罗蜜名字乃至佛名字。是难可信。答曰。有世界。大福德智慧人生处。树木虚空土地山水等。常出诸法实相之音。所有法皆是不生不灭不净不垢空无相无作等。众生生便闻是音。自然得无生法忍。如是世界中。不须分别说诸法名字。所谓是五众十二入等。檀波罗蜜乃至十八不共法。须陀洹乃至诸佛。是世界中众生。皆有三十二相八十随形好庄严身。无量光明一种道一种果。是中不应住者。菩萨自念我能生如是世界则生高心。以是故不应取相住此中。须菩提自说不住因缘。诸佛得佛道时。于诸法中不得定实相。故当何所住。今舍利弗作是念。若都无所住。当住何处得成佛道。须菩提知舍利弗心之所念。语舍利弗。诸菩萨皆是佛子。子法应如父所行。诸佛心于一切法中无所住。所谓色乃至一切种智。菩萨亦应如是学。用无所住心。行般若波罗蜜。如诸佛无所住心中亦不住。非不住心中亦不住。毕竟清净故。诸菩萨亦应随佛住毕竟清净故。诸菩萨亦应随佛学

【经】尔时会中有诸天子作是念。诸夜叉言语字句所说尚可了知。须菩提所说言语论义解释。般若波罗蜜了不可知。须菩提知诸天子心所念。语诸天子。不解不知耶。诸天子言。大德。不解不知。须菩提语诸天子。汝等法应不知。我无所论说乃至不说一字。亦无听者。何以故。诸字非般若波罗蜜。般若波罗蜜中无听者。诸佛阿耨多罗三藐三菩提无字无说。诸天子如佛化作化人。是化人复化作四部众。比丘比丘尼优婆塞优婆夷。化人于四部众中说法。于汝意云何。是中有说者有听者有知者不。诸天子言。不也大德。须菩提言。一切法皆如化。此中无说者无听者无知者。诸天子。譬如人梦中见佛说法。于汝意云何。是中有说者有听者有知者不。诸天子言。不也大德。须菩提语诸天子。一切法皆如梦。无说无听无知者。诸天子。譬如二人在大深涧各住一面赞佛法众。有二向出。于诸天子意云何。是二人向展转相解不。诸天子言。不也大德。须菩提语诸天子。一切法亦如是。无说无听无知者。诸天子。譬如工幻师。于四衢道中化作佛及四部众于中说法。于诸天子意云何。是中有说者有听者有知者不。诸天子。言不也大德。须菩提语诸天子。一切诸法如幻。无说者无听者无知者。尔时诸天子心念。须菩提所说。欲令易解转深转妙。须菩提知诸天子心所念。语诸天子言。色非深非妙。受想行识非深非妙。色性非深非妙。受想行识性非深非妙。眼性乃至意性。色性乃至法性。眼界性乃至意界性。眼识乃至意识。眼触乃至意触。眼触因缘生受乃至意。触因缘生受。檀波罗蜜乃至般若波罗蜜。内空乃至无法有法空。四念处乃至十八不共法。一切诸三昧门。一切陀罗尼门。乃至一切种智。一切种智性。非深非妙。诸天子复作是念。是所说法中不说色。不说受想行识。不说眼乃至意触。因缘生受。不说檀波罗蜜乃至般若波罗蜜。不说内空乃至无法有法空。不说四念处乃至十八不共法。不说陀罗尼门三昧门乃至一切种智。不说须陀洹果乃至阿罗汉果。不说辟支佛道。不说阿耨多罗三藐三菩提道。是法中不说名字语言。须菩提知诸天子心所念。语诸天子言。如是如是诸天子。是法中诸佛得阿耨多罗三藐三菩提不可说相。是中亦无说者无听者无知者。以是故诸天子善男子善女人。欲住须陀洹果。欲证须陀洹果者。是人不离是忍。斯陀含阿那含阿罗汉果辟支佛道佛道。欲住欲证不离是忍。如是诸天子。菩萨摩诃萨从初发心。般若波罗蜜中应如是住。以无说无听故

【论】问曰。诸夜叉语虽隐覆不正。而事则鄙近。说深般若波罗蜜。虽用常辞而幽旨玄远事异趣乖。何以相况。答曰。诸天适以人所不解。况已未悟。不必事趣皆同以为喻也。有人言。天帝九百九十九门。门皆以十六青衣夜叉守之。此诸夜叉语言浮伪情趣妖谄。诸天贱之不以在意。是故不解其言而其意况可不须言辩而识故言尚可了知。今闻深般若。言似可及而玄旨幽邃。寻之虽深而失之逾远。故以夜叉言况其叵知。又以夜叉语虽难解眼见相传以其言度其心则皆可知。譬如深渊驶水得船可渡。须菩提所说般若波罗蜜。毕竟空义无有定相。不可取不可传译得悟。不得言有。不得言无。不得言有无。不得言非有非无非非有非非无亦无。一切心行处灭言语道断故。是故诸天子惊疑迷闷。须菩提答诸天子。汝所不解者。汝自应尔。是法无所一说乃至不说一字可着可取。无字无语是诸佛道。何以故。是名字皆空虚诳无实。如破色名字中说。用名字则有语言。若无名字则无语言。诸天子作是念。若无说若无听。今日和合聚会为何所作。须菩提欲解此义故。以譬喻明之。诸天子复作是念。欲以譬喻解悟。我等而此譬喻转更深妙譬喻。以粗喻细。以定事明不定。今此譬喻亦微妙无定相。须菩提知诸天子心于深般若中迷没不能自出。是故说般若波罗蜜不异五众。五众实相即是般若波罗蜜。今是五众非深非妙。乃至一切种智非深非妙。诸天子尔时深知须菩提口虽说色心无所说。乃至阿耨多罗三藐三菩提亦如是。须菩提知诸天子心答言。如是如是。非我独尔。佛得菩提时。亦无说寂灭相。实无说者听者。是故须陀洹果乃至佛道。皆因无为法而有。离是法离是忍。则无须陀洹。乃至佛道亦如是。菩萨初发心乃至得佛。于其中间一切法无说无闻。诸观灭故。语言断故不可说。不可说故不可听。不可听故不可知。不可知故于一切法无受无著。则入涅槃

大智度论卷第五十四大智度论释幻人听法品第二十八(卷五十五)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】尔时诸天子心念。应用何等人听须菩提所说。须菩提知诸天子心所念。语诸天子言。如幻化人听法。我应用如是人。何以故。如是人无闻无听无知无证故。诸天子语须菩提。是众生如幻如化听法者亦如幻如化耶。如是如是。诸天子。众生如幻。听法者亦如幻。众生如化听法者亦如化。诸天子我如幻如梦。众生乃至知者见者亦如幻如梦。诸天子色如幻如梦。受想行识如幻如梦。眼乃至意触因缘生受如幻如梦。内空乃至无法有法空。檀波罗蜜乃至般若波罗蜜如幻如梦。诸天子。四念处乃至十八不共法如幻如梦须陀洹果如幻如梦。斯陀含果阿那含果。阿罗汉果辟支佛道如幻如梦。诸天子。佛道如幻如梦。尔时诸天子问须菩提。汝说佛道如幻如梦。汝说涅槃亦复如幻如梦耶。须菩提语诸天子。我说佛道如幻如梦。我说涅槃亦如幻如梦。若当有法胜于涅槃者。我说亦复如幻如梦。何以故。诸天子。是幻梦涅槃不二不别

【论】问曰。上已说如幻如梦。无说者无听者。今何以故复问。应用何等人随须菩提意听法者。答曰。诸天子先言须菩提所说不可解。此中须菩提说幻化人喻。今诸天子更作是念。何等人听与须菩提所说相应。能信受行得道果。须菩提答。如幻化人听者。则与我说法相应。问曰。是化人无心心数法不能听受。何用说法。答曰。非即使幻化人听。但欲令行者于诸法用心无所著如幻化人。是幻化人无闻亦无证。众生如幻如梦。听法亦如幻如梦。众生者说法人。听法者是受法人。须菩提言。不但说法者听法者如幻如梦。我乃至知者见者皆如幻如梦。色亦如幻如梦。乃至涅槃如幻如梦。即是所说法如幻如梦。一切众生中佛为第一。一切诸法中涅槃第一。闻是二事如幻如梦心则惊疑。佛及涅槃最上最妙。云何如幻如梦。以是故更重问其事。佛及涅槃审如幻如梦耶。须菩提将无误说。我等将无谬听。是以更定问。须菩提语诸天子。我说佛及涅槃正自如幻如梦。是二法虽妙。皆从虚妄法出故空。所以者何。从虚妄法故有涅槃。从福德智慧故有佛。是二法属因缘无有实定。如念佛念法义中说。须菩提作是念。般若波罗蜜力假令有法胜涅槃者能令如幻。何况涅槃。何以故。涅槃一切忧愁苦恼毕竟灭。以是故无有法胜涅槃者。问曰。若无法胜涅槃者。何以故说若有法胜涅槃亦复如幻。答曰。譬喻法或以实事。或时假设随因缘故说。如佛言。若令树木解我所说者。我亦记言得须陀洹。但树木无因缘可解。佛为解悟人意故。引此喻耳。涅槃是一切法中究竟无上法。如众川万流大海为上。诸山之中须弥为上。一切法中虚空为上。涅槃亦如是。无有老病死苦。无有邪见贪恚等诸衰。无有爱别离苦。无怨憎会苦。无所求不得。苦无常虚诳败坏变异等一切皆无。以要言之。涅槃是一切苦尽。毕竟常乐。十方诸佛菩萨弟子众所归处。安隐常乐无过是者。终不为魔王魔人所破。如阿毗昙中说。有上法者。一切有为法。及虚空非智缘尽。无上法者智缘尽。所谓涅槃。是故知无法胜涅槃者。须菩提美般若波罗蜜力大故。言若有法胜涅槃者是亦如幻。譬如大热铁丸以着擘起毳上直烧下过热势无损但更无可烧者。般若波罗蜜智慧。破一切有法乃至涅槃。直过无碍智力不减。直更无法可破。是故言设有法胜涅槃。智慧力亦能破

【经】尔时慧命舍利弗。摩诃目揵连。摩诃拘絺罗。摩诃迦旃延。富楼那。弥多罗尼子。摩诃迦叶。及无数千菩萨。问须菩提。般若波罗蜜如是甚深。难见难解难知寂灭微妙。谁当受者。尔时阿难语诸大弟子及诸菩萨。阿鞞跋致诸菩萨摩诃萨。能受是甚深难见难解难知寂灭微妙般若波罗蜜。正见成就人。漏尽阿罗汉。所愿已满亦能受之。复次善男子善女人多见佛。于诸佛所多供养种善根。亲近善知识有利根。是人能受。不言是法非法。须菩提言。不以空分别色。不以色分别空。受想行识亦如是。不以无相无作分别色。不以色分别无相无作。受想行识亦如是。不以无生无灭寂灭离分别色。不以色分别无生无灭寂灭离。受想行识亦如是。眼乃至意触因缘生受亦如是。檀波罗蜜乃至般若波罗蜜。内空乃至无法有法空。四念处乃至十八不共法。一切三昧门。一切陀罗尼门。须陀洹乃至阿罗汉辟支佛佛一切智。不以空分别一切智。不以一切智分别空。不以空分别一切种智。不以一切种智分别空。无相无作无生无灭寂灭离亦如是。须菩提语诸天子言。是般若波罗蜜甚深。谁能受者。是般若波罗蜜中。无法可示。无法可说。若无法可示无法可说。受人亦不可得。尔时舍利弗语须菩提言。般若波罗蜜中广说三乘之教。及摄取菩萨之法。从初发意地乃至十地。檀波罗蜜乃至般若波罗蜜。四念处乃至八圣道分。佛十力乃至十八不共法。护持菩萨之教。菩萨摩诃萨如是行般若波罗蜜。常化生不失神通。游诸佛国具足善根。随其所欲供养诸佛即得如愿。从诸佛所听受法教。至萨婆若初不断绝。未曾离三昧时。当得捷疾辩利辩不尽辩不可断辩随应辩义辩一切世间最上辩须菩提言。如是如是。如舍利弗言。般若波罗蜜广说三乘之教。及护持菩萨之教。乃至菩萨摩诃萨。得一切世间最上辩不可得故。我乃至知者见者不可得。色受想行识。檀波罗蜜乃至般若波罗蜜不可得。内空乃至无法有法空不可得。四念处乃至八圣道分。佛十力乃至一切种智。亦不可得故。舍利弗语须菩提。何因缘故。般若波罗蜜中。广说三乘而不可得。何因缘故。般若波罗蜜中护持菩萨。何因缘故。菩萨摩诃萨得捷疾辩。乃至一切世间最上辩不可得故。须菩提语舍利弗言。以内空故。般若波罗蜜。广说三乘不可得故。外空乃至无法有法空故。广说三乘不可得故。内空故护持菩萨。乃至一切世间最上辩不可得故。外空乃至无法有法空故。护持菩萨。乃至一切世间最上辩不可得故

【论】者言。是时诸大弟子舍利弗等。语须菩提。是般若波罗蜜法甚深难解。以诸法无定相故为甚深。诸思惟观行灭故难见。亦不着般若波罗蜜故。名难解难知。灭三毒及诸戏论故名寂灭。得是智慧妙味故。常得满足更无所求。余一切智慧皆粗涩叵乐故言微妙。诸大弟子作是言。般若波罗蜜智慧甚深。世间人智慧浅薄。但贪着福德果报。而不乐修福德。著有则情勇。破有则心怯。本所闻习邪见经书坚着不舍。如是人常乐世乐。以是故言谁能信受。是深般若波罗蜜。若无信受。何用说为阿难助。答有四种人能信受。是故大德须菩提所说必有信受。不空说也。一者阿鞞跋致菩萨摩诃萨。知一切法不生不灭。不取相无所著故是则能受。二者漏尽阿罗汉。漏尽故无所著。得无为最上法。所愿已满更无所求故。常住空无相无作三昧。随顺般若波罗蜜故。则能信受。三者三种学人正见成就。漏虽未都尽四信力故亦能信受。四者有菩萨。虽未得阿鞞跋致。福德利根智慧清净。常随善知识。是人亦能信受。信受相不言是法非佛菩萨大弟子所说。虽闻般若波罗蜜诸法皆毕竟空。不以爱先法故而言非法。问曰。自上已来阿难都无言论。今何以伐须菩提答。答曰。阿难是第三转法轮。将能为大众师。是世尊近侍。虽得初道以漏未尽故。虽有多闻智慧。自以于空智慧中未能善巧。若说空法自未入故皆是他事。是故无言。或时说诸有事。则能问能答。如后品中。问佛言。世尊何以故但赞叹般若波罗蜜。不赞五波罗蜜。此中问人谁能信是深般若波罗蜜者。非是空事故阿难便答。须菩提常乐说空事不喜说有。又以阿难是时乐说心生。是故听答。阿难烦恼未尽故智慧力钝。然信力猛利故。于甚深般若波罗蜜中。能如法问答。问曰。般若波罗蜜无所有。无有一定法。云何四种人信受不言非法。答曰。今须菩提此中自说因缘。不以空分别色。色即是空空即是色。以是故般若波罗蜜无所失无所破。若无所破则无过罪。是故不言非法。空即是般若波罗蜜。不以空智慧破色令空。亦不以破色因缘故有空。空即是色色即是空。故以般若波罗蜜中破诸戏论。有如是功德。故无不信受。无相无作无生无灭寂灭远离亦如是。乃至一切种智皆应广说。问曰。诸大弟子问是义。须菩提何以乃答诸天子。答曰。诸大弟子已得阿罗汉。但自为疑故问益利事少。诸天子发心为菩萨。利益深故为说。复次虽为诸天子说。即是答诸大弟子。上说诸法空。今说深般若波罗蜜中众生毕竟空。以是故般若波罗蜜中无有说者何况有听受者。若能如是解诸法空。心无。所著则能信受。尔时须菩提。说深般若波罗蜜。舍利弗赞叹助成其事。般若波罗蜜。非但以空故可受。亦广说有三乘。三乘义如先说。摄取菩萨者。以般若波罗蜜。利益诸菩萨令得增长。复次摄取者。是般若波罗蜜中有十地。令菩萨从一地至一地乃至第十地。十地义从六波罗蜜。乃至一切种智义如先说。化生者。说般若波罗蜜行报。行般若波罗蜜。于一切法无碍故得捷疾辩。有人虽能捷疾。钝根故不能深入。以能深入故利。是利辩说诸法实相。无边无尽故。名乐说无尽辩。般若中无诸戏论故无能问难。断绝者。名不可断辩。断法爱故随众生所应而为说法。名随应辩。说趣涅槃利益之事故。名义辩。说一切世间第一之事。所谓大乘。是名世间最上辩。须菩提然其问言如是如是。舍利弗作是念。须菩提常乐说空。何以故。受我所说般若波罗蜜广说三乘之教。应当更有因缘。须菩提答。般若波罗蜜虽广说三乘法。非有定相。皆以十八空和合故说。摄取菩萨七种辩亦如是。以空智慧故

    大智度论释散华品第二十九

【经】尔时释提桓因。及三千大千世界中四天王天。乃至阿迦尼吒诸天作是念。慧命须菩提为雨法雨。我等宁可化作华散佛菩萨摩诃萨。比丘僧须菩提及般若波罗蜜上。释提桓因及三千大千世界中诸天。化作华散佛菩萨摩诃萨比丘僧及须菩提上。亦供养般若波罗蜜。是时三千大千世界华。悉周遍于虚空中。化成华台端严殊妙。须菩提心念。是诸天子所散华天上未曾见。如是华比是华。是化华非树生华。是诸天子所散华。从心树生非树生华。释提桓因知须菩提心所念。语须菩提言。大德。是华非生华。亦非意树生须菩提语释提桓因言。憍尸迦。汝言是华非生华。亦非意树生。憍尸迦。是若非生法不名为华。释提桓因语须菩提言。大德。但是华不生色亦不生。受想行识亦不生。须菩提言。憍尸迦。非但是华不生色亦不生。若不生是不名为色。受相行识亦不生。若不生是不名为识。六入六识六触六触因缘生诸受亦如是。檀波罗蜜不生。若不生是不名檀波罗蜜。乃至般若波罗蜜不生。若不生是不名般若波罗蜜。内空不生。若不生是不名内空。乃至无法有法空不生。若不生是不名无法有法空。四念处不生。若不生是不名四念处。乃至十八不共法不生。若不生是不名十八不共法。乃至一切种智不生。若不生是不名一切种智

【论】释曰。释提桓因及诸天。闻须菩提所说般若义。一切法尽是实相无所分别虽说空于诸法无所破。亦不失诸行业果报。声闻人。于佛前能说是甚深法故。释提桓因等。皆欢喜作是念。须菩提所说法无碍无障。譬如时雨如有国土溉灌种莳及种种用水。常苦不足。若时雨普降无不沾洽。无不如愿。小乘法亦如是。初种种赞叹布施持戒禅定无常等诸观有量有限。末后说涅槃。此中须菩提所明。从初发心乃至佛道。唯说诸法实相无所分别。譬如大雨遍满阎浮提无所不润。又如地。先虽有谷子。无雨则不生。行者亦如是。虽有因缘不得法雨发心者退。未发者住。若得法雨发心者增长。未发者发。以是故说如雨法雨。复次譬如恶风尘土诸热毒气等得雨则消灭。法雨亦如是。恶觉观尘土三不善毒邪见恶风邪师恶虫及诸恶知识等。得般若波罗蜜法雨。则皆除灭。人蒙时雨故供养天。诸天闻法雨大利益。欲供养故作是念。我等宁可作华散佛诸大菩萨比丘僧及须菩提亦供养般若波罗蜜。以须菩提善说般若敬之重故。甄名供养。是般若波罗蜜。多说诸法空。又上欲得如化人听法随其相故。以化华供养。复次诸天当欢喜时。便称心供养。不容多还取故。即作化华散佛须菩提诸菩萨比丘僧及般若波罗蜜。华散佛上是供养佛宝。散诸菩萨须菩提及般若波罗蜜。是供养法宝。散诸比丘僧是供养僧宝。作是念已。随意变化供养三宝。大福德成就故。心生所愿皆得如意不从他求。问曰。华台端严为是谁方。答曰是诸天力。诸天福德自在故。小能为大。有人言是佛神力。佛以此般若波罗蜜有大功德。因时少而果报甚大成就佛道。是故现此奇特。须菩提即时分别知非实华。释提桓因知须菩提觉是化华。语须菩提言。大德是华非生华。非生华者。言是华无生空无所出。须菩提说是般若波罗蜜。诸法无生空寂故以无生华供养。意树者诸天随意所念则得。以要言之。天树随意所欲应念则至。故言意树。释提桓因难须菩提。故言是华无生。何以言是华不从树生。须菩提反质言。若不生何以名华。不生法中无所分别。所谓是华是非华。是时释提桓因心伏而问。但是华无生。诸法亦无生。须菩提答。非但是华不生。色亦不生。何以故。若一法空则一切法皆空。若行者于一法中了了决定知空。则一切法中皆亦明了。若五众不生则非五众相。乃至一切种智亦如是。五众从因缘和合生无有定性。但有假名。假名实相者。所谓五众如法性实际。须菩提所说不违此理何以故。圣人知名字是俗谛。实相是第一义谛。有所说者随凡夫人。第一义谛中无彼此亦无诤。乃至一切种智亦如是。众生空乃至知者见者空故。须陀洹但有假名。乃至佛亦如是

【经】尔时释提桓因作是念。是慧命须菩提。其智甚深不坏假名。而说诸法实相。佛知释提桓因心所念语释提桓因言。如是如是。憍尸迦。须菩提其智甚深不坏假名。而说诸法实相。释提桓因白佛言。大德须菩提。云何不坏假名。而说诸法实相。佛告释提桓因。色但假名。须菩提不坏假名。而说诸法实相受想行识但假名须菩提亦不坏假名。而说诸法实相。所以者何。是诸法实相无坏不坏故。须菩提所说亦无坏不坏。眼乃至意触因缘生诸受亦如是。檀波罗蜜乃至般若波罗蜜。内空乃至无法有法空。四念处乃至十八不共法亦如是。须陀洹果乃至阿罗汉果。辟支佛道菩萨道佛道。一切智一切种智亦如是。须陀洹乃至阿罗汉辟支佛佛。是但假名。须菩提不坏假名。而说诸法实相。何以故。是诸法实相无坏不坏故。须菩提所说。亦无坏不坏如是。憍尸迦。须菩提不坏假名。而说诸法实相。须菩提语释提桓因。如是如是。憍尸迦。如佛所说。诸法但假名。菩萨摩诃萨当作是知。诸法但假名。应如是学般若波罗蜜。憍尸迦。菩萨摩诃萨作如是学。为不学色不学受想行识。何以故。不见色当可学者。不见受想行识当可学者。菩萨摩诃萨如是学。为不学檀波罗蜜。何以故。不见檀波罗蜜当可学者。乃至不学般若波罗蜜。何以故。不见般若波罗蜜当可学者。如是学为不学内空乃至无法有法空。何以故。不见内空乃至无法有法空当可学者。如是学为不学四念处乃至十八不共法。何以故。不见四念处乃至十八不共法当可学者。如是学为不学须陀洹果乃至一切种智。何以故。不见须陀洹果乃至一切种智当可学者。尔时释提桓因语须菩提言。菩萨摩诃萨何因缘故不见色。乃至不见一切种智。须菩提言。色色空。乃至一切种智。一切种智空。憍尸迦。色空不学色空。乃至一切种智空。不学一切种智空。憍尸迦。若如是不学空。是名学空。以不二故。是菩萨摩诃萨学色空。以不二故。乃至学一切种智空。以不二故。若学色空不二故。乃至学一切种智空不二故。是菩萨摩诃萨。能学檀波罗蜜不二故。乃至能学般若波罗蜜不二故。能学四念处不二故。乃至能学十八不共法不二故。能学须陀洹果不二故。乃至能学一切种智不二故。是菩萨能学无量无边阿僧祇佛法。若能学无量无边阿僧祇佛法。是菩萨不为色增学。不为色减学。乃至不为一切种智增学。不为一切种智减学。若不为色增减学。乃至不为一切种智增减学。是菩萨不为色受学。不为色灭学。亦不为受想行识受学。亦不为灭学。乃至一切种智。亦不为受学。亦不为灭学。舍利弗语须菩提。菩萨摩诃萨。如是学不为受色学。不为灭色学。乃至一切种智亦不为受学。亦不为灭学。须菩提言。菩萨摩诃萨。若如是学。不为受色学。不为灭色学。乃至一切种智。亦不为受学。亦不为灭学。须菩提。何因缘故。菩萨摩诃萨。不为受色学。不为灭色学。乃至一切种智。亦不为受学。亦不为灭学。须菩提言。是色不可受。亦无受色者。乃至一切种智不可受。亦无受者。内外空故如是。舍利弗。菩萨摩诃萨。一切法不受故。能到一切种智。是时舍利弗语须菩提。菩萨摩诃萨。如是学般若波罗蜜。能到一切种智耶。须菩提言。菩萨摩诃萨。如是学般若波罗蜜。能到一切种智。一切法不受故。舍利弗语须菩提。若菩萨摩诃萨。于一切法不受不灭学者。菩萨摩诃萨云何能到一切种智。须菩提言。菩萨摩诃萨。行般若波罗蜜。不见色生不见色灭。不见色受不见色不受。不见色垢不见色净。不见色增不见色减。何以故。舍利弗。色色性空故。受想行识亦不见生。亦不见灭。亦不见受亦不见不受。亦不见垢亦不见净。亦不见增亦不见减。何以故。识识性空故。乃至一切种智。亦不见生亦不见灭。亦不见受亦不见不受。亦不见垢亦不见净。亦不见增亦不见减。何以故。一切种智一切种智性空故。如是舍利弗。菩萨摩诃萨为一切法不生不灭不受不舍不垢不净不合不散不增不减故。学般若波罗蜜。能到一切种智。无所学无所到故

【论】释曰。释提桓因欢喜言。须菩提其智甚深不坏假名。而说诸法实相。尔时佛赞须菩提言。如是如是如释所言。问曰。佛何故赞须菩提。答曰。示师不自高。弟子承顺师法故。有人。师所说弟子不受。弟子所说师不听。如凡夫人处众说法时。破一切语不受。以佛无吾我心故。赞须菩提言如是如是。复次佛以大悲心。欲令众生信受须菩提所说。故赞言其智甚深。菩萨知一切法假名。则应般若波罗蜜学。所以者何。一切法但有假名。皆随顺般若波罗蜜毕竟空相故。如是学不学色者。假名法中无有定色。若无色者云何学色。何以故。菩萨以五眼求色。而不见是色。若我若无我等相。乃至一切种智亦如是。何以故不见色者。答言。色中色相空。不可得故不可见。即是自相空。乃至一切种智亦如是。复次不学色者。是色空。即自不能学色空。以诸法行于他相不行自相故。譬如人乘马非马乘马。问曰。若如是不学一切法。云何学一切智。答曰是中说。若能。于诸法空中无所著。是为真学色空。若着空者。是破诸法而不破空。若人破色而不着空。是则色与空不二不别。是为能学色空。以不可得空故。不见空。乃至一切种智亦如是。无量无边阿僧祇佛法者。是赞一切种智。上一切种智是。菩萨心中有量有限。在佛心中则无量无限。以是故。上虽说学佛法。今更别说。若能如是学。正行菩萨道不增减。色学不增者。若但见四大及造色和合成身者则不生着。以于是身中起男女好丑长短相谓为定实生染着心。是为增。若破色使空心着是空。是为减。乃至一切种智亦如是。不受不灭者。空故不受业果。因缘相续故不灭。是中须菩提自说。因缘色受者。不可得故不受。又以色内外空故不受。以色中内外空空故不灭。问曰。应以十八空空诸法。此中何以但说内外空。答曰。受色者无故说内空。色不可受故名外空。是内外空则摄一切法空。乃至一切种智亦如是。若菩萨能如是学。则出生一切种智。一切种智是无障碍相。若菩萨观一切法。如虚空无障碍。则是学一切种智。因果相似故。舍利弗作是念。菩萨法应当灭一切烦恼。应当受一切诸善法。今不受不灭学。云何出至萨婆若。作是念已问须菩提。须菩提答言。破一切法生相故不生。破一切法无常相故不灭。观一切法种种过罪故不受。观一切法种种利益故不舍。一切法性常清净故不垢。一切法能生着心故不净。一切法虽是有作无作起灭入出来往等。而不多不少不增不减。譬如大海众流归之不增。火珠煎之不减。诸法亦如是。法性常住故。一切法自性不可得故。能如是学则出到萨婆若。不见学相不见出相。不见菩萨相。不见般若波罗蜜相。此中略说故。但说无学无出

【经】尔时释提桓因语舍利弗。菩萨摩诃萨般若波罗蜜。当于何处求。舍利弗言。菩萨摩诃萨般若波罗蜜。当于须菩提品中求。释提桓因语须菩提。是汝神力使舍利弗言。菩萨摩诃萨般若波罗蜜。当于须菩提品中求。须菩提语释提桓因。非我神力。释提桓因语须菩提。是谁神力。须菩提言。是佛神力。释提桓因言。一切法皆无受处。何以故。言是佛神力。离无受处相。如来不可得离。如如来亦不可得。须菩提语释提桓因言。如是如是。憍尸迦。离无受处相。如来不可得。离如如来亦不可得。无受处相中如来不可得。如中如来不可。得色如中如来如不可得。如来如中色如不可得。色法相中。如来法相不可得。如来法相中。色法相不可得。受想行识法相中。乃至一切种智亦如是。憍尸迦。如来色如中不合不散。受想行识如中不合不散。如来离色如不合不散。离受想行识如不合不散。乃至一切种智亦如是。如来色法相中不合不散。受想行识法相中不合不散。如来离色法相中不合不散。离受想行识法相中不合不散。乃至一切种智亦如是。憍尸迦。如是等一切法中不合不散。是佛神力用无所受法故。如憍尸迦言。菩萨摩诃萨般若波罗蜜。当于何处求。憍尸迦。不应色中求般若波罗蜜。亦不应离色求般若波罗蜜。不应受想行识中求。亦不应离受想行识求。何以故。是般若波罗蜜。色受想行识。是一切法皆不合不散。无色无形无对一相。所谓无相。乃至一切种智中。不应求般若波罗蜜。亦不应离一切种智求般若波罗蜜。何以故。是般若波罗蜜一切种智。是一切法皆不合不散。无色无形无对一相。所谓无相。何以故。般若波罗蜜非色。亦非离色。非受想行识。亦非离受想行识。乃至非一切种智。亦非离一切种智。般若波罗蜜非色如。亦非离色如。非受想行识如。亦非离受想行识如。般若波罗蜜非色法。亦非离色法。非受想行识法。亦非离受想行识法。乃至非一切种智如。亦非离一切种智如。般若波罗蜜非一切种智法。亦非离一切种智法。何以故。憍尸迦。是一切法。皆无所有不可得。以无所有不可得故。般若波罗蜜非色。亦非离色。非色如。亦非离色如。非色法。亦非离色法。乃至非一切种智。亦非离一切种智。非一切种智如。亦非离一切种智如。非一切种智法。亦非离一切种智法

【论】问曰。佛舍利弗须菩提。从上来种种因缘。明般若波罗蜜相。今释提桓因。何以故问当何处求般若波罗蜜。答曰。此不问般若体。但问般若言说名字可读诵事。是故舍利弗言当于须菩提所说品中求。须菩提乐说空。常善修习空故。舍利弗虽智慧第一。以无吾我嫉妒心。又断法爱故。而言当于须菩提所说品中求。问曰。佛处处说般若波罗蜜。欲比须菩提所说。百千万倍不可算数譬喻为比。何以不言于佛所说品中求。答曰释提桓因意。除佛一人谁能善说者。是以推须菩提。复次佛常一日一夜六时。以佛眼观众生。无令不闻法故堕落。是故随众生所应解所应得所应习行等说。或说般若波罗蜜无常苦空无我如病如痈等。名为般若波罗蜜。或分别诸法总相别相。或说诸法因缘和合生。无有作者受者无知者见者。名为般若波罗蜜。或时说法空。或说毕竟空。名为般若波罗蜜。以是故不言佛所说品中求。又释提桓因心念。不知何者定是般若定相。是以舍利弗言。须菩提常深入空。所说皆趣空。所说空亦空是故言当于须菩提所说品中求。释提桓因欢喜。赞须菩提言。大德神力甚大。须菩提谦言。非是我力是佛所受神力。释提桓因言。若一切法皆无所受。云何言是佛所受神力。若离无受相。如来不可得。离如中如来不可得。释提桓因作是念言。一切法无受相。一切法空无依止处。云何当言定有如来。若无如来云何有所受神力。又复离无受相。如来亦不可得。今离是如如来不可得。问曰。无受相与如有何等异。答曰。诸法实相亦名无受。亦名如。诸法中不可着故名无受诸戏论。不能破坏故名为如。今如来空中不可得。离空亦不可得。须菩提然其言如是如是。今须菩提广说其事。无受相如相中。如来不可得者。或以佛名名为如来。或以众生名字名为如来。如先世来后世亦如是去。是亦名如来。亦名如去。如十四置难中说。死后如去者为有为无。亦有亦无亦非有非无。佛名如来者。如定光佛等。行六波罗蜜得成佛道。释迦文佛亦如是来故名如来。如锭光佛等。智知诸法如。从如中来故名如来。释迦文佛亦如是来故名如来。此二种如来中。此间说是佛如来。因解佛如来无所有。一切众生一切法皆如是。亦无所有。无受及如来义如先说。今当更略说。无受相如来相皆空无所有。无受相如相。无定性故无如来。有人言。诸法实相有二种说。一者诸法相毕竟空是实。二者有人言。毕竟空可示可说故非实。如涅槃相不可示不可说。是名为实。于此二事毕竟空中如来不可得。破毕竟空实相中如来亦不可得。毕竟空即是无受相。破毕竟空实相即是如。从此已下广说二义。于五众乃至一切种智。如来不可得。如来不可得故。云何当有如来神力。如来不可得如上说。是五众非如来。离五众非如来。五众不在如来中。如来不在五众中。如来亦不有五众。五众生灭无常苦空无我相故。非是如来。若是如来者。如来亦应是生灭。复次五众是五法如来是一。云何五法作一。若五即是一。一亦应即是五。若尔者世间法出世间法。一切乱坏。如是种种因缘故。五众非如来。若离五众有如来者。如来应无见无闻无知无识。亦不觉苦乐。所以者何。知觉等是五众法故。问曰。如来用眼耳智慧等。能知见者有何咎。答曰。能见是眼非是如来。若如来非见相。用眼能见者。未取色时云何知用是眼。亦可用耳见。问曰。如来用智慧分别能知。眼是能见余不能见。以是故用眼不取余根。答曰。知亦如眼。过知是五众非是如来。若用知知眼。复用何事能知此知。问曰。如来用知知眼以眼知色。若欲知如来以何得知。若以如来知如来是则无穷。答曰。知相知中住。如来若知即是知相。若是知相则是无常。若无常者则无后世。复次离五众有如来者。如来应是常。如虚空相不应变异。受苦受乐亦应无缚无解。有如是等过罪破异故。五众不在如来。如来不在五众。亦非如来有五众。问曰。应以五众因缘故有如来。若无五众则无如来。答曰。若以五众因缘有如来者。则如来无自性。若无自性何得从他性生于五众中。五种求如来不可得。是故无如来。但以戏论故说有如来。以断戏论故无如来。如来是不生不灭法。云何当以戏论求于如来。若以戏论求如来者。则不见如来。若当都无如来则堕邪见。是故若以有无戏论求如来是则不然。如来相即是一切法相。一切法相即是如来相。如来相即是毕竟空相。毕竟空相。即是一切法相。问曰。此中何以但说二事。言五众如中无如来如。如来如中无五众如。答曰。此是略说说二。则五事都摄。复次二十种我见。虽一切凡夫人有不能一时起。今是会中或此二事。以是故但说二事如五众。乃至一切种智亦如是。五众法相乃至一切种智法相亦如是。五众如即是法相。问曰。若如即是法相。何以重说。答曰。行者既到五众如心惊法相。何以毕竟空无所有。是故说五众法法相自尔。如人触火烧手则无愠心。以其火相自尔故。若人执火烧之则忿然而怒。以其执火烧故。如来五众如中五众法相中。不合不散者。除五众如无如来。即是一相所谓无相。所以者何。一法无合无散故。二法故有合有散。离五众法相亦无合无散。所以者何。离五众法相。如来不可得故。如来如法相五众如法相无二无别故。言离五众如五众法相亦不合不散。乃至一切种智亦如是。能如是知诸法如法相不合不散故。有是神力。当于何处求者。上来因佛神力说般若相。今直说云何求般若。论者言。五众虚诳无常。本无今有已有还无。如幻如梦。般若波罗蜜。是诸佛实智慧。云何当于五众中求。譬如求重宝必于大海宝山中求。不应在沟渎臭秽处求。离五众则无生无灭无作无起无有法相。是中云何可求。复次五众般若波罗蜜。不一不异不合不散。无色无形无对一相所谓无相。问曰。般若波罗蜜。是智慧心数法故。可应无色无形无对。五众中色众。云何当说无形无对。答曰。圣人以慧眼观诸法平等。皆空一相所谓无相。以是故色众无形无对。复次凡夫人所见色非实。种种如先破。复次有因缘。般若波罗蜜。不即是如凡夫人所见五众。破凡夫人所见五众故。即是般若波罗蜜故言不离。乃至一切种智亦如是。如相法相相如先说

【经】释提桓因语须菩提。是摩诃波罗蜜。是菩萨摩诃萨般若波罗蜜。无量波罗蜜。无边波罗蜜。是菩萨摩诃萨。般若波罗蜜。诸须陀洹须陀洹果。从是般若波罗蜜中学成。乃至诸阿罗汉阿罗汉果。诸辟支佛辟支佛道。诸菩萨摩诃萨。皆从是般若波罗蜜中学成。成就众生净佛世界。得阿耨多罗三藐三菩提。皆从是学成。须菩提语释提桓因言。如是如是憍尸迦。是摩诃波罗蜜。是菩萨摩诃萨般若波罗蜜。无量波罗蜜。无边波罗蜜。是菩萨摩诃萨般若波罗蜜。从是中学成。须陀洹果乃至阿罗汉果辟支佛道。诸菩萨摩诃萨。从是般若波罗蜜中学成。成就众生净佛世界。得阿耨多罗三藐三菩提。已得今得当得。憍尸迦。色大故般若波罗蜜亦大。何以故。是色前际不可得。后际不可得。中际不可得。受想行识大故。般若波罗蜜亦大。何以故。受想行识前际不可得。后际不可得。中际不可得。乃至一切种智亦如是。以是因缘故。憍尸迦。是摩诃波罗蜜。是菩萨摩诃萨般若波罗蜜。憍尸迦。色无量故。般若波罗蜜无量。何以故。色量不可得故。憍尸迦。譬如虚空量不可得。色亦如是。量不可得。虚空无量故色无量。色无量故般若波罗蜜无量。受想行识。乃至一切种智无量故。般若波罗蜜无量。何以故。一切种智量不可得。譬如虚空量不可得。一切种智亦如是。量不可得。虚空无量故。一切种智无量。一切种智无量故。般若波罗蜜无量。以是因缘故。是菩萨摩诃萨般若波罗蜜无量。憍尸迦。色无边故。诸菩萨摩诃萨。般若波罗蜜无边。何以故。憍尸迦。色前际不可得。后际不可得。中际不可得。受想行识无边故。般若波罗蜜无边。何以故。受想行识前际后际中际皆不可得故。乃至一切种智无边故。般若波罗蜜无边。何以故。一切种智前后中际不可得故。以是因缘故。憍尸迦。是般若波罗蜜无边色无边。乃至一切种智无边。复次憍尸迦。缘无边故。般若波罗蜜无边。须菩提。云何缘无边故。般若波罗蜜无边。须菩提言。缘一切无边法故。般若波罗蜜无边。云何缘一切无边法故。般若波罗蜜无边。须菩提言。缘无边法性故。般若波罗蜜无边。复次憍尸迦。缘无边如故。般若波罗蜜无边。释提桓因言。云何缘无边如故。般若波罗蜜无边。须菩提言。如无边故缘亦无边。缘无边故如亦无边。以是因缘故。诸菩萨摩诃萨般若波罗蜜无边。复次憍尸迦。众生无边故。般若波罗蜜无边。释提桓因问须菩提。云何众生无边故。般若波罗蜜无边。须菩提言。于汝意云何。何等法名众生。释提桓因言。无有法名众生。假名故为众生。是名字本。无有法亦无所趣。强为作名。憍尸迦。于汝意云何。是般若波罗蜜中。说众生有实不。释提桓因言。无也。憍尸迦。若般若波罗蜜中实不说。众生无边亦不可得。憍尸迦。于汝意云何。佛恒河沙劫寿。说众生众生名字。颇有众生法。有生有灭不。释提桓因言不也。何以故。众生从本已来常清净故。以是因缘故。憍尸迦众生无边故。当知般若波罗蜜亦无边

【论】问曰。释提桓因。是须陀洹人。云何能问深般若波罗蜜。答曰。如须菩提是具足阿罗汉。以利益菩萨怜愍众生故。问菩萨所行事。释提桓因虽是声闻人。是诸天主有利智慧。怜愍众生故。问般若波罗蜜亦如是。复次有人言。三千大千世界中。有百亿释提桓因。中阿含中说。释提桓因得须陀洹者。异今释提桓因。今释提桓因。是大菩萨怜愍众生故。三种赞般若波罗蜜。所谓摩诃波罗蜜。无量波罗蜜。无边波罗蜜。是般若波罗蜜。是般若波罗蜜中。学成诸圣道故。须菩提然释提桓因赞。而广解其赞言。以五众大故。般若波罗蜜大。五众大者。所谓三际不可得故。亦以无量无边故言大。破是无量无边五众。将一切众生入无余涅槃中故。言般若波罗蜜大。乃至一切种智亦如是。无量者亦尔。但以虚空譬喻为异。有法虽大不必无量。是故不得以空为喻。如须弥山于诸山中虽大而有量。所谓八万四千由旬。无边者。以五众广大无量故言无边。亦以五众有边则有始。有始则有终。即是无因无缘。堕断灭等种种过故。复次五众。三世中不可得故言无边。缘无边者。所谓一切法四缘。因缘生一切有为法次第缘。过去现在心心数法缘缘增上缘。一切法是四种缘。一切处一切时皆有故。说缘无边。缘无边故般若波罗蜜无边。复次缘无边者。四缘法虚诳无实毕竟空故无边。复次缘如法性实际无边故。般若波罗蜜无边。如法性实际。是自然无为相故无量无边。五众无边是观力故。强作无边。复次众生无边者。以众生多故。无量阿僧祇三世十方众生。无人能知数故言无边。复次是中说众生空故言无边。但强为作名。亦无所趣者。以众生无有定法可趣向故。如火定有所趣。而众生名无实众生可趣。于汝意云何。般若波罗蜜中。颇说实有众生不。不也大德。若众生实无。云何有边。譬如诸佛。是一切实语人中第一。于无量恒河沙劫寿。说众生名字。是众生法不以说故有生有灭。何况余人颠倒虚诳少时说生我心故当有众生。是众生不以入般若波罗蜜中故言无。从本已来常清净无所有。有无等戏论灭故。是以说众生无边故。般若波罗蜜无边。问曰。无边中何以故广说。而大及无量何以略说。答曰。以众生因缘故。一切凡夫起诸烦恼。于五众中作诸邪行难破故。是以广说。若破众生相。余一切易破

大智度论卷第五十五大智度论释顾视品第三十(卷五十六)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】尔时诸天王及诸天。诸梵王及诸梵天。伊赊那天及神仙并诸天女。同时三反称叹。快哉快哉。慧命须菩提所说法。皆是佛出世间因缘。恩力演布是教。若有菩萨摩诃萨。行是般若波罗蜜不远离者。我辈视是人如佛。何以故。是般若波罗蜜中。虽无法可得。所谓色受想行识。乃至一切种智。而有三乘之教。声闻辟支佛佛乘。尔时佛告诸天子。如是如是。诸天子。如汝所言。是般若波罗蜜中。虽无法可得。而有三乘之教。所谓声闻辟支佛佛乘。诸天子。若有菩萨摩诃萨。行是般若波罗蜜不远离者。视是人当如佛。以无所得故。何以故。是般若波罗蜜中。广说三乘之教。所谓声闻辟支佛佛乘。檀波罗蜜中佛不可得。离檀波罗蜜佛亦不可得。乃至般若波罗蜜中佛不可得。离般若波罗蜜佛亦不可得。内空乃至无法有法空。四念处乃至十八不共法。一切种智亦如是。佛语诸天子。菩萨摩诃萨若能学是一切法。所谓檀波罗蜜。乃至一切种智。以是事故。当视是菩萨摩诃萨如佛。诸天子。我昔于然灯佛时。华严城内四衢道头见佛闻法。即得不离檀波罗蜜行。不离尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜行。不离内空乃至无法有法空四念处乃至八圣道分。不离四禅四无量心四无色定一切三昧门一切陀怜尼门。不离四无所畏佛十力四无碍智十八不共法大慈大悲及余无量诸佛法行。亦无所得故。是时然灯佛记我。当来世过一阿僧祇劫。当作佛号释迦牟尼多陀阿伽度阿罗诃三藐三佛陀鞞侈遮罗那修伽度路迦惫无上士调御丈夫天人师佛世尊。尔时诸天子白佛言。世尊。希有。是般若波罗蜜能令诸菩萨摩诃萨得萨婆若。于色不取不舍故。于受想行识不取不舍故。乃至一切种智不取不舍故

【论】释曰。人以欢喜之至。则三反称叹。是故诸天闻大德须菩提说般若波罗蜜。欢喜言快哉快哉。天王者。四天处四天王三十三天王释提桓因。乃至诸梵天王。梵天已上更无有王。诸天是欲界天。诸梵是色界天。伊赊那是大自在天王。并其眷属。神仙者有二种。或天或人。天女者是天帝释夫人。舍脂等诸天女。所以叹须菩提说深般若波罗蜜者。知其承佛神力故。若能行是般若波罗蜜。我等当视是人如佛。所以者何。尊重法故。法者所谓深般若波罗蜜。深法者一切法。虽毕竟空。而有三乘分别。所以者何。诸法若毕竟空。更不应修集三乘功德则堕断灭中。若修三乘功德。则是分别差降。不应是毕竟空。是般若波罗蜜虽毕竟空。而不堕断灭。虽分别有三乘。亦不生着心。于二事中不取定相。是事甚深微妙故。诸天大欢喜叹言快哉。佛然其赞。更说甚深因缘。从六波罗蜜。乃至一切种智中佛不可得。离此佛亦不可得。诸法和合因缘故有佛。无有自性。若菩萨能如是行者。当知是菩萨即是佛。即是佛者。是世界中语如太子。虽未正位必当为王。此中佛自引本事以为证。此菩萨已得无生忍入菩萨位。见十方诸佛。诸天闻佛广明已所叹义。解心转深重复赞叹。以见一切法过罪故不取。有利益故不舍。又以一切法毕竟空不生不灭故。不取不舍

【经】尔时佛观四众和合。比丘比丘尼优婆塞优婆夷及诸菩萨摩诃萨并四天王天乃至阿迦尼吒诸天皆会坐。普观已佛告释提桓因。憍尸迦。若菩萨摩诃萨。若比丘若比丘尼。若优婆塞若优婆夷。若诸天子若诸天女。是般若波罗蜜。若听受持亲近读诵为他说。正忆念不离萨婆若心。诸天子。是人魔若魔天不能得其便。何以故。是善男子善女人。谛了知色空。空不能得空便。无相不能得无相便。无作不能得无作便。谛了知受想行识空。空不能得空便。乃至无作不能得无作便。乃至谛了知一切种智空。空不能得空便。乃至无作不能得无作便。何以故。是诸法自性不可得。无事可得便。谁受恼者。复次憍尸迦。是善男子善女人。若人非人不能得其便。何以故。是善男子善女人。一切众生中。善修慈心悲喜舍心。以无所得故。憍尸迦。是善男子善女人终不横死。何以故。是善男子善女人。行檀波罗蜜。于一切众生等心供给故。复次憍尸迦。三千大千世界四天王天三十三天。夜摩天兜率陀天化槃天他化自在天。梵天光音天遍净天广果天。是诸天中有发阿耨多罗三藐三菩提心者。未闻是般若波罗蜜。未受持亲近。是诸天子今应闻受持亲近读诵正忆念不离萨婆若心。复次憍尸迦。诸善男子善女人。闻是般若波罗蜜。受持亲近读诵正忆念不离萨婆若心。是诸善男子善女人。若在空舍若在旷野。若人住处终不怖畏。何以故。是诸善男子善女人。明于内空以无所得故。明于外空乃至无法有法空。以无所得故

【论】问曰。此中佛观四部众已。何以告释提桓因。答曰。余品中多说般若波罗蜜体。今欲赞般若功德故。命释提桓因。譬如先以好宝示人然后赞宝所能。复次普观者。欲令会中众生各知佛顾念则不自轻。不自轻。故堪任听法。是以普观。譬如王顾眄群下。群下则欣然自庆。说功德故。应以白衣证。白衣中释提桓因为大。说般若者以出家人为证。出家人中是舍利弗须菩提等为大。问曰。先言释是字提婆因是天主。今佛何以不言释。乃命言憍尸迦。答曰。昔摩伽陀国中有婆罗门名摩伽。姓憍尸迦。有福德大智慧。知友三十三人。共修福德命终。皆生须弥山顶第二天上。摩伽婆罗门为天主。三十二人为辅臣。以此三十三人故。名为三十三天。唤其本姓故。言憍尸迦。或言天主或言千眼等。大人唤之故称其姓。此中所说般若波罗蜜者。是十方诸佛所说。语言名字书写经卷。宣传显示实相智慧。何以故。般若波罗蜜无诸观语言相。而因语言经卷。能得此般若波罗蜜。是故以名字经卷名为般若波罗蜜。此中略说佛意。若能闻受持般若。等当得种种功德。后当广说。欲度众生为得佛道故。供养受学般若波罗蜜。是人魔若魔天不能得便。问曰。何者是魔。何故恼菩萨。云何得便。答曰。魔名自在天主。虽以福德因缘生彼。而怀诸邪见。以欲界众生是己人民。虽复死生展转不离我界。若复上生色无色界还来属我。若有得外道五通。亦未出我界。皆不以为忧。若佛及菩萨出世者。化度我民拔生死根。入无余涅槃永不复还。空我境界。是故起恨仇嫉。又见欲界人皆往趣佛不来归己。失供养故心生嫉妒。是以以佛菩萨名为怨家。是菩萨入法位。得法性生身。魔虽起恶不能坏败。若未得阿鞞跋致者。魔则种种破坏。若菩萨一心不惜身命。有方便求佛道者。十方诸佛及诸大菩萨皆共护持。以是因缘故能成佛道。若为菩萨而有懈怠贪着世乐。不能专心勤求佛道。是则自欺亦欺十方诸佛及诸菩萨。所以者何。自言我为一切众生故求佛道。而行杂行坏菩萨法。以是罪故。诸佛菩萨所不守护。魔得其便。所以者何。一切圣人已入正位。一心行道深乐涅槃。魔入邪位爱着邪道。邪正相违。是故憎嫉正行。狂愚自高唤佛沙门瞿昙。佛称其实名为弊魔。以相违故名为怨家。如经说。魔有四种。一者烦恼魔。二者五众魔。三者死魔。四者自在天子魔。此中以般若力故。四魔不能得便。得诸法实相。烦恼断则坏烦恼魔。天魔亦不能得其便。入无余涅槃故。则坏五众魔及死魔。云何为得便。魔及魔民来恐怖菩萨。如经中说。魔作龙身种种异形可畏之象。夜来恐怖行者。或现上妙五欲坏乱菩萨。或转世间人心。令作大供养行者贪着供养故。则失道德。或转人心令轻恼菩萨。或骂或打或伤或害。行者遭苦或生嗔恚忧愁。如是等魔随前人意所趣向因而坏之。是名得便。如魔品中广说。问曰。魔力甚大。肉身菩萨道力尚少。云何不得便。答曰。如上说为诸佛菩萨所护故。此中佛自说因缘。是人善修诸法空。亦不着空。不着空者。云何当得便。譬如无疮则不受毒。无相无作亦如是。复次一切法实观皆是空无相无作相。皆是空无相无作相故。则无得便。亦无受便者。是故空不应得空便。无相不应得无相便。无作不应得无作便。以一相故。如火不能灭火得水则灭。以异相故。问曰。菩萨住三解脱门。则是受便处。与一切法相违故。空与有相违。无相与有相相违。无作与有作相违。答曰。此经中佛自说三解脱门无有自性。又先论议中。说于空无相无作中亦不着。是故虽住三解脱门。魔及魔民不得其便。问曰。余处皆言菩萨摩诃萨。今何以言善男子善女人。答曰。先说实相智慧。难受以能受故则是菩萨摩诃萨。今说供养受持读诵等。杂说故得称善男子善女人。复次经中说。女人有五碍。不得作释提桓因梵王魔王转轮圣王佛。闻是五碍不得作佛。女人心退不能发意。或有说法者。不为女人说佛道。是故佛此间说善男子善女人。女人可得作佛。非不转女身也。五碍者说一身事。善男子善女人义先已广说。人不得便者。人名若贼若官若怨等。欲恼乱菩萨求索其便。问曰。先说不得便因缘。何以但说空。今说人不得便。但说四无量心。答曰。有人言。先说魔若魔民。怨大故法亦大。故说空。怨小故法亦小。故说四无量心。有人言。四无量心是菩萨常行。为集诸功德故。后以般若波罗蜜空相令除邪见。不着众生亦不着法。是二法前后无在。复次上魔作恐怖事甚多。多不现本形。或现雷震或作风雨或作病痛等。是故说诸法空。令人来恶口骂詈刀杖打斫故。用四无量心。不横死者。所谓无罪而死。或寿命未尽错投药故。或不顺药法。或无看病人。或饥渴寒热等夭命。是名横死。菩萨从初发意来。于一切众生中。常行檀波罗蜜。应病与药随病所须。拯济孤穷随其所乞皆给与之。于一切众生中。悉皆平等好心供养亦行是般若波罗蜜。以是功德故不横死。是中略说三功德已。三千大千世界中。诸天发心未闻般若波罗蜜者。先说善男子善女人应闻受持乃至正忆念。今说因缘。诸天有大功德犹尚供养。何况于人。虽一切人天应听般若。能发无上道心者。最应深心听。所以者何。般若是佛道之本故。问曰。此天发心。何以不闻般若。答曰。有人言。此天前世人中发意今生天上。五欲覆心故不闻。复次诸天虽发无上道心。五情利五欲。妙染着深故。视东忘西。不能求般若。色界诸天虽先闻法发心。以味着禅定深故。不能求般若。是故说不闻者应闻受持。复次先说魔及魔民不能得其便。是内因缘。所谓空三昧。及四无量心。今更说不得便。是外因缘。所谓佛告诸天。汝等供养受持般若。是善男子善女人。亦受持供养是般若同事故。若魔来破汝应守护。复次受持般若者。若在空舍住。若在旷野。若在人间住。处空舍中多诸鬼魅及以贼寇。众恶易来故初说。除人住处及以空舍。余残山泽树林等皆是旷野。少人行故。多诸虎狼师子恶贼鬼魅。人所住处不净故。魔及鬼神鲜来诸难少故。是以后说。行者于三处住无所畏惧。以二因缘故。一者善修十八空。二者般若波罗蜜威德故

【经】尔时三千大千世界中。诸四天王天三十三天夜摩天兜率陀天化乐天他化自在天。乃至首陀婆诸天白佛言。世尊。是善男子善女人。能受持般若波罗蜜。亲近读诵正忆念。亦不离萨婆若心者。我等常当守护。何以故。世尊。以菩萨摩诃萨因缘故。断三恶道。断天人贫。断诸灾患疾病饥饿。以菩萨因缘故。便有十善道出世间。四禅四无量心四无色定。檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。内空乃至无法有法空。四念处乃至一切种智以菩萨因缘故。世间便有生刹利大姓婆罗门大姓居士大家诸王。及转轮圣王四天王天乃至阿迦尼吒天。以菩萨因缘故。有须陀洹须陀洹果乃至阿罗汉阿罗汉果辟支佛辟支佛道。以菩萨因缘故。有成就众生净佛世界。便有诸佛出现于世。便有转法轮。知有佛宝法宝比丘僧宝。世尊。以是因缘故。一切世间诸天及人阿修罗。应守护是菩萨摩诃萨。佛语释提桓因。如是如是。憍尸迦。以菩萨摩诃萨因缘故。断三恶道。乃至三宝出现于世。以是故。诸天及人阿修罗常应守护供养恭敬尊重赞叹是菩萨摩诃萨。憍尸迦。供养恭敬尊重赞叹是菩萨摩诃萨。即是供养我。以是故。是诸菩萨摩诃萨。诸天及人阿修罗常应守护供养恭敬尊重赞叹。憍尸迦。若三千大千世界满中声闻辟支佛。譬如竹[竺-二+韋]稻麻丛林。若有善男子善女人。供养恭敬尊重赞叹不如供养恭敬尊重赞叹初发心菩萨摩诃萨。不离六波罗蜜所得福德。何以故。不以声闻辟支佛因缘故。有菩萨摩诃萨及诸佛出现于世。以有菩萨摩诃萨因缘故。有声闻辟支佛诸佛出现于世。以是故。憍尸迦。是诸菩萨摩诃萨。一切世间诸天及人阿修罗。常应守护供养恭敬尊重赞叹

【论】释曰。尔时诸天白佛。我等当守护是菩萨。与我等同事故。亦以求佛道者。能自舍身乐欲使一切众生得乐故。因菩萨断三恶道者。菩萨虽未离欲。能遮众生十不善故。断三恶道及天人贫诸灾患等。行十善故开三善道门。或有菩萨。见五欲过罪能离欲得四禅。以本愿故起四无量心。欲离种种因缘身苦故。起四无色定。为佛道故修六波罗蜜乃至一切种智。是法亦自行亦教人。以是福德道法。于众生中展转相教常在世间。今当说是诸善法果报。生刹利大姓。乃至三宝出现于世。如先义中说。今是菩萨结业生身在因缘中无有力势。而能说是善法。令众生修行。我等云何当不守护。譬如太子虽小群臣百官无不奉承。佛可诸天述而成之。若供养菩萨。即是供养佛者。般若是三世佛母。若为般若故供养菩萨。则为供养佛。不如供养恭敬初发意菩萨者。问曰。二乘已证实际。是一切众生福田。何以故。不如初发意菩萨。答曰。以三事故不如。一者用萨婆若心行般若。二者常不离六波罗蜜等诸功德。三者由是菩萨断三恶道出生三乘。依二乘人不能断三恶道出生三乘

    大智度论释灭诤乱品第三十一

【经】尔时释提桓因白佛言。世尊。甚奇希有。诸菩萨摩诃萨。是般若波罗蜜。若闻受持亲近读诵为他人说正忆念时。得如是今世功德。亦成就众生净佛世界。从一佛界至一佛界供养诸佛所欲供养之具随意即得。从诸佛闻法。至得阿耨多罗三藐三菩提终不中忘。亦得家成就母成就生成就眷属成就相成就光明成就眼成就耳成就三昧成就陀罗尼成就。是菩萨以方便力变身如佛。从一界至一界。到无佛处。赞檀波罗蜜乃至般若波罗蜜。赞四禅四无量心四无色定。赞四念处乃至十八不共法。以方便力说法。以三乘法度脱众生。所谓声闻辟支佛佛乘。世尊。快哉希有。受是般若波罗蜜。为已总摄五波罗蜜乃至十八不共法。亦摄须陀洹果乃至阿罗汉果辟支佛道佛道一切智一切种智。佛告释提桓因。如是如是。憍尸迦。受是般若波罗蜜。为已总摄五波罗蜜乃至一切种智。复次憍尸迦。是般若波罗蜜。受持亲近读诵为他说正忆念。是善男子善女人所得今世功德。汝一心谛听。释提桓因言。唯世尊受教。佛告释提桓因。憍尸迦。若有外道诸梵志若魔若魔民若增上慢人。欲乖错破坏菩萨般若波罗蜜心。是诸人适生此心。即时灭去终不从愿。何以故。憍尸迦。菩萨摩诃萨长夜行檀波罗蜜。行尸罗羼提毗梨耶禅般若波罗蜜。以众生长夜贪诤故。菩萨悉舍内外物。安立众生于檀波罗蜜中。以众生长夜破戒故。菩萨悉舍内外法。安立众生于戒。以众生长夜斗诤故。菩萨悉舍内外法。安立众生于忍辱。以众生长夜懈怠故。菩萨悉舍内外法。安立众生于精进。以众生长夜乱心故。菩萨悉舍内外法。安立众生于禅。以众生长夜愚痴故。菩萨悉舍内外法。安立众生于般若波罗蜜。以众生长夜为爱结故。流转生死。是菩萨摩诃萨以方便力故。断众生爱结。安立于四禅四无量心四无色定四念处乃至八圣道分空无相无作三昧。安立众生于须陀洹果乃至阿罗汉果辟支佛道佛道。憍尸迦。是为菩萨摩诃萨行般若波罗蜜得现世功德。后世功德。得阿耨多罗三藐三菩提。菩萨转法轮所愿满足。入无余涅槃。憍尸迦。是为菩萨摩诃萨后世功德。复次憍尸迦。善男子善女人。是般若波罗蜜。若闻受持亲近读诵为他说正忆念。其所住处魔若魔民若外道梵志增上慢人。欲轻毁难问破坏般若波罗蜜。终不能成其人恶心转灭功德转增。闻是般若波罗蜜故。渐以三乘道得尽众苦。譬如憍尸迦有药名摩只。有蛇饥行索食。见虫欲啖。虫趣药所。药气力故。蛇不能前即便还去。何以故。是药力能胜毒故。憍尸迦。摩只药有如是力。是善男子善女人。是般若波罗蜜若受持亲近读诵为他说正忆念。若有种种斗诤起。欲来破坏者。以般若波罗蜜威力故。随所起处即疾消灭。其人即生善心增益功德。何以故。是般若波罗蜜能灭诸法诤乱。何等诸法。所谓淫怒痴无明乃至大苦聚诸盖结使缠。我见人见众生见断见常见垢见净见有见无见。如是一切诸见悭贪犯戒嗔恚懈怠乱意无智常想乐想净想我想。如是等爱行着色。着受想行识。着檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。着内空外空内外空乃至无法有法空。着四念处乃至十八不共法。着一切智一切种智。着涅槃。是一切法诤乱尽能灭。不令增长

【论】释曰。闻者。若从佛若菩萨若余说法人边。闻般若波罗蜜。是十方三世诸佛法宝藏闻已。用信力故受。念力故持。得气味故常来承奉。咨受故亲近。亲近已或看文或口受故言读。为常得不忘故诵。宣传未闻故言为他说。圣人经书直说难了故解义。观诸佛法不可思议。有大悲于众生故说法。不以邪见戏论求佛法。如佛意旨不着故说法亦不着。除四颠倒等诸邪忆念故。住四念处正忆念中。但为得道故不为戏论。名为正忆念。正忆念是一切善法之根本。修习行者初入。名为正忆念。常行得禅定故名为修。今世功德者如先说义。今释提桓因。更说今世功德。所谓教化众生乃至令众生得三乘。先说般若波罗蜜摄三乘令解其义。是故言般若波罗蜜中摄五波罗蜜乃至一切种智。佛可其所说者。欲令人信故。所得今世功德汝一心谛听者。上略说今世功德。佛今欲广说其事。难信故。言一心谛听。复次因小果大难信故。言一心谛听。帝释虽信受。人不知故言唯世尊。是般若波罗蜜。虽不可破坏。而宣示实相。语言可破。语言破故。信心未定者亦可破。是故说若外道梵志等来欲破坏般若波罗蜜。梵志者。是一切出家外道。若有承用其法者。亦名梵志。梵志爱着其法。闻实相空法不信故欲破坏魔若魔民如先说。增上慢人者。是佛弟子得禅定未得圣道自谓已得是人闻无须陀洹乃至无阿罗汉无道无涅槃。便发增上慢生忿恼心。欲破是实相空法。是般若波罗蜜神力故。令彼恶心即时灭去终不成愿。如人以手障鉾但自伤其手鉾无所损。何以故。菩萨于内外法不着。众生从无始世界来。常着内外法故起斗诤。菩萨舍内外着处。自安立六波罗蜜。教化众生令舍内外斗法。安立众生于六波罗蜜。是无量世修集福德力。斗诤根尽故。虽有斗乱事来。不能得便。譬如毒蛇欲食虾蟆常随逐之。虾蟆到摩只药所蛇闻药气毒即消歇。是坏法恶人亦复如是。欲坏行般若波罗蜜人常随逐之。以般若力势故。嗔恚邪见之毒即时消灭。有降伏得道者。有作弟子者。有复道还去者。是般若波罗蜜。能破无明等诸结使。灭诸断常邪见等。能灭着五众乃至涅槃。何况嗔恚嫉妒斗乱之事而不能灭

【经】复次憍尸迦。三千大千世界中。诸四天王天诸释提桓因诸梵天王。乃至阿迦尼吒天。常守护是善男子善女人能受持供养读诵为他说正忆念般若波罗蜜者。十方现在诸佛。亦共拥护是善男子善女人能闻受持供养读诵为他说正忆念般若波罗蜜者。是善男子善女人。不善法灭善法转增。所谓檀波罗蜜转增。以无所得故。乃至般若波罗蜜转增。以无所得故。内空转增乃至无法有法空转增。以无所得故。四念处乃至十八不共法转增。以无所得故。诸三昧门。诸陀罗尼门。一切智一切种智转增。以无所得故。是善男子善女人所说人皆信受。亲友坚固不说无益之语。不为嗔恚所覆。不为憍慢悭贪嫉妒所覆。是人自不杀生。教人不杀生。赞不杀生法。亦欢喜赞叹不杀生者。自远离不与取。亦教人远离不与取。赞远离不与取法。亦欢喜赞叹远离不与取者。自不邪淫教人不邪淫。赞不邪淫法。亦欢喜赞叹不邪淫者。自不妄语教人不妄语。赞不妄语法。亦欢喜赞叹不妄语者。两舌恶口无利益语亦如是。自不贪教人不贪。赞不贪法。亦欢喜赞叹不贪者。不嗔恼不邪见亦如是。自行檀波罗蜜。教人行檀波罗蜜。赞行檀波罗蜜法。亦欢喜赞叹行檀波罗蜜者。自行尸罗波罗蜜。教人行尸罗波罗蜜。赞尸罗波罗蜜。亦欢喜赞叹行尸罗波罗蜜者。自行羼提波罗蜜。教人行羼提波罗蜜。赞羼提波罗蜜。亦欢喜赞叹行羼提波罗蜜者。自行毗梨耶波罗蜜。教人行毗梨耶波罗蜜。赞毗梨耶波罗蜜。亦欢喜赞叹行毗梨耶波罗蜜者。自行禅波罗蜜。教人行禅波罗蜜。赞禅波罗蜜。亦欢喜赞叹行禅波罗蜜者。自行般若波罗蜜。教人行般若波罗蜜。赞般若波罗蜜。亦欢喜赞叹行般若波罗蜜者。自修内空教人修内空。赞内空亦欢喜赞叹修内空者。乃至自修无法有法空。教人修无法有法空。赞无法有法空。亦欢喜赞叹修无法有法空者。自入一切三昧中。教人入一切三昧中。赞一切三昧。亦欢喜赞叹入一切三昧者。自得陀罗尼。教人得陀罗尼赞陀罗尼。亦欢喜赞叹得陀罗尼者。自入初禅。教人入初禅。赞初禅。亦欢喜赞叹入初禅者。二禅三禅四禅亦如是。自入慈心中。教人入慈心中。赞慈心亦欢喜赞叹入慈心者。悲喜舍心亦如是。自入无边空处。教人入无边空处。赞无边空处。亦欢喜赞叹入无边空处者。无边识处无所有处非有想非无想处亦如是。自修四念处。教人修四念处。赞四念处亦欢喜赞叹修四念处者。四正勤四如意足五根五力七觉分八圣道分亦如是。自修空无相无作三昧。教人修空无相无作三昧。赞空无相无作三昧。亦欢喜赞叹修空无相无作三昧者。自入八解脱中。教人入八解脱。赞八解脱。亦欢喜赞叹入八解脱者。自入九次第定中。教人入九次第定。赞九次第定。亦欢喜赞叹入九次第定者。自修佛十力四无所畏四无碍智大慈大悲十八不共法亦如是。自行不谬错法。自行常舍法。教人行不谬错法常舍法。赞不谬错法常舍法。亦欢喜赞叹行不谬错法常舍法者。自得一切种智。教人得一切种智。赞一切种智。亦欢喜赞叹得一切种智者。是菩萨摩诃萨。行六波罗蜜时。所有布施与众生共已回向阿耨多罗三藐三菩提。以无所得故。所有持戒忍辱精进禅定智慧与众生共已回向阿耨多罗三藐三菩提。是亦无所得故。是善男子善女人。如是行六波罗蜜时作是念。我若不布施。当生贫穷家。不能成就众生净佛世界。亦不能得一切种智。我若不持戒。当生三恶道中。尚不得人身。何况能成就众生净佛世界。得一切种智。我若不修忍辱。则当诸根毁坏色不具足。不能得菩萨具足色身。众生见者必至阿耨多罗三藐三菩提。亦不能得以具足色身成就众生净佛世界得一切种智。我若懈怠不能得菩萨道。亦不能得成就众生净佛世界得一切种智。我若乱心不能得生诸禅定。不能以此禅定成就众生净佛世界得一切种智。我若无智不能得方便智以方便智过声闻辟支佛地成就众生净佛世界得一切种智。是菩萨复作是思惟。我不应随悭贪故不具足檀波罗蜜。不应随犯戒故不具足尸罗波罗蜜。不应随嗔恚故不具足羼提波罗蜜。不应随懈怠故不具足毗梨耶波罗蜜。不应随乱意故不具足禅波罗蜜。不应随痴心故不具足般若波罗蜜。若不具足檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。我终不能出到一切种智。如是善男子善女人。是般若波罗蜜。受持亲近读诵为他说正忆念。亦不离萨婆若心。得是今世后世功德。释提桓因白佛言世尊。希有。是菩萨摩诃萨。般若波罗蜜。为回向萨婆若心故。亦为不高心故。佛告释提桓因。憍尸迦。云何菩萨摩诃萨般若波罗蜜。为回向萨婆若心故。亦为不高心故。释提桓因白佛言。世尊。菩萨摩诃萨若行世间檀波罗蜜。布施诸佛辟支佛声闻及诸贫穷乞丐行路人。是菩萨无方便故生高心。若行世间尸罗波罗蜜。言我行尸罗波罗蜜我能具足尸罗波罗蜜。无方便故生高心。言我行羼提波罗蜜毗梨耶波罗蜜禅波罗蜜。我行般若波罗蜜。我修般若波罗蜜。以是世间般若波罗蜜。无方便故生高心。世尊。菩萨修世间四念处时。自念言。我修四念处。我具足四念处。无方便力故生高心。我修四正勤四如意足五根五力七觉分八圣道分。自念言。我修空无相无作三昧。我修一切三昧门。当得一切陀罗尼门。我修佛十力四无所畏十八不共法。我当成就众生。我当净佛世界。我当得一切种智。着吾我无方便力故生高心。世尊。如是菩萨摩诃萨行世间善法。着吾我故生高心。世尊。若菩萨摩诃萨行出世间檀波罗蜜。不得施者不得受者不得施物。如是菩萨摩诃萨行出世间檀波罗蜜。为回向萨婆若故。亦不生高心。行尸罗波罗蜜。尸罗不可得。行羼提波罗蜜。羼提不可得。行毗梨耶波罗蜜。毗梨耶不可得。行禅波罗蜜。禅不可得。行般若波罗蜜。般若不可得。修四念处。四念处不可得。乃至修十八不共法。十八不共法不可得。修大慈大悲。大慈大悲不可得。乃至修一切种智。一切种智不可得。世尊。如是菩萨摩诃萨般若波罗蜜。为回向萨婆若故。亦为不生高心故

【论】问曰。先已说魔若魔民等。三种人欲破坏般若。今何以故重说。答曰。佛先说三种人来求便恐怖欲令愁恼。中来者不为恼人但欲破毁般若波罗蜜。不随其愿不能得破。后来三种人。虽欲生心破坏即时灭去。所语人皆信受者。是菩萨常令不善法断灭。善法转增。所谓檀波罗蜜。乃至一切种智。是人修集福德智慧故。成大威德。设使妄语人皆信受。何况实语亲友坚固者。是人于一切众生中。深有慈悲心。何况亲友于我有益。是菩萨爱敬佛道。知身口无常故。不说无益之言。以善法增长故。嗔恚等烦恼不能覆心。行者作是念。结使虽起智慧思惟不令覆心。结使若起今世不善后世不善妨于佛道。设使心起结使不起口业。设口业起不成身业。设身业起不至大恶如凡夫人也。是菩萨虽卑陋鄙贱。以行胜法故。得在胜人数中。是今世功德。是人深乐善法故。能于善法四种正行求。二乘人不能具足四行。以不深乐善法故。所谓自不杀生慈悲一切。深自利故亦教他慈。是一切贤圣法故。常赞叹是菩萨。常欲令人得乐故。见有不杀者欢喜爱乐。乃至一切种智亦如是。上四种行广说。今略说一切功德。总摄入六波罗蜜中。所得果报与众生共之。是菩萨未入正位。诸烦恼未尽故。或时起悭等诸烦恼。尔时应作是思惟谏喻其心。若不布施我自失四事功德。所谓后身生贫穷。贫穷故自不能利益何能利他。若不利他则不能成就众生。若不能成就众生。亦不能净佛世界。何以故。以众生净故。世界清净。若不具足是等众事。云何当得一切种智。以要言之。无方便者虽行六波罗蜜。内不能离我心。外取诸法相。所谓我是施者彼是受者是布施物。是因缘故。不能到佛道。与此相违是有方便。问曰。若世间波罗蜜等非是正道。是般若波罗蜜中。佛何以说。答曰。此是行者初门。与正道相似故。先行相似法。后得真道

大智度论卷第五十六大智度论释宝塔校量品第三十二(卷五十七)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】尔时佛告释提桓因。若有善男子善女人。闻是深般若波罗蜜。受持亲近读诵正忆念。不离萨婆若心。两阵战时是善男子善女人。诵般若波罗蜜故。入军阵中终不失命刀箭不伤。何以故。是善男子善女人。长夜修行六波罗蜜。自除淫欲刀箭。亦除他人淫欲刀箭。自除嗔恚刀箭。亦除他人嗔恚刀箭。自除愚痴刀箭。亦除他人愚痴刀箭。自除邪见刀箭。亦除他人邪见刀箭。自除缠垢刀箭。亦除他人缠垢刀箭。自除诸结使刀箭。亦除他人结使刀箭。憍尸迦。以是因缘。是善男子善女人。不为刀箭所伤。复次憍尸迦。是善男子善女人。闻是深般若波罗蜜。受持亲近读诵正忆念。不离萨婆若心。若以毒药薰若以蛊道若以火坑若以深水若欲刀杀若与毒。如是众恶皆不能伤。何以故。是般若波罗蜜。是大明咒是无上咒。若善男子善女人。于是明咒中学。自不恼身。亦不恼他。亦不两恼。何以故。是善男子善女人。不得我不得众生不得寿命。乃至知者见者皆不可得。不得色受想行识。乃至一切种智。亦不可得。以不可得故。不自恼身亦不恼他亦不两恼。学是大明咒故。得阿耨多罗三藐三菩提。观一切众生心随意说法。何以故。过去诸佛学是大明咒。得阿耨多罗三藐三菩提。当来诸佛学是大明咒。当得阿耨多罗三藐三菩提。今现在诸佛学是大明咒。得阿耨多罗三藐三菩提。复次憍尸迦。般若波罗蜜。若有但书写经卷于舍供养。不受不读不诵不说不正忆念。是处若人若非人不能得其便何以故。是般若波罗蜜为三千大千世界中。四天王诸天乃至阿迦尼吒诸天子。及十方无量阿僧祇世界中。诸四天王天乃至阿迦尼吒诸天所守护故。是般若波罗蜜所止处。诸天皆来供养恭敬尊重赞叹礼拜已去。是善男子善女人是般若波罗蜜。但书写经卷于舍供养。不受不读不诵不说不正忆念。今世得如是功德。譬如若人若畜生来入菩提树下诸边内外。设人非人来不能得其便。何以故。是处过去诸佛。于中得阿耨多罗三藐三菩提。未来诸佛现在诸佛。亦于中得阿耨多罗三藐三菩提。得佛已施一切众生无恐无畏。令无量阿僧祇众生受天上人中福乐。亦令无量阿僧祇众生得须陀洹果。乃至得阿耨多罗三藐三菩提。以般若波罗蜜力故。是处得恭敬礼拜华香璎珞捣香泽香幢盖伎乐供养

【论】问曰。现有受持读诵。入于军阵为刀兵所伤。或至失命。又佛说业因缘非空非海中。无有得免者。是中佛何以故。言读诵般若者入军阵中兵刃不伤亦不失命。答曰。有二种业因缘。一者必应受报。二者不必受报。为必应受报故。法句中如是说。此中为不必受报故。说读诵般若兵刃不伤。譬如大逆重罪应死之人。虽有强力财宝不可得免。有人罪轻虽入死科理在可救用力势财物便得济命。不救则死。善男子亦如是。若无必受报罪。虽有死事来至。读诵般若波罗蜜则得济度。若不读诵则不免死。是故不得言般若波罗蜜无有力势。复次善男子善女人。若远离恶法调伏其心。烦恼折减。一心直信善法无有疑悔。从久远已来。修集福德智慧。于一切众生有慈悲心。教化众生除去恶心。如是善男子刀兵不伤命不中断。如佛自说因缘。长夜行六波罗蜜。除己身及他身三毒刀箭。五波罗蜜是福德。般若波罗蜜是智慧。以广集此二事故。不中失命。毒药水火等亦如是。复次如外道神仙咒术力故。入水不溺入火不热毒虫不螫。何况般若波罗蜜。是十方诸佛所因成就咒术。问曰。如上所说是事可信。今此中不能受持读诵念般若等。但书写供养。云何得是功德。答曰。是人所得功德。亦同于上。何以故。有人先已闻师说般若义。深入爱乐。然不识文字。违离师故不能读诵。而不惜财宝雇人书写。尽心种种供养。意与读诵者同故。亦得功德。人不能得便者。诸天守护。是事难信故。佛以菩提树为喻。佛以般若力故。于菩提树下成无上道。无上道气势故。其处犹有威德。众生入中众恶不得其便。何况般若波罗蜜是诸佛之母。善男子。尽心供养而无功德

【经】释提桓因白佛言。世尊。若善男子善女人书写般若波罗蜜。华香璎珞乃至伎乐供养。若有人佛般涅槃后。若供养舍利。若起塔供养恭敬尊重赞叹华香璎珞乃至伎乐供养。是二何者得福多。佛告释提桓因。我还问汝。随汝意答我。于汝意云何。如佛得一切种智及得是身。从何道学得是一切种智得是身。释提桓因白佛言。佛从般若波罗蜜中学。得一切种智及相好身。佛告释提桓因。如是如是。憍尸迦。佛从般若波罗蜜中学。得一切种智。憍尸迦。不以是身名为佛。得一切种智故名为佛。憍尸迦。是佛一切种智。从般若波罗蜜中生。以是故。憍尸迦是佛身一切种智所依处。佛因是身得一切种智。善男子当作是思惟。是身一切种智所依处。是故我涅槃后。舍利当得供养。复次憍尸迦。善男子善女人若闻是般若波罗蜜。书写受持亲近读诵正忆念。华香璎珞捣香泽香幢盖伎乐恭敬供养尊重赞叹。是善男子善女人。则为供养一切种智。以是故。憍尸迦。若有善男子善女人。书是般若波罗蜜。若受持亲近读诵说正忆念。供养恭敬尊重赞叹华香璎珞乃至伎乐。若复有善男子善女人。佛般涅槃后。供养舍利起塔。恭敬尊重赞叹华香乃至伎乐。若有善男子善女人。是般若波罗蜜书持供养恭敬尊重赞叹华香璎珞乃至伎乐。是人得福多。何以故。是般若波罗蜜中。生五波罗蜜。生内空乃至无法有法空。四念处乃至十八不共法一切三昧一切禅定一切陀罗尼。皆从般若波罗蜜中生。成就众生净佛世界。皆从般若波罗蜜中生。菩萨家成就。色成就。资生之物成就。眷属成就。大慈大悲成就。皆从般若波罗蜜中生。刹利大姓婆罗门大姓居士大家。皆从是般若波罗蜜中生。四天王天乃至阿迦尼吒天。须陀洹乃至阿罗汉辟支佛。诸菩萨摩诃萨诸佛。诸佛一切种智。皆从是般若波罗蜜中生。尔时释提桓因白佛言。世尊。阎浮提人不供养般若波罗蜜。不恭敬不尊重不赞叹。为不知供养多所利益耶。佛告释提桓因。憍尸迦。于汝意云何。阎浮提中几所人。信佛不坏信法信僧不坏。几所人于佛无疑。于法于僧无疑。几所人于佛决了。于法于僧决了。释提桓因白佛言。世尊阎浮提人于佛法僧不坏信少。于佛法僧无疑决了亦少。憍尸迦。于汝意云何。阎浮提几所人。得三十七品三解脱门八解脱九次第定四无碍智六神通。阎浮提几所人。断三结故得须陀洹道。几所人断三结。亦淫嗔痴薄故。得斯陀含道。几所人断五下分结得阿那含道。几所人断五上分结得阿罗汉。阎浮提几所人求辟支佛。几所人发阿耨多罗三藐三菩提心。释提桓因白佛言。世尊。阎浮提中少所人。得三十七品。乃至少所人发阿耨多罗三藐三菩提心。佛告释提桓因。如是如是。憍尸迦。少所人信佛不坏。信法不坏信僧不坏。少所人于佛无疑。于法无疑于僧无疑。少所人于佛决了于法决了于僧决了。憍尸迦亦少所人。得三十七品三解脱门八解脱九次第定四无碍智六神通。憍尸迦。亦少所人。断三结得须陀洹。断三结亦淫嗔痴薄。得斯陀含。断五下分结得阿那含。断五上分结得阿罗汉。少所人求辟支佛。于是中亦少所人发阿耨多罗三藐三菩提心。于发心中亦少所人行菩萨道。何以故。是众生前世不见佛不闻法不供养比丘僧。不布施不持戒不忍辱不精进不禅定无智慧。不闻内空外空乃至无法有法空。亦不闻不修四念处乃至十八不共法。亦不闻不修诸三昧门诸陀罗尼门。亦不闻不修一切智一切种智。憍尸迦。以是因缘故。当知少所众生。信佛不坏信法不坏信僧不坏。乃至少所众生求辟支佛道。于是中少所众生。发阿耨多罗三藐三菩提心。于发心中少所众生行菩萨道。于是中亦少所众生。得阿耨多罗三藐三菩提。憍尸迦。我以佛眼见东方无量阿僧祇众生。发心行阿耨多罗三藐三菩提心。行菩萨道。是众生远离般若波罗蜜方便力故。若一若二住阿鞞跋致地。多堕声闻辟支佛地。南西北方四维上下亦如是。以是故。憍尸迦。善男子善女人。发心求阿耨多罗三藐三菩提者。应闻般若波罗蜜。应受持亲近读诵说正忆念。受持亲近读诵说正忆念已。应书经卷恭敬供养尊重赞叹香华璎珞乃至伎乐。诸余善法入般若波罗蜜中者。亦应闻受持乃至正忆念。何等是诸余善法。所谓檀波罗蜜。尸罗波罗蜜。羼提波罗蜜。毗梨耶波罗蜜。禅波罗蜜。内空外空乃至无法有法空。诸三昧门诸陀罗尼门。四念处乃至十八不共法大慈大悲。如是等无量诸善法。皆入般若波罗蜜中。是亦应闻受持乃至正忆念。何以故。是善男子善女人当如是念。佛本为菩萨时。如是行如是学。所谓般若波罗蜜。禅波罗蜜。毗梨耶波罗蜜。羼提波罗蜜。尸罗波罗蜜。檀波罗蜜。内空乃至无法有法空。诸三昧门。诸陀罗尼门。四念处乃至十八不共法。大慈大悲。如是等无量佛法。我等亦应随学。何以故。般若波罗蜜是我等所尊。禅波罗蜜乃至无量诸余善法。亦是我等所尊。此是诸佛法印。诸辟支佛阿罗汉阿那含斯陀含须陀洹法印。诸佛学是般若波罗蜜乃至一切种智。得度彼岸。诸辟支佛阿罗汉阿那含斯陀含。须陀洹。亦学是般若波罗蜜乃至一切智得度彼岸。以是故。憍尸迦。若善男子善女人。若佛在世若般涅槃后。应依止般若波罗蜜。禅波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀波罗蜜。乃至一切种智亦应依止。何以故。是般若波罗蜜乃至一切种智。是诸声闻辟支佛菩萨摩诃萨及一切世间天人阿修罗所可依止

【论】问曰。佛已种种赞般若功德。今释提桓因。何故以舍利校般若功德多少。答曰。信根多者。喜供养舍利。慧根多者。好读诵经法。是故问。有人书经供养。有人供养舍利。何所为多。华香璎珞等义如先说。于汝意云何者。四事答中此是反问答。是故佛即反问释提桓因。或有人供养舍利得福德多。或有人供养般若波罗蜜得福德亦多。随人心故佛不得一定答。是故反问。从般若波罗蜜中。生五波罗蜜者。后品中佛自说。无方便智慧布施回向。不名檀波罗蜜。十八空即是智慧。智慧因缘故。生四念处乃至一切种智。虽非尽是智慧。以性同故。以智慧为主。是故言从般若生。行般若波罗蜜。得诸法实相。于布施持戒等通达。若不得般若实相。不能通达布施持戒。何以故。若一切法空。则无罪无福。何用布施持戒。若诸法实有相不应从因缘生。先已有故。若众生是常。则譬如虚空亦无死者。若无常神则随身灭。亦无后世罪福。若无众生何有杀罪。如是亦无不杀生戒等。若得是般若波罗蜜实相法。则不堕有无二边。用中道通达布施持戒等。以此布施持戒等果报故。有刹利大姓乃至诸佛。问曰。阎浮提人。多贪利福德。何以不供养般若波罗蜜。答曰。智人少故。不知供养般若无咎。譬如金宝盲者不识。以阎浮提人但信三尊者少。何况知而能行。佛欲令释提桓因自说故。反问有几许人于三尊得不坏信等。问曰。不坏信无疑决了。有何差别。答曰。有人言。无有差别。佛庄严种种说。开悟人心故。有人言。于三宝中得不坏信。何以知之以无疑故。何以知无疑以决了故。问曰。无疑决了有何异。答曰。初信三宝故是无疑。智慧究竟故是决了。譬如渡水初入是无疑。出彼岸是决了。三分圣戒力故信不坏。四分力故是无疑。正见分力故是决了。复次见谛道中是不坏信。思惟道中是无疑。无学道中是决了。如是等种种分别。是三事得何果报。从三十七品至六神通。是有为果。三结尽乃至烦恼及习尽。是无为果。得如是等果报。释提桓因。有报生知他心。亦曾以天耳闻诸道差别。又以是大菩萨利根入观众生心三昧故。得知诸道差别。是故答佛深信者少。从须陀洹乃至初发心。求佛道转少。转少故不知供养般若。何以故少。前世生死中。不闻三宝名。乃至不闻一切种智名。佛欲证上事故说。我今以佛眼观十方无量阿僧祇众生。发无上道。离般若方便力故。若一若二住阿毗跋致地。诸余善法入般若波罗蜜者是诸余经。所谓法华经密迹经等。十二部经中义同般若者。虽不名为般若波罗蜜经。然义理即同般若波罗蜜。问曰。云何须陀洹。亦学般若波罗蜜乃至一切种智得到彼岸。答曰。此中六波罗蜜三解脱门三十七品等乃至一切种智。此非独菩萨法三乘共有各随分学

【经】憍尸迦。若有善男子善女人。佛般涅槃后。为供养佛故。作七宝塔高一由旬。天香天华天璎珞天捣香天泽香天衣天幢盖天伎乐。供养恭敬尊重赞叹。憍尸迦。于汝意云何。是善男子善女人。从是因缘得福多不。释提桓因言。世尊。甚多甚多。佛言。不如是善男子善女人闻是般若波罗蜜书写受持亲近正忆念。不离萨婆若心。亦供养恭敬尊重赞叹。若花香璎珞捣香泽香幢盖伎乐供养。是善男子善女人福德多。佛告释提桓因。憍尸迦。置一七宝塔。若善男子善女人。供养佛故。佛般涅槃后。起七宝塔满阎浮提。皆高一由旬。恭敬尊重赞叹华香璎珞幢盖伎乐供养。憍尸迦。于汝意云何。是善男子善女人得福多不。释提桓因言。世尊。其福甚多。佛言。不如是善男子善女人如前供养般若波罗蜜其福甚多。憍尸迦。复置一阎浮提满中七宝塔。有善男子善女人。供养佛故。佛般涅槃后。起七宝塔满四天下。皆高一由旬。供养如前。憍尸迦。于汝意云何。是善男子善女人其福多不。释提桓因言。甚多甚多。佛言。不如是善男子善女人书持般若波罗蜜恭敬尊重。赞叹华香乃至伎乐供养其福甚多。憍尸迦。复置四天下满中七宝塔。若有善男子善女人。供养佛故。佛般涅槃后。起七宝塔满小千世界。皆高一由旬。供养如前。憍尸迦。于汝意云何。是善男子善女人。其福多不。释提桓因言甚多甚多。佛言。不如是善男子善女人书是般若波罗蜜受持恭敬尊重赞叹华香乃至伎乐供养其福甚多。憍尸迦。复置小千世界满中七宝塔。若有善男子善女人。供养佛故。佛般涅槃后。起七宝塔满二千中世界。皆高一由旬。供养如前。不如供养般若波罗蜜其福甚多。复置二千中世界七宝塔。若有善男子善女人。供养佛故。佛般涅槃后。起七宝塔满三千大千世界。皆高一由旬。尽形寿供养天华天香天璎珞乃至天伎乐。于汝意云何。是善男子善女人得福多不。释提桓因言。世尊。甚多甚多。佛言。不如是善男子善女人书持是般若波罗蜜恭敬尊重赞叹华香乃至伎乐供养其福甚多。复置三千大千世界中七宝塔。若三千大千世界中众生。一一众生供养佛故。佛般涅槃后。各起七宝塔。恭敬尊重赞叹花香乃至伎乐供养。若有善男子善女人。书持般若波罗蜜乃至正忆念。不离萨婆若心。亦恭敬尊重赞叹华香璎珞乃至伎乐供养。是人得福甚多。释提桓因白佛言。如是如是。世尊。是人供养恭敬尊重赞叹是般若波罗蜜。则为供养过去未来现在佛。世尊。若十方如恒河沙等世界众生。一一众生供养佛故。佛般涅槃后。各起七宝塔高一由旬。是人若一劫若减一劫。恭敬尊重赞叹华香乃至伎乐供养。世尊。是善男子善女人得福多不。佛言。甚多。释提桓因言。若有善男子善女人。书持是般若波罗蜜。乃至正忆念。亦恭敬尊重赞叹华香乃至伎乐供养其福大多。何以故。世尊。一切善法皆入般若波罗蜜中。所谓十善道。四禅四无量心四无色定。三十七品。三解脱门空无相无作。四谛苦谛集谛灭谛道谛。六神通八解脱九次第定。檀波罗蜜。尸罗波罗蜜。羼提波罗蜜。毗梨耶波罗蜜。禅波罗蜜。般若波罗蜜。内空乃至无法有法空。诸三昧门。诸陀罗尼门。佛十力四无所畏。四无碍智。大慈大悲十八不共法。一切智道种智一切种智。世尊。是名一切诸佛法印。是法中一切声闻及辟支佛。过去未来现在诸佛。学是法印得度彼岸

【论】释曰。般若波罗蜜。若闻受持诵读等。有无量功德。更欲说故。以现事譬喻证之。人见土塔高大。即时生心谓是塔主福德极大。何况七宝起塔高一由旬。是故佛以塔为喻。问曰。是塔为实为假。答曰。佛欲使人解知分别福德多小故。作是譬喻。不应问其虚实。有人言。有实有假。如迦叶佛般涅槃后有国王名吉梨姞。尔时人寿二万岁。是王为供养舍利故。起七宝塔高五十里。又过去世有转轮王名德主。一日起五百塔高五百由旬。此言满三千大千世界。是事假喻。有人言。皆是实有。如小国王随力起七宝塔。大王能起一由旬七宝塔。或过一由旬。小转轮王能起七宝塔。满四天下。大转轮王能起七宝塔。过四天下。梵天王主三千大千世界。是佛弟子能心生变化起塔。高至梵天。满三千大千世界。或有菩萨得陀罗尼门诸三昧门。深行六波罗蜜故。佛灭度后。能起七宝塔。满三千大千世界。满者举其多故。不言间不容间。后言一一众生者。施主多故福德多。佛是中自说得福因缘。十善道乃至一切种智。皆摄在般若波罗蜜中。和合是法名为般若波罗蜜。是般若中但出生佛。尚应当供养。何况出生三乘及人天中乐。皆因般若波罗蜜有而不供养。舍利是无记法。是诸善法所依止处故。后乃能与人果报。行般若波罗蜜。即时得果后亦得报

    大智度论释述诚品第三十三

【经】尔时佛告释提桓因。如是如是。憍尸迦。是诸善男子善女人。书是般若波罗蜜。持经卷受学亲近读诵说正忆念。加复供养华香璎珞捣香泽香幢盖伎乐。当得无量无数不可思议不可称量无边福德。何以故。诸佛一切智一切种智。皆从般若波罗蜜中生。诸菩萨摩诃萨。禅波罗蜜。毗梨耶波罗蜜。羼提波罗蜜。尸罗波罗蜜。檀波罗蜜。皆从般若波罗蜜中生。内空乃至无法有法空。四念处乃至十八不共法。皆从般若波罗蜜中生。诸佛五眼皆从般若波罗蜜中生。成就众生净佛世界。道种智一切种智诸佛法。皆从般若波罗蜜中生。声闻乘辟支佛乘佛乘。皆从般若波罗蜜中生以是故。憍尸迦。善男子善女人。书是般若波罗蜜。受持经卷亲近读诵说正忆念。加复供养华香乃至伎乐。过出前供养七宝塔。百分千分千亿万分。乃至算数譬喻所不能及。何以故。憍尸迦。若般若波罗蜜在于世者。佛宝法宝比丘僧宝终不灭。若般若波罗蜜在于世者。十善道四禅四无量心四无色定。檀波罗蜜乃至般若波罗蜜。四念处乃至十八不共法。一切智一切种智。皆现于世。若般若波罗蜜在于世者。世间便有刹利大姓婆罗门大姓居士大家四天王天乃至阿迦尼吒诸天。须陀洹果乃至阿罗汉果辟支佛道菩萨摩诃萨无上佛道。转法轮成就众生净佛世界

【论】释曰。上帝释答佛言。供养般若福德甚多。更有大天以帝释非一切智人故。所说或错。是以佛印可所说。言如是如是。问曰。若般若波罗蜜相。一切诸观灭。语言道断不生不灭如虚空相。今何以说般若在世者三宝不灭。答曰。般若波罗蜜体性。有佛无佛常住不灭。此言在世者。所谓般若经卷。可修习读诵者。是因中说果。譬如井深绠短不及便言失井。井实不失。般若波罗蜜实相如深井。经卷名为绠。行者不能书写修习故言灭。问曰。若说三宝。尽摄一切善人善法。何以复言般若在世者。世间有十善道乃至一切种智。答曰。此诸法及诸道。皆广解三宝中义。佛宝者。佛法所摄无学五众。法宝者。第三谛所谓涅槃。除四沙门所摄学无学功德。余残辟支佛功德菩萨功德。僧宝者。四向四果。学无学五众。余十善道四禅四无量等皆是道方便门。是故别说

大智度论卷第五十七大智度论释劝受持品第三十四(卷五十八)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】尔时三千大千世界所有四天王天乃至阿迦尼吒天。语释提桓因诸天言。应受是般若波罗蜜。应持应亲近应读诵说正忆念。何以故。若受持般若波罗蜜乃至正忆念故。一切所修集善法当具足满。增益诸天众。减损阿修罗。诸天子。受持般若波罗蜜乃至正忆念故。佛种不断法种僧种不断。佛种法种僧种不断故。世间便有檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。皆现于世。四念处乃至十八不共法菩萨道。皆现于世。须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道佛道。须陀洹乃至佛皆现于世。尔时佛告释提桓因。憍尸迦。汝当受是般若波罗蜜持读诵说正忆念。何以故。若诸阿修罗生心欲与三十三天共斗。憍尸迦。汝尔时当诵念般若波罗蜜。诸阿修罗恶心即灭更不复生。憍尸迦。若诸天子天女五死相现时。当堕不如意处。汝当于其前诵读般若波罗蜜。是诸天子天女。闻般若波罗蜜功德力故还生本处。何以故。闻般若波罗蜜。有大利益故。复次憍尸迦。若有善男子善女人。若诸天子。天女闻是般若波罗蜜经耳。以是功德故。渐当得阿耨多罗三藐三菩提。何以故。憍尸迦。过去诸佛及弟子皆学是般若波罗蜜。得阿耨多罗三藐三菩提。入无余涅槃。憍尸迦。未来世诸佛。今现在十方诸佛及弟子。皆学是般若波罗蜜。得阿耨多罗三藐三菩提。入无余涅槃。何以故。憍尸迦。是般若波罗蜜摄一切善法。若声闻法若辟支佛法若菩萨法若佛法。释提桓因。白佛言。世尊。般若波罗蜜是大明咒无上明咒无等等明咒。何以故。世尊。是般若波罗蜜能除一切不善法。能与一切善法。佛语释提桓因。如是如是。憍尸迦。般若波罗蜜是大明咒无上明咒无等等明咒。何以故。憍尸迦。过去诸佛因是明咒故。得阿耨多罗三藐三菩提。未来世诸佛今现在十方诸佛。亦因是明咒。得阿耨多罗三藐三菩提。因是明咒故。世间便有十善道。便有四禅四无量心四无色定。便有檀波罗蜜乃至般若波罗蜜四念处乃至十八不共法。便有法性如法相法住法位实际。便有五眼须陀洹果乃至阿罗汉果辟支佛道佛道一切智一切种智。憍尸迦。菩萨摩诃萨因缘故。十善出于世间。四禅四无量心乃至一切种智须陀洹乃至诸佛出于世间。譬如满月照明星宿亦能照明。如是憍尸迦。一切世间善法正法十善乃至一切种智。若诸佛不出时。皆从菩萨生。是菩萨摩诃萨方便力。皆从般若波罗蜜生。菩萨摩诃萨以是方便力。行檀波罗蜜乃至禅波罗蜜内空乃至无法有法空四念处乃至十八不共法。不证声闻辟支佛地。成就众生净佛世界。寿命成就世界成就菩萨眷属成就。得一切种智。皆从般若波罗蜜生。复次憍尸迦。若善男子善女人。闻般若波罗蜜。受持亲近乃至正忆念。是人当得今世后世功德。释提桓因白佛言。世尊。何等是善男子善女人。受持般若波罗蜜。乃至正忆念。得今世后世功德。佛告释提桓因。若有善男子善女人。受持般若波罗蜜。乃至正忆念。终不中毒死。兵刃不伤水火不害。乃至四百四病所不能中。除其宿命业报。复次憍尸迦。若有官事起。是善男子善女人。读诵般若波罗蜜故。往到官所官不谴责。何以故。是般若波罗蜜威力故。若善男子善女人。读诵是般若波罗蜜。到王所若太子大臣所。王及太子大臣皆欢喜问讯和意与语。何以故。是诸善男子善女人。常有慈悲喜舍心向众生故。憍尸迦。若善男子善女人。受持般若波罗蜜乃至正忆念。得如是等种种今世功德。憍尸迦。何等是善男子善女人后世功德。是善男子善女人。终不离十善道四禅四无量心四无色定六波罗蜜四念处乃至十八不共法。是人终不堕三恶道。受身完具。终不生贫穷下贱工师除厕人担死人家。常得三十二相常得化生诸现在佛界。终不离菩萨神通。若欲从一佛界至一佛界供养诸佛听诸佛法。即得随意。所游佛界成就众生净佛世界。渐得阿耨多罗三藐三菩提。憍尸迦。是名后世功德。以是故。憍尸迦。善男子善女人。应当受持般若波罗蜜亲近读诵说正忆念。华香乃至伎乐供养常不离萨婆若心。是善男子善女人。乃至阿耨多罗三藐三菩提。得今世后世功德成就

【论】释曰。佛是法王。赞叹受持般若波罗蜜者已。次天王释赞释赞已。今次诸天赞。以多众赞故。令人信心转深。作是言应受持是般若波罗蜜。此中说受持因缘。修诸功德增益诸天。减损阿修罗。三宝不断六波罗蜜等诸功德出现于世。尔时佛可诸天赞告释言。汝受持是般若波罗蜜。此中说因缘。若阿修罗生恶心。欲共三十三天斗。汝尔时读诵般若者恶心即灭。若二阵相对时。读诵般若者。阿修罗即退去。问曰。若尔者何以不常诵般若令阿修罗恶心不生。何故乃使两阵相对。答曰。诸天多着福乐染欲心利。虽知般若有大功德。不能常诵故。又以忉利天不净业因缘故。致有怨敌不得不斗。诸天命欲终时五死相现。一者华鬘萎。二者掖下汗出。三者蝇来着身。四者见更有天坐己坐处。五者自不乐本坐。诸天见是死相念惜天乐。见当生恶处心怀忧毒。尔时若闻般若波罗蜜实相诸法虚诳无常空寂信是佛法。心清净故还生本处。是天人不但还生本处。以闻般若故。世世受福乐。渐成无上道。此中因缘如经说。般若波罗蜜为大明咒者是。问曰。释提桓因何以故。名般若为大明咒。答曰。诸外道圣人。有种种咒术利益人民。诵是咒故能随意所欲。使诸鬼神诸仙人有是咒故。大得名声。人民归伏贵咒术故。是以帝释白佛言。诸咒术中般若波罗蜜是大咒术。何以故。能常与众生道德乐故。余咒术乐因缘能起烦恼。又不善业故堕三恶道。复次余咒术。能随贪欲嗔恚自在作恶。是般若波罗蜜咒。能灭禅定佛道涅槃诸着。何况贪恚粗病。是故名为大明咒无上咒无等等咒。复次是咒能令人离老病死。能立众生于大乘。能令行者于一切众生中最大。是故言大咒。能如是利益故名为无上。先有仙人所作咒术。所谓能知他人心咒。名抑叉尼。能飞行变化咒。名揵陀梨。能住寿过千万岁咒。于诸咒中无与等。于此无等咒术中。般若波罗蜜过出无量故。名无等等。复次诸佛法名无等。般若波罗蜜。得佛因缘故言无等等。复次诸佛于一切众生中名无等。是般若咒术佛所作故。名无等等咒。复次此经中自说三咒因缘。所谓是咒能舍一切不善法。能与一切善法。佛顺其所叹故。言如是如是。亦更广其所赞。所谓因般若故。出生十善道乃至诸佛。是般若波罗蜜属菩萨故。佛说譬喻。诸佛能大破无明闇故如满月。菩萨破闇不如故如星宿。如夜中有所见。皆是星月力。世间生死夜中有所知见。皆是佛菩萨力。若世无佛。尔时菩萨说法度众生。着人天乐中。惭渐令得涅槃乐。菩萨所有智慧。皆是般若波罗蜜力。复次是菩萨。虽行三十七品十八空知诸法毕竟不可取亦不证声闻辟支佛道。而能还起善法。教化众生净佛世界。寿命具足等。皆是方便般若波罗蜜力。若是人能受持般若。乃至正忆念。得今世后世功德。今世功德者。所谓终不中毒死等。问曰。先已说不横死。今何以更说。答曰。先已说般若波罗蜜。不一会中说。此为后来者更为说。复次刀毒水火。有二种有他作有自作。先说他加兵毒水火等。今为不自伤。何以知之。次说四百四病故。知上虽说人不能得其便。不说其人还恭敬供养。四百四病者。四大为身常相侵害。一一大中百一病起。冷病有二百二。水风起故。热病有二百二。地火起故。火热相地坚相。坚相故难消。难消故能起热病。血肉筋骨骸髓等地分。除其业报者。一切法和合因缘生无有作者。无有作者故必受业报。佛所不能救。何况般若。必受业报不必受业报先已说。官事起者。诵般若波罗蜜力故随起皆灭。问曰。先说人不能得便。今何以复更说。答曰。先虽说人不能得便。不说国王大臣等既不能得便还复恭敬供养。何以故。是菩萨常有慈悲喜舍心。向众生故。后世功德者。世世所生常不离十善道等。是故常不堕恶道。是人折伏恶心故受身完具。不生下贱等家。学佛所学道故得变化身。似佛有三十二相八十随形好。常得化生现在佛国者。随心所到十方世界。供养诸佛听受诸法。教化众生渐渐得成佛道。是故行者应闻受持乃至正忆念不离萨婆若心。如是得今世后世功德

    大智度论释梵志品第三十五

【经】尔时诸外道梵志。来向佛所欲求佛短。是时释提桓因心念。是诸外道梵志。来向佛所欲求佛短。我今当诵念从佛所受般若波罗蜜。是诸外道梵志等。终不能中道作碍断说般若波罗蜜。释提桓因作是念已。即诵般若波罗蜜。是时诸外道梵志。遥绕佛复道还去。时舍利弗心念。是中何因缘。诸外道梵志。遥绕佛复道还去。佛知舍利弗心念。告舍利弗。是释提桓因。诵念般若波罗蜜。以是因缘故。诸外道梵志。遥绕佛复道还去。舍利弗。我不见是诸外道梵志一念善心。是诸外道梵志。但持恶心来欲求索佛短。舍利弗。我不见说般若波罗蜜时一切世间若天若魔若梵若沙门众婆罗门众中有持恶意来能得短者。何以故。舍利弗。是三千大千世界中。诸四天王天乃至阿迦尼吒天。诸声闻辟支佛诸菩萨摩诃萨等。守护是般若波罗蜜。所以者何。是诸天人皆从般若波罗蜜中生故。复次舍利弗。十方如恒河沙等世界中。诸佛及声闻辟支佛菩萨摩诃萨诸天龙鬼神等。皆守护是般若波罗蜜。所以者何。是诸佛等皆从般若波罗蜜中生故。尔时恶魔心念。今佛四众现前集会。亦有欲界色界诸天子。是中必有菩萨摩诃萨。受记当得阿耨多罗三藐三菩提。我宁可至佛所破坏其意是时恶魔化作四种兵来至佛所。尔时释提桓因心念。是四种兵或是恶魔化作欲来向佛。何以故。是四种兵严饰。频婆娑罗王四种兵所不类。波斯匿王四种兵亦不类。诸释子四种兵。诸梨唱四种兵。皆亦不类。是恶魔长夜索佛便欲恼众生。我宁可诵念般若波罗蜜。释提桓因。即时诵念般若波罗蜜。恶魔如所诵闻渐渐复道还去。尔时会中四天王诸天子。乃至阿迦尼吒诸天子。化作天华于虚空中而散佛上作是言。世尊。愿令般若波罗蜜久住阎浮提。所以者何。阎浮提人受持般若波罗蜜随所住时佛宝住不灭。法宝僧宝亦住不灭。尔时十方如恒河沙等世界中诸天。亦皆散华作是言。世尊。愿令般若波罗蜜久住阎浮提。若般若波罗蜜久住。佛法僧亦当久住。亦分别知菩萨摩诃萨道。复次所在住处。有善男子善女人。书持般若波罗蜜经卷。是处则为照明已离众冥。佛告释提桓因等诸天子。如是如是憍尸迦。及诸天子。阎浮提人受持般若波罗蜜。随所住时佛宝如是住。法宝僧宝亦如是住。乃至所住在处。善男子善女人有书持般若波罗蜜经卷。是处则为照明已离众冥。尔时诸天子化作天华散佛上作是言。世尊。若有善男子善女人。受持般若波罗蜜乃至正忆念。魔若魔天不能得其便。世尊。我等亦当拥护是善男子善女人。何以故。若善男子善女人。受持般若波罗蜜乃至正忆念。我等视是人即是佛若次佛。是时释提桓因白佛言。世尊。善男子善女人。受持般若波罗蜜乃至正忆念者。当知是人先世于佛所作功德多。亲近供养诸佛。为善知识所护。世尊。诸佛一切智应当从般若波罗蜜中求。般若波罗蜜亦当从一切智中求。所以者何。般若波罗蜜不异一切智。一切智不异般若波罗蜜。般若波罗蜜一切智不二不别。是故我等视是人即是佛若次佛。佛告释提桓因。如是如是。憍尸迦。诸佛一切智。即是般若波罗蜜。般若波罗蜜。即是一切智。何以故。憍尸迦。诸佛一切智。从般若波罗蜜中生。般若波罗蜜。不异一切智。一切智不异般若波罗蜜。般若波罗蜜一切智不二不别

【论】释曰。上品中说闻受般若者。魔若魔民外道梵志不得其便。今欲现证验故。以威神感致众魔及诸外道。是以外道梵志作是念。佛在耆阇崛山中。说般若波罗蜜。所谓诸法毕竟空无所有。以引致十方众生。我等共往难问破此空论。其论若破佛则自退。我等还得如本。是诸外道但有邪见恶心憍慢故来。欲出是毕竟清净般若波罗蜜过罪。譬如狂人欲中伤虚空徒自疲苦。尔时帝释如佛教受持般若。外道不能得便。今欲验实令人信知故。帝释无量福德成就。以天利根深信般若即时诵念。得般若力故。外道遥绕佛复道而去。问曰。可以不直还。方绕佛而去。答曰。以般若神力故。于远处降伏作是念。佛众威德甚大。我等今往徒自困辱无所成办。我等今若遥见直去。人当谓我等怯弱来而空去。以是故。诈现供养绕佛复道而去。舍利弗本是梵志。见诸外道远处而去心少怜愍。不能以小事故入三昧求知。作是念。此诸外道何因缘来。竟不蒙度而空还去。佛言是般若波罗蜜力。舍利弗意念。佛以般若波罗蜜无事不济。云何令此外道空来而去。佛知舍利弗所念。语舍利弗。是诸梵志乃至无一念善心。但持恶意邪见着心。欲求诸法定相。是故不中度。譬如必死之病虽有良医神药不能救济。舍利弗说般若波罗蜜时。非但此梵志一切世间人持恶心来不能得便。何以故一切诸佛及诸菩萨诸天常守护般若故。所以者何。诸佛菩萨天人作是念。我等皆从般若生故。魔来欲难问破坏亦如是。是时会中诸天子。先闻般若功德今见证验。心大欢喜化华供养。作是愿。令般若波罗蜜久住阎浮提。是事如下广说。佛即印可。诸天于佛前自誓言。行者若闻受般若波罗蜜乃至正忆念。我等常当守护。所以者何。我等视是人如佛若次佛。如佛者法性身住阿鞞跋致得无生法忍乃至十地。次佛者肉身菩萨能说般若波罗蜜及其正义。尔时帝释以先世因缘所集功德智慧赞是菩萨。此中更说赞叹因缘。诸佛一切种智。应从般若中求者。菩萨行般若波罗蜜具足故得佛时。般若变成一切种智故。言一切种智当从般若中求。佛能说般若波罗蜜故。言般若波罗蜜当从一切智中求。譬如乳变为酪离乳无酪亦不得言乳即是酪。般若波罗蜜变为一切种智。离般若亦无一切种智。亦不得言般若即是一切种智。般若与一切种智作生因。一切种智与般若作说因。因果不相离故。言不二不别

    大智度论释阿难称誉品第三十六

【经】尔时慧命阿难白佛言。世尊何以故。不称誉檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜乃至十八不共法。但称誉般若波罗蜜。佛告阿难。般若波罗蜜。于五波罗蜜乃至十八不共法为尊导。阿难。于汝意云何。不回向萨婆若布施。得称檀波罗蜜不。不也。世尊。不回向萨婆若。尸罗羼提毗梨耶禅智慧是般若波罗蜜不。不也。世尊。以是故。知般若波罗蜜于五波罗蜜乃至十八不共法为尊导。是故称誉。阿难白佛言。世尊。云何布施回向萨婆若。作檀波罗蜜。乃至作般若波罗蜜。佛告阿难。以无二法布施回向萨婆若。是名檀波罗蜜。以不生不可得。回向萨婆若。布施是名檀波罗蜜乃至以无二法智慧。回向萨婆若。是名般若波罗蜜。以不生不可得。回向萨婆若。智慧是名般若波罗蜜。阿难白佛言。世尊。云何以不二法。回向萨婆若。布施是名檀波罗蜜。乃至以不二法。回向萨婆若。智慧是名般若波罗蜜。佛告阿难。以色不二法故。受想行识不二法故。乃至阿耨多罗三藐三菩提不二法故。世尊。云何色不二法。乃至阿耨多罗三藐三菩提不二法。佛言。色色相空。何以故。檀波罗蜜色不二不别。乃至阿耨多罗三藐三菩提。檀波罗蜜不二不别。五波罗蜜亦如是。以是故。阿难。但称誉般若波罗蜜。于五波罗蜜乃至一切种智为尊导。阿难。譬如地以种散中。得因缘和合故便生。是诸种子依地而生。如是阿难。五波罗蜜依般若波罗蜜得生。四念处乃至一切种智。亦依般若波罗蜜得生。以是故。阿难般若波罗蜜。为五波罗蜜乃至十八不共法尊导。尔时释提桓因白佛言。世尊。佛说善男子善女人。受持般若波罗蜜乃至正忆念者。功德未尽。何以故。受持般若波罗蜜乃至正忆念。则受三世诸佛无上道。所以者何。欲得萨婆若。当从般若波罗蜜中求。欲得般若波罗蜜。当从萨婆若中求。世尊。受持般若波罗蜜乃至正忆念故。十善道现于世间。四禅四无量心四无色定乃至十八不共法现于世间。受持般若波罗蜜乃至正忆念故。世间便有刹利大姓婆罗门大姓居士大家四天王天乃至阿迦尼吒诸天。受持般若波罗蜜乃至正忆念故。便有须陀洹乃至阿罗汉辟支佛菩萨摩诃萨。受持般若波罗蜜乃至正忆念故。诸佛出于世间。尔时佛告释提桓因。憍尸迦。善男子善女人。受持般若波罗蜜乃至正忆念。我不说但有尔所功德。何以故。憍尸迦。是善男子善女人。受持般若波罗蜜乃至正忆念。不离萨婆若心。无量戒众成就。定众慧众解脱众解脱知见众成就。复次憍尸迦。是善男子善女人。能受持般若波罗蜜乃至正忆念。不离萨婆若心。当知是人为如佛。复次憍尸迦。一切声闻辟支佛。所有戒众定众慧众解脱众解脱知见众。不及是善男子善女人戒众乃至解脱知见众。百分千分千亿万分。乃至算数譬喻所不能及。何以故。是善男子善女人。于声闻辟支佛地中。心得解脱。更不求大乘法故。复次憍尸迦。若有善男子善女人。书持般若波罗蜜经卷。供养恭敬尊重。华香璎珞乃至伎乐。亦得今世后世功德。尔时释提桓因白佛言。世尊。是善男子善女人。受持般若波罗蜜乃至正忆念。不离萨婆若心。供养般若波罗蜜。恭敬尊重华香乃至伎乐。我常当守护是人

【论】释曰。阿难虽多闻力能分别空。而未离欲故不能深入。虽常侍佛不数问难空事。今佛赞叹般若波罗蜜。亦赞叹行者。是故阿难白佛言。世尊。何以不称叹余波罗蜜及诸法。而独称叹般若波罗蜜。问曰。佛从初以来。常说六波罗蜜名。今阿难何以言不称说。答曰。虽说名字不为称美。皆为入般若中故说。佛语阿难。一切有为法中智慧第一。一切智慧中度彼岸。般若波罗蜜第一。譬如行路虽有众伴导师第一。般若亦如是。虽一切善法各各有力。般若波罗蜜。能示导出三界到三乘。若无般若波罗蜜。虽行布施等善法。随受业行果报有尽。以有尽故。尚不能得小乘涅槃。何况无上道。若布施等善法。能观如佛道相不二。不生不灭不得不失毕竟空寂。是名回向萨婆若。是布施福世世常受果报而不尽。后当得一切种智。如布施。一切法亦如是相。问曰。佛何以不答不二因缘。还以不二解。答曰。阿难不问不二因缘。但问何法不二。是故佛答色等诸法不二故。般若波罗蜜。能令五事等作波罗蜜故。但称誉般若波罗蜜。佛欲令是义了了易解故。作是喻譬。如大地能生万物。般若波罗蜜亦如是。能持一切善法种子者。从发心来。除般若波罗蜜。余一切善法。是因缘和合者。是佛道中一心信忍精进不休不息。欲受通达不坏。有如是等法。事得成办者。是增长者。从发心起学诸波罗蜜。从一地至一地乃至佛地是。问曰。帝释何以故。言佛说行者受持般若功德未尽。答曰。般若波罗蜜无量无边。功德亦无量无边。说未究竟。中间外道梵志及魔来故傍及异事。今还欲续闻。帝释深爱福德果报。乐闻般若功德听无厌足。今更欲闻说故。自说因缘。世尊。若人受持般若波罗蜜乃至正忆念。则受三世诸佛无上道功德智慧。所以者何。般若中应求一切种智。一切种智中应求般若。如上品未说。行者若受持般若波罗蜜发心求阿耨多罗三藐三菩提。为度众生故。集般若波罗蜜等诸功德。所谓十善道乃至十八不共法。现于世间。是善法因缘故。有刹利大姓乃至诸佛。佛告天帝是人不但得如上功德。亦得无量戒众等功德。戒众者。是菩萨行般若波罗蜜。于一切众生中。修毕竟无畏施。众生十方中数无量无边。三世中数亦无量无边。六道四生种类。各各相亦无量无边。于此无量无边众生中。施第一所爱乐物。所谓寿命。是故得无量戒众果报。如是不杀等戒。但说名字则二百五十。毗尼中略说。则八万四千。广说则无量无边。是戒凡夫人。或一日受或一世或百千万世。菩萨世世于一切众生中施无畏。乃至入无余涅槃。是名无量戒众。乃至解脱知见众亦如是随义分别。是五众功德胜于二乘不可计量。若人书写供养般若波罗蜜。得今世后世功德。问曰。今世后世功德深重。书持供养轻微。云得得二世功德。答曰供养有二种。一者效他供养。二者深心供养。知般若功德。深心供养故。得二世功德。是般若有种种门入。若闻持乃至正忆念者。智慧精进门入。书写供养者。信及精进门入。若一心深信。则供养经卷胜。若不一心虽受持而不如。复次有如如意宝珠。是无记色法无心无识以众生福德因缘故生。有人供养者。能令人随意所得。何况般若波罗蜜。是无上智慧诸佛之母。诸法宝中是第一宝。若人如所闻一心信受供养。云何不得二世功德。但人不一心供养。又先世重罪故。虽供养般若而不得如上功德。般若无咎

【经】佛告释提桓因。憍尸迦。是善男子善女人。欲读诵说般若波罗蜜时。无量百千诸天皆来听法。是善男子善女人。说般若波罗蜜法。诸天子益其胆力。是诸法师若疲极不欲说法。诸天益其胆力故便更能说。善男子善女人。受持是般若波罗蜜乃至正忆念。供养华香乃至伎乐故。亦得是今世功德。复次憍尸迦。是善男子善女人。于四部众中说般若波罗蜜时心无怯弱。若有论难亦无畏想。何以故。是善男子善女人。为般若波罗蜜所护持故。般若波罗蜜中。亦分别一切法。若世间若出世间。若有漏若无漏。若善若不善。若有为若无为。若声闻法若辟支佛法。若菩萨法若佛法。善男子善女人。住内空乃至住无法有法空故。不见有能难般若波罗蜜者。亦不见受难者。亦不见般若波罗蜜。如是善男子善女人。为般若波罗蜜所护持故。无有能难坏者。复次善男子善女人。受持般若波罗蜜乃至正忆念时。不没不畏不怖。何以故。是善男子善女人。不见是法没者恐怖者。憍尸迦。善男子善女人。受持般若波罗蜜乃至正忆念。华香供养乃至幡盖。亦得是今世功德。复次憍尸迦。善男子善女人受持般若波罗蜜乃至正忆念。书持经卷华香供养乃至幡盖。是人为父母所爱宗亲知识所念。诸沙门婆罗门所敬。十方诸佛及菩萨摩诃萨辟支佛阿罗汉乃至须陀洹所爱敬。一切世间若天若魔若梵及阿修罗等皆亦爱敬。是人行檀波罗蜜。檀波罗蜜无有断绝时。尸罗波罗蜜。羼提波罗蜜。毗梨耶波罗蜜。禅波罗蜜。般若波罗蜜。亦无有断绝时。修内空不断。乃至修无法有法空不断。修四念处不断。乃至修十八不共法不断。修诸三昧门不断。修诸陀罗尼门不断。诸菩萨神通不断。成就众生净佛世界不断。乃至修一切种智不断。是人亦能降伏难论毁谤。善男子善女人。受持般若波罗蜜乃至正忆念。不离萨婆若心。书持经卷华香供养乃至幡盖。亦得是今世后世功德。复次憍尸迦。善男子善女人。书持经卷在所住处。三千大千世界中。所有诸四天王天。发阿耨多罗三藐三菩提心者。皆来到是处。见般若波罗蜜。受读诵说供养礼拜还去。三十三天夜摩天兜率陀天化乐天他化自在天。梵众天梵辅天梵会天大梵天。光天少光天无量光天光音天。净天少净天无量净天遍净天。无荫行天福德天广果天。发阿耨多罗三藐三菩提心者。皆来到是处。见般若波罗蜜。受读诵说供养礼拜还去。净居诸天所谓无诳天无热天妙见天喜见天色究竟天。皆来到是处。见是般若波罗蜜。受读诵说供养礼拜还去。复次憍尸迦。十方世界中。诸四天王天。乃至广果天。发阿耨多罗三藐三菩提心。及净居天并余诸天。龙鬼神揵闼婆阿修罗迦楼罗紧那罗摩睺罗伽。亦来见般若波罗蜜。受读诵说供养礼拜还去。是善男子善女人应作是念。十方世界中诸四天王天。乃至广果天。发阿耨多罗三藐三菩提心。及净居天并余诸天。龙鬼神揵闼婆阿修罗迦楼罗紧那罗摩睺罗伽。来见般若波罗蜜。受读诵说供养礼拜。我则法施已。憍尸迦。三千大千世界中。所有诸四天王天。乃至阿迦尼吒天。乃至十方世界中。诸四天王天。乃至阿迦尼吒天。发阿耨多罗三藐三菩提心者。护持是善男子善女人。诸恶不能得便。除其宿命重罪。憍尸迦。是善男子善女人。亦得是今世功德。所谓诸天子发阿耨多罗三藐三菩提心。皆来到是处。何以故。憍尸迦。诸天子发阿耨多罗三藐三菩提心。欲救护一切众生。不舍一切众生。安乐一切众生故。尔时释提桓因白佛言。世尊。善男子善女人。云何当知。诸四天王天乃至阿迦尼吒天来。及十方世界中诸四天王天。乃至阿迦尼吒天。来见般若波罗蜜。受读诵说供养礼拜时。佛告释提桓因。憍尸迦。若善男子善女人。见大净光明。必知有大德诸天来见般若波罗蜜。受读诵说供养礼拜时。复次憍尸迦。若善男子善女人。若闻异妙香必知有大德诸天来见般若波罗蜜。受读诵说供养礼拜时。复次憍尸迦。善男子善女人。行净洁故诸天来到其处见般若波罗蜜。受读诵说供养欢喜礼拜。是中有小鬼辈。即时出去不能堪任。是大德诸天威德故。以是大德诸天来故。是善男子善女人生大心。以是故。般若波罗蜜所住处。四面不应有诸不净。应然灯烧香散众名华众香涂地众盖幢幡种种严饰。复次憍尸迦。善男子善女人。说法时终无疲极。自觉身轻心乐。随法偃息。卧觉安隐无诸恶梦。梦中见诸佛三十二相八十随形好比丘僧恭敬围绕而为说法。在诸佛边听受法教。所谓六波罗蜜四念处乃至十八不共法。分别六波罗蜜义四念处乃至十八不共法。亦分别其义。亦见菩提树庄严殊妙。见诸菩萨趣菩提树得阿耨多罗三藐三菩提。见诸佛成已转法轮。见百千万菩萨共集法论义。应如是求萨婆若。应如是成就众生。应如是净佛世界。亦见十方无数百千万亿诸佛。亦闻其名号。某方某界某佛。若干百千万菩萨。若干百千万声闻恭敬围绕说法。复见十方无数百千万亿诸佛般涅槃。复见无数百千万亿诸佛七宝塔。见供养诸佛塔恭敬尊重赞叹华香乃至幢盖。憍尸迦。是善男子善女人。见如是善梦。卧安觉安。诸天益其气力。自觉身体轻便。不大贪着饮食衣服卧具汤药。于此四供养其心轻微。譬如比丘坐禅从禅定起心与定合。不贪着饮食其心轻微。何以故。憍尸迦。诸天法。应以诸味之精益其气力故。十方诸佛。及天龙鬼神阿修罗揵闼婆迦楼罗紧那罗摩睺罗伽。亦益其气力。如是憍尸迦。善男子善女人。欲得今世如是功德。应当受持般若波罗蜜亲近读诵说正忆念。亦不离萨婆若心。憍尸迦。善男子善女人。虽不能受持乃至正忆念。应当书持经卷恭敬供养尊重赞叹华香璎珞乃至幡盖。憍尸迦。若善男子善女人。闻是般若波罗蜜。受持读诵说正忆念书经卷恭敬供养尊重赞叹华香乃至幢盖。是善男子善女人功德甚多。胜于供养十方诸佛及弟子。恭敬尊重赞叹衣服饮食卧具汤药。诸佛及弟子。般涅槃后起七宝塔。恭敬供养尊重赞叹华香乃至幢盖

【论】问曰。天上自有般若。何以来至说法人所益其胆力。答曰。天上虽有般若。诸天怜愍众生故来。天来恶鬼远去。益法师胆力令其乐说。又使众生益加信敬。以是故来。有人言。天甘露味微细沾洽能入孔孔。使善男子四大诸情柔软轻利乐有所说。问曰。一切说般若者。皆得诸天甘露味。令其乐说不。答曰。不也。若有行者一心求佛道。折伏结使。衣服净洁所说法处清净。华香幡盖香水洒地无诸不净。是故诸天欢喜亦利益。诸听法者说法者。虽不多读内外经书。深入般若波罗蜜义故。心不怯弱不没不畏不恐。何以故。般若波罗蜜中无有定法可执可难可破故。复次是般若波罗蜜中。亦分别说诸法世间出世间常无常善不善等无法不有。以备有诸法故不怯不畏。若但有一法则多所阙故有恐畏。是菩萨行般若波罗蜜。烦恼折薄。诸福德增益薰身故威德可敬。身是功德住处故。虽形体丑陋无所能作。犹为人所爱重。何况自然端正能利益人。问曰。若诸佛沙门婆罗门所爱敬可尔。父母爱念何足称。答曰。人虽父母所生。不顺父母教则不爱念。菩萨于恭顺之中倍复殊胜。供养恭敬尊重道德故。沙门婆罗门。爱敬平实至诚口不妄言。深爱后世功德不着今世乐。接养下人不自高大。若见他有过。尚不说其实。何况谗毁。若必不得已终不尽说。给恤孤穷不私附己。如是等事。皆是般若波罗蜜力。是人功德远闻故。诸天世人皆所爱敬。是供养般若波罗蜜故。世世常得六波罗蜜等。无有断绝时。是人福德智慧名闻故。若有问难毁谤悉能降伏。复次诸天为供养般若波罗蜜故。来至般若所住处。复次山河树木土地城廓。一切鬼神皆属四天王。四天王来故。皆随从共来。是诸鬼神中。有不得般若经卷者。是故来至般若波罗蜜处。供养读诵礼拜。亦为利益善男子故。此亦是今世功德以诸天善神来故天帝破肉眼人疑故。问云何知大德天来。答时见大光明若闻殊异之香。亦以如先说住处清净故。问曰。人身不净内充外净何益。答曰。净其住处及以衣服则外无不净。外无不净故诸天欢喜。譬如国王大人来处。群细庶民避去。诸大德天来。小鬼去亦如是。大天威德重故。旧住小鬼避去。是诸大天来近故。是人心则清净广大。行者若欲令大德天来。当如经所说。恶鬼远去故身心轻便。所以者何。近诸恶鬼令人身心渐恶。譬如近嗔人喜令人嗔。近美色则令人好色情发。是人内外恶因缘远离故。卧安觉安无诸恶梦。若梦但见诸佛。如经所说。问曰。般若波罗蜜在佛身中。若供养一佛。则供养般若波罗蜜。何以言供养十方佛不如供养般若波罗蜜。答曰。供养者心。若供养佛取人相。人毕竟不可得。以取相故福田虽大而功德薄少。供养般若波罗蜜者则如所闻。般若中不取人相不取法相。用是心供养故福德大。复次般若波罗蜜。是一切十方诸佛母亦是诸佛师。诸佛得是身三十二相八十随形好及无量光明神通变化。皆是般若波罗蜜力。以是故。供养般若波罗蜜胜。以是等因缘故。胜供养十方诸佛。非不敬佛

大智度论卷第五十八大智度论释校量舍利品第三十七(卷五十九)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】佛告释提桓因言。憍尸迦。若满阎浮提佛舍利作一分。复有人书般若波罗蜜经卷作一分。二分之中汝取何所。释提桓因白佛言。世尊。若满阎浮提佛舍利作一分。般若波罗蜜经卷作一分。二分之中我宁取般若波罗蜜经卷。何以故。世尊。我于佛舍利非不恭敬非不尊重。以舍利从般若波罗蜜中生。般若波罗蜜薰修故。是舍利得供养恭敬尊重赞叹。尔时舍利弗问释提桓因。憍尸迦。是般若波罗蜜不可取。无色无形无对一相。所谓无相。汝云何欲取。何以故。是般若波罗蜜。不为取故出。不为舍故出。不为增减聚散损益垢净故出。是般若波罗蜜。不与诸佛法不舍凡人法。不与辟支佛法阿罗汉法学法。不舍凡人法。不与无为性。不舍有为性。不与内空乃至无法有法空。不与四念处乃至一切种智。不舍凡人法。释提桓因语舍利弗。如是如是。舍利弗。若有人知是般若波罗蜜。不与诸佛法不舍凡人法。乃至不与一切种智。不舍凡人法。是菩萨摩诃萨能行般若波罗蜜。能修般若波罗蜜。何以故。般若波罗蜜。不行二法故。不二法相是般若波罗蜜。不二法相是禅波罗蜜。乃至檀波罗蜜。尔时佛赞释提桓因言。善哉善哉。憍尸迦。如汝所说。般若波罗蜜不行二法故。不二法相是般若波罗蜜。不二法相是禅波罗蜜。乃至檀波罗蜜。憍尸迦。若人欲得法性二相者。是人为欲得般若波罗蜜二相。何以故。憍尸迦。法性般若波罗蜜无二无别。乃至檀波罗蜜亦如是。若人欲得实际不可思议性二相者。是人为欲得般若波罗蜜二相。何以故。般若波罗蜜。不可思议性无二无别。释提桓因白佛言。世尊。一切世间人及诸天阿修罗。应礼拜供养般若波罗蜜。何以故。诸菩萨摩诃萨。般若波罗蜜中。学得阿耨多罗三藐三菩提。世尊。我常在善法堂上坐。我若不在坐时。诸天子来供养我故。为我坐处作礼绕竟还去。诸天子作是念。释提桓因在是处坐。为诸三十三天说法故。如是世尊。在所处书是般若波罗蜜经卷。受持读诵为他演说。是处十方世界中诸天龙夜叉揵闼婆阿修罗迦楼罗紧那罗摩睺罗伽。皆来礼拜般若波罗蜜供养已去。何以故。是般若波罗蜜中。生诸佛及一切众生乐具故。诸佛舍利亦是一切种智住处因缘。以是故。世尊。二分中我取般若波罗蜜。复次世尊。我若受持读诵般若波罗蜜。心深入法中。我是时不见怖畏相何以故。世尊。是般若波罗蜜。无相无貌无言无说。世尊。无相无貌无言无说。是般若波罗蜜。乃至是一切种智。世尊。般若波罗蜜。若当有相非无相者。诸佛不应知一切法无相无貌无言无说得阿耨多罗三藐三菩提。为弟子说诸法无相无貌无言无说。世尊。用般若波罗蜜实是无相无貌无言无说故。诸佛知一切诸法无相无貌无言无说得阿耨多罗三藐三菩提。为弟子说诸法亦无相无貌无言无说。以是故。世尊。是般若波罗蜜。一切世间诸天人阿修罗。应供养恭敬尊重赞叹华香璎珞乃至幡盖。复次世尊。若有人受持般若波罗蜜亲近读诵说正忆念及书写供养华香乃至幡盖。是人不堕地狱畜生饿鬼道中。不堕声闻辟支佛地。乃至得阿耨多罗三藐三菩提。常见诸佛从一佛界至一佛界。供养诸佛。恭敬尊重赞叹华香乃至幡盖。复次世尊。满三千大千世界。佛舍利作一分。书般若波罗蜜经卷作一分。是二分中。我故取般若波罗蜜。何以故。世尊。是般若波罗蜜中。生诸佛舍利。以是故。舍利得供养恭敬尊重赞叹。是善男子善女人。供养恭敬舍利故。受天上人中福乐。常不堕三恶道。如所愿渐以三乘法入涅槃。是故世尊。若有见现在佛。若见般若波罗蜜经卷等无异。何以故。世尊。是般若波罗蜜与佛无二无别故

【论】问曰。上以起七宝塔。校供养般若波罗蜜。义已具足。今佛何以以舍利经卷对校。答曰。先明七宝塔是舍利住处。今但明舍利以对经卷。舍利虽不及般若。而满阎浮提。般若妙故但明经卷。复次出家人多贪智慧。智慧是解脱因缘故。在家人多贪福德。福德是乐因缘故。出家人多贪意识所知物。在家人多贪五识所知物。释提桓因已证福乐。果报最大。于在家人中最为尊胜。以是故。佛问释提桓因。释提桓因言。我于二分中取般若波罗蜜经卷。此中自说因缘。世尊。我不敢轻慢不恭敬舍利。我知供养芥子许舍利功德无量无边。乃至得佛功德不尽。何况满阎浮提。世尊。菩萨受身便有舍利。人所不贵。得成佛时。舍利以般若熏修故。人所恭敬尊重供养。是故二分中我取胜者。问曰。舍利弗知释提桓因以世谛故言取般若波罗蜜。何以故难。答曰。释提桓因在家中。为烦恼所缚五欲所覆。而能说般若波罗蜜。是事希有。以是故舍利弗质问。欲令释提桓因更问佛深义故难。释提桓因顺舍利弗意答言如是。释提桓因意。于一切法中无二相。不以舍利为小。不以般若波罗蜜为大。般若波罗蜜无二无分别相。为利益新发意菩萨故。致以世谛如是说般若波罗蜜。能令众生心无二无分别。以是利益故我取般若。是时佛赞释提桓因。善哉善哉。以能分别诸法亦能善说般若相故。所谓无二相。是故赞叹。佛此中自说譬喻。若人欲分别法性实际等作二分。是人为欲分别般若波罗蜜作二分。帝释自说般若。又闻佛重说。其心清净深信欢喜言。一切世间所应礼敬。帝释此中自说因缘。一切菩萨学是般若得阿耨多罗三藐三菩提。又此中以己身为喻。己身喻佛。般若经卷喻坐处。有人言。己身喻般若。坐处喻舍利。是故二分中我取般若。复次世尊我若受持般若读诵。是时乃至不见怖畏相。何况实怖畏。所以者何。一切诸法无相无言无说故。般若波罗蜜能令人得是无相法故无所畏。受持供养般若者。不堕三恶趣及二乘道。世世不离诸佛。常供养十方诸佛。是故般若波罗蜜。一切世间所应供养。复次佛开其初以舍利满阎浮提。帝释既悟二事胜负。为一切众生故。广增至三千大千世界。此中自说因缘。见般若波罗蜜。与见佛无异

【经】复次世尊。如佛住三事示现说十二部经。修多罗祇夜乃至优婆提舍。复有善男子善女人。受持诵说是般若波罗蜜等无异。何以故。世尊。是般若波罗蜜中。生三事示现及十二部经。修多罗乃至优波提舍故。复次世尊。十方诸佛住三事示现。说十二部经。修多罗乃至优波提舍。复有人受般若波罗蜜。为他人说等无异。何以故。般若波罗蜜中生诸佛。亦生十二部经。修多罗乃至优波提舍。复次世尊。若有供养十方如恒河沙等世界中诸佛。恭敬尊重赞叹华香乃至幡盖。复有人书般若波罗蜜经卷。恭敬尊重赞叹华香乃至幡盖。其福正等。何以故。十方诸佛皆从般若波罗蜜中生。复次世尊。善男子善女人。闻是般若波罗蜜。受持读诵正忆念。亦为他人说。是人不堕地狱道畜生饿鬼道。亦不堕声闻辟支佛地。何以故。当知是善男子善女人。正住阿鞞跋致地中故。是般若波罗蜜。远离一切苦恼衰病。复次世尊。若有善男子善女人。书是般若波罗蜜经卷。受持亲近供养恭敬尊重赞叹。是人离诸恐怖。世尊。譬如负债人。亲近国王供给左右。债主反更供养恭敬是人。是人不复畏怖。何以故。世尊。此人依近国王。凭恃有力故。如是世尊。诸佛舍利是般若波罗蜜薰修故。得供养恭敬。世尊。当知般若波罗蜜如王。舍利如负债人负债人依王故得供养。舍利亦依般若波罗蜜修薰故得供养。世尊。当知诸佛一切种智亦从般若波罗蜜修薰故得成就。以是故。世尊。二分中。我取般若波罗蜜。何以故。世尊。般若波罗蜜中生诸佛舍利三十二相。般若波罗蜜中亦生佛十力四无所畏四无碍智十八不共法大慈大悲。世尊。般若波罗蜜中生五波罗蜜。使得波罗蜜名字。般若波罗蜜中生诸佛一切种智。复次世尊。所在三千大千世界中。若有受持供养恭敬尊重赞叹般若波罗蜜。是处若人若非人。不能得其便。是人渐渐得入涅槃。世尊。般若波罗蜜为大利益。如是于三千大千世界中能作佛事。世尊。所在处。有般若波罗蜜则为有佛。世尊。譬如无价摩尼宝在所住处非人不得其便。若男子若女人有热病。以是珠着身上。热病即时除差。若有风病若有冷病若有杂热风冷病。以珠着身上皆悉除愈。若闇中是宝能令明。热时能令凉。寒时能令温。珠所住处其地不寒不热时节和适。其处亦无诸余毒螫。若男子女人为毒蛇所螫。以珠示之毒即除灭。复次世尊。若男子女人眼痛肤曀盲瞽。以珠示之即时除愈。若有癞疮恶肿。以珠着其身上病即除愈。复次世尊。是摩尼宝所在水中。水随作一色。若以青物裹着水中。水色即为青。若黄赤白红缥物裹着水中。水随作黄赤白红缥色。如是等种种色物裹着水中。水随作种种色。世尊若水浊以珠着中水即为清。是珠其德如是。尔时阿难问释提桓因言。憍尸迦。是摩尼宝为是天上宝。为是阎浮提宝。释提桓因语阿难是天上宝。阎浮提人亦有是宝。但功德相少不具足。天上宝清净轻妙不可以譬喻为比。复次世尊。是摩尼宝若着箧中举珠出。其功德薰箧故人皆爱敬。如是世尊。在所住处。有书般若波罗蜜经卷。是处则无众恼之患。亦如摩尼宝所著处则无众难。世尊。佛般泥洹后。舍利得供养。皆般若波罗蜜力。禅波罗蜜乃至檀波罗蜜。内空乃至无法有法空。四念处乃至十八不共法。一切智法相法住法位法性实际不可思议性一切种智。是诸功德力。善男子善女人作是念。是佛舍利一切智。一切种智。大慈大悲。断一切结使及习。常舍行不错谬法。等诸佛功德住处。以是故。舍利得供养。世尊。舍利是诸功德宝。波罗蜜住处不垢不净。波罗蜜住处不生不灭。波罗蜜不入不出。波罗蜜不增不损。波罗蜜不来不去不住。波罗蜜是佛舍利。是诸法相波罗蜜住处。以是诸法相波罗蜜薰修故。舍利得供养。复次世尊。置三千大千世界满中舍利。如恒河沙等诸世界满其中舍利作一分。有人书般若波罗蜜经卷作一分。二分之中。我取般若波罗蜜。何以故。是般若波罗蜜中生诸佛舍利。是般若波罗蜜修薰故。舍利得供养。世尊。若有善男子善女人。供养舍利恭敬尊重赞叹其功德。报不可得边。受人中天上福乐。所谓刹利大姓婆罗门大姓居士大家。四天王天处乃至他化自在天中受福乐。亦以是福德因缘故。当得尽苦。若受是般若波罗蜜。读诵说正忆念。是人能具足禅波罗蜜。乃至能具足檀波罗蜜。能具足四念处。乃至能具足十八不共法。过声闻辟支佛地。住菩萨位。住菩萨位已。得菩萨神通。从一佛界至一佛界。是菩萨为众生故受身。随其所应成就众生。若作转轮圣王。若作刹利大姓。若作婆罗门大姓成就众生。以是故。世尊。我不为轻慢不恭敬。故不取舍利。以善男子善女人供养般若波罗蜜则为供养舍利故。复次世尊。有人欲见十方无量阿僧祇诸世界中现在诸佛法身色身。是人应闻受持般若波罗蜜读诵正忆念为他人广说。如是善男子善女人。当见十方无量阿僧祇世界中诸佛法身色身。是善男子善女人行般若波罗蜜。亦应以法相修念佛三昧。复次善男子善女人。欲见现在诸佛。应当受是般若波罗蜜乃至正忆念

【论】复次佛住三事示现。说十二部经者。问曰。一切说法人中。无与佛等者。佛说十二部经。则无不备具。云何善男子但受持读诵般若与佛等无异。答曰。此中佛欲称叹般若为大故。于十二部经中般若为最胜。所以者何说是般若波罗蜜。多有发菩萨心。说十二部经。杂发三乘意故。不以菩萨功德比佛无量身。此说法身菩萨但说般若劝导大乘。佛杂说劝导三乘故。等无异。复次三事示现及十二部经根本者。所谓般若波罗蜜是。供养十方如恒河沙等诸佛。若复有供养般若经卷。亦等无异。此中佛说般若。所以福德胜因缘。所谓般若能破一切苦恼衰病怖畏等。如负债人依王。王喻般若。负债人喻舍利。舍利是先世业因缘所成。因缘中应偿诸对。以般若波罗蜜薰修故。宿命因缘诸对。及饥渴寒热所不能得。而得诸天世人所见供养。如负债人依王反为债主所敬。先说无诸衰病及怖畏。以明内。今说摩尼宝人非人不得其便。以明外。是人供养般若波罗蜜故。若今世若后世。若身衰心病尽皆能除。诸善愿事随意能与。得是般若波罗蜜大宝故。无诸怖畏无所乏短。譬如无价宝珠所愿皆得。问曰。摩尼宝珠。于颇梨金银车磲马瑙琉璃珊瑚琥珀金刚等中。是何等宝。答曰。有人言。此宝珠从龙王脑中出。人得此珠毒不能害入火不能烧。有如是等功德。有人言。是帝释所执金钢用。与阿修罗斗时。碎落阎浮提。有人言。诸过去久远佛舍利。法既灭尽舍利变成此珠以益众生。有人言。众生福德因缘故。自然有此珠。譬如罪因缘故地狱中自然有治罪之器。此宝珠名如意。无有定色清彻轻妙。四天下物皆悉照现。如意珠义如先说。是宝常能出一切宝物。衣服饮食随意所欲尽能与之。亦能除诸衰恼病苦等。是宝珠有二种。有天上如意宝。有人间如意宝。诸天福德厚故珠德具足。人福德薄故珠德不具足。是珠所著房舍函箧之中。其处亦有威德。般若波罗蜜亦如是者。如如意宝珠。能与在家人今世富乐随意所欲。般若波罗蜜能与出家求道人三乘解脱乐。随意所愿。如意宝珠在所著处。非人不得其便。般若波罗蜜亦如是。行者心与相应。恶邪罗刹不能入其心中沮坏道意夺智慧命。复次般若波罗蜜所在处。魔若魔民地神夜叉诸恶鬼等不能得便。如宝珠能除四百四病。根本四病风热冷杂。般若波罗蜜亦能除八万四千病。根本四病贪嗔痴等分。淫欲病分二万一千。嗔恚病分二万一千。愚痴病分二万一千。等分病分二万一千。以不净观除贪欲。以慈悲心除嗔恚。以观因缘除愚痴。总上三药或不净或慈悲或观因缘除等分病。如宝珠能除黑闇。般若亦如是能除三界黑闇。如宝珠能除热。般若亦如是能。除淫欲嗔恚热。如宝珠能除冷。般若亦如是能除无明不信不恭敬懈怠等冷心。日月皆诸宝所成。日能作热月能作冷。虽俱利益众生。以不能兼故。不名为如意。宝珠所在处。毒蛇等诸恶虫所不能害。般若亦如是。贪欲等毒所不能病。若有人毒蛇所螫。持宝珠示之即时除愈。有人为贪欲等毒蛇所螫。得般若波罗蜜。贪恚毒即除。如难陀鸯群梨摩罗等。有人眼痛盲瞽以宝珠示之即时除愈。般若波罗蜜亦如是。有人以无明疑悔颠倒邪见等破慧眼。得般若即时明了。如人癞疮痈肿。以宝珠示之即时除愈。般若亦如是。五逆癞罪等得般若即时消灭。如以种种色裹宝珠着水中随作一色。般若亦如是。行者得般若力故。心则柔软无所著。随信手五根等。亦随顺四禅四无量心背舍胜处及一切入。复次于须陀洹斯陀含阿那含阿罗汉辟支佛地。随顺遍学无所违逆。第六缥色者。是虚空色。行者得般若观诸法空。心亦随顺不着。如是等种种者。入一切诸法。皆随顺无碍。如水浑浊杂色不净。以珠着中皆清净一色。般若亦如是。人有种种烦恼邪见戏论扰心浑浊。得般若则清净一色。如如意珠有无量功德。般若功德亦如是。今当别相说般若功德。是如意珠但能除恶鬼。不能坏魔天。般若则能除二事。珠能治身病。般若能治身心病。珠能治人神所治病。般若能治一切天龙鬼神所不能治病。珠能治世世曾所治病。般若能治无始世界来未曾所治病。如是等种种差别。珠能照所住处夜闇。般若能照一切烦恼相应无明黑闇及不共无明一切法中不了痴黑闇。珠但能破所住处热。不能破余处热。般若力乃至无量世界劫尽大火一吹能灭。何况一处热。珠但能除形质火日之热。般若能除三毒心热。珠能除风雨寒雪。般若能除十方无量世界众生不信不恭敬懈怠心等寒。珠能却外毒螫。不能除四大毒蛇。般若能毕竟除此二种毒。珠不能治邪见毒。般若能除。珠能治肉眼。般若能治慧眼。珠能治近见眼。般若能治远见眼。珠能治肉眼。肉眼不作珠。般若能治慧眼。慧眼即作般若。珠能治肉眼后病复发。般若治慧眼毕竟清净。珠能治癞疮恶肿。般若能治身癞心癞。问曰。四种病中摄一切病何以故别说眼痛癞病等。答曰。眼是身中第一所用最贵。是故别说。诸病中癞病最重。宿命罪因缘故难治。是故更说。珠能令水随所裹色。般若能随顺心数善法。珠不能转人心。般若能转一切众生心性所乐所欲。珠能令所著处浊水清非一切水。般若力能令六觉浊心即时清净。又于诸龙王鬼神王人王等。贪恚浊心能令清净。殊能使所著函箧房舍有威德。般若力能度十方无量世界阿僧祇众生。令有威德。珠功德力入函箧。函箧不能与人随意功德。舍利得般若薰修故。有人供养。必还得般若而得成佛。是函箧凡夫之人所贵。舍利凡夫圣人所贵。函箧世间受乐人所贵。舍利出世间世间受乐人所贵。般若是如意宝珠。函箧是舍利。舍利中虽无般若。般若所薰故得供养。复次诸圣法中般若第一。无可譬喻。以世间人贵是宝珠故。以珠为喻。人见如意宝珠所愿皆得。若见珠所住处。亦得少愿。行者亦如是。得是般若波罗蜜义即入佛道。若见般若所住舍利供养故。得今世后世无量福乐久必得道。如是总相别相应当知。问曰。般若若有如是功德者。何以故。说舍利是五波罗蜜乃至一切种智所住处故得供养。答曰。先已说。一切诸法般若波罗蜜为首为明导。譬如王来必有将从。但举其主名。余者已尽得。赞般若波罗蜜。是义先已说

【经】复次世尊。有二种法相。有为诸法相。无为诸法相。云何名有为诸法相。所谓内空中智慧。乃至无法有法空中智慧。四念处中智慧。乃至八圣道分中智慧。佛十力四无所畏四无碍智。十八不共法中智慧。善法中不善法中。有漏法中。无漏法中。世间法中。出世间法中智慧。是名有为诸法法相。云何名无为诸法法相。若法无生无灭无住无异无垢无净无增无减诸法自性。云何名诸法自性。诸法无所有性。是诸法自性。是名无为诸法相。尔时佛告释提桓因。如是如是。憍尸迦。过去诸佛因是般若波罗蜜。得阿耨多罗三藐三菩提。过去诸佛弟子。亦因般若波罗蜜。得须陀洹道乃至阿罗汉辟支佛道。未来现在世十方无量阿僧祇诸佛。因是般若波罗蜜。得阿耨多罗三藐三菩提。未来现在诸佛弟子。亦因般若波罗蜜。得须陀洹道乃至辟支佛道。何以故。般若波罗蜜中广说三乘义。以无相法故。无生无灭法故。无垢无净法故。无作无起不入不出不增不损不取不舍法故。以俗法故。非以第一义。何以故。是般若波罗蜜非此非彼。非高非下。非等非不等。非相非无相。非世间非出世间。非有漏非无漏。非有为非无为。非善非不善。非过去非未来非现在。何以故。憍尸迦。般若波罗蜜不取声闻辟支佛法。亦不舍凡夫法。释提桓因白佛言。世尊。菩萨摩诃萨行般若波罗蜜。知一切众生心。亦不得众生乃至知者见者。亦不得是菩萨。不得色。不得受想行识。不得眼乃至意。不得色乃至法。不得眼触因缘生受乃至意触因缘生受。不得四念处乃至十八不共法。不得阿耨多罗三藐三菩提。不得诸佛法。不得佛。何以故。般若波罗蜜不为得法故出。何以故。般若波罗蜜性无所有不可得。所用法不可得。处亦不可得。佛告释提桓因。如是如是。憍尸迦。如汝所说。菩萨摩诃萨长夜行般若波罗蜜。阿耨多罗三藐三菩提不可得。何况菩萨及菩萨法。尔时释提桓因白佛言。世尊。菩萨摩诃萨但行般若波罗蜜。不行余波罗蜜耶。佛告释提桓因言。憍尸迦。菩萨尽行六波罗蜜法。以无所得故。行檀波罗蜜。不得施者不得受者不得财物。行尸罗波罗蜜。不得戒不得持戒人不得破戒人。乃至行般若波罗蜜。不得智慧不得智慧人不得无智慧人。憍尸迦。菩萨摩诃萨行布施时。般若波罗蜜为作明导。能具足檀波罗蜜。菩萨摩诃萨行持戒时。般若波罗蜜为作明导。能具足尸罗波罗蜜。菩萨摩诃萨行忍辱时。般若波罗蜜为作明导。能具足羼提波罗蜜。菩萨摩诃萨行精进时。般若波罗蜜为作明导。能具足毗梨耶波罗蜜。菩萨摩诃萨行禅时。般若波罗蜜为作明导。能具足禅波罗蜜。菩萨摩诃萨观诸法时。般若波罗蜜为作明导。能具足般若波罗蜜。一切法以无所得故。所谓色乃至一切种智。憍尸迦。譬如阎浮提诸树种种叶种种华种种果种种色其荫无差别。诸波罗蜜入般若波罗蜜中至萨婆若无差别亦如是。以无所得故。释提桓因白佛言。世尊。般若波罗蜜。大功德成就。世尊。般若波罗蜜一切功德成就。世尊。般若波罗蜜无量功德成就。无边功德成就。无等功德成就。世尊。若有善男子善女人。书是般若波罗蜜经卷。恭敬供养尊重赞叹华香乃至幡盖。如般若波罗蜜所说正忆念。复有善男子善女人。书般若波罗蜜经卷与他人。其福何所为多。佛告释提桓因。憍尸迦。我还问汝。随汝意报我。若有善男子善女人。供养诸佛舍利。恭敬尊重赞叹华香乃至幡盖。若复有人分舍利如芥子许。与他人令供养。恭敬尊重赞叹华香乃至幡盖。其福何所为多。释提桓因白佛言。世尊。如我从佛闻法中义。若有善男子善女人。自供养舍利。乃至幡盖。若复有人分舍利如芥子许。与他人令供养。其福甚多。世尊。佛见是福利众生故。入金刚三昧中。碎金刚身作末舍利。何以故。有人佛灭度后。供养佛舍利。乃至如芥子许。其福报无边乃至苦尽故。佛告释提桓因。如是如是。憍尸迦。若善男子善女人。书般若波罗蜜经卷。供养恭敬华香乃至幡盖。若复有人书般若波罗蜜经卷。与他人令学。是善男子善女人其福甚多。复次憍尸迦。善男子善女人。如般若波罗蜜中义。为他人说开示分别令易解。是善男子善女人胜于前善男子善女人功德。所从闻般若波罗蜜。当视其人如佛。亦如高胜梵行人。何以故。当知般若波罗蜜即是佛。般若波罗蜜不异佛。佛不异般若波罗蜜。过去未来现在诸佛。皆从般若波罗蜜中。学得阿耨多罗三藐三菩提及高胜梵行人。高胜梵行人者。所谓阿鞞跋致。菩萨摩诃萨。亦学是般若波罗蜜。当得阿耨多罗三藐三菩提。声闻人亦学是般若波罗蜜。得阿罗汉道。求辟支佛道人。亦学是般若波罗蜜。得辟支佛道。菩萨亦学是般若波罗蜜。得入菩萨位。以是故。憍尸迦。善男子善女人。欲供养现在诸佛。恭敬尊重赞叹华香乃至幡盖。当供养般若波罗蜜。我见是利益。初得阿耨多罗三藐三菩提时作如是念。谁有可供养恭敬尊重赞叹依止住者。憍尸迦。我一切世间中。若天若魔若梵若沙门婆罗门中。不见与我等者。何况有胜者。我自思念。我所得法自致作佛。我供养是法恭敬尊重赞叹。当依止住依是法。何等是法。所谓般若波罗蜜。憍尸迦。我自供养是般若波罗蜜。恭敬尊重赞叹已依止住。何况善男子善女人。欲得阿耨多罗三藐三菩提。而不供养般若波罗蜜恭敬尊重赞叹华香璎珞乃至幡盖。何以故。般若波罗蜜中。生诸菩萨摩诃萨。诸菩萨摩诃萨中生诸佛。以是故。憍尸迦。善男子善女人。若求佛道。若求辟支佛道。若求声闻道。皆应供养般若波罗蜜恭敬尊重赞叹华香乃至幡盖

【论】问曰。何因缘故。说是有为法无为法相。答曰。帝释赞叹般若波罗蜜摄一切法。此中欲说因缘。有为法相。所谓十八空三十七品乃至十八不共法。略说善不善等乃至世间出世间。是名有为法相。何以故。是作相先无今有已有还无故。与上相违即是无为法相。是二法皆般若波罗蜜中摄。有为善法是行处。无为法是依止处。余无记不善法以舍离故不说。此是新发意菩萨所学。若得般若波罗蜜方便力。应无生忍。则不爱行法不憎舍法。不离有为法。而有无为法。是故不依止涅槃。是以经中说般若波罗蜜中。广说三乘用无相法故。无生无灭等。以世谛故作是说。非第一义谛。菩萨行是诸法实相。虽能观一切众生。心亦不得众生。虽能行一切法。亦不得一切法。何以故。以得无所得般若波罗蜜故。佛可其所叹。菩萨常习是行。乃至阿耨多罗三藐三菩提不可得。何况余法。帝释意念。若般若是究竟法者。行人但行般若波罗蜜。何用余法。佛答菩萨行六波罗蜜。以般若波罗蜜用无所得法和合故。此即是行般若波罗蜜。若但行般若不行五法。则功德不具足不美不妙。譬如愚人不识饮食种具闻盐是众味主便纯食盐失味致患。行者亦如是。欲除着心故。但行般若反堕邪见。不能增进善法。若与五波罗蜜和合。则功德具足义味调适。虽众行和合般若为主。若布施等诸法。离般若波罗蜜。则有种种差别。至般若波罗蜜中。皆一相无有差别。譬如阎浮提阿那婆达多池四大河流一大河有五百小川归之俱入大海则失其本名合为一味无有别异。又如树木枝叶华果众色别异荫则无别。问曰。荫亦有差别。树大则荫大。枝叶华果大小种种异形。云何无差别。答曰。蔽光故影现。无光之处即名为荫。荫不以大小异形为义。问曰。行般若波罗蜜。受诵乃至正忆念。此事为难。书持般若经卷。与他人为易。功德尚不应等。云何言胜。答曰。独行读诵正忆念虽难。或以我心故功德小。以经卷与他者有大悲心。作佛道因缘。无吾我故功德为大。如佛问帝释。若人自供养舍利。复有人以舍利与他令供养。其福何所为多。答曰。与他人令供养得福多。以无吾我慈悲心与故。佛虽不用福德。见有如是大利益众生故。是以入金刚三昧自碎其身。问曰若福德在心。佛何用碎身如芥子令人供养答曰。信净心从二因缘生。一者内正忆念。二者外有良福田。譬如有好谷子田又良美所收必多。是故心虽好必因舍利。然后得大果报。佛既可其言。复更自说。有人书写经卷与人。复有人于大众中广解其义。其福胜前。视是人如佛。若次佛。如佛。若次佛义如先说。佛以二种因缘。证般若波罗蜜为胜。一者三世圣人。从中学成圣道。二者我以此法故。得成无上圣。我今还师仰此法。法者诸法实相。所谓般若波罗蜜。憍尸迦。我更无所求。而犹推尊般若供养。何况善男子。不以种种供具供养般若波罗蜜。此中说因缘。般若是菩萨根本因缘。菩萨是诸佛根本因缘。诸佛是一切世间。大利益安乐因缘。是故声闻辟支佛人。欲疾安隐入三解脱门者。犹尚供养般若波罗蜜。何况菩萨。供养具者。所谓以一心听受。乃至正忆念。及以华香。乃至幡盖

大智度论卷第五十九大智度论释挍量法施品第三十八(卷六十)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】佛告释提桓因言。憍尸迦。若有善男子善女人。教一阎浮提人行十善道。于汝意云何。以是因缘故得福多不。答言。甚多世尊。佛言。不如是善男子善女人书持般若波罗蜜经卷与他人令读诵说得福多。何以故。是般若波罗蜜中。广说诸无漏法。善男子善女人从是中学。已学今学当学。入正法位中。已入今入当入。得须陀洹果。已得今得当得。乃至阿罗汉果。求辟支佛道亦如是。诸菩萨摩诃萨求阿耨多罗三藐三菩提。入正法位中。已入今入当入。得阿耨多罗三藐三菩提。已得今得当得。憍尸迦。何等是无漏法。所谓四念处乃至八圣道分。四圣谛内空乃至无法有法空。佛十力乃至十八不共法。善男子善女人。学是法得阿耨多罗三藐三菩提。已得今得当得。憍尸迦。若有善男子善女人。教一人令得须陀洹果。是人得福德。胜教一阎浮提人行十善道。何以故。憍尸迦。教一阎浮提人行十善道。不离地狱畜生饿鬼苦。憍尸迦。教一人得须陀洹果。离三恶道故。乃至阿罗汉果辟支佛道亦如是。憍尸迦。若善男子善女人。教一阎浮提人。令得须陀洹果斯陀含果阿那含阿罗汉辟支佛道。不如善男子善女人教一人令得阿耨多罗三藐三菩提得福多。何以故。憍尸迦。以菩萨因缘故。生须陀洹果乃至阿罗汉辟支佛。以菩萨因缘故生诸佛。以是因缘故。憍尸迦当知。善男子善女人。书般若波罗蜜经卷与他人。令书持读诵说得福多。何以故。是般若波罗蜜中。广说诸善法。是善法中学。便出生刹利大姓婆罗门大姓居士大家四天王天乃至非有想非无想天。便有四念处乃至一切种智。便有诸须陀洹乃至阿罗汉辟支佛。便有诸佛。憍尸迦。置一阎浮提人。若有善男子善女人。教四天下世界中众生。令行十善道。于汝意云何。是人以是因缘故得福多不。答言。甚多世尊。佛言。不如是善男子善女人书般若波罗蜜经卷与他人令书持读诵说得福多。余如上说。憍尸迦。置四天下世界中众生。若教小千世界中众生令行十善道亦如是。憍尸迦。置小千世界中众生。若教二千中世界中众生令行十善道。若有善男子善女人。书般若波罗蜜经卷与他人令书持读诵。是人得福多。余如上说。憍尸迦。置二千中世界中众生。若教三千大千世界中所有众生。令行十善道。复有人书般若波罗蜜经卷与他人。令书持读诵。是人福德多。憍尸迦。置三千大千世界中众生。若教如恒河沙等世界中所有众生。令行十善道。若复有人书般若波罗蜜经卷与他人。令书持读诵其福德多。余如上说。复次憍尸迦。有人教一阎浮提众生。令立四禅四无量心四无色定五神通。于汝意云何。是善男子善女人福德多不。释提桓因言。甚多世尊。佛言。不如是善男子善女人书般若波罗蜜经卷与他人令书持读诵说得福多。何以故。是般若波罗蜜中。广说诸善法。余如上说。憍尸迦。置阎浮提众生。复置四天下世界中众生小千世界中众生二千中世界中众生三千大千世界中众生。憍尸迦。若有人教十方如恒河沙等世界中众生。令立四禅四无量心四无色定五神通。于汝意云何。是人福德多不。答言。甚多世尊。佛言。不如是善男子善女人书般若波罗蜜经卷与他人令书持读诵说得福多。何以故。是般若波罗蜜中。广说诸善法。余如上说。复次憍尸迦。若有善男子善女人。受是般若波罗蜜。书持读诵说正忆念。是人福德胜教阎浮提人行十善道立四禅四无量心四无色定五神通正忆念者。受持亲近般若波罗蜜。乃至正忆念。不以二法。不以不二法。受持亲近禅波罗蜜毗梨耶波罗蜜羼提波罗蜜尸波罗蜜檀波罗蜜。乃至正忆念。不以二法。不以不二法。为阿耨多罗三藐三菩提。正忆念。内空乃至一切种智。不以二法。不以不二法。复次憍尸迦。若有善男子善女人。为他人种种因缘。演说般若波罗蜜义。开示分别令易解。憍尸迦。何等是般若波罗蜜义。憍尸迦。般若波罗蜜义者。不应以二相观。不应以不二相观。非有相非无相。不入不出不增不损不垢不净不生不灭不取不舍不住非不住非实非虚非合非散非着非不着非因非不因非法非不法非如非不如非实际非不实际。憍尸迦。若善男子善女人。能以是般若波罗蜜义。为他人种种因缘演说。开示分别令易解。是善男子善女人。所得福德甚多。胜自受持般若波罗蜜亲近读诵说正忆念。复次憍尸迦。善男子善女人。自受持般若波罗蜜。亲近读诵说正忆念。亦为他人种种因缘。演说般若波罗蜜义。开示分别令易解。是善男子善女人。所得功德甚多。释提桓因白佛言。世尊。善男子善女人。应如是演说般若波罗蜜义开示分别令易解。佛告释提桓因。如是憍尸迦。是善男子善女人。应如是演说般若波罗蜜义开示分别令易解。憍尸迦。善男子善女人。如是演说般若波罗蜜义。开示分别令易解。得无量无边阿僧祇福德。若有善男子善女人。供养十方无量阿僧祇诸佛。尽其寿命随其所须。恭敬尊重赞叹华香乃至幡盖供养。若复有善男子善女人。种种因缘。为他人广说般若波罗蜜义。开示分别令易解。是善男子善女人功德甚多。何以故。诸过去未来现在诸佛。皆于是般若波罗蜜中学。得阿耨多罗三藐三菩提。已得今得当得。复次憍尸迦。若善男子善女人。于无量无边阿僧祇劫。行檀波罗蜜。不如是善男子善女人以般若波罗蜜为他人演说其义开示分别令易解其福甚多。以无所得故。云何名有所得。憍尸迦。若菩萨摩诃萨。用有所得故布施。布施时作是念。我与彼受。所施者物。是名得檀不得波罗蜜。我持戒此是戒。是名得戒不得波罗蜜。我忍辱为是人忍辱。是名得忍辱不得波罗蜜。我精进为是事勤精进。是名得精进不得波罗蜜。我修禅所修是禅。是名得禅不得波罗蜜。我修慧所修是慧。是名得慧不得波罗蜜。憍尸迦。是善男子善女人。如是行者不得具足檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。释提桓因白佛言。世尊。菩萨摩诃萨云何修具足檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。佛告释提桓因。菩萨摩诃萨布施时。不得与者。不得受者。不得所施物。是人得具足檀波罗蜜。乃至修般若波罗蜜时。不得智不得所修智。是人得具足般若波罗蜜。憍尸迦。是为菩萨摩诃萨具足檀波罗蜜乃至般若波罗蜜。善男子善女人。如是行般若波罗蜜。当为他人演说其义。开示分别令易解。禅波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀波罗蜜。演说其义。开示分别令易解。何以故。憍尸迦。未来世当有善男子善女人。欲说般若波罗蜜。而说相似般若波罗蜜。有善男子善女人。发阿耨多罗三藐三菩提心。闻是相似般若波罗蜜失正道。善男子善女人。应为是人具足演说般若波罗蜜义开示分别令易解。释提桓因白佛言。世尊。何等是相似般若波罗蜜。佛言。有善男子善女人。说有所得般若波罗蜜。是为相似般若波罗蜜。释提桓因白佛言。世尊。云何善男子善女人。说有所得般若波罗蜜。是为相似般若波罗蜜。佛言。善男子善女人。说有所得般若波罗蜜。是相似般若波罗蜜者。说色无常作是言。能如是行。是行般若波罗蜜。行者求色无常。是为行相似般若波罗蜜。说受想行识无常作是言。能如是行。是行般若波罗蜜。行者求受想行识无常。是为行相似般若波罗蜜。说眼无常乃至说意无常。说色无常乃至说法无常。说眼界无常色界眼识界无常。乃至说意界法界意识界无常。说地种无常。乃至说识种无常。说眼识界无常。乃至说意识界无常。说眼触无常。乃至说意触无常。说眼触因缘生受无常。乃至说意触因缘生受无常。广说如五众。说色苦。乃至说意触因缘生受苦。说色无我。乃至说意触因缘生受无我。皆如五众说。行者行檀波罗蜜时。为说色无常苦无我。乃至意触因缘生受。说无常苦无我。尸罗波罗蜜乃至般若波罗蜜亦如是。行四禅四无量心四无色定。为说无常苦无我。行四念处为说无常苦无我。乃至行萨婆若时。为说无常苦无我。作如是教。能如是行者。是为行般若波罗蜜。憍尸迦。是名相似般若波罗蜜。复次憍尸迦。若善男子善女人。当来世说相似般若波罗蜜。作是言。汝善男子修行般若波罗蜜。汝修行般若波罗蜜时。当得初地乃至当得十地。禅波罗蜜乃至檀波罗蜜亦如是。行者以相似有所得。以总相修是般若波罗蜜。憍尸迦。是名相似般若波罗蜜。复次憍尸迦。善男子善女人。欲说般若波罗蜜作是言。汝善男子修行般若波罗蜜已。当过声闻辟支佛地。是名相似般若波罗蜜。复次善男子善女人。为求佛道者如是说。汝善男子善女人。修行般若波罗蜜已。入菩萨位。得无生法忍。得无生法忍已。便住菩萨神通。从一佛界至一佛界。供养诸佛恭敬尊重赞叹。如是说者。是名相似般若波罗蜜。复次憍尸迦。善男子善女人。为求佛道者如是说。汝善男子善女人。学是般若波罗蜜。受持读诵说正忆念。当得无量无边阿僧祇功德。如是说者。是名相似般若波罗蜜。复次善男子善女人。为求佛道者说。如过去未来现在诸佛功德善本。从初发心至成得佛。都合集回向阿耨多罗三藐三菩提。如是说者。是名相似般若波罗蜜。释提桓因白佛言。世尊。云何善男子善女人。为求佛道者。不说相似般若波罗蜜。佛言。若善男子善女人。为求佛道者。说般若波罗蜜。善男子善女人。汝修行般若波罗蜜。莫观色无常。何以故。色色性空。是色性非法。若非法即名为般若波罗蜜。般若波罗蜜中。色非常非无常。何以故。是中色尚不可得。何况常无常。憍尸迦。善男子善女人。如是说者。是名不说相似般若波罗蜜。受想行识亦如是。复次憍尸迦。善男子善女人。为求佛道者说。汝善男子善女人修行般若波罗蜜。于诸法莫有所过莫有所住。何以故。般若波罗蜜中。无有法可过可住。所以者何。一切法自性空。自性空是非法。若非法即是为般若波罗蜜。般若波罗蜜中。无有法可入可出可生可灭。憍尸迦。是善男子善女人如是说。是名不说相似般若波罗蜜。广说如上。与相似相违。是名不说相似般若波罗蜜。如是憍尸迦。善男子善女人。应如是演说般若波罗蜜义。若如是说般若波罗蜜义。所得功德胜于前者

【论】者言。佛更欲以异门明般若波罗蜜胜故。问帝释言。若有人教一阎浮提人行十善道。其福多不。如经中广说。此中说所以胜因缘。所谓般若波罗蜜。广说诸无漏法。成三乘道入涅槃。不复还十善道。但善有漏法。受世间无常福乐。还复堕苦是故不如。复次先是世间法。后是出世间法。先是能生生死法。后是能灭生死法。先是无常乐因缘。后是常乐因缘。先是凡夫圣人共法。后但是为圣人法。如是等差别。无漏法者。三十七品十八不共法。乃至无量诸佛法。欲令是事了了易解故更说因缘。所谓教一人。令得须陀洹果得大福德。胜于教阎浮提人行十善道。虽行十善未免三恶道故。乃至得阿罗汉辟支佛道亦如是。佛更说譬喻。若有人教一阎浮提人。令得声闻辟支佛道。不如有人教一人令得阿耨多罗三藐三菩提是人得福多。何以故。须陀洹至辟支佛。皆从菩萨生故。是般若波罗蜜中。种种说佛道因缘。是故书般若波罗蜜经卷与人。胜以十善教四天下乃至如恒河沙等世界。复次教阎浮提人。乃至恒河沙等世界人。令行四禅等乃至五神通亦如是。但四禅等是离欲人。与十善差别。复次若有人教一阎浮提人。乃至如恒河沙世界。令行十善道四禅四无量心四无色定五神通。不如是人受持般若波罗蜜读诵说正忆念得福多。得福多者。上以般若经卷与他人。今自行般若为异。先十善道乃至五神通别说。今合说。问曰。何以不解受持读诵说。但解正忆念。答曰。受持读诵说福德多。以正忆念能具二事。所谓福德智慧。是故别说。如人采药草乃至合和而未服之于病无损服乃除病。正忆念如服药病愈。是故但解正忆念。正忆念相。所谓非二非不二。行般若波罗蜜。二不二义如先说。初以书经卷胜舍利。中以经卷与人。胜教人行十善乃至五通。今受持读诵说。于受持边正忆念最胜今如诸佛怜愍众生故。为解其义令易解。胜自行正忆念。是时佛欲广分别福德故说言。若有人尽形寿。供养十方佛。不如为他解说般若义。此中说胜因缘。三世诸佛皆学是般若。成无上道。复次若菩萨。于无量劫。行六波罗蜜。以有所得故。不如为人解说般若波罗蜜。有所得者。所谓以我心于诸法中取相故。佛更欲说般若正义故。答帝释。菩萨以无所得。行六波罗蜜则得具足。具足即是般若波罗蜜正义。有人未来世。说相似般若者。会中人闻说正忆念作是思惟。何者是邪忆念。是故说相似般若波罗蜜相。如人知是道非道故。能舍非道行正道。复次怜愍未来世众生。不见佛及诸大菩萨。但见经书。邪忆念故堕着音声。说相似般若波罗蜜。相似者。名字语言同而心义异。如以着心取相。说五众等无常乃至无生无灭。是相似般若。若以不着心不取相说五众无常。但为破常颠倒故。不着无常是真实般若。如是说法。人教舍相似般若波罗蜜。修习真般若波罗蜜。是名说般若波罗蜜正义。胜前功德

【经】复次憍尸迦。阎浮提中所有众生。皆教令得须陀洹。于汝意云何。是人得福多不。答言。甚多世尊。佛言。不如是善男子善女人以般若波罗蜜为他人。种种因缘演说其义开示分别令易解。如是言。善男子。汝来受是般若波罗蜜。勤读诵说正忆念。如般若波罗蜜中所说行。何以故。是般若波罗蜜中。出生诸须陀洹。憍尸迦。置阎浮提中众生。复置四天下众生小千世界二千中世界三千大千世界中众生。若有人教十方如恒河沙等世界中众生。尽教令得须陀洹。于汝意云何。是人得福多不。答言。甚多世尊。佛言。不如是善男子善女人以般若波罗蜜为他人种种因缘演说其义开示分别令易解。如是言。善男子汝来受是般若波罗蜜。勤读诵说正忆念。如般若波罗蜜中所说行。何以故。般若波罗蜜中。出生诸须陀洹。复次憍尸迦。若有善男子善女人。教阎浮提中人。令得斯陀含阿那含阿罗汉。于汝意云何。是人得福多不。答言。甚多世尊。佛言。不如是善男子善女人以般若波罗蜜为他人种种因缘演说其义开示分别令易解。如是言。汝来善男子。受是般若波罗蜜。勤读诵说正忆念。如般若波罗蜜中所说行。何以故。般若波罗蜜中。出生诸斯陀含阿那含阿罗汉故。乃至教十方如恒河沙等世界中众生亦如是。复次憍尸迦。若善男子善女人教一阎浮提中众生。令得辟支佛道。于汝意云何。是人得福多不。答言。甚多世尊。佛言。不如善男子善女人以般若波罗蜜为他人种种因缘演说其义开示分别令易解。如言是汝来善男子受是般若波罗蜜。勤读诵说正忆念。如般若波罗蜜中所说行。何以故。般若波罗蜜中。出生诸辟支佛道故。四天下乃至十方如恒河沙等世界中众生亦如是。复次憍尸迦。善男子善女人。教一阎浮提中众生。令发阿耨多罗三藐三菩提心。于汝意云何。是人得福多不。答言。甚多世尊。佛言。不如是善男子善女人以般若波罗蜜为他人种种因缘演说其义开示分别令易解。如是言。汝当随般若波罗蜜中学。当得一切智法。汝若得一切智法。汝便得修行般若波罗蜜增益具足。若得修行般若波罗蜜增益具足。汝当得阿耨多罗三藐三菩提。何以故。憍尸迦。般若波罗蜜中。生诸初发意菩萨摩诃萨故。乃至十方如恒河沙等世界亦如是。复次憍尸迦。善男子善女人。教一阎浮提中众生。令住阿鞞跋致地。于汝意云何。是人得福多不。答言。甚多世尊。佛言。不如是善男子善女人以般若波罗蜜为他人种种因缘演说其义开示分别令易解如是言。汝来善男子。受是般若波罗蜜。乃至如般若波罗蜜中所说行。汝便得一切智法。得一切智法已。乃至便得阿耨多罗三藐三菩提。何以故。般若波罗蜜中。生诸菩萨摩诃萨阿鞞跋致地故。乃至十方如恒河沙等世界亦如是。复次憍尸迦。一阎浮提中众生。发意求阿耨多罗三藐三菩提若有。善男子善女人。为是人演说般若波罗蜜。及其义解开示分别。如是言。汝来善男子。受是般若波罗蜜。乃至如般若波罗蜜中所说行。学已汝当得阿耨多罗三藐三菩提。复有人为一阿鞞跋致菩萨。演说般若波罗蜜及其义解开示分别。如是言。善男子汝来受是般若波罗蜜。乃至如般若波罗蜜中所说行。学已汝当得阿耨多罗三藐三菩提。是善男子所得功德甚多。乃至十方如恒河沙等世界中亦如是。复次憍尸迦。若有一阎浮提中众生。皆得阿鞞跋致阿耨多罗三藐三菩提。复有善男子善女人。以般若波罗蜜。为是人演说其义。于是中有一菩萨疾得阿耨多罗三藐三菩提。若有善男子善女人。为是菩萨演说般若波罗蜜及其义解。是人功德最多。乃至十方如恒河沙等世界亦如是。释提桓因白佛言。世尊。如菩萨摩诃萨。转转近阿耨多罗三藐三菩提者。如是应转转教行檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。应教内空乃至无法有法空四念处乃至八圣道分佛十力四无所畏四无碍智十八不共法。亦应供养衣服卧具饮食汤药随其所须。是善男子善女人法施财施。供养是菩萨。所得功德胜于前者。何以故。世尊。是菩萨摩诃萨疾得阿耨多罗三藐三菩提故。尔时慧命须菩提语释提桓因言。善哉善哉。憍尸迦。汝为圣弟子。安慰诸菩萨摩诃萨。为阿耨多罗三藐三菩提者。以法施财施。利益法应尔。何以故。菩萨中生诸佛圣众。若菩萨不发阿耨多罗三藐三菩提心者。是诸菩萨不能学六波罗蜜乃至十八不共法。若不学六波罗蜜乃至十八不共法者。不能得阿耨多罗三藐三菩提。若不能得阿耨多罗三藐三菩提者。则无声闻辟支佛。以是故。憍尸迦。诸菩萨摩诃萨。学六波罗蜜乃至十八不共法。学六波罗蜜乃至十八不共法时。得阿耨多罗三藐三菩提。得阿耨多罗三藐三菩提故。断地狱畜生饿鬼道。世间便有刹利大姓婆罗门大姓居士大家四天王天乃至非有想非无想天。便有檀波罗蜜尸罗羼提毗梨耶禅波罗蜜般若波罗蜜。内空乃至无法有法空。四念处乃至十八不共法出现于世。声闻辟支佛乘佛乘。皆现于世

【论】者言。教阎浮提人乃至如恒河沙等世界中人。令得声闻辟支佛道。不如为他人演说般若波罗蜜义。此中说因缘。是诸贤圣皆从般若波罗蜜中出故。般若波罗蜜。是诸法实相。正遍知名为佛。小不如是大菩萨。辟支佛阿罗汉。转不如是阿那含斯陀含须陀洹爱念供养能知诸法实相者。是天王人王等世间福德人。是故常说般若波罗蜜。出生诸贤圣刹利大姓乃至一切诸天。复次教一阎浮提乃至恒河沙等世界中人发无上道乃至阿鞞跋致不如为一阿鞞跋致人解说般若波罗蜜正义。问曰。上说凡夫法。二乘法不如可尔。今说教人发无上道得阿鞞跋致。是佛道事。何故不如。答曰。说般若正义有二种。一者生死肉身菩萨。二者出三界不生不死法性生身菩萨。是菩萨但说过阿鞞跋致菩萨事。所谓教化众生净佛世界。分别一切众生三世无量劫心行业因缘。分别诸世界起灭成败劫数多少大慈大悲一切智等无量诸佛法。为是一人说法。胜教阎浮提乃至如恒河沙世界众生令发心。又复至阿鞞跋致。从阿鞞跋致已上。至佛道中间。更有一人近佛道。疾欲成佛。教是人般若波罗蜜正义者。其福最多。何以故。福田大故福德亦大。譬如供养一切十方如恒河沙等世界圣人乃至欲坐道场。菩萨不如供养一佛。譬如犯于太子得罪。过犯一切人。若供养太子得恩。胜于供养一切凡人。若犯国王得罪。过于犯太子。若供养国王。胜于供养太子如是教化供养。疾近作佛菩萨。胜于供养教如恒河沙等阿鞞跋致菩萨功德。所以者何。福田深厚。其法能令众生增长故。尔时帝释知是法力大故。白佛言。菩萨转转近无上道。如是应教化供养功德转多。尔时须菩提赞帝释言。善哉。善哉。汝能安慰劝进诸菩萨为阿耨多罗三藐三菩提者。以财法二施。财施者。供养具衣食等。法施者。所谓教六波罗蜜等。帝释得道故。名为圣弟子。圣弟子法。应安慰劝进诸菩萨。是中说因缘。是诸圣众。皆从菩萨中出。何以故。若菩萨不行六波罗蜜。不成无上道。则无须陀洹乃至辟支佛菩萨因缘故。十善道乃至无量佛法出现于世。是故三恶道断。有刹利大姓乃至诸佛出现于世。是故菩萨说般若波罗蜜正义。教近佛道福德最大

大智度论卷第六十大智度论释随喜回向品第三十九(卷六十一)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】尔时弥勒菩萨摩诃萨。语慧命须菩提。有菩萨摩诃萨随喜福德。与一切众生共之。回向阿耨多罗三藐三菩提。以无所得故。若声闻辟支佛福德。若一切众生福德。若布施若持戒若修定若随喜。是菩萨摩诃萨随喜福德。与一切众生共之。回向阿耨多罗三藐三菩提。其福最上第一最妙无上无与等者。何以故。声闻辟支佛。及一切众生。布施持戒修定随喜。为自调为自净为自度故。所谓四念处乃至八圣道分空无相无作。菩萨随喜福德。回向阿耨多罗三藐三菩提。持是功德为调一切众生。为净一切众生。为度一切众生故起。尔时慧命须菩提白弥勒菩萨言。诸菩萨摩诃萨念十方无量无边阿僧祇世界中无量无边阿僧祇诸灭度佛。是佛从初发心。至得阿耨多罗三藐三菩提。乃至入无余涅槃。乃至法尽。于其中间诸善根。应六波罗蜜。及诸声闻人善根。若布施福德持戒福德修定福德。及诸学人无漏善根。无学人无漏善根。诸佛戒众定众慧众解脱众解脱知见众。一切智大慈大悲。及余无量阿僧祇诸佛法。及诸佛所说法。是法中学得须陀洹果。乃至得阿罗汉果辟支佛道。入菩萨摩诃萨位。及余众生种诸善根。是诸善根一切和合随喜福德。回向阿耨多罗三藐三菩提。最上第一最妙无上无与等者。如是随喜已。持是随喜福德。回向阿耨多罗三藐三菩提。若有善男子行菩萨乘者作是念。我是心回向阿耨多罗三藐三菩提。是生心缘事。若善男子。取相回向阿耨多罗三藐三菩提。如所念可得不。弥勒菩萨语须菩提。是善男子行菩萨乘。回向阿耨多罗三藐三菩提。心是缘事。若善男子取相。不得如所念。须菩提语弥勒菩萨。若诸缘诸事无所有。是善男子行菩萨乘者。取相于十方诸佛诸善根。从初发心乃至法尽。及声闻辟支佛诸善根。学无学善根。一切和合随喜功德。回向阿耨多罗三藐三菩提。以无相故。是菩萨将无颠倒。无常谓常。想颠倒心颠倒见颠倒。不净谓净。苦谓乐。无我谓我。想颠倒心颠倒见颠倒。若如缘如事。阿耨多罗三藐三菩提亦如是。回向心亦如是。檀波罗蜜尸罗羼提毗梨耶禅般若波罗蜜乃至十八不共法亦如是。若尔者。何等是缘何等是事。何等是阿耨多罗三藐三菩提。何等是善根。何等是随喜心。回向阿耨多罗三藐三菩提

【论】释曰。先七品中。佛命须菩提令说般若。中间帝释多问。多说功德事。今弥勒顺佛本意。还欲令须菩提因随喜法。广说般若波罗蜜。复次帝释闻上供养般若以华香妓乐幡盖之具得福甚多。深自庆幸。此供养具唯我等能办非出家人所有。是故弥勒欲抑其自多之情故语须菩提。菩萨但以心随喜。则胜声闻辟支佛一切众生布施等及诸无漏功德。何况华香供养经卷等。菩萨摩诃萨义如先说。随喜福德者。不劳身口业作诸功德。但以心方便见他修福。随而欢喜作是念。一切众生中。能修福行道者最为殊胜。若离福德人与畜生同行三事。三事者。淫欲饮食战斗。能修行福德行道之人。一切众生所共尊重爱敬。譬如热时清凉满月无不乐仰。亦如大会告集。伎乐肴馔无不毕备。远近诸人咸共欣赴。修福之人亦复如是。福德有二种乐因缘。世间出世间。出世间者。诸无漏法虽无福报。能生福德故名福德。是故有漏无漏通名福德。复次福德是菩萨摩诃萨根本能满所愿。一切圣人所赞叹。无智人所毁呰。智人所行处。无智人所远离。是福德因缘故。作人王转轮圣王天王阿罗汉辟支佛诸佛世尊。大慈大悲十力四无所畏一切种智自在无碍皆从福德中生。如是等种种福德。得正见故随而欢喜。复次菩萨自念。我应与一切众生乐。而众生能自行福德。是故心生欢喜。复次一切众生。行善与我相似。是我同伴。是故随喜。诸菩萨摩诃萨。于十方三世诸佛及菩萨声闻辟支佛。及一切修福众生布施持戒修定慧。于此福德中。生随喜福德。是故名随喜。持是随喜福德。共一切众生。回向阿耨多罗三藐三菩提。共一切众生者。是福德不可得与一切众生。而果报可与。菩萨既得福德果报。衣服饮食等世间乐具。以利益众生。菩萨以福德清净。身口人所信受。为众生说法。令得十善道四禅等。与作后世利益。末后成佛得福德果报。身有三十二相八十种随形好无量光明。观者无厌无量。清净梵音柔和无碍解脱等诸佛法。于三事示现。度无量阿僧祇众生。般涅槃后碎身舍利与人供养。久后皆令得道。是果报可与一切众生。以果中说因故。言福德与众生共。若福德可以与人者。诸佛从初发心。所集福德尽可与人。然后更作善法体。不可与人今直以无畏无恼施与众生用无所得故者义如先说。是名菩萨摩诃萨随喜福德比一切声闻辟支佛及众生三种福德中。最胜最上第一最妙无上无与等。义如先说。是中说胜因缘。是二乘福德。皆为自调自净自度。持戒者是自调修。禅者是自净。智慧者是自度。复次自调者。正语正业正命。自净者。正念正定。自度者。正见正思惟正方便。复次布施因缘故自调。持戒因缘故自净。修定因缘故自度。修定者。是无漏法近因缘。无漏者。所谓三十七品三解脱门等。布施持戒远故不解。菩萨随喜福德虽无勤劳。为度一切众生故胜。问曰。实不度一切众生。何以言度一切众生。故胜。答曰。诸佛菩萨功德力。能度一切众生。但以众生无和合因缘故。譬如大火常有烧力。但以薪不近故不得烧。近则能烧。尔时须菩提。以毕竟空智慧。难问弥勒菩萨。念诸佛福德随喜。回向无上道。是所念过去事。是事如所念不。弥勒以二因缘故。答言。不也。一者过去无量阿僧祇劫诸佛久已灭度无复遗余。菩萨或无宿命智。或有而不能及。但以如所闻忆想分别故。不如所念。二者诸佛及功德。出三界出三世。断戏论语言道。如涅槃相毕竟空清净。随喜者。分别诸佛及诸弟子善根功德。是回向心及无上道非实故言不也。须菩提难言。若无是事是菩萨忆念分别应堕颠倒。若是事毕竟空清净相。忆念亦如是。诸过去佛功德亦如是。无分别无异。云何得随喜。是略说义。广则如经说。所谓须菩提问弥勒。若菩萨摩诃萨。忆念过去十方无量无边阿僧祇世界中诸灭度佛者。是菩萨欲起随喜福德。佛是福德主。是故念佛。闻经书说。有过去佛名故。因是名广念一切过去诸佛。从初发心者。初发心作愿。我当度一切众生。是心相应三善根。不贪不嗔不痴善根。相应诸善法及善根所起身心口业和合是法名为福德。从初发心行六波罗蜜。入菩萨位得十地。乃至坐道场。是中菩萨自修福德。和合得佛道。乃至入无余涅槃。灭度后舍利及遗法。皆是佛自身功德和合。因诸佛大乘人。行六波罗蜜相应福德。相应者。除六波罗蜜。余菩萨所行法。皆摄入六波罗蜜中故。说应六波罗蜜和合。若求声闻辟支佛人。种布施持戒修定等福德。声闻辟支佛人有二种。一者漏尽名为无学。二者得道。漏未尽名为学。是二人诸福德中。善根胜故但说善根。上言求二乘人者。总凡夫圣人。今学无学者纯是圣人。相好是无记色法。非是善功德故但说佛。五无学众大慈大悲佛法义。如初品中说。诸佛所说法。学是法得须陀洹果。乃至入菩萨位者。是佛灭度后。遗法中得道。是故重说。及余众生种诸善根者。此是佛在世及遗法中。天人乃至畜生。种福德因缘。是上四段福德。行者心遍缘。忆念随喜求佛道故回向。名无上随喜最上无与等。问曰。求佛道者。何以不自作功德而心行随喜。答曰。诸菩萨以方便力。他勤劳作功德。能于中起随喜者福德胜自作者。复次是随喜福德。即是实福德。所以者何。念过去佛即是念佛三昧。亦是六念中。念佛念法念僧念戒念舍念天等。因行清净戒入禅定。起毕竟智慧和合故。能起正随喜。是故不但随喜而已。亦行是实法。是心回向者。即是随喜心。缘者随喜心所缘。所谓一切诸佛。及一切众生所作功德。事者若是所缘之本。福德是缘功德所住处。所谓诸佛及众生。并土地山林精舍住处皆名事。如所念可得不。弥勒答言不也。须菩提语弥勒。若诸事诸缘无所有者。云何不堕颠倒。颠倒者四颠倒。三种分别。此颠倒是譬喻。无佛而忆想念佛。犹如无常而念常不净而念净。问曰。见为诸颠倒本。如得初道人。能起想心颠倒。无见颠倒。以见谛道断故。答曰。是颠倒生时异断时异。生时想在前。次是心。后是见。断时先断见。见谛所断故。颠倒体皆是见相见谛所断。想心颠倒者。学人未离欲。忆念忘故取净相。起结使还得正念即时灭。如经中譬喻。如渧水堕大热铁上即时消灭。小错故假名颠倒。非实颠倒。是故说凡夫人三种颠倒学人二种颠倒。复次诸缘诸事如实。毕竟空念亦空。菩提亦空。随喜心亦空。檀波罗蜜乃至十八不共法亦空。若诸法一相。所谓无相。此中何等是缘。何等是事。何等是心。回向无上道

【经】弥勒菩萨语须菩提。若诸菩萨摩诃萨久行六波罗蜜。多供养诸佛种善根。与善知识相随善学自相空法。是诸菩萨是缘是事。诸佛诸善根随喜。福德不取相。回向阿耨多罗三藐三菩提。以不二法非不二法。非相非不相。非可得法非不可得法。非净非垢不生不灭法。是名回向阿耨多罗三藐三菩提。若诸菩萨不久行六波罗蜜。不多供养诸佛。不种善根。不与善知识相随。不善学自相空法。是诸菩萨是诸缘是诸事。诸佛诸善根随喜福德诸心取相。回向阿耨多罗三藐三菩提。是不名回向。须菩提。如是般若波罗蜜义。乃至一切种智义。所谓内空乃至无法有法空。不应为新学菩萨说。何以故。是菩萨所有少许信乐恭敬清净心皆亡失。当在阿鞞跋致菩萨摩诃萨前说。若有为善知识所护。若久供养诸佛种诸善根。应为是人说。如是般若波罗蜜义。乃至一切种智义。所谓内空乃至无法有法空。是人闻是法。不没不惊不畏不怖。须菩提。菩萨摩诃萨随喜福德。应如是回向阿耨多罗三藐三菩提。所谓菩萨用心随喜功德。回向阿耨多罗三藐三菩提。是心尽灭变离。是缘是事。是诸善根。亦尽灭变离。是中何等是随喜心。何等是诸缘。何等是诸事。何等是诸善根。随喜回向阿耨多罗三藐三菩提。二心不俱是心性亦不可得回向。菩萨云何随喜心。回向阿耨多罗三藐三菩提。若菩萨摩诃萨行般若波罗蜜时。如是知是。般若波罗蜜无有法。乃至檀波罗蜜亦无有法。色无有法。受想行识。乃至阿耨多罗三藐三菩提无有法。菩萨摩诃萨。应如是随喜功德回向阿耨多罗三藐三菩提。若能如是回向。是名随喜功德回向阿耨多罗三藐三菩提

【论】释曰。弥勒意。以诸法甚深随喜心微妙。所谓不坏诸法相。而随喜心。回向无上道。是事甚难。凡夫人心刚强。不能行是法。是故弥勒答言。若行者久修六波罗蜜。诸功德深厚故不动所谓能信能行。多供养诸佛。种善根故。集无量无边阿僧祇功德。结使折损其心柔软此是先世因缘。今世得好师好同学。亦自学诸法实相空。巧方便故不着是空。如是等种种无量因缘故。诸法虽无相而能起随喜心。回向无上道。譬如铁虽坚[革*卬]入炉则柔软随作何器。菩萨心亦如是。久行六波罗蜜。善知识所护故其心调柔。过去诸佛诸缘诸事诸善根中不取相。能起随喜心用无相。回向无上道。无相者。能用不二非不二乃至不生不灭等。与上相违者。是名不能回向。弥勒知须菩提乐说空故语言如是。般若波罗蜜随喜义。不应新学菩萨前说。何以故。若有少福德善根者。闻是毕竟空法。即着空作是念。若一切法毕竟空无所有者。我何为作福德。则忘失善业。以是故。新发意菩萨。先教取相随喜。渐得方便力。尔乃能行无相随喜。譬如鸟子羽翼未成不可逼令高翔六翮成就则能远飞。阿鞞跋致菩萨。入法位得法忍能信能行故可为说。若有久行六波罗蜜。与善知识相随。内福德外因缘力助。虽非阿鞞跋致能信能行。是二种人。闻是心清净欢喜信受。如久饥渴者得好饮食。如大热得凉大寒得温。其心爱乐欢喜。是二菩萨亦如是。得是无相智慧作是念。我因是智慧。能度无量众生。何况有惊惧恐怖。恐怖从我心中出。是法中诸法相尚空。何况有我而决定取诸法相。闻一切法无相则生惊惧。是说随喜义体竟后。当更以种种异门释上事。复次须菩提。菩萨应如是思惟。用是心回向无上道。是心念念尽灭变离无有住时。是诸缘事。所谓过去诸佛。及诸善根。诸佛等诸缘事久已灭。随喜心今灭既灭无异。是故经中说。用是心回向。是心即尽灭。如是等入过去世故。入诸法实相故。无有分别是心是缘是事是善根等。若能如是回向。是为正回向。复次一时二心不和合。随喜心时无菩提心。一切心相毕竟空。不可以取相回向。何以故。菩萨知般若波罗蜜。空无有定法。如般若波罗蜜。一切法乃至无上道亦如是。是时断法爱舍着心于空无诤。是名菩萨正回向

【经】尔时释提桓因语须菩提。新发意菩萨。闻是事将无惊惧怖畏。须菩提。云何新发意菩萨。作诸善根回向阿耨多罗三藐三菩提。复云何随喜福德。回向阿耨多罗三藐三菩提。须菩提语释提桓因。若新发意菩萨。行般若波罗蜜。不受是般若波罗蜜。以无所得故。无相故。乃至檀波罗蜜亦如是。多信解内空。乃至多信解无法有法空。多信解四念处乃至十八不共法。常与善知识相随。是善知识为说六波罗蜜义。开示分别如是教授。令常不离般若波罗蜜。乃至得入菩萨法位。终不离般若波罗蜜。乃至不离檀波罗蜜。不离四念处乃至十八不共法。亦教语魔事。闻种种魔事已不增不减。何以故。是菩萨摩诃萨。不受一切法故。是菩萨亦常不离诸佛。乃至得菩萨位。于中种善根。以是善根故。生菩萨家。乃至得阿耨多罗三藐三菩提。终不离是善根。复次新发意菩萨摩诃萨。于过去十方无量无边阿僧祇世界中诸佛。断生死道断诸戏论道。尽弃重担灭聚落刺断诸有结。正智得解脱。及弟子所作功德。于中若刹利大姓婆罗门大姓居士大家四天王天乃至净居天所种善根。是一切和合称量以。随喜心最上第一最妙无上无与等者。回向阿耨多罗三藐三菩提。尔时弥勒菩萨语须菩提。若新发意菩萨摩诃萨。念诸佛及弟子诸善根随喜功德。最上第一最妙无上无与等者。随喜已应回向阿耨多罗三藐三菩提。云何菩萨不堕想颠倒心颠倒见颠倒。须菩提言。若菩萨摩诃萨念诸佛及僧。于中不生佛想。不生僧想。无善根想。用是心回向阿耨多罗三藐三菩提。是心中亦不生心想。菩萨如是回向。想不颠倒。心不颠倒。见不颠倒。若菩萨摩诃萨。念诸佛及僧善根取相。取相已回向阿耨多罗三藐三菩提。菩萨如是名为想颠倒心颠倒见颠倒。若菩萨摩诃萨。用是心念诸佛及僧诸善根。是心念时即知尽灭。若尽灭是法。不可得回向。所用回向心亦是尽灭相。所回向处法亦如是相。若如是回向。是名正回向。非邪回向。菩萨摩诃萨。应如是回向阿耨多罗三藐三菩提。复次若菩萨摩诃萨。过去诸佛善根。及弟子善根。是中凡夫人。闻法种善根。若诸天龙夜叉揵闼婆阿修罗迦楼罗紧那罗摩睺罗伽。闻法种善根。若刹利大姓婆罗门大姓居士大家四天王天。乃至阿迦尼吒天。闻法种善根。发阿耨多罗三藐三菩提心。是一切福德和合称量随喜功德。最上第一最妙无上无与等者。回向阿耨多罗三藐三菩提。是时菩萨若如是知是诸法尽灭所回向处。法亦自性空。能如是回向。是名真回向阿耨多罗三藐三菩提。复次若菩萨如是知无有法。能回向法。何以故。一切法自性空故。若如是回向。是名正回向阿耨多罗三藐三菩提。如是菩萨摩诃萨。行般若波罗蜜乃至檀波罗蜜。不堕想颠倒心颠倒见颠倒。何以故。菩萨不着是回向。亦不见以诸善根回向菩提心处。是名菩萨摩诃萨无上回向。【论】问曰。新发意菩萨。闻是事将无怖畏惊惧者耶。此义先已问答。今何以复问。答曰。上弥勒虽语须菩提。不应为新学说。可为阿鞞跋致及久行者说。是二种人闻能信行。已说正回向因缘。而犹说空法。是故帝释疑言。是众中有新发意者。云何更说使不恐怖。须菩提欲成弥勒所说。欲令新发意者应正回向故答帝释。若新发意菩萨。虽不久行六波罗蜜不供养诸佛。而以利根得善知识。是二因缘故。堪任正回向。是故语帝释。新发意菩萨。行般若波罗蜜。不受是般若。以无所得故。毕竟空故。般若波罗蜜。亦不得亦不着。乃至檀波罗蜜亦如是。多信解内空者。常修乐入观内空三昧故信解。乃至十八不共法。多信解亦如是。善知识相如先说。此中但明能随六波罗蜜义说。闻是义已。常不离般若波罗蜜。乃至得入菩萨法位。有久行入菩萨位。有新发意入菩萨位。复次是新发意菩萨。善知识为说魔事。闻魔事已不增不减。以善修习诸法实相故。若魔欲破为欲破空空则无破。若有增益如幻如梦何所增益。是故说不增不减。是因缘故常不离诸佛。常生菩萨家。世世不离善根乃至无上道。是新发意菩萨。得如是因缘。与久发意无异。复次随喜回向。所谓新发意菩萨。于过去十方无量阿僧祇世界中诸佛断道者。断生死道入无余涅槃。诸戏论断故。言灭诸戏论。以空空等三昧。舍八圣道分故言道尽。五众能生苦恼故。是重担五众。有二种舍。一者有余涅槃中。舍五众因缘诸烦恼。二者入无余涅槃中。舍五众果。一切白衣舍名为聚落。出家人依白衣舍活。而白衣舍有五欲刺。为食故来入恶刺果林。以取果故为刺所刺。如人着木屐践刺。刺则摧折。如是诸佛以禅定智慧屐。摧五欲刺名灭断下五分结。有分结尽。名断上分五结。诸法实相金刚三昧相应智慧。断一切烦恼及习故。言正智得解脱。如是等皆名赞叹过去诸佛及弟子所作功德者。佛弟子有三种。菩萨辟支佛声闻。刹利大姓乃至净居天。是中种善根者。是四种福田。因是种福德处。是福德和合称量。随喜心最上无与等。回向无上道。是回向心作正非邪。所以者何。今弥勒问须菩提。若新发意菩萨。念诸佛等功德。回向无上道。云何不堕颠倒。须菩提答。若是菩萨以般若波罗蜜方便力故。于诸佛不生佛想及弟子想。诸善根中不生善根想。一切法从和合生。无有自性故。无有定法。名为佛。是故不生佛等想。是回向心亦不生心想。是故菩萨不堕颠倒。与上相违即堕颠倒。复次菩萨以是心念。诸佛等及诸善根。是心尽时即知尽。尽心不得回向。何以故。变失灭坏故。是心亦入无常门到法性中。法性中无有分别是心是非心是佛是弟子是善根是无上道。回向心回向处尽相亦如是。初心是忆念过去诸佛等随喜功德。后心是回向心。若如是回向。是名正回向。问曰。初心后心是生灭相可无常。所回向处法。是无上道。在未来世中。云何言尽灭。答曰。汝不闻我先答。入无常门到法性中。此中不说尽是无常。但说诸法实相是尽。先亦说阿耨多罗三藐三菩提出三世过三界无受相。能如是回向者。是为正回向。复次非正非邪回向。所谓菩萨。于过去诸佛善根等。乃至无上无与等。回向无上道。若菩萨知是事皆尽灭。知回向处法亦自性空。能知灭知空。是真回向。若过去法无常。无常故不可回向自性空法中。若过去法空空故。不可回向自性空法中。用如是智慧回向。是名正回向。复次若菩萨。知一切法因缘生故。无自力常住。自法相不动。况能有所作。无所作故。一切法中无有法能回向法。是名正回向。如是菩萨。虽行般若波罗蜜等诸善法。亦不堕颠倒。一切法不着故

【经】复次若菩萨摩诃萨。知所起福德。离五众十二入十八界。亦知般若波罗蜜是离相。乃至檀波罗蜜是离相。内空乃至无法有法空是离相。四念处乃至十八不共法是离相。如是菩萨摩诃萨。随喜心起福德。回向阿耨多罗三藐三菩提。复次若菩萨摩诃萨随喜福德。知随喜福德自性离。亦知诸佛离佛性。诸善根亦离善根性。菩提心菩提心性亦离。回向回向性亦离。菩萨菩萨性亦离。般若波罗蜜般若波罗蜜性亦离。禅波罗蜜。毗梨耶波罗蜜。羼提波罗蜜。尸罗波罗蜜。檀波罗蜜。檀波罗蜜性亦离。乃至十八不共法。十八不共法性亦离。菩萨摩诃萨应如是行离相般若波罗蜜。是名菩萨摩诃萨般若波罗蜜中生随喜福德。复次菩萨摩诃萨。诸过去灭度佛诸善根。若欲回向。应如是回向。作是念。如诸佛灭度相。诸善根相亦如是。灭度法相亦如是。我用心回向。是心相亦如是。若能如是回向。当知是回向阿耨多罗三藐三菩提。不堕想颠倒心颠倒见颠倒。若菩萨摩诃萨。行般若波罗蜜时。取诸佛善根相。回向阿耨多罗三藐三菩提。是不名为回向。何以故。诸过去佛及善根。非相缘非无相缘。若菩萨摩诃萨。作如是取相。是不名善根回向阿耨多罗三藐三菩提。如是菩萨摩诃萨。堕想颠倒心颠倒见颠倒。若菩萨摩诃萨诸佛。及诸善根及诸心不取相。是名以诸善根回向阿耨多罗三藐三菩提。是菩萨摩诃萨。不堕想颠倒心颠倒见颠倒。尔时弥勒菩萨问须菩提。云何菩萨摩诃萨。于诸善根不取相。能回向阿耨多罗三藐三菩提。须菩提言。以是事故当知。菩萨摩诃萨所学般若波罗蜜中。应有般若波罗蜜方便力。若是福德离般若波罗蜜。不得回向阿耨多罗三藐三菩提。何以故。般若波罗蜜中。诸佛不可得。诸善根不可得。回向阿耨多罗三藐三菩提心。亦不可得。于是中菩萨摩诃萨。行般若波罗蜜时。应如是思惟。诸过去佛及弟子身皆灭。诸善根亦灭。我今取相分别诸佛诸善根及诸心。如是取相回向阿耨多罗三藐三菩提。诸佛所不许。何以故。取相有所得故。所谓于过去诸佛取相分别。是故菩萨摩诃萨。欲以诸善根回向阿耨多罗三藐三菩提。不应有得。不应取相。如是回向。若有得取相回向。诸佛不说有大利益。何以故。是回向杂毒故。譬如美食杂毒。虽有好色好香为人所贪而杂毒。愚痴之人食之欢喜。贪其好色香美可口。饭欲消时。受若死若死等苦。若善男子善女人。不谛受不谛取相不谛诵读不解中义。如是教他言。汝善男子过去未来现在十方诸佛。从初发意已来。至得阿耨多罗三藐三菩提。入无余涅槃乃至法尽。于其中间行般若波罗蜜时作诸善根。行禅波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀波罗蜜时作诸善根。修四禅四无量心四无色定四念处乃至八圣道分佛十力。乃至修十八不共法时作诸善根。净佛世界成就众生。作诸善根。及诸佛戒众定众慧众解脱众解脱知见众一切种智。无错谬法常舍行。及诸弟子是中所种善根。及诸佛所记。当作辟支佛。是中诸天龙阿修罗迦楼罗紧那罗摩睺罗伽等所种善根是诸福德称量和合。随喜回向阿耨多罗三藐三菩提。是回向以取相得法故。如杂毒食。得法者终无正回向。何以故。是得法杂毒。有相有动有戏论。若如是回向则为谤佛。不随佛教不随法说。是善男子善女人。求佛道应如是学。过去未来现在诸佛。从初发意乃至法尽。及弟子行般若波罗蜜时作善根。乃至修一切种智。如上说。云何诸善根。回向阿耨多罗三藐三菩提。正回向有求佛道。善男子善女人。行般若波罗蜜。不欲谤诸佛者。诸福德应如是回向。如诸佛所知无上智慧。是诸善根相。是诸善根性。我亦如是随喜。如诸佛所知。我亦如是回向阿耨多罗三藐三菩提。求菩萨道。善男子善女人。应如是回向阿耨多罗三藐三菩提。若如是回向。则为不谤佛。如佛所教如佛法说。是菩萨摩诃萨回向。则无杂毒

【论】释曰。所起福德离五众者。先但说过去事。今说自起随喜福德。若知是福德中。无五众十二入十八界。虽行般若波罗蜜等诸法。亦知空离相。如是福德名正回向。复次若菩萨知随喜福德中。随喜福德性自离。诸佛及善根。并诸起阿耨多罗三藐三菩提心回向心。菩萨般若波罗蜜等诸行法。知自性空。是名正回向。随喜福德者。总说一切福德相。善根随喜起福德。是别相说。菩萨自缘所求阿耨多罗三藐三菩提。是名阿耨多罗三藐三菩提心。是菩萨随喜心功德果。但求无上道。是名回向心。行者五众中。假名字为菩萨。般若波罗蜜等诸法如先义说。先说福德中离五众。今说福德福德自相空。复次菩萨念过去佛因缘生福德。应如是回向。如过去诸佛。入无余涅槃。无相无戏论性常寂灭。是福德及回向心亦如是。如是回向是名正回向。不堕颠倒。复次若菩萨。于诸过去佛功德。取相分别回向。是不名回向。何以故。有相是一边。无相是一边。离是二边行中道。是诸佛实相。是故说诸过去佛不堕相数中。不堕无相数中。若如是取相数。是不名回向则堕颠倒。与上相违。是为不堕颠倒。是事难故弥勒重问。所谓一切法不取相而复能回向。须菩提。是中不得决定答处。是故语弥勒以是事故。菩萨学般若波罗蜜求方便力。是福德离般若波罗蜜。不得回向者。一切法中一法实而不诳。所谓阿耨多罗三藐三菩提。随是阿耨多罗三藐三菩提行不诳道尔乃可得。不诳道者。即是般若波罗蜜。是故说离般若波罗蜜是福德不可得回向。何以故。是般若波罗蜜。毕竟空无有分别福德。若离般若波罗蜜。若不离般若波罗蜜。不可得回向。菩萨应作是念。诸过去佛及弟子身。并诸善根福德皆灭。我今取相分别。所谓是诸佛是弟子是善根。是随喜福德取相回向我为不是。何以故。与诸法实相异故。受果报已久久当尽故。不疾至佛道。有所得故。于过去诸佛。忆想分别即是大失。所谓过去佛空无。而我忆想分别。譬如杂毒食。食是随喜福德。毒是取相故。爱见等诸烦恼生。好色者。福德因缘作人王转轮王天王得福乐。好香者。得好名誉富贵势力。凡夫无智之人所共贪爱。愚痴人者。是新发意取相着心菩萨。食之欢喜者。富乐福德因缘故。于天人中受此富乐。饭欲消时受若死若死等苦者。是富乐若无常破坏。离时忧愁遂死。若次死受诸苦恼。复次若死若死等者。自失命根名死。失所著物名死等。复次若死若死等者。苦恼多故失智慧命名死。妨行善道名死等。此经中须菩提自说。是无智人不审谛受。不取其义但着语言。不谛取相者。不如法分别。不谛读诵者。忘失句逗若自失若受不具足。不解义者不得经意。如是少智师教化弟子。汝善男子。过去未来现在十方诸佛。从初发意乃至如是回向。则为谤佛。不随佛教不随法说。与此相违名为正回向。复次正回向菩萨应作是念。如十方三世诸佛所知。用无上智慧。知诸善根相。一切智人中佛第一胜。佛所知诸善根必是实相。如佛所知。我亦用如是善根相回向。譬如射地无不着时。若射余物或着或不着。如诸佛所知随喜。如射地无不着。若用余道随喜。如射余物或着或不着。如是回向是为不谤佛

【经】复次求佛道善男子善女人。行般若波罗蜜时。诸善根应如是回向。如色不系欲界。不系色界。不系无色界。不系法者。不名过去。不名未来不名现在。如受想行识。不系欲界不系色界。不系无色界。不系法者。不名过去未来现在。十二入十八界亦如是。如般若波罗蜜。不系欲界。不系色界不系无色界。不系法者。不名过去未来现在。禅波罗蜜乃至檀波罗蜜亦如是。内空乃至无法有法空亦如是。如四念处。不系欲界。不系色界。不系无色界。不系法者。不名过去未来现在。乃至八圣道分亦如是。佛十力乃至十八不共法亦如是。如如法性法相法住法位实际不可思议性。戒定慧解脱解脱知见众。一切种智无错谬法常舍行。不系欲界。不系色界。不系无色界。不系法者。不名过去未来现在。是回向所回向处。行者不系皆亦如是。如是诸佛亦不系。诸善根亦不系。是诸声闻辟支佛善根亦不系。不系法者。不名过去未来现在。若菩萨摩诃萨。行般若波罗蜜时。如是知色不系三界。不系法者。不名过去未来现在。若法不过去未来现在者。不可以取相有所得法回向阿耨多罗三藐三菩提。何以故。是色无生。若法无生则无法。无法中不可回向。受想行识亦如是。檀波罗蜜乃至般若波罗蜜四念处乃至无错谬法常舍行。不系三界。不系法者。亦非过去未来现在。若非过去未来现在法者。不可以取相有所得法回向阿耨多罗三藐三菩提。何以故是法无生。若法无生则无法。无法中不可回向。菩萨摩诃萨。如是回向则无杂毒。若求佛道善男子善女人。以取相得法。以诸善根。回向阿耨多罗三藐三菩提。是名邪回向。若邪回向诸佛所不称誉。用是邪回向。不能具足檀波罗蜜乃至般若波罗蜜。不能具足四念处乃至八圣道分内空乃至无法有法空佛十力乃至无错谬法常舍行。不能具足净佛世界成就众生。若不能净佛世界成就众生。则不能得阿耨多罗三藐三菩提。何以故。是回向杂毒故。复次菩萨摩诃萨行般若波罗蜜时。应作是念。如诸佛所知诸善根回向是真回向。我亦应以是法相回向。是名正回向。尔时佛赞须菩提。善哉善哉。如汝所为为作。佛事。为诸菩萨摩诃萨。说所应回向法。以无相无得无出无垢。无净无法性自相空常性空法性如实际故。须菩提。若三千大千世界中众生。皆当得十善道四禅四无量心四无色定五神通。于须菩提意云何。是众生得福多不。甚多世尊。佛言。不如是。善男子善女人于诸善根心不着。回向阿耨多罗三藐三菩提。最上第一最妙无上无与等。复次须菩提。若三千大千世界中众生。皆当作须陀洹乃至阿罗汉辟支佛。若有善男子善女人。尽形寿供养恭敬尊重赞叹。衣服饮食卧具医药供给所须。于须菩提意云何。是善男子善女人。是因缘故得福德多不。甚多世尊。佛言。不如是。善男子善女人。于诸善根心不着。回向阿耨多罗三藐三菩提。最上第一最妙无上无与等。复次须菩提。若三千大千世界中众生。皆发阿耨多罗三藐三菩提心。十方如恒河沙等世界中一一众生。如恒河沙等劫。恭敬尊重赞叹供养是菩萨。衣服饮食卧具医药供给所须。于须菩提意云何。是善男子善女人。是因缘故得福多不。甚多世尊。无量无边阿僧祇不可以譬喻为比。世尊。若是福德有形者。十方如恒河沙。等世界所不受。佛告须菩提。善哉善哉。如汝所言。虽尔不如善男子善女人于诸善根心不着回向阿耨多罗三藐三菩提。最上第一最妙无上无与等。是无著回向功德。比前功德。百倍千倍百千亿倍。乃至算数譬喻所不能及。何以故。是善男子善女人。取相得法行十善道四禅四无量心四无色定五神通。取相得法供养须陀洹。恭敬尊重赞叹。衣服饮食卧具医药供给所须。乃至取相供养菩萨故。尔时四天王天与二万诸天子。合掌礼佛作是言。世尊。菩萨摩诃萨最大回向。以方便力故。以无所得故。以无相法故。以无觉法故。诸善根回向阿耨多罗三藐三菩提如是回向不堕二法。尔时释提桓因。亦与无数三十三天及余诸天子。持天华璎珞捣香泽香天衣幡盖鼓天伎乐。以供养佛。作如是言。世尊。菩萨摩诃萨最大回向。以方便力故。以无所得故。以无相法故。以无觉法故。诸善根回向阿耨多罗三藐三菩提。如是回向不堕二法。须夜摩天王与千天子。删兜率陀化乐他化自在诸天王。各与千天子俱。供养佛已。作如是言。世尊。菩萨摩诃萨最大回向。以方便力故。以无所得故。以无相法故。以无觉法故。诸善根回向阿耨多罗三藐三菩提。如是回向不堕二法。尔时诸梵天王。与无数百千亿那由他诸天俱。诣佛所头面礼佛足。发大音声作如是言。未曾有也。世尊。菩萨摩诃萨为般若波罗蜜所护。以方便力故。胜前善男子善女人取相有所得者。光音天乃至阿迦尼吒天。与无数百千亿那由他诸天俱。诣佛所头面礼佛足。发大音声作如是言。未曾有也。世尊。菩萨摩诃萨为般若波罗蜜所护。以方便力故。胜前善男子善女人取相有所得者。尔时佛告四天王天乃至阿迦尼吒诸天子。若三千大千世界中所有众生。皆发阿耨多罗三藐三菩提心。是一切菩萨。念过去未来现在诸佛及声闻辟支佛诸善根。从初发意乃至法住。于其中间所有善根。并余一切众生所有善根。所谓布施持戒忍辱精进一心智慧。檀波罗蜜乃至般若波罗蜜。戒众定众慧众解脱众解脱知见众。如是等诸余无量佛法一切和合随喜。随喜已回向阿耨多罗三藐三菩提。以取相有所得故。复有善男子善女人。发阿耨多罗三藐三菩提心。念过去未来现在诸佛及声闻辟支佛。从初发意乃至法住。于其中间所有善根。并余一切众生所有善根。所谓布施持戒忍辱精进一心智慧。檀波罗蜜乃至无量诸佛法。一切和合称量。以无所得故。无二法故。无相法故。不着法故。无觉法故。是最上随喜。第一最妙无上无与等随喜。随喜已回向阿耨多罗三藐三菩提。是善男子善女人功德。胜前善男子善女人功德。百倍千倍百千亿倍乃至算数譬喻所不能及。尔时须菩提白佛言。世尊。世尊说。善男子善女人和合诸善根称量。随喜回向。最上第一最妙无上无与等。世尊。云何名随喜最上乃至无与等。佛言。若善男子善女人。念过去未来现在诸法。不取不舍不念非不念不得非不得。是诸法中亦无有法生者灭者若垢若净。诸法不增不减不来不去不合不散不入不出。如过去未来现在诸法相如如相法性法住法位。我亦如是随喜。随喜已回向阿耨多罗三藐三菩提。如是回向最上第一最妙无上无与等。须菩提。是随喜法比余随喜。百倍千倍百千亿倍乃至算数譬喻所不能及。复次须菩提。求佛道善男子善女人。于过去未来现在诸佛及声闻辟支佛。从初发心乃至法住。于其中间所有善根。若布施乃至智慧。檀波罗蜜乃至无量诸佛法。及余一切众生所有善根。若欲随喜者。应如是随喜。作是念。布施与解脱等。戒忍精进禅智与解脱等。色与解脱等。受想行识亦与解脱等。内空与解脱等。乃至无法有法空亦与解脱等。四念处与解脱等。乃至八圣道分亦与解脱等。佛十力与解脱等。乃至一切种智亦与解脱等。戒众定众慧众解脱众解脱知见众亦与解脱等。随喜与解脱等。过去未来现在诸法与解脱等。十方诸佛与解脱等。诸佛回向与解脱等。诸佛与解脱等。诸佛灭度与解脱等。诸佛弟子声闻辟支佛与解脱等。诸佛弟子灭度与解脱等。诸佛法相与解脱等。诸声闻辟支佛法相与解脱等。一切诸法相亦与解脱等。我以是诸善根相随喜功德。回向阿耨多罗三藐三菩提。亦与解脱等。不生不灭故。须菩提。是名诸菩萨摩诃萨随喜功德最上第一最妙无上无与等。须菩提。菩萨成就是随喜功德。当疾得阿耨多罗三藐三菩提。复次须菩提。十方如恒河沙等诸佛及弟子。现在若有求佛道善男子善女人。尽形寿供养是诸佛及弟子。一切所须供养恭敬尊重赞叹。衣服饮食卧具医药。是诸佛灭度后。昼夜勤修供养恭敬尊重赞叹。华香乃至旛盖伎乐。以取相有所得故。持戒忍辱精进禅定修智慧。以取相有所得故。复有善男子善女人。发意求阿耨多罗三藐三菩提。行檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜时。以不取相无所得法方便力诸善根。回向阿耨多罗三藐三菩提。是福德最上第一最妙无上无与等。胜前福德百倍千倍百千亿倍乃至算数譬喻所不及。如是须菩提。菩萨摩诃萨行檀波罗蜜时。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜时。以方便力故。诸善根应回向阿耨多罗三藐三菩提。以不取相无所得法故

【论】释曰。菩萨应作是念。从色乃至常舍行。诸法不系三界故三世不摄。诸佛及弟子并诸功德随喜心回向处所用回向法回向者亦如是。是名正回向。尔时菩萨作是念。若色出三界三世不摄。不可以取相有所得回向。何以故。是色出三界者。即是色实相。初后生相不可得。如破生品中说。若法无生即是无所有。无所有回向心。云何回向无所有菩提心。色受想行识乃至常舍行亦如是。是名无杂毒回向。所谓无相无得回向。杂毒者。所谓诸佛不赞叹。不能具足六波罗蜜等。乃至不能得阿耨多罗三藐三菩提。复次菩萨应作是念。如十方三世诸佛所知。应如是生心如是念如是观如是回向。是功德直至无上道。我亦如是随喜回向。是菩萨必得实随喜回向不虚。如先说因缘。是略说诸回向品。菩萨礼佛有三品。一者悔过品。二者随喜回向品。三者劝请诸佛品。广说则无量无边。善哉善哉。汝作佛事者。佛初发心誓度一切众生。须菩提虽是阿罗汉。而能助佛说法开菩萨道。是故赞言善哉善哉。复次佛自说因缘。为诸菩萨说所应回向法。用无相故者。以无相智慧和合回向。福德相者。与上相违名为无相。无相有三种。假名相法相无相相。假名相者。如车如屋如林如军如众生。诸法和合中更有是名。无明力故取是假名相。起诸烦恼业。法相者。五众十二入十八界等。诸法肉眼观故有。以慧眼观则无。是故法亦虚诳妄语。应舍离法相。离是二相。余但有无相相。有人取是无相相。随逐取相还生结使。是故亦不应取无相相。离三种相故名无相。若无有相是中无所得。无得故无出。若法无得无出。即是无垢无净。若法无垢无净则是无法性。若法无性即是自相空。若法自相空。即是法常自性空。若法常自性空。即同法性如实际。用如是法和合随喜福德回向故。赞言善哉善哉。复有善哉因缘。所谓随喜福德。大利益众生有大果报。何者是大利益。所谓佛语须菩提。若三千大千世界众生。行十善乃至五通。问曰。欲界中二处天及梵天王。何以与多天俱。余四天何以少。答曰。是二天依止地近佛故。又五欲不如上天。佛生时苦行时降魔时得道时转法轮时。常来供养佛。是故多。余四处天宫殿在虚空中不属地。五欲妙染着深故。不能多来。又兜率天虽利根乐法。而其天上常有补处菩萨说法。是故不来。梵天虽远离欲。故乐法情深。佛为法王。是故多来。复次梵天王为色界主。请佛初转法轮。是故应与多众俱来。余色界天尽名梵天。问曰。先种种因缘说正回向。正回向即是最上。今何以更问。答曰。上处处广说。今略说。所谓三世十方一切法决定心。知于是法中无生者灭者等。一切法不可得不可念。不得不念故不取不舍。入诸法实相中作是念。如诸法实相我亦如是。以随喜福德回向。不分别诸法。不坏法性。是名最上回向。何以故。果报常无尽故。问曰。六波罗蜜等。诸法各名相。若色相若无色相等。解脱有二种。有为解脱无为解脱。云何皆与解脱等。答曰。我先已说。凡夫人以肉眼。六识颠倒观故见异。若以慧眼观诸法皆虚妄。唯涅槃为实。是有为解脱属无为。随无为故名解脱。如实得道者名道人。今未得道者。衣服法则随得道者故。亦名道人。如无余涅槃。不生不灭不入不出不垢不净非有非无非常非无常常寂灭相。心识观灭语言道断。非法非非法等相。用无所有相故。慧眼观一切法。亦如是相。是名六波罗蜜等与解脱等。是故佛法中说解脱为贵。上智慧贵解脱。佛是中分别说。若人无量阿僧祇劫。行六波罗蜜用有所得法。种种修集善根。一人用无所得法。但以心随喜。念他功德回向无上道。是人百千万分不及其一。何以故。先福德有量。今福德无量。先福德有尽。今福德无尽。先福德杂毒。今福德无毒。先福德随生死。今福德随涅槃。先福德不定。或作佛或退。今福德定到必疾作佛。有如是等差别是故四种人。若凡夫人求世间乐。若声闻辟支佛人求涅槃乐。若诸菩萨摩诃萨求佛乐。应如是随喜生福德回向阿耨多罗三藐三菩提。如此品中说

大智度论卷第六十一大智度论释照明品第四十(卷六十二)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】尔时慧命舍利弗白佛言世尊。是般若波罗蜜。佛言。是般若波罗蜜。世尊。般若波罗蜜能照一切法毕竟净故。世尊。应礼般若波罗蜜。世尊。般若波罗蜜不着三界。世尊。般若波罗蜜除诸闇冥一切烦恼诸见除故。世尊。般若波罗蜜一切助道法中最上。世尊。般若波罗蜜安隐。能断一切怖畏苦恼故。世尊。般若波罗蜜能与光明。五眼庄严故。世尊。般若波罗蜜能示导堕邪道众生。离二边故。世尊般若波罗蜜是一切种智。一切烦恼及习断故。世尊。般若波罗蜜诸菩萨摩诃萨母。能生诸佛法故。世尊。般若波罗蜜不生不灭。自相空故。世尊。般若波罗蜜远离生死。非常非灭故。世尊。般若波罗蜜无救者作护。施一切珍宝故。世尊。般若波罗蜜具足力。无能破坏故。世尊。般若波罗蜜能转三转十二行法轮。一切诸法不转不还故。世尊。般若波罗蜜能示诸法性。无法有法空故。世尊。应云何供养般若波罗蜜。佛言。当如供养世尊。礼般若波罗蜜。当如礼世尊。何以故。世尊不异般若波罗蜜。般若波罗蜜不异世尊。世尊即是般若波罗蜜。般若波罗蜜即是世尊。是般若波罗蜜中。出生诸佛菩萨辟支佛阿罗汉阿那含斯陀含须陀洹。般若波罗蜜中。生十善道四禅四无量心四无色定五神通内空乃至无法有法空四念处乃至八圣道分。是般若波罗蜜中。生佛十力十八不共法大慈大悲一切种智。尔时释提桓因心念。何因缘故。舍利弗问是事。念已语舍利弗。何因缘故问是事。舍利弗语释提桓因言。憍尸迦。诸菩萨摩诃萨。为般若波罗蜜守护。以沤和拘舍罗力故。于过去未来现在诸佛。从初发心乃至法住。于其中间所作善根。一切和合随喜。回向阿耨多罗三藐三菩提。以是因缘故我问是事。憍尸迦。菩萨摩诃萨般若波罗蜜。胜檀波罗蜜尸罗羼提毗梨耶禅波罗蜜。譬如生盲人。若百若千若百千。而无前导不能趣道入城。憍尸迦。五波罗蜜亦如是。离般若波罗蜜。如盲无导不能趣道。不能得一切种智。憍尸迦。若五波罗蜜得般若波罗蜜将导。是时五波罗蜜名为有眼。般若波罗蜜将导。得波罗蜜名字。释提桓因语舍利弗。如汝所言。般若波罗蜜将导五波罗蜜故。得波罗蜜名字。舍利弗。若无檀波罗蜜。五波罗蜜不得波罗蜜名字。若无尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜。五波罗蜜不得波罗蜜名字。若尔者何以故独赞般若波罗蜜。舍利弗言。如是如是。憍尸迦。无檀波罗蜜。五波罗蜜不得波罗蜜名字无。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜。五波罗蜜不得波罗蜜名字。但菩萨摩诃萨住般若波罗蜜中。能具足檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜。以是故憍尸迦。般若波罗蜜。于五波罗蜜中。最上第一最妙无上无与等。舍利弗白佛言。世尊。云何应生般若波罗蜜。佛告舍利弗。色不生故。般若波罗蜜生。受想行识不生故。般若波罗蜜生。檀波罗蜜不生故。般若波罗蜜生。乃至禅波罗蜜不生故。般若波罗蜜生。内空乃至无法有法空。四念处乃至八圣道分佛十力。乃至一切智一切种智不生故。般若波罗蜜生。如是诸法不生故。般若波罗蜜应生。舍利弗言。世尊。云何色不生故般若波罗蜜生。乃至一切诸法不生故般若波罗蜜应生。佛言。色不起不生不得不失故。乃至一切诸法不起不生不得不失故。般若波罗蜜生。舍利弗白佛言。如是生般若波罗蜜。与何等法合。佛言。无所合。以是故得名般若波罗蜜。世尊。不合何等法。佛言。不与不善法合。不与善法合。不与世间法合。不与出世间法合。不与有漏法合。不与无漏法合。不与有罪法合。不与无罪法合。不与有为法合。不与无为法合。何以故。般若波罗蜜。不为得诸法故生。以是故。于诸法无所合。尔时释提桓因白佛言。世尊。是般若波罗蜜亦不合萨婆若。佛言。如是憍尸迦。般若波罗蜜亦不合萨婆若亦不得。释提桓因言。世尊。云何般若波罗蜜。亦不合萨婆若亦不得。佛言。般若波罗蜜不如名字不如相不如起作法合。释提桓因言。今云何合。佛言。若菩萨摩诃萨。如不取不受不住不着不断。如是合亦无所合。如是憍尸迦。般若波罗蜜一切法合亦无所合。尔时释提桓因白佛言。未曾有也。世尊。是般若波罗蜜为一切法不起不生不得不失故生须菩提白佛言。世尊。若菩萨摩诃萨行般若波罗蜜时作是念。般若波罗蜜若一切法合若不合。是菩萨摩诃萨则舍般若波罗蜜。远离般若波罗蜜。佛告须菩提。复有因缘。菩萨摩诃萨舍般若波罗蜜。远离般若波罗蜜。若菩萨摩诃萨作是念。是般若波罗蜜无所有空虚不坚固。是菩萨摩诃萨则舍般若波罗蜜。远离般若波罗蜜。须菩提。以是因缘故。舍离般若波罗蜜。须菩提白佛言。世尊。信般若波罗蜜。为信何法。佛告须菩提。信般若波罗蜜。则不信色不信受想行识。不信眼乃至意。不信色乃至法。不信眼界乃至意识界。不信檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜。不信内空乃至无法有法空。不信四念处乃至八圣道分。不信佛十力乃至十八不共法。不信须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道。不信菩萨道。不信阿耨多罗三藐三菩提乃至一切种智。须菩提白佛言。世尊。云何信般若波罗蜜时。不信色乃至一切种智。佛告须菩提。色不可得故。信般若波罗蜜。不信色乃至一切种智。不可得故。信般若波罗蜜。不信一切种智。以是故。须菩提。信般若波罗蜜时。不信色乃至不信一切种智

【论】释曰。上佛弥勒须菩提释提桓因。共说随喜义。舍利弗虽默然听闻是般若波罗蜜随喜义甚深无量无边。大利益众生。虽漏尽寂灭发欢喜心。从坐起合掌白佛言。能作随喜断诸戏论。利益无量众生。令入佛道者。是般若波罗蜜。佛可其语故言是。般若波罗蜜中说诸法实相。诸法实相中无戏论垢浊故。名毕竟清净。毕竟清净故。能遍照一切五种法藏。所谓过去未来为现在无为及不可说。是故舍利弗言。世尊。般若波罗蜜。能照一切法。毕竟净故。般若波罗蜜。能守护菩萨救诸苦恼。能满所愿。如梵天王守护三千大千世界故。众生皆礼。三界中三毒泥所不污故。言不着三界。破一切爱等百八烦恼我见等六十二见故。言破无明黑闇。诸法中智慧最上。一切智慧中。般若波罗蜜为上。以智慧为本。分别四念处等三十七品。是故言一切助道法中最上。能断生老病死等诸怖畏苦恼故言安隐。是般若波罗蜜中。摄五眼故。言能与光明。离有边无边等诸二边故。言能示正道。菩萨住金刚三昧。断一切烦恼。微习令无遗余。得无碍解脱故。言一切种智。复次知一切法总相别相一切种智因缘故。名一切种智。能生十方三世无量诸佛法故。言诸菩萨母。一切法中各各自相空故。言不生不灭。断常是诸见本。诸见是诸结使本。诸结使是一切生死中苦本。是故言远离生死。能令众生信三宝等诸善法宝得诸善法宝故。得世间出世间乐。能令众生得二种乐故。言无救者作护。是般若波罗蜜相。乃至十方诸佛所不能坏。所以者何。毕竟不可得故何况余人。故言具足波罗蜜。是般若波罗蜜中。无自性故。说诸法不转。生死中不还入涅槃。不生故不转。不灭故不还。故言能转三转十二行法轮。三转十二行法轮义如先说。一切法有二分。若有若无。是般若中有亦不应取。无亦不应取。离是有无。即是诸法性。是故言能示诸法性。如是等无量因缘。赞叹般若。后当广说。是般若波罗蜜是无相相。有人心未淳熟。求其定相。不能得便生慢心。是故舍利弗问应云何供养。佛教言当如供养佛。以人从久远已来深着众生相。于贵法情薄。是故言如供养世尊。智者观之佛与般若等无异。所以者何。般若修集即变为一切智。此中佛自说因缘。是般若波罗蜜中。出生贤圣等。出生十善道等世间出世间法乃至一切种智。尔时帝释作是念者。帝释意以舍利弗漏尽离欲人。如似着法人赞叹般若。今舍利弗自说因缘。菩萨为般若守护故。以方便力。能随喜福德回向。而不破般若波罗蜜相。是事希有故。尊敬般若波罗蜜。是故问佛云何供养。复次憍尸迦。般若波罗蜜自力势故。胜五波罗蜜。问曰。五波罗蜜应以五盲人作喻。何以乃说百千。答曰。此中说其力势不论多少。复次若言导五不足为贵故说百千。复次波罗蜜亦多。如贤劫三昧中有八万四千种波罗蜜。广说则无量。问曰。檀波罗蜜亦有眼。所以者何。信有罪福。破邪见等无明故能布施。何以故喻无眼。答曰。布施中智慧是客来非正体。譬如四大常和合不得相离。诸波罗蜜和合亦如是。不能趣道。道者菩萨十地道。城者一切种智等诸佛法。复次道者。八圣道分。城者涅槃。如盲人虽有手足力。不能得随意有所至。得有眼人示导。则随意所往皆能成办五波罗蜜。虽各各有事。能不得般若示导。尚不得二乘。何况无上道。五波罗蜜。得般若波罗蜜将导故。得波罗蜜名字。至成佛道。帝释问。汝自说诸波罗蜜和合互相佐助。如四大不得相离。如是者。般若波罗蜜亦待五法。何以独说以般若故五法得波罗蜜名字。答曰。虽六事和合互相佐助。但般若波罗蜜力大故。五法因得波罗蜜名字。譬如合散虽众药各各有力。石势大故名为石散。又如大军摧敌虽各各有力。主将力大故主得名字。舍利弗已问供养般若事。今问行者云何生般若波罗蜜。佛答若行者观色等诸法不生相。是则生般若波罗蜜。舍利弗复问。云何观色等不生故。般若波罗蜜生。答曰。色等因缘和合起。行者知色虚妄不令起。不起故不生。不生故不得。不得故不失。尔时舍利弗问意。般若无生。缘处行者亦无生。如是般若与何法合。终归何处住。得何果报。答曰。般若波罗蜜无生相故无所合。若般若波罗蜜有法合者。若善若不善等。是不名般若波罗蜜。今无所合故。入般若波罗蜜数中。问曰。若尔者帝释已知一切法不合。何以独问萨婆若不合。答曰。帝释贵重深着是般若。于萨婆若爱未断故。言乃至萨婆若亦不合耶。佛答。般若波罗蜜萨婆若亦不合。一切法毕竟无生故。此中佛破断灭邪见故。说合般若波罗蜜。不如凡夫人取相著名作起有为法合。如佛心合。问曰。云何如佛心合。答曰。一切相虚诳故。不取相。一切法。中有无常等过咎故不受。吾我心缚着世间。皆动相故不住。能生种种苦恼。后变异故不着。一切世间颠倒。颠倒果报不实如幻如梦。无所灭故不断。是故佛不着法不生高心。入毕竟空善相中。深入大悲以救众生。菩萨应如佛心合。帝释欢喜赞言希有。是般若波罗蜜。不破坏诸法。不生不得不失故。而能成就菩萨。令得至佛。须菩提言。若菩萨用有所得。如是分别一切智等一切法若合若不合。是菩萨则失般若波罗蜜。佛然可其言如是。更有因缘。菩萨若取汝所说。一切法无合不合取是空相。言般若空无所有不牢固。是亦失般若波罗蜜。须菩提知般若波罗蜜不可得相。是故问。若信般若波罗蜜。信何法。般若波罗蜜空亦不可得。为决定心信于何法。佛言色等一切法不可信。何以故。色等一切法自性不可得故。不可信

【经】须菩提白佛言。世尊。是般若波罗蜜。名为摩诃波罗蜜。须菩提。何因缘故。是般若波罗蜜。名为摩诃波罗蜜。须菩提言。世尊。是般若波罗蜜不作色大不作色小。受想行识不作大不作小。眼乃至意。色乃至法。眼识界乃至意识界。不作大不作小。檀波罗蜜乃至禅波罗蜜。不作大不作小。内空乃至无法有法空。不作大不作小。四念处乃至阿耨多罗三藐三菩提。不作大不作小。诸佛法不作大不作小。诸佛不作大不作小。是般若波罗蜜。不作色合不作色散。受想行识不作合不作散。乃至诸佛不作合不作散。色不作无量。不作非无量。乃至诸佛不作无量亦不作非无量。色不作广不作狭。乃至诸佛不作广不作狭。不作色。有力。不作色无力。乃至诸佛不作有力不作无力。世尊。以是因缘故。是般若波罗蜜。名摩诃波罗蜜。世尊。若新发意菩萨摩诃萨。若不远离般若波罗蜜。不远离禅波罗蜜。不远离毗梨耶波罗蜜。不远离羼提波罗蜜。不远离尸罗波罗蜜。不远离檀波罗蜜。如是念是般若波罗蜜。不作色大不作色小。乃至诸佛不作大不作小。色不作合不作散不作色无量。不作色非无量。不作色有力。不作色无力。乃至诸佛不作有力不作无力。世尊。菩萨摩诃萨。若如是知是。为不行般若波罗蜜。何以故。是非般若波罗蜜相。所谓作色大小。乃至诸佛作大小色有力无力。乃至诸佛有力无力。世尊。是菩萨摩诃萨用有所得故。有大过失。所谓行般若波罗蜜时。作色大作色小。乃至诸佛作有力作无力。何以故。有所得相者。无阿耨多罗三藐三菩提。所以者何。众生不生故。般若波罗蜜亦应不生。色不生故。般若波罗蜜不生。乃至佛不生故。般若波罗蜜不生。众生性无故。般若波罗蜜性无。色性无故。般若波罗蜜性无。乃至佛性无故。般若波罗蜜性无。众生非法故。般若波罗蜜非法。色非法故。般若波罗蜜非法。乃至佛非法故。般若波罗蜜非法。众生空故。般若波罗蜜空。色空故。般若波罗蜜空。乃至佛空故。般若波罗蜜空。众生离故。般若波罗蜜离。色离故。般若波罗蜜离。乃至佛离故。般若波罗蜜离。众生无有故。般若波罗蜜无有。色无有故。般若波罗蜜无有。乃至佛无有故。般若波罗蜜无有。众生不可思议故。般若波罗蜜不可思议。色不可思议故。般若波罗蜜不可思议。乃至佛不可思议故。般若波罗蜜不可思议。众生不灭故。般若波罗蜜不灭。色不灭故。般若波罗蜜不灭。乃至佛不灭故。般若波罗蜜不灭。众生不可知故。般若波罗蜜不可知。色不可知故。般若波罗蜜不可知。乃至佛不可知故。般若波罗蜜不可知。众生力不成就故。般若波罗蜜力不成就。色力不成就故。般若波罗蜜力不成就。乃至佛力不成就故。般若波罗蜜力不成就。世尊。以是因缘故。诸菩萨摩诃萨。般若波罗蜜。名为摩诃波罗蜜

【论】释曰。须菩提闻佛所说。疑心开解赞叹般若波罗蜜言。是般若名为摩诃波罗蜜。佛反问。须菩提。于汝意云何。何以名为大波罗蜜。须菩提答。色等诸法不作大不作小故。凡夫人心于诸法中随意作大小。如人急时其心缩小安隐富乐时心则宽大。又如八背舍中。随心故外色或大或小。又如凡夫人。于眼见色中。非色事亦言色。如指业指量指数指一异等。法合为色。是名色作大。有人眼见色可见处名色。不可见处不名色。有人言。粗色虚诳非真色。但微尘常故是真色。微尘和合时假名为色。是名色作小。如是等因缘。凡夫人于色或作大或作小。随忆想分别故破诸法性。般若波罗蜜。随色性如实观不作大小。不合不散者。般若波罗蜜。不说微色和合更有色生。但有假名无有定相色。是故无合无散。色无边故无量。无处不有色。无时不有色故无有量。色是作法。般若波罗蜜中。不以微尘合故有粗色。不以粗色散故还归微尘。是故言不合不散。起法有分别筹量多少。不得言不合不散无量如凡人。空故说无量。实故说有量。般若波罗蜜。远离空实故。言非量非无量。凡夫人随心忆念得解故。于色作广作狭。般若波罗蜜观实法相。不随心故非广非狭。凡夫人不知和合因缘生诸法故言色有力。如合众缕以为绳。不知者。谓绳有力。又如墙崩杀人。言墙有力。若各各分散则无有力。般若波罗蜜知和合相。不说一法有力。不说言无力。是故名摩诃般若波罗蜜。复有大因缘。若菩萨不远离六波罗蜜。色等诸法不作大不作小。但行般若波罗蜜。则心散乱不调顺。多生疑悔邪见。失般若波罗蜜相。若与五波罗蜜和合行。则调柔不错能成办众事。譬如八圣道分。正见是道。若无七事佐助。则不能办事。亦不名正见。是故佛说一切诸善法。皆从因缘和合共生。无有一法独自生者。是故和合时各各有力。但力有大小。是名行般若波罗蜜。若菩萨离五波罗蜜。行般若波罗蜜。分别色等诸法若大若小等。是人即堕用有所得。堕有边中。若于色等诸法无所分别若大若小离五波罗蜜。着是不大不小等空相。先分别诸法大小有所得为失。今着不大不小等空相亦是失。所以者何。此中须菩提说因缘。有所得相者。乃至无阿耨多罗三藐三菩提。所以者何。阿耨多罗三藐三菩提。寂灭相无所得相毕竟清净相。有所得相者。生诸戏论。诤竞一切法无生无灭。无所得相。如我众生十方求索不可得。但有假名实不生。众生不生故。般若波罗蜜。亦如众生相。破吾我颠倒故。不生不灭。如色等诸法。生相不可得故。不生二法摄一切法。若众生若法。此二法因缘故和合生。但有假名无有定性。若法无定性。此法即是无生。是二法无生故。当知色等诸法亦无生。众生法无性无所有。空离。不可思议。不灭。不可知亦如是。众生力不成就故。般若波罗蜜力不成就者。先说一切法从因缘和合生。各各无自力。般若波罗蜜知诸法各各无自力故。无自性。无自性故空。般若波罗蜜。从诸法生故无自力。无自力故。亦同诸法毕竟空。是故说众生及法力不成就故。般若波罗蜜力亦不成就。问曰。先说色等诸法。不作有力不作无力。今何以更说众生及色等。诸法力不成就故。般若波罗蜜力亦不成就。答曰。上说般若观诸法。不作有力不作无力。听者谓般若波罗蜜。能作是观即有大力。是故此中说。众生色等力不成就故。般若波罗蜜力亦不成就。如是等种种因缘故。名摩诃波罗蜜

    大智度论释信谤品第四十一

【经】尔时慧命舍利弗白佛言。世尊。有菩萨摩诃萨。信解是般若波罗蜜者。从何处终来生是间。发阿耨多罗三藐三菩提心来为几时。为供养几佛。行檀波罗蜜尸罗波罗蜜羼提波罗蜜。毗梨耶波罗蜜禅波罗蜜般若波罗蜜来。几时能随顺。解深般若波罗蜜义。佛告舍利弗。是菩萨摩诃萨供养十方诸佛来生是间。是菩萨发阿耨多罗三藐三菩提心来。无量无边阿僧祇百千万亿劫。是菩萨摩诃萨。从初发心常行檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。供养无量无边不可思议阿僧祇诸佛来生是间。舍利弗。是菩萨摩诃萨若见若闻般若波罗蜜作是念。我见佛从佛闻法。舍利弗。是菩萨摩诃萨。能随顺解深般若波罗蜜义。以无相无二无所得故。须菩提白佛言。世尊。是般若波罗蜜可闻可见耶。佛告须菩提。是般若波罗蜜无有闻者无有见者。般若波罗蜜无闻无见。诸法钝故。禅波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀波罗蜜无闻无见。诸法钝故。内空无闻无见。诸法钝故。乃至无法有法空无闻无见。诸法钝故。四念处无闻无见诸法钝故。乃至八圣道分无闻无见。诸法钝故。佛十力乃至十八不共法无闻无见。诸法钝故。须菩提。佛及佛道无闻无见。诸法钝故。须菩提白佛言。世尊。是菩萨几时行佛道。能习行如是深般若波罗蜜。佛告须菩提。是中应分别说。须菩提。有菩萨摩诃萨。初发意习行深般若波罗蜜禅波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀波罗蜜。以方便力故。于诸法无所破坏。不见诸法无利益者。亦终不远离行六波罗蜜。亦不远离诸佛。从一佛世界。至一佛世界。若欲以善根力供养诸佛随意即得。终不生母人腹中。终不离诸神通。终不生诸烦恼及声闻辟支佛心。从一佛世界。至一佛世界。成就众生净佛世界。须菩提。如是等诸菩萨摩诃萨。能习行深般若波罗蜜。须菩提。有菩萨摩诃萨多见诸佛。若无量百千万亿。从诸佛所行布施持戒忍辱精进一心智慧。皆以有所得故。是菩萨闻说深般若波罗蜜时。便从众中起去。不恭敬深般若波罗蜜及诸佛。是菩萨今在此众中坐。闻是甚深般若波罗蜜。不乐便舍去。何以故。是善男子善女人等。先世闻深般若波罗蜜时弃舍去。今世闻深般若波罗蜜。亦弃舍去身心不和。是人种愚痴因缘业。种是愚痴因缘罪故。闻说深般若波罗蜜毁呰。毁訾般若波罗蜜故。毁呰过去未来现在诸佛一切智一切种智。是人毁呰三世诸佛一切智起破法业。因缘集故。无量百千万亿岁。堕大地狱中。是破法人辈。从一大地狱。至一大地狱。若火劫起时至他方大地狱中生在彼间。从一大地狱。至一大地狱。彼间若火劫起时。复至他方大地狱中生在彼间。从一大地狱。至一大地狱。如是遍十方。彼间若火劫起故从彼死。破法业因缘未尽故。还来是间大地狱中生此间。亦从一大地狱。至一大地狱受无量苦。此间火劫起故。复至十方他世界生畜生中。受破法罪业苦。如地狱中说。重罪渐薄或得人身。生盲人家生旃陀罗家。生除厕担死人种种下贱家。若无眼若一眼若眼瞎若无舌无耳无手。所生处无佛无法无佛弟子处。何以故。种破法业积集厚重具足故。受是果报。尔时舍利弗白佛言。世尊。五逆罪与破法相似耶。佛告舍利弗。不应言相似。所以者何。若有人听说是甚深般若波罗蜜时。毁呰不信作是言。不应学是法。是非法非善非佛教。诸佛不说是语。是人自毁訾般若波罗蜜。亦教他人毁訾般若波罗蜜。自坏其身亦坏他人身。自饮毒杀身。亦饮他人毒。自失其身。亦失他人身。自不知不信。毁訾深般若波罗蜜。亦教他人令不信不知。舍利弗。如是人我不听闻其名字。何况眼见。何以故。当知是人名为污法人。为堕衰浊黑性。如是人若有听其言信用其语。亦受如是苦。舍利弗。若人破般若波罗蜜。当知是名为破法人。舍利弗白佛言。世尊。世尊说破法之人所受重罪。不说是人所受身体大小。佛告舍利弗。不须说是人受身大小。何以故。是破法人若闻所受身大小。便当吐热血若死若近死苦。是破法人闻如是身有如是重罪。是人便大愁忧。如箭入心渐渐干枯作是念。破法罪故。得如是大丑身。受如是无量苦。以是故佛不听舍利弗问是人所受身体大小。舍利弗白佛言。愿佛说之。为未来世作明诫。令知破法业积集故。得如是大丑身受如是大苦。佛告舍利弗。后世人若闻是破法业积集厚重具足受大地狱中久久无量苦。闻是久久无量苦时。足为未来世作明诫。舍利弗白佛言。世尊。若白净善男子善女人。闻是法足作依止。宁失身命终不破法。自念我若破法。当受如是苦

【论】释曰。舍利弗。闻般若波罗蜜甚深微妙闻者尚难何况能行。是故言信解般若者是为希有。是故问。世尊若信解般若者。是人于何处终来生是间。舍利弗作是念。是人应从好世界终来生是间。是人不应新发意。不应少供养佛。不应少行六波罗蜜。必是大德人。未圣而能知圣法故。是故问。发意几时供养几佛。行六波罗蜜几时。能随顺解深般若波罗蜜义者。是菩萨于诸法不取相不着空。行空行和合五波罗蜜。行般若波罗蜜。用大慈悲心。为一切众生。行般若波罗蜜故。十方诸佛清净世界中终来生是间者。为度有缘众生。又与释迦文尼佛。共因缘故。虽有此间死此间生者。但以从他方佛所来者贵故。发心来无量阿僧祇劫。诸福德力集厚故。能信解随顺深义。有人虽无量阿僧祇劫发心。久不行功德者。是故说从发心来常行六波罗蜜。常行六波罗蜜福德故。能得见能得供养无量无边阿僧祇佛。是菩萨成就上四因缘故。得无量无边福德智慧。是福德因缘故。诸烦恼薄心柔软。菩萨信慧等。诸根利转增得力故。深入般若波罗蜜。污厌世间事。若见般若波罗蜜经卷。即时心生如见佛。若披卷寻义。即时心生如从佛闻。信力成就慧力成就故。随顺解深般若波罗蜜义。所谓一切无相故。出十二入。二法不二法中。心无所著故。名无所得。略说三相。是随顺解般若波罗蜜义。须菩提闻说见经卷如见佛。读经文如从佛闻。如似有着。是故问。般若可见可闻耶。须菩提意。以般若波罗蜜毕竟空。天眼天耳犹不能见闻。何况肉眼肉耳。出世间慧眼亦不得见。何况世间眼。佛顺其意答。般若波罗蜜不可得见闻。此中说因缘。诸法入般若波罗蜜中。皆一相无相。是中无分别闻者见者及可闻可见。三界凡夫人。作分别是眼是色是耳是声。六情是利六尘是钝。色等诸法是钝。慧等是利。诸法入般若波罗蜜中。如百川归海皆为一味。是故说般若波罗蜜不可见不可闻。以诸法钝故。从檀波罗蜜。乃至佛道须陀洹。乃至佛亦如是。复次众生离法不能闻。不能见。法离众生亦不能闻不能见。问曰。上已问菩萨发意几时供养几佛能顺解深义。今何以更问。答曰。上佛说般若无闻无见。亦说见般若经卷如见佛。读般若如从佛闻二相说。是般若亦言可见可闻。亦言不可见不可闻。是故还问。佛菩萨几时行得是方便。能行有能行无。行有不堕三界。行无不堕断灭。能随般若波罗蜜相行。佛答有此事不定。应当分别说。或有菩萨。初发心便能习行甚深六波罗蜜。习行者一心信受常行。方便力故者。虽行六波罗蜜。起福德因缘。而心不着诸法。无所破坏者。是菩萨信力智慧力大故。闻摩诃衍深法。即时信闻声闻法。亦信闻外道在家出家法亦不破坏。而于中出二种利。一者分别是道非道。舍非道行是道。二者一切法入般若波罗蜜中。无是无非无破无受。不见诸法无利益者。即是上说。于中出利者。是德福具足故。终不远离六波罗蜜。乃至净佛世界。略说义。有菩萨虽新发意。深信受是般若波罗蜜。有菩萨久发意。供养千万亿诸佛。用有所得行六波罗蜜。不信受是般若波罗蜜。此中佛自说因缘。是人于过去世。闻深般若波罗蜜。不信不受从坐起去。今佛为说不信不受。破般若波罗蜜罪业果报故。说是人不信不受业因缘故。即起愚痴业因缘。得愚痴业因缘故。疑悔恶邪着心转增。着心转增故。于大众中。毁訾破坏般若波罗蜜。破坏般若波罗蜜故。破三世十方诸佛一切智。破三世十方诸佛一切智罪故。转身堕大地狱。大地狱者。阿鼻地狱。无量百千万亿阿僧祇岁。受忧愁苦恼。忧愁是心苦。恼是身苦。从一大地狱。至一大地狱者。如福德因缘故。上有六欲天。罪业因缘亦如是。下有八种大地狱。八种大地狱。各有十六小地狱。是中阿鼻最大。余须弥四天下亦如是。是三千大千世界中。有百亿须弥山。有百亿阿鼻地狱。是故说从一阿鼻大地狱至一阿鼻大地狱。如人从会至会。又如入正位者从天上来受人间乐从人中还至天上受乐。若此间火劫起。其罪未尽故。转至他处。十方世界大地狱中受罪。若彼间火劫起。复展转至他方。他方火劫起。复还生此间阿鼻地狱中。展转如前。是破般若波罗蜜罪。小灭展转生勤苦畜生中。此间火劫起。复生他方世界畜生中展转受苦。彼间火劫起还来此间。复展转如前。罪转微轻或得人身生下贱家。所谓生生盲家。不欲见般若波罗蜜。罪故轻贱说法人故生旃陀罗及除粪担死人等下贱家。毁呰说法者故无舌。不欲闻故无耳。麾手非拨故无手。此人心虽爱佛。以愚痴无智故。毁灭佛母破坏法藏。破坏法藏故。生无佛法众处。问曰。何以不说生饿鬼中。答曰。是破坏法者。多以二烦恼。所谓嗔恚愚痴。悭贪发故堕饿鬼。此中无悭故不说。问曰。舍利弗何以言五逆罪与破法罪相似。答曰。舍利弗。是声闻人常闻五逆罪最重堕阿鼻地狱一劫受苦。声闻人不悉知供养般若得大果报。又不知谤毁般若得大罪故。举五逆对问相似不。答言。不相似者。以相去悬远故。所以者何。此人毁谤般若者自失大利。亦令他失。自远离般若。亦令他远离。自破坏善根。亦破他善根。自涂邪见毒。亦涂他邪见毒。自失其身亦失他身。自不知故。着法爱故破。亦令他破般若波罗蜜。如父母爱子恩极一世。又以因缘故爱。是行般若波罗蜜菩萨。于无边世中。深心爱念众生。父母念子无能以一眼与者。行般若波罗蜜者。于无边劫中。以头目髓恼积过须弥。以施众生。出佛身血杀阿罗汉。但坏肉身不坏法身。坏僧是离眷属赞五法不坏般若。是故五逆罪不得似坏般若波罗蜜。般若波罗蜜。能令人作佛。毁般若罪则无喻。是故破般若人。我不欲听闻其名字。何况眼见是破般若人。或先世福德因缘。广学多闻富贵威德巧于谈语诸魔官属常随逐佐助故。未得阿鞞跋致。菩萨见其多人供养多有出家在家弟子。是故若有说其名者不听闻之。何况亲附礼拜受其教训。所以者何。菩萨欲增长善法利益众生。是人欲破法令众生堕大衰浊。二事相违故。衰浊者。如人着衰。虽好衣美食常无色力。虽勤身作务财产日耗。是人坏一切佛上法宝故。虽身口业善。持戒布施赞经善法终不增长。如浊水泥不见面像亦不中饮。是人不中亲近。若亲近者则喜染着。是人破法故。邪见疑悔常扰乱心。先所闻法深染爱着。不解般若波罗蜜相故。言般若波罗蜜无所有空不坚固无有罪福。如是浊乱蔽其心故。不能得见清净实法相。黑性者。佛法中善法名白。不善法名黑。是人常积集不善法故成不善性。若有信受其语其罪亦同。问曰。舍利弗何以问是人受身大小而佛不答。答曰。舍利弗既闻受罪时节及处所。不闻其身大小。意欲闻佛说其大身。又如帝释身长十里。受乐遍满故。欲知受罪身大受苦亦多。有二因缘故佛不为说。一者上已说。其在二恶道中久受苦恼。今复说其身大丑恶人。或不信。不信者当受久剧之苦故。二者若信佛语则大忧怖。忧怖故风发吐热血。死若死等者。设令不死身常干枯。若不信后世受重罪故佛不说。舍利弗白佛。今虽以二因缘故不说。愿怜愍未来世人故说。佛言若有善根白性福德人足作依止。白性者与黑性相违。依止者。闻是受苦更不敢作若不信。虽说身大亦不信。若信闻上受苦久远足可信

大智度论卷第六十二大智度论释信谤品第四十一之余(卷六十三)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】尔时须菩提白佛言。世尊。若善男子善女人。应好摄身口意业无受如是诸苦。或不见佛。或不闻法。或不亲近僧。或生无佛世界中。或生人中堕贫穷家。或人不信受其言。须菩提白佛言。世尊。以积集口业故。有是破法重罪耶。佛告须菩提。以积集口业故。有是破法重罪。须菩提。是愚痴人在佛法中出家受戒。破深般若波罗蜜毁呰不受。须菩提。若破般若波罗蜜。毁呰般若波罗蜜。则为破十方诸佛一切智。一切智破故。则为破佛宝。破佛宝故破法宝。破法宝故破僧宝破三宝故。则破世间正见。破世间正见故。则为破四念处。乃至破一切种智法。破一切种智法故。则得无量无边阿僧祇罪。得无量无边阿僧祇罪已。则受无量无边阿僧祇忧苦。须菩提白佛言。世尊。是愚痴人毁呰破坏深般若波罗蜜有几因缘。佛告须菩提。有四因缘。是愚痴人毁呰破是深般若波罗蜜。须菩提言。世尊。何等四。是愚痴人为魔所使故。欲毁呰破坏深般若波罗蜜。是名初因缘。是愚痴人不信深法。不信不解心不得清净。是第二因缘故。是愚痴人欲毁呰破坏深般若波罗蜜。是愚痴人与恶知识相随。心没懈怠坚着五受众。是第三因缘故。是愚痴人欲毁呰破坏深般若波罗蜜。是愚痴人多行嗔恚自高轻人。是第四因缘故。是愚痴人。欲毁呰破坏深般若波罗蜜。须菩提。以是四因缘故。是愚痴人欲毁呰破坏深般若波罗蜜

【论】问曰。口业是破法。何以言摄身口意业。答曰。意业是口业之本。若欲摄口业先摄意业。意业摄故身口业亦善。身口业善意业亦善。是中须菩提自说因缘。莫受是诸苦或不见佛等。世间人以身业为重口业为轻。是故须菩提问。但以口业得如是罪耶。佛可其意示言。是愚痴人自无急事。又无使作者。亦无所得。而自以舌故。作如是罪是为大狂。是狂人未来世。在我法中出家。出家者五众。受戒者有七众。是声闻人。着声闻法佛法。过五百岁后。各各分别有五部。从是已来以求诸法决定相故。自执其法不知佛。为解脱故。说法而坚着语言。故闻说般若诸法毕竟空如刀伤心。皆言决定之法。今云何言无。于般若波罗蜜无得无著相中。作得作着相故。毁呰破坏言非佛教。佛怜愍众生故。为说是道非道。今般若中是道非道尽为一相所谓无相。是故先生疑后定心。于空法生邪见。邪见得力故。于大众中。处处毁坏般若波罗蜜。毁坏般若波罗蜜故。则破十方三世诸佛一切智等诸佛功德。破佛功德故即破三宝。三宝破故则破世间乐因缘。所谓世间正见。若破世间正见。则破出世间乐因缘。出世间正见。所谓四念处乃至一切种智。是法名为无量无边福德因缘。破是法故得无量无边罪。得无量无边罪故。受无量无边忧愁苦恼。问曰。先以说破法因缘。所谓爱着法等。须菩提何以更问。答曰。先论中说。今经中说。先不遍说。今遍广说。所谓四因缘。是人为魔所使。若魔若魔人来入其心中。转其身口令破般若波罗蜜。如阿难。佛三问阎浮提乐寿命。亦乐魔入身故三不答佛。阿难得初道犹为魔娆。何况凡人。复次魔有四种。五众魔烦恼魔死魔自在天子魔。四魔中多烦恼魔自在天子魔故。令不信般若。自贪着法憎嫉他法。愚痴颠倒故。能破般若波罗蜜。有人言。初因缘烦恼魔。后第四自在天子魔。是二种魔所使故。名为魔所使。坚着邪见贪爱自法。慧根钝故不识佛意。不信不受甚深般若故破。有人利根堪信魔又不来。但随恶师教故破般若。有人虽属恶知识。诸结使薄故。勤精进能信般若波罗蜜。是故二事和合为一。亦属恶知识。亦深着五众结使。厚生懈怠心。是故不信般若。是人世世多集嗔恚成其性。嗔相者是不信相。是人刚强自高。轻贱说法人。我智德如是尚不能解。况汝愚贱而能知之。以是嗔恚憍慢多故。破般若波罗蜜

【经】须菩提白佛言。世尊。是般若波罗蜜。不勤精进。种不善根。恶友相得人。难信难解。佛言。如是如是。须菩提。是深般若波罗蜜不勤精进。种不善根恶友相得人难信难解。须菩提白佛言。世尊。是般若波罗蜜云何甚深难信难解。须菩提。色不缚不解。何以故。无所有性。是色受想行识不缚不解。何以故。无所有性。是受想行识檀波罗蜜不缚不解。何以故。无所有性。是檀波罗蜜尸罗波罗蜜不缚不解。何以故。无所有性。是尸罗波罗蜜。羼提波罗蜜不缚不解。何以故。无所有性。是羼提波罗蜜。毗梨耶波罗蜜不缚不解。何以故。无所有性。是毗梨耶波罗蜜。禅波罗蜜不缚不解。何以故。无所有性。是禅波罗蜜。般若波罗蜜不缚不解。何以故。无所有性。是般若波罗蜜。须菩提。内空不缚不解。何以故。无所有性。是内空乃至无法有法空不缚不解。何以故。无所有性。是无法有法空四念处不缚不解。何以故。无所有性。是四念处乃至一切智。一切种智不缚不解。何以故。无所有性。是一切种智。须菩提色本际不缚不解。何以故。本际无所有性。是色受想行识。乃至一切种智本际不缚不解何以故。本际无所有性。是一切种智。须菩提。色后际不缚不解。何以故。后际无所有性。是色受想行识。乃至一切种智。后际不缚不解。何以故。后际无所有性。是一切种智。须菩提。现在色不缚不解。何以故。现在无所有性。是色受想行识。乃至现在一切种智不缚不解。何以故。现在无所有性。是一切种智。须菩提白佛言。世尊。是般若波罗蜜不勤精进。不种善根恶友相得。懈怠少进喜忘无巧便慧。如此之人实难信难解。如是如是。须菩提。是般若波罗蜜不勤精进。不种善根恶友相得系属于魔。懈怠少进喜忘无巧便慧。如此之人实难信难解。何以故。色净果亦净。受想行识净果亦净。乃至阿耨多罗三藐三菩提净果亦净。复次须菩提。色净故。即般若波罗蜜净。般若波罗蜜净即色净。受想行识净。故即般若波罗蜜净。般若波罗蜜净。即受想行识净。乃至一切种智净。即般若波罗蜜净。般若波罗蜜净。即一切种智净。色净般若波罗蜜净。无二无别无断无坏。乃至一切种智净。般若波罗蜜净。无二无别无断无坏。复次须菩提。不二净故色净。不二净故。乃至一切种智净。何以故。是不二净色净。乃至一切种智净。无二无别故。我净众生净。乃至知者见者净故色净。受想行识净。乃至一切种智净。色净乃至一切种智净故。我众生乃至知者见者净。何以故。我众生乃至知者见者净。色净乃至一切种智净。不二不别无断无坏

【论】释曰。尔时须菩提白佛言。是般若波罗蜜甚深故。懈怠随恶知识。种不善根故难信。与上相违。名为信般若波罗蜜。佛可其言。须菩提更问是般若波罗蜜。云何甚深故难信。佛答。色等诸法无缚无解。三毒是缚。三解脱门是解。是三毒等诸烦恼虚诳不实。从和合因缘生。无自性故无缚。无缚故无解。破是三毒故。三解脱门亦空。复次取相着法颠倒。一切烦恼等是缚缚法。若实定有自性者则不可解。若实定有谁能破者。若破即堕断灭中。若取相颠倒等诸烦恼。虚诳不实亦无所断。复次一切心心数法。忆想分别取相皆缚在缘中。若入诸法实相中。知皆是虚诳。如上品中说。心清净相者。即是非心相是缚。空故解亦空。如是等种种因缘故。色等诸法不缚不解。此中佛自说因缘。色等诸法有为作法。从因缘和合生故。无有定性故。说无所有性。是色等诸法。复次色等诸法三世中不缚不解。如破三世中说。是时须菩提。知般若波罗蜜非甚深非不甚深。如后品中说。若谓般若波罗蜜甚深。则远离般若波罗蜜。以是故白佛言。世尊恶人以般若波罗蜜甚深难解非谓善人。恶人者不与般若相应。不一心勤精进。不种解般若波罗蜜善根。随破坏般若。恶师懈怠者。着世间乐不愿出世间。如此人若有精进少不足言。诸烦恼乱心故。喜忘善不善法相不破憍慢。不除邪见戏论故。求诸法实相。不知分别诸法相好丑。是名无巧便慧。有如是等恶法故。是人难解甚深般若。佛可其意言如是如是。问曰。须菩提说中无有魔事。佛说中何以益魔事。答曰。须菩提直说内外因缘不具足。佛今具足说故。言是人为魔所使。佛更欲说甚深难解相告须菩提。色等诸法净故果亦净。四念处。是色等诸法果。何以故。观色等诸法不净无常等。即得身念处。余念如上说。是中四念处性无漏。断烦恼为涅槃故清净。见果净故知因亦净。问曰。先说观色不净无常等得身念处。云何言果净故知因亦净。答曰。不净观是初入门非实观。是故不入十六圣行。是十六行中。观无常苦空无我。不观不净。净颠倒故生淫欲。破净故言不净非是实。是故不净不入十六圣行。但是得解观。是般若中不观常不观无常。不观净不观不净等。常无常净不净空实等诸观灭。戏论灭是色实相。色实相净故果亦净。复次佛此中自说因缘。般若波罗蜜如虚空。毕竟净无所染污。是般若波罗蜜观色等。诸法实相不生不灭。行六波罗蜜。修四念处等。如是可得般若波罗蜜。是般若波罗蜜三种因缘。正观正行正修。是故言般若波罗蜜净故。色等诸法净。色等诸法净故。般若波罗蜜净。所以者何。色等诸法般若波罗蜜。实相中无二无别。不异不别不离不散故不断不坏。复次如我法乃至十方三世中求不可得。于五众中。但有假名众生乃至知者见者亦如是。如我空无所有清净故。一切法亦如是

【经】复次须菩提。淫净故色净。乃至一切种智净。何以故。淫净色净乃至一切种智净不二不别。嗔痴净故色净。乃至一切种智净。何以故。嗔痴净色净。乃至一切种智净不二不别。复次须菩提。无明净故诸行净。诸行净故识净。识净故名色净。名色净故六入净。六入净故触净。触净故受净。受净故爱净。爱净故取净。取净故有净。有净故生净。生净故老死净。老死净故。般若波罗蜜净。般若波罗蜜净故。乃至檀波罗蜜净。檀波罗蜜净故内空净。内空净故乃至无法有法空净。无法有法空净故四念处净。四念处净故乃至一切智净。一切智净故一切种智净。何以故。是一切智净一切种智净。不二不别无断无坏。复次须菩提。般若波罗蜜净故色净。乃至般若波罗蜜净故一切智净。是般若波罗蜜净。一切智净。不二不别故。须菩提。禅波罗蜜净故乃至一切智净。毗梨耶波罗蜜。羼提波罗蜜。尸罗波罗蜜。檀波罗蜜净故乃至一切智净。内空净故乃至一切智净。四念处净故乃至一切智净。复次须菩提。一切智净故乃至般若波罗蜜净。如是一一如先说。复次须菩提。有为净故无为净。何以故。有为净无为净。不二不别无断无坏故。复次须菩提。过去净故未来现在净。未来净故过去现在净。现在净故过去未来净。何以故。现在净过去未来净。不二不别无断无坏故

【论】问曰。佛说三毒是垢秽不净。此中云何言淫欲等净故色等亦净。答曰。佛说三毒实性清净故。色等诸法亦清净。三毒净色等净故。不二不别。欲广说三毒清净及三毒清净果报因缘故。说无明净故。诸行亦净。无明净者。所谓无明毕竟空。如破无明十喻中说。从十二因缘。乃至一切种智亦如是。是故色等无明等。诸法清净故。般若波罗蜜清净。般若波罗蜜清净故。诸菩萨所行法。所谓禅波罗蜜。乃至一切种智皆清净。禅波罗蜜等诸法亦如是。复次用十八空故。色等乃至一切种智空。乃至一切种智空故。十八空亦空一切种智不离十八空。十八空不离一切种智。是故言不二不别。空者即是清净。今色乃至一切种智一法为首。余法各各为首。展转皆清净。复次诸法多无量故。略说有为无为。有为法实相。即是无为法。知净行者。于诸法中求常乐我净不可得。若不可得。是为实知有为法。实知不可得。即是无为法。是故说有为法净故。无为法清净。复次因有为法故。知无为法。圣人得是无为法。说有为法相。是故说有为法清净故。无为法清净。无为法清净故。有为法清净。有为法在三世中故说。过去世清净故。未来世亦清净。未来世清净故。过去世亦清净。所以者何。如过去世破坏散灭无所有故空。未来世。未生未有故空。二世无故。现在亦无。何以故。有先有后知有现在。复次有为法。念念生灭故无住时。住时无故。无现在世。三世空故。有为法空。有为法空故。无为法空。空即是毕竟清净不破不坏。无戏论如虚空。如是般若波罗蜜毕竟清净。三世诸佛法藏。破是能宣示实相般若言说文字故堕地狱。问曰。若不信般若堕地狱。信者得作佛。若有五逆罪破戒邪见懈怠之人。信是般若。是人得成佛不。复有持戒精进者。而不信般若。是云何堕地狱。答曰。破般若有二种。一者佛口所说。弟子诵习书作经卷。愚人谤言非是佛说。是魔若魔民所作。亦是断灭邪见人手笔。庄严口力者说。或言虽是佛说。其中处处余人增益。或有人着心分别取相。说般若波罗蜜。口说空法而心著有。初破者堕大地狱。不得圣人说般若意故。第二破着心论议者。是不名为破般若。如调达出佛身血只域亦出佛身血。虽同一名出血。心异故。一人得罪一人得福。如画作佛像一人以像不好故破一人以恶心故破。以心不同故。一人得福一人得罪。破般若波罗蜜者亦如是。复次或有人破般若。虽不嗔不轻佛。自用心忆想分别是甚深法。一切智人所说。应有深妙法。云何言都空。佛以无著心。为度众生故说法。是人以着心取相故。起口业毁呰。破坏般若。能起身业。手麾非拨指毁令去。与二种不信相违故。名二种信。一者知般若实义。信得如说果报。二者信经卷言语文字。得功德少。邪见罪重故。虽持戒等身口业好。皆随邪见恶心。如佛自说喻譬。如种苦种。虽复四大所成皆作苦味。邪见人亦如是。虽持戒精进皆成恶法。与此相违名为正见。五逆罪人恶罪常覆心。疑今世后世业果。何况能信甚深般若。虽复书经卷供养望免恶罪。去般若大远。或有遇善知识。先世精进福德。利智第一信般若波罗蜜清净因缘。能得如所说果报。如阿阇世王。杀父之罪。蒙佛文殊师利善知识故。除其重罪。得如所说般若果报。受无上道记

    大智度论释叹净品第四十二

【经】尔时舍利弗白佛言。世尊。是净甚深。佛言。毕竟净故。舍利弗言。何法净故是净甚深。佛言。色净故是净甚深。受想行识净故。四念处净故。乃至八圣道分净故。佛十力净故。乃至十八不共法净故。菩萨净故。佛净故。一切智一切种智净故。是净甚深。世尊。是净明。佛言。毕竟净故。舍利弗言。何法净故是净明。佛言。般若波罗蜜净故是净明。乃至檀波罗蜜净故是净明。四念处乃至一切智净故是净明。世尊。是净不相续。佛言。毕竟净故。舍利弗言。何法不相续故。是净不相续。佛言。色不去不相续故。是净不相续。乃至一切种智不去不相续故。是净不相续。世尊。是净无垢。佛言。毕竟净故。舍利弗言。何法无垢故是净无垢。佛言。色性常净故是净无垢。乃至一切种智性常净故是净无垢。世尊。是净无得无著。佛言。毕竟净故。舍利弗言。何法无得无著故。是净无得无著。佛言。色无得无著故。是净无得无著。乃至一切种智无得无著故。是净无得无著。世尊。是净无生。佛言。毕竟净故。舍利弗言。何法无生故是净无生。佛言。色无生故。是净无生。乃至一切种智无生故。是净无生。世尊。是净不生欲界中。佛言。毕竟净故。舍利弗言。云何是净不生欲界中。佛言。欲界性不可得故。是净不生欲界中。世尊。是净不生色界中。佛言。毕竟净故

舍利弗言。云何是净不生色界中。佛言。色界性不可得故。是净不生色界中。世尊。是净不生无色界中。佛言。毕竟净故。舍利弗言。云何是净不生无色界中。佛言。无色界性不可得故。是净不生无色界中。世尊。是净无知。佛言。毕竟净故。舍利弗言。云何是净无知。佛言。诸法钝故。是净无知世尊。色无知是净净。佛言。毕竟净故。舍利弗言。云何色无知是净净。佛言。色自性空故色无知是净净。世尊。受想行识无知是净净。佛言。毕竟净故。舍利弗言。云何受想行识无知是净净。佛言。受想行识自性空故无知是净净。世尊。一切法净故是净净。佛言。毕竟净故。舍利弗言。云何一切法净故是净净。佛言。一切法不可得故。一切法净是净净。世尊。是般若波罗蜜。于萨婆若无益无损。佛言。毕竟净故。舍利弗言。云何般若波罗蜜。于萨婆若无益无损。佛言。法常住相故。般若波罗蜜。于萨婆若无益无损。世尊。是般若波罗蜜净。于诸法无所受。佛言。毕竟净故。舍利弗言。云何般若波罗蜜净。于诸法无所受。佛言。法性不动故。是般若波罗蜜净。于诸法无所受

【论】释曰。是净甚深者。净有二种。一者智慧净。二者所缘法净。此二事相待。离智净无缘净。离缘净无智净。所以者何。一切心心数法从缘生。若无缘则智不生。譬如无薪火无所然。以有智故知缘为净。无智则不知缘净。此中智净缘净相待世间常法。是中说离智离缘诸法实相本自清净。为心心数法所缘则污染不清净。譬如百种美食与毒同器则不可食。诸法实相常净。非佛所作。非菩萨辟支佛声闻一切凡夫所作。有佛无佛常住不坏相。在颠倒虚诳法及果报中则污染不净。是清净有种种名字。或名如法性实际。或名般若波罗蜜。或名道。或名无生无灭空无相无作无知无得。或名毕竟空等。如是等无量无边名字。舍利弗观是般若波罗蜜相。虽不可见不可闻不可说不可破坏而诽谤得无量罪。信受正行则得无上果报。舍利弗发希有欢喜心。而白佛言。世尊。是净甚深。佛答。汝所见者以为希有。实相中复过汝所见。一切法中。毕竟净无所著。乃至净体亦不着。是名毕竟清净。复次清净主。所谓十方三世诸佛。诸佛亦不着是清净。是故言毕竟清净故是清净。般若波罗蜜。能令一切贤圣无边苦尽。有是大利益。而亦不着是般若波罗蜜。如是有无量因缘毕竟清净。是净甚深。舍利弗问。何法毕竟清净故是净甚深。佛答。色等诸法清净故。是净甚深。所以者何。色等诸法本末因果清净故。是净甚深。如上品中说。菩萨于色等法中观行断故。得如是清净。以是故。名色等清净。是净能破一切法中戏论无明能与毕竟空智慧光明。是故言净明。行檀波罗蜜等诸菩萨妙法故。得是净明。是净能与有余涅槃故。言是净明。今与无余涅槃故。言是净不相续。先以空等三三昧舍诸善法。后寿命自然尽故。色等五众不去。亦不相续故净不相续。以百八诸烦恼不能遮覆污染净故。言净无垢。行如是诸法实相不二道。从苦法忍乃至十五心是名得。第十六心得沙门果。是名著。著者着不堕落。得之别名也。复次行六波罗蜜。乃至生柔顺忍。是名得。能生无生法忍入菩萨位。是名著。是清净法中。用无所得心。无此二事故。名无得无著。行如是法知一切法毕竟空。毕竟空故不取相。不取相故。不起不作三种业。不作业故。一切世间无生。世间所谓三界。此中二因缘故不生。一者三种生业不起故。二者三界自性不可得故。此中佛总说因缘。所谓三界自性空。是故说三界色等诸法自性不可得。是净无知诸法钝故。如上品中说。一切诸法性常不生。不生故不可得。不可得故毕竟清净。舍利弗得声闻波罗蜜。佛为一切智人。是二人问答故。诸菩萨贪着是般若波罗蜜。是故舍利弗。欲断其贪着故。说言世尊般若波罗蜜。虽有如是功德。毕竟清净故。于萨婆若亦无益无损。如梦如幻。中虽有得失。亦无益无损。如虚空毕竟清净无所有。亦因是虚空有所成济。亦不得言空有所作。亦不得言空无所益。檀波罗蜜。因般若波罗蜜有所作。是故言般若波罗蜜无益无损。般若波罗蜜。观一切法有失不净。无常苦空无我不生不灭非不生非不灭等。种种因缘赞叹。灭诸观戏论断语言道。是故说般若波罗蜜清净。于诸法无所受。灭诸观戏论断语言道。即是入法性相。是故此中说法性不动故

【经】尔时慧命须菩提白佛言。世尊。我净故色净。佛言。毕竟净故。须菩提言。以何因缘。我净故色净毕竟净。佛言。我无所有故。色无所有毕竟净。世尊。我净故受想行识净。佛言。毕竟净故。须菩提言。何因缘故。我净故受想行识净毕竟净。佛言。我无所有故。受想行识无所有毕竟净。世尊。我净故檀波罗蜜净。我净故尸罗波罗蜜净。我净故羼提波罗蜜净。我净故毗梨耶波罗蜜净。我净故禅波罗蜜净。世尊。我净故般若波罗蜜净。世尊。我净故四念处净。世尊。我净故乃至八圣道分净。世尊。我净故佛十力净。世尊。我净故乃至十八不共法净。佛言。毕竟净故。须菩提言。何因缘故。我净檀波罗蜜净。我净乃至十八不共法净。佛言。我无所有故。檀波罗蜜无所有净。乃至十八不共法无所有故净。世尊。我净故须陀洹果净。我净故斯陀含果净。我净故阿那含果净。我净故阿罗汉果净。我净故辟支佛道净。我净故佛道净。佛言。毕竟净。须菩提言。何因缘故。我净须陀洹果净。斯陀含果净。阿那含果净。阿罗汉果净。辟支佛道净。佛道净。佛言。自相空故。世尊。我净故一切智净。佛言。毕竟净故。须菩提言。何因缘故。我净故一切智净。佛言。无相无念故。世尊。以二净故无得无著佛言。毕竟净。须菩提言。何因缘故。以二净故。无得无著是毕竟净。佛言。无垢无净故。世尊。我无边故。色净受想行识净。佛言。毕竟净。须菩提言。何因缘故。我无边故。色净受想行识净。佛言。毕竟空无始空故。须菩提白佛言。世尊。若菩萨摩诃萨能如是知。是名菩萨摩诃萨般若波罗蜜。佛言。毕竟净故。须菩提言。何因缘故。菩萨摩诃萨能如是知。是名菩萨摩诃萨般若波罗蜜。佛言。知道种故。世尊。若菩萨摩诃萨行般若波罗蜜。以方便力故作是念。色不知色。受想行识不知识。过去法不知过去法。未来法不知未来法。现在法不知现在法。佛言。菩萨摩诃萨行般若波罗蜜。以方便力故。不作是念。我施与彼人。我持戒如是持戒。我修忍如是修忍。我精进如是精进。我入禅如是入禅。我修智慧如是修智慧。我得福德如是得福德。我当入菩萨法位中。我当净佛世界成就众生。当得一切种智。须菩提。是菩萨摩诃萨行般若波罗蜜。以方便力故。无诸忆想分别。内空外空内外空空空大空第一义空有为空无为空无始空散空性空诸法空自相空故。须菩提。是名菩萨摩诃萨行般若波罗蜜。方便力故无所碍

【论】释曰。佛初命须菩提说般若。有所说不应求其因缘。若余人所说者当求因缘。舍利弗已问清净相佛作证。今须菩提说清净相。佛亦为证。我净故五众净者。如我毕竟无所有不可得。五众亦如是。毕竟空即是我清净。五众清净解我空易。解五众空难。是故以易解喻难解。六波罗蜜。乃至十八不共法。须陀洹果乃至佛道亦如是。我净故是法亦净。问曰。上言我无所有故。色乃至十八不共法亦无所有。今何以说须陀洹果乃至佛道自相空。答曰。我从和合因缘假名生。于无我中有我颠倒。是故说我虚妄无所有。以五众着处因缘故无所有。檀波罗蜜等诸法。虽善是有为作法。菩萨所著故言无所有。须陀洹果等是无为法。无为法自相空。所谓无生无灭无住异。故是故不说无所有。但言自相空。复次有为法中邪行多故。说无所有。无为法中。无生无灭无邪行故。说自相空。我净一切种智净者。以菩萨深着故。无相无念。无相者。是无相三昧。无念者。于无相三昧亦不念。今须菩提。知般若波罗蜜真清净故白佛。用二净故无得无著。清净有二种。一者用二法清净。二者用不二法清净。二法清净是名字清净。用不二法清净者。是真清净。佛言。诸法毕竟空相。云何以二法清净有得有着。此中说因缘。所谓一切法无垢无净。二清净中分别是垢是净。我无边故。五众清净者。如我空。空故无边。五众亦如是。问曰。常言毕竟清净故。今何以言毕竟空无始空。答曰。毕竟空。即是毕竟清净。以人畏空故言清净。此中说我无边。我即众生众生空。何以故。无始空故。问曰。能如是知是名般若者。能以众生空法空。以一切法毕竟空。是名般若波罗蜜。般若波罗蜜。即是毕竟清净。佛常答毕竟空。是故问。若毕竟空。云何言菩萨能如是知是名菩萨般若(难毕竟空也以毕竟空无知故)佛言。知道种故。菩萨虽知一切法毕竟空。欲令众生得此毕竟空远离着心。毕竟空但为破着心。故说。非是实空(毕竟空即是答道种智)尔时须菩提白佛言。世尊。行般若者作是念。色不知色等。佛意般若无定相。但以道种智故分别说。令菩萨行般若。有方便故。法虽毕竟空亦如是。知色不知色法等。观一切法毕竟空。唯有能观智慧在。不应毕竟空以引导众生着心令入毕竟空。佛答。若菩萨行般若。有方便能观外法毕竟空。色不知色等。内自观内心亦如是。方便力故。若行檀时不作是念。我施与彼彼是受施。须菩提色不知色等者。一切法空故不相知。不相知故无所作。破二事。所谓受者所施物(此二事皆是外也)今破与者。乃至我修一切种智亦如是。此中说因缘。菩萨行般若方便故。无如是分别。以内空故。乃至自相空。是十三空破诸法尽。后五种空总相说。是名菩萨无所碍。无所碍者。以是诸空于一切法无所碍

大智度论卷第六十三大智度论释叹净品第四十二之余(卷六十四)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】尔时释提桓因问须菩提。云何是求菩萨道善男子碍法。须菩提报释提桓因言。憍尸迦。有求菩萨道善男子善女人。取心相。所谓取檀波罗蜜相。取尸罗波罗蜜相羼提波罗蜜相。毗梨耶波罗蜜相。禅波罗蜜相。般若波罗蜜相。取内空相外空相内外空相乃至无法有法空相。取四念处相乃至八圣道分相。取佛十力相乃至十八不共法相。取诸佛相。取于诸佛种善根相。是一切福德和合取相。回向阿耨多罗三藐三菩提。憍尸迦。是名求菩萨道善男子善女人碍法。用是法故。不能无碍行般若波罗蜜。何以故。憍尸迦。是色相不可回向。受想行识相不可回向。乃至一切智相不可回向。复次憍尸迦。若菩萨摩诃萨示教利喜他人阿耨多罗三藐三菩提。应示教利喜一切诸法实相。若求菩萨道善男子善女人。行檀波罗蜜时。不应作是分别言。我施与我持戒我忍辱我精进我入禅我修智慧。我行内空外空内外空。乃至我行无法有法空。我修四念处。乃至我行阿耨多罗三藐三菩提。善男子善女人。应如是示教利喜他人阿耨多罗三藐三菩提。若如是示教利喜阿耨多罗三藐三菩提自无错谬。亦如佛所许法示教利喜。令是善男子善女人远离一切碍法。尔时佛赞须菩提。善哉善哉。如汝为诸菩萨说诸碍法。须菩提。汝今更听。我说微细碍相。汝须菩提。一心好听。佛告须菩提。有善男子善女人。发阿耨多罗三藐三菩提心。取相念诸佛。须菩提。所可有相皆是碍相。又于诸佛从初发意乃至法住。于其中间所有善根取相忆念。取相忆念已。回向阿耨多罗三藐三菩提。须菩提。所可有相皆是碍相。又于诸佛及弟子所有善根及余众生善根。取相回向阿耨多罗三藐三菩提。须菩提。所可有相皆是碍相。何以故。不应取相忆念诸佛。亦不应取相念诸佛善根。须菩提白佛言。世尊。是般若波罗蜜甚深。佛言一切法常离故。须菩提言世尊。我当礼般若波罗蜜。佛告须菩提。是般若波罗蜜。无起无作故。无有能得者。须菩提言。世尊。一切诸法亦不可得。佛言。一切法一性非二性。须菩提。是一法性是亦无性。是无性即是性。是性不起不作。如是须菩提。菩萨摩诃萨若知诸法一性。所谓无性无起无作。则远离一切碍相。须菩提白佛言。世尊。是般若波罗蜜难知难解。佛言。如所言。是般若波罗蜜无见者无闻者无知者无识者无得者。世尊。是般若波罗蜜不可思议。佛言。如所言。是般若波罗蜜不从心生。不从色受相行识生。乃至不从十八不共法生

【论】问曰。若与无碍相违。是名为碍。帝释何以更问碍。答曰。菩萨碍法微妙。入诸善法和合。利根者所觉。钝根者不觉。以难解故。于佛前更问碍法。何者是所谓菩萨分别悭心施心。舍悭心取施心。是名取心相。知布施物贵贱。知修集布施能一切与。是檀波罗蜜。乃至随喜福德取相。诸善法虽为是妙内着我外着法堕碍法中。譬如食虽香美过啖则病。此中须菩提自说因缘。色等诸法相。毕竟空故不可得回向无上道。上说碍相。今说无碍相。所谓菩萨若欲教他无上道。应以实法示教利喜。示教利喜义如先说。实法者。所谓灭诸忆想分别。是故说行檀时不分别我与等。若能如是教化得二种利。一者自无错谬。二者亦如佛所得法以化他人。如是等无量碍相相违。是名无碍相。问曰。佛以赞须菩提说无碍相。今何以故。复更自说微细碍相。答曰。佛就须菩提力中赞叹。汝是舍众生人。而能说菩萨碍相。微细碍相须菩提力所不及。是故佛自说是碍相。微细故汝一心好听。何者是所谓菩萨用取相念诸佛等。皆是碍无相相。是般若波罗蜜。佛从般若中出。亦是无相相。诸善根着心取相回向。是世间果报。有尽杂毒故。不能得无上道。问曰。上说粗碍言取相。今微细碍中亦言取相。有何差别。答曰。上说我是与者彼是受者。如是等今但说取相。复次今说诸菩萨念佛三昧故微细相。微细心人中碍。是故名微细碍。须菩提知佛所说深妙非己所及。是故赞言甚深。佛答。一切法常远离相故。佛说是般若远一切法。远一切法故微细相不得入般若中。须菩提欢喜言。我当为般若作礼。须菩提意作是念。我得解是般若波罗蜜甚深相故发心。我应作礼。佛言。是般若波罗蜜。无起无作故。十方如恒河沙佛无能得者。汝声闻人云何言得。须菩提言。世尊非但般若。一切法皆无知无得。佛言诸法一性无二。一性所谓毕竟空。无二者。无毕竟不毕竟一法性。即是无性毕竟空。不应着不应取相。所以者何。从因缘和合生故。须菩提作是念。若无性即是性。以不起不作故。后世苦不相续。能如是知般若波罗蜜。一切诸碍皆远离。若远离诸碍。则自在得无上道。须菩提闻是说作是念。我以为得佛谓不得。是般若波罗蜜难解难知。佛答非独汝难。一切众生无见者无闻者无知者无识者无得者。耳鼻舌身所不知意所不识不得是般若。出过六种知故言难解。须菩提入深般若中。智力穷极故。言不可思议。佛言是般若非心生非五众生。乃至不从十八不共法生。无生相故。问曰。若说不从心生。何以复说五众。五众中识众即是心。答曰。先说心是略说。后说五众等是广说。五众乃至十八不共法。可与般若作因缘。不能生般若。譬如猛风除云能令日月出现。而不能作日月也

    大智度论释无作实相品第四十三

【经】须菩提白佛言。是般若波罗蜜无所作。佛言。作者不可得故。色不可得。乃至一切法不可得故。世尊。若菩萨摩诃萨欲行般若波罗蜜。应云何行。佛告须菩提。菩萨摩诃萨欲行般若波罗蜜。不行色。是行般若波罗蜜。不行受想行识。是行般若波罗蜜。乃至不行一切种智。是行般若波罗蜜。不行色常无常。是行般若波罗蜜。乃至一切种智不行常无常。是行般若波罗蜜。不行色若苦若乐。是行般若波罗蜜。乃至不行一切种智若苦若乐。是行般若波罗蜜。不行色是我非我。是行般若波罗蜜。乃至不行一切种智是我非我。是行般若波罗蜜。不行色净不净。是行般若波罗蜜。乃至不行一切种智净不净。是行般若波罗蜜。何以故。是色无所有性。云何有常无常苦乐我无我净不净。受想行识亦无所有性云何有常无常乃至净不净。乃至一切种智无所有性。云何有常无常乃至净不净。复次须菩提。菩萨摩诃萨。行般若波罗蜜时。不行色不具足。是行般若波罗蜜。不行受想行识不具足。是行般若波罗蜜。乃至不行一切种智不具足。是行般若波罗蜜。何以故。色不具足者。是不名色。如是亦不行。是行般若波罗蜜。受想行识不具足者。是不名识。如是亦不行。是行般若波罗蜜。乃至不行一切种智。不具足者。是不名一切种智。如是亦不行。是行般若波罗蜜。须菩提白佛言。未曾有也。世尊。善说求菩萨道善男子善女人碍不碍相。佛言。如是如是。须菩提。佛善说求菩萨道善男子善女人碍不碍相。复次须菩提。若菩萨摩诃萨行般若波罗蜜时。不行色不碍。是行般若波罗蜜。不行受想行识不碍。是行般若波罗蜜。不行眼不碍。是行般若波罗蜜。不行耳鼻舌身不碍。是行般若波罗蜜。不行意不碍。是行般若波罗蜜。不行檀波罗蜜不碍。是行般若波罗蜜。不行尸罗波罗蜜不碍。是行般若波罗蜜。不行羼提波罗蜜不碍。是行般若波罗蜜。不行毗梨耶波罗蜜不碍。是行般若波罗蜜。不行禅波罗蜜不碍。是行般若波罗蜜。不行般若波罗蜜不碍。是行般若波罗蜜。乃至不行一切种智不碍。是行般若波罗蜜。须菩提。菩萨摩诃萨如是行般若波罗蜜时。知色是不碍。知受想行识是不碍。乃至知一切种智是不碍。知须陀洹果不碍。知斯陀含果不碍。知阿那含果不碍。知阿罗汉果不碍。知辟支佛道不碍。知阿耨多罗三藐三菩提道不碍。尔时慧命须菩提白佛言。未曾有也。世尊。是甚深法。若说亦不增不减。若不说亦不增不减。佛语须菩提。如是如是。是甚深法。若说亦不增不减。若不说亦不增不减。譬如佛尽形寿若赞若毁虚空。赞时亦不增不减。毁时亦不增不减。须菩提。如幻人。若赞时不增不减。毁时亦不增不减。赞时不喜毁时不忧。须菩提。诸法相亦如是。若说亦如本不异。若不说亦如本不异须菩提白佛言。世尊。诸菩萨摩诃萨所为甚难。修行是般若波罗蜜时。不忧不喜。而能习行般若波罗蜜。于阿耨多罗三藐三菩提亦不转还。何以故。世尊。修般若波罗蜜。如修虚空。如虚空中。无般若波罗蜜。无禅无毗梨耶无羼提无尸罗无檀波罗蜜。如虚空中。无色无受想行识。亦无内空外空内外空乃至无法有法空。无四念处。乃至无八圣道分。无佛十力。乃至无十八不共法。无须陀洹果斯陀含果阿那含果阿罗汉果。无辟支佛道。无阿耨多罗三藐三菩提。修般若波罗蜜亦如是。世尊。应礼是诸菩萨摩诃萨能大庄严。世尊。是人为众生大庄严勤精进。如为虚空大庄严勤精进。世尊。是人欲度众生。如欲度虚空。世尊。是诸菩萨摩诃萨大庄严。为虚空等众生大庄严。世尊。是人大庄严欲度众生。为如举虚空。世尊。诸菩萨摩诃萨大精进力。欲度众生故。发阿耨多罗三藐三菩提心。世尊。诸菩萨摩诃萨大庄严。欲度众生故。发阿耨多罗三藐三菩提心。世尊。诸菩萨摩诃萨大勇猛。为度如虚空等众生故。发阿耨多罗三藐三菩提心。何以故。世尊。若三千大千世界满中诸佛。譬如竹苇甘蔗稻麻丛林。诸佛若一劫若减一劫说法。一一佛度无量无边阿僧祇众生。令入涅槃。世尊。是众生性亦不减亦不增。何以故。众生无所有故。众生离故。乃至十方世界中诸佛所度众生亦如是。世尊。以是因缘故。我如是说。是人欲度众生故。发阿耨多罗三藐三菩提心。为欲度虚空。是时有一比丘作是言。我当礼般若波罗蜜。般若波罗蜜中。虽无法生无法灭。而有戒众定众慧众解脱众解脱知见众。而有诸须陀洹诸斯陀含诸阿那含诸阿罗汉诸辟支佛。有诸佛。而有佛宝法宝比丘僧宝。而有转法轮

【论】释曰。须菩提闻佛说般若波罗蜜无起无作相。是故今在佛前。说般若波罗蜜无所作。若无作者。不能断诸烦恼。不能修集诸善法。此中佛说因缘。从作者乃至一切法不可得故。知者尚无。何况作者。须菩提言。若无作者。般若波罗蜜无所能作。应云何行云何得般若波罗蜜。佛言。若菩萨不行一切法。不得一切法。所谓若常若无常。乃至若净若不净。是名行般若波罗蜜。一切法者。从色乃至一切种智。是菩萨行法。是法中无智人。行诸法常等。智人行诸法无常等。是般若波罗蜜。示诸法毕竟实相故。不说诸法常无常。无常等虽能破常等颠倒。般若中不受是法。以能生着心故。思惟筹量。求常无常相。不可得定实。问曰。色等罪法。可观不净苦。余善法云何观不净苦。答曰。是名字不净苦。如随意安稳好法。名清净快乐。不随意非安稳法。名不净苦。于善法中爱乐悦可者。以为净乐。厌恶不喜者。以为不净苦。须菩提作是念。若离诸观法者。将无不具足菩萨道耶。是故佛说。若不行色等不具足。是行般若波罗蜜。色具足者。有人言。色等法中。常无常等忆想分别。是名具足。不具足者。是中用无常等观破常等。是名不具足。少常等故。今于色中亦不行无常等。是故言不行色不具足。是为行般若波罗蜜。复次有人言。具足者。谓补处菩萨能如色实观。乃至一切种智是名具足。余者是不具足。若菩萨不行色等不具足者。即是行具足般若波罗蜜。何以故。色不具足则非色。色非无常相故。佛言出众生于常中。着无所有中。随语言音声故。是故说。如是实清净亦不行。是为行般若波罗蜜。善说道非道故。须菩提言。希有。碍者是非道。无碍者是道。佛观会众心多回向空。知般若波罗蜜无碍相。是故说不行色等无碍是行般若波罗蜜。能如是行者。于色等法无碍。须菩提虽不能究尽知毕竟空理。而常乐说是空法。希有与一切世间法相违。佛可须菩提所说。若说不说无增无减。是诸法实相。若以身业毁坏。亦不能令异。何况口说。常不生相故。譬如虚空。虚空是般若波罗蜜。幻人是行者。行者虽罪业因缘生是虚诳法。般若波罗蜜合故无有异。如种种诸色到须弥山边同为金色。是诸法实相不可知不可说故。若说不说如本不异。尔时须菩提作是念。若诸法毕竟空。无所有如虚空。乃至无有微细相。而菩萨能修集善法得无上道。是事难信难受。作是念已白佛言。诸菩萨所为甚难。能为难事故应礼拜。谓能大庄严故。须菩提希有心说。是菩萨摩诃萨。为阿耨多罗三藐三菩提大庄严。一切天人皆应礼拜。问曰。云何知是大庄严。答曰。须菩提此中自说譬喻。如有人为虚空故勤行精进利益。故大庄严。菩萨为利益众生勤精进亦如是。世尊若有人欲度虚空。菩萨摩诃萨欲度众生亦如是。问曰。一事何以再说。答曰。利益者未得涅槃。但令得智慧禅定等今世后世乐。欲度者令得漏尽成三乘道入无余涅槃。如虚空无生无灭无苦无乐无缚无脱无所有故。众生亦如是。是故说。世尊为度虚空等众生故大庄严。如虚空无色无形。若有欲举虚空是为难。众生法亦如是。毕竟空而菩萨欲举三界众生着涅槃中。是故名大庄严。须菩提复赞是菩萨大精进力。不随邪疑心故。虽未得佛道未灭诸结。而能大勇猛能如是行菩萨道为众生。众生亦空。譬如以种种彩色欲画虚空。此中佛说众生空因缘。所谓十方如恒河沙诸佛。以神通力为众生无量劫说法。一一佛度无量阿僧祇众生入涅槃。假令如是于众生无所减少。若实有众生实有减少者。诸佛应有减众生罪。若众生实空。和合因缘有假名众生故。无有定相。是故尔所佛度众生实无减少。若不度亦不增。是故诸佛无减众生咎。是故说菩萨欲度众生。为欲度虚空。尔时一比丘。闻毕竟空相惊喜言。我当礼般若波罗蜜。般若中无有法定实相。而有戒众等及诸果报

【经】尔时释提桓因语须菩提。若菩萨摩诃萨。习般若波罗蜜。为习何法。须菩提语释提桓因言。憍尸迦。是菩萨摩诃萨。习般若波罗蜜为习空。释提桓因白佛言。世尊。若善男子善女人。受持般若波罗蜜。亲近读诵说正忆念。我当作何等护。尔时须菩提语释提桓因言。憍尸迦。汝颇见是法可守护者不。释提桓因言。不也须菩提。我不见是法可守护者。须菩提言。憍尸迦。若善男子善女人。如般若波罗蜜中所说行。即是守护。所谓常不远离。如所说般若波罗蜜行。是善男子善女人。若人若非人不得其便。当知是善男子善女人。不远离般若波罗蜜。憍尸迦。若人欲护行般若波罗蜜菩萨。为欲护虚空。憍尸迦。于汝意云何。汝能护梦焰影响幻化不。释提桓因言。不能护。若人欲护行般若波罗蜜诸菩萨摩诃萨亦如是。徒自疲苦。憍尸迦。于汝意云何。能护佛所化不。释提桓因言。不能护。若人欲护行般若波罗蜜诸菩萨摩诃萨亦如是。憍尸迦。于汝意云何。能护法性实际如不可思议性不。释提桓因言。不能护。若人欲护行般若波罗蜜诸菩萨摩诃萨亦如是。尔时释提桓因问须菩提。云何菩萨摩诃萨行般若波罗蜜。知见诸法如梦如焰如影如响如幻如化。诸菩萨摩诃萨。如所知见故。不念梦。不念是梦。不念用梦。不念我梦。焰影响幻化亦如是。须菩提言。憍尸迦。若菩萨摩诃萨行般若波罗蜜。不念色。不念是色。不念用色。不念我色。是菩萨摩诃萨。亦能不念梦。不念是梦。不念用梦。不念我梦。乃至化亦不念化。不念是化。不念用化。不念我化。受想行识亦如是。乃至一切智。不念一切智。不念是一切智。不念用一切智。不念我一切智。是菩萨摩诃萨。亦能不念梦。不念是梦。不念用梦。不念我梦。乃至化亦如是。如是憍尸迦。菩萨摩诃萨知诸法如梦如焰如影如响如幻如化

【论】释曰。即时帝释问。从佛须菩提所闻。是甚深般若为习何法。须菩提言。诸法久久皆归涅槃故。当习诸法空。是故说。欲习般若当习空。帝释是人天王。于世间自在。能与所须。愿作守护。闻是般若波罗蜜。欢喜白佛言。我当作何事守护。随其所须尽当与之。须菩提及一比丘。出家法敬礼而已。诸恶鬼常恼是人。魔若魔民常恼行者。是故问佛。我当以何事守护。若自守护若遣子弟若遣官属侍卫随佛教敕。须菩提知般若有无量力。又知佛意。欲令般若波罗蜜贵重。不用受恩故语帝释。憍尸迦。般若波罗蜜中。皆空如幻如梦。汝颇见定有一法可守护不。帝释言不也。若可见者。不名为般若波罗蜜毕竟空。若不可见。云何说言我当作何事守护。复次憍尸迦。若行者如所说。般若中住。即是守护。若菩萨如般若中所说。一心信受思惟正忆念。入禅定观诸法实相。得毕竟空智慧。应无生法忍入菩萨位。如是人不惜身命。何况外物。是人不须守护。守护名遮诸苦恼令得安乐。是人离一切世间法故。无有忧愁苦恼。得世间事不以为喜。失世间事不以为忧。所谓常不离如所说般若波罗蜜行。若人少时应行后还失者。宜须守护。若常不离如所说般若波罗蜜。则不须守护。如伽罗夜叉。以拳打舍利弗头。舍利弗时入灭尽定不觉打痛。般若波罗蜜气分。即是灭尽定。是故若人若非人不能得便。略说二种因缘不须守护。若人若非人不得便。一者从身乃至一切诸法皆厌离。无我无我所故。皆无所著。如斩草木不生忧愁。二者得上妙法故。为十方诸佛菩萨诸天守护。复次譬如人欲守护虚空。虚空雨不能坏。风日不能干。刀杖等不能伤。若有人欲守护虚空者。徒自疲苦于空无益。若人欲守护行般若波罗蜜菩萨亦如是。欲令此事明了故问。汝能守护空及梦中所见人及影响幻化人不。答言不也。此法但诳心眼。暂现已灭。云何可守护。行般若菩萨亦如是。观五众如梦等虚诳。如无为法如法性实际不可思议性。无能守护者。亦无所利益。行般若菩萨。知身如如法性实际不分别得。供养利时不喜。破坏失时不忧。如是人何须守护。尔时帝释贪贵是如梦等智慧。菩萨得是智慧力。不须外守护故。问须菩提。云何菩萨知是如梦等空法。如所知见不念梦等者。梦等喻五众。五众人所著不着梦等。欲令离着事故。以不着事为喻。欲令观五众如梦。于梦亦复生着。是故帝释问。如梦亦不着是梦。凡夫人以梦喻五众。即复着梦作是言。定有梦法眠睡时生。是名念梦。是梦恶是梦好。如是分别是名念是梦。梦得好事则心高。得恶事则心愁。又用此梦譬喻。得是如梦实智慧。是名念用梦。闻是譬喻。我因此梦得知诸法如梦。是名念我梦。余喻亦如是。尔时须菩提答帝释。若行者不念色是色人色非人色树色山色是四大若四大所造色等。不念是色若常若无常等。不以色故心生憍慢。不念色是我所非我所入无我门直至诸法实相中。是人能不念梦。不念是梦等用是梦等譬喻。破着五众。破着故于梦中亦不错。若不能破色着。是人于色错于梦亦错。受想行识乃至一切种智亦如是。幻焰响影化等亦如是。诸菩萨知诸法如梦。于梦亦不念

【经】尔时佛神力故。三千大千世界中。诸四天王天。三十三天夜摩天兜率陀天化乐天他化自在天。梵身天梵辅天梵众天大梵天。少光天乃至净居天。是一切诸天。以天栴檀遥散佛上。来诣佛所头面礼佛足却住一面。尔时四天王天释提桓因。及三十三天梵天王。乃至诸净居天。佛神力故。见东方千佛说法。亦如是相如是名字。说是般若波罗蜜品。诸比丘皆字须菩提。问难般若波罗蜜品者。皆字释提桓因。南西北方四维上下亦如是。各千佛现。尔时佛告须菩提。弥勒菩萨摩诃萨得阿耨多罗三藐三菩提时。亦当于是处说般若波罗蜜。如贤劫中诸菩萨摩诃萨得阿耨多罗三藐三菩提时。亦当于是处说般若波罗蜜。须菩提白佛言。世尊。弥勒菩萨摩诃萨得阿耨多罗三藐三菩提时。用何相何因何义。说是般若波罗蜜义。佛告须菩提。弥勒菩萨摩诃萨得阿耨多罗三藐三菩提时。色非常非无常。当如是说法。色非苦非乐。色非我非无我。色非净非不净。当如是说法。色非缚非解。当如是说法。受想行识非常非无常。乃至非缚非解。当如是说法。色非过去。色非未来。色非现在。当如是说法。受想行识亦如是。色毕竟净当如是说法。受想行识毕竟净。当如是说法。乃至一切智毕竟净。当如是说法。须菩提白佛言。世尊。是般若波罗蜜清净。佛言。色清净故。般若波罗蜜清净。受想行识清净故。般若波罗蜜清净。世尊。云何色清净故。般若波罗蜜清净。云何受想行识清净故。般若波罗蜜清净。佛言。若色不生不灭不垢不净。是名色清净。受想行识不生不灭不垢不净。是名受想行识清净。复次须菩提虚空清净故。般若波罗蜜清净。世尊。云何虚空清净故。般若波罗蜜清净。佛言。虚空不生不灭故清净。般若波罗蜜亦如是。复次须菩提。色不污故。般若波罗蜜清净。受想行识不污故。般若波罗蜜清净。世尊。云何色不污故般若波罗蜜清净。受想行识不污故。般若波罗蜜清净。佛言。如虚空不可污故。虚空清净。世尊。云何如虚空不可污故。虚空清净。佛言。虚空不可取故虚空清净。虚空清净故。般若波罗蜜清净。复次须菩提。虚空可说故。般若波罗蜜清净。世尊。云何虚空可说故般若波罗蜜清净。佛言。因虚空中二声出。般若波罗蜜。亦如虚空可说故清净。须菩提。虚空不可说故。般若波罗蜜清净。世尊。云何虚空不可说故。般若波罗蜜清净。佛言。如虚空不可说故。般若波罗蜜清净。复次如虚空不可得故。般若波罗蜜清净。世尊。云何如虚空不可得故。般若波罗蜜清净。佛言。如虚空无所得相。般若波罗蜜亦如虚空无所得相故清净。复次须菩提。一切法不生不灭不垢不净故。般若波罗蜜清净。世尊。云何一切法不生不灭不垢不净故。般若波罗蜜清净。佛言。一切法。毕竟清净故。般若波罗蜜清净

【论】释曰。是般若波罗蜜。虽皆甚深。是品中了了说诸法实相故。是以三千大千世界中诸天。持诸供养具来。供养佛一面立。问曰。即是上诸天今更来。答曰。有人言。事久故去竟更来。有人言。更有新天来者。欲令信般若故。十方面各千佛现。是人福德因缘。应见千佛故。佛神力故。在会众人皆见十方佛。人天所见有限。非佛威神无由得见彼诸佛。佛前说法者。皆字须菩提。难问者。皆字释提桓因。取其同字者有千人。是时须菩提帝释皆欢喜言。非独我等能说能问。佛欲证其事故。广引其事说。弥勒及贤劫菩萨。于是摩伽陀国王舍城耆阇崛山。说般若波罗蜜。如经中说。弥勒菩萨将大众。到耆阇崛山。以足指开山顶。摩诃迦叶骨身着僧伽梨执杖持钵而出。弥勒为大众说言。有过去释迦牟尼佛。人寿百岁时。是人是少欲知足行头陀。弟子中第一。具六神通得三明。常怜愍利益众生故。以神通力令此骨身至今。因此小身得如是利。何况汝等大身。生于好世而不能自利。尔时弥勒因是事广说法。令无量众生得尽苦际。以此事故。知。弥勒在耆阇崛山中说法。是般若波罗蜜。过去未来现在佛所说。应当信受。须菩提问。弥勒菩萨以何相何因。以何法门说。佛言如我说色等。诸法非常非无常非缚非解等如先说。亦不说色过去未来现在。如涅槃出三世色等。诸法亦如是。如先说。一切法如涅槃相。弥勒所说亦如是。尔时须菩提。欢喜白佛言。世尊是般若波罗蜜第一清净。佛言。色等诸法清净故。因果相似故。色等法清净者。所谓色等法。不失业因缘故。及不得诸法生相定实故。不生不灭。诸法相常不污染故。不垢不净。此中说譬喻。欲令事明了故。如虚空尘水不着。性清净故。般若波罗蜜亦如是。不生不灭故常清净。如虚空不可染污。般若波罗蜜亦如是。虽有邪见戏论不能染污。刀杖恶事不能坏。无色无形故不可取。不可取故则不可染污。复次诸菩萨住辩才乐说无碍智中。为众生说十二部经八万四千法聚。皆是般若波罗蜜一事。而分别为说。是故说般若波罗蜜可说故清净如虚空。因虚空及山谷。有人声从口中空出。因是出声故名响。如响空口声亦如是。是二声皆虚诳不实。而人以声为实以响为虚。般若亦如是。一切法皆毕竟空。如幻如梦。凡夫法圣法皆是虚诳。小菩萨以凡夫法为虚诳。圣法为实。问曰。是二皆虚诳。何以故。小菩萨以凡夫法为虚。圣法为实。答曰。圣法因持戒禅定智慧修集功德所成故。以为实。以凡夫法自然有。如响自然出。非是故作。以为虚。众生无始世来。着此身故声从身出。以为实。小菩萨深乐善法故。以为实。复次如虚空中。无音声语言相故。无所说。是语言音声皆是作法。虚空是无作法。般若波罗蜜亦如是。第一深义毕竟空无有言说。一切语言道断故。复次如虚空无所得相。不得有不得无。若有无相如先破虚空相。若无因是虚空造无量事。般若波罗蜜亦如是。有无相不可得故清净。复次般若波罗蜜。因诸法正忆念故生。正忆念者。毕竟空清净故。一切法不生不灭不垢不净

大智度论卷第六十四大智度论释无作实相品第四十三之余(卷六十五)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】须菩提白佛言。世尊。若善男子善女人。受持是般若波罗蜜。亲近正忆念者。终不病眼耳鼻舌身。亦终不病身无刑残。亦不衰耄。终不横死。无数百千万诸天四天王天。乃至净居诸天皆悉随从听受。六斋日。月八日二十三日十四日二十九日十五日三十日诸天众会。善男子为法师者。在所说般若波罗蜜处。皆悉来集。是善男子善女人。在大众中说是般若波罗蜜。得无量无边阿僧祇不可思议不可称量福德

佛告须菩提。如是如是。是善男子善女人。若六斋日。月八日二十三日十四日二十九日十五日三十日。在诸天众前。说是般若波罗蜜。是善男子善女人。得无量无边阿僧祇不可思议不可称量福德。何以故。须菩提。般若波罗蜜是大珍宝。何等是大珍宝。是般若波罗蜜。能拔地狱畜生饿鬼及人中贫穷。能与刹利婆罗门大姓居士大家。能与四天王天处乃至非有想非无想处。能与须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道阿耨多罗三藐三菩提。何以故。是般若波罗蜜中。广说十善道四禅四无量心四无色定四念处乃至八圣道分檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。广说内空乃至无法有法空。广说佛十力乃至一切智。从是中学。出生刹利大姓婆罗门大姓居士大家。出生四天王天三十三天夜摩天兜率陀天化乐天他化自在天。梵身天梵辅天梵众天大梵天光天少光天无量光天光音天净天少净天无量净天遍净天阿那婆伽天得福天广果天无想天阿浮呵那天不热天快见天妙见天阿迦尼吒天。虚空无边处天识无边处天无所有处天非有想非无想处天。是法中学。得须陀洹果斯陀含果阿那含果阿罗汉果。得辟支佛道。得阿耨多罗三藐三菩提。以是故。须菩提。般若波罗蜜名为大珍宝。珍宝波罗蜜中。无有法可得。若生若灭若垢若净若取若舍。珍宝波罗蜜亦无有法。若善若不善若世间若出世间若有漏若无漏若有为若无为。以是故。须菩提。是名无所得珍宝波罗蜜。须菩提。是珍宝波罗蜜。无有法能染污。何以故。所用染法不可得故。须菩提。以是故名无染珍宝波罗蜜。须菩提。若菩萨摩诃萨行般若波罗蜜时。亦如是不知。亦如是不分别。亦如是不得。亦如是不戏论。是为能修行般若波罗蜜。亦能礼觐诸佛。从一佛国至一佛国。供养恭敬尊重赞叹诸佛。游诸佛刹成就众生净佛国土。须菩提。是般若波罗蜜。于诸法无有力无非力。亦无受亦无与。不生不灭不垢不净不增不减。是波罗蜜亦非过去非未来非现在。不舍欲界不住欲界。不舍色界不住色界。不舍无色界不住无色界。是般若波罗蜜不与檀波罗蜜亦不舍。不与尸波罗蜜亦不舍。不与羼提波罗蜜亦不舍。不与毗梨耶波罗蜜亦不舍。不与禅波罗蜜亦不舍。不与般若波罗蜜亦不舍。不与内空亦不舍。乃至不与无法有法空亦不舍。不与四念处亦不舍。乃至不与八圣道分亦不舍。不与佛十力亦不舍。乃至不与十八不共法亦不舍。不与须陀洹果亦不舍。乃至不与阿罗汉果亦不舍。不与辟支佛道亦不舍。乃至不与一切智亦不舍。是般若波罗蜜不与阿罗汉法。不舍凡人法。不与辟支佛法。不舍阿罗汉法。不与佛法。不舍辟支佛法。是般若波罗蜜。亦不与无为法。不舍有为法。何以故。若有诸佛若无诸佛。是诸法相常住不异。法相法住法位常住。不谬不失故

【论】问曰。若受持般若正忆念。犹有众患。云何言终不病眼等。答曰。是事上功德地狱品中已广说。所谓非必受报业故无众患。又常受持正忆念。如所说行般若故无众患。譬如良药能破众病。若不能将顺则不除患。非药之失。又如[病-丙+寧]人虽得利器不能御难。非器之过。行者如是。先世重罪。今世不如所说行故。不得般若力。非般若过。问曰。天上亦有般若波罗蜜。诸天何以于六斋日。随逐不净人身。求闻般若。答曰。天上有经卷。传闻如是亦非佛说。若令有者。忉利天上兜率天上当有。何以故。阿修罗共忉利天斗时。佛敕帝释汝当诵念般若。兜率天上常有补处菩萨。为诸天说故可有。色界诸天身及衣服轻微。乃至无两数。常乐宴寂受禅定味。是故不应有经卷。诸天着二种乐。欲乐定乐。不能勤苦书持般若波罗蜜。阎浮提人。能精进书持精学正忆念。如经说。阎浮提人以三因缘。胜诸天及郁单曰人。一者能断淫欲。二者强识念力。三者能精勤勇猛。是阎浮提人。能书写读诵受持。以是故。诸天来下礼拜般若经卷。或欲闻说。复有人言。天上若有经卷。远来供养福德增益。求般若波罗蜜。亦无厌足。有菩萨天。欲令般若尊重故来下。欲令众生益加信敬。诸天尚来。何况我等行者。若闻好香若见光明。有如是希有事故。深心信乐般若。又未离欲人。恶鬼魔民常逐。伺便令堕恶处。从四天王乃至净居天。是大力诸天来小鬼避去。菩萨能生清净大心。如先品中说。是故来随逐法师。六斋日诸天来观人心。十五日三十日上白诸天。复次是六斋日是恶日。令人衰凶。若有是日受八戒持斋布施听法。是时诸天欢喜。小鬼不得其便。利益行者。是日法师高座说法。如是等种种因缘故。诸天皆来。说法者赞叹无量无边无上法。所谓般若波罗蜜。亦得无量无边福德。若为人说。人钝根福德薄故。得福少。诸天利根福德多。福田胜故得福多。故佛说行者斋日。诸天及大众中。说般若得福无量。此中佛可须菩提所言。复自说无量福德因缘。所谓般若波罗蜜。是大珍宝波罗蜜。如如意宝珠能满一切人愿。是般若波罗蜜。能满一切众生愿。所谓离苦得乐。离苦者般若波罗蜜。能拔众生地狱畜生饿鬼及人中贫穷与乐者。能与刹利大姓乃至阿耨多罗三藐三菩提。是乐因缘善法。般若波罗蜜中广说。所谓十善道乃至一切智。如如意宝能出衣服饮食金银等随意所须。般若波罗蜜亦如是。能令得十善道乃至一切智刹利大姓乃至佛。以是事故。名为珍宝波罗蜜。复次珍宝波罗蜜者。如人得如意宝。则随意所须皆得。失则忧恼。是般若波罗蜜。不生不灭常不失。世世与众生乐。末后令得佛道。如人得如意宝。则心生自高。轻贱他人。是为衰因缘。若人得世间般若波罗蜜亦如是。分别着诸善法。舍诸恶法。生高心轻蔑余人。则开诸罪门。珍宝般若波罗蜜。出世间般若波罗蜜中。不分别善不善。是名大珍宝波罗蜜。能利众生毕竟无忧。是珍宝波罗蜜。善法尚不能污染。何况不善法。如此中说。如是亦不知者如上说。般若相亦不作是知。不作知者不取相。亦不生着不分别不得定相。是名无有过患无有法爱断诸戏论。如是人能实修行般若波罗蜜。以法礼佛。自得实法利益故。能利益众生。能自离恶能令众生离恶故。得净佛世界。用无所得方便力故。知诸法毕竟寂灭相。而能为众生故起诸善法。般若波罗蜜毕竟清净故。无力无非力。譬如虚空虽无有法而因虚空得有所作。无有一法定相可着故无有力。得诸法实相。于诸善法无碍。乃至降魔成佛非无有力。不受不与不生不灭等。乃至不舍有为法不与无为法亦如是。此中说因缘。有佛无佛诸法性常住。世间诸法性者。即是诸法实相。诸法实相者。即是般若波罗蜜。若以常无常等。求诸法实相。是皆为错。若人入法性中求。则无有错谬。法性常故不失

【经】尔时诸天子虚空中立。发大音声踊跃欢喜。以沤钵罗华波头摩华拘物头华分陀利华而散佛上。如是言。我等于阎浮提见第二法轮转。是中无量百千天子。得无生法忍。佛告须菩提。是法轮非第一转。非第二转。是般若波罗蜜不为转故出。不为还故出。无法有法空故。须菩提白佛言。世尊。云何无法有法空故。般若波罗蜜不为转不为还故出。佛言。般若波罗蜜般若波罗蜜相空。乃至檀波罗蜜檀波罗蜜相空。内空内空相空。乃至无法有法空。无法有法空相空。四念处四念处相空。乃至八圣道分。八圣道分相空。佛十力。佛十力相空。乃至十八不共法十八不共法相空。须陀洹果须陀洹果相空。斯陀含果斯陀含果相空。阿那含果阿那含果相空。阿罗汉果阿罗汉果相空。辟支佛道辟支佛道相空。一切种智一切种智相空。须菩提白佛言。世尊。诸菩萨摩诃萨般若波罗蜜。是摩诃波罗蜜。何以故。虽一切法自相空。而诸菩萨摩诃萨因般若波罗蜜。得阿耨多罗三藐三菩提。亦无法可得。转法轮亦无法可转。亦无法可还。是摩诃般若波罗蜜中。亦无有法可见。何以故。是法不可得。若转若还。一切法毕竟不生故。何以故。是空相不能转不能还。无相相不能转不能还。无作相不能转不能还。若能如是说般若波罗蜜。教照开示分别显现解释浅易。有能如是教者。是名清净说般若波罗蜜。亦无说者亦无受者亦无证者。若无说无受无证亦无灭者。是说法中。亦无毕定福田

【论】释曰。诸天闻般若。大欢喜踊跃。诸天身轻利根。分别着相知有轻重。闻般若波罗蜜毕竟清净平等实相。大利益众生。无有过者。是故踊跃欢喜。起身业口业。持供养具莲华等供养于佛。作是言。我等于阎浮提。见第二法轮转。问曰。初说法令人得道。是名转法轮。今何以言第二法轮转。若以佛说名为转法轮者。皆是法轮何限第二。答曰。初说法。名定实一法轮。因初转乃至法尽。通名为转。是诸天见是会中。多有人发无上道。得无生法忍。见是利益故。赞言第二转法轮。初转法轮。八万诸天得无生法忍。阿若憍陈如一人得初道。今无量诸天得无生法忍。是故说第二法轮转。今转法轮似如初转。问曰。今转法轮多人得道。初转法轮得道者少。云何以大喻小。答曰。诸佛事有二种。一者密。二者现。初转法轮。声闻人见八万一人得初道。诸菩萨见无数阿僧祇人得声闻道。无数人种辟支佛道因缘。无数阿僧祇人。发无上道心。无数阿僧祇人。行六波罗蜜道。得诸深三昧陀罗尼门。十方无量众生。得无生法忍。无量阿僧祇众生。从初地中乃至十地住。无量阿僧祇众生。得一生补处。无量阿僧祇众生。得坐道场闻是法疾成佛道。如是等不可思议相。是名密转法轮相。譬如大雨大树则多受小树则少受。以是故。当知初转法轮亦大。以后喻前无咎。转法轮非一非二者。为毕竟空及转法轮果报涅槃故。如是说。是则因中说果。法轮即是般若波罗蜜。是般若波罗蜜。无起无作相故。无转无还。如十二因缘中说。无明毕竟空故。不能实生诸行等。无明虚妄颠倒。无有实定故。无法可灭说世间生法故。名为转。说世间灭法故。名为还。般若波罗蜜中。无此二事故。说无转无还。无法有法空故。无转是有法空。无还是无法空。问曰。须菩提何以作是问。有法无法空故。般若波罗蜜。不为转不为还故出。而佛还以空答。答曰。有人说。诸法有四种相。一者说有。二者说无。三者说亦有亦无。四者说非有非无。是中邪忆念故。四种邪行。着此四法故。名为邪道。是中正忆念故。四种正行中不着故。名为正道。是中破非有非无故。名无法有法空。佛说乃至破非有非无故。说无有转无有还。破非有非无有二种。一者用上三句破。二者用涅槃实相破。须菩提虽知佛以涅槃破有无。是中有新发意菩萨。或错谬故。用三句。破非有非无。于无法有法空中。还生邪见。是故佛说有法无法亦自相空。是故说般若波罗蜜无转无还。般若波罗蜜中。无般若波罗蜜相。一切法无相故。乃至檀波罗蜜亦如是。内空乃至一切种智相空亦如是。尔时须菩提及大众。欢喜赞叹般若波罗蜜作是言。大波罗蜜所谓般若波罗蜜。大波罗蜜者。所谓一切法虽自性空。而般若波罗蜜。能利益菩萨。令得阿耨多罗三藐三菩提。虽得亦无所得。虽转法轮亦无所转。问曰。若诸法空。般若波罗蜜空。阿耨多罗三藐三菩提亦空。不应赞般若为摩诃波罗蜜。答曰。此中说一切法自性空故。自性空中。亦无自性空。是故名摩诃波罗蜜。若无空相不应作难。以毕竟空故无所碍。而能行诸善法。得阿耨多罗三藐三菩提。世俗法故非第一义。诸佛虽说法令他得道。破烦恼从此至彼名为转。今我等诸烦恼。虚诳颠倒妄语无有定相。若无定相为何所断。若无所断亦无转无还。是故说虽转法轮亦无转还。何以故。是般若波罗蜜中。无有法。五眼所能见。若转若还一切法。从本已来毕竟不生故。是自性空毕竟空。非转相非还相。畏堕常故不转。畏堕灭故不还。畏堕有故不转。畏堕无故不还。畏着世间故不转。畏着涅槃故不还。如是自性空毕竟空十八空等无量诸空。是空解脱门。不转不还无相无作。亦如是入是三解脱门。舍我我所心。是名说得解脱。能如是不取相不着心。说般若波罗蜜。教照等说者。若案文若口传。教者为人赞般若。令受持读诵正忆念。照者如人执灯照物。若人不知般若。以智慧明照之令知。开者如宝藏闭门虽有好物而不能得。若开其门则随意所取。如人疑不信般若者。开邪疑扉折无明关。是人则随意所取。示者如人眼视不明指示好丑。如人有小信小智者。示是道非道是利是失等。分别者分别诸法是善是不善是罪是福是世间是涅槃经书。略说难解难信。能广为分别解说。令得信解。显现者佛为种种众生说种种法。或时毁呰善法。助不善法。趣令众生得解。说法者说佛意。趣以应众生令知轻重相。解释者。如囊中宝物系口则人不知。若为人解经卷囊。解释义理。又如重物披析令轻。种种因缘譬喻。解释本末令易解。浅易者。如深水难渡有人分散此水令浅则渡者皆易。般若波罗蜜。如水甚深。论议方便力故。种种说能令浅易。乃至小智之人皆能信解。能以十种为首说甚深义。是名清净说般若波罗蜜义。第一义中实无所说。毕竟空故无说。无说故无受。无受故无证。无证故无灭诸烦恼者。若无灭烦恼则无福田。受者名信受读诵行是法。得沙门果无生法忍。是名为证。证时诸烦恼灭。得有余涅槃。得有余涅槃故。是毕定福田。毕定者。诸法同无余涅槃性故。说无毕定福田

    大智度论释诸波罗蜜品第四十四

【经】尔时慧命须菩提白佛言。世尊。无边波罗蜜。是般若波罗蜜。佛言。如虚空无边故(一)世尊。等波罗蜜是般若波罗蜜。佛言。诸法等故(二)世尊。离波罗蜜是般若波罗蜜。佛言。毕竟空故(三)世尊。不坏波罗蜜是般若波罗蜜。佛言。一切法不可得故(四)世尊。无彼岸波罗蜜是般若波罗蜜。佛言。无名无身故(五)世尊。空种波罗蜜是般若波罗蜜。佛言。入出息不可得故(六)世尊。不可说波罗蜜是般若波罗蜜。佛言。觉观不可得故(七)世尊。无名波罗蜜是般若波罗蜜。佛言。受想行识不可得故(八)世尊。不去波罗蜜是般若波罗蜜。佛言。一切法不来故(九)世尊。无移波罗蜜是般若波罗蜜。佛言。一切法不可伏故(十)世尊。尽波罗蜜是般若波罗蜜。佛言。一切法毕竟尽故(十一)世尊。不生波罗蜜是般若波罗蜜。佛言。一切法不灭故(十二)世尊。不灭波罗蜜是般若波罗蜜。佛言。一切法不生故(十三)世尊。无作波罗蜜是般若波罗蜜。佛言。作者不可得故(十四)世尊。无知波罗蜜是般若波罗蜜。佛言。知者不可得故(十五)世尊。不到波罗蜜是般若波罗蜜。佛言。生死不可得故(十六)世尊。不失波罗蜜是般若波罗蜜。佛言。一切法不失故(十七)

【论】释曰。无边波罗蜜者。须菩提闻佛说大珍宝波罗蜜义因而自赞般若。为摩诃波罗蜜。又以智慧深入种种法门。观般若波罗蜜。如大海水无量无边。深知般若波罗蜜功德。因发大欢喜。欲以种种因缘赞叹般若。是故白佛言。世尊无边波罗蜜。是般若波罗蜜。无边义从品初至竟。皆是无边义。妨说余事故略说。若广说则无量。复次常是一边。无常是一边。我无我有无。世间有边无边。众生有边无边。如是等法名为邪见边。得般若波罗蜜。则无是诸边故言无边。复次譬如物尽处名为边。虚空无色无形故无边。般若波罗蜜。毕竟清净故。无有边无有尽无取处无受处。是故佛答如虚空无边故。般若波罗蜜亦无边。菩萨得法忍。观一切法皆平等。是故说一切法等故。言等波罗蜜。菩萨用毕竟空心离诸烦恼。亦离诸法。是故名离波罗蜜。菩萨用是般若波罗蜜总相别相。求诸法不得定相。如毛发许。以不可得故。于一切法心不着。若有邪见戏论人。用邪见着心。欲破坏是菩萨。是菩萨无所著故。不可破坏。是名不坏波罗蜜。此岸名为生死。彼岸名涅槃。中有诸烦恼大河。一切出家人欲舍此岸贪着彼岸而般若波罗蜜无彼岸。彼岸是涅槃无色无名。是故说无色无名。故是名无彼岸波罗蜜。有虚空则有出入息。出入息皆从虚诳业因缘生。出者非入入者非出。念念生灭不可得实相。息不可得故。一切法亦不可得。不可得故名空种波罗蜜。一切法空寂相故。不须觉观。觉观无故则无言说。无言说故说般若波罗蜜断语言道。是故名不可说波罗蜜。二法摄一切法。所谓名色。四大及造色色所摄。受等四众名所摄。分别诸法者。说般若波罗蜜。是智慧相故名所摄。今实不离色。是名不离。名是色是般若波罗蜜。无知相故。说受想行识不可得故。言无名波罗蜜。一切法无来无去故。名无去波罗蜜。般若波罗蜜。是三世十方佛法藏。以三法印印无天无人。能破故。名无移波罗蜜。诸有为法念念尽灭无有住时。若尔者过去法不尽。未来法亦不尽。现在法不住故不尽。三世尽不可得故。名为毕竟尽。毕竟尽故名尽波罗蜜。一切法三世中生不可得故无生。无生故名无生波罗蜜。不灭波罗蜜亦如是。作有二种。一者众生作。二者法作。众生作者。布施持戒等。法作者。火烧水烂心识所知。众生空故无作者。一切法钝不起作相故。法亦不作。是二无作故。名无作波罗蜜。无知波罗蜜亦如是。一切法钝故无所知。天眼见有生死。用空慧眼见生死不可得。生死不可得故。今世众生死。无到后世者。但五众先业因缘相续生故。名不到波罗蜜。般若波罗蜜不失诸法实相。亦能令一切法不失实相。离般若波罗蜜。一切法皆失。观一切法实相。得般若波罗蜜。是故名不失波罗蜜

【经】世尊。梦波罗蜜是般若波罗蜜。佛言。乃至梦中所见不可得故(十八)世尊。响波罗蜜是般若波罗蜜。佛言。闻声者不可得故(十九)世尊。影波罗蜜是般若波罗蜜。佛言。镜面不可得故(二十)世尊。焰波罗蜜是般若波罗蜜。佛言。水流不可得故(二十一)世尊。幻波罗蜜是般若波罗蜜。佛言。术事不可得故(二十二)世尊。不垢波罗蜜是般若波罗蜜。佛言。诸烦恼不可得故(二十三)世尊。无净波罗蜜是般若波罗蜜。佛言。烦恼虚诳故(二十四)世尊。不污波罗蜜是般若波罗蜜。佛言。处不可得故(二十五)世尊。不戏论波罗蜜。是般若波罗蜜。佛言。一切戏论破故(二十六)世尊。不念波罗蜜是般若波罗蜜。佛言。一切念破故(二十七)世尊。不动波罗蜜是般若波罗蜜。佛言。法性常住故(二十八)世尊。无染波罗蜜是般若波罗蜜。佛言。知一切法妄解故(二十九)世尊。不起波罗蜜是般若波罗蜜。佛言。一切法无分别故(三十)世尊。寂灭波罗蜜是般若波罗蜜。佛言。一切法相不可得故(三十一)世尊。无欲波罗蜜是般若波罗蜜。佛言。欲不可得故(三十二)世尊。无嗔波罗蜜是般若波罗蜜。佛言。嗔恚不实故(三十三)世尊。无痴波罗蜜是般若波罗蜜。佛言。无明黑闇灭故(三十四)世尊。无烦恼波罗蜜是般若波罗蜜。佛言。分别忆想虚妄故(三十五)世尊。无众生波罗蜜是般若波罗蜜。佛言。众生无所有故(三十六)世尊。断波罗蜜是般若波罗蜜。佛言。诸法不起故(三十七)世尊。无二边波罗蜜是般若波罗蜜。佛言。离二边故(三十八)世尊。不破波罗蜜是般若波罗蜜。佛言。一切法不相离故(三十九)世尊。不取波罗蜜是般若波罗蜜。佛言。过声闻辟支佛地故(四十)世尊。不分别波罗蜜是般若波罗蜜。佛言。诸妄想不可得故(四十一)世尊。无量波罗蜜是般若波罗蜜。佛言。诸法量不可得故(四十二)世尊。虚空波罗蜜是般若波罗蜜。佛言。一切法无所有故(四十三)

【论】释曰。须菩提赞般若波罗蜜。示众生世间空如梦。佛言。梦亦不可得故名梦波罗蜜。响影焰幻亦如是。人心以声为实。以响为虚。影以人面镜为实。像为虚。焰以风尘日光为实。水为虚。幻以祝术为实。祝术所作为虚。须菩提赞般若以喻为空。佛说喻本事皆空。本事皆空故。是喻亦空。是般若波罗蜜。无垢能断灭一切垢。佛言。诸烦恼从本已来常无。今何所断。是故名无垢波罗蜜。无净波罗蜜亦如是。无烦恼即是净淫欲嗔恚等。诸烦恼名为污。是般若波罗蜜。一切垢法所不污。六情是诸烦恼处。六情及一切法。诸烦恼缘处住处。皆不可得故。名不污波罗蜜。得是般若波罗蜜。一切戏论忆想分别灭故。名不戏论波罗蜜。一切法毕竟空故。无忆无念相。无忆无念相故。名无念波罗蜜。住法性菩萨。一切论议者。所不能胜。一切结使邪见所不能覆。一切法无常。破坏心不生忧。如是等因缘故。名不动波罗蜜。一切法妄解。非但爱染故。名无染波罗蜜。忆想分别是一切结使根本。有结使能起后身业。知忆想分别虚妄。一切后世生业。更不复起故。是名不起波罗蜜。般若波罗蜜中。不取三毒火相故。言寂灭波罗蜜。佛言。非但三毒相寂灭。一切法相不可得故。是般若波罗蜜。乃至善法中尚不贪。何况余欲。佛说欲从本已来。不可得故。贪欲虚诳。自性不可得故。名无欲波罗蜜。非是离欲故名无欲。嗔恚性毕竟无所有故。名无嗔波罗蜜。非是离嗔故。名无嗔。一切法中。无明黑闇破故。名无痴波罗蜜。非是灭痴故。名无痴。无烦恼波罗蜜者。菩萨得无生法忍故。一切烦恼灭。佛言。忆想分别是烦恼根本。忆想尚无何况烦恼。故名无烦恼波罗蜜。般若能破无众生中有众生颠倒故。名无众生波罗蜜。佛言。是众生从本已来不生。无所有故。名无众生。须菩提意。以般若波罗蜜能断一切有漏法故。名断波罗蜜。佛言。诸法不起不生无所作。诸法自然断相故名断。二边者。所谓我无我断无断可断法无断法常灭有无。如是等无量二边。般若波罗蜜中。无是诸边故。名无二边波罗蜜。佛言。是诸边从本已来无。但以虚诳颠倒故着。菩萨求实事故。离是颠倒边。是般若波罗蜜。一相空故不可破。佛言。不但般若波罗蜜。一切法皆无定异相。如果不离因因不离果。有为法不离无为法。无为法不离有为法。般若波罗蜜不离一切法。一切法不离般若波罗蜜。一切法实相。即是般若波罗蜜故。名不破波罗蜜。破者所谓诸法各各离散一切法常无常等过失。是故般若波罗蜜。不取一切法。佛言。一切法。乃至二乘出世间清净法。亦不取故。名不取波罗蜜。分别名取相。生心妄想分别。般若波罗蜜是实相故。无是妄想分别。佛言。因忆想分别。有无分别。今忆想分别。从本已来无故。名无分别波罗蜜。般若波罗蜜。出四无量故。名无量波罗蜜。复次毕竟空。为得涅槃无量法故。名无量。复次智慧所不能到边崖。是名无量。是名六情所筹度。是法空无相无生灭。六情所不能量。何以故。物多而量器小故。佛言。非但是般若波罗蜜无量。色等一切法不可得故。皆无量。如虚空无色无形无所能作。般若波罗蜜亦如是。佛言。非但虚空无所有。色等诸法皆无所有故。名虚空波罗蜜

【经】世尊。无常波罗蜜是般若波罗蜜。佛言。一切法破坏故(四十四)世尊。苦波罗蜜是般若波罗蜜。佛言。一切法恼相故(四十五)世尊。无我波罗蜜是般若波罗蜜。佛言。一切法不着故(四十六)世尊。空波罗蜜是般若波罗蜜。佛言。一切法不可得故(四十七)世尊。无相波罗蜜是般若波罗蜜。佛言。一切法不生故(四十八)世尊。内空波罗蜜是般若波罗蜜。佛言。内法不可得故(四十九)世尊。外空波罗蜜是般若波罗蜜。佛言。外法不可得故(五十)世尊。内外空波罗蜜是般若波罗蜜。佛言。内外法不可得故(五十一)世尊。空空波罗蜜是般若波罗蜜。佛言。空空法不可得故(五十二)世尊。大空波罗蜜是般若波罗蜜。佛言。一切法不可得故(五十三)世尊。第一义空波罗蜜是般若波罗蜜。佛言。涅槃不可得故(五十四)世尊。有为空波罗蜜是般若波罗蜜。佛言。有为法不可得故(五十五)世尊。无为空波罗蜜是般若波罗蜜。佛言。无为法不可得故(五十六)世尊。毕竟空波罗蜜是般若波罗蜜。佛言。诸法毕竟不可得故(五十七)世尊。无始空波罗蜜是般若波罗蜜。佛言。诸法无始不可得故(五十八)世尊。散空波罗蜜是般若波罗蜜。佛言。散法不可得故(五十九)世尊。性空波罗蜜是般若波罗蜜。佛言。有为无为法不可得故(六十)世尊。诸法空波罗蜜是般若波罗蜜。佛言。一切法不可得故(六十一)世尊。自相空波罗蜜是般若波罗蜜。佛言。自相离故(六十二)世尊。无法空波罗蜜是般若波罗蜜。佛言。无法不可得故(六十三)世尊。有法空波罗蜜是般若波罗蜜。佛言。有法不可得故(六十四)世尊。无法有法空波罗蜜是般若波罗蜜。佛言。无法有法不可得故(六十五)世尊。念处波罗蜜是般若波罗蜜。佛言。身受心法不可得故(六十六)世尊。正勤波罗蜜是般若波罗蜜。佛言。善不善法不可得故(六十七)世尊。如意足波罗蜜是般若波罗蜜。佛言。四如意足不可得故(六十八)世尊。根波罗蜜是般若波罗蜜。佛言。五根不可得故(六十九)世尊。力波罗蜜是般若波罗蜜。佛言。五力不可得故(七十)世尊。觉波罗蜜是般若波罗蜜。佛言。七觉分不可得故(七十一)世尊。道波罗蜜是般若波罗蜜。佛言。八圣道分不可得故(七十二)世尊。无作波罗蜜是般若波罗蜜。佛言。无作不可得故(七十三)世尊。空波罗蜜是般若波罗蜜。佛言。空相不可得故(七十四)世尊。无相波罗蜜是般若波罗蜜。佛言。寂灭相不可得故(七十五)世尊。背舍波罗蜜是般若波罗蜜。佛言。八背舍不可得故(七十六)世尊。定波罗蜜是般若波罗蜜。佛言。九次第定不可得故(七十七)世尊。檀波罗蜜是般若波罗蜜。佛言。悭贪不可得故(七十八)世尊。尸罗波罗蜜是般若波罗蜜。佛言。破戒不可得故(七十九)世尊。羼提波罗蜜是般若波罗蜜。佛言。忍不忍辱不可得故(八十)世尊。毗梨耶波罗蜜是般若波罗蜜。佛言。懈怠精进不可得故(八十一)世尊。禅波罗蜜是般若波罗蜜。佛言。定乱不可得故(八十二)世尊。般若波罗蜜是般若波罗蜜。佛言。痴慧不可得故(八十三)世尊。十力波罗蜜是般若波罗蜜。佛言。一切法不可伏故(八十四)世尊。无所畏波罗蜜是般若波罗蜜。佛言。道种智不没故(八十五)世尊。无碍智波罗蜜是般若波罗蜜。佛言。一切诸法无障无碍故(八十六)世尊。佛法波罗蜜是般若波罗蜜。佛言。过一切法故(八十七)世尊。如实说者波罗蜜是般若波罗蜜。佛言。一切说如实故(八十八)世尊。自然波罗蜜是般若波罗蜜。佛言。一切法中自在故(八十九)世尊。佛波罗蜜是般若波罗蜜。佛言。知一切法一切种智故(九十)

【论】释曰。般若波罗蜜中。有无常圣行故。名无常波罗蜜。佛言。非但般若中有无常观。一切法无常故名无常波罗蜜。问曰。上来说般若波罗蜜法性常住。今何以说无常。答曰。般若波罗蜜。是智慧观法。从因缘和合生。是有为法故无常。般若波罗蜜所缘处。如法性实际无为法故常。须菩提说。有为般若故。言般若波罗蜜无常。问曰。若尔者佛何以说一切法尽是破坏无常无为法无破坏相。答曰。一切法名六情。内外皆是作法。作法故。必归破坏相。离有为法无无为法。亦更无有法相。因有为法相故。说无为法不生不灭。复次一切有为法有二种。一者名字一切。二者实一切。一切有为法破坏故。名一切无常苦等。乃至无法有法空亦如是。须菩提说一切法相赞般若。佛举一切法答。正观身等四法。从四念处生。四念处是四谛之初门。四谛是四沙门果初门。阿罗汉果分别。即是三乘四念处。般若波罗蜜中种种广说。佛言。是四种法缘处。从本已来皆不可得故。名念处波罗蜜。从四正勤乃至般若波罗蜜亦如是。问曰。余法可以赞般若。云何复以般若赞般若。答曰。有二种般若。一者常住般若。二者与五波罗蜜共行。有用般若波罗蜜须菩提赞有用般若波罗蜜。能破无明黑闇能与真智慧。是故佛说常住般若波罗蜜。痴慧不可得故。行是般若波罗蜜。菩萨初得菩萨十力。后得佛十力。是故说十力波罗蜜。佛言。非但十力者不可破不可伏。一切法实相。亦不可破亦不可伏。佛意为度众生故。说十方佛力无量无边。如佛力一切法实相亦如是。不可伏故。名十力波罗蜜。菩萨得是般若波罗蜜力。于佛前能说法论议。何况余处。尚不畏魔王何况外道。故名无所畏波罗蜜。佛言。道种智不没故。道种智名法眼。知一切众生以何道得涅槃。般若波罗蜜。常寂灭相不可说。是菩萨以道种智故。引导众生。于大众中师子吼。道种智增益故不没。无所畏不自憍慢我有是法。名无畏波罗蜜。须菩提从佛闻无畏转深故。赞般若波罗蜜。言无碍波罗蜜。佛言非但四无碍。一切法入如法性实际故。皆是无碍相。菩萨因般若波罗蜜。能集十力四无所畏四无碍智大慈大悲等诸佛法故。说佛法波罗蜜。佛言。声闻法于于凡夫法为胜。辟支佛法于声闻法为胜。法于一切法最胜。如一切色中虚空广大。佛法最胜无能及。无可喻。过一切法故。名佛法波罗蜜。如过去佛。行六波罗蜜。得诸法如相。今佛亦如是。行六波罗蜜。得佛道故。名多陀阿伽陀波罗蜜。多陀阿伽陀者。或言如来。或言如实说。或言如实知。此中佛说。非但佛说名如实说。一切语言皆是如实故。名如实说波罗蜜。是般若波罗蜜具足。后身自然作佛故。名自然波罗蜜。自然名佛。佛所说故。名自然波罗蜜。复次是般若波罗蜜。实相自然不由他作故。名自然。佛言。佛一切法中。得自在力故。名自然波罗蜜。具足十地。得十力四无所畏。转法轮击法鼓。觉世间无明睡众生故。名为佛波罗蜜。佛秦言觉者知者。何者是。所谓正知一切法一切种故名觉。一切法者。所谓五众十二入十八界等。复次一切法。名外道经书伎术禅定等。略说有五种。所谓凡夫法。声闻法。辟支佛法。菩萨法。佛法。佛略知有二种相。所谓总相别相。又以分别相毕竟空相。广知则一切种。一切种是一切无量无边法门。以是事故。名为佛波罗蜜。不以佛身故名为佛波罗蜜。但以一切种智故

大智度论卷第六十五大智度论释叹信行品第四十五(卷六十六)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】尔时释提桓因作是念。若善男子善女人得闻般若波罗蜜经耳者。是人于前世佛作功德与善知识相随。何况受持亲近读诵正忆念如说行。当知是善男子善女人多亲近诸佛。能得听受如说行能问能答。当知是善男子善女人于前世多供养亲近诸佛故。闻是深般若波罗蜜不惊不怖不畏。当知是人亦于无量亿劫。行檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。尔时舍利弗白佛言。世尊。若有善男子善女人闻是深般若波罗蜜不惊不怖不畏。闻已受持亲近如说习行。当知是善男子善女人如阿鞞跋致菩萨摩诃萨。何以故。世尊。是般若波罗蜜甚深。若先世不久行檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。终不能信解深般若波罗蜜。世尊。若有善男子善女人呰毁深般若波罗蜜者。当知是人前世亦呰毁深般若波罗蜜。何以故。是善男子善女人闻说深般若波罗蜜时。无信无乐心不清净。当知是善男子善女人。先世不问不难诸佛及弟子。云何应行檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。云何应修内空乃至云何应修无法有法空。云何应修四念处。乃至云何应修八圣道分。云何应修佛十力。乃至云何应修十八不共法。释提桓因语舍利弗。是深般若波罗蜜。若有善男子善女人。不久行檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。不行内空乃至无法有法空。不行四禅四无量心四无色定。不行四念处乃至八圣道分。不行佛十力乃至十八不共法。如是人不信解是深般若波罗蜜。有何可怪。大德舍利弗。我礼般若波罗蜜。礼般若波罗蜜是礼一切智。佛告释提桓因。如是如是。憍尸迦。礼般若波罗蜜是礼一切智。何以故。憍尸迦。诸佛一切智皆从般若波罗蜜生。一切智即是般若波罗蜜。以是故憍尸迦。善男子善女人欲住一切智。当住般若波罗蜜。若善男子善女人欲生道种智。当习行般若波罗蜜。欲断一切诸结及习。当习行般若波罗蜜。善男子善女人欲转法轮。当习行般若波罗蜜。善男子善女人欲得须陀洹果斯陀含果阿那含果阿罗汉果。当习行般若波罗蜜。欲得辟支佛道。当习行般若波罗蜜。欲教众生令得须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道。当习行般若波罗蜜。若善男子善女人欲教众生令得阿耨多罗三藐三菩提。若欲总摄比丘僧。当习行般若波罗蜜

【论】释曰。释提桓因是诸天主。利根智胜信佛法故倍复增益。如火得风愈更炽尽。闻须菩提以种种因缘赞般若波罗蜜佛以深理成其所赞。帝释发希有心作是念。若善男子善女人得闻般若经耳者。是人于前世多供养诸佛作大功德。今世得遇好师同学等善知识。因先世供养佛。缘今世善知识故。闻般若波罗蜜能信。何况读诵思惟正忆念修习禅定筹量分别义趣能成办事者。当知是人从过去诸佛及弟子闻深般若波罗蜜义。信受不怖不畏。何以故。是人于无量阿僧祇劫行六波罗蜜等诸功德。是故虽未得阿鞞跋致地。于深法中不疑不悔。譬如新劈干毳随风东西湿毳绁致则不可动。新发意菩萨亦如是。不久修德作福。浅薄随他人语。不能信受般若波罗蜜。若久修福德不随他语。则能信受深般若波罗蜜不惊不怖。帝释思惟念般若波罗蜜有无量功德。时舍利弗知帝释所念而白佛言。世尊。善男子善女人。虽未入菩萨位。能信受深般若波罗蜜。不惊不怖如说修行。是人大福德智慧信力故。当知如阿鞞跋致无异。此中佛自说因缘。般若波罗蜜甚深无相可取可信可受。若能信受是为希有。如人空中种殖是为甚难。一切凡夫得胜法则舍本事。如得禅定乐舍五欲乐。乃至依有顶处舍无所有处功德。不能无所依止而有所舍。如尺蠖寻条安前足进后足尽树端更无所依止还归本处。是菩萨未得道。于般若波罗蜜无所依止。而能修福德舍五欲。是事希有。是中说因缘。是人先世信受久行六波罗蜜。大集诸福德。与信相违则毁呰般若波罗蜜。如厚福德者从久积集。不信毁呰者亦从久习。问曰。若先世毁呰诽谤应堕地狱。何缘复得闻般若。答曰。有人言。是人堕地狱罪毕还来毁呰。不说次后身。有人言。作业积集厚重则能与果报。是人前世虽不信。而积业未厚。则未得果报。以余福德故生人中续复不信。复次有人言。五逆罪次后身必受余罪。不尔或次后身或久后身。尔时帝释语舍利弗。是般若波罗蜜毕竟空无所有故甚深。菩萨不久行功德。则着心坚固信力微弱不信般若波罗蜜。乃至一切智何足怪。帝释思惟筹量。信般若波罗蜜福德无量。不信者得罪深重。深爱敬般若波罗蜜故发是言。我当礼是般若。何以故礼般若波罗蜜则为礼一切智。礼一切智者则礼三世十方诸佛。尔时佛可其言。复说赞般若波罗蜜因缘。所谓诸佛一切智慧。皆从般若中生。是故言若有菩萨欲住一切智中乃至总摄比丘僧。当习行般若波罗蜜

【经】释提桓因白佛言。世尊。菩萨摩诃萨欲行般若波罗蜜时。云何名住般若波罗蜜禅波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀波罗蜜。云何住内空乃至无法有法空。云何住四禅四无量心四无色定五神通。云何住四念处乃至八圣道分。云何住佛十力乃至十八不共法。世尊。菩萨摩诃萨云何习行般若波罗蜜乃至檀波罗蜜内空乃至十八不共法。佛语释提桓因。善哉善哉。憍尸迦。汝能乐问是事。皆是佛神力。憍尸迦。若菩萨摩诃萨行般若波罗蜜时。若不住色中为习行般若波罗蜜。若不住受想行识中为习行般若波罗蜜。眼耳鼻舌身意色声香味触法。眼界乃至意识界亦如是。憍尸迦。若菩萨摩诃萨不住般若波罗蜜中。为习般若波罗蜜。不住禅波罗蜜中为习禅波罗蜜。不住毗梨耶波罗蜜中为习毗梨耶波罗蜜。不住羼提波罗蜜中为习羼提波罗蜜。不住尸罗波罗蜜中为习尸罗波罗蜜。不住檀波罗蜜中为习檀波罗蜜。如是憍尸迦。是名菩萨摩诃萨不住般若波罗蜜为习般若波罗蜜。憍尸迦。不住内空中为习内空。乃至不住无法有法空为习无法有法空。不住四禅为习四禅。不住四无量心为习四无量心。不住四无色定为习四无色定。不住五神通为习五神通。不住四念处为习四念处。乃至不住八圣道分为习行八圣道分。不住佛十力为习行佛十力。乃至不住十八不共法。为习行十八不共法。何以故。憍尸迦。是菩萨不得色可住可习处。乃至十八不共法不得十八不共法可住可习处。复次憍尸迦。菩萨摩诃萨不习色。若不习色是名习色受想行识。乃至十八不共法亦如是。何以故。是菩萨摩诃萨色前际不可得。中际不可得。后际不可得。乃至十八不共法亦如是。舍利弗白佛言。世尊。是般若波罗蜜甚深。佛言。色如甚深故。般若波罗蜜甚深。受想行识如甚深故。般若波罗蜜甚深。乃至十八不共法亦如是。舍利弗言。世尊。是般若波罗蜜难可测量。佛言。色难可测量故。般若波罗蜜难可测量。受想行识乃至十八不共法难可测量故。般若波罗蜜难可测量。世尊。是般若波罗蜜无量。佛言。色无量故。般若波罗蜜无量。受想行识乃至十八不共法无量故。般若波罗蜜无量。佛告舍利弗。若菩萨摩诃萨行般若波罗蜜时。不行色甚深为行般若波罗蜜。不行受想行识。乃至不行十八不共法甚深。为行般若波罗蜜。何以故。色甚深相为非色。受想行识乃至十八不共法甚深相。为非十八不共法。如是不行为行般若波罗蜜。舍利弗。若菩萨摩诃萨行般若波罗蜜时。不行色难测量。为行般若波罗蜜。不行受想行识乃至不行十八不共法难测量。为行般若波罗蜜。何以故。色难测量相为非色。受想行识乃至十八不共法难测量相。为非十八不共法。舍利弗。若菩萨摩诃萨行般若波罗蜜时。不行色无量。为行般若波罗蜜。不行受相行识乃至不行十八不共法无量。为行般若波罗蜜。何以故。色是无量相为非色。受想行识乃至十八不共法无量相。为非十八不共法。舍利弗白佛言。世尊。是般若波罗蜜甚深。甚深相难见难解不可思量。不应在新发意菩萨前说。何以故。新发意菩萨闻是甚深般若波罗蜜。或当惊怖心生疑悔。不信不行是甚深般若波罗蜜。当在阿鞞跋致菩萨摩诃萨前说。是菩萨闻是甚深般若波罗蜜不惊不怖心不疑悔。则能信行。释提桓因问舍利弗。若在新发意菩萨摩诃萨前。说是深般若波罗蜜有何等过。舍利弗报释提桓因。憍尸迦。若在新发意菩萨前。说是深般若波罗蜜。或当惊怖呰毁不信。是新发意菩萨或有是处。若新发意菩萨闻是深般若波罗蜜毁呰不信。种三恶道业。是业因缘故。久久难得阿耨多罗三藐三菩提

【论】释曰。尔时帝释从佛闻赞般若波罗蜜具足故今问佛。菩萨云何住般若波罗蜜。从禅波罗蜜乃至十八不共法。佛赞言善哉善哉者。以释提桓因诸天中主言必可信。问是事断大众疑。通达无碍能大利益故言善哉善哉。复次佛以帝释能舍上妙五欲七宝宫殿能问佛贤圣所行事。是故言善哉。以佛神力故汝能乐问此事。是中更有上妙诸天。观佛神德无量。今帝释能于大众中咨问佛事故。是佛威神。如持心经说。佛光明入身中能问佛事。佛答憍尸迦。若菩萨不住色等。是习行般若波罗蜜者。是菩萨见色无常苦等过罪故不住色。若不住色即是能习行般若波罗蜜。凡夫人见色着色故起颠到烦恼。失是般若波罗蜜道。以是故不住者。能习行般若波罗蜜。五众十二入十八界亦如是。问曰。何以故。不住六波罗蜜等。各各自习其行。答曰。是六波罗蜜等皆是善法行法。以是故说不住六度等。言各习其行。众界入为习行般若波罗蜜。若于是法中不着则断爱着。断爱着故色等诸法中清净习。此中说不住因缘。所谓不得色等法住处。不得色等法习处。复次佛以此事难解故更说因缘。不习色者是菩萨见色过故不住色中。不住故不习。习色名取色相。若常若无常等。复次菩萨常行善法。正语正业等。积习纯厚故名习色。今菩萨欲行般若故。散坏是色不习。所以者何。过去色已灭。未来色未有故不可习。现在色生时即灭故不住。若住一念尚无习。何况念念灭。是故此中说不习色因缘。三世色不可得。乃至十八不共法亦如是。若能如是观诸法散坏不取相。是名能习色等诸法实相。尔时舍利弗从佛闻是义。欢喜深入空智。白佛。般若波罗蜜甚深。佛然可成其所赞。色等诸法如故甚深。佛语不但眼见色甚深。以般若波罗蜜分别色入如实故甚深。如雨渧渧不名甚深和合众流入于大海乃名甚深。色等亦如是。天眼肉眼见浅而不深。若以慧眼观则深不可测。甚深故难可测量。唯有诸佛乃尽其底。甚深不可测量故名无量。无有智慧能取色等实相。若常若无常筹量有过罪故。是时舍利弗及诸听者作是念。般若波罗蜜不可测量无有量。菩萨当云何行。佛知其念告舍利弗。菩萨摩诃萨若行色等甚深者。则为失般若波罗蜜。若不行色甚深是为得般若波罗蜜。凡夫钝根故言甚深。若有一心福德利根者为非甚深。譬如水深浅无定若于小儿则深长者则浅。乃至大海于人则深。于罗睺阿修罗王则浅。如是于凡夫人新发意懈怠者为甚深。于久积德阿鞞跋致则浅。诸佛如罗睺阿修罗王。于一切法无有深者。得无碍解脱故。以是故知为众生及时节利钝初久懈怠精进故。分别说深浅不可测量无有量亦如是。此中佛自说因缘。色等法甚深相为非色。何以故。怖畏心没疑悔故以色为甚深。色相则无深知先说。舍利弗白佛言。世尊。是般若波罗蜜甚深。甚深相难见难解。问曰。上说菩萨不行甚深为行般若波罗蜜。今舍利弗何以复说甚深。答曰。舍利弗非定心说甚深。得佛意趣为人故说甚深。是故此中说世尊不应于新发意菩萨前说是般若波罗蜜。新学菩萨闻是深智慧则心没。应当在阿鞞跋致菩萨前说。阿鞞跋致智慧深故信而不没。譬如深水不应使小儿渡应教大人令渡。帝释问舍利弗。若为新发意菩萨说有何等过。舍利弗答。是新发意者则不信心没。心没故生疑悔怖畏。若受一切空法。我云何当堕断灭中。若不受者佛所说法何可不受。是故怖畏生疑悔。若心定则生恶邪毁呰。毁呰果报如地狱品中说。此中略说种三恶道业因缘。久久难得无上道

【经】释提桓因问舍利弗。颇有未受记菩萨摩诃萨。闻是深般若波罗蜜不惊不怖者不。舍利弗言。如是憍尸迦。若有菩萨摩诃萨闻是深般若波罗蜜不惊不怖。当知是菩萨受阿耨多罗三藐三菩提记不久。不过一佛两佛。佛告舍利弗。如是如是。是菩萨摩诃萨久发意行六波罗蜜。多供养诸佛。闻是深般若波罗蜜不惊不怖不畏。闻即受持如般若波罗蜜中所说行。尔时舍利弗白佛言。世尊。我欲说譬喻。如求菩萨道善男子善女人梦中修行般若波罗蜜入禅定。勤精进具足忍辱。守护于戒行布施。修行内空外空。乃至坐于道场。当知是善男子善女人近阿耨多罗三藐三菩提。何况菩萨摩诃萨欲得阿耨多罗三藐三菩提。觉时修行般若波罗蜜入禅定。勤精进具足忍辱。守护于戒行布施。而不疾成阿耨多罗三藐三菩提坐于道场。世尊。善男子善女人善根成就。得闻般若波罗蜜。受持乃至如说行。当知是菩萨摩诃萨久发意种善根。多供养诸佛与善知识相随。是人能受持般若波罗蜜乃至正忆念。当知是人近受阿耨多罗三藐三菩提记。当知是善男子善女人如阿鞞跋致菩萨摩诃萨。于阿耨多罗三藐三菩提不动转。能得深般若波罗蜜。得已能受持读诵乃至正忆念。世尊。譬如人欲过百由旬若二百三百四百由旬。旷野崄道先见诸相。若放牧者若疆界若园林。如是等诸相故知近城邑聚落。是人见是相已作如是念。如我所见相当知城邑聚落不远。心得安隐不畏贼难恶虫饥渴。世尊。菩萨摩诃萨亦如是。若得是深般若波罗蜜受持读诵乃至正忆念。当知近受得阿耨多罗三藐三菩提记不久。当知是菩萨摩诃萨不应畏堕声闻辟支佛地。是诸先相所谓甚深般若波罗蜜得闻得见得受。乃至正忆念故。佛告舍利弗。如是如是。汝复乐说者便说。世尊。譬如人欲见大海发心往趣。不见树相不见出相。是人虽未见大海知大海不远。何以故。大海处平无树相无山相故。如是世尊。菩萨摩诃萨闻是深般若波罗蜜。受持乃至正忆念时。虽未佛前受劫数之记。若劫百千劫万劫百千万亿劫。是菩萨自知近受阿耨多罗三藐三菩提记不久。何以故。我得闻是深般若波罗蜜。受持读诵乃至正忆念故。世尊。譬如初春诸树陈叶已堕。当知此树新叶华果出在不久。何以故。见是诸树先相故。知今不久叶华果出。是时阎浮提人见树先相皆大欢喜。世尊。菩萨摩诃萨得闻是深般若波罗蜜。受持读诵乃至正忆念如说行。当知是菩萨善根成就多供养诸佛。是菩萨应作是念。先世善根所追趣阿耨多罗三藐三菩提。以是因缘故得见得闻是深般若波罗蜜。受持读诵乃至正忆念如说行。是中诸天子曾见佛者欢喜踊跃作是念言。先诸菩萨摩诃萨亦有如是受记先相。今是菩萨摩诃萨受阿耨多罗三藐三菩提记亦不久。世尊。譬如母人怀妊身体苦重。行步不便坐起不安。眠食转少不喜言语。厌本所习受苦痛故。有异母人见其先相。当知产生不久。菩萨摩诃萨亦如是。种善根多供养诸佛。久行六波罗蜜。与善知识相随。善根成就得闻深般若波罗蜜。受持读诵乃至正忆念如说行。诸菩萨亦知是菩萨摩诃萨得阿耨多罗三藐三菩提记不久。佛告舍利弗。善哉善哉。汝所乐说皆是佛力。尔时须菩提白佛言。希有世尊。诸多陀阿伽度阿罗呵三藐三佛陀。善付诸菩萨摩诃萨事。佛告须菩提。是诸菩萨摩诃萨发阿耨多罗三藐三菩提心。安隐多众生。令无量众生得乐。怜愍安乐饶益诸天人故。是诸菩萨行菩萨道时。以四事摄无量百千众生。所谓布施爱语利益同事。亦以十善道成就众生。自行初禅。亦教他人令行初禅。乃至自行非有想非无想处。亦教他人令行乃至非有想非无想处。自行檀波罗蜜。亦教他人令行檀波罗蜜。自行尸罗波罗蜜。亦教他人令行尸罗波罗蜜。自行羼提波罗蜜。亦教他人令行羼提波罗蜜。自行毗梨耶波罗蜜。亦教他人令行毗梨耶波罗蜜。自行禅波罗蜜。亦教他人令行禅波罗蜜。自行般若波罗蜜。亦教他人令行般若波罗蜜。是菩萨得般若波罗蜜。以方便力教众生令得须陀洹果。自于内不证。教众生令得斯陀含果阿那含果阿罗汉果。自于内不证。教众生令得辟支佛道。自于内不证。自行六波罗蜜。亦教无量百千万诸菩萨令行六波罗蜜。自住阿鞞跋致地。亦教他人住阿鞞跋致地。自净佛世界。亦教他人净佛世界。自成就众生。亦教他人成就众生。自得菩萨神通。亦教他人令得菩萨神通。自净陀罗尼门。亦教他人净陀罗尼门。自具足乐说辩才。亦教他人具足乐说辩才。自受色成就。亦教他人令受色成就。自成就三十二相。亦教他人成就三十二相。自成就童真地。亦教他人成就童真地。自成就佛十力。亦教他人令成就佛十力。自行四无所畏。亦教他人行四无所畏。自行十八不共法。亦教他人行十八不共法。自行大慈大悲。亦教他人令行大慈大悲。自得一切种智。亦教他人令得一切种智。自离一切结使及习。亦教他人令离一切结使及习。自转法轮。亦教他人转法轮

【论】释曰。尔时帝释问舍利弗。颇有未受记菩萨闻是深般若不惊不怖者不。舍利弗言。无有不受记闻般若能信者。若或时能信者。当知垂欲受记不过见一佛二佛。便得受记。佛可舍利弗语。舍利弗闻佛可其所说心生欢喜。复欲分明了了是事故说譬喻作是言。梦中心为睡所覆故非真心所作。若善男子善女人于梦中发意行六波罗蜜。乃至坐于道场。当知是人福德轻微近于受阿耨多罗三藐三菩提记。何况菩萨摩诃萨觉时实心发阿耨多罗三藐三菩提行六波罗蜜而不近受记。世尊若人往来六道生死中。或时得闻般若波罗蜜。受持读诵正忆念。必知是人不久得阿耨多罗三藐三菩提。如吞钩之鱼虽复游戏池中当知出在不久。行者亦如是。深信乐般若波罗蜜。不久住于生死。此中舍利弗自说譬喻。若人欲过险道。险道者即是世间。百由旬者是欲界。二百由旬者是色界。三百由旬者是无色界。四百由旬者是声闻辟支佛道。复次四百由旬是欲界。三百由旬是色界。二百由旬是无色界。百由旬是声闻辟支佛。欲出者是信受行般若波罗蜜人。先见诸法相者。见大菩萨舍世间欲乐深心乐般若波罗蜜。疆界者分别诸法。是声闻法是辟支佛法是大乘法。如是小利是声闻。大利是菩萨。魔界是生死。佛界是般若波罗蜜甘露法味不死之处。园林者随佛道禅定智慧等乐。如是等无量善法相。聚落者是柔顺法忍。邑是无生法忍。城是阿耨多罗三藐三菩提。得安稳者菩萨闻是法思惟筹量行。我得是法心安稳当得阿耨多罗三藐三菩提。贼者是我等六十二邪见。恶虫者是爱恚等诸烦恼。不畏贼者人不得便。不畏恶虫者非人不得便。不畏饥者不畏不能得圣人真智慧。不畏渴者不畏不能得禅定解脱等法乐味。此中自说因缘。菩萨摩诃萨得先相者。不久当得阿耨多罗三藐三菩提。不畏堕恶道中。饥饿死者不畏堕声闻辟支佛地。佛然可其喻。以粗喻细以世间喻出世间。余三譬喻亦应如上分别说。大海水是无上道。平地无树无山是般若波罗蜜经卷等。树果是无上道。树华是阿鞞跋致地。春时陈叶落更生新叶。是诸烦恼邪见疑等灭能得般若波罗蜜经卷等。母人是行者。所任身是无上道。欲产相是菩萨久习行般若波罗蜜。厌本所习是患世间淫欲乐不复喜着。佛赞其所说善哉。尔时须菩提闻佛然舍利弗所说赞其善哉。知佛意深敬念是菩萨。是故白佛言。世尊。甚为希有。善付菩萨事。菩萨事者空道福德道。亦如佛种种总相别相说以寄付阿难弥勒等。入无余涅槃后好自奉行。教示利益众生无令谬错。佛说善付因缘。诸菩萨发阿耨多罗三藐三菩提心安稳多众生者。一切众生中无量无边阿僧祇。除佛无能计知者。从佛得利益者不可数故名多。安稳者众生着常教无常。着乐者教苦。着实者教空。着我者教无我。如是等名安稳。凡夫人闻是当时虽不喜乐。久久灭诸烦恼得安稳乐。如服苦药当时虽苦后得除患。无量众生得乐者。菩萨求般若波罗蜜未得成就时。以今世后世乐利益众生。如菩萨本生经说。若得般若波罗蜜已断诸烦恼。亦以世间乐出世间乐利益众生。若得无上道时但以出世间乐利益众生。安乐饶益者但以怜愍心故安乐饶益。饶者多利益天人。余道中饶益少故不说。利益事者。所谓四摄法。以财施法施二种摄取众生。爱语有二种。一者随意爱语。二者随其所爱法为说。是菩萨未得道。怜愍众生自破憍慢。随意说法。若得道随所应度法为说。高心富人为赞布施。是人能得他物利名声福德故。若为赞持戒毁呰破戒则心不喜乐。如是等随其所应而为说法。利益亦有二种。一者今世利后世利为说法。以法治生勤修利事。二者未信教令信。破戒令持戒。寡识令多闻。不施者令布施。痴者教智慧。如是等以善法利益众生。同事者菩萨教化众生令行善法同其所行。菩萨善心众生恶心。能化其恶令同己善。是菩萨以四种摄众生令住十善道。是广说四摄义。于二施中法施随其所乐而为说法。是爱语中第一。众生爱惜寿命令行十善道则得久寿。利益于一切宝物利中法利最胜。是为利益。同事中同行善法为胜。是菩萨自行十善。亦以教人。有人言。后自行十善等是第四同义。是故说自行十善亦教人行。自行初禅亦教他行。初禅等同离欲同持戒。是故名相摄。相摄故渐渐能以三乘法度。乃至非有想非无想处亦如是。自行六波罗蜜亦以教他。因般若故令众生得般若分。所谓得须陀洹等方便力故自不证。是人福德智慧力增益故。教无量阿僧祇菩萨令住六波罗蜜。自住阿鞞跋致地等亦以教他。乃至自转法轮亦教他转法轮。是故我以慈悲心故善付是菩萨事。不以爱着故

大智度论卷第六十六大智度论释叹信行品第四十五之余(卷六十七)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】须菩提白佛言。希有世尊。诸菩萨摩诃萨大功德成就。所谓为一切众生行般若波罗蜜。欲得阿耨多罗三藐三菩提。世尊。云何诸菩萨摩诃萨具足修行般若波罗蜜。佛告须菩提。若菩萨摩诃萨行般若波罗蜜时。不见色增相亦不见色减相。不见受想行识增相。亦不见减相。乃至一切种智不见增相。亦不见减相。菩萨摩诃萨是时具足般若波罗蜜。复次须菩提。菩萨摩诃萨行般若波罗蜜时。不见是法是非法。不见是过去法是未来现在法。不见是善法不善法有记法无记法。不见是有为法无为法。不见欲界色界无色界。不见檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。乃至不见一切种智。如是菩萨摩诃萨具足修行般若波罗蜜。何以故。诸法无相故。诸法空欺诳不坚固。无觉者无寿者故。须菩提言。世尊。世尊所说不可思议。佛告须菩提。色不可思议故所说不可思议。受想行识不可思议故所说不可思议。六波罗蜜不可思议故所说不可思议。乃至一切种智不可思议故所说不可思议。须菩提。若菩萨摩诃萨行般若波罗蜜时。知色是不可思议受想行识是不可思议。乃至知一切种智是不可思议。是菩萨则不能具足般若波罗蜜。须菩提白佛言。世尊。是深般若波罗蜜谁当信解者。佛言。若有菩萨摩诃萨。久行六波罗蜜。种善根多观近供养诸佛。与善知识相随。是菩萨能信解深般若波罗蜜。须菩提白佛言。世尊。云何菩萨摩诃萨久行六波罗蜜。种善根多亲近供养诸佛。与善知识相随。佛言。若菩萨摩诃萨不分别色。不分别色相。不分别色性。不分别受想行识。不分别识相。不分别识性。眼耳鼻舌身意。色声香味触法。眼界乃至意识界亦如是。不分别欲界色界无色界。不分别三界相性。不分别檀波罗蜜乃至般若波罗蜜内空乃至无法有法空四念处乃至八圣道分佛十力乃至十八不共法。不分别十八不共法相性。不分别道种智相性。不分别一切种智。不分别一切种智相。不分别一切种智性。何以故。须菩提。色不可思议受想行识不可思议。乃至一切种智不可思议。如是须菩提。是名菩萨摩诃萨久行六波罗蜜种善根多亲近供养诸佛与善知识相随。须菩提白佛言。世尊。色甚深故般若波罗蜜甚深。受想行识甚深。乃至一切种智甚深故。般若波罗蜜甚深。世尊。是般若波罗蜜珍宝聚。有须陀洹果宝故。有斯陀含果阿那含果阿罗汉果辟支佛道阿耨多罗三藐三菩提宝故。有四禅四无量心四无色定五神通四念处乃至八圣道分佛十力四无所畏四无碍智大慈大悲十八不共法一切智一切种智宝故。世尊。是般若波罗蜜是清净聚。色清净故般若波罗蜜清净聚。受想行识清净。乃至一切种智清净故。般若波罗蜜清净聚

【论】释曰。是菩萨大功德成就者如先说。自行亦教他人。复次多功德者。众生非亲里又无所贪利。而为是众生勤苦行般若波罗蜜。得阿耨多罗三藐三菩提。是名菩萨摩诃萨有大恩分故名大功德。修般若波罗蜜相如先品中种种因缘说。今问修般若具足相。佛言。如修般若具足相亦如是。所以者何。若菩萨不见色等诸法增减。如是名具足。是菩萨虽得十地坐道场。尔时修般若波罗蜜具足。如梦如幻不增不减。以毕竟空故说。复次若菩萨于一切法不分别是法是非法。悉皆是法。如大海水百川万流皆合一味。尔时修般若波罗蜜具足。复次若菩萨入法空中不见法有三世善不善等。不见六波罗蜜乃至一切种智。尔时修般若波罗蜜具足。何以故。诸法无相是实相。若分别诸法皆是邪见相。用十八空故名诸法空。诸法和合因缘生以为有诸缘。离则破坏故虚诳。一切有为法中无常无实故是名不坚固。无受苦乐者。众生空故无觉者。不觉苦乐无寿命者寿名命根。有人言。是命根有我相。是故寿命为我。众生空中已种种因缘破。是故无行法者。无受法者。若观诸法空众生空法空。如是则具足修般若波罗蜜。须菩提是时惊喜不能自安。所说般若波罗蜜不可思议。佛言。色等诸法不可思议故不可思议。所以者何。因果相似故。复次若菩萨知色等法亦不可思议。若住是不可思议中。则不具足般若波罗蜜。取不可思议相故。是故说若菩萨知色等法不可思议相故。则不具足般若波罗蜜。尔时须菩提于般若中不得依止处如没大海。是故白佛。是深般若不可思议。不可思议亦不可思议故谁当信解者。若但不可思议犹不可信。何况不可思议复不可思议。佛答。若菩萨久行六波罗蜜。久种善根久供养亲近诸佛。久与善知识相随。是因缘故信心牢固能信受深般若波罗蜜。余品中说有新发意者。亦能信深般若波罗蜜。今佛说久发意故能信。是以须菩提问。云何是久发意者。佛言。若菩萨摩诃萨了了知般若波罗蜜相。不分别一切法。所谓不分别色四大若四大造色。不分别色相者不分别色是可见声是可闻是色若好若丑若短若长若常若无常若苦若乐等。不分别色性者不见色常法。所谓地坚性等。复次色实性名法性。毕竟空故。是菩萨不分别法性。法性不坏相故。乃至一切种智亦如是。问曰。地是坚相何以言性。答曰。是相积习成性。譬如人嗔日习不已则成恶性。或性相异如见烟知火烟是火相而非火也。或相性不异如热是火相亦是火性。此中佛说因缘色等诸法不可思议。不可思议即是毕竟空诸法实相常清净。须菩提言。菩萨虽日月年岁不久能如是行是名久。须菩提闻般若波罗蜜更得深利益故白佛言。世尊。般若波罗蜜甚深。色等甚深故。色等甚深相如先说。世尊。般若波罗蜜是珍宝聚。珍宝者所谓须陀洹果能灭三结恶毒故。乃至阿耨多罗三藐三菩提能灭一切烦恼及习能满一切愿。是诸果依诸禅乃至一切种智因果合说。是名珍宝聚。是般若波罗蜜清净聚色等诸法清净故。色等法中正行不邪名为清净。无诸过患乃至毕竟空亦不着。不可思议亦不着。是故名清净聚。尔时须菩提应作是念。是般若波罗蜜是珍宝聚。能满一切众生愿。所谓今世乐后世乐涅槃乐阿耨多罗三藐三菩提乐。愚痴之人而复欲破坏是般若波罗蜜清净聚。如如意宝珠无有瑕秽。如虚空无有尘垢。般若波罗蜜毕竟清净聚。而人自起邪见因缘欲作留难破坏。譬如人眼翳见妙珍宝谓为不净作是念已

【经】须菩提言。世尊。甚可怪。说是般若波罗蜜时多有留难。佛言。如是如是。须菩提。是甚深般若波罗蜜多有留难。以是事故。善男子善女人若欲书是般若波罗蜜时。应当疾书。若读诵思惟说正忆念修行时。亦应疾修行。何以故。是甚深般若波罗蜜若书时。读诵思惟说正忆念修行时。不欲令诸难起故。善男子善女人若能一月书成当应勤书。若二月三月四月五月六月七月若一岁书成亦当勤书。读诵思惟说正忆念修行。若一月得成就。乃至一岁得成就。应当勤成就。何以故。须菩提。是珍宝中多有难起故。须菩提言。世尊。是甚深般若波罗蜜中。恶魔喜作留难故。不得令书。不得令读诵思惟说正忆念修行。佛告须菩提。恶魔虽欲留难是深般若波罗蜜令不得书读诵思惟说正忆念修行。亦不能破坏是菩萨摩诃萨书般若波罗蜜乃至修行。尔时舍利弗白佛言。世尊。谁力故令恶魔不能留难菩萨摩诃萨书深般若波罗蜜乃至修行。佛言。是佛力故。恶魔不能留难。菩萨摩诃萨书深般若波罗蜜乃至修行。舍利弗。亦是十方世界现在诸佛力故。是诸佛拥护念是菩萨故。令魔不能留难菩萨摩诃萨令不书成般若波罗蜜乃至修行。何以故。十方世界中现在无量无边阿僧祇诸佛拥护念是菩萨。书深般若波罗蜜乃至修行法应尔无能作留难。舍利弗。善男子善女人应当作是念。我书是深般若波罗蜜。乃至修行。皆是十方诸佛力。舍利弗言。世尊。若有善男子善女人书是深般若波罗蜜。乃至修行。皆是佛力故。当知是人是诸佛所护。佛言。如是如是。舍利弗当知。若有善男子善女人。书是深般若波罗蜜。乃至修行。皆是佛力故。当知亦是诸佛所护。舍利弗言。世尊。十方现在无量无边阿僧祇诸佛皆识。皆以佛眼见。是善男子善女人书深般若波罗蜜乃至修行时。佛言。如是如是。舍利弗。十方现在无量无边阿僧祇诸佛皆识。皆以佛眼见。是善男子善女人书深般若波罗蜜乃至修行时。舍利弗。是中求菩萨道善男子善女人。若书是深般若波罗蜜。受持读诵正忆念如说修行。当知是人近阿耨多罗三藐三菩提不久。舍利弗。善男子善女人书是深般若波罗蜜。受持读诵乃至正忆念。是人于深般若波罗蜜多信解相。亦供养恭敬尊重赞叹是深般若波罗蜜。华香璎珞乃至幡盖供养。舍利弗。诸佛皆识皆以佛眼见是善男子善女人。是善男子善女人供养功德。当得大利益大果报。舍利弗。是善男子善女人以是供养功德因缘故。终不堕恶道中。乃至阿鞞跋致地。终不远离诸佛。舍利弗。是善男子善女人以是善根因缘故。乃至阿耨多罗三藐三菩提。终不远离六波罗蜜。终不远离内空乃至无法有法空。终不远离四念处乃至八圣道分。终不远离佛十力乃至阿耨多罗三藐三菩提

【论】释曰。留难者。魔事等坏般若波罗蜜因缘。佛可须菩提所说。若善男子善女人欲书是般若波罗蜜。当疾疾书乃至正忆念如说行时疾修行。所以疾者是有为法不可信多有留难起。是般若波罗蜜部党经卷。有多有少有上中下。光赞放光道行。有书写者书有迟疾。有一心勤书者。有懈堕不精勤者。人身无常有为法不可信。释迦文佛出恶世故多有留难。是故说若可一月书竟。当勤书成莫有中废。畏有留难故。乃至一岁如书。乃至修行亦如是。随人根利钝得有迟疾。此中佛更说因缘。世间以珍宝故多有贼出。般若即是大珍宝故多有留难。留难者虽有疾病饥饿等。但以魔事大故说言魔事。若魔若魔民恶鬼作恶因缘。入人身中。娆乱人身心破书般若。或令书人疲厌。或令国土事起或书人不得供养。如是等读诵时师徒不和合。大众中说时。或有人来说法师过罪。或言不能如说行何足听受。或言虽能持戒而复钝根不解深义。听其所说了无所益。或说般若波罗蜜空无所有。灭一切法无可行处。譬如裸人自言我着天衣。如是等留难令不得说。不正忆念者魔作好身若善知识身。或作所敬信沙门形。为说般若波罗蜜空无所有。虽有罪福名而无道理。或说般若波罗蜜空可即取涅槃。如是等破修佛道正忆念事。新发意菩萨闻是事心大惊怖。我等生死身。魔是欲界主威势甚大。我等云何行般若波罗蜜得无上道。是故佛说恶魔虽欲留难亦不能破坏。何以故。大能破小故。如离欲人常胜贪欲者慈悲人常胜嗔恚者智人常胜无智者。般若波罗蜜是真智慧其力甚大。魔事虚诳。是菩萨虽未得具足般若波罗蜜。得其气分故魔不能坏。是事因缘故舍利弗白佛。谁力故魔不能破。佛答。佛力故。如恶人中魔为大。善人中佛为大。缚人中魔为大。解人中佛为大。留难人中魔为大。通达人中佛为大。初说佛力者释迦文佛。后说十方现在佛。是余佛阿閦阿弥陀等。如恶贼余恶相助。诸佛法亦如是。常为一切众生故有发意者便为作护。所以者何。般若波罗蜜是十方诸佛母。人欲沮坏不得不护。应当知其有书读乃至正忆念者。皆是十方佛力。是诸留难力大故。舍利弗言。若有书持乃至修行皆是诸佛所护。佛可其言。舍利弗复说。世尊。书持等善男子善女人。十方现在诸佛皆以佛眼见知念耶。佛可言。如是。先恶魔来欲破坏。佛及十方诸佛守护不令沮坏。今以佛眼见是善男子善女人。知是人功德难有。未破魔网而能行是般若波罗蜜大事。是故十方佛以佛眼见知念是人。问曰。为以天眼见以佛眼见。若以天眼见。云何此中说佛眼。若以佛眼见众生虚诳。云何以佛眼见。答曰。天眼有二种。一者佛眼所摄。二者不摄佛眼。所不摄者见现在众生有限有量。佛眼所摄者见三世众生无限无量。法眼入佛眼中。但见诸法不见众生。慧眼入佛眼中不见法但见毕竟空。问曰。佛眼所摄天眼为实为虚妄。若虚妄佛不应以虚妄见。若实者众生空。现在众生尚不实。何况未来过去。答曰。佛眼所摄皆是实。众生于涅槃是虚妄。非于世界所见是虚妄。若人于众生取定相故说言虚妄。非为世谛故说虚妄。以是故佛眼所摄天眼见众生。问曰。若尔者何以不以佛眼所摄慧眼见众生。答曰。慧眼无相利故。慧眼常以空无相无作共相应不中观众生。何以故。五众和合假名众生。譬如小儿可以小杖鞭之不可与大杖。此中赞菩萨行般若波罗蜜为世谛故说非第一义谛。问曰。未来世未有念知尚难何况眼见。答曰。如过去法虽灭无所有而心心数法中念力故。能忆过去事尽其宿命。圣人亦如是。有圣智力虽未起而能知能见。复次是般若中三世无分别。未来过去现在不异。若见现在过去未来亦应见。若不见过去未来亦应不见现在。问曰。北方末法众生漏结未尽是罪恶人。佛何以故见知念。答曰。佛大悲相爱彻骨髓。是菩萨能发无上道心为众生故佛观是法末后炽盛。我涅槃后是人佐助佛法故是以念知。复次北方末后人生于边地恶世三毒炽盛刀兵劫中贤圣希少。是人自不知诸罪福业因缘。但从人闻若读经便能信乐供养疾近无上道。不久是事为难。若佛在世作阿鞞跋致信行般若波罗蜜。不足为难。如是等种种无量因缘故佛应见念知。是人信解相大故能供养般若波罗蜜。供养具华香等如先说。是供养故得大果报。如毁呰者受大苦恼。大果报者如须陀洹。终不堕三恶道。是菩萨一心信解供养。般若波罗蜜亦如是。爱念诸佛故。常行念佛三昧故。终不离诸佛。乃至到阿鞞跋致地。教化众生离诸佛无咎。如小儿不离其母。恐堕诸难故。常深爱念善法故。乃至阿耨多罗三藐三菩提。终不离六波罗蜜等。得如是等今世后世大果报

【经】舍利弗。是深般若波罗蜜佛般涅槃后。当至南方国土。是中比丘比丘尼优婆塞优婆夷。当书是深般若波罗蜜。当受持读诵思惟说正忆念修行。以是善根因缘故。终不堕恶道中。受天上人中乐。增益六波罗蜜。供养恭敬尊重赞叹诸佛。渐以声闻辟支佛佛乘而得涅槃。舍利弗。是深般若波罗蜜从南方当转至西方。所在处是中比丘比丘尼优婆塞优婆夷。当书是深般若波罗蜜。当受持读诵思惟说正忆念修行。以是善根因缘故。终不堕恶道中。受天上人中乐。增益六波罗蜜。供养恭敬尊重赞叹诸佛。渐以声闻辟支佛佛乘而得涅槃。舍利弗。是深般若波罗蜜从西方当转至北方。所在处是中比丘比丘尼优婆塞优婆夷。当书是深般若波罗蜜。当受持读诵思惟说正忆念修行。以是善根因缘故。终不堕恶道中。受天上人中乐增益六波罗蜜。供养恭敬尊重赞叹诸佛。渐以声闻辟支佛佛乘而得涅槃。舍利弗。是深般若波罗蜜是时北方当作佛事。何以故。舍利弗。我法盛时无有灭相。舍利弗。我已念是善男子善女人受持是深般若波罗蜜乃至修行。亦念是善男子善女人。能书是般若波罗蜜。恭敬供养尊重赞叹。华香乃至幡盖。舍利弗是善男子善女人以是善根因缘故。终不堕恶道中。受天上人中乐。增益六波罗蜜。供养恭敬尊重赞叹诸佛。渐以声闻辟支佛佛乘而得涅槃。何以故。舍利弗。我以佛眼见是人。我亦称誉赞叹十方世界中无量无边阿僧祇诸佛。亦以佛眼见是人。亦称誉赞叹舍利弗白佛言。世尊。是深般若波罗蜜后时当在北方广行耶。佛言。如是如是。舍利弗。是深般若波罗蜜后时在北方当广行。舍利弗。后时于北方是善男子善女人。若闻是深般若波罗蜜。若书受持读诵思惟说正忆念如说修行。当知是善男子善女人久发大乘心。多供养诸佛种诸善根。久与善知识相随。舍利弗白佛言。世尊。后时北方当有几所善男子善女人求佛道书深般若波罗蜜乃至如说修行。佛告舍利弗。后时北方虽多有求佛道善男子善女人。少有善男子善女人闻是深般若波罗蜜不没不惊不怖不畏。何以故。是人多亲近供养诸佛多咨问诸佛。是人必能具足般若波罗蜜禅波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀波罗蜜。具足四念处。乃至具足十八不共法。舍利弗。是善男子善女人善根纯厚故。能多利益众生。为阿耨多罗三藐三菩提。何以故。我今为是善男子善女人。说应萨婆若法。过去诸佛亦为是善男子善女人。说应萨婆若法。以是因缘故。是人后生时。续得阿耨多罗三藐三菩提心。亦为他人说阿耨多罗三藐三菩提法。是善男子善女人皆一心和合。魔若魔民不能沮坏阿耨多罗三藐三菩提心。何况恶行人毁呰行深般若波罗蜜者。能坏其阿耨多罗三藐三菩提心。舍利弗。是求菩萨道诸善男子善女人。闻是深般若波罗蜜。大得法喜法乐。亦立多人于善根。为阿耨多罗三藐三菩提

【论】释曰。是深般若波罗蜜。佛灭度后当至南方国土者。佛出东方于中说般若波罗蜜。破魔及魔民外道。度无量众生。然后于拘夷那竭双树下灭度。后般若波罗蜜从东方至南方。如日月五星二十八宿。常从东方至南方。从南方至西方。从西方至北方。围绕须弥山。又如供养常法。右绕遍度阎浮提人。以是因缘故。从东方至南方从南方至西方。如佛无著心故不定一处。般若波罗蜜亦如是。不定住一处。从西方至北方。二方众生好供养书读乃至修行。华香乃至幡盖受大果报。如经中说。后展转至北方。此中供养所得果报如上所说。舍利弗。是般若波罗蜜北方当作佛事。是中说因缘。佛在时能断众疑。佛法兴盛不畏法灭。佛灭后过五百岁正法渐灭。是时佛事转难。是时利根者读诵正忆念亦华香供养。钝根者书写华香等供养。是二种人久久皆当得度。是故说当作佛事。佛言。是善男子善女人我及十方诸佛。皆以佛眼见念知赞叹。舍利弗白佛言。是深般若在北方广行耶。广行者于阎浮提北方广大故。又北方地有雪山。雪山冷故药草能杀诸毒。所食米谷三毒不能大发三毒不能大发故。众生柔软信等五根皆得势力。如是等因缘北方多行般若波罗蜜。是人闻是深般若波罗蜜。书持乃至正忆念如说行。当知是人久发大乘意。多供养佛种善根。与善知识相随。是故能于恶世书持信受乃至如说修行。舍利弗问。北方有几许人。闻是深般若波罗蜜。能书读诵乃至如说修行。佛答。是深般若波罗蜜难知难行。虽多有人发无上道心得名菩萨少。有人闻是般若波罗蜜心通达不惊不没心通达不惊不怖相。佛此中自说。是人多亲近诸佛。亲近诸佛者于无量世常见诸佛恭敬供养。问难者直问其事。疑心不解重种种问名为难。是人世世从诸佛问难般若波罗蜜事。是人功德果报虽未成。当知是人具足六波罗蜜三十七品乃至十八不共法。具足是福德淳熟故多利益众生。所谓檀波罗蜜尸罗波罗蜜因缘故。生于富贵家自行布施教人布施。羼提波罗蜜禅波罗蜜因缘故。令无量众生出家受戒发阿耨多罗三藐三菩提心。此中佛说因缘。是人从我及过去诸佛闻应萨婆若大乘法。是故后生不失是心。是人亦教化他人说如是事。如然一灯展转皆然。是人诸烦恼薄无悭贪嫉妒嗔恚故不相谗谤。常一心和合。是故魔若魔民不能沮坏。若人少有错故魔得其便。如人有疮受毒。魔是欲界主尚不能沮坏。何况恶行人。或有人恶行而非恶。如未离欲圣人。以是故说恶行人毁呰般若波罗蜜即毁坏菩萨。复次诸善男子善女人无量世来爱佛法深着实法。信力慧力多故闻深般若波罗蜜。得大慈大悲心故随众生力令入深般若波罗蜜。若令得般若因缘。所谓布施持戒等诸善根。为阿耨多罗三藐三菩提故者。是善男子善女人求无上道故。教他令住诸善根福德

【经】是善男子善女人于我前立誓愿。我行菩萨道时。当度无数百千万亿众生。令发阿耨多罗三藐三菩提心。示教利喜乃至阿鞞跋致地受记。我知其心我亦随喜。是善男子善女人亦于过去诸佛前立誓愿。我行菩萨道时。当度无数百千万亿众生。令发阿耨多罗三藐三菩提心。示教利喜乃至阿鞞跋致地受记。诸过去佛亦知其心而随喜。舍利弗。是诸善男子善女人所为心大。所受色声香味触法亦大。亦能大施。能大施已种大善根。种大善根已得大果报。为摄众生故受身。能于众生中舍内外所有物。以是善根因缘故。发愿欲生他方世界现在诸佛说深般若波罗蜜处。于诸佛前闻是深般若波罗蜜已。亦于彼示教利喜百千万亿众生。令发阿耨多罗三藐三菩提心。舍利弗白佛言。希有世尊。佛于过去未来现在法。无法不知无法知相不知。众生之行无事不知。今佛悉知过去诸佛及菩萨声闻。亦知今现在十方诸佛世界菩萨及声闻。亦知未来诸佛及菩萨声闻。世尊。未来世有善男子善女人。勤求六波罗蜜。受持读诵乃至修行。有得有不得。佛告舍利弗。若善男子善女人一心精进勤求。当得应六波罗蜜诸经

舍利弗白佛言。善男子善女人如是勤行。当得是应六波罗蜜深经。佛语舍利弗。是善男子善女人得是应六波罗蜜深经。何以故。善男子善女人为阿耨多罗三藐三菩提故。与众生说法示教利喜令住六波罗蜜中。以是因缘故。是善男子善女人后身转生。易得应六波罗蜜深经。得已如六波罗蜜所说修行精勤不息。乃至净佛世界成就众生。得阿耨多罗三藐三菩提

【论】释曰。佛说。善男子善女人于我前及过去诸佛前立誓愿。我行菩萨道。当令无量百千万亿众生发无上道意示教利喜令得阿鞞跋致记。我及过去佛。知是善男子心大能有所作故随喜。善男子善女人闻佛知其心则生欢喜。自念过去作誓愿事。倍加精进。大心者一切众生心皆乐缘六尘。有人行杂福德。所谓作福时心生疑悔。是福德果报虽得富贵不能好用。亦不能与他。罪业因缘故。诸根闇钝不择好丑。是善男子未得道时。清净福德故。得上妙五欲。亦能尽意用能随意施与。或施穷乏或种于福田。若得善知识闻佛法着欲心息怜愍众生。为阿耨多罗三藐三菩提故。内外所有布施无所爱惜。若持戒遍行十善道具戒律仪。以慈悲心共行。余善法亦如是。皆以深心自行。及引导他人令行善道。是福德因缘故。不求世乐天王人王富贵处。闻有现在佛处愿往生彼。是菩萨知诸法实相故不乐生。若为众生生十方佛前闻深般若波罗蜜。闻已于彼开化无量百千众生发无上道心。舍利弗无一切智。闻说三世菩萨愿行事发希有心。白佛言。世尊。佛于三世中无法不知。从如法性实际无不知者。诸众生心所行业果报因缘无事不知。从十方现在诸佛及过去未来世佛及世界弟子及所行事皆悉遍知。佛一切智其力甚大不可思议。舍利弗意谓。同是出家人俱求般若波罗蜜。何以故。有得有不得者。佛答。若是菩萨常一心求六波罗蜜不惜身命。是人内有好心外诸佛菩萨及诸天所护助故。舍利弗意虽复精进佛不在世魔力复大。是菩萨云何得是般若波罗蜜深经。是故更问得是应六波罗蜜深经。佛言。得此中说得因缘。所谓善男子善女人为无上道故。为众生说法示教利喜令住六波罗蜜开佛道。是业果报故转身易得应六波罗蜜深经。若得能疾受持乃至如所说。修行精进不舍。世世常不离。用六波罗蜜果报故。净佛世界成就众生。乃至无上道。若吝惜法则常生边地无佛法处

大智度论卷第六十七大智度论释魔事品第四十六(卷六十八)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】慧命须菩提白佛言。世尊。是善男子善女人发阿耨多罗三藐三菩提心。行六波罗蜜。成就众生净佛世界。佛已赞叹说其功德。世尊。云何善男子善女人求于佛道生诸留难。佛告须菩提。乐说辩不即生。当知是菩萨魔事。须菩提言世尊。何因缘故乐说辩不即生。是菩萨魔事。佛言。有菩萨摩诃萨。行般若波罗蜜时。难具足六波罗蜜。以是因缘故。乐说辩不即生。是菩萨魔事。复次须菩提。乐说辩卒起。当知亦是菩萨魔事。世尊。何因缘故。乐说辩卒起复是魔事。佛言。菩萨摩诃萨行檀波罗蜜。乃至般若波罗蜜着乐说法。以是因缘故。乐说辩卒起。当知是菩萨魔事。复次须菩提。书是般若波罗蜜经时偃[仁-二+蹇]傲慢。当知是菩萨魔事。复次须菩提。书是经时戏笑乱心。当知是菩萨魔事。复次须菩提。若书是经时轻笑不敬。当知是菩萨魔事。复次须菩提。若书是经时心乱不定。当知是菩萨魔事。复次须菩提。若书是经时各各不和合。当知是菩萨魔事。复次须菩提。善男子善女人作是念。我不得是经中滋味便弃舍去。当知是菩萨魔事。复次须菩提。受持般若波罗蜜读诵说若正忆念时偃[仁-二+蹇]傲慢。当知是菩萨魔事。复次须菩提。若受持般若波罗蜜经亲近正忆念时转相形笑。当知是菩萨魔事。复次须菩提。若受持般若波罗蜜经读诵正忆念修行时共相轻蔑。当知是菩萨魔事。若受持般若波罗蜜读诵乃至正忆念时散乱心。当知是菩萨魔事。若受持般若波罗蜜读诵乃至正忆念时心不和合。当知是菩萨魔事。须菩提白佛言。世尊。世尊说善男子善女人作是念。我不得经中滋味便弃舍去。当知是菩萨魔事。世尊。何因缘故。菩萨不得经中滋味便弃舍去。佛言。是菩萨摩诃萨前世不久行般若波罗蜜禅波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀波罗蜜。是人闻说是般若波罗蜜。便从坐起作是念言。我于般若波罗蜜中无记心不清净。便从坐起去。当知是菩萨魔事。须菩提白佛言。世尊。何因缘故不与受记。闻说是深般若波罗蜜时。便从坐起去。佛告须菩提。若菩萨未入法位中。诸佛不与受阿耨多罗三藐三菩提记。复次须菩提。闻说般若波罗蜜时菩萨作是念。我是中无名字心不清净。当知是菩萨魔事。须菩提言。何因缘故。是深般若波罗蜜中。不说是菩萨名字。佛言。未受记菩萨诸佛不说名字。复次须菩提。是菩萨摩诃萨作是念。是般若波罗蜜中无我生处名字若聚落城邑。是人不欲听闻般若波罗蜜。便从会中起去。是人如所起念时。念念却一劫。甫当更勤精进求阿耨多罗三藐三菩提

【论】释曰。一切有为法各有增上。增上者共相违。相违即是怨贼。如水得增上力灭火火得增上力则消水。乃至草木各有相害。何况众生。菩萨摩诃萨有大悲心。虽不与众生作怨。而众生与菩萨作怨。菩萨身有为法故能作留难。佛上说菩萨功德。所谓诸佛菩萨诸天所护。而未说怨贼相。以佛怜愍故。先虽略说今须菩提请佛广说留难事。佛虽于一切众生一切法心平等。以是菩萨能大利益世间故。说好丑相及利害相是道非道留难事。佛不令行人毁害留难者。但令觉知不随其事。何者是怨贼略说。若众生法非众生法。能沮坏菩萨无上道心。非众生者若疾病饥渴寒热槌压坠落等。众生者魔及魔民恶鬼邪疑不信者。断善根者。定有所得者。实定分别诸法者。深着世间乐者。怨贼官事师子虎狼恶兽毒虫等众生。贼有二种若内若外。内者自从心生忧愁不得法味。生邪见疑悔不信等。外者如上说。如是诸难事。佛总名为魔。魔有四种。烦恼魔五众魔死魔天子魔。烦恼魔者。所谓百八烦恼等。分别八万四千诸烦恼。五众魔者。是烦恼业和合因缘得是身。四大及四大造色眼根等色是名色众。百八烦恼等诸受和合名为受众。小大无量无所有想。分别和合名为想众。因好丑心发能起贪欲嗔恚等心相应不相应法名为行众。六情六尘和合故生六识。是六识分别和合无量无边心是名识众。死魔者。无常因缘故。破相续五众寿命尽离三法识断寿故名为死魔。天子魔者。欲界主深着世间乐用有所得故生邪见。憎嫉一切贤圣涅槃道法。是名天子魔。魔秦言能夺命者。虽死魔实能夺命余者亦能作夺命因缘亦夺智慧命。是故名杀者。问曰。一五众魔摄三种魔。何以故。别说四。答曰。实是一魔。分别其义故有四。烦恼魔者人因贪欲嗔恚故死。亦能作夺命因缘。是近夺命因缘故别说。天子魔杂福德业因缘故力势大。邪见力故能夺慧命。亦能作死因缘。是故别说无常死力大。一切无能免者甚可畏厌故别说。问曰。是魔何以恼乱行道者。答曰。先已广说。是品中皆有四种魔义。但随处说。复次三魔不相远离。若有五众则有烦恼。有烦恼则天魔得其便。五众烦恼和合故有天魔。是故须菩提问佛上已赞叹说菩萨功德。今云何是菩萨魔事起。佛答乐说辩不即生是为魔事者。若菩萨摩诃萨怜愍众生故。高座说法而乐说辩不生听者忧愁。我等故来而法师不说。或作是念法师怖畏故不能说。或言不知故不说。或自惟过咎深重故不说。或谓不得供养故不肯说。或谓轻贱我等故不说。或串乐故不说。如是等种种因缘听者心坏故。以不乐说名为魔事。复次是菩萨怜愍众生故来欲说法。听者欲闻而法师心生欲说而口不能言。现见是魔事如魔入阿难心。佛三问而三不答久乃说者。此中须菩提问世尊何因缘故辩不即生。佛答菩萨行六波罗蜜时难具足六波罗蜜。所以者何。是人先世因缘故。钝根懈怠魔得其便。不一心行六波罗蜜故。乐说辩不即生。问曰。如乐说辩不即生可是魔事。今乐说辩卒起。何以复是魔事。答曰。是法师爱法着法求名声故自恣乐说无有义理如逸马难制。又如大水暴涨众秽浑杂。是故此中佛自说菩萨行六波罗蜜着乐说法。是为魔事。复次是般若波罗蜜为破憍慢故出。而书是经者生我心憍慢心。憍慢故身亦高。所谓偃[仁-二+蹇]傲慢书是般若波罗蜜时。用轻心嗔心戏笑不敬。复次是般若波罗蜜一心摄心犹尚难得。何况散乱心书。书时从人口受。或写经卷若一心和合则得。若授者不与。如是等种种因缘是不和合。复次观看是般若波罗蜜经时。品品皆空无可乐处。作是念。我于是经不得滋味。便弃舍去。般若波罗蜜。是一切诸乐根本。此人不得其味是为魔事。复次受持读诵说正忆念时。偃[仁-二+蹇]形笑散乱心不和合如上说。共相轻蔑者。从人受持读诵正忆念时。师徒互相轻贱。书写经时但有舍去无相轻贱。问曰。上诸事中何以但问不得经中滋味不问余者。答曰。般若波罗蜜圣人所说与凡人说异。是故凡夫人不得滋味。须菩提意谓。般若波罗蜜是清净珍宝聚能利益众生无有过恶。是人云何不得滋味。佛答。是人先世不久行六波罗蜜故。菩萨信等五根薄。薄故不能信空无相无作无依止法。娆乱心起作是言。佛一切智何以不与我受记。便舍去。余者易解故不问。须菩提问。若尔者何以故。不与授记。佛是大悲应当愍念防护其心不令堕恶。佛言。未入法位人诸佛不与授记。所以者何。诸佛虽悉知众生久远事为五通仙人及诸天。见是人未有善行业因缘可授记者若为授记。轻佛不信无有因缘云何与授记。是故入法位者与授记。是人名字及聚落处亦如是。是人从坐起去随其起念多少。念念却一劫。偿罪毕还得人身甫当复尔所劫行

【经】复次须菩提。菩萨学余经弃舍般若波罗蜜。终不能至萨婆若。善男子善女人为舍其根而攀枝叶。当知亦是菩萨魔事。须菩提白佛言。世尊。何等是余经。善男子善女人所学。不能至萨婆若。佛言。是声闻所应行经。所谓四念处四正勤四如意足。五根五力七觉分八圣道分。空无相无作解脱门。善男子善女人住是中。得须陀洹果斯陀含果阿那含果阿罗汉果。是名声闻所行经。不能至萨婆若。如是善男子善女人舍般若波罗蜜亲近是余经。何以故。须菩提。般若波罗蜜中出生诸菩萨摩诃萨。成就世间出世间法。须菩提。菩萨摩诃萨学般若波罗蜜时。亦学世间出世间法。须菩提。譬如狗不从大家求食反从作务者索。如是须菩提。当来世有善男子善女人。弃舍深般若波罗蜜。而攀枝叶声闻辟支佛所应行经。当知是为菩萨魔事。须菩提。譬如有人欲得见象见已反观其迹。须菩提。于汝意云何。是人为黠不。须菩提言。为不黠。佛言。诸求佛道善男子善女人亦复如是。得深般若波罗蜜弃舍去。取声闻辟支佛所应行经。须菩提当知。是为菩萨魔事。须菩提。譬如人欲见大海见已反求牛迹水作是念。大海水能与此等不。须菩提。于汝意云何是人为黠不。须菩提言。为不黠。佛言。当来世有求佛道善男子善女人亦如是。得深般若波罗蜜弃舍去。取声闻辟支佛所应行经。当知是亦菩萨摩诃萨魔事。须菩提。譬如工匠若工匠弟子。欲拟作释提桓因胜殿而揆则日月宫殿。须菩提。于汝意云何。是人为黠不。须菩提言。为不黠。如是须菩提。当来世有薄福德善男子善女人求佛道者。得是深般若波罗蜜弃舍去。取声闻辟支佛所应行经中求萨婆若。须菩提。于汝意云何。是人为黠不。须菩提言。为不黠。佛言。当知亦是菩萨魔事。须菩提。譬如有人欲见转轮圣王见而不识。后见诸小国王取其相貌作如是言。转轮圣王与此何异。须菩提。于汝意云何。是人为黠不。须菩提言。为不黠。须菩提。当来世有薄福德善男子善女人求佛道者。得是深般若波罗蜜弃舍去。取声闻辟支佛所应行经持求萨婆若。须菩提。于汝意云何。是人为黠不。须菩提言。为不黠。当知是为菩萨魔事。须菩提。譬如饥人得百味食弃舍去反食六十日谷饭。须菩提。于汝意云何。是人为黠不。须菩提言。为不黠。佛言。当来世有求佛道善男子善女人。得闻深般若波罗蜜弃舍去。取声闻辟支佛所应行经持求萨婆若。于汝意云何。是人为黠不。须菩提言。为不黠。当知是亦菩萨魔事。须菩提。譬如人得无价摩尼珠反持比水精珠。须菩提。于汝意云何。是人为黠不。须菩提言。为不黠。佛言。当来世有求佛道善男子善女人。得闻深般若波罗蜜弃舍去。取声闻辟支佛所应行经持求萨婆若。是人为黠不。须菩提言。为不黠。当知是亦菩萨魔事。复次须菩提。是求佛道善男子善女人。书是深般若波罗蜜时。乐说不如法事。不得书成般若波罗蜜。所谓乐说色声香味触法。乐说持戒禅定无色定。乐说檀波罗蜜乃至般若波罗蜜。乐说四念处乃至阿耨多罗三藐三菩提。何以故。须菩提。是般若波罗蜜中无乐说相。须菩提。般若波罗蜜不可思议相。般若波罗蜜不生不灭相。般若波罗蜜不垢不净相。般若波罗蜜不乱不散相。般若波罗蜜无说相。般若波罗蜜无言无义相。般若波罗蜜无所得相。何以故。须菩提。是般若波罗蜜中无是诸相。须菩提。若有善男子善女人求菩萨道者。书是般若波罗蜜经时。以是诸法散乱心。当知是亦菩萨魔事。须菩提白佛言。世尊。是般若波罗蜜可书耶。佛言。不可书。何以故。般若波罗蜜自性无故。禅波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀波罗蜜乃至一切种智自性无故。若自性无是不名为性。无法不能书无法。须菩提。若求菩萨道善男子善女人作是念。无法是深般若波罗蜜。当知即是菩萨魔事。世尊。是求菩萨道善男子善女人。用文字书般若波罗蜜。自念。我书是般若波罗蜜。以字着般若波罗蜜。当知亦是菩萨魔事。何以故。世尊。是般若波罗蜜无文字。禅波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀波罗蜜无有文字。世尊。色无文字。受想行识无文字。乃至一切种智无文字。世尊。若求菩萨道善男子善女人。着无文字般若波罗蜜。乃至着无文字一切种智。当知亦是菩萨魔事。读诵说正忆念如说修行亦如是。复次须菩提。求佛道善男子善女人。书般若波罗蜜时。若国土念起。聚落念起。城邑念起。方念起。若闻谤毁其师念起。若念父母及兄弟姊妹诸余亲里。若念贼若念旃陀罗。若念众女若念淫女。如是等种种诸余异念。留难恶魔复益其念。破坏书般若波罗蜜。破坏读诵说正忆念如说修行。须菩提当知。是亦菩萨魔事。复次须菩提。求佛道善男子善女人。得名誉恭敬布施供养。所谓衣服饮食卧床疾药种种乐具。善男子善女人书是般若波罗蜜经。受读诵乃至正忆念时。爱着是事。不得书成般若波罗蜜乃至正忆念。当知是亦菩萨魔事。复次须菩提。求佛道善男子善女人书般若波罗蜜乃至如说修行时。恶魔方便持诸余深经。与是菩萨摩诃萨。有方便者不应贪着恶魔所与诸余深经。何以故。是经不能令人至萨婆若故。是中无方便菩萨摩诃萨。闻是诸余深经。便舍深般若波罗蜜。须菩提。我是般若波罗蜜中广说诸菩萨摩诃萨方便道。诸菩萨摩诃萨应当从是中求。须菩提。今善男子善女人求菩萨道。舍是深般若波罗蜜。于魔所与声闻辟支佛深经中求方便道。当知亦是菩萨魔事

【论】释曰。学余经舍般若波罗蜜等。有人于声闻法中受戒学法。初不闻般若波罗蜜。或时余处闻深着先所学法舍于般若波罗蜜。于先所学法中求萨婆若。有声闻弟子。先得般若波罗蜜不知义趣不得滋味。以声闻经行菩萨道。有人是声闻弟子得般若波罗蜜经欲信受。余声闻人沮坏其心。语言是经初后不相应无有定相汝宜舍之。声闻法中何所不有。六足阿毗昙及其论议分别诸法相。即是般若波罗蜜。八十部律即是尸罗波罗蜜。阿毗昙中分别诸禅解脱诸三昧等。是禅波罗蜜。三藏本生中赞叹解脱布施忍辱精进。即是三波罗蜜。如是等种种因缘舍般若波罗蜜。于声闻经中求萨婆若。如人欲得坚实好木舍其根茎而取枝叶。虽是木名而不中用。复次般若波罗蜜是三藏根本。得般若波罗蜜已为度众生故说余事。是名枝叶。复次声闻经中虽说诸法实相而不了了。般若波罗蜜经中分明显现易见易得。如人攀缘枝叶则堕落。若捉茎干则坚固。若执声闻经则堕小乘中。若持般若波罗蜜易得无上道。是故说舍根茎取枝叶。问曰。三十七品三解脱门般若经中亦有。今何以故。但名声闻辟支佛经。答曰。摩诃衍中虽有是法。与毕竟空合心无所著。以不舍萨婆若大悲心为一切众生故说。声闻经则不尔。为小乘证故。复次菩萨行般若波罗蜜故能成就世间出世间法是。故菩萨若求佛。应当学般若波罗蜜。譬如狗为主守备应当从主索食而反于奴客求。菩萨亦如是。狗喻行者。般若波罗蜜喻主人。般若中有种种利益。而舍求余经。佛欲令分明易见故说譬喻。象大海帝释殿转轮圣王无价宝亦如是。问曰。五欲生五盖。以五盖覆智慧故不应乐说。何以故。乐说余六波罗蜜乃至无上道而言不如法。答曰。不如法者不如般若波罗蜜实相。般若波罗蜜实相中无定相法。云何可乐说。若有定相则心着乐说。诸佛及菩萨以大悲心故。为众生说法不着语言。用无所得法。示众生毕竟空相般若波罗蜜。是人书读诵等以染着心取六尘相。乃至无上道故言不如法。问曰。若般若波罗蜜毕竟空无所有法。不可书读诵等。如是则不应有魔事。答曰。毕竟空无所有亦非般若波罗蜜相。何以故。是魔事此中说。若是人知无所有是般若波罗蜜相。即是魔事若用文字书般若波罗蜜。自知我书般若波罗蜜。有此着心即是魔事。若人知般若波罗蜜相不以着心书读诵等。若有来破者是为破般若波罗蜜。复次内有烦恼魔外有天子魔。是二事因缘故书般若波罗蜜。乃至修行时坏般若波罗蜜。念起者所谓念此国土不安稳彼国土丰乐。聚落城邑方亦如是。或闻谤毁其师舍般若波罗蜜欲助师除灭恶名。或闻父母疾病官事。或念贼恐怖欲发心诣余处旃陀罗亦如是。与贼旃陀罗共住则发嗔恚。与众淫女共住故淫欲心发。如是等种种因缘破坏般若波罗蜜。菩萨觉知当莫念莫说。或书般若波罗蜜时。钝根者于多恭敬供养事中爱着自念。我能书能随行故有是着。是利养即是魔事。或有利根者魔或思惟。是菩萨不着世间乐。一心受般若波罗蜜。此人不可沮坏。我今当以声闻深经转其心使成阿罗汉。佛言声闻经虽深不应贪着。譬如烧热金丸色虽妙好不可捉。若菩萨无方便不大利根得是经欢喜。是空无相无作尽苦本。何复过是便舍般若波罗蜜亦是魔事。何以故。此中佛说因缘。于般若波罗蜜中广说诸菩萨摩诃萨方便道。所谓观声闻辟支佛道而不证。以大悲心行三解脱门故。譬如人以酥和毒毒势则歇不能害人。般若亦如是。菩萨于般若中求无上道易得于余经则难。如但服毒。是故不应从声闻经中。求菩萨道

    大智度论释两不和合品第四十七

【经】复次须菩提。听法人欲书持般若波罗蜜读诵问义正忆念。说法人懈堕不欲为说。当知是为菩萨摩诃萨魔事。须菩提。说法之人心不懈堕。欲令书持般若波罗蜜。听法者不欲受之。二心不和。当知是为魔事。复次须菩提。听法人若欲书持般若波罗蜜读诵乃至正忆念。说法者欲至他方。当知是为魔事。须菩提。说法人欲令书持般若波罗蜜。听法者欲至他方。二心不和。当知是为魔事。复次须菩提。说法人贵重布施衣服饮食卧具医药资生之物。听法人少欲知足行远离行。摄念精进一心智慧两不和合。不得书般若波罗蜜受持读诵问义正忆念。当知是为魔事。须菩提。说法人少欲知足行远离行。摄念精进一心智慧。听法者贵重布施衣服饮食卧具医药资生之物。两不和合。不得书持般若波罗蜜读诵问义正忆念。当知是为魔事。复次须菩提。说法者受十二头陀。一作阿兰若。二常乞食。三纳衣。四一坐食。五节量食。六中后不饮浆。七冢间住。八树下住。九露地住。十常坐不卧。十一次第乞食。十二但三衣。听法人不受十二头陀。不作阿兰若。乃至不受但三衣。两不和合。不得书持般若波罗蜜读诵问义正忆念。当知是为魔事。须菩提。听法者受十二头陀。作阿兰若。乃至受但三衣。说法人不受十二头陀。不作阿兰若。乃至不受但三衣。两不和合。不得书持般若波罗蜜读诵问义正忆念。当知是为魔事

【论】释曰。一切有为法因缘和合故生。众缘离则无。譬如攒燧求火有钻有母二事因缘得火。书写般若乃至正忆念亦如是。内外因缘和合故生。所谓师弟子同心同事故乃得书成。是故佛告须菩提。听法人信等五善根发故。欲书持般若乃至正忆念。说法者五盖覆心故不欲说。问曰。若五盖覆心故不欲说何以作师。答曰。是人着世间乐不观空无常。虽能心知口说不能自行。弟子虽必欲行而不能知。不能知故更无余处。必咨此人或时师悲心发故欲令书持般若。弟子信等五善根钝不发故。着世间乐故。不欲受书持乃至正忆念。问曰。若不欲受持何以名为听法者。答曰。少多听受读诵不能究竟成就故。但名听法。若二人善心共同能得般若波罗蜜。若不同则不能得是名魔事。内烦恼发外天子魔作因缘。虽是般若菩萨应觉是魔事防令不起。若自失当具足若弟子失当教令得。复次师或慈悲心薄舍弟子至他方。或不宜水土四大不和。或善法无所增益。或水旱不适。或土地荒乱。如是等种种因缘故至他方。弟子亦种种因缘不能追随。贵重利养者如上五盖覆心等。复次是二人皆有信有戒。而一人以十二头陀庄严戒。一人不能。问曰。一人何以故不能。答曰。佛所结戒弟子受持。十二头陀不名为戒。能行则戒庄严。不能行不犯戒。譬如布施能行则得福不能行者无罪。头陀亦如是。是故两不和合则是魔事。十二头陀者行者以居家多恼乱。故舍父母妻子眷属出家行道。而师徒同学还相结着心复娆乱。是故受阿兰若法令身远离愦闹住于空闲。远离者最近三里能远益善。得是身远离已。亦当令心远离五欲五盖。若受请食若众僧食起诸漏因缘。所以者何。受请食者若得作是念。我是福德好人故得。若不得则嫌恨请者。彼为无所别识不应请者请应请者不请。或自鄙薄懊恼自责而生忧苦。是贪忧法则能遮道。僧食者入众中当随众法。断事摈人料理僧事处分。作使心则散乱妨废行道。有如是等恼乱事故。受常乞食法。好衣因缘故。四方追逐堕邪命中。若受人好衣则生亲着。若不亲着檀越则恨。若僧中得衣如上说。众中之过。又好衣是未得道者生贪着处。好衣因缘招致贼难。或至夺命。有如是等患故受弊纳衣法。行者作是念。求一食尚多有所妨。何况小食中食后食。若不自损则失半日之功。不能一心行道。佛法为行道故。不为益身。如养马养猪。是故断数数食受一食法。有人虽一食而贪心极啖。腹胀气塞妨废行道。是故受节量食法。节量者略说随所能食三分留一分。则身轻安稳易消无患。于身无损。则行道无废。如经中舍利弗说。我若食五口六口足之。以水则足支身。于秦人中食不十口许。有人虽节量食过中饮浆则心乐着。求种种浆果浆蜜浆等。求欲无厌。不能一心修习善法。如马不着辔勒左右啖草不肯进路。若着辔勒则不啖草意断随人意去。是故受中后不饮浆。无常空观是入佛法门。能厌离三界。冢间常有悲啼哭声死尸狼藉。眼见无常后或火烧鸟兽所食不久灭尽。因是尸观一切法中易得无常相空相。又冢间住若见死尸嗅烂不净易得。九相观是离欲初门。是故受冢间住法能作不净无常等观已得道。事办舍至树下。或未得道者心则不大厌取是相树下思惟。如佛生时成道时转法轮时般涅槃时皆在树下。行者随诸佛法常处树下。如是等因缘故受树下坐法。行者或观树下如半舍无异荫覆凉乐又生爱者。我所住者好彼树不如。如是等生漏故至露地住作是思惟。树下有二种过。一者雨漏湿冷。二者鸟屎污身毒虫所住。有如是等过。空地则无此患。露地住则着衣脱衣随意快乐。月光遍照空中明。净心易入空三昧。身四仪中坐为第一。食易消化气息调和。求道者大事未办。诸烦恼贼常伺其便不宜安卧。若行若立则心动难摄。亦不可久故受常坐法。若欲睡时胁不着席。行者不着于味不轻众生。等心怜愍故。次第乞食不择贫富故。受次第乞食法。行者少欲知足衣趣盖形不多不少故。受但三衣法。白衣求乐故多畜种种衣。或有外道苦行故裸形无耻。是故佛弟子舍二边处中道行。住处食处常用故事多。衣不须日日求故略说。是十二头陀。佛意欲令弟子随道行舍世乐。故赞十二头陀。是佛意常以头陀为本有因缘。不得已而听余事。如转法轮时五比丘初得道。白佛言。我等着何等衣。佛言。应着纳衣。又受戒法尽寿着纳衣。乞食树下住。弊弃药。于古四圣种中。头陀即是三事。佛法唯以智慧为本。不以苦为先。是法皆助道随道故诸佛常赞叹

大智度论卷第六十八大智度论释两不和合品第四十七之余(卷六十九)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】复次须菩提。说法者有信有善。欲书受深般若波罗蜜乃至正忆念。听法者无信破戒恶行。不欲书受深般若波罗蜜乃至正忆念。当知是为魔事。须菩提。听法者有信有善。说法者无信破戒恶行。两不和合。当知是为魔事。复次须菩提。说法者能一切施心不悭惜。听法者吝惜不舍。当知是为魔事。须菩提。听法者一切能施心不悭惜。说法者吝法不施。两不和合。不得书持般若波罗蜜乃至正忆念。当知是为魔事。复次须菩提。听法者欲供养说法人衣服饮食卧具医药资生所须。说法者不欲受之。当知是为魔事。须菩提。说法者欲供给听法人衣服乃至资生所须。听法者不欲受之。两不和合。不得书持般若波罗蜜乃至正忆念。当知是为魔事。复次须菩提。说法者易悟。听法人闇钝。当知是为魔事。须菩提。听法者易悟。说法人闇钝。两不和合。不得书持般若波罗蜜乃至正忆念。当知是为魔事

复次须菩提。说法者知十二部经次第义。所谓修妒路乃至优波提舍。听法者不知十二部经次第义。当知是为魔事。听法者知十二部经次第义。说法人不知十二部经次第义。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。复次须菩提。说法者成就六波罗蜜。听法人不成就六波罗蜜。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。听法者有六波罗蜜。说法人无六波罗蜜。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。复次须菩提。说法者于六波罗蜜有方便力。听法人于六波罗蜜无方便力。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。听法者于六波罗蜜有方便力。说法人于六波罗蜜无方便力。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。复次须菩提。说法者得陀罗尼。听法者无陀罗尼。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。听法者得陀罗尼。说法者无陀罗尼。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。复次须菩提。说法者欲令书持般若波罗蜜乃至正忆念。听法人不欲书持般若波罗蜜读诵乃至正忆念。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。听法者欲书读诵说般若波罗蜜。说法者不欲令书般若波罗蜜。乃至不欲令说。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。复次须菩提。说法者离贪欲嗔恚睡眠掉悔疑。听法人贪欲嗔恚睡眠掉悔疑。当知是为魔事。听法者离贪欲嗔恚睡眠掉悔疑。说法人贪欲嗔恚睡眠掉悔疑。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。复次须菩提。书是深般若波罗蜜。乃至正忆念时。或有人来说三恶道中苦剧。汝何不于是身尽苦入涅槃。何用是阿耨多罗三藐三菩提为。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。复次须菩提。书是深般若波罗蜜。受持读诵说正忆念时。或有人来赞四天王诸天。赞三十三天夜摩天兜率陀天化乐天他化自在天梵天乃至非有想非无想天。赞初禅乃至非有想非无想定。作是言。善男子。欲界中受五欲快乐。色界中受禅生乐。无色界中受寂灭乐。是事亦无常苦空无我。变相尽相散相离相灭相。汝何不于是身中取须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道。何用是世间生死中受种种苦。求阿耨多罗三藐三菩提为。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。复次须菩提。说法者一身无累自在无碍。听法人多将人众。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。听法者一身无累自在无碍。说法者多将人众。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。复次须菩提。说法者如是言。汝能随我意者。当与汝般若波罗蜜令书读诵说正忆念。若不随我意者。则不与汝。两不和合。不得书深般若波罗蜜读诵说正忆念。当知是为魔事。复次须菩提。听法者欲得追随如其意。说法者不听。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。复次须菩提。说法者欲得财利故。与般若波罗蜜令书持乃至正忆念。听法者以是因缘故。不欲从受。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。听法者为财利故。欲书深般若波罗蜜读诵说。说法者以是因缘故不欲与。两不和合。不得书深般若波罗蜜读诵说。当知是为魔事。复次须菩提。说法者欲至他方危命之处。听法者不欲随去。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。听法者欲至他方危命之处。说法者不欲去。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。复次须菩提。说法者欲至他方饥饿谷贵无水之处。听法者不欲随去。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。听法者欲至他方饥饿谷贵无水之处。说法者不欲去。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。复次须菩提。说法者欲至他方丰乐之处。听法者欲随从去。说法者言。善男子汝为利养故追随我。汝善自思惟。若得若不得无令后悔。以是少因缘故。两不和合。听法者闻之心厌作是念。是为距逆我。不欲与我相随便止不去。两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事

复次须菩提。说法者欲过旷野。贼怖旃陀罗怖猎师怖恶兽毒蛇怖。听法者欲随逐去。说法者言。善男子汝何用到彼。彼中多有诸怖。贼怖乃至毒蛇怖。听法者闻之知其不欲与般若波罗蜜书持乃至正忆念。心厌不欲追随。以是少因缘故。两不和合。当知是为魔事。复次须菩提。说法者多有檀越数往问讯。以是因缘故。语听法者。我有因缘应往到彼。听法人知其意便止两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事

【论】问曰。有人书持读诵般若波罗蜜不能行而犯戒。或可有是若不信云何从受法。答曰。是人不信般若波罗蜜。所谓毕竟空。但欲求名故读诵广说如佛弟子。不信外道经书亦为人讲说。复次不能深心信乐般若故名不信。非都不信。问曰。弟子法应供养师奉诸所有。何以言师不能施。答曰。弟子作是念。师少物不能舍。何况舍身虽赞说布施是为欺诳。是故不和合。弟子欲以四事供养师。师少欲知足故不受。或羞愧似如卖法故不受。或师多知多识无所乏少。能供给弟子。弟子自念人当谓我贪师衣食故受法。或自以德薄不消所给。此心虽好不能成般若波罗蜜故亦是魔事。师钝根者是诵经师非解义师。十二部经亦是诵经师。复次师有六波罗蜜者。作是念弟子罪人钝根不能行六波罗蜜。着世间事。但有弟子名无有实事。是师不知弟子闻般若已后成大事。但以现前无六波罗蜜不肯教化。弟子亦作是念。六波罗蜜义我亦能行。师但能口说不能修行。不知师转身因缘当成大事。又不知师别有读诵利益因缘故不和合。复次弟子直信着善法。师不着法。以方便行六波罗蜜。弟子谓为不深乐六波罗蜜。何以知之。师或时赞叹六波罗蜜。或时断人着故破散六波罗蜜。弟子有方便亦如是。问曰。若弟子得陀罗尼师无陀罗尼。何以为师。答曰。陀罗尼有种种。有弟子得闻持陀罗尼。能持能诵不能解义。师能为解说。弟子或能得诸法实相陀罗尼义。而不能次第读诵。或师得闻持陀罗尼未得大悲故。轻贱弟子不能教导。问曰。弟子欲受持般若波罗蜜师不与。或可有是云何师欲与法弟子不欲受。答曰如先答。弟子见师有过故不欲受法。复次师欲教化前人为弟子。而是人或邪见诸恶因缘故不肯受教。复次一切众生所行法同则和合。一人离五盖一人不离故相轻。相轻故不和合。一切上法皆尔。复次书诵般若波罗蜜乃至正忆念时。一人呵三恶道。一人赞叹诸天。是事如先答。虽不能都破其善行。且坏其大乘授小乘法。复次师少欲知足不乐众聚。弟子多有人众。师作是念。弟子虽好可度而将徒众多。师深着善法舍离弟子。弟子一身亦如是。复次说法者意若弟子随我意行。若去若住随时问讯。如是等听法者但欲从求法利。不能行此众事是不和合。或时听法者随意进止问讯等。说法者不听作是念。何用是事损我功德。听法者意谓轻贱不相好喜是不和合。复次师为利养故欲与法。弟子心则不敬师。云何欲卖经法。弟子亦如是。为财利养读诵般若。非清净心故。师知弟子心。如是则薄贱不与故不和合。复次师欲至他方路经崄难。弟子惜身命故不能随。作是念我有身然后求法。弟子欲去亦如是。饥饿谷贵无水处亦如是。复次师欲至丰乐处。弟子欲随师。或羞愧不欲将去。或弟子串乐不任涉远。或道里悬远。或师谙彼国弟子不悉。谓师称美彼国不必实尔。时或虑师谓贪饮食故去。如是等种种因缘。师语弟子如汝所闻。彼国土所有不必尽尔。好自筹量若自欲去者便去。无以财物丰乐故去。至彼不得随意。勿以见怨师。复为说汝闻彼国土丰乐故去。非为法故不须随我。师好心止弟子。不知是坏般若波罗蜜因缘。弟子闻是说敬难师故不能答。便止不去故不和合。师复欲至远国。彼中有种种虎狼贼盗。语弟子言。彼间多难汝不须去。弟子闻已便止。师但知彼有难事故止弟子。不知是坏般若波罗蜜因缘。问曰。若远国多难何以自去。答曰。有人言。师彼国生故服习彼土能自防护。有人言。彼有好师经书。不惜身命故去。师作是念我身自死则可。云何枉他。如是等因缘故止弟子不令去。师多有知识檀越心生乐着。弟子少欲知足不着檀越。师常随时问讯檀越。弟子但欲求法不喜是事。师知其意语言。我有因缘不得为汝说法。弟子闻已不悦。师贵俗缘不贵于法是不和合

【经】复次须菩提。恶魔作比丘形像来。方便破坏是般若波罗蜜。不得令书持读诵说正忆念。须菩提白佛言。世尊。何因缘故。恶魔作比丘形像。方便破坏般若波罗蜜。不得令书持乃至正忆念。佛言。恶魔作比丘形像来。坏善男子善女人心。令远离般若波罗蜜。作是言。如我所说经。即是般若波罗蜜。此经非般若波罗蜜。须菩提。是中破坏诸比丘时。有未受记菩萨便堕疑。随疑故不书深般若波罗蜜。不受不持。乃至不作正忆念不和合。不得书深般若波罗蜜。乃至正忆念。当知是为魔事。复次须菩提。恶魔作比丘身到菩萨所作如是言。若菩萨行般若波罗蜜。于实际作证。得须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道以是两不和合。不得书深般若波罗蜜乃至正忆念。当知是为魔事。复次须菩提。菩萨说是深般若波罗蜜时。多有魔事起留难。般若波罗蜜是为魔事。菩萨摩诃萨应当觉知知已远离。须菩提言。世尊。何等是魔事留难。菩萨应当觉知知已远离。佛言。似般若波罗蜜诸魔事起。似禅波罗蜜。似毗梨耶波罗蜜。似羼提波罗蜜。似尸罗波罗蜜。似檀波罗蜜魔事起。菩萨应当觉知知已远离。复次须菩提。声闻辟支佛所应行经。是菩萨摩诃萨应当知是魔事而远离之。复次须菩提。内空乃至无法有法空。四念处乃至八圣道分。空无相无作解脱门。用是法得须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道。如是等诸经。恶魔作比丘形像方便与菩萨摩诃萨。是不和合故。不得书深般若波罗蜜乃至正忆念。当知是为魔事。复次须菩提。恶魔作佛身金色丈光到菩萨所。是菩萨贪着。贪着故耗减萨婆若。是不和合故。不得书深般若波罗蜜乃至正忆念。当知是为魔事。复次须菩提。恶魔作佛身及比丘僧到菩萨前。是菩萨起贪着。意作是念。我于当来世亦当如是从比丘僧为说法。是菩萨贪着魔身故。耗减萨婆若。不得书成般若波罗蜜多乃至正忆念。当知是为魔事。复次须菩提。恶魔化作无数百千万亿菩萨。行檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。指示善男子善女人。善男子善女人见已贪着。贪着故耗减萨婆若。不得书深般若波罗蜜乃至正忆念。当知是为魔事。何以故。是深般若波罗蜜中无有色。无有受想行识。乃至无有阿耨多罗三藐三菩提。须菩提。是般若波罗蜜若无有色。乃至无阿耨多罗三藐三菩提。是中无佛无声闻无辟支佛无菩萨。何以故。一切诸法自性空故。复次须菩提。善男子善女人书是深般若波罗蜜。受读诵说正忆念时。多有留难起。须菩提。譬如阎浮提中珍宝金银琉璃车磲马瑙珊瑚等宝多难多贼。如是须菩提。善男子善女人。书是深般若波罗蜜。乃至正忆念时。多贼多留难起。须菩提白佛言。如是世尊。阎浮提中珍宝金银琉璃车磲马瑙珊瑚等多贼多难。世尊。善男子善女人。亦如是。书是深般若波罗蜜乃至正忆念时。多贼多留难起多有魔事。何以故。是愚痴人为魔所使。善男子善女人。书是深般若波罗蜜乃至正忆念时。破坏令远离。世尊。是愚痴人少智少慧。是善男子善女人。书深般若波罗蜜乃至正忆念时。破坏令远离。是愚痴人心不乐大法。是故不书是深般若波罗蜜。不受不读不诵不正忆念不如说修行。亦坏他人令不得书深般若波罗蜜乃至如说修行。佛言。如是如是。须菩提。新发大乘意善男子善女人为魔所使。不种善根。不供养诸佛。不随善知识故。不书深般若波罗蜜。乃至不正忆念而作留难。是善男子善女人。少智少慧心不乐大法。是故不能书是深般若波罗蜜。乃至正忆念。魔事起故。须菩提。若善男子善女人。能书是深般若波罗蜜乃至正忆念时。魔事不起。能具足禅波罗蜜乃至檀波罗蜜。能具足四念处乃至一切种智。须菩提。当知佛力故。是善男子善女人。能书是深般若波罗蜜。乃至正忆念。亦能具足禅波罗蜜乃至檀波罗蜜内空乃至无法有法空。具足四念处乃至八圣道分佛十力乃至一切种智。须菩提。十方现在无量无边阿僧祇诸佛。亦助是善男子善女人。令得书是深般若波罗蜜乃至正忆念。十方阿鞞跋致诸菩萨摩诃萨。亦拥护祐助是善男子善女人。书深般若波罗蜜。乃至正忆念

【论】释曰。魔作大沙门形有重威德。令人受其语多持经卷。与众弟子俱语诸比丘。般若波罗蜜如我经所说。真实佛语汝先闻者不实非佛所说。呵毁先经种种自赞所说。钝根菩萨信受是语生邪见。若利根未得受记者生疑。何以故。诸佛毕竟空无相智慧难解故不和合。或时魔语菩萨。般若波罗蜜三解脱门广说但是空。汝常习此空于中得证。不得证云何作佛。作佛法先行布施持戒等。修三十二相福德坐道场时尔乃用空。菩萨或信或疑离般若波罗蜜。问曰。云何似六波罗蜜。名魔事。答曰。如相似般若波罗蜜中说。复次以着心行六波罗蜜。是名似声闻辟支佛经。无有慈悲不求佛道但欲自度。虽是好事破菩萨道故名魔事。问曰。若菩萨见佛身则信心清净。云何名魔事。答曰。一切烦恼取相皆是魔事。是小菩萨未应见佛身。魔作佛妙形。菩萨心着为是好身故行道。如未离欲人见天女形。深心染着不能堪受天欲迷闷而死。是故魔愿得满。菩萨虽得少净心而失实相智慧。如人手捉重宝有人以少金诳之舍大价宝而取贱物。是名耗减。魔作佛身将诸比丘。示多菩萨行六波罗蜜亦如上。此中佛说因缘。色等一切法自性空。复次众会生疑。般若波罗蜜是无上法多有利益。云何有人憎嫉。是故佛说譬喻。如阎浮提金银等多怨多贼。为是故出不为瓦石等生。般若波罗蜜是佛法藏中妙宝微妙甚深。懈怠钝根者所不解。是故呰毁魔。以般若波罗蜜多令众生入涅槃故魔作怨贼。须菩提喜受佛教述其所说。毁呰破坏般若者。世尊是狂痴之人。为魔所使不得自在。以少智故不能通达佛意。是人无有大心。不知清净法味但知三相。贪味淫欲嗔恚。如畜生法。与般若波罗蜜生留难。佛可须菩提所说。语须菩提。若菩萨摩诃萨书般若乃至正忆念魔事不起。当知是佛力。亦是十方诸佛及诸菩萨所拥护而能具足五波罗蜜乃至一切种智。亦是十方现在佛力。何以故。魔是欲界主世间福德智慧具足。魔是世间生死根本。色界诸天虽有邪见常入禅定故。心柔软不能有所破坏。无色界中无形故。又心微细不能有所作。下诸天无有力势故不能如是破坏。是魔先世业因缘力。又住处因缘。他作夺取。是中贼主名为魔。是魔相。尔破坏好事。初发心菩萨福德智慧薄故惜身。若十方诸佛菩萨不拥护佐助者不能成。是故诸佛菩萨诸天为破坏魔事。是菩萨或觉或不觉如贼绕城大人守护小儿不觉。略说魔事如是。广说则无量无边。然佛意但欲令行者成般若大事是故师徒宜应和合一切恶事不应计念

    大智度论释佛母品第四十八

【经】佛告须菩提。譬如母人有子。若五若十若二十若三十若四十若五十若百若千。母中得病。诸子各各勤求救疗。作是念。我等云何令母得安无诸患苦不乐之事。风寒冷热蚊虻蛇蚖侵犯母身。是我等忧。其诸子等常求乐具供养其母。所以者何。生育我等示我世间。如是须菩提。佛常以佛眼视是深般若波罗蜜。何以故。是深般若波罗蜜能示世间相。十方现在诸佛亦以佛眼常视是深般若波罗蜜。何以故。是深般若波罗蜜。能生诸佛。能与诸佛一切智。能示世间相。以是故诸佛常以佛眼视是深般若波罗蜜。又以般若波罗蜜能生禅波罗蜜乃至檀波罗蜜能生内空乃至无法有法空。能生四念处乃至八圣道分。能生佛十力乃至一切种智。如是般若波罗蜜能生。须陀洹斯陀含阿那含阿罗汉辟支佛诸佛。须菩提。所有诸佛已得阿耨多罗三藐三菩提。今得当得。皆因深般若波罗蜜因缘故得。须菩提。若求佛道善男子善女人。书是深般若波罗蜜乃至正忆念。诸佛常以佛眼视是人。须菩提。是求菩萨道善男子善女人。诸十方佛常守护令不退阿耨多罗三藐三菩提。须菩提白佛言。如世尊所说。般若波罗蜜能生诸佛。能示世间相。世尊。般若波罗蜜云何能生诸佛。云何能示世间相。云何诸佛从般若波罗蜜生。云何诸佛说世间相。佛告须菩提。是深般若波罗蜜中生佛十力乃至十八不共法一切种智。须菩提。得是诸法故名为佛。须菩提。以是故深般若波罗蜜。能生诸佛。须菩提。诸佛说五众是世间相。须菩提言。世尊。云何深般若波罗蜜中说五众相。云何深般若波罗蜜中示五众。须菩提。般若波罗蜜不示五众破。不示五众坏。不示生不示灭。不示垢不示净。不示增不示减。不示入不示出。不示过去不示未来不示现在。何以故。空相不破不坏。无相相无作相不破不坏。不起法不生法无所有法性法不破不坏相如是示。如是须菩提。佛说深般若波罗蜜能示世间相。复次须菩提。诸佛因深般若波罗蜜。悉知无量无边阿僧祇众生心所行。须菩提。是深般若波罗蜜中。无众生无众生名。无色无色名。无受想行识无受想行识名。无眼乃至无意。无眼识乃至无意识。无眼触乃至无意触。乃至无一切智无一切智名。如是须菩提。是深般若波罗蜜能示世间相。须菩提。是深般若波罗蜜亦不示色。不示受想行识。乃至不示一切种智。何以故。须菩提。是深般若波罗蜜中尚无般若波罗蜜。何况色乃至一切种智。复次须菩提。所有众生名数。若有色若无色。若有想若无想。若非有想非无想。若此间世界。若遍十方世界。是诸众生若摄心若乱心。是摄心乱心佛如实知。须菩提。云何佛知众生摄心乱心相。以法相故知。用何等法相故知。须菩提。是法相中尚无法相相。何况有摄心乱心。须菩提。以是法相故佛知众生摄心乱心。复次须菩提。佛知众生摄心乱心。云何知。须菩提。以尽相故知。以无染相故知。以灭相故知。以断相故知。以寂相故知。以离相故知。如是须菩提。佛因般若波罗蜜知众生摄心乱心。复次须菩提。佛因般若波罗蜜知众生染心。如实知染心嗔心痴心。如实知嗔心痴心。须菩提白佛言。世尊。云何佛知众生染心如实知染心。嗔心痴心如实知嗔心痴心。佛告须菩提。染心如实相则无染心相。何以故。如实相中心心数法不可得。何况当得染心不染心。须菩提。嗔心痴心如实相则无嗔无痴相。何以故。如实相中心心数法尚不可得。何况当得嗔心不嗔心痴心不痴心。如是须菩提。佛因般若波罗蜜。众生染心如实知染心。嗔心痴心如实知嗔心痴心。复次须菩提。佛因般若波罗蜜。众生无染心如实知无染心。无嗔心无痴心如实知无嗔心无痴心。须菩提白佛言。世尊。云何众生无染心如实知无染心。无嗔心如实知无嗔心。无痴心如实知无痴心。佛告须菩提。是心无染相中。染相不染相不可得。何以故。须菩提。二心不俱故。如是须菩提。佛因般若波罗蜜。众生无染心如实知无染心。须菩提。是无嗔心无痴心相中。痴心不痴心不可得。何以故。二心不俱故。如是须菩提。佛因般若波罗蜜。众生无嗔心无痴心如实知。复次须菩提。佛因般若波罗蜜。是众生广心如实知广心。须菩提白佛言。世尊。云何佛因般若波罗蜜。是众生广心如实知广心须菩提。佛知诸众生心相。不广不狭不增不减不来不去。心相离故。是心不广。乃至不来不去。何以故。是心性无故。谁作广谁作狭。乃至来去如是。须菩提。佛因般若波罗蜜。是众生广心。如实知广心。复次须菩提。佛因般若波罗蜜。是众生大心如实知大心。须菩提白佛言。世尊。云何佛因般若波罗蜜。是众生大心如实知大心。佛告须菩提。佛因般若波罗蜜不见众生心来相去相。不见众生心生相灭相住相异相。何以故。是诸心性无故。谁来谁去谁生灭住异。如是须菩提。佛因般若波罗蜜。是众生大心如实知大心。复次须菩提。佛因般若波罗蜜。众生无量心如实知无量心。须菩提白佛言。世尊。云何佛因般若波罗蜜。众生无量心如实知无量心。佛告须菩提。佛因般若波罗蜜。知是众生心。不见住不见不住。何以故。是无量心相无依止故。谁有住不住处。如是须菩提。佛因般若波罗蜜。众生无量心如实知无量心。复次须菩提。佛因般若波罗蜜。众生不可见心如实知不可见心。须菩提白佛言。世尊。云何佛因般若波罗蜜。众生不可见心如实知不可见心。佛告须菩提。众生心是无相。佛如实知无相。自相空故。复次须菩提。佛知众生心。五眼不能见。如是须菩提。佛因般若波罗蜜。众生不可见心。如实知不可见心

【论】释曰。上说十方诸佛及大菩萨拥护般若波罗蜜乃至正忆念不令魔得其便。会中听者闻是事已或作是念。诸佛阿耨陀罗三藐三菩提。寂灭相于诸法及众生无憎无爱。何以故。拥护书持般若乃至正忆念者。是故佛告须菩提。为说譬喻。如子知恩故守护其母。般若是十方诸佛母故。若有魔等留难欲破坏般若波罗蜜者。诸佛虽行寂灭相怜愍众生故。知恩分故。用慈悲心常念。用佛眼常见。守护是行般若者。令得增益不失佛道。此中佛说因缘。诸贤圣及贤圣法。皆从般若中生。问曰。须菩提问四种。佛何以止答三事而不说诸佛从般若中生。答曰。般若生诸佛。诸佛从般若生。义无异。有人言。诸法和合故能生般若波罗蜜。般若波罗蜜能生诸佛。有人行般若波罗蜜及众行得成佛。初谓作者。二谓法。若言堕枝杀人。若言堕树杀人。以是事同故不别答。若说般若波罗蜜能生诸佛。即说诸佛从般若生。问曰。如余经说五众破坏故名世间。此中何以言般若波罗蜜示五众无破坏生灭等。答曰。彼是小乘事。此是大乘事。小乘法多说无常。大乘法中多说法空。小乘法中先说无常后说法空。大乘法中初便说法空。小乘法中说无常。令众生怖畏。大乘则不然。是故说无破坏等。此中佛自说因缘。空无相无作终不破不坏般若波罗蜜。示如是等世间相。复次五众名世间。众生身形色易知。余心数法无形故难知。是故佛语须菩提。无量阿僧祇众生心所行皆知。深般若中虽无众生及色等法乃至一切种智。以般若方便力而能知众生心所行。是般若波罗蜜中毕竟空故。不示色等法乃至一切种智。此中佛说因缘。般若波罗蜜中尚无般若相。何况色等法。复次般若波罗蜜示世间者。一切众生。若色若无色。色者欲色界众生。无色者无色界众生。有想者除无想天及非有想非无想天。余者是有想。无想者是无想众生。非有想非无想者是有顶处天。此间世界者是三千大千世界。遍十方者。余无量无边阿僧祇世界。是世界六道中三世众生佛悉知其摄心乱心。须菩提闻已心疑怪。诸佛常乐行寂灭诸法空。今云何遍知无始无边众生摄心乱心。佛心一众生心无量种。云何一时知一切众生心。以是故问佛云何知。佛答诸法实相智慧故。知众生摄心乱心。须菩提问。何等是诸法实相。答曰所谓毕竟空。是毕竟空毕竟空性亦不可得。何况摄心乱心。问曰。诸法实相毕竟空中无分别心心数法。佛云何知其心。答曰。此中佛自说诸法实相性亦不可得。以是智慧知众生摄心乱心。何以故。若空性可得应有难。空性不可得云何作难。今佛过一切亿想分别虚妄法安住实相。如实知一切众生心。众生心住虚妄法中故。不能知他众生如实。先略说知他心。次分别众生摄心乱心所谓三毒。无三毒者广大无量不可见出没屈申等。须菩提事事问。初答以诸法实相故知摄心乱心。次以尽无染灭断寂离故知尽者无常慧。菩萨行是无常慧心离一切世间染。用世间道遮灭结使是名灭。用无漏道断故名断。断诸结使已观涅槃寂灭离相。以是因缘得诸法实相。以诸法实相知他摄心乱心。皆是实相。复次是心念念生灭。未来无故不可知。现在念念灭。住时无故不可知。凡夫人取相分别。于三世中忆想妄见谓知心念。以尽门观即是毕竟空。毕竟空故无所著。是时得道知诸法实相。于一切法不妄想分别。则如实知他心。染心者一切法入法性中皆清净。是故说染心实相。是中无染心。何以故。如实中无心无心数法。何况染心。嗔心痴心亦如是。无染心相中是中无有染心相。染心从本来无故亦无不染心。无染心是寂灭相无所分别。此中佛自说因缘。须菩提。二心不俱故。众生法心心次第生无染心时则无染心。何以故。过去染心已灭。未来未有。现在无染心。则无有染心。染心无故亦无不染心相。待法无故是故无染实相中无有染心不染心。无嗔心无痴心亦如是。广狭增减心皆是众生取相分别。佛不如是知。何以故。是心无色无形无住处念念灭则无广狭增减差别。此中佛自说因缘。心性相无故广狭等不可得。广狭增减大小义如四无量心中说。无量心者广心大心即是无量。又缘无量众生故名无量。又缘涅槃无量法故名无量。又心相不可取故名无量。如有眼有色因缘故眼识生。是识不在眼不在色不在中间。不在此不在彼。是故无住处。若实无住处。云何能有所作。若好若丑如梦所见。事不可求其实定相。心亦如是。无依止故无定相故名无量。广大亦应如是随义分别说。问曰。若知心不可见。佛何以故说如实知不可见心。答曰。有坐禅人忆想分别见是心。如清净珠中缕观。白骨人中见心次第相续生。或时见心在身或见在缘。如无边识处。但见识无量无边。破如是等虚妄故。佛言如实知众生心。众生心自相空故无相相。复次佛以五眼观此心不可得。肉眼天眼缘色故不见。慧眼缘涅槃故不见。初觉法眼分别知诸法善不善有漏无漏等。是法眼入实相中则无所分别。如先说一切法无知者无见者。是故不应见。佛眼观寂灭相故不应见。众生心见者如实见。不如凡夫人忆想分别见。复次五眼因缘和合生。皆是作法虚诳不实。佛不信不用。是故言不以五眼见

大智度论卷第六十九大智度论释佛母品第四十八之余(卷七十)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】复次须菩提。佛因深般若波罗蜜。众生心数出没屈申如实知。世尊。云何佛因般若波罗蜜。众生心数出没屈申如实知。佛言。一切众生心数出没屈申等。皆依色受想行识生。须菩提。佛于是中知众生心数出没屈申。所谓神及世间常。是事实余妄语。是见依色神及世间无常。是事实余妄语。是见依色神及世间常亦无常。是事实余妄语。是见依色神及世间非常非无常。是事实余妄语。是见依色神及世间常。是事实余妄语。是见依受神及世间无常。是事实余妄语。是见依受神及世间常亦无常。是事实余妄语。是见依受神及世间非常非无常。是事实余妄语。是见依受神及世间常。是事实余妄语。是见依想神及世间无常。是事实余妄语。是见依想神及世间常亦无常。是事实余妄语。是见依想神及世间非常非无常。是事实余妄语。是见依想神及世间常。是事实余妄语。是见依行神及世间无常。是事实余妄语。是见依行神及世间常亦无常。是事实余妄语。是见依行神及世间非常非无常。是事实余妄语。是见依行神及世间常。是事实余妄语。是见依识神及世间无常。是事实余妄语。是见依识神及世间常亦无常。是事实余妄语。是见依识神及世间非常非无常。是事实余妄语。是见依识世间有边。是事实余妄语。是见依色世间无边。是事实余妄语。是见依色世间有边无边。是事实余妄语。是见依色世间非有边非无边。是事实余妄语。是见依色依受想行识。亦如是。神即是身。是见依色神异身异。是见依色依受想行识亦如是。死后有如去。是事实余妄语。是见依色死后无如去是事实余妄语。是见依色死后或有如去或无如去。是事实余妄语。是见依色死后非有如去非无如去。是事实余妄语。是见依色依受想行识亦如是。如是须菩提。佛因般若波罗蜜。众生出没屈申如实知。复次须菩提。佛知色相。云何知色相。如如不坏无分别无相无忆无戏论无得。色相亦如是。须菩提。佛知受想行识相。云何知受想行识相。如如相不坏无分别无相无忆无戏论无得。受想行识相亦如是。如是须菩提。佛知众生如相及众生心数出没屈申如相。五众如相诸行如相。即是一切法如相。何等是一切法如相。所谓六波罗蜜如相。六波罗蜜如相。即是三十七品如相。三十七品如相。即是十八空如相。十八空如相。即是八背舍如相。八背舍如相。即是九次第定如相。九次第定如相。即是佛十力如相。佛十力如相。即是四无所畏四无碍智大慈大悲。乃至十八不共法如相。十八不共法如相。即是一切种智如相。一切种智如相。即是善法不善法世间法出世间法有漏法无漏法如相。无漏法如相。即是过去未来现在法如相。过去未来现在法如相。即是有为法无为法如相。有为法无为法如相。即是须陀洹果如相。须陀洹果如相。即是斯陀含果如相。斯陀含果如相。即是阿那含果如相。阿那含果如相。即是阿罗汉果如相。阿罗汉果如相。即是辟支佛道如相。辟支佛道如相。即是阿耨多罗三藐三菩提如相。阿耨多罗三藐三菩提如相。即是诸佛如相。诸佛如相皆是一如相。不二不别不尽不坏。是名一切诸法如相。佛因般若波罗蜜得是如相。以是因缘故。般若波罗蜜能生诸佛。能示世间相。如是须菩提。佛知一切法如相非不如相不异相。得是如相故佛名如来。须菩提。白佛言。世尊。是诸法如相非不如相不异相甚深。世尊。诸佛用是如。为人说阿耨多罗三藐三菩提。世尊。谁能信解是者。唯有阿鞞跋致菩萨及具足正见人漏尽阿罗汉。何以故。是法甚深故。须菩提。是如无尽相故甚深。须菩提言。何法无尽相故甚深。佛言。一切法无尽故如是。须菩提。佛得是一切诸法如已为众生说

【论】释曰。佛悉知一切众生所作所行六十二邪见等诸邪见九十八结使等诸烦恼。是故说佛知众生心心数法出没屈申。在家者为爱等诸烦恼所没名为没。九十六种邪见。出家者名出。复次常着世乐故名为没或知无常怖畏求道故名出。复次受九十六种道法。不能得正道故还没在世间。屈者不离欲界。申者离欲界色界。离不离亦如是。如人立清池上见鱼。或有常在水中。或有暂出还没。或有出观四方。或有出欲渡者近岸还没。佛亦如是。以佛眼观十方六道众生。有常着五欲诸烦恼覆心不求出者。或有好心能布施能持戒而以邪疑覆心故还没。有人出五欲能得暖法顶法等。观四谛未得实法故还没。有人离五欲乃至无所有处。不得涅槃故还没。何等是出没屈申相。此中佛说所谓神及世间常。神者。凡夫人忆想分别随我心取相故计有神。外道说神有二种。一者常二者无常。若计神常者常修福德后受果报故。或由行道故。神得解脱。若谓神无常者为今世名利故有所作。常无常者。有人谓神。有二种。一者细微常住。二者现有所作。现有所作者。身死时无常。细神是常。有人言神非常非无常。常无常中俱有过。若神无常即无罪福。若常亦无罪福。何以故若常则苦乐不异。譬如虚空雨不能湿风日不能干。若无常则苦乐变异。譬如风雨在牛皮中则烂坏。以我心故说必有神。但非常非无常。佛言四种邪见皆缘五众。但于五众谬计为神。神及世间者。世间有三种。一者五众世间。二者众生世间。三者国土世间。此中说二种世间。五众世间国土世间。众生世间即是神。于世间相中亦有四种邪见。问曰。神从本已来无故应错。世间是有云何同神邪见。答曰。但破于世间起常无常相不破世间。譬如无目人得蛇以为璎珞有目人语是蛇非是璎珞。佛破世间常颠倒不破世间。何以故现见无常故亦不得言无无常。罪福不失故因过去事有所作故常无常二俱有过故非常非无常。着世间过故。世间有边者。有人求世间根本不得其始。不得其始则无中无后。若无初中后则无世间。是故世间应有始始即是边。得禅者宿命智力乃见八万劫事。过是已往不复能知。但见身始中阴识。而自思惟此识不应无因无缘必应有因缘。宿命智所不能知。但忆想分别有法名世性。非五情所知。极微细故于世性中初生觉。觉即是中阴识。从觉生我从我生五种微尘所谓色声香味触。从声微尘生空大。从声触生风大。从色声触生火大。从色声触味生水大。从色声触味香生地大。从空生耳根。从风生身根。从火生眼根。从水生舌根。从地生鼻根。如是等渐渐从细至粗。世性者从世性已来至粗。从粗转细还至世性。譬如泥丸中具有瓶盆等性以泥为瓶破瓶为盆如是转变都无所失。世性亦如是。转变为粗。世性是常法无所从来。如僧佉经广说世性。复次有人说。世间初边名微尘。微尘常法不可破不可烧不可烂不可坏。以微细故但待罪福因缘和合故有身。若天若地狱等。以无父母故罪福因缘尽则散坏有人以自然为世界始贫富贵贱非愿行所得。有人言天主即是世界始。造作吉凶祸福天地万物。此法灭时天还摄取。如是邪因是世界边。有人说众生世世受苦乐尽自到边。譬如山上投缕丸缕尽自止。受罪受福会归于尽。精进懈怠无异。有人说国土世间八方有边。唯上下无边。有人说下至十八地狱上至有顶。上下有边八方无边。如是种种说世界边。有人说众生世间有边。如说神在体中如芥子如米。或言一寸。大人则神大小人则神小。说神是色法有分故言神有边。无边者有人说神遍满虚空无处不有。得身处能觉苦乐。是名神无边。有人言国土世间无始。若有始则无因缘。后亦无穷常受身。是则破涅槃是名无边。复次说国土世间十方无边。如是等说神世间国土世间无边有边者。有人言。神世间无边国土世间有边。或言神世间有边。国土世间无边。如上说神是色故。或言上下有边八方无边。如是总上二法名为有边无边世间。非有边非无边者。有人见世间有边有过无边亦有过故不说有边不说无边。着非有边非无边。以为世间实。神即是身者。有人言身即是神。所以者何。分折此身求神不可得故。复次受好丑苦乐皆是身。是故言身即是神。身异神异者。有人言。神微细五情所不得。亦非凡夫人所见。摄心清净得禅定人乃能得见。是故言身异神异。复次若身即是神。身灭神亦灭。是邪见说身异神异。身灭神常在。是边见。死后有如去者。问曰。先说常无常等。即是后世或有或无。今何以别说如去四句。答曰。上总说一切世间常非常。后世有无事要故别说。如去者如人来此间生。去至后世亦如是。有人言先世无所从来。灭亦无所去。有人言身神和合为人。死后神去身不去。是名如去不如去。非有如去非无如去者。见去不去有失故说非去非不去。是人不能舍神而着非去非不去。如是诸邪见烦恼等是名心出没屈伸。所以者何。邪见者种种道求出不得故欲出而没。邪见力多难解故说常无常等十四事。外道虽复种种忆想分别。佛言皆缘五众依止五众无神无常。佛知五众空无相无作无戏论。但知五众如不如凡夫虚诳颠倒见如。五众如一切法如亦如是。何以故二法摄一切法。所谓有为无为。五众是有为法。五众如即是无为法。观察筹量思惟五众。能行六波罗蜜。是故说五众如即是一切法如。一切法如即是六波罗蜜如。行六波罗蜜菩萨求实道。观五众无常空生三十七品八背舍九次第等。是声闻道。知已直过行十八空十力等诸佛法。皆正观五众。五众如无分别故。皆是一切诸法如。是故说善法如即是不善法如不善法如即是善法如。世间出世间法亦如是。是以行者不得着善法。乃至阿耨多罗三藐三菩提。佛如相亦如是。皆是一如相不二不别。所以者何。求诸法实到毕竟空无复异。如是等诸法如。佛因般若波罗蜜得。是故言般若波罗蜜能生诸佛能示世间相。须菩提。叹未曾有白佛言。世尊。一切诸法如甚深随顺。不相违。三世十方诸佛如即是诸法如。解是诸法如故为众生种种说法。是甚深如难解难信。阿鞞跋致菩萨入法位受记者能信。具足正见人者三道人。漏尽阿罗汉不受一切法故能信。其有信者近阿鞞跋致故皆摄在阿鞞跋致中故。不别说。佛语须菩提。一切法无尽故是如无尽。如无尽故得圣道者能信。无为法中差别故。有须陀洹诸道。闻自所得法故能信。凡夫人着虚诳颠倒法故不能信。佛告须菩提。诸佛得是诸法如故名为如来。名为一切智人。能教众生令至涅槃

    大智度论释问相品第四十九

【经】尔时三千大千世界中。所有欲界天子色界天子。遥散华香来至佛所。顶礼佛足一面住白佛言。世尊。所说般若波罗蜜甚深。何等是深般若波罗蜜相。佛告欲界色界诸天子。诸天子。空相是深般若波罗蜜相。无相无作无起无生无灭无垢无净无所有法无相无依止虚空相。是深般若波罗蜜相。诸天子。如是等相。是深般若波罗蜜相。佛为众生用世间法故说。非第一义。诸天子。是诸相一切世间天人阿修罗不能破坏。何以故。是一切世间天人阿修罗亦是相故诸天子。相不能破相。相不能知相。相不能知无相。无相不能知相。是相是无相相。无相皆无所知。谓知者知法皆不可得故。何以故。诸天子。是诸相非色作。非受想行识作。非檀波罗蜜作。非尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜。禅波罗蜜般若波罗蜜作。非内空作。非外空作。非内外空作。非无法空作。非有法空作。非无法有法空作。非四念处作。乃至非一切种智作。诸天子。是诸相非人所有。非非人所有。非世间非出世间。非有漏非无漏。非有为非无为。佛复告诸天子。譬如有人问何等是虚空相。此人为正问不。诸天子言。世尊。此不正问。何以故。世尊。是虚空无相可说。虚空无为无起故。佛告欲界色界诸天子。有佛无佛相性常住。佛得如实相性故名为如来。诸天子白佛言。世尊。世尊所得诸相性甚深。得是相故。得无碍智住是相中。以般若波罗蜜集诸法自相。诸天子言。希有世尊。是深般若波罗蜜是诸佛常所行处。行是道得阿耨多罗三藐三菩提。得阿耨多罗三藐三菩提已。通达一切法相。若色相若受想行识相。乃至一切种智相。佛言。如是如是。诸天子。恼坏相是色相。佛得是无相。觉者受相。取者想相。起作者行相。了别者识相。佛得是无相。能舍者檀波罗蜜相。无热恼者尸罗波罗蜜相。不变异者羼提波罗蜜相。不可伏者毗梨耶波罗蜜相。摄心者禅波罗蜜相。舍离者般若波罗蜜相。佛得是无相心无所娆恼者。是四禅四无量心四无色定相。佛得是无相。出世间者三十七品相。佛得是无相。苦者无作脱门相。离者空脱门相。寂灭者无相脱门相。佛得是无相。胜者十力相。不恐怖者无所畏相。遍知者四无碍智相。余人无得者。十八不共法相。佛得是无相。愍念众生者大慈大悲相。实者无谬错相。无所取者常舍相。现了知者一切种智相。佛得是无相。如是诸天子。佛得一切诸法无相。以是因缘故。佛名无碍智

【论】问曰。上处处已说空无相无作乃至无起无所有是般若相。今诸天子何以复问何等是般若相。答曰。佛虽处处说般若波罗蜜。或说空等或说有。或说果报或说罪福。不定故是以今问何者定是般若相。复次是般若波罗蜜如幻化。如似可得而无定相可取。唯诸佛能正遍知其相。诸天子虽有利智不能了知故问。复次有人言。是诸天子有后来者不闻故问。佛答诸天子空等是般若波罗蜜相。空相者内外空等诸空。若诸法空者即是无有男女长短好丑等相。是名无相相。若空无相不复生愿。着后世身是名无作相。三解脱门是初入般若波罗蜜相。三乘共有不生不灭不垢不净无所依止虚空等。是般若波罗蜜深相。上三解脱门。中无相无男女等外相无所有。下无相相无一切法相空。虽是一人根有利钝入有深浅故差别说空。无生无灭等论议如先说。佛知天子必有如是念。若般若波罗蜜空无所有如虚空相。云何可说。若说即是有相。诸天子以佛威德大故。不敢致难。是故佛自为说。佛怜愍众生以世谛故说空等诸相。非以第一义谛。若以第一义故应难。以世谛故说则不应难。复次虽说空不以着心取相不示法。若是若非一切法同一相无分别。是故复了了说。所谓无所有如虚空相。无有一法不入此相者。是故说一切世间无能破坏。何以故。一切世间天人阿修罗即是相故。若异法相违则有可破。如水能灭火。火不自灭火。口言如实欲破者竟不能破。何况不实者譬如盲人蹈践珍宝。口言非珍宝竟不能令非珍宝。此中佛更说般若波罗蜜毕竟空无相故。相不能破相。复次有人言。相不能破相者。有法能解散诸法和合。竟无所破无所失。如斧析薪分分解散竟无所失。复次诸法无定相。如树根茎枝叶和合故名为树。树无定相故无所破。如是等名为相不能破相。问曰。色等诸法非觉故可不相知。心数法是知相。云何言不知。答曰。此中以实相故不说如凡夫人虚妄知。是智慧有为法故因缘和合生。虚妄法不能实有所知。是故舍入无余涅槃。若智慧知常无常乃至空寂灭等。上来已广破灭无所有。若如是者云何当有知。以是故相不知相相不能知无相者。内虽有智慧外空故无法可知。外无缘云何智慧生。是故言相不能知无相。譬如刀虽利不能破空无相不能知相者。有人言内智慧无定相。外所缘法有定相。心随缘而生。是故说无相不应知相。譬如无刀虽有物无刀可斫。是相是无相相无相皆不可得者。相不入相。何以故。先有相故相不入无相。何以故。相无入处故。离是相无相更无处可入。复次相所相法不定故。因所相故有相。所以者何。若先有相无所相者。则无相无所因故。若先有所相而无相者。云何有所相。无所因待故。复次相以所相不定。相或时作所相。所相或时是相。是故相不定不实故所相亦无。若所相不定不实故相亦无。是故说是相是无相是相无相不可得如先说。空等诸相是实。何以故。是相非五众所作。非六波罗蜜乃至一切种智所作。是相无为故无法可作。亦无若人若非人能作。人者菩萨诸佛等。非人者诸天等。是相毕竟空故非有漏非无漏非世间非出世间。先虽说无为相但破有为故说无为。无为亦无定相。此中佛欲使是事明了故说譬喻。听者作是念。若无佛则不闻是相。佛于众生最上故应当作是相。是故佛语诸天。有佛无佛此相常住佛能知是相故名为佛。尔时诸天子欢喜复白佛言。世尊。是诸相甚深虽不可取相。而可行能与人无上果报。佛得是相故于一切法得无碍智。若分别诸法有定相。则是有碍智。世尊。住是诸法实相中则通达无碍。能说诸法各各别相。所谓恼坏相是色相。乃至了现知者是一切种智相。佛可其意为分别诸相。凡夫所知诸相各异。佛知皆是空相。空相即是无相。佛得是无相。得者是知无比遍知故名得。是诸法相今转名般若波罗蜜故

【经】尔时佛告须菩提。般若波罗蜜是诸佛母。般若波罗蜜能示世间相。是故佛依止是法住。供养恭敬尊重赞叹是法。何等是法。所谓般若波罗蜜。诸佛依止般若波罗蜜住。恭敬供养尊重赞叹是般若波罗蜜。何以故。是般若波罗蜜出生诸佛。佛知作人。若人正问知作人者。正答无过于佛。何以故。须菩提。佛知作人故。佛所乘来法佛所从来道。得阿耨多罗三藐三菩提。是乘是道佛还恭敬供养尊重赞叹受持守护。须菩提。是名佛知作人。复次须菩提。佛知一切法无作相。作者无所有故。一切法无起形。事不可得故。须菩提。佛因般若波罗蜜。知一切法无作相。亦以是因缘故。佛知作人。复次须菩提。佛因般若波罗蜜。得一切法不生。以无所得故。以是因缘故。般若波罗蜜能生诸佛。亦能示世间相。须菩提言。世尊。若一切法无知者无见者。云何般若波罗蜜能生诸佛。能示世间相。佛告须菩提。如是如是。一切法实无知者无见者。云何无知者无见者。一切法空虚诳不坚固。是故一切法无知者无见者。复次须菩提。一切法云何无知者无见者。一切法无依止无所系。以是故一切法无知者无见者。如是须菩提。般若波罗蜜能生诸佛。能示世间相。不见色故示世间相。不见受想行识故示世间相。乃至不见一切种智故示世间相。如是须菩提。般若波罗蜜能生诸佛。能示世间相。须菩提言。世尊。云何不见色故。般若波罗蜜示世间相。不见受想行识乃至一切种智故。示世间相。佛告须菩提。若不缘色生识。是名不见色相故示。不缘受想行识生识。乃至不缘一切种智生识。是名不见一切种智相故示。如是须菩提。是深般若波罗蜜能生诸佛。能示世间相。复次须菩提。般若波罗蜜云何能生诸佛。能示世间相。须菩提。般若波罗蜜能示世间空。云何示世间空。示五众世间空。示十二入世间空。示十八界世间空。示十二因缘世间空。示我见根本六十二见世间空。示十善道世间空。示四禅四无量心四无色定世间空。示三十七品世间空。示六波罗蜜世间空。示内空世间空。示外空世间空。示内外空世间空。示无法空世间空。示有法空世间空。示无法有法空世间空。示有为性世间空。示无为性世间空。示佛十力世间空。示十八不共法世间空。乃至示一切种智世间空。如是须菩提。般若波罗蜜能生诸佛。能示世间相。复次须菩提。佛因般若波罗蜜示世间空。知世间空。觉世间空。思惟世间空。分别世间空。如是须菩提。般若波罗蜜能生诸佛。能示世间相。复次须菩提。般若波罗蜜示佛世间空。云何示佛世间空。示五众世间空。乃至示一切种智世间空。如是须菩提。般若波罗蜜能生诸佛。能示世间相。复次须菩提。般若波罗蜜示佛世间不可思议。云何示世间不可思议。示五众世间不可思议。乃至示一切种智世间不可思议。复次须菩提。般若波罗蜜示佛世间离。云何示世间离。示五众世间离。乃至示一切种智世间离。如是须菩提。般若波罗蜜示佛世间离。复次须菩提。般若波罗蜜示佛世间寂灭。云何示世间寂灭。示五众世间寂灭。乃至示一切种智世间寂灭。复次须菩提。般若波罗蜜示佛世间毕竟空。云何示世间毕竟空。示五众世间毕竟空。乃至示一切种智世间毕竟空。复次须菩提。般若波罗蜜示佛世间性空。云何示世间性空。示五众世间性空。乃至示一切种智世间性空。复次须菩提。般若波罗蜜示佛世间无法空。示何示世间无法空。示五众世间无法空。乃至示一切种智世间无法空。复次须菩提。般若波罗蜜示佛世间无法有法空。云何示世间无法有法空。示五众世间无法有法空。乃至示一切种智世间无法有法空。复次须菩提。般若波罗蜜示佛世间独空。云何示世间独空。示五众世间独空。乃至示一切种智世间独空。如是须菩提。般若波罗蜜能生诸佛。能示世间相。复次须菩提。是深般若波罗蜜示世间相。所谓不生今世后世相。何以故。诸法无可用生今世后世相故。

【论】释曰。般若波罗蜜是诸佛母。是因缘故诸佛依止般若波罗蜜住。余经中说诸佛依止法以法为师。佛此中告须菩提。法者即是般若波罗蜜。一切不善法中无过邪见。邪见故不识恩分。我自然应尔知恩者。诸世间善法中最上。能与今世好名声。后与上妙果报。是故佛自说知恩报恩中第一。我尚知布施持戒等恩。何况般若波罗蜜。复次诸天子作是念。般若波罗蜜毕竟空无定相故。或有人不贪不贵。是故佛说我为三界尊。尚供养般若波罗蜜。何况余人。复有人生疑。佛于一切世间如虚空无所著。何以故。贪是般若波罗蜜。尊重供养似如贪着。是故佛说我无贪心。但分别知诸法好丑力用多少。知是般若波罗蜜。能断一切戏论。开三乘道能灭众苦等。有无量无边功德。是故赞叹尊重供养。譬如人行安稳道免诸患难常念此道以示于人。佛知作人者。知他作恩。于已余处说。佛不知作人恐人疑。是故说佛知一切法无作相。知一切法无作相故言无作人。不以不知恩分故名不知作人。言知作人不知作人无咎。尔时须菩提以毕竟空难世尊。若一切法毕竟空故无知者无作者。云何般若波罗蜜能生诸佛。能示诸佛世间。佛可其问。此中自说因缘。一切法空虚诳无坚固。须菩提意一切法钝相无见无知。云何般若波罗蜜独能知见。佛意一切法非但无知无见。一切法空不牢固。无知者无见者亦不可得故不应难。复次一切法无所依止。无系故无知者无见者。种种门破诸法令空。或破常行无常入空。或破实入空。或毕竟尽故入空。或一切法远离故入空。如是等入空今以一切法无住处故无依止。无系无依止故亦无生灭。以是故即是空。不系者一切法实相不系出三界。所以者何。三界虚诳故。是以一切法无知者无见者。如是示世间是般若不见色等诸法故。示世间色等法。无依止无系虚诳故不见。此中佛自说不见因缘。所谓不生缘色识。乃至不生缘一切种智识。是名不见色等法。问曰。识可不生。色云何不生。答曰。恼坏相是色。因识故分别知。无识亦无恼坏相。复次一切诸法从因缘和合故生。相无有自性。如有身识触诸缘和合故。知地坚相坚相不离身识。是故诸法皆由和合生无有自性。般若波罗蜜示世间空者。世间名五众。乃至一切种智。菩萨行般若波罗蜜时观是法。若大若小若内若外无不空者。是名般若波罗蜜示世间空。佛示世间空者。或有人疑佛爱着法故。说般若波罗蜜示世间空。非是诸法常实相。是故佛说我非爱法故说。佛知诸法相本末筹量思惟分别。无有法出于空者。我非但读诵。从他闻故说。我以内心觉知思惟分别故说示世间空。此一段说示世间空者。上广说离六十二见等。今但说五众乃至一切种智时。会者谓般若波罗蜜是毕竟空心想取着。是故说不可思议。不可思议者毕竟空亦不可得。毕竟空或名离或名寂灭。离名分散。诸法久后无遗余。又自离其性。知毕竟空已。无心数法无语言故。名寂灭毕竟空等如先说。问曰。云何是独空。答曰。十八空皆因缘相待如内空。因内法故名内空。若无内法则无内空。十八空皆尔。是独空无因无待故名独空。复次独空者如虚空如法性实际涅槃。示世间非今世相非后世相者。有诸外道但说今世不说后世。是人邪见堕断灭中。有人说今世后世言今世神入后世。是人邪见堕常中。般若波罗蜜离二边说中道。虽空而不着空故为说罪福。虽说罪福不生常邪见。亦于空无碍。此中佛自说因缘。此中毕竟空故。云何有今世后世见若断若常

【经】须菩提。白佛言。世尊。是般若波罗蜜为大事故起。世尊。是般若波罗蜜为不可思议事故起。世尊。是般若波罗蜜为不可称事故起。世尊。是般若波罗蜜为无量事故起。世尊。是般若波罗蜜为无等等事故起。佛言。如是如是。须菩提。般若波罗蜜为大事起。为不可思议事起。为不可称事起。为无量事起。为无等等事起。须菩提。云何是般若波罗蜜为大事故起。须菩提。诸佛大事者。所谓救一切众生不舍一切众生。须菩提。云何是般若波罗蜜为不可思议事起。须菩提不可思议事者。所谓诸佛法如来法。自然人法一切智人法。以是故。须菩提。诸佛般若波罗蜜为不可思议事起。须菩提。云何般若波罗蜜为不可称事起。须菩提。一切众生中无有能思惟称佛法如来法自然人法一切智人法。以是故须菩提。般若波罗蜜为不可称事起。须菩提。云何般若波罗蜜为无量事起。须菩提。一切众生中无有能量佛法如来法自然人法一切智人法。以是故。须菩提。般若波罗蜜。为不可量事起。须菩提。云何般若波罗蜜为无等等事起。须菩提。一切众生中无有能与佛等者。何况过。以是故须菩提。般若波罗蜜为无等等事起。须菩提。白佛言。世尊。但佛法如来法自然人法一切智人法。不可思议不可称无有量无等等事起耶。佛告须菩提。如是如是。佛法如来法自然人法一切智人法。不可思议不可称无有量无等等。色亦不可思议不可称无有量无等等。受想行识亦不可思议不可称无有量无等等。乃至一切种智法性法相不可思议不可称无有量无等等。是中心心数法不可得。复次须菩提。色不可思议。是亦不可得。乃至色无等等是亦不可得。受想行识乃至一切种智无等等是亦不可得。须菩提。白佛言。世尊。何因缘色不可思议。乃至无等等是亦不可得。受想行识乃至一切种智无等等是亦不可得。佛告须菩提。色量不可得故。受想行识量不可得故。乃至一切种智量不可得故。须菩提。白佛言。世尊。何因缘色量不可得。乃至一切种智量不可得。佛告须菩提。色不可思议故。乃至色无等等故量不可得。乃至一切种智不可思议故。乃至一切种智无等等故。量不可得。须菩提。于汝意云何。不可思议乃至无等等中。宁可得色受想行识乃至一切种智不。须菩提言。世尊。不可得。以是故须菩提。一切法不可思议。乃至无等等。如是须菩提。诸佛法不可思议不可称无有量无等等。须菩提。是名诸佛法。不可思议乃至无等等。须菩提。是诸佛法不可思议。过思议相故不可称。过称故无有量。过量故无等等。过等等故。须菩提。以是因缘故。一切法亦不可思议相乃至无等等须菩提。不可思议名是义不可思议。不可称名是义不可称。无有量名是义不可量。无等等名是义无等等。须菩提。是诸佛法不可思议乃至无等等。不可思议如虚空不可思议。不可称如虚空不可称。无有量如虚空无有量。无等等。如虚空无等等。须菩提。是亦名诸佛法不可思议乃至无等等。佛法如是无量。一切世间天人阿修罗。无能思议筹量者。说是诸佛法不可思议不可称无有量无等等品时。五百比丘一切法不受故。漏尽心得解脱得阿罗汉。二十比丘尼亦不受一切法故。漏尽得阿罗汉。六万优婆塞三万优婆夷诸法中远尘离垢。诸法中法眼生。二十菩萨摩诃萨得无生法忍。于是贤劫中当受记

【论】释曰。须菩提深解般若相。于诸法中无著无碍心生欢喜。白佛言。世尊般若波罗蜜为大事故起等。大事者破一切众生大苦恼。能与佛无上大法故名为大事。不可思议先已答。不可称者称名智慧。般若定实相甚深极重。智慧轻薄。是故不能称。又般若多智慧少故不能称。又般若利益处广。未成能与世间果报。成已与道果报。又究竟尽知故名称般若波罗蜜。无能称知若常若无常若实若虚若有若无。如是等不可称义应当知。无量事者。有人言称即是量。有人言取相名为量。是般若波罗蜜不可取相故无量。又菩萨以四无量心行般若故名无量。又量名智慧。凡夫智慧二乘智慧菩萨智慧。无能量般若得边者名无量无等等者。无等名涅槃一切有为法无有与涅槃等者。涅槃有三分。声闻涅槃辟支佛涅槃佛涅槃。般若能与大乘涅槃故名无等等。复次一切众生无与佛等故佛名无等。般若波罗蜜利益众生令与佛相似故名无等等。复次诸佛法第一微妙。无能与等无能及者无可为疋。般若波罗蜜能令众生得是心故名无等等。复次无等名诸法实相。诸观诸行无能及者。无戏论无能破坏故名无等。菩萨得是无等能于众生中生慈悲心故名无等等。是名无等等义。须菩提。是声闻人无一切智。而能说是不可思议般若等故佛可其所说。佛自说五事。众生无量无边多。于十方恒河沙等世界中。微尘诸佛以十力等法尽欲救济是名大事。复有菩萨久得无生法忍不舍众生故。不入无余涅槃。复次是菩萨得佛道时。为众生故受五事。一者受诸劳苦。二者舍寂定乐。三者与恶人共事。四者与人接对。五者入大众会。佛深得离欲乐而为众生故。甘受是五事等种种疾苦如受功德。是为大事。不可思议者。所谓佛法如来法自然人法一切智人法。佛法者佛名为觉。于一切无明睡眠中最初觉故名为觉。如来者如过去诸佛行六波罗蜜得诸法如相来至佛道。今佛亦如是道来如诸佛来是名如来。自然人法者。声闻人亦有觉亦有知。而从他闻是弟子法。是故说佛是自然人。不从他闻。一切智人法者。辟支佛亦自然得不从他闻而无一切智。是故说佛一切智人得。是四种法。无有人能思惟称量。是故名不可思议不可称不可量。更无有法与是法相似者。是故名无等等。须菩提意恐新学菩萨着是四法。是故白佛言。但是四法不可思议无有与等耶。佛答色等诸法亦不可思议无称无量无等等。佛是中自说因缘。色等一切法不可得故如是。须菩提诸佛法不可思议者。是如上事。是名不可思议者结句。论者先广解。佛此中略说。不可思议过思议相。过等等相义趣。涅槃法不可思议名字世谛故可思议。如虚空不可思议者。如先品中说。虚空相不可思议。是故说不可思议乃至无等等如虚空。虚空无可喻故名无等等。般若波罗蜜相即是佛法相。不可思议无量无称无等等即是佛法相。是佛法一切世间天人阿修罗无能思议称量者。六道中但说三道者。三善道众生尚不能称量。何况三恶道。问曰。说是品时。何以故比丘尼菩萨得道者少。答曰。此中多赞叹诸佛法。所谓不可思议无称无量无等等。闻者多增益信根故。是故白衣得道者多。女人虽复信多智慧少故得道者亦少。白衣贪着世事智慧浅薄钝根不能尽漏。诸比丘信慧诸根等一心求道故漏尽者多。比丘尼智慧少故二十人得漏尽。虽多得初道数过白衣。不尽漏故不异白衣。此中不说入无生忍法。甚深难得故少。又以于此法种因缘者少。贤劫中当受记者。或有人言贤劫中千佛除四佛当与受记。或有人言释迦文佛与受记。于贤劫中在余世界作佛

大智度论卷第七十大智度论释大事起品第五十(卷七十一)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】尔时须菩提白佛言。世尊。是深般若波罗蜜为大事故起。不可思议事故起。不可称事故起。无有量事故起。世尊。是深般若波罗蜜无等等事故起

佛告须菩提。如是如是。是深般若波罗蜜为大事故起。乃至无等等事故起。何以故。般若波罗蜜中含受五波罗蜜。般若波罗蜜中含受内空乃至无法有法空。含受四念处乃至八圣道分。是深般若波罗蜜中含受佛十力乃至一切种智。譬如灌顶王国土中尊。诸有官事皆委大臣。国王安乐无事。如是须菩提。所有声闻辟支佛法若菩萨法若佛法。一切皆在般若波罗蜜中。般若波罗蜜能成办其事。以是故须菩提。般若波罗蜜为大事故起。乃至无等等事故起。复次须菩提。是般若波罗蜜不取色不着色故能成办。受想行识不取不着故能成办。乃至一切种智不取不着故能成办。须陀洹果乃至阿罗汉果辟支佛道。乃至阿耨多罗三藐三菩提。不取不着故能成办。须菩提白佛言。云何色不取不着故般若波罗蜜能成办。云何受想行识乃至阿耨多罗三藐三菩提不取不着故般若波罗蜜能成办。佛告须菩提。于汝意云何。颇见是色可取可着不。须菩提言。不也世尊。须菩提。于汝意云何。颇见受想行识乃至阿耨多罗三藐三菩提可取可着不。须菩提言。不也。世尊。佛言。善哉善哉。须菩提。我亦不见是色可取可着。不见故不取。不取故不着。我亦不见受想行识乃至阿耨多罗三藐三菩提及一切种智可取可着。不见故不取。不取故不着。须菩提。我亦不见佛法如来法自然人法一切智人法可取可着。不见故不取。不取故不着。以是故须菩提。诸菩萨摩诃萨。色亦不应取。亦不应着。受想行识乃至佛法如来法自然人法一切智人法。亦不应取亦不应着。尔时欲色界诸天子白佛言。世尊。是般若波罗蜜。甚深难见难解不可思惟比类。知微妙善巧智慧寂灭者。可知能信是般若波罗蜜者。当知是菩萨多供养诸佛多种善根。与善知识相随。能信解深般若波罗蜜。世尊。若三千大千世界中所有众生。皆作信行法行人八人得须陀洹斯陀含阿那含阿罗汉辟支佛若智若断。不如是菩萨一日行深般若波罗蜜忍欲思惟筹量。何以故。是信行法行人八人须陀洹斯陀含阿那含阿罗汉辟支佛若智若断。即是菩萨摩诃萨无生法忍。佛告欲色界诸天子。如是如是。诸天子。若信行法行人八人须陀洹乃至阿罗汉辟支佛。即是菩萨摩诃萨无生法忍。诸天子。若善男子善女人。闻是深般若波罗蜜。书持受读诵说正忆念。是善男子善女人疾得涅槃。胜求声闻辟支佛乘。善男子善女人远离深般若波罗蜜行余经。若一劫若减一劫。何以故。是深般若波罗蜜中广说上妙法。是信行法行人八人须陀洹斯陀含阿那含阿罗汉辟支佛所应学。菩萨摩诃萨亦所应学。学已得阿耨多罗三藐三菩提。是时欲色界诸天子俱发声言。世尊。是深般若波罗蜜名摩诃波罗蜜。世尊。是般若波罗蜜名不可思议不可称无有量无等等波罗蜜。信行法行人八人。学是深般若波罗蜜。得成就须陀洹斯陀含阿那含阿罗汉辟支佛。学是深般若波罗蜜。得成菩萨摩诃萨。是深般若波罗蜜中学。得阿耨多罗三藐三菩提。是深般若波罗蜜亦不增亦不减。是时诸欲色界天子顶礼佛足绕佛而去。去是不远忽然不现各还本处。须菩提白佛言。世尊。若菩萨摩诃萨闻是深般若波罗蜜即时信解者。从何处终来生是间。佛告须菩提。若菩萨摩诃萨闻是深般若波罗蜜即时信解。不没不却不难不疑不悔。欢喜乐听。听已忆念。终不远离是深般若波罗蜜。若行若住若坐若卧终不废忘常随法师。譬如新生犊子不离其母。菩萨摩诃萨亦如是。为闻深般若波罗蜜故。终不远离法师。乃至得是深般若波罗蜜。口诵心解正见通达。须菩提。当知是菩萨从人道中终还生是间人中。何以故。是求佛道者前世时闻深般若波罗蜜。书持恭敬尊重赞叹华香乃至幡盖供养。以是因缘故。人中命终还生人中。闻是深般若波罗蜜即时信解。须菩提白佛言。世尊。颇有菩萨摩诃萨。如是功德成就。他方世界供养诸佛。于彼命终来生是间。闻深般若波罗蜜即时信解。书持读诵正忆念有是者不。佛言有。菩萨如是功德成就。他方世界供养诸佛。于彼命终来生是间。闻是深般若波罗蜜即时信解。书持读诵说正忆念。何以故。是菩萨摩诃萨从他方诸佛所。闻是深般若波罗蜜。信解书持读诵说正忆念。于彼间终来生此间。当知是人是先世功德成就

复次须菩提。有菩萨从弥勒菩萨摩诃萨。闻是深般若波罗蜜。以是善根因缘故来生此间。须菩提。复有菩萨摩诃萨。前世时虽闻深般若波罗蜜。不问中事。来生人中闻是深般若波罗蜜。心有疑悔难悟须菩提。如是菩萨当知先世虽闻是深般若波罗蜜。不问故今续生疑悔难悟。须菩提。若菩萨先世虽闻禅波罗蜜。不问中事。今世闻般若波罗蜜时。不问故续生疑悔。须菩提。若菩萨先世虽闻毗梨耶波罗蜜。不问中事。今世闻般若波罗蜜。不问故续复疑悔。须菩提。若菩萨先世闻羼提波罗蜜。不问中事。今世闻般若波罗蜜。不问故续复疑悔。须菩提。若菩萨先世虽闻尸罗波罗蜜。不问中事。今世闻般若波罗蜜。不问故续复疑悔。须菩提。若菩萨先世虽闻檀波罗蜜。不问中事。今世闻般若波罗蜜。不问故续复疑悔。复次须菩提。菩萨摩诃萨先世虽闻内空外空内外空乃至无法有法空。不问中事。来生人中闻是深般若波罗蜜。不问故续复疑悔难悟。复次须菩提。菩萨摩诃萨先世虽闻四念处乃至八圣道分四禅四无量心四无色定五神通佛十力乃至一切种智。不问中事。来生人中闻是深般若波罗蜜。不问故续复疑悔难悟。复次须菩提。菩萨摩诃萨先世闻深般若波罗蜜。不问中事而不行。舍身生时闻是深般若波罗蜜。若一日二日三日四日五日。其心坚固无能坏者。若离所闻时便退失。何以故。先世闻是深般若波罗蜜时。虽问中事不如说行。是人或时欲闻。或时不欲闻。心轻不固志乱不定。譬如轻毛随风东西。须菩提当知。是菩萨发意不久。不与善知识相随。不多供养诸佛。先世不书是深般若波罗蜜。不读不诵不正忆念。不学般若波罗蜜。不学禅波罗蜜。不学毗梨耶波罗蜜。不学羼提波罗蜜。不学尸罗波罗蜜。不学檀波罗蜜。不学内空乃至无法有法空。不学四念处乃至八圣道分。不学四禅四无量心五神通佛十力。乃至不学一切种智。如是须菩提。当知是菩萨摩诃萨新发大乘意。少信少乐故。不能书是深般若波罗蜜。不能受持读诵说正忆念。须菩提。若求佛道善男子善女人。不书是深般若波罗蜜。不受持读诵不说不正忆念。亦不为深般若波罗蜜所护。乃至不为一切种智所护。是人亦不如说行深般若波罗蜜。乃至不如说行一切种智。是人或堕二地。若声闻地若辟支佛地。何以故。是善男子善女人。不书是深般若波罗蜜。不读不诵不说不正忆念。是人亦不为深般若波罗蜜所护。亦不如说行。以是故。是善男子善女人于二地中当堕一地

【论】问曰。上来数说是般若波罗蜜甚深因缘。今何以复重说。答曰。处处说甚深。多有所益。凡人不知谓为重说。譬如大国王。未有嫡子求祷神祇积年无应。时王出行夫人产子男。遣信告王。大夫人产男。王闻喜而不答乃至十反。使者白王。向所白者王不闻耶。王曰。我即闻之。久来愿满故。喜心内悦乐闻不已耳。即敕有司赐此人百万两金。一语十万两。王闻使者言语。语中有利益非重语。不知者谓为重。处处说甚深亦如是。佛与菩萨须菩提知大有利益。须菩提闻佛说深般若不能得底转觉甚深。听者处处闻甚深。得禅定智慧利益等。凡夫人谓为重说。复次深浅无定随众生。解者无深不解者谓为深。般若波罗蜜除佛无能遍知。故常言甚深。是故佛为众生故说甚深。无定甚深相。若定甚深无人能行。是故言菩萨谓般若甚深。为不行般若波罗蜜甚深因缘。所谓为大事故起。乃至无等等事故起。大事等义如先说。此中佛自说大事等因缘。所谓般若波罗蜜含受五波罗蜜等诸法。问曰。五波罗蜜等各异相。云何言般若波罗蜜中含受。答曰。是中说经中含受。复次五波罗蜜等诸法。与般若波罗蜜和合方便回向故。五波罗蜜等诸法得至佛道。灌顶王如佛。国事是种种度众生法。大臣是般若波罗蜜。佛委仗般若波罗蜜成办种种法。故安处禅定快乐无事。又如欲除干薪草木。以火投中则火力能烧令尽人便无事。复次是般若波罗蜜不取不着色等诸法故名含受。初染曰取。生爱曰着。须菩提问。云何般若为色等诸法不取不着故名含受。佛于四答中以反问答。于汝意云何。以智慧眼见是色等法可取可着不。须菩提意念。若智慧眼见空无相无作无量不可思议相。云何当答色等法定相可取可着。佛可其所说。汝未得一切智。不见色等诸法。我一切智人亦不见色等诸法。是故叹言善哉。是时诸天子赞叹般若波罗蜜及行般若波罗蜜者作是言。若三千大千世界中众生。皆作信行法行。乃至辟支佛若智若断。智者十智。断者二种断。有残断无残断。学人有残断。无学人无残断。不如是菩萨一日行深般若波罗蜜。何以故。是诸贤圣智断。皆是菩萨无生法忍。问曰。若诸贤圣智断即是无生忍者。何以言不如。答曰。信行等人无大悲舍众生故不如。无方便力不能于涅槃自反。譬如众水会恒河俱入大海。欲入海时水势凑急众生在中无能自反。惟有大力者乃能自出。复次诸余贤圣智断成就。菩萨始得无生忍而力能过之。是故胜智断功德虽成就。不及菩萨初忍。譬如大臣功业虽大不及太子。复次暖顶忍法是小乘初门。菩萨法忍是大乘初门。声闻辟支佛虽终成。尚不及菩萨初入道门。何况成佛。问曰。声闻辟支佛法是小乘。菩萨是大乘。云何言二乘智断即是菩萨无生忍。答曰。所缘同如法性实际亦同。利钝智慧为异。又有无量功德及大悲心守护。故胜余种种说。是赞般若波罗蜜行般若波罗蜜人有上中下。下者闻般若波罗蜜直信听受不问中义。中者既闻已问义而不能行。上者闻解能行。下者虽得人身闻般若疑悔难悟。根钝福薄故。中者得人身闻般若。一心信乐能知义趣。从一日至四五日心能坚固。过是已往不能信乐。或欲闻或不欲闻。以其宿世虽解义而不能行。根钝福薄故。上者得人身闻般若。心即深解信乐不舍常随法师。上二种菩萨不能得上地故当堕二乘。不为般若所守护故。为更明了是事故。佛于后品中为作譬喻。如大海水中船破。若得所依则能渡。不得所依则不能渡

    大智度论释譬喻品第五十一

【经】佛告须菩提。譬如大海中船破坏。其中人若不取木不取器物不取浮囊不取死尸。须菩提。当知是人不到彼岸没海中死。须菩提。若船破时其中人取木取器物浮囊死尸者。当知是人终不没死。安隐无碍得到彼岸。须菩提。求佛道善男子善女人亦复如是。若但有信乐不依深般若波罗蜜。不书不读不诵不正忆念。不依禅波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀波罗蜜。不书不读不诵不正忆念。乃至不依一切种智。不书不读不诵不正忆念。须菩提当知。是善男子中道衰耗。是人未到一切种智。于声闻辟支佛地取证。须菩提。若有求佛道善男子善女人。为阿耨多罗三藐三菩提故。有信有忍有净心有深心有欲有解有舍有精进。是人依深般若波罗蜜。书持读诵说正忆念。是善男子善女人为阿耨多罗三藐三菩提故。有诸信忍净心深心欲解舍精进。为深般若波罗蜜所护。乃至一切种智所护故。终不中道衰耗。过声闻辟支佛地。能净佛世界成就众生。当得阿耨多罗三藐三菩提。须菩提。譬如男子女人持坏瓶取水。当知是瓶不久烂坏。何以故。是瓶未熟故还归于地。如是须菩提。善男子善女人。虽有为阿耨多罗三藐三菩提心。有信有忍有净心有深心有欲有解有舍有精进。不为般若波罗蜜方便力所守护。不为禅波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀波罗蜜所守护。不为内空乃至无法有法空四念处乃至八圣道分佛十力乃至一切种智所守护。须菩提当知。是人中道衰耗。堕声闻辟支佛地。须菩提。譬如男子女人持熟瓶取水。若河若井若池若泉。当知是瓶持水安隐。何以故。是瓶成熟故。如是须菩提。善男子善女人。求阿耨多罗三藐三菩提。有诸信忍净心深心欲解舍精进。为般若波罗蜜方便力所护。为禅定精进忍戒施乃至一切种智所护故。须菩提当知。是人不中道衰耗。过声闻辟支佛地。能净世界成就众生。得阿耨多罗三藐三菩提。须菩提。譬如大海边船未庄治便持财物着上。须菩提当知。是船中道坏没。船与财物各在一处。是估客无方便力故亡其重宝。如是须菩提。是求佛道善男子善女人。虽有为阿耨多罗三藐三菩提。心有信忍净心深心欲解舍精进。不为般若波罗蜜方便力所守护。乃至不为一切种智所守护故。当知是人中道衰耗失大珍宝。大珍宝者所谓一切种智。衰耗者堕声闻辟支佛地。须菩提。譬如人有智方便庄治海边大船。然后推着水中持财物着上而去。当知是船不中道没坏。必得安隐到所至处。如是须菩提。善男子善女人。为阿耨多罗三藐三菩提。有信忍净心深心欲解舍精进。为般若波罗蜜方便力所护。为禅精进忍持戒施乃至一切种智所护故。当知是菩萨得到阿耨多罗三藐三菩提。不中道堕声闻辟支佛地。须菩提。譬如有人年百二十岁年耆根熟。又有风冷热病若杂病。须菩提。于汝意云何。是人能从床起不。须菩提言。不能。佛言。是人或能起者云何。须菩提言。是人虽能起不能远行若十里若二十里。以其老病故。如是须菩提。善男子善女人虽有为阿耨多罗三藐三菩提心。有信忍净心深心欲解舍精进。不为般若波罗蜜方便力所守护。乃至不为一切种智所守护故。当知是人中道堕声闻辟支佛地。何以故。不为般若波罗蜜方便力所守护故。须菩提。如向老人。百二十岁年耆根熟。又有风冷热病若杂病。是人欲起行。有两健人各扶一腋。语老人言。莫有所难随所欲至。我等二人终不相舍。如是须菩提。若善男子善女人。为阿耨多罗三藐三菩提。有信忍净心深心欲解舍精进。为般若波罗蜜方便力所护。乃至为一切种智所护。当知是人不中道堕声闻辟支佛地。能到是处。所谓阿耨多罗三藐三菩提

【论】释曰。菩萨有二种。一者得诸法实相。二者虽未得实相。于佛道中有信有忍有净心有深心有欲有解有舍有精进。信者信罪福业因缘果报。信行六波罗蜜。得阿耨多罗三藐三菩提。有人虽信佛道思惟筹量心不能忍。是故说有忍。有人虽忍邪疑未断故心浊不净。是故说有净。有人虽信忍心净而有浅有深。是故说深心。四事因缘故一心欲得无上道不欲余事。是故说有欲。了了决定知无上道为大。世间余事为小。是故说有解。以欲解定心故。舍财及舍诸恶心悭恚等烦恼。是故说舍。为舍故常能精进。有如是等诸功德。若不得般若波罗蜜。若身坏命终时。若恶知识沮坏则失菩萨道。世间功德故受世间果报。然后堕声闻辟支佛地。不能至无上道。此中佛自说五譬喻。船是行者身。浮囊等物即是般若方便。瓶是菩萨道。般若方便是火。未与般若方便和合。故不能受持六波罗蜜功德水至无上道。不补治船。是菩萨无方便。信等功德宝物。是五波罗蜜等诸善法船。宝异处者与本愿乖异。或受人天乐。或堕二乘。大利者所谓一切智等佛法宝。老病人是有信等功德菩萨。不断六十二邪见故名老。不断百八等诸烦恼故名病。从床起者从三界床起我当作佛。以邪见烦恼因缘故不能成菩萨道。二人者般若及方便。般若波罗蜜能灭诸邪见烦恼戏论。将至毕竟空中。方便将出毕竟空

【经】尔时佛语须菩提言。善哉善哉。须菩提。汝为诸菩萨摩诃萨问佛是事。须菩提。若有求佛道善男子善女人。从初发意已来以我我所心。布施持戒忍辱精进禅定智慧。是善男子善女人布施时作是念。我是施主我施是人我施是物。我持戒我修忍我精进我入禅我修智慧。是善男子善女人念有是施是我施。乃至念有是慧是我慧。何以故。檀波罗蜜中无如是分别。远离此彼岸是檀波罗蜜相。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜中无如是分别。何以故。远离此彼岸。是般若波罗蜜相。是人不知此岸不知彼岸。是人不为檀波罗蜜。乃至不为一切种智所护故。堕声闻辟支佛地。不能到萨婆若。须菩提。云何求佛道人无方便。须菩提。求佛道人从初发心已来无方便。行布施持戒忍辱精进禅定修智慧。是人作如是念。我布施施是人以是物施。我持戒修忍辱勤精进入禅定修智慧。如是修智慧。是人念有是施是我施。以是施自高。念有是戒是我戒。以是戒自高。念有是忍是我忍。以是忍自高。念有是精进是我精进。以是精进自高。念有是禅定是我禅。以是禅定自高。念有是慧是我慧。以是慧自高。何以故。檀波罗蜜中无如是分别。远离此彼岸。是檀波罗蜜相。远离此彼岸。是尸罗波罗蜜相。远离此彼岸。是羼提波罗蜜相。远离此彼岸是毗梨耶波罗蜜相。远离此彼岸是禅波罗蜜相。远离此彼岸。是般若波罗蜜相。何以故。般若波罗蜜中无如是忆念分别。是求佛道善男子善女人。不知此岸不知彼岸。是人不为檀波罗蜜所护。不为尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜所护故。乃至不为一切种智所护故。或堕声闻道中。或堕辟支佛道中。不能得到萨婆若。如是须菩提。菩萨摩诃萨不为般若波罗蜜方便力所守护故。或堕声闻地。或堕辟支佛道中。须菩提。云何菩萨摩诃萨。为般若波罗蜜方便力所守护故。不堕声闻辟支佛道中。疾得阿耨多罗三藐三菩提。须菩提。菩萨从初已来以方便力布施无我我所心。布施乃至无我我所心修智慧。是人不作是念。我有是施是我施。不以是施自高。乃至般若波罗蜜亦如是。是菩萨不念我布施。不念我施是人用是物施。不念我持戒有是戒。不念我忍辱有是忍辱。不念我精进有是精进。不念我禅定有是禅定。不念我修智慧有是智慧。何以故。是檀波罗蜜中无如是分别。远离此彼岸。是檀波罗蜜相。远离此彼岸是尸罗波罗蜜相。远离此彼岸。是羼提波罗蜜相。远离此彼岸。是毗梨耶波罗蜜相。远离此彼岸。是禅波罗蜜相。远离此彼岸。是般若波罗蜜相。何以故。是般若波罗蜜中无如是忆想分别。是菩萨摩诃萨知此岸知彼岸。是人为檀波罗蜜所护。为尸罗波罗蜜所护。为羼提波罗蜜所护。为毗梨耶波罗蜜所护。为禅波罗蜜所护。为般若波罗蜜所护乃至为一切种智所护故。不堕声闻辟支佛地。得到萨婆若。如是须菩提。菩萨摩诃萨为般若波罗蜜方便力所护故。不堕声闻辟支佛地。疾得阿耨多罗三藐三菩提

【论】释曰尔时佛可须菩提意。更说失行因缘。菩萨虽行信等善法。亦不得无上道。所谓以我我所心行六波罗蜜故。是中无分别此岸彼岸。以远离相是般若波罗蜜。而分别着行是为失。上佛虽说无方便义。不说无方便名。欲令是事明了故命须菩提。云何有方便无方便。内无我我所心。外观一切法空不取相。般若方便乃至一切种智守护菩萨故名有方便。守护者五波罗蜜边得功德力。般若波罗蜜边得智慧力。以二因缘故不失道

    大智度论释善知识品第五十二

【经】尔时须菩提白佛言。世尊。新学菩萨摩诃萨。云何应学般若波罗蜜禅波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀波罗蜜

佛告须菩提。新学菩萨摩诃萨。若欲学般若波罗蜜禅精进忍戒檀波罗蜜。先当亲近供养善知识能说是深般若波罗蜜者。是人作是教。汝善男子。所有布施一切回向阿耨多罗三藐三菩提。善男子。所有持戒忍辱精进禅定智慧。一切回向阿耨多罗三藐三菩提。汝莫以色。是阿耨多罗三藐三菩提。莫以受想行识。是阿耨多罗三藐三菩提。莫以檀波罗蜜。是阿耨多罗三藐三菩提。莫以尸罗波罗蜜。羼提波罗蜜。毗梨耶波罗蜜。禅波罗蜜。般若波罗蜜。是阿耨多罗三藐三菩提。莫以内空乃至无法有法空。是阿耨多罗三藐三菩提。莫以四念处四正勤四如意足五根五力七觉分八圣道分。是阿耨多罗三藐三菩提。莫以四禅四无量心四无色定五神通。是阿耨多罗三藐三菩提莫以佛十力乃至十八不共法。是阿耨多罗三藐三菩提。所以者何。不取色。便得阿耨多罗三藐三菩提。不取受想行识。便得阿耨多罗三藐三菩提。不取檀波罗蜜乃至般若波罗蜜。便得阿耨多罗三藐三菩提。不取内空乃至无法有法空不取四念处乃至十八不共法。便得阿耨多罗三藐三菩提。善男子。行是深般若波罗蜜时莫贪色。何以故。善男子。是色非可贪者。莫贪受想行识。何以故。受想行识非可贪者。善男子。莫贪檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。莫贪内空乃至无法有法空。莫贪四念处乃至八圣道分。莫贪四禅四无量心四无色定五神通。莫贪佛十力乃至一切种智。何以故。一切种智非可贪者。善男子。莫贪须陀洹果乃至阿罗汉果。莫贪辟支佛道。莫贪菩萨法位。莫贪阿耨多罗三藐三菩提。何以故。阿耨多罗三藐三菩提非可贪者。所以者何。诸法性空故

【论】问曰。须菩提问新学所行。佛何以乃答菩萨久行微妙事。所谓不取一切法。一切法性空故。答曰。诸法性空有二种。一者大菩萨所得。二者小菩萨所学。柔顺忍以智慧发心。此中但说小菩萨所学空。复次有实智慧气分。佛数为菩萨。若无者虽久行余功德不数为菩萨。譬如佛说声闻法中顶法相。于三宝中有少信是名顶法。是信过暖法。修禅定生以色界心。得于佛无碍解脱是为小。于凡夫为大。如是新发意菩萨得般若波罗蜜气味。故能受化名为新学。过五波罗蜜功德。于凡夫为大。于佛为小。复次佛不直说诸法性空。先教供养亲近善知识。善知识为说五波罗蜜功德。善知识虽种种教化。佛但称其不坏法。所谓于色等诸法不贪不着不取。譬如金翅鸟子始生从一须弥至一须弥。菩萨亦如是。初学能生如是深智。何况久学。又如小火能烧。何况大者。菩萨亦如是。新学时能以般若转世间法。令毕竟空烧诸烦恼。何况得力具足

【经】须菩提白佛言。世尊。诸菩萨摩诃萨能为难事。于一切性空法中。求阿耨多罗三藐三菩提。欲得阿耨多罗三藐三菩提。佛言。如是如是。须菩提。菩萨摩诃萨能为难事。于一切性空法中。求阿耨多罗三藐三菩提。欲得阿耨多罗三藐三菩提。须菩提。诸菩萨摩诃萨为安隐世间故。发阿耨多罗三藐三菩提心。为安乐世间故。为救世间故。为世间归故。为世间依处故。为世间洲故为世间将导故。为世间究竟道故。为世间趣故。发阿耨多罗三藐三菩提心。须菩提。云何菩萨摩诃萨为安隐世间故发阿耨多罗三藐三菩提心。须菩提。菩萨摩诃萨得阿耨多罗三藐三菩提时。拔出六道众生。着无畏岸涅槃处。须菩提。是为菩萨摩诃萨为安隐世间故。发阿耨多罗三藐三菩提心。云何菩萨摩诃萨为安乐世间故。发阿耨多罗三藐三菩提心。须菩提。菩萨摩诃萨得阿耨多罗三藐三菩提时。拔出众生种种忧苦愁恼。着无畏岸涅槃处。须菩提。是为菩萨摩诃萨为安乐世间故发阿耨多罗三藐三菩提心。云何菩萨摩诃萨为救世间故发阿耨多罗三藐三菩提心。须菩提。菩萨摩诃萨得阿耨多罗三藐三菩提时。救众生生死中种种苦。亦为断是苦故而为说法。众生闻法渐以三乘而得度脱。须菩提。是为菩萨摩诃萨为救世间故发阿耨多罗三藐三菩提心。云何菩萨摩诃萨为世间归故发阿耨多罗三藐三菩提心。须菩提。菩萨摩诃萨得阿耨多罗三藐三菩提时。拔出众生生老病死相忧悲愁恼法。着无畏岸涅槃处。须菩提。是为菩萨摩诃萨为世间归故。发阿耨多罗三藐三菩提心。云何菩萨摩诃萨为世间依处故发阿耨多罗三藐三菩提心。须菩提。菩萨摩诃萨得阿耨多罗三藐三菩提时。为众生说一切法无依处。须菩提。是为菩萨摩诃萨为世间依处故发阿耨多罗三藐三菩提心。须菩提白佛言。世尊。云何一切法无依处。佛言。色不相续即是色无生。色无生即是色不灭。色不灭即是色无依处。受想行识乃至一切种智亦如是。须菩提。是为菩萨摩诃萨为世间依处故发阿耨多罗三藐三菩提心。云何菩萨摩诃萨为世间究竟道故。发阿耨多罗三藐三菩提心。须菩提。若菩萨摩诃萨得阿耨多罗三藐三菩提时。为众生说如是法。色究竟相非是色。受想行识乃至一切种智究竟相非是一切种智。须菩提。如究竟相一切法相亦如是。须菩提言。世尊。若一切法如究竟相者。诸菩萨摩诃萨皆应得阿耨多罗三藐三菩提。何以故。世尊。色究竟相中无有分别。受想行识究竟相中无有分别。乃至一切种智究竟相中无有分别。所谓是色是受想行识。乃至是一切种智。佛告须菩提。如是如是。色究竟相中无有分别。受想行识乃至一切种智究竟相中无有分别。所谓是色乃至是一切种智。须菩提是为菩萨摩诃萨难事。如是观诸法寂灭相。而心不没不却。何以故。是菩萨摩诃萨作是念。是诸深法我应如是知得阿耨多罗三藐三菩提。如是寂灭微妙法当为众生说。是为菩萨摩诃萨为世间究竟道故发阿耨多罗三藐三菩提心。云何菩萨摩诃萨为世间洲故发阿耨多罗三藐三菩提心。须菩提。若江河大海四边水断是名为洲。须菩提。色亦如是。前后际断。受想行识前后际断。乃至一切种智前后际断。以是前后际断故。一切法亦断。须菩提。是一切法前后际断故。即是寂灭即是妙宝。所谓空无所得。爱尽无余离欲涅槃。须菩提。菩萨摩诃萨得阿耨多罗三藐三菩提时。以寂灭微妙法为众生说。须菩提。是为菩萨摩诃萨为世间洲故发阿耨多罗三藐三菩提心。云何菩萨摩诃萨为世间将导。故发阿耨多罗三藐三菩提心。须菩提。菩萨摩诃萨得阿耨多罗三藐三菩提时。为众生说色不生不灭不垢不净。说受想行识不生不灭不垢不净。说十二处十八界四念处乃至八圣道分四禅四无量心四无色定五神通不生不灭不垢不净。说须陀洹果乃至阿罗汉果辟支佛道不生不灭不垢不净。说佛十力乃至一切种智不生不灭不垢不净。须菩提。是为菩萨摩诃萨为世间将导故发阿耨多罗三藐三菩提心

【论】释曰。须菩提发希有心白佛言。诸菩萨未断烦恼大悲未具未得阿鞞跋致知诸法本性空而能发无上道心是事甚难。佛可其言如是更赞菩萨希有因缘。所谓菩萨安稳世间故发心。安稳者能破一切烦恼究竟不变失。譬如良药能破病不问甘苦以能究竟除病安稳故。佛能使众生常安稳。不期一世二世世间乐者。有法虽安稳而不乐。有法今世苦后世乐。如服苦药腹中安稳口中不美。是故说佛能与今世后世乐。六道无常相故非安稳。是故说出六道名安稳。世间乐着因缘故。久后必生忧恼不名为乐。涅槃乐始终无变故。说离忧苦为乐。救世间者如人为怨贼所逐若亲戚若官力能救。众生亦如是。恶罪诸烦恼因缘及魔民所逐。惟诸佛能说法救护。世间归者如人遇暴风疾雨必归房舍。世间种种邪见烦恼等。身心内外苦恼老病死诸忧苦等。若归佛佛以种种因缘拔其忧悲苦恼。依处者一切有为法。从和合因缘生。故无有自力不可依止。众生为苦所逼来依止佛。佛为说无依止法。无依止法者是真实。所谓无余涅槃。色等五众灭更不相续。不相续即是不生不灭。不生不灭即是毕竟空无依止处。问曰。若无依止处何以说依止。答曰。依止有二种。一者以爱见等诸烦恼依止有为法。二者清净智慧说依止涅槃。烦恼见故说无依止。究竟道者所谓诸法实相毕竟空。色等法前际中无后际中亦无现在中。凡夫人忆想分别业果报诸情力故有颠倒见。圣人以智慧眼观之皆虚诳不实。如前后中亦尔。若无先后云何有中。能如是为众生说法。则安处众生于究竟第一道中。世间洲者如洲四边无地。色等法亦如是。前后皆不可得。中间如究竟道中破。入前后空故。中间亦空。水者三漏。四流诸烦恼及业果报中一切法毕竟空无所取。所谓涅槃是为洲。众生没在四流水中。佛以八正道船。引着涅槃洲上。如是种种因缘接度众生名为将导

【经】云何菩萨摩诃萨为世间趣故发阿耨多罗三藐三菩提心。须菩提。菩萨摩诃萨得阿耨多罗三藐三菩提时为众生说色趣空。说受想行识趣空。乃至说一切种智趣空。为众生说色非趣非不趣。何以故。是色空相非趣非不趣。说受想行识非趣非不趣。何以故。是受想行识空相非趣非不趣。乃至一切种智非趣非不趣。何以故。是一切种智空相非趣非不趣。如是须菩提。菩萨摩诃萨为世间趣故发阿耨多罗三藐三菩提心。何以故。一切法趣空是趣不过。何以故。空中趣非趣不可得故。须菩提。一切法趣无相是趣不过。何以故。无相中趣非趣不可得故。须菩提。一切法趣无作是趣不过。何以故。无作中趣非趣不可得故。须菩提。一切法趣无起是趣不过。何以故。无起中趣非趣不可得故。须菩提。一切法趣无所有不生不灭不垢不净是趣不过。何以故。无所有不生不灭不垢不净中趣非趣不可得故。须菩提。一切法趣梦是趣不过。何以故。梦中趣非趣不可得故。须菩提。一切法趣幻趣向趣影趣化趣是趣不过。何以故。是化等中趣非趣不可得故。须菩提。一切法趣无量无边是趣不过。何以故。无量无边中趣非趣不可得故。须菩提。一切法趣不与不取是趣不过。何以故。不与不取中趣非趣不可得故。须菩提。一切法趣不举不下是趣不过。何以故。不举不下中趣非趣不可得故。须菩提。一切法趣不增不减是趣不过。何以故。无增无减中趣非趣不可得故。须菩提。一切法趣不来不去是趣不过。何以故。不来不去中趣非趣不可得故。须菩提。一切法趣不入不出不合不散不着不断是趣不过。何以故。不着不断中趣非趣不可得故。须菩提。一切法趣我众生寿命人起使起作使作知者见者是趣不过。何以故。我乃至知者见者毕竟不可得。何况当有趣非趣。须菩提。一切法趣有常是趣不过。何以故。常毕竟不可得。云何当有趣非趣。须菩提。一切法趣乐净我是趣不过。何以故。乐净我毕竟不可得。云何当有趣非趣。须菩提。一切法趣无常苦不净无我是趣不过。何以故。无常苦不净无我毕竟不可得。云何当有趣非趣。须菩提。一切法趣欲事是趣不过。何以故。欲事毕竟不可得。何况当有趣非趣。须菩提。一切法趣嗔事痴事见事是趣不过。何以故。嗔事痴事见事毕竟不可得。何况当有趣非趣。须菩提。一切法趣如是趣不过。何以故。如中无来无去故。须菩提。一切法趣法性实际不可思议性是趣不过。何以故。法性实际不可思议性中无来无去故。须菩提。一切法趣平等是趣不过。何以故。平等中趣非趣不可得故。须菩提。一切法趣不动相是趣不过。何以故。不动相中趣非趣不可得故。须菩提。一切法趣色是趣不过。何以故。色毕竟不可得。云何当有趣非趣。须菩提。一切法趣受想行识是趣不过。何以故。受想行识毕竟不可得。云何当有趣非趣。十二处十八界亦如是。须菩提。一切法趣檀波罗蜜是趣不过。何以故。檀毕竟不可得故。云何当有趣非趣。须菩提。一切法趣尸罗波罗蜜是趣不过。何以故。尸罗毕竟不可得故。云何当有趣非趣。须菩提。一切法趣羼提波罗蜜是趣不过。何以故。羼提毕竟不可得故。云何当有趣非趣。须菩提。一切法趣毗梨耶波罗蜜是趣不过。何以故。毗梨耶毕竟不可得故。云何当有趣非趣。须菩提。一切法趣禅波罗蜜是趣不过。何以故。禅毕竟不可得故。云何当有趣非趣。须菩提。一切法趣般若波罗蜜是趣不过。何以故。般若毕竟不可得故。云何当有趣非趣。须菩提。一切法趣内空是趣不过。何以故。内空毕竟。不可得故。云何当有趣非趣。须菩提。一切法趣外空是趣不过。何以故。外空毕竟不可得故。云何当有趣非趣。须菩提。一切法趣内外空是趣不过。何以故。内外空毕竟不可得故。云何当有趣非趣。乃至一切法趣无法有法空是趣不过。何以故。无法有法空毕竟不可得故。云何当有趣非趣。须菩提。一切法趣四念处乃至八圣道分是趣不过。何以故。四念处乃至八圣道分毕竟不可得故。云何当有趣非趣须菩提。一切法趣佛十力乃至一切种智是趣不过。何以故。一切种智中趣非趣不可得故。须菩提。一切法趣须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道是趣不过。何以故。须陀洹果乃至辟支佛道中趣非趣不可得故。须菩提。一切法趣阿耨多罗三藐三菩提是趣不过。何以故。阿耨多罗三藐三菩提中趣非趣不可得故。须菩提。一切法趣须陀洹乃至佛是趣不过。何以故。须陀洹乃至佛中趣非趣不可得故。须菩提白佛言。世尊。是深般若波罗蜜谁能信解者。佛告须菩提。有菩萨摩诃萨。先于诸佛所久行六波罗蜜。善根纯熟。供养无数百千万亿诸佛。与善知识相随。是辈人能信解深般若波罗蜜。须菩提白佛言。世尊。能信解是深般若波罗蜜者。有何等性何等相何等貌。佛言。欲嗔痴断离是性相貌。是菩萨摩诃萨则能信解深般若波罗蜜

【论】问曰。上诸事中略说。今趣中何以广说。答曰。趣是总上九事之会归。是故多说。复次安乐等及趣皆同一义。俱出众生着涅槃故。若事事广说则不可尽。趣最在后故广说。当知余者亦皆应广说。色等法趣空者。如虚空但有名而无法。色等法亦尔终归于空。诸法究竟相必空故余者皆虚妄。如人初虽有善言久久乃知情实。色等诸法亦如是。入无余涅槃时。与虚空无异。当知先亦如是。但凡夫颠倒果报故见异。一切法无有过出空等诸相。如人欲出过虚空不可得。我等十六名皆因五众和合。假有此名无有实法。云何当有趣非趣。若常净乐我等四颠倒破四圣行。如常等四法不可得。以颠倒故色等诸法亦如是。如常等不可得。无常等从常等出故亦不可得。是故说一切法趣常等趣无常等。须菩提问佛是法甚深微细谁当信解者。佛答说久行等因缘能信。更问久行等人有何等相。佛答是人离三毒心亦不见是离。深入诸法实相故。问曰。是人未得无生忍法。云何言断三毒。答曰。断有二种。一者根本断。二者薄少断。此中说薄少断行者不分别是断是烦恼。何以故。烦恼相颠倒不定故。烦恼即是断。是故言离

    大智度论释趣一切智品第五十三

【经】须菩提白佛言。世尊。是诸菩萨摩诃萨解深般若波罗蜜者。当趣何所。佛告须菩提。是菩萨摩诃萨解深般若波罗蜜者。当趣一切种智。须菩提白佛言。世尊。是菩萨摩诃萨能趣一切种智者。则为一切众生所归趣。修般若波罗蜜故。世尊。修般若波罗蜜即是修一切诸法。世尊。无所修是修般若波罗蜜。不受修坏修是修般若波罗蜜。佛告须菩提。何等法坏故。般若波罗蜜为坏修。世尊。色坏故。般若波罗蜜为坏修。受想行识十二处十八界坏故。般若波罗蜜为坏修。我乃至知者见者坏故。般若波罗蜜为坏修。世尊。檀波罗蜜坏故。般若波罗蜜为坏修。乃至般若波罗蜜坏故。般若波罗蜜为坏修。内空乃至无法有法空。四念处乃至十八不共法。须陀洹果乃至一切种智坏故。般若波罗蜜为坏修。佛言。如是如是。须菩提。色坏故。般若波罗蜜为坏修。乃至一切种智坏故。般若波罗蜜为坏修。尔时佛告须菩提。是深般若波罗蜜中。阿鞞跋致菩萨摩诃萨。应当验知。若菩萨摩诃萨是深般若波罗蜜中不着。当知是阿鞞跋致禅波罗蜜。乃至檀波罗蜜中不着。四念处乃至一切种智中不着。当知是阿鞞跋致

【论】问曰。般若波罗蜜非趣非不趣。须菩提何以故。问行般若者趣至何处。又佛何以答趣萨婆若。答曰。外道言诸法从因趣果。从先世入今世。从今世趣后世。破是常颠倒故言无趣不趣此中。须菩提以无著心问。佛以无著心答。般若波罗蜜毕竟空于诸法无障无碍。得无障无碍解脱故。无障无碍因果相似故。故言解深般若者趣一切种智。须菩提言。菩萨知般若波罗蜜者。为一切众生所归趣。如子为苦恼所逼则趣父母。问曰。何以故。但菩萨解深般若波罗蜜。为众生所归趣。答曰。菩萨于众生中大悲心故。常修习般若波罗蜜。以修故能解一切诸法。皆入般若波罗蜜。是故修般若波罗蜜即修一切法。般若无定实法可得。故经中说无所修是修般若波罗蜜。般若波罗蜜中一切诸观有过故不受。是名不受修。坏修者。一切法无常散坏故名坏修。可破坏法者。所谓色等乃至一切种智。佛可须菩提所说。上品未说阿鞞跋致菩萨性相貌。今应验试知于深般若波罗蜜中着不。若着则非若不着则是其相。行般若波罗蜜菩萨有二种。一者因般若波罗蜜观一切法毕竟空。般若亦自空。二者不能观般若亦空。是故经中试知着不

【经】若阿鞞跋致菩萨摩诃萨。行深般若波罗蜜时。不以他人语为坚要。亦不随他教行。阿鞞跋致菩萨摩诃萨。不为欲心嗔心痴心所牵。若阿鞞跋致菩萨摩诃萨。不远离六波罗蜜。若阿鞞跋致菩萨摩诃萨。闻说深般若波罗蜜时。心不惊不没不怖不畏不悔。欢喜乐闻受持读诵正忆念如说行。须菩提当知。是菩萨先世已问是深般若波罗蜜中事已。受持读诵说正忆念。何以故。是菩萨摩诃萨有大威德故。闻是深般若波罗蜜。心不惊不怖不畏不没不悔。欢喜乐闻受持读诵正忆念。须菩提白佛言。世尊。若菩萨摩诃萨闻深般若波罗蜜。不惊不怖乃至正忆念。世尊。是菩萨摩诃萨云何行般若波罗蜜。佛言。随顺一切种智心。是菩萨摩诃萨应如是行般若波罗蜜。世尊。云何名随顺一切种智心。是菩萨摩诃萨应如是行般若波罗蜜。佛言。以空随顺。是为菩萨摩诃萨行深般若波罗蜜。以无相无作无所有不生不灭不垢不净随顺。是菩萨摩诃萨。应如是行般若波罗蜜。以如梦幻炎向化随顺。是行般若波罗蜜。须菩提白佛言。佛说以空随顺。乃至如梦如幻随顺。是行般若波罗蜜。世尊。是菩萨摩诃萨行何法。若色若受想行识乃至一切种智。佛告须菩提。菩萨摩诃萨不行色不行受想行识。乃至不行一切种智。何以故。是菩萨摩诃萨行处无作法无坏法。无所从来亦无所去无住处。是法不可数无有量。若无数无量。是法不可得。不可以色得。乃至不可以一切种智得。何以故。色即是萨婆若。乃至一切种智即是萨婆若。色如相乃至一切种智如相。皆是一如无二无别

【论】释曰。阿鞞跋致菩萨所说事。于他语言中不生念。是中有实不实。何以故他人有二种。在家人着五欲乐虚诳不净。出家外道着诸邪见不实。此等所说皆无实事。是故不信。自得诸法实相故乃至佛身来说。破诸法实相者亦不信。得无为法故心则安重不复移转。是菩萨虽未得佛道。贪欲等诸烦恼折薄故不为所牵。心常不离六波罗蜜。知善法果报味故。心常爱乐不离六波罗蜜。如是等种种因缘故。闻深般若不怖不畏。欢喜欲闻。读诵问义修习。如雷霆小鸟则怖畏闷死。孔雀大鸟欢喜舞戏。般若波罗蜜亦如是。邪见凡夫闻则恐怖。阿鞞跋致菩萨闻则欢喜心无厌足。是故说欢喜乐闻。是中佛说因缘。是菩萨于过去世。已闻深般若波罗蜜。多集诸福德智慧故有大威德。有大威德故不怖畏。须菩提问。是菩萨闻深般若波罗蜜虽不怖畏。是般若无定相云何应行。佛言。随顺一切种智心。问曰。是菩萨未得一切种智云何能顺。答曰。是故说随顺毕竟空心则顺一切种智心。一切种智是寂灭相。佛后品中说一切寂灭相是一切种智。是故言顺毕竟空则顺一切种智。无相无作虚空无生无灭无垢无净如梦等亦如是。尔时须菩提问。顺毕竟空心观何等法。佛答。不观色乃至一切种智。何以故智慧欲求实事。色等有为作法皆虚妄。一切种智是实法。实法故过有为法。过有为法故说是法无作。无作者无坏法。无坏者是法不从六波罗蜜来。故言无所从来。不入佛法中故言无所去。有为虚诳故不住无为法中。无忆想分别故。亦不住五众和合故。有六道数坏。五众相续故。则无数无量。无数无量故则语言道断。语言道断故不可以行色等诸法得。佛此中自说因缘。色等诸法即是萨婆若。萨婆若。即是色等诸法。何以故。色等诸法如即是萨婆若如。萨婆若如即是色等诸法如。以是故说如是如无二无别

大智度论卷第七十一大智度论释大如品第五十四(卷七十二)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】尔时欲界诸天子色界诸天子。以天末栴檀香。以天青莲华赤莲花红莲华白莲华遥散佛上。来至佛所顶礼佛足一面住白佛言。世尊。诸佛阿耨多罗三藐三菩提。甚深难见难解不可思惟知。微妙寂灭智者能知。一切世间所不能信。何以故。是深般若波罗蜜中如是说。色即是萨婆若。萨婆若即是色。乃至一切种智即是萨婆若。萨婆若即是一切种智色如相萨婆若如相。是一如无二无别。乃至一切种智如相萨婆若如相一如无二无别

佛告欲色界诸天子如是如是。诸天子。色即是萨婆若。萨婆若即是色。乃至一切种智即是萨婆若。萨婆若即是一切种智。色如相乃至一切种智如相一如无二无别。诸天子。以是义故。佛初成道时。心乐嘿然不乐说法。何以故。是诸佛阿耨多罗三藐三菩提法。甚深难见难解不可思惟知。微妙寂灭智者能知。一切世间所不能信。何以故。阿耨多罗三藐三菩提。无得者无得处无得时。是名诸法甚深相。所谓无有二法。诸天子。如虚空甚深故是法甚深。如甚深故是法甚深。法性甚深实际甚深。不可思议无边甚深故是法甚深。无来无去甚深故是法甚深。不生不灭无垢无净无知无得甚深故是法甚深。诸天子。我甚深乃至知者见者甚深故是法甚深。诸天子。色甚深受想行识甚深故是法甚深。檀波罗蜜甚深乃至般若波罗蜜甚深故是法甚深。内空乃至无法有法空甚深故是法甚深。四念处甚深乃至一切种智甚深。故是法甚深。尔时欲色界诸天子白佛言。世尊。是所说法一切世间所不能信。世尊。是甚深法。不为受色故说。不为舍色故说。不为受受想行识故说。不为舍受想行识故说。不为受须陀洹果故说。不为舍须陀洹果故说。乃至不为受一切种智故说。不为舍一切种智故说。诸世间皆受着行。所谓色是我是我所。受想行识是我是我所。乃至十八不共法是我是我所。须陀洹果是我是我所。乃至一切种智是我是我所。佛告诸天子。如是如是。诸天子。是法非为受色故说。非为舍色故说。乃至非为受一切种智故说。非为舍一切种智故说。诸天子。若有菩萨为受色故行。乃至为受一切种智故行。是菩萨不能修般若波罗蜜。不能修禅波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜。不能修檀波罗蜜。乃至不能修一切种智者。须菩提白佛言。世尊。是法随顺一切法。云何是法随顺一切法。是法随顺般若波罗蜜。乃至随顺檀波罗蜜。是法随顺内空。乃至随顺无法有法空。是法随顺四念处。乃至随顺一切种智。是法无碍不碍于色。不碍受想行识。乃至不碍一切种智。诸天子。是法名无碍相。如虚空等故。如法性法住实际不可思议性等故。空无相无作等故。是法不生相色不生不可得故。受想行识不生不可得故。乃至一切种智不生不可得故。是法无处色处不可得故。受想行识处不可得故。乃至一切种智处不可得故。是时欲色界诸天子白佛言。世尊。须菩提是佛子随佛生。何以故。须菩提所说皆与空合。尔时须菩提语诸天子。汝等言须菩提是佛子随佛生。云何为随佛生。诸天子。如相故须菩提随佛生。何以故。如来如相不来不去。须菩提如相亦不来不去。是故须菩提随佛生。复次须菩提从本已来随佛生。何以故。如来如相即是一切法如相。一切法如相即是如来如相。是如相中亦无如相。是故须菩提

为随佛生。复次如来如常住相。须菩提如亦常住相。如来如相无异无别。须菩提如相亦无异无别。是故须菩提为随佛生。如来如相无有碍处。一切法如相亦无碍处。是如来如相一切法如相。一如无二无别。是如相无作终不不如。是故是如相一如无二无别。是故须菩提为随佛生。如来如相一切处无念无别。须菩提如相亦如是。一切处无念无别。如来如相不异不别不可得。须菩提如相亦如是。以是故须菩提为随佛生。如来如相不远离诸法如相。是如终不不如。是故须菩提如不有异。为随佛生亦无所随。复次如来如相不过去不未来不现在。诸法如相亦不过去不未来不现在。是故须菩提为随佛生。复次如来如不在过去如中。过去如亦不在如来如中。如来如不在未来如中。未来如不在如来如中。如来如不在现在如中。现在如不在如来如中。过去未来现在如如来如。一如无二无别。色如。如来如。受想行识如。如来如。是色如受想行识如如来如。一如无二无别。我如乃至知者见者如如来如。一如无二无别。檀波罗蜜如乃至般若波罗蜜如。内空如乃至无法有法空如。四念处如乃至一切种智如如来如。一如无二无别。须菩提菩萨摩诃萨得是如故名为如来。说是如相品时。是三千大千世界大地六种振动。东踊西没西踊东没。南踊北没北踊南没。中央踊四边没。四边踊中央没

【论】问曰。若般若波罗蜜无不甚深。何以或时赞甚深。答曰。般若波罗蜜中。或时分别诸法空是浅。或时说世间法即同涅槃是深。色等诸法即是佛法。听者闻说心信佛语。自智慧不及故言甚深。譬如河水有洄复深处有浅处。问曰。诸天所赞法甚深。一切世间所不能信何用说为。答曰。一切有二种。一者名字一切。二者实一切。如此中说名字一切。以多不信故言一切。如此中说微妙寂灭智者能知。知者必有信先信后知故。复次是般若波罗蜜惟佛能知众生闻所说而信者。此中不名为信。智慧知已名为信。问曰。若尔者何以言微妙智者能知。答曰。一切世间无能遍尽知。诸佛智者寂灭智者能知少分。如须陀洹于无上道得少分。所谓断三结。如是诸道展转增多。若世间都不信者云何有诸道。以是故言寂灭智者能知阿耨多罗三藐三菩提即是般若波罗蜜。但名字异。在菩萨心中为般若。在佛心中名阿耨多罗三藐三菩提。是中说色等法即是萨婆若萨婆若即是色等法。此中说色等法如萨婆若如无二无别。佛可诸天子意更说因缘。如名色等诸法真实相。譬如除宫殿及诸陋庐。如烧栴檀及杂木其处虚空无异色。及萨婆若等诸法求其实皆是如。以是义故佛初成道时心乐嘿然不乐说法知甚深法。凡夫人难悟故。复次是法无二故甚深。如虚空故甚深。如法性等甚深故甚深。尔时诸天子知是法无可取相。白佛言。是所说法一切世间所不能信。是法不为受色等法故说。佛可其言。若有菩萨为受色等故行菩萨道。不能修般若波罗蜜等诸功德。须菩提白佛言。世尊。是般若波罗蜜相。随顺一切法无所障碍。何以故。于般若波罗蜜亦不着。说不障碍因缘如虚空等故。譬如壁中先有空相小儿以橛钉之力少故不入大力者能入。行者亦如是。色等诸法中自有如实相。智慧力少故不能令空。大智者能知。是故说诸法无碍如虚空平等。色等法不生亦不可得。以是故名不生。非但色等不生。若不生法可得则非毕竟空。非名无得。无住处亦如是。尔时诸天子白佛言。世尊。须菩提随佛生。何以故。所知所说皆与空合。复次经说有三种子一者不随顺生。二者随顺生。三者胜生。世人皆愿二种子随顺子胜子。佛法中惟欲一种随顺生。以无有胜佛故。佛子有五皆从口生法生。须陀洹乃至阿罗汉入正位菩萨。辟支佛虽佛法中种因缘。无佛时自能得道。不得言从佛口生。因缘远故。诸漏尽者是随顺生。须菩提于漏尽中常乐毕竟空是随顺生。何以故。所行法不可破坏如虚空。佛法如是相是名随佛生。问曰。何以不说入法位菩萨随顺佛生。答曰。有人言。漏未尽故不说。须菩提漏尽故说。有人言。入无余涅槃者是第一清净。阿罗汉末后身住有余涅槃。近无余涅槃门故说。菩萨虽有深利智慧往返生死中。是故不说。有人言。般若有二种。一者唯与大菩萨说。二者三乘共说。共声闻说中须菩提是随佛生。但与菩萨说时不说须菩提随佛生。何以故。法性生身大菩萨。是中无有结业生身。但有变化生身。灭三毒出三界。教化众生净佛世界故住于世间。此中都无一切声闻人。佛大慈悲心菩萨心亦尔。是名菩萨随生。须菩提但取涅槃故不说随生。此经共二乘说。须菩提知般若波罗蜜甚深。法性生身菩萨力大。诸天虽赞不应受语。诸天子言诸法如一相所谓无相。是因缘故随佛生。如不异故。如经中说。如如来如相不来不去。须菩提如相亦不来不去

复次如来如毕竟空。一切法如亦毕竟空。一切法如中摄须菩提如。是故须菩提用如来如故随佛生。复次如如来如无忆想分别常住如虚空。须菩提如亦如是。是故须菩提随佛生。复次如如来如得无碍解脱故。一切法中无挂碍。一切法如亦如是。于一切法中亦无挂碍。如来如一切法如一如无异。须菩提如亦入一切法如故。是以随佛生。复次诸法如相无作无作者。如来如相亦如是。须菩提如一切法如摄故随佛生。复次如如来如相一切处常无忆想分别。须菩提如一切法如摄故随佛生。复次如来如相不离一切法如。正观一切法名为佛。一切法是因缘佛是果报。是故说如来如不离一切法如。是如实故常如无不如时。须菩提如亦如是。不异故随佛生。亦无法可随。复次如来如相无忆想分别出过三世。一切法如亦如是。须菩提如亦出三世。是故随佛生。复次如来如不在过去如中。何以故如来空。过去亦毕竟空。是故空不在空中住。譬如虚空不住虚空中。未来现在亦如是。三世如如来如不二。不分别者。三世如空无相无生无灭等。如来如亦如是。三世如无障碍如。过去世无穷无边。未来世亦无穷无边。现在世亦无穷无边。如来如亦如是。此三世十方无穷无边。须菩提如亦如是。复次五众如。乃至一切种智如。如来如。无二无别。何以故。色等诸法和合故有如来如。是如来不得言但是色等法。亦不得言离色等法。亦不得言色等法在如来中。亦不得言如来在色等法中。亦不得言色等法属如来。亦不得言无如来。五众色等法中假名如来。如来如即是一切法如。是故说色等法如如来如不二不别。凡夫人见有二有别。圣人观无二无别。圣人可信。凡夫人所见不可信。佛语须菩提。是名为如。佛因此如故名为如来。如来者如实行来到佛法中。说是如时。地六种震动如上说

【经】是时诸欲天子诸色天子。以天末栴檀香散佛上。及散须菩提上。白佛言。未曾有也世尊。须菩提以如来如随佛生。须菩提复为诸天子说言。诸天子。须菩提不从色中随佛生。亦不从色如中随佛生。不离色随佛生。亦不离色如随佛生。须菩提不从受想行识中随佛生。亦不从受想行识如中随佛生。不离受想行识随佛生。亦不离受想行识如随佛生。乃至不从一切种智中随佛生。亦不从一切种智如中随佛生。不离一切种智随佛生。亦不离一切种智如随佛生。须菩提不从无为中随佛生。亦不从无为如中随佛生。不离无为随佛生。亦不离无为如随佛生。何以故。是一切法皆无所有不可得。无随生者。亦无随生法

尔时舍利弗白佛言。世尊。是如实不虚。法相法住法位甚深。是中色不可得。色如不可得。何以故。色尚不可得。何况色如当可得。受想行识不可得。受想行识如不可得。何以故。受想行识尚不可得。何况受想行识如当可得。乃至一切种智不可得。一切种智如不可得。何以故。一切种智尚不可得。何况一切种智如当可得。佛告舍利弗。如是如是。舍利弗。是如实不虚。法相法住法位甚深。是中色不可得。色如不可得。何以故。色尚不可得。何况色如当可得。乃至一切种智不可得。一切种智如不可得。何以故。一切种智尚不可得。何况一切种智如当可得。舍利弗说是如相时。二百比丘不受一切法故。漏尽得阿罗汉。五百比丘尼远尘离垢。诸法中得法眼净生天人中。五千诸菩萨摩诃萨得无生忍法。六千菩萨诸法不受故。漏尽心得解脱成阿罗汉。舍利弗。是六千菩萨。先世值五百佛亲近供养。于五百佛法中行布施持戒忍辱精进禅定。无般若波罗蜜。无方便力故行别异相。作是念。是施是持戒是忍辱是精进是禅定。无般若波罗蜜。无方便力故。布施持戒忍辱精进禅定行别异相。行别异相故不得无异相。不得无异相故。不得入菩萨位。不得入菩萨位故。得须陀洹果乃至阿罗汉果。舍利弗。菩萨摩诃萨虽有道若空若无相若无作法。远离般若波罗蜜无方便力故。便于实际作证取声闻乘

舍利弗白佛言。世尊。何因缘故。俱行空无相无作法。远离方便力故。于实际作证取声闻乘。菩萨摩诃萨亦修空无相无作法。有方便力故。得阿耨多罗三藐三菩提。佛告舍利弗。有菩萨远离萨婆若心。修空无相无作法。无方便力故取声闻乘。舍利弗。复有菩萨摩诃萨不远离萨婆若心。修空无相无作法。有方便力故入菩萨位。得阿耨多罗三藐三菩提

舍利弗。譬如有鸟身长百由旬。若二百三百由旬而无有翅。从三十三天自投阎浮提。舍利弗。于汝意云何。是鸟中道作是念。欲还上三十三天。能得还不。不得也世尊。舍利弗。是鸟复作是愿。到阎浮提欲使身不痛不恼。舍利弗。于汝意云何。是鸟得不痛不恼不。舍利弗言。不得也世尊。是鸟到地若痛若恼若死若死等苦。何以故。世尊。是鸟身大而无翅故。舍利弗。菩萨摩诃萨亦如是。虽如恒河沙等劫修布施持戒忍辱精进禅定发大事生大心为得阿耨多罗三藐三菩提故受无量愿。是菩萨远离般若波罗蜜方便力故。若堕阿罗汉若堕辟支佛道。何以故。是菩萨远离萨婆若心。布施持戒忍辱精进禅定。无般若波罗蜜。无方便力故。堕声闻地若辟支佛道中。舍利弗。菩萨摩诃萨虽念过去未来现在诸佛持戒禅定智慧解脱解脱知见。取相受持。是人不知不解诸佛戒定慧解脱解脱知见。但闻空无相无作名字声。而取名字声回向阿耨多罗三藐三菩提。菩萨摩诃萨若如是回向。住声闻辟支佛地中不能得过。何以故。远离般若波罗蜜及方便力。持诸善根回向阿耨多罗三藐三菩提故。舍利弗。有菩萨摩诃萨。从初发意已来。不远离萨婆若心。行布施持戒忍辱精进禅定。不远离般若波罗蜜及方便力。故不取相。于过去未来现在诸佛戒定慧解脱解脱知见。不取空解脱门相。不取无相无作解脱门相。舍利弗当知。是菩萨摩诃萨不堕声闻辟支佛道。直至阿耨多罗三藐三菩提。何以故。是菩萨摩诃萨从初发心已来。行布施不取相。持戒忍辱精进禅定不取相。过去未来现在诸佛戒定慧解脱解脱知见不取相

舍利弗。是名菩萨方便力。以离相心行布施持戒忍辱精进禅定。乃至离相心行一切种智。舍利弗白佛言。世尊。如我解佛所说义。若菩萨摩诃萨不远离般若波罗蜜方便力。当知是菩萨近阿耨多罗三藐三菩提。何以故。是菩萨摩诃萨从初发心已来无法可知。若色若受想行识乃至一切种智。世尊。有求菩萨道善男子善女人。远离般若波罗蜜方便力。当知是人于阿耨多罗三藐三菩提。或得或不得。何以故。世尊。是求菩萨道善男子善女人。所有布施皆取相。所有持戒忍辱精进禅定皆取相。以是故。是善男子善女人。于阿耨多罗三藐三菩提不定。世尊。以是因缘故。菩萨摩诃萨欲得阿耨多罗三藐三菩提。不应远离般若波罗蜜方便力。是菩萨摩诃萨住般若波罗蜜方便力中。以无得无相心。应修布施持戒忍辱精进禅定。乃至以无得无相心。应修一切种智

【论】释曰。诸天子欢喜以末栴檀香散佛及须菩提上叹言。希有世尊。须菩提以如来如随佛生者。诸天子意谓须菩提智慧力故。令一切法皆如佛法。是故说随佛生

须菩提知诸天子心少贵尚是诸法如。是故须菩提欲断诸天子心故。说是如毕竟空相。以四种破着如心。所谓须菩提不在色中不在色如中。不以色等不以色等如。不离色等不离色等如随佛生。佛此中自说因缘。此法皆空不可得。舍利弗言。世尊。是如甚深。是如中但色等法不可得。何况色等法如当可得。问曰。何者是色等法。何者是色等法如。答曰。色等法。眼所见等诸法如。名色等法实相不虚诳。人于色等如法中错谬故。或起不善业堕恶道中。或起善业生于人天中。终归磨灭还生诸苦。或起无漏业应求大利。而取小乘不得毕竟清净如相故。色等法皆是作法有为虚妄从颠倒生。凡夫所忆想分别行处。是故色等法虚妄不即是如。知色等法如实故即是如。因色等法得如名。是故言不离色等法得如色等法入如中皆一相无异。是故须菩提谦言。非但我随佛生。一切法亦如是相。舍利弗赞叹须菩提所说。色等法亦毕竟空。何况如。因若空何况果。闻如是甚深如相。众生各得道利益

问曰。是般若波罗蜜为菩萨说。何故六千人成阿罗汉道。答曰。佛知必有难者。自为舍利弗说因缘。是人无般若波罗蜜无方便力。过去作功德无方便故邪行不正。是人离般若波罗蜜故深着善法。今从佛闻般若波罗蜜深厌世间。慈悲心薄故求自利不受一切法。即得阿罗汉于般若无咎。如人持器诣海随器大小各自取足。问曰。如经说。六千菩萨无般若波罗蜜方便力故。行五波罗蜜不得是无分别法作阿罗汉。若一切圣人皆得无为法。得无为法即是无分别。何以此中说不得无分别法作阿罗汉。答曰。非说今世听法时。乃是过去五百世时。不得般若方便。修集五波罗蜜功德。以是故言不得无分别失菩萨信等五根。失菩萨信等五根故。虽闻般若不得如菩萨所闻。即于实际作证。问曰。俱行空无相无作。何以一人得作佛。一人作阿罗汉。答曰。虽有种种因缘。得阿罗汉大因缘。所谓离萨婆若心行空等故。大鸟者金翅鸟在于天上。如此间人鸟雀等无异。是鸟所以不来者。此鸟食龙翅出毒风扇一切人眼失明故。是鸟初出[聲-耳+卵]羽翼未成。意欲飞去即时堕落。中道心悔我未应飞。还欲住本天上舍摩梨树上。是鸟身大羽翼未成不能举身。鸟身是菩萨。身大者世世广集五波罗蜜功德。无两翅者是无般若波罗蜜无方便。须弥山者是三界。虚空是无量佛法。未应飞而飞者。是菩萨功德未成满。欲行菩萨三解脱门。欲游无量佛法虚空中而自退没。是心虽欲愿作佛而不能得。若死者是阿罗汉道。死等者辟支佛道。若病若恼者失菩萨本愿功德。佛自结句乃至住是无得无相心中应布施等。此经中合喻义自明了故不说

【经】尔时欲色界诸天子白佛言。世尊。阿耨多罗三藐三菩提难得。何以故。是菩萨摩诃萨应知一切诸法已得阿耨多罗三藐三菩提。是法亦不可得。佛言。如是如是。诸天子。阿耨多罗三藐三菩提难得。我亦得一切法一切种智已。得阿耨多罗三藐三菩提。亦无所得无能知无可知亦无知者。何以故。诸法毕竟净故。须菩提白佛言。世尊。如佛所说阿耨多罗三藐三菩提难得。如我解佛所说义。我心思惟。是阿耨多罗三藐三菩提易得。何以故。无有得阿耨多罗三藐三菩提者。亦无可得法。一切法一切法相空。无法可得无能得者。何以故。一切法空故。亦无法可增。亦无法可减。所谓布施持戒忍辱精进禅定。乃至一切种智。是法皆无可得者无能得者。世尊。以是因缘故。我意谓阿耨多罗三藐三菩提为易得。何以故。世尊。色色相空。受想行识识相空。乃至一切种智一切种智相空。舍利弗语须菩提。若一切法空如虚空。虚空不作是念。我当得阿耨多罗三藐三菩提。若菩萨摩诃萨信解一切诸法空如虚空。是阿耨多罗三藐三菩提易得者。今恒河沙等诸菩萨摩诃萨。求阿耨多罗三藐三菩提。何以故退还。须菩提。以是故知阿耨多罗三藐三菩提不易得。须菩提语舍利弗。于意云何。色于阿耨多罗三藐三菩提退还不。舍利弗言不。受想行识于阿耨多罗三藐三菩提退还不。舍利弗言不。乃至一切种智于阿耨多罗三藐三菩提退还不。舍利弗言不。离色有法。于阿耨多罗三藐三菩提退还不。舍利弗言不。离受想行识有法。于阿耨多罗三藐三菩提退还不。舍利弗言不。乃至离一切种智有法。于阿耨多罗三藐三菩提退还不。舍利弗言不。舍利弗。于意云何。色如相。于阿耨多罗三藐三菩提退还不。舍利弗言不。受想行识如相。乃至一切种智如相。于阿耨多罗三藐三菩提退还不。舍利弗言不。离色如相有法。于阿耨多罗三藐三菩提退还不。舍利弗言不。离受想行识如相。乃至离一切种智如相有法。于阿耨多罗三藐三菩提退还不。舍利弗言不。舍利弗。于意云何。如于阿耨多罗三藐三菩提退还不。舍利弗言不。法性法住法位。实际不可思议性。于阿耨多罗三藐三菩提退还不。舍利弗言不。舍利弗。于意云何。离如有法。于阿耨多罗三藐三菩提退还不

舍利弗言不。离法性法住法位实际不可思议性有法。于阿耨多罗三藐三菩提退还不。舍利弗言不。须菩提。语舍利弗言。若诸法毕竟不可得。何等法于阿耨多罗三藐三菩提退还。舍利弗语须菩提如须菩提所说。是法忍中无有菩萨于阿耨多罗三藐三菩提退还者。若不退还。佛说求道者有三种。阿罗汉道辟支佛道佛道。是三种为无分别。如须菩提说。独有一菩萨求佛道。是时富楼那弥多罗尼子语舍利弗。应当问须菩提。为有一菩萨乘不

尔时舍利弗问须菩提。须菩提。为欲说有一菩萨乘。须菩提。语舍利弗。于诸法如中欲使有三乘人声闻乘辟支佛乘佛乘耶。舍利弗言。不也。舍利弗。三乘分别中有如可得不。舍利弗言。不也。舍利弗。是如有若一相若二相若三相不。舍利弗言。不也。舍利弗。汝欲于如中乃至有一菩萨不。舍利弗言。不也。如是四种中三乘人不可得。舍利弗。云何作是念。是求声闻乘人。是求辟支佛乘人。是求佛乘人。舍利弗。菩萨摩诃萨闻是诸法如相。心不惊不没不悔不疑。是名菩萨摩诃萨能成就阿耨多罗三藐三菩提。尔时佛赞须菩提言。善哉善哉。须菩提。汝所说者皆是佛力。须菩提。若菩萨摩诃萨闻说是如。无有诸法别异心。不惊不怖不畏不难不没不悔。当知是菩萨能成就阿耨多罗三藐三菩提。舍利弗。白佛言。世尊。成就何等菩提。佛言。成就佛阿耨多罗三藐三菩提

【论】释曰。尔时诸天子作是念白佛言。世尊。阿耨多罗三藐三菩提难得。何以故。一切法毕竟空。而菩萨求佛道。观行修集成佛度众生。是法亦不可得。佛可其言自身为证。我坐道场以一切种得一切法。亦无一定相可得。须菩提言。世尊。如我意。阿耨多罗三藐三菩提易得。一切法毕竟常空故。是中无得者无可得法。无障无碍无所修无所断故。尔时舍利弗言。若佛道易得者。何以故。恒河沙等无量菩萨求佛道。若一若二作佛余者皆退还。须菩提答舍利弗。色于阿耨多罗三藐三菩提退还不。受想行识乃至一切种智退还不。答言。不也。何以故。色等法毕竟空无有退还。色等法如无二相亦无分别故无退还。离色等法更有法退还不。答言。离色等更无有法。是故言不也。离色等法如更有法退还不。答言。如破色等法已如亦自空。是故言不。法性法位乃至不可思议性亦如是。须菩提语舍利弗。若法无退还。何以故。言如恒河沙等菩萨退还。舍利弗答。如须菩提所说。法忍中则无退还。法忍者是法门法修法行。入须菩提所说法门中则无退还。出是法门则有退还。舍利弗。虽现受须菩提语。亦自引佛法作难。若无退者尽当作佛。何以说有三乘。须菩提。还以如相四句破三乘。佛叹须菩提善哉。若菩萨闻如中无三乘分别不恐怖。是菩萨即能成无上道。问曰。若佛说菩萨成阿耨多罗三藐三菩提。舍利弗。何以故。问成就何等菩提。答曰。各各有无上。舍利弗疑故。问何等道无上。答大乘无上。复次须菩提。以毕竟空智慧。破着三乘心。佛赞善哉。须菩提言。菩萨闻是心不没不怖。则能成就阿耨多罗三藐三菩提。舍利弗。问三乘菩提无定相。今言成就菩提成何等菩提。佛言。成就佛阿耨多罗三藐三菩提。若入毕竟空门一切法尽一相。若出毕竟空三乘则有异。今佛分别诸法故说有上中下乘。不为毕竟空故说

【经】须菩提。白佛言。世尊。若菩萨摩诃萨。欲成就阿耨多罗三藐三菩提。应云何行。佛言。应起等心。于一切众生亦以等心与语无有偏党。于一切众生中起大慈心。亦以大慈心与语。于一切众生中下意。亦以下意与语。于一切众生中应生安隐心。亦以安隐心与语。于一切众生中应生无碍心。亦以无碍心与语。于一切众生中应生无恼心。亦以无恼心与语。于一切众生中应生爱敬心。如父如母如兄如弟如姊如妹如儿子如亲族知识。亦以爱敬心与语。是菩萨摩诃萨亦应自不杀生。亦教人不杀生。赞不杀生法欢喜赞叹诸不杀生者。乃至自行不邪见。亦教他人不行邪见。赞不邪见法。欢喜赞叹不邪见者。如是须菩提。菩萨摩诃萨。欲成就阿耨多罗三藐三菩提。当如是行。复次须菩提。菩萨摩诃萨欲成就阿耨多罗三藐三菩提。应自行初禅。亦教他人行初禅。赞叹行初禅法。欢喜赞叹行初禅者。二禅三禅四禅亦如是。复次须菩提。菩萨摩诃萨。欲成就阿耨多罗三藐三菩提。应自行慈心。亦教人行慈心。赞叹行慈心法。欢喜赞叹行慈心者。悲喜舍心亦如是。自行虚空处。亦教人行虚空处。赞叹行虚空处法。欢喜赞叹行虚空处者。识处无所有处。非有想非无想处亦如是

自具足檀波罗蜜。亦教人具足檀波罗蜜。赞叹具足檀波罗蜜法。欢喜赞叹具足檀波罗蜜者。尸罗羼提毗梨耶禅般若波罗蜜亦如是。复次菩萨摩诃萨欲成就阿耨多罗三藐三菩提。自行内空。亦教人行内空。赞叹行内空法。欢喜赞叹行内空者。乃至无法有法空亦如是。自行四念处。亦教人行四念处。赞叹行四念处法。欢喜赞叹行四念处者。乃至八圣道分亦如是。自修空三昧无相无作三昧。亦教人修空无相无作三昧。赞叹修空无相无作三昧法。欢喜赞叹修空无相无作三昧者。自行八背舍。亦教人行八背舍。赞叹行八背舍法。欢喜赞叹行八背舍者。自行九次第定。亦教人行九次第定。赞叹行九次第定法。欢喜赞叹行九次第定者。自具足佛十力。亦教人具足佛十力。赞叹具足佛十力法。欢喜赞叹具足佛十力者。自行四无所畏四无碍智十八不共法大慈大悲。亦教人行四无所畏乃至大慈大悲。赞叹行四无所畏乃至大慈大悲法。欢喜赞叹行四无所畏乃至大慈大悲者。自逆顺观十二因缘。亦教人逆顺观十二因缘。赞叹逆顺观十二因缘法。欢喜赞叹逆顺观十二因缘者。须菩提。菩萨摩诃萨欲成就阿耨多罗三藐三菩提。应如是行。复次须菩提。菩萨摩诃萨欲成就阿耨多罗三藐三菩提。自应知苦断集灭证修道。亦教人知苦断集灭证修道。赞叹知苦断集灭证修道法。欢喜赞叹知苦断集灭证修道者。自生须陀洹果。证智而不证实际。亦教人着须陀洹果中。赞叹须陀洹果法。欢喜赞叹得须陀洹果者。斯陀含果阿那含果阿罗汉果亦如是。自生辟支佛道。证知而不证辟支佛道。亦教人着辟支佛道中。赞叹辟支佛道法。欢喜赞叹得辟支佛道者。自入菩萨位。亦教人入菩萨位。赞叹入菩萨位法。欢喜赞叹入菩萨位者。自净佛世界成就众生。亦教人净佛世界成就众生。赞叹净佛世界成就众生法。欢喜赞叹净佛世界成就众生者。自起菩萨神通。亦教人起菩萨神通。赞叹起菩萨神通法。欢喜赞叹起菩萨神通者。自生一切种智。亦教人生一切种智。赞叹生一切种智法。欢喜赞叹生一切种智者。自断一切结使习。亦教人断一切结使习。赞叹断一切结使习法欢喜赞叹断一切结使习者。须菩提。菩萨摩诃萨欲成就阿耨多罗三藐三菩提。应如是行。复次须菩提。菩萨摩诃萨欲成就阿耨多罗三藐三菩提。自取寿命成就。亦教人取寿命成就。赞叹取寿命成就法。欢喜赞叹取寿命成就者。自成就法住。亦教人成就法住。赞叹成就法住法。欢喜赞叹成就法住者。须菩提。菩萨摩诃萨欲成就阿耨多罗三藐三菩提。应如是行。亦应如是学般若波罗蜜方便力。是菩萨如是学如是行时。当得无碍色得无碍受想行识乃至得无碍法住。何以故。是菩萨摩诃萨从本已来不受色不受受想行识。乃至不受一切种智。何以故。色不受者为非色。乃至一切种智不受者为非一切种智。说是菩萨行品时。二千菩萨得无生法忍

【论】释曰。须菩提问。菩萨欲成无上道者云何应行。佛答应起等心。于一切众生无有偏党。五众和合假名众生如车如林。一切众生者尽举十方六道无有遗余。一切众生法各行三分。怨亲中人。佛今教菩萨等心。一切众生皆有亲爱想莫生怨心。莫生中人心。复次众生有二种爱及憎。佛言。于一切众生离是二心莫生憎爱。爱者贪欲烦恼心不应行。当行慈爱心。世间法爱念妻子牛马等。憎恶怨贼等。菩萨转此世间法。但行慈爱心于一切众生。复次等心者菩萨生法喜。于一切众生欲令皆至佛道。菩萨自舍憎爱心。亦舍众生憎爱心加己。世间有三种人。恶大恶恶中恶。善大善善中善。恶者如人以恶事加己还报之以恶事。诸佛法于一切众生平等心。不应起恶念。何况起身行口行。大恶者如无人侵己而以恶加人。恶中恶者如人以好心供给慈念而反以恶心毁害。如是等恶名恶中恶。善者如人以好事于己还以善报。大善者如人于己无善而以善事利益。善中善者如人以恶事害于己而以善事乃至身命供养。是名善中善。菩萨舍是三恶。过是二种善行。第六心于一切众生。问曰。是菩萨未得法身。云何能行是心。答曰。是菩萨求无上道。应行无上法。受如是难为苦行乃成无上道。譬如估客于险道中备受诸苦乃得大利。复次是菩萨闻佛法正体。所谓毕竟空无我无我所。无一定实法。所见所闻所知皆是虚诳如幻如梦。深信是法故能以身命供养怨贼。复次菩萨知此身从罪业烦恼颠倒因缘生所见所闻皆是虚诳罪垢之本。若有人来欲加害于我。我宜欢喜受之。以此弊身而得无上道利何为不与。复次菩萨发心深爱众生。欲利益故。自以己身供养怨贼。欲令众生效己所行。以有众生说法教者不必肯受。故以身教令其信受。复次多有人发言求无上道而身行不称。亦以是故菩萨以身教之。令坚心行此难事。欲求无上道当行善中善法。为此难事尔乃可得。如是等无量因缘自以身命供养怨贼。问曰。等心慈心有何等异。答曰。等心者是四无量心。慈心者是一无量。有人言初舍怨亲是等心。后加愍念是慈心。复次有人言等心者观众生如如实际法性。是法皆无为无量故。等爱念众生是名慈心。所以不说悲心者悲心或忧念众生。积集此心心则退没。或有众生不爱菩萨悲念言。汝何以不自忧其身而念他人。慈心无如是事。易摄众生故但说慈心。问曰。若众生有三种上中下。菩萨福德智慧积集故应是大人。云何言于一切众生中起下意。答曰。菩萨作是念。一切法无常一切众生上中下皆归磨灭。是中何者是大何者是小。人以世法故有大小。复次大小不定。此国以为大余国以为小。于此为大于彼为小。如今世卑贱后世为天王。如是业因缘在世间轮转。贵贱大小无定。如水火贵贱随时用舍无定。复次菩萨虽有功德知是功德毕竟空。如幻如梦不着此功德。不有是大小。复次一切众生中有佛道因缘者。唯佛能知。菩萨作是念若我以众生形貌才能。以此事轻者则为轻未来佛。若轻佛则为永了。复次菩萨作是念。我誓度一切众生。若众生无所得。我则孤负众生。譬如主人请客则应敬客而自卑。若无所供设是则负愧于客。复次以自大心故则喜生嗔恚。憍慢是嗔之本。嗔是一切重罪之根。若菩萨于众生起下心。众生若骂若打则无恚恨。譬如大家打奴奴不敢嗔恨。若菩萨自高意下众生者。众生侵害忿然生怒。如奴打大家则起嗔怒。下意有如是等种种利益。故菩萨应当行安隐心者。与今世后世究竟乐。非如父母知识与现世乐。菩萨若以等心慈心下心利益众生时。若有不知恩人来恼菩萨。不信所行谓为欺诳为求名故无有实事。又为魔所使来恼菩萨。恶中之恶不识恩分。菩萨等心于此通达无碍。得是无碍心已众生虽有大罪大过。但欲利益不生恼心。慈心安隐无碍不恼心。譬如孝子爱敬父母。如兄如弟如姊妹。如儿女无淫欲心而生爱敬慈念。世人但能爱敬所亲。菩萨普及一切。得是柔软清净好心名众生忍。是法忍初门。次行十善道。十善道有佛无佛世间常有是善法教。菩萨先以四十种行行是十善道。何以故。是菩萨深念善法心慈众生故。难欲凡夫法有十二事。亦以四十八种行六波罗蜜乃至法住。是客法。有佛说则有菩萨行。上来旧法客法本末具足。今世得善法智慧无碍。舍身得法身无碍。随意至十方教化众生。于十方佛前修集善法。闻是法时二千菩萨得无生法忍者。是品说如微妙深法。亦说有行善门智门二行具足。但说如法所利少。若说有法所利亦少。今说有无二法具足故得无生法忍。譬如二轮具足故能有所至。此中善说二谛故二千菩萨得无生法忍

大智度论卷第七十二大智度论释阿毗跋致品第五十五(卷七十三)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】须菩提白佛言。世尊。以何等行何等类何等相貌。知是阿鞞跋致菩萨摩诃萨。佛告须菩提。若菩萨摩诃萨能知凡夫地声闻地辟支佛地佛地。是诸地如相中无二无别。亦不念亦不分别。入是如中闻是事直过无疑。何以故。是如中无一无二相故。是菩萨摩诃萨亦不作无益语。但说利益相应语。不视他人长短。须菩提。以是行类相貌。知是阿鞞跋致菩萨摩诃萨。须菩提言。世尊。复以何等行类相貌。知是阿鞞跋致菩萨摩诃萨。佛告须菩提。若菩萨摩诃萨能观一切法无行无类无相貌。当知是名阿鞞跋致菩萨摩诃萨。须菩提白佛言。世尊。若一切法无行无类无相貌。菩萨于何等法转名不转。佛言。若菩萨摩诃萨。色中转。受想行识中转。是名菩萨不转。复次须菩提。菩萨摩诃萨檀波罗蜜中转。乃至般若波罗蜜中转。内空中乃至无法有法空中转。四念处中乃至十八不共法中转。声闻辟支佛地中转。乃至阿耨多罗三藐三菩提中转。当知是菩萨摩诃萨不转。何以故。须菩提。色性无是菩萨何所住。乃至阿耨多罗三藐三菩提性无。是菩萨何所住。复次须菩提。菩萨摩诃萨不观外道沙门婆罗门面类言语。不作是念。是诸外道若沙门若婆罗门。实知实见若说正见无有是事。复次菩萨不生疑不着戒取不堕邪见。亦不求世俗吉事以为清净。不以华香璎珞幡盖伎乐礼拜供养余天。须菩提。以是行类相貌。当知是名阿鞞跋致菩萨摩诃萨。复次须菩提。阿鞞跋致菩萨摩诃萨。常不生不贱家。乃至不生八难之处。常不受女人身。须菩提。以是行类相貌。当知是名阿鞞跋致菩萨摩诃萨。复次须菩提。菩萨摩诃萨常行十善道自不杀生。不教人杀生。赞叹不杀生法。欢喜赞叹不杀生者。乃至自不邪见。不教人邪见。不赞叹邪见法。不欢喜赞叹行邪见者。须菩提。以是行类相貌。当知是名阿鞞跋致菩萨摩诃萨

复次须菩提。菩萨摩诃萨乃至梦中亦不行十不善道。以是行类相貌。当知是名阿鞞跋致菩萨摩诃萨。复次须菩提。菩萨摩诃萨为利益一切众生故。行檀波罗蜜。乃至为利益一切众生故。行般若波罗蜜。须菩提。以是行类相貌。当知是名阿鞞跋致菩萨摩诃萨。复次须菩提。菩萨摩诃萨所有诸法受读诵说正忆念。所谓修姤路乃至优波提舍。是菩萨法施时作是念。是法施因缘故。满一切众生愿。以是法施功德与一切众生共之。回向阿耨多罗三藐三菩提。须菩提。以是行类相貌。当知是名阿鞞跋致菩萨摩诃萨。复次须菩提。菩萨摩诃萨于甚深法中不疑不悔。须菩提言。世尊。菩萨于甚深法中何因缘故不疑不悔。佛言。是阿鞞跋致菩萨。都不见有法可生疑处。若色受想行识。乃至阿耨多罗三藐三菩提。不见是法可生疑处悔处。须菩提。以是行类相貌。当知是名阿鞞跋致菩萨摩诃萨。复次须菩提。菩萨摩诃萨身口意业柔软。须菩提。以是行类相貌。当知是名阿鞞跋致菩萨摩诃萨。复次须菩提。菩萨摩诃萨以慈身口意业成就。须菩提。以是行类相貌。当知是名阿鞞跋致菩萨摩诃萨。复次须菩提。菩萨摩诃萨不与五盖俱淫欲嗔恚睡眠掉悔疑。须菩提。以是行类相貌。当知是名阿鞞跋致菩萨摩诃萨。复次须菩提。菩萨摩诃萨一切处无所爱着。须菩提。以是行类相貌。当知是名阿鞞跋致菩萨摩诃萨。复次须菩提。菩萨摩诃萨出入去来坐卧行住常念一心。出入去来坐卧行住举足下足安隐庠序。常念一心视地而行。须菩提。以是行类相貌。当知是名阿鞞跋致菩萨摩诃萨。复次须菩提。菩萨摩诃萨所著衣服及诸卧具。人不恶秽好乐净洁少于疾病。须菩提。以是行类相貌。当知是名阿鞞跋致菩萨摩诃萨。复次须菩提。常人身中有八万户虫侵食其身。是阿鞞跋致菩萨摩诃萨身无是虫。何以故。是菩萨功德过出世间。以是故是菩萨无是户虫。是菩萨功德增益。随其功德得身清净得心清净。须菩提。以是行类相貌。当知是名阿鞞跋致菩萨摩诃萨。须菩提白佛言。世尊。云何菩萨摩诃萨得身清净得心清净。佛言。菩萨摩诃萨随其所得增益善根。灭除心曲心邪。须菩提。是名菩萨摩诃萨身清净心清净。以是身心清净故。能过声闻辟支佛地入菩萨位中。须菩提。以是行类相貌。当知是名阿鞞跋致菩萨摩诃萨。复次须菩提。菩萨摩诃萨不贵利养。虽行十二头陀。不贵阿兰若法。乃至不贵但三衣法。须菩提。以是行类相貌。当知是名阿鞞跋致菩萨摩诃萨。复次须菩提。菩萨摩诃萨常不生悭贪心。不生破戒心嗔动心懈怠心散乱心。不生愚痴心。不生嫉妒心。须菩提。以是行类相貌。当知是名阿鞞跋致菩萨摩诃萨。复次须菩提。菩萨摩诃萨心住不动。智慧深入一心。听受所从闻法及世间事。皆与般若波罗蜜合。是菩萨摩诃萨不见产业之事不入法性者。是事一切皆见。与般若波罗蜜合。以是因缘故。须菩提。是名阿鞞跋致菩萨阿鞞跋致相

【论】问曰。上来处处说阿鞞跋致相。今何以复问。答曰。上虽处处略说今欲广说。此中多是阿鞞跋致相故。名阿鞞跋致相品。复次上来解般若波罗蜜相。次说魔因缘坏般若波罗蜜相。今说信受般若波罗蜜者。是阿鞞跋致。欲说其相貌。故须菩提问。复次菩萨初发心来。所行因缘所得果报。是阿鞞跋致。受记必当作佛。如人受职已得印信心无复疑。又如声闻人所行众行皆为四沙门果。阿鞞跋致是决定安隐地。过凡夫不入二乘地。虽未成佛道能为世间作福田。是事微妙难得。故须菩提问其行貌。佛本命须菩提说般若波罗蜜故须菩提问。世尊阿鞞跋致有何行类相貌。问曰。是三事有何等异。答曰。有人言是三事皆一义。以此知是阿鞞跋致非阿鞞跋致。有人言。行名是阿鞞跋致。菩萨身口意业异于他人。以此行表阿鞞跋致甚深智慧。类者分别知诸菩萨是阿鞞跋致非阿鞞跋致。相貌者除行类余种种因缘。得知阿鞞跋致相。佛说义趣若菩萨能具足五波罗蜜。深入般若波罗蜜方便力故。不着般若波罗蜜。但观如。所谓诸法实相。菩萨尔时不以凡夫二乘地为下贱。不以佛地为高贵。入诸法如故。诸法如中无有分别二法。但以如入如更无余事。亦不分别取相。何以故。如平等故能如是。入者即入诸佛法藏心不生疑。更求诸法决定相。是故经说。须菩提凡夫地。乃至佛地如相中无二无别。得如是法名阿鞞跋致行类相貌。复次略说是义。菩萨因诸法如。所谓毕竟空。舍一切世间事亦不住毕竟空。何以故得诸法毕竟清净实相故。菩萨若闻是无依止法。心无疑悔不念依止。自上事是阿鞞跋致正体。自是以下尽是毕竟空行果。得毕竟空故心淳熟。寂灭相不说无益语。所说常是法不是非法。所说皆实非妄语。所言柔软不粗穬。皆以慈悲心说不以嗔恚心。所说应时常得机会。观察人心随其方俗。今此中略说利益之言。若教佛道若二乘若人天道。若今世得非罪乐。常远离口四恶故。于众生中慈悲心大故。又能自摧薄诸烦恼故。是以能种种因缘说诸利益语。问曰。声闻人直趣涅槃。可不观他人。菩萨视众生如子常欲教化。云何不观其长短。答曰。若众生不可伏折不可化度。如是等莫观。何以故若以好心教诏。则谓嫉己如刀刺心。既无所益更增其罪。是故不观长短。复次菩萨应作是念。如诸佛一切智烦恼习尽。尚不能尽度众生。何况我未得菩萨神通。未得无碍智。云何能普观众生。阿鞞跋致有得神通者有不得者。得阿鞞跋致已别修神通道乃得。若先得神通者不具足故不能遍观。问曰。须菩提初问行相类。佛何以不即答无行相类。今此中方说。答曰。初问时众生未着阿鞞跋致相故。佛答或说空相或说有相。今以众生着阿鞞跋致相。欲从凡夫入阿鞞跋致地。是故佛说一切无行无类无相貌。须菩提更问。若诸法尽空者。何以言于何法转名不转法。应当从凡夫地转于佛地不转。佛答若菩萨能观色等诸法空无所有。转诸着心故。于佛道中不转。色等法和合因缘生菩萨。知是有为过罪故。不应此中住。诸法空故能转着心。转着心故名不转。复次阿鞞跋致菩萨入正位故。心决定不疑。一切外道中有实智。若有实智。不名外道。如是名阿鞞跋致相。问曰。今说不生疑。后说深法不疑。是二不疑有何差别。答曰。今不疑者四谛中如须陀洹所断。后不疑者于佛所知深法中不疑。是菩萨福德智慧力故。虽不作须陀洹未作佛。而能无此二疑。戒取名外道戒行此外道戒不得涅槃。余四见皆名邪见。深信业因缘果报故不求吉事。不以华香等供养天。求道破憍慢根本故。常不生下贱家。不障他功德常行劝助故。不生八难处。折薄淫欲远离谄媚心故。不受女人身。复次余人虽行十善道。或一或二或三不能具足四种。是菩萨大悲心深爱善法故。具足行四种。常修集十善道故。乃至梦中不行十不善道。余人所修福德但自为身。小菩萨虽为众生亦自为己。阿鞞跋致诸所作福皆为众生不为其身。若福德可以与人则尽与众生。更自修习但不可得与。故菩萨以十二部经教化众生。亦但为众生不自为己

复次菩萨信等五根利故。虽未作佛于诸法能信佛。此中更说空因缘。菩萨不见色等法故无生疑处。复次是菩萨常行慈悲心故意业柔软。意业柔软故身口慈业成就。问曰。慈悲心外道亦有。云何说是阿鞞跋致相。答曰。外道虽有而不深。不能遍念众生亦不常有。非诸法实相和合故。菩萨不尔。复次是菩萨呵五欲除五盖入五支初禅。不与五盖俱。五盖覆心能耗减智慧破佛道开魔路。故是菩萨知一切有为作法虚妄不实如幻如梦无为法空无所有寂灭相。是故于一切处无所爱着。于众生中乃至佛亦不着。于法中乃至涅槃亦不着。嗔粗罪小菩萨已断故不说。爱深微难断故今说。复次是菩萨深入禅定故。守护一切众生守护一切众生故。常一心念不恼众生。不破戒故出入来去等安详。一心举足下足视地而行者。为护众生为避乱心故。复次是菩萨久修集无量无边善法。身中无八万户虫。亦少于病痛故衣服卧具等常净洁无污。得诸法实相等善根力故。身中无八万户虫。心清净故身口等亦清净。离虚诳邪曲等下贱烦恼故心清净。二事清净故虽行世间离诸逼迫苦恼。心不厌没故出过声闻辟支佛地。是菩萨贵佛道故不贵利养。虽行头陀不贵是法。以是法是究竟道因缘少分非究竟道。是名阿鞞跋致菩萨行类相貌。问曰。是菩萨未得佛道。未断诸烦恼。云何常不生悭贪等诸恶心。答曰。阿鞞跋致菩萨得无生法忍时断诸烦恼。但未断习。若不断者云何常能不生诸悭贪等障道心。如经说须陀洹乃至阿罗汉。即是菩萨无生法忍。复次有人言。菩萨行六波罗蜜。深修集诸功德故。诸烦恼折薄心中不生故。是名常不生。复次是菩萨无量世行禅波罗蜜故心住不动。积习般若故深入智慧。是菩萨知法味微妙故。从他闻法一心听受乐法情深故。所闻若三乘法若外道及世间法。自心妙故皆与般若和合不破法相。譬如壮夫无病所食之物无不消化。又如佛得最上味相。虽复苦辛不美之食在佛口中皆是上味。又如煮石蜜。欲熟时种种物内中皆成石蜜。妙味力盛故。菩萨亦如是。般若波罗蜜力盛故。种种诸法能令皆与般若合为一味无诸过罪。复次世间事者。菩萨所起身口诸业皆为怜愍度众生故。此怜愍心皆入般若波罗蜜初门。又复世间诸事因缘。乃至坐起行步饮食言语。常念安隐众生。是来去等法皆入法性。如破来去中说。产业之事亦如是。是名阿鞞跋致相

【经】复次须菩提。若恶魔于阿鞞跋致菩萨前化作八大地狱。一一地狱中有千万亿菩萨。皆被烧煮受诸辛酸苦毒。语菩萨言。是诸菩萨皆是阿鞞跋致。佛所授记堕大地狱中。汝若为佛授阿鞞跋致记者。当入是大地狱中。佛为授汝地狱记。汝不如还舍菩萨心。可得不堕地狱得生天上。须菩提。若是菩萨见是事闻是事。心不动不疑不惊作是念。阿鞞跋致菩萨若堕地狱畜生饿鬼中终无是处。须菩提。以是行类相貌。当知是名阿鞞跋致菩萨摩诃萨。复次须菩提。恶魔化作比丘被服来至菩萨所。语菩萨言。汝先闻应如是净修六波罗蜜。乃至应如是修行得阿耨多罗三藐三菩提。是事汝疾悔舍。汝先于过去未来现在诸佛所。从初发心乃至法住。于其中间所作善根随喜。回向阿耨多罗三藐三菩提。是事汝亦疾放舍。若汝疾舍我当语汝真佛法。汝先所闻皆非佛法非佛教。皆是文饰合集作耳。我所说是真佛法。若是菩萨闻作是说心惊疑悔。当知是菩萨未得诸佛授记。未定住阿鞞跋致性中。若是菩萨心不动不惊不疑不悔。随顺依止无作无生法。不信他语不随他行。行六波罗蜜时不随他语。乃至行阿耨多罗三藐三菩提时。亦不随他语。须菩提。譬如漏尽阿罗汉。不信他语不随他行。现见诸法实相恶魔不能转。如是须菩提。阿鞞跋致菩萨摩诃萨亦如是。求声闻道辟支佛道人不能破坏不能折伏其心。须菩提。是菩萨摩诃萨必定住阿鞞跋致地中不随他语。乃至佛语不直信取。何况求声闻辟支佛人及恶魔外道梵志语。终无是处。何以故。是菩萨不见有法可随信者。所谓色若受想行识。若色如乃至识如。乃至不见阿耨多罗三藐三菩提。何况阿耨多罗三藐三菩提如。须菩提以是行类相貌。当知是名阿鞞跋致菩萨摩诃萨。复次须菩提。恶魔作比丘身来到菩萨所。语菩萨言。汝所行者是生死法。非萨婆若道。汝今身取苦尽证。是时恶魔为菩萨用世间行说似道法。是似道法三界系。所谓骨相。若初禅乃至非有想非无想。语善男子用是道用是行。当得须陀洹果。乃至当得阿罗汉果。汝行是道今世苦尽。汝用受生死中种种苦恼为。今是四大身尚不用受。何况当更受未来身。须菩提。若是菩萨摩诃萨。心不惊不疑不悔作是念。是比丘益我不少。为我说似道法。行是似道法。不得至须陀洹果证。不得至阿罗汉辟支佛道证。何况得至阿耨多罗三藐三菩提。是菩萨摩诃萨益复欢喜作是念。是比丘益我不少。为我说障道法。我知是障道法不障学三乘道。是时恶魔知菩萨欢喜作是言。善男子。汝欲见是菩萨摩诃萨。供养如恒河沙等诸佛衣被饮食卧具医药资生所须。亦于如恒河沙等诸佛所。行檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。亦亲近如恒河沙等诸佛。咨问菩萨摩诃萨道。世尊。菩萨摩诃萨云何住菩萨摩诃萨乘。云何行檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。四念处乃至大慈大悲。是菩萨摩诃萨如佛所教。如是住如是行如是修。是菩萨摩诃萨如是教如是学。尚不得阿耨多罗三藐三菩提。不得萨婆若。何况汝当得阿耨多罗三藐三菩提。若菩萨摩诃萨闻是事。心不异不惊。益复欢喜作是念。是比丘益我不少。为我说障道法。是障道法不得须陀洹道。乃至不得阿罗汉辟支佛道。何况得阿耨多罗三藐三菩提。是时恶魔知是菩萨心不没不惊。即于是处化作多比丘语菩萨言。此皆是发意求佛道菩萨。今皆住阿罗汉地。是辈尚不能得阿耨多罗三藐三菩提。汝云何能得。若菩萨摩诃萨即作是念。此是恶魔说相似道行。菩萨摩诃萨行般若波罗蜜。不应转阿耨多罗三藐三菩提心。亦不应堕声闻辟支佛道中。复作是念。行檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜乃至一切种智。不得阿耨多罗三藐三菩提。无有是处。须菩提。以是行类相貌。当知是名阿鞞跋致菩萨摩诃萨。复次须菩提。菩萨摩诃萨作是念。若菩萨能如佛所说。不远离般若波罗蜜心乃至一切种智。是菩萨终不退阿耨多罗三藐三菩提。若菩萨觉知魔事。亦不失阿耨多罗三藐三菩提。以是行类相貌。当知是名阿鞞跋致菩萨摩诃萨相。须菩提白佛言。世尊。于何法转名为不转。佛言。于色相转。于受想行识相转。于十二入相十八界相。淫欲嗔恚愚痴相。邪见相四念处相。乃至声闻辟支佛相。乃至佛相转。以是故名为不退转菩萨摩诃萨相。何以故。是阿鞞跋致菩萨摩诃萨。以是自相空法入菩萨位。得无生法忍。乃至少许法不可得。不可得故不作。不作故不生。是名无生法忍。菩萨摩诃萨以是行类相貌。当知是名阿鞞跋致菩萨摩诃萨

【论】释曰。魔了了知是菩萨是阿鞞跋致者。不复沮坏。若未了了知者。则种种因缘验试破坏。或作八大地狱。化作无数菩萨在中烧煮。语菩萨言。此皆是阿鞞跋致。诸佛授记者。汝若受记为受地狱记。问曰。恶魔何因缘故。言行善者受地狱记。答曰。恶魔以是菩萨欲代一切众生受苦故。言受地狱记。汝若行福德生天者。则自为身无豫众生事。若菩萨闻是事心动疑悔。若信受魔语。当知是未受阿鞞跋致记。若菩萨闻是事不疑不动不惊作是念。阿鞞跋致得诸法实相故不着一切法者。乃至不生小罪。何况三恶道罪。如火中有水水中生火。无有是处。复有魔作比丘被服来语菩萨。汝先从小师闻修六波罗蜜法。皆是虚妄所集。随喜心功德亦是虚诳。汝先所闻皆是虚诳。文饰不真非是佛口所说。今我为汝说者真是佛法。汝疾舍之。若是菩萨闻是心动嗔疑。当知诸佛未与受记。譬如伪金火烧磨打若黑若赤若白乃知非真。若菩萨闻是不嗔不疑。随无生无灭无起无作法。行于六波罗蜜相中。自知不随于他语。当知是真阿鞞跋致。譬如阿罗汉漏尽故诸魔事来不能破。阿鞞跋致菩萨亦如是。无能降伏者。自现前知诸法实相故。乃至魔作佛身来。所说异于法相者亦不信受。譬如狗着师子皮。诸兽见之虽怖闻声则知是狗。何况变作余身等。此中佛自说因缘。是菩萨见色等法空故。谁当随他语。复次恶魔来作比丘身语菩萨言。是六波罗蜜皆是生死道。布施等福德因缘故。欲界中受福乐。禅波罗蜜因缘故。色界中受乐。是般若波罗蜜无定相故名虚诳法。回转五道中不能自出是生死道。人诳汝言。是一切种智道。我今实语汝取涅槃今世尽苦。是菩萨若默然。魔即为说似道法。若观三十六种不净。若观骨人若出入息。因是道得四禅四无色定。汝因是禅定可得须陀洹乃至阿罗汉。汝今此身是罪因缘所生。佛说弹指顷不赞更受身。何况久住生死中。阿鞞跋致菩萨。闻是事心喜作是念。是比丘大益我。为我说似道法。我得是似道法即知真道。如行路人知邪迳则知正道。障道亦如是。阿鞞跋致是大人贵重故。不与是比丘诤语。魔见菩萨默然欢喜言。是人信受我语。语菩萨言。善男子。有无量菩萨。供养如恒河沙等诸佛。咨问奉行六波罗蜜及菩萨道法。面受佛教尽受行诸菩萨行。尚不得无上道。今皆作阿罗汉。汝欲见不。菩萨闻是事已默然。魔于是处即化作无数阿罗汉比丘。语菩萨言。是诸比丘皆久行无上道。今皆取阿罗汉。汝今云何独欲作佛。阿鞞跋致即复欢喜。是比丘为我说似道障道法。是菩萨实行六波罗蜜诸功德。定不退堕二乘如佛所说。心常不离六波罗蜜等诸功德。不得无上道无有是处。菩萨若知是魔事。则大得利益而无所失。以是故菩萨心不动转。是名阿鞞跋致相。尔时须菩提白佛言。世尊。于何法转名为不转。佛言。于色相等法中转。还上略说。今广说。若菩萨于色等相皆能转。是名行一切法性空得无生法忍入菩萨位。无生法忍者乃至微细法不可得。何况大。是名无生。得是无生法不作不起诸业行。是名得无生法忍。得无生法忍菩萨是名阿鞞跋致。如是等无量行类相貌。是阿鞞跋致相

    大智度论释转不转品第五十六

【经】复次须菩提。恶魔到菩萨所。坏其心作是言。萨婆若与虚空等无所有相。诸法亦与虚空等空无有相。虚空等诸法空。无所有相中无有得阿耨多罗三藐三菩提者。亦无有不得者。是诸法皆如虚空无所有相。汝唐受勤苦。汝所闻阿耨多罗三藐三菩提。皆是魔事非佛所说。汝当放舍是。愿汝莫长夜受是不安隐忧苦堕恶道。是诸善男子善女人闻是呵时应如是念。是恶魔事坏我阿耨多罗三藐三菩提心。诸法虽如虚空无所有自相空。而众生不知不见不解。我亦以是如虚空等无所有自相空。大誓庄严得一切种智。为众生说此法令得解脱。得须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道阿耨多罗三藐三菩提。须菩提。菩萨摩诃萨从初发意已来。闻是法应坚固其心不动不转。菩萨摩诃萨以是坚固心不转不动心。行六波罗蜜。当入菩萨位中。须菩提白佛言。世尊。不转故名阿鞞跋致。转故亦名阿鞞跋致。佛言。不转故名阿鞞跋致。转故亦名阿鞞跋致。须菩提白佛言。世尊。云何不转故名阿鞞跋致。转故亦名阿鞞跋致。佛告须菩提。若菩萨摩诃萨于声闻地辟支佛地不转。是故名不转。若菩萨摩诃萨于声闻地辟支佛地转。是故亦名不转。须菩提。以是行类相貌。当知是名阿鞞跋致菩萨摩诃萨相。以是行类相貌故。恶魔不能坏其意。令离阿耨多罗三藐三菩提。复次须菩提。阿鞞跋致菩萨摩诃萨。若欲入初禅第二第三第四禅乃至灭定禅即得入。复次须菩提。阿鞞跋致菩萨摩诃萨。若欲修四念处乃至八圣道分空无相无作三昧乃至五神通即能修。是菩萨虽修四念处乃至五神通。是人不受四念处果。虽修诸禅不受诸禅果。乃至不受灭定禅果。不证须陀洹果。乃至不证辟支佛道。是菩萨故为众生受身。随其所应而利益之。须菩提。以是行类相貌。当知是名阿鞞跋致菩萨摩诃萨。复次须菩提。是阿鞞跋致菩萨摩诃萨常忆念阿耨多罗三藐三菩提。终不离萨婆若心故。不贵色不贵相。不贵声闻辟支佛。不贵檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。不贵四禅四无量心四无色定。不贵五神通。不贵四念处乃至八圣道分。不贵佛十力乃至十八不共法。不贵净佛世界。不贵成就众生。不贵见佛。不贵种善根。何以故。一切法自相空。不见可贵法能生贵心者。何以故。是一切法与虚空等。无所有自相空。须菩提。是阿鞞跋致菩萨摩诃萨成就是心。于四种身仪中。出入来去坐卧行住一心不乱。须菩提。以是行类相貌。当知是阿鞞跋致菩萨摩诃萨。复次须菩提。阿鞞跋致菩萨摩诃萨。若在居家以方便力为利益众生故。受五欲布施众生。须食与食须饮与饮。衣服卧具乃至资生所须尽给与之。是菩萨自行檀波罗蜜。教人行檀波罗蜜。赞叹行檀波罗蜜法。欢喜赞叹行檀波罗蜜者。尸罗波罗蜜乃至般若波罗蜜亦如是。须菩提。阿鞞跋致菩萨摩诃萨在家时。能以满阎浮提珍宝施与众生。乃至三千大千世界满中珍宝给施众生。亦不自为常修梵行。不凌易虏掠他人令其忧恼。须菩提。以是行类相貌。当知是名阿鞞跋致菩萨摩诃萨。复次须菩提。阿鞞跋致菩萨摩诃萨。执金刚神王常随逐作是愿。是菩萨摩诃萨当得阿耨多罗三藐三菩提。我常随逐。乃至五姓执金刚神常随守护。以是故若天若魔若梵若余世间大力者。不能破坏是菩萨摩诃萨萨婆若心。乃至得阿耨多罗三藐三菩提。须菩提。是名菩萨摩诃萨阿鞞跋致相。复次须菩提。菩萨摩诃萨常具足菩萨五根。信根精进根念根定根慧根。是名阿鞞跋致相。复次须菩提。阿鞞跋致菩萨摩诃萨。为上人不为下人须菩提白佛言。世尊。云何为上人。佛告须菩提。若菩萨摩诃萨。一心行阿耨多罗三藐三菩提心不散乱。是名上人。以是行类相貌。当知是名阿鞞跋致相。复次须菩提。阿鞞跋致菩萨。一心常念佛道。不作咒术合和诸药。不咒鬼神令着男女问其吉凶男女禄相寿命长短。何以故须菩提。是菩萨摩诃萨知诸法自相空。不见诸法相故行净命。须菩提以是行类相貌。当知是名阿鞞跋致菩萨摩诃萨相

【论】释曰。复有阿鞞跋致菩萨相。若恶魔作是言。萨婆若与虚空等。萨婆若有种种名字。或说一切智或说一切种智。或说无上道。或说无量诸佛法。或说菩提。皆是萨婆若名字。此中说萨婆若。当知是阿耨多罗三藐三菩提。一切菩萨皆愿欲得萨婆若。魔来欲坏作是言。是萨婆若空无所有。但诸师诳汝耳。如虚空无所有无色无形不可知。萨婆若亦如是。是故说与虚空等。诸法者六波罗蜜等趣萨婆若助道法。是法亦空。萨婆若亦空无所有相。是法但有名字无有实事。是中无得萨婆若者。无趣萨婆若。无有助道者。汝唐受辛苦。汝师常教汝离魔事。萨婆若即是魔事。何以故舍涅槃取生死故。汝先所闻经。若六波罗蜜义非是佛法。皆是人造。汝今疾悔舍是邪心。若不舍长夜受三恶道苦。阿鞞跋致菩萨闻是事即觉知魔事。是魔毁呰萨婆若。欲令我远离阿耨多罗三藐三菩提。何以故。一切法虽空无所有。而凡夫众生颠倒覆心故不知不见。我亦当以自相空庄严得一切智为众生说法。若一切法空我以实庄严是不相应。若诸法空庄严亦空者是则相称。为众生说法亦如是。令众生得须陀洹果。须陀洹果有二种一者三结断无为法。二者空无相无作三昧相应有为须陀洹果。是二皆空。有为法中三解脱门故空。无为法中无生无住无灭相故即是空。乃至阿耨多罗三藐三菩提亦如是。阿鞞跋致菩萨从初发意已来。闻是法坚固其心不动不转。一切诸烦恼箭不入故名为坚。一切外道魔民不能转故名不动。于阿耨多罗三藐三菩提不退故名不转。是菩萨以如是三种心。行六波罗蜜入菩萨位。菩萨位义如先说。是名入菩萨位。入菩萨位者名阿鞞跋致。须菩提问不转故名阿鞞跋致。转故名阿鞞跋致。佛二种答。以二谛故。所谓世谛第一义谛。若菩萨入菩萨位。转声闻辟支佛心。直入菩萨位是名转。不转者入阿鞞跋致第一义诸法一相中。所谓无相。尚无一乘定相。何况三乘则无所转。无所转故。名阿鞞跋致。复次阿鞞跋致虽行欲界法度众生。于禅定出入自在。于禅定自在故。若欲教化他人。修四念处乃至八圣道分三解脱门乃至五神通皆得自在。虽入禅定其心清净柔软故。不受长寿天福。于欲界教化虽修四念处道法。亦不证须陀洹果。乃至不证辟支佛道。是菩萨观十方国土。知何处有可利益众生处故。为受身生其国。如是等名阿鞞跋致相。是菩萨一心深念。常不离阿耨多罗三藐三菩提故。但贵阿耨多罗三藐三菩提不贵余事。所谓诸佛三十二相金色身。不舍本愿度众生故。不贵声闻辟支佛道。是人贵无所得毕竟空故不贵是布施。乃至不贵种善根。何况五欲世间利养。何以故菩萨观一切法。自相空不见实定法可生贵心。复次有人有所贪贵故。心动不能自安。若得则欢喜失则忧戚。菩萨无所贵无所贪故。至于得失心清净不动故。身行口行调和不异故。身四威仪一心常念无所违失。复次深入禅波罗蜜故。身四威仪无所违失。是阿鞞跋致菩萨相。问曰。经中说阿鞞跋致菩萨方便力。为利益众生故受五欲。是何等方便。答曰。譬如以钳取火虽捉而不烧。五欲如火能烧人善根。是菩萨思惟我出家一身。云何能以布施摄众生。众生多须饮食衣服须法者少。菩萨为摄众生故。故生富贵家布施众生恣其所须。出家在家众生能广利益。譬如大地人民鸟兽皆蒙利润。是时四种行六波罗蜜。若出家赞布施或有人言汝自一身无财。但教人施则不信受。是故菩萨方便作白衣。以财充满一切而劝行施人则信受是菩萨。或作转轮圣王。心念施时则满阎浮提珍宝。如顶生王宫殿中心生欲宝则宝至于膝。或作帝释或作梵王。能雨珍宝满三千世界供养于佛。充满一切为摄众生故而自不受。人受五欲则心生憍慢凌易于人。是人常断淫欲故。诸烦恼薄不生憍慢。不生憍慢故。不凌易众生。是名阿鞞跋致相。复次若菩萨得无生法忍入菩萨位得受记。即时执金刚神王等法。应随逐守护。得佛道时则现其身时令人见。此中自说因缘。若人若非人无能破坏。人破者若杀若缚若论议得胜等。非人破者与病令狂。若夺命若作恶身令其恐怖。若变作佛身说邪道。如是等不能折伏菩萨。问曰。若为金刚神王所守护者。菩萨自无有力。答曰。菩萨亦自有力。复以菩萨功德故。能使金刚神所守护。金刚神所守护故。虽未得法身而功德增益。又使天神见金刚神侍卫故益加敬畏。具足菩萨根者。如人无眼等五情根则无异木石五情力故能见能闻。菩萨心中无信等五根。即是凡夫不入圣数。问曰。如阿毗昙经说。谁成就五根。答曰不断善根者。今何以言无信等五根即是凡夫。答曰。不断善根众生。虽成就五根而不能发起为用。譬如小儿虽成就烦恼淫欲等。未能发用故言无信等五根亦如是。众生虽有。不发不用是故不数。信等五根有二种。一者属声闻辟支佛。二者属佛诸菩萨。属声闻辟支佛道五根。能深信涅槃能以智慧。知世间无常空。能知涅槃寂灭。菩萨五根能生深慈悲心。于怨恶众生亦能观诸法实相。所谓无生无灭等。虽未得佛亦能信受佛事。复有以菩萨根故能见能闻能知。诸佛神通力非诸声闻辟支佛所及。如不可思议解脱经中说。舍利弗目连须菩提等。虽在佛左右。以无菩萨根故。不见是大菩萨会及所有神通力。亦不闻佛说不可思议解脱。是故说若菩萨具足得是信等五根故名阿鞞跋致。问曰。余经中说善人身口意业无恶知恩报恩。能为一切众生故。自舍身乐安隐众生。有所利益不求果报。如是等上人相。何以故。但说不散乱心行无上道一事名为上人。答曰。此中佛自略说。一心不散乱尽摄诸善法。何以故贪重佛道故。一切诸烦恼折薄。是故于众生深加慈心。能自以身命给施。何况不知报恩等。常一心念阿耨多罗三藐三菩提。清净持戒故不行邪命。所谓不作祝术合药。祝术者能翳身令人不见。能变人为畜兽。如是等种种祝术。合药者饵食求仙。亦合和诸药疗疾求财。及求名声。祝鬼者有人欲知未来事。祝鬼令着男女。问其吉凶生男生女寿命修短丰乐胜负等。若有作者为摄众生。破其憍慢不为财利名闻。何以故。是人知一切诸法自相空故不见诸法相。所谓己身妻子男女等。不见是相故不行邪命

大智度论卷第七十三大智度论释转不转品第五十六之余(卷七十四)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】复次须菩提。今当更说阿鞞跋致菩萨摩诃萨行类相貌。一心谛听。佛告须菩提。菩萨摩诃萨行般若波罗蜜。常不离阿耨多罗三藐三菩提心故。不说五众事。不说十二入事。不说十八界事。何以故。常念观五众空相十二入十八界空相故。是菩萨摩诃萨不好说官事。何以故。是菩萨诸法空相中住。不见法若贵若贱。不好说贼事。何以故。诸法自相空故。不见若得若失。不好说军事。何以故。诸法自相空故。不见若多若少。不好说斗事。何以故。是菩萨摩诃萨住诸法如中。不见法若憎若爱。不好说妇女事。何以故。住诸法空中。不见好丑故。不好说聚落事。何以故。诸法自相空故。不见法若合若散。不好说城邑事。何以故。住诸法实相中。不见有胜有负。不好说国事。何以故。住实际中不见法有所属有不属。不好说我事。何以故。法性中住不见法是我是无我。乃至不见知者见者。如是等不说种种世间事。但好说般若波罗蜜。不远离萨婆若心。若行檀波罗蜜时不为悭贪事。行尸波罗蜜时不为破戒事。行羼提波罗蜜时不为嗔诤事。行毗梨耶波罗蜜时不为懈怠事。行禅波罗蜜时不为散乱事。行般若波罗蜜时不为愚痴事。是菩萨虽行一切法空而乐法爱法。是菩萨虽行法性。常赞不坏法而爱乐善知识。所谓诸佛及菩萨声闻辟支佛。诸能教化令乐住阿耨多罗三藐三菩提者。是人常愿欲见诸佛。闻在所处国土中有现在佛。随愿往生。如是心常昼夜行。所谓念佛心。如是须菩提。阿鞞跋致菩萨摩诃萨。行初禅乃至非有想非无想处。以方便力故起欲界心。若众生能行十善道者。及现在有佛处在中生。如是行类相貌。当知是为阿鞞跋致菩萨摩诃萨

复次须菩提。阿鞞跋致菩萨摩诃萨。行般若波罗蜜时。住内空外空乃至无法有法空。住四念处乃至空无相无作解脱门。于自地中了了不疑。我是阿鞞跋致非阿鞞跋致。何以故。乃至不见少许法。于阿耨多罗三藐三菩提中。若转若不转。须菩提。譬如人得须陀洹果。住须陀洹地中自了知终不疑不悔。阿鞞跋致菩萨摩诃萨亦如是。住阿鞞跋致地中终不疑。住是地中净佛世界成就众生。种种魔事起即时觉知。亦不随魔事破坏魔事。须菩提。譬如有人作五逆罪。五逆罪心乃至死时常逐不舍。虽有异心不能障隔。须菩提。阿鞞跋致菩萨摩诃萨亦如是。自住其地心常不动。一切世间天人阿修罗不能动转。何以故。是菩萨摩诃萨出一切世间天人阿修罗上。入正法位中自证地中住。具足诸菩萨神通。能净佛世界成就众生。从一佛界至一佛界。于十方佛所殖诸善根。亲近咨问诸佛。是菩萨如是住。种种魔事起觉而不随。以方便力处魔事着。实际中自证地中不疑不悔。何以故。实际中无疑相故。知是实际非一非二。以是因缘故。是人乃至转身。终不向声闻辟支佛地。是菩萨摩诃萨诸法自相空中。不见法若生若灭若垢若净。须菩提。是菩萨摩诃萨乃至转身亦不疑。我当得阿耨多罗三藐三菩提若不得。何以故。须菩提。诸法自相空。即是阿耨多罗三藐三菩提。须菩提。是菩萨摩诃萨住自证地中。不随他语无能坏者。何以故。是阿鞞跋致菩萨摩诃萨。成就不动智慧故。须菩提。以是行类相貌。当知是名阿鞞跋致菩萨摩诃萨。复次须菩提。是菩萨摩诃萨。若恶魔作佛身来语菩萨言。汝今于是间取阿罗汉道。汝亦无阿耨多罗三藐三菩提记。汝亦未得无生法忍。汝亦无是阿鞞跋致行类相貌。亦无是相得受阿耨多罗三藐三菩提记。须菩提。若菩萨摩诃萨闻是语。心不异不没不惊不畏。是菩萨应自知。我必从诸佛受阿耨多罗三藐三菩提记。何以故。诸菩萨以是法受记。我亦有是法得受记。须菩提。若恶魔若为魔所使。作佛形像来。与菩萨受声闻辟支佛记。须菩提。是菩萨作是念。是恶魔若为魔所使。作佛形像来语。佛不应教菩萨远离阿耨多罗三藐三菩提。教住声闻辟支佛道。须菩提。以是行类相貌。当知是名阿鞞跋致相。复次须菩提。恶魔作佛身来到菩萨所作是言。汝所学经书非佛所说。亦非声闻说。是魔所说。须菩提。是菩萨摩诃萨当作是知。是恶魔若魔所使。教我远离阿耨多罗三藐三菩提。须菩提当知。是菩萨已为过去佛所受记。住阿鞞跋致地。何以故。诸菩萨所有阿鞞跋致行类相貌。是菩萨亦有是行类相貌。是名阿鞞跋致菩萨相。复次须菩提。阿鞞跋致菩萨摩诃萨。行般若波罗蜜时。为护持诸法故不惜身命。何况余物。是菩萨护持法故作是念。我不为护持一佛法故。我为护持三世十方诸佛法故。须菩提。云何菩萨摩诃萨。护持佛法故不惜身命。须菩提。如佛说一切诸法真空。是时有愚痴人破坏不受。作是言。是非法非善非世尊教。须菩提。菩萨护持如是法故不惜身命。菩萨亦应作是念。未来世诸佛我亦在是数中在中受记。是法亦是我法。以是故不惜身命。须菩提。菩萨见是利益故。护持是法不惜身命。须菩提。以是行类相貌。知是阿鞞跋致相。复次须菩提。阿鞞跋致菩萨摩诃萨。闻佛说法不疑不悔。闻已受持终不忘失。何以故。得陀罗尼故。须菩提言。世尊。得何等陀罗尼。闻佛所说诸经而不忘失。佛告须菩提。菩萨得闻持等陀罗尼故。闻佛说诸经不忘不失不疑不悔。须菩提白佛言。世尊。但闻佛说法。不忘不失不疑不悔。声闻辟支佛说。天龙鬼神阿修罗紧那罗摩睺罗伽说。亦复不忘不失不疑不悔耶。佛告须菩提。所有言说众事。得陀罗尼菩萨皆不忘不失不疑不悔。须菩提。如是行类相貌成就故。当知是阿鞞跋致菩萨摩诃萨

【论】释曰。佛更欲细说阿鞞跋致相故告须菩提一心谛听。是菩萨常不离阿耨多罗三藐三菩提。乐行毕竟空故。不喜说分别五众十二入十八界决定相。又不喜说国王等事。如余外道受他供养无正道故虚妄深着。心懈怠故说诸国事。分别过去世诸王力势等乐。阿鞞跋致菩萨不说是事。见一切世间常为无常火烧。众生可愍。我未得佛道。我但应说度众生法。不应说余事。一切法毕竟空故。大小相不可得。贼等事亦如是。毕竟空即是如法性实际。行六波罗蜜不说六弊。菩萨虽安住一切法空中。而乐法爱法。何以故是菩萨不着是一切法空故。又我行次第法禅定智慧等。然后得一切法空。此空不可但口说而心着。是故先行次第法。复次法性中不分别诸法故。法性非破坏相。是菩萨不着法性。怜愍众生为种种分别善不善法等。令众生得解。虽为众生如是说。亦常赞叹不坏法引导众生。令入法性中故。复次阿鞞跋致菩萨更无亲善。但以诸佛及大菩萨诸能赞叹实相法者为亲善。是人功德智慧大故随意所往。若欲至诸佛世界随意得生。是菩萨虽离欲得诸禅定。以方便力故为众生生欲界。有现在佛处生欲界者故。为众生留爱慢分。不以此禅定果报生色无色界。但以禅定柔和其心不受其报。复次是菩萨安住内空等诸空中。安住者深入通达。心无所著故不生疑。我是阿鞞跋致非阿鞞跋致。自心中深入智慧故。是名自地证。又是人不见一切法若转若不转。是故不生疑。疑名取相有所得。如人夜见树杌寻复生念。人形亦尔便生疑心。若取此二相故名疑。菩萨行无相三昧故。于一切法中不取相则无生疑处。此中佛说譬喻。如须陀洹从无始世来。未得是无漏智慧。三结断故即自知得无漏法。于四谛中定心不疑若苦若乐。阿鞞跋致亦如是。从无始世来未得诸法实相。所谓阿鞞跋致地得时亦不生疑。诸生疑者见违失事。不如本所闻故。是菩萨于一切法毕竟空故。不得是不如所闻法疑。无住处故无疑。自知此是究竟道。不可论不可破。住是地中教化众生净佛世界。亦能以方便力故破种种魔事。是阿鞞跋致法常随逐菩萨乃至成佛。此中佛说二譬喻。一者须陀洹二者五逆。是二心厚重故不可却。须陀洹心常不却。五逆心罪毕乃除。如人着衰鬼常随逐。阿鞞跋致心复过于是。阿鞞跋致心一切无能动转者。种种苦事逼迫不能动。种种供养利乐因缘。不能令舍实相心及慈悲心。上来种种说阿鞞跋致相貌。今说其行事。所谓教化众生净佛世界。从诸佛所新种善根。从一佛咨问诸佛诸深法要及种种度众生门。十方种种魔事起而不随逐。以方便力观是魔事。如佛法观诸魔身如佛无异。所以者何。一切法及实际同一相。所谓无相故是人转身。亦不向声闻辟支佛地。何以故。是菩萨初得阿鞞跋致地时知一切法实相空。转身心亦不向二地。心不自疑。若得无上道若不得。是菩萨世世无人能降伏破坏者。佛为验是菩萨故作譬喻。若魔作佛身来欲诳试是菩萨语言。汝可今世取阿罗汉。汝无阿鞞跋致相可得佛道。无生忍法即是无一切法。是中云何可得忍。若菩萨闻是心不退没。是菩萨自知必从诸佛受记。何以故。我有无生法忍。闻是魔事心不怖畏故。复次恶魔知菩萨欢喜。与授声闻辟支佛道记。若今世得阿罗汉。后世得辟支佛道。若菩萨不随此变化佛身语。觉知是魔若魔所使。何以故。身是而言非。如试金钱。弹之声出则知其真伪。若佛与菩萨受声闻辟支佛记终无是处。所以者何。诸佛种种方便。欲令一切人尽入佛道。云何引菩萨与声闻记。复次魔作佛身语菩萨言。汝所行经书尽是魔所说。是菩萨觉知是魔事。当知是菩萨已得受记安住阿鞞跋致中。复次阿鞞跋致菩萨深爱乐法故。闻即心深衣毛皆竖。念佛大悲则欢喜悲泣。或于甚深法中生大欢喜。当知是阿鞞跋致。譬如大军退败则怖懅迷闷卧地似死。亲族见之欲知活不以杖鞭之。若瘾疹起者则知必活。菩萨亦如是。皆是肉身。何以故知必能成佛。若闻说佛法身中相现。衣毛为竖颜色相异。余人闻不入心。则无异相如死人无异。是菩萨深爱法故能舍身命为法。若佛若佛弟子。于大会种种因缘说诸法毕竟空。有一狂人取音声名字相。着是毕竟空出其过罪。若诸法尽毕竟空。则无佛无法无罪福业因缘。亦无修行精进得道果报。如是等出无量过罪。阿鞞跋致菩萨观察筹量。知说法有无著心。随佛语怜愍故说。知狂人着语言取相破是毕竟空。尔时阿鞞跋致则没命佐助言。是狂人言是邪见人。自没邪见亦多化众人令堕邪见坏灭佛法。深怀嗔恨故或自杀或使弟子杀。尔时菩萨若死事至为佐法故。不以怖畏而坏诸法性。此中佛说因缘。菩萨作是念。未来世佛我亦在是数中。是法亦是我法。是我法故不惜身命而守护之。作是思惟。我无量世中为烦恼邪见故丧身无数。今为十方三世诸佛法佐助发起。若有益而死胜无益而生。如是等为法故不惜身命。复次是菩萨未成佛道。从佛闻甚深法能尽受。不失信力故能受。闻持陀罗尼力故不失。断疑陀罗尼力故不疑。须菩提问。但闻佛语能信持不疑。闻余语亦尔。佛言一切有所说者皆能持。若二乘天龙等所说。有道理能信持不疑。无道理者持之无疑而不信。复次有人言。信是邪法不疑不善是善。有人言。诸天龙二乘所说皆是佛法。是阿鞞跋致相。闻则能持无疑无悔。是菩萨虽未作佛。于诸法实相中都无有疑。如是等行类相貌。是阿鞞跋致菩萨。问曰。得何事来名阿鞞跋致。答曰。阿毗昙毗婆沙中说。过三阿僧祇劫后。种三十二相因缘。从是以来名阿鞞跋致。毗泥阿波陀那中说。从见然灯佛。以五茎花散佛。以发布地。佛为授阿鞞跋致记。腾身虚空以偈赞佛。从是已来名阿鞞跋致。此般若波罗蜜中。若菩萨具足行六波罗蜜。得智慧方便力。不着是毕竟空波罗蜜。观一切法不生不灭不增不减不垢不净不来不去不一不异不常不断非有非无。如是等无量相待二法。因是智慧观破一切生灭等无常相。先因无常等故破常等倒。今亦舍无生无灭等舍无常观等。于不生不灭亦不着。亦不堕空无所有中。亦知是不生不灭相不得不着故。亦信用是不生不灭法。三世十方诸佛真智慧中信力故通达无碍。是名菩萨得无生忍法入菩萨位。名阿鞞跋致。是菩萨虽从初发心以来名阿鞞跋致。阿鞞跋致相未具足故不与授记。何以故。外道圣人诸天小菩萨等作此念。佛见是人有何等事而与授记。是人于佛道因缘中未住。云何与授记。是故佛未与授记。是菩萨有二种。一者生死肉身。二者法性生身。得无生忍法断诸烦恼。舍是身后得法性生身。肉身阿鞞跋致亦有二种。有于佛前得授记。有不于佛前授记。若佛不在世时得无生法忍。是不于佛前授记。问曰。若尔者有人读诵说正忆念。随顺无生法忍义。是人未得禅定。或生疑心或为着心所牵。如是人比是何等菩萨为是阿鞞跋致不。答曰。是人不名为阿鞞跋致。阿鞞跋致菩萨。于甚深佛法中尚无疑。何况无生忍初法门。是未得阿鞞跋致者有二种。一者信少疑多。二者疑少信多。疑多信少者于读诵经人小胜。信多疑少者若得禅定即时得柔顺忍。未断法爱故或生着心或还退没。是人若常修习此柔顺忍。柔顺忍增长故断法爱。得无生忍入菩萨位。略说阿鞞跋致相义

    大智度论释灯炷品第五十七

【经】须菩提白佛言。世尊。是阿鞞跋致菩萨摩诃萨大功德成就。世尊。是阿鞞跋致菩萨摩诃萨。无量功德成就。无边功德成就。佛告须菩提。如是如是。是阿鞞跋致菩萨摩诃萨。大功德成就。是阿鞞跋致菩萨摩诃萨。无量无边功德成就。何以故。是菩萨摩诃萨。得无量无边智慧。不与一切声闻辟支佛共故。阿鞞跋致菩萨住是智慧中。生四无碍智。得是无碍智故。一切世间天及人无能穷尽。须菩提白佛言。世尊。佛能以如恒河沙等劫。叹说阿鞞跋致菩萨摩诃萨行类相貌。须菩提言。世尊。何等是深奥处。阿鞞跋致菩萨摩诃萨。住是中行六波罗蜜时。具足四念处。乃至具足一切种智。佛赞须菩提。善哉善哉。须菩提。汝能为阿鞞跋致菩萨摩诃萨问是深奥处。须菩提。深奥处者空是其义。无相无作无起无生无染离寂灭如法性实际涅槃。须菩提。如是等法是为深奥义。须菩提白佛言。世尊。但空乃至涅槃是深奥。非一切法深奥耶。佛言。一切法亦是深奥义。须菩提。色亦深奥。受想行识亦深奥。眼亦深奥。乃至意色乃至法眼界乃至意识界。檀波罗蜜乃至般若波罗蜜。四念处乃至阿耨多罗三藐三菩提亦深奥。世尊。云何色深奥乃至阿耨多罗三藐三菩提亦深奥。佛言。色如深奥故。色深奥。受想行识如。乃至阿耨多罗三藐三菩提如深奥故。阿耨多罗三藐三菩提深奥。世尊。云何色如深奥。乃至阿耨多罗三藐三菩提如深奥。须菩提。是色如非是色非离色。乃至识如非是识非离识。乃至阿耨多罗三藐三菩提如。非是阿耨多罗三藐三菩提。非离阿耨多罗三藐三菩提。须菩提白佛言。希有世尊。微妙方便力故。令阿鞞跋致菩萨离色处涅槃。亦令离受想行识处涅槃。亦令离一切法若世间若出世间若有诤若无诤若有漏若无漏法处涅槃。佛言。如是如是。须菩提。佛以微妙方便力故。令阿鞞跋致菩萨离色处涅槃。乃至离有漏无漏法处涅槃。须菩提。若菩萨摩诃萨如是甚深法与般若波罗蜜相应。观察筹量思惟作是念。我应如是行。如般若波罗蜜中教。我应如是学。如般若波罗蜜中说。须菩提。若是菩萨摩诃萨。能如说行如说学。如般若波罗蜜中观。具足勤精进。一念生时当得无量无边阿僧祇福德。是菩萨摩诃萨超越无量劫。近阿耨多罗三藐三菩提。何况常行般若波罗蜜。应阿耨多罗三藐三菩提念。须菩提。譬如多淫欲人与端正净洁女人共期。此女人限碍不得时往。于须菩提意云何。是人所念为在何处。世尊。是人念念常在彼女人所。恒作是念。忆想当来与共坐卧欢乐。须菩提。是人一日一夜为有几念生。须菩提言。世尊。是人一日一夜其念甚多。佛告须菩提。菩萨摩诃萨念般若波罗蜜。如般若波罗蜜中说。行是道一念顷超越劫数。亦如彼人一日一夜心念之数。是菩萨摩诃萨行般若波罗蜜远离众罪。所谓离阿耨多罗三藐三菩提罪。是菩萨摩诃萨行般若波罗蜜。一日所得善根功德。假令满如恒河沙等三千大千世界中。余功德犹亦不减于余残功德。百分不及一分。千分千亿万分乃至算数譬喻所不能及

【论】释曰。须菩提闻阿鞞跋致相时。具闻阿鞞跋致功德。心大欢喜欲赞叹阿鞞跋致功德故。白佛言。世尊阿鞞跋致成就大功德。成就无量无边功德。佛可其所赞更自说大功德等因缘。所谓阿鞞跋致菩萨。得无量无边智慧。不与声闻辟支佛共。行者要先知而后行。行已受其功德。以是故说功德因缘。由于智慧无量无边。智慧者所谓般若波罗蜜。菩萨住是般若波罗蜜中。能生四无碍智。一切法实义中。智慧无碍无障。既知义无碍已分别种种诸法名字为说义故。是名法无碍。是名字要由语言。由语言故出是种种名字。是名辞无碍。得是法无碍及辞无碍故。便乐说诸法实义。是名乐说无碍。是菩萨安住四无碍中。一切众生问难无能穷尽。如大海水不可倾竭。须菩提闻佛上二品中说阿鞞跋致具足相。入此品。佛方开四无碍门。更欲说阿鞞跋致相。是故须菩提赞佛。世尊智慧无量无边。阿鞞跋致功德亦无量无边。佛若恒河沙等劫乐说。乐说亦不可尽。阿鞞跋致相貌亦不可尽。世尊何等是阿鞞跋致深奥处。阿鞞跋致菩萨住是深奥处。能具足六波罗蜜四念处乃至一切种智。佛叹须菩提。善哉汝能为阿鞞跋致菩萨问深奥义。佛语须菩提。空等乃至涅槃是名深奥。问曰。诸有法种种细分别。人不解故有深。空无所有以何为深。答曰。非直口说名字故空。分别解诸有相。内不见有我外不见定实法。得是空已观一切法相。皆是虚诳有诸过罪。若灭诸相更不作愿生三界。此空是得道空非但口说。是故言深。复次空亦复空。若着是空则有过失。是不名深。若空从破邪见有故出是为深。若于空中亦不着空故亦深。复次观五众生灭。破常颠倒观毕竟空破生灭。何以故。空中无无常。无生灭故无生。灭有二种。一者邪见人谓世间常有故无生灭。二者破生灭故言无生灭。此中破生灭。亦不着是不生不灭故名为深。诸烦恼难除故言离欲寂灭故深。错误易真实难故。如法性实际为深涅槃。诸梵天等九十六种道所不能及故深。复次涅槃中一切得道人。入者永不复出故深。问曰。此中说空等法深。是何等空。答曰。有人言。三三昧空无相无作心数法名为定。定故能观诸法空。有人言。外所缘色等诸法皆空。缘外空故名为空三昧。此中佛说不以空三昧故空。亦不以所缘外色等诸法故空。何以故。若外法不实空。以三昧力故空者。是虚妄不实。若缘外空故生三昧者是亦不然。所以者何。若色等法实是空相。则不能生空三昧。若生空三昧则非是空。此中说离是二边说中道。所谓诸法因缘和合生。是和合法无有一定法故空。何以故。因缘生法无自性。无自性故即是毕竟空。是毕竟空从本以来空。非佛所作亦非余人所作。诸佛为可度众生故。说是毕竟空相。是空相是一切诸法实体不因内外。有是空有种种名字。所谓无相无作寂灭离涅槃等。须菩提知诸菩萨利根深着涅槃。为是菩萨故问。世尊。但涅槃甚深诸法不甚深耶。佛答。正观色等一切法得涅槃。色等诸法因涅槃故甚深。是故经中说。色等如故甚深。色等如即是正观。须菩提问。云何色等如故色等法甚深。此中佛自说深因缘。所谓如非是色非离色。譬如以泥为瓶泥非即是瓶不离泥有瓶亦不得言无瓶。须菩提知是因缘法甚深如大海无有底故赞言希有。世尊佛以微妙方便力故。令菩萨离色等诸法处于涅槃亦不着涅槃亦不住世间。是微妙方便。佛可其所说赞叹菩萨行诸法实相果报福德。告须菩提。如是甚深法与般若相应。观察筹量等一念生时。得无量无边阿僧祇福德。问曰。二乘无漏法尚无果报福德。何况大乘毕竟空观法得无量福德。而福德从大慈悲愍众生故生。如罪亦由恼害众生故得。答曰。二乘无漏心中烦恼尽故无果报福德。菩萨烦恼未尽故。应有福德果报。复次二乘于实际证故烧尽诸功德。菩萨不证更有生故便有福德。复次人于实事错谬故福德少。正行实事故得福多。如施畜生得百倍施。恶人得千倍施。善人得十万倍施。离欲人得十亿万倍施。须陀洹等诸圣人得无量福。凡夫人虽离欲行慈悲心。不得实法相故不得作无量福田。须陀洹虽未离欲。分别诸法实相故福田无量。诸法实相得有深浅。是故菩萨深入实相故一念中福德无量无边。此中念念福德多故说譬喻。众生心虽念念生灭。但相续生故不觉随灭。淫欲人心深着。所欲不遂情故心生忆念。取相种种分别不来因缘事。所谓彼女为心自悔不来为人遮不来。如是等多生觉观心。是心易觉知故以为譬喻。如是一念因缘事超一劫。如人服软药一岁乃差病服大力药一曰能差。菩萨亦如是。行五波罗蜜久久乃成佛者。有行般若波罗蜜疾得成佛者。复次一曰行般若波罗蜜功德。假令有形取满如恒河沙等三千大千世界中。于一日中正功德体犹故不减。于此福德百分不及一。乃至算数譬喻所不能及

【经】复次须菩提。若菩萨摩诃萨远离般若波罗蜜。如恒河沙等劫。布施三宝佛宝法宝比丘僧宝。须菩提。于意云何。是菩萨摩诃萨以是因缘故得福多不。须菩提言。世尊甚多。无量无边阿僧祇。佛告须菩提。不如菩萨摩诃萨深般若波罗蜜中一日如说修行得福多。何以故。般若波罗蜜是诸菩萨摩诃萨道。乘是道疾得阿耨多罗三藐三菩提。须菩提。若菩萨远离般若波罗蜜。如恒河沙劫供养须陀洹斯陀含阿那含阿罗汉辟支佛及诸佛。须菩提。于意云何。是菩萨摩诃萨以是因缘故得福多不。须菩提言。世尊甚多。佛言。不如是菩萨摩诃萨深般若波罗蜜如说修行一日得福多。何以故。菩萨摩诃萨行是般若波罗蜜。过一切声闻辟支佛地入菩萨位。渐渐得阿耨多罗三藐三菩提。须菩提。菩萨摩诃萨远离般若波罗蜜。如恒河沙劫行布施持戒忍辱精进禅定智慧。于意云何。是人以是因缘故得福多不。须菩提言。世尊甚多。佛言。不如是菩萨摩诃萨行般若波罗蜜如说修行一日布施持戒忍辱精进禅定智慧得福多。何以故。须菩提。般若波罗蜜是菩萨摩诃萨母故。是般若波罗蜜能生诸菩萨摩诃萨。诸菩萨摩诃萨住般若波罗蜜中。能具足一切佛法。须菩提。若菩萨摩诃萨远离般若波罗蜜。如恒河沙劫寿行法施。须菩提。于汝意云何。是人得福多不。须菩提言。甚多世尊。佛言。不如是善男子善女人深般若波罗蜜如说修行乃至一日法施得福多。何以故。须菩提。是菩萨摩诃萨不远离般若波罗蜜。则不远离一切种智。不远离一切种智。则不远离般若波罗蜜。以是故须菩提。菩萨摩诃萨欲得阿耨多罗三藐三菩提。不当远离般若波罗蜜。须菩提。若菩萨摩诃萨如恒河沙劫。远离般若波罗蜜。修行四念处乃至八圣道分内空乃至一切种智。须菩提。于汝意云何。是善男子善女人得福多不。须菩提言。世尊甚多。佛言。不如是善男子善女人。深般若波罗蜜如说一日修行。四念处乃至一切种智得福多。何以故。须菩提。若菩萨摩诃萨不远离般若波罗蜜。于萨婆若转者无有是处。须菩提。若菩萨摩诃萨远离般若波罗蜜。于萨婆若转则有是处。须菩提。以是故。菩萨摩诃萨常不应远离般若波罗蜜行。须菩提。若菩萨摩诃萨远离般若波罗蜜。如恒河沙劫寿财施法施及禅定福德。回向阿耨多罗三藐三菩提。于汝意云何。是人得福多不。须菩提言。世尊。甚多甚多。佛言。不如是善男子善女人深般若波罗蜜。如说修行乃至一日财施法施禅定福德。回向阿耨多罗三藐三菩提得福多。何以故。是第一回向。所谓般若波罗蜜回向若远离般若波罗蜜回向。是不名回向。须菩提。以是故。菩萨摩诃萨欲得阿耨多罗三藐三菩提。应方便学般若波罗蜜回向。须菩提。若善男子善女人远离般若波罗蜜。如恒河沙劫寿过去未来现在诸佛及弟子善根和合随喜。回向阿耨多罗三藐三菩提。须菩提。于汝意云何。是人得福多不。须菩提言。世尊甚多。佛言。不如是善男子善女人深般若波罗蜜如说修行乃至一日随喜善根。回向阿耨多罗三藐三菩提得福多。须菩提。以是故。菩萨摩诃萨欲得阿耨多罗三藐三菩提。应学般若波罗蜜中方便回向阿耨多罗三藐三菩提。须菩提白佛言。世尊。如佛所说。因缘起法从妄想生非实。云何善男子善女人得大福德。世尊。用是因缘起法。不应得正见入法位。不应得须陀洹果。乃至不应得阿耨多罗三藐三菩提果。佛告须菩提。如是如是。须菩提。用是因缘起法。不应得正见入法位。乃至不应得阿耨多罗三藐三菩提。须菩提。行般若波罗蜜菩萨摩诃萨。知因缘起法亦空无坚固虚诳不实。何以故。须菩提。是菩萨摩诃萨善学内空。乃至善学无法有法空故。是菩萨摩诃萨住是十八空。种种观作法空。即不远离般若波罗蜜。若菩萨摩诃萨如是渐渐不离般若波罗蜜。渐渐得无数无量无边福德。须菩提白佛言。世尊。无数无量无边有何等异。须菩提。无数者。名不堕数中。若有为性中若无为性中。无量者。量不可得。若过去若未来若现在。无边者。诸法边不可得。须菩提言。世尊。颇有色。亦无数无量无边。颇有受想行识。亦无数无量无边。须菩提。有因缘色亦无数无量无边。受想行识亦无数无量无边。世尊。何等因缘故。色亦无数无量无边。受想行识亦无数无量无边。佛告须菩提。色空故无数无量无边。受想行识空故。无数无量无边。世尊。但色空受想行识空非一切法空耶。须菩提。我不说一切法空耶。须菩提言。世尊。说一切法空。世尊。诸法空即是不可尽无有数无量无边。世尊。空中数不可得量不可得边不可得。以是故。世尊。是不可尽无数无量无边义无有异。佛告须菩提。如是如是。是法义无别异。须菩提。是法不可说。佛以方便力故分别说。所谓不可尽无数无量无边无著。空无想无作无起无生无灭无染涅槃。佛种种因缘以方便力说。须菩提白佛言。希有世尊。诸法实相不可说。而佛以方便力说。世尊。如我解佛所说义。一切法亦不可说。佛言。如是如是。须菩提。一切法不可说。一切法不可说相即是空。是空不可说。世尊。不可说义有增有减不。佛言。不也。须菩提。不可说义无增无减。世尊。若不可说义。无增无减檀波罗蜜亦当无增无减。乃至般若波罗蜜亦当无增无减。四念处乃至八圣道分亦当无增无减。四禅四无量心四无色定五神通八背舍八胜处九次第定。佛十力四无所畏四无碍智十八不共法。亦当无增无减。世尊。若菩萨摩诃萨六波罗蜜不增。乃至十八不共法不增者。云何菩萨摩诃萨得阿耨多罗三藐三菩提。佛言。如是如是。须菩提。不可说义无增无减菩萨摩诃萨习行般若波罗蜜。有方便力故不作是念。我增般若波罗蜜。乃至增檀波罗蜜。当作是念。但名字故名檀波罗蜜。是菩萨摩诃萨行檀波罗蜜时。是心及善根如阿耨多罗三藐三菩提相回向。乃至行般若波罗蜜时。是心及善根如阿耨多罗三藐三菩提相回向。须菩提白佛言。世尊。何等是阿耨多罗三藐三菩提。佛言。一切法如相是名阿耨多罗三藐三菩提。须菩提白佛言。世尊。何等是一切法如相。是阿耨多罗三藐三菩提。佛告须菩提。色如相受想行识如相乃至涅槃如相。是阿耨多罗三藐三菩提。是如相亦不增不减。须菩提。是菩萨摩诃萨不离般若波罗蜜。常观是如法。不见有增有减。以是因缘故。须菩提。不可说义无增无减。檀波罗蜜亦不增不减。乃至十八不共法亦不增不减。须菩提。菩萨摩诃萨以是不增不减法故。应般若波罗蜜行

【论】释曰。离般若波罗蜜恒河沙劫供养三宝。不及一日行般若。又复有人住寿如恒河沙等劫。供养须陀洹等。亦不及一日行般若。此中佛自说因缘。菩萨行般若过二地入菩萨位成无上道。又复远离般若恒河沙等劫行布施等六法。亦不及一日如所说住般若中行布施等六法。是中说胜因缘。般若是诸佛母。住是般若中能具足诸佛法(财施章)若远离般若如恒河沙等劫行法施。不及一日住般若中行法施。复次远离般若用声闻辟支佛法修行四念处如恒河沙等劫。不如一日如所说住般若中修四念处乃至一切种智。此中自说胜因缘。所谓不离般若于萨婆若转者无有是处。复次菩萨离般若如恒河沙等劫。财施法施禅定生福德回向无上道。不如一日应般若财施法施禅定生福德回向无上道。何以故。般若波罗蜜无杂毒正回向故。复次若菩萨离般若寿如恒河沙劫等。十方三世诸佛功德随喜回向无上道。不如一日应般若随喜回向。尔时须菩提难佛。如佛说一切有为法虚诳不实如幻。不能生正见入正位。云何菩萨一日福德胜。佛可其言如是如是。有为法皆虚诳不得。以虚诳法入正位得圣道。菩萨行般若波罗蜜时。所作福德知皆虚诳空无坚固。心不着是福德。是福德清净故胜余福德。如金刚虽小能摧破大山。此中佛说菩萨善学十八空。虽观空而能行诸功德。虽知涅槃无上道而怜愍众生故修集福德。虽知一切法相不可说。而为众生种种方便说法。虽知法性中无有分别一相无相。而为众生分别是善是不善是可行是不可行是取是舍是利是失等。若菩萨虽观毕竟空。而能起诸福德。是名不离般若波罗蜜行。若菩萨常不离般若波罗蜜。渐得无数无量无边功德。何以故。若菩萨初学般若时。烦恼力强般若力弱。渐渐得般若力。断诸烦恼灭诸戏论。是故得福德无数无量无边。无数无量无边义佛自分别说。所谓无数者不堕若有为性中若无为性中。三世量不可得故名无量。十方边不可得故名无边。须菩提问佛。五众颇有因缘。亦无数无量无边耶。佛答有以五众空故亦无数无量无边。须菩提问。世尊。但五众空非一切法空耶。佛答。一切法空。须菩提言。是空法即不可尽。不可尽故即是无数。无数即是无量。无量即是无边。是故空中尽不可得故名无尽。数不可得故名无数。量不可得故名无量。边不可得故名无边。四事名虽异义是一。所谓毕竟空。佛可其言如是。更自说因缘。须菩提。是空法相不可说。若不可说不名为空。佛以大慈悲心怜愍众生故方便为说。强作名字语言。令众生得解。所谓空。或说不可尽无数无量无边等。是实相不生不作故说不尽。诸圣人得诸法实相。入无余涅槃时。不堕六道数。是实相法亦不堕有为无为等诸法数中。是故说无数量名。以智慧称量好丑多少大小是非等。诸法实相中灭诸相故是故说无量。诸法实相不可量故说无边。是实相法寂灭故说无著。是实相法我我所定相不可得故说空。空故无相。无相故则无作无起。是法常住不坏故无生无灭。是法能断三界染故名无染。更不织烦恼业故名涅槃。如是等有无量名字种种因缘。说是诸法实相。尔时须菩提白佛。希有世尊。诸法实相虽不可说。而佛以方便力说。如我解佛义。非但实相不可说。一切诸法亦不可说。佛可其言而说因缘。一切法终归于空。归于空故不可说。不可说义即是无增无减。若一切法无增无减。六波罗蜜等诸善法亦无增无减。若六波罗蜜善法不增者。云何得无上道。佛可其言更为说因缘。法虽无增减而可得无上道。所谓菩萨习行般若波罗蜜方便力故。虽行檀波罗蜜。诸助道法我我所憍慢断故不作是念。我增长是六波罗蜜等法。不取内外诸法相。行是谓善法如无上道相回向。须菩提问。何等是无上道。佛答。诸法如即是无上道。须菩提问。何等是一切法。佛答。色等法乃至涅槃。是诸法如即是寂灭。相是无上道。相寂灭者不增不减不高不下。灭诸烦恼戏论。不动不坏无所障碍。菩萨以般若波罗蜜方便力故。亦能令布施等如寂灭相如是种种因缘说无上道相。若菩萨常念无上道寂灭相。令一切法皆同寂灭相。亦观不可说义。所谓不增不减相。菩萨如是疾得无上道。以不增不减不可得故

大智度论卷第七十四大智度论释灯喻品第五十七之余(卷七十五)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】须菩提白佛言。世尊菩萨摩诃萨用初心得阿耨多罗三藐三菩提。用后心得阿耨多罗三藐三菩提。世尊。是初心不至后心。后心不在初心。世尊。如是心心数法不俱。云何善根增益。若善根不增。云何当得阿耨多罗三藐三菩提。佛告须菩提。我当为汝说譬喻。智者得譬喻则于义易解。须菩提。譬如燃灯。为用初焰燋炷。为用后焰燋炷。须菩提言。世尊。非初焰燋炷。亦非离初焰。世尊。非后焰燋炷。亦非离后焰。须菩提。于汝意云何。炷为燋不。世尊。炷实燋。佛告须菩提。菩萨摩诃萨亦如是。不用初心得阿耨多罗三藐三菩提。亦不离初心得阿耨多罗三藐三菩提。不用后心得阿耨多罗三藐三菩提。亦不离后心得阿耨多罗三藐三菩提。而得阿耨多罗三藐三菩提。须菩提。是中菩萨摩诃萨。从初发意行般若波罗蜜具足十地。得阿耨多罗三藐三菩提。须菩提白佛言。世尊。何等是十地。菩萨具足已得阿耨多罗三藐三菩提。佛言。菩萨摩诃萨具足干慧地性地八人地见地薄地离欲地已作地辟支佛地菩萨地佛地。具足是地得阿耨多罗三藐三菩提。须菩提。菩萨摩诃萨学是十地已。非初心得阿耨多罗三藐三菩提。亦不离初心得阿耨多罗三藐三菩提。非后心得阿耨多罗三藐三菩提。亦非离后心得阿耨多罗三藐三菩提。而得阿耨多罗三藐三菩提。须菩提言。世尊。是因缘法甚深。所谓非初心非离初心。非后心非离后心。得阿耨多罗三藐三菩提。而得阿耨多罗三藐三菩提。佛告须菩提。于汝意云何。若心灭已是心更生不。不也世尊。须菩提。于汝意云何。心生是灭相不。世尊。是灭相。须菩提。于汝意云何。以心灭相是灭不。不也世尊。佛告须菩提。于汝意云何。亦如是住不。须菩提言。世尊。亦如是住如如住。佛告须菩提。于汝意云何。若是心如如住。当作实际不。不也世尊。佛告须菩提。于汝意云何。是如深不。世尊。甚深。须菩提。于汝意云何。但如是心不。不也世尊。离如是心不。不也世尊。须菩提。于汝意云何。如见如不。不也世尊。须菩提。于汝意云何。若菩萨能如是行。为行深般若波罗蜜不。须菩提言。世尊。若菩萨摩诃萨能如是行。为行深般若波罗蜜。须菩提。于汝意云何。菩萨摩诃萨如是行。是何处行。须菩提言。世尊。若菩萨摩诃萨如是行。为无处所行。何以故。若菩萨摩诃萨行般若波罗蜜。住诸法如中。无如是念无念处无念者。佛告须菩提。若菩萨摩诃萨如是行为何处行。须菩提言。世尊。是菩萨摩诃萨。如是行为第一义中行。二行不可得故

须菩提。于汝意云何。若菩萨第一义无念中行为行相不。不也世尊。佛告须菩提。于汝意云何。是菩萨摩诃萨坏相不。不也世尊。佛告须菩提。云何名不坏相。须菩提言。世尊。是菩萨摩诃萨。行般若波罗蜜不作是念。我当坏诸法相。世尊。菩萨摩诃萨行般若波罗蜜。未具足佛十力四无所畏四无碍智大慈大悲十八不共法。不得阿耨多罗三藐三菩提。世尊。菩萨摩诃萨以方便力故。于诸法亦不取相亦不坏相。何以故。世尊。是菩萨摩诃萨知一切诸法自相空故。菩萨摩诃萨住是自相空中。为众生故入三三昧。用三三昧成就众生。须菩提言。世尊。云何菩萨摩诃萨入三三昧成就众生。佛言。菩萨住是三三昧。见众生作法中行。菩萨以方便力故。教令得无作。见众生我相中行。以方便力故教令行空。见众生一切相中行。以方便力故教令行无相。如是须菩提。菩萨摩诃萨行般若波罗蜜入三三昧。以三三昧成就众生

【论】须菩提问佛以初心得无上道。为用后心得者。问曰。须菩提何因缘故作是问难。答曰。须菩提。上闻诸法不增不减心自生疑。若诸法不增不减。云何得无上道。复次若以如实正行得无上道唯佛能尔。菩萨未断无明等烦恼。云何能如实正行。复次须菩提。此中自说难问因缘。所谓初心不至后心。后心不在初心。云何增益善根得无上道。如是等因缘故作是问。以初心得后心得。佛以深因缘法答。所谓不但以初心得。亦不离初心得。所以者何。若但以初心得。不以后心者。菩萨初发心便应是佛。若无初心云何有第二第三心。第二第三心以初心为根本因缘。亦不但后心。亦不离后心者。是后心亦不离初心。若无初心则无后心。初心集种种无量功德。后心则具足。具足故能断烦恼习得无上道。须菩提。此中自说难因缘。初后心心数法不俱。不俱者则过去已灭不得和合。若无和合则善根不集。善根不集云何成无上道。佛以现事譬喻答。如灯炷非独初焰燋。亦不离初焰。非独后焰燋。亦不离后焰而灯炷燋。佛语须菩提。汝自见炷燋。非初非后而炷燋。我亦以佛眼见菩萨得无上道。不以初心得。亦不离初心。亦不以后心得。亦不离后心而得无上道。灯譬菩萨道。炷喻无明等烦恼。焰如初地相应智慧乃至金刚三昧相应智慧。燋无明等烦恼炷。亦非初心智焰。亦非后心智焰。而无明等烦恼炷燋尽得成无上道。此中佛更解得无上道因缘。所谓菩萨从初发心来行般若波罗蜜。具足初地乃至十地。是十地皆佐助成无上道。十地者干慧地等。干慧地有二种。一者声闻二者菩萨。声闻人独为涅槃故勤精进持戒心清净堪任受道。或习观佛三昧或不净观。或行慈悲无常等观。分别集诸善法舍不善法。虽有智慧不得禅定水。则不能得道故名干慧地。于菩萨则初发心乃至未得顺忍。性地者声闻人从暖法。乃至世间第一法。于菩萨得顺忍。爱着诸法实相亦不生邪见得禅定水。八人地者。从苦法忍乃至道比智忍是十五心。于菩萨则是无生法忍入菩萨位。见地者初得圣果。所谓须陀洹果。于菩萨则是阿鞞跋致地。薄地者。或须陀洹或斯陀含。欲界九种烦恼分断故。于菩萨过阿鞞跋致地乃至未成佛。断诸烦恼余气亦薄。离欲地者。离欲界等贪欲诸烦恼。是名阿那含。于菩萨离欲因缘故得五神通。已作地者。声闻人得尽智无生智得阿罗汉。于菩萨成就佛地。辟支佛地者。先世种辟支佛道因缘。今世得少因缘出家。亦观深因缘法成道名辟支佛。辟支迦秦言因缘亦名觉。菩萨地者。从干慧地乃至离欲地如上说。复次菩萨地。从欢喜地乃至法云地皆名菩萨地。有人言。从一发心来。乃至金刚三昧名菩萨地。佛地者。一切种智等诸佛法。菩萨于自地中行具足。于他地中观具足。二事具故名具足。问曰。何以故。不说菩萨似辟支佛地。答曰。余地不说名字。辟支佛地说辟支佛名字故

复次菩萨能分别知众生。可以辟支佛因缘度者。是故菩萨以智慧行辟支佛事。如首楞严经中文殊尸利七十二亿反作辟支佛。菩萨亦如是。满足九地修集佛法。十力四无所畏等。虽未具足以修习近佛道故名具足。以是故言十地。具足故得无上道。是诸法皆因缘和合故。非初亦不离初。非后亦不离后而得无上道。须菩提尊重是法故。叹言。世尊。是因缘法甚深。所谓过去心不灭不住而能增益得无上道。是事甚深希有难可信解。此心为住为灭耶。佛反问须菩提。于汝意云何。若心灭已更生不者。诸法虽毕竟空不生不灭。为众生以六情所见生灭法故。问心已灭更生不。须菩提言。不也世尊。何以故。心灭已云何当更生。若心灭已更生则堕常中。若心生是灭相不者。上问过去心已。今问现在心相当灭不。是故答是灭相。何以故。生灭是相待法。有生必有灭故先无今有。已有还无故。心灭相是灭不者。若心灭相即是灭耶更有灭耶。答言。不也世尊。何以故。若即是灭则一心有两时生时灭时。说无常者心不过一念时。如阿毗昙经说。有生法有不生法。有欲生法有不欲生法。有灭法有不灭法。有欲灭法有不欲灭法。生法现在一心中有二种。一者生二者欲灭生。非欲灭相。欲灭相非生。是事不然故言不也。当如是住不者。若灭相非即是灭者。应常住不。若常住即是不灭相。佛如是翻覆难。须菩提理穷故作是念。我若言灭相即是灭。则一心堕二时。若言不灭实是灭相。云何言不灭。以上二理有过故。须菩提自以所证智慧答。世尊如是住如如住。若是心如如住。当作实际不者。若说心相同如住者。如即是实际。若尔者心可即作实际不。须菩提言。不也世尊。何以故。须菩提久尊重是实际。心是虚诳法。小乘智慧力少不能观心。即作实际是故言不也。问曰。若须菩提已说是心如如。何以不得作实际。答曰。如名一切法实相心。实相亦名如。须菩提心谓凡夫六情所见。虚妄颠倒故有过。今说心相如实无咎故言如如住。今实际即是涅槃。须菩提久贵涅槃故。不能即以心为涅槃。是故言不也。复次以实际无相故。不得言心即是实际。是如深不者。以须菩提言心如如住。复言不得作实际。是故问如是甚深不。须菩提不能遍知故答言甚深。但如是心不。须菩提答言不也。世尊何以故。如是一相不二相。心忆想分别因缘生故是二相。如无所知心有所知。又复如毕竟清净故无所知。心有所觉知故离如。心亦如是。何以故一切法皆有如。云何离如而有心。佛问须菩提如能见如不。答如中无分别是知是可知。是菩萨不住如法性实际。真行深菩萨道。佛问须菩提。若如是行。能行深般若波罗蜜不。须菩提自观小乘浅薄观大乘法深故。答言如是行是为行深般若波罗蜜。尔时有未得无生法忍菩萨。闻是法则心高自谓出小乘深入大乘。佛欲破其高心故问须菩提。菩萨如是行为何处行。须菩提言。如是行为无处所行。何以故。菩萨住如中无所分别故。菩萨闻无处所行。或堕断灭中。是故佛复问须菩提。菩萨行般若为何处行。须菩提言第一义中行。第一义相者无有二相。佛语须菩提。于汝意云何。若菩萨无念行第一义。是行取相法不。须菩提言不也。世尊。何以故。一切法毕竟空无忆念即是不行相。佛问须菩提。是菩萨坏相得无相不。须菩提言不也。相从本已来无。但为除颠倒故不坏法相。佛语须菩提。若不坏相云何行无相行。须菩提言。世尊菩萨不作是念。我当破相故行般若。是菩萨未具足佛十力等诸佛法。以方便力故。不作有相不作无相。何以故。若取相是相皆虚诳妄语有诸过失。若破相则堕断灭中亦多过失。是故不取有相不取无相。取相即是有法。不取相即是无法。方便力故。离是有无二边行于中道。此中佛自说因缘。所谓知一切法自性空故。不著有无自相空。破一切法相亦自破其相。菩萨住是自相空中。起三三昧利益众生。众生于六道中种种作愿受身。有人不摄心不能修福。自放恣随意造业若堕地狱。临死时冷风逼切则愿欲得火。便入地狱等三恶道。若得为人贫穷下贱。有人摄心能折伏悭贪。行布施持戒等善行。是人生欲界人天中富乐处。有人离欲界除五盖。因信等五根得五支等诸禅则生色界。有人舍诸色相灭有对相。不念杂相故。入无边虚空处无色定等。是诸所作皆是邪愿。何以故。久久皆当破坏堕落。譬如以绳系鸟绳尽复还。菩萨以是无作三昧断众生作愿。又复是身皆空。但有筋骨五藏。血涂皮裹不净充满风随心动作。是心生灭不住。如幻如化无定实相。众生见是来去语言诸相故。谓有人有我有我所起颠倒心。但忆想分别故有是错谬。菩萨以空三昧断众生我我所心令住空中。又复众生取诸男女色声香味好丑修短相。以取相故生种种烦恼受诸忧苦。菩萨以是无相三昧断众生诸相令住无相。问曰。若教化众生令得空便足。何用无相无作三昧。答曰。众生根有利钝。利根者闻空即得无相无作。钝根者闻空破诸法即取空相。是故说无相。若人虽知空无相。因是智慧更欲作身。是有为法有种种过患。是故不应作身。如经说离菩萨身。余身弹指顷不可乐。何况久住。是故说无作。以是因缘故具说三三昧教化众生

    大智度论释梦中入三昧品第五十八

【经】尔时舍利弗问须菩提。若菩萨摩诃萨梦中入三三昧空无相无作三昧。宁有益于般若波罗蜜不。须菩提报舍利弗。若菩萨昼日入三三昧。有益于般若波罗蜜。夜梦中亦当有益。何以故。昼夜梦中等无异故。舍利弗。若菩萨摩诃萨昼日行般若波罗蜜有益。是菩萨梦中行般若波罗蜜亦应有益。舍利弗问须菩提。菩萨摩诃萨若梦中所作业。是业有集成不。如佛说一切法如梦。以是故不应集成。何以故。梦中无有法集成。若觉时忆想分别应有集成。须菩提语舍利弗。若人梦中杀众生。觉已忆念取相。分别我杀是快耶。舍利弗。是事云何。舍利弗言。无缘业不生。无缘思不生。有缘业生有缘思生。舍利弗。如是如是。无缘业不生无缘思不生。有缘业生有缘思生。于见闻觉知法中心生。不从不见闻觉知法中心生。是中心有净有垢。以是故舍利弗。有缘故业生。不从无缘生。有缘故思生不从无缘生。舍利弗语须菩提。如佛说。一切诸业诸思自相离。云何言有缘故业生无缘不生。有缘故思生无缘不生。须菩提语舍利弗。取相故有缘业生。不从无缘生。取相故有缘思生。不从无缘生。舍利弗语须菩提。若菩萨摩诃萨梦中布施持戒忍辱精进禅定修智慧。是善根福德回向阿耨多罗三藐三菩提。是实回向不。须菩提语舍利弗。弥勒菩萨今现在前。佛授不退转记当作佛。当问弥勒。弥勒当答。舍利弗白弥勒菩萨。须菩提言。弥勒菩萨今现在前。佛受不退转记当作佛。弥勒当答。弥勒菩萨语舍利弗。当以弥勒名答耶。若色受想行识答耶。若色空答耶。若受想行识空答。是色不能答。受想行识不能答。色空不能答。受想行识空不能答。我不见是法可答。不见能答者。我不见是人授记。亦不见法可授记者。亦不见授记处。是一切法皆无二无别。舍利弗语弥勒菩萨。如仁者所说。如是为得法作证不。弥勒答舍利弗。如我所说法如是不证。尔时舍利弗作是念。弥勒菩萨智慧甚深。久行檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。用无所得故能如是说。尔时佛告舍利弗。于汝意云何。汝用是法得阿罗汉见是法不。舍利弗言。不见也。舍利弗。菩萨摩诃萨行般若波罗蜜亦如是。不作是念。是法当得授记。是法已授记。是法当得阿耨多罗三藐三菩提。如是舍利弗。菩萨摩诃萨行般若波罗蜜。不疑我若得若不得。自知实得阿耨多罗三藐三菩提

【论】问曰。舍利弗何以故梦难菩萨三三昧。答曰。以梦虚诳如狂非实见故。是三三昧是实法。又复余处说。梦中亦有三种。善不善无记。若菩萨善心行三三昧应得福德。然梦是狂痴法。不应于中行实法得果报。若有实法不名为梦。以是故问。若菩萨梦中行三三昧。增益般若波罗蜜。福德集善根近佛道不。须菩提意若言有益。梦是虚诳般若是实法。云何得增益。若言无益梦中有善。云何无益不得。答言有益无益。是故须菩提离此二边难故。以诸法实相答。尚破昼日所行。何况梦中。作是言。舍利弗。菩萨若昼日行般若有益者。夜亦应有益。而昼日无益故。何况梦中。何以故。般若波罗蜜不分别有昼夜。舍利弗闻须菩提所说。既知般若无增无减不应复难。今更因余事问梦中。须菩提若梦中所作业。是业有集成不集成者。是业实集能成果报不。是业若有实。佛常说一切法空如梦不应得集成。何以故。是梦心微弱故不能集成。昼日微弱心尚不能集成何况梦中。若梦觉已分别梦中生善不善心是应集成。须菩提语舍利弗。如人梦中杀人。觉已分别我杀是快耶。舍利弗是业云何为集成不。舍利弗语须菩提。一切业若昼若梦皆从因缘生。无因缘则不生。须菩提可其言。如是业有因缘生无因缘不生。思有因缘生无因缘不生。业者身口业思者但意业思是真业。身口业为思故名为业。是三业因四种法。若见若闻若觉若知。因此四种则心生。是心随因缘生。或净或不净。不净罪业净福业。是故若梦中所见皆因先见闻觉知。梦中所作善恶为眠覆心不自在故。无有势力不能集成果报。若是业得觉时善恶心和合故。能助成果报。须菩提意谓。梦中业实有集成。何以故。有因缘起故。昼日心梦中心无异。所以者何。皆因四种生故。舍利弗以空难须菩提。如佛说一切诸业自相离。汝云何定说。诸业有因缘生。无因缘不生。须菩提答。诸法虽空远离相。而凡夫取相。有因缘故业生。若不取相无因缘则不生。是故一切业皆从取相因缘生。故有昼日梦中无异。舍利弗复问。若菩萨梦中行六波罗蜜回向无上道。是实回向不。舍利弗难。若梦中昼日无异者。是梦中回向应当是实。又复若昼日着心取相不名为回向。何况眠睡覆心。须菩提以此二难深难答故语舍利弗。当问弥勒。问曰。弥勒何以但说空而不答。答曰。是二大弟子为利益菩萨故。分别觉梦若同若异。以佛常说一切法如梦故。若昼日行道梦中亦应行道。弥勒知见二人各有所执不能通达故。是故弥勒不答。复有人言。弥勒以是空答。舍利弗问弥勒。如所说空以此为证不。舍利弗意。若以此法为证即欲生难。云何为证若不证汝自不得不知云何能说。弥勒意。汝以涅槃为证。我以涅槃亦空无所得故不证。有人言。弥勒未具足佛法故。说言不证菩萨法。应知空无相无作法不应证。尔时舍利弗作是念。弥勒菩萨其智甚深能如是说。能知涅槃相而不取证是名甚深。此中舍利弗自说因缘。久行六波罗蜜故其智甚深。舍利弗意。弥勒次当作佛应当能答而今不答。是故佛还问舍利弗。于汝意云何。汝见用是法得阿罗汉不。舍利弗言不见。何以故。是法空无相无作。云何得见。若见即是有相。肉眼天眼分别取相故不应见。慧眼无分别相故亦不见。以是故言不见。佛言。菩萨摩诃萨亦如是。得无生忍时不作是言。见是法得授记当得无上道。虽不作是见亦不生疑。我不得无上道。如汝虽不见法亦不疑我成阿罗汉不成阿罗汉

【经】佛告须菩提。有菩萨摩诃萨行檀波罗蜜时。若见众生饥寒冻饿衣服弊坏。菩萨当作是愿。我随尔所时行檀波罗蜜。我得阿耨多罗三藐三菩提时。令我国土众生无如是事。衣服饮食资生之具。当如四天王天三十三天夜摩天兜率陀天化乐天他化自在天。须菩提。菩萨摩诃萨作如是行。能具足檀波罗蜜。近阿耨多罗三藐三菩提。复次须菩提。菩萨摩诃萨行尸罗波罗蜜时。见众生杀生乃至邪见短寿多病颜色不好无有威德贫乏财物生下贱家形残丑陋。当作是愿。我随尔所时行尸罗波罗蜜。如我得佛时。令我国土众生无如是事。须菩提。菩萨摩诃萨作如是行。能具足尸罗波罗蜜。近阿耨多罗三藐三菩提。复次须菩提。菩萨摩诃萨行羼提波罗蜜时。见诸众生互相嗔恚骂詈刀杖瓦石共相残害夺命。当作是愿。我随尔所时行羼提波罗蜜。我作佛时令我国土众生无如是事。相视如父如母如兄如弟如姊如妹如善知识皆行慈悲。须菩提。菩萨摩诃萨作如是行。能具足羼提波罗蜜。近阿耨多罗三藐三菩提。复次须菩提。菩萨摩诃萨行毗梨耶波罗蜜时。见众生懈怠不勤精进弃舍三乘声闻辟支佛佛乘。当作是愿。我随尔所时行毗梨耶波罗蜜。如我得阿耨多罗三藐三菩提时。令我国土众生无如是事。一切众生勤修精进。于三乘道各得度脱。须菩提。菩萨摩诃萨作如是行。能具足毗梨耶波罗蜜。近阿耨多罗三藐三菩提。复次须菩提。菩萨摩诃萨行禅波罗蜜时。见众生为五盖所覆。淫欲嗔恚睡眠掉悔疑。失于初禅乃至第四禅。失慈悲喜舍虚空处识处无所有处非有想非无想处。当作是愿。我随尔所时行禅波罗蜜。如我得阿耨多罗三藐三菩提时。令我国土众生无如是事。须菩提。菩萨摩诃萨作如是行。能具足禅波罗蜜。近阿耨多罗三藐三菩提。复次须菩提。菩萨摩诃萨行般若波罗蜜时。见众生愚痴失世间出世间正见。或说无业无业因缘。或说神常。或说断灭。或说无所有。当作是愿。我随尔所时行般若波罗蜜。净佛世界成就众生。如我得阿耨多罗三藐三菩提时。令我国土众生无如是事。须菩提。菩萨摩诃萨作如是行。能具足般若波罗蜜近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。见众生住于三聚。一者必正聚。二者必邪聚。三者不定聚。当作是愿。我随尔所时行六波罗蜜。净佛世界成就众生。我得佛时令我国土众生无邪聚乃至无其名。须菩提。菩萨摩诃萨作如是行。能具足六波罗蜜。近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。见地狱中众生畜生饿鬼中众生。当作是愿。我随尔所时行六波罗蜜。净佛世界成就众生。我得佛时。令我国土中乃至无三恶道名。须菩提。菩萨摩诃萨作如是行。能具足六波罗蜜近一切种智

复次须菩提。菩萨摩诃萨行六波罗蜜时。见是大地株杌荆棘山陵沟坑秽恶之处。当作是愿。我随尔所时行六波罗蜜。净佛世界成就众生。我作佛时令我国土无如是恶。地平如掌。须菩提。菩萨摩诃萨作如是行。能具足六波罗蜜近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。见是大地纯土无有金银珍宝。当作是愿。我随尔所时行六波罗蜜。净佛世界成就众生。我作佛时令我国土以金沙布地。须菩提。菩萨摩诃萨作如是行。能具足六波罗蜜。近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。见众生有所恋着。当作是愿。我随尔所时行六波罗蜜。净佛世界成就众生。我作佛时令我国土众生无所恋着。须菩提。菩萨摩诃萨作如是行。能具足六波罗蜜。近阿耨多罗三藐三菩提。复次须菩提。菩萨摩诃萨行六波罗蜜时。见四姓众生刹帝利婆罗门鞞舍首陀罗。当作是愿。我随尔所时行六波罗蜜。净佛世界成就众生。我作佛时令我国土众生无四姓之名。须菩提。菩萨摩诃萨作如是行。能具足六波罗蜜。近阿耨多罗三藐三菩提。复次须菩提。菩萨摩诃萨行六波罗蜜时。见众生有下中上生下中上家。当作是愿。我随尔所时行六波罗蜜。净佛世界成就众生。我作佛时令我国土众生无如是优劣。须菩提。菩萨摩诃萨作如是行。能具足六波罗蜜近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。见众生种种别异色。当作是愿。我随尔所时行六波罗蜜。净佛世界成就众生。我作佛时令我国土众生无种种别异色。一切众生皆端政净洁妙色成就。须菩提。菩萨摩诃萨作如是行。能具足六波罗蜜近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。见众生有主。当作是愿。我随尔所时行六波罗蜜。净佛世界成就众生。我作佛时令我国土众生无有主名。乃至无其形像。除佛法王。须菩提。菩萨摩诃萨作如是行。能具足六波罗蜜近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。见众生有六道别异。当作是愿。我随尔所时行六波罗蜜。净佛世界成就众生。我作佛时令我国土众生无六道之名。是地狱是畜生是饿鬼是神是天是人。一切众生皆同一业。修四念处乃至八圣道分。须菩提。菩萨摩诃萨作如是行。能具足六波罗蜜近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。见众生有四生。卵生胎生湿生化生。当作是愿。我随尔所时行六波罗蜜。净佛世界成就众生。我作佛时令我国土众生无三种生等一化生。须菩提。菩萨摩诃萨作如是行。能具足六波罗蜜近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。见众生无五神通。当作是愿。我随尔所时行六波罗蜜。净佛世界成就众生。我作佛时令我国土众生一切皆得五神通。乃至近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。见众生有大小便患。当作是愿。我作佛时令我国土众生皆以法喜为食无有便利之患。乃至近一切种智

复次须菩提。菩萨摩诃萨行六波罗蜜时。见众生无有光明。当作是愿。我作佛时令我国土众生皆有光明。乃至近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。见有日月时节岁数。当作是愿。我作佛时令我国土中无有日月时节岁数之名。乃至近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。见众生短命。当作是愿。我作佛时令我国土中众生寿命无量劫。乃至近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。见众生无有相好。当作是愿。我作佛时令我国土中众生皆有三十二相成就。乃至近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。见众生离诸善根。当作是愿。我作佛时令我国土中众生诸善根成就。以是福德供养诸佛。乃至近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。见众生有三毒四病。当作是愿。我作佛时令我国土中众生无四种病。冷热风病三种杂病及三毒病。乃至近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。见众生有三乘。当作是愿。我作佛时令我国土中众生无二乘之名纯一大乘。乃至近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。见众生有增上慢。当作是愿。我作佛时令我国土中众生无增上慢之名。乃至近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。应作是愿。若我光明寿命有量僧数有限。当作是愿。我行六波罗蜜。净佛世界成就众生。我作佛时令我光明寿命无量僧数无限。乃至近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。应作是愿。若我国土有量。当作是愿。我随尔所时行六波罗蜜。净佛世界成就众生。我作佛时令我一国土如恒河沙等诸佛世界。须菩提。菩萨摩诃萨作如是行。能具足六波罗蜜近一切种智。复次须菩提。菩萨摩诃萨行六波罗蜜时。当作是念虽生死道长众生性多。尔时应如是正忆念。生死边如虚空。众生性边亦如虚空。是中实无生死往来。亦无解脱者。菩萨摩诃萨作如是行。能具足六波罗蜜。近一切种智

【论】问曰。有何次第故。说菩萨见众生饥寒冻饿等。答曰。菩萨过声闻辟支佛地。得无生法忍授记更无余事。唯行净佛世界成就众生。今说净佛世界因缘。见不净世界相。愿我国土无如是事。是故次第说是事。菩萨行檀波罗蜜时。若见众生饥渴衣服弊坏。即作念言。我今福德智慧未成就。不能给足众生所须。若我但行慈悲心则于众生无益。我当尔所时深行三种福德。住三种福德中。能令贫穷众生皆得满足。若作转轮圣王。若作天王。若作神通圣人。则能多引导众生。破其坚贪令住布施。以是众生布施乃至菩萨布施因缘故。后成佛时国土中无有贫穷者。心生随意所得如欲界第六天所有诸物。菩萨如是随尔所时积集檀波罗蜜功德故充满一切。何以故。一切有为法属因缘。行善因缘具足故皆随意得果报。复次众生破尸罗波罗蜜因缘故。短命多病无有威德等。菩萨作是愿。我自具足持戒。亦教众生令持戒。余残诸愿亦如是随义分别。最后愿义不明了今当略说。菩萨作如是上愿已疲厌心起。佛道无量无数阿僧祇劫行诸功德然后可得。但一劫岁数不可得数故佛以譬喻示人。何况无量无边阿僧祇劫。经此生死受诸苦恼。众生亦无量无边非可譬喻算数所及。但以三千大千世界中微尘等众生犹尚难度。何况十方无量世界微尘等众生而可得度。以是事故或心生退没。是名邪忆念。是故佛教是菩萨正忆念。生死虽长是事皆空如虚空。如梦中所见非实长远。不应生厌心。又未来世亦是一念所缘亦非长远。复次菩萨无量福德智慧力故能超无量劫。如是种种因缘故。不应生厌心。此中佛说大因缘。所谓生死如虚空。众生亦如是。众生虽多亦无定实众生。如众生无量无边。佛智慧亦无量无边度亦不难。是故菩萨不应生疲厌心

    大智度论释恒伽提婆品第五十九

【经】尔时有一女人。字恒伽提婆。在众中坐。是女人从坐起。偏袒右肩右膝着地。合掌白佛言。世尊。我当行六波罗蜜取净佛世界。如般若波罗蜜中所说。我尽当行。是时女人以金银华及水陆生华种种庄严供养之具金缕织成叠两张。以散佛上。散已于佛顶上虚空中。化成四柱宝台端正严好。是女人持是功德与一切众生共之。回向阿耨多罗三藐三菩提。尔时世尊知是女人深心因缘。即时微笑。如诸佛法种种色光从口中出。青黄赤白红缥。遍照十方无量无边佛国。还绕佛三匝从顶上入。尔时阿难从座起。右膝着地合掌白佛。佛何因缘微笑。诸佛法不以无因缘而笑。佛告阿难。是恒伽提婆姊。未来世中当作佛。劫名星宿。佛号金花。阿难。是女人毕女身受男子形。当生阿閦佛阿毗罗提国土。于彼净修梵行。阿难。是菩萨在彼国土亦号金花。是金华菩萨于彼寿终。复至他方佛国。从一佛国至一佛国不离诸佛。譬如转轮圣王从一观至一观。从生至终足不蹈地。阿难。是金花菩萨摩诃萨亦如是。从一佛国至一佛国。乃至阿耨多罗三藐三菩提。未尝不见佛。时阿难作是念言。是金华菩萨摩诃萨后作佛时。诸菩萨摩诃萨会当知为如佛会。佛知阿难意所念。告阿难言。如是如是。是金花佛时菩萨摩诃萨会当知为如佛会。阿难。是金花佛比丘僧无量无边不可数不可数。若干百千万亿那由他。阿难。是金花菩萨作佛时。其国土无有是诸众恶如上所说。阿难白佛言。世尊。是女人从何处殖德本种善根。佛告阿难。是女人从然灯佛所种善根。初发阿耨多罗三藐三菩提心。以是功德回向阿耨多罗三藐三菩提。亦以金华散然灯佛上。求阿耨多罗三藐三菩提。阿难。如我尔时。以五华散然灯佛上。求阿耨多罗三藐三菩提。然灯佛知我善根成就。与我受阿耨多罗三藐三菩提记。是女人闻我受记发心言。我当来世亦如是菩萨。得受阿耨多罗三藐三菩提记。阿难当知。是女人于然灯佛所初发心。阿难白佛言。世尊。是女人久习行阿耨多罗三藐三菩提。佛言。如是如是。是女人久习行阿耨多罗三藐三菩提

【论】问曰。如是大众闻说净国土行。何以但一女人取净国土愿。答曰。多有发净国土愿者。但不发言。女人性轻躁好胜世世习气故发言。复次有人言。大人有得道分余人无分。佛法不然。随众生业因缘。譬如良药疗治诸病不择贵贱。虽复女人浅智。而先世业因缘应得受记。心生欲说故佛听自说。复次若佛默然与受记者人则生疑。有何因缘故独与此女受记。是故佛因其自说故而与受记。问曰。何以名为恒伽提婆。答曰。一切皆有名字为识故。何足求义。有人言是女父母。供养恒伽神得此女故。言恒伽提婆。恒伽是河名。提婆名天。是女人福德因缘生于富家闻佛法信乐故。能以金银宝华金缕织成上下衣并庄严自身璎珞具用供养上佛。佛报以受记。观是女人宿世所行便微笑。微笑义如先说。此中小因缘而起大事故佛微笑。问曰。是女福德应久转女人。何以方于阿閦佛国乃转女身。答曰。世间五欲难断。女人着欲情多故。虽世世行诸福德。不能得男子身。今得受记诸烦恼折薄。是故于阿閦佛国方得男子身。有人言此女宿世以人多轻女人故。愿女身受记。如是等因缘不转女身而得受记。复次经说女人五碍不说不得受记。是故不应生难。阿难闻是女人无量劫中从一佛国至一佛国广集功德。当来得净佛世界。其中菩萨皆有三十二相八十种随形好无量光明。是故阿难叹未曾有。能如是净佛国土。便为如佛会。佛可其言已。阿难等疑此女人希有闻少法而得大果报。是故难问是女人从何处殖诸德本。佛答定光佛授我记时。是女人持金华散佛。彼作是愿此人后成佛时。亦当受与我记。从彼种善根今得果报

大智度论卷第七十五大智度论释学空不证品第六十(卷七十六)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】须菩提白佛言。世尊。若菩萨摩诃萨欲行般若波罗蜜。云何学空三昧。云何入空三昧。云何学无相无作三昧。云何入无相无作三昧。云何学四念处。云何修四念处。乃至云何学八圣道分。云何修八圣道分。佛告须菩提。菩萨摩诃萨行般若波罗蜜时。应观色空受想行识空。十二入十八界。乃至应观欲色无色界空。作是观时不令心乱。是菩萨摩诃萨若心不乱则不见是法。若不见是法则不作证。何以故。是菩萨摩诃萨善学自相空故。不有余不有分。证法证者皆不可见。须菩提白佛言。世尊。如佛所说。菩萨摩诃萨不应空法作证。世尊。云何菩萨住空法中而不作证。佛告须菩提。若菩萨摩诃萨具足观空先作是愿。我今不应空法作证。我今学时非是证时。菩萨摩诃萨不专摄心系在缘中。是故菩萨摩诃萨于阿耨多罗三藐三菩提中不退。亦不取漏尽证。须菩提。菩萨摩诃萨如是大善妙法成就。何以故。住是空中作是念。我今是学时非是证时。须菩提。菩萨摩诃萨应如是念。我是学檀波罗蜜时。非是证时。学尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜时。修四念处时。乃至修八圣道分时。非是证时。修空三昧无相三昧无作三昧时。非是证时。修佛十力四无所畏四无碍智十八不共法大慈大悲时。非是证时。我今学一切种智时。非是得须陀洹果证乃至阿罗汉辟支佛道证时。如是须菩提。菩萨摩诃萨行般若波罗蜜。学空观住空中。学无相无作观。住无相无作中。修四念处不证四念处。乃至修八圣道分不证八圣道分。是菩萨虽学三十七品。虽行三十七品。而不作须陀洹果证乃至辟支佛道。须菩提。譬如壮夫劲勇猛健善于兵法。六十四能坚持器仗安立不动。巧诸伎术端正净洁人所爱敬。少修事业得报利多。以是因缘故。众所恭敬尊重赞叹。见人敬重倍复欢喜。少有因缘当至他处。扶将老弱过诸险难恐怖之处。安慰父母晓喻妻子莫有恐懅。我能过此必无所苦。崄难道中多有怨贼潜伏劫害。其人智力具足故。能度恶道还归本处。不遇贼害欢喜安乐。须菩提。菩萨摩诃萨亦如是。于一切众生中。慈悲喜舍心遍满足。尔时菩萨摩诃萨住四无量心。具足六波罗蜜。不取漏尽证。学一切种智。入空无相无作解脱门。是时菩萨不随一切诸相。亦不证无相三昧。以不证无相三昧故。不堕声闻辟支佛地。须菩提。譬如有翼之鸟飞腾虚空而不堕坠。虽在空中亦不住空。须菩提。菩萨摩诃萨亦如是。学空解脱门。学无相无作解脱门亦不作证。以不作证故不堕声闻辟支佛地。未具足佛十力大慈大悲无量诸佛法一切种智。亦不证空无相无作解脱门。须菩提。譬如健人学诸射法善于射术。仰射空中复以后箭射于前箭。箭箭相拄不令箭堕随意自在。若欲令堕便止后箭尔乃堕地。须菩提。菩萨摩诃萨亦如是。行般若波罗蜜以方便力故。为阿耨多罗三藐三菩提。诸善根未具足。不于实际作证。若善根成就。是时便于实际作证。以是故。须菩提。菩萨摩诃萨行般若波罗蜜时。应如是观诸法法相。须菩提白佛言。世尊。菩萨摩诃萨所为甚难。何以故。虽学是诸法相学实际学如学法性学毕竟空乃至学自相空及三解脱门。终不中道堕落。世尊。是甚希有。佛告须菩提。是菩萨摩诃萨不舍一切众生故作如是愿。须菩提。若菩萨摩诃萨作是念。我不应舍一切众生。众生没在无所有法中。我应当度。尔时即入空解脱门无相解脱门无作解脱门。须菩提当知。是菩萨摩诃萨成就方便力。未得一切种智。行是解脱门亦不中道取实际证。复次须菩提。菩萨摩诃萨欲观是诸甚深法。所谓内空乃至无法有法空。四念处乃至三解脱门尔时菩萨摩诃萨应生如是心。是诸众生长夜行我相。乃至知者见者相着于得法。为众生断是诸相故。得阿耨多罗三藐三菩提当说法。尔时菩萨行空解脱门无相无作解脱门。亦不取实际证。以不证故不堕须陀洹果乃至辟支佛道。须菩提。是菩萨摩诃萨以是心欲成就善根故。不中道实际作证。不失四禅四无量心四无色定。四念处乃至八圣道分。空无相无作佛十力四无所畏四无碍智大慈大悲十八不共法。是时菩萨摩诃萨成就一切助道法。乃至阿耨多罗三藐三菩提。终不耗减。是菩萨有方便力故。常增益善法。诸根通利胜于阿罗汉辟支佛根。复次须菩提。若菩萨摩诃萨作是念。众生长夜着四颠倒。常想乐想我想净想。为是众生故求萨婆若。我得阿耨多罗三藐三菩提时。为说无常法苦不净无我法。是菩萨成就是心。以方便力行般若波罗蜜。不得佛三昧。未具足佛十力四无所畏四无碍智大慈大悲十八不共法。亦不实际作证。尔时菩萨修无作解脱门。虽未得阿耨多罗三藐三菩提。亦不实际作证。复次须菩提。若菩萨摩诃萨作是念。众生长夜着得法。所谓我众生乃至知者见者。是色是受想行识。是入是界。是四禅四无量心四无色定。我如是行。如我得阿耨多罗三藐三菩提时。令众生无是得法。菩萨是心成就。以方便力行般若波罗蜜。未具足佛十力四无所畏四无碍智大慈大悲十八不共法。不于实际作证。尔时菩萨具足修空三昧。复次须菩提。若菩萨摩诃萨作是念。众生长夜行诸相。所谓男相女相色相无色相。我如是行。如我得阿耨多罗三藐三菩提时。令众生无是诸相过失。是心成就以方便力行般若波罗蜜。未具足佛十力乃至十八不共法。不于实际作证。尔时菩萨摩诃萨具足修无相三昧。须菩提。若菩萨摩诃萨学六波罗蜜。学内空乃至无法有法空。学四念处乃至空无相无作解脱门。学佛十力四无所畏四无碍智大慈大悲。学十八不共法。如是智慧成就。若著作法若住三界。无有是处。是菩萨摩诃萨学助道法行助道法时。应当试问。诸菩萨摩诃萨欲得阿耨多罗三藐三菩提。云何学是法。观空不证实际。以不证故不堕须陀洹果乃至辟支佛道。观无相无作无起无生无所有亦不取证。而修行般若波罗蜜。应如是问。须菩提。若诸菩萨摩诃萨。若试问时。是菩萨若如是答。菩萨摩诃萨但应观空。但应观无相无作无起无生无所有。是菩萨摩诃萨不应学空无相无作无起无生无所有。不应学是助道法。须菩提当知。是菩萨诸佛未授阿耨多罗三藐三菩提记。何以故。是人不能说阿鞞跋致菩萨所学相。不能示不能答。若是菩萨摩诃萨能说能示能答阿鞞跋致所学相。当知是菩萨摩诃萨已习学菩萨道入薄地。如余阿鞞跋致菩萨摩诃萨阿鞞跋致相。须菩提白佛言。世尊。颇有未得阿鞞跋致菩萨能如是答不。佛言有。须菩提。是菩萨摩诃萨六波罗蜜若闻若不闻。能如是答。如阿鞞跋致菩萨摩诃萨。须菩提言。世尊。多有菩萨求佛道。少有菩萨能如是答。如阿鞞跋致菩萨摩诃萨学道无学道中。佛语须菩提。如是如是。是菩萨甚少。何以故。菩萨摩诃萨少有如是得授记行阿鞞跋致。慧地若有得授记。是人能如是答。是人善根明了。诸天世人所不能坏

【论】问曰。学空入空有何差别。答曰。初名学空后是入空。因是学空。果是入空。方便名学空得名入空。如是等二道无相无作。三十七品亦如是。三解脱门三十七品是声闻辟支佛涅槃道。佛敕菩萨应行是道。须菩提作是念。此是涅槃道。云何菩萨行是道法而不取涅槃证。佛答菩萨观色等一切法空。是菩萨以深入禅定心不可乱得利智慧力故。不见是空法。以不见故无所证。声闻辟支佛断吾我舍爱着直趣涅槃。是菩萨善学自相空。色法中乃至微尘不留遗余微细之分。无色法中乃至不留一念。直入毕竟空中。乃至不见是空法可以为证。佛虽答须菩提未达佛意。更问如佛所说。菩萨不应空法作证。今入空中云何不作证。佛答以深入故能不作证。具足者即是深入。譬如执菅草捉缓则伤手若急捉则无伤。菩萨亦如是。深入空故知空亦空。涅槃亦空故无所证。复次菩萨未入空时作是思惟。我应遍观诸法空。不应不具足知而取证。是故不专心摄念入禅系在空缘中。所以者何若专心系在空缘中。则心柔软不能从空自出。问曰。上言深入禅定不令心乱。今云何言不专心。答曰。今言不专心是初入时为不能自出故。上言深入者入已深知空亦空。不令心在余事故言不乱。复次是菩萨应作是念。我今未具三十二相八十种随形好十力四无所畏诸佛法。云何取涅槃证。我今是学时。薄诸烦恼教化众生令入佛道。若我得佛事具足。是时当取证。是故菩萨虽入三解脱门而不取证。是中说譬喻。壮夫是菩萨父母亲族是可度众生。险道是三界生死。恶贼是魔民及诸烦恼。器仗是菩萨五神通等种种方便力。还归本处是菩萨所行道。安立不动是菩萨住毕竟空以四无量心运致可度众生着涅槃安乐处。时会者疑空中无所有云何可行。是故佛说鸟喻。如鸟飞虚空无所依止而远逝不坠。复次是菩萨未具足道法未至佛道。于其中间而不作证。如鸟未到所至终不中住。学是空法为自断烦恼为度众生故。又为明了故说善射譬喻。如人善于射术。弓是菩萨禅定。箭是智慧。虚空是三解脱门。地是涅槃。是菩萨以智慧箭射三解脱门虚空。更以方便力故以后箭射前箭不令堕涅槃地。未具足十力等佛事故终不取证。须菩提欢喜白佛言。诸菩萨所为甚难实为希有。所谓行空而不作证。佛答。是菩萨本愿诸一切众生令得离苦。以是本愿大悲心所持故。虽行空。不作证。复次若菩萨作是念。一切众生处在苦中。为颠倒所缚没在无所有中。是时即行空无相无作解脱门。当知是菩萨有方便力。行三解脱门而不舍众生。复次菩萨欲观甚深法。所谓十八空三十七品三解脱门。先应作是念。众生长夜着我相等。行者若直观甚深法。或得声闻道或堕邪见。以无怜愍心不能深入自相空故。是以菩萨欲观是法先生悲心。所谓众生长夜着吾我心诸烦恼。长夜名久远。无量劫来是我必不可得但空。虚诳颠倒故受诸忧恼。菩萨见是已作愿。我当为众生成佛道断是众生着我颠倒。是时即是行空等三解脱门而不证实际。是善根成就菩萨不取实际证。亦不失四禅等诸功德。菩萨深入空故诸根猛利胜于二乘。破四颠倒义亦如上说。复次菩萨作是念。众生长夜着得法。所谓我众生乃至若著作法。若住三界无有是处。义皆同观空而不取证。问曰。云何知是菩萨未得道而能行此深空。答曰。经中自说因缘。是菩萨应试问。云何菩萨应学空而不取证。若菩萨答但应念空一心习行。如声闻辟支佛法不但学知而已。乃至无生无所有亦如是。当知是菩萨未为诸佛所授记。所以者何不说方便学知故观空。若是菩萨异于上答者。当知是阿鞞跋致已习学入于薄地。学习名先学知空。薄地名阿鞞跋致地中诸烦恼薄。须菩提闻阿鞞跋致相非阿鞞跋致相已白佛言。世尊。颇有菩萨未得阿鞞跋致。能如是答不。佛言有。菩萨若闻六波罗蜜若不闻。能如阿鞞跋致答。若闻者但从师闻自未具足菩萨地。若不闻者自思惟正忆念。虽未得无生忍能求诸法相。如阿鞞跋致菩萨答。须菩提言多有人求佛道。少能如是答如阿鞞跋致菩萨学地无学地中。未得无生法忍名学地。得无生法忍名无学地。佛言少。何以故少有菩萨。从诸佛受记。已从诸佛受记者能如是答。何以故诸法实相惟佛能遍知。佛知此人能如法答故悬与受记。是菩萨虽少善根。明了能广利益众生无能坏者

    大智度论释梦中不证品第六十一

【经】佛告须菩提。若菩萨摩诃萨乃至梦中。不贪声闻辟支佛地。亦不贪三界。观诸法如梦如幻如向如焰如化亦不作证。须菩提当知。是阿鞞跋致菩萨摩诃萨阿鞞跋致相。复次须菩提。菩萨摩诃萨梦中见佛。与无数百千万亿比丘比丘尼优婆塞优婆夷天龙鬼神甄陀罗等说法。从佛闻法即解中义随法行。须菩提当知。是阿鞞跋致菩萨摩诃萨阿鞞跋致相。复次须菩提。菩萨摩诃萨梦中见佛三十二相八十随形好。大光明踊在虚空。于大比丘僧中说法现大神力化作化人。到他国土施作佛事。须菩提当知。是阿鞞跋致菩萨摩诃萨阿鞞跋致相。复次须菩提。若菩萨摩诃萨梦中见兵起若破聚落若破城邑若失火时。若见虎狼师子猛害之兽。若见欲来级其头者。若见父母丧亡兄弟姊妹及诸亲友知识死者。见如是等种种愁苦之事。不惊不怖亦不忧恼。从梦觉已即时思惟。三界虚妄皆如梦耳。我得阿耨多罗三藐三菩提时。亦当为众生说三界如梦。须菩提当知。是阿鞞跋致菩萨摩诃萨阿鞞跋致相。复次须菩提。云何当知。是阿鞞跋致菩萨摩诃萨。得阿耨多罗三藐三菩提时。国中无三恶道。须菩提。菩萨摩诃萨若梦中见地狱畜生饿鬼作是念。我当勤精进得阿耨多罗三藐三菩提时。令我国中无一切三恶道。何以故。是梦及诸法无二无别。须菩提当知。是阿鞞跋致菩萨摩诃萨阿鞞跋致相。复次须菩提。菩萨摩诃萨梦中见地狱火烧众生。作是誓。若我实是阿鞞跋致者。是火当灭。是火即灭。若地狱火灭。即是阿鞞跋致相。复次若菩萨昼日见城郭火起。作是念。我梦中见阿鞞跋致行类相貌。我今实有是者。自立誓言。是火当灭。若火灭者。当知是菩萨得受阿耨多罗三藐三菩提记。住阿鞞跋致地。若火不灭烧一家置一家烧一里置一里。须菩提当知。被烧家破法业因缘厚集。以是故烧一家置一家。是诸众生今世受破法余殃故被烧。须菩提。以是因缘故。当知是阿鞞跋致菩萨摩诃萨阿鞞跋致相。佛告须菩提。今当更为汝说阿鞞跋致行类相貌。须菩提。若男子若女人为非人所持。是时菩萨摩诃萨作是念若我为过去诸佛所授记。我心清净求阿耨多罗三藐三菩提。行清净正道。远离声闻辟支佛心。远离声闻辟支佛念。应当成阿耨多罗三藐三菩提。我必得阿耨多罗三藐三菩提非不得。十方国土中现在无量诸佛。无所不知无所不见。无所不解无所不证。诸佛知我深心审定必当得阿耨多罗三藐三菩提。以是至诚誓故。是男子女人为非人所持。为非人所恼。是非人当远去。须菩提。是菩萨摩诃萨如是誓。若非人不去者。当知是菩萨摩诃萨。未从过去诸佛受阿耨多罗三藐三菩提记。须菩提。若菩萨摩诃萨如是誓。若非人去者。当知是菩萨摩诃萨。已从过去诸佛受阿耨多罗三藐三菩提记。须菩提。以是行类相貌。当知是阿鞞跋致菩萨摩诃萨阿鞞跋致相。复次须菩提。菩萨摩诃萨远离六波罗蜜及方便力。不久行四念处。乃至不久行空无相无作三昧。未入菩萨位。是菩萨为恶魔所娆。菩萨作是誓。若我实从诸佛受记者。是非人当去。是时恶魔即作方便。敕非人令去。恶魔有威力胜诸非人故。非人即去。是时菩萨作是念。以我誓力故非人去。不知是恶魔力。恃是证故轻弄毁蔑诸余菩萨。作是言。我已从诸佛受记。汝等未得。用是空誓。无方便力故生增上慢。以是事故远离萨婆若。远离阿耨多罗三藐三菩提。须菩提当知。是人堕于二地。若声闻地若辟支佛地。以是誓因缘故起于魔事。是人以不亲近依止善知识。不问阿鞞跋致相故。为魔所缚益复坚固。所以者何。是菩萨不久行六波罗蜜。无方便力故。须菩提当知。是为菩萨魔事。须菩提。云何菩萨摩诃萨不久行六波罗蜜。乃至未入菩萨位。为恶魔所娆。须菩提。恶魔变化作种种身。语菩萨言。汝于诸佛所得受阿耨多罗三藐三菩提记。汝字某汝父字某汝母字某。汝兄弟姊妹字某。汝七世父母名字如是。汝在某方某国某城某聚落中生。若见菩萨性行和柔。语菩萨言。汝先世亦复柔和。若见急性卒暴便言。汝先世亦尔。若见菩萨修阿兰若行语言。汝先世亦修。阿兰若行若见菩萨乞食纳衣。中后不饮浆。一坐食一钵他食。死尸间住露地住树下住。常坐不卧如敷坐。但受三衣。若少欲若知足。若远离住若不涂脚。若少言语。便语菩萨言。汝先世亦有是行。何以故。汝今有此头陀功德。汝先世亦必有是功德。是菩萨闻是先世事及名姓闻今赞头陀功德。即欢喜生慢憍心。是时恶魔语菩萨言。汝有如是功德如是相。汝实从诸佛受阿耨多罗三藐三菩提记。须菩提。恶魔或作比丘被服。或作居士形。或作父母身。来到菩萨所如是言。汝已得受阿耨多罗三藐三菩提记。何以故。是阿鞞跋致功德相。汝尽具足有之。须菩提。我所说实阿鞞跋致行类相貌是人永无。须菩提当知。是菩萨摩诃萨为恶魔所持。何以故。是阿鞞跋致行类相貌是人永无。以闻是名字故。生憍慢心。轻弄毁蔑余人。须菩提。是名菩萨摩诃萨为魔所持。当知是为菩萨魔事。复次须菩提。菩萨摩诃萨不久行六波罗蜜。不知名字相不知色相。不知受想行识相。恶魔来语言。汝当来世得阿耨多罗三藐三菩提时。有如是名字。随其本念说其名号。是无智无方便菩萨作是念。我先亦有是成佛名号念。是人如我所念说。是人所说合我本念。我必为诸佛所授记。须菩提。我所说阿鞞跋致行类相貌。是人永无。但以空名字轻弄毁蔑余人。以是事故。远离阿耨多罗三藐三菩提。是菩萨摩诃萨远离般若波罗蜜。无方便力。远离善知识。与恶知识相得。故堕二地。若声闻辟支佛地。若久久往来生死中。然后还依止般若波罗蜜。若值善知识常随逐亲近故。得阿耨多罗三藐三菩提。是人于是身若不即悔。当堕二地。若阿罗汉地若辟支佛地。须菩提。譬如比丘于四重禁法若犯一事。非沙门非释子。是人现身不得四沙门果。须菩提。是着空名字菩萨心亦如是。轻弄毁蔑余人故。当知是罪重于比丘四禁。须菩提。置是重罪。其罪过于五逆。以受是名字故生高心。轻弄毁蔑余人。若生是心。当知其罪甚重。如是名字等微细魔事菩萨当觉知。复次须菩提。菩萨在空闲山泽旷远之处。魔来到菩萨所。赞叹远离法作是言。善男子。汝所行是佛所称誉远离法。须菩提。我不赞是远离。所谓但在空闲山泽旷远之处。须菩提言。世尊。若空闲山泽旷远之处非远离法者。云何更有异远离。佛言。须菩提。若菩萨摩诃萨远离声闻辟支佛心。住空闲山泽旷远之处。是佛所许远离法。须菩提。如是远离法。菩萨摩诃萨应所修行。昼夜行是远离法。是名远离行菩萨。须菩提。若恶魔所说远离法。空闲山泽旷远之处。是菩萨心在愦闹。所谓不远离声闻辟支佛心。不勤修般若波罗蜜。是菩萨摩诃萨不能具足一切种智。是菩萨行恶魔所说远离法。心不清净而轻余菩萨城傍心清净无声闻辟支佛愦闹心亦无诸余杂恶心具足禅定解脱智慧神通者。是远离般若波罗蜜无方便。菩萨摩诃萨虽在绝旷百由旬外禽兽鬼神罗刹所住之处。若一岁百千万亿岁。若过万亿岁。不知是菩萨远离法。所谓诸菩萨以是远离法。深心发阿耨多罗三藐三菩提不杂行。是菩萨愦闹行而依受着。是远离法是人所行佛所不许。须菩提。我所说实远离法。是菩萨不在是中。亦不见是远离相。何以故。但行是空远离故。尔时恶魔来在虚空中住。赞言。善哉善哉。善男子。此是佛所说真远离法。汝行是远离。疾得阿耨多罗三藐三菩提。是菩萨摩诃萨念着是远离。而轻易诸余求佛道清净比丘以为愦闹。以愦闹为不愦闹。以不愦闹为愦闹。应恭敬而不恭敬。不应恭敬而恭敬。是菩萨作是言。非人念我来称赞我。我所行者是真远离。住城傍者谁当称美。汝以是因缘故。轻余菩萨摩诃萨。须菩提当知。是名菩萨旃陀罗。污染诸菩萨。是人似像菩萨。实是天上人中之大贼。亦是沙门被服中贼。如是人诸求佛道者。所不应亲近不应供养恭敬。何以故。须菩提当知。是人堕增上慢。以是故若菩萨摩诃萨欲不舍一切智。欲得阿耨多罗三藐三菩提。一心欲求阿耨多罗三藐三菩提。欲利益一切众生。不应亲近是人恭敬供养。菩萨摩诃萨法。常应勤求自利厌患世间心常远离三界。于是人当起慈悲喜舍心。我行菩萨道不应生如是过罪。若生当疾灭。须菩提。菩萨摩诃萨当善觉是事。是事中善自免出。复次须菩提。菩萨摩诃萨深心欲得阿耨多罗三藐三菩提者。当亲近恭敬供养善知识。须菩提白佛言。世尊。何等是菩萨摩诃萨善知识。佛告须菩提。诸佛是菩萨摩诃萨善知识。诸菩萨摩诃萨亦是菩萨善知识。须菩提。阿罗汉亦是菩萨善知识。是为菩萨摩诃萨善知识。复次须菩提。六波罗蜜亦是菩萨善知识。四念处乃至十八不共法亦是菩萨善知识。须菩提。如实际法性亦是菩萨善知识。须菩提。六波罗蜜是世尊。六波罗蜜是道。六波罗蜜是大明。六波罗蜜是炬。六波罗蜜是智。六波罗蜜是慧。六波罗蜜是救。六波罗蜜是归。六波罗蜜是洲。六波罗蜜是究竟道。六波罗蜜是父是母。四念处乃至一切种智亦如是。何以故。六波罗蜜三十七道法。亦是过去诸佛父母。六波罗蜜三十七道法。亦是未来现在十方诸佛父母。何以故。须菩提。六波罗蜜三十七道法中。生过去未来现在十方诸佛故。以是故须菩提。菩萨摩诃萨欲得阿耨多罗三藐三菩提净佛世界成就众生。当学六波罗蜜三十七道法。及四摄法摄取众生。何等四。布施爱语利益同事。须菩提。以是利益故。我言六波罗蜜及三十七道法是诸菩萨摩诃萨世尊。是道是大明是炬是智是慧是救是归是洲是究竟道是父是母。须菩提以是故。菩萨摩诃萨欲不随他人教住。欲断一切众生疑。欲净佛世界成就众生。当学是般若波罗蜜。所以者何。是般若波罗蜜中广说诸法是菩萨摩诃萨所应学处

【论】问曰。阿鞞跋致品中。已广说阿鞞跋致相。今何以更说。答曰。所说般若波罗蜜义。皆是阿鞞跋致相。但阿鞞跋致品中多说其事。余品中亦处处有说阿鞞跋致相。但不次第。有人言为后来众生异语说阿鞞跋致相。有人言有二种阿鞞跋致。一者已得记。二者未得记。得授记有二种。一者现前授记。二者不现前授记。不现前授记有二种。一者具足授记因缘。二者未具足授记因缘。具足授记因缘者。知诸法实相具足六波罗蜜。不具足授记因缘者。但知诸法实相得般若波罗蜜分。余波罗蜜未具足。是菩萨能如阿鞞跋致菩萨答。此是前品未所说阿鞞跋致。是故次第说。梦中不贪二地。虽未具足阿鞞跋致法。亦名阿鞞跋致。欲说如是等阿鞞跋致相故。此品中次第说。是菩萨昼日常习行空故。夜梦中亦不贪三界。是人常行慈悲心于众生深乐佛法故不贪二乘。若梦若觉观一切法如梦如幻等。是菩萨虽未得现前授记余法未具足。亦名阿鞞跋致相。何以故菩萨于二处退转。一者着世间乐故转。二者取二乘故转。是菩萨坚心深入空及慈悲心故。乃至梦中亦不贪三界二乘。何况觉时。复次若菩萨梦见佛在人天大众中说法。所谓诸法实相义。菩萨知是义心与法合。复次诸佛秘密法。菩萨梦中得见。所谓见佛身无量过须弥山色如阎浮檀金。三十二相八十种随形好以自庄严。放无量光明。梵音声说法。及身毛孔出无量化佛。至十方种种方便力。施作佛事度脱众生。尔时是菩萨见是佛神通力故。深心清净问佛法得诸法实相。是名阿鞞跋致。是菩萨常行毕竟空故。我我所等诸烦恼折薄。乃至自身不惜。何况余亲。是因缘故若梦中见若自身若父母等若杀若死因缘及聚落破等。不忧恼怖畏。觉已思惟如梦中不死而见死。不畏而见畏。一切三界皆尔。何但梦中。我作佛时当为众生说诸法毕竟空皆如梦。复次有菩萨种清净国土因缘时作是愿。我尔许时积集净国土行。是心修习故梦中若见三恶道众生。即时得是心。我作佛时令我国土乃至无三恶道名

复次是菩萨常修慈悲心故。梦中见地狱火烧众生。作誓火即灭。觉已取是相。若见实火烧城郭。作是念我梦中能灭火。此火亦当可灭。所以者何。佛说梦觉无异故。是菩萨于无量劫修集福德得诸法实相故。鬼神龙王等助灭是火。其中有不灭烧一家置一家者。是众生重罪故菩萨福德智慧力不能灭。重罪者所谓破法业。法者般若波罗蜜。诸余法利益无及般若波罗蜜者。是故破者罪重。以菩萨誓力故不次第烧。惟罪重者不救不妨。是阿鞞跋致相。非人所持亦如咒火。有菩萨未得无生法忍。闻是阿鞞跋致咒故。鬼去便作咒。是菩萨自未有力。魔来遣鬼神故自恃为己力。有如是失故佛示令觉知

复次菩萨未入正位。魔作种种形随其念而示语。汝已得授记。汝有是相。但以肉眼故不知。以是因缘故生增上慢轻蔑余人。复次菩萨不得诸法实相。不知色等五众和合边更有名字相。魔来与授记汝当作佛字名某甲。是菩萨思惟我本有是名字念。今所说者同我所愿。必是诸佛授记。是故心生憍慢轻余大菩萨。以是因缘故远离无上道。受罪毕堕于二乘。若即此身悔。当久久偿罪毕还依止般若波罗蜜得作佛。所以者何。若转身乃悔则罪重叵灭不得作佛。是心着是空名字得重罪。故佛说四重禁喻。破是重禁现身不得四道果。所以者何。是四禁中妄语称我是阿罗汉。此中着是受莂名字。自言我当作佛。是故重于四禁。过五逆罪者如地狱品中破般若波罗蜜罪说。微细魔事者。细名不逆。其意随其本念助成其心。是菩萨未得阿鞞跋致法。魔诳言已得是微细魔事。利根菩萨应觉除远。复次菩萨在远离处。魔来赞叹。汝能远离亲族同学。独在深山林中。为佛道故。是为真菩萨道行。是菩萨用是故生憍慢心。轻余在众中住菩萨。以是事故远离佛道堕于二乘。佛种种因缘诃是菩萨。是贼是旃陀罗等。如经中说不应亲近。佛所说远离。心离二乘三界。是名真远离。如经中广说。如是等细微魔事应当觉而远离

复次菩萨欲深心得无上道。深心名一心。重心深爱佛道。出于一切世间所乐。当亲近善知识。所以者何。有二因缘故得无上道。一者内。二者外。内名正忆念思惟筹量诸法。外名诸善知识。佛余处种种说善知识相。是故须菩提问佛。世尊何等是菩萨善知识。佛答。诸佛大菩萨及声闻。是菩萨善知识。六波罗蜜乃至一切种智如法性实际等诸法。亦是善知识法。能成办其事故。说六波罗蜜等诸法名善知识。三种圣人以此六波罗蜜法。令菩萨奉行得作佛。是故法及人通名善知识

问曰。佛及菩萨六波罗蜜。能成菩萨故应是善知识。小乘道异。云何能与作善知识

答曰。有小乘人先世求佛道故利根。虽是小乘有怜愍心。观应成大乘者为说大乘法。知报佛恩故。令佛种不断。如舍利弗六十劫求佛道虽退转作阿罗汉亦利根智慧能为诸菩萨说大乘。须菩提常行无诤三昧常有慈悲心于众生故。亦能教化菩萨大乘法。如摩诃迦叶以神通力持此身至弥勒出世于九足山中出与大众作得道因缘。如是等甚多。问曰。六波罗蜜摄一切法。今何以别说三十七品至如法性实际。答曰。六波罗蜜是略说。四念处等是广说。解六波罗蜜。六波罗蜜是菩萨初道小远。三十七品是近因缘。于六波罗蜜中禅波罗蜜般若波罗蜜最大。譬如虽有星宿日月最胜。是二波罗蜜中。四念处佛十力等法。最妙能大利益现世。令人得道故持戒布施等不如故。别说如等无为法实不虚诳故。能成菩萨事行。四念处等法。得如是等法。令菩萨得出虚诳法故名善知识。复次是六波罗蜜等法如佛无异。佛现在亦以是法度人。是故言世尊。如世尊所说不可坏。六波罗蜜等所说亦不可坏。是故言六波罗蜜是世尊。是道者行是道径入无量佛法中。六波罗蜜中所说人。筹量思惟分别常修行。令人得大智慧破诸世间无明。是故说六波罗蜜是大明是大炬是智是慧是救是归是洲是究竟道。如上说般若波罗蜜是母。五波罗蜜是父。和合说故言六波罗蜜是父母。如六波罗蜜说四念处等亦如是。是中说因缘。六波罗蜜等法。亦是三世十方佛父母。是六波罗蜜等是自利法。行者欲以六波罗蜜教化众生净佛世界。应以四摄法摄取众生。四摄法义如先说。如是自利利他故。佛说六波罗蜜三十七品等诸法是世尊是道等。是故菩萨若欲不随他教。不随他教名自知诸法实相乃至变作佛身来说。异于法相亦不信不随。自得菩萨道渐渐具足诸佛法。净佛世界成就众生得佛道。能断一切众生疑若欲得是者。当学般若。般若波罗蜜中世间出世间。若大若小无事不说

大智度论卷第七十六大智度论释梦中不证品第六十一之余(卷七十七)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】尔时须菩提白佛言。世尊。何等是般若波罗蜜相。佛告须菩提。如虚空相是般若波罗蜜相。须菩提。般若波罗蜜无所有相。须菩提白佛言。世尊。颇有因缘。如般若波罗蜜相。诸法相亦如是耶

佛告须菩提。如是如是。如般若波罗蜜相诸法相亦如是。何以故。须菩提。一切法离相空相。以是因缘故。须菩提。如般若波罗蜜相诸法相亦如是。所谓离相空相故。须菩提白佛言。世尊。若一切法一切法离。一切法一切法空。云何知众生若垢若净。世尊。离相法无垢无净。空相法无垢无净。离相空相法不能得阿耨多罗三藐三菩提。离相空相无法可得。世尊。离相中空相中。无有菩萨得阿耨多罗三藐三菩提者。世尊。我云何当知佛所说义。佛告须菩提。于汝意云何。是众生长夜行我我所心不。如是世尊。众生长夜行我我所心。于汝意云何。是我我所心离相不空相不。须菩提言。世尊。我我所心离相空相。于汝意云何。以此我我所心。众生往来生死中不。如是世尊。以此我我所心。众生往来生死中。如是须菩提。众生往来生死中故知有垢恼。须菩提。若众生无我我所心无著心。是众生不复往来生死中。若不往来生死中则无垢恼。如是须菩提。众生有净。须菩提白佛言。世尊。若菩萨摩诃萨如是行。为不行色不行受想行识。为不行四念处乃至八圣道分。为不行内空乃至无法有法空。为不行佛十力乃至一切种智。何以故。是法不可得。亦无行者亦无行处亦无行法。世尊。菩萨摩诃萨如是行。一切世间诸天人阿修罗不能降伏是菩萨摩诃萨。一切声闻辟支佛所不能及。何以故。所住处无能及故。所谓菩萨位。世尊。是菩萨摩诃萨行应萨婆若心无能及者。须菩提。菩萨摩诃萨如是行疾近萨婆若。须菩提。于汝意云何。若阎浮提众生尽得人身。得人身已皆得阿耨多罗三藐三菩提。若有善男子善女人。尽其形寿供养恭敬尊重赞叹。持是善根回向阿耨多罗三藐三菩提。是人以是因缘得福多不。须菩提言。甚多世尊。佛言。不如是。善男子善女人于大众中说是般若波罗蜜出示分别照明开演。亦应般若波罗蜜行正忆念其福多。乃至三千大千世界中众生亦如是。须菩提。于汝意云何。阎浮提中众生一时皆得人身。得人身已。若善男子善女人。教行十善道四禅四无量心四无色定。教令得须陀洹道乃至阿罗汉辟支佛道。教令得阿耨多罗三藐三菩提。持是善根回向阿耨多罗三藐三菩提。须菩提。于汝意云何。是善男子善女人得福多不。须菩提言。甚多世尊。佛言。不如是善男子善女人以是甚深般若波罗蜜为众生说出示分别照明开演。亦不离萨婆若得福多。乃至三千大千世界亦如是。是菩萨摩诃萨不远离应萨婆若心。则到一切福田边。何以故。除诸佛无有余法如菩萨摩诃萨势力。何以故。诸菩萨摩诃萨行般若波罗蜜时。于一切众生中起大慈心。见诸众生趣死地故。而起大悲行是道时。欢悦而生大喜。不与想俱便得大舍。须菩提。是为菩萨摩诃萨大智光明。大智明者。所谓六波罗蜜。须菩提。是诸善男子虽未作佛。能为一切众生作大福田。于阿耨多罗三藐三菩提亦不转。所受供养衣服饮食卧具床敷疾药资生所须。行应般若波罗蜜。念能毕报施主之恩。疾近萨婆若。以是故须菩提。若菩萨摩诃萨欲不虚食国中施。欲示众生三乘道。欲为众生作大明。欲拔出三界牢狱。欲与一切众生眼。应常行般若波罗蜜。行般若波罗蜜时。若欲有说但说般若波罗蜜。说般若波罗蜜已。常忆念般若波罗蜜。常忆念般若波罗蜜已。常行般若波罗蜜不令余念得生。昼夜勤行般若波罗蜜。相应念不息不休。须菩提。譬如士夫未曾得摩尼珠后时得。得已大欢喜踊跃。后复失之便大忧愁。常忆念是摩尼珠作是念。我奈何忽亡失此大宝。须菩提。菩萨摩诃萨亦如是。常忆念般若波罗蜜不离萨婆若心。须菩提白佛言。世尊。一切念性自离。一切念性自空。云何菩萨摩诃萨行般若波罗蜜不离应萨婆若念。是远离空法中无菩萨亦无念。无应萨婆若。佛告须菩提。若菩萨摩诃萨如是知。一切法性自离。一切法性自空。非声闻辟支佛作。亦非佛作。诸法相常住法相法住法位如实际。是名菩萨行般若波罗蜜不离萨婆若念。何以故。般若波罗蜜性自离性自空不增不减故。须菩提白佛言。世尊。若般若波罗蜜。性自离性自空。云何菩萨摩诃萨与般若波罗蜜等得阿耨多罗三藐三菩提。佛告须菩提。菩萨摩诃萨与般若波罗蜜等不增不减。何以故。如法性实际不增不减故。所以者何。般若波罗蜜非一非异故。若菩萨闻如是般若波罗蜜相。不惊不没不畏不怖不疑。须菩提当知。是菩萨摩诃萨行般若波罗蜜。当知是菩萨摩诃萨必住阿鞞跋致地中。须菩提白佛言。世尊。般若波罗蜜空无所有不坚固。是行般若波罗蜜不。不也。须菩提世尊。离空更有法行般若波罗蜜不。不也须菩提。世尊。是般若波罗蜜行般若波罗蜜不。不也。须菩提。世尊。离般若波罗蜜行般若波罗蜜不。不也。须菩提。世尊。色是行般若波罗蜜不。不也。须菩提。世尊。受想行识是行般若波罗蜜不。不也。须菩提。世尊。六波罗蜜是行般若波罗蜜不。不也。须菩提。世尊。四念处乃至十八不共法。是行般若波罗蜜不。不也须菩提。世尊。色空相虚诳不实无所有。不坚固相色如相法相法住法位实际。是行般若波罗蜜不。不也。须菩提。世尊。受想行识乃至十八不共法。空相虚诳不实无所有。不坚固相如法相法住法位实际。是行般若波罗蜜不。不也须菩提。世尊。若是诸法。皆不行般若波罗蜜。云何行名菩萨摩诃萨行般若波罗蜜。佛告须菩提。于汝意云何。汝见有法行般若波罗蜜者不。不也。世尊。须菩提。汝见般若波罗蜜菩萨摩诃萨可行处不。不也。世尊。须菩提。汝所不见法是法可得不。不也。世尊。须菩提。若法不可得。是法当生不。不也。世尊。须菩提。是名菩萨摩诃萨无生法忍。菩萨摩诃萨成就是忍。得受阿耨多罗三藐三菩提记。须菩提。是名诸佛无所畏无碍智。菩萨摩诃萨行是法忍勤精进。若不得大智一切种智。所谓阿耨多罗三藐三菩提智者。无有是处何以故。是菩萨摩诃萨得无生法忍故。乃至阿耨多罗三藐三菩提不减不退。须菩提白佛言世尊。诸法无生相。此中得阿耨多罗三藐三菩提记不。不也。须菩提。世尊。诸法生相。此中得阿耨多罗三藐三菩提记不。不也。须菩提。世尊诸法非生非不生相。得阿耨多罗三藐三菩提记不。不也。须菩提。世尊。诸菩萨摩诃萨云何知诸法。得阿耨多罗三藐三菩提记。佛告须菩提。汝见有法得阿耨多罗三藐三菩提记不。不也。世尊。我不见有法得阿耨多罗三藐三菩提记。我亦不见法有得者得处。佛言。如是如是。须菩提。若菩萨摩诃萨于一切法无所得时。不作是念。我当得阿耨多罗三藐三菩提。用是事得阿耨多罗三藐三菩提。是阿耨多罗三藐三菩提处。何以故。诸菩萨摩诃萨行般若波罗蜜。无诸忆想分别。所以者何。般若波罗蜜中无诸分别忆想故

【论】问曰。上已种种说般若相。今何以更问。答曰。般若波罗蜜第一微妙。闻者无厌足无满时无一定相故不应难。如十住大菩萨。于般若波罗蜜犹未满足。何况须菩提小乘人。复次上闻种种赞般若。是父是母等。是故更问。佛因须菩提问。为余众生故广说般若波罗蜜相。须菩提所谓虚空相是般若波罗蜜相。如虚空无色相无非色相。般若波罗蜜亦如是无所有相。须菩提更问。颇有因缘诸法相如般若相不。佛答有一切法究竟空究竟离相故。说如般若波罗蜜相一切法亦如是。须菩提难。若一切法离相空相。云何知有垢净。云何菩萨得无上道。佛告须菩提于汝意云何。众生长夜行我我所。等是佛所说义。如我我所毕竟无。众生狂颠倒因缘故生诸烦恼。烦恼因缘故有业。业因缘故于生死中往来。是事本末空。何以故。我无故我所心虚诳。我所心虚诳故。诸余因果展转法皆是虚诳。若因般若波罗蜜实智慧观五众。无常苦空无我。离自相自相空。从本来毕竟不生。尔时我我所心则灭。如日出众冥皆除。我我所心灭故余烦恼灭。余烦恼灭故业因缘亦灭。业因缘灭故往来生死中断。是名为净。虽一切法相皆空。亦以如是因缘故有净有垢。尔时须菩提思惟筹量佛语已白佛言。世尊菩萨如是行。实不行色等一切法。何以故。是菩萨不得是法若行行处行者。世尊若菩萨能如是行。一切人天世间无能降伏者。世间人皆着假名。是行者行实法。是故不能伏。世间人着一切虚诳颠倒及虚诳果报。是菩萨于毕竟空中尚不着。何况余法。如是云何可降伏天人阿修罗。世间者是三种善道。中有智慧人故说不能降伏。又复一切声闻辟支佛所不能及者。上三善道据未得道人。此中说得道者不能及。此中说不能及因缘。所谓菩萨入法位。一切魔魔所使无能恼者。是菩萨常行应萨婆若心。则近阿耨多罗三藐三菩提。何以故。不着一切法常集一切助道法故。佛可其言而赞。佛欲以如是智慧为他人说故。先赞菩萨自利益。今为利益他分别福德果报故问。须菩提于汝意云何。阎浮提众生尽得人身如经广说。乃至应萨婆若心出一切福田之上。是中说因缘。若菩萨能自行般若波罗蜜。亦能教化。是人于一切福田能到其边。福田者。从须陀洹乃至佛。是菩萨能如所说般若波罗蜜履行则得作佛。余福德善法离般若波罗蜜故皆尽。般若波罗蜜不可尽故言无有余福德。如菩萨摩诃萨力势者。是中自说因缘。菩萨行般若时得诸法平等忍。得平等忍故虽行空亦能生四无量心。四无量心中大悲是大乘之本。见众生就于死法如囚受戮。诸菩萨能生六波罗蜜等乃至一切种智。是故诸菩萨能生大悲

是故是人虽未得无上道。已是一切众生之福田。是故言菩萨摩诃萨若欲不空食国中施者。当学般若波罗蜜。不空食名能报。施主能生道。能令施主之福无尽乃至入涅槃。若示众生三乘道。为众生示一切智大明。亦欲拔出三界狱中四缚。欲令众生得五眼。应常行般若波罗蜜。相应念相应念者。即是般若心。若行般若波罗蜜心。若有所说但说般若波罗蜜。佛敕弟子若和合共住常行二事。一者贤圣默然。二者说法。贤圣默然者是般若心。说法者说般若波罗蜜。是人从般若心出说般若波罗蜜。说般若波罗蜜已还入般若中。不令余心余语得入。昼夜常行是不休不息。如是得先所说功德。佛欲令是事明了故说譬喻。如贫人失大价宝常念不离。菩萨亦如是不离萨婆若心。常行般若波罗蜜不休不息。尔时须菩提闻是事白佛言。世尊若一切诸念空。云何菩萨不离萨婆若念。空中菩萨不可得。萨婆若亦不可得。佛答。若菩萨知一切法离自性非声闻辟支佛所作。亦非佛所作自从因缘出诸法法相如实际常住世间。即是菩萨不离般若波罗蜜行。佛自说因缘。般若波罗蜜空故离故不增不减。须菩提闻是复问佛。若般若波罗蜜性空。云何菩萨与般若合得无上道。佛随须菩提语。若菩萨与般若波罗蜜合则不增不减。诸法如法性实际不增不减故。般若波罗蜜不增不减。般若波罗蜜即是诸法如法性实际。如法性实际即是般若波罗蜜。此中佛自说因缘。如如等三法非一非异。般若亦如是。世间法非一即是二不异即是一。般若波罗蜜则不尔。是故般若波罗蜜无量无边。空无相无作故不增不减。若菩萨得是不增不减。则能得阿耨多罗三藐三菩提。若菩萨闻是事通达无碍入佛智慧。虽未作佛信力故。于佛法中亦无疑不怖不畏。所以者何。凡夫着我心故有畏。是菩萨我相断故无所畏。当知是菩萨即住阿鞞跋致地。亦能正行般若。须菩提闻是菩萨正行般若波罗蜜。是故问佛。世尊般若波罗蜜观一切空不牢固是空相为行般若不。佛言不也。何以故。若空无有法云何行般若。离是空更有法行般若不。佛言不也。何以故。若一切法空无相无作。云何离空更有法。是故说不。须菩提闻空非行般若。离空非行般若。一切法皆摄在般若中。今但问般若行般若不。法不自行应以异法行。是故言不。复问离般若更有法行般若不。佛言不。何以故。一切法摄在般若中。更无法行般若。先来略问行般若者。今问名字因缘。五众行般若不。佛言不。何以故。是五众从虚诳和合因缘不自在故无住相云何能行。须菩提更问。若菩萨假名字空不实故不行般若。今六波罗蜜等诸助道法。行般若波罗蜜不。佛言不。何以故。如五众和合有故不能行。是诸法亦如是。色等法空相不牢固。如法相法位法住实际。是法行般若不。佛答。是法无为法不生不灭常住自性故不行。须菩提问佛。世尊假名字故人不行。诸法亦和合因缘生无自性故亦不行。谁当行般若。若不行云何得无上道。今佛以反问答。于汝意云何。须菩提从佛急求行般若者。是故佛问。汝以慧眼见。定有一法行般若不。须菩提因三解脱门入诸法实相中。法相不可得何况行者。是故答言。世尊。不见有行般若者。复问。汝见是般若波罗蜜菩萨行处不。须菩提答不见。何以故。般若波罗蜜中。一切诸观灭。若常若无常若生灭等无一法定相。是般若云何当说是般若波罗蜜。复问。若汝以智慧眼不见法。是不见法为有为无。答言无。何以故。佛说智慧眼。实肉眼天眼虚诳。须菩提以慧眼观不见故言无。复问。若法无不可得。是法有生不。答言不生。是法本自无。毕竟空无所有。是法有无等戏论已灭。云何有生。佛语须菩提。若菩萨于是法中通达无疑。信力智慧力故能住是法中是名无生忍。五众中假名菩萨得如是法。是名行般若波罗蜜。世俗法故说非第一义。第一义中诸戏论语言即是无生。得是无生忍便受无上道记。佛言若菩萨一心勤精进不休不息随无生忍行。不得是大智慧无上智慧一切智无有是处。何以故。如经说。若无因无缘则无果报耶。因缘亦无果报。因缘少亦无果报。如是菩萨得是无生法忍。舍是生死肉身。得法性生身。住菩萨果报神通中。一时能作无量变化身。浮佛世界度脱众生。是人末后身具足佛法。坐道场具足正因缘。若不得阿耨多罗三藐三菩提无有是处。所以者何。是人得无生忍法。一心直进无有废退故。菩萨未得无生法忍。深着世间法。诸烦恼厚。虽有福德。善心软薄不进故。为烦恼所遮得无生忍法无复是事。未得无生忍法用力艰难譬如陆行。得无生法忍已用力甚易譬如乘船。是故无生法忍。诸菩萨所贵。以是贵故须菩提问世尊得无生法故受记。佛言不也。何以故。无生法不生不灭无得相。云何因是受记。复问。生法得记耶。佛言不得。何以故。生法虚诳妄语作法。云何得阿耨多罗三藐三菩提真实法。复问生不生得受记不。佛言不也。何以故。此二俱有过故。复问。世尊。若尔者。云何当授记。佛反问。汝以慧眼观见有法与菩萨授记不。答言不见。何以故。是法从本已来寂灭相。是中无见不见授记不授记。亦不见阿耨多罗三藐三菩提。亦无得法亦无得者。此中自说因缘。般若波罗蜜无是忆想分别。问曰。须菩提上问菩萨得无生忍故受记。佛言不。佛何以还以无生理答。所谓菩萨行般若时。无一切忆想分别。答曰。行者实以无生忍故受记。而须菩提为菩萨故以着心得心问。以是故言不。如一切法实无我。婆蹉梵志问佛有我不。佛默然不答。无我不。佛亦不答。一切虽实无我以梵志着心问欲戏弄无我故不答。须菩提问意。知定有受记事。但不知观何法得记故问。是故。佛以须菩提所得法问。汝以慧眼见定有法受记不。须菩提住三解脱门中。观法性不见定有受记者。诸法法性无相无量故。若不见受记法。云何当得阿耨多罗三藐三菩提者。须菩提。闻是受记者空。难情则息自解无疑。佛可其意如是如是。汝不见不得法是实。何以故。般若波罗蜜相无所分别故

    大智度论释同学品第六十二

【经】尔时释提桓因白佛言。世尊。是般若波罗蜜无诸忆想分别。毕竟离故。世尊。是众生闻是般若波罗蜜。能受持读诵说正忆念亲近如说行。乃至阿耨多罗三藐三菩提。不杂余心心数法者。不从小功德来。佛言。如是如是。闻是深般若波罗蜜。乃至不杂余心心数法者。不从小功德来。憍尸迦。于汝意云何。若阎浮提众生成就十善道四禅四无量心四无色定。复有善男子善女人。受持深般若波罗蜜。读诵亲近正忆念如说行。胜于阎浮提众生成就十善道乃至四无色定。百倍千倍千万亿倍。乃至算数譬喻所不能及。尔时有一比丘语释提桓因。憍尸迦。是善男子善女人。行般若波罗蜜功德胜于仁者。释提桓因言。是善男子善女人。一发心胜于我。何况闻是般若波罗蜜。书持读诵正忆念如说行。是善男子善女人行般若波罗蜜非但胜我。亦胜一切世间天及人阿修罗。非但胜一切世间天及人阿修罗。亦胜诸须陀洹斯陀含阿那含阿罗汉辟支佛。非但胜是须陀洹乃至辟支佛。亦胜菩萨行五波罗蜜远离般若波罗蜜者。非但胜菩萨行五波罗蜜远离般若波罗蜜者。亦胜菩萨行般若波罗蜜无方便力者。是菩萨摩诃萨如说行般若波罗蜜。不断佛种常见诸佛疾近道场。菩萨如是行。为欲拔出众生沉没长流者。是菩萨如是学。为不学声闻辟支佛学。菩萨如是学。四天王天来至菩萨所如是言。善男子当勤疾学。坐道场成阿耨多罗三藐三菩提时。如过去诸佛所受四钵亦当应受。我当持来奉上菩萨。及诸余天四天王天三十三天夜摩天兜率陀天化乐天他化自在天。梵天乃至首陀会天亦当供养。十方诸佛亦常念。是菩萨摩诃萨如说行是深般若波罗蜜者。是菩萨诸所有世间厄难勤苦之事永无复有。一切世间有四百四病。是菩萨身中无是诸病。以行深般若波罗蜜故得是现世功德。尔时阿难作是念。释提桓因自以力说耶。以佛神力说乎。释提桓因知阿难意所念。语阿难言。我之所说皆佛威神。佛告阿难。如是如是。如释提桓因所说皆佛威神。阿难。是菩萨摩诃萨习学是深般若波罗蜜时。三千大千世界中诸恶魔皆生孤疑。今是菩萨为当得阿耨多罗三藐三菩提。当中道于实际作证。堕声闻辟支佛地

复次阿难。若菩萨摩诃萨不离般若波罗蜜时。魔大愁毒如箭入心。是时魔复放大火风四方俱起。欲令菩萨心没恐怖懈怠于萨婆若中乃至起一乱念。阿难白佛言。世尊。魔为都娆乱。诸菩萨有不娆乱者。佛告阿难。有娆者有不娆者。阿难白佛言。世尊。何等菩萨为恶魔所娆。佛言。有菩萨摩诃萨。先世闻是深般若波罗蜜心不信解。如是菩萨魔得其便。复次阿难。菩萨闻说是深般若波罗蜜时意疑。是般若波罗蜜为实有为实无。如是菩萨魔得其便。复次阿难。有菩萨远离善知识为恶知识所摄故。不闻深般若波罗蜜。不闻故不知不见不问。云何应行般若波罗蜜。云何应修般若波罗蜜。是菩萨恶魔得其便。复次阿难。若菩萨远离般若波罗蜜受恶法。是菩萨为恶魔得其便。魔作是念。是辈当有伴党当满我愿。是菩萨自堕二地。亦使他人堕于二地。复次阿难。若菩萨闻说深般若波罗蜜时。语他人言。是般若波罗蜜甚深。我尚不能得其底。汝复用闻用学是般若波罗蜜为。如是菩萨魔得其便。复次阿难。若菩萨轻余菩萨言。我行般若波罗蜜行远离空。汝无是功德。是时恶魔大欢喜踊跃。若有菩萨自恃名姓多人知识故。轻余行善菩萨。是人无实阿鞞跋致行类相貌功德。无是功德故。生诸烦恼。但着虚名故。轻贱余人言。汝不在如我所得法中。尔时恶魔作是念。今我境界宫殿不空。增益三恶道。恶魔助其威力。令余人信受其语。信受其语故。受行其经如说修学。如说修学时。增益诸结使。是诸人心颠倒故。身口意业所作皆受恶报。以是因缘增益三恶道。魔之眷属宫殿益多。阿难。魔见是利故大欢喜踊跃。阿难。若行菩萨道者。与求声闻道家共诤斗。魔作是念。是远离萨婆若。阿难。若菩萨菩萨共诤斗嗔恚骂詈。是时恶魔便大欢喜踊跃。言两离萨婆若远。复次阿难。若未受记菩萨向得记菩萨。生恶心诤斗骂詈。随起念多少劫。若干劫数。若不舍一切种智。然后乃补尔所劫大庄严。阿难白佛言。世尊。是恶心乃经尔所劫数。于其中间宁得出除不。佛告阿难。我虽说求菩萨道及声闻人得出罪。阿难。若求菩萨道人共斗诤嗔恚骂詈。怀恨不悔不舍者。我不说有出。必当更尔所劫数。若不舍一切种智。然后乃大庄严。阿难。若是菩萨斗诤嗔恚骂詈。便自改悔作是念。我为大失。我当为一切众生下屈。今世后世皆使和解。我当忍受一切众生履践。如桥梁如聋如哑。云何以恶语报人。我不应坏是甚深阿耨多罗三藐三菩提心。我得阿耨多罗三藐三菩提时。应当度是一切苦恼众生。云何当起嗔恚。阿难白佛言。世尊。菩萨菩萨共住云何。佛告阿难。菩萨菩萨共住相视当如世尊。何以故。是菩萨摩诃萨应作是念。是我真伴共乘一船。彼学我学所谓檀波罗蜜。乃至一切种智。若是菩萨杂行离萨婆若心。我不应如是学。若是菩萨不杂行。不离萨婆若心。我亦应如是学。菩萨摩诃萨如是学者。是为同学

【论】释曰。释提桓因。上说善男子书受持般若。乃至正忆念得无量功德。今说其义。是人读诵般若。乃至阿耨多罗三藐三菩提。不令余心心数杂者。得如上所说功德。但从闻说而不能行。余心不入者虽得功德不名为无上。余心心数法杂者。有人言。悭贪等及破六波罗蜜恶心是。有人言。但不令恶心增长成其势力来则灭除。有人言。不令声闻辟支佛心得入。有人言。无记散乱心虽非恶以遮善道故亦不令得入。是故是人不从小功德来。佛可其言。如是欲分别清净行势力故反问憍尸迦。若阎浮提人一切成就十善道等。如经说。是福德虽多离诸法实相故。虚妄不牢固。无常尽灭不足为多。如草芥虽多不如一小金刚。问曰。是比丘何以语帝释善男子福德胜仁者。答曰。帝释已作福德果报中。人天之主威德尊重。是比丘重是善法。欲显此功德故言胜于仁者。复次是比丘闻帝释得声闻道。是故言汝虽有福德是菩萨胜汝。帝释得道深念佛法故。不生高心受其语言。菩萨为阿耨多罗三藐三菩提但发心便胜我。何况如所说行。何以故。帝释福报微薄。是菩萨功德淳厚。又以帝释福德着天乐自为其身。菩萨功德为一切众生回向佛道乐故。时会听者闻比丘说胜于仁者帝释受其语。咸生轻帝释心。是故帝释言不但胜我乃至胜菩萨行般若无方便力者。如所说行般若波罗蜜时。不杂余心心数法故。是中帝释自说胜因缘。所谓是菩萨如说行般若不断佛种。乃至以行般若波罗蜜故得是现世功德。问曰。阿难何以作是念言。帝释自以力说用佛力说。答曰。阿难知帝释是声闻。而所说甚深过声闻辟支佛智。是故生疑而问。问曰。帝释自有智能问能答。何以言佛力。答曰。般若甚深甚难无量无边。若在异处说尚难。何况于佛前大众中说。是故言佛力。如持心经说。佛以光明威神入其身故。能于佛前难问有所说。佛告阿难。可帝释所语。更叹行深般若菩萨有大威德。所谓阿难是菩萨习学深般若时恶魔生疑。恶魔是菩萨怨贼常求菩萨。便如魔品中说。以菩萨深行般若波罗蜜故。魔大作方便坏菩萨心。若菩萨懈怠者魔大欢喜。是人自当堕落。有人言。一切菩萨应有魔怨。是故阿难问为尽有魔亦有无者。佛分别答。所谓深清净心行菩萨道则无魔扰。不清净为魔所坏者如经广说。问曰。如佛所说一切有为法皆可转可舍。阿难何以疑而问佛是罪可悔不。答曰。阿难知般若波罗蜜是无尽因缘。若供养福无边。乃至得佛福犹不尽。若诃嗔罪亦如是无边。是故问佛。佛答我法虽有出罪。若菩萨共斗结恨不即舍则不可出。何以故。是菩萨深心轻慢嗔余菩萨故。以嗔憍慢故。不能下意共悔。欲更行余功德求灭此罪。佛言。此罪不可出。以怀恨故虽作余福德皆不清净。不清净故无力。无力故不能灭罪。此人若欲作佛不舍一切智下意忏悔者。补尔所劫乃得发大庄严。问曰。心中怀恨云何可灭。答曰。破嗔因缘如经说。阿难知一切众生属业因缘不得自在无能救者心怀怖畏。问佛菩萨共住云何。云何用心恭敬佛。答供养恭敬当如视佛。是未来佛故。此中佛自说因缘。菩萨共住应作是念。是我真伴俱到佛道共乘一船。船者六波罗蜜。三界三漏为水。彼岸是佛道。彼所学者我亦应学。学者所谓六波罗蜜等同戒同见同道。如白衣兄弟不应共斗。我是同法兄弟亦不应共诤。若是菩萨杂行离萨婆若心。我不应如是学。何以故。胜事应从他学恶事应舍。菩萨若作是学。轻慢嗔恨事皆灭。是则名菩萨同学

    大智度论释等学品第六十三

【经】须菩提白佛言。世尊。何等是菩萨摩诃萨等法。菩萨所应学。须菩提。内空是菩萨等法。外空乃至自相空是菩萨等法须菩提。色色相空。受想行识识相空乃至阿耨多罗三藐三菩提。阿耨多罗三藐三菩提相空。须菩提。是名菩萨摩诃萨等法住是等法得阿耨多罗三藐三菩提。须菩提白佛言。世尊。若菩萨摩诃萨为色尽故学。为学萨婆若。为色离故学。为色灭故学。为学萨婆若。为色不生故学。为学萨婆若。受想行识亦如是。修行四念处乃至十八不共法尽离灭不生故学。为学萨婆若。佛告须菩提。如须菩提所说。为色尽离灭不生故学。为学萨婆若。受想行识乃至十八不共法尽离灭不生故学。为学萨婆若。佛告须菩提。于汝意云何。色如受想行识如。乃至阿耨多罗三藐三菩提如佛如。是诸如尽灭断不。须菩提言。不也世尊。佛告须菩提。菩萨摩诃萨如是学如。为学萨婆若。是如不作证不灭不断。须菩提。菩萨摩诃萨如是学如。为学萨婆若。须菩提。菩萨摩诃萨如是学。为学六波罗蜜。为学四念处乃至十八不共法。若学六波罗蜜乃至十八不共法。为学萨婆若。须菩提。如是学为尽诸学边。如是学魔若魔天所不能坏。如是学直到阿鞞跋致地。如是学为学佛所行道。如是学为得拥护。为学大慈大悲。为学净佛世界成就众生。须菩提。如是学为学三转十二行法轮转故。如是学为学度众生。如是学为学不断佛种。如是学为学开甘露门。如是学为学欲示无为性。须菩提。下劣之人不能作是学。如是学者。为欲拔出沉没生死众生。菩萨摩诃萨如是学。终不堕地狱饿鬼畜生中。终不生边地。终不生栴陀罗家。终不聋盲喑哑拘癖。诸根不缺。眷属成就终不孤穷。菩萨如是学。终不杀生乃至终不邪见。如是学不作邪命活。不摄恶人及破戒者。如是学以方便力故不生长寿天。何等是方便力。如般若波罗蜜品中所说。菩萨摩诃萨以方便力故。入四禅四无量心四无色定。不随禅无量无色定生。须菩提。菩萨如是学。一切法中得清净。所谓净声闻辟支佛心。须菩提白佛言。世尊。一切法本性清净。云何言菩萨一切法中得清净。佛告须菩提。如是如是。一切诸法本性清净。若菩萨摩诃萨于是法中心通达不没。即是般若波罗蜜如是诸法一切凡夫不知不见。菩萨摩诃萨为是众生故。行檀波罗蜜乃至般若波罗蜜。行四念处乃至一切种智。须菩提。菩萨如是学。于一切法中得智力无所畏。如是学为了知一切众生心所趣向。譬如大地少所处出金银珍宝。须菩提。众生亦如是。少所人能学般若波罗蜜。多堕声闻辟支佛地。须菩提。譬如少所人受行转轮圣王业多受行小王业。如是须菩提。少所众生行般若波罗蜜求一切智。多行声闻辟支佛道。须菩提。诸菩萨摩诃萨发心求阿耨多罗三藐三菩提中少有如说行。多住声闻辟支佛地。多有菩萨摩诃萨行般若波罗蜜。无方便力故。少所人住阿鞞跋致地。须菩提。以是故菩萨摩诃萨。欲住阿鞞跋致地。欲在阿鞞跋致数中。应当学是深般若波罗蜜。复次须菩提。菩萨摩诃萨学是般若波罗蜜时。不生悭贪心。不生破戒嗔恚懈怠散乱愚痴心。不生诸余过失心。不生取色相取受想行识相心。不生取四念处相心。乃至不生取阿耨多罗三藐三菩提相心。何以故。是菩萨摩诃萨行是深般若波罗蜜。无有法可得。以不可得故。于诸法不生心取相。须菩提。菩萨摩诃萨如是学深般若波罗蜜。总摄诸波罗蜜。令诸波罗蜜增长。诸波罗蜜悉随从。何以故。须菩提。是深般若波罗蜜。诸波罗蜜悉入中。须菩提。譬如我见中悉摄六十二见。如是须菩提。是深般若波罗蜜。悉摄诸波罗蜜。须菩提。譬如人死命根灭故余根悉随灭。如是须菩提。菩萨摩诃萨行深般若波罗蜜时。诸波罗蜜悉随从。须菩提。菩萨摩诃萨欲令诸波罗蜜度彼岸。应学深般若波罗蜜。须菩提。菩萨摩诃萨学是深般若波罗蜜者。出一切众生之上。须菩提。于汝意云何。三千大千世界中众生多不。须菩提言。一阎浮提中众生尚多。何况三千大千世界。佛告须菩提。若三千大千世界中众生。一时皆得人身。悉得阿耨多罗三藐三菩提。若有菩萨尽形寿。供养尔所佛衣服饮食卧具汤药资生所须。须菩提。于汝意云何。是人以是因缘故得福德多不。须菩提言。甚多甚多。佛言。不如是善男子善女人学般若波罗蜜如说行正忆念得福多。何以故。般若波罗蜜有势力。能令菩萨摩诃萨得阿耨多罗三藐三菩提。须菩提。以是故菩萨摩诃萨欲出一切众生之上。当学般若波罗蜜。欲为无救护众生作救护。欲与无归依众生作归依。欲与无究竟道众生作究竟道。欲为盲者作目。欲得佛功德。欲作诸佛自在游戏。欲作佛师子吼。欲撞击佛钟鼓。欲吹佛呗。欲升佛高座说法。欲断一切众生疑。当学深般若波罗蜜。须菩提。菩萨摩诃萨若学深般若波罗蜜。诸善功德无事不得。须菩提。白佛言。世尊。宁复得声闻辟支佛功德不。佛言。声闻辟支佛功德皆能得。但不于中住。以智观已直过入菩萨位中。须菩提。菩萨摩诃萨如是学近萨婆若。疾得阿耨多罗三藐三菩提。须菩提。菩萨摩诃萨如是学。为一切世间天人阿修罗作福田。须菩提。菩萨摩诃萨如是学。过诸声闻辟支佛福田之上。疾近萨婆若。须菩提。菩萨摩诃萨如是学。是名不舍不离般若波罗蜜常行般若波罗蜜。须菩提。菩萨摩诃萨如是学深般若波罗蜜。当知是不退转菩萨疾近萨婆若。远离声闻辟支佛。近阿耨多罗三藐三菩提。须菩提。菩萨摩诃萨行般若波罗蜜时。若作是念。是般若波罗蜜。我以是般若波罗蜜得一切种智。若如是念。不名行般若波罗蜜。须菩提。若不作是念。是般若波罗蜜。是人有般若波罗蜜。是般若波罗蜜法。是人行般若波罗蜜。得阿耨多罗三藐三菩提。是名行般若波罗蜜。须菩提。若菩萨作是念。无是般若波罗蜜。无人有是般若波罗蜜。无有行是般若波罗蜜得阿耨多罗三藐三菩提。何以故。一切法如法性实际常住故。如是行是为菩萨摩诃萨行般若波罗蜜

【论】释曰。上阿难问斗诤。佛答同学清净。今须菩提问佛甚深同心等法。是菩萨所学处。佛答内空乃至自相空是名等法。有二种等忍。上品末说众生等忍。此品说法等忍。如称两头停等。如是内空等诸空于诸法中平等。如内法有种种差别。得内空则皆平等无法。乃至自相空一切法相皆自空。是时心则平等。菩萨住是等中。能得阿耨多罗三藐三菩提。须菩提复问。为色等尽故为学萨婆若。观色等无常念念灭不住。若得是观心则离色。心离色故诸烦恼灭。烦恼灭故得不生法。须菩提问。如是学为学萨婆若。佛反问须菩提。于汝意云何。色等诸法如及如来如是如为尽灭断不。须菩提言不。是如从本已来不集不和合云何有尽。本来不生云何有灭。是法本来虚诳无有定相云何可断。须菩提菩萨摩诃萨能如是学如。为学萨婆若。是如常不可证不可灭不可断。是尽离断除颠倒故行非是究竟。此中说究竟事于是佛赞叹。如是学虽不定。为一法故学而学萨婆若。若学萨婆若即是学六波罗蜜等。若能学六波罗蜜等。是为尽诸学边。若尽诸学边。是人无量福德智慧具足故。魔若魔民无能降伏。如是正学故直到阿鞞跋致地。如是学为学佛所行道。如是学皆为十方诸佛及大菩萨诸天善人所守护。能如是学。是人无有邪见心无所著。于一切众生能起大慈大悲。大慈大悲故能教化众生。众生心清净故佛界清净。佛界清净已得佛道。三转十二行法轮。以三乘度无量众生。以大乘度众生故不断佛种。不断佛种故于世间常开甘露法门。常示众生无为性。无为性者。所谓如法性实际涅槃。甘露者。无为性门者。三解脱门。下劣者。名懈怠放逸不乐佛法不一心行道罪福杂行。如是等不能学是法。何以故。是下劣者作是念。我身及亲属是我所应护。诸余众生何豫我事。而以头目髓脑施之令其得乐。一切人皆方便求乐。我今何为舍乐求苦。或生邪见复作是念。众生无量无边度不可尽。若可度尽即是有量有边。一佛便可度尽。或作是念。佛说一切法空不生不灭。我复何所度。求佛道不求佛道同如幻梦。如是等下劣人。以种种邪见贪欲因缘故。不能学此大法。或时有大人出世。筹量思惟诸法实相。所谓非常非无常。非有边非无边。非有非无等行如是道。破颠倒见。还舍此道直入法性。常住是清净法性中。以一切众生不知是事故生大悲心。然后修集六波罗蜜等诸功德佛神通智慧无碍解脱。得阿耨多罗三藐三菩提。以种种方便门广度众生。如是人为希有。问曰。如先说众生无量无边。又言。众生空复何所度。如是云何可有所度。答曰。此是下劣人所说。何足以之为证。复次先所说以邪见贪欲因缘故。下劣之人作是念言。众生有边无边一切法空无所有。一切法常实。皆是六十二邪见所摄。大人无欲思惟筹量。离如是过罪住于法性生大悲心。譬如大人但以施心施与他财而不取价。贪欲之人求因缘而与。邪见之人依有边无边等。无有能无利事而有所作。譬如小人市易求利乃与。又复大人菩萨无所求欲。能以头目等施与众生。所得果报亦以施与一切法。心无所依而能集诸功德。是故佛说欲拔一切众生沉没生死者能如是学。复次菩萨如是学者。常有慈悲怜愍心。不恼众生故不堕地狱。常观因缘诸法实相。不生愚痴故不堕畜生。常行布施破悭贪心故不生饿鬼中。佛所说十二部经八万四千法聚。常不吝惜故不生边地。常供养尊长善人破憍慢故不生旃陀罗等下贱人中。深心爱众生。具足行利益事故受身完具。以善法多化众生故。眷属成就终不孤穷。深爱乐尸罗波罗蜜故。不行十恶道及以邪命无有我心。但利益众生不自为身故。不摄恶人及破戒者。恶人名心恶。破戒者名身口恶。复次行三不善道名恶人。行七不善道名破戒。复次菩萨若在家摄恶人名恶人。出家摄恶人名破戒。问曰。菩萨为度恶人故出现于世。譬如良医疗诸疾病。何以故。不摄恶人。答曰。恶人破戒者。有可化有不可化。此中但说不可化者。若摄取共住则自坏其道于彼无益。譬如救溺自不能浮而欲济彼二俱不免。是故说远离恶人。以欲界多恶生怜愍心故生欲界中。虽行禅心调柔软。以方便力故命终时不随禅生。如经中广说。须菩提。菩萨如是学。于一切法中得清净。所谓净声闻辟支佛心。净名舍离无所有毕竟空。须菩提白佛言。若一切法从本已来空清净。云何言菩萨如是学得一切法中清净。佛可须菩提言。为说因缘。若菩萨知一切法从本已来空清净。于是中心不没不却。不没名不疑不生邪见。通达不与空诤。是名般若波罗蜜。一切凡夫人不知不见如是清净法。为是人故行六波罗蜜等诸助道法。菩萨法应教化是众生。是名菩萨一切法中得清净。所谓舍三界颠倒过声闻辟支佛地。一切法中得清净智慧力。得是功德故。三世十方一切众生心心数法。心所行起种种业因缘悉能遍知。知已随其所应为说法开化。如是等利益皆是学般若故得。是故言尽诸学边。少有能如是学。是人难得佛。欲令此义明了故说譬喻金银及转轮圣王业等。复次菩萨学是般若时不生悭等心。不生悭等心者。菩萨学般若波罗蜜故抑制诸烦恼。烦恼虽未尽无所能作。是故言不生。菩萨行般若。知一切诸法相皆虚诳不实故。是以不取色乃至阿耨多罗三藐三菩提相。何以故。不欲令堕有无见中故。直行中道集菩萨行。此中佛自说因缘。菩萨行般若。于一切法无所得。无所得故无有法可取相。若善若不善等。菩萨若能如是学。总摄诸波罗蜜。檀等诸波罗蜜不离般若波罗蜜。般若波罗蜜力故。令余波罗蜜离诸邪见贪着各得增长。佛欲令此义明了故说譬喻。如我见及命根等。问曰。我见诸见各有别相。云何摄入我见中。答曰。虽有别相。我见是本人以无明因缘故空。五众中生我见。生我见故言是身死如去不如去。若如去则是常见。若不如去则是断见。若谓断灭现今受乐着五欲。以恶法为最则生见取。若谓常出家学道持戒苦行则生戒取。或时见断常。俱有过故便言无因缘果报。则生邪见住是五见中。世间常无常前际后际等。生五十七见。是故说身见摄六十二见无咎。如是等种种因缘譬喻。故知般若波罗蜜诸法中最第一。般若波罗蜜诸法中最第一故。菩萨学是般若故。于众生中第一。佛欲以是事善化众生故说譬喻。须菩提。于汝意云何。三千大千世界中众生多不。如是等乃至菩萨。如是学当知是不退转。远离二乘近佛乘。复次佛告须菩提。若菩萨作是念。是般若波罗蜜。是般若波罗蜜者。示般若波罗蜜相。若有若无等见般若。得般若着般若等。我以是般若波罗蜜。得一切种智者。五众和合假名菩萨。菩萨随逐假名字计以为我。以是般若有所作。般若是无著相。而是人说有相。般若是第一义。是人随假名而生我心。般若是无作相。而是人欲用般若有所作。所谓我用是般若得阿耨多罗三藐三菩提。是故佛言。作如是念者。不名行般若。若不如是念名为行般若波罗蜜。问曰。作是念不作是念事已尽。何以复有第三说。答曰。初者是邪行相。第二遮邪行未说正行相。是故第三说正行相。复次初是着心取相。第二破是着相。不说云何是诸法相。第三中破邪着亦说实相。菩萨作是念。于一切处不显示般若波罗蜜相。亦不生我心。我用般若波罗蜜有所作。但知一切法常住如法性实际中。于如法性实际中不诤。是故说第三无咎

大智度论卷第七十七大智度论释愿乐品第六十四(卷七十八)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】尔时释提桓因作是念。菩萨摩诃萨行般若波罗蜜禅波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀波罗蜜。乃至十八不共法时。出一切众生之上。何况得阿耨多罗三藐三菩提时。是诸众生闻是萨婆若信者。得人中之善利寿命中最。何况发阿耨多罗三藐三菩提意者。是众生能发阿耨多罗三藐三菩提意者。其余众生应当愿乐。尔时释提桓因以天曼陀罗华而散佛上发是言。以此福德。若有求阿耨多罗三藐三菩提者。令此人具足佛法具足一切种智具足自然法。若求声闻者令具足声闻法。世尊。若有菩萨发阿耨多罗三藐三菩提意者。我终不生一念令其转还。我亦不生一念令其转还堕声闻辟支佛地。世尊。我愿诸菩萨倍复精进于阿耨多罗三藐三菩提。见众生生死中种种苦恼。欲利益安乐一切世间天及人阿修罗。以是心作是愿。我既自度亦当度未度者。我既自脱当脱未脱者。我既安隐当安未安者。我既灭度当使未入灭度者得灭度。世尊。善男子善女人于初发意菩萨功德随喜心。得几许福德。于久发意菩萨功德随喜心。得几许福德。于阿鞞跋致菩萨功德随喜心。得几许福德。于一生补处菩萨功德随喜心。得几许福德。佛告释提桓因。憍尸迦。四天下世界可称知斤两。是随喜心福德不可称量。复次憍尸迦。是三千大千世界皆可称知斤两。是随喜心福德不可称量。复次憍尸迦。三千大千世界满中海水。取一发破为百分。以一分发渧取海水可知渧数。是随喜心福德不可数知。释提桓因白佛言。世尊。若众生心不随喜阿耨多罗三藐三菩提者。皆是魔眷属。诸心不随喜者。从魔中来生。何以故。世尊。是诸发心菩萨。为破魔境界故生。是故欲爱敬三尊者。应生随喜心。随喜已应回向阿耨多罗三藐三菩提。以不一不二相故。佛言。如是如是。憍尸迦。若有人于菩萨能如是随喜回向者。常值诸佛终不见恶色。终不闻恶声。终不嗅恶香。终不食恶味。终不触恶触。终不随恶念。终不远离诸佛。从一佛界至一佛界。亲近诸佛种善根。何以故。善男子善女人为无量阿僧祇初发意菩萨诸善根随喜回向。为无量阿僧祇第二地第三地乃至第十地一生补处诸菩萨摩诃萨善根随喜。回向阿耨多罗三藐三菩提。以是善根因缘故。疾近阿耨多罗三藐三菩提。是诸菩萨得阿耨多罗三藐三菩提已。度无量无边阿僧祇众生。憍尸迦。以是因缘故。善男子善女人于初发意菩萨善根应随喜。回向阿耨多罗三藐三菩提。非心非离心。于久发意阿鞞跋致一生补处善根随喜。回向阿耨多罗三藐三菩提。非心非离心。须菩提白佛言。世尊。是心如幻。云何能得阿耨多罗三藐三菩提。佛告须菩提。于汝意云何。汝见是心如幻不。不也世尊。我不见幻。亦不见心如幻。须菩提。于汝意云何。若无幻亦无心如幻。汝见是心不。不也世尊。须菩提。于汝意云何。离幻离心如幻。汝见更有法得阿耨多罗三藐三菩提不。不也世尊。我不见离幻离心如幻更有法得阿耨多罗三藐三菩提。世尊。我不见更有法何等法可说若有若无。是法相毕竟离故。不堕有不堕无。若法毕竟离者。不能得阿耨多罗三藐三菩提无所有法。亦不应得阿耨多罗三藐三菩提。何以故。世尊。一切法无所有。是中无垢者无净者。世尊。以是故般若波罗蜜毕竟离。禅波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀波罗蜜毕竟离。乃至阿耨多罗三藐三菩提亦毕竟离。若法毕竟离。则不应修不应坏。行般若波罗蜜亦无有法可得。毕竟离故。世尊。若般若波罗蜜毕竟离者。云何因般若波罗蜜得阿耨多罗三藐三菩提。阿耨多罗三藐三菩提亦毕竟离。二离中云何能有所得。佛告须菩提。善哉善哉。是般若波罗蜜毕竟离。禅波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀波罗蜜毕竟离。乃至一切种智毕竟离。须菩提。若般若波罗蜜毕竟离。乃至一切种智毕竟离。以是故能得阿耨多罗三藐三菩提。须菩提。若般若波罗蜜非毕竟离。乃至一切种智非毕竟离。是不名般若波罗蜜。不名禅波罗蜜乃至一切种智。须菩提。若般若波罗蜜毕竟离。乃至一切种智毕竟离。以是故须菩提。非不因般若波罗蜜得阿耨多罗三藐三菩提。亦不以离得离。而得阿耨多罗三藐三菩提。非不因般若波罗蜜。须菩提白佛言。世尊。菩萨摩诃萨所行义甚深。佛言。如是须菩提。菩萨摩诃萨所行义甚深。须菩提。诸菩萨摩诃萨能为难事。所谓行是深义。而不证声闻辟支佛地。须菩提白佛言。世尊。如我从佛闻义。菩萨摩诃萨所行不为难。何以故。是菩萨摩诃萨不得是义可作证亦不得般若波罗蜜作证。亦无作证者。世尊。若一切法不可得。何等是义可作证。何等是般若波罗蜜作证。何等是作证者。作证已得阿耨多罗三藐三菩提。世尊。是名菩萨摩诃萨无所得行菩萨行。是于一切法皆得明了。世尊。若菩萨摩诃萨闻是深法。心不惊不没不怖不畏。是名为行般若波罗蜜。是菩萨摩诃萨行般若波罗蜜时。不见我行般若波罗蜜。亦不见是般若波罗蜜。亦不见我当得阿耨多罗三藐三菩提。何以故。菩萨摩诃萨行般若波罗蜜时。不作是念。声闻辟支佛地去我远。萨婆若去我近。世尊。譬如虚空不作是念。有法去我远去我近。何以故。世尊。虚空无分别故。世尊。行般若波罗蜜菩萨亦不作是念。声闻辟支佛地去我远。萨婆若去我近。何以故。般若波罗蜜中无分别故。世尊。譬如幻人不作是念。幻师去我近观人去我远。何以故。幻人无分别故。行般若波罗蜜菩萨亦不作是念。声闻辟支佛地去我远。萨婆若去我近。世尊。譬如镜中像不作是念。所因者去我近余者去我远。何以故。像无分别故。行般若波罗蜜菩萨亦不作是念。声闻辟支佛地去我远。萨婆若去我近。何以故。般若波罗蜜中无分别故。世尊。行般若波罗蜜菩萨无爱无憎。何以故。般若波罗蜜自性不可得故。世尊。譬如佛无爱无憎。行般若波罗蜜菩萨无爱无憎亦如是。何以故。般若波罗蜜中无憎无爱故。世尊。譬如佛一切分别想断。行般若波罗蜜菩萨亦如是。一切分别想断毕竟空故。世尊。譬如佛所化人不作是念。声闻辟支佛去我远。阿耨多罗三藐三菩提去我近。何以故。佛所化人无分别故。行般若波罗蜜菩萨亦如是。不作是念。声闻辟支佛去我远。阿耨多罗三藐三菩提去我近。世尊。譬如有所为故作化。化所作事无分别。世尊。般若波罗蜜亦如是。有所为事而修是事成就。而般若波罗蜜亦无分别。世尊。譬如工匠若工匠弟子。有所为故作木人。若男若女象马牛羊。是所作亦能有所作。是亦无分别。世尊。般若波罗蜜亦如是。有所为故说是事成就。而般若波罗蜜亦无分别。舍利弗问须菩提。但般若波罗蜜无分别。禅波罗蜜乃至檀波罗蜜亦无分别。须菩提语舍利弗。禅波罗蜜无分别。乃至檀波罗蜜亦无分别。舍利弗问须菩提。色无分别乃至识亦无分别。眼乃至意无分别。色乃至法无分别。眼识触乃至意识触无分别。眼触因缘生受。乃至意触因缘生受。四禅四无量心四无色定四念处。乃至八圣道分空无相无作。佛十力四无所畏四无碍智。大慈大悲十八不共法。阿耨多罗三藐三菩提无为性亦无分别。须菩提。若色无分别。乃至无为性无分别。若一切法无分别。云何分别有六道生死。是地狱是饿鬼是畜生是天是人是阿修罗。云何分别是须陀洹斯陀含阿那含阿罗汉辟支佛诸佛。须菩提报舍利弗。众生颠倒因缘故。造作身口意业。随欲本业报受六道身。地狱饿鬼畜生人天阿修罗身。如汝言。云何分别有须陀洹乃至佛道。舍利弗。须陀洹即是无分别故有。须陀洹果亦是无分别故有。乃至阿罗汉阿罗汉果辟支佛辟支佛道佛佛道亦是无分别故有。舍利弗。过去诸佛亦是无分别。断分别故有。以是故舍利弗。当知一切法无有分别。不坏相如法如法性实际故。舍利弗。如是菩萨摩诃萨。应行无分别般若波罗蜜。行无分别般若波罗蜜已。便得无分别阿耨多罗三藐三菩提

【论】释曰。是时释提桓因。及会中人皆共欢喜。释提桓因作是念。是菩萨行菩萨道时。所有功德尚胜一切众生。何况成阿耨多罗三藐三菩提。众生有二种。一者发心。二者未发心。发心菩萨胜一切未发心者。所以者何。是人种无量无上佛法因缘。欲度一切众生令离苦得乐。其余众生但自求乐欲与他苦。如是等因缘故发心者胜。问曰。诸阿罗汉辟支佛及五通是离欲人发心者。或有未离欲但发心。云何得胜。答曰。是事先品中已种种答。阿罗汉等虽漏尽不如初发心菩萨。譬如转轮圣王太子虽在胎中已胜余子。又如国王太子虽未即位胜诸大臣有位富贵者。发心菩萨有二种。一者行诸波罗蜜等菩萨道。二者但空发心。此中说行菩萨道者。是人虽事未成就。能胜一切众生。何况成就。如歌罗频伽鸟在[聲-耳+卵]中未发声已能胜诸鸟。何况成就。菩萨亦如是。虽未成佛。行菩萨道说诸法实相音声。破诸外道及魔民戏论。何况成佛。有人言。若有能一发心言。我当作佛灭一切众生苦。虽未断烦恼未行难事。以心口业重故胜于一切众生。一切众生皆自求乐。自为身故爱其所亲。阿罗汉辟支佛虽不贪世乐。自为灭苦故求涅槃乐。不能为众生。菩萨心生口言为度一切。是故胜。譬如一六神通阿罗汉。将一沙弥令负衣钵循路而行。沙弥思惟。我当以何乘入涅槃。即发心。佛为世尊最上最妙。我当以佛乘入涅槃。师知其念。即取衣钵自担。推沙弥在前行。沙弥覆复思惟。佛道甚难。久住生死受无量苦。且以小乘早入涅槃。师复以衣钵囊还与沙弥令担。语在后行。如是至三。沙弥白师。师年老耄状如小儿戏。方始令我在前已复令我在后。何其太速。师答。汝初念发心作佛。是心贵重则住我师道中。如是人诸辟支佛尚应供养。何况阿罗汉。以是故推汝在前。汝心还悔。欲取小乘。而未便得。汝去我悬远。是故令汝在后。沙弥闻已惊悟。我师能知我心。我一发意已胜阿罗汉。何况成就。即自坚固住大乘法。复次胜名不必一切事中皆胜。但以一发心欲作佛度众生。是事为胜。诸余禅定解脱等犹尚未有何得言胜。譬如以飞言之鸟则胜人。未来当得功德。此事不论。小乘人言。乃至补处菩萨尚不胜小沙弥得无量律仪者。摩诃衍论中或有人如是言。其有发大乘心者。虽复在弊恶小人中。犹胜二乘得解脱者。是名二边。离是二边名为中道。中道义如上说。以其有义理实故应当取。是故说初发心时胜一切众生。何况成佛。闻萨婆若信者。得人中善利。有人言。六波罗蜜是利。有人言。六波罗蜜果报是利。所谓转轮圣王释梵天王人王法王等。有人言。得阿鞞跋致不堕恶道。常生人天富贵处。有人言。菩萨住于果报神通。游至十方供养诸佛。种种方便教化众生。信受因缘教化众生。得如是等大利。寿命中最者。众生有二种命。一者命根。二者智慧命。是人得智慧命故。说寿命中最。何况发心。发心者可敬可贵。所以者何。如先说因缘。能舍自乐与他乐。不自忧苦忧他人苦故。尔时释提桓因欲现欢喜相。以天文陀罗花散佛上。如经广说。问曰。罪福不可以与人。虽欲与亦不得。释提桓因何以言以此福德令求佛道者具足佛法。答曰。虽不可与人。然自令心好。又是释提桓因显此不着福。是故以随喜心与求佛道者。与声闻人亦尔。释提桓因白佛。我虽得声闻道。亦不生一念令菩萨转还向二乘心。所以者何。诸菩萨见众生在生死中有种种苦。欲利益一切世间故作是愿。未度者我当等度。尔时会中众生有作是念。若如上说。随喜有功德。初发心人随喜。于久发心人随喜有何差别。释提桓因欲解众人疑故问佛言。世尊于初发心菩萨功德随喜得几许福德。如经广说。是福德无量无边。以种无量无边田中人不能数知。故说譬喻令解。如经中广说。随喜之德虽无量无边。于近佛道者随喜福德转多。是时帝释欢喜故白佛言。世尊诸有闻是功德不随喜者。则是魔民从魔天来。所以者何。在魔境界积集恶心故不随喜。此中说因缘随喜心能破魔界。是故求佛道者欲爱敬三尊不舍者。当以随喜心回向阿耨多罗三藐三菩提。不一不二相者不见诸法有一定相不属因缘者故言不一。不分别随喜心回向心。是名不二。毕竟空故佛可帝释意已。更称说随喜功德。是人常忆念十方诸佛功德随喜故。疾得见佛。又以深心于一切众生欲令离苦得乐。是故往来生死六情初不受恶尘。终不离生诸佛前。以不断种见佛行故。此中佛自说因缘。是人于无央数阿僧祇。初发心菩萨乃至无量一生补处菩萨。皆随喜故得如上果报。疾成佛道度无量阿僧祇众生。复次憍尸迦。是菩萨因是福德如诸法实相。回向于实相中心不可得。是故说非心亦不离心。如上说不一不二义。以事异故更说。须菩提闻已取是空无有心相难佛。是心非心空无所有如幻。云何能得阿耨多罗三藐三菩提。佛反问须菩提。汝见是空心定相如幻不。须菩提作是念。心若空如幻云何可见。若可见则非空。是故答言不。佛言。心若空无所有。汝见是中有。是若有若无戏论不。答言不也。离是空无所有如幻心。汝见更有法能得无上道不。答言不见。不见不可得故何有法。若有若无一切诸法毕竟离故毕竟空故。不堕有不堕无。若法不堕有无中。是则毕竟无所有不应得无上道。以是因缘故般若波罗蜜毕竟离相。见有无二俱过故。禅波罗蜜乃至阿耨多罗三藐三菩提亦如是毕竟离相。若法毕竟离则不可得见不可得修不可得断不可得证。行是法则更无所得。毕竟离故。世尊今般若波罗蜜毕竟离。阿耨多罗三藐三菩提毕竟离。云何以毕竟离得毕竟离。若一法毕竟离。尚不应有所得。何况二离。譬如以指触虚空。虚空无触故指不能触。何况二皆无触。亦如虚空涅槃。般若波罗蜜毕竟离。阿耨多罗三藐三菩提毕竟离。云何用离得离。佛知须菩提。随诸法实相说故。可其言善哉善哉。即说因缘。须菩提。若般若波罗蜜毕竟离。阿耨多罗三藐三菩提毕竟离。以是因缘故可得。何以故。若一法定有相非空者。则是常法不生相。从未来至现在。从现在至过去。若无实生相则无灭相。若无生灭则无四谛。若无四谛则无法宝。法宝无故亦无阿耨多罗三藐三菩提。法宝即是阿耨多罗三藐三菩提故。若无法宝则无佛宝。若无佛法则无僧宝。若无三宝则无一切诸法。有如是等过罪故。毕竟离相则通达无碍。若说毕竟离当知亦离空。若不离空不名毕竟离。是故经说言。般若波罗蜜毕竟离故。能得阿耨多罗三藐三菩提。虽不离般若波罗蜜。得阿耨多罗三藐三菩提。亦不以二离而得二离。毕竟空故不应难须菩提知佛所说甚深相。是故白佛言。若菩萨能如是行。则是行甚深义。佛可其言。是菩萨能为难事。能行如是甚深义而不证二乘。所以者何。是菩萨一心以利智深入空而不证涅槃。是则为难。须菩提言。如我解佛所说义。是不为难。何以故。是人不得是甚深义。一定相可作证。不得般若波罗蜜。不得证者谁当以甚深义得证。若不证是甚深义。谁当得阿耨多罗三藐三菩提。是名菩萨无所得行。行是道则照明一切法。问曰。佛说言难。须菩提言不难。师弟子义应同。何以各相违背。答曰。佛以世谛故说。须菩提以第一义谛故说。佛说菩萨得是甚深义。须菩提说菩萨亦不得是甚深义。佛以须菩提为众生故说。有人闻难事则发心故说难事。有人闻难事而废退故说无难。是名菩萨无所得行。住是行中于一切法通达无碍。须菩提言。若菩萨闻如是说毕竟离无法可证无取证者。亦无般若及阿耨多罗三藐三菩提。是时不惊不没通达无碍者。是名行般若波罗蜜。行般若波罗蜜者是名真行深行。何以故。是菩萨不见般若波罗蜜。亦不见我行般若波罗蜜。不见阿耨多罗三藐三菩提。亦不见是法可得阿耨多罗三藐三菩提。都无所分别。是菩萨安住一切诸法实相中故。不作是分别。言二乘离我远佛道离我近。此中说虚空等譬喻。此诸譬喻为明了毕竟空义故。般若波罗蜜虽空。若有所修能成其事。乃至如木人随作何事皆能成就。舍利弗问须菩提。但般若无分别。诸波罗蜜亦无分别。若但般若空无分别。余波罗蜜应是有相。是则菩萨道有别异不平等。又初品中说行檀波罗蜜时无施者受者亦无财物。今云何言别。若五事皆空则无分别。无有六名亦无可修行。须菩提言。五波罗蜜亦空无有分别。初发心未得无生法忍者有分别。譬如四河未会大海则有别名既入大海则无差别。菩萨亦如是。世俗谛中有差别。第一义谛则无分别。舍利弗问色乃至阿耨多罗三藐三菩提乃至无为性亦无分别。若此法空无差别。云何有六道别异。云何有分别须陀洹乃至佛道。须菩提答舍利弗。诸法虽毕竟空无分别。而是众生狂颠倒心而起身口意业。随业受身。业报贪欲是本。但为欲所逼而生着心。诸法无有定相。业果报者所谓六道。以是故知空无所分别是其实本。但以颠倒不实故有六道差别。又须陀洹等贤圣亦因毕竟空无分别法生。所谓断三结法名须陀洹果。三结使即是颠倒觉。颠倒除却名为断。是故断法即是空无有分别。世谛故假名人。得是法故名须陀洹果。是故当知须陀洹人及果。毕竟空无分别。乃至佛佛道亦如是。此中说因缘。非但现在无分别。过去如恒河沙诸佛。一切分别断故入无余涅槃。无有少许法定相可分别。一切法毕竟空。入是如法性实际门故。是故言因缘法甚深。入是三昧门故菩萨应如是行无分别般若波罗蜜。行无分别般若波罗蜜故得无分别法。所谓阿耨多罗三藐三菩提

    大智度论释称扬品第六十五

【经】舍利弗语须菩提。菩萨摩诃萨行般若波罗蜜。为行真实法。为行无真实法。须菩提报舍利弗。菩萨摩诃萨行般若波罗蜜。为行无真实法。何以故。是般若波罗蜜无真实。乃至一切种智无真实故。菩萨摩诃萨行般若波罗蜜。无真实不可得。何况真实。乃至行一切种智无真实法不可得。何况真实。尔时欲色界诸天子作是念。诸有善男子善女人。发阿耨多罗三藐三菩提意。如深般若波罗蜜所说义行。于等法不作实际证。不堕声闻辟支佛地。应当为作礼。须菩提语诸天子。诸菩萨摩诃萨于等法不作证声闻辟支佛地不为难。诸菩萨摩诃萨大誓庄严。我当度无量无边阿僧祇众生。知众生毕竟不可得而度众生。是乃为难。诸天子。诸菩萨摩诃萨发阿耨多罗三藐三菩提心作是愿。我当度一切众生。众生实不可得。是人欲度众生。如欲度虚空。何以故。虚空离故。当知众生亦离。虚空空故。当知众生亦空。虚空无坚固。当知众生亦无坚固。虚空虚诳。当知众生亦虚诳。诸天子。以是因缘故。当知菩萨所作为难。为利益无所有众生故而大庄严。是人为众生结誓。为欲与虚空共斗。是菩萨结誓已。亦不得众生。而为众生结誓。何以故。众生离故。当知大誓亦离。众生虚诳故。当知大誓亦虚诳。若菩萨摩诃萨闻是法。心不惊不没。当知是菩萨摩诃萨行般若波罗蜜。何以故。色离即是众生离。受想行识离即是众生离。色离即是六波罗蜜离。受想行识离即是六波罗蜜离。乃至一切种智离即是六波罗蜜离。若菩萨摩诃萨闻是一切诸法离相。心不惊不没不怖不畏。当知是菩萨摩诃萨行般若波罗蜜。佛告须菩提。何因缘故。菩萨摩诃萨于深般若波罗蜜中心不没。须菩提白佛言。世尊。般若波罗蜜无所有故不没。般若波罗蜜离故不没。般若波罗蜜寂灭故不没。世尊。以是因缘故。菩萨于深般若波罗蜜中心不没。何以故。是菩萨不得没者不得没事不得没处。是一切法皆不可得故。世尊。若菩萨摩诃萨闻是法。心不惊不没不怖不畏。当知是菩萨为行般若波罗蜜。何以故。没者没事没处。是法皆不可得故。菩萨摩诃萨如是行般若波罗蜜。诸天及释提桓因天梵天王天及世界主天皆为作礼。佛告须菩提。不但释提桓因诸天梵王及诸天世界主及诸天礼是菩萨行般若波罗蜜者。过是上光音天遍净天广果天净居天。皆为是菩萨摩诃萨作礼。须菩提。今现在十方无量诸佛。亦念是行般若波罗蜜菩萨摩诃萨。当知是菩萨为如佛。须菩提。若恒河沙等世界中众生。悉使为魔。是一一魔复化作魔。如恒河沙等魔。是一切魔不能留难菩萨行般若波罗蜜

【论】释曰。尔时舍利弗闻上无分别相法。心大欢喜问须菩提。若菩萨行般若波罗蜜。为行真实法为行无真实法。真实法者审定不变异。即是可取可着。若不真实即是虚诳妄语。须菩提常乐行深空心无障碍故答。行般若者即是行无真实。何以故。般若波罗蜜空无定相无分别故。乃至一切种智亦如是。菩萨行如是般若波罗蜜时。先来生死中所习所著虚诳有为法尚不可得。何况后来观虚诳因缘生。般若波罗蜜非所著法而可得。是故菩萨观一切世间不真实。亦不着是般若波罗蜜。世谛故说真实第一义中真实不可得。何况不真实。尔时欲色界诸天子欢喜言。其有发菩萨心者皆应礼敬。能为难事能行第一深义而不作证故。第一义即是平等法。但以异名说。须菩提语诸天子。菩萨于平等法不作证不为难。菩萨欲度无量众生。众生毕竟不可得。是则为难。何以故。欲度众生者为欲度虚空。虚空离故众生亦离。虚空虚诳不实故。众生亦虚诳不实。问曰。于平等法而不证。众生毕竟空而度众生。此二俱毕竟空。云何言一难一不难。答曰。众生虚诳假名故。是所著处平等法无为故。非所著处。众生从有为法假名而生。无为法是第一义。于颠倒着处而能不着为难。于无著处不着是不为难。以是故如是说。众生空故大庄严亦空。若大庄严空而能发心为难。菩萨若闻是第一平等义。度众生大庄严皆毕竟空。而心不惊不没。譬如调马自见影不惊。何以故。自知影从身出故。菩萨亦如是。知毕竟空因有为和合虚妄法生故。菩萨闻是事不惊不没。是为行般若波罗蜜。色等法离故众生亦离。离名为空。若众生空法不空应有怖畏。若法亦空无生怖畏处。若菩萨闻是一切法离相心不畏。是亦名菩萨行般若波罗蜜。上闻众生空故不畏。今闻法空故不畏。若闻是二空不畏。是为真行般若。佛问须菩提。何以故。菩萨心不没者。问曰。佛是一切智人。何以问弟子心不惊不没。答曰。以众会有疑敬难故不敢问。是以佛问。复次是第一平等义甚深难得。深处应当没而不没故试问须菩提。复次佛以须菩提为说法主。听者法应问难。问曰。佛为一切智。何以不自为说主而令须菩提说。答曰。众中有人以佛智慧无量无边我等智力有量。若心有所疑不敢发问。为是人故命须菩提说。问曰。若尔者何以不令大菩萨说。答曰。大菩萨智慧亦大不可思议。威德重故亦不敢问难。复次有人言。阿罗汉辟支佛佛三界系无明永尽无余故能如实说法。诸菩萨虽广集福德漏未尽故或不可信。是故不命。问曰。若尔者舍利弗智慧第一及余大弟子何以不命。答曰。是事先已答。所谓须菩提乐于空行偏善说空。般若波罗蜜多说空故令须菩提说。须菩提白佛。一切法毕竟空无所有。无所有故自相离。离相故常寂灭。常寂灭故无忆想分别。是故菩萨不应惊不应没。没者没处没法皆不可得。若菩萨闻是事不惊不没。是为行般若波罗蜜。须菩提答已白佛言。能如是行亦名为行般若波罗蜜。世尊菩萨能如是行。一切诸天帝释及世界主礼菩萨者。地神虚空中神四天王忉利天帝释为主。皆共礼是菩萨。梵天王初禅中梵世界众生主。世界主者欲界余天主。众生多信有此天故。须菩提说言作礼。何以故。是菩萨舍自乐欲利益众生。是三种天但自求乐故。佛语须菩提。非但是三种天作礼。光音天等清净一心诸天皆亦作礼。欲界诸天着淫欲心多故礼不足为贵。初禅天有觉观散乱亦不足为妙。上诸天心清净以菩萨有大功德故作礼尔乃为难。须菩提。菩萨若能如是行般若。为十方无量诸佛所念。佛念因缘如先说。今佛说是菩萨诸佛念果报。所谓当知是菩萨为如佛。以其必至佛道不退故。所以者何。如恒河沙等魔。不能坏是菩萨。如经广说

大智度论卷第七十八大智度论释称扬品第六十五之余(卷七十九)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

须菩提。菩萨摩诃萨成就二法魔不能坏。何等二。观一切法空。不舍一切众生须菩提。菩萨成就此二法魔不能坏。复次须菩提。菩萨摩诃萨复有二法成就魔不能坏。何等二。所作如所言。亦为诸佛所念。菩萨成就此二法魔不能坏。须菩提。菩萨如是行。是诸天皆来至菩萨所。亲近咨问劝喻安慰作是言。善男子。汝疾得阿耨多罗三藐三菩提不久。善男子。汝常当行是空无相无作行。何以故。善男子。汝行是行。无护众生汝为作护。无依众生为作依。无救众生为作救。无究竟道众生为作究竟道。无归众生为作归。无洲众生为作洲。冥者为作明。盲者为作眼。何以故。是菩萨摩诃萨行般若波罗蜜。十方现在无量阿僧祇诸佛。在大众中说法时。自赞叹称扬是菩萨摩诃萨名姓言。某甲菩萨成就般若波罗蜜功德。须菩提。如我今说法时。自称扬宝相菩萨尸弃菩萨。复有诸菩萨摩诃萨。在阿閦佛世界中。行般若波罗蜜净修梵行。我亦称扬是菩萨名姓。须菩提。亦如东方现在诸佛说法时。是中有菩萨摩诃萨净修梵行。佛亦欢喜自称扬赞叹是菩萨。南西北方四维上下亦如是。复有菩萨从初发意欲具足佛道乃至得一切种智。诸佛说法时亦欢喜自称扬赞叹是菩萨。何以故。是诸菩萨摩诃萨所行甚难。不断佛种行。须菩提白佛言。世尊。何等菩萨摩诃萨。诸佛说法时自赞叹称扬。佛告须菩提。阿鞞跋致菩萨诸佛说法时自赞叹称扬。须菩提言。何等阿鞞跋致菩萨为佛所赞。佛言。如阿閦佛为菩萨时所行所学。诸菩萨亦如是学。是诸阿鞞跋致菩萨诸佛说法时欢喜赞叹。复次须菩提。有菩萨行般若波罗蜜。信解一切法无生。未得无生忍法。信解一切法空。未得无生忍法。信解一切法虚诳不实不坚固。未得无生忍法。须菩提。如是等诸菩萨摩诃萨。佛说法时欢喜自赞叹称扬名姓。须菩提。若诸菩萨摩诃萨诸佛说法时欢喜自赞叹者。是菩萨灭声闻辟支佛地。当得阿耨多罗三藐三菩提记。须菩提。若菩萨摩诃萨诸佛说法时欢喜自赞叹者。是菩萨当住阿鞞跋致地。住是地已当得萨婆若。复次须菩提。若菩萨摩诃萨闻是深般若波罗蜜。其心明利不疑不悔作是念。是事如佛所说。是菩萨亦当于阿閦佛及诸菩萨所。广闻是般若波罗蜜亦信解。信解已如佛所说。当住阿鞞跋致地。如是须菩提。但闻般若波罗蜜得大利益。何况信解。信解已如说住如说行。如说住行已住一切种智中。须菩提白佛言。世尊。若佛说。菩萨摩诃萨如所说住如所说行住萨婆若。若菩萨摩诃萨无所得法。云何住萨婆若。佛告须菩提。菩萨摩诃萨住诸法如中住萨婆若。须菩提言。世尊。除如更无法可得。谁住如中。住如中已当得阿耨多罗三藐三菩提。谁住如中当说法。如尚不可得。何况住如得阿耨多罗三藐三菩提。谁住如中而说法。无有是处。佛告须菩提。如汝所言。除如更无法。谁住如中。住如中已当得阿耨多罗三藐三菩提。谁住如中当说法。如尚不可得。何况住如得阿耨多罗三藐三菩提。谁住如中而说法。无有是处。佛言。如是如是。须菩提。除如更无有法可得。谁住如中。住如中已当得阿耨多罗三藐三菩提。谁住如中当说法。如尚不可得。何况住如中得阿耨多罗三藐三菩提。谁住如中而说法。何以故。是如生不可得灭不可得住异不可得。若法生灭住异不可得。是中谁当住如。谁当住如已得阿耨多罗三藐三菩提。谁当住如而说法。无有是处。释提桓因白佛言。世尊。诸菩萨摩诃萨所为甚难。深般若波罗蜜中欲得阿耨多罗三藐三菩提。何以故。世尊。无有如中住者。亦无当得阿耨多罗三藐三菩提者。亦无说法者。菩萨摩诃萨于是处心不惊不没不怖不畏不疑不悔

尔时须菩提语释提桓因。如憍尸迦说。菩萨摩诃萨所为甚难。是甚深法中心不惊不没不怖不畏不疑不悔。憍尸迦。诸法空中谁惊谁没谁怖谁畏谁疑谁悔。是时释提桓因语须菩提。须菩提所说。但为空事无所挂碍。譬如仰射空中箭去无碍。须菩提说法无碍亦如是

【论】释曰。众会疑菩萨何因缘故。得如是力魔不能坏。佛答有二因缘故魔不能坏。一者观诸法空。二者不舍一切众生。以日月因缘故万物润生。但有月而无日则万物湿坏但有日而无月则万物燋烂。日月和合故万物成熟。菩萨亦如是。有二道一者悲二者空。悲心怜愍众生誓愿欲度空心来则灭怜愍心。若但有怜愍心无智慧。则心没在无众生而有众生颠倒中。若但有空心舍怜愍度众生心则堕断灭中。是故佛说二事兼用。虽观一切空而不舍众生。虽怜愍众生不舍一切空。观一切法空空亦空故不着空。是故不妨怜愍众生。观怜愍众生亦不着众生。不取众生相。但怜愍众生引导入空。是故虽行怜愍而不妨空。虽行空亦不取空相故。不妨怜愍心。如日月相须。诸神天轻贱妄语人。若菩萨不如所说行。则五种执金刚神舍离不复守护。恶鬼得便是人喜生恶心。恶心故则生恶业。生恶业故则堕恶道。菩萨不为诸佛所念者则善根朽坏。如鱼子不为母念则烂坏不生。是故言所作如所言。亦为诸佛所念。得此二法故不可破坏。若菩萨能如是真行般若波罗蜜魔不能坏。功德智慧增益。诸天则来亲近咨问安慰劝喻作是言。善男子。汝疾得阿耨多罗三藐三菩提不久。以是因缘故常行空行。问曰。诸天未得一切智。云何能与菩萨授记。答曰。诸天长寿从过去诸佛闻如是行得记。今见菩萨有如是行故说。见因知有果故。诸天见是菩萨行三解脱门印。亦兼行慈悲心于众生。是故说言不久作佛。无守护众生汝为作守护。无归与作归等义如先说。若菩萨能如是行甚深般若波罗蜜。十方现在无量诸佛说法时。称扬赞叹是名字者。如我今称扬宝相菩萨尸弃菩萨及阿閦佛世界中菩萨。又如十方佛说法时称扬诸妙行菩萨。菩萨能如所说应诸法实相者。十方诸佛说法时。亦以是菩萨为譬喻。作是言某方某世界菩萨虽未作佛。能如是行甚深般若波罗蜜。功德希有故如大国王有大将不惜身命有方便能破怨敌常为国王所称誉。菩萨亦如是。观毕竟空不惜我身。破烦恼贼有方便而不作证。教化众生诸佛所称誉。诸佛虽无著心无分别善不善法视诸阿罗汉外道亦无憎爱。为利益众生故赞叹善人称扬善法毁訾不善。所以者何欲使众生依附好人心随善法。令出世间故。问曰。何经中说二菩萨。佛所赞叹。答曰。佛经无量佛涅槃后诸恶邪见王出焚烧经法。破坏塔寺害诸沙门。五百岁后像法不净。诸阿罗汉神通菩萨难可得见。故诸深经不尽在阎浮提。行者受者少故诸天龙神持去。问曰。如遍吉菩萨观世音菩萨大力势菩萨文殊尸利弥勒菩萨等。何以故不赞叹而但称誉二菩萨。答言。是二菩萨未得无生忍法而能似无生忍法行。必有此事一切魔民所不能坏。是故佛叹希有。复次是二菩萨清净大愿行深大慈悲心。不期疾作佛为度众生故。有如是等功德故佛称赞。复次遍吉观世音菩萨等功德极大人皆知是二菩萨人未知。故称扬阿閦佛世界菩萨皆效阿閦佛。初发心来行清净不杂行。生彼菩萨皆效其行。是故说阿閦佛世界菩萨称誉其德。又如十方诸佛亦称扬诸世界上妙菩萨。亦如释迦文尼佛称扬二菩萨。何等是菩萨。从初发意乃至十地。佛赞叹是菩萨所为甚难能不断佛种。此中须菩提问何等菩萨。佛说法时称扬赞叹说其名字。问曰。佛已先说。须菩提何以更问。答曰。佛初说大菩萨。后称说一切菩萨。从初发意乃至十地。是故须菩提疑问佛。佛赞叹何等菩萨称其名字。佛答佛虽皆爱念一切菩萨。其中有德行胜者称扬其名字。何等菩萨佛所称叹。如阿閦佛初发心时。行清净行不休不息。乃至阿耨多罗三藐三菩提。如是等菩萨佛所赞叹。复次有菩萨未得无生法忍。未入菩萨位。行般若波罗蜜力故。常思惟筹量求诸法实相。能信解忍通一切法无生相空虚诳不坚固。有如是等相。诸菩萨摩诃萨。佛称名赞叹。虚诳不实不坚固者皆是无常。苦无我门。一切法空者即是空门。一切法无生者即是诸法实相灭诸观。复次虚诳不实不坚固即是无作解脱门。一切法空即是空解脱门。一切法无生即是无相解脱门。如是等三种差别。是人出柔顺法忍。未得无生法忍。出凡夫法未入圣法而能信受圣法。似得圣法人是故希有。如佛所称誉。阿鞞跋致菩萨能断二地得受记。是人为佛所称誉亦如是。如是相人虽未得无生法忍。智慧力故为诸佛称名赞叹。今以信根力胜故。佛亦称名赞叹。何者是所谓。复次须菩提。若菩萨摩诃萨闻是深般若。其心明利不疑不悔作是念。是事如佛所说。问曰。是菩萨已信解般若波罗蜜。何以更从阿閦佛及诸菩萨边闻。答曰。是人闻阿閦佛作菩萨时所行清净。是人闻已欲效阿閦佛所行。是故佛说此人于是得信力。于彼得智慧力。故当住阿鞞跋致地。是人未得无生忍法。以智慧力故得如阿鞞跋致。为诸佛所赞。有信力故得。如阿鞞跋致为诸佛所赞。若但闻般若得如是利益。何况信受如所说行。渐住一切种智中。须菩提问佛一切法空相无所得。云何菩萨住萨婆若。佛言如中住。如者即是空。菩萨住是毕竟空中名为住萨婆若。此中须菩提问佛。除如更无法可得。谁住如中乃至无有是处。如经广说。佛可须菩提所语。说如亦空因缘。所谓是如生灭住异不可得。若法无三相即是毕竟空云何可住。若住此中得阿耨多罗三藐三菩提。而说法无有是处。释提桓因欲取般若一定相。闻佛共须菩提说无相亦不可得。是故白佛言。希有世尊。是般若甚深是菩萨所为甚难。欲得阿耨多罗三藐三菩提。何以故。是如毕竟空除如更无。菩萨住是如中得阿耨多罗三藐三菩提。亦无定法名为佛。说法者所度众生亦不离如。亦无拔出处涅槃。诸法常住如相故。菩萨闻是事心不疑悔是事为难。虽信一切法毕竟空。而欲求阿耨多罗三藐三菩提。精进不休不息是为难。须菩提语帝释若诸法毕竟空无所有。疑从何生何有难事。帝释心欢喜作是念。须菩提实是乐说空法。须菩提有所解说皆说空事。虽说色等余事其义皆趣向空。若有难问不能作碍。空亦空故若人难空。须菩提先已破空。于有无中都无所碍。譬如仰射空中。虚空即是毕竟空。箭是须菩提智慧。所说如箭于空无碍。势尽自堕非为空尽。须菩提说法因缘事办故便止非为法尽。若有人虽有利箭射壁不能过。人虽有利智慧邪见著有则碍而不能通。是故须菩提说无障无碍法

    大智度论释嘱累品第六十六

【经】尔时释提桓因白佛言。世尊。我如是说如是答。为随顺法不为正答不。佛告释提桓因言。憍尸迦。汝所说所答实皆随顺。释提桓因言。希有世尊。须菩提所乐说皆为空。为无相无作。为四念处。乃至为阿耨多罗三藐三菩提。佛告释提桓因。须菩提比丘行空时檀波罗蜜不可得。何况行檀波罗蜜者。乃至般若波罗蜜不可得。何况行般若波罗蜜者。四念处不可得。何况修四念处者。乃至八圣道分不可得。何况修八圣道分者。禅解脱三昧定不可得。何况修禅解脱三昧定者。佛十力不可得。何况修佛十力者。四无所畏不可得。何况能生四无所畏者。四无碍智不可得。何况能生四无碍智者。大慈大悲不可得何况行大慈大悲者。十八不共法不可得。何况生十八不共法者。阿耨多罗三藐三菩提不可得。何况得阿耨多罗三藐三菩提者。一切智不可得。何况得一切智者。如来不可得。何况当作如来者。无生法不可得。何况无生法作证者。三十二相不可得。何况得三十二相者。八十随形好不可得。何况得八十随形好者。何以故。憍尸迦。须菩提比丘一切法离行。一切法无所得行。一切法空行。一切法无相行。一切法无作行。憍尸迦。是为须菩提比丘所行。欲比菩萨摩诃萨般若波罗蜜行。百分不及一。千分千万亿分。乃至算数譬喻所不能及。何以故。除佛行是菩萨摩诃萨行般若波罗蜜。于声闻辟支佛诸行中。最尊最妙最上。以是故菩萨摩诃萨欲得于一切众生中最上。当行是般若波罗蜜行。何以故。憍尸迦。诸菩萨摩诃萨行般若波罗蜜时。过声闻辟支佛地入菩萨位。能具足佛法得一切种智。断一切烦恼习作佛。是会中诸三十三天。以天文陀罗花散佛及僧。是时八百比丘从坐起以华散佛。偏袒右肩合掌右膝着地白佛言。世尊。我等当行是无上行声闻辟支佛所不能行。尔时佛知诸比丘心行便微笑。如诸佛法。种种色光青黄赤白红缥从口中出。遍照三千大千世界。绕佛三匝还从顶入。尔时阿难偏袒右肩右膝着地白佛言。世尊。何因缘故笑。诸佛不以无因缘而笑。佛告阿难。是八百比丘于星宿劫中。当得阿耨多罗三藐三菩提。佛名散华皆同一字。比丘僧世界寿命皆等。各各过十万岁出家作佛。是时诸世界常雨五色天花。以是故阿难。菩萨摩诃萨欲行最上行。当行般若波罗蜜。佛告阿难。若有善男子善女人。能行是深般若波罗蜜。当知是菩萨人中死此间生。若兜率天上死来生此间。若人中若兜率天上。广闻是深般若波罗蜜。阿难。我见是诸菩萨摩诃萨能行是深般若波罗蜜。阿难。若有善男子善女人。闻是深般若波罗蜜。受持读诵亲近正忆念。转复以般若波罗蜜教行菩萨道者。当知是菩萨面从佛闻深般若波罗蜜。乃至亲近。亦从诸佛所种善根。善男子善女人当作是念。我等非声闻所种善根。亦不从声闻所闻是深般若波罗蜜。阿难。若有善男子善女人。受持是深般若波罗蜜。读诵亲近随义随法行。当知是善男子善女人则为面见佛。阿难。若有善男子善女人。闻是深般若波罗蜜。信心清净不可沮坏。当知是善男子善女人曾供养诸佛种善根。与善知识相得。阿难。于诸佛福田种善根。虽不虚诳要得声闻辟支佛佛而得解脱。应当深了了行六波罗蜜乃至一切种智。阿难。若菩萨深了了行六波罗蜜乃至一切种智。是人若住声闻辟支佛道。不得阿耨多罗三藐三菩提。无有是处。是故阿难。我以般若波罗蜜嘱累汝。阿难。汝若受持一切法。除般若波罗蜜。若忘若失其过小小无有大罪。阿难。汝受持深般若波罗蜜。若忘失一句其过甚大。阿难。汝若受持深般若波罗蜜。后还忘失其罪甚多。以是故阿难。嘱累汝是深般若波罗蜜。汝当善受持读诵令利。阿难。若有善男子善女人。受持般若波罗蜜。则为受持过去未来现在诸佛阿耨多罗三藐三菩提。阿难。若善男子善女人。现在供养我恭敬尊重赞叹。华香璎珞捣香泽香衣服幡盖。应当受持般若波罗蜜读诵说亲近供养恭敬尊重赞叹华香乃至幢幡。阿难。供养般若波罗蜜。则为供养我。亦供养过去未来现在佛已。若有善男子善女人。闻说深般若波罗蜜信心清净恭敬爱乐。则为信心清净恭敬爱乐过去未来现在诸佛已。阿难。汝爱乐佛不舍离。当爱乐般若波罗蜜莫舍离。阿难。深般若波罗蜜乃至一句不应令失。阿难。我说嘱累因缘甚多今但略说如我。为世尊般若波罗蜜。亦是世尊以是故。阿难。种种因缘嘱累汝般若波罗蜜。阿难。今我于一切世间人天阿修罗众中嘱累汝。诸欲不舍佛不舍法不舍僧不舍过去未来现在诸佛阿耨多罗三藐三菩提者。慎莫舍般若波罗蜜。阿难。是我所教化弟子法。阿难。若善男子善女人受持深般若波罗蜜。读诵说正忆念。复为他人种种广说其义。开示演畅分别令易解。是善男子善女人疾得阿耨多罗三藐三菩提。疾近萨婆若。何以故。般若波罗蜜中生诸佛阿耨多罗三藐三菩提。阿难。过去未来诸佛阿耨多罗三藐三菩提。皆从般若波罗蜜中生。今现在东方南方西方北方四维上下诸佛阿耨多罗三藐三菩提。亦从般若波罗蜜中生。以是故阿难。诸菩萨摩诃萨欲得阿耨多罗三藐三菩提。应当学六波罗蜜。何以故。阿难。六波罗蜜是菩萨摩诃萨母。生诸菩萨故。阿难。若有菩萨摩诃萨学是六波罗蜜。皆当得阿耨多罗三藐三菩提。以是故我以六波罗蜜倍复嘱累汝。阿难。是六波罗蜜是诸佛无尽法藏。阿难。十方诸佛现在说法。皆从六波罗蜜法藏中出。过去诸佛亦从六波罗蜜中学得阿耨多罗三藐三菩提。未来诸佛亦从六波罗蜜中学得阿耨多罗三藐三菩提。现在诸佛亦从六波罗蜜中学得阿耨多罗三藐三菩提。过去未来现在诸佛弟子。皆从六波罗蜜中学得灭度。已得今得当得灭度。阿难。汝为诸声闻人说法。令三千大千世界中众生皆得阿罗汉果证。犹未为我弟子事。汝若以般若波罗蜜相应一句教菩萨摩诃萨。则为我弟子事。我亦欢喜。胜教三千大千世界中众生令得阿罗汉果。复次阿难。是三千大千世界中众生。不前不后一时皆得阿罗汉果证。是诸阿罗汉行布施功德持戒禅定功德是功德多不。阿难言。甚多世尊。佛言。阿难。不如弟子以般若波罗蜜相应法为菩萨摩诃萨说乃至一日其福多。置一日但半日。置半日但一食顷。置一食顷但须臾间说其福多。何以故。菩萨摩诃萨善根胜一切声闻辟支佛故。菩萨摩诃萨自欲得阿耨多罗三藐三菩提。亦示教利喜他人。令得阿耨多罗三藐三菩提。阿难。如是菩萨行六波罗蜜行四念处。乃至行一切种智增益善根。若不得阿耨多罗三藐三菩提。无有是处。说是般若波罗蜜品时。佛在四众中天人龙鬼神甄陀罗摩睺罗伽等于大众前。而现神足变化。一切大众皆见阿閦佛比丘僧围绕说法。大众譬如大海水。皆是阿罗汉。漏尽无烦恼皆得自在。得好解脱心好解脱慧好解脱其心调柔。譬如大象。所作以办逮得己利。尽诸有结正智得解脱。一切心心数法中得自在。及诸菩萨摩诃萨无量功德成就。尔时佛摄神足。一切大众不复见阿閦佛声闻人菩萨摩诃萨及其世界。不与眼作对。何以故。佛摄神足故。尔时佛告阿难。如是阿难。一切法不与眼作对。法法不相见。法法不相知。如是阿难。如阿閦佛弟子菩萨世界。不与眼作对。如是阿难。一切法不与眼作对。法法不相知。法法不相见。何以故。一切法无知无见无作无动不可捉不可思议。如幻人无受无觉无真实。菩萨摩诃萨如是行为行般若波罗蜜。亦不着诸法阿难。菩萨摩诃萨如是学。名为学般若波罗蜜。欲得诸波罗蜜。当学般若波罗蜜。何以故。如是学名为第一学最上学微妙学。如是学安乐利益。一切世间。无护者为作护。是诸佛所学。诸佛住是学中。能以右手举三千大千世界还着本处。是中众生无觉知者。何以故。阿难。诸佛学是般若波罗蜜过去未来现在法中得无碍智见。阿难。如般若波罗蜜。于诸学中最尊第一微妙无上。阿难。若有人欲得般若波罗蜜边际。为欲得虚空边际。何以故。阿难。般若波罗蜜无有量。我初不说般若波罗蜜量。名众句众字众是有量。般若波罗蜜无有量。阿难白佛言。世尊。般若波罗蜜何以故无有量。佛告阿难。般若波罗蜜无尽故无有量。般若波罗蜜离故无有量。阿难。过去诸佛皆学般若波罗蜜得度。般若波罗蜜故不尽。未来世诸佛亦学是般若波罗蜜得度。是般若波罗蜜故不尽。现在十方诸佛皆学是般若波罗蜜得度。般若波罗蜜故不尽。已不尽今不尽当不尽。阿难欲尽般若波罗蜜。为欲尽虚空。般若波罗蜜不可尽。已不尽今不尽当不尽。禅波罗蜜乃至檀波罗蜜不可尽。已不尽今不尽当不尽。乃至一切种智亦如是。何以故。是一切法皆无生。若法无生云何有尽。尔时佛出覆面舌相告阿难。从今日于四众中广演开示分别般若波罗蜜。当令分明易解。何以故。是深般若波罗蜜中广说诸法相。是中求声闻辟支佛求佛者。皆当于中学。学已各得成就。阿难。是深般若波罗蜜。则是一切字门。行是深般若波罗蜜能入陀罗尼门。学是陀罗尼门诸菩萨得一切乐说辩才。阿难。般若波罗蜜是三世诸佛妙法。以是故阿难。我为汝了了说若有人受持深般若波罗蜜读诵亲近。是人则能持三世诸佛阿耨多罗三藐三菩提。阿难。我说般若波罗蜜是行者足。汝持是般若波罗蜜陀罗尼故。则能持一切诸法

【论】问曰。释提桓因何以自疑所说。言我为随顺法正答不。答曰。释提桓因非一切智人。虽得初道三毒未尽犹有错谬而自筹量。我虽福德因缘为诸天主。虽得圣道味。而未有一切智。一切漏未尽故。所说或能错谬不自觉知是故问。复次众中大有阿鞞跋致菩萨漏尽阿罗汉及离欲诸天。是诸人见释提桓因与佛须菩提共问难心不怯弱作是念。是释提桓因漏尚未尽何能问难尽诸法边。释提桓因以是事故问佛。复次释提桓因自知所说诸法相无违错。求佛印可使听者信受。故佛即可之。问曰。佛何以可释提桓因说。答曰。释提桓因虽非一切智人。常从佛闻诵读力强。是故所说有理佛便印可。佛说有三种慧。闻慧思慧修慧。有人闻慧思慧明了故。能与修慧人问难。譬如乘船随流不自用力而疾于陆行。如阿难虽未离欲未得甚深禅定。而能与佛漏尽阿罗汉等论议随法无违。释提桓因白佛言。世尊。须菩提好乐说空善巧说空。于诸弟子中最为第一。有所言说皆趣向空无相无作。所谓四念处乃至阿耨多罗三藐三菩提。是法中皆和合毕竟空说。佛语释提桓因。须菩提是行毕竟空人。世世修集非但今世。是人以空解脱门入道。亦以此门教化众生。是人若入深空法尚不得法。何况行是法者。如经说檀波罗蜜不可得。何况行檀者。乃至八十随形好不可得。何况得八十种随形好者。须菩提所行空行。欲比菩萨空行百分不及一。问曰。法空众生空复有何不尽而言百分不及一。答曰。佛此中自说。除佛。诸声闻辟支佛无有及菩萨者。诸法实相有种种名字。或说空或说毕竟空或说般若波罗蜜。或名阿耨多罗三藐三菩提。此中说诸法实相名为空行。如一切声闻弟子中。须菩提空行最胜。如是除佛诸菩萨空行胜于二乘。何以故智慧分别利钝入有深浅故。皆名得诸法实相。但利根者得之了了。譬如破闇故然灯更有大灯明则转胜。当知先灯虽昭微闇不尽。若尽后灯则无用。行空者亦如是。虽俱得道智慧有利钝故。无明有尽不尽。惟有佛智能尽诸无明。复次声闻辟支佛无慈悲心。无度众生心。无净佛世界。无无量佛法。愿无转法轮度众生。亦无入无余涅槃。乃至遗法度众生。愿无有三世度众生心。所谓菩萨时。作佛时。灭度时。非但以空行故与菩萨等。复次二乘得空有分有量。诸佛菩萨无分无量。如渴者饮河不过自足。何得言俱行空不应有异。又如毛孔之空欲比十方空无有是理。是故比佛菩萨千万亿分不及一。佛分别是空行已告释提桓因。若欲于一切众生最上。当行般若波罗蜜。此中佛自说因缘。菩萨学是般若波罗蜜空行。不取空相故过于二地。得无生忍法入菩萨位。入菩萨位故具足佛法。佛法是菩萨道。菩萨道具足故当得一切种智。得一切种智故名为佛断一切烦恼习人是诸事空行为根本。问曰。涅槃是无量。何以言二乘所得有量。答曰。言智慧有分有量。不说诸法法性有量。不闻说大水喻耶。器有量非水有量。复次量无量相待法。于凡人是无量。佛皆能量。尔所分是须陀洹。乃至尔所分是阿罗汉辟支佛菩萨。余残究尽法性是佛。尔时会中诸天以天曼陀罗华散佛等如经中说。问曰。华供养佛及僧。是八百比丘何以独取供养佛。答曰。诸天所散华。诸比丘当分所得。堕衣上者见其色香甚妙。因以发心供养于佛白言。我从今日当行是无上行。所谓毕竟空无相无作等。为度一切众生故。如佛所说二乘所不及。尔时佛微笑。笑义如恒伽提婆品中说。是八百比丘皆是善知识。行同心等世世共修集功德故。一时作佛皆同一字。五色天华供养佛故。世界中常雨五色天曼陀罗华。佛因是事赞般若作是言。阿难欲行最上菩萨道。当行般若波罗蜜。阿难若有善男子。能行是深般若波罗蜜。当知是人人道中来。或兜率天上来。所以者何。三恶道中罪苦多故。不得行深般若。欲界天着净妙五欲心则狂惑不能行。色界天深着禅定味故不能行。无色界无形故不能行。鬼神道眼根等利诸烦恼覆心故。不能专行深般若。人道中苦差三恶道。乐不如诸天。眼等诸根浊重身多地种故。能制苦乐意而行般若。兜率天上常有一生补处菩萨。彼中诸天常闻说般若。五欲虽多法力胜是故说二处来。若从他方佛世界来。若此间有般若波罗蜜处来。复次阿难若有求佛道者。能问能信受持乃至正忆念。当知是人佛常以佛眼见。是诸人等应当作是念。我等便是面从佛受从佛发心种善根。不从二乘发。阿难若有人信心清净不可破坏者。当知是人先世供养无量诸佛。为善知识守护故能受持。问曰。佛亦名为宝。亦名为无上福田。若人从佛种善根。必以三乘法入涅槃不虚。如法华中说。有人或以一华或以少香供养于佛。乃至一称南无佛。如是等人皆当作佛。若尔者有人作是念。但行五波罗蜜欲作佛时乃观空。何用常行般若波罗蜜难知难得空行。答曰。以是事故佛自答。阿难。于佛福田中虽不虚诳。要得三乘入涅槃。应当了了行六波罗蜜。乃至一切种智了了行故。疾得佛道不久受生死苦。般若有如是等利益功德故应当行。阿难。般若有如是功德利益故我嘱累汝。问曰。佛无所贪。乃至一切种智佛。无碍解脱清净微妙。诸佛法犹尚不贪。何以故以般若波罗蜜殷勤嘱累阿难似如贪惜。答曰。诸佛为利益众生故出世。现三十二相八十种随形好。无量光明神足变化皆为众生故。第一利益众生。无过般若波罗蜜。能尽诸苦故。是般若波罗蜜因语言文字章句可得其义。是故佛以般若经卷殷勤嘱累阿难。复次有人见佛殷勤嘱累故言。佛大事办犹尚尊重般若。是法必尊必妙。譬如大富长者。命欲终时以众宝与儿。偏以如意宝珠殷勤嘱累汝勿以此宝自无定色质如虚空微妙难识故而不守护。若失余宝为可。此宝不可失也。大富长者是佛。以般若波罗蜜嘱累阿难。汝好受持守护无令忘失。除般若。虽有十二部经尽皆忘失。其过尚少。若失般若一句其过太多。何以故是深般若法藏。是十方三世诸佛母。能令人疾至佛道。如经中说。三世诸佛皆从般若得。乃至为声闻人说法。其中皆是赞般若事。问曰。说法令三千大千世界众生尽得阿罗汉。云何不如以般若一句教菩萨。答曰。是事先虽答今当更略说。是三千大千世界中众生。虽皆得阿罗汉。自度其身不中作佛。若说般若一句。闻者得作佛故。如人种众果树。不如一人种一如意树。能随人所愿如意皆得。复次为声闻说法中无大慈悲心。大乘法中一句虽少有大慈悲。声闻法中皆自为身。大乘法中广为众生。声闻法中无欲广知诸法心。但欲疾离老病死。大乘法中欲了了知一切法。声闻法功德有限量。大乘法中欲尽诸功德无有遗余。如是等大小乘差别。譬如金刚虽小能胜一切宝不得言少。故不如多三千大千世界中阿罗汉福德比般若一句教菩萨一日乃至须臾其福甚多。此中佛自说因缘。是人自欲得阿耨多罗三藐三菩提。亦教人令得。自行六波罗蜜诸功德亦为人说。菩萨集二处功德不得佛道。无有是处。尔时佛欲明了是事故。引证亦欲证一切法空。不着是空法但怜愍众生故嘱累。如阿閦佛大众庄严不与眼作对。一切法不与眼作对亦如是。肉眼天眼所见。皆是作法虚诳不实。慧眼法眼佛眼。皆是无相无为法。故不可见。若不可见亦不可知。无作等亦如是。所见阿閦佛会如幻如梦。能如是观诸法。是名菩萨行般若。名无所著。佛所嘱累亦无所著。但以大慈悲故赞是般若。一切法虽是不可思议相。而以利益众生故赞叹作是言。阿难如是学为学般若。若欲得一切诸波罗蜜。当学般若波罗蜜。如是等如经广说。佛以无量赞般若。若佛智慧不可尽。般若功德亦不可尽。何以故。般若波罗蜜无量相故。名众等言语章句卷数有量。如小品放光光赞等般若波罗蜜经卷章句有限有量。般若波罗蜜义无量。阿难问般若波罗蜜云何无量。佛答般若波罗蜜相自离。离故从本已来不生不集。不生不集故不尽不灭。此中佛自说因缘。过去无量阿僧祇诸佛及弟子。用是般若波罗蜜照明十方。度无量众生皆共入无余涅槃。般若波罗蜜故不尽。未来现在亦如是。譬如有人欲尽虚空虚空不可尽。般若波罗蜜等诸功德乃至一切种智亦如是。今不尽已不尽当不尽。有人知过去不尽。谓未来现在有尽。是故说三世不可尽。何以故。诸法本无生。云何当尽。佛知般若是真无尽为名字语言句众有尽故嘱累。如人以香油瓶嘱累子弟。虽不惜瓶为受持香油故。语言能持义亦如是。若失语言则义不可得。尔时佛为人信受般若故。出舌相覆面告阿难。我今于四众中嘱累汝般若。汝当为众生解说显示分别令易解。所以现舌相者。世间相法舌能覆鼻是不妄语相。何况覆面。是故佛示众生。我从父母生身有此舌相。欲以般若波罗蜜令汝信解。以汝等未得一切智不能遍知。欲令汝等信故。非以神通力所现。佛于甚深妙法智慧禅定中犹尚不着。何况世间八法。供养利故而作虚诳。于一切法中如鸟飞虚空无所触碍。但以本愿誓度众生。大悲心怜愍一切故。以第一利般若波罗蜜殷勤嘱累汝。复次阿难是行深般若波罗蜜者。能入一切文字陀罗尼。因一字即入毕竟空。是名文字陀罗尼。如先陀罗尼中说。诸文字法皆因般若波罗蜜得。余闻持等诸陀罗尼亦皆从学般若波罗蜜得。菩萨得诸陀罗尼已得种种乐说辩才。无量阿僧祇劫说一句义不可尽。是名三世诸佛真法。更无异法。又复阿难般若是十方三世诸佛妙法如一门城。四方来者无异门入。阿难。我今为汝了了说。若有人受持般若。非但受持我法。是人受持三世诸佛阿耨多罗三藐三菩提。阿难是般若波罗蜜。我处处说。是行者足。所以者何。菩萨得是般若能行菩萨道。阿难。汝得是般若波罗蜜陀罗尼故。能持一切佛所说法。问曰。以闻持陀罗尼力故能持。何以言得般若故能持一切诸佛法。答曰。闻持陀罗尼。能持有数有量法世间亦有如须尸摩外道亦得闻持陀罗尼。是人虽少时得久则忘失。从般若得陀罗尼。广受持诸法终不忘失。以是为差别。问曰。般若便是波罗蜜。何以名为陀罗尼。答曰。诸法实相是般若。能种种利益众生爱念故作种种名。如佛有十号等文字。般若波罗蜜亦如是。能到一切诸智慧边。是名为般若波罗蜜。菩萨行般若作佛已。变名为阿耨多罗三藐三菩提。若在小乘心中。但名为三十七品三解脱门。若人欲得闻而不忘。在是人心中名为陀罗尼。是故佛说如意珠譬喻。随前物色变为名佛如是种种说般若大功德

大智度论卷第七十九大智度论释无尽方便品第六十七(卷八十)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】尔时须菩提作是念。是诸佛阿耨多罗三藐三菩提甚深。我当问佛。作是念已白佛言。世尊。是般若波罗蜜不可尽。佛言。虚空不可尽故。般若波罗蜜不可尽。世尊。云何应生般若波罗蜜。佛言。色不可尽故。般若波罗蜜应生。受想行识不可尽故。般若波罗蜜应生。檀波罗蜜不可尽故。般若波罗蜜应生。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜不可尽故。般若波罗蜜应生。乃至一切种智不可尽故。般若波罗蜜应生。复次须菩提。痴空不可尽故菩萨摩诃萨般若波罗蜜应生。行空不可尽故。菩萨般若波罗蜜应生。识空不可尽故。菩萨般若波罗蜜应生。名色空不可尽故。菩萨般若波罗蜜应生。六处空不可尽故。菩萨般若波罗蜜应生。六触空不可尽故。菩萨般若波罗蜜应生。受空不可尽故。菩萨般若波罗蜜应生。爱空不可尽故。菩萨般若波罗蜜应生。取空不可尽故。菩萨般若波罗蜜应生。有空不可尽故。菩萨般若波罗蜜应生。生空不可尽故。菩萨般若波罗蜜应生。老死忧悲苦恼空不可尽故。菩萨般若波罗蜜应生。如是须菩提。菩萨摩诃萨般若波罗蜜应生。须菩提。是十二因缘是独菩萨法。能除诸边颠倒。坐道场时应如是观。当得一切种智。须菩提。若有菩萨摩诃萨。以虚空不可尽法。行般若波罗蜜。观十二因缘。不堕声闻辟支佛地。住阿耨多罗三藐三菩提。须菩提。若求菩萨道而转还者。皆离般若波罗蜜念故。是人不知云何行般若波罗蜜。以虚空不可尽法观十二因缘。须菩提。若求菩萨道而转还者。皆不得是方便力故。于阿耨多罗三藐三菩提而转还。须菩提。若菩萨摩诃萨于阿耨多罗三藐三菩提不转还者。皆得是方便力故。须菩提。菩萨摩诃萨应以虚空不可尽法观般若波罗蜜。应以虚空不可尽法生般若波罗蜜。如是须菩提。菩萨摩诃萨观十二因缘时。不见法无因缘生。不见法常不灭。不见法有我人寿者命者众生知者见者。不见法无常。不见法苦。不见法无我。不见法寂灭非寂灭。如是须菩提。菩萨摩诃萨行般若波罗蜜。应如是观十二因缘。须菩提。若菩萨摩诃萨能如是行般若波罗蜜。是时不见色若常若无常若苦若乐若我若无我若寂灭若非寂灭。受想行识亦如是。须菩提。菩萨摩诃萨是时亦不见般若波罗蜜。亦不见以是法见般若波罗蜜禅波罗蜜乃至阿耨多罗三藐三菩提。亦不见阿耨多罗三藐三菩提。亦不见以是法见阿耨多罗三藐三菩提。如是须菩提。一切法不可得故。是为应般若波罗蜜行。若菩萨行无所得般若波罗蜜时。恶魔愁毒如箭入心。譬如人新丧父母。如是须菩提。恶魔见菩萨行无所得般若波罗蜜时。便大愁毒如箭入心。须菩提白佛言。世尊。但一魔愁毒。三千大千世界中魔亦复愁毒。佛告须菩提。三千大千世界中诸恶魔。皆愁毒如箭入心。各于其坐不能自安。须菩提。菩萨摩诃萨能如是行般若波罗蜜。是时一切世间天及人阿修罗。不能得其便令其忧恼。须菩提。以是故菩萨摩诃萨欲得阿耨多罗三藐三菩提。当行是般若波罗蜜。菩萨摩诃萨行般若波罗蜜时。具足修檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。须菩提。菩萨摩诃萨行般若波罗蜜时。具足诸波罗蜜。须菩提白佛言。世尊。菩萨摩诃萨行般若波罗蜜时。云何具足檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。佛告须菩提。菩萨摩诃萨所有布施皆回向萨婆若。如是须菩提。菩萨摩诃萨行般若波罗蜜时。具足檀波罗蜜。须菩提。菩萨摩诃萨所有持戒皆回向萨婆若。是为具足尸罗波罗蜜。菩萨摩诃萨所有忍辱皆回向萨婆若。是为具足羼提波罗蜜。菩萨摩诃萨所有精进皆回向萨婆若。是为具足毗梨耶波罗蜜。菩萨摩诃萨所有禅定皆回向萨婆若。是为具足禅波罗蜜。菩萨摩诃萨所有智慧皆回向萨婆若。是为具足般若波罗蜜。如是须菩提。菩萨摩诃萨行般若波罗蜜具足六波罗蜜

【论】释曰。须菩提从佛闻般若波罗蜜种种相。初闻毕竟空相。中闻嘱累。知似有后还闻说空所谓般若义无量。名字句众有量是时须菩提作是念。诸佛阿耨多罗三藐三菩提甚深。我当问佛所以甚深。佛说菩提少许分。但为破众生颠倒故不具足说。所以者何。无能受者故。若人取如相。佛言如亦空。无生住灭故。若法无生住灭。是法即无。法性实际亦如是。若有取毕竟空者亦言非也。何以故。若毕竟空是定相可取。是非毕竟空。是故言甚深。我当更问佛。须菩提作是念已。如佛自说。三世诸佛用般若波罗蜜得道。般若故不尽。已不尽今不尽当不尽。是故我今但问不尽义。佛答如虚空不尽故。般若亦不尽。如虚空无有法但有名字。般若波罗蜜亦如是。般若波罗蜜若如虚空无所有故不可尽。云何菩萨能生是般若波罗蜜能生者。菩萨云何心中生能行能得佛答色无尽故般若波罗蜜应生。如色初后中生不可得。色即生色不可得离色生色不可得。生不可得生生不可得如先破生中说。生不可得故色亦不可得。色不可得故色生不可得。二法不可得故。色如幻如梦但诳人眼。若色有生必有尽。以无生故亦无尽。色真相即是般若波罗蜜相。是故说色不可尽。般若波罗蜜亦不可尽。受想行识檀波罗蜜乃至一切种智亦如是。复次应生般若者。无明虚空不可尽故。若人但观毕竟空多堕断灭边。若观有多堕常边。离是二边故说十二因缘空。何以故。若法从因缘和合生。是法无有定性。若法无定性。即是毕竟空寂灭相。离二边故假名为中道。是故说十二因缘。如虚空无法故不尽。痴亦从因缘和合生故无自相。无自相故毕竟空如虚空。复次因缘生故无实。如经中说因眼缘色生触念。触念从痴生。触念不在眼中不在色中不在内不在外亦不在中间。亦不从十方三世来。是法定相不可得。何以故。一切法入如故。若得是无明定相。即是智慧。不名为痴。是故痴相智慧相无异。痴实相即是智慧。取着智慧相即是痴是故痴实相毕竟清净。如虚空无生无灭。是故说得是观。故回向阿耨多罗三藐三菩提。即名般若波罗蜜。问曰。若无无明亦无诸行等。云何说十二因缘。答曰。说十二因缘有三种。一者凡夫肉眼所见颠倒着我心。起诸烦恼业往来生死中。二者贤圣以法眼分别诸法。老病死心厌欲出世间。求老死因缘由生故。是生由诸烦恼业因缘。何以故。无烦恼人则不生。是故知烦恼为生因。烦恼因缘是无明。无明故应舍而取。应取而舍。何者应舍。老病诸苦因缘烦恼应舍。以少颠倒乐因缘故而取。持戒禅定智慧诸善根本。是涅槃乐因缘。是事应取而舍。是中无有知者见者作者。何以故。是法无定相。但从虚诳因缘相续生。行者知是虚诳不实则不生戏论。是但灭苦故入于涅槃。不究尽求诸苦相。三者诸菩萨摩诃萨大智人利根故。但求究尽十二因缘根本相。不以忧怖自没。求时不得定相。老法毕竟空。但从虚诳假名有。所以者何。分别诸法相者说老。是心不相应行。是相不可得。头白等是色相非老相。二事不可得故无老相。

复次世人名老相发白齿离面皱身曲羸瘦力薄诸根闇塞。如是等名老相。但是事不然。所以者何。发白非唯老者。又年壮而白老年而黑者。羸瘦皱曲亦尔。有人老而诸根明利。少而闇塞者。又服还年药虽老而壮。如是老无定相。无定相故诸法和合假名为老。又如假轮轴辕辐等为车。是假名非实。复次有人言说果报五众故相名为老。是亦不然。所以者何。一切有为法念念生灭不住。若不住则无故。无故则无老。一切有为法若有住则无无常。若无无常即是常。若常则无老。何况非常非无常。毕竟空中而有老。复次诸法毕竟空中生相不可得何况有老。如是等种种因缘。求老法不可得。不可得故无相如虚空不可尽。如老乃至无明亦如是。破无明如上说。菩萨观诸法实相毕竟空。无所有无所得。亦不着是事故。于众生中而生大悲。众生愚痴故。于不实颠倒虚妄法中受诸苦恼。初十二因缘但是凡夫人故。于是中不求是非第二十二因缘。二乘人及未得无生忍法菩萨所观。第三十二因缘从得无生忍法乃至坐道场菩萨所观。是故说无明虚空不可尽乃至忧悲苦恼虚空不可尽故。菩萨行般若波罗蜜如是深观因缘法。离诸边颠倒者。边名常边断灭边有边无边实边空边世间有边等。着诸边颠倒者。无常中起常等诸颠倒烦恼。观是十二因缘法。诸边颠倒灭。诸烦恼有二分。一者外道邪见人名为边。二者余众生烦恼名为颠倒。观十二因缘。是二种烦恼皆灭。是第三十二因缘观甚深。唯诸菩萨坐道场者能观。先虽能观未能具足。如城譬喻经中说。佛言我本未得道。时如是思惟。众生可愍深入崄道。所谓数数生数数老数数死。往来世间不知出处。我即时复作是念。何因缘有老死。如是求觅时得实智慧生。因缘是老死等。是故知第三观坐道场乃得。如经广说。又复观如是因缘法。过于二乘得一切种智。若有人于佛道退者。皆不得是甚深观故。若得是观则不退。何以故。深入毕竟空中则不见声闻辟支佛地。不见故则不于是中住。复次能如是观因缘法者。不见有一法定自在。无因缘而生。一切法不自在皆属因缘生。有人虽见一切法从因缘生。谓为从邪因缘生。邪因缘者微尘世性等。是故说不见法无因缘生亦不见法从常因缘微尘世性生。如虚空常常故则无生。虚空亦不与物作因。以是故无有法从常因缘生。复次菩萨如是观一切法属因缘生不自在不自在故无我乃至无知者见者。尔时菩萨安住毕竟空十二因缘中。不见一切色等法。若有若无等。亦不见般若。亦不见用是法行般若乃至阿耨多罗三藐三菩提亦如是。是名菩萨无所得般若波罗蜜。得是无所得般若。于一切法中便得无所障碍般若。尔时诸魔极大愁毒。何以故。以是菩萨深入十二因缘毕竟空中。不著有无非有非无等六十二诸邪见魔网。我今无有法可得菩萨便。譬如捕鱼人见一鱼深入大水钩网所不及则绝望忧愁。亦如新丧父母。复次菩萨能如是行无所得般若波罗蜜。则能具足檀波罗蜜等。何以故。行如是法。诸烦恼障般若法皆折薄。诸魔人民不能得便故。诸波罗蜜得具足。先来虽行六波罗蜜未能得如是具足。须菩提问。世尊。菩萨云何能行如是般若波罗蜜。能具足檀波罗蜜等诸波罗蜜。佛答。若菩萨所有布施皆回向萨婆若者有二种人。软根利根。软根者少多布施皆取相。回向阿耨多罗三藐三菩提。利根者破是取相而戏论。空法信力转薄不用萨婆若。但求诸法实相。是二种人皆不能具足檀波罗蜜。一者以信力多慧力少。二者以慧力多信力少故。佛今说信力慧力等故能回向萨婆若。念萨婆若者是信力。如萨婆若回向者是智力。乃至般若波罗蜜亦如是

    大智度论释六度相摄品第六十八

【经】须菩提白佛言。世尊。云何菩萨摩诃萨住檀波罗蜜取尸罗波罗蜜。佛告须菩提。菩萨摩诃萨布施时。持是布施回向萨婆若。于众生中住慈身口意业。是为菩萨住檀波罗蜜取尸罗波罗蜜。世尊。云何菩萨住檀波罗蜜取羼提波罗蜜。佛告须菩提。菩萨布施时。受者嗔恚骂辱恶言加之。是时菩萨忍辱不生嗔心。是为菩萨住檀波罗蜜取羼提波罗蜜。世尊。云何菩萨住檀波罗蜜取毗梨耶波罗蜜。佛言。菩萨布施时。受者嗔恚骂辱恶言加之。菩萨增益布施心作是念。我应当施不应有所惜。即时生身精进心精进。是为菩萨住檀波罗蜜取毗梨耶波罗蜜。世尊。云何菩萨摩诃萨住檀波罗蜜取禅波罗蜜。佛言。菩萨布施时。回向萨婆若不趣声闻辟支佛地。但一心念萨婆若。是为菩萨住檀波罗蜜取禅波罗蜜。世尊。云何菩萨摩诃萨住檀波罗蜜取般若波罗蜜。佛言。菩萨布施时。知布施空如幻。不见为众生布施有益无益。是为菩萨住檀波罗蜜取般若波罗蜜。须菩提白佛言。世尊。云何菩萨摩诃萨住尸罗波罗蜜取檀波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。佛告须菩提。菩萨摩诃萨住尸罗波罗蜜中。身口意生布施福德。助阿耨多罗三藐三菩提。持是功德不取声闻辟支佛地。住尸罗波罗蜜中不夺他命。不劫夺他物。不行邪淫。不妄语不两舌不恶口不绮语。不贪嫉不嗔恚不邪见。所有布施。饥者与食。渴者与饮。须乘与乘。须衣与衣。须香与香。须璎珞与璎珞。涂香卧具房舍灯烛资生所须尽给与之。持是布施与众生共之。回向阿耨多罗三藐三菩提。如是回向不堕声闻辟支佛地。须菩提。是为菩萨摩诃萨住尸罗波罗蜜取檀波罗蜜。世尊。云何菩萨摩诃萨住尸罗波罗蜜取羼提波罗蜜。佛言。菩萨摩诃萨住尸罗波罗蜜中。若有众生来节节支解。菩萨于是中不生嗔恚心乃至一念。作是言我得大利。众生来取我支节用。我无一念嗔恚。是为菩萨住尸罗波罗蜜中取羼提波罗蜜。世尊。云何菩萨摩诃萨住尸罗波罗蜜取毗梨耶波罗蜜。佛言若菩萨摩诃萨身精进心精进常不舍。作是念一切众生在生死中。我当拔着甘露地。是为菩萨住尸罗波罗蜜中取毗梨耶波罗蜜。世尊。云何菩萨摩诃萨住尸罗波罗蜜取禅波罗蜜。佛言。菩萨入初禅第二第三第四禅。不贪声闻辟支佛地。作是念我当住禅波罗蜜中度一切众生生死。是为菩萨住尸罗波罗蜜取禅波罗蜜。世尊。云何菩萨摩诃萨住尸罗波罗蜜取般若波罗蜜。佛言。菩萨住尸罗波罗蜜中。无有法可见。若作法若有为法若数法若相法若有若无。但见诸法不过如相。以般若波罗蜜沤和拘舍罗力故。不堕声闻辟支佛地。是为菩萨住尸罗波罗蜜取般若波罗蜜

【论】释曰。上品末说。云何菩萨行般若波罗蜜时具足六波罗蜜。佛一一答。此品中须菩提问。云何菩萨行一波罗蜜摄五波罗蜜。问曰六波罗蜜各各异相。云何行一波罗蜜摄五波罗蜜。答曰。菩萨以方便力故。行一波罗蜜能摄五波罗蜜。复次有为法因缘果报相续故相成善法。善法因缘故。是波罗蜜皆是善法故。行一则摄五。以一波罗蜜为主余波罗蜜有分。有菩萨摩诃萨深行檀波罗蜜。安住檀波罗蜜中布施众生时得慈心。从慈能起慈身口业。是时菩萨即取尸罗波罗蜜。何以故。慈业是三善道。尸罗波罗蜜根本。所谓不贪不嗔正见。是三慈业能生三种身业四种口业。慈即是善业。为利益众生故名为慈。取羼提波罗蜜者。菩萨为一切智慧故布施受者嗔。若施主唱言我能一切施。受者不得称意。便作是言。谁使汝请我而不随我意。嗔者是心恶业。骂者是口恶业。打害者是身恶业。嗔有上中下上者害杀。中者骂詈。下者心嗔。尔时菩萨不生三种恶业。意业是根本故但说意业。作是念是我之罪。我请彼人而不能得称意。由我薄福不能具足施与。我若嗔者既失财物又失福德。是故不应嗔。取毗梨耶波罗蜜者。若菩萨布施时受者打害。心不没不舍。布施如先说。为布施故身心勤精进。作是念我先世不强意布施故。今不能得称受者意。但当勤布施不应计余小事。取禅波罗蜜者。菩萨布施不求今世福乐。亦不求后世转轮圣王天王人王。亦不求世间禅定乐为众生故不求涅槃乐。但摄是诸意在一切种智中不令散乱。取般若波罗蜜者。菩萨布施时常观一切有为作法虚诳不坚固如幻如梦。施众生时不见有益无益。何以故。是布施物非定是乐因缘。或时得食腹胀而死。或时得财为贼所害。亦以得财物故生悭贪心而堕饿鬼中。又此财物有为相故。念念生灭无常生苦因缘。复次此财物入诸法实相毕竟空中不分别有利无利。是故菩萨于受者不求恩分。于布施不望果报。设求报若彼不报则生怨恨。菩萨作是念。诸法毕竟空故。我无所与。若求果报当求毕竟空阿耨多罗三藐三菩提。如布施相。是故不见有益。以毕竟空故亦不见无益。如是于檀波罗蜜边取五波罗蜜。菩萨以尸罗波罗蜜为主。所有身口意善业。布施多闻思惟持戒等助阿耨多罗三藐三菩提。持戒力大故总名尸罗波罗蜜。何以故。欲界中持戒为上余布施闻思修慧等以欲界心散乱故得力微薄。如阿毗昙中说出法名。欲界系戒色无色界系净禅定学无学法及涅槃。菩萨以是持戒等法不趣声闻辟支佛地。但安住尸罗波罗蜜中不夺众生命。乃至不为邪见住。是助道戒。具足十善道戒。菩萨住是二种戒中布施众生。须食与食。食等义如初品中说。皆以此福回向佛道不趣二乘。何以故。菩萨有二种破戒。一者十不善道。二者向声闻辟支佛地。与此相违则是二种持戒。取羼提波罗蜜者。菩萨住尸罗波罗蜜。欲具足忍辱波罗蜜。若众生来节节支解持去。乃至不生一念嗔心。何况起身口恶业。问曰。忍辱名一切侵夺能忍。何以但说割截身体。答曰。所著物有内外。内名自身。头目髓脑等。外名妻子珍宝等。虽俱是着处内着最深。复次或有人虽随逐财物而死。亦是为身故。又复人多惜身时有惜财。惜财者少故不说。复次是人尚不惜身。何况余物。是故但说大因缘。当知已摄小者。问曰。乃至不生一念嗔心者。为是变化身。为是父母生身。若是变化身则不足为奇。若是父母生身未断结人。云何能不生一念嗔心。答曰。有人言。烦恼业因缘生身。是菩萨于无量劫为众生修集慈心故。虽有割截不生嗔心。如慈母养育婴儿。虽复屎尿污身。以深爱故而不生嗔。又愍其无知。菩萨于众生亦如是。未得圣道者皆如小儿。我为菩萨应生慈心当如父母。众生虽复加恶于我我不应嗔。何以故。众生不自在烦恼所使故。复次菩萨无量劫来常修毕竟空法。不见割者骂者。亦不见善者恶者。皆如幻如梦。诸嗔恚者皆愚痴。若我报彼与彼无异。复次菩萨作是念。我应嗔处而不嗔则为大利。取毗梨耶波罗蜜者。住尸罗波罗蜜。多是出家人。时有在家者。一切出家人得无量戒律仪。具足四十种善道。深入诸法实相过声闻辟支佛地。是三种戒名尸罗波罗蜜。在家者无无量戒律仪。是故不具足住尸罗波罗蜜。菩萨作是念。我今舍世乐入道不可但住持戒。持戒是余功德住处。若但得住处不得余功德者得利甚薄。譬如人在宝洲。但得水精珠则所利益薄。是故菩萨欲具足五波罗蜜故。身心勤精进。身精进者。如法致财以用布施等。心精进者。悭贪等诸恶心来破六波罗蜜者不令得入。得此二种精进已应作是念。一切众生沉没生死。我应拯济着甘露地。声闻人但度自身尚不应懈怠。何况菩萨自度及为一切众生而当懈怠。以是事故我不应懈废。虽身疲苦心不应息。所以者何。此大乘法若不运用则为败坏。取禅波罗蜜者。菩萨住尸罗波罗蜜。或未得无生忍法故。诸烦恼风吹动愿树。欲坏其尸罗波罗蜜。尔时应求禅定乐除去五欲乐。五欲乐除故戒德清净。烦恼虽未断已折伏故不能生乱。譬如毒蛇以咒术力故毒不得螫。禅者四禅四无色定四无量心等诸禅定。菩萨得禅心虽柔软安住尸罗波罗蜜。故亦不取声闻辟支佛地。是菩萨但作是念。我应行禅波罗蜜。不为小乘涅槃。亦不为果报。但为度一切众生故说诸法实相。是实智从禅定生。是心不为觉观所动。亦不为贪欲嗔恚所浊。系心一处清净柔软则能生实智。如水澄静照鉴分明。菩萨住尸罗波罗蜜得是禅。得禅故心清净。心清净故知诸法如实。有为法从因缘和合生虚诳。菩萨以慧眼观。不见是有为法。实有为法有种种名。所谓作法有为数法相法。若有若无。以有为故可说无为。有为相尚不可得。何况无为。问曰。有为法是有相。无为法是无相。今何以有为相中说无相。答曰。无为有二种。一者无相。寂灭无戏论如涅槃。二者相待。无因有而生。如庙堂上无马能生无心。此无心是生诸烦恼因缘。云何是无为法。是菩萨不见此有无等法。但见诸法如法性实际。问曰。汝先言离有则无无。今云何见如法性实际。答曰。不见有为法若常乐我净等。是虚诳法若无。即是诸法实见。无生法故能离有生法。是无生法无定实相可取。但能令人离虚诳有生法故名无生。若得如是智慧。以方便力本愿悲心故。不取二乘证直至阿耨多罗三藐三菩提。是名菩萨住尸罗波罗蜜取五波罗蜜

大智度论卷第八十大智度论释六度品第六十八之余(卷八十一)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】须菩提白佛言。世尊。云何菩萨摩诃萨住羼提波罗蜜取檀波罗蜜。佛言。菩萨从初发心乃至坐道场。于其中间若一切众生来嗔恚骂詈若节节支解。菩萨住于忍辱作是念。我应布施一切众生不应不与。是众生须食与食。须饮与饮乃至资生所须尽皆与之。持是功德与一切众生共之。回向阿耨多罗三藐三菩提。是菩萨回向时不生二心。谁回向者。回向何处。是为菩萨住羼提波罗蜜取檀波罗蜜。世尊。云何菩萨摩诃萨住羼提波罗蜜取尸罗波罗蜜。佛言。菩萨从初发心乃至坐道场。于其中间终不夺他命。不与不取乃至不邪见。亦不贪声闻辟支佛地。持是功德与一切众生共之。回向阿耨多罗三藐三菩提。是菩萨回向时三种心不生。谁回向阿耨多罗三藐三菩提。用何法回向。回向何处。是为菩萨住羼提波罗蜜取尸罗波罗蜜。世尊。云何菩萨摩诃萨住羼提波罗蜜取毗梨耶波罗蜜。佛言。菩萨住羼提波罗蜜生精进作是念。我当往一由旬若十由旬百千万亿由旬过一世界乃至过百千万亿世界。乃至教一人令持五戒。何况令得须陀洹果乃至阿罗汉果辟支佛道阿耨多罗三藐三菩提。持是功德与一切众生共之。回向阿耨多罗三藐三菩提。是为菩萨住羼提波罗蜜取毗梨耶波罗蜜。世尊。云何菩萨摩诃萨住羼提波罗蜜取禅波罗蜜。佛言。菩萨住羼提波罗蜜离欲离恶不善法有觉有观。离生喜乐入初禅。乃至入第四禅。是诸禅中净心心数法皆回向萨婆若。回向时是菩萨诸禅及禅支皆不可得。是为菩萨住羼提波罗蜜取禅波罗蜜。世尊。云何菩萨摩诃萨住羼提波罗蜜取般若波罗蜜。佛言。菩萨住羼提波罗蜜观诸法若离相若寂灭相若无尽相。不以寂灭相作证。乃至坐道场得一切种智。从道场起便转法轮。是为菩萨住羼提波罗蜜取般若波罗蜜。不取不舍故。须菩提白佛言。世尊。云何菩萨摩诃萨住毗梨耶波罗蜜取檀波罗蜜。佛告须菩提。菩萨住毗梨耶波罗蜜。身心精进不懈不怠作是念。我必应当得阿耨多罗三藐三菩提不应不得。是菩萨为利益众生故。往一由旬若百千万亿由旬。若过一世界若过十世界。若过百千万亿世界。住毗梨耶波罗蜜中。若不能得一人教令入佛道中。若声闻道中。若辟支佛道中。或得一人教令行十善道。精进不懈法施及以财施令具足。持是功德与众生共之。回向阿耨多罗三藐三菩提。不回向声闻辟支佛地。是为菩萨住毗梨耶波罗蜜取檀波罗蜜。世尊。云何菩萨摩诃萨住毗梨耶波罗蜜取尸罗波罗蜜。佛言。菩萨住毗梨耶波罗蜜。从初发意乃至坐道场。自不杀生不教他杀。赞不杀生法。欢喜赞叹不杀生者。乃至自远离邪见。教他远离邪见。赞不邪见法。欢喜赞叹不邪见者。是菩萨住尸罗波罗蜜因缘不求欲界色界无色界福。不求声闻辟支佛地。持是功德与众生共之。回向阿耨多罗三藐三菩提。不生三种心。不见回向者。不见回向法。不见回向处。是为菩萨住毗梨耶波罗蜜取尸罗波罗蜜。世尊。云何菩萨摩诃萨住毗梨耶波罗蜜取羼提波罗蜜。佛言。菩萨住毗梨耶波罗蜜。从初发意乃至坐道场。于其中间若人若非人来节节支解。菩萨作是念。割我者谁。截我者谁。夺我者谁。复作是念。我大得善利。我为众生故受身。众生还自来取。是时菩萨正忆念诸法实相。持是功德与众生共之。回向阿耨多罗三藐三菩提。不向声闻辟支佛地。是为菩萨住毗梨耶波罗蜜取羼提波罗蜜。世尊。云何菩萨摩诃萨住毗梨耶波罗蜜取禅波罗蜜。佛言。菩萨住毗梨耶波罗蜜离欲离恶不善法有觉有观。离生喜乐入初禅第二第三第四禅。入慈悲喜舍。乃至入非有想非无想处。持是禅无量心无色定不受果报。生于利益众生之处。以六波罗蜜成就众生。所谓檀波罗蜜乃至般若波罗蜜。从一佛土至一佛土。亲近供养诸佛种善根。是为菩萨住毗梨耶波罗蜜取禅波罗蜜。世尊。云何菩萨摩诃萨住毗梨耶波罗蜜取般若波罗蜜。佛言。菩萨住毗梨耶波罗蜜不见檀波罗蜜法。不见檀波罗蜜相。乃至不见禅波罗蜜法。不见禅波罗蜜相。四念处乃至一切种智。亦不见法亦不见相。不见一切法非法非非法。于一切法中无所著。是菩萨所作如所言。是为菩萨住毗梨耶波罗蜜取般若波罗蜜。须菩提白佛言。世尊。云何菩萨摩诃萨住禅波罗蜜取檀波罗蜜。佛言。菩萨摩诃萨住禅波罗蜜离诸欲离恶不善法。有觉有观离生喜乐。入初禅第二第三第四禅。入慈悲喜舍。乃至入非有想非无想处。住禅波罗蜜中心不乱。行二施以施众生。法施财施。自行二施教他行二施。赞叹二施法。欢喜赞叹行二施者。持是功德与众生共之。回向阿耨多罗三藐三菩提。不向声闻辟支佛地。是为菩萨住禅波罗蜜取檀波罗蜜。世尊。云何菩萨摩诃萨住禅波罗蜜取尸罗波罗蜜。佛言。菩萨住禅波罗蜜不生淫欲嗔恚愚痴心。不生恼他心。但修行一切智相应心。持是功德与众生共之。回向阿耨多罗三藐三菩提。不向声闻辟支佛地。是为菩萨住禅波罗蜜取尸罗波罗蜜。世尊。云何菩萨摩诃萨住禅波罗蜜取羼提波罗蜜。佛言。菩萨住禅波罗蜜。观色如聚沫。观受如泡观想如野马。观行如芭蕉。观识如幻。作是观时。见五众无坚固相。作是念。割我者谁。截我者谁。谁受谁想谁行谁识。谁骂者谁受骂者谁生嗔恚。是为菩萨住禅波罗蜜取羼提波罗蜜。世尊。云何菩萨摩诃萨住禅波罗蜜取毗梨耶波罗蜜。佛言。菩萨住禅波罗蜜离欲离恶不善法。有觉有观离生喜乐。入初禅第二第三第四禅。是诸禅及支取相生种种神通。履水如地入地如水。如先说。天耳闻二种声。若天若人。知他心。若摄心若乱心。乃至有上心无上心。忆种种宿命。如先说。以天眼净过人眼。见众生乃至如业受报。如先说。菩萨住是五神通。从一佛世界至一佛世界。亲近供养诸佛种善根。成就众生净佛世界。持是功德与众生共之。回向阿耨多罗三藐三菩提。是为菩萨住禅波罗蜜取毗梨耶波罗蜜。世尊。云何菩萨摩诃萨住禅波罗蜜取般若波罗蜜。佛言。菩萨住禅波罗蜜。不得色不得受想行识。不得檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜。不得般若波罗蜜。不得四念处。乃至不得一切种智。不得有为性。不得无为性。不得故不作。不作故不生。不生故不灭。何以故。有佛无佛是如法相法性常住不生不灭。常一心应萨婆若行。是为菩萨住禅波罗蜜取般若波罗蜜。须菩提白佛言。世尊云何菩萨摩诃萨住般若波罗蜜取檀波罗蜜。佛言。菩萨住般若波罗蜜。内空内空不可得。外空外空不可得。内外空内外空不可得。空空空空不可得。乃至一切法空一切法空不可得。菩萨住是十四空中。不得色相若空若不空。不得受想行识相若空若不空。不得四念处若空若不空。乃至不得阿耨多罗三藐三菩提若空若不空。不得有为性无为性若空若不空。是菩萨摩诃萨如是住般若波罗蜜中有所布施。若饮食衣服种种资生之具。观是布施空。何等空。施者受者及财物空。不令悭着心生。何以故。菩萨摩诃萨行般若波罗蜜。从初发意乃至坐道场。无有妄想分别。如诸佛得阿耨多罗三藐三菩提时无悭着心。菩萨摩诃萨亦如是。行般若波罗蜜时无悭着心。是菩萨所可尊者般若波罗蜜。是为菩萨住般若波罗蜜取檀波罗蜜。世尊。云何菩萨摩诃萨住般若波罗蜜取尸罗波罗蜜。佛言。菩萨住般若波罗蜜。不生声闻辟支佛心。何以故。是菩萨声闻辟支佛地不可得。趣向声闻辟支佛心亦不可得。是菩萨摩诃萨从初发意乃至坐道场。于其中间自不杀生。不教他杀生。赞不杀生法。欢喜赞叹不杀生者。乃至自不邪见。不教他邪见。赞不邪见法。欢喜赞叹不邪见者。以是持戒。无法可取若声闻若辟支佛地。何况余法。是为菩萨住般若波罗蜜取尸罗波罗蜜。世尊。云何菩萨摩诃萨住般若波罗蜜取羼提波罗蜜。佛言。菩萨住般若波罗蜜随顺法忍生。作是念。此法中无有法若起若灭若生若死若受骂詈若受恶口若割若截若破若缚若打若杀。是菩萨从初发意乃至坐道场。若一切众生。来骂詈恶口刀杖瓦石割截伤害心不动。作是念。甚可怪。此诸法中无有法受骂詈恶口割截伤害者。而众生受苦恼。是为菩萨住般若波罗蜜取羼提波罗蜜。世尊。云何菩萨摩诃萨住般若波罗蜜取毗梨耶波罗蜜。佛言。菩萨住般若波罗蜜为众生说法。令行檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。教令行四念处乃至八圣道分。令得须陀洹果斯陀含阿那含阿罗汉果辟支佛道。令得阿耨多罗三藐三菩提。不住有为性中。不住无为性中。是为菩萨住般若波罗蜜取毗梨耶波罗蜜。世尊。云何菩萨摩诃萨住般若波罗蜜取禅波罗蜜。佛言。菩萨住般若波罗蜜除诸佛三昧。入余一切三昧。若声闻三昧。若辟支佛三昧。若菩萨三昧。皆行皆入。是菩萨住诸三昧。逆顺出入八背舍。何等八。内有色相外观色是初背舍。内无色相外观色二背舍。净背舍身作证三背舍。过一切色相灭有对相。不念种种相故。入无量虚空处四背舍。过一切虚空处入无边识处五背舍。过一切识处入无所有处六背舍。过一切无所有处入非有想非无想处七背舍。过一切非有想非无想处。入灭受想处八背舍。于是八背舍逆顺出入九次第定。何等九。离诸欲离诸恶不善法。有觉有观离生喜乐入初禅。乃至过非有想非无想处。入灭受想定。是名九次第定逆顺出入。是菩萨依八背舍九次第定。入师子奋迅三昧。云何名师子奋迅三昧。须菩提。菩萨离欲恶不善法。有觉有观。离生喜乐。入初禅乃至入灭受想定。从灭受想定起。还入非有想非无想处。从非有想非无想处起。乃至还入初禅。是菩萨依师子奋迅三昧入超越三昧。云何为超越三昧。须菩提。菩萨离欲离诸恶不善法。有觉有观。离生喜乐入初禅。从初禅起乃至入非有想非无想处。非有想非无想处起入灭受想定。灭受想定起还入初禅。从初禅起入灭受想定。灭受想定起还入二禅。二禅起入灭受想定。灭受想定起入三禅。三禅起入灭受想定。灭受想定起入四禅。四禅起入灭受想定。灭受想定起入空处。空处起入灭受想定。灭受想定起入识处。识处起入灭受想定。灭受想定起入无所有处。无所有处起入灭受想定。灭受想定起入非有想非无想处。非有想非无想处起入灭受想定。灭受想定起入散心中。散心中起入灭受想定。灭受想定起还入散心中。散心中起入非有想非无想处。非有想非无想处起还住散心中。散心中起入无所有处。无所有处起住散心中。散心中起入识处。识处起住散心中。散心中起入空处。空处起住散心中。散心中起入第四禅。第四禅中起住散心中。散心中起入第三禅。第三禅中起住散心中。散心中起入第二禅。第二禅中起住散心中。散心中起入初禅。初禅中起住散心中。是为菩萨摩诃萨住超越三昧得诸法等相。是为菩萨住般若波罗蜜取禅波罗蜜

【论】问曰。何以但一波罗蜜为主。答曰。行因缘次第应尔。菩萨有二种在家出家。在家菩萨福德因缘故大富。大富故求佛道因缘。行诸波罗蜜。宜先行布施。何以故。既有财物又知罪福。兼有慈悲心于众生故。宜先行布施随次第因缘行诸波罗蜜。出家菩萨以无财故次第宜持戒忍辱禅定。次第所宜故名为主。除财施余波罗蜜皆出家人所宜行。菩萨以羼提波罗蜜为主。作是愿。若人来截割身体不应生嗔心。我今行菩萨道。应具足诸波罗蜜。诸波罗蜜中檀波罗蜜最在初。于檀中所重惜者无过于身。能以施人不惜不嗔能具足忍辱波罗蜜摄取檀。菩萨住忍辱中布施众生。衣食等诸物尽给与。受者逆骂打害菩萨破其施忍。菩萨作是念。我不应为虚诳身故毁波罗蜜道。我应布施不应生恶心。不以小恶因缘故而生废退。是菩萨命未尽间增益施心。若命终时二波罗蜜力故。即生好处续行布施。取尸罗波罗蜜者。问曰。住忍辱时不为恶即是戒。何以故。更说住忍取戒波罗蜜。应当住戒摄忍。答曰。此中说相不说次第相生。虽和合而各各有相。若次第法应先戒后忍。戒名不夺他命。忍名不自惜命。是故于忍辱中别说戒相。复次忍名自摄其心不起嗔恚。持戒有二种。一者不恼众生。二者自为生禅定根本故。有菩萨行忍辱未受持戒法。但以畏罪故。忍辱未能深怜愍众生。是人或从师闻。或自思惟。持戒是佛道因缘不娆众生。我今已能忍辱则行此事易。是名说忍辱能取尸罗波罗蜜。复次忍辱是心数法。持戒是色法。持戒名心生口说受持。忍辱但是心生非受持法。复次身口清净名持戒。意清净名忍辱。问曰。禅智波罗蜜亦是心清净法。何以但说忍辱。答曰。禅智力大故不说。持戒时心未能清净。须忍辱守心故此经中自说因缘。有菩萨大功德智慧利根。于现在佛所发心行诸波罗蜜。是故世世增益乃至阿耨多罗三藐三菩提不堕恶处。为是菩萨故说。从初发心乃至坐道场。不生嗔心夺众生命。亦不着二乘。皆是二波罗蜜功德故。离三种心回向阿耨多罗三藐三菩提。三心者。无人无法无回向处。无有我心颠倒心。取毗梨耶波罗蜜者。若自集功德。若度众生。发心不懈。乃至成办其事。若有遮道因缘心不没不退。能堪受众苦。不以久远勤苦为难。如经中说。是菩萨乃至过千万由旬。乃至不得一人令入实法得涅槃。是时心亦不愁。若得一人令持五戒等。尔时心欢喜不作是念。我过此无量国土正得此一人以为愁苦。何以故。一人相即是一切人相。一切人相即是一人相。是诸法相不二故。取禅波罗蜜者。是菩萨忍辱力故其心调柔。心调柔故易得禅定。于禅定中得慈悲等诸清净心心数法。皆以是不着心回向阿耨多罗三藐三菩提。取般若波罗蜜者。菩萨住众生忍中忍一切众生加恶事行大慈悲。是故得大福德。得大福德故心柔软。心柔软故易得法忍。所谓一切毕竟无生。住是法忍中观一切法。空相离相无尽寂灭相如涅槃相。尔时还增长众生忍。如是毕竟空中谁有骂者谁有害者。尔时具足二忍故不见三事。忍法忍者忍处。如是不戏论一切法故能见一切法空。寂灭相如涅槃。本愿求佛道不着是毕竟空法故。乃至未坐道场不证实际。坐道场已具足佛法。得佛道转法轮。随意利益众生。皆是般若波罗蜜力。住毗梨耶波罗蜜取檀波罗蜜者。菩萨初用精进门入诸波罗蜜中。勤行五波罗蜜。身心精进不休不息。精进更无异体。住是精进中不畏阿鼻泥梨苦。何况余苦。菩萨亦知一切法毕竟空。从毕竟空出。以慈悲心故还起善业不取涅槃。是精进力。菩萨住精进中应作是念。我久久必应当得阿耨多罗三藐三菩提。不应不得。是人过一由旬乃至百千由旬。以财法二事施惠众生。乃至过百千万亿国土。正使不得一人入三乘。菩萨心亦不悔不没不作是念。我尔所佛土而不得一人可度。云何可得度一切人。过百千国土或得一人可令行十善不中入三乘。不以一人不得实相故心怀轻悔。复作是念。我今并使此人行十善道。渐以三乘而度脱之。教十善已复以财法二施满足众生。持是功德回向阿耨多罗三藐三菩提。身心精进过无数国为众生说法。问曰。一切布施皆以精进。何以但言此二施从精进生。答曰。虽一切施皆由精进生。此以多精进力生故。如经说。过百千国土以二施满足众生。取尸罗波罗蜜者。菩萨直行十善道。是名尸罗波罗蜜。或从忍辱等波罗蜜生。若菩萨从初发心乃至坐道场。舍十不善道行四十种善道不休不息。是名精进波罗蜜力。有人一种不能行。何况四种。亦以尸罗波罗蜜故不生三界不受二乘。众生以懈怠烦恼心故生三界中。厌恶生死故舍佛道取小乘。此皆是懈怠相。是故说是菩萨不贪三界不证二乘。取羼提波罗蜜者。菩萨从初发心乃至坐道场。若人若非人来割截身体持去。尔时菩萨破我颠倒善集。毕竟空故作是念。此中无有割者截者。是事皆是凡夫虚诳所见。我得大利我知诸法实相时能入涅槃。但为怜愍众生故受身。众生自来取去我不应惜。尔时深入诸法实相。此中无有定相。众生自生怖畏。以此功德与众生共之。回向阿耨多罗三藐三菩提。是中若有骂詈打害。能忍者是为忍。欢喜不退是为精进。是二法或从精进生忍辱。或从忍辱生精进。今从精进生忍辱。取禅波罗蜜者。有人自然得禅定。如劫尽时或有退得生得或上地生下地得。如是虽得禅定不从精进生。有因大布施破悭贪等五盖即得禅定。或有人持戒清净修集忍辱故。因小厌心便得禅定。或有人大智慧力故。知欲界无常虚诳不净即得禅定。禅定虽亦虚诳犹胜欲界。如是虽有精进更因余法得禅故。不名从精进生。有人不因五法为主。但日夜精进经行坐禅常与心斗。以信等五力深御五盖。若心驰散便摄令还。如与贼斗乃至流汗。如是等人得禅定从精进生。或有菩萨钝根宿罪所覆。深着世乐驰逸难制。如是人深加精进尔乃得定。譬如有福德之人安坐无事福禄自至。薄福之人勤设方便斗战乃得。有福之人自然得者名为福德自至。方便战斗得者名为精进而得。如是一切处虽有精进多处受名。取般若波罗蜜者。菩萨精进力故得禅波罗蜜。得禅波罗蜜故生菩萨神通力。二事因缘故以神通力遍至十方。未具足功德欲令具足。天欲教化一切众生。除四波罗蜜所生般若。余智慧多从精进生故。住精进为主取智慧。般若波罗蜜者有二种。一者观诸法实相。于一切法中不见法相不见非法相。二者如所说行人有懈怠心故不能行二事。精进力故能具足行二事。住禅波罗蜜为主。取五波罗蜜者。菩萨住禅波罗蜜中。心调柔不动能观察诸法实相。譬如密室然灯光照明了。是名住禅波罗蜜生智慧。尔时不恼一切众生。又加怜愍。是名甚深清净持戒忍辱。以神通力变化财物具足布施。又遣化人为一切说法。又菩萨从禅起。以清净柔软心为众生说法。是名布施。因禅定力起神通。周至十方导利一切而不懈息。是名精进。又因禅定令四波罗蜜增益。是名禅定生精进。余义如经广说。住般若波罗蜜为主。取五波罗蜜者。如经中佛自广说。问曰。佛虽广说。其中犹有不解者。今当问。十八空中何以不说四空。答曰。第十四名一切法空。言一切者法无不尽。是故不说。问曰。若尔者但应说十四。何以有十八。答曰。彼中分别一切法相空。一切空皆总入十八空。此中为行者说。行者或行一空二空乃至十四空。随本所著多少故。有深着邪见者以余四空。所以者何。有法无法等是外道邪见。是菩萨修慈悲心柔软故不生如是有无见。复次菩萨以十四空熏心故。于有无中了了不错。是故不说后四空。问曰。何以故。说菩萨如诸佛无贪着心。此说有何义。答曰。佛断诸烦恼习不起。菩萨以般若力制令不起。今欲赞叹般若力故结使虽未断。与佛断无异。令人知贵般若般若力。故发心作是念。此中无有法若生若灭若受骂詈割截等。问曰。此即是无生忍。何以言柔顺忍。答曰。此中说破五众和合假名众生不能破法。是故经说无生者灭者无受骂詈者。又是人破我虽观法空未能深入。犹有着法爱故如得无生忍法而有慈愍众生。柔顺忍中亦有念法空。是二法中一处众生不可得故名众生忍。二于法不可得故名为法忍。法忍者不妨众生忍。众生忍不妨法忍。但以深浅为别。问曰。超越三昧不得超二。又不从散心而入灭尽定。此中何以如是说。答曰。大小乘法异。不超二者是小乘法中说。菩萨无量福德智慧深入禅定力故能随意超越。如人力超踯不过丈数。若以天力超之无广远之难。又阿毗昙中皆为凡夫人声闻人说。菩萨则不然。智慧力故入师子奋迅三昧。能于诸法得自在。般若力故能随意自在说诸法应适众生。复有菩萨多行般若波罗蜜。知诸法实相安住不动法中。一切世间天及人。无能难诘令倾动者。若得财物布施二种众生。若施佛若施众生。以众生空故其心平等。不贵着诸佛不轻贱众生。若施贫贱人轻贱故福少。若施诸佛贪着故福不具足。若以金银宝物及施草木。以法空故亦等无异。断诸分别一异等诸妄想。入不二法门布施是名财施。法施亦如是。不贪贵有智能受法者。不轻无智不解法者。所以者何。佛法无量不可说不可思议故。若说布施等浅法。及说十二因缘空无相无作。空无相无作等诸甚深法等无异。何以故。是法皆入寂灭不戏论法中故。如是等名般若生布施。复次是菩萨于十方三世诸佛及弟子所修三种功德。随喜皆与一切众生共之。回向阿耨多罗三藐三菩提。智慧力故无所不施。能与众生福德分。复有菩萨若布施时生种种好心。拔出悭贪根本而行布施。慈心施故灭诸嗔恚。见受者得乐欢喜故灭嫉妒心。恭敬心施受者故破憍慢。了了信知布施果报故破疑及无明。不得与者受者定实故破有无等余邪见。观受者如佛观物如阿耨多罗三藐三菩提相。观己身从本已来毕竟空。若如是布施不虚诳故。直至阿耨多罗三藐三菩提。如是等相名般若波罗蜜生檀波罗蜜。复次菩萨深入清净般若波罗蜜故非无众生。而能受持十善等诸戒。欲破杀生颠倒故有不杀生戒。非实相中有。复次有人为百由旬众生持戒不杀。有为一阎浮提众生故持戒不杀。如是等为有量。众生持戒或有一日持戒。或受五戒十戒。如是等有量持戒。菩萨行般若为无量国土一切众生故持戒。不为一世二世。如如虚空法性实际住。以毕竟空相故不取是戒相。不憎破戒不着持戒。是名菩萨般若波罗蜜生具足无分别戒。忍辱有二种。一者众生忍。二者法忍。菩萨深入般若波罗蜜故得诸法忍。能信受无量佛法心无是非分别。如是相名般若波罗蜜中生忍辱。复有菩萨勤精进具足五波罗蜜故行般若波罗蜜。得诸法实相灭三业。身无所作口无所说心无所念。如人梦中没在大海动以手足求渡。觉已梦心即息。是名从般若波罗蜜中生第一精进。如持心经中说。我得是精进故于然灯佛得受记别。佛言。虽离智慧无禅定。多用智慧力得禅定。是故从智慧生禅定。如佛说辟支佛经中。有一国王。见二特牛淫欲故斗死。即自觉悟。我以财色故征伐他国与此何异。即舍离五欲得禅定成辟支佛。菩萨亦如是。少多因缘能厌患五欲。筹量五欲乐禅乐相去悬远。我岂可以五欲少乐而弃禅定乐。禅定乐者。福德清净遍身受乐。如是等从分别智慧生禅定。禅定义如经中说。复次是菩萨于无量劫为佛道故种善根。离欲故于诸禅定得自在。深入如法性实际。精进方便慈悲力故出于甚深法还修功德。是人胜伏其心。一念中能行六波罗蜜。所谓菩萨布施时如法舍财。是为檀波罗蜜。安住十善道中布施不向二乘。是为尸罗波罗蜜。若悭贪等诸烦恼及魔人民来不能动心。是名羼提波罗蜜。布施时身心精进不休不息。是名精进波罗蜜。摄心在布施不令散乱。无疑无悔。正向阿耨多罗三藐三菩提。是名禅波罗蜜。布施时与者受者财物不可得。不如邪见取相妄见一定相。如诸佛贤圣观物相受者与者及回向处相。法施时亦如是。是名般若波罗蜜。菩萨尽受诸戒。善心起正语正业三种律仪。戒律仪禅定律仪无漏律仪。住是戒中施一切众生无异。是名檀波罗蜜。淫欲嗔恚等诸烦恼欲破戒能制能忍。复次人来骂詈打害。畏破戒故忍而不报。又复饥渴寒热诸苦所逼。为持戒故如是等悉皆能忍。是名羼提波罗蜜。分别诸戒相轻重有残无残因缘本末或遮或听等。是心精进。能如戒法行。有犯则下意忏除。是名身精进。以是持戒精进。不求天王人王。乃至不求小乘涅槃。但为戒是菩萨道住处故。持戒能修集五波罗蜜。是名精进波罗蜜。菩萨若持戒清净不离禅定。何以故。持戒清净破诸烦恼力。心则调伏。譬如老夺壮力死来易坏。行者不得禅定故。念五欲生五盖侵害持戒。是故为戒坚牢故求禅定乐。禅定者摄诸心心数法一处和合名为禅定。行者能除恶身口破戒业。次除三恶觉观。然后除三细觉观。所谓国土亲里不死。如是除已即得禅定。是名禅波罗蜜。持戒时知戒能生如是今世后世功德果报。是名智慧。复次爱戒持戒破戒者。三事不可得。是名智慧。人有三种。下人破戒。中人着戒。上人不着戒。是菩萨思惟。若我憎破戒及破戒者。爱戒及持戒者。而生爱恚。则还受罪业因缘。譬如象浴洗已还以土坌。是故不应生憎爱。复次一切法皆属因缘。无自在者。诸善法皆因恶生。若因恶生云何可着。恶是善因云何可憎。如是思惟。直入诸法实相。观持戒破戒皆从因缘生。从因缘生故无自性。无自性故毕竟空。毕竟空故不着。是名般若波罗蜜。菩萨行忍辱时作是念。若众生来割截我身。我即布施不令众生得劫盗之罪。或修忍时因忍说法。种种因缘分别世间涅槃。令众生住六波罗蜜中。得众生忍能以身施是名财施。得法忍深入诸法。为众生说。是为法施。是二施从二忍生故名檀波罗蜜。菩萨行忍辱时不惜身命为忍辱。何况恼众生而破戒。是故因忍持戒怜愍一切众生。欲度脱之。持戒名一切诸善法安立住处。是名尸罗波罗蜜。菩萨于忍中身心勤行四波罗蜜。是名精进。于忍中心调柔不着五欲摄心一处。我于一切众生能忍如地。是名禅波罗蜜。菩萨知忍辱果报相好严身等。菩萨修忍能障诸烦恼。能忍众生过恶。能忍受一切深法。后得诸法实相。是时行者心中得是无生法忍。即是般若波罗蜜。菩萨住精进生诸波罗蜜。精进虽是一切善根本。离精进则无善法可得。但以精进力多生五波罗蜜故名精进生。菩萨常行三种施。未曾舍废财施法施无畏施。是名檀波罗蜜。菩萨善身口正业。直向佛道不贪二乘。是名尸罗波罗蜜。勤行精进。时有人来毁坏菩萨道。能忍不动。是名羼提波罗蜜。菩萨虽行种种余法。心不散乱。一心念萨婆若。是名禅波罗蜜。有二种精进。一动相身心勤行。二灭一切戏论故身心不动。菩萨虽勤行动精进亦不离不动精进。不动精进不离般若波罗蜜。菩萨入禅定。慈悲心力故施一切众生无畏。或禅定力故变化宝物。如须弥山充满一切。雨众华香等供养诸佛。及施贫穷众生衣服饮食等。或入禅定中为十方众生说法。是名檀波罗蜜。此中随禅定行身口善业。及离声闻辟支佛心。是名尸罗波罗蜜。菩萨入禅定得清净柔软乐。能不着禅味。禅定力故能深入诸法空。能忍受是法心不疑悔。是名羼提波罗蜜。菩萨忍辱时欲起诸三昧。超越三昧师子奋迅三昧等。无量诸菩萨三昧。不休不息是名精进波罗蜜。菩萨禅定力故心清净不动。能入诸法实相。诸法实相即是般若波罗蜜。菩萨行般若波罗蜜能观三种布施相。如阿耨多罗三藐三菩提。灭诸非有非无等戏论。是名无量无尽。般若中檀波罗蜜身口业随般若行。得般若故能牢固清净持戒是名尸罗波罗蜜。住般若心中众生忍法忍转深清净。是名羼提波罗蜜。行般若菩萨身心清净得不动精进。观动精进如幻如梦。得不动精进故不入涅槃。是名精进波罗蜜。菩萨行是无碍般若故。虽常入禅定。得般若波罗蜜力故不起于禅而能度众生。是名禅波罗蜜。如是等菩萨利智慧故。一心中一时能具足六波罗蜜

大智度论卷第八十一大智度论释大方便品第六十九(卷八十二)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】尔时须菩提白佛言。世尊。是菩萨摩诃萨如是方便力成就者。发意已来几时。佛告须菩提。是菩萨摩诃萨能成就方便力者。发心已来无量亿阿僧祇劫。须菩提言。世尊。是菩萨摩诃萨如是成就方便力者。为供养几佛。佛言。是菩萨成就方便力者供养如恒河沙等诸佛。须菩提白佛言。世尊。菩萨得如是方便力者。种何等善根。佛言。菩萨成就如是方便力者。从初发意已来。于檀波罗蜜无不具足。于尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜无不具足。须菩提白佛言。世尊。菩萨摩诃萨成就如是方便力者甚希有。佛言。如是如是。须菩提。菩萨摩诃萨成就如是方便力者甚希有。须菩提。譬如日月周行照四天下多有所益。般若波罗蜜亦如是。照五波罗蜜多有所益。须菩提。譬如转轮圣王若无轮宝不得名为转轮圣王。轮宝成就故得名转轮圣王。须菩提。五波罗蜜亦如是。若离般若波罗蜜。不得波罗蜜名字。不离般若波罗蜜故得波罗蜜名字。须菩提。譬如无夫妇人易为侵凌。五波罗蜜亦如是。远离般若波罗蜜。魔若魔天坏之则易。譬如有夫妇人难可侵凌。五波罗蜜亦如是。得般若波罗蜜。魔若魔天不能沮坏。须菩提。譬如军将铠仗具足邻国强敌所不能坏。五波罗蜜亦如是。不远离般若波罗蜜。魔若魔天若增上慢人。乃至菩萨旃陀罗所不能坏。须菩提。譬如诸小国王随时朝侍转轮圣王。五波罗蜜亦如是。随顺般若波罗蜜。譬如众川万流皆入于恒河随入大海。五波罗蜜亦如是。般若波罗蜜所守护故。随到萨婆若。譬如人之右手所作事便。般若波罗蜜亦如是。如人左手造事不便。五波罗蜜亦如是。譬如众流若大若小俱入大海合为一味。五波罗蜜亦如是。为般若波罗蜜所护。随般若波罗蜜入萨婆若。得波罗蜜名字。譬如转轮圣王四种兵轮宝在前导。王意欲住轮则为住。令四种兵满其所愿。轮亦不离其处。般若波罗蜜亦如是。导五波罗蜜到萨婆若。常是中住不过其处。譬如转轮圣王四种兵轮宝在前导。般若波罗蜜亦如是。导五波罗蜜到萨婆若中住。般若波罗蜜亦不分别檀波罗蜜随从我。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜不随从我。檀波罗蜜亦不分别我随从般若波罗蜜。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜不随从。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜。亦如是。何以故。诸波罗蜜性无所能作。自性空虚诳如野马。尔时须菩提白佛言。世尊。若一切法自性空。云何菩萨摩诃萨行六波罗蜜。当得阿耨多罗三藐三菩提。须菩提。菩萨摩诃萨行六波罗蜜时作是念。是世间心皆颠倒。我若不行方便力。不能度脱众生生死。我当为众生故行檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。是菩萨为众生故舍内外物。舍时作是念。我无所舍。何以故。是物必当坏败。菩萨作如是思惟。能具足檀波罗蜜。为众生故终不破戒。何以故。菩萨作是念。我为众生故发阿耨多罗三藐三菩提。若杀生是所不应。乃至我为众生故发阿耨多罗三藐三菩提。若作邪见。若贪着声闻辟支佛地是所不应。菩萨摩诃萨如是思惟。能具足尸罗波罗蜜。菩萨为众生故不嗔心乃至不生一念。菩萨如是思惟。我应利益众生。云何而起嗔心。菩萨如是思惟。能具足羼提波罗蜜。菩萨为众生故。乃至阿耨多罗三藐三菩提常不生懈怠心。菩萨如是行。能具足毗梨耶波罗蜜。菩萨为众生故。乃至得阿耨多罗三藐三菩提不生散乱心。菩萨如是行。能具足禅波罗蜜。菩萨为众生故。乃至得阿耨多罗三藐三菩提。终不离智慧。何以故。除智慧不可以余法度脱众生故。菩萨如是行。能具足般若波罗蜜。须菩提白佛言。世尊。若诸波罗蜜无差别相。云何般若波罗蜜于五波罗蜜中第一最上微妙

佛告须菩提。如是如是。诸波罗蜜虽无差别。若无般若波罗蜜。五波罗蜜不得波罗蜜名字。因般若波罗蜜。五波罗蜜得波罗蜜名字。须菩提。譬如种种色身到须弥山王边皆同一色。五波罗蜜亦如是。因般若波罗蜜到萨婆若中一种无异。不分别是檀波罗蜜是尸罗波罗蜜是羼提波罗蜜是毗梨耶波罗蜜是禅波罗蜜是般若波罗蜜。何以故。是诸波罗蜜无自性故。以是因缘故。诸波罗蜜无差别。须菩提白佛言。世尊。若随实义无分别。云何般若波罗蜜于五波罗蜜中最上微妙。佛言。如是如是。须菩提。虽实义中无有分别。但以世俗法故说。檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。为欲度众生生死。是众生实不生不死不起不退。须菩提。众生无所有故。当知一切法无所有。以是因缘故。般若波罗蜜于五波罗蜜中最上最妙。须菩提。譬如阎浮提众女人中玉女宝第一最上最妙。般若波罗蜜亦如是。于五波罗蜜中第一最上最妙。须菩提白佛言。世尊。佛以何意故。说般若波罗蜜最上最妙。佛告须菩提。是般若波罗蜜取一切善法到萨婆若中住不住故。须菩提白佛言。世尊。般若波罗蜜有法可取可舍不。佛言。不也。须菩提。般若波罗蜜无法可取。无法可舍。何以故。一切法不可取不可舍故。世尊。般若波罗蜜于何等法不取不舍。佛言。般若波罗蜜于色不取不舍。于受想行识乃至阿耨多罗三藐三菩提不取不舍。世尊。云何不取色。乃至不取阿耨多罗三藐三菩提。佛言。若菩萨不念色。乃至不念阿耨多罗三藐三菩提。是名不取色。乃至不取阿耨多罗三藐三菩提。须菩提言。世尊。若不念色乃至不念阿耨多罗三藐三菩提。云何得增益善根。善根不增云何具足诸波罗蜜。若不具足诸波罗蜜。云何得阿耨多罗三藐三菩提。佛告须菩提。若菩萨不念色乃至不念阿耨多罗三藐三菩提。是时善根增益。善根增益故具足诸波罗蜜。诸波罗蜜具足故。得阿耨多罗三藐三菩提。何以故。不念色乃至不念阿耨多罗三藐三菩提时。便得阿耨多罗三藐三菩提。世尊。何因缘故色不念时。乃至阿耨多罗三藐三菩提不念时。便得阿耨多罗三藐三菩提。佛言。以念故着欲界色界无色界。不念故无所著。如是须菩提。菩萨摩诃萨行般若波罗蜜不应有所著。世尊。菩萨摩诃萨如是行般若波罗蜜当住何处。佛言。菩萨摩诃萨如是行。不住色乃至不住一切种智。世尊。何因缘故色中不住。乃至一切种智中不住。佛言。不着故不住。何以故。是菩萨不见有法可着可住。如是须菩提。菩萨摩诃萨以不着不住法行般若波罗蜜。须菩提。若菩萨摩诃萨作是念。若能如是行如是修。是行般若波罗蜜我今行般若波罗蜜修般若波罗蜜。若如是取相则远离般若波罗蜜。若远离般若波罗蜜。则远离檀波罗蜜。乃至远离一切种智。何以故。般若波罗蜜无有着处亦无著者。自性无故。菩萨摩诃萨若复如是取相。则于般若波罗蜜退。若退般若波罗蜜。则是退阿耨多罗三藐三菩提。不得受记。菩萨摩诃萨复作是念。住是般若波罗蜜能生檀波罗蜜。乃至能生大悲。若作是念则为失般若波罗蜜。失般若波罗蜜者。则不能生檀波罗蜜。乃至不能生大悲。菩萨若复作是念。诸佛知诸法。无受相故。得阿耨多罗三藐三菩提。菩萨若作如是演说开示教诏。则失般若波罗蜜。何以故。佛于诸法无所知无所得。亦无法可说。何况当有所得。无有是处。须菩提白佛言。世尊。菩萨行般若波罗蜜。云何无是过失。佛言。若菩萨摩诃萨行般若波罗蜜作是念。诸法无所有不可取。若法无所有不可取则无所得。若如是行为行般若波罗蜜。若菩萨摩诃萨着无所有法。则远离般若波罗蜜。何以故。般若波罗蜜中无有着法故。须菩提白佛言。世尊般若波罗蜜远离般若波罗蜜耶。檀波罗蜜远离檀波罗蜜耶。乃至一切种智远离一切种智耶。世尊。若般若波罗蜜远离般若波罗蜜。乃至一切种智远离一切种智。菩萨云何得般若波罗蜜。乃至得一切种智。佛言。菩萨摩诃萨行般若波罗蜜时不生色。是色谁色。乃至一切种智不生。是一切种智谁一切种智。如是菩萨能生般若波罗蜜。乃至能生一切种智。复次须菩提。菩萨摩诃萨行般若波罗蜜时。不观色若常若无常若苦若乐若我若非我若空若不空若离若非离。何以故。自性不能生自性。乃至一切种智亦如是。若菩萨摩诃萨行般若波罗蜜。如是观色乃至观一切种智。能生般若波罗蜜。乃至能生一切种智。譬如转轮圣王有所至处四种兵皆随从。般若波罗蜜亦如是。有所至处五波罗蜜皆悉随从。到萨婆若中住。譬如善御驾驷不失平道随意所至。般若波罗蜜亦如是。御五波罗蜜不失正道至萨婆若。须菩提言。世尊。何等是菩萨摩诃萨道。何等是非道。佛言。声闻道非菩萨道。辟支佛道非菩萨道。一切种智道是菩萨摩诃萨道。须菩提。是名菩萨摩诃萨道非道。须菩提言。世尊。诸菩萨摩诃萨般若波罗蜜为大事故起。所谓示是道是非道。佛言。如是如是。须菩提。般若波罗蜜为大事故起。所谓示是道是非道。须菩提。是般若波罗蜜为度无量众生故起。为利益阿僧祇众生故起。般若波罗蜜虽作是利益。亦不受色亦不受受想行识。亦不受声闻辟支佛地。须菩提。般若波罗蜜是诸菩萨摩诃萨导示阿耨多罗三藐三菩提。能令离声闻辟支佛地住萨婆若。般若波罗蜜无所生无所灭。诸法常住故。须菩提言。世尊。若般若波罗蜜无所生无所灭。云何菩萨摩诃萨行般若波罗蜜时应布施。云何应持戒。云何应修忍。云何应勤精进。云何应入禅定。云何应修智慧。佛告须菩提。菩萨摩诃萨念萨婆若应布施。念萨婆若应持戒忍辱精进禅定智慧。是菩萨摩诃萨持是功德与众生共之。应回向阿耨多罗三藐三菩提。若如是回向。则具足修六波罗蜜乃至慈悲心诸功德。须菩提。若菩萨摩诃萨不远离六波罗蜜。则不远离萨婆若。以是故须菩提。菩萨摩诃萨欲得阿耨多罗三藐三菩提。应学应行六波罗蜜。菩萨摩诃萨行六波罗蜜具足一切善根。当得阿耨多罗三藐三菩提。以是故须菩提。菩萨摩诃萨应习行六波罗蜜。须菩提言。世尊。云何菩萨摩诃萨应习行六波罗蜜。佛言。菩萨摩诃萨应如是观。色不合不散。受想行识不合不散。乃至一切种智不合不散。是名菩萨摩诃萨习行六波罗蜜。复次须菩提。菩萨摩诃萨应作是念。我当不住色中。不住受想行识中。乃至不住一切种智中。如是应习行六波罗蜜。何以故。是色无所住。乃至萨婆若无所住。如是须菩提。菩萨摩诃萨以无所住法习行六波罗蜜。应当得阿耨多罗三藐三菩提。须菩提。譬如士夫欲食庵罗果若波罗那婆果。当种其子随时溉灌守护渐渐生长。时节和合便有果实得而食之。须菩提。菩萨摩诃萨亦如是。欲得阿耨多罗三藐三菩提。当学六波罗蜜。以布施摄取众生。持戒忍辱精进禅定智慧摄取众生。度众生生死。如是行当得阿耨多罗三藐三菩提以是故须菩提。菩萨摩诃萨欲不随他人语。当学般若波罗蜜。欲净佛国土成就众生。欲坐道场欲转法轮。当学般若波罗蜜。须菩提白佛言。世尊。应如是学般若波罗蜜耶。佛言。菩萨应如是学般若波罗蜜。欲于诸法得自在。当学般若波罗蜜。何以故。学是般若波罗蜜。于一切诸法中得自在故。复次般若波罗蜜于一切诸法中最大。譬如大海于万川中最大。般若波罗蜜亦如是。于一切诸法中最大。以是故诸欲求声闻辟支佛道及诸菩萨道。应当学般若波罗蜜檀波罗蜜乃至一切种智。须菩提。譬如射师执如意弓箭不畏怨敌。菩萨摩诃萨亦如是。行般若波罗蜜乃至一切种智。魔若魔天所不能坏。以是故须菩提。菩萨摩诃萨欲得阿耨多罗三藐三菩提。应学般若波罗蜜。是行般若波罗蜜菩萨。为十方诸佛所念。须菩提白佛言。世尊。云何十方诸佛念是菩萨摩诃萨。佛告须菩提。菩萨摩诃萨行檀波罗蜜时。十方诸佛皆念。行尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜时十方诸佛皆念。云何念。布施不可得。持戒忍辱精进禅定智慧不可得。乃至一切种智不可得。菩萨能如是。不得诸法故。诸佛念是菩萨摩诃萨。复次须菩提。诸佛不以色故念。不以受想行识故念。乃至不以一切种智故念。须菩提言。世尊。菩萨摩诃萨多有所学实无所学。佛言。如是如是。须菩提。菩萨多有所学实无所学。何以故。是菩萨所学诸法皆不可得。须菩提白佛言。世尊。佛所说法若略若广。于此法中。诸菩萨摩诃萨欲求阿耨多罗三藐三菩提。六波罗蜜若略若广。应当受持亲近读诵。读诵已思惟正观。心心数法不行故。佛告须菩提。如是如是。菩萨摩诃萨略广学六波罗蜜。当知一切法略广相。须菩提言。世尊。云何菩萨摩诃萨知一切法略广相。佛言。知色如相。知受想行识。乃至知一切种智如相。如是能知一切法略广相。须菩提言。世尊。云何色如相。云何受想行识乃至一切种智如相。佛告须菩提。色如相无生无灭无住异。是名色如相。乃至一切种智如相无生无灭无住异。是名一切种智如相。是中菩萨摩诃萨应学。复次须菩提。菩萨摩诃萨知诸法实际时。知一切法略广相。世尊。何等是诸法实际。佛言。无际是名实际。菩萨学是际。知一切诸法略广相。须菩提。若菩萨摩诃萨知诸法法性。是菩萨能知一切法略广相。世尊。何等是诸法法性。佛言。色性是名法性。是性无分无非分。须菩提。菩萨摩诃萨知法性故。知一切法略广相。须菩提白佛言。世尊。复云何应知一切法略广相。佛言。若菩萨摩诃萨知一切法不合不散。须菩提言。世尊。何等法不合不散。佛言。色不合不散。受想行识不合不散。乃至一切种智不合不散。有为性无为性不合不散。何以故。是诸法自性无。云何有合有散。若法自性无是为非法。非法不合不散。如是应当知一切法略广相。须菩提言。世尊。是名菩萨摩诃萨略摄般若波罗蜜。世尊。是略摄般若波罗蜜中。初发意菩萨摩诃萨应学。乃至十地菩萨摩诃萨亦应学。是菩萨摩诃萨学是略摄般若波罗蜜。则知一切法略广相

【论】释曰。须菩提闻菩萨摩诃萨大利根相。所谓一波罗蜜边能生五波罗蜜。行一波罗蜜即能具五波罗蜜。如上品中说。是事希有。故问佛。是菩萨发心已来为几时能得如是方便。佛答。是菩萨发心已来。除大菩萨于余众生无量亿阿僧祇劫。或有菩萨发心已来。无量亿阿僧祇劫大罪因缘覆心故。不见佛不亲近供养。是故问。是菩萨为供养几佛。佛答。是菩萨为已供养如恒河沙等诸佛。上言无量亿阿僧祇。今言恒河沙者。多数理同故。有菩萨久发心虽多以华香供养诸佛。而未能种善根。作是念我必当得果报。深心行六波罗蜜故。若以深心行六波罗蜜。为阿耨多罗三藐三菩提故作功德。是名种善根。是故第三问种何等善根。佛答。是菩萨从初发心已来。具足行六波罗蜜。一切福德无不作者。一切善法无不修集。须菩提闻已欢喜白佛言。希有世尊。是菩萨能如是行方便。所谓未断诸烦恼未离生死。而能胜断烦恼离生死法者。无始生死已来集诸恶法。菩萨心后来而能用后来心不随先所集恶心。是为希有。一切众生无恩于菩萨。而菩萨常欲利益是诸众生。或欲夺菩萨命割截身体。菩萨欲以第一佛乐。智慧命欲与众生。如是等是为希有。佛可须菩提所说。欲令此事明了故作譬喻。如日月照四天下。若无日月则百谷药草及众生无以生长。月是阴气日是阳气。二气和合故万物成长。是故日月于四天下大有利益。菩萨亦如是。于四生中以大悲心怜愍众生故能随所愿行一切善法。大智慧力故破众生着善法心。如是六波罗蜜等诸善增长成就。直至阿耨多罗三藐三菩提。又复众生虽复有眼若无日月则无所见。众生虽有世俗善根利智。不得般若波罗蜜照明尚不得二乘。何况得阿耨多罗三藐三菩提。又复菩萨虽行五波罗蜜。不得般若波罗蜜。不得名波罗蜜。以不破着心故。若菩萨乃至能自以身命布施。若无般若其心易破。如无夫之妇侵凌则易。若有般若则不可破坏。菩萨虽行种种诸余深法。不得般若不名为行波罗蜜。但名为行善法。有量有尽故。此中说譬喻。转轮圣王虽有千子八万四千小王及六宝。不得名为转轮圣王。不能飞行到四天下。若天遣金轮宝至乃得名为转轮圣王。菩萨亦如是虽有布施等诸善法。不得般若波罗蜜故不名为菩萨。为行六波罗蜜人不能除障碍行菩萨道故。譬如健将善知战法器仗具足不畏怨敌。健将即是菩萨。器仗是般若。增上慢者未得圣道意谓已得。菩萨说毕竟空法。是人行善法心不同故毁坏菩萨。外道梵志等及诸魔民乃至菩萨旃陀罗者。菩萨旃陀罗者如魔品中说。闻魔来称其名字而与受记而生轻慢。复次为般若波罗蜜故说五波罗蜜。若人能直行诸法实相则不为说布施等入般若初门。以人钝根罪重故种种因缘说。以布施破悭。持戒折薄诸烦恼。忍辱开福德门能行难事。精进如风吹火炽然不息。禅定摄心一定。观诸法实相故。是五波罗蜜皆趣向般若波罗蜜。如诸小王朝宗转轮圣王。如一切众流皆入大海。布施等诸善法亦如是。为般若波罗蜜所守护故得至萨婆若。问曰。五波罗蜜如诸川流。般若波罗蜜应如大海。今何以言五波罗蜜为般若波罗蜜所守护故得入萨婆若。答曰。汝不闻先说般若有种种名字耶。萨婆若即是般若异名。五波罗蜜福德入般若波罗蜜中。即得清净般若。般若清净故得佛道变名萨婆若。是故言入萨婆若即是入般若。有人疑诸波罗蜜各各有力。何以独言般若波罗蜜功用为大。是故言譬如人之右手自然稳便。五波罗蜜如左手。不得般若波罗蜜则所作不便。如人开目造事所作皆成。如导师在前余伴随逐进止取舍皆随导师不得自在。般若波罗蜜亦如是。导五波罗蜜所可修集成办皆仰般若。此中佛自说譬喻。如转轮圣王轮宝在四兵前导。轮住余宝则住。轮是般若波罗蜜。常在五波罗蜜前导。五波罗蜜随逐。如般若初品中说。菩萨欲具足檀波罗蜜不见施者受者及财物。先筹量分别断一切著然后布施。是则般若在前导。如轮宝伏四天下已常在王宫住虚空中。圣王是菩萨。轮是般若。破诸魔民烦恼已入萨婆若宫中住。是轮无所分别。我常在前余宝在后。无憎爱心是可来是不可来。般若无分别亦如是。檀波罗蜜随我来。尸罗波罗蜜勿来。如经中广说。此中佛自说因缘。一切法性无所能作。须菩提闻是已白佛言。若一切法性空无所有。云何菩萨行六波罗蜜能得阿耨多罗三藐三菩提。佛答。菩萨行般若作是念。诸法虽毕竟空。众生狂颠倒故深着不解。我若不以方便力则不可得度。方便者所谓金色身三十二相八十随形好无量光明神通变化。能以一指动十方三千大千国土。梵音说法无厌。色身十力四无所畏十八不共法无碍解脱一切种智大慈大悲等。具足无量诸佛法。然后能教化众生。众生必能信受。得如是力假令妄语人犹当信何况实语。如经说我虽知诸法实相能入涅槃。但为众生故行檀波罗蜜等。如经中广说。乃至不可以异事度众生。须菩提白佛言。世尊。若诸波罗蜜毕竟空故无差别。云何般若波罗蜜于诸波罗蜜中最尊。佛可须菩提。毕竟空中诸波罗蜜实无差别。若无般若波罗蜜。诸波罗蜜毕竟空无差别谁能知者。若无般若五法云何得波罗蜜名字。五波罗蜜未入般若时有差别。既入般若则无差别。如诸异色物到须弥山边皆同一色。不得言余物色皆同。何以独称须弥为大。檀波罗蜜等亦如是。虽无差别皆是般若力故不得言。何以独称般若为大。须菩提虽蒙开释犹未善解。复以异涂而问世尊。若实义中无差别。云何般若于五波罗蜜为上。先说未得圣道空。今说得圣道空。是故说第一实义。第一实义圣道是最可信。是中亦无差别。佛可言如是如是。我说六波罗蜜分别。皆为世俗故。何以故。世人不可但为说诸法实相。闻则迷闷生于疑悔。是故以第一义为心。用世俗语言为说。是故说分别有诸波罗蜜教化众生。众生实无有法。皆是空不生不死不退不起。色等法亦如是。是故般若波罗蜜虽空能示如是事故而最上最妙。譬如玉女宝于众女中最为第一而最上最妙。须菩提白佛。佛以何意故。常说般若最上者。须菩提种种因缘说般若五波罗蜜无差别。佛亦然可其所说而复言般若最上。佛言般若波罗蜜守护一切善法。至萨婆若中住者。一切虽空若无般若一切诸善法皆不能至萨婆若。善法者五波罗蜜三十七品大慈悲等诸菩萨法。问曰。若行诸善法亦能至萨婆若。何以但说般若故得至。答曰。虽诸善法和合能破烦恼得阿耨多罗三藐三菩提。而般若波罗蜜于中功力最大。譬如大军摧敌而主将得功名。复有人言。诸善法不得般若。不得至萨婆若。般若不得诸善法。独能至萨婆若。如经说。师子雷音佛国宝树庄严。其树常出无量法音。所谓一切法毕竟空无生无灭等。其土人民生便闻此法音故。不起恶心得无生法忍。如此人何有布施持戒等诸功德。亦有狂人醉人从佛闻四谛即时得道。如是等无有智慧。行余法得道无有是事。须菩提问佛。般若毕竟空。不取圣法不舍凡夫法。云何佛言是般若波罗蜜能至萨婆若住。佛可其言如是如是。是般若波罗蜜无取无舍。虽言取萨婆若以不取法故。取住义亦如是。此中佛自说因缘。所谓一切法不取相。一切法者色乃至菩提。是法虚诳从因缘生。自性无故不取。不取故不舍。以不忆念取相故。须菩提言。若不忆念色等法。云何增长善根。善根不增长云何得阿耨多罗三藐三菩提。佛答。若菩萨能灭一切法中忆念。即是空无相无作解脱门。解脱即是诸法实相。虽有善根以取相着心颠倒故不增长。譬如种谷其苗虽好秽草多故不能增长。此中说因缘。以众生忆念故。生三界善不善处。若无忆念则不着。不着则不生。须菩提从佛闻是已。思惟筹量是法。毕竟空无所有。若行是法亦应无所得无住处。何以故。因果相似故。是故问佛。菩萨作是念行般若。何所住何所得。佛答。色等一切法中不住。乃至不住中亦不住。不取相故不着。不着故则不住。此中佛自说因缘。是菩萨不见法有可着可住著者。住者此中法难破故。但说法不说著者。须菩提若菩萨住是众生空法空。作是念我能如是行者则是失则是离。何以故。般若波罗蜜是不着相。是菩萨以我心外着空内着我。不如般若行故言远离般若。何以故。般若波罗蜜是不着相。以性无故。上以着空故失。今以破空得般若而着。般若无性故失。失故不得受记。若作是念住般若中能生檀波罗蜜等者亦复是失。问曰。上二失因缘可尔。今以何为失。答曰。上二失以着空着无性法故。便不能修檀波罗蜜等功德而生邪见故。作是念若法都空复何所行。是人以不着空不着无性故行檀波罗蜜等。作是念能不着空无性。而能行是功德。是为真道是亦为失。以其心有悕望故。若失般若则不能行檀波罗蜜乃至大悲。何以故。阿耨多罗三藐三菩提是真实法。般若波罗蜜与此相似。檀等诸善法不相似。以其取相着故。若菩萨自忆想分别一切法不取相。诸佛知是已得阿耨多罗三藐三菩提。不取相者名毕竟空。不可取诸相灭故。亦为他开示演说则失般若。是人以求空则失。无性亦失。我是凡夫生死人。诸烦恼未尽云何能得。但随佛语自不分别。而定心为他人说不取一切相。是佛法。种种因缘以此事开示教诏。是亦为失。何以故。诸佛于诸法无所得取。义亦如是。是不取相法乃至假名字不可说。何况有所得。诸佛法寂灭相无诸戏论。一切语言道断故。须菩提作是念。若空有失空空中亦有失。无取法中亦有失。然不可无道。今当问佛。云何行者无是过失。佛答。若菩萨知诸法毕竟空。无所有不可取。是法不可得。知如是行者则无失。菩萨着毕竟空着无性着菩萨所行道。佛说三种皆失。菩萨闻是已则舍着心。今犹着佛所行未息。如佛所行必是真道。我但当随佛行。一切法无所有不取相。是故为失。今能如佛心中所得法。如是法相佛亦无所得。无所得故不贪贵佛不轻贱余人。于一切众生其心平等。此中更问。如是是清净般若无有过失。离自相不着。不离自相是即有相着法。若离自相云何可行。佛答。若菩萨于一切法不生。是名能行般若。是菩萨不说是色若常若无常等。是色谁色是色破色谁色破人。色乃至一切种智亦如是。若法如是毕竟空。推求不可得是不可生。所以者何。性不能生性。无性不能生无性。如是等破颠倒得实论议。皆是般若波罗蜜力。余波罗蜜皆随从。譬如转轮圣王有所至处。四种兵常随从。圣王福故四种兵皆能飞。般若力故诸余法皆是实性同至佛道。复次譬如善御驾驷不失平道。马虽有致车之力。若无御者则不能有所至。布施等亦如是虽有功德果报力。无般若调御不能至佛道。如是种种譬喻。五波罗蜜入般若中虽无差别。以是事故而般若波罗蜜最尊最妙。须菩提闻佛种种因缘说般若最大。又闻不行是行般若波罗蜜。是故问佛世尊何等是菩萨道。何等非菩萨道。佛答二乘非菩萨道。虽有凡夫及诸烦恼非菩萨道。粗故不说。二乘同行空同求涅槃故。说非菩萨道。粗事人不疑细事人疑故。萨婆若是菩萨道。因中说果故。须菩提欢喜赞叹般若作是言。世尊。般若波罗蜜为大事故起。如经中广说。乃至诸法常住故。须菩提难。若般若无所生无所灭。云何行布施持戒等。佛答。以般若无所生无所灭。即是毕竟空。毕竟空故不妨行六波罗蜜。菩萨闻种种因缘赞一切智。为一切智故行布施等法。是法为度一切众生故。回向阿耨多罗三藐三菩提。是六波罗蜜功德安立诸法实相中。回向阿耨多罗三藐三菩提。如是菩萨具足六波罗蜜慈等诸功德。不颠倒正行善根故。须菩提问。菩萨云何应习六波罗蜜。佛答。若菩萨观色等诸法不合不散。色等诸法颠倒烦恼和合故合。以正智慧观故散。菩萨以利智慧深观则无法合。颠倒烦恼皆虚诳故非合。如先破染染者事中说。是故菩萨知诸法本。不合故亦无散。则不生高心。复次菩萨不应作是念。我以真智慧令色等诸法清净而住其中。何以故。色等法无住处。如地住于水。水住于风。风住于空。空无所住。以本无住处故。一切都无住。菩萨应如是住无住法中得阿耨多罗三藐三菩提。此中说譬喻。树是般若波罗蜜。果是阿耨多罗三藐三菩提。若人欲得阿耨多罗三藐三菩提。应当种般若波罗蜜子。人是行者。水是五波罗蜜。如人溉灌树时虽未见果实时至则得。时节和合是具足诸法。如经中说。赞叹般若。若菩萨欲不随他行得诸法实相。若有邪见人来破坏。觉而不随。若欲净佛国土坐道场转法轮。当学般若。须菩提问佛如佛所教。菩萨当学般若。佛言我教令学般若。须菩提作是念。一切法平等相。何以故。但教学般若。佛答学是般若波罗蜜。于一切法得自在故。我教学般若波罗蜜。般若波罗蜜于一切法中最大。如佛于一切众生中最尊。又如万川大海为大。如经中说射师喻。若菩萨能如是一切法中行自在般若。魔若魔人所不能胜。何况增上慢及邪见人。是菩萨为十方诸佛所念。诸佛念义如先说。此中佛说若菩萨行六波罗蜜亦能观六波罗蜜毕竟空。如是人有大功夫故为诸佛所念譬如勇士入阵破贼而不被疮则为主所念。菩萨亦如是。破诸烦恼贼具足六波罗蜜。而不着六波罗蜜。则为诸佛所念。诸佛不取是菩萨色故念。不取受想行识故念。何以故。色等诸法虚诳不实故。诸佛观是菩萨身如实相故念。须菩提欢喜言。菩萨多有所学。亦学俗法亦学道法。亦学诸波罗蜜。亦学毕竟空。亦学起亦学灭。凡夫学起不能学灭。声闻学灭不能学起。菩萨亦学起亦学灭。是故言多有所学。是起灭如幻如梦毕竟空故实无所学。佛可其言自说因缘。菩萨所学皆无所得。须菩提白佛言。世尊。佛所说法若略若广。菩萨所应学。何以故言所学皆无所得。须菩提意。如佛所说八万四千法聚。十二部经若广若略。诸三乘人所学。此中说菩萨欲得阿耨多罗三藐三菩提。应学六波罗蜜若略若广。学者应当受持亲近是法读诵思惟正观乃至入无相三昧心心数法不行。菩萨能如是学。则能知诸法略广相。广者从八万四千法聚已来无量佛法。略者乃至小品。小品中一品。一品中一段。复次略者知诸法一切空无相无作无生无灭等。广者诸法种种别相分别。如后善知识中说。须菩提问。云何菩萨知一切法略广相。佛答。若知诸法如如相者。所谓不生不灭不住异。问曰。若如一相无生相。云何菩萨知是如故知诸法总相别相。总相别相即是略广相。答曰。如名诸法实相。常住不坏不随诸观。菩萨得是如即破无明邪见等诸颠倒。是人得实法故一切世间法总相别相了了知先。凡夫时智慧眼病以无明颠倒覆故不能实知。问曰实法相者所谓空无相无作诸智灭。云何言得如实相故了了知诸法总相别相。答曰我已先答。而汝于如中取相故。复作是难汝若知如不应作是难。是如毕竟无相故。不妨知诸法总相别相。以智慧明了了故。复次譬如人年既长大乃知小时所行皆愚痴可笑。菩萨亦如是。入诸法实相起已还在颠倒果报六情中。念寂灭解脱乐。乃知世间六情所著皆是虚诳可舍法。是名总相。于此中分别不净有上中下。无常苦空无我等亦如是。乃至八万四千种诸错谬。复次知如法性实际故。亦知诸法略广相。如法性实际差别义如初品中说。此中佛说非际是实际。非际者无相可取。无定法可着。得法性故知色等十八性皆是法性。法性相者佛说无分无非分。无分者不可示此示彼。无分别无相无量。无非分者不着是无相无量等。破量相法性。二事妨故不见。一有相有量。二无相无量。有相有量为粗。无相无量为细。是故说法性相无分无非分。菩萨入三解脱门住如等三实法。则能筹量知一切法总相别相。须菩提闻佛答已。欲更问无量佛法异门事。佛答知一切法无合无散故。则知诸法总相别相。问曰。眼见二指有合散。云何言无合散。答曰。我先言肉眼所见与牛羊无异不可信。复次三节皮肉具足为指。指无定法。复次设有指法亦不尽合。一分合多分不合。多分不合故不得言指合。问曰。以少合故名为合。答曰。指少分不名为指云何言指合。若多分不合不名为不合。何以少分合故名为合。是故不得言二指合。复次指与分不异不一故即是无指。无指故无合。入破一异门中则都无合。如佛此中说。一切法自性无。性无故即是无法。无法云何有合散。须菩提闻佛说如法性实际不合不散四门知略广相。是故须菩提言世尊是名略摄般若波罗蜜。略摄闻是安隐道故一切菩萨所应学

大智度论卷第八十二大智度论释大方便品第六十九之余(卷八十三)

        圣者龙树菩萨造

        后秦龟兹国三藏鸠摩罗什译

【经】世尊。是门利根菩萨摩诃萨所入。佛言。钝根菩萨亦可入是门。中根菩萨散心菩萨亦可入是门。是门无碍。若菩萨摩诃萨一心学者皆入是门。懈怠少精进妄忆念乱心者所不能入。精进不懈怠正忆念摄心者能入。欲住阿鞞跋致地。欲逮一切种智者能入。是菩萨摩诃萨如般若波罗蜜所说当学。乃至如檀波罗蜜所说当学。是菩萨摩诃萨当得一切智。是菩萨摩诃萨行般若波罗蜜。所有魔事欲起即灭。以是故菩萨摩诃萨欲得方便力。当行般若波罗蜜。若菩萨摩诃萨如是行如是习如是修般若波罗蜜。是事无量阿僧祇国土中现在诸佛。念是行般若波罗蜜菩萨。何以故。是般若波罗蜜中。生过去未来现在诸佛故。以是故菩萨摩诃萨应如是思惟。过去未来现在诸佛所得法我亦当得。如是须菩提。菩萨摩诃萨应习般若波罗蜜。若如是习般若波罗蜜。疾得阿耨多罗三藐三菩提。以是故菩萨摩诃萨常应不远离萨婆若念。若菩萨摩诃萨如是行般若波罗蜜。乃至弹指顷。是菩萨福德甚多。若有人教三千大千世界中众生。自恣布施教令持戒禅定智慧。教令得解脱解脱知见。教令得须陀洹果乃至阿罗汉果辟支佛道。不如是菩萨修般若波罗蜜乃至弹指顷。何以故。是般若波罗蜜中生布施持戒禅定智慧须陀洹果乃至辟支佛道。十方现在诸佛亦从般若波罗蜜中生。过去未来诸佛亦从般若波罗蜜中生故。复次须菩提。菩萨摩诃萨应萨婆若念行般若波罗蜜。若须臾时若半日若一日若一月若百日若一岁若百岁若一劫若百劫。乃至无量无边阿僧祇劫。是菩萨修是般若波罗蜜。福德甚多。胜于教十方恒河沙等世界中众生布施持戒禅定智慧解脱解脱知见。教令得须陀洹果乃至辟支佛道。何以故。诸佛从般若波罗蜜中生。说是布施持戒禅定智慧解脱解脱知见须陀洹果乃至辟支佛道。若有菩萨摩诃萨。如般若波罗蜜所说住。当知是菩萨摩诃萨是阿鞞跋致。为诸佛所念。如是方便力成就。当知是菩萨亲近供养无量千万亿诸佛种善根。与善知识相随。久行六波罗蜜。久修十八空四念处乃至八圣道分佛十力乃至一切种智。当知是菩萨住法王子地。满足诸愿。常不离诸佛。不离诸善根。从一佛国至一佛国。当知是菩萨辩才无尽具足得陀罗尼。身色具足受记具足故。为众生受身。当知是菩萨善知字门。善知非字门。善于言善于不言。善于一言善于二言善于多言。善知女语善知男语善知色乃至识。善知世间性。善知涅槃性。善知法相。善知有为相善知无为相。善知有法善知无法。善知自性善知他性。善知合法善知散法。善知相应法。善知不相应法。善知相应不相应法。善知如善知不如。善知法性善知法位。善知缘善知无缘。善知阴善知界。善知入善知谛。善知十二因缘。善知禅善知无量心。善知无色定。善知六波罗蜜。善知四念处。乃至善知一切种智。善知有为性。善知无为性。善知有性善知无性。善知色观善知受想行识观。乃至善知一切种智观。善知色色相空。善知受想行识识相空。乃至善知菩提菩提相空。善知舍道善知不舍道。善知生善知灭善知住异。善知欲善知嗔善知痴。善知不欲善知不嗔善知不痴。善知见善知不见。善知邪见善知正见善知一切见善知名善知色善知名色。善知因缘善知次第缘。善知缘缘善知增上缘。善知行相。善知苦善知集。善知灭善知道。善知地狱善知饿鬼善知畜生。善知人善知天。善知地狱趣。善知饿鬼趣。善知畜生趣。善知人趣善知天趣。善知须陀洹。善知须陀洹果。善知须陀洹道。善知斯陀含。善知斯陀含果。善知斯陀含道。善知阿那含。善知阿那含果。善知阿那含道。善知阿罗汉。善知阿罗汉果。善知阿罗汉道。善知辟支佛。善知辟支佛果。善知辟支佛道。善知佛善知一切智。善知一切智道。善知诸根善知诸根具足。善知慧善知疾慧。善知有力慧善知利慧。善知出慧善知达慧善知广慧善知深慧善知大慧。善知无等慧善知宝慧。善知过去世。善知未来世。善知现在世。善知方便善知待众生。善知心善知深心。善知义善知语。善知分别三乘。须菩提。菩萨摩诃萨行般若波罗蜜。生般若波罗蜜。修般若波罗蜜。得如是等利益

【论】释曰。须菩提意以四种门虽安隐。以甚深故利根者乃得入。佛答无不入者。须菩提明智慧利根者能入。佛意但一心精进欲学者可入。譬如热时清凉池有目有足皆可入。虽近不欲入者则不入四门般若波罗蜜池亦如是。四方众生无有遮者。不懈怠者是正精进。不妄念者是正念。不乱心者是正定。如等四门是正见。正见等安住是戒行。此八圣道能得般若波罗蜜。须菩提小乘智短故。但说利根者能入。佛大乘大智故。说虽中根钝根八法和合故能入是四门。佛此中以大悲气故说中根钝根皆可得入。若菩萨能如般若所说六波罗蜜学。不久当得萨婆若。如声闻法中不但以正见得道。以八分合行故。大乘法亦如是。不但学般若故得。萨婆若与五波罗蜜合故得。是故说。菩萨如所说般若波罗蜜当学得一切智。问曰。上说但般若能至一切种智。今何以言与五波罗蜜合故得至。答曰。常说与六波罗蜜合故得至。或时有清净佛国。但闻实相得至萨婆若。不用次第行诸波罗蜜。此中说菩萨得萨婆若则般若功报已足。今但赞行般若人力势。如经中说是菩萨行般若。所有魔事起即灭。从上诸佛所念来至此。皆是赞菩萨行般若功德乃至分别善知三乘善知字门者。如文字陀罗尼中说。非字名如法性实际。此中无文字。略说义是菩萨无量福德力故。善知二法世间及涅槃。若厌世苦则念涅槃。若欲没涅槃还念世间。集诸福德道故善知字。破福德中颠倒故善知无字。语不语亦如是。一语者以是一语能分别多少净语不净语一语二语多语男语女语等音声各异。菩萨善知是事故。能伏诸邪道及诸豪胜。善知色乃至识二种相若常若无常。如先说善知舍道者。菩萨从一地至一地。舍下地不忧得上地。不贪不舍道者。住是地中邪见。次世间正见。一切见学无学等诸见。行者十六行。善知须陀洹者人也。须陀洹道者见谛道也。须陀洹果第十六心心数法及无漏戒等诸法。乃至佛亦如是。善知诸根者。善分别二十二根。有人言观可度众生根有利钝。具足者可度。不具足者未可度。又菩萨亦自知善根具足不具足。如鸟子自知毛羽具足尔乃可飞。慧者一切智慧总相。疾慧者速知诸法。有人虽疾而智力不强。如马虽疾而力弱。有人虽有强智力而不利。譬如钝斧虽有大力不能破物。出慧者于种种难中能自拔出。亦能于诸烦恼中自拔出三界入涅槃。达慧者究尽通达于佛法中。乃至漏尽得涅槃。破坏诸法到法性中。广慧者道俗种种经书论议。于佛法中有无无不悉知。深慧者观一切法无量无相不可思议世间深智慧者能知久远事。利中有衰衰中有利。大慧者总具上诸慧名为大。又复一切众生中佛为大。诸法中般若为大。知佛信法与大法和合故名为大。无等慧者于般若中不着般若。能如是深入更无异法可喻。复次菩萨渐渐行道到不可思议性中。无有与等者故名无等。宝慧者如如意宝自无定色随前物而变。般若亦如是。自无定相随诸法行。又如如意珠随愿皆得。般若亦如是。有人行者能得佛愿何况余者。过去已灭未来未起。不得言有不得言无。于是中能行实相是名善知。现在法念念生灭故不可知而能通达是名善知。现在世方便名欲成办其事能具足因缘多少得所。于中不令有失。如菩萨虽行空不证实际虽行福德亦复不着。待众生者。如估客大将虽乘駃马能疾到所止故待众人。菩萨亦如是乘智慧駃马虽能疾入涅槃。亦待众生故不入。善知众生种种善恶心。深心者现在虽恶其本则好。如父母挝子外恶内善。如佛度鸯崛魔罗。知其浅心虽恶深心实善。菩萨观众生信等五善根从深心中来。是时可度义者有二。亦法亦名。语者语言以名字名物。得义无碍法无碍故。名善知义辞无碍。乐说无碍故名善知语。菩萨住是二善知中。能以三乘度众生。是名善知分别三乘。如是难解故解说。易解者不说。问曰。何以故。先说善知色乃至识。后说知众界入。何以先说善知缘。后说因次第缘增上。答曰。先广说后略说。复有人言先五众有三种善不善无记。戒众等五亦名为五众缘。先略说后广说

    大智度论释三惠品第七十

【经】须菩提白佛言。世尊。菩萨摩诃萨云何行般若波罗蜜。云何生般若波罗蜜。云何修般若波罗蜜。佛言。色寂灭故色空故色虚诳故色不坚实故。应行般若波罗蜜。受想行识亦如是。如汝所问。云何生般若波罗蜜。如虚空生故。应生般若波罗蜜。如汝所问。云何修般若波罗蜜。修诸法破坏故。应修般若波罗蜜。须菩提言。世尊。行般若波罗蜜。生般若波罗蜜。修般若波罗蜜。应几时。佛言。从初发意乃至坐道场。应行应生应修般若波罗蜜。须菩提白佛言。世尊。次第心应行般若波罗蜜。佛言。常不舍萨婆若心。不令余念得入。为行般若波罗蜜。为生般若波罗蜜。为修般若波罗蜜。若心心数法不行故。为行般若波罗蜜。为生般若波罗蜜。为修般若波罗蜜。须菩提白佛言。世尊。菩萨摩诃萨修般若波罗蜜。当得萨婆若不。佛言不。世尊。不修般若波罗蜜得萨婆若不。佛言不。世尊。修不修得萨婆若不。佛言不。世尊。非修非不修得萨婆若不。佛言不。世尊。若不尔。云何当得萨婆若。佛言。菩萨摩诃萨得萨婆若如如相。世尊。云何如如相。如实际。云何如实际。如法性。云何如法性。如我性众生性寿命性。世尊。云何我性众生性寿命性。佛告须菩提。于汝意云何。我众生寿命法可得不。须菩提言。不可得。佛言。若我众生寿命不可得。云何当说有我性众生性寿命性。若般若波罗蜜中不说有一切法。当得一切种智。须菩提言。世尊。但般若波罗蜜是不可说。禅波罗蜜乃至檀波罗蜜亦不可说。佛告须菩提。般若波罗蜜不可说。檀波罗蜜乃至一切法。若有为若无为。若声闻法若辟支佛法。若菩萨法若佛法亦不可说。世尊若一切法不可说。云何说是地狱是畜生是饿鬼是人是天是须陀洹是斯陀含阿那含阿罗汉辟支佛是诸佛。佛告须菩提。于汝意云何。是众生名字实可得不。世尊。不可得。佛言。若众生不可得。云何当说有地狱饿鬼畜生人天须陀洹乃至佛。如是须菩提。菩萨摩诃萨行般若波罗蜜时。应当学一切法不可说。须菩提言。世尊。菩萨摩诃萨学般若波罗蜜时。应学色受想行识。乃至应学一切种智。佛告须菩提。是菩萨摩诃萨学般若波罗蜜时。应学色不增不减。乃至应学一切种智不增不减。须菩提言。世尊。云何色不增不减学。乃至一切种智不增不减学。佛言。不生不灭故学。世尊。云何名不生不灭学。佛言。不起不作诸行业若有若无故。世尊。云何不起不作诸行业若有若无。佛言。观诸法自相空故。世尊。云何应观诸法自相空。佛言。应观色色相空。应观受想行识识相空。应观眼眼相空乃至意色乃至法眼识界乃至意识界意识界相空。应观内空内空相空。乃至应观自相空自相空相空。应观四禅四禅相空乃至灭受想定灭受想定相空。应观四念处四念处相空乃至阿耨多罗三藐三菩提阿耨多罗三藐三菩提相空。如是须菩提。菩萨行般若波罗蜜时。应行诸法自相空。世尊。若色色相空。乃至阿耨多罗三藐三菩提阿耨多罗三藐三菩提相空。云何菩萨摩诃萨应行般若波罗蜜。佛言。不行是名行般若波罗蜜。世尊。云何不行是行般若波罗蜜。佛言。般若波罗蜜不可得故。菩萨不可得。行亦不可得。行者行法行处亦不可得故。是名菩萨摩诃萨行不行般若波罗蜜。一切诸戏论不可得故。世尊。若不行是菩萨摩诃萨行般若波罗蜜。从初发意菩萨。云何行般若波罗蜜须菩提。菩萨从初发意已来应学空无所得法。是菩萨用无所得法故。布施持戒忍辱精进禅定。以无所得法故修智慧。乃至一切种智亦如是。须菩提白佛言。世尊。云何名有所得。云何名无所得。佛告须菩提。诸有二者是有所得。无有二者是无所得。世尊。何等是二有所得。何等是不二无所得。佛言。眼色为二。乃至意法为二。乃至阿耨多罗三藐三菩提佛为二。是名为二。世尊。从有所得中无所得。从无所得中无所得。佛言。不从有所得中无所得。不从无所得中无所得。须菩提。有所得无所得平等。是名无所得。如是须菩提。菩萨摩诃萨于有所得无所得平等法中应学。须菩提。菩萨摩诃萨如是学般若波罗蜜。是名无所得者无有过失。须菩提白佛言。世尊。若菩萨行般若波罗蜜。不行有所得。不行无所得。云何从一地至一地得一切种智。佛告须菩提。菩萨摩诃萨行般若波罗蜜时。不住有所得中。从一地至一地。何以故。有所得中住不能从一地至一地。何以故。须菩提。无所得是般若波罗蜜相。无所得是阿耨多罗三藐三菩提相。无所得亦是行般若波罗蜜者相。须菩提。菩萨摩诃萨应如是行般若波罗蜜。须菩提白佛言。世尊。若般若波罗蜜不可得。阿耨多罗三藐三菩提亦不可得。行般若波罗蜜者亦不可得。云何菩萨摩诃萨分别诸法相。是色是受想行识。乃至是阿耨多罗三藐三菩提。佛告须菩提。菩萨摩诃萨行般若波罗蜜时。不得色不得受想行识。乃至不得阿耨多罗三藐三菩提。世尊。若菩萨摩诃萨行般若波罗蜜时。色不可得乃至阿耨多罗三藐三菩提不可得。云何具足檀波罗蜜。乃至具足般若波罗蜜。入菩萨法位中。入已净佛国土成就众生。得一切种智。得一切种智已转法轮作佛事。度众生生死。佛告须菩提。菩萨摩诃萨不为色故行般若波罗蜜。乃至不为阿耨多罗三藐三菩提故行般若波罗蜜。须菩提白佛言。世尊。菩萨为何事故行般若波罗蜜。佛言。无所为故行般若波罗蜜。何以故。一切诸法无所为无所作。般若波罗蜜亦无所为无所作。阿耨多罗三藐三菩提亦无所为无所作。菩萨亦无所为无所作。如是须菩提。菩萨摩诃萨应行般若波罗蜜无所为无所作

【论】释曰。听者闻种种赞般若功德。得善知一切事。而贵爱是般若波罗蜜方便欲得。须菩提知众人意。是故问佛。世尊。云何行般若云何生云何修。有人言。行者在干慧地。生者得无生忍法。修者得无生忍法。后以禅波罗蜜熏修般若。佛答。五众是一切世间心所行结缚处。涅槃是寂灭相。菩萨以般若波罗蜜利智慧力故。能破五众通达令空。即是涅槃寂灭相。从寂灭出住六情中。还念寂灭相。知世间诸法皆是空虚诳不坚实。是名般若。行般若无定相故不可得说。若有若无言语道断故空如虚空。是故说如虚空生。又如虚空。虚空中无有法生。虚空亦不能有所生。所以者何。无法无形无触无作相故。般若波罗蜜亦如是。复有人言。有是虚空但以常法无作故。不能生是为定相。摩诃衍中虚空名无法。不得说常不得说无常。不得言有不得言无。非有非无亦不可得灭诸戏论。无染无著亦无文字。般若波罗蜜亦如是。能观世间似如虚空。是名生般若波罗蜜。菩萨得般若已入甚深禅定。以般若力故观禅定及禅定缘皆破坏。何以故。般若波罗蜜舍一切法不着相故。是名修般若波罗蜜。听者作是念。一切法皆有时节。是故须菩提问。般若波罗蜜应几时行。佛答。从初发心乃至坐道场应行。问曰。菩萨从初发心。应行十地六波罗蜜三十七品一切善法。何以但说行般若。答曰。须菩提但问般若故。佛答以行般若。又复是一切法皆与般若波罗蜜和合。以般若大故不说余法。问曰。般若波罗蜜无量无限。何以故以道场为限。答曰。先已答。是般若到佛心中转名萨婆若。理虽一名变故。言至道场应行。菩萨至道场发意已来。所得诸法皆舍得无碍解脱故。皆通达三世。问曰。弹指顷六十念念念生灭。云何一心常念萨婆若。不令余念得入。答曰。心有二种。一者念念生灭心。二者相续次第生。总名一心。以相续次第生故。虽多名为一心。是时不令贪恚等心相续得入。何以故。贪恚等心久住则能障般若波罗蜜。念少则不能为害。此为新发意菩萨故说。复有大菩萨。虽行余诸善法皆与般若和合。能令念念中余心不久。菩萨多于般若中起种种戏论及诸邪心。是故佛教常念萨婆若不令余念得入。常念者心无余向。纵使死急事至不忘萨婆若。般若波罗蜜行相者。所谓心心数法不行。问曰。凡夫人入无想定。若生无想天。圣人住有余涅槃入灭尽定。一切圣人入无余涅槃。心心数法皆不行。是则心心数法不行。菩萨行般若时云何心心数法不行。答曰。是事阿毗昙中说。非大乘中义。小乘大乘种种差别如先说。是故不应以阿毗昙难摩诃衍。复次无相三昧中。色等诸相灭故名无相。以无相故不应生心心数法。此亦非无想定灭尽定。问曰。无相义佛种种说。或名见谛道信行法行为无相。人以疾故或说无色定。想微细难觉故亦名无相。或以三解脱门中缘涅槃故名无相。是故不得。但以无相故名心心数法不行。乃至缘涅槃无相法。心心数法不灭。何况缘有相法。答曰。见谛道中无色定中说无相可尔。若言缘涅槃无相法是事不然。佛常种种赞叹涅槃无相无量不可思议法。即是无相无缘法。汝云何言缘。问曰。灭男女色等相故名无相。不言无涅槃相。行者取是涅槃相生心心数法是名缘。答曰。佛说一切有为生法。皆是魔网虚诳不实。若缘涅槃心心数法是实则失有为法虚诳相。若不实不能见涅槃。是故汝言涅槃有相可缘。是事不尔。问曰。佛自说涅槃法有三相。云何言无相。答曰。是三相假名无实。何以故。破有为三相故。说无生无灭无住无异无为更无别相。复次生相。先已种种因缘破生。毕竟不可得故。云何有无生。离有为相无为相不可得。是故无为但有名字无有自相。复次佛法真实寂灭无戏论。若涅槃有相。即是有定相可取。便是戏论。戏论故而生诤讼。若诤讼嗔恚尚不得生天人中。何况涅槃。是故如佛说。涅槃无相无量不可思议灭诸戏论此涅槃相。即是般若波罗蜜。是故不应有心心数法。如先品说。菩萨行般若。离心非心相。若有非心相应当难言无心相云何行般若。今离此二边故不应难。复次先世无明颠倒邪见因缘故得是身。是身中心心数法虽有善因缘生故无自性虚诳不实。是善心果报受人天福乐。皆是无常故能生大苦。亦是虚诳不实。何况不善无记心。因虚诳故果亦虚诳。般若波罗蜜真故。心心数法不行。须菩提闻是心心数法不行故。问佛。世尊。修般若波罗蜜得萨婆若不。佛言不。何以故。修名常行积集。皆应是心心数法力。是故言修。修尚不得何况不修。修不修者。是般若无为法故不修。能观实相故言修。二俱有过故言不。问曰。若第三中有过。第四有何过复言不。答曰。须菩提以取相着心问故佛言不。以受修不修故有非修非不修。是故佛言不。若以不取相心说非修非不修则无有过。须菩提四种问佛皆不听。心惑故复问。世尊。今云何当得萨婆若。佛答如如相如亦不解。是故佛言如实际。问曰。如品中须菩提自善说如。今云何有疑。答曰。是如无一定相。是故不得不问。若如有一定相者便应已解。是如甚深无量故。须菩提有处解有处不解。譬如大水有人入深者入浅者皆名入水。不得言入浅者不入水。问曰。何以不以如喻实际而以实际喻如。实际有何易解故譬喻。答曰。如实际虽是一物观时异。如是诸法体性实际是行者心取证。佛以须菩提得是实际为证故以为譬喻。问曰。常说法性次如实际次法性。今法性何以在后。答曰。今欲以我性众生性说毕竟空故转次在后。复次从见谛道学道中能观诸法。如无学道中。烦恼尽故定心作证。定心作证故。于一切总相别相中通达名为法性。诸法本生处名为性。是故以法性喻实际。法性有声闻分有大乘分。须菩提于声闻分中不疑。大乘分中有疑故问。佛欲以凡人所可解事为证故。言如我性众生性寿命性。须菩提更无所问。佛欲结句故反问。须菩提于汝意云何。我法相实有不。须菩提得道故言无。须陀洹尚不见我。何况阿罗汉。佛言。汝以小乘钝智。尚不得我何况佛。佛以智慧求我不可得。云何可说。如我不可说有一切法亦如是。菩萨能行是不可说法故当得萨婆若。不可说者。不可分别若有若无。须菩提问世尊。诸法若不可分别。云何分别说有地狱等五道须陀洹等诸圣道。佛答。众生无有定法。但有假名字。云何当分别说有地狱等众生及诸圣人。从分别众生等故有诸道名。众生实不可得。如是须菩提。菩萨应如是学不可说般若波罗蜜。须菩提问。世尊。菩萨应学色等诸法。今何以言学一切法不可说。佛答。菩萨虽应学色等法。但应作不增不减故学。不增不减义如先说。此中佛自说得不增不减因缘。若菩萨学不生不灭法。即是学不增不减。须菩提问。云何学不生不灭。佛答。不起不作诸行业若有若无故。有名三有。欲有色有无色有。无名断灭边。离八圣道强欲求灭。以是二事凡夫人起诸行业若善若不善。是菩萨知诸法实相。所谓不生不灭。是故不作三种业。不起业相应诸法。是名无作解脱门。不生不灭是无相解脱门。复问。世尊。何等方便故能不作不起诸行业。佛答。若菩萨能观诸法自相空。所谓色色相空。乃至阿耨多罗三藐三菩提。阿耨多罗三藐三菩提相空。菩萨尔时能作二事。一能不作不起诸行业。二能于一切法中行自相空。复问。世尊。若色等法自相空。云何菩萨应般若波罗蜜中行。佛答。不行是名菩萨般若中行。此中自说因缘。般若波罗蜜体不可得。行者行法行处不可得。法空故般若波罗蜜不可得。行处亦不可得。众生空故行者不可得。一切戏论不可得故。菩萨不行名为般若波罗蜜行。须菩提问。若不行是般若行者。初发心菩萨云何应行般若。须菩提意。若不行为行者。初发心菩萨心则迷闷。若以行为行者是则颠倒。是故问。佛答。初发心菩萨应学无所得法。无所得法即是无行学名。以方便力渐渐行。所谓布施时以无所得法故。应布施诸法实相毕竟空。毕竟空中无有可得若有若无。菩萨住如是智慧心中。应若多若少布施。布施物与者受者平等观故。所谓皆不可得。乃至萨婆若亦如是。须菩提作是念。有所得故则是世间颠倒。无所得故即是涅槃。是故问佛。云何有所得。云何无所得。佛略答二相是有所得。无二相是无所得。二相者眼一色一两一和合名为二。以眼故知是色。以色故知是眼。眼色是相待法。问曰。若不见色时亦有眼。云何眼不离色。答曰。以曾见色故名为眼。今虽不观色以本为名。是故一切有为法皆属因缘。因属果果属缘。无有定自在者乃至意法。菩萨佛亦如是。凡夫无智各各分别。作善不善业。智者知是二法皆虚诳属因缘。不以是二为二。须菩提问。是二法即是有所得。不二法即是无所得。世尊从有所得法中无所得。从无所得法中无所得。为缘诸法取相行道故。得是毕竟空无所得。为不作缘不取相不行道故。得是毕竟空无所得。若有所得中无所得者。有所得即是颠倒。行颠倒云何得实。若无所得中得无所得者。无所得即是无所有。无所有云何能生无所有。佛以二俱过故皆不听。有所得无所得二事。皆能平等观。平等即是毕竟空无所得。因无所得破有所得事既办。亦舍无所得。如是菩萨于有所得无所得平等般若中应学。若菩萨能如是学。是名真无所得者无有过失。从一地至一地义亦如是。须菩提问。世尊。若般若不可得。菩提不可得。菩萨不可得。云何菩萨学般若分别诸法相。所谓恼相是色苦乐相是受等。若菩萨行般若波罗蜜。色等法不可得。云何能具足檀波罗蜜等诸善法。云何能入菩萨位中。如经中广说。佛语须菩提。菩萨不以得色等诸法相故行般若。复问。为何等事故行般若。佛答。以无所得故行般若。何以故。一切法空无相无作无起。般若波罗蜜菩萨菩提。亦无相无作无起。菩萨为一切法实相故行般若。非以颠倒故。须菩提。菩萨应如是无作般若中行无作无起故

大智度论卷第八十三大智度论释三慧品第七十之余(卷八十四)

        圣者龙树菩萨造

        后秦龟兹国三藏鸠摩罗什译

【经】须菩提白佛言。世尊。若诸法无所为无所作。不应分别有三乘声闻辟支佛佛乘。佛告须菩提。诸法无所为无所作无有分别。有所为有所作中有分别。何以故。凡夫愚人不闻圣法着五受众。所谓色受想行识。着檀波罗蜜。乃至着阿耨多罗三藐三菩提。是人念有是色得是色。乃至念有是阿耨多罗三藐三菩提。得是阿耨多罗三藐三菩提。是菩萨作是念。我当得阿耨多罗三藐三菩提。我当度众生生死。须菩提。我以五眼观。尚不得色乃至阿耨多罗三藐三菩提。是狂愚人无目而欲得阿耨多罗三藐三菩提度脱众生生死。须菩提白佛言。世尊。若佛以五眼观。不见众生生死中可度者。今世尊云何得阿耨多罗三藐三菩提。分别众生有三聚正定邪定不定。须菩提。我得阿耨多罗三藐三菩提。初不得众生三聚若正定若邪定若不定。须菩提。以众生无法有法想。我以除其妄着世俗法故。说有得非第一义。世尊。非住第一义得阿耨多罗三藐三菩提耶。佛言不也。世尊。住颠倒得阿耨多罗三藐三菩提耶。佛言不也。世尊。若不住第一义中得。亦不住颠倒中得。将无世尊不得阿耨多罗三藐三菩提耶。佛言不也。我实得阿耨多罗三藐三菩提。无所住若有为相若无为相。须菩提。譬如佛所化人。不住有为相不住无为相。化人亦有来有去亦坐亦立。须菩提。是化人若行檀波罗蜜。行尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。行四禅四无量心四无色定五神通。行四念处乃至行八圣道分。入空三昧无相三昧无作三昧。行内空乃至无法有法空。行八背舍九次第定佛十力四无所畏四无碍智大慈大悲。得阿耨多罗三藐三菩提转法轮。是化人化作无量众生有三聚。须菩提。于汝意云何。是化人有行檀波罗蜜乃至有三聚众生不。须菩提言不也。须菩提。佛亦如是。知诸法如化。如化人度化众生。无有实众生可度。如是须菩提。菩萨摩诃萨行般若波罗蜜。如佛所化人行。须菩提白佛言。世尊。若一切法如化。佛与化人有何等差别。佛告须菩提。佛与化人无有差别。何以故。佛能有所作。化人亦能有所作。世尊。若无佛化独能有所作不。佛言。能有所作。须菩提言。世尊。云何无佛化能有所作。须菩提。譬如过去有佛名须扇多。为欲度菩萨故。化作佛已而自灭度。是化佛住半劫作佛事。授应菩萨行者记已灭度。一切世间众生知佛实灭度。须菩提。化人实无生无灭。如是须菩提。菩萨行般若波罗蜜。当信知诸法如化。世尊。若佛佛所化人无差别者。云何令布施清净。如人供养佛。是众生乃至无余涅槃福德不尽。若供养化佛。是人乃至无余涅槃。福德亦应不尽耶。佛告须菩提。佛以诸法实相故。与一切众生天及人作福田。化佛亦以诸法实相故。与一切众生天及人作福田。佛告须菩提。置是化佛及于化佛所种福德。若有善男子善女人。但以敬心念佛。是善根因缘乃至毕苦其福不尽。须菩提。置是敬心念佛。若有善男子善女人但以一华散虚空中念佛。乃至毕苦其福不尽。须菩提。置是敬心念佛散华念佛。若有人一称南无佛。乃至毕苦其福不尽。如是须菩提。佛福田中种其福无量。以是故。须菩提当知。佛与化佛无有差别。诸法法相无异故。须菩提。菩萨摩诃萨应如是行般若波罗蜜入诸法实相中。是诸法实相不应坏。所谓般若波罗蜜相。乃至阿耨多罗三藐三菩提相。须菩提白佛言。世尊。若诸法实相不应坏。佛何以故坏诸法相。言是色是受想行识是内法是外法是善法是不善法是有漏是无漏是世间是出世间是有诤法是无诤法是有为法是无为法等。世尊。将无壤诸法相。佛告须菩提。不也。以名字相故示诸法。欲令众生解。佛不坏诸法法相。须菩提白佛言。世尊。若以名字相故说诸法令众生解。世尊。一切法无名无相。云何以名相示众生欲令解。佛告须菩提。随世俗法有名相实无著处。须菩提。如凡夫说若著名随相。须菩提。诸佛及弟子不著名不随相。须菩提。若名著名相着相。空亦应着空。无相亦应着无相。无作亦应着无作。实际应着实际。法性应着法性。无为性应着无为性。须菩提。是一切法但有名相。是法不住名相中。如是须菩提。菩萨摩诃萨但名相中住。应行般若波罗蜜。是名相中亦不应着。世尊。若一切有为法但名相者。菩萨摩诃萨为谁故。发阿耨多罗三藐三菩提心受种种勤苦。菩萨行道时。布施持戒行忍辱勤精进入禅定。修智慧行四禅四无量心四无色定四念处乃至八圣道分。行空行无相行无作行佛十力。乃至具足大慈悲。佛言。如须菩提所说。若一切有为法但名相者。菩萨摩诃萨为谁故行菩萨道。须菩提。若有为法但名相等。是名相名相相空。以是故菩萨摩诃萨行菩萨道得一切种智。得一切种智已转法轮。转法轮已以三乘法度脱众生。是名相亦无生无灭无住异。尔时须菩提白佛言。世尊。世尊说一切种智。佛告须菩提。我说一切种智。须菩提言。佛说一切智。说道种智。说一切种智。是三种智有何差别。佛告须菩提。萨婆若是一切声闻辟支佛智。道种智是菩萨摩诃萨智。一切种智是诸佛智。须菩提白佛言。世尊。何因缘故。萨婆若是声闻辟支佛智。佛告须菩提。一切名所谓内外法。是声闻辟支佛能知。不能用一切道一切种智。须菩提言。世尊。何因缘故。道种智是诸菩萨摩诃萨智。佛告须菩提。一切道菩萨摩诃萨应知。若声闻道辟支佛道菩萨道应具足知。亦应用是道度众生。亦不作实际证。须菩提白佛言。世尊。如佛说。菩萨摩诃萨应具足诸道。不应以是道实际作证耶。佛告须菩提。是菩萨未净佛土未成就众生。是时不应实际作证。须菩提白佛言。世尊。菩萨住道中应实际作证。佛言不也。世尊。住非道中实际作证。佛言不也。世尊。住道非道实际作证。佛言不也。世尊。住非道亦非非道实际作证。佛言不也。世尊。菩萨摩诃萨住何处应实际作证。佛告须菩提。于汝意云何。汝住道中受诸法故。漏尽得解脱不。须菩提言。不也世尊。汝住非道漏尽得解脱不。不也世尊。汝住道非道漏尽得解脱不。不也世尊。汝住非道亦非非道漏尽得解脱不。不也世尊。我无所住不受诸法。漏尽心得解脱。佛告须菩提。菩萨摩诃萨亦如是。无所住应实际作证。须菩提言。世尊。云何为一切种智相。佛言。一相故名一切种智。所谓一切法寂灭相。复次诸法行类相貌名字显示说。佛如实知。以是故名一切种智。须菩提白佛言。世尊。一切智道种智一切种智。是三智结断有差别。有尽有余不。佛言。烦恼断无差别。诸佛烦恼习一切悉断。声闻辟支佛烦恼习不悉断。世尊。是诸人不得无为法得断烦恼耶。佛言不也。世尊。无为法中可得差别不。佛言不也。世尊。若无为法中不可得差别。何以故。说是人烦恼习断是人烦恼习不断。佛告须菩提。习非烦恼。是声闻辟支佛身口。有似淫欲嗔恚愚痴相。凡夫愚人为之得罪。是三毒习诸佛无有。须菩提白佛言。世尊。若道无法涅槃亦无法。何以故。分别说是须陀洹是斯陀含是阿那含是阿罗汉是辟支佛是菩萨是佛。佛告须菩提。是皆以无为法而有分别。是须陀洹是斯陀含是阿那含是阿罗汉是辟支佛是菩萨是佛。世尊。实以无为法故。分别有须陀洹乃至佛。佛告须菩提。世间言说故有差别。非第一义。第一义中无有分别说。何以故。第一义中无言说道断结故说后际。须菩提言。世尊。诸法自相空中前际不可得。何况说有后际。佛告须菩提。如是如是。诸法自相空中无有前际。何况有后际无有是处。须菩提。以众生不知诸法自相空故。为说是前际是后际。诸法自相空中。前际后际不可得。如是须菩提。菩萨摩诃萨应以自相空法行般若波罗蜜。须菩提。若菩萨行自相空法则无所著。若内法若外法若有为法若无为法。若声闻法若辟支佛法若佛法。须菩提白佛言。世尊。常说般若波罗蜜。般若波罗蜜以何义故名般若波罗蜜佛言。得第一度一切法到彼岸。以是义故。名般若波罗蜜。复次须菩提。诸佛菩萨辟支佛阿罗汉。用是般若波罗蜜得度彼岸。以是义故名般若波罗蜜。复次须菩提。分别筹量破坏一切法乃至微尘。是中不得坚实。以是义故名般若波罗蜜。复次须菩提。诸法如法性实际。皆入般若波罗蜜中。以是义故名般若波罗蜜。复次须菩提。是般若波罗蜜无有法若合若散若有色若无色若可见若不可见若有对若无对若有漏若无漏若有为若无为。何以故。是般若波罗蜜。无色无形无对。一相所谓无相。复次须菩提。是般若波罗蜜能生一切法一切乐说辩一切照明。须菩提。是般若波罗蜜。魔若魔天求声闻辟支佛人。及余异道梵志怨仇恶人不能断坏。菩萨行般若波罗蜜。何以故。是人辈般若波罗蜜中皆不可得故。须菩提。菩萨摩诃萨应如是行般若波罗蜜义。复次须菩提。菩萨摩诃萨欲行深般若波罗蜜义。应行无常义苦义空义无我义。亦应行苦智义集智义灭智义道智义法智义比智义世智义他心智义尽智义无生智义如实智义。如是须菩提。菩萨摩诃萨为般若波罗蜜义故。应行般若波罗蜜。须菩提白佛言。世尊。是深般若波罗蜜中义与非义皆不可得。云何菩萨为深般若波罗蜜义故。应行般若波罗蜜。佛告须菩提。菩萨摩诃萨为深般若波罗蜜义故。应如是念。贪欲非义如是义不应行。嗔恚愚痴非义。如是义不应行。一切邪见无义。如是义不应行。何以故。三毒如相无有义无有非义。一切邪见如相无有义无有非义。复次须菩提。菩萨摩诃萨应作是念。色非义非非义。乃至识非义非非义。檀波罗蜜乃至阿耨多罗三藐三菩提。非义非非义。何以故。须菩提。佛得阿耨多罗三藐三菩提时。无有法可得若义若非义。须菩提。有佛无佛。诸法法相常住无有是义无有非义。如是须菩提。菩萨摩诃萨行般若波罗蜜应离义非义。须菩提白佛言。世尊。何以故。般若波罗蜜非义非非义。佛告须菩提。一切有为法无作相。以是故般若波罗蜜非义非非义。世尊。一切贤圣若佛若佛弟子。皆以无为为义。云何佛言般若波罗蜜无有义非义。佛言。虽一切贤圣若佛若佛弟子皆以无为为义。亦不以增亦不以损。须菩提。譬如虚空如。不能益众生不能损众生。如是须菩提。菩萨摩诃萨般若波罗蜜。无有增无有损。世尊。菩萨摩诃萨不学无为般若波罗蜜。得一切种智耶。佛言。如是如是。须菩提。菩萨摩诃萨学是无为般若波罗蜜。当得一切种智。不以二法故。世尊。不二法能得不二法耶。佛言不也。须菩提言。二法能得不二法耶。佛言不也。须菩提言。世尊。菩萨摩诃萨若不以二法亦不以不二法。云何当得一切种智。须菩提。无所得即是得。以是得无所得

【论】释曰。须菩提复问。世尊。若一切法无作无起相。云何分别有三乘。佛可其意更说因缘。凡夫人未得道。着五众故亦着是空无作无起法故生疑。云何分别有三乘。汝已得道不着五众。亦不着空无作无起云何生疑。佛此中自说因缘。我以五眼尚不得色等诸法。狂人无眼而欲得。须菩提问。若无法无众生。云何说有三聚众生。佛答。我观众生一聚不可得。云何有三。但为欲破颠倒故分别有三。能破颠倒者名正定。必不能破颠倒者是邪定。得因缘能破。不得则不能破是名不定。皆以世俗法故说。非最第一义。问曰。佛实住第一义中得道。何以答须菩提言不。答曰。须菩提为新发意著者故问。是故佛言不。何以故。颠倒有法中尚不可住。何况第一义无所有中住。是故须菩提疑。若二处不住将无世尊不得正觉耶。佛答。实得阿耨多罗三藐三菩提道。但无所住。有为性虚诳不实。无为性空无所有故不可住。此中佛欲明了是事故说化佛譬喻。如化佛不住有为性不住无为性。而能来去说法。问曰。化人来去说法可尔。云何能行檀波罗蜜等。答曰。不言化人能实行。众生眼见似有所行是化事。如经中说乃至须扇多。须菩提意已信伏。种种因缘化佛真佛等无异。今犹少疑问佛。若无分别者供养真佛乃至无余涅槃福故不尽。供养化佛亦尔不。佛答。供养化佛真佛其福不异。何以故。佛得诸法实相故。供养福无尽。化佛亦不离实相故。若供养者心能不异其福亦等。问曰。化佛无十力等诸功德。云何与真佛等。答曰。十力等诸功德皆入诸法实相。若十力等离诸法实相则非佛法。随颠倒邪见。问曰。若尔真化中定有诸法实相者。何以言恶心出佛身血得逆罪不说化佛。答曰。经中但说恶心出佛身血。不辩真化。若供养化佛得具足福者。恶心毁谤亦应得逆罪。恶人定谓化佛是真而恶心出血。血则为出便得逆罪。问曰。若尔者毗尼中何以言杀化人不犯杀戒。答曰。毗尼中皆为世间事摄众僧故。结戒不论实相。何以故。毗尼中有人有众生。逐假名而结戒。为护佛法故不观后世罪多少。有后世罪重戒中便轻。如道人鞭打杀牛羊等罪重而戒轻。赞叹女人戒中重后世罪轻。杀化牛羊则众人不嫌不讥不论。但自得心罪。若杀真化牛羊心不异者得罪等。然制戒意为众人讥嫌故为重。是故经中说意业最大非身口业。如人大行布施。不及行慈三昧。行慈三昧众生无所得。而自得无量福。邪见断善根人不恼众生。而入阿鼻地狱。是故供养化佛真佛以心等故其福不异。复次此中佛说。置是化佛光相具足。有人见石泥像等慈心念佛。是人乃至毕苦其福不尽。佛言。复置泥像。若有恭敬心虽不见佛像。念佛故以华散空中。其福亦得毕苦。复置散华。但一称南无佛。是人亦得毕苦其福不尽。问曰。云何但空称佛名字。便得毕苦其福不尽。答曰。是人曾闻佛功德能度人老病死。若多若少供养及称名字得无量福。亦至毕苦不尽。是故福田无量。故虽濡心布施其福亦无尽。如是种种因缘譬喻故。真佛化佛无异于佛福田供养者其福无量。以一切法实相无别无异故。尔时须菩提问佛。世尊。若诸法实相无坏故二佛无异。今佛分别说诸法是色是受想行识乃至是有为是无为法。将无坏诸法相耶。佛答须菩提。佛虽种种分别说诸法。但以言说欲令众生得解心无所著。若二佛共语不应说诸法名字。以众生无及佛者欲牵引令解故。说是善是恶。如法华经说火宅以三乘引出诸子。但以名相说诸法不坏第一义。须菩提问。虽以名相为众生说无有实事。将无虚妄耶。佛答。圣人随世俗言说。于中无有名相着处。佛此中自说因缘。如凡夫说苦著名取相。诸佛及弟子。口说苦而心不着。若着不名苦圣谛。苦谛即是名相等无有定实。凡夫著者亦是名相无有定实。云何空名相中着空名相。若空名相中著名相者。空亦应着空。无相亦应着无相。无作亦应着无作。乃至无为性亦应着无为性。是法皆如。凡夫苦谛相但有名相。名相亦不住名相中。菩萨入是名相等诸法门中。住是名相般若中。应观一切法无有实。须菩提问。若一切法但有名相。菩萨为何等故发心。如经中说。佛答。若一切法但有名相者。名相中名相亦空。是法皆毕竟空入如法性实际中。是故菩萨能发阿耨多罗三藐三菩提。乃至能以三乘度众生。若诸法有定实非名相者。即是无生灭。无生灭故无苦无集无尽无道。云何以三乘度众生。若诸法但是空名相无实者。亦无生灭。无生灭故无苦集尽道。亦云何可度。今菩萨知一切法名相等空。则离世间颠倒。亦知名相空。亦离名相空。如是离有离无处中道能度众生。佛意菩萨行是中道般若得一切种智。尔时须菩提欲难故。先定佛语乃问。世尊说一切种智耶。佛言。我说一切种智。复问。佛常说三种智。三种智有何差别。佛答。萨婆若是声闻辟支佛智。何以故。一切名内外十二入。是法声闻辟支佛总相知。皆是无常苦空无我等。道种智是诸菩萨摩诃萨智。道有四种。一者人天中受福乐道。所谓种福德。并三乘道为四。菩萨法应引导众生着大道中。若不任入大道者着二乘中。若不任入涅槃者着人天福乐中。作涅槃因缘世间福乐道。是十善布施诸福德。三十七品是二乘道。三十七品及六波罗蜜是菩萨道。菩萨应了了知是诸道。菩萨以佛道自为为人。以余三道但为众生。是菩萨道种智。须菩提问。何以道种智为菩萨事。佛答。菩萨应具足一切道。以是道化众生。虽出入是道未教化众生净佛国土而不取证。具足是事已然后坐道场乃取证。是故须菩提。道种智是菩萨事。须菩提复问。是菩萨住何处实际作证。须菩提意。若住道中作证是事不然。有二过故。一者有结使。人不应有毕竟清净正智。若有则与佛无异。若异者有烦恼习气故应有错谬。二者一切有为法。皆是虚诳和合故有假名无有定实。是故佛言不也。若住道中尚不得。何况非道道。非道亦有二过故。非道非不道。以着心取相故亦言不也。尔时须菩提意。或作是念。佛所得道甚深不可得底。是故复问菩萨住何处实际作证。佛反问须菩提。问曰。佛何以故不直答而反问须菩提。答曰。须菩提自于所得道中了了无或贵尚佛所证故。四句戏论如有着心不了故问。是故佛以须菩提所得证反问。汝得道时住四句中得证耶。答言不也。我无所住而得漏尽。汝以无所住而心得解脱。当知菩萨摩诃萨亦如是。不住四句而证实际。是故佛反问。复有人言。四种答中是名反问答。问曰。须菩提住金刚三昧心得解脱。云何言不住道中。答曰。住名取相定有是法。是人更求无为胜法故不名为住有为法。为不用故不于中住。复有人言住是名相。凡夫法中便有分别。是金刚是解脱。得无相法则无所分别。佛为无相法故反问须菩提。汝不应以名相故问。汝不应以名相为难。一切种智是佛智。一切种智名一切三世法中通达无碍。知大小精粗无事不知。佛自说一切种智义有二种相。一者通达诸法实相故寂灭相。如大海水中风不能动。以其深故波浪不起。一切种智亦如是。戏论风所不能动。二者一切诸法可以名相文字言说了了通达无碍。摄有无二事故名一切种智。有人言。十力四无所畏四无碍法十八不共法。尽是智慧相和合。名为一切种智。复有人言。金刚三昧次第得无碍解脱故。若大小近远深浅难易无事不知。如是等种种无量因缘名一切种智。须菩提闻是已问佛。智慧故有上中下分别。烦恼断复有差别不。佛言无差别。断时有差别。断已无差别。譬如刀有利钝。断时有迟速。断已无差别。如来烦恼及习都尽。声闻辟支佛但烦恼尽而习气有余。须菩提问佛。世尊三种。断是有为是无为。佛答。皆是无为。复问。世尊无为法中可得差别不。佛答。是法无相无量。云何可得差别。复问。世尊若无差别。云何说是断中有余是断中无余。须菩提。是习不名真烦恼。有人虽断一切烦恼。身口中亦有烦恼相出。凡人见闻是相已则起不清净心。譬如蜜婆私诧阿罗汉。五百世在猕猴中。今虽得阿罗汉犹腾跳树木。愚人见之即生轻慢。是比丘似如猕猴。是阿罗汉无烦恼心而犹有本习。又如毕陵伽婆蹉阿罗汉。五百世生婆罗门中习轻蔑心故。虽得阿罗汉犹语恒水神言。小婢止流。恒神嗔恚诣佛陈诉。佛教忏悔犹称小婢。如是等身口业烦恼习气二乘不尽。佛无如是事。如一婆罗门恶口。一时以五百事骂佛。佛无愠色。婆罗门心乃欢喜。即复一时以五百善事赞叹于佛。佛亦无喜色。当知佛烦恼习气尽故好恶无异。又复佛初得道。实功德中出好名声充满十方。唯佛自知。而孙陀梨梵志女杀身谤佛。恶名流布。佛于此二事心无有异亦不忧喜。又入婆罗门聚落中空钵而出。天人种种供养。又复三月食马麦。释提桓因恭敬以天食供养。阿罗婆伽林中棘刺寒风。佛在中宿。又于欢喜园中在天白宝石上。柔濡滑泽。又敷天卧具。于此好恶事中心无忧喜。又提婆达嗔心以石堆佛。罗睺罗敬心合手礼佛。于此二人其心平等如爱两眼。如是等种种干乱无有异想。譬如真金烧磨锻截其色不变。佛经此众事心无增减。是故可知诸佛爱恚等诸烦恼习气都尽。须菩提意。若诸法实相中。若道若涅槃无所有。若无所有何以分别是须陀洹乃至辟支佛习气未尽佛习气尽。佛言。三乘圣人皆以无为法而有差别。虽因无为有差别。而有为法中可得说。须菩提欲定佛语故问。世尊。实以无为法故有差别耶。佛答。世俗法语言名相故可分别。第一法中无分别。何以故。第一义中一切语言道断。以一切心所行断故。但以诸圣人结使断故说有后际。后际者所谓无余涅槃。须菩提问世尊。诸法自相空故。前际不可得。何况后际。何以故。因前际故有后际。佛可其意以众生不知诸法自相空故。说是前际是后际。自相空诸法中前后际不可得。何以故。若先有生则后有老死。若离老死。有生。是则不死而生。是生无因无缘。若先老死后有生者。不生云何有老死。先后既不可得。一时亦不可得。以是故说自相空法中无有前后际。佛言。如是须菩提。菩萨应以自相空法行般若。内外法乃至佛法不着故。问曰。上来常说般若波罗蜜相。今何以更问。答曰。不但问相。人常说般若波罗蜜。般若波罗蜜以何义故名般若。佛言。以第一度一切法到彼岸名般若波罗蜜。第一度者声闻人以下智度。辟支佛以中智度。菩萨以上智度故名第一度。复次烦恼有九种。上中下各有三品。智慧亦有九种。下下智慧从钝根须陀洹来。乃至上下是第一声闻舍利弗等。上中是大辟支佛。上上是菩萨。以上上智慧度故名第一度。声闻辟支佛但总相度于别相少。菩萨一切法总相别相皆了了知故名第一度。复次菩萨度时智慧遍满可知法中。二乘人可知法中不能遍满。是故名第一度。复次第一度者。大乘福德智慧六波罗蜜。三十七品具足满故安隐度。又十方诸佛大菩萨诸天。皆来佐助安隐得度。如人乘七宝船牢治行具上有种种好食有好导师。遇随意好风则为好度。若人乘草筏度恐怖不名好度。复次佛说三乘人。以是般若波罗蜜度到彼岸。涅槃灭一切忧苦。以是义故名般若波罗蜜。复次是般若波罗蜜中。一切法内外大小思惟筹量分别推求。乃至如微尘不得坚实。既到微尘则不可分别。心心数法乃至一念中亦不可分别。是般若波罗蜜中。心色二法破坏推求不得坚实。以是义故名般若波罗蜜。复次般若名慧。波罗蜜到彼岸。彼岸名尽一切智慧边智慧。名不可破坏相。不可破坏相即是如法性实际。以其实故不可破坏。是三事摄入般若中故名为般若波罗蜜。复次般若波罗蜜无有法与法有合有散。毕竟空故是般若无色无形无对一相所谓无相。是义如先说。如是等种种因缘故名般若义。今当说般若力。所谓般若能生一切智慧禅定等诸法。能生一切乐说辩才。以般若力故演说一句。种种庄严穷劫不尽。星宿日月不能照处。般若能照能破邪见无明黑闇故。魔若魔人求声闻辟支佛人。外道恶人所不能坏。何以故。菩萨行般若。此诸恶人于般若中皆不可得故。复次若行者一心信受讽诵。诸恶不能得便。何况正忆念如说行。如是须菩提。菩萨应行般若义。般若义者所谓无常义。苦空无我义。四谛智尽智无生智法智比智世智知他心智如实智义。故应行般若。是般若如大海有种种宝物或大或小唯一是如意宝。般若波罗蜜亦有种种诸智慧宝无常等四圣行十智。唯有如实智。如如意宝。问曰。如先品说。若常若无常等行不名行般若波罗蜜。今何以言行无常等义故应行般若波罗蜜。答曰。我已先答。无常有二种。若着心戏论无常。是不名行般若。若以无著心不戏论无常为破常倒。又不自生着心。是名行般若。问曰。三藏中但有十智。此中何以有如实智。答曰。是故名大乘。大法能受小法。小不能受大。问曰。十智各各有体相。如实智有何等相。答曰。有人言。能知诸法实相。所谓如法性实际。是名如实智相。佛此中说如实智。唯是诸佛所得。何以故。烦恼未尽者。犹有无明故不能知如实。二乘及大菩萨。习未尽故不能遍知一切法一切种。不名如实智。但诸佛于一切无明尽无遗余。故能如实知。问曰。若除佛更无如实知者。二乘云何得涅槃。大菩萨得无生忍。答曰。如实智有二种。一有遍满具足。二者未具足。具足者佛。不具足者二乘及大菩萨。譬如闇室中为有所作故然灯。所为已办后来灯其明益增。黑闇有二分。一分初灯已除。第二分后灯所除。第二分闇与初灯明和合。若不尔第二灯则无所用。如是二乘及大菩萨智慧。虽已破无明。佛智慧所除无明分。是诸人所不能除。不得言初灯无照。如是不得言二乘及菩萨智慧是遍如实智。遍如实智是佛。但如实智二乘及菩萨所共。尔时须菩提问佛。世尊。若深般若中。义非义不可得。云何言菩萨为深般若义故行般若。佛答。贪欲等烦恼非义不应行者。诸法有三分。贪欲等诸烦恼是非义。六波罗蜜等诸善法是义。色等法无记故非义非非义。若人于烦恼及行烦恼者中生怨憎心。于六波罗蜜等诸善法及行善法者中生爱念心。于色等无记法及行无记法者中即生痴心。如经中说。凡人得受乐时生贪心。受苦时生嗔心。受不苦不乐时生痴心。是故说菩萨应作是念。欲贪等非义不应念以为非。如经广说。此中自说因缘。恶法善法无记法一如相无有义非义。如相无二无分别故。复次佛得道时不见一法若义若非义。诸法实相有佛无佛常住不作义非义。若如是知即是义。但破分别心故说义非义不应行。如是须菩提。菩萨应行是离义非义般若波罗蜜。须菩提复问。何缘故。般若非义非非义。佛答。一切法无作无起相故无所能作。云何般若波罗蜜作义以非义。须菩提复问。世尊。若一切诸佛及弟子。皆以无为法为义。佛何以说般若波罗蜜不能作义以非义。佛答。一切圣人虽以无为法为义。不作义以非义无增无损故。此中说譬喻。如虚空如不能益众生不能损众生。虚空无法故无有义以非义。何况虚空如。虚空虽无法。一切世间因虚空故得有所作。般若波罗蜜亦如是。虽无相无为而因般若能行五波罗蜜等一切佛道法。以着心故说般若无义非义。无著心故说第一实义。以世谛故说言义。第一义中无有义。复次般若有二种。一者有为二者无为。学有为般若能具足六波罗蜜住十地中。学无为般若灭一切烦恼习成佛道。今须菩提问佛。世尊。菩萨学无为般若得一切智。云何言无义。佛答。虽得萨婆若不以二法故。得分别取相者是名二法。复问。不二法能得不二法耶。佛答不也。何以故。不二法即是无为。无为无有得不得相。是无为法不可行故。复问。若以不二法不得。可以二法得不二法不。答言不也。何以故。二法虚诳不实故。云何行不实而得实法。复问。世尊。若不以二不以不二。云何当得一切种智。佛答。无所得即是得。此中二不二即是无分别皆无所得。是无所得不以有所得为行。虽行有为法。得是无所得心不取相故无所得。何以故。与空无相无作合行故

大智度论卷第八十四大智度论释道树品第七十一(卷八十五)

        圣者龙树菩萨造

        后秦龟兹国三藏鸠摩罗什译

【经】须菩提白佛言。世尊。是般若波罗蜜甚深。世尊。诸菩萨摩诃萨不得众生。而为众生求阿耨多罗三藐三菩提。是为甚难。世尊。譬如人欲于虚空中种树是为甚难。世尊。菩萨摩诃萨亦如是。为众生故求阿耨多罗三藐三菩提。众生亦不可得。佛告须菩提。如是如是。诸菩萨摩诃萨所为甚难。为众生故求阿耨多罗三藐三菩提。度着吾我颠倒众生。须菩提。譬如人种树。不识树根茎枝叶华果。而爱护溉灌。渐渐长大华叶果实成就皆得用之。如是须菩提。诸菩萨摩诃萨为众生故。求阿耨多罗三藐三菩提。渐渐行六波罗蜜得一切种智。成佛树以叶华果实益众生。须菩提。何等为叶益众生。因菩萨摩诃萨得离三恶道。是为叶益众生。何等为华益众生。因菩萨得生刹利大姓婆罗门大姓居士大家四天王天处乃至非有想非无想天处。是为华益众生。何等为果益众生。是菩萨得一切种智。令众生得须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道佛道。是众生渐渐以三乘法。于无余涅槃而般涅槃。是为果益众生。是菩萨摩诃萨不得众生实法而度众生。令离我颠倒着。作是念一切诸法中无众生我所。为众生求一切种智。是众生实不可得。须菩提白佛言。世尊。当知是菩萨为如佛。何以故。是菩萨因缘故。断一切地狱种一切畜生种一切饿鬼种。断一切诸难。断一切贫穷下贱道。断一切欲界色界无色界。佛言。如是如是。须菩提当知。是菩萨摩诃萨如佛。须菩提。若菩萨摩诃萨不发心求阿耨多罗三藐三菩提。世间则无过去未来现在诸佛。世间亦无辟支佛阿罗汉阿那含斯陀含须陀洹。三恶趣及三界亦无断时。须菩提。汝所说是菩萨摩诃萨当知如佛。如是如是。须菩提当知。是菩萨实如佛。何以故。以如故说如来。以如故说辟支佛阿罗汉一切贤圣。以如故说为色乃至识。以如故说一切法乃至有为性无为性。是诸如如实无异。以是故说名为如。诸菩萨摩诃萨学是如。得一切种智。得名如来。以是因缘故说菩萨摩诃萨当知如佛。以如相故。如是须菩提。菩萨摩诃萨应学如般若波罗蜜。菩萨学如般若波罗蜜。则能学一切法如。学一切法如则得具足一切法如。具足一切法如已。住一切法如得自在。住一切法如得自在已。善知一切众生根。善知一切众生根已。知一切众生根具足。知一切众生根具足已亦知一切众生业因缘。知一切众生业因缘已。得愿智具足。得愿智具足已净三世慧。净三世慧已饶益一切众生。饶益一切众生已净佛国土。净佛国土已得一切种智。得一切种智已转法轮。转法轮已安立众生于三乘。令入无余涅槃。如是须菩提。菩萨摩诃萨欲得一切功德自利利人。应发阿耨多罗三藐三菩提心。须菩提白佛言。世尊。是诸菩萨摩诃萨能如说行深般若波罗蜜。一切世间天及人阿修罗应当作礼。佛告须菩提。如是如是。是菩萨摩诃萨能如说行深般若波罗蜜。一切世间天及人阿修罗应当为作礼。世尊。是初发意菩萨摩诃萨为众生故。求阿耨多罗三藐三菩提得几所福德。佛告须菩提。若千国土中众生。皆发声闻辟支佛意。于汝意云何。其福多不。须菩提言。甚多无量。佛告须菩提。其福不如初发意菩萨摩诃萨。百倍千倍巨亿万倍。乃至算数譬喻所不能及。何以故。发声闻辟支佛意者。皆因菩萨出故。菩萨终不因声闻辟支佛出。二千世界三千大千世界中亦如是。置是三千大千世界中住声闻辟支佛地者。若三千大千世界中众生皆住干慧地。其福多不。须菩提言。甚多无量。佛言。不如初发意菩萨。百倍千倍巨亿万倍乃至算数譬喻所不能及。置是住干慧地众生。若三千大千世界中众生皆住性地八人地见地薄地离欲地已办地辟支佛地。是一切福德欲比初发意菩萨。百倍千倍巨亿万倍乃至算数譬喻所不能及。须菩提。若三千大千世界中初发意菩萨。不如入法位菩萨。百千万倍巨亿万倍。乃至算数譬喻所不能及。若三千大千世界中入法位菩萨。不如向佛道菩萨。百千万倍巨亿万倍。乃至算数譬喻所不能及。若三千大千世界中向佛道菩萨。不如佛功德。百千万倍巨亿万倍。乃至算数譬喻所不能及。须菩提白佛言。世尊。初发心菩萨摩诃萨当念何等法。佛言。应念一切种智。须菩提言。何等是一切种智。一切种智何等缘。何等增上。何等行。何等相。佛告须菩提。一切种智无所有。无想无念无生无示。如须菩提所问。一切种智何等缘何等增上何等行何等相。须菩提。一切种智无法缘念为增上。寂灭为行。无相为相。须菩提。是名一切种智缘增上行相。须菩提白佛言。世尊。但一切种智无法。色受想行识亦无法。内外法亦无法。四禅四无量心四无色定四念处四正勤四如意足五根五力七觉分八圣道分。空三昧无相三昧无作三昧。八背舍九次第定佛十力四无所畏四无碍智十八不共法。大慈大悲大喜大舍。初神通第二第三第四第五第六神通有为相无为相亦无法。佛告须菩提。色亦无法。乃至有为相无为相亦无法。须菩提言。世尊。何因缘故。一切种智无法。色无法乃至有为相无为相亦无法。佛言。一切种智自性无故。若法自性无是名无法。色乃至有为无为相亦如是。世尊。何因缘故诸法自性无。佛言。诸法和合因缘故。生法中无自性。若无自性是名无法。以是故。须菩提。菩萨摩诃萨当知一切法无性。何以故。一切法自性空故。以是故当知一切法无性。须菩提白佛言。世尊。若一切法无性。初发意菩萨以何等方便力能行檀波罗蜜。净佛世界成就众生。能行尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。行初禅乃至第四禅。行慈心乃至舍心行空处乃至非有想非无想处内空乃至无法有法空四念处乃至八圣道分空三昧无相三昧无作三昧八背舍九次第定佛十力四无所畏四无碍智十八不共法大慈大悲。能行一切种智。净佛世界成就众生。佛告须菩提。菩萨摩诃萨能学诸法无性。亦能净佛世界成就众生。知世界众生亦无性。即是方便力。须菩提。是菩萨摩诃萨行檀波罗蜜修学佛道。行尸罗波罗蜜。修学佛道。行羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜修学佛道。乃至行一切种智修学佛道。亦知佛道无性。是菩萨摩诃萨行六波罗蜜修学佛道。乃至未成就佛十力四无所畏四无碍智十八不共法大慈大悲一切种智。是为修学佛道。能具足佛道因缘具足佛道因缘已。用一念相应慧得一切种智。尔时一切烦恼习永尽以不生故。是时以佛眼观三千大千世界。无法尚不可得。何况有法。如是须菩提。菩萨摩诃萨应行无性般若波罗蜜。须菩提。是名菩萨摩诃萨方便力。无法尚不可得。何况有法。须菩提。是菩萨摩诃萨若布施时。布施无法尚不可得。何况有法。受者及菩萨心无法尚不知。何况有法。乃至一切种智得者得法得处无法尚不知。何况有法。何以故。一切法本性尔。非佛作非声闻辟支佛作。亦非余人作。一切法无作者故。须菩提白佛言。世尊。诸法诸法性离耶。佛言。如是如是。诸法诸法性离。世尊。若诸法诸法性离。云何离法能知离法若有若无。何以故。无法不能知无法。有法不能知有法。无法不能知有法。有法不能知无法。世尊。如是一切法无所有相。云何菩萨摩诃萨作是分别。是法若有若无。佛言。菩萨摩诃萨以世谛故。示众生若有若无。非以第一义。世尊。世谛第一义谛有异耶。须菩提。世谛第一义谛无异也。何以故。世谛如即是第一义谛如。以众生不知不见是如故。菩萨摩诃萨以世谛示若有若无。复次须菩提。众生于五受众中有着相故不知无所有。为是众生故。示若有若无。令知清净无所有。如是须菩提。菩萨摩诃萨应当作是行般若波罗蜜

【论】释曰。须菩提从佛闻无所得。即是得叹未曾有。白佛言。世尊。是般若甚深。如经中广说。以树为譬喻。叶华果实从薄转厚。如树叶荫热时凉乐。众生因菩萨道树荫。得离三恶道热苦。何以故。遮恶故。如华色好香净柔软众生因菩萨以布施持戒教化故受人天中福乐。如树果色香味力众生因菩萨故得须陀洹等诸圣道果。须菩提闻是欢喜言。是菩萨如佛无异。此中自说因缘。因菩萨故断地狱等恶道。佛可其意更说因缘。须菩提。若菩萨不发心求阿耨多罗三藐三菩提。乃至三界无断时。复次得诸法如故说名如来。乃至名须陀洹。以如故说色乃至无为性。是诸法如皆一无异。菩萨学是如必当得萨婆若。是故言如佛无异。不以我心贪贵菩萨故说言如佛。以得如故言如佛。是如在佛亦在菩萨。以一相故是名菩萨为如佛。离如更无有法不入如者。问曰。若以同如故名菩萨如佛乃至畜生中亦有是如。何以不名如佛。答曰。畜生虽亦有如因缘。未发故不能利益众生。不能行如至萨婆若故。如是须菩提。菩萨应学是如般若波罗蜜。菩萨学是如般若波罗蜜故。则能具足一切法如。具足名得诸法实相。能以种种门令众生得解。以得具足故于一切法如得自在。得是诸法如自在已。能善知众生根。能善知众生根故。能知众生诸根具足。诸根者信等五善根。三乘人各各有能分别。是人有是人无。是人得力是人不得力。具足者信等善根具足。如是人能出世间。信根得力则决定能受持不疑。精进力故虽未见法。一心求道不惜身命。不休不息念力故常忆师教。善法来听入恶法来不听入。如守门人。定力故摄心一处不动。以助智慧。智慧力故能如实观诸法相。得根有二种。一者在大心。人身中则成菩萨根。二者在小心。人身中则成小乘根。得是具足根则可度。或有菩萨见人虽得信等五根而不可度。由先世恶业罪重故。是故言知一切众生业因缘。欲知无数劫业因缘要得宿命通。既知已为众生说过去罪业因缘。众生以是过去罪故不畏。是故求愿智欲知三世事。既知已为众生说未来世罪业因缘当堕地狱。众生闻已则怀恐怖。恐怖已心伏易度。众生若欲知未来世福报因缘。为说已则欢喜可度。是故说知业因缘已愿智具足。愿智具足故得三世慧净通达无碍知过去善恶业。又知未来善恶果报。知现在众生诸根利钝。然后说法教化多所利益不虚。大利益众生故能净佛国土。净佛国土已得一切种智。得一切种智故转法轮。转法轮已以三乘安立众生入无余涅槃。如是利益皆从学如中来。是故佛说菩萨欲得一切功德。自利利人当发阿耨多罗三藐三菩提心。须菩提闻是菩萨功德甚多白佛言。世尊。菩萨能如说行般若波罗蜜一切世间应当作礼如经中广说。分别初发意菩萨功德。尔时须菩提知是甚深般若无忆想非初学所得。是故问佛。初发心菩萨应念何等法。佛答。应念一切种智。一切种智者即是阿耨多罗三藐三菩提。萨婆若佛法佛道皆是一切种智异名。问曰。佛何以答言念一切种智。答曰。初发意菩萨未得深智慧。既舍世间五欲乐故。佛教系心念萨婆若。应作是念虽舍小杂乐当得清净大乐。舍颠倒虚诳乐得实乐。舍系缚乐得解脱乐。舍独善乐得共一切众生善乐。得如是等利益故。佛教初发意者常念萨婆若。须菩提问世尊。是一切种智。为是有法为是无法。何等缘何等增上。何等行何等相。佛答须菩提。一切种智无所有。无所有名非法。无生无灭诸法如实缘亦无所有。念为增上寂灭为行无相为相。问曰。皆是毕竟空念。何以独言增上。答曰。诸法各各有力。佛智慧是毕竟空如法性实际无相所谓寂灭相。佛得一切种智。不复思惟无复难易。远近所念皆得故言念为增上须菩提问世尊。但一切种智无法。色等法亦无法。佛答。色等一切法亦是无法。自说因缘若法从因缘和合生即无自性。若法无自性即是空无法。以是因缘故当知一切法无所有性。须菩提问。初发心菩萨以何方便行檀波罗蜜乃至一切种智。净佛世界教化众生。佛答。无所有法性中学。入观亦能集诸功德。教化众生净佛世界。即是方便力。所谓有无二法能一时行故。所谓毕竟空集诸福德。是人行六波罗蜜时亦修治佛道。如佛心以毕竟空无所有法。行六波罗蜜乃至一切种智。是菩萨行是道。能具足佛十力四无所畏四无碍智十八不共法大慈大悲。行菩萨道时。具足是法坐道场。用一念相应慧得一切种智。如人夜失贯珠。电光暂现即时还得。故烦恼及习永尽更不复生。得佛已以佛眼观一切十方世界中一切物。尚不见无法。何况有法。毕竟空法能破颠倒。令菩萨成佛。是事尚不可得。何况凡夫颠倒有法。是故须菩提。当知一切法无所有相。是名菩萨方便。空尚不可得。何况有。须菩提。菩萨应行无所有般若波罗蜜。是菩萨行是无所有般若波罗蜜。若布施时即知布施物空无所有。受者及菩萨心亦无所有。乃至一切种智得者得法。得处无法尚不知。何况有法。得者菩萨。得法是阿耨多罗三藐三菩提。用得法是菩萨道。皆知是法无所有。何以故。一切法本性尔。不以智慧故异。非凡夫作亦非诸圣人作。一切法无作无作者故。须菩提意。若诸法都是无所有相。谁知是无所有。是故问佛。世尊诸法诸法性离。云何离法能知离法若有若无。何以故。无法不能知无法。有法不能知有法。无法不能知有法。有法不能知无法。世尊。如是一切法无所有相。云何菩萨作是分别是法若有若无。佛答。菩萨世俗故为众生说若有若无。非第一义。若有是实有无亦应有实。若有不实无云何应实。须菩提问。世俗第一义有异耶。若异破坏法性故。是故佛言不异。世俗如即是第一义如。众生不知是如故。以世俗为说若有若无。复次众生于五受阴中有所著。为是众生。离所有得无所有故。菩萨说无所有。世欲法故分别诸法。欲令众生知是无所有。如是须菩提。菩萨应学无所有般若波罗蜜

    大智度论释菩萨行品第七十二

【经】须菩提白佛言。世尊。世尊说菩萨行何等是菩萨行。佛言。菩萨行者。为阿耨多罗三藐三菩提行。是名菩萨行。世尊。云何菩萨摩诃萨为阿耨多罗三藐三菩提行。佛言。若菩萨摩诃萨行色空。行受想行识空。行眼空乃至意。行色空乃至法。行眼界空乃至意识界。行檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。行内空。行外空行内外空行空空行大空。行第一义空有为空无为空毕竟空无始空散空诸法空性空自相空无法空有法空无法有法空。行初禅第二第三第四禅。行慈悲喜舍。行无量虚空处无量识处无所有处非有想非无想处行四念处。行四正勤四如意足五根五力七觉分八圣道分。行空三昧行无相无作三昧。行八背舍九次第定。行佛十力。行四无所畏。行四无碍智。行十八不共法。行大慈大悲。行净佛国土。行成就众生行诸辩才。行文字入无文字。行诸陀罗尼门。行有为性。行无为性。如阿耨多罗三藐三菩提不作二。如是须菩提。菩萨摩诃萨行般若波罗蜜。名为阿耨多罗三藐三菩提行。须菩提白佛言。世尊。世尊说言佛何义故名佛。佛告须菩提。知诸法实义故名为佛。复次得诸法实相故名为佛。复次通达实义故名为佛。复次如实知一切法故名为佛。须菩提言。何义故名菩提。须菩提。空义是菩提义。如义法性义实际义是菩提义。复次须菩提。名相言说是菩提义须菩提。菩提实义不可坏不可分别是菩提义。复次须菩提。诸法实相不诳不异是菩提义。以是故名菩提。复次须菩提。是菩提诸佛所有故名菩提。复次须菩提。诸佛正遍知故名为菩提。须菩提白佛言。世尊。若菩萨摩诃萨为是菩提。行六波罗蜜。乃至行一切种智。于诸法何得何失何增何减何生何灭何垢何净。佛告须菩提。若菩萨摩诃萨行六波罗蜜。乃至行一切种智。于诸法无得无失无增无减无生无灭无垢无净。何以故。菩萨摩诃萨行般若波罗蜜。不为得失增减生灭净垢故出。须菩提白佛言。世尊。若菩萨摩诃萨行般若波罗蜜不为得失。乃至不为净垢故出。菩萨摩诃萨云何行般若波罗蜜。能取檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。云何行内空乃至无法有法空。云何行禅无量心无色定。云何行四念处乃至八圣道分。云何行空无相无作解脱门。云何行佛十力四无所畏四无碍智十八不共法大慈大悲。云何行菩萨十地。云何过声闻辟支佛地入菩萨位中。佛告须菩提。菩萨摩诃萨行般若波罗蜜时。不以二法故。行檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。不以二法乃至行一切种智。须菩提言。世尊。若菩萨摩诃萨不以二法故行檀波罗蜜乃至般若波罗蜜。不以二法故乃至行一切种智。菩萨从初发意乃至后意云何善根增益。佛告须菩提。若行二法者善根不得增益。何以故。一切凡夫皆依二法不得增益善根。菩萨摩诃萨行不二法。从初发意乃至后意。于其中间增益善根。以是故菩萨摩诃萨一切世间天及人阿修罗无能伏。无能坏其善根令堕声闻辟支佛地。及诸众恶不善法不能制菩萨令不能行檀波罗蜜增益善根。乃至般若波罗蜜亦如是。须菩提。菩萨摩诃萨应如是行般若波罗蜜。世尊。菩萨摩诃萨为善根故。行般若波罗蜜不。佛言。不也须菩提。菩萨摩诃萨亦不为善根故行般若波罗蜜。亦不为非善根故行般若波罗蜜。何以故。须菩提。菩萨摩诃萨法。未供养诸佛。未具足善根。未得真知识。不能得一切种智。须菩提言。世尊。云何菩萨摩诃萨供养诸佛具足善根。得真知识。能得一切种智。佛告须菩提。菩萨摩诃萨从初发意供养诸佛。诸佛所说十二部经。修妒路乃至忧波提舍。是菩萨闻持诵利心观了达。了达故得陀罗尼。得陀罗尼故能起无碍智。起无碍智故所生处乃至萨婆若终不忘失。是法亦于诸佛所种善根。为是善根所护。终不堕恶道诸难。以是善根因缘故。得深心清净。得深心清净故。能净佛国土成就众生。以善根所护故。常不离真知识。所谓诸佛诸菩萨摩诃萨及诸声闻。能赞叹佛法众者。如是须菩提。菩萨摩诃萨应供养诸佛种善根亲近善知识

【论】释曰。上品中。须菩提问。佛经常说般若波罗蜜。何以故。名般若波罗蜜。佛种种因缘答。因此事故此品中复问。世尊经常说菩萨行。何等是菩萨行。是故须菩提问菩萨行。问曰。若般若波罗蜜中摄一切法。又般若即是菩萨行。何以故更问。答曰。一切菩萨道名菩萨行。悉遍知诸法实相智慧名般若波罗蜜。是为异。若般若经菩萨行等共相摄无异。复次有人言。菩萨行者菩萨身口意业诸有所作。皆名菩萨行。以是事故须菩提但欲分别菩萨正行故问。是故佛答。菩萨行者为阿耨多罗三藐三菩提。诸善行是名菩萨正行。菩萨不善无记及着心行善法非菩萨行。但以悲心故及空智慧。为阿耨多罗三藐三菩提行。是名菩萨行。何等是清净行。所谓色空行。受想行识空行。乃至有为性无为性空行。于是诸法不分别是空是实乃至是有为是无为。如阿耨多罗三藐三菩提。灭戏论不二相。是名菩萨行。无能坏者亦无过失。须菩提闻是菩萨行已欢喜问。菩萨行果报得作佛。经常言佛。何等是佛义。佛答知诸法实义故名为佛。问曰。若尔者阿罗汉辟支佛及大菩萨。是人亦知诸法实义。何故不名为佛。答曰。上已说然灯喻。于凡夫为实于佛不为实。以烦恼习所覆故不名为实。不能得一切种智断一切法中疑悔故不名正智。实义如上分别。问曰。知诸法实义。得诸法实相。通达实义一切法如实知。是四有何异。答曰。有人言义无异名字异。有人言。有差别。义名诸法实相不生不灭法相常住如涅槃。知是义故名为佛。是义中常觉悟无错谬。于是义以种种名相法令众生解第一实义。是故四无碍中别说义无碍法无碍。有人虽得诸法实义不能通达。有二因缘故。一者烦恼未尽。二者未得一切智故。如须陀洹斯陀含阿那含。未断烦恼故不能通达。阿罗汉辟支佛大菩萨。烦恼虽尽未得一切种智故不能通达。是故说通达实义故名为佛。如实知一切法者。总上三事亦义亦法。一切法若有若无。种种了了知故如一切种智义中说。亦知寂灭相亦知有为相。复次菩提名智佛名智者。得是智故名为智者。须菩提问世尊。何等是菩提。佛答。空如法性实际名为菩提。空三昧相应实相智慧。缘如法性实际。菩提名实智慧。三学道未断烦恼。虽有智慧不名为菩提。三无学人无明永尽无余故。智慧名菩提。二无学人不得一切智正遍知诸法故。不得名阿耨多罗三藐三菩提。唯佛一人智慧。名阿耨多罗三藐三菩提。复次名相语言文字故名菩提。菩提实义不可分别破坏。复次菩提是如不异常不虚诳。何以故。一切众生智慧转转有胜。至佛更无胜者。诸法亦转转有胜。先者虚妄后者真实。至菩提更无实者。是故菩提名为实。复次如得菩提故名为佛。今以佛得故名菩提。复次有人言。尽智知生永尽是名菩提。有人言。尽智无生智名菩提。有人言。无碍解脱名菩提。何以故。得是解脱于一切法皆通达。有人言。四无碍智是菩提。何以故。佛知诸法实相是义无碍。知诸法名相分别。是名法无碍。分别种种语言使众生得解。是名辞无碍。有所说法教化无穷无尽。是名乐说无碍。以四无碍具足利益众生故名菩提。有人言。佛十力四无所畏四无碍智十八不共法大慈大悲一切种智。如是无量佛法尽名菩提。何以故。以智慧大故诸法皆名菩提。有人言。真菩提名佛。无漏十智。是十智相应受想行识身口业及心不相应诸行皆名菩提。共缘共生共相佐助故皆名菩提。复有人言。菩提义无量无边。唯佛能遍知。余人知其少分。譬如转轮圣王宝藏中诸宝无能分别知其价者。圣王出宝赐人。正可知其所得者。此中须菩提问佛菩提相已更问。世尊。若菩提毕竟空不坏相。菩萨行六波罗蜜诸法增益何等善根。佛答。若菩萨行是菩提实相。于一切法无所增益。何况善根。何以故。般若波罗蜜不为得失乃至垢净故。出毕竟清净故。佛可其意。复更问若无增减。云何菩萨行般若取檀波罗蜜等诸菩萨行。佛答。菩萨虽行是法。不以二法故行毕竟空和合共行。是故不应难。复问世尊。若菩萨不行二法。云何从初发意乃至后心增长善根。佛答。若人行二法。即是颠倒不能增长善根。如人梦中虽大得财竟无所得。觉已所得多少真名为得。佛语须菩提。一切凡人皆着二法故不能增益善根。菩萨行诸法实相所谓不二法。从初发心来乃至后心。增益善根无有错谬。是故菩萨一切天人阿修罗无能坏其善根令堕二乘。及余众恶亦不能坏。余恶者悭贪等烦恼破檀波罗蜜诸善法等。复问世尊。菩萨为善根故行般若耶。佛答。不为善不为不善故行般若。问曰。不为不善根故行般若可尔。云何不为善根故行。答曰。此中佛意贵阿耨多罗三藐三菩提故。虽行诸善根为办事故行。不以为贵。如筏喻经说。善法尚应舍何况不善法。善根是助佛道法。若人不为筏故渡。为到彼岸故渡。此中佛说因缘。菩萨未供养诸佛。未得真知识。不能得一切种智。是故虽种善根不以为贵。但为阿耨多罗三藐三菩提。故须菩提言。云何菩萨虽不为善根。而能供养诸佛。乃至得一切种智。佛答。菩萨从初发心已来供养诸佛。如经中说。供养佛大故但说佛。当知已供养辟支佛乃至住干慧地。凡人为闻法故从其闻说十二部经。以不能常得师故皆当受持。以喜忘故诵读令利。心观者常系心经卷次第忆念。先以语言宣义。后得了达即得陀罗尼。陀罗尼有二种。一者闻持陀罗尼。二者得诸法实相陀罗尼。读诵修习常念故得闻持陀罗尼。通达义故得实相陀罗尼。住是二陀罗尼门中能生无碍智。为众生说法故具足四无碍智。问曰。若菩萨有无碍智与佛何异。答曰。无碍有二种。一真无碍。二名字无碍。此中除佛无碍。余者随菩萨所得无碍。是菩萨读经等因缘故。所生之处乃至得一切种智终不忘失。何以故。深入读诵诸法故烦恼折薄。为善根所护故终不堕恶道诸难。如盲人为有目者所将护故终不坠落沟壑。集善根福德故得深心清净。深心清净者慈爱一切众生。虽怨贼中人亦不加恶。所谓夺命等。复次智慧福德大集故。烦恼微少不能遍覆菩萨善心。复次深心者于众生中得慈悲心不舍心救度心。于诸法中得无常苦空无我毕竟空心。乃至佛不生佛想涅槃想。是名深心清净。深心清净故能教化众生。何以故。是烦恼薄故。不起高心我心嗔心故。众生爱乐信受其语教化众生。教化众生故得净佛世界。如毗摩罗诘佛国品中说众生净故世界清净。为善根所护故终不离善知识。善知识者诸佛大菩萨阿罗汉。略说善知识相能赞叹三宝者如是。菩萨应供养诸佛种善根亲近善知识。何以故。如病人应求良医药草。佛为良医。诸善根为药草。瞻病人为善知识。病者具此三事故病得除差。菩萨亦如是。具此二事灭诸烦恼故能利益众生

    大智度论释种善根品第七十三

【经】须菩提白佛言。世尊。菩萨摩诃萨若不供养诸佛不具足善根。不得真知识。当得萨婆若不。佛告须菩提。菩萨摩诃萨供养诸佛种善根。得真知识。一切种智尚难得。何况不供养诸佛不种善根不得真知识。须菩提白佛言。世尊。菩萨摩诃萨供养诸佛种善根得真知识。何以故。难得一切种智。佛告须菩提。是菩萨摩诃萨远离方便力。不从诸佛闻方便力。所种善根不具足。不常随善知识教。世尊。何等是方便力。菩萨摩诃萨行是方便力得一切种智。佛言。菩萨摩诃萨从初发意行檀波罗蜜。应萨婆若念。布施佛若辟支佛若声闻若人若非人。是时不生布施想受者想。何以故。观一切法自相空无生无定相无所转入诸法实相。所谓一切法无作无起相。菩萨以是方便力故增益善根。增益善根故行檀波罗蜜。净佛国土成就众生。布施不受世间果报。但欲救度一切众生故行檀波罗蜜。复次须菩提。菩萨摩诃萨从初发意行尸罗波罗蜜。应萨婆若念持戒时。不堕淫怒痴中。亦不堕诸烦恼缠缚及诸不善。破道法若悭贪破戒嗔恚懈怠乱意愚痴慢大慢慢慢我慢增上慢不如慢邪慢。若声闻心若辟支佛心。何以故。是菩萨摩诃萨观一切法自相空无生无定相无所转入诸法实相。所谓一切法无作无起相。菩萨成就是方便力故增益善根。增益善根故行尸罗波罗蜜。净佛国土成就众生。持戒不受世间果报。但欲救度一切众生故。行尸罗波罗蜜。复次须菩提。菩萨摩诃萨从初发意行羼提波罗蜜。应萨婆若念。方便力成就故。行见谛道思惟道。亦不取须陀洹果斯陀含阿那含阿罗汉果。何以故。是菩萨摩诃萨知诸法自相空无生无定相无所转。虽行是助道法。而过声闻辟支佛地。须菩提。是名菩萨无生法忍。复次须菩提。菩萨摩诃萨从初发意行毗梨耶波罗蜜。入初禅乃至入第四禅。入四无量心四无色定。虽出入诸禅。而不受果报。何以故。是菩萨成就是方便力故。知诸禅定自相空无生无定相无所转。净佛国土成就众生。精进不受世间果报。但欲救度一切众生故。行毗梨耶波罗蜜。复次须菩提。菩萨摩诃萨从初发意行禅波罗蜜应萨婆若念。入八背舍九次第定。亦不证须陀洹果。乃至不证阿罗汉果。何以故。是菩萨摩诃萨知诸法自相空无生无定相无所转。复次须菩提。菩萨摩诃萨从初发意行般若波罗蜜。学佛十力四无所畏四无碍智十八不共法大慈大悲。乃至未得一切种智。未净佛国土未成就众生。于其中间应如是行。何以故。是菩萨摩诃萨知诸法自相空无生无定相无所转。须菩提。是菩萨摩诃萨应如是行般若波罗蜜不受果报

【论】问曰。须菩提何以故作是粗问。不供养诸佛。不具足善根。不得真知识。当得萨婆若不。答曰。有人言。若一切诸法无所有性毕竟空。毕竟空中种善根不种善根等无异。若尔者可不供养诸佛不种善根不得真知识得萨婆若耶。复有人疑言。得萨婆若更有种种门。可不须种善根等。是故问佛。佛答若供养诸佛种善根。得真知识尚难得。何况不。须菩提问。以毕竟空中无有福以非福。何以但以福德故得。佛答。以世谛中有福故得。须菩提为众生着无所有故问。佛以不著有法答。所谓精进修福尚不可得。何况不修福。如受乞食道人。至一聚落从一家至一家乞食不得。见一饿狗饥卧。以杖打之言。汝畜生无智。我种种因缘家家求食尚不能得。何况汝卧而望得。须菩提问世尊。有是供养诸佛等因缘。何故不得其果报。佛答离方便故。方便者所谓般若波罗蜜。虽见诸佛色身不以智慧眼见法身。虽少种善根而不具足。虽得善知识不亲近咨受。又佛自说因缘。所谓菩萨从初发意。以有无心行檀波罗蜜。有心者所谓应萨婆若心布施。念诸佛种种无量功德怜愍众生故布施。无心者若施佛乃至凡人不生三想。所谓施者受者财物。何以故。施物等一切法自相空。从本已来常不生无定相。若一若异若常若无常等。是法自相空故不可转。安住如中故如是观即入诸法实相。所谓无作无起相。一切法无所能作。不生高心无所悕望。如是方便力故能增益善根。离不善根教化众生净佛世界。布施若多若少不受世间果报。但欲救度一切众生故。菩萨布施众生有量有限。作是念我先世不行深福德。今不能广施众生。我今当深实多行檀波罗蜜。得是果报已能具足利益。广施无量众生。若今世利若后世利若道德利。无如是方便。菩萨虽供养诸佛种善根得真知识尚不得。何况不供养。余五波罗蜜亦如是

大智度论卷第八十五大智度论释遍学品第七十四(卷八十六)

        圣者龙树菩萨造

        后秦龟兹国三藏鸠摩罗什译

【经】尔时须菩提白佛言。世尊。是菩萨摩诃萨大智慧成就行是深法。亦不受果报。佛告须菩提。如是如是。菩萨摩诃萨大智慧成就行是深般若波罗蜜。亦不受果报。何以故。是菩萨摩诃萨诸法性中不动故。世尊。何等诸法性中不动。佛言。于无所有性中不动。复次菩萨摩诃萨色性中不动。受想行识性中不动。檀波罗蜜性中不动。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜性中不动。四禅性中不动。四无量性中不动。四无色定性中不动。四念处性中不动。乃至八圣道分性中不动。空三昧无相无作三昧。乃至大慈大悲性中不动。何以故。须菩提。是诸法性即是无所有。须菩提。以无所有法不能得所有法。须菩提言。世尊。所有法能得所有法不。佛言不也。世尊。所有法能得无所有法不。佛言不也。世尊。无所有法能得无所有法不。佛言不也。世尊。若无所有不能得所有。所有不能得所有。所有不能得无所有。无所有不能得无所有。将无世尊不得道耶。佛言。有得不以此四句。世尊。云何有得。佛言。非所有非无所有无诸戏论。是名得道。须菩提白佛言。世尊。何等是菩萨摩诃萨戏论。佛告须菩提。菩萨摩诃萨观色若常若无常。是为戏论。观受想行识若常若无常。是为戏论。观色若苦若乐受想行识若苦若乐。是为戏论。观色若我若非我受想行识若我若非我色若寂灭若不寂灭受想行识若寂灭若不寂灭。是为戏论。苦圣谛应见。集圣谛应断。灭圣谛应证。道圣谛应修。是为戏论。应修四禅四无量心四无色定。是为戏论。应修四念处四正勤四如意足五根五力七觉分八圣道分是为戏论。应修空解脱门无相解脱门无作解脱门。是为戏论。应修八背舍九次第定。是为戏论。我当过须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道。是为戏论。我当具足菩萨十地。是为戏论。我当入菩萨位。是为戏论。我当净佛国土。是为戏论。我当成就众生。是为戏论。我当生佛十力四无所畏四无碍智十八不共法。是为戏论。我当得一切种智。是为戏论。我当断一切烦恼习。是为戏论。须菩提。是菩萨摩诃萨行般若波罗蜜时。色若常若无常不可戏论故不应戏论。受想行识若常若无常不可戏论故不应戏论。乃至一切种智不可戏论故不应戏论。何以故。性不戏论性。无性不戏论无性。离性无性更无法可得。所谓戏论者。戏论法戏论处。以是故须菩提。色无戏论。受想行识乃至一切种智无戏论。如是须菩提。菩萨摩诃萨应行无戏论般若波罗蜜。须菩提白佛言。世尊。云何色不可戏论。乃至一切种智不可戏论。佛告须菩提。色性无。乃至一切种智性无。须菩提。若法性无即是无戏论。以是故色不可戏论。乃至一切种智不可戏论。须菩提。若菩萨摩诃萨能如是行无戏论般若波罗蜜。是时得入菩萨位。须菩提白佛言。世尊。若诸法无有性菩萨。行何等道入菩萨位。为用声闻道。为用辟支佛道。为用佛道。佛告须菩提。不以声闻道。不以辟支佛道。不以佛道得入菩萨位。菩萨摩诃萨遍学诸道得入菩萨位。须菩提。譬如八人先学诸道然后入正位。未得果而先生果道。菩萨亦如是。先遍学诸道然后入菩萨位。亦未得一切种智而先生金刚三昧。尔时以一念相应慧得一切种智。须菩提白佛言。世尊。若菩萨摩诃萨遍学诸道入菩萨位者。八人向须陀洹得须陀洹。向斯陀含得斯陀含。向阿那含得阿那含。向阿罗汉得阿罗汉辟支佛道佛道。是诸道各各异。世尊。若菩萨摩诃萨遍学诸道。然后入菩萨位者。是菩萨若生八道。应作八人生见道。应作须陀洹生思惟道。应作斯陀含作阿那含作阿罗汉。若生辟支佛道作辟支佛。世尊。若菩萨摩诃萨作八人。然后入菩萨位。无有是处。不入菩萨位得一切种智。亦无是处。作须陀洹乃至作辟支佛。然后入菩萨位。亦无是处。不入菩萨位得一切种智。亦无是处。世尊。我云何当知菩萨摩诃萨遍学诸道得入菩萨位。佛告须菩提。如是如是。若菩萨摩诃萨作八人。得须陀洹果。乃至得阿罗汉果。得辟支佛道。然后入菩萨位。无有是处。不入菩萨位当得一切种智。无有是处。须菩提。若菩萨摩诃萨从初发意行六波罗蜜时。以智观过八地。何等八地。干慧地性地八人地见地薄地离欲地已办地辟支佛地。以道种智入菩萨位。入菩萨位已。以一切种智断一切烦恼习。须菩提。是八人若智若断。是菩萨无生法忍。须陀洹若智若断。斯陀含若智若断。阿那含若智若断。阿罗汉若智若断。辟支佛若智若断。皆是菩萨忍。菩萨学如是声闻辟支佛道。以道种智入菩萨位。入菩萨位已。以一切种智断一切烦恼习得佛道。如是须菩提。菩萨摩诃萨遍学诸道。具足应得阿耨多罗三藐三菩提。得阿耨多罗三藐三菩提已。以果饶益众生。须菩提白佛言。世尊。世尊所说道。声闻道辟支佛道佛道何等是菩萨道种智。佛告须菩提。菩萨摩诃萨应生一切道种净智。须菩提。何等是道种净智。若诸法相貌所可显示法。菩萨应正知。正知已为他演说开示。令诸众生得解。是菩萨摩诃萨应解一切音声语言。以是音声说法遍满三千大千世界如响相。以是故须菩提。菩萨摩诃萨应先具足学一切道。道智具足已应分别知众生深心。所谓地狱众生地狱道地狱因地狱果。应知应障。畜生饿鬼道畜生饿鬼因畜生饿鬼果。应知应障。诸龙鬼神犍闼婆紧那罗摩睺罗伽阿修罗道因果应知应障。人道因果应知。诸天道因果应知。四天王天三十三天夜摩天兜率陀天化乐天他化自在天。梵天光音天遍净天广果天无想天阿婆罗呵天无热天易见天喜见天阿迦尼吒天道因果应知。无边虚空处无边识处无所有处非有想非无想处道因果应知。四念处四正勤四如意足五根五力七觉分八圣道分因果应知。空解脱门无相解脱门无作解脱门。佛十力四无所畏四无碍智。十八不共法大慈大悲因果应知。菩萨以是道令众生入须陀洹道乃至阿罗汉辟支佛道。乃至阿耨多罗三藐三菩提道。须菩提。是名菩萨摩诃萨净道种智。菩萨学是道种智已。入众生深心相。入已随众生心如应说法所言不虚。何以故。是菩萨摩诃萨善知众生根相。知一切众生心心数法生死所趣。须菩提。菩萨摩诃萨如是应行道般若波罗蜜。何以故。一切诸善助道法皆入般若波罗蜜中。诸菩萨摩诃萨声闻辟支佛所应行。须菩提白佛言。世尊。若四念处乃至阿耨多罗三藐三菩提。是一切法皆不合不散。无色无形无对一相。所谓无相。世尊。云何是助道法能取阿耨多罗三藐三菩提。世尊。是不合不散无色无形无对一相。所谓无相法。无所取无所舍。譬如虚空无取无舍。佛言。如是如是。须菩提。诸法自相空无所取无所舍。须菩提。有众生不知诸法自相空。为是众生故显示助道法。能至阿耨多罗三藐三菩提。复次须菩提。所有色受想行识。所有檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。所有内空外空乃至无法有法空。初禅乃至非有想非无想处四处念。乃至八圣道分三解脱门八背舍九次第定。佛十力四无所畏四无碍智。十八不共法大慈大悲一切种智等诸法。于是圣法中皆不合不散。无色无形无对一相。所谓无相。以世俗法故为众生说令解。非以第一义。须菩提。于是一切法中菩萨摩诃萨以智见如法应学。学已分别诸法应用不应用。须菩提言。世尊。何等法菩萨分别已应用不应用。佛言。声闻辟支佛法。分别知不应用。一切种智分别知应用。如是须菩提。菩萨摩诃萨于是圣法中应学般若波罗蜜。须菩提白佛言。世尊。何以故说名圣法。何等是圣法。佛告须菩提。诸声闻辟支佛法诸菩萨摩诃萨及诸佛。于欲嗔痴不合不散。身见戒取疑不合不散。欲染嗔恚不合不散。色染无色染掉慢无明不合不散。初禅乃至第四禅不合不散。慈悲喜舍虚空处。乃至非有想非无想处不合不散。四念处乃至八圣道分不合不散。内空乃至大悲有为性无为性不合不散。何以故。是一切法皆无色无形无对一相。所谓无相。无色法与无色法不合不散。无形法与无形法不合不散。无对法与无对法不合不散。一相法与一相法不合不散。无相法与无相法不合不散。须菩提。是无色无形无对一相。所谓无相。般若波罗蜜诸菩萨摩诃萨应学。学已不得诸法相。须菩提白佛言。世尊。菩萨摩诃萨不学色相耶。不学受想行识相耶。不学眼相乃至意相。不学色相乃至法相。不学地种相乃至识种相。不学檀波罗蜜相尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜相。不学内空乃至无法有法空相。不学初禅相乃至第四禅相。不学慈相乃至舍相不学无边空相乃至非有想非无想相。不学四念处相乃至八圣道分相。不学空三昧相无相无作三昧相。不学八背舍九次第定相。不学佛十力相四无所畏四无碍智相十八不共法相大慈大悲相。不学苦圣谛相集灭道圣谛相。不学逆顺十二因缘相。不学有为性相无为性相耶。世尊。若不学诸法相。菩萨摩诃萨云何学诸法相若有为若无为。学已过声闻辟支佛地若不过声闻辟支佛地。云何入菩萨位。若不入菩萨位。云何当得一切种智。若不得一切种智。云何当转法轮。若不转法轮。云何以三乘度众生生死。佛告须菩提。若诸法实有相菩萨应学是相。须菩提。以一切法实无有相无色无形无对一相。所谓无相。以是故。须菩提。菩萨摩诃萨不学相不学无相。何以故。有佛无佛诸法一相性常住。须菩提白佛言。世尊。若一切法非有相非无相。菩萨摩诃萨云何修般若波罗蜜。若不修般若波罗蜜。不能过声闻辟支佛地。若不过声闻辟支佛地。不能入菩萨位。若不入菩萨位。不得无生法忍。若不得无生法忍。不能得诸菩萨神通。若不得菩萨神通。不能净佛国土成就众生。若不净佛国土成就众生。不能得一切种智。若不得一切种智。不能转法轮。若不转法轮。不能令众生得须陀洹果斯陀含阿那含阿罗汉果辟支佛道。不能令得阿耨多罗三藐三菩提。亦不能令众生得布施福。亦不能令得持戒修定福。佛告须菩提。如是如是。诸法无相非一相非异相。若修无相是修般若波罗蜜。须菩提言。世尊。云何修无相是修般若波罗蜜。佛言。修诸法坏。是修般若波罗蜜。世尊。云何修诸法坏。是修般若波罗蜜。佛言。修色坏是修般若波罗蜜。修受想行识坏。是修般若波罗蜜。修眼坏耳鼻舌身意法坏。是修般若波罗蜜。修色法坏声香味触法坏。是修般若波罗蜜。修不净观坏。是修般若波罗蜜。修初禅坏第二第三第四禅坏。是修般若波罗蜜。修慈悲喜舍坏。是修般若波罗蜜。修无边空处无边识处无所有处非有想非无想处坏。是修般若波罗蜜。修念佛念法念僧念戒念舍念天念灭念安般坏。是修般若波罗蜜。修无常相苦相无我相空相集相因相生相缘相闭相灭相妙相出相道相正相迹相离相坏。是修般若波罗蜜。修十二因缘坏。修我相众生相寿命相坏。乃至修知者见者相坏。是修般若波罗蜜。修常相乐相净相我相坏。是修般若波罗蜜。修四念处乃至八圣道分坏。是修般若波罗蜜。修空三昧无相三昧无作三昧坏。是修般若波罗蜜。修八背舍九次第定坏。是修般若波罗蜜。修有觉有观三昧无觉有观三昧无觉无观三昧坏。是修般若波罗蜜。修苦圣谛集圣谛灭圣谛道圣谛坏。是修般若波罗蜜。修苦智集智灭智道智坏。是修般若波罗蜜。修尽智无生智坏。是修般若波罗蜜。修法智比智世智他心智坏。是修般若波罗蜜。修檀波罗蜜坏。是修般若波罗蜜。修尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜坏。是修般若波罗蜜。修内空外空内外空空空大空第一义空有为空无为空毕竟空无始空散空性空诸法空自相空不可得空无法空有法空无法有法空坏。是修般若波罗蜜。修佛十力四无所畏四无碍智十八不共法坏。是修般若波罗蜜。修须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道坏。是修般若波罗蜜。修一切智坏。是修般若波罗蜜。修断一切烦恼习坏。是修般若波罗蜜。须菩提白佛言。世尊。云何名修色坏乃至修断一切烦恼习坏。是修般若波罗蜜。佛告须菩提。菩萨摩诃萨行般若波罗蜜时。不念有色法。是修般若波罗蜜。不念有受想行识。乃至不念有坏一切烦恼习法。是为修般若波罗蜜。何以故。有法念者不修般若波罗蜜。须菩提。有法念者不修檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。何以故。须菩提。是人着法不行檀波罗蜜乃至般若波罗蜜。如是著者。无有解脱无有道无有涅槃。有法念者。不修四念处四正勤四如意足五根五力七觉分八圣道分。不修空三昧。乃至不修一切种智。何以故。是人着法故。须菩提白佛言。世尊。何等是有法。何等是无法。佛告须菩提。二者是有法。不二者是无法。世尊。何等是二。佛言。色相是二。受想行识相是二。眼相乃至意相是二。色相乃至法相是二。檀波罗蜜乃至佛相。阿耨多罗三藐三菩提相。有为无为性相是二。须菩提。一切相皆是二。一切二皆是有法。适有法便有生死。适有生死不得离生老病死忧悲苦恼。以是因缘故。须菩提当知。二相者。无有檀波罗蜜乃至般若波罗蜜。无有道无有果。乃至无有顺忍。何况见色相。乃至见一切种智相。若无修道云何得须陀洹果乃至阿罗汉果辟支佛道阿耨多罗三藐三菩提及断一切烦恼习

【论】释曰。佛说菩萨行六波罗蜜不受世间果报。须菩提叹未曾有。白佛言。世尊。是菩萨大智慧成就。行是深法能作因而不受果。是菩萨为大利故不受小报。佛可其意已更自说因缘。所谓菩萨于诸法性中不动。诸法性者无所有毕竟空如法性实际。菩萨定心安住是中不动。须菩提问世尊。何等性中不动。佛答。色性中不动。乃至大慈悲等性中不动。何以故。是诸法性众因缘生故。不自在无定相。无定相故无所有。诸法者所谓色等法。因是色等法故说无为。是故无为法。亦无所有。何以故。不可以无所有法得所有法。须菩提言。若无所有不能得所有者。岂可以所有法得所有法耶。佛答不。何以故。无所有法一切圣人所称赞。所住处尚不能有所得。何况所有法。所有法得无所有不。佛言不。何以故。所有无所有二俱有过故言不。可以无所有得无所有不。佛言不。何以故。所有法有生相住相。以虚诳故尚无所得。何况无所有。从本已来毕竟空而有所得。此中须菩提更问世尊。若以四句皆不得。将无道无得果耶。佛答。实有得道法。但不以是四句。何以故。四句有如上失故。若离是四句戏论即是道。复问。世尊何等是菩萨戏论相。佛答色等若常若无常是菩萨戏论。何以故。若常则不生不灭。无罪福好丑。无常亦不然。何以故。因常说无常。常既不可得。何况无常。复次若无常定是色等实相。亦不应有业因缘果报。何以故。色等诸法念念灭失故。若业因缘果报灭则不名无常相。如是等种种因缘故。无常非是色等实相。如先破无常中说。乃至作是念。我当断一切烦恼习。是为戏论。色等诸法不可戏论。而凡夫人戏论诸法。菩萨于不可戏论随法不戏论。何以故。自性不能戏论自性。所以者何。性从因缘生故但有假名。云何能戏论。若性不能戏论。何况无性离性。无性更无第三法可戏论。所谓戏论者戏论法戏论处。是法皆不可得。须菩提。色等法是不可戏论相。如是菩萨应行无戏论般若波罗蜜。复次佛自说不可戏论因缘。色等法无性。若法无性即是不可戏论。若菩萨能行是不可戏论般若。便得入菩萨位。须菩提。意无戏论是三乘道。菩萨以何道入无戏论菩萨位。佛答皆言不。何以故。菩萨大乘人故不应用二乘道。六波罗蜜未具足故不能用佛道。此中佛自说因缘。菩萨应遍学诸道入菩萨位。此中说譬喻。如见谛道中八人先时遍学诸道入正位而未得须陀洹果。菩萨亦如是。先遍学诸道入菩萨位。而未得一切种智果。若菩萨住金刚三昧。以一念相应慧得一切种智果。须菩提问世尊。若菩萨遍学诸道。然后入菩萨位。是诸道各各异。若菩萨遍学是诸道。若生八道即是八人。乃至生辟支佛道即是辟支佛。世尊。若菩萨作八人。乃至作辟支佛。然后入菩萨位。无有是处。若不入菩萨位。得一切种智。亦无有是处。我当云何知菩萨遍学诸道入菩萨位。佛可其意已更自说因缘。菩萨初发意行六波罗蜜时。以智见观入八地直过。如人亲亲系狱故入而看之亦不与同着杻械。菩萨欲具足道种智故入菩萨位。遍观诸道入菩萨位。入菩萨位已。得一切种智断烦恼习。佛示须菩提。二乘人于诸佛菩萨智慧得少气分。是故八人若智若断。乃至辟支佛若智若断。皆是菩萨无生法忍智。名学人八智。无学或九或十断。名断十种结使。所谓上下分十结。须陀洹斯陀含略说断三结。广说断八十八结。阿那含略说断五下分结。广说断九十二。阿罗汉略说三漏尽。广说断一切烦恼。是名智断。智断皆是菩萨忍。声闻人以四谛得道。菩萨以一谛入道。佛说是四谛皆是一谛。分别故有四。是四谛二乘智断皆在一谛中。菩萨先住柔顺忍中。学无生无灭。亦非无生非无灭。离有见无见有无见非有非无见等。灭诸戏论得无生忍。无生忍者佛后品中自说。乃至作佛常不生恶心。是故名无生忍。论者言得是忍观一切法毕竟空。断缘心心数不生。是名无生忍。又复言能过声闻辟支佛智慧名无生忍。声闻辟支佛智慧。观色等五众生。灭心厌离欲得解脱。菩萨以大福德智慧观生灭时。心不怖畏如小乘人。菩萨以慧眼求生灭。实定相不可得。如先破生品中说。但以肉眼粗心见有无常生灭。凡夫人于诸法中着常见。是所著法还归无常。众生得忧悲苦恼。是故佛说欲离忧苦莫观常相。是无常破常颠倒故。不为着无常故说。是故菩萨舍生灭观。入不生不灭中。问曰。若入不生不灭。不生不灭即复是常。云何得离常颠倒。答曰如无常有二种。一者破常颠到不着无常。二者着无常生戏论。无生忍亦如是。一者虽破生灭不着无生无灭故不堕常颠倒。二者着不生灭故堕常颠倒。真无生者灭诸观语言道断。观一切法如涅槃相。从本已来常自无生。非以智慧观故令无生得是无生无灭毕竟清净。无常观尚不取。何况生灭。如是等相名无生法忍。得是无生忍故即入菩萨位。入菩萨位已以一切种智断烦恼及习。种种因缘度一切众生。如好果树多所饶益。须菩提白佛言。世尊。何等是菩萨道种智。佛答。菩萨住无生忍法得诸法实相。从实相起取诸法名相语言。既自善解无众生说令得开悟。菩萨福德因缘故。解一切众生音声语言。以是音声遍三千大千世界亦不着是声。知如响相是音声即是梵音相。以是故菩萨应知一切道。遍观众生心知其本末。以善法利益遮不善法。如经中广说。菩萨先知诸法实相故。于二乘道入出自在。观已直过入菩萨位为度众生故起道慧。欲为众生说法。解一切众生语言音声。以梵音声说法。所谓遮恶道开善道。恶道者三恶道。善道者三善道。人天阿修罗。种种因缘呵恶道赞善道。遮恶道者所谓地狱道地狱因地狱果。地狱如先说。地狱道者上不善道。地狱因者三毒。贪欲增长起贪嫉不善道。嗔恚增长起恚恼不善道。愚痴增长起邪见不善道。三毒三不善道因。三不善道是七不善道因。地狱果者以是因故受地狱身。身心受种种苦恼是名果。菩萨应示众生地狱果。然后为说法令断地狱道及因果。十不善道有上中下。上者地狱中者畜生下者饿鬼。十善道亦有上中下。上者天中者人下者鬼神。住十善道能离欲生色界。离色生无色界。三恶道中常受苦故。言应知应遮。天人中有得道因缘。为涅槃故或时应遮以不定故。不说余助道法故。不应说遮乃至阿耨多罗三藐三菩提。菩萨能如是分别已。知众生应以小乘法度者。以小乘法而度之。应以大乘法度者。以大乘法而度之。是菩萨知众生深心数事及宿命业因缘。又知未来世果报因缘。又知众生可化时节。及知处所。诸余可度因缘尽皆知之。是故所说不虚。如是道种慧及诸助道法。皆摄在般若中。是故菩萨当行道慧般若。须菩提白佛言。若助道法菩提是法。皆不合不散无色无形无对一相。所谓无相。是助道法皆空。云何能取阿耨多罗三藐三菩提。空无所有法。应无取无舍。譬如虚空无法故无取无舍。须菩提所说真实无著心故。佛可言如是如是。更说因缘。有众生不知如是诸法自相空故。为分别是助道法。能得阿耨多罗三藐三菩提。须菩提非但三十七品空不合不散。所有色等乃至一切种智。于圣法中亦自相空不合不散。不合不散者是毕竟空义。如此中说一相所谓无相。是法虽空以世谛故。为众生说欲令得入圣法。非第一义。是中菩萨皆应以知见学是法。初知名知后深入名见。知名未了见名已了。问曰。知见有何差别。答曰。有人言。有知非见有见非知。有亦知亦见。有非知非见。有知非见者。尽智无生智。除世间正见及五见。余慧皆名知。是慧非见。见非知者。五见世间正见。见谛道中八忍。是见非知。余无漏慧亦名知亦名见。离是见知余法非见非知。复次有人言。定心名为见。定未定通名为知。如转法轮经中说。苦谛知已应见。知已分别知是法应见是苦谛。是法应断是集谛。是法应证是灭谛。是法应修是道谛。或知烦恼断名为见。如九断知。须菩提闻般若异名字。所谓圣法故问。何等是圣法。佛答。圣法中诸贤圣若佛若辟支佛声闻等。以欲等诸法不合不散。不合者一切烦恼名颠倒。颠倒即无所有。若无所有云何可合。若不合云何有散。不合故不轻凡人。不散故不自高。于一切众生不憎不爱。又复此中佛自说不合不散因缘。所谓是法皆无色无形无对一相。所谓无相。无色与无色法。不合不散乃至无相法与无相法不合不散。何以故。是法皆一性故。自性不与自性合。是名一相无相。般若波罗蜜菩萨应学。学已无法可得相。须菩提白佛言。世尊。菩萨不学色相耶。乃至不学有为无为相耶。世尊。若不学是诸法相。云何经中说菩萨先学诸法相后过声闻辟支佛地。若不过声闻辟支佛地。云何入菩萨位。如此中广说。佛告须菩提。若诸法实有相应当学是相。须菩提。一切法实无相。是故菩萨不应学相。无相亦不应学。以取相故破相事。如问相品中说。有佛无佛诸法常住一相所谓无相。须菩提从佛闻一切法无相。今还问佛。世尊。若一切法非有相非无相。云何菩萨修般若。若有无相因无相可修般若。今相以无相皆无。因何事得修般若。若不修般若不能得过声闻辟支佛地。乃至不能安立于三福田。佛可其言如是如是。而更说修般若因缘。所谓菩萨不以修相故是修般若。修无相故是修般若。复问。世尊。云何修无相是修般若。若无相云何可修。佛答修诸法坏是修般若。以诸法坏故无相相亦坏。譬如车分坏故车相亦灭。又如轮分坏故轮相亦灭。如是乃至微尘。世尊。何等是诸法可破坏者。佛答修色法坏即是修般若波罗蜜。乃至修断一切烦恼习坏。即是修般若波罗蜜。须菩提白佛。云何修色坏。乃至修断一切烦恼习坏是修般若。佛答。菩萨一心念萨婆若。怜愍众生欲得正行般若波罗蜜。不念色是有法。如是修是修般若。以色是定实有相过故。所以者何。佛此中自说因缘。有相者不修般若。般若中无法尚无。何况有法。是人不修般若波罗蜜。亦不修五波罗蜜。是人著有法戏论。不修布施等。如是著者无有解脱。无道无涅槃无三解脱门故。言无解脱无圣人。空法故言无道。无道故言无涅槃。问曰。何以故无道。答曰。是人戏论诸法不厌老病死。着法故生邪见。邪见故不能如实观身不净等。不能观身故不修身念处。不修身念处故不能修受心法念处。不修四念处故不能修乃至一切种智。何以故著有法故。须菩提问佛。世尊何等是有法何等是无法。凡人或于有法中生无想。无法中生有想。欲分别是事故问。佛答。二相是有。不二相是无。复问何等是二相。佛答取色相即是二。如先品中说。离色无眼离眼无色。乃至有为无为性。何以故。离有为不得说无为。离无为不得说有为实相。是故是二法不得相离。凡人谓此为二。是故颠倒。佛略说二相。一切法中取相皆是二。一切二皆是有。适有便有生死。何以故。有中生着心。着心因缘生诸烦恼。烦恼因缘往来生死。生死因缘忧悲苦恼。是故说适有法便有生死有生死不得免老病忧苦。须菩提以是当知二相人无有檀波罗蜜。乃至无有顺忍。何况见色实相。乃至见一切种智实相。是人若不见色等诸法实相则无修道。云何有须陀洹果乃至断一切烦恼习。六波罗蜜有二种。世间出世间。此人无有出世间六波罗蜜故。是故说是有相人无有六波罗蜜。若有者。但有世间波罗蜜。此中不说世间波罗蜜。声闻道果尚无。何况有佛道。问曰。顺忍是何等顺忍。答曰。是小乘顺忍。小乘顺忍尚无。何况大乘。问曰。顶法已能不退。何以说乃至忍法。答曰。声闻法中亦说顶堕。摩诃衍亦说顶堕。汝何以故言顶法不堕。有人言。虽顶法不堕不牢固。不能一定故不说忍。是久住已入正定。虽未得无漏而与无漏同。以随顺苦法忍故名为忍。未曾见是法故见便能忍。是故名忍。是人于诸佛圣人为小。于凡夫为大。见色有二种。一者见色实相了了。二者断系诸色烦恼故名为见。如色乃至一切种智一切烦恼习事亦如是。若人见色修道尚无。何况能得修须陀洹果乃至断烦恼习

    大智度论释次第学品第七十五

【经】尔时须菩提白佛言。世尊。若有法相者。尚不得顺忍。何况得道。世尊。若无法相者。当得顺忍不。若干慧地。若性地。若八人地。若见地。若薄地。若离欲地。若已办地。若辟支佛地。若菩萨地。若佛地。若修道。因是修道当断烦恼不。以是烦恼故。不得过声闻辟支佛地入菩萨位。若不入菩萨位。则不得一切种智。不得一切种智。则不能得断一切烦恼习。世尊。若无有法是诸法则不生。若不生是诸法则不能得一切种智。佛告须菩提。如是如是。若无有法者则有顺忍。乃至断一切烦恼习。须菩提白佛言。世尊。菩萨摩诃萨行般若波罗蜜时。有法相不。所谓色相乃至识相。眼相乃至意相。色相乃至法相。眼界相乃至意识界相。四念处相乃至一切种智相。若色相若色断相。乃至识相识断相。十二入十八界亦如是。若无明相若无明断相。乃至忧悲愁恼相。忧悲愁恼断相。若欲相若欲断相。若嗔相若嗔断相。若痴相若痴断相。若苦相若苦断相。若集相若集断相。若灭相若灭断相。若道相若道断相。乃至一切种智相。断一切烦恼习相。佛言。不也。须菩提。菩萨摩诃萨行般若波罗蜜时。无有法相非法相。即是菩萨顺忍。若无有法相。无有非法相。即是修道亦是道果。须菩提。菩萨摩诃萨有法是菩萨道。无法是菩萨果。以是因缘故。当知一切法无所有性。须菩提白佛言。世尊。若一切法无所有性。佛云何知一切法无所有性故得成佛于一切法得自在力。佛告须菩提。如是如是。一切法无所有性。我本行菩萨道修六波罗蜜。离诸欲离恶不善法。有觉有观离生喜乐入初禅。乃至入第四禅。于是诸禅及支取相。不念有是禅。不受禅味。不得是禅。无染清净行四禅。我于是诸禅不受果报。依四禅住起五神通。身通天耳知他人心宿命通天眼证。于诸神通不取相。不念有是神通。不受神通味。不得是神通。我于是五神通不分别行。须菩提。我尔时用一念相应慧。得阿耨多罗三藐三菩提。所谓是苦圣谛是集是灭是道圣谛。成就十力四无所畏四无碍智十八不共法大慈大悲。得作佛分别三聚众生。正定邪定不定。须菩提白佛言。云何世尊。于诸法无所有性中起四禅六神通。亦无众生而分别作三聚。佛言。须菩提。若诸欲恶不善法当有性。若自性若他性。我本为菩萨行时。不能观诸欲恶不善法无所有性入初禅。以诸欲恶不善法无所有性。若自性若他性。皆是无所有性故。我本行菩萨道时。离诸欲恶不善法入初禅。乃至入第四禅。须菩提。若诸神通有性。若自性若他性。我不能知是神通无所有性得阿耨多罗三藐三菩提。须菩提。以神通无有性。若自性若他性。皆无所有性。以是故。诸佛于神通知无所有性。得阿耨多罗三藐三菩提

【论】问曰。诸法空一义。何以故。须菩提种种因缘重问。此中问有法相者不得顺忍。乃至若不生。是诸法不能得萨婆若。答曰。是诸法毕竟空义甚深难解。说者尚难何况受者行者。是故须菩提以般若垂讫。恐人多疑多惑。故种种因缘重问。复次所问义虽一所因处异。或问。世尊若一切法空。云何分别有五道。或问。若一切无所有相。云何分别有三乘。或问。世尊有相者乃至不得顺忍。云何当观八地入菩萨位。如是等种种问。异门故义得差别。般若无一定相故。佛可须菩提意如是如是。须菩提先问顺忍者。是小乘顺忍。今须菩提问菩萨顺忍法。若菩萨行般若时有法相不。佛答。菩萨行般若时。无法生相若有若无。何以故。见有无二俱有过故。则是菩萨顺忍。于一切法中不生有相即是修道。须菩提有法是菩萨道。无法是果。有法名有为法。无法是无为法。行有为八圣道断诸烦恼得无为果。复次有人言。五波罗蜜名有法。是菩萨道。般若波罗蜜毕竟空故无有法。是菩萨果。有人言。般若波罗蜜智慧相有为法故是为道。如法性实际不从因缘生常有故名为果。如是等有无法差别。以是因缘故。须菩提当知一切法。皆是无所有性名为无法。复问世尊若一切法无所有性。佛云何于无所有性中。正知得阿耨多罗三藐三菩提。于诸法中得自在。佛可其言。菩萨以无所有智合行一切法能断一切着故。得阿耨多罗三藐三菩提。此中佛自引为证。我本为菩萨时。行六波罗蜜离欲离恶不善法。有觉有观离生喜乐入初禅。离欲者离五欲。离恶不善法者离五盖。将人入恶道名为恶。障善法故名不善。有觉有观初禅所摄善觉观。离生喜乐者舍离五欲生喜乐。喜乐者色界中有二种乐。一者有喜乐二者无喜乐。喜乐初禅二禅中。无喜乐三禅中。初禅二禅俱有喜乐。有何差别。初禅中喜乐从离欲故生。二禅喜乐从定生。问曰。亦离初禅烦恼得二禅。何以不说离生。答曰。欲界中散乱故无定称。行者能离欲故名为离生。初禅中有定。二禅因初禅定生故名为定生。复次欲界烦恼不善相故障初禅。行者欲离大障故是故说离生。色界烦恼名无记。为患微弱以觉观因缘故失禅。是故佛说灭诸觉观内心清净故得二禅。三禅四禅如先说。我于是诸禅支。取相得已不念有是禅。初习禅时取相乃至得。得已恐着味故。观无常不念有是禅。不得是禅定相。亦不受味无染心。行四禅异于外道。于是诸禅修不受果报禅。依四禅住起五神通。亦如禅法不受其味。宿命通故知一切众生本业因缘来生是间。天眼通力故见众生未来世所生之处。随其业行知一切众生本末已心生大悲。云何断众生生死相续苦。尔时心回向入漏尽通。即时以一念相应慧得阿耨多罗三藐三菩提。所谓是苦相。苦因是爱。爱断苦尽为到。苦尽是道。通达四谛故得十力四无所畏四无碍智十八不共法。分别众生作三聚。住三神通度是众生。所谓天耳知他心身通。为众生说法令度生死。须菩提复问。若诸法无所有。云何佛为菩萨时起四禅六神通。若无众生云何分别众生作三聚。佛答。诸欲诸恶若当有性若自性若他性。我本为菩萨时不能观诸欲恶不善法无所有性入初禅。佛意若诸欲不善法有定性实法若多若少。自相者若自身中若有净常等性。性有二种。若自性若他性。自性名自身不净性。他性名衣服等庄严身具。此皆无常虚诳苦恼因缘。内外五欲中无有常乐我净实。若有者我本行菩萨道时。不能观五欲空无所有性入初禅今欲恶不善法无有实性若自性若他性。是故我为菩萨时。离五欲恶不善法入初禅。乃至入第四禅。若诸神通有性。若自性若他性。我本行菩萨时。不能知神通无所有故得阿耨多罗三藐三菩提。须菩提问。若诸法定无所有性空。佛云何于诸法中得自在力。佛答。我以四禅故于诸烦恼得解脱。六神通故于诸法得自在度众生。须菩提意以四禅六神通是有。云何于空得自在力。佛示我观五欲等空。虚诳无定相故不着此禅。而起诸神通。诸禅有相有量故。可舍得阿耨多罗三藐三菩提。初离欲时以无所有性为因。得阿耨多罗三藐三菩提果。亦无所有。若禅定空。阿耨多罗三藐三菩提不空。可有是难。今皆空故不应有难

大智度论卷第八十六大智度论释次第学品第七十五之余(卷八十七)

        圣者龙树菩萨造

        后秦龟兹国三藏鸠摩罗什译

【经】须菩提言。世尊。若菩萨摩诃萨知诸法无所有性。因四禅五神通。得阿耨多罗三藐三菩提。世尊。新学菩萨摩诃萨云何于诸法无所有性中。次第行次第学次第道。以是次第行次第学次第道。得阿耨多罗三藐三菩提。佛告须菩提。菩萨摩诃萨若初从诸佛闻。若从多供养诸佛菩萨闻。若诸阿罗汉。若诸阿那含。若诸斯陀含。若诸须陀洹所闻。得无所有故是佛。得无所有故。是阿罗汉阿那含斯陀含须陀洹。一切贤圣皆以得无所有故有名。一切有为作法无所有性。乃至无有如毫末许所有。是菩萨摩诃萨闻是已作是念。若一切法无所有性。得无所有故是佛。乃至得无所有故是须陀洹。我若当得阿耨多罗三藐三菩提。若不得一切法常无有性。我何以不发心得阿耨多罗三藐三菩提。得阿耨多罗三藐三菩提已。一切众生行于有相。当令住无所有中。须菩提。菩萨摩诃萨如是思惟已。发阿耨多罗三藐三菩提心。为度一切众生故。菩萨摩诃萨所行次第行次第学次第道者。如过去诸菩萨摩诃萨所行道。得阿耨多罗三藐三菩提。是新发意菩萨应学六波罗蜜。所谓檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。是菩萨摩诃萨若行檀波罗蜜时。自行布施亦教人行布施。赞叹行布施功德。欢喜赞叹行布施者。以是布施因缘故得大财富。是菩萨远离悭心布施众生。饮食衣服香华璎珞房舍卧具灯烛种种资生所须尽给与之。菩萨摩诃萨行是布施及持戒。生天人中得大尊贵。以是持戒布施故得禅定众。以是布施持戒禅定故。得智慧众解脱众解脱知见众。是菩萨因是布施持戒禅定众智慧众解脱众解脱知见众故。过声闻辟支佛地入菩萨位。入菩萨位已得净佛国土成就众生。得一切种智。得一切种智已转法轮。转法轮已以三乘法度脱众生生死。如是须菩提。菩萨以是布施。次第行次第学次第道。是皆不可得。何以故。自性无所有故。复次须菩提。菩萨摩诃萨从初发意自行持戒教人持戒。赞叹持戒功德。欢喜赞叹行持戒者。持戒因缘故。生天人中得大尊贵。见贫穷者施以财物。不持戒者教令持戒。乱意者教令禅定。愚痴者教令智慧。无解脱者教令解脱。无解脱知见者教令解脱知见。以是持戒禅定智慧解脱解脱知见故。过声闻辟支佛地入菩萨位。入菩萨位已得净佛国土。净佛国土已成就众生。成就众生已得一切种智。得一切种智已转法轮。转法轮已以三乘法度脱众生。如是须菩提。菩萨以是持戒。次第行次第学次第道。是事皆不可得。何以故。一切法自性无所有故。复次须菩提。菩萨摩诃萨从初以来。自行羼提波罗蜜。教人行羼提。赞叹羼提功德。欢喜赞叹行羼提者。行羼提波罗蜜时。布施众生各令满足。教令持戒教令禅定。乃至解脱知见。以是布施持戒禅定智慧因缘故。过阿罗汉辟支佛地入菩萨位中。入菩萨位中已得净佛世界。净佛世界。已成就众生。成就众生已得一切种智。得一切种智已转法轮。转法轮已以三乘法度脱众生。如是须菩提。菩萨以羼提波罗蜜。次第行次第学次第道。是事皆不可得。何以故。一切法自性无所有故。复次须菩提。菩萨摩诃萨从初以来。自行毗梨耶波罗蜜。教人行毗梨耶。赞叹行毗梨耶功德。欢喜赞叹行毗梨耶者。乃至是事不可得。自性无所有故。复次须菩提。菩萨摩诃萨从初以来。自入禅入无量心入无色定。亦教人入禅入无量心入无色定。赞叹入禅入无量心入无色定功德。欢喜赞叹行禅无量心无色定者。是菩萨住诸禅定无量心。布施众生各令满足。教令持戒教令禅定智慧。以是布施禅定智慧解脱解脱知见因缘故。过阿罗汉辟支佛地入菩萨位。入菩萨位已净佛世界。净佛世界已成就众生。成就众生已得一切种智。得一切种智已转法轮。转法轮已以三乘法度脱一切众生。乃至是事不可得。自性无所有故。复次须菩提。菩萨摩诃萨从初以来。行般若波罗蜜。布施众生各令满足。教令持戒禅定智慧解脱解脱知见。是菩萨行般若波罗蜜时。自行六波罗蜜。亦教他人令行六波罗蜜。赞叹六波罗蜜功德。欢喜赞叹行六波罗蜜者。是菩萨以是檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜因缘及方便力。过声闻辟支佛地入菩萨位。乃至是事不可得。自性无所有故。须菩提。是名初发意菩萨摩诃萨次第行次第学次第道。复次须菩提。菩萨摩诃萨次第行次第学次第道。菩萨摩诃萨从初以来。以一切种智相应心。信解诸法无所有性。修六念。所谓念佛念法念僧念戒念舍念天。须菩提。云何菩萨摩诃萨修念佛。菩萨摩诃萨念佛不以色念。不以受想行识念。何以故。是色自性无。受想行识自性无。若法自性无。是为无所有。何以故。无忆故。是为念佛。复次须菩提。菩萨摩诃萨念佛。不以三十二相念。亦不念金色身。不念丈光。不念八十随形好。何以故。是佛身自性无故。若法无性是为无所有。何以故。无忆故。是为念佛。复次须菩提。不应以戒众念佛。不应以定众智慧众解脱众解脱知见众念佛。何以故。是众无有自性。若法无自性。是为非法无所有。念是为念佛。复次须菩提。不应以十力念佛。不应以四无所畏四无碍智十八不共法念佛。不应以大慈大悲念佛。何以故。是诸法自性无。若法自性无。是为非法。无所念是为念佛。复次须菩提。不应以十二因缘法念佛。何以故。是因缘法自性无。若法自性无是为非法。无所念是为念佛。如是须菩提。菩萨摩诃萨行般若波罗蜜时应念佛。是为菩萨初发意次第行次第学次第道。是菩萨摩诃萨次第行次第学次第道中住。能具足四念处四正勤四如意足五根五力七觉分八圣道分。修行空三昧无相无作三昧乃至一切种智。诸法性无所有故。是菩萨知诸法性无所有。是中无有性无无性。须菩提。云何菩萨摩诃萨应修念法。须菩提。菩萨摩诃萨行般若波罗蜜时。不念善法。不念不善法。不念记法无记法。不念世间法。不念出世间法。不念净法。不念不净法。不念圣法。不念凡夫法。不念有漏法。不念无漏法。不念欲界系法色界系法无色界系法不念有为法无为法。何以故。是诸法自性无。若法自性无是为非法。无所念是为念法。念法中学无所有性故。乃至当得一切种智。是菩萨得阿耨多罗三藐三菩提时。得诸法无所有性。是无所有性中非有相非无相。如是须菩提。菩萨摩诃萨应修念法。于是法中乃至无少许念。何况念法。须菩提。菩萨摩诃萨云何应修念僧。须菩提。菩萨摩诃萨念僧。无为法故分别有佛弟子众。是中乃至无有少许念。何况念僧。如是菩萨摩诃萨应修念僧。须菩提。菩萨摩诃萨云何应修念戒须菩提。菩萨摩诃萨从初发意已来。应念圣戒无缺戒无隙戒无瑕戒无浊戒无著戒自在戒智者所赞戒具足戒随定戒。应念是戒无所有性。乃至无少许念。何况念戒。须菩提。菩萨摩诃萨从初发意已来应念舍。若自念舍若念他舍。若舍财若舍法若舍烦恼观是舍不可得故乃至无少许念。何况念舍。如是须菩提。菩萨摩诃萨应念舍。须菩提。云何菩萨摩诃萨应念天。须菩提。菩萨作是念。四天王诸天所有信戒施闻慧。此间命终生彼天处。我亦有是信戒施闻慧。乃至他化自在天所有信戒施闻慧。此间命终生彼天处。我亦有是信戒施闻慧。如是须菩提。菩萨摩诃萨应念是天。无所有性中尚无少许念。何况念天。须菩提。菩萨摩诃萨行是六念。是名次第行次第学次第道。尔时须菩提白佛言。世尊。若一切法无所有性。所谓念色乃至识眼乃至意色乃至法。是无所有性。眼界乃至意识界。是无所有性。檀波罗蜜乃至般若波罗蜜。内空乃至无法有法空。四念处乃至八圣道分。佛十力乃至一切种智。是无所有性。世尊。若一切法无所有性者。是则无道无智无果。佛告须菩提。汝见是色性实有不。乃至一切种智实有不。须菩提言。不见也世尊。佛告须菩提。汝若不见诸法实有。云何作是问。须菩提言。世尊。我于是法不敢有疑。但为当来世诸比丘求声闻辟支佛道菩萨道者。是人当如是言。若一切法无所有性。谁垢谁净谁缚谁解。是不知不解故。而破于戒破正见破威仪破净命。是人破此事故。当堕三恶道。世尊。我畏当来世有如是事。以是故问佛。世尊。我于是法中信不疑不悔

【论】释曰。须菩提伏受佛语。一切诸法虽空。而能起四禅神通。是大菩萨近成佛者能行。今未知新发意者云何行。是故疑问佛。世尊新发意菩萨摩诃萨。云何于诸法无所有性中。次第行次第学次第道。用是次第行得阿耨多罗三藐三菩提。以次第行次第学次第道故。当知是新发意菩萨虽无量劫发意。未得诸法实相。皆名新学。问曰。若如是人是新学。但应教行布施持戒等。佛何以教令于诸法无所有毕竟空性中行。答曰。今明始入无所有毕竟空法故。令行无所有。而是菩萨以无所有毕竟空。和合布施持戒等行。譬如小儿服药。须蜜乃下。是故虽新发意亦观深空无咎。佛答须菩提。菩萨若初从诸佛闻。若从多供养诸佛者闻。诸佛者若过去若现在。多供养诸佛者。遍吉观世音得大势菩萨文殊师利弥勒菩萨等。四种声闻圣人义如先说。辟支佛不乐说法故不说。诸佛等圣人皆因无所有故有是分别。圣人虽有禅定等诸功德。皆为涅槃故。涅槃即是寂灭相无所有法。是故说诸圣人皆因涅槃有是差别。一切有为作法从因缘和合生起故。有无有实定性乃至如毫末许所有。有为有二种。一者色二者无色。色法破坏分别乃至微尘无有定实。无色法中乃至无有一念定实。破义如上说。是菩萨从诸佛圣人闻是法。余人多以着心说。诸圣人以无著心说。是故但从圣人闻。尔时次第学菩萨闻是法。以比智筹量决定知诸法究竟必空。皆入佛所得实相中。所谓寂灭无戏论相。我若得作佛。若不作佛。一等无异。何以故。诸法实相不增不减。更无新法可得故法亦不失。若度众生。众生毕竟空本末不可得。我所愿所作功德。及成佛时神通力。皆如梦如幻故无一定实相毕竟空。得不得虽同我何以不发心作佛。问曰。若知诸法毕竟空无所有者。云何复言。我何以不发心作佛。答曰。毕竟空无所有无所障碍。何妨发心作佛。复次若说毕竟空灭诸戏论。云何障发心。若障即是有性。云何言无所有性。问曰。若不障发心亦应不障不发心。菩萨何不安住而发心受诸勤苦。答曰。有人言。是菩萨有种种因缘应发心。或以多诸亲属知识皆不闻不知。不得是诸法实相。是故今世后世受诸苦恼。我幸有力。能使是人得离众苦。譬如人得好良药。亲里知识受诸病苦。云何不与。是故菩萨虽知诸法性无所有。因亲里故而发心利益众生。菩萨复作是念。我虽闻诸法实相。心未深入未有禅定。智慧未熟。受诸苦恼。是故发心求阿耨多罗三藐三菩提。集诸功德。以无所有法作证。自为亦为他人。是菩萨复闻大乘深义。住众生等法等中。无别异心可得佛。虽复中人及怨。都无异心。所以者何。是菩萨以毕竟空心。烦恼微薄怨亲平等。作是念。怨亲无定。以因缘故。亲或为怨。怨或为亲。以此大因缘具足忍波罗蜜故得作佛。由何而得。由忍怨故。是以菩萨视怨如亲。譬如欲过崄道。应当敬重顶戴导师。又如良医虽贱为贵者所重。如是思惟筹量分别。中人怨家虽于我无用。而是佛道因缘。是故发阿耨多罗三藐三菩提心。是名一种次第行次第学次第道。是故以过去菩萨所行为证。问曰。次第行次第学次第道。有何差别。答曰。有人言。无差别。若行若学若道。义一而语异。有人言。初名行中名学后名道。行名布施学名持戒道名智慧。复次行名持戒学名禅定道名智慧。复次行名正语正业正命。学名正精进正念正定。道名正见正思惟。此八事虽名为道。然分别有三分。正见是道体。发起是道名。正思惟正语正业正命。助益正见故名为行。正精进正念正定。能成就正见使令牢固是名学。复次有人言。檀波罗蜜毗梨耶波罗蜜名为行。初入道故。尸罗波罗蜜名为学。人心常随五欲难禁难制。无须臾停息。渐以尸罗波罗蜜禅波罗蜜制伏其心。是故名学。羼提波罗蜜般若波罗蜜名为道。何以故。忍为善般若为智慧。善智具足故名道。譬如人有眼有足随意所至。如是等名为三事差别。问曰。何以名次第。答曰。以须菩提意。若一切法无所有。初发心菩萨于是空法中。云何能渐次第学。以是故说次第。诸法虽空难解。次第行得力故能得成就。譬如缘梯从一初桄渐上上处。虽高虽难亦能得至。次第行者。四种行六波罗蜜。如经中说。自行檀教人行檀。赞檀功德欢喜赞行檀者。善拔悭贪根深爱檀波罗蜜。慈悲于众生。通达诸法实相。以此因缘故。能四种行檀波罗蜜。或有人自行布施。不能教人布施。或畏他嗔或畏为己教布施以之为恩。如是等因缘故不能教人。或有人教人布施自不能施。或有人种种赞叹布施之德劝人令施。而不能自行。有人自行布施。亦教人布施。称赞布施之德。而见人布施不能欢喜。所以者何。或有破戒恶人。行施而不喜见。有人。喜见施主而不赞叹。以其邪见不识施果故。如是各各不能具足。菩萨大悲心深爱善法故。能行四事如上说。菩萨若但自布施不教他人。但能今世少许利益是众生。随业因缘堕贫穷处。是故菩萨教众生言。我不惜财物。我虽多施汝。汝亦不得持至后世。汝今当自作后当自得。以布施实功德。种种因缘教众生行施。见行施者。虽是破戒恶人。但念其好心布施之德。不念其恶。是故欢喜赞叹。复次见三宝无尽福田中施故施福不尽必至佛道。观其未来无尽功德故。欢喜行是四种布施。世世财富。是菩萨虽不为财富布施。未具足阿耨多罗三藐三菩提六波罗蜜等法。中间而财富自至。譬如人为谷故种禾而稾草自至。菩萨得财物报时。离悭贪心随众生意布施。须食与食等。问曰。是菩萨布施时。先施何等人。答曰。是菩萨虽因众生起大悲心。而菩萨布施必先供养诸佛大菩萨辟支佛阿罗汉及诸圣人。若无圣人。次第施持戒精进禅定智慧离欲人。若无此人。施一切出家佛弟子。若无是人。次施持五戒行十善道及持一日戒三归。若无此人。次施中人非正非邪者。若无此人。次施五逆恶人。及诸畜生不可不与。菩萨以施摄一切众生故。有人言。应先布施五逆罪人断善根者贫穷老病下贱乞丐者乃至畜生。譬如慈母多有众子先念羸病给其所须。又如菩萨为饿虎欲食子故以身施之。问曰。如是种种应先施何者。答曰一切众生皆是菩萨福田。能生大悲故。菩萨常欲以阿耨多罗三藐三菩提施众生。何况衣食等而有分别。又菩萨得无生忍法平等无差。未得无生忍者。或慈悲心多或分别心多。此二心不得俱行。悲心多者先施贫穷恶人。作是念种福田中果报虽大。怜愍众生故先利贫者。如是田虽不良。以慈悲心得大果报。分别心多者作是念。诸佛有无量功德故应先供养。以分别诸法取着佛身故心小。其心虽小福田良故功德亦大。若得诸法实相。入般若波罗蜜方便力中。心得自在二事俱行慈愍众生。又视皆如佛。如是等菩萨随因缘行布施。问曰。经何以不言与衣食等。而言须食与食。答曰。有人须食与饮。须饮与衣以不称受者意故福德少。是故言须食与食。问曰。有人若羞若怖。虽有所须不能发言。云何知其所须。答曰。菩萨观其相貌。随时所须土地所宜。或有知他心者。资生之具随意而与。是人因是布施得成戒众。复作是念。我怜愍众生。以衣食布施。所益甚少不如持戒。常以无恼无畏施于众生。菩萨住是持戒中。为守护戒故生禅定心。不散清净故得成慧众无戏论。舍诸着是慧相。以是慧破诸烦恼缚得解脱众。了了知见证解脱故。名解脱知见众。是人先行布施及五众因缘故。过声闻辟支佛地入菩萨位。问曰菩萨应行六波罗蜜入菩萨位。此中何以说五众。答曰法虽一以种种异名说。是故说五众无咎。是人从一波罗蜜中欲起诸波罗蜜。布施为主。已先说持戒众名尸波罗蜜。定众解脱众名禅波罗蜜。慧众解脱知见众是般若波罗蜜。行诸波罗蜜时能忍诸恶事。是名羼提波罗蜜。能起诸波罗蜜不休不息。是名毗梨耶波罗蜜。问曰若尔者何以不但说诸波罗蜜名而说五众。答曰是人欲入菩萨位。此中不但以持戒禅定得和合众戒清净戒无尽戒。以要言之摄一切戒名为戒众。能破烦恼过二乘入菩萨位。譬如一人二人不名为军和合多人乃成为军能破怨敌。余众亦如是。菩萨自得禅定等众。亦令众生得。是名菩萨教化众生。教化众生已持自功德及众生功德。尽回向净佛国。具此二法即得一切种智转法轮以三乘度众生。是名菩萨次第行次第学次第道。先粗后细先易后难。渐渐习学名为次第。余五波罗蜜亦应随义分别。诸法性虽无所有。而随世谛行为破颠倒故。复次念佛等六念。是初次第行。以易行易得故。问曰六念中亦言。不以色念佛云何言易。答曰有法共行故名为易。譬如服苦药以蜜下之则易。六念义如初品中广说。六波罗蜜六念等。柔软易行不生邪见。是菩萨次第学法。余三解脱门等。思惟筹量或生邪见故不说此中。须菩提难。世尊若实无所有。云何有次第行等。佛反问须菩提。汝以声闻智慧见色等法。是一定实法不。答言不见色等一切法。但从因缘和合假有其名。无有定实云何言有。佛语须菩提。汝若不见实定有。云何以次第等。难空而次第法不离于空。尔时须菩提受解了了。是故说我无所疑为当来世求三乘人。闻佛说空无所有性。以罪重智钝故取空相。便言谁垢谁净。凡夫恶人何以名垢。出家得道人何以名净。是人不解佛语深义。以何事而说。着是空故言何用持戒等。为以是因缘即生邪见破正见破正见故。以少因缘而破戒及威仪无所畏忌。出家人资仰白衣。便妄语求利衣食等。破于正命等。种此罪故堕三恶道。或重于白衣。见有是失故问佛。我已得道于诸法无所受。又常闻佛说空法。云何戏论生疑。又我常修无诤三昧怜愍众生是故问佛

    大智度论释一心具万行品第七十六

【经】须菩提白佛言。世尊。若一切法性无所有。菩萨见何等利益故。为众生求阿耨多罗三藐三菩提。佛告须菩提。以一切法性无所有故。菩萨为众生求阿耨多罗三藐三菩提。何以故。须菩提。诸有得有著者难可解脱。须菩提。诸得相者。无有道无有果无阿耨多罗三藐三菩提。须菩提白佛言。世尊。无得相者。有道有果有阿耨多罗三藐三菩提不。须菩提。无所得即是道即是果即是阿耨多罗三藐三菩提。法性不坏故。若无所得法。欲得道欲得果欲得阿耨多罗三藐三菩提。为欲坏法性。须菩提白佛言。世尊。若无所得法。即是道即是果即是阿耨多罗三藐三菩提。云何有菩萨初地乃至十地。云何有无生忍法。云何有报得神通。云何有报得布施持戒忍辱精进禅定智慧。住是果报法中。能成就众生。能净佛国土。及供养诸佛衣服饮食香华璎珞房舍卧具灯烛种种资生所须之具。乃至得阿耨多罗三藐三菩提。不断是福德。乃至般涅槃后。舍利及弟子得供养尔乃灭尽。佛告须菩提。以诸法无所得相故。得菩萨初地乃至十地。有报得五神通布施持戒忍辱精进禅定智慧。成就众生净佛国土。亦以善根因缘故。能利益众生。乃至般涅槃后。舍利及弟子得供养。须菩提白佛言。世尊。若诸法无所得相。布施持戒忍辱精进禅定智慧诸神通有何差别。佛告须菩提。无所得法布施持戒忍辱精进禅定智慧神通无有差别。以众生着布施乃至神通故分别说。世尊。云何无所得法布施乃至神通无差别。须菩提。菩萨摩诃萨行般若波罗蜜时不得布施。施者受者皆不可得而行布施。不得戒而持戒。不得忍而行忍。不得精进而行精进。不得禅而行禅。不得智慧而行智慧。不得神通而行神通。不得四念处而行四念处。乃至不得八圣道分而行八圣道分。不得空三昧无相无作三昧。而行空无相无作三昧。不得众生而成就众生。不得佛国土而净佛国土。不得诸佛法而得阿耨多罗三藐三菩提。须菩提。菩萨摩诃萨应如是行无所得般若波罗蜜。菩萨摩诃萨行是无所得般若波罗蜜时。魔若魔天不能破坏。须菩提白佛言。世尊。云何菩萨摩诃萨行般若波罗蜜时。一念中具足行六波罗蜜四禅四无量心四无色定四念处四正勤四如意足五根五力七觉分八圣道分三解脱门佛十力四无所畏四无碍智十八不共法大慈大悲三十二相八十随形好。佛告须菩提。菩萨摩诃萨所有布施。不远离般若波罗蜜。所修持戒忍辱精进禅定不远离般若波罗蜜。四禅四无量心四无色定修四念处乃至八十随形好。不远离般若波罗蜜。须菩提白佛言。世尊。云何菩萨摩诃萨不远离般若波罗蜜故。一念中具足行六波罗蜜乃至八十随形好。佛言。菩萨行般若波罗蜜时。所有布施不远离般若波罗蜜不二相。持戒时亦不二相修忍辱。勤精进入禅定亦不二相。乃至八十随形好亦不二相。须菩提白佛言。世尊。云何菩萨摩诃萨布施时。不二相乃至修八十随形好不二相。须菩提。菩萨摩诃萨行般若波罗蜜时。欲具足檀波罗蜜。檀波罗蜜中摄诸波罗蜜及四念处乃至八十随形好。世尊。云何菩萨布施时摄诸无漏法。佛告须菩提。若菩萨摩诃萨行般若波罗蜜时。住无漏心布施。于无漏心中不见相。所谓谁施谁受所施何物。以是无相心无漏心。断爱断悭贪心而行布施。是时不见布施。乃至不见阿耨多罗三藐三菩提法。是菩萨以无相心无漏心持戒。不见是戒乃至不见一切佛法。以无相心无漏心忍辱不见是忍。乃至不见一切佛法。以无相心无漏心精进不见是精进。乃至不见一切佛法。以无相心无漏心入禅定。不见是禅定。乃至不见一切佛法。以无相心无漏心修智慧。不见是智慧。乃至不见一切佛法。以无相心无漏心修四念处。不见是四念处乃至八十随形好。世尊。若诸法无相无作。云何具足檀波罗蜜尸波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。云何具足四念处四正勤四如意足五根五力七觉分。八圣道分云何具足空三昧无相无作三昧佛十力四无所畏四无碍智十八不共法大慈大悲。云何具足三十二相八十随形好。佛告须菩提。菩萨摩诃萨行般若波罗蜜。以无相心无漏心布施。须食与食乃至种种所须尽给与之。若内若外若支解其身。若国城妻子布施众生。若有人来语菩萨言。何用是布施为是无所益。行般若波罗蜜菩萨作是念。是人虽来诃我布施我终不悔。我当勤行布施不应不与。施已与一切众生共之回向阿耨多罗三藐三菩提。亦不见是相。谁施谁受所施何物。回向者谁。何等是回向法。何等是回向处。所谓阿耨多罗三藐三菩提。是相皆不可见。何以故。一切法皆以内空故空。外空故空。内外空故空。空空有为空无为空毕竟空无始空散空性空一切法空自相空故空。如是观作是念。回向者谁。回向何处用何法回向。是名正回向。尔时菩萨能成就众生净佛国土。能具足檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜乃至三十七助道法空无相无作三昧乃至十八不共法。是菩萨能如是具足檀波罗蜜。而不受世间果报。譬如他化自在诸天随意所须即皆得之。菩萨亦如是。心生所愿随意即得。是菩萨摩诃萨以是布施果报故。能供养诸佛。亦能满足一切众生天及人阿修罗。是菩萨以檀波罗蜜摄取众生。用方便力以三乘法度脱众生。如是须菩提。菩萨摩诃萨于无相无得无作诸法中。具足檀波罗蜜。须菩提。菩萨摩诃萨云何于无相无得无作法中。具足尸罗波罗蜜。须菩提。是菩萨摩诃萨行尸罗波罗蜜时。持种种戒。所谓圣无漏入八圣道分戒自然戒报得戒受得戒心生戒。如是等不缺不破不杂不浊不着自在戒智所赞戒。用是戒无所取。若色若受想行识。若三十二相八十随形好。若刹利大姓。若婆罗门大姓居士大家。若四天王天三十三天夜摩天兜率陀天化乐天他化自在天梵众天光音天遍净天广果天无想天无烦天无热天妙见天喜见天阿迦腻吒天空处天识处天无所有处天非有想非无想处天。若须陀洹果若斯陀含果若阿那含果若阿罗汉果若辟支佛道。若转轮圣王若天王。但为一切众生共之回向阿耨多罗三藐三菩提。以无相无得无二回向。为世俗法故非第一实义。是菩萨具足尸罗波罗蜜。以方便力起四禅不味着故得五神通。因四禅得天眼。是菩萨住二种天眼修得报得。得天眼已见东方现在诸佛。乃至得阿耨多罗三藐三菩提。如所见事不失。南西北方四维上下现在诸佛。乃至得阿耨多罗三藐三菩提。如所见不失。是菩萨用天耳净过于人耳。闻十方诸佛说法。如所闻不失。能自饶益亦益他人。是菩萨以知他心智知十方诸佛心。及知一切众生心。亦能饶益一切众生。是菩萨用宿命智知过去诸业因缘。是诸业因缘不失故。是众生在在处处所生悉知。是菩萨用是漏尽智。令众生得须陀洹果乃至阿罗汉果辟支佛道。在在处处能令众生入善法中。如是须菩提菩萨摩诃萨于诸法无相无得无作。具足尸罗波罗蜜。世尊。云何诸法无相无作无得。菩萨摩诃萨能具足羼提波罗蜜。须菩提。菩萨摩诃萨从初发意以来。乃至坐道场。于其中间若一切众生来以瓦石刀杖加是菩萨。菩萨是时不起嗔心。乃至不生一念。尔时菩萨应修二种忍。一者一切众生恶口骂詈。若加刀杖瓦石嗔心不起。二者一切法无生无生法忍。菩萨若人来恶口骂詈。或以瓦石刀杖加之。尔时菩萨应如是思惟。骂我者谁。讥诃者谁。打掷者谁。谁有受者。即时菩萨应思惟诸法实性。所谓毕竟空无法无众生。诸法尚不可得。何况有众生。如是观诸法相时。不见骂者不见割截者。是菩萨如是观诸法相时。即得无生法忍。云何名无生法忍。知诸法相常不生诸烦恼。从本已来亦常不生。是菩萨摩诃萨住是二忍。能具足四禅四无量心四无色定四念处乃至八圣道分三解脱门佛十力四无所畏四无碍智十八不共法大慈大悲。是菩萨住是圣无漏出世间法。不共一切声闻辟支佛。具足圣神通。住圣神通已。以天眼见东方诸佛。是人得念佛三昧。乃至阿耨多罗三藐三菩提终不断绝。南西北方四维上下亦如是。是菩萨用天耳闻十方诸佛所说法。如所闻为众生说。是菩萨亦知十方诸佛心。及知一切众生念。知已随其心而为说法。是菩萨以宿命智知一切众生宿世善根。为众生说法令其欢喜。是菩萨以漏尽神通教化众生令得三乘。是菩萨摩诃萨行般若波罗蜜。以方便力成就众生具足一切种智。得阿耨多罗三藐三菩提转法轮。如是须菩提。菩萨摩诃萨无相无得无作法中具足羼提波罗蜜。须菩提言。世尊。菩萨摩诃萨云何于诸法无相无作无得能具足毗梨耶波罗蜜。佛告须菩提。菩萨摩诃萨行般若波罗蜜时。成就身精进心精进。入初禅乃至入第四禅。受种种神通力能分一身为多身。乃至手扪摸日月。成就身精进故飞到东方。过无量百千万诸佛世界。供养诸佛饮食衣服医药卧具华香璎珞种种所须。乃至阿耨多罗三藐三菩提。福德果报终不可尽。是菩萨得阿耨多罗三藐三菩提时。一切世间天及人勤设供养衣服饮食。乃至入无余涅槃后。舍利及弟子得供养。亦以是神通力故。至诸佛所听受法教。乃至阿耨多罗三藐三菩提终不违失。是菩萨修一切种智时。净佛世界成就众生。如是须菩提。菩萨摩诃萨行般若波罗蜜成就身精进。能具足毗梨耶波罗蜜。须菩提。云何菩萨成就心精进能具足毗梨耶波罗蜜。须菩提。菩萨摩诃萨心精进。以是心精进圣无漏入八圣道分。精进不令身口不善业得入。亦不取诸法相。若常若无常若苦若乐若我若无我若有为若无为若欲界若色界若无色界若有漏性若无漏性若初禅乃至第四禅若慈悲喜舍若无边虚空处乃至非有想非无想处若四念处若四正勤四如意足五根五力七觉分八圣道分若空无相无作若佛十力乃至十八不共法不取相若常若无常若苦若乐若我若无我若须陀洹果斯陀含果阿那含果若阿罗汉果若辟支佛道若菩萨道若阿耨多罗三藐三菩提若是须陀洹斯陀含阿那含阿罗汉若是辟支佛是菩萨是佛不取相。是众生断三结故得须陀洹。是众生三毒薄故得斯陀含是众生断下分结故得阿那含。是众生断上分结故得阿罗汉。是众生以辟支佛道故作辟支佛。是众生行道种智故名菩萨。亦不取是诸法相。何以故。不可以性取相。是性无故。是菩萨以是心精进故广利益众生。亦不得是众生。是为菩萨具足毗梨耶波罗蜜。具足诸佛法。净佛国土成就众生。不可得故。是菩萨身精进心精进成就故摄取一切诸善法。是法亦不着故。从一佛国至一佛国为利益众生。所作神通随意无碍。若雨诸华若诸名香若作伎乐若动大地若放光明若示七宝庄严国土若现种种身若放大智光明令知圣道令远离杀生乃至邪见。或以布施利益众生。或以持戒或支解身体。或以妻子或以国土或以己身给施。随所方便利益众生。如是须菩提。菩萨摩诃萨行般若波罗蜜。无相无作无得诸法中。用身心精进能具足毗梨耶波罗蜜。世尊。云何菩萨摩诃萨行般若波罗蜜住无相无作无得法中。能具足禅波罗蜜。须菩提。菩萨摩诃萨除佛诸禅定。余一切诸禅三昧皆能具足。是菩萨离诸欲诸恶不善法。离生喜乐有觉有观入初禅。乃至入第四禅。以是慈悲喜舍心遍满一方乃至十方。一切世间遍满。是菩萨过一切色相灭有对相。不念别异相故入无边虚空处。乃至入非有想非无想处。是菩萨于禅波罗蜜中住。逆顺入八背舍九次第定。入空三昧无相无作三昧。或时入如电光三昧。或时入圣正三昧。或时入如金刚三昧。是菩萨住禅波罗蜜中修三十七助道法。用道种智入一切禅定。过干慧地性地八人地见地薄地离欲地已办地辟支佛地入菩萨位。入菩萨位已具足佛地。是诸地中行。乃至阿耨多罗三藐三菩提不中道取道果。是菩萨住是禅波罗蜜中。从一佛国至一佛国供养诸佛。从诸佛所植诸善根净佛国土。从一佛国至一佛国利益众生。以布施摄取众生。或以持戒或以三昧。或以智慧或以解脱。或以解脱知见。摄取众生。教众生令得须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道。诸有善法能令众生得道。皆教令得。是菩萨住此禅波罗蜜中。能生一切陀罗尼门。得四无碍智报得神通。是菩萨终不入母人胞胎。终不受五欲无生不生。虽生不为生法所污。何以故。是菩萨见一切作法如幻而利益众生。亦不得众生及一切法。教众生令得无所得处。是世俗法故非第一实义。住是禅波罗蜜一切行禅定解脱三昧。乃至阿耨多罗三藐三菩提。终不离禅波罗蜜。是菩萨行如是道种智时。得一切种智断一切烦恼习。断已自益其身亦益他人。自益益他已。为一切世间天及人阿修罗作福田。如是须菩提。菩萨摩诃萨行般若波罗蜜时。能具足无相禅波罗蜜。世尊。云何菩萨摩诃萨行般若波罗蜜时。住无相无作无得法中修具足般若波罗蜜。须菩提。菩萨摩诃萨行般若波罗蜜时。于诸法不见定实相。是菩萨见色不定非实相。乃至见识不定非实相。不见色生乃至不见识生。若不见色生乃至不见识生。一切法若有漏若无漏。不见来处不见去处。亦不见集处。如是观时不得色性乃至识性亦不得有漏无漏法性。是菩萨行般若波罗蜜时。信解一切诸法无所有相。如是信解已行内空乃至无法有法空。于诸法无所著。若色若受想行识。乃至阿耨多罗三藐三菩提。是菩萨行无所有般若波罗蜜。能具足菩萨道。所谓六波罗蜜乃至三十七助道法。佛十力四无所畏四无碍智十八不共法三十二相八十随形好。是菩萨住空净佛道中。所谓六波罗蜜三十七助道法报得神通。以是法饶益众生。宜以布施摄。教令布施。宜以戒摄。教令持戒。宜以禅定智慧解脱解脱知见摄。教令修禅定智慧解脱解脱知见。宜以诸道法教者。教令得须陀洹果得斯陀含果阿那含果阿罗汉果辟支佛道。宜以佛道化者教令得菩萨道具足佛道。如是等随其所应道地而教化之各令得所。是菩萨现种种神通力时。过无量恒河沙国土度脱众生。随其所须皆化给之各令满足。从一国土至一国土见净妙国土以自庄严己佛国土。譬如他化自在天。中资生所须随意自至。亦如诸净佛国离于求欲。是人以是报得檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜报得五神通行菩萨道。种智成就一切功德。当得阿耨多罗三藐三菩提。是菩萨尔时不受色法乃至识。不受一切法若善若不善。若世间若出世间。若有漏若无漏。若有为若无为。如是一切法皆不受。是菩萨得阿耨多罗三藐三菩提时。国土一切所有资生之物皆无有主。何以故。是菩萨行一切法不受。以不可得故。如是须菩提。菩萨摩诃萨无相法中。能具足般若波罗蜜

【论】问曰。问者答者俱言无所有。云何分别知是问是答

答曰。所言法虽一而心异。问者以着心问。答者以无著心答。须菩提意。谓无所有中不应发心。须菩提为听者着心故作是问。诸法空中不见菩萨发心者。不见众生可利益者。不见阿耨多罗三藐三菩提。是故于无所有法中作难者。若一切法无所有性。菩萨见何利故发心。须菩提于菩萨众生阿耨多罗三藐三菩提中不疑。但问无所有法。佛答正以无所有空故能发心。若无所有空。菩萨众生阿耨多罗三藐三菩提亦皆空无所有。云何起难。若众生菩萨及阿耨多罗三藐三菩提。离无所有空者。可有是难。如先说毕竟空于诸法无所障碍。何妨发心。佛还以无所有空破须菩提所问。亦复自说因缘。须菩提着心者难得解脱。是人从无始生死中来。以一切烦恼故深着诸法。闻有亦著闻空亦着。得失亦着。如是众生难可勉出。是故菩萨发无上道心。自以相好严身。得梵音声有大威德。知众生三世心根本。以种种神通力因缘譬喻。为说无所有法空解脱门引导其心。众生见如是希有事。即时其心柔软信佛受法。是故经说著有者难得解脱有所得者无道无果无阿耨多罗三藐三菩提。须菩提问世尊。若有所得者无道无果无阿耨多罗三藐三菩提。无所得者有道有果不。佛答无所有即是道即是果即是阿耨多罗三藐三菩提。若人不分别是有所得是无所得。入诸法实相毕竟空中。是亦无所得。即是道即是果即是阿耨多罗三藐三菩提。不破坏诸法实相故。法性即是诸法实相。须菩提意。谓法性正行邪行常不可破坏。何以佛言不坏法性是道是果。佛答法性虽不可破坏。众生邪行故名为破坏。如虚空云雾土尘虽不能染亦名不净。如人实欲染污虚空。是人为欲染污法性。无是事故佛说譬喻。若人欲坏法性。是人为欲于无所有法中得道得果得阿耨多罗三藐三菩提。须菩提白佛。若无所有即是道。云何有十地等诸菩萨法。如经广说。问曰。此事佛已先答。所谓若法空。菩萨见何事故发心。今言若法空。云何有初地等。佛皆以空答。今须菩提何以更问

答曰。以众生着心难解故更问。是众中有新发意菩萨。闻是诸法实相空即生着心。佛破其着亦着所破法。须菩提为是人故更问。佛答。须菩提以无所得故。有初地乃至般涅槃后。舍利得供养。有所著中不可说初地及诸功德。亦以无所得因缘故。从布施乃至诸神通无有差别。无有差别故不应难。须菩提复问。云何无所得布施乃至诸神通无有差别。佛答。菩萨从初发心已来。似阿耨多罗三藐三菩提寂灭相。布施毕竟空。所谓不得施者受者财物而行布施。如是布施中无有分别。乃至不得菩提。而得阿耨多罗三藐三菩提亦如是。是名菩萨行无所得般若波罗蜜行是无所得般若波罗蜜。魔若魔天不能破坏。一念中行六波罗蜜者

问曰。须菩提何以故问一念中行六波罗蜜等诸功德

答曰。须菩提从佛闻般若波罗蜜甚深无所有相。于诸法中无碍相。若尔者则无所不能无事不作。云何菩萨一念中能摄六波罗蜜乃至八十随形好。初发心时以著有无心重故。渐渐次第行今有无悉舍故无所不能。是故问。佛答。菩萨不离般若波罗蜜。行布施等诸功德无障碍故。能一念中行。若远离般若波罗蜜则渐渐次第行。须菩提问。云何名不远离。佛答。菩萨不以二相行布施等。复问。云何不以二相。佛答。菩萨行般若波罗蜜时。欲具足檀波罗蜜。于布施一念中摄一切善法。如先说。何等是一念。所谓菩萨得无生法忍。断一切烦恼。除诸忆想分别。安住无漏心中布施一切。无漏心是无相相。菩萨住是心中。不见谁施谁受谁物。离一切相心布施不见有一法。乃至阿耨多罗三藐三菩提尚不见。何况余法。是名不二相。乃至八十随形好亦如是。须菩提更以异事问此义。世尊。诸法无相无作无起。云何能具足檀波罗蜜等乃至八十随形好。佛答。菩萨无相无作法中。不取相故无障碍心布施。须食与食等经中已委悉。又先品中亦广说。是故更不解。无漏无相六波罗蜜有二种。一者得无生法忍菩萨所行。二者未得无生法忍菩萨所行。得无生法忍菩萨所行。如此中所说。何以故。住无相无漏心中。行布施等诸法故。问曰。生身菩萨贪惜未除故。割截甚痛是则为难。得无生法忍菩萨。如化人所作割截无痛。有何恩分

答曰。得无生法忍菩萨。行是六波罗蜜为难。所以者何。得无生法忍寂灭心。应受涅槃乐。而舍此寂灭乐。入众生中受种种身。或为贱人或为畜生等。是则为难。生身菩萨贪爱未除。着佛身故以身布施。是为悕望非清净施。是故不如。复次行无漏无相六波罗蜜。是时能具足有漏有相。则不能具足。是故能具足者有大恩分

大智度论卷第八十七大智度论释六喻品第七十七(卷八十八)

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

【经】须菩提白佛言。世尊。云何无相不可分别自相空。诸法中具足修六波罗蜜。所谓檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。世尊云何无异法中而分别说异相。云何般若波罗蜜摄檀尸羼精进禅。云何行异相法以一相道得果。佛告须菩提。菩萨摩诃萨住五阴如梦如响如影如焰如幻如化。住是中行布施持戒。修忍辱勤精进入禅定修智慧。知是五阴实如梦如响如影如焰如幻如化。五阴如梦无相。乃至如化无相。何以故。梦无自性响影焰幻化皆无自性。若法无自性是法无相。若法无相是法一相所谓无相。以是因缘故。须菩提当知。菩萨布施无相。施者无相受者无相。能如是知布施。是能具足檀波罗蜜。乃至能具足般若波罗蜜。能具足四念处乃至八圣道分。能具足内空乃至无法有法空。能具足空三昧无相无作三昧。能具足八背舍九次第定五神通五百陀罗尼门。能具足佛十力四无所畏。四无碍智十八不共法。是菩萨住是报得无漏法中。飞到东方无量国土。供养诸佛衣服饮食。乃至随其所须而供养之。亦利益众生。应以布施摄者而布施摄之。应以持戒摄者教令持戒。应以忍辱精进禅定智慧摄者。教令忍辱精进禅定智慧而摄取之。乃至应以种种善法摄者。以种种善法而摄取之。是菩萨成就是一切善法受世间身。不为世间生死所污。为众生故。于天人中受尊贵富乐。以是尊贵富乐摄取众生。是菩萨知一切法无相故。知须陀洹果。亦不于中住。知斯陀含果阿那含果阿罗汉果。亦不于中住。知辟支佛道。亦不于中住。何以故。是菩萨用一切种智。知一切法已。应当得一切种智。不与声闻辟支佛共。如是须菩提菩萨摩诃萨知一切法无相已。知六波罗蜜无相。乃至知一切佛法无相。复次须菩提。菩萨摩诃萨住五阴。如梦如响如影如焰如幻如化。能具足无相尸罗波罗蜜。是戒不缺不破不杂不着。圣人所赞无漏戒。入八圣道分住是戒中持一切戒。所谓名字戒自然戒律仪戒作戒无作戒威仪戒非威仪戒。是菩萨成就诸戒不作是愿。我以此戒因缘故。生刹利大姓婆罗门大姓居士大家若小王家若转轮圣王家若四天王天处。生若三十三天夜摩天兜率陀天化乐天他化自在天。不作是愿。我持戒因缘故。当得须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道。何以故。一切法无相所谓一相。无相法不能得无相法。有相法不能得有相法。无相法不能得有相法。有相法不能得无相法。如是须菩提。菩萨摩诃萨行般若波罗蜜时。能具足无相尸罗波罗蜜而入菩萨位。入菩萨位已得无生法忍。行道种智得报得五神通。住五百陀罗尼门得四无碍智。从一佛国至一佛国。供养诸佛成就众生净佛国土。虽入五道中生死业报不能染污。须菩提。譬如化转轮圣王。虽坐卧行住不见来处不见去处不见住处坐处卧处而能利益众生亦不得众生。菩萨亦如是。须菩提。譬如须扇多佛得阿耨多罗三藐三菩提。为三乘转法轮无有得菩萨记者。化作化佛已舍身寿命入无余涅槃。须菩提菩萨亦如是。行般若波罗蜜时。能具足尸罗波罗蜜。具足尸罗波罗蜜已摄取一切善法。复次须菩提。菩萨摩诃萨行般若波罗蜜时。住五阴如梦如响如影如焰如幻如化。具足无相羼提波罗蜜。世尊。云何菩萨摩诃萨具足无相羼提波罗蜜。须菩提。菩萨摩诃萨住二忍中。能具足羼提波罗蜜。何等二忍。生忍法忍。从初发意乃至坐道场。于其中间若一切众生来骂詈粗恶语。或以瓦石刀杖加是菩萨。是菩萨欲具足羼提波罗蜜故。乃至不生一念恶。是菩萨如是思惟。骂我者谁害我者谁。以恶言加我以瓦石刀杖害我者谁。何以故。是菩萨于一切法得无相忍故。云何作是念。是人骂我害我。若菩萨摩诃萨如是行。能具足羼提波罗蜜。以是羼提波罗蜜具足故得无生法忍。须菩提白佛言。世尊。云何为无生法忍。是忍何所断何所知。佛告须菩提。得法忍乃至不生少许不善法。是故名无生法忍。一切菩萨所断烦恼尽。是名断。用智慧知一切法不生。是名知。须菩提白佛言。世尊。诸声闻辟支佛无生法忍。菩萨无生法忍有何等异。佛告须菩提。诸须陀洹若智若断是名菩萨忍。斯陀含若智若断是名菩萨忍。阿那含若智若断是名菩萨忍。阿罗汉若智若断是名菩萨忍。辟支佛若智若断是名菩萨忍。是为异。须菩提。菩萨摩诃萨成就是忍。胜一切声闻辟支佛。住如是报得无生忍中。行菩萨道能具足道种智。具足道种智故。常不离三十七助道法及空无相无作三昧。常不离五神通。不离五神通故。能成就众生净佛国土。成就众生净佛国土已当得一切种智。如是须菩提。菩萨摩诃萨具足无相羼提波罗蜜。复次须菩提。菩萨摩诃萨住无相五阴如梦如响如影如焰如幻如化。行身精进心精进。以身精进故起神通。起神通故到十方国土。供养诸佛饶益众生。以身精进力教化众生令住三乘。如是须菩提。菩萨摩诃萨行般若波罗蜜。能具足无相精进波罗蜜。是菩萨以心精进圣无漏精进入八圣道分中。能具足毗梨耶波罗蜜。是毗梨耶波罗蜜皆摄一切善法。所谓四念处四正勤四如意足五根五力七觉分八圣道分四禅四无量心四无色定八解脱九次第定佛十力四无所畏四无碍智十八不共法。是菩萨行是法应具足一切种智具足。一切种智已断一切烦恼习。具足满三十二相。身放无等无量光明。放光明已三转十二行法轮。法轮转故三千大千世界六种震动。光明遍照三千大千世界。三千大千世界中众生。闻说法声皆以三乘法而得度脱。如是须菩提。菩萨摩诃萨住精进波罗蜜中能大饶益。及能具足一切种智。复次须菩提。菩萨住无相五阴如梦如响如影如焰如幻如化。能具足禅波罗蜜。世尊。云何菩萨住五阴如梦如响如影如焰如幻如化。能具足禅波罗蜜。须菩提。菩萨摩诃萨入初禅乃至入第四禅。入慈悲喜舍无量心。入无边虚空处。乃至入非有想非无想处。入空三昧无相无作三昧。入如电光三昧。入如金刚三昧。入圣正三昧除诸佛三昧。诸余三昧若共声闻辟支佛三昧皆证皆入。亦不受三昧味亦不受三昧果。何以故。是菩萨知是三昧无相无所有性。当云何于无相法受无相法味。无所有法受无所有法味。若不受味则不随禅定力生若色界若无色界。何以故。是菩萨不见是二界。亦不见是禅。亦不见入禅者。亦不见用法入禅者。若不得是法。即能具足无相禅波罗蜜。菩萨用是禅波罗蜜能过声闻辟支佛地。须菩提白佛言。世尊。云何菩萨具足无相禅波罗蜜故。能过声闻辟支佛地。佛告须菩提。菩萨善学内空善学外空。乃至善学无法有法空。于是诸空无法可住处。若须陀洹果若斯陀含果阿那含果阿罗汉果。乃至一切种智。是诸空亦空。菩萨摩诃萨行如是诸空能入菩萨位中。须菩提白佛言。世尊。云何菩萨摩诃萨位云何非位。须菩提。一切有所得是非菩萨位。一切无所得是菩萨位。世尊。何等是有所得何等是无所得。须菩提。色是有所得。受想行识是有所得。眼耳鼻舌身意乃至一切种智有所得。是非菩萨位。须菩提。菩萨位者。是诸法不可示不可说。何等法不可示不可说。若色乃至一切种智。何以故。须菩提。色性是不可示不可说。乃至一切种智性是不可示不可说。须菩提。如是名菩萨位。是菩萨入位中。一切禅定三昧具足。尚不随禅定三昧力生。何况住淫怒痴于中起罪业生。菩萨但住如幻法中饶益众生。亦不得众生及如幻法。若无所得是时能成就众生净佛国土。如是须菩提。是名菩萨具足无相禅波罗蜜。乃至能转法轮。所谓不可得法轮。复次须菩提。菩萨摩诃萨行般若波罗蜜。知一切法。如梦如响如焰如影如幻如化。须菩提白佛言。世尊。菩萨摩诃萨云何知一切法如梦如响如影如焰如幻如化。须菩提。菩萨摩诃萨行般若波罗蜜时。不见梦不见见梦者。不见响不见闻响者。不见影不见见影者。不见焰不见见焰者。不见幻不见见幻者。不见化不见见化者。何以故。是梦响影焰幻化。皆是凡夫愚人颠倒法故。阿罗汉不见梦不见见梦者。乃至不见化不见见化者。辟支佛菩萨摩诃萨诸佛。亦不见梦不见见梦者。乃至不见化亦不见见化者。何以故。一切法无所有性不生不定。若法无所有性不生不定。菩萨摩诃萨当云何行般若波罗蜜。是中取生相定相。是处不然。何以故。若诸法少多有性有生有定。不名修般若波罗蜜。如是须菩提。菩萨摩诃萨行般若波罗蜜。不着色乃至不着识。不着欲色无色界。不着诸禅解脱三昧。不着四念处乃至八圣道分。不着空三昧无相无作三昧。不着檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。不着故能具足菩萨初地。于初地中亦不生着。何以故。是菩萨不得是地云何生贪着。乃至十地亦如是。是菩萨行般若波罗蜜。亦不得般若波罗蜜。若行般若波罗蜜时。不得般若波罗蜜。是时见一切法皆入般若波罗蜜中。亦不得是法。何以故。是诸法与般若波罗蜜无二无别。何以故诸法入如法性实际故无分别。须菩提白佛言。世尊。若诸法无相无分别。云何说是善是不善是有漏是无漏是世间是出世间是有为是无为。须菩提。于汝意云何。诸法实相中有法可说是善是不善乃至是有为是无为是须陀洹果乃至是阿罗汉是辟支佛是菩萨是阿耨多罗三藐三菩提不。世尊。不可说也。须菩提。以是因缘故。当知一切法无相无分别无生无定不可示。须菩提。我本行菩萨道时。亦无有法可得性。若色若受想行识乃至若有为若无为须陀洹果乃至阿耨多罗三藐三菩提。如是须菩提。菩萨摩诃萨行般若波罗蜜。从初发意乃至阿耨多罗三藐三菩提。应善学诸法性。善学诸法性故。是名阿耨多罗三藐三菩提道。行是道能具足六波罗蜜。成就众生净佛国土。住是法中得阿耨多罗三藐三菩提。以三乘法度脱众生亦不着三乘。如是须菩提。菩萨摩诃萨以无相法应学般若波罗蜜

【论】问曰。须菩提问佛。若诸法无相无分别。云何差别说六波罗蜜。佛还答。菩萨住是如梦五众中。能具足六波罗蜜。须菩提以空问。佛还以空答。此问答云何得别异。答曰。须菩提问。若诸法空。今眼见菩萨行六波罗蜜作佛。佛答。凡夫远实智慧取相。见菩萨行六波罗蜜作佛。着是空法故难。菩萨虽住五众。住五众如幻如梦空法中。亦以空心行布施。是故虽行诸法具足六波罗蜜不妨于空。譬如云雾远视则见。近之则无所见。凡夫亦如是。远实相故见诸佛。菩萨近实相故见皆空。是故不妨。不妨故能于檀波罗蜜一念中。具足行诸善法。是人常修无漏清净波罗蜜故。转身还报得无漏波罗蜜。报得名更不修行自然而得。譬如报得眼根自然能见色。得是报得无漏波罗蜜已。能变一身作无量阿僧祇身。于十方佛所具足闻诸佛甚深法。度脱十方众生。渐渐净佛世界。随愿作佛。问曰。若诸法空无相。云何分别云何得知行檀波罗蜜等。各各具足余波罗蜜。答曰。行者虽不自分别。而诸佛菩萨说其行檀行尸具足诸行。如声闻人入见谛无漏无相无分别法中。余圣人亦数其所入法。知诸法实相。所谓无相相。是名正见。正见得力已名为正行。是时不恼众生不作诸恶。是名正语正业正命。是时虽无所说亦无所造。而名为正语正业。所以者何。是名深妙正语正业。所谓毕竟不恼众生故。是中发心有所造作是名精进系念缘中是名正念。摄心一处是名正定。见身受心法实相是名四念处。乃至七觉意亦如是。于四念处中亦如八直圣道中诸圣人为数。菩萨亦如是。行是无相檀波罗蜜。能具足尸波罗蜜等诸善法。如檀波罗蜜。尸波罗蜜等摄诸善法亦如是。问曰。上品中以一波罗蜜具诸波罗蜜。此无相摄一切法有何差别。答曰。上以一念中能具诸波罗蜜。此以诸法虽空无相而能具诸波罗蜜为异

    大智度论释四摄品第七十八

【经】须菩提白佛言。世尊若诸法如梦如响如影如焰如幻如化无有实事。无所有性自相空者。云何分别是善法是不善法是世间法是出世间法是有漏法是无漏法是有为法是无为法。是法能得须陀洹果。能得斯陀含果阿那含果阿罗汉果。能得辟支佛道。能得阿耨多罗三藐三菩提。佛告须菩提。凡夫愚人得梦得见梦者。乃至得化得见化者。起身口意善业不善业无记业起福业。若起罪业作不动业。是菩萨摩诃萨行般若波罗蜜住二空中。毕竟空无始空。为众生说法作是言。诸众生是色空无所有。受想行识空无所有。十二入十八界空无所有。色是梦。受想行识是梦。十二入十八界是梦。色是响是影是焰是幻是化。受想行识亦如是。十二入十八界是梦是响是影是焰是幻是化。是中无阴入界。无梦亦无见梦者。无响亦无闻响者。无影亦无见影者。无焰亦无见焰者。无幻亦无见幻者。无化亦无见化者。一切法无根本实性无所有。汝等于无阴中见有阴。无入见有入。无界见有界。是一切法皆从因缘和合生以颠倒心起属业果报。汝等何以故。于诸法空无根本中而取根本相。是时菩萨摩诃萨行般若波罗蜜。以方便力故于悭法中拔出众生。教行檀波罗蜜持是布施功德得大福报。从大福报拔出教令持戒。持戒功德生天上尊贵处。复拔出令住初禅。初禅功德生梵天处。二禅三禅四禅无边空处无边识处无所有处非有想非无想处亦如是。众生行是布施及布施果报。持戒及持戒果报。禅定及禅定果报。种种因缘拔出安置无余涅槃及涅槃道中。所谓四念处四正勤四如意足五根五力七觉分八圣道分空解脱门无相无作解脱门八背舍九次第定佛十力四无所畏四无碍智十八不共法。安隐众生令住圣无漏法无色无形无对法中。有可得须陀洹果者。安隐教化令住须陀洹果。可得斯陀含果阿那含果阿罗汉果辟支佛道者。令住斯陀含果阿那含果阿罗汉果辟支佛道。可得阿耨多罗三藐三菩提者。亦安隐教化令住阿耨多罗三藐三菩提中。须菩提白佛言。世尊。诸菩萨摩诃萨甚希有难及。能行是深般若波罗蜜。诸法无所有性毕竟空无始空。而分别诸法是善是不善是有漏是无漏乃至是有为是无为。佛告须菩提。如是如是。诸菩萨摩诃萨甚希有难及。能行是深般若波罗蜜。诸法无所有性毕竟空无始空而分别诸法。须菩提。汝等若知是菩萨摩诃萨希有难及法。则知一切声闻辟支佛不能报。何况余人。须菩提白佛言。世尊。何等是菩萨摩诃萨希有难及法。诸声闻辟支佛所无有。佛告须菩提。一心谛听。有菩萨摩诃萨。行般若波罗蜜住报得六波罗蜜中。及住报得五神通三十七助道法。住诸陀罗尼诸无碍智。到十方世界可以布施度者以布施摄之。可以持戒度者以持戒摄之。可以忍辱精进禅定智慧度者。随其所应而摄取之。可以初禅度者以初禅摄取之。可以二禅三禅四禅无边空处无边识处无所有处非有想非无想处度者。随其所应而摄取之。可以慈悲喜舍心度者。以慈悲喜舍心摄取之。可以四念处四正勤四如意足五根五力七觉分八圣道分空三昧无相无作三昧度者随所摄之。世尊。菩萨摩诃萨云何以布施饶益众生。须菩提。菩萨行般若波罗蜜时。布施随其所须。饮食衣服车马香华璎珞种种所须。尽给与之。若供养佛辟支佛阿罗汉阿那含斯陀含须陀洹等无有异。若施入正道中人及凡人。下至禽兽皆无分别等一布施。何以故。一切法不异不分别故。是菩萨无异无别布施已当得无分别法报。所谓一切种智。须菩提。若菩萨摩诃萨见乞匈者若生是心。佛是福田我应供养禽兽非福田不应供养。是非菩萨法。何以故。菩萨摩诃萨发阿耨多罗三藐三菩提心不作是念是众生应以布施饶益。是不应布施是众生。布施因缘故应生刹利大姓婆罗门大姓居士大家。乃至以是布施因缘以三乘法度之。令入无余涅槃。若众生来从菩萨乞。亦不生异心分别应与是不应与是。何以故。是菩萨为是众生故发阿耨多罗三藐三菩提心。若分别简择便堕诸佛菩萨辟支佛学无学人一切世间天及人诃责处。谁请汝救一切众生。汝为一切众生舍一切众生护一切众生依。而分别简择应与不应与。复次若菩萨摩诃萨行般若波罗蜜时。若人若非人来欲求乞菩萨身体支节。是时不应生二心。若与若不与。何以故。是菩萨摩诃萨为众生故受身。众生来取何可不与。我以饶益众生故受是身。众生不乞自应与之。何况乞而不与。菩萨摩诃萨行般若波罗蜜应如是学。复次须菩提。菩萨摩诃萨见有乞者应生是念。是中谁与谁受所施何物。是一切法自性皆不可得。以毕竟空故空相法无与无夺。何以故。毕竟空故。内空故。外空内外空大空第一义空自相空故。住是诸空布施。是时具足檀波罗蜜。具足檀波罗蜜故。若断内外法。时作是念。截我者谁割我者谁。复次须菩提。我以佛眼见东方如恒河沙等诸菩萨摩诃萨。入大地狱令火灭汤冷。以三事教化。一者神通。二者知他心。三者说法。是菩萨以神通力令大地狱火灭汤冷。知他心以慈悲喜舍随意说法。是众生于菩萨生清净心。从地狱得脱渐以三乘法得尽苦际。南西北方四维上下亦如是。复次须菩提。我以佛眼观十方世界。见如恒河沙等国土中诸菩萨。为诸佛给使供养。诸佛随意爱乐恭敬。若诸佛所说尽能受持。乃至阿耨多罗三藐三菩提终不忘失。复次须菩提。我以佛眼观十方如恒河沙等国土中诸菩萨摩诃萨。为畜生故舍其寿命割截身体分散诸方。诸有众生食是诸菩萨摩诃萨肉者。皆爱敬菩萨。以爱敬故即得离畜生道值遇诸佛。闻佛说法如说修行。渐以三乘声闻辟支佛佛法。于无余涅槃而般涅槃。如是须菩提。诸菩萨摩诃萨所益甚多。教化众生令发阿耨多罗三藐三菩提心。如说修行乃至于无余涅槃而般涅槃。复次须菩提。我以佛眼见十方如恒河沙等国土中诸菩萨摩诃萨。除诸饿鬼饥渴苦。是诸饿鬼皆爱敬菩萨。以爱敬故得离饿鬼道值遇诸佛。闻诸佛说法如说修行。渐以三乘声闻辟支佛佛法而般涅槃。乃至无余涅槃。如是须菩提。菩萨摩诃萨为度众生故行大悲心。复次须菩提。我以佛眼见诸菩萨摩诃萨。在四天王天上说法。在三十三天夜摩天兜率陀天化乐天他化自在天上说法。诸天闻菩萨说法渐以三乘而得灭度。须菩提。是诸天众中有贪着五欲者。是菩萨示现火起烧其宫殿而为说法作是言。诸天。一切有为法悉皆无常谁得安者。复次须菩提。我以佛眼观十方世界。见如恒河沙等国土中诸梵天着于邪见。诸菩萨摩诃萨教令远离邪见作是言。汝等云何于空相虚妄诸法中而生邪见。如是须菩提。菩萨摩诃萨住大慈心为众生说法。须菩提。是为诸菩萨希有难及法。复次须菩提。我以佛眼观十方世界如恒河沙等国土中诸菩萨摩诃萨。以四事摄取众生。何等为四。布施爱语利益同事。云何菩萨以布施摄取众生。须菩提。菩萨以二种施摄取众生。财施法施。何等财施摄取众生。须菩提。菩萨摩诃萨以金银琉璃颇梨真珠珂贝珊瑚等诸宝物。或以饮食衣服卧具房舍灯烛华香璎珞。若男若女若牛羊象马车乘。若以己身给施众生。语众生言。汝等若有所须各来取之。如取己物莫得疑难。是菩萨施已教三归依。归依佛归依法归依僧。或教受五戒。或教一日戒。或教初禅。乃至教非有想非无想定。或教慈悲喜舍。或教念佛念法念僧念戒念舍念天。或教不净观。或教安那般那观。或相或触。或教四念处四正勤四如意足五根五力七觉分八圣道分空三昧无相无作三昧八背舍九次第定佛十力四无所畏四无碍智十八不共法大慈大悲三十二相八十随形好。或教须陀洹果斯陀含果阿那含果阿罗汉果。或教辟支佛道。或教阿耨多罗三藐三菩提。如是须菩提。菩萨摩诃萨行般若波罗蜜。以方便力教众生财施已后。教令得无上安隐涅槃。须菩提。是名菩萨摩诃萨希有难及法。须菩提。菩萨云何以法施摄取众生。须菩提。法施有二种。一者世间。二者出世间。何等为世间法施。敷演显示世间法。所谓不净观安那般那念四禅四无量心四无色定。如是等世间法。及诸余共凡夫所行法是名世间法施。是菩萨如是世间法施已。以种种因缘教化令远离世间法。远离世间法已。以方便力令得圣无漏法及圣无漏法果。何等是圣无漏法。何等是圣无漏法果。圣无漏法者。三十七助道法三解脱门。圣无漏法果者。须陀洹果乃至阿罗汉果辟支佛道阿耨多罗三藐三菩提。复次须菩提。菩萨摩诃萨圣无漏法。须陀洹果中智慧。乃至阿罗汉果中智慧。辟支佛道中智慧。三十七助道法中智慧。六波罗蜜中智慧。乃至大慈大悲中智慧。如是等一切法若世间若出世间智慧。若有漏若无漏若有为若无为是法中一切种智。是名菩萨摩诃萨圣无漏法。何等为圣无漏法果。断一切烦恼习。是名圣无漏法果。须菩提白佛言。世尊。菩萨摩诃萨得一切种智不。佛言。如是如是。须菩提。菩萨摩诃萨得一切种智。须菩提言。菩萨与佛有何等异。佛言。有异。菩萨摩诃萨得一切种智。是名为佛。所以者何。菩萨心与佛心无有异。菩萨住是一切种智中。于一切法无不照明。是名菩萨摩诃萨世间法施。须菩提。菩萨摩诃萨因世间法施得出世间法施。如是须菩提。菩萨摩诃萨教众生令得世间法已。以方便力教令得出世间法。须菩提。何等是菩萨出世间法。不共凡夫法同。所谓四念处四正勤四如意足五根五力七觉分八圣道分三解脱门八背舍九次第定佛十力四无所畏四无碍智十八不共法三十二相八十随形好五百陀罗尼门。是名出世间法。须菩提。云何为四念处。菩萨摩诃萨观内身循身观。观外身循身观。观内外身循身观。勤精进以一心智慧观身观身集因缘观身灭。观身集生灭。行是道无所依。于世间无所爱。受心法念处亦如是。须菩提。云何为四正勤。未生恶不善法为不生故。勤生欲精进。已生恶不善法为断故。勤生欲精进。未生善法为生故。勤生欲精进。已生诸善法为增长修具足故。勤生欲精进。是名四正勤。须菩提。云何为四如意足。欲三昧断行成就初如意足。精进三昧心三昧思惟三昧断行成就如意足。云何为五根。信根精进根念根定根慧根。云何为五力。信力精进力念力定力慧力。云何为七觉分。念觉分择法觉分精进觉分喜觉分除息觉分定觉分舍觉分。云何为八圣道分。正见正思惟正语正业正命正精进正念正定。云何为三三昧。空三昧门无相无作三昧门。云何为空三昧。以空行无我行摄心是名空三昧。云何为无相三昧。以寂灭行离行摄心是为无相三昧。云何为无作三昧。无常行苦行摄心是为无作三昧。云何为八背舍。内色相外观色是初背舍。内无色相外观色。是二背舍。净背舍是三背舍。过一切色相灭一切对相。不念一切异相故。观无边虚空入无边空处。乃至过一切非有想非无想处。入灭受想背舍是名八背舍。云何九次第定。行者离欲恶不善法。有觉有观离生喜乐入初禅。第二第三第四禅。乃至过非有想非无想处入灭受想定。是名九次第定。云何为佛十力。是处不是处如实知。知众生过去未来现在诸业诸受法。知造业处。知因缘知报。诸禅定解脱三昧定垢净分别相如实知。知他众生诸根上下相。知他众生种种欲解。知一切世间种种无数性知一切到道相。知种种宿命一世乃至无量劫。如实知。天眼见众生乃至生善恶道。漏尽故无漏心解脱如实知。是为佛十力。云何为佛四无所畏。佛作诚言。我是一切正智人。若有沙门婆罗门若天若魔若梵若复余众。如实言是法不知。乃至不见是微畏相。以是故我得安隐得无所畏。安住圣主处。在大众中师子吼能转梵轮。诸沙门婆罗门若天若魔若梵若复余众实不能转。一无畏也。佛作诚言。我一切漏尽。若有沙门婆罗门若天若魔若梵若复余众。如实言是漏不尽。乃至不见是微畏相。以是故我得安隐得无所畏。安住圣主处。在大众中作师子吼能转梵轮。诸沙门婆罗门若天若魔若梵若复余众实不能转。二无畏也。佛作诚言我说障法。若有沙门婆罗门若天若魔若梵若复余众。如实言受是法不障道。乃至不见是微畏相。以是故我得安隐得无所畏。安住圣主处。在大众中师子吼能转梵轮。诸沙门婆罗门若天若魔若梵若复余众实不能转。三无畏也。佛作诚言。我所说圣道能出世间。随是行能尽苦。若有沙门婆罗门若天若魔若梵若复余众。如实言行是道不能出世间不能尽苦。乃至不见是微畏相。以是故我得安隐得无所畏。安住圣主处。在大众中师子吼能转梵轮。诸沙门婆罗门若天若魔若梵若复余众实不能转。四无畏也。云何为四无碍智。一者义无碍智。二者法无碍智。三者辞无碍智。四者乐说无碍智。云何为义无碍智。缘义智慧。是为义无碍智。云何为法无碍智。缘法智慧。是为法无碍智。云何为辞无碍智。缘辞智慧。是为辞无碍智。云何为乐说无碍智。缘乐说智慧。是为乐说无碍智。云何为十八不共法。一者诸佛身无失。二者口无失。三念无失。四无异想。五无不定心。六无不知已舍心。七欲无减。八精进无减。九念无减。十慧无减。十一解脱无减。十二解脱知见无减。十三一切身业随智慧行。十四一切口业随智慧行。十五一切意业随智慧行。十六智慧知过去世无碍。十七智慧知未来世无碍。十八智慧知现在世无碍。云何三十二相。一者足下安平立平如奁底。二者足下千辐辋轮轮相具足。三者手足指长胜于余人。四者手足柔软胜余身分。五者足跟广具足满好。六者手足指合缦网胜于余人。七者足趺高平好与跟相称。八者伊泥延鹿[跳-兆+專][跳-兆+專]纤好如伊泥延鹿王。九者平住两手摩膝。十者阴藏相如马王象王。十一者身纵广等如尼俱卢树。十二者一一孔一毛生色青柔软右旋。十三者毛上向青色柔软右旋。十四者金色相其色微妙胜阎浮檀金。十五者身光面一丈。十六者皮薄细滑不受尘垢不停蚊蚋。十七者七处满两足下两手中两肩上项中皆满字相分明。十八者两腋下满。十九者上身如师子。二十者身广端直。二十一者肩圆好。二十二者四十齿。二十三者齿白齐密而根深。二十四者四牙最白而大。二十五者方颊车如师子。二十六者味中得上味咽中二处津液流出。二十七者舌大软薄能覆面至耳发际。二十八者梵音深远如迦兰频伽声。二十九者眼色如金精。三十者眼睫如牛王。三十一者眉间白毫相软白如兜罗绵。三十二者顶髻肉成。是三十二相佛身成就。光明遍照三千大千世界。若欲广照则遍满十方无量阿僧祇世界。为众生故受丈光。若放无量光明则无日月时节岁数。佛音声遍满三千大千世界。若欲大声则遍满十方无量阿僧祇世界。随众多少音声遍至

【论】问曰。上来已处处说诸法性空。云何分别有善不善。须菩提。何以从后已来。品品中义无异而作种种名问。答曰。是事上已答。复次众生从无始生死已来着心深难解故。须菩提复作是重问。复次是般若波罗蜜欲说是空义要故数问。复次佛在世时。众生利根易悟。佛灭度五百年后。像法中众生爱着佛法堕着法中。言若诸法皆空如梦如幻何以故有善不善。以是故须菩提怜愍未来众生钝根不解故重问世尊。若诸法皆空。云何分别有善不善等。此中佛自说因缘。凡夫颠倒心故。于法皆作颠倒异见。乃至不见一法是实。凡夫于梦中着梦得梦见梦者。亦着梦中所见事。是人若不信罪福起三种不善业。若信罪福起三种善业。善不善不动。善名欲界中善法喜乐果报。不善名忧悲苦恼果报。不动名生色无色界因缘业。菩萨知是三种业皆是虚诳不实。住二空中为众生说法。毕竟空破诸法。无始空破众生相。住中道为众生说法。所谓五众十二入十八界。皆是空如梦如幻乃至如化。是法中无梦亦无见梦者。菩萨语众生。汝等于空法颠倒心故生诸着。如经中广说。是菩萨方便力故。于颠倒中拔出众生着破颠倒法中。譬如悭贪是颠倒。以布施破悭贪法。而众生着是布施故。为说布施果报无常实空。从布施拔出众生令持戒。持戒及持戒果报中拔出众生。语众生言。天福尽时无常苦恼。拔出众生令离欲行禅定。而为说禅定及果报虚诳不实能令人堕颠倒中。种种因缘为说布施持戒禅定无常过失令住涅槃得涅槃方便。所谓四念处乃至十八不共法。令众生住是法中。若布施持戒禅定是定实法。则不应令远离。如布施持戒等破凡夫法。此则因颠倒而生。虽少时益众生。久则变异能生苦恼故。亦教令舍离。菩萨方便力故先教众生舍罪。称赞持戒布施福德。次复为说持戒布施亦未免无常苦恼。然后为说诸法空。但称赞实法。所谓无余涅槃是。时须菩提欢喜甚希有。菩萨能如是知是诸法实相。所谓毕竟空。而为众生说法令至无余涅槃。佛言。是一种希有问。欲更知菩萨希有法。一切声闻辟支佛。不能报是菩萨。何况余人。须菩提问。何等是更有希有法。佛答如经中说。问曰。经中教令布施持戒禅定。今复更说有何等异。答曰。先说生身菩萨。今说变化身。先说一国土。今说无量世界。如是等差别。问曰。若菩萨知佛是福田众生非福田。是非菩萨法。菩萨以何力故能令佛与畜生等。答曰。菩萨以般若波罗蜜力故。一切法中修毕竟空心。是故于一切法无分别。如畜生五众十二入十八界和合生名为畜生。佛亦如是。从诸善法和合假名为佛。若人怜愍众生得无量福德。于佛着心起诸恶因缘得无量罪。是故知一切法毕竟空故。不轻畜生不着心贵佛。复次诸法实相是一切法无相。是无相中不分别是佛是畜生。若分别即是取相。是故等观。复次菩萨有二法门。一者毕竟空法门。二者分别好恶法门。入空法门则得等观入分别法门。诸阿罗汉辟支佛尚不及佛。何况畜生。为其轻众生不怜愍布施故教不分别。问曰。菩萨身非木石。云何众生来割截而不生异心。答曰。有人言。菩萨久修羼提波罗蜜故能不愁恼。如羼提仙人被截手足血皆为乳。有人言。菩萨无量世来深修大慈悲心故。虽有割截亦不愁忧。譬如草木无有嗔心。有人言。菩萨深修般若波罗蜜。转身得般若波罗蜜果报空心故了了知空。割截身时心亦不动。如外物不动。内亦如是。得般若果报。故于诸法中无所分别。有人言。是菩萨非生死身。是出三界法性生身。住无漏圣心果报中故身如木石。而能慈念割截者。是菩萨能生如是心故。割截劫夺内外法时。其心不动。是为菩萨希有法。复次希有法者。如经中说。我以佛眼见十方如恒河沙等世界中菩萨。入地狱中令火灭汤冷。以三事教化众生。如经中说。问曰。若尔者不应有三恶道。答曰。三恶道众生无边无量。菩萨虽无边无量众生倍多无量。菩萨随众生可度因缘。若于三恶道中有余功德者菩萨则度。重罪者则不见菩萨。菩萨一相见无分别心故。不一一求觅众生。譬如大赦及者得脱不及者则不蒙。问曰。若众生割截菩萨或食其肉。应当有罪。云何得度。答曰。此菩萨本愿。若有众生啖我肉者当令得度。如经中说。众生食菩萨肉者则生慈心。譬如有色声香触人闻见则喜复有闻见则嗔。味亦如是。有嗔者有起慈心者。如毗摩罗鞊经说。服食香饭七日得道者有不得者。非以啖肉故得度。以起发慈心故得免畜生。生善处值佛得度。有菩萨于无量阿僧祇劫深行慈心。外物给施众生意犹不满。并自以身布施。尔乃足满。如法华经中。药王菩萨外物珍宝供养佛。意犹不满。以身为灯供养于佛。尔乃足满。复次人得外物虽多不以为恩。所以者何。非所爱重故。得其身时乃能惊感。是故以身布施。菩萨又为天上诸天说法。如经中广说。人以四事摄之。布施爱语利益同事。布施有二事。如经中广说。问曰。何以略说余四道。而广说人道中法。答曰。三恶道中苦多故众生少疑。若见菩萨大神通希有事。则直信爱着得度。诸天有天眼故自见罪福因缘。菩萨少现神足则解。人以肉眼不见罪福因缘果报。又多着外道邪师及邪见经书。诸烦恼有二分。一者属见。二者属爱。若但有一事则不能成大罪。三毒人得邪见力。能尽作重恶。邪见人得贪欲嗔恚。能大作罪事。如须陀洹虽有三毒无邪见故。不作堕三恶道重罪。是故人中多有三毒邪见。又眼不见罪福因缘故难度。难度故多说。问曰。若尔者于四事中何以多说布施。余三略说。答曰。布施中摄三事故。以财施法施教化众生。则无所不摄。复次四事中初广开布施。则知余三亦如是。问曰。若尔者何以略说财施而广说法施。答曰。财施少法施广故。所以者何。财施有量果报。法施无量果报。财施欲界系果报。法施亦三界系果报。亦是出三界果报。财施能与三界富乐。法施能与涅槃常乐。又财施从法施生。闻法则能施故。复次财施果报但富乐无种种。法施亦有富乐亦有余事。乃至佛道涅槃果报。以是等因缘故广说法施。二施义如经中佛自广说。问曰。经中须菩提何以故言菩萨得一切种智不。答曰。须菩提意。若菩萨时得一切种智则不名菩萨。云何未得佛而能得一切种智。得一切种智故名为佛。若先作佛何用一切种智为。佛答。今得一切种智名为菩萨。已得一切种智名为佛。菩萨时具足佛因缘。生心欲得一切种智。得已名为佛。真实之言菩萨不得。佛亦不得。所以者何。菩萨未得佛。得已竟更不复得。世俗法故说菩萨今得佛得已竟。第一义中则无一切法。何况佛及菩萨。又经中言。佛心不异菩萨。菩萨不异佛心。次第相续不断故有二心。如无异无分别故。问曰。九次第定三十二相八十随形好。此是世间共有法。何以故。名为出世间不共法。答曰。四禅四无色定灭受想名九次第。灭受定但圣人能得。四禅四无色定。从初禅起更不杂余心而入二禅。从二禅乃至灭受定。念念中受不杂余心名为次第。凡夫是罪人钝根。云何能得三十二相。如转轮圣王提婆达难陀所得相。名字虽同而威德具足。净洁得处则不同于佛。如先分别转轮圣王佛相不同中说。又是相圣无漏法果报故。自在随意无量无边。转轮圣王等相。是福德业因缘不能自在有量有限。复次提婆达难陀。有三十相无三十二相。转轮圣王虽有三十二相无威德不具足。不得处与爱等烦恼俱。八十随形好具足。唯佛菩萨有之。余人正可有少许。或指纤长或失腹。有如是等无威德之好不足言。是故说言出世间不共凡夫法无咎

问曰。从初来处处说诸法五众乃至一切种智不说是三十二相八十随形好。今经欲竟何以品品中说

答曰。佛有二种身。法身生身。于二身中法身为大。法身大所益多故。上来广说。今经欲讫故生身义应当说。是故今说。复次是生身相好庄严。是圣无漏法果报。今次第说。上杂诸波罗蜜说四念处等诸法义。如先说十力等。是佛法甚深义今当更略说

问曰。佛十力者若总相说则一力。所谓一切种智力。若别相说则千万亿种力。随法为名。今何以但说十力

答曰。佛实有无量智力。但以众生不能得不能行故不说。是十力可度众生事办。所以者何。佛用是处非处力。定知一切法中因果。所谓行恶业堕恶道。有是处。行恶业生天上无是处。善亦如是。不离五盖不修七觉得道者。无有是处。离五盖修七觉得道者有是处。余九力尽入此力中。佛以此力筹量十方六道中众生可度者不可度者。可度者以种种因缘神通变化而度脱之。不可度者于此人中修舍心。譬如良医观其病相审定知其可活则治之不可活者则舍之。度众生方便者。所谓二力。业力定力。求其业因缘生处。人以业因缘故。受身缚着世间。禅定因缘故得解脱。行者必应求苦。从何而生由何而灭。是故用二力。业力有二分。一者净业能断恶业。二者垢业。净业名禅定解脱诸三昧。不净业者。能于三界中受身。人有二种。钝根为受身故作业。利根为灭身故作业。问曰。若尔者何以不皆令作净业。答曰。以众生根有利钝故。问曰。众生何因缘故有利钝。答曰。以有种种欲力故。恶欲众生常入恶故钝。欲名嗜好。嗜好罪事生恶业故钝。善欲者乐道修助道法故利。问曰。众生何以不皆作善欲。答曰。是故佛说世间种种性恶性善性。恶性者恶欲。恶欲故根钝。如火热性水湿性。不应责其所以。问曰。恶欲即是恶性有何差别而作二力。答曰。性先有欲。得因缘而生。譬如先有疮得触因缘则血出。性在内欲在外。性重欲轻。性难除欲易舍。性深欲浅。用性作业必当受报。用欲作业不必受报。有如是等差别。复有人言。欲常习增长遂成为性。性亦能生欲。是人若今世若后世常习是欲。则成为性。住是性中作恶作善。若住善性则可度。若住恶性则不可度。佛既知众生二种性。已知其果报善道恶道种种差别。恶性者堕三恶道。善性者有四种道。人天阿修罗涅槃道。问曰。一切到处道力与天眼力有何差别。答曰。天眼但见生死时此中未死时知。见因知果天眼。见现前罪福果报。是名一切到处道力。问曰。声闻辟支佛亦得涅槃。亦能化众生。何以无是力。答曰。是故说后三力。三世中众生事尽能通达遍知。以宿命力一切众生过去事本末悉知。以天眼生死智力故。一切众生未来世中无量事尽能遍知。作是知已知现世中众生可度者。为说漏尽法。以是故但佛有此力二乘所无。如有一人即日应得阿罗汉。舍利弗日中时语言。汝无得道因缘舍而不度。晡时佛以宿命神通见。过去八万劫前得道因缘今应成就。晡时说法即得阿罗汉道。复次佛以初力知众生可度不可度相。以第二力知众生为三障所覆无覆者。以第三力知众生禅定解脱净不净者。以第四力知众生根有利有钝能通法性不通者。以第五力知众生利钝根因缘善恶欲。以第六力知二欲因缘种种性。以第七力知众生利钝根善恶果报处七种道。以第八力知众生宿世善恶业障不障。以第九力知众生今世未可度未来世生处可度。以第十力知是人以空解脱门入涅槃无相无作门入涅槃。知是人于见谛道思惟道中念念中断若干结使。以是十力筹量众生。所应度缘而为说法。是故说法初无空言。问曰。佛智慧无量身相亦应无量。又佛身胜诸天王。何以正与转轮圣王同有三十二相。答曰。三十二相不多不少义如先说。复次有人言。佛菩萨相不定。如此中说。随众生所好可以引导其心者为现。又众生不贵金而贵余色琉璃颇梨金刚等。如是世界人。佛则不现金色。观其所好则为现色。又众生不贵纤长指及网缦。以长指利爪为罗刹相。以网缦为水鸟相。造事不便如着手衣。何用是为。如罽宾国弥帝隶力利菩萨。手网缦。其父恶以为怪。以刀割之言。我子何缘如鸟。有人不好肩圆大以为似肿。有以腹不现无腹如饿相。亦有人以青眼为不好。但好白黑分明。是故佛随众生所好而为现相好。如是等无有常定。有人言。此三十二相。实定以神通力变化身。随众生所好而为现相。有人言。佛有时神通变化。有时随世界处生。当生处不得言神通变化。又于三千大千世界中。随可度众生处生则为现相。如密迹经中说。或现金色或现银色。或日月星宿色。或长或短。随可引导众生则为现相。随此间阎浮提中天竺国人所好。则为现三十二相。天竺国人于今故治肩[骨*專]。令厚大头上皆以有髻为好。如人相中说五处长为好。眼鼻舌臂指髀手足相。若轮若莲华若贝若日月。是故佛手足有千辐轮纤长指。鼻高好舌广长而薄。如是等皆胜于先所贵者故。起恭敬心有国土。佛为现千万相。或无量阿僧祇相。或五六三四相。随天竺所好故。现三十二相八十种随形好

大智度论卷第八十八大智度论释四摄品第七十八之余(卷八十九)

        圣者龙树菩萨造

        后秦龟兹国三藏鸠摩罗什译

【经】云何为八十随形好。一者无见顶。二者鼻直高好孔不现。三者眉如初生月绀琉璃色。四者耳轮埵成。五者身坚实如那罗延。六者骨际如钩锁。七者身一时回如象王。八者行时足去地四寸而印文现。九者爪如赤铜色薄而润泽。十者膝骨坚着圆好。十一者身净洁。十二者身柔软。十三者身不曲。十四者指长纤圆。十五者指文庄严。十六者脉深。十七者踝不现。十八者身润泽。十九者身自持不逶迤。二十者身满足。二十一者识满足。二十二者容仪备足。二十三者住处安无能动者。二十四者威震一切。二十五者一切乐观。二十六者面不大长。二十七者正容貌不挠色。二十八者面具足满。二十九者唇赤如频婆果色。三十者音响深。三十一者脐深圆好。三十二者毛右旋。三十三者手足满。三十四者手足如意。三十五者手文明直。三十六者手文长。三十七者手文不断。三十八者一切恶心众生见者和悦。三十九者面广姝。四十者面净满如月。四十一者随众生意和悦与语。四十二者毛孔出香气。四十三者口出无上香。四十四者仪容如师子。四十五者进止如象王。四十六者行法如鹅王。四十七者头如摩陀罗果。四十八者一切声分具足。四十九者牙利。五十者舌色赤。五十一者舌薄。五十二者毛红色。五十三者毛洁净。五十四者广长眼。五十五者孔门相具足。五十六者手足赤白如莲华色。五十七者赍不出。五十八者腹不现。五十九者细腹。六十者身不倾动。六十一者身持重。六十二者其身分大。六十三者身长。六十四者手足净洁软泽。六十五者边光各一丈。六十六者光照身而行。六十七者等视众生。六十八者不轻众生。六十九者随众生音声不过不减。七十者说法不差。七十一者随众生语言而为说法。七十二者一发音报众声。七十三者次第有因缘说法。七十四者一切众生不能尽观相。七十五者观者无厌足。七十六者发长好。七十七者发不乱。七十八者发旋好。七十九者发色好如青珠。八十者手足有德相。须菩提。是八十随形好。佛身成就如是。须菩提。菩萨摩诃萨以二施摄取众生。所谓财施法施。是为菩萨希有难及事。云何为菩萨摩诃萨爱语摄取众生。菩萨摩诃萨以六波罗蜜为众生说法作是言。汝行六波罗蜜摄一切善法。云何为菩萨摩诃萨利行摄取众生。菩萨摩诃萨长夜教众生令行六波罗蜜。云何为菩萨摩诃萨同事摄取众生。菩萨摩诃萨以五神通力故。种种变化入五道中。与众生同事以此四事而摄取之。复次须菩提。菩萨摩诃萨行般若波罗蜜时教化众生。善男子当善学分别诸字。亦当善知一字乃至四十二字。一切语言皆入初字门。一切语言亦入第二字门乃至第四十二字门。一切语言皆入其中。一字皆入四十二字。四十二字亦入一字。是众生应如是善学四十二字。善学四十二字已。能善说字法。善说字法已。善说无字法。须菩提。如佛善知字法。善知字善知无字。为无字法故说字法。何以故。须菩提。过一切名字故名为佛法。须菩提白佛言。世尊。若众生毕竟不可得。法亦不可得。法性亦不可得。毕竟空故。无始空故。世尊。菩萨摩诃萨行般若波罗蜜。行禅波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀波罗蜜时。行四禅四无量心四无色定三十七助道法十八空。行空无相无作三昧八背舍九次第定佛十力四无所畏四无碍智十八不共法三十二相八十随形好。云何住报得五神通为众生说法。众生实不可得。众生不可得故色不可得。乃至识亦不可得。五众不可得故六波罗蜜乃至八十随形好皆不可得。是不可得中无众生无色。乃至无八十随形好。世尊。云何菩萨摩诃萨行般若波罗蜜为众生说法。世尊。菩萨行般若波罗蜜时。菩萨尚不可得。何况当有菩萨法。佛告须菩提。如是如是。如汝所言。众生不可得故。当知是内空外空内外空空空大空第一义空有为空无为空毕竟空无始空散空诸法空自相空性空不可得空无法空有法空无法有法空。当知五阴空十二入空十八界空十二因缘空四谛空我空寿者命者生者养者育者众数者人者作者使作者起者使起者受者使受者知者见者皆空。众生不可得故。当知四禅空四无量心空四无色定空。当知四念处空乃至八圣道分空。空空无相空无作空八背舍空九次第定空。众生不可得故。当知佛十力空四无所畏空四无碍智空十八不共法空。当知须陀洹果空斯陀含果空阿那含果空阿罗汉果空辟支佛道空。当知菩萨地空。当知阿耨多罗三藐三菩提空。须菩提。菩萨摩诃萨如是见一切法空为众生说法不失诸空相。是菩萨如是观时知一切法无碍。知一切法无碍已不坏诸法相不二不分别。但为众生如实说法。譬如佛所化人。化人复化作无量千万亿人。有教令布施者有教持戒有教忍辱有教精进有教禅定有教智慧。有教四禅四无量心四无色定者。于汝意云何。佛所化人有分别破坏诸法不。须菩提言。不也世尊。是化人无心无心数法。云何分别破坏诸法。以是故。须菩提。当知菩萨摩诃萨行般若波罗蜜。为众生如应说法拔出众生。于颠倒地令众生各得如所应住地。以不缚不脱法故。何以故。须菩提。是色不缚不脱。受想行识不缚不脱。色无缚无脱不是色。受想行识无缚无脱不是识。何以故。色毕竟清净故。受想行识乃至一切法。若有为若无为亦毕竟清净故。如是须菩提。菩萨摩诃萨为众生说法。亦不得众生及一切法。一切法不可得故。菩萨以不住法故住诸法相中。所谓色空乃至有为无为法空。何以故。色乃至有为无为法自性不可得故。无有住处。无所有法不住无所有法。所有法不住所有法。自性法不住自性法。他性法不住他性法。何以故。是一切法皆不可得故。不可得法当住何处。如是须菩提。菩萨摩诃萨行般若波罗蜜。以是诸空能如是说法。如是行般若波罗蜜。于诸佛及声闻辟支佛无有过。何以故诸佛菩萨辟支佛阿罗汉得是法已为众生说法。亦不转诸法相。何以故。如法性实际不可转故。所以者何。诸法性无故。须菩提白佛言。世尊。若法性如实际不转。色与法性异不。色与如实际异不。受想行识乃至有为无为法。世间出世间有漏无漏异不。佛言不也。色不异法性不异如不异实际受想行识乃至有漏无漏亦不异。须菩提白佛言。世尊。若色不异法性不异如不异实际受想行识乃至有漏无漏不异者。云何分别。黑法有黑报。所谓地狱饿鬼畜生。白法有白报。所谓天及人。黑白法有黑白报。不黑不白法有不黑不白报。所谓须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道阿耨多罗三藐三菩提。佛告须菩提。世谛故分别说有果报。非第一义。第一义中不可说因缘果报。何以故。是第一义实无有相。无有分别。亦无言说。所谓色乃至有漏无漏法。不生不灭相。不垢不净毕竟空无始空故。须菩提白佛言。世尊。若以世谛故。分别说有果报。非第一义者。一切凡夫人应有须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道阿耨多罗三藐三菩提。佛告须菩提。于汝意云何。凡夫人为知是世谛法是第一义谛不。若知是凡夫人应是须陀洹果乃至阿耨多罗三藐三菩提。须菩提。以凡夫人实不知世谛不知第一义谛不知道。不知分别道果。云何当有诸果。须菩提。圣人知世谛知第一义谛。有道有修道。以是故圣人差别有诸果。须菩提白佛言。世尊。修道得果不。佛言不也。须菩提。修道不得果。不修道亦不得果。亦不离道得果。亦不住道中得果。如是须菩提。菩萨摩诃萨行般若波罗蜜时。为众生故分别果。亦不分别是有为性无为性。世尊。若不分别有为性无为性得诸果者。云何世尊自说。三结尽名须陀洹果。淫怒痴薄故名斯陀含果。五此间结尽名阿那含果。五彼间结尽名阿罗汉果。所有集法皆灭散相名辟支佛道。一切烦恼习断故名阿耨多罗三藐三菩提。世尊。我当云何知不分别有为性无为性得诸果。佛告须菩提。汝以须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道阿耨多罗三藐三菩提是诸果。是有为是无为。须菩提言。世尊。皆是无为。须菩提。无为法中有分别不。不也世尊。须菩提。若善男子善女人通达一切法。若有为若无为一相所谓无相。是时有分别。若有为若无为不。不也世尊。如是须菩提。菩萨摩诃萨为众生说法不分别诸法。所谓内空故。乃至无法有法空故。是菩萨自得无所著法。亦教人令得无所著法。若檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。初禅乃至第四禅。慈悲喜舍无边虚空处。乃至非有想非无想处。若四念处乃至一切种智。是菩萨自不着故。亦教他令得无所著。无所著故无所碍。譬如佛所化人。布施亦不受布施报。但为度众生故。乃至行一切种智不受一切种智报。菩萨摩诃萨亦如是行六波罗蜜。乃至一切法有漏无漏有为无为不住亦不受报。但为度众生故。何以故。是菩萨摩诃萨善达一切诸法相故

【论】问曰。八十随形好是庄严身法。识满足何以在随形好中。答曰。此识是果报生识。世间好丑自然而知。凡人识不具足故学人法乃知。佛一岁具足满乃生故身识皆具足。余人若八月若九月处胎总言十月。菩萨处胎十月总得一岁。身根具足故果报得识亦具足。问曰。足安立住处与安住处何异。答曰。住处安者。如白衣勇士。牢持器仗安据住处则不可动。又出家时魔民恶鬼无能动转令退败者。四十二字义如摩诃衍中说。一字尽入诸字者。譬如两一合故为二三一故为三四一为四。如是乃至千万。又如阿字为定阿变为罗亦变为波。如是尽入四十二字。四十二字入一字者。四十二字尽有阿分。阿分还入阿中。善知字故善知诸法名。善知诸法名故。善知诸法义。无字即是诸法实相义。所以者何。诸法义中诸法无名字。须菩提问。若诸法毕竟空无名字。云何菩萨住果报六神通。为众生说诸法。若毕竟无众生则无有法。佛可须菩提言。如是以十八空故一切法不可得。我众生乃至知者见者。乃至当知佛菩萨皆空。如是知已而为众生说是空法。若众生是有而为说空是则不可。以众生空但从颠倒有。是故菩萨不失于空而为说法。不失者不作诸法皆空所说不空。若以所说不空则为失空相。若口说空而心是有是亦为失。此中佛自说不二。不坏法相故。欲明了是事说譬喻。如佛所化作化人。而为说法。持戒布施诸功德。若以如是方便说法是则无咎。则能拔出众生于颠倒。无缚无解故。第一义中无缚无解。世谛故有缚有解。此中佛自说因缘。色不缚不解。何以故。是不缚不解中无色相故。乃至识亦如是。菩萨如是用不住法故。住空法中为众生说法。众生不可得。众生及一切法不可得故。此中佛自说因缘。所谓无所有法不住无所有。譬如虚空不住虚空。自性法不住自性法。譬如火不住火中。他性法不住他性法。譬如水性中无火性。又他性不定故。若能如是清净说法。是菩萨于诸佛贤圣则无有过。何以故。诸佛贤圣不着一切法。说法者亦不着一切法。诸佛贤圣以毕竟空皆寂灭相。为心所行说法者亦如是。诸佛贤圣入三解脱门。得一切法实性。所谓无余涅槃。说法者随是法故无咎。此中佛自说因缘。诸佛贤圣得是法已。为众生说法不转法性。法性空无相故。须菩提问。若不转法性。色等诸法与法性异不。佛答不也。何以故。色等诸法实相即是法性故。佛意以菩萨说法时亦不坏法性。须菩提问。色等诸法亦与法性不异。何以故。但贵法性。以佛答色不异法性故。故须菩提难。若不异者云何分别有善恶白黑。须陀洹等诸果。佛答。色等法虽不离法性。以世谛故有分别。于第一义中无分别。何以故。得第一义圣人无所分别。闻有所得不喜闻无所有不忧。得空无相证故。乃至微细法尚不取相。何况分别有善恶。未得实相者欲得第一义故有所分别。佛此中自说因缘。是法无言说。亦无生灭垢净法者。所谓毕竟空无始空。问曰。此中何以但说二空名为法。答曰。一切所有若法若众生。若言毕竟空则破诸法。若言无始空则破众生。破此二法已则一切法尽破。此中菩萨为众生说法。是故以二空破二事。虽有余空。不如毕竟空甚深毕尽。余空如火烧木犹有灰烬。毕竟空无灰无烬。有人言。若说十八空无咎。略说故说二空。须菩提言。若以世谛故。分别有善恶白黑及诸圣果者。第一义中凡夫人应有须陀洹等圣果。何以故。若以世谛虚妄中分别有诸贤圣者。第一义中凡夫应作贤圣。须菩提分别实相凡夫为异。佛言。第一义一相。是故须菩提言。凡夫应是圣人。尔时佛答。若凡夫知分别是第一义是世谛者。凡夫人应有须陀洹等诸圣果。以凡夫实不知道。不知分别道不知行道修道。何况得道果。佛言。圣人能作是分别故说是圣果。尔时须菩提自知有失故。言无量无相无动性中。我云何取相欲量无量法。云何强以凡夫法为圣果。尔时受佛语知行道者得果不行道者不得果。是故白佛修道得果不。佛言不。问曰。佛上说分别修道得道果。今云何言不。答曰。佛先说非着心。今须菩提以着心问。欲从道中出果。如麻中出油。若尔者道之与果同为虚诳。是故言不。听者生念若修不得不修应当得。是故佛言修尚不得。何况不修。譬如二人欲有所到。一者住不行。二道失道二俱不到。若不修道尚无少许摄心乐。何况道果。若心取相修道。虽有摄心禅定乐无有道果。若不取相着心。修道则有道果。是故佛说菩萨行般若波罗蜜。不分别有为无为性故。有道果差别。尔时须菩提问。若尔者佛何以故。说断三结得须陀洹。有如是等分别。佛以反问答。于汝意云何。汝以须陀洹果等是有为是无为。须菩提言是无为。佛言。若尔者无为中有差别不。须菩提言。不也世尊。若无分别汝云何作难。又复问。须菩提。若善男子善女人。通达一切法一相。所谓无相住三解脱门中证涅槃时。是时有法分别若有为若无为不。答言不也。佛意唯是心为真实。余时皆虚诳。汝云何作难。菩萨行般若波罗蜜不分别一切法。住内空等诸空中是大清净。自不着亦教众生令无所著。所谓檀波罗蜜乃至一切种智。菩萨道中皆教令不着。譬如佛所化人。行布施等亦不分别布施等。亦不受布施等法果报。但为利益度众生故。菩萨心亦如是。何以故。善通达诸法性故。善通达者不取法性相亦不住法性中。于法性中不疑不闷而说法。无挂无碍无遮。是则通达法性

    大智度论释善达品第七十九

【经】须菩提白佛言。世尊。云何菩萨善达诸法相。佛告须菩提。譬如化人不行淫怒痴。不行色乃至识。不行内外法。不行诸烦恼结使。不行有漏法无漏法世间法出世间法有为法无为法亦无圣果。菩萨亦如是。无有是事。亦不分别是法是名善达诸法相。须菩提言。世尊。化人云何有修道。佛言化人修道不垢不净。亦不在五道生死。须菩提。于汝意云何。佛所化人有根本实事。有垢有净不。须菩提言不也。佛所化人无有根本实事。亦无垢无净。亦不在五道生死。如是须菩提。菩萨摩诃萨善达诸法相亦如是。须菩提言。世尊。一切色如化不。一切受想行识如化不。佛言。一切色如化。一切受想行识如化。世尊。若一切色如化。一切受想行识如化。一切法如化。化人无色无受想行识。无垢无净无五道生死亦无解脱处。菩萨有何等功用。佛告须菩提。于汝意云何。菩萨摩诃萨本行菩萨道时。颇见有众生从地狱饿鬼畜生人天中得解脱不。须菩提言。不也世尊。佛言。如是如是。须菩提。菩萨摩诃萨不见众生从三界得解脱。何以故。菩萨摩诃萨见知一切法如幻如化。世尊。若菩萨摩诃萨见知一切法如幻如化。为何事故行六波罗蜜四禅四无量心四无色定三十七助道法。乃至行大慈大悲净佛国土成就众生。佛告须菩提。若众生自知诸法如幻如化。菩萨摩诃萨终不于阿僧祇劫为众生行菩萨道。须菩提。以众生自不知诸法如幻如化。以是故菩萨摩诃萨于无量阿僧祇劫行六波罗蜜。成就众生净佛国土。得阿耨多罗三藐三菩提。须菩提白佛言。世尊。若一切法如梦如响如影如焰如幻如化。众生在何处住。菩萨行六波罗蜜而拔出之。须菩提。众生但住名相虚妄忆想分别中。是故菩萨行般若波罗蜜。于名相虚妄中拔出众生。须菩提白佛言。世尊。何等是名何等是相。佛言此名强作假施设。所谓此色此受想行识。此男此女。此大此小。此地狱此畜生此饿鬼此人此天。此有为此无为。此须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道此佛道。须菩提。一切和合法皆是假名。以名取诸法。是故为名。一切有为法但有名相。凡夫愚人于中生着。菩萨摩诃萨行般若波罗蜜。以方便力故于名字中教令远离。作是言。诸众生是名但有空名。虚妄忆想分别中生。汝等莫着虚妄忆想。此事本末皆无自性空故。智者所不着。如是须菩提。菩萨摩诃萨行般若波罗蜜。以方便力故为众生说法。须菩提是为名。何等为相。须菩提有二种相。凡夫人所著处。何等为二。一者色相。二者无色相。须菩提。何等名色相。诸所有色若粗若细若好若丑皆是空。是空法中忆想分别着心是名为色相。何等是无色相。诸无色法忆想分别着心取相故生烦恼。是名无色相。是菩萨摩诃萨行般若波罗蜜。以方便力故教众生远离是相。着无相法中令不堕二法。所谓是相是无相。如是须菩提。菩萨摩诃萨行般若波罗蜜。教化众生远离相令住无相性中。须菩提白佛言。世尊。若一切法但有名相。云何菩萨行般若波罗蜜。能自饶益亦教他人令得善利。云何菩萨具足诸地。从一地至一地。教化众生令得三乘。佛告须菩提。若诸法根本定有非但名相者。菩萨行般若波罗蜜时。不能自益亦不能利益他人。须菩提。诸法无有根本实事。但有名相。是故菩萨行般若波罗蜜时。能具足禅波罗蜜。无相故。毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀波罗蜜。无相故。具足四禅波罗蜜四无量心波罗蜜四无色定波罗蜜。无相故。具足四念处波罗蜜。无相故。乃至具足八圣道分波罗蜜。无相故。具足内空波罗蜜。无相故。乃至具足无法有法空波罗蜜。无相故。足具八背舍波罗蜜。无相故。具足九次第定波罗蜜。无相故。具足佛十力波罗蜜。无相故。乃至具足十八不共法波罗蜜。无相故。是菩萨无相故自具足是善法。亦教他人令具足善法。无相故。须菩提若诸法相。当实有如毫厘许者。菩萨摩诃萨行般若波罗蜜时不能知诸法。无相无忆念得阿耨多罗三藐三菩提。亦教众生令得无漏法。何以故。一切无漏法无相无忆念故。如是须菩提。菩萨摩诃萨行般若波罗蜜。以无漏法利益众生。须菩提白佛言。世尊。若一切法无相无忆念。云何数是声闻法是辟支佛法是菩萨法是佛法。佛告须菩提。于汝意云何。无相法与声闻法异不。不也世尊。无相法与辟支佛法菩萨法佛法异不。不也世尊。佛告须菩提。无相法即是须陀洹果斯陀含果阿那含果阿罗汉果辟支佛法菩萨法佛法。须菩提言。如是世尊。须菩提。以是因缘故当知一切法皆是无相。须菩提。菩萨摩诃萨学是一切法无相得增益善法。所谓六波罗蜜四禅四无量心四无色定四念处乃至十八不共法。何以故。菩萨不以余法为要。如三解脱门。所谓空无相无作。所以者何。一切善法。皆入三解脱门。何以故。一切法自相空是名空解脱门。一切法无相。是名无相解脱门。一切法无作无起相。是名无作解脱门。若菩萨摩诃萨学三解脱门。是时能学五阴相。能学十二入相。能学十八界相。能学四圣谛十二分因缘法。能学内空外空乃至无法有法空。能学六波罗蜜四念处乃至八圣道分。能学佛十力四无所畏四无碍智十八不共法。须菩提白佛言。世尊。云何菩萨摩诃萨行般若波罗蜜。能学五受阴相。佛告须菩提。菩萨行般若波罗蜜。知色相知色生灭知色如。云何知色相。知色毕竟空。内分异虚无实。譬如水沫无坚固。是为知色相。云何知色生灭。色生时无所从来。去无所至。若不来不去是为知色生灭相。云何知色如。是色如不生不灭不来不去不增不灭不垢不净。是为知色如。须菩提。如名如实不虚。如前后中亦尔常不异。是为知色如。云何知受相。云何知受生灭。云何知受如。菩萨知诸受相如。水中泡一起一灭。是为知受相。知受生灭者。是受无所从来去无所至。是为知受生灭。知受如者。是如不生不灭不来不去不增不减不垢不净是为知受如。云何知想相。云何知想生灭。云何知想如。知想相者。是想如焰水。不可得而妄生水想。是为知想相。知想生灭者。是想无所从来去无所至。是为知想生灭。知想如者。诸想如不生不灭不来不去不增不减不垢不净不转于实相。是为知想如。云何知行相。云何知行生灭。云何知行如。知行相者。行如芭蕉叶叶除却不得坚实。是为知行相。知行生灭者。诸行生无所从来去无所至。是为知行生灭。知行如者。诸行不生不灭不来不去不增不减不垢不净。是为知行如。云何知识相。云何知识生灭。云何知识如。知识相者。如幻师幻作四种兵。无有实识亦如是。知识生灭者。是识生时无所从来灭时无所去。是为知识生灭。知识如者。知识不生不灭不来不去不垢不净不增不减。是为知识如。云何知诸入。眼眼性空。乃至意意性空。色色性空。乃至法法性空。云何知界。眼眼界空。色色界空。眼识眼识界空。乃至意识界亦如是。云何知四圣谛。知苦圣谛时远离二法。知苦圣谛不二不别。是名苦圣谛。集灭道亦如是。云何知苦如。苦圣谛即是如。如是苦圣谛。集灭道亦如是。云何知十二因缘。知十二因缘不生相。是名知十二因缘。须菩提白佛言。世尊。若菩萨摩诃萨行般若波罗蜜时。各各分别知诸法。将无以色性坏法性乃至一切种智性坏法性耶。佛告须菩提。若法性外更有法者。应坏法性。法性外法不可得。是故不坏。何以故。须菩提。佛及佛弟子。知法性外法不可得故。不说法性外有法。如是须菩提。菩萨摩诃萨行般若波罗蜜应学法性。须菩提白佛言。世尊。菩萨摩诃萨若学法性为无所学。佛告须菩提。菩萨摩诃萨若学法性则学一切法。何以故。一切法即是法性。须菩提白佛言。世尊。何因缘故一切法即是法性。佛言。一切法皆入无相无为性中。以是因缘故学法性则学一切法。须菩提白佛言。世尊。若一切法即是法性。菩萨摩诃萨何以学般若波罗蜜禅波罗蜜毗梨耶波罗蜜羼提波罗蜜尸罗波罗蜜檀波罗蜜。菩萨摩诃萨何以学初禅第二第三第四禅。菩萨摩诃萨何以学慈悲喜舍。何以学无边虚空处无边识处无所有处非有想非无想处。何以学四念处四正勤四如意足五根五力七觉分八圣道分。何以学空无相无作解脱门。何以学八背舍九次第定佛十力四无所畏四无碍智十八不共法。何以学六神通。何以学三十二相八十随形好。何以学生刹利大姓婆罗门大姓居士大家。何以学生四天王天处三十三天夜摩天兜率陀天化乐天他化自在天。何以学生梵天王住处光音天遍净天广果天无想定净居天。何以学生无边空处生无边识处生无所有处生非有想非无想处。何以学初发意地第二第三第四第五第六第七第八第九第十地。何以学声闻地辟支佛地菩萨法位。何以学成就众生净佛国土。何以学诸陀罗尼。何以学乐说法。何以学阿耨多罗三藐三菩提。学已得一切种智知一切法。世尊。诸法法性中无是分别。世尊。将无菩萨堕非道中。何以故。世尊法性中无如是分别。法性中无色无受想行识。诸法性亦不远离色受想行识。色即是法性。法性即是色。受想行识亦尔。一切法亦如是。佛告须菩提如是如是。如汝所言。色即是法性。受想行识即是法性。须菩提。菩萨摩诃萨行般若波罗蜜时。若法性外见有法者。为不求阿耨多罗三藐三菩提。菩萨摩诃萨行般若波罗蜜时。知一切法性即是阿耨多罗三藐三菩提。以是故菩萨摩诃萨行般若波罗蜜时。知一切法即是法性。已以无名相之法以名相说。所谓是色是受想行识。乃至是阿耨多罗三藐三菩提。须菩提譬如工幻师若幻师弟子多人处立幻作种种形色男女象马端严园林。及诸卢馆流泉浴池衣服卧具香华璎珞肴膳饮食。作众伎乐以乐众人。又复幻作人。令布施持戒忍辱精进禅定修智慧。是幻师复幻作刹利大姓婆罗门大姓居士大家四天王天处须弥山三十三天夜摩天兜率陀天化乐天他化自在天以示众人。复幻作梵众天乃至非有想非无想天。复幻作须陀洹斯陀含阿那含阿罗汉辟支佛。菩萨摩诃萨从初发意行檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。行初地乃至行十地入菩萨位。游戏神通成就众生净佛国土。游戏诸禅解脱三昧。行佛十力四无所畏四无碍智十八不共法大慈大悲。具足佛身三十二相八十随形好以示众人。是中无智之人叹未曾有。是人多能巧为众事娱乐众人。种种形色乃至三十二相八十随形好庄严佛身。其中有智之士思惟言未曾有也。是中无有实事。而以无所有法娱乐众人令有形相。无事事相无有有相。如是须菩提。菩萨摩诃萨不见离法性有法行般若波罗蜜。以方便力故虽不得众生而自布施。亦教人布施。赞叹布施法。欢喜赞叹行布施者。自持戒亦教人持戒。自忍辱亦教人忍辱。自精进亦教人精进。自行禅亦教人行禅。自修智慧亦教人修智慧。赞叹修智慧法欢喜赞叹修智慧者。自行十善亦教人行十善。赞叹行十善法。欢喜赞叹行十善者。自受行五戒亦教他人受行五戒。赞叹五戒法。欢喜赞叹受行五戒者。自受八戒斋亦教他人受八戒斋。赞叹八戒斋法。欢喜赞叹行八戒斋者。自行初禅乃至自行第四禅。自行慈悲喜舍。自行无边空处乃至非有想非无想处。亦教他人行。自行四念处乃至八圣道分。自行三解脱门佛十力。乃至自行十八不共法。亦教他人行十八不共法。赞叹十八不共法欢喜赞叹行十八不共法者。须菩提。若法性前后中有异者。是菩萨摩诃萨不能以方便力示法性成就众生。须菩提。以法性前后中无异。是故是菩萨行般若波罗蜜。为利益众生故行菩萨道

【论】问曰。佛品品中说通达诸法相。今须菩提。何以更问。答曰。是般若波罗蜜无一定相。无言说故虽数闻犹未足具故更问。譬如犊子虽大善母美乳饮犹不止。佛大慈悲犹如善母。般若波罗蜜如美乳。须菩提如犊子。虽数闻诸法相犹未厌足。复次唯佛一切智能通达诸法实相。余人虽达不能究尽。是故问余菩萨未作佛。云何能通达。佛以譬喻答。如幻化人。无三毒诸烦恼结使。无心心数法。内外有漏无漏法中所不摄。不堕凡夫法亦不堕圣果中。不得言是须陀洹等亦能发他心善恶。所为变化事必能令成就。此变化其实不垢不净。六道所不摄。菩萨身亦如是。无三毒等烦恼。知是心心数法。皆是先世虚诳颠倒法。因缘生故不信不随。逐能如是行。是为善通达诸法相。是时须菩提。虽善知空以贵敬尊重佛法不能限量佛法故问佛。世尊。一切色等法皆空如化耶。佛答。一切色等法皆如化。汝贵重佛法故不敢言空。我以一切智故。能说诸法空。如余人贵师子力师子自不贵其力。尔时须菩提言。若一切法毕竟空皆如化。佛何以种种赞菩萨功德。因菩萨故断三恶道。能拔出众生令得涅槃。佛反问。须菩提。于汝意云何。菩萨本行菩萨道时。见定有众生从五道中拔出不。须菩提言无也。佛可其意如是如是。何以故。菩萨得无生法忍时。知见一切法如幻如化。须菩提言。若尔者菩萨以何事故行六波罗蜜等。佛答。若众生自知诸法空如幻。菩萨则无功夫。复次若诸法决定空相。则菩萨无功夫。令诸法非实非空。过诸语言道毕竟空寂灭相。众生不知是事故。生吾我心起恶罪业受无量苦。是故菩萨知诸法实相生大悲心。如长者有子盲而饮毒。长者知其必死起种种方便遮令不饮。菩萨亦如是。见是众生颠倒无明。盲故饮三毒则生大悲心。于无量阿僧祇劫修六波罗蜜。净佛国土教化众生。须菩提闻是已更白佛言。世尊。若一切法空无根本如梦如幻等。众生在何处住而菩萨拔出。须菩提意。谓如人没深泥而得拔出。佛答。众生但住名相虚诳忆想分别中。佛意一切法中无决定实者。但凡夫虚诳故着。如人闇中见似人物谓是实人而生畏怖。又如恶狗临井自吠其影水中无狗但有其相而生恶心投井而死。众生亦如是。四大和合故名为身。因缘生识和合故动作言语。凡夫人于中起人相。生爱生恚起罪业堕三恶道。菩萨行般若波罗蜜时。怜愍众生种种因缘教化。令知空法而拔出之。作是言是法皆毕竟空无所有。众生颠倒虚妄故见似如有如化如幻如乾闼婆城无有实事。但诳惑人眼。复次一切法但从名字和合。更有余名。如头足腹脊和合故假名为身。如发眼耳鼻口皮骨和合故假名为头。诸毛和合故名为发。分分和合故假名为毛。诸微尘和合故名为毛分。亦和合诸分故名为微尘。问曰。微尘第一微细故。不得作分。无分故无和合。此则定法。是故不得言一切空无有定法。答曰。若微尘是色则应有分。何以故。一切色皆在虚空中。皆有十方。若微尘是色则有十分。若有十分云何是极微。若如汝说微尘无分者则非色。何以故。出色相故。又复色名五情可得。若微尘非五情所得者。云何得知是色。是故微尘但有虚名。眼见粗色尚可破令空。何况不可见不可触。问曰。微尘细故五情所不能得。圣人得天眼则见。答曰。天眼见虽细是色相故应当有分。若无分则非色。非色则天眼不见。以是故天眼亦虚诳妄见。是故圣人以慧眼观世间则得道。微尘如先说。但有名无实。微尘无故一切法名字和合故。更有假名无有实定。而众生妄生贪着。贪欲嗔恚因缘故起恶业。无量阿僧祇劫在三恶道受苦。若诸法实定尚不应作贪欲嗔恚罪因缘。何况虚诳无实。若能舍虚诳名相不着空法者。则受涅槃常乐

问曰。名相有何差别。答曰。名者是众物字。如热物字为火。相者如见烟知是火相。热是火体。复次如五众和合中男女。是为名身貌可别男女是为相。见是相故作名字名为男女。问曰。若尔者名相无异。所以者何。见相故得名。知名故得相。答曰。汝不解我所说耶。先见男女貌。然后名为男女。相为本名为末。又复如人眼见色。偏取所好相而生着。于余人则不然。以其能生染着心是名为相。复次此中佛自说名相分别。名者假名以名取诸法。如经中广说。须菩提问。若一切法但有名相。菩萨云何自利利人。佛答。若诸法根本定有。菩萨行般若波罗蜜时。不能自利利人。何以故。若诸法性定实有即是无生。何以故。以性先定有故。若是法从因缘和合生。即是无定性。若性定有则不须因缘和合。若尔者则无生。无生故无灭。无灭故无罪福。以知无常故则舍罪修福。若常则无缚解无世间无涅槃等。是故佛告须菩提。若法定有非但名相者。菩萨不行般若波罗蜜自利利人。不行禅波罗蜜等自利利人。无相故。是菩萨自具足是善法。亦以善法利益众生以无相故。佛告须菩提。若诸法当实有如毫厘许。菩萨坐道场时。不能观一切法空无相无所有得成阿耨多罗三藐三菩提。亦不能以此法利益众生。何以故。是菩萨坐道场时。观一切法第一真实。若小错不应得阿耨多罗三藐三菩提。亦不能为众生说是空无相法。所以者何。法若定有。佛云何诳众生。一切法无漏无相无忆念。问曰。四谛中三谛皆有相。苦谛则有苦相。集谛则有集相。道谛则有道相。唯灭谛无相。亦有忆念是无相涅槃。汝何以言一切无漏法无相无忆念。答曰。摩诃衍法与声闻法异。摩诃衍法中说一切无漏法无相无忆念。复次有相有忆念。皆是虚诳不实。若虚诳不实。即是诸烦恼漏。云何是无漏。复次是三谛皆随灭谛。见苦即舍。见集即断。不言实定见道为趣灭故。亦不住是道中灭尽是主。是灭尽法无相无缘。云何有忆念。忆念皆是缘相着法。是故无漏法皆无相无忆念。须菩提意。若无漏法是第一实无相无忆念。一切法性亦应无相无忆念。但凡夫颠倒故有相有忆念。是故问佛。若一切法无相无忆念。云何数是声闻法是辟支佛法是菩萨法是佛法。佛反问须菩提。三乘法与无相法异不。须菩提答曰。诸烦恼灭即是断。断即是无为法。亦知灭道谛即是无漏无相。是故言三乘不异无相法。佛复问。须陀洹乃至佛不即是无相法耶。答言。是以是因缘故当知一切法皆是无相。若无相汝云何难言有诸道。正以无相故有三乘诸道。佛言。若菩萨能如是学无相法。则能增益诸善法。所谓六波罗蜜乃至十八不共法。此中佛自说因缘。菩萨唯住三解脱门。不以余法为要。所以者何。三解脱门是实法。余四念处等法虽实皆方便说。三解脱门近涅槃。亦能摄一切实善法。是故说菩萨应学。问曰。若菩萨学是三解脱门。即学五众十二入十八界等。是三解脱门皆空无相无分别。是五众诸法皆是有相有分别法。云何学三解脱门故学是余法。答曰。菩萨学是三解脱门。则出三界尽三漏故。于诸法中得实智慧无所不通。先来五众中皆虚妄邪行。今得此三解脱门故得正通达。此中佛自说因缘。菩萨行是三解脱门无相法时。知色生知色灭知色如。乃至识亦尔。如经中广说。须菩提复问。如佛所言。菩萨知色等相。知色等生。知色等灭。知色等如。若如是分别将无色性坏法性耶。佛答。若有法出法性者。色性应坏法性。一切法实相名为法性。是故一切法皆入法性中。色性实相即是法性同一性。云何色性能坏法性。佛更说因缘。诸佛贤圣不见出法性更有法者。不得故不说。诸佛贤圣最可信者。菩萨应如是学法性。须菩提白佛。若菩萨学法性是为无所学。所以者何。法性无性故。佛答。法性无性者。若菩萨学法性为学一切法。若法性当别有性。若无性是性。应但学法性不学一切法。今法性实无别性。亦无无性故。遍学一切法。但诸法实相是法性。是故得实相则正遍学一切法。尔时须菩提白佛。世尊。若一切法即是法性。菩萨摩诃萨以何等故学六波罗蜜乃至陀罗尼门。何以故。诸法实相即是法性。若一切法即是法性。菩萨更何所求。复次法性中无分别是六波罗蜜乃至陀罗尼。今菩萨分别行是法将无堕颠倒中耶。佛可须菩提意而答。若菩萨出法性见有法者。不求阿耨多罗三藐三菩提。何以故。出法性有法者是常颠倒。无明不可转令实。云何断一切法中无明得作佛。菩萨知一切法即是毕竟空常寂灭相。无戏论无名字怜愍众生。以方便力故以名相说。所谓是色是受想行识乃至阿耨多罗三藐三菩提。如经中所说幻喻。幻师即是菩萨。幻法即是六波罗蜜等诸法。虽行是诸法无著心如幻师虽幻作种种物知其无实而不着。智者是佛及大菩萨。无智者凡夫人及新发意。而大欢喜叹未曾有。菩萨行菩萨道虽出法性更不见有法亦不见有一定众生。而大利益自身及众生。如经中说。是菩萨自行布施等。亦教他人赞叹布施法。欢喜赞叹行布施者。乃至十八不共法亦如是。此中佛自说因缘。若法性先无后有。菩萨不能得阿耨多罗三藐三菩提。亦不能以方便力说。所以者何。若法性先无后有。从因缘生者则与凡夫共法无异。若法性先有后无。众生及诸法则堕断灭。以诸法性先空中后亦尔。非智慧力故令空。众生及诸法非以入无余涅槃时乃空。从本已来常空。菩萨教众生。何以不观其实性而着颠倒。若观诸法毕竟空性者。则知从本已来常空今无所失。如是行般若波罗蜜菩萨。则能祐利众生

大智度论卷第八十九大智度论释实际品第八十(卷九十)

        圣者龙树菩萨造

        后秦龟兹国三藏鸠摩罗什译

【经】须菩提白佛言。世尊。若众生毕竟不可得。菩萨为谁故行般若波罗蜜。佛告须菩提。菩萨为实际故行般若波罗蜜。须菩提实际众生际异者。菩萨不行般若波罗蜜。须菩提实际众生际不异。以是故菩萨摩诃萨为利益众生故行般若波罗蜜。复次须菩提。菩萨摩诃萨行般若波罗蜜时。以不坏实际法立众生于实际中。须菩提白佛言。世尊。若实际即是众生际。菩萨则为建立实际于实际。世尊。若建立实际于实际。则为建立自性于自性。世尊。不得建立自性于自性。世尊。云何菩萨摩诃萨行般若波罗蜜时。建立众生于实际。佛告须菩提。实际不可建立于实际。自性不可建立于自性。须菩提。今菩萨摩诃萨行般若波罗蜜时。以方便力故建立众生于实际。实际亦不异众生际。实际众生际无二无别。须菩提。白佛言。世尊。何等是诸菩萨摩诃萨方便力用是方便力菩萨摩诃萨行般若波罗蜜时。建立众生于实际。亦不坏实际相。佛告须菩提。若菩萨摩诃萨行般若波罗蜜时。以方便力故建立众生于布施。建立已说布施先后际相。作是言如是布施。前际空后际空。中际亦空施者亦空。施报亦空受者亦空。诸善男子是一切法实际中不可得。汝等莫念布施异施者异施报异受者异。若汝等不念布施异施者异施报异受者异。是时布施能取甘露味得甘露味果。汝善男子以是布施故莫着色。莫着受想行识。何以故。是布施布施相空。施者施者空。施报施报空。受者受者空空中布施不可得。施者不可得。施报不可得。受者不可得。何以故。是诸法毕竟自性空故。复次须菩提。菩萨摩诃萨行般若波罗蜜时。以方便力故教众生持戒。语众生言。汝善男子除舍杀生法。乃至除舍邪见。何以故。善男子如汝所分别法。是诸法无如是性。汝善男子当谛思惟。何等是众生而欲夺命。用何等物夺命。乃至邪见亦如是。须菩提。菩萨摩诃萨如是方便力成就众生。是菩萨摩诃萨即为众生说布施持戒果报。是布施持戒果报自性空。知布施持戒果报自性空已是中不着。不着故心不散能生智慧。以是智慧断一切结使烦恼入无余涅槃。是世俗法非第一实义。何以故。空中无有灭亦无使灭者。诸法毕竟空即是涅槃。复次须菩提。菩萨摩诃萨见众生嗔恚恼心。教言。汝善男子来修行忍辱。作忍辱人当乐忍辱。汝所嗔者自性空故。汝来善男子如是思惟。我于何所法中嗔。谁为嗔者。所嗔者谁。是法皆空是性空法。无不空时。是空非诸佛作。非辟支佛声闻作。非菩萨摩诃萨作。非诸天鬼神龙王阿修罗紧那罗摩睺罗伽。非四天王天。乃至非他化自在天。非梵众天。乃至非净居天。非无边空处。乃至非有想非无想处诸天所作。汝当如是思惟。所嗔谁。谁是嗔者。何等是嗔事。是一切法性空。性空法中无有所嗔。如是须菩提。菩萨摩诃萨行般若波罗蜜时。以是因缘建立众生于性空。次第渐渐示教利喜令得阿耨多罗三藐三菩提。是世俗法非第一实义。何以故。是性空中无有得者无有得法无有得处。须菩提。是名实际性空法。菩萨摩诃萨为众生故行是法。众生亦不可得。何以故。一切法离众生相。复次须菩提。菩萨摩诃萨行般若波罗蜜时。方便力故见众生懈怠教令身精进心精进。作是言。诸善男子诸法性空中。无懈怠法无懈怠者无懈怠事。是一切法性皆空无过性空者。汝等生身精进心精进。为生善法故莫懈怠。善男子若布施若持戒若忍辱若精进若禅定若智慧。若诸禅定解脱三昧。若四念处乃至八圣道分。若空解脱门无相无作解脱门。乃至十八不共法中莫懈怠。诸善男子是一切法性空中。当知无碍相。无碍法中无懈怠者无懈怠法。如是须菩提。菩萨摩诃萨行般若波罗蜜时。教众生令住性空不堕二法。何以故。是性空无二无别故。是无二法则无可嗔处。复次须菩提。菩萨摩诃萨行性空般若波罗蜜时。教众生令精进。作是言。诸善男子勤精进。若布施若持戒若忍辱若精进若禅定若智慧若禅定解脱三昧若四念处乃至八圣道分。若空解脱门无相无作解脱门若佛十力。若四无所畏。若四无碍智。若十八不共法。若大慈大悲是诸法汝等莫念二相。莫念不二相。何以故。是法性皆空。是性空法不应用二相念。不应用不二相念。如是须菩提。菩萨摩诃萨行般若波罗蜜。以方便力故成就众生。成就众生已。次第教令得须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道菩萨位。令得阿耨多罗三藐三菩提。复次须菩提。菩萨摩诃萨行般若波罗蜜时。见众生乱心以方便力为利益众生故。作是言。诸善男子当修禅定。汝莫生乱想。当生一心。何以故。是法性皆空性。空中无有法可得。若乱若一心。汝等住是三昧。所有作业若身若口若意若布施若持戒若行忍辱若勤精进若行禅定若修智慧。若行四念处。乃至若行八圣道分。若诸解脱次第定。若行佛十力四无所畏四无碍智十八不共法大慈大悲三十二相八十随形好。若声闻道若辟支佛道若菩萨道若佛道。若须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道。若一切种智。若成就众生。若净佛国土。汝等皆当应随所愿得。行性空故。如是须菩提。若菩萨摩诃萨行般若波罗蜜方便力。为利益众生故。从初发意终不懈废。常求善法利益众生。从一佛国至一佛国。供养诸佛。从诸佛闻法。舍身受身乃至阿耨多罗三藐三菩提终不忘失。是菩萨常得诸陀罗尼诸根具足。所谓身根语根意根。何以故。是菩萨摩诃萨常修一切种智。修一切种智故一切诸道皆修。若声闻道若辟支佛道若菩萨神通道。行神通道菩萨常利益众生终不忘失。是菩萨住报得神通利益众生入生死五道终不耗减。如是须菩提。菩萨摩诃萨行般若波罗蜜住性空。以禅定利益众生。复次须菩提。菩萨摩诃萨行般若波罗蜜住性空。以方便力故利益众生。作是言。汝等诸善男子观一切法性空。善男子。汝等当作诸业若身业若口业若意业。取甘露味得甘露果。性空中无有法退。何以故。性空不退亦无退者。以性空非法亦非非法于无所有法中。云何当有退须菩提。菩萨摩诃萨行般若波罗蜜时。如是教众生常不懈废。是菩萨自行十善亦教他人行十善。五戒八戒亦如是。自行初禅亦教他人令行初禅。乃至第四禅亦如是。常自行慈心亦教他人令行慈心。乃至舍心亦如是。自行无边空处。亦教他人令行无边空处。乃至非有想非无想处亦如是。自行四念处亦教他人令行四念处。乃至八圣道分佛十力乃至八十随形好亦如是。自于须陀洹果中生智慧。亦不住是中。亦教他人令得须陀洹果。乃至阿罗汉果亦如是。自于辟支佛道中生智慧。亦不住是中亦教他人令得辟支佛道。自生阿耨多罗三藐三菩提道。亦教他人令得阿耨多罗三藐三菩提道。如是须菩提。菩萨摩诃萨行般若波罗蜜方便力故终不懈怠。须菩提白佛言。世尊。若诸法性常空。常空中众生不可得。法非法亦不可得。菩萨摩诃萨云何求一切种智。佛告须菩提如是如是。如汝所言。诸法性皆空。空中众生不可得。法非法亦不可得。须菩提。若一切法性不空。菩萨摩诃萨不依性空成阿耨多罗三藐三菩提。为众生说性空法。须菩提。色性空受想行识性空。菩萨摩诃萨行般若波罗蜜时。说五阴性空法。说十二入十八界性空法。说四禅四无量心四无色定四念处乃至八圣道分性空法。说三解脱门八背舍九次第定佛十力四无所畏四无碍智十八不共法大慈大悲三十二相八十随形好性空法。说须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道一切种智。断烦恼习性空法。须菩提。若内空性不空外空乃至无法有法空性不空者则坏空性。是性空不常不断。何以故。是性空无住处。亦无所从来亦无所从去。须菩提。是名法住相。是中无法无聚无散无增无减无生无灭无垢无净。是为诸法相。菩萨摩诃萨在是中发阿耨多罗三藐三菩提心。不见法有所发。无发无住是名法住相。是菩萨摩诃萨行般若波罗蜜时。见一切法性空不转阿耨多罗三藐三菩提。何以故。是菩萨不见有法能障碍。当何处生疑。是名阿耨多罗三藐三菩提性空。不得众生不得我不得人不得寿不得命。乃至不得知者见者。性空中色不可得。受想行识不可得。乃至八十随形好不可得。须菩提。譬如佛化作四众比丘比丘尼优婆塞优婆夷。常为是诸众说法。千万亿劫不断。佛告须菩提。是诸化众当得须陀洹果斯陀含果阿那含果阿罗汉果。得阿耨多罗三藐三菩提记不。须菩提言。不也世尊。何以故。是诸化众无有根本实故。一切诸法性空亦无根本实事。何等是众生得须陀洹果乃至阿罗汉果。得阿耨多罗三藐三菩提记。须菩提。菩萨摩诃萨亦如是。为众生说性空法。是众生实不可得。以众生堕颠倒故。拔众生令住不颠倒。颠倒即是无颠倒。颠倒不颠倒。虽一相而多颠倒少不颠倒。无颠倒处中则无我无众生。乃至无知者见者。无颠倒处中。亦无色无受想行识无十二入。乃至无阿耨多罗三藐三菩提。是为诸法性空。菩萨摩诃萨住是中行般若波罗蜜时。于众生相颠倒中拔出众生。所谓无众生有众生相中拔出。乃至知者见者相中拔出。于无色色相中无受想行识。受想行识相中拔出众生。十二入十八界乃至一切有漏法亦如是。须菩提。亦有诸无漏法。所谓四念处四正勤四如意足五根五力七觉分八圣道分。如是等法虽无漏亦不如第一义相。第一义相者无作无为无生无相无说。是名第一义。亦名性空亦名诸佛道。是中不得众生。乃至不得知者见者。不得色受想行识。乃至不得八十随形好。何以故。菩萨摩诃萨非为道法故。求阿耨多罗三藐三菩提心。为诸法实相性空故求阿耨多罗三藐三菩提。是性空前际亦是性空。后际亦是性空。中际亦是性空。常性空无不性空时。菩萨摩诃萨行是性空般若波罗蜜。为众生着众生相。欲拔出故求道种智。求道种智时遍行一切道。若声闻道若辟支佛道若菩萨道。是菩萨具足一切道拔出众生于邪想着。净佛国土已。随其寿命得阿耨多罗三藐三菩提。须菩提。过去十方诸佛道性空。未来现在十方诸佛道亦性空。离性空世间无道无道果。要从亲近诸佛闻是诸法性空行是法不失萨婆若。须菩提白佛言。世尊。甚希有。诸菩萨摩诃萨行是性空法亦不坏性空相。所谓色与性空异。受想行识与性空异。乃至阿耨多罗三藐三菩提与性空异。世尊但色即是性空。性空即是色。乃至阿耨多罗三藐三菩提。阿耨多罗三藐三菩提即是性空。性空即是阿耨多罗三藐三菩提。佛告须菩提如是如是。若色与性空异。若受想行识与性空异。乃至阿耨多罗三藐三菩提与性空异。菩萨摩诃萨不能得一切种智。须菩提。今色不异性空。乃至阿耨多罗三藐三菩提不异性空。以是故。菩萨摩诃萨知一切法性空。发意求阿耨多罗三藐三菩提。何以故。是中无有法若实若常。但凡夫着色受想行识。凡夫取色相取受想行识相。有我心着内外物故。受后身色受想行识。是故不得脱生老病死愁忧苦恼往来五道。以是事故。菩萨摩诃萨行性空波罗蜜。不坏色等诸法相若空若不空。何以故。是色性空相不坏色。所谓是色是空。譬如虚空不坏虚空。内虚空不坏外虚空。外虚空不坏内虚空。如是须菩提色不坏色空相。色空相不坏色。何以故。是二法无有性。能有所坏。所谓是空是非空。乃至阿耨多罗三藐三菩提亦如是。须菩提白佛言。世尊。若一切法空无分别。云何菩萨摩诃萨从初发意已来作是愿。我当得阿耨多罗三藐三菩提。世尊。若一切法无分别。云何菩萨发心言。我当得阿耨多罗三藐三菩提。世尊。若分别诸法不能得阿耨多罗三藐三菩提。佛告须菩提如是如是。若菩萨摩诃萨行二相者。无阿耨多罗三藐三菩提。若分别作二分者。无阿耨多罗三藐三菩提。若不二不分别。诸法则是阿耨多罗三藐三菩提。菩提是不二相不坏相。须菩提。是菩提不色中行。不受想行识中行。乃至菩提亦不菩提中行。何以故。色即是菩提。菩提即是色不二不分别。乃至十八不共法亦如是。是菩提非取故行非舍故行。须菩提白佛言。世尊。若菩萨摩诃萨。菩提非取故行非舍故行。菩萨摩诃萨菩提何处行。佛告须菩提。于汝意云何。如佛所化人。在何处行。若取中行若舍中行。须菩提言。世尊。非取中行非舍中行。佛言。菩萨摩诃萨菩提亦如是。非取中行非舍中行。须菩提。于汝意云何。阿罗汉梦中菩提何处行。若取中行若舍中行。不也世尊。非取中行非舍中行。世尊。阿罗汉毕竟不眠。云何梦中菩提。若取中行若舍中行。须菩提。菩萨摩诃萨阿耨多罗三藐三菩提亦如是。非取中行非舍中行。所谓色中行乃至一切种智中行。世尊将无菩萨摩诃萨。不行十地不行六波罗蜜。不行三十七助道法。不行十四空。不行诸禅定解脱三昧。不行佛十力乃至八十随形好。住五神通净佛国土成就众生。得阿耨多罗三藐三菩提。佛告须菩提如是如是。如汝所言。今菩萨虽菩提无处行。若不具足十地六波罗蜜四禅四无量心四无色定四念处乃至八圣道分空无相无作解脱佛十力乃至八十随形好。常舍法不错谬法。不具足是诸法。终不得阿耨多罗三藐三菩提。是菩萨摩诃萨住色相中住受想行识相中乃至住阿耨多罗三藐三菩提相中。能具足十地。乃至得阿耨多罗三藐三菩提。是相常寂灭无有法能增能减能生能灭能垢能净能得道能得果。世谛法故。菩萨摩诃萨得阿耨多罗三藐三菩提。非第一实义。何以故。第一实义中无有色。乃至无有阿耨多罗三藐三菩提。亦无行阿耨多罗三藐三菩提者。是一切法皆以世谛故说。非第一义。须菩提。菩萨摩诃萨从初发意已来。行阿耨多罗三藐三菩提。菩提亦不增众生亦不减。菩萨亦无增减。须菩提于意云何。若人初得道时。住无间三昧。得无漏根。若成就须陀洹果斯陀含果阿那含果阿罗汉果。汝尔时有所得若梦若心若道若道果不。须菩提言。世尊。不得也。佛告须菩提。云何当知得阿罗汉道者。世尊。世谛法故分别名阿罗汉道。佛语须菩提。世谛故说名菩萨。说名色受想行识。乃至一切种智。是菩提中无法可得若增若减。以诸法性空故。诸法性空尚不可得。何况得初地心乃至十地心。六波罗蜜三十七助道法空三昧无相无作三昧。乃至一切佛法。当有所得。无有是处。如是须菩提。菩萨摩诃萨行阿耨多罗三藐三菩提。得阿耨多罗三藐三菩提利益众生

【论】释曰。上品中须菩提种种因缘难。若诸法空。云何有五道生死善不善法。今难众生作是言。世尊。若众生毕竟不可得。菩萨为谁故行般若。先难法为众生。今难众生为法故。佛答。为实际故菩萨行般若波罗蜜。须菩提意。谓菩萨为度众生故行般若波罗蜜。佛意众生假名虚诳毕竟不可得。菩萨为一切实法故行般若波罗蜜。实法即是实际。问曰。一切菩萨见众生苦恼。为度众生故发大悲心。今何以言为实际。答曰。初发意菩萨但为灭众生苦故发大悲心。苦者所谓老病死等及身心衰恼。云何灭是苦。寻苦因缘由生故。如佛十二因缘中说。何因缘故有老病死以有生故。问曰。一切众生皆知生因缘是苦。菩萨有何奇特。答曰。众生不知由生有苦。若遭苦时但怨恨人。自不将适初不怨生。以是故增长结使。重增生法不知真实苦因。有人无鞭杖刀兵诸愁恼苦而有死苦。此死从何所来。从生而有。复次鞭杖刀兵愁恼皆由生故有。余法或有苦或无苦。是生法必定有苦。正使大智及诸天。有生必有死有死必有苦。是故知生定是苦本。如草木有生故必可焚烧。若当不生虽有猛火大风无所烧害。菩萨既得苦因缘复推生因缘。生因缘者有。有有三种。欲有色有无色有。着是三有起善恶业。是生因。有因者四种取。取因缘者爱等诸烦恼。小者未能起业故名为爱。增长能起业故名为取。欲取见取戒取我语取取着是四事故能起种种业。爱因缘三种受。受因缘者眼等六种触。触名受等诸心数法。情尘识三事和合故。心中生受等心数法。根本虽三事和合故生触。为六情依止住处故但说六入。六入因缘名色。六入虽即是名色分。成就名六入未成就名名色。色成就名五入。名成就名一入。是胎中时因缘次第名色因缘。是识若识不入胎。胎初则烂坏。识名中阴。中五众是五众细故但名为识。若识不入而胎成者如一切和合时。皆应成胎。问曰。识何因缘故入胎。答曰。行因缘。行即是过去三种业。业将识入胎。如风吹绝焰空中而去焰则依止于风。先世作人身时。然六识故命终时业将识入胎。问曰。上业何以名有。今业何以名行。答曰。上是今世业。为未来有故名为有。今业过去世已灭尽但有名名为行。(天竺语删迦罗秦言行)是行因缘名无明。一切烦恼虽是过去业因缘。无明是根本故但名无明。今世现在着爱取多故爱取爱名。过去世中是疑邪见处故但名无明。今得一切苦恼根本是无明。问曰。无始生死展转甚多。何以止齐无明。答曰。是事先已答。菩萨思惟为人从苦得脱故求苦因缘。众生过去现在老死等苦不可得除。为除未来世老死苦。断相续不令复生。如良医过去病不可治现在病亦不可治。服药但能治应起病破其冷热不复令起。又如失火烧舍不为己过去火故勤灭。亦不为现在火故勤灭。但为未来火不令更烧故勤灭。良医灭火人勤方便亦不虚。菩萨灭众生苦恼亦如是。过去苦已灭无所复能现在苦恼。先世因缘成就故不可却。但破未来世老死等苦因缘故。破是生法老死等苦自然永灭。是故菩萨欲灭未来世老死等苦因缘生。得现在有等八因缘。一名有漏业。二名现在世诸烦恼。所谓四取一爱。是二种烦恼从二心数法生。所谓受及触。触能生一切心数法。受前生故得名。触是受因缘。受虽能生三毒。一切众生爱是旧烦恼。触因缘是内六入。如先说。虽有外六入内六入无故。触等心数法不生。是故内六入得名。名色是六入因缘。如此中说。初入胎识是名色因缘。识名色在胎中。此中虽有六入未成就未可用故未得名字。既生婴孩未能有所作但有六入。转大有六触。如小儿蹈火履冰但有触未知苦乐。转大受苦乐未深爱着。如小儿虽嗔未能起杀等恶业。虽喜未能起施等善业。年及成人得苦生恚得乐生爱求乐具故。取欲等四取。取时能起善恶业。若知先一世无明业因缘则亿万世可知。譬如现在火热。过去未来火亦如是。若无明因缘更求其本则无穷。即堕边见失涅槃道。是故不应求。若更求则堕戏论非是佛法。菩萨欲断无明故求无明体相。求时即入毕竟空。何以故。佛经说。无明相内法不知外法不知内外法不知。菩萨以内空观内法内法即空。以外空观外法外法即空。以内外空观内外法内外法即空。如是等一切是无明相如先品。德女经中破无明广说。复次菩萨求无明体即时是明。所谓诸法实相名为实际。观诸法如幻如化。众生颠倒因缘故起诸烦恼。作恶罪业轮转五道受生死苦。譬如蚕出丝自裹缚入沸汤火炙。凡夫众生亦如是。初生时未有诸烦恼。后自生贪欲嗔恚等诸烦恼。是烦恼因缘故覆真智慧。转身受地狱火烧汤煮。菩萨知是法本末皆空。但众生颠倒错故受如是苦。菩萨于此众生起大悲心。欲破是颠倒故求于实法。行般若波罗蜜通达实际。种种因缘教化众生令住实际。是故住实际无咎。复次经中说。若众生与实际异。菩萨不应行般若波罗蜜。异者实际是毕竟空。众生际是决定有。若尔者应难。若诸法实际相空。菩萨云何为众生故修是实际。若众生毕竟空实际定有。无众生则无所利益。为谁故行实际。今众生际实不异实际故行般若波罗蜜。欲觉悟狂惑颠倒凡夫故行般若波罗蜜。令众生住实际中而不坏实际。是时须菩提更问。若众生际实际不异。云何以实际着实际。自性不应自性中住。如指端不能自触指端。佛可其意菩萨以方便故建立众生于实际。如众生实际不异一亦不可得。若是一则坏实际相。所以者何。得是一性故。菩萨知是二法不一不二亦不不一亦不不二毕竟寂灭无戏论相。菩萨生大悲心。但欲拔出众生离于颠倒故教化众生。又问。云何名方便。佛言。菩萨行般若波罗蜜时。以方便力故建立众生于檀中说是檀。先际后际空中际亦尔。如经中广说。菩萨知实际者到众生边。如先檀品中说。众生闻已发心。折薄烦恼深着布施。菩萨怜愍众生。我从悭中拔出。今复着布施。众生若受布施。福尽受诸苦恼。又受富贵因缘得作大罪则堕地狱。是故愍此众生得少许时乐而受苦长久。是故菩萨为说布施实相所谓毕竟空。作是言。是布施过去已灭。不可见不可得不可用但可忆念。如梦所见无异。未来未生故亦无所有毕竟空。是布施先后际无故中际亦无。如破六尘中破色法中说。现在布施虽眼见。分分破析乃至微尘不可得。布施三世空。施者受者果报亦如是。菩萨语施者言。布施等法是初入佛法门。实际中实际相亦无。何况布施。汝莫念莫着布施等法。若不念不着如布施体相。如是布施者则得甘露味甘露果。甘露味者是八圣道分。甘露果者是涅槃。菩萨虽住实际中。以方便力布施门度众生。余波罗蜜亦如是。如经中广说。须菩提白佛言。世尊。若一切法性空性空中无法及非法亦无众生。菩萨云何住是空中求一切种智。佛答。菩萨安立性空中故能行是布施等诸法。又问。性空破一切法悉尽无余。云何菩萨住性空中能行布施等诸善法。佛可须菩提意而说因缘。菩萨知诸法实相住是中。能得阿耨多罗三藐三菩提。诸法实相者即是性空。若一切法性不空。菩萨不应住是诸法性空中得阿耨多罗三藐三菩提。已为众生说性空法。所谓色性空受想行识性空。乃至为众生说一切种智断烦恼习性空法。复次须菩提十八空。若性不空是为坏空体。何以故。十八空能令一切法空。若自不空则为虚诳。又若不空者则堕常边着处。能生烦恼。性空无实住处。无所从来去无所至。是名常住法相。常住法相是性空之异名。亦名诸法实相。是相中无生无灭无增无减无垢无净。菩萨住是中见一切法性空。于阿耨多罗三藐三菩提不退不疑不悔。何以故。不见诸法能障碍者。以方便力故度众生。方便力者毕竟无法亦无众生而度众生。问曰。若众生及法从本已来无为。谁作方便为度脱谁。答曰。性空名空性亦无。汝何以取是空性相作难。若有性空相应当作难。复次得诸法实相者知是性空。是人则知诸法性空。无法无众生。凡夫未得实相故种种忆想分别。如狂人妄有所见以为实有。为度凡夫狂人故言为众生说狂法中有是诸法分别实法中则无。菩萨欲满本愿故。又不着性空故有度众生。此中则不应难。复次此经中佛自说因缘。性空中众生不可得。知者见者亦不可得。乃至八十随形好亦如是。而菩萨立是法。为众生说是世谛故非是实。此中佛说譬喻。如佛作化人。又化作四部众而为说法。可有得道者不。须菩提言不也。所以者何。无定根本实事。何有得须陀洹乃至得佛者。菩萨说法度众生亦如是。众生无有定实。但欲于颠倒中拔出众生着无颠倒中。无颠倒法亦无处所。是中无众生乃至无知者见者。虽空性一相而颠倒多不颠倒少。是故贵是性空不颠倒法。菩萨住此中但破众生妄想不破众生。又无漏法乃至八圣道分。虽是无漏以生灭故不如第一义。须菩提是性空一切诸佛唯有是道更无异道。何以故。诸佛皆求实智。不坏不异法虽有十力四无所畏诸异法不名为一道。所以者何。此皆是有为法转变无常故。是性空中无众生亦无色等诸法。菩萨不为菩萨道故求阿耨多罗三藐三菩提。但为性空故。问曰。何等是性空何等是菩萨道。答曰。第一义中无分别。世谛中有分别。诸法实相名性空。余布施等乃至八十随形好是菩萨道。虽行是法不为此法为求性空故。是故说不为菩萨道故行是性空。先亦性空中后亦性空。从本已来常空无有作者。非是福德力故使空。亦非智慧力故使空。但性自尔故。诸佛贤圣以大福德智慧方便力故。破众生心中颠倒令知性空。譬如虚空性常清净不着垢闇。或时风云闇翳。世人便言虚空不净。更有猛风吹除风云。便言虚空清净。而虚空实无垢无净。诸佛亦如是。以说法猛风吹却颠倒云翳令得清净。而诸法性常自无垢无净。是菩萨知一切法性空故。能行一切种种道度众生。具足一切道净佛国土教化众生。得阿耨多罗三藐三菩提时。随意寿命。随意寿命者。菩萨得无生忍法入如幻菩萨道。能一时变化作千亿万身。周遍十方具足行一切菩萨道。处处国土中随众生寿命长短而受其形。如释迦牟尼佛于此国土寿命百年。于庄严佛国寿七百阿僧祇劫。佛法于五不可思议中。是第一不可思议。佛告须菩提。一切法性空是诸佛真法。若得是法则名为佛。若说此法名为度众生。三世佛皆亦如是。离是性空则无道无果。道者八圣道分。果者七种果。所以者何。若离性空别有定法则取相生着。着故亦无离欲。无离欲故则无道果。若离性空虽行布施持戒行慈悲等。善法力故虽不堕恶道生天。果尽还堕恶道如本不异。行性空法亦不着性空即是涅槃。行余法生着心有退失。若行此法则无退失。须菩提。欢喜白佛言。甚希有。菩萨行是性空法亦不坏性空相。佛答。若色等法与性空异。菩萨则不得阿耨多罗三藐三菩提。何以故。有空法则不可得离。须菩提今色等诸法实性空。菩萨知是法已得阿耨多罗三藐三菩提。所以者何。此中无有一法定是常。但凡夫生我心故着内外法。不得脱生老病死。是故菩萨行是性空和合六波罗蜜不坏色等诸法相。所谓若空若不空若空不空若非空非不空。不作如是示诸法相是名不坏。所以者何。色实相即是性空。性空云何自坏性空。乃至菩提亦如是。此中佛说譬喻。如内虚空不坏外虚空以同体故。须菩提问。世尊。若诸法性空无别异。菩萨于何处得阿耨多罗三藐三菩提。佛可其意言如是。若分别有二相。则不得阿耨多罗三藐三菩提。阿耨多罗三藐三菩提名实智慧。于色法中不行。所谓不着不染。所以者何。是智慧不为取色故行。是故不行色中。须菩提复问。若菩提不取中行不舍中行当于何处行。取名实法舍名空法。取名著行舍名不着行。取名二行舍名不二行。如是等分别。佛反问须菩提。于汝意云何。佛所化人为何处行。须菩提言。是化人无处行。化人无心无心数法故。菩提亦如是。复问。于汝意云何。阿罗汉梦中菩提为在何处行

须菩提言。阿罗汉尚不眠。何况梦中菩提有行处。问曰。菩提有三种。阿罗汉菩提辟支佛菩提佛菩提。阿罗汉菩提不在有漏心中无记心中行。但在无漏心中行。佛何以故问阿罗汉梦中菩提何处行。答曰。阿罗汉是一切漏尽圣人则无梦。佛以必无处故。问欲明必无行法

问曰。乃至佛犹尚有眠。何以知之。佛尝命阿难。汝四襞优多罗僧敷我欲小眠。汝为诸比丘说法。又萨遮尼干问佛。佛自念昼日有眠不。佛言。春末夏初以时热故小眠息。除食患故。萨遮尼干白佛。余人有言昼日眠是痴相。佛言汝置汝不别痴相。诸漏能生后身相续不断者是名痴相。虽常不眠亦是痴。若是诸漏永灭无余。虽眠不名痴。如是等经中处处说。须菩提。何以言阿罗汉尚不眠。答曰。眠有二种。一者眠而梦。二者眠而不梦。阿罗汉非为安隐着乐故眠。但受四大身法。应有食息眠觉。是故少许时息名为眠。不为梦眠故。须菩提言。阿罗汉尚不眠。有人言。离欲者得禅定。色界系四大入身中。身心欢乐则无有眠。慧解脱阿罗汉。色界四大不入身中故有眠。是故须菩提言阿罗汉尚不眠。是故阿罗汉有眠有不眠。佛以方便力为度众生。受人法故现眠

须菩提复问。若不行者。云何菩萨从一地至十地。乃至得阿耨多罗三藐三菩提。佛可其意。菩提虽无处行未具足六波罗蜜。诸法终不得阿耨多罗三藐三菩提。是菩萨住色相乃至菩提相中住。得阿耨多罗三藐三菩提。不舍色等法亦不着菩提相。知色等法即是菩提。常寂灭无法。若增若减若垢若净若得道若得果。但世谛故说菩萨得阿耨多罗三藐三菩提。第一义中无有色乃至菩提。佛欲明是事故。反问须菩提。于汝意云何。汝断烦恼得道时有所得不。所谓如梦等五众。若道若道果决定一法不。须菩提言。不得也。所以者何。须菩提意。住无相门中入道云何取相。佛言。汝若乃至不得微细少法。云何说汝为阿罗汉。须菩提言。世谛法故说言阿罗汉。凡夫颠倒法中有得有失有众生有法。佛言。菩提亦如是。世谛法故说有菩萨。说有色等乃至菩提。菩提中无有定法。亦无众生亦无菩提。菩萨观是菩提法无有增无有减。所以者何。诸法性如是。菩萨亦不得是诸法性。何况有初发心乃至十地及六波罗蜜。三十七品乃至十八不共法。当有所得。无有是处。所以者何。诸法性是一切法根本尚不可得。何况六波罗蜜等。是作法当有定实。如是菩萨行是诸法性得佛时。能大利益众生

大智度论卷第九十大智度论释照明品第八十一(卷第九十一)

        龙树菩萨造

        后秦龟兹国三藏鸠摩罗什译

【经】须菩提白佛言。世尊。若菩萨摩诃萨行六波罗蜜十八空三十七助道法佛十力四无所畏四无碍智十八不共法。不具足菩萨道。不能得阿耨多罗三藐三菩提。世尊。菩萨摩诃萨当云何具足菩萨道能得阿耨多罗三藐三菩提。佛告须菩提。若菩萨摩诃萨行般若波罗蜜时。以方便力故行檀波罗蜜。不得施不得施者不得受者。亦不远离是法。行檀波罗蜜。是则照明菩萨道。如是须菩提。菩萨以方便力故具足菩萨道。具足已能得阿耨多罗三藐三菩提。持戒忍辱精进禅定智慧。乃至十八不共法亦如是。舍利弗白佛言。世尊。云何菩萨摩诃萨习般若波罗蜜。佛告舍利弗。若菩萨摩诃萨行般若波罗蜜。以方便力故不坏色不随色。何以故。是色性无故不坏不随。乃至识亦如是。舍利弗。菩萨摩诃萨行般若波罗蜜。以方便力故檀波罗蜜不坏不随。何以故。檀波罗蜜性无故。乃至十八不共法亦如是。舍利弗白佛言。世尊。若诸法无自性可坏可随者。云何菩萨摩诃萨能习般若波罗蜜。诸菩萨摩诃萨所学处。何以故。菩萨摩诃萨不学般若波罗蜜。不能得阿耨多罗三藐三菩提。佛告舍利弗。如汝所言。菩萨不学般若波罗蜜。不能得阿耨多罗三藐三菩提。不离方便力故可得。舍利弗。若菩萨摩诃萨行般若波罗蜜。若有一法可得应当取。若不可得何所取。所谓此是般若波罗蜜。是禅波罗蜜。是毗梨耶波罗蜜。是羼提波罗蜜。是尸罗波罗蜜。是檀波罗蜜。是色受想行识。乃至是阿耨多罗三藐三菩提。舍利弗。是般若波罗蜜不可取相。乃至一切诸佛法不可取相。舍利弗。是名不取般若波罗蜜乃至佛法。是菩萨摩诃萨所应学。菩萨摩诃萨于是中学时。学相亦不可得。何况般若波罗蜜。佛法菩萨法辟支佛法声闻法凡夫人法。何以故。舍利弗。诸法无一法有性。如是无性诸法。何等是凡夫人须陀洹斯陀含阿那含阿罗汉辟支佛菩萨佛。若无是诸贤圣云何有法。以是法故分别说是凡夫人须陀洹斯陀含阿那含阿罗汉辟支佛菩萨佛。舍利弗白佛言。世尊。若诸法无性无实无根无本。云何知是凡夫人乃至是佛。佛告舍利弗。凡夫人所著处色有性有实不。不也世尊。但以颠倒心故。受想行识乃至十八不共法亦如是。舍利弗。菩萨摩诃萨行般若波罗蜜时。以方便力故。见诸法无性无根本故。能发阿耨多罗三藐三菩提心。舍利弗白佛言。云何菩萨摩诃萨行般若波罗蜜时。以方便力故。见诸法无性无根本故。发阿耨多罗三藐三菩提心。佛告舍利弗。菩萨摩诃萨行般若波罗蜜时。不见诸法根本。住中退没生懈怠心。舍利弗诸法根本实无我无所有性常空。但颠倒愚痴故众生着阴入界。是菩萨摩诃萨见诸法无所有性常空自性空时。行般若波罗蜜自立如幻师。为众生说法。悭者为说布施法。破戒者为说持戒法。嗔者为说忍辱法。懈怠者为说精进法。乱想者为说禅定法。愚痴者为说智慧法。令众生住布施乃至智慧。然后为说圣法能出苦。用是法故得须陀洹果。乃至得阿罗汉果辟支佛道。乃至得阿耨多罗三藐三菩提。舍利弗白佛言。世尊。菩萨摩诃萨得是众生无所有。教令布施持戒乃至智慧。然后为说圣法能出苦。以是法故得须陀洹果乃至阿耨多罗三藐三菩提。佛告舍利弗。菩萨摩诃萨行般若波罗蜜时。无有所得过罪。何以故。舍利弗。是菩萨摩诃萨行般若波罗蜜时。不得众生。但空法相续故名为众生。舍利弗。菩萨摩诃萨住二谛中为众生说法。世谛第一义谛。舍利弗。二谛中众生虽不可得。菩萨摩诃萨行般若波罗蜜。以方便力故为众生说法。众生闻是法。今世吾我尚不可得。何况当得阿耨多罗三藐三菩提及所用法。如是舍利弗。菩萨摩诃萨行般若波罗蜜时。以方便力故为众生说法。舍利弗白佛言。世尊。是菩萨摩诃萨心旷大无有法可得。若一相若异相若别相。而能如是大誓庄严。用是庄严故。不生欲界不生色界不生无色界。不见有为性。不见无为性。而于三界中度脱众生。亦不得众生。何以故。众生不缚不解。众生不缚不解故。无垢无净。无垢无净故。无分别五道。无分别五道故。无业无烦恼。无业无烦恼故。亦不应有果报。以是果报故生三界中。佛告舍利弗。如是如是。如汝所言。若众生先有后无。诸佛菩萨则有过罪。诸法五道生死亦如是。若先有后无。诸佛菩萨则有过罪。舍利弗。今有佛无佛诸法相常住不异。是法相中尚无我无众生无寿命。乃至无知者无见者。何况当有色受想行识。若无是法云何当有五道往来拔出众生处。舍利弗。是诸法性常空。以是故诸菩萨摩诃萨从过去佛闻是法相。发阿耨多罗三藐三菩提意。是中无有法我当得。亦无有众生定着处法不可出。但以众生颠倒故着。以是故菩萨摩诃萨发大誓庄严。常不退阿耨多罗三藐三菩提。是菩萨不疑。我当不得阿耨多罗三藐三菩提。我必当得阿耨多罗三藐三菩提。得阿耨多罗三藐三菩提已。用实法利益众生令出颠倒。舍利弗。譬如幻师。幻作百千万亿人。与种种饮食令饱满。欢喜唱言。我得大福我得大福。于汝意云何。是中有人食饮饱满不。不也世尊。佛言如是。舍利弗。菩萨摩诃萨从初发意已来。行六波罗蜜四禅四无量心四无色定四念处乃至八圣道分十四空三解脱门八背舍九次第定佛十力乃至十八不共法。具足菩萨道成就众生净佛国土。无众生法可度。须菩提白佛言。世尊。何等是菩萨摩诃萨道。菩萨行是道能成就众生净佛国土。佛告须菩提。菩萨摩诃萨从初发意已来。行檀波罗蜜。行尸罗羼提毗梨耶禅般若波罗蜜。乃至行十八不共法。成就众生净佛国土。须菩提白佛言。世尊。云何菩萨摩诃萨行檀波罗蜜成就众生。佛告须菩提。有菩萨摩诃萨行檀波罗蜜时。自布施亦教众生布施。作是言。诸善男子汝等莫着布施。汝着布施故当更受身。受身故多受众苦。诸善男子。诸法相中无所施无施者无受者。是三法性皆空。是性空法不可取。不可取相是性空。如是须菩提。菩萨摩诃萨行檀波罗蜜时布施众生。是中不得布施不得施者不得受者。何以故。无所得檀波罗蜜。是名为檀波罗蜜。是菩萨不得是三法故。能教众生令得须陀洹果。乃至令得阿罗汉果辟支佛道阿耨多罗三藐三菩提。如是须菩提。菩萨摩诃萨行檀波罗蜜时成就众生。是菩萨自行布施。亦教他人行布施。赞叹布施法。欢喜赞叹行布施者。是菩萨如是布施已。生刹利大姓婆罗门大姓居士大家。若作小王若转轮圣王。是时以四事摄取众生。何等四。布施爱语利行同事。是四事摄众生已。众生渐渐住于戒四禅四无量心四无色定四念处乃至八圣道分空无相无作三昧。得入正位中。得须陀洹果。乃至得阿罗汉果。若得辟支佛道。若教令得阿耨多罗三藐三菩提。作是言。诸善男子。汝等当发阿耨多罗三藐三菩提心。是阿耨多罗三藐三菩提易得耳。何以故。无有定法众生所著处。但颠倒故众生着。是故汝当自离生死。亦当教他离生死。汝等当发心能自利益。亦当得利益他人。须菩提。菩萨摩诃萨应如是行檀波罗蜜是行檀波罗蜜因缘故。从初发意已来终不堕恶道。常作转轮圣王。何以故。随其所种得大果报。是菩萨作转轮圣王时。见有乞者作是念。我不为余事。故受转轮圣王果。但为利益一切众生故。是时作是言。此是汝物汝自取之莫有所难我无所惜。我为众生故受生死。怜愍汝等故具足大悲。行是大悲饶益众生。亦不得实定。众生相。但有假名故可说是众生。是名字亦空如向声。实不可说相。须菩提。菩萨摩诃萨应如是行檀波罗蜜。于众生中无所惜。乃至不惜自身肌肉。何况外物。以是法故能出众生生死。何等是法。所谓檀波罗蜜尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。乃至十八不共法。令众生从生死中得脱。复次须菩提。菩萨摩诃萨住檀波罗蜜中布施已。作是言。诸善男子。汝等来持戒。我当供给汝等令无乏短。衣食卧具乃至资生所须尽当给汝。汝等乏少故破戒。我当给汝所须令无所乏。若饮食乃至七宝。汝等住是戒律仪中渐渐当得尽苦。成于三乘而得度脱。若声闻乘辟支佛乘佛乘。复次须菩提。菩萨摩诃萨住檀波罗蜜中。若见众生嗔恼。作是言。诸善男子。汝等以何因缘故嗔恼。我当与汝所须。汝等所欲从我取之。悉当给汝令无所乏。若饮食衣服乃至资生所须。是菩萨住檀波罗蜜中教众生忍辱。作是言。一切法中无有坚实。汝等所嗔是因缘空无坚实。皆从虚妄忆想生。汝无有根本。汝嗔恚坏心恶口骂詈刀杖相加以至害命。汝等莫以是虚妄法起嗔故堕地狱畜生饿鬼中及余恶道受无量苦。汝等莫以是虚妄无实诸法故而作罪业。以是罪业故尚不得人身。何况得生佛世。诸人佛世难值人身难得。汝等莫失好时。若失好时则不可救。是菩萨摩诃萨如是教化众生。自行忍辱亦教他人令行忍辱。赞叹忍辱法。欢喜赞叹行忍辱者。是菩萨令众生住忍辱中。渐以三乘得尽众苦。如是须菩提。菩萨摩诃萨住檀波罗蜜。令众生住忍辱。须菩提。云何菩萨摩诃萨住檀波罗蜜。令众生精进。须菩提。菩萨见众生懈怠。作如是言。汝等何以懈怠。众生言。因缘少故。是菩萨行檀波罗蜜时。语诸人言。我当令汝因缘具足。若布施若持戒若忍辱。如是等因缘令汝具足。是众生得菩萨利益因缘故。身精进口精进心精进。身精进口精进心精进故。一切善法具足。修圣无漏法。修圣无漏法故。当得须陀洹果乃至阿罗汉果辟支佛道。若得阿耨多罗三藐三菩提。如是须菩提。菩萨摩诃萨行檀波罗蜜时。住精进波罗蜜摄取众生。须菩提。云何菩萨摩诃萨行檀波罗蜜时。教化众生令修禅波罗蜜。佛告须菩提。菩萨见众生乱心。作是言。汝等可修禅定。众生言。我等因缘不具足故。菩萨言。我当与汝等作因缘。以是因缘故。令汝心不随觉观亦不驰散。众生以是因缘故。断觉观入初禅二禅三禅四禅。行慈悲喜舍心。众生以是禅无量心因缘故。能修四念处乃至八圣道分。修三十七助道法时。渐入三乘而得涅槃终不失道。如是须菩提。菩萨摩诃萨行檀波罗蜜时。以禅波罗蜜摄取众生。令行禅波罗蜜。须菩提。云何菩萨摩诃萨行檀波罗蜜。以般若波罗蜜摄取众生。须菩提。菩萨见众生愚痴无有智慧。作是言。汝等何以故不修智慧。众生言。因缘未具故。菩萨住檀波罗蜜中。作是言。汝等所须得智慧具从我取之。所谓布施持戒忍辱精进入禅定。是因缘具足已。汝等如是思惟。思惟般若波罗蜜时。有法可得不。若我若众生若寿命。乃至知者见者可得不。若色受想行识。若欲界色界无色界。若六波罗蜜。若三十七助道法。若须陀洹果。若斯陀含阿那含阿罗汉果辟支佛道。若阿耨多罗三藐三菩提可得不。是众生如是思惟时。于般若波罗蜜中。无有法可得可着处。若不着诸法。是时不见法有生有灭有垢有净。不分别是地狱是畜生是饿鬼是阿修罗众是天是人是持戒是破戒是须陀洹是斯陀含是阿那含是阿罗汉是辟支佛是佛。如是须菩提。菩萨摩诃萨行檀波罗蜜时。以般若波罗蜜摄取众生。须菩提。云何菩萨摩诃萨住檀波罗蜜中。以尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。乃至以三十七助道法摄取众生。须菩提。菩萨摩诃萨住檀波罗蜜中。以供养具利益众生。以是利益因缘故。众生能修四念处四正勤四如意足五根五力七觉分八圣道分。众生行是三十七助道法。于生死中得解脱。如是须菩提。菩萨摩诃萨以无漏圣法摄取众生。复次须菩提。菩萨摩诃萨教化众生时。如是言。诸善男子。汝等从我取所须物。若饮食衣服卧具香华。乃至七宝等种种资生所须。汝当以是摄取众生。汝等长夜利益安乐莫作是念。是物非我所有。我长夜为众生故集此诸物。汝等当取是物如己物无异。教化众生令行布施持戒忍辱精进禅定智慧。乃至令得三十七助道法佛十力乃至十八不共法。亦令得无漏法果。所谓须陀洹乃至阿罗汉果辟支佛道阿耨多罗三藐三菩提。如是须菩提。菩萨摩诃萨行檀波罗蜜时。应如是教化众生令得离三恶道及一切生死往来苦。复次须菩提。菩萨摩诃萨住尸罗波罗蜜教化众生。作是言。众生汝等少何因缘故破戒。我当与汝作具足因缘。若布施乃至智慧。及种种资生所须。是菩萨住尸罗波罗蜜利益众生。令行十善远离十不善道。是诸众生持诸戒。不破戒不缺戒不浊戒不杂戒不取戒。渐以三乘而得尽苦。尸罗波罗蜜为首。如檀波罗蜜说余四波罗蜜亦如是

【论】问曰。先说菩萨行六波罗蜜等诸助道法不具足菩萨道则不能得阿耨多罗三藐三菩提。今须菩提应自知行六波罗蜜等具足菩萨道应得阿耨多罗三藐三菩提。何以更问。答曰。须菩提不疑。云何得阿耨多罗三藐三菩提。今但问。云何具足菩萨道得阿耨多罗三藐三菩提。佛答。若菩萨用六波罗蜜等诸法。以方便力和合故能行。是时具足菩萨道。方便力者。不决定得是布施等三事。亦不离是三事行檀波罗蜜。是时照明菩萨道。照明具足是一义。若菩萨决定得布施等三事。直堕常颠倒取相着法等过罪。若不得是三事则堕断灭边着空。还起邪见等诸烦恼便离菩萨道。若菩萨离是二边。因空舍是施等假名字虚诳法。因诸法实相离是着空无施者无受者。如阿耨多罗三藐三菩提相。观是布施亦尔无异。如是布施名为具足。乃至十八不共法亦如是。舍利弗在会中闻佛与须菩提说般若甚深果报大有利益。虽有利益无决定性云何可习。佛答。菩萨行般若波罗蜜时。不坏色不随色。如是名习般若波罗蜜。菩萨初发心为知实法故。常行般若波罗蜜。次第随其所宜行布施等诸法。是故常说菩萨行般若波罗蜜时行布施等诸法。色不坏者。不言是色无常。不言是色空无所有。是名不坏色。不随色者。不如眼见色取相生着。复次不说是色若常若无常若苦若乐等。是名不随色。常无常等皆非色实相。复次不说是色根本从世性中来若从微尘中来从大自在天中来。亦不说从时来。亦不说自然生。亦不说无因无缘而强生。如是等名为不随不坏。此中佛自说因缘。是色性无故不随不坏。性无者。是色从一切四大和合假名为色。是中无定一法名为色。如先破色中说。是色从因缘和合生故即是无性。若无性即是性空。若得是色相性空。即是习般若波罗蜜。乃至十八不共法亦如是。复问。世尊若诸法无自性可坏可随者。云何菩萨习般若波罗蜜。不学般若波罗蜜不得阿耨多罗三藐三菩提。佛可舍利弗意自说因缘。若菩萨用方便力行六波罗蜜。是人虽知诸法空而能起般若波罗蜜。舍利弗若菩萨求一切法。若得少许定性则可取可着。今菩萨实求觅一切法不得定实。所谓是般若波罗蜜是禅波罗蜜。乃至是十八不共法。是诸法皆不可得。不可得故何所取。舍利弗。是名菩萨无取般若波罗蜜。菩萨应学无取般若波罗蜜。无取尚不可得。何况般若等诸法。一切法无性故。舍利弗复问。若一切法无性云何知是凡人乃至佛。佛答。一切法虽无根本定相。但凡人颠倒故着。菩萨行般若波罗蜜时。以方便力故见一切法无根本。而发阿耨多罗三藐三菩提心。是菩萨深行诸法性空故不见一切法有根本。不见故不懈不退。了了知一切法无我无所有性性常空。但众生愚痴颠倒故着是阴界入。是时菩萨思惟筹量诸法甚深寂灭相。而众生深着虚诳颠倒。菩萨自立如幻师。种种神通变化说法度人。如幻所作。无憎无爱等心说法。所谓悭者教施等六法复为说转胜法令出生死得须陀洹果乃至阿耨多罗三藐三菩提。问曰。六波罗蜜外更有何法为胜。何以言更为说胜法。答曰。此中不说波罗蜜。但为悭者说施。乃至痴者为说智慧。诸佛菩萨法有初有后。初法所谓布施持戒。受戒施果报得天上福乐为说五欲味利少失多。受世间身但有衰苦。赞叹远离世间断爱法。然后为说四谛令得须陀洹果。此中菩萨但说欲令众生得佛道故先教令行六法。此中善智慧不名为三解脱门所摄。是善智慧能生布施等善法。能灭悭贪嗔恚等恶法。能令众生得生天上。何以知之。更有胜法故。胜法者所谓四谛圣法。出法一切圣人所行法名为圣法。出三界生死名为出法。以是四谛说法故随众生根因缘令得须陀洹果。乃至得一切种智。此中虽不说初六法说布施等当知已摄。复次菩萨为佛道故说是六法。但众生意劣故自取小乘。是故不说布施持戒生天受报等初六法。舍利弗白佛言。世尊。先说菩萨是毕竟不可得法。今为无所有众生说法。令得无所有法。所谓须陀洹果乃至一切种智。世尊。菩萨今得无所有法故能令众生得无所有法。无所得是有所得。佛答。菩萨行般若波罗蜜时。无有有所得过。何以故。菩萨行般若波罗蜜时。不见众生及法。但诸因缘和合假名众生。菩萨住二谛中为众生说法。不但说空。不但说有。为爱着众生故说空。为取相着空众生故说有。有无中二处不染。如是方便力为众生说法。众生现在我身及我尚不可得。何况当得阿耨多罗三藐三菩提。舍利弗欢喜白佛言。世尊。旷大心是菩萨。旷大心者。此中自说因缘。所谓无有法可得若一相若异相如人市买必须交易。大心人则不然。无所依止而能发大庄严。大庄严故不生三界。亦拔众生令出三界。而众生不可得。不缚不解故一切法空。从久远以来烦恼颠倒皆是虚诳不实。是故名无缚。缚无故亦无解。缚即是垢。解即是净。无净无垢故无六道分别。不分别六道故无罪福业。罪福业无故无烦恼。能起罪福业者不起罪福业。亦不应有果报。如是诸法毕竟空中而作大庄严。是为希有。譬如人虚空中种树树叶花果多所利益。佛可舍利弗意。舍利弗难是空故佛亦答亦可。以其说空故可。以其难空故答。所谓舍利弗若众生及诸法先有今无。诸佛贤圣有过罪。过罪者所谓令众生入无余涅槃永灭色等一切法入空中皆无所有。以断灭众生及一切法故有过罪。舍利弗。众生及一切法先来无。若有佛无佛常住不异。是诸法实相。是故无六道生死。亦无众生可拔出。舍利弗。一切法先空。是故菩萨于诸佛所闻诸法如是相故发阿耨多罗三藐三菩提心。作是念。菩提中亦无有法可得。亦无实定法令众生着而不可度。但众生痴狂颠倒故着是虚诳法。是故菩萨发大庄严。不转于阿耨多罗三藐三菩提。作是念。我必当得阿耨多罗三藐三菩提。非不得得已用实法利益众生。利益众生故众生从颠倒得出。欲明了是事故经中说幻师譬喻。幻师即是菩萨。幻师所作园林卢观。即是六波罗蜜等度众生法。幻师所作象马男女。即是菩萨所度众生。如幻师一身以幻力故幻作众生园林卢观等娱乐众生。若幻师以所幻作事为实。于所幻人求其恩惠即是狂人。菩萨亦如是。从诸佛闻一切法性空如幻。而以布施等利益众生欲求恩惠福报即是颠倒。问曰。幻法咒术实有。幻所作物可虚。如众生空菩萨亦空。菩萨不化作众生何得为喻。答曰。诸法实相中法尚无。何况众生。众生异名名为幻师。幻师实无何以言幻师有而所幻者无。如汝以幻师实有所幻者无。圣人观幻师及所幻物不异。以明了事故说譬喻。取其少许相似处为喻。何以尽取为难。如师子喻王。师子于兽中无畏。王于群下自在。无难故以为喻。复何可责四脚负毛为异也。佛说性空法。诸法皆空犹有众生。是故说幻为喻。我今说喻以破众生。汝云何复以众生为难。尔时须菩提白佛言。世尊。何等是成就众生净佛国土道。须菩提虽知菩萨道。以中说甚深性空故听者生疑。是故发问。佛答。菩萨从初发心行六波罗蜜乃至十八不共法。是菩萨道行是道。成就众生净佛国土。须菩提复问。云何行是法成就众生。须菩提意。若是法性空众生亦性空。云何可得成就。佛答。菩萨以方便力故以布施法教化众生不教令着布施以为真实。方便者。菩萨语众生。汝曹善男子来布施莫着是布施。如经中说。众生以布施生贵乐处。贵乐因缘故生我憍慢。我憍慢增长故破善法。破善法故堕三恶道。是故菩萨先教言莫着布施。但因是布施修持戒等善法。皆回是法向涅槃。所以者何。是性空。诸法实相不可取相。如是菩萨方便力故。教化众生令得须陀洹果乃至佛道。是菩萨自行布施亦教众生布施。若不自施。或有人言。若施是好法何不自行。是故菩萨先自布施。复次菩萨深爱善法布施是初门。是故行是布施。又菩萨深慈悲众生。以慈悲心虽大而不能充满众生。是故先行布施令其心濡可以引导。布施因缘生于四姓。及作转轮王以四摄法摄取众生。渐渐以三乘法令得涅槃。教他布施赞叹布施法欢喜赞叹行布施者。是深爱布施。见同行故欢喜赞叹。复次怜愍心于众生。若见修福则为之欢喜。如慈父见子行善心则欢喜。是人四种行布施。生刹利等贵姓中。以布施摄已渐渐教令持戒禅定等。乃至令得辟支佛道。或见众生有大心者。有少许慈悲心。是人怖畏生死长远故其心懈退。菩萨方便力故语是众生。咄众生阿耨多罗三藐三菩提易得。汝等何以为难。众生所著处此中无有定实法能遮者难解者。汝等当发阿耨多罗三藐三菩提心。既自得度复当度脱众生。度脱众生者。菩萨自乘大乘得度。以三乘随众生所应度而度之。既自利益复利益他人。利益他者。既自作佛而以三乘度脱众生。若菩萨能如是行般若波罗蜜者。从初发心终不堕三恶道。常作转轮圣王者。菩萨多生欲界。何以故。以无色界中无形故不可教化。色界中多味着禅定乐。无厌恶心故难化。亦不生欲天。所以者何。着妙五欲多故难化。在人中世世以四事摄众生故作转轮圣王。此中佛自说因缘。随其所种得大果报等。如经中说布施相。复有菩萨行檀波罗蜜时。见众生破戒作是言。汝曹以因缘不具足故破戒。我当给汝所须令无乏少。破戒人有二种。一者持戒因缘不具足故。如贫穷人饥寒急故作贼。二者持戒因缘虽具足以习恶心故。好行恶事贫穷破戒者。菩萨语之言。汝但持戒我当给汝所须。汝等住持戒中渐渐以三乘而得度脱。是名因布施生戒。众生以不如意事故嗔。若以求物不如意故嗔。人不称意故嗔。菩萨住檀中随其意而给足之。问曰。若贫乏者。给施令不嗔可尔。人不得称意恼之令嗔复云何。答曰。以如意珠施之则使人皆称意。珠之威德故人无嗔者。如行者入慈三昧故人无嗔者。是故说少。何因缘故嗔。我当令汝所少具足。复次一切法性皆空无所有。汝所嗔因缘亦皆虚诳无定。汝云何以虚诳事故嗔骂加害乃至夺命。起此重罪业故堕三恶道受无量苦。汝莫以虚诳无实事故而受大罪。如山中有一佛图。彼中有一别房。房中有鬼来恐恼道人故。诸道人皆舍房而去。有一客僧来。维那处分令住此空房而语之言。此房中有鬼神喜恼人。能住中者住。客僧自以持戒力多闻故。言小鬼何所能我能伏之。即入房住。暮更有一僧来求住处。维那亦令在此房住。亦语有鬼恼人。其人亦言。小鬼何所能我当伏之。先入者闭户端坐待鬼。后来者夜闇打户求入。先入者谓为是鬼不为开户。后来者极力打户。在内道人以力拒之。外者得胜排户得入。内者打之外者亦极力熟打。至明旦相见乃是故旧同学各相愧谢。众人云集笑而怪之。众生亦如是。五众无我无人空。取相致斗诤。若支解在地但有骨肉无人无我。是故菩萨语众生言。汝莫于根本空中斗诤作罪。斗诤故人身尚不可得。何况值佛。当知人身难得佛世难值好时易过。一堕诸难永不可治。若堕地狱烧炙屠割何可教化。若堕畜生共相残害亦不可化。若堕饿鬼饥渴热恼亦不可化。若生长寿天千万佛过着禅定味故皆不觉知。如安息国。诸边地生者。皆是人身愚不可教化。虽生中国或六情不具。或四支不完。或盲聋喑哑。或不识义理。或时六情具足。诸根通利而深着邪见言无罪福不可教化。是故为说好时易过。堕诸难中不可得度。余波罗蜜如经中广说故不复解之。问曰。住檀波罗蜜行五波罗蜜讫。何以复更说六波罗蜜。答曰。上一度中次第具足五。今则一时总说。复次先但说六波罗蜜。今通说三十七品及诸道果。问曰。三十七品自从心出。云何是因缘可与。答曰。菩萨供给坐禅者衣服饮食医药法杖禅鞠禅镇。令得好师教照。令得好弟子受化。与骨人令观。与禅经令人为说禅法。如是等三十七助道法因缘。又令人为说摩诃衍法。汝等所须衣服饮食尽来取之。便是汝物莫自疑难。汝等得是物已。自行六波罗蜜亦教化他人令行六波罗蜜。是布施性皆空。汝等莫着是施及以果报。众生得是性空。渐渐得阿耨多罗三藐三菩提入无余涅槃。如布施为首生五波罗蜜。余波罗蜜亦如是

大智度论卷第九十一大智度论释净佛国土品第八十二(卷第九十二)

        龙树菩萨造

        后秦龟兹国三藏鸠摩罗什译

【经】尔时须菩提作是念。何等是菩萨摩诃萨道。菩萨住是道。能作如是大庄严。佛知须菩提心所念告须菩提。六波罗蜜是菩萨摩诃萨道。三十七助道法是菩萨摩诃萨道。十八空是菩萨摩诃萨道。八背舍九次第定是菩萨摩诃萨道。佛十力乃至十八不共法是菩萨摩诃萨道。一切法亦是菩萨摩诃萨道。须菩提。于汝意云何。颇有法菩萨所不学。能得阿耨多罗三藐三菩提不。须菩提。无有法菩萨所不应学者。何以故。菩萨不学一切法。不能得一切种智。须菩提白佛言。世尊。若一切法空。云何言菩萨学一切法。将无世尊无戏论中作戏论耶。所谓是此是彼。是世间法是出世间法。是有漏法是无漏法。是有为法是无为法。是凡夫人法是阿罗汉法。是辟支佛法是佛法。佛告须菩提。如是如是。一切法实空。须菩提。若一切法不空者。菩萨摩诃萨不能得阿耨多罗三藐三菩提。须菩提。今一切法实空故。菩萨摩诃萨能得阿耨多罗三藐三菩提。须菩提。如汝所言。若一切法空。将无佛于无戏论中作戏论。分别此彼。是世间法是出世间法。乃至是佛法。须菩提。若世间众生知一切法空。菩萨摩诃萨不学一切法得一切种智。须菩提。今众生实不知一切法空。以是故菩萨摩诃萨得阿耨多罗三藐三菩提已。分别诸法为众生说。须菩提。于是菩萨道从初已来。应如是思惟。一切诸法中定性不可得。但从和合因缘起法故有名字。诸法我当思惟诸法实性无所著。若六波罗蜜性。若三十七助道法。若须陀洹果。乃至阿罗汉果。若辟支佛道。若阿耨多罗三藐三菩提。何以故。一切法一切法性空。空不着空。空亦不可得。何况空中有着。须菩提。菩萨摩诃萨如是思惟。不着一切法而学一切法。住是学中观众生心行。是众生心在何处行。知众生虚妄不实中行。是时菩萨作是念。是众生着不实虚妄法易度耳。是时菩萨摩诃萨住般若波罗蜜时。以方便力故如是教化言。汝诸众生当行布施可得饶财。亦莫恃布施果报而自高。何以故。是中无坚实法。持戒禅定智慧亦如是。诸众生行是法。可得须陀洹果乃至阿罗汉果辟支佛道佛道。莫念有是法。如是教化行菩萨道而无所著。是中无有坚实故。若如是教化是名行菩萨道。于诸法无所著故。何以故。一切法无所著相。以性无故。性空故。须菩提。是菩萨摩诃萨如是行菩萨道时无所住。是菩萨用不住法故。行檀波罗蜜亦不住是中。行尸罗波罗蜜亦不住是中。行羼提波罗蜜亦不住是中。行毗梨耶波罗蜜亦不住是中。行禅波罗蜜亦不住是中。行般若波罗蜜亦不住是中。行初禅亦不住是中。何以故。是初禅初禅相空。行禅者亦空。所用法亦空。第二第三第四禅亦如是。慈悲喜舍四无色定八背舍九次第定亦如是。得须陀洹果亦不住是中。得斯陀含果阿那含果阿罗汉果亦不住是中。得辟支佛道亦不住是中。须菩提白佛言。世尊。何因缘故不住是中。佛言。二因缘故不住是中。何等二。一者诸道果性空无住处。亦无所用法。亦无住者。二者不以少事为足。作是念。我不应不得须陀洹果。我必应当得须陀洹果。我但不应是中住。乃至辟支佛道我不应不得。我必应当得。我但不应是中住。乃至得阿耨多罗三藐三菩提不应住。何以故。我从初发意已来更无余心。一心向阿耨多罗三藐三菩提。须菩提。菩萨一心向阿耨多罗三藐三菩提中远离余心所。作身口意业。皆应阿耨多罗三藐三菩提。须菩提。是菩萨摩诃萨住是一心能生菩提道。须菩提白佛言。世尊。若一切诸法不生。云何菩萨摩诃萨能生菩提道。佛告须菩提。如是如是。一切法无生。云何无生无所作无所起者。一切法不生故。须菩提白佛言。世尊。有佛无佛诸法法相不常住耶。佛言。如是如是。有佛无佛是诸法法相常住。以众生不知是法住法相。为是故菩萨摩诃萨为众生故生菩提道。用是道拔出众生生死。须菩提白佛言。世尊。用生道得菩提。佛言不也。世尊。用不生道得菩提。佛言不也。世尊。用不生非不生道得菩提。佛言不也。须菩提言。世尊。云何当得菩提佛言。非用道得菩提。亦不用非道得菩提。须菩提。菩提即是道。道即是菩提。须菩提白佛言。世尊。若菩提即是道。道即是菩提者。今菩萨未作佛。应当得阿耨多罗三藐三菩提。云何说诸佛多陀阿伽度阿罗呵三藐三佛陀有三十二相八十随形好十力四无所畏四无碍智十八不共法大慈大悲。佛告须菩提。于汝意云何。佛得菩提不。不也世尊。佛不得菩提。何以故。佛即是菩提。菩提即是佛。如须菩提所问。菩萨时亦应得菩提。须菩提是菩萨摩诃萨具足六波罗蜜三十七助道法。具足佛十力四无所畏四无碍智十八不共法。具足住如金刚三昧。用一念相应慧。得阿耨多罗三藐三菩提。是时名为佛。一切法中得自在。须菩提白佛言。世尊。云何菩萨摩诃萨净佛国土。佛言。有菩萨从初发意已来。自除身粗业除口粗业除意粗业。亦净他人身口意粗业。世尊。何等是菩萨摩诃萨身粗业口粗业意粗业。佛告须菩提。不善业若杀生乃至邪见。是名菩萨摩诃萨身口意粗业。复次须菩提。悭贪心破戒心嗔心懈怠心乱心愚痴心。是名菩萨意粗业。复次戒不净是名菩萨身口粗业。复次须菩提。若菩萨远离四念处行。是名菩萨粗业。远离四正勤四如意足五根五力七觉分八圣道分空三昧无相无作三昧。亦名菩萨粗业。复次须菩提。菩萨摩诃萨贪须陀洹果。乃至贪阿罗汉果证辟支佛道。是名菩萨摩诃萨粗业

【论】释曰上来须菩提常种种问空法以时会疑。其己体寂灭无戏论法犹复多问。是以不问而心念。复次有菩萨及诸天。深入禅定不好语言。而欲得法利。是故须菩提不发言而心念。问曰。须菩提虽无言而世尊以言答。答曰。佛身色视无厌足。如色无厌。声亦如是。虽语而不妨细禅定行。是故佛以言答。复次佛安立寂灭相。于阿耨多罗三藐三菩提中住。不分别一切法若善若不善等。众生有疑而问。佛随所问所念而答。是故不与须菩提同。须菩提闻是六波罗蜜等诸法甚深义。不能得其边。是故问何等是菩萨道。行是道如清净无所著。六波罗蜜等诸善法庄严。佛知其意。于须菩提所益虽少。为增益诸菩萨故答。六波罗蜜等是菩萨道。六波罗蜜是菩萨初发心道。次行四禅八背舍九次第定及三十七道品。但求涅槃十八空佛十力等。微细但为求佛道。六波罗蜜道多为众生故。三十七品等但求涅槃。十八空等于涅槃中。出过声闻辟支佛地。入菩萨位道。是三种皆是生身菩萨所行。所以者何。分别诸法故。今又一切法皆是菩萨道。是法性生身菩萨所行。不见诸法有好恶。安立诸法平等相故。此中佛自说因缘。菩萨应学一切法。若一法。不学则不能得一切种智。学一切法者用一切种门思惟筹量修观通达。须菩提白佛。若一切法一相。所谓空。云何菩萨学一切法。将无于无戏论相法中作戏论耶。所谓此彼诸法略说是戏论相。此东彼西是上是下是常是无常是实是虚是世间是出世间。乃至是二乘法是佛法。佛可具说。一切法空相。若法实定有不空者。即是无生无灭。无生无灭故无四谛。无四谛故无佛法僧宝。如是三宝等诸法皆坏。今诸法实空。乃至空相亦空。众生愚痴颠倒故着。是故于众生中起悲心欲拔出故求佛身力。欲令众生信受其语舍颠倒入诸法实相。是故菩萨虽知诸法空而为利益众生分别说。若众生自知诸法空。菩萨但自住空相中。不须学分别一切法。菩萨行菩萨道时。从初发意已来。如是思惟一切法。无定实性但从因缘和合起。是众因缘亦各各从和合起。乃至到毕竟空。毕竟空唯是一法实。余者无性故皆虚诳。我从无始世来。着是虚诳法。于六道中厌受苦恼。我今是三世十方佛子。般若是我母。今不应复随逐虚诳法是故菩萨乃至毕竟空中亦不着。何况余法。所谓檀波罗蜜等。尔时菩萨照明菩萨道。其心安隐自念。我但断着心道自然至。知是事已。念众生深着世间而毕竟空。亦空无性无有住处。众生难可信受。为令众生信受是法故学一切法。修行生起是度众生方便法。观众生心行所趣。知好何法念何事何所志愿。观时悉知众生所著处。皆是虚诳颠倒忆想分别故着。无有根本实事。尔时菩萨大欢喜作是念。众生易度耳。所以者何。众生所著皆是虚诳无实。譬如人有一子。喜在不净中戏聚土为谷。以草木为鸟兽而生爱着。人有夺者嗔恚啼哭。其父知已此子今虽爱着此事易离耳。小大自休。何以故。此物非真故。菩萨亦如是。观众生爱着不净臭身及五欲。是无常种种苦因。知是众生得信等五善根成就时即能舍离。若小儿所著实是真物。虽复年至百岁。着之转深不可得舍。若众生所著之物定实有者。虽得信等五根着之转深亦不能离。以诸法皆空虚诳不实故得无漏清净智慧眼时。即能远离所著大自惭愧。譬如狂病所作非法醒悟之后羞惭无颜。菩萨知众生易度已。安住般若中以方便力教化众生。汝等当行布施可得饶财。莫恃是布施果报而自憍高。此中无有坚实皆当破坏。与未布施时无异。持戒等乃至十八不共法亦如是。是诸法虽清净大有所益。皆是有为法从因缘生无有自性。汝等若着是法能生苦恼。譬如热金丸虽是宝物捉则烧手。如是菩萨教化众生行菩萨道自无所著。亦为众生说无所著。以无著心行檀波罗蜜故。于檀中不住。不住者所谓布施时不取三种相。亦不着果报而自高生罪业。布施果报灭坏时亦不生恼。尸罗波罗蜜乃至阿耨多罗三藐三菩提亦如是。此中佛自说不住因缘。有二种。一者菩萨深入空不见诸法性故不住。二者不以小事为足故不住。是菩萨无有异心。但一向能生菩提道。须菩提白佛。若一切法无生。云何菩萨能生菩提道。佛可须菩提意。一切法无生。我实处处说诸法无生。非为凡夫说。但为得无作解脱不起三种业者说。复问。世尊佛自说有佛无佛诸法法相常住。如圣人法相空。凡夫亦如是。佛可其所说诸法实相常住。以众生不知不解故起菩提道。但为除凡夫颠倒法故名为道。若决定有道可著者即复是颠倒。道非道平等即是道。是故不应难。须菩提复问。云何可得菩提。用生道故得耶。佛言不也。何以故。生道者菩萨观是有为法。生灭相谓是实。是故言不。如先说热金丸喻。不生法即是无为无作法故亦不可以得菩提。生不生二俱有过故。非生非不生得菩提耶。答言不也。问曰。若生不生二俱有过。非生非不生复不应有过。何以言不得。答曰。若分别非生非不生是好是丑取相生着故。故言有过。若能不着则是菩提道。须菩提问。若不以四句得者。云何得道。佛答。不以道不以非道则得菩提。何以故。菩提即是道。道即是菩提。菩提名诸法实相。是诸佛所得究竟实相无有变异。一切法入菩提中。皆寂灭相。如一切水入大海同为一味。是故佛说菩提性即是道性。若菩提性道性异者。不名菩提为无戏论寂灭相。是故说菩提即是道道即是菩提。复次是二法异者行道。不应到菩提。诸法因果不一不异故。须菩提复问。若尔者菩萨行道应便是佛。所以者何。道即是菩提故。又佛应是菩萨。何以故菩提即是道故。今何以说有差别。佛有十力等三十二相八十随形好。须菩提为新学菩萨故分别难佛。菩萨应即是佛。佛以反问答。佛得菩提不。答言不也。何以故。菩提不离佛。佛不离菩提。二法和合故。是佛是菩提。是故不应难言菩萨即是佛。此总相答。问曰。佛是众生。菩提是法。云何言佛即是菩提。答曰。先有三十二相庄严身。六波罗蜜等功德庄严心。而不名为佛。得菩提故名之为佛。是故言佛与菩提不异。微妙清净五众和合。假名为佛法。即是五众。五众不离假名。菩提即是五众实相。一切法皆入菩提故。是故佛即是菩提菩提即是佛。但凡夫心中分别有异。问曰。汝先论议中说言。菩提与道不一不异。经中何以说道即是菩提菩提即是道。佛即是菩提菩提即是佛。答曰。一异虽俱不实而多用一故。此中说菩提即是道道即是菩提无咎。如常无常。是二边常多生烦恼故不用。无常能破颠倒故多用。事既成办亦舍无常。此中亦如是。若以观种种别异法故多生着心。若观诸法一相若无常苦空等。是时烦恼不生。着心少故。是故多用是一。于实义中一亦不用。若着一即复是患。复次别异无故一亦不可得。相待法故。但以不着心不取一相。故说无咎。一不实故。菩萨不得即是佛。复次今佛更答。须菩提自说因缘。菩提虽寂灭相而菩萨能具足六波罗蜜等诸功德。住金刚三昧。以一念相应慧得阿耨多罗三藐三菩提。尔时于一切法中自在得名为佛。菩萨虽知道及菩提不异。未具足诸功德故不名为佛。又佛诸事毕竟愿行满足故。不名为菩萨。得者是佛法是菩提。求菩提者是菩萨。须菩提从佛闻菩提相道相成就众生已。今问净佛国土事。诸阿罗汉辟支佛无有力知净佛国事。是故问。问曰。何等是净佛土。答曰。佛土者百亿日月百亿须弥山百亿四天王等诸天。是名三千大千世界。如是等无量无边三千大千世界名为一佛土。佛于此中施作佛事。佛常昼三时夜三时。以佛眼遍观众生谁可种善根谁善根成就应增长谁善根成就应得度。见是已以神通力随所见教化众生。心随逐外缘得随意事则不生嗔恼。得不净无常等因缘则不生贪欲等烦恼。若得无所有空因缘则不生痴等诸烦恼。是故诸菩萨庄严佛土。为令众生易度。故国土中无所乏少。无我心故则不生悭贪嗔恚等烦恼。有佛国土一切树木常出诸法实相音声。所谓无生无灭无起无作等。众生但闻是妙音不闻异声。众生利根故便得诸法实相。如是等佛土庄严名为净佛土。如阿弥陀等诸经中说。佛答。菩萨从初发意来。自净粗身口意业。亦教他人净粗身口意业。问曰。若菩萨净佛土。是菩萨得无生法忍住神通波罗蜜。然后能净佛土。今何以言从初发意来净粗身口意业。答曰。三业清净非但为净佛土。一切菩萨道皆净此三业。初净身口意业。后为净佛土。自身净亦净他人。何以故。非但一人生国土中者。皆共作因缘。内法与外法作因缘。若善若不善。多恶口业故地生荆棘。谄诳曲心故地则高下不平。悭贪多故则水旱不调地生沙砾。不作上诸恶故地则平正多出珍宝。如弥勒佛出时。人皆行十善故地多珍宝。问曰。若布施等诸善法得净佛土果报。何以但说净三业。答曰。虽知善恶诸法是苦乐因缘。如一切心心数法中。得道时智慧为大。摄心中定为大。作业时思为大。得是思业已。起身口意业布施禅定等以思为首。譬如缝衣以针为导。受后世果报时业力为大。是故说三业则摄一切善法。意业中尽摄一切心心数法。身口则摄一切色法。人身行三种福德具足则国土清净。内法净故外法亦净。譬如面净故镜中像亦净。如毗摩罗诘经中说。不杀生故人皆长寿如是等。问曰。身口意粗业是事易知。须菩提何以故问。答曰。粗细不定故。如求道人中布施是粗善。于白衣为细。如小乘中不善业为粗。善业为细。摩诃衍中取善法相乃至涅槃皆名为粗。以粗细不定故问。佛次第为说粗业相。所谓夺命乃至邪见。是三种身业四种口业三种意业。皆名为粗。复次破菩萨六波罗蜜法悭贪等。皆名为粗。问曰。先说十不善道已摄悭贪等。何以复别说。答曰。是六法不入十不善道。十不善道皆是恼众生法。是六法不但为恼众生。如悭心但自惜财不恼众生。贪心有二种。一者但贪他财未恼众生。二者贪心转盛求而不得则欲毁害。是名业道。以能起业故。嗔心亦如是。小者不名业道。以其能趣恶处故为道。是故别说六法无咎。问曰。六波罗蜜中已说戒。今何以复说戒不净。答曰。破戒法是杀生等粗罪。戒不净是微细罪。不恼众生。如饮酒等不入十不善道。复次破五众戒名为破戒。不破所受戒常为三毒覆心不忆念戒。回向天福邪见持戒如是等名为戒不净。复次若菩萨心远离四念处等三十七品三解脱门。是名粗业。所以者何。此中心皆观实法。随涅槃不随世间。若出四念处等法。心则散乱。譬如蛇行本性好曲若入竹筒则直出筒还曲。复次若菩萨贪须陀洹果证是为粗。如人闻佛说须陀洹果不堕三恶道尽无量苦如五十由旬池水余在者如一渧二渧。则生贪心。以其心不牢固。本求作佛为众生。今为自身而欲取证。是为欺佛。亦负众生。是故名粗。譬如人请客欲设饮食而竟不与。是则妄语负客。菩萨亦如是。初发心时作愿。我当作佛度一切众生。而贪须陀洹。是则负一切众生。如贪须陀洹果。乃至贪辟支佛道亦如是

大智度论卷第九十二大智度论释净佛国土品第八十二之余(卷第九十三)

        龙树菩萨造

        后秦龟兹国三藏鸠摩罗什译

【经】复次须菩提菩萨取色相受想行识相眼相耳鼻舌身意相色声香味触法相男相女相欲界相色界相无色界相善法相不善法相有为法相无为法相。是名菩萨粗业。菩萨摩诃萨皆远离如是粗业相。自布施亦教他人布施。须食与食须衣与衣。乃至种种资生所须尽给与之。亦教他人种种布施。持是福德与一切众生。共之回向净佛国土故。持戒忍辱精进禅定智慧亦如是。是菩萨摩诃萨或以三千大千国土满中珍宝施与三尊。作是愿言我以善根因缘故。令我国土皆以七宝成。复次须菩提。菩萨摩诃萨以天妓乐乐佛及塔。作是愿言。以是善根因缘愿我国土中常闻天乐。复次须菩提。菩萨摩诃萨以三千大千国土满中天香。供养诸佛及塔。作是愿言以是善根因缘令我国土中常有天香。复次须菩提。菩萨摩诃萨以百味食施佛及僧。作是愿言。以是善根因缘故。令我国土中众生皆得百味食。复次须菩提。菩萨摩诃萨以天香细滑施佛及僧。作是愿言。以是善根因缘故。令我国土中一切众生受天香细滑。复次须菩提。菩萨摩诃萨以随意五欲施佛及僧并一切众生。作是愿言。以是善根因缘故。令我国土中弟子及一切众生皆得随意五欲。是菩萨以随意五欲共一切众生回向净佛国土。作是愿言。我得佛时。是国土中如天五欲应心而至。复次须菩提。菩萨摩诃萨行般若波罗蜜时。作是愿言。我当自入初禅。亦教一切众生入初禅第二第三第四禅。慈悲喜舍心乃至三十七助道法亦如是。我得阿耨多罗三藐三菩提时。令一切众生不远离四禅。乃至不远离三十七品助道法。如是须菩提。菩萨摩诃萨能净佛国土。是菩萨随尔所时行菩萨道。满足是诸愿。是菩萨自成就一切善法。亦成就一切众生善法。是菩萨受身端正。所化众生亦得端正。所以者何。福德因缘厚故。须菩提。菩萨摩诃萨应如是净佛国土。是国土中乃至无三恶道之名。亦无邪见三毒二乘声闻辟支佛之名。耳不闻有无常苦空之声。亦无我所有乃至无诸结使烦恼之名。亦无分别诸果之名。风吹七宝之树。随所应度而出音声。所谓空无相无作如诸法实相之音。有佛无佛一切法一切法相空。空中无有相。无相中则无作出如是法音。若昼若夜若坐若卧若立若行。常闻此法。是菩萨得阿耨多罗三藐三菩提时。十方国土中诸佛赞叹众生。闻是佛名必至阿耨多罗三藐三菩提。是菩萨得阿耨多罗三藐三菩提时。说法众生闻者无有不信而生疑言。是法是非法。何以故。诸法实相中皆是法无有非法。诸有薄福之人于诸佛及弟子不种善根。不随善知识。没在我见中。乃至没在一切种种见中。堕在边见若断若常。如是人以邪见故。非佛言佛佛言非佛。非法言法法言非法。如是人破法故。身坏命终堕恶道地狱中。诸佛得阿耨多罗三藐三菩提时。见此众生往来五道。令离邪聚立正定聚中。更不堕恶道。如是须菩提。菩萨摩诃萨净佛国土中。众生无杂秽心。若世间法若出世间法。若有漏若无漏。若有为若无为。乃至是国土中众生。毕竟至阿耨多罗三藐三菩提。须菩提。是为菩萨摩诃萨净佛国土

【论】释曰。复有粗业。于诸法毕竟空中取相生着心。所谓取色相受想行识相眼相乃至意相色相乃至法相男相女相三界善不善有为无为相等。问曰。男女相可是虚妄不实。余色等善不善法若不取相。云何能厌色等成就善法。答曰。佛法中有二种空。一者众生空。二者法空。以众生空破众生相。所谓男女等相。以法空破色等法中虚妄相。如破一切法空中说。能观色等善法如幻如化不取定实相。得厌心则舍戏论常无常等。是不名为取相。又色等及善法皆和合性空行故。不生诸烦恼。问曰。一切有为法假名和合故不应取。无为法是真实法。所谓如法性实际。何以不取。答曰。以不取相是无为法无相名为无为法门。若取相便是有为。如是等一切虚诳取相不实。远离粗身口意业。菩萨欲行净佛土。远离如是等粗身口意业。自行六波罗蜜亦教他人令行。共清净因缘故则佛土清净。上总相说下别相说。是菩萨满三千大千世界七宝施佛及僧。作是愿。我以是布施因缘令我国土皆七宝庄严。问曰。若满三千大千世界珍宝从何处得。又诸佛贤圣少欲知足。谁受是者。若凡夫无厌足。何能受三千世界物。答曰。是菩萨是法性生身。住具足神通波罗蜜中。为供养十方佛故。以如三千世界珍宝供养。又此宝物神通力所作轻细无妨。如第三禅遍净天六十人坐一针头而听法不相妨碍。何况大菩萨深入神通所作宝物。或有菩萨变身如须弥山遍十方佛前。以为灯炷供养于佛若佛塔庙。而作愿言。令我国土常有光明。不须日月灯烛。或有菩萨雨诸华香幡盖璎珞以为供养。复作是愿。令我国土众生端正如华身相严净无有丑陋。如是等种种好色因缘。复有菩萨以天伎乐娱乐于佛若佛塔庙。是菩萨或时以神通力故作天伎乐。或作天王转轮圣王伎乐。或作阿修罗神龙王等天伎乐供养。愿我国中常闻好音。问曰。诸佛贤圣是离欲人。则不须音乐歌舞。何以伎乐供养。答曰。诸佛虽于一切法中心无所著。于世间法尽无所须。诸佛怜愍众生故出世。应随供养者令随愿得福故受。如以华香供养。亦非佛所须。佛身常有妙香诸天所不及。为利益众生故受。是菩萨欲净佛土故求好音声。欲使国土中众生闻好音声其心柔软。心柔软故易可受化。是故以音声因缘而供养佛。或有菩萨满三千大千世界香。供养诸佛若塔。根香茎香叶香末香。若天香若变化香若菩萨果报生香。作是愿令我国土中常有好香无有作者。或有菩萨以百味供养诸佛及僧。有人言。能以百种供养。是名百味。有人言。饼种数五百。其味有百。是名百味。有人言。百种药草药果作欢喜丸。是名百味。有人言。饮食羹饼总有百味。有人言。饮食种种备足故。称为百味。人饮食故百味。天饮食则百千种味。菩萨福德生果报食。及神通力变化食。则有无量味。能转人心令离欲清净。是四种食菩萨随因缘供养佛及僧。是故国土中自然有百味饮食。或有菩萨以天涂香。天竺国热。又以身臭故以香涂身供养诸佛及僧。以此因缘故。令我国土众生受天细滑。问曰。沙弥戒乃至受一日戒。尚不以香涂身。云何以香供养佛及僧。答曰。是菩萨以身所贵物。随所须时用以供养。或以涂地涂壁及行坐处。又以随意五欲供养诸佛及僧及余众生。是菩萨以好车马妻妾伎直幡盖金银衣服珍宝。出家人所不受则施诸众生。作愿言。令我国土众生常得随意五欲。问曰。此五欲佛说如火如坑如疮如狱如怨如贼能夺人善根。菩萨何以愿使众生得五欲。又佛说弟子应纳衣乞食坐林树下。菩萨何以为众生求得五欲。答曰。天上人中五欲是福德果报。若今世若后世。贫穷薄福者不能自活。则行劫盗或为物主所害。或为财杀他或被诘问妄言不作。如是次第作十不善。皆由贫穷故作。若人五欲具足则所欲随意则不行十不善。菩萨国土众生丰乐。自恣无所乏少。则无众恶。但有爱慢等软结使。若闻佛所说。或闻弟子所说。以心柔软故闻法易可得道。虽着心多利根故闻无常苦空等即便得道。譬如垢腻之衣则以灰泥淹之经宿以水浣之一时都去。菩萨不欲令众生着故。以五欲施但欲令一时舍故与之。如汝先说。佛教弟子纳衣乞食。宿罪因缘生在恶世。染着心多。若得好衣美食着心则深。又为求好衣食故妨废行道。是菩萨净佛国土。众生无量福德成就。五欲一等故不复贵着。亦不更求故无所妨。又复若行者离五欲修苦行则增长嗔恚。又复忆念五欲则生烦恼。尔时则无所向。是故佛言。舍苦乐用智慧处中道。是故净佛国土。五欲施无妨。问曰。若尔者毗尼中何以一比丘言。我知佛法义受五欲不妨道。是比丘应呵乃至三。不止摈出。答曰。佛法有二种。小乘大乘。小乘中薄福之人三毒偏多。如婆差经中佛说。我白衣弟子非一非二乃至出五百人。受赤栴檀涂身及受好香花。妻子共卧使令奴婢而断三结得须陀洹。尽三结薄三毒得斯陀含。是阿梨吒比丘闻是事即言。虽受五欲而不妨道。不知是事。佛为谁说。佛为白衣故说。此比丘持着出家法中说。是须陀洹斯陀含等不作是言我尽形寿不犯欲。以有余三毒故。时时忘道而发淫心。出家人于僧中口自誓言。我尽形寿不犯淫欲。佛言。若出家人犯欲则弃。是比丘自誓而犯。是一罪。知佛所制而故违犯。是二罪。是比丘见白衣得道故。而以自身同彼。是故堕罪。净佛国土有二种众生。若出家若在家。在家者虽受五欲无罪亦无所妨。如兜率陀诸天及郁单曰人。虽受五欲不起重罪。出家众生随佛所听。出家五欲亦无过咎。小乘法中为阿梨吒比丘说。薄福重罪之人心多悔故。净佛土者世世习行六波罗蜜三解脱门。虽得五欲亦不染着。如经中说。所谓菩萨摩诃萨行般若波罗蜜作是念。我当自入初禅。亦当教化众生入初禅四禅四无量心。乃至三十七品亦如是。是菩萨作是愿。我作佛时尽行四禅乃至三十七品。如是福德故众生虽受五欲不能为妨。是菩萨作无量阿僧祇愿。随尔所时行道尽具足是愿。是菩萨一切善法皆成就。及所成就众生一切善法成就故。得身端正见者无厌。亦成就众生令得端正。须菩提。菩萨应如是净佛土。复次净佛土者。乃至无三恶之名。何况有三恶道。问曰。诸佛以大慈悲心为苦恼众生故出世。若无三恶道何所怜愍。答曰。佛出为度众生故。而三恶道众生不可度。但可令种善根而已。是故佛名天人师。若无天人但有三恶道可应有难。应作是问。问曰。佛怜愍众生净佛国土中。何以无三恶道众生。答曰。怜愍一切众生平等无异。此中说清净业因缘。是国土中无三恶道。又佛非但一国土。乃有十方恒河沙国土。佛有清净国土有杂国土。杂国土中则具有五道净佛国土。或有人天别异。或无有人天别异。如过去天王佛国土中。唯佛世尊以为法王。是故名为天王佛。复有国土无三毒邪见。问曰。诸佛但为除众生烦恼故出世。邪见三毒即是烦恼。若无烦恼出何所为。答曰。有人言。是中大福德因缘故。邪见三毒不发故言无。复次有人言。是中诸菩萨皆得无生法忍。常修六波罗蜜等诸功德。常游十方度脱众生。于诸佛所修习诸佛三昧胜教化无数声闻辟支佛。亦胜教化阿鞞跋致菩萨成就众生菩萨净佛土菩萨。为近佛道故利益转大。是国土无二乘之名者。问曰。余佛有三乘教化岂独劣耶。答曰。佛出五浊恶世。于一道分为三乘。问曰。若尔阿弥陀佛阿閦佛等不于五浊世生。何以复有三乘。答曰。诸佛初发心时。见诸佛以三乘度众生。自发愿言我亦当以三乘度众生。亦无无常苦空无我之名者。以众生深着常乐等颠倒故为说无常等苦法。是中无常乐等倒故不须无常苦。若无病则不须药。亦无我所有乃至无诸烦恼结使亦如是。无二乘故亦无须陀洹等诸果。但一向着诸法实相。先得无生法忍者得诸三昧陀罗尼门。转复增益诸地等功德。风吹七宝之树随所应度而出声者。是菩萨欲使众生易闻法故。七宝之树出法音声。宝树遍满国土故。众生生便闻法。余心不生但生法心。问曰。诸佛有无量不可思议神通力。何以不变化作无量身说法度众生。何须树木音声。答曰。众生甚多。若佛处处现身众生不信。谓为幻化心不敬重。有众生从人闻法心不开悟。若从畜生闻法则便信受。如本生经说。菩萨受畜生身为人说法。人以希有故无不信受。又谓畜生心直不诳故。有人谓畜生是有情之物皆有欺诳。以树木无心而有音声则皆信受。所谓空无相无作。有佛无佛一切法常空。空故无相。无相故无作无起。如是等法昼夜常出。余国土以神通力口力种种变化。此中常自然音声净佛国土。佛常为诸佛所赞大作功德故。能得如是净国。若闻净国佛名则毕定作佛。问曰。余佛种种勤苦说法。众生尚不得道。何以但闻佛名便得道。答曰。余处佛种种说法。众生或得道或得善根终不空说。若闻是佛名毕至阿鞞跋致不言今得。问曰。一切佛若人好心闻名皆当至佛。如法华经中说。福德若大若小皆当作佛。何以独说净国佛。答曰。人闻余佛名字。谓受生与人无异但有一切智得道。为异心不敬重故。虽种善根亦不能深。是中是法性身佛身无量无边光明说法音声遍满十方国土。国中众生皆是近佛道者。无量阿僧祇由旬众中说法。胜无量亿阿僧祇日月光明。常从身出。佛令众生见则得见若不听则不见。是佛一一毛孔边常出无量无边阿僧祇佛。一一诸佛等无异。于化佛边展转复出。随应度众生。见佛优劣。根本真佛无有分别大小之异。如是等若见若闻名若闻如是功德。深信敬重故。所种善根云何不毕定作佛。复次是佛说法时无有疑者。乃至无一人言是法为非。佛口所说悉皆是法。问曰。人从释迦文尼佛闻法生疑者多。答曰。佛此中自说因缘。有人薄福不种善根不得善知识故。生疑着我见边见邪见等。诸烦恼覆故非佛言是佛。是佛言非佛。不深种善根不顺善师。三毒邪见一时发起无所依。随任意自恣若见邪见。顺其意故言是一切智。见诸佛说毕竟空。不顺其意便言非佛。非法言法。法言非法。如是人于诸佛所多生疑。多生疑故心悔。是净佛国中无如是罪人故不生疑。佛言。如是罪人破诸法实相故死堕地狱恶道中。诸菩萨得阿耨多罗三藐三菩提。见诸罪人往来生死中。以佛神通力拔出众生令住正定聚中。不堕三恶趣。是名净佛土。是佛土中无如是诸过无不具足。于世间出世间有漏无漏有为无为等中无有障碍。所谓国土七宝众生身端正相好庄严无量光明常闻法音。常不远离六波罗蜜乃至十八不共法。是中众生皆毕竟至阿耨多罗三藐三菩提。问曰。上闻佛名毕定至佛。此于诸法无碍必得作佛。有何差别。答曰。此中众生常见佛常闻法。深种善根多集佛法故疾得作佛。闻名者虽俱毕竟定而小不如。如是等名为净国土相。如十地中庄严菩提树说

    大智度论释毕定品第八十三

【经】须菩提白佛言。世尊。是菩萨摩诃萨为毕定为不毕定。佛告须菩提。菩萨摩诃萨毕定非不毕定。世尊。何处毕定。为声闻道中为辟支佛道中为佛道中。佛言。菩萨摩诃萨非声闻辟支佛道中毕定。是佛道中毕定。须菩提白佛言。世尊。为初发意菩萨毕定。为最后身菩萨毕定。佛言。初发意菩萨亦毕定。阿鞞跋致菩萨亦毕定。最后身菩萨亦毕定。世尊。毕定菩萨堕恶道中生不。不也。须菩提。于汝意云何。若八人若须陀洹斯陀含阿那含阿罗汉辟支佛生恶道中不。不也世尊。如是须菩提。菩萨摩诃萨从初发意已来。布施持戒忍辱精进行禅定修智慧。断一切不善业。若堕恶道。若生长寿天若不得修善法处。若生边国若生恶邪见家无作见家。是中无佛名无法名无僧名。无有是处。须菩提。初发意菩萨于阿耨多罗三藐三菩提。以深心行十不善道。无有是处。世尊。若菩萨摩诃萨有如是善根功德成就。如佛自说本生受不善果报。是时善根为何所在。佛告须菩提。菩萨摩诃萨为利益众生故随而受身。以是身利益众生。须菩提。菩萨摩诃萨作畜生时。有是方便力。若怨贼欲来杀害。以无上忍辱无上慈悲心。舍身不恼怨贼。汝诸声闻辟支佛无有是力。以是故。须菩提。当知菩萨摩诃萨欲具足大慈悲心。为怜愍利益众生故受畜生身。须菩提白佛言。世尊。菩萨摩诃萨住何等善根中受如是诸身。佛告须菩提。菩萨摩诃萨从初发意乃至道场。于其中间无有善根不具足者。具足已当得阿耨多罗三藐三菩提。以是故。菩萨摩诃萨从初发意应当学具足一切善根。学善根已当得一切种智。当断一切烦恼习。须菩提白佛言。世尊。云何菩萨摩诃萨成就如是白净无漏法。而生恶道畜生中。佛告须菩提。于汝意云何。佛成就白净无漏法不。须菩提言。佛一切白净无漏法成就。须菩提。若佛自化作畜生身。作佛事度众生。实是畜生不。须菩提言。不也。佛言。菩萨摩诃萨亦如是。成就白净无漏法。为度众生故受畜生身。用是身教化众生。佛告须菩提。如阿罗汉作变化身。能使众生欢喜不。须菩提言能。佛言。如是如是。须菩提。菩萨摩诃萨用是白净无漏法。随所度众生而受身。以是身利益众生亦不受苦。须菩提。于汝意云何。幻师幻作种种形。若象马牛羊男女等以示众人。须菩提。是象马牛羊男女等有实不。须菩提言。不实也世尊。佛言。如是须菩提。菩萨摩诃萨白净无漏法成就。现作种种身以示众生故。以是身饶益一切。亦不受众苦。须菩提白佛言。世尊。菩萨摩诃萨大方便力得圣无漏智慧。而随所应度众生身而作种种形以度众生

【论】问曰。上阿鞞跋致品中说如是相。是阿鞞跋致如是相非阿鞞跋致。阿鞞跋致即是毕定。须菩提。今何以更问。答曰。是般若波罗蜜有种种门。有种种道。阿鞞跋致是一门中说。今问毕定更问异门。复次佛心中一切众生一切法皆毕定人以智不及故名为不毕定。佛知虽无量阿僧祇劫积大功德必退作小乘者。亦知微细昆虫虽未有善心。过尔所劫发心后当作佛。定知一切法皆如是。从是因得是果。是故名佛一切法中无碍。以毕定知故。复次须菩提。闻法华经中说。于佛所作少功德。乃至戏笑一称南无佛。渐渐必当作佛。又闻阿鞞跋致品中有退不退。又复闻声闻人皆当作佛。若尔者不应有退。如法华经中说毕定。余经说有退有不退。是故今问为毕定为不毕定。如是等种种因缘故问定不定。佛答。菩萨是毕定。须菩提。心以入涅槃为毕定。是故问为何道中毕定。佛答非毕定二乘。但于大乘中毕定。求佛道者有上中下。是故问。为初发意为阿鞞跋致为最后身毕定。须菩提意。谓为阿鞞跋致已上毕定。住佛道中故。佛答三种菩萨皆毕定。毕定者必当作佛。问曰。如上品中说。佛以佛眼见十方菩萨。求佛如恒河沙。得阿鞞跋致者若一若二。今何以言三种菩萨尽皆毕定。答曰。我先已说般若甚深有无量门。有说诸菩萨退而不毕定。有处说菩萨毕定不退如阿鞞跋致品中。须菩提问佛。菩萨退者于何处退。为从色为从受想行识乃至十八不共法。毕竟空故诸法皆不退。此中佛何以更说不退。问曰。是二义何者是实。答曰。二事皆实。佛口所说无不实者。如佛或说诸法空无所有。或说布施持戒等是有为。初发心者说诸法有为。久学人着善法者说诸法空无所有。懈怠于阿耨多罗三藐三菩提不牢固者。如是人应从声闻道得度而不求声闻久于生死中受苦。是故说发心如恒河沙得阿鞞跋致者若一若二。众生闻是已能堪受众苦者。毕定阿耨多罗三藐三菩提。若不能者取声闻辟支佛道。有人堪任得佛。而大悲心薄自爱身重。此人闻佛难得多有退者。作是念。我或不能得佛不如早取涅槃。何用世世受勤苦为。为是人故说一切菩萨乃至初发心皆毕定。如法华经中说。问曰。若菩萨皆毕定佛。何以故。种种呵二乘。不听菩萨取二乘证。答曰。求佛道者应遍知法性。是人畏老病死故于法性少分取证。便自止息舍佛道不度众生。诸佛菩萨之所呵责。汝欲舍去会不得离。得阿罗汉证时不求诸菩萨深三昧。又不广化众生。是则迂回于佛道稽留。问曰。阿罗汉先世因缘。所受身必应当灭。住在何处而具足佛道。答曰。得阿罗汉时。三界诸漏因缘尽。更不复生三界。有净佛土出于三界。乃至无烦恼之名。于是国土佛所。闻法华经具足佛道。如法华经说。有罗汉若不闻法华经自谓得灭度。我于余国为说是事。汝皆当作佛。问曰。若阿罗汉往净佛国土受法性身。如是应得疾作佛。何以言迂回稽留。答曰。是人着小乘因缘。舍众生舍佛道。又复虚言得道。以是因缘故。虽不受生死苦恼。于菩萨根钝不能疾成佛道。不如直往菩萨。复次佛法于五不可思议中最第一。今言漏尽阿罗汉还作佛。唯佛能知论议者正可论其事不能测知。是故不应戏论。若求得佛时乃能了知。余人可信而不可知。毕定菩萨堕三恶道中不者。须菩提闻佛说无量本生因缘或象鹿龟鸽孔雀鹦鹉等受种种苦。是故问佛。世尊若菩萨受如是等畜生身。云何言一切菩萨毕定。毕定者即是阿鞞跋致。阿鞞跋致者不堕三恶趣。佛反问答。于汝意云何。八人等圣人为堕三恶道不。须菩提思惟。是诸圣人入圣道故无堕三恶道因缘。思惟已。答言。不也。佛言。菩萨亦如是。堕三恶道因缘尽故云何堕三恶道。堕三恶道因缘者。所谓诸不善法。是菩萨从初发心已来修习布施持戒等诸善法。断诸杀生等十不善道。若是人堕三恶道。无有是处。何以故。灭诸恶法增益善法故。不善道有上中下。上者堕地狱中者堕畜生下者堕饿鬼。是菩萨三种已尽。深心悲念众生。是故不堕。问曰。若尔者三恶道可不于中生。是菩萨福德多。何以不于长寿天中生。答曰。是菩萨怜愍众生行六波罗蜜。虽能入禅波罗蜜。和合慈悲行不着禅味。命欲终尽念欲界法故退禅道。以彼中无苦恼深着禅味难可得度故。不生长寿天。以边国障碍不得修善法故不生。所以者何。是菩萨拔出吝法根本。吝法因缘故生边国不知法处。复次是菩萨常好中道舍离二边故。不生边国。边国者无三宝之名。不识七众。但贵今世现事。不贵福德道法故名边地。不但生边国故名为边地。若识三宝知罪福相续因缘。解诸法实相。是人虽生阎浮提外不名为边。何况生阎浮提中。是菩萨常乐为他说法。亦深爱善法故得随意善众生共生。所谓为中国人。于中国不生邪见家。何以故。是菩萨世世常自行正见。亦教他正见。赞正见法。欢喜赞叹行正见者。是故不生恶邪见家。问曰。是菩萨大福德智慧力。应生边地邪见家而教化之。何以畏而不生。答曰。菩萨有二种。一者成就大力菩萨。二者属因缘新发心菩萨。大菩萨为众生随所应度受身。不避边地邪见。新发意菩萨若生是处。既不能度人又自败坏。是故不生。譬如真金在泥终不败坏铜铁则坏。邪见者所谓无作见。虽六十二种皆是邪见无作最重。所以者何。无作言不应作功德求涅槃。若言天作。若言世界始来。虽是邪见而不遮作福德。以无作大恶故不生。又初发心菩萨深恶心行十不善道。无有是处。何以故。是菩萨一心回向。贵重阿耨多罗三藐三菩提。不贵世间法。是人未离欲因缘故。虽起诸烦恼终不深心作恶。虽加杖楚终不夺命。不取他财令其失命。是菩萨断一切不善法。修集一切善法故。不生八难处常得八好处。须菩提问。若菩萨有如是善根成就。云何本生因缘作鹿马等。佛答。菩萨实有福德善根成就。为利益众生故受畜生形。亦无畜生罪。此中佛自说因缘。所谓菩萨在畜生中慈愍怨贼。阿罗汉辟支佛所无有。阿罗汉辟支佛怨贼来害。虽不加报不能爱念供养供给。如菩萨本身作六牙白象。猎师以毒箭射胸。尔时菩萨象以鼻拥抱猎者。不令余象得害。语雌象言。汝为菩萨妇何缘生恶心。猎师是烦恼罪。非人过也。我得阿耨多罗三藐三菩提。当灭除其烦恼罪。譬如鬼着人咒师来但治鬼而不嗔人。是故莫求其罪。徐问猎者。汝何以射我。答言。我须汝牙。象即就石罅拔牙与之。血肉俱出不以为痛。供给粮食示语道径。如是等慈悲。阿罗汉辟支佛所无有。如是好心云何受畜生身。当知是变化度于众生。问曰。何以不作人身而为说法而作此兽身。答曰。有时众生见人身则不信受。见畜生身说法。则生信乐受其教化。又菩萨欲具足大慈悲心。欲行其实事。众生见之惊喜皆得入道

大智度论卷第九十三大智度论释毕定品第八十三之余(卷第九十四)

        龙树菩萨造

        后秦龟兹国三藏鸠摩罗什译

【经】世尊菩萨摩诃萨住何等白净法。能作如是方便力而不受染污。佛言。菩萨用般若波罗蜜作如是方便力。于十方如恒河沙等国土中饶益众生。亦不贪着是身。何以故。著者着法着处。是三法皆不可得。自性空故空不着空。空中无著者亦无著处。何以故。空中空相不可得须菩提是名不可得空。菩萨住是空中。能得阿耨多罗三藐三菩提。世尊菩萨但住般若波罗蜜中。得阿耨多罗三藐三菩提。不住余法中耶。须菩提。颇有法不入般若波罗蜜者不。世尊。若般若波罗蜜自性空。云何一切法皆入般若波罗蜜中。世尊空中无有法若入若不入。须菩提。一切法一切法相空不。世尊空。须菩提。若一切法一切法相空。云何言一切法不入空中。须菩提白佛言。世尊。云何菩萨摩诃萨行般若波罗蜜时。住一切法空中。能起神通波罗蜜。住是神通波罗蜜中。到十方如恒河沙等国土。供养现在诸佛。闻诸佛说法。于诸佛所种善根。佛告须菩提。菩萨摩诃萨行般若波罗蜜时。观是十方如恒河沙等国土皆空。是国土中诸佛亦性空。但假名字故。诸佛现身所假名字亦空。若十方国土及诸佛性不空者。空为有偏。以空不偏故。一切法一切法相空。以是故一切法一切法相空。是故菩萨摩诃萨行般若波罗蜜。用方便力生神通波罗蜜。住是神通波罗蜜中。起天眼天耳如意足知他心智宿命智。知众生生死。若菩萨远离神通波罗蜜。不能得饶益众生。亦不能得阿耨多罗三藐三菩提。是菩萨摩诃萨神通波罗蜜。是阿耨多罗三藐三菩提道。何以故。用是天眼自见诸善法。亦教他人令得诸善法。于善法亦不着。诸善法自性空故空无所著。若着则受味。是空中无有味。是菩萨摩诃萨行般若波罗蜜时能生如是天眼。用是眼观一切法空。见是法空不取相不作业。亦为人说是法。亦不得众生相。不得众生名。如是菩萨摩诃萨用无所得法故。起神通波罗蜜。用是神通波罗蜜。神通所应作者能作。是菩萨用天眼通过于人眼。见十方国土。见已飞到十方饶益众生。或以布施或以持戒。或以忍辱或以精进。或以禅定或以智慧饶益众生。或以三十七助道法。或以诸禅解脱三昧。或以声闻法或以辟支佛法。或以菩萨法或以佛法饶益众生。为悭者如是说法。诸众生当行布施。贫穷是苦恼法。贫穷之人自不能益。何能益他。以是故。汝等当勤布施。自身得乐亦能令他得乐。莫以贫穷故共相食啖。不得离三恶道为破戒者说法。诸众生破戒法大苦恼。破戒之人自不能益何能益他。破戒法受苦果报。若在地狱若在饿鬼若在畜生。汝等堕三恶道中自不能救何能救人。以是故。汝等不应随破戒心死时有悔。若有共相嗔诤者。说如是法。诸众生莫共相嗔。嗔乱心人不顺善法。汝等今共相嗔乱心。或堕地狱若饿鬼畜生中。以是故。汝等不应生一念嗔恚心。何况多。为懈怠众生说法令得精进。散乱众生令得禅定。愚痴众生令得智慧。亦如是行淫欲者令观不净。嗔恚者令观慈心。愚痴众生令观十二因缘。行非道众生令入正道。所谓声闻道辟支佛道佛道。为是众生如是说法。汝等所著是法性空。性空法中不可得着。不着相是空相。如是须菩提。菩萨摩诃萨行般若波罗蜜时。住神通波罗蜜中。为众生作利益。须菩提。菩萨若远离神通。不能随众生意善说法。以是故。须菩提菩萨摩诃萨行般若波罗蜜时应起神通。须菩提譬如鸟无翅不能高翔。菩萨无神通不能随意教化众生。以是故须菩提。菩萨摩诃萨行般若波罗蜜。应起诸神通。起诸神通已。若欲饶益众生随意能益。是菩萨用天眼见如恒河沙等诸国土。及见是国土中众生。见已用神通力往到其所。知众生心随其所应而为说法。或说布施或说持戒或说禅定。乃至或说涅槃法。是菩萨用天耳闻二种音声。若人若非人。用天耳闻十方诸佛所说法皆能受持。如所闻法为众生说。或说布施乃至或说涅槃。是菩萨净他心智。用他心智知众生心。随其所应而为说法。或说布施乃至或说涅槃。是菩萨宿命智忆念种种本生处。亦自忆亦忆他人。用是宿命智念过去在在处处诸佛名字及弟子众。有众生信乐宿命者。为现宿命事而为说法。或说布施乃至或说涅槃。用如意神通力到种种无量诸佛国土。供养诸佛从诸佛种善根还来本国。是菩萨漏尽神通智证。用是漏尽神通智证故。为众生随应说法。或说布施乃至或说涅槃。如是须菩提。菩萨摩诃萨行般若波罗蜜时。应如是起诸神通。菩萨用修是神通故。随意受身苦乐不染。譬如佛所化人作一切事苦乐不染。菩萨摩诃萨行般若波罗蜜时。应如是游戏神通能净佛国土成就众生。复次须菩提。菩萨摩诃萨不净佛国土。不成就众生。不能得阿耨多罗三藐三菩提。何以故。因缘不具足故。不能得阿耨多罗三藐三菩提。须菩提白佛言。世尊。何等是菩萨摩诃萨因缘具足已得阿耨多罗三藐三菩提。佛告须菩提。一切善法是菩萨阿耨多罗三藐三菩提因缘。须菩提白佛言。世尊。何等是善法。以是善法故得阿耨多罗三藐三菩提。佛告须菩提。菩萨从初发意已来。檀波罗蜜是善法因缘。是中无分别是施者是受者。性空故。用是檀波罗蜜能自利益。亦能利益众生。从生死拔出令得涅盘。是诸善法皆是菩萨摩诃萨阿耨多罗三藐三菩提因缘。行是道过去未来现在诸菩萨摩诃萨得度生死。已度今度当度。尸罗波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。四禅四无量心四无色定四念处。乃至八圣道分十八空八背舍九次第定陀罗尼门。佛十力四无所畏四无碍智十八不共法。如是等功德皆是阿耨多罗三藐三菩提道。须菩提是名善法。菩萨摩诃萨具足是善法已当得一切种智。得一切种智已当转法轮。转法轮已当度众生

【论】释曰。尔时须菩提问。住何等善根故能受此身。佛答。菩萨摩诃萨一切善法具足。乃至须菩提大欢喜白佛言。菩萨摩诃萨大方便成就力。住何等圣无漏法能受此身。而不为畜身所染。譬如幻师亦如变化住何等白净法能作如是方便。佛答。菩萨以般若波罗蜜力故能成就如是方便。作种种身能利益十方国土中众生。亦不贪是身。佛此中说因缘。是菩萨三法不可得。一者是菩萨身。二者所作鹿马。三者所用法。何以故。是法皆性空。空亦不着空。空中亦无贪着。法无故众生无。众生无故法亦无。此中佛说因缘。空中空不可得。不可得故菩萨云何贪是智慧。是名无所得空般若波罗蜜。菩萨住是中能得阿耨多罗三藐三菩提。以无障碍故易得。须菩提问。菩萨住六波罗蜜乃至十八不共法。今何以但说住无所得般若波罗蜜中得。佛答。须菩提。何法不入般若中。一切法皆入般若波罗蜜中。若住般若波罗蜜则住一切法。复问。若般若波罗蜜性空。云何一切法皆入中。此中须菩提自说因缘。一切法性空中无有法出无有法入。佛告须菩提。一切法一切法相空耶。世尊空。须菩提。若一切法一切法相空。一切法应入空中。汝云何言空中无有法出入。尔时须菩提心伏受解。闻是菩萨化身度众生。今问。世尊。菩萨云何住一切法空中。能起神通波罗蜜到十方如恒河沙国土供养佛听法种甚深善根。善根者诸陀罗尼三昧门。无碍解脱之根本。须菩提意般若波罗蜜性空。云何菩萨安住性空波罗蜜中能行是神通有法。佛言。空故能行。所以者何。须菩提。菩萨行般若时。观十方如恒河沙国土皆空。是国土诸佛亦空。问曰。若国土空佛亦应空。何以别说。答曰。佛以无量阿僧祇实功德得是身。能以一足指动十方如恒河沙国土。又菩萨世世来。深爱重佛不能疾观使空。是故不共国土合说。此中佛自说因缘。若十方国土及诸佛不空者空为有偏。有偏名有空不空处。今实不偏故。一切法一切法相空。菩萨行般若波罗蜜一切法无碍。以肉眼观色不通。见上不见下。见前不见后。通见障不见。昼见夜不见。知肉眼力少故。以方便更求天眼。方便力者令他界四大来在身中。用天眼义如先说。生天耳如意足他心智宿命智。知众生生死所趣等。菩萨若无神通不能得饶益众生。何以故。若无神通云何能令多众生发心。菩萨有神通犹尚不能尽令众生发心。何况无。是故神通波罗蜜是菩萨所行道。菩萨自见善法。亦令他人得见善法。亦不着是善法。何以故。是法性皆空故。问曰。天眼可见色。云何见善法。又言。见一切法性空。答曰。因中说果以天眼见。自见己身及见十方众生。然后用他心智宿命智。求其今世后世善根。是善根及果报久皆磨灭。磨灭故见空。是善根皆是有为法无自性。无自性故空。空故不可着亦不可受味。不可受味故不着。譬如蝇无处不着唯不着火焰。众生爱着亦如是。善不善法中皆着。乃至非有想非无想着故不能入涅槃。唯不能着般若波罗蜜性空火。所以者何。般若波罗蜜般若波罗蜜相空。若般若波罗蜜不空。即是味是可着处。菩萨住是智慧中不起有漏业。为众生说法。亦知众生假名不可得安住是无所得般若波罗蜜中。而能具足神通事。若菩萨不得是无障碍般若。则不能得无碍神通。菩萨得是无障碍空神通。飞到十方国土利益众生。如经中广说。或以布施或以持戒等。悭者为说布施等六波罗蜜义。如此中佛自广说。如此中说譬喻。如鸟无翅不能飞翔。菩萨亦如是。无神通波罗蜜不能教化众生。菩萨以天眼见十方国土诸佛及一切众生。以天耳力从诸佛闻法。以如意神通力放大光明。或现水火作种种变化现奇特事。令众生发希有尊重心。以他心智力故。知他心心数法所著所厌可度不可度是利是钝是善根成就是未成就。如是等知他众生心。摄取善根成就者有可度者。以宿命智生死智观其本末何所从来。种何善根所好何行。从此终当生何所。何时当得解脱。如是筹量思惟知可度者。过去业因缘未来世果报。复以神通力。是人应以恐怖度者。以地狱示之。汝当生此中。应以欢喜度者示以天堂。眼见是事心怀惊怖欢喜厌患世间。尔时以漏尽神通说漏尽法。众生闻是法破其着心。以三乘而得涅槃。譬如白鹭欲取鱼时筹量进止不失期会知其可得即便取之终不空也。菩萨亦如是。以神通力故观众生本末应度因缘国土时节。知其信等诸根增利诸因缘具足而为说法则不空也。是故说菩萨离神通不能饶益众生如鸟无翅。余神力如佛自说。以天眼见十方众生生死。亦知众生心随意说法。乃至善修神通力。而为众生受身。不为苦乐所污。是菩萨于众生中。或为父或为子或为师或为弟子或为主或为奴。或为象马或为乘象马者。或时富贵力势或时贫贱。于此诸事亦不为染污。譬如佛所化人作一切事不染苦乐。一切事者如先作种种阿僧祇身度众生。苦乐不染者乐中不生爱。苦中不生嗔。不如生死众生随处起烦恼。菩萨应如是游戏神通成就众生净佛国土。问曰。菩萨神通力有所作。何以名游戏。答曰戏名如幻师种种现变。菩萨神通种种现化名之为戏。复次佛法中三三昧空名为上行。何以故。似如涅槃无所著无所得故。诸余行法皆名为下。下如小儿。是故说神通力名为游戏。于成就众生净佛土中最为要用成就众生。如是中说净佛土共修善根。问曰。何必要用成就众生净佛国土。答曰。佛自说因缘。不成就众生净佛国土不能得无上道。何以故。因缘不具足则不能得阿耨多罗三藐三菩提。因缘者所谓一切善法。从初发意行檀波罗蜜乃至十八不共法。于是行法中无忆想分别。是施者是财物是受者。乃至十八不共法亦如是。若菩萨不着心无所分别。行六波罗蜜乃至十八不共法。是为阿耨多罗三藐三菩提因缘。以是道得阿耨多罗三藐三菩提。亦能自度又能度众生。问曰。菩萨若着心布施有何等过而不名具足。着心布施受者恩重。答曰。虽有小利而有大过。如美食杂毒虽有美利而自丧命。问曰。何者是过。答曰。若着心布施有不称意事则生恚怒。若受者不感其恩即成怨嫌。若着心供养善人有少凶衰则嫌。布施无应悔惜所施。若布施心悔所受果报则不清净。复次着心布施者深心贪着财物。若有侵夺则便加害。自念我为福德好事集财。汝何故侵夺。先贪财物为今世事。而作布施为后世事爱惜转深。以染着故若有侵夺能为重罪。重罪因缘故受三恶道苦。复次贪着因缘故生嗔恚。嗔恚因缘故加刀杖。刀杖杀害受诸苦恼。复次人起愚痴业大不安隐。行此虚诳不实事故后必致大患。十方诸佛皆说无相解脱门。诸法无相相是为实。若人取是财物虚诳不实相。然后心着。心着故期大果报而能施与。譬如人欲求多收故大用谷子。如是着心布施果报少而不净。终归于尽受诸忧恼不可称说皆由取相。故有如是过。若以如实相行布施。无有如是过。无量阿僧祇生死中受诸福乐而亦不尽。乃至得阿耨多罗三藐三菩提。复次若人以着心行善法。是人若闻诸法毕竟空。即时舍所行法着是空法取相以此为实。先者为虚诳。是人则失二种法。失先善法而堕邪见。着心者有如是过。譬如重病之人虽有众药疗之无损药复作病。着心行诸功德有如是等过罪。菩萨舍于着心不取空相如如法性实际。于布施等法亦如是。见为一切众生回向阿耨多罗三藐三菩提。复次菩萨布施时作是念。如十方三世诸佛。毕竟清净智慧知诸法实相。亦知是布施相。我亦以是性回向。复次是菩萨一切五情心心数法中。不用不行不能知诸法相故。是法皆是因缘边生。虚诳无有自性故我今欲知诸法实相。回向是诸虚诳入实相中皆无有异。我今未能得诸法清净实智慧故。有所分别是虚是实。以清净智慧知之则皆作第一义谛。入第一义谛中皆为清净无有别异。如是布施等回向直至佛道。是故说无所分别心能行布施等。是名真菩萨道

    大智度论释四谛品第八十四

【经】须菩提白佛言。世尊。若是诸法是菩萨法何等是佛法。佛告须菩提。如汝所问。是诸法是菩萨法何等是佛法者。须菩提。菩萨法亦是佛法。若知一切种是得一切种智断一切烦恼习。菩萨当得是法。佛以一念相应慧。知一切法已得阿耨多罗三藐三菩提。须菩提是为菩萨佛之差别。譬如向道得果异。是二人俱为圣人。如是须菩提。菩萨摩诃萨无碍道中行。是名菩萨摩诃萨。解脱道中无一切闇蔽是为佛。须菩提白佛言。世尊。若一切法自相空。自相空法中云何有差别之异。是地狱是饿鬼是畜生是天是人是性地人是八地人是须陀洹人是斯陀含阿那含阿罗汉人是辟支佛是菩萨是多陀阿伽度阿罗呵三藐三佛陀。世尊。如诸人不可得。业因缘亦不可得。果报亦不可得。佛言。如是如是。如汝所言。自相空法中无众生无业因缘无果报。须菩提。众生不知是诸法自相空。是众生作业因缘若善若恶若无动。罪业因缘故堕三恶道中。福业因缘故在人天中生。无动业因缘故色无色界中生。是菩萨摩诃萨行檀波罗蜜乃至十八不共法时。尽受行是助道法。如金刚三昧得阿耨多罗三藐三菩提。得已饶益众生。是利常不失故不堕五道生死中。须菩提白佛言。世尊。佛得阿耨多罗三藐三菩提已。得五道生死不。佛言。不得也须菩提。世尊。得业若黑若白若不黑不白不。佛言不也。世尊。若不得云何说。是地狱饿鬼畜生人天须陀洹乃至阿罗汉辟支佛菩萨诸佛。须菩提。若众生知诸法自相空。菩萨摩诃萨不求阿耨多罗三藐三菩提。亦不拔众生于三恶趣乃至五道往来生死中。须菩提以众生实不知诸法自性空故。不得脱五道生死。是菩萨从诸佛所闻诸法自性空。发意求阿耨多罗三藐三菩提。须菩提。诸法不尔。如凡夫人所著。是众生于无所有法中。颠倒妄想分别得法。无众生有众生。相无色色相。无受想行识受想行识相。乃至一切有为法无所有。用颠倒妄想心作身口意业因缘。往来五道生死中不得脱。是菩萨摩诃萨行般若波罗蜜时。一切善法内般若波罗蜜中。行菩萨道得阿耨多罗三藐三菩提。得阿耨多罗三藐三菩提已。为众生说四圣谛。苦苦集苦灭苦灭道。开示分别一切助道善法。皆入四圣谛中。用是助道善法故分别有三宝。何等三。佛宝法宝僧宝。不信拒逆是三宝故。不得离五道生死。须菩提白佛言。世尊。用苦圣谛得度。用苦智得度。用集圣谛得度。用集智得度。用灭圣谛得度。用灭智得度。用道圣谛得度。用道智得度。佛告须菩提。非苦圣谛得度。亦非苦智得度。乃至非道圣谛得度。亦非道智得度。须菩提。是四圣谛平等故。我说即是涅槃。不以苦圣谛。不以集灭道圣谛。亦不以苦智。不以集灭道智得涅槃。须菩提白佛言。世尊。何等是四圣谛平等。须菩提。若无苦无苦智。无集无集智。无灭无灭智。无道无道智。是名四圣谛平等。复次须菩提。是四圣谛如不异。法相法性法住法位实际。有佛无佛法相常住为不诳不失故。是菩萨摩诃萨行般若波罗蜜时。为通达实谛故行般若波罗蜜。须菩提白佛言。世尊。云何菩萨摩诃萨为通达实谛故。行般若波罗蜜时。如通达实谛故不堕声闻辟支佛地。直入菩萨位中。佛告须菩提。若菩萨摩诃萨如实见诸法。见已得无所有法。得无所有法已见一切法空。四圣谛所摄。四圣谛所不摄法皆空。若如是观。是时便入菩萨位中。是为菩萨住性地中不从顶堕。用是顶堕故堕声闻辟支佛地。是菩萨住性地中能生四禅四无量心四无色定。是菩萨住是初定地中分别一切诸法。通达四圣谛。知苦不生缘苦心。乃至知道不生缘道心。但顺阿耨多罗三藐三菩提心。观诸法如实相。世尊。云何观诸法如实相。佛言。观诸法空。世尊。何等空。佛言自性空。是菩萨用如是智慧观一切法空。无法性可见。住是性中得阿耨多罗三藐三菩提。何以故无性相。是阿耨多罗三藐三菩提。非诸佛所作。非辟支佛所作。亦非阿罗汉所作。亦非向道人所作。亦非得果人所作。亦非菩萨所作。但众生不知不见诸法如实相。以是事故菩萨摩诃萨行般若波罗蜜。以方便力故为是众生说法

【论】问曰。佛法菩萨法大有差别。佛是一切智。菩萨未是一切智。须菩提何故生疑而问佛。何等是诸菩萨法。何等是佛法。答曰。此中佛教菩萨如佛所行。应如是行六波罗蜜等乃至一切种智。是故须菩提问。若如佛行与佛何异。佛可其意应如是问。色等诸法行处是同。但智慧利钝有异。此中佛自说因缘。菩萨虽如实行六波罗蜜而未能周遍。未能入一切门。是故不名为佛。若菩萨已入一切种智门。入诸法实相中。以一念相应智慧得阿耨多罗三藐三菩提。断一切烦恼习。得诸法中自在力。尔时名为佛。如月十四日十五日虽同为月十四日不能令大海水潮。菩萨亦如是。虽有实智慧清净。未能具足诸佛法故。不能动一切十方众生。月十五日光明盛满时。能令大海水潮。菩萨成佛亦如是。放大光明能动十方国土众生。此中佛自说譬喻。如向道得果虽同为圣人而有差别。菩萨亦如是。行者名为菩萨。从初发心乃至金刚三昧。佛已得果。断一切法中疑无所不了故名为佛。须菩提复问。自相空法中差别不可得。所谓是地狱乃至天。是性人八人是须陀洹乃至佛。世尊。如地狱等众生不可得业因缘亦应不可得。何以故。作业者不可得。业不可得故果报亦不可得。佛云何说佛与菩萨有差别。佛可须菩提意。还以所问答。须菩提。众生不知自性空法故能起善恶业。如经中广说。众生者凡夫未入正位人。是人我心颠倒烦恼因缘故起诸业。业者有三种。身口意。是三种业有二种。若善若恶。若有漏若无漏。恶业故堕三恶趣。善业故生天人中。善业复有二种。一者欲界系。二者色无色界系。色无色界系生业名不动。不动业故生色无色界。若众生自知诸法性空。即时不生着心。着心不生故不起业。乃至不生色无色界。以实不知故生。以是事故菩萨摩诃萨尽受行布施等法乃至十八不共法。无所失无所少。乃至用如金刚三昧。得阿耨多罗三藐三菩提。大饶益众生。众生得是利益故不复往来五道生死。须菩提复问。佛得阿耨多罗三藐三菩提时。实得是五道不。佛言不得。问曰。佛先说大利益故不堕五道。今云何言不得。答曰。决定取相邪见。堕邪见五道生死不得。但凡夫人以颠倒因缘起业。假名有生死五道。其实如幻如梦。复问。得黑白等四种业不。佛言不。黑业者是不善业果报。地狱等受苦恼处。是中众生以大苦恼闷极故名为黑。受善业果报处。所谓诸天。以其受乐随意自在明了故名为白业。是业是三界天。善不善业受果报处。所谓人阿修罗等八部。此处亦受乐亦受苦故名为白黑业。无漏业能破不善。有漏业能拔众生令离善恶果报中。问曰。无漏业应是白。何以言非白非黑。答曰。无漏法虽清净无垢。以空无相无作故无所分别不得言白。黑白是相待法。此中无相待故不得言白。复次无漏业能灭一切诸观中分别故有黑白。此中无观故无白。须菩提复问。若不得是四种业。云何分别是地狱乃至阿罗汉。若无黑业云何说是地狱畜生饿鬼。若无白业云何说是天人。若无黑白业云何说是阿修罗道。若无不白不黑业云何说是须陀洹乃至阿罗汉。佛答。若一切众生自知诸法自性空者。菩萨不发阿耨多罗三藐三菩提意。亦不于六道中拔出众生。何以故。众生自知诸法性空则无所度。譬如无病则不须药。无闇则不须灯明。须菩提。今众生实不知自相空法故。随心取相生着。以着故染。染故随于五欲。随五欲故为贪所覆。贪因缘故悭虚诳嫉妒嗔恚斗诤。以嗔恚故起诸罪业无所识知。是故寿终随业因缘生于彼处。续作生死业。常往来六道中无复穷已。是故菩萨于诸佛及弟子所。闻说诸法空而慈愍众生。众生以狂愚颠倒故生着。我当作佛破众生颠倒令解诸法空相。所以者何。诸法不尔如凡人所著。众生法无有定实。但自于无所有中忆想分别望有所得。无众生中起众生想。无色中起色想。无受想行识中起识想。以狂颠倒故是人能起身口意业。于六道生死中不能得脱。若但生众生法想结缚犹轻易可得度。生贪欲嗔恚于是中起诸重业是为重缚。受此业果报则难可得度。譬如积微尘成山难可得移动。菩萨为是众生故欲破其生死因缘果报故。于般若中摄一切善法。行菩萨道得阿耨多罗三藐三菩提。为众生说四圣谛。所谓苦苦集苦灭灭苦道。种种因缘开示敷演。问曰。佛无量阿僧祇劫来习微妙法。所谓十八不共法。乃至无碍解脱诸甚深业。何以但说苦集灭道。答曰。众生所畏急者无过于苦。为除苦已然后示以佛道。如人重病先以除病为急。然后以宝物衣服庄严其身。苦者受五受众身。是一切苦本。性即是苦。是苦略而言之。是生老病等。如经中处处广说。苦集者爱等诸烦恼。爱是心中旧法。以是故佛说爱能生后身故是苦因。苦因即是集。若人欲舍苦先当断爱。爱断苦则灭。断爱即是苦灭。苦灭即是道。观是五众种种因缘苦及苦集过罪。所谓无常苦空无我。如病如疮如怨如贼等。于八圣道分中为正见。余七事助成发起。能断一切法中爱。如以酒发药。此人于一切世间无所复贪。得离苦火。然后示以妙法。复次此中佛自说因缘。所谓于四圣谛中摄一切善法。有人言。佛何以但说苦等四法。以是故佛说。一切助道善法。皆摄在四谛中。助道善法因缘故分别有三宝。众生不信三宝故不得离六道生死。问曰。须菩提何以作是粗问言为以苦灭以苦智灭以集灭集智灭。答曰。此非粗问。今问见苦等四谛体故灭。为用智故灭。爱等诸烦恼灭故名有余涅槃。若以苦谛得道。一切众生牛羊等亦应得道。若用苦智得道。离苦则无智。离苦智不名为苦谛。但名为苦。苦谛苦智和合故生。不得言但以苦灭但以智灭。乃至道谛亦如是。佛答。不以苦谛灭。亦不以苦智灭。乃至道谛道智亦如是。我说是四谛平等即是灭。不用苦谛灭。不用乃至道谛灭。何以故。是苦等四法皆从缘生。虚妄不实无有自性故不名为实。不实故云何能灭。问曰。二谛有漏凡夫所行法故。可是虚诳不实。道谛是无漏法无所著。虽从因缘和合生而不虚诳。又灭谛是无为法不从因缘有。云何言四法皆是虚诳。答曰。初得道知二谛是虚诳。将入无余涅槃亦知道谛虚诳。以空空三昧等舍离道谛。如说筏喻。灭谛亦无定法。如经中说。离有为无无为。因有为故说无为。苦灭如灯灭。不应戏论求其处所。是故佛说不以用苦乃至用道得灭。须菩提问佛。何者是四谛平等。佛答。若无八法处。所谓四谛四谛智是则平等。复次须菩提。四谛如实不诳不异。如法性法相法住实际。若有佛无佛法相常住。不用心心数法及诸观。但为不诳众生故。住一切余法皆颠倒妄着。颠倒果报生故虽能与人天喜乐。久久皆虚妄变异。但有一法所谓诸法实相。以不诳故常住不灭。如是菩萨行般若波罗蜜通达诸法实谛。须菩提复问。云何菩萨通达得实谛过声闻辟支佛地入菩萨位。佛答。若菩萨思惟筹量求诸法。无有一法可得定相。见一切法皆空。若在四谛若不在四谛。非四谛者虚空非数缘尽。余在四谛。若观如是法空。尔时入菩萨位。问曰。何以不说空亦空观入菩萨位。答曰不须是说。何以故。若说诸法空即是空。空亦空。若是空不空。不名为一切空。是故行是空得入菩萨位。菩萨住是性地中不堕顶性地者。所谓菩萨法位。如声闻法中燸法顶法忍法世间第一法名为性地。是法随顺无漏道故名为性。是中住必望得道。菩萨亦如是。安住是性地中。必望作佛。能生四禅四无量心四无色定。是菩萨住在禅地中。摄心分别思惟筹量诸法。通达四谛。所谓知见苦亦非缘。苦生心知苦是凡夫受身。着苦因缘故受诸忧恼。是人身皆如贼如怨无常空等。得是已即时舍不取苦相。亦不缘苦谛。菩萨法位力故。乃至道谛亦如是。但一心回向阿耨多罗三藐三菩提。知是四谛。药病相对。亦不着是四谛。但观诸法如实相。不作四种分别观。须菩提问。云何如实观诸法。佛言。观空。须菩提。若菩萨能观一切法若大若小皆空。是名如实观。复问。用何等空。佛答。用自相空。问曰。十八空中佛何以但说自相空。答曰。是中道空内外空等是小空。毕竟空无所得空等是甚深空。自相空是中空。自相有理破故而心不没。而能入甚深空中。是菩萨得如是法。观一切法皆空。乃至不见一法有性可住。得阿耨多罗三藐三菩提观诸法。如阿耨多罗三藐三菩提。阿耨多罗三藐三菩提亦自性空非佛所作。非大菩萨所作。非阿罗汉辟支佛所作。常寂灭相无戏论语言。众生不能知见如实相。是故菩萨行般若波罗蜜。以方便力为众生说法。方便力者菩萨得无生忍法入菩萨位。通达菩萨第一义谛观。是道相甚深微妙无得无舍。用妙智慧不可得。何况可得口说。大悲心深念众生。以空事故堕三恶道受大剧苦。若我直说是法则不信不受。则破坏法堕于地狱。我今当成就一切善法庄严身三十二相。引导众生。起无量无边诸佛神通力。得成佛道。一切众中主。于诸法得自在。若赞恶法众生犹尚当受。何况实法。是菩萨如所愿思惟行。为众生说使皆度脱

大智度论卷第九十四大智度论释七喻品第八十五(卷第九十五)

        龙树菩萨造

        后秦龟兹国三藏鸠摩罗什译

【经】须菩提白佛言。世尊。若诸法性无所有。非佛所作。非辟支佛所作。非阿罗汉所作。非阿那含斯陀含须陀洹所作。非向道人非得果人非诸菩萨所作。云何分别有诸法异。是地狱是畜生是饿鬼是人是天。乃至是非有想非无想天。用是业因缘故知有生地狱者。是业因缘故。知有生畜生饿鬼者。是业因缘故。知有生人中生四天王天乃至生非有想非无想天者。是业因缘故。知有得须陀洹斯陀含阿那含阿罗汉辟支佛者。是业因缘故。知是诸菩萨摩诃萨。是业因缘故。知是多陀阿伽度阿罗诃三藐三佛陀。世尊。无性法中无有业用作业因缘故。若堕地狱饿鬼畜生。若生人天乃至生非有想非无想天。以是业因缘故。得须陀洹斯陀含阿那含阿罗汉辟支佛。菩萨摩诃萨行菩萨道。当得一切种智。得一切种智故。能拔出众生于生死中。佛告须菩提。如是如是。无性法无业无果报。须菩提。凡夫人不入圣法。不知诸法无性相。颠倒愚痴故。起种种业因缘。是诸众生随业得身。若地狱身若畜生身若饿鬼身若人身若天身若四天王天身。乃至非有想非无想天身。是无性法无业无果报。无性常是无性。如须菩提所言。若一切法无性。云何是须陀洹乃至诸佛得一切种智。须菩提于汝意云何。道是无性不。须陀洹果乃至诸佛一切种智是无性不。须菩提言。世尊。道无性。须陀洹果亦无性。乃至诸佛一切种智亦无性。须菩提。无性法能得无性法不。不也世尊。佛告须菩提。有性法能得有性法不。不也世尊。须菩提。无性法及道。是一切法皆不合不散无色无形。无对一相所谓无相。须菩提。是菩萨摩诃萨行般若波罗蜜时。以方便力见众生。以颠倒故着五众。无常中常相。苦中乐相。不净中净相。无我中我相。着无所有处。是菩萨以方便力故于无所有中拔出众生。须菩提白佛言。世尊。凡夫人所著。颇有实不异不着故起业。业因缘故五道生死中不得脱。佛告须菩提。凡夫人所著起业处。无如毛发许实事但颠倒故。须菩提。今为汝说譬喻。智者以譬喻得解。须菩提。于汝意云何。如梦中所见人受五欲乐。有实住处不。须菩提白佛言。世尊。梦尚虚妄不可得。何况住梦中受五欲乐。于汝意云何诸法若有漏若无漏。若有为若无为。颇有不如梦者不。世尊。诸法若有漏若无漏。若有为若无为。无不如梦者。佛告须菩提。于汝意云何。梦中有五道生死往来不。世尊无也。于汝意云何。梦中有修道。用是修道若着垢若得净不。不也世尊。何以故。是梦法无有实事。不可说垢净。于汝意云何。镜中像有实事。能起业因缘。用是业因缘。堕地狱饿鬼畜生。若人若天四天王天处。乃至非有想非无想天处不。须菩提言。不也世尊。是像无有实事。但诳小儿。是事云何。当有业因缘。用是业因缘当堕地狱。乃至非有想非无想处。于汝意云何。是镜中像有修道。用是修道若着垢若得净不。须菩提言。不也世尊。何以故。是像空无实事。不可说垢净。于汝意云何。如深涧中有向。是向有业因缘。用是业因缘若堕地狱。乃至若生非有想非无想处不。须菩提言。不也世尊。是事空无有实音声。云何当有业因缘。用是业因缘堕地狱。乃至生非有想非无想处。于汝意云何。是向颇有修道。用是修道若着垢若得净不。不也世尊。是事无实。不可说是垢是净。于汝意云何。如焰非水。水相非河。河相是炎。颇有业因缘。用是业因缘堕地狱。乃至生非有想非无想处不。不也世尊。焰中水毕竟不可得。但诳无智人眼。云何当有业因缘。用是业堕地狱。乃至生非有想非无想处。于汝意云何。是焰有修道。用是修道若着垢若得净不。不也世尊。是焰无有实事。不可说垢净。于汝意云何。揵闼婆城如日出时见揵闼婆城。无智人无城有城想。无庐观有庐观想。无园有园想。是揵闼婆城颇有业因缘。用是业因缘堕地狱。乃至生非有想非无想处不。不也世尊。是揵闼婆城毕竟不可得。但诳愚夫眼。云何当有业因缘。用是业因缘堕地狱。乃至生非有想非无想处。于汝意云何是揵闼婆城有修道。用是修道若着垢若得净不。不也世尊。是揵闼婆城无有实事。不可说垢净。须菩提。于汝意云何。幻师幻作种种物。若象若马若牛若羊若男若女。于汝意云何。是幻有业因缘。用是业因缘堕地狱。乃至生非有想非无想处不。不也世尊。是幻法空无实事。云何当有业因缘。用是业因缘堕地狱。乃至生非有想非无想处。于汝意云何。用是幻有修道。用是修道若着垢若得净不。不也世尊。是法无有实事。不可说垢净。须菩提。于汝意云何。如佛所化人。是化人有业因缘。用是业因缘堕地狱。乃至生非有想非无想处不。不也世尊。是化人无有实事。云何当有业因缘。用是业因缘堕地狱。乃至生非有想非无想处。于汝意云何。是化人有修道。用是修道若着垢若得净不。不也世尊。是事无有实。不可说垢净。佛告须菩提。于意云何。于是空相中有垢者有净者不。不也世尊。是中无所有。无有着垢者。无有净者。须菩提。如无有着垢者。无有净者。以是因缘故。亦无垢净。何以故。住我我所众生有垢有净。实见者不垢不净。如实见者不垢不净。如是亦无有垢净

【论】问曰。佛已处处答是事。今须菩提。何以复问。答曰。义虽一所因事异。所谓一切法若有佛若无佛。诸法性常住空无所有。非贤圣所作。般若波罗蜜甚深微妙难解难量。不可以有量能知。诸佛贤圣怜愍众生故。以种种语言名字譬喻为说。利根者解圣人意。钝根者处处生着。着于语言名字。若闻说空则着空。闻说空亦空亦复生着。若闻一切法寂灭相语言道断而亦复着。自心不清净故。闻圣人法为不清净。如人目翳视清净珠见其目影便谓珠不净。佛种种因缘说。见有过罪而生于疑。作是言。若一切法空。空亦空。云何分别有六道常生。如是等疑难故。须菩提以经将讫。为众生处处问是事。是故重问。佛可须菩提意。问曰。须菩提以有难空。佛云何可其意。答曰。佛可其说。诸法空常住有佛无佛不异不可其难。云何分别有六道等。何以故。以其难欲破空故是中佛解其所难。所谓凡夫人不入圣法。未得圣道。不知无所有性。不善修习空三昧故。颠倒者四颠倒。愚痴者三界系无明。虽不说余烦恼。而此二法虚诳不实颠倒即是妄语虚诳。若从颠倒所生业及果报。以根本不实故。众生虽深着亦无定实。以是故五道皆空但有假名。又汝难诸贤圣。是诸贤圣以断颠倒差别故有异名。以颠倒不实故无所断。又复灭失无所有故名为断。若实有法可断。尚无断法。何况颠倒。是故一切贤圣果。皆是无所有。断颠倒即是圣人果。果即是断为果。所修道亦同无所有。是故修道时必当用空无相无作。道果分别故贤圣有差别。今实无所有法不能得无所有。云何有差别。是故不应难。须菩提意。若但颠倒故有世间。若有颠倒亦应有实。虚实相待故。是故问世尊。凡夫所著颇有实生。着起业业因缘故。六道生死不得解脱。佛答言不。何以故此中佛自说因缘。但颠倒故生着。若无颠倒云何有相待实法。乃至无毫厘许实事。毕竟无故。问曰。诸佛所行实义。所谓毕竟空。此非实耶。答曰。是第一义空亦因分别。凡夫颠倒故说。若无颠倒亦无第一义。若凡夫颠倒少多有实。第一义亦应有实。问曰。若二俱不实。云何得解脱。如人手垢还以垢洗。云何得净。答曰。诸法实相毕竟空第一义实清净。以有凡夫颠倒不清净法故有此清净法。不可破坏不变异故。以人于诸法实相起着欲生烦恼。是故说是法性空无所有。无所有故无实。虽二法皆不实。而不实中有差别。如十善十不善二事。皆有为法故虚诳不实。而善不善有差别。杀生法故堕恶道。不杀故生天上。如布施偷盗二事。虽取相着心是虚诳不实而亦有差别。如众生乃至知者见者无所有。而恼众生有大罪。慈念众生有大福。如慈能破嗔施能破悭。虽二事俱是不实而能相破。是故佛说诸法无有根本定实如毫厘许所有。欲证明是事故。说梦中受五欲譬喻。须菩提意。若一切法毕竟空无所有性。今何以故现有眼见耳闻法。以是故佛说梦譬喻。如人梦力故虽无实事而有种种闻见嗔处喜处。觉人在傍则无所见。如是凡夫人无明颠倒力故妄有所见。圣人觉悟则无所见。一切法若有漏若无漏。若有为若无为。皆不实虚妄故有见闻。又如梦中见六道生死往来。见须陀洹乃至阿罗汉。梦中无是法而梦见。梦中实无净无垢。业果报六道亦如是。颠倒因缘故起业。业果报亦应空。除却颠倒故名为道。颠倒无实故道亦不应实。镜中像向焰乃至如化亦如是。佛反问须菩提。于是法中有垢者有净者不。须菩提意。一切法中无我。云何当说有垢有净者。是故言无。佛言。若无受垢受净者。垢净亦无。问曰。若分别诸法。阿毗昙等经中有垢有净。但受垢净者无。三毒等诸烦恼是垢。三解脱门诸助道法等是净。答曰。虽有是说。是事不然。若众生法无所属亦无作者。若无作者亦无作法。无缚无解如人为火所烧。畏而舍离非火离火。众生亦如是。畏五众苦故舍离。非苦离苦。若无垢净者无有解脱。复次佛此中自说因缘。所谓我我所法中住。众生受垢受净。我毕竟无故。垢净无住处。住处无故。无垢无净。问曰。我虽无我见实有凡夫人住此中起诸烦恼。答曰。若无我我见无所缘。无所缘云何得生。问曰。虽无我于五众中邪行。谓有我生我见。五众是我我所。答曰。若以五众中定生我见因缘。于他五众中何以故不生。若于他五众生者则为大错乱。是故我见无有定缘。但颠倒故生。问曰。若颠倒生。何以故但自于己身生见。答曰。是颠倒狂错。不应求其实事。又复于无始生死中来。自于相续五众中生着。是故佛说。住我心众生受垢受净。又实见者无垢无净。若我定有实见者应有垢净。如实见者不垢不净。以是因缘故无垢无净。无垢无净者见诸法实相。又于诸法实相亦不着。是故无垢。诸法实相无相可取。是故无净。复次八圣道中不着。是名无净。除诸烦恼不着颠倒。是名无垢

    大智度论释平等品第八十六

【经】须菩提白佛言。世尊。见实者不垢不净。见不实者亦不垢不净。何以故。一切法性无所有故。世尊。无所有中无垢无净。所有中亦无垢无净。世尊。无所有中有所有中。亦无垢无净。世尊。云何如实语者不垢不净。不实语者亦不垢不净。佛告须菩提。是诸法平等相我说是净。须菩提。何等是净是诸法平等。所谓如不异不诳法相法性法住法位实际。有佛无佛法性常住是名净。世谛故说非最第一义。最第一义过一切语言论议音声。须菩提白佛言。世尊。若一切法空不可说。如梦如向如焰如影如幻如化。云何菩萨摩诃萨用是如梦如向如焰如影如幻如化法。无有根本定实。云何能发阿耨多罗三藐三菩提心。作是愿。我当具足檀波罗蜜。乃至具足般若波罗蜜。我当具足神通波罗蜜。具足智波罗蜜。具足四禅四无量心四无色定四念处。乃至具足八圣道分。我当具足三解脱门八背舍九次第定。我当具足佛十力。乃至具足十八不共法。我当具足三十二相八十随形好。具足诸陀邻尼门诸三昧门。我当放大光明遍照十方。知诸众生心如应说法。佛言须菩提。于汝意云何。汝所说诸法。如梦如向如焰如影如幻如化不。须菩提言。尔世尊。世尊。若一切法。如梦乃至如化。菩萨摩诃萨云何行般若波罗蜜。世尊。是梦乃至如化虚妄不实。世尊。不应用不实虚妄法能具足檀波罗蜜乃至十八不共法。佛告须菩提。如是如是不实虚妄法。不能具足檀波罗蜜乃至十八不共法。行是不实虚妄法。不能得阿耨多罗三藐三菩提。须菩提。是一切法皆是忆想思惟作法。用是思惟忆想作法。不能得一切种智。须菩提。是一切法能助道法。不能益其果。所谓是诸法无生无出无相。菩萨从初发意已来所作善业。若檀波罗蜜乃至一切种智。何以故。知诸法皆如梦乃至如化。如是等法不具足檀波罗蜜乃至一切种智。不能得成就众生净佛国土得阿耨多罗三藐三菩提。是菩萨摩诃萨所作善业。檀波罗蜜乃至一切种智。知如梦乃至如化。亦知一切众生如梦中行。乃至知如化中行。是菩萨摩诃萨不取般若波罗蜜。是有法用是不取故得一切种智。知是诸法如梦无所取。乃至诸法如化无所取。何以故。般若波罗蜜是不可取相。禅波罗蜜乃至十八不共法是不可取相。是菩萨摩诃萨知一切法是不可取相。已发心求阿耨多罗三藐三菩提。何以故。一切法不可取相。无根本定实如梦乃至如化。用不可取相法不能得不可取相法。但以众生不知不见如是诸法相。是菩萨摩诃萨为是众生故。求阿耨多罗三藐三菩提。是菩萨从初发意已来所有布施为一切众生故。乃至有所修智慧。皆为一切众生不为己身。菩萨摩诃萨不为余事故。求阿耨多罗三藐三菩提。但为一切众生故。是菩萨行般若波罗蜜时。见众生无众生。但众生相中住。乃至无知者无见者。知见相中住令众生远离颠倒。远离已置甘露性中。住是中者无有妄相。所谓众生相乃至知者见者相。是时菩萨动心念心戏论心皆舍。常行不动心不念心不戏论心。须菩提。以是方便力故。菩萨摩诃萨行般若波罗蜜时。自无所著亦教一切众生令得无所著。世谛故非第一义。须菩提白佛言。世尊。世尊得阿耨多罗三藐三菩提时得诸佛法。以世谛故得。以第一义中得。佛言。以世谛故说佛得是法。是法中无有法可得。是人得是法。何以故。是人得是法。是为大有所得。用二法无道无果。须菩提白佛言。世尊。若行二法无道无果。行不二法有道有果不。佛言。行二法无道无果。行不二法亦无道无果。若无二法无不二法。即是道即是果。何以故。用如是法得道得果。用是法不得道不得果。是为戏论。诸平等法中无有戏论无戏论相。是诸法平等。须菩提白佛言。世尊。诸法无所有性。是中何等是平等。佛言。若无有法无有无法。亦不说诸法平等相。除平等更无余法离一切法平等相。平等者若凡夫若圣人。不能行不能到。须菩提白佛言。世尊。乃至佛亦不能行亦不能到。佛言。是诸法平等。一切圣人皆不能行不能到。所谓诸须陀洹斯陀含阿那含阿罗汉辟支佛诸菩萨摩诃萨及诸佛。须菩提白佛言。世尊。佛者一切诸法中行力自在。云何说佛亦不能行不能到。佛告须菩提。若诸法平等与佛有异。应当如是问。须菩提。今诸凡夫人平等诸须陀洹斯陀含阿那含阿罗汉辟支佛诸菩萨摩诃萨诸佛及圣法皆平等。是一平等无二。所谓是凡夫人。是须陀洹乃至佛。是一切法平等中皆不可得。须菩提白佛言。世尊。若诸法平等中皆不可得。是凡夫人乃至是佛世尊凡夫人须陀洹乃至佛为无有分别。佛告须菩提。如是如是。诸法平等中无有分别。是凡夫人是须陀洹乃至是佛世尊。若无分别诸凡夫人须陀洹乃至佛。云何分别有三宝。现于世间佛宝法宝僧宝。佛言。于意云何。佛宝法宝僧宝与诸法等异不。须菩提白佛言。如我从佛所闻义。佛宝法宝僧宝与诸法等无异。世尊。是佛宝法宝僧宝即是平等。是法皆不合不散无色无形无对一相所谓无相。佛有是力能分别无相诸法处所。是凡夫人是须陀洹是斯陀含是阿那含是阿罗汉是辟支佛是菩萨摩诃萨是诸佛。佛告须菩提。如是如是。诸佛得阿耨多罗三藐三菩提不分别诸法。当知是地狱是饿鬼是畜生是人是天是四天王天。乃至是他化自在天是梵天乃至是非有想非无想处天。是四念处乃至八圣道分是内空乃至是无法有法空。是佛十力乃至是十八不共法不。须菩提言。不知也。世尊。以是故须菩提。当知佛有大恩力。于诸法等中不动而分别诸法。须菩提白佛言。世尊。如佛于诸法等中不动。凡夫人亦于诸法平等中不动。须陀洹乃至辟支佛亦于诸法平等中不动。世尊。若诸法等相即是凡夫人相即是须陀洹相乃至诸佛即是平等相。世尊。今诸法各各相。所谓色相异。受想行识相异。眼相异。耳鼻舌身意相异。地相异。水火风空识相异。欲相异。嗔痴相异。邪见相异。禅相异。无量心相异。无色定相异。四念处相异。乃至八圣道分相异。檀波罗蜜相异。乃至般若波罗蜜相异。三解脱门相异。十八空相异。佛十力相异。四无所畏相异。四无碍智相异。十八不共法相异。有为法性异。无为法性异。是凡夫人相异。乃至佛相异。诸法各各相异。云何菩萨摩诃萨行般若波罗蜜时。诸法异相中不作分别。若不作分别。不能行般若波罗蜜。若不行般若波罗蜜。不能从一地至一地。若不从一地至一地。不能入菩萨位。不能入菩萨位故。不能过声闻辟支佛地。不能过声闻辟支佛地故。不能具足神通波罗蜜。不具足神通波罗蜜故。不能具足檀波罗蜜。乃至不能具足般若波罗蜜。从一佛国至一佛国供养诸佛。于诸佛所种善根用是善根能成。就众生净佛国土。佛告须菩提。如汝所问。是诸法相亦是凡夫人。亦是须陀洹乃至佛世尊。是诸法各各相。所谓色相异。乃至有为无为法相异。云何菩萨摩诃萨观一相不作分别。须菩提。于汝意云何。是色相空不。乃至诸佛相空不。世尊实空。须菩提。空中各各相法可得不。所谓色相乃至诸佛相。须菩提言。不可得。佛言。以是因缘故当知诸法平等中。非凡夫人亦不离凡夫人。乃至非佛亦不离佛。须菩提白佛言。世尊。是平等为是有为法为是无为法。佛言。非有为法非无为法。何以故。离有为法无为法不可得。离无为法有为法不可得。须菩提。是有为法无为法。是二法不合不散无色无形无对一相所谓无相。佛亦以世谛故说非以第一义。何以故。第一义中无身行无口行无意行。亦不离身口意行得第一义。是诸有为法无为法平等相。即是第一义。菩萨摩诃萨行般若波罗蜜时。第一义中不动。而行菩萨事饶益众生

【论】释曰。须菩提思惟。佛答实见者妄见者无异。垢净见无故。思惟已问佛。见实者无垢无净。见不实者亦不垢不净。一切法性无所有故。无所有中无垢无净。所有中亦无垢无净。无所有断灭见故不应有垢净。所有无常见故不应有垢净。所有若决定是有。则不从因缘生。不从因缘生故常。常故无垢无净。须菩提白佛。实见者不实见者是义云何。佛答。垢净虽无别相。可说诸法平等故是名为净。若分别说垢净相是事不然。一切法平等故我说名净。佛告须菩提。诸法实相如法性法住法位实际是平等。菩萨入是平等中心无憎爱。是法有佛无佛常住。作法皆是虚诳。是故说无作法有佛无佛常住。听者心即取相着。是诸法平等。如人以指指月不知者但观其指而不视月。是故佛说诸法平等相亦如是皆是世谛。世谛非实但为成办事故说。譬如以金贸草。不知者言何以以贵易贱。答曰我事须用故。是平等义不可说。一切名字语言音声悉断。何以故。诸法平等是无戏论寂灭相。但觉观散心中有语言故有所说。须菩提从佛闻诸法平等相解其旨趣。为诸新发意菩萨故问。世尊若一切法空不可说如梦乃至如化。云何菩萨于无根本法中而生心作是愿。我当具足檀波罗蜜。乃至为众生如应说法。佛以反问答。须菩提布施等乃至陀罗尼门说法等。此诸法非如幻如梦等耶。须菩提言实尔。是诸法虽有利益不出于如梦法。须菩提复问。世尊梦等法皆虚妄不实。菩萨为求实法故。行般若波罗蜜得佛道。云何行不实法。不实法不能行檀波罗蜜等。佛可须菩提言如是如是。布施等法皆是思惟忆想分别作起生法。不得住如是法中成一切种智。即时众中听者心生懈怠。是故佛说是一切法皆是助道因缘。若于是法中邪行谬错是名不实。若直行不谬即是助道法。是法为助道故不为果。是布施等是有为法。道亦有为同相故相益道果者。所谓诸法实无出生一相无相寂灭涅槃。是故于涅槃不能有益。如时雨能益草木不益虚空。是故菩萨知是助道法及道果。从初发心来所作善法布施等。知皆是毕竟空如梦乃至如化。问曰。若菩萨知诸法实相。何用行布施等为。答曰。佛此中说布施等不具足不能成就众生菩萨庄严身及音声语言得佛神通力以种种方便力能引导众生。是故菩萨为成就众生故行檀波罗蜜。亦不取檀波罗蜜。若有若无相亦不戏论。如梦等诸法直行。乃至得阿耨多罗三藐三菩提。何以故。般若波罗蜜不可取相。乃至十八不共法亦不可取相。知一切不可取相已。发心求阿耨多罗三藐三菩提。作是念一切无根本不可取相如梦乃至如化。以不可取法不能得不可取相法。但以众生不知是法故。我为是众生求阿耨多罗三藐三菩提。是菩萨从初发心来所有布施为一切众生。所谓布施等诸善法为一切众生故修。不自为身。此中佛自说因缘。不为余事故求阿耨多罗三藐三菩提。但为一切众生故。所以者何。是菩萨远离怜愍众生心。但行般若波罗蜜。求诸法实相。或堕邪见中。是人未得一切智。所求一切智事心未调柔故堕诸边。诸法实相难得故。是故佛说菩萨从初发心怜愍众生故。着心渐薄。不戏论毕竟空若空有此过。若不空有彼过等。问曰。如余处菩萨自利益亦利益众生。此中何以但说利益众生不说自利。自利利人有何咎。答曰。菩萨行善道为一切众生。此是实义。余处说自利亦利益众生是为凡夫人作是说。然后能行菩萨道。入道人有下中上。下者但为自度故行善法。中者自为亦为他。上者但为他人故行善法。问曰。是事不然。下者但自为身。中者但为众生。上者自利亦利他人。若但利他不能自利。云何言上。答曰不然。世间法尔自供养者不得其福。自害其身而不得罪。以是故为自身行道名为下人。一切世人但自利身不能为他。若自为身行道。是则断灭自为爱着故。若自能舍己乐但为一切众生故行善法是名上人。与一切众生异故。若但为众生故行善法。众生未成就。自利则为具足。若自利益又为众生是为杂行。求佛道者有三种。一者但爱念佛故自为己身成佛。二者为己身亦为众生。三者但为众生。是人清净行道。破我颠倒故。是菩萨行般若波罗蜜时无众生。乃至无知者见者。安住是中拔出众生着甘露性中。甘露性者。所谓一切助道法。何以故。行是法得至涅槃。涅槃名甘露。住是甘露性中我等妄想不复生。是菩萨自得无所著。亦令众生得无所著。是名第一利益众生。问曰。上说但利益众生故行道。今何以故自得无所著。令众生得无所著。答曰不得已故。若自无智慧何能利人。以是故先自得无所著。然后教人。若是功德可得与他。如财物者诸佛大菩萨所有功德皆应与他。乃至调达怨贼皆可与之。然后更自修集功德。但是事不然。不可我作而他得。是亦世俗说非第一义。何以故第一义中无众生。无一无异。等分别诸法相。此中说亦无所著处。复次如先说不可说相。是第一义。此中可说故是世俗。尔时须菩提问佛。于道场所得法为用世谛故得。为用第一义谛。须菩提意若以世谛故得。即是虚妄不实。若以第一义故得。第一义中无得。无得者。不可说不可受。佛答以世俗语言故。说佛得阿耨多罗三藐三菩提。是中无得者无有得法。何以故。若是人得是法即是二法。二法中无道无果。二法者是菩萨是得阿耨多罗三藐三菩提。如是二法皆是世谛故有。若二者佛法何得不虚妄。若有人不得第一义。但以二法分别诸法是则虚妄。诸佛大菩萨得第一义故。为度众生令得第一义。虽分别诸法非是虚妄。须菩提复问。世尊若用二法无道无果。今以不二法故有道有果耶。佛答。二法无道无果。不二法亦无道无果。问曰。余处说二法是凡夫法不二法是贤圣法。如毗摩罗诘经不二入法门中说。答曰不二入是真实圣法。或有新发意菩萨未得诸法实相。闻是不二法取相生着。是故或称赞不二法或时毁呰。又佛遮二边说中道。所谓非二非不二。二法名各各别相不二名一空相。以是一空相破各各别异相。破已事讫还舍不二相。是即是道是果。何以故。诸贤圣虽赞叹无二法。为不着故用是法得道得果。用是法无道无果。即是戏论无戏论是平等法。须菩提白佛言。若诸法无所有性何等是平等。佛答。若离有性无性假名为平等。若菩萨不说一切法有。不说一切法性。不说一切法相等。显示亦不说无法无法性无法相等。显示亦不说离是二边更有平等相。一切处不取平等相。亦不言无是平等。不妨行诸善法。是名诸法平等。复次诸法平等者。所谓出过一切法。问曰。先处处说诸法即是平等相。平等即是诸法实。名异而义同。色如非色非离色。今何以说平等出过一切法。答曰。一切法有二种。一者色等诸法体。二者色等法中行。凡夫邪行贤圣正行。此中说平等。于凡夫行中出。不言色等中出。复次平等无能行无能到。于是须菩提惊问。佛亦不能行不能到。须菩提谓是法虽甚深微妙难行是事佛应当得。佛答从须陀洹乃至佛。皆无能行无能到。佛意三世十方佛不能行。不能到。何况一佛平等性自尔。故须菩提复问。佛于一切法中行力自在。佛无碍智慧无处不到。云何言不能行不能到。佛答。若佛与平等异应有是难。何以不能行不能到。今凡夫平等须陀洹平等佛平等。皆一平等无二无分别是凡夫乃至佛。自性不能自性中行。不能自性中到。自性应他性中行。是故佛说若佛与平等异。佛应行平等。但佛即是平等故不行不到。非以智慧少故。须菩提白佛言。若平等凡夫乃至佛不可得异。今凡夫圣人不应有差别。佛可须菩提问。平等中无差别。世谛故凡夫法中有差别。复问。若凡夫乃至佛无有差别。云何三宝大现于世间大利益众生。佛答。平等即是法宝。法宝即是佛宝僧宝。何以故。未得法时不名为佛。得平等法故名为佛。得是平等法故分别有须陀洹等差别。须菩提受佛教。是法皆无合无散无色无形无对一相所谓无相。唯佛有是力于空无相中分别是凡夫是圣人。佛告须菩提。如是如是。若诸佛不分别是法。云何当知有地狱乃至十八不共法。问曰。诸佛如日出。不能令高者下下者高。但能照明万物令有眼者别识。诸佛亦如是。亦不转诸法相。但以一切智照为人演说令知。汝何以故言若佛不分别诸法云何知有地狱乃至十八不共法。如今畜生等现目所见人皆识知何须佛说。答曰。佛虽不作好丑诸事而演说示人。知有二种。一者凡夫虚妄知。二者如实知。知畜生等相是凡人虚妄知。佛为知实相故言佛不分别诸法云何知有地狱等。复次诸佛法寂灭相无戏论。此中若分别有地狱等相。不名为寂灭不二无戏论法。佛虽知寂灭不二相。亦能于寂灭相中分别诸法而不堕戏论。离诸法实相者。虽眼见畜生等亦不能如实知其相。如牛角足尾等诸分边和合更有牛法生。是为一。诸分多。牛法一。一不作多。多不作一。有人言。此说非也。除此诸分应更有牛法。力用可见。牛法众分和合生。而牛法不异众分。何以故。见此众分合故名为见牛。更不见余物为牛。异者破一一者破异。不一不异破一异。若无一异云何有不一不异。若入是诸法平等中。尔时始如实得牛相。是故言若佛不分别诸法相不说二谛。云何善说畜生等。所谓于平等不动而分别诸法。不动者分别诸法时不着一异相。须菩提白佛。如佛于诸法等中不动。辟支佛乃至凡夫于诸法等中亦不动。何以故。诸佛平等相。乃至凡夫亦平等相。世尊若尔者。佛云何分别诸法是色异色性异受性异乃至有为无为性异。若不分别诸法。菩萨行般若波罗蜜时。不得从一地至一地乃至净佛国土。佛答。于汝意云何。推寻色等相为是空不。世尊。实空。空中有异相法不。答言不。何以故。是毕竟空以无相智慧可解。是中云何有异相。佛语须菩提。若空中无异相空便是实。是故汝云何于空中分别诸法。作是难毕竟空中空亦不可得。各各相亦不可得。汝云何以空各各相为难。以是因缘故。当知诸法平等中无分别故无凡夫人。但凡夫人非实相不离实相。凡夫实相即是圣人相。是故言不。但凡夫不离凡夫。乃至佛亦如是。须菩提以平等相大利益。欲知平等定相。是故问为是有为为是无为。佛答非有为非无为。何以故。若有为皆是虚诳作法。若无为无为法无生住灭故无法。无法故不得名无为。因有为故有无为。如经中说离有为无为不可得。如离长无短。是相待义。问曰。有为法是无常。无为法是常。云何言离有为无为不可得。答曰。无为法无分别故无相。若说常相不得言无相。破有为法故名无为。更无异法。如人闭在牢狱穿墙得出破壁是空更无异空。空亦不从因缘生。无为法亦如是。有为法中先有无为性。破有为即是无为。是故说离有为无为不可得。是有为无为性皆不合不散一相所谓无相。佛以世谛故说是事非第一义。何以故。佛自说因缘。第一义中无身口意行。有为无为法平等。即是第一义。观是有为无为法平等。亦不着一相。菩萨于第一义中不动而利益众生。方便力故种种因缘为众生说法也

大智度论卷第九十五大智度论释涅槃如化品第八十七(卷第九十六)

        龙树菩萨造

        后秦龟兹国三藏鸠摩罗什译

【经】须菩提白佛言。世尊。若诸法平等无所为作。云何菩萨摩诃萨行般若波罗蜜。于平等中不动而行菩萨事以布施爱语利益同事。佛告须菩提。如是如是如汝所说。是诸法平等无所作。若是众生自知诸法平等。佛不用神力于诸法平等中不动而拔出众生吾我想。以空度五道生死乃至知者见者相。度色相乃至识相眼相乃至意相地种相乃至识种相。远离有为性相令得无为性相。无为性相即是空。须菩提言。世尊。用何等空故一切法空。佛言。菩萨远离一切法相。用是空故一切法空。须菩提。于汝意云何。若有化人作化人。是化颇有实事不空者不。须菩提言。不也世尊。是化人无有实事而不空。是空及化人二事不合不散。以空空故空。不应分别是空是化。何以故。是二事等空中不可得。所谓是空是化。所以者何。须菩提。色即是化受想行识即是化。乃至一切种智即是化。须菩提白佛言。世尊。若世间法是化。出世间法所谓四念处四正勤四如意足五根五力七觉分八圣道分三解脱门佛十力四无所畏四无碍智十八不共法。并诸法果及贤圣人所谓须陀洹斯陀含阿那含阿罗汉辟支佛菩萨摩诃萨诸佛世尊。是法亦是化不。佛告须菩提一切法皆是化。于是法中有声闻法变化有辟支佛法变化有菩萨摩诃萨法变化有诸佛法变化有烦恼法变化有业因缘法变化。以是因缘故。须菩提。一切法皆是化。须菩提白佛言。世尊。是诸烦恼断。所谓须陀洹果斯陀含果阿那含果阿罗汉果辟支佛佛道。断诸烦恼习皆是变化不。佛告须菩提。若有法生灭相者皆是变化。须菩提言。世尊。何等法非变化。佛言。若法无生无灭是非变化。须菩提言。何等是不生不灭非变化。佛言。无诳相涅槃是法非变化。世尊。如佛自说诸法平等。非声闻作非辟支佛作非诸菩萨摩诃萨作非诸佛作。有佛无佛诸法性常空性空即是涅槃。云何言涅槃一法非如化。佛告须菩提。如是如是。诸法平等非声闻所作。乃至性空即是涅槃。若新发意菩萨闻是一切法皆毕竟性空乃至涅槃亦皆如化。心则惊怖。为是新发意菩萨故分别生灭者如化。不生灭者不如化。须菩提白佛言。世尊。云何教新发意菩萨令知是性空。佛告须菩提。诸法本有今无耶

【论】问曰。是事佛先已答。须菩提今何以更问。所谓世尊若诸法平等无所作为。云何菩萨于诸法平等中不动而大利益众生。答曰。以是事难解故虽先说而更问。又经将讫佛说深空。凡夫圣人所不能行所不能到。是故须菩提知一切法平等相定空。云何菩萨住是法中而能利益众生。平等法无作相利益是有作相。佛可须菩提意。还以须菩提问而答。可其平等答。其利益众生所谓若众生自知诸法平等毕竟空。佛无恩力。若病人自知将适则药师无功。须菩提复问。若诸法实相毕竟空无所能作。菩萨何以住是中而利益众生。若菩萨用是平等利益众生则坏实相。佛答。菩萨不以诸法实相利益众生。但众生不知毕竟空故菩萨教诏令知。菩萨教化众生是为对治悉檀。须菩提以第一义悉檀无利益为难。佛答。众生颠倒不知。佛但破其颠倒不言是实。是故菩萨住是平等相中。远离我相乃至知者见者相。是名众生空。以是一切无吾我法教化众生。众生有二种。一者爱多二者见多。爱多者得是无我法则生厌心离欲。作是念若无我何用余物。见多者虽知无我法于色等法中戏论若常若无常等。是故次说色相五众十二入十八界。乃至远离有为性相令得无为性相。无为性相即是空。是名法空。问曰。须菩提何以作是问。用何等空故一切法空。答曰。空有种种。如火中无水水中无火亦是空。五众中无我亦如是。或有众生空或有法空。法空中或有人言。诸法虽空亦不尽空。如色空中有微尘根本在。是故须菩提问以何等空故一切法空。佛答。以无所得毕竟空故远离一切相。是故此中说众生空法空。是二空故一切法无不空。问曰。若尔者此中何以说离一切法相。答曰。一切法不可尽坏。但离其邪忆想。一切法自离。如神通人坏色相故则石壁无碍。如佛说汝等当于五众中修正忆念断贪欲得正解脱。是故说离相。须菩提闻是已心惊。云何一切法若大若小都无本实。凡夫人虚妄可无实事。圣人应有少许实。须菩提虽是阿罗汉深贵佛法。亦为新发意菩萨故问。佛知须菩提意欲明了是事故说譬喻。反问须菩提。于汝意云何。如化人复作化。是化有本实不空不。答言不也。是化无有实事而不空者。空及化人二事不合不散皆空故用空空故空。问曰。何以名为空空故空。答曰。为破十八事实故有十八空。破众生心中变化空法故用空空。世间人皆知幻化法不久住无所能作故名空。是故言空空故空。不应分别是空是化。凡夫人知变化是空不实。谓余法为实。是故以化为喻。当知余法与化无异。如圣人所解不得以化为喻。以无所分别故。一切法名为五众。佛言。色受想行识无不是化以空故。须菩提白佛言。世尊。凡夫法虚妄应如化。出世间法亦如变化耶。所谓四念处乃至十八不共法若四念处法等。从因缘边生故如化。是法果所谓涅槃。亦复如化耶。若能起是行者。所谓须陀洹乃至佛。亦复如化耶。佛答。若有为若无为及诸贤圣皆是化。毕竟空故是义从初品已来处处广说。是故言一切法空皆如化。问曰。若一切法皆空如化。何以故有种种诸法别异。答曰。如佛所化及余人所化。虽不实而有种种形像别异。梦中所见种种亦如是。人见梦中好恶事。有生喜者有生怖者。如镜中像虽无实事而随本形像有好丑。诸法亦如是。虽空而各各有因缘。如佛此中说。是化法中有声闻变化有辟支佛变化有菩萨变化有佛变化有烦恼变化有业变化。是故一切法皆是变化。声闻变化者。三十七品四圣谛乃至三解脱门。何以故声闻人住持戒中。禅定摄心求涅槃。观内外身不净。是名身念处。如是等法为涅槃故。勤精进生起是法。本无而今有已。有还无。是为声闻变化。辟支佛变化者。所谓观十二因缘等诸法。所以者何。辟支佛智慧深于声闻人故。菩萨变化者。所谓六波罗蜜及二种神通报得及修得。佛法变化者。三十二相八十随形好。十力一切种智等无量佛法。烦恼变化者。烦恼起种种业。善不善无记业毕定业不毕定业善不善无动业等无量诸业。问曰诸烦恼是恶法。云何能生善业无动业。答曰有二种因。一者近因二者远因。人有我心为后身当常乐故修布施是近因。为离欲界衰恼不净身故修禅定是为远因。复有人言一切凡夫皆以我心和合故起业。有人言无有离我心起第六识住我心故起第六识。我心即是诸烦恼根本。问曰烦恼是垢心。善心是净心。垢净不得和合。何以言住我心中能起善业。答曰不尔一切心皆与慧俱生。无明心中亦应有慧。慧与无明相违法。而一心中起净。垢亦如是。凡夫未得圣道云何能得离我心而行善。嗔等烦恼中则不得行善。我心无记柔软故。是故烦恼心中生善业无动业无咎业。变化者生一切果报法所谓六道。恶业果报是三恶道。善业果报是三善道。恶业有上中下。上者地狱中者畜生下者饿鬼。善业亦有上中下。上者天中者人下者阿修罗等。上善业有种种轻重等分别。上恶业亦有轻重差别。次第轻重如地狱中说。余道亦如分别业品中说。问曰若从业有何以言变化。答曰凡夫人见诸法不如化。圣人知毕竟空相故以天眼观众生皆无有终始中间。如化主远处作变。化业亦如是。在过去世中作。今身变化如变化事。能种种令人生忧喜怖畏。智者观之皆无有实而人横生忧喜是人可笑。业亦如是。是故说业变化。问曰是诸变化皆业所作。何以不但说业变化。答曰业有二种净业垢业。净业者声闻变化乃至佛变化。垢业是烦恼变化。复次有二种业。凡夫业圣人业。凡夫业是烦恼变化。圣人业须陀洹乃至佛。是故虽皆是业变化而广分别无咎。是故须菩提当知一切法空皆如化。须菩提复问。世尊是诸圣人烦恼断。所谓须陀洹果乃至阿罗汉果辟支佛道断一切烦恼习。是诸断皆如化不。须菩提意有为法虚诳故如变化。无为法真实无作故不应是化。是故问。佛答。一切法若生若灭皆如化。何以故本无今有今有后无。诳惑人心故。佛意一切从因缘生法皆无自性。无自性。故毕竟空。毕竟空故皆如化。须菩提求诸法实相意犹未息故问。佛何等法不如化。须菩提意谓有一决定实法不如化。可依是法而精进求。佛答。有若法无生无灭即是非化。何者是所谓无诳相涅槃。是法无生故无灭。无灭故不能令人生忧。佛分别一切有为法毕竟空皆如化唯有涅槃一法非如化。尔时须菩提白佛。如佛说平等法非佛所作。非声闻辟支佛所作。有佛无佛诸法常住性空相。性空相即是涅槃。须菩提意谓。深入般若波罗蜜中涅槃亦空。上品中处处说。今佛何以说唯一涅槃不如化。是故引佛语为难。诸法实相性空法常住。诸佛但为人演说。性空者即是涅槃。今何以于生灭法中别说无诳相涅槃不如化。佛答。诸法平等常住非贤圣所作。若新学菩萨闻则恐怖。是故分别说。生灭者如化不生灭者不如化。问曰唯佛一人是无诳人。一切人皆于佛所欲求实事。今佛何以说一切法都空或说不都空。答曰佛此中自说因缘。为新发意菩萨故说涅槃不如化。问曰可为人故转诸法相耶。答曰此中佛说诸法相者性空。性空云何可转。佛初得是诸法实相时。心但趣向涅槃寂灭。是时十方诸佛诸天请佛莫入涅槃。一切众生苦恼当度脱之。佛即受请。佛但为度众生故住。以是故知有可利益众生随事为说。观诸有为法虚诳故涅槃为实不变不异。有新发意菩萨着是涅槃。因是着起诸烦恼。为断是着故说涅槃如化。若无著心是时则说涅槃非如化。复次有二道。小乘道大乘道。小乘论议以涅槃为实。大乘论议以利智慧深入故。观色等诸法皆如涅槃。是故二说无咎。须菩提复问。云何教化新发意菩萨令知平等性空。须菩提意谓。性空是凡夫人大怖畏处。闻性空无所有如临深坑。何以故。一切未得道者。我心深着故怖畏空法。作是念佛教人勤修善行终归入无所有中。以是故须菩提问。以何方便教诲是新发意者。佛答。诸法先有今无耶。佛意以新发意者怖畏后当无故。说诸法先有今无耶。须菩提自了了知诸法先自无今亦无。但以新发意者我见心覆故生惊怖。为除颠倒令得实见竟无所失。知诸烦恼颠倒实相所谓性空。是时则无恐怖。如是等法应教新发意者。若诸法先有以行道故无。应当恐怖初自无故不应恐怖。但为除颠倒耳

    大智度论释萨陀波仑品第八十八

【经】佛告须菩提。菩萨摩诃萨求般若波罗蜜。当如萨陀波仑菩萨摩诃萨。是菩萨今在大雷音佛所行菩萨道。须菩提白佛言。世尊。萨陀波仑菩萨摩诃萨。云何求般若波罗蜜。佛言。萨陀波仑菩萨摩诃萨。本求般若波罗蜜时。不惜身命不求名利。于空闲林中闻空中声言。汝善男子从是东行。莫念疲极。莫念睡眠。莫念饮食。莫念昼夜。莫念寒热。莫念内外。善男子。行时莫观左右。汝行时莫坏身相。莫坏色相。莫坏受想行识相。何以故。若坏是诸相则于佛法有碍。若于佛法有碍便往来五道生死中。亦不能得般若波罗蜜。尔时萨陀波仑菩萨报空中声言。我当从教。何以故。我欲为一切众生作大明。欲集一切诸佛法。欲得阿耨多罗三藐三菩提故。萨陀波仑菩萨复闻空中声言。善哉善哉。善男子。汝于空无相无作之法应生信心。以离相心求般若波罗蜜。离我相乃至离知者见者相。当远离恶知识。当亲近供养善知识。何等是善知识。能说空无相无作无生无灭法及一切种智。令人心入欢喜信乐。是为善知识。善男子。汝若如是行不久当闻般若波罗蜜。若从经卷中闻。若从菩萨所说闻。善男子。汝所从闻。是般若波罗蜜处。应生心如佛想。善男子。汝当知恩。应作是念。所从闻是般若波罗蜜者。即是我善知识。我用闻是法故疾得不退转。于阿耨多罗三藐三菩提亲近诸佛。常生有佛国中远离众难。得具足无难处。善男子。当思惟筹量是功德。于所从闻法处应生心如佛想。汝善男子。莫以世利心故随逐法师。但为爱法恭敬法故随逐说法菩萨。尔时当觉知魔事。若恶魔与说法菩萨作五欲因缘假为法故令受。若说法菩萨入实法门以德力故受而无所染。又以三事故受是五欲。以方便力故。欲令众生种善根故。欲与众生同其事故。汝于是中莫生污心当起净想。自念我未知沤和拘舍罗。大师以方便法为度众生令得福德故受是诸欲。于智慧无著无碍不为欲染。善男子。即当观诸法实相。诸法实相者。所谓一切法不垢不净。何以故。一切法自性空无众生。无人无我一切法如幻如梦如响如影如炎如化。善男子。观是诸法实相已当随法师。汝不久当成就般若波罗蜜。复次善男子。汝当复觉知魔事。若说法菩萨见欲受般若波罗蜜人意不存念。汝不应起心怨恨。汝但当以法故恭敬。莫起厌懈意常应随逐法师

【论】释曰。上品中说。新发意菩萨云何教性空法。性空法毕竟无所有空难解难得故。佛答。法先有今无耶。佛意性空法非难得难知。何以故。本来常无更无新异。汝何以心惊谓为难得。是性空法虽甚深菩萨但能一心勤精进不惜身命。作如是一心求便可得。此中说萨陀波仑本生为证。佛法有十二部经。或因修妒路偈经本生经得度。今佛以本生经为证。若有闻者作是念。彼人能得我亦应得。是故说萨陀波仑菩萨本生因缘。佛告须菩提。菩萨求般若波罗蜜应如萨陀波仑。问曰。若般若波罗蜜无相毕竟空。行禅定犹尚难得。何况忧愁啼哭散心求觅而当可得。答曰。为新发意菩萨说萨陀波仑。问曰。若萨陀波仑是新发意。十方诸佛云何现在其前得诸三昧不惜身。又见昙无竭复得无量阿僧祇三昧。云何名新发意。答曰。新学菩萨有二种。一者深心着世间乐软心发意。二者深心发意不着世间乐。软心发意者。佛不以为发心。深心发意者。乃名为发心。如声闻法中。佛语二比丘。于我法中乃至无如毛厘暖法。佛观是暖法最为微小。凡人观之以为大。譬如国王见一张[疊*毛]不以为多。贫者见之以为多。以一心不惜身故说萨陀波仑为证。问曰。若萨陀波仑菩萨能作如是苦行。从昙无竭得诸三昧应当作佛。今何以故。在大雷音佛所修菩萨行。答曰。佛法无量无边。若千万阿僧祇劫修勤苦行尚不可得。何况萨陀波仑一世苦行。复有菩萨具足菩萨道十力四无所畏等。为众生故住世间未取实际。如文殊师利等。萨陀波仑或能如此故未作佛。菩萨三昧如十方国土中尘数。萨陀波仑所得六万三昧何足为多。大雷音佛者。应如大龙王将欲降雨震大雷音。乌雀小虫悉皆怖畏。是佛初转法轮时。十方众生皆发心。外道邪见皆恐怖慑伏。是故天人众生称佛为大雷音。是佛今现在。须菩提问。萨陀波仑菩萨摩诃萨云何求般若波罗蜜。问曰。萨陀波仑未得阿鞞跋致。何以故。名菩萨摩诃萨。答曰。以有大菩萨故小者亦名大。又以其虽未得实智慧而能深念般若波罗蜜故不惜身命。有大功德故亦名菩萨摩诃萨。

问曰。何以名萨陀波仑。(萨陀秦言常波论名啼)为是父母与作名字。是因缘得名字。答曰。有人言。以其小时喜啼故名常啼。有人言。此菩萨行大悲心柔软故。见众生在恶世贫穷老病忧苦为之悲泣。是故众人号为萨陀波仑。有人言。是菩萨求佛道故远离人众在空闲处求心远离。一心思惟筹量勤求佛道时世无佛。是菩萨世世行慈悲心。以小因缘故生无佛世。是人悲心于众生欲精进不失。是故在空闲林中。是人以先世福德因缘及今世一心。大欲大精进。以是二因缘故闻空中教声不久便灭。即复心念。我云何不问。以是因缘故忧愁啼哭七日七夜。因是故天龙鬼神号曰常啼。佛答须菩提。过去世有萨陀波仑菩萨。不惜身命不贪财利求般若波罗蜜时。在空闲林中闻空中声到空林中如上说。问曰。空中声为是何声。答曰。若诸佛菩萨诸天龙王。怜愍众生故。见是人不着世间法一心求佛道。以时无佛法。欲示其得般若因缘。故空中发声。有人言。是萨陀波仑。先世善因缘人。在此林中作鬼神见其愁苦。以其是先世因缘故。又是神亦求佛道。以是二因缘故发声如蜜膊婆罗门。为须达多至王舍城诣大长者家求儿妇。时蜜膊于王舍城大婆罗门众中。饮食过度腹胀而死作鬼神。于王舍城城门上住。须达多闻是婆罗门已死自往长者家宿。长者于后夜起办具饮食。须达多问言。汝有何事为欲娶妇嫁女。为欲请大国王。为是邑会何其匆匆营事乃尔。长者答言。我欲请佛及僧。须达多闻佛名惊喜毛竖。长者先得道迹。为其广说佛德。须达多闻已爱乐情至。甚欲见佛乘。念佛心。而小睡以念佛情至故须臾便觉。夜见月光谓为日出。即起趣门见城门已开。王舍城门初夜未闭为客来故。后夜早开为客去故。既见门开即直向佛。佛时在寒林中住。于其中路月没还闇。须达多心悔踌躇欲还入城。时蜜膊神放身光明照诸林野。告言居士。居士。莫怖莫畏。直去莫还去得大利。如彼经偈中广说。须达多见佛得须陀洹道。请佛及僧于舍卫城尽形供养佛。令舍利弗为须达师。于舍卫作精舍。如须达知识神示导萨陀波仑知识示导亦如是。是故见其愁苦而示导之。作是言。善男子。汝从是东行。行时莫念疲极等。问曰。疲极饥渴交来切身云何不念。答曰。大欲精进力故。一心爱乐佛道不惜身命。休息饮食等皆是助身法。是事虽来不为乱心。知皆虚诳无常无实如怨如贼。但为身乐故何足存念。莫为饥渴疲极等故而舍佛道。莫念昼夜者。莫念昼是行法夜应止息。实无昼夜。所以者何。日依须弥影翳故名夜。莫念内外者。众生多着内法。内法名身外法名五欲。内外法不定性空故不应着。莫观左右者。人散心行道故左右顾看。行者无缘观后。当前则不得不视。故但言莫左右顾看。复次恶魔常惑乱行者。或作种种形或作好色或作畏兽。在道左右故言莫观。是皆止其粗念莫坏身相色等相者。五众和合故假名为身。若说别更决定有身法。是则坏身相。若着无身法是亦坏身相。离是一异有无等边行于中道。则疾得阿耨多罗三藐三菩提。是故说莫坏身相等。此中佛自说因缘。若坏是诸相则于佛法有碍。佛法有碍者。则往来五道生死中。不能得般若波罗蜜。萨陀波仑报空中声言。而自说因缘。所谓萨陀波仑见一切众生堕在无明黑闇中。我欲为然智慧光明。一切众生有一切烦恼。我欲设一切佛法药。一切众生皆堕邪道。我为是众生故求无上道。是三种愿得般若波罗蜜则能具足。是故言受教。问曰。萨陀波仑不见其形但闻其声。何以便言受教。答曰。人所求事急故闻声则应。萨陀波仑亦如是。复次闻其所说理好则知其人亦好故不须眼见。如黑闇中有种种。众生眼虽不见闻其声则知其种类。尔时空中声复赞言善哉。以其虽不见形而能信受善语故。又复以其欲度一切众生故。求阿耨多罗三藐三菩提心不懈息。如是等因缘故赞言善哉。于三解脱门中应生信心者。是门诸法实相所入门。离是三门皆是虚诳无有实者。汝虽未得应生大信根力。信根力故渐具诸根。以离相心求般若波罗蜜者。所谓观诸法毕竟空。离众生相离法相。问曰。三解脱门摄在般若中不。若摄何以别说。若不摄云何经中说一切助道法皆摄在般若中。答曰。一切法皆入般若中。人皆畏苦故求解脱。是故于般若分中前说三解脱门。以何因缘得此解脱离诸二边。所谓众生相法相行般若波罗蜜。问曰。初教精进后教三解脱门般若。今复欲为何事故教亲近善知识。答曰。虽有好法若无教者行时多错。譬如虽有好药亦须良医。又萨陀波仑是新发意菩萨。般若波罗蜜甚深。云何但闻空中略教而能自具足。是故教语亲近善知识。善知识义如先说。今略说二相是善知识。一者教一心向萨婆若。二者教空无相无作无生无灭等般若波罗蜜法。若能如是行不久得般若波罗蜜。如药师为病者说服药法。汝能如法服病则得差。若从经卷闻从菩萨说闻者。遣萨陀波仑至昙无竭菩萨所。彼中二处有般若。一宝台上金牒书。二昙无竭所说。若人福德多者从昙无竭所说闻。福德少者从经卷闻。于师生佛想。以能教佛道因缘故。世间小人因缘事讫则忘其恩义。作是念。如人乘船度水。既到彼岸何用船为。是故说汝当知恩。应作是念。所从闻般若者即是我善知识。一切诸利中般若利最胜。行是般若疾得阿耨多罗三藐三菩提不退转。又复行般若因缘故亲近诸佛。常生有佛国中。离于八难值佛在世。菩萨应作是念。我得如是等诸功德。皆从般若得。般若波罗蜜从师而得。是故视师如佛想。有人能说般若波罗蜜者。有大福德多知识多得供养。弟子初为般若故随逐。后渐渐为供养利。是故说莫以世利故随逐法师。问曰。何以不但说亲近善知识。而说是种种因缘。答曰。有人既得善知识不得其意。反成仇隙而堕地狱。更相谤毁故。唯佛一人无有过失。余人谁能无者。若弟子见师之过。若实若虚其心自坏不复能得法利。是故空中声教若见师过莫起嫌恨。汝应作是念。我先世福德不具足故不得值佛。今值是杂行师我不应念其过失。而自妨失般若。师之过失不着于我。我但从师受般若波罗蜜法。如狗皮囊盛好宝物不应以囊故而弃其宝。如罪人执烛照道不可以人罪故不受其明自坠沟壑。又如行遣小人导道不可以人小故不随其语。如是等因缘不应远离于师。师若实有罪尚不应离。何况此中魔作因缘令说法者有深妙五欲。令弟子不染着法。说法者以方便故现受。方便者。所谓欲令众生种福德因缘。亦为同事摄众生故。复有诸菩萨通达诸法实相故。无所障碍无有过罪。虽作过罪亦无所妨。如人年壮力盛腹中大热虽食不适饮食不能生病。又如有好药虽被恶毒不能为害。如是等因缘故汝于师所莫起嫌恨而自失般若。如经中说。复有说法者。持戒清净离于五欲。多知多识有好名闻。威德尊重。弟子受法而不顾录。汝于是中莫生怨恨。当作是念。我宿世罪故今为小人。师不轻我我自无福不能得道。又我于师所应破憍慢。以求法利有如是等种种诸师。菩萨为求般若波罗蜜故。但一心恭敬不应念其长短。若能如是忍辱于师一心不起增减者。汝于师所尽得妙法。如完牢之器所受不漏。萨陀波仑闻空中声已从是东行。如经中广说

大智度论卷第九十六大智度论释萨陀波仑品第八十八之余(卷第九十七)

        龙树菩萨造

        后秦龟兹国三藏鸠摩罗什译

【经】尔时萨陀波仑菩萨。受是空中教已。从是东行不久。复作是念。我云何不问空中声。我当何处去。去当远近当从谁闻般若波罗蜜。是时即住啼哭忧愁作是念。我住是中过一日一夜。若二三四五六七日七夜。不念疲极乃至不念饥渴寒热。不闻听受般若波罗蜜因缘终不起也。须菩提。譬如人有一子卒死忧愁苦毒。唯怀懊恼不生余念。如是须菩提。萨陀波仑菩萨。尔时无有异心。但念我何时当得闻般若波罗蜜。我云何不问空中声。我应何处去。去当远近当从谁闻般若波罗蜜。须菩提。萨陀波仑菩萨如是愁念时。空中有佛语萨陀波仑菩萨言。善哉善哉。善男子。过去诸佛行菩萨道时。求般若波罗蜜亦如汝今日。善男子。汝以是勤精进爱乐法故。从是东行去此五百由旬。有城名众香。其城七重七宝庄严。台观栏楯皆以七宝校饰。七宝之堑七宝行树周匝七重。其城纵广十二由旬。丰乐安静人民炽盛。五百市里街巷相当端严如画。桥津如地宽博清净。七重城上皆有七宝楼橹。宝树行列以黄金白银车磲马瑙珊瑚琉璃颇梨红色真珠以为枝叶。宝绳连绵金为铃网以覆城上。风吹铃声。其音和雅娱乐众生。譬如巧作五乐甚可悦喜。其城四边流池清净冷暖调适。中有诸船七宝严饰。是诸众生宿业所致。乘此宝船娱乐游戏。诸池水中种种莲华青黄赤白众杂好华遍覆水上。是三千大千世界所有众华皆在其中。其城四边有五百园观。七宝庄严甚可爱乐。一一园中各有五百池。池各纵广十里。皆以七宝校成杂色庄严。诸池水中亦有青黄赤白莲华弥覆水上。其诸莲华大如车轮。青色青光黄色黄光赤色赤光白色白光。诸池水中凫雁鸳鸯异类众鸟音声相和。是诸园观适无所属。是诸众生宿业所致。长夜信乐深法。行般若波罗蜜因缘故受是果报。善男子。是众香城中有大高台。昙无竭菩萨摩诃萨宫舍在上。其宫纵广一由旬。皆以七宝校成。杂色庄严甚可喜乐。垣墙七重皆亦七宝。七重栏楯七宝楼阁宝堑七重。皆亦七宝。周围深堑七宝累成。七重行树七宝枝叶。七重围绕其宫舍。中有四种娱乐园。一名常喜二名离忧。三名华饰。四名香饰。一一园中各有八池。一名贤二名贤上。三名欢喜四名喜上。五名安隐六名多安隐。七名远离八名阿鞞跋致。诸池四边面各一宝。黄金白银琉璃颇梨玟[王*回]为池底。其上布金沙。一一池侧有八梯陛。种种妙宝以为严饰。诸梯陛间有阎浮檀金芭蕉行树。一切池中种种莲华。青黄赤白弥覆水上。诸池四边生好华树。风吹诸华堕池水中。其池成就八种功德香。若栴檀色味具足。昙无竭菩萨与六万八千婇女。五欲具足共相娱乐。及城中男女俱入常喜等园贤等池中。五欲具足共相娱乐。善男子。昙无竭菩萨与诸婇女游戏娱乐已。日三时说般若波罗蜜。众香城内男女大小。于其城中多聚人处敷大法座。其座四足或以黄金或以白银或以琉璃或以颇梨。敷以綩綖杂色茵褥。垂诸帏带以妙白[疊*毛]而覆其上。散以种种杂妙花香。座高五里张白珠帐。其池四边散五色花。烧众名香泽香涂地。供养恭敬般若波罗蜜故。昙无竭菩萨于此座上说般若波罗蜜。彼诸人众如是恭敬供养昙无竭。为闻般若波罗蜜故。于是大会百千万众诸天世人一处和集。中有听者。中有受者。中有持者。中有诵者。中有书者。中有正观者。中有如说行者。当是时中众生以是因缘故。皆不堕恶道。不退转于阿耨多罗三藐三菩提。汝善男子往趣昙无竭菩萨。当闻般若波罗蜜。善男子。昙无竭菩萨世世是汝善知识。能教汝阿耨多罗三藐三菩提。示教利喜。是昙无竭菩萨本求般若波罗蜜时亦如汝。今汝去莫计昼夜。莫生障碍心。汝不久当得闻般若波罗蜜。尔时萨陀波仑菩萨摩诃萨。欢喜心悦作是念。我当何时得见是善男子得闻般若波罗蜜。须菩提。譬如有人为毒箭所中更无余念。唯念何时当得良医拔出毒箭除我此苦。如是须菩提。萨陀波仑菩萨摩诃萨更无余念。但作是愿。我何时当得见昙无竭菩萨。令我得闻般若波罗蜜。我闻是般若波罗蜜。断诸有心。是时萨陀波仑菩萨于是处住。念昙无竭菩萨。一切法中得无碍知见已。即得无量三昧门现在前。所谓诸法性观三昧。诸法性不可得三昧。破诸法无明三昧。诸法不异三昧。诸法不坏自在三昧。诸法能照明三昧。诸法离闇三昧。诸法无异相续三昧。诸法不可得三昧。散华三昧。诸法无我三昧。如幻威势三昧。得如镜像三昧。得一切众生语言三昧。一切众生欢喜三昧。入分别音声三昧。得种种语言字句庄严三昧。无畏三昧。性常默然三昧。得无碍解脱三昧。离尘垢三昧。名字语句庄严三昧。见诸法三昧。诸法无碍顶三昧。如虚空三昧。如金刚三昧。不畏着色三昧。得胜三昧。转眼三昧。毕法性三昧。能与安隐三昧。师子吼三昧。胜一切众生三昧。华庄严三昧。断疑三昧。随一切坚固三昧。出诸法得神通力无畏三昧。能达诸法三昧。诸法财印三昧。诸法无分别见三昧。离诸见三昧。离一切闇三昧。离一切相三昧。解脱一切着三昧。除一切懈怠三昧。得深法明三昧。不可夺三昧。破魔三昧。不着三界三昧。起光明三昧。见诸佛三昧。萨陀波仑菩萨住是诸三昧中。即见十方无量阿僧祇诸佛。为诸菩萨摩诃萨说般若波罗蜜

【论】问曰。萨陀波仑何以忘不问空中声。答曰。萨陀波仑大欢喜覆心故忘。如人大忧愁大欢喜。以此二事故忘。问曰。空中声已灭。何以住此七日不更求问处。答曰。如本于空闲处一心求般若故空中有声。今亦欲一心如本冀更闻声断其所疑。复次萨陀波仑于世乐已舍深入佛道爱乐情至。空中声告少为开示竟未断疑。其声便灭。如小儿得少美味着是味故更复啼泣而欲得之。萨陀波仑亦如是。得般若波罗蜜因缘味不能通达。不知那去。是故住而啼泣。问曰。何以乃至七日佛身乃现。答曰。譬如人大渴故乃知水美。若二日三日精进欲未深。若过七日恐其忧愁妨心不任求道。是故七日忧愁。如譬喻经中说。问曰。萨陀波仑何以愁忧乃尔如丧爱子。答曰。般若波罗蜜于诸法中第一。实是十方诸佛真实法宝。萨陀波仑得少气味未具足故。忧愁如丧爱子。念其长大多所成办冀得其力。菩萨亦如是。念增益般若波罗蜜力。得阿鞞跋致已成就佛事。如子于父孝行终身无有异心。般若波罗蜜于菩萨亦如是。若能得入乃至成佛终不远离。如父见子心即欢悦。菩萨虽得种种诸法。不如见般若波罗蜜之欢喜。如子假为其名。般若波罗蜜亦如是。空无定实但有假名。如是等是总相因缘。父虽爱子不能以头目与之。菩萨为般若波罗蜜故。无量世中以头目髓脑施与众生。子之于父或不能报恩。若能报恩正可现世小利衣食欢乐等。菩萨于般若波罗蜜中无所不得乃至一切智慧。何况菩萨力势世间富乐。子之报父恩极一世。般若之益至无量世乃至成佛。子之于父或好或恶。般若波罗蜜无诸不可。子但是假名虚诳不实之法。般若波罗蜜真实圣法无有虚诳。子之报恩虽得现世小乐。而有忧愁苦恼无量之苦。般若波罗蜜但得欢喜实乐乃至佛乐。子但能以供养利益于父。不能免其生老病死。般若波罗蜜令菩萨毕竟清净无复老病死患。子但能令父得世乐自在。般若波罗蜜能令菩萨于一切世间为天人主。如是等种种因缘譬喻差别相。世人皆知丧子忧愁故以此为喻。问曰。空中佛现是何等佛。先何以但有音声而今现身。佛既现身何以不即度。方遣至昙无竭所。答曰。有人言非真佛但是像现耳。或诸佛遣化或大菩萨现作。以先善根福德未成就故但闻声。今七日七夜一心念佛功德成就故得见佛身。佛所以不即度者。以其与昙无竭世世因缘应当从彼度故。有人应从舍利弗度。假使诸佛现身不能令悟。佛赞言善哉者。以萨陀波仑至意求知去处闻般若因缘故。佛现身而赞善哉。过去诸佛行菩萨道时求此般若亦如是种种勤苦。以初发心先罪厚重福德未集故。佛安慰其心。汝求般若波罗蜜。虽勤苦莫懈怠莫生退没心。一切众生行异因时皆苦受果时乐。当思惟诸佛无量功德果报以自劝勉。如是安慰已作是言。汝从是东行去此五百由旬。有城名众香。乃至不久当闻般若波罗蜜。问曰。众香城在何处。答曰。过去佛灭度后但有遗法。是法不周遍阎浮提。众生有闻法因缘处则到。尔时众香国土丰乐。多出七宝故以七宝作城。时萨陀波仑虽同在阎浮提而在无佛法无七宝处生。但传闻佛名般若波罗蜜是佛道。是人先世广集福德。烦恼轻微故闻即信乐厌恶世乐。舍其亲属到空林中住。欲至有佛法国土。音声示语者。恐其异去不得到昙无竭菩萨所。是故语之次后佛为现身示其去处。问曰。萨陀波仑因缘已具闻于上。今昙无竭因缘为云何。答曰。郁伽陀秦言盛。达磨秦言法。此菩萨在众香城中。为众生随意说法。令众生广种善根故号法盛。其国无王。此中人民皆无吾我。如郁单越人。唯以昙无竭菩萨为王其国难到。萨陀波仑不惜身命。又得诸佛菩萨接助能到。大菩萨为度众生故生如是国中。众生无所乏短。其心调柔易可得度。故问曰。昙无竭菩萨为是生身。为是法身为度众生故以神通力化作此身。若化身者何用六万婇女园观浴池种种庄严而自娱乐。若是生身云何能令萨陀波仑供养具皆在空中化成大台。入诸三昧乃至七岁。答曰。有人言是生身菩萨。得诸法实相及禅定神通力故。欲度是城中众生。如余菩萨利根故能入禅定。亦能入欲界法。为摄众生故受五欲而不失禅定。如人避热故在泥中卧还洗则如故。凡夫钝根故不能如是。是故以神通力化作华台七岁入定。又以方便力故能受五欲。如先义说菩萨不但行一道。为众生故行种种道引导之。如龙起云能降大雨雷电霹雳。菩萨亦如是。虽是生身未离烦恼而能修行善法。为众生故不尽结使。有人言。是菩萨是法性生身。为度众香城人故变化而度。若是生身云何能令十方佛称赞而遣萨陀波仑。令从受法得六万三昧。是故知是大菩萨变化身。譬如大海中龙死相出时如果熟应堕金翅鸟则来食之。众生亦如是。行业因缘熟故大菩萨来度之。尔时萨陀波仑闻空中佛教大欢喜大欲心生故。我何时当得见昙无竭菩萨说般若波罗蜜者。能令我心中爱见等诸烦恼箭出。欲明是事故。此中佛说毒箭譬喻。如人毒箭在身更无余念。一者苦痛急。二者毒不疾出则遍满身中而失命。萨陀波仑亦如是。诸邪疑等箭入心。贪欲等毒涂箭。闻昙无竭菩萨能拔出此箭。是人以邪见箭毒伤心。人畏贪欲等毒遍入身中夺智慧命与凡人同死。是故急欲见昙无竭菩萨无复余念。此中说断诸所有心。所有心者取相着。乃至善法中亦有是病。萨陀波仑目睹佛身。先所未见从佛闻教。得法喜故离五欲喜。即得一切法中无碍知见。无碍知见者如萨陀波仑力所得无碍。非佛无碍。是时得入诸三昧门。诸法性观三昧者。能观一切诸法实性。实性者如先种种因缘说。诸法性不可得三昧者。初得三昧所谓空无生无灭。今得是三昧则不着是性。不得其决定相。破诸法无明三昧者。诸法于凡夫人心中以无明因缘故邪曲不正。所谓常乐我净。得是三昧故常等颠倒相应无明破。但观一切法无常空无我。问曰。若是菩萨破一切法中无明。此人尚不须见佛。何用至昙无竭菩萨所。答曰。破无明不唯一种。有遮令不起亦名为破。有得诸法实相故破无明。又无明种数甚多。有菩萨所破分有佛所破分。有小菩萨所破分大菩萨所破分。如先说灯譬喻。又须陀洹亦名破无明。乃至阿罗汉方是实破。大乘法中亦如是。新发意菩萨得诸法实相故亦名破无明。乃至佛无明尽破无余。是故萨陀波仑于佛法中邪见无明及我见皆尽。故得名破无明三昧无咎。诸法不异三昧者。得是三昧观一切法一相。所谓无相诸法。不坏自在三昧者。得是三昧观一切法如法性实际无为相故名不坏。得是法已得自在。了了知诸法。为佛道故不证是法。诸法能照明三昧者。以总相别相知一切法。诸法离闇三昧者。无明有二种。一者厚二者薄。薄者名无明。厚者名黑闇。破厚无明故名离闇。先破薄无明故名破诸法无明。诸法无异相续三昧者。五众念念灭。相似相续生。死时相续生而不相似。得是三昧知诸法念念相续法不异。诸法不可得三昧者。即是一切法空相应三昧。散华三昧者。得是三昧者。于十方佛前能以七宝华散佛。诸法无我三昧者。观一切法无我。如幻威势三昧者。得是三昧者能种种变化身如大幻师。能引导众生发希有心如大幻师。以幻力故能转一国人心。得如镜像三昧者。得是三昧者观三界所有。如镜中像虚诳无实。得一切众生语言三昧者。得是三昧故能解一切众生语言。一切众生欢喜三昧者。入是三昧能转众生嗔心令欢喜。入分别音声三昧者。入是三昧中。皆能分别一切天人音声大小粗细等。得种种语言字句。庄严三昧者。得是三昧者义理虽浅能庄严字句语言。令人欢喜。何况深义。无畏三昧者。得是三昧者。不畏一切魔民外道论师及诸烦恼性。常默然三昧者。入是三昧者。常默然摄心。为度众生故随所应闻而出音声。如天妓乐应意而出。得无碍解脱三昧者。得是三昧者。于一切法中得无碍智慧离尘垢三昧者。得是三昧者。诸烦恼结使尘垢皆灭。即是无生法忍三昧。名字语句庄严三昧者。得是三昧者。能种种庄严偈句语言。说法见诸法三昧者。入是三昧者。以见世谛及第一义谛知诸法。诸法无碍顶三昧者。如人在山顶遍观四方。菩萨住是三昧中。普见一切诸法无碍。如虚空三昧者。入是三昧者。身及外法皆如虚空。皆得自在。如金刚三昧者。如金刚能破诸山。是三昧亦如是。能破障碍。六波罗蜜法直至佛道。不畏着色三昧者。得是三昧者。乃至天色尚不着。何况余色。得胜三昧者。欲有所作皆能得胜不负。转眼三昧者。得是三昧者。魔及魔民欲见菩萨短者。转之令作好见。毕法性三昧者。得是三昧者。见一切法毕入法性中。能与安隐三昧者。得是三昧虽往来六道回转。自知必当作佛。安乐无忧师子吼三昧者。入是三昧者。皆能降伏一切魔民外道无敢当者。胜一切众生三昧者。得是三昧于一切众生最胜。一切有二种。一者名字一切。二者实一切。于三界着心凡夫及声闻辟支佛及初发意未得是三昧者中胜故言一切。花庄严三昧者。得是三昧者。见十方佛坐七宝莲花上。于虚空中雨宝莲花于诸佛上。断疑三昧者。得是三昧者。虽未得佛能断一切众生所疑。随一切坚固三昧者。诸法实相名坚固。得是三昧者。随诸法实相不随余法。出诸法得神通力无畏三昧者。得是三昧者。过出一切凡夫法。得菩萨六神通十力四无所畏。能达诸法三昧者。得是三昧者。乃至诸法如法性实际中通达不住。乃至诸法平等。诸法财印三昧者。财名善法。印者名相如人得印绶无敢陵易。菩萨得善法财印亦无能为作留难者。诸法无分别见三昧者。若分别诸法即生憎爱心。得是三昧者。见一切法不作分别。离诸见三昧者。见者六十二邪见。及色等法中取相。乃至佛见法见僧见涅槃见。皆名为见。所以者何。取相能生着心故。离一切相三昧者。即是无相解脱门相应三昧。离一切着三昧者。离一切相故于一切法亦不着。除一切懈怠三昧者。得是三昧者。如此中说乃至七岁不坐不卧。菩萨得是三昧常无懈怠心。乃至得佛初不止息。得深法明三昧者。深法名诸佛法一切智慧等。菩萨得是三昧故能遥见佛法。思惟筹量知深妙无比。不可夺三昧者。得是三昧者。行菩萨法无能夺其志者。破魔三昧者。得是三昧力魔虽是欲界主。菩萨以人身能破魔事。不着三界三昧者。得是三昧身虽在三界中心常在涅槃故。不着起光明三昧者。得是三昧者。能放无量光明照于十方。见诸佛三昧者。得是三昧虽未得天眼天耳。而能见十方诸佛。闻十方诸佛所说法。咨问所疑。萨陀波仑住如是等三昧中。即见十方无量阿僧祇诸佛在大众中。为诸菩萨说般若波罗蜜

大智度论卷第九十七大智度论释萨陀波仑品第八十八之余(卷第九十八)

        龙树菩萨造

        后秦龟兹国三藏鸠摩罗什译

【经】是时十方诸佛。安慰萨陀波仑菩萨言。善哉善哉善男子。我等本行菩萨道时。求般若波罗蜜得是诸三昧。亦如汝今所得。我等得是诸三昧。善入般若波罗蜜。成就方便力住阿鞞跋致地。我等观是诸三昧性。不见有法出三昧入三昧者。亦不见行佛道者。亦不见得阿耨多罗三藐三菩提者。善男子是名般若波罗蜜。所谓不念有是诸法。善男子我等于无所念法中住。得是金色身。丈六光明三十二相八十随形好不可思议智慧无上戒无上三昧无上智慧一切功德皆悉具足。一切功德具足故。佛尚不能取相说尽。何况声闻辟支佛及诸余人。以是故善男子于是佛法中倍应恭敬爱念生清净心。于善知识中应生如佛想。何以故。为善知识守护故。菩萨疾得阿耨多罗三藐三菩提。是时萨陀波仑菩萨。白十方诸佛言。何等是我善知识所应亲近供养者。十方诸佛告萨陀波仑菩萨言。汝善男子昙无竭菩萨。世世教化成就汝阿耨多罗三藐三菩提。昙无竭菩萨守护汝教。汝般若波罗蜜方便力。是汝善知识汝供养。昙无竭菩萨若一劫若二劫若三劫乃至过百千劫。顶戴恭敬以一切乐具三千世界中所有妙色声香味触。尽以供养未能报须臾之恩。何以故。昙无竭菩萨摩诃萨因缘故。令汝得如是等诸三昧。得般若波罗蜜方便力。诸佛如是教化安慰。萨陀波仑菩萨令欢喜已。忽然不现

是时萨陀波仑菩萨从三昧起已不复见佛。作是念。是诸佛从何所来去至何所。不见诸佛故。复惆怅不乐谁断我疑。复作是念。昙无竭菩萨久远已来。常行般若波罗蜜。得方便力及诸陀罗尼。于菩萨法中得自在。多供养过去诸佛。世世为我师常利益我。我当问昙无竭菩萨。诸佛从何所来去至何所。尔时萨陀波仑菩萨于昙无竭菩萨生恭敬爱乐尊重心。作是念。我当以何供养昙无竭菩萨。今我贫穷无华香璎珞烧香泽香衣服幡盖金银真珠琉璃颇梨珊瑚虎珀。无有如是等物可以供养般若波罗蜜及说法师。昙无竭菩萨。我法不应空往昙无竭菩萨所。我若空往喜悦心不生。我当卖身得财为般若波罗蜜故供养法师昙无竭菩萨。何以故。我世世丧身无数无始生死中。或死或卖或为欲因缘故。世世在地狱中受无量苦恼。未曾为清净法故。为供养说法师故丧身。是时萨陀波仑菩萨中道入一大城。至市肆上高声唱言。谁欲须人谁欲须人谁欲买人。尔时恶魔作是念。是萨陀波仑爱法故自欲卖身为般若波罗蜜故供养。昙无竭菩萨。当得正问般若波罗蜜及方便力。云何菩萨摩诃萨行般若波罗蜜。疾得阿耨多罗三藐三菩提。当得多闻具足如大海水。是时不可沮坏得具足一切功德饶益诸菩萨摩诃萨为阿耨多罗三藐三菩提故。过我境界亦教余人出我境界得阿耨多罗三藐三菩提。我今当坏其事。尔时恶魔隐蔽诸婆罗门居士令不闻其自卖声。除一长者女魔不能蔽。尔时萨陀波仑卖身不售忧愁啼哭。在一面立涕泣而言。我为大罪卖身不售我自卖身。为般若波罗蜜故供养昙无竭菩萨。尔时释提桓因作是念。是萨陀波仑菩萨爱法自卖其身。为般若波罗蜜故欲供养昙无竭菩萨。我当试之。知是善男子实以深心爱法故舍是身不。是时释提桓因化作婆罗门身在萨陀波仑菩萨边行问言。汝善男子何以忧愁啼哭颜色焦悴。在一面立答言。婆罗门我爱敬法欲自卖身为般若波罗蜜故。欲供养昙无竭菩萨。今我卖身无有买者。自念薄福无财宝物欲自卖身供养般若波罗蜜及昙无竭菩萨而无买者。尔时婆罗门语萨陀波仑菩萨言。善男子我不须人。我今欲祠天。当须人心人血人髓。汝能卖与我不。尔时萨陀波仑菩萨作是念。我得大利得第一利。我今便为具足般若波罗蜜方便力。得是买心血髓者。是时心大欢喜悦乐无忧。以柔和心语婆罗门言。汝所须者我尽与汝。婆罗门言。善男子汝须何价。答言随汝意与我。即时萨陀波仑右手执利刀刺左臂出血。割右髀肉复欲破骨出髓。时有一长者女。在阁上遥见萨陀波仑菩萨自割身体不惜寿命作是念。是善男子何因缘故困苦其身。我当往问。长者女即下阁。到萨陀波仑所问言。善男子何因缘困苦其身。用是心血髓作何等。萨陀波仑答言。卖与婆罗门为般若波罗蜜故。供养昙无竭菩萨。长者女言。善男子作是卖身欲自出心血髓。欲供养昙无竭菩萨。得何等功德利益。萨陀波仑答言。善女人是人善学般若波罗蜜及方便力。是人当为我说菩萨所。应作菩萨所应行道我学是法学是道得阿耨多罗三藐三菩提。时为众生作依止。当得金色身三十二相八十随形好大光无量明大慈大悲大喜大舍四无所畏。佛十力四无碍智十八不共法。六神通不可思议清净戒禅定智慧。得阿耨多罗三藐三菩提。于诸法中得无碍一切知见。以无上法宝分布与一切众生如是等诸功德利我当从彼得之。是时长者女闻是上妙佛法。即大欢喜心惊毛竖。语萨陀波仑菩萨言。善男子甚希有。汝所说者微妙难值。为是一一功德法故。应舍如恒河沙等身。何以故。汝所说者甚大微妙。汝善男子汝今所须尽当相与。金银真珠琉璃颇梨虎珀珊瑚等诸珍宝物及华香璎珞涂香烧香幡盖衣服伎乐等供养之具。供养般若波罗蜜及昙无竭菩萨。汝善男子莫自困苦其身。我亦欲往昙无竭菩萨所。共汝植诸善根为得如是微妙法如汝所说故。尔时释提桓因即复本身。赞萨陀波仑菩萨言。善哉善哉善男子。汝坚受是事其心不动。诸过去佛行菩萨道时。亦如是求般若波罗蜜及方便力得阿耨多罗三藐三菩提。善男子我实不用人心血髓。但来相试汝愿何等。我当相与萨陀波仑言。与我阿耨多罗三藐三菩提。释提桓因言。此非我力所办。是诸佛境界。必相供养更索余愿。萨陀波仑言。汝若于此无力。汝必见供养。令我是身平复如故。是时萨陀波仑身。即平复无有疮瘢如本不异。释提桓因与其愿已忽然不现。尔时长者女语萨陀波仑菩萨言。善男子来到我舍。有所须者从我父母索之。尽当相与。我亦当辞我父母。与诸侍女共往供养昙无竭菩萨。为求法故。即时萨陀波仑菩萨与长者女。俱到其舍在门外住。长者女入白父母。与我众妙花香及诸璎珞涂香烧香幡盖衣服金银琉璃颇梨真珠珊瑚虎珀及诸伎乐供养之具。亦听我身及五百侍女先所给使共萨陀波仑菩萨。到昙无竭菩萨所为供养般若波罗蜜故。昙无竭菩萨。当为我等说法。我当如说行当得诸佛法。女父母语女言。萨陀波仑菩萨是何等人。女言是人今在门外。是善男子以深心求阿耨多罗三藐三菩提。欲度一切众生无量生死苦。是善男子为法故自卖其身供养般若波罗蜜。般若波罗蜜名菩萨所学道。为供养般若波罗蜜及供养昙无竭菩萨故。在市肆上高声唱言。谁须人谁须人谁欲买人。卖身不售。在一面立忧愁啼哭。是时释提桓因化作婆罗门来欲试之。问言善男子何以忧愁啼哭一面立。答言婆罗门我欲卖身为供养般若波罗蜜及昙无竭菩萨摩诃萨故而我薄福卖身不售。婆罗门语是善男子。我不须人我欲祠天。当用人心人血人髓。汝能卖不。是时是善男子不复忧愁。其心和悦语是婆罗门言。汝之所须我尽相与。婆罗门言汝须何价。答言随汝意与我。即时是善男子右手执利刀。刺左臂出血。割右髀肉复欲破骨出髓。我在阁上遥见是事。我尔时作是念。是人何故困苦其身。我当往问。我即下阁往问善男子。汝何因缘故自困苦其身。是善男子答我言。姊我为法故欲供养般若波罗蜜及昙无竭菩萨说法者。我贫穷无所有无金银琉璃车磲马瑙珊瑚虎珀玻梨真珠花香伎乐。姊我为供养法故自卖其身。今得买者须人心人血人髓。我用是价供养般若波罗蜜及昙无竭菩萨说法者。我问是善男子。汝今自出身心血髓。欲供养昙无竭菩萨。得何功德。是善男子言。昙无竭菩萨当为我说般若波罗蜜及方便力。此是菩萨所应学。菩萨所应作。菩萨所应住。菩萨所行道。我当学是道。得阿耨多罗三藐三菩提。为一切众生作依止。我当得金色身三十二相。八十髓形好大光。无量明大慈大悲大喜大舍四无所畏。四无碍智。佛十力十八不共法六神通不可思议清净戒禅定智慧。得阿耨多罗三藐三菩提。于诸法中得无碍一切知见。以无上法宝分布与一切众生。如是等微妙大法。我当从彼得之。我闻是微妙不可思议诸佛功德。闻其大愿。我心欢喜作是念。是清净微妙。甚大希有。乃至如是为一一法故。应舍如恒河沙等身。今善男子为法能受苦行难事。所谓不惜身命。我多有妙宝。云何不生愿勤求如是法。供养般若波罗蜜及昙无竭菩萨。我如是思惟已。语萨陀波仑菩萨。汝善男子莫困苦其身。我当白我父母多与汝金银琉璃车磲马瑙珊瑚虎珀颇梨真珠花香璎珞涂香末香衣服旛盖及诸伎乐。供养般若波罗蜜及昙无竭菩萨说法者。我亦求父母与诸侍女。共汝俱去供养昙无竭菩萨说法者。共汝植诸善根。为得如是等微妙清净法。如汝所说。父母今听我并五百侍女先所给者。亦听我持众妙花香璎珞涂香末香衣服幡盖伎乐金银琉璃供养之具。与萨陀波仑菩萨共去供养般若波罗蜜。及昙无竭菩萨说法者。为得如是等清净微妙诸佛法故。尔时父母报女言。汝所赞者希有难及。说是善男子为法精进大乐法相。及是诸佛法不可思议。一切世间最为第一。一切众生欢喜因缘。是善男子为是法故大庄严。我等听汝往见昙无竭菩萨亲近供养。汝发大心为得诸佛法故如是精进。我等云何当不随喜。是女为供养昙无竭菩萨故。得蒙听许。报父母言。我等亦随是心欢喜。我终不断人善法因缘。是时长者女庄严七宝车五百乘。身及侍女种种宝物供养之具。持种种水陆生华。及金银宝华。众色宝衣。好香捣香泽香璎珞。及众味饮食。共萨陀波仑菩萨五百侍女。各载一车恭敬围绕渐渐东去。见众香城七宝庄严七重围绕七宝之堑七宝行树皆亦七重。其城纵广十二由旬。丰乐安静甚可喜乐。人民炽盛。百千市里街巷相当端严如画桥津如地宽博清净遥见众香城。既入城中。见昙无竭菩萨坐高台法座上。无量百千万亿众恭敬围绕说法。萨陀波仑菩萨见昙无竭菩萨时心即欢喜。譬如比丘入第三禅摄心安隐。见已作是念。我等仪不应载车趣昙无竭菩萨。作是念已下车步进。长者女并五百侍女皆亦下车。萨陀波仑菩萨。与长者女及五百侍女。众宝庄严围绕恭敬。俱到昙无竭菩萨所。尔时昙无竭菩萨摩诃萨。有七宝台赤牛头栴檀以为庄严。真珠罗网以覆台上。四角皆悬摩尼宝珠以为灯明。及四宝香炉常烧明香。为供养般若波罗蜜故。其台中有七宝大床四宝小床重敷其上。以黄金牒书般若波罗蜜置小床上。种种幡盖庄严垂覆其上。萨陀波仑菩萨及诸女人见是妙台众宝严饰。及见释提桓因与无量百千万诸天。以天曼陀罗花碎末栴檀磨众宝屑。以散台上。鼓天伎乐于虚空中娱乐此台。尔时萨陀波仑菩萨问释提桓因。憍尸迦。何因缘故。与无量百千万诸天。以天曼陀罗花碎末栴檀磨众宝屑。以散台上。鼓天妓乐于虚空中娱乐此台。释提桓因答言。汝善男子不知耶。此是摩诃般若波罗蜜。是诸菩萨摩诃萨母。能生诸佛摄持菩萨。菩萨学是般若波罗蜜。成就一切功德。得诸佛法一切种智。是时萨陀波仑菩萨即欢喜悦乐。问释提桓因。憍尸迦。般若波罗蜜诸菩萨摩诃萨母能生诸佛摄持菩萨。菩萨学是般若波罗蜜。成就一切功德。得诸佛法一切种智。今在何处。释提桓因言。善男子。是台中有七宝大床四宝小床重敷其上。以黄金牒书般若波罗蜜置小床上。昙无竭菩萨以七宝印印之。我等不能得开以示汝。是时萨陀波仑与长者女及五百侍女。取供养具华香璎珞幡盖分作二分。一分供养般若波罗蜜。一分供养法座上昙无竭菩萨。尔时萨陀波仑菩萨。与五百女人。持华香璎珞幡盖伎乐。及诸珍宝供养般若波罗蜜已。然后到昙无竭菩萨所。到已见昙无竭菩萨在法座上坐。以诸华香璎珞捣香泽香金银宝华幡盖宝衣散其昙无竭菩萨上为法故供养。是时诸华香宝衣于昙无竭菩萨上虚空中化成华台碎末栴檀宝屑金银宝华。化成宝帐。宝帐之上所散种种宝衣化为宝盖。宝盖四边垂诸宝幡。萨陀波仑及诸女人见昙无竭菩萨所作变化。皆大欢喜作是念未曾有也。昙无竭大师神德乃尔。行菩萨道时神通力尚能如是。何况得阿耨多罗三藐三菩提时。是时长者女及五百女人清净信心敬重昙无竭菩萨。皆发阿耨多罗三藐三菩提心作是愿言。如昙无竭菩萨得菩萨诸深法。如昙无竭菩萨供养般若波罗蜜。如昙无竭菩萨于大众中演说显示般若波罗蜜义。如昙无竭菩萨得般若波罗蜜方便力。成就神通于菩萨事中得自在。我等亦当如是。是时萨陀波仑菩萨及五百女人华香宝物供养般若波罗蜜及昙无竭菩萨已。头面礼昙无竭菩萨合掌恭敬一面立。一面立已白昙无竭菩萨言。我本求般若波罗蜜时于空闲林中闻空中声言。善男子汝从是东行当得闻般若波蜜。我受是语东行。东行不久作是念。我何不问空中声。我当何处去。去是远近当从谁闻。我是时大忧愁啼哭于是处住七日七夜。忧愁故乃至不念饮食。但念我何时当得闻般若波罗蜜我如是忧愁。一心念般若波罗蜜多见佛身在虚空中语我言。善男子汝大欲大精进心莫放舍以是大欲大精进心从是东行。去是五百由旬有城名众香。是中有菩萨摩诃萨名昙无竭。从是人所当得闻般若波罗蜜。是菩萨世世是汝善知识常守护汝。我从佛受教诲已。便东行更无余心。但念我何时当见昙无竭菩萨为我说般若波罗蜜。我尔时中道住于一切法中得无碍知见得观诸法性等诸三昧现在前住是三昧已。见十方无量阿僧祇诸佛说是般若波罗蜜。诸佛赞我言。善哉善哉善男子我本求般若波罗蜜时。得诸三昧。亦如汝今日。得是诸三昧已。遍得诸佛法诸佛为我广说法要安慰我已。忽然不现。我从三昧起作是念。诸佛从何处来去至何所。我不见诸佛故大愁忧复作是念。昙无竭菩萨供养先佛植诸善根久行般若波罗蜜。善知方便力于菩萨道中得自在。是我善知识守护我。我当问昙无竭菩萨是事。诸佛从何所来去至何所。我今问大师。是诸佛何处来去至何处。大师当为我说诸佛所从来所至处令我得知。知已亦常不离见诸佛

【论】释曰。萨陀波仑渴仰欲闻般若故。见十方诸佛为大众说法。其心欢喜其意得满。诸佛以其信力坚固精进难动故。安慰其心赞言善哉。我本初行菩萨道求般若时。亦如汝今。汝莫忧愁自谓福薄。尔时萨陀波仑大得诸三昧力其心深着。是故诸佛为说求诸三昧性不见实体。亦不见入三昧出三昧者。众生空法空故。诸佛为略说般若波罗蜜相。不念有是法。所谓一切法无相故不可念着。我等住是无所念法中能具足六波罗蜜。具足六波罗蜜故得佛金色身。如经中说。诸佛教化利喜安慰其心。问曰。上化佛已为说昙无竭是汝世世善知识。今何以复问何等是我善知识。答曰。以佛敕于善知识中倍应恭敬爱念故。又以欲于十方佛所闻昙无竭功德。欲自令信心坚固不疑故问。十方佛答如经中说。萨陀波仑是昙无竭所度因缘人故。诸佛佐助示导。或有诸菩萨佐助佛所应度者令至佛所。问曰。上闻虚空声。不问故七日啼哭。今不见十方佛。何以不大忧愁更求见佛。但欲于昙无竭所问诸佛去来事。答曰。萨陀波仑。先时但有肉眼未得三昧。以深心信着善法故大啼哭。今得诸三昧力。又见十方佛。诸烦恼微薄。着心已离故。但一心念。我当何时见昙无竭。问曰。若萨陀波仑得是三昧力。何以不还入三昧问十方诸佛从何所来去至何所而欲见问昙无竭。答曰。十方佛上以种种因缘赞昙无竭。世世是汝师。是故欲问。是时萨陀波仑念昙无竭菩萨。是我先世因缘。是故生恭敬尊重心。以有大功德故尊重。是先世因缘故恭敬爱乐。问曰。先说萨陀波仑不大著世间事。深爱般若波罗蜜故愁忧啼哭。今何以自鄙贫穷无以供养但以好心随师意则是法供养。何用华香为。答曰。法供养虽上。而世间众生见远来求法。而空无所有。则不发喜心。以世法故求供养具。复次五波罗蜜为助般若波罗蜜法。助法中檀波罗蜜为首。萨陀波仑思惟。我得尊重福田。昙无竭菩萨当以助道法根本供养。亦欲为起发众人。萨陀波仑是智人善人。贫穷而能供养。何况我等。复次诸善法行时思惟时。其味各异。萨陀波仑欲行布施味。是故求供养具。问曰。萨陀波仑是大菩萨。能见十方佛又得诸深三昧。何以贫穷。答曰。有人言。此人舍家求佛道。虽生富家道里悬远。一身独去不赍财物。有人言。虽是大人宿世小罪因缘故生贫穷家有。虽是小人先世少行布施因缘故生大富家。如苏陀夷尼陀等是诸天所供养人而生小家。贫有二种。一者财贫。二者功德法贫。功德法贫最大可耻。财贫好人亦有法。贫好人所无。无有华香者。无有上妙宝华。又以少故言无。我若空往。师虽不须我心不得大喜。是故欲卖身。问曰。若卖身与他谁买此物往供养师。答曰。舍身即是大供养。去住无在。有人言。是人卖身取财因人供养。我为供养故卖身为奴。又人言。尔时世好人皆知法。虽自卖身主必能听供养而还。复次是人发深心欲行檀波罗蜜。为供养法及法师。而无外物唯有己身。是故卖是内物。于外内物中内施为重惜之深故。是故欲不破布施愿故卖身供养。此中自说不悔因缘。我世世丧身无数。未曾为清净法故。今为供养说法者故。丧是身大得法利。萨陀波仑定心断贪惜身意。于道中入一大城。欲得卖买如意故入此大城。一心欲卖身除羞愧破憍慢故。唱言谁须人。问曰。魔何以欲破其意。答曰。魔常为诸佛菩萨怨家故欲来破。复次诸小菩萨未得诸法实相。魔及恶人能坏。若得无生法忍住诸菩萨神通力无能破者。如小树栽小儿能破大不可破。复次此中自说魔破因缘。所谓是萨陀波仑爱法故。自卖身供养般若波罗蜜及法盛菩萨。当得正闻般若波罗蜜。如经中广说。问曰。若魔欲坏萨陀波仑。先来闻空中声。及见十方佛时何以不坏。今方隐蔽诸婆罗门居士。令不闻其声。答曰。萨陀波仑先心未定。惜身未尽见十方佛。已得诸三昧。其心乃定。今定心相现。是故魔惊。若菩萨心未定。未能动魔。若大菩萨其心已定。魔亦不来。萨陀波仑今欲定心出魔境界。是故魔来。譬如负债人未欲远去债主不遮。欲出他界则不听去。问曰。魔有大力。何以不杀此菩萨而但破坏。答曰。魔本不嫉其寿命。但憎其作佛心。是故欲坏。又复诸天神法人无重罪不得妄杀。但得坏乱恐怖。若神无此法则人无活者。是故不杀。婆罗门性中生受戒故名婆罗门。除此通名居士。居士真是居舍之士。非四姓中居士。除一长者女者。以其为佛道世世集功德故魔不能蔽。复有人言。是萨陀波仑不应死故令一女人闻。有人言。是昙无竭菩萨神通力故令长者女得闻。如是三唱无人买者便大愁忧。问曰。萨陀波仑既不惜身。虽无人买亦不应愁。答曰。既发大心不满其愿。是故大愁。释提桓因作是念。萨陀波仑欲卖其身无有买者。如经中广说。问曰。释提桓因报得知他心。应知萨陀波仑心已决定。今何以来试。答曰。诸天但知世间人心。作佛不作佛心非其所知。除佛无有能知其为佛道故与授记。复次释提桓因欲多所引导故来试之。令闻见者皆发心求佛。又如金银等诸宝不以轻贱故烧锻磨打。菩萨亦如是。若能割肉出血破骨出髓其心不动。是正定菩萨。是故天帝来试。问曰。帝释是大天王。何以妄语作是言。我欲祠天须人心血髓。答曰。若以悭贪嗔恚烦恼欲求自利故妄语。是故为罪。帝释若作实身实语。菩萨则不信。是故如其国法天祠所须为其信受故。是时萨陀波仑信其语而大欢喜我得大利。大利者阿鞞跋致地。第一利者是佛道。大利者五波罗蜜。第一利者般若波罗蜜。大利者般若波罗蜜。第一利者般若波罗蜜方便力。大利者菩萨初地。第一利者十地。大利者从初地乃至十地。第一利者第十地。大利者菩萨地。第一利者佛地。如是等分别虽未具足。已住具足因缘故言便为具足。问曰。若释提桓因化身来。何以言汝须何等价。答曰。知其欲供养昙无竭菩萨满其愿故。又复释提桓因苦困萨陀波仑。畏其所索者大。是故言须何等价。随汝意与我者言于汝不大贪惜不致悔恨者与我。萨陀波仑无力势故不能得使旃陀罗故自捉刀。婆罗门亦畏罪故不能破。是以自执刀破身。问曰。若长者女闻声。何以不来问。汝何以自卖身耶。答曰。但空言卖身事轻。破身出心随事重。故长者女发心。长者女住在阁上见是人自割刺作是念。一切众生皆求乐畏苦贪爱其身。萨陀波仑而自割刺是为希有。又以先世福德因缘所牵故即往到其所而问。萨陀波仑答欲供养昙无竭菩萨。复问。得何等利。答言。般若波罗蜜名菩萨所学。当从彼闻我学是道。当得作佛与一切众生作依止。譬如厚叶树多所荫覆。又如热时旷野险道清凉大池。为说佛功德现事可以发心者。所谓金色身三十二相大光无量光大光。为阎浮提恶世众生。诸佛真实光明无有限量。大慈乃至六神通义如先说。不可思议清净戒禅定智慧。如佛戒等五众中说。于诸法中得一切无碍知见者诸佛有无碍解脱。是解脱相应知见。一切法中无所碍知见分别如先说。萨陀波仑言。我得如是无量佛功德。以无上法宝分布与一切众生。无上宝者。有人言。三宝中法宝。有人言。一切八万四千法众是为法宝。得是故除诸烦恼灭诸戏论得脱一切苦。有人言。无上法宝即是阿耨多罗三藐三菩提。更无过上者故。有人言。涅槃是无上法宝。何以故。一切有为法皆有上。如阿毗昙言。一切有为法及虚空非数缘尽名为有上法。数缘尽是无上法。数缘尽即是涅槃之别名。有人言涅槃道虽是有为以其为涅槃。故于有为法中为无上。如是等法宝分布为三乘与众生。如是等无量佛法当从师得。是故我舍是老病死所住处不净臭秽之身。为供养般若波罗蜜故。当得佛身金色等。如先说长者女世世供养诸佛种善根智慧明利。闻是法其心深入大得法喜。乃至心惊毛竖语萨陀波仑言。甚为希有。汝所赞法大微妙。为是一一法故应舍如恒河沙等身。何况一身。长者女不知何因缘故。困苦其身而怜愍之心谓不可。今闻是无量无边无比清净佛法。以是因缘可得故大欢喜。是故说为是法故应舍如恒河沙身。女言。汝以贫故自苦困其身。于今可止。恣汝所须当以相与。我亦随汝而求是道。问曰。是菩萨既自割截身体。云何能与长者女多说佛法。答曰。是菩萨心力大虽有身苦不能覆心。是菩萨始以刀割肉流血方欲破骨出髓。而长者女来未大闷故能得说法。释提桓因知其心定试之而已。故无所言。即复本身赞言善哉。汝心坚受是事者。帝释意如汝今生死肉身未得佛道。能如是不惜身。汝不久当于一切法中得无所著。住无生法忍中疾得阿耨多罗三藐三菩提。以过去佛为证。如是等种种因缘安慰其心。我是天王。爱乐佛道故来相试。欲知汝心坚软云何。欲令汝信故言须人心髓祠天。实不须也。汝愿何等当以相与。汝是好人为是佛种当相拥护。萨陀波仑直信心善软深着佛道故不分别众生。闻帝释语便言。与我阿耨多罗三藐三菩提。帝释言。此非我力所能办。是佛境界。复次有人言。帝释大苦困萨陀波仑。今以此语谢之。帝释意谓求金银宝物。不知乃索阿耨多罗三藐三菩提。既不能与愧负而已。复更语言。必相供养更索余愿。帝释语意我既大相苦困不得直尔而去要相供养。萨陀波仑虽不惜身欲以此身供养昙无竭闻般若波罗蜜。是故语言。若汝无此力。令我身体平复如故。帝释言。如汝所言。疮即平满与本无异。问曰。先已割肉云何令得平满。答曰。佛说有五不可思议。龙事所作尚不可思议。何况天。又虚空中微尘充满。帝释福德生心便能和合平满。如诸天及地狱中身非是三生身。罪福因缘故和合便有。是时帝释知其心坚与愿已即时灭去。尔时萨陀波仑宿世微罪已毕福德明盛。是故长者女将归。有所须者从我父母索之。如经中广说。问曰。是女先言汝所须物尽从我索之。今何以言从我父母索。答曰。今既将归到舍。以萨陀波仑目见入舍从父母得之愧不称前言。是故先自说从我父母牵之。又女虽力能得宝以子女法故从父母索之。女既入舍如先所许。从父母索与。其国无有佛法。是故问女阿谁是萨陀波仑菩萨。女如所见如所闻尽向父母说萨陀波仑事。今父母当听我与萨陀波仑菩萨俱及五百侍女并供养具供养昙无竭菩萨。父母闻其言即听。如汝意。问曰。长者贵而有力。云何先不识萨陀波仑。闻其功德故便能令女及其眷属宝物与之俱去。答曰。长者亦植德本以少因缘故生无佛国。暂闻佛德发其宿识心即开悟故能发遣。譬如莲花生长具足见日开敷。父母知女心淳熟无不净行持操不妄不乐世乐但求法利。知其心至不可制止。若违其意恐其自害。思惟筹量已既全其意。自得功德欢喜令去。世间因缘深着难解。爱之至故尚不能违。何况为佛道。故其心清净无所染着而不听之。女以父母为法见听不惜宝物。亦以随喜心为之欢喜。尔时众心既定庄严七宝之车。与大众围绕稍稍东行。是时五百女亲属及城中众人。见是希有难及之事皆亦随去。人众既集欢悦共行。渴仰众香城如渴者思饮。渐渐进路遥见众香城。乃至与长者女及五百女人恭敬围绕。欲往昙无竭所。问曰。昙无竭是大菩萨。得闻持等诸陀罗尼。般若波罗蜜义已自通利忆持。何用七宝台书般若经卷着中供养。答曰。虽有种种因缘。略说有二义。一者众生心行不同。或乐见经卷。或乐闻演说。二者昙无竭身为白衣现有家属。钝根众生或作是念。此有居家必有染着。何能以毕竟清净无著般若波罗蜜利益众生。自未无著。何能以无著法教化。是故书其经文着七宝牒上众宝供养。诸天龙鬼神皆亦共来恭敬供养花香幡盖雨于七宝。众生见者增益信根。则以此法示传佛语。案文演教劝发一切宝台庄严之具及萨陀波仑。问释提桓因如经中说七宝印。印者是昙无竭真实印。常自手执以印于经。有人言七宝印者有求佛道七大神。是执金刚杵。常给昙无竭菩萨使守护经文。不令魔及魔民改更错乱。为贵敬般若故。有人但闻演说而发心者。有人见其庄严文字而欢喜发心者。是故庄严宝台用金牒书七宝印印。问曰。台上书写般若。昙无竭菩萨口所演说般若。虽二处俱有而书写处不能益人。何以先至台所。答曰。所书般若入法宝中。佛宝次第有法宝故应先供养。昙无竭一人故僧宝所不摄。是故先供养法宝。又昙无竭菩萨所说者虽是法而众生取人相故多生着心。若见所书般若不生人相。虽取余相着心少于着人生患。是故先供养经。经法诸佛尚供养。何况昙无竭及萨陀波仑。昙无竭因般若波罗蜜故得供养所因之本。何得不先供养。是故分所供养具为二分。问曰。昙无竭有六万婇女五欲宫殿。云何能以所散花物化为花台。答曰。有人言诸佛神力因萨陀波仑所供养物作此变化。有人言昙无竭是大菩萨法性生身。为度众生故受五欲。如昙无竭菩萨名字义中说。问曰。菩萨法先于众生中起悲心。欲度众生苦故。求阿耨多罗三藐三菩提。今但见昙无竭神力威德。云何发心。答曰。发心有种种。有闻说法而发心者。有于众生起慈悲而发心者。有见神通力大威德而发心者。然后渐渐而生悲心。如智印经中说。依爱而断爱。依慢而断慢。如人闻道法爱着是法。故舍五欲出家。又有闻某甲得阿罗汉道而生高心。此人无胜我事。彼尚能尔。我何不能。而生大精进得阿罗汉道。佛道中亦如是。长者女等及五百女人常深贪势力自在乐。闻往古有人神力变化宝物具足人中受天乐后。见昙无竭台观宫殿在大法座上坐。天人供养。又见所供养物于虚空中化成大台心即大喜。发难遭想知皆从福德因缘可办是事。是故皆发作佛心所闻发心者行皆次第行。如毗摩罗鞊经中说。爱慢等诸烦恼皆是佛道根本。是故女人见是事已生爱乐心。知以福德因缘可得是事故皆发心。因是爱慢后得清净好心故言佛道根本。譬如莲花生污泥。发心已作愿。如昙无竭所为。我等亦当得是。时萨陀波仑等头面礼昙无竭菩萨。花香等供养不贵故先。以供养身贵重故后礼拜。礼拜已说本求般若因缘。如经中说。我本求般若时。闻空中声。乃至我今问大师诸佛从何所来去至何处。问曰。萨陀波仑得诸大三昧。所谓破无明观诸法性等。云何不知空而取佛相深生爱着。答曰。若新发意菩萨虽能总相知诸法空无相。于诸佛所深爱着故。不能解佛相毕竟空。虽知空而不能与空合。何以故。诸佛有无量无边实功德。是菩萨利根故深入深着。若佛不为是菩萨说空者。是菩萨为爱佛故能自灭亲族。何况余人。但以解空故无是事。萨陀波仑深着诸佛故不能知而问大师。今为我说诸佛来去相。我见佛身无厌足故。常不离见诸佛

大智度论卷第九十八大智度论释昙无竭品第八十九(卷第九十九)

        龙树菩萨造

        后秦龟兹国三藏鸠摩罗什译

【经】尔时昙无竭菩萨摩诃萨语萨陀波仑菩萨言。善男子。诸佛无所从来。去亦无所至。何以故。诸法如不动相。诸法如即是佛。善男子。无生法无来无去。无生法即是佛。无灭法无来无去。无灭法即是佛。实际法无来无去。实际法即是佛。空无来无去。空即是佛。善男子。无染无来无去。无染即是佛。寂灭无来无去。寂灭即是佛。虚空性无来无去。虚空性即是佛。善男子。离是诸法更无佛。诸佛如诸法如。一如无分别。善男子。是如常一无二无三出诸数法。无所有故。譬如春末月日中热时。有人见焰动。逐之求水望得。于汝意云何。是水从何池何山何泉来。今何所去。若入东海西海南海北海耶。萨陀波仑言。大师。焰中尚无水。云何当有来处去处。昙无竭菩萨语萨陀波仑菩萨言。善男子。愚夫无智为热渴所逼。见焰动无水生水想。善男子。若有人分别诸佛有来有去。当知是人皆是愚夫。何以故。善男子。诸佛不可以色身见。诸佛法身无来无去。诸佛来处去处亦如是。善男子。譬如幻师幻作种种若象若马若牛若羊若男若女。如是等种种诸物。于汝意云何。是幻事从何处来。去至何所。萨陀波仑菩萨言。大师。幻事无实。云何当有来去处。善男子。是人分别佛有来有去亦如是。善男子。譬如梦中见若象若马若牛若羊若男若女。于汝意云何。梦中所见有来处有去处不。萨陀波仑言。大师。是梦中所见虚妄。云何当有来去。善男子。是人分别佛有来有去亦如是。善男子。佛说诸法如梦。若有众生不知是诸法义以名字色身着佛。是人分别诸佛有来有去。不知诸法实际相故。皆是愚夫无智之数。是人数数往来五道。远离般若波罗蜜。远离诸佛法。善男子。佛说诸法如幻如梦。若有众生如实知。是人不分别诸法若来若去若生若灭。若不分别诸法若来若去若生若灭。则能知佛所说诸法实相。是人行般若波罗蜜。近阿耨多罗三藐三菩提。名为真佛弟子。不虚妄食人信施。是人应受供养为世间福田善男子。譬如大海水中诸宝。不从东方来。不从南方西方北方四维上下来。众生善根因缘故。海生此宝。此宝亦不无因缘而生。是宝皆从因缘和合生。是宝若灭亦不去至十方。诸缘合故有。诸缘离故灭。善男子。诸佛身亦如是。从本业因缘果报生。生不从十方来。灭时亦不去至十方。但诸缘合故有。诸缘离故灭。善男子。譬如箜篌声。出时无来处。灭时无去处。众缘和合故生。有槽有颈有皮有弦有柱有棍。有人以手鼓之众缘和合而有声。是声亦不从槽出。不从颈出。不从皮出。不从弦出。不从柱出。不从棍出。亦不从人手出。众缘和合尔乃有声。是因缘离时亦无去处。善男子。诸佛身亦如是。从无量功德因缘生不。从一因一缘一功德生。亦不无因缘有众。缘和合故有。诸佛身不独从一事成。来无所从。去无所至。善男子。应当如是知诸佛来相去相。善男子。亦当知一切法无来去相。汝若知诸佛及诸法无来无去无生无灭相。必得阿耨多罗三藐三菩提。亦能行般若波罗蜜及方便力。尔时释提桓因以天曼陀罗花与萨陀波仑菩萨摩诃萨作是言。善男子。以是花供养昙无竭菩萨摩诃萨。我当守护供养汝。所以者何。汝因缘力故。今日饶益百千万亿众生。使得阿耨多罗三藐三菩提。善男子。如是善人甚为难遇。为饶益一切众生故。无量阿僧祇劫受诸勤苦。萨陀波仑菩萨摩诃萨受释提桓因曼陀罗花。散昙无竭菩萨上。白言。大师。我从今日以身属师供给供养。如是三白已。合手师前立。是时长者女及五百侍女白萨陀波仑菩萨言。我等从今日亦以身属师。我等以是善根因缘故。当得如是法。亦如师所得。共师世世供养诸佛世世常供养师。是时萨陀波仑菩萨语长者女及五百女人。若汝等以诚心属我者。我当受汝。诸女言。我等以诚心属师。当随师教。是时萨陀波仑菩萨及五百女人。并诸庄严宝物上妙供具及五百乘七宝车。奉上昙无竭菩萨。白言。大师。我持是五百女人奉给大师。是五百乘车随师所用。尔时释提桓因赞萨陀波仑菩萨言。善哉善哉。善男子。菩萨摩诃萨舍一切所有。应如是如是布施。疾得阿耨多罗三藐三菩提。作如是供养说法人。必得闻般若波罗蜜及方便力。过去诸佛本行菩萨道时。亦如是住布施中得闻般若波罗蜜及方便力。得阿耨多罗三藐三菩提。尔时昙无竭菩萨欲令萨陀波仑菩萨善根具足故。受五百乘车长者女及五百侍女。受已还与萨陀波仑菩萨。是时昙无竭菩萨说法日没。起入宫中。萨陀波仑菩萨摩诃萨作是念。我为法故来。不应坐卧。当以二事。若行若立。以待法师从宫中出说法。尔时昙无竭菩萨七岁一心入无量阿僧祇菩萨三昧。及行般若波罗蜜方便力。萨陀波仑菩萨七岁经行住立不坐不卧。无有睡眠。无欲恚恼。心不着味。但念昙无竭菩萨摩诃萨何时当从三昧起出而说法。萨陀波仑菩萨过七岁已。作是念。我当为昙无竭菩萨摩诃萨敷说法座。昙无竭菩萨摩诃萨当坐上说法。我当洒地清净散种种华庄严是处。为昙无竭菩萨摩诃萨当说般若波罗蜜及方便力故。是时萨陀波仑菩萨与长者女及五百侍女。为昙无竭菩萨摩诃萨敷七宝床。五百女人各脱上衣以敷座上。作是念。昙无竭菩萨摩诃萨当坐此座上说般若波罗蜜及方便力。萨陀波仑菩萨敷座已。求水洒地而不能得。所以者何。恶魔隐蔽令水不现。魔作是念。萨陀波仑菩萨求水不得。于阿耨多罗三藐三菩提行乃至生一念劣心异心。则善根不增智慧不照。于一切智而有稽留。尔时萨陀波仑菩萨作是念。我当自刺其身以血洒地。令无尘土来坋大师。我何用此身。此身必当破坏。我从无始生死已来数数丧身。未曾为法。即以利刀自刺出血洒地。萨陀波仑菩萨及长者女并五百侍女。皆无异心。恶魔亦不能得便。是时释提桓因作是念。未曾有也。萨陀波仑菩萨爱法乃尔。以刀自刺出血洒地。萨陀波仑及众女人心不动转。恶魔波旬不能坏其善根。其心坚固发大庄严。不惜身命。以深心欲求阿耨多罗三藐三菩提。当度一切众生无量生死苦。释提桓因赞萨陀波仑菩萨言。善哉善哉。善男子。汝精进力大坚固难动不可思议。汝爱法求法最为无上。善男子。过去诸佛亦如是。以深心爱法惜法重法。集诸功德。得阿耨多罗三藐三菩提。萨陀波仑菩萨作是念。我为昙无竭菩萨摩诃萨。敷法座扫洒清净已讫。当于何处得好名华庄严此地。若昙无竭菩萨摩诃萨法座上坐说法时。亦当散华供养。释提桓因知萨陀波仑菩萨心所念。即以三千石天曼陀罗华与萨陀波仑。萨陀波仑受华以半散地。留半待昙无竭菩萨摩诃萨。坐法座上说法时当供养。尔时昙无竭菩萨摩诃萨。过七岁已从诸三昧起为说般若波罗蜜故。与无量百千万众恭敬围绕往法座上坐。萨陀波仑菩萨摩诃萨见昙无竭菩萨摩诃萨时。心净悦乐。譬如比丘入第三禅

释曰萨陀波仑菩萨。虽知诸法空无来去相。未能深入。亦不能解种种法门。于诸佛身恭敬深重故不能观空。如大海水波其力虽大到须弥山边则退而无用。萨陀波仑亦如是。虽有大空智力。到佛所则亦无用。是故昙无竭菩萨。今为说诸佛无所从来去亦无所至。此中昙无竭自说因缘。所谓诸法如不动相。诸法如即是佛。问曰。何等是诸法如。答曰。诸法实相。所谓性空无所得空等诸法门。问曰。摩诃般若波罗蜜。于佛法大乘六波罗蜜中第一法。若无佛则无说般若者。三十二相八十随形好十力四无所畏等。色无色法等净妙五众和合。是故名为佛。如五指和合名为拳。不得言无拳。名字既异形亦异力用亦异。不得言无拳。是故知有佛。答曰。不然。佛法中有二谛。世谛第一义谛。世谛故言佛说般若波罗蜜。第一义故说诸佛空无来无去。如汝说清净五众和合故名为佛。若和合故有。是即为无。如经中佛自说因缘。五众非佛。离五众亦无佛。五众不在佛中。佛不在五众中。佛非五众有。何以故。五众是五。佛是一。一不作五。五不作一。又五众无自性故虚诳不实。佛自说一切无诳法中我最第一。是故五众不即是佛。复次若五众即是佛。诸有五众者皆应是佛。问曰。以是难故我先说第一清净五众三十二相等名为佛。答曰。三十二相等菩萨时亦有。何以不名为佛。问曰。尔时虽有相好庄严身而无一切种智。若一切种智在第一妙色身中是即名为佛。答曰。一切应智般若中说是寂灭相无戏论。若得是法则名无所得。无所得故名为佛。佛即是空。如是等因缘故。五众不得即是佛。离是五众亦无佛。所以者何。离是五众更无余法可说。如离五指更无拳法可说。问曰。何以故无拳法。形亦异力用亦异。若但是指者不应异。因五指合故拳法生。是拳法虽无常生灭不得言无。答曰。是拳法若定有。除五指应更有拳可见。亦不须因五指。如是等因缘离五指更无有拳。佛亦如是。离五众则无有佛。佛不在五众中。五众不在佛中。何以故。异不可得故。若五众异佛者。佛应在五众中。但是事不然。佛亦不在五众。所以者何。离五众无佛。离佛亦无五众。譬如比丘有三衣钵故可得言有。但佛与五众不得别异。是故不得言佛有五众。如是五种求佛不可得故。当知无佛。佛无故无来无去。问曰。若无佛即是邪见。云何菩萨发心求作佛。答曰。此中言无佛。破着佛想。不言取无佛想。若有佛尚不令取。何况取无佛邪见。又佛常寂灭无戏论相。若人分别戏论常寂灭事。是人亦堕邪见。离是有无二边处中道。即是诸法实相。诸法实相即是佛。何以故。得是诸法实相名为得佛。复次色等法如相即是佛。色等法性空是如相。诸佛如亦性空。以是故不来不去不生不灭法性实际空无染寂灭。虚空性亦如。无来无去如。乃至虚空性如佛如。是如一无二无三等别异。此中自说因缘。何以故。出诸数法无所有故。如等法是实。是中无有忆想分别取相故有名字名字中有数。此中自说因缘。空非实无所有故。问曰若是法无所有。云何可见可闻有苦有乐有缚有脱等分别诸异。答曰。此中昙无竭自种种分别譬喻说。所谓如春末月见焰。乃至是人不分别诸法若来若去。如焰等中虽无实事亦能诳人自生苦乐事。诸法亦如是。虽空无所有亦能令人得苦乐忧喜事。梦等法亦如是。复次佛有二种身。一者法身。二者色身。法身是真佛。色身为世谛故有。佛法身相上种种因缘说诸法实相。是诸法实相亦无来无去。是故说诸佛无所从来去亦无所至。若人得诸佛法身相是名近阿耨多罗三藐三菩提。未得一切智故名为近。以相似故般若波罗蜜名诸法实相。若能如是行是为行般若波罗蜜。真佛弟子。真佛弟子者得诸法实相名为佛。得诸法实相差别故。有须陀洹乃至辟支佛大菩萨。须陀洹等乃至大菩萨。是名真佛弟子。不虚妄食人信施者。布施畜生虽得百倍果报。而此福有尽有量。不能度众生生死故名为虚食。须陀洹等乃至佛诸贤圣受人信施。此福果报乃至涅槃无尽无量。是故说不虚妄食人信施。是人应受一切众生供养。若须陀洹应受一切凡夫人供养。斯陀含应受凡夫人乃至须陀洹供养。阿那含应受凡夫人及须陀洹斯陀含供养。阿罗汉应受凡夫人须陀洹斯陀含阿那含供养。辟支佛应受凡夫人及须陀洹乃至阿罗汉供养。近成佛大菩萨。应受凡夫人及声闻辟支佛供养。为世间福田者。如植种良田成收必多。持戒禅定智慧福田。众生植福获果无量。上说诸佛无来无去。萨陀波仑及诸听者意谓。诸佛尚无。诸法亦应皆灭。则堕断灭。是故今说因缘法譬喻。昙无竭示萨陀波仑。如汝所著意谓实有者。无为度众生故从因缘和合则有像现。欲证明此事故说譬喻。如大海中生宝。不从十方来。灭亦无所去。亦不无因缘而生。以四天下众生福德因缘故海生此宝。若劫尽灭时亦无去处。譬如灯灭焰无所至。佛身亦尔。从初发心所种善根功德皆是佛身相好因缘。佛身亦不自在皆属本因缘。业果报故生是因缘。虽久住性是有为法故必归无常。散坏则无身。譬如善射之人仰射虚空箭去虽远必当堕地。诸佛身亦如是。虽相好光明福德成就名称无量度人无限亦归磨灭。问曰。若众生福德因缘故海生珍宝。何以不近众生处生。而乃在大海难得之处。答曰。海中亦有众生。龙阿修罗等用是宝。复次若宝生人中浊世。贪者覆藏不令人得。若好世时珍宝自生。人间无有惜者。如弥勒佛时珍宝如瓦砾。以懈怠懒惰人惜身强作愿求乐。是故宝在大海不能得。若大心不惜身命勤求者乃得。大海水喻十方六道国土。诸珍宝即是诸佛。如珍宝为一切众生故生。而懈怠懒惰者所不能得。诸佛亦如是。虽为众生故出世门。懈怠小心贪身着我者不得度。所以者何。诸法皆从众缘和合生。众生有二因缘。故得度。一者内有正见。二者外有善说法者。诸佛虽善说法。众生内正见不具故不能尽度。如宝物虽为众生出而有贫穷众生。诸佛亦如是。虽为众生出而众生内正见少故亦不得度。复有箜篌譬喻。有槽有颈有皮有弦有棍有人以手鼓之。众缘和合而有声。如声亦不在众缘中。离众缘亦无声。以因缘和合故有声可闻。诸佛身亦如是。六波罗蜜及方便力。众因缘和合边生佛身。不在六波罗蜜等法中。亦不离六波罗蜜等法。如声不以一因缘亦非无因缘。佛身亦如是。不从无因缘亦不从少因缘。诸善法因缘具足故生诸佛身。如镜中像众因缘和合故有。众缘离故无。诸佛亦如是。有诸因缘故出现。诸因缘散故灭。善男子。应如是观诸佛来去相。一切诸法相亦应如是知。昙无竭语萨陀波仑。善男子。汝能知诸法相不来不去。必得阿耨多罗三藐三菩提不退转。亦必能行般若波罗蜜及方便力。何以故。一切法无障碍故。问曰。释提桓因何以化作文陀罗华与萨陀波仑。答曰释提桓因爱乐佛道故常供养诸菩萨。复次释提桓因欲摄众生令入佛道故现天王身以华与萨陀波仑。萨陀波仑一心求佛道故。诸天来供养。众生见者皆亦发心释提桓因为引导众生故。供养萨陀波仑。有人言。释提桓因深爱敬萨陀波仑。上品来试已令身体平复。今复以华与之。释提桓因力能与一切人华。以众生无福力故。设当与者华即变坏。萨陀波仑福德成就故得必不变。是故与。若一切菩萨供养师时。不尽与应守护供养者。先已说因缘。所谓割肉出血试以成亲旧故守护。复次释提桓因此中自说因缘。所谓汝因缘力故饶益百千等众生。萨陀波仑取华如其意供养昙无竭。萨陀波仑初闻师名。后眼见闻法断疑故以身供养。长者女等亦效萨陀波仑。以身施萨陀波仑。问曰。萨陀波仑以身供养昙无竭。昙无竭福田大。女何以不以身供养而与萨陀波仑。答曰。女人智短着多故不用舍本师而供养他又以女身罪秽心虽清白为外有讥谤故。问曰。长者女初舍父母已属萨陀波仑。今何以复以身施。答曰。初舍父母共萨陀波仑诣昙无竭。为法故供养。亦不自以身施。父母亦不以施萨陀波仑。今见萨陀波仑问甚深义。昙无竭为解说。释提桓因欢喜供养。是故发欢喜心以身供养。以自在心故。又一切女身无所系属则受恶名。女人之礼。幼则从父母。少则从夫。老则从子。是长者女等虽道路共来不得久无所属。是故自以身施而作是愿。如师所得。我等亦当得之。尔时萨陀波仑欲以此女供养昙无竭。虑其嫌恨故问。汝等实以诚心供养我当受。汝诚心者不自用心随所处分如无心物。诸女人等言实以诚心。即时萨陀波仑以长者女并诸侍女及五百乘车奉上昙无竭。萨陀波仑欲除世人常疑。谓其欺诳长者将诸女来。是故尽以布施明已无著。复次萨陀波仑如空中声所闻得解欢喜。如世人所贵内外物尽以供养。欲深入檀波罗蜜门故。释提桓因知萨陀波仑爱贪等烦恼未尽而能尽舍内外布施无复遗余故赞言善哉。以过去佛为喻。行难事故得难得果报。所谓阿耨多罗三藐三菩提。问曰。若昙无竭欲令萨陀波仑善根具足故受。善根者所谓具足檀波罗蜜。何以故还与萨陀波仑。答曰。昙无竭大智方便。令萨陀波仑大得福德而无所失是谓上受萨陀波仑至诚心施。断诸贪着不望还得福德具足。昙无竭思惟。萨陀波仑远来而于五欲心不染着。旧人供养为善。是故还与。又闻诸女先以身上萨陀波仑。人非财物欲遂其本意故。又是诸女世世为萨陀波仑弟子如是等因缘故还与萨陀波仑。问曰。诸大菩萨说法不应疲极。何以入宫。答曰。随世人法故。又众香城中众生不常求道。或时厌息受五欲乐。诸天常受五欲故妨废求道。有菩萨所住国常勤精进不受五欲。是众香城众生本愿杂受。昙无竭随其志愿欲引导之故生其国。是故以众生听法疲惓起入宫中。又未得道者。法虽微妙常闻故生疲厌心。是众中有是人故。又昙无竭在是中受富乐人法故日没应息。是时萨陀波仑作是念。我为法来不应坐卧。问曰。为法故何以不应坐卧。答曰。无是定法。此人大欲大精进恭敬法故自作是念。我若坐卧则是懒惰。我初求法时身尚不惜何况疲惓。是故不坐卧。大欲大精进与坐卧相违故。又坐卧则不勤力。行立则勤力精进。是故常住二威仪以待师出。问曰。萨陀波仑先知师七岁不出不。答曰。初来不知故。不复昙无竭亦常七岁不出。以因缘故。自誓七岁入定。萨陀波仑自誓师未出终不坐卧。又大人世间法尚不自违。何况为道法。又以初求法时尚不惜身今立七岁。何足为难。问曰。人身软弱。何能七岁不坐不卧。答曰。是时人寿命长。虽复七岁如今七日。又好世人身福德力大。虽立七岁不以为难。如勤比丘年六十始出家。而自结誓我胁不着席要尽得声闻所应得事。乃至得六神通阿罗汉。作四阿含优婆提舍。于今大行于世。此人于恶世尚尔。何况萨陀波仑生于好世。又身力虽弱以心强故能办其事。复次一心求佛道者。十方诸佛所念诸大菩萨及求佛道诸天益其气力。围绕守护。是故虽住立七岁而不疲极。问曰。昙无竭入三昧。何以乃至七岁。答曰。先已答。好世人寿长。虽七岁不以为久。又昙无竭宫殿婇女微妙五欲与天相似。萨陀波仑等新发意者心未柔软疑昙无竭。虽说空法赞叹离欲。谓其心未能舍。是故七岁三昧欲以除众疑故生贵敬心。闻昙无竭七岁三昧心口相应能说能行。则信受其语易可得度。譬如痈疮未熟医则不破但以药涂令熟熟则易破。复次欲受心生实乐故入无量三昧。复次说法有二种。一者口说法。二者身现法。今欲以身现法故入无量三昧。令众生知摄心入慧得如实智。菩萨三昧者如菩萨义中说。行般若方便力者如方便品中说。萨陀波仑于七岁中三恶觉观不生不味于味。是人虽未破烦恼而集诸善法故。制诸烦恼不令得生。但一心念昙无竭。何时当出。我当从闻般若。过七岁已作是念。我当为昙无竭敷坐处扫洒庄严。问曰。萨陀波仑云何得知过七岁已昙无竭当出。答曰。有人言。先曾七岁展转闻知。有人言。昙无竭初入三昧时自说七岁为限。如释迦文尼佛告阿难。我欲一月二月入禅定。阿难以告四众。萨陀波仑深爱佛法敬重昙无竭故。供养庄严说法处。出家菩萨但庄严其心诣师受法。在家菩萨则庄严说法处华香供养。复次萨陀波仑作是庄严。欲令昙无竭知其爱法欲法相。深心信乐故现是事。是故生心共五百女等展力扫洒。自以其金银珍宝敷座。萨陀波仑等虽自有妙好茵褥。为爱法情至故。以身所著上衣敷座。求水洒地。魔隐蔽故求不能得。此中自说因缘。魔作是念。若萨陀波仑求水不得其心则劣。志愿不满故。又令自鄙其身。我薄福德故。为供养法求水不得。以自轻忧愁覆心故。福德不增智慧不照不明者。诸忧愁烦恼覆心故。诸福德智慧不能照明。譬如日障蔽故其照不明。魔知其心大不可沮坏但小沮坏令其稽留。尔时萨陀波仑自刺其身。出血洒地欲以淹尘。人血肉虽臭以其至心求水不得。意不分别香臭好恶。为欲淹尘不惜身命。又萨陀波仑深心爱着般若波罗蜜故无所爱惜。有人言。多有诸天龙鬼神等。常随逐萨陀波仑佐助守护。是故所出之血变为香水。如羼提仙人被割截时血化为乳。又以无量福德成就故随愿即成。问曰。若福德成就随愿即得。魔不应隐蔽其水。答曰。是菩萨新发意能成小愿未能却魔。此中萨陀波仑自说出血因缘。我从无始生死已来。数数丧身未曾为法。问曰。若萨陀波仑爱法刺身出血。若其身死谁复听法。答曰。是事如破骨出髓中答。又此中诸天大菩萨守护故令其不死。又复恶魔知其心不可沮坏。水则还出。萨陀波仑等皆无异心者。如人初习慈心。欲为众生及为般若波罗蜜故不惜身命。既得利刀割身以痛自逼故心生悔恨。是名异。是菩萨信力大故。欲得阿耨多罗三藐三菩提果报故不计是苦。又以深悲心爱念众生。虽受种种苦恼不以为难。譬如慈母爱子。虽为子长受勤苦不净不以为恶。又复见诸法实相毕竟空故。知是身但是虚诳和合。破是虚诳故。割截身时。不妨阿耨多罗三藐三菩提。魔不得其便者。如人有疮则受毒。菩萨若有贪欲忧愁疮者。魔得其便。以出血洒地心不忧愁故魔不得便。如萨陀波仑心五百女人心亦如是。敬重萨陀波仑故。见其刺身应有忧愁。以其愿得满故不以为愁。尔时释提桓因见是事已叹未曾有者。是人未得无生忍。诸烦恼未断。为供养法故不惜身命。如诸离欲人无异。割截其身如断草木。初心既尔。后心转增。复次未曾有者。此中释提桓因自说因缘。萨陀波仑爱法乃尔。以刀自刺等。释提桓因作是心欢喜已赞言善哉。赞其爱法乐法勤心精进。以过去佛为喻。非但汝今辛苦。过去诸佛求般若亦尔。萨陀波仑闻释提桓因安慰其心已。如火得酥转更炽盛。作是念。我既敷座洒地。当于何处得好名华庄严法处。问曰。不见水时何以不作是念。当于何处得水洒地。答曰。萨陀波仑以先有水处即时皆无知魔所作。是故自于四大分中刺水分洒地。身中水种虽多。血是命之所在。是故刺以洒地。华不自有。昙无竭出时欲至不容远求。又所须复多。当以遍覆其地。是故生念欲得。帝释知其念即以天华中妙者。名曼陀罗。三千石与之。足以周事。帝释所以不以人华与者。欲令发希有心故。萨陀波仑受华已分作二分。好者留以说法时散。余者覆地。其国俗法以华覆地。令行其上以为供养。尔时昙无竭如其先要。满七岁已从三昧起。与无量百千众恭敬围绕直趣法座。为说般若故。问曰。若诸菩萨入微妙三昧中谁能令起。答曰。行者初入时自作限齐。然后入定时至。其心自在从三昧起。悲心故而生觉观。如一比丘。入灭受定三昧时。自期闻犍捶时当起。既入已时僧坊失火。诸比丘惶懅不打犍捶而去。尔时过十二岁已檀越更和合。众僧欲起僧坊方打犍捶。闻犍捶声起即身散而死。后诸得道者说其如此。复次有人言。法性生身大菩萨。如诸佛常入三昧无散乱粗心。以神通力故能说法。飞行度脱众生。世俗法故有出入三昧相。是故虽入微妙三昧而能还出。以大悲心牵故。譬如咒术出龙。大众围绕者。是内眷属恭敬。散华烧香随从而出。为说般若波罗蜜故。说般若波罗蜜者。因世谛名字语言欲示众生第一义不动相故。萨陀波仑见昙无竭即得清净欢喜乐遍其身如比丘入于三禅。所以者何。多欲众生虽非净妙得犹喜乐。何况得见真功德庄严身者。萨陀波仑从空中佛闻昙无竭即生大欲得诸三昧见十方诸佛。复闻十方诸佛说先世因缘。唯有昙无竭能度汝耳。闻是已增益其心渴仰欲见。是故中道欲卖身供养。今于众香城七岁不坐不卧。欲见昙无竭。如是渴仰欲乐来久。如人热渴所逼。得浊暖潦水犹尚欢喜。何况得清冷美水。既以渴仰情久。又昙无竭功德大。是故悦乐。问曰。乐有四种。何以但说第三禅乐而不说上地定乐及解脱乐。答曰。以欲界众生于三受中多贪乐受。闻涅槃乐无所有则心不乐喜。以上四禅中断苦乐故心亦不乐。第三禅中乐乐之极。复有人言。萨陀波仑新发意未入细深妙定故。见昙无竭发大欢喜似如三禅乐。萨陀波仑自觉我大欢喜故。即时舍喜得清净法性遍身安乐。是故以三禅乐为喻

大智度论卷第九十九大智度论释昙无竭品第八十九(卷第一百)

        龙树菩萨造

        后秦龟兹国三藏鸠摩罗什译

【经】尔时萨陀波仑菩萨摩诃萨及长者女并五百侍女。到昙无竭菩萨摩诃萨所。散天曼陀罗华头面礼毕退坐一面。昙无竭菩萨见其坐已。告萨陀波仑菩萨言。善男子谛听谛受。今当为汝说般若波罗蜜相。善男子诸法等故当知般若波罗蜜亦等。诸法离故当知般若波罗蜜亦离。诸法不动故当知般若波罗蜜亦不动。诸法无念故当知般若波罗蜜亦无念。诸法无畏故当知般若波罗蜜亦无畏。诸法一味故当知般若波罗蜜亦一味。诸法无边故当知般若波罗蜜亦无边。诸法无生故当知般若波罗蜜亦无生。诸法无灭故当知般若波罗蜜亦无灭。虚空无边故当知般若波罗蜜亦无边。大海水无边故当知般若波罗蜜亦无边。须弥山庄严故当知般若波罗蜜亦庄严。虚空无分别故当知般若波罗蜜亦无分别。色无边故当知般若波罗蜜亦无边。受想行识无边故当知般若波罗蜜亦无边。地种无边故当知般若波罗蜜亦无边。水种火种风种无边故当知般若波罗蜜亦无边。空种无边故当知般若波罗蜜亦无边。如金钢等故当知般若波罗蜜亦等。诸法无分别故当知般若波罗蜜亦无分别。诸法性不可得故当知般若波罗蜜性亦不可得。诸法无所有等故当知般若波罗蜜亦无所有等。诸法无作故当知般若波罗蜜亦无作。诸法不可思议故当知般若波罗蜜亦不可思议。是时萨陀波仑菩萨摩诃萨即于座上得诸三昧。所谓诸法等三昧。诸法离三昧。诸法无畏三昧。诸法一味三昧。诸法无边三昧。诸法无生三昧。诸法无灭三昧。虚空无边三昧。大海水无边三昧。须弥山庄严三昧。虚空无分别三昧。色无边三昧。受想行识无边三昧。地种无边三昧。水种火种风种空种无边三昧。如金钢等三昧。诸法无分别三昧。诸法不可思议三昧。如是等得六百万诸三昧门。尔时佛告须菩提。如我今于三千大千世界中与诸比丘僧围绕。以是相以是像貌以是名字说般若波罗蜜。萨陀波仑得是六百万三昧门。见东方南西北方四维上下如恒河沙等三千大千世界中诸佛与诸比丘恭敬围绕。以如是相以是像貌以是名字。说是摩诃般若波罗蜜亦如是。萨陀波仑菩萨从是已后。多闻智慧不可思议如大海水。常不离诸佛生于有佛土中。乃至梦中未曾不见佛时。一切众难皆悉已断。在所佛土随愿往生。须菩提。当知是般若波罗蜜因缘能成就菩萨摩诃萨一切功德得一切种智。以是故。须菩提。诸菩萨摩诃萨若欲学六波罗蜜。欲深入诸佛智慧。欲得一切种智。应受持是般若波罗蜜。诵读正忆念广为人说。亦书写经卷供养尊重赞叹香华乃至妓乐。何以故。般若波罗蜜是过去未来现在十方诸佛母。十方诸佛所尊重故

【论】释曰。昙无竭既出至法座所。遍观无胜己者于是而坐。尔时萨陀波仑菩萨知坐已定。到昙无竭所头面礼足一面坐。礼有三种。一者口礼。二者屈膝头不至地。三者头至地。是为上礼。人之一身头为最上。足为最下。以头礼足恭敬之至。昙无竭见其坐已。知从远来不惜身命种种勤苦为欲闻法。初相见时日垂欲没。少时闻法。昙无竭以日没故起入宫中。今为法故七岁渴仰不生异心。垂欲出时以血洒地。知其为法不惜身命其心不退决定无疑堪受教化。是故告言。善男子一心谛听。上疑诸佛来去已断。今但欲闻甚深般若波罗蜜。是故为说般若波罗蜜相。般若波罗蜜相者。如先诸法平等义中说。或有人言。般若波罗蜜力故观诸法皆平等。非诸法性性自平等。是故昙无竭言。诸法平等故般若波罗蜜平等。所以者何。因果相似故。初观诸法平等。是因。决定心得般若波罗蜜。是为果。问曰。观诸法平等即是般若。般若即是平等。何以分别为因果。答曰。般若及诸法虽一相无二无别。行者初观时是因。观竟名为果。如须陀洹道得向。又如有漏五众。因时名集。果时名苦。色等一切法平等。即是般若波罗蜜平等。问曰。应说般若波罗蜜相。今何以说平等。因不平故有平等。因平故有不平。于般若中亦不一相亦不异相。汝何以故欲取一相。答曰。般若波罗蜜甚深微妙不以方便说则无解者。是故若分别不等则生诸烦恼三毒增长。所谓憎怨爱亲爱善。憎不善。菩萨住是二等中观一切法皆平等。住众生等中怨亲憎爱皆悉平等。开福德门闭诸恶趣住法等中。于一切法中忆想分别着心取相皆除灭。但见诸法空。空即是平等。有人得是诸法平等空直趣菩萨道。于空不戏论。有人虽得平等而生戏论。若观都空有如是失。如是人于平等即是不等。是故此中为真平等。故说般若波罗蜜等。非是戏论离平等不平等二边。是般若波罗蜜相。问曰。平等者于般若波罗蜜相已具足。何以故。更说离等是般若波罗蜜相。答曰。经中但说诸法等故般若等。行者取是平等相而生着。是故说般若波罗蜜平等相。自性离色等诸法自相离故。离义如相无相品中说。得此诸法平等。又于平等离安住空中。空中则不动。戏论不能动。诸烦恼山亦不能动。无常时亦不能动。所以者何。于一切法得实相故。菩萨住是二空。得不动般若波罗蜜。是则究竟。若有念即是有相着处。是故说诸法无念故。当知般若波罗蜜亦无念。无动相是般若波罗蜜。般若波罗蜜诸相灭故。若不念是般若。或迷闷无所趣向。有戏论者在大众中则生怖畏。或于涅槃中不了故亦生怖畏。是故说无怖畏相是般若波罗蜜。是人虽不决定取诸法相。而深入法性故。于大众中有难论诸相者。心无所畏。于诸法得无相故。又入无生法忍时。知一切法不可得。于是中亦无所畏。所以者何。是菩萨善通达一切法故。复次一切法一相所谓性空。是故般若波罗蜜随一切法故亦性空一味。问曰。上已说诸法平等。今何以更说一味。答曰。空或时有味或时无味。若行者为诸见取相分别好丑筹量。尔时。得是诸法平等空心大欢喜故名为味。如人为热渴所逼。得清冷水以为真味无比。随时用故名味。真实毕竟空则无味不味。复次一味者菩萨行般若波罗蜜时。所缘所观皆为一味。空智力大故余法皆随而为空。譬如煮石蜜欲熟时。虽异物和合皆为石蜜。又如大海百川归之皆为一味。所谓毕竟空味。色等诸法亦如是。凡夫心中各各别异。入般若波罗蜜中皆为一味。边名为相。若有若无实观色等诸法非有非无故无相。无相即是无边。观是已即是无边般若波罗蜜。复次有人言。边有二种。常边断边世间边涅槃边恶边善边等。此中无如是等诸边故名为无边般若波罗蜜。复次有人言。边名前际后际。世间无始故无前际。入无余涅槃故有前际。不复更出故无后际。如是等分别诸边。着世间故畏涅槃。是故般若波罗蜜中无是一切边。但闻诸法实相无入无出。问曰。诸法平等诸法离。皆是无边。何以复别说。答曰。有人知诸法平等。知诸法离。则不须说。若有人取相着是一味故说无边。昙无竭非但为萨陀波仑故说。萨陀波仑亦不但自为故问。但为众生有种种心种种行故。于般若波罗蜜相中略说无生无灭。如先种种因缘破生灭中说。虚空无边。如摩诃衍。虚空譬喻中说。大海水无边。须弥庄严先未说。故今当略说。问曰。虚空无为常法故无得其边者。可言无边。大海水在四天中绕须弥山有由旬数量。有人能渡。何以言无边。答曰。无边有二种。一者实无边。二者人不能到故无边。海亦有二种。一者可渡。二者绕须弥山在九宝山里。广八万二千由旬。世间人不能得边故言无边。如小海船力可渡。大海水船力不可渡。唯有神通者能度。如外道凡夫能生禅定船。度欲界色界海。无色界如大海深广。则不能渡。以不能破我心故。诸贤圣人智慧禅定翅力。破诸法邪相。得实相故能度。是故说大海譬喻。问曰。须弥山一色何以言庄严。答曰。外书说须弥山一色纯是黄金。六足阿毗昙中说须弥山四边各以一宝成金银颇梨琉璃庄严。若诸鸟随所至方各同其色。难陀婆难陀龙王兄弟以身围绕七匝。山顶有三十三天宫。其城七重名为喜见。九百九十九门。一一门边皆有十六青衣大力鬼神守护城中。高处作殿名曰最胜。四边有四大园。四天王在四边。有山名游乾陀。各高四万二千由旬。四天王治其上。四大海水诸阿修罗宫及诸龙王宫殿游乾陀等九宝山日月五星二十八宿及诸余星围绕庄严。如是等种种杂饰以为庄严。视之无厌。般若波罗蜜亦如是。六波罗蜜果报故。作转轮王梵释天王净居天王大自在天。如是等果报行般若波罗蜜未具足时。受此果报庄严。般若波罗蜜具足时。则有须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道阿毗跋致菩萨诸佛道果庄严。如须弥山上下皆有庄严。般若波罗蜜庄严亦尔。未具足时。诸天王等庄严。具足已诸道果庄严。如须弥山者劫初立时四边大风吹聚地之精味积为须弥山。更有风吹令坚而成宝。般若波罗蜜亦如是。一切善法中第一坚实牢固和合以为般若。如须弥山。四边大风吹。大海水波所不能动。般若波罗蜜亦如是。邪见外道戏论及诸魔民所不能动。如须弥山顶四园。诸天到者受种种乐。般若亦如是。行者能登般若顶到四禅等诸定园中受种种乐。复次有人言。须弥山众鸟到者皆同一色。般若波罗蜜亦如是。诸法入中皆同一相。所谓无相如虚空无分别者。虚空无分别是内是外是远是近是长是短是净是不净等。般若波罗蜜亦如是。诸法入般若中亦无内外善不善等分别。如五众无边者。五众常遍满世间。般若波罗蜜亦如是。不远离于五众。五众实相即是般若波罗蜜。复次如色等法。分析破裂乃至微尘则无方。无方故无边。无色法无形故无此彼。无此彼故无边。般若波罗蜜亦如是。于一切法分别色。乃至微尘分别无色法。乃至一念中不见决定有常乐我净。是故说色无边故般若无边。乃至虚空六种亦如是。如金钢等者如天王所执金钢无憎无爱。随所用处无不摧碎。诸佛一切智前心。此心中三昧能断一切结使烦恼颠倒。及习皆灭故名为如金钢。如金钢三昧相应智慧观一切法皆平等。般若波罗蜜观诸法平等亦如是。何以故。般若先观诸法平等。然后得是三昧。诸法无分别者。世间凡夫烦恼力故种种分别诸法。得诸法实相则皆破坏变异。是故圣人得般若波罗蜜。不随忆想分别诸法。入空无相无作三昧中。若得诸法变异时则不忧愁。以先来不分别取诸法相故。诸法性不可得者。一切法皆从因缘和合生无有无因缘。若少因缘而起者。若从因缘生则无自性。性者名本有决定实事。若性从因缘和合边生。当知未和合时则无。若先无今从因缘和合有者则知无性。若从因缘而生性者。性即是作法。性名不相待不相因。常应独有。如是有为法则无。是故言一切诸法性不可得。般若波罗蜜性亦尔。诸法无所有等故者。诸法性不可得故众因缘亦不可得。众因缘亦不可得故皆是无所有。入无所有中故则皆平等。所以者何。有故有分别。无故无分别。如草香栴檀香烧时有分别灭时无分别。诸法无作者。众生空法。空故则皆无作。众生所作者。所谓十善十不善等法。作者所谓火然水流风动。识能识智能知。如是法各各自有力。无众生乃至无知者见者。无色等乃至一切种智先已破。破众生故无作者。破法故无所作。但凡夫人颠倒覆故言我有所作。诸法不可思议者。色等一切法不得决定。若常若无常若苦若乐若实若空若我若无我若生灭若不生灭若寂灭若不寂灭若离若不离若有若无等。种种门分别亦如是。不可得思议。所以者何。是法皆从心中忆想分别生。亦不可决定。一切法实性皆过心心数法。出名字语言道。如前品说。一切诸法平等。一切贤圣不能行不能到。是故不可思议。般若波罗蜜亦尔。观是法故生。是时萨陀波仑即于坐上得诸三昧。问曰。萨陀波仑先已知诸法空相。今种种勤苦住立七岁。见昙无竭得何等利益。答曰。萨陀波仑先见诸佛得诸三昧。贵重般若波罗蜜生着相。今昙无竭七岁从定起。为说般若破其着心。一切法性自空。非般若波罗蜜令其空。是故说诸法等故般若波罗蜜等诸法离相。乃至诸法不可思议故。般若不可思议。不令轻贱余法贵重般若。何以故。不令因般若故更生垢着。般若波罗蜜虽毕竟清净多所饶益。复不可取相而生着心。如热金虽好不可手捉。萨陀波仑得是教化断般若中着心。即得诸法等诸三昧句句解说。散乱心中但有智慧不名三昧。今从师闻已一心思惟名为三昧。摄心不散智慧变成三昧。如风中灯不能照明在静室闭门明乃遍照。先已欲界心散乱故智慧力未成就。今入摄心中所闻诸法皆名三昧。能破诸烦恼等及魔人民。如水寒风未至未成为冰则无坚用若成冻冰能有所蹈。得如是等六百万三昧门。萨陀波仑得闻昙无竭所说法。得诸法中大智慧明。所谓种种诸法实相门诸法平等。平等是智慧。入萨陀波仑禅定心中变为三昧。今欲说三昧智慧。今世后世果报故。尔时佛告须菩提。如我今在大众中说般若。以是相以是像貌以是名字说般若。萨陀波仑从昙无竭得是三昧。于三昧中见十方佛。在大众中说般若亦如是。须菩提。萨陀波仑从是以后深爱乐法故多集诸经。广诵多闻如阿难佛所说皆能持。萨陀波仑亦如是。多闻智慧不可思议如大海水。即于是世常不离佛。如是等名为今世果报。舍身常生有佛国中。好修行念佛三昧故。乃至梦中初不离见佛。地狱等诸难皆已永绝。随意往生诸佛国土。以其深入般若波罗蜜集无量功德故不随业生。萨陀波仑从一佛土至一佛土。供养诸佛度脱众生。集无量功德。譬如豪贵长者。从一会至一会。乃至今在大雷音佛所净修梵行。若有欲求般若波罗蜜若。当如萨陀波仑菩萨坚正一心不可倾动。是故当知般若波罗蜜因缘故。能成就一切功德者。诸菩萨等得般若者。贪欲嗔恚等。在家罪垢邪疑戏论等。出家罪垢皆悉除灭得心清净。心清净故得一切功德成就。得一切种智者。所谓得阿耨多罗三藐三菩提。六波罗蜜者。从初地乃至七地得无生忍法。八地九地十地是深入佛智慧。得一切种智成就作佛。于一切法得自在者。皆应受持乃至华香妓乐。须菩提虽常乐空行。佛共说般若。又得无诤三昧故不应嘱累。阿难得闻持陀罗尼。又常亲近世尊故广嘱累

    大智度论释嘱累品第九十

【经】尔时佛告阿难。于汝意云何。佛是汝大师不。汝是佛弟子不。阿难言。世尊。佛是我大师。修伽陀是我大师。我是佛弟子。佛言。如是如是。我是汝大师。汝是我弟子。若如弟子所应作者汝已作竟。阿难。汝用身口意慈业供养供给。我亦常如我意无有违失。阿难。我身现在汝爱敬供养供给心常清净。我灭度后是一切爱敬供养供给事当爱敬供养般若波罗蜜。乃至第二第三以般若波罗蜜嘱累汝。阿难。汝莫忘莫失莫作最后断种人。阿难。随尔所时般若波罗蜜在世。当知尔所时。有佛在世说法。阿难。若有书般若波罗蜜受持读诵正忆念为人广说恭敬尊重赞叹华香幡盖宝衣灯烛种种供养。当知是人不离见佛不离闻法常亲近佛。佛说般若波罗蜜已。弥勒等诸菩萨摩诃萨。慧命须菩提舍利弗大目犍连摩诃迦叶富楼那弥多隶耶尼子摩诃俱絺罗摩诃迦旃延阿难等。并一切大众及一切世间诸天人犍闼婆阿修罗等。闻佛所说皆大欢喜

【论】问曰佛已断法爱。乃至一切种智涅槃不着不取相。今何以种种因缘嘱累是法似如爱着。答曰。诸佛大慈悲心从初发意已来。乃至到涅槃门常不舍离。于娑罗双树间。以金钢三昧为众生碎身如麻米。何况经法多所饶益而不嘱累。又阿难是未离欲人。未尽知般若波罗蜜力势果报多所利益。是以殷勤嘱累汝。当好受持无令忘失。是故佛虽于一切法无憎爱常寂灭相。而嘱累是般若。问曰。阿难是声闻人。何以以般若波罗蜜嘱累。而不嘱累弥勒等大菩萨。答曰。有人言。阿难常侍佛左右供给所须。得闻持陀罗尼。一闻常不失。既是佛之从弟。又多知多识名闻广普四众所依。是能随佛转法轮第三师。佛知舍利弗寿短早灭度故不嘱累。又阿难是六神通三明共解脱。五百阿罗汉师。能如是多所利益。是故嘱累。弥勒等诸大菩萨佛灭度后。各各分散至随所应度众生国土。弥勒还兜率天上。毗摩罗鞊文殊师利亦至所应度众生处。佛又以是诸菩萨深知般若波罗蜜力不须苦嘱累。阿难是声闻人随小乘法。是故佛殷勤嘱累。问曰。若尔者法华经诸余方等经。何以嘱累喜王诸菩萨等。答曰。有人言。是时佛说甚深难信之法。声闻人不在。又如佛说不可思议解脱经。五百阿罗汉虽在佛边而不闻。或时得闻而不能用。是故嘱累诸菩萨。问曰。更有何法甚深胜般若者。而以般若嘱累阿难。而余经嘱累菩萨。答曰。般若波罗蜜非秘密法。而法华等诸经说阿罗汉受决作佛。大菩萨能受持用。譬如大药师能以毒为药。复次如先说。般若有二种。一者共声闻说。二者但为十方住十地大菩萨说非九住所闻。何况新发意者。复有九地所闻乃至初地所闻。各各不同。般若波罗蜜总相是一而深浅有异。是故嘱累阿难无咎。问曰。先见阿閦佛品中嘱累。今复嘱累有何等异。答曰。菩萨道有二种。一者般若波罗蜜道。二者方便道。先嘱累者为说般若波罗蜜体竟。今以说令众生得是般若方便竟嘱累。以是故。见阿閦佛后说沤和拘舍罗品。般若波罗蜜中虽有方便。方便中虽有般若波罗蜜。而随多受名。般若与方便本体是一。以所用小异故别说。譬如金师以巧方便故以金作种种异物虽皆是金而各异名。菩萨得是般若波罗蜜实相。所谓一切法性空无所有寂灭相。即欲灭度以方便力故不取涅槃证。是时作是念。一切法性空涅槃亦空。我今于菩萨功德未具足不应取证。功德具足乃可取证。是时菩萨以方便力过二地入菩萨位。住菩萨位中知甚深微妙无文字法引导众生。是名方便。复次有方便。菩萨知一切法毕竟空性无所有。而能还起善法行六波罗蜜不随空。若能生四种事。若疑若邪见若入涅槃若作佛。以般若有如是分别。若能除邪疑不入涅槃是为方便。有人言。般若波罗蜜多所饶益。于大珍宝聚中最胜。佛知灭度后多有怨贼欲毁坏者。品品嘱累犹尚无咎。何况二处。问曰。若嘱累何以乃尔殷勤郑重。答曰。佛随世俗法引导众生。譬如估客主欲远出他国。虽以财宝嘱累于子大价妙宝偏独殷勤以其子未识妙宝价重故。余人以估客主是识宝价人而殷勤嘱累必知其贵。若闻其子赞说宝价则不信之。佛亦如是。复次若于余人异众中赞叹般若嘱累人则讥佛自称赞法。疑而不信。自于弟子中嘱累则无嫌。复有人言。佛上品中说寂灭相无戏论。是一切智是中无有决定法可取。则人以为无所可贵。今殷勤嘱累。则知佛不着空法。一切众生中爱念般若无过佛者。佛知般若恩深故。贵重是般若而殷勤嘱累。有人言。佛欲现中道故嘱累。先说诸法空以遮有边。今殷勤嘱累则破无边。是则中道。若人谓佛贪心爱着此法。佛以种种因缘说般若波罗蜜空相。若人谓佛堕断灭中。是故殷勤嘱累。如是则离二边。问曰。佛知阿难是弟子。何以故。问阿难汝是我弟子不。我是汝师不。答曰。佛有恶弟子须那刹多罗等。有少因缘故作弟子。欲于佛所取射法。佛不为说。于是反戒言。我非佛弟子。又如须尸摩。为盗法故作弟子。如是等是名字弟子。又复外道等谓。阿难不得已而在佛边。阿难曾作外道弟子。着草衣求神仙。今以佛是其亲族尊重故给侍。以如是等事故。于大众中问。阿难。汝是我弟子不。若言是真弟子当随我敕。是故阿难为欲令人信故重答。佛告阿难弟子所应作法汝尽具足。弟子法者所谓以善身口意业供给师。有弟子心好身口业不称。有弟子身口业好而心不称。若弟子以善心深爱乐师。身口相称不惜身命不难勤劳。自舍其心随师教敕。阿难尽具足此事。佛告阿难。汝今现在恭敬于我。我灭度后恭敬般若亦当如是。问曰。般若是诸佛师。而阿难何以不恭敬其师而恭敬佛。答曰。阿难虽得初道漏未尽故。不深知法实如佛所知。是故佛告阿难。汝恭敬般若如恭敬我。复次众生见佛三十二相八十随形好大光明金色身多爱敬。般若波罗蜜微妙甚深无形无色。智者能知佛身相好。愚智视之皆无厌足。是故佛以身喻般若。佛在世时能自遮魔。是故佛告阿难。我灭度后好守护般若。问曰。一嘱累则足何以至三。答曰。佛深爱般若波罗蜜故三嘱。问曰。若深爱者何限于三。答曰。诸佛常法语不过三。若过三不从。执金钢神则以杵拟之。又执金钢神意。若过三不从则是逆人便当杀之。是故佛问不过三。复次若一说犹缓。过三太急。似如凡夫贪著者。复次受者心有三种。钝根者至三乃生善心。阿难虽复利根心向声闻。但一身求度。是故三告。所以嘱累者为不令法灭故。汝当教化弟子。弟子复教余人展转相教。譬如一灯复然余灯其明转多。莫作最后断种人者。世人有子若不绍继则名断种最为可耻。佛以此喻告阿难。汝莫于汝身上令般若断绝。问曰。如先品中明般若波罗蜜说亦不增不说亦不减毕竟寂灭相。今何以言莫令断灭。譬如虚空谁能灭者。答曰。般若波罗蜜虽寂灭无生无灭相如虚空不可戏论。而文字语言书般若波罗蜜经卷为他人说。是此中般若于此因中而说其果。凡人闻般若波罗蜜微妙。即生着心取般若相分别诸法所谓是善是不善是世间。是涅槃等。以分别故于是法中生着心。着心故斗诤。斗诤故起诸罪业。如是人名为灭般若波罗蜜。佛告阿难。汝当如般若波罗蜜相。莫著文字语言教化众生。是名不灭。阿难随般若在世几时。则知尔许时佛在世。如经中广说。佛殷勤嘱累。在会众生有疑。是故佛说嘱累因缘。所谓有般若在世则为佛在。所以者何。般若波罗蜜是诸佛母。诸佛以法为师。法者即是般若波罗蜜。若师在母在不名为失利。所以者何。利本在故。是故说若般若在世佛亦在世。又法宝不离佛宝。菩萨有三十二相八十随形好不名为佛。得法宝故名为佛。法宝即是般若波罗蜜。如人从佛得利乃至得解脱涅槃。若人于般若中能信行。亦以三乘法而入涅槃。是故说般若在世如佛在世说法无异。阿难。若有人听受般若及书持等。当知是人不离见佛闻法亲近诸佛。问曰。有人重罪三不善业成就。听受书持般若。是人云何当得不离诸佛闻法亲近佛不。答曰。是事先品中已答。所谓听法者有二种人。一者但听而不信受行。二者听而信受奉行。如弟子不听不信受行师语是名不听。若以一心听闻信受奉行。厌世爱涅槃离小乘乐大乘。作如是听受。是名真听。诵读亦如是。正忆念随如佛意。离有无二边。行于中道如所闻受持。及其义解。为他人解说。恭敬尊重供养赞叹花香等。初始微薄。乃至正忆念为他人说。其心转厚功德转多。牢固不动。若闻师说若见经卷。花香等供养。若智者知般若功德。供养者福德重。不知者供养福德微薄。福德纯厚者。转身不离见佛闻法亲近诸佛。福德微薄者。不言转身得三福报。偿众罪已久后亦必当得佛。此中佛总说福德纯厚微薄渐渐皆当见十方佛闻佛所说渐渐具足六波罗蜜皆得作佛。佛以佛眼见。般若有如是大利益众生故。殷勤嘱累。问曰。是诸大阿罗汉已证实际无复忧喜。小喜尚无何况大欢喜。答曰。诸大阿罗汉虽离三界欲未得一切智慧故。于诸甚深法中犹疑不了。是摩诃般若波罗蜜中。了了解说断除其疑。是故大欢喜。复次此诸大弟子已证实际。实际者即是空无相无量无所分别。佛以此寂灭法种种分别名字语言譬喻广说亦不坏法性。又不与世间相违。诸阿罗汉是法中证故大欢喜。佛善说是空无相无量寂灭法。诸余大众未悉漏尽。信力深故。亦大欢喜言。此法能尽我等生死苦令得佛道。如是等无量因缘故大众皆欢喜。问曰。若佛嘱累阿难是般若波罗蜜。佛般涅槃后阿难共大迦叶结集三藏。此中何以不说。答曰。摩诃衍甚深难信难解难行佛在世时有诸比丘闻摩诃衍。不信不解故从坐而去。何况佛般涅槃后。以是故不说。复次三藏正有三十万偈。并为九百六十万言。摩诃衍甚多无量无限。如此中般若波罗蜜品有二万二千偈。大般若品有十万偈。诸龙王阿修罗王诸天宫中有千亿万偈等。所以者何。此诸天龙神。寿命长久识念力强故。今此世人寿命短促识念力薄。小般若波罗蜜品尚不能读。何况多者。诸余大菩萨所知般若波罗蜜无量无限。何以故。佛非但一身所说。无量世中或变化作无数身。是故所说无量。又有不可思议解脱经十万偈。诸佛本起经宝云经大云经法云经各各十万偈。法华经华手经大悲经方便经龙王问经阿修罗王问经等诸大经。无量无边如大海中宝。云何可入三藏中。小物应在大中。大物不得入小。若欲问应言。小乘何以不在摩诃衍中。摩诃衍能兼小乘法故。是故不应如汝所问。复次有人言。如摩诃迦叶将诸比丘在耆阇崛山中集三藏。佛灭度后。文殊尸利弥勒诸大菩萨。亦将阿难集是摩诃衍。又阿难知筹量众生志业大小。是故不于声闻人中说摩诃衍。说则错乱无所成办。佛法皆是一种一味。所谓苦尽解脱味。此解脱味有二种。一者但自为身。二者兼为一切众生。虽俱求一解脱门。而有自利利人之异。是故有大小乘差别。为是二种人故。佛口所说以文字语言分为二种。三藏是声闻法。摩诃衍是大乘法。复次佛在世时无有三藏名。但有持修多罗比丘持毗尼比丘持摩多罗迦比丘。修多罗者是四阿鋡中经名。摩诃衍中经名修多罗有二分。一者四阿含中修多罗。二者摩诃衍经名为大修多罗。入二分。亦大乘亦小乘。二百五十戒如是等名为修多罗。毗尼名比丘作罪。佛结戒应行是不应行。是作是事得是罪。略说有八十部。亦有二分。一者摩偷罗国毗尼含阿波陀那本生有八十部。二者罽宾国毗泥除却本生阿波陀那。但取要用作十部。有八十部毗婆沙解释。是故知摩诃般若波罗蜜经等在修多罗经中。以经大事异故别说。是故不在集三藏中

究摩罗耆婆法师。以秦弘始三年岁在辛丑十二月二十日至长安。四年夏于逍遥园中西门阁上。为姚天王出此释论。七年十二月二十七日乃讫。其中兼出经本禅经戒律百论禅法要解。向五十万言。并此释论一百五十万言。论初品三十四卷。解释一品是全论具本。二品已下法师略之。取其足以开释文意而已。不复备其广释。得此百卷。若尽出之。将十倍于此

大智度论卷第一百


能断金刚般若波罗蜜多经论释

    No. 1513 [No. 1511, cf. Nos. 1514, 1512]

能断金刚般若波罗蜜多经论释卷上

        无著菩萨造颂　世亲菩萨释

        三藏法师义净奉　制译

  此经文句义次第　　世无明慧不能解
  稽首于此教我等　　无边功德所生身
  具如斯德应礼敬　　彼之足迹顶戴持
  觉辕难驾彼能乘　　要心普利诸含识

经云。能以最胜利益者。此据成熟菩萨。能以最胜付嘱者。此据未成熟菩萨。云何于诸菩萨最胜利益。复何者是最胜付嘱。为答此问颂曰

  胜利益应知　　于身并属者
  得未得不退　　谓最胜付嘱

谓于菩萨身中为其利益。亦能令彼菩萨益其所有相属伴类。名最胜利益。于彼身中令其佛法成熟摄聚故。即是利益彼身。亦令化余有情所有堪能。皆成就故。是于属者能为利益。如是应知。于得未得所有功德。能为彼作不退之因。由于善友而亲委寄。是名以胜付嘱而相付嘱。此中得而不退者。欲令不舍大乘。未得不退者。令于大乘更趣殊胜。诸有发趣菩萨乘者。应云何住。为答此问。颂曰

  于心广最胜　　至极无颠倒
  利益意乐处　　此乘功德满

此明何义。若菩萨作此四种利益意乐。始是发心住。于大乘具此意乐。方可名为功德圆满。云何为四。利益意乐。一广大。二最胜。三至极。四无颠倒。经云诸有发趣菩萨乘者。当生如是心。广说乃至如是一切。此明广大利益意乐。我皆令入无余涅槃而灭度之者。此明最胜利益意乐。虽度如是无量众生。乃至不名菩萨。此明至极利益意乐。此何意耶。欲明所有一切众生悉皆摄同菩萨。己身由斯但是寂灭。己身无别有情也。若作别有众生。不为己想者。此即不名菩萨。若摄为己体。即是至极不舍。是故名为至极意乐。若菩萨有我想众生想寿者想。更求趣想者。则不名菩萨。此明无颠倒利益意乐。此即由依有身见故我等想生。为令正断是不颠倒。次下当显诸有发趣菩萨乘者。应如是修行。经云。菩萨不住于事应行布施。如是广说。此中何意。以一施声而总收尽六到彼岸耶。答曰

  六度皆名施　　由财无畏法
  此中一二三　　名修行不住

为明此六咸有施相。此之施性由财无畏法。财施由一谓是初施无畏。由二谓是戒忍。于无怨仇(戒也)及怨仇处(忍也)不为怖惧故。法施由三谓是勤等。由其亡倦(勤也)了彼情已(定也)宣如实法(慧也)此是大菩萨修行之处。即是以一施声。收尽六度。经云菩萨不住于事应行布施如是等者。此中何谓不住性耶。颂曰

  为自身报恩　　果报皆不着

言不住于事者。此显不着自身。不住随处。应行布施者。此显不着报恩于利养恭敬等。求恩望益之处事有多途故。云不应随处生着而行布施。不住于色等者。谓不着果报。问何须如是行不住施耶。颂曰

  为离于不起　　及离为余行

由顾自身不行其施为欲离其不起心故。莫着自身速应行施。由望恩心及悕果故遂舍正觉菩提果性。为于余事而行惠施。是故当舍求余行施。次下当说摄伏心。其事云何

  摄伏在三轮　　于相心除遣
  后后诸疑惑　　随生皆悉除

经云。菩萨如是应行布施。乃至相想亦不应着。此显所舍之物。及所施众生并能施者。于此三处除着想心。次明布施利益。或有难云。既于施等离其相状。如何当获福德利益。为答此故。说生福甚多。问何故宣说于修行后不彰福利于摄伏下方始言之。答为显若人不着相想。方能行彼不着施也。从此已后所有经文。皆为除遣后后疑惑。于此便有如是疑生。问若不着于法而行施者。如何为求正觉胜果行惠施耶。为答此疑。经云于汝意云何。可以胜相观如来不。如是广说。颂曰

  若将为集造　　妙相非胜相
  三相迁异故　　无此谓如来

若谓如来是由施等因缘所造。于有为相中得最胜性者。便见如来有其胜相。若望如来真如之性。即无此胜相。是故不应以胜妙相观于如来。由彼法身是非集造之所显故。次云。何以故。如来说彼胜相三相迁异故。由此胜相即非胜相。此中意说三相之体。是迁流故。妙生所有胜相皆是虚妄。是故应以胜相非相观于如来。此意欲明从因生法是虚假故无。此谓如来由彼全无三种相故。由离此相即以无相为相。若于是处无生住灭变异之性可了知者。此显如来不是有为造作之性因缘所成。如是明解如来性已。虽为佛果而行布施非着法施。即是除去疑情。次下妙生重生疑念。若由如是行无住施者。即因极甚深。复说如来是无为性。即是果极甚深。如何末代得有信者。令彼果报不虚弃耶。为断此疑。颂曰

  因与果甚深　　于彼恶时说
  此非无利益　　由三菩萨殊

纵于末代而有菩萨具戒具德具慧。由此说法果利不虚颂曰

  由于先佛所　　奉持于戒学
  并植善根故　　名具戒具德

经云。然彼菩萨非于一佛而行恭事。非于一佛植诸善根。此显于先佛所为持戒故。而行恭敬承事。及为种诸善根。如其次第即是具戒具德次明具慧人。颂曰

  能断于我想　　及以法想故
  此名为具慧　　二四殊成八

此明我想有四。法想亦四。故成八想。颂曰

  别体相续起　　至寿尽而住
  更求于余趣　　我想有四种

我想四者。谓是我想有情想寿者想更求趣想。四种不同。此于别别五蕴有情自生。断割为我想故。见相续起作有情想。(萨埵是相续义)乃至寿存作寿者想。命根既谢转求后有。作更求趣想。法想四者。颂曰

  皆无故非有　　有故不可说
  是言说因故　　法想有四种

法想四者。一法想。二无法想。三想。四无想。此谓能取所取诸法皆无故。法想不生。即无法想。彼之非有法无自性。空性有故非无法想。即彼非有有非有性。非言所诠故非是想。是言说因故非是无想。由想力故。虽非言显而以言说故。有八义不同。由我及法八想断故。名具慧人。何意此义。但于具慧而说。非具戒具德者何。答为显实想有差异故何者是。颂曰

  由彼信解力　　信故生实想
  不如言取故　　取为正说故

由此义故说。彼之后而云是人乃能闻此经典生一信心。由具慧者不如言而取。及由随顺胜义智故。取为正说故。名为实想。为斯理故说彼之后便云不应取为法。不应取为非法。不应如言所说将以为法。亦复不即执为非法。由此是能随顺胜义智。取为正说故。即是经云闻说是经生实信不。经云妙生如来悉已知见是人等者。为显何义。颂曰

  佛了果非比　　由愿智故知

彼具戒等人所有果报。佛非比知。然由愿智现量而了。若不言见或谓比知。若不言知恐是肉眼等见。是故知见并言。何故世尊作如是语。颂曰

  为求利敬者　　遮其自说故

彼具戒等。为求利养恭敬。自说己德便生念曰。如来既遥鉴我。为此无宜自说

经云。妙生彼诸有情当生当摄无量福聚者。此目何义。谓是令其福聚当生。又是彼福当能相续熏习不断。言有我执等者。意说有随眠性非有现行执

经云。是故如来密意宣说筏喻法门。诸有智者法尚应舍。何况非法。此中有何密意。颂曰

  证不住于法　　为是随顺故
  犹如舍其筏　　是密意应知

谓于经等法非增上证所住处故。即得证已应舍彼法。如到彼岸舍弃其筏。于增上证是随顺故。应须收取。如未达岸必凭其筏。是名密意。一筏之上有其取舍故名为密。若是自余非顺证法理须舍故。次后更为除疑。何者是上。文云不应以胜相观于如来。彼从无为所显性故。若如是者。复如何说。释迦牟尼如来证于无上正等菩提。乃能宣扬所有法教。由斯道理彼非正觉亦不说法。答此疑故。颂曰

  化体非真佛　　亦非说法者

由有三佛。一法身佛。二受用身佛。三化身佛。言释迦牟尼佛者。即是化身。此乃元非证觉。亦不说法度生。文云。何以故。佛所说法等者。为遮总拨一切说法之事故。云化体非真佛亦非说法者。然非总无。颂曰

  说法非二取　　所说离言诠

如是二种。谓法性非法性。非耳能听非言能说。是故应知。非法非非法。此据真如道理而说。彼非是法。谓是法无为其性故。复非非法。由彼无自性体是有故。何故但言所说之法。不言能证之人。答但言所说能证义显。由非不觉得有所说

经云以诸圣者皆从无为之所显故者。为明说此法因。由诸圣人并从真如清净之法所显现。故名无为所显是故彼还说无为法。凡所有事言不能宣者。此即岂能取也。彼之自性非是言说所行处故。明此即是非言说性。何故此中无有简别。总说圣者不唯言佛。答为明圣人皆从真如清净所显。由有全净一分净故。随其所应故无有过。又说福差殊欲何所显。答法虽实是不可取性及不可说。然而有益。颂曰

  自受为他说　　非无益集福

何故经云。世尊此福聚者则非是聚。是故如来说为福聚福聚。颂曰

  福不持菩提　　彼二能持故

言福于菩提不能持负故。二于菩提是能持故。颂意如是何谓为二。谓自受为他说。经云既自受已。于他演说。未了此言将述何义。由其聚声(梵云塞建陀有其多义或是聚义或是肩义或是分段义若依此方译之为聚但得积聚义遂无余义此中且据二种此为昔人不解梵音又译之为趣深成辽落又复须知此聚义肩义解时极难也)有二种义。一是聚积义。二是肩荷义。犹如在肩能持于担。为此名肩为聚。由斯理故。彼福积聚说为福聚。由其不能持荷菩提说为非聚。即非肩义是积聚义。此二是菩提因福乃甚多。问何故此二能持菩提。为显斯义故。经云何以故妙生由诸如来无上菩提从此经出等。何故菩提言出。诸佛言生。颂曰

  得自性因故　　此余者是生

言菩提者即是法身。此是无为性故。名为自性。是故此二是得彼之因。非是生因。若望此余受用化身。是生因故。由此亲能持菩提故。生福甚多。为显此义。经云何以故等。何故此是能成立因。颂曰

  唯是佛法故　　能成最胜福

言如来说为非佛法者。此显所觉之法唯佛能证由不共性。是故最胜。此是最胜福因性故。招福极多。意明此是能成胜福之亲因。上经云。圣人皆是非集造之所显示。为此诸圣于彼证法不可取不可说者。诸预流等圣人。并悉取其自果。如何此成非所取性。于其所取而宣说者。非不可说性。为遣疑故生起后文。即彰非所取所证理善成就。颂曰

  不取自果故　　非可取可说

由是无为所显性故。彼于六境无有少法可得。既无可预名为预流。乃至阿罗汉亦无有法理皆同此无为之法体。无可取为此圣人。于自果不取不说。若圣人作如是念。我得果者即是有其我等执者。意说有随眠惑非是现行。由非彼证现观之时。有我等执而云我得。何意妙生自说得阿罗汉。为令一分有情知已亲证故。又复自说得无诤住者。为显身与胜德相应。为欲令他生胜敬信故。为何意趣而云。妙生都无所住。而说我得无诤住得无诤住。颂曰

  解脱二障故　　说妙生无诤

障有二种。一是烦恼障。二是定障。于斯脱故不住二障。为此再言。此言二无诤性即是诤之非有。次复起疑言。世尊昔于然灯佛所有法可取。彼亦为他说其法要。以此而言如何得成无取无说。为答斯难故。云实无有法是如来所取。此有何意。颂曰

  在然灯佛所　　言不取证法

此言世尊在然灯佛所。亦不以言取其证法。颂曰

  由斯证法成　　非所取所说

若言诸圣皆是无为所显。彼法不是所取。亦非所说者。如何诸菩萨取严胜佛国土耶。又受用身如何自己取为法王。世间于彼将为法王。为遣疑故方生下文此中意者。颂曰

  智流唯识性　　国土非所执

由彼实无佛土严胜是可取事。除从诸佛净智所流唯识所现。此即不能有所执取。若言实有形质是可取性。我当成就国土严胜者。斯诚妄语。如来说彼不是严胜。由此说为国土严胜。此有何意。颂曰

  无形故胜故　　非严许严性

言庄严者此有二义。一是形相。二是胜相。此最胜者。是第一义。此由无形质故。佛土庄严非是庄严。以彼不是真庄严故。是故说此以为最胜。胜法集此故名最胜。若执有佛土形胜庄严。云我当成就彼。即便于色等境界有住着心。为遮此见故有不住文生所云受用身佛如何自己取为法王。他亦尔者为答此难故。将受用身同妙高山。此文欲显何义。颂曰

  譬如妙高山　　于受用无取

如妙高山王。获得胜大尊主性故。名为妙高。而不自取为山王性。以山无分别性故。受用身佛亦复如是。具法王性由获胜大尊主性故。名为胜大。而不自取其法王性。我是法王以无分别故。如何得是无分别耶。为显斯义。文云如来说为非身。由彼非有说名有身。此有何意。颂曰

  非有漏性故　　亦非是因造

然受用身非有漏性故。由此非有说为有身。皎然纯净自体有故。亦非是因造。由此有身非是仗他因缘生故。何故于先显福德性已说其喻。今何更说。颂曰

  为显多差别　　及以成殊胜
  前后福不同　　更陈其喻说

前明三千世界喻显福多。今说无数三千彰其更广。何故于前不言斯喻。为受化者所乐不同。先少后多意在于此。前福差别不明成立之因。为于菩提无有荷持之用。今欲显其能立因相。更将别喻随事而言

能断金刚般若波罗蜜多经论释卷上能断金刚般若波罗蜜多经论释卷中

        无著菩萨造颂　世亲菩萨释

        三藏法师义净奉　诏译

何谓能立因相

  两成尊重故　　由等流殊胜
  烦恼因性故　　由劣亦胜故

言两成尊重者。由所托处成制底塔故。谓是说法之地。其所依身成如大师尊重性故。即是持经之人施宝之地。及能施者无如是事故。次下经文显此法门。乃是诸佛亲所证会等流之性。颇曾有法是如来说不者。此明何意。言无有法是如来独说。皆是诸佛共宣扬故

又此施珍宝福是苦恼事生起之因。法门功德乃是烦惑断除之要。优劣悬隔。是故下文将地尘为喻。如来说作非尘。由此说为地尘。所言世界如来说为非界。由此说为世界者。此有何意。言此地尘不是染等性尘。是故名作地尘。又彼世界非是烦恼之因名界。为此说为世界。界是因义。即是世之因也。斯言意显彼福乃是烦惑尘坌之因由其外尘。虽是无记彼福纵善方之极卑。况并成佛福因。而不更为微劣。又彼能成大丈夫相所有福业。媲此成菩提因。持说法门之福亦为是劣。由彼众相非是正觉之体性故。为此名为大丈夫相。是彼标相故。由持说福能得大觉性。为此名劣。亦胜过施宝之福。况法身因而不超越。是故劣亦胜也。即是宝福极卑为能成立因。此既成立施宝之福与此福因有差别已。次下诸文更复成立。欲何所明。颂曰

  彼果胜苦故　　难逢胜事故
  境岸非知故　　于余不共故
  是甚深性故　　胜余略诠故
  胄族高胜故　　望福福殊胜

此述何义。答施宝之福获得自身所受用果。彼身是胜。以能舍彼无边之身。此福胜前。由彼自身是苦性故。何况为彼而行其施

尔时具寿妙生。了彼自身是苦事故。由法势力遂便堕泪。此之法门复是难逢。妙生自从生智已来。亦未曾闻。复是胜事。此言欲显般若之名。此下意欲成立是胜妙事。即经云如来说为般若波罗蜜多者。彼即非波罗蜜多。为何意趣作如是说。答境岸非知故。由其所知境岸除佛于余无能知者。复是于余不共故。此之法门所有实想。即实想者。除佛教已余处无故。言实想者唯此处有。言非实者是于余不生义。是故文云若能生如是想者。彼当成就第一希有。又此法门亦是甚深。由于此经或少受或遍持。于我等想不复生起。于我等想不生故者。明于所取义无有颠倒。于我等想即是非想者。明于能取无有颠倒。此二如其次第明我法二无性智。佛于此义随印妙生所说之事。言不惊不怖不畏者。此三皆名为惧。即是惊惧怖惧畏惧。然随事不同。故有三别。言惊者谓于非处生惧(若正译梵音应云越怖今言惊等者此为不能移旧若准论释惊义未甚相当下二准此应可思之也)违越正理如越正道可厌恶故。言怖者。(应云续怖)相续生惧怖。既生已不能除断故。言畏者。(应云定怖)生决定心一向畏惧。此等若无便成心离惶惑(若不见本音本意于文即未闲释义为此注出本音斯乃可亡疑惑余家释别义非此论)又此法门胜余略诠故者。由经说此是最胜波罗蜜多如来所说。(经是略诠)又此法门族胄高胜故。言胜族者。谓由诸佛所共说故。然彼宝施无有如斯众德圆备。即是成立此福望前福聚升况理别也。所云于身是其苦性。彼施即是苦果性故。其福卑劣者。然此法门若有持说。彼之大士行诸苦行。此亦岂非是招苦报。如何不是得苦果耶。为除此难故有下文。欲显何义。颂曰

  彼行堪忍时　　虽苦行善故
  彼德难量故　　由斯名胜事
  由无恚怒情　　不名为苦性
  有安乐大悲　　行时非苦果

此述何义。答纵令彼人行苦行时有苦恼果。然于彼时由有堪忍性故。此名胜事。有其二因。一是善性故。由诸波罗蜜多皆以善为体性故。二是彼德难量故。如经云此即是其非波罗蜜多。由彼德岸曾无知者。为此名为不知其岸。由与胜法相应故。即此难行之苦。望前苦恼自有殊别。何况我想嗔想悉皆无故。必无其苦。非但无苦更生悲乐。如经云我无是想亦非无想。言非无想者。此显有想与悲心相应。准斯语理。若诸有情于我想等不除遣者。苦行之时见有苦恼。即便欲舍菩提之心。是故应离诸想。乃至广说。此何所显。若人不发胜菩提心。便有如斯过失生嗔恨心。颂曰

  生心因不舍　　是故应坚求

问于何处心是此心生因。而遣坚固勤求。复于何处是不舍菩提心因令进求也。颂曰

  谓是得忍边　　及此心方便

此谓入初地胜义之心。得忍边际行。无住心即是。文云应离诸想发起无上正等觉心。何以故者。此谓显其无住着心生起之因。若于色等处有住着心者。此必不能进求佛果故。诸菩萨应无所住而行布施者。文意欲明施摄六到彼岸。即是生起无住着心方便。谓得忍已。虽复遭苦而不弃舍大菩提心。问如何起行为利有情。复遣不住利有情事。此则取舍同。问疑情遂发。答曰。菩萨如是应行布施为利诸众生等。此显何意。颂曰

  应知正行者　　是利生因故
  于有情事相　　应知遍除遣

此述何义。言此正行者。是利益众生因。应知即是利益有情。而不取有情所有相貌。何谓有情相貌事耶。颂曰

  彼事谓名聚

彼众生者。即是名字施设。唤为众生及所依事。何者是其正行。谓于众生事相皆除遣故。由彼名字想者即是非想。以彼自体本非有故。即彼众生不是众生。谓于五蕴名为众生。由彼众生自体无故。此我法无性。何以故。由佛世尊并除诸想。此明我法二想皆无。如何能成最胜妙事。颂曰

  最胜除其想　　诸世尊无此
  由真见相应

此述何义。由非彼二是实有性。而诸大师强除彼想。然诸如来与真见相应故。果不住因位。如何得见彼果之因。既有此疑。答如经云妙生如来是实语者。有其四句。颂曰

  果不住因位　　是得彼果因
  世尊实语故　　应知有四种

此实语性有其四种。何谓为四。颂曰

  立要说下乘　　及说大乘义
  由诸授记事　　皆无有差舛

由佛自立要期。元求佛果无有妄谬。于下劣乘及以大乘并诸授记。并无谬故。于此随其次第。实语如语不诳语不异语。而相配属。言如来者。由于声闻乘说苦等四谛。是实不虚。于其大乘说法无性。所显真如称实知故。如来是知义。于一切时过去未来现在。所有授记如其事故。皆无妄谬故曰如来。经云如来所证法及所说法。此即非实非妄者。此有何意。答曰

  不得彼顺故　　是非实非妄
  如言而执者　　对彼故宣说

言诸如来所有说法。此说不得彼故。而是随顺于彼。由彼说法不能亲获内证法故。于其言下无有体故。故非是实。由顺彼故。故非是妄言。我现证无上觉者。此据文句道理而有此说。问何故世尊自立要言。我是真实语者。而所说法非实非虚。一说两兼理成难信。由此答云。如言而执者。对彼故宣说。言诸圣人是无为所显者。然真如性常时遍有。如何佛果以无住心方能证得。非有住心。又复如何常时遍有实体真如。或有得者或不得者。为除此疑。说入闇喻。此明何义。颂曰

  常时诸处有　　于真性不获
  由无知有住　　智无住得真

此中意道真如之性。虽是常时遍有。由其无智有住心故。即不能得。是不清净义。由其有智无住心故。即便得见是清净义。然佛世尊是真如所显。由斯理故。以有住心不能证得。由此颂曰

  无智由如闇　　当闇智若明
  能对及所治　　得失现前故

犹如闇者。是与闇相似义。由斯以闇比其无识。以其日光譬同有智有眼。如文具述。故云能对及所治得失现前故。随其所应由其有眼者显得能对。夜分晓已显破所治冥闇谢故。日明既出者。显能对现前。日光既照见众色像。次后之文欲说何事。颂曰

  由如是正行　　获如是福量
  于法正行者　　业用今当说

由如是正行者。此明文正行。颂曰

  于文有三种　　受持读演说

文有三者。一受持。二读诵。三演说。言受持者。谓持法人。读诵者依多闻说。虽不能持由能读故亦多闻摄。义正行者。谓是周遍得其义故。颂曰

  义得由从他　　及己闻思故

义之得因从他及己。何谓从他。云何由己。为闻思故。如其次第从他及己而得者。据遍得义。此谓文义正行。颂曰

  此谓熟内己　　余成他有情
  由事时大性　　望福福殊胜

此受持等。但为成熟内己。余成他有情。即是于他广为正说。获如是福量者。显其福量差别。由事时大性望福福殊胜。此舍身福望前舍身福。由事大故有其差别。及由时大。由一日中尚以极多自身而行布施。复经多时于法正行者。业用今当说。何谓彼行业用耶。颂曰

  非境性独性　　能依是大人
  及难可得闻　　无上因增长
  若但持正法　　所依处成器
  蠲除诸业障　　速获智通性
  世妙事圆满　　异熟极尊贵
  于此法修行　　应知获斯业

经云不可思者。此显不是凡情。比度所行境界。言不可称者。此显独性所获之福。于声闻等是不共性故。言为益发趣极上最胜乘有情故说者。显此法门是大人所依大乘教。名极上乘大乘行。名最胜乘。乐下劣者不欲闻故。此显难闻性。听者难得故。由能成就不可思量等福聚故。此显增长无上之因。福种增长故。此中文云不可思不可称者。谓以非量非度。如次应知。当知是人则为以肩荷负等者。此即显其能持法者。由彼持法即是持菩提也。所在之处香花供养者。此显所依之处成胜妙器。由被轻辱故。所有应生恶趣之业。皆当消尽故。此显净除业障。言此为善事者。谓遭轻辱时。显被辱之人有福德性故。言此为善事。(自古翻译皆无此语由梵本中字隐密故)于然灯佛先供事诸佛。所得之福比于末代。于此法门能受持等。获多福故。此显得成智通性。多福资粮悉圆满故。乃至当知。是经不可思议。此显果报不可思也。即是世妙事圆满。果报极尊贵。谓于护世帝释婆罗门等所有圆满皆当摄取。言狂乱者。应知此是狂心因。言不可思果报者。此之多性胜性二种。皆非凡情所测。斯谓于法正行。便能安住如是众德。是故名此为正行业果报功用。又复如前三种问答。此中重问。义有何殊。答曰

  由自身行时　　将己为菩萨
  说名为心障　　违于无住心

妙生实无有法可名菩萨者。若无菩萨。云何如来于然灯佛所。行菩萨行耶。答此疑曰。实无有法如来于然灯佛所如是等。此显何义。颂曰

  授后时记故　　然灯行非胜
  菩提彼行同　　非实由因造

此中意言。我昔于然灯佛所。非是胜上行菩萨行。而我昔行时实无有法可于彼边证得正觉。若证觉者即不记我后时成佛。此中意者。言彼行时自云我当成佛。若言菩提非有者。佛亦是无。即总拨无。佛为除此难。文云妙生。言如来者。即是实性真如异名。谓无颠倒义。名为实性。无改变义是曰真如。妙生若有说云如来证得无上正等觉者。是为妄语者。此显何义。答曰。菩提彼行同非实由因造。由昔菩萨修行之时实无可行。诸佛亦尔。无法可证正等菩提。此还总拨实无无上正等菩提。答斯难曰。妙生如来所有正觉之法。此即非实非妄者。此有何意。然真如理是佛所证。彼即非实由从因生。诸有为相是聚相义。彼即无其色等相故。颂曰

  无彼相为相　　故显非是妄
  由法是佛法　　皆非有为相

谓此无彼色声等相。色等相无是其自相。由此故云无彼相为相故。显非是妄。是故如来说。一切法即是佛法。此显何义。由如来证此法故。由法是佛法皆非有为相者。此显以无为体此何所陈。由一切法。以真如为自性。此乃但是佛所觉悟。是故一切法。名为佛法。由此色等不能持其自体相故。所有彼诸色声等法。皆不是法。由不是法。是故此成其法。即是毕竟能持非有之相。丈夫之喻何所显耶。颂曰

  谓以法身佛　　应知喻丈夫
  无障圆具身　　是遍满性故
  及得体大故　　亦名为大身
  非有身是有　　说彼作非身

烦恼所知二障无故。名圆具身。言遍满者是遍行义。遍诸处故名为具身。及得体大故。亦名为大身。此遍行者。应知即是真如之性。在诸法中无有异性故。云非有身。是有说彼作非身如来说为非身。由此名为具身。大身者。斯何所陈。以非有为身故。名彼为非身。即真如性故。由其无身故。是故名此为具身大身。若言无有菩萨者。正觉亦无。所觉亦无。亦无众生令入涅槃。亦不严净诸佛国土。有何所为。诸菩萨等。令诸众生入于圆寂。又复作意净佛土耶。为答斯难故有下文。此显何义。颂曰

  不了于法界　　作度有情心
  及清净土田　　此名为诳妄

若言此心是其诳妄。为此不名菩萨者。若尔由何得名。答妙生若有信解一切法无性。一切法无性者。如是等此文欲显何义。答曰

  于菩萨众生　　诸法无自性
  若解虽非圣　　名圣慧应知

此明何义。言法无性。法无性者。此据众生及菩萨所有之法。于彼若能信解。或世出世。谓是异生及圣。皆名菩萨。由此便成决定。许有覆俗胜义二种菩萨。此即显其顺彼。再说菩萨菩萨。经文前云。如来是无得所显者义成明白。若如是者。岂彼圣人全无所见。为答斯难许有五眼。为显其义。颂曰

  虽不见诸法　　此非无有眼
  佛能具五种　　由境虚妄故

此乃如何不是妄耶。为答此难先为喻已。彼诸众生种种性其心流转。我悉知之。如是广说。此显何义。言彼非是妄见。由境虚妄故。何者是虚妄境。谓种种妄识。颂曰

  种种心流转　　离于念处故
  彼无持常转　　故说为虚妄

即是种种识有六识殊故。复是其妄。何因名识为心流转。经云如来说为无陀罗者。此显离于念处性故。由彼念处是此持处。彼若无者。即是无持。陀罗喃阿罗痾陀罗。此之三名。共目二义。皆得名持。亦有流注义。由无持故心即流散。言无持者。为显常转之缘。既无持故显其常转。是虚妄性(问何故本经初留梵语陀罗。不译为汉字者。有何意趣。答梵本三处皆是陀罗。而义有差别。今时译者若也全为梵字。即响滞于东土。如其总作唐音。顿理乖于西域。是故初题梵字。可谓义诠流转所由。于内道持。便是正述执持之事。作斯译者。方称颂本无著菩萨之意。符释者世亲菩萨之情。如其不作斯传。定贻伤手之患。若总译为流。持理便成不现。咸为持字。流义固乃全无。作此双兼。方为惬当。若译为流。于理亦得。然含多义。不及陀罗。一处既尔。余皆类知。诸存梵本者咸有异意。此波若已经四译五译。寻者当须善观。不是好异。重译意存鞠理。西国声明。自有一名目多事。一事有多名。为此陀罗一言。遂含众义。有流有持。理应体方俗之殊致。不得恃昔而胶柱。若勘旧译全成疏漏。无暇言其藏否)何以故者。由有过去等心不可得言故。所云过去未来心者。由是过去未来性故。是不可得。其现在者即是遍计所执。自性非有故。此显流转之心。是妄识性所缘。无有三世性故。复有何意说福聚喻耶。答曰

  应知是智持　　福乃非虚妄
  显此福因故　　重陈其喻说

此述何义。心既流转是诳妄性故。所有福聚亦并成虚。此既是妄何成于善。既有深疑理须明决。答流转之心可是其妄。所言福聚体不是虚。由是正觉智之持故。如何显此是其持性。如云妙生若此福聚者。如来即不说为福聚。此何意趣。由五取蕴体是虚妄。若此福聚是取蕴者。如来即不说此福聚为福聚性。是不说为智之持处义。若言如来是非集造所显。如何如来说有诸好及众相耶。为除此难故云。不应色身圆满及相具足观于如来。言色身者。是堕好义故

能断金刚般若波罗蜜多经论释卷中能断金刚般若波罗蜜多经论释卷下

        无著菩萨造颂　世亲菩萨释

        三藏法师义净奉　诏译

如来说彼为具相者。此非具相。由此说为具相。此有何意。颂曰

  谓于真法身　　无随好圆满
  亦非是具相　　非身性应知
  于法身无别　　非如来无二
  重言其具相　　由二体皆无

言法身实不圆满随好色身。应知亦不具足众相。彼无身性故。是谓法身无具相义。亦非如来无斯二种。所谓色身圆满及以具相。由斯二种不离法身。是故如来有其相好。为此重言。色身圆满及以具相。由二皆无故。是故此二亦说为无。言此非圆满此亦非具相。亦说为有。以说色身圆满及具相言故。斯有何意。由其法身无此相好。是故名此为如来。色身圆满及以具相。由与彼身不相离故。法身之性即不如是。然法身非彼自性故。若言不应以色身圆满及具相身观如来者。如何如来有所说法耶。为答斯难。此即以其恶取而谤于我。由不能解我所说义故。颂曰

  如来说亦无　　说二是所执

何意重言。说法说法者。颂云说二是所执。云何为二。一乃是文。二便是义。由何所以。文云无法可说是名说法耶。答曰

  由不离法界　　说亦无自性

由不离法界外有说法自性可得。若言无有世尊是能说者。所说之法亦复不离法身。故成非有。如是甚深之法。如何当有敬信之人。为除此难。答曰

  能说所说虽甚深　　然亦非无敬信者

经云。妙生彼非众生非非众生者。此有何意。颂曰

  由非众生非非生　　非圣圣性相应故

诸有当能生敬信者。彼非众生。由余众生不与圣性相应。即与凡夫性相应故。非非众生者。由与圣性相应故。此中义者。由彼望其凡夫性故。不是众生。由望圣人性故。非非众生。何以故。众生众生者。如来说彼为非众生。此据愚小异生性。由此说为众生者。此据圣人性。若言如来曾无有法。是所觉知者。云何离其后后正知次第。而名无上正等觉耶。为答此难。非是有法可觉方名无上正觉。然由颂曰

  少法无有故　　无上觉应知
  由法界不增　　清净平等性
  及方便无上

于此乃至无有少法能过故名无上。又复法界无有增故。其法平等故。名无上上。上性无故。又复如来法身清净平等故。其法无不齐等。无有少增故名无上。又复其法是无我自相。此即高。高性无故名无上。又复于诸方便亦是无上。所有善法皆圆满故。名为无上。此余菩提于诸善法不圆满故。即此方便实为有上。此乃如来说为非法。由此说为善法者。此有何意。颂曰

  由漏性非法　　是故非善法
  由此名为善

由有漏性彼不是持有漏之相。不能持故。由此说为善法。由无漏性决定能持是善性故。若要以善法获大菩提者。所有说法亦应不获菩提。是无记性故。为遮此难更言差别之福答所说法。纵令无记终有所得。颂曰

  说法虽无记　　非不得应知

由非离此能得菩提故。知籍斯菩提方契。颂曰

  由斯一法宝　　胜彼宝无量

故此宣说法宝。望前无数妙高无边之宝。显福差别。假为第百分亦不能及一者。乃至广说。将显何义。颂曰

  于诸算势类　　因亦有差殊
  寻思于世间　　喻所不能及

此言何义。谓以此福望前福聚。谓是算势类。因四种差别。于此世间遍寻思已。无有其喻能比况者。言由算差别者。始从假为第百分。乃至或为算分不显差殊。但言算者。此即应知总摄。其余所有算数。或为势分者。由其势力有差殊故。如强弱人事不相并。或为比数者。由品类别。言此福类元不比数前之福类。如贵贱人不相比数。因者明其因。果亦不相干涉故。言彼亦不可与此为因(邬波尼杀昙译为因字如芥子种将比松柏)于此世间竟无其喻可况于福。由斯前福望于此福。实为减少皆不足言。故云乃至譬喻亦不能及。若言彼法性相平等故。无不平者即无能度所度。云何如来说脱有情耶。为除此难故起后文。将显何义。颂曰

  法界平等故　　佛不度众生
  于诸名共聚　　不在法界外

凡名有情者。于彼蕴处由名共蕴。不在法界之外。即此法界其性平等。是故曾无有一众生可是如来之所度脱。此即如何当有我执者。此有何意。若言但唯脱其五蕴而已。此即是有所许众生。由如是故。颂曰

  若起于法执　　与我执过同
  定执脱有情　　是无执妄执

如云妙生言我执者如来说为非执。妄执如来说为非生者。是不能生圣法之义。若言不应以其具相观于如来。非彼自性故。由是法身自性故。然彼如来自性法身。可以具相而比知之。有作斯难。为除疑意生起后文。将显何义。颂曰

  不应以色体　　准如来法身
  勿彼转轮王　　与如来齐等

此则报相之福。亦名具相。由彼成此故。藉其福力得菩提故。有作是说。此则如来以其具相。现证无上正觉。为除此意。不应以具相如是等。将显何义。颂曰

  即具相果报　　圆满福不许
  能招于法身　　由方便异性

由真法身是智自性故。与彼福体性不同。此二伽他要显何义。颂曰

  若以色见我　　以音声求我
  彼人起邪勤　　不能当见我
  应观佛法性　　即导师法身
  法性识难知　　故彼不能了

此二颂中。所说之义。颂曰

  唯见色闻声　　是人不知佛
  此真如法身　　非是识境故

此文意显不应以色声二种观于如来。由是异生不能见者。此何为也。彼人起邪勤。言彼异生妄起邪勤。不依正道求见于我。此云法性者即是真如。若言福不证菩提者。此即菩萨福业其果应断。为释此疑故有下文。言此福性虽复不能亲招觉处。颂曰

  其福不失亡　　果报不断绝
  得忍亦不断　　以获无垢故
  更论于福因　　为此陈其喻
  彼福无报故　　正取非越取

由此是彼智资粮性故。又复何为。更于其福而陈喻耶。故云得忍亦不断。以获无垢故。更论其福因。为此陈其喻。又有疑云。既得无生法忍智乃不生。菩萨诸福皆应断绝。为显福不断绝至极清净。获福既多果报亦胜。于不生法得无性者。有二种无性。由其二性体不生故。经云妙生应正取不应越取者。云何是正取不应越取。答彼福无报故。正取非越取。凡所有福招果报者。是可厌故。当知彼取即是越取。如越正路而行崄道。而彼福不招报。是故彼是正取非为越取。问菩萨福津既不感报。所获之果如何可知。答曰

  彼福招化果　　作利有情事
  彼事由任运　　成佛现诸方
  去来等是化　　正觉常不动
  彼于法界处　　非一异应知

诸佛世尊现众变化。非彼如来若来若去等故。云彼事由任运成佛现诸方去来等是化正觉常不动。为显斯义生起下文。曾无有去亦不有来。由此故名为如来。此有何意。若如来有去来等异者。彼即不是。如其常性无有变易。微尘作墨喻者。是谁之喻显何事耶。答曰

  彼于法界处　　非一异应知

言彼如来于法界处。非一非异性。意显斯事故彰其喻。颂曰

  微尘将作墨　　喻显于法界

又世界为墨。喻显何义。颂曰

  此论造墨事　　为彰烦恼尽
  非聚非集性　　显是非一性
  于彼总集性　　明其非异性

譬如造墨。所有尘埃众多极微性非一处。其聚集物非一事故。亦非异性。由总集故。此由无有别别断割之理。如是应知。诸佛世尊于法界中烦恼障尽。非一处性。亦非异性。此即兼述三千大千世界。不是聚性。及是聚性其喻亦同。如来说为非是聚性。是故说为极微聚者。此显何义。若其聚物是其一者。不应名此为极微聚。又复若是一界者。亦不应言三千大千世界。由此故云。此即是其有聚执也。此即如来说为非执。不为聚执故。由其妄执是故说为聚执。欲明异此余悉应无无上正智。复有何因。诸凡愚类于实无聚而执耶。为除斯难。而云其聚执者。但俗论说有如是等。此何所明。颂曰

  不了但俗言　　诸凡愚妄执

妙生诸有说云。如来宣说我见等者。此明何义。颂曰

  断我法二种　　非证觉无故

言我法二种体是无故。此两虽言得断。而亦不证菩提。是谁之断而能获耶。答由二见之断。彼二之见是所除故。颂曰

  是故见无见　　无境虚妄执

由此故知我体是无。诸有我见如来说为非见。以无境故。意道所有我境元来是无。文云故名我见者。明虚妄分别有也。如是于无我理显见无见性已。亦是显其于法见无见性。是故文云。于一切法应如是知等。然其法想亦是非相性故。犹如我见。复有何意。此之我法二见说为非见性耶。答曰

  由此是细障　　如是知故断

是所显义。此之我法二见。是其见取。此谓细障。由于二事如是正知非见性故。方能除断。经云应如是知。应如是见。应如是解者。此文说颂曰

  由得二种智　　及定彼方除

谓以覆俗胜义智。及以此二所依之定。方除彼障。又论差别之福何所显耶。答颂曰

  陈福明化身　　非无无尽福

如来虽复任运广为化用。然彼化身宣说正法。即是无漏之福。便成无有尽期。云何正说等者。此意为显如来不自言我是化身。颂曰

  诸佛说法时　　不言身是化
  由不自言故　　是其真实说

此何所陈。欲明如来虽为众生宣扬法化。而不自说我是化身。由作如是不正说故。为此名彼以为正说。意道若异此者。于彼所化诸众生辈不生极敬。斯乃为利多众生事。复是无法可说故。若言如来为多化身无尽说法。如何彼复说有涅槃耶。为释此疑说伽他曰

  如来涅槃证　　非造亦不殊

非诸如来所证圆寂是其造作。有为自性望其造作复不是异。虽现涅槃而是其化。示同生死利益有情。欲显如来无住涅槃。生死涅槃两皆不住故。复有何因。示同生死而不住于生死因缘事耶。答颂曰

  一切有为法　　如星翳灯幻
  露泡梦电云　　应作如是观
  此集造有九　　以正智观故

由以星等九事为同法喻。喻九种正智而观于境。何谓九观。应知即是九种所观之事。何谓所观。颂曰

  见相及与识　　居处身受用
  过去并现存　　未至详观察

此中应观见如星宿。谓是心法正智日明。亦既出已光全灭故。应观所缘境相。如翳目人睹发团等。是妄现故。应观其识犹若于灯。此能依见由爱腻力而得生故。应观居处犹如于幻。即器世间有多奇质。性不实故。应观其身譬如露渧。暂时住故。观所受用犹若水泡。其受用性是三事合所生性故。应观过去所有集造同于梦境。但唯念性故。应观现在事同于电。疾灭性故。应观未至体若重云。阿赖耶识在种子位。体能摄藏诸种子故

作斯九种观察之时。有何利益。获何胜智。颂曰

  由观察相故　　受用及迁流
  于有为事中　　获无垢自在

此义云何。观有为法有其三种。一由观见境识故。即是观察集造有为之相。二由观器界身及所用故。即是观其受用。于此由彼所受用也。三由观三世差别转故。即是观其迁流不住。由此观故便能于诸有为法中。获无障碍随意自在。为此纵居生死尘劳不染。其智设证圆寂灰烬。宁味其悲。颂曰

  由斯诸佛希有法　　陀罗尼句义深邃
  从尊决已义广开　　获福令生速清净

能断金刚般若波罗蜜多经论释卷下


能断金刚般若波罗蜜多经论颂

    No. 1514 [cf. Nos. 1511-1513]

能断金刚般若波罗蜜多经论颂一卷

        无著菩萨造

        唐三藏法师义净奉　制译

  胜利益应知　　于身并属者
  得未得不退　　谓最胜付嘱
  于心广最胜　　至极无颠倒
  利益意乐处　　此乘功德满
  六度皆名施　　由财无畏法
  此中一二三　　名修行不住
  为自身报恩　　果报皆不着
  为离于不起　　及离为余行
  摄伏在三轮　　于相心除遣
  后后诸疑惑　　随生皆悉除
  若将为集造　　妙相非胜相
  三相迁异故　　无此谓如来
  因与果甚深　　于彼恶时说
  此非无利益　　由三菩萨殊
  由于先佛所　　奉持于戒学
  并植善根故　　名具戒具德
  能断于我想　　及以法想故
  此名为具慧　　二四殊成八
  别体相续起　　至寿尽而住
  更求于余趣　　我想有四种
  皆无故非有　　有故不可说
  是言说因故　　法想有四种
  由彼信解力　　信故生实想
  不如言取故　　取为正说故
  佛了果非比　　由愿智故知
  为求利敬者　　遮其自说故
  证不住于法　　为是随顺故
  犹如舍其筏　　是密意应知
  化体非真佛　　亦非说法者
  说法非二取　　所说离言诠
  自受为他说　　非无益集福
  福不持菩提　　彼二能持故
  得自性因故　　此余者是生
  唯是佛法故　　能成最胜福
  不取自果故　　非可取可说
  解脱二障故　　说妙生无诤
  在然灯佛所　　言不取证法
  由斯证法成　　非所取所说
  智流唯识性　　国土非所执
  无形故胜故　　非严许严性
  譬如妙高山　　于受用无取
  非有漏性故　　亦非是因造
  为显多差别　　及以成殊胜
  前后福不同　　更陈其喻说
  两成尊重故　　由等流殊胜
  烦恼因性故　　由劣亦胜故
  彼果胜苦故　　难逢胜事故
  境岸非知故　　于余不共故
  是甚深性故　　胜余略诠故
  胄族高胜故　　望福福殊胜
  彼行堪忍时　　虽苦行善故
  彼德难量故　　由斯名胜事
  由无恚怒情　　不名为苦性
  有安乐大悲　　行时非苦果
  生心因不舍　　是故应坚求
  谓是得忍边　　及此心方便
  应知正行者　　是利生因故
  于有情事相　　应知遍除遣
  彼事谓名聚　　最胜除其想
  诸世尊无比　　由真见相应
  果不住因位　　是得彼果因
  世尊实语故　　应知有四种
  立要说下乘　　及说大乘义
  由诸授记事　　皆无有差别
  不得彼顺故　　是非实非妄
  如言而执者　　对彼故宣说
  常时诸处有　　于真性不获
  由无知有住　　智无住得真
  无智犹如闇　　当闲智若明
  能对及所治　　得失现前故
  由如是正行　　获如是福量
  于法正行者　　业用今当说
  于人有三种　　受持闻广说
  义得由从他　　及已闻思故
  此谓熟内已　　余成他有情
  由事时大性　　望福福殊胜
  非境性独性　　能依是大人
  及难可得闻　　无上因增长
  若但持正法　　所依处成器
  蠲除诸业障　　速获智通性
  世妙事圆满　　异熟极尊贵
  于此法修行　　应知获斯业
  由自身行时　　将已为菩萨
  说名为心障　　违于无住心
  授后时记故　　然灯行非胜
  菩萨彼行同　　非实由因造
  无彼相为相　　故显非是妄
  由法是佛法　　皆非有为相
  谓以法身佛　　应知喻丈夫
  无障圆具身　　是遍满性故
  及德体大故　　亦名为大身
  非有身是有　　说彼作非身
  不了于法界　　作度有情心
  及清净土田　　此名为诳妄
  于菩萨众生　　诸法无自性
  若解虽非圣　　名圣慧应知
  虽不见诸法　　此非无有眼
  佛能具五种　　由境虚妄故
  种种心流转　　离于念处故
  彼无持常转　　故说为虚妄
  应知是智持　　福乃非虚妄
  显此福因故　　重陈共喻言
  谓于真法身　　无随好圆满
  亦非是具相　　非身性应知
  于法身无别　　非如来无二
  重言其具相　　由二体皆无
  如佛说亦无　　说二是所执
  由不离法界　　说亦无自性
  能说所说虽甚深　　然亦非无敬信者
  由非众生非非生　　非圣圣性相应故
  少法无有故　　无上觉应知
  由法界不增　　清净平等性
  及方便无上　　由漏性非法
  是故非善法　　由此名为善
  说法虽无记　　非不得应知
  由斯一法宝　　胜彼宝无量
  于诸算势类　　因亦有差殊
  寻思于世间　　喻所不能及
  法界平等故　　佛不度众生
  于诸名共聚　　不在法界外
  若起于法执　　与我执过同
  定执脱有情　　是无执妄执
  不应以色体　　唯如来法身
  勿彼转轮王　　与如来齐等
  即具相果报　　圆满福不许
  能招于法身　　由方便异性
  唯见色闻声　　是人不知佛
  此真如法身　　非是识境界
  其福不失亡　　果报不断绝
  得忍亦不断　　以获无垢故
  更论于福因　　为此陈其喻
  彼福无报故　　正取非越取
  彼福招化果　　作利有情事
  彼事由任运　　成佛现诸方
  去来等是化　　正觉常不动
  彼于法界处　　非一异应知
  微尘将作墨　　喻显于法界
  此论造墨事　　为彰烦恼尽
  非聚非集性　　显是非一性
  于彼总集性　　明其非异性
  不了但俗言　　诸凡愚妄执
  断我法二种　　非证觉无故
  是故见无见　　无境虚妄执
  由此是细障　　如是知故断
  由得二种智　　及定彼方除
  陈福明化身　　非无无尽福
  诸佛说法时　　不言身是化
  由不自言故　　是其真实说
  如来涅槃证　　非造亦不殊
  此集造有九　　以正智观故
  见相及与识　　居处身受用
  过去并现存　　未至详观察
  由观察相故　　受用及迁流
  于有为事中　　获无垢自在

能断金刚般若波罗蜜多经论颂


涅槃经本有今无偈论

    No. 1528

涅槃经本有今无偈论一卷

        天亲菩萨造

        陈世真谛三藏于广州译

    涅槃经三世义

解纯陀疑问。论曰。多弟子已成熟。纯陀未成熟。佛为纯陀未成熟故。显示大般涅槃。讲说大经。受大功德。为成熟故来拘尸那城。云何纯陀而有疑心。有二因缘。一见同相未见别相生疑心。二见别相不见同相故。起疑心者。如遥见杌疑为是人为是杌。若见乌鸟集上鹿从其下过。知是杌非人。若见举手挑衣者。知人非杌。别相不见同相生疑心者。如空不共相是常住。如见地不共相是无常。声闻者不共相。于声闻不共相生疑。为同空是常住。为同地是无常。凡夫为同相故起疑心。声闻缘觉为别相故起疑心。凡夫为有生法故起疑心。声闻缘觉为无生法故起疑心。纯陀不为此二种故起疑心。为欲利益众生故生此疑。如此大菩萨。那得于佛生疑。于此大会大有外道聚集有外道说佛死而更生。复有说。如灯尽火灭。复有说。佛灭后有尽有不尽。为释此疑故。佛说偈

  本有今无　　本无今有　　三世有法
  无有是处

佛为二乘故说偈。烦恼生得圣修得。凡夫性生得。圣性修得。烦恼缚生得。解缚修得。生死生得涅槃修得。本生今修。本是生今是修。为二乘作此解说不谤大乘。为大乘作此解说是谤大乘。此是不相应大乘。谁能令相应大乘。是故我等依义选择。思惟义不依语言。不选择思惟语言。为修行大乘者说。过三种义显了别义。言本有今无。本无今有。三时有。是三种义无有。无有是处。何故三种义不成就。若本有今无者。一切如来等则无解脱。何以故。性不定住故。以前有后无故。一切真有亦无。真有俗有亦无。何以故。真有前后无异故。俗有无本故。是故真俗二义不成就。于此二义不明了。僧佉外道亦如是说。因中有果。譬如乳有酪生酥等。是增益僧佉等义。若本无碍。现在时中谁能为障。若汝思惟妨碍。因缘和合为障者。是义不然。何以故。前后无异故。若今不障本时何故不障。有何道理。本不依因缘生。后依那因缘灭。所言本者。以何法为本。为初起为当相续为本。若初起为本。初不为因缘所生。后如初。亦不为因缘所生。若如是说十二因缘法如如义。皆悉已破。则同外道说无因义。若相续为本者。相续亦不定。何以故。分分不定故。云何相续为本。是故一切有生之法。说本无因。如此说者则无道理。本无今有者。若前是无本而今有。有者则无得解脱者。前烦恼未起。则是离解脱。而后生烦恼则无解脱。若前无今有者。最极无生当应得生。如空生花。若汝思惟一则无因。是义不然。何以故。如屋与花二同是未有。何故因缘生屋。不因缘生花。等是无故。是义无道理。若本无生。而今得生。则破本义。是义不然。何以故。初生是本故。若汝思惟因缘。是初生则非初。是故生非是本。是亦不然。何以故。汝意欲破本有故。欲立因缘本者。是故不过本故。前未有法因云何生。若其生者为具足生。为分分生。若具足生者。为一时生。为前后生。若一时生。则因果同时不可分别。若果后生。因在前灭。谁生后果。如煮熟鸡而复作声还生。若具足者。何用观因。若分分生者。亦同前失。是故本无今有。欲安立因。是义不然

三时有者。无有是义。若有是三世者。为一义遍三世。为一一义各各三世。如此二义并皆不然。何以故。若一义遍三世者。不得一世有三。何以故。相妨碍故。若义依时。则过去未来分分无穷。若时依义。义一故则无三世。离义故则无别时。是故三时皆不成就。若一物遍三世者。是物则不可说名。何以故。一物二成就故。若尔生死涅槃则是一。若各各世有者。三世各自有如现世能生果。过去未来何意不能生。若具能生。则无一人得解脱者。若不能生过去未来。谁断果报。言过去未来是有者。为体故说有。为用故说有。若为体说有。云何可破而为三分。若为用说有者。过去灭未来未生。云何起用。若汝思惟三世是有为能说。三世不为能说。三世不为体说。若同有体。一则有能。二则无能。是义不然。若汝思惟为时节有能。不说能。知芭蕉一生果不能重生。义亦不然。何以故。义不定故。此三时谁之所有。若有因生难则无穷。若无因生则时节义不成就。若汝思惟未来是前。现在是中。过去是后。作三世者。何以故。未来力逼出故现在。现在力逼出过去。如恒河水。未来水逼现在水。现在水逼过去水。若一世成就。则三世成就。是义不然。何以故。水是同时。处所别故。故说三时三世有义。是故不然。无无是处者。如小乘说无是处。如外道说无是处。破小乘外道如是。偈义一破邪义。二立正义。破邪义者。依语言说。立正义者。依于义说。所言正义者。本有今有。过于三世。是名正义。本有今有者。从初发心至得涅槃。一味无异。不依生因。不依灭因。有则清净。凡夫法不能染。圣人法不能清净。若起四重五逆不能令减。若修慧断恶不能令增。若有见得清净眼。若有见得毒恶眼。依方便则过语言道及一切思惟。不可说不可思惟摄受。因果非因非果。是地非数量一时能分别。是诸佛如来境界。生死涅槃是地逆顺故。若逆是生死。若顺是涅槃地。是前际是后际。是发心地是金刚后心地。破一切见。清净一切见。一切众生应当受用。如来一体最归依处。摄受一切宝是大涅槃。过三世者。为用说涅槃功德。何者过三世。为生故分别三世。涅槃无生故。不可分别。三世者。未生得生。已生即灭。涅槃无灭故常住。是故自在。以自在故。是故最乐。为体故说清净。为用故说常乐我。自体故清净。对生死故常乐我。复次有二种义。若本有今有。则是常见。若过三世。则是断见。若二义待来离断常。是中道。如是俗谛真谛相待故。有如是十二因缘真实。何以故。离二边是真十二因缘。若能善解。即见如来现在于世。是故如来说十二因缘是如来身。于真俗二谛。以不二故。是十二缘真佛道。如是偈有二义。一则对因义。断于邪道。二理得义显示实。如是二义。是如来事。依大智依。大慈悲。五常义

一无穷常。二无起常。三恒在常。四湛然常。五无变常。无穷常者有十。一因无边故常。二众生无边故常。三大悲无边故常。四四如意足无边故常。五慧无边故常。六恒在定故常。七安乐清凉故常。八行于世间八法不能染故常。九甘露寂静远离四魔故常。十性无生故常。因无边者。无量劫来舍身命财。为摄持正法。正法既无边际无穷尽。此即以无穷之因。得无穷之果。果即三身也

二无起常者。依前际非本无今有。不为意生身所生故。三恒在常者。依后际离不可思议死坏故。四湛然常者。依中际不为无明烦恼病所破坏故。五无变常者。过三际不为无漏业果报所变异故。第三恒在离死。第四湛然离病。第五无变者。初地至如来地通名无穷。从八地至如来名无起。从九地至如来。亦分得名为无变常者。正论五义并在佛地

  诸行无常　　是生灭法　　生灭灭已
  寂灭为乐

三藏阇梨解旨云。诸行无常者。诸行即是色心诸行。行于三世中也。无常自有五义。一失灭无常。二相离无常。三变异无常。亦名回转无常。四有分无常。五自性无常。所言失灭者。如百年报尽寿命失灭也。二相离无常者。即是骨肉离散也。三变异者。如骨色初白后变为鸽色也。回转者。即转白为鸽色。四有分无常。如根尘识三事未和合时。名为本无无常。已有还无名为灭坏。即是已有还无。无常根尘识共聚。总名为有分也。五自性者。为有前四义故。名为自性无常也。是生者。是未来世生也。灭法者。是过去世已灭法也。生灭者是现在世也。而现在摄生灭者。生而即灭故。云生灭居现在也。言寂灭为乐者。若言灭法为乐。此义不然。何以故。为有现在灭是过去。已灭法为残。以有残故非乐也。若灭现在生灭为乐者。此事不然。何以故。为有未来生是现在世残故。有残故非乐也。若言未来生是常者。此义不然。生必有灭。故非常也。若能令未来应生法而不得生。乃可为乐耳。寂灭为乐。即其义也。上三句明生死有为法故无常。后一句辨涅槃。是无为法故常住

涅槃经本有今无偈论


涅槃论

    No. 1527

涅槃论一卷

        婆薮槃豆作

        沙门达磨菩提译

  顶礼净觉海　　住持甘露门
  亦礼不思议　　自性清净藏
  救世诸度门　　正趣实谛道
  及如学而学　　如法证实义
  愍长迷苍生　　含悲传世间

从初如是至流血洒地。名不思议神通反示分。纯陀哀叹二品。名成就种性遣执分。从三告以下讫大众问品。名正法实义分。五行十功德。名方便修成分。师子吼品。名离诸放逸入证分。迦叶品名慈光善巧住持分。憍陈如品。名显相分。云何得长寿金刚不坏身。迦叶欲共众生同闻故问。答意我修三业故得长寿。云何金刚不坏身。问一切众生皆败坏。云何得不坏。如前所行得不坏。云何坚固力。心无分别故得坚固。无来无去故长寿。不可说故不坏。无流动故坚固。云何得长寿。金刚不坏身故得长寿。云何不坏。得坚固力故不坏。迦叶为众生非一问可了答法相不尽故问

愿佛开微密广为众生说。云何微密。身外有佛亦不密。身内有佛亦非密。非有非无亦非密。众生是佛故微密。云何众生是佛。众生非有非无非非有非非无。是故众生是佛

云何得广大。为众作依止。何以故名广大。无有识相无不是佛。行无不净德无不满。故言为众作依止。见释迦依止者。不名依止。小乘解义。慈故令众生依止。实非阿罗汉。如与罗汉等者。昔教王宫生得阿罗汉。今说王宫非生双林非灭。云何非罗汉。如与罗汉等。迦叶未蒙佛教。不问四依止。问如来若王宫非生。双林非灭。自然得戒。不由四果。实非阿罗汉。云何如来。与罗汉等。解云。若如来实是阿罗汉。四依可与罗汉等。佛实非罗汉。那得言如与罗汉等。释迦身有二名。一名应来二名菩萨实行。言应者。从莲华藏世界。是大庄严佛。作太子现王宫生双林灭此是菩萨游戏法。第二真者无所从来。云何与罗汉等。佛有二种名。一真佛化同声闻。阿罗汉佛。非实声闻。云何与四声闻等。解向前实有罗汉。可言我与罗汉等。前不曾有罗汉。言罗汉者我身自作。云何与等。又解释迦身名阿罗汉。性地菩萨云何与罗汉等。第二实行菩萨。应来亦能化作佛。释迦实是阿罗汉可言等。释迦不曾是罗汉。云何等。是故正性地菩萨是阿罗汉。阿罗汉此菩萨。实非佛。罗汉云何与佛等。释迦实是阿罗汉可言等。释迦不曾是罗汉。云何等。是故正实行菩萨。是阿罗汉。是故王宫生双林灭皆是游戏。菩萨现作。前实无阿罗汉。由我化故众生得阿罗汉。是故我作阿罗汉。第二莲华藏世界菩萨化与我无异。是故实非阿罗汉。如与罗汉等。若我实是罗汉。菩萨可与我等。执我为罗汉者。此非菩萨法相化通。皆是不实解。四依。欢喜地为初依。六地为二依。八地为三依。法云地为四依。化声闻声闻虚断。不曾是阿罗汉。云何与等。菩萨名为法佛。亦名缘佛。云何法佛。从法中生行法故。得见故。名法佛。云何缘佛。有缘故。见名为缘佛。问迦叶意。若自解不须如此问。若不曾闻不曾见。云何作如此问。答迦叶是十二童子。如来威神力加教故能问。迦叶所问正是涅槃更无异外

云何知天魔为众作留难。解此迦叶正问如来身。不问未来何以得知。众生身自不信。云何有外魔来作留难。如来今在道树下始成佛。正法将兴。魔畏失其徒众故作留难

云何诸调御心喜说真谛。云何名调御。凡夫众生无所知。闻大乘是大乘。闻小乘是小乘。闻苦是苦。闻乐是乐。何以名调御。非苦说苦。非乐说乐。非常说常。昔日说小今说大。亦不名心喜说真谛。不名为调御。今说无常非无常。苦乐非苦乐。无来无去。是名说真谛

正善具成就。演说四颠倒。正善具成就者。菩萨行四无量心十波罗蜜无不平等。是名相中正善。菩萨行无不正善。声闻有彼此故。不名为正善。菩萨无彼此故。名为正善。第二正善者。昔教不正。声闻不具成就。今者涅槃理正。无来无去无生无灭。名为正善具成就。第二从欢喜已上至法云地。是名具成就。演说四颠倒。声闻人言我常乐我净。佛苦空无常是倒。声闻苦空无常。佛常乐我净亦颠倒。佛常乐我净。众生苦空无常亦是倒。云何如来说四颠倒。为声闻说。正说四颠倒是不颠倒更无外法是颠倒不颠倒。是名心喜说真谛。经云说法不有亦不无。是名真谛

云何诸菩萨能见难见性。迦叶有二种意。一欲使一切众生知有佛性。二不欲使见佛性。何以不欲使知见。欲令如来深解佛性。何以故名深。佛性非是可作可造可修可得故。名深。声闻狭小不究竟。不能见。菩萨行慈悲广济。不求见。为众生故。被缚故。名难见。第二解。佛性非是可见法能见所见能知所知能修所修故。名能见难见性

云何解满字及与半字义。半字者渐教。满字者涅槃。满足教故名满字。摄佛教果功德尽名满字。声闻缘觉教不满足故。名半字。涅槃名顿亦名渐。今论涅槃二谛相对中满。就行有满不满故名渐教。就理无满不满。是故涅槃名渐教。形半字。涅槃名顿教。第二复次言满半者。是众生妄想。理不是满不满。是故言涅槃渐教。云何诸菩萨能见难见性。是或但见法。又言云何解满字及与半字义。今更无见不见

云何共圣行。如娑罗娑鸟。如来在王宫。取妇有儿。或出家与声闻同。譬如娑罗娑鸟共为一群不可分别。圣者如来与一切众生。同修同行故。言云何共圣行如娑罗娑鸟第二解。色为圣人。声闻色心为圣人。菩萨圣人非心色。言有心色者故非圣人。声闻圣人形色为共。菩萨圣人无青黄赤白心识。理共有心识凡夫。无心识圣人故言圣人。言娑罗娑鸟者总名。譬如来共一切众生不可分别。迦邻提者。譬涅槃别一切众生。还去声闻意。菩萨知如来与一切众生无差别故名共。解有相舍离。如来未出世。有凡有圣相舍离。如来出世一切众生不相舍离。声闻意。菩萨不相舍离者。如来不出世不相舍离。如来出世不相离。解世谛无苦空无常。第一义谛无常乐我净。有人言。无世谛有常乐我净。浅解义理。又有人言。有是世谛。无是第一义谛。亦有亦无是世谛。非有非无是第一义谛。非有非无更无外法故。名共圣行

迦邻提。日月太白与岁星。云何名日月。此日月者。譬喻凡夫见日月有出没。圣人不曾见出没。第二声闻人。见佛王宫生双林灭。菩萨不曾见王宫生双林入涅槃。第三日月没故。太白岁星出。世人生怪。如来入涅槃。声闻缘觉出。法与如来异故言星出。众生妄见日月岁星有出没。而实无出没。众生见如来有生灭。而如来实无生灭

云何未发心而名为菩萨。声闻有发不发。缘觉亦有发不发。菩萨亦有发不发。此三种菩萨名发心。云何发心者。果异可得名发心。如来从初教。众生有发不发。昔教有发不名为发。云何不名发。见有佛异可得可求差别不名发。何者名发。今说无相涅槃理薰故。令一切发名为发。无有声闻缘觉菩萨。有发不发故。言未发心而名为菩萨。涅槃平等照一切故。一切未发心。皆名为菩萨。迦叶何故问云何未发心而名为菩萨。发心者。见日月。不发心不见日月。二发心者。见常住。不发心者不见。向者如来出世有发不发。发者见不发不见。今者涅槃平等照。发亦是发亦是不发

云何于大众而得无所畏。菩萨出世慈悲平等。不坏众生相故。言无所畏。菩萨无畏众生亦无畏。云何众生不畏。菩萨出世不坏众生相。是故众生亦不畏。如来出世。以慈悲喜舍四无量心。平等无有差别。无有天魔外道乃至一阐提。如一子想无所畏。何以众生无所畏。一切众生视如来。如父母故无所畏。何以名阐提。不识佛不识内外道名一阐提。问一阐提不识内外。与菩萨何异。解言菩萨不识内外不杀。一阐提不识故行杀。犹如阎浮金无能说其过。解此是和众义。阎浮檀金有四种。其四者何。一青二黄三赤四紫磨。青者喻外道。黄者喻声闻缘觉。赤喻六波罗蜜菩萨。紫磨喻如来。阎浮金亦有青黄赤白。有四种诸色。二者世间好物。虽复端正犹有阙少。阎浮金者不如此物。不可说其过。喻如来得涅槃。亦种种声闻外道六波罗蜜菩萨。犹如阎浮金不可说其过。紫磨金具有众色。喻涅槃具有天魔外道声闻缘觉六波罗蜜菩萨。何以如此。此外更无异法。紫磨金一切具足。诸色不可说。声闻缘觉六波罗蜜外道种种有故不可说。涅槃理非青黄赤白法。亦青黄赤白故。言不可说。若有青黄赤白可说其过。此青黄赤白不曾有故不可说。云何处浊世不污如莲华。浊世者五浊。云何五浊。劫浊烦恼浊。释迦出于五浊。王宫生有妻子。金银七珍种种财物。皆名为浊不为所染故。名处浊世不污如莲华。第二第三乘法。名之为浊。金者涅槃不为三乘所染故名不污

云何处烦恼。烦恼不能染。如医疗众病。不为病所污。迦叶问意据如来。三界烦恼九十八使。如来出世不为所污。一切众生。三界烦恼九十八使所污。第二声闻缘觉六波罗蜜。计有烦恼可断佛果可得。是故为烦恼所污。十地菩萨。行通达大智故。不为烦恼所污。第四大菩萨望果。亦为烦恼所污。今者涅槃非是因果所得。是故不为所污。第五四谛教乃至般若波罗蜜法华。亦名烦恼所污。今者涅槃理。无流动无得失无起灭。是故不为所污。如医疗众病不为病所污。如来出世始从三归五戒。乃至菩萨戒弹指低头。以渐教化治众生病。知烦恼故不为病所污。众生不知烦恼故。恒为病所污。第二次第教。亦名治众生病。第三名力教神通变化身一切降伏。亦名治众生病。第四今时说涅槃治前别教患。亦名疗众病。云何名患。一切众生未发心名患。见丈六发心。又解非丈六使发心。涅槃平等照令使发心故。名疗众病

生死大海中。云何作船师。三界名生死。如来出世亦名生死。何以名生死如来法能度众生。令不生死故言生死大海中作船师。第二丈六说次第法。乃至法华。亦名生死法。今说涅槃无来无去无生无灭。度前生死教故名船师。初解丈六不生死。及教不生灭。第二丈六及教亦生死。涅槃无生灭。第三佛灭度后。谁能度生死。唯大菩萨能度生死。第四菩萨亦不能度。大涅槃理能度生死。喻世间船师善解方便能知海难。烦恼大海三界为船。如来种种方便。说三乘法为船师。世间船师指因指果众生上船。如来方便说三乘法。说因说果。言出三界者犹是生死。是故以三界为船。初次第教者。以生死度众生故。名为船师。法华以万行为船师。今涅槃以无生死为船。何以示病所污。复有生死大海中。云何作船师。前去烦恼。又烦恼大海中作船师。度令到彼岸。云何舍生死。如蛇脱故皮。迦叶问。如来出世生死。今说入涅槃道。我不生不死。如蛇脱故皮不生灭。次第丈六所说是生死法。今者说涅槃不灭。前次第教此教无理。如蛇脱故皮。无利无功德。今者涅槃无生无灭亦不破教。第二一切众生。乃至言说不言说。有形类悉有空名。唯涅槃是真实理

云何观三宝。犹如天意树。三宝名轨则。如来出世示现有三宝。由有三宝故。受三归得五戒。亦得弹指。亦得随意所修随意所得。如来亦名如意三宝。亦名如来如意众生如意。云何众生如意。随意受三归五戒。乃至菩萨悉得果报故。名众生如意。如来如意者。随众生根感故名如意。今言涅槃如意者。一切苦乐善恶。无不是理故名如意。故言观三宝犹如天意树。喻他化自在天有一树。能随诸天意所得故。名如意树。诸天行行久故感得此树。三宝亦如是。众生行行久故。感得丈六故名三宝犹如天意树

三乘若无性。云何而得说三乘者。非如来说一法。三乘者众生根故。言一音说随类解。如来说三乘不名说。逐众生根故。有小有大。如来虽说三乘。非如来本意。何者如来本意。涅槃是。迦叶问意三乘若无性。云何而得说。如来答意。一切诸佛不为众生说三乘。今者涅槃实相小非小大非大。当知三乘教是一相无有大小。第三说涅槃理处。不道大不道小。众生智差别故教差别。理无差别大小故。得说大小。向者差别者。正是无差别更无异外

犹如乐未生。云何名受乐迦叶问言众生不知乐。云何说受乐。凡夫有苦无乐。菩萨有乐无苦。何以有乐。菩萨智通达到果故知乐。众生不知故苦。菩萨知果。言菩萨乐不是乐。众生苦不是苦。等是妄故。涅槃无苦无乐。名为大乐故乐未生。云何名受乐。问如来娑罗林说法。何以不纯戒持得福戒不得福戒外道是佛戒非。佛答意。向者杂教是涅槃。更无外道涅槃。云何诸菩萨而得不坏众。一解声闻缘觉六波罗蜜菩萨。乃至外道。有彼此有得证。故名为坏众。第二菩萨密行密教。知众生根性。不坏众生相故名坏。菩萨所不坏者能坏。不能坏非菩萨。能作法如此不乖法相故。名不坏众。第三菩萨知涅槃无青黄赤白无彼此故。名不坏众。第四不坏者。涅槃理非得非证非造非作故。得不坏众。第五真理不坏众生。众生亦不坏理。何以如此。众生是理。理外更无众生故。不坏众

云何为生盲而作眼目导。迦叶问。云何作眼目导。一解前教声闻缘觉六波罗蜜。随其相解名生盲。如来解声闻缘觉六波罗蜜。若曾有所得。是不可开。此法曾有故开。譬如盲人不知青黄赤白。若有人语青黄赤白转迷。若道无青黄赤白称所解。名作开喻。三乘人明有因有果。差别有得不得。今语涅槃。若有长有短有得有不得转迷。言涅槃无青黄赤白。无得无证无长无短故。名为开因。丈六修道持戒布施。不是因。因佛性无得无修。是名为因。一切众生视三乘人以为法。三乘者名青盲。非但三乘人。一切众生亦青盲。法非可见不可见。可开不可开。可至不可至。以教故道青盲理不道青盲无青盲。是故道青盲不青盲不乖法相。若有此二种可道不曾有不曾无。何以说。是有不有无不无开不开。都不乖故言开

云何示多头。唯愿大仙说迦叶问意。如来初教种种多头。今涅槃。何以唯一无二。如来答非我多头。众生昔行多根故。是故说多头。故言示多头。第二法多。何以名多。法相如此所以示多头。第三所由说多。此法若有。可名多说。此法不曾有。是故不多说。第四涅槃理相如此。非是多不多。第五真理。本末非是有无法。是故说不说无所妨碍

涅槃论一卷


三法度论

    No. 1506 [No. 1505]

三法度论卷上

        东晋罽宾三藏瞿昙僧伽提婆译

    德品第一

  知生苦无量　　善寂趣彼安
  用悲众生故　　轮转于多劫
  舍己之妙善　　为一切说法
  普智灭诸趣　　稽首礼最觉
  开此三法门　　功德之所归
  安快彼众生　　离于一切苦
  前礼于善逝　　法及无上众
  今说真谛法　　三三如其义

说曰。今说三法问尊云说三法。三法何义。答此经因法故。唯三相续撰。三法者是假想。问何故三法撰。答此佛经依无量想。众生为恶世所坏。命以食存。欲求其真。为彼开想故。及善持故。此三法撰。一切世间亦依真想及假想。是以开想故三法撰。问已答三法撰。三法唯愿说。答德恶依觉善胜法门若。觉德恶依觉则善胜法门。此三法经本三三品说品各三真度。问可说三品。但于说有咎。所以者何。善胜者应前说。是善胜说善胜已。然后说德恶依当觉。答乐所向者则不应说。此一切世间乐向善胜。乃至昆虫亦乐向乐。所以者何。为食故有所求。善胜者乐妙爱。如是比义说善胜。世间者多乐向乐而背乐因。乐者大涅槃。及无病是多乐。向但背是因。若已乐向不应为说。譬人趣道。若已知道则不语道彼亦如是。是故无咎。问云何此德恶依觉便有善胜。颇有见金得富。见药病无耶。是故不可德恶依觉而有善胜。答虽有此言。是义不然。当取如灯譬。如然灯即时坏闇。非然灯已后坏闇。如是智生即有善胜智觉。是一义。问德名何等。为众生数为色味香比为摄为诤伏耶。答我欲不乐自想作经而此中德者。福根无恶。福根无恶者。此三是德想。白净法及法果我以为德想。是一切此三中摄。今当相续显示。问已说福根无恶。何等为福。答福者施戒修数数处善胜谓之福。亦扬去人恶。谓之福。是三种施戒修。如所说

问已说福施戒修。何等为施答为已他摄故。舍财时俱思愿及无教是三种施。问此云何。答施者法无畏财。法施无畏施财施。是三说施。法施者说经出于世间。无畏施者。八种三归为首。如世尊说。归佛为无量众生施无畏。不结恨无恶法。众亦如是。问如三归亦杀生。云何施为无畏首。答不说一切众生。但如此邪见为痴。杀生盗他财作众恶。是三归者所不作。已得正见故。若三归无正见者。则非三归。是故施无量众生无畏为首。无咎财施者。饮食为首。摄他故施。供养等以香华为首。自为故。或复俱故。是己他俱德故得大果。此中施净。应广分别。如所说

  譬树用其根　　时复用于枝
  或有二俱用　　是事世之常
  如是方便成　　是施得大果
  有从因缘净　　俱功德亦然

问云何戒。答戒者身口二摄他不娆。饶益戒者有三相。从身口生。问此云何。答摄他不娆他。及饶益摄他者。饥乏时众生爱命恕已不害。离他财他妻亦如是。此是摄他。离两舌恶口妄言绮语。是不娆他。复次七枝不逼他。是不娆他。众苦所逼。无所归依。而救济是摄他。受持此二。若福相续生是饶益。我从今离杀生。发心即饶益增长。譬如出物日有滋息。受戒心生善相续受。实已灭如种有萌牙饶益。若不舍善相续。乃至眠亦增益福。此是饶益是谓戒。问云何修。答修者禅无量无色。此修于善行。是故修如华薰麻。习是修如习近王。譬如王臣善习近。必成其果。如是习修必得白净果故。说修禅者是念义此四种。问此云何。答禅者离欲观喜苦乐。是四禅初者。已离欲恶不善法。缘善系心住谓之离欲。第二离观。观者微于觉如铃有余声。是此中无。谓之离观。欲前已离。第三离喜。喜者心悦。如海涌波。是此中无及欲观。故说离喜。第四离苦乐。乐者身心不逼。苦者逼。是此中无及欲观喜故。说离苦乐。是四说禅。问云何无量。答无量者慈悲喜护。是四假想为无量。无量众生彼缘故无量。亦不可数功德故无量。慈者愍一切众生心行。一切众生润在前念是慈。悲者。苦恼众生愍伤在前。离忧恼念是悲。喜者。于多乐众生系缚悦踊是喜。护者。无求不勇猛恕众生过。若众生作恶。是不作为快。是反观众生自业。如是恕过。谓之护。问已说无量。云何无色。答无色者。空识无所有。非想非非想处。处者依是四种。空者除色见色过。是离欲一心缘空。于空系想是空处。不猗于空但有识。缘识便有识处。是亦为依。无依乃胜。若无所有。是谓无所有处。于想见过灭想见怖。一心是非想非非想处。是无色道。是名一切福。问根云何。答根者无贪无恚无愚痴。不贪不嗔不痴。此三根相。问此是谁根。答非是前说德本。那是一切趣善胜法之本。随其义一增余相随。如无贪于施增。无恚于戒增。无痴于修增。复次无贪于财施增。无恚于无畏施增。无愚痴于法施增。是谓三种施增。复次无贪于摄他增。无恚于不娆他增。无愚痴于饶益增。是谓三种戒增。复次无贪于禅增。无恚于无量增。无愚痴于无色增。是谓三修增。复次无贪于不恶增。无恚于忍辱增。无愚痴于多闻增。如是于力根如是。当知一切善行根。无贪者于所有众具不利不着。意无恚者灭于恚。无愚痴者灭于痴。故曰根。问云何无恶。答无恶者。忍辱多闻。不恶无恶者。是俗数假相。复次恶者。是增恶是不增恶。故曰无恶如所说。无恶者。妙善之言。忍辱者苦。贵贱力自制不怒怒。忍辱为苦。贵力贱力随其事自制不怒。怒为苦所逼自制。是堪耐义。为贵力所迫。怒而不能报。但弊恶人故起怒。若于大力所迫不起怒。是忍辱。为贱力所加恕贱力。怨家能报。若不报者是恕。如是众生过及行过。堪耐此义。今当说。苦者寒热饥渴风日勤劳。为众苦所逼。当自制此苦。从二事起恼。于身不怒。于无情怒者。众生因缘说。是以依二逼身。当堪忍

问已说忍辱云何多闻。答多闻者。契经阿毗昙律。多闻者若能除淫怒痴。是多闻。余者非多闻。是三种契经阿毗昙律。于中契经者。萨云若说及彼所印可。显示秽污白净。明四圣谛。离无量恶。阿毗昙者。于契经所有尽分别。律者说威仪礼节令清净。是谓三种多闻。于中律多制欲。阿毗昙多制恚。阿毗昙者说诸业性。以此止恚。因恚起犯戒。因犯戒堕地狱契经多制痴。契经者说十二因缘。问是多闻云何不恶。答不恶者。真知识御意由。真知识真御意真由。是谓不恶。真知识者。慈善能师弟子同学。若慈善能者。是谓真知识。彼三种师弟子同学。问云何若慈是师善是弟子能是同学。说如是耶。答不。所以者何。说无差降。慈善能者。谓真知识相。是说当观。师弟子同学。此中慈相最胜。余二枝所成。或慈者但不善知事。亦不能说。如父年老无德。或有能者亦不善故。虽有慈不善故。教恶如六师等。若有具足成就三相者。当知是真知识。或有师过故。坏或弟子过。或同学过。是以具足成就三相。真知识当求。问是真知识云何真御意。答真御意者止举护想。勇猛止想。举想护想。向是勇猛。于中止者。止心逸意。下此中观相故说。止举者。意弱柔濡。下筋力扶起令高。此中观相故说。举护者。以平等意任其行。如善御乘。迟者使速。急者制之。等行而护。此亦如是。四无量中护不可意。众生以慈为首护。此中平等意护。问云何知。如下意当举。举意当制。等者护。答非为自随所欲是真御意那。是故此自随所欲。随时随方便义。若高下者此非真御意。问是真御意云何真由。答真由者。具方便果。真由者。向彼或说习修。是真由。具方便果。问为谁具。答前已说善胜。问具名何等。答具者善损伏根近行禅。此是资于善行。故曰具。如行具足具。具者是枝义。此具三种善。损伏根近行禅。问云何善损。答善损者。粪扫衣无事乞食。众聚中损谓之善损。善损者是清薄义。工师作二种像。有增者有损者。损者石工木工。增者泥工画工。彼成二种像。若从损是能耐风雨。余虽有好色。不耐风雨。如是二种人。在家及出家。出家者于家累意解脱。已舍众具损为妙。在家者因妻子亲族为增。众事得成。在家者虽有众具为美味。但爱相别离忧悲斗诤等。为非法雨所坏。意无所耐。如画像为风雨所坏。非出家。如世尊说

  如饰弃鸟　　青鸱妙色　　终不能及
  鹅雁飞行　　在家如是　　不及比丘
  牟尼远离　　闲居坐禅

是谓善损粪扫无事乞食。此三净功德。为十二本。余九是眷属。彼当别说。世尊欲令难陀欢喜。故亦说此三

  难陀何见汝　　无事粪扫衣
  知已乐于高　　舍离不染欲

以是故知此三是本。复次四爱生。衣食坐处。有故。于中为衣爱所持说粪扫衣。为食爱所持说乞食。为坐爱所持说无事。若成就此三功德。是方便灭有爱。以善损故。复次有二种。计着我行及我所作。于中为贪衣食坐处故。生我所作计着。彼以此三净功德止。若灭一事必断计我。是故说净功德。问云何粪扫衣。答粪扫衣者。三衣栴衣随坐。此粪扫衣三种所。满三衣栴衣随坐。若粪扫衣惟三者。应有九净功德。若尔者经相违。粪扫衣者从冢间里巷。拾弊坏衣。三衣者僧伽梨。郁多罗僧。安陀罗会。或有持三衣者。为爱好衣。所困汲汲行求。由此爱极烦劳。若不得多者。三当极妙。爱有二种。妙爱多爱。譬如求一最胜女。或求不端政千。如是多爱三衣所制生妙爱。世尊为彼说。持三衣有六种。劫贝毕竟缯麻布葛纻布。于中要用一。彼见已是好。是好多劳。为彼说栴衣。如是持栴三衣。或在众中。或在居家床座。若见余好座移就坐。为彼说。随座已坐。不应为好故移座。以我大故。起他是随座。如是三满粪扫衣。问无事云何。答无事者树下暴露。正坐受树下受暴露。受正坐。受此三满无事。此四除处所爱。于中精进人信施作舍。柔濡敷大床座。教化者贪着。世尊知已为彼说此事。不应舍自家着他家。当舍此舍乐无事。彼已在无事。复作高大楼阁屋。此亦不应尔。在无事中爱乐高阁屋。如以马乘具被驴。是故树下当受持。彼已受树下。不乐弊恶小树。而复求好大华果树。世尊教彼。当受持暴露。汝施主长养身。复何为此。当学神仙乐。于暴露汝无家。非为爱所逼。彼已在暴露。便作是念。我难行已行。由是舍正思惟。即便倾卧眠至日出。世尊教彼此事。不可如人截耳而严饰首。是故汝当受持正坐布草结跏趺坐。观世间如真而作自业。如是具足无事。问是无事云何乞食。答乞食者。一食过中不饮浆。冢间出家者。有二种食。僧食及乞食。僧食者。恒精进家得具足食。或复精进者。为除烦劳故。于外作房作食饷。乞食者。从家家乞至极少。是名乞食。余者邪命彼僧食者作是念。我能致彼施主食。便起贡高大慢。世尊为彼说。当乞食。彼乞食已。数数食至时。以是废学。世尊教彼当一食。如所说

  人当有念意　　每食自知少
  则是受用薄　　节消而保寿

彼一食已着于食。便作是念。世尊唯听饮浆。而求种种浆。以是废学。世尊教彼。汝得如是苦处当舍浆。渴者水亦能除。当受持过中不饮浆。彼如是少食知足已。复乐澡浴涂身。世尊教彼。此亦是食想贡高。所以者何。身者从食中生。虽有极肥亦当弃冢间。是故汝当乐冢间。观于冢问。从食所有烂坏散。膖胀脂血流漫。见已灭此贡高。如是乞食满。是谓善损。问云何伏根。答伏根者不害守降。伏根者能制诸根是伏根。是三种不害守降。问不害何等。答前已说根。害根者不能调根。如马虽断水谷无道不调。饱以水谷以道则调。如是害根不调。摄诸根则调。若害根谓调是盲者离欲。是故莫害根。但正御于境界。正思惟摄。即得守。如所说

  诸根至境界　　当远离众想
  不可害境界　　但除其染着

降根者。若见极妙女色。便起如母想。是谓三种伏根。近行禅者忍名想。近于思惟故曰近行禅。问为近谁。答如前说善胜。问如前已说四禅。何故重说。答前说禅。是趣生死胜。此趣出要胜此。次第观真谛。如人始度旷野。见种种妙好华池若干清泉盈满。及园观种种华树严饰。见已作是念。此非空野中可得。必近城邑。如是行者在生死旷野。淫怒痴烦劳。得真知识故正思惟。观阴界入无常苦空无我时。若欲乐是谓忍。正思惟意不动。是谓名如梦中见亲如镜中像。如是苦观想。是世间第一法。由世尊想。是谓近行禅。彼次第如梦觉。见亲后得圣谛观。亦如是

德品第一真度说竟

问云何名方便。答方便者戒上止智。方便者是道。是趣善胜故说方便。是三种戒上止智。问非为重说戒耶。答前已说。善胜有二种。一受生。二出要。前戒受生。此出要戒义者是习义。问此云何。答戒者正语业命。正语正业正命是三种名戒。正语者。离两舌恶口妄言绮语。正业者。离杀盗淫。正命者。比丘僧食乞食衣药具。是正命余邪命。优婆塞离五业。刀毒酒肉众生。是谓正命。问云何上止。答上止者进念定。上止者满具。复次灭淫怒痴。谓之上止。向彼住故说上止。是三种进念定。于中进者力。若说进当知已说力。复次能作故说进。进者行。此能进至善胜故说进。问此云何。答进者。信勤不舍。信勤不舍是三假名进。所以者何。信增一切善行。在一切善法前。于一切法最第一。如所说

  士有信行　　为圣所誉　　乐无为者
  一切缚解

是三种信。问云何三种。答信者净欲解。是信净欲解。于中净者。除浊故。浊者人所恶。恚贡高无惭无愧比。譬如象水牛等混乱泉水。是说浊。停住便澄清。如是人恶恚贡高无惭无愧比乱意谓之浊。无是谓之净。欲者爱乐于胜。如人为病所困不欲好食。病差已而欲得。是人为恶所困。不乐欲闻法。得善知识已乐于法。便作是念。此法极微妙。更复说是名为欲。解者执持。譬如人为毒蛇所螫。师咒毒时彼意至到。便作是念。实如说咒。从此必差已。意解便求药。如是人为淫怒痴蛇所螫。世尊为彼慈心说法。彼若意解者无异。彼心得除淫怒痴。余者不除是解。问是信云何勤。答勤者起习专。起习专此三种谓之勤。起者始造善。如钻火时造众火具。习者数数作。专者着不舍不散意成一缘。如救头然。是三种谓勤。问曰。何不舍。答不舍者。不止不厌不离。不止不厌不离。此三谓不舍。不止者。一切时不远。我极精进不废是不厌。我一向勤久时烦劳。或有果或无舍置何用。若以此不舍精进。是谓不舍。此三事必获得果。如行人爱乐所至方。问已说进云何念。答念者身痛心法。内外俱不忘。内外俱不忘。是三种念为自己内。余者外。二事为俱。复次内者受阴界入。外者他受。及不受俱。复次三烦恼在内在外俱。在内者欲在外者恚。恚者为他非自嗔。若作是念。欲亦为他。此不应尔所以者何。内者染外为他生欲。以内着故。如经所说。人见女如内根痴俱行若灭此三烦恼。是三种念。彼身三痛心法三。是十二种念。问已说念云何定。答定者空无愿无想。空无愿无想。是三种定事空故曰空。问多有空空村空舍。如是比此中。说何等空。答空者我行我作俱不见。我行我作俱不见者。是谓空。问何得不见我行我作。如世尊说。我尔时名随蓝梵志。复如所说。比丘。我手着虚空。答非如是我行。我作是假号。但于五阴中计我是我行。世尊不行此。若于境界计着我许。是名我作。是世尊亦无。如圣法印经说。空者观世间空。如是比彼亦我我所有俱得成。以故无咎。是谓空。问云何无愿。答无愿者。过去未来现在不乐立。无愿者不立义。是入此三中过去未来现在。是一切有为。如说处经所说。彼若作是意。我及涅槃。彼不摄是三。此不应尔。所以者何。一无二义故。涅槃者离世一向无缘。彼中无意我者。离三世更无此不可说。是以三中不乐立。是谓无愿。问无想云何。答无想者。事作俱想。离事作俱想。离是无想。如所说。离一切有为。一切者事及作。可作是事。能造是作。如由无明福无福不动作行。彼缘相续有生识是事。无明及行是作。如是一切有为。若离彼是说无想。复次如圣法印经所说。无想者不见其色相。如是一切彼中亦说。此三事作俱离。彼一切是三义。但说异。如言河无水不见水。是一义而说异。空无愿无想亦如是。是谓定。问云何智。答智者见修无学地所行。智者是觉。是三地见地修地无学地。此中见故曰见。问何等见何等。答见未曾见。圣地根力觉道枝及实修者习义。如以淳灰浣衣。虽去垢白净犹有灰气。然后须蔓那华等诸香华熏。如是见地。清净意禅无量诸定。断除诸结尽极勋。是谓修。无学地者。淫怒痴尽无余。是谓无学。问何等于见地智。答见地者。法观未知智。法智观智未知智。此是见地智。于中法智者。是现智义。譬如良医知痈已熟以利刀破痈。然后以指贯通道。令不伤脉而后破痈。彼修行人亦如是。正思惟观欲界苦时。断见苦所断烦恼。然后生第二智。如欲界苦无常。色无色界亦如是。从此比智断色无色界烦恼。是谓见苦三智。欲界爱苦因。是法智即是观智。如是色无色。界未知智。是见习三智。欲界灭止。是法智即是观智。如是色无色界未知智。是谓见尽三智。此道灭欲界苦。是法智即是观智。如是色无色界未知智。是谓见道三智。此十二智见地广当知。问云何修地。答修地者相行种知。相知行知种知。此三修地。问云何相。答相者起住坏。起者生。住者成。坏者败。问漫说于众生涅槃有疑。众生及涅槃。亦有此相。若有者为大过。即有无常。若不者此经有过。应当说起住坏是有为相。答众生者。于相是余不可说。若异即有。常若是即无常。是二过不可说。涅槃亦如是。是故分别当知相者。一向有为相。问今说功德。云何此相是功德。答今说智。若此三中智。是功德非相。问云何行。答行者无常苦非我见。行者尽智是行义。此相由是行知是行义。阴无常。若无常者是苦。若苦者是不自在故非我。无常者不久住。故如水泡。苦者逼迫故如箭在体。非我者不自在故如借璎珞。是谓行。问云何种。答种者味患离。种者是味是患是离。问是谁。答是有为。于中味者是妙。患者是恶。离者俱息。于中天人乐是味。三恶道苦是患。离罪福是离。若如是观正见功德故。故即得解脱是谓种。此是修地智。问云何无学地智。答无学地者达通辩智。达智通智有辩智。是三无学地智。问云何达智。答达者宿命生死漏尽智。宿命智生死智漏尽智是谓达。能达故曰达。达是知义。于中宿命智忆过去所作行。生死智知得业果。漏尽智后当说。复次烦恼有三种。过去未来现在处。过去者十八见。未来四十四见。现在处身见。由此故生故。分别过去未来。于中若得宿命智者。不谤过去。得生死智者不痴。于未来得漏尽智者。不着现在处。问云何漏尽智。答漏尽智者。尽无生愿智。我烦恼尽。观如是是尽智。不复生者。是无生智。譬如师治蛇所螫。知已除毒。是一智。不为前气所熏。是第二智。无生智亦如是。愿智者。若声闻以宿命智。自忆生相续非余。是愿智以愿故亦知他。是谓愿智。问云何通。答通者如意足天耳他心智。如意足天耳他心智。此三是通。如意足者后当说。天耳者。以定力故。处一缘中增长四大净。此天人至恶趣。闻声随其力。如眼或见近或见远。随其眼力。如是随其定力得天耳。他心智者。如见众生若闻声。知彼心念如是如是

问云何如意足。答如意足者。游空变化圣自在。如意足者。得如意故说如意。如意是自在义。游空自在变化自在圣自在。是谓三种如意足。游空自在者。履水蹈虚。能彻入地。石壁皆过。扪摸日月。是谓游空自在。变化自在者。现人象马车。山林城郭皆能化现。圣自在者能化寿化水为酥。化土石为金银。如是比是谓如意足。圣所增长养。如意足天耳他心智是谓通。宿命智生死智。是凡夫五通。问云何辩。答辩者法义辞应。善知法。善知义。善知辞。善知应。此四是辩知法者知名句味。知义者即知彼性实。如火是名彼热。是义于中不痴。知辞者此文饰如是次第。知应者不颠倒说句文饰。亦不差错。是谓辩。此亦于学地智已广说。问如戒及定。学无学地中。亦可得戒定。何以不三种说。答无戒戒差别非为学离杀生。众生极护无学。不如是若学不杀生。即是无学。以是无差降故。不说三种

德品第二真度说竟

三法度论卷上三法度论卷中

        东晋罽宾三藏瞿昙僧伽提婆译

问前说由者具方便果。于中已说具方便。云何果。答果者佛辟支佛声闻。佛辟支佛声闻者。此三是果。问为谁果。答戒上止智。问今说由。由者是道。云何果亦是道耶。答此果说是有余。前说无余。无余般涅槃故。是故无咎。佛者离一切障碍。得十力逮四无畏。获一切佛法。诸佛戒定慧等无差降。辟支佛者为自觉不为他。而自觉故说辟支佛。声闻者由他说。复次解脱具有二种。一者悲。二者厌。若从悲具得道者是佛。厌具有二种。一者由自得。二由他得。若自得者是辟支佛。若由他得是声闻。复次若普知尽具功德。离诸恶者是佛。辟支佛者虽离诸恶。余事不如。声闻者缘他离诸恶。问云何知诸佛无差降。声闻亦为不。答声闻者。离欲未离欲。阿罗汉声闻有差降。分别相故。信首五根有软中上依。是诸声闻有差降一切诸地。问云何离欲。答无欲者。信解脱见到身证。以信为首度故曰信解脱。以慧为首度故曰见到。二俱是身证。是无量种。今当现示。信解脱者。上流行无行般涅槃。上流般涅槃。行般涅槃。无行般涅槃。此三是信解脱。上流者爱彼将至上。复次流者道。彼于欲界将至上故曰上流。行般涅槃者。行谓之有为。多方便及道缘行至无为。故曰行般涅槃。无行般涅槃者。无行谓之无为。少方便及道。缘无为至无为。故曰无行般涅槃。是谓三种信解脱。问云何见到。答见到者。中生般涅槃。亦上流见到。亦三种。中般涅槃。生般涅槃。上流般涅槃。中般涅槃者。此命终未生余得道。中般涅槃如小火迸未堕已灭。此义亦尔。生般涅槃者。如火迸堕地即灭。如是始生次第得道般涅槃。上流如前说。此无色界亦如是。此三是见到。问云何身证。答身证者。行无行生般涅槃。此前已说。问非为。重说耶。答不。界异故离欲。界及离色界故。是二种尽除中阴。非有无色界中阴。复次前说无解脱。身证者有解脱。解脱后当说。问是离欲云何未离欲。答未离欲者第八须陀洹薄地。第八须陀洹薄地。此三是未离欲。问云何第八若数者应第一不第八。初向后至阿罗汉云何此是阿罗汉耶。答不当观。如人有八。儿彼非以长为第。八以幼为第。八如是世尊功德子有八。彼阿罗汉为长。诸漏已尽故。谓初向为幼。是以说第八。问是云何。答第八者信慧俱。此族姓凡人时。有如是具信及慧。彼或信胜慧随。或慧胜信随。或等是生法智。已从信行为钝根。从法行为中根。俱行为利根。此三是第八。已见谛若信为胜。是极七慧胜者中。俱胜者家家。此是见地。若升修地者在薄地。信胜者一往来。慧胜者中。俱胜者一种。若离欲界欲。信胜者信解脱。慧胜者见到。俱胜者离色得身证。若一切漏尽。信胜者慧解脱。慧胜者俱解脱。具得解脱。俱胜者亦俱解脱。复次信胜者钝根。慧胜者中根。俱胜者利根。如是次至上。问已广说第八。渐渐生功德林。而不知此何谓。当为显示。答须陀洹者。极七家家中。须陀洹者。是三种。住初果求第二须陀洹者是道。升是道故谓洹。身见戒盗疑断恶趣尽。钝根极七受天人中乐。要般涅槃。家家者亦住初果。三结尽。思惟所断少尽。是于此中生。从家至家而般涅槃。中者此二中非一向从家至家般涅槃。亦不一向极七天人生般涅槃。而于中间般涅槃。问是须陀洹。云何薄地。答薄地者。一来一种中。欲界结薄住。故曰薄地。此三一来一种中。一来者此终生天上。一来而般涅槃。一种者。受一有而般涅槃。增益功德故。中者此二俱。是三谓未离欲。问云何阿罗汉。答阿罗汉者利钝中根。阿罗汉者是说供养名。堪受供养故曰阿罗汉。问谁堪受。答为一切众生。故说阿罗汉。是阿罗汉三种。利根钝根中根。问云何利根。答利根者。住法升进不动法住法。升进法不动法。当知是利根。住法者。离方便除烦恼故。故曰住法。升进者。除诸烦恼。求上胜能得。故说升进。胜者达通辩。不动法者。已得胜果。一切谈论不动辩才。是谓利根。问云何钝根。答钝根者。退念护法。退法念法护法。此三是钝根。退法者。或差降退非圣谛故曰退法。或复于修地退。修者修习。说以不修习是名退。如学经已不数习忘。如是不修习修地退。是病业诵和诤远行观故退。以是故名修地。念法者已得阿罗汉。劣行故及身劣。便作是念。我所作以作。我何为住。如是思念思。念者多品数。亦思念财产及裁衣。但此中思念。舍命护法者。不退亦不思念。但极大方便护。如贫多方便得财守。是钝根。问中根云何。答中根者。慧解脱具不具解脱。得慧解脱者下。俱解脱二。一得具解脱。二不具俱解脱者。信及慧。已得此二故胜。问云何解脱。答解脱者。欲色灭尽。解脱欲界色界。灭上心住。及三界尽。是三种解脱。解脱于烦恼。故曰解脱。问云何欲解脱。答欲解脱者。内色无色想。不净亦净。内者自内。是二种有色想及坏色想。于中内坏。色冢间地观腐烂肉段眼脱腹溃肠出。大小便处流出不净。无量种虫交乱其上。乌鸟争食。手脚髑髅。各在异处。见已起无欲。此便作是念。是身以此故众生怒斗诤讼贡高憍慢。起无量恶。如是观已解脱恶上心定。是谓内色想不净解脱。二内坏色想。由定故如无色。如是得立观。他身亦复如上。是谓内无色想。不净解脱净解脱。青黄赤白色华衣等缘。以发意思惟心住不动。是净解脱。此三种是欲解脱。问色解脱云何。答色解脱者。无色离色欲已。四种心住亦复有漏。是谓色解脱。此前已说。问云何灭尽解脱。答心等诸心想应灭。是谓灭尽解脱

    恶品第二

问已广说德品三真度。云何为恶。答恶者恶行爱无明。恶行爱无明。此三当知。是恶污善行故曰恶。此亦污人谓污人。意乐于恶。如猪乐不净。于中初身口意恶行。此众恶初。是三种身口意恶行。恶行者。恶人所行故曰恶行。复次此行是恶故曰恶行。是身所作恶。谓之身恶行。口意亦如是。问云何身恶行。答身恶行者杀盗淫。身恶行当知。是三种杀盗淫。问已知身恶行是三种。云何为杀。答杀者念教作。念教作是说杀三种。余亦如是。如身恶行。杀三种念教作。盗淫亦如是。口业亦如是。问知余亦如是。而未知念云何为念。答念者。心欲欲使他作喜。念名思惟。是三种心欲作欲使作他作喜。如意杀众生是欲作。意使杀是欲使作。他杀已意悦。是他作喜。是谓三种念。问曰。云何为教。答教者诲令可。诲令可者。是谓三种教。诲者如外道说杀猪羊以祠天是诲。令者如王令臣。我有怨敌卿往害之。是谓令。可者如人问某是我怨欲往杀之。彼即然可。是谓可。此三是教。问云何为作。答作者众生想舍断命。作名施行事。若说杀生者。当知诲令可。意恶行亦如是。于中有他众生想舍众生断众生命。是三作具满。医者不晓破痈。若破痈时死者。非以医杀生。彼无害意故。如是三事不具非杀生。是谓三种作。问云何盗。答盗者他物想偷意取。他物想偷意取。是三种盗满。所以者何。设使有他物。非盗意取物者。是我许。以相似故非偷。若他物不偷意取无盗。如取知识物。如是三事。不具非盗。具是盗。是谓三种盗。问云何邪淫。答邪淫者。他法受。非道行邪淫。三种犯他受犯法受犯非道。问说淫是本。以何等故说邪淫。答人有二种。出家及在家。于中出家者行淫。是说恶行。在家淫非恶行。而邪是恶行。若在家淫是恶行者。须陀洹行淫应堕地狱。若不尔者邪为恶行。故经说二种无咎。问云何他受。答他受者。主亲王主所受。亲所受王所受。是一切他受主有二。有至竟有少时。至竟者如方土家法女属主。若淫此女从彼邪淫。少时主者。若女从彼取物。齐限有时。若淫此女从彼邪淫。亲者父母兄弟舅等及养女。若弃女取养。王受者。若无亲无主而受王禀。问云何法受。答法受者。学斋族法。若受学法是学法受。若受斋法是斋法受。若受族法是族法受。是俱中可说。学法受者。若主前听学。后犯者是邪。是谓学法受。斋法受者。若主先听受斋。后犯者是邪。是谓斋法受。族法受者。如前说亲受。但作经者。欲令满三法故。重说族法受。母姊妹女子妇及同姓。是一切不可犯。犯者邪。问云何非道行。答非道行者。女产男不成男。非道行名。若女新产后犯道。是非道行。若以力势犯未嫁女。是非道行。及淫男不成男。是谓三非道行。问此说不具。所以者何。此中更有余邪淫。此说云何摄彼。若不摄者。是故此说不具。答此说已具。所以者何。前已说离产时女。若说女当知已说畜生。若说离产者。当知已说余行。是故具说。问此恶非义从何而生。答尽从淫怒痴生。彼一切当知从淫怒痴生。问云何一切为杀盗淫耶。答不但是。若但说是作经者。应当。说即是但摄一切。故当求经本。一切身口意恶行当别说。问云何此从三恶中生。此中有咎。所以者何。非以乐痛苦痛一时生。亦非以嗔乐痛所使。淫者说乐习。欲者淫。此中云何嗔。答非为说从淫生嗔那。此中说本愿。为爱牙毛故起嗔杀。如是前发恚。彼犯我妇我亦报彼。而后行淫起爱。但本愿从恚中生。欲从彼生故是故无咎。余亦如是。问前说一切从淫怒痴生。于中已说身恶行。但不知口恶行是云何。答口恶行者。不实不虚绮语。口恶行者四种。但撰三法故。当知是三。是三亦显示四。问云何不实。答不实者。为己他利讳实。若不实口恶行。是为己故。他故利故意讳实。讳实者意覆藏。如意知已口说异是。说三种为己为他为利。为己者自命故。为他者亲故。为利者财物故。是谓三种。如世尊说。在眷属因己因他因利知已妄语。问已说口不实恶行。云何口不虚恶行。答不虚者。不爱别离。俱行不虚。名为不爱。行为别离。行为俱行。行者谓作不爱。行者名恶口。爱故说嗔。是不恶口。若不尔者无非恶口。恶口者为已生。若异者。世尊亦恶口。彼为慈愍。调达说而嗔。是以为不爱行。是恶口。如人瞎呼瞎嗔。虽有实言但以恶意。是故为不爱说是恶行。别离行者。虽有实言。但为别离行故是两舌。若不为别离行。而能别离者。是非两舌。若不尔者。世尊亦当两舌。世尊者慈愍异学故。过度为弟子。是以为别离行故。恶俱行者。即此二事。作不实及不虚。如是恶口是以恶口亦名两舌。问云何绮语。答绮语者。不时不诚无义说。不时说。不诚无义说。是三种绮语。分别为无量。不时说者。应说时不说。不应说时说。如婚姻欢会时。或有人说。某族姓子。一切合会皆归磨灭。万物无常盛者必衰。君速舍此事。彼说此言。佛辟支佛声闻所称。但非时说故是绮语不诚说者。若实想故邪说。如异学说我是萨云若。彼虽有实想但绮语。所以者何。此非萨云若但想尔。若为人说。佛萨云若者是妄语。所以者何。本非萨云若意。无义说者。笑歌舞愁忧说。是谓口恶行。问云何意恶行。答意恶行者。贪恚邪见意所行恶故曰意恶行。是三种贪恚邪见。贪者愿他财物。问若愿他财物是贪者。重说有咎。在念中故彼中说。念者心欲欲使作他作喜。答此说非重。意欲尔故。念者意欲尔欲作。此中不欲作而欲夺他物。贪故令此财物于我有。如是染污意着他财物中。贪者向他物故说贪。恚者逼迫他恶意。问云何邪见。答邪见者。业果相违无见。业相违果相违无见。是略三种邪见。若分别无量。如此异见是邪见。问云何业相违。答业相违者。净不净意。不净净意。俱一意。净不净意不净净意俱一意。是三种业相违。净不净意者。善身口意业不善果。不净净意者。不善身口意业善果。俱一意者。善不善身口意业。善不善果。果亦如是。如分别业分别果亦尔。天上苦涅槃苦。如是比净果不净意。恶道乐生死乐。如是比不净果净意。恶道苦非苦。如是比俱一意。问云何无见。答无见者。业果众生无见。无业见。无果见。无众生见。是谓三种无见。无业见者。无施无斋无说无方便无作善不善业。无果见者。作善不善无果报。无地狱畜生饿鬼。无众生见者。无父母。无众生生世间。无实沙门梵志。是谓邪见无量种。此是三种意。恶行无量种。一切恶所作因。相违一切善所作因。彼前戒中已说

恶品第一真度说竟

问已说恶行。云何为爱。答爱者染恚慢。染恚慢是三种当知爱。爱者求。是三种总说一。问云何为染。答染者欲有梵行着。欲著有着梵行着。是三种染。于中欲者五欲。色声香味细滑。是依三种众生各各着乐。余事不尔。于中欲著者。女男不成男欲着。女欲男。男欲女。及不成男。不成男欲女欲男。问前已说五欲着。今说女男不成男。非为过耶。答女男不成男。女男不成男。是重于五欲中各各着。于余事不尔。如世尊所说。我不见余色爱如是男女色如是五欲境界。是故无过爱。欲有三种微中上。微者男欲。中者女欲。上者不成男欲。是谓欲着。问云何有着。答有著者。欲色无色有。欲有色有无色有着。是谓有着。问如此欲着前已别说。女男不成男。今何以复于有着中说。答有着为众生故说欲着。为烦恼故说。一切欲界法说欲有。若着彼是谓欲有。着色界法说色有。若着彼是谓色有。着无色界法说无色有。若着彼是谓无色有着。是以别说故无咎。问云何梵行着。答梵行著者。得未得失着欲忧。梵行着已得便着。未得便求失便忧。以此义亦应说欲有着。已得便着。未得便求。失便忧。如是欲有梵行着各三应说九。复次得女便着。未得便求失便忧。如是男不成男欲着。亦应说九种。如是有着梵行着。应说二十七。问可得尔梵行着是烦恼耶。答有。如世尊说。三求。欲求有求梵行求。求爱染着是一义。复次如所说。欲及梵行离爱常念。问若尔者梵行不可行。所以者何。有着故。复次若如所说。一切梵行者应有着。答应方便行。如释种所行。释种者行梵行不着梵行。彼离罪福故。行道不以求果。求果者是说着我。以此戒以此苦行。以此梵行生天上。及余如是行着染污求我何时当得梵行。使我生善趣中。若梵行着后世乐。乐爱所持。作非梵行生悔咄我退。是谓忧。是谓梵行着。问云何为恚。答恚者已亲怨故。忿怒已故。亲故怨故。忿怒者是三种恚。问云何恚爱处说。答恚者求恶求非爱耶。是已故四门中行亲怨故。亦四门中行。问此云何。答为己及亲未得乐求已得令不失。已得苦欲舍。未得不欲令得。如是己及亲四种为怨。未得苦欲使得。已得欲令不舍。未得乐欲使不得。已得欲使速失。是谓为怨求恶是恚。是以爱处说恚无咎。问云何为己故答。为己故者。三时求不利。三时名过去未来现在。如所说。彼为我求不利。当求不利。今求不利生恚。是谓为己三时求不利生恚。问云何为亲。答亲亦如是。如为已三时求不利生恚。如是为亲三时求不利生恚。问此云何。答如所说。若我亲爱彼为此已求不利。当求不利。今求不利生恚。是谓亲。问云何怨。答异怨家异。如所说。如我怨彼为此。已求利当求利今求利生恚。如是为怨求利。三时生恚。是谓九种恚。问此恚三恶行中恚何差别。答此依方便生。恶行恚者。当知从无智嗔。问一切众生九种恚为等不。答此住如画水地石。此恚随众生。当知如画水地石。众生者若干种。当知恚有软中上。如画水即时坏。画地少时。若风雨及余因缘乃灭。画石至石住。无石乃灭。如是众生若干种恚。或始生恚时便自责。我不是众生者自然灭法。无量苦所逼自当灭。我无辜坏他故生恶意。如是彼嗔自止如画水。或复生恚不能自制。若师善友慈愍呵责乃得止。如画地。或复恶意不正思惟生恚。彼佛辟支佛声闻不能止。与身俱灭如画石。是谓恚。问云何慢。答慢者卑等上起意。以此猗故曰慢。复次称量彼彼故曰慢。是三种我卑起意。我等起意。我上起意。若有色富族术。我不如彼。故曰我卑起意。若有色富族术。我与彼等。故曰我等起意。若有色富族术。我于彼胜。故曰我上起意。问已说卑等上慢相。云何知此真度。分别一切慢。慢有无量种。如粗杂中说。答卑者邪不如极下慢。卑慢者三种邪慢。不如慢极下慢。邪慢者我极作恶业。起贡高。不如慢者。受他称叹赞说善哉汝有大德。闻已内怀欢喜。于我云何得无尔乎。极下慢者。懈怠作是念人不能趣胜。是三卑慢。问云何等慢。答等慢者。我贡高不敬慢。等慢三种。我慢贡高慢不敬慢。我慢者。见五阴是我。已于恶中计功德。贡高慢者。受他恭奉。不敬慢者。不敬师长。是谓三种等慢。问上慢云何。答上慢者。大慢。慢大慢。增上慢。大慢者。于卑及等我胜生慢。慢大慢者。于胜我胜生慢。增上慢者。于未得胜谓得生慢。是谓三种上慢。是一切慢从爱乐忧惧生。是以爱处说

恶品第二真度说竟

问已说爱云何无明。答无明者。非邪或智非智。邪智或智者。此三种是无明。无明者痴假名。是分别字者说彼毁訾而立名。如人有恶子说无子。如是此无明恶明故说无明。问此云何。答非智者。有为无为不可说不知。有为无为不可说不知。是谓三种非智。问二种有为受及不受。此中何者定。答有为者。受不受俱。若非智者。当知受痴不受痴俱痴。于中受者。阴界入二种自受他受。不受者。草木墙壁比。于中若他受若不受者。是当知不受。此中一一痴闇。是谓非智。如世尊说。六更入非智不见。如是广如经所说。受名者取义也。因业及烦恼痴意计我是我所。是名受。问无为是涅槃。是一云何说三。答无为者。有余无余俱。虽涅槃一无为。但事故说二种。有余及无余。有余者。业及烦恼所受身。是说有余。彼断一切烦恼尽。作证已故有余。是说有余。无余者。若此受阴舍。更不相续如灯灭。是涅槃此名无余。于中一一及俱痴。是无为不知。问云何不可说。答不可说者。受过去灭施设。受施设。过去施设。灭施设。若不知者。是谓不可说不知。受施设者。众生已受阴界入。计一及余。过去施设者。因过去阴界入说。如所说。我于尔时名瞿旬陀。灭施设者。若已灭是因受说。如所说。世尊般涅槃。复次过去施设者。制众生断。灭施设者。制有常。受施设者。制无。不受施设者。制有。彼中一一无知。是谓不可说无智。问已说无智。云何邪智。答邪智者。身边盗见见身见边见盗。是三种邪智。邪者是颠倒。非如不真同一义。身见者。我是我自在。我必尔。是我必尔。自在必尔。是身见。我必尔者。阴幻化野马响水月形相似五阴。计着是我。是我必尔者。假借璎珞树果怨相似五阴。计是我所有。自在必尔者。芭蕉树水泡沫相似五欲境界。计自在。如空聚邑。身见者。是身我所有见。如是谓三种身见。问云何边见。答边见者断常俱断常。俱是三种边见受。边者非以道理是边见。于中断常者。世间有常无常非有常非无常。有边无边非有边非无边。众生有终众生无终。非有终非无终。是身是命如是比。俱者有常无常有边无边。有终无终如是比。是谓三种边见。问云何盗见。答盗见者。戒见依。彼盗见从三中生。一戒二见三依。彼于中戒第一。真度已说。由此戒得清净及受戒。是谓二种戒盗。此真实余虚非真。是谓见盗计是真必尔。是亦说见盗。身缚依彼者。若依戒及见是五阴。由此故或戒或见计五阴净。当知是戒盗计五阴第一非余。当知见盗是依彼。是谓三种盗见。问云何惑智。答惑智者。宝谛定中不了。宝不了。谛不了。定中不了。不了者不决疑。犹豫同一义。问云何宝。答宝者佛法僧。佛宝法宝僧宝。当知是三宝。佛者普智。成就一切功德。离一切恶。问佛以何故名宝。答以此功德故。复次大慈大悲故。不空说法故。无事亲故。难出世故如优昙华。如是不可计功德成就故说宝。法者方便及方便果。但此中说涅槃是法宝。彼佛处在一切法上。如经所说。若有法有为及无为者。彼无为涅槃是第一。此宝不败坏故。灭诸苦故。至竟冷故。难得故。不可尽故。如是比故说宝。僧者前声闻中已说是宝。广福德故。不违世尊教故。无上福田故。世尊称誉故。不败坏故。和合无诤故。如是比无量功德成就故说宝。问已说宝。云何为谛。答谛者等相第一义谛。等谛相谛第一义谛。是三种谛。谛者实有谛真谛不虚谛如谛故说谛。等谛者。方俗族学举。方俗举族举学举。是谓三种等谛。行种种事故曰等谛。行种种事者是智义。于中方俗举者必尔义。此事是我许某事某名。如水润渍泽。如是比如是所举。是谓等谛。族举者是我家法。学举者。以威仪礼节为行及解经想。复次昼食不夜食。不截草夏不行。如是比行是谓等谛。问云何相谛。答相谛者苦集道。苦谛集谛道谛是三相谛。以谛相观故相。谛相者说生老无常。相者说幖帜。于中逼相苦谛。转成相集谛。出要相道谛。灭者无相。此当别说。复次苦谛者阴界入。集谛者淫怒痴。道谛者。戒定智是谓相谛。问云何第一义谛。答第一义者。作字念至竟止。作字及一切念至竟止。是谓第一义谛。作者身业。字者口业。念者意业。若此三至竟灭。是谓第一义谛。是涅槃义。问如佛说偈

  一谛无有二　　若生生于惑
  观众谛难陀　　是不说沙门

如四谛云何说一。答此第一义故。说无有二涅槃。如此偈所说

  观众谛难陀　　是不说沙门

以此半偈可知。不说余谛无咎。问已说谛。云何为定。答定者色无色无漏定。色定无色定无漏定。是谓定。定者定心行义。于中色定者。色界禅无量除入。初第二第三解脱。及初八一切入。无色定者。四无色二一切入。无漏定者。空无愿无想。无漏禅无漏。无色定无漏。前五想及断界定。此一切不决疑惑犹豫。是谓惑智。此亦是苦非苦。集尽道非道惑。如是四谛。欲界色界无色界。是十二种。于此惑智如爱处所说。无智处所亦说邪智邪见。前意恶行中已说。见盗亦如是。身见边见。在苦三界。戒盗在苦道三界。复次爱亦思惟断如是。分别说九十八使

恶品第三真度说竟

三法度论卷中三法度论卷下

        东晋罽宾三藏瞿昙僧伽提婆译

    依品第三

问已说德及恶。云何为依。答依者阴界入。阴界入者此三是依。可依故说依。可依者是立义。众生于阴界入作依行德及恶。是故当知此是德恶所依。问云何为阴。答阴者色行知。色行知者。此三当知是阴。阴积聚束同一义。于中青黄赤白粗细长短方圆比。当知总是色阴。于中色者四大及四大所造。可见不可见。是说色阴。四大及造色者。是二种可见及不可见。可见者谓眼所见。不可见者是声香味细滑。眼耳鼻舌身及四大。问说色者四大及四大造。此中四大尚不知。况复四大造。云何为四大。答大者地水火风。此地水火风假名是大。是色一一及合。于中坚相地。湿相水。热相火。动相风。彼造色者。烟云雾影闇明日五色五情如是比

问已说色阴。云何为行。答行者依身口心。此依于身故说依身。依于口故说依口。依于心故说依心。依身口心作行。作有为行故说行。如佛契经说。色者有为行。彼复更作如子复造子。如色当知五阴亦如是。彼无量种无量合作已。谓之五阴。如谷聚。行者福非福不动。是三说行。问云何为知。答知者痛想识。此三是知亦说道法。以道不相离故。如世尊说。若痛者即是知。问云何为痛。答痛者乐苦不苦不乐痛。痛性说痛。痛无所由痛痛。即能痛。若痛有由者。应有异命。若即能痛者。应即是命但痛非命故。痛性是痛。是分别字者。说此痛三种。乐痛苦痛不苦不乐痛。是各各相缘。缘乐痛有苦痛。缘苦痛有乐痛。缘俱有不苦不乐痛。如世尊说。乐痛与苦痛对。苦痛与乐痛对。乐苦痛与不苦不乐痛对。对者是怨敌义。问云何乐痛。答乐者欲不恶无著生。乐痛者有三种。欲生不恶生无著生。于中欲生者行五欲悦乐。不恶生者。不恶名说不增恶。是行善无欲戒。于戒不悔意由此悦乐。无著生者。伏根离五欲。无乱意行禅无量等时悦乐。是说无著生。无著名不着。于根义亦复说不染。是说乐痛三种。问云何苦痛。答苦者生老死。生老死者此三是苦痛。于中生苦如生痈。老苦如初发痈。死苦如已发痈深入骨节中。复次生故有一切苦。故曰生苦。如世尊说。生故有截手足如是比。老苦者色壮力坏故。死苦者爱相别离故。是谓苦痛。问云何不苦不乐痛。答不苦不乐者三界。若不苦不乐者。当知是三界。不苦不乐者。障碍于苦乐。是三界后当说。若使不苦不乐是三界。制前说苦乐。当知非以乐苦三界。欲界三痛。色界二乐及不苦不乐。无色界一不苦不乐。是故不苦不乐当知三界。问是痛为何依。答乐者多欲所依。苦者多恚所依。不苦不乐者多痴所依。所以者何。有乐痛无欲。能除欲如三禅中苦痛。无恚如世尊头痛及伤脚不起恚。不苦不乐。觉第四禅及四无色定。彼中无痴能除痴。若尔者随义可得说。问彼从何生。答彼业逼界生彼乐痛苦痛不苦不乐痛。当知从业生逼生界生。非自然非偶尔。问业者无量种。此中说何业。答业生者。福非福不动。此乐痛苦痛不苦不乐痛。从此三业福非福不动中生。如义乐痛从福生。苦痛从罪生。不苦不乐痛从不动生。于中福者能除恶行。是四禅为首。非福者是恶行。不动者第四禅及无色。问如前已说。福者施戒修。修者即是禅无量及无色。今云何别说乐痛从福生。答别说无咎。以众多聚故此别说。禅如所说。与比丘三衣别。与佛护钵不可以佛护。亦是比丘故。与三衣钵。而比丘异于佛护者。应与彼衣。如是修者禅无量无色。福者三禅。若不分别三禅。于修应有过。众多聚故。问云何逼生。答逼生者。己他俱逼生痛三种。为己为他为俱。逼者二种。为乐为苦。于中为己者。如以刀自刺。若后以旃檀药涂。为他者。如击破他头复治以药。为俱者。如语人使击破我头已复以药涂。如是尽当知是谓逼生苦。问云何界生。答界生者时恶患。问界者已说欲色无色界。云何即是耶。答此非界者。离众生是三种想。时恶患。此界是假想。于中时者夏冬春。夏冬春者。当知此三是时。夏者澹增长。冬者涎唾增长。春者风增长。如医方说时故有乐痛。是谓三时。问云何恶为恶行爱无明耶。答不破坏法身。此说坏四大身。问云何恶。答恶者风澹涎唾。此风澹涎唾坏四大身。由是故生痛。问云何患。答患者众生因离患多。若众生因离生苦。墙壁树山岩崩。因者因己他俱是谓痛。问云何想。答想者有想无想无所想观差别。想者说是受形像差别。此中有想无想无所想观差别。是同一义。于中有想者俱依。无想者不俱依。如众多瓶。或有人说。是蜜瓶是酥瓶。由此想故想。若无蜜无酥。是空受空想。如是声想比受差别。若遣声比如是受。无所想者。此无所有即舍。复次有欲说有所有。是有欲说解脱处观已无所有。复次有想者。观善识处。无想者观非想非非想处。无所想者观无所有处。问云何识。答识者生成不成入。行名色俱依缘可得。识者异种智故说识。种种智故说识。是三种生成入不成入。依行依名色依二缘。可得是三种。世尊十二缘起中说行缘识。复说名色缘识。复说眼色缘生眼识。于中种种行造生时。入母胎网俱生识。是谓行缘生识。即于母胎中渐厚成诸入。已生识是名色缘识。复次成入。诤不诤入。定不入定。缘根及根义生识。是依二缘。缘者是依。不可无依而生识。是谓俱依缘可得。问如前已说戒定智。何以复重说识。答依智及所依是二种。此是依彼是所依。复次如说戒二种。如是此中亦说二种无咎

依品第一真度说竟

问已说阴。云何界。答界者欲色无色界。欲界色界无色界。此三是界。持是业故曰界。于中住业故曰界。是摄一切众生。至无余般涅槃。问云何欲界。答欲界者人天恶趣。人天恶趣者此略说欲界。于中住欲故说欲界。持欲故说欲界。问云何为人。答人者男女命根所观相。依四洲男根所观相。女根所观相。命根所观相。当知此一切是人。是一切亦依四洲。于中女相谓之女。男相谓之男。问命根所观相。非为男女。是以命根别说耶。答虽有男女命根所观相。此中说差别。不成男者。不在男女根。所观相中但有命根。所观相住膜渐厚有命根。而男女根未成。是谓差别。问云何四洲。答洲者。阎浮提。弗于逮。瞿耶尼。郁单越。是说四洲。于中阎浮提所观相故。说阎浮提。随方所观相三。弗于逮瞿耶尼郁单越。彼寿随其数。乐具差别有限。展转有胜问天者。总名二种天。欲生及离欲。此中云何说天。答天者细滑说视欲生。说欲生者当知不说离欲。欲生天者三种。细滑欲生。说欲生。视欲生。说欲生者。化乐天。彼若染污心。于染污心天女共语言。彼于尔时便成欲。若一染污意者不成欲但欢乐。如此间人捉时欢悦。彼亦如是。不染污意如母女。造化妙境界悦乐于欲。故曰化乐天。视欲生者。他化自在天。彼若共天女各各染着相视。彼于尔时成欲若一染着意不成欲但欢乐。如此间人抱时生乐。不染污意。如见他人。他所化自在故。说他化自在天。问是说视欲生天。云何细滑欲生。答细滑欲生者。两两相抱执手。细滑欲生天三种。两两欲生。抱欲生。执手欲生。于中两两欲生后当说。抱欲生者。炎磨天(炎磨天晋曰时分天也)彼各各染着意。若抱时便成欲。一染著者不成欲但欢悦。如此间人相抱生乐。不染着意如他人。夜时时欢喜说乐故曰炎磨。问云何执手欲生。答执手欲生者。兜率哆天(兜率哆天晋曰知足天也)彼若共天女各各染污意执手尔时成欲。一染着不成欲但欢悦。如此抱时生乐。无染污意如他人。自所有境界知足故说兜率哆。问云何两两欲生。答两两欲生者。三十三四王地。两两共事故。曰两两欲生。彼一切欲事。具如前所说。但分别故说两两欲生天。如此间人于中三十三天者。在须弥山顶。彼行欲如人。四王者处中。地天者依此地树山间居。爱乐乐境界。是一切名天行欲。如人间无不净而有气。居止转倍上。是谓欲界天。问云何恶趣。答恶趣者。地狱畜生饿鬼。此三是恶趣。此趣恶故曰恶趣。恶者不可爱故曰恶趣。问云何地狱。答地狱者。寒热边地狱寒地狱热地狱边地狱。狱者不可乐故曰地狱。是无量种今当说。问云何寒地狱。答寒地狱者。了叫唤。不了叫唤。不叫唤。是三相观相寒地狱。了叫唤。不了叫唤。极恶唤呼故曰叫唤。问云何了叫唤。答了叫唤者。阿浮陀。泥罗浮陀。阿波跛。阿浮。泥罗浮陀。阿波跛者。此三是了叫唤。阿浮陀者是说数。如摩竭国十芥子仓。各受二十佉梨。满中芥子。假使有人百年取一犹可尽。阿浮陀地狱寿不可尽。二升名一阿勒。四阿勒为一独笼那。十六独笼那为一佉梨。二十佉梨为一仓。如是至十。阿浮陀地狱寿数。当知余各转倍。复次阿浮陀者似痈。阿浮陀地狱中由寒身中生似痈故。曰阿浮陀。泥罗浮陀者不似痈。但举身风吹胀满故。说泥罗浮陀。阿波跛者。为极寒风所吹。剥身皮肉落急战。唤阿波跛故。曰阿波跛。此三种了叫唤。问云何不了叫唤。答不了叫唤者。阿吒鸺吒鸺优钵罗。阿吒鸺吒鸺优钵罗。此三是不了叫唤。于中阿吒鸺吒鸺者。亦为极寒风所吹。剥身皮肉落。彼不堪苦。或时大方便唤阿吒鸺吒鸺优钵罗者。极大寒风吹剥身皮肉落。因罪故自体中生铁叶缠身。如优钵罗华。彼以诽谤贤圣人故。堕优钵罗地狱。常受如是苦。问云何不叫唤。答不叫唤者。拘牟陀须。揵缇伽分。陀梨伽。波昙摩。此四是不叫唤。而极寒风吹身胀满。使身如拘牟陀须揵缇伽分陀梨伽波昙摩。受困苦极呻吟住。彼以诽谤贤圣人故。堕彼四种地狱。一切时受无量苦。是一切十寒地狱。处在四洲间。着铁围大铁围山底。仰向居止在闇中。寒风坏身体。大火所然。身如烧竹[竺-二+韋]林声驳。驳各各相触生想。亦复有余众生于中受苦。彼一切谤毁贤圣故。受如是苦。如世尊说偈

  泥罗浮有百千　　阿浮陀三十五
  是圣恶趣地狱　　口及意恶愿故

是谓寒地狱。问云何热地狱。答热地狱者。有主治少主治无主治。此三相观相有主治少主治无主治。主治者是考掠。此多为众生所治。或不多为所治。或自治。或由罪自生。或离众生方便受大苦。问云何有主治。答有主治者。活行黑绳。活行黑绳此三是有主治。活地狱者。狱卒以利刀斧。解剥剉斩罪众生。如斩剉羊头。皮肉解散已。彼罪缘未尽以冷风吹还生如故。复因恶罪手自然生铁爪。锋利犹若刀刃。形如半月。各各生怨结意彼曾逼迫我。今复逼迫。由此生恚。更相爴截也。如刈竹[竺-二+韋]。彼于此间结恨心死故生彼中。黑绳地狱者。挓罪人着地。以黑绳絣段段斫截。彼于此间以刀斫众生故生彼。复次以热赤铜铁鍱。缠身骨破髓血流出。彼于此间以鞭杖加众生及出家。不精进受着信施衣故。生彼极大暗冥苦烟熏。倒悬身使吸烟。彼于此间以烟熏穴居众生故。行地狱者行列罪众生。如屠肆者。截手足耳鼻及头。本为屠儿故受如是苦。复次热铁地驾铁火车。狱卒乘之张眼[口*戒]唤叱叱便走。彼于此间乘象马比驱。使疲劳故堕彼中。淫犯他妻。驱上剑树自然火然。受如是苦。是谓有主治地狱。狱卒者以行缘故。不被火烧。行报者不可思。问云何少主治地狱。答少主治者。众合大哭铁槛。众合大哭铁槛。此三是少主治地狱。众合地狱者。罪众生畏地狱卒。无量百千走入山间。入已前后自然生火遮彼。为火前后遮已。两两山自合如磨。由此故血流如河。骨肉烂尽。彼于此间喜磨众生为首。复次火烧大铁臼。以杵捣百年。彼以罪缘故命不尽。彼于此间以臼捣杀蚤虱。及殛杀故。大哭地狱者。大铁山遍火然。四绝无行处。恶狱卒无慈。嗔恚言欲何所趣。无事与事。以火烧铁杵击破其头。彼于此间因苦万民故生彼中。铁槛者。火然铁地。驱罪众生使入中熬令熟。熟已复驱出。为恶狗所食食肉尽。风吹使生还复如故。复已还驱使入。彼于此间养蚕煮炙故生彼中。是谓少主治。问云何无主治。答无主治者。哭炙无缺。哭炙无缺者。此三是无主治。哭地狱者。火炽然铁似如龟甲。处极狭迮。各盛在中以铁盖覆。受如此极苦。彼于此间焚烧旷野。及薰烧穴居众生故生彼中。炙地狱者。大铁山火焰相搏。以铁铲铲之。周匝猗炙。一面适熟。铲自然转反覆颠倒。彼于此间贯刺杀人故生彼中。无缺地狱者。铁地周匝火然。纵广百由旬。四门如城。以铜薄覆上。炎炎相续。罪众生在中积聚如薪。炎无挂碍。燋烂其身受苦无缺。彼于此间杀父母真人。恶意向佛使血出斗乱众僧。及作增上十不善业迹故生彼中。是谓无主治。问云何边地狱。答边地狱者。所在处水间山间及旷野。独一受恶业报。是谓边地狱。问已说地狱。云何畜生。答畜生者。陆水空行。一切无足二足多足。陆行水行空行。此三是畜生。陆行者。象马牛羊驴骡骆驼为首。水行者。鱼摩竭失收摩赖为首。空行者。鸟及蚊蚋为首。一切无足二足多足。无足者蛇为首。二足者鸟为首。多足者牛马蜂及百足为首。彼一切种种大罪业行生彼中。是谓畜生。问已说畜生。云何饿鬼。答饿鬼者。无财少财多财。无财少财多财者。此三种是饿鬼。问云何无财。答无财者。炬针臭口。炬口针口臭口。是三种无财。炬口者。合口猛火炎从口出自烧。如野火烧多罗树。彼于此间多行悭贪故生彼受苦。针口者。腹大如山谷。咽如针孔。设得丰饶食而不得食。臭口者。口烂腐臭。如粪厕自噫气臭。无腹不得食受大苦。是谓无财。问云何少财。答少财者。针臭毛[癭-女+瓦]。针毛臭毛[癭-女+瓦]者。此三种是少财。彼或时少得不净物故说少财。针毛者。毛极坚长头利如针覆身。遍满自体节节相离。行来甚难毛还自刺。如利箭射鹿。受极大苦。或时少得食。臭毛者。毛极臭覆身。更互自刺体。身臭风发恼生。嗔恚自拔毛。受如此苦。[癭-女+瓦]者。自罪业报生[癭-女+瓦]。还自决破脓血流出。取而食之。是谓少财。问云何多财。答多财者弃。失大势。弃失大势此三种是多财。弃者若宿命施故得残。彼终身祭祠得。由此故得乐。失者。街巷四道所遗落者。彼终身得。由此故得乐。大势者。夜叉罗刹毗舍遮。夜叉罗刹毗舍遮。此三种是大势。彼境界如天。宿命福德故。或得妙食。食已无量饿鬼围绕相见生苦。如人在狱见亲生苦。彼亦如是围绕生苦。由此苦故食化为脓。受如是苦是谓大势。彼畜人天形。是饿鬼畜形人形天形。随其业故。是谓欲界。问已说欲界。云何色界。答色界者。有喜无喜护。色界者无欲。但由禅除恚故。得妙色如炼真金。是界有喜无喜离苦乐是护。喜俱乐故曰有喜。离喜不喜俱乐故曰无喜。是离苦息乐如马息驾。问云何有喜。答有喜者。有觉无觉少观。俱觉故说有觉。离觉故说无觉。少有观故说少观。乐者离是说禅。于中有觉者是初禅。无觉者是二禅。少观者是初中间。习此禅生色界中。说众生为说界。说界为说禅。问谁习有观禅生。答有觉者。梵富楼。梵迦夷。梵波产。习有觉禅生彼中。梵富楼梵迦夷梵波产。此三种是有觉。软中随其生。大梵者。由少观生。觉观义前已说。问云何无觉。答无觉者。少光无量光光耀。觉习无觉喜乐相应禅。是生三种天。少光无量光光耀。此想或是假想或因想。复次少光者。语言时口出少光。光少故说少光。光多故说无量光。净光无边故说光耀。问已说有喜。云何无喜。答无喜者。少净无量净遍净。觉习无喜乐相应禅。是生三种天。少净者。是不多名。此少方便相应禅。生少净天受乐。亦少中方便。生无量净天。上生遍净天。问已说无喜乐。云何护。答护相应三种。一有想。二无想。三觉意相应。彼护者。果实无想净居。修习护乐相应禅。生彼中故说护。是三种果实天无想天净居天。于中果实者。修习微中上第四禅生果实。无想者。灭想故生无想。彼灭痛想识。以无欲想故俱灭。唯有色阴行阴少人生想便死。问云何净居。答净居者。善现善见净。善现善见净。此三种是净居。净居者。诸烦恼尽居。问五净居地。今何以说三。答净者无烦无热色究竟。无烦无热色究竟者。此三是净相。作经者意欲尔。问已说色界。云何无色界。答无色者。前修中已说。彼于是间修习正受。生无色界。是道及果俱说

依品第二真度说竟

问已说阴界。云何为入。答入者。细滑度解脱入。细滑入度入解脱入。此三是入相。入者依如天庙。问彼为谁入。答德恶入。于中解脱入者。是德所依。度入者。是恶所依。细滑入俱所依。染污意生恶。净意生德。问云何细滑入。答细滑入者。近境界不近境界无境界。细滑入是近境界不近境界无境界。境界者是缘处。随其缘行是彼境界近缘。说近境界。不近缘说不近境界。无缘说无境界。问云何近境界。答近境界者。鼻舌身入。鼻入舌入身入。是三近境界。香至鼻闻不至不闻。虽有华极远。但香离华来至鼻闻。香者性色。是以因北风香至南不至北。是以香离华来至鼻闻。味亦如是。着舌知味不从器不从手。细滑亦如是。身根所觉是八种。坚软轻重粗涩寒热。由彼彼种细滑而后觉。是故彼三近境界。问云何不近境界。答不近境界者。眼耳意入。眼入耳入意入。是三不近境界。问眼亦近见少不逼境界。耳亦如是。蚊在耳中亦闻声。意是无色。云何知不近境界。答以是故说不近境界。若不逼则受境界。问不近境界为齐几何。答此中无齐限。或有四十千由旬见日月。或不见。或一由旬见色。或十里。随其根力。以是故说不近境界。不说远。但不逼受境界。非以物至见处见。离而后见。耳亦如是。非以逼近故得闻。蚊虽在耳中不至闻处。此亦随其根力闻声。意者无色。彼无近远是以说不近境界不说远。问云何无境界。答无境界者外已受。他受及不受。外者无境界。色声香味细滑法。于此法中假名外。是已受他受及不受。此无境界。但为他境界。此五境界无缘。而他所缘法当分别。是亦多无境界。故说无境界。问已说细滑入。云何度入。答度入者。一处因不正因无因说。一处因说。不正因说。无因说。此三义无量。而略说是三度入。于中一处因者说言。如因陀罗幢众人所举来。于中一说者。调达持来。彼亦在中。但非独调达于此事应说众而说一。一处因说亦如是。三事合成义。或宿命业。或现所作。或由他因。如是三事成义唯说一。不正因说者言。如此因陀罗幢。有人说非一人所持。来亦非二。此中虽有因但不正。无因说者言。如是因陀罗幢。无所因而来。问云何一处因。答一处者。业自他功夫。一说已所作者有二种。或宿命所作。或现所作。于中若宿命所作者是名业。或复有说。天作者。如是三种成义。如前说。如是三种义。或说业者。或说功夫。或说他恩。一处者唯说业。彼负他功夫。不知恩义。不可与从事。若我本所作求以不求。会当自得。一处说者有如是咎。问云何不正因。答不正因说者。众生法俱根因想说。不正因说。三种众生法。俱众生及法根因想。好恶众生所作。或复说法所作。或说众生及法所作。是不正因说三种。但非众生作。非法作亦非俱。问云何众生根因想。答众生者。梵伊摄披罗。谓驶耨说。说者众生作世间。梵造化主。伊摄披罗造化主。谓驶耨造化主。无慧者谓尔。言梵造化者。说梵天造虚空。虚空造风。风造水地。水地造丘山草木。如是有世间。彼一切有过。所以者何。若梵天造空及地者。彼住何处。造此空及地。若即住中造者。是义不然。如是有过。如摄披罗谓驶耨。亦如是。问云何法。答法者。时气自然作。时作气作自然作。此三说法根因。于中言时者

  时节生一切　　一切时节熟
  一切时所坏　　一切世时作

此说有咎。如前一处说中。可求者不求。若不可求求。得者。是时作行非作。莫言有过。所以者何。时者空若空。造物者义不然。如是皆有过

  气亦不能造　　气者无有情
  是谓事无事　　气无有此念
  自然亦如是
  自然若生　　非自然义

若无者非因。若无因生一切。生亦如是自然何差降。若有常者彼何咎。非有常败坏。如是比过。莫言有咎。问云何无因。答无因者性偶无。说无因者。是三种说。性说偶说无说。性者言万物性中生非因他。所以者何。如棘刺利无能利者。如是一切说偶者。言万物偶生。如大水泉原草堕中合在一处。说偶尔。彼偶风来。或吹东西南北。万物生亦如是。说无者言审尔。此中无所有。云何生由何生何处生。此非有所有。彼一切有咎。所以者何。若万物性应生者。生萌牙时。不须作田业。亦不须溉灌。若无此事萌牙终不生。是以万物非性所生。如是一一当止。问已说度入。云何解脱入。答解脱入者。想禅博闻。想禅博闻。此三是解脱入。解脱者灭恶彼解脱。此三入依是得解脱。想者是缘义。依此佛辟支佛声闻得解脱。禅者如第一品已说。当观此义。亦依彼得解脱。问云何博闻。答博闻者说听诵。说者说如所听。听者听如所说。诵者如所闻诵。问博闻者前多闻已说。契经阿毗昙律。此中有何异。复说说听诵。答前三种多闻。应三种受。说时受。听时受。诵时受。世尊弟子四种。有真谛处成有施处。成有止处。成有慧处。成彼是方便。听真谛故得解脱。施处说止止处从禅慧处从诵。是谓解脱处。此三法度正观无挂碍。意欲令见其真渐次得是解脱。得解脱故。慧者学世尊法

依品第三真度说竟

三法度论卷下


三具足经忧波提舍(有释论无经本)

    No. 1534

    三具足经优波提舍翻译之记一卷

施戒闻三备摄众行。是以如来说名具足。法门深邃浅识未窥。天亲菩萨慈心开示。唯显义弗释章句。是故名为忧波提舍。昔出中国今现魏都。三藏法师毗目智仙。婆罗门人瞿昙流支。爱敬法人沙门昙林。于邺城内在金华寺。兴和三年岁次辛酉月建在戍朔次庚午十三日译千百十言。骠骑大将军开府仪同三司御史中尉渤海高仲密启请供养守护流通

三具足经忧波提舍(有释论无经本)

        元魏天竺三藏毗目智仙等译

如是我闻。一时婆伽婆住毗舍离大林精舍。与大比丘僧大菩萨众俱。尔时世尊告无垢威德大力士言。善男子。菩萨有三具足。何等为三。一者施具足。二者戒具足。三者闻具足。善男子。此是菩萨三种具足世尊说已。无垢威德大力士闻心生欢喜。又彼比丘彼诸菩萨闻世尊说皆悉赞叹

如是菩萨三种具足我今解释。以何义故。彼无垢胜无量具足。勤进正出相好严身。过百千日光明世尊。而说是经偈言

  无量种具足　　出身三界主
  第一胜相集　　超日光牟尼
  何所饶益故　　说此修多罗

世尊何故。游毗舍离大林精舍。以何义故。名为世尊。何故世尊游毗舍离大林精舍不于余处。为善男子说此菩萨三种具足。以何因缘。而说如是三种具足不多不少。又复云何菩萨为当唯有如是三种具足。为当更有余法具足。若此说三大海慧经云何相避。彼说菩萨四十具足。所谓菩萨布施具足。乃至菩萨方便具足。弥勒解脱修多罗中言。善男子菩萨满足无量具足。更有大乘修多罗中。彼处世尊为菩萨说无量具足。彼云何避。又复圣者龙树已说偈言

  净道皆具足　　余人不能说
  佛无量智慧　　故能说具足
  佛无边功德　　具足是善根
  若如是菩提　　有无量具足

若余处说菩萨则有无量具足。此修多罗云何相避。善男子者是种姓义。何故菩萨名为种姓。此义须说。以何义故名为具足。施具足者何故名施。有几种施。戒具足者何故名戒。有几种戒。闻具足者。何故名闻。有几种闻。又复施戒二具足。漏闻具足者。则是不漏。以何因缘。以漏不漏二种具足。得一切智不漏之法。此义须说。又施具足几种因缘。戒闻具足几种因缘。又复世尊说三具足。何故初施中戒后闻。此意须说。以要言之世尊示现。云何施具足。云何戒具足。云何闻具足。此皆作难我今解释。何故世尊施戒闻等。无量无垢不可称量布施具足。身如虚空住无垢法而说是经。彼义今说。偈言

  第一施戒闻　　寂正行苦身
  如空胜法持　　具足善光明
  人天礼牟尼　　第一世间觉
  无垢除三苦　　何义说此经

此义今说。发菩提心学菩萨业相应。饶益一切智人示现此义。菩萨既发菩提心已。次满施等三种具足。此菩提业非唯发心。而能证得阿耨多罗三藐三菩提。偈言

  若发菩提心　　悲众生苦恼
  彼相应善业　　佛说此胜经

又复何义佛说此经。为怯弱者除怯弱故。为彼始行菩萨行者。闻修无量种种法故。尔乃获得阿耨多罗三藐三菩提生怯弱心。佛知彼意为除怯弱饶益彼故。而说是经言。善男子。菩萨唯有三种具足。世尊示言汝勿怯弱。若我广说过不可数菩萨具足。以要言之三具足摄。偈言

  若有诸佛子　　畏经无量劫
  怯弱于善法　　久远得菩提
  如来自然智　　安慰饶益彼
  是故第一觉　　说此修多罗

又复何义佛说此经。菩萨欲得趣一切智第一胜舍须资粮乘。及道方便示现此义。大导师言若汝欲得趣一切智第一胜舍。须道资粮取施具足。若须所乘取戒具足。知道方便取闻具足示现此义。偈言

  佛子若欲趣　　一切智胜舍
  彼人乐相应　　道资粮等觉
  世尊饶益彼　　说此修多罗

又复何义佛说此经。菩萨悕望境界生智三种具足。不解其因觉因饶益。世尊已示。若汝欲得境界生智。非唯悕望汝应修满三种具足。若施具足当得境界。若戒具足汝当得生。若闻具足汝当得智。偈言

  菩萨若悕望　　善微妙境界
  欲胜生不劣　　第一增上智
  示现因饶益　　世尊说是经

又复何义佛说此经。菩萨欲得过五怖畏。不解其因觉因饶益。何等为五。一者不活畏。二者恶名闻畏。三者死畏。四者恶道畏。五者大众威德畏。世尊已示。若汝欲得过五怖畏。应当修满三种具足。若施具足离不活畏恶名闻畏。若戒具足则离死畏离恶道畏。若闻具足则离大众威德怖畏。偈言

  第一善逝子　　欲离种种畏
  智慧人觉示　　第一广胜因
  是故牟尼尊　　说此修多罗

又复何义佛说此经。为彼疑者断疑义故。彼大众中有人有天有阿修罗有龙夜。叉鸠槃茶等。见闻世尊胜身口意不可思议生如是心。不知世尊几种具足。获得此三不可思议。是故世尊为断此疑。已说是经言。善男子菩萨修行三种具足。此已示现世尊往昔发菩提心三具足满。是故得三不可思议。偈言

  若人天修罗　　龙鸠槃茶等
  闻佛胜功德　　而不解其因
  牟尼断彼疑　　故为说是经

又复何义佛说此经。菩萨生于如来种姓法种性中相应示现。世尊已示若人得生婆罗门姓若刹利姓。如是之人法性相应。若离法种是则卑劣彼人若生如来种姓不离法性。若生法性如来种姓。以满施等三种具足。若不满足是则卑劣。是故如来如是教言。汝满具足莫后卑劣。偈言

  若生善逝姓　　离过大富乐
  天人所礼赞　　牟尼王令彼
  不离自法义　　说此无垢经

又复何义佛说此经。若人自谓行于大乘第一坚固。是大众生唯口教言。欲护世间一切众生。学菩萨行修诸功德而无真实。彼如是人如说如行相应饶益。是故如来为说此经。令彼人知修一切行。如来世尊为彼人说。非此菩提唯言语得。多种苦行乃得成就。我云何得。我于往昔为取菩提一切行智。悕望利益一切众生。彼彼生处种种苦行及种种舍。所谓种种美味饮食。种种骑乘坐卧等处。园林池水戏乐之处。宅舍田业城邑聚落。宝庄严具冠髻真珠。及毗琉璃金宝璎珞众宝金刚诸庄严具。白象牛马水牛辇舆庄严之具。并及所乘诸牛马等僮仆导从。皆以舍施。过去久远我尔时。作一切庄严见王身时。城邑聚落国土山川海畔大地。并及人民一切树林种种苗稼。及诸药草无量华果鲜净妙宝。种种庄严诸粟豆等。满藏财宝布施贫穷。又复本作善牙童子。我于尔时所爱妻子舍施不吝。又复往昔作善王时。满宫婇女有十千数舍施不吝。又复往作宝髻王时。直阎浮提上身宝髻妙庄严冠脱施不吝。又复往作迦施王时。上身爱分舍施不吝。又复往作无怨胜王。舍身耳鼻施而不吝。又复往作月光王时。如青莲华无垢平满广长好眼。莲华面上自手挑施。又复往作华德王时。白净无垢犹如雪堆。及君陀华乳色齿鬘挑施不吝。又复往作善面王时。广妙长薄清净无垢如莲华叶。口中舌根自手拔施。又复往作给求者王。一切世间贫穷乞人。忆念我者令彼心喜。以一切珠金等珍宝巧作自身宝手用施。又复往作知足王时。以手足施。又复往昔曾。作光金阎浮提王。舍手足指以用布施。又复往昔作求善语大富王时。以爱法故用手足抓。挑自身肉舍以布施。又复往昔作示一切饶益王子。自舍身血给与病人。又复往作利益仙王。割肉截足舍以布施。又复往作居素摩王童子之时。破自身骨脂髓布施。又复往昔作尼啰拏童子之时。舍心布施。又复往作降恶王时。舍大小肠乳肚肝肺胞肾胃胆脾脂头脑以用布施。又复往作净藏王时。舍自身皮以用布施。又复往作金胁鹿王舍身皮施。又复往作光明王时。一切身分分分舍施。又复往作成就一切饶益导主。一切爱物皆悉舍施。临被杀者复舍自身而救济之。又复往昔身作仆使。舍身供给一切众生。又复往昔作求善语大富王时。高千肘山在上。舍身投大火聚。为善说句法因缘故。又复往作一切施王。尽割身肉称用施与为救怖畏来归我者。又复往作不吝王时。于被杀者自舍己身救护饶益。又复往作大悲长者。若入城内狱中系者放令得脱。又复往昔作象王时。自身作桥度诸众生。又复往作鱼龟瞿陀。受一切苦自身忍耐。又复往作师子鹿王。不惜筋脉救济大众。不护自身救怨家命。又复往作悲心仙时。然自身臂失道众生作明示道。又复往作说忍仙时。脔割我身我救彼怨。又复往作不休息坚等住菩萨。他入我舍侵我妻妇。有自在力能忍不嗔。又复往昔作熊身时。畏失命人来至我所。我皆安慰自舍爱身。又复往昔作上仙时。心爱正法以正法。俭无法渴法爱正法故。破身取皮取血取骨书写法言。又复往昔作王童子。为病人故自舍己命。与作第一难得之药而施与之。又复往作胜福德王。于破乱世财物倾尽。近怨家所自缚己身。以利益他饶益安乐。又复往作摩那婆时。在深山中见有饿虎睡寤饥急。自舍己身施令饱满。又复往作精进比丘。发勤精进一切智智求相应行。众生淳熟护正法故。一切苦恼种种欺陵能忍不嗔。又复往昔作坚钾时。一正遍知正像法中勤苦持戒如是。八万四千之身如是。阿僧祇那由他百千苦恼我皆作来。我以悕求一切智智。为欲利益一切众生。然我不曾退菩提心。不堕大乘不舍本愿不缓大钾。于菩萨业不生怯弱。不曾舍离檀波罗蜜。不曾舍离尸波罗蜜。不曾退堕羼提波罗蜜。不曾破坏毗梨耶波罗蜜。不曾放舍禅波罗蜜。不疲倦修般若波罗蜜。不舍摄法修行一切菩萨之道。具足清净不错不谬。坚住一切菩萨之地不倦。一切菩萨三昧三摩跋提。教诸众生发菩提心不生疲倦。聚集一切菩提分法非不得恩。发行一切菩萨之行坚住不退心。常欲满一切菩萨诸愿法门不生畏惧。聚集修行一切功德不生怯弱。何以故。一切世间最胜之处。一切所有学与无学辟支佛智。所不能证所不能入不能观察。此佛法名彼不易得。若小功德和集修行则不能得。小善根者不能得故如是。若人有此宗愿我当成佛。是故翘勤修行精进如功德法聚集修行。我于此处悕望欲得如是义故佛说此经

以何义故名世尊者。彼义今说。言世尊者。供养义故。复有余义。如菩提心忧波提舍。彼说应知

何故世尊游毗舍离大林精舍不余处者。彼义今说。如是难者则不相应随在何处。彼一切处皆有此难。若在余处不离此难。更有余义如菩提心忧波提舍。彼说应知

以何因缘而说如是三种具足不多少者。彼义今说。以有三分相对义故。以此三种。对治贪嫉破戒愚痴。以施具足对治贪嫉。以戒具足对治破戒。以闻具足对治愚痴。又复示现三种福德。施具足者示施福德。戒具足者正行福德。闻具足者示修福德。又复有义。一切众生随顺淳熟施戒具足。一切众生既淳熟已。然后能闻。闻已观察相应淳熟。如是随顺一切众生淳熟相应。是故说三。又复有义二种具足。一切佛法聚集住处得不乱法。依止不乱则闻具足如法。正觉一切佛法皆具足。得如是一切佛法聚集住处。如是因缘是故说三。为当唯有三种具足。为当更有余法具足。彼义今说。如是三种总摄具足。若佛广说无量具足皆此中摄。若大海慧修多罗中彼言世尊。菩萨所有一切具足福德具足智具足摄应如是知。何以故。世尊。菩萨若修福德具足。以是因缘尊胜富贵。复能令他尊胜富贵。智具足故口说善语。一切众生闻者欢喜。彼施与戒福德具足闻智具足如是无违

何故菩萨名种姓者。彼义今说。有师说言有四种家如来生处。如偈说言

  谛舍寂静慧　　此四真胜家
  正遍知家生　　师说言种姓

又善方便是菩萨父。般若波罗蜜是菩萨母。如彼无垢名称经说。般若菩萨母。方便以为父。一切众导师无不由是。生菩萨般若波罗蜜者持故如母。方便生者如父生子。如父母故说言种姓。如是种姓父母二种相似义故。又奢摩他毗婆舍那。如是种姓生正遍知。一切姓中此门第一。一切善法是姓是门如经中说。佛正法中二法双行。彼奢摩他父。毗婆舍那母。彼二法种姓。偈言

  毗婆舍那母　　奢摩他为父
  生一切菩萨　　因毗婆舍那
  奢摩他等故　　有一切正觉

又复有义。诸佛菩萨现前正住三昧大悲。此二法是如来种姓。因此二法生于如来。诸佛菩萨现前正住。三昧为父大悲为母。又复如是此佛菩萨。现前正住三昧为父忍菩萨母。此是种姓。偈言

  佛菩萨现前　　正住三昧父
  若大悲戒忍　　是菩萨之母

此偈明何义。说菩萨种姓之义

以何义故。名具足者。彼义今说。推觅众物处处将来举掌积聚计挍备办增益和集故名具足。又复多法和集之义故名具足。又复有义。荷担菩提故名具足。如外道斋大会具足。初取羊等将来营办。如是菩提如前具足。后菩提觉又复多法说名具足。如药和集乃得成散。如是具足又复有义。前种姓法坚持不失。复向彼岸如大船舶。先和集已后向宝洲。又复有义。正圆非邪如观察耳。如是之义故名具足。又复常修一切胜行故名具足。又具足者。欲得出过荷负重担出到度义。荷负重担不懈怠义。三界过义故名具足

又具足者。平等集修平等负修平等行修平等起修平等作修平等持修平等拄修平等养修故名具足。等养修者。于诸众生犹如医师消息病者疗治众病等。负修者六波罗蜜。如乘船舶等。行修者如大乘说等。起修者菩萨修学如学射等。先正足住等。作修者巧作一切菩萨诸业。如巧作师等。持修者常无常等如称平等等。拄修者一切菩萨能拄法舍。如堂粗柱等。集修者一切白法如蜜蜂集。如是等义故名具足

又自田义若和合义。若或多义若别异义。若或广义若宽博义。若或胜义。若坚固义若牢固义。若和集义若和合义。若或物义若或财义。若或取义若积聚义。若或惭义若或愧义故名具足

何故名施彼义今说。若破贪贫得大富乐福德具足。是故名施。施有几种彼义今说。略有三种何等为三。一者资生施。二者无畏施。三者法施。资生施者。谓饮食等种种舍施。彼资生施色香味胜净洁如法。远离贪垢无匮吝垢。离贪垢者。心不狭小如是舍施自手多施。无吝垢者。不存富乐如是舍施。无畏施者。谓能救济师子虎鼋王贼水等如是诸畏。何者法施。倒说法者为之正说。次第学句教彼正取。广说则有无量种种。圣无尽意说不可量。菩萨施业所谓菩萨须食与食即是布施。一切众生色力寿命安乐辩才

又菩萨施心浊等过皆悉远离。彼浊心施有十四种。一者心浊二者先妒三者嫉心四者慢心五者不减慢六者嗔心七者简择八者疑心九者恼害十者乱心十一者先名十二者依准上法选日时等次第行施十三者懈怠十四者先为报力。如是等法能染心故名为浊心。心体有浊故名为浊。先妒施者。得富乐少眷属不爱。先嫉施者。虽得富乐不乐胜报惟喜下劣。坐卧床敷止宿等处。食饮富乐贪着不离。先慢施者。虽得富乐生下劣姓心不正直。先不减慢而布施者。后受报时依他得活如事王人伎儿使卒诳惑之人防逻戍护种种驱使平准市官当门守户放牧畜兽承事太子下贱官人恐哧他等博戏等人捔力相扑。如是种种广设方便强力取物。复有踊跃劫贼之人。如是等业以自利益。先嗔施者。后得大力畜生等身师子虎豹蛇蟒熊罴猴等中生。简择施者。后得报时治生田业作子林子若种林人作林等人得少果报以自存活。先疑施者。后得果报富乐不常。先恼施者。虽得富乐生夷人中若隘狭处若灾[薛/女]地边地生等。乱心施者。得富乐少或不得果。先名施者。虽得富乐得财富已而复喜失。依准上法选日时等次第施者。虽受富乐勤苦难得。懈怠施者。后受富乐虽得不常。先为报施。后虽得报难得而少。如是初过菩萨。如是皆悉观察。既观察已自心清净。净心生已远离浊心。离浊心已正信相应。悲等功德相应。和合自手施与。先信布施得好方处种姓力色受胜富乐眷属自在。名闻辩才安乐色命。他不欺陵。为人赞叹第一自在。胜坐卧处止宿等处。堂舍庄严饮食衣服涂香众香色声味触。得如是等富乐住处

何故名戒。彼义今说。若能寂静非法律仪。恶不善法能生善道能得三昧。如是名戒。戒有几种。彼义今说略有三种。谓律仪戒。摄善法戒。摄众生戒。彼所谓戒律仪戒者。菩萨正取七众律仪。所谓比丘比丘尼式叉摩那沙弥沙弥尼优婆塞优婆夷戒。出家在家如是次第皆律仪摄

何者菩萨摄善法戒。菩萨所有善法及戒皆正聚已。然后修集大菩提善。若身若口若意等善如是。略说摄善法戒。又复菩萨何所依止依戒住戒。然后修闻次修思惟。后奢摩他毗婆舍那专一乐行。如尊长前正面言语。先礼拜已后起合掌时时常尔。如是时时如是尊长敬重供给。常于病者悲心供给。若闻善语赞言善哉。于功德人说实功德。生如是心普为十方。如彼十方一切众生一切福德勤心随喜。喜心生已然后口说。于他一切犯触己者皆能忍受。一切所修身口意善。皆悉愿取阿耨多罗三藐三菩提。时时种种供养三宝。一切种种设供养已。口发正愿相应精进常护善分。身不放逸口诵学句。意念发行藏护根门食惟知足。初夜后夜觉寤相应。亲近善人依善知识。自识己错犯过。识知见已知改犯。佛菩萨诸福德人尽心忏悔。如是等分摄取善法。得善法已守护增长。若如是戒是名菩萨摄善法戒

何者菩萨摄众生戒。彼要略说有十一种。此义应知。何等十一。一者种种饶益众生。种种因缘同事相应。二者众生病不病等。种种诸苦供给伴等。三者世间出世间义。如彼法说先示方便先示道理。四者报众生恩不忘恩报。随所宜护随报供给。五者师子虎王水火贼等。种种畏处护诸众生。六者诸亲善友亡失富乐。忧悲殃罪能为除遣。七者贫穷苦恼乞丐众生。一切所须皆悉给与。行善之人依正舍法功德摄取。八者先语问讯后语问讯应时而往。九者若他呼唤取食饮等。世间饶益彼此往来。以要言之一切所有不饶益事不可爱行。皆悉舍离心随顺转。十者自实功德心生欢喜。公白正取毕竟唱说以润益心。若治若摈若罚若黜。或时驱遣。诸如是等不善处摈令住善处相应饶益。十一者以神通力示地狱等毁呰不善。令入佛法教化众生。令其欢喜得未曾有。又复圣者无尽意说六十七种。谓于一切诸众生所。不起恼害如是等故。又菩萨藏修多罗中。广说无量如来戒故

又复此戒无量无边功德和集。如是功德今说少分。所谓戒名出家人戒。如大富人身少喜乐。于善法中增长如母。于恶法中能护如父。如在俗人有财物故。一切饶益皆悉成就。出家人戒亦复如是。正导如是如人正行则无衰损。如善人所报恩具足。如世间人爱惜身命。又如胜智世所赞叹。如慎王语。求解脱。人护戒亦尔。欲求解脱当归依佛。欲生善道当归依戒。安身之本戒是第一知识。遇恶善友不舍戒亦如是。欲自利益至死不舍。如女惭愧世人庄严。如人胜行不谄为最。如梵行中见柔和胜。如欲大贵不幻为本。如不放逸多饶功德。欲证胜法依观察得。如近善友初中后时。悕望学人。时节如海不可得过。如诸众生依地而住。依戒住持一切胜法。如水能润一切种子。戒能津润善法种子。如火成根。如风能令分分开张。如行住物空为无障。欲证果人。戒如坚瓶戒如宝藏。如随所欲[聲-耳+牛]得之。牛如食资粮。如人因杖得行住等。如息依命如命慧胜。如国有王人所依止。如军有将功德军众。戒是统将。如妇女人一切乐行皆因夫主。如行道人所有资粮。若行天道戒是资粮。如旷野行主将善导。行善法者戒是前导如大海船。若人方便渡生死海以戒为船。如病大药烦恼病者戒为良药。如战斗处所有器杖。共魔王战以戒遮防。如润亲友不可得舍。戒是贤圣。如大闇中灯为照明。未来大闇以戒为灯。如过度河等因桥而渡。出三恶道诸方便中戒最为大。如清凉舍能离大热。烦恼大热戒能清凉。如怖畏者归依健儿执刀杖者。畏恶道人戒是归依。菩萨之人如住实家。善凡夫人如自己物。菩萨之人如住舍家。行道之人如所行道。菩萨之人如住家家。得果之人能为他说。菩萨之人如住慧家。不动之人平坦清净。如谄舍直如贪舍施。如嫉心人舍不嫉心。如幻伪人心不观察。如沉审人舍离高心。如谨慎人舍放逸过。如王有眼无眼闇人非其境界。八圣道分解脱相应。不观察人去之甚远。如阿罗汉爱涅槃法。如人自爱。如佛出世次第善转。如住正法则住果证。如佛世尊利益自他。如仆事主物时方处皆须相应。如人获得须陀洹果则心安隐。如得良时造作不悔。如菩萨愿终得解脱。如良善田种善种子生长广收。如时方则因缘具足智色爱乐自多受用。如善根熟则有势力。如自善行自心欢喜。如人无罪此世来世则无所畏。如勇健人所依正行。戒如正行善喜自修。如修慈者善心安乐。如修喜者心常庆悦。如修悲者心则正信。如修舍者心常随顺。四种正法如实谛信。如世间法障碍寂静随顺乐行。如因闻故则得辩才。如巧语人则无所畏。如智明人则有名称。如善语人不可破坏。如法顺法能成就证。得明解脱。正觉之人正道如幢。如有智人则能修禅。如伴修道。如健因缘则无所畏。如山饶宝饶功德宝。如海住处多饶。希有如来弟子。戒如大海是入道行如信得果。如觉知者依道理行。虽曰无水犹能洗浴。无根茎叶而生香物。不穿不莹非金非宝非是真珠而是庄严。虽非境界而能生于后世乐报。世间人天修罗魔梵一切沙门婆罗门等之所赞叹。非因他乐是得天道涅槃方便。如济不邪无有泥溺。离石得石如是可渡渡信可济。如财物等离种种过。如离过道资粮柴薪水及水泉。正直不回不高不下。恶虫蛇蝎青蝇蚊子寒热贼等恶物离道。如不须犁不种不熟饶种种田。虽无种树无药无林。而得美果味如甘露。不在高原不下湿生非余人作。又无人穿。常新华鬘不干不燥如善冷水淋灌却热。虽不防护不器仗斗。不与财物不令怖畏而得乐具。常得富乐离诤斗处。如大宝山价直无量不出于海。过大众畏命畏罚畏不活畏恶道等畏。如影随身。此世后世常与身俱此。如是等种种功德戒相应故

何故名闻彼义今说。谓不善法寂静相应。若不能尔则非义语。修多罗等十二部经言语说法是故名闻。圣无尽意说八十种。谓欲修行顺心行等。以何义故。漏与不漏二种具足得一切智。不漏法者彼义今说。智慧观察唯一味故。如蜜蜂王。譬如蜂王种种异物皆作一味。菩萨亦尔。漏与不漏二种具足。以智慧力皆为一味。又愿方便令漏不漏二种具足得一切智。不漏之法如宝积经。佛言迦叶。譬如诸方四维等处所有大河并及眷属一切水聚。入大海已彼一切水平等一味。所谓碱味如是。迦叶菩萨如是以种种门。集诸善根愿菩提故。一切一味。所谓皆是一切智味

施戒闻等几因缘者。彼义今说。施具足者二种因缘。一离贫穷二得大富。戒具足者二种因缘。一离恶道二生善道。闻具足者二种因缘。谓离愚痴得大智慧

又复菩萨三种具足。自他利益施摄众生。摄众生已令住戒闻。如是具足他利益行。自利成就阿耨多罗三藐三菩提。如是具足自利益行

说三具足。何故初施中戒后闻。彼义今说。依渐次义示现佛法如彼大海。譬如大海次第渐深佛法亦尔。初说布施中戒后闻。又复有义。在家菩萨食等施已。彼后时闻出家功德。闻已深信舍家出家。既出家已方得净戒。以住戒故离世间业得无上闻。是故在后说闻具足。又复有义。上生次第菩萨最初自他饶益是故行施。彼布施已次行何者。如是思惟。世尊说戒及持戒人。复有何者次第相应此则说闻。以要言之施具足者。世尊示现檀波罗蜜。戒具足者尸波罗蜜。闻具足者忍进禅慧波罗蜜尔。又复有义施戒示现福德具足闻智具足。又复有义。施戒具足示障碍道。闻具足者示无碍道

三具足经论忧波提舍


胜思惟梵天所问经论

    No. 1532

胜思惟梵天所问经论卷第一

        天亲菩萨造

        后魏北印度三藏菩提流支译

归命释迦牟尼佛。四句之义于诸经首有论解释。如彼应知。于大众中说此法门者。示现法胜大众摄在说法住处。依彼山等胜处说故。六万四千比丘僧者。示现庄严如来大众故。此经法门快妙甚深。出过一切声闻境界。示现如来能说胜义故。七万二千诸菩萨者。何故菩萨多于声闻。以此经典为诸菩萨摩诃萨说甚深法故。皆是智者之所识。知者何故重说。依世间法故。世间说言胜中胜者。如言于端正中最端正者乃可将来。于有德中有胜德者乃可将来。彼诸菩萨各别有智非共有故。复更有义。皆是智者之所识。知者入地菩萨之所知故。此明何义。以诸菩萨摩诃萨先行菩萨行者知彼菩萨故。以是故言。皆是智者之所识知。彼诸菩萨智者。所知有七种德。皆依乐说辩才应知。何等为七。一者种种乐说辩才。二者无滞乐说辩才。三者坚固乐说辩才。四者了了乐说辩才。五者不怯弱乐说辩才。六者相应乐说辩才。七者任放乐说辩才。此诸辩才如经得具足陀罗尼。乃至得无生法忍。如是七句次第而说。此义应知。应云何知。陀罗尼者以多闻慧乐说种种诸法门故。故名种种乐说辩才。速疾不住故名无滞乐说辩才。以得摄受诸三昧故。无有忘失。故名坚固乐说辩才。以诸菩萨摩诃萨等依胜通力之所住持。不畏一切诸魔等故。故名了了乐说辩才。菩萨摄得四无所畏威德快妙。于自他众无所怖畏。故名不怯弱乐说辩才。依于假名他力成就三法体相而不颠倒。故名相应乐说辩才。得八地中无生法忍任意说法离说法障。故名任放乐说辩才

圣者文殊师利诸菩萨等。以何义故名法王子。以初发心来常断淫欲法故。初发心者已入菩萨定心正位。应如是知

一切菩萨皆是大贤士。何故唯说圣者跋陀婆罗等名为大贤士。以为示现心行胜故。彼跋陀婆罗等菩萨有如是心。我所教化众生。皆悉令得阿耨多罗三藐三菩提心。既如是复化众生。令得阿耨多罗三藐三菩提。是故自利利他行胜如实修行。自求菩提亦化众生令得菩提。是故说彼跋陀婆罗等名为大贤士

有百千万大众围绕者。示现如来大眷属故。一切皆是得心定者。此以如来能领大众于大众中最为胜故。以百千万众示现大事。是故围也。所言绕者。示现大众皆悉善伏诸烦恼。故言说法者。示现如来常说诸法而不断绝离诸过故

右膝着地者。示现欲问威仪相故。复为示现诸大众等一心之相故。双膝着地者。不成礼拜相亦不成问相。以诸世间右膝着地敬重相故。动此三千大千世界者。以诸魔等与说法者而作留难。为令诸魔生惊怖故。又为说法时大众不起散乱心故。又为可化众生

若放逸者令觉知故。又为令众生念法相故。又复有义。动此三千大千世界诸众生等。令其观察此诸大众说法处故。又为教化淳熟众生令得解脱故。又为令随顺问正义故。佛言网明恣汝所问。我当解说悦可尔心者。如来听问示现自身我是一切智人。为令听者闻如来说法生尊重心故。能见佛身者。随观如来何等身分不能舍离。更观余分。以如来身相微妙故。超百千万日月光明者。示现胜相快妙相相应故。示现如来出世间相。以如来身有如是相故。智心为与众生安隐与众生乐示现正直心相应知。修行智果相应应知。应云何知。应知如来依彼色相放诸光明。能作众生二种利益。谓与众生安隐及乐与智相应照诸佛土。我自惟念若有众生能见佛身及思惟者。此中见者。初睹色相也。言思惟者。次后观察也。说诸光明依三种法差别应知。三者所谓因名成办。所言因者。即彼与乐与安隐智相应修行。此义应知。名者如经名寂庄严乃至名曰示现一切种色。如是等也。依自各各作业差别此义应知。言成办者。所成办事略有四种。依彼义故略说则有四种光明。所谓受用增长功德止恶令信。言受用者。诸佛如来可化众生共受法乐故。彼受用乐。谓见如来供养如来礼拜如来问如来应知。见如来供养如来者。依第一光明。得见如来思惟如来也。见如来供养如来者。第一光明说礼拜如来者。示现身业供养。见如来者非供养应知。问如来者。第二光明说于所问中以有世间及出世间果报差别次第。复有六种光明。世间果报胜妙差别。依二种地。一非定地。二依定地。非定地中以愿摄取二种果报。一者转轮圣王胜妙果报。二者天帝释王胜妙果报。依定地者。谓梵天王胜妙果报。何故不取夜摩天等诸果报者。以世间诸经皆不说故。佛放光明亦应照彼。而诸经中无是故不明。言出世间果报差别者。谓依三乘三种差别。此义应知。增长功德者。所谓增长三种功德。一者恶道众生令出彼处。于未来世生善道中。二者受苦众生即现身中。与彼安乐令得欢喜。三者能令放逸众生生于善法

言止恶者。谓令众生离诸趣故。离诸地故。离诸难故。离诸障故。名为止恶。诸趣二种。一者恶道二者善道。恶道三种。令诸众生离诸难者。谓令众生离三恶道种种苦难。令诸众生离诸障者。谓令众生离善道中诸根不具盲聋恶业心见迷惑种种诸障。离诸地中种种诸障。诸地有三。一菩萨地。二声闻地。三凡夫地菩萨地中。谓令众生远离六种诸波罗蜜所对治障。声闻地中。谓令众生离三种障不恭敬障及无智障。增上烦恼不能禁止而起烦恼。故名为障。又不恭敬者。谓不信障。又无智者。无多闻慧障。又增上烦恼不能禁止而起烦恼。故名障者。无惭愧障。凡夫地中。谓令众生离四种障依本修集贪嗔痴等烦恼现行障。谓邪念等现行故。一切烦恼现行障。谓杂烦恼现行故。此是止恶。依二十一光明次第说。应知

言令信者。见如来身种种。光明微妙殊胜。是故生信希望欲见故。种种异色者。见种种色也。见者。希望欲见也。又种种异色者。青黄赤白等各各差别也。无量种色者。青等各各有无量种也。过百千万色者。余青等色中过胜光明也。过者。谓青黄等中复过无量无边也。若余残劫者。过于一劫乃至无量无边劫说也。光明功德无量无边不可穷尽者。光明功德无量无边算数譬喻所不能及。乃至无余涅槃界不尽应知。一切光明乃至阿僧祇。阿僧祇光不出受用等四种光明相应。如是知如来示现无量无边身光庄严不可思议方便善巧相应说法者。示现说者。所说令可化众生生尊重心故。示现希有令生胜因敬重心故。世尊我未闻此诸光明名者。示现如来无量无边光明功德。所不说者。不赞叹者也若如是者。今何故说。示现无上功德因故。是以次言。世尊如我解佛所说法义。世尊。若有众生得闻如此诸光明名。能生净信恭敬心者。彼诸众生毕竟定得如来如是光明之身也。先放光明。网明菩萨已知一切如来所作利益众生业受种种法乐。欲共无量余诸菩萨同受法乐。故请如来令放光明。如经世尊唯愿今日放请菩萨光觉诸菩萨故。此光不出前四种中受法乐光。令余世界菩萨觉知者。此光入前分散光明。亦入增长功德光明。应如是知。以何等光明照于无量无边世界。此中示现过于可数。故名无量。去到他方犹如虚空。边不可得故名无边。言现住者。更余世界彼处不去。故名现住。不入涅槃故名现命。以无诸病故名现在。复说诸法清净相应。是故名为无病应知。奉见彼佛者。以现见释迦牟尼佛故。供养彼佛者。一切所应供养之具尽以给施故。问彼佛者。如法咨请故。答彼佛者。如法对故。深细意问者。断诸疑网故。又复有义。现见面故。供养佛故。依本行威仪故。听问以不故。如是次第依法依义问法问义故。自此以下依问答义。应如是知。十种清净坚固心。略依二种心说。一依不染心说。二依恭敬心说。依不染心者。依染净世界七种差别染离染法应知。七种差别者。所谓法差别。以净法不净法差别故。受差别以受苦乐差别故。业差别以下中上姓家生差别故。以恶行善行杂行差别故。心差别以诸众生于佛法中信法不信法差别故。行差别以正行邪行差别故。心修行差别以三乘愿行差别故。道差别以善道恶道差别故。如是等恶心等染。此对治无染相故。说八种清净坚固心。此义应知。应云何知。法差别染者。此有二种。一者依义。谓善说相不善说相。如是分别。二者依法。谓闻善相闻不善相。如是分别。对治者。初句以不嗔恨心对治嗔恨心。谓于善语于不善语不起心故。于恶语中不生心念言我能忍。此义应知。第二句言等以慈心者。以诸文字性如是故。以说非颠倒法令诸众生住安隐处故。受差别染对治者。所有诸受皆悉是苦。如是一切事中。等生悲心怜愍众生故。业差别染对治者。谓正修行如是一切处。心皆平等与乐修行智故。心差别染对治者。于供养轻毁离高下心故。行差别染对治者。不见诸过故。不生利益心故。心修行差别染对治者。等一味故。以彼此三乘不相是非故。道差别染对治者。不生惊怖随顺自业。如是善知。以观察法体故。是名八种清净坚固心。依于七种不染心说。应如是知

依恭敬心者。此有二种。一者于一切菩萨生世尊想故。此明何义。谓于此界生五浊中诸菩萨所生如来想故。如是佛国土中。见诸菩萨行于苦行求大菩提不生疲倦毕竟如实修行。于是菩萨生如来想。以是故言生世尊想。复生希有想。此义应知。应云何知。如佛出世难甚为希有。菩萨摩诃萨亦复如是。以不舍离发菩提心。亦名希有。是故于彼生世尊想。二者于佛生希有想故。此有何义。如无染世界生彼众生无量百千万劫寿命。诸佛如来常作无量众生利益。如是多烦恼过世界中生。于少时间能作无量众生利益。此中见佛生希有想。此义应知。清净坚固心能增长成就。此义应知

入寂静行依清净坚固心。与菩萨念菩萨受取。于彼世界百千万劫。不离正念常修梵行。娑婆世界从旦至中坚持禁戒。不染心行示现胜故。此明何义。如治重病为令速差。但与妙药令服则愈。如是众生多烦恼过。为速灭故。令得胜法对治则灭。此义应知。示现生在恶国众生。多有诸苦多有烦恼。污染世界故。为令诸余菩萨见世尊释迦牟尼佛礼拜供养。问答如来故。圣者胜思惟梵天以为上首为问。问答依胜思惟梵天生于大众恭敬心故。示现胜思惟梵天毕竟得何。等乐说辩才。得何等乐说辩才果。依此二种说正问中为最第一。此义应知。初说。得何等乐说辩才。以一切处问讯相应故。以巧能。令众生解故。以言语最胜故。以尊重言语故。以说正因故。以依实义说故。以依安隐说故。是名美妙。以有人情故。以于大天人边得清净心供养故。以一切诸魔怨敌不能降伏故。以说深密意义故。以此八句说胜思惟梵天美妙言语乐说辩才。此义应知。应云何知。所谓。一者相应。二者令解。三者尊重。四者安隐。五者人情。六者大清净至到。七者不可降伏。八者甚深

次说乐说辩才因。示现如是多种功德言语说法时。若诸众生有不如实修正行者。而不舍彼诸众生故。以与胜乐善相应故。以求众生离于诸苦得胜乐故。以与乐等胜功德时欢喜庆彼故。以求不染等与胜乐安隐心故。以此五句说胜思惟梵天彼美妙言语乐说辩才因。此义应知。应云何知。示现三种心。一者不舍心。二者与乐心。三者安隐心。如是一三一次第说应知

次说得何等乐说辩才果。所谓为彼一切众生于一切义中能断疑故

偈义如经

尔时世尊赞胜思惟梵天言。善哉善哉。梵天。复善哉梵天者。以其发问仪式诣佛于此三时中事相应故。应知善哉。梵天汝今至心谛听我为汝说者。如是次第不颠倒心正念心故

其心坚固而不疲倦者。是正直心。此中大菩提信心为本。是作愿相。依彼愿故则能具足得如来地一切功德。依菩提心坚固方便有第一问。于大乘中略有四种疲倦之事。依彼四种疲倦事故。菩萨虽发菩提之心作菩提愿而失彼心。何等为四。一者以诸众生不如实修行故。二者多作众事故。三者多时在有中行故。四者等解脱中心常欲得速解脱故为彼有力故。此四种障对治法者。谓于众生起大悲心等。如是四种法次第而说。此义应知。应云何知。谓诸菩萨依大悲心如是如是见诸众生不能如实修正行时。如是如是转转增上生怜愍心。为彼众生令得解脱。如是如是转转增上增长作愿。又诸菩萨常勤精进。而不疲倦所作事多而悉能作。又诸菩萨无始世来过去诸苦。信解如梦。不计后时未来世苦。又诸菩萨为一切智。虽同二乘解脱烦恼。虽取无量不共功德。为彼有力断彼欲得速解脱心。言无等者。不共功德无有等故。所言等者。二乘少分断烦恼等。是故名等。以是义故名无等等。如是四种不疲倦心对治四种疲倦心障。是故菩萨于大乘中。其心坚固而不疲倦。如是其心坚固而不疲倦。依于自身佛法淳熟如实修行。正说法已。次依为他如实修行。略说四法。所言决定而不中悔者。于二种义。一者无义。二者有义。言无义者。以无我故。彼无我者离于法故。言无法者。无彼相故。是菩萨毕竟说言诸法无我。诸菩萨等如是毕竟说一切法悉无有我。言有义者。有三种义。一有过义。二功德义。三者二义。以差别故有过义者。谓一切生处以摄一切诸烦恼故。不愿彼处故不乐说。是故菩萨毕竟说。彼一切生处无有乐者。诸菩萨等如是毕竟说。诸生处无有乐者。功德义者。谓赞大乘无上之法。以诸功德一切相应故。是故菩萨毕竟决定常赞大乘。诸菩萨等如是毕竟常赞大乘。言二义者。彼过功德二法不空故。是故菩萨毕竟说彼二法不空。诸菩萨等如是毕竟说彼罪福二法不空。此明何义。虽无量时得因缘相应。能与果报故

如是依自利他利如实修行毕竟说法已。次说增长诸善根。依世间果报因善根增长说。依出世间果报因善根增长说。世间果报因有二种。一者自妙身成就因。二者资生成就因。自妙身成就因有二种。一者不定地中自妙身成就因。谓戒善根增长。二者定地中自妙身成就因。谓智善根增长彼上地下地智功德过。以依智根本离欲得彼故。资生成就因者。舍一切物。谓布施因善根增长。出世间果报因者。谓解脱因。是出家相。离贪着因。以因彼故得解脱因。一切功德善根增长。又增长者。此诸善根依世辩说。有五种增上义故名增长。何等为五。一者降伏诸善根增上故名增长。以此善根胜出声闻辟支佛等诸善根故。二者不违增上故名增长。以不退故。以坚固故。三者不畏增上故名增长。以依此善根过地狱等恶道怖畏故。四者不偏增上故名增长。以能等破所治法故。五者无差别增上故名增长。以作自利他利无异相故。如是增长诸善根已。于不信佛法。不如实修行众生。不生恨心。于读诵等善行分中如法而说。无所恐畏威仪不转。是故次第说彼法相。谓于不信佛法不如实修行众生。无所恐畏威仪不转。彼有三种。谓软中上。软者为命常畏自身不得资生。中者有二。一者常畏毁辱。二者常畏恶名现前说恶屏处说恶。上者常畏苦恼于身中受

如是无所恐畏威仪不转随顺白法。是故次说增长诸白法。依四种白法说。一者欲白法。二者行白法。三者满足功德白法。四者证白法。欲白法者。谓诸菩萨以大菩提教化众生生彼欲心。令诸众生于未来世诸白法中得自体相欲。行白法者。谓诸菩萨舍己资生珍宝等物以用布施。不求未来自身果报。满足功德白法者。谓诸菩萨依彼舍珍宝因。得好妙法成就。心不贪着。而复修行白法摄取妙法。以多闻相应故。一切白法薰习满足。是故菩萨诸功德满足。证白法者。谓诸菩萨摩诃萨。依彼证智为于自身大菩提故说智方便。得彼白法证智胜法

如是增长诸白法已。随顺善知从一地至一地。是故次下说彼法相。谓依四种法说。一者满足功德。二者清净诸障。三者成就心。四者具足修行。集诸善根者。为得从地至地功德满足故。离诸过者。为清净彼一切诸障故。回向方便者。离有资生及离小乘速解脱心故。所有善根一切回向取大菩提故勤精进者。至心修行一切时中常不断绝。以依根本取胜处故

如是说方便已。次说方便法相。善知方便教化众生者。依四种法说。一者能教化众生。二者集无量智功德。三者集无量智慧。四者方便。能教化众生者。谓依布施爱语等。随顺诸众生。摄取诸众生。是故菩萨能教化众生。集无量智功德者。虽离定不定地。而依布施等行。于三世中一切众生一切种功德悉皆随喜。是故菩萨得无量智功德。集无量智慧者。虽无智障对治而常修行发露忏悔。是故菩萨集无量智慧。方便者。依一切菩萨修行对治。劝请诸佛。依为诸众生与智慧光明集诸智慧。以善方便为根本故。是名方便

如是已说修行方便。次说为彼说法之相。随顺诸众生者。为之说法故。谓依四种诸众生说。一者依中间众生。二者依入法众生。三者依谤法众生。四者依所尊重众生。随顺彼众生威仪方便故。依中间众生者。谓依未信佛法众生。菩萨修行随彼众生所信佛法而为说之。与彼众生安隐事门。不但与彼供养恭敬虚妄诳之。菩萨行如是。依入法众生者。谓菩萨心为令众生得入法义故供给之。令彼众生贪着利养亲近菩萨得入法义。于如是法有未度者令得度故。为求衣食资生之具不生疲倦。不为自身贪着己乐。菩萨行如是。依谤法众生者。菩萨自行无诸过失。依柔和忍辱不计彼罪。教令忏悔。菩萨行如是依所尊重众生者。菩萨于彼屈伏顺从随语而受。菩萨行如是。如是已说随顺众生如实修行。而不疲倦为之说法已。次说不失菩提之心。以为不失菩提之心随顺说法故。见佛妙果以为最胜。依四种法说。一者依不夺他物。二者依定因。三者依缘力。四者依因力。常忆念佛者。心常忆念佛菩提心果故。以见佛果成就无量不共功德。此依不夺他物。是故不失菩提之心。所作善根不离菩提心者。一切善根皆菩提心以为根本。依菩提心无量世中长远因故。依彼定因世间种种受果报处所不能牵。此依定因吹之而去。是故不失菩提之心。亲近善知识者。以正修行依外缘力善知识等。此依缘力。是故不失菩提之心。赞叹大乘者。为诸众生发菩提心赞叹大乘。生生世世为于自身增长一切善根种子为因力。大因力坚固。此依因力。是故不失菩提之心

如是不失菩提心故。毕竟一心行菩萨行。是故次第说彼法相。能一其心而不散乱者。以对四种散乱心障故。说四种不散乱心。何等四种散乱心障。一者乘障。二者教化众生障。三者聚集佛法满足功德障。四者毕竟聚集一切佛法障。何等四种不散乱心。云何对治。一者远离声闻心者。对治乘障不堕声闻小乘心故。是故菩萨于大乘中心不散乱。二者舍辟支佛心念者。对治教化众生障。不着自身三昧乐行故。是故菩萨教化众生心不散乱。三者求法无有厌足者。对治聚集佛法满足功德障。以求佛法无厌足故。为集一切诸佛法故。增长种种诸善根故。满足佛法诸功德故。是故菩萨聚集佛法满足功德心不散乱。四者如所闻法广为人说者。对治毕竟聚集一切佛法障。如所闻法如是如是正念观察。以正觉知毕竟聚集一切佛法故。是故菩萨毕竟聚集一切佛法心不散乱。是名四种不散乱心。对治四种散乱心障。此义应知。如是毕竟得一心已善求于法。是故次说善求于法以对世间四种果报成就。相似说出世间四种果报成就。应知示现菩萨求出世间果报成就故。求于法何等名为世间四种果报成就。一者快妙端正成就。二者无病成就。三者富贵成就。四者不畏他人成就。云何相对治如世间人以为成就自身端正作希有因故求珍宝。如是菩萨为诸相好快妙成就于善法因生于宝想生希有想故求诸法。如世间人为无病故。求妙药草。菩萨如是为断一切诸烦恼病。于佛法中生妙药想故求诸法。如世间人为富贵故求于财利。菩萨如是为求诸通成就不退为求义相令得不失。于佛法中生财利想故求诸法。如世间人为离贼等成就不畏故求财宝。菩萨如是为离一切诸障烦恼令彼不能降伏菩萨。菩萨不畏一切诸处。菩萨不畏一切处者。所谓世间一切诸苦。以为欲过一切世间。离诸世间一切苦相得寂静相。为得涅槃成就不畏。于佛法中生无苦想故求诸法

胜思惟梵天所问经论卷第一胜思惟梵天所问经论卷第二

        天亲菩萨造

        后魏北印度三藏菩提流支译

复有异义。依世间珍宝四种功德。相似相对说出世间法宝。应知。何等名为世间珍宝四种功德。云何复名相似相对。一者最上大价贵重。如世间人得彼宝故则能出生无量财宝。菩萨如是得出世间佛法宝故能生出世无量善根。二者最胜法相应。如世间人得彼宝故则能疗治种种诸病。菩萨如是得出世间佛法宝故。则能断除一切诸烦恼病。如彼妙药。三者如意如世间人得彼摩尼宝体依彼宝故如心所须求之皆得。菩萨如是得出世间佛法宝故。依法思惟一切善根功德具足。四者宝体如世间人得彼摩尼宝故。如心所须求得无尽。菩萨如是为过世间一切诸苦。得出世间佛法宝故得果无尽。得为众生说不生不死宝

又复有义。世间众生得无量宝。宝在手故则能随意成就无量殊胜之事。菩萨如是得出世间大乘法宝则能随意成就世间及出世间一切功德殊胜果报。如是得无量宝治诸病等。依初句释余句应知

如是求法随顺多闻有巧方便能离诸过。是故次第说彼法相善出毁禁之罪者。依如实观不取不舍。依不生灭不去不来。依未来世不复作恶。依能远离一切所疑。得无生忍者。谓内心忍灭诸法忍如实观察不取不舍故。得无灭忍者。如实观察罪过之体虚妄分别不生不灭以不去不来故。得因缘忍者。观察因缘本来不生以他体摄故。如实观察毁禁染体离生因故。于未来世不复作恶。得无住忍者。以异异心展转生悔。如实观察诸罪根本即在身中不离于心。不见彼罪过如是不见一切罪过。远离一切心中所疑。能灭悔故善出过罪

如是诸过根本是虚妄染法。若欲断过要断过本。是故次说断彼过本。善断诸烦恼者。依三世说。正观察者。如实正念依邪念行现起烦恼。如实正观不见彼体故。远离未来诸障。增长诸白法者。于未来世更不作恶。以是至心不作恶故得清净心。得善法力者。观察虚妄烦恼诸过。不见过去一切烦恼。以得白法力故。独处远离者。以得寂静心种子故。如是次第善根增上故。随顺不生烦恼境界护诸烦恼故。得因缘力故。未来世中烦恼不起故。如是折伏诸烦恼已。善往诸大众。是故次第说彼法相。善往诸大众者。有二种差别。依人差别依心差别。依人差别者。往何等人。何所为往。何义故往。云何而往。此明何义。贵人出家有多闻慧为求法故。生贵重心往诣彼人不觅其过。此人如是不觅彼人过失故往贱人出家有多闻慧。为求法故生尊重心。往诣彼人非憍慢心。此人如是非憍慢心往诣彼人阿兰若。人无多闻慧非轻贱心。求少善法往诣彼人不自显故。此人如是不自显故。往诣彼人愦闹处。人无多闻慧不为欺彼不为自身。我是高胜何所为往。以为自身为于他身求善根故往诣彼人。不为自身供养恭敬名称赞叹。此人如是不为自身供养恭敬名称赞叹故往彼人依心差别者。以依四种心成就故。一者求法心成就。以见法胜犹如真宝。为求彼法故往大众。二者威仪心成就。脱去金冠宝履伞等威仪柔软而往大众。三者求上上义善根心成就。虽得上法不以为足。更求上上胜中胜法。为与法施故往大众。四者本愿心成就。不求自身供养恭敬名称赞叹。为自他利故往大众

如是往诸大众应行法施。是故次第说彼法相。善开法施者。以何法说。以何义说。依何事说。云何而说。因彼事说故。以何法说者。以法摄取法故。如得闻慧如是说法。以何义说者。以得义故自作誓愿已。毕竟故内自思惟为他人说。依何事说者。以作妙事作贤事故。如所说法如是作事。以诸言语不虚妄故。云何而说者。示现染净法故。示现二二谛法相次第故

如是为他说法令生善根。增长坚固自身因力。是故次第说彼法相。得先因力不失善根者。依四种法说。一者教化众生。二者能忍诸苦。三者远离邪见。四者修行一切功德善根。依止因力坚固说故。于他阙失不见其过者。不见他过护自身过。应众生过故。得化众生因力坚固。生生世世常能教化一切众生。因力增长现前坚固依止。如是坚固因力。于未来世教化众生。坚固增长而得成就。是名菩萨得先因力不失善根。于嗔怒人常修慈心者。乐修大慈以能忍彼嗔恨。众生作苦恼事能忍诸苦。因力坚固。生生世世乐修大慈常能忍彼故。嗔恨众生作苦恼事。因力增长现前坚固。菩萨依彼依止如是坚固因力。于未来世能忍诸苦。坚固增长而得成就。是名菩萨得先因力不失善根。常说诸法因缘者。于诸法中为他示现非颠倒因。因力得果为离邪见乐正见事。因力坚固生生世世于诸法中为他示现非颠倒因。因力得果为离邪见乐正见事。因力增长现前坚固。菩萨依彼坚固因力。于未来世自身正见不乐邪见。坚固增长而得成就。是名菩萨得先因力不失善根。常念菩提者。不舍菩提心愿力故。常不舍离菩提之心。修行一切功德善根。见大菩萨心愿力坚固生生世世常修一切功德善根因力增长现前坚固。菩萨依彼坚固因力于未来世修行一切功德善根。坚固增长悉得成就。是名具足得先因力不失善根

如是以有先因力故。虽未有人说波罗蜜行。而有方便波罗蜜行。是故次说不由他教。而能自行波罗蜜行法。以施导人者。谓于布施波罗蜜中最为上首。初自修行后为他人。令入修行。菩萨如是修行布施故于未来施行成就。生生世世不由他教而能自行檀波罗蜜故。不说他人毁禁之罪者。示现不见他人过失故。善住持戒菩萨。如是善住持戒故。于未来不失一切诸禁戒行。生生世世不由他教而能自行尸波罗蜜故。善知摄法教化众生者。以为教化诸众生故。为诸众生令得安隐忍。彼众生不修诸行勤说诸法。不生疲惓知心知使摄取众生。菩萨如是修行忍辱精进禅定故。于未来忍辱精进禅定成就。生生世世如是次第不由他教而能自行忍辱精进禅波罗蜜故。解达深法者。善知一切诸法无我。菩萨如是信解深法故。于未来智慧成就。生生世世不由他教而能自行般若波罗蜜故。如是修行波罗蜜。行得柔软胜行。能回转诸禅还生欲界。是故次第说彼法相。其心柔软者。谓诸菩萨以得三昧三摩跋提有自在力。以巧方便而能转起胜妙境界。以彼菩萨于禅定中得自在力。不为禅定生于色界故。得诸善根力者。谓诸菩萨能胜处去而不取胜处。虽生下地于彼禅定亦不退失故。善修智慧方便力者。谓诸菩萨以有方便般若故善修诸行。是故不退下地。厌中不受彼地亦不修行生彼处行。示现正因故。不舍一切诸众生者。谓诸菩萨以不舍离诸众生故。舍胜妙处取下处生。示现教化诸众生故

如是不着自乐为与他乐。示现与众生乐。以得不退法轮地故。是以次第说彼法相。得不退转法轮地者。以对三种所治退法故。说四种对治之法。此义应知。应云何知。所谓修行菩萨行中。有三种法令菩萨退。一者时节久远无量。以不能忍生等种种诸苦恼故。而生退心。二者功德智慧少故。而生退心。三者舍弃一切众生无慈悲故。而生退心。堪受无量生死者。所谓菩萨毕竟心取无量无边久远时节。虽有生等种种诸苦。堪能忍受而不怖畏不生疲倦。供养无量诸佛者。所谓菩萨供养恭敬无量诸佛。从佛闻法获得无量功德智慧。是故菩萨快妙功德智慧成就。修行无量大慈修行无量大悲者。所谓菩萨如是次第为与一切众生安隐。为与一切诸众生乐。以不舍离诸众生故

如是以得不退地故。不断佛种如实修行。是故次第说彼法相。不断佛种如实修行者。为得第一义佛地故。为得世间佛地故。第一义佛地者。有三种因得。一者根本欲心。二者至心欲得。三者上欲心。不退本愿者。以不失根本故是名根本欲心。如是示现根本欲心。示现本愿力相故。如说修行者。此有如来如法如说如是修行是名如说修行。示现诸菩萨至心欲得故。于诸善法大欲精进者。是上欲心虽得少分不以为足更求胜法故。深心行于佛道者。示现假名佛地因故。假名佛者。入涅槃时生佛示现。言深心者示现求彼生佛心故。行于佛道者。如实修行故。生佛示现住持佛故。又为示现彼生佛时。复有说法转法轮等摄取众生故

为受何等法义乐故。佛放光明摄取。圣者胜思惟梵天。为欲受彼种种法乐故。圣者网明童子菩萨依彼先说问中胜故。问彼种种胜说法相。自此以下胜思惟梵天广说。应知。彼问有八种邪问正问记为说彼法。如经梵天言。网明若菩萨见我故问。名为邪问非为正问。如是等故。何等八种。一者依二者体三者依止四者依事五者过六者利益七者起八者根本

所言依者。谓依大乘。以依彼乘此中正问故。所言体者。邪问为体。彼体有三种。谓外道声闻始发心菩萨

言依止者。有三种无智。谓粗中微彼三种闇。谓外道等次第应知。应云何知。外道之人依粗无智。是故不识无我体相。自他身中执著有我。以不能知诸法相故。依自心见所说邪论。随彼句义执着法相。如是次第自身他身虚妄见问。如是一切非正念问。悉是邪问。声闻分知无我法相复有不知。是故名为中无智闇。依中无智取自业等造作诸业。即因彼业受于果报。不于余处。及着自体同相异相。成就色等诸法必有。彼如是问。执着自身及他身法。以有随顺断烦恼障。依于自乘名为正念。依断烦恼障名为邪念。以不随顺断智障故。依于大乘名为邪问。始发心菩萨少分能知诸法无我。复有不知有微无智依微无智依有无物。离于有相取于无相。于二法中一向取无法取无法相问。是不正问

言依事者。事有六种。一者阴入界事。二者因缘集事。三者谛事。四者证智事。五者对对治事。六者佛法事。依阴入界事者。依我我问故。依因缘集事者。依顺问故依逆问故。以生故问以灭故问。以是处非处故问。即彼因缘集问。生灭即是是处非处。如经中说。身口等业修行诸善若生恶道无有是处。依谛事者。顺因缘集逆因缘集。顺因缘集者。染体二谛有因有果是有漏行法之体故。逆因缘集者。净体二谛依道能灭是故道谛名为灭谛。如是依二二谛。为染净问。依二种谛染法体故。有生死世间问。依二种谛净法体故。有寂灭涅槃问。如是次第生于世间过于世间。获得涅槃。如是世间涅槃二种差别。依有余涅槃无余涅槃故。如是问世间等事依实谛问。此义应知。以是义故。依谛四种事遮法无我

依证智事者。依知依离问。为得为修问。如是次第。彼智于见道时得智名。已证智者自此以上。得修道名。以得彼证知依证智问。得智名修行名。此义应知。以离彼集得出世间正道果故。以离诸使烦恼身故。依离彼事问。如经是故网明以何处无得无取无证无分别无知无依止无修无修见问。是为正问故。此明何义。于真如中如所说字句。说无如是智为遮彼处无如是法如一一句分别之处亦遮彼句一一之处无如是故。言无取者。以不虚妄分别我已得故。无分别者。以不虚妄分别我已证故。无依止者。以不虚妄分别我已知涅槃故。不分别者。是第一义。言依止者。依止见道见道为修道依止说故。无修见者。不见我修道故。如是说法则名为正

依对对治事者。所谓善不善等法。不善法名。为对善法名为对治。又彼善法二种差别。谓有漏无漏差别。又诸外道以邪见浊长夜有过。此义应知。无过亦有二种差别。谓有为无为差别。善法复有二种差别。谓世间出世间差别。彼有分别以无分别依彼所治治能治事问。网明若菩萨不见二不见不二者。不见二数不见一数。以遮可取法无我故。无明无相平等行问名为正问者。为取彼法相遮彼能取可取相故。又无相无相平等行问者。遮彼能说可说相故。又能说者。说名平等可说名相。以一切事平等知故。彼可说法亦名平等。多种法相同名说故

依佛法事者。依佛依法依修行依处依可化众生依进取证智。如是次第佛等示现因彼差别故问。佛等种种。应知。佛种种者。谓时家姓命差别故。法种种者。谓修多罗祇夜等差别故。僧种种者。谓一向菩萨声闻杂僧多少差别故。国土种种者。谓一向清净染杂差别故。众生种种者。谓贪嗔痴杂等差别故。乘种种者。谓声闻乘等差别故

所言过者。谓外道等为生法灭法是处非处问。见生法问。见灭法问。见染法问。见净法问。如是等问皆是染问。是故名过。声闻之人如是等一切问。为灭为净为成涅槃而不得大菩提。是故名过。始发菩提心菩萨。亦不正念问。以不成就如实净智。是故名过。言利益者。若如是不问即名利益。此义应知。如是等问非正问等。如是等问名正问等。示现彼义

所言起者。即非正问及正问等。示现彼义。如经复次网明一切法正一切法邪故。此以何义。阴界入等皆悉摄在佛法中说。如向所说。阴界入等事相诸法如说不可思议名为正。而起思议名为邪者。是不正问及正问事。如经梵天言。网明以何义故。诸法不可思议故一切法名为正。若不可思议而思议者。一切法名为邪故。以何义故。一切诸法不可思议。如经一切法寂静。名为正思惟故。以离虚妄分别体故。名为寂静。以离戏论故。亦名寂静。以不信寂静法无我故。堕增上慢边。虚妄分别可分别法。而修诸行。以分别四大故起彼问。法示现非正问法正性者。离自境界离余欲际。是名法性。此以示现正问因故

此以何义以何等观而能离欲。以何等智知于彼法。彼二不二名为真如。此中如是无分别智真如智相。名为实际。言实际者。谓离余欲之胜际也。言实际者。离于诸欲。谓无分别真如智相。此谓内心自境界中如实观察地观相故。如是次第明为法性寂静。应知。地者。自心境界成就。及观真如是所观地。何等法上。谓如所说阴界等事。彼阴等事离于真如。以彼真如无戏论故。观彼真如无分别智。彼智寂静以彼真如离于能取可取处故。如是说甚深法。知此正法甚深难解。如经网明菩萨言。梵天少有众生能解如是诸法正性故。如此中说诸法正性。离正法性更求智者则不可得。以彼法性出过世间一异数故。遮有法体。所言少者依一数故。离彼一数更无少分如是为遮取有物体。非彼法体一向是无。不觉不知遮无法相。此说何义。此中谓说信此三世诸法根本不见法相。非谓实证遮。诸菩萨摩诃萨等有实证法。示现此义以随顺此义故名为信非证。此法证者。名为不见一事。网明。若有善男子善女人。得闻如是诸法正性勤行精进。是名如实修行者。依闻思慧于智慧中说彼法相。如向所说以依何心以依何意如来说法。此义应知。不戏一切法故是名证法。以如实知故。是故彼人不住世间不住涅槃。以彼世间烦恼染中无一法舍。是故不减。以涅槃中无一法取。是故不增。示现诸菩萨摩诃萨不住世间涅槃相故。如是闻说正法相者。次第从他闻法。然后内心自正思惟。次第能生出世正见获得彼果。离于诸相示现实体不住相故。示现不住涅槃因故。此以如来见法无我等一味故。示现诸菩萨世间涅槃诸过功德无有分别平等相故。如是诸菩萨得不住世间不住涅槃故

说法次第至此已竟。复依异义次下更问。此明何义。如来说法不能异过于者。不能异过于身。不能异过世间更有一法。是故世间无一法减。于涅槃中无一法增。遮离一物遮得一物故。此以何义。非谓一向不过世间有过世间。以为遮彼见无物故。此示何义。以为示现过二相故。此义云何。言二相者。一者世间行二者涅槃。分别世间过分别功德过。彼二种过菩萨摩诃萨毕竟远离故。此义云何。平等法中无染无净。以依离欲实际法性故。如是说。以彼实际一向不同生死。世间以其常故。是故无有入涅槃者。以是义故。不染不净。如是次第不必说法默然而住。亦得如法修行诸行。若欲说者。应当如彼梵天所说。是故赞言。善哉善哉。法不可说而能说之。是故如来重赞善哉。我不得生死不得涅槃。如是等者领先说义。更无有法而可说也。如来何故重说此法。以五百比丘闻说此法生于惊怖。如来为欲令彼比丘于此义中毕竟定故。此示何义。示现如来意亦如是。非独梵天如是。众生堕无物边。是故如来同梵天说。空修梵行者不解深意义虚妄分别也。何者梵行。谓受持戒。如说修行而不毁犯故。修行正道者。修行四谛差别观也。诸禅者。初禅等四禅也。三昧者。有觉有观等种种行也。三摩跋提者。无色四定也。彼诸比丘以见有法见无法故。闻上说已。谓如来说一向无物亦无修行梵行故生惊怖。以彼比丘见有法故见无法故。为断比丘有见无见。则于其人佛不出世等者。彼人乃至涅槃以为有物故求得涅槃。为对治此有物见故。如经彼人乃至求决定相故。如是依无名相正说法已。为呵责彼惊怖比丘故。以二喻。此二种喻。令生二种念因。谓生厌念因。生观念因。因彼二因获得涅槃。是故呵责。此示何义。示现依彼求法见过逼恼心故。起于厌观。初喻相似相对治法。示现利益观故。共乐身转故生欢喜观。第二譬喻相似相对治法。次明彼人虽行正相而是邪行相。以起生相以起灭相以得涅槃相以证道相故。向来说法诸比丘闻微损恶行。自此已下。为令诸比丘入于法中。是故圣者网明菩萨请于梵天令入法者。此中示现二种法相。一者示现实体。二者示现得果。言实体者。令信法故。所言果者。令离邪见得解脱故。毕竟示现正见相故。为比丘身此间说法能生种子。余佛国土诸佛如来亦说此法。明彼比丘以何处畏而无去处。不能远离所说法相。以一切处不离于法。以不可避。示如是相令彼不去故。说虚空以为譬喻。示现此义。何处怖畏舍之而去。终不远离所怖畏处。如畏空者。不能过空有无空处而可求也。依彼证法示现得相。空无相无愿者。是真如。应知欲求涅槃行涅槃中而不得涅槃者。涅槃是真如清净相故。此以何义。以彼真如一切法中悉平等故名为涅槃。口中言说不可取故。此为何义。遮彼实体是可取故。如是远离有无物法能如实知诸法体相。彼诸比丘如是见已心得解脱。得心解脱已则得实法。得实法已自说法相。彼诸比丘先是凡夫。次作学人次成罗汉。以此义故。于三时后依先不成而作是言。世尊我等今者非凡夫非学非无学非阿罗汉也。不在世间者。谓彼无余涅槃界中。永断一切受生处故。不在涅槃者。有余涅槃中取阴相未尽故。如实示现有佛出世现觉知相。所言动者。散乱心也。言我想者谓我见也。所言发者谓能起作行心相也。所言戏者动等三句分别心也。如是因果或尽示现彼人有佛出世。圣者舍利弗依道依得依灭依证。问诸比丘。诸比丘应如是答。如舍利弗说而诸比丘如是说言。我已得七不可作而作言语问答。此为示现实答返答故。此有二种。一者所证答。二者说答。以有如是所立记故。同行诸比丘说法不能至到。大生尊重心以彼比丘说彼法体生尊重心故

胜思惟梵天所问经论卷第二胜思惟梵天所问经论卷第三

        天亲菩萨造

        后魏北印度三藏菩提流支译

住于福田能消供养者。依福田地住罗汉道堪受供养故。大师世尊犹尚不能消诸供养。何况我等能消供养者。此明何义。如实知法性本来清净故。以是故言。大师世尊犹尚不能消诸供养。何况我等。此以何义。以离法界更无有人受供养者。以彼法界本来清净故。此以何义。以住福田地者住罗汉地堪受供养。以如实知清净法界故。以诸世间不知如来是胜福田。是故说言。大师世尊犹尚不能消诸供养。此以何义。以离法界更无别有清净法相。以波法界自性清净故。依受供养故问福田故。次问应受供养福田之人。何者是耶。如经次言不为世法之所牵者故。世尊如是依诸菩萨是世福田。说受供养福田之相。是故答言。不为世法之所牵故。此以何义。以诸菩萨摩诃萨等常在世间行世间法。不为世法之所染污。虽有胜负得失毁誉称讥苦乐世法等门皆不能牵。菩萨心体其心坚固不随如是八种世法。于如是等心坚不动。贪欲嗔痴所不能牵。如是人者。是受供养福田人也。是名福田能受供养是为清净。以是义故。因福田人故问清净福田之相

以诸菩萨虽复多受眷属利养。而不起心摄取一法执着一法。以是义故。能消供养。是胜福田能消供养。示现此义。是故次问能消供养无所取著者。示现能受福田胜相。是故得彼二相功德福田之名

以诸菩萨为诸众生不失安隐。起菩提心为诸众生修行彼处诸功德故。得彼功德供养恭敬福田中胜。示现此义。是故次问清净福田。以彼不坏菩提心故。是能受供清净福田以是菩萨能作福田摄取众生作善知识。示现此义。是故次第问善知识。直心修行如是次第入于禅定。从禅定起与诸众生安隐之乐。不舍一切诸众生故。示现菩萨胜善知识。菩萨如是能作善友。依如来教自利利他修行诸行不失师恩。示现此义。是故次问能报佛恩。为得菩提不断佛种故。心为利益他故。于如来自作所作胜报恩行

以报恩者有诸功德供养等行。示现此义。是故次问。供养于佛以法身实际自体不生。于如来身能知不生实际证相。为求彼法必得不失。于一切时供养如来。是故菩萨以胜供养供养诸佛

以为供养诸如来故。亲近诸佛。示现此义。是故次问亲近于佛。谓诸菩萨宁舍身命。终不舍于十地诸行。以为摄取十地行故。不舍禁戒得如法体。亲近诸佛及诸菩萨示现胜行故

以近诸佛及诸菩萨生尊重心恭敬如来。示现此义。是故次问恭敬于佛。以无差别一切诸根为一切根修行诸行。是故不生烦恼之心以能修行。善护诸根。是故得彼尊重胜心。菩萨如是正修行已得大果报。示现此义。是故次第问于财富。得出世间信等七种最胜法财。示现于此胜法大财而得上上胜欲心相。已得断除障行诸欲离诸欲相。受于法乐受饮食乐。得证如实法。如实修行信戒惭愧闻舍慧等。说财物施如次第说。又惭与愧二种法财。此依断除烦恼热法。应如是知

菩萨虽有七种法财不生心念我足不足。示现此义。是故次第问于知足。以为摄取诸众生故。菩萨虽求供养恭敬而心常求无上般若。不以为足不生具足心名为知足。既知足已离于诸欲。示现此义。是故次第问于远离。菩萨虽于三界中行而不求彼处。以得寂静胜上心故

既得寂静胜上心已远离身心。示现此义。是故次问无诸恶行。菩萨虽复受用种种胜妙境界。而心不为烦恼所染。以得胜心护诸根故

菩萨既得护诸根已。于一切处皆不怖畏。不怖畏故得受安乐。示现此义。是故次第问于乐人。菩萨虽受供养恭敬而不贪着。常不舍离一切众生。如实善知诸有为行离诸烦恼故。得胜乐

如是不着。离诸烦恼得胜乐已则得不舍受乐众生。如是则能到于彼岸。示现此义。是故次问。能到彼岸以诸菩萨示现诸趣六入之身。摄取一切六入众生为断彼欲。令得彼岸离贪欲心。是故名为能舍六入舍六入故则得胜心到于彼岸

菩萨如是以得胜心到彼岸故彼处正住。示现此义。是故次问住于彼岸。以不分别世间涅槃道。无分别智证无我法。住于无住涅槃得无生法忍。以是义故。第八地中得同不同智。是故名为到于彼岸住于胜处

菩萨如是住于彼岸满足出世间诸波罗蜜。示现此义。是故次问云何增长诸波罗蜜。以求一切智心故。施等增长以为施等展转增长。是故菩萨为诸众生说一切智心。诸菩萨等为令众生发菩提心增长施行。是故菩萨先世已曾令诸众生发菩提心修行布施。菩萨如是自行布施教人行施。余者复施教化众生令行布施。彼诸菩萨亦令众生发菩提心修行布施。彼诸菩萨复令众生发心行施。如是展转自心住施。令他住施。以是义故。施波罗蜜展转增长。以常不舍菩提心故。说持戒波罗蜜。余毁禁者令得持戒。以不舍离菩提行心为得大菩提故。为令住持戒故。以见一切智心不退故。说忍辱波罗蜜。于菩提心中说菩萨名为令余处诸余众生生忍心故。忍一切罪忍一切恶。思惟一切智心不得故。说精进波罗蜜。依精进波罗蜜不见彼岸不取苦行相。是故不生疲倦之心。以证一切智心寂静故。说禅波罗蜜法。所谓心自性清净不生不灭。以知寂静智故以散乱心一切不行故。不戏一切法故。说般若波罗蜜。以摄取无分别智故。以为示现余波罗蜜善清净故。为余波罗蜜依一切智心。说

障行烦恼对治法者。其唯如是见波罗蜜胜行无我。为佛法淳熟故。为教化众生故依于彼法。次问无量于诸众生不生有心而生慈心。此明何义。无异自身安隐心故。不生异身他众生想。菩萨依彼不生法想行于悲心。以见苦法不成就故。以诸众生着彼苦苦故生悲心。菩萨依彼不生我想行于喜心。依彼见自身相离于喜心。见他资生具足成就。起贪嫉意心不生喜。菩萨不尔。更无贪相随喜于彼。是故远离所治嫉妒。依离嫉妒行于喜心。菩萨依彼不生彼我想行于舍心。依见彼我想此对治故。行于舍心。第八地中无功用行以得无分别智力故。以得同不同智慧力故。能远离自他二心相故。于诸众生与离染因快方便故

如是依波罗蜜依于无量。为利自身亦利他身而修行者。复依上上欲心依受法乐依断烦恼。为如所说一切功德得增长故。次问云何住于信等。如彼次第能信无言之法住于信法。信第一法甚深法无我已。余甚深法难信得信。以不执着一切音声住闻慧中。如所闻法无有如是执着之心异求于法。虽少闻慧而能作多事故。但闻一行偈说多闻慧故。依内心相是故有惭。谓依他身自身不如法行。以知过失离于彼处。舍外入故愧行成就。他人说法不如法行。离彼过失。以他人身是外入故。嫉妒人说彼人如是舍于彼法名舍外入。此义应知。身口意业三种清净。遍一切处成就功德能受供养。净福田等乃至惭愧如是所说诸功德等。对治所治身口意业善恶相应。以是义故名为清净。依彼至到功德具足。是故名为遍行一切功德处也。如是应知。又复有义遍至一切功德处者。于彼所说一切功德法中住故

十偈之义一一如经

如是依世间法说能受供胜福田等诸功德已。即依彼义如是次第梵天发问。此义应知。云何菩萨过世间法者。以诸声闻亦过世间。是故如来示现胜法过诸声闻出世间法。是故说言出过世间法。又复示现虽在世间行世间法而过世间。又而不为彼世法所染着。现行世间化众生故。如经如实善知世间诸法故。又为聚集诸众生故。现巧方便为彼众生摄取令入世间法故。知世间集谛知世间所去。而依愿智生于彼处。不为世间集所生故。取如是生示现世间成就世谛依世谛故为众生说法。令诸众生出过世间故。菩萨虽于世间中行而终不为世间所染。得法无我住无住道。以为教化一切众生。是故虽生于世间。为彼摄取世间之道故

三十五偈如经所说

依说世间法。如来亦依自身世间法世间。识知境界以乐说辩才说入世间法相。以如来法出过声闻出世间法。声闻亦过世间境界。如来过彼声闻境界。复说胜法说彼法者。为余众生过世间故。示现如是出世间方便。梵天言。世间者。我说五阴名为世间者。此中示现五取阴。应知依世间说故。贪着五阴者。贪着是爱也。名为世间集者。以依彼爱世间聚集故。过去未来现在诸阴灭故。以未来世阴因尽故。以更不种未来种子故名为灭。观察五阴不见二名为世间灭道者。求道不求道一。二一向不得圣道示现胜故。此明何义。世间对治非一向定。若有对治则能厌苦。若无对治则退彼法。若有一法为对治此法。则不对治余法。若有一法为对治下地则非上地对治。圣道对治则不如是。以一切时一切法对治故

如是依声闻乘对治之义。说世间等差别相已。次依大乘对治法之义差别相说。依于大乘说法相者。如经复次梵天如是等故。所言五阴五阴者但有言说者。于五阴中见闻知等但是名字分别说故。以依无始久远集来依分别体。是故执着彼法。菩萨观察若依如是名字分别是言语见之世间也若如言语名字分别贪着相者彼为邪见。离随顺行名世间集。如彼世间寂灭之相。如实观察灭相之体。如实观察所缘灭故名世间灭。以何等道不取彼见名世间灭道。向说分别能治分别示现无分别智。如是等世间境界如来已过。如来已得大涅槃故。摄取非过世间非离世间道

如是依世间世间等说苦谛等。已依胜圣谛。次下复问如来所说四圣谛者。以彼圣人虚妄分别苦等诸谛。如来示现真实圣谛则不如是。此以何义。谛有二种。一者相谛。二者心谛。以依如是二种谛故。依相谛者。说苦谛等所有法相所有法体所有实体。依彼非圣谛圣谛无差别故。说道圣谛。依心谛者。说胜圣谛。彼圣谛中知颠倒心不颠倒心故。此以何义以非圣者。说苦谛者。彼但受苦不知苦谛。说集谛者。彼人但闻虚妄集法不知集谛。说灭谛者。彼闻灭名堕于断见不知灭谛。说道谛者。彼人但闻业与烦恼有为之法。如是之法但是有为世间集法不知道谛。如是分别苦谛等四谛。若如是等皆有谛者生三恶道诸众生等。皆应有谛而彼无谛。以为示现如是义故。如经梵天若彼苦是实圣谛者。一切牛猪诸畜生等应有实谛。何以故。以彼皆受种种苦故。以是义故苦非实谛如是等故。以何义故。诸畜生中唯说牛猪余不说者。以畜生中唯牛与猪最愚朦故。以诸世间皆知牛猪最为钝故。如是非圣虚妄分别谓以为谛。此义应知。以世间人依于苦门虚妄执着以为苦谛。依于集门虚妄执着以为集谛。依于灭门欲离有漏法虚妄执着以为灭谛。依道对治门虚妄执着以为道谛。又苦集二谛无彼体相。以彼自体不成就故。以彼自体本来不生不和合故。以依彼虚妄执着心对治故。说知无生无和合是名圣人圣谛。诸有漏法亦一切时无如是体。以彼法体无可离故。以依彼虚妄执着心对治。依真如清净彼一切法本来寂灭故。说知无生无灭是名圣人圣谛对治。对治亦无彼体相以彼自体不成就故。以彼道谛非对治谛故。以依彼虚妄执着心对治依自性清净心。依平等观可观。依淳熟智依观察智依彼诸法一切法平等无二无修道故。说以不二法得道。是名圣人圣谛。以说第一圣谛涅槃异名名为道谛。是名圣人圣谛。以不诳故以不生故说为圣谛。又从无生乃至不二。谓依涅槃所修之道依圣道谛一切法平等故。说一切法不二说涅槃者。以真如法清净得名。以彼涅槃离于可取能取法故。以依彼法而得名故。如是次第

又彼谛者。因不正念名为虚妄语非实圣谛。又即彼谛因正念故名为实语亦非实圣谛。是故示现妄语实语皆不成就。如经梵天实圣谛实圣谛者非妄语非实语故。彼非正念取我相等示现应知。如是诸句于一一法中生执着故。以异异义相缚。应知。谓有一我我体是有以为根本。依根本我故有种种。以我不断名为众生。依命根住故名为命。数堕六道故名丈夫。如是等见自身是一虚妄执着。取我相等。即于彼我虚妄分别。常与无常堕于常见堕于断见。见我是色我是无色。如是种种虚妄分别异异执着。着我是一。以我是物以虚妄分别。是故取相。依彼我虚妄分别取无明等生。虚妄分别。而取生相。即依彼我虚妄分别取无明等灭。虚妄分别取断灭相。如是生灭依于我相。次第成彼虚妄分别。取世间相取涅槃相。取彼世间取涅槃者。如前所说诸取相等。所谓。取者希乐信等虚妄分别坚执定取。唯此是实余者虚妄是名为着。以彼诸见不可舍离。虚妄执着是名为触。不离彼触是名为取。如是次第不着不触不取等者是名实语。示现正念

如是依丈夫无我非妄语非实语说法已。次依法无我说苦等分别。离无分别智是故名诳。以是诳故名为妄语。是故示现彼二乘谛虚妄不实。分别三世一切法故彼念虚妄。是故示现无分别智。此以何义。以忆过去一切法门。分别现在一切诸法。念未来世一切法门。以是义故离于正念。菩萨住彼无分别智中不戏一切法相。观法无我得无住涅槃。以不住世间涅槃中故得平等见。菩萨如是善知法已诸谛如说示现。不见成就谛故。圣人谛者。彼处无实语无妄语。以是义故。示现彼义

虽有正念不正念心二种差别。而彼圣谛犹不成就。若住实相成就谛者。则一切时古今常尔恒如是住自此以下示现彼义。如经梵天言实。实者古今实故。此明何义。彼法性法体示现胜法体圣法体因。世间涅槃无差别故。是故名为常圣谛也。依世间涅槃示现二二圣谛成就。如是依真如相圣谛。示现不离世间圣谛。示现不取涅槃圣谛。如是说法相谛证已而说者示现彼人名为实说。彼人说圣谛名为邪说。自此以下示现彼义。示现彼人无增上戒学因。彼人不能守护诸根示现少因故。示现彼无增上戒学无彼增上定学因。示现彼无增上定学无彼增上慧学因。示现彼无增上慧学。示是生相是苦谛等执着虚妄法。次第自配此义应知

如是彼婆伽婆以为世尊。而彼声闻但是外道。次下示现彼声闻人成于外道。以彼愚人失物为谛说物为谛。示现彼人堕于恶道故。以自不说。以如来得无言语法故。苦等诸谛自体不成示说谛相。我如是证示现不立有法相故。示现他不取故。菩提不可得以无分别体故不取。我已得菩提法。无如是取离一切有以离三界离五道故。以过彼法得出世间圣道法故。如是不见一切诸法是菩提相。不证一法而证诸法。是故说为应正遍知。若如来于法无所得者。以何义故。说如来坐道场名为佛者。此问如来。遮有物得故如来说言我不得物闻说法名世谛摄故。分别相故。依无体相法无我说。次依法无我问。彼法相彼法无我以一切法无体为体。遮有无二法。示现何义。示现彼法非有物可证非无物可证。以彼法离于二相。是故说证

如是说已自下次说。非谓一向不证实法。以见虚妄执着法无故如实善知自性不生。以依颠倒他体而生。所谓染等分别体性。常一切时自性不生。知真如我如是。证法云何而知。如常不知不觉而知。言知识者。此为示现彼真如相亦不分别。以不见彼真实法体。以彼法体一切言语不可得故。是故示现彼证智因。不知不识不可见等者。于见闻觉识堕四种语。此诸句等。上上起门示现。应知。不可取等如彼法体如是彼法不可以彼见等取故。此以何义。以诸名字不可得故。过心境界故。以无戏论事故。相应法中不可相当故。以诸言语不能至到故。相应法中不可相当故。不可问答故。过六根故过名字故。内身一切不可说故。无世间相故。世间法不行故。离于所作以有为法所不行故。以无世间心意意识分别相故。出过世间以无彼体故。以过於戏论无可对事故

如是示现所说法体无有一切诸分别已。示现彼法虚空相似。应知。彼法虚空相似。有二种相应知。一者遍去。以离有无戏论法故。以得诸佛不可思议毕竟法故。二者无碍以大慈心第一忍苦所不可作而能作故。以无言法依言说故。以依彼法令诸众生得入法故。为示何义。诸有众生依于黠慧我慢心故。不能信此所说法相。以为示现彼诸众生善根微薄故。说彼法相为明何义。明此法门一切世间所难信者。以世间意于同法中常颠倒故。此义云何世间人意念云我等应证实谛。依三学法修行满足。我依彼法应得涅槃。一向修善法以依彼法现受法乐此善行次第依佛出世以为根本。次有说法次有如实修行伴侣众僧。如是此法实谛等如实而住以无戏论故。诸世间人所不能信。此义应知。世尊譬如水中出火火中出水者。为示何义。以为示现烦恼如火以非寂静体。远离彼体故菩提如水以其能灭烦恼火故。以彼不信与信相违相应法而不相应。此义应知。言烦恼者。所谓一切愚痴凡夫。如是执着戏论言有烦恼染我为彼愚人遮烦恼体不成就故。以观察法不可得故。以出世间智乃证得故。以识不能分别知故。以对治所治学修道故。以不执着能治所治二相法故。以得真如清净法故。以无有心取得法故。能令彼障无势力故。以彼障法本性不生故。如说法相若人不生诸法相者。则得远离一切邪见而得解脱。以得远离取不实相能治所治分别心故

自此已下。依诸菩萨摩诃萨信。法功德赞叹彼菩萨。有七种功德。此义应知。何等为七。一者所作诸行满足功德。二者修行功德。三者入位功德。四者以自在心生有功德。五者善练功德。六者能集佛法修行功德。七者得果功德

云何所作诸行满足功德。示现过去于诸佛所能作所作种种功德皆悉已办故。复有何义。依二种义。一依功德。二依智慧。以能供养恭敬给侍。诸修行等如威仪故。闻正法故。如是次第菩萨如是满足功德智慧行已。次应修行入地诸行。是故次说修行功德四句。示现有诸功德智慧增上。以饮食法食二种摄故。以依善知识复修诸行。能于义中能于法中作巧方便。随顺正法如实修行故。以得上妙善根力故。依巧方便故。妙有二种。一者能作所作妙。二者深妙。能信彼处以闻如是二种大妙不惊不怖故。以善护如来妙法藏故。以如说法。一一随顺如实修行故。以不自见以不自触法故

菩萨如是如实修行。自身毕竟入菩萨位。是故次说入位功德。二十五句示现此义。云何名为生如来家。以是菩萨依佛家生得佛法故。以能舍于分别烦恼。尔时摄取无分别智故。示现修行施等行故。以断所治破戒法故。此以何义。以持戒故对于破戒。能起破戒诸烦恼灭。是故持戒治彼所治。以得对治惜身命故。以得对治懈怠心故。以对欲界恶不善故。以对一切诸不正见乃至对于小乘见故。如是名为入位功德。是出世间波罗蜜行功德。应知以于如来如实所说甚深之法正入功德不颠倒故。以彼不能作诸功德障所谓天魔烦恼魔等不能作障。如是次第说以能说法入功德故。以深意说不颠倒法功德入故。说法功德以如世谛第一义谛真实说故。如次第说。此明何义。法自性者。所谓诸法自体相等入彼。应知住持功德入法门流位得清净法故。以依如来住持之力能作所作故。是诸菩萨不共住功德同梵行故。以得持戒平等行故。以是菩萨有善法分增长功德。以出世间信等功德皆现前故。此是以不触诸食功德。此明何义。随宜而得。谓依乞食住处卧具及汤药等知足功德。圣人所行随何资生皆不触故。乐离诸欲修行之相不触功德对触。应知此复何义。不依于他智慧命活。是故易满易养。应知以能随顺证智功德。自身毕竟得阿耨多罗三藐三菩提故。以心毕竟我定得故。当知是人为能度者。以是人能度未度者。如是等八句为他利益修行功德。应如是知。以能安慰烦恼所缚诸众生等令入道故。能安众生解脱法中故能令众生得解脱故。二句次第示现胜处能为说道故能与解脱故。二句次第示现能知对治法故。示现能与对治所治能治法故

胜思惟梵天所问经论卷第三胜思惟梵天所问经论卷第四

        天亲菩萨造

        后魏北印度三藏菩提流支译

菩萨如是入菩萨位已。以为利益一切众生心生有故。摄诸趣生。是故次说菩萨摩诃萨以自在心生于三有。是故名为摄取功德四句示现。以自在力摄胜处生。虽生彼处而不为彼之所染故。以长远时摄取生处不疲倦故。以不为彼烦恼业等他力而生。自在如意摄取生故。以诸菩萨一切处生。不畏彼处所受种种诸苦恼故。菩萨如是以为利益一切众生修行诸行。常为一切众生上首。是故次说能为上首。能领大众能办功德。有十五句示现此义。菩萨自身如佛所说修行之法勤而学之教他无过故。以长远时学习禁戒受持不毁守慎坚固故。以有如是二种功德于先后时自善住故。以是义故能领大众。此义应知。以为众生能作上首令降伏故。以是菩萨能领大众诸魔不能与作障难。远离一切诸魔业故。以有不护身口意业毕竟得故。不畏他人说其过故。以其现见甚深之法能答问难不怯弱故。以说法胜巧方便故。以领大众行于大事。修行诸行不退自身善根分故。二句示现可化众生生于明故。可化众生离无明故能作因缘。如是次第此义应知。以诸众生有随顺者不随顺者而心坚固。虽有相违有不相违诸烦恼等心不异故。以于众生无差别故。为彼众生成就一切种种功德。能受一切功德数故。以作他恩他人不作报恩障缚不住心故。以为除灭一切诸使与诸众生对治法故。以其虽为大众围绕而不高心故。菩萨如是自利利他修行诸行。以为成就佛法修行。是故次说为成就佛法修行功德。二十九句示现此义。当知是人如须弥山以其坚固不可动者。以依一切诸胜功德无分别智。余七地等一切分别不能动故。以依彼法一切声闻辟支佛念不能破坏以坚固故。以依如来内法修行。违佛法者所不能坏。以得胜力故。以入第一甚深之义法无我故。以是人得转身胜法依彼法故。得胜解脱灭烦恼故。以依修行转身得身。以一切种诸烦恼染依身灭故。以于一切诸如来所常闻正法不厌足故。以证实际更无境界。未证可证更不求故。以为众生演说正法转法轮故。以诸相好庄严其身住持可乐。如帝释王为诸众生之所乐故。以得八地中十自在力故。二句示现于九地中以依乐说辩才说法。与诸众生相应正念。如次第说此义应知。以于菩萨第十地中得能治法善增长故。以得远离所治障法故。所言弱者所对治法。说名为弱以诸菩萨住如是处说名佛故。以是菩萨虽有障地而无障故。以是菩萨胜住余地诸菩萨故。以是菩萨无等地住菩萨平等。又复无等无差别等复有差别说修多罗等法无我平等一味证故。以诸菩萨住于彼处他不能以觉观测量故。以乐说辩说一切密无滞着故。以于无量诸佛如来无量说法而能持能受故。以不去而去。即次闻慧受大法雨。后以如实觉入所觉故。以觉彼法随顺正入彻诸法故。以入众生八万四千诸行门故。以如彼行与对治法不疲倦故。以是菩萨虽见世间而离世间故。以得失等世间诸法憎爱贪恚诸使烦恼不能增长故。以彼菩萨虽有得等大利益事而于修行诸善根分不能灭坏故

菩萨如是修集佛法正修诸行得彼彼胜果。是故次说得果功德二十六句。示现此义。依未解成就依色成就依业成就。依菩萨地尽具足成就。依入佛地尽成就。如是次第此义应知。当知是人为得快爱。以诸黠慧之所爱者。以是菩萨如实证谛。是故为彼同伴侣者之所恭敬心爱念故。以依法句依解法相知彼法重而供养故。如次第说。以尊重佛法者能供养故。以依中间人以依不信佛法人。见彼菩萨有大胜事归依菩萨礼拜等故。以进究竟修菩萨行。余诸菩萨于此菩萨亦供养故。余二乘人虽复进得彼二乘道。以是菩萨有胜功德为彼二乘人求此功德故。以是菩萨依彼胜行不求小乘故。此是心成就得果功德相

当知是人为不谄曲。以无点污谄曲法者。以离世间有为法相诸谄曲故。以其能生世间欢喜去来坐卧诸威仪故以成就妙色形相上下故。以威具足为诸世间生尊重故。以身具足三十二相故。以彼菩萨八十种好一切种种身显现故。此是色成就得果功德相

依佛法僧等住持业成就得果功德相

是人诸佛见者。以一切佛皆现见故。即是彼佛诸功德故如实见故。以得现见如来法身故。以得无量证法受位故。以软中上得法忍故。言软忍者于七地中。言中忍者八九地中。言上忍者第十地中。此是菩萨地尽具足成就得果功德相

是人满足道场者。以证一切种一切功德皆满足故。是人能降伏众魔乃至是人能作佛所作事者。以降伏魔如是次第依作。众生利益。应知此是入佛地成就。得果功德相

不惊等者。云何为惊。以闻深法谓为异道故名为惊。因彼惊故转更增上相续不断名增上惊。惊不断绝相应执著名上上惊。以堕惊怖中故。以在惊怖故。以怖无物故。如是次第彼人不惊不增上惊不上上惊。此义应知。说彼功德犹不可尽者。依如说修行七种功德种种差别不可数故。佛菩提者。如先所说以彼菩提难可知故。难见难觉二句。示现以出世间智依出世间智。得智境界余世间智则不能知彼境界故。言能信者。依取受持读诵解释能自随法如说修行。为令他知故名为信。所谓令他如实修行巧方便智。此义应知。信取受持读诵说等所有功德不可称量。以是一切智境界故

次依梵天不能尽知彼具足智。如经尔时如来告胜思惟大梵天言。梵天汝少分知彼诸菩萨摩诃萨色及功德而赞叹之故。此依何义以依赞叹以依功德以依于事。如是次第依甚深义说。谓于义中句中字中甚深。应知示现知彼进趣去处知深意故。此以何义。知深意者。知能说者说法意故。示现依量相应法故前后义法相应知。以不随顺文字义故以依于义不依字故。以依正问依正语故。以五种力修行说故。是故即说五力言语名为乐说。此义应知。此五力者云何名力。以有四种力相应故。何等为四。一者住持佛所作力。二者降伏一切诸外道力。三者能知一切魔业。知已则能远离彼力。四者三乘毕竟取力。于彼法中一一相应。以依彼法如来能说善相应故。此五力者依五甚深说何等为五。一者依相甚深。二者依意甚深。三者依时处甚深。四者依进取甚深。五者依常说法随顺甚深。如是次第

依相甚深者。一切诸法三世等差别相难觉故。过去等法依四种说。一者依事说。二者依对对治说。三者依世谛义说。四者依进取乘差别说。此义云何。依事说者。谓三世事以说三世事相法故。三世事者。所谓过去未来现在即此名为说三世记。以依如来无障碍智说三世事名三世记。依对对治说者。所治烦恼染能治法清净。及彼烦恼二种差别。谓善不善差别。善法亦有二种差别。谓世间出世间差别。世间复有二种差别。谓有漏无漏差别。有漏亦有二种差别。谓有过无过差别。无过亦有二种差别。谓有为无为差别。依世谛义说者。依假名名字说我众生等差别相故。依进取乘差别说者。得第一义证真如正智依清净故。如次第证。如是进取世间涅槃。此明何义。世间之人所进取者。即是世间二乘摄取异地证法以为涅槃以取寂灭际涅槃故。诸菩萨摩诃萨不住二处故

为彼初力说不执着无过失故。说幻等喻。此明何义。如幻所作象等身体皆不成就。如是言语所说诸法色等身体不成就故。如梦中梦见受用种种境界。而彼梦中种种境界颠倒故。见如是言说所用法义受法乐门惟是虚妄分别故。有如彼响声言语说身虚空中间而无住处。如是说法言语音声第一义谛中无住善住故。犹如彼影现见唯相虽见有色种种形相而诸形相等共彼法体非是相应。而依彼法随顺而生如是言语。说一切法亦唯是相。虽有种种名字差别而诸名字共所说法非是相应。而依彼法随顺相故。如以众印印于泥等见第二印而诸印体不转不入。而如是见如是言语说于诸法。虽因言语闻色等义差别异相。而诸言语不在法义而如是闻故。如彼阳焰实无水身而亦见水。如是言语说于诸法无如所说诸法体相。而亦见彼种种诸法故。如彼虚空本来不生本来不灭。虽以言语说于虚空而彼虚空无体可说。如是言语说于法义。第一义谛无可说体故。以一切法无彼言语可以说故。如是说法无一说法以彼说法如幻等故。故以幻等譬喻示现

如是。不着言说法义。得无障碍智乐说辩才是名利益。此义应知。此明何义。一切言语法不离法界说不差别法界说。此以何义。一切说法色等差别不离法界。以说法界和合故。以说色等诸法差别而不执着故

依意甚深者。以依如来六种密意能知如来有甚深意。此义应知。何等名为六种密意。一者念密意。二者无说密意。三者对对治密意。四者法密意。五者心密意。六者字转密意。梵天如来或染法说净等。此示现念密意。此以何义。以不见烦恼染法体故。以坚执着净法体故。以染正念染净无体故

以不摇动执着此是染法体相故。以心摇动执着此是净法体相故。以彼染法虽非正念而彼染法不成染法故。是名如来念密意。复次梵天我依布施即示涅槃等。此示现无说密意。此以何义。以佛无起心而说诸法。以一切法无如是力能从此世转至彼世我法无体是故无有一法可转。以是义故。无一毫法转至异世。是故依施说得涅槃无有是处。是名如来无说密意

持戒乃至般若以示现涅槃。此明何义。此明对对治密意。此以何义。以断戒等所治之法依波罗蜜乐行行故。说持戒等名为涅槃。以断能起破戒烦恼身口意等不行恶行故。以离一切杀害等心依彼害心空故。以不复生忍辱心故。以离懈怠常修精进为增长善为灭恶行无如是心为善不增长恶行不灭无如是心故。又复更无摇动心故。以无觉观故。此以何义。以离一切摇动心故。以无分别散乱心故。以离一切所见境界是故不生。我已得心以无所得而名为得。以不见法故。是名如来对对治密意

贪欲是实际法性无欲相故乃至愚痴是实际法性无痴。离于真如贪等实际等无故示现法密意此明何义。实际法性无痴相故此示现法密意。此以何义。以离真如贪等实际等无法可说故此义应知是名如来法密意。世间是涅槃无退无生故。乃至虚妄是实语为增上慢人故。此示现心密意。此以何义。以解世间本来不生本来不灭即是涅槃。执着涅槃涅槃身体。如是取相以此心过即是世间。实言语者依言语说门。若见是实即是虚妄。言虚妄者。是我慢人虚妄分别以之为实取于实相而不实故。是名如来心密意。复次梵天如来以随意故。或自说言我是说常边者等。此示现字转密意。此以何义。以说涅槃等是常法故。以说烦恼等诸染法故。以说断贪等诸使烦恼故。以说无有恶行作故。以说无有身等业故。以见一切戏论诸邪见故。以一切智不随他因缘故。以证无为涅槃法界故。以不依业烦恼一切趣中生无生缚故。以得毕竟断爱业故。以不住三界不属三界故。如经而如来无有如此诸事故。此以何义。此以如来依常边等无常等见故。又言无有如此诸事者。以佛法中无如是说如是所说不可见故。梵天当知是为如来随意。以依何意憍慢众生能舍我慢者。此明何义。即于向来所说法中示现异义。执着如名义亦如是故。梵天若菩萨。知如来随行方便说者。依离如是名义执着。次下复说。此以何义。以说法中有二种行。一者字行。二者义行。此明何义。如是名字于义中行。如是义于名字中行。此是如来甚深之意。依此深意如是善知巧方便相字义行智。应知此行即名为行菩萨进取如意行故。如彼所说甚深之意。善巧方便集诸法故。则能善知一切所说种种诸法。是故菩萨能于诸佛一切说法言语音声不惊不怖。应如是知。以诸众生随种种心。是故菩萨依彼方便则能信受。闻佛出世不出世等。以异异相如彼出世不出世等一一示现。不执不着以巧方便令彼众生信入诸法故。以可化众生身不淳熟。令彼众生身淳熟故。为说浅法依乐示乐。为身受乐身淳熟故为说深法。是故次第依时说法。此义应知。应云何知。先为众生说粗浅法。此明何义。摄取因果故。摄取彼观故。摄取彼业故。以教化方便摄取众生故。摄取修行故。摄取修行果故。布施得大富乃至慧舍诸烦恼者。依善法修行摄取因果也。以忍为对对治丑陋。以忍能生欢喜心故。以忍能作端正因故。以闻慧等勤修诸行能作智因故。以过苦苦因故。以慧如实观能离诸烦恼。以诸烦恼因散灭不集故。又此闻慧行修善法观。何者是观因以多闻慧为摄彼观故。摄取彼观也。修行身等行摄取十善业道。依十种业摄取天人中成就诸功德故。摄取彼业也。无量摄取业怜愍众生故。以教化方便摄取众生也。摄取众生淳熟方便。以依止奢摩他修行一切善法。是故奢摩他得毗婆舍那修行故。摄取修行也。以依三乘得三乘涅槃故。摄取修行果也。以摄取乞乞少欲头陀等。为诸众生少作利益故。不能说法故。为令众生随顺入故

如来如是说浅法已。然后方乃为说深法。此明何义。说粗浅法明因果。为根不熟可化众生自心觉知明因果事。众生摄取能作所作我等相见。是故如来明因果已。次说对治能治所治。示现自身离彼邪见。如来实不得我众生寿命及丈夫等故。此义云何。有我众生寿命丈夫义。如先说应如是知。以不见彼能治所治因果法故。略说依随世间果报以不见施等受果报故。以不见悭等不受果报故。以得远离能治所治修行法故。以不见彼离世间果得涅槃果有无法相故。梵天如来常为众生说法。而诸众生依如来教如所说法如实修行勤修诸行。为何义修行勤行彼行。乃至不得涅槃不见涅槃。此明何义。如浅说法众生摄取见诸法相。如是修行出世间果不见彼果。如来示现如是说法是世间因。此有何义依佛说法而修行者。此是根本随顺善法。修诸行者。此是解释以依不得法依不见法次第说故。不得法者。以慧观察不能得故。不见法者。以身不能证涅槃故。为令众生摄取妙法者。此明何义。彼浅说法及深说法。为令众生入彼深浅二种法故。以为示现入法相故。此以何义。令入法者依四种入。为可化众生示现解脱令证彼法。此义应知。四种入者相行说得眼等诸根离我我所体二相空故。解彼相已则不能诳得入解脱故名相。入依眼等相能入解脱。是故说为入解脱相。如是彼空相中修正行故得入解脱相。所不诳与诳相违。以是义故。依修行入说诸众生入解脱相。是故依此相行二法示现对治业烦恼染及生等染空等门者。此明何义。对治所治见相愿染业烦恼染及生等染对治法故。此明何义。以空无相无愿等门。对治业染及烦恼染。以不行门对生死故对治生染。不生不灭门。此明何义。即彼生染中间差别对治法故。即彼所治复有对治。以无所从来无所至去门复有对治。以不退不去门入解脱相。如彼次第。自性清净方靖门者。此明何义。以彼法退自性寂静故。示现何义。示现彼染一切寂静故。以何故说自性寂静。以依性净说法入故。是以次言。复次梵天如来于一切名字示是解脱门。如是等此以何义。以有递共无相应故。自性顽故。此以何义。以依异异法说异异名字。以诸名字前字后字不相到故。复有差别。以言语义不相到故。如是说者为明何义。以说诸法无彼言语可以说故。依无言语名字法相如是说已。示现一切言语名字。如来说名为解脱因故。此明何义。说实谛故。依彼如实正说法已云何得解脱。是故次言。梵天如来说法无有法染。此明何义。为身淳熟浅说法已。以为随顺断诸烦恼染法等因依入法门故。言一切所说法中示解脱门。此示现何义示现涅槃故。此示现何义。见谛学人余残烦恼示现学人离彼烦恼得解脱故。未见实谛者。为令彼人入一切法平等真如。方便说法示现涅槃。有二种义应知。大悲一者毕竟治彼所治之法。二者谓一切种大悲之心。此明何义。远离一切所治之法。及离一切习气烦恼以得如来身故。以得一切种故。略依四种大悲心说。一者远离相应大悲之心。二者相应大悲之心。三者谓心大悲之心。四者修行大悲之心。远离相应者。以识离识不相应故。以见我等心相应故。此示何义。示现远离相应大悲之心。示现相应大悲之心。如是次第一切法无我。乃至一切法无丈夫。依人无我说一切法无所有。依法无我说即彼二种。人无我相法无我相名为无住。言无住者。以不执着诸法体故。是以不住一切诸法。应如是知。此明何义。所言住者住诸入故。依我见爱门住彼处故。夫无住者则无归处。无归处者云何有归。归三界故归六道故。以依彼入摄取身故。依彼生故。以于彼处常沉没故。言沉没者。我我所故以彼彼处生于身故。以生我心故有生故。无归处者则无我想。无我想者则无我所。有归处者则着我想。着我者则有我所。着我所者。诸法平等既共有之。而诸众生虚妄分别我是增上故。此明何义。所谓依事摄取执着。言依事者。依田依宅依园林等。依于父母及妻子等。依衣服饮食及卧具等。依摄取者。摄取一切受用之事。依执著者。执着以为自己所有。以田宅等我别有故。如是着生着于退生。言着生者自于此处自异处去以取着故。业烦恼染增上遍满。来去生染满时处故。依贪嗔痴三种所缠染随所染。此义云何贪嗔痴染随所染者。以何义故。二种名说依根本染。谓过去世来至此世。从此世中向彼世去以为上首故。如是说如是示现。世世生生相续不断。有所为作。众生如是生不断绝轮转彼彼。学种种术学种种业。丈夫力相作诸有为戏论之法集得境界受用境界。众生如是虚妄分别。如是一切依俗人分。此义应知。又复次有依出家分。谓外道等邪见之相邪见相愿。此明何义。言邪见者。谓见我等所言相者虚妄分别彼彼义相。所言愿者。心常乐求生世间等。即此上说远离悲心不远离悲心。示现心悲心。此义应知。为彼远离不远离心说法修行。依于欲求依于有求依梵行求诸颠倒道。为彼所治能治法故。是以次说修行悲心。此明何义。依于欲求颠倒道者。以摄取故递共斗诤。为诸欲故自于父母及妻子等共相斗诤。依于恚恨竞讼等过。如是次第依于有求颠倒道者。颠倒相应。求梵天等常见颠倒。颠倒取故故名颠倒。为颠倒者。离颠倒道令得入于非颠倒道。又依有求颠倒道者。住于异道。为教化彼异道众生令入实道不可得故。依梵行求颠倒道者。略有三种。所谓不求邪求下求此复何义。一切世间不自在过。及邪命过作亲相过。诸烦恼染业苦染法俗人乐家。是故众生不求梵行。不求梵行者不求解脱道故。此所谓悭及悭压没行贪行诳行懈怠习气。如是次第一一拔济不知厌足。夺他财物者。以自资生非法求故。施等不足众生常为财物屋宅妻子恩爱而作僮仆者。示现彼心不自在故。于此危脆无坚之物生坚固想者。以于无常资生等中生常想故。供养恭敬者。此为何义。为饮食所缚不成就故。众生虽谓是善知识而是众生恶知识者。示现怨家故。邪命自活者。以斗秤等欺诳他故。一切法中勤修诸行方能毕竟得大菩提。而彼众生懈怠疲倦故。圣人最胜解脱处者。非颠倒因修行者得。而诸众生求邪梵行依颠倒因而修诸行。所应得者是人乃求外道解脱。为令不行彼邪道故。何以故。以彼不得圣人解脱故。众生弃舍最上大乘无碍等者。以彼求于下梵行故。舍于无上第一大乘。而求下分小乘法故

胜思惟梵天所问经论卷第四


圣佛母般若波罗蜜多九颂精义论

    No. 1516

圣佛母般若波罗蜜多九颂精义论卷上

        胜德赤衣菩萨造

        西天译经三藏朝散大夫试鸿胪卿传梵大师赐紫沙门臣法护等奉　诏译

  般若波罗蜜多智　　体积善宝功德聚
  所有一切波罗蜜　　而彼本来性常住
  离诸戏论无对碍　　离诸分别得安隐
  最上微妙无自性　　离诸所有名相等
  方便宣说三乘法　　而彼三乘所得相
  皆是一切智智因　　稽首般若波罗蜜
  所有胜慧到彼岸　　若人乐欲正观者
  应当于彼九颂义　　总略如理而思择

其九颂曰

  从业增上生　　所谓六处相
  即此说复生　　所因如影现
  如幻所化城　　能观者亦化
  如彼所见色　　业化世亦然
  诸有说法声　　即是闻境界
  一切如对响　　缘成能所闻
  嗅香及了味　　触等境爱着
  此一切如梦　　虽得无所有
  如幻轮成人　　诸行作无实
  此如彼行作　　身轮亦无我
  若种种所得　　彼极刹那生
  此与阳焰等　　见即坏无相
  所取如影像　　无始从心生
  而彼相及识　　互相如影像
  观自净种中　　若智月出现
  彼如水中月　　现前无所有
  若相应者智　　彼即虚空相
  是故智所知　　皆如虚空相

如前颂言

  所有胜慧到彼岸　　若人乐欲正观者
  应当于彼九颂义　　总略如理而思择

所言胜慧者。谓闻思修等相。彼岸者边际义。到者往到谓到毕竟边际离诸分别处所。如是乃至此义终竟。正观者。谓不颠倒相。乐欲者。所谓作意希望为性。彼义者。谓彼九颂说时所有之义。义即义门。思择者。谓思惟决择何所思邪。颂言总略。总略者。谓包总含略

此中应问何故总略说邪。答为令钝根之者能解其义故

前标九颂次第今释

第一颂言

  从业增上生　　所谓六处相
  即此说复生　　所因如影现

业谓善不善业。增上者谓业增上。由彼诸业增上力故彼即有生。何所生邪。颂言六处相。处谓识所依所生之处故名为处。此复云何谓眼等内六处。颂言相者标表为义。若此六处相有所生故。即彼如是复生诸法。此如是说是义终竟决定成就

问于胜义谛中云何自性。颂自释言所因如影现。由取影现而为喻故。于影现中诸有作者作业及所作事悉离性空。此义终竟

复次于外色等六处自性所生。今当一一次第显示

第二颂言

  如幻所化城　　能观者亦化
  如彼所见色　　业化世亦然

犹如幻法所化城邑。后能观者亦即是化。彼二非有。何以故。不实生性故。然能见所见彼二色相。外有对碍皆是业化。世间三界所见此犹彼故。其义亦然。此如是化与彼所化无差别性故。下颂言如声对响。为证成此义故

第三颂言

  诸有说法声　　即是闻境界
  一切如对响　　缘成能所闻

所言说法即能说者增上所生。彼所对声是闻境界。若闻境界此如是故。自余诸法皆如是生。是故取喻如声对响。此声对响与余法同。此中如是无差别言。乃云一切所言。缘成者。谓即闻等缘成故。闻若彼所有皆所作性。是故能闻所闻有所得中悉是缘成。所以有声皆如对响。如是所说此义毕竟。故下颂云一切如梦。为证成此义故

第四颂言

  嗅香及了味　　触等境爱着
  此一切如梦　　虽得无所有

言嗅香者。谓鼻识境界。诸所作性所嗅香等。了味者谓舌识境界。了诸味等。触谓身识境界觉诸触等。于如是等诸境界中所求所乐而生爱着。于彼彼境各各系属随所系属。香味触等别别所受。若于彼等境中起有所得相即不可得。是故颂言一切如梦。一切者此即无差别意

然眼等内处色等外处亦非不有。若不尔者云何发起作者所行。为破此疑故

第五颂言

  如幻轮成人　　诸行作无实
  此如彼行作　　身轮亦无我

譬如幻轮法用成人身相。彼幻所成人种种行作皆悉具有。亦复如人假有作者及所作用。又复亦有所行作事去来等相。颂言诸者。种种分类所作之义。何所作邪。谓幻所成身。若如是身幻法成故。即彼幻身而实无我。无者离义。我谓主宰。此言无我谓离我故。所以此中无其作者。于胜义谛中都无所有。是故颂言。诸行作无实。无实者谓无力能义。今此如是无其力能。谓此作者无主宰故。若幻所成人无其主宰。虽所显示而无其实。诸法亦然毕竟无实。此中应知无差别意故。下颂言与阳焰等。为证成此义故

第六颂言

  若种种所得　　彼极刹那生
  此与阳焰等　　见即坏无相

种种者。谓多种类。所得者。谓差别遍计所取境相。彼所取境极刹那生。刹那刹那名极刹那。生者起义。谓极刹那有所生起。若极刹那有所生故。彼彼诸法从极刹那之所生者悉是无常此义终竟

圣佛母般若波罗蜜多九颂精义论卷上圣佛母般若波罗蜜多九颂精义论卷下

        胜德赤衣菩萨造

        西天译经三藏朝散大夫试鸿胪卿传梵大师赐紫沙门臣法护等奉　诏译

此中应问。彼胜义谛中云何自性。答颂自喻言与阳焰等

其阳焰者。谓地尘日光三事假合。如阳焰聚前见后坏。是故颂言见即坏无相

诸有所得别别境界其义亦然。虽各表了皆无自性。何以故。彼等自性前后不和合故。性不相等故。愚者取着于一性转。是故此等皆堕世俗有情趣故

复次此中若能取所取对碍性空即自性。明亮本来不生心法发现犹如影像。为释此义故

第七颂言

  所取如影像　　无始从心生
  即彼相及识　　互相如影像

此言所取知影像者。谓此与彼而相似故。所似云何如镜等中见面等像。此复云何。谓从心生以彼唯心有所生故。心即系属有其所取外境相等不舍为性。此义终竟

复次如外所取镜中面像。即彼诸法以惯习种子领纳于心。于无二中取其有二对碍之相。由无始来从心所生如彼影像。或同时异时所缘伺察彼皆无性。非唯心法亦由所缘之相而能引生能缘识心。是故有相

凡言相者摄集为义。非唯一法由彼所取如是有相能取亦然。此中意者。所取无性能取不实。颂言互相。互相者即和合义。互相和合皆如影像。如影像故能取所取彼二互相不相离性。即彼二法于无所得中互相从。彼心法出现有所得相

此总意者。彼心自性本来明亮无能取所取二种之相。本离贪等无明垢染。清净洁白离诸取着。故下颂云。如水中月。为释此义故

第八颂言

  观自净种中　　若智月出现
  彼如水中月　　现前无所有

观者定义。定谓心一境性相。于彼定中有所观想。心自在故。颂言自者。谓自种子净即清净。清净者离浊之义。从自身语心种子所成。等无间缘出生想

◇纥哩字变成普遍炽焰光明。于是光中从心种子出甘露光广大照耀其光复成极大火轮。乘彼火轮出慧方便。复从是生彼

◇诃字门。其字振发大声。于中出现八叶莲华。诃字处中内外想布十六分位。复想

◇迦字成星宿众周匝围绕。复于相应方位想佛莲华。彼十六分皆成月轮。如是观已复于其上自净种中想现

◇吽字具炽盛光。于其光中出现大火炽盛光焰。当观自身从智月中生菩提心。复从是生金刚智月。当知月者即金刚智普遍世间。智光照耀一切色相。是故颂言若智月出现

彼智金刚成就出生慧及方便。无喻涅槃之相复从慧生。金刚界中摩摩枳菩萨相观想。甚深最上微密三摩钵底密云弥布普现光明。其菩萨者。身相青色八臂三面。正面青色。右面黄色。左面白色。右第一手执剑。第二手执箭。第三手执钩。第四手执金刚杵。左第一手执轮。第二手执弓。第三手执罥索。第四手执铃。而彼菩萨理智相合。诸所施作皆顺方便。众相庄严顶戴阿閦佛冠。现于熙怡可爱之相。加趺而坐。如阿多西清净之华具有日轮最胜圆光。复如大乐自性金刚萨埵之相。洒诸甘露遍于一切。此菩萨身即如来身。从慧方便之所出生。是故颂言如水中月

颂言若者即是如义如水月故。此即是空。从是空法之中出生诸法。其所出生即本来不生性。所以喻言如水中月

此中如是。若于法界自性中取著有性者而实无性。何以故。颂言现前无所有故

由彼如是于一切法无所得。真如中有所作所证而实不能。若有作有证者皆是方便建立诸法。与虚空等为证成此义故

第九颂言

  若相应者智　　彼即虚空相
  是故智所知　　皆如虚空相

所言相应。当知即是智之与定二法相应。彼之相应即是金刚。有彼相应法故名相应者

由彼相应者所有之智。于一切法无所取无二相中。以慧方便生如来身。非如前说蕴处界等戏论自性。此义终竟

然如来身不动法界自性所成本来不生。何以故。以如来等自性离故。此即无性止不可说

无性者。谓本来不生故名无性。是故颂言如虚空相

此复云何。谓离一切戏论之性。故如虚空。以彼虚空如是相故。而虚空相应当如是。如理伺察。相者标表义。复次当知于一切法无障碍自性中有所作用者。谓由智入三界心心所相如虚空相。显示所知无明随现有情及器二世间相蕴处界等戏论自性。是即所知为智境界。有所作性此所知境。随有系属觉了所知遍计诸境。是故此说名为所知。所以一切智一切智智此之二种皆如虚空。应如是观。为总摄此义故。颂言皆。皆者无余义。无余少分故

此中除彼声闻人中乐欲取证有余依涅槃者。彼虽证得人无我理谓于蕴事取为有故。余证无余依涅槃解脱相者今此所摄。如佛所言一切种一切一切有皆空。此中又除一分外道所说之空。以是义故。此中应知世间无复少法可有。一切如彼虚空之相

所言如虚空相者。当知即是虚空自性如是真实。此之九颂如所说已。复为显示诸菩萨等种智果故。总说颂曰

  如理思惟此实性　　彼一切性无所依
  所有菩提胜愿心　　大智庄严当获得

圣佛母般若波罗蜜多九颂精义论卷下


十地经论

    No. 1522

    十地经论序

        侍中崔光制

十地经者。盖是神觉之玄苑。灵慧之妙宅。亿善之基舆。万度之纲统。理包群藏之秘。义冠众典之奥。积渐心行。穷忍学之源。崇广住德。极道慧之府。所以厚集肇虑。朗成圆种。离怖首念。赫为雷威。其为教也。微密精远。究净照之宗。融冶莹练。尽性灵之妙。自寂场启旭。固林辍晖。虽复圣训充感。金言满世。而渊猷冲赜。莫不网罗于其中矣。至于光宣真轨。融畅玄门。始自信仁。终泯空寂。因果既周。化业弥显。默耀大方。影焕八极。岂直日月丽天。洞烛千象。溟壑带地。混纳百川而已哉。既理富瀛岳。局言靡测。廓明洪旨。寔系渊儒。北天竺大士。婆薮槃豆。魏云天亲。挺高悟于像运。拔英规于季俗。故能徽踪马鸣。继迹龙树。每恨此经文约而义丰。言迩而旨远。乃超然遐慨。邈尔悠想。慕释迦之余范。追刚藏之遗轨。诚复岁踰五百。处非六天。人梵乖辽。正像差迥。而妙契寰中。神协靡外。通法贯玄。莫愧往烈。遂乃准傍大宗。爰制兹论。发趣精微。根由睿哲。旨奥音殊。宣译俟贤固以义嘱中兴。时凭圣代。大魏皇帝。俊神天凝。玄情汉远。扬治风于宇县之外。敷道化于千载之下。每以佛经为游心之场。释典为栖照之囿。搜隐访缺。务乎昭扬。有教必申。无籍不备。以永平元年岁次玄枵四月上日。命三藏法师北天竺菩提留支。魏云道希。中天竺勒那摩提。魏云宝意。及传译沙门。北天竺伏陀扇多。并义学缁儒一十余人。在太极紫庭。译出斯论十有余卷。斯二三藏并以迈俗之量。高步道门。群藏渊部。罔不研揽。善会地情。妙尽论旨。皆手执梵文。口自敷唱。片辞只说。辩诣蔑遗。于时皇上。亲纡玄藻。飞翰轮首。臣僚僧徒毗赞下风。四年首夏。翻译周讫。洋洋斖斖。莫得其门。义富趣玄。孰云窥测。刚藏妙说。更兴于像世。天亲玄旨。再光于季运。忝厕末筵。敢窃只记

十地经论初欢喜地第一之一

        天亲菩萨造

        后魏北印度三藏菩提流支等译

  说此法门者　　及诸劝请法
  分别义藏人　　受持流通等
  法门等最胜　　顶礼解妙义
  欲令法久住　　自利利他故

十地法门。初地所摄八分。一序分。二三昧分。三加分。四起分。五本分。六请分。七说分。八校量胜分

经曰。如是我闻。一时婆伽婆。成道未久第二七日。在他化自在天中自在天王宫摩尼宝藏殿。与大菩萨众俱。一切不退转。皆一生得阿耨多罗三藐三菩提。从他方佛世界俱来集会。此诸菩萨一切菩萨智慧境界悉得自在。一切如来智慧境界悉皆得入。勤行不息善能教化一切世间。随时普示一切神通等事。于刹那中皆能成办具足。不舍一切菩萨所起大愿。于一切世一切劫一切国土常修一切诸菩萨行。具足菩萨福德智慧。如意神足而无穷尽。能为一切而作饶益。能到一切菩萨智慧方便彼岸。能令众生背世间道向涅槃门。不断一切菩萨所行。善游一切菩萨禅定解脱三昧神通明慧。诸所施为善能示现。一切菩萨无作自在。如意神足皆悉已得。于一念顷能至十方诸佛大会。劝发咨请受持一切诸佛法轮。常以大心供养诸佛。常能修习诸大菩萨所行事业。其身普现无量世界。其音遍闻无所不至。其心通达明见三世。一切菩萨所有功德具足修习。如是诸菩萨摩诃萨功德无量无边。于无数劫说不可尽。其名曰金刚藏菩萨。宝藏菩萨。莲华藏菩萨。胜藏菩萨。莲华胜藏菩萨。日藏菩萨。月藏菩萨。净月藏菩萨。照一切世间庄严藏菩萨。智慧普照明藏菩萨。妙胜藏菩萨。栴檀胜藏菩萨。华胜藏菩萨。俱素摩胜藏菩萨。优钵罗华胜藏菩萨。天胜藏菩萨。福德胜藏菩萨。无碍清净智藏菩萨。功德藏菩萨。那罗延德藏菩萨。无垢藏菩萨。离垢藏菩萨。种种乐说庄严藏菩萨。大光明网照藏菩萨。净明胜照威德王藏菩萨。大金山净光明威德王藏菩萨。一切相庄严净胜藏菩萨。金刚焰胜胸相庄严藏菩萨。焰炽藏菩萨。宿王光照藏菩萨。虚空库无碍智藏菩萨。无碍妙音远藏菩萨。陀罗尼功德持一切世间愿藏菩萨。海庄严藏菩萨。须弥胜藏菩萨。净一切功德藏菩萨。如来藏菩萨佛胜藏菩萨。解脱月菩萨。如是等菩萨摩诃萨无量无边阿僧祇。不可思议。不可称。不可量。无有分齐不可说。不可说种种佛国土集。金刚藏菩萨。而为上首

论曰。时处等校量显示胜故。此法胜故。在于初时及胜处说。此处宫殿等胜是名处胜。何故不色界说。此处感果故。何故不初七日说。思惟行因缘行故。本为利他成道。何故七日思惟不说。显示自乐大法乐故。何故显己法乐。为令众生于如来所增长爱敬心故。复舍如是妙乐悲愍众生为说法故。何故唯行因缘行。是因缘行显示不共法故。何故菩萨说此法门。为令增长诸菩萨力故。何故唯金刚藏说。一切烦恼难坏。此法能破。善根坚实犹如金刚故。不异名说。何故名金刚藏。藏即名坚。其犹树藏。又如怀孕在藏。是故坚如金刚。如金刚藏。是诸善根。一切余善根中。其力最上犹如金刚。亦能生成人天道行。诸余善根所不能坏故。名金刚藏。已说序分。次说三昧分

经曰。尔时金刚藏菩萨摩诃萨。承佛威神。入菩萨大乘光明三昧

论曰。入三昧者。显示此法非思量境界故。已说三昧分。次说加分

经曰。尔时金刚藏菩萨。入是菩萨大乘光明三昧。即时十方过十亿佛土微尘数等诸佛世界。有十亿佛土微尘数诸佛。皆现其身。同名金刚藏。是诸佛如是赞言。善哉善哉。金刚藏乃能入是菩萨大乘光明三昧。复次善男子。如是十方十亿佛土微尘数等诸佛。皆同一号。加汝威神。此是卢舍那佛本愿力故加

论曰。何故多佛加。显法及法师。增长恭敬心故。何故同号金刚藏。加本愿力故。何故如来作如是愿。显示多佛故。此三昧是法体。本行菩萨时皆名金刚藏。同说此法。今成正觉亦名金刚藏。故不异名加。又是菩萨闻诸如来同己名已增踊悦故。何故不言过无量世界。方便显多佛故。何故定言十亿佛土。为说十地故。此经如是多说十数。彼佛先作是愿。今复自加。后余佛加故言卢舍那佛本愿力故加。何故加。为说此法故加。复云何加

经曰。又一切菩萨不可思议。诸佛法明说令入智慧地故。摄一切善根故。善分别选择一切佛法故。广知诸法故。善决定说诸法故。无分别智清净不杂故。一切魔法不能染故。出世间法善根清净故。得不可思议智境界故。乃至得一切智人智境界故。又得菩萨十地始终故。如实说菩萨十地差别方便故。念随顺一切佛法故。观达分别无漏法故。善择大智慧光明方便故。令入具足智门故。随所住处正说无畏辩才明故。得大无碍智地故。忆念不忘菩提心故。教化成就一切众生界故。得通达分别一切处法故

论曰。此二十句。依一切菩萨自利利他故加。如是初十句依自利行。后十句依利他行。是中一切菩萨者。谓住信行地。不可思议诸佛法者。是出世间道品。明者见智得证。说者于中分别。入者信乐得证。智慧地者谓十地智。如本分中说。此是根本入。如经又一切菩萨不可思议诸佛法明说令入智慧地故。此修多罗中说依根本入有九种入。一者摄入。闻慧中摄一切善根故。如经摄一切善根故。二者思议入。思慧于一切道品中智方便故。如经善分别选择一切佛法故。三者法相入。彼彼义中无量种种知故。如经广知诸法故。四者教化入。随所思义名字具足善说法故。如经善决定说诸法故。五者证入。于一切法平等智见道时中善清净故。如经无分别智清净不杂故。菩萨教化众生即是自成佛法。是故利他亦名自利。六者不放逸入。于修道时中远离一切烦恼障故。如经一切魔法不能染故。七者地地转入。出世间道品无贪等善根净故。如经出世间法善根清净故。复有善根能为出世间道品因故。八者菩萨尽入。于第十地中入一切如来秘密智故。如经得不可思议智境界故。九者佛尽入。于一切智入智故。如经乃至得一切智人智境界故。是诸入为校量智义差别次第转胜。非根本入。一切所说十句中。皆有六种差别相门。此言说解释应知除事。事者谓阴界入等。六种相者。谓总相别相。同相异相。成相坏相。总者是根本入。别相者余九入。别依止本满彼本故。同相者入故。异相者增相故。成相者略说故。坏相者广说故。如世界成坏。余一切十句中随义类知。第二十句所谓得菩萨十地始终故。此根本始终。是中始者信欲亲近等。终者念持诸地。复有阿含及证。如是次第依初相。应知依根本始终。有十种始终。一者摄始终。思慧智随所闻义受持说故。如经如实说菩萨十地差别方便故。二者欲始终。令证一切佛法故。如经念随顺一切佛法故。三者行始终。观分时中无漏道品分别修相觉故。如经观达分别无漏法故。四者证始终。见道时中法无我智方便故。如经善择大智慧光明方便故。是中善择者。择中最胜。最胜者。法无我智故。大智慧者。过小乘故。光明者。对治无明故。此事中彼时中皆善知故。五者修道始终。出世间智智力得入法义故。如经令入具足智门故。此处菩萨于菩提有五种障。一者不能破诸邪论障。已说正义他言能坏。复眷属离散。二者不能答难障。于他问中茫然无对。设有言说人不信受。三者乐着小乘障。自不能得大菩提。复舍利益众生。四者化众生懈怠障。于中舍利他行。不助他善。复自善根不增长故。五者无方便智障。不能善化众生。复自菩提行不满足故。对治是障有五始终。一者能破邪论障始终。随彼所著显己正义。对治邪执无畏辩才性不闇故。如经随所住处正说无畏辩才明故。二者能善答难始终。证大无碍智地故。如经得大无碍智地故。三者乐着小乘对治始终。大菩提愿大菩提念不忘失故。如经忆念不忘菩提心故。四者化众生懈怠对治始终。利益众生无疲倦故。如经教化成就一切众生界故。五者无方便智对治始终。于五明处通达分别故。如经通达分别一切处法故。已说何故加。复云何加。谓口意身加。云何口加

经曰。复次善男子。汝当辩说此诸法门差别方便法故。承诸佛神力如来智明加故。自善根清净故。法界净故。饶益众生界故。法身智身故。正受一切佛位故。得一切世间最高大身故。过一切世间道故。出世间法道清净故。得一切智人智满足故

论曰。此十句中。辩才者。随所得法义忆持不忘说故。诸法门者。谓十地法。差别者。种种名相故。此法善巧成。是故名方便。依根本辩才有二种辩才。一者他力辩才。二者自力辩才。他力辩才者。承佛神力故。云何承佛神力。如来智力不闇加故。如经承诸佛神力如来智明加故。自力辩才者有四种。一者有作善法净辩才。如经自善根清净故。二者无作法净辩才。如经法界净故。三者化众生净辩才。如经饶益众生界故。四者身净辩才。是身净中显三种尽。一者菩萨尽有二种利益。二者声闻辟支佛不同尽。三者佛尽。菩萨尽者。法身离心意识唯智依止。如经法身智身故。二种利益者。现报利益。受佛位故。后报利益。摩醯首罗智处生故。如经正受一切佛位故。得一切世间最高大身故。二乘不同尽者。度五道复涅槃道净故。如经过一切世间道故。出世间法道清净故。佛尽者。入一切智智满足故。如经得一切智人智满足故。自力辩才校量转胜上上故。已说口加。云何意加

经曰。尔时诸佛与金刚藏菩萨真实无畏身。与无障碍乐说辩才。与善净智差别入。与善忆念不忘加。与善决定意方便。与遍至一切智处。与诸佛不坏力。与如来无所畏不怯弱。与一切智人智无碍分别法正见。与一切如来善分别身口意庄严起故

论曰。此十句意加。无畏身者有二种。一者与无上胜威德身。如王处众自在无畏。二者与辩才无畏身。前色身胜后名身胜。是名身有九种。一者不着辩才。说法不断无滞碍故。如经与无障碍乐说辩才故。二者堪辩才。善净堪智有四种。一者缘二者法三者作四者成。善知此义成不成相故。如经与善净智差别入故。三者任放辩才。说不待次言辞不断处处随意不忘名义故。如经与善忆念不忘加故。是不忘加意力加故。四者能说辩才。随所应度种种譬喻能断疑故。如经与善决定意方便故。五者不杂辩才。三种同相智常现前故。如经与遍至一切智处故。六者教出辩才。得佛十力不坏于可度者令断烦恼故。如经与诸佛不坏力故。七者不畏辩才。得佛决定无畏于他言说不怯弱故。如经与如来无所畏不怯弱故。八者无量辩才。于一切智随顺宣说修多罗等法六种正见故。如经与一切智人智无碍分别法正见故。九者同化辩才。得一切佛无畏身等三种教化。随所度者显示殊胜三业神化故。如经与一切如来善分别身口意庄严起故。又诸佛有力有慈悲。何故以十种无畏身唯加金刚藏而不加余者

经曰。何以故。以得菩萨大乘光明三昧法故。亦是菩萨本愿起故。善净深心故。善净智圆满故。善集助道法故。善修本业故。念持无量法故。信解清净光明法故。善得陀罗尼门不坏故。法界智印善印故

论曰。以是菩萨得大乘光明三昧法余者不得故。得三昧法有二种。一者本愿成就现前故。如经亦是菩萨本愿起故。二者三昧身摄功德故。此三昧身摄功德有八种。依自利利他故。一者因净。深心趣菩萨地尽清净故。如经善净深心故。深心者信乐等。复是一切善法根本故。二者智净。趣菩萨地尽修道真如观智故。如经善净智圆满故。此真如观内智圆满普照法界。犹如日轮光遍世界故。三者身转净。生生转胜善行成满故。如经善集助道法故。四者心调伏净。善断烦恼习故。如经善修本业故。五者闻摄净。堪能受持一切如来所说秘密法故。如经念持无量法故。六者通净。得胜通自在故。如经信解清净光明法故。以决定信力摄取通故。七者辩才净。善知陀罗尼门不相违故。如经善得陀罗尼门不坏故。于中所有初章字者是陀罗尼门。一一字门摄持无量名句字身故。不坏者前后不相违故。八者离慢净。谓真实智教授不异故。如经法界智印善印故。于中三昧身摄功德有四种依自利因。善净深心故。善净智圆满故。善集助道法故。善修本业故。此修多罗中四句次第说。精进因。不忘因。势力因彼不染因。复依利他因有四种。念持无量法故。断疑因。信解清净光明法故。敬重因。以神通力示现不思议处。令诸见者决定信入故。善得陀罗尼门不坏故。转法理因。法若坏时假余尊法诵持故。法界智印善印故。教授出离因。如是化者得自利不忘故。已说意加。云何身加。摩顶觉故

经曰。尔时十方诸佛。不离本处以神通力皆申右手。善摩金刚藏菩萨摩诃萨顶

论曰。不离本处而摩此者。显示殊胜神力。若来此处则非奇异。是如意通力非余通等。已说加分。云何起分

经曰。诸佛摩金刚藏菩萨顶已。尔时金刚藏菩萨即从三昧起

论曰。即从三昧起者。以三昧事讫故。又得胜力。说时复至定无言说故。已说起分。云何本分

经曰。起三昧已告诸菩萨言。诸佛子。是诸菩萨愿善决定无杂不可见。广大如法界。究竟如虚空。尽未来际覆护一切众生界。佛子。是诸菩萨乃能入过去诸佛智地。乃能入未来诸佛智地。乃能入现在诸佛智地。诸佛子。此菩萨十地是过去未来现在诸佛已说今说当说。我因是事故如是说。何等为十。一名欢喜地。二名离垢地。三名明地。四名焰地。五名难胜地。六名现前地。七名远行地。八名不动地。九名善慧地。十名法云地。诸佛子。此菩萨十地过去未来现在诸佛已说今说当说。佛子。我不见有诸佛世界是诸如来不叹说此菩萨十地者。何以故。此是菩萨摩诃萨增上胜妙法故。亦是菩萨光明法门。所谓分别十地事。诸佛子。是事不可思议。所谓菩萨摩诃萨诸地智慧

论曰。何故不请而说。若不自说众则不知为说不说。又复不知欲说何法。愿善决定者。如初地中说发菩提心。即此本分中愿应知。善决定者。真实智摄故。善决定者。即是善决定。此已入初地。非信地所摄。此善决定有六种。一者观相善决定真如观一味相故。如经无杂故。二者真实善决定。非一切世间境界出世间故。如经不可见故。三者胜善决定。大法界故。一切佛根本故。如经广大如法界故。大胜高广一体异名法相义故。一切法法尔故。复法界大真如观。胜诸凡夫二乘智等净法法尔故。复法界大方便集地。谓说大乘法法尔故。复法界大白法界善法法尔故。四者因善决定有二种。一成无常爱果因善决定。是因如虚空。依是生诸色。色不尽故。如经究竟如虚空故。二常果因善决定。得涅槃道。如经尽未来际故。五者大善决定。随顺作利益他行。如经覆护一切众生界故。次前善决定。此愿世间涅槃中非一向住故。六者不怯弱善决定。入一切诸佛智地不怯弱故。如经佛子是诸菩萨乃至入现在诸佛智地故。复此十地生成佛智住持故。如经诸佛子此菩萨十地是过去未来现在诸佛已说今说当说故。于中善决定者是总相。余者是别相。同相者善决定。异相者别相故。成相者是略说。坏相者广说故。如世界成坏。何故定说菩萨十地。对治十种障故。何者一障。一者凡夫我相障。二者邪行于众生身等障。三者闇相于闻思修等诸法忘障。四者解法慢障。五者身净我慢障。六者微烦恼习障。七者细相习障。八者于无相有行障。九者不能善利益众生障。十者于诸法中不得自在障。何故十地初名欢喜。乃至十名法云。成就无上自利利他行。初证圣处多生欢喜故名欢喜地。离能起误心犯戒烦恼垢等。清净戒具足故名离垢地。随闻思修等照法显现故名明地。不忘烦恼薪智火能烧故名焰地。得出世间智方便善巧能度难度故名难胜地。般若波罗蜜行有间大智现前故名现前地。善修无相行功用究竟能过世间二乘出世间道故名远行地。报行纯熟无相无间故名不动地。无碍力说法成就利他行故名善慧地。得大法身具足自在故名法云地。如是受法王位。犹如太子于诸王子而得自在。是处有微智障故不自在。对治此障故说佛地。又如怀孕在藏。菩萨十地亦复如是。以诸地有障故。如子生时。佛时亦尔。事究竟故。又如生时诸根觉了。佛亦如是。于一切境界智明了故。藏有十时。一者陀罗婆身时。二者捭罗婆身时。三者尸罗他身时。四者坚身时。五者形相似色身时。六者性相似身时。七者业动身时。八者满足身时。于中有三种根满足时。男女相别满足时。广长诸相满足时。如是十时诸地相似故。佛子我不见有诸佛世界是诸如来不叹说此菩萨十地者。显此胜法为令时众增渴仰故。佛世界者。于中成佛。喻如稻田。往作佛事者。亦名佛世界。叹说者。于中有二种。一者为说阿含义。二者为证入义。摩诃萨者。有三种大。一愿大。二行大。三利益众生大。胜妙法者。诸法门中最殊胜故。光明者。此大乘法显照一切余法门故。法门者。名为法故。分别十地事者。显示世间智所知法故。是事不可思议。所谓菩萨摩诃萨诸地智慧者。显示出世间智故。此非世间分别地智能成菩萨清净道故。已说本分。云何请分

经曰。尔时金刚藏菩萨。说诸菩萨十地名已。默然而住。不复分别。是时一切菩萨众闻说菩萨十地名已。咸皆渴仰欲闻解说。各作是念。何因何缘。是金刚藏菩萨说诸菩萨十地名已。默然而住。不更解释。时大菩萨众中有菩萨名解脱月。知诸菩萨心深生疑已。即以偈颂问金刚藏菩萨曰

  何故净觉人　　念智功德具
  说诸上妙地　　有力不解释
  决定此一切　　菩萨大名称
  何故说地名　　而不演其义
  此众皆乐闻　　佛子智无畏
  如是诸地义　　愿为分别说
  此众皆清净　　离懈怠严净
  安住坚固中　　功德智具足
  迭共相瞻住　　一切咸恭敬
  如蜂欲熟蜜　　如渴思甘露

论曰。何故默然住。欲令大众渴仰请说故。复增菩萨尊敬法故。何故解脱月菩萨初请。彼众上首故。余问则乱众调伏故。何故偈颂请。少字摄多义故。诸赞叹者多以偈颂故。此五偈说何等义。显示说者听者无诸过故。若有过者则不应说。是中显示说者净觉无过故。复显听者同法决定故。有乐闻故。复示余者净心故。又显此众皆堪闻法故。偈言迭共相瞻住故。云何叹说者。偈言

  何故净觉人　　念智功德具
  说诸上妙地　　有力不解释

何故唯叹净觉。净觉是说因故。觉名觉观。是口言行有净说因何故不说。叹净觉有二种。一摄对治。二离诸过。是中念智具者。摄对治故。所治有二种。一者杂觉。二者杂觉因忆想分别故。念者四念处。对治杂觉故。智者真如无相智。对治杂觉因忆想分别故。余者显示离诸过。是过有三种。有三过者则不能说。何者为三。一悭嫉。二说法懈怠。三不乐说。悭者其心吝法。嫉者忌他胜智。功德具者。不嗔等功德具。示无初过故。说上地者。示无第二过故。有力者。示无第三过故。如是二种净觉叹说者已。次叹听者。偈言

  决定此一切　　菩萨大名称
  何故说地名　　而不演其义

决定者。黠慧明了故。决定有三种。一上决定。愿大菩提故。二名闻决定。他善敬重故。三摄受决定。彼说者善知故。偈言。菩萨故。大名称故。说地名故。如是次第应知。虽有决定堪受法器。心不欲闻亦不得说。偈言

  此众皆乐闻　　佛子智无畏
  如是诸地义　　愿为分别说

决定者。是中有阿含决定非证决定。有非现前决定无现前决定。如是决定法器不满足故不能听受。示现此众具足决定故能听受偈言佛子智无畏故。智有二种。一证法故。二现受故。如是善知法器满足请金刚藏。如是诸地义。愿为分别说。已叹同法众决定乐闻功德。次复叹异众。偈言

  此众皆清净　　离懈怠严净
  安住坚固中　　功德智具足

清净者不浊故。浊有六种。离此诸浊故言清净。何者为六。一不欲浊。二威仪浊。三盖浊。四异想浊。妒胜心破坏心故。五不足功德浊。善根微少故。是故于彼说中心不乐住。六痴浊。谓愚闇等故。此对治有六种不浊。安住坚固者。于所说法修行坚固。如是次第相对。离懈怠者。对不欲浊。严者对威仪浊。净者对盖浊。坚固者对异想浊。功德具者对不足功德浊。智具者对痴浊。此六句示现是二偈显同生众净。次一偈显异生众净。后一偈显二众清净。偈言

  迭共相瞻住　　一切咸恭敬
  如蜂欲熟蜜　　如渴思甘露

迭共相瞻者。示无杂染心故。咸恭敬者。示敬重法。非妒心故。下半偈喻敬法转深。此偈迭共相瞻是总相。一切咸恭敬是别相。如是余偈初句总相。余句别相。同异成坏如上所说。偈曰

  大智无所畏　　金刚藏闻已
  欲令大众悦　　即时说颂曰
  难第一希有　　菩萨所行示
  地事分别上　　诸佛之根本
  微难见离念　　非心地难得
  境界智无漏　　若闻则迷闷
  持心如金刚　　深信佛智慧
  心地无我智　　能闻智微细
  如彩画虚空　　如虚空风相
  智如是分别　　难见佛无漏
  我念佛智慧　　第一世难知
  难信希有法　　是故我默然

论曰。此初偈中。欲令大众悦是总正詶答相。詶答有二种。一堪詶答。二不怯弱詶答。偈言大智故。无所畏故。离不堪答。离不正答。此二示现自他无过故。何者是正答相。此法难说复难闻故。云何难说。偈言

  难第一希有　　菩萨所行示
  地事分别上　　诸佛之根本

难者难得故。难有二种。一最难。二未曾有难。偈言。第一故希有故。此二示现所说难。何者是难。偈言菩萨所行示地事分别上。菩萨行者。是出世间智。示者。显示故。地事者。谓诸地菩萨行事。分别上者。说胜故。何者菩萨行。偈言。诸佛之根本。佛者觉佛智故。已说难说复说所以难。何者是难。彼菩萨行事义住不可如是说。云何彼义住。偈言

  微难见离念　　非心地难得
  境界智无漏　　若闻则迷闷

此偈中。难得者是总。余者是别。难得者难证故。是难得有四种。一微难得。二难见难得。三离念难得。四非心地难得。微难得者。非闻慧境界故。粗事不须思惟。难见难得者。非思慧境界故。离念难得者。非世间修慧境界故。示现三界心心数法分别。世间修道智非境界故。非心地难得者。示现报生善得修道智非境界故。此示现心境界者是心地此谁境界。偈言智境界。何者是智见实义故。何故非余境界。无漏故。无漏者。出世间义。是义非世间智境界。如是甚深义。如是可解。如是不可说。若闻则迷闷者。云何迷闷。随闻取着故。闻者即闻非是不闻。已辩难说。复显难闻。偈言

  持心如金刚　　深信佛智慧
  心地无我智　　能闻智微细

如金刚者。坚如金刚。坚有二种。一决定信坚。二证得坚。此三句示现坚者是总。余者是别。云何深信佛智慧。唯佛所知。非我境界。佛菩提无边。佛化众生所说法门种种信故。何者是心地。云何无我智。心地者。随心所受三界中报。又随心所行一切境界亦名心地。无我智者有二种。我空法空。如实知故。能闻智微细者。难知。如是微细如前所说。复以譬喻显微细义。偈言

  如彩画虚空　　如虚空风相
  智如是分别　　难见佛无漏

此偈示现如空中画色如壁。是中不住故不可见。如空中风如树叶。是中不住故不可见。此动作者。非不空中有是二事。如是虚空处事不可说处。是画风如说。以非自性不可得见。是不住故。以其客故。非不于中有此言说。如是佛智言说显示地校量胜分别难见。画者。喻名字句身。何以故。依相说故。风者以喻音声。说者以此二事说。听者以此二事闻。若如是可说。如是可闻。如是难见。何故不说

  我念佛智慧　　第一世难知
  难信希有法　　是故我默然

难知者难证故。难信者难生决定心故。此偈示现有证有信可说可闻。世间难得证信故。我不说

经曰。尔时解脱月菩萨闻说此已。请金刚藏菩萨言。佛子。是大菩萨善净众集。善清净深心。善清净诸念。善集诸行多亲近诸佛。善集助道法。具足无量功德。离痴疑悔无有染污。善住深心信于佛法中不随他教。善哉佛子。敷演此义。是诸菩萨于是深法皆能证知

论曰。圣者解脱月何故复叹此众。上言世间证信者难得。示现此众有堪能故。善净深心者是总。此善净深心有二种。一阿含净。二证净。是阿含净有五种。一者欲净。随所念阿含得方便念觉净。如经善清净诸念故。二者求净。得随顺身口敬行。如经善集诸行故。三者受持净。于无量世多闻忆持不谬故。如经多亲近诸佛故。四者生得净。愿得上上生胜念胜。如经善集助道法故。五者行净。求善证法习少欲头陀等成就多功德。如经具足无量功德故。证净者有四种。一者得净。现智善决定故。如经离痴疑悔故。二者不行净。修道中一切烦恼不行故。如经无有染污故。三者无厌足净。不乐小乘得上胜悕望心。如经善住深心信故。深心者悕欲故。信者决定故。复念持彼功德故。四者不随他教净。趣尽道中自正行故。如经于佛法中不随他教故

经曰。尔时金刚藏菩萨言。佛子。虽此菩萨众善清净深心善清净诸念善集诸行多亲近诸佛善集助道法具足无量功德离痴疑悔无有染污善住深心信于佛法中不随他教。其余乐小法者。闻是甚深难思议事多生疑惑。是人长夜受诸无利衰恼。我愍此等。是故默然

论曰。是圣者金刚藏领彼解脱月菩萨所叹众清净功德已。于所说法中不见法器闻增疑惑。是故不说。于一法中有二种过。疑者正行相违犹豫义故。惑者心迷义故。能坏善法远离善法故。如是显示不受行因受行退因

经曰。尔时解脱月菩萨请金刚藏菩萨言。善哉佛子。重请此事。愿承佛神力。善分别此不可思议法佛所护念事。令人易信解。所以者何。善说十地义。十方诸佛法应护念。一切菩萨护是智地勤行方便。何以故。此是菩萨最初所行成就一切诸佛法故。佛子。譬如一切书字数说。皆初章所摄。初章为本。无有书字数说不入初章者。如是佛子。十地者。是一切佛法之根本。菩萨具足行是十地。能得一切智慧。是故佛子。愿说此义。诸佛护念加以神力。令人信受不可破坏

论曰。圣者解脱月何故复重请。示彼疑惑此不可避。若不说者有多过咎。不得成就一切佛法故。以是义故重请金刚藏菩萨。若诸佛有力能令生信。何故众生于彼法中犹起谤意。有二种定。一感报定。二作业定。此二种定。诸佛威力所不能转。最初所行者。依阿含行故。成就一切佛法者。谓是证智。书者是字相。如嘶字师子形相等。字者恶阿等音。数者名句。此二是数义。说者是语。一切书字数说等。皆初章为本

经曰。尔时诸菩萨众。一时同声以偈颂请金刚藏菩萨言

  上妙无垢智　　堪无量义辩
  演说美妙言　　真实义相应
  念坚清净慧　　为十力净心
  无碍分别义　　说此十地法
  定戒深正意　　离我慢妄见
  此众无疑心　　唯愿闻善说
  如渴思冷水　　如饥思美食
  如病思良药　　如众蜂依蜜
  我等亦如是　　愿闻甘露法
  善哉清净智　　说胜地无垢
  具十力无碍　　尽说善逝道

论曰。初偈叹证力辩才成就。第二偈上句叹阿含力辩才成就。以证力阿含力故能有所说。是故赞叹。上者是总。又复上者显证力辩才胜故。叹辩才有三种。一真实智二体性三者果。真实智者是无漏智。胜声闻缘觉智等。偈言妙无垢智故。体性者成就无量义辩才。偈言堪无量义辩故。果者字义成就。复是滑利胜上字义成就。偈言演说美妙言真实义相应故。第二偈上句叹阿含力。偈言

  念坚清净慧　　为十力净心
  无碍分别义　　说此十地法

念坚者受持显说故。是菩萨于阿含中净慧无疑故。如是叹证力阿含力已。次令听者入证入阿含。是故请说。云何入证。已入地者令得佛力故。未入地者令得入地故。偈言为十力故为净心故。云何为入阿含。无碍分别义令受持十地法故。如是叹说者成就证力阿含力已。次复叹听众堪受阿含及证力故。偈言

  定戒深正意　　离我慢妄见
  是众无疑心　　唯愿闻善说

此偈中唯愿者是总。唯愿有二种。一求阿含。二求正证。有二种妄想不堪闻阿含。一我二慢。以我慢故于法法师不生恭敬。复有二种妄想不堪得证。一见二疑。见者颠倒见故。疑者于不思议处不生信故。妄者谓妄想见中同使故。有二种对治堪闻阿含。一定二戒。定者心调伏故。戒者善住威仪故。次有二种对治堪能得证。一正见二正意。正见者善思义故。正意者得欢喜故。深者细意善思惟故。复以诸喻显示大众求法转深。偈言

  如渴思冷水　　如饥思美食
  如病思良药　　如众蜂依蜜
  我等亦如是　　愿闻甘露法

此四喻者喻四种义门。示现正受彼所说义。何等为四。一受持。二助力。三远离。四安乐行。此义云何。如水不嚼随得而饮。如是闻慧初闻即受随闻受持。如食咀嚼身力助成。如是思慧嚼所闻法智力助成。如服良药药行除病。如是具闻思慧随顺正义如法修行。远离一切烦恼习患。如蜜众蜂所依乐行住处。如是闻思修慧果圣所依处。现法爱味受乐行故。如是赞叹说者听者请说已。次叹所说法利益咸皆共请。偈言

  善哉清净智　　说胜地无垢
  具十力无碍　　尽说善逝道

善哉者所说法中善具足故。善哉有三种。一所依二体性三果。所依者谓净慧。体性者谓说诸地未曾说法。胜地者地挍量胜。无垢者说不违义。违义说者有三种垢。一者倒说。二谤如来。三诳闻者。果者谓具十力无障碍佛菩提故。如是请已犹故不说。何故不说请不满故

十地经论初欢喜地卷第一十地经论初欢喜地卷之二

        天亲菩萨造

        后魏北印度三藏菩提流支译

论曰。此菩萨前同生众上首请。次大众请。复待诸佛法王加请。何以故。为增敬重法故

经曰。尔时释迦牟尼佛。从眉间白毫放菩萨力明光焰阿僧祇阿僧祇光以为眷属。放斯光已。普照十方诸佛世界靡不周遍。照已还住本处。三恶道苦皆得休息。一切魔宫隐蔽不现。悉照十方诸佛众会。显现如来境界不思议力。是光遍照十方世界。加一切如来所。加说法者及诸菩萨众。于上虚空中成大光明云网台而住。彼十方诸佛亦复如是。从眉间白毫相放菩萨力明光焰阿僧祇阿僧祇光以为眷属。放斯光已。普照十方诸佛世界靡不周遍。照已还住本处。三恶道苦皆得休息。一切魔宫隐蔽不现。悉照十方诸佛众会。显现如来境界不思议力。是光遍照十方世界加一切如来所。加说法者及诸菩萨众。显现如来境界不思议力。并照释迦牟尼佛大会之众。及金刚藏菩萨身。于上虚空中亦复成大光明云网台而住。尔时释迦牟尼佛从眉间放白毫光明。照彼十方世界诸佛大会诸菩萨身及师子座。此诸大众皆悉现。见彼十方世界诸佛从眉间放白毫光明。照此三千大千娑婆世界释迦牟尼佛大会。并金刚藏菩萨身及师子座。彼诸大众皆悉现见。时大光明云网台中诸佛神力故。而说颂曰

论曰。何故如来现神通力放光同请。是如来前已意加未身口加异于余佛。是故今欲具身口加。何故不以常口常身加。为重法故。不轻自身故。此光有八种业二种身。云何八种业。一者觉业。是光照诸菩萨身已。自觉如来力加。如经放菩萨力明光焰故。二者因业。阿僧祇光皆有无量光明眷属。如经阿僧祇阿僧祇光以为眷属故。三者卷舒业。舒则遍至阿僧祇世界。卷则还入常光。如经放斯光已普照十方诸佛世界靡不周遍。照已还住本处故。四者止业。除灭一切恶道种种苦恼。如经三恶道苦皆得休息故。五者降伏业。令一切魔宫威光不现惊怖恐惧不能坏乱可化众生。如经一切魔宫隐蔽不现故。六者敬业。现不思议佛神力故。如经悉照十方诸佛众会显现如来境界不思议力故。七者示现业。加十方世界诸佛所加菩萨大会令此众见。如经是光遍照十方世界加一切如来所加说法者及诸菩萨众故。八者请业。发声说偈。如经时大光明云网台中诸佛神力而说颂曰故。云何二身。一如流星身往他方世界故。二如日身处于虚空。如经于上虚空中成大光明云网台而住故。于一切处一时遍照故。如是彼此诸众生迭互相见。犹如一会听说亦尔。是名身加。何者口加。偈曰

  诸佛无等等　　功德如虚空
  十力无畏等　　无量诸众首
  释迦姓法生　　天人上作加
  承诸佛神力　　为开法王藏
  诸地上妙行　　分别智地义
  是诸如来加　　护于诸菩萨
  此人能闻持　　如是微妙法
  诸地净无垢　　渐次而满足
  证佛十种力　　成无上菩提
  虽在于大海　　及劫尽火中
  决定信无疑　　必得闻此经
  诸地胜智道　　入地住展转
  渐次而演说　　无量行境界

论曰。是初二偈半显能加者及加所为。此二加示现何义故加。若请非尊者法非殊胜圣者则不说。云何初偈显能加者。偈言天人上作加故。何者天人上。谓诸佛如来。此有何义。法王义故。云何知彼是法王。成就四种胜故。一自在胜。二力胜。三眷属胜。四种姓胜。何者诸佛自在胜。于烦恼障智障得解脱自在。彼于此处心智无碍随意所受无上乐故。此云何知。偈言诸佛无等等故。谓一切智故。复如虚空世间法不能染。无明烦恼习气灭故。无等者。诸佛比余众生彼非等故。等者此彼法身等故。何故不但说无等。示现等正觉故。何者诸佛力胜。具足十力故。能伏一切邪智坏魔怨故。此云何知。偈言十力无畏等故。何者诸佛眷属胜。具摄菩萨声闻诸众故。此云何知。偈言无量诸众首故。彼菩萨是初众故。无量者阿僧祇故。诸众首者。佛于世间最胜上故。何者佛种姓胜。谓家姓胜故。此云何知。偈言释迦姓法生故。何故唯叹此佛种姓。以现见故。复以法为家非但生家。法家者如法中住故。作加者是总相。加有二种。一具身加。依法身故。二具果加。证佛果故。天人上者亦总亦别。余者唯别。云何第二偈显加所为。此菩萨彼诸佛法王。为开现法藏义故加。偈言

  承诸佛神力　　为开法王藏
  诸地上妙行　　分别智地义

叹此法藏有二种。一义藏成就。二字藏成就。云何义藏。偈言诸地上妙行。行者诸菩萨行。所谓助道法故。妙者真实智故。上者神力胜故。如是显示深妙胜上故。云何字藏。偈言分别智地义。分别者说十地差别故。此偈中何故显承佛神力说。或有众生于如来所生轻慢想已。自不能请他而说。为遮此故。如是请说法已。次显说法利他有三时益。于中有三偈。三时益者。一闻时益。二修行时益。三转生时益。何者闻时益。偈言

  是诸如来加　　护于诸菩萨
  此人能闻持　　如是微妙法

菩萨闻持者佛力加故。是名闻时益。何者修行时益。偈言

  诸地净无垢　　渐次而满足
  证佛十种力　　成无上菩提

渐次满十地自身得十力成无上菩提故。是名修行时益。何者转生时益。偈言

  虽在于大海　　及劫尽火中
  决定信无疑　　必得闻此经

恶道善道难处生必得闻此法。龙世界长寿亦得闻此经。偈言虽在于大海故。虽在色界光音天等亦得闻此经。偈言及劫尽火中故。闻此法者为皆得利益有不得者不也。何者能得决定不疑。信此法者是人能得。偈言决定信无疑必得闻此经故。如是显示请说利益已。上言分别智地义者。此所说法有三种渐次。第六偈教分别此事。偈言

  诸地胜智道　　入地住展转
  渐次而演说　　无量行境界

何者三渐次。一观渐次。二证渐次。三修行渐次。第一第二第四句皆说渐次。胜智道者。谓十地胜智道。说此十地若观若依止能生诸地智故。入者入地故。住者未转向余地故。展转者地地转所住处故。行者谓入住展转成就故。境界者此行种种异行境界故。渐者次第故。说者授与故。如是教说何义故显一切因如来能有所说生后正信义故

经曰。尔时金刚藏菩萨摩诃萨观察十方。欲令大众重增踊悦生正信故。以偈颂曰

  微难知圣道　　非分别离念
  难得无垢浊　　智者智行处
  自性常寂灭　　不灭亦不生
  自体本来空　　有不二不尽
  远离于诸趣　　等同涅槃相
  非初非中后　　非言辞所说
  出过于三世　　其相如虚空
  定灭佛所行　　言说不能及
  地行亦如是　　难说复难闻
  离念及心道　　智起佛境界
  非阴界入说　　心意所不及
  如空中鸟迹　　难说不可见
  十地义如是　　不可得说闻
  我但说一分　　慈悲及愿力
  渐次非心境　　智满如净心
  是境界难见　　难说自心知
  我承佛力说　　咸共恭敬听
  如是智入行　　亿劫说不尽
  今如是略说　　如实满足住
  一心恭敬待　　承佛力善说
  说上法妙音　　喻相应善字
  是言说甚难　　无量佛神力
  光焰入我身　　是力我能说

论曰。何故观察十方。示无我慢无偏心故。欲令大众重增踊悦深生正信。是故说偈示说正地。增益闻者堪受义故。踊悦者心清不浊故。踊悦有二种。一义大踊悦为得义故。二说大踊悦因此说大能得彼义故。是中前五偈显义大踊悦。云何义大。彼义深故。何者深义。偈言

  微难知圣道　　非分别离念

此偈依何义说。依智地故。云何知依智地。上来所说皆依智地。后复所说亦依智地。第四偈言智起佛境界故。微者云何微。偈言难知圣道故。云何难知谓说时难知。复云何难知。大圣道难知。大圣者所谓诸佛。是故言微。道者是因。修行此道能到圣处故。言难知圣道。此微有二种。一说时甚微。二证时甚微。如是次第何故复难知。偈言非分别离念故。非分别者离分别境界故。离念者自体无念故。如是圣道名为甚微。何故甚难得。难得者难证故。是名甚微。何故复甚难得。偈言

  难得无垢浊　　智者智行处
  自性常寂灭　　不灭亦不生

无垢浊者。智中无无明故。有无明杂智是名为浊。智者智行处者。自证知故。自证知者依彼生故。于中智者见实谛义故。复增上善解法故。增上善寂灭故。复有世间智随闻明了知故。自性常寂灭者。自性离烦恼故。非先有染后时离故。不灭者非一往灭为不舍利益众生故。不生者出世间故。如是此智不住涅槃世间中故。如是观行甚微依止甚微清净甚微功德甚微故。言甚难得。于中第一甚微不同世间三昧故。第二第三不同外道自言尊者故。第四不同声闻辟支佛故。于此偈中微者是总。二种微是别。复显难得得时甚微是总。余四种甚微是别。此甚微智复有何相。偈言

  自体本来空　　有不二不尽
  远离于诸趣　　等同涅槃相
  非初非中后　　非言词所说
  出过于三世　　其相如虚空

是智相有二种。所谓同相不同相。是中同相者。云何相彼智相故。偈言自体本来空智自空故。云何同相一切诸法如说自体空。自体空者可如是取如兔角耶不也。可如是取异此空智更有异空耶不也。可如是取有彼此自体彼此转灭耶不也。云何取此自体空。有不二不尽如是取。此句显离三种空摄。一离谤摄。二离异摄。三离尽灭摄。有二种颂。一有不二不尽。二定不二不尽。此颂虽异。同明实有。若非实有不得言定。此云何定。此定能灭诸烦恼故是名同相。何者不同相。谓净相解脱。此复有二种。一何处得解脱。二云何解脱。何处得解脱者。偈言远离于诸趣。此显诸道解脱远离烦恼业生故。云何解脱者。偈言等同涅槃相。世间涅槃平等摄取故。非如声闻一向背世间故。此智尽漏为初智断为中为后。非初智断亦非中后。偈言非初非中后故。云何断如灯焰非唯初中后。前中后取故。如是解脱可同他音声观耶不也。云何观。偈言非言辞所说离语言故。可同世间智依世间耶不也。云何依。偈言出过于三世。转依止依止常身故。非如无常意识智依止无常因缘法。如修多罗中决定说此解脱可同声闻缘觉智有障解脱得解脱耶不也。云何解脱。偈言其相如虚空无一切烦恼障碍故。如是观智如是断烦恼如是观观如是依止。依止如是解脱得解脱。如是说已。于中自体空是总。三种空是别。解脱是总。五种解脱是别。偈言

  定灭佛所行　　言说不能及
  地行亦如是　　难说复难闻

此偈云何彼智已显方便坏涅槃。复示性净涅槃。偈言定灭故。定者成同相涅槃自性寂灭故。灭者成不同相方便坏涅槃。示现智缘灭故。此智是谁证。偈言佛所行故。谁说谁听无说无听。偈言言说不能及故。言说者。以音言导。谓名句字身。何故不但说无言。示现依言求解故。彼智既如是。地行复何相。偈言地行亦如是难说复难闻。地者境界。观行者智眷属。智眷属者谓同行。同行者谓檀等诸波罗蜜。何故复难说难闻。偈言

  离念及心道　　智起佛境界
  非阴界入说　　心意所不及

此偈示现思慧及报生识智是则可说。此智非彼境界以不同故。偈言智起佛境界故。如阴界入可说。此智不尔。离文字故。是故不可说。偈言非阴界入说故。非耳识所知非意识思量是故不可闻。偈言心意所不及故。智者是地。智起者以何观以何同行能起此智。云何可证而不可说而不可闻。今复以喻证成此义。偈言

  如空中鸟迹　　难说不可见
  十地义如是　　不可得说闻

此偈示何义。如鸟行空中。迹处不可说。相亦不可见。何以故。虚空处鸟迹相不可分别故。非无虚空行迹。如是鸟迹住处名句字身住处。菩萨地证智所摄。不可得说不可得闻。何以故。非如声性故。非无地智名句字身。此中深故。示义大踊悦。何故我复说此。汝等不应如声取义。随声取义有五种过。一不正信。二退勇猛。三诳他。四谤佛。五轻法。大众自知无此五过已说深义。复显说大令生正信。次说五偈

  我但说一分　　慈悲及愿力
  渐次非心境　　智满如净心
  是境界难见　　难说自心知
  我承佛力说　　咸共恭敬听
  如是智入行　　亿劫说不尽
  今如是略说　　如实满足住
  一心恭敬待　　承佛力善说
  说上法妙音　　喻相应善字
  是言说甚难　　无量佛神力
  光焰入我身　　是力我能说

前言十地义。如是不可得说闻。今言我但说一分。此言有何义。是地所摄有二种。一因分二果分。说者谓解释。一分者是因分于果分为一分故。言我但说一分。此说大有三种。一因成就大。二因渐成就大。三教说修成就大。何者因成就大。偈言慈悲及愿力故。慈者同与喜乐因果故。悲者同拔忧苦因果故。愿者发心期大菩提故。此慈悲愿长夜熏修不同二乘故。何者因渐成就大。偈言渐次故。渐者说闻思慧等次第乃至能生出世间智因故。何者教说修成就大。有二种。一满足修。二观修。满足修者偈言非心境故。非心境者。此句示现闻思慧等心境界处。唯是智因能生出世间智。而此不能满彼出世间智地。偈言智满如净心故。如净心者。如出世间清净心。能满彼地智故。观修者偈言

  是境界难见　　难说自心知
  我承佛力说　　咸共恭敬听

此偈显何义。是境界难见。自心清净可见。此境界不可说。如是教说修成就已。于说法中有二种过。不能得证。一说者过二听者过。说者过有二种。一佛不随喜说。二不平等说。听者亦有二种过。一见诤过。我法是彼法非如是执着种种诸见。二于说法者不生恭敬。于中示现说者自身无过。我非诸佛不随喜说。偈言。我承佛力说咸听故。次教听者防二种过。偈言。共恭敬听故。如是次第如是许说。而众未知广说略说。不可广说唯许略说。地义满足。如第三偈说

  如是智入行　　亿劫说不尽
  今如是略说　　如实满足住

智入者。此所说地法众生以智入。云何入如实满足摄取。入如行修故。如行修满足故。示彼广说义摄取故。住者如来家决定住故。我如是说前言恭敬听不说云何恭敬是故示现。偈言

  一心恭敬待　　承佛力善说
  说上法妙音　　喻相应善字

一心恭敬待者有二种。一身正恭敬待。如威仪住堪受说法故。二心正恭敬待。如心决定堪能忆持故。此句劝诫二种恭敬待。所谓身心故。善说者示己无谄无有憍慢故。承佛力者示己无增上慢故。下半偈说上法妙音喻相应善字。示现何事以何事云何事依止何事。示现何事者所谓上法。以何事者谓妙音声。云何事者譬喻相应。依止何事者谓依止善字。我一切善说。又相应者譬喻共相应。善字者有二种相。一随方言音善随顺故。二字句圆满。不增不减与理相应故言善字。前言承佛神力。未说云何力。第五偈示现佛神力事。偈言

  是言说甚难　　无量佛神力
  光焰入我身　　是力我能说

已说请分。自此以后正说初地。此说分中说何等事。分别有三。一住二释名三安住。住中有四种。依何身为何义以何因有何相。彼心生时即住初地。是名为住。于中诸佛子善集善根故。如是等四十句说此住事。初说依何身生如是心

经曰。诸佛子若有众生厚集善根故。善集诸善行故。善集诸三昧行故。善供养诸佛故。善集清白法故。善知识善护故。善清净心故。入深广心故。信乐大法好求佛智慧故。现大慈悲故。如是众生乃能发阿耨多罗三藐三菩提心

论曰。如是十句说依何身。此集有九种。一者行集善作眷属持戒。如经善集诸善行故。二者定集善作眷属三昧。如经善集诸三昧行故。三昧行者观行增上故。三者亲近集善习闻慧智。如经善供养诸佛故。四者聚集思慧智善思量波罗蜜等诸善法。如经善集清白法故。五者护集修行实证善得教授。如经善知识善护故。六者净心集得出世间正智。如经善清净心故。七者广集深心作利益一切众生。如经入深广心故。八者信心集求一切智智。如经信乐大法好求佛智慧故。九者现集多行慈悲。如经现大慈悲故。于中慈念依苦苦坏苦悲依行苦。是中初二种集显增上戒学增上定学。行集善作眷属持戒故。定集善作眷属三昧故。次有四集显增上慧学。亲近集善习闻慧智故。聚集思慧智善思量波罗蜜等诸善法故。护集修行实证善得教授故。净心集得出世间正智故。后三集显胜声闻辟支佛等故。广集深心作利益一切众生故。信心集求一切智智故。现集多行慈悲故。此十句中厚集善根是总。余九种是别。集者是同相。别者是异相。成者略说故。坏者广说故。已说依何身生如是心。次说为何义故生如是心

经曰。为得佛智故。为得十力力故。为得大无畏故。为得佛平等法故。为救一切世间故。为净大慈悲故。为得十方无余智故。为得一切世界无障净智故。为得一念中觉三世事故。为得转大法轮无所畏故。菩萨摩诃萨生如是心

论曰。于中佛智者。谓无上智知断证修故。此佛智有九种业差别。为求彼故生如是心。一者力佛智问记业。此如来是处非处智力问记故。如修多罗中说。如经为得十力力故。二者无畏佛智破邪说业。如经为得大无畏故。三者平等佛智得人法无我教授众生证入业。如经为得佛平等法故。四者救佛智以四摄法化众生业。如经为救一切世间故。五者净佛智是净为救摄因业。如经为净大慈悲故。六者无余智佛智常以佛眼观世间众生业。如经为得十方无余智故。七者无染佛智一切世界无障无染自然应化令信作业。智心无碍。如经为得一切世界无障净智故。八者觉佛智于一念中知三世众生心心数法业。如经为得一念中觉三世事故。九者转法轮佛智解脱方便善巧业故。于百亿阎浮提同时转大法轮。如经为得转大法轮无所畏故。生如是心者。即是本分中说诸佛子是菩萨愿善决定故。何故唯言生心不言生智及余心数法。心中即摄知断证修一切助道法故。已说为何义故生如是心。次说以何因生如是心

经曰。是心以大悲为首。智慧增上方便善巧所摄。直心深心淳至。如来力无量。善决定众生力智力。随顺自然智能受一切佛法。以智慧教化。广大如法界。究竟如虚空尽未来际

论曰。此大悲为首。于中悲大有九种。一者增上大细苦智增上生故。如经智慧增上故。智者因果逆顺染净观故。慧者自相同相差别观故。二者摄大救苦众生方便善巧所摄。如经方便善巧所摄故。三者淳至大向时许乃至尽众生界作利益众生悲心增上。如经直心深心淳至故。四者无量大摄取如来无量力。如经如来力无量故。五者决定大上妙决定信深智胜对治。如经善决定众生力智力故。六者随顺大随顺菩提正觉。如经随顺自然智故。七者正受大能取大胜法教授众生。如经能受一切佛法以智慧教化故。八者最妙大摄受胜妙功德。如经广大如法界故。九者住尽大无量爱果因尽涅槃际。如经究竟如虚空尽未来际故。已说以何因生如是心。次说是心生时有何等相

经曰。菩萨生如是心。即时过凡夫地入菩萨位生在佛家。种姓尊贵无可讥嫌。过一切世间道入出世间道。住菩萨法中住在菩萨正处。入三世真如法中。如来种中。毕定究竟阿耨多罗三藐三菩提。菩萨住如是法名住菩萨欢喜地。以不动法故

论曰。过凡夫地者以过凡夫地故。示现得出世间圣道。此过有八种。一者入位过初成出世间心。如始住胎相似法故。如经入菩萨位故。二者家过家生相似法故。如经生在佛家故。三者种姓过子相似法大乘行生故。如经种姓尊贵无可讥嫌故。四者道过世间出世间道不摄摄故。异道生相似法故。如经过一切世间道入出世间道故。五者法体过以大悲为体于作他事即是己事自身体相似法故。如经住菩萨法中故。六者处过不舍世间方便不染善巧住故。住处相似法故。如经住在菩萨正处故。七者业过顺空圣智生命相似法故。如经入三世真如法中故。八者毕定过佛种不断究竟涅槃道成就相似法故。如经如来种中毕定究竟阿耨多罗三藐三菩提故。如是示现凡夫生菩萨生。入胎不相似。有烦恼无烦恼故。如是次第家不相似种姓不相似道不相似体不相似处不相似生业不相似成就不相似如是说住此地中是名为住。如经菩萨住如是法名住菩萨欢喜地。以不动法故。已说住义次说释名。云何说多欢喜故示名欢喜。以何欢喜。此地中菩萨欢喜复以何念。初说十句后说二十句

经曰。诸佛子。是菩萨住菩萨欢喜地中。成就多欢喜多信敬多爱念多庆悦多调柔多踊跃多堪受多不坏他意多不恼众生多不嗔恨

论曰。欢喜者名为心喜体喜根喜。是欢喜有九种。一者敬欢喜于三宝中恭敬故。如经多信敬故。二者爱欢喜。乐观真如法。如经多爱念故。三者庆欢喜。自觉所证挍量胜。如经多庆悦故。四者调柔欢喜。自身心遍益成就。如经多调柔故。五者踊跃欢喜。自身心遍益增上满足。如经多踊跃故。六者堪受欢喜。自见至菩提近。如经多堪受故。七者不坏欢喜。自心调伏论义解说时心不扰动。如经多不坏他意故。八者不恼欢喜。教化他摄取众生时慈悲调柔。如经多不恼众生故。九者不嗔欢喜。见诸众生不如说修行威仪不正时忍不嗔故。如经多不嗔恨故。已说多欢喜。次说以何念故欢喜成是第二十句第三十句说。是念有二种。一念当得二念现得。何者念当得

经曰。诸佛子菩萨住是欢喜地中。念诸佛故生欢喜心。念诸佛法故生欢喜心。念诸菩萨摩诃萨故生欢喜心。念诸菩萨所行故生欢喜心。念诸波罗蜜清净相故生欢喜心。念诸菩萨地挍量胜故生欢喜心。念诸菩萨力不退故生欢喜心。念诸如来教化法故生欢喜心。念能利益众生故生欢喜心。念入一切如来智行故生欢喜心

论曰。云何念。如佛所得我亦当得。如是念。此念佛有九种。一者念佛法。如经念诸佛法故生欢喜心。二者念佛菩萨。如经念诸菩萨摩诃萨故生欢喜心。三者念佛行。如经念诸菩萨所行故生欢喜心。四者念佛净。如经念诸波罗蜜清净相故生欢喜心。五者念佛胜。如经念诸菩萨地挍量胜故生欢喜心。六者念佛不退。如经念诸菩萨力不退故生欢喜心。七者念佛教化。如经念诸如来教化法故生欢喜心。八者念佛利益。如经念能利益众生故生欢喜心。九者念佛入如经念入一切如来智行故生欢喜心。于中初二念共念佛。如佛所得我亦当得故。念佛法念诸佛法故。佛佛法二故。念佛菩萨二念诸菩萨故。念佛行念诸菩萨行故。如是次第余有六句。念佛净念诸波罗蜜清净相故。念佛胜念诸菩萨地挍量胜故。念佛不退念诸菩萨力不退故。念佛教化念诸如来教化法故。念佛利益念能利益众生故。念佛入念入一切如来智行故。随所显彼菩萨行。以何显如是诸念应知。复何显彼波罗蜜净。显云何显彼菩萨行地挍量胜转去故地尽去故。于中余者得教化法故。作利益众生行不虚故。入如来地行故。是中念佛行者亦总亦别。已说念当得故生欢喜心。次说念现得故生欢喜心

经曰。诸佛子。菩萨复作是念。我转离一切世间境界故生欢喜心。近入如来所故生欢喜心。远离凡夫地故生欢喜心。近到智慧地故生欢喜心。断一切恶道故生欢喜心。与一切众生作依止故生欢喜心。近见一切诸佛故生欢喜心。生诸佛境界故生欢喜心。入一切菩萨真如法故生欢喜心。我离一切怖畏毛竖等事故生欢喜心

论曰。我转离一切世间境界者。转离一切凡夫取着事。此转离有九种。一者入转离。如经近入如来所故生欢喜心。二者远转离。如经远离凡夫地故生欢喜心。三者近至转离。如经近到智慧地故生欢喜心。四者断转离。如经断一切恶道故生欢喜心。五者依止转离。如经与一切众生作依止故生欢喜心。六者近见转离。如经近见一切诸佛故生欢喜心。七者生转离。如经生诸佛境界故生欢喜心。八者平等转离。如经入一切菩萨真如法故生欢喜心。九者舍转离。如经我离一切怖畏毛竖等事故生欢喜心。于中入转离者。显事不相似故。远转离近至转离者。示自身不相似故。余有六句。断转离依止转离近见转离生转离平等转离舍转离。如是次第行不相似故。迭相依止不相似故。他力不相似故。处不相似故。生业不相似故。成就不相似故。怖畏者不爱疑虑忧想共心相应故。复身相差别谓毛竖等事。次说何者是怖畏。云何怖畏因。远离此因无怖畏故

经曰。所以者何。是菩萨摩诃萨得欢喜地已。所有诸怖畏即皆远离。所谓不活畏恶名畏死畏堕恶道畏大众威德畏。离如是等一切诸畏。何以故。是菩萨离我想故尚不贪身。何况所用之事。是故无有不活畏。心不悕望供养恭敬。我应供养一切众生供给一切所须之具。是故无有恶名畏。远离我见无我想故无有死畏。又作是念。我若死已生必不离诸佛菩萨。是故无有堕恶道畏。我所志乐一切世间身心无与等者何况有胜。是故无有大众威德畏。诸佛子菩萨如是离诸怖畏毛竖等事

论曰。此五怖畏是初地障。复说地利益胜。是五怖畏第一第二第五依身口意。第三第四依身。依身者爱憎善道恶道舍得依身故。何故但说五怖畏。打缚等诸畏皆五所摄故。此怖畏因略有二种。一邪智妄取想见爱着故。二善根微少故。此对治如经离我想故。尚不贪身乃至无有大众威德畏故。怖畏毛竖等事。何故二处说。前说身怖畏。后说异身怖畏故

经曰。诸佛子。是菩萨以大悲为首。深大心坚固转复勤修一切善根成就故

论曰。深大心坚固者。烦恼小乘不能坏此观故。转复勤修一切善根成就者。诸所说善根此地摄受故。云何勤修。于中有三种成就。一信心成就二修行成就三回向成就。有三十句示现。初十句说信心成就

经曰。所谓信心增上故。多恭敬故。信清净故。多以信分别故。起悲愍心故。成就大慈故。心无疲懈故。以惭愧庄严故。成就忍辱安乐故。敬顺诸佛教法信重尊贵故

论曰。信心增上者。随所有事于中信增上成就。此信增上有九种。一者敬信增上尊敬三宝。如经多恭敬故。二者净信增上自证真净智。如经信清净故。三者分别信增上令他证净智。如经多以信分别故。四者悲信增上。五者慈信增上教化众生。如经起悲愍心故。成就大慈故。悲者除苦相决定救济故。慈者与乐相永与无量乐故。起者转复现前故。六者不疲惓信增上。教化无量众生久处世间能利益故。如经心无疲懈故。七者惭愧信增上不着世间故。于悭等波罗蜜障法深惭愧故。如经以惭愧庄严故。八者安乐信增上于同法者不恼乱故。如经成就忍辱安乐故。九者敬法信增上增益敬信殊胜心故。如经敬顺诸佛教法信重尊贵故。后三句示修何等行波罗蜜行故。谁为等侣同事安乐故。入何法中谓诸佛教法故。如是信心成就。云何修行成就

经曰。日夜修集善根无厌足故。亲近善知识故。常爱乐法故。求多闻无厌故。如所闻法正观故。心不贪着故。不着利养名闻恭敬故。不求一切资生之物故。常生如宝心无厌足故

论曰。此十句说修行成就。云何修行成就。集诸善根无休息故。如经日夜修集善根无厌足故。此集有八种。一者亲近集不忘诸法。如经亲近善知识故。二者乐法集。于问答中论义解释心喜心乐故。如经常爱乐法故。三者多闻集。如经求多闻无厌故。四者正观集。如经如所闻法正观故。五者不着集。如经心不贪着故。向说多闻集等三句。是闻思修慧如是次第。不著者于三昧中无爱着故。六者不贪集。七者不求集。于已得利养不贪。未得利养不求。障菩萨戒退菩萨戒。如经不着利养名闻恭敬故。不求一切资生之物故。八者如宝心集。出世间心念念现前。如经常生如宝心无厌足故。如是修行成就。云何回向成就

经曰。求一切智地故。求诸佛力无畏不共法故。求诸波罗蜜无著法故。离诸谄曲故。如说能行故。常护实语故。不污诸佛家故。不舍菩萨戒故。不动如大山王生萨婆若心故。不舍一切世间事成就出世间道故。集助菩提分法无厌足故。常求上上胜道故。诸佛子菩萨摩诃萨成就如是净治地法。名为安住菩萨欢喜地

论曰。求一切智地等说何等事示现回向成就故。求一切智地是总。求如来力等于一切智地是别。一者观求一切智地。二者无障求一切智地。三者离求一切智地故。四者如说能行求一切智地。五者护求一切智地。六者不污求一切智地。七者不舍求一切智地。八者不动求一切智地。九者不舍成就求一切智地。十者集求一切智地。十一者常求求一切智地。于中求何等事。求一切智地故。以何观求。观诸佛力无畏不共法故。云何求。求诸波罗蜜无著法故。此三求者是家依家无障求故云何求求诸波罗蜜无著法故此无障求差别异求于中檀波罗蜜有二种垢。一者谄曲见乞求者。诈设方便无心许与。二者不随先言许而不与。对治是垢。如经离诸谄曲故。如说能行故。尸波罗蜜有一种垢。不护实语违本所受犯已覆藏。对治是垢。如经常护实语故。羼提波罗蜜有一种垢污如来家。云何菩萨污如来家。恼乱他业故。利益他业即是如来家。是故菩萨生此家者。恼乱他业非善事故。对治是垢。如经不污诸佛家故。毗梨耶波罗蜜有一种垢。菩萨戒无量劫数长远难持难行生退转心。对治是垢。如经不舍菩萨戒故。禅波罗蜜有二种垢。一者乱心。二不能调伏忆想分别。对治是垢。如经不动如大山王生萨婆若心故。般若波罗蜜有三种垢。一无善巧方便。世间涅槃一向不现现故。二不修集出出世间道故。三于胜上证法中愿欲心薄故。如是次第对治是垢。如经不舍一切世间事成就出世间道故。集助菩提分法无厌足故。常求上上胜道故。如是回向成就。是名勤行具足成就。是勤行有四种。一信二欲三精进四方便。初十句示现信增上成就。是信增上即摄受欲。第二十句。日夜修集善根无厌示现精进。第三十句。求一切智地示现方便故。是名此地说中安住。何以故。如经诸佛子菩萨摩诃萨成就如是净治地法。名为安住菩萨欢喜地故。如是说分讫

十地经论欢喜地卷之二十地经论初欢喜地卷之三

        天亲菩萨造

        后魏北印度三藏菩提流支译

论曰。已显说分。次说挍量胜分。云何挍量胜。菩萨住此地中。胜声闻辟支佛故。挍量胜有三种。一愿胜。二修行胜。三果利益胜。何者愿胜。所谓十大愿

经曰。菩萨如是安住菩萨欢喜地。发诸大愿起如是大方便。如是大行成就。所谓无余一切诸佛一切供养一切恭敬故。一切种具足上深信清净。广大如法界究竟如虚空。尽未来际尽一切劫数一切佛成道数。大供养恭敬无有休息

论曰。是初大愿无余者有三种。一者一切佛无余。二者一切供养无余。三者一切恭敬无余。一切佛者有三种佛。一应身佛。二报身佛。三法身佛。一切供养者有三种供养。一者利养供养。谓衣服卧具等。二者恭敬供养。谓香花幡盖等。三者行供养。谓修行信戒行等。一切恭敬者有三种恭敬。一给侍恭敬。二迎送恭敬。三修行恭敬。是故作愿供养恭敬。如经所谓无余一切诸佛一切供养一切恭敬故。一切种具足者。无量种种复有胜事等供养故。上深信清净者。增上敬重故。愿回向菩提决定信故。广大如法界者。一切余善根中胜故。究竟如虚空者。无常爱果无量因故。尽未来际者。此因得涅槃常果故。一切劫数一切佛成道数大供养恭敬无有休息故。此初愿中有六种大名为大愿。一者福田大。如经所谓无余一切诸佛一切供养一切恭敬故。二者供事大。如经一切种具足故。三者心大。如经上深信清净故。四者摄功德大。如经广大如法界故。五者因大。如经究竟如虚空故。六者时大。如经尽未来际故

经曰。又发大愿。所谓一切诸佛所说法轮皆悉受持故。摄受一切佛菩提故。一切诸佛所教化法皆悉守护故。广大如法界究竟如虚空。尽未来际尽一切劫数一切佛成道数。摄护正法无有休息

论曰。第二大愿有三种法。一切诸佛所说法轮皆悉受持者。谓教法修多罗等。书写供养读诵受持为他演说故。摄受一切佛菩提者。所谓证法证三种佛菩提法。摄受此证法教化转授故。一切诸佛所教化法皆悉守护者。谓修行法于修行时有诸障难摄护救济故。复名三种成就。一者于诸佛所说修多罗等阿含次第令法轮不断成就故。二者证三种正觉得证成就故。三者修行乃至如实修行正觉成就故。是名三种成就。三种佛菩提者。声闻辟支佛亦名为佛故

经曰。又发大愿。所谓一切成佛无余一切世界住处从兜率天来下。入胎及在胎中。初生时出家时成佛道时请转法轮时示入大涅槃。我于尔时尽往供养摄法为首。一切处一时成一时转故。广大如法界究竟如虚空。尽未来际尽一切劫数一切佛成道数。尽往摄法无有休息

论曰。第三大愿。一切成佛无余一切世界住处者。一切应佛无边遍满一切世界住处故。随何等世界诸佛住处应感相顺众生见故。从兜率天来下乃至示入大涅槃。我于尔时尽往供养摄法为首者。随彼众生供养佛方便。以如来所说摄法方便。集功德智慧助菩提法故。一切处一时成一时转者示非前后故。何故示现彼处住。不在色无色处。此难处来不为我故。起于轻心不生恭敬。为遮此等故。何故不住他化自在天等。如来有力能胜处生舍而不生。为念众生故来生兜率。如是生大恭敬心故。何故人中舍上天乐愍我等故。来生人中生增上敬重心故。何故处胎示现同生增长力故。何故自成正觉。示非余佛教化现丈夫力。成就非因他得菩提故。何故示入大涅槃。为令懈怠众生勤心修道故

经曰。又发大愿。所谓一切菩萨所行广大无量不杂诸波罗蜜所摄。诸地所净生诸助道法。总相别相同相异相成相坏相。说一切菩萨所行如实地道。及诸波罗蜜方便业。教化一切令其受行心得增长故。广大如法界究竟如虚空。尽未来际尽一切劫数行数增长无有休息

论曰。第四大愿心得增长者。以何等行令心增长。一切菩萨所行教化一切令其受行心得增长故。彼菩萨行有四种一种种二体三业四方便。以此四种教化令其受行。何者是菩萨行种种世间行有三种。广者从初地乃至六地。大者七地。无量者从八地乃至十地。不杂者法无我平等观出世间智故。如经一切菩萨所行广大无量不杂故。体者如经诸波罗蜜所摄故。业者如经诸地所净生诸助道法故。方便者如经总相别相同相异相成相坏相故。说一切菩萨所行如实地道及诸波罗蜜方便业故

经曰。又发大愿。所谓无余一切众生界。有色无色有想无想非无想非想非非想。卵生胎生湿生化生。三界所系杂入六道一切生处名色所摄。为教化成就一切众生界令信入诸佛法故。断一切世间数道故。令住一切智智处故。广大如法界究竟如虚空。尽未来际尽一切劫数一切众生界数。教化一切众生无有休息

论曰。第五大愿教化众生故。何者是众生为何义故。化一切众生有六种差别。一粗细差别。二生依止差别。三不净净处差别。四苦乐差别。五自业差别。六自体差别。何者粗细差别。粗者有色细者无色。色中粗者有想细者无想。无色中粗者非无想细者非想非非想。是名粗细差别。如经有色无色有想无想非无想非想非非想故。生依止差别者。如经卵生胎生湿生化生故。化生者云何依止依止业生故。不净净处差别者。如经三界所系故。苦乐差别者。种种身故。如经杂入六道故。自业差别者如经一切生处故。自体差别者。如经名色所摄故。是名众生。为何义化者为三义故。一者为信入诸佛所说法中。如经为教化成就一切众生界令信入诸佛法故。二者已入佛法中令入二乘菩提故。如经断一切世间数道故。三者已入二乘菩提令入无上菩提故。如经令住一切智智处故

经曰。又发大愿。所谓无余一切世界广大无量。粗细乱住倒住正住如帝网差别。十方世界无量差别入皆现前知故。广大如法界究竟如虚空。尽未来际尽一切劫数一切世界数。信入无有休息

论曰。第六大愿。无余一切世界者有三种相。随入如是世界智皆现前知。一者一切相二者真实义相。三者无量相。一切相者。如经广大无量乃至正住故。广大无量者一千世界二千世界三千世界故。细者随何等世界意识身故。粗者随何等世界意色身故。乱住者非次第住故。倒住者不造舍宅住故。正住者造舍宅住故。是名一切相。如帝网差别者。真实义相故。如业幻作故。无量相者。十方世界无量差别入故。无量相故。真实义相者。唯智能知。余相者可现见故

经曰。又发大愿。所谓一切佛土一佛土。一佛土一切佛土。一切国土平等清净。一切佛土神通庄严光相具足。离一切烦恼成就清净道。有无量智慧众生悉满其中。入佛上妙平等境界故。随诸众生心之所乐而为示现故。广大如法界究竟如虚空。尽未来际尽一切劫数佛国土数。清净一切佛土无有休息

论曰。第七大愿净佛国土相有七种。一者同体净。如经一切佛土一佛土。一佛土一切佛土故。二者自在净。如经一切国土平等清净故。三者庄严净。如经一切佛土神通庄严光相具足故。光明庄严众宝等庄严故。四者受用净。如经离一切烦恼成就清净道故。五者住处众生净。如经有无量智慧众生悉满其中故。六者因净。如经入佛上妙平等境界故。七者果净。如经随诸众生心之所乐而为示现故。显智神力等故

经曰。又发大愿。所谓一切菩萨同心同行故。共集善根无怨嫉故。一切菩萨平等一观故。常亲近诸佛菩萨不舍离故。随意能现佛身故。自于心中悉能解知诸佛神力智力故。得不退随意神通故。悉能游行一切世界故。一切佛会皆现身相故。一切生处普生其中故。成就不可思议大乘故。具足行菩萨行故。广大如法界究竟如虚空。尽未来际尽一切劫数一切行数。入大乘道无有休息

论曰。第八大愿不念余乘故。如经一切菩萨同心同行故。菩萨行有十种。一者共集善根无怨嫉故。二者一切菩萨平等一观故。三者常亲近诸佛菩萨不舍离故。四者随意能现佛身故。五者自于心中悉能解知诸佛神力智力故。六者得不退随意神通故。七者悉能游行一切世界故。八者一切佛会皆现身相故。九者一切生处普生其中故。十者成就不可思议大乘故。具足行菩萨行故。于中初句显功德行故。第二住寂静等观故。第三聚集解说论佛法故。第四随心示现成佛故。第五自发胜心念如来法身故。第六得常不退神通故。余四者以通业得名。一往余世界。二自余异身示现。三同生往故。四入不可思议大乘故

经曰。又发大愿。所谓乘不退轮行菩萨行故。身口意业所作不空。众生见者即必定佛法故。闻我音声即得真实智慧故。心喜恭敬即断烦恼故。得如药树王身故。得如如意宝身故。行大菩萨行故。广大如法界究竟如虚空。尽未来际尽一切劫数一切行数。所作利益不空无有休息

论曰。第九大愿显不空行菩萨行。复行菩萨行。显乘不退轮行菩萨行故。于中不空有二种。一作业必定不空。身口意业所作不空故。如是次第三句说应知。众生见者即必定佛法故者。明身业不空。闻我音声即得真实智慧者。明口业不空。心喜恭敬即断烦恼者。明意业不空。二作利益不空。一切众生有二种苦。一种种诸苦。二贫穷苦。对治是二。如经得如药树王身故。得如如意宝身故

经曰。又发大愿。所谓于一切世界处成阿耨多罗三藐三菩提故。于一凡夫道不离一切凡夫道处。示身初生坐道场成佛道转法轮度众生。示大涅槃。现诸佛境界大神通智力。随一切众生界所应度者于念念中示得佛道度诸众生灭苦恼故。以一三菩提遍知一切法如涅槃性故。以一音说令一切众生心皆欢喜故。示大涅槃而不断菩萨所行故。示大智慧地发起一切法故。法智通如意神通幻通遍一切世界故。广大如法界究竟如虚空。尽未来际尽一切劫数成三菩提数。求大智慧大神通等。无有休息。诸佛子菩萨如是安住菩萨欢喜地。发诸大愿起如是大方便。如是大行以十愿门为首生如是等。满足十百千万阿僧祇大愿。是菩萨住菩萨欢喜地。起如是等愿

论曰。第十大愿起大乘行。云何大菩提。云何作业。大菩提者。如经成阿耨多罗三藐三菩提故。作业者有七种。一示正觉业。二说实谛业。三证教化业。四种种说法业。五不断佛种业。六法轮复住业。七自在业。初业者于一凡夫道不离一切凡夫道处乃至示大涅槃故。一凡夫道者。一阎浮提义。阎浮提凡夫道者。可化众生住处名为凡夫道。第二业者。现诸佛境界大神通智力故。随一切众生界所应度者于念念中示得佛道度诸众生灭苦恼故。随诸世界一切可化者随心示现佛身。示现佛身者。除诸难处彼彼胜处生。示除苦断集证灭修道。第三业者。以一三菩提观法无我一切法性净涅槃令众生信解故。第四业者。以一音声随种种信解可化众生一时皆令心欢喜故。第五业者。示现大涅槃而不断菩萨所行力故。第六业者复佛智地一切修多罗等。所说法轨则不失故。第七业法智通者。观一切法无性相故。如意神通者。自身现生住灭修短随心自在故。幻通者。转变外事无不随意故。初法智通不住世间故。如意神通幻通不住涅槃故。何故唯说此十大愿。初愿功德行满足故。第二愿智慧行满足故。次五愿为教化众生故。一以何身。二以何心。三何者众生。四众生住何处。五自身住何处能教化众生。后三愿显自身。一得地挍量胜故。二得菩萨地尽挍量胜故。三得一切地尽究竟故。此三示现如实教化众生故。发诸大愿者。随心求义故。起如是大方便者。成彼所作方便勇猛故。如是大行者。彼所作行成就故。菩萨住此地渐次久习起此三行非一时故。何以故。此十大愿一一愿中有百千万阿僧祇大愿以为眷属故。如经诸佛子菩萨如是安住菩萨欢喜地发诸大愿。起如是大方便如是大行。以十愿门为首。生如是等满足十百千万阿僧祇大愿是菩萨住菩萨欢喜地起如是等愿故。何故名大愿。光明善根转胜增广故。此挍量菩萨愿胜有二种。胜声闻辟支佛。一常勤修习无量行故。二与一切众生同行故。同行者十尽句示现

经曰。以十尽句成诸大愿。何等为十。所谓一众生界尽。二世界尽。三虚空界尽。四法界尽。五涅槃界尽。六佛出世界尽。七如来智界尽。八心所缘界尽。九佛境界智入界尽。十世间转法转智转界尽。如众生界尽我愿乃尽。如世界尽。如虚空界尽。如法界尽。如涅槃界尽。如佛出世界尽。如佛智界尽。如心所缘界尽。如佛境界智入界尽。如世间转法转智转界尽。若彼界尽我愿乃尽。如是众生界尽不尽。我此善根亦不可尽。世界尽不尽。虚空界尽不尽。法界尽不尽。涅槃界尽不尽。佛出世界尽不尽。如来智界尽不尽。心所缘界尽不尽。佛境界智入界尽不尽。世间转法转智转界尽不尽。我此诸愿善根亦不可尽

论曰。于中众生界尽是总。世界尽乃至智转界尽是别。何等是众生界众生界尽故。何处住世界尽故。所有虚空界虚空界尽故。说何法教化法界尽故。随化众生置何处涅槃界尽故。佛出世界尽故。以何方便善巧如来智界尽故。复随所缘心缘界尽故。复随以何界佛境界智入界尽故。此事已说。尽者示现不断尽。非念念尽故。此九种尽略说三种。三转示现此十尽句增上力故。诸佛以此力常为众生作利益故。如是已说愿挍量胜。云何行挍量胜

经曰。诸佛子。菩萨决定发如是诸大愿已。则得调顺心柔软心。如是则成信者。信诸佛如来本所行入。集诸波罗蜜而得增长。善成就诸地具足无畏力不共佛法不坏故。不可思议佛法无中无边。如来境界起无量行门诸如来境界入。信成就果。举要言之。信一切菩萨行。乃至得如来智地说加故

论曰。发如是诸大愿已。则得调顺心者。彼诸善根中得自在胜故。柔软心者得胜乐行故。如是则成信者。于中本行入者。从菩萨行入乃至成菩提觉故。于中信菩萨行所摄本行入有二种相。一云何菩萨行。二云何次第成。如经集诸波罗蜜而得增长故。善成就诸地故。此菩提所摄本行入有六种胜。是故信胜。一者外道魔怨声闻缘觉对治等胜。如经具足无畏力不共佛法不坏故。二者不思议神通力上胜。如经不可思议佛法故。三者不杂染胜。如经无中无边如来境界起故。四者一切种智胜。如经无量行门诸如来境界入故。五者离胜。一切烦恼习常远离故。如经信成就果故。复略说彼菩萨本行入示现。如经举要言之信一切菩萨行乃至得如来智地说加故。说者所说。加者得证故。此菩萨三种观于诸众生起大慈悲。一远离最上第一义乐。二具足诸苦。三于彼二颠倒。云何远离最上第一义乐

经曰。诸佛子。彼菩萨作是念。诸佛正法如是甚深。如是寂静。如是寂灭。如是空。如是无相。如是无愿。如是无染。如是无量。如是上。此诸佛法如是难得

论曰。诸佛正法如是甚深者有九种。一寂静甚深。二寂灭甚深。三空甚深。四无相甚深。五无愿甚深。六无染甚深。七无量甚深。八上甚深。九难得甚深。寂静者离妄计实有故。妄计正取故。寂灭者法义定故。空无相无愿者。三障对治解脱门观故。何者三障。一分别二相三取。舍愿故。无染者离杂染法观故。无量者不可算数不可思量生善根观故。上者依自利利他增上智观故。难得者三阿僧祇劫证智观故。云何具足诸苦

经曰。而诸凡夫心堕邪见。为无明痴闇蔽其意识常立憍慢幢堕在念欲渴爱网中。随顺谄曲林常怀嫉妒而作后身生处因缘。多集贪欲嗔痴。起诸业行嫌恨猛风吹罪心火常令炽燃。有所作业皆与颠倒相应。随顺欲漏有漏无明漏。相续起心意识种子

论曰。而诸凡夫心堕邪见者。邪见有九种。一者蔽意邪见。如经为无明痴闇蔽其意识故。二者憍慢邪见。如经常立憍慢幢故。三者爱念邪见。如经堕在念欲渴爱网中故。四者谄曲心邪见。如经随顺谄曲林故。五者嫉妒行邪见。如经常怀嫉妒而作后身生处因缘故。六者集业邪见。如经多集贪欲嗔痴起诸业行故。七者吹心炽燃邪见。如经嫌恨猛风吹罪心火常令炽燃故。八者起业邪见。如经有所作业皆与颠倒相应故。九者心意识种子邪见。如经随顺欲漏有漏无明漏相续起心意识种子故。是中蔽意邪见憍慢邪见爱念邪见。此三邪见依法义妄计如是次第。谄曲心邪见嫉妒行邪见。此二邪见于追求时心行过故。嫉者于身起邪行故。妒者于资财等。是故生生之处堕卑贱中。形貌鄙陋资生不足故。第六集业邪见。受诸受时憎爱彼二颠倒境界故。第七吹心炽燃邪见。于怨恨时互相追念欲起报恶业故。第八起业邪见。于作恶时迭相加害故。第九心意识种子邪见。于作善业时所有布施持戒修行善根等业皆是有漏故

经曰。于三界地复有芽生。所谓名色共生。不离此名色增长已成六入聚。成六入已。内外相对生触。触因缘故生受。深乐受故生渴爱。渴爱增长故生取。取增长故复起后有。有因缘故有生老死忧悲苦恼。如是众生生长苦聚。是中皆空离我我所。无知无觉如草木石壁又亦如响。然诸众生不知不觉而受苦恼

论曰。是中因缘有三种。一自相从复有芽生。乃至于有。二同相谓生老病死等过。三颠倒相离我我所等。自相者有三种。一者报相。名色共阿黎耶识生。如经于三界地复有芽生。所谓名色共生故。名色共生者。名色共彼生故。二者彼因相。是名色不离彼依彼共生故。如经不离故。三者彼果次第相。从六入乃至于有。如经此名色增长已成六入聚。成六入已内外相对生触。触因缘故生受。深乐受故生渴爱。渴爱增长故生取。取增长故复起后有。有因缘故有生老死忧悲苦恼。如是众生生长苦聚故。是中离我我所者。此二示现空。无知无觉者。自体无我故。彼无知无觉示非众生数动不动事。如经如草木石壁又亦如响故。因缘相似相类法故。云何于彼二颠倒。如经然诸众生不知不觉而受苦恼故

经曰。菩萨如是见诸众生不离苦聚。是故即生大悲智慧。是诸众生我应教化令住涅槃毕竟之乐。是故即生大慈智慧

论曰。云何具诸苦聚。云何远离最上第一义乐。此先已说。示现大悲慈等故

经曰。诸佛子菩萨摩诃萨。随顺如是大慈悲法住在初地。以深妙心于一切物无所吝惜。以智求佛大妙智故。修行大舍。即时所有可施之物皆悉能舍。所谓一切财谷库藏等舍。或以金银摩尼真珠琉璃珂贝车磲马瑙生金等舍。或以宝庄严具璎珞等舍。或以象马车乘辇舆等舍。或以寺舍园林楼观流泉浴地等舍。或以奴婢僮仆等舍。或以国土聚落城邑王都等舍。或以妻子男女等舍。或以一切所爱之事皆悉能舍。或以头目耳鼻支节手足一切身分等舍。如是一切可舍之物而不贪惜。唯求无上佛智慧故。而行大舍。如是菩萨摩诃萨住于初地能成大舍

论曰。即时所有可施之物皆悉能舍者。求佛无上大妙智故。是中一切物者。略有二种。一外二内。外者复有二种。一所用二贮积。如经所谓一切财谷库藏等故。如是次第于中广有八种。从金银等乃至一切所爱之事。内者自身所摄。是外事舍中。初舍是总。余九舍是别。依二种喜。一藏摄喜二利益喜。藏摄喜者。谓金银等。利益喜者复有八种。一者严饰利益喜。谓宝庄严等。二者代步利益喜谓象马等。三者戏乐利益喜。谓园林楼观等。四者代苦利益喜。谓奴婢等。五者自在利益喜。谓国土聚落等。六者眷属利益喜。谓妻子等。七者坚着利益喜。谓一切所爱等。八者称意利益喜。谓头目耳鼻等

经曰。菩萨如是以大施心救一切众生故。转转推求世间出世间利益胜事。彼推求利益胜事时心不疲惓。是故菩萨成不疲惓心。成不疲惓已。于一切经论心无怯弱。是名成一切经论智。如是成一切经论智已。善能筹量应作不应作。于上中下众生随宜随宜而行。随力随感。是故菩萨成就世智。成世智已知时知量惭愧庄严修习自利利他之道。是故菩萨成惭愧庄严。如是行中精勤修行得不退不转力。如是菩萨成坚固力。得坚固力已勤行供养诸佛。随所闻法如说修行。诸佛子是菩萨悉知生起如是清净诸地法。所谓信悲慈舍不疲惓。知诸经论善解世法。惭愧坚固力供养诸佛如说修行

论曰。是中依此世智随宜随宜而行者。如论中说随自己力随彼能受故。依惭愧知时知量者。示三种时。一者念时。二者日夜时。三者所作必得不断时。依坚固力如是彼行中者如上所说。信等故。精勤修行者有二种。一不退力不舍行故。二不转力精进不息故。供养诸佛如说修行者有二种。一利养供养。二修行供养。此十种行显二种胜成就。一深心成就谓信悲慈等。二修行成就谓舍不疲惓。知诸经论善解世法惭愧坚固力供养诸佛如说修行等。于中依自利行。谓信能信菩萨行及诸佛法。求必能得故。依利他行。所谓悲慈能安隐与乐心故。舍者以财摄他行故。不疲惓者。自摄法行故。知诸经论善解世法者。以法摄他行故。余有三行摄护信等。一者不着行。以惭愧对治障。信等不着行故。二者不动行。有坚固力信等不可动故。三者修行。彼垢清净依止行供养诸佛。摄信等善根故。是中依二种供养故。得二种身。一者上妙身。所可见者心生敬重利益不空故。二者调柔心。自性善根成就乐行法故。前所说三十句。从信增上等乃至常求上上胜道。是清净地法。今此十句从信等乃至供养诸佛。尽是障地净法。是名修行挍量胜。云何果利益挍量胜

经曰。诸佛子是菩萨住此菩萨欢喜地已。多见诸佛以大神通力大愿力故。见多百佛多千佛多百千佛多百千那由他佛多亿佛多百亿佛多千亿佛多百千亿佛多百千亿那由他佛。以大神通力大愿力故。是菩萨见诸佛时。以上心深心供养恭敬尊重赞叹。衣服饮食卧具汤药一切供具悉以奉施。以诸菩萨上妙乐具供养众僧。以此善根皆愿回向阿耨多罗三藐三菩提。是菩萨因供养诸佛故。成教化利益众生法。是菩萨多以二摄摄取众生。所谓布施爱语。后二摄法但以信解力行未善通达。是菩萨十波罗蜜中檀波罗蜜增上。余波罗蜜非不修集。随力随分是菩萨随所供养诸佛。教化众生皆能受行清净地法。如是如是彼诸善根皆愿回向萨婆若。转复明净调柔成就随意所用。诸佛子譬如金师善巧炼金数数入火。如是如是转复明净调柔成就随意所用。诸佛子菩萨亦复如是。如是如是供养诸佛教化众生。皆能修行清净地法。正修行已。如是如是彼诸善根皆愿回向萨婆若。转复明净调柔成就随意所用

论曰。果利益挍量胜有四种。一调柔果利益胜。二发趣果利益胜。三摄报果利益胜。四愿智果利益胜。调柔果利益胜者。金相似法。信等善法犹如真金数数入火者。有三种入。一功德入。供养佛僧故。二悲心入。教化众生故。三无上果入。愿回向大菩提故。以大神通力见诸佛者。以胜神通力见色身佛。大愿力者以内正愿力见法身佛。多百佛乃至百千亿那由他佛者。方便善巧示现多佛。显多数故。供养者有三种。一恭敬供养。谓赞叹等显佛功德故。二尊重供养。谓礼拜等。三奉施供养。谓花香涂香末香幡盖等。以诸菩萨上妙乐具者。是诸菩萨所有世间不供之物。具足奉施一切众僧故。云何发趣果利益胜

经曰。复次诸佛子菩萨摩诃萨。住此菩萨欢喜地。于初地中诸相得果。应从诸佛菩萨善知识所推求请问成地诸法无有厌足。如是菩萨住初地中。应从诸佛菩萨善知识所推求请问。第二地中诸相得果成地诸法无有厌足。如是第三第四第五第六第七第八第九第十地中诸相得果。应从诸佛菩萨善知识所推求请问。成十地法无有厌足。是菩萨善知诸地障对治。善知地成坏。善知地相。善知地得修。善知地清净分。善知地地转行。善知地地住处。善知地地挍量胜智。善知地得不退转。善知一切菩萨地清净转入如来智地。诸佛子菩萨如是善起地相。发于初地不住意成乃至转入十地。无障碍故。以得十地智慧光明故。能得诸佛智慧光明。诸佛子譬如善巧导师。多将人众向彼大城。未发之时应先问道中利益诸事。复问道中退患过咎。复问道处中间胜事。复问道处中间退患过咎。具道资粮作所应作推求请问。未发初处。是大导师乃至善知到彼大城。未发初处。此导师能以智慧思惟筹量。具诸资用令无所乏。正导众人乃至得到大城。于崄道中免诸患难。身及众人皆无忧恼。诸佛子菩萨摩诃萨善巧导师亦复如是。住于初地善知地障对治。乃至善知一切菩萨地清净转入如来智地。尔时菩萨具大福德助道资粮善择智慧助道。欲将一切众生向萨婆若大城。未发初处应先问地道功德。复问诸地退患。复问地道处中间胜事。复问地道处中间退患。具大功德智慧资粮作所应作。应从诸佛菩萨善知识所推求请问。未发初处。是菩萨善知地障对治。乃至善知能到萨婆若大城。未发初处。菩萨如是智慧分别。具大功德智慧资粮。将一切众生如应教化。出过世间崄难恶处。乃至令住萨婆若大城。不为世间生死崄过所染。身及众生无诸衰恼。诸佛子是故菩萨摩诃萨常应心不疲惓勤修诸地业胜智本行。诸佛子是名略说菩萨摩诃萨入初菩萨欢喜地门。广说则有无量百千万亿阿僧祇事

论曰。诸相者随诸地中所有诸障及对治相故。得者证出世间智故。果者因证智力得世间出世间智故。成地诸法者。所谓信等为满足彼故。有五种方便。一观方便二得方便三增上方便四不退方便五尽至方便。观方便者。障对治成坏善巧。如经是菩萨善知诸地障对治故。善知地成坏故。十种地障对治故。名为十地。如本分中说。如是次第集故成散故坏。得方便者。欲入方便已入方便彼胜进方便。如经善知地相故。善知地得修故。善知地清净分故。增上方便者。地地转行地地住处地地增长善巧。如经善知地地转行故。善知地地住处故。善知地地挍量胜智故。不退方便者。如经善知地得不退转故。尽至方便者。菩萨地尽入如来地善巧。如经善知一切菩萨地清净转入如来智地故。诸佛子譬如善巧导师多将人众向彼大城者。令得正行故。于中导师者有二种方便。一者不迷道方便。于道路中是利是退患。于道路处是胜是过咎。皆善巧知。如经先问道中利益诸事故。复问道中退患过咎故。复问道处中间胜事故。复问道处中间退患过咎故。二者资具利益方便。如经具道资粮作所应作故。云何摄报果利益胜

经曰。菩萨摩诃萨住此初地。多作阎浮提王豪贵自在常护正法。能以大施摄取众生。善除众生悭贪妒嫉之垢。常行大舍而无穷尽。所作善业布施爱语利益同事。是诸福德皆不离念佛。不离念法。不离念僧。不离念诸菩萨。不离念菩萨行。不离念诸波罗蜜。不离念十地。不离念不坏力。不离念无畏。不离念佛不共法。乃至不离念具足一切种一切智智。常生是心我当于一切众生中为首为胜。为大为妙为微妙为上为无上为导为将为师为尊。乃至为一切智智依止者。诸佛子。是菩萨摩诃萨。若欲舍家勤行精进。于佛法中便能舍家妻子五欲。得出家已勤行精进。于一念间得百三昧得见百佛。知百佛神力能动百佛世界。能入百佛世界能照百佛世界。能教化百佛世界众生。能住寿百劫。能知过去未来世各百劫事。能善入百法门。能变身为百。于一一身能示百菩萨以为眷属

论曰。摄报果利益胜者有二种。一在家果。二出家果。在家果复有二种。一者上胜身。阎浮提王等。如经菩萨摩诃萨住此初地多作阎浮提王豪贵自在常护正法故。二者上胜果。善巧调伏悭贪嫉妒等。如经能以大施摄取众生善除众生悭贪嫉妒垢等。能以大施摄取众生者。自行布施善劝他施。摄取众生善转众生悭嫉之垢。方便善巧以四摄法摄取众生故。不离念佛等者。示现不离念自利益事。如是诸念于事中行已。成大恭敬除诸妄想。此念略有四种。一者上念。念三宝故。二者同法念。念诸菩萨故。三者功德念。念自身他身菩萨行自体转胜故。四者求义念。念诸力等此是真实究竟故。何者是上念。念佛等。念佛法等故。于施者受者财物及菩提不生分别不取着故。如是一切所作业中作者不着。境界不着。作事不着。果报不着。以此一切诸行皆愿回向大菩提故。为首者有二种。一者胜首。光明功德故。二者大首。独无二故。胜者有二种。一者妙智。自在胜故。二者微妙。离一切烦恼自在胜故。大者有二种。一者上。无与等故。二者无上。无能过故。如是显示自体功德故。导者于阿含中分别法义正说故。将者令他证得义灭诸烦恼故。师者教授令入正道故。乃至一切智智依止者。以大菩提道教化故。是名在家菩萨摄报果利益胜。复次出家菩萨禅定胜业。胜业有二种。一者三昧胜。所谓于一念间得百三昧。得三昧自在力故。二者三昧所作胜。谓见百佛等以得是三昧力故。于十方诸佛及佛所加诸菩萨所修习智慧故。能动百佛世界者。令可化众生生正信故。能入百佛世界能照百佛世界。能教化百佛世界众生者。往至及见正化众生故。能住寿百劫者。摄取胜生故。能知过去未来世各百劫事者。化诸众生作离恶上首说善恶业道故。能善入百法门者。为增长自智慧思惟种种法门义故。能变身为百。于一一身能示百菩萨以为眷属者。作多利益速疾行故。云何愿智果利益胜

经曰。若以愿力自在胜上。菩萨愿力示现过于此数。示种种神通。或身或光明或神通或眼或境界或音声或行或庄严或加或信或业。是诸神通乃至无量百千万亿那由他劫不可数知

论曰。于中身者。是一切菩萨行根本所依故。依彼身故有光明及神通。依光明有天眼。以有天眼见前境界。一切眼有五种应知。依神通有音声及行庄严加等。音声者应彼言说故。行者遍至十方故。庄严者作种种应现故。加者神力加彼故。信者依三昧门现神通力。随众生信利益成就故。业者依慧眼所摄陀罗尼门现说法故。略说一切诸地各有因体果相应知

十地经论初欢喜地卷之三十地经论离垢地第二卷之四

        天亲菩萨造

        后魏北印度三藏菩提流支译

论曰。菩萨如是已证正位依出世间道因清净戒说第二菩萨离垢地。此清净戒有二种净。一发起净。二自体净。发起净者说十种直心

经曰。尔时金刚藏菩萨摩诃萨言。诸佛子。若菩萨已具足初地。欲得第二地者。当生十种直心。何等为十。一直心。二柔软心。三调柔心。四善心。五寂灭心。六真心。七不杂心。八不悕望心。九胜心。十大心。菩萨生是十心得入第二菩萨离垢地

论曰。十种直心者。依清净戒直心性戒成就。随所应作自然行故。直心复有九种。一者柔软直心。共喜乐意持戒行故。二者调柔直心。自在力故。性善持戒烦恼不杂故。三者善直心。守护诸根不误犯戒。犹如良马性调伏故。四者寂灭直心。调伏柔软不生高心故。五者真直心。能忍诸恼如真金故。六者不杂直心。所得功德不生厌足。依清净戒更求胜戒乐寂静故。七者不悕望直心。不愿诸有势力自在故。八者胜直心。为利益众生不断有愿故。九者大直心。随顺有果而不染故。自体净者有三种戒。一离戒净。二摄善法戒净。三利益众生戒净。离戒净者谓十善业道。从离杀生乃至正见亦名受戒净。摄善法戒净者。于离戒净为上。从菩萨作是思惟。众生堕诸恶道。皆由十不善业道集因缘。乃至是故我应等行十善业道。一切种清净故。利益众生戒净者。于摄善法戒为上。从菩萨复作是念。我远离十不善业道。乐行法行乃至生尊心等

经曰。诸佛子。菩萨住菩萨离垢地。自性成就十善业道。远离一切杀生。舍弃刀杖无嗔恨心。有惭有愧具足怜愍于一切众生生安隐心慈心。是菩萨尚不恶心恼诸众生。何况于他众生起众生想故起重心身行加害

论曰。说十善业道远离一切杀生者。示现远离胜利益胜故。依离杀生有三种离。一者因离。如经舍弃刀杖无嗔恨心有惭有愧具足怜愍故。二者对治离。如经于一切众生生安隐心慈心故。三者果行离。如经尚不恶心恼诸众生。何况于他众生起众生想故。起重心身行加害故。于中杀生有二种因。一受畜因。二起因。受畜因有二种。所谓刀杖。刀者斫截事。杖者捶打事。如经舍弃刀杖故。乃至咒术诸药能杀之具悉皆远离。起因有二种。所谓贪嗔。为财利故造诸恶业。乃至没命心无耻悔。对治是等。如经有惭有愧故。为贪众生捕养笼系令生苦恼。对治是等。如经具足怜愍故。离此二种故言因离。对治离有二种。一者安隐心于一切众生而作利益。以善法教化令住善道涅槃因故。二者慈心令彼众生得人天报涅槃乐果故。如经于一切众生生安隐心慈心故。如是于因果中不颠倒求。离愚痴心杀生祭祀等。对治者即名为离。故名对治离。彼能离故。言众生者。示诸众生非常非断随命根因缘。乃至现得寿命住世。死则依业烦恼力未来还生故。果行离有二种。一者微细心念害故。二者粗重身行恼害故。如经是菩萨尚不恶心恼诸众生。何况于他众生起众生想故起重心身行加害故。于中粗行有五种。一者身。如经他故。二者事。如经众生故。三者想。如经众生想故。四者行。如经故起重心故。五者体。如经身行加害故

经曰。离诸劫盗资生之物常自满足。不坏他财。若物属他他所用事他守护想不生盗心。是菩萨乃至草叶不与不取。何况其余资生之具

论曰。依离劫盗有三种离。一因离。二对治离。三果行离。因离者。自资生不足此对治。如经资生之物常自满足故。对治离者。所谓布施。于自资生舍而不着。以无贪故。不坏当来资生。如经不坏他财故。果行离者有二种。一者微细物不与不取。二者粗重物不与不取。此五种示现。一者身。如经若物属他故。二者事。如经他所用事故。三者想。如经他守护想故。四者行。盗心取故。如经不生盗心故。五者体。所谓微粗。如经乃至草叶不与不取。何况其余资生之具故

经曰。离于邪淫自足妻色不求他妻。他守护女人及以他妻姓亲标护戒法所护。是菩萨乃至不生贪求念想之心。何况彼此二形从事。况复非处

论曰。依离邪淫有三种离。一因离。二对治离。三果行离。因离者自妻不足。此对治。如经自足妻色故。对治离者。现在梵行净故。不求未来妻色。如经不求他妻故。果行离者有二种。一者微细。所谓心中。二者粗重。谓身相。中身相有三种。一不正。二非时。三非处。不正者。他守护女共不共等。共者他守护故。不共者他妻故。如经他守护女人及以他妻故。姓亲标护者。所谓父母亲族姓护。及已许他标识所护故。如经姓亲标护故。女人者。示现远离非众生数女名故。非时者。谓修梵行时。如经戒法所护故。非处者。谓非道行淫。如经况复非处故。细粗者。谓意业身业二种远离故。如经乃至不生贪求念想之心。何况彼此二形从事故

经曰。离于妄语常作实语谛语时语。是菩萨乃至梦中不起覆见忍见无心欲作诳他语。何况故妄语

论曰。依离妄语有二种离。一对治离。二果行离。对治离者即是因离。何以故。彼身业有二种离。妄语中无外事故。复无异因故。如离杀生中受畜因有二种。谓刀杖外事如彼中说。离弃舍刀杖故。离妄语中无彼身业二种外事故。无异因者。杀生因贪嗔痴等。妄语因者。谓诳他心远离彼故。即实语成如是实语对治诳他心即是因离。依彼生此故言无异因。如是对治离即是因离。复对治离有三种。一者随想语。如经常作实语故。二者善思量。如事语。如经谛语故。三者知时语。不起自身他身衰恼故。如经时语故。果行离者。一细。二粗。如经是菩萨乃至梦中不起覆见忍见无心欲作诳他语何况故作妄语。梦中者是细故。作者是粗。覆见忍见易解。智见名为见

经曰。离于两舌。无破坏心不恐怖心不恼乱心。此闻不向彼说此坏故。彼闻不向此说彼坏故。不破同意者。已破者不令增长。不喜离别心。不乐离别心。不乐说离别语。不作离别语。若实若不实

论曰。依离两舌有二种离。一对治离。二果行离。对治离者。谓不破坏行。一者心。二者差别。随其所闻往异处说。此二种用心受忆持口业言说破坏心故。如经此闻不向彼说此坏故。彼闻不向此说彼坏故。差别者有三种。一身坏。二心坏。三业坏。身坏有二种。一未坏。二已坏。此对治。如经不破同意者。已破者不令增长故。心坏亦有二种。一未破者欲破。二已破者随喜。此对治。如经不喜离别心故。不乐离别心故。业坏亦有二种。一细。二粗。实不实语。此对治。如经不乐说离别语不作离别语若实若不实故

经曰。离于恶口。所有语言侵恼语粗犷语苦他语。令他嗔恨语现前语不现前语鄙恶语不断语。不喜闻语闻不悦语嗔恼语心火能烧语心热恼语不爱语不乐语不善自坏身亦坏他人语。如是等语皆悉舍离。所有语言美妙悦耳。所谓润益语软语妙语喜闻语乐闻语入心语顺理语多人爱念语多人喜乐语和悦语心遍喜语能生自心他心欢喜敬信语。常说如是种种美妙语

论曰。依离恶口有二种离。一果行离二对治离。果行离者。谓损他语能令他嗔。如经侵恼语粗犷语若他语令他嗔恨语故。此句次第以后释前。此等义一名异。复有相对语不相对语粗恶语常行语故。如经现前语不现前语鄙恶语不断语故。于中现前语者粗而不断。不现前语者微而有断。如是说者与戒相违能生他苦令他嗔故。如经不喜闻语闻不悦语故。作不利益语因嗔妒心起。令他戒相违。如经嗔恼语故。令他嗔恼有二种无饶益事。一未起嗔者能令生嗔。闻时忆时不爱不乐胸心闭塞故。如经心火能烧语心热恼语不爱语不乐语故。二者已有同意乐事自身失坏令他失坏。如经不善自坏身亦坏他人语故。离如是等恶语故。言果行离。对治离者。谓润益语。于中有二种。一者不粗不疾语。二者可乐语。如经软语妙语故。是中不粗不疾者。戒分所摄受行不断故。喜者名为可乐故。可乐有二种。一者乐可乐。二者安隐可乐。乐者随顺人天故。安隐者随顺涅槃城。如经喜闻语乐闻语入心语顺理语故。又复怨亲中人闻时忆时能生欢喜。如经多人爱念语多人喜乐语故。此语如是能作二种利益。一者他未生嗔恨令其不生生欢喜故。复能生三昧故。二者未生亲友令生故。自身现作故。令他现作故。如经心和悦语心遍喜语能生自心他心欢喜敬信语。常说如是种种美妙语故

经曰。离于绮语。常善思语时语实语义语法语顺道语毗尼语随时筹量语善知心所乐语。是菩萨乃至戏笑尚不绮语。何况故作绮语

论曰。依离绮语有二种离。一对治离。二果行离。对治离者。善知言说时。依彼此语劝发忆念。修行时若见非善处众生令舍不善安住善法。彼时教化语故。如经常善思语故。时语故。复不颠倒语依展转教诲随顺修行时义言法言故。如经实语义语法语故。复依展转举罪灭诤学行时如法语及阿含语。如经顺道语毗尼语故。复依摄受语说法摄受修行时如威仪住语故。譬喻顺义语故。如经随时筹量语善知心所乐语故。果行离有二种。一细。二粗。远离此二故。言果行离。细粗者。如经是菩萨乃至戏笑尚不绮语。何况故作绮语故

经曰。离于贪心。于他所有一切财物。他所用财不生贪心。不求不愿不生贪心

论曰。依不贪有三种。一事。二体。三差别。事者摄受用。于中有二种。一已摄受用。二摄护想。如经于他所有一切财物故。体者有二种。一所用事。谓金银等。二资用事。谓饮食衣服等。如经他所用财故。不贪性者对治贪心故。如经不生贪心故。此差别对治三种贪。三种贪者。一欲门行。二得门行。三夺门行。对治是等。如经不求不愿不生贪心故。于中初二细第三粗

经曰。离于嗔心于一切众生常起慈心安隐心怜愍心乐心利润心摄饶益一切众生心。所有嗔恨妒害妄想垢等悉皆远离。所有一切随顺慈悲善修成就一切行故

论曰。依离嗔障对治。为五种众生说。一于怨仇所生慈愍心。如经常起慈心故。二于恶行众生所。如经生安隐心故。三于贫穷乞丐及苦众生所。如经生怜愍心乐心故。四于乐众生所烦恼染着处。如经利润心故。五于发菩提心众生所。无量利益行中勤劳疲惓故。如经摄饶益一切众生心故。此慈心等有六种障。此非分别亦非一一对。于未生怨者能生。已生者随顺增长。未生亲者令不生。已生者令不增长。于自身中善法未生者令不生。已生者令灭。于不善法未生者能生。已生者令增长。于他身中不爱事未生者令生。已生者令增长。爱事未生者令不生。已生者不令随顺。如经所有嗔恨妒害妄想垢等皆悉远离故。此修多罗文句次第说此嗔恨等无量恶行根本故。言等彼悉舍离故。余随所念一切尽以慈心利益。如经所有一切随顺慈悲善修成就一切行故

经曰。离于邪见随顺正道。舍于种种占相吉凶。离恶戒见修正直见。不奸欺不谄曲。决定诚信佛法僧宝。菩萨如是日夜常护十善业道

论曰。依正见有七种见对治。何者七种见。一者异乘见。此对治。如经随顺正道故。二者虚妄分别见。三者戒取净见。此对治。如经舍于种种占相吉凶离恶戒见故。恶戒见者。自取所见故。四者自谓正见。此对治。如经修正直见故。五者覆藏见。六者诈现不实见。此对治。如经不奸欺不谄曲故。七者非清净见。谓世间见。此对治。如经决定诚信佛法僧宝故。如是已说一切种离戒

复说离戒增上清净。不断不阙常护持故。如经菩萨如是日夜常护十善业道故。如是具足一切种离戒性成就故。复示不断不阙故。次说摄善法戒净。谓菩萨作是思惟等修多罗次第说

经曰。菩萨作是思惟。一切众生堕诸恶道。皆由不离十不善业道集因缘故。是故我当先住善法。亦令他人住于善法。何以故。若人自不行善不具善行。为他说法令住善者。无有是处

论曰。堕诸恶道者有三种义。一者乘恶行往故。二者依止自身能生苦恼故。三者常堕种种苦相处故。何故言十不善业道。谓摄到一切恶果数故。言十不善业道。摄到一切恶果数者。说十不善业道故。数者摄取十名故。恶者不善故。果者堕地狱畜生饿鬼等可毁故。到者摄取业故。集因者受行故。菩萨如是远离无因颠倒。因善解众生自行恶业。住非法处不能远离。菩萨思惟深寂静已。欲救彼众生自知堪能。复观察障及对治不善业道及果。善业道及果。及上上清净起增上心。求学修行摄善法戒清净行故

经曰。是菩萨复深思惟。行十不善业道集因缘故。则堕地狱畜生饿鬼。行十善业道集因缘故。则生人中。乃至生有顶处。又是上十善业道与智慧观和合修行其心狭劣故。心厌畏三界故。远离大悲故。从他闻声而通达故。闻声意解成声闻乘

论曰。智慧观者实相观故。恶道者是苦。不善业道是集。彼离是灭。彼对治是道。又善道者是苦。善业道是集。离彼使是灭。彼对治是道。智慧同观修行无分别。声闻有五种相。一因集。二畏苦。三舍心。四依止。五观。如是狭劣等是声闻心。因集者修行微少善根故。但依自身利益。如经其心狭劣故。畏苦者如经心厌畏三界故。舍心者舍诸众生。如经远离大悲故。依止者依师教授故。观者念音声故。何者音声。我众生等但有名故。如是彼者从音声解故。入众生无我非法无我。如经从他闻声而通达故。闻声意解成声闻乘故

经曰。又是上十善清净业道不从他闻故。自正觉故。不能具足大悲方便故。而能通达深因缘法成辟支佛乘

论曰。辟支佛有三种相。一者自觉。二不能说法。三观少境界。不假佛说法及诸菩萨唯自觉悟。如经不从他闻故。自正觉故。不起心说法。不堪说法故。如经不能具足大悲方便故。观微细因缘境界行故。如经而能通达深因缘法成辟支佛乘故。因集畏苦舍众生。辟支佛亦有此法。所有胜事此中已说

经曰。又是上上十善业道清净具足其心广大无量故。于诸众生起悲愍故。方便所摄故。善起大愿故。不舍一切众生故。观佛智广大故。菩萨地清净波罗蜜清净入深广行成

论曰。菩萨有四种相。一者因集。二者用。三者彼力。四者地依。一切善根起行故。依一切众生利益行故。大乘心广无量故。此是因集。如经又是上上十善业道清净具足其心广大无量故。见诸众生习行苦因及受苦时起悲愍心。依彼众生作利益是菩萨用。如经于诸众生起悲愍故。彼力者。谓四摄法。如经方便所摄故。地者有三种。一者净深心地。十大愿得名。如经善起大愿故。二者不退转地。得寂灭行已不舍解脱众生。如经不舍一切众生故。三者受大位地。是故求证佛广大智。如经观佛智广大故。菩萨地清净波罗蜜清净入深广行成。此中但说菩萨地广成便足。何故复说地净波罗蜜净。有上上清净故。第一法清净故。显示菩萨深广行成。第一义者波罗蜜义故

经曰。又是上上十善业道。一切种清净十力力故。集一切佛法令成就故。是故我应等行十善业道修行一切种令清净具足

论曰。上上者。有四种义显上上事。一者灭。二者舍。三者方便。四者无厌足。不善业道共习气灭故。善业自在成就故。声闻辟支佛舍故。方便者于菩萨乘善巧故。余残无厌足故。一切智中得自在智故。一切种令清净故。如经又是上上十善业道一切种清净故。十力力故。集一切佛法令成就故。是故我应等行十善业道修行一切种令清净具足故。降伏魔怨小乘作增上故。显示力佛法。应知。次上依大悲利益众生戒增上。有五种义。一者智。二者愿。三者修行。四者集。五者集果。智者有三种相。一者时差别。二者报果差别。三者习气果差别

经曰。是菩萨复作是思惟。此十不善业道。上者地狱因缘。中者畜生因缘。下者饿鬼因缘。于中杀生之罪。能令众生堕于地狱畜生饿鬼。若生人中得二种果报。一者短命。二者多病。劫盗之罪。亦令众生堕于地狱畜生饿鬼。若生人中得二种果报。一者贫穷。二者共财不得自在。邪淫之罪。亦令众生堕于地狱畜生饿鬼。若生人中得二种果报。一者妇不贞良。二者二妻相诤不随己心。妄语之罪。亦令众生堕于地狱畜生饿鬼。若生人中得二种果报。一者多被诽谤。二者恒为多人所诳。两舌之罪。亦令众生堕于地狱畜生饿鬼。若生人中得二种果报。一者得破坏眷属。二者得弊恶眷属。恶口之罪。亦令众生堕于地狱畜生饿鬼。若生人中得二种果报。一者常闻恶声。二者所有言说恒有诤讼。绮语之罪。亦令众生堕于地狱畜生饿鬼。若生人中得二种果报。一者所说正语人不信受。二者所有言说不能辩了。贪欲之罪。亦令众生堕于地狱畜生饿鬼。若生人中得二种果报。一者贪财无有厌足。二者多求恒不从意。嗔恚之罪。亦令众生堕于地狱畜生饿鬼。若生人中得二种果报。一者常为他人求其长短。二者常为他所恼害。邪见之罪。亦令众生堕于地狱畜生饿鬼。若生人中得二种果报。一者常生邪见家。二者心恒谄曲。诸佛子。如是十不善业道。皆是众苦大聚因缘

论曰。时差别者。依不善业道因果上中下差别。如经是菩萨作是思惟。此十不善业道。上者地狱因缘。中者畜生因缘。下者饿鬼因缘故。前总观不善业道因。今别观报果一切诸恶处。如经杀生之罪能令众生堕于地狱畜生饿鬼乃至邪见之罪亦令众生堕于地狱畜生饿鬼故。习气果者。人中一一各有二种果。如经若生人中得二种果报。一者短命。二者多病。乃至若生人中得二种果报。一者常生邪见家。二者心恒谄曲故。是中时报差别者。示现苦深重故。云何示现。下者饿鬼中深故。中者复转深故。上者转转重深故。习气果差别者。随顺至善道中故。总别合观恶道中无量大苦。如经诸佛子如是十不善业道皆是众苦大聚因缘故。云何为愿

经曰。菩萨复作是念。我当远离十不善业道乐行法行

论曰。愿者复乐行大乘法。作利益众生义故。摄善法故。如经菩萨复作是念乃至乐行法行故。云何修行

经曰。菩萨远离十不善业道。安住十善业道。亦令他人住于十善业道

论曰。修行者。自住善法远离彼障。修行对治亦令众生住善法故。如经菩萨远离十善业道。乃至亦令他人住于十善业道故。云何为集

经曰。是菩萨复于一切众生中生安隐心乐心慈心悲心怜愍心利益心守护心我心师心生尊心

论曰。集者依增上悲。复为念众生故生十种心。复次此心为八种众生故生。一者于恶行众生欲令住善行故。如经安隐心故。二者于苦众生欲令乐具不尽故。如经乐心故。三者于怨憎众生不念加报。如经慈心故。四者于贫穷众生欲令远离彼苦。如经悲心故。五者于乐众生欲令不放逸。如经怜愍心故。六者于外道众生欲令现信佛法故。如经利益心故。七者于同行众生欲令不退转。如经守护心故。八者于一切摄菩提。愿众生取如己身是诸众生即是我身。如经我心故。生余二心者。观彼众生乘大乘道进趣集具足功德。如经师心故。生尊心故。集果者胜悲所摄欲胜

复次依增上颠倒为首于三种众生。一欲求。二有求。三梵行求。欲求众生者有二种。一受用时。二追求时。受用有三种。一受不共财。二受无厌足财。三受贮积财。追求有二种。一追求现报。习恶行故。二追求后报。习善行故。有求众生亦有二种。一者道差别。二者界差别。梵行求众生亦有二种一者邪见诸外道等。二者正见同法小乘等。彼诸众生趣如是道。随顺对治令住如所应处。云何颠倒为首

经曰。菩萨复作此念。是诸众生堕于邪见恶意恶心行恶道稠林。我应令彼众生行真实道。住正见道如实法中

论曰。邪见者谓四颠倒。此颠倒者二倒名为恶意。专念行故。二倒名为恶心。非专念行。谓我净想故。彼非正道稠林行因。非正道者是诸烦恼。稠林者烦恼使故。如经菩萨复作此念。是诸众生堕于邪见恶意恶心行恶道稠林故。彼诸众生随顺对治妙法正念正见出世间法。如经我应令彼众生行真实道。住正见道如实法中故。云何受不共财

经曰。是诸众生共相破坏。分别彼我常共斗诤。日夜嗔恨炽然不息。我应令彼众生住于无上大慈中

论曰。受不共财者互相破坏。破坏有二种。一对怨于心中。二斗诤于言中。如是破坏思念作报增长行炽。如经是诸众生共相破坏乃至日夜嗔恨炽然不息故。对怨于心中分别彼我。此言示现斗诤于言中。常共斗诤。此言示现思念作报增长行炽。日夜嗔恨炽然不息。此言示现彼诸众生随顺对治与大慈益。如经我应令彼众生住于无上大慈中故。云何受无厌足财

经曰。是诸众生心无厌足常求他财邪命自活。我应令彼众生住于清净身口意业正命法中

论曰。受无厌足财者有二种。一贪于心中。二于身口中。斗秤妄语等方便夺故。如经是诸众生心无厌足常求他财邪命自活故。彼诸众生随顺对治清净身口意业正命自活。如经我应令彼众生住于清净身口意业正命法中故。云何受贮积财

经曰。是诸众生因随逐贪欲嗔恚愚痴。常为种种烦恼炽火之所烧然。不能志求出要方便。我应令彼众生灭除一切烦恼大火。安置清凉无畏之处

论曰。受贮积财者。贪等因体过彼染着故。于彼散用起嗔心故。彼宝玩受用中多乐境界。数为烦恼火之所烧然过。不见彼过无求出意。如经是诸众生因随逐贪欲嗔恚愚痴常为种种烦恼炽火之所烧然。不能志求出要方便故。彼诸众生随顺对治。除一切烦恼置清凉处。如经我应令彼众生灭除一切烦恼大火。安置清凉无畏之处故。云何追求现报习诸恶行

经曰。是诸众生常为愚痴闇冥妄见厚曀。无明黑闇所覆入大黑闇稠林。远离智慧光明。堕大黑闇处。随其所见到种种险道。我应令彼众生得无障碍清净慧眼。以是眼故知一切法如实相。得不随他一切如实无障碍智

论曰。追求现报习恶行者。既有愚痴闇冥妄见厚曀黑闇所覆过妄见乐故。不见未来实果报过故。亦不见现在实果报过故。如经是诸众生常为愚痴闇冥妄见厚曀无明黑闇所覆故。又愚痴者。多为闇冥故。妄见者。颠倒乐见故。厚曀者不见未来实果报过故。黑闇者不见现在实果报过故。是愚痴因满足使事是过及远离无漏智处故。彼善行障顺不善行故。如经入大黑闇稠林故。远离智慧光明故。稠林者是愚痴因使故。大者满足故。受至大对过患。如经堕大黑闇处故。是中对者黑闇示现。如闇中行处处障碍如是相似法故。受大对事成至诸恶趣。是故名堕多作罪因。于临终时见恶报相心生悔见过。如经随其所见到种种险道故。见险道者悔见故。见本罪相不能集彼对治正见。随其所见者于死时故。彼诸众生随顺对治。以如实法令得无障碍清净慧眼。如经我应令彼众生得无障碍清净慧眼。以是眼故知一切法如实相。得不随他。一切如实无障碍智故。云何追求后报习诸善行

经曰。是诸众生随顺世间生死险道。将坠地狱畜生饿鬼深坑。随顺入恶见网中。为种种愚痴稠林所覆。随逐虚妄道行颠倒行。常盲冥故远离有智导师。非出要道处谓出要想。随逐魔道怨贼所摄。远离善巧导师入魔意稠林远离佛意。我应拔济彼诸众生种种诸苦度于世间险道艰难安置无畏处。令住萨婆若大城

论曰。追求后报习善行者。随顺险道过。如经是诸众生随顺世间生死险道故。彼险道有三种。一自体。二障碍。三者失。自体者世间乏少善根本故。障碍者有八种。一者求出而随顺世间堕三恶趣。如经将坠地狱畜生饿鬼深坑故。二者入网。于苦果中妄生乐故。如经随顺入恶见网中故。三者黑暗稠林所覆彼彼痴使所覆故。为说苦因而不知觉。如经为种种愚痴稠林所覆故。四者行颠倒道舍真实乐妄行邪道故。如经随逐虚妄道行颠倒行故。五者盲冥得果贪着爱欲所盲故。如经常盲冥故。六者远离导师生恶道中。及放逸等过。虽值佛世而不见不闻故。如经远离有智导师故。七者怖求涅槃而趣彼异处。谓梵天等梵世间等。以为出世正见。如经非出要道处谓出要想故。八者怨贼行魔境界。贪着诸欲劫功德尽令不集故。如经随逐魔道怨贼所摄故。失者有三种。一者离善导师依不善地。如经远离善导师故。二者依止怨地。如经入魔意稠林故。三者远离作善知识地。如经远离佛意故。彼诸众生随顺对治以如实法令出世间住一切智地。如经我应拔济彼诸众生种种诸苦。度于世间险道艰难。安置无畏处。令住萨婆若大城故。云何道差别

经曰。是诸众生为大瀑水波浪所没。随顺欲流有流见流无明流。随顺世间漂流没大爱河在大驶流。不能正观。常有欲觉嗔觉恼觉恶行广故。爱见水中罗刹所执顺入欲林。回复求欲事中深爱着故。我慢陆地之所燋枯无能救者。于六入聚落不能动发。自离善行无正度者。我应于彼众生生大悲心以善根力而拔济之。令得无畏不染寂静离诸恐怖住于一切智慧宝洲

论曰。有求众生道差别者。没在大河过。如经是诸众生为大瀑水波浪所没故。彼大瀑水波浪有三种。一自体。二起难。三者失。自体者有五种相。一者深无量水故。如经随顺欲流有流见流无明流故。二者流随顺世间常流不断。如经随顺世间漂流故。三者名爱水所没。如经没大爱河故。四者漂。念念不住不见岸故。如经在大驶流不能正观故。五者广随顺欲等念觉广故。如经常有欲觉嗔觉恼觉恶行广故。起难有四种。一者执着我我所窟宅不能动离故。如经爱见水中罗刹所执故。二者入回先舍欲已还复转入欲念中故。如经顺入欲林回复故。三者中着。于受用时求欲等乐着故。如经求欲事中深爱着故。四者洲。于用事时中我等最胜。三种我慢自高轻彼。如经我慢陆地之所燋枯故。失者有三种。一者无救失。处恶道中无人济拔。如经无能救者故。二者无出意失。处善道中无出离心。如经于六入聚落不能动发故。三者异处去失。生诸难处不值佛世。如经自离善行无正度者故。彼诸众生随顺对治。以如实法令住一切智洲。如经我应于彼众生生大悲心以善根力而拔济之。令得无畏不染寂静。离诸恐怖住于一切智慧宝洲故。云何界差别

经曰。是诸众生闭在世间牢狱之处。众多患苦多恼妄想爱憎系缚忧悲共行爱锁所系。入于三界无明稠林所覆。我应令彼众生远离一切三界所著。令住离相无碍涅槃

论曰。有求众生界差别者。闭在牢狱过。如经是诸众生闭在世间牢狱之处故。此牢狱过有五种随逐应知。一苦事。二财尽。三爱离。四者缚。五障碍。此示五种难差别。一者无病难。多种病苦妄想愁恼。如经众多患苦多恼妄想故。二者资生难。于爱不爱事中憎爱所缚。如经爱憎系缚故。三者亲难。亲爱离坏忧悲增长。如经忧悲共行故。四者戒难。虽生色无色中暂离犯戒。不免戒行相违爱欲使缚。如经爱锁所系故。五者见难。得世间智彼相违无明使之所覆蔽。如经入于三界无明稠林所覆故。彼诸众生随顺对治。以如实法令住离相无碍涅槃。如经我应令彼众生远离一切三界所著。令住离相无碍涅槃故。云何邪见诸外道等

经曰。是诸众生深着我相。于五阴巢窟不能自出。行四颠倒。依六入空聚常为四大毒蛇之所侵恼。为五阴怨贼之所杀害。受此一切无量苦恼。我应令彼众生离一切障碍。令住空无我智道。所谓涅槃灭一切障碍

论曰。邪梵行诸外道等者。执取我相过。此余见根本。如经是诸众生深着我相故。彼诸众生欲趣涅槃城。以有我故于五阴舍不能动发。如经于五阴巢窟不能自出故。欲行正道以颠倒故。行彼邪道。如经行四颠倒故。依恃我想欲趣涅槃。虚妄我见住六入聚。如经依六入空聚故。受老病死等诸苦。意欲远离而不得离。恒随己身。如经常为四大毒蛇之所侵恼故。阴怨随逐而不放舍。如经为五阴怨贼之所杀害故。常为种种诸苦随逐。如经受此一切无量苦恼故。彼诸众生随顺对治。以如实法离一切障。令住涅槃。如经我应令彼众生离一切障碍。令住空无我智道。所谓涅槃灭一切障碍故。云何正梵行同法小乘等

经曰。是诸众生小心狭劣不求大乘。其心远离无上一切智智。等有出行而乐声闻辟支佛乘。我应令彼众生安住微妙无上佛法深广大意。诸佛子。菩萨如是随顺持戒力。善能广起方便行故

论曰。正行梵行求小乘过。此小乘意有二种。一者小心。佛法微妙广大无量。其心退没而不能证故。二者狭心。于无量众生作利益懈怠故。如经是诸众生小心狭劣不求大乘法故。复依小乘心愿过。愿小乘故。如经其心远离无上一切智智故。修行过。不定聚众生实有大乘出法而修行小乘。如经等有出行而乐声闻辟支佛乘故。彼诸众生随顺对治。以如实法令住微妙无上佛法广大心故。如经我应令彼众生安住微妙无上佛法深广大意故。依持戒行故。得此戒力能作善法。善巧起诸善行故。如经诸佛子菩萨如是随顺持戒力善能广起方便行故

经曰。诸佛子是菩萨。住此菩萨离垢地已。多见诸佛。以大神通力大愿力故。见多百佛多千佛多百千佛多百千那由他佛多亿佛多百亿佛多千亿佛多百千亿佛多百千亿那由他佛。以大神通力大愿力故。是菩萨见诸佛时。以上心深心供养恭敬尊重赞叹。衣服饮食卧具汤药。一切供具悉以奉施。以诸菩萨上妙乐具供养众僧。以此善根皆愿回向阿耨多罗三藐三菩提。于诸佛所。生上恭敬心。复受十善法。受善法已。乃至得阿耨多罗三藐三菩提终不中失。是菩萨于无量劫无量百劫无量千劫无量百千劫无量亿劫无量百亿劫无量千亿劫无量百千亿劫无量百千亿那由他劫远离悭嫉破戒垢心。习行布施持戒清净。诸佛子。譬如成炼真金置矾石中煮已离一切垢转复明净。诸佛子。菩萨住此离垢地中亦复如是。于无量劫乃至无量百千亿那由他劫。远离悭嫉破戒垢心。成就布施持戒清净。菩萨尔时于四摄法中爱语偏多。十波罗蜜中戒波罗蜜增上。余波罗蜜非不修集随力随分。诸佛子。是名略说菩萨摩诃萨第二菩萨离垢地。菩萨住是地中。多作转轮圣王。得法自在七宝具足。有自在力能除一切众生破戒等垢。以善方便令诸众生修行十善业道。所作善业布施爱语利益同事。是诸福德皆不离念佛念法念僧念菩萨念菩萨行念波罗蜜念十地念不坏力念无畏念不共佛法。乃至不离念具足一切种一切智智。常生是心。我当于一切众生中为首为胜为大为妙为微妙为上为无上为导为将为师为尊。乃至为一切智智依止者。诸佛子。是菩萨摩诃萨。若欲舍家勤行精进。于佛法中便能舍家妻子五欲。得出家已勤行精进。于一念间得千三昧。得见千佛。知千佛神力。能动千佛世界。能入千佛世界。能照千佛世界。能教化千佛世界众生。能住寿千劫。能知过去未来世各千劫事。能善入千法门。能变身为千。于一一身能示千菩萨以为眷属。若以愿力自在胜上。菩萨愿力过于此数。示种种神通。或身或光明或神通或眼或境界或音声或行或庄严或加或信或业。是诸神通乃至无量百千万亿那由他劫不可数知

论曰。此中果利益挍量胜事者。如初地说。此地亦如是。有者同无者应知。此中胜事者。于无量劫远离悭嫉破戒垢心。成就布施持戒清净等诸事胜故。于初地中戒未净故。施亦未净。若尔何故初地中说檀波罗蜜增上余者不如。然彼檀波罗蜜等此地中转胜清净故。以离悭嫉破戒等垢。是故此地释名离垢。初地中金但以火炼除外贪等粗垢故。说炼金清净。今于此地复置矾石中煮除自体明垢故。自性真净故。说性戒清净义

十地经论离垢地卷之四十地经论明地第三卷之五

        天亲菩萨造

        后魏北印度三藏菩提流支译

论曰。依第三明地差别有四分。一起厌行分。二厌行分。三厌分。四厌果分。起厌行者。谓十种深念心。厌行者。观一切行无常乃至未入禅。厌者四禅四空三摩跋提。厌果者。四无量等净深心应知

经曰。诸佛子。菩萨善清净心行第二地已。欲得第三菩萨地。当起十种深念心。何等为十。一净心。二不动心。三厌心。四离欲心。五不退心。六坚心。七明盛心。八淳厚心。九快心。十大心。菩萨以是十种深念心得入第三地

论曰。是中十种深念心者。一依彼起净深念心。如经净心故。二依不舍自乘。如经不动心故。三志求胜法起善方便。此能厌患当来贪欲。四依现欲不贪。如经厌心故。离欲心故。五依不舍自乘进行。如经不退心故。六依自地烦恼不能破坏。如经坚心故。七依三摩跋提自在。如经明盛心故。八依禅定自在有力。虽生下地而不退失。如经淳厚心故。九依彼生烦恼不能染。如经快心故。十依利益众生不断诸有。如经大心故。已说起厌行分。次说厌行分。厌行有三种。一修行护烦恼行。二修行护小乘行。三修行方便摄行。修行护烦恼行者。观一切行无常无有救者。此二十句示现云何观一切行无常

经曰。诸佛子。是菩萨住第三菩萨地已。正观有为法一切行无常。苦不净无常败坏不久住。念念生灭不从前际来。不去至后际。现在不住。如是正观一切诸行

论曰。是中命行不住故。总明无常观。如经正观有为法一切行无常故。云何此无常。何者是无常。如是正观。云何此无常者。依身转时力生三种苦。如经苦故。依饮食力形色增损等。如经不净故。依不护诸恶力横夭寿等。如经无常故。依世界成力灭坏故。如经败坏故。资生依主无有定力一处不住。如经不久住故。何者是无常者。无常有二种。一者少时。如经念念生灭故。二者自性不成。实过去未来现在三世中。不生不转不住。如经不从前际来不去至后际现在不住。如是正观一切诸行故。如是观一切有为法。无常行中无有救者

经曰。是菩萨如是真实观见一切行。无有救者无所依止。共忧共悲共热恼。憎爱所系忧恼转多。无有停积。常为贪嗔痴火所然。见身无量病苦增长

论曰。是菩萨如是真实观见一切行无有救者。第二十句说此无救有九种。一者于无常未至中无所依告。如经无所依止故。二者无常既至无能救者。以无常至故多共忧苦。如经共忧故。三者中间同悲。如经共悲故。四者同苦恼事中忧悲随逐。其力虚弱转增热恼。如经共热恼故。五者追求资生时。欲所爱事不欲不爱。如是妄想爱憎常缚。如经憎爱所系故。六者受用时中乐少苦多。如经忧恼转多故。七者于身老时中少壮盛色不可复集。如经无有停积故。八者于少壮时具三种受贪等常烧。如经常为贪嗔痴火所然故。九者于年衰时无量病苦增长。如经见身无量病苦增长故。后三句皆明身患事。何故不在初说。示身数数患事故。云何修行护小乘行

经曰。是菩萨见如是已。于一切行转复厌离。趣如来智慧。是菩萨见如来智慧不可思议。无等无量难得无杂。无恼无忧。能至无畏安隐大城不复转还。见能救无量苦恼众生

论曰。修行护小乘者。于一切有为行生厌离已。趣向佛智慧。依如来智有二种大。一摄功德大。二清净大。摄功德大者有五种。一者神力摄功德大。如经是菩萨见如来智慧不可思议故。二者无比摄功德大。无有敌对。如经无等故。三者大义摄功德大。广能利益无量众生。如经无量故。四者无讥嫌摄功德大。希有难得。如经难得故。五者不同摄功德大。诸外道不杂。如经无杂故。清净大者。离烦恼使苦得涅槃故。离烦恼使者。离烦恼习无明不杂。如经无恼故。离苦者。苦根本尽忧悲随尽。如经无忧故。得涅槃者。如经能至无畏安隐大城故。菩萨至涅槃城不复退还。而能利益众生。得世间出世间涅槃胜事。如经不复转还故。见能救无量苦恼众生故。依无救众生起十种殊胜心

经曰。菩萨如是见如来智无量。见一切有为行无量苦恼。复于一切众生转生殊胜十心。何等为十。所谓众生可愍孤独无救生殊胜心。恒常贫穷生殊胜心。三毒之火炽然不息生殊胜心。闭在三有牢固之狱生殊胜心。常为烦恼诸恶稠林所覆生殊胜心。无正观力生殊胜心。远离善法心无喜乐生殊胜心。失诸佛妙法生殊胜心。而常随顺世间水流生殊胜心。失涅槃方便生殊胜心。是名生殊胜十心

论曰。是中无救者以孤独故。孤独无救有九种。一恒常贫穷孤独无救。二三毒之火炽然不息孤独无救。三闭在三有牢固之狱孤独无救。四常为烦恼诸恶稠林所覆孤独无救。五无正观力孤独无救。六远离善法心无喜乐孤独无救。七失诸佛妙法孤独无救。八而常随顺世间水流孤独无救。九失涅槃方便孤独无救。是中依欲求众生心无厌足。于他资财求无休息。此二应知。如经恒常贫穷生殊胜心故。三毒之火炽然不息生殊胜心故。依有求众生六道世间轮转故。彼因烦恼所覆故。常生难处故。如是三句次第应知。如经闭在三有牢固之狱生殊胜心故。常为烦恼诸恶稠林所覆生殊胜心故。无正观力生殊胜心故。依梵行求众生不起胜念者。怀增上慢者。无入涅槃心者。妄行外道者。如是四句次第应知。如经远离善法心无喜乐生殊胜心故。失诸佛妙法生殊胜心故。而常随顺世间水流生殊胜心故。失涅槃方便生殊胜心故。次说救度众生精进行发此十心

经曰。是菩萨见诸众生界如是具受种种苦恼。已发大精进行。是诸众生我应救我应解。应令清净应令得脱。应着善处。应令安住。应令欢喜。应知所宜。应令得度。应令涅槃

论曰。何处救度以何救度云何救度成。此分别救度众生差别。何处救度者。于业妄想中烦恼妄想中生妄想中。如经我应解故。应令清净故。应令得脱故。如是次第我应救度故。以何救度者。授三学摄取故。劝置持戒处故。劝住定慧处故。如经应着善处故。应令安住故。如是次第三昧地故。定慧合说。复劝置持戒处有二种。一除疑网令信戒故。如经应令欢喜故。二已入戒者令心乐住安固不动。如经应知所宜故。复劝住定慧处灭除掉没随烦恼使。如经应令得度故。云何救度成者。令得二种涅槃界。如经应令涅槃故。是名修行护小乘行。云何修行方便摄行

经曰。菩萨如是善厌离一切有为行已。深念一切众生界。趣一切智智无量利益。即时依如来智慧救度众生。作是思惟。此诸众生堕在大苦烦恼业中。以何方便行而拔济之令住涅槃毕竟之乐

论曰。是中厌离深念利益。示现三种因。一者远离妄想因。善厌离一切有为行故。二者不舍世间因。深念一切众生故。三者发精进因。趣一切智智无量利益故。于中趣利益处者。能修行彼道故。深念者能善化众生故。依如来智慧救度众生。此言示现发起方便摄行。如经作是思惟。此诸众生堕在大苦烦恼业中。以何方便行而拔济之令住涅槃毕竟之乐故。堕在大苦烦恼业中者。苦者生妄想。烦恼者烦恼妄想。业者业妄想。涅槃毕竟乐者。无上涅槃故。是中方便摄行有三种。一证毕竟尽。二起上上证毕竟尽。三彼起依止行

经曰。是菩萨作如是念。不离无障碍解脱智处。彼无障碍解脱智处。不离一切法如实觉。彼一切法如实觉。不离无行无生行慧。如是智慧光明。不离禅方便决定智慧观。彼禅方便决定智慧观。不离闻慧方便

论曰。证毕竟尽者。住无障碍解脱智中。如经是菩萨作如是念。不离无障碍解脱智处故。彼尽以如来所说一切法随顺如实觉起。以此如实觉起彼无障碍解脱智。如经彼无障碍解脱智处不离一切法如实觉故。此自相同相无分别行慧。如经彼一切法如实觉不离无行无生行慧故。如是智慧光明不离禅方便决定智慧观者。彼慧此中名光明。依是光明故名明地。彼菩萨于禅定中方便决定智慧观。如经彼禅方便决定智慧观不离闻慧方便故。彼禅方便者。得胜进禅故。决定者。于他决定故。智慧观者。自智慧观故。是名起上上证毕竟尽。彼如是智慧观依闻慧方便得。此是彼起依止行。闻慧方便是起所依。是故修行是名彼起依止行。是中行者。日夜求法闻法。如是次第依教依义

经曰。菩萨如是正观知已。转复勤修求正法行。日夜常求。闻法喜法乐法依法随法益法思法究竟法归依法随顺行法

论曰。是中求正法行者。依经教依义如前说。日夜常求闻法喜法乐法者。无慢心无妒心无折伏他心问义故。依法者。依大乘教法自见正取不忘失故。随法益法思法者。依读诵依为他说依静处思义故。究竟法者。依定修行故。归依法者。依出世间智故。随顺行法者依解脱。于诸佛解脱法随顺彼行故。是中求正法行常求闻法。此初二句示现常勤行故。喜法等九句示现正修行故。彼常勤行以何为因。示现恭敬重法毕竟尽故。彼菩萨以财为首。于财宝中及王位处。或生天处。世间净中及以己身以法为重

经曰。菩萨如是方便求佛法故。无有诸财钱谷仓库宝藏等事而不能舍。于此物中不生难想。但于说法者生难遭想。是菩萨为求佛法故。无有所用外财而不能舍无有内财而不能舍。无有所作供给尊事而不能行。无有憍慢我慢大慢等而不能舍。质直柔软故。无有身苦而不能受。是菩萨得成就胜财心。若闻一句未曾闻法。胜得满三千大千世界珍宝。是菩萨得闻一偈正法生上财想。胜得转轮圣王位。复得胜财心。若得未曾闻法能净菩萨行。胜得释提桓因梵天王处无量劫住。是菩萨若有人来作如是言。我与汝佛所说法一句能净菩萨行。汝今若能入大炽然火坑受大苦者。当以相与。是菩萨作如是念。我受一句佛所说法能净菩萨行故。尚于三千大千世界满中大火从梵天投下。何况入小火坑。我等法应尽受一切诸地狱苦犹应求法。何况人中诸小苦恼。菩萨如是发精进行。修诸正法。随所闻法。于寂静处悉能正观

论曰。彼菩萨为重法故。能舍一切财物。如经菩萨如是方便求佛法。乃至但于说法者生难遭想故。彼财所得处田宅等外财彼亦能舍。如经是菩萨为求佛法故。无有所用外财而不能舍故。及彼财所为内法此亦能舍。如经无有内财而不能舍故。及彼所为是亦能舍。身行恭敬奉给等。如经无有所作供给尊事而不能行故。谁于此物能得能舍。彼高大意此亦能舍。如经无有憍慢我慢大慢等而不能舍质直柔软故。所应护者彼亦能舍。种种身苦而无不受。如经无有身苦而不能受故。于得众多胜妙财宝然不爱乐。重法心成故。如经是菩萨得成就胜财心。乃至胜得满三千大千世界珍宝故。是名于财中胜。云何王位等中胜。是菩萨得法转生喜心成就。胜得转轮王位释梵天王等。如经是菩萨得闻一偈正法生上财想。乃至胜得释提桓因梵天王处无量劫住故。为求法故投身满三千大千世界炽然火中。及地狱中久受苦恼。如经是菩萨若有人来作如是言。我与汝佛所说法一句。乃至何况人中诸小苦恼故。是中闻一句法者。谓闻字句法。得闻一偈法者。谓闻偈法故。能净菩萨行者。谓闻义故。此正修行以何为因。示现依寂静处思惟正观故。如经菩萨如是发精进行。乃至悉能正观故。云何厌分。是菩萨闻诸法已。知如说修行乃得佛法。入禅无色无量神通彼非乐处。于中不染必定应作故

经曰。是菩萨闻诸法已。降伏其心于空闲处心作是念。如说行者乃得佛法。不可但以口之所言而得清净。是菩萨住此明地因如说行故。即离诸欲恶不善法有觉有观离生喜乐入初禅行。是菩萨灭觉观内清净心一处无觉无观定生喜乐入二禅行。是菩萨离喜行舍忆念安慧身受乐诸贤圣能说能舍念受乐入三禅行。是菩萨断苦断乐先灭忧喜不苦不乐。舍念清净入四禅行。是菩萨过一切色想。灭一切有对想。不念一切别异想。知无边虚空即入无边虚空处行。是菩萨过一切无边虚空想。知无边识即入无边识处行。是菩萨过一切无边识想。知无所有即入无所有处行。是菩萨过一切无所有处。知非有想非无想安隐。即入非有想非无想处行。但随顺法行故而不乐着

论曰。以何义故。入禅无色无量神通。为五种众生故。一为禅乐憍慢众生故入诸禅。二为无色解脱憍慢众生故入无色定。三为苦恼众生令安善处永与乐故。应解彼苦令不受故。入慈悲无量。四为得解脱众生故。入喜舍无量。五为邪归依众生故。入胜神通力。令正信义故。此地得不退禅故。名为三昧地。前地非无三昧此地胜故。是中禅无色差别有四种。一离障。二修行对治。三修行利益。四彼二依止三昧。是初禅中离诸欲恶不善法是名离障。如经即离诸欲恶不善法故。有觉有观是名修行对治。如经有觉有观故。喜乐是名修行利益。如经离生喜乐故。入初禅行是名彼二依止三昧。如经入初禅行故。第二禅中灭觉观是名离障。如经灭觉观故。内净是名修行对治灭觉观障。如经内清净心一处无觉无观故。心一处者。修无漏不断三昧行一境故。定生喜乐是名修行利益。如经定生喜乐故。入二禅行是名彼二依止三昧。如经入二禅行故。第三禅中离喜是名离障。如经离喜故。行舍忆念安慧是名修行对治。如经行舍忆念安慧故。身受乐是名修行利益。如经身受乐故。入三禅行是名彼二依止三昧。如经入三禅行故。第四禅中断苦断乐先灭忧喜是名离障。如经断苦断乐先灭忧喜故。舍念清净是名修行对治。如经舍念清净故。不苦不乐是名修行利益。如经不苦不乐故。入四禅行是名彼二依止三昧。如经入四禅行故。无色三摩跋提亦有四种。一离障。二修行对治。三修行利益。四彼二依止三昧。过一切色想者。过眼识想故。灭一切有对想者。耳鼻舌身识和合想灭故。不念一切别异想者。不念意识和合想故。意识分别一切法故。说别异想是名离障。如是对治过色等境界想。不分别色等境界见无我故。是名修行对治。知无边虚空者。是名修行利益。即入无边虚空行者。是名彼二依止三昧。过一切无边虚空想者。是名离障。如是对治过彼无边虚空见外念粗分别过患是名修行对治。知无边识者。是名修行利益。即入无边识行者。是名彼二依止三昧。过一切无边识想者。是名离障。如是对治过彼无边识见粗事念分别过患。是名修行对治知无所有者。是名修行利益。即入无所有行者。是名彼二依止三昧。过一切无所有想者。是名离障。如是对治过彼无所有见粗念分别过患。是名修行对治。知非有想非无想安隐者。是名修行利益。即入非有想非无想行者。是名彼二依止三昧。已说厌分

云何厌果。谓四无量五神通等。云何四无量

经曰。是菩萨慈心随顺广大无量不二。无嗔恨无对无障无恼害。遍至一切世间处法界世间最究竟虚空界。遍覆一切世间行。如是菩萨悲心随顺喜心。随顺舍心。随顺广大无量不二。无嗔恨无对无障无恼害。遍至一切世间处法界世间最究竟虚空界。遍覆一切世间行

论曰。无量有三种。一众生念。二法念。三无念。众生念者。有四种相差别。一与乐。二障对治。三清净。四摄果。云何与乐。与三种乐。一与欲界乐。二与色界同喜乐。三与不同喜乐。彼离苦离喜故。不二者。亦是广大无量。如经是菩萨慈心随顺广大无量不二故。云何障对治。与不爱者与爱此障对治。如经无嗔恨无对故。云何清净。正断身心不调睡眠掉悔诸盖等。如经无障故。云何摄果。欲色界中受正果习果无苦事故。如经无恼害故。云何法念。遍一切处所有欲色无色界凡夫。有学无学众生等法。及众生所有分别作者皆能念知。如经遍至一切世间处故。无念者有二种。一自相无念。观法无我世间中最。如经法界世间最故。二遍至无尽观。如经究竟虚空界故。一切世间者。一切世界普行故。如经遍覆一切世间行故。诸神通者。四通明智第五明见。初一神通身业清净。天耳他心智二通口业清净。宿命生死智二通意业清净。一身通能到众生所。天耳他心二通能知说法音声义故。以知他心故。随种种言音皆能尽知。依于此义种种异名说随众生用故。去来二通尽知众生过去未来所应受化故。云何身通

经曰。是菩萨现无量神通力能动大地。一身为多身多身为一身。现没还出石壁山障皆能彻过如行虚空。于虚空中加趺而去犹如飞鸟。入出于地如水无异。履水如地。身出烟焰如大火聚。身中出水犹如大云。日月有大神德有大威力而能以手扪摸摩之。身力自在乃至梵世。是菩萨以天耳界清净过人。悉闻人天二种音声若近若远乃至蚊虻蝇等悉闻其声。是菩萨以他心智如实知他众生心及心数法。有贪心如实知有贪心。离贪心如实知离贪心。如实知有嗔心离嗔心有痴心离痴心。如实知有染心离染心小心广心大心无量心摄心不摄心住定心不住定心解脱心不解脱心求心不求心。上心如实知上心。非上心如实知非上心。如是以他心智如实知他众生心及心数法。是菩萨如实念知无量宿命诸所生处。亦能念知一生二三四五乃至十二十三十四十五十。亦能念知百生。念知无量百生无量千生无量百千生。念知成劫坏劫及成坏劫无量成坏劫。乃至念知百劫千劫百千劫亿劫百亿劫千亿劫百千亿劫。乃至念知无量百千万亿那由他劫。我本在某处。如是名如是姓如是生如是色如是饮食如是寿命如是久住。如是受苦乐。我于彼死生于此间。于此间死生于彼间。如是过去世种种相貌。说姓相等皆能念知。是菩萨天眼界清净过人。见诸众生若生若死形色好丑善行不善行贫贱富贵。是诸众生随所造业皆如实知。是诸众生成就身恶业。成就口恶业。成就意恶业。谤诸贤圣成就邪见。及邪见业因缘故。身坏命终必堕恶道生地狱中。是诸众生成就身善业。成就口善业。成就意善业。不谤贤圣成就正见。及正见善业因缘故。身坏命终必生善道及诸天中。如是菩萨天眼界清净过人。相貌姓名。见诸众生若生若死形色好丑善行不善行贫贱富贵。是诸众生随业受报皆如实知。是菩萨于禅解脱三昧三摩跋提能入能出。而不随禅解脱力生。随见能满菩提分法处。以愿力故而生其中

论曰。身通者。得胜自在应知。自在有三种。一世界自在。能动世界大地。如经是菩萨现无量神通力能动大地故。二身自在。彼能散合隐显。如经一身为多身多身为一身现没还出故。三作业自在。作业有八种。一者傍行无碍。如经石壁山障皆能彻过如行虚空故。二者上行。如经于虚空中加趺而去犹如飞鸟故。三者上下行。如经入出于地如水无异故。四者涉水不没。如经履水如地故。五者其身炽然。如经身出烟焰如大火聚故。六者身能注水。如经身中出水犹如大云故。七者身能摩扪。如经日月有大神德有大威力而能以手扪摸摩之故。八者自在。乃至梵世间器世间。随意转变得自在故。如经身力自在乃至梵世故。天耳通者。随能闻所闻如实示现清净谛闻故。过人者。远闻故过人。声者下乃至阿鼻地狱等声悉能闻故。如经是菩萨以天耳界清净过人故。随人天等所作音声现闻明了。乃至蚊虻蝇等微细音声亦能闻故。如经悉闻人天二种音声若近若远乃至蚊虻蝇等悉闻音声故。他心通者。他心差别有八种。一随烦恼。二使。三生。四学三昧行。五得三昧。六得解脱。七妄行正行。八余凡夫增上慢。随烦恼者。与贪嗔等和合。如经是菩萨以他心智如实知他众生心及心数法有贪心如实知有贪心乃至离痴心故。使者。有烦恼离烦恼等。如经如实知有染心离染心故。生者。人中小欲天中广色天中大。无色二解脱中无量。如经小心广心大心无量心故。学三昧行者。散心不散心。如经摄心不摄心故。得三昧者。入定不入定时及在定起时。如经住定心不住定心故。得解脱者。有缚无缚。如经解脱心不解脱心故。妄行正行者。于名闻中现起悕望顺不顺故。如经求心不求心故。余凡夫增上慢者。粗细习行故。如经上心如实知上心。非上心如实知非上心故。宿命智通者。谁能念智能念故。如经是菩萨如实念知无量宿命诸所生处故。念何等事。如经亦能念知一生乃至念知无量百千万亿那由他劫故。云何念因名字差别。如经我本在某处如是名故。家差别。如经如是姓故。贵贱差别。如经如是生故。好丑差别。如经如是色故。供膳差别。如经如是饮食故。业行差别。如经如是寿命如是久住故。衰利成坏差别。如经如是受苦乐我于彼死生于此间于此间死生于彼间故。是中家差别者。谓父母差别。贵贱差别者。刹利婆罗门等差别。业行差别者。命差别时非时死故。是中种种相貌者。一切诸相差别。如经种种相貌故。说者名称。如经说故。姓相者家姓等故。如经姓相等皆能念知故。复有异义亦能念知一生二生。如是等是名相貌。说者。名等故。相者。我于彼死生于此间。如是等皆能念知故。生死智通者。谁能见。以天眼见故。清净者审见故。过人者远见故。如经是菩萨以天眼界清净过人故。见何等事。谓众生生死等。如经见诸众生若生若死乃至随所造业皆如实知故。云何见。如经是诸众生成就身恶业乃至随业受报皆如实知故。余者如前二地中说。善恶业报此亦如是应知。是中禅者四禅。解脱者四无色定。三昧者四无量。三摩跋提者五神通。能入能出者。即生心时随心用现在前故。而不随禅解脱力生者。彼淳厚深念心此成就示现。随见能满菩提分法处者。与诸佛大菩萨共生一处故。如经是菩萨于禅解脱乃至以愿力故。而生其中故

经曰。是菩萨住菩萨明地已多见诸佛。以大神通力大愿力故。见多百佛多千佛多百千佛多百千那由他佛多亿佛多百亿佛多千亿佛多百千亿佛多百千万亿那由他佛。以大神通力大愿力故。是菩萨见诸佛时。以上心深心供养恭敬尊重赞叹。衣服饮食卧具汤药一切供具悉以奉施。以诸菩萨上妙乐具供养众僧。以此善根皆愿回向阿耨多罗三藐三菩提。于诸佛所生上恭敬心专心听法。闻已受持如说修行。是菩萨观一切法不生不灭因缘而有

论曰。一切法不生不灭者。于清净法中不见增。于烦恼妄想中不见减。因缘集生故。彼清净中。无一法可增。彼烦恼妄想中无一法可减。然依对治因缘故。离烦恼妄想。转胜清净般若现前。如经观一切法不生不灭因缘而有故

经曰。是菩萨一切欲缚转复微薄。一切色缚一切有缚一切无明缚皆悉微薄。诸见缚者先已除灭。是菩萨住菩萨明地已。无量百劫无量千劫无量百千劫无量百千那由他劫无量亿劫无量百亿劫无量千亿劫无量百千亿劫无量百千万亿那由他劫。不复现集断于妄贪。不复现集断于妄嗔。不复现集断于妄痴。是菩萨彼诸善根转增明净。诸佛子。譬如本真金巧师炼治秤两等住转更精好光明倍胜。诸佛子。菩萨亦复如是。住菩萨明地已。无量百劫乃至无量百千万亿那由他劫。不复现集断于妄贪。不复现集断于妄嗔。不复现集断于妄痴。彼诸善根转增明净。是菩萨忍辱安乐心转复明净。同和心柔软心不嗔心不动心不浊心不高下我心众生所作不悕望心有所施作不望报心不谄曲心不稠林心转复清净。是菩萨四摄法中利益增上。十波罗蜜中忍辱波罗蜜增上。余波罗蜜非不修习随力随分。诸佛子。是名略说菩萨第三菩萨明地

论曰。一切欲缚转复微薄者。断一切修道欲色无色界所有烦恼。及彼因同无明习气。皆悉微薄远离故。诸见缚者。于初地中见道时已断。如经是菩萨一切欲缚转复微薄。乃至诸见缚者先已除灭故。不复现集断于妄贪等者。断不善根使习气行。非断粗烦恼。粗烦恼前地已断。如经是菩萨住菩萨明地已无量百劫乃至彼诸善根转增明净故。真金喻者。示现不减秤两等住故。菩萨住明地。厌离世间胜于前地自在不失故。如经诸佛子譬如本真金乃至彼诸善根转增明净故。是菩萨忍辱安乐心转复明净者。他人加恶心能忍受善护他心。如经是菩萨忍辱安乐心转复明净故。加恶不改善护他心。分别示现作恶怀疑。现同伴侣爱语诲诱。如经同和心故。柔软心故。加恶不嗔闻骂不报不生忧恼。如经不嗔心故。不动心故。不浊心故。过去不憍慢自与善语。如经不高下我心故。心不悕望他人恭敬。如经众生所作不悕望心故。于所作事心不求报。如经有所施作不望报心故。非不实心作利益行。及无偏心等作利益故。如经不谄曲心故。微细隐覆垢心皆悉远离。如经不稠林心转复清净故

经曰。菩萨住是地中。多作忉利天王得法自在。能除众生贪欲等诸烦恼垢。以善方便力拔济众生诸欲淤泥。所作善业布施爱语利益同事。是诸福德皆不离念佛念法念僧念菩萨念菩萨行念波罗蜜念十地念不坏力念无畏念不共佛法。乃至不离念具足一切种一切智智。常生是心。我当于一切众生中为首为胜为大为妙为微妙为上为无上为导为将为师为尊。乃至为一切智智依止者。复从是念发精进行。以精进力故。于一念间得百千三昧。得见百千佛。知百千佛神力。谓动百千佛世界。能入百千佛世界。能照百千佛世界。能教化百千佛世界众生。能住寿百千劫。能知过去未来世各百千劫事。能善入百千法门。能变身为百千。于一一身能示百千菩萨以为眷属。若以愿力自在胜上菩萨愿力过于此数。示种种神通力。或身或光明或神通或眼或境界或音声或行或庄严或加或信或业。是诸神通乃至无量百千万亿那由他劫不可数知

论曰。此地摄报果愿智力果。如初地中释

十地经论明地第三卷之五十地经论焰地第四卷之六

        天亲菩萨造

        后魏北印度三藏菩提流支译

论曰。第四焰地依彼净三昧闻持如实智净显示故。此地差别有四分。一清净对治修行增长因分。二清净分。三对治修行增长分。四彼果分。清净对治修行增长因者。谓十法明入

经曰。尔时金刚藏菩萨言。诸佛子若菩萨得第三菩萨地具足清净明已欲得第四菩萨地者。当以十法明入得入第四地。何等为十。一思量众生界明入。二思量世界明入。三思量法界明入。四思量虚空界明入。五思量识界明入。六思量欲界明入。七思量色界明入。八思量无色界明入。九思量胜心决定信界明入。十思量大心决定信界明入。菩萨以此十法明入。得入第四地

论曰。法明入者。得证地智光明。依彼智明入如来所说法中。彼智名法明入。彼所说法正观思量如实知。二处顺行故。此思量有十种差别。思量分别众生界假名差别。如经思量众生界明入故。依住分别。如经思量世界明入故。染分别。如经思量法界明入故。无尽分别。如经思量虚空界明入故。染净依止分别。如经思量识界明入故。烦恼使染分别。如经思量欲界明入故。思量色界明入故。思量无色界明入故。净分别。如经思量胜心决定信界明入故。思量大心决定信界明入故。是中烦恼使染者谓三界。净者后二句。一依烦恼不染。二依不舍众生声闻等同不同义故。云何清净分。即于如来家转有势力故

经曰。诸佛子。是菩萨得菩萨焰地。即于如来家转有势力。得彼内法故。以十种法智教化成熟故。何等为十。一不退转心故。二于三宝中决定恭敬毕竟尽故。三分别观生灭行故。四分别观诸法自性不生故。五分别观世间成坏故。六分别观业有生故。七分别观世间涅槃故。八分别观众生世界业差别故。九分别观前际后际差别故。十分别观无所有尽故。诸佛子。菩萨如是。十种法智教化成熟。即于如来家转有势力。得彼内法故

论曰。云何即于如来家转有势力。依止多闻智究竟故。除灭智障摄胜故。此如是净胜如来家。是故名得彼内法。如来自身所有诸法。以是诸法显示如来。谓十种法智教化成熟故。此法明入同时得应知。彼复四种智教化故。名法智教化成熟。四种智者。一自住处毕竟智。如经不退转心故。二同敬三宝毕竟智。如经于三宝中决定恭敬毕竟尽故。三真如智。如经分别观生灭行故。分别观诸法自性不生故。四分别所说智。如经分别观世间成坏故。分别观业有生故。分别观世间涅槃故。分别观众生世界业差别故。分别观前际后际差别故。分别观无所有尽故。菩萨自住处者。谓大乘法。是中初二法者。不退转心于三宝中决定恭敬毕竟尽心。是初二智。自住处毕竟智。同敬三宝毕竟智。教化成熟故。次二法分别观生灭行。分别观诸法自性不生。是真如智。谓众生法无我观。如是次第分别应知。余者是分别所说智。彼复依烦恼染净故。随烦恼染。以何烦恼染。所有净。随所净。云何随烦恼染顺器世间故。如经分别观世间成坏故。众生世间生同因受生故。如经分别观业有生故。何者烦恼染谓世间。何者所有净。谓涅槃。如经分别观世间涅槃故。云何随所净。诸佛世界中教化众生自业成熟故。如经分别观众生世界业差别故。烦恼染及净。谓前际后际。如经分别观前际后际差别故。彼前际后际不损不益。如经分别观无所有尽故。于染法中不见一法可减。于净法中不见一法可增故。云何对治。修行增长有二种。一修行护烦恼染。二修行护小乘。何者护烦恼染。修行菩提分法故

经曰。诸佛子。是菩萨住此菩萨焰地已。观内身循身观。精勤一心除世间贪忧。观外身循身观。精勤一心除世间贪忧。观内外身循身观。精勤一心除世间贪忧。如是观内受外受内外受。如是观内心外心内外心。如是观内法循法观。精勤一心除世间贪忧。观外法循法观。精勤一心除世间贪忧。观内外法循法观。精勤一心除世间贪忧。是菩萨未生诸恶不善法为不生故。欲生勤精进发心正断。已生诸恶不善法为断故。欲生勤精进发心正断。未生诸善法为生故。欲生勤精进发心正行。已生诸善法为住不失修满增广故。欲生勤精进发心正行。是菩萨修行四如意分欲定断行成就。修如意分依止厌依止离依止灭回向于舍。精进定断行成就。修如意分依止厌依止离依止灭回向于舍。心定断行成就。修如意分依止厌依止离依止灭回向于舍。思惟定断行成就。修如意分依止厌依止离依止灭回向于舍。是菩萨修行信根。依止厌依止离依止灭回向于舍。修行精进根。依止厌依止离依止灭回向于舍。修行念根。依止厌依止离依止灭回向于舍。修行定根。依止厌依止离依止灭回向于舍。修行慧根。依止厌依止离依止灭回向于舍。是菩萨修行信力。依止厌依止离依止灭回向于舍。修行精进力。依止厌依止离依止灭回向于舍。修行念力。依止厌依止离依止灭回向于舍。修行定力。依止厌依止离依止灭回向于舍。修行慧力。依止厌依止离依止灭回向于舍。是菩萨修行念觉分。依止厌依止离依止灭回向于舍。修行择法觉分。依止厌依止离依止灭回向于舍。修行精进觉分。依止厌依止离依止灭回向于舍。修行喜觉分。依止厌依止离依止灭回向于舍。修行猗觉分。依止厌依止离依止灭回向于舍。修行定觉分。依止厌依止离依止灭回向于舍。修行舍觉分。依止厌依止离依止灭回向于舍。是菩萨修行正见。依止厌依止离依止灭回向于舍。修行正思惟。依止厌依止离依止灭回向于舍。修行正语。依止厌依止离依止灭回向于舍。修行正业。依止厌依止离依止灭回向于舍。修行正命。依止厌依止离依止灭回向于舍。修行正精进。依止厌依止离依止灭回向于舍。修行正念。依止厌依止离依止灭回向于舍。修行正定。依止厌依止离依止灭回向于舍

论曰。云何修行护小乘。不舍一切众生故。修行助菩提分法

经曰。是菩萨以不舍一切众生心故行。以本愿起淳至故。大悲为首故。大慈成就故观一切智智故。为起庄严佛国故。为具佛诸力无畏不共佛法相好庄严具足妙声故。为求上上胜行故。为随顺闻甚深佛法解脱故。为思惟大方便故行

论曰。不舍一切众生心者。此不舍众生心有四种。一始二益三悕四行。始者本愿故。如经以本愿起淳至故。益者怜愍故。如经大悲为首故。大慈成就故。悕者求佛智故。如经观一切智智故。行者修行故。修行有五种。一者修净土行。如经为起庄严佛国故。二者修起佛法行。如经为起如来力无畏不共佛法相好庄严具足妙声故。妙声者法蠡声故。三者修彼地方便无厌足行。如经为求上上胜行故。四者修入不退转地行。如经为随顺闻甚深佛法解脱故。五者修教化众生行。如经为思惟大方便故行。是名对治修行增长分。云何对治修行增长果分

经曰。是菩萨所有身见为首。我人众生寿命。阴界入我慢所起出没等事思惟多观。治故我故护故。贪着处故。是菩萨如是等事。皆悉断灭

论曰。对治修行增长果者。我知大知我修是我所修。如是等出没等事皆悉灭故。出者三昧起义故。没者三昧灭义故。彼复有五种。一本二起三行四护五过。是中本者依身见为本故。众生我慢法我慢如是差别。如经是菩萨所有身见为首。我人众生寿命阴界入我慢。所起出没等事故。起者起不正思惟。如经思惟故。行者令他知。如经多观故。护者数数观故。起我想故。受持故。如经治故我故护故。过者心安处诸事等。如经贪着处故。如是学行事中出没等皆悉远离。如经是菩萨如是等事皆悉断灭故。此是依烦恼染生远离果

经曰。是菩萨所有不可作业。如来所呵诸烦恼染。一切不行。所有可作业随顺菩萨行。如来所赞一切正修行

论曰。所有不可作业者。有二种事故不应作。一不尊敬如来佛不赞叹故。二畏恶名闻生烦恼故。如经是菩萨所有不可作业。乃至一切不行故。所有可作业者有二种事。是故应作。一见无恶名利随顺菩萨行故。二尊敬如来佛赞叹故。如经所有可作业乃至一切正修行故。此是依业染生远离果。是菩萨转复随所随所方便智所起修行助道分。如是如是成润益心。如是等四十句显示四种果。一者于胜功德中生增上欲心。二者彼说法尊中起报恩行。三者彼方便行中发勤精进。四者彼增上欲本心界满足。云何于胜功德中生增上欲心

经曰。是菩萨转复随所随所方便智所起修行助道分。如是如是成润益心软心调心安隐乐心不染心。转求上上胜行心。转求胜智心。救一切世间心。恭敬诸师随顺受教心。随所闻法修行心

论曰。是中随所随所方便智所起修行者不舍一切众生修行故。如前说。助道分者。谓一切菩提分法道支故。如是如是成润益心者。深欲爱敬故。彼润益心有三种相。一乐行胜。如经软心故。二三昧自在胜。如经调心故。三离过对治胜。如经安隐乐心故。彼过复有六种。一为食过。或说法中妒心过。此对治。如经不染心故。二少欲功德过。不乐多布施头陀等。此对治。如经转求上上胜行心故。三少欲智过。不好求胜智。此对治。如经转求胜智心故。四懈怠过。不勤化众生。此对治。如经救一切世间心故。五自见取过。于尊教法心不随顺。此对治。如经恭敬诸师随顺受教心故。六舍为首过。不随说行。此对治。如经随所闻法修行心故。如是成润益心。此十句是名于胜功德中生增上欲心果。云何彼说法尊中起报恩行

经曰。是菩萨如是成知恩心知报恩。心转柔和。同止安乐。直心软心。无稠林行。无有谄曲。无有我慢。善受教诲得说者意。如是善心成就。如是寂灭心成就。如是善寂灭心成就

论曰。彼说法尊中起报恩行。彼知恩心第二十句示现。是中彼成知恩心者。随顺行报恩行。报恩行者有九种。依尊起报恩心。如经知报恩故。依同法者。起将护心。如经心转柔和故。同止安乐故。依法行随顺受教发事能忍。如经直心故。软心故。依受用食于施主所自过不覆。不妄说己德。如经无稠林行故。无有谄曲故。依自胜功德不起高心。如经无有我慢故。依教正受语。如经善受教诲故。依教不颠倒受。如经得说者意故。菩萨如是于彼尊所修报恩行。成如是善心成就者。是对治修行增长故。如是寂灭心成就者。是初对治。修行增长力故。如是善寂灭心成就者彼果。前二句显是名彼说法尊中起报恩行果。云何彼方便行中发勤精进

经曰。是菩萨如是成不休息精进。不杂染精进。不退精进。广精进。无边精进。光明精进。无等精进。不坏精进。教化一切众生精进。善分别是道非道精进

论曰。彼方便行中发勤精进。成不休息精进。第三十句示现不休息精进有九种。一彼精进行平等流注。如经不杂染精进故。杂染者。共懈怠共染若过若不及故。二自乘不动。如经不退精进故。三广念。如经广精进故。四为无量众生作利益愿摄取故。如经无边精进故五常至心顺行。如经光明精进故。六修习过余精进。如经无等精进故。七一切魔烦恼行不能破坏。如经不坏精进故。八摄取故。如经教化一切众生精进故。九能断疑惑降伏他言。正修习故。如经善分别是道非道精进故。是名彼方便行中发勤精进果。云何彼本心界满足

经曰。是菩萨深心界转清净深心界不失。信解界转明利。生善根增长。远离世间垢浊。断诸疑心。无有疑网现前具足。成就喜乐。如来现前加。无量深心现前成就

论曰。彼心界转清净第四十句示现。心界者依菩提分心初句示现。心界清净有九种。一彼道心修行增益。如经深心界不失故。二于胜上证中转生决定心。如经信解界转明利故。三彼因对治增长。如经生善根增长故。四灭除诸障。如经远离世间垢浊故。五除此地秘密疑事。如经断诸疑心故。六以断疑故。于余处决定。如经无有疑网现前具足故七依胜乐行。如经成就喜乐故。八依化众生力。如经如来现前加故。九依现无量三昧心智障清净。如经无量心现前成就故。是名本心界满足果

经曰。是菩萨住菩萨焰地。已多见诸佛以大神通力大愿力故。见多百佛多千佛多百千佛多百千那由他佛多亿佛多百亿佛多千亿佛多百千亿佛多百千万亿那由他佛。以大神通力大愿力故是菩萨见诸佛时。以上心深心。供养恭敬尊重赞叹。衣服饮食卧具汤药。一切供具悉以奉施。以诸菩萨上妙乐具供养众僧。以此善根皆愿回向阿耨多罗三藐三菩提。于诸佛所生上恭敬专心听法。闻已受持随力修行。于诸佛法中出家修道。是菩萨深心决定信。解转复明净。是菩萨住此菩萨焰地无量百千万亿那由他劫深心决定信解平等清净。彼诸善根转胜明净。诸佛子。譬如本真金巧师炼治作庄严具。成就不失。余非庄严具真金所不能及。诸佛子。菩萨如是住此菩萨焰地中。彼诸善根成就不退下地善根所不能及。诸佛子。譬如摩尼宝珠生光。清净光轮能放光明。成就不坏。余宝光所不能夺。一切风飘雨渍水浇光明不灭。诸佛子。如是菩萨住此菩萨焰地中。下地菩萨所不能及。一切众魔及诸烦恼皆不能坏。是菩萨四摄法中同事偏胜。十波罗蜜中精进波罗蜜增上。余波罗蜜非不修习随力随分。诸佛子。是名略说菩萨第四菩萨焰地。若菩萨住此地中。多作须夜摩天王。所作自在破诸众生身见等事。方便善巧令诸众生住正见等事。所作善业布施爱语利益同事。是诸福德皆不离念佛念法念僧念菩萨念菩萨行念波罗蜜念十地念不坏力念无畏念不共佛法。乃至不离念具足一切种一切智智。常生是心。我当于一切众生中。为首为胜为大为妙为微妙为上为无上为导为将为师为尊乃至为一切智智依止者。复作是念。发精进行。以精进力故。于一念间得亿三昧。能见亿佛。能知亿佛神力。能动亿佛世界。能入亿佛世界。能照亿佛世界。能化亿佛世界众生。能住寿亿劫。能知过去未来世各亿劫事。能善入亿法门。能变身为亿。于一一身能示亿菩萨以为眷属。若以愿力自在胜上。菩萨愿力过于此数。示种种神通。或身或光明或神通或眼或境界或音声或行或庄严或加或信或业。是诸神通。乃至无量百千万亿那由他劫。不可数知

论曰。是菩萨深心决定信解平等清净。彼诸善根转胜明净者。如余净地诸菩萨。真金作庄严具譬者。喻阿含现作证智庄严。示现得证智故。如经譬如本真金巧师炼治作庄严具成就不失故。摩尼宝生光明喻者。彼证智法明摩尼宝光中。放阿含光明。入无量法门义光明智处普照示现。以是义故。此地释名为焰。如经诸佛子譬如摩尼宝珠生光。清净光轮能放光明成就不坏。余宝光明所不能夺故。生光者。有光明具足故。清净光轮者。光明圆满无垢故。所作自在者。破诸众生身见等事故。是中作者所作故。自在者能力故。余如前说应知

十地经论焰地卷之六十地经论难胜地第五卷之七

        天亲菩萨造

        后魏北印度三藏菩提流支译

论曰。第五地中分别有三。一胜慢对治。二不住道行胜。三彼果胜。云何胜慢对治

经曰。尔时金刚藏菩萨言。诸佛子。若菩萨得第四菩萨地善满诸行已。欲入第五菩萨地。当以十平等深净心得入第五地。何等为十。一过去佛法平等深净心故。二未来佛法平等深净心故。三现在佛法平等深净心故。四戒净平等深净心故。五心净平等深净心故。六除见疑悔净平等深净心故。七道非道智净平等深净心故。八行断智净平等深净心故。九思量一切菩提分法上上净平等深净心故。十化度一切众生净平等深净心故。诸佛子。菩萨以是十种平等深净心。得入第五菩萨地

论曰。胜慢对治者。谓十平等深净心。同念不退转心故。前已说解法慢对治。今此地中说身净分别慢对治。是中平等深净心者。于平等中心得清净。此深净心分别有十种。十种深净心者。是诸佛法及随顺诸佛法。彼分别应知。何者是诸佛法。谓三世力等。如经过去佛法平等深净心故。未来佛法平等深净心故。现在佛法平等深净心故。如是三世佛法力等已说。次说随顺诸佛法。彼诸佛法云何得成。因戒定智及化众生故。是中依戒净。如经戒净平等深净心故。依定净。如经心净平等深净心故。依智净。如经除见疑悔净平等深净心故。道非道智净平等深净心故。行断智净平等深净心故。思量一切菩提分法上上净平等深净心故。是中行断智者。思量一切菩提分法上上转胜故。依教化众生。如经化度一切众生净平等深净心故

经曰。诸佛子。是菩萨住第五菩萨地已。善修行菩提分法故。善深净心故。转求上胜行故。随顺如道行故。得大愿力故。以慈悲心不舍一切众生故。修习功德智慧行故。不休息诸行故。起方便善巧故。照见上上地故。正受如来加故。得念意去智力故。成就不退转心故

论曰。是中善修行菩提分法。乃至随顺如道行者。皆是正修诸行。善修行菩提分法者。第四菩萨地中修菩提分法善清净深心故。彼深净心等悕求胜行。如是不住道行胜破彼慢故。随顺如道行者。彼平等中深净心不退转心现成就故。随彼平等清净法住。如是菩萨深心安住名为随顺如道行故。是中随顺如道行有八种。一修习菩提心。如经得大愿力故。二不疲惓。如经以慈悲心不舍一切众生故。三得善根力。如经修习功德智慧行故。四不舍众行。如经不休息诸行故。五正修行。如经起方便善巧故。六无厌足。如经照见上上地故。七得他胜力。如经正受如来加故。八自身得胜力故。胜念等三慧故。如经得念意去智力故。成就不退转心故。去者修慧观。无障碍义故。云何不住道行胜。不住道行胜有二种观。一所知法中智清净胜。二利益众生勤方便胜。以是二法故。不住世间不住涅槃。云何所知法中智清净胜

经曰。是菩萨如实知。是苦圣谛是苦集谛是苦灭谛。如实知是至灭苦道圣谛。是菩萨善知世谛。善知第一义谛。善知相谛。善知差别谛。善知说成谛。善知事谛。善知生谛。善知尽无生智谛。善知令入道智谛。善知一切菩萨地次第成就谛。及善知集如来智谛。是菩萨随众生意令欢喜故。善知世谛。通达一切法一相故。善知第一义谛。觉法自相同相故。善知相谛。觉法差别故。善知差别谛。觉分别阴界入故。善知说成谛。觉身心苦恼故。善知事谛。觉诸道生相续故。善知生谛。毕竟灭一切热恼故。善知尽无生智谛。起不二行故。善知令入道智谛。正觉一切法相故。善知一切菩萨地次第成就谛。及善知集如来智谛。以信解力故。知非得一切究竟智知

论曰。彼所知法中智清净胜有二种。一实法分别如实知四谛。如经是菩萨如实知苦圣谛乃至如实知至灭苦道圣谛故。二化众生方便差别十谛差别方便智。如经是菩萨善知世谛乃至及善知集如来智谛故。是中实法分别者。有佛无佛苦集二谛果因差别体是妄想染故。灭道二谛果因差别体是净法故。化众生方便差别者。所化众生差别故。方便差别应知。所化众生有七种。小乘可化有六种。一为根未熟众生故。知世谛方便。二为根熟众生故。知第一义谛方便。三为疑惑深法众生故。知相谛方便。四为谬解迷惑深法众生故。知差别谛方便。五为离正念众生故。知说成谛方便。六为正见众生义故。知事谛方便。知生谛方便。知尽无生智谛方便。知令入道智谛方便。事谛等四谛苦谛等所摄。七为大乘可化众生故。善知一切菩萨地次第成就谛方便及善知集如来智谛方便。如经是菩萨随众生意令欢喜故。善知世谛乃至非得一切究竟智知故。是中菩萨地次第者。地地中间如自地次第入。应知一切生处身心受苦恼故。知事谛苦者。所有受者皆是苦事故。起不二行者一行故。正觉一切相者。五明论处善巧知故。信解力故。知者镜像观智力。非成就观智力故。如是所知法中智清净胜已说。云何利益众生勤方便胜。以知一切有为法虚妄相故。起怜愍众生念

经曰。是菩萨如是善起诸谛智已。如实知一切有为行。皆是虚妄诳诈诳惑凡夫。菩萨尔时复于众生中大悲转胜而现在前。及生大慈光明

论曰。是菩萨如是善起诸谛智已。乃至及生大慈光明者。是中妄想常等不相似无故虚。常作我想慢事故。妄世法尽坏故。诳世法牵取愚痴凡夫故。诈常等相无非有似有故。虚事中意正取我想慢事正取故。妄事是患世法利尽故。诳事牵心世法愚痴凡夫牵取故。诈事相现故言诳惑凡夫。此诸句义应知。凡夫者。依止彼正取我慢身。大悲大慈者怜愍彼众生。胜利益示现胜彼前地悲故。言大悲不住道行胜故。救众生方便智成就故。言大慈光明

经曰。是菩萨得如是智慧力。不舍一切众生。常求佛智慧。如实观一切有为行。先际后际。知诸众生从先际无明有爱故生。流转世间归五阴家。不能动发增长苦阴聚。是中无我无寿命无众生离我我所。皆如实知。后际亦如是。此无所有虚妄贪着分段。尽出有无。皆如实知

论曰。是菩萨得如是智慧力者如前说。不舍一切众生者。大悲大慈光明亦如前说求佛智慧者。救一切众生义故。如实观一切有为行。先际后际者。随彼大悲观示二种相。一如实观苦因缘集故。如经知诸众生从先际无明有爱故生。乃至有无皆如实知故。是中从先际无明有爱故生者。此显凡夫生非菩萨生。菩萨以善巧方便生。何故不言余因缘分。无明有爱是有分根本故。彼生者。说有三种众生欲求众生。妄梵行求众生有求众生。乃至依有顶五阴苦聚。是无我事是中自身无我。及彼无我事第一义故无。然后无我依命根力住。数数受生。众生身心相续。非常非断故。说有命有众生。破彼慢取意故。说无命无众生。远离能取所取我慢意故。说离我我所前际。以何因随所有众生随所有苦行。彼正观已。后际亦如是。随彼苦因。无明爱事尽者名灭。胜世间灭故。出者名道。无亦如实知。有亦如实知。是名一种大悲正观因缘集念如实苦故。次说第二种大悲正观深重苦无量世随逐及种种苦事

经曰。菩萨尔时作如是念。此诸凡夫甚为可怪。愚痴无智有无量无边阿僧祇身。已灭今灭当灭。如是尽灭已。不能于身生厌离想。转更增长机关苦身。常随世间漂流不能得返。归五阴舍不能舍离。不畏四大毒蛇。不能拔出我慢见箭。不能灭除贪恚痴火。不能破坏无明黑暗。不能干竭爱着大河。不求十力大圣导师。常入魔意稠林。于生死海中。常为诸恶觉观所转

论曰。大悲正观深重苦者。无量世随逐种种苦故。有无量无边阿僧祇身灭者。无量世随逐故。云何种种苦观。生苦故。彼集故。离彼灭道故。如是观老病死苦故。彼集故。离彼灭道故。是中此身依因缘有机关苦身者。生苦示现。常随世间漂流不能得返者。集爱示现。归五阴舍不能舍离者。离彼灭道示现。不畏四大毒蛇者。谓病苦彼增损生故。妄梵行求众生欲求众生受欲者。行恶行者。有求众生者。不能拔出我慢见箭示现。不能灭除贪恚痴火。不能破坏无明黑暗。不能干竭爱着大河。如是次第彼集示现趣无畏处。不求十力大圣导师。远离彼灭示现。常入魔意稠林。随顺怨道。远离彼道示现。于生死海中常为诸恶觉观所转者。一切三界心心数相虚妄分别应知。次说上大慈光明观行

经曰。我见彼诸众生受如是苦恼。孤独无救。无有依者。无有舍者。无有洲者。无究竟者。盲无目者。无明翳藏所缠。愚痴所覆。为此众生发如是心。唯我一人独无等侣。修集功德智慧助道。以是功德智慧助道资粮令一切众生得住毕竟清净。乃至使得佛十力无障碍智尽

论曰。彼受如是苦恼者。如前所说。孤独者。于彼苦中无救拔故。复次孤独者。于已受苦未受苦中故。言无救无依者。离善知识故。言无有舍者。离闻正法故。言无有洲者。离寂静思惟故。言无究竟者。离于正见故。言盲无目者。彼障诸旧烦恼及客尘烦恼常起。邪念不闻正法等故。言无明翳藏所缠愚痴所覆。唯我一人独无等侣者。显示勇猛胜事。修集功德智慧助道者。显示修行增长。依彼教化众生作人天因乃至涅槃因故。毕竟清净者。胜世间清净故。得佛十力者。降伏诸魔怨故。无障碍智尽者。胜声闻辟支佛净智故

经曰。菩萨如是善观起智慧力。所修诸善。发愿为救一切众生故。为一切众生作利益故。为一切众生得安乐故。愍念一切众生故为令一切众生无苦恼故。为令一切众生得解脱故。为摄一切众生故。为一切众生心清净故。为调伏一切众生故。发愿为一切众生令入大涅槃故

论曰。是中善观起智慧力者。以正观智调伏众生故。皆为救度一切众生者。拔一切苦恼故。救度有九种。一住不善众生令住善法。如经为一切众生作利益故。二住善法众生令得乐果。如经为一切众生得安乐故。三住贫乏众生与一切资生之具。如经愍念一切众生故。四住病苦及诸外缘所恼众生皆令除断。如经为令一切众生无苦恼故。五世间系闭众生令得出离。如经为令一切众生得解脱故。有四种相令诸外道信解正法。如经为摄一切众生故。疑惑众生善决定断疑。如经为一切众生心清净故。已住决定众生劝修三学。如经为调伏一切众生故。已住三学众生令得涅槃。如经发愿为一切众生令入大涅槃故。此九种救苦中。初二句为救未来。余句为救现在亦救未来。是名不住道修行胜。次说不住道修行胜果。有四种相。一摄功德胜。二修行胜。三教化众生胜。四起随顺世间智胜。云何摄功德胜。摄闻戒智胜故

经曰。是菩萨住此第五菩萨难胜地已。名为念者。不忘诸法故。名为意者。善决定智慧故。名为去者。知经书意次第故。名为有惭愧者。自护护彼故。名为坚心者。不舍持戒行故。名为觉者。善思惟是处非处故。名为随智者。不随他故。名为随慧者。善分别诸法章句是义非义故。名为得神通者。善修禅定故。名为善方便者。随世间法行故

论曰。摄闻胜者。摄闻思修慧胜故。云何慧胜。如经名为念者不忘诸法故。名为意者善决定智慧故。名为去者知经书意次第故。是中念者闻慧胜故。意者思慧胜故。去者修慧胜故。此诸句次第复有异释。闻持胜故名为念者。法智甚深胜故名为意者。意甚深智胜故名为去者。此略说成就二种善巧法善巧义善巧故。戒摄胜者有二种。忍辱柔和胜。及戒无缺胜。如经名为有惭愧者自护护彼故。名为坚心者不舍持戒行故。摄智胜者有五种。一者因缘集智无因颠倒因邪见对治。如经名为觉者善思惟是处非处故。二者证智魔事对治。如经名为随智者不随他故。三者知妄说智异说对治。善知是句义非句义杂句义。如经名为随慧者善分别诸法章句是义非义故。四者神力智邪归依行对治。如经名为得神通者善修禅定故。五者化众生智方便摄取故。如经名为善方便者。随世间法行故。是名摄功德胜。云何修行胜

经曰。名为无厌足者。善集功德行助道故。名为不休息精进者。常求智慧行助道故。名为无疲惓者。集大慈悲行助道故。名为常念佛法者。求佛十力四无所畏十八不共佛法故。名为善念修行者。起庄严佛国故。名为具足修行种种善业者。集三十二相八十种好故。名为常行精进者。求庄严佛身口意故。名为乐大恭敬法者。亲近供养一切菩萨及法师故。名为善起愿自在者。大方便善入世间故。名为日夜远离余心者。常乐教化一切众生故

论曰。是中修行胜有十种。一增长因行。如经名为无厌足者善集功德行助道故。二依止因行。如经名为不休息精进者。常求智慧行助道故。三化众生不疲惓行。如经名为无疲惓者集大慈悲行助道故。四起佛法行。如经名为常念佛法者求佛十力四无所畏十八不共佛法故。五起净佛国土行。如经名为善念修行者起庄严佛国故。云何庄严。无烦恼染得坚固智慧。众生住在其中及佛法庄严故。六依佛法身起行。如经名为具足修行种种善业者集三十二相八十种好故。七依佛所作起行。如经名为常行精进者求庄严佛身口意故。八敬重法行。如经名为乐大恭敬法者亲近供养一切菩萨及法师故。九愿取有行。如经名为善起愿自在者大方便善入世间故。十离小乘心行。如经名为日夜远离余心者常乐教化一切众生故。是名修行胜。云何教化众生胜

经曰。是菩萨成就如是行时。以布施教化众生。又以爱语利益同事教化众生。又以色身示现教化众生。又以说法教化众生。又广示菩萨行神通事教化众生。又说诸佛大事教化众生。又示世间过恶教化众生。又说诸佛智慧利益教化众生。又现大神通庄严相。亦说种种行教化众生。是菩萨如是教化众生。方便成就。身心常趣佛智而不退失。诸善根行常勤修行转胜道故

论曰。是中教化众生胜者。以四摄法教化。如经是菩萨成就如是行。时以布施教化众生。又以爱语利益同事教化众生故。为同事随顺众生应化自众。如经又以色身示现教化众生故。为疑惑众生可说法成就。如经又以说法教化众生故。为于菩提无方便众生。如经又广示菩萨行神通事教化众生故。为于大乘疲惓众生。如经又说诸佛大事教化众生故。为乐世间众生。如经又示世间过恶教化众生故。为不信大乘众生。如经又说诸佛智慧利益教化众生故。为无智众生现神通庄严。示种种行。以一身示无量身如是事令生决定信。如经又现大神通庄严相。亦说种种行教化众生故。是菩萨如是教化众生方便成就者如前说。身心常趣佛智者。为教化众生求胜力故。而不退失诸善根行者。随所得功德智慧皆不退失故。常勤修行转胜道者。彼所修诸行欲令增胜故。是名教化众生胜。云何起随顺世间智胜染障对治

经曰。是菩萨为利益众生故。善知世间所有书论印算数石性等论。治诸病方。所谓治干枯病。治颠狂病。治鬼着病。治蛊毒病等。损害众生者皆悉能治。谓咒药等。作论经书伎乐戏笑欢娱等事。国土城邑聚落室宅。河泉池流园观花果。药草林树等。金银琉璃摩尼真珠珊瑚琥珀车磲马瑙诸宝性等。日月星宿地动梦想吉凶入等遍身诸相。持戒行处禅定神通四无量心四无色定。凡诸不恼众生事。能利益安乐众生事。怜愍众生故出渐令信入无上佛法故

论曰。随顺世间智者。染障对治。如经是菩萨为利益众生故。善知世间所有一切书论等。是中书等有四种障对治。四种障者。一所用事中忘障。取与寄付闻法思义。作不作事。已作未作事。应作不应作事。此对治故书。二邪见软智障。以因论声论对治此二故论。三所取物不守护障。此对治故印。四取与生疑障。此对治故算数。数者一一为二。二二为四。如是等。算者一纵十横。如是等。石性等论者。贫事障对治故。治诸病方者。四大不调众生毒相病障对治故。干枯颠狂病者。四大不调相故。鬼着病等。是众生相。蛊毒病者。亦四大不调。亦众生相病因及死因。此对治谓咒药等。日月星宿地动梦想吉凶入等。遍身诸相者。是中唯有日月等相见故。日等曜等摄故。入者入八业果故。遍身诸相者。爱不爱果行故。持戒行处等者。是中持戒行处。禅定神通四无量心四无色定等。如是次第破戒染。贪欲染。邪归依染。妄行功德染。妄修解脱染。如是次第说。如经石性等论乃至咒药等故。作论经书伎乐戏笑欢娱等者。忧恼障对治故。国土城邑乃至药草林树等者。此不喜乐障对治故。金银琉璃乃至诸宝性等者。系闭等障此对治故。日月星宿乃至遍身诸相等者。所得报分过作恶因障此对治故。持戒行处乃至无色定者五种染对治。何者五种染。破戒染乃至妄修解脱染故。此起世间智具四种相。一异障中无障故。如经凡诸不恼众生事者。二与无过乐。如经能利益安乐众生事故。三发起清净。如经怜愍众生故出。四所用清净。如经渐令信入无上佛法故

经曰。诸佛子。是菩萨住此菩萨难胜地已多见诸佛。以大神通力大愿力故。见多百佛多千佛多百千佛多百千那由他佛多亿佛多百亿佛多千亿佛多百千亿佛多百千万亿那由他佛。以大神通力大愿力故。是菩萨见诸佛时。以上心深心供养恭敬尊重赞叹。衣服饮食卧具汤药一切供具悉以奉施。以诸菩萨上妙乐具供养众僧。以此善根皆愿回向阿耨多罗三藐三菩提。于诸佛所生上恭敬专心听法。闻已受持随力修行。于佛法中出家。得出家已于诸佛所听受经法而为法师说法利益。得转胜多闻陀罗尼成就法师。是菩萨尔时住此菩萨难胜地中。无量百劫彼诸善根转胜明净。无量千劫无量百千劫无量百千那由他劫无量亿劫。无量百亿劫无量千亿劫无量百千亿劫无量百千万亿那由他劫。彼诸善根转胜明静。是菩萨成就如是教化众生法。诸佛子。譬如本真金以车磲摩莹光色转胜明净诸佛子。菩萨住此菩萨难胜地中。彼诸善根以方便智思量力故转胜明净。彼智慧善根成就不退思量转胜。下地善根所不能及。诸佛子。譬如日月星宿诸天宫殿光轮圆满成就不坏风不能动。如是诸佛子。菩萨住此菩萨难胜地中。彼诸善根以方便智思量力故成就不退。一切声闻辟支佛世间善根所不能及。是菩萨十波罗蜜中禅波罗蜜增上。余波罗蜜非不修习随力随分。诸佛子。是名略说菩萨第五菩萨难胜地。若菩萨住此地中。多作兜率陀天王。所作自在摧伏一切外道邪见。能令众生住实谛中。所作善业布施爱语利益同事。是诸福德皆不离念佛念法念僧念菩萨念菩萨行念波罗蜜念十地念不坏力念无畏念不共佛法。乃至不离念一切种一切智智。常生是心。我当于一切众生中为首为胜为大为妙为微妙为上为无上为导为将为师为尊。乃至为一切智依止者。复从是念发精进行。以精进力故。于一念间得千亿三昧。见千亿佛。知千亿佛神力。能动千亿佛世界。能入千亿佛世界。能照千亿佛世界。能化千亿佛世界众生。能住寿千亿劫。能知过去未来世各千亿劫事。能善入千亿法门。能变身为千亿。于一一身能示千亿菩萨以为眷属。若以愿力自在胜上菩萨愿力过于此数示种种神通。或身或光明或神通或眼或境界或音声或行或庄严或加或信或业。是诸神通乃至无量百千万亿那由他劫。不可数知

论曰。得转胜多闻陀罗尼成就法师者。非得义陀罗尼以平等清净心甚难得故。又乐出世间智现世间智最难故。得闻持陀罗尼。此地智光明真如事示现。如经诸佛子譬如本真金乃至下地善根所不能及故。日月光轮者。依阿含增长智慧光明胜于前地智故。如经诸佛子譬如日月星宿。乃至世间善根所不能及故

十地经论难胜地第五卷之七十地经论现前地第六卷之八

        天亲菩萨造

        后魏北印度三藏菩提流支译

论曰。如五地中三分差别胜慢对治不住道行胜及彼果胜。第六地亦如是。应知转胜故。云何胜。第四地中已说众生我慢解法慢对治。第五地中已说身净分别慢对治。今第六地中说取染。净法分别慢对治。以十平等法故

经曰。尔时金刚藏菩萨言。诸佛子。若菩萨已善具足第五地道。欲入第六菩萨地。当以十平等法得入第六地。何等为十。一者一切法无相平等故。二者一切法无想平等故。三者一切法无生平等故。四一切法无成平等故。五一切法寂静平等故。六一切法本净平等故。七一切法无戏论平等故。八一切法无取舍平等故。九一切法如幻梦影响水中月镜中像焰化平等故。十一切法有无不二平等故。是菩萨如是观一切法相除垢故。随顺故。无分别故。得入第六菩萨现前地。得明利顺忍未得无生法忍

论曰。取染净法分别慢对治者。谓十平等法。是中一切法无相乃至一切有无不二平等者。是十二入一切法自性无相平等故。复次相分别对治有九种。一十二入自相想。如经一切法无想平等故。二念展转行相。如经一切法无生平等故。三生展转行相。如经一切法无成平等故。四染相。如经一切法寂静平等故。五净相。如经一切法本净平等故。六分别相。如经一切法无戏论平等故。七出没相。如经一切法无取舍平等故。八我非有相。如经一切法如幻梦影响水中月镜中像焰化平等故。九成坏相。如经一切法有无不二平等故。除垢者远离障垢故。随顺者随顺平等真如法故。无分别者。不生分别相故。明利者。微细慢对治故。前二地中粗中慢对治故。得软中忍顺者。随顺无生法忍故。未得无生法忍者。此忍顺无生法忍非即无生忍故。是名取染净法分别慢对治。云何不住道行胜

经曰。是菩萨如是观一切法相随顺得至。复以胜大悲为首故。大悲增上故。令大悲满足故。观世间生灭故

论曰。是菩萨如是观一切法相随顺得至者。得至不住道行胜故。不住道行胜者。不舍众生过去现在未来大悲摄胜故。一切所知法中智净故。一切种微细因缘集观故。不住世间涅槃故。如经复以大悲为首。乃至观世间生灭故

经曰。是菩萨观世间生灭已。作是念。世间所有受身生处差别皆以贪着我故。若离着我则无世间生处。菩萨复作是念。此诸凡夫愚痴所盲贪着于我。无智闇障常求有无。恒随邪念妄行邪道。集起妄行罪行福行不动行。以是行故起心种子。有漏有取想故。起未来生老死身复生后有。业为地无明覆蔽。爱水为润我心溉灌。种种见网令得增长。生名色牙生已增长。名色增长已成诸根。诸根成已迭互相对生触。触相对生受。受后所悕生爱。以有爱故生取。取增长已生有。有成已生五阴身。五阴身增长已。于五道中渐渐衰变名为老。衰老变灭名为死。死后生诸热恼。因热恼故生一切忧悲苦恼聚。是因缘集。无有集者自然而集。无有灭者自然而灭。是菩萨如是随顺观因缘集

论曰。是中世间所有受身生处差别者。五道中所有生死差别是名世间所有差别。此因缘集有三种观门应知。一成答相差别。二第一义谛差别。三世谛差别。云何成差别。初明唯因缘集释无我义。成一切世间所有受身生处。皆以贪着我故。若离着我则无世间生处。即无我义成。若第一义中实有我相者。着我之心即是第一义智。不应在世间受身生处生。又复若第一义中实有我相者。若离着我则应常生世间。显示此义。如经世间所有受身生处差别皆以贪着我故。若离着我则无世间生处故。云何答差别。若实无我云何着我。此中应有是难。即自答言。愚痴所盲贪着于我。此示现如经菩萨复作是念。此诸凡夫愚痴所盲贪着于我故。如是实无有我有。何次第贪着于我。得有生间受身生处。成此示现。如经无智闇障常求有无故。如是答难差别。是中无智有无者悕求常断。此示无明有爱是二有支根本故。恒随邪念妄行邪道集起妄行罪行福行不动行。恒随邪念者。示无明因故。妄行邪道者。示于解脱处不正行故。集起妄行者。示菩萨胜义故。菩萨虽行于有不名妄行。以是行故起心种子。有漏有取想乃至随顺观因缘集。是中起心种子者。示生老死体性。复生后有者。随顺摄取成就罪福等行业为地故。前说无智闇障无明覆蔽故。常求有无爱水为润故。如是往如是生心我是我所我我想是慢我生不生如是等种种见网。自然而灭者性自灭故。非智缘灭。如是答难因缘集释无我义成已。云何相差别。若因缘无我以何相住因缘集行

经曰。是菩萨复作是念。不如实知诸谛第一义故名为无明。无明所作业果是名为行。依行有初心识。与识共生有四受阴名为名色。名色增长有六入。根尘识三事和合生有漏触。触共生故有受。受染着故名爱。爱增长故名取。从取起有漏业名有。有业有果报名生。生阴增长衰变名为老。老已阴坏名为死。死别离时愚人贪着心热名为忧发声啼哭名为悲。五根相对名为苦。意根相对名为忧。忧苦转多名为恼。如是但有苦树增长无有作者。菩萨作是念。若有作者则有作事。若无作者则无作事。第一义中无有作者无有作事

论曰。是中无明所作业果者。所谓名色于中识者彼依止故。名色与识共生故。识名色迭互相依故。若无作者于中分别作事亦无。此说因缘集有分。自体无作事故。是名有分次第因缘集观。应知云何第一义谛差别。如是证第一义谛则得解脱彼观故

经曰。是菩萨作是念三界虚妄但是一心作

论曰。但是一心作者。一切三界唯心转故。云何世谛差别。随顺观世谛即入第一义谛。此观有六种。一何者是染染依止观。二因观。三摄过观。四护过观。五不厌厌观。六深观。是中染依止观者。因缘有分依止一心故

经曰。如来所说十二因缘分皆依一心。所以者何随事贪欲共心生。即是识事即是行。行诳心故名无明。无明共心生名名色。名色增长名六入。六入分名触。触共生名受。受已无厌足名爱。爱摄不舍名取。此有分和合生有。有所起名生。生变熟名老。老坏名死

论曰。此是二谛差别。一心杂染和合因缘集观。因观者有二种。一他因观。二自因观。云何他因观

经曰。是中无明有二种作。一者缘中痴令众生惑。二者与行作因。行亦有二种作。一者生未来世果报。二者与识作因。识亦有二种作。一者能令有相续。二者与名色作因。名色亦有二种作。一者互相助成。二者与六入作因。六入亦有二种作。一者能缘六尘。二者与触作因。触亦有二种作。一者能触所缘。二者与受作因。受亦有二种作。一者觉憎爱等事。二者与爱作因。爱亦有二种作。一者于可染中生贪心。二者与取作因。取亦有二种作。一者增长烦恼染缚。二者与有作因。有亦有二种作。一者能于余道中生。二者与生作因。生亦有二种作。一者增长五阴。二者与老作因。老亦有二种作。一者令诸根熟。二者与死作因。死亦有二种作。一者坏五阴身。二者以不见知故而令相续不绝

论曰。是中坏五阴身以不见知而令相续不绝者。坏五阴能作后生因。以不见知故能作后生因。是名他因观。云何自因观。无明等自生因观缘事故。何者是无明等因缘行不断助成故

经曰。是中无明缘行者。无明因缘令行不断助成行故。行缘识者。行因缘令识不断助成识故。识缘名色者。识因缘令名色不断助成名色故。名色缘六入者。名色因缘令六入不断助成六入故。六入缘触者。六入因缘令触不断助成触故。触缘受者。触因缘令受不断助成受故。受缘爱者。受因缘令爱不断助成爱故。爱缘取者。爱因缘令取不断助成取故。取缘有者。取因缘令有不断助成有故。有缘生者。有因缘令生不断助成生故。生缘老死者。生因缘令老死不断助成老死故无明灭故则行灭。无明因缘无行灭不助成故。行灭故则识灭。行因缘无识灭不助成故。识灭故则名色灭。识因缘无名色灭不助成故。名色灭故则六入灭。名色因缘无六入灭不助成故。六入灭故则触灭。六入因缘无触灭不助成故。触灭故则受灭。触因缘无受灭不助成故。受灭故则爱灭。受因缘无爱灭不助成故。爱灭故则取灭。爱因缘无取灭不助成故。取灭故则有灭。取因缘无有灭不助成故。有灭故则生灭。有因缘无生灭不助成故。生灭故则老死灭。生因缘无老死灭不助成故

论曰。是中无明缘行无明因缘令行不断助成行故者。无明有二种。一子时二果时。是中子时者。令行不断有二种义故。缘事示现。如是余因缘分自生因二种义缘事应知。自因观者。不相舍离观故。离前支无后支观故。不离无明则成行观。若不离无明有行者。不应言无明缘行。若离无明有行成者异则不成。是故偈言

  众缘所生法　　是则不即因
  亦复不异因　　非断亦非常

自生因缘观如前说。无明有二种。一子时二果时。行乃至老死亦如是。先际后际灭中际亦无是故不说。云何摄过观。所谓三道摄苦因苦果故

经曰。是中无明爱取三分不断是烦恼道。行有二分不断是业道。余因缘分不断是苦道。先际后际相续不断故。是三道不断。如是三道离我我所。但有生灭故犹如束竹

论曰。云何护过观。若言因缘生者。分别有三种过。一者一切身一时生过。何以故。无异因故。二者自业无受报过。何以故。无作者故。三者失业过。何以故。未受果业已灭故。此三种过以见过去世等异因答故。受生报等差别故

经曰。无明缘行者。是见过去世事。识名色六入触受是见现在世事。爱取有生老死。是见未来世事。于是见有三世转。无明灭故诸行灭。名为断因缘相续说

论曰。无明缘行即是见过去世事者。现在生是过去作故。现在果即是当来即是见过去世因义。识乃至受是见现在世事者。过去世中随所有业彼业得现在识等果报。复能得未来果报。爱取有是见未来世事者。复有生一往定故。于是见有三世转者。复有后世生转故。此说何义。有三种义故。过去业不得报。或有未作或已作未得报。或得对治断故。是中无明缘行是作示现。行缘识乃至触受。此作已得报示现。爱取有不断此不得对治示现。若断爱取虽有作业则无明缘行不能生有。是故诸业有已作未作。有得果未得果。有已断未断。若如是则无一切身一时生过。若尔非一切业即当来受。亦非不受亦非一时。若自作业果报不失。非他身受故。若如是则无自业不受报过他不作故。离彼三事业。定得果不失。若如是则无失业过。是名护三种过示现。云何不厌厌观。厌种种微苦分别。所有受皆是苦故。及厌种种粗苦故

经曰。十二因缘分说名三苦。是中无明行识名色六入名为行苦。触受名为苦苦。余因缘分名为坏苦。无明灭故行灭乃至生灭故老死灭。名为断三苦相续说

论曰。云何深观

经曰。无明因缘行生因缘能生行余亦如是。无明灭行灭行无余亦如是。无明因缘行是生缚说余亦如是。无明灭行灭是灭缚说余亦如是。无明因缘行是随顺有观说余亦如是。无明灭行灭是随顺无所有尽观说余亦如是

论曰。深观者有四种。一者有分非他作自因生故。二者非自作缘生故。如经无明因缘行生因缘能生行余亦如是。无明灭行灭行无余亦如是故。三者非二作但随顺生故。无知者故。作时不住故。如经无明因缘行是生缚说余亦如是。无明灭行灭是灭缚说余亦如是故。四者非无因作随顺有故。如经无明因缘行是随顺有观说余亦如是。无明灭行灭是随顺无所有尽观说余亦如是故。若无因生生应常生非不生以无定因故亦可恒不生。何以故。无因生故。此非佛法所乐。若尔随顺有观有因非无因故。若无因不得言随顺有。是名十种因缘集观相谛差别观已说

经曰。是菩萨如是十种逆顺观因缘集法。所谓因缘分次第故。一心所摄故。自业成故。不相舍离故。三道不断故。观先后际故。三苦集故。因缘生故。因缘生灭缚故。随顺有尽观故

论曰。复有二种异观。一大悲随顺观。二一切相智分别观。大悲随顺观者有四种。一愚痴颠倒。二余处求解脱。三异道求解脱。四求异解脱。云何愚痴颠倒。随所著处愚痴及颠倒此事观故。以着我故。一切处受生远离我故。则无有生。云何愚痴无明闇故。如经是菩萨观世间生灭已作是念世间所有受身生处差别皆以贪着我故。若离着我则无世间生处故。愚痴所盲贪着于我。如是颠倒及有相支中疑惑颠倒。如经菩萨复作是念此诸凡夫愚痴所盲贪着于我无智闇障尝求有无如是等故。云何余处求解脱。是凡夫如是愚痴颠倒常应于阿梨耶识及阿陀那识中求解脱。乃于余处我我所中求解脱。此对治。如经是菩萨作是念三界虚妄但是一心作乃至老坏名死故。云何异道求解脱。于颠倒因中求解脱。颠倒因有三种。性因自在天因苦行因及无因。不应如是求。何以故。因缘有支二种业能起因缘事故。如经是中无明有二种作。一者缘中痴令众生惑。二者与行作因如是等故。自生因故。如经是中无明缘行者无明因缘令行不断助成行故。如是等故。烦恼业妄想因故。非乐因故。如经是中无明爱取三分不断是烦恼道。如是等故。先中际因故。及中后际因故。中际前后二际故。如经是中无明因缘行者是见过去世事。如是等故。若无如是事则种种众生亦无。云何求异解脱真解脱者有四种相。离一切苦相。无为相。远离染相。出世间相。彼诸行苦事随逐乃至无色有缚。如经十二因缘分说名三苦。无明行乃至六入名为行苦。如是等故。如是因缘生故。如经是中无明因缘行因缘能生行余亦如是等故。如是复染生缚。如经是中无明缘行是生缚说余亦如是等故。如是随顺有求无色有解脱。如经无明因缘行随顺有观说余亦如是等故。如是大悲随顺观因缘集已说。一切相智分别观者。是中有九种。一染净分别观。着我慢离我慢染净故。如经是菩萨观世间生灭已作是念世间所有受身生处差别皆以贪着我故若离着我则无世间生处故。二依止观。此因缘集依何等法。如经是菩萨复作是念不如实知诸谛第一义故名为无明。如是等故。三方便观。因缘有支二种业能起因缘事故。如经是中无明有二种作。一者缘中痴令众生惑。二者与行作因如是等故。四因缘相观。有支无作故。如经是中无明缘行无明因缘令行不断助成行故。如是等故。五入谛观。三道苦集谛故。如经是中无明爱取三分不断是烦恼道。行有二分不断是业道。余因缘分不断是苦道故。六力无力信入依观。先中后际化胜故。如经无明缘行者是见过去世事。如是等故。七增上慢非增上慢信入观。不如实知微苦我慢故。如经是中无明行乃至六入名为行苦。如是等故。八无始观。中际因缘生故。后际生随顺缚故。如经无明因缘行因缘能生行余亦如是无明因缘行是生缚说余亦如是故。九种种观。随顺有观故。欲色无色爱等。如经无明因缘行随顺有观说余亦如是故。如是不住道行胜已说。次说彼果胜有五种相。一得对治行胜及离障胜。二得修行胜。三得三昧胜。四得不坏心胜。五得自在力胜。云何得对治行胜。谓三解脱门

经曰。是菩萨如是十种观因缘集已。无我无寿命无众生自性空离作者受者。如是观时空解脱门现前生。是菩萨观彼有支自性灭故。常解脱现前。见因缘处无少法相可生。如是不见少法相故。无相解脱门现前生。是菩萨如是入空入无相不生愿乐。唯除大悲为首教化众生。如是无愿解脱门现前生。是菩萨修行是三解脱门。离彼我相离作者受者相。离有无相

论曰。是中空解脱门有三种相说。一见众生无我。二见法无我。三彼二作无见无作者故。如经是菩萨如是十种观因缘集已。无我无寿命无众生自性空离作者受者。如是观时空解脱门现前生故。见众生无我者。无我无寿命无众生。此句示现见法无我者自性空。此句示现彼二作无者。见众生及法无作事等。以无作者作事亦无。不见作者故。离作者受者。此句示现无相解脱门。亦三种相说。一灭障。二得对治。三念相不行。如经是菩萨观彼有支自性灭故。常解脱现前。见因缘处无少法相可生。如是不见少法相故。无相解脱门现前生。是中灭障者。观彼有支自性灭故。此句示现得对治者常解脱现前。此句示现念相不行者。见因缘处无少法相可生。此句示现无愿解脱门亦三种相说。一依止二体三胜。如经是菩萨如是入空入无相不生愿乐唯除大悲为首教化众生如是无愿解脱门现前生故。是中入空入无相是名依止。以依止入空入无相故。能成无愿不生愿乐不生愿乐是名无愿体。大悲为首教化众生者是名为胜。声闻亦有不生愿乐。无愿体远离大悲不乐教化众生故。灭障胜者离三种相故。如经是菩萨修行是三解脱门离彼我相离作者受者相。离有无相故如是次第于五地中远离平等深净心故四地中远离出没等相。此六地中远离法平等故。云何得修行胜

经曰。是菩萨大悲转增以重悲故。勤行精进未满助菩提分法欲令满足。菩萨作是念。有为和合故。行离和合故。不行众缘具故。行不具故不行。唯我知有为法多过。不应具和合因缘。亦不毕竟灭有为法。为教化众生故。诸佛子。菩萨如是知有为法多过。离自性不生不灭自性观。是菩萨作如是观已。起大悲故。不舍一切众生故。即时得无障碍智门现前。名般若波罗蜜行光明现前。是菩萨成就如是般若波罗蜜行光明现前照已。为满助菩提分法因缘而不与有为法共住。观有为法性寂灭相。亦不住其中。欲具足无上菩提分法故

论曰。得修行胜者有二种修行。一发勇猛修行。二起丈夫志修行。发勇猛修行者。知有为法多过。远离生业烦恼同缚。作胜利益众生。如经是菩萨大悲转增以重悲故。勤行精进未满助菩提分法欲令满足。菩萨作是念。有为和合故。行离和合故。不行众缘具故。行不具故不行。唯我知有为法多过。不应具和合因缘。亦不毕竟灭有为法。为教化众生故。起丈夫志修行者。厌对观见多过观故。灭对故。自性同相无观故。如经诸佛子菩萨如是知有为法多过离自性不生不灭自性观故。修行胜者。智及大悲胜随顺故。依不住道行无障碍智门现前。般若波罗蜜行光明现前。知有为法及涅槃平等证故。彼不共住故。彼助道行不满故。如经是菩萨作如是观已起大悲故。不舍一切众生故。即时得无障碍智门现前名般若波罗蜜行光明现前。是菩萨成就如是般若波罗蜜行光明现前照已。为满助菩提分法因缘而不与有为法共住。观有为法性寂灭相亦不住其中。欲具足无上菩提分法故。无障碍智者。谓如来智。然此未成就名为光明现前。云何得三昧胜。有十空三昧门同为上首。及彼眷属故

经曰。是菩萨住此菩萨现前地中。得信空三昧性空三昧第一义空三昧第一空三昧大空三昧合空三昧起空三昧如实不分别空三昧不舍空三昧得离不离空三昧。是菩萨得如是等十空三昧门上首。百千万空三昧门现在前。如是十无相三昧门上首。百千万无相三昧门现在前。如是十无愿三昧门上首。百千万无愿三昧门现在前

论曰。此空三昧有四种差别。一观二不放逸三得增上四因事。除第四三昧有五三昧。是名为观。一观众生无我。如经得信空三昧故。二观法无我。如经性空三昧故。三取彼空观。如经第一义空三昧故。四依彼阿黎耶识观。如经大空三昧故。五观转识。如经合空三昧故。不放逸者。第四三昧分别善修行故。修行无厌足故。如经第一空三昧故。得增上者。第七三昧得增上功德。如经起空三昧故。因事者。余三种三昧智障净因事。如经如实不分别空三昧故。教化众生因事。如经不舍空三昧故。愿取有因事。如经得离不离空三昧故。如是愿取有远离烦恼染而随顺诸有故。名离不离。云何得不坏心胜

经曰。是菩萨住菩萨现前地中。复转满足不坏心决定心真心深心不退转心不休息心净心无边心求智心满足方便智行心

论曰。不坏心者。坚固不退故。是不坏心有九种。一信观不坏。如经决定心故。二堪受调柔不坏。如经真心故。三于密处不惊怖不坏。如经深心故。四自乘不动不坏。如经不退转心故。五发精进不坏。如经不休息心故。六离嫉妒破戒垢不坏。如经净心故。七广利益众生不坏。如经无边心故。八求上胜解脱不坏。如经求智心故。九化众生行不坏。如经满足方便智行心故。云何得自在力胜

经曰。是菩萨此诸菩萨心随顺成就趣向阿耨多罗三藐三菩提。不退转精进成一切外道异论不能动故。随顺成入诸智地故。远离成转声闻辟支佛地故。一向成决定趣佛智故。不退成一切诸魔烦恼不能坏故。坚住成善住菩萨智慧明故。正住成善修空无相无愿法行故。助正行成方便智观故。不舍行成集助菩提分法故。是菩萨住菩萨现前地中。般若波罗蜜行增上成就。得第三利顺忍。随顺如实法无有违逆故

论曰。是菩萨此诸菩萨心随顺成就趣向阿耨多罗三藐三菩提者。得般若波罗蜜行力胜能深入故。是中力胜有九种。一能降伏他力。如经不退转精进成一切外道异论不能动故。二能断疑力。如经随顺成入诸智地故。三自乘不动力。如经远离成转声闻辟支佛地故。四密处决定信力。如经一向成决定趣佛智故。五不散坏力。如经不退成一切诸魔烦恼不能坏故。六依烦恼障净对治坚固力。如经坚住成善住菩萨智慧明故。七广对治力。如经正住成善修空无相无愿法行故。八化众生力。如经助正行成方便智观故。九智障净力。如经不舍行成集助菩提分法故。是菩萨住菩萨现前地中。般若波罗蜜行增上成就。得第三利顺忍。随顺如实法无有违逆。是诸法者如上所说力胜所摄故

经曰。诸佛子。是菩萨住此菩萨现前地已多见诸佛以大神通力大愿力故。见多百佛多千佛多百千佛多百千那由他佛多亿佛多百亿佛多千亿佛多百千亿佛多百千万亿那由他佛。以大神通力大愿力故。是菩萨见诸佛时。以上心深心供养恭敬尊重赞叹。衣服饮食卧具汤药一切供具悉以奉施。以诸菩萨上妙乐具供养众僧。以此善根皆愿回向阿耨多罗三藐三菩提。于诸佛所生上恭敬。专心听法闻已受持。闻受持已得如实三昧智慧光明随顺修行行已忆持。是菩萨智慧转胜。复得诸佛法藏。是菩萨住此菩萨现前地中。于无量百劫。彼诸善根转胜明净。无量千劫无量百千劫无量百千那由他劫无量亿劫无量百亿劫无量千亿劫无量百千亿劫无量百千亿那由他劫。彼诸善根转胜明净。诸佛子。譬如本真金以琉璃磨莹光色转胜明净。诸佛子菩萨如是。住此菩萨现前地中。彼诸善根方便智观转胜明净。转转寂灭成就不坏。诸佛子。譬如月光明轮照众生身令得清凉。四种风吹所不能坏。诸佛子。菩萨如是住此菩萨现前地中。彼诸善根能灭无量百千万亿那由他众生烦恼之火。四种魔道所不能坏。是菩萨十波罗蜜中般若波罗蜜增上。余波罗蜜非不修习随力随分。诸佛子。是名略说菩萨第六菩萨现前地。若菩萨住此地中。多作化乐天王。所作自在善巧灭除众生我慢。善转众生我慢法心。所作善业布施爱语利益同事。是诸福德皆不离念佛念法念僧念菩萨念菩萨行念波罗蜜念十地念不坏力念无畏念不共佛法。乃至不离念一切种一切智智。常生是心。我当于一切众生中为首为胜为大为妙为微妙为上为无上为导为将为师为尊。乃至为一切智智依止者。复从是念发精进行。以精进力故。于一念间得百千亿三昧。见百千亿佛。知百千亿佛神力。能动百千亿佛世界。能入百千亿佛世界。能照百千亿佛世界。能教化百千亿佛世界众生。能住寿百千亿劫。能知过去未来世各百千亿劫事。能善入百千亿法门。能变身为百千亿。于一一身能示百千亿菩萨。以为眷属。若以愿力自在胜上。菩萨愿力过于此数。示种种神通。或身或光明或神通或眼或境界或音声或行或庄严或加或信或业是诸神通。乃至无量百千万亿那由他劫不可数知

论曰。闻受持已。得如实三昧智慧光明随顺修行者。得义陀罗尼。此句示现因彼事故说依胜三昧得奢摩他毗婆舍那光明胜行。行已忆持者。能持彼行故。是菩萨智慧转胜。乃至彼诸善根转胜明净者。解脱彼障证彼义故。琉璃磨莹真金喻者。此地中出世间智增上光明转胜示现。如经诸佛子譬如本真金以琉璃磨莹光色转胜明净。乃至以方便智观转胜明净故。以无障碍智现前。般若波罗蜜行光明现前故。名为现前地。方便智观者。不住道行所摄明智故。月光明轮喻者。胜前地智示现轮小光明大。如经诸佛子譬如月光明轮。乃至四种魔道所不能坏故。魔道者。随顺魔事魔行故。余如前释

十地经论现前地第六卷之八十地经论远行地第七卷之九

        天亲菩萨造

        后魏北印度三藏菩提流支译

论曰。第七地中。有五种相差别。一乐无作行对治差别。二彼障对治差别。三双行差别。四前上地胜差别。五彼果差别。云何乐无作行对治

经曰。尔时金刚藏菩萨言。诸佛子。若菩萨善具足六地行已欲入第七菩萨地者。是菩萨当以十种方便智发起殊胜行入。何等为十。所谓善修空无相无愿而集大功德助道。入诸法无我无寿命无众生而不舍起四无量。起功德法。作增上波罗蜜行而无法可取。得远离三界而能应化起庄严三界行。毕竟寂灭诸烦恼焰而能为一切众生起灭贪嗔痴烦恼焰行。随顺幻梦影响化水中月镜中像自性不二而起作业无量差别心。善知一切国土道如虚空而起庄严净佛国土行。知诸佛法身自性无身而起色身相好庄严行。知诸佛音声无声本来寂灭不可说相而随一切众生。起种种差别庄严音声行。入诸佛。于一念顷通达三世事而能分别种种相劫数修行。随一切众生心差别观故。诸佛子是菩萨如是十种方便智。发起殊胜行。具足六地行已。得入第七菩萨地。诸佛子。是菩萨此十种方便智发起殊胜行现前行。名入第七菩萨地

论曰。乐无作行对治者。方便智发起十种殊胜行。如经诸佛子若菩萨善具足六地行已欲入第七菩萨地者是菩萨当以十种方便智发起殊胜行入。彼菩萨无障碍智现前般若波罗蜜行现前时即于无作行中生乐心。非起增上行。彼乐对治此十种法差别示现。方便智者。不舍众生法无我智对治。摄取增上行。发起殊胜行。此胜行于出世间及世间增上行更无胜者。有四种功德故。一财及身胜因事。随所须意取得财及身胜因功德集故。如经所谓善修空无相无愿而集大功德助道故。二护恶行因事。如是得胜无量修行。于一切众生中。不起妄行故。如经入诸法无我无寿命无众生而不舍起四无量故。三护善根因事。得彼胜因增上故。功德法增上行。以波罗蜜行故。如经起功德法作增上波罗蜜行而无法可取故。四摄众生因事。于中有七种门。一愿力取生作上首。教化余众生故。上首者。众生随逐故。如经得设离三界而能应化起庄严三界行故。二说对治故。为灭烦恼染及随烦恼使常自寂灭故。如经毕竟寂灭诸烦恼焰而能为一切众生起灭贪嗔痴烦恼焰行故。三为灭诸障故。障有四种。如五地中说。如经随顺幻梦影响化水中月镜中像自性不二而起作业无量差别心故。四于大法众会集故。如经善知一切国土道如虚空而起庄严净佛国土行故。五见闻亲近供养修行生福德故。如经知诸佛法身自性无身而起色身相好庄严行故。六转法轮故。如经知诸佛音声无声本来寂灭不可说相。而随一切众生起种种差别庄严音声行故。七随所问善释故。如经入诸佛于一念顷通达三世事而能分别种种相劫数修行随一切众生心差别观故。此十种发起殊胜行共对摄取对治摄取善修行空无相无愿等。入一切法无我无寿命无众生等。如是次第应知。此十种法现前得住第七地。如经诸佛子。是菩萨此十种方便智发起殊胜行现前行名入第七菩萨地故。如是乐无作行对治差别。七地已说。次说彼障对治有二种相。一修行无量种。二修行无功用行

经曰。是菩萨住第七菩萨地中。入无量众生界。入诸佛无量教化众生业。入无量世界网。入诸佛无量清净国土。入无量诸法差别。入无量诸佛智得无上道。入无量劫数。入无量诸佛通达三世事。入无量众生信乐胜事差别入无量诸佛名色身种种示现。入无量众生心行根信种种差别。入无量诸佛音声语言令众生欢喜。入无量众生心心所行种种差别。入无量诸佛随智慧行。入乘无量声闻乘信解。入诸佛无量说道。令众生信解。入无量辟支佛乘集成。入诸佛无量深智慧门。入所说。入诸菩萨无量所行道。入诸佛无量所说大乘集成事。令菩萨得入

论曰。修行无量种者。随所作利益何等众生。众生住何处。以何等智慧。以何等心。以何等行。置何等乘。以此差别。有十种修行。是中随所作利益何等众生者。于无量众生以无量业教化故。如经是菩萨住第七菩萨地中入无量众生界入诸佛无量教化众生业故。众生住何处者。于无量世界中。令依清净佛国土故。如经入无量世界网入诸佛无量清净国土故。以何等智慧者。无量种种法界智慧觉故。如经入无量诸法差别入无量诸佛智得无上道故。无量劫数通达三世。亦入智慧觉。如经入无量劫数入无量诸佛通达三世事故。以何等心者。有三种事。一有众生信种种天身心随同行。随彼信说故。如经入无量众生信乐胜事差别入无量诸佛名色身种种示现故。二知过去心习软中利根如应说法。如经入无量众生心行根信种种差别入无量诸佛音声语言令众生欢喜故。三以何等行者。随众生心说对治故。如经入无量众生心心所行种种差别入无量诸佛随智慧行故。置何等乘者。于三乘中置声闻乘中者。如经入乘无量声闻乘信解入诸佛无量说道令众生信解故。置辟支佛乘中者。如经入无量辟支佛乘集成。入诸佛无量深智慧门入所说故。置大乘中者。如经入诸菩萨无量所行道。入诸佛无量所说大乘集成事令菩萨得入故。如是彼障对治无量种差别修行十种已说。次说修行无功用行

经曰。是菩萨作如是念。是诸佛世尊。有无量无边境界。是境界不可以若千百亿劫千亿劫百千亿劫。乃至复过此数无量百千万亿那由他劫不可算数。如是诸佛境界我皆应集。自然不以分别得成。以不分别不取相故成。是菩萨如是善观智通。日夜常修方便智。熏发起殊胜行。善住坚固以不动法故

论曰。是中自然者。自性胜无分别故。如经自然不以分别得成以不分别不取相故成。此句示现是菩萨如是善观智通日夜常修方便智熏发起殊胜行善住坚固以不动法故者。彼障对治故。如是彼障对治差别此地已说。次说双行分有四种相。一二行双无间二信胜。三能作大义。四菩提分差别

经曰。是菩萨起于道时。一念心不舍。是菩萨修行智慧。来时亦起去时亦起。住时亦起坐时亦起卧时亦起。乃至睡梦皆能起道。离诸阴盖住诸威仪。常不离如是相念。是菩萨于念念中。具足菩萨十波罗蜜。何以故。如是菩萨起一切心。于念念中以大悲为首。修习一切佛法。皆回向如来智故。是菩萨求佛道时。所修善根。舍与一切众生是檀波罗蜜。能灭一切烦恼热是尸波罗蜜慈悲为首。能忍一切众生是羼提波罗蜜。求转胜善根心无厌足是毗梨耶波罗蜜。所修诸行心不驰散常向一切智智是禅波罗蜜。现忍诸法自性不生是般若波罗蜜。能起无量智门是方便波罗蜜。期上上胜智是愿波罗蜜。一切外道邪论及诸魔众不能沮坏菩萨道是力波罗蜜。如实观知一切法相是智波罗蜜。如是诸佛子。是菩萨住此菩萨远行地中。念念具足十波罗蜜。亦具足四摄法。亦具足四家三十七助菩提分法三解脱门。略说乃至一切助菩提分法。于念念中皆悉具足

论曰。是中一念中。奢摩他毗婆舍那二行双现前故。住诸威仪者。一切行中彼修行时无间不断不息行故。如经是菩萨起于道时一念心不舍。乃至住诸威仪故。远离一切烦恼盖故。信胜者。彼无量智中殊异义庄严相现前专念故。如经常不离如是相念故。能作大义者。念念具足十波罗蜜大义故。如经是菩萨于念念中具足菩萨十波罗蜜乃至智波罗蜜故。是中方便波罗蜜者。起无量智事。以是智故。起布施等无量行愿力摄故。愿波罗蜜者。起上上智。以是智故起布施等上上行生摄取胜故。力波罗蜜者。一切异论及诸魔众不能坏行。以是行故远离布施等障故。智波罗蜜者。如实观知一切法相。以是智故布施等一切种差别知为化众生故。菩提分差别者。有四种相。一依大乘行波罗蜜故。如经如是诸佛子是菩萨住此菩萨远行地中。念念具足十波罗蜜故。二依教化众生。行四摄法故。如经亦具足四摄法故。三依烦恼障增上净故。家菩提分解脱门者。何处住。以何等门修行得清净。如经亦具足四家三十七助菩提分法三解脱门故。家者般若家谛家舍烦恼家苦清净家故四依智障清净。如经略说一切助菩提分法于念念中皆悉具足故。如是双行差别已说。次说前上地胜差别。下地增上方便行满足故。七地中说

经曰。尔时解脱月菩萨。问金刚藏菩萨言。佛子。菩萨但于第七菩萨地中具足一切助菩提分法。为当一切菩萨诸地中亦皆具足。金刚藏菩萨言。佛子。菩萨于十菩萨地中悉具足一切助菩提分法。但第七地胜故得名。何以故。佛子。是菩萨此菩萨地中方便行具足得入智慧神通行故。佛子。菩萨于初地中发愿。观一切佛法故。具足助菩提分法。第二地中除心恶垢故。具足助菩提分法。第三地中愿转增长得法明故。具足助菩提分法。第四地中入道故。具足助菩提分法。第五地中随顺行世间法故。具足助菩提分法。第六地中。入甚深法门故。具足助菩提分法。此第七菩萨地中。起一切佛法故。具足一切助菩提分法

论曰。云何下地增上方便行满足。以满足故。入大智通行。如经金刚藏菩萨言。佛子。菩萨于十菩萨地中悉具足一切菩提分法。但第七地胜故得名。何以故。佛子。是菩萨此菩萨地中方便行具足得入智慧神通行故。是中通者五神通。智者如前说。云何此地中方便行满足。彼余世间出世间行中更起殊胜行。是故此七地中起一切佛法故。能具足助菩提分法。如经佛子。菩萨于初地中发愿观一切佛法故具足助菩提分法。乃至此第七菩萨地中起一切佛法故。具足一切助菩提分法故。如是前上地胜差别下地增上方便行满足已说。云何上地增上修行智慧方便菩提分。功用行满足故

经曰。何以故。佛子。菩萨从初地来乃至七地。得诸智慧所行道。以是力故。从第八菩萨地乃至第十地。无功用行自然满足。佛子。譬如二世界。一染净世界。二纯净世界。是二中间难可得过。欲过此界当以大神通力。佛子。菩萨如是行于染净菩萨道难可得过。当以大愿力大方便智力大神通力故乃可得过。解脱月菩萨言。佛子。七菩萨地为是染行为是净行。金刚藏菩萨言。佛子。从初地来菩萨所行皆离烦恼染业。何以。故回向阿耨多罗三藐三菩提故。随道所行如分平等故。不名为过七地烦恼行。佛子。譬如转轮圣王乘上宝象游四天下。知有贫穷困苦染过之人。而不为彼过所染。然王未免人身。若舍人身生于梵世住梵天宫。见行千世界。示梵王光明威力。尔时不名为人。佛子。菩萨亦如是。从初地来乘诸波罗蜜乘行一切世间。亦知世间烦恼染过。而不为烦恼过之所染。以乘正道故。而不名为过七地烦恼染。若菩萨舍一切功用行。从七地入第八地。尔时名为乘菩萨清净乘行一切世间。如实知一切烦恼染过。而不为烦恼过之所染。以得过故。佛子。菩萨住是第七菩萨地。过多贪欲等诸烦恼众。是菩萨住此菩萨远行地中。不名有烦恼者。不名无烦恼者。何以故。一切烦恼不行故。不名有烦恼者。贪求如来智慧未满足故。不名无烦恼者

论曰。云何上地增上智慧方便行菩提分。功用满足故。如经。何以故。佛子。菩萨从初地来乃至七地得诸智慧所行道乃至当以大愿力大方便智力大神通力乃可得过故。从初地来远离一切烦恼示现如是。此地名为染净。非染行如分行平等道故。彼菩萨此地中。随力分舍功用道如转轮王譬。第八地中。自然得报行过烦恼染过。示现如生梵世舍转轮王人身。如经诸佛子。譬如转轮圣王乃至不为烦恼过之所染。以得过故。佛子。菩萨住是第七菩萨地过多贪欲等诸烦恼众者。未至报地故。是故此地不名离烦恼行。有功用故。菩萨住此远行地中。不名有烦恼者。乃至未满足故。不名无烦恼者。如是前上地胜差别分已说。次说双行果差别。此有四种相。一业清净。二得胜三昧。三过地。四得胜行。云何业清净

经曰。是菩萨住此第七菩萨远行地中。毕竟成就深净身业。毕竟成就深净口业。毕竟成就深净意业。是菩萨所有不善业道。诸佛所呵皆已舍离。所有善业道诸佛所叹是则常行。世间所有经书技术。如五地中说自然而行。是菩萨于三千大千世界中得为大师。唯余诸佛及八地菩萨无有众生。深心妙行能与等者。是菩萨所有禅定三昧三摩跋提神通解脱一切现前。修行门中非善成就报力。如第八菩萨地。是菩萨住此第七菩萨远行地。于念念中具足修集方便智力及一切助菩提分法。得转胜具足

论曰。业清净者有四种相。一戒净胜。如经是菩萨住此第七菩萨远行地中毕竟成就深净身业乃至是则常行故。二世间智清净胜。如经世间所有经书技术乃至自然而行故。三得自身胜心行二平等无与等者。如经是菩萨于三千大千世界中乃至深心妙行无与等者故。四得胜力禅等现前胜。如经是菩萨所有禅定三昧乃至得转胜具足故。是中依禅起三昧三摩跋提神通解脱。为教化众生故。寂灭乐行故。灭定三摩拔提。如是次第如是双行果。业清净四种相已说。次说得胜三昧

经曰。是菩萨住此第七菩萨远行地中。入名善择智菩萨三昧善思义三昧益意三昧分别义藏三昧择一切义三昧善住坚根三昧智神通门三昧法界业三昧如来利益三昧入名种种义藏世间涅槃门菩萨三昧。菩萨如是大智通门。满足上首十三昧。能入百千菩萨三昧门。净治此地

论曰。得胜三昧者有十种相。一依未观义。二依已观义如经是菩萨住此第七菩萨远行地中入名善择智菩萨三昧故。善思义三昧故。三依一句无量义胜。四依一义说无量名如经益意三昧故。分别义藏三昧故。五依通一切五明处智。如经择一切义三昧故。六依烦恼障净。真如观坚根故。如经善住坚根三昧故。七依智障净。有四种障净故。一胜功德障此对治。如经智神通门三昧故。二无障碍智障此对治。如经法界业三昧故。三于深上佛法性弱障此对治。如经如来利益三昧故。四不住行障此对治。如经入名种种义藏世间涅槃门菩萨三昧故。种种义藏者种种善根故。如是大智通门满足上首十三昧。能入百千万菩萨三昧门。净治此地故。已说得胜三昧。次说过地

经曰。是菩萨得是三昧智慧方便善清净故。得大悲力故。过声闻辟支佛地。现前思量趣智慧地

论曰。过声闻辟支佛地者。有二种相。一修行方便智力。二大悲力故。现前者。能入法流水。思量智慧地者。八地智慧应知。但观奢摩他毗婆舍那道。彼处成就故。复次过者业胜故示现

经曰。是菩萨住此第七菩萨远行地中。无量身业无相行。无量口业无相行。无量意业无相行。是菩萨善清净行故。得无生法忍光明。解脱月菩萨言。佛子。菩萨住菩萨初地。有无量身业无量口业无量意业。已过一切声闻辟支佛行成。金刚藏菩萨言。佛子。观大法故过。非是自智行力。此第七菩萨地。得自智行力观故。一切声闻辟支佛所不能坏。佛子。譬如王子生在王家。具足王相胜一切臣众。以豪尊力故。非自智行力故。若身长大自具智力所作事成。过一切臣众。如是佛子。菩萨初发心时。已胜一切声闻辟支佛。以深心大故。今住此第七菩萨地中。自智行住故。过一切声闻辟支佛事

论曰。无量三业无相行者。入定远离相是。无量声闻缘觉。亦有净业远离相非无量相。不能利益一切众生故。复次此无量胜余下地事故。善清净行者。修方便行满足故。无生法忍光明者。相现前故。王子喻者。此地中胜过示现。修方便行满足故。自智行住者。方便行尽念观住故。如经佛子。譬如王子生在王家乃至自智行住故过一切声闻辟支佛事故。无量身等胜业已说。非但多无量神力。亦无量示胜义故

经曰。诸佛子。是菩萨住此第七菩萨远行地。得甚深远离无行。身口意业转求胜行而不舍离

论曰。甚深者远入故。远离者彼障灭故。无行者。彼余出世间世间地不能行故。身口意业转求胜行而不舍离者。声闻辟支佛虽离彼相业不如是。得少为足不求上行故。如是双行果过。二乘地已说。云何得胜行

经曰。解脱月菩萨言。佛子。菩萨从何地来能入寂灭定。金刚藏菩萨言。佛子。菩萨从第六地来能入寂灭定今住第七菩萨地。于念念中能入寂灭定而不证寂灭定。是菩萨毕竟成就不可思议身口意业。佛子。是诸菩萨行实际行而不证寂灭定。佛子。譬如有人乘大船舫入于大海。善知行船善知水相。不为大海水难所害。如是佛子。菩萨住此第七菩萨地中。乘诸波罗蜜船行实际行。而不证寂灭定

论曰。行实际行而不证寂灭定。以不舍有故。如经金刚藏菩萨言。佛子。菩萨摩诃萨从第六地来能入寂灭定乃至而不证寂灭定故。如是三摩跋提胜行已说。次说发起胜行

经曰。菩萨如是通达三昧智力修行。起大方便智力故。现身世间门深心涅槃。虽眷属围绕而心常远离。以愿力受生三界而不为世间所染。心常寂灭以方便力而还炽然虽然不烧。随顺佛智转声闻辟支佛地。通达诸佛境界藏现魔境界。过四魔道现行魔境界。现诸外道行而深心不舍佛济。通达一切世间事心常在出世间道法。所有庄严之事。胜诸天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人四天王释提桓因梵天王而不舍乐法念

论曰。发起殊胜行者。有八种行共对治摄。一起功德行随顺世间门。如经菩萨如是通达三昧智力修行起大方便智力故现身世间门深心涅槃故。二上首摄余行。如经虽眷属围绕而心常远离故。三愿取有行。如经以愿力受生三界而不为世间所染故。四家不断行。远离贪欲随烦恼使而示贪欲行事。如经心常寂灭以方便力而还炽然虽然不烧故。五入行。如经随顺佛智转声闻辟支佛地故。六资生行。饮食睡梦等魔境界故。如经通达诸佛境界藏现魔境界故。七退行。示老病死此三魔境界故。如经过四魔道现行魔境界故。八转行。有三种转。一见贪转。如经现诸外道行而深心不舍佛济故。二障碍转。如经通达一切世间事而心常在出世间道法故。三贪转。天龙等尊重心摄取转彼贪心故。如经所有庄严之事胜诸天龙乃至而不舍乐法念故

经曰。菩萨成就如是智慧。住此菩萨远行地已多见诸佛。以大神通力大愿力故。见多百佛多千佛多百千佛多百千那由他佛多亿佛多百亿佛多千亿佛多百千亿佛多百千亿那由他佛。以大神通力大愿力故。是菩萨见诸佛时。以上心深心供养恭敬尊重赞叹。衣服饮食卧具汤药一切供具悉以奉施。以诸菩萨上妙乐具供养众僧以此善根皆愿回向阿耨多罗三藐三菩提。于诸佛所生上恭敬。专心听法闻已受持。闻受持已得如实三昧智慧光明随顺修行行已忆持守护诸佛正法。一切声闻辟支佛智慧问难所不能坏。是菩萨复能利益众生故法忍转净。是菩萨住此菩萨远行地中。于无量劫彼诸善根转胜明净调柔成就。复转尽成就。无量百劫无量千劫。无量百千劫。无量百千那由他劫。无量亿劫无量百亿劫。无量千亿劫无量百千亿劫。无量百千亿那由他劫。彼诸善根转胜明净调柔成就。复转尽成就。佛子。譬如本真金。以一切众宝具足庄严。光色转胜明净。余庄严具所不能及。如是佛子。菩萨住此第七菩萨远行地中。彼诸善根从方便智起转胜明净。一切声闻辟支佛所不能坏。佛子。譬如日光。一切星宿月光所不能坏。阎浮提内所有泥水悉能干竭。如是佛子。菩萨住此第七菩萨远行地中。彼诸善根一切声闻辟支佛所不能坏。又能干竭一切众生烦恼淤泥。是菩萨十波罗蜜中。方便波罗蜜增上。余波罗蜜非不修习随力随分。诸佛子。是名略说菩萨第七菩萨远行地。若菩萨住此地中多作他化自在天王所作自在善令众生发生正智。亦令众生渡烦恼海。所作善业布施爱语利益同事是诸福德。皆不离念佛念法念僧念菩萨念菩萨行念波罗蜜念十地念不坏力念无畏念不共佛法。乃至不离念一切种一切智智。常生是心。我当于一切众生中为首为胜为大为妙为微妙为上为无上为导为将为师为尊乃至为一切智智依止者。复从是念发精进行。以精进力故。于一念间得百千亿那由他三昧。见百千亿那由他佛。知百千亿那由他佛神力。能动百千亿那由他佛世界。能入百千亿那由他佛世界。能照百千亿那由他佛世界。能化百千亿那由他佛世界众生。能住寿百千亿那由他劫。能知过去未来世各百千亿那由他劫事。能善入百千亿那由他法门。能变身为百千亿那由他。于一一身能示百千亿那由他菩萨以为眷属。若以愿力自在胜上菩萨愿力。过于此数示种种神通。或身或光明或神通或眼或境界或音声或行或庄严或加或信或业。是诸神通乃至无量百千万亿那由他劫。不可数知

论曰。守护诸佛正法者。于三千大千世界中得为大师故。修方便行满足故。彼守护上首故。利益众生故法忍转显。此地释名应知。如经是菩萨复能利益众生故法忍转净故。修行功用尽至故。名为远行地。一切众宝具足庄严。真金喻者。示现一切菩提分法方便行。功用满足故。此地中诸善根转胜明净示现。如经譬如本真金乃至一切声闻辟支佛所不能坏故。日光喻者。如前地说。此地胜故。如经佛子譬如日光乃至又能干竭一切众生烦恼淤泥故。余如前说

十地经论远行地第七卷之九十地经论不动地第八卷之十

        天亲菩萨造

        后魏北印度三藏菩提流支译

论曰。第八地中有七种相差别。一总明方便作集地分。二得净忍分。三得胜行分。四净佛国土分。五得自在分。六大胜分。七释名分。云何总明方便作集地分

经曰。尔时金刚藏菩萨言。诸佛子。若菩萨于七地中善集慧方便。善清净诸行。善集助道法。善起大愿力。善加如来力加。自善根力得力故。常念随顺如来力无畏不共佛法故。善净深心觉故。成就福德智力故。大慈悲等不舍一切众生行故。通达无量智道故

论曰。总明方便作集地分者。七地总故同相及别相。云何同相。同相有三种。一者二种无我上上证故。二者不住道清净故。三者彼方便智行所摄满足。助菩提分法故。如经诸佛子。若菩萨于七地中善集慧方便故。善清净诸行故。善集助道法故。云何别相。善起大愿力。等初地等诸地。如经善起大愿力故。第二地中。是故我应等行十善业道修行一切种令清净具足彼处如来力故。如经善加如来力加故。第三地中厌得不退禅定等。自善根力得通达故。如经自善根力得力故。第四地中所说法分别智教化智障净胜念通达佛法。如经常念随顺如来力无畏不共佛法故。第五地中深净心平等善净深心等。如经善净深心觉故。第六地中大悲自在为首增上观因缘集成就福德智力。如经成就福德智力故。第七地中方便智慧发起殊胜道。不舍一切众生行。如经大慈悲等不舍一切众生行故。以无量众生界故入无量智道。如经通达无量智道故。如是第八地总明方便作集地分已说。云何得净忍分。得无生法忍故。彼清净自然无功用行应知

经曰。入一切法本来无生。无成。无相。无出。不失。无尽。不行。非有有性。初中后平等。真如无分别入一切智智。是菩萨远离一切心意识忆想分别。无所贪着。如虚空平等。入一切法如虚空性。是名得无生法忍

论曰。复次彼忍于四种无生中应知。四种无生者。一事无生。二自性无生。三数差别无生。四作业差别无生。是中事无生者。实有七种事。一净分法中本有实此对治。如经入一切法本来无生故。二新新生实此对治。如经无成故。三者相实此对治。如经无相故。四后际实此对治。如经无出故。五先际实染分中烦恼障故此对治。如经不失故。六尽实诸众生此对治。如经无尽故。七杂染实净分中此对治。如经不行故。自性无生者。是法无我彼法无我。自体无性故。如经非有有性故。彼观事故是此忍不得言无所有观。法无我无二相故。数差别无生者。于三时中染净法不增减故。如经初中后平等故。作业差别无生者。于真如中净无分别佛智故。如经真如无分别入一切智智故。如是无生法忍观示现。次示现行远离报分别境界想。摄受分别性想故。如经是菩萨远离一切心意识忆想分别故。想者远离障法想非无治法想。彼治想于下地中有三种胜事。一无功用自然行。如经无所贪着故。二遍一切法相。如经如虚空平等故。三入真如不动自然行故。如经入一切法如虚空性。是名得无生法忍故。如是八地得净忍分已说。次说得胜行分

经曰。又佛子。如是成就法忍。菩萨即时得是第八菩萨不动地。得为深行菩萨难可得知。无能分别。离一切相。离一切想一切贪着。无量无边一切声闻辟支佛所不能坏寂静一切寂静而现在前。佛子。譬如比丘得具足神通心得自在。次第入灭尽定。一切动心忆想分别皆悉尽灭。佛子。菩萨亦如是。住是第八菩萨不动地。即离一切有功用行及诸忆念得无功用法。离身口意务住报行成。佛子。譬如有人梦中见身堕在大河。是人尔时发大勇猛施大方便欲出此河。发勇猛时忽然便寤。寤已即离一切勇猛方便懅事。佛子。菩萨亦如是。从初已来见诸众生堕四大河。发大精进力广修行道至不动地。即离一切想有功用行。是菩萨一切不行二心诸所忆想不复现前。佛子。譬如生在梵天。欲界烦恼一切不行。如是佛子。菩萨住此菩萨不动地。一切心意识等不行。一切佛心菩提心菩萨心涅槃心不行。何况当行世间心

论曰。是中得胜行者。得深行故。深行有七种。一难入深。如经又佛子。如是成就法忍菩萨即时得是第八菩萨不动地得为深行菩萨难可得知故。二同行深。诸净地菩萨同故。如经无能分别故。三境界深。能取可取不现前故。如经离一切相离一切想一切贪着故。护一切障想故。言离一切贪着。四修行深。自利利他行故。如经无量无边故。五不退深。如经一切声闻辟支佛所不能坏故。六离障深。如经寂静故。七对治现前深。如经一切寂静而现在前故。真如一切寂静故。灭尽定喻者。示彼行寂灭故。如经佛子譬如比丘乃至离身口意务住报行成故。一切动心忆想分别皆悉尽灭者无彼依止故。即离一切有功用行者。过功用行地故。得无功用法者。得彼对治法故。以得无功用法自然行故。住报行成示现得有功用行相违法故。复住报行成者。善住阿梨耶识真如法中故梦寤喻者。示此行中护彼过想有正智想此行寂灭故。如经佛子譬如有人梦中见身乃至诸所忆想不复现前故。是中依清净世间涅槃二心不行故。依境界受用念想不行故。生梵天喻者。于下地心一向不行得报地故。此说远离胜。如经佛子譬如生在梵天乃至何况当行世间心故。是中顺行不顺行二分心等佛等不行故。大乘小乘差别故。大乘小乘中。众生法差别故无学学差别。佛等涅槃差别说应知。是中顺行者。顺行分中心等不行故。如经一切心意识等不行故。是中不顺行者。不顺行分中佛等不行故。如经佛心乃至涅槃心不行故。大乘小乘差别。大乘中差别者。佛菩萨涅槃差别故。小乘中差别者。声闻涅槃阿罗汉等差别故。大小乘中众生法差别者。佛菩萨差别故。法差别者。菩提涅槃差别故。小乘中无学学众生差别故。是中法差别者。涅槃差别故。无学差别者。阿罗汉差别故。有学差别故。阿那含等差别故。如是等行皆悉不行故

经曰。佛子。是菩萨得此不动地已。本愿力住故。诸佛尔时彼法流水门中与如来智慧。复作是言。善哉善哉。善男子。汝得此究竟忍顺一切诸佛法故。善男子。我等所有十力四无所畏十八不共佛法成就。汝今未得当为成就诸佛法故。勤求精进亦莫舍此忍门

论曰。此与如来智慧力。转彼深行乐足心故。叹得上法故。不得修教授故。若不舍此忍行不得成就一切佛法故。依彼有力能作故。如经佛子是菩萨得此不动地已本愿力住乃至亦莫舍此忍门故

经曰。复次善男子。汝虽得是寂灭解脱。此凡夫众生不善不寂灭。常在种种烦恼集中。为种种异念觉观所害。汝当愍念如是众生

论曰。依彼众生无大利益事。现起烦恼使在家出家分中深着烦恼众生转故。如经善男子汝虽得是寂灭解脱乃至汝当愍念如是众生故。不善者现起烦恼染故。不寂灭者不远离彼使故。常在种种烦恼集中者。于在家分中故。为种种异念觉观所害者。于出家分中故

经曰。复次善男子。汝应念本所愿欲大利益众生欲得不可思议智慧门

论曰。依愿教化众生。智行广能转故。如经复次善男子汝应念本所愿乃至欲得不可思议智慧门故

经曰。复次善男子。此一切法中。法性有佛无佛法界常住。诸如来不以得此法故。说名为佛。声闻辟支佛亦得此无分别法

论曰。依不共义。功行疲惓彼垢转故。如经复次善男子此一切法中法性乃至亦得此无分别法故

经曰。复次善男子。汝观我等无量净身无量智慧无量佛国土无量光轮无量起智无量净音。汝今应起如是等事

论曰。无量净身等彼佛法成就有力示现依利益众生故。此利益众生事以何事身。如经复次善男子。汝观我等无量净身故。以何等智。世谛智第一义谛智。如经无量智慧故。以何等土清净国土。如经无量佛国土故。以何等摄伏。如经无量光轮故。随所度众生行智慧。如经无量起智故。随所言说。如经无量净音故。如来作无量利益众生。汝今应起如是等事示现

经曰。复次善男子。汝今适得此一法明。所谓一切法寂灭无分别法明。如是善男子。如来法明。无量入无量作无量转。汝为得彼故应起此法

论曰。复示诸佛无量胜行。如经复次善男子汝今适得此一法明乃至应起此法故。无量入者法门差别故。无量作者作事差别故。无量转者依上上不断差别故

经曰。复次善男子。汝观十方无量国土无量众生。无量法差别。汝应如实尽通达彼事。如是佛子。诸佛与此菩萨。如是等无量无边起智慧门。以此无量智慧门故。是菩萨能起无量差别业皆悉成就

论曰。复少作在随所见无量世界众生法差别。少分观即能成就转故。如经复次善男子。汝观十方无量国土乃至皆悉成就故

经曰。金刚藏菩萨。语解脱月菩萨言。佛子。若诸佛不与此菩萨起智门者。是菩萨尔时即入涅槃。弃舍利益一切众生。以诸佛与此菩萨无量无边起智门故于一念中所起智业。比从初发心以来乃至竟第七地。百分不及一。千分百千分百千那由他分亿分百亿分千亿分百千亿分百千亿那由他分不及一。乃至无量无边阿僧祇分亦不及一。乃至非算数譬喻之所能及。所以者何。佛子先以一身起行起故。今此菩萨地中。得菩萨无量身差别故。集无量行力故。无量音声起故。无量智慧起故。无量生起故。无量清净国土故。教化无量众生故。供养恭敬无量诸佛故。随顺觉无量法故。得无量神通力起故。无量众会差别故。无量身口意业集一切菩萨行力。以不动法故。佛子。譬如乘船欲入大海。未至大海多用功力。若至大海不复用力。但以风力而去。若于大海一日所行。比本功力。至于百岁不能得及。如是佛子。菩萨善集善根资粮。乘大乘船。到菩萨所行大智慧海。于一念间无功用智能入一切智智处。本有功用行。若一劫若百千万劫不能得及

论曰。是中即入涅槃者。与智慧示现。如经以诸佛与此菩萨无量无边起智门故。乃至以不动法故。以诸佛与此菩萨无量无边起智门者。彼行中摄功德因胜。同作教授说故。乃至算数等。次第解释应知。数分者。一一为二二二为四。如是等喻亦不及一。是事不可喻比故。无量身差别者。一切菩萨身。信解如自身故。如是无量音声起等亦无量应知。此十句依教化众生。依集助道行。依障清净应知。随身住随所说随依智随所取生随何国土。得教化众生随集功德助道。集智慧助道。供养恭敬无量诸佛故。随顺觉无量法故。随神通障正觉障清净故。此一切处。随顺无量身口意业应知。以不动法者。无间不断集故。佛子譬如乘船乃至百千万劫不能得及者。船喻彼行速疾。知因胜示现。善集善根资粮者。于七地中修菩萨行故。乘大乘船到菩萨所行。大智慧海者。八地智慧海应知。如是八地得胜行分已说。次说净佛国土。此净佛国土有三种自在行。一器世间自在行。二众生世间自在行。三智正觉自在行。云何器世间自在行

经曰。佛子。是菩萨得菩萨第八地。从大方便慧起无功用心。在菩萨道观一切智智力。所谓观世界成观世界坏。是菩萨随世间成彼如实知。随世间坏彼如实知。随业因缘集故。世间成彼亦知。随业因缘尽故。世间坏彼亦知。随世间几时成彼亦知。随世间几时坏彼亦知。随世间几时成住彼亦知。随世间几时坏住彼亦知。是菩萨知地界小相。知地界大相。知地界无量相。知地界差别相。是菩萨知水界小相。知水界大相。知水界无量相。知水界差别相。是菩萨知火界小相。知火界大相。知火界无量相。知火界差别相。是菩萨知风界小相。知风界大相。知风界无量相。知风界差别相。是菩萨知微尘细相粗相无量相。知差别相。随何世界中所有微尘集散。微尘差别皆悉能知。随何世界中。所有地界若干微尘皆悉能知。所有水界若干微尘皆悉能知。所有火界若干微尘皆悉能知。所有风界若干微尘皆悉能知所有众生身若干微尘皆悉能知。所有国土身若干微尘皆悉能知。是菩萨知诸众生粗身细身差别若干微尘成。知地狱身依若干微尘成。知畜生身依若干微尘成。知饿鬼身依若干微尘成。知阿修罗身依若干微尘成。知天身依若干微尘成。知人身依若干微尘成。是菩萨通达入如是分别微尘智已。知欲界成知色界成知无色界成。知欲界坏知色界坏知无色界坏。知欲界小相。知欲界大相。知欲界无量相。知欲界差别相。知色界小相。知色界大相。知色界无量相。知色界差别相。知无色界小相。知无色界大相。知无色界无量相。知无色界差别相。如是入思量三界智中。是菩萨复善起智明。善知众生身差别。善知分别众生身。善观所应生处。是菩萨随众生生处。随众生身集业。而为受身教化众生故。是菩萨现身遍满三千大千世界。随众生身各各差别。如是随顺生处。起现前光明。若二三千大千世界。若三四五。若十二十三十四十五十。若百三千大千世界。若千若万若百万若千万若百千万若亿万若百千万亿那由他。乃至无量无边不可说不可说三千大千世界。身遍其中随众生自身差别信如是生处起现前光明智随顺故。是菩萨成就如是智慧。于一佛国土身不动摇。乃至不可说诸佛国土。于众会中。起现前光明故

论曰。器世间自在。行者有五种自在。一随心所欲彼能现及不现。二随何欲彼能现。三随时欲彼即时现。四随广狭欲彼能现。五随心几许欲彼能现。如经佛子是菩萨得菩萨第八地从大方便慧起无功用心在菩萨道观一切智智力乃至随世间坏彼如实知故。此世界成坏等。初器世间自在行中。随心所欲彼能现及不现故。随业因缘集故。世间成彼亦知。随业因缘尽故。世间坏彼亦知。业集尽智。第二随何欲彼能现故。随世间几时成乃至第四句随世间几时坏住彼亦知。随世间几时成等智。第三随几时欲彼即时现故。是菩萨知地界小相。乃至知人身依若干微尘成。地等相差别智。第四随广狭欲彼能现故。是菩萨入如是分别微尘智中乃至现前光明成坏智乃至于一佛国土身不动摇。第五随心几许欲彼能现故。是中地界次第境界智相智。云何境界智。非定地报识境界是名小相。定地识境界是名大相。如来境界是名无量相。云何相智。自相同相是名差别相。身粗细者。色无色等诸众生如是次第欲界等境界智相智。欲界人境界是名小相。天境界大相。色界觉观境界小相。无觉无观境界大相。无色界佛法中凡夫境界小相。声闻菩萨大相。一切如来境界无量相。善知众生身差别。善知分别众生身者。善知身不同方便异生同生差别。应知诸佛国土于众会中起现前光明者。彼处处法身体示现如是净佛国土器世间自在行已说。云何众生世间自在行

经曰。是菩萨随众生身差别信。随决定信差别。彼彼佛国土中。彼彼大会中。如是如是自身示现。是菩萨若于沙门众中示沙门形色。婆罗门众中示婆罗门形色。刹利众中示刹利形色。毗舍众中示毗舍形色。首陀众中示首陀形色。居士众中示居士形色。长者众中示长者形色。四天王众中示四天王形色。帝释众中示帝释形色。如是焰摩众中。兜率众中。化乐众中。他化自在众中。魔众中。梵天众中。示梵天形色。乃至阿迦尼吒天众中示阿迦尼吒天形色。是菩萨应以声闻身度者示声闻形色。应以辟支佛身度者示辟支佛形色。应以菩萨身度者示菩萨形色。应以佛身度者示佛身形色。佛子如是所有不可说诸佛国土中。随众生身信乐差别。彼彼佛国土中。如是自身差别示现

论曰。众生世间自在行者。彼调伏自在故彼行化众生身心自同事自身心等分示现。如经是菩萨随众生身差别信乃至彼彼佛国土中如是自身差别示现故。如是众生世间自在行已说。云何智正觉自在行。第一义谛智世谛智等

经曰。是菩萨远离一切身相分别得身平等。是菩萨知众生身。知国土身。知业报身。知声闻身。知辟支佛身。知菩萨身。知如来身。知智身。知法身。知虚空身。是菩萨如是知众生深心起乐。若以众生身作自身。如是国土身业报身声闻身辟支佛身菩萨身如来身智身法身虚空身作自身。是菩萨如是知众生深心起乐。若以自身作众生身。如是国土身业报身声闻身辟支佛身菩萨身如来身智身法身虚空身作众生身。是菩萨如是知众生深心起乐。何等何等身。何等何等身中能自在作。是菩萨知众生身集业身报身烦恼身色身知无色身。是菩萨知国土身小相大相无量相垢相净相广相乱住相倒住相平正相。知方网差别相知业报身假名差别声闻身假名差别辟支佛身假名差别。知菩萨身假名差别。是菩萨知如来身菩提身愿身化身受神力身相好庄严身光明身意生身功德身法身。知智身。是菩萨善知智身善思量相。善如实观相。果行所摄相。世间出世间差别相。三乘差别相。共不共相。乘不乘相。善知学无学相。是菩萨知法身平等相。知不坏相。知转时假名差别相众生非众生法差别相。知佛法圣僧法差别相。是菩萨知虚空身无量相周遍相无形相不异相无边相。知显色身别异相

论曰。第一义谛智者。远离一切身相分别。示得身平等自身他身不分别故。如经是菩萨远离一切身相分别得身平等故。此是不同声闻辟支佛。第一义智示现世谛智者。善知众生身等染分净分不二分善分别知故。如经是菩萨知众生身乃至知虚空身故。是中众生世间器世间。彼二生因业。烦恼是染分。三乘是净分。此三乘随何智随何法。彼净显示虚空是不二分故。是菩萨如是知众生深心起乐。若以众生身作自身。乃至以虚空身作自身等。是菩萨如是知众生深心起乐。若以自身作众生身。乃至以自身作虚空身等。是中以众生身作自身者。彼自在中所作摄取行种种示现。是中众生身者。业生烦恼妄想染差别。色无色界差别皆如实知。如经是菩萨知众生身集业身报身烦恼身色身知无色身故。国土身者。千等世界差别应知。净不净世界差别皆善分别知。广等世界差别皆善分别知。如经是菩萨知国土身乃至知方网差别相故。广相等诸句义如初地说。业报声闻辟支佛菩萨身假名差别者。自相同相差别假名分别无我人故。如经是菩萨知业报身假名差别乃至知菩萨身假名差别故。是菩萨知如来身者。示成正觉为菩提故。愿生兜率天故。所有佛应化故。自身舍利住持故。所有实报身故。所有光明摄伏众生故。所有同不同世间出世间心得自在解脱故。所有不共能作广大利益因故。所有如来无漏界故。所有无障碍智故。是故此智能作一切事。彼事差别皆悉能知。如经是菩萨知如来身菩提身乃至知智身故。是菩萨知智身者。闻思智差别修智差别果行智差别世间出世间智差别皆如实知。如经是菩萨善知智身乃至知学无学相故。是菩萨知法身平等相者。无量法门明等一法身故。如闻取故。随所化众生根性相应时说差别故。有根无根差别相故。知第一相差别皆悉能知。如经是菩萨知法身平等相乃至知佛法圣僧法差别相故。是菩萨知虚空身者。知无尽相遍相不可见相无障碍相无为相。能通受色相因色彼分别皆悉能知。如经是菩萨知虚空身无量相乃至知显色身别异相故。如是八地净佛国土三自在行已说。次说得十自在

经曰。是菩萨善知起如是诸身。则得命自在不可说不可说劫命住持故。得心自在无量阿僧祇三昧入智故。得物自在一切世界无量庄严严饰住持示现故。得业自在如现生后时业报住持示现故。得生自在一切世界生示现故。得愿自在随心所欲佛国土时示成三菩提故。得信解自在一切世界中佛满示现故。得如意自在。一切佛国土中如意作变事示现故。得法自在无边无中法门明示现故。得智自在如来力无畏不共法相好庄严三菩提示现故

论曰。得自在者。是菩萨如是修行。器世间众生世间智正觉世间三种自在行故。得十自在。如经是菩萨善知起如是诸身则得命自在乃至得智自在故。此十自在对治十种怖畏。如是次第应知。何者是十种怖畏。一死怖畏。二烦恼垢怖畏。三贫穷怖畏。四恶业怖畏。五恶道怖畏。六求不得怖畏。七谤法罪业怖畏。八追求时缚不活怖畏。九云何云何疑怖畏。十大众威德怖畏。如是八地得十自在分已说。次说大胜分

经曰。是菩萨得是菩萨十自在已。即时名为不可思议智者无量智者广智者不可坏智者。菩萨如是至已。如是智成就。常集起清净身业。常集起清净口业。常集起清净意业。智慧为首智随顺转般若波罗蜜增上。大悲为首方便善巧善能分别。自起愿力善加诸佛所加。常不舍利益众生行。遍知无边世界差别事。佛子略说菩萨得此菩萨不动地。身口意业所作皆能集起一切佛法。是菩萨得此菩萨不动地。善住净心力中离一切烦恼集故。善住深心力中常不离道故。善住大悲力中不舍利益众生故。善住大慈力中救一切世间故。善住陀罗尼力中不忘法故。善住辩才力中智慧善巧分别一切佛法故。善住神通力中行无边世界差别故。善住愿力中不舍一切菩萨所行故。善住波罗蜜力中修集一切佛法故。善住如来加力中一切种一切智智现前故。是菩萨得如是智力。示一切所作。一切事中无有过咎故

论曰。大胜者。有三种大。一智大二业大三彼二住功德大。云何智大。不可思议智者不住世间。不住涅槃故。如经是菩萨得是菩萨十自在已。即时名为不可思议智者故。此不可思议有三种应知。一修行尽至不可思议。二所知不可思议。三除障智不可思议。如经无量智者故广智者故不可坏智者故。是名智大。菩萨如是至已。乃至集起一切佛法故。是菩萨如是至已者。如上说。如是智成就者。亦如上说。常集起清净三业者。此是业大。彼净业有四种相。一起能起起同时。如经智慧为首故智随顺转故。二智摄不染作利益众生行等。如经般若波罗蜜增上故大悲为首方便善巧善能分别故。三因摄自行他行因等。如经善起愿力故善加诸佛所加故。四作业所起利益众生。净佛国土成就一切佛法。如经常不舍利益众生行故。遍知无边世界差别事故。佛子略说菩萨得此菩萨不动地身口意业所作皆能集起一切佛法故。是名业大。彼二住功德大者。善住净心力等示现依七种功德故。一善住道功德。如经是菩萨得此菩萨不动地善住净心力中离一切烦恼集故。善住深心力中常不离道故。善住大悲力中不舍利益众生故。善住大慈力中救一切世间故。又善住道功德。初二远离障故。对治坚固故。次二不舍众生故。二不忘功德。如经善住陀罗尼力中不忘法故。三成就口业功德。如经善住辩才力中智慧善巧分别一切佛法故。四心自在成就功德。如经善住神通力中行无边世界差别故。五愿力成就功德。如经善住愿力中不舍一切菩萨所行故。六修行成就功德。如经善住波罗蜜力中集一切佛法故。七与智功德。如经善住如来加力中一切种一切智智现前故。是菩萨得如是智力示一切所作者。得无憎爱。不分别众生有烦恼无烦恼。平等作业故。一切事中无有过咎者。以得此七种功德故。如是八地大胜分已说。次说释名分

经曰。佛子。此菩萨智地名为不动地。不可坏故。名为不转地。智慧不退故。名为难得地。一切世间难知故。名为王子地。无家过故。名为生地。随意自在故。名为成地。更不作故。名为究竟地。智慧善分别故。名为涅槃地。善起大愿力故。名为加地。他不能动故。名为无功用地。善起先道故

论曰。释名有二种。一地释名。二智者释名。地释名者有六种相。一染对治。此染有二种。一下地功用行小乘愿诸魔业。二烦恼习行此对治。如经佛子此菩萨智地名为不动地不可坏故名为不转地智慧不退故。二得甚深。如经名为难得地一切世间难知故。三发行清净。如经名为王子地无家过故名为生地随意自在故。是中发净者。如王子一切所作无过故。行净者。住生地所欲事自在成就故。四世间出世间有作净胜。如经名为成地更不作故名为究竟地智慧善分别故。是中出世间有作净胜者。以智慧善分别智障净故。五彼二无作净胜。如经名为涅槃地善起大愿力故。无作净胜者。以本愿力不舍利益一切众生故。六菩萨地胜。如经名为加地他不能动故名为无功用地善起先道故。又菩萨地胜者。六地七地胜故。六地胜者。发起殊胜行他事念动故。七地有功用。此地中善起先道无功用自然行故。智者释名者。以何义故。菩萨名为得不动菩萨。今说此事应知

经曰。佛子菩萨成就如是智慧。名为得入佛性。名为佛功德自照明。名为随佛威仪行。名为佛境界现前。日夜常为善加诸佛加。常为四天王释提桓因梵天王等之所奉迎。常为密迹金刚神之所侍卫。不舍三昧力。常现无量诸身差别。一切身行中势力成就。成就大果报神通。于无边三昧中得自在。能受无量记。随化世间示成正觉。是菩萨如是通达入大乘众数。善思量大乘通。日夜常放智光明炎。入无障碍法界道。善知界道差别。能示一切相功德随意自在。善解先际后际。通达一切回转魔道智。入如来智慧境界。能于无边世界中行菩萨道不退转力故。是故菩萨名为得不动菩萨

论曰。彼复有二种义。名为得不动菩萨。一一向不动。二一体不动。佛性随顺因故。如经佛子菩萨成就得如是智慧名为得入佛性等。是中佛性者。界满足胜。随顺因者。三种相示现。一摄功德二行三近。如经名为佛功德自照明故。名为随佛威仪行故。名为佛境界现前故。是中自照明者。善清净义故。威仪行者。名为正行故。现前者。近佛境界故。是中一向不动者。如经日夜常为善加诸佛加故。彼复依五功德应知。一供养功德。如经常为四天王释提桓因梵天王等之所奉迎故。二护功德。如经常为密迹金刚神之所侍卫故。三依止功德。如经不舍三昧力故。四国土清净功德。如经常现无量诸身差别故。五教化众生功德

复次教化众生功德。有五种示现。一愿取诸有生。如经一切身行势力成就故。二根心使智力。如经成就大果报神通故。三无量法力转法轮故。如经于无边三昧中得自在故。四受力。如经能受无量记故。五说力。如经随化世间示成正觉故。是菩萨如是通达者。一向不动故。是中一体不动者。入大乘众数。如经是菩萨如是通达入大乘众数故。入大乘众数者。名不破坏义。此有九种。一智不坏。如经善思量大乘通故。二说不坏。如经日夜常放智光明焰故。三解脱不坏。如经入无障碍法界道故。四佛国土清净不坏。如经善知界道差别故。五入大乘不坏。如经能示一切相功德故。六神通不坏。如经随意自在故。七能解释义不坏。如经善解先际后际故。八坐道场不坏。如经通达一切回转魔道智故。九正觉不坏。如经入如来智慧境界故。能于无边世中行菩萨道不退转力故者。行无障碍不断绝故。以行无障碍不断义故。名为得不动地菩萨

经曰。菩萨得菩萨不动地。常不离见无量诸佛。善行三昧力故。及大愿力故。见诸佛时而不舍供养恭敬。是菩萨于一一劫中一一世界中见无量佛无量百佛无量千佛无量百千佛无量百千那由他佛无量亿佛无量百亿佛无量千亿佛无量百千亿佛无量百千万亿那由他佛。以大神通力大愿力故。见诸佛时。以上心深心供养恭敬尊重赞叹。衣服饮食卧具汤药一切供具悉以奉施。以诸菩萨上妙乐具供养众僧。以此善根皆愿回向阿耨多罗三藐三菩提亲近诸佛。从诸佛受本世界差别等诸法明。是菩萨转深入如来法藏。问世界差别事中无能尽者。是菩萨彼诸善根。无量劫中转胜明净。无量百劫无量千劫无量百千劫无量百千那由他劫无量亿劫无量百亿劫无量千亿劫无量百千亿劫无量百千亿那由他劫。彼诸善根转胜明净。佛子。譬如本真金。善巧金师作庄严具。已系在阎浮提王若颈若项。阎浮提人余宝庄严具无能夺者。如是佛子菩萨住此不动地。彼诸善根一切声闻辟支佛。乃至七地菩萨所不能坏。菩萨得是地大智光明灭诸众生烦恼闇障。以善分别智门故。佛子譬如千世界主大梵天王。能于一时流布慈心满千世界。亦能放光遍照其中如是

佛子菩萨。住此菩萨不动地中。能放身光照十千万三千大千世界微尘数世界众生。渐能除灭诸烦恼火令得清凉。是菩萨十波罗蜜中。愿波罗蜜增上。余波罗蜜非不修习随力随分。佛子。是名略说菩萨第八菩萨不动地。若广说者于无量劫数不能尽。菩萨住是地中。多作大梵天王主千世界自在最胜。与诸众生声闻辟支佛菩萨波罗蜜道无有穷尽。说世间性差别中无能坏者。所作善业布施爱语利益同事。是诸福德皆不离念佛念法念僧念菩萨念菩萨行念波罗蜜念十地念不坏力念无畏念不共佛法。乃至不离念一切种一切智智。常生是心我当于一切众生中为首为胜为大为妙为微妙为上为无上为导为将为师为尊。乃至为一切智智依止者。复从是念发精进行。以精进力故于一念间得百万三千大千世界微尘数三昧。见百万三千大千世界微尘数诸佛。能知百万三千大千世界微尘数佛神力。能动百万三千大千世界微尘数世界。能入百万三千大千世界微尘数佛世界。能照百万三千大千世界微尘数佛世界。能化百万三千大千世界微尘数佛世界众生。能住寿百万三千大千世界微尘数劫。能知过去未来世各百万三千大千世界微尘数劫事。能善入百万三千大千世界微尘数法门。能变身为百万三千大千世界微尘数。于一一身能示百万三千大千世界微尘数菩萨以为眷属。若以愿力自在胜上。菩萨愿力过于此数。示种种神通。或身或光明或神通或眼或境界或音声或行或庄严或加或信或业。是诸神通乃至无量百千万亿那由他劫不可数知

论曰。从诸佛受本世界差别等诸法明者。彼因相故。阎浮提王真金作庄严具譬者。得清净地身心胜故。善根光明转更明净示现。如经佛子譬如千世界主大梵天王乃至令得清凉故。余如前说

十地经论不动地第八卷之十十地经论善慧地第九卷之十一

        天亲菩萨造

        后魏北印度三藏菩提流支译

论曰。第九地中有四分差别。一法师方便成就。二智成就。三入行成就。四说成就。第八地中但净佛国土教化众生。此第九地中辩才力故。教化众生成就一切相。能教化故此胜彼故。云何法师方便成就

经曰。尔时金刚藏菩萨言。佛子。菩萨以如是无量智善思量智。更求转胜深寂灭解脱。复转求如来究竟智慧。入如来深密法中。思惟选择不思议大智慧。选择诸陀罗尼三昧及智令清净故。现诸神通广大行。通达世界差别行。修如来力无畏不共佛法无障调柔。通达如来转法轮庄严事。不舍大悲大愿力。得入第九菩萨地

论曰。是中法师方便成就者。依他利益自利益。一一五三句示现。依无色得解脱想可化众生作利益故。如经尔时金刚藏菩萨言佛子菩萨以如是无量智善思量智更求转胜深寂灭解脱故。依未得究竟佛智自利益。如经复转求如来究竟智故。依根熟菩萨。依邪念修行可化众生。依未知法众生。转法轮令得知。依邪归依众生。依信生天众生。如是次第五句示利益他行。如经入如来深密法中故。思惟选择不思议大智慧故。选择诸陀罗尼三昧及智令清净故。现诸神通广大行故。通达世界差别行故。示清净国土。转信生天众生令入佛法故。依正觉依转法轮依涅槃。此如是次第三句示自利益行。如经修如来力无畏不共佛法无障调柔故。通达如来转法轮庄严事故。不舍大悲大愿力。得入第九菩萨地故。不舍利益众生。大涅槃示现。以得不舍大悲大愿力故。应知如是九地法师方便成就分已说。云何智成就

经曰。是菩萨住此菩萨善慧地中。如实知善不善无记法行。有漏无漏法行。世间出世间法行。思议不思议法行。定不定法行。声闻辟支佛法行。菩萨行法行。如来地法行。有为法行。如实知无为法行

论曰。是中智成就者。依何等法说法。应知彼法净染不二。如经是菩萨住此菩萨善慧地中如实知善不善无记法行故。于净法中有有漏无漏。如经有漏无漏法行故。复无漏法中。有世间出世间法行。如经世间出世间法行故。复彼法有思议不思议。如经思议不思议法行故。彼思议复有定不定。如经定不定法行故。彼复于三乘中。如经声闻辟支佛法行故。菩萨行法行如来地法行故。彼复三乘法中。示有为无为依顺行。如经有为法行如实知无为法行故。如是九地智成就分已说。云何入行成就

经曰。是菩萨。随顺如是智慧。如实知众生心行稠林。烦恼行稠林。业行稠林。根行稠林。信行稠林。性行稠林。深心行稠林。使行稠林。生行稠林。习气行稠林。如实知三聚差别行稠林

论曰。是中入行成就者。依共依烦恼业生共染烦恼染净等。依定不定时。如经是菩萨随顺如是智慧如实知众生心行稠林故。乃至三聚差别行稠林故。彼复定不定时根等。次第根等相似信等。如经根行稠林故。信行稠林故。性行稠林故。深心行稠林故。使行稠林故。生行稠林故。习气行稠林故。如实知三聚差别行稠林故。稠林者。众多义故难知义故。行者不正信义故。云何心行稠林差别

经曰。是菩萨如实知众生诸心种种相。心杂相。心轻转生不生相。心无形相。心无边一切处众多相。心清净相。心染不染相。心缚解相。心幻起相。心随道生相。乃至无量百千种种心差别相。皆如实知

论曰。是中心行稠林差别者。心种种差别异故。如经是菩萨如实知众生心种种相故。彼心种种相。有八种。一差别相。心意识六种差别故。如经心杂相故。二行相。住异生灭行故。如经心轻转生不生相故。三第一义相。观彼心离心心身不可得故。如经心无形相故。四自相顺行无量境界取故。如经心无边一切处众多相故。五自性不染相。如经心清净相故。六同烦恼不同烦恼相。如经心染不染相故。七同使不同使相。如经心缚解相故。八因相。诸菩萨以愿力生余众生自业力生故。如经心幻起相故。心随道生相故。乃至无量百千种种心差别相皆如实知故。以自性清净心故。第六第七心染不染故。心缚解故。此二句烦恼染示现。第八句心随道故。生染示现。云何烦恼行稠林差别

经曰。是菩萨。如实知诸烦恼深入相。行无边相。共生不离相。烦恼使一义相。心相应不相应相。随道生处得报相。三界中差别相。爱无明见箭大过相。三种业因不断相。略说乃至如实知八万四千烦恼行差别相

论曰。烦恼行稠林差别者。三种事示现。一远入乃至有顶故。如经是菩萨如实知烦恼深入相故。二难知无量善根等修集行故。如经行无边相故。三染业烦恼生染故。是中随所缚以何缚及所缚事此事说烦恼染染事示现。如经共生不离相故。烦恼使一义相故。心相应不相应相故。是中随所缚者。迭共同事迭共相依共生不离故。以何缚者。谓使以有使故。不得解脱烦恼使一义故。所缚事者。谓心心相应不相应故。不相应者。示可得解脱故。身事生道界因故。生烦恼染示现。如经随道生处得报相故。三界中差别相故。于三分中业因障解脱故。随顺世间身口意业故。不断起因故。业烦恼妄想染示现如经爱无明见箭大过相故。三种业根本不断相故。乃至如实知八万四千烦恼行差别相故。三分者。一爱行欲众生。二无戒众生。三外道众生。云何业行稠林差别

经曰。是菩萨如实知诸业善不善无记相。有作未作相。心共生不离相。因自性尽集果不失次第相。有报无报相。黑业白业黑白业不黑不白业正受业差别相。业因无量相。圣世间差别相。现报生报后报相。乘非乘定不定相。乃至如实知八万四千诸业差别相

论曰。业行稠林差别者。道因差别示现。如经是菩萨如实知诸业善不善无记相故。自性差别。如经有作未作相故。方便差别。如经心共生不离相故。尽集果差别。如经因自性尽集果不失次第相故。已受果未受果差别。如经有报无报相故。对差别。如经黑业白业黑白业不黑不白业正受业差别相故。因缘差别。如经业因无量相故。未集已集差别。如经圣世间差别相故。定不定报差别。如经现报生报后报相故。乘非乘定不定相故。乃至如实知八万四千诸业差别相故。是中自性差别有二种业。一筹量时。二作业时。方便差别者。心共生熏心不别生果故。尽集果差别者。无始时业自然。念念灭坏集不失故。有为作业因尽集故。已受果未受果差别者。生报后报受不受应知。对差别者。黑业对白业。白业对黑业。不黑不白业对二业。二业对不黑不白业。业集成就差别应知。定不定差别者。三种时定不定故。三种乘定不定故。非乘者。世间定不定应知。云何根行稠林差别

经曰。是菩萨如实知诸根濡中上差别相。先际后际别异不别异相。上中下相。烦恼共生不离相。乘非乘定不定相。淳熟定相。随根网轻转坏取相相。根增上不坏相。转不转根差别相。深入共生种种差别相。略说乃至如实知八万四千诸根差别相。是菩萨如实知众生信濡中利相。略说乃至如实知八万四千信差别相。是菩萨如实知诸性濡中上相。略说乃至如实知八万四千诸性差别相。是菩萨如实知心濡中上相。略说乃至如实知八万四千心差别相

论曰。根行稠林差别有九种。一说器差别。如经是菩萨如实知诸根濡中上差别相故。二根转差别。如经先际后际别异不别异相故。三性差别。如经上中下相故。四烦恼染差别。如经烦恼共生不离相故。五定不定差别。如经乘非乘定不定相故。淳熟定相故。六顺行差别。如经随根网轻转坏取相相故。七声闻净差别。如经根增上不坏相故。八菩萨净差别。如经转不转根差别相故。九示一切根摄差别。如经深入共生种种差别相故。略说乃至如实知八万四千诸根差别相故。是中根转差别者。前后根前根下增平故。性差别者。于三乘中性差别故。烦恼染差别者。喜乐等诸根随烦恼习使染故。定不定差别者。于三乘中于世间中定不定熟不熟故。是中小乘不定根众生。菩萨令转向大乘故。定根者。菩萨令度二乘中解脱报定者。舍顺行差别者。有三种顺行。一身依顺行迭共相缚六入展转故。二生灭顺行轻坏故。三观行取相故。声闻净差别者。行增上障灭能成义故。菩萨净差别者。转不转地差别故。一切根摄差别者。始行方便报熟根差别故。信性心濡中上等无量差别相皆如实知。如经是菩萨如实知众生信濡中上相。乃至如实知八万四千心差别相故。如是性入应知。云何使行稠林差别

经曰。是菩萨如实知诸使深共生心共生相。心相应不相应不离相。远入相。无始来不恐怖相。一切禅定解脱三昧三摩跋提神通正修相违相。坚系缚三界系相。无始来心相续集相。开诸入门集相。得对治实相。地入随顺不随顺相。不异圣道灭动相。略说乃至如实知八万四千种种使差别相

论曰。是中使者。随逐缚义故。此使行稠林差别者。何处随逐以何随逐此事差别示现。何处随逐者。报非报心。如经是菩萨如实知使深共生心共生相故。心不离现事故。欲色无色上中下差别。如经心相应不相应不离相故。随顺乃至有顶。如经远入相故。无边世界唯智怖畏如怨贼未曾有闻思修智是故不灭。如经无始来不恐怖相故。世间禅定等不能灭心随顺行。如经一切禅定解脱三昧三摩跋提神通正修相违相故。以何随逐者。有六种随逐。六种随逐者六句说。一者有不断随逐。以有不断相。似使作缚故。如经坚系缚三界系相故。二远时随逐故。如经无始来心相续集相故。三一身生随逐故。眼等诸入门六种生集识同生随逐故。及阿黎耶熏故随逐。如经开诸入门集相故。四不实随逐。对治实义故。如经得对治实相故。五微细随逐。于九地中六入处烦恼身随逐故。如经地入随顺不随顺相故。六离苦随逐。出世间行余行不能离故。如经不异圣道灭动相故。略说乃至如实知八万四千种种使差别相故。云何生行稠林差别

经曰。是菩萨如实知诸生差别相。随业生相。地狱畜生饿鬼阿修罗人天差别相。有色无色生差别相。有想无想生差别相。业是田。爱是水。无明是黑闇。识是种子。后身是生芽相。名色共生而不离相。有痴求爱相续相。欲受欲生乐众生相续无际相。贪着三界相出相。皆如实知

论曰。生行稠林差别有八种。一身种种。如经是菩萨如实知诸生差别相故。二业种种。如经随业生相故。三住处种种。如经地狱畜生饿鬼阿修罗人天差别相故。四色相上下种种。如经有色无色生差别相故。有想无想生差别相故。五同外色因种种。如经业是田爱是水无明是黑闇识是种子后身是生芽相故。六自相种种。如经名色共生而不离相故。七本顺生因种种。如经有痴求爱相续相故。八集苦谛种种差别示现。如经欲受欲生乐众生相续无际相故。贪着三界相出相皆如实知故。是中欲爱者。乐贪共取处处求故。欲生者。复有乐有众生爱自身他身心着相往来上下界取着故。小大无量无想相出有轮展转苦谛差别示现。云何习气行稠林差别

经曰。是菩萨如实知习气行不行差别相。随道生处熏有习气。随共众生行有习气。随业烦恼有习气。随善不善无记法有习气。后有有习气。次第随逐有习气。深入不断烦恼牵有习气。有实不实有习气。声闻辟支佛菩萨如来见闻亲近熏有习气。皆如实知

论曰。习气行稠林差别有十种。一与果现在非现在差别。如经是菩萨如实知习气行不行相故。二道熏差别。如经随道生处熏有习气故。三亲近众生熏差别。如经随共众生行行有习气故。四功业烦恼熏差别。如经随业烦恼有习气故。五善业等熏差别。如经随善不善无记法有习气故。六中阴熏差别。如经后有有习气故。七与果次第熏差别。如经次第随逐有习气故。八离世间禅因熏差别。远入熏不断烦恼烦恼牵故。如经深入不断烦恼牵有习气故。九同法异外道行解脱熏差别。如经有实不实有习气故。十乘熏差别示现。如经声闻辟支佛菩萨如来见闻亲近熏有习气皆如实知故。云何三聚行稠林差别

经曰。是菩萨如实知众生三聚正定相邪定相离此二不定相。正见正定相邪见邪定相离此二不定相。五逆邪定相五根正定相。离此二不定相。八邪邪定相正位正定相。更不作故离此二不定相。妒吝恶行不转邪定相修行无上圣道正定相。离此二不定相。皆如实知。佛子。菩萨随顺如是智。名为安住菩萨善慧地

论曰。众生三聚行稠林差别有五种。一有涅槃法无涅槃法三乘中一向定差别。如经是菩萨如实知众生三聚正定相邪定相离此二不定相故。二善行恶行因差别。如经正见正定相邪见邪定相离此二不定相故。三恶道善道因差别。如经五逆邪定相五根正定相离此二不定相故。四外道声闻因差别。如经八邪邪定相正位正定相更不作故离此二不定相故。五菩萨差别示现。如经妒吝恶行不转邪定相修行无上圣道正定相离此二不定相皆如实知故。舍可化众生名妒。不喜施他财名吝过能生他苦恶行不转。菩萨波罗蜜相违邪定菩萨。是名法师方便成就智成就入行成就。三种事成就此地中善住。如经佛子菩萨随顺如是智名为安住菩萨善慧地故。云何说成就与众生解脱方便故

经曰。是菩萨。住此菩萨善慧地已。如实知众生如是诸行差别相。随其解脱而与因缘。是菩萨如实知化众生法。如实知度众生法。说声闻乘法。说辟支佛乘法。说菩萨乘法。如实知说如来地法。是菩萨如是知已。如实为众生说法令得解脱。随心差别随使差别。随根差别随信差别。随境界差别。种种行习气。随顺一切境界智随顺性行稠林。随生烦恼业习气转。随聚差别。随乘信令得解脱而为说法

论曰。说成就者。随其解脱而与因缘。如经是菩萨住此菩萨善慧地已如实知众生如是诸行差别相随其解脱而与因缘故。彼说成就。复三种相示现。一智成就。二口业成就。三法师成就。智成就者。随所知随所依此事说应知。何者随所知说。解脱器得熟故。解脱体正度故。解脱差别以三乘差别故。如经是菩萨如实知化众生法乃至如实知说如来地法故。何者随所依说。所说法对器故。随应度者。授对治法故。是义二句说所说法器成随根随信而为说法此义二句说。如经是菩萨如是知已如实为众生说法令得解脱随心差别随使差别随根差别随信差别故。随譬喻解器。如经随境界差别种种行习气故。随种种异行器。如经随顺一切境界智故。乃至得成就器。如经随顺性行稠林故。随辞辩器彼生烦恼业熏同行故。如经随生烦恼业习气转故。定不定根转器。如经随聚差别故。随乘因能乘出器。如经随乘信令得解脱而为说法故。云何智业成就

经曰。是菩萨住此菩萨善慧地中。略说作大法师。住在大法师深妙义中。守护诸佛法藏

论曰。是中说者持者二句示现。住在大法师深妙义中者。有二十种能作法师事。云何能作法师事。一者时。二者正意。三者顿。四者相续。五者渐。六者次。七者句义渐次。八者示。九者喜。十者劝。十一者具德。十二者不毁。十三者不乱。十四者如法。十五者随众。十六者慈心。十七者安隐心。十八者怜愍心。十九者不着利养名闻。二十者不自赞毁他。是中时者无八难故。如偈说

  如王怀忧恼　　病恚着诸欲
  险处无侍卫　　谗佞无忠臣
  如是八难时　　智臣不应语
  心王亦如是　　非时不应说

正意者。正威仪住非不正住。此义云何。自立他坐不应为说法。如是等如戒经中广说。何以故诸佛菩萨敬重法故。以敬法故。令他生尊重心。闻法恭敬摄心听故。顿者。是菩萨正意。为一切众说一切法。离悭法垢故。相续者。说无休息舍诸法中嫉妒意故。渐者。如字句次第说故。次者。如字句次第义。亦如是说故。句义渐次者。说同义法不说不同义法故。示者。示所应示等故。喜者。喜所应喜故。劝者怯弱众生助令勇猛故。具德者。现智比智阿含所证具说故。不毁者。随顺善道说故。不乱者。不动不杂正入非稠林故。如法者。具说四圣谛故。随众者。于四众八部随所应闻而为说法故。如是十五种相。菩萨随顺利益他说一切法故。慈心者。于怨众生中起慈心说法故。安隐心者。于恶行众生中起利益心说法故。怜愍心者。于受苦乐放逸众生中起怜愍利乐心说法故。不着利养名闻者。心不悕望常行远离故。不自赞毁他者。离我慢嫉妒随烦恼为众生说法故。如是五种相。菩萨自心清净故。具此二十事能作法师。是名住大法师深妙义中故。如是说成就中智成就已说。云何口业成就

经曰。通达无量智方便四无碍智。起菩萨言辞说法。是菩萨日夜常不坏四无碍智。何等为四。所谓法无碍。义无碍。辞无碍。乐说无碍

论曰。口业成就者。菩萨以四无碍言音说法。如经通达无量智方便乃至乐说无碍故。不坏者。不动故。是中四无碍境界者。一法体。二法境界体。三正得与众生。四正求与无量门。是中法体者。远离二边生法所摄如色碍相如是等。法境界体者。彼远离二边生法所摄中。如实智境界。菩萨如彼生法所摄智境界中住如色。何者是色眼色等虚妄分别如是等。正得与众生者。于彼如实智境界中随他所喜言说正知随他言说正知而与故。正求与无量门者。于彼随他所喜言语正知无量种种义语随知而与故。是四无碍智十种差别。一依自相。二依同相。三行相。四说相。五智相。六无我慢相。七小乘大乘相。八菩萨地相。九如来地相。十作住持相。后五是净相。云何自相

经曰。是菩萨用法无碍智知诸法自相。以义无碍智知诸法差别相。以辞无碍智知不坏说诸法。以乐说无碍智知诸法次第不断说

论曰。是中自相者。有四种。一生法自相。二差别自相。三想坚固自相。四彼想差别自相。如经是菩萨用法无碍智知诸法自相故。以义无碍智知诸法差别相故。以辞无碍智知不坏说诸法故。以乐说无碍智知诸法次第不断故。是中不坏说者。随所觉诸相随彼彼众生种种说法故。次第不断说者。次第不息无量众多异名为坚固彼义故。云何同相

经曰。复次以法无碍智知诸法无体性。以义无碍智知诸法生灭相。以辞无碍智知诸法假名而不断假名法说。以乐说无碍智随假名不坏无边法说

论曰。是中同相有四种。一者一切法同相。二者一切有为法同相。三者一切法假名同相。四者假名假名同相。如经复次以法无碍智知诸法无体性故。以义无碍智知诸法生灭相故。以辞无碍智知诸法假名而不断假名法说故。以乐说无碍智随假名不坏无边法说故。是中无常门入无我义中。第二同相初智境界成。是中知诸法假名。而不断假名法者。假名法以余假名法说。随假名不坏无边法者。不坏前假名而能异假名说。云何行相

经曰。复次以法无碍智知现在诸法差别。以义无碍智知过去未来诸法差别。以辞无碍智知过去未来现在诸法。以不坏说法。以乐说无碍智于一一世得无量法明故说法

论曰。是中行相者有四种。一生行相。二已生未生行相。三物假名行相。四说事行相。如经复次以法无碍智知现在诸法差别故。以义无碍智知过去未来诸法差别故。以辞无碍智知过去未来现在诸法以不坏说法故。以乐说无碍智于一一世得无边法明故。说法故一一世现在世故。过去未来彼彼世间摄受应知。见过去未来世知现在世。如是彼菩萨智境界成就。事行相者。不出三世中应知。无量法明者。异异法明应知。云何说相

经曰。复次以法无碍智知诸法差别。以义无碍智知诸法义差别。以辞无碍智随诸言音而为说法。以乐说无碍智随所乐解而为说法

论曰。是中说相者有四种一修多罗说相。二彼解释说相。三随顺说相。四相似说相。如经复次以法无碍智知诸法差别故。以义无碍智知诸法义差别故。以辞无碍智随诸言音而为说法故。以乐说无碍智随所乐解而为说法故。是中随诸言音说者。随彼众生言音说故。随所乐解说者。随诸众生所有心念。乃至随所有种种譬喻说。云何智相

经曰。复次以法无碍智以法智知诸法差别不坏方便。以义无碍智以比智如实知诸法差别。以辞无碍智以世智正见故说法。以乐说无碍智以第一义智方便故说法

论曰。是中智相者。有四种。一现见智。二比智。三欲得方便智。四得智。如经复次以法无碍智以法智知诸法差别不坏方便故。以义无碍智以比智如实知诸法差别故。以辞无碍智以世智正见故说法。以乐说无碍智以第一义智方便故说法。是中法智者。知谛差别不异方便法智差别不坏方便故。比智者。如此如实分别余亦如是。比智如实谛差别知故。第一义智方便者。非颠倒异说应知。云何无我慢相

经曰。复次以法无碍智知诸法一相不坏。以义无碍智知阴界入谛因缘集方便。以辞无碍智知一切世间之所归敬善妙音声字句说法。以乐说无碍智所说转胜无量法明说法

论曰。是中无我慢相者。有四种。一第一义谛无我慢相。二世谛无我慢相。三说美妙无我慢相。四说无上无我慢相。如经复次以法无碍智知诸法一相不坏故。以义无碍智知阴界入谛因缘集方便故。以辞无碍智知一切世间之所归敬善妙音声字句说法故。以乐说无碍智所说转胜无量法明说法故。是中一相不坏者。无我不坏故。我知无我我证无我。如是等坏阴等方便入无我故。是故彼菩萨智境界成。一聚积着我。二异因着。三欲着。四作着。此对治如是次第。阴等方便应知。云何小乘大乘相

经曰。复次以法无碍智知诸法无有差别摄在一乘。以义无碍智知分别诸乘差别门。以辞无碍智能说诸乘不坏。以乐说无碍智于一一乘无量法明说

论曰。是中小乘大乘相者。有四种。一观相。二性相。三解脱相。四念相。如经复次以法无碍智知诸法无有差别摄在一乘故。以义无碍智知分别诸乘差别门故。以辞无碍智能说诸乘不坏故。以乐说无碍智于一一乘无量法明说故。是中知诸法无有差别摄在一乘者。一观不异应知。能说诸乘不坏者。依同解脱不惧。无量法明说者。种种法明分别说故。随可度者依种种念行随顺解脱。云何菩萨地相

经曰。复次以法无碍智知一切菩萨行法行智行随智入。以义无碍智知分别说十地义差别入。以辞无碍智不坏说与随顺诸地道。以乐说无碍智说一一地无量相

论曰。是中菩萨地相者。有四种。一智相。二说相。三与方便相。四入无量门相。如经复次以法无碍智知一切菩萨行法行智行随智入故。以义无碍智知分别说十地义差别入故。以辞无碍智知不坏说与随顺诸地道故。以乐说无碍智说一一地无量相故。是中一切菩萨行者。法行智行示现观智说故。十地差别者。谓心说者口言应知。不坏说与随顺诸地道者。不颠倒教授故。云何如来地相

经曰。复次以法无碍智知一切佛于一念间得正觉。以义无碍智知种种时事相差别。以辞无碍智随正觉差别说。以乐说无碍智于一一句法无量劫说而不穷尽

论曰。是中如来地相者。有四种。一法身相。二色身相。三正觉相。四说相。如经复次以法无碍智知一切佛于一念间得正觉故。以义无碍智知种种时事相差别故。以辞无碍智随正觉差别说故。以乐说无碍智。于一一句法无量劫说而不穷尽故。是中时者。随何劫中成何等佛事者。随以何等佛国土。随何等佛身相者。随名所记可得见闻故。随正觉者。依十种佛如正觉应知。云何作住持相

经曰。复次以法无碍智知一切佛语力无畏不共佛法大悲无碍智行转法轮随顺一切智智。以义无碍智知随顺如来音声出八万四千随众生心随根随信差别。以辞无碍智一切众生行以如来音声不坏说。以乐说无碍智。以诸佛智行神通圆满。随信说法

论曰。是中作住持相者。有四种。一觉相。二差别相。三说相。四彼无量相。如经复次以法无碍智知一切佛语力无畏不共佛法大悲无碍智行转法轮随顺一切智智故。以义无碍智知随顺如来音声出八万四千随众生心随根随信差别故。以辞无碍智一切众生行以如来音声不坏说故。以乐说无碍智以诸佛智行神通圆满随信说法故。是中佛语者。能说法故。力者。能破憍慢众生故。无畏者。能降伏外道故。不共佛法者。不同声闻辟支佛故。大悲者。常能说法故。无碍智行者。依彼说法故。转法轮者。随顺说法故。此一切事一切智智通达知故。随心者。随心性应知。诸佛智行神通圆满者。诸佛法身此行为利益众生行不可坏故。言圆满随彼信故。示现菩萨无尽乐说。如是口业成就已说。云何法师自在成就。四种事示现。一持成就。二说成就。三问答成就。四受持成就。云何持成就

经曰。佛子菩萨如是善知无碍智。安住第九菩萨地。名为得诸佛法藏能作大法师。得众义陀罗尼。众法陀罗尼。起智陀罗尼。光明陀罗尼。善意陀罗尼。众财陀罗尼。威德陀罗尼。无障碍门陀罗尼。无量陀罗尼。得种种义陀罗尼。得如是等陀罗尼门。满足十阿僧祇百千陀罗尼门。如是十阿僧祇百千音声方便。如是十阿僧祇百千无量信乐门差别说法。是菩萨得如是十阿僧祇百千无量陀罗尼门。能于无量诸佛所听法闻已不忘。如所闻法能以无量差别门为人演说

论曰。持成就者。有十种陀罗尼。一义陀罗尼。如经得众义陀罗尼故。二闻陀罗尼。如经得众法陀罗尼故。三智陀罗尼。如经起智陀罗尼故。四放光陀罗尼。如经光明陀罗尼故。五降伏他陀罗尼。如经善意陀罗尼故。六供养如来布施摄取贫穷众生陀罗尼。如经得众财陀罗尼故。七于大乘中狭劣众生。示教利益陀罗尼。如经威德陀罗尼故。八不断辩才陀罗尼。如经得无障碍门陀罗尼故。九无尽乐说陀罗尼。如经得无量陀罗尼故。十种种义乐说陀罗尼。如经得种种义陀罗尼故。乃至随所闻无量差别说如是等。余经文。说成就问答成就受持成就。如经说应知。易解故不释。余如前说

经曰。是菩萨于一佛所以十阿僧祇百千陀罗尼门听受法。如从一佛听法。余无量无边诸佛亦复如是。是菩萨于礼敬佛时所闻法明门能受。非多学声闻。得大陀罗尼力。于十万劫所能受持。是菩萨得如是陀罗尼力及无碍智乐说力说法。说法时在于法座。遍一切三千大千世界随众生心差别说法。是菩萨法座。唯除诸佛及受职菩萨于一切中最为殊胜。得无量法明。是菩萨处于法座。或以一音说。令一切大众悉得解了。即得解了。或以种种音说。令一切大众各得开解。即得开解。或但放光明说。令一切大众各得解法。即得解法。或以一切毛孔皆出法音。或以三千大千世界所有色物皆出法音。或以一音周遍一切法界皆令得解。或以一切音声法声住持。或于一切世界歌咏乐音一切音声皆出法音。或于一字声中一切法字句声皆差别说。或于不可说世界无量地水火风聚细微尘差别一一微尘中不可说法门皆悉能说。是菩萨三千大千世界所有众生于一念间一时问难。彼一一众生以无量音声差别问难。如一人所问余者异问。是菩萨于一念间悉受如是问难。但以一音皆令开解。如是二三千大千世界。若三四五。若十二十三十四十五十。若百三千大千世界。若千三千大千世界。若万十万百万若亿三千大千世界。若十亿百千万亿那由他。乃至无量无边不可说不可说三千大千世界满中众生。于一念间一时问难。彼一一众生以无量音声差别问难。如一人所问余者异问。是菩萨于一念间悉受如是问难。但以一音皆令开解

是菩萨于不可说不可说世界遍满其中。随心随根随信为众生说法得法明故。求如来力满足佛事。与一切众生而作依止

是菩萨转倍精进摄取如是智明。若于一一毛头处。有不可说不可说世界微尘数如来大会。佛在其中而为说法。一一如来为不可说不可说世界微尘数众生说法。一一众生心中有不可说不可说世界微尘数心生如来。如是随众生心而与法门。如一佛一切佛在一一毛头处亦如是。如是一切法界中。于是中生大忆念力。于一念间从一切佛所受一切法明而不失一句。何况所说一切世界中众生

是菩萨住此菩萨善慧地中。转胜昼夜更无余念入佛境界。常得亲近一切诸佛。通达甚深菩萨解脱。是菩萨随顺如是智。常入三昧不离亲近诸佛。而于一一劫中见无量佛无量百佛无量千佛无量百千佛无量百千那由他佛无量亿佛无量百亿佛无量千亿佛无量百千亿佛无量百千亿那由他佛。以上妙供具供养恭敬尊重赞叹亲近诸佛。于诸佛所种种问难通达说法陀罗尼。是菩萨彼诸善根转胜明净。佛子譬如本真金作庄严具。已系在转轮圣王若颈若顶。一切小王四天下人。所有一切诸庄严具无能及者。如是佛子。菩萨住此菩萨善慧地中。彼诸善根转胜明净。一切声闻辟支佛及下地菩萨所不能坏。是菩萨善根转明。能照众生烦恼心稠林处。照已还摄。佛子。譬如大梵王二千世界中所有一切深稠林处皆悉能照。如是佛子。菩萨住此菩萨善慧地中。彼诸善根光明照诸众生烦恼心稠林处。照已还摄。是菩萨十波罗蜜中。力波罗蜜增上。余波罗蜜非不修习随力随分。佛子。是名略说菩萨第九菩萨善慧地。若广说者。于无量劫说不可尽。菩萨住此地中。多作大梵天王得大势力主二千世界。于自在中而得自在。如实正解最为殊胜善能宣说。声闻辟支佛菩萨波罗蜜行众生问难无能穷尽。所作善业布施爱语利益同事。是诸福德。皆不离念佛念法念僧念菩萨念菩萨行念波罗蜜念十地念不坏力念无畏念不共佛法。乃至不离念一切种一切智智。常生是心。我当于一切众生中为首为胜为大为妙为微妙为上为无上为导为将为师为尊。乃至为一切智智依止者。复从是念发精进行。以精进力故。于一念间得十阿僧祇百千佛国土微尘数三昧。见十阿僧祇百千佛国土微尘数佛。知十阿僧祇百千佛国土微尘数佛神力。能动十阿僧祇百千佛国土微尘数世界。能入十阿僧祇百千佛国土微尘数世界。能照十阿僧祇百千佛国土微尘数世界。能化十阿僧祇百千佛国土微尘数世界众生。能住寿十阿僧祇百千佛国土微尘数劫。能知过去未来世各十阿僧祇百千佛国土微尘数劫事。能善入十阿僧祇百千佛国土微尘数法门。能变身为十阿僧祇百千佛国土微尘数。于一一身能示十阿僧祇百千佛国土微尘数菩萨以为眷属。若以愿力自在胜上菩萨愿力。过于此数示种种神通。或身或光明或神通或眼或境界或音声或行或庄严或加或信或业。是诸神通乃至无量百千万亿那由他劫不可数知

十地经论善慧地第九卷之十一十地经论法云地第十卷之十二

        天亲菩萨造

        后魏北印度三藏菩提流支译

论曰。菩萨于九地中已作净佛国土及化众生。第十地中修行令智觉满足。此是胜故。此地中有八分差别。一方便作满足地分。二得三昧满足分。三得受位分。四入大尽分。五地释名分。六神通力无上有上分。七地影像分。八地利益分。云何方便作满足地分

经曰。尔时金刚藏菩萨言。佛子。若菩萨如是无量智善观智。乃至第九菩萨地善择智。善满足清白法。集无量助道法。善摄大功德智慧。广行增上大悲。广知世界差别。深入众生界稠林行。念随顺入如来行境界。深入趣向如来力无畏不共佛法。名为得至一切种一切智智受位地

论曰。是中地方便作满足地分者。于初地至九地中善择智业应知。如经佛子若菩萨如是无量智善观智。乃至第九菩萨地善择智故。此善择智有七种相。一善修行故。有三句。如经善满足清白法集无量助道法善摄大功德智慧故。此诸句次第相释应知。二普遍随顺自利利他故。如经广行增上大悲故。三令佛土净。如经广知世界差别故。四教化众生。如经深入众生界稠林行故。五善解。如经念随顺入如来行境界故。如来境界者。真如法故。六无厌足。如经深入趣向如来力无畏不共佛法故。七地尽至入。如经名为得至一切种一切智智受位地故。如是十地方便作满足地分已说。云何得三昧满足分

经曰。佛子。菩萨随顺行如是智。得入受位地。即得菩萨名离垢三昧而现在前。名入法界差别三昧。名庄严道场三昧。名一切种花光三昧。名海藏三昧。名海成就三昧。名虚空界广三昧。名善择一切法性三昧。名随一切众生心行三昧。名现一切诸佛现前住菩萨三昧而现在前。如是等上首十阿僧祇百千诸三昧门皆现在前。是菩萨皆悉入此一切三昧。善知三昧方便。乃至三昧所作正受。此菩萨乃至十阿僧祇百千三昧。最后三昧名一切智智受胜位菩萨三昧而现在前

论曰。得三昧满足者。离垢三昧等共眷属现前故。离垢三昧者。离烦恼垢故。而现在前者。不加功力自然现在前故。此离垢三昧复有九种三昧。离八种垢应知。一入密无垢。如经名入法界差别三昧故。二近无垢。如经名庄严道场三昧故。三放光无垢。如经名一切种花光三昧故。四陀罗尼无垢。如经名海藏三昧故。五起通无垢。如经名海成就三昧故。六清净佛土无垢有二句。无量正观故。如经名虚空界广三昧。名善择一切法性三昧故。七化众生无垢。如经名随一切众生心行三昧故。八正觉无垢。成菩提时一切诸佛迭共现前知故。如经名现一切诸佛现前住菩萨三昧而现在前故。乃至名一切智智受胜位菩萨三昧而现在前者。一切智智无分别一切智智平等。受位故。善知三昧方便。乃至三昧所作正受者。满足三昧事示现如是。十地得三昧满足分已说。云何得受位分

经曰。是三昧现在前时。即有大宝莲华王出。周圆如十阿僧祇百千三千大千世界。一切众宝间错庄严。过于一切世间境界。出世间善根所生。行诸法如幻性境界所成。光明普照一切法界。过一切诸天所有境界。大琉璃摩尼宝为茎。不可量栴檀王为台。大玛瑙宝为须。阎浮檀金为叶。华身有无量光明。一切众宝间错其内。无量宝网弥覆其上。满十三千大千世界微尘数等莲花以为眷属。如是成就具足诸相已。尔时菩萨其身姝妙称可花座。是菩萨得一切智智受胜位三昧力故。即时身在大宝莲花王座上坐。是菩萨在大宝莲花王座上坐时。尔时大宝莲花王眷属莲花座上皆有菩萨。一一菩萨皆坐莲花座上。围绕彼菩萨。一一菩萨各得十十百千三昧。皆一心恭敬瞻仰大菩萨

论曰。是中得受位者。随何等座随何等身量。随何等眷属。随何等相。随何等出处。随所得位。随如是说。六事应知。是中座处者有十种相。一生相。如经是三昧现在前时即有大宝莲花王出故。二量相。如经周圆如十阿僧祇百千三千大千世界故。三胜相。如经一切众宝间错庄严故。四地相。如经过于一切世间境界故。五因相。如经出世间善根所生故。六成相。如经行诸法如幻性境界所成故。七第一义相。如经光明善照一切法界故善照者。名为正观故。八功德相。过一切诸天故。如经过一切诸天所有境界故。九体相。茎台等。如经大琉璃摩尼宝为茎等。十庄严具足相。如经花身有无量光明一切众宝间错其内无量宝网弥覆其上故。随何等身量者。身称花座。如经尔时菩萨其身姝妙称可花座如是等。随何等眷属者。此坐处大宝莲花王座眷属菩萨眷属住在其中。如经尔时大宝莲花王眷属如是等

经曰。是菩萨升大宝莲花王座。及眷属菩萨坐莲花座入三昧已。尔时十方一切世界皆大震动。一切恶道皆悉休息。光明普照一切法界。一切世界皆悉严净。皆得见闻一切诸佛大会。何以故。佛子。是菩萨坐大宝莲花王座时。即时两足下放十阿僧祇百千光明。出已悉照十方无量阿鼻地狱等。灭众生苦恼。两膝放十阿僧祇百千光明。出已悉照十方无量畜生。灭除苦恼。脐轮放十阿僧祇百千光明。出已悉照十方无量饿鬼。灭除苦恼。左右胁放十阿僧祇百千光明。出已悉照十方无量人身。灭除苦恼。两手放十阿僧祇百千光明。出已悉照十方无量诸天阿修罗宫。两肩放十阿僧祇百千光明。出已悉照十方无量声闻人项背放十阿僧祇百千光明。出已悉照十方无量辟支佛身面门放十阿僧祇百千光明。出已悉照十方无量从初发心乃至得九地菩萨。白毫相放十阿僧祇百千光明。出已悉照十方无量得位菩萨身而住一切魔宫隐蔽不现。顶上放十阿僧祇百千三千大千世界微尘数光明。出已悉照十方一切诸佛大会。围绕一切世界十匝。住虚空中成大光明轮网台。名高大光明作大供养供养诸佛。如是供养从初发心乃至得九地菩萨所作供养诸佛。百分不及一。千分不及一。百千分不及一。百千那由他分不及一。亿分不及一。百亿分不及一。千亿分不及一。百千亿分不及一。百千亿那由他分不及一。乃至算数譬喻所不能及。是大光明轮网台胜十方世界所有华香末香烧香涂香散香花鬘衣服宝盖幢幡众宝璎珞摩尼宝珠供养之具。过于一切世间境界。以从出世间善根生故。一一佛大会上皆雨众宝。犹如大雨。若有众生觉知如是供养者。当知皆是必定不退无上大道。如是诸光明雨大供养已。彼一切光明悉照十方一切诸佛大会。围绕一切世界十匝。入诸佛足下。尔时彼诸佛及彼大菩萨。知某世界中某甲菩萨行如是菩萨道成就菩萨得位地时。又佛子。即时十方无边菩萨乃至住九地者。皆来围绕设大供养一心瞻仰。各得十十百千三昧诸得位地菩萨。于功德庄严金刚万字胸出一大光明名坏魔怨。有十阿僧祇百千光明以为眷属。出已悉照十方无量世界。示无量神力亦来入是大菩萨功德庄严金刚万字胸。此光明灭已。是菩萨即时得百千增上大势力功德智慧而现在前

论曰。随何等相者。一切世界动等相。如经是菩萨升大宝莲花王座乃至皆得见闻一切诸佛大会故。随何等出处者。以出光明故。复次光明三种业应知。一利益业。二发觉业。三摄伏业。如经何以故佛子是菩萨坐大莲花王座即时两足下放十阿僧祇百千光明乃至功德智慧而现在前故。必定不退无上大道。于地中决定义故。复有异义定不放逸。所作之事决定心故。功德庄严金刚万字胸者。于菩萨胸中有功德庄严金刚万字相。名为无比

经曰。如是佛子。尔时诸佛放眉间白毫相光。名益一切智通。有阿僧祇光明眷属。照于十方一切世界无有遗余十匝围绕一切世界。示于诸佛大神通力。劝发无量百千万亿诸佛。一切十方诸佛国土六种震动。灭除一切恶道苦恼。一切魔宫隐蔽不现。示一切诸佛得菩提处。示一切诸佛大会神通庄严之事。照明一切法界际。一切虚空界。尽一切世界已还来集。在一切菩萨大会之上周匝围绕。示大神通光明庄严之事。是光明入彼大菩萨顶上。其诸眷属光明入诸眷属莲花座上。菩萨顶上光明入是菩萨身时。彼诸菩萨各得先所未得十十百千三昧。彼诸光明一时入彼菩萨顶时。彼菩萨名为得位。入诸佛境界具佛十力堕在佛数。佛子。譬如转轮圣王长子玉女宝所生具足王相。转轮圣王令子在白象宝阎浮檀金座上。取四大海水。上张罗网宝盖幡华宝幢种种庄严。手执金钟香水灌子顶上。即名灌顶刹利王数。具足转十善道故。得名转轮圣王。如是佛子。彼菩萨从诸如来得受位已。名得智位。具足十力堕在佛数。佛子。是名菩萨大乘位地。菩萨为是位故。受无量百千万亿苦难行事。是菩萨得是位已。无量功德智慧转增。名为安住菩萨法云地

论曰。随所得位者。诸如来光明。彼菩萨迭互知平等摄受故。如经如是佛子尔时诸佛放眉间白毫相光名益一切智通如是等。云何得位如转轮圣王长子。如经譬如转轮圣王长子如是等。此菩萨同得位时。名为善住此地中。如经是菩萨得是位已无量功德智慧转增名为安住菩萨法云地。如是得受位分已说。云何入大尽分。入大尽分者。有五种。一智大。二解脱大。三三昧大。四陀罗尼大。五神通大此事依五种义分别应知。一依正觉实智义。二依心自在义。三依发心即成就一切事义。四依一切世间随利益众生义。五依堪能度众生义。云何智成就

经曰。佛子。是菩萨住此菩萨法云地。如实知欲界集色界集无色界集。如实知众生界集识界集。有为界集无为界集。虚空界集法界集。如实知涅槃界集。如实知邪见诸烦恼界集。世界成坏集。声闻行集。辟支佛行集菩萨行集。诸佛力无畏不共佛法色身法身集。一切种一切智智集。得菩提转法轮示灭度集。略说乃至如实知入一切法成智差别集。是菩萨以如是智通达胜慧。如实知众生业化。烦恼化见作化。世界化法界化。声闻化辟支佛化。菩萨化如来化。如实知一切分别无分别化。是菩萨如实知佛力持法持僧持。业持烦恼持时持。愿持供养持。行持劫持。如实知智持。是菩萨如实知诸佛所有细微入智。所谓行细微入智。退细微入智。入胎细微入智。生细微入智。奋迅细微入智。出家细微入智。得菩提细微入智。转法轮细微入智。持寿命细微入智。示涅槃细微入智。如实知法久住细微入智。是菩萨如实知诸佛所有密处。所谓身密口密意密。筹量时非时密。与菩萨授记密。摄伏众生密。乘种种密。一切根行差别密。一切信如实所作密。如实知行得菩提密。是菩萨如实知诸佛所有入劫智。所谓一劫入阿僧祇劫。阿僧祇劫入一劫。有数劫入无数劫。无数劫入有数劫。一念劫入无量劫。无量劫入一念劫。劫入非劫。非劫入劫。有佛劫入无佛劫。无佛劫入有佛劫。有佛劫入有佛劫。无佛劫入无佛劫。过去未来劫入现在劫。现在劫入过去未来劫。未来过去劫入现在劫。现在劫入未来过去劫。长劫入短劫。短劫入长劫。短劫入短劫。长劫入长劫。如实知一切劫相相入。是菩萨如实知诸佛所有入智。所谓入凡夫道智。入微尘智。入国土身菩提智。入众生身心菩提智。入一切处随菩提智。入乱行示现智。入顺行示现智。入逆行示现智。入思议不思议智。入世间出世间智。行示现智。入声闻智。辟支佛智。菩萨智。如实知如来智行智。佛子。诸佛智慧如是广大无量无边。菩萨住此地即能得入如是智慧

论曰。是中智大复有七种应知。一集智大。二应化智大。三加持智大。四入细微智大。五密处智大。六入劫智大。七入道智大。是中初依能断疑力应知。第二依彼身起力。第三依彼如是如是转行力。第四依彼应化加持善集不二智作故。第五依护根未熟众生不令惊怖。第六依命行加持舍自在意故。第七依对治意说。是中集智者。因缘集智应知。彼复随所有分染。或净或灭。随所有三界处。随所有众生。随染净等心。随所有有为法无为法无知知故。随所有处虚空等。随所说正不正法。随所证不证。谓于涅槃随所邪见过余外道等彼不能证。随所有器世间坏成。随所有三乘。彼集差别应知。如经佛子是菩萨住此菩萨法云地。如实知欲界集。乃至如实知入一切法成智差别集故。是中应化智者。众生应化等差别应知。如经是菩萨以如是智通达胜慧乃至如实知一切分别无分别化故。是中烦恼见作化者。应化示烦恼染见作故。法界化者。所说法行故。彼应化一切分别无分别如实知故。是中加持智者。如经是菩萨如实知佛力持乃至如实知智持故。如经应知。是中智持者。一切智智故。此智能作一切事故。入细微智者。如经是菩萨如实知诸佛所有细微入智乃至如实知法久住细微入智故。如经应知。是中奋迅者。现行七步等应知。是中密处智者。如经是菩萨如实知诸佛所有密处。乃至如实知行得菩提密故。如经应知。是中入劫智者。所谓入劫。如经是菩萨如实知诸佛所有入劫智。所谓一劫入阿僧祇劫乃至如实知一切劫相相入故。如经应知。是中入者。平等解脱一切劫迭相入故。是中入道智者。依凡夫地依我慢行者。依信求生天者。依觉观者。如经是菩萨如实知诸佛所有入智。所谓入凡夫道智乃至即能得入如是智慧故。如是七种智大已说。云何解脱大

经曰。佛子。是菩萨如是通达此地行。得名菩萨不思议解脱门。无障碍解脱。净智差别解脱。普门光解脱。如来藏解脱。随顺不退轮解脱。入通达三世解脱。法界藏解脱。解脱光轮解脱。名得菩萨一切境界无余解脱。佛子。是菩萨十菩萨解脱门为首。得如是等无量无边百千万阿僧祇菩萨解脱门。皆于第十菩萨地中得如是乃至无量无边百千万阿僧祇三昧。无量无边百千万阿僧祇陀罗尼。无量无边百千万阿僧祇神通。亦复如是

论曰。是中解脱大者。一依神通境界。如经佛子是菩萨如是通达此地行得名菩萨不思议解脱门故。二能至无量世界愿智无碍。如经无障碍解脱故。三知世间出世间有学无学声闻辟支佛菩萨如来解脱智等。如经净智差别解脱故。四随意转事。如经普门光解脱故。五法陀罗尼。如经如来藏解脱故。六能破他言。如经随顺不退转轮解脱故。七三世劫随意住持。如经入通达三世解脱故。八一切法一切种因缘集智。如经法界藏解脱故。九光不离身而能普照。如经解脱光轮解脱故。十依一时知无量世界诸众生心。如经名得菩萨一切境界无余解脱故。是中三昧大者。如经如是乃至无量无边百千万阿僧祇三昧故。是中陀罗尼大者。如经无量无边百千万阿僧祇陀罗尼故。是中神通大者。如经无量无边百千万阿僧祇神通亦复如是故。如是十地入大尽分已说。云何地释名分

经曰。是菩萨通达如是智慧随顺菩提。成就无量念力方便毕竟。是菩萨于十方无量佛所。无量大法明。无量大法照。无量大法雨。于一念间皆悉能受能堪能思能持。佛子。譬如娑伽罗云澍大雨聚余地处不能受不能堪不能思不能持。唯除大海。如是佛子。一切如来秘密处。所谓大法明大法照大法雨。彼一切众生。一切声闻辟支佛。皆不能受不能堪不能思不能持。从初地乃至住九地菩萨。亦不能受不能堪不能思不能持。唯此住法云地菩萨。皆悉能受能堪能思能持。佛子。譬如大海。一大龙王起大云雨皆悉能受能堪能思能持。若二若三四五若十二十三十四十五十。若百龙王。若千若万若亿若百亿若千亿若百千亿那由他龙王。乃至无量无边不可称说诸大龙王起大云雨。于一念间一时澍下。皆悉能受能堪能思能持。所以者何。大海是无量广大器故。如是佛子。菩萨住此菩萨法云地中。于一佛所大法明大法照大法雨。皆悉能受能堪能思能持。若二若三四五若十二十三十四十五十。若百诸佛若千若万若亿若百亿若千亿若百千亿那由他诸佛。乃至无量无边不可称说诸佛所。大法明大法照大法雨。于一念间皆悉能受能堪能思能持。是故此地名为法云地。解脱月菩萨言。佛子。菩萨住此法云地几许佛所大法明大法照大法雨。于一念间能受能堪能思能持。金刚藏菩萨言。佛子。菩萨住此法云地。于不可数不可说佛所大法明大法照大法雨。于一念间皆悉能受能堪能思能持。佛子。譬如十方所有不可说百千万亿那由他佛国土微尘数等诸世界中所有众生。彼众生中一众生得闻持陀罗尼。无余为佛持者。最大声闻闻持陀罗尼第一。譬如金刚莲华上佛。有名大胜比丘。闻持陀罗尼第一。其一众生成就如是闻持陀罗尼力。如彼一众生余一切世界所有众生皆亦如是成就闻持陀罗尼力。其一人所受法第二人不重受。如是一切各各不同。佛子。于意云何。彼一切众生所受闻持陀罗尼力宁为多不。解脱月菩萨言。佛子。彼一切众生所受闻持陀罗尼力甚多无量。金刚藏菩萨言。佛子。我今当为汝说。是菩萨住此法云地。于一念间于一佛所名三世法界藏大法明大法照大法雨。皆悉能受能堪能思能持。彼大法明大法照大法雨。受持方便上说。一切众生闻持陀罗尼力。比此百分不及一。千分不及一。百千分不及一。百千那由他分不及一。亿分不及一。百亿分不及一。千亿分不及一。百千亿分不及一。百千亿那由他分不及一。乃至算数譬喻所不能及。如一佛所如前所说。十方世界微尘数等诸佛所。复过此数无量无边诸佛所。名三世法界藏大法明大法照大法雨。于一念间皆悉能受能堪能思能持。是故此地名为法云地。复次佛子。是菩萨住此法云地。自从愿力起大慈悲云。震大法雷音。通明无畏以为电光。大智慧光以为疾风。大福德善根为厚密云。现种种色身为杂色云。说正法雨破诸魔怨。于一念间如前所说。诸世界中所有微尘如是百千万亿那由他世界皆悉遍覆。复过此数无量无边百千万亿那由他世界亦皆遍覆澍大甘露善根法雨。灭除众生随心所乐无明所起烦恼尘焰。是故此地名为法云地。复次佛子。是菩萨住此菩萨法云地。于一世界中从兜率天退。入胎。住胎。初生。出家。得佛道。请转法轮。示大涅槃。一切佛事随所度众生得智自在。若三千大千世界乃至如前微尘数等世界。复过此数百千万亿阿僧祇世界。从兜率天退乃至示大涅槃。一切佛事随所度众生得智自在

论曰。是中地释名者。有三种。一云法相似。以遍覆故。此地中闻法相似如虚空身遍覆故。二灭尘除垢相似法。此法能灭众生烦恼尘故。三度众生从兜率天退乃至示大涅槃故渐化众生故。如大云雨生成一切卉物萌芽故。是中成就无量念力方便毕竟者。近说受持义故。如经是菩萨通达如是智慧随顺菩提成就无量念力方便毕竟故复能受持众多微密速疾持故。如经是菩萨于十方无量佛所无量大法明。如是等。是中无量诸佛无量大法明者。说众多故。入如来微密处故。一念间者。速疾受故。闻法者。性故作故。二事示现。云何性。大法光明故。闻思智摄受故。大法照修慧智摄受故。云何作大法雨。如大云与他法雨故。于中起信故。言受受所说字句故。言堪以能取义故。言思彼二摄受不失故。言持大海亦如是。以不浊故。言受能受一切水故。言堪余水数入失本名故。言思用不可尽故。言持应知。如经名三世法界藏大法明大法照大法雨皆悉能受能堪能思能持。乃至是故此地名为法云地故。是中名三世法界藏者。于法界中三种事藏。云雷电等譬喻相似法应知。如经复次佛子是菩萨住此法云地自从愿力乃至是故此地名为法云地故。是中大智慧光以为疾风者。风相似法。现种种色身者。随世间种种身回转。杂色云相似法故。说正法雨破诸魔怨者。雨相似法故。如是此地释名分已说。云何神通力无上有上分

经曰。是菩萨住在此地。于智慧中得上自在力。善择大智通随心所念。或以狭国为广。广国为狭。复随心念。或以垢国为净。净国为垢。如是广大无量乱住倒住正住等一切世界。自在力故种种能成。是菩萨复随心念。或于一微尘中示一世界所有一切铁围山等。然彼微尘而不增长。若二若三四五若十二十三十四十五十。若百若千若万若亿若百亿若千亿若百千亿若百千亿那由他世界。乃至不可说不可说世界所有一切铁围山等。入一微尘中。然彼微尘亦不增长。是菩萨复随心念。或以一世界庄严之事示二世界。复随心念。或以一世界庄严之事乃至示无量不可说不可说世界。复随心念。或以二世界庄严之事示一世界。乃至或以无量不可说不可说世界庄严之事示一世界。复随心念。乃至或以无量不可说不可说世界众生置一世界中。然诸众生而不恐怖不觉不知。复随心念。或以一世界众生乃至置无量不可说不可说世界中。然诸众生亦不恐怖不觉不知。复随心念。或于一毛道示一切佛境界庄严之事。复随心念。乃至或以无量不可说不可说一切佛境界庄严之事示一毛道。复随心念。于一念间示现无量不可说不可说世界微尘等身。于一一身中示如是等微尘数手以此诸手勤心供养十方诸佛。以一一手执恒河沙等花箱以散诸佛。如是花箱如是花鬘末香涂香熏香衣服宝盖幡花宝幢一切庄严事亦复如是。于一一身中示如是等微尘数头。于一一头中示如是等微尘数舌。以此诸舌赞叹诸佛功德之事。如是等事于念念中遍满十方。于念念中无量世界示得菩提。乃至示大涅槃庄严住持。于三世中示无量身。于自身中示有无量诸佛。示无量佛世界庄严之事。亦示世界成坏之事。或于自身一毛孔中出一切风灾而不恼众生。复随心念。或以无量无边世界为一海水。此海水中作大莲花光明庄严遍覆无量无边世界。于中示现大菩提树庄严妙事。乃至示一切种一切智智。或于自身示十方光明摩尼宝珠电光日月星宿诸光明等乃至一切世界诸光明等皆于身中现。以口嘘气能动十方无量世界而不令众生有惊怖想。示十方世界风灾劫尽火灾劫尽水灾劫尽。随一切众生种种心念应现色身庄严成就。或以自身作如来身。以如来身作自身。以如来身作自佛国。以自佛国作如来身。如是佛子。是菩萨住此菩萨法云地中神变如是。复过于此有余无量无边百千万亿那由他神通庄严。自在示现

论曰。是中神通力无上有上者。有六种相应知。一依内。二依外。三自相。四作住持。五令欢喜。六大胜。是中神通力无上者。比余众生神通力故。有上者。比于如来神通力故。是中依内者。有四种。一不思议解脱。二三昧。三起智陀罗尼。四神通。如前所说。依外者。外事地等。复有外事自他身等。是中自相者有二种。一转外事等。二应化自身等。是中转者。复有三种。一略广转。二异事转。三自在转。能作一切众生种种庄严等。云何略广转。如经是菩萨住在此地于智慧中得上自在力善择大智通随心所念或以狭国为广广国为狭故。云何异事转。如经复随心念或以垢国为净净国为垢乃至一切世界自在力故种种能成故。云何自在转。如经是菩萨复随心念于一微尘中示一世界乃至然诸众生亦不恐怖不觉不知故。云何应化自身等。如经复随心念或于一毛道示一切佛境界庄严之事复随心念乃至或以不可说不可说一切佛境界庄严之事示一毛道故。是中作住持者。供养门等成就集助菩提法故。如经复随心念于一念间示现无量不可说不可说世界微尘等身乃至无量无边百千万亿那由他庄严自在示现故。云何令欢喜

经曰。尔时会中一切菩萨众。及一切天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽四天王释提桓因梵天王摩醯首罗净居天等。各作是念。若菩萨神通智力能如是。无量无边佛复云何。尔时解脱月菩萨。知诸大众心所念已。问金刚藏菩萨言。佛子。今诸大众。闻是菩萨神通智力堕在疑网。为断疑故少示菩萨神通之力庄严妙事。尔时金刚藏菩萨。即入一切佛国体性菩萨三昧。金刚藏菩萨入一切佛国体性菩萨三昧。时彼一切菩萨众及一切天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽四天王释提桓因梵天王摩醯首罗净居天等。皆自见身入金刚藏菩萨身中于其身内见佛国土。彼国土中所有诸相庄严妙事。于百千万亿劫说不可尽。于中有道场树。其茎周围十万三千大千世界。高百万三千大千世界。覆荫三千亿三千大千世界。称树高广有师子座。其座上有佛。号一切智通王如来。一切大众咸皆见。佛坐在道场树下师子座上。其中诸相庄严妙事。于百千万亿劫说不可尽。金刚藏菩萨示现如是大神力已。还令一切诸菩萨众及一切天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽四天王释提桓因梵天王摩醯首罗净居天等各在本处。尔时一切大众欢喜踊跃生希有想默然而住。观金刚藏菩萨。尔时解脱月菩萨语金刚藏菩萨言。佛子。甚为希有。此三昧神通庄严有大势力。佛子此三昧名为何等。金刚藏菩萨言。佛子。此三昧名为一切佛国体性。尔时解脱月菩萨问金刚藏菩萨言。佛子。此三昧境界庄严神通妙事为齐几许。金刚藏菩萨言。佛子。若菩萨随心所念。善修成此三昧力故。能示如是佛国土微尘数等。诸佛国土自身中现。复过此数。佛子。菩萨住此菩萨法云地。得如是等无量百千菩萨三昧。以是义故。此菩萨乃至得位菩萨及住善慧地菩萨。不能测知。若身身业难可测知。若口口业难可测知。若意意业难可测知。若神通事难可测知。若观三世智难可测知。若入三昧境界难可测知。若智境界难可测知。若游戏诸解脱难可测知。若应化所作。若加所作。若神力所作难可测知。乃至举足下足所作。乃至得位菩萨及住善慧地菩萨不能测知。佛子。菩萨法云地。如是无量今已略说。若广说者。无量百千阿僧祇劫。无量百千万无量百千亿不能得尽。解脱月菩萨问金刚藏菩萨言。佛子。若菩萨神通行境界力如是无量。佛神通行境界力复云何。金刚藏菩萨言。佛子。譬如有人取四天下中二三豆土。作如是言。无边世界地界为多此耶。汝所问者。我谓如是。如来无量智慧。云何以菩萨智慧而欲测量。佛子如人取四天下中少地界余在极多如是。佛子。菩萨法云地。于无量劫说但说一分。何况如来地。金刚藏菩萨语解脱月菩萨言。佛子。是诸如来证知我言。佛子。假使十方于一一方无量世界微尘数等诸佛国土十地菩萨皆满其中。譬如甘蔗竹苇稻麻丛林。此诸菩萨于无量劫所修行业功德智慧。于如来功德智慧力。百分不及一。千分不及一。百千分不及一。百千那由他分不及一。亿分不及一。百亿分不及一。千亿分不及一。百千亿分不及一。百千亿那由他分不及一。乃至算数譬喻所不能及。如是佛子。是菩萨通达如是智慧。顺如来身口意业。不舍菩萨三昧力。能见诸佛勤心供养。于一一劫中以一切种供具上上供养无量诸佛。而能具受诸佛神力所加转复明胜。是菩萨于法界中所有问难无能胜者。无量百劫。无量千劫。无量百千劫。无量百千那由他劫。无量亿劫。无量百亿劫。无量千亿劫。无量百千亿劫。无量百千亿那由他劫。不可穷尽。佛子。譬如善巧金师善治此金为庄严具。以无上摩尼宝珠间错其中。系在自在天王若颈若顶。其余天人庄严之具无能及者。如是佛子。是菩萨住此第十菩萨法云地中。彼菩萨不可思议智行。一切众生一切声闻辟支佛。从初地乃至住第九地菩萨所不能及。是菩萨住此地中。大智照光明。能令一切众生乃至住一切智智。其余智慧之明所不能坏。佛子。譬如摩醯首罗天王光明过一切生处众生。光明能令众生身心清凉。如是佛子。是菩萨住此第十菩萨法云地中。彼智慧光明。一切声闻辟支佛。从初地乃至住九地菩萨所不能及。是菩萨住此地中。能令一切众生住一切智智法中。佛子。是菩萨随顺如是智慧。十方诸佛为说智慧。令通达三世行。正知法界差别。遍覆一切世间界。照一切世间界。令一切众生界得证法故。略说。乃至随顺得一切智智。是菩萨十波罗蜜中。智波罗蜜增上。佛子。是名略说菩萨第十菩萨法云地。若广说者。无量无边阿僧祇劫不可穷尽。若菩萨住此地中。多作摩醯首罗天王具足自在。善授众生声闻辟支佛菩萨波罗蜜行。于法界中有问难者无能令尽。所作善业布施爱语利益同事。是诸福德皆不离念佛念法念僧念菩萨念菩萨行念波罗蜜念十地念不坏力念无畏念不共佛法。乃至不离念具足一切种一切智智。常生是心我当于一切众生中为首为胜为大为妙为微妙为上为无上为导为将为师为尊乃至为一切智智依止者。复从是念发精进行。以精进力故。于一念间。得十不可说百千万亿那由他佛世界微尘数三昧。得见十不可说百千万亿那由他佛世界微尘数佛。能知十不可说百千万亿那由他佛世界微尘数佛神力。能动十不可说百千万亿那由他佛世界微尘数世界。能入十不可说百千万亿那由他佛世界微尘数世界。能照十不可说百千万亿那由他佛世界微尘数世界。能教化十不可说百千万亿那由他佛世界微尘数世界众生。能住寿十不可说百千万亿那由他佛世界微尘数劫。能知过去未来世各十不可说百千万亿那由他佛世界微尘数劫事。能善入十不可说百千万亿那由他佛世界微尘数法门。能变身为十不可说百千万亿那由他佛世界微尘数身。于一一身示十不可说百千万亿那由他佛世界微尘数菩萨以为眷属。若以愿力自在。胜上菩萨愿力。过于此数示种种神通。或身或光明或神通或眼或境界或音声或行或庄严或加或信或业。是诸神通。乃至无量百千万亿那由他劫。不可数知

论曰。是中令欢喜者。能断疑故。断疑有二种。一示现自神通力。二说一切法故。云何示现自神通力。如经尔时会中一切菩萨众及一切天龙夜叉。如是等。如是自力示现。断众生疑令欢喜故。云何说一切法。如经如是佛子是菩萨通达如是智慧顺如来身口意业乃至转复明胜。是菩萨于法界中所有问难无能胜者。如是等。是中大胜者。有二种。一神通力胜。二算数胜。此二种事胜一切前地故。如经说应知三世智等通故。通三种行故。一能断疑行。如经佛子是菩萨住此地中随顺如是智十方诸佛为说智慧令通达三世行等。三世行者。道义应知。二速疾神通行。闻说如来秘密法故。如经正知法界差别故。三等作助行。此有三种应知。一作净佛国土平等。为化众生故。二作法明平等。三作正觉平等。如经遍覆一切世间界故。照一切世间界故。令一切众生界得证法故。略说。乃至随顺得一切智智。如是等。如是此地神通力无上有上分已说。次说地影像分。是中地影像者。有四种。一池。二山。三海。四摩尼宝珠。以况四种功德故。一修行功德。二上胜功德。三难度能度大果功德。四转尽坚固功德。云何修行功德

经曰。佛子。是菩萨十地。次第顺行趣向一切种一切智智。佛子。譬如从阿耨大池流出四河。充满阎浮提。不可穷尽。转复增长乃至充满大海。如是佛子。菩萨从菩提心流出善根大愿之水。以四摄法充满众生界不可穷尽。转复增长乃至满足得一切种一切智智

论曰。是中修行功德者。依本愿力修行。以四摄法作利益他行。自善根增长及得菩提自利益行应知。如经佛子譬如从阿耨大池流出四河乃至满足得一切种一切智智故。云何上胜功德

经曰。佛子。是菩萨十地。因佛智故而有差别。譬如依大地故有十大山王差别。何等为十。所谓雪山王。香山王。毗陀略山王。仙圣山王。由乾陀罗山王。马耳山王。尼民陀罗山王。斫迦婆罗山王。众相山王。须弥山王。佛子。譬如雪山王。一切药草集在其中。是诸药草取不可尽。如是佛子。菩萨住在菩萨欢喜地中。一切世间书论技艺文诵咒术集在其中。一切世间书论技艺文诵咒术不可穷尽。佛子。譬如香山王。一切诸香集在其中。一切诸香取不可尽。如是佛子。菩萨住在菩萨离垢地中。一切菩萨持戒正受行香集在其中。一切菩萨持戒正受行香不可穷尽。佛子。譬如毗陀略山王。纯净宝性一切诸宝集在其中。一切诸宝取不可尽。如是佛子。菩萨住在菩萨明地中。一切世间禅定神通解脱三昧三摩跋提集在其中。一切世间禅定神通解脱三昧三摩跋提问答不可穷尽。佛子。譬如仙圣山王。纯净宝性五通圣人集在其中。五通圣人不可穷尽。如是佛子。菩萨住在菩萨焰地中。一切行中殊胜智行集在其中。一切行中殊胜智行种种问难不可穷尽。佛子。譬如由乾陀罗山王。纯净宝性一切夜叉诸大鬼神集在其中。一切夜叉诸大鬼神不可穷尽。如是佛子。菩萨住在菩萨难胜地中。一切自在如意神通变化庄严集在其中。一切自在如意神通变化庄严问答不可穷尽。佛子。譬如马耳山王。纯净宝性一切众果集在其中。一切众果取不可尽。如是佛子。菩萨住在菩萨现前地中。说入因缘集观集在其中。说入因缘集观声闻果证问答不可穷尽。佛子。譬如尼民陀罗山王。纯净宝性一切大力龙神集在其中。一切大力龙神不可穷尽。如是佛子。菩萨住在菩萨远行地中。种种方便智集在其中。种种方便智说辟支佛果证问答不可穷尽。佛子。譬如斫迦婆罗山王。纯净宝性得自在众集在其中。得自在众不可穷尽。如是佛子。菩萨住在菩萨不动地中。起一切菩萨自在道集在其中。起一切菩萨自在道。说一切世间界差别问答不可穷尽。佛子。譬如众相山王。纯净宝性诸大阿修罗众集在其中。诸大阿修罗众不可穷尽。如是佛子。菩萨住在菩萨善慧地中。知一切众生逆顺行集在其中。知一切众生逆顺行。说一切世间生灭相问答不可穷尽。佛子。譬如须弥山王。纯净宝性诸大天众集在其中。诸大天众不可穷尽。如是佛子。菩萨住在菩萨法云地中。如来力无畏不共佛法集在其中。如来力无畏不共佛法示现佛事问答不可穷尽。佛子。此十大宝山王同在大海。因大海得名。如是佛子。菩萨十地同在一切智。因一切智得名

论曰。是中上胜功德者。依一切智增上行十地故。如经佛子是菩萨十地因佛智故而有差别。譬如依大地故有十大山王差别故。是中纯净诸宝山喻者。喻八种地。厌地善清净故。复次诸山王非众生数。众生数依故。非众生数者。有二种。一受用事。二守护积聚宝事等。是中受用事者。有二种。一众生四大增损对治。二长养众生依雪山香山毗陀略山马耳山。此四山非众生数依故。药草众香众宝一切果集在其中。一切果者。第六山中众生数者。复有六种难对治故。六种难者。一贫难。二死难。三俭难。四不调伏难。五恶业难。六怨敌难。第四山中五通福田对治贫难。第五山中夜叉大神神通变化对治死难。第七山中诸大龙王对治俭难。第八山中得自在众对治不调伏难。第九山中阿修罗说咒对治恶业难。第十山中自在四天王。对治怨敌难。此一切山集在其中者。如所说事能生一切物故。言集在其中不可穷尽者。顺行不断不休息故。彼十大山因大海得名。大海亦因大山得名。菩萨十地亦复如是。同在一切智因一切智得名。彼因果相显故。如经佛子此十大宝山王同在大海。因大海得名。如是佛子菩萨十地同在一切智。因一切智得名故。云何难度能度大果功德

经曰。佛子譬如大海以十相故数名大海无有能坏。何等为十。一渐次深。二不受死尸。三余水失本名。四同一味。五无量宝聚。六甚深难度。七广大无量。八多有大身众生依住。九潮不过限。十能受一切大雨无有厌足。如是佛子。菩萨行以十相故数名菩萨行无有能坏。何等为十。所谓菩萨欢喜地中。渐次起大愿故。菩萨离垢地中。不共破戒死尸住故。菩萨明地中。舍诸世间假名数故。菩萨焰地中。恭敬三宝得一味不坏故。菩萨难胜地中。无量方便智起世间所作宝故。菩萨现前地中。观甚深因缘集法故。菩萨远行地中。以无量方便智。善择诸法故。菩萨不动地中。示现起大庄严事故。菩萨善慧地中。得甚深解脱通达世间行。如实所证不过限故。菩萨法云地中。能受一切诸佛大法明雨无有厌足故

论曰。是中难度能度大果功德者。因果相顺故。十地如大海难度能度。得大菩提果故。大海有八种功德应知。一易入功德。如经渐次深故。二净功德。如经不受死尸故。三平等功德。如经余水失本名故。四护功德。如经同一味故。五利益功德。如经无量宝聚故。六不竭功德。谓深广等。如经甚深难度故。广大无量故。七住处功德。以大众生依住故。如经多有大身众生依住故。八护世间功德。潮不过时受水无厌。如经潮不过限故。能受一切大雨无有厌足故。大海相似法菩萨十地行。亦有十种相应如经。如是佛子菩萨行以十相故。数名菩萨行。无有能坏故。如是等。云何转尽坚固功德

经曰。佛子。譬如大摩尼宝珠过十宝性。一出大海。二巧匠善治。三善转精妙。四善清净。五善净光泽。六善钻穿。七贯以宝缕。八置在琉璃高幢。九放一切光明。十随王意雨众宝物能与一切众生一切宝物。如是佛子。菩萨发萨婆若心过十圣性。一初发心布施离悭。二善修持戒正行明净。三善修禅定三昧三摩跋提令转精妙。四菩提分善清净。五方便神通善净光泽。六因缘集观善钻穿。七种种方便智缕善贯穿。八置于自在神通幢上。九观众生行放多闻智慧光明。十诸佛授智位。尔时能为一切众生现作佛事。即名得萨婆若

论曰。是中转尽坚固功德者。大摩尼宝喻。如经佛子譬如大摩尼宝珠等故。过十宝性者。摩尼宝过毗琉璃等以出故取。乃至放一切光明示现此宝。有八种功德摄故。八种功德者。一出功德。选择而取以善观故。二色功德。巧匠善治故。三形相功德。善转精妙故。四无垢功德。善清净故。五明净功德。善净光泽故。六起行功德。善钻穿故。贯以宝缕故。置在琉璃高幢故。此三句示现。七神力功德。放一切光明遍照一切处故。八不护功德。随王意雨众宝物。能与一切众生一切宝物。正智受位故。一切众生同善根藏故。过十圣性者。过声闻辟支佛等性故。声闻有八种性。四行四果差别故。辟支佛有二种性。行果差别故。如是十地影像分已说。云何地利益分

经曰。佛子。是菩萨行善集一切种一切智智功德集法门品。若众生不深种善根者。不能得闻解脱月菩萨言。佛子。此集一切种一切智智功德集法门品。若得闻者。此人成就几许功德。金刚藏菩萨言。佛子。随一切智智所摄观集诸功德。此集一切种一切智智功德集法门品亦复如是。此人得闻此法门。所得功德亦复如是。何以故佛子若非菩萨不得闻此集一切种一切智智功德集法门品。何况能信。何况能持。何况正修行。说此经时。以佛神力。以得法力。十方世界十亿佛土微尘数等诸佛世界。六种十八相动。所谓动遍动等遍动。踊遍踊等遍踊。觉遍觉等遍觉。起遍起等遍起。震遍震等遍震。吼震吼等遍吼。以佛神力以得法力故。雨种种天花如云而下。雨天衣雨天宝。雨天庄严具雨天盖雨天幡。雨天幢雨天伎乐。雨天音声。赞叹一切智地。及赞十地殊胜之事。如此世界四天下。他化自在天中自在天王宫摩尼宝藏殿说十地法。如是十方一切世界周遍皆说此十地法。以佛神力故。十方过十亿佛土微尘数等世界。有十亿佛土微尘数等诸菩萨来集遍满十方虚空。到已皆作是言。善哉善哉。佛子。善说菩萨住诸地相。佛子。我等一切亦名金刚藏。从名金刚胜世界金刚幢佛所来。彼一切世界皆承佛神力说此法门。众会亦如是。字句亦如是。释名亦如是。义趣亦如是不增不减。佛子。是故我等承佛神力。来到此众为证是法。佛子。如我等来至此众。如是十方一切世界。一一世界中四天下。上他化自在天中自在天王宫摩尼宝藏殿。皆有十亿佛土微尘数等菩萨往为作证。尔时金刚藏菩萨摩诃萨承佛神力说此经时。如来随喜。彼一切菩萨众及一切天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽四天王释提桓因梵天王摩醯首罗净居天众皆大欢喜。佛在他化自在天中成道未久第二七日自在天王宫摩尼宝藏殿。金刚藏菩萨说欢喜奉行

论曰。是中地利益者。有二种。一生信功德。二供养功德。复次此法门中。决定信说大利益义示现。如经佛子是菩萨行善集一切种一切智智功德集法门品。如是等。解脱月菩萨言。如是等。金刚藏菩萨言。如是等故。为于此经中生信得功德。复生信功德缘生义故。以神通力示现六种十八相动。如经说此经时以佛神力以得法力故。如是等。是中六种动者。一动。二踊。三上去。四起。五下去。六吼。十八相此六种动等相。下中上如是次第应知。器世间中。依四种众生聚。一依不善众生。二依信种种天众生。三依我慢众生。四依咒术众生。为此众生下中上次第差别故。动乃至吼。如是十八句异义应知。如是生信功德及缘生义已说。是中供养功德者。如经雨种种天华如云而下。如是等。一切世界说此法门示现为无量法门利益众生示现。如经如此世界四天下。如是等。余者易解

十地经论法云地第十卷之十二


十住毗婆沙论

    No. 1521

十住毗婆沙论卷第一

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

    序品第一

  敬礼一切佛　　无上之大道
  及诸菩萨众　　坚心住十地
  声闻辟支佛　　无我我所者
  今解十地义　　随顺佛所说

问曰汝欲解菩萨十地义。以何因缘故说。答曰。地狱畜生饿鬼人天阿修罗六趣险难恐怖大畏。是众生生死大海旋流洄澓。随业往来是其涛波。涕泪乳汁流汗脓血是恶水聚。疮癞干枯呕血淋沥。上气热病瘭疽痈漏吐逆胀满。如是等种种恶病为恶罗刹。忧悲苦恼为水。娆动啼哭悲号为波浪声。苦恼诸受以为沃焦。死为崖岸无能越者。诸结烦恼有漏业风鼓扇不定。诸四颠倒以为欺诳。愚痴无明为大黑闇。随爱凡夫无始已来常行其中。如是往来生死大海。未曾有得到于彼岸。或有到者兼能济渡无量众生。以是因缘说菩萨十地义。问曰。若人不能修行菩萨十地。不得度生死大海耶。答曰。若有人行声闻辟支佛乘者。是人得度生死大海。若人欲以无上大乘度生死大海者。是人必当具足修行十地。问曰。行声闻辟支佛乘者。几时得度生死大海。答曰。行声闻乘者。或以一世得度。或以二世。或过是数。随根利钝。又以先世宿行因缘行辟支佛乘者。或以七世得度。或以八世。若行大乘者。或一恒河沙大劫。或二三四至十百千万亿。或过是数。然后乃得具足修行菩萨十地而成佛道。亦随根之利钝。又以先世宿行因缘。问曰。声闻辟支佛佛。俱到彼岸。于解脱中有差别不。答曰。是事应当分别。于诸烦恼得解脱是中无差别。因是解脱入无余涅槃。是中亦无差别。无有相故。但诸佛甚深禅定障解脱。一切法障解脱。于诸声闻辟支佛。有差别非说所尽。亦不可以譬喻为比。问曰。三乘所学皆为无余涅槃。若无余涅槃中无差别者。我等何用于恒河沙等大劫。往来生死具足十地。不如以声闻辟支佛乘速灭诸苦。答曰。是语弱劣。非是大悲有益之言。若诸菩萨效汝小心无慈悲意。不能精勤修十地者。诸声闻辟支佛何由得度。亦复无有三乘差别。所以者何。一切声闻辟支佛皆由佛出。若无诸佛。何由而出。若不修十地何有诸佛。若无诸佛亦无法僧。是故汝所说者则断三宝种。非是大人有智之言。不可听察。所以者何。世间有四种人。一者自利二者利他三者共利四者不共利。是中共利者。能行慈悲饶益于他。名为上人。如说

  世间可愍伤　　常背于自利
  一心求富乐　　堕于邪见网
  常怀于死畏　　流转六道中
  大悲诸菩萨　　能极为希有
  众生死至时　　无能救护者
  没在深黑闇　　烦恼网所缠
  若有能发行　　大悲之心者
  荷负众生故　　为之作重任
  若人决定心　　独受诸勤苦
  所获安隐果　　而与一切共
  诸佛所称叹　　第一最上人
  亦是希有者　　功德之大藏
  世间有常言　　家不生恶子
  但能成己利　　不能利于人
  若生于善子　　能利于人者
  是则如满月　　照明于其家
  有诸福德人　　以种种因缘
  饶益如大海　　又亦如大地
  无求于世间　　以慈愍故住
  此人生为贵　　寿命第一最

如是声闻辟支佛佛烦恼解脱虽无差别。以度无量众生久住生死多所利益具足菩萨十地故有大差别。问曰。佛有大悲。汝为弟子种种称赞慈愍众生诚如所说。汝以种种因缘明了分别开悟引导。行慈悲者闻则心净我甚欣悦。汝先偈说十地之义。愿为解释。答曰。敬名恭敬心。礼名曲身接足。一切诸佛者。三世十方佛。无上大道者。一切诸法如实知见通达无余。更无胜者。故曰无上。大人所行故曰大道。菩萨众者。为无上道发心名曰菩萨。问曰。但发心便是菩萨耶。答曰。何有但发心而为菩萨。若人发心必能成无上道乃名菩萨。或有但发心亦名菩萨。何以故。若离初发心则不成无上道。如大经说。新发意者名为菩萨。犹如比丘虽未得道亦名道人。是名字菩萨。渐渐修习转成实法。后释欢喜地中。当广说如实菩萨相。众者从初发心。至金刚无碍解脱道。于其中间过去未来现在菩萨。名之为众。坚心者。心如须弥山王不可沮坏。亦如大地不可倾动。住十地者。欢喜等十地。后当广说。问曰。若菩萨更有殊胜功德。何故但称坚心。答曰。菩萨有坚心功德能成大业。不堕二乘。软心者怖畏生死。自念何为久在生死受诸苦恼。不如疾以声闻辟支佛乘速灭诸苦。又软心者。于活地狱黑绳地狱众合地狱叫唤地狱大叫唤地狱烧炙地狱大烧炙地狱无间大地狱。及眷属炭火地狱沸屎地狱烧林地狱剑树地狱刀道地狱铜柱地狱刺棘地狱碱河地狱。其中斧钺刀槊矛戟弓箭铁刬椎棒铁锵[金*疾]鑗铁[矛*贊]刀铁臼铁杵铁轮以如是等治罪器物斩斫割刺打棒剥裂系缚枷锁烧煮考掠。磨碎其身捣令烂熟。狐狗虎狼师子恶兽竞来[齒*(虎-儿+且)]掣食啖其身。乌鸱雕鹫铁嘴所啄。恶鬼驱逼令缘剑树。上下火山以铁火车加其颈领。以热铁杖而随捶之。千钉鏒身刬刀刮削。入黑闇中熢勃臭处热铁鍱身脔割其肉剥其身皮还系手足。镬汤涌沸炮煮其身。铁棒棒头脑坏眼出。贯着铁丳举身火燃血流浇地。或没屎河。行于刀剑锵刺恶道。自然刀剑从空而下。犹如驶雨割截支体。辛碱苦臭秽恶之河浸渍其身。肌肉烂坏举身堕落唯有骨在。狱卒牵抴蹴蹋捶扑。有如是等无量苦毒。寿命极长求死不得。若见若闻如是之事何得不怖求声闻辟支佛乘。又于寒冰地狱。頞浮陀地狱。尼罗浮陀地狱。阿波波地狱。阿罗罗地狱阿睺睺地狱。青莲华地狱。白莲华地狱。杂色莲华地狱。红莲华地狱。赤莲华地狱。常在幽闇大怖畏处。谤毁贤圣生在其中。形如屋舍山陵埠阜。粗恶冷风声猛可畏。悲激吹身如转枯草。肌肉堕落犹如冬叶。冻剥创夷脓血流出。身体不净臭处难忍。寒风切裂苦毒辛酸。唯有忧悲啼哭更无余心。号啕茕独无所依恃。斯罪皆由诽谤贤圣。其软心者见闻此事。何得不怖求声闻辟支佛乘。又于畜生猪狗野干猫狸狖鼠猕猴[狂-王+加]玃虎狼师子兕豹熊罴象马牛羊蜈蚣蚰蜒蚖蛇蝮蝎鼋龟鱼鳖蛟虬螺蚌乌鹊鸱枭鹰鸽之类。如是鸟兽共相残害。又弶网伺捕屠割不一。生则羁绊穿鼻络首。负乘捶杖钩刺其身皮肉破裂痛不可忍。烟熏火烧苦毒万端。死则剥皮食啖其肉。有如是等无量苦痛。其软心者闻见此事。何得不怖求声闻辟支佛乘。又于针颈饿鬼火口饿鬼火瘿饿鬼食吐饿鬼食荡涤饿鬼食脓饿鬼食屎饿鬼浮陀鬼鸠槃茶鬼夜叉鬼罗刹鬼毗舍阇鬼富单那鬼迦罗富单那鬼等诸鬼。须发蓬乱长爪大鼻。身中多虫臭秽可畏。众恼所切常有悭嫉饥渴苦患。未曾得食得不能咽。常求脓血屎尿涕唾荡涤不净。有力者夺而不得食。裸形无衣寒热倍甚。恶风吹身宛转苦痛。蚊虻毒虫唼食其体。腹中饥热常如火然。其软心者见闻此事。何得不怖求声闻辟支佛乘。又于人中恩爱别苦怨憎会苦老病死苦贫穷求苦。有如是等无量众苦。及诸天阿修罗退没时苦。其软心者见此诸苦。何得不怖求声闻辟支佛乘。若坚心者见地狱畜生饿鬼天人阿修罗中受诸苦恼。生大悲心无有怖畏。作是愿言。是诸众生深入衰恼。无有救护无所归依。我得灭度当度此等。以大悲心勤行精进。不久得成所愿。是故我说。菩萨诸功德中坚心第一。复次菩萨有八法能集一切功德。一者大悲。二者坚心。三者智慧。四者方便。五者不放逸。六者勤精进。七者常摄念。八者善知识。是故初发心者疾行八法如救头然。然后当修诸余功德。又依此八法故。有一切声闻众四双八辈。所谓须陀洹向须陀洹等。辟支佛无我我所者。世间无佛无佛法时有得道者名辟支佛。诸贤圣离我我所贪着故。名为无我我所者。今解十地义随顺佛所说者。十地经中次第说。今当随次具解。问曰。汝所说者不异于经。经义已成何须更说。为欲自现所能求名利耶。答曰

  我不为自现　　庄严于文辞
  亦不贪利养　　而造于此论

问曰。若不尔者。何以造此论。答曰

  我为欲慈悲　　饶益于众生
  不以余因缘　　而造于此论

见众生于六道受苦无有救护。为欲度此等故。以智慧力而造此论。不为自现智力求于名利。亦无嫉妒自高之心求于供养。问曰。慈愍饶益众生事。经中已说。何须复解徒自疲苦。答曰

  有但见佛经　　通达第一义
  有得善解释　　而解实义者

有利根深智之人。闻佛所说诸深经。即能通达第一义。所谓深经者。即是菩萨十地。第一义者即是十地如实义。有诸论师有慈悲心。随佛所说造作论议庄严辞句。有人因是而得通达十地义者。如说

  有人好文饰　　庄严章句者
  有好于偈颂　　有好杂句者
  有好于譬喻　　因缘而得解
  所好各不同　　我随而不舍

章句名庄严句义。不为偈颂。偈名义趣。言辞在诸句中。或四言五言七言等。偈有二种。一者四句偈名为波蔗。二者六句偈名祇夜。杂句者名直说语言。譬喻者。以人不解深义故。假喻令解。喻有或实或假。因缘者。推寻所由随其所好而不舍之。问曰。众生自所乐不同。于汝何事。答曰。我发无上道心故。不舍一切随力饶益。或以财或以法。如说

  若有大智人　　得闻如是经
  不复须解释　　则解十地义

若有福德利根者。但直闻是十地经。即解其义不须解释。不为是人而造此论。问曰。云何为善人。答曰。若闻佛语即能自解。如丈夫能服苦药。小儿则以蜜和。善人者略说有十法。何等为十。一者信。二者精进。三者念。四者定。五者善身业。六者善口业。七者善意业。八者无贪。九者无恚。十者无痴。如说

  若人以经文　　难可得读诵
  若作毗婆沙　　于此人大益

若人钝根懈慢。以经文难故。不能读诵。难者文多难诵难说难谙。若有好乐庄严语言杂饰譬喻诸偈颂等。为利益此等故造此论。是故汝先说但佛经便足利益众生。何须解释者。是语不然。如说

  思惟造此论　　深发于善心
  以然此法故　　无比供养佛

我造此论时思惟分别。多念三宝及菩萨众。又念布施持戒忍辱精进禅定智慧故。深发善心则是自利。又演说照明此正法故。名为无比供养诸佛。则是利他。如说

  说法然法灯　　建立于法幢
  此幢是贤圣　　妙法之印相
  我今造此论　　谛舍及灭慧
  是四功德处　　自然而修集

今造此论。是四种功德自然修集。是故心无有倦。谛者一切真实名之为谛。一切实中佛语为真实。不变坏故。我解说此佛法即集谛处。舍名布施。施有二种。法施财施。二种施中法施为胜。如佛告诸比丘。一当法施二当财施。二施之中法施为胜。是故我法施时即集舍处。我若义说十地时。无有身口意恶业。又亦不起欲恚痴念及诸余结。障此罪故即名集灭处。为他解说法得大智报。以是说法故即集慧处。如是造此论。集此四功德处。复次

  我说十地论　　其心得清净
  深贪是心故　　精勤而不倦
  若人闻受持　　心有清净者
  我亦深乐此　　一心造此论

此二偈其义已显不须复说。但以自心他心清净故。造此十地义。清净心至所应至处得大果报。如佛语迦留陀夷。勿恨阿难。若我不记阿难。于我灭后作阿罗汉者。以是清净心业因缘故。当于他化自在天七反为王。如经中广说

    入初地品第二

问曰。汝说此语开悟我心甚以欣悦。今解十地必多所利益。何等为十。答曰

  此中十地法　　去来今诸佛
  为诸佛子故　　已说今当说
  初地名欢喜　　第二离垢地
  三名为明地　　第四名焰地
  五名难胜地　　六名现前地
  第七深远地　　第八不动地
  九名善慧地　　十名法云地
  分别十地相　　次后当广说

此中者大乘义中。十者数法。地者菩萨善根阶级住处。诸佛者。十方三世诸如来。说者。开示解释。诸佛子者。诸佛真实子诸菩萨是。是故菩萨名为佛子。过去未来现在诸佛。皆说此十地。是故言已说今说当说。菩萨在初地始得善法味心多欢喜故名欢喜地。第二地中行十善道离诸垢故名离垢地。第三地中广博多学为众说法能作照明故名为明地。第四地中布施持戒多闻转增。威德炽盛故名为炎地。第五地中功德力盛。一切诸魔不能坏故名难胜地。第六地中障魔事已。诸菩萨道法皆现在前故名现前地。第七地中去三界远近法王位故名深远地。第八地中若天魔梵沙门婆罗门无能动其愿故名不动地。第九地中其慧转明调柔增上故名善慧地。第十地中菩萨于十方无量世界。能一时雨法雨如劫烧已普澍大雨名法云地。问曰。已闻十地名。今云何入初地。得地相貌及修习地。答曰

  若厚种善根　　善行于诸行
  善集诸资用　　善供养诸佛
  善知识所护　　具足于深心
  悲心念众生　　信解无上法
  具此八法已　　当自发愿言
  我得自度已　　当复度众生
  为得十力故　　入于必定聚
  则生如来家　　无有诸过咎
  即转世间道　　入出世上道
  是以得初地　　此地名欢喜

厚种善根者。如法修集诸功德。名为厚种善根。善根者不贪不恚不痴。一切善法从此三生故名为善根。如一切恶法皆从贪恚痴生。是故此三名不善根。阿毗昙中种种分别。欲界系色界系无色界系不系合为十二。有心相应有心不相应合二十四。此中无漏善根得阿耨多罗三藐三菩提时修集。余九菩萨地中修集。又未发心时久修集。或一心中有三。或一心中有六。或一心中有九。或一心中有十二。或但集心相应不集心不相应。或集心不相应不集心相应。或集心相应亦心不相应。或不集心相应心不相应。是诸善根分别。如阿毗昙中广说。此中善根为众生求无上道故。所行诸善法皆名善根。能生萨婆若智故名为善根。行于诸行者。善行名清净。诸行名持戒。清净持戒次第而行。是持戒与七法和合故名为善行。何等为七。一惭二愧三多闻四精进五念六慧七净命净身口业。行此七法具持诸戒。是名善行诸行。又经说诸禅为行处。是故得禅者名为善行诸行。此论中不必以禅乃得发心。所以者何。佛在世时无量众生皆亦发心不必有禅。又白衣在家亦名为行。善集资用者。上偈中所说。厚种善根善行诸行多供养佛善知识护具足深心悲念众生信解上法。是名资用。又本行善法必应修行亦名资用。所谓布施忍辱质直不谄心柔和同止。乐无愠恨性殚尽不隐过。不偏执不佷戾。不诤讼不自恃不放逸。舍憍慢。离矫异。不赞身堪忍事。决定心能果敢受。不舍易教授。少欲知足乐于独处。如是等诸法随行已。渐能具足殊胜功德。是法味坚牢故名为本行。若离是法不能进得胜妙功德。是故此本行法与八法和合故。为初地资用。善供养诸佛者。若菩萨世世。如法常多供养诸佛。供养有二种。一者善听大乘正法若广若略。二者四事供养恭敬礼侍等。具此二法供养诸佛。名为善供养诸佛。善知识者。菩萨虽有四种善知识。此中所说能教入大乘。具诸波罗蜜。能令住十地者。所谓诸佛菩萨及诸声闻。能示教利喜大乘之法令不退转。守护者。常能慈愍教诲。令得增长善根。是名守护。具足深心者。深乐佛乘无上大乘一切智乘。名为具足深心。问曰。无尽意菩萨。于和合品中。告舍利弗。诸菩萨所有发心皆名深心。从一地至一地故名为趣心。增益功德故名为过心。得无上事故名为顶心。摄取上法故名为上心。现前得诸佛法故名为现前心。集利益法故名为缘心。通达一切法故名为度心。所愿不倦故名为决定心。满所愿故名为喜心。身自成办故名无侣心。离败坏相故名调和心。无诸恶故名为善心。远离恶人故名不杂心。以头施故名难舍心。救破戒人故名持难戒心。能受下劣加恶故名难忍心。得涅槃能舍故名难精进心。不贪禅故名难禅定心。助道善根无厌足故名难慧心。能成一切事故。名度诸行心。智慧善思惟故名离慢大慢我慢心。不望报故是一切众生福田心。观诸佛深法故名无畏心。不障阂故名增功德心。常发精进故名无尽心。能荷受重担故名不闷心。又深心义者。等念众生普慈一切。供养贤善悲念恶人尊敬师长。救无救者无归作归无洲作洲。无究竟者为作究竟。无有侣者能为作侣。曲人中行于直心。败坏人中行真正心。谀谄人中行无谄心。不知恩中行于知恩。不知作中而行知作。无利益中能行利益。邪众生中行于正行。憍慢人中行无慢行。不随教中而不愠恚罪众生中常作守护。众生所有过不见其失。供养福田随顺教诲受化不难。阿练若处一心精进。不求利养不惜身命。复次内心清净故无有诳惑。善口业故不自称叹。知止足故不行威迫。心无垢故行于柔和。集善根故能入生死。为众生故忍一切苦。菩萨有如是等深心相。故不可穷尽。汝今但说深心相何得不少。答曰。不少也。无尽意。总一切深心相在一处说。而此中分布诸地。此十住经。地地别说深心相。是故菩萨随诸地中皆得深心深心之义即在其地。今初地中说二深心。一者发大愿。二者在必定地。是故当知随在十地善说深心。汝说何得不少。是事不然。悲心于众生者。成就悲故名为悲者。何谓为悲。悼愍众生救济苦难。信解诸上法者。于诸佛法信力通达。发愿我得自度已当度众生者。一切诸法愿为其本。离愿则不成。是故发愿。问曰。何故不言我当度众生。而言自得度已当度众生。答曰。自未得度不能度彼。如人自没淤泥。何能拯拔余人。又如为水所[漂*寸]不能济溺。是故说我度已当度彼。如说

  若人自度畏　　能度归依者
  自未度疑悔　　何能度所归
  若人自不善　　不能令人善
  若不自寂灭　　安能令人寂

是故先自善寂而后化人。又如法句偈说

  若能自安身　　在于善处者
  然后安余人　　自同于所利

凡物皆先自利后能利人。何以故。如说

  若自成己利　　乃能利于彼
  自舍欲利他　　失利后忧悔

是故说自度已当度众生。问曰。得何利故能成此事入必定地。又以何心能发是愿。答曰。得佛十力能成此事。入必定地能发是愿。问曰。何等是佛十力。答曰。佛悉了达一切法因果名为初力。如实知去来今所起业果报处名为二力。如实知诸禅定三昧分别垢净入出相名为三力。如实知众生诸根利钝名为四力。如实知众生所乐不同名为五力。如实知世间种种异性名为六力。如实知至一切处道名为七力。如实知宿命事名为八力。如实知生死事名为九力。如实知漏尽事。名为十力。为得如是佛十力故。大心发愿即入必定聚。问曰。凡初发心皆有如是相耶。答曰。或有人说。初发心便有如是相。而实不尔。何以故。是事应分别不应定答。所以者何。一切菩萨初发心时。不应悉入于必定。或有初发心时即入必定。或有渐修功德。如释迦牟尼佛。初发心时不入必定。后修集功德值燃灯佛得入必定。是故汝说一切菩萨初发心便入必定是为邪论。问曰。若是邪论者。何故汝说以是心入必定。答曰。有菩萨初发心即入必定。以是心能得初地。因是人故说初发心入必定中。问曰。是菩萨初心。释迦牟尼佛初发心。是心云何。答曰。是心不杂一切烦恼。是心相续不贪异乘。是心坚牢一切外道无能胜者。是心一切众魔不能破坏。是心为常能集善根。是心能知有为无常。是心无动能摄佛法。是心无覆离诸邪行。是心安住不可动故。是心无比无相违故。是心如金刚通达诸法故。是心不尽集无尽福德故。是心平等等一切众生故。是心无高下无差别故。是心清净性无垢故。是心离垢慧昭明故。是心无垢不舍深心故。是心为广慈如虚空故。是心为大受一切众生故。是心无阂至无障智故。是心遍到不断大悲故。是心不断能正回向故。是心众所趣向。智者所赞故。是心可观小乘瞻仰故。是心难见。一切众生不能睹故。是心难破能善入佛法故。是心为住一切乐具所住处故。是心庄严福德资用故。是心选择智慧资用故。是心淳厚以布施为资用故。是心大愿持戒资用故。是心难沮忍辱资用故。是心难胜精进资用故。是心寂灭禅定资用故。是心无恼害慧资用故。是心无嗔阂慈心深故。是心根深悲心厚故。是心悦乐喜心厚故。是心苦乐不动舍心厚故。是心护念诸佛神力故。是心相续三宝不断故。如是等无量功德庄严初必定心。如无尽意品中广说。是心不杂一切烦恼者。见谛思惟所断二百九十四烦恼不与心和合故名为不杂。是心相续不贪异乘者。从初心相续来。不贪声闻辟支佛乘。但为阿耨多罗三藐三菩提故。名为相续不贪异乘。如是等四十句论。应如是知。问曰。汝说是心常。一切有为法皆无常。如法印经中说。行者观世间空无有常而不变坏。是事何得不相违耶。答曰。汝于是义不得正理故作此难。是中不说心为常。此中虽口说常。常义名必定初心生必能常集诸善根不休不息故名为常。生如来家者。如来家则是佛家。如来者。如名为实。来名为至。至真实中故名为如来。何等为真实所谓涅槃。不虚诳故是名如实。如经中说。佛告比丘。第一圣谛无有虚诳涅槃是也。复次如名不坏相。所谓诸法实相是。来名智慧。到实相中通达其义故名为如来。复次空无相无作名为如。诸佛来至三解脱门。亦令众生到此门故。名为如来。复次如名四谛。以一切种见四谛故名为如来。复次如名六波罗蜜所谓布施持戒忍辱精进禅定智慧。以是六法来至佛地故名为如来。复次谛舍灭慧四功德处。名为如来。以是四法来至佛地故名为如来。复次一切佛法名为如。是如来至诸佛故。名为如来。复次一切菩萨地喜净明炎难胜现前深远不动善慧法云名为如。诸菩萨以是十地来至阿耨多罗三藐三菩提故名为如来。又以如实八圣道分来故名为如来。复次权智二足来至佛故名为如来。如去不还故名为如来。如来者。所谓十方三世诸佛是。是诸佛家名为如来家。今是菩萨行如来道。相续不断故名为生如来家。又是菩萨必成如来故。名为生如来家。譬如生转轮圣王家有转轮圣王相。是人必作转轮圣王。是菩萨亦如是生如来家。发是心故必成如来。是名生如来家。如来家者。有人言。是四功德处所谓谛舍灭慧。诸如来从此中生故。名为如来家。有人言。般若波罗蜜及方便。是如来家。如助道经中说

  智度无极母　　善权方便父
  生故名为父　　养育故名母

一切世间以父母为家。是二似父母故名之为家。有人言。善慧名诸佛家。从是二法出生诸佛。是二则是一切善法之根本。如经中说。是二法俱行能成正法。善是父慧是母。是二和合名为诸佛家。如说

  菩萨善法父　　智慧以为母
  一切诸如来　　皆从是二生

有人言。般舟三昧及大悲名诸佛家。从此二法生诸如来。此中般舟三昧为父。大悲为母。复次般舟三昧是父。无生法忍是母。如助菩提中说

  般舟三昧父　　大悲无生母
  一切诸如来　　从是二法生

家无过咎者。家清净故。清净者。六波罗蜜四功德处方便般若波罗蜜善慧般舟三昧大悲诸忍。是诸法清净无有过故名家清净。是菩萨以此诸法为家故无有过咎。转于过咎转于世间道入出世上道者。世间道名即是凡夫所行道转名休息。凡夫道者不能究竟至涅槃常往来生死。是名凡夫道。出世间者。因是道得出三界故名世间道。上者妙故名为上。入者正行道故名为入。以是心入初地名欢喜地。问曰。初地何故名为欢喜。答曰

  如得于初果　　究竟至涅槃
  菩萨得是地　　心常多欢喜
  自然得增长　　诸佛如来种
  是故如此人　　得名贤善者

如得初果者。如人得须陀洹道。善闭三恶道门。见法入法得法。住坚牢法不可倾动。究竟至涅槃。断见谛所断法故心大欢喜。设使睡眠懒惰不至二十九有。如以一毛为百分。以一分毛分取大海水若二三渧。苦已灭者如大海水。余未灭者如二三渧。心大欢喜。菩萨如是得初地已。名生如来家。一切天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽天王梵王沙门婆罗门一切声闻辟支佛等所共供养恭敬。何以故。是家无有过咎故。转世间道入出世间道。但乐敬佛得四功德处得六波罗蜜果报滋味。不断诸佛种故心大欢喜。是菩萨所有余苦如二三水渧。虽百千亿劫得阿耨多罗三藐三菩提。于无始生死苦。如二三水渧。所可灭苦如大海水。是故此地名为欢喜

十住毗婆沙论卷第一十住毗婆沙论卷第二

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

    地相品第三

问曰。得初地菩萨有何相貌。答曰

  菩萨在初地　　多所能堪受
  不好于诤讼　　其心多喜悦
  常乐于清净　　悲心愍众生
  无有嗔恚心　　多行是七事

菩萨若得初地。即有是七相。能堪受者。能为难事修集无量福德善根。于无量恒河沙劫往来生死。教坚心难化恶众生。心不退没。能堪受如是等事故名为堪忍。无诤讼者。虽能成大事而不与人诤竞。共相违返。喜者。能令身得柔软心得安隐。悦者于转上法中心得踊悦。清净者。离诸烦恼垢浊。有人言。信解名为清净。有人言。坚固信名为清净。是清净心于佛法僧宝。于苦集灭道谛。于六波罗蜜。于菩萨十地。于空无相无作法。略而言之。一切深经诸菩萨及其所行一切佛法。悉皆心信清净。悲者。于众生怜愍救护。是悲渐渐增长而成大悲。有人言。在菩萨心名为悲。悲及众生名为大悲。大悲以十因缘生。如第三地中广说。不嗔者是菩萨结未断故名为行善心少于嗔恨。如是菩萨在于初地。心不畏没故名为能有堪忍。乐寂灭故名为不好诤讼。得顺阿耨多罗三藐三菩提大悲故名为心多喜。离诸烦恼垢浊故于佛法僧宝诸菩萨所心常清净。心安隐无患故名为心悦。深愍众生故名为悲。心常乐慈行故名为不嗔。是名菩萨在初地相貌。问曰。何故不说菩萨于初地中有此七事而言多。答曰。是菩萨漏未尽故。或时懈怠于此事中暂有废退。以其多行故说为多。于初地中已得是法。后诸地中转转增益。问曰。初欢喜地菩萨在此地中名多欢喜。为得诸功德故欢喜为地。法应欢喜。以何而欢喜。答曰

  常念于诸佛　　及诸佛大法
  必定希有行　　是故多欢喜

如是等欢喜因缘故。菩萨在初地中心多欢喜。念诸佛者。念然灯等过去诸佛阿弥陀等现在诸佛弥勒等将来诸佛。常念如是诸佛世尊如现在前。三界第一无能胜者。是故多欢喜。念诸佛大法者。略说诸佛四十不共法。一自在飞行随意。二自在变化无边。三自在所闻无碍。四自在以无量种门知一切众生心。如是等法后当广说。念必定诸菩萨者。若菩萨得阿耨多罗三藐三菩提记入法位得无生法忍。千万亿数魔之军众不能坏乱。得大悲心成大人法。不惜身命为得菩提勤行精进。是念必定菩萨。念希有行者。念必定菩萨第一希有行令心欢喜。一切凡夫所不能及。一切声闻辟支佛所不能行。开示佛法无碍解脱及萨婆若智。又念十地诸所行法。名为心多欢喜。是故菩萨得入初地名为欢喜。问曰。有凡夫人未发无上道心。或有发心者未得欢喜地。是人念诸佛及诸佛大法。念必定菩萨及希有行亦得欢喜。得初地菩萨欢喜。与此人有何差别。答曰

  菩萨得初地　　其心多欢喜
  诸佛无量德　　我亦定当得

得初地必定菩萨念诸佛有无量功德。我当必得如是之事。何以故。我以得此初地入必定中。余者无有是心。是故初地菩萨多生欢喜。余者不尔。何以故。余者虽念诸佛。不能作是念。我必当作佛。譬如转轮圣子生是转轮王家。成就转轮王相。念过去转轮王功德尊贵。作是念。我今亦有是相。亦当得是豪富尊贵。心大欢喜。若无转轮王相者无如是喜。必定菩萨若念诸佛及诸佛大功德威仪尊贵。我有是相必当作佛。即大欢喜。余者无有是事。定心者深入佛法心不可动。复次菩萨在初地念诸佛时。作是思惟。我亦不久当作利益诸世间者及念佛法。我亦当得相好严身成就佛不共法。随诸众生所种善根心力大小而为说法。又我已得善法滋味。不久当如必定菩萨游诸神通。又念必定菩萨所行之道。一切世间所不能信。我亦当行。如是念已心多欢喜。余者不尔。何以故。是菩萨入初地故。其心决定愿不移动求所应求。譬如香象所作唯有香象能作。余兽不能。是故汝所说者。是事不然。复次菩萨得初地无诸怖畏故心多欢喜。若怖畏者心则不喜。问曰。菩萨无何等怖畏。答曰

  无有不活畏　　死畏恶道畏
  大众威德畏　　恶名毁呰畏
  系闭桎梏畏　　拷掠刑戮畏
  无我我所故　　何有是诸畏

问曰。菩萨何故住初地无不活畏。答曰。有大威德故。能堪受故。大智慧故。知止足故。作是念。我多修福德。有福之人衣服饮食。所须之物自然即至。如昔劫初大人群臣士民请以为王。若薄福德者。虽生王家以身力自营。衣食尚不充足。何况国土。菩萨作是念。我多修福德。如劫初王自然登位。我亦如是。亦当复得如是事故。不应有不活畏。复次人虽薄福有堪受力。勤修方便能生衣食。如经说。以三因缘得有财物。一者现世自作方便。二者他力作与。三者福德因缘。我能堪受难成之事。现世亦有方便力故。不应有不活畏。有智之人少设方便能得自活。能求佛道智慧分今已有之。是智慧利能得自活也。不应有不活畏。复次菩萨作是念。我住世间。世间有利衰毁誉称讥苦乐。如是八事何得无也。不应以不得故有不活畏。复次是菩萨以知足故好丑美恶随得而安。不应有不活畏。若不知足者。设得满世间财物。意犹不足。如说

  若有贫穷者　　但求于衣食
  既得衣食已　　复求美好者
  既得美好者　　复求于尊贵
  既得尊贵已　　求王一切地
  设得尽王地　　复求为天王
  世间贪欲者　　不可以财满

若知足之人。得少财物。今世后世能成其利。是菩萨乐布施故。具足智慧故。多能发起不贪善根。若不乐施若多作众恶。以悭贪愚痴因缘故。增益悭贪不善根。无厌足法属于悭贪。是故菩萨多发不贪善根故知足。知足故无不活畏。复次无死畏者。多作福德故。念念死故。不得免故。无始世界习受死法故。多修习空故。菩萨作是念。若人不修福德则畏于死。自恐后世堕恶道故。我多集诸福德。死便生于胜处。是故不应畏死。如说

  待死如爱客　　去如至大会
  多集福德故　　舍命时无畏

复作是念。死名随所受身。末后心灭为死。若心灭为死者。心念念灭故皆应是死。若畏死者心念念灭皆应有畏。非但畏末后心灭。亦应当畏前心尽灭。何以故。前后心灭无有差别故。若谓畏堕恶道故畏末后心灭者。福德之人不应畏堕恶道。如先说。我当受念念灭故。于末后心灭。不应有死畏。复作是念。我于无始世界往来生死受无量无边阿僧祇死法。无有处所能免死者。佛说生死无始。若人于一劫中死已积骨高于雪山。如是诸死不为自利不为利他。我今发无上道愿。为欲自利亦为利他故。勤心行道有大利故。云何惊畏。如是菩萨即舍死畏。复次作是念。今此死法必当应受无有免者。何以故。劫初诸大王。顶生喜见照明王等有三十二大人相庄严其身。七宝导从天人敬爱。王四天下常行十善道。是诸大王皆归于死。复有蛇提罗诸小转轮王。自以威力王阎浮提。身色端正犹如天人。于色声香味触自恣无乏。所向皆伏无有退却善通射术。是诸王等霸王天下人民眷属皆不免死。又诸仙圣迦叶憍瞿摩等行诸苦行得五神通。造作经书皆不免死。又诸佛辟支佛阿罗汉。心得自在离垢得道。皆为死法之所磨灭。一切众生无能过者。我发无上道心不应畏死。又为破死畏故。发心精进自除死畏亦除于他。是故发心行道。云何于死而生惊畏。菩萨如是思惟无常即除死畏。复次菩萨常修习空法故。不应畏死。如说

  离死者无死　　离死无死者
  因死有死者　　因死者有死
  死成成死者　　死先未成时
  无有决定相　　无死无成者
  离死有死者　　死者应自成
  而实离于死　　无有死者成
  而世间分别　　是死是死者
  不知死去来　　是故终不免
  以是等因缘　　观于诸法相
  其心无有异　　终不畏于死

无恶道畏者。菩萨常修福德故。不畏堕恶道。作是念。罪人堕恶道。非是福德者。我乃至一念中。不令诸恶得入。而于身口意常起清净业。是故我得无量无边功德成就。如是大功德聚。云何畏堕恶道。复次菩萨一发心为利安一切众生故。大慈悲所护故。住四功德处。得无量功德。度一切恶道。何以故。是心胜一切声闻辟支佛。如净毗尼经中。迦叶白佛言。希有世尊。善说菩萨以是萨婆若多心能胜一切声闻辟支佛。我成就如是大功德。住如是大法。云何当畏堕于恶道。复作是念。我无始已来。往来生死堕诸恶道受无量苦。不为自利亦不利他。我今发无上大愿。为欲自利亦为利他。先来堕恶道无所利益。今为利益众生故。设堕恶道不应有畏。复次实行菩萨发如是心。假令我于阿鼻地狱一劫受苦然后得出。能令一人生一善心。积集如是无量善心。堪任受化令发三乘。如是教恒河沙等众生声闻乘。恒河沙等众生辟支佛乘。恒河沙等众生发大乘。然后我当得阿耨多罗三藐三菩提心。尚不应退没。何况我今修集无量无边功德远离恶道。菩萨如是思惟。何得有恶道畏。复次如叫唤地狱经中说。菩萨答魔言

  我以布施故　　堕在叫唤狱
  所受我施者　　皆生于天上
  若尔犹尚应　　常行于布施
  众生在天上　　我受叫唤苦

菩萨如是等种种因缘。能遮恶道畏。无有大众畏者。成就闻慧思慧修慧故。又离诸论过咎故。是菩萨建立语端所说无失。能以因缘譬喻结句不多不少无有疑惑。言无非义无有谄诳。质直柔和种种庄严。易解易持义趣次序。能显己事能破他论离四邪因具四大因。如是等庄严言辞。大众中说无有所畏。无恶名畏呵骂畏者。不贪利养故。身口意行清净故。无有系闭桎梏考掠畏者。无有罪故。慈愍一切众生故。忍受一切众苦恼故。依止业果报故。我先自作今还受报。是菩萨以如是等因缘故。无有不活等畏。复次乐观一切法无我。是故无一切怖畏。一切怖畏皆从我见生。我见皆是诸衰忧苦之根本。是菩萨利智慧故。如实深入诸法实相故则无有我。我无故何从有怖畏。问曰。是菩萨云何无有我心。答曰。乐空法故。菩萨观身离我我所故。如说

  我心因我所　　我所因我生
  是故我我所　　二性俱是空
  我则是主义　　我所是主物
  若无有主者　　主所物亦无
  若无主所物　　则亦无有主
  我即是我见　　我物我所见
  实观故无我　　我无无非我
  因受生受者　　无受无受者
  离受者无受　　云何因受成
  若受者成受　　受则为不成
  以受不成故　　不能成受者
  以受者空故　　不得言是我
  以受是空故　　不得言我所
  是故我非我　　亦我亦非我
  非我非无我　　是皆为邪论
  我所非我所　　亦我非我所
  非我非我所　　是亦为邪论

菩萨如是常乐修空无我故。离诸怖畏。所以者何。空无我法能离诸怖畏。故菩萨在欢喜地。有如是等相貌

    净地品第四

问曰。菩萨已得初地。应云何修治。答曰

  信力转增上　　深行大悲心
  慈愍众生类　　修善心无倦
  喜乐诸妙法　　常近善知识
  惭愧及恭敬　　柔软和其心
  乐观法无著　　一心求多闻
  不贪于利养　　离奸欺谄诳
  不污诸佛家　　不毁戒欺佛
  深乐萨婆若　　不动如大山
  常乐修习行　　转上之妙法
  乐出世间法　　不乐世间法
  即治欢喜地　　难治而能治
  是故常一心　　勤行此诸法
  菩萨能成就　　如是上妙法
  是则为安住　　菩萨初地中

菩萨以是二十七法净治初地。信力增上者。信名有所闻见必受无疑。增上名殊胜。问曰。有二种增上。一者多二者胜。今说何者。答曰。此中二事俱说。菩萨入初地。得诸功德味故信力转增。以是信力筹量诸佛功德无量深妙能信受。是故此心亦多亦胜。深行大悲者。愍念众生彻入骨髓故名为深。为一切众生求佛道故名为大。慈心者。常求利事安隐众生。慈有三种。后当广说。修善心无倦者。善法名可亲近修习能与爱果。修如是法时心不懈堕。善法因缘名四摄法十善道六波罗蜜菩萨十地等及诸功德。喜乐妙法者。常思惟修习深得法味久则生乐。如人在花林与爱色相娱乐。常近善知识者。菩萨有四种善知识。后当广说。此中善知识者。诸佛菩萨是。常以正心亲近能令欢悦。惭愧名为喜羞耻。恭敬名念其功德尊重其人。柔软名其心和悦同止安乐乐观法者。法名五阴十二入十八界空无相无作等。以正忆念常观此法。无著者。著名心归趣三有。是众生所归。有人言。五欲诸邪见是所归趣。何以故。众生心常系着故。菩萨利智心无贪着。一心名贵重佛法心无余想。求多名闻者。佛说九部经。能尽推寻修学明了若少不尽。不贪利养者。利名得饮食财物等。养名恭敬礼拜施设床座迎来送去。菩萨应以是事施与众生不自贪着。奸欺名斗秤邪伪衣物不真。谄名心不端直。诳名五邪命法。一名矫异。二名自亲。三名激动。四名抑扬。五名因利求利。矫异者。有人贪求利养故。若作阿练若着纳衣。若常乞食若一坐食。若常坐。若中后不饮浆。受如是等头陀行。作是念。他作是行。得供养恭敬。我作是行或亦得之。为利养故改易威仪名为矫异。自亲者。有人贪利养故。诣檀越家语言。如我父母兄弟姊妹亲戚无异。若有所须我能相与。欲有所作我能为作。我不计远近能来问讯。我住此者正相为耳。为求供养贪着檀越。能以口辞牵引人心。如是等名为自亲。激动者。有人不计贪罪欲得财物。作得物相如是言。是钵好若衣好若户钩好若尼师檀好。若我得者则能受用。又言。随意能施此人难得。又至檀越家作是言。汝家羹饭饼肉香美。衣服复好。常供养我。我以亲旧必当见与。如是示现贪相。是名激动抑扬者。有人贪利养故语檀越言。汝极悭惜。尚不能与父母兄弟姊妹妻子亲戚。谁能得汝物者。檀越愧耻俯仰施与。又至余家作是言。汝有福德受人身不空。阿罗汉常入出汝家。汝与坐起语言作是念想檀越或生是心。更无余人入出我家必谓我。是名为抑扬。因利求利者。有人以衣若钵僧伽梨若尼师檀等资生之物。持示人言。若王王等及余贵人与我是物。作是念。檀越或能生心。彼诸王贵人尚能供养。况我不与是人。因以此利更求余利故名因利求利。是故应当远离如此谄伪。不污诸佛家者。何等为污诸佛家。有人言。若人发求无上道心已。后回向声闻辟支佛道。不能住世继三宝种。是名污诸佛家。是义不然。何以故。是人能度生死。又得诸无漏根力觉道。亦是佛子。云何言污诸佛家。如经说。佛告比丘。汝是我子。从我心生口生得法分者。又声闻人言谛舍灭慧处。名诸佛家。何以故。从是四事出生诸佛故。若污此四法名污诸佛家。是故若人虚妄悭贪狂乱愚痴。是污佛家。若正行此四。则不污诸佛家。有人言。六波罗蜜是诸佛家。从此生诸佛故。若违此六事。是污佛家。有人言。般若波罗蜜是诸佛母。方便为父。是名诸佛家。以此二法出生诸佛。若违此法是污佛家。复次偈中自说污不污相。所谓不毁戒不欺佛。若受佛戒不能护持则欺诸佛。是污佛家。何以故。受戒时生佛家中。破戒则欺诸佛。名污佛家。问曰。必定菩萨有破戒耶。答曰。不断烦恼是事可畏未久入必定菩萨或有破戒。如大胜佛法中说。难陀故破戒。我说此事犹以为畏。但以经有此说。信佛语故心则信受。若受戒不破不欺诸佛。名为不污佛家。复次戒名三学。戒学心学慧学。破此学名污佛家。如法受戒而后毁破名为欺佛。如是二句各有义趣。欺佛者。空自发愿不如说行。欺诳众生是名欺佛。复次一切法中不如说行。名为欺佛。坚住萨婆若不动如大山者。是菩萨一切发愿求萨婆若种种因缘。乃至大地狱苦心不移动。如须弥山王吹不可动。常修转上法者。从初发心常求索胜法。入初地中更修上法。如是展转心无厌足。乐出世间法不乐世间者。世间法名随顺世间事增长生死。六趣三有五阴十二入十八界十二因缘诸烦恼有漏业等出世间法名随所用法能出三界。所谓五根五力七觉八道四念处四正勤四如意足空无相无作解脱门戒律仪多闻无贪恚痴善根厌离心不放逸等。是菩萨利根故。不乐世间虚妄法。但乐出世间真实法。即治欢喜地。难治而能治者。治名通达无碍。如人破竹初节为难余者皆易。初地难治治已余皆自易。何以故。菩萨在初地。势力未足善根未厚。修习善法未久故。眼等诸根犹随诸尘心未调伏。是故诸烦恼犹能为患。如人势力未足逆水则难。又此地中魔及魔民多为障碍故。以方便力勤行精进。是故此地名为难治。如是信力转增上为首。不乐世间法为后。修此二十七法。治菩萨初欢喜地。是故说菩萨应常修行此法。修行名一心不放逸。常行常观除诸过恶。故名为治。如人所行道路治令清净。是诸法不但修治初地。一切诸地皆以此法。问曰。汝已说得初地方便及净治法。菩萨云何安住而不退失。答曰。常行成就。如是信力转增上等法。名为安住初地。菩提名上道。萨埵名深心。深乐菩提故名为菩提萨埵。复次众生名萨埵。为众生修集菩提故名菩提萨埵。上法者。信等法能令人成佛道故名为上法

    释愿品第五

已说入初地方便及净治法。菩萨因愿故得入诸地。又成就信力增上等功德故安住其地。今当分别此愿

  愿供养奉给　　恭敬一切佛
  愿皆守护持　　一切诸佛法

此是诸菩萨初愿。从初发心乃至得阿耨多罗三藐三菩提。于其中间所有诸佛。尽当供养奉给恭敬。供养名花香璎珞幡盖灯明起塔庙等。奉给名衣服卧具所须之物。恭敬名尊重礼拜迎来送去合掌亲侍。复次以小乘法教化众生名为供养。以辟支佛法教化众生名为奉给。以大乘法教化众生名为恭敬。是第一愿。护持一切诸佛法者。菩萨作是念。一切过去未来现在十方三世诸佛法我应守护。问曰。过去诸佛已灭法亦随灭。未来诸佛未出法亦未有。尚无初转法轮。何况余法。云何当得守护。正可守护现在诸佛法。以诸佛现在故。答曰。过去未来现在诸佛法。皆是一体一相。是故若守护一佛法。则为守护三世诸佛法。如经说。佛告诸比丘。毗婆尸佛法出家受戒着衣持钵禅定智慧说法教化亦如我也。是故汝难不然。是第二愿也。复次

  诸佛从兜术　　退来在世间
  乃至教化讫　　永入无余界
  处胎及生时　　出家趣道场
  降魔成佛道　　初转妙法轮
  奉迎诸如来　　及于余时中
  愿我悉当得　　尽心而供养

诸佛始从兜术天上退下世间。终至无余涅槃。于其中间入胎时大设供养。及生时出家趣道场。降魔王成佛道转法轮奉迎如来。余时者。现大神通人天大会广度众生。尔时当以华香幡盖伎乐歌颂称赞。出家受法如说修行。以第一供养之具供养诸佛。是第三愿。复次

  愿教化众生　　令悉入诸道

教名教他以善法。化名远离恶法。我当以此二法令无量阿僧祇众生。住声闻辟支佛道。是第四愿。复次

  愿一切众生　　成就佛菩提
  有人向声闻　　辟支佛道者

是人修集声闻辟支佛法未入法位。我当教化令趣佛道。有人不向声闻辟支佛道。我当教化令向无上佛道。有人向无上佛道者。我当示教利喜令其功德转更增益。如是教化一切众生。是第五愿。复次

  愿使一切法　　信解入平等

一切法者。凡所有法。度法非度法。摄觉意法。非摄觉意法。助道法非助道法。圣道所摄法非圣道所摄法。应修法不应修法。应近法不应近法。应生法不应生法。生法不生法。现在法非现在法。因缘生法非因缘生法。因缘法非因缘法。从思惟生法不从思惟生法。粗法细法。受法不受法。内法外法。内入所摄法非内入所摄法。外入所摄法非外入所摄法。五阴所摄法非五阴所摄法。五受阴所摄法非五受阴所摄法。四谛所摄法非四谛所摄法。助世法非助世法。依贪法依出法。颠倒法非颠倒法。变法非变法。悔法非悔法。大法小法。受处法非受处法。可断法不可断法。知见法不知见法。有漏法无漏法。有系法无系法。有净法无净法。有上法无上法。有觉法无觉法。有观法无观法。可喜法不可喜法。相应法不相应法。有分别法无分别法。行法无行法。有缘法无缘法。有次第法无次第法。可见法不可见法。有对法无对法。可见有对法不可见无对法。有相法无相法。可行法不可行法有为法无为法。险法非险法。有本法无本法。有出法无出法。众生法非众生法。苦者法非苦者法。恼法非恼法。有法非有法。逆法非逆法。乐报法非乐报法。苦报法非苦报法。忆生法非忆生法。智首行法非智首行法。信首行法非信首行法。思惟首行法非思惟首行法。愿首行法非愿首行法。色法非色法。教法非教法。变化法非变化法。如意游行法非如意游行法。欲本法非欲本法。因善法非因善法。因善根法非因善根法。定法非定法。身法非身法。口法非口法。意法非意法。有对触生法非有对触生法。意触生法非意触生法。恶法非恶法。善法非善法。能生法非能生法。念念灭法非念念灭法。摄聚法非摄聚法。明分法非明分法。因法非因法。缘法非缘法。因缘法非因缘法。因生法非因生法。有因法非有因法。一法异法。灭法非灭法。摄根法非摄根法。共心法非共心法。心法非心法。心数法非心数法。共触五法非共触五法。共得十六法非共得十六法。细法粗法。回向法非回向法。善法不善法。无记法见谛所断法思惟所断法不断法。学法无学法。非学非无学法等。无量千万种诸法。皆令入空无相无作门平等无二。以信解力故。是第六愿。复次

十住毗婆沙论卷第二十住毗婆沙论卷第三

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

    释愿品之余

  愿净佛土故　　灭除诸杂恶

杀生偷盗邪淫妄语两舌恶口绮语。贪恚邪命饮酒等。有如是恶名为不净。复次国土中有地狱畜生饿鬼等诸恶道名为不净。复次众生无信懈怠乱心愚痴谄曲悭嫉忿恨重邪见慢憍慢大慢我慢邪慢。矫异自亲激动抑扬。因利求利贵于世乐。放逸自恣多欲恶欲邪贪邪淫。不识父母沙门婆罗门。不忍辱破威仪难与语。邪觉观贪欲嗔恚睡眠调戏疑所覆蔽名为不净。复次恶鸟兽多怨贼。无水浆饥馑灾疫人畏非人畏。内反逆外贼寇。若多雨若亢旱诸衰恼小劫尽诸苦恼等名为不净。复次众生短命恶色无力多诸忧苦。少胆干多疾病少威力。少眷属恶眷属易坏眷属。小居家儜劣邪出家名为不净。复次僧佉榆伽忧楼迦王那波罗他毗佉那蓱莎王。那吉略仙人象仙人断淫人上弟子行者。放羊者。大心者。忍辱者。乔昙摩鸠兰陀磨活人者。度人者。缘水者。婆罗沙伽那颇罗堕阇。着衣者。无衣者。韦索衣者。皮衣者。草衣者。着下衣者。角鸱毛衣者。木皮衣者。三洗者。随顺者。事梵王者。事究摩罗者。事毗舍阇者。事金翅鸟者。事乾闼婆者。事阎罗王者。事毗沙门王者。事密迹神者。事浮陀神者。事龙者。裸形沙门。白衣沙门。染衣沙门。末迦梨沙门。毗罗哆子者。迦旃延尼子者。萨耆遮子者。持牛戒者。鹿戒者。狗戒者。马戒者。象戒者。乞戒者。究摩罗戒者。诸天戒者。上戒者。淫欲戒者。净洁戒者。火戒者。说色灭涅槃者。说声灭涅槃者。说香灭涅槃者。说味灭涅槃者。说触灭涅槃者。说觉观灭涅槃者。说喜灭涅槃者。说苦乐灭涅槃者。水衣为鬘者。水净者。食净者。生净者。执杵臼者。打石者。喜洗者。浮没者。空地住者。卧刺蕀者。世性者。大者我者。色等者。声等者。香等者。味等者。触等者。地知者。水知者。火知者。风知者。虚空知者。和合知者。变知者。眼知者。耳知者。鼻知者。舌知者。身知者。意知者。神知者。如是等在家出家种种邪见邪行名为不净。复次其地高下坑坎埠阜榛丛刺蕀多所妨阂。尘土坌秽泥潦臼陷。恶山巉岩屈曲隈障。重岭隔塞峻峭难上。碱卤干燥沙砾瓦石。众果少味色香不具。药草不良。势力薄少少有妙色声香味触。园林楼阁流水浴池小山土岭。登缘远望娱乐之处皆悉鲜少。郡县聚落不相接近。地多丘荒人民希少。多见无福贫穷下劣诸城。宰牧大官贵人诸贾客主。巧匠工师学读之人。亦复甚少。衣服卧具医药便身之具甚为难得。虽得非妙名为不净。不净略说有二种。一以众生因缘。二以行业因缘。众生因缘者。众生过恶故。行业因缘者。诸行过恶故。此二事上已说。转此二事则有众生功德行业功德。此二功德名为净土。是净国土当知随诸菩萨本愿因缘。诸菩萨能行种种大精进故。所愿无量不可说尽。是故今但略说开示事端。其余诸事应如是知。略说净土相。所谓菩萨善得阿耨多罗三藐三菩提。佛功德力法具足。声闻具足。菩提树具足。世界庄严众生善利。可度者多大众集会佛力具足。善得菩提者以十事庄严。一离诸苦行。二无厌劣心。三速疾得。四无求外道师。五菩萨具足。六无有魔怨。七无诸留难。八诸天大会。九希有事具足。十时具足。离诸苦行者。若菩萨为阿耨多罗三藐三菩提出家。不行诸苦行。所谓若四日若六日若八日。若半月若一月。乃至食一麻一米一果。或但饮水或但服气。不以如是苦行求道。安坐道场。而成佛道。无厌劣心者。若菩萨少得厌离心即时出家。速疾得者。若菩萨出家已即得阿耨多罗三藐三菩提。不求外道师者。若菩萨出家已时。有外道大师。有名称者。不往咨求。汝等说何法论何事以何为利。亦不于四方求索。菩萨具足者。菩萨欲成佛道时。三千大千世界中诸菩萨及他方诸菩萨。各持供养具来围绕已。待佛成道放大光明各共供养。从佛闻法皆是不退转一生补处。无魔怨者。若菩萨垂成佛时。无有魔军能来破者。无诸留难者。菩萨垂成佛时。乃至无有毫厘烦恼来入其心。诸大众集会者。若菩萨垂成佛时。四天王诸天忉利诸天夜摩天兜率陀天化乐天他化自在天梵天乃至阿迦腻吒天。诸龙神夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽等一切诸神。十方无量世界。各持第一上妙供养之具来供养菩萨。名为大众集会。又声闻人言。十世界诸天尽来。名为诸天大会。希有行具足者。若菩萨得佛时。地六种震动。十方无量三千大千世界诸魔王宫殿。皆变坏无色光不复现。无量须弥山皆悉动摇。无量大海皆悉振荡。一切世界出非时华。雨栴檀末香及诸天名华诸希有事。时具足者。时无疾疫饥馑刀兵流离逃迸。雨泽随时无诸灾横。诸国王等如法治化。人民安乐寿命延长。无有怨贼诸恶鸟兽毒虫鬼神恼害众生。佛功德力者。一切去来今佛威力。功德智慧无量深法。等无差别。但随诸佛本愿因缘。或有寿命无量。或有见者即得必定。闻名者亦得必定。女人见者即成男子身。若闻名者亦转女身。或有闻名者即得往生。或有无量光明众生遇者离诸障盖。或以光明即入必定。或以光明灭一切苦恼。无量寿命者。寿命无量劫过诸算数。一劫百劫千劫万劫亿劫百千万亿那由他阿僧祇劫。如是久住为利益怜愍众生故。一切诸佛虽力能无量寿。以本愿故。有久住世者。有不久住者。见时得入必定者。有众生见佛即住阿耨多罗三藐三菩提阿惟越致地。何以故。是诸众生见佛身者。心大欢喜清净悦乐。其心即摄得如是菩萨三昧。以是三昧力通达诸法实相。能直入阿耨多罗三藐三菩提必定地。是诸众生长夜深心种见佛入必定善根。以大悲心为首。善妙清净。为通达一切佛法故。为度一切众生故。是善根成就时至。是故得值此佛。又以诸佛本愿因缘二事和合故此事得成。闻佛名入必定者。佛有本愿。若闻我名者即入必定。如见佛闻亦如是。女人见得转女形者。若有一心求转女形。深自厌患。有信解力誓愿男身。如是女人得见佛者即转女形。若女人无有如是业因缘。又女身业未尽。不得值如是佛。女人闻佛名转女形者。此事因缘如见佛中说。闻佛名得往生者。若人信解力多。诸善根成就。业障碍已尽。如是之人得闻佛名。又是诸佛本愿因缘便得往生。无量光明者。一切佛光明所昭。随意远近。此说无量者是其常光。常光明不可由旬里数以为限量。遍满东方若干百千万亿由旬。不可得量。南西北方四维上下亦复如是。但知其无量而莫知边际。遇光明得除诸盖者。是诸佛本愿力所致。贪欲嗔恚睡眠调悔疑除此障盖。众生遇光即能念佛。念佛因缘故念法。念法故诸盖得除。光明触身苦恼皆灭者。若众生堕地狱畜生饿鬼非人之中。多诸苦恼。以佛本愿神通之力光触其身即得离苦。法具足者。一切诸佛法悉皆具足。无有具足不具足者。诸佛说法同故法俱具足。但以本愿因缘故差别不同。或有久住不久住耳。何谓法具足。法有略说有广说。有略广说。有具足声闻乘。有具足辟支佛乘。有具足大乘。以诸神通力守护。令不为外道所坏。不为诸魔所破。久住于世。略说者。以少言辞包含多义。利根之人闻则开悟。广说者。于一事一义种种因缘。为诸钝根乐分别者敷演解说。若略广说者。亦以一言包举广义。又亦种种演散一义。有具足声闻乘具足辟支佛乘具足大乘者。此义后当说。神力护法者。以佛神力护念是法。以诸佛印印之。诸佛印者。所谓四大因离四黑因。不为外道所坏者。一切沙门婆罗门外道论师。所有邪见。说生灭味患出。又觉一切善。说破坏因缘。不为一切魔所坏者。诸佛有无量无边功德智慧方便神通力故。魔虽有力而不能坏。又诸菩萨力故魔不能坏。法久住者。若一劫若减一劫。若过数百劫千劫万劫十万劫百万劫千万劫万万劫无量千万亿那由他阿僧祇劫乃至无量无边劫。声闻具足者。一切诸佛悉皆具足声闻僧。但诸佛本愿因缘故。有少多差别。何谓具足。所谓如来声闻众。具足持戒禅定智慧解脱解脱知见。同等清净悉是利根。益诸菩萨形色严净。具足持戒者。远离杀生偷盗邪淫妄语两舌恶口绮语饮酒邪命等诸恶法。又毗尼所制皆悉远离。又能成就无漏戒故。具足禅定者。四禅四无量心四无色定八解脱八背舍八胜处十一切入等。及得无漏诸禅定故。具足智慧者。成就四种智慧。从多闻生从思惟生。从修集生从先世业因缘果报生。具足解脱者。于一切烦恼得解脱。又于一切障阂得解脱。具足解脱知见者。知名识其事。见名明了其事。于解脱中了了知见无疑。又知名尽智。见名见四谛。同等者。诸入须陀洹果。悉皆同等。乃至阿罗汉亦如是。清净者成就三种清净。身清净口清净意清净。利智者。但闻少语能广解了通达义趣。略能作广广能作略。义理微隐能令易解。利益菩萨者。念诸菩萨乃至初发心者亦不轻慢。深爱敬故。常开示善恶为说佛道方便因缘。形色严净者。身体姝美姿容具足兼有相好。见者欢喜如辟支佛。行来进止坐卧寐寤。饮食澡浴着衣持钵。威仪庠序无所阙少。若人见者心则清净。菩提树具足者。所有大树娑罗树多罗树提罗迦树多摩罗树婆求罗树瞻卜树阿输迦树娑呵迦罗树分那摩树那摩树那迦树尸利沙树涅劬陀树阿输陀树波勒叉树忧昙钵罗树等。于此诸大树中随取一树。在平地者高广具足根茎枝叶滋润茂盛。华色鲜明无有伤缺。其树举高五十由旬。端直平泽无有盘节。皮肤细软色白鲜净。无有刺阂内不朽腐。又不空中虫蝎伤啮。其根深固连编相次。其华严饰如鬘璎珞。枝叶蔚茂犹如圆盖。次第分布功殊人造。其叶青鲜犹如宝色。枝无绞戾萎黄枯叶。无有虫蚁蚊蚋虻蚁。其下清净布诸金沙。种种光明周匝昭耀。栴檀香水以洒其地。平坦柔软清凉快乐。牛头栴檀细末布上。诸天常雨曼陀罗华。烧黑沉香芬馨流溢。五色天缯参罗垂列。清风微动猗靡随顺。鸟兽游侧寂然无声。其树左右天常雨华。众妙杂色自然间错垂以为璎犹如龙身身上往往悬以金色华贯。四面大枝垂宝罗网。众宝庄严犹紫金山。巍巍姝妙如帝释幢。斯由菩萨百千万亿阿僧祇劫修集善行功德所致。种种妙宝化为师子王。四师子顶上有广大宝床敷诸天缯。四天王天忉利诸天夜摩天兜率陀天化乐天他化自在天梵天乃至阿迦腻吒天。乘琉璃车磲马瑙大青宝帝青宝金刚颇梨众宝宫殿。其色无比光明远昭。俱集宝树围绕供养。又十方无量世界诸菩萨众随本所愿备诸供具。雨众宝物花香幡盖种种伎乐等。是名具足菩提树。世间庄严者。菩萨观察十方清净国土最上妙者而发大愿。我修集功德所得国土。复胜于此第一无比。众生善利者。众生端正无诸疾患无有老病。寿无量阿僧祇劫悉皆化生。身无众秽具足三十二相。光明无量。烦恼微薄易可化度。可度具足者。一坐说法恒河沙众生同时得度自有余佛演说法时度一人二人。是诸众生宿种善根。结使微薄闻说即悟。大众集会者。有佛大会满一由旬。或十由旬。有百千万亿由旬。有满三千大千世界。此中大集会者。十方恒河沙世界以为大会。又其会中但是福德之人。及诸天八部。初地菩萨乃至十住悉共来会。唯除诸佛。佛力具足者。诸佛所行四十不共法。是一一法所行处。一切无量无边。是第七愿。复次

  俱行于一事　　愿无有怨竞

若菩萨所作福德。若布施持戒忍辱精进禅定智慧。若谛舍灭慧四功德处。若因诸大愿。求佛道时应作是愿。若有余人同我行此六波罗蜜四功德处求佛道者。愿我以此福德因缘。不于余人而生怨竞。何以故。同行一事。诸有智者说有怨相。世间亦复现有此事。除此过故发是大愿。是第八愿。复次

  愿行菩萨道　　转不退转轮
  令除诸烦恼　　得入信清净

轮者法轮。不退转者无人能坏。菩萨应如是发愿。我当如说行道。必转不退法轮。转此法轮除诸众生三毒烦恼。转舍生死入佛法众。苦集灭道中使得清净。是第九愿。复次

  愿一切世界　　皆示成菩提

随诸世界应有佛事处。尽于其中示得阿耨多罗三藐三菩提。安乐一切众生故。灭度一切众生故。以阿耨多罗三藐三菩提大故独说。其余入胎出胎生长在家出家受戒苦行。降伏魔众梵王劝请及转法轮。大众集会广度众生。现大神力示大灭度。如此诸事悉皆如是应作。是知有如是无量力。能利无量无边众生。不应但于一国示成佛道。有人言。于一佛国所有四天下。诸阎浮提是一佛土。过此已外唯佛能知。而实不尔。是第十愿。复次

  如是诸菩萨　　十大愿为首
  广大如虚空　　尽于未来际
  及余无量愿　　亦各分别说

愿名心所贪乐求欲。必成十者有十种门。广大如虚空者。愿所缘方如所有虚空处愿亦如是。尽未来际者。愿时所住尽一切众生未来生死际。有人言。阿耨多罗三藐三菩提。是未来世生死际。若诸佛入无余涅槃。是生死后际。菩萨志愿无尽而实成佛则止。一切十方世界诸大菩萨。皆有是愿。余无量愿者。诸菩萨成就无量希有功德故。诸所有愿不可尽说。复次

  菩萨发如是　　十大愿究竟

是十大愿。有十究竟事。何等为十。答曰

  众生性世性　　虚空性法性
  涅槃佛生性　　诸佛智性竟
  一切心所缘　　诸佛行处智
  世间法智转　　是名十究竟

初众生性竟。二世间性竟。三虚空性竟。四法性性竟。五涅槃性竟。六佛生性竟。七诸佛智性竟。八一切心所缘竟。九诸佛行处智竟。十世间法智转竟。是名十究竟。问曰。汝言竟何者为竟。此义应分别。答曰

  众生性若竟　　我愿亦复竟
  如众生等竟　　如是诸愿竟
  竟义名无竟　　我善根无竟

众生性竟者。若众生都尽灭。我愿便应息。随世间性尽。虚空性尽。诸法性尽。涅槃性尽。诸佛生性尽。诸智性尽。一切众生心所缘性尽。入佛法智性尽。世间转法转智转尽。我此十愿尔乃尽息。但是众生性等十事实不尽。我是福德善根亦不尽不息。不息义者。无量无边不可思议。过诸算数名为不息。如此三千大千世界。十方无量无边过诸算数故名为世间无边。是诸世界中三界六趣众生无边故名为众生性无边。是一切世界中内外二种虚空性无边故名为虚空性无边。是诸世界中。欲色无色无漏性所摄有为法无边故名为法性无边。若一切众生灭度涅槃性不增不减。是故涅槃性无边。若过去十方诸佛无量无边。今现在十方诸佛亦无量无边。未来十方世界诸佛亦无量无边。是故佛生性无边。诸佛智无量。不可称不可量无等无等等无对无比故。诸佛智性亦无量无边。如佛告阿难。是声闻人诸佛智无量。是故诸佛智性无量无边。于过去世一一众生无量无边心。是诸心皆有缘生。未来世亦如是。现在世一切众生心。亦无量无边皆有缘生。是故心所缘亦无量无边。诸佛力略说有四十不共法。是四十不共法。一一法行处无量无边。行处无量无边故智亦无量无边。是故说佛行处智无量无边。世间转法转智转者。转名以此法有所转。世间者。世间有二种。国土世间众生世间。此中说众生世间。诸佛及诸菩萨。以无量无边方便力引导众生。法转者。以无量无边善根福德摄取诸佛法。智转者。无量诸善法六波罗蜜十地等摄取佛智。是故智转无边。此三同转故合为一愿。是菩萨一一愿牢坚故。成是十无尽愿。方如虚空时如未来际。如是以略说广说。解是十愿究竟

    发菩提心品第六

问曰。初发心是诸愿根本。云何为初发心。答曰

  初发菩提心　　或三四因缘

众生初发菩提心。或以三因缘。或以四因缘。如是和合有七因缘。发阿耨多罗三藐三菩提心。问曰。何等为七。答曰

  一者诸如来　　令发菩提心
  二见法欲坏　　守护故发心
  三于众生中　　大悲而发心
  四或有菩萨　　教发菩提心
  五见菩萨行　　亦随而发心
  或因布施已　　而发菩提心
  或见佛身相　　欢喜而发心
  以是七因缘　　而发菩提心

佛令发心者。佛以佛眼观众生。知其善根淳熟堪任能得阿耨多罗三藐三菩提。如是人者。佛教令发心作是言。善男子来。今可发心当度苦恼众生。或复有人生在恶世。见法欲坏。为守护故。发心作是念。咄哉从无量无边百千万亿阿僧祇劫来。唯有一人二处行出三界。四圣谛大导师。知五种法藏脱于六道。有七种正法大宝。深行八解脱。以九部经教化。有十大力说十一种功德。善转十二因缘相续。说十三助圣道法。有十四觉意大宝。除十五种贪欲。并得十六心无碍解脱。出十六地狱众生。及身十七具足十八不共法。善分别十九住果人。善知分别学人阿罗汉辟支佛诸佛二十根是。大悲心者。是大将主大众主大医王大导师大船师。久乃得是法。行难行苦行。乃得是法。而今欲坏。我当发阿耨多罗三藐三菩提心。厚种善根得成佛道。令法久住无数阿僧祇劫。又行菩萨道时。护持无量诸佛法故勤行精进。或复有人见众生苦恼。可愍无救无归无所依止。流转生死险难恶道。有大怨贼诸恶虫兽生死恐怖诸恶鬼等。常有忧悲苦恼刺蕀。恩爱别离怨会深坑。喜乐之水甚为难得。大寒大热独行其中。旷绝无荫难得度脱。众生于中多诸怖畏。无有救护将导之者。见如是众生。入此生死险恶道中受诸苦恼。以大悲故发阿耨多罗三藐三菩提心。作是言。我当为无救作救无归作归无依作依。我得度已当度众生。我得脱已当脱众生。我得安已当安众生。复有人但从人闻以信乐心等。发无上道心。作是念。我当修善法不断绝故。或堕必定得无生法忍。集诸福德善根淳熟故。或值诸佛或值大菩萨。能知众生诸根利钝深心本末性欲差别。善知方便为般若波罗蜜所护。能作佛事者知我发愿。善根成熟故令住必定。若无生法忍。是诸菩萨。在第七第八第九第十地。如佛善知众生心力教令发心。不以但有信乐力等教令发心。复有人见余菩萨行道修诸善根大悲所护。具足方便教化众生。不惜身命多所利益。广博多闻世间奇特人中标胜。疲苦众生为作荫覆。安住布施持戒忍辱精进禅定智慧惭愧质直柔软调和。其心清净深乐善法。见如是人而作是念。是人所行我亦应行所修愿行我亦应修。我为得是法故当发是愿。作是念已发无上道心。复有人行大布施。施佛及僧或但施佛以饮食衣服等。是人因是布施。念过去诸菩萨能行施者。韦蓝摩韦首多罗萨婆檀尸毗王等。即发菩提心。以此施福回向阿耨多罗三藐三菩提。复有人若见若闻佛三十二相。足下平手足轮指网缦手足柔软七处满纤长指足跟广身佣直足趺高平毛上旋伊泥[跳-兆+尃]臂长过膝阴马藏身金色皮软薄一一孔一毛生眉间白毫上身如师子肩圆大腋下满得知妙味身方如尼拘楼陀树顶有肉髻广长舌梵音声师子颊四十齿齐白密致眼睛绀青色睫如牛王等相。心则欢喜作是念。我亦当得如是相。如是相人所得诸法我亦当得。即发阿耨多罗三藐三菩提心。以是七因缘发菩提心。问曰。汝说七因缘发菩萨心。为皆当成有成有不成。答曰。是不必尽成。或有成有不成。问曰。若尔者应解说。答曰

  于七发心中　　佛教令发心
  护法故发心　　怜愍故发心
  如是三心者　　必定得成就
  其余四心者　　不必皆成就

是七心中佛观其根本。教令发心必得成。以不空言故。若为尊重佛法为欲守护。若于众生有大悲心。如是三心必得成就。根本深故。余菩萨教令发心。见菩萨所行发心。因大布施发心。若见若闻佛相发心。是四心多不成。或有成者。根本微弱故

十住毗婆沙论卷第三十住毗婆沙论卷第四

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

    调伏心品第七

问曰。如上品说。三发心必成。余四不必成。云何为成。云何不成。答曰。若菩萨发菩提心行。失菩提心法。是则不成。若行不失菩提心法。是则必成。是故偈说

  菩萨应远离　　失菩提心法
  应一心修行　　不失菩提法

远离名除灭恶法不令入心。若入疾灭。失名若今世若后世忘菩提心。不复随顺修行。应远离如是法。若不失菩提法。不忘菩提心。应常一心勤行。问曰。何等法失菩提心。答曰

  一不敬重法　　二有憍慢心
  三妄语无实　　四不敬知识

有是四法者。若于今世死时。若次后世。则忘失菩提心。不能自知我是菩萨。不复发愿。菩萨行法不复在前。不恭敬法者。法名诸佛所说上中下乘。取要言之。是诸佛如来所用教法。于此法中不恭敬供养尊重赞叹。不生希有想难得想宝物想满愿想。是法能失菩提心。慢心者。自高其心。未得谓得未证谓证。空无相无愿。若无生忍法。若六波罗蜜。若菩萨十地。如是等及诸余从修生者。于此法中未得谓得。妄语者。有属突吉罗。有属波夜提。有属偷兰遮。有属僧伽婆尸沙。有属波罗夷。或有人言。有第六妄语。是妄语心生忏悔。上五妄语初轻后重。第六者最轻。属波罗夷者。自无过人法。若口言若形示。趣以方便现有此德。属僧伽婆尸沙者。若口言若形示。于彼比丘四事中。以一一有根无根事谤。属偷兰遮者。欲以有根无根事谤而说不成。属波夜提者。以无根僧伽婆尸沙事谤。属突吉罗者。除入四种罪余妄语是。自心除灭者。若说戒时自知有小罪。不得向他说。即自心悔。问曰。是妄语者。但在比丘不在白衣。而此论通在家出家。答曰。凡知事实尔。而异知说者。此论中说是总相妄语。以有众生分别故。事分别故。时分别故。五众罪分别故。住处分别故。则有轻重。虽轻妄语习久则重。能失菩提心。众生分别者。断善根邪见者。及余深烦恼者。是则为重。事分别者。若说过人法破僧是。时分别者。出家人妄语则重。五众罪分别者。如波罗夷僧伽婆尸沙罪则重。住处分别者。僧中妄语若证时则重。不恭敬善知识者。不生恭敬畏难想。多行此四法。则失菩提心。问曰。但是四法能失菩提心。更有余法。答曰

  吝惜最要法　　贪乐于小乘
  谤毁诸菩萨　　轻贱坐禅者

吝惜要法者。师所知甚深难得之义。多所利者。贪着利养恐与己等故。秘惜不说。贪乐小乘者。不得大乘滋味故。贪乐二乘。谤诸菩萨者。无罪而言有罪名为谤。菩萨义先已说。此人无过而妄加其罪。若实有罪而论说者。此虽有罪比前为轻。何以故。经说。诸菩萨若实有罪若无有罪。皆不应说。轻贱坐禅者。若在家出家为断诸烦恼故勤行精进。为遮一切烦恼集助佛道法。此人或不善论议。或无才辩。或无重威德。无智之人而轻贱之。则得重罪。复次若于善知识其心怀结恨。亦有谄曲心。贪诸利养等。善知识义先已说。于此教化说法者生嫌恨心。如嫌父母得重罪。谄者心佞媚。曲者身口业现有所作。贪利养等者。贪着利乐称誉。以此法坏质直心故。不能深起善根。如恶色染衣更不受好色。复次

  不觉诸魔事　　菩提心劣弱
  业障及法障　　亦失菩提心

不觉魔事者。若不知诸魔事。则不能制伏。若不制伏则失菩提心。问曰。何等是诸魔事。答曰。说应布施持戒忍辱精进禅定智慧波罗蜜时。及说大乘所摄深义时。不疾乐说。若乐说于其中间余缘散乱。若书读解说论议听受等。骜慢自大其心散乱。缘想余事妄念戏笑。互相讥论两不和合。不能通达实义。从座而去作是念。我于此中无有受记心不清净。亦不说我城邑聚落居家生处。是故不欲闻法不得滋味从座而去。舍大乘所说诸波罗蜜。及于声闻辟支佛自调度经中求萨婆若。若书读解说听受等时。欲乐说余种种事。破散般若波罗蜜。所谓说方国聚落城邑园林帅事贼事。兵甲器仗憎爱苦乐父母兄弟男女妻子衣服饮食卧具医药资生之物。心则散乱失般若波罗蜜。又说贪恚痴怨家亲属好时恶时歌舞伎乐忧愁戏笑经书文颂往世古事国主帝王地水火风五欲富贵及利养等世间诸事。令心喜悦。若魔化作比丘比丘尼形。以声闻辟支佛经因缘令得而作是言。汝应习学是经舍本所习。听法之人不乐听受。说法者其心懈怠各有余缘。听者须法而说者欲至余方。说者乐说而听者欲至余方。说者多欲贪诸利养。听者无有与心。听者信心乐欲闻法。而说者不乐为说。说者乐说听者不乐。或时有说地狱诸苦。不如此身尽苦早取涅槃是最为利。说畜生无量苦恼饿鬼阿修罗种种过恶。说诸生死多有忧患汝于此身早取涅槃是最为利。又称赞世间尊贵富乐。称赞色无色界功德快善。生此中者是为大利。称赞须陀洹乃至阿罗汉果功德之利。汝于此身证此诸果。是汝大利。又说法者乐于眷属。听法者不欲随从。说法者欲至饥乱不安隐国土。语听者言。汝今何用随我至此诸国。即生厌懈而不随逐。说法者贵敬檀越数行问讯。使听法者不得听受。于深法中令生疑惑。此非诸佛所说经法。我所说者是佛经法。若菩萨能行是法得证实际。如是等种种因缘两不和合。当知是等悉是魔事。取要言之于一切善法有障阂者皆是魔事。菩提心劣弱者。诸烦恼有力故。道心劣弱无有势力。于阿耨多罗三藐三菩提志愿永绝。业障者谁有种种业障。此中说能令求大乘人退转者。是法障者乐行不善法。恶空无相无愿及诸波罗蜜等诸深妙法。如是四法能失菩提心。复次

  许施师而诳　　其罪甚深重
  人无有疑悔　　强令生疑悔
  信乐大乘者　　深加重嗔恚
  呵骂说恶名　　处处广流布
  于诸共事中　　心多行谄曲
  如此四黑法　　则失菩提心

施师不与者。应施师物若许若未许而后不与。若与非时与非处与不如法与。此是世间外道法。佛法中从师得经法。若有财物供养法故则以与师。若无无咎无有疑悔。令生疑悔者。此人实不破戒。有少罪相而言大罪。若破正命威仪若破正见皆令生疑悔。嗔大乘人者。有人乘大乘无上乘如来乘大人乘一切智人乘。乃至初发心者于此人中深生嗔恚呵骂讥论。说其恶名令广流布。共事谄曲心者。于和上阿阇梨诸善知识所。不以直心亲近。习行曲心故。乃至未曾所识亦行谄曲。四黑法者。黑名垢秽不净。能失菩提心。如说

  转此五四法　　世世修善行
  如是则不失　　无上菩提心

五四合为二十法。是失菩提心。转此法修习行。世世不忘阿耨多罗三藐三菩提心。转者转上五四法。所谓恭敬法破慢心远离妄语。深尊重善知识。余应如是知。问曰。以何等法世世增长菩提愿。又后复能更发大愿。答曰

  乃至失身命　　转轮圣王位
  于此尚不应　　妄语行谄曲
  能令诸世间　　一切众生类
  于诸菩萨众　　而生恭敬心
  若有人能行　　如是之善法
  世世得增长　　无上菩提愿

菩萨以是法世世增长菩提愿。又复能生清净大愿。若以实语故。死失转轮王位。及失天王位。犹应实说不应妄语。况小因缘而不实语。又于眷属及诸外人离于谄曲。又从初发心已来。一切菩萨生恭敬心。尊重称赞如佛无异。又当随力令住大乘

    阿惟越致相品第八

问曰。是诸菩萨有二种。一惟越致。二阿惟越致应说其相。是惟越致是阿惟越致。答曰

  等心于众生　　不嫉他利养
  乃至失身命　　不说法师过
  信乐深妙法　　不贪于恭敬
  具足此五法　　是阿惟越致

等心众生者。众生六道所摄。于上中下心无差别。是名阿惟越致。问曰。如说于诸佛菩萨应生第一敬心。余则不尔。又言亲近诸佛菩萨恭敬供养。余亦不尔。云何言于一切众生等心无二。答曰。说各有义不应疑难。于众生等心者。若有众生视菩萨如怨贼。有视如父母。有视如中人。于此三种众生中。等心利益欲度脱故无有差别。是故汝不应致难。不嫉他利养者。若他得衣服饮食卧具医药房舍产业金银珍宝村邑聚落国城男女等。于此施中不生嫉妒。又不怀恨而心欣悦。不说法师过者。若有人说应大乘空无相无作法若六波罗蜜若四功德处若菩萨十地等诸大乘法。乃至失命因缘。尚不出其过恶。何况加诸恶事。信乐深妙法者。深法名空无相无愿及诸深经。如般若波罗蜜菩萨藏等。于此法一心信乐无所疑惑。于余事中无如是乐。于深经中得滋味故。不贪恭敬者。通达诸法实相故。于名誉毁辱利与不利等无有异。具此五法者。如上所说。于阿耨多罗三藐三菩提不退转不懈废。是名阿惟越致。与此相违名惟越致。是惟越致菩萨有二种。或败坏者。或渐渐转进得阿惟越致。问曰。所说败坏者其相云何。答曰

  若无有志干　　好乐下劣法
  深著名利养　　其心不端直
  吝护于他家　　不信乐空法
  但贵诸言说　　是名败坏相

无有志干者。颜貌无色威德浅薄。问曰。非以身相威德是阿惟越致相。而作此说是何谓耶。答曰。斯言有谓不应致疑。我说内有功德故身有威德。不但说身色颜貌端正而已。志干者所谓威德势力。若有人能修集善法除灭恶法。于此事中有力名为志干。虽复身若天王光如日月。若不能修集善法除灭恶法者。名为无志干也。虽复身色丑陋形如饿鬼。能修善除恶乃名为志干耳。是故汝难非也。好乐下劣法者。除佛乘已余乘比于佛乘。小劣不如故名为下。非以恶也。其余恶事亦名为下。二乘所得于佛为下耳。俱出世间入无余涅槃故不名为恶。是故若人远离佛乘信乐二乘。是为乐下法。是人虽乐上事。以信乐二乘远离大乘故亦名乐下法。复次下名恶事。所谓五欲又断常等六十二见一切外道论议。一切增长生死。是为下法。行此法故名为乐下法。深著名利者。于布施财利供养称赞事中。深心系念善为方便。不得清净法味故贪乐此事。心不端直者。其性谄曲喜行欺诳。吝护他家者。是人随所入家。见有余人得利养恭敬赞叹。即生嫉妒忧愁不悦。心不清净计我深故。贪着利养生嫉妒心嫌恨檀越。不信乐空法者。诸佛三种说空法。所谓三解脱门。于此空法不信不乐不以为贵。心不通达故。但贵言说者。但乐言辞不能如说修行。但有口说不能信解诸法得其趣味。是名败坏相。若人发菩提心。有如是相者。当知是败坏菩萨。败坏名不调顺。譬如最弊恶马名为败坏。但有马名无有马用。败坏菩萨亦如是。但有空名无有实行。若人不欲作败坏菩萨者。当除恶法随法受名。问曰。汝说在惟越致地中。有二种菩萨。一者败坏菩萨。二者渐渐精进后得阿惟越致。败坏菩萨已解说。渐渐精进后得阿惟越致者。今可解说。答曰

  菩萨不得我　　亦不得众生
  不分别说法　　亦不得菩提
  不以相见佛　　以此五功德
  得名大菩萨　　成阿惟越致

菩萨行此五功德。直至阿惟越致。不得我者。离我着故。是菩萨于内外五阴十二入十八界中求我不可得。作是念

  若阴是我者　　我即生灭相
  云何当以受　　而即作受者
  若离阴有我　　阴外应可得
  云何当以受　　而异于受者
  若我有五阴　　我即离五阴
  如世间常言　　牛异于牛主
  异物共合故　　此事名为有
  是故我有阴　　我即异于阴
  若阴中有我　　如房中有人
  如床上听者　　我应异于阴
  若我中有阴　　如器中有果
  如乳中有蝇　　阴则异于我
  如可然非然　　不离可然然
  然无有可然　　然可然中无
  我非阴离阴　　我亦无有阴
  五阴中无我　　我中无五阴
  如是染染者　　烦恼烦恼者
  一切瓶衣等　　皆当如是知
  若说我有定　　及诸法异相
  当知如是人　　不得佛法味

菩萨如是思惟即离我见。远离我见故则不得我。不得众生者。众生名异于菩萨者。离贪我见故作是念。若他人实有我者。彼可为他因有我故以彼为他。而实求我不可得。彼亦不可得故无彼亦无我。是故菩萨亦不得彼。不分别说法者。是菩萨信解一切法不二故无差别故一相故作是念。一切法皆从邪忆想分别生虚妄欺诳。是菩萨灭诸分别无诸衰恼。即入无上第一义因缘法不随他慧

  实性则非有　　亦复非是无
  非亦有亦无　　非非有非无
  亦非有文字　　亦不离文字
  如是实义者　　终不可得说
  言者可言言　　是皆寂灭相
  若性寂灭者　　非有亦非无
  为欲说何事　　为以何言说
  云何有智人　　而与言者言
  若诸法性空　　诸法即无性
  随以何法空　　是法不可说
  不得不有言　　假言以说空
  实义亦非空　　亦复非不空
  亦非空不空　　非非空不空
  非虚亦非实　　非说非不说
  而实无所有　　亦非无所有
  是为悉舍离　　诸所有分别
  因及从因生　　如是一切法
  皆是寂灭相　　无取亦无舍
  无灰衣不净　　灰亦还污衣
  非言不宣实　　言说则有过

菩萨如是观信解通达于说法中。无所分别。不得菩提者。是菩萨信解空法故。如凡夫所得菩提。不如是得作是念

  佛不得菩提　　非佛亦不得
  诸果及余法　　皆亦复如是
  有佛有菩提　　佛得即为常
  无佛无菩提　　不得即断灭
  离佛无菩提　　离菩提无佛
  若一异不成　　云何有和合
  凡诸一切法　　以异故有合
  菩提不异佛　　是故二无合
  佛及与菩提　　异共俱不成
  离二更无三　　云何而得成
  是故佛寂灭　　菩提亦寂灭
  是二寂灭故　　一切皆寂灭

不以相见佛者。是菩萨信解通达无相法。作是念

  一切若无相　　一切即有相
  寂灭是无相　　即为是有相
  若观无相法　　无相即为相
  若言修无相　　即非修无相
  若舍诸贪着　　名之为无相
  取是舍贪相　　则为无解脱
  凡以有取故　　因取而有舍
  谁取取何事　　名之以为舍
  取者所用取　　及以可取法
  共离俱不有　　是皆名寂灭
  若法相因成　　是即为无性
  若无有性者　　此即无有相
  若法无有性　　此即无相者
  云何言无性　　即为是无相
  若用有与无　　亦遮亦应听
  虽言心不着　　是则无有过
  何处先有法　　而后不灭者
  何处先有然　　而后有灭者
  是有相寂灭　　同无相寂灭
  是故寂灭语　　及寂灭语者
  先亦非寂灭　　亦非不寂灭
  亦非寂不寂　　非非寂不寂

是菩萨如是通达无相慧故无有疑悔。不以色相见佛。不以受想行识相见佛。问曰。云何不以色相见佛。不以受想行识相见佛。答曰。非色是佛。非受想行识是佛。非离色有佛。非离受想行识有佛。非佛有色。非佛有受想行识。非色中有佛。非受想行识中有佛。非佛中有色。非佛中有受想行识。菩萨于此五种中不取相。得至阿惟越致地。问曰。已知得此法是阿惟越致。阿惟越致有何相貌。答曰

  般若已广说　　阿惟越致相

若菩萨观凡夫地声闻地辟支佛地佛地。不二不分别无有疑悔。当知是阿惟越致。阿惟越致。有所言说皆有利益。不观他人长短好丑。不悕望外道沙门有所言说。应知即知应见便见。不礼事余天。不以华香幡盖供养。不宗事余师。不堕恶道不受女身。常自修十善道。亦教他令行。常以善法示教利喜。乃至梦中不舍十善道。不行十不善道。身口意业所种善根。皆为安乐度脱众生。所得果报与众生共。若闻深法不生疑悔。少于语言利安语和悦语柔软语。少于眠睡行来进止心不散乱。威仪庠雅忆念坚固。身无诸虫。衣服卧具净洁无垢。身心清净闲静少事。心不谄曲不怀悭嫉。不贵利养衣服饮食卧具医药资生之物。于深法中无所诤竞。一心听法常欲在前。以此福德具足诸波罗蜜。于世技术与众殊绝。观一切法皆顺法性。乃至恶魔变现八大地狱化作菩萨而语之言。汝若不舍菩提心者当生此中。见是怖畏而心不舍。恶魔复言。摩诃衍经非佛所说。闻是语时心无有异。常依法相不随于他。于生死苦恼而无惊畏。闻菩萨于阿僧祇劫修集善根而退转者。其心不没。又闻菩萨退为阿罗汉得诸禅定说法度人心亦不退。常能觉知一切魔事。若闻萨波若空大乘十地亦空可度众生亦空诸法无所有亦如虚空。若闻如是惑乱其心欲令退转疲厌懈废。而是菩萨倍加精进深行慈悲。意若欲入初禅第二第三第四禅而不随禅生还起欲界法。除破憍慢不贵称赞心无嗔碍。若在居家不染着五欲。以厌离心受如病服药。不以邪命自活。不以自活因缘恼乱于他。但为众生得安乐故处在居家。密迹金刚常随侍卫人及非人不能坏乱。诸根具足无所缺少。不为咒术恶药伏人害物。不好斗诤不自高身不卑他人。不占相吉凶不乐说众事。所谓帝王臣民国土疆界。战斗器仗衣物酒食。女人事古昔事大海中事。如是等事悉不乐说。不往观听歌舞伎乐。但乐说应诸波罗蜜义。乐说应诸波罗蜜法令得增益。离诸斗讼常愿见佛。闻他方现在有佛愿欲往生。常生中国终不自疑我是阿惟越致非阿惟越致。决定自知是阿惟越致。种种魔事觉而不随。乃至转身不生声闻辟支佛心。乃至恶魔现作佛身。语言汝应证阿罗汉。我今为汝说法。即于此中成阿罗汉。亦不信受。为护法故不惜身命常行精进。若说法时无有疑难。无有阙失。如是等事名阿惟越致相。能成就此相者。当知是阿惟越致。或有未具足者。何者是未久入阿惟越致地者。随后诸地修集善根。随善根转深故。得是阿惟越致相

十住毗婆沙论卷第四十住毗婆沙论卷第五

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

    易行品第九

问曰。是阿惟越致菩萨初事如先说。至阿惟越致地者。行诸难行久乃可得。或堕声闻辟支佛地。若尔者是大衰患。如助道法中说

  若堕声闻地　　及辟支佛地
  是名菩萨死　　则失一切利
  若堕于地狱　　不生如是畏
  若堕二乘地　　则为大怖畏
  堕于地狱中　　毕竟得至佛
  若堕二乘地　　毕竟遮佛道
  佛自于经中　　解说如是事
  如人贪寿者　　斩首则大畏
  菩萨亦如是　　若于声闻地
  及辟支佛地　　应生大怖畏

是故若诸佛所说有易行道疾得至阿惟越致地方便者。愿为说之。答曰。如汝所说是儜弱怯劣无有大心。非是丈夫志干之言也。何以故。若人发愿欲求阿耨多罗三藐三菩提。未得阿惟越致。于其中间应不惜身命。昼夜精进如救头燃。如助道中说

  菩萨未得至　　阿惟越致地
  应常勤精进　　犹如救头燃
  荷负于重担　　为求菩提故
  常应勤精进　　不生懈怠心
  若求声闻乘　　辟支佛乘者
  但为成己利　　常应勤精进
  何况于菩萨　　自度亦度彼
  于此二乘人　　亿倍应精进

行大乘者佛如是说。发愿求佛道。重于举三千大千世界。汝言阿惟越致地是法甚难久乃可得。若有易行道疾得至阿惟越致地者。是乃怯弱下劣之言。非是大人志干之说。汝若必欲闻此方便今当说之。佛法有无量门。如世间道有难有易。陆道步行则苦。水道乘船则乐。菩萨道亦如是。或有勤行精进。或有以信方便易行疾至阿惟越致者。如偈说

  东方善德佛　　南栴檀德佛
  西无量明佛　　北方相德佛
  东南无忧德　　西南宝施佛
  西北华德佛　　东北三行佛
  下方明德佛　　上方广众德
  如是诸世尊　　今现在十方
  若人疾欲至　　不退转地者
  应以恭敬心　　执持称名号

若菩萨欲于此身得至阿惟越致地成就阿耨多罗三藐三菩提者。应当念是十方诸佛称其名号。如宝月童子所问经阿惟越致品中说。佛告宝月。东方去此过无量无边不可思议恒河沙等佛土有世界名无忧。其地平坦七宝合成。紫磨金缕交络其界。宝树罗列以为庄严。无有地狱畜生饿鬼阿修罗道及诸难处。清净无秽无有沙砾瓦石山陵堆阜深坑幽壑。天常雨华以布其地。时世有佛号曰善德如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。大菩萨众恭敬围绕。身相光色如燃大金山如大珍宝聚。为诸大众广说正法。初中后善有辞有义。所说不杂具足清净如实不失。何谓不失不失地水火风。不失欲界色界无色界。不失色受想行识。宝月。是佛成道已来过六十亿劫。又其佛国昼夜无异。但以此间阎浮提日月岁数说彼劫寿。其佛光明常照世界。于一说法令无量无边千万亿阿僧祇众生住无生法忍。倍此人数得住初忍第二第三忍。宝月。其佛本愿力故。若有他方众生。于先佛所种诸善根。是佛但以光明触身。即得无生法忍。宝月。若善男子善女人闻是佛名能信受者。即不退阿耨多罗三藐三菩提。余九佛事皆亦如是。今当解说诸佛名号及国土名号。善德者。其德淳善但有安乐。非如诸天龙神福德惑恼众生。栴檀德者。南方去此无量无边恒河沙等佛土有世界名欢喜。佛号栴檀德。今现在说法。譬如栴檀香而清凉。彼佛名称远闻如香流布。灭除众生三毒火热令得清凉。无量明佛者。西方去此无量无边恒河沙等佛土有世界名善。佛号无量明。今现在说法。其佛身光及智慧明昭无量无边。相德佛者。北方去此无量无边恒河沙等佛土有世界名不可动。佛名相德。今现在说法。其佛福德高显犹如幢相。无忧德者。东南方去此无量无边恒河沙等佛土有世界名月明。佛号无忧德。今现在说法。其佛神德令诸天人无有忧愁。宝施佛者。西南方去此无量无边恒河沙等佛土有世界名众相。佛号宝施。今现在说法。其佛以诸无漏根力觉道等宝常施众生。华德佛者。西北方去此无量无边恒河沙等佛土有世界名众音。佛号华德。今现在说法。其佛色身犹如妙华其德无量。三乘行佛者。东北方去此无量无边恒河沙等佛土有世界名安隐。佛号三乘行。今现在说法。其佛常说声闻行辟支佛行诸菩萨行。有人言。说上中下精进故。号为三乘行。明德佛者。下方去此无量无边恒河沙等佛土有世界名广大。佛号明德。今现在说法。明名身明智慧明宝树光明。是三种明常照世间。广众德者。上方去此无量无边恒河沙等佛土有世界名众月。佛号广众德。今现在说法。其佛弟子福德广大故号广众德。今是十方佛善德为初。广众德为后。若人一心称其名号。即得不退于阿耨多罗三藐三菩提。如偈说

  若有人得闻　　说是诸佛名
  即得无量德　　如为宝月说
  我礼是诸佛　　今现在十方
  其有称名者　　即得不退转
  东方无忧界　　其佛号善德
  色相如金山　　名闻无边际
  若人闻名者　　即得不退转
  我今合掌礼　　愿悉除忧恼
  南方欢喜界　　佛号栴檀德
  面净如满月　　光明无有量
  能灭诸众生　　三毒之热恼
  闻名得不退　　是故稽首礼
  西方善世界　　佛号无量明
  身光智慧明　　所照无边际
  其有闻名者　　即得不退转
  我今稽首礼　　愿尽生死际
  北方无动界　　佛号为相德
  身具众相好　　而以自庄严
  摧破魔怨众　　善化诸人天
  闻名得不退　　是故稽首礼
  东南月明界　　有佛号无忧
  光明踰日月　　遇者灭烦恼
  常为众说法　　除诸内外苦
  十方佛称赞　　是故稽首礼
  西南众相界　　佛号为宝施
  常以诸法宝　　广施于一切
  诸天头面礼　　宝冠在足下
  我今以五体　　归命宝施尊
  西北众音界　　佛号为华德
  世界众宝树　　演出妙法音
  常以七觉华　　庄严于众生
  白毫相如月　　我今头面礼
  东北安隐界　　诸宝所合成
  佛号三乘行　　无量相严身
  智慧光无量　　能破无明闇
  众生无忧恼　　是故稽首礼
  上方众月界　　众宝所庄严
  大德声闻众　　菩萨无有量
  诸圣中师子　　号曰广众德
  诸魔所怖畏　　是故稽首礼
  下方广世界　　佛号为明德
  身相妙超绝　　阎浮檀金山
  常以智慧日　　开诸善根华
  宝土甚广大　　我遥稽首礼
  过去无数劫　　有佛号海德
  是诸现在佛　　皆从彼发愿
  寿命无有量　　光明照无极
  国土甚清净　　闻名定作佛
  今现在十方　　具足成十力
  是故稽首礼　　人天中最尊

问曰。但闻是十佛名号执持在心。便得不退阿耨多罗三藐三菩提。为更有余佛余菩萨名得至阿惟越致耶。答曰

  阿弥陀等佛　　及诸大菩萨
  称名一心念　　亦得不退转

更有阿弥陀等诸佛。亦应恭敬礼拜称其名号。今当具说。无量寿佛。世自在王佛。师子意佛。法意佛。梵相佛。世相佛。世妙佛。慈悲佛。世王佛。人王佛。月德佛。宝德佛。相德佛。大相佛。珠盖佛。师子鬘佛。破无明佛。智华佛。多摩罗跋栴檀香佛。持大功德佛。雨七宝佛。超勇佛。离嗔恨佛。大庄严佛。无相佛。宝藏佛。德顶佛。多伽罗香佛。栴檀香佛。莲华香佛。庄严道路佛。龙盖佛。雨华佛。散华佛。华光明佛。日音声佛。蔽日月佛。琉璃藏佛。梵音佛。净明佛。金藏佛。须弥顶佛。山王佛。音声自在佛。净眼佛。月明佛。如须弥山佛。日月佛。得众佛。华生佛。梵音说佛。世主佛。师子行佛。妙法意师子吼佛。珠宝盖珊瑚色佛。破痴爱闇佛。水月佛。众华佛。开智慧佛。持杂宝佛。菩提佛。华超出佛。真琉璃明佛。蔽日明佛。持大功德佛。得正慧佛。勇健佛。离谄曲佛。除恶根栽佛。大香佛。道映佛。水光佛。海云慧游佛。德顶华佛。华庄严佛。日音声佛。月胜佛。琉璃佛。梵声佛。光明佛。金藏佛。山顶佛。山王佛。音王佛。龙胜佛。无染佛。净面佛。月面佛。如须弥佛。栴檀香佛。威势佛。燃灯佛。难胜佛。宝德佛。喜音佛。光明佛。龙胜佛。离垢明佛。师子佛。王王佛。力胜佛。华齿佛。无畏明佛。香顶佛。普贤佛。普华佛。宝相佛。是诸佛世尊现在十方清净世界。皆称名忆念。阿弥陀佛本愿如是。若人念我称名自归。即入必定得阿耨多罗三藐三菩提。是故常应忆念以偈称赞

  无量光明慧　　身如真金山
  我今身口意　　合掌稽首礼
  金色妙光明　　普流诸世界
  随物增其色　　是故稽首礼
  若人命终时　　得生彼国者
  即具无量德　　是故我归命
  人能念是佛　　无量力威德
  即时入必定　　是故我常念
  彼国人命终　　设应受诸苦
  不堕恶地狱　　是故归命礼
  若人生彼国　　终不堕三趣
  及与阿修罗　　我今归命礼
  人天身相同　　犹如金山顶
  诸胜所归处　　是故头面礼
  其有生彼国　　具天眼耳通
  十方普无碍　　稽首圣中尊
  其国诸众生　　神变及心通
  亦具宿命智　　是故归命礼
  生彼国土者　　无我无我所
  不生彼此心　　是故稽首礼
  超出三界狱　　目如莲华叶
  声闻众无量　　是故稽首礼
  彼国诸众生　　其性皆柔和
  自然行十善　　稽首众圣王
  从善生净明　　无量无边数
  二足中第一　　是故我归命
  若人愿作佛　　心念阿弥陀
  应时为现身　　是故我归命
  彼佛本愿力　　十方诸菩萨
  来供养听法　　是故我稽首
  彼土诸菩萨　　具足诸相好
  以自庄严身　　我今归命礼
  彼诸大菩萨　　日日于三时
  供养十方佛　　是故稽首礼
  若人种善根　　疑则华不开
  信心清净者　　华开则见佛
  十方现在佛　　以种种因缘
  叹彼佛功德　　我今归命礼
  其土甚严饰　　殊彼诸天宫
  功德甚深厚　　是故礼佛足
  佛足千辐轮　　柔软莲华色
  见者皆欢喜　　头面礼佛足
  眉间白毫光　　犹如清净月
  增益面光色　　头面礼佛足
  本求佛道时　　行诸奇妙事
  如诸经所说　　头面稽首礼
  彼佛所言说　　破除诸罪根
  美言多所益　　我今稽首礼
  以此美言说　　救诸着乐病
  已度今犹度　　是故稽首礼
  人天中最尊　　诸天头面礼
  七宝冠摩足　　是故我归命
  一切贤圣众　　及诸人天众
  咸皆共归命　　是故我亦礼
  乘彼八道船　　能度难度海
  自度亦度彼　　我礼自在者
  诸佛无量劫　　赞扬其功德
  犹尚不能尽　　归命清净人
  我今亦如是　　称赞无量德
  以是福因缘　　愿佛常念我
  我于今先世　　福德若大小
  愿我于佛所　　心常得清净
  以此福因缘　　所获上妙德
  愿诸众生类　　皆亦悉当得

又亦应念毗婆尸佛。尸弃佛。毗首婆伏佛。拘楼珊提佛。迦那迦牟尼佛。迦叶佛。释迦牟尼佛。及未来世弥勒佛。皆应忆念礼拜以偈称赞

  毗婆尸世尊　　无忧道树下
  成就一切智　　微妙诸功德
  正观于世间　　其心得解脱
  我今以五体　　归命无上尊
  尸弃佛世尊　　在于邠他利
  道场树下坐　　成就于菩提
  身色无有比　　如然紫金山
  我今自归命　　三界无上尊
  毗首婆世尊　　坐娑罗树下
  自然得通达　　一切妙智慧
  于诸人天中　　第一无有比
  是故我归命　　一切最胜尊
  迦求村大佛　　得阿耨多罗
  三藐三菩提　　尸利沙树下
  成就大智慧　　永脱于生死
  我今归命礼　　第一无比尊
  迦那含牟尼　　大圣无上尊
  优昙钵树下　　成就得佛道
  通达一切法　　无量无有边
  是故我归命　　第一无上尊
  迦叶佛世尊　　眼如双莲华
  弱拘楼陀树　　于下成佛道
  三界无所畏　　行步如象王
  我今自归命　　稽首无极尊
  释迦牟尼佛　　阿输陀树下
  降伏魔怨敌　　成就无上道
  面貌如满月　　清净无瑕尘
  我今稽首礼　　勇猛第一尊
  当来弥勒佛　　那伽树下坐
  成就广大心　　自然得佛道
  功德甚坚牢　　莫能有胜者
  是故我自归　　无比妙法王

复有德胜佛。普明佛。胜敌佛。王相佛。相王佛。无量功德明自在王佛。药王无阂佛。宝游行佛。宝华佛。安住佛。山王佛。亦应忆念恭敬礼拜以偈称赞

  无胜世界中　　有佛号德胜
  我今稽首礼　　及法宝僧宝
  随意喜世界　　有佛号普明
  我今自归命　　及法宝僧宝
  普贤世界中　　有佛号胜敌
  我今归命礼　　及法宝僧宝
  善净集世界　　佛号王幢相
  我今稽首礼　　及法宝僧宝
  离垢集世界　　无量功德明
  自在于十方　　是故稽首礼
  不诳世界中　　无碍药王佛
  我今头面礼　　及法宝僧宝
  今集世界中　　佛号宝游行
  我今头面礼　　及法宝僧宝
  美音界宝花　　安立山王佛
  我今头面礼　　及法宝僧宝
  今是诸如来　　住在东方界
  我以恭敬心　　称扬归命礼
  唯愿诸如来　　深加以慈愍
  现身在我前　　皆令目得见

复次过去未来现在诸佛。尽应总念恭敬礼拜以偈称赞

  过去世诸佛　　降伏众魔怨
  以大智慧力　　广利于众生
  彼时诸众生　　尽心皆供养
  恭敬而称扬　　是故头面礼
  现在十方界　　不可计诸佛
  其数过恒沙　　无量无有边
  慈愍诸众生　　常转妙法轮
  是故我恭敬　　归命稽首礼
  未来世诸佛　　身色如金山
  光明无有量　　众相自庄严
  出世度众生　　当入于涅槃
  如是诸世尊　　我今头面礼

复应忆念诸大菩萨。善意菩萨。善眼菩萨。闻月菩萨。尸毗王菩萨。一切胜菩萨。知大地菩萨。大药菩萨。鸠舍菩萨。阿离念弥菩萨。顶生王菩萨。喜见菩萨。郁多罗菩萨。萨和檀菩萨。长寿王菩萨。羼提菩萨。韦蓝菩萨。睒菩萨。月盖菩萨。明首菩萨。法首菩萨。成利菩萨。弥勒菩萨。复有金刚藏菩萨。金刚首菩萨。无垢藏菩萨。无垢称菩萨。除疑菩萨。无垢德菩萨。网明菩萨。无量明菩萨。大明菩萨。无尽意菩萨。意王菩萨。无边意菩萨。日音菩萨。月音菩萨。美音菩萨。美音声菩萨。大音声菩萨。坚精进菩萨。常坚菩萨。坚发菩萨。庄严王菩萨。常悲菩萨。常不轻菩萨。法上菩萨。法意菩萨。法喜菩萨。法首菩萨。法积菩萨。发精进菩萨。智慧菩萨。净威德菩萨。那罗延菩萨。善思惟菩萨。法思惟菩萨。跋陀婆罗菩萨。法益菩萨。高德菩萨。师子游行菩萨。喜根菩萨。上宝月菩萨。不虚德菩萨。龙德菩萨。文殊师利菩萨。妙音菩萨。云音菩萨。胜意菩萨。照明菩萨。勇众菩萨。胜众菩萨。威仪菩萨。师子意菩萨。上意菩萨。益意菩萨。增意菩萨。宝明菩萨。慧顶菩萨。乐说顶菩萨。有德菩萨。观世自在王菩萨。陀罗尼自在王菩萨。大自在王菩萨。无忧德菩萨。不虚见菩萨。离恶道菩萨。一切勇健菩萨。破闇菩萨。功德宝菩萨。花威德菩萨。金璎珞明德菩萨。离诸阴盖菩萨。心无阂菩萨。一切行净菩萨。等见菩萨。不等见菩萨。三昧游戏菩萨。法自在菩萨。法相菩萨。明庄严菩萨。大庄严菩萨。宝顶菩萨。宝印手菩萨。常举手菩萨。常下手菩萨。常惨菩萨。常喜菩萨。喜王菩萨。得辩才音声菩萨。虚空雷音菩萨。持宝炬菩萨。勇施菩萨。帝网菩萨。马光菩萨。空无阂菩萨。宝胜菩萨。天王菩萨。破魔菩萨。电德菩萨。自在菩萨。顶相菩萨。出过菩萨。师子吼菩萨。云荫菩萨。能胜菩萨。山相幢王菩萨。香象菩萨。大香象菩萨。白香象菩萨。常精进菩萨。不休息菩萨。妙生菩萨。华庄严菩萨。观世音菩萨。得大势菩萨。水王菩萨。山王菩萨。帝网菩萨。宝施菩萨。破魔菩萨。庄严国土菩萨。金髻菩萨。珠髻菩萨。如是等诸大菩萨。皆应忆念恭敬礼拜求阿惟越致地

    除业品第十

问曰。但忆念阿弥陀等诸佛及念余菩萨得阿惟越致。更有余方便耶。答曰。求阿惟越致地者。非但忆念称名礼敬而已。复应于诸佛所忏悔劝请随喜回向。问曰。是事何谓。答曰

  十方无量佛　　所知无不尽
  我今悉于前　　发露诸黑恶
  三三合九种　　从三烦恼起
  今身若先身　　是罪尽忏悔
  于三恶道中　　若应受业报
  愿于今身偿　　不入恶道受

十方诸佛者。现在一切诸佛。命根成就未入涅槃。十方名四方四维上下。佛名所应知事悉知无余。发露者。于诸佛所发露一切罪无所覆藏。后不复作如堤防水。黑恶者。无智慧明故多犯众恶若不善法若隐没无记。三三种者。身口意生恶现报生报后报。自作教他作随喜作。从三种烦恼起三种烦恼。谓欲界系色界系无色界系。若助贪欲烦恼。若助嗔恚烦恼。若助愚痴烦恼。若上烦恼若中烦恼若下烦恼。今身先身尽忏悔者。今世先世所作众恶尽悔无余。地狱者。八种热地狱。十种寒冰地狱。畜生者。若地生若水生若无足若二足若多足。饿鬼者。食唾食吐食荡涤汁。食脓血屎尿等。若我行业应于此三恶道受者。愿令是罪此身现受。若后身受莫于地狱饿鬼畜生中受

复次佛自说忏悔法。若菩萨欲忏悔罪。应作是言。我于今现在十方世界中诸佛得阿耨多罗三藐三菩提。转法轮雨法雨。击法鼓吹法蠡建法幢。以法布施满足众生。多所利益多所安隐。怜愍世间饶益天人。我今以身口意。头面礼现在诸佛足。诸佛知者见者世间眼世间灯。我于无始生死已来所起罪业。为贪欲嗔恚愚痴所逼故。或不识佛不识法不识僧。或不识罪福。或身口意多作众罪。或以恶心出佛身血。或毁灭正法。破坏众僧。杀真人阿罗汉。或自行十不善道。或教他令行。或复随喜。若于众生有不爱语。若以斗秤欺诳侵人。以诸邪行恼乱众生。或不孝父母。或盗塔物及四方僧物。佛所说经戒或有毁破。违逆和尚阿阇梨。若人发声闻乘辟支佛乘。发大乘者。恶言毁辱轻贱嫌恨悭嫉覆心故。于诸佛所或起恶口。或说是法非法。说非法是法。今以是罪于现在诸佛知者见者证者所。尽皆发露不敢覆藏。从今已后不敢复作。若我有罪应堕地狱畜生饿鬼阿修罗中。不值三尊生在诸难。愿以此罪今世现受。如过去诸菩萨求佛道者。忏悔恶业罪。我亦如是发露忏悔不敢覆藏后不复作。若今诸菩萨求佛道者。忏悔恶业罪。我亦如是发露忏悔不敢覆藏后不复作。如未来诸菩萨求佛道者。忏悔恶业罪。我亦如是发露忏悔不敢覆藏后不复作

如过去未来现在诸菩萨求佛道者。忏悔恶业罪。已忏悔今忏悔当忏悔。我亦如是忏悔恶业罪不敢覆藏后不复作

问曰。汝已说忏悔法。云何为劝请。答曰

  十方一切佛　　现在成道者
  我请转法轮　　安乐诸众生
  十方一切佛　　若欲舍寿命
  我今头面礼　　劝请令久住

转法轮者。说四圣谛义三转十二相是苦谛是苦集是苦灭是至苦灭道。是名一转四相。是苦谛应知。是苦集应断。是苦灭应证。是至苦灭道应修。是名第二转四相。是苦谛知已。是苦集断已。是苦灭证已。是至苦灭道修已。是名第三转四相。四相者。四谛中生眼智明觉。有人言声闻乘辟支佛乘大乘。是名法轮解说。是三乘义名为转法轮。安乐诸众生者。五欲乐不名为安乐。为今世后世。得清净安乐入于三乘。是名安乐。是人劝请诸佛转法轮。令诸众生受涅槃乐。若未得涅槃令受世间乐。是故说安乐。寿者。受业报因缘故。命根相续得住。如变化所作随心业而住。心业止则灭。劝请名至诚求愿。诸佛观诸众生巨细无异。是故求请望得从愿。莫舍寿命住无量阿僧祇劫度脱众生

复次佛自说劝请法。菩萨应作是言。我礼现在十方诸佛。始得阿耨多罗三藐三菩提未转法轮我今求请。愿转法轮击法鼓吹法蠡建法幢。设大法祠然大法炬。以是法施满足众生。多所利益多所安乐。怜愍世间饶益天人。是故我今劝请。是名劝请。诸佛转法轮久住者。亦应言现在十方诸佛。是诸佛欲舍寿命我请久住。多所利益多所安乐。怜愍世间饶益天人。问曰。汝已说忏悔劝请。云何名为随喜。答曰

  所有布施福　　持戒修禅行
  从身口意生　　去来今所有
  习行三乘人　　具足三乘者
  一切凡夫福　　皆随而欢喜

布施福者。从舍悭法生。持戒福者。能伏身口业生。禅行者诸禅定是。从身口生者。因身口布施持戒迎来送去等。因意生者禅定慈悲等。去来今所有者。一切众生三世福德。行三乘者。求声闻乘辟支佛乘大乘。具足三乘者。成就阿罗汉乘辟支佛乘佛乘。一切者皆尽无余。凡夫者未得四谛者是。福德者有二种业。善及不隐没无记业是。随喜者。他人作福心生欢喜称以为善

问曰。汝以说忏悔劝请随喜。云何为回向。答曰

  我所有福德　　一切皆和合
  为诸众生故　　正回向佛道

我者己身。所有福德者。若从身生。若从口生。若从意生。若因布施生。若因持戒生。若因修禅生。若因随喜生。若因劝请生。如是等及余所有善。皆名所有福德。一切皆和合者。心念诸福德合集称量知其广大。诸众生者三界众生。正者如诸佛回向。如真实回向。回向菩提。回向菩提者。回诸福德向阿耨多罗三藐三菩提。又随喜回向。此二事佛亦自说。有菩萨摩诃萨。欲随喜回向应念诸佛。断三界相续道灭诸戏论。干烦恼淤泥。灭诸刺棘除诸重担逮得己利。正智解脱心得自在尽诸有结。无量无边不可思议阿僧祇十方世界。一一世界中。亦无量无边不可思议阿僧祇诸佛出已灭度。从初发心乃至得佛入无余涅槃。至遗法未尽于其中间是诸佛所有善根福德。应六波罗蜜及所受辟支佛记所有善根。又声闻人善根。若布施持戒修禅。及学无学无漏善根。及诸佛戒品定品慧品解脱知见品。大慈大悲等无量功德。及诸佛有所说法。于此法中有人信解受学得此法利。是诸人等所有善根。于此法中及凡夫所种善根及诸天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。得闻法已生诸善心。乃至畜生闻法生诸善心。及诸佛欲入涅槃时。众生所种善根。是诸善根福德一切和合称量使无遗余。以最上最妙最胜无上无等无等等随喜。随喜已。以是随喜所生福德。回向阿耨多罗三藐三菩提。未来现在诸佛亦如是。是三世诸佛福德及因诸佛所生福德心皆随喜。回向阿耨多罗三藐三菩提。是故偈说

  罪应如是忏　　劝请随喜福
  回向无上道　　皆亦应如是
  如诸佛所说　　我悔罪劝请
  随喜及回向　　皆亦复如是

无始世界来。有无量遮佛道罪。应于十方诸佛前忏悔。劝请诸佛随喜回向亦应如是。如佛所知所见所许忏悔。我亦如是忏悔劝请诸佛。随喜回向亦复如是。若如是忏悔劝请随喜回向。是名正回向。问曰。云何名为诸佛所知所见所许忏悔劝请随喜回向。答曰。忏悔劝请如先说。随喜回向。如大品经中。须菩提白佛言。世尊。所说菩萨于过去未来现在一切诸佛及诸弟子一切众生所有福德善根尽和合称量。以最上随喜。世尊。云何名为最上随喜。佛告须菩提。若菩萨于过去未来现在诸法。不取不念不见不得不分别而能如是思惟。是诸法皆从忆想分别众缘和合有一切法实不生无所从来。是中乃至无有一法已生今生当生。亦无已灭今灭当灭。诸法相如是。我顺诸法相随喜。随喜已亦随诸法实相回向阿耨多罗三藐三菩提。是名最上随喜回向

复次须菩提。求佛道善男子善女人。不欲谤佛者。应以善根如是回向。应作是念。如诸佛心佛智佛眼。知见是善根福德本末体相从何而有。我亦如是随诸佛知见随喜。如诸佛所许我亦如是以善根回向。若菩萨如是回向。则不谤诸佛亦无过咎。深心信解如实回向。是名大回向具足回向。复次须菩提。善男子善女人以诸善根福德应如是回向。如诸贤圣。戒品定品慧品解脱品解脱知见品。不系欲界不系色界不系无色界。不在过去不在未来不在现在。以不系三界故。是回向亦如是不系。所回向处亦不系。若菩萨能如是得心信解如实。是名不失回向无毒回向法性回向。若菩萨于此回向取相贪着是名邪回向。是故诸菩萨摩诃萨。应如诸佛所知法相。以是法相回向。能至阿耨多罗三藐三菩提。是名正回向

十住毗婆沙论卷第五十住毗婆沙论卷第六

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

    分别功德品第十一

问曰。忏悔劝请随喜回向。应云何作于昼夜中几时行。答曰

  以右膝着地　　偏袒于右肩
  合掌恭敬心　　昼夜各三时

以恭敬相故。右膝着地偏袒右肩合掌。是事应初夜一时礼一切佛。忏悔劝请随喜回向。中夜后夜皆亦如是。于日初分日中分日后分亦如是。一日一夜合为六时。一心念诸佛如现在前。问曰。作是行已得何果报。答曰

  若于一时行　　福德有形者
  恒河沙世界　　乃自不容受

若于一时中。行此事者。所得福德若有形者。恒河沙等无量无边不可思议三千大千世界所不容受。如三支经除罪业品中说。佛告舍利弗。若善男子善女人。以满恒河沙等三千大千世界七宝布施诸佛。若复有人劝请诸佛转法轮此福为胜。又佛于般若波罗蜜随喜回向品中说。善哉善哉须菩提。汝能作佛事。与诸菩萨说回向法。若菩萨作是念。如诸佛知见是善根福德本末体相。何因缘故有。我亦如是随佛所知所见回向。是人得福多。譬如恒河沙等三千大千世界中众生皆成就十善道。菩萨回向福德最上最妙最胜无比无等无等等。须菩提。置是恒河沙等三千大千世界众生。成就十善道。若恒河沙等三千大千世界众生皆得四禅。其福比此。亦复最上最妙最胜。四无量心四无色定五神通。得须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道亦如是。如法回向福德最上最妙最胜。须菩提。置此恒河沙等三千大千世界众生皆作辟支佛。若有恒河沙等三千大千世界众生。皆发阿耨多罗三藐三菩提心。复有恒河沙等三千大千世界众生。其一菩萨以取相心。供养是诸众生衣服饮食卧具医药。于恒河沙等劫。以一切乐具供养恭敬尊重赞叹。一一菩萨皆亦如是。须菩提。于意云何。是诸菩萨以此因缘。得福多不。甚多世尊。如是福德算数譬喻所不能及。若是福德有形。恒河沙等世界所不能受。佛告须菩提。善哉善哉须菩提。是菩萨为般若波罗蜜守护。以善根随法性回向所得福德。先诸菩萨取相布施福德。百分不及一。千分万分百千万亿分。乃至算数譬喻所不能及。何以故。先诸菩萨取相分别布施。皆是有量有数。又般若波罗蜜回向品中说。佛告净居天子。置此恒河沙等三千大千世界众生皆发阿耨多罗三藐三菩提心。余恒河沙等三千大千世界众生。一一菩萨以取相心供养是诸众生衣服饮食卧具医药资生之物。随意供养于恒河沙等劫。诸天子。若是恒河沙等三千大千世界众生发阿耨多罗三藐三菩提心。余恒河沙等三千大千世界中众生皆亦发阿耨多罗三藐三菩提心。其一菩萨供养是诸菩萨衣服饮食卧具医药资生之物于恒河沙等劫。是布施取相分别。如是诸菩萨各于恒河沙等劫。供养是诸菩萨衣服饮食卧具医药资生之物。随意供养恭敬尊重赞叹。皆是取相布施。若菩萨为般若波罗蜜所护。过去未来现在诸佛戒品定品慧品解脱品解脱知见品。及声闻五品。及诸凡夫人于中种善根。已种今种当种。尽和合称量使无遗余。最上最妙最胜无等无等等不可思议随喜福德。回向阿耨多罗三藐三菩提。作是念。我是福德能至佛道。是福德于先取相福德百分不及一。千分万分亿分乃至算数譬喻所不能及。何以故。是诸菩萨取相分别布施故。复有恒河沙等三千大千世界众生。皆发阿耨多罗三藐三菩提心。身行善业口行善业意行善业。复有恒河沙等三千大千世界众生。皆发阿耨多罗三藐三菩提心。若人于恒河沙等劫恶口骂詈皆能忍受。于恒河沙等劫。身心精进除诸懈怠。摄心禅定无诸乱想。而皆取相不如菩萨如法性回向其福为胜。是故如汝先说。作如是事得何等利者。得如是大福德聚。是故若人欲得如是无量无边不可思议福德聚者。应行是忏悔劝请随喜回向。不惜身命利养名闻。于昼夜中常应勤行。问曰。汝但说劝请随喜回向中福德。何故不说忏悔中福德耶。答曰。于诸福德中。忏悔福德最大。除业障罪故。得善行菩萨道行劝请随喜回向与空无相无愿和合无异。复次忏悔。如如意珠随愿皆得。如佛说。若人欲于婆罗门大姓中生。刹利大姓中生。居士大家中生。应如是忏悔罪业无所覆藏后不更作。若有人欲生四天王天上忉利天上夜摩天上兜率陀天上化乐天上他化自在天上。亦应如是忏悔罪业无所覆藏后不更作。若人欲生梵世乃至非想非非想处。是人亦应如是忏悔罪业无所覆藏后不更作。若人欲得须陀洹果斯陀含果阿那含果阿罗汉果。亦应如是忏悔罪业。若人欲得三明六神通声闻道中自在力尽声闻功德彼岸。亦应如是忏悔罪业。若人欲得辟支佛道。亦应如是忏悔罪业。若人欲得一切智慧不可思议智慧无碍智慧无上智慧。亦应如是忏悔罪业无所覆藏后不更作。是故当知忏悔有大果报。问曰。汝言忏悔除业障罪。余经中说。佛告阿难故作业必当受报。又阿毗昙中说。诸业因缘不空。果报不失不灭。又经说众生皆属业。皆从业有依止于业。众生随业各自受报。若现报若生报若后报。又业报经中阎罗王为众生说言。咄众生。汝此罪非父母作天作沙门婆罗门作。汝自作自应受报。又贤圣偈中说

  实法如金刚　　业力将无胜
  今我已得道　　而受恶业报

又佛自说

  大海诸名山　　丘陵树林木
  地水火风等　　日月诸星宿
  若至劫烧时　　皆尽无有余
  业于无量劫　　常在而不失
  汝遇具相者　　一切智人师
  先所造罪业　　已偿其果报
  今虽得值佛　　垢尽证圣果
  以余因缘故　　木刺犹在身

是故不应言忏悔除业罪。答曰。我不言忏悔则罪业灭尽无有报果。我言忏悔罪则轻薄于少时受。是故忏悔。偈中说。若应堕三恶道愿人身中受。又如来智印经中说。佛告弥勒。诸菩萨深心爱乐阿耨多罗三藐三菩提者。有罪应在恶道受报是罪轻微。后世受恶形。或多疾病无有威德生下贱家贫穷家邪见家邪业自活家。生违意处多忧愁处。国土破坏聚落破坏。居家破坏所爱破坏。不遇善知识常不闻法不得利养。若得粗弊常不自供。能令下贱之所信敬于诸大人不得信敬。修集诸福时。多有障碍不得成就。诸根闇钝习禅意乱。不得无漏觉意功德。不知经法随宜所趣乃至恶梦偿恶道报。又佛说人有小罪。今世可受报。是罪转多便堕地狱。云何是人今世小罪转多而堕地狱。有人不修身不修戒不修心不修慧无有大意。是人小罪便堕地狱。云何是人有罪今世应受报。罪不增长不入地狱。有人修身修戒修心修慧。有大志意心无拘阂。如是人有罪不复增长今世现受。譬如人以小器盛水。着一升盐则不可饮。若复有人。以一升盐投于大池尚不觉盐味。何况叵饮。何以故。水多盐少故。罪亦如是。偈说

  升盐投大海　　其味无有异
  若投小器水　　碱苦不可饮
  如人大积福　　而有少罪恶
  不堕于恶道　　余缘而轻受
  又人薄福德　　而有少罪恶
  心志狭小故　　罪令堕恶道
  若人火势弱　　食少难消食
  此人虽不死　　其身受大苦
  若人身势强　　食少难消食
  此人终不死　　但受轻微苦
  善福慧火弱　　而有少恶罪
  是罪无救者　　能令堕地狱
  有大福德者　　虽有罪恶事
  不令堕地狱　　现身而轻受
  譬如鸯崛魔　　多杀于人众
  又欲害母佛　　得阿罗汉道

今世轻受又如阿阇世害得道父王。以佛及文殊师利因缘故重罪轻受。又如人毒蛇生时雨血。后渐长大意欲杀人眼看即死。若以气嘘亦死。是故时人号为气嘘。是人命终时。舍利弗往至其所。心中嗔恚眼看不死嘘亦不死。舍利弗身色方更光显。心即清净上下七观。以是因缘命终之后七反生天上七反生人中。于后人寿四万岁时。当得辟支佛道。身黄金色。时人谓是金聚来。欲斫取即命终涅槃。又如阿输伽王。以兵伏阎浮提。杀万八千宫人。先世施佛土故。起八万塔。常于大阿罗汉所听受经法。后得须陀洹道。即人身轻偿。如是等罪多行福德志意旷大。集诸功德故不堕恶道。是故汝先难若忏悔罪业。则灭尽无有果报者是语不然。复次若言罪不可灭者。毗尼中佛说忏悔除罪则不可信。是事不然。是故业障罪应忏悔

    分别布施品第十二

菩萨能行如是忏悔劝请随喜回向

  福德力转增　　心亦益柔软
  即信佛功德　　及菩萨大行

是菩萨以忏悔劝请随喜回向故。福力转增心调柔软。于诸佛无量功德清净第一凡夫所不信而能信受。及诸大菩萨清净大行。希有难事亦能信受。复次

  苦恼诸众生　　无是深净法
  于此生愍伤　　而发深悲心

菩萨信诸佛菩萨无量甚深清净第一功德已愍伤诸众生。无此功德但以诸邪见受种种苦恼故。深生悲心

  念是诸众生　　没在苦恼泥
  我当救拔之　　令在安隐处

是菩萨得悲心已作是念。是诸众生常为贪恚痴所病。以身心受诸苦恼。我当拔济使离身心苦恼深埿。毕竟无生老病死患。得住安隐涅槃乐处。是故于此苦恼众生生深悲心。以悲心故为求随意使得安乐。则名慈心

  若菩萨如是　　深随慈悲心
  断所有贪惜　　为施勤精进

菩萨是求佛道。度苦恼众生。念者随名随顺慈悲不随余心。深慈名遍。诸众生念彻骨髓。所有名一切内外。所有金银珍宝国城妻子等。贪名欲得无厌惜名。爱着不欲与他断名。离此三恶如是则开檀波罗蜜门。是故常应一心勤行无令放逸。何以故。菩萨作是念。我今随所能作利益众生。发坚固施心

  所有一切物　　有命若无命
  转轮天王位　　无求而不与
  乃至于男女　　族姓好妻妾
  年少甚端严　　巧便能事人
  恭顺心柔和　　爱念情甚至
  惜之过寿命　　求者皆能与
  乃至身血肉　　骨髓及手足
  头目耳鼻等　　及身皆能与

是菩萨定心布施。凡所有外物。若有命若无命。无有乞而不与。无命物者金银珍宝。乃至转轮圣王位天王位。有命物者男女贵族好家年少妻妾。端严柔和恭敬善顺。爱惜之至过于身命而能施人。如一切施菩萨所有外物及妻子等皆能施与。是菩萨乃至自身肉血头目手足耳鼻。割肉出骨破骨出髓。如萨陀波仑。或举身施与。一切所爱无过身者。亦能施与如萨和檀。如菩萨为兔以身施与仙人。如尸毗王以身代鸽。问曰。是菩萨为分别知布施及布施果报故。能以难事施。为但以慈悲心所发故施。答曰

  如是布施者　　则得如是报
  内以支节等　　并及诸外物

内物名头目手足等。外物名妻子金银宝物等。是菩萨如实知施。是得是报各各分别。又信诸经所说。或以天眼得知。问曰。汝先说知以身支节布施及外物布施所得果报。今可说所得果报。答曰。宝顶经中无尽意菩萨第三十品檀波罗蜜义中说。菩萨立愿须食者施食。令我得五事报。一者得寿命。二者得胆。三者得乐。四者得力。五者得色。须浆与浆者。先于人中得香美饮。后得除诸烦恼渴爱。须乘与乘则得随意乐报。成就四如意足。后得三乘道。须衣与衣则得惭愧衣报。须灯明与灯明。则得佛眼光明。须伎乐与伎乐。则得具足天耳。须末香涂香与末香涂香。则得身无臭秽。须汁与汁则得味味相报。须房舍与房舍。则得与一切众生作归依救护。施资生之具者。则得助菩提功德。施医药者则得无老病死常乐安隐。施奴婢者。则得自在随意具足智慧。施金银珊瑚车磲马脑者。则得具足三十二相。施种种杂物庄严具。则得八十随形好。施象马车者。则得具足大乘。施园林者则得具足禅定乐。施男女者。得所爱阿耨多罗三藐三菩提。施仓谷宝藏者。则得具足法藏。施以一国土一阎浮提四天下王位者。则得道场自在法王。施诸戏乐具者。则得法乐。以足施者。则得法足能到道场。以手施者。则得宝手。能施一切以耳鼻施者。则得具足身体。以眼施者。则得具足无阂法眼。以头施者。则得三界特尊一切智慧。以血肉施者。令诸众生得坚固行。以髓施者得金刚身无能坏者。如是开施门果报。余施果报亦应知。以卧具施者。得三乘安隐解脱。床以坐处施者。则得菩提树下道场不可坏处。以妻施者。为得法喜娱乐故。以道施者。为生死失道众生得入正道故。以筏施者为得度欲流有流见流无明流故。以骨施者。为得戒坚定坚解脱坚解脱知见坚众生坚故。以眷属施者。为得成就无量无边阿僧祇福德天人眷属同心清净不可沮坏故。以善哉施者。为得说法时天龙夜叉乾闼婆沙门婆罗门欢喜称赞故。以经卷施者。为得九部经久住无量时故。以法施者。为得通达一切法故。集一切功德故。是菩萨如是乐行布施。知布施清净。知布施果报所得多少。是故

  非法财施等　　乃至智呵施
  无有如是施　　但合空等施

非法者。恶行所得财。财名资生之物。取要言之。以恶业得财物施。菩萨知是布施不清净故。如是等诸余非法施乃至智所呵施不为此事。菩萨行布施。唯与空智慧等种种功德和合。问曰。所说非法得财施等。及空智慧等和合施。此二施应广分别。答曰。是二施。无尽意菩萨会品中檀波罗蜜中说。初分别布施功德。所谓诸菩萨无非法求财施。无热恼众生施。无恐畏施。无著故施。无请而不施。无不如所许施。无吝好以不好施。无不深心施。无谄曲施。无假伪施。无损果施。无邪心施。无痴心施。无杂心施。无不信解脱施。无疲厌施。无亲附施。无以承望己施。无求福田者施。无轻一切众生非福田者施。无持戒毁戒高下心施。无求名闻施。无自高心施。无卑他施。无懊惜施。无悔心施。无急唤故施。无恶贱施。无自然法施。无求果报施。无嗔恚施。无令人渴乏施。无恼求者施。无轻弄彼施。无欺诳施。无俾面施。无掷与施。无不一心施。无不自手施。无不常施。无休息施。无断绝施。无竞胜施。无轻少物施。无请随自恣而以轻物施。无不称力施。无非福田施。无于少物劣弱心施。无恃多物憍心施。无邪行施。无乐受生施。无恃色族富贵施。无求生四王释梵天上施。无求声闻辟支佛乘施。无求国王王子施。无限一世施。无厌足施。无不回向萨婆若施。无不净施。无非时施。无刀毒施。无恼弄众生施。无智者所呵施。如是开示施门余不净施亦应当知。所谓诸菩萨无应弃物施。无憎恶涅槃施。无丰饶易得物施。无量恩施。无报恩施。无求反报施。无求守护施。无求吉施。无慢心施。无家法施。无因得即施。无不终身施。无垢心施。无游戏施。无以善知识故施。无轻施。无游逸施。无因失施。无以赞己故施。无以呵骂故施。无以祝愿故施。无以称希有事故施。无以明己信故施。无以畏故施。无诳施。无求眷属施。无不唱导施。无引众施。无不信施。无无因缘施。无随意施。无现奇特施。无自称赞施。无不随所求施。无为伏彼施施。无不爱施。无不任用物施。无不恭敬施。无下施。无以怪相故施。无抑挫施。无挟势得物施。无不清净心施。无疑心施。无破求者心施。无禁忌物施。无分别施。无以酒施。无以兵杖施。无夺彼物施。无令人生疑心施。无以亲近故施。无说彼过咎施。无随所爱施。无嗔施。无痴施。无戏论施。无不为菩提施。问曰。非法求财施。乃至不为菩提施。菩萨为有为无。若尽无者则有过咎不求福田。于众生无差别心。亦无知恩报恩。亦无家法国法施。若有者何以皆言无。答曰。是非法得财施。乃至不为菩提施。菩萨不必尽无。或时有。是布施。檀波罗蜜所不摄。不能具足檀波罗蜜故言无。空等功德和合施者。如无尽意菩萨经檀波罗蜜品中说。菩萨布施。与空心合故不尽。是施无相修故不尽。是施无愿守护故不尽。是施善根所摄故不尽。是施随解脱相故不尽。是施能破一切魔故不尽。是施不杂烦恼故不尽。是施得转胜利故不尽。是施决定心故不尽。是施集助菩提法故不尽。是施正回向故不尽。是施得道场解脱果故不尽。是施无边故不尽。是施不可尽故不尽。是施不断故不尽。是施广大故不尽。是施不可坏故不尽。是施不可胜故不尽。是施至一切智慧故不尽。是施断非法求财施等垢成就空等诸功德故不尽。非法求财施等是施垢施。与垢合是不净施。与空等功德合是净。复次是施净不净今当更说。经说施有四种。有施于施者是净不于受者净。有施于受者是净不于施者净。有施于施者净亦于受者净。有施不于施者净亦不于受者净。若施者成就善身口意业受者成就恶身口意业。是名于施者净不于受者净。若施者成就恶身口意业受者成就善身口意业。是名于受者净不于施者净。若施者成就善身口意业受者亦成就善身口意业。是名于施者净于受者亦净。若施者成就不善身口意业受者亦成就不善身口意业。是名不于施者净亦不于受者净。贪欲嗔恚愚痴。若断若不断。亦应如是分别。复次四种布施中。有净不净。一从施者净。二从受者净。三共净是名净。一不从施者净。二不从受者净。三不共净。是名不净。是中施者有功德故从施者施得净。以受者有功德故从受者施得净。以施者受者有功德故从施者受者施得净。施者有罪故从施者施不净。受者有罪故从受者施不净。施者受者有罪故从施者受者施不净。施者功德受者功德。施者罪受者罪。先已说。问曰。汝说此四种施中。菩萨应行何施。答曰

  四种布施中　　行二种净施
  不求于名利　　及以求果报

是布施有四种三净三不净。不净尽不行。净中行二净。一者施者净不于受者净。二者共净。于此二净施中应常精进。何以故。是菩萨不期果报故。若期果报者。则求受者清净。净名施者受者功德庄严其心清净。不净名施者有悭惜心。如佛说悭为施垢。余烦恼虽为不净悭最为重。问曰。若菩萨于施者净及共净。应勤行此二施。悭为施者垢。亦是施大垢。若菩萨未离欲未能断悭。云何能行此二净施。答曰

  若物能起悭　　则不畜此物

菩萨若于有命无命物知生悭心者则不畜此物。是故有所施皆无吝惜。问曰。外物可不畜身当云何。答曰

  常为利众生　　解身如药树

为利益众生故。信解身如药树。如药树众生有用根茎枝叶华实等各得差病。随意而取无有遮护。菩萨亦如是。为利众生故能自舍身。作是念。若众生取我头目手足肢节脊腹髀膊耳鼻齿舌血肉骨髓等。随其所须皆能与之。或举身尽施。如是降伏其心修集善根。为方便所护。行檀波罗蜜

  总相别相施　　皆悉能回向

是菩萨能以二种净施能知二种回向。一为总相。二为别相。总相回向者。有所施皆回向阿耨多罗三藐三菩提。别相施者。如布施果报中说。复次总相回向者。为安乐利益一切众生。别相回向者。无信众生令得信故。破戒者得持戒故。少闻者得多闻故。懈怠者得精进故。散乱心者得禅定故。愚痴众生得智慧故。悭者得舍心故。如是等种种别相。复次总相回向者。以六波罗蜜。回向阿耨多罗三藐三菩提。别相回向者。施外物时愿诸众生得大最乐。支节布施时愿诸众生具足佛身。问曰。布施有几种回向几种不回向。答曰。一为净四回向三种不回向。一菩萨布施为清净四事故回向。三种不回向。不为得王故回向。不为得欲乐故回向。不为得声闻辟支佛地故回向。不为得王故回向者。遮王则并遮一切贵人力势自在者。不为得欲乐回向者。除上贵人余受富乐五欲自娱者。不为得声闻辟支佛回向者。遮因小乘入无余涅槃。令得安住大乘。久后乃入无余涅槃。为四净回向者。菩萨所施为清净佛土故回向。为清净菩萨故回向。为清净教化众生故回向。为净萨婆若故回向。菩萨应如是方便回向无令布施损减使得势力。问曰。以何法令布施损减。以何法令布施增益。答曰

  若施不回向　　亦无有方便
  求生于下处　　亲近恶知识
  如是布施者　　是则为损减

若布施不回向阿耨多罗三藐三菩提。随逐世间乐故。求生下处无有方便。能出布施禅定果报自在所生。亲近障阂大乘知识。以是四法则布施损减

  离四施得增　　又应三心施
  菩萨顺佛语　　亦不求果报

离此四法布施则得增益。一回向阿耨多罗三藐三菩提。二有方便回向。三求法王处。四亲近善知识。又应以三法心而行布施。一者怜愍一切众生故以菩提心行施。二者不远佛法而行布施。三者不求果报而行布施。复次

  为得三法故　　而行于布施
  为欲求二法　　应当行布施

菩萨为得三法故行布施。一者佛法。二者说法。三者令诸众生住无上乐。又欲求二法行布施者。一者大富。二者具足檀波罗蜜。何以故。若菩萨大富。则离贫苦不取他财不求息利。无有债主不忧偿债。多财富足能自衣食。有能惠施利益亲族及善知识。眷属安乐其家丰饶。常如节会心常欢悦能大施与。眷属不轻人所敬仰。言皆信受众所依附人来师仰入众无畏。常好洗浴名香涂身。着好新衣具足庄严。见诸好色听好音声闻诸妙香。常食最上美味。细触怨贼难坏。善知识欢喜。是于人身得善果报。人所钦慕常称吉善。忘其丑恶。虽生下贱有大人相。虽无巧言成巧言者。虽不多闻成多闻者。虽少智慧成智慧者。若先端正倍复殊胜。若先大家倍复尊贵。若先巧言倍复巧言。若先多闻倍复多闻。若先智慧倍复有智。所可坐卧贵价宝床寤寐安隐侍卫具足。众宝为舍极意游戏。其身贵重须诸经书应意即得。势位随意亲近王易。诸贵人所念。诸医自往常有亲信消息所宜。有疾轻微若病易差。远离今世后世怖畏。毕竟永离不活怖畏常有救护。多有人众诸亲近者自谓多福。为同意者深自欣庆。有少施恩得大酬报。若加小恶得大殃祸。族姓女人少年端正具足庄严。自求给侍诸有谐利悉来归己。若作恶事事辄轻微。少有施作即获大利。多善知识怨憎转少。蛇虺毒药放逸恶人如是等事不得妄近。诸爱敬事皆悉归趣。若获利时众人代喜。若有衰恼人皆忧戚。众共示导竞以善吉。令远非法安住善法。所施业大见莫不欢。若与同心则以为足。不期世间富贵荣利。假使居位人思匡助除其衰恼。见他富贵无所悕尚。人咏其德不扬其过。虽小人名得大人号无不足色。视他颜貌不作矫异。若作婆罗门。于天寺中大获果报。读诸经书得其实利得而能施。若是刹利所习成就。善射音声善能贯练。治世典籍能得果报若是毗舍播殖如意。若是商估能获其利。若是首陀罗所作事业多得如意。问曰。汝先说菩萨不以求果报心施。又复不为豪贵故施。而今说求大富故布施。是语得无自相违背。答曰。不相违也。若自为身求富受乐。是故说不应求富。今说求富但为利益众生。是故说为欲大施故求富。不为身已求富受乐。是则果中说因。若菩萨不得大富虽信乐布施无财可与。是故汝不应作难。复次断二法故应行布施。何等为二。一者悭。二者贪。此二法最为施垢。又得二法故行布施。所谓尽智无生智。又增益三种慧。一者自利慧。二者本慧。三者多闻慧。有人言。增长二法故应行施。一善二慧。略说菩萨应行四种施摄一切善法。一者等心施。二者无对施。三者回向菩提施。四者具足善寂灭心施。菩萨如是具足檀波罗蜜故勤行财施

十住毗婆沙论卷第六十住毗婆沙论卷第七

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

    分别法施品第十三

菩萨于财施应如是修学又应修学法施如说

  众施法施最　　智者应修行

一切布施中第一最上最妙。所谓法施。是施智者所应行。问曰。何故但言智者应行法施。答曰。不智者若行法施即说异论。说异论故自失利亦失他利。问曰。何谓异论。答曰。佛欲灭度时告阿难。从今日后依修多罗莫依人。阿难云何名依修多罗不依人。有比丘来作是言。我现从佛闻现从佛受。是法是善是佛所教。是比丘语莫受莫舍。审谛听已应以经律捡其所说。若不入修多罗不入毗尼。又复违逆诸法相义。应报是比丘言。是法或非佛所说。或长老谬受。何以故。是法不入修多罗不入毗尼。又复违逆诸法相义。是则非法非善非佛所教。如是知已即应除却。复有比丘来作是言。彼住处有大众。有明经上座善说戒律。我现从彼闻。现从彼受。是法是善是佛所教。是比丘语莫受莫舍。审谛听已应以经律捡其所说。若不入修多罗不入毗尼。又复违逆诸法相义。应报是比丘言。长老彼比丘僧法相善相。或作非法非善说。或长老谬受。何以故。是法不入修多罗不入毗尼。又复违逆诸法相义。是则非法非善非佛所教。如是知已即应除却。复有比丘来作是言。彼住处多诸比丘。持修多罗持毗尼持摩多罗迦。我现从彼闻现从彼受。是法是善是佛所教。是比丘语莫受莫舍。审谛听已应以经律捡其所说。若不入修多罗不入毗尼。又复违逆诸法相义。应报是比丘言。长老彼比丘僧法相善相。或作非法非善说。或长老谬受。何以故。是法不入修多罗不入毗尼。又复违逆诸法相义。是则非法非善非佛所教。如是知已即应除却。复有比丘来作是言。彼住处中有长老比丘。多知多识人所尊重。我现从彼闻现从彼受。是法是善是佛所教。是比丘语莫受莫舍。审谛听已应以经律捡其所说。若不入修多罗不入毗尼。又复违逆诸法相义。应报是比丘言。长老彼诸比丘法相善相。或作非法非善说。或长老谬受。何以故。是法不入修多罗不入毗尼。又复违逆诸法相义。是则非法非善非佛所教。如是知已即应除却。是四名异论。是故言智者不依异论而行清白法施。问曰。云何知诸施中法施第一。答曰。经说有二施财法施。二施之中法施为上。复次

  决定王经中　　赞说法功德
  及说法仪式　　应常修习行

若菩萨欲以法施众生者。应如决定王大乘经中称赞法师功德及说法仪式随顺修学。谓说法者应行四法。何等为四。一者广博多学能持一切言辞章句。二者决定善知世间出世间诸法生灭相。三者得禅定慧。于诸经法随顺无诤。四者不增不损如所说行。说法者处师子座复有四法。何等为四。一者欲升高座。先应恭敬礼拜大众然后升座。二者众有女人应观不净。三者威仪视瞻有大人相。敷演法音颜色和悦人皆信受。不说外道经书心无怯畏。四者于恶言问难当行忍辱。处师子座复有四法。何等为四。一者于诸众生生饶益想。二者于诸众生不生我想。三者于诸文字不生法想。四者愿诸众生从我闻法者于阿耨多罗三藐三菩提而不退转。处师子座复有四法。何等为四。一者善能安住陀罗尼门。深信乐法。二者善得般舟三昧。勤行精进持戒清净。三者不乐一切生处。不贪利养。不求果报。四者于三解脱心无有疑。又能善起诸深三昧具足威仪。忆念坚固有念安慧。不调戏不轻躁。不无羞不痴乱。言无错谬守护诸根不贪美味。善摄手足所念不忘。乐行头陀分别世间出世间法。心无疑悔言辞章句不可穷尽。为诸听者求安隐利不求他过。有如是法应处师子座。复有四法。一不自轻身。二不轻听者。三不轻所说。四不为利养。佛告阿难。说法者应说何法。阿难。所可说法不可示不可说无相无为。世尊。法若尔者云何可说。阿难。是法甚深。如来以四相方便而为演说。一以音声。二以名字。三以语言。四以义理。又以四因缘而为说法。一者为度应度众生。二者但说色受想行识名字。三者以种种文辞章句利益众生。四者虽说名字而亦不得。譬如钵油清净无垢。于中观者自见面相。阿难。汝若见若闻智慧男子若持戒女人若圣弟子能作是说我于钵油见实人不。世尊我不闻不见智慧男子持戒女人若圣弟子能作是言我于钵油见真实人。何以故。智者先知钵油非有何况有人。但以假名说言钵油而见人相。阿难。如来亦复如是。但以名字假有所说。阿难。如来以四因缘而为说法。众生闻者心得安乐。种涅槃因。如来说法音声遍满十方世界。众生闻者心得欢喜。离诸恶趣生兜术天。如来声中无男无女。男不取女相女不取男相。如来音者不恼众生不坏诸法。但为示现音声之性。说法者应习行是事。应随所行而为法施。施者受者所得果报。后当广说

    归命相品第十四

上已解说财施法施。今更分别

  白衣在家者　　应多行财施
  余诸善行法　　今当复解说

是二施中。在家之人当行财施。出家之人当行法施。何以故。在家法施不及出家。以听受法者于在家人信心浅薄故。又在家之人多有财物。出家之人于诸经法读诵通达为人解说在众无畏。非在家人之所能及。又使听者起恭敬心不及出家。又若欲说法降伏人心不及出家。如说

  先自修行法　　然后教余人
  乃可作是言　　汝随我所行

是事出家者所宜。非在家者所行。又说

  身自行不善　　安能令彼善
  自不得寂灭　　何能令人寂
  是故身自善　　能令彼行善
  自身得寂灭　　能令人得寂

善法寂灭。是出家者之所应行。又出家之人于听法者恭敬心胜。又出家之人若行财施则妨余善。又妨行远离阿练若处空闲林泽。出家之人若乐财施悉妨修行。如是等事。若行财施必至聚落与白衣从事多有言说。若不从事无由得财。若出入聚落见闻声色。诸根难摄发起三毒。又于持戒忍辱精进禅定智慧心薄。又与白衣从事。利养垢染发起爱恚悭嫉烦恼。惟心思惟力。而自抑制心志。弱者或不自制。或乃致死。或得死等诸恼苦患贪着五欲舍戒还俗故名为死。或能反戒多起重罪。是名死等诸恼苦患。以是因缘故。于出家者称叹法施。于在家者称叹财施。如是广说在家菩萨所行财施。余诸善行今当说之。发心菩萨先应归依佛归依法归依僧。从三归所得功德。皆应回向阿耨多罗三藐三菩提。复次

  归依佛法僧　　菩萨所应知

菩萨应当如实善解归依佛归依法归依僧。问曰。云何名为归依佛。答曰

  不舍菩提心　　不坏所受法
  不舍大悲心　　不贪乐余乘
  如是则名为　　如实归依佛

菩提心者。发心求佛不休不息不舍是心。不坏所受法者。谓菩萨各受所乐善法戒行。是行应行是不应作。若应诸波罗蜜。若应四功德处。如是等种种善法。为利益众生故。受持修行不令毁缺。大悲心者欲度苦恼众生为求佛道乃至梦中亦不离大悲。不贪余乘者。深信乐佛道故。不贪声闻辟支佛乘。有是法故。当知如实归依佛。问曰。云何名为归依法。答曰

  亲近说法者　　一心听受法
  念持而演说　　名为归依法

说法者于佛深法解说敷演。开示善恶断诸疑惑。常数亲近往至其所。供养恭敬一心听受。以忆念力执持不忘。思惟筹量随顺义趣。然后为人如知演说。以是法施功德。回向佛道。是名归依法。问曰。云何名为归依僧。答曰

  若诸声闻人　　未入法位者
  令发无上心　　使得佛十力
  先以财施摄　　后乃以法施
  深信四果僧　　不分别贵众
  求声闻功德　　而不证解脱
  是名归依僧　　又应念三事

声闻人者成声闻乘。未入法位者。于声闻道未得必定。能令此人发佛道心而得十力。若入法位者终不可令发无上心。设或发心亦不成就。如般若波罗蜜中尊者须菩提所说。已入正法位。不能发无上心。何以故。是人于生死已作障隔。不复往来生死。发无上心先以财施。摄者。以衣服饮食卧具医药所须之物摄。出家者以衣服饮食卧具医药杂香涂香摄。在家者以摄因缘生亲爱心。所言信受然后法施。令发无上道心果。僧者四向四果。众者于佛法中。受出家者相。具持诸戒未有果向不分别。如是僧以离恩爱奴故名为贵僧。信乐空无相无愿。而不分别戏论。依止是僧名为归依僧。求声闻功德而不证解脱者。知是僧持戒具足禅定具足智慧具足解脱具足解脱知见具足三明六通心得自在有大威德。舍世间乐出魔境界。利誉称乐不以为喜。衰毁讥苦不以为忧。常行六舍得八解脱随佛所教。有行道者有解脱者行一道者。破二种烦恼。善知三界。善通四谛善除五盖。安住六和敬法。具足七不退法八大人觉。舍离九结得声闻十种力。成就如是诸功德者。名为佛弟子众求如是功德。不求其解脱。何以故。深心信乐佛无碍解故。是名归依僧。复次若闻章句文字法。即得念实相法。名为归命法。若见声闻僧即念发菩提心诸菩萨众是名归依僧。见佛形像即念真佛是故归依佛。问曰。云何名为念真佛。答曰。如无尽意菩萨经中说念佛三昧义。念真佛者。不以色。不以相。不以生。不以性。不以家。不以过去未来现在。不以五阴十二入十八界。不以见闻觉知。不以心意识。不以戏论行。不以生灭住。不以取舍。不以忆念分别。不以法相。不以自相。不以一相。不以异相。不以心缘数。不以内外。不以取相觉观。不以入出。不以形色相貌。不以所行威仪。不以持戒禅定智慧解脱解脱知见。不以十力四无所畏诸佛法。如实念佛者。无量不可思议。无行无知无我我所。无忆无念。不分别五阴十二入十八界。无形无碍无发无住无非住。不住色不住受想行识。不住眼色不住眼识。不住耳声不住耳识。不住鼻香不住鼻识。不住舌味不住舌识。不住身触。不住身识。不住意法不住意识。不住一切诸缘。不起一切诸相。不生一切动念忆想分别等。不生见闻觉知。随行一切正解脱相。心不相续灭诸分别。破诸爱恚坏诸因相。除断先际后际中际。究畅明了无有彼此。无动故无喜。不受味故无乐。本相寂灭故无热。心无所营故解脱。相无色故无身。不受故无受。无想故无结。无行故无为。无知故无识。无取故无行。不舍故非不行。无处故无住。空故无来。不生故无去。一切忆念心心数法及余诸法。不贪不着不取不受不然不灭。先来不生无有生相。摄在法性过眼色虚空道。如是相名为真念佛。又念法者。佛法是善说。得今世报无有定时。可得观察善。将至道智者。内知初中后善言善义善淳善无杂具足清净。能断贪欲能断嗔恚能断愚痴。能除慢心能除诸见能除疑悔。能除憍贵能除诸渴。破所归趣断相续道。尽爱离欲寂灭涅槃。如是相名为念法。以空无相无愿。不生不灭毕竟寂灭无比无示。如念佛义中说。又念法有三种。从佛法是善说。至具足清净名为道。能断贪欲至寂灭涅槃。名为涅槃。空等至无比无示名为法体。又念僧者如先说僧功德。念是三宝得决定心。以如是念求于佛道而行布施。是名归依佛。为守护法而行布施。是名归依法。以是布施起回向心。成佛道时摄菩萨声闻僧。是名归依僧

    五戒品第十五

如是在家菩萨。能修善人业。远离恶人业。如说

  修起善人业　　如法集财用
  堪则为重任　　不堪则不受

善人业者。略说善人业。自住善利亦能利人。恶人业者。自陷衰恼令人衰恼。如法集财用者。不杀不盗不诳欺人。以力集财如法用之供养三宝济恤老病等。堪受能行者则为重任。不堪行者则不受。若菩萨于今世事及后世事。若自利若利他如先所说必能成立。若知不堪行者此则不受复次

  世法无忧喜　　能舍于自利
  常勤行他利　　深知恩倍报

世间法者。利衰毁誉称讥苦乐。于此法中心无忧喜。舍自利勤行他利者。菩萨乃至未曾知识。无因缘者所行善行舍置自利助成彼善。问曰。舍自利勤行他利此事不然。如佛说。虽大利人不应自舍己利如说舍一人以成一家。舍一家成一聚落。舍一聚落成一国土。舍一国土以成己身。舍己身以为正法

  先自成己利　　然后乃利人
  舍己利利人　　后则生忧悔
  舍自利利人　　自谓为智慧
  此于世间中　　最为第一痴

答曰。于世间中为他求利犹称为善以为坚心。况菩萨所行出过世间。若利他者即是自利。如说

  菩萨于他事　　心意不劣弱
  发菩提心者　　他利即自利

此义初品中已广说。是故汝语不然。深知恩倍报者。若人于菩萨所作好事应当厚报。又深知其恩。此是善人相。复次

  贫者施以财　　畏者施无畏
  如是等功德　　乃至于坚牢

施贫以财者。有人先世不种福德。今无方便资生俭少。如是之人随力给恤。施无畏者。于种种诸怖畏。若怨贼怖畏饥饿怖畏水火寒热等。菩萨于此众怖畏中教喻诸人。安隐欢悦令无怖畏。如是功德最坚牢。最在后者于诸忧者为除其忧。于无力者而行忍辱。离慢大慢等。于诸所尊深加恭敬。于多闻者常行亲近。于智慧者咨问善恶。自于所行常行正见。于诸众生不谄不曲不作假爱。求善无厌多闻无量。诸所施作坚心成就。常与善人而共从事。于恶人中生大悲心。于善知识非善知识。皆作坚固善知识想。等心众生不吝要法。如所闻者为人演说。诸所闻法得其趣味。于诸五欲戏乐事中生无常想。于妻子所生地狱想。于资生物所生疲苦想。于产业事生忧恼想。于诸所求破善根想。于居家中生牢狱想。亲族知识生狱卒想。日夜思量得何利想。于不牢身得牢身想。于不坚财生坚财想。复次

  在家法五戒　　心应坚牢住

在家菩萨以三自归行上诸功德应坚住五戒。五戒是总在家之法。应离杀心慈愍众生。知自止足不贪他物。乃至一草非与不取。离于邪淫厌恶房内。防远外色目不邪视。常观恶露生厌离想。了知五欲究竟皆苦。若念妻欲亦应除舍。常观不净心怀怖畏。结使所逼离欲不着。常知世间为苦无我应发是愿。我于何时心中当得不生欲想。况复身行远离妄语。乐行实语不欺于人。心口相应有念安慧如见闻觉知而为人说。以法自处乃至失命言不诡异。酒是放逸众恶之门。常应远离不过于口。不狂乱不迷醉。不轻躁不惊怖。不无羞不戏调。常能一心筹量好丑。是菩萨或时乐舍一切而作是念。须食与食须饮与饮。若以酒施应生是念。今是行檀波罗蜜时随所须与。后当方便教使离酒得念智慧令不放逸。何以故。檀波罗蜜法悉满人愿。在家菩萨以酒施者是则无罪。以是五戒福德回向阿耨多罗三藐三菩提。护持五戒如护重宝如自护身命。问曰。是菩萨但应护持五戒。不护持诸余善业耶。答曰

  菩萨应坚住　　总相五戒中
  余身口意业　　悉亦复应行

在家五戒已说其义。受此五戒应坚牢住。及余三种善业亦应修行。复次在家菩萨所应行法

  随应利众生　　说法而教化

是菩萨于诸众生。随有所乏皆能施与。若在国土城郭聚落林间树下。是中众生随所利益说法教化。所谓不信者为说信法。不恭敬者为说礼节。为少闻者说多闻法。为悭贪者说布施法。为嗔恚者说和忍法。为懈怠者说精进法。为乱意者。说正念处。为愚痴者解说智慧。复次

  随诸所乏者　　皆亦应给足

诸众生有所乏少皆应给足。有人虽富犹有不足。乃至国王亦应有所乏少。是故先虽说贫穷者施财。今更说随所乏少而给足之。复次

  诸有恶众生　　种种加恼事
  谄曲怀憍逸　　恶骂轻欺诳
  背恩无返复　　痴弊难开化
  菩萨心愍伤　　勇猛加精进

诸恶众生以种种恶事侵娆菩萨。菩萨于此心无懈厌不应作是念。如是恶人谁能调伏谁能教化谁能劝勉。令度生死究竟涅槃。谁能与此往来生死。谁能与此和合同事。诸恶无理谁能忍之。我意止息不复共事。我悉舍远不复共事。亦复不能与之和合。是恶中之恶无有返复。何用此等而共从事。菩萨知见众生恶罪难除。应还作是念。是等恶人非少。精进能得令住如所乐法。为是等故我当加心勉力勤行亿倍精进后得大力乃能化。此恶中之恶。难悟众生如大医王。以小因缘便能疗治众生重病。菩萨如是除烦恼病。令住随意所乐功德。我于重罪大恶众生。倍应怜愍起深大悲。如彼良医多有慈心疗治众病。其病重者深生怜愍勤作方便为求良药。菩萨如是于诸众生烦恼病者悉应怜愍。于恶中之恶烦恼重者深生怜愍。勤作方便加心疗治。何以故

  菩萨随所住　　不开化众生
  令堕三恶道　　深致诸佛责

菩萨随所住国土城邑聚落山间树下。力能饶益教化众生。而懈厌嫌恨贪着世乐。不能开化令堕恶道。是菩萨即为十方现在诸佛。深所呵责甚可惭耻。云何以小因缘而舍大事。是故菩萨不欲诸佛所呵责者。于种种谄曲重恶众生。心不应没随力饶益。应以诸方便勤心开化。譬如猛将将兵多所伤损王则深责以诸兵众。无所知故王不责之

    知家过患品第十六

菩萨如是学。应知家过恶。何以故。若知过恶或舍家入道。又化余人令知家过出家入道。问曰。家过云何。答曰。如经中说。佛告郁迦罗。家是破诸善根。家是深棘刺林难得自出。家是坏清白法。家是诸恶觉观住处。家是弊恶不调凡夫住处。家是一切不善所行住处。家是恶人所聚会处。家是贪欲嗔恚愚痴住处。家是一切苦恼住处。家是消尽先世诸善根处。凡夫住此家中不应作而作不应说而说。不应行而行。在此中住。轻慢父母及诸师长。不敬诸尊福田沙门婆罗门家是贪爱忧悲苦恼众患因缘。家是恶口骂詈苦切刀杖系缚考掠割截之所住处。未种善根不种已种能坏。能令凡夫在此贪欲因缘而堕恶道。嗔恚因缘愚痴因缘而堕恶道怖畏因缘而堕恶道。家是不持戒品。舍离定品。不观慧品。不得解脱品。不生解脱知见品。于此家中生。父母爱兄弟妻子眷属车马。增长贪求无有厌足。家是难满如海吞流。家是无足如火焚薪。家是无息觉观相续如空中风。家是后有恶如美食有毒。家是苦性如怨诈亲。家是障碍能妨圣道。家是斗乱种种因缘共相违诤。家是多嗔呵责好丑。家是无常虽久失坏。家是众苦求衣食等方便守护。家是多疑处犹如怨贼。家是无我颠倒贪着假名为有。家是技人虽以种种文饰庄严现为贵人。须臾不久庄严还作贫贱。家是变异会必离散。家如幻假借和合无有实事。家如梦一切富贵久则还失。家如朝露须臾灭失。家如蜜渧其味甚少。家如棘丛受五欲味恶刺伤人。家是针嘴虫。不善觉观常唼食人。家污净命多行欺诳。家是忧愁心多浊乱。家是众共王贼水火恶亲所坏。家是多病多诸错谬如是长者在家菩萨。应当如是善知家过。复次

  菩萨应当知　　在家之过恶
  亲近于布施　　持戒善好喜
  若见诸乞人　　应生五三想

在家菩萨应如是知家过患。当行布施持戒善好。布施名舍贪心。持戒名身口业清净。善名善摄诸根。好喜名同心欢乐。五三想名见乞儿应生五三想。初三者善知识想转身大富想。裨助菩提想。又有三想。折伏悭贪想。舍一切想。贪求一切智慧想。又有三想。随如来教想。不求果报想。降伏魔想。又有三想。见来求者生眷属想。不舍摄法想。舍邪受想。又有三想。离欲想。修慈想。无痴想。今当解第五三想。菩萨因来求者。令三毒折薄舍所施物生离欲想。于求者与乐因缘故。嗔恨心薄名修慈想。是布施回向无上道则痴心薄。是名不痴想。余想义应如是知。复次

  菩萨因求者　　具六波罗蜜
  以是因缘故　　见求应大喜

六波罗蜜者。布施持戒忍辱精进禅定智慧。以因求者能得具足。以是利故。菩萨遥见求者心大欢喜作是念。行福田自然而至。我因此人得具足六波罗蜜。所以者何。若于所施物心不贪惜。是名檀波罗蜜。为阿耨多罗三藐三菩提施与。是名尸罗波罗蜜。若不嗔乞者是名羼提波罗蜜。当行施时不虑空匮心不退没。是名毗梨耶波罗蜜。若与乞者若自与时心定不悔。是名禅波罗蜜。以不得一切法而行布施不求果报。如贤圣无所著。以是布施回向阿耨多罗三藐三菩提。是名般若波罗蜜。复次

  所施物果报　　种种皆能知
  悭惜在家者　　亦知种种过

所施物所获功德利物。悭惜在家所有过恶菩萨于此皆悉了知。问曰。若施得何功德。若惜在家有何过咎。答曰。菩萨以真智慧如是知。施与已是我物。在家者非我物。物施已则坚牢。在家者不坚牢。物施已后世乐。在家少时乐。物施已不忧守护。在家者有守护。苦物施已爱心薄。在家者增长爱。物施已无我所。在家者是我所。物施已无所属。在家者有所属。物施已无所畏。在家者多所畏。物施已助菩提道。在家者助魔道。物施已无有尽。在家则有尽。物施已从得乐。在家从得苦。施已舍烦恼。在家增烦恼。施已得大富乐。在家不得大富乐。施已大人业。在家小人业。施已诸佛所叹。在家愚痴所赞。复次

  于妻子眷属　　及与善知识
  财施及畜生　　应生幻化想
  一切诸行业　　是则为幻师

在家菩萨。于妻子等应生幻化想。如幻化事但诳人目。行业是幻主。妻子等事不久则灭。如经说。佛告诸比丘。诸行如幻化诳惑愚人无有实事。当知因业故有业尽则灭。是故如幻作是念

  我非彼所有　　彼非我所有
  彼我皆属业　　随业因缘有
  如是正思惟　　不应起恶业

父母妻子亲里知识奴婢僮客等。不能为我作救作归作趣。非我非我所。五阴十二入十八界。尚非我非我所。何况父母妻子等。我亦不能为彼作救作归作趣。我亦属业随业所受。彼亦属业随业所受。好恶果报如是三种筹量。一有义趣。二见经说。三见现事。不应为父母妻子等起身口意毫厘恶业。复次

  菩萨于妻所　　应生三三想
  亦复有三三　　又复有三三

在家菩萨应生三想。所谓三者。妻是无常想失想坏想。又有三想。是戏笑伴非后世伴。是共食伴非受业果报伴。是乐时伴非苦时伴。又有三想。是不净想臭秽想可厌想。又有三想。是怨家想恼害想相违想。又有三想。罗刹想毗舍阇鬼想丑陋想。又有三想。入地狱想入畜生想入饿鬼想。又有三想。重担想减想属畏想。又有三想。非我想无定属想假借想。又有三想。因起身恶业想起口恶业想起意恶业想。又有三想。欲觉处想嗔觉处想恼觉处想。又有三想。枷杻相锁械相缚系相。复有三相。遮持戒相。遮禅定相。遮智慧相。复有三相坑相罗网相围合相。复有三相。灾害相疾病相衰恼相。复有三相。罪相黑耳相灾雹相。复有三相。病相老相死相。复有三相。魔相魔处相畏相。复有三相。忧愁相懊恼相啼哭相。复有三相。大豺狼相大摩竭鱼相大猫狸相。复有三相。黑毒蛇相鳣鱼相夺势力相。复有三相。无救相无归相无舍相。复有三相。失相退相疲极相。复有三相贼相狱卒相地狱卒相。复有三相。留相缚相结相。复有三相。泥相流相[漂*寸]相。复有三相。械相锁相[米*离]粘相。复有三相。猛火聚相刀轮相草炬相。复有三相。无利相刺棘相恶毒相。复有三相。陵上相覆映相贪着相。复有三相。恨相鞭杖相刀槊相。复有三相。忿恚相诤讼相打棒相。复有三相。怨憎会相离爱相闹相。取要言之。是以一切臭恶不净相。一切衰浊相。是一切不善根相。是故在家菩萨。于妻子见如是相。应生厌离心出家修善为善。若不能出家。不应于妻起诸恶业。复次

  若于子偏爱　　即以智力舍
  因子行平等　　普慈诸众生

在家菩萨。若自知于子爱心偏多。即以智力思惟舍离。智力者应如是念。菩萨平等心。乃有阿耨多罗三藐三菩提。高下心者则无菩提。是阿耨多罗三藐三菩提。从一相无相得。不从别异相得。我今求阿耨多罗三藐三菩提。若于子所爱心偏多即有高下不名平等。即是别相非是一相。若如是者去阿耨多罗三藐三菩提。则为甚远。是故我不应于子偏生爱心。尔时于子应生三相。一于我为贼佛说等慈破令不等。爱心偏多故。二为贼害因是子故。破诸善根遮正智命。三我因是子逆道中行不行顺道。即时因子于诸众生等行慈心应作是念。子从余处来我亦从余处来。子至异处我去异处。我不知彼去处。彼不知我去处。彼不知我来处。我不知彼来处。是子非我所有。何为无故横生爱缚。如说

  彼我不相知　　所来所去处
  彼我云何亲　　而生我所心

复次无始生死中。一切众生曾为我子。我亦曾为彼子。有为法中无有决定此是我子彼是他子。何以故。众生于六道中转轮互为父子。如说

  无明蔽慧眼　　数数生死中
  往来多所作　　更互为父子
  贪着世间乐　　不知有胜事
  怨数为知识　　知识数为怨

是故我方便莫生憎爱心。何以故。若有善知识。常种种求利益。若有怨贼。常种种生无益相。有此憎爱心则不得通达诸法平等想。心高下者死后生邪处。正行者生正行处。是故我不应行邪行。于众生行平等。当得平等萨婆若

十住毗婆沙论卷第七十住毗婆沙论卷第八

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

    入寺品第十七

如是在家菩萨。不应于诸事中生贪着心我我所心。何以故。随所贪着难舍之物法应施与。若能施与则除此过。菩萨如是无有贪着悭惜之心可以处家。问曰。在家菩萨。或有贪惜爱着之物有来求者。此应云何。答曰

  于所贪着物　　有来求索者
  当自劝喻心　　即施勿悭惜

菩萨所贪惜物。若有乞人急从求索。汝以此物施与我者速得成佛。菩萨即时应自劝喻而施与之。如是思惟。若我今者不舍此物。此物必当远离于我。设至死时不随我去。此物则是远离之相。今为阿耨多罗三藐三菩提。具足檀波罗蜜故施与。后至死时心无有悔。经说。不悔心死必生善处。是得大利云何不舍。如是自劝犹贪惜者应辞谢乞者言

  我今是新学　　善根未成就
  心未得自在　　愿后当相与

应辞谢乞者言。勿生嗔恨。我新发意善根未具。于菩萨行法未得势力。是以未能舍于此物。后得势力善根成就。心得坚固当以相与。复次

  若众不和合　　断于经法事
  菩萨应随力　　方便令不绝

众僧或以事缘诤竞乖散法事有废。在家菩萨应勤心方便彼此之间心无所偏。若以财物若以言说礼敬求请令还和合。或以乏少衣食因缘。或邪见者横作障碍。或说法者欲求利养。或听法者心不恭敬。在家菩萨于此事中随宜方便。若以财物若以言说下意求请使法事不废。法事不废者。是为然佛法灯供养十方三世诸佛。复次

  斋日受八戒　　亲近净戒者
  以戒善因缘　　深心行爱敬

斋日者。月八日十四日十五日二十三日二十九日三十日。及遮三忌。三忌者。十五日为一忌。从冬至后四十五日。此诸恶日多有鬼神侵克纵暴。世人为守护日故过中不食。佛因教令受一日戒。既得福德。诸天来下观察世间见之欢喜则便护念。在家菩萨于诸小事犹尚增益。何况先有此斋而不随顺。是故应行一日斋法。既得自利亦能利人。问曰。斋法云何。答曰。应作是言。如诸圣人常离杀生。弃舍刀杖常无嗔恚。有惭愧心慈悲众生。我某甲今一日一夜远离杀生。弃舍刀杖无有嗔恚。有惭愧心慈悲众生。以如是法随学圣人。如诸圣人常离不与取。身行清净受而知足。我今一日一夜远离劫盗不与取。求受清净自活。以如是法随学圣人。如诸圣人常断淫泆远离世乐。我今一日一夜除断淫泆远离世乐净修梵行。以如是法随学圣人。如诸圣人。常离妄语。真实语正直语。我今一日一夜远离妄语。真实语正直语。以如是法随学圣人。如诸圣人常远离酒。酒是放逸处。我今一日一夜远离于酒。以如是法随学圣人。如诸圣人常远离歌舞作乐花香璎珞严身之具。我今一日一夜远离歌舞作乐华香璎珞严身之具。以如是法随学圣人。如诸圣人常远离高广大床处在小榻草蓐为座。我今一日一夜。远离高广大床。处在小榻。草蓐为座。以如是法随学圣人。如诸圣人常过中不食。远离非时行非时食。我今一日一夜过中不食远离非时行非时食。以如是法随学圣人。如说

  杀盗淫妄语　　饮酒及华香
  璎珞歌舞等　　高床过中食
  圣人所舍离　　我今亦如是
  以此福因缘　　一切共成佛

亲近持净戒比丘者。在家菩萨应亲近诸比丘尽能护持清净禁戒成就功德防远众恶者。以戒善因缘者。又应亲近持戒比丘身口业净心行直善无众恶者。深心爱敬者于上直心善行持戒比丘成就诸功德者。应生最上恭敬深心爱乐。问曰。在家菩萨若于持戒比丘成就功德生爱敬心者。应于破戒比丘生轻恚心耶。答曰

  若见破戒者　　不应起轻恚

在家菩萨若见破戒杂行比丘威仪不具所行秽浊覆藏瑕疵无有梵行自称梵行。于此比丘不应轻慢有嗔恚心。问曰。若不嗔恨应生何心。答曰

  应生怜愍心　　诃责诸烦恼

在家菩萨若见破戒比丘不应生嗔恨轻慢应生怜愍利益之心。作是念。咄哉此人遇佛妙法。得离地狱畜生饿鬼色无色界边地生处。诸根具足不聋哑不顽钝。值佛妙法别识好丑。心存正见解知义理。人身难得如大海中有一眼鳖头入板孔。生在人中倍难于此。既闻佛法能灭诸恶度诸苦恼得至正智。舍诸资生所有多少。永割亲族无所顾恋。若生凡庶或在种姓。信佛语故能舍出家。常闻破戒之罪。所谓自贱其身智所诃责。恶名流布常怀疑悔。死堕恶道得闻此事而犹破戒。行十善道乃得人身。而不能如法善用以自利益。咄哉三毒其力甚恶。常陵众生难得舍离。诸佛种种呵骂烦恼恶贼恶行如实有理。如是思惟不应轻贱破戒之人。又作是念。若我不能都离嗔恚轻慢心者。应自思惟。佛法无量犹如大海。或有开通而我不知。如大乘决定王经中。佛告阿难。或有比丘。根钝闇塞心不明了。不达诸法相。常念有想无想法中而取有想。生男女想生罪碍想生垢想生净想。生如是想者。名为钝根。心不明了则为有罪。阿难。若人一切法中不能善解名为不了。一切诸法从初以来。本体性相常不可得。是人不知如是之事。生是诸想则与外道无有差别。阿难。我所说法皆有开通明了清净。此中无罪亦无罪者。阿难。罪名疑悔愚痴闇冥。罪者名生众生想我想命想人想。皆因身见名为罪者。于我法中无如此人。若我法中定实有我众生命人身见等者。不言我法有开非是不开。我法从本已来常清净明了。复次阿难。若决定有罪有受罪者则身即是神即堕常见则无佛道。若身异于神即堕断见亦无佛道。如是六十二见皆可是菩提但是事不然。是故阿难。我于大众中师子吼说而无所畏言。我法有开非不有开。从本已来常清净明了。阿难。若罪定有。则毕竟无涅槃。我则不言我法有开。阿难。我法实从本已来清净明了。是故我弟子降心安隐无有疑悔。无诸罪恶清净行道。菩萨应如是思惟不应嗔恚破戒者。又作是念。是戒必定得住阿耨多罗三藐三菩提。何以故。曾闻必定菩萨有起罪者。如过去十万劫。有菩萨诽谤漏尽阿罗汉。名为阿罗汉。又闻必定菩萨于此劫前三十一劫。以矛刺须陀洹。又此贤劫中。闻有菩萨诽谤劬楼孙佛言何有秃人而当得道。如是等众生难可得知。是故我于此事何用知为。得失好恶彼自作自受何豫于我。我今若欲实知彼事。或自伤害筹量众生。佛所不许。如经中说。佛告阿难。若人筹量于他即自伤身。唯我可得筹量。众生与我等者亦应筹量。如说

  有瓶盖亦空　　无盖亦复空
  有瓶盖亦满　　无盖亦复满
  当知诸世间　　有此四种人
  威仪及功德　　有无亦如是
  若非一切智　　何能筹量人
  宁以见威仪　　而便知其德
  正智有善心　　名为贤人相
  但见外威仪　　何由知其内
  内有功德慧　　外现无威仪
  游行无知者　　如以灰覆火
  若以外量内　　而生轻贱心
  败身及善根　　命终堕恶道
  外诈现威仪　　游行似贤圣
  但有口言说　　如雷而无雨
  诸心所行处　　错谬难得知
  是故诸众生　　不可妄度量
  唯有一切智　　悉知诸心心
  微密所行处　　是故量众生
  佛言与我等　　乃能量众生
  若佛如是说　　谁能筹量人
  若见外威仪　　称量其内德
  自败其善根　　如水自崩岸
  若于此错谬　　则起大业障
  是故于此人　　不应起轻贱

是故在家菩萨不应于破戒人起轻慢嗔恚。又持戒破戒白衣之人不与同住。何由得知。我若欲于此事分别明了者则起罪障。罪障因缘故于千万劫受诸苦分。如无行经中说。又大乘经中。佛告郁伽罗长者。如是在家菩萨应于破戒比丘生怜愍心。是人垢行恶行不善。何以故。是人披如来善寂灭圣主法衣。自不善软不能调伏诸根行败坏行。又佛经中说。不轻未学。此非人罪是烦恼罪。此人以是烦恼起不善事。又佛法有开。是人或能自除过罪。正念因缘得入法位。若入必定在于阿耨多罗三藐三菩提。又如佛言。唯有智慧可破烦恼。又复说言。不应妄称量人。若称量者则为自伤。唯佛智慧乃能明了。如此事者非我所知。即于破戒人中不生嗔恚轻慢之心。复次

  菩萨若入寺　　应行诸威仪
  恭敬而礼拜　　供养诸比丘

是在家菩萨若入佛寺。初欲入时于寺门外五体投地。应作是念。此是善人住处。是空行者住处。无想行者住处。无愿行者住处。此是行慈悲喜舍者住处。此是正行正念者住处。若见诸比丘威仪具足视瞻安详摄持衣钵坐卧行止寤寐饮食言说寂默容仪进止皆可观察。若见比丘修行四念圣所行处持戒清净诵读经法精思坐禅。见已恭肃敬心礼拜亲近问讯。应作是念

  若我恒沙劫　　常于天祠中
  大施不休废　　不如一出家

是菩萨尔时应作是念我如法求财。于恒河沙等劫常行大施。是诸施福犹尚不如发心出家。何况有实。何以故。在家则有无量过恶。出家能成无量功德。在家则溃闹。出家则闲静。在家则属垢。出家则无属。在家是恶行处。出家是善行处。在家则染诸尘垢。出家则离诸尘垢。在家则没五欲泥。出家则出五欲泥。在家难得净命。出家易得净命。在家则多怨贼。出家则无怨贼。在家则多恼碍。出家则无恼碍。在家是忧处。出家是喜处。在家是恶道门。出家是利益门。在家是系缚。出家是解脱。在家则杂畏。出家则无畏。在家有鞭杖。出家无鞭杖。在家有刀槊。出家无刀槊。在家有悔热。出家无悔热。在家多求故苦。出家无求故乐。在家则戏调。出家则寂灭。在家是可愍。出家无可愍。在家则愁悴。出家无愁悴。在家则卑下。出家则高显。在家则炽然。出家则寂灭。在家则为他。出家则自为。在家少势力。出家多势力。在家随顺垢门。出家随顺净门。在家增刺棘。出家破刺棘。在家成就小法。出家成就大法。在家作不善。出家则修善。在家则有悔。出家则无悔。在家增泪乳血海。出家竭泪乳血海。在家则为诸佛辟支佛声闻所呵贱。出家则为诸佛辟支佛声闻所称叹。在家则不知足。出家则知足。在家则魔喜。出家则魔忧。在家后有衰。出家后无衰。在家则易破。出家则难破。在家是奴仆。出家则为主。在家永在生死。出家究竟涅槃。在家则堕坑。出家则出坑。在家则黑闇。出家则明显。在家不能降伏诸根。出家则能降伏诸根。在家则傲诞。出家则谦逊。在家则鄙陋。出家则尊贵。在家有所由。出家无所由。在家则多务。出家则小务。在家则果小。出家则果大。在家则谄曲。出家则质直。在家则多忧。出家则多喜。在家如箭在身。出家如身离箭。在家则有病。出家则病愈。在家行恶法故速老。出家行善法故少壮。在家放逸为死。出家有智慧命。在家则欺诳。出家则真实。在家则多求。出家则少求。在家则饮杂毒浆。出家则饮甘露浆。在家多侵害。出家无侵害。在家则衰耗。出家无衰耗。在家如毒树果。出家如甘露果。在家则怨憎和合。出家则离怨憎会苦。在家则爱别离苦。出家则亲爱和合。在家则痴重。出家则痴轻。在家则失净行。出家则得净行。在家则破深心。出家则成深心。在家则无救。出家则有救。在家则孤穷。出家不孤穷。在家则无舍。出家则有舍。在家则无归。出家则有归。在家则多嗔。出家则多慈。在家则重担。出家则舍担。在家则事务无尽。出家则无有事务。在家则罪会。出家则福会。在家则苦恼。出家则无苦恼。在家则有热。出家则无热。在家则有诤。出家则无诤。在家则染着。出家无染着。在家有我慢。出家无我慢。在家贵财物。出家贵功德。在家有灾害。出家灭灾害。在家则减失。出家则增益。在家则易得。出家则难遇。千万劫中时乃一得。在家则易行。出家则难行。在家则顺流。出家则逆流。在家则漂流。出家则乘筏。在家则为烦恼所[漂*寸]。出家则有桥梁自度。在家是此岸。出家是彼岸。在家则缠缚。出家离缠缚。在家怀结恨。出家离结恨。在家随官法。出家随佛法。在家有事故。出家无事故。在家有苦果。出家有乐果。在家则轻躁。出家则威重。在家伴易得。出家伴难得。在家以妇为伴。出家坚心为伴。在家则入围。出家则解围。在家则以侵恼他为贵。出家则以利益他为贵。在家则贵财施。出家则贵法施。在家则持魔幢。出家则持佛憧。在家有归处。出家坏诸归处。在家增长身。出家则离身。在家入深榛。出家出深榛。复次

  又于出家者　　心应深贪慕

是在家菩萨。如是思惟出家功德。于出家者心应贪慕。我何时当得出家得有如是功德。我何时当得出家次第具行沙门法。则说戒布萨安居自恣次第而坐。我何时当得圣人所著戒定慧解脱解脱知见熏修法衣。何时当得持圣人相。何时当得闲林静住。何时当得持钵乞食得与不得。若多若少若美若恶若冷若热次第而受趣以支身如涂疮膏车。何时当得于世八法心无忧喜。何时当得关闭六情如絷狗鹿鱼蛇猴鸟。狗乐聚落鹿乐山泽。鱼乐池沼蛇好穴处。猴乐深林鸟依虚空。眼耳鼻舌身意常乐色声香味触法。非是凡夫浅智弱志所能降伏。唯有智慧坚心正念。乃能摧伏六情寇贼不令为患自在无畏。何时当得乐欲坐禅诵读经法乐断烦恼乐修善法乐着弊衣。趣足障体。念昔在俗多行放逸。今得自利又利他故。当勤精进。何时当得随顺菩萨所行道法。何时当得亦为世间作无上福田。何时当得离恩爱奴。何时当得脱是家狱。如说

  礼敬诸塔寺　　因佛生三心

是在家菩萨既已慕尚出家。若入塔寺敬礼佛时。应生三心。何等为三。我当何时得于天龙夜叉乾闼婆阿修罗迦楼罗摩睺罗伽人非人中受诸供养。何时当得神力舍利流布世间利益众生。我今深心行大精进。当得阿耨多罗三藐三菩提。我作佛已入无余涅槃。复次

  诣诸比丘时　　随所行奉事
  默然顺所诲　　济乏无所惜

是在家菩萨敬礼塔已。求造诸比丘说法者。所持律者。读修多罗者。读摩多罗迦者。读菩萨藏者。作阿练若者。着纳衣者。乞食者。一食者。常坐者。过中不饮浆者。但三衣者。着褐衣者。随敷坐者。在树下者。在冢间者。在空地者。少欲者。知足者。远离者。坐禅者。劝化者。应各随诸比丘所行奉事。若至读阿毗昙者所。随其所说诸法性相相应不相应等请问所疑。问已习学。若遇持律者。应当请问起罪因缘罪之轻重灭罪之法及阿波陀那事。问已修学行。若遇读修多罗者。应当请问诸阿含诸部中义习学多闻。若遇读摩多罗迦应利众经忧陀那波罗延法句者。应当学习如是等经。若遇读菩萨藏者。应当请问六波罗蜜及方便事问已修学。若遇阿练若。应学其远离法。若遇坐禅者。应学其坐禅法。余诸比丘亦应如是随其所行请问修学无所违逆。摄护口者诣诸比丘应善摄口安详默然。观时观土随事思惟心不错乱少于语言。又于说法者所。诸比丘等随所乏少。若衣若钵若尼师坛。资生之物随力而施无所匮惜。所以者何。菩萨尚应施诸恶人。何况比丘有功德者。乃至身肉犹当不惜。况复外物。助道因缘。复次

  若行布施时　　莫生他烦恼

行布施时若与一人。一人不得便生恚恼。应善筹量而行布施。勿使他人生于恚恼。何以故

  将护凡夫心　　应胜阿罗汉

是在家菩萨。施诸比丘衣服饮食医药卧具供养迎送敬礼亲近。将护凡夫心。应胜将护阿罗汉。何以故。诸阿罗汉于利衰毁誉称讥苦乐心无有异。凡夫有爱恚悭嫉故能起罪业。以是罪业堕在地狱畜生饿鬼。是故应深将护凡夫。菩萨事者。皆为利益一切众生布施。非为自乐不为自得后世果报。非如市易。复次

  因以财施故　　可以法施摄
  随所欲利益　　教发无上心

是在家菩萨为自利故随所利益。比丘若以衣施。若以钵施。如是等种种余财物施。如是比丘未入法位未得道果。应劝令发阿耨多罗三藐三菩提愿。何以故。因财施摄故得以法施摄。或于所施檀越有爱敬心信受其语。复次

  为欲护持法　　舍命而不惜
  疗治病比丘　　乃至以身施

是在家菩萨为欲护持法故。乃至自舍身命。勤行精进摧破六十二种外道及诸魔民憎嫉佛法者。佛弟子中或有邪行诡异佛法。如是之人如法摧破。名为护持法。又应于诸多闻说法者。加信敬心四事供养。亦名护持法。若自读诵解说书写修多罗毗尼阿毗昙摩多罗迦菩萨藏者。亦教他人读诵解说书写。以是因缘法得久住利益一切。在家出家称扬叹说法久住利。若法疾灭说有过恶。又念如来久远已来。行菩萨道行诸难行乃得是法。以是因缘于诸在家出家。勤心精进示教利喜。若令得道。若令入阿惟越致。略说护法因缘。令得一切安乐之具。亦复自能如说修行。皆名护持法。复次是在家菩萨法。若有病比丘应须疗治。是菩萨乃至舍身为治其病而不爱惜是最为要。出家之人应于在家求此要事。所谓身自瞻视疾病供给医药。复次

  决定心布施　　施已而无悔

是菩萨若为护持正法。若为瞻视病人。应时供施心无有悔。是名清净施。若不求果报。不分别是应受是不应受。但以怜愍利益心与。是名清净施。如说

  若人悲心施　　是名清净施
  不言是福田　　不言非福田
  若人行布施　　无所为故与
  若人为果报　　是名为出息
  是故说施已　　心无有悔恨
  乃至微小福　　皆向无上道

以是布施因缘所得福德。皆应回向阿耨多罗三藐三菩提。不求今世后世利乐及小乘果。但为众生求阿耨多罗三藐三菩提。如我先说在家菩萨余行当说者今已说竟。皆于大乘经中处处抄集。随顺经法菩萨住是行中。疾得阿耨多罗三藐三菩提。第二地中多说出家菩萨所行。在家出家菩萨共行今当复说

    共行品第十八

问曰。汝言当说在家出家菩萨共行法今可说之。答曰。忍辱法施法忍思惟不曲法。尊重法不障法。供养法信解修空。不贪嫉随所说行。灯明施伎乐施乘施正愿摄法思量利安众生。等心于一切。此是在家出家共行要法。是故偈说

  行忍身端严　　法施知宿命
  法忍得总持　　思惟获智慧
  于诸法不曲　　常得正忆念

行忍得端严者。能忍恶言骂詈咒誓系缚刀杖考掠搒笞。心不动异悉能堪受。如是忍辱所获果报。生于人天常得端正。后成佛时相好无比。法施知宿命者。行法施者能知过去无量劫事。法施名为种种分别。声闻乘辟支佛乘佛乘解说义理。法施果报虽有三十五。要者知宿命。说法因缘断人所疑。是故得知宿命。法忍得总持者。法名应空无相无愿应六波罗蜜菩萨诸地。一切菩萨所行之法。晓了明解心能忍持。名为法忍。行是忍者则得总持。总持名为如所闻经如所读诵其中义趣乃至百千万劫终不忘失。思惟得智慧者。思惟名为筹量善法分别义趣。是故能得今世后世利益。不曲心得正念者。不曲名为质直无谄。修行此法则于一切法中得坚固念。复次

  重法法则坚　　不障得守护
  供养法值佛　　信解舍诸难

重法法则坚者。若人尊重恭敬于法法则坚固。坚法名为所受持习学之法自然牢坚不可动转。后成佛时多有菩萨声闻弟子。住是坚固法无能障其所受法者。又坚名为法得久住。不障得守护者。若人说法及人听法。不横与作障碍之事。后成佛时。诸天世人共守护法。未得佛道常能护持诸佛正法。诸佛灭后守护遗法。乃能至于后佛出世。以是因缘菩萨声闻。皆应尽心善守护法。供养法值佛者。供养名为恭敬诸法。法施法会敬心供养说法之人。施设法座起立禅坊。庄挍严饰讲法之处。如是深心爱乐。供养法因缘故。得值诸佛。以信解舍诸难者。信名于诸善法深生欲乐。以是法故得离八难。解者能灭诸罪。能于诸善法中。以心力故随意而解。如十一切入随意所解。若人多有信解力者。能灭无始生死已来无量罪恶。如先悔过品中说。复次

  修空不放逸　　不贪得成利
  随说灭烦恼　　灯施得天眼

修空不放逸者。修有二种得修行修。修空力故。信有为法皆是虚诳亦不住空。诸法无定。是故常自摄捡心不放逸。不贪得成利者。贪名于他物中生贪取心。若除是事所求皆成所愿皆满。随说灭烦恼者。随有所说身即行之则断烦恼于诸事中皆如说行。世世已来诸烦恼气常熏其心则皆除灭。转诸烦恼恶气习性。灯施得天眼者。若人然灯供养佛声闻辟支佛及塔像舍利。以是因缘得天眼报。复次

  乐施天耳报　　以正愿净土
  乘施获神足　　摄法得具僧

乐施得天耳报者。于大会作诸音乐供养于佛得天耳报。乘施得神足者。乘名辇舆象马等乘。复有人言。以履屣等施亦得神足。以正愿净土者。随以所愿取清净土。若金银颇梨珊瑚琥珀车磲码瑙无量众宝清净国土。摄法得具僧者。若菩萨具足行四摄法。得具足僧。以布施爱语利益同事。摄取众生故。后成佛时得清净具足无量菩萨僧及声闻僧。如阿弥陀佛有二种僧清净具足。愿具足者如先十愿中说。复次

  利益众生故　　一切所爱敬
  平等心无二　　得为最胜者

若菩萨以身口意业有所作。皆为利益安乐众生。是故众生皆悉敬爱。若菩萨于诸众生怨亲中人行平等心。不舍一切众生。以是业报得为最胜。胜名能胜贪欲嗔恚愚痴一切烦恼恶法故名为佛。问曰。人皆俱有眼耳鼻舌口等无有异。云何得知是佛。答曰。佛有三十二大人相。有是相者当知是佛。在家出家应当分别了知三十二相。是相以何法得是法。以何业得是相。是业亦应当知。何以故。欲得功德。当知是相欲得是相。当知是业。问曰。如此事者于何得解。答曰

  于法相品中　　一相三分别

阿毗昙三十二相品中。一一相有三种分别。悉应当知。问曰。云何为一一相有三种分别。答曰。一说相体。二说相果。三说得相业。手足轮相等先已说。转轮圣王亦有是相。诸菩萨亦有是相。余人亦有。但不如耳手足轮者。手足掌中有千辐轮。具足明了如印文现。足安住不动名足安立相。网缦软薄犹如鹅王画文明了如真金缕故名手足网相。柔软犹如兜罗树绵如婴儿体其色红赤胜身余分名为手足柔软相。手掌足下项上两腋七处俱满故名七处满相。修指纤佣故名长指相。足跟长广故名足跟广相。身长七肘不曲故名身直大相。足上隆起故名足趺高相。毛上向右旋故名毛上旋相。佣[跳-兆+尃]渐粗如伊泥鹿[跳-兆+尃]故名鹿[跳-兆+尃]相。平立两手摩膝故名长臂相。如宝马宝象阴不现故名阴藏相。第一金色光明故名金色相。皮软如成炼金不受尘垢故名皮薄细密相。一一孔一毛生故名一一毛相。眉间白毫光如珂雪故为白毛相。如师子前身广厚得所故名师子上身相。肩圆大故名肩圆大相。腋下平满故名腋下满相。舌根不为风寒热所坏故善分别诸味余人不尔故名知味味相。身纵广等如尼驹楼树故名圆身相。肉髻团圆发右上旋故名肉髻相。舌如赤莲华广长而薄故名广长舌相。声如梵王迦陵频伽鸟故名梵音相。颊圆广如镜故名师子颊相。齿白如珂雪如君坻华故名齿白相。平齐不参差故名齿齐相。齿密致不疏故名具足齿相。齿上下相当故名四十齿相。眼白黑分明净无赤脉故名绀青眼相。睫不交乱上下俱眴不长不短故名为牛王睫相。于诸所尊迎送恭敬。于塔寺中大法会处说法处。供给人使故得手足轮相。有是相故。在家作转轮圣王。多得人民。出家学道。多得徒众。所受诸法坚持不舍故得安立足相。有是相故无能倾动。常修四摄法布施爱语利益同事故得手足网缦相。有是相故速摄人众。以诸香甘美濡饮食供施于人及诸所尊供给所须故得手足柔软相及七处隆满相。有是相故多得香甘美软饮食。救免应死及增寿命。又受不杀戒故得纤长指相足跟满相身大直相。有是相故寿命长远。所受善法增益不失故得足趺高毛上向右旋相。有是相故得诸功德不退失。能以技艺及诸经书教授不惜及履屣等施故得伊尼鹿[跳-兆+尃]相。有是相故诸所修学速疾如意。有来求索无所遗惜故得佣长臂相。有是相故能得势力能大布施。能善调人不令众生亲里远离。若有乖离还令和合故得阴藏相。有是相故多得弟子。以好净洁衣服卧具楼阁房舍施故得金色相及皮肤薄相。有是相故得好净洁衣服卧具楼阁房舍。随所应供养和尚阿阇梨父母兄弟及所尊重善能卫护故得一一孔一毛生毛右旋相白毛庄严面相。有是相故无与等者。惭愧语随顺语爱语故得上身如师子相肩圆大相。有是相故见者乐视无有厌足。供给疾病医药饮食身自看视故得腋下满相得味味相。有是相故身少疾病。布施园林甘果桥梁茂树池井饮食华香璎珞房舍起塔福舍等及共众施时能出多物故得身如尼俱楼树相及肉髻相。有是相故得尊贵自在。长夜修习实语软语故得广长舌相梵音声相。有是相故得五功德音声。五功德音声者。易解声。听者无厌声。深远声。悦耳声。不散声。长夜实语不绮语故得师子颊相。有是相故言必信受。初既供养后不轻慢。随意供给故得齿白相齿齐相。有是相故得清净和顺同心眷属。长夜实语不谗谤故得四十齿相齿密致相。有是相故眷属和同不可沮坏。深心爱念和颜视众生无爱恚痴故得绀青眼相睫如牛王相。有是相故。一切见者无不爱敬

十住毗婆沙论卷第八十住毗婆沙论卷第九

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

    四法品第十九

如所说得三十二相诸业。菩萨应一心修习。修如此三十二相业以慧为本。是故

  退失慧四法　　菩萨应远离
  得慧四种法　　应常修习行

有四法能退失慧。菩萨所应远离。复有四得慧法应常修习。何等四法失慧。一不敬法及说法者。二于要法秘匿吝惜。三乐法者为作障碍坏其听心。四怀憍慢自高卑人。何等四法得慧。一恭敬法及说法者。二如所闻法及所读诵为他人说。其心清净不求利养。三知从多闻得智慧故。勤求不息如救头然。四如所闻法受持不忘。贵如说行不贵言说。是为四。若人不坏诸善根者。是人能舍失慧四法。能行得慧四法。是故求增益智慧者。如偈说

  食善根四法　　菩萨应远离
  增善根四法　　菩萨应修习

何等是侵食善根四法。一怀憍慢贪求世事。二着利养出入诸家。三起憎嫉谤诸菩萨。四未闻经闻不信受。何等是增长善根四法。一所未闻经求之无厌。所谓六波罗蜜菩萨藏。二于众生除憍慢心谦逊下下。三如法得财趣足而已。离诸邪命乐行四圣种行。四于他罪若实不实无有刺讥不求人短。若于法中有所不达。心不违逆以佛为证。佛是一切智其法无量。随宜而说非我所知。如是增益善根。四法非谄曲者所能成就。是故

  菩萨应远离　　谄曲相四法
  应常修习行　　直心相四法

在家出家菩萨。应远离四谄曲法。如曲木在稠林难可得出。如是世间有佛弟子虽入佛法不能得出生死深林。何等为四。一于佛法怀疑不信无有定心。二于众生憍慢嗔恨。三于他利心生贪嫉。四毁谤菩萨恶声流布。是为四。何等是四直心相。一者有罪即时发露无所隐藏悔过除灭行无悔道。二者若以实语失于王位及诸财宝。犹不妄语口未曾说轻人之言。三者若人恶口骂詈轻贱讥谤系闭鞭杖考掠等罪。但怨前身不咎于他。信业果报心无恚恨。四者安住信功德中。诸佛妙法甚难信解。心清净故皆能信受。败坏菩萨行四谄曲。调和菩萨有四直行。是故菩萨欲不行谄曲相。欲行直心如说

  应舍离四种　　败坏菩萨法
  应修习四种　　调和菩萨法

云何名为四败坏菩萨法。一多闻而戏调不随法行。二于教化而生戏论。不敬顺和尚阿阇梨。三者不能消人信施。毁坏防制而受供养。四者不敬柔善菩萨心怀憍慢是为四。云何名为四调和菩萨法。一常乐闻所未闻法。闻已能如所说行。依法依义依如说行。二随顺义趣不惑言辞调和易化。于师事中用意施作。三不失戒定清净活命。四于调和菩萨生恭敬心随顺情重破憍慢心求其功德。复次菩萨有四种错谬。常于此中求菩萨短。是名败坏菩萨。若能亲近四种善道。是名调和菩萨。如偈说

  菩萨应远离　　四种菩萨谬
  菩萨应修习　　四种菩萨道

何谓菩萨四种错谬。一于非器众生说甚深法。是名错谬。二乐深大法者。为说小乘。是名错谬。三于正行道者持戒善心。轻慢不敬。是名错谬。四于未成就者。未可信而信。摄破戒恶人以为亲善。是名错谬。何等为四种菩萨道。一于一切众生行平等心。二以善法教化一切。三等为一切众生说法。四以正行行于一切众生。若常行菩萨四种错谬。不乐思惟诸法。不勤修习善法。则是像菩萨。是故

  诸菩萨法中　　四种像菩萨
  佛说如是法　　一一应远离

何等为四。一贪重利养不贵于法。二但为名誉不求功德。三求欲自乐不念众生。四贪乐眷属不乐远离。是为四问曰像菩萨法云何可舍。答曰。若菩萨应修菩萨初行功德。是则能离像菩萨法。是故菩萨若欲离像菩萨法。如偈说

  初行四功德　　精勤令得生
  生已令增长　　增长已当护

何等为四。一者信解空法。亦信业果报。二者乐无我法。而于一切众生生大悲心。三者心在涅槃而行在生死。四者布施为欲成就众生。而不求果报。若人欲生菩萨初行四功德。增长守护者。当亲近善知识。如偈说

  菩萨当亲近　　四种善知识
  亦应当远离　　四种恶知识

菩萨爱乐阿耨多罗三藐三菩提者。应当亲近恭敬供养四种善知识。当深远离四种恶知识。何等为四种善知识。一于来求者生贤友想。以能助成无上道故。二于说法者生善知识想。以能助成多闻智慧故。三称赞出家者生善知识想。以能助成一切善根故。四于诸佛世尊生善知识想。以能助成一切佛法故。何等为四种恶知识。一求辟支佛乘心。乐少欲少事。二求声闻乘比丘。乐坐禅者。三好读外道路伽耶经。庄严文颂巧问答者。四所亲近者。得世间利不得法利。是故菩萨应亲近四善知识远离四恶知识。若菩萨能远离四恶知识。亲近四善知识者则得四广大藏。过一切魔事法。能生无量福德。尽能摄取一切善法。问曰。何等是菩萨大藏法。何等是能过一切魔事法。何等是能生无量福德法。何等是能摄取一切善法。答曰

  诸菩萨有四　　广大藏妙法
  四摄诸善法　　菩提心为先

何等为四。一得值佛。二得闻六波罗蜜。三于说法者心无嗔阂。四以不放逸心乐住阿练若处。是为四大藏。能过一切魔者。有四法。何等四。一不舍菩提心。二于一切众生心无嗔碍。三觉知一切诸见。四于诸菩萨心无憍慢。是为四。得无量福德法。复有四法。何等为四。一于法施无所悕求。二于破戒恶人生大悲心。三于教众生中发无上菩提。四于下劣众生而行忍辱。是为四。摄一切善法者。有四法。何等为四。一于空闲不现矫异常行。二行四摄法不求恩报。三不惜身命护持正法。四种诸善根时以菩提心为先。是为四。是一一四法皆应广解。于文烦多故不广。今如佛所说以偈略解。若菩萨欲得诸菩萨藏。欲过一切魔事。欲摄一切善法者。皆当远离

  二空系二缚　　二障二垢法
  二疮及二坑　　二烧二病法

若菩萨欲得诸菩萨藏等功德者。应当远离是诸二法。何等为二空系法。一贪着应路伽耶等经。二严饰衣钵。二缚者。一着诸见缚。二贪名利缚。二障法者。一亲近白衣。二疏远善人。二垢法者。一忍受诸烦恼。二乐诸檀越知识。二疮法者。一见他人过。二自藏其过。二坑法者。一毁坏正法。二破戒受供。二烧法者。一以秽浊心而着袈裟。二受净戒者供给。出家之人有二病难治。一憎上慢人自谓能降伏心。二求大乘者沮坏其意。若菩萨远离如是等法。更有疾得阿耨多罗三藐三菩提法。则能疾得。又得诸佛辟支佛阿罗汉之所称叹。问曰。何等法是疾得阿耨多罗三藐三菩提法。何等是诸佛辟支佛阿罗汉之所称叹。答曰

  能行四谛相　　疾得佛菩提
  又行四法者　　三圣所称叹

何等为四谛相。一求一切善法故勤行精进。二若听受读诵经法如所说行。三厌离三界如杀人处常求免出。四为利益安乐一切众生故。自利其心谛名真实不诳。得阿耨多罗三藐三菩提故名为不虚。复有四法。为三圣称叹。何等为四。一乃至失命不为恶事。二常行法施。三受法常一其心。四若生染心。即能正观染心起染因缘。是染根者何名为染。何者是染于何事起谁生是染。如是正忆念。知虚妄无实无有。决定信解诸法空故。无所有法故。如是正观染因缘故。不起诸恶业。余一切烦恼亦如是观。菩萨得是大人所称叹法。离诸恶烦恼业故。心则具足舍心者如说

  具足于舍心　　求世出世利
  求此诸利时　　心无有厌倦

是菩萨具足舍法。欲行法施行财施利益众生故。若求世间出世间诸利。未得时心无疲懈。世间利者。善解世间经书技艺方术巧便等。出世间利者。诸无漏根力觉道法。如说

  如是求二利　　心无有疲懈
  以无疲懈故　　能得诸深法
  因从求经书　　而能得智慧
  具足知世间　　最上第一法

无疲懈者。疲懈名厌恶。所学若无厌恶则心无疲倦。若无疲倦则求诸经艺医方技术礼仪法则皆无疲倦。无疲倦故则得智慧。具足深知世间宜法。世间法者。方俗所宜随世间心。世间治法皆悉能知。是故能知上中下众生。随宜而引导。善解世间事深有惭愧心。随宜引导者。于上中下者各有所宜。惭愧者。自耻所行名为惭。因他生耻名为愧。有人以自作而羞见他而愧。世间法中愧为先用。如经说。二清白法护持世间。所谓惭愧。如偈说

  随人有愧时　　知法知罪福
  无愧善人远　　无恶而不作

问曰。何故殷勤教菩萨善知世间宜法。答曰。菩萨若知世间法者。则于众生易相悦入。化导其心令住大乘。若不知世法。乃至不能教化一人。是故世间法者。则是教化众生方便之道。菩萨如是知世间法。具足惭愧心。如说

  加恶而敬养　　何况利己者
  有愧有恭敬　　不轻笑善者

是菩萨愧心多故。于诸恶人尚能恭敬供养迎送问讯。何况善人能利于我有功德者。有愧恭敬二心故。于诸贤善少知识者而不轻慢。作是念。有功德者自隐于世。如灰覆火。鄙薄世法不应轻贱。若我以小因缘而轻贱者。即便得罪。复次

  凡诸有所作　　虽难能究竟
  则于世间中　　亦是不退相

是菩萨凡有所作。若起塔寺若设大会若救罪人。如是等一切世间诸难事中心无废退。所造未成。要以种种诸方便力身口心力令得成就。不但佛法有不退转。世间事中亦有不退转相。问曰。以何因缘能成此事。答曰。有堪忍力者。则能究竟。如说

  得大堪忍力　　深供养诸佛
  随佛所教化　　皆悉能受持

菩萨得堪忍力故。以是力于诸佛供养敬礼。随宜供奉衣服饮食等。又佛教化。若持戒禅定。若降伏心意。若实观诸法。于是事中用堪任力。如人得利刀宜应有益中用不于无益中用。如说

  以信悲慈舍　　堪受无疲厌
  又能知义趣　　引导众生心
  愧堪受第一　　深供养诸佛
  住佛所说中　　正行此十法
  能净治初地　　是则菩萨道

若菩萨以信为始后住佛故则能净治初地。是十法中以信为初。信名于诸佛法因缘中心得决定又加好乐。何以故。是菩萨心性清净故得深根信力。有信力故于众生中而生悲心作是念。一切诸佛法以大悲为本。我今一心好乐佛法。是故于众生中应生悲心。此悲渐增则成大悲。得大悲故于众生中则生慈心。作是念。我应随力利益众生则成实悲行慈。利众生时即能行舍。内外所有皆能施与。作是念。如我是物。为欲利益安乐众生则成实慈。又诸众生信受我语。为欲行舍求利财物故。堪受种种诸苦恼事。作是念若有疲厌。则于世间技艺经书田作工巧诸求财利因缘则无所获。是故应于世间技艺经书等无有疲厌。以堪受故能知义趣。作是念。世间经书以义为味。若人善知经书义味。则于世间法悉能通了。能通了故则能引导上中下众生。作是念。若人无有惭愧则不能令众生欢喜。为令欢喜故当行惭愧。作是念。若无堪受则不成世间出世间利。有堪受故则能引导一切众生皆令欢喜心欢喜故信受我语。以信受故勤行方便而作唱导。作是念。若众生供养佛者。则多所利益。欲令众生供养佛故。即自一心供养于佛及形像舍利。众生信受则便随效供养于佛。种人天因缘。住于三乘菩萨。如是次行十法。则能净治初地

    念佛品第二十

菩萨于初地。究竟所行处。自以善根力能见数百佛菩萨。如是降伏其心深爱佛道。如所闻初地行具足究竟。自以善根福德力故能见十方现在诸佛皆在目前。问曰。但以善根福德力故得见诸佛。为更有余法耶。答曰

  佛为跋陀婆　　所说深三昧
  得是三昧宝　　能得见诸佛

跋陀婆罗是在家菩萨。能行头陀。佛为是菩萨说般舟三昧经。般舟三昧名见诸佛现前菩萨。得是大宝三昧。虽未得天眼天耳而能得见十方诸佛。亦闻诸佛所说经法。问曰。是三昧者当以何道可得。答曰

  当念于诸佛　　处在大众中
  三十二相具　　八十好严身

行者以是三昧念诸佛三十二相八十种好庄严其身。比丘亲近诸天供养。为诸大众恭敬围绕。专心忆念取诸佛相。又念诸佛是大愿者。成就大悲而不断绝。具足大慈深安众生。行于大喜满一切愿。行于舍心舍离憎爱不舍众生。行于谛处常不欺诳。行于舍处净除悭垢。行于善处其心善寂。行于慧处得大智慧。具行檀波罗蜜为法施主。具行尸罗波罗蜜戒行清净。具行羼提波罗蜜能忍如地。具行毗梨耶波罗蜜精进超绝。具行禅波罗蜜灭诸定障。具行般若波罗蜜破智慧障阂。手足轮相能转法轮。足安立相安住诸法。手足网缦相灭诸烦恼。七处满相诸功德满。手足柔软相说柔和法。纤长指相长夜修集诸善妙法。足跟广相眼广学广。大直身相说大直道。足趺高相一切中高毛上旋相能令众生住上妙法。伊泥鹿[跳-兆+尃]相[跳-兆+尃]佣渐粗。臂长过膝相臂如金关。阴马藏相有法宝藏。身金色相有无量色。皮细薄相说细妙法。一一毛相示一相法。白毫庄严面相乐观佛面无厌。师子上身相如师子无畏。肩圆大相善分别五阴。腋下满相满大善根。得味味相具足寂灭味。方身相破生死畏。肉髻相头未尝低敬。舌大相色如真珊瑚能自覆面。梵音相身相至梵天。师子颊车相肩广相能破外道。齿齐相行清白禅。齿平等相平等心于一切众生。齿密致相离诸贪着。四十齿相具足四十不共法。绀青眼相慈心视众生。牛王睫相睫长不乱。得希有色乐见无厌。以此三十二相庄严其身。八十种好间错映发。福德具足威力殊绝名闻流布。戒香涂身世法所不动。诸烦恼所不染。恶言所不污。游戏诸神通。诸佛如是威力猛盛无敢当者。以慧说法如师子吼如意自在。以精进力破诸痴闇。以大光明普照天地。诸问答中最无有上。一切仰瞻无下观者。常以慈心观察众生。念如大海。定如须弥。忍辱如地。增长众主所种福德如水滋润。能生众生诸善根力如风开发。成就众生如火熟物。智慧无边犹如虚空。普雨大法如大密云。不染世法犹如莲华。破外道师如师子搏鹿。能举重担如大象王。能导大众如大牛王。眷属清净如转轮王。世间最上如大梵王。可爱可乐如清天明月。普照能然犹如朗日。与诸众生安乐因缘。犹如仁父。怜愍众生随宜将护犹如慈母。所行清净如天真金。有大势力如天帝释。勤利世间如护世主。治烦恼病犹如医王。救诸衰患犹如亲族。积诸功德如大库藏。其戒无量。其定无边。其慧无称。解脱无等解脱知见无等等。于一切事最无有比。一切世间最无上故名第一人。成大法故名为大人。如是菩萨以大人相念观诸佛。是诸佛者于无量无边百千万亿不可思议不可计劫修习功德。善能守护身口意业。于过去未来现在无为不可说五藏法中悉断诸疑。定答分别答反问答置答。于四问答无有错谬。善说根力觉道念处正勤如意三十七助道法。善能分别无明诸行识名色六入触受爱取有生老死因果。于眼色耳声鼻香舌味身触意法无所系着。善说九部经法。所谓修多罗岐夜授记伽陀忧陀那尼陀那如是诸经斐肥儸未曾有经。不为贪欲嗔恚愚痴憍慢身见边见邪见见取戒取疑诸使所使。不为无信无惭愧谄曲戏调放逸懈怠睡眠嗔恨悭嫉诸恼所侵。知见苦断集证灭修道。可去已去。可见已见。所作已办。尽破怨贼。具足诸愿。是世间尊是世间父是世间主。是善来善去善意善寂善灭善解脱者。在无量无边十方恒河沙等世间中住。如现在前菩萨。又应以八十种好念观诸佛。甲色鲜赤行清白法。甲隆而大生在大家。甲色润泽深爱众生。指圆纤长其行深远。指肉充满善根充满。指渐次而长次第集诸佛法。脉覆不见不覆身口意念脉。无粗结破烦恼结。踝平不现不隐藏法。足不邪曲度堕邪众。行如师子是人中师子。行如象王是人象王。行如鹅王。高飞如鸿。行如牛王人中最尊。行时右旋善说正道。身不偻曲心常不曲。身坚而直赞坚牢戒。身渐次大次第说法。普身诸分大而端严。善能解说大妙功德。身相具足具足法者。足步间等等心众生。其身净洁三业清净。身肤细软心性自软。身离尘垢善见离垢。身不缩没心常不没。身无边量善根无量。肌肉紧密永断后身。支节分明善说十二因缘分别明了。身色无闇知见无闇。腹圆周满弟子行具。腹净鲜洁善能了知生死过恶。腹不高出破憍慢山。腹平不现说平等法。脐圆而深通甚深法。脐画右旋弟子顺教。身遍端严弟子遍净。威仪鲜洁心净无比。身无点子无黑印法。手濡胜兜罗绵。受化者身轻如毛。手画文深威仪深重。手画文长观受法者长远后事。手画润泽舍亲爱润得大道果。面貌不长结戒有开。唇赤如频婆果。见一切世间。如镜中像。舌柔而软先以软语度脱众生。舌薄而广功德纯厚。舌赤如深红凡夫心难解佛法令解。声如雷震不畏雷声。其声和柔说柔软法。四牙圆直说直道法。四牙俱利度利根者四牙鲜白清白第一。四牙齐等住戒平地。牙渐次细渐次说四谛法。鼻高隆直住智高山。鼻中清净弟子清白。眼广而长智慧广远。睫不希疏善择众生。眼白黑鲜净如青莲华叶。天人婇女以好眼敬礼。眉高而长名闻远流。眉毛润泽善知软法。耳等相似闻法者等。耳根不坏度不坏心众生。额平而好善离诸见。额广无妨广破外道。头分具足善具大愿。发色如黑蜂转五欲乐。发厚而致结使已尽。美发柔软软利智者能知法味。发不散乱言常不乱。发润而泽常无粗言。发有美香。以七觉意香华随宜化导。发中有德字安字喜字。手足中亦有德字安字喜字。菩萨如是应念诸佛处在大众讲说正法坐师子座。其座以琉璃杂宝为脚。以真珊瑚妙赤真珠以为枕。金薄帏帐柔软滑泽种种天衣以为敷具。以宝师子赤金为身。虎珀为眼。车磲为尾。珊瑚为舌。白金刚为四牙。真白银为发。毛发长广。具足其床在此四师子上。大象王牙以为凭机。其承足机众宝所成。为诸天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽之所敬礼。诸佛如是在此床上。着竭支泥洹僧。不高不下覆身三分。周匝齐整着浅色袈裟。条数分明不高不下亦不参差。处八大圣庄严众中人天大会。龙金翅鸟俱共听法心无嗔恨。一切大众深心惭愧敬爱于佛。皆共一心听佛所说。受持思惟如所说行。专心听受心清净故能障诸盖。一切大众瞻仰如来无有厌足。衣毛皆竖泣泪心热或有大喜。有如是者。则知其人心得清净寂默湛然如入禅定。无爱无恚心无余缘。有大悲相慈愍众生。欲救一切心不谄曲。寂灭清净分别好丑。有大志量不没不缩不高不下。佛悉瞻见处在如是。大众说法易解易了乐闻无厌。音深不散柔软悦耳从脐而出。咽喉舌根鼻颡上龂齿唇。气激变成音句。柔软悦耳。如大密云雷声隐震。如大海中猛风激浪。如大梵天音声引导可度众生。离眉眼唇可呵语法。言不阙少又不烦重。所说无疑言必利益。无有诳语可破语等。离如是过远近等闻。四种问难随意能答。开示四谛令得四果。建立义端因缘结句。语言法则皆悉具足。种种所说事义易了。所宣分明不故隐曲。言不卒疾又不迟缓。始终相称无能难者。以如是语敷演说法。初中后善有义有利唯法具足。能令众生得今世报。无有时节可得尝试能满所愿。深妙智者以内可知。能灭众生三毒猛火。能除一切身口意罪。善能开示戒定慧品。初以名字后令知义而生欢喜。从喜生乐从乐生定。从定生如实智。从如实智生厌离。从厌离灭结使。灭结使故得解脱。如是能令此法次第。善能开示谛舍灭慧四处。能示众生令满布施持戒忍辱精进禅定智慧波罗蜜。能令众生次第得至喜地净地明地炎地难胜现前深远不动善慧法云。能分别声闻乘辟支佛乘大乘。能令证须陀洹斯陀含阿那含阿罗汉果。能令成就人天之中所有富乐。是为一切第一利益诸功德藏。如是正心忆念诸佛。在闲静处除却贪欲嗔恚睡眠疑悔调戏。一心专念不生障碍失定之心。以如是心专念诸佛。若心没当起若散当摄。并见大众常如现前。未入定时常应称赞相好二事。以偈叹佛令心调习。如此偈说

  世尊诸相好　　何业因缘得
  我以相及业　　称赞于大圣
  足相千辐轮　　清净眷属施
  以是因缘故　　贤圣众围绕
  足下安立相　　受善持不失
  是故魔军众　　不能得毁坏
  手足指网缦　　身相紫金色
  善行摄法故　　大众自然伏
  手足极柔软　　身相七处满
  随意食施故　　多得自然供
  长指广脚跟　　身佣大直相
  离杀因缘故　　乃至于劫寿
  毛上向右旋　　足趺隆高相
  常进诸善事　　故得不退法
  伊泥鹿[跳-兆+尃]相　　常乐读诵经
  为人说法故　　疾得无上道
  修臂下过膝　　一切所有物
  求者无吝惜　　随意化导人
  阴藏功德藏　　善知离散故
  多得人天众　　净慧眼为子
  薄皮耀金光　　妙衣堂阁施
  故多得妙衣　　清净房楼观
  一孔一毛生　　眉间白毫峙
  常为最上护　　故于三界尊
  身上如师子　　两肩圆而满
  常行人爱语　　无有违反者
  腋满知味相　　病施医药故
  人天皆敬爱　　身无有疾病
  身圆肉髻相　　和悦心施福
  劝化刚强者　　法王中自在
  迦陵频伽音　　广舌声如梵
  所言常软实　　得大圣八音
  先加以思虑　　后言必有实
  故得师子相　　见者皆信伏
  齿白齐密相　　所曾供养者
  后常不轻故　　眷属心和同
  上下四十齿　　密致不疏漏
  无谗不妄语　　徒众不可破
  眼黑青白明　　睫相如牛王
  慈心和视故　　观者无厌足
  虽转轮圣王　　典主四天下
  有是诸相好　　光明不如佛
  我所称叹说　　诸相好功德
  愿令一切人　　心净常安乐

菩萨又应以八十种好念诸佛。如此偈说

  诸佛有妙好　　八十庄严身
  汝等应欢喜　　一心听我说
  世尊圆纤指　　其甲紫红色
  隆高有润泽　　所有无有量
  脉平踝不现　　双足无邪曲
  行如师子王　　威望无等比
  行时身右旋　　安庠有仪雅
  方身分次第　　端严可爱乐
  身坚极柔软　　支节甚分明
  行时不逶迤　　诸根悉充满
  肌体极密致　　鲜明甚清净
  身形甚端雅　　无有可呵处
  腹圆不高现　　脐深而无孔
  其文右向旋　　威仪甚清净
  身无有疵点　　手足极柔软
  其文深且长　　修直有润色
  舌薄面不长　　牙白圆纤利
  唇色频婆果　　音深若鸿王
  鼻隆眼明净　　睫致而不乱
  眉高毛柔软　　端直不邪曲
  眉毛齐而整　　善知诸法过
  眉毛色润泽　　善度润众生
  耳满长而等　　不坏甚可爱
  额广而齐正　　头相皆具足
  发致而不乱　　如黑蜂王色
  清净而香洁　　中有三种相

是名八十种好。以此八十种好间杂庄严三十二相。若人不念三十二相八十种好赞叹佛身者。是则永失今世后世利乐因缘

十住毗婆沙论卷第九十住毗婆沙论卷第十

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

    四十不共法品第二十一

菩萨如是以三十二相八十种好念佛生身已。今应念佛诸功德法。所谓

  又应以四十　　不共法念佛
  诸佛是法身　　非但肉身故

诸佛虽有无量诸法不与余人共者有四十法。若人念者则得欢喜。何以故。诸佛非是色身。是法身故。如经说。汝不应但以色身观佛。当以法观。四十不共法者一者飞行自在。二者变化无量。三者圣如意无边。四闻声自在。五无量智力知他心。六心得自在。七常在安慧处。八常不妄误。九得金刚三昧力。十善知不定事。十一善知无色定事。十二具足通达诸永灭事。十三善知心不相应无色法。十四大势波罗蜜。十五无碍波罗蜜。十六一切问答及记具足答波罗蜜。十七具足三转说法。十八所说不空。十九所说无谬失。二十无能害者。二十一诸贤圣中大将。二十五四不守护。二十九四无所畏。三十九佛十种力。四十无碍解脱。是为四十不共之法。今当广说。飞行自在者。诸佛飞行如意自在。如意满足速疾无量无碍。所以者何。佛若欲于虚空先举一足次举一足。即能如意。若欲举足蹑虚空而去。若欲住立不动而去。即能得去。若结跏趺安坐而去亦能得去。若欲安卧而去亦复能去。若欲于青琉璃茎真珊瑚叶黄金为须如意珠台无量围绕如日初出是宝莲花遍于空中蹈上而去。若欲如日月宫殿帝释胜殿夜摩天兜率陀天化乐天他化自在天诸梵王等宫殿。随意化作如彼宫殿坐中而去即能成办。若更以余种种因缘随意能去。是故说言。随诸所愿皆能满足。是故诸佛能以一步。过恒河沙等三千大千世界。有人言。佛能一念顷过若干百千国土。有人言。若知佛一步一念能如是去即可得量。经中说诸佛力无量。是故当知。诸佛虚空飞行自在无量无边。何以故。若大声闻弟子神通自在以一念顷。能过百亿阎浮提瞿陀尼弗婆提郁多罗越四大王天忉利天夜摩天兜率陀天化乐天他化自在天梵天。一瞬中过若干念。积此诸念以成一日七日一月一岁。乃至百岁。一日过五十三亿二百九十六万六千三千大千世界。如是声闻人百岁所过。佛一念能过。复次假令恒河中沙一沙为一劫。有大声闻神通第一寿命如是诸恒河沙大劫。于一念中过若干世界。积如是念以为日月岁数以自在力尽是诸大劫数所过国土。佛能一念中过。诸佛飞行自在如是速疾。于一切铁围山十宝山四天王处忉利天处夜摩兜率陀化乐他化自在梵世梵众大梵少光无量光光音少净无量净遍净广果无相不广不恼喜见妙见阿迦尼吒天如是诸处。大风大水劫尽火等。及诸天龙夜叉乾闼婆阿修罗紧那罗摩睺罗伽诸天魔及梵沙门婆罗门及得诸神通者不能为碍。是故说飞行无碍。又飞行自在如意所作出没于地能过石壁诸山障碍等。佛于此事胜诸圣人。又佛能以常身立至梵天。声闻人所不能及。有如是等差别。变化自在者。变化事中有无量力。余圣变化有量有边。诸佛变化无量无边。余圣于一念中变化一身。佛以一念随意变化有无量事。如大神通经中说。佛从脐中出莲花。上有化佛次第遍满上至阿迦尼吒天。诸佛变化所作众事。种种色种种形皆以一念。又声闻人能于千国土内变化。诸佛能于无量无边国土变化自在。又能倍是诸佛得坚固变化三昧。又诸佛变化。能过恒沙世界。皆从一身出。复次佛能普于十方无量无边世界现生受身堕地行七步。出家学道破魔军众。得道转法轮。如是等事皆以一念作之。是诸化佛皆亦复能施作佛事。如是等诸佛所变化事无量无边。又于圣如意中有无量力。圣如意者。所谓从身放光犹如猛火又出诸雨。变化寿命随意长短。于一念顷能至梵天能变诸物。随意自在能动大地。光明能照无量世界而不断绝。圣如意者。不与凡夫等故。无有量故。过诸量故。诸凡夫等虽变化诸物少不足言。声闻人能裂千国土。还使令合。能令寿命若至一劫若减一劫。还能令短。短已不能令长。于一念中能至千国土梵世界。能于千国土随意变化。能动千国土。能身出光明相续不绝照千国土。设使身灭能留神力变化如本于千国土。小辟支佛能于万国土万种变化。中辟支佛能于百万国土百万种变化。大辟支佛能于三千大千国土变化如上。诸佛世尊能过诸恒河沙世界算数变化身出水火能末恒河沙等世界令如微尘。又能还合能住。寿命无量劫数还能令少。少已还能令长。能于无量时住。变化随意。能以一念至无量无边恒河沙等世界。能以常身立至梵世。又能变化无量无边阿僧祇世界皆令作金。或令作银琉璃珊瑚车磲马瑙。取要言之。能令作无量宝物。随意所作。又复能变恒河沙等世界大海水。皆使为乳酥油酪蜜随意而成。又能以一念变化诸山皆是真金。过诸算数不可称计。又能震动无量无边世界一切欲界色界诸天宫殿。又以一念能令若干金色光明遍照如是无量世界。日月光明及欲色界诸天宫殿光明皆令不现。虽灭度后能于如是诸世界中随意久近。流布神力常不断绝。闻声自在者。诸佛所闻声中随意自在。若无量百千万亿技乐同时俱作。若无量百千万亿众生一时发言。若远若近随意所闻。假令恒河沙等三千大千世界所有众生。同时俱作若干百千万种伎乐遍满世界。复有恒河沙等世界众生。同时以梵音。遍满一切世界。诸佛若欲于中闻一音声随意得闻。余者不闻。声闻所应闻者。若有大神力障者不能得闻。诸佛所闻音声虽有大神力障亦能得闻。声闻能闻千国土内音声。诸佛世尊所闻音声过无量无边世界最细音声皆亦得闻。大神力声闻住梵世界。发大音声能满千国土内。诸佛世尊若住于此若住梵世若住余处。音声能满无量无边世界。若欲令众生闻过无量无边世界最细音声能令得闻。欲令不闻即便不闻。是故但有诸佛于闻声中得自在力。知他心无量自在力者。诸佛世尊于无量无边世界现在众生悉知其心。余人但随名相故知。诸佛以名相义故知。又余人不能知无色界众生诸心。诸佛能知。余人虽有知他心智。大力者障则不能知。假使一切众生成就心通。皆如舍利弗目犍连辟支佛等。以其神力障一人心。不令他知。而佛能坏彼神力得知其心。复次佛以神力悉知众生上中下心垢心净心。又知诸心各有所缘从是缘至是缘次第。遍知一切诸缘。又以实相知众生心。是故诸佛以无量力悉知他心。第一调伏心波罗蜜者。善知诸禅定三昧解脱住入起时。诸佛若入定若不入定。欲系心一缘中。随意久近如意能住。从此缘中更住余缘随意能住。若佛住常心欲令人不知则不能知。假使一切众生。知他心智如大梵王如大声闻辟支佛。成就智慧知他人心。以此诸智令一人得。是人欲知佛常心。若佛不听则不能知。如七方便经中说。行者善知定相。善知住定相。善知起定相。善知安隐定相。善知定行处相。善知定生相。善知宜诸定法不宜诸定法。是名诸佛第一调伏心波罗蜜。诸佛常安慧者。诸佛安慧常不动念常在心。何以故。先知而后行。随意所缘中住无疑行故。断一切烦恼故。出过动性故。如佛告阿难。佛于此夜得阿耨多罗三藐三菩提。一切世间若天魔梵沙门婆罗门。以尽苦道教化周毕入无余涅槃。于其中间佛于诸受知起知住知生知灭。诸相诸触诸觉诸念亦知起知住知生知灭。恶魔七年昼夜不息常随逐佛不得佛短。不见佛念不在念安慧。是名诸佛常住安慧行中。不忘失法者。诸佛得不退法故。通达五藏法故。得无上法故。诸佛常不忘失。诸佛菩提树下所得。乃至入无余涅槃。若天魔梵沙门婆罗门。及余圣人。无能令佛有所忘失。如法印经中说。道场所得是名实得更无胜法。如衣毛竖经说。舍利弗。若人实语。有能于法不忘失者。应说我是。何以故。唯我一人无所忘失。是名诸佛于法无忘失。金刚三昧者。诸佛世尊金刚三昧。是不共法。无能坏故。于一切处无有障碍故。得正遍知故。坏一切法障碍故。等贯穿故。得诸功德利益力故。诸禅定中最上故。无能坏者。是故名为金刚三昧。如金刚宝无物能破者。是三昧亦如是。无有法可以坏者。是故名金刚三昧。问曰。何故不可坏。答曰。一切处无有阂故。如帝释金刚无有阂处。是三昧亦如是。问曰。是三昧。何故名一切处不阂。答曰。正通达一切法故。诸佛住是三昧。悉能通达过去现在未来。过出三世不可说五藏所摄法。是故名一切处不阂。若诸佛住是三昧。诸所有法若不通达名为有碍。而实不尔。是故名无碍。问曰。何以故。是三昧通达一切法。答曰。是三昧能开一切障碍法故。所谓烦恼障阂定障阂智障阂能开故。是名能通达一切法。问曰。是三昧。何故能开一切障。余三昧不能。答曰。是三昧善等贯穿二法。能坏诸烦恼山令无余故。正遍通达一切法故。善得不坏心解脱故。是故此三昧能开一切障阂。问曰。是三昧何故等贯穿二法。答曰。住是三昧得力故。能得一切诸功德。余三昧无如是力。是故是三昧能等贯穿。问曰。何故住是三昧得力故能得一切诸功德。答曰。是三昧于诸定中最为第一。是故住是三昧能得诸功德。问曰。何故是三昧于诸定中最为第一。答曰。是三昧无量无边善根所成故。于诸定中最为第一。问曰。是三昧何故无量无边善根所成。答曰。是三昧唯一切智人有余人所无。是故名为金刚三昧

    四十不共法中难一切智人品第二十二

问曰。汝说金刚三昧。唯一切智人有。余人所无。若是三昧但一切智人有。余人无者。即无是三昧。何以故。无一切智人故。何以故。所知法无量无边。而智慧有量有边。以此有量有边智慧。不应知无量事。如今现阎浮提水陆众生过诸算数。是众生三品。若男若女非男非女在胎孩童少壮衰老苦乐等法。过去未来现在诸心心数法。及诸善恶业。已集今集当集。已受报今受报未受报。万物生灭及阎浮提中山河泉池草木丛林根茎枝叶花果。所可知者无有边际。余三天下亦如是如四天下三千大千世界物亦如是。如三千大千世界物一切世界所可知物亦如是。但世间数尚无量无边难可得知。何况诸阎浮提诸世间中。众生非众生诸物分。以是因缘当知。所可知物无量无边故。无一切智者。若谓智慧有大力于所知法中无障阂故遍知一切可知。法如虚空遍在一切法中。是故应有一切智人者。是事不然。智大力可尔。大智不能自知。如指端不自触。是故无一切智。若谓更有智能知是智。是亦不然。何以故。有无穷过故。智若自知若以他知。二俱不然。若是智有无量力。以不自知故。不得言有无量力。是故无有能知一切法智。无知一切法智故。则无一切智者。何以故。一切智者。以智知一切法故。复次所知法无量无边。若和合百千万亿智人尚不能尽知。何况一人。是故无有一人能知一切法。无有一切智。若谓不以遍知一切山河众生非众生故名一切智人。但以尽知一切经书故名一切智人者。是亦不然。何以故。佛法中不说韦陀等经书义。若佛是一切智人者。应用韦陀等经书而实不用是故。佛非一切智人。又四韦陀罗经有量有限。今世尚无尽能知者。况有尽知一切经书。是故无有一切智人。复次有经书能增长贪欲。歌舞音乐等。若一切智人知是事者即有贪欲。是经书者是贪欲因缘。若有因必有果。若一切智人不知此事则不名一切智人。复次有诸经书能助嗔恚喜诳于人。所谓治世经书等。若知是事则有嗔恚。何以故。有因必有果故。若不知则不名一切智人。是故知无一切智人。复次佛不必尽知未来世事。譬如我今难一切智人。佛无经书豫记是人如是姓如是家在某处以如是事难一切智人。若谓佛尽知何以故不说是事。若说经者经中应有不说是事。是故知非一切智人。复次佛若尽知未来世事。应当豫知调达出家已破僧。若知者不应听出家。复次佛不知木机激石。佛若豫知者则不应于中经行。复次佛不知旃遮婆罗门女以淫欲谤。若佛先知。应告诸比丘未来当有是事。复次有梵志嫉佛故于余处杀梵志女孙陀罗于祇洹堑中埋。佛不知是事。若知是者。应于诸梵志所救此女命。至调达所推石下。不说婆罗门女梵志女事。以不知故。当知佛不尽知未来世。是故非一切智人。复次佛入婆罗门聚落乞食空钵而出。不能豫知魔时转诸人心。乃至不得一食。佛若知者则不应入婆罗门聚落。是故知佛不尽知未来事。复次阿阇世王欲害佛故放守财醉象。佛不知故入王舍城乞食。若豫知者则不应入城。是故不知未来事。不知未来事故则非一切智人。复次佛不知恶涅达多请佛因缘。即受其请将诸比丘诣韦罗阇国。是婆罗门忘先请故。使佛食马麦。若佛豫知则不应受请三月食马麦。是故知佛不知未来事。不知未来事故则非一切智人。复次佛受须涅叉多罗为弟子故则不知未来事。是人恶心坚牢难化不信佛语。佛若知者云何受为弟子。受为弟子故则不知未来事。不知未来事故则非一切智人。复次若佛是一切智人则应防护未有犯罪者当为结戒。以先不知结戒因缘有作罪已方乃结戒则不知未来事。不知未来事故则非一切智人。复次佛法但以出家受戒岁数处在上座恭敬礼拜。不以耆年贵族诸家功德智慧多闻禅定果断神通为大。若是一切智者。应以耆年贵族诸家功德智慧多闻禅定果断神通为大供养恭敬。若如是者名为善制。岁数者受戒年数。如五岁道人礼六岁者。贵族者世间有四品众生。婆罗门刹利韦舍首陀罗。首陀罗应恭敬韦舍刹利婆罗门。韦舍应恭敬刹利婆罗门。刹利应恭敬婆罗门。诸家者。工巧家商估家居士家长者家大臣家王家等。于诸家中。其小家应恭敬大家。如是于贫贱中出家者。应恭敬富贵中出家者。功德者毁戒人应恭敬礼拜持戒者。持戒者不应礼毁戒者。不行十二头陀者。应礼行十二头陀者。不具足行头陀者。应礼具足行头陀者。智慧者。无智慧人应礼敬有智慧者。多闻者。少闻人应礼多闻者。不多诵者应礼敬多诵者。果者。须陀洹应礼敬斯陀含。如是展转应礼阿罗汉。一切凡夫应礼得果者。断者。少断结使及未断者应礼多断者。神通者。若未具神通者应礼具神通者。佛若如是次第善说供养恭敬法者。是为上说。而实不尔。是故知非一切智人。复次佛尚不能知现在事。汝若谓我云何知佛不知现在事者。今当说之。有众生结使薄者。无业障者。离八难者。堪行深法者。能成正法者。而佛不知。佛成道已初欲说法。生如是疑。我所得法甚深玄远微妙寂灭难知难解。唯有智者可以内知。世间众生贪着世事。此中除断一切烦恼灭爱厌离第一难见。若我说法众生不解。徒自疲苦。生如是疑。而实众生有薄结使无业障者。有离八难者。堪行深法者。能成正法者。佛不能知如是众生。是故当知不知现在事。又作是念。昔我苦行。五比丘供养执侍应先利益。今在何处。作是念已时有天告。今在波罗捺鹿野苑中。是故当知佛不知现在事。不知现在事故。则非一切智人。复次佛得道已受请说法而作是念。我今说法谁应先闻。即复念言。郁头蓝弗。此人利智易可开悟。尔时此人先已命终。而佛访求。时天告言。昨夜命终。佛又思惟回心欲度阿罗逻。天复白言。是人亡来七日。若佛是一切智者先应知此诸人命终。而实不知。不知过去事故则不名一切智人。一切智人法应度可度者。不可则置。复次佛处处有疑语。如巴莲弗城。是事当以三因缘坏。若水若火若内人与外人谋。若佛是一切智人者则不应有疑惑语。是故知非一切智人。复次佛问比丘。汝等聚会为说何事。如是等问。若一切智人者则不应问如是等事。以问他故非一切智人。复次佛自称赞身毁訾他人。如经中说。佛告阿难。唯我一人第一无比无与等者。告诸比丘尼犍子等是弊恶人成就五邪法。诸尼犍子等无信无惭无愧寡闻懈怠少念薄智。又说梵志尼犍诸外道弟子等诸不可事。若自称赞毁訾他人。世人尚愧。何况一切智人。有此事故非一切智人。复次佛经始终相违如经中说。诸比丘我新得道。又言我得往古诸佛所得道。世间有智尚离终始相违。何况出家一切智人而有相违。以终始相违故。当知非一切智人。是故汝说金刚三昧唯一切智人得。是事不然。无一切智人故。一切智三昧亦不成。答曰。汝莫说此。佛实是一切智人。何以故。凡一切法有五法藏。所谓过去法。未来法。现在法。出三世法。不可说法。唯佛如实遍知是法。如汝先难所知法无量无边故无一切智人者。我今当答。若所知法无量无边。智亦无量无边。以无量无边智知无量无边法无咎。若谓是知亦应以智知是则无穷者。今当答。法应以智知。智如世间人言。我是智者我是无智者。我是粗智者。我是细智者。以是因缘以智知智故。则无无穷过。如以现在智知过去智则尽知一切法无有遗余。复次如人数他通身为十知亦如是。自知亦知他则无有咎。如灯自照亦照他。如汝所说和合百千万亿智人尚不能尽知一切法。何况一人知者。是事不然。何以故。一切智慧人能知众事。虽复众多无有智慧不能有所知。如百千盲人不任作导。一人有眼任为导师。是故汝以一人为难。虽复多智于佛则无智。是事不然。汝谓佛不说韦陀等外经故非一切智人者。今当答。韦陀中无善寂灭法。但有种种诸戏论事。诸佛所说皆为善寂灭故。佛虽知韦陀等经。不能令人得善寂灭。是故不说。问曰。韦陀中亦有善寂灭解脱说。世间先皆幽闇都无所有。初有大人出现如日。若有见者得度死难。更有余导。又说。人身小则神小。人大则神大。身为神宅常处其中。若以智慧开解神缚则得解脱。是故当知韦陀中有寂灭解脱。答曰。无是事也。何以故。韦陀经中有四颠倒。世间无常而别有常世间。如说一作天祠堕落再亦堕落三作则不堕。是为无常中常颠倒。世间苦而说有常乐处。是为苦中乐颠倒。又说我神转为子愿使寿百岁。子是他身云何为我。是为无我中我颠倒。说身清净第一无比。金银珍宝无及身者。是名无净中净颠倒。颠倒则无实。无实云何有寂灭。是故韦陀中无善寂灭法。问曰。韦陀中说。能知韦陀者清净安隐。云何言无善寂灭法。答曰。知韦陀者虽说安隐非毕竟解脱。于异身中生解脱想。是说因长寿天。说为解脱。是故韦陀中实无解脱。复次韦陀中。略说有三义。一者咒愿。二者称赞。三者法则。咒愿名为令我得妻子牛马金银珍宝。称赞名为汝火神头黑颈赤体黄常在众生五大中。法则名为是事应作是不应作。如从昴星初受火法而实咒愿称赞法。则无有寂灭解脱。何以故。贪着世乐然苏咒愿无真智慧。不断烦恼何有解脱。问曰。韦陀法自古有之第一可信。汝言无善寂灭故不可信者。是事不然。何以故。佛法近乃出世。韦陀自古久远常在世间。是故古法可信近法不可信。汝言韦陀中无善寂灭法。是事不然。答曰。时不可信。无明先出正智后出。邪见先出正见后出。不可以无明邪见先出故可信。正智正见后出不可信。如先有污泥后有莲花。先有病后有药。如是不可以在先出者为贵。是故韦陀先出。佛法后出。谓不可信者。是事不然。复次过去锭光等诸佛皆先出世。其法则古出。韦陀是后出。若汝以先久为贵者。此诸佛及法则应是贵。问曰。韦陀不能作善寂灭。是故佛法中不说。若佛知不能作寂灭。何用知为。若不知则非一切智人。二俱有过。答曰。汝语非也。佛先知韦陀不能善寂灭故不说亦不修行。问曰。若佛知韦陀无有利益故而说不修习者何用知为。答曰。大智之人应悉分别是正道是邪道。欲令无量人众度险恶道故行于正道。譬如导师善分别邪道正道。佛亦如是。既自得出生老死险道。亦复欲令众生出故。善知八真圣道。亦知韦陀等邪险恶道。为离邪恶道故。行于正道故。但知而不说。犹如农夫为谷种植至秋收获亦得草[麩-夫+戈]。佛亦如是。为无上道故勤行精进得菩提道。亦知韦陀等诸邪道。是故无咎。如汝先说无人能有具知四韦陀者。此难不然。世间人各有念力。有人一日能诵五偈。有诵百偈。有诵二百偈。若人一日不诵十偈则谓无能诵百偈出百偈者。此非实语。汝等不能尽知故。便言都无智者。若人见一人不能度河便言无能度者。是人不名正说。何以故。自有余大力者能度。此亦如是。设使余人不能尽知。一切智者知之何咎。复次脾娑仙人。皆读韦陀亦应成一切智。若有尽读韦陀。何以言无一切智。若汝言有经书能生贪欲嗔恚者。我今当答。若人欲长寿。应离死因缘。佛亦如是欲断一切众生贪欲嗔恚。应知贪欲嗔恚因缘。复次如汝说能知生贪欲嗔恚经书则有贪欲嗔恚者。无有是处也。佛虽知是不用不行故无过咎。如人知死因缘则不死。若行死因缘则死。是事亦尔。若汝说不知未来事故不名一切智者。我今当答。此则非难。我等亦知有难一切智者如经中说。佛告诸比丘。凡夫无智有三相。不应思而思。不应说而说。不应作而作。是故皆已总说。汝等未来世凡夫皆在其中无利益故。何用分别说其名字等。若谓佛知有难不豫答者亦不须此。今现四众中亦有善断疑难者。今亦有能破诸难问者。何用先答。如汝今日现见比丘之中能破婆罗门者。是故不须先答。又先时亦有答。散在众经。人不能具知佛法故。不知处所。若言受调达出家事。我今当答。谓受调达出家则非一切智人者。是语不然。调达出家非佛所度。问曰。若余人度者佛何以听。答曰。善恶各有时。不必出家便恶。调达出家之后有持戒诸功德。是故出家无过。复次调达于十二年清净持戒诵六万法藏。此果报者当来不空必有利益。汝说调达机关激石者。我今当说。诸佛成就无杀法故。一切世间无能夺命者。问曰。若成就不杀法者。何故迸石而来。答曰。佛于先世种坏身业定报应受。示众生业报不可舍故现受。是故自来。汝言旃遮女佛不先说者。我今当答。以旃遮女故讥佛者。不能坏一切智人因缘。若佛先说旃遮女当来谤我者。旃遮女则不来。复次佛先世谤人罪业因缘。今必应受。汝说佛何以不遮孙陀利入祇洹事。我今当答。此事不能坏一切智人因缘。佛无有力令一切众生尽作乐人。又诸佛离一切诤讼不自高身不着持戒。是故不遮。复次佛先世业熟故。必应受七日谤。又众生见佛闻谤不忧。雪明不喜故。发无上道心。作是愿言。我等亦当得如是清净心。是故无咎。汝先说佛入婆罗门聚落空钵而出非一切智人者。今当答。佛不以饮食先观人心入聚落已魔转其意。问曰。是事佛应先知。我入聚落魔当转人心。答曰。佛亦先知此事。为大利益众生。诸佛非但以受人食故。以为利益度脱众生。有以清净心迎逆敬礼和颜瞻视。此皆大利何必饮食。以种种门利益众生。非空入聚落。汝说佛逆趣醉象者。今当答。佛虽知此事。以因缘故往以此醉象必应得度。又能障其害佛罪业。复次此象身如黑山。众人见此低头礼佛皆起恭敬。以是因缘故佛故往趣。复次佛趣此象无有过失。若有恶事可作此难。汝难至随兰若者。为受先世业果报故。汝说畜须洹叉多罗为弟子者。今当说。佛身口意命不须守护。无所畏故听为弟子。复次是人常近佛故得见种种大神力。见诸天龙夜叉乾闼婆阿修罗等诸王来供养佛请问种种甚深要法心得清净。心清净故得利益因缘。是故虽恶听为弟子。问曰。此人于佛多生恶心。是故不应听为弟子。答曰。若不听为弟子亦有恶心。是故听为弟子无咎。汝说先未作罪时何以不制戒。今当答。佛先结戒。说八圣道正见正思惟正语正业正命正精进正念正定。说是至涅槃道故。已说一切诸戒。复次佛说三学。善学戒善学心善学慧。当知已说一切诸戒。复次佛告诸比丘。一切恶决定不应作。是不名先结戒耶。复次佛说十善道。离杀盗淫两舌恶骂妄言绮语贪嫉嗔恚邪见。不名先结戒耶。佛先十二年中说一偈为布萨法。所谓一切恶莫作。一切善当行。自净其志意。是则诸佛教。是故当知先已结戒。复次佛说诸小恶因缘皆应当离。如说

  离身诸恶行　　亦离口诸恶
  离意诸恶行　　余恶悉远离

如是说者当知先已结戒。复次佛先已说诸守护法。如说

  护身为善哉　　能护口亦善
  护意为善哉　　护一切亦善
  比丘护一切　　得远离诸恶

如是说者当知先已结戒。复次佛先说善相。如说

  手足勿妄犯　　节言慎所行
  当乐守定意　　是名真比丘

如是说者当知先已结戒。复次说沙门法故。当知先已结戒。沙门有四法。一于嗔不报。二于骂默然。三杖捶能受。四害者忍之。复次佛说四念处。观身观受观心观法。是涅槃道住处故。当知先已结戒。若微小恶尚不听。何况身口恶业。如是等因缘当知先已结戒。如王者立制。不应作恶。后有犯者随事轻重作如是罪如是治之。佛亦如是。先总说戒。后有犯者说其罪相。如有作恶者教令忏悔。作如是罪应如是忏。不见摈灭摈不共住等。成如是事故。后乃结戒

十住毗婆沙论卷第十十住毗婆沙论卷第十一

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

    四十不共法中难一切智人品之余

汝说耆年贵族家等应为上座。今当答。道法中耆年贵族家等于道无益。何以故。生佛法中名为贵族好家中生。从受大戒数其年数名为耆年。汝谓耆年应供养者。先出家受戒非是大耶。又从受戒以后无有诸姓等差别。诸比丘受大戒。名为生在佛家。是则失先大小家名皆为一家。汝说持戒者。出家在先持戒日久长夜护持。年岁多故应为上座。如结戒中说。汝说持戒之人不应礼破戒者。今当答。破戒人尚不应共住。何况礼拜供养。以其自言是比丘故。随其大小而为作礼。如礼泥木天像。以念真天故。佛敕年少应礼上座。顺佛教故则便得福。汝说以头陀故应敬礼者。今当答。若头陀人有五种故难得分别。一者愚痴无所知故贪受难法。二者钝根悕望得利。三者恶意欺诳于人。四者狂乱。五者作念。头陀法者。诸佛贤圣所共称赞。以其随顺涅槃道故。是五种人。行头陀法真伪难别。多闻者。多闻之人亦如头陀难可分别。何以故。或以乐道故多闻。或以利养故多闻。如是等亦难分别。又佛法贵如说行。不贵多读多诵。又如佛说行一法句能自利益名为多闻。智慧亦如是。若不能如所说行何用智慧为。是故不以智慧故说为上座。譬如世间现事弟虽多闻多智而兄不为作礼。是故不以智慧故先受供养礼拜如是。虽多闻智慧应礼先受戒者。若先供养多闻智慧者则为斗乱。余得沙门果断结。得神通最难知。是人得果是不得果。是多断结是少断结。是得神通是不得神通。不可以此为上座。若同得道果断结神通谁为上座。是故随佛教行最为第一。汝说佛于说法生疑。今当答。佛于深法尚不有疑。何况应说不应说中而有疑乎。佛不言我都不说法。但云心乐闲静不务兴事。而后于说法中无咎。复次诸外道言。佛为大圣寂默无戏论。何用畜众而教化为。设使教化亦不可尽。似如分别何用说法畜养弟子是贪着相。是故佛自思惟。我法甚深智慧方便无量无边。而可度者少。是故自言不如默然。又防外道所讥呵故。令梵天王求请说法。即时梵天王等白佛言。众生可愍。中有利根结使薄者易可化度。是故受诸梵王等请。如人得大宝藏应示余人。如是诸圣自得法利亦应利人。如汝所说佛不知阿兰迦兰等先已命终欲为说法者。今当答。佛不念其死与不死。但念此人结使微薄堪任化度。随所念处则有智生。是故佛先自说。而后天告理故宜然。又佛先出家。就此二人曾经宿止。诸天人民傥能疑佛受其妙法余处得道。佛欲断彼疑故。即时唱言彼人长衰如此。妙法如何不闻。推如是义。五比丘事亦复可知。但念其可度因缘。不念其住止所在。后念住处即便得知。是故不应破一切智人。汝言疑说巴连弗城坏者。今当答。是城破因缘不定。不定因缘而定说者是则为过。又我先说四十不共法中诸佛善知不定。答者则不受此难。汝说佛问诸比丘。汝等聚会为何所说。今当答。佛将欲说法门故。作如是问。或欲结戒故。命其自说如是种种说法故。问而无咎。世间亦有知而复问。如见人食问言食耶。如天寒时问言寒耶。佛亦如是知而复问随俗无咎。汝言自赞毁他非一切智人者。今当答。佛不贪身不贪供养。不恚他人不增上慢。所以自说我于世间最第一者。有信众生诸根猛利舍恶知识。以我为师是人长夜当得安隐。是故佛自赞身。复次有人求第一乐道。而有懈怠不能精进。是故佛言无上利中不应懈怠。我于世间第一导师善说正法。宜勤精进可得道果。如是等因缘自赞其身。非为自贵轻贱他人。呵恶人者欲令除灭恶法。非为憎恚众生。有人求如法利。其心清净质直。而与恶知识和合。欲令远离此故而呵骂之。未得佛时尚以髓脑施人。何况成佛而当呵骂。汝说佛法初后相违。今当答。佛法中无有始终相违事。汝等不知佛法义故以为相违。是涅槃道者。从迦叶佛灭已来。无复人说。亦无人得。是故言我新得道。余处复说我得故道。是道锭光等诸佛所得。所谓八圣道能至涅槃。一道一因缘故名为故道。是故当知佛成一切智。问曰。所言一切智者。云何名为一切智。为知一切故名为一切智耶。答曰。一切智者知可知。可知者五法藏。过去未来现在出三世不可说所用。知此五藏者名为知。是故知及所知名为一切。问曰。知可知名一切者。是事不然。何以故。是法但是一。可知知亦是可知故。如世间言是人知利是人知钝。答曰。若一切是一者则寒热相违皆应是一。明闇苦乐诸相违事亦应是一。但是事不然。是故不得言一切皆是一。问曰。汝所执亦同此过。若可知是一者。苦乐等亦应是一而实不一。答曰。我不言一切可知是一。汝所执一切皆是一。是故不与汝同过。复次汝说同有过故。汝自执中有过。若人自受所执中过即堕负处。汝知所执有过。不应复说他过。是故汝说同有过者。是事不然。复次若谓知可知二法为一者。应用可知法知瓶衣等物而实用知知一切物。若谓瓶衣等于知无异者。今瓶衣等不能知物。即应有异而实用知知一切物。如是处处有过故不得言一切皆是一。复次知所知是二名为一切知。是一切法故。名如来名一切智者。是一切智人因金刚三昧。是故金刚三昧成。汝先言金刚三昧不成一切智不成者。是事不然

    四十不共法中善知不定品第二十三

善知不定法者。诸法未生未出未成未定未分别。是中如来智慧得力。如佛分别业经中说。佛告阿难。有人身行善业。口行善业。意行善业。是人命终而堕地狱。有人身行恶业。口行恶业。意行恶业。是人命终而生天上。阿难白佛言。何故如是。佛言。是人或先世罪福因缘已熟。今世罪福因缘未熟。或临命终生正见邪见善恶心。垂终之心其力大故。又首迦经中说。叔迦婆罗门子白佛言。瞿昙。诸婆罗门在家白衣。能修福德善根胜出家者。是事云何。佛言。我于此中不定答。出家或有不修善则不如在家。在家能修善则胜出家。又大涅槃经中说。巴连弗城当以三事坏。或水或火或内人与外人谋。又因波梨末梵志说。是裸形波梨末梵志。若不舍是语。若是心若是邪见。到我目前无有是处。若皮绳断。若身断。终不来到佛前。又筏喻经中说。我此法甚深。以方便说令浅易解。若有直心如教行者得二种利。若今世尽漏。若不尽漏当得不还道。又增一阿含舍迦梨经中。佛告阿难。若人故起业。无有不受报而得道者。若现受报若生受若后受。又增一阿浮罗经中说。佛告诸比丘。诸恶人死若作畜生若堕地狱。善人生处若天若人。又无畏王子经中说。无畏白佛言。佛有所说能令他嗔不。佛言。王子是事不定。佛或怜愍心故。令他人嗔得种善因缘。如乳母以曲指钩出小儿口中恶物虽伤无患。又阿毗昙中说。众生三品。从不定聚或堕邪定。或堕正定。如是等四法藏中无定事。数千万种。问曰。若人智慧不定无决定心。于事中或尔或不尔则不名一切智人。一切智人者不二语者。决定语者。明了语者。是故善知不定。不得名为佛不共法。答曰。不定事。若尔若不尔。随属众因缘故。是中不应定说。又若不定事而作定答不名一切智人。是故于不定事中必应用不定智。是故有不定智不共法。复次若人于一切法中决定知。是人即堕必定邪论中。若一切法必定则诸所作为则不须人功方便而得。如说

  若好丑已定　　人功则应定
  不须诸因缘　　方便而修习

复次现见不自守护身则有众苦。若自防护身则安利。又如种种作业事中受诸疲苦后得种种富乐果报。或复有人今世静默都无所作而得果报。是故有是不定事。为知是不定事故。知有不定智。问曰。汝守护不守护。施功不施功。而亦有不定事成者。有人好自防护而得苦恼。不自防护不得苦恼。又勤自疲苦不得功果。不勤施功而得功果。是事不定。答曰。汝所说则成我不定义。若有不定事应有不定智。我不言若人不自防护悉皆受苦。又不言离功业有果报。有人虽作功夫先世罪障故不得受乐。不言一切皆尔。是故汝难非也。是名诸佛于不定事中独有不定智具足。知无色处者。声闻辟支佛。知生无色处众生及法少分。诸佛世尊于无色处众生及法具足悉知。是无色处有若干众生生此处。若干众生生彼处。若干众生生初无色定处。若干众生生第二处。若干众生生第三处。若干众生生第四处。若干众生生来尔所时。若干众生经尔所时当退没。若干众生极寿尔所时。若干众生毕定寿命。若干众生不毕定寿命。若干众生从欲界命终来生此中。若干众生从色界命终来生此中。若干众生从无色界命终还生此中。若干众生人中命终即来生此。若干众生天中命终即来生此。是诸众生于此命终。若生欲界若生色界若生无色界。是诸众生此中命终。若生天道若生人道若生阿修罗道。若生地狱畜生饿鬼道中。是诸众生于彼处入涅槃。若干众生皆是凡夫。若干众生是佛贤圣弟子。若干众生凡夫弟子。若干众生成声闻乘。若干众生成辟支佛乘。若干众生皆成大乘。若干众生不成声闻乘。若干众生不成辟支佛乘。不成大乘。若干众生行灭者。若干众生不行灭者。若干众生上行。若干众生某佛弟子。诸佛又知是定受味。是定不受味。是善是无记。是定中断若干结。是定上中下。略说无色诸定。唯有诸佛以一切种智悉能分别大小深浅心相应不相应果报非果报等。是名诸佛具足悉知无色定处通达。灭法者。诸辟支佛诸阿罗汉。过去现在灭度者。诸佛通达如经中说。诸比丘是贤劫前九十一劫。毗婆尸佛出至三十一劫。有二佛出。一名尸弃。二名毗式婆。此贤劫中鸠楼孙迦那含牟尼迦叶佛出。如是过去诸佛大知见。经此中应说。及诸声闻弟子灭度入无余涅槃。及辟支佛。号曰成。号曰华相。号曰见法。号曰法箧。号曰喜见。号曰无垢。号曰无得。如是等诸辟支佛。入无余涅槃佛悉通达。复次未灭度在有余涅槃。生缘都尽通达是事。亦名通达知灭。如经说。佛告阿难。我于此人悉知无有微闇。是人毕定尽是内法。是人命终当入涅槃。亦名知灭。又于余人通达四谛能知其事。亦名知灭。如经说。我何不方便。令此人即于此处漏尽解脱。如佛告阿难。汝乐禅定乐断结使。亦名通达知灭。如佛告舍利弗。我知涅槃知至涅槃道。知至涅槃众生。如是等诸经。此中应说。是名诸佛通达知灭。善知心不相应非色法者。戒善根使善律仪不善律仪等诸心不相应非色法。声闻辟支佛不能通达。诸佛善能通达如现目前。于心不相应诸法中。成就第一智慧力故。问曰。戒善律仪不善律仪是色法。何以言非色法。答曰。戒善律仪不善律仪有二种。有作有无作。作是色。无作非色。无作非色。佛以不共力故现前能知。余人以比智知。问曰。诸佛但善知心不相应非色法。不善知相应法耶。答曰。若通达不相应法。相应法无所复论。如人能射毫毛。粗物则不论。复次七百不相应法中。声闻辟支佛以第六识能知七法。一名二相三义四无常五生六不生七度。佛以第六识皆悉能知。佛知四谛相及知世俗法。是故言诸佛善知心不相应无色法。势力波罗蜜者。于一切所知法无余中得一切种智势力十力四无所畏四功德处助成故。又善得十力故。是故佛能成就势力波罗蜜。是势力在第十六心中得增益。一切智常在佛身。乃至无余涅槃。因是事故。于一切法中得无碍智。无碍智波罗蜜者。法义辞乐说。于此四法势力无量通达无碍。如经中说。佛告诸比丘。如来四第子成就第一念力智慧力堪受力。如善射射树叶即过无难。是诸弟子以四念处来问难。我常不休息。除饮食便利睡眠。于百年中如来常答。乐说智慧无有穷尽。佛于此中以少欲相自论智慧。若三千大千世界所有四天下满中微尘。随尔所尘数作尔所三千大千世界。满中众生皆如舍利弗如辟支佛。皆悉成就智慧乐说。寿命如上尘数大劫。是诸人等因四念处尽其形寿问难如来。如来还以四念处义答其所问。言义不重乐说无尽。法无碍智者。善能分别诸法名字通达无碍。义无碍者。于诸法义通达无碍。辞无碍者。随众生类以诸言辞令其解义通达无碍。乐说无碍者。问答时善巧说法无有穷尽。余贤圣不能究尽。唯有诸佛能尽其边。是故名无碍智波罗蜜。具足答波罗蜜者。一切问难中。佛善能具足答。何以故。于四种问答中无有错乱。善知义故。具足不坏义波罗蜜故。乐欲深知一切众生性所行所乐故。如舍利弗白佛言。世尊。佛为人说善法。而是中多有众生得证。证已心无渴爱。无渴爱故于世间无所受。无所受已心则内灭。佛于善法中无上事尽知无余。更无胜者。问曰。汝言四种问答。何谓为四。答曰。一定答。二分别答。三反问答。四置答。定答者。如一比丘问佛。世尊。颇有色常不变异不。世尊。受想行识常不变异不。佛答言。比丘无有色常而不变。无有受想行识常而不变。如是等名为定答。分别答者。如布多梨子梵志问娑摩提。有人故作身口意业。受何等果报。娑摩提定答。有人以身口意故作业受苦恼报。是问应分别答。是梵志后来问佛是事。佛答言。布多梨子。有人若身口意故作业。是业或受苦报。或受乐报。或受不苦不乐报。苦业受苦报。乐业受乐报。不苦不乐业受不苦不乐报。如是等诸经皆分别答。反问答者。如先尼梵志问佛。佛言。我还问汝。随汝意答。先尼于汝意云何。色是如来不。受想行识是如来不。答言。非也世尊。离色受想行识是如来不。答言。非也世尊。如是等经应广说。是名反问答。置答者。十四种邪见是。所谓世间常世间无常。世间常无常。世间非常非无常。世间有边。世间无边。世间亦有边亦无边。世间非有边非无边。如来灭后有。如来灭后无。如来灭后亦有亦无。如来灭后非有非无。身即是神。身异神异。如上一切众生如大辟支佛智慧乐说以如是四种问佛。佛皆随顺答其所问。不多不少。是故说佛具足答波罗蜜。无有能害。佛者得不可杀法故。无能断佛身分支节存亡自在。如经说。若人欲方便害佛者。无有是处。问曰。佛寿命为定为不定。答曰。有人言不定。若佛寿命有定者。于余定寿命者有何差别。而实佛寿命不定。无能害者。乃为希有。有人言。佛寿命有定。余人寿命虽定。而手足耳鼻可断。佛无是事。问曰。云何佛不可害。是不共法。答曰。诸佛不可思议。假喻可知。假使一切十方世界众生皆有势力。设有一魔有尔所势力。复令十方一一众生力如恶魔。欲共害佛。尚不能动佛一毛。况有害者。问曰。若尔者调达云何得伤佛。答曰。此事先已答。佛欲示众生三毒相。调达虽持戒修善贪着利养而作大恶。又令知佛于诸人天心无有异。加以慈愍视调达罗睺罗如左右眼。佛常说等心。是时现其平等。天人见此起希有心益更信乐。又长寿天见佛先世有恶业行。若今不受谓恶行无报。佛欲断其邪见故现受此报。复次佛于苦乐心无有异。无吾我心。毕竟空故。诸根调柔不可变故。不须作方便离苦受乐。如菩萨藏中说。佛以方便故现受此事。应当广知。是名佛不可杀害不共法。说法不空者。诸佛所有言说皆有果报。是故诸佛说法不空。何以故。诸佛未说法时。先观众生本末心在何处结使厚薄。知其先世所从功德。见其根性势力多少。知其障碍方处时节。应软法可度苦事可度。或复应以软苦事度。或须小发度。或广分别度。有以阴入界十二因缘而得度者。或以信门或以慧门而得入者。是人应从佛度。是人应从声闻度。是人应以余缘得度。是人应成声闻乘。是人应成辟支佛乘。是人应成大乘。是人久习贪欲习嗔恚习愚痴。是人习贪欲嗔恚。是人习贪欲愚痴。如是各各分别。是人堕断见。是人堕常见。是人多着身见。是人多习边见。是人多习戒取见取。是人多习憍慢。是人多习自卑谄曲。是人心多疑悔。是人好乐言辞。有贵义理有乐深义有乐浅事。是人先世集助道法。是人今世集助道法。是人但集福报善根。是人但集贯穿善根。是人应疾得道。是人久乃得道。佛先观察筹量随应得度。而为说法而度脱之。是故一切说法皆悉不空。如经说。世尊先知见而说法。非不知见说法。无谬无失者。诸佛说法无谬无失。无谬者。语义不乖违故。无失者。不失义故。不失道因缘故名不失。不谬道果因缘故名不谬。不少故名不失。不过故名不谬。以通达四无碍智故。念安慧常调和故。远离断常无因邪因等诸见故。所说法中不使人有迷闷。所言初后无相违过。随此义经。应此中广说。如经说。诸比丘为汝说法。初善中善后善。语善义善淳一无杂具说梵行。以希有事说法者。随所教化即得道果。是名希有。若有所答若所受记皆实不异。是亦希有。佛有所说道。此道不杂烦恼能断烦恼。是亦希有。佛有所说皆有利益终不空言是亦希有。若人于佛法中勤心精进。能断不善法增益善法。是亦希有。复次有三希有。现神通希有。逆说彼心希有。有教化希有。以是三希有说法。名为以希有说法。诸众圣中最上导师者。诸佛知一切众生心所行所乐。结使深浅诸根利钝。上中下智慧。善知通达故。于众圣中最上导师。又能善知四谛相。善知诸法总相别相。又以说法不空因缘不谬不失法故。于众圣中最上导师。问曰。四众亦能说法破外道令入佛法。何以但称佛为最上导师。答曰。当以假喻说。若一切众生智慧势力皆如辟支佛。是诸众生若不承佛意。欲度一人无有是处。若是诸人说法时。乃至不能断无色界结使毫厘分。若佛欲度众生有所言说。乃至外道邪见诸龙夜叉等及余不解佛语者皆悉令解。是等亦能转化无量众生。乃至今日声闻众令众生住四果中。皆是如来最上导师相。是故佛名最上导师。于众圣中不共之法。四不守护法者。诸佛不守护身业。不护口业。不护意业。不护资生。何以故。是四事于他不护。不作是念。我身口意命恐他人知。何以故。长夜修习种种清净业故。皆善见知断一切烦恼法故。成就一切无比善根故。善行可行法无可呵故。具足行舍波罗蜜故。舍者。眼见色舍忧喜心。乃至意法亦如是。婆呵提郁多罗等诸经应此中说。四无所畏者。问曰。一法名为无畏。何以故有四。答曰。于四事中无有疑畏故有四。一者如佛告诸比丘。我自发诚言。是一切智人。此中若有沙门婆罗门诸天魔梵及余世间智人。如法难言。不知此法。我于此中乃至不见有微畏相。不见是相故。得安隐无畏。是初无畏。如实尽知一切法故。二者自发诚言。我一切诸漏尽。若沙门婆罗门诸天魔梵。言是漏不尽。乃至不见有是相。不见是相故安隐无畏。是二无畏。善断诸烦恼及断烦恼习气故。三者我说障道法。此中若有沙门婆罗门诸天魔梵及余世间智人。如法难言。是法虽用不能障道。我于此中不见有微畏相。不见是相故得安隐无有疑畏。是三无畏。善知障解脱法故。四者我所说道如法说行者。得至苦尽。若有沙门婆罗门诸天魔梵及余世间智人。如法难言。如是法虽如说行不能至尽苦道。我于此中无有微畏相。不见是相故得安隐无有疑畏。是四无畏。善知至苦尽道故。是四无畏皆过怖畏心惊毛竖等相故。名为无畏。又在大众威德殊胜故。名为无畏。又善知一切问答故。名为无畏。诸天会经此中应广说。问曰。若佛是一切智人。应于一切法尽无畏。何以但说四。答曰。略举大要以开事端。余亦如是。佛十力者。力名扶助。气势不可穷尽。无能沮坏。虽有十名而实一智。缘十事故名为十力。佛智缘一切事故。应有无量力。以此十力足度众生故。但说十力。但开此十力。余皆可知。初力者。一切法因非因。决定通达智。名为初力。如佛说。若是狂人不舍是语不舍邪见不舍是心。来在佛前无有是处。如佛告阿难。世间二佛一时出世无有是处。一佛出世则有是处。是事为一佛世界故说。而实十方无量无边诸世界中。百千万亿无数诸佛一时出世。又经说身口意恶业有妙爱果报无有是处。若身口意善业有妙爱果报则有是处。如是等五藏诸经应此中广说。第二力者。于过去未来现在诸业诸法受佛如实分别知处所知事知果报。佛若欲知一切众生过去诸业过去业报即能知。或业过去报在现在。或业过去报在未来。或业过去报在过去。或业过去报在过去未来。或业过去报在过去现在。或业过去报在未来现在。或业过去报在过去未来现在。或业现在报在现在。或业现在报在未来。或业现在报在现在未来。或业未来报在未来。有如是等分别受法者。四受法。现受乐后世受苦。现受苦后世受乐。现受乐后受乐。现受苦后受苦。处者。随业时方所在。又知是业受报处。事者。或随因缘。或随三不善根。或多自作。或多因他。如是等善恶业因缘佛尽知。报者。知诸业各各有报。善业或善处生或得涅槃。恶业诸恶处生。佛悉知是诸业本末因缘自身及他。是中智力不退故名为力。三力者。佛于禅定解脱三昧垢净相如实知。禅者四禅。定者四无色定四无量心等皆名为定。解脱者八解脱。三昧者除诸禅解脱余定尽名三昧。有人言。三解脱门及有觉有观定。无觉有观定。无觉无观定。名为三昧。有人言。定小三昧大。是故一切诸佛菩萨所得定。皆名三昧。是四处皆摄在一切禅波罗蜜。垢名受味。净名不受味。复次垢名有漏定。净名无漏定。三昧解脱等分别者。如是禅分别知他众生他人上下诸根。如实知名第四力。他众生者凡夫是。他人者须陀洹等诸贤圣是。或有人言。众生名为凡夫。及诸学人烦恼未尽故。他人者阿罗汉等烦恼尽故。或有人言。众生与人一种名有差别。诸根者。信精进念定慧非眼等根。上名猛利堪任得道。下名闇钝不堪受道。佛于此二根上下如实知不错谬。他众生他人心各有所乐如实知。是第五力。所乐名为贵所向事。如有人贵财物世乐或有贵重福德善法。是事佛如实知。世间种种性无量性。佛如实知。是第六力。种种性者杂性万端。无量性者。于一一性有无量种分别。性者从先世来心常习用常所乐行修习故成性。是二善恶性佛如实知。至一切处道如实知。是第七力。至一切处道者。能得一切功德。是道名为至一切处道。所谓五分三昧。若五知三昧。若八圣道分是。或圣道所摄诸法。或四如意足。如经说。比丘善修习四如意足无利不得。有人言四禅是。如经说。比丘得四禅。心安住一处清净。除诸烦恼灭诸障碍。调和堪用不复动转。若回向知宿命事。即能知宿命事。是第八力。佛若欲念自身及一切众生无量无边宿命。一切事皆悉知。无有不知过恒河沙等劫事。是人何处生。姓名贵贱饮食资生苦乐所作事业所受果报。心何所行本从何来。如是等事。以天眼清净过于人眼。见六道众生随业受身。是第九力。大力声闻以天眼见小千国土。亦见中众生生时死时。小辟支佛见千小千国土。见中众生生时死时。中力辟支佛见百万小千国土。见中众生生时死时。大力辟支佛见三千大千国土。见中众生生死所趣。诸佛世尊见无量无边不可思议世间。亦见是中众生生时死时。第十力者。欲漏有漏无明漏一切漏尽。诸烦恼及气都尽。是名第十力。无碍解脱者。解脱有三种。一者于烦恼障碍解脱。二者于定障碍解脱。三者于一切法障碍解脱。是中得慧解脱阿罗汉。得离烦恼障碍解脱。共解脱阿罗汉及辟支佛。得离烦恼障碍解脱。得离诸禅定障碍解脱。唯有诸佛具三解脱。所谓烦恼障碍解脱。诸禅定障碍解脱。一切法障碍解脱。总是三种解脱故。佛名无碍解脱。常随心共生。乃至无余涅槃则止。是四十不共法。略开佛法门令众生解故说。所不说者无量无边。所谓一常不离慧。二知时不失。三灭一切习气。四得定波罗蜜。五一切功德殊胜。六随所宜行波罗蜜。七无能见顶者。八无与等者。九无能胜者。十世间中上。十一不从他闻得道。十二不转法者。十三自言是佛终不能到佛前。十四不退法者。十五得大悲者。十六得大慈者。十七第一可信受者。十八第一名闻利养。十九与佛同止。诸师无与佛等者。二十诸师无有得第子众如佛者。二十一端正第一见者欢悦。二十二佛所使人无能害者。二十三佛欲度者无有伤害。二十四心初生时能断思惟结。二十五可度众生终不失时。二十六第十六智得阿耨多罗三藐三菩提。二十七世间第一福田。二十八放无量光明。二十九所行不同余人。三十百福德相。三十一无量无边善根。三十二入胎时。三十三生时。三十四得佛道时。三十五转法轮时。三十六舍长寿命时。三十七入涅槃时能动三千大千世界。三十八扰动无量无边诸魔宫殿令无威德皆使惊畏。三十九诸护世天王释提桓因夜摩天王兜率陀天王化乐天王自在天王梵天王净居诸天等。一时来集请转法轮。四十佛身坚固如那罗延。四十一未有结戒而初结戒。四十二有所施作势力胜人。四十三菩萨处胎母于一切男子无染着心。四十四力能救度一切众生。佛不共法有如是等无量无数。妨余事故不须广说。声闻法虽似佛法。优劣不同则有差别。复次总说诸佛一切诸法无量无边不可思议第一希有。一切众生所不能共。假使十方诸三千大千世界过诸算数是中所有众生智慧皆如大梵天王。皆如大辟支佛。皆如舍利弗。合集是诸智慧令一人得。欲及于佛四十不共法中微少分者。无有是处。若于一法百千万亿分中不及其一。诸佛有如是无量无边功德之力。何以故。无数大劫安住四功德处。深行六波罗蜜。善能具足菩萨一切所行诸法。不共一切众生故。果报亦不共

十住毗婆沙论卷第十一十住毗婆沙论卷第十二

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

    赞偈品第二十四

已如是解四十不共法竟。应取是四十不共法相念佛。又应以诸偈赞佛。如现在前对面共语。如是则成念佛三昧。如偈说

  圣主大精进　　四十独有法
  我今于佛前　　敬心以称赞
  如意及飞行　　其力无边限
  于圣如意中　　无有与等者
  声闻中自在　　他心智无量
  善能调伏心　　随意而应适
  其念如大海　　湛然在安隐
  世间无有法　　而能扰乱者
  诸佛所称叹　　金刚三昧宝
  得之在胸中　　如贤怀直心
  善知不定法　　四无色定事
  微细难分别　　尽知无有余
  众生若已灭　　今灭及当灭
  唯独有世尊　　智慧能通达
  善知不相应　　非色法中事
  一切诸世间　　悉皆不能知
  世尊大威力　　功德不可量
  智慧无边际　　皆无与等者
  于四问答中　　超绝无伦匹
  众生诸问难　　一切皆易答
  若诸世间中　　欲有害佛者
  是事皆不成　　以成不杀法
  若于三时中　　诸有所说者
  言必不虚设　　常有大果报
  凡有所说法　　无非是希有
  义趣尚不谬　　何况于言辞
  于三圣弟子　　上中下差别
  四双八辈等　　第一大导师
  身口意业命　　毕竟常清净
  是故于此中　　不复须防护
  自说一切智　　心无有疑畏
  若人来难我　　恐有所不知
  自说漏尽相　　尽到无漏边
  心无有疑畏　　余漏有不尽
  自说障碍法　　于中无疑难
  虽有用此法　　不能为障碍
  所说八圣道　　心无有疑畏
  有言是八道　　不能至解脱
  如实知是因　　是果及与非
  故号一切智　　名闻流无量
  三世所有业　　是诸业定报
  及非定果报　　种种皆悉知
  诸禅三昧中　　粗细深浅事
  皆悉能了知　　禅中无等者
  先知众生根　　上中下差别
  种种乐及性　　随宜而说法
  行道得诸利　　兼以化导人
  是以弟子众　　如实得善利
  宿命知无量　　天眼见无边
  一切人天中　　无能知其限
  住金刚三昧　　灭烦恼及气
  又知人漏尽　　故名漏尽力
  烦恼诸禅障　　一切法障碍
  三碍得解脱　　号无碍解脱
  四十不共法　　功德不可量
  无能广说者　　我已略说竟
  世尊若一劫　　称说此佛法
  犹尚不可尽　　况我无此智
  世尊大慈荫　　无量业善集
  四功德处故　　得佛无量法
  世尊所称说　　四功德胜处
  我今还以此　　称赞于如来
  三十二相具　　相有百福德
  八十种妙好　　三界谁能有
  三千大千界　　众生所有福
  果报为百倍　　相有如是德
  如此诸福德　　并及其果报
  复以为百倍　　成一白毫相
  三十相一一　　福德及果报
  复以为千倍　　成一肉髻相
  世尊诸功德　　不可得度量
  如人以尺寸　　量空不可尽
  从初发大心　　为度众生故
  坚心无量劫　　是故成佛道
  精勤欲成满　　如此之大愿
  无量劫数中　　行诸难苦行
  如诸往古佛　　说四功德处
  无量劫乃成　　今得安住中
  本为护实谛　　舍身及亲爱
  财宝诸富乐　　是故得具足
  无量劫数中　　见闻觉知法
  每先善思惟　　而后为人说
  若于不见等　　及于中有疑
  而能如实说　　所益无有量
  不说他匿事　　嫌讥而拒逆
  念常在安慧　　顺化令安隐
  第一真妙谛　　涅槃实为最
  余者皆虚妄　　世尊德具足
  饮食卧具等　　堂阁妙楼观
  名好象马车　　端严诸婇女
  金银珍宝等　　聚落诸城邑
  国土及荣位　　并以四天下
  爱子所亲妇　　支节及头目
  割肉出骨髓　　及以举身施
  怜愍诸众生　　悉施无所惜
  为求出生死　　不以求自乐
  虚空诸星宿　　地上所有沙
  世尊菩萨时　　布施数过是
  终不以非法　　求财而布施
  无有不知施　　无侵恼人施
  不贪惜好物　　而以恶者施
  无谄曲心施　　无惜而强施
  无恚无疑心　　无邪无轻笑
  无厌无不信　　[卑*頁]面等布施
  无有分别心　　此应彼不应
  但以悲心故　　平等而行施
  不轻于众生　　以为非福田
  见圣心恭敬　　破戒者怜愍
  不自高其身　　卑下于他人
  亦不为称赞　　不求报等施
  无悔无忧愁　　无恶贱心施
  无待急恨心　　无法应当施
  无不敬心施　　无弃着地施
  无求恼者施　　无垢竞胜施
  无戏弄求者　　无不自手施
  不轻于少物　　以多自高施
  不以声闻乘　　辟支佛乘施
  不限一世施　　无有非时施
  世尊无数劫　　行诸希有施
  皆为无上道　　不为求自乐
  于诸佛法中　　出家行远离
  修习诸佛法　　为诸人天说
  说如是施法　　于诸施中上
  犹如日光明　　星月中殊胜
  如是胜舍处　　超越诸天人
  犹亦如世尊　　一切世间上
  是故能具足　　如是胜舍处
  名闻无量劫　　流布无穷已
  世尊无量劫　　护持清净戒
  开诸禅定门　　为得深寂处
  先离于五相　　后行八解脱
  入净三三昧　　亦住三解脱
  世尊善分别　　六十五种禅
  无有一禅定　　先来不生者
  于此诸定中　　亦不受其味
  世尊因诸定　　得三种神通
  以此度众生　　是故一切胜
  世尊无量劫　　等心弘慈化
  阿僧祇众生　　令住于梵世
  能以巧方便　　善说禅定故
  世尊菩萨时　　常于无量世
  无贪烦恼缠　　而往来世间
  过去得值者　　无量生天上
  过去诸菩萨　　所可行寂灭
  世尊菩萨时　　亦等无有异
  是故于寂灭　　胜处悉充满
  世尊菩萨时　　所有诸智慧
  以慧求菩提　　今成是慧报
  一切所资食　　如人依地生
  世尊于世世　　舍十闇恶道
  常行十善道　　斯由慧气分
  舍五欲五盖　　得种种禅定
  无量劫数世　　不从他人受
  善哉大圣尊　　悉是慧势力
  众生因世尊　　无量生六天
  亦令至梵世　　斯皆由慧力
  世尊于生死　　苦乐所迷闷
  不失菩提心　　斯皆是慧力
  世尊于生死　　不乐而常在
  乐涅槃不取　　斯皆是慧力
  安坐道场时　　降魔及军众
  度脱诸群生　　斯皆是慧力
  本求菩提时　　集无量助法
  闻者常迷闷　　何况能受行
  世尊能堪忍　　斯皆是慧力
  经书诸技术　　世世生自知
  亦能兼教人　　斯皆是慧力
  亲近无量佛　　悉饮甘露教
  种种咨请问　　亦随而分别
  经法智慧中　　未曾有吝惜
  乃至仆僮奴　　亦咨受善语
  世尊以是故　　慧胜处流布
  世尊于前世　　求是菩提时
  于一切众生　　行大慈悲心
  以第一智慧　　常出大势力
  悉作无量种　　希有诸难事
  一切诸世间　　尽共无量劫
  说之不可尽　　亦非算数及
  如是等诸事　　超越于人天
  一切世间中　　奇特无有比
  大业所获果　　具足一切智
  能破生死王　　安住法王处

    助念佛三昧品第二十五

  菩萨应以此　　四十不共法
  念诸佛法身　　佛非色身故

是偈次第略解四十不共法六品中义。是故行者先念色身佛。次念法身佛。何以故。新发意菩萨。应以三十二相八十种好念佛。如先说。转深入得中势力。应以法身念佛心转深入得上势力。应以实相念佛而不贪着

  不染着色身　　法身亦不着
  善知一切法　　永寂如虚空

是菩萨得上势力。不以色身法身深贪着佛。何以故。信乐空法故。知诸法如虚空。虚空者无障碍故。障碍因缘者。诸须弥山由乾陀等十宝山。铁围山黑山石山等。如是无量障碍因缘。何以故。是人未得天眼故。念他方世界佛。则有诸山障碍。是故新发意菩萨。应以十号妙相念佛。如说

  新发意菩萨　　以十号妙相
  念佛无毁失　　犹如镜中像

十号妙相者。所谓如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。无毁失者。所观事空如虚空。于法无所失。何以故。诸法本来无生寂灭故。如是一切诸法皆亦如是。是人以缘名号增长禅法则能缘相。是人尔时即于禅法得相。所谓身得殊异快乐。当知得成般舟三昧。三昧成故得见诸佛。如镜中像者。若菩萨成此三昧已。如净明镜自见面像。如清澄水中见其身相。初时随先所念佛见其色像。见是像已后。若欲见他方诸佛随所念方得见诸佛无所障碍。是故此人

  虽未有神通　　飞行到于彼
  而能见诸佛　　闻法无障碍

是新发意菩萨于诸须弥山等诸山无能为作障碍。亦未得神通天眼天耳。未能飞行从此国至彼国。以是三昧力故。住此国土得见他方诸佛世尊。闻所说法常修习是三昧故。得见十方真实诸佛。问曰。如是定以何法能生。云何可得。答曰

  亲近善知识　　精进无懈退
  智慧甚坚牢　　信力不妄动

以是四法能生是三昧。亲近善知识者。能以是三昧教诲人者名为善知识。应加恭敬勤心亲近莫有懈怠废退舍离则得闻是深三昧义利智通达智不失智。名为坚牢信根深固。若沙门婆罗门若天魔梵及余世人无能倾动。名为信力不可动。如是四法。能生三昧。复次

  惭愧爱恭敬　　供养说法者
  犹如诸世尊　　能生是三昧

惭愧爱恭敬者。于说法者深生惭愧。恭恪爱乐供养如佛。如是四法能生是三昧。复次初四法者。一于三月未尝睡眠。唯除便利饮食坐起。二于三月乃至弹指不生我心。三于三月经行不息。四于三月兼以法施不求利养。是为四。复有四法。一能见佛。二安慰劝人听是三昧。三常不贪嫉行菩提心者。四能集菩萨所行道法。是为四。复有四法。一造作佛像乃至画像。二当善书写是三昧经。令信乐者得已诵读。三教增上慢人令离憎上慢法。使得阿耨多罗三藐三菩提。四当护持诸佛正法。是为四。复有四法。一少语言。二在家出家不与共住。三常系心取所缘相。四乐远离空闲静处。是为四。初五法者。一无生忍法。厌离一切诸有为法。不乐一切诸所生处。不受一切诸外道法。恶厌一切世间诸欲乃至不念何况身近。二心常修习无量诸法定在一处。于诸众生无有嗔碍。心常随顺行四摄法。三能成就慈悲喜舍不出他过。四能多集佛所说法如所说行。五清净身口意业及见。是为五。复有五法。一乐如经所赞布施无有悭心。乐说深法无所吝惜亦能自住。二忍辱柔和同住欢喜。恶口骂詈鞭捶缚等。但推业缘不恚他人。三常乐听是三昧读诵通利为人解说令流布增广勤行修习。四心无妒嫉。不自高身不下他人。除眠睡盖。五于佛法僧宝信心清净。于上中下坐深心供奉。他有小恩常忆不忘。常住真实语中。是为五复次

  出家诸菩萨　　所学三昧法
  在家菩萨者　　是法应当知

若在家菩萨欲修习是三昧一当深以信心。二不求业果报。三当舍一切内外物。四归命三宝。五净持五戒无有毁缺。六具足行十善道。亦令余人住此法中。七断除淫欲。八毁呰五欲。九不嫉妒。十于妻子中不生爱着。十一心常愿出家。十二常受齐戒。十三心乐住寺庙。十四具足惭愧。十五于净戒比丘起恭敬心。十六不悭吝法。十七于说法者深爱敬心。十八于说法者生父母大师想。十九于说法者以诸乐具敬心供养。二十知恩报恩。如是在家菩萨。住如是等功德者。则能学是三昧。出家菩萨修习是三昧法者。所谓一于戒无毁疵。二持戒不杂污。三持戒不浊。四清净戒。五无损戒。六不取戒。七不依戒。八不得戒。九不退戒。十持圣所赞戒。十一持智所称戒。十二随波罗提木叉戒。十三具足威仪行处。十四乃至微小罪心大怖畏。十五净身口意业。十六净命。十七所有戒尽受持。十八信乐甚深法。十九于无所得法心能忍。空无相无愿法中心不惊。二十勤发精进。二十一念常在前。二十二信心坚固。二十三具足惭愧。二十四不贪利养。二十五无嫉妒。二十六住头陀功德。二十七住细行法中。二十八不乐说世间俗语。二十九远离聚语。三十知报恩。三十一知作恩报恩者。三十二于和上阿阇梨所生恭敬忌难心。三十三破除憍慢。三十四降伏我心。三十五善知识难遇故勤心供给。三十六所从闻是法处。若得经卷若口诵处。于此人所生父母想善知识想大师想大惭愧爱敬想。三十七常乐阿练若。三十八不乐住城邑聚落。三十九不贪着檀越善知识家。四十不惜身命。四十一心常念死。四十二不存利养。四十三于诸物中心不染着。四十四无所渴爱。四十五守护正法。四十六不着衣钵。四十七不畜遗余。四十八但欲乞食。四十九次第乞食。五十常知惭愧心常有悔。五十一不畜金银珍宝钱财。离诸不善悔。五十二心无缠垢。五十三常行慈心。五十四除断嗔恚。五十五常行悲心。五十六除断爱着。五十七常求利安一切世间。五十八常怜愍一切众生。五十九常乐经行。六十除却睡眠。出家菩萨住如是等法中。应修习是三昧。复次

  余修三昧法　　亦应如是学

能生是般舟三昧。余助法亦应修习。何等是。一缘佛恩常念在前。二不令心散乱。三系心在前。四守护根门。五饮食知止足。六初夜后夜常修三昧。七离诸烦恼障。八生诸禅定。九禅中不受味。十散坏色相。十一得不净相。十二不贪五阴。十三不着十八界。十四不染十二入。十五不恃族姓。十六破憍慢。十七于一切法心常空寂。十八于诸众生生亲族想。十九不取戒。二十不分别定。二十一应勤多学。二十二以是多学而不憍慢。二十三于诸法无疑。二十四不违诸佛。二十五不逆法。二十六不坏僧。二十七常诣诸贤圣。二十八远离凡夫。二十九乐出世间论。三十修六和敬法。三十一常修习五解脱处。三十二除九嗔恼事。三十三断八懈怠法。三十四修八精进。三十五常观九相。三十六得大人八觉。三十七具足诸禅定三昧。三十八于此禅定无所贪无所得。三十九听法专心。四十坏五阴相。四十一不住事相。四十二深怖畏生死。四十三于五阴生怨贼想。四十四于诸入中。生空聚想。四十五于四大中生毒蛇想。四十六于涅槃中生寂灭想安隐乐想。四十七于五欲中生涎唾想。心乐出离。四十八不违佛教。四十九于一切众生无所诤讼。五十教化众生令安住一切功德。复次

  如是三昧报　　菩萨应当知

菩萨行是般舟三昧。果报亦应知。问曰。修习是三昧得何果报。答曰。于无上道得不退转报。复次如经所说果报。佛语颰陀婆罗菩萨。譬如有人能摧碎三千世界地皆如微尘。又三千大千世界中所有草木花叶一切诸物皆为微尘。颰陀婆罗。以一微尘为一佛世界。有尔所世界皆满中上妙珍宝以用布施。跋陀婆罗于意云何。是人以是布施因缘得福多不。甚多世尊。佛言。颰陀婆罗。我今实语汝。若有善男子。得闻诸佛现前三昧。不惊不畏其福无量。何况信受持读讽诵为人解说。何况定心修习。如一构牛乳顷。颰陀婆罗。我说此人福德尚无有量。何况能得成是三昧者。佛又告颰陀婆罗。若有善男子善女人。受持读诵为他人说。若劫尽时设堕此火火即寻灭。颰陀婆罗。持是三昧者。若有官事。若遇怨贼师子虎狼恶兽恶龙诸毒虫等。若夜叉罗刹鸠槃荼毗舍阇等。若人非人等。若害身若害命若毁戒。无有是处。若读诵为人说时亦无衰恼。唯除业报必应受者。复次颰陀婆罗。菩萨受持读诵是三昧时。若得眼耳鼻舌口齿病风寒冷病如是等种种余病。以是病故而失寿命无有是处唯除业报必应受者。复次颰陀婆罗。若人受持读诵是三昧者。诸天守护诸龙夜叉摩睺罗伽人非人四天王帝释梵天王诸佛世尊皆共护念。复次是人皆为诸天所共爱念乃至诸佛皆共爱念。复次是人皆为诸天所共称赞乃至诸佛皆共称赞。复次诸天皆欲见是菩萨来至其所。乃至诸佛皆欲见是菩萨来至其所。复次是菩萨受持是三昧者。所未闻经自然得闻。复次是菩萨得是三昧者。乃至梦中皆得如是诸利益事。颰陀婆罗。菩萨若我一劫若减一劫。说受持读诵是三昧者功德不可得尽。何况得成就者。颰陀婆罗。如人于百岁中身力轻健其疾如风。是人百岁行不休息。常至东方南西北方四维上下。于汝意云何。是人所诣十方有人能数知里数不。颰陀婆罗言。不可数也。唯除如来舍利弗阿惟越致余不能知。颰陀婆罗。若有善男子善女人以是人所行处满中真金布施。若有人但闻是三昧。以四种随喜回向阿耨多罗三藐三菩提。常求多闻。如过去诸佛行菩萨道时随喜是三昧。我亦如是。如今现在菩萨随喜是三昧。我亦如是。如未来诸佛行菩萨道时随喜是三昧。我亦如是。如过去未来现在菩萨所行三昧。我亦随喜皆为得多闻。我亦如是求多闻故。随喜是三昧。颰陀婆罗。是随喜福德。于上福德百分不及一。百千万亿分不及一。乃至算数譬喻所不能及。是三昧得如是无量无边果报。复次

  是三昧住处　　少中多差别
  如是种种相　　皆当须论义

是三昧所住处。少相中相多相。如是等应分别。知是事应当解释。住处者。是三昧或于初禅可得。或第二禅或第三禅或第四禅可得。或初禅中间得势力。能生是三昧。或少者人势力少故名为少。又少时住故名为少。又见少佛世界故。名为少。中多亦如是。说是三昧或说有觉有观。或无觉有观。或无觉无观。或喜相应。或乐相应。或不苦不乐相应。或有入出息。或无入出息。或定是善性。或有漏。或无漏。或欲界系。或色界系。或无色界系。或非欲界。或非色界。或非无色界系。是三昧是心数法。心相应。随心行法。共心生法。非色。非现。能缘。非业。业相应。随业行。非先世业果报。除因报。可修可知可证。亦以身证亦以慧证。或可断或不可断。有漏应断。无漏不可断。知见亦如是。不与七觉合。如是一切诸分别三昧义。皆应此中说。复次修习是三昧得见诸佛。如说

  得见诸佛已　　勤心而供养
  善根得增长　　能疾化众生

供养名心意清净。恭敬欢喜念佛有无量功德。以种种赞叹名口供养。敬礼华香等名身供养。是故福德转更增长。如谷子在地雨润生长。疾教化者令众生住三乘中。如是菩萨增长善根

  以初二摄法　　摄取诸众生
  后余二摄法　　未尽能信受

初二者布施爱语。利益同事名为后二。是菩萨在初地。不能具解故。但能信受

  尔时诸善根　　回向于佛道
  如彼成炼金　　调熟则堪用

智慧火所炼故。于菩萨所行事中。善根成熟则堪任用

    譬喻品第二十六

  是菩萨应闻　　地相得修果
  为得诸地分　　故勤行精进

相者是相貌。因以得知。得者成就。以是法故名成就是法。修名得修行修。常念果者。从因有事成名为果。是菩萨欲得十地行。应善闻相得修果。闻者从诸佛菩萨所闻。及胜己者。为得诸地分者。为得是地分故勤行精进。此中初地相者。如先说

  菩萨在初地　　多所能堪受
  不好于诤讼　　其心多喜悦
  常乐于清净　　悲心愍众生
  无有嗔恚心　　多行是七事

是故堪受不诤喜悦清净悲心无嗔等七法。是初地相。成就此堪受等七法名为得。复次堪受等七法相。即是初地得。如偈说

  若厚种善根　　善行于诸行
  善集诸资生　　善供养诸佛
  善知识所护　　具足于深心
  悲心念众生　　信解无上法
  具此八法已　　当自发愿言
  我已得自度　　当复度众生
  为得十力故　　入于必定聚
  则生如来家　　无有诸过咎
  即转世间道　　入出世上道
  以是得初地　　此地名欢喜

是故当知。为菩提故所得决定心。名为初地得修名。从初发心乃至成诸佛现前三昧。于其中间具说诸地功德。能生是诸功德。生已修集增长。名为初地。修果者。先已处处说得若干福德。不回向声闻辟支佛地。今当更说。菩萨得初地果。能得菩萨数百定等。初地分者。所有诸法合成初地。名为诸分。如麴米等合能成酒故。名酒因缘。所有诸法能成初地。名为初地分。所谓

  信力转增上　　成就大悲心
  慈愍众生类　　修善心无惓
  喜乐于妙法　　常近善知识
  惭愧及恭敬　　柔软和其心
  乐观法无著　　一心求多闻
  不贪于利养　　离奸欺谄诳
  不污诸佛家　　不毁戒欺佛
  深乐萨婆若　　不动如大山
  常乐修习行　　转上之妙法
  乐出世间法　　不乐世间法
  即治欢喜地　　难治而能治
  是故常一心　　勤行此诸法
  菩萨能成就　　如是上妙法
  是则为安住　　菩萨初地中

问曰。菩萨何用闻是初地相等为。答曰。是菩萨初地相等法中。应善知方便。是故应闻。问曰。菩萨但应于此法中。善知方便。更于余法中善知方便。答曰。是诸法中应善知方便。亦于余法善知方便。问曰。若尔者可略说。答曰

  有法能助地　　有法违于地
  有法能生地　　有法能坏地
  有诸地相果　　有诸地中得
  诸地清净分　　从地至一地
  住地转增益　　无能令退者
  从菩萨净地　　至无量佛地
  于此诸事中　　应善知方便
  请问诸善人　　除破于憍慢

助初地法者。所谓信戒闻舍精进念慧等。如是等及余诸法随顺初地者。是名助法。相违法者。不信破戒少闻悭贪懈怠乱念无慧等及余不随顺不能助初地者是。灭地法者。能令此地退失障碍不现。如劫尽时万物都灭。何者是所谓能偷夺菩提心法。是先已说。生地法者。能生能成初地。所谓不偷夺菩提心法。是先已说。地相得果地分上已说。清净法者。用是法能净初地。所谓如先说

初地中七法

  菩萨在初地　　多所能堪受
  不好于诤讼　　其心多喜悦
  常乐于清净　　悲心愍众生
  无有嗔恚心　　多行是七事

如是七法能净治初地。从一地至一地者。如从初地至二地从二地至三地。余亦如是。从初地至二地得不谄曲等十心故。从二地至三地得信乐等十心故。得如是等种种心种种法故。能从一地至一地。住地转增益者。如初地中檀波罗蜜多第二地中尸波罗蜜多又信等诸法转得势力。第三地中多闻多又布施持戒信等转得势力。余地中亦如是。无能令退者。住是地中。若沙门婆罗门若天魔梵及余世间无能转者。何以故。得大功德力故。深入法性底故。大信解故。从菩萨净地至无量佛地者。若菩萨具足清净一切地已则得佛地。于此诸事中皆应善知方便。请问诸善人者。成就正法故名为善人。正法者。略说一信。二精进。三念。四定。五慧。六身口意律仪。七无贪无恚无痴。除舍于憍慢者。自谓我于胜人中胜。名为大慢。于与己等中胜而心自高。名为憍慢。大不如他言小不如。名为小慢。问曰。汝说于是诸法中应善知方便。得是方便何用为。答曰

  菩萨若善知　　诸地中相得
  不得成佛道　　终不转初地

相名助诸地等七法。得名相违法有八种。灭等八法不应行。若菩萨善知是法不得佛道终不退转

十住毗婆沙论卷第十二十住毗婆沙论卷第十三

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

    譬喻品余

问曰。菩萨善知是诸法。未得佛道终不退者。其喻云何。答曰

  如大力导师　　善知好道相
  此处与彼处　　转道之所宜
  资粮及行具　　皆悉令备足
  于彼险道中　　令众得安隐
  得至大城邑　　能令众无患
  由是大导师　　善能知道故
  善知诸地转　　具足助道法
  菩萨善知道　　好恶此彼处
  自度生死险　　兼导多众生
  令至安隐处　　无为涅槃城
  悉令于恶道　　不遇众苦患
  菩萨方便力　　善能知道故

好道相者。多有薪草水。无有寇贼师子狼虎及诸恶兽毒虫之属。不寒不热。无有恶山沟坑绝涧险隘深榛丛林隈障。亦无高下平直夷通少于岐道。宽博多容多人行处。行无厌惓多有华果可食之物。如是等事名为好道相。与此相违名为恶道相。此处名人众止宿食息之处。彼处名从是处至异处。若二宿中间亦名异处。转道名见有岐道。至大城者。是道应行余者应舍。资粮名糗蜜抟等道路所食。大力名大势力多有财物善解治法。备足名多有饮食无所乏少。安名无有贼寇恐怖之事。隐名无有疾病苦痛衰患。大城名多容人众能令多人众得至大城。导师善解道相自无患难。亦令人众无有患难。善谙道故。无有寒热饥渴怨贼恶兽毒虫恶山恶水深坑坎等如是过患。何以故。善知道路好恶相故。以此喻欢喜等十地。如人行路去不休息能至大城。菩萨如是行是十地。得至佛法入涅槃大城。如彼好道多有薪草水等。行者无乏。草名如人乘马路多好草马力强盛。十地道功德亦如是。谛舍灭慧四胜处。助诸功德故名为草。何以故。若人贵于实事乐随谛语。当亲近实语者。见实有利乐随实事。深恶妄语远离妄语。见妄语过不欲乐闻。如是等因缘得谛胜处。舍等三处亦应如是知。如彼好道须诸象马牛驴等得至大城草助成其力。如是谛舍灭慧处。能令至佛法入涅槃大城。薪名多闻思修慧能至大智慧业。如薪能令火然亦令猛盛。如是闻思修慧能生大慧能令增长。如火能烧能煮能照智慧火亦如是。烧诸烦恼成熟诸善根照四圣谛。如火是智慧薪是能生智慧等诸法。多水名多有诸流河渠随意取用充足大众。泉井及池所不能尔

复次多水者。如人乘船随水至大城。井泉陂池水则不能得尔。如经说。信为大河福德为岸。如河除热除渴除垢能生势力。善法中信亦如是。能灭三毒热。除三恶行垢。除三有渴。为涅槃故。于善法中得势力。如彼好道多有诸根药草则行者无乏。十地道亦如是。根名深心所爱。如有根故则生芽茎枝叶等及诸果实。深心爱道。生正忆念大愿等诸功德。药草名诸波罗蜜。如药草能灭诸毒诸波罗蜜药草灭贪恚痴毒诸烦恼病亦复如是。如彼好道不失韦婆陀。则行道安隐。韦陀秦言无对义。是符檄。如行者不失符檄则在所欲至无有障碍。十地道亦如是。不失韦婆陀则在所过诸地所集善根则能随意助成。增长现在善根。彼又能教化声闻道辟支佛道欲界色界诸天道众生。令住佛道。若魔若外道不能干乱。是名不失韦婆陀。如彼好道无有蚊虻毒虫之属。十地道亦如是无有忧愁啼哭之声。如彼好道无有贼难。十地道亦如是无有五盖诸恶贼众。如佛告比丘。聚落贼者。所谓五盖。如贼先夺人物后乃害命。五盖贼亦如是。先夺善根后断慧命。则堕放逸而死。如道中无师子虎狼诸恶兽等。十地道亦如是无有嗔恚斗诤。如师子等恶兽好恼害他嗔恚等为恼他故生亦复如是。如恶兽等啖肉饮血。嗔恨等食多闻慧肉饮修慧等血亦复如是。如彼好道无有寒热过恶。十地道亦如是不堕寒冰地狱故无有寒过恶。不堕热地狱故无有热过恶。如彼好道无深坑等诸难。十地道亦如是无有外道苦行等诸难。所谓灰身入冰拔发日三洗翘一足。日一食二日一食。乃至一月一食默然至死。常举一臂常行忍辱。五热炙身卧刺蕀上。入火入水自投高岩。深炉中立牛屎烧身。直趣一方不避诸难。常着湿衣裳。水中卧等。身苦心苦不至正智。无如是等故名为无难。如道无邪径。十地道亦如是无身口意恶业故名为无邪径。如道无刺蕀者。十地道亦如是无诸业障刺蕀故名为无刺蕀。如刺刺脚则废行路。业障刺蕀障行佛法入涅槃。如道正直。十地道亦如是无一切谄曲欺诳故名为正直。如道少岐道。十地道亦如是少于异道。何以故。发大乘者少行声闻辟支佛道。是故少于异道。或有菩萨行二乘道者。当知未到菩萨地。未入正位。行于边行故。如彼好道无诸丛林妨碍。十住道亦如是无有五欲诸恶丛林。问曰。何故不言都无五欲丛林但言无恶林耶。答曰。发大乘者。福德因缘有第一五欲。是故不得言无。但无恶耳。复次如深丛林。难入难过多诸难碍。菩萨五欲则不然。不如凡夫于五欲生诸过恶。如是故但说无丛林。如道宽博多容不相妨碍。十住道亦如是多所容受。无量百千万亿众生共发无上道心而不相妨碍。是百千万亿众生若一切众生俱发阿耨多罗三藐三菩提心。同行此道不相妨碍。如道多人所行。十住道亦如是恒河沙等过去现在诸佛。行菩萨道时皆行此道。如彼好道行不疲厌。十住道亦如是多有因果诸乐。所谓多生人天中受果报。乐离欲故受欢喜乐禅定乐无喜乐现在乐。得是诸乐故无有疲厌。如道多有华果根。十住道亦如是多根华果。根者三善根。华者七觉华是。如经说。七华者七觉意是。果者四沙门果是。无如是等违好道功德过故。名为离恶。如导师知道中是中应食是应宿彼处亦应宿。菩萨行十地亦如是知何处可宿何处可食。可宿名有诸现在佛处。可食名可得修习善法处。如食能利益诸根亦助寿命。诸善法亦如是。能益信等诸根助成慧命。异处宿名从彼佛所至余佛所。复次此佛国土彼佛国土中间亦名异处。善知道转者。如彼导师知道不安隐则转。菩萨亦如是。善知是道至声闻。是道至辟支佛。是道至佛。如是知已。舍声闻道辟支佛道。但行至佛道。如彼好道多有饮食。十住道亦如是多行布施持戒修禅。如彼导师以多财物善能治法有大势力。菩萨亦如是有财物治法故有大势力。财者七财。所谓信戒惭愧舍闻慧。治法者。一切魔种种沙门婆罗门外道论师悉能摧伏。是为威势。如彼大城无有怨贼疫病暴死种种衰恼故。名为安隐。涅槃大城亦如是。无有诸魔外道诸流贪欲嗔恚放逸死忧悲苦恼啼哭故。名为安隐。如彼大城多有饮食故名为丰饶。涅槃城亦如是。多有诸深禅定解脱三昧故。名为丰饶。如彼大城多所容受故名为大城。涅槃城亦如是。多受众生故名为大。假令一切众生不受诸法故。皆入无余涅槃。而涅槃性无增无减。如彼导师能将多众安隐示好道故。名为导师。菩萨亦如是。善将众生示佛法示涅槃。从生死险道得至涅槃故。名为大导师。如彼导师善知道相故。身及余人皆无有恶。菩萨亦如是。自不行贪嗔恚等诸盖诸恶苦行老死深坑。亦不堕寒热地狱饿鬼故。名为自不得恶所随从者亦不得恶。是故偈中说善知道相故。自不得恶余不得恶

    略行品第二十七

  菩萨欢喜地　　今已略说竟
  菩萨住是中　　多作阎浮王
  常离悭贪垢　　不失三宝念
  心常愿作佛　　救护诸众生

初地名欢喜。已略说竟。诸佛法无量无边是地为本。若广说亦无量无边。是故言略说。菩萨住是地中。多作阎浮提势力转轮王。先世修习是地因缘故。信乐布施无悭贪垢。常施三宝故不失三宝念。常念作佛救诸众生。如是等善念常在心中。复次

  若欲得出家　　勤心行精进
  能得数百定　　得见数百佛
  能动百世界　　飞行亦如是
  若欲放光明　　能照百世界
  化数百种人　　能住寿百劫
  能择数百法　　能变作百身
  能化百菩萨　　示现为眷属
  利根过是数　　依佛神力故
  已说初地相　　果力净治法
  今当复更说　　第二无垢地

果名得数百定见数百佛等。势力名能化数百众生。余偈义先已说。不复解余偈。今当复说第二无垢地。问曰。汝欲广说菩萨所行法。初地义尚多。诸学者恐转增广则懈怠心生不能读诵。是故汝今应为不能多读诵者。略解菩萨所行诸法。答曰

  菩萨所有法　　是法皆应行
  一切恶应舍　　是则名略说

如上来诸品所说。能生能增长诸地法。如上诸品中说。若于余处说者。皆应令生菩萨过恶事皆应远离。是名略说菩萨所应行。如法句中说。诸恶莫作诸善奉行自净其意是诸佛教。有一法摄佛道。菩萨应行。云何为一。所谓于善法中一心不放逸。如佛告阿难。我不放逸故。得阿耨多罗三藐三菩提。如说

  不放逸成佛　　世间无与等
  若能不放逸　　何事而不成

复有二法能摄佛道。一不放逸。二智慧。如说

  不放逸智慧　　佛说是利门
  不见不放逸　　而事不成者

复有三法能摄佛道。一学胜戒。二学胜心。三学胜慧。如说

  戒生上三昧　　三昧生智慧
  智散诸烦恼　　如风吹浮云

复有四法能摄佛道。一谛处。二舍处。三灭处。四慧处。如说

  谛舍定具足　　得慧利清净
  精进求佛道　　当集此四法

复有五法能摄佛道。一信根。二精进根。三念根。四定根。五慧根。如说

  信根精进根　　念定慧坚牢
  是法大悲合　　终不退佛道
  如人得五根　　能通达五尘
  如得信等根　　能通诸法相

复有六法能摄佛道。所谓布施持戒忍辱精进禅定智慧波罗蜜。如说

  如所说六度　　降伏诸烦恼
  常增长善根　　不久当得佛

复有七法能摄佛道。所谓七正法。信惭愧闻精进念慧。如说

  欲得七正法　　当乐定精进
  除去七邪法　　能知诸功德
  是人能疾得　　无上佛菩提
  拔没生死者　　令在安隐处

复有八法能摄佛道。所谓八大人觉。少欲知足远离精进念定慧乐不戏论。如说

  若人决定心　　住八大人觉
  为求佛道故　　除诸恶觉观
  如是则不久　　疾得无上道
  如人行善者　　必当得妙果

复有九法能摄佛道。所谓大忍大慈大悲慧念坚心不贪不恚不痴。如说

  具足于大忍　　大慈及大悲
  又能住于慧　　念及坚心中
  深心入无贪　　无恚痴善根
  若能如是者　　佛道则在手

复有十法能摄佛道。所谓十善道。自不杀生不教他杀见杀心不称赞见杀心不喜。乃至邪见亦如是。以是福德回向阿耨多罗三藐三菩提。如说

  不恼害众生　　亦不行劫盗
  不淫犯他妇　　是三为身业
  不妄语两舌　　不恶口绮语
  不贪恼邪见　　是七口意行
  如是则能开　　无上佛道门
  若欲得佛者　　当行是初门

如是等法菩萨应生。生已应守护。守护已应增长。于一善事从一转增。亦应当知。求佛道者。于一恶法应疾远离。所谓远离不放逸。如说

  若人不能度　　生死险恶道
  是为可呵责　　最是罪恶事
  虽乐于富乐　　而生贫贱家
  不能种善根　　为人作奴仆
  皆由于放逸　　因缘之所致
  是故有智者　　疾远如恶毒
  若未成大悲　　无生忍不退
  而行放逸者　　是则名为死

复有二过应疾远离。一贪声闻地。二贪辟支地。如佛说

  若堕声闻地　　及辟支佛地
  是名菩萨死　　亦名一切失
  虽堕于地狱　　不应生怖畏
  若堕于二乘　　菩萨应大畏
  虽堕于地狱　　不永遮佛道
  若堕于二乘　　毕竟遮佛道
  佛说爱命者　　斩首则大畏
  如是欲作佛　　二乘应大畏

复有三过应疾远离。一憎诸菩萨。二憎菩萨所行。三憎甚深大乘经。如说

  小智以小缘　　憎恚诸菩萨
  亦憎菩萨道　　亦憎大乘经
  不解故不信　　堕在大地狱
  怖畏大惊唤　　是事应远离

复有四过应疾远离。一谄。二曲。三急性。四无慈愍。如说

  自言是菩萨　　其心多谄曲
  急性无所容　　不行慈愍心
  是近阿鼻狱　　离佛道甚远

复有五过应疾远离。一贪欲。二嗔恚。三睡眠。四调戏。五疑。是名五盖覆心。如说

  若人放逸者　　诸盖则覆心
  生天犹尚难　　何况于得果
  若勤行精进　　则能裂诸盖
  若能裂诸盖　　随愿悉皆得

复有六过与六波罗蜜相违。应疾远离。一悭贪。二破戒。三嗔恚。四懈怠。五调戏。六愚痴。如说

  悭贪垢污心　　破戒而懈怠
  无知如牛羊　　好嗔如毒蛇
  心乱如猕猴　　不远离诸盖
  生天为甚难　　何况得佛道

复有七过应疾远离。一乐多事务。二乐多读诵。三乐睡眠。四乐语说。五贪利养。六常欲令人喜。七迷闷于道心随爱行。如说

  弊人乐事务　　乐多诵外经
  痴人乐睡眠　　乐共聚众语
  虽愿欲作佛　　而深着利养
  是恩爱奴仆　　迷闷于佛道
  如是诸恶人　　自言是菩萨

复有八法应疾远离。一邪见。二邪思惟。三邪语。四邪业。五邪命。六邪方便。七邪念。八邪定。如说

  若有人愚痴　　行于八邪道
  学邪诸经法　　好随逐邪师
  远离八圣道　　深妙诸功德
  坚深着烦恼　　而或愿菩提
  如是愚痴人　　欲度于大海
  舍好坚牢船　　抱石欲求渡

复有九法应疾远离。一不闻阿耨多罗三藐三菩提。二闻已不信。三若信不受。四若受不诵持。五若又诵持不知义趣。六若知不说。七若说不如说行。八若如说行不能常行。九若能常行不能善行。如说

  痴人不欲闻　　无上正真道
  闻已不能信　　又不能诵持
  不知义不说　　不如所说行
  不能常善行　　又无念安慧
  如是愚痴人　　不堪得道果
  犹如罪恶人　　不得生天上

复有十过应疾远离。所谓十不善道。如说

  痴人于少时　　贪爱弊五欲
  舍离十善道　　行十不善道
  诸天乐在手　　而复自舍弃
  如贪小钱利　　而舍大宝藏

问曰。汝说无上道相时。种种因缘诃骂空发愿菩萨自言菩萨但名字菩萨。若是三不名为菩萨者。成就何法名为真菩萨。答曰

  非但发空愿　　自言是菩萨
  名字为菩萨　　略说能成就
  三十二法者　　乃名为菩萨

若人发心欲求佛道。自言是菩萨。空受名号不行功德慈悲心诸波罗蜜等。是不名为菩萨。如土城名宝城。但自诳身亦诳诸佛。亦诳世间众生。若人有三十二妙法亦能发愿是名真实菩萨。何等三十二。一深心为一切众生求诸安乐。二能入诸佛智中。三自审知堪任作佛不作佛。四不憎恶他。五道心坚固。六不假伪结托亲爱。七乃至未入涅槃常为众生作亲友。八亲疏同心。九已许善事心不退转。十于一切众生不断大慈。十一于一切众生不断大悲。十二常求正法心无疲懈。十三勤发精进心无厌足。十四多闻而解义。十五常省己过。十六不讥彼阙。十七于一切见闻事中常修菩提心。十八施不求报。十九持戒不求一切生处。二十于一切众生忍辱无嗔碍。二十一能勤精进修习一切善根。二十二不随无色定生。二十三方便所摄智慧。二十四四摄法所摄方便。二十五持戒毁戒慈愍无二。二十六一心听法。二十七一心阿练若处住。二十八不乐世间种种杂事。二十九不贪着小乘。三十见大乘利益为大。三十一远离恶知识。三十二亲近善知识。菩萨住是三十二法。能成七法。所谓四无量心。能游戏五神通。常依于智。常不舍善恶众生。所言决定言必皆实。集一切善法心无厌足。是为三十二法。为七法。菩萨成就此者。名为真实菩萨

    分别二地业道品第一

  诸菩萨已得　　具足于初地
  欲得第二地　　当生十种心

诸菩萨已得欢喜初地。为得二地故生十种心。因是十心能得第二地。如人欲上楼观要因梯而上。问曰。何等是十心得第二地方便。答曰

  直心堪用心　　软伏寂灭心
  真妙不杂贪　　快大心为十

诸菩萨已具足于初地。欲得第二地。生是十方便心。一直心。二堪用心。三柔软心。四降伏心。五寂灭心。六真妙心。七不杂心。八不贪心。九广快心。十大心。直心者。离谄曲。离谄曲故心转柔软。柔软者。不刚强粗恶。菩萨得是柔软心。生种种禅定。亦修习诸善法。观诸法实相。心则堪用。心堪用故生伏心。伏心者。善能降伏眼等诸根。如经中说。何等是善道。所谓比丘降伏眼根乃至意根。以降伏六根故。名为伏心。心已降伏则易生寂灭心。寂灭心者。能灭贪欲嗔恚愚痴等诸烦恼。先伏心已遮令寂灭。复有人言。得诸禅定是名寂灭心。如经说。若人善知禅定相不贪其味。是名寂灭心。得寂灭心已。必生真妙心。真妙心者。于诸禅定神通所愿事中如意得用。譬如真金随意所用。行者既得直心乃至真妙心已。为守护是心故。乐生不杂心。不杂心者。不与在家出家从事。是人作是念。我得如是等心。皆由禅定力故。以是诸心当得第二地等无量利益。若与众人杂者则失此利。何以故。若人与众人杂行。则眼等六根或时还发诸不善法。何以故。亲近可染可嗔可痴法故。诸根发动烦恼火然。烦恼火然故则失此利。见此等过故生不杂心。不应与在家出家者杂行。是人得是不杂心已。次生不贪心。不贪心者。于在家出家人中所谓父母兄弟和上师长等不生贪着。作是念。若我于在家出家生贪著者。必当来往问讯。我则何有不杂心耶。是故我欲令诸禅定等利住不杂心者。当于在家出家舍贪着心。问曰。菩萨法不应舍众生。不应生舍心。如助菩提中说

  菩萨初精进　　所有方便力
  应令诸众生　　住于大乘中
  若人教恒沙　　众生住罗汉
  不如教一人　　住大乘为胜
  若人少势力　　不堪发大乘
  次当教令住　　辟支声闻乘
  若人不堪住　　辟支声闻乘
  应教此众生　　令行福因缘
  不任住三乘　　不堪人天乐
  常以今世事　　随而利益之
  若有诸众生　　不受菩萨利
  于此不应舍　　应生大慈悲

汝云何言菩萨得不杂心生不贪心。若菩萨不贪众生则为舍离。何能度耶。答曰。应随顺菩萨道行舍心。何以故。是人因舍心生广快心。作是念。我若舍是众闹。当得禅定因禅定生妙广快法。得是法已其后则能利益众生。胜今千万倍。是故为多利益众生少时舍心权舍众闹。当得禅定五神通等利益众生。菩萨何故作如是方便。菩萨为得大心而作是念。大人乐大利益故不存小利。是故我今当求大人之法随而修学。应如是勤加精进为大利益。所谓诸禅定神通灭苦解脱等。是故汝说非也。问曰。初地中已有直心等法。何故复说菩萨欲得二地生于十心。答曰。初地虽有此法未得深乐。未有坚固。在此地中心常喜乐转深坚固堪任施用。是故汝难非也。问曰。若深乐坚固此法者得何异事。答曰

  若其一时得　　深乐坚固心
  更不复用功　　如使常随逐

如使一时生常随逐人。菩萨如是一时得深乐坚固心已即常随逐。更不须用功而生若以少因缘便生。何以故。根深入故茎节相续。问曰。若菩萨得是十种心得何等果。答曰

  若得是诸心　　正住第二地
  具三种离垢　　恶业及烦恼

若菩萨得是直等十心。即名住第二菩萨地。一离垢者。地名也。二离垢者。于此地中离十不善道罪业之垢。三离垢者。离贪欲嗔恚等诸烦恼垢故。名为离垢。复次离垢义者

十住毗婆沙论卷第十三十住毗婆沙论卷第十四

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

    分别二地业道品之余

  菩萨住此地　　自然不行恶
  深乐善法故　　自然行善道

问曰。十不善道自然不作。自然行十善道。此二种道。几是身行。几是口行。几是意行。答曰

  身意二三种　　口四善亦尔
  略说则如是　　此应当分别

不善身行有三种。所谓夺他命劫盗邪淫。不善口行四种妄语两舌恶口散乱语。不善意行三种。贪取嗔恼邪见。善身行亦有三种。离夺命劫盗邪淫。善口行亦四种。离妄语两舌恶口散乱语。善意行有三种。不贪取不嗔恼正见。身口意业道。是善不善应须论议令人得解。初夺命不善道者。所谓有他众生知是众生故行恼害。因是恼害则失寿命。起此身业是名初夺命不善道。离此事故。名为离夺命善行。劫盗者。所谓属他之物。知是物属他生劫盗心。手捉此物举离此处。若劫若盗计是我物生我所心。是名劫盗行。离此事者名为离劫盗善行。邪淫者。所有女人。若为父母所护。亲族所护。为姓所护。世法所护。戒法所护。若他人妇知有鞭杖恼害等障碍。于此事中生贪欲心起于身业。或于自所有妻妾。若受戒若怀妊若乳儿若非道。是名邪淫。远离此事名为善身行。妄语者。覆相覆心覆见覆忍覆欲知如是相而更异说。是名妄语。远离此事名为远离妄语善行。两舌者。欲离别他。以此事向彼说。以彼事向此说。为离别他故。和合者令别离。别离者则随顺乐为别离。喜别离好别离。是名两舌。离如此事名为远离两舌善行。恶口者。世间所有恶语害语苦语粗语弊语令他嗔恼是名恶口。远离此事名为离恶口善行。散乱语者。非时语无利益语非法语无本末语无因缘语。是名散乱语。远离此事名为离散乱善行。贪取者。属他之物他所欲。他田坞他财物。心贪取愿欲得。于此事中不贪不妒不愿欲得是名不贪善行。嗔恼者。于他众生嗔恨心碍心发嗔恚。作是念。何不打缚杀害是名嗔恼离如此事名为无嗔恼善行。邪见者。言无布施无有恩报。善恶业无果报。无今世无后世。无父母无沙门无婆罗门。能知此世后世。了了通达自身作证。是名邪见。正见者。为有施者有恩报。有善恶业报有今世后世。世间有沙门婆罗门。知此世后世了了通达自身作证。是名正见善行。是菩萨如是入正见道

  善道不善道　　各二十分别
  知何处起等　　十二种分别

菩萨于十不善道十善道等种种别相知二十种分别。又于是二十种分别善知从何处起等十二种分别。于此十不善道中有二十种分别。所谓不离夺他命罪。一是不善。二欲界系。三有漏。四非心数法。五心不相应。六不随心行。七或共心生或不共心生。何等共心生。实有众生知是众生。以身业故夺其命。是名共心生。云何名不共心生。若人欲杀众生捉持牵挽扑着地已然后能死。是名不共心生。又身不动口不言。但生心我从今日当作杀众生者。如是夺他命罪。是名不共心生。又是不离夺他命者。若睡若觉常积习增长。亦名不共心生。八或色或非色。初共心生杀罪是色。第二杀罪第三第四非是色。九或作或非作。有色是作。余者无作。十或有缘或无缘。色是有缘余者是无缘。问曰。是心为有缘为无缘。答曰。非有缘。问曰。若心非有缘身不动口不言时但心生念我从今日当作杀众生者。如是罪业云何名为非缘。答曰。若杀罪是心则应有缘。今实杀罪非是心。若心是杀罪即是身业。而心实非身业。是故杀生罪不名有缘。但杀生罪共心在身中生。以是无作故言非缘。十一是业。十二非业相应。十三不随业行。十四或共业生或不共业生。如共心生无异。但除心与思共生为异。十五非先世业报。十六不可修。十七应善知。十八应以慧证不以身证。十九可断。二十可知见。不离劫盗罪。不离邪淫罪。不离妄语罪中。但一共心生二不共心生。一有色二无色。一作二无作。一有缘二无缘。余如杀中说。不离两舌不离恶口亦如是。不离散乱语。或不善或无记从不善心生。是不善从无记心生。是无记或欲界系。或色界系。欲界系者。以欲界身心。散乱语是欲界系。色界系亦如是。余如妄语中说。贪取欲界系。是有漏心数法。非心相应。非随心行。心共生。无色无作。有缘。非业相应。非随业行。非共业生。非先世业报。除因报。非可修。应善知。应以慧证。身证。可断。可见知。嗔恼。或心相应。或心不相应。缠所摄名心相应。使所摄名心不相应。随心行不随心行亦如是。共心生不共心生。有觉众生与心共生。无觉众生不与心共生。如心相应。随心行共心生业相应。随业行共业生亦如是。如心不相应不随心行不共心生业不相应不随业行不与业共生亦如是。余分别如贪取中说。如嗔恼邪见亦如是。十善道中离夺他命是善性。或欲界系。或不系三界。欲界系者以欲界身离夺他命。是欲界系。非三界系者。学无学人八圣道所摄。离杀生正业。是或有漏或无漏。欲界系是有漏。非三界系是无漏。非心数法。非心相应。非随心行。或共心生或不共心生。何等是共心生。如行人见虫而作是念。我当身业远离不伤害。是名离夺命善行共心生。何等是离杀生善不共心生。有人身不动口不言但心念从今日不杀生。是名不共心生。又有人先远离杀生。若睡若觉心缘余事。于念念中不杀生。福常得增长。亦不共心生。或是色或非色。一是色二非色。一是作二非作。一有缘二无缘。是业非业相应。不随业行。或共业生或不共业生。如共心生不共心生除心与思为异。非先业报。除因报。可修可善知可以身证。慧证或可断或不可断有漏则可断。无漏不可断。可知见亦如是。离劫盗。离邪淫。离妄语。离两舌。离恶口亦如是。离散乱语。或欲界系。或色界系。或不系三界。欲界系者。以欲界身心离散乱语。色界系亦如是。不系三界者。如不杀中说。或有漏或无漏。有漏者系。无漏者不系。余如离妄语中说。不贪取者是善性。或欲界系。或非系三界。欲界系者。欲界凡夫不贪取及贤圣不贪取善行。是欲界系。非三界系者。诸贤圣不贪取无漏善行。是或有漏或无漏。欲界系是有漏。不系三界是无漏。是心数法。心相应。随心行。共心生。无色无作。有缘。非业。业相应。随业行。共业生。非先业报。除因报。可修。可善知。可以身证。慧证。或可断。或不可断。有漏可断。无漏不可断。知见亦如是。离嗔恼是善性。或欲界系。或色界系。或无色界系。或不系三界。欲界系者。欲界不嗔恼善根。余二界亦如是。不系者。余不系是或有漏或无漏系三界者。是有漏。余是无漏。心数法。或心相应。或心不相应。与缠相违不嗔善根与心相应。与使相违不嗔善根与心不相应。随心行共心生亦如是。无色无作。或有缘或无缘。心相应是有缘。心不相应是无缘。非业或与业相应。或不与业相应。或随业行或不随业行。或共业生。或不共业生。亦如心说非业。报除因报。可以身证慧证。或可断或不可断。有漏可断。无漏不可断。可知见亦如是。正见是善性。或欲界系。或色界系。或无色界系。或非三界系。欲界系者。若凡夫若贤圣。欲界念相应正见。是色无色界亦如是。不系三界者。贤圣无漏正见。或有漏或无漏。三界系是有漏。不系是无漏。心数法。心相应。随心行。共心生。无色无作。有缘。非业。业相应。随业行。共业生。非先业报。除因报。可以身证。慧证。或可断。或不可断。有漏可断。无漏不可断。可见可知亦如是。是名善等二十种分别。从何起等十二论者。一从何起。二起谁。三从何因起。四与谁作因。五何缘。六与谁作缘。七何所缘。八与谁作缘。九何增上。十与谁作增上。十一何失。十二何果杀罪。从何起者。从三不善根起。又从邪念起。又随以何心夺众生命。从是心起。起谁者。从杀罪边所有诸法。已生今生当生。是因缘亦如是。何所缘者。缘众生。又因何心夺众生命。亦缘此心。与谁作缘者。因杀罪边所有诸法。若已生若今生若当生。是法缘于杀生罪。何失者。今世恶名人所不信等。何果者。堕地狱畜生饿鬼阿修罗等及余恶处。受苦恼报。增上与谁增上者。如从何处起中说。劫盗邪淫妄语两舌恶口散乱语贪取嗔恼邪见亦如是。但所缘有异。劫盗罪缘所用物。邪淫缘众生。妄语两舌恶口散乱语缘于名字。贪取缘所用物。嗔恼缘众生。邪见缘名字。余残亦如上。不杀生从三善根起。又从正念起。又随以何心离杀生。从是心起。起谁者。从是法所有诸法。若已生若今生若当生。是因缘亦如是。所缘者。缘于众生。与谁作缘者。因是不杀生边所有诸法。若已生若今生若当生。缘于不杀生。增上者。诸善根增上。正念亦增上。随以何心不杀生。是心亦增上。与谁作增上者。于是不杀生边所有诸法。若已生若今生若当生。何利益者。与杀罪相违是名为利。何果者。与杀生相违名为果。不劫盗邪淫妄语两舌恶口散乱语不贪不恚正见亦如是。但所缘有异。不劫盗缘所用物。不邪淫缘众生。不妄语不两舌不恶口不散乱语缘名字。不贪取缘所用物。不嗔恼缘众生。正见或缘名字或缘义。有漏缘于名字。无漏缘于义。是菩萨于善等论及起等十二论。行十善道。应如是分别知。又知

  七种不善处　　以贪嗔痴生
  及四门分别　　业众生各二

是菩萨知七不善业道以贪嗔痴生。而分别于世。又知七种不善业中四门分别。是杀罪或从贪生。或从嗔生。或从痴生。从贪生者。若人见众生。生贪着心。从是因缘。受用好色声香味触。或须齿角毛皮筋肉骨髓等。是人生如是贪心故夺他命。是名从贪生杀罪。若人嗔心不喜杀众生。是名从嗔生。若人邪见不知后世善恶业杀众生。是名从痴生杀罪。或以为福德故。或使欲度苦故而杀。如西方安息国等。复有取福德因缘故杀。以是杀业因缘故。欲得生天。如东天竺人于天寺中杀生。以此事故欲生天上。是名从痴生。复有人以贪心故取他物。作是念。以我当随意得好色声香味触。是名从贪生。复有人以嗔心不喜彼人故劫盗财物。欲令其恼。是名从嗔生。复有人邪见不知果报。劫盗他物。是名从痴生。如诸婆罗门说世间财宝皆是我物。我力弱故诸小人等以非法取用。若我取者。自取其物无有过罪。以如是心劫盗他物者。是亦从痴生。若人贪着色因缘故而邪淫。是名从贪生。若人嗔不喜作是念。是人犯我母妇姊妹女等。我亦还以淫事污彼母妇姊妹女等。是名从嗔生邪淫。若人邪见不知果报而故犯者。是名从痴生。如有人言。人中无有邪淫。何以故。女人皆为男子故生。如余所用物。如有所须。若与从事无邪淫罪。以是心作淫欲者。是名从痴生。如劫盗罪妄语亦如是。为贪财故妄语。是名从贪生。为欲诳彼令得苦恼。是名从嗔生。邪见不知业果报故妄语。是名从痴生。两舌恶口散乱语亦如是。三不善道则是根本。从是分别生七种身口业果。问曰。不离杀生皆是杀生罪不。若杀生罪皆是不离杀生耶。答曰。有不离杀生即是杀生罪。有不离杀生非杀生罪。何等是不离杀生即是杀生罪。若有众生知是众生故杀夺命起身业。是名不离杀生亦是杀生罪。何等是不离杀生非杀生罪。此人先虽作杀因缘而众生不死又身不动口不说。但心念我从今日当杀众生。是名不离杀生非杀生罪。是二门分别。为四种分别。所谓善不善各二种

  不但善不善　　身心二种业
  亦复应当知　　更有余分别

除身杀生劫盗邪淫。余残打缚闭系鞭杖牵挽等。但不死而已。如是不善身业非夺命等所摄。善中迎送合掌礼拜恭敬问讯洗浴按摩布施等善身业非不杀生等所摄。意业中除贪取嗔恼邪见余所有不守摄心诸结使等不善法。又意业中除不贪取不嗔恼正见余善守摄心信戒闻定舍慧等善法

  七业亦业道　　三业道非业

杀生劫盗邪淫妄语两舌恶口散乱语七。是业即业道。贪取嗔恼邪见。是业道非业。此三事相应思是业。问曰。前七事何故亦是业亦是业道。答曰。习行是七事转增故。至地狱畜生饿鬼。以是故名为业道。是七能作故名业。三是业道非业者。是不善业根本。以是故名三业道非业。善中亦如是。所谓离杀生劫盗邪淫妄语两舌恶口散乱语亦业亦业道。余三不贪取不嗔恼正见是业道非业。此三相应思是业。问曰。前七事何故是业亦业道。答曰。常修习此事故。能至人天好处名为道。是七能作故名为业。问曰。余三何故但业道非业耶。答曰。三是诸善业根本。诸善业从中行故。名为业道非业。复次

  戒法即是业　　业或戒非戒
  业及于业道　　有四种分别

身口业是戒。意业是业非戒。业及于业道四种分别者。有业非业道。有业道非业。有业亦是业道。有非业非业道。业非业道者。三种不善身业。业道所不摄。所谓手拳鞭杖等。及三种善身业。业道所不摄。所谓迎逆敬礼等。是二善不善业。非业道所摄。或有人言。亦是业道。何以故。是二业或时至善恶处故。名为业道。以不定故不说业道。业道非业者。后三不善及三善是烦恼性故非业。能起业故名为业道。三善是善根性故非业。能起善业故名为业道。亦业亦业道者。所谓杀生不杀生等七事。是非业非业道者余法是。复次

  菩萨初地边　　以三种清净
  安住十善道　　则生决定心

是菩萨于第二地中了了分别知如是十善十不善道。知已以三种清净住十善道。所谓自不杀生不教他杀。于杀生罪心不喜悦。乃至正见亦如是。问曰。菩萨初地中已住十善道。此中何故重说。答曰。初地中。非不住十善道。但此中转胜增长。以三种清净故。先初住中虽作阎浮提王不能行此三种清净。是故此中说三种清净。菩萨住是二地。知如是分别诸业。生决定心

  世所有恶道　　皆十不善生
  世所有善道　　因于十善生

世间所有恶道者。所谓三种地狱道。热地狱冷地狱。黑地狱。三种畜生道。水行畜生。陆行畜生。空行畜生。种种鬼道。有饥饿鬼者食不净鬼者火口者阿修罗夜叉等。皆由行十不善道。有上中下因缘故。出世间所有善道若天若人。皆由行十善道生。三界所摄。天有二十八。人者四天下人是。如是决定知已。作是念。我欲自生善处。亦令众生生于善处

  是故我自应　　住于十善道
  亦令余众生　　即住此善道

若生善处若生恶处。皆属十善十不善道。我知是世间诸业因缘有无有定主。是故我应先自行十善道。然后令诸众生亦住十善道。问曰。何以故。要先自住十善道后乃令他住耶。答曰

  行于恶业者　　令他善不易
  自不行善故　　他则不信受

若恶人自不行善。欲令他行善者则为甚难。何以故。是人自不行善。他人不信受其语。如偈说

  若人自不善　　不能令他善
  若自不寂灭　　不能令他寂
  以是故汝当　　先自行善寂
  然后教他人　　令行善寂灭

是菩萨当如是行善法

  从阿鼻地狱　　乃至于有顶
  分别十业果　　及其受报处

当如是正知。下从阿鼻地狱。上至非有想非无想处。皆是善不善种种业受果报处。于中习行上十不善道故生阿鼻地狱。小减生大炙地狱。小减生小炙地狱。小减生大叫唤地狱。小减生小叫唤地狱。小减生僧伽陀地狱。小减生大陌地狱。小减生黑绳地狱。小减生活地狱。小减生剑林等小眷属地狱中。亦应如是转小分别。行中十不善道生畜生中。畜生中亦应转少分别。行下不善道生饿鬼中。如是总相说。是中应广分别差别。有诸阿修罗夜叉生鬼道中。有诸龙王生畜生中。所受快乐或与诸天同。是诸众生以不善因缘故生。生已受善业果报。行最下十善道生阎浮提人中在贫穷下贱家。所谓栴陀罗边地工巧小人等。转胜生居士家。转胜生婆罗门家。转胜生刹利家。转胜生大臣家。转胜生国王家。于十善道转复胜者生瞿陀尼。转胜生弗婆提。转胜生郁单越。转胜生四天王处。转胜生忉利天炎摩天兜率陀天化乐天。习行上十善道生他化自在天。于是中亦应种种分别小大差别。如人中小王大王阎浮提王转轮圣王。四天王处有四天王。忉利天中有释提桓因。炎摩天上有须炎摩天王。兜率陀天上有珊兜率陀天王。化乐天上有善化天王。他化自在天上有他化自在天王。过是以上。要行禅定思得生上界。问曰。若以禅定思得生上界者。何以故。说乃至非有想非无想处皆以十善道故得生。答曰。虽修禅定生色界无色界。要当先坚住十善道然后得修禅定。以是故。彼处以十善业道为大利益。以是故。说乃至非有想非无想处皆以十善道因缘故得生。所以者何。先行清净十善道离欲。修初禅下思得生梵众天。修初禅中思生梵辅天。修初禅上思故得生大梵天。修二禅下思生少光天。修二禅中思得生无量光天。修二禅上思得生妙光天。修三禅下思得生小净天。修三禅中思故得生无量净天。修三禅上思得生遍净天。修四禅下思故生阿那婆伽天。修四禅中思故生福生天。修四禅上思故生广果天修无想定中思得生无想天。以无漏熏修四禅下思故生不广天。以无漏熏修四禅胜思故生不热天。以无漏熏修四禅胜思故生喜见天。以无漏熏修四禅胜思故生妙见天。以无漏熏修四禅最上思故生阿迦腻吒天。修虚空处定相应思得生空处天。修识处定相应思得生识处天。修无所有处定相应思得生无所有处天。修非有想非无想处定相应思得生非有想非无想处天。是名生死世间众生往来之处

    分别声闻辟支佛品第二

问曰。是十善业道。但是生人天因缘。更有余利益耶。答曰有

  所有声闻乘　　辟支佛大乘
  皆以十善道　　而为大利益

凡出生死因缘唯有三乘。声闻辟支佛大乘。是三乘皆以十善道为大利益。何以故。是十善道能令行者至声闻地。亦能令至辟支佛地。亦能令人至于佛地。问曰。是十善道。能令何等众生至声闻地。答曰

  随他无大悲　　畏怖于三界
  乐少功德分　　其志甚劣弱
  心乐于厌离　　常观世无常
  及知一切法　　皆亦无有我
  乃至一念顷　　不乐于受生
  常不信世间　　而有安隐法
  观大如毒蛇　　阴如拔刃贼
  六入如空聚　　不乐世富乐
  贵于坚持戒　　而为禅定故
  常乐于安禅　　修习诸善法
  唯观于涅槃　　第一救护者
  常求尽苦慧　　乐集行解脱
  但贵于自利　　一一胜处来
  善道令是人　　能至声闻地

随他音声者。闻他所说随顺而行。不能自生智慧。问曰。十善道能令一切从他闻者皆作声闻耶。答曰。不尔。若无大悲心十善道能令此人至声闻地。若有菩萨从诸佛闻法。以有大悲心故十善道不能令至声闻地。问曰。一切无大悲心者。十善道皆能令至声闻地耶。答曰。不然。怖畏三界者十善道能令此人至声闻道。余不怖畏者令生人天善处。以乐三界故。问曰。一切怖畏三界者。十善道皆能令至声闻地。若尔者菩萨亦怖畏三界为身故。复为众生勤行精进求于涅槃。如是十善道。亦应令至声闻地。答曰。不必一切怖畏三界者尽堕声闻地。何等为堕。乐习行功德少分者。于佛所教化六波罗蜜中受行少分。如是之人堕声闻地。若人能取诸佛功德遍学智慧十善道必令此人径至佛道。随他闻声怖畏三界取功德少分。是人有二种十善道。能令至声闻地者。至辟支佛地者。问曰。是人云何俱从他闻怖畏三界取功德少分十善道能令至声闻地至辟支佛地。答曰。志劣弱者作阿罗汉。小坚固者作辟支佛。问曰。十善道令一切志劣弱者至声闻地。答曰。不然。何以故。所谓志弱乐厌离生死者。非但志劣无厌离者。问曰。观何事得知乐厌离心。答曰。观有为法无常一切法无我。当知是必乐于厌离。问曰。已知乐厌离。菩萨亦如是观有为无常一切法无我。是十善道何得不令此人堕声闻地耶。答曰。是人深厌离离大悲故。乃至一念中不乐受生。不信世间有安隐相。如经中佛告诸比丘。譬如少粪尚臭秽不净。何况多也。如是一念中受生尚苦。何况多也。诸比丘。当学断生莫令更受。声闻人信受是语故。乃至一念中不乐受生。是人复作是念。世间无常。于所作事及受命都无安隐相。死常逐人谁能知死时节。不知死时为受何业果报。为生何心。如是事中不安隐故。不可信故。当疾求尽苦。菩萨则不尔。于恒河沙无量阿僧祇劫受生。为得阿耨多罗三藐三菩提度诸众生。是故偈中说。乃至一念顷不乐于受生。善道令是人能至声闻地。问曰。是人乐修集何事故不乐受生。答曰。是人观地水火风四大喜生嗔恨故。不净臭秽不知恩故。生毒蛇想。色受想行识五阴。能夺智慧命故。生怨贼想。眼耳鼻舌身意。入离常离不动不变不坏无我无我所故。生空聚想。若人于世间一切受生及资生乐具。以无常虚诳无须臾住故不生喜悦心。如是之人于一切生处生无安隐想。但涅槃一法能为救护。如经中说。诸比丘世间皆是炽然。所谓眼然色然眼识然眼触然。及眼触因缘生受皆亦是然。以何事故然。所谓贪欲火嗔恚火愚痴火。生老病死忧悲苦恼火之所炽然。耳鼻舌身意亦如是。观一切有为法皆是炽然。唯涅槃寂灭法能为救护。贵涅槃一法故舍一切事勤习坐禅。问曰。若观一切有为法皆是炽然。唯涅槃寂灭能为救护者。十善道皆令至声闻地耶。答曰。不然。佛所结戒。为禅定故贵重此戒。有决定心而不毁犯。舍一切事但乐坐禅。求尽苦智常勤修习解脱因缘。于先世中或从一胜处来二胜处来者。十善道能令此人至声闻地。何以故。持戒清净则心不悔。心不悔故得欢喜。得欢喜故身轻软。身轻软故心快乐。心快乐故摄心得定。摄心得定故。生如实智慧。生如实智慧故即生厌。从厌生离从离得解脱。若一若二胜处来者。如尊者罗睺罗从谛胜处来。如尊者施曰罗从舍胜处来。如尊者离跋多从寂灭胜处来。如尊者舍利弗从慧胜处来。或从谛舍二胜处来。或从谛寂灭二胜处来。或从谛慧二胜处来。或从舍寂灭二胜处来。或从舍慧二胜处来。或从寂灭慧二胜处来。如是十善道。能令至声闻地

十住毗婆沙论卷第十四十住毗婆沙论卷第十五

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

    分别声闻辟支佛品之余

问曰。十善道令何等人至辟支佛地。答曰

  于声闻所行　　十善道转胜
  深禅不随他　　常喜于远离
  恒乐善修习　　甚深因缘法
  远离方便力　　及以大悲心
  少欲及少事　　恶贱愦闹语
  常乐远离处　　威德深重人
  喜为福田地　　常观于出性
  成办有理事　　恭敬于诸主
  已成就系心　　知心在所缘
  常乐于禅定　　中人之势力
  乐于出家法　　善心不缩没
  得慧光明者　　或从二胜处
  或三胜处来　　十善之业道
  能令如是人　　至于缘觉地

于声闻所行十善道转胜者。过声闻人所行十善道。而不及菩萨所行。作是念。声闻人应随他闻而行道然后得自证智慧。我则不然。不乐随他人。以是故。我应令十善道转胜。以是因缘故。我乐不随他十善道。令我至辟支佛地。如是思惟已常乐于远离。作是念。若我常乐愦闹则为集诸恶不善法。以近可染可嗔可痴事故。于是远离中应修习甚深因缘法。复作是念。若我不修习甚深因缘法者则不得不随他智。我今何故不常修习甚深因缘。然后可得不随他智。甚深者。难得其底不可通达。一切凡夫从无始生死中所有经书及其技艺皆可得其边底。唯甚深因缘不可得底。如兔等小虫不能得大海边底。若人有方便大悲心及修集甚深因缘即得阿耨多罗三藐三菩提。若离此二事修集甚深因缘智则成辟支佛。方便名于成就教化众生中种种思惟而不错谬。亦于甚深法不取相大悲名深。怜愍众生。胜声闻辟支佛。何况凡夫。少欲少事恶贱愦闹语。如是则得辟支佛地。若大欲大事好聚众人。为方便大悲所护者。阿耨多罗三藐三菩提则为易得。何以故。求辟支佛人少欲者作是念但自度身。少事者但自成就善根不及余人。是人舍离教化众生事故不亲近众闹。菩萨大欲大事作是念。我应度一切众生。以此大欲因缘故则为大事教化众生。教化众生此非小事。若憎恶愦闹语则不成此事。是故菩萨入愦闹中亦用愦闹之语但无所著。复次覆真实功德故是为少欲。少事务故名为少事。恶贱愦闹名少欲。乐独处故名为少事。如是之人少欲少事。不乐众闹语。乐于亲近远离可畏深邃之处其心深大。是人作是念。若我住远离可畏深邃之处人则不来。以远离处住故。心亦深远。若人自不深远喜戏调者。外人往来则不为难。如是人不与众生和合。虽舍众生亦欲令众生种诸善根为大利益作是念。我云何不与众生和合亦能利益众生。如是思惟知已。我当为众生作福田之利受其供养。如是虽不与众生和合。而能作大利益。是人复思惟。我云何当得福田地。即自见知。若我深乐为福田地。常观出性。然后福田地法自然而来。乃至出性之法亦自然而来。所谓持戒禅定智慧等。复作是念。我当云何疾至福田地及出性法。我当为正观者于诸现有理趣事中皆悉成办供养恭敬诸主。如是福田地及出性法不久疾得。何以故。我当成办有理之事正观诸法能得不随他智。又供养恭敬诸主故令善根增厚。善根增厚故智慧深厚。智慧深厚故能通达实事。能通达实事故能生厌。从厌则生离。从离得解脱。得解脱故前后所集善根得为福田。然后得证出性之法。诸主者诸佛世尊。是种诸善根时是最大因缘。是人复思惟。我云何能疾成有理趣事。是人即自知见。若我集系心一处知其所缘。常乐禅定。是人能系心一处则能得三昧。得三昧故有理事皆能成办。如经中说。得禅定能如实知如实见。若人已行系心则疾入三昧。疾入三昧故名禅定者常定者。若能如是修集诸法则为供养恭敬诸佛。若人以香华四事供养佛不名供养佛。若能一心不放逸亲近修集圣道是名供养恭敬诸佛。如经说。般涅槃时佛告阿难。天雨文陀罗华及栴檀末香作天伎乐。不名供养恭敬如来也。阿难。若比丘比丘尼优婆塞优婆夷一心不放逸亲近修集圣法。是名真供养佛。是故阿难。汝当修学真供养佛。如是众功德。皆是中势力人乐出家善心不缩没者。最上势力能得成佛。下势力者作声闻。以是故中势力人作辟支佛。乐出家故能成众功德。何以故。若在居家则不能少欲少事。不能身心远离。亦不能禅定。若心缩没不清净者。不能成办众事。不能知甚深因缘法。不能证出性。不能如法真供养恭敬诸佛。如是众生是中势力。作是念。我中势力人。常乐出家心不缩没。诸所愿功德事皆自然来。复作是思惟。是中势力乐为得何果。即知当得智慧果。何以故。智慧能为照明。如经中说。诸比丘一切光明中智慧光为胜。复作是念。我所乐慧光云何当得。即知若从二胜处来。若三胜处来。二胜处者先已说。三胜处者。所谓谛舍寂灭。或谛舍慧。或谛寂灭慧。以是故我当修集如是诸胜处。我修集是已得智慧光明。所愿智慧自然而至。如是相如是修集助道法者。十善道能令至辟支佛地

    大乘品第三

问曰。如仁已说。十善道能令人至声闻辟支佛地。十善业道。复令何等众生至于佛地。答曰

  所行十善道　　胜于二种人
  无量希有修　　胜一切世间
  发坚善二愿　　成大悲无碍
  善受行方便　　忍辱诸苦恼
  不舍诸众生　　深爱诸佛慧
  于佛力自在　　乐尽遍行者
  能破邪见意　　受护佛正法
  健堪受精进　　坚心化众生
  不贪着自乐　　及无量身命
  一切事中上　　所作无过咎
  一切种清净　　一切胜处来
  善道令此人　　至十力世尊

所修十善道胜二种人者。菩萨修十善道。于求声闻辟支佛者为转胜。转胜者。一心修行常修行。为自利故修行。为他利故修行。清净修行。一心行者用意修行。常修行者不中休息。为自利故修行者。生天人因缘泥洹因缘。为他利修行者。菩萨修行十善道。回向利安一切众生故。以是因缘故。能度过算数众生。清净修行者。不坏行无杂行。不浊行自在行。具足行不贪着行。智者所赞行。坏者有行有不行。与此相违名不坏行。杂者自不作令他作。与此相违名不杂行。浊者与烦恼罪业合行。与此相违名为不浊行。自在者。破戒人为田业妻子财物所系不得自在。持戒者无如是事。随意自在无所系属。具足者。尽行一切大小戒。遮止诸烦恼。常忆念守护。为禅定作因缘。回向佛道能令同真际法性。是名具足。不贪著者。不向世间不取戒相自高卑他。智者所赞者。声闻法中不随生死。但为涅槃故名智者所赞。此大乘法中。尚不回向声闻辟支佛乘。何况生死。但向阿耨多罗三藐三菩提。是名智者所赞十善道。问曰。修有何相名为善修。答曰。以无量希有修十善道。胜一切世间。是名善修。问曰。云何菩萨。以此修胜一切世间。答曰。诸菩萨以五事修故。胜一切世间。一愿二坚心三深心四善清净五方便。愿者菩萨所行愿。一切凡夫人及声闻辟支佛人所无。以是故。菩萨所行愿胜一切世间。如大智经毗摩罗达多女问中。佛因目揵连说。菩萨从初发愿乃至道场。能为一切世间天及人作福田。又胜一切声闻辟支佛。又如净毗尼中。摩诃迦叶于佛前说。世尊善说希有。所谓菩萨初一发愿胜一切声闻辟支佛。又如偈中说

  菩萨初发心　　与大慈悲合
  为于无上道　　即是心为胜
  是故以此愿　　住于世间上

坚心者。菩萨于诸苦恼所谓活地狱。黑绳地狱。合会地狱。小叫唤地狱。大叫唤地狱。小炙地狱。大炙地狱。阿鼻地狱。沸屎。剑林。灰河。阿浮陀。尼罗浮陀。阿波簸。阿罗逻。休休。郁钵罗。拘勿陀。须曼那。分陀利。钵头摩。寒热地狱中种种拷掠。如是苦恼。畜生饿鬼阿修罗人天。共相食啖互相恐怖。饥饿谷贵。从天退失。悭妒嗔恼。恩爱别离。怨憎合会。生老病死忧悲恼等。此六道中。所有诸苦若见若闻若受。修十善道。为阿耨多罗三藐三菩提时心终不坏。以是故此菩萨以坚心修十善道。胜一切世间。如说

  地狱及畜生　　饿鬼阿修罗
  天人六趣苦　　不能动其心
  是故诸菩萨　　以此坚固心
  所修十善道　　胜一切世间

深心者。大心用心爱心念心。诸菩萨以如是等心修十善道。胜一切世间。除诸佛世尊及久行菩萨。如说

  深心及用心　　利益世间心
  菩萨以是心　　胜一切世间

善清净者。菩萨修十善业道三种清净。余人所无。以是故。胜一切世间。如说

  菩萨人中宝　　具深心净心
  以是善法力　　世间所不及

方便者。菩萨以方便力修于善法。余人所无。是故胜一切世间。无量修者。菩萨以五因缘故名无量修。一时无量。二善根无量。三缘无量。四究竟无量。五回向无量。时无量者。谓菩萨修行善业道过于时量。时量过故。所修善业道亦无量。是故胜一切世间。如说

  诸菩萨师子　　所修善业道
  过诸算数时　　故修善最胜

善根无量者。诸菩萨修无量无边善根。从是善根所修善业道亦无量。是故胜一切世间。如大乘法中净毗尼经。佛告迦叶。譬如生酥满四大海。菩萨有为善根资粮亦如是。是福德回向无为智则大利益一切众生。是故菩萨虽处有为能胜一切世间。如说

  为一切众生　　及求佛道故
  善根则无量　　以是胜世间

缘无量者。菩萨不缘有量众生故修集善根。而所修善根不言为利益若干众生。菩萨但缘一切众生故修集善根。是故菩萨缘无量众生所修善业道亦无量。胜一切世间。如净毗尼经中。佛告诸天子。如大菩萨薄有慈悲心求利益他。是心能令无量众生得利乐。深发心菩萨。勤行精进亦如是。能教化无量阿僧祇众生令得涅槃乐。如说

  菩萨无量善　　功德自庄严
  皆为度众生　　无量之大苦

究竟无量者。初地中为发愿故。已说十究竟。是究竟无量故。菩萨所修善业道亦无量。是故胜一切世间。如说

  菩萨修善道　　从十究竟生
  是故胜一切　　无有能坏者

回向无量者。如初地中说。菩萨回向果报无量。以是回向果报无量。所修善业亦无量。是故胜一切世间。如说

  以无量因缘　　修于善业道
  回向佛乘故　　是以为最上

希有者。诸菩萨修善道。以五因缘故名希有。一堪受故。二精进故。三心坚故。四慧故。五果故。堪受者。我当作天人中尊一切智慧者。能如是堪受。是为希有。若人以指举三千大千世界。于虚空中令住百千万劫。是事可成。不足为难。若发愿言我当作佛。是为希有甚难。如说

  为无量佛法　　立誓当作佛
  是人无有比　　何况有胜者

精进者。多有人堪受发阿耨多罗三藐三菩提心。不能精进行六波罗蜜。若人以堪受发阿耨多罗三藐三菩提心。能精进行六波罗蜜。是名实堪受无量功德。精进希有故。所修善业道亦希有。如说

  希有大精进　　凡人念已怖
  菩萨实行之　　何得不希有

心坚者。有人发精进心修集佛道。若有障碍心不坚固则不能成。是故发精进安住希有。坚心中则成其事。坏诸障碍。是为菩萨修善业道第一希有。如说

  若人无坚心　　尚不成小事
  何况成佛道　　世间无上者

慧者。是堪受精进坚心皆以慧为根本。是故菩萨慧为第一希有。能生如是堪受精进坚心故。以慧为希有以慧为希有故。所修善业亦希有。如说

  如有人堪受　　欲得于佛法
  精进得坚心　　皆以慧为本

果者。修善业故得无量无边诸佛之法。是故希有。如说

  行此善得道　　无量功德力
  为诸众生师　　谁闻而不行

坚愿者。菩萨以五因缘故名为坚愿。一于声闻乘心不转。二于辟支佛乘不转。三于外道事不转。四于一切魔事不转。五无因缘不转。如说

  闻二乘解脱　　何不为此道
  若未入于位　　则失菩萨道
  又贪外道事　　或为魔所坏
  或复无因缘　　自舍菩萨道

善愿者。菩萨以五因缘故名善愿。一先筹量得失者。二知道者。三知道果者。四不贪惜自乐者。五欲灭众生大苦者。如是作愿名为善愿。如说

  先见世过患　　佛道大利益
  知行无上道　　及其无量果
  舍自寂灭乐　　欲除众生苦
  发是无比愿　　为诸佛所赞

大悲无碍者。以五因缘故。知菩萨有大悲。一利安无量众生故。于资生之物不生贪惜。二不惜身。三不惜命。四不观时久远。五欲怨亲中等心利益。如说

  内外所爱物　　于中不贪着
  为利众生故　　及舍于身命
  生死无量劫　　犹如一眴顷
  怨亲中平等　　名菩萨大悲

无碍者。菩萨以五因缘故。悲心有碍。一以地狱苦故。二以畜生苦故。三以饿鬼苦故。四以恶人无返复故。五以生死过恶故。若此五事不障其心是名无碍大悲。如说

  第一地狱苦　　畜生饿鬼苦
  恶人及生死　　不障名大悲
  菩萨能如是　　佛说无碍悲

善受行方便者。菩萨以五因缘故。名善受行方便。一知方时。二知他心所乐。三知转入道。四知事次第。五知引导众生

知方时者知是方处。应以如是说法。知是时中。应以如是说法知是方处。应以如是因缘度众生。知是时中应以如是因缘度众生菩萨先知是事已随顺而行。如说

  若以世尊意　　为他人解说
  先应知二事　　后随时方说
  若不知时方　　而欲说佛意
  不得所为利　　而更有过咎

知他心所乐者。知他深心为在何事为何所乐。菩萨先知已。入众生所知所乐。随顺起发度脱方便。如是则不虚也。如说

  菩萨知众生　　深心难测意
  先知其意已　　渐令住佛意
  遍知世间事　　自利亦利他
  若能如是者　　说名善方便

知转入道者。能转外道凡夫意令入佛道。亦转众生恶事令住善事中。亦知转声闻辟支佛道令入大乘中。已在佛法者不令入外道。先知是事已随顺而修行。如说

  若人令众生　　远离外道法
  及诸不善者　　入佛上寂灭
  若知诸众生　　上中下之心
  知已能引导　　是名善方便

知事次第者。如声闻乘中。初说布施。次持戒。次生天。次五欲过患。次在家苦恼。次出家利乐。次说苦谛。次集谛。次灭谛。次道谛。次须陀洹果。次斯陀含果。次阿那含果。次阿罗汉果。次不坏解脱。次说诸无碍。辟支佛乘中亦说。我我所物多有过患。舍此过患之物得大利益。在家为过恶。出家为利益。次众闹乱语为过恶。独行为善利。聚落为过恶。阿练若处为善利。厌离多欲多事。乐于少欲少事。守护诸根。饮食知节。初夜后夜随时觉悟。观缘取相乐住空舍。贵于持戒禅定智慧不现奇异。令他欢喜但自利益。乐于深法不随他智。如大乘中次第者。初说檀波罗蜜。次尸罗波罗蜜。羼提波罗蜜。毗梨耶波罗蜜。禅波罗蜜。般若波罗蜜。初说谛胜处。次说舍胜处灭胜处慧胜处。复次初赞叹发菩提心。次十种愿。次十究竟。次赞叹远离退失菩提心法。次修集不退失菩提心法。次坚心精进。次坚固堪受。次坚誓。复次初说能得诸地法。次说能住诸地法。次说能得诸地底法。次说远离诸地垢法。次说能作净地法。次说诸地久住法。次说能到诸地边法。次说能作不退失诸地法。次说诸地果。次说诸地果势力。复次或初说欢喜地。次说离垢地。次说明地。次说炎地。次说难胜地。次说现前地。次说深远地。次说不动地。次说善慧地。次说法云地。如说

  初施次持戒　　果报得生天
  无常在家过　　出家为大利
  次无上四谛　　断结证四果
  是方便次第　　令人住初乘
  初说生死过　　次说涅槃利
  守护于诸根　　持戒及禅定
  不随他智慧　　功德乐独处
  自依不依他　　乐求自利乐
  亦不舍他人　　深行头陀法
  其求中乘者　　教法相如是
  以四十不共　　说佛无量德
  亦说菩萨时　　一切所行法
  为利众生故　　次第说是法
  自利及利他　　说种种功德
  亦说诸佛子　　所乐十种地
  求法大乘者　　如是次第度

引导者。随众生所乐门。知是门已。以是门引导众生。随其所乐任其势力而令得度。如说

  或有诸众生　　可以深经书
  难事及工巧　　咒术以爱语
  善说及资财　　布施戒定慧
  如是筹量已　　引来入大乘
  或现于女身　　引导诸男子
  复现男子身　　引导于女人
  示众五欲乐　　然后说欲过
  而令一切人　　得离于五欲

善行是五事。是名菩萨善受行方便。能忍苦恼者。若有人过算数劫于生死中能忍诸苦恼。十善业道能令此人住于阿耨多罗三藐三菩提。问曰。一切人皆乐乐恶苦。是人云何能忍苦恼。答曰。以五因缘故。一乐无我。二信乐空。三筹量世法。四观业果报。五念过算数劫唐受苦恼。如说

  乐无我空法　　又知业果报
  利衰等八法　　处世必应受
  亦念过去世　　空受无量苦
  何况为佛道　　而当不受耶

不舍于一切者。或有众生第一弊恶无有功德不可利益。菩萨于此终不生舍心。问曰。若是恶人不可度者。云何不舍。答曰。以五因缘故。一贱小人法故。二贵大人法故。三畏诳诸佛故。四知恩故。五为是世间事故出世间。如说

  欲度众生故　　生心持重担
  于恶怨贼中　　心常不应舍
  贱小贵大人　　是小大差别
  不应众生中　　愍怜心还息
  于诸急难中　　无事而利益
  担于重担时　　而不中懈废
  若发无上心　　或有舍众生
  若自心疲苦　　及恶人所害
  即为欺诳于　　十方三世佛
  诸佛世中尊　　为利益众生
  行种种苦行　　修集于佛道
  佛于恒沙劫　　舍乐作福业
  若舍一恶人　　则为背佛恩
  是故恶众生　　不应于中舍
  若人于无量　　阿僧祇劫中
  所修集佛道　　大悲为根本
  若以贪欲心　　嗔恚怖畏心
  舍一可度者　　是断佛道根

是故善业道能令不舍者至阿耨多罗三藐三菩提。深乐佛慧者。若人深乐佛慧。便疾得阿耨多罗三藐三菩提。以五因缘故。深乐佛慧。一佛慧无与等。二佛智能令人为世中尊。三佛以佛智自度其身。四佛智亦度他人。五佛智是一切功德住处。如说

  诸佛之智慧　　天上及世间
  一切无与等　　何况而得胜
  诸佛以此智　　为天阿修罗
  一切世间人　　恭敬而作礼
  佛以智自度　　亦度于他人
  若得是佛智　　是功德藏者

于诸佛力及自在法中乐尽遍行者。遍行名久习。一切行力名十种智力。自在名随意所作。若人深乐佛十力及自在法中尽遍行。如是人阿耨多罗三藐三菩提不久疾得。以五因缘故乐尽遍行。一尊重诸佛教敕。二诸佛有大弟子故。三身证一切法故。四摄取堕落者。五已堕落者能拔济之。如说

  尊佛教无比　　佛子有四八
  及以六三种　　堪为诸天师
  以佛智慧眼　　见诸法现前
  逆恶断善根　　及诸破戒等
  如是坠落人　　摄取而济度
  若人于佛力　　自在中遍行
  涅槃及天福　　常在此人手

于是中诸佛以佛力能为五种事。一令众生学声闻乘。二令众生学辟支佛乘。三令众生学大乘法。四力具足者令得解脱。五力劣者令住世乐。如说

  诸佛以神力　　令厌离众生
  或令学小乘　　中乘及大乘
  有力具足者　　令其得解脱
  力不具足者　　生天令世乐

自在者。诸佛于五事中自在。一诸神通自在。二自心中得自在。三灭尽中得自在。四圣如意中得自在。五寿命中得自在。如说

  飞行等自在　　自心得自在
  于灭禅定中　　如入出自舍
  一切净不净　　随心而能转
  命不为他害　　自缘亦无尽
  如是等自在　　一切法亦尔
  是故人师子　　名为自在者

能破恶意者。所谓远离正道。凡夫九十六种外道等。略说恶意者。说五阴为我。或言我有五阴。或言五阴中有我。或言我中有五阴。或言离五阴有我。如说

  若五阴是我　　即为堕断灭
  则失业因缘　　无功而解脱
  余残有四种　　异阴无有相
  无相无有法　　皆应如是破

复次五邪见名为恶意。所谓邪见身见边见见取戒取。如说

  破因果邪见　　二十种身见
  有见及无见　　下事以为最
  但以戒力故　　而得于解脱
  如先一异破　　此见如是破
  正意八道破　　说名得解脱

守护诸佛正法者。若人能守护诸佛所教法所谓十二部经。以其心能信能受。十善业道能令此人至阿耨多罗三藐三菩提。以五因缘故应受护正法。一知报诸佛恩故。二令法久住故。三以最上供养供养诸佛故。四利益无量众生故。五正法第一难得故。如说

  若人欲施作　　诸佛所受事
  亦令法久住　　以上供养佛
  为欲疗治于　　众生之重病
  亦知诸世尊　　从苦得是法
  以是因缘故　　知法为难得
  是故有智者　　应当爱护法

于是中。以五因缘故。名为爱护正法。一如所说行。二令他人如法行。三除破佛法刺蕀故。四离四黑印。五行四大印。如说

  自于佛法中　　如佛所教住
  悲心不吝法　　亦令他得住
  又破于魔众　　及外道论师
  若憎佛法者　　以无嗔心破
  远离四黑印　　受行四大印
  如是则名为　　爱护于正法

勇健者。菩萨以五因缘故名为勇健。一破魔贼故。二破外道贼故。三破烦恼贼故。四破诸根贼故。五破五阴贼故。如说

  恶魔起兵众　　道树欲害佛
  常求于佛便　　娆乱听者心
  佛日出世间　　魔请令涅槃
  常乱受学者　　破于解脱道
  乃至于今日　　其心犹不息
  是憎涅槃者　　善人之大贼
  应以戒定慧　　摧破魔力怨
  自谓有智慧　　常轻慢于佛
  以种种因缘　　灭佛法故出
  常憎佛弟子　　自失教他失
  是诸外道辈　　世间之大贼
  当以无嗔心　　应以多闻慧
  及以大心力　　摧破外道怨
  烦恼力起业　　轮转堕恶道
  烦恼力障故　　不能行大道
  以烦恼力故　　堕种种邪见
  以烦恼力故　　不行甘露道
  以是因缘故　　烦恼最大贼
  以正念定慧　　破此烦恼贼
  若为根贼牵　　令人堕恶道
  又堕天人中　　不得至涅槃
  今此诸根贼　　何不以惭愧
  正念及智慧　　摧破诸根贼
  譬如世间人　　以软语欺诳
  财物及刀槊　　以此四除贼
  以此五阴故　　受生老病死
  亦堕大怖畏　　得诸急苦恼
  五阴因缘故　　忧悲及啼哭
  五阴因缘故　　受种种诸苦
  是故汝当知　　应以知见法
  摧破此五阴　　犹如破怨贼

堪受者。心志力强有大人相。见事深远。以五因缘故。名为堪受者。一所愿事成其心不高。二所愿不成心亦不下。三苦恼切己其心不动。四乐事加身心亦不异。五其心深远。若嗔若喜难可得知。如说

  身心新苦至　　其意亦不动
  随意乐事至　　大智心不异
  若嗔喜怖畏　　他人不能测
  如是深心相　　是说堪受者

勤精进者。于五事中勤行精进。一未生恶法为不生故勤行精进。二已生恶法为断灭故勤行精进。三未生善法为令生故勤行精进。四已生善法为增长故勤行精进。五于世间事中有所作无能障碍故勤行精进。如说

  断已生恶法　　犹如除毒蛇
  断未生恶法　　如预断流水
  增长于善法　　如溉甘果栽
  未生善为生　　如攒木出火
  世间善事中　　精进无障碍
  诸佛说是人　　名为勤精进

坚心化众生者。若菩萨于五乘中教化众生时。供养轻慢憎爱怖畏苦乐疲极等事中其心不转。是名坚心化众生。五乘者。一者佛乘。二者辟支佛乘。三者声闻乘。四者天乘。五者人乘。如说

  如应以一心　　一切诸力势
  依种种方便　　离于憎爱心
  教化诸众生　　离垢心清净
  令得无量世　　难得无上乘
  若入无势力　　不堪住大乘
  次教辟支佛　　声闻天人乘

不贪自乐者。所谓不着一切诸乐。菩萨以五因缘故不贪自乐。一乐无常如水泡。二世乐变苦。三从众缘生故。四从渴爱起故。五少乐如蜜渧故。如说

  乐少住如泡　　变苦如毒食
  三合从触有　　贪欲[病-丙+(瓜-、)]故生
  若离于贪爱　　更无有别乐
  如枯井蜜渧　　乐少而苦多
  利益众生者　　不应有贪着

及无量身命者。菩萨以五因缘故不贪惜身。一身不从先世来。二不去至后世。三不坚牢。四是身无我。五无我所。如说

  汝身众秽聚　　不净遍充满
  不从先世来　　不持至后世
  虽久好供事　　而破大恩分
  是身不坚固　　如沫不久坏
  缘生无定性　　无性不自在
  是故应当知　　非我非我所
  是身无量过　　不应有贪惜

菩萨以五因缘故不贪惜寿命。一乐慧命故。二怖畏罪故。三念无始生死中无量死故。四与一切众生共受故。五不可免故。如说

  从多闻正论　　生贪慧命故
  怖畏失命时　　而起于罪恶
  又见一切人　　无脱死王者
  不可以财智　　方便力所免
  修集善法者　　何得惜是命

一切事中上者。若人有所作事必能究竟。是名为上人。菩萨以五事发必得究竟。一者财物。二者布施。三持戒。四修定。五道德。如说

  勤求聚财利　　殷勤行布施
  次第净持戒　　精进求禅定
  行种种方便　　生八道解脱
  是名诸事中　　名之为上人

所作无过咎者。是菩萨所作智者不呵。以五因缘故。所作无过智者不呵。一作可作事。二大果利。三不坏法。四次后无过。五大名声。如说

  先种种筹量　　自作易作事
  从是事所得　　无量大果利
  不妨于善法　　作已无恶随
  善人所赞叹　　名闻广流布
  智者所起业　　名为无过咎
  可作及易作　　自属于己身
  无量大功德　　疾得果利益
  智者如是知　　后无有过咎
  应加勤精进　　而作如是事

一切种清净一切胜处来者。以五因缘故诸胜处一切种清净。一深心清净。二回向清净。三自如说行胜处。四令他人行。五离诸胜处相违法所谓妄语悭贪戏调愚痴。如说

  菩萨深净心　　远离于谄曲
  皆以四胜处　　回向于佛道
  先自修善法　　后令他人行
  菩萨如是者　　四胜处清净

十善道能令至十力世尊者。如是修习十善业道。能令人至十力。十力者名为正遍知。正遍知者则是佛。以五因缘故名世尊。一断过去世疑。二断未来世疑。三断现在世疑。四断过三世法疑。五断不可说法疑。如说

  无始过去世　　通达无有疑
  无边未来世　　知通达无疑
  十方无有边　　现在一切世
  出过于三世　　无为微妙法
  十四不可说　　亦通无有疑
  是故功德藏　　诸佛名世尊

如是功德成就者十善业道能令菩萨至阿耨多罗三藐三菩提。是故求佛道者。应如是修十善业

十住毗婆沙论卷第十五十住毗婆沙论卷第十六

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

    护戒品第四

是菩萨如是行诸善道

  于善不善道　　总相及别相
  各各分别知　　有二种果报

十善业道总相果报者。若生天上若生人中。别相果报者。离杀生善行。有二种果报。一者长寿。二者少病。离劫盗善行。有二种果报。一者大富。二者独有财物。离邪淫善行。有二种果报。一者妻妇贞良。二者不为外人所坏。离妄语善行。有二种果报。一者不为人所谤毁。二者不为人所欺诳。离两舌善行。有二种果报。一者得好眷属。二者不为人所坏。离恶口善行。有二种果报。一者得闻随意所乐音声。二者无有斗诤。离散乱语善行。有二种果报。一者人信受其语。二者所言决定。离贪取善行。有二种果报。一者知足。二者少欲。离嗔恼善行。有二种果报。一者在所生处常求他好事。二者不喜恼害众生。正见善行。有二种果报。一者离谄曲。二者所见清净。十不善道亦如是。总相果报者。上行堕地狱。中行堕畜生。不行堕饿鬼。别相果报者。杀生不善行。有二种果报。一者短命。二者多病。劫盗不善行。有二种果报。一者贫穷。二者失财。邪淫不善行。有二种果报。一者得丑恶妻妇。又不贞良。二者为他所坏。妄语不善行。有二种果报。一者人所谤毁。二者为人欺诳。两舌不善行。有二种果报。一者得恶眷属。二者眷属可坏。恶口不善行。有二种果报。一者耳闻恶声。二者常有斗诤。散乱语不善行。有二种果报。一者语不信受。二者言无本末。贪取不善行。有二种果报。一者心不知足。二者多欲无厌。嗔恼不善行。有二种果报。一者恶性。二者喜恼众生。邪见不善行。有二种果报。一者其心谄曲。二者堕在邪见

  知已爱乐法　　于法心不动
  于诸众生中　　慈悲心转胜

爱法者。但爱于法更无胜事。此中法者。先说十善业道。乐法者。但乐于法更无余事。于法心不动者。乃至失命终不舍法。菩萨行如是法。于众生中慈悲转胜。初地中虽有慈悲不及此地。以通达罪福业因缘故。众生可愍皆属于业不得自在。则无嗔恨憎恚之心。如是行者慈悲转胜。作是念

  咄哉诸众生　　深堕于邪见
  我应说正见　　令得入正道

菩萨通达罪福业因缘。于诸众生深行慈悲。作是念。众生可愍不知诸法实相故。多行妄想生诸邪见。因邪见故起诸烦恼。因烦恼故而起诸业。起业因缘故轮转生死。我先发心求阿耨多罗三藐三菩提。为度众生故当说正见。是诸众生是我应度。今当为说正见令入真道使得度脱。如是念已。知诸众生有种种烦恼。所谓

  观所起烦恼　　及诸烦恼垢
  种种黑恶业　　受种种苦恼
  愍念诸众生　　多有所阙少
  种种观察已　　是皆如我有
  即时以悲心　　方便发大愿
  云何令众生　　得灭是诸苦

烦恼烦恼垢者。使所摄名为烦恼缠所摄名为垢。使所摄烦恼者。贪嗔慢无明身见边见见取戒取邪见疑。是十根本随三界见谛思惟所断分别故名九十八使。非使所摄者。不信无惭无愧谄曲戏侮坚执懈怠退没睡眠佷戾悭嫉憍不忍食不知足。亦以三界见谛思惟所断分别故有一百九十六缠垢。有言人。烦恼在深心垢在浅心。有人言。诸障盖名为缠垢。余皆名烦恼。黑恶业者。即是七不善业道。及贪取嗔恼邪见相应思。能生苦报。种种苦恼者。身中种种恶事名为苦。心中种种恶事名为恼。又今世苦名为苦。后堕恶道名为恼。多有所少者。或诸根支体。或资生所须。或信戒等诸功德不具故名为少。余句易解如偈中所说。不复须释。如是思惟已。众生甚可愍。堕在于二乘。我当为发愿令住于大乘。是事如此十地经中金刚藏菩萨自说。是菩萨离十不善业道。亦令众生住十善业道。为众生深求胜心好心乐心怜愍心慈悲心利益心守护心我所有心大师心摄取心受取心。作是念。此诸众生甚可怜愍。堕种种邪意邪见行邪险道。我今应令住在真实正见道中。是诸众生种类不同互相诤竞。常怀忿恚嗔恼炽盛。然我当令住无上大慈。是诸众生无有厌足。贪求他利邪命自活。我当令住清净身口意业。是诸众生在贪欲嗔恚愚痴因缘中常起种种烦恼结使而不方便求欲自出。我当灭其诸苦恼事令住无苦恼处。是诸众生为无明所翳入黑闇稠林。不能自出离。智慧明入在诸见险恶道中。我应救之使得无碍智慧之眼。以是慧眼不随他人。于一切法知如实相。是诸众生堕在生死长流。欲堕地狱畜生饿鬼阿修罗坑入邪曲网中。种种烦恼恶草所覆无有导师不生出心。道言非道非道言道。魔民怨贼常共随逐无有善师。随顺魔意远离佛法。如是众生我应令度此诸生死险恶道得住无畏无衰一切智慧城。是诸众生为欲流有流见流无明流所漂种种罪业涛波所覆没在爱河。随生死波浪。为洄澓所转不能自出。为欲觉嗔觉恼觉碱水淹烂为身见罗刹之所执持。入五欲深林为喜染所著吹。在我慢陆地。甚可怜愍。无洲无救。于六入空聚落不能动发。无善度者。如是众生我今应以大悲牢坚智慧之船载至诸安隐无怖畏一切智洲。是诸众生多苦可愍。闭在生死忧悲苦恼牢狱。多怀贪恚爱憎堕四颠倒为四大毒蛇所害。为五阴怨家所残。喜染诈贼所陷。在六入空聚受无量苦恼。我应破其生死牢狱令得自在无碍涅槃安隐快乐。是诸众生甚可怜愍。狭劣小心乐于少利。缩没无有一切智心。设求出者则乐声闻辟支佛乘。我应令得大心使乐佛广大之法

  菩萨如是行　　则得持戒力
  善知起善业　　使令得增长
  是则为佛子　　深入离垢地

持戒力者。一心清净具足十善道。戒则得修集福德力。能起善业者。善知自生增长善道。亦令他众生深入者。所行转远尽其边底。佛子者。能随法行名为佛子。于初地始生。至二地增长。是菩萨应如是勤行精进

  菩萨若得至　　离垢地边际
  尔时则得见　　百种千种佛

初地中已说。般舟三昧。见现在佛助三昧法。所谓以三十二相八十种好四十不共法念佛。于一切法无所贪着。亦说利益三昧。能成就果报势力。问曰。若菩萨于初地中已到其边能见诸佛。初入第二地。即应见诸佛。云何言乃至第二地边乃见诸佛。若尔者。入第二地初中应失此三昧。至后乃得。答曰。初入第二地中亦见诸佛亦不退失是三昧。汝不能善解偈义故作此难。第二地初中。但见百种佛。乃至其边得见百种千种佛。见诸佛已心大欢喜。欲得佛法故。勤行精进

  即能以四事　　供养于诸佛
  能于诸佛所　　复受十业道

四事者。衣服饮食卧具医药。余义则可知

  作如是行已　　从佛受善道
  至百千万劫　　不毁亦不失

不毁者。不令戒羸弱。或以清净事名不毁。都不复行名为失。是菩萨如是。过初地入第二地已。如说

  善离悭贪垢　　乐行清净舍
  善离悭贪垢　　深爱清净戒

清净名但以善心行舍。不杂诸烦恼。深爱名坚住其中。究竟不舍。此地中悭贪垢。破戒垢无有遗余。是故此地名为离垢。菩萨如是无悭贪破戒心。于四摄法中爱语偏利。六波罗蜜中戒度偏利。利名多行势力转深。问曰。若第二地中。尸罗波罗蜜已得势力。今此地中。应解说尸罗波罗蜜分生力净差别。答曰

  略说尸罗度　　有六十五分
  生力净差别　　处处论中说

尸罗波罗蜜无量无边。但略说有六十五分。余戒生戒力戒净戒差别。论中先后处处说相。如宝顶经中和合佛法品中。无尽意菩萨于佛前说六十五种尸罗波罗蜜分。尸罗名不恼。一切众生于他物中无劫盗想不着外色不诳众生。眷属具足故不两舌。多忍恶言故无有恶口。常思惟筹量利益语故无散乱语。喜人乐故心无贪取。忍诸苦故无有嗔恼。不称誉余师故名为正见。信净心故信佛。知法真实故信法。乐尊重恭敬贤圣众故信僧。念佛以五体投地供养礼敬。乃至小戒深心怖畏故。戒不羸弱。不依余乘故不毁戒。离邪行故戒不缺损。不起恶烦恼故名不杂戒。毕竟常乐增长善法故名不浊戒。随意行故名自在戒。不为智者所呵故名为圣所赞戒。常在念安慧故名为易行戒。一切无过故名不可呵戒。守护诸根故名为善护戒。诸佛所念故名为名闻戒。如法物中知量取故名为少欲戒。断悭贪故名知足戒。身心远离故名远离戒。离众闹语故名阿兰若戒。不视他面望有所得故名为具足圣种戒。属善根故名细行头陀戒。生人天中故名随说行戒。救一切众生故名为慈戒。忍一切苦故名为悲戒。心不退没故名为喜戒。离憎爱故名为舍戒。降伏心故名为自见过戒。护彼心故名为不错戒。善护戒故名为善摄戒。成熟众生故名为布施戒。无所愿故名忍辱戒。不懈退故名精进戒。集助禅法故名为禅戒。多闻善根无厌足故名为智慧戒。从多闻得智慧故名为求多闻戒。集助七觉法故名亲近善知识戒。舍邪道故名离恶知识戒。观无常故名不贪身戒。勤集善根故名不信命戒。深心清净故名不悔戒。行清净故名不假伪戒。深心无垢故名无热戒。善起业故名无忧戒。不自高故。名无慢戒。离染欲故名不戏调戒。心质直故名不自高戒。心调和故名有羞戒。恶心不发故名调善戒。灭诸烦恼故名为寂灭戒。如说行故名为随所教戒。行四摄法故名教化众生戒。不失自法故名为护法戒。本来清净故名一切愿满戒。回向无上道故名至佛法戒。等心一切众生故名得佛三昧戒。大德舍利弗是六十五分。诸菩萨清净戒。则为无尽。生戒者处处说。略说有八种生戒。四从身生。四从口生。从身生者。离夺命离恼苦众生离劫盗离邪淫。从口生者。离妄语两舌恶口散乱语。是名八。是八种戒从受生。是受法。若以身若以口若以心受和合为二十四教。他受亦二十四。随喜受亦二十四。修习行时亦二十四。合九十六。皆是欲界系。从是昼夜生。何以故。初受心已灭。是第二心昼夜常生。用福德亦如是。所以者何。初布施心灭已。从第二心后。用时当生。是名善身业。有十善业道所摄。有不摄。欲界所系如是。色界系有二种。一从身生二从口生。从身生者。离十不善道。所不摄罪。从口生者。离散乱语。是戒以身受口受心受。二三为六。教他亦六。随喜亦六。习行时亦六。四六二十四。先说九十六合为百二十。如是从行生戒。复有证道时生戒。退道时生戒。初生时生戒。以事广故今但略说。戒力者。随波罗蜜增长。戒转得力。随所得地戒亦坚固得力。戒净者。不毁坏缺减等如先说。复次戒净不净相。七梵行法中说。如经说。以七种淫欲名戒不净。一者虽断淫欲而以染心受女人洗浴按摩。二以染心闻女人香共语戏笑。三以染心目共相视。四虽有障碍。以染心闻女人音声。五先共女人语笑。后虽相离忆念不舍。六自限尔所时断淫欲然后当作。七期生天上受天女乐及后身富乐。是故断淫欲是名不净。离此七事名戒清净。戒差别者。有二种。一有漏。二无漏。三种欲界系色界系不系。四种正命所摄二种正语正业。正命所不摄亦二种正语正业。五种凡夫戒菩萨戒声闻戒辟支佛戒无上佛戒。六种欲界正命所摄身口。一。正命所不摄二。色界系正命所摄身口业三。正命所不摄四。无漏正命所摄身口五。正命所不摄六。七种七善业道。八种如先说。身四种口四种。九种七欲界系七善业道二种如先说。十种道戒三种。对治戒三种。但戒三种。是九种。无漏戒有漏戒为十。如是等种种分别差别。问曰。声闻乘中。说身业口业名为尸罗。此二善业名好。二不善业名恶。是善身口业名尸罗。此论中即以此为尸罗。为更有尸罗。答曰

  不但身口业　　名之为尸罗
  修亲近乐行　　亦名为尸罗

此三事一义。所谓修习亲近乐行。问曰。若以修习亲近乐行。名为尸罗者。一切法皆应名尸罗。何以故。常修习亲近乐行故汝今应说最胜修习尸罗答曰

  若无我我所　　远离诸戏论
  一切无所得　　是名上尸罗

若不知内外法实相。即因尸罗生憍慢贪着故。开诸罪门。是故若于内法不见有我。于外法中不得我所。知内外法毕竟空无所得。亦于毕竟空不取相戏论是名最胜尸罗。何以故。如是尸罗中尚无心错。何况身口。是故诸佛菩萨。第一能行尸罗者。于一切法无所得。名为上尸罗。如迦叶经中说。佛告迦叶。尸罗名无我无非我无作无所作。无作者。无行无不行。无名无色无相无无相。非善非非善。非寂灭非非寂灭。非取非舍。无众生无众生因缘。无身无口无心。无世间无世间法不依世间。不以尸罗自高。不以尸罗下人不以尸罗起增上慢。不以尸罗分别此彼。迦叶。是名诸贤圣尸罗。离于三界无漏无系。如无尽意菩萨尸罗品中。语舍利弗。尸罗名不分别是众生不说是我。不说是寿者命者。不说是人。不说是养育者。不说是色阴受想行识阴。不说是地种水火风种。尸罗名不分别是眼相不分别是色相不分别是耳相声相鼻相香相舌相味相身相触相意相法相。尸罗名不分别是身是口是心。尸罗名摄心故是一心相。选择诸法故是慧相。尸罗名到空至无相际不杂三界。无作无起无生忍。尸罗名不从先际来不至后际亦不住中际。尸罗名不住。心意识不与念和合。尸罗名不依欲界不依色界不依无色界。尸罗名离贪尘除嗔垢灭无明闇。非常非断不违众缘生相。尸罗名离我心舍我所心不住身见。尸罗名不贪著名相不与名色和合。尸罗名不为结使所使。不为诸缠所覆。不住障碍疑悔中。尸罗名贪不善根所不住过嗔不善根断痴不善根。尸罗名无急无热猗心快乐。尸罗名不断诸佛种故不破法身。不分别法性故不断法种。无为相故不断僧种。舍利弗。是名诸菩萨最胜无上尸罗。如是尸罗则不可尽唯除诸佛尸罗皆有尽也所谓

  从凡夫尸罗　　后至辟支佛
  是皆有尽相　　菩萨则无尽

从凡夫来所有尸罗虽久受果报终归于尽。诸阿罗汉辟支佛所有尸罗皆亦有尽。菩萨尸罗无我无我所离一切所得灭诸戏论。是故无尽。如无尽意菩萨尸罗品中说。诸凡夫尸罗随生处尽故。尸罗则尽。外道五通退转时尽故。尸罗则尽。人以十善业道尽故。尸罗则尽。欲界诸天福德尽故。尸罗则尽。色界诸天四禅四无量尽故。尸罗则尽。无色界诸天随定生处尽故。尸罗则尽。诸学无学人入涅槃尽故。尸罗则尽。诸辟支佛无大悲故。尸罗则尽。大德舍利弗。但诸菩萨尸罗无有尽。何以故。从菩萨尸罗出诸尸罗差别因无尽故果亦无尽。菩萨尸罗无尽故。如来尸罗亦无尽。是故诸大人尸罗名为无尽。问曰。汝解粗尸罗时。说六十五种尸罗。声闻中有八种尸罗。四种从身生。四种从口生。如是事者何得不相违。答曰。不相违也。何以故

  虽非尸罗体　　益故名为分
  八种身口业　　即是尸罗体

虽六十五种分非尸罗体而利益身口八种粗尸罗故名尸罗分。凡能有所利益皆名为分。如象马扇盖名为王分。是故禅定智慧等虽非尸罗体以利益尸罗故。亦名尸罗分

    解头陀品第五

菩萨如是行尸罗法

  见十利应着　　二六种衣法
  又以见十利　　尽形应乞食

比丘欲具足行持戒品。应着二六种衣。以见十利故。何等十。一以惭愧故。二障寒热蚊虻毒虫故。三以表示沙门仪法故。四一切天人见法衣恭敬尊贵如塔寺故。五以厌离心着染衣非为贪好故。六以随顺寂灭非为炽然烦恼故。七着法衣有恶易见故。八着法衣更不须余物庄严故。九着法衣随顺修八圣道故。十我当精进行道不以染污心于须臾间着坏色衣。以见是十利故。应着二种衣。一者居士衣。二者粪扫衣。六种者。一劫贝。二刍摩。三憍絺耶。四毳衣。五赤麻衣。六白麻衣。见有十利尽形乞食者。一所用活命自属不属他。二众生施我食者令住三宝然后当食。三若有施我食者当生悲心我当勤行精进令善住布施作已乃食。四随顺佛教行故。五易满易养。六行破憍慢法。七无见顶善根。八见我乞食余有修善法者亦当效我。九不与男女大小有诸因缘事。十次第乞食故。于众生中生平等心。即种助一切种智

  佛虽听请食　　欲以自利己
  亦利他人故　　则不受请食

自利者。能具诸波罗蜜。利他者教化众生令住三宝。行者如是自利利他

  见有十利故　　常不舍空闲
  问疾及听法　　教化乃至寺

受阿练若处比丘。虽增长种种功德。略说见十利故。尽形不应舍。何等为十。一自在来去。二无我无我所。三随意所住无有障碍。四心转乐习阿练若住处。五住处少欲少事。六不惜身命。为具足功德故。七远离众闹语故。八虽行功德不求恩报。九随顺禅定易得一心。十于空处住易生无障碍想。问讯病等来至寺者

  若有因缘事　　来在塔寺住
  于一切事中　　不舍空闲想

比丘虽受尽形阿练若法。有因缘事至则入塔寺。佛法有通有塞。非如外道阿练若。名常乐空闲静处。于一切法不舍空想。以一切法体究竟皆空故。问曰。有何因缘故来至塔寺。答曰。一供给病人。二为病求医药具。三为病者求看病人。四为病者说法。五为余比丘说法。六听法教化。七为供养恭敬大德者。八为供给圣众。九为读诵深经。十教他令读深经。有如是等诸因来至塔寺

  精进行诸觉　　随阿练若法
  比丘已住于　　阿练若处者
  常应精勤生　　种种诸善法
  大胆心无我　　灭除诸怖畏

阿练若精进者。若比丘断贪。不惜身命利养故。昼夜常勤精进如救头然。身依随阿练若。觉者所谓出觉不嗔觉不恼觉等诸善觉。复次念佛是正遍知者。众生中尊。佛法是善说。弟子众随顺正行。复次随顺空随顺无相随顺无愿诸觉名随阿练若觉。复次随顺四胜处。随顺六波罗蜜诸觉。是名随顺阿练若觉。复次如佛为郁伽长者说在家出家菩萨行。若出家菩萨受阿练若法。应如是思惟。我何故住阿练若处。我非但住阿练若处故名为沙门。而阿练若处。多有众生。多恶不善。不护诸根不精进不修习善法者。如獐鹿猿猴众鸟恶贼旃陀罗等不名为比丘。我今为何事故住阿练若处。应成办其事。长者何等为事。一谓念不散乱。二得诸陀罗尼。三行慈心。四行悲心。五自在住五神通。六具足六波罗蜜。七不舍一切智心。八修习方便智。九摄取众生。十成就众生。十一不舍四摄法。十二常念六思念。十三为多闻故不舍精进。十四正观择诸法。十五应正解脱。十六知得果。十七住于正位。十八守护佛法。十九信业果报故名正见。二十离一切忆想分别思惟故名正思惟。二十一随众生所信乐为说法故名为正语。二十二灭诸业故起业名为正业。二十三破烦恼气故名为正命。二十四得无上道故名正精进。二十五观不虚妄法故名正念二十六得一切智慧故名正定。二十七于空不怖。二十八于无相不畏。二十九于无愿不没。三十故以智受身。三十一依义不依语。三十二依智不依识。三十三依了义经不依不了义经。三十四依法不依人。长者如是等名为出家菩萨比丘。利益事应生。随顺阿练若法者。所谓四禅四无量心。天耳天眼他心智宿命智神通等。灭诸怖畏者。是人以三因缘能灭怖畏。一见无我我所法相故能除怖畏。二以方便力故。三以心胆力故能除怖畏。见无我我所者。如初地中所说。除五种怖畏方便力者。此论中念正思惟业果报故。名方便力。应作是念。诸大国王在深宫殿。象马车步四兵侍卫业因缘尽。亦受种种诸衰恼事。又业因缘守护者。虽行险道中入大海水在大战阵亦安隐无患。我先世业因缘。若在聚落。若在阿练若处。业因缘必受其报。如是思惟已除灭怖畏。复作是念。若我为守护身故。入城邑聚落。舍阿练若处者。无有能胜善身业善口业善意业守护者。如佛告波斯匿王。若人行身善业行口善业行意善业。是名为人善自守护。是人若言我善自守护者是为实说。大王是人虽无四兵卫护亦可名为善好守护。何以故。如是守护名内守护。非外守护。是故我以身业善行口业善行意业善行故名为善自守护。复作是念。是诸鸟兽腹行虫等在阿练若处。身不行善口不行善意不行善。以远聚落住故而无所畏。我之心智岂不如此鸟兽等耶。如是思惟除诸怖畏。又以念佛故。在阿练若处。能破一切诸怖畏事。如经说。汝诸比丘阿练若处。若在树下若在空舍。或生怖畏。心没毛竖者。汝当念我是如来应正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。如是念时怖畏即灭。大胆名心不怯弱决定求道。如说

  比丘住空闲　　当以心胆力
  除灭诸怖畏　　念佛无畏者
  若人自起业　　怖畏不得脱
  不怖亦不脱　　怖则失正利
  如是知不免　　而破余利者
  则行小人事　　比丘所不应
  若有怖畏者　　应畏于生死
  一切诸怖畏　　生死皆为因
  是故行道者　　欲脱于生死
  亦救于他人　　不应生怖畏

如佛离怖畏经中说怖畏法。有沙门婆罗门。住阿练若处。应如是念。以不净身业故。不净口业故。不净意业故。念不清净故。自高卑人故。懈怠心故。妄忆念故。心不定故。愚痴故怖畏。与此相违。身业清净等则无怖畏。又佛为郁伽长者说。出家菩萨在阿练若处。应作是念。我何故在此。即时自知。欲离怖畏故。来至于此。怖畏于谁。畏众愦闹。畏众语言。畏贪欲嗔恚愚痴。畏憍慢恚恨嫉他利养。畏色声香味触。畏五阴魔。畏诸愚痴障碍处。畏非时语。畏不见言见。畏不闻言闻。畏不觉而觉。畏不知而知。畏诸沙门垢。畏共相憎恶。畏欲界色界无色界一切生处。畏堕地狱畜生饿鬼及诸难处。略说畏一切恶不善法故。来在此住。若人在家乐在众闹不修习道。住在邪念不能得离如是怖畏所。有过去诸菩萨。皆在阿练若处。离诸怖畏得无畏处。得一切智慧。所有当来诸菩萨亦在阿练若处离诸怖畏得一切智慧。今现在诸菩萨。住阿练若处离诸怖畏。得无畏处成一切智慧。以是故。我怖畏一切诸恶度诸怖畏故。应住阿练若处。复次一切怖畏皆从着我生。贪着我故。爱受我故。生我想故。见我故。贵我故。分别我故。守护我故。若我住阿练若处不舍贪着我者。则为空在阿练若处。复次长者见有所得者。则不住阿练若处。住我我所心者。则不住阿练若处。住颠倒者。则不住阿练若处。长者乃至生涅槃想者。尚不住阿练若处。何况起烦恼想者。长者譬如草木在阿练若处。无有惊畏。菩萨如是。在阿练若处。应生草木想石瓦想水中影想镜中像想。于语言生响想。于心生幻想。此中谁惊谁畏。菩萨尔时则正观身。无我无我所。无众生无寿者命者。无养育者。无男无女。无知者见者。怖畏名为虚妄分别。我则不应随虚妄分别。菩萨如是应如草木住阿练若处。又知一切法皆亦如是。断斗诤名阿练若处。无我无我所无所属名阿练若处。不应乐在家出家众闹处住。诸佛不听阿练若处比丘与在家出家者和合

问曰。佛不听与一切众人和合耶。答曰。不然

  佛听四和合　　余者则不听
  是故应亲近　　余者则远离

菩萨在阿练若处。听与四众和合。所谓入听法众。教化众生供养于佛。不离一切智心和合。是故唯听此四事和合。余者不应亲近。复次菩萨应作是念。云何诸佛所听。阿练若住处。我当亲近。我或非阿练若住处。谓是住阿练若处。或有错谬。问曰。何等是阿练若住处。菩萨应当和合。答曰。佛自经中说阿练若住处。名不住一切法。不归诸尘。不取一切法相。不贪色声香味触。一切法平等故。无所依止住名阿练若处住。自心善故。不相违住处。名阿练若住。舍一切担猗乐住故。名阿练若住。脱一切烦恼。无怖畏住故。名阿练若住。度诸流住故。名阿练若住。住圣种故名阿练若住。知足趣得故。名阿练若住。易满易养少欲住故。名阿练若住。智慧足住故。名阿练若住。正行多闻住故。名阿练若住。空无相无愿解脱门现前故。名阿练若住。断诸缚得解脱住故。名阿练若住。顺十二因缘随顺住故。名阿练若住。毕竟寂灭所作已作住故。名阿练若住。阿练若住处者。随顺戒品佐助定品。利益慧品易得解脱品。易得解脱知见品。易行诸助菩提法。能摄诸头陀功德。阿练若住处通达诸谛。阿练若处见知诸阴。阿练若处。诸性同为法性。阿练若处出离十二入。阿练若处不忘失菩提心。阿练若处观空不畏。阿练若处能护佛法。阿练若处。求解脱者不失功德。阿练若处。能得一切智者则能增益阿练若处。菩萨如是行。疾得具六度

何以故。若菩萨在阿练若处住。不贪惜身命是名檀波罗蜜行。三种善业清净入细头陀行法。是名尸波罗蜜。不嗔恨心于诸众生慈心普遍。但忍乐萨婆若乘不在余乘。是名羼提波罗蜜。自立誓愿于阿练若处不得正法忍终不舍此处是名毗梨耶波罗蜜。得禅定故不观生处修习善根是名禅波罗蜜。如身阿练若亦如是。如身菩提亦如是。如实中无差别。是名般若波罗蜜

  佛听有四法　　住阿练若处

何等四。如佛告长者。一者多闻。二善知决定义。三乐修正忆念。四随顺如所说行。如是人应住阿练若处。复有菩萨烦恼深厚。是人若在众闹则发烦恼。应在阿练若处住降伏烦恼

复次菩萨得五神通。是人欲教化成就天龙夜叉乾闼婆故。应住阿练若处。复有菩萨作是念。诸佛所赞听处。是阿练若处。复次住阿练若处。助满一切善法增长善根。然后入聚落。为众生说法。成就如是功德。乃可住阿练若处。复次

  决定王经中　　佛为阿难说
  阿练若比丘　　应住四四法

菩萨住阿练若处者。一远离在家出家。二欲读诵深经。三引导众生使得阿练若处功德。四昼夜不离念佛。复有四法。一乃至弹指顷于众生中不生嗔恨心。二不应一时顷使眠睡覆心。三于一念顷不应生众生想。四于一念顷不应忘舍菩提心。复有四法。一常应闲坐不应聚众。二常乐经行。三常观诸法无新故想。四不应离深空无相无愿法。复有四法。一行四禅不行世间禅。行四无量缘众生生悲心而不取众生相。二虽行慈心而不缘众生。虽行喜心而不贪乐。虽行舍心而不舍众生。三自见身有四圣种行而不自高卑下他人。四自行多闻如所闻行。是为四。复次

  无智无精进　　而住空闲处
  即得于四法　　复得余四法
  又复得三事　　如是佛所说

阿练若比丘于诸功德中应勤修习。何以故。阿练若功德中。此二事能生诸功德故。若比丘愚痴懈怠在阿练若处住者则得四非法。一多眠睡。二多贪利养。三以因缘现矫异相。四现不乐阿练若处复有四法。一增上慢未得谓得。二于深经心怀憎恶。三坏空无相无愿法。四于持深经者心生嗔恨。复有三事。一若在阿练若处。不精进无智慧。或值女人堕在非法。若得僧残。若得重罪。若反戒还俗。是为三

复次

  广说空闲法　　及与乞食法
  余十头陀德　　皆亦应广说

十二头陀法。上来以广解二事。余十头陀功德亦应如是知。何以故。是二则为开十头陀门。余则易解。十头陀者。一着粪扫衣。二一坐。三常坐。四食后不受非时饮食。五但有三衣。六毳衣。七随敷坐。八树下住。九空地住。十死人间住。粪扫衣者。人所弃舍受而后着。受者。若心生若口言。一坐者。先受食处更不复食。常坐者。夜常不卧。食后不饮浆者。食后不受非时饮。石蜜等可食之物。但有三衣者。唯受三衣更不畜余衣。毳衣者。从毳所成粗毛毳衣褐毡钦婆罗等。随敷坐者。随所得坐处不令他起。树下住者。乐住树下不入覆处。空地坐者。露地止住。住死人间者。随顺厌离心故。常止宿死人间法。是名十二头陀。令戒清净。粪扫衣有十利。一不以衣故与在家者和合。二不以衣故现乞衣相。三亦不方便说得衣相。四不以衣故四方求索。五若不得衣亦不忧。六得亦不喜。七贱物易得无有过患。八是顺行初受四依法。九入在粗衣数中。十不为人所贪着。一坐食亦有十利。一无有求第二食疲苦。二于所受轻少。三无有所用疲苦。四食前无疲苦。五入在细行食法。六食消后食。七少妨患。八少疾病。九身体轻便。十身快乐。常坐亦有十利。一不贪身乐。二不贪睡眠乐。三不贪卧具乐。四无卧时胁着席苦。五不随身欲。六易得坐禅。七易读诵经。八少睡眠。九身轻易起。十求坐卧具衣服心薄。食后不受非时饮食亦有十利。一不多食。二不满食。三不贪美味。四少所求欲。五少妨患。六少疾病。七易满。八易养。九知足。十坐禅读经身不疲极。但三衣亦有十利。一于三衣外无求受疲苦。二无有守护疲苦。三所畜物少。四唯身所著为足。五细戒行。六行来无累。七身体轻便。八随顺阿练若处住。九处处所住无所顾惜。十随顺道行。受毳衣亦有十利。一在粗衣数。二少所求索。三随意可坐。四随意可卧。五浣濯则易。六染时亦易。七少有虫坏。八难坏。九更不受余衣。十不废求道。随敷坐亦有十利。一无求好精舍住疲苦。二无求好坐卧具疲苦。三不恼上座。四不令下坐愁恼。五少欲。六少事。七趣得而用。八少用则少务。九不起诤讼因缘。十不夺他所用。树下坐亦有十利。一无有求房舍疲苦。二无有求坐卧具疲苦。三无有所爱疲苦。四无有受用疲苦。五无处名字。六无斗诤事。七随顺四依法。八少而易得无过。九随顺修道。十无众闹行。死人间住亦有十利。一常得无常想。二常得死想。三常得不净想。四常得一切世间不可乐想。五常得远离一切所爱人。六常得悲心。七远离戏调。八心常厌离。九勤行精进。十能除怖畏。空地坐者亦有十利。一不求树下。二远离我所有。三无有诤讼。四若余去无所顾惜。五少戏调。六能忍风雨寒热蚊虻毒虫等。七不为音声刺蕀所刺。八不令众生嗔恨。九自亦无有愁恨。十无众闹行处

十住毗婆沙论卷第十六十住毗婆沙论卷第十七

        圣者龙树造

        后秦龟兹国三藏鸠摩罗什译

    解头陀品之余

  如五空闲说　　余功德亦尔
  自读诵教他　　得舍空闲处

阿练若比丘有五种分别。一以恶意欲求利养。二愚痴钝根故行阿练若。三狂痴失意作阿练若。四为行头陀行故作阿练若。五以诸佛菩萨贤圣所称赞故作阿练若。于此五阿练若中为行头陀行故作阿练若。以诸佛菩萨贤圣所称赞故作阿练若。是二为善。余三可呵。如五种分别阿练若法余十一头陀行亦应如是分别知。问曰。佛说若已受阿练若法终不应舍。若有因缘得舍去不。答曰

  读诵经因缘　　可舍阿练若

若比丘欲从他受读诵经法。若欲教他读诵。应从阿练若处来入塔寺。以是因缘可得舍离

  教他读诵时　　不应望供给
  即时应念佛　　佛常有所作

阿练若从空闲处来。教他读诵。不应求敬心供给。应当念佛。尚自有所作。何况于我。念佛者。佛是多陀阿伽陀三藐三佛陀。诸天龙神乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽释提桓因四天王人非人所供养。一切众生无上福田。尚不求他供给身自执事。我今未有所知。始欲求学。云何受他供给。复应作是念

  我应善供给　　一切诸众生
  不望彼供给　　自利利他故

云何为自利。若贵供给则失法施功德。若不贵供给者则得法施功德。云何为利他。若贵彼供给而教令读诵者。彼则生念师直以世利故而教诲我不以法故。是人若以是心供给师者则不得大利。若但恭敬法故尊重师者则得大利是名利他

  从他求智慧　　应不惜身命

若行者欲从他求智慧应舍身命。舍者为智慧故。勤心精进恭敬于师不惜身命。问曰。何以故。为智慧恭敬师而不惜身命。答曰

  若一字一心　　以此为劫数
  恭敬于师所　　能说此论者
  离诸谄曲心　　深爱而恭敬
  昼夜不休息　　尽于尔所劫

随师所教论义字数及尔所心念。若受法者心无谄曲不惜身命。昼夜恭敬始终无异。虽能如是犹不报师所益论议智慧之恩。是故弟子应离谄曲心舍贪惜身命破于憍慢。若师轻蔑及以敬爱心无有异。当生深爱心第一恭敬心。应生父母心。应生大师心。应生善知识想。应生能为难事想。应生难报心。若师听则受所常行事。不须师敕余事则相望师意随事而行。师所爱重随而爱重。不应因师求于世利。莫求师赞叹。莫求名闻。但求智慧法宝。师有谬失常应隐藏。若师过衅若彰露者。当方便覆之。师有功德称扬流布。深心爱乐听受持解。思惟义趣如所说行。求自利利他者。莫为秸弟子。莫为大弟子。莫为垢弟子。莫为衰弟子。莫为无益弟子。无如是等过。但住善弟子法中。供给于师。如般舟经说。佛告颰陀婆罗。若菩萨欲得是三昧者。应勤精进于诸师所生尊重心难遭心。若从口闻。若得经卷处。于是师所应深心恭敬生父母心善知识心大师心。以能说如是法助菩提故。颰陀婆罗。若求菩萨道者。若求声闻者。所从师读诵是法处。不生深恭敬心父母心善知识心大师心。能得诵利是法。令不忘失久住不灭者。无有是处。何以故。颰陀婆罗以不恭敬因缘故。佛法则灭。是故颰陀婆罗。若求菩萨道者。若求声闻者。于所从闻。读诵书写是法处。生恭敬心父母心善知识心大师心者。于所读诵书写未得者令得已得久住则有是处。何以故。以恭敬心故佛法不灭。是故颰陀婆罗。我今告汝。于是师所应生深恭敬心父母心善知识心大师心。是则随我所教

    助尸罗果品第六

如是菩萨。为求多闻知多闻义已随说行故。能令尸罗清净。清净尸罗法应当修行。问曰。何等法能令尸罗清净。答曰

  护身口意业　　亦不得护法
  终不令我见　　及以余见杂
  回向萨婆若　　此四净尸罗

行者修此四法。尸罗自然清净。护身口意业者。常应正念身口意业乃至小罪不令错谬。譬如龟鳖常护头足。此人深乐空故。于第一义中而亦不得护三业法。有人虽见法空谓知空者在。是故说不杂我见众生见人见寿者见知者见。回向萨婆若者。持戒果报不求余福。但为度一切众生。以求佛道。是为四。复有四法。能令尸罗清净。所谓

  无我我所心　　亦无断常见
  入于众缘法　　则能净尸罗

无我我所心者。不贪着我我所心。但知此心虚妄颠倒而无我法。无断常见者。以断常见多过故。入众缘法者。知诸法从众缘生无有定性。行于中道。如是四法能净尸罗。复有四法能净尸罗。所谓

  行四圣种行　　及十二头陀
  亦不乐众闹　　念何故出家

四圣种者。所谓趣得衣服而足。趣得饮食而足。趣得坐卧具而足。乐断乐修行。十二头陀者。所谓受阿练若法。受乞食法。粪扫衣。一坐。常坐。食后不受非时饮食。但有三衣。毛毳衣。随敷坐。树下住。空地住。死人间住。亦不乐众闹者。不与在家出家者和合。有人虽行阿练若法。多知多识故。多人往来。是故说不乐众闹。若至余处。若心不与和合。何故出家者。行尸罗者作是念。我何故而出家。念已。随出家事欲成就故。如所说行。是为四。复有四法能净尸罗。所谓

  五阴无生灭　　六性如法性
  见六情亦空　　不着世俗语
  如是之四法　　亦能净尸罗

五阴无生灭者。思惟五阴本末故。见五阴无生灭者。见地等六性如法性。如法性不可得六性亦不可得。知六情虽是苦乐等。心心数法因缘。以正智推求。亦知是空。了达三种皆知是空。有行者贪着于空则还妨道。是故说莫贪着空。随于世俗说空名字。如是法者能净尸罗。问曰。若尔者云何言五阴诸法。答曰。以空故。五阴诸法空。最后言莫着于空者。空亦应舍。如是无有邪疑法妨碍尸罗。问曰。五阴诸法。以有相可相故。决定有。如说色是苦恼相觉苦乐是受相。现有如是等诸相。云何言非空非不空。答曰

  恼坏是色相　　何等为是色
  若恼是色相　　离相无可相
  此相在何处　　无相无可相
  世界终无有　　无相有可相
  相与及可相　　非合非不合
  其来无所从　　去亦无所至
  若有合非合　　成于相可相
  如是则为失　　相及可相相
  以相成可相　　相亦不自成
  相自不能成　　云何成可相
  世界甚可愍　　分别相可相
  迷惑诸邪径　　邪师所欺诳
  相可相则是　　无相无可相
  如是眼见事　　如何不能知
  随计相可相　　有如是戏论
  随起戏论时　　则随烦恼处

复次行者以不来不去门观诸阴性入空。如说

  生老病死法　　生时无从来
  生老病死法　　灭时无所去
  诸阴界入性　　生时无从来
  灭时无所去　　佛法义如是
  如火非人功　　亦不在钻木
  和合中亦无　　而因和合有
  薪尽则火灭　　灭时无所去
  诸缘合故有　　缘散则皆无
  眼识亦如是　　不在于眼中
  不在于色中　　亦不在中间
  不在和合中　　亦不离和合
  亦不从余来　　而因和合有
  和合散则无　　诸法亦如是
  生时无从来　　灭时无所至
  如彼龙心力　　而有阴云现
  不从龙身出　　亦不余处来
  而此大阴云　　雨流满世界
  然后乃消灭　　亦无有去处
  如云无来去　　诸法亦如是
  生时无从来　　灭时无所去
  如壁上画人　　不在一一彩
  亦不在和合　　壁中亦复无
  画师所亦无　　画笔中亦无
  不从余处来　　而因和合有
  和合散则无　　诸法亦如是
  有时无从来　　无时无所去
  灯炎不在油　　亦不从炷出
  亦不余处来　　而因油炷有
  因缘尽则灭　　灭时无去处
  诸法来去相　　皆亦复如是

复有四法。能净尸罗。所谓

  能自思量身　　不自高下他
  此二无所得　　心猗无有慢
  观诸法平等　　是四净尸罗

能自思量者。行者作是念。我身不净无常死相为何所直。如是念已。即不自高下于他人。信解身及他无我我所故无所得。猗者。得如是法故。心轻柔软堪任受法。以此猗乐心不自高。观诸法平等者。以空观有为无为法一切悉等无上中下差别。如说

  若当因于下　　而有中上者
  下不作中上　　云何因下有
  下自作下者　　中上先定有
  若当因于中　　而有下上者
  中不作下上　　云何因中有
  中自作中者　　下上先定有
  若当因于上　　而有中下者
  上不作中下　　云何因上有
  上自作上者　　中下先定有
  因下不得作　　不因亦不得
  若先定有者　　不应因于下
  若先定无者　　云何成中上
  因中不得作　　不因亦不得
  若先定有者　　不应因于中
  若先定无者　　云何成下上
  因上不得作　　不因亦不得
  若先定有者　　不应因于上
  若先定无者　　云何成中下

复次以空一相故。观诸法皆平等众生亦如是。如说

  智者于空中　　不说分别相
  空一而无异　　能如是见空
  是则为见佛　　佛不异空故
  说言诸佛一　　一切众生一
  一切法一法　　无上中下别
  一切佛世尊　　离自性他性
  一切诸众生　　亦离自他性
  一切法亦尔　　离自性他性
  以是因缘故　　是故名一相
  有诸佛则非　　无诸佛亦非
  有诸众生非　　无诸众生非
  有诸法则非　　无诸法亦非
  离于有无故　　名之为平等
  一切佛世尊　　众生及诸法
  一切不可取　　名诸法平等
  一切佛众生　　及法无差别
  不可分别故　　名之为平等
  诸佛与众生　　并及一切法
  入生住灭中　　寂灭无所有
  亦无所从来　　亦复无所去
  以无来去故　　名之为平等
  诸佛与众生　　并及一切法
  悉皆无所有　　过一切有道
  此三非是等　　亦复非非等
  非等非非等　　非非等不等
  如是说诸法　　皆等无差别

复有四法。能净尸罗。如说

  善能信解空　　不惊无相法
  众生中大悲　　能忍于无我
  如是之四法　　亦能净尸罗

行者了达诸法无自性无他性故。名为信解空。如说

  一切所有法　　终不自性生
  若从众缘生　　则应从他有
  不从自性生　　云何从他生
  自性已不成　　他性亦复无
  若离自性生　　则无有自性
  若离于自性　　则无有自相
  自性自性相　　不以合故有
  不以散故无　　二定有则无
  他不能生法　　自亦不能生
  自他亦不能　　离二亦不生
  若无有自者　　云何从他生
  离于世俗法　　则无有自他
  若他从他生　　他即无自体
  无体则非有　　以何物生他
  以无自体故　　他生亦复无
  四种皆空故　　无法定生灭

不惊无相者。信乐远离诸相故不惊。如说

  一切若无相　　一切即有相
  寂灭是无相　　即为是有法
  若观无相法　　无相即为相
  若言修无相　　即非修无相
  若舍诸计着　　名之为无相
  取是舍着相　　则为无解脱
  凡以有取故　　因取而有舍
  离取取何事　　名之以为舍
  取者所用取　　及以可取法
  共离俱无有　　是皆名寂灭
  若法相因成　　此即为无性
  若无有性者　　此即无有相
  若法无有性　　此即无相者
  云何言无性　　即名为无相
  若用有与无　　亦遮亦应听
  虽言心不着　　是则无有过
  何处先有法　　而后不灭者
  何处先有然　　而后有灭者
  此有相寂灭　　同无相寂灭
  是故寂灭语　　及寂灭语者
  先来非寂灭　　亦非不寂灭
  亦非寂不寂　　非非寂不寂

众生中大悲者。众生无量无边故。悲心亦广大。复次诸佛法无量无边无尽如虚空。悲心是诸佛法根本。能得大法故名为大悲。一切众生中最大者名为佛。佛所行故名为大悲。忍无我法者。信乐实法故。诸佛皆一涅槃道故。名为无我法。若入此法中心则不忍。如小草入火则烧尽。若真金入火能堪忍无失如是。若凡夫人不修习善根入无我中不能堪忍即生邪疑。是菩萨无量世来修习善根智慧猛利诸佛护念。虽未断结使入无我法中心能忍受。无我法者阴界入十二因缘等诸法是。破我因缘如先说。是故欲净尸罗。当行此四法。复次

  有四破尸罗　　而似持尸罗
  行者当精进　　自制慎莫为

宝顶经迦叶品中。佛告迦叶。四种破戒比丘似如持戒比丘。何等四。迦叶。有比丘。于经戒中尽能具行而说有我。迦叶是名破戒似如持戒。复次迦叶。有比丘。诵持律经守护戒行。于身见中不动不离。是名破戒似如持戒。复次迦叶。有比丘。具行十二头陀。而见诸法定有。是名破戒似如持戒。复次迦叶。有比丘。缘众生行慈心。闻诸行无生相心则惊畏。是名破戒似如持戒。迦叶。此四破戒人似如持戒。复次

  世尊之所说　　沙门有四品
  应为第四者　　远离前三种

迦叶品中说四种比丘者。应学第四沙门。不应为三。何等为四。佛告迦叶。有四种沙门。一者形色相沙门。二者威仪矫异沙门。三者贪求名利沙门。四者真实行沙门。云何名为形色相沙门。有沙门形沙门色相。所谓着僧伽梨剃除须发。执持黑钵。而行不净身业不净口业不净意业。不求寂灭。不求善。悭贪懈怠行恶法。破戒不乐修道。是名形色相沙门。云何威仪矫异沙门。具四种威仪。审谛安详趣得衣食。行圣种行。不与在家出家和合。少于语言。以是所行。欲取人意心不清净。如此威仪不为善。不为寂灭。而见诸法定有。于空无所有法畏如堕坑。见说空者生怨家想。是名威仪矫异沙门。云何为贪求名利沙门。有沙门虽强能持戒。作是念。云何令人知我持戒。强求多闻。云何令人知我多闻。强作阿练若法。云何令人知我是阿练若。强行少欲知足远离。云何令人知我少欲知足行远离法。非为厌离心故。非为灭烦恼故。非以求八直圣道故。非为涅槃故。非度一切众生故。是名求名利沙门。云何真实行沙门。有沙门尚不贪惜身。何况惜名利闻诸法空无所有。心大欢喜随说而行。尚不贪惜涅槃而行梵行。何况贪惜三界。尚不着空见。何况着我人众生寿者命者知者见者见。于诸烦恼中而求解脱。不于外求。观一切法本来清净无垢。此人但依于身不依于余。以诸法实相尚不贪法身。何况色身。见法离相不以言说。尚不分别无为圣众。何况众人。不为断不为修习故。不恶生死不乐涅槃无缚无解。知诸佛法无有定相。知已不往来生死亦复不灭。迦叶。是名随真实行沙门。迦叶。汝等应勤行真实行。沙门莫为名字所害。复次

  不为王等法　　而持于尸罗
  亦不依生等　　而持于尸罗

行者欲净尸罗。不应为王等法。王等法者。佛为净德力士说。善男子。菩萨尸罗者。乃至失命因缘犹不破戒。不期为国王故持戒。不期生天故持戒。不期为释提桓因不为梵天王不为富乐自在力故持戒不为名闻称赞故。不为利养故持戒。不为寿命故。不为饮食衣服卧具医药资生物故持戒。不依生等法者。不为生天人持戒。不自依持戒。不依他持戒。不依今世持戒。不依后世持戒。不依色不依受想行识不依眼不依入不依耳鼻舌身意故持戒。不依欲界色界无色界故持戒。不为得脱地狱畜生饿鬼阿修罗恶道故持戒。不为畏天中贫故持戒。不为畏人中贫故持戒。不为畏夜叉贫故持戒。问曰。若不为如此等法者。为何法故持戒。答曰

  为欲令三宝　　久住故持戒
  为欲得种种　　利益故持戒

三宝久住者。为不断佛种故持戒。为转法轮故持戒。为摄圣众故持戒。为脱生老病死忧悲苦恼故持戒。为度一切众生故持戒。为令一切众生得安乐故持戒。为令众生到安乐处故持戒。为修禅定故持戒。为智慧解脱解脱知见故持戒。是事如净德经中广说

  菩萨能如是　　成就于尸罗
  不失于十利　　及余种种利
  亦复不堕于　　四难处邪道
  不得四失法　　不值四坏法
  又得不欺诳　　诸佛等四法
  能过堕地狱　　十事诸怖畏

不失于十利者。不失常为转轮圣王。常于彼中不失不放逸心。不失常作释提桓因。常于彼中不失不放逸心。常不失求诸佛道。常不失诸菩萨所教化事。常不失乐说辩才。常不失种诸善根福德满足所愿。常不失为诸佛菩萨贤圣所赞。常不失疾能具足一切智慧。是为十。种种利者。于种种功德不退失。如经中说。菩萨善守持戒。常为诸天所赞。诸龙王善护诸人供养。常为诸佛所念。常为世间大师。愍念众生。不堕四难处等邪道者。菩萨能如是成就尸罗者。不堕四难处。一不生无佛处。二不生邪见家。三不生长寿天。四不堕一切恶道。得四不失法者。一不失菩提心。二不失念佛。三不失常求多闻。四不失念无量世事。不值四坏法者。一不值法坏。二不值刀兵。三不值恶毒。四不值饥饿。得四不诳法者。一不欺诳十方诸佛。二不欺诳诸天神等。三不欺诳众生。四不自欺诳身。又过十怖畏者。菩萨如是清净持戒。能过堕地狱等十怖畏。何等十。一能过地狱怖畏。二能过畜生怖畏。三能过饿鬼怖畏。四能过贫穷怖畏。五能过诽谤呵骂恶名怖畏。六能过诸烦恼所覆怖畏。七能过声闻辟支佛正位怖畏。八能过天人龙神夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽等怖畏。九能过刀兵恶毒水火师子虎狼他人所害怖畏。十能过邪见怖畏。菩萨如是净持于戒。则能住诸佛法。所谓四十不共法。堪任为法器

    赞戒品第七

菩萨如是净持尸罗。能摄种种功德诸利。如无尽意菩萨说。复次略赞尸罗少分。尸罗者。是出家人第一所喜乐处。如年少富贵最可喜乐。能增长善法。如慈母养子。能防护衰患如父护子。尸罗能成就诸出家者一切大利。如白衣多财尸罗能救一切苦恼。如正行顺理。尸罗善人所敬。如报恩法。尸罗人所爱重。犹如寿命。尸罗智者所贵。如智慧。求解脱者善护尸罗。如王密事大臣守护。乐道利者。爱重尸罗。如乐涅槃爱重佛法。智慧之人善守尸罗。如惜寿者护安身法救死时急。尸罗为最如遇急难得善知识。尸罗清净庄严贤人。如贵家女惭愧无秽。尸罗即是功德之初门。如不谄曲开诸善利。尸罗最是梵行之本。如直心则是正见之本。诸大人法以尸罗为本。如求重位以直心为本。尸罗即是功德宝[卄/積]。如不放逸。亦如正念能生诸利。亦如贤友初中后善。学正法者不得过越。如海常限。尸罗即是功德住处。亦如大地万物依止。尸罗润益诸善功德。亦如天雨润益种子能成五根。如火熟物能生诸利。如风成身。尸罗能受一切道果。亦如虚空含受万物亦如吉瓶随愿皆得。亦如美膳利益诸根。尸罗善能通利诸道。能令诸根清净无碍。智慧寿命以尸罗为本。犹如身命以气息为本。尸罗即是最上依处如民依王。尸罗即是诸功德主。如军大将。尸罗得众快乐。如随意妇能称夫心。若求涅槃及生天上。尸罗即是学道资用。如彼远行必持衣粮。尸罗将人令至善处。如经险路得善导师。尸罗度人从生死过。犹如牢船得渡大海。尸罗能灭诸烦恼患。犹如良药能消众病。尸罗器仗能御魔贼。如善兵器能对敌阵。如所爱亲经难不舍。尸罗将人诸衰恼中随护不舍。尸罗能照后世痴冥。如大灯明能除黑闇。尸罗度人出诸恶道。如度深水得好桥梁。尸罗能除烦恼热急。如清凉室能除毒热。欲堕恶趣尸罗能救。如勇士持刃救人怖畏。诸凡夫人应深爱尸罗如诸菩萨学谛胜处。行者善行尸罗如诸菩萨行舍胜处得果之人善修尸罗亦如菩萨修灭胜处护持尸罗令人得果。亦如菩萨修慧胜处。不坏法者能净尸罗如诸菩萨清净无垢。诸恶人等舍离尸罗如彼谄曲舍离直心。放逸之人不行尸罗如悭贪者不行惠施。放逸之人舍离尸罗如戏论者离寂灭法。愚痴之人无有尸罗犹如盲者不见五色。无思惟者去尸罗远。如离八道去涅槃远。善爱身者深乐尸罗如阿罗汉深爱乐法。尸罗能使无恼善法相续不断。如佛出世善事不绝。尸罗能令诸道果住。如佛神力令法久住。尸罗如佛自利利人。尸罗善护诸善功德。如王知时能护国界。尸罗安行者心。如须陀洹果。如时发事后则无悔。尸罗究竟必得涅槃。如菩萨愿究竟得佛。尸罗亦如良田好泽投之以种疾得增长。尸罗是正行之因。如知时方等是成诸事因。如人端严福德智慧人所尊贵。尸罗如是自他所敬。如福德熟时心则安隐。尸罗能使心得安隐受诸利报。尸罗能令行者欢喜。犹如好儿令父心悦。尸罗则是无有过失无畏之法。如人无过心则无畏。尸罗令人今世后世无有怖畏无诸罪恶。供养称赞持尸罗者余者亦喜自知有分。尸罗亲爱众生。如修慈定。尸罗灭苦如修悲定。尸罗与喜如修喜定。尸罗无憎无爱。如修舍定。尸罗为人所信。如四种善语能令人信。尸罗乐行。如世法中常欢喜心。如多闻是乐说因。尸罗则是言行相应因。尸罗是无畏因。如辩才无畏。尸罗是名闻因。如通诸经有好名称。尸罗是能救法。如易与语者为人所救。尸罗能成明解脱法。如随所说行。尸罗是诸佛相。如阿耨多罗三藐三菩提。尸罗助修道法。如定助慧。尸罗令人无所畏难。如大心胆无所畏惧。尸罗是诸功德聚处。犹如雪山宝物积聚信等功德。诸希有事所可依止。尸罗犹如大海有诸奇异。亦如美果依止于树。尸罗与人随所乐果。如随正智慧者如行即得。尸罗名为无水而净。尸罗则是最上妙香。不从根茎枝叶华果中出。尸罗庄严过诸宝饰。常住其身无能却者。尸罗大乐不从五欲生。后世亦有诸妙乐报。尸罗是一切世间天人魔梵沙门婆罗门所赞叹者。尸罗快乐自在身中不从他得生天涅槃之善方便。尸罗即是信河正济。无有泥陷瓦石刺蕀。随意可入善渡无碍。尸罗是宝财无诸衰恼。尸罗是净道无能坏者犹如平路行旅无难。尸罗是好田不种不获自然获实。尸罗是甘露果。不从树草生。香美无比。尸罗是沙华不从水陆生常不萎坏。尸罗除烦恼热。如冷水洗浴。尸罗善守护胜诸刀杖行尸罗者不以人畏故而得恭敬。尸罗是自在处无有诤竞。尸罗是好宝不从山生。不从大海出。而宝价无量。尸罗能过不活畏入众畏考掠畏堕恶道畏。尸罗常随逐人。今世后世如影随形

    戒报品第八

菩萨离垢地。清净具说已。菩萨住此地。常作转轮王。第二地于十地中名为离垢。悭贪十恶根本永尽故名为离垢。菩萨于是地中深行尸罗波罗蜜。是菩萨若未离欲。此地果报因缘故。作四天下转轮圣王。得千辐金轮种种珍宝庄严。其辋真琉璃为毂。周圆十五里。百种夜叉神所共守护。能飞行虚空导四种兵。轻健迅疾如金翅鸟王。如风如念。所诣之处灭诸衰患降伏怨贼。一切小王皆来归伏。亲族人民莫不爱敬。普能照明。圣王姓族种种华鬘璎珞间错庄校。五种伎乐常随逐之。以奇妙宝盖罗覆其上。行时有种种华香碎末旃檀常雨供养。烧真黑沉水牛头旃檀黄旃檀以涂其身。其轮两边天女执持白拂侍立。种种珍宝以为其盖。其轮有种种希有之事而用庄严。是名金轮宝具足。一切象相。身大而白如真银山王出神岳。大象众中能飞行虚空。伊罗婆那安阇那王摩那等诸大象王皆能摧却。是名白象宝具足。马相色如孔雀颈。其体轻疾如金翅鸟王飞行无碍。是名马宝。贵家中生身无疾病。有大势力形体净洁忆念深远直心柔软。持戒坚固深敬爱王。能通达种种经书技术。是名主兵臣宝。如财主天王富相具足千万亿种诸宝伏藏常随逐行。千万亿种诸夜叉神眷属随从。皆是先世行业之报。善知分别。金银帝青大青金刚摩罗竭车磲马瑙珊瑚颇梨摩尼真珠琉琉等种种宝物。悉能善知出入多少。随宜能用。能满王愿。是名居士宝。光明如日月照十六由旬。形如大鼓能灭种种毒虫恶气疾病苦痛。人天见者莫不珍爱。好华璎珞以为庄严。处在高幢威光奇特。能令众生发希有心生大欢喜。是名珠宝。其手爪甲红赤而薄。其形修直高隆。润泽不肥不瘦。身肉次第肌肤厚实细密薄皮不堪苦事。身安坚牢如多罗树。身上处处吉字明了。吉树文画严庄其身。象王牛王马王画文幡盖文鱼文园林等文现其身上。踝平不现。足如龟背。足边俱赤。足跟圆广。[跳-兆+專]佣柔软。膝圆不现。髀如金柱如芭蕉树。如象王鼻软泽光润。佣圆而直。横文有三。腹佣不现。脐圆而深。脊背平直。乳如频婆果。如双鸳鸯圆起不垂柔软鲜净。又其臂纤佣圆且长节隐不现。其鼻端直不偏现出不大不小孔覆不现。两颊不深平满不高两边俱满。额平而长有吉画文。耳软而垂着无价环。齿如真珠贯如月初生。如雪如珂。唇如丹霞。如频婆果上下相当不粗不细。如赤真珠贯。眼白黑睛二色分明。庄严长广光明清净。其睫青致长而不乱。眉毛不厚不薄不高不下如月初生。高曲而长两边相似。发软而细润泽不乱。其身芬馨常有香气。如开种种上好香奁。身诸毛孔常出真妙栴檀名香能悦人心。口中常有青莲华香。身体柔软如伽陵伽。天衣细滑之事一切具足。心无谄曲直信惭愧深爱敬王。知时知方善有方便摄取王心坐起言语能得王意随王意行常出爱语。如人间德女众好具足。色如提卢多摩天女清净分明。如月十五日画文炳现。如帝释夫人舍脂。着天衣天鬘天香。多以天光明金摩尼珠庄校其身。善知歌舞伎乐娱乐戏笑之事。善有方便随意能令王发欢喜。一切女中是女为最。是名玉女宝。又转轮圣王有四如意德。一者色貌端严。于四天下第一无比。二无病痛。三人民深爱。四寿命长远。教诲众生以十善业。能令诸天宫殿充满。能减阿修罗众。能薄诸恶趣增益善处。能为众生多求利事有所施作。不用兵仗以法治化天子安乐。外无敌国畏内无阴谋畏。又其国内无疫病饥饿及诸灾蝗衰恼之事。一切边王皆所归伏。多有眷属能疾摄人。更无有能侵害国界。其四种兵势力具足。诸婆罗门居士庶人皆共爱敬。甘香美食自然而有。国界日增无有损减善能通达经书技艺算数咒术皆悉受持。巧能论说分别义趣。群臣具足悉有威德。常行财施无能及者。千子端严如诸天子威德勇健能破强敌。所住宫殿堂阁楼观如四天王帝释胜殿。王所教诲无有能坏于四天下。唯有此王威相具足故无能及者。音声深远易听易解不散不乱。如迦罗频伽鸟美软和雅闻者悦耳。眷属同心不可沮坏。所住之处地水虚空无有障碍。威力猛盛能堪大事。念问耆老不欺诳人。心无妒嫉不忍非法无有嗔恨。威仪安详而不轻躁。所言诚实未曾两舌。行施持戒常修善心。进止知时不失方便。神色和悦言常含笑。未曾皱眉恶眼视人。退失利者为之作利。已有利者令深知报怀惭愧心。有大智慧威德尊严而能忍辱。大丈夫相其性猛厉。诸所为事疾能成办。先正思量然后乃行。王有法眼所为殊胜。善思量者乃与从事。若不任者更求贤明。善集福德财物。清净能自防护不破禁戒。多饶财宝如毗沙门王。有大势力如天帝释。端严可爱犹如满月。能照如日。能忍如地。心深如海不为苦乐之所倾动。如须弥山王风不能摇。诸宝妙事之所住处。诸善福德之所依止。是诸一切世间亲族。诸苦恼者之所归趣。无归作归无舍作舍。有怖畏者能除怖畏。转轮圣王有如是等相

  能转破戒者　　令住于善法
  其余所行事　　如初地中说

转破戒者。能令众生舍恶行善得安乐事。令住善法者。能转众生恶身口意业令行善身口意业。此事如初地中说。所谓见诸佛得诸三昧。但彼数百此地数千以为差别

十住毗婆沙论卷第十七


四阿鋡暮抄

    No. 1505 [No. 1506]

    四阿鋡暮抄序

阿鋡暮者。秦言趣无也。阿难既出十二部经。又采撮其要迳至道法。为四阿鋡暮。与阿毗昙及律并为三藏焉。身独学士以为至德未坠于地也。有阿罗汉。名婆素跋陀。抄其膏腴以为一部。九品四十六叶。斥重去复文约义丰。真可谓经之璎鬘也。百行美妙。辩是与非。莫不悉载也。优奥深富行之能事毕矣。有外国沙门。字因提丽。先赍诣前部。国秘之佩身。不以示人。其王弥第求得讽之。遂得布此。余以壬午之岁八月。东省先师寺庙于邺寺。令鸠摩罗佛提执梵佛念佛护为译。僧导昙究僧睿笔受。至冬十一月乃讫。此岁夏出阿毗昙。冬出此经。一年之中具三藏也。深以自幸。但恨八九之年。始遇斯经。恐韦编未绝不终其业耳。若加数年将无大过也。近敕译人。直令转梵为秦。解方言而已。经之文质所不敢易也。又有悬数悬事。皆访其人为注其下。时复以意消息者。为其章章注修妒路者。其人注解引经本也。其有直言修妒路者。引经证非注解也

四阿鋡暮抄解第一(此土篇目题皆在首是故道安为斯题)卷上

        阿罗汉婆素跋陀撰

        符秦西域三藏鸠摩罗佛提等译

阿鋡暮(秦言趣无)前礼善逝法众坏有众(礼三尊众能除结也)当说所欲。略速义说。是故三法当说。弟子问说。是有三法说。是三法何义。师答法依三门(面也向也)结句。是次第作是故三法想识。问三法次第何义。答大佛经章系无数相。淫恚怀味精进因缘食持(味恚也着也进行系之故曰持也食味也)众生少智求圣谛。是辈想当知义。疾知义三法方便想。分别是次第。一切是世间所有想。随所欲想等结是故想知义三法作。问是方便相应说三法。答功德恶依觉解脱(修妒路功德一恶二依三)功德恶依觉解脱。有是句义。是根句是三。各各三度三分。问有三分句。初思惟解脱说。何义是解脱。彼解脱功德。恶依觉相应。答已入不为说。是解脱世间等生。至虫蚁。虫蚁亦求乐等生。谓见食而趣解脱。乐痛一义世间少乐相应乐因缘。不知如乐道乐涅槃乐无病等生也。以道乐有不知是所欲。若所欲不是为说。已入道。不为说如小儿。问何者眼即自知眼处。是自知是不为说。如是乐世间所欲。是道所欲。是故说道义作无恶

问是何功德。觉乐解脱。有若尔者不可见金见为富也。有病不可言闻。是故不觉解脱。答中间如明灯入坏闇。有不是明灯后有闇。是智生解脱者。知觉一义。问是何法功德。名为众生深痴。为色味香。为受不受已受。答或随想外经说是功德福德根无恶(修妒路三句福也根也无恶也)福德根无恶。是三功德清净法果。我功德想。是一切三皆入。是当略说。问已说是福德根。无恶是何法。答福德施戒分别(修妒路)复复善事(复复犹恒恒也)复簁人恶是故福(簁犹卢也)是三行施戒分别。如是先师说

常能作福。德所行施(八字也)众生之命。命速乎驰(八字也)若簁消恶。作行之数(八字也)是故福德。如斯说喻(八字也名首卢首卢三十二字偈也)

问已说福德施戒分别是何施名。答己身他受自财。施念俱去所更施。是三行施。法食无畏(修妒路)法施食施。无畏施。是三说施也。是法施世间出世间章说。是法施无畏施。八行三归命去五戒。世尊说归佛去。无量众生。无畏无妒无恚无杀。余者如是。问若归去见有杀虫。何法无畏护。答我不说一切众生以邪见痴杀虫。作他财恶。作是三归去。不有世间等见。得若归去无。世间等见是不归去。是故无量吉食施。名食为首。种种他施与塔为首(种种象)香为首(种种供也)己身受(二受己与他也)或二受。是故二功德具足大果报。是施净。如是我先师言。根财作有。或念或二作有。或义作世间吉是方便净。施少有大果。有因缘净。少俱功德得。问是戒何法。答戒身口他受不坏他坏增(修妒路)戒名三相应相应身口俱起。问何法。答他受他不受增。是他受名己饥羸。自知不娆他受。众生自知众生不娆(解不杀也)如是他财他妇不染取如是(虽言受亦不受耳直分身口不受也)不他受妄言两舌粗言不要言。不着他受。若七支不娆他受。种种贫穷为力助他受二共想。福增续如从今如杀生不作发意。中间增多相应。如出财得报意。善生觉受如种谷。枝叶增至得果。如是连续至睡眠增多。是故增是戒(梦不失也)

问是分别何法。答分别禅无量无色(修妒路)分别是善行。是故分别如麻油花合行分别。如王求如等求王果得有是求行。净果相应有分别。是禅思惟义是四行。问是何法。答禅淫行爱乐痛苦痛止(修妒路)是四禅初淫不善行。止善因缘系意住离淫说。二自行说自行自觉少铃声欲止。是故无行(譬三定也铃余音自行止喻也)是自行止淫前已说也。爱止三爱意欢喜如泉踊跃是无(三禅无)淫行止。增止。苦痛乐痛止。乐痛乐身意无逼(乐痛止也)苦外是彼无淫行爱。乐痛苦痛止。是四禅

问是为无量何法。答无量者。慈悲喜护(修妒路)是四无量想。众生无量。彼受因缘是无量。不是善能量。是故无量。是慈名一切众生爱。谓意行。一切众生敏。是身念是慈等。已悲苦恼众生爱。自身爱喜乐念众生。共系喜护无所作。众生他非法忍。若是众生作是相违见因缘。是故过忍护。已说无量

问何法无色。答无色虚空。识无所有。有想无想处(修妒路)处者依义也。众生是四分处空色助色恶见助。是故意无染。虚空因缘意一定。虚空共系想。彼虚空处。如何故虚空依为有识。是故识因缘行识处。是亦依无依解脱。谓无所作。是无所有处想。见恶相灭见恐一意。有想无想处。是无色界。观空已说。已说无色分别说。是一切福德说

问是根何法。答根无悭无恚无痴(修妒路)无悭无恚无痴是三事根相。问是谁根。答非前功德说也。是故一切解脱入法。是根如相应说。当使相应。一大二相应(痴大恚悭入)如无悭施无恚戒无痴分别。复无悭食施无恚无恐施无痴法施。复无悭无娆他无恚不娆他无痴增益。如是三戒复无悭禅根无恚无量无痴无色。如是三分别。复无悭圣事无恚忍无痴闻。如是无恶根。如是一切善行根。如是无悭名所作行念不取。无所为无恚名恚灭助。无痴名无明。无智灭助。是故根

问是无恶何法说。答无恶忍闻圣分(修妒路)忍闻圣分。是三无恶说。无恶俗数义。随想所作。或不恐畏恶。世尊已说无恶极行者言。是忍苦增恶力。自下无恚忍(修妒路)忍苦增力。恶力加数苦增力无恶。恶力自下(下欣也)厌苦是忍义。增力加无恶。不增力能不能为说(心如死灰恶声不出)唯当恐畏众生恶发。谓增无恶是忍。小人来力加自下。足能报而不报。是自下是众生过。行过当忍。是义当说。苦寒暑饥渴风暖起(修妒路)苦名如增事。是二事起身恼不。无意众生恶众生因缘恶说。是故二依(外内)谓逼身是当忍是忍

问已说忍。云何闻。答闻修妒路(举四阿鋡所出十二首也)阿毗昙鼻奈耶(修妒路三藏也)闻名谓淫恚痴尽。等有是闻余者非闻。是三藏修妒路阿毗昙鼻奈耶。是修妒路名谓一切智说。佛所可者。着断现四圣谛。现明无内无外解脱。阿毗昙名谓修妒路。所有显示相应章鼻奈耶(律也秦言志真也)名无行无命清净说。是三行闻。是增贪淫止鼻奈耶。恚止阿毗昙。阿毗昙行所作觉说。是故恚薄。恚起犯戒枝。地狱有痴止(修妒路)因缘说是一切闻

问云何圣分。答圣分等。善知识思惟得(修妒路)等。善知识等思惟等得。是三圣分。圣分无敢说恶义是善知识。所欲助善力。师弟子伴(修妒路)谓所欲。助善力谓彼善知识。彼三师弟子伴。问云何助师。云何善弟子。云何力伴。如数说。答如是说已知差别。助善力是善知识相。彼师弟子伴。知说是增助善二有是枝。彼或相助不善助觉不力说。如父无足年高父子。或有力不善念。欲助善不助不善处(助不助二也)如末迦兰富兰(六师之二)或欲无助善力。如一切明知医。前有怨知病不救。若是三相等具。是善知识。或师过或弟子过或伴过。是故三相相应是善知识

问是何法思惟。答思惟息觉精进护想所行(修妒路)息觉精进护想。以为面是无作。彼息名意乱定。彼相像觉精进意懈怠念。教不乱护等得等相应。如御车马迟则策之牛奔则抑之。等行是护。当如是观意。无量内入一护一。皆有缘众生前相应。是意等得护

问何所说。若护之意即奔则抑之。若意迟则策之等得护。答我前不说是等思惟耶。如等思惟。如恐怖时。相应行数。若异者无等思惟也。是故思惟

问是得云何。答得等具方便果(修妒路)方便定入无外供养。是相应入等具方便果

问何谁等具。答如说解脱

问是何等具名。答等具等书(等者书文字曰等也沙门具十二法为等具也)根断近禅(修妒路)等聚是善行。是故等具如种等具。种等具是枝义。是等具三行等书根断近禅

问彼等书名何法。答等书五纳阿练茹比丘行(修妒路)具足等书等书。等书增是义。二象作工师能画。彼巧匠作凿刻石木。削治作像。书作经作画作。彼像二行作。巧师所作能耐风雨。彼虽好不能耐。如是二人。道人白衣。彼道人念弃亲属。所作弃如巧师也。彼白衣妻不奴婢如画师所作。彼白衣展转爱乐。彼爱别离忧喜恐斗诤为首。非法而破坏。作经像无坚。有非道人。世尊说如孔雀好青项鸟。飞行不如野雁步。如是白衣不似比丘牟尼(亦比丘也)坐空野禅是书也。五纳阿练若作比丘行。是三头陀功德。十二根有。是余九眷属各当别说。世尊酸陀梨所。将难陀为说三功德。何时卿难陀得见汝(八字)无事而粗服衣纳五(八字)彼信施之而无所染(八字)远淫欲行能离其崄。(八字首卢)是故知根有是三功德及余四利。起衣乞食床卧有利。彼衣利持五纳为说。乞食利。教乞利床卧利。为说阿练行。是功德具坏有利等书。或二行入贡高入自叹入。彼衣乞食床卧利也。入贡高是三功德息一助止去贡高。是得乐为说头陀功德

问云何五纳。答五纳三衣取得(不择好恶也修妒路)五纳彼常住。是故五纳。五纳分是五纳。彼五纳三枝具足满。有三衣为面首。是修妒路义。问若五纳三事。九头陀功德有如是等(修妒路)相违。彼丘冢道路。弊坏衣被。得着被三衣。僧伽梨郁怛罗僧安陀罗婆[口*(葵-天+示)]。彼或有我持三衣。最好利坏。即由利便乱若不多最好求二利。最利多利。如或有人求最好女人二。不求好千。如是多利。持三衣止最好利生。是世尊我持三衣。一一割截。持六衣劫贝四。[鳥*奏](葛也青构反)系布傍渠(麻布)阿鞞駏(榜也)蒖麻([這-言+(茼-一)]布库打反)是辈六遇得便着割碎持。是故义不最好作不得恶。是名无好。彼如是三衣持名不求好。若众许若白衣许。床卧坐见余好而坐(二皆得坐也)彼如遇得作说。如坐好因缘得是当坐。若上座命是随遇。如是具足满五纳

问是阿练茹何法。答阿练者。坐树下露坐常坐常住(修妒路)我常当坐树下。我常当露坐。我常当坐(三坐也)是阿练茹具足。满阿练茹行。是故阿练茹。阿练茹分。是故阿练茹。是四床卧利助彼喜信作讲堂。柔软褥作乐想知为分别说。世尊我是不相像。弃家他舍着弃讲堂上。取阿练若行。如是阿练若行。作屈坻(今郁反容身禅小屋)作平屋意。欲作是二。是世尊我是非阿练茹行。平屋事。如舍马如乘驴。是故当坐树下。弃恶树而乐好树乐。利果好华树乐。彼世尊教露坐。用是为男女所欲。婆罗门所乐。为露坐已。利不生彼。如是露坐苦行作大床卧。至日出弃。思惟念眠。是故我世尊。我是非清净。如截耳欲着交露珰。是故当坐彼坐草蓐。结跏趺坐。世间所有遍思惟自行。行如是为具足满阿练茹行

问何法乞食名。答乞食一坐后无食(无贮)在丘冢间(修妒路)二行学道僧住处得。及乞食彼住处得食。名谓信家日日来具足食施。或恐来为劳外。为立僧园堂。作已即中办具与食。乞食谓家家少多得乞食。是乞食若违二非法行。彼一处食欲得食。檀越施我当食。作如是意于食乐着。世尊示行乞食。彼乞食来数数食至于时。如是不得思惟。彼世尊制一食

若如有人(四字)计常(二字)思念有慕(四字)得浆饭食(四字)知节(二字)能自抑寤(四字)是得彼一坐食复索好饮。佛听饮大得种种饮。不能思惟。是世尊我用是为弃。斯饮渴水亦得止是后食止。彼如是一坐食弃。后澡浴涂身严饰其身。彼世尊我亦是食想贡高食。长身极供养之要。当坏尽捐丘冢间。是故教丘冢间。见丘冢间食所化。复彼丘冢间虫半消。膖胀欲坏烂脂血流漫骨髓。千身骨交乱。见已贡高止。如是比丘行具足满。有是为等书

问何法是根断。答根断不可强止。自制不染有(修妒路)根断是根断不可强止。自制不染有

问是谁不可强止。答根起不可止。根不可止如断马水谷。若不护根不可断。多与水草腹满。马不能行。若不随时根不可强止。如瞎者亦当离淫。是故不可强止知行界所不受等思惟可护。或先师说根界去想。受弃不能至界。谓受自弃不染近。谓相似女人像。最好如见母见根。是三根断

问是近禅何法。答近禅忍无想(修妒路)等近思惟。是故近禅前说解脱

问如前说四禅何故说是。答彼世间出世间解脱得是行必定解脱。是辈中间圣谛可得。如人度空野地。见园宅果树花实。彼意必定为不复饥饿。为近城郭如思因缘。为旷野地淫怒痴。为劳善知识将导思惟。疾行阴界处。无常无我苦所有观。若欲是有忍(三忍)增思惟不动如梦中见乐。见其形像。苦时相见。是想增。世间最好法。世尊想如是。是禅行其中间觉见喜。是圣谛时婆素跋陀(秦言今贤人名也得无著道)三法解脱度。初说[口*(葵-天+示)]未都(尽也天竺品题皆在品后也)

    四阿鋡暮抄解第二(功德之第九名得得之第二也)

问何法是方便名。答方便戒忧簸笞(息也)智(修妒路)方便是道义。谓是解脱为首(首向也前也)是方便三揵度戒息智

问何故重说戒。答我不前说戒有二。世间出世间也。彼世间说。是出世间说。彼戒行为义

问彼何法。答戒等口行命(修妒路)等口等行等命。是三犍度戒。彼等口妄言两舌粗言不要言行离及余言。是等口等行名杀盗淫行离。及余事等行等命名比丘乞食。住食乞食衣床卧病医药自受。是余邪命。优婆塞离五事。彼刀毒酒肉众生(不卖)是等命

问是息何法。答息精进念定(修妒路)具足灭息。若淫怒痴止息彼为首。(面也向也)住是息是三精进念定。彼精进名勤力。是义精进。如是说勤力说有。若能行去解脱。是故精进

问是何法。答精进信行不舍(修妒路)信行不舍是三精进。说彼施一切善行。是故信何义一切善法。最始行一切善法。最信信二人行(信与人此二四信三宝)是偈彼亦三

问何法。答信敬喜行得解(修妒路)是信敬喜行得解。彼敬名弃浊。浊人。过恚嫉无羞耻过。如鸟水。牛猪交乱泉水。是浊说是恶去得清。是恶意乱浊说。彼恶弃清。是敬喜行乐解脱。如病病身好食不欲。病差必欲得食。是恚依不。乐闻法(恚三毒侯举)得善知识便乐行。然后彼如是念最好法。复为说是喜行也。得解名能持如人蛇。所啮。他功德分别医咒时至意听如是。如是咒语彼能得差(功德是医有德)得解等药吉利如是。贪淫为首。蛇啮人佛世尊愍彼无行。或彼弟子愍为说法。彼谓法得解不异。彼能淫可息作不他。是得解是信

问行名何等。答行勤起常念(修妒路)勤起常念是三行。彼起谓作善。如钻下木燥末牛粪而起火勤。数数作求索。复求索是常念无乱念。一因缘相应。如火然发及冠。手但欲救之。是三勤行

问行是不舍何法。答不舍不离不厌不转(修妒路)不离不厌不转。是三不舍。彼不离名不数数。劳缓精进作(劳惓也)不厌名久。行中无有果意。不厌不转名中。无有果有必当使有不欲。彼谓强行精进。如是弃。如是三。能得果如道所趣处

问已说精进行。是念何法。答念身痛意法。内外二不忘(修妒路)内外二。内外谓不忘是三念。彼内念己身依。内及余外二内外。或内受阴界处。外他受受不受二。或三结内主外主二主。彼内主淫外主恚。恚他不自恚。彼有是觉淫。亦他作是不何义。内染发他淫内着。如世尊说。女内女根等见。是修妒路痴二相应。彼三结助三是念。彼身三如上说。如是痛意法。如是十二行念

问是三昧何法。答定空无想无愿(修妒路)空无想无愿是三三昧。彼空所有空。问多有空色空舍空。是如是何空说。答空我作所有作二不可见(修妒路)我作所有作二不可见是空。问何法我作所有作不可见。谓世尊说我本时。名坻罗末婆罗门(我作)见比丘我手是虚空(所有作也)是何法。答是非我作。所有作是俗数。谓我阴觉是我作。不是世尊所。入谓界善。是所有作。彼世尊无谓法印空。空世间观行常。彼及是吾我二知得。是故无见是空。问是无愿愿何法。答无愿相应过去当来无作(修妒路)无愿无立是义(立住)是意三无住相应。过去当来(相应现在也住止也)是一切有为如说。处修妒路说。过去修妒路。彼有是觉己身泥洹不。是三受是不(三也)何义一耶余耶。涅槃弃身无有因缘。彼觉相应一切思惟灭。是涅槃无尽觉相应。己身余不余不说。是故是彼不说是无愿。问是无想何法。答无想行作俱无想(修妒路)行作俱。谓弃是无想略说。一切有为弃一切行作。谓作是行谓行是作。如入无明福无福。阿尼署(末尽)行作因。彼有近识持来。是行无明行。作一切有为是弃无想说。如法印色想不可得。是说一切彼行作俱想去(引法经证)一切是三义说。想知是定。问是智何法。答智见分别无学地相应(修妒路)知是智觉。是义彼三地住。见地分别地无学地。彼现是见。问何现。答前未见圣地根力觉宝分别行。是说如浣濯极净衣。本香犹故香。香是后香。花香极香。如是见地净意禅无量。正受增因缘弃。最好香作是分别无学。谓淫怒痴止不有因缘。是无学地。问何见地智。答见地法观未知智(修妒路)法智观智未知智。如是三见地。彼法智观智。是义如医知痈生熟以刀破。是后以指撩摩脉所趣向。令不伤脉然后割广。如是行者淫行为苦无常。等无常行入见苦止结弃。彼二智断耶未断乎。如是行发思惟(未知智亦名耳)如欲界无常。如是色界无色界。彼已思惟智色无色行结弃。如是见苦淫行。利苦界法智。如是观智。如是色无色行未知智如是习三淫行利灭息。是法智息是观智(结正是法智也分别解脱是观智)如是色无色行未知智。如是灭三是道淫行苦。息法智是亦观智。如是色无色行。未知智是道。是道是十二智见地广知(四谛各三十二)问是分别地几智。答分别地。相行种等知(修妒路)相智行智种智。是三智分别地。如上说。问何法相。答相生住坏(修妒路)相名生住坏。彼生谓相应住。次第应坏谓破。问无说益众生涅槃。数为是相众生涅槃。若彼为大过无常数。若不是彼是修妒路过。当如是说有为相生住坏功德增。是何相功德。当为说我相。我相异不异。是不说若异有常。若不异无常。俱过不说涅槃无相。是故说益乐知有为相如是。谓所说功德增。何相功德当为说智。是增行谓是三智已功德。是相是说相

问是行。答行无常苦无我见(修妒路)行遍知是义是相是行。知是义无常阴谓无常。是故苦谓苦。是故会当相应。无我是行。彼无常不久住。如水泡。苦逼如刺在体。无我不自由如假借严身是行。问是何种。答种气味灾得离(修妒路)种。名是气味灾是得离

问是谁。答是有为。彼气味名染着。灾名恶。得离名俱息。若天人乐气味地狱畜生饿鬼趣。苦灾福恶等过。是得离如是见。彼等功德恶见得解。是种是分别地智

问是何无学地智。答无学地毗署神通辩(修妒路辩四辩也)明达神通辩。是无学地智。问何法明达。答明达前世时。生处漏尽智(修妒路)前世念智生处智漏尽智明达有为首。是故明达知是义。彼前世念智所行念生处智名行果。所为智漏尽智后当说。若三结前世当来世现在世处。彼前世处十八见。作前世所作当来世处四十四见。作现在世处见身。彼知是现在行过去当来。觉前世念生得前世。不忘生处。觉后世不忘无漏智(是上后当说者)尽无所生智愿智(修妒路)我结已尽。是观尽智不复生。是无所生智。如医蛇所啮疗治破坏毒。是一智不复病前毒气。是二。智如是尽知。无所生智愿智名谓前世念智。声闻己身所更念不他也。以是智前愿他。亦知是愿智。问何法神通。答神通飞彻听知他意(修妒路)能飞是飞自在是义。彼六神通彼三飞。天耳知他意智飞。后当说彼彻听名前行定。一因缘去大地意增闻所知。以是天人趣闻声随其力。如或远见或近见。随眼力如是。如定得如是他意智所见。众生所闻声。是辈知其意。是思惟。知他智飞行。虚空化圣自在(修妒路)虚空行自在化自在圣自在。是三飞行。彼飞虚空自在。名能入水能入地能不现墙屋山无碍。手扪摸日月。如是飞行虚空自在化名如鸟马。车人山树城园河水能现圣自在名能住。命化水为酥眉间放光明。如是及余转增。是飞是圣说飞行(上言后当说者)彻听知他意。神通前世生灭智。谓凡人是五神通。问是何法辩。答辩法义应分别方便(修妒路)觉法方便觉义方便。应方便分别方便。是四辩彼觉法名句。合觉方便义。随彼所有如火名彼热。为热为义。彼不忘也。应名如是。是合邑是义。等知分别。方便名随应报无违错不耶。避是辩是无学地智广知。问是思惟戒定学无学者。何故彼不三示。答不戒戒增益学杀。生弃增。众生护有非阿罗汉。谓是不娆学。如是意住。是故不大增说。知是亦三。如是婆苏跋陀三法。次二解脱度说尽

    四阿鋡暮抄解第三(上功德之第九名得得之第三也)

问前已说等具方便果是。彼已说等具方便是何果名。答果佛辟支佛声闻(修妒路)佛辟支佛。声闻是三果。问是谁果。答戒息智中闻是说(修妒路)问具。是说具是道是何果或道。答有余是果欲。是外无余是义。世尊已说无余般涅槃是义(修妒路)是故无恶彼佛名。一切结解脱。有十力力事四无所异。自由一切佛法得。彼佛无差降。戒定慧辟支佛名自依。是时无异义。彼不从他说。是辟支佛声闻从他说。或二解脱等具。怜愍增等厌增彼怜愍增等具。谓时是三耶三菩。得等厌二己身生因他。彼己身生辟支佛。因他为声闻。若谓萨芸若一切功德具足。一切恶离是等正觉。辟支佛一切恶弃功德。少声闻因他弃恶

问云何如佛无中间。及余如是声闻。答声闻弃结不弃结阿罗汉(修妒路)是声闻。声闻有中间根。因缘信根为首。软中上增可得。是依声闻种种一切地。问是何法弃结名。答弃结信解脱见得身证(修妒路)信为首。度彼岸是信解脱思惟为首。见得三身证彼无量行。当示信解脱上道行。无行般涅槃(修妒路上道道迹也)上道行般涅槃。无行般涅槃。是三信解脱。彼道名利彼得至上上道。若迹是道。彼行般涅槃。名行因缘。道息去无行般涅槃。名无疾涅槃因缘道。般涅槃是信解脱说。问是见得何法。答见得中间。生般涅槃已上道(修妒路)见得。是三中间。般涅槃生般涅槃上道。彼中间般涅槃。名此终。他生得道中间。般涅槃。如小火迸未堕。中间般涅槃。生般涅槃。名如迸火堕地灭度。如是生于中间时。般涅槃上道名如上说。是无色界知是见得。问是何身证名。答身证行及行。生般涅槃(修妒路)是已说。问何故复说。答不复说界因缘。欲界解脱。色界解脱。是二一切中间。般涅槃弃不无色界。中间有复前不解脱。报身证是解脱报。是解脱后当说。是弃结说

问无弃结何法。答无弃结八须陀洹薄地(修妒路)八须陀洹薄地。是三无弃结

问何法八名。谓至数说。初得不八。前生后次第。阿罗汉是何阿罗汉。答如生见知。如人八儿彼。不初是八相应。最后者相应。彼世尊作功德。是见阿罗汉。大无余结尽。如是小前前最小已住。初是八说。若想随书定八也。问何八名。答八信思惟彼增等(修妒路)是凡人神名。族姓子是等。具有信思惟。彼或信增有智慧相应。或智慧增信相应。或俱等法智发。一牢信软根思惟。牢信中根俱牢利根。是三八谛见作。信增七死生有慧增中间住。有俱依家家。有如是见地分别地。乘乘薄地。住信增斯陀含有智慧增。中间住俱依一死生。有止住行因缘。信增信解脱。有慧增见得。有俱依色行止。身证有无余因缘。止信增软根。有慧增中根。有俱依利根。有是等向上如初日出

问已说是广八分别生功德网。是亦不知何是当说。答须陀洹七死生家家中间住(修妒路)须陀洹名二初果住。求二迹道说是乘。是故须陀洹。见身疑惑。愿失止趣尽去(恶道灭也)软根七行天上人界乐。得要当般涅槃(乐三界福)家家住利根。初果住分别止。因缘牢作行。是家家住般涅槃中间住。彼中间不必家家住。般涅槃彼要七住。天人中间二般涅槃。问已说须陀洹。是何法薄地住。答薄地斯陀含一死一生中间住(修妒路)淫行因缘薄作住是薄地。彼斯陀含一死一生。二中间住。彼一说此终生天上。一还般涅槃。上分因缘薄。上分因缘名五色欲无色欲。憍慢奥达吒(乱志)无明一生一还有来。般涅槃增多上。彼俱中间住。是不弃结

问是阿罗汉何法。答阿罗汉利软中根(修妒路)阿罗汉供养是义。彼供养相似。是阿罗汉。问何处供养。答一切众生。是三利根软根中根。问是利根何法。答利根住劫能坏有无疑法(修妒路)住劫能坏有无疑法。是利根知已尽分别。结尽过去住。是故住劫尽。一切结上增义。求能得过。是故能坏有。彼有增益义。明达神通辩。无疑法得增。一切难无疑辩。是利根因缘。问是软根何法。答软根减法念护有(修妒路)减法念有护有。是软根增上去。是故意减是减法。减法不众生减。分别地减分别行行。是说如所说章不诵失。彼不行分别地失。彼减痛事诵长行观(游观)是五事减。是亦分别地减。彼思惟有得阿罗汉。劣行用住为已作念念。是世间多行种种意。如念人世俗。如世尊说。衣授(已念不离)是念坏命(用住为也)是不护有得。阿罗汉不欲减当。不念是常大。护如贫人得财守。是软根因缘。问软根何等。答软根慧解脱。尽不尽解脱报(修妒路)慧解脱已说。俱分解脱二尽。解脱报不尽。解脱报俱分。解脱名念解脱慧解脱。是二增去义彼义。问是何彼解脱名。答解脱淫色助灭(修妒路)欲界色界俱助上意住。三界灭是三行解脱。解脱结是故解脱。问是何淫助名。答淫助中间色。无色想净不净(修妒路)增已。己身中间。己身亦增。是义是二。色想不坏色想。彼中间色不分别。谓丘冢地色腐烂肉脱眼。溃肠出不净。小便处百虫交乱(处共同处)乌扇发交乱啄鼻断。分离手脚头髑髅。如是见已淫结弃发。是身谓义及余怨斗诤。诈言谄贡高憍慢为首。有彼如是念作。谓恶解脱意定。是中间色想不净解脱。二自己身内色分别。由定无色住。如是他身念。是中间离淫想。不净解脱三净。青赤黄白花衣为首。因缘发意念住无动。是净解脱(观四色及衣而不着)问是色助。答色助无色以说(修妒路)色弃结发四意住。是有漏是色助福说俱去。问是何灭名。答识为首等相应灭。无漏正受阿罗汉。二弃结婆素跋陀。三法度三[口*蔡]末都(尽也)初功德中间说

    四阿鋡暮抄解第四(三法初功德已竟次说第二恶也)

问已说广功德。功德中间三法度。是何恶名。答恶苦行爱无明(修妒路)苦行爱无明。是略说恶当知。杂恶善行是杂恶是人愚。谓杂恶念如猪不净乐。世间彼前苦行。身口意苦行(修妒路)是恶数。谓初是三身苦行。口苦行。意苦行。苦行恶众生行。是苦行恶念行苦行。问是何身苦行名。答身苦行杀盗淫(修妒路)谓是身苦行。是三杀盗淫愚行知。问我当知身苦行三。是何法杀名。答杀念教行(修妒路)念教行。是三杀说。如是余如身苦行杀。分别三念教行。彼不与取淫愚行因缘。知余口行。问有是是亦不知是何法念名。答念欲作他作喜(修妒路)念名意觉。是三欲作教。作他作喜。如杀虫欲杀。教奴杀他杀称善。欢喜是念。问是教何法。答教处使作听(修妒路)教处使作听。是三教彼处处名。问曰是羊(披罗门云)以是为首。妄语富人欲食(欲严羊欺富人使杀羊祠曰贪自欲食)是教杀处使作名如王处。如杀是辈罔杀听之名。如或处贵来。问我有怨家娆我。我当报怨。答听是三处作。问是行何法。答杀行他众生。众生想舍断命(修妒路)杀行作是义。杀受知处分别听口意。苦行知。彼他众生想舍他命断(舍去便治)是三杀作。具足有何义。医虽善意病肿割之。当割时死。非是医杀生。彼不舍如是一少(若不舍为少一也具则非杀)是句无有杀生。三无如是杀处有。问是不与取何法。答不与取名他想。彼觉偷(修妒路)他有财。他觉(觉知也知彼财)彼取去。如是三行相应。不与取有何义(彼财一知是彼财二持去三)他财有取去。非盗觉自己作(觉知也知识财为举而无盗心如己有也)如彼是象相似觉取非盗。复他取无盗觉无过。如亲田根花果为首或取(为首非一也恐失时为收也)问何法淫愚行。答淫愚行他法受行更淫(修妒路)淫愚行略三他。他取去法。受行更淫。问淫是修妒路。根是何淫愚行作是说。答二人道人白衣。被道人至意。说无淫恶行(不断)淫愚行无作(逼人)若淫白衣恶行。须陀洹恶行。已随趣谓不尔。是故淫愚行谓不净。是故二无恶(道人白衣断不断也)修妒路说。问何法他他受。答他他受夫亲里王(修妒路)夫受亲里受王受。是一切他他受。彼谓女人以淫为主。是主是二至竟时中间。彼至竟名如方土家法。作主时中间。名是放法。妇人初财请。彼未及期若他堕(堕随也更行也)彼淫愚行。如是知亲里。名父母姊为首。谓小女若无夫慈养之。王受名谓无夫无亲里。悉属王为受。有是王受。是他他受。问是法受何法。答法受学斋家法(修妒路)学法彼受。是故学受斋法彼。是故斋法受家法。彼受是故家法受。彼听或前听。斋后不听非法(夫使受斋而悔行乱)是法受我今受斋。已听然后。若作乱。彼受斋法住为非法家法。种种因缘三事。一切不得往。母姊女儿妇为首。如是随性如是法受。问是更淫何法。答更淫舍妇人所生处。更以余淫男儿山持(修妒路)更淫名谓舍妇人所生处。作余淫力强淫男儿。行山持行是更淫

问是说不尽。何义更有因缘。余有淫行结。何法是中间去。若中间去说。若不是为不尽。答说已尽何义。舍妇人所生处向畜生。所说淫行余者尽。是故为尽。问从何起是非义行。答一切贪淫嗔恚愚痴(修妒路)贪恚痴等有知

问是何一切。云何是杀盗淫行。答不是说。若是说不是修妒路行作有。是一切受根修妒路说。身口苦行知意苦行别当说。问何法是三事相违现。何义不乐痛。一时等有恚。苦痛欲淫乐痛。说行淫是结。是何法恚。答我不说。贪淫嗔恚愚痴。是前愿说。是中间所作财着。嗔恚起杀。如是盗恚。发前如是。彼妹淫我当报怨后着。如是行淫前愿是恚。说是等起。是故无过如是余

问已说身苦行处。一切贪淫嗔恚愚痴。说如是口行处何法。答口苦行不如无如(犹是妄言不妄言耳)不要之言(修妒路)口苦行四是三系当现四(三中二也现四也)彼不如无如不要言。问是何不如名。答不如己身他义。义想所有取(修妒路)谓彼不如口苦行。是己义他义义义。己身所有取。所有取名觉。自下如余意异说。知是三义说。己身义己命义他义亲义义义种种所作义。是三世尊己说。是聚去眷属去。己因缘他因缘。食所有财等。知无妄言。问已说不如口苦行。是何法无如口苦行。答无爱因缘俱念相应(修妒路)无如名无爱念相应。因缘念相应。俱念相应。相应名是义。彼无爱念相应粗言。谓无爱念说恚是粗言。若尔者无有粗言者(其人谓此句弟子言)己身念起口苦行余。世尊亦当粗言。彼调达念欲度说彼恚。是故无爱。念相应。粗言如瞎缘。说嗔真诚彼恚。是故无爱念。口苦行因缘念相应名谛说。因缘念相应。两舌相应。若念相应。增生相助。非两舌。若尔者。世尊亦当两舌。世尊学道为首。欲益已自行说离本。是故念恶。是故当知俱相应名因缘。二作妄言不妄言粗言。亦如是。是故粗言两舌。问是不要之语何法。答不要语。非时非谛非义言(修妒路)非时言非谛言非义言。是三略阿跋度路柘那(秦言不要语)是因缘无量。彼非时言名如相应时。离语因缘如时尽具当手授作(外国婚礼夫亲迎女女氏具送女之具澡夫手父以女手授故云尔)

吉祥所用随所欲中。或有言君善哉。无常因缘坏法有后。必当衰离。是淫如是。彼谛语佛辟支佛声闻所说。非时言不要言去不谛言。名谓如谛想无谛说。如尼揵所说(念谓师真谛而邪道)萨芸若是我师。是故彼想是不要语。何义不萨芸若。是彼师增。彼如是想。若说相应义。佛是萨芸若。亦彼妄言何义。彼念不是萨芸若。无义言名如戏笑歌。忧愁为首相应言。是口苦行

问是意苦行何法。答意苦行贪恚邪见(修妒路)念恶行。是故意苦行。是亦三贪恚邪见。彼贪名他所有欲得。问若他所有欲得贪重。说为过。念内入前已说念欲。作他作欢喜。答是不重说过。由欲得念欲得欲。作是此不欲作。他所有取。是亦由贪是他财是我有。如是着意他所有欲。得着是贪。他所有为首。念相应是贪恚。名娆他入念恚。问是何法邪见名。答邪见行果相违无有见(修妒路)行相违果相违无有见。是略三邪见分别无量因缘。谓他异取是邪见略。问是何法行相违名。答行相违净不净觉。不净净觉。俱一觉(修妒路)行相违净不净觉。不净净觉。俱一觉。彼净不净觉。着身口意行。不爱去见。不净净觉。不爱爱去俱一觉。爱不爱行。净不净去。问是果。答以是果说(修妒路)以是说苦果说如苦天上苦涅槃。如是净不净觉。趣乐世间乐。不净净觉乐。或苦趣如是俱。问云何无见名。答无见行果。众生无有见(修妒路)行无有见。果无有见。众生无有见。是三无有见。彼行无有见名如。无有与无有爱。无有善不善行作。是行无有见。果无有见名如。无有极作不极作。行果报无有地狱畜生饿鬼界。天上去众生无有见。名如无有母无有父。无有众生化生。无有世间沙门婆罗门。如是是邪见无量行。是三意苦行。无量因缘。一切无善作因缘颠倒善。是本戒去。如是解脱度说。知婆素跋度三法度二。中间初度说尽

四阿鋡暮抄解卷上四阿含暮抄解第五(首三法第二恶之二也)卷下

        阿罗汉婆素跋陀撰

        符秦西域三藏鸠摩罗佛提等译

已说恶行。云何爱名。答爱欲恚嫉妒(修妒路嫉妒憍慢其人皆以为嫉妒也)欲恚嫉妒者是三。谓之爱渴爱。彼是三象(即上三疾之根)彼三象无数行

问云何。答欲淫有着梵行(修妒路也)淫著有着梵行。著者是三欲。彼淫名五界。色声香味细滑是三象。依众生各各染着。不多着杂物。彼淫着男女。不成男(修妒路)淫想着女也。男男也女(男女各有想也)不成男也。男男也不成男(亦各各有情也)问师虽说色男中着。复言今女男不成男。何以作是语。以何不恶。答女男不成男。相因色男为本。各各著有差降。不名染着杂物。世尊亦说。我普不见一色中染着。如男女色(普者十方大千界也)女如男色。是以五男无苦。三有小中大。小者男欲。中者女欲。大者不成男。欲有中(修妒路)淫。有色有无色。有中谓着此是有着

问如淫着别说女男不成男。何故复说有着。答由结说淫著有着。依众生一切淫行法。谓淫有彼著者谓淫有着色行法色有彼著者是色有着无色行法无色有彼著者是无色有着。是故别说无苦。问云何梵行著名。答梵行著者。得无得失位希望欲得忧(修妒路)梵行著名。得希望不得。欲得失位便忧。忧以是句义过去淫有着。可知得淫。复希望不得欲得(其人云此中应有失忧)如是有着如是淫有梵行着也。各各三分便有九。若得女着希望不得。欲得得失位忧。如是男不成男可知如是淫著有九。如是有着梵行。着如是。问说今有是不闻梵行着是结。答我已说阿那含果(上已说不还有结何云梵行无结也)世尊亦说三求。淫求有求梵行求。求爱欲着此一义。复说淫梵行中所弃爱常念。问假令尔者不足行梵行无著。作如是一切自合梵行。答彼当渐行行自任行。行梵行无著。梵行福恶等度求钵赖堤彼陀。一苦乐二檀度三神通(持言奉法之第四也)不求果求果者着我。以此精进梵行当作天中天。如是行可著者此即希望。云何得梵行使得乐处。是得欲希望后世乐梵行。今以爱为乐。为爱所飘作非梵行。咄我堕落戒自悔忧。是故梵行着(爱欲竟也)问云何恚名。答恚者己亲怨相恚(修妒路)己想亲想怨想及恚是二恚。问云何恚爱句处(恚爱共合为一义何以说恚爱同句)答欲想为恚从想为爱也。彼己想四门行怨想各有四(其人云怨上当有亲字也)

问云何。答己亲未得乐望得(一也)已得乐惧失。(二也)得苦欲使失(三也)未得不欲得(四也)如是己亲各有四。怨有相违(怨亲反也)何故怨未得苦。欲令得得苦。不欲失未得乐。不欲令得得欲。令坏此怨欲坏是恚是故爱句处。问假使尔己想欲广闻。答己想者三时惧失(思惟省察修妒路也)三时名者。过去未来现在时名。如我过去所失。是故起恚意当有有(有现在也当有未来)如是己想三时惧失恚。问亲云何。答如亲己(修妒路)如是己想三时惧失。是故恚生亲想如是。问云何。答为我所爱者彼有所失。是以起恚当有有。是故起恚如是亲。问云何怨。答怨相违(修妒路)相违与彼异。若我怨乐生。是故起恚。当有有如是怨者。欲令坏三时欲灭尽是九恚

问若此恚若苦行有何差降。答恚者依因缘有。亦依十恶无智可知(恚九恼也。苦十恶之意三也。因缘亲怨也。无智十恶之八也)

问为是一切众生。九恚行为等不。答此辈住水地如画石(修妒路)此恚行住由众生。如画水画地画石。种种依众生则有得。说濡中增上如水中画即灭。地画延时。若风雨足践尔乃灭。画石石住石灭(与石俱灭)是故众生各怀恚不同。或起恚自悔。咄我辈丈夫。我辈性行。于坏法种种苦。自更自起坏法自起坏意。是以此恚自息。如画水。地亦尔。恚已起不能自除。或师知识亲觉寤。是恚得息去。如画地。次三者极。恶不思念。行意炽盛嗔恚充体。彼佛辟支佛所不能寤。唯嗔恚与身灭。如画石。此恚义。问彼云何嫉妒。答嫉妒者下等增上起妒(修妒路)贡高嫉妒相惑。复相量此彼是谓嫉妒。是为三。下愚也等愚也增上愚也。色富族术为首。我胜他是下愚。胜己者谓与己等。余者不如是等愚。我出彼上是增上愚(自谓胜上二者也)

问已说是下等增上相矣。云何是一切愚得当多种愚。不恚已说。答下妄语轻毁慢怠。(修妒路)若下嫉妒有三。如是妄语嫉妒轻毁嫉妒慢怠。彼妄语嫉妒名极意作恶自庆。复轻毁嫉妒名受他嗟叹。汝善哉有功德具。如是彼人内怀欢喜。外诈言我无是德。慢怠名昼夜眠寤。不能由人身得度生此意。是谓慢怠此三者。是下嫉妒也。问云何为等。答等者己嫉妒。憍不敬(修妒路)等我。嫉妒有三。我嫉妒憍不敬。彼我嫉妒名得受阴(一也)彼受好恶(嫉妒也)憍名供养杂种(而不受也此憍也)不敬礼师。问云何增上。答增上者甚嫉妒嫉妒中嫉妒无限嫉妒(修妒路)增上嫉妒。名甚嫉妒甚嫉妒名下等中我最胜。此谓甚嫉妒。嫉妒中嫉妒。名极妙中计我为胜。此嫉妒中嫉妒。无限嫉妒。名未得解脱言得。此无限嫉妒。是嫉妒九义。一切渴者有有中作有(有三有也)是故爱句处嫉妒。可知婆素跋陀三法。次二三度尽(于首三法之第二恶恶之三事次二也度亦尽也)

    四阿鋡暮抄解第六(三法之第二恶之第三也)

问已说爱云何无明名。答无明无智邪智疑智(修妒路)无智邪智疑智是三无明智。由口显文字亦尔。被恶口是无。(又无知也)如恶子非子如恶朋非朋。彼无智名有为无为不说无觉。(修妒路)有为无为不说无觉是无智。问有为有二。内受外受云何是受。答有为内受外受。此二事(修妒路)有为中无智。彼当知内受外受。此二事痴也。彼内受阴界处各二行己受彼受也。外受者草木垣壁为首。彼谓己受及他受外受。此二外受。知此中一一遍痴杂内受外受是无智。世尊亦说六更处无智无见是修妒路内受名受。为义行结因缘愚情。是我所是内受名。问云何无为。无为一涅槃。此是无义云何处三。答无为有余无余此二(二种举上二以为三修妒路)假令涅槃一无为。彼由行说二也。有余无余此间有余名行结得受。是身是有余是有余名。彼尽一切结灭作证尽身有余。如是有余无余名。谓此受阴弃更不受身如灯灭。是无余名。此谓一一或二愚。此无为无智。问云何不说。答不说不说受方便灭教授中。(修妒路)彼受教授方便教授灭教授。谓愚此不说无智。彼受教授名命(天竺音命与众生同也)阴界处现在受内命受是教授。谓现在受内命法受。由行结是受教授。不过去不未来。法命受教授命非一。不若干得合命及身。若是一无常苦若异常为苦。若常者不行梵行。不常者不须梵行。果受施无义无常者。无义遍断方便中二无苦吉法(师引佛方便答异道两得也)方便教授名。过去未来现在行方便教授方便教授。此方便教授名。是三时相应。如我过去时。我是衢黠王。(梵言衢黠。十名羊也眼也地也天也水也说也。方也金刚也光也剪也。如是比有十也。其人不了是十生中何也)

未来当有名无胜。现在时工师达(咒术)为首。诸行路贰暑(云商人也证三世也)是未受受已。俗数故教授以此断常。若是衢黠灭。云何我是。彼若不灭云何言是我。以世俗义说此方便教授。问云何灭教授。答受尽不受息灭教授(修妒路)受如上说。彼尽不受不侵他己息无余度此彼岸。是灭教授此断常转还如是。一若干止如用本受般涅槃教授。是亦不说。若此异者不般涅槃。若不异者不般涅槃。如是见生苦已不说已。应般涅槃如灯灭内。受一。若干苦不着受方便教授过去阴界处。本说如我名衢黠王。如是未来灭教授。谓灭受为首说。世尊般涅槃。若方便教授命不断灭。教受命常断。受教授命有无断。己说无智

问云何邪智。答邪智己身内受摸见(修妒路也摸如手摩摸也)见己身受内见摸受见。是为三邪智。邪相违非贤谄是一义。彼己身见吾我自在相应入(修妒路)五入我入自在相应入。是己身见彼五入。名幻化城野马向镜中像相似处。计有五入名我名者。假借严具树果似。亲阴计有我自在相应名坏法。芭蕉树画水上不熟器似白骨时。我富贵如空邑。使作主是己身见。此是我身我是己身。见前着入。问是内受云何。答内受断常俱思惟(修妒路)断思惟常思惟二思惟。此说内受。内受名无方便受。是义无方便外见。彼断名世间无常不是常。不是无常。外有不外有。不无外是命外。无非有无有彼命。彼身以为首。二思惟。名常外有无外有外。无不有以为首。是内受见。问云何摸受。答摸受戒见依彼(修妒路)摸受见三事生戒见二依。彼初品已说戒以是戒净。此戒受是二戒摸受(净受二也)见摸受。此是谛余者痴。是着入谛身结亦说二依。谓戒见依彼略。五阴身。彼知有或戒或见阴行净。此是戒摸受知阴。妙余不妙是。依见是见摸受

问云何疑智。答疑智珍宝谛正受疑(修妒路)珍宝疑谛疑正受疑疑名。不能持迷惑犹豫是一义。问云何珍宝。答珍宝者佛法众。(修妒路)佛法众是珍宝。如前已说。佛萨芸若一切功德具足。弃一切恶解脱。问何因故珍宝。答以上三功德是佛珍宝。如是为大慈不妄说法无因缘。为作善知识佛出难有不可思议无比法(十二部之第九)功德如是功德具足成佛。珍宝说法名方便。方便果此闻涅槃教授。是世尊一切法为最上。现诸法有为无为。彼灭最第一。修妒路。彼是珍宝为无所作。一切苦灭至竟清凉行难坏难行无尽。如是功德具足成法。珍宝僧者已说。乃至声闻。一切是亦珍宝施得广果报。用世尊语无上福田。得世尊难无能坏不相违戾。如是功德。具足成僧珍宝。此疑是疑智。问云何谛。答谛者俗数相第一义。(修妒路)俗数谛相谛第一义谛(此中说无解解在下正受无首也)所谓疑是疑智。正受四解脱二观处(地水观也四色观四无色定观并十想也)二直无漏前五想(取十漏之前五)第二第八解脱。谓彼知界正受此非持功德。是疑智是苦苦也(重苦者苦而不知苦也)如是习尽道如是。四谛颠倒欲界色界无色界是有十二行。(颠倒疑也)如疑智受义亦尔(欲恚慢爱之三也)无智邪智义邪见此别苦行说。彼见摸受己身身内受见苦也。三界戒摸苦道(疑邪无智无明三也邪戒摸习)积聚说婆三跋陀二法。次二内受三度尽。(内受是第二之三竟法名也。爱三无明三六使也。故结九十八)

    四阿含暮抄解第七(首三法之三也)

问已说功德亦说恶。云何依名。答依阴界处(修妒路也)阴界处者是名依此相。依是故依依立。是义阴者界者处者。此众生依作相应功德及恶。故是依功德恶可知。问云何阴名。答阴者色行智(修妒路)色行智是阴可知。阴积聚束是一义。此青黄赤白一长短。小大圆四方。以是为首。解色义。所生物姓受色阴。知彼色有是受。是色二义可见不可见可见属眼不可见异。彼声香味细滑风。如是以为首(是五事皆不可见)问已说。诸大彼受诸大。未知云何知色受。答诸大地水火风(修妒路)此地为四首诸大相。此是色一一等坚地也。湿水也暖火也动摇风也。此诸大受彼色烟云。尘雾影光镜像五根净。以为首(色五情也)

问已说色阴云何行。答行者身口意依(修妒路也)身是依是故依身口是依。是故依口意。是依是故依意此身口意依已依也。此是行有为所作。是故行修妒路说。色有为此复。以色成有为行(行是色也)如谷子成谷子。如是知五阴。彼无数彼。是阴说如谷聚薪聚。彼福无福不纯淑行

问云何智名。答痛想识(修妒路)痛想识此三道品法。不为他界所取(不为六欲所牵也)世尊亦说。谓忍则想知。谓想知则智(忍则知痛知痛智所了也)此法杂是修妒路。问云何痛名。答痛者乐苦不苦不乐(修妒路)痛者痛之声以此痛(痛无形故云声)余命不相应。若此痛痛此命相应。是故言痛。痛字亦尔。彼痛有三。苦乐不苦不乐。是故各各生苦因。乐生乐因。苦生俱因。不苦不乐。世尊亦说乐痛者。苦分苦乐。不苦不乐。苦乐分。各对是义。问云何乐名。答乐淫不恶止生(修妒路)谓乐说此有三。淫生不恶生止生。彼淫生有五界。爱淫界乃至欢喜不恶生。不彼谤是义。此是善出家者。义戒戒想意不变悔是想。谓爱此是不恶生。止生。根为首。五盖得解脱无乱念。禅等为首。念行是想。谓念欢喜。此止生(自守也)止生名谓。无热根。义中不着(不受也)止生亦尔。说此是三乐痛。问云何苦。答苦者生老死(修妒路)生老死者此是苦痛。彼生名苦。如生疽老。如熟疽死。如疽内溃流入支节。若生已有一切苦。此是生苦。世尊亦说。生已截手为首。老苦色变。力消如压(如压油也)死苦一切所爱财物。离为首苦痛。问云何不苦不乐。答不苦不乐者。谓三界(修妒路)此不苦不乐痛。此有三当知。不苦不乐苦乐相对界中。当说前三界。说前二苦乐痛。不苦不乐三界。是知欲界有三色界。二乐。无苦乐无色界。一不苦不乐。是故此一切界相应。问云何此依。答乐依欲为妙。苦依恚为妙。不苦不乐痴为妙。何故此有乐痛。谓无欲欲已尽如三禅苦。如世尊头痛枪脚不起恚。不苦不乐第四禅。及四无色。彼痴稍尽。是故如相应说。问此从何所起。答彼因缘行界生(修妒路)彼苦乐不苦不乐痛行生因缘生界生。如是为九若卒遇痛。问因缘无数为尽。是因缘也不尽是乎。答因缘生福无福无余随数(修妒路)此苦乐不苦不乐痛因缘生。彼因缘有。三福无福无余随数相应。福是乐不福。是苦无余。不苦不乐。彼福者苦行对三禅也。无福苦行无余。第四禅及无色也。问如福说施戒分别也。如师说分别禅等无色。是一向说福乐。答此彼受言所伤。(受三禅也)如与比丘三衣。持钵与佛图罗刹(喻也。衣与比丘者非一人以喻十二门。钵与觉护喻一切三禅也)不与佛图罗刹比丘三衣也与钵耳。若复有胜佛图罗刹比丘者。三衣与如是分别禅等。无色福三禅。受福三禅分别。受异他与是故禅福无所伤。问此行生云何。答行生者。己身他行俱(修妒路)行痛有三。己身想他想行有二。知乐想苦想。如自刀刺己也。若已栴檀用涂(自治)他想彼系首破乐俱想语。他为我刺头治涂以此为首(俱两也刺弹首凿凿首如是比也)

问此界生云何。答界生者时患卒遇。(修妒路)问界异说欲色无色为是界。答此非是界。除众生。此是因缘。略举要有三想。时患卒遇是界想。彼时名。夏冬春(修妒路)夏时冬时春时。此三时知也。痰夏时聚(风增唾减)唾冬时聚(风增痰息也)风春时聚。(痰增唾息)如方说时想。苦乐痛有。问云何患为如苦行。爱痴如所说说耶。答此不也。是法身相对耳。此说依大身异。彼患风澹唾(修妒路)此是风痰唾患大身。彼想痛有。问此云何卒遇。答卒遇除众生因(修妒路)卒遇名除众生因。苦痛生垣墙树山崖崩为首。所因众生。斯已他俱入内。此痛义智。问此云何想名。答想有想无想有所有相(修妒路)想。增益相似说。此中随修妒路。以想为首增益相。是义彼想名。及依是义无。想无依。如众多瓶。或有言此是糗瓶。此是酥瓶。以此想得分别。此中无糗无酥。空是无想受。如是声为首想。增益受声为首。除是受无所有名。此非所有。如是相欲为首说所有。彼杂欲者欲解脱处。知相无所有知相。若虚空识处受。无想有想无想处想杂想。无所有无所有智相。问此识云何。答识者欲起成未成门行(修妒路)无色俱依因缘。可得识种种识。是识各二识(心识与根识六情皆尔)此是三起。成门不成门。行依俱依因缘可得。此三因缘起世尊演行因识。若复名色因识。若复眼因色起眼识。此是三行所作。是故彼起阴阳精合在母胎识生。此是生生因行在胎中稍长聚(藕叶上水也)转长。(如小指状也)渐凝凝为首(转厚)未成门谓识是名色因(六情未成为名色因)若复成门未灭。灭正受因根义识生。此二依因缘依一义不异依得识。是故因缘。得问何故重说智。前说戒息智。依何故复说智。答依智所布依智。是二此中依智。彼依智如戒分二说。如是此知。是故无所伤婆素跋陀三法。次三初度说竟也

    四阿含暮抄解第八(第三之二也)

问已说阴。云何界名。答界者欲色无色(修妒路)欲界色界无色界者。此是三界持。彼此行是故界也。此一切众生受。至不般涅槃无余。问云何此欲界名。答欲界者人天趣(修妒路)人天趣取要此欲界。欲此间持。是故欲界若与欲是故欲界。问云何人。答人者女男命根相四方依(修妒路)女根相男根相命根相。此一切人也。彼一切四方依。彼女有女根义也。男有男根也。问命根相。为非男非女乎。而别说命根耶。答虽说男女命根相。余处有异不成男。不应女相。不应男相。唯知有命根相。阴阳精合(藕叶上水状也)凝聚转长转坚命相趣。未成男女根。是故异。问云何方名。答方者阎浮提。弗婆鞞提。衢陀尼。郁怛。鸠罗婆者。彼谓如方相。弗婆鞞提次衢陀尼。郁怛鸠罗婆。南阎浮提。此辈如寿数乐。有限诸具为首。有异(其居生之具也)转上转上妙

问天有二行淫弃结。此二何者是。答天执手。口义见行淫(修妒路)行淫此受弃结不复入。此天有三行。淫行执手行口义行(言语成淫)见淫行彼口义淫行化乐。此染着意。女亦染着。共语言顷如是便欲生。若一染着不成淫。如此间执。男如不相染。如母姊女相抱耳。他化己所爱男俱乐。是故化染。(五天淫也。男女同欲便化。已令前人悦之。而共言语成淫也)见行淫他化自由相应。彼如展转相染念展转相视。如是淫生。有不染视。如己他化自由相应。是故他化自由相应(六天见他化着之以成淫也五天自化而成淫)问已说口见淫行。前不说执手行淫。答执手行淫有二相抱执手(修妒路)谓执手行淫天。彼有三俱行淫。相抱行淫。执手行淫。彼俱行后。当说相抱行淫名焰摩。彼展转相染意。如抱女寻淫生。独一染着。如此间相抱乐。彼如是得不着意。如尊长夜起乐喜意。是故焰摩(秦言夜半)问云何执手行淫。答兜率陀彼展转发淫。如女共执手行如是淫生。独一染着。如相抱不染着。如尊长自有侍从喜是故名兜率陀。(秦言止足。天不犯他淫梵曰自。有己慧不仰人。故曰自也)问云后当说俱行此云何。答俱行者。三十二(第二天也)大王地(修妒路)有二着二淫此一切淫行。依二彼行义。此二想师说。如人彼三十三须弥顶。彼如人行淫四大王。游乾陀罗。上(秦言持天地也)彼亦如人地者。此间地树河山上居处。爱所欲得。此一切天如所说。有下风而无便利转上。转上两倍乐。此辈天欲界住者

问趣云何。答趣者地狱畜生饿鬼(修妒路)地狱畜生饿鬼。此是三趣无善趣故恶趣。彼地狱寒热因缘想(修妒路)寒地狱热地狱因缘想。地狱狱一义极苦。是故地狱中无可乐。是故地狱。彼多种此当说。彼寒地狱者。能语不了语不语(修妒路)三语相。寒地狱能语不了语不语。极多语。彼能语者。字可了。是故能语。问云何能语。答能语頞浮陀。(秦言卒起)尼赖浮陀(秦言不卒起)阿波簸(秦言战修妒路)此三寒地狱能语。彼卒起者。(数拘利至百为一次复至百如是五名卒起)数为声如十摩竭(国人也)胡麻担一担二十聚也。念百岁取一胡麻此时犹可尽。尔许百岁。彼卒起地狱众生命如此。四掬成一。升四升成一独笼。奈十六独笼奈成一佉。隶(取也)二十佉隶。成一担。如是命为十倍。成不卒起。以此十倍作已余者亦尔。知若不卒起。中以寒身体疱着生。是故不卒起(无数疱着身也)身无空处疱满。是故不卒起。战狱名寒内松落。作尔战唤阿波波。问云何不了语。答不了语者。阿吒鸺吒鸺优钵(修妒路)此三不了语。大逼迫时不耐苦。称阿吒鸺吒鸺作。如是不了皮落如优钵(皮落但有肉存)甚寒因缘合会使皮。落如优钵花。部身亦尔。彼于此间诽谤贤人。优钵罗受罪(句倒受罪如优钵)

问云何不能语。答不能语者。须揵提(极香花)拘物度(白花)分陀黎。钵暮(藕花修妒路)此四地狱。不能语。唯极冬疾风吹身令强。须揵提(修妒路)拘物度分陀黎藕花。随其象身更苦喟喘(喟音穹诡反)身战栗住此诽谤贤人。是须揵提。如是一切殃受此苦。如是。十劫尽是寒地狱十也。四方间轮围山(铁围)着(近也)上狭如覆舍人。常闇冥寒切破身。如丛大火然竹[竺-二+韋]。身声吒吒(犹骇骇貌也)如熟橘甘果自剖。展转相枨生想。此中亦有人受苦者也。一切谤贤圣受此。世尊亦说可诽贤圣者。百千堕卒起地狱心口愿恶。此是寒地狱。问云何热地狱。答热地狱者。所考掠处。少考掠处。无考掠考掠处(修妒路)热地狱有三事考掠处。少考掠处。无考掠处。考掠处行所作。此中众生。或役多役少。或自苦役。随行造此生。而受苦。彼考掠处。还活狱。市狱黑綖狱(修妒路)那耆婆(谌伊反)市狱黑綖狱。此三考掠处。还活如倒悬。羊头以斧斤破为首。狱卒削肉尽索。因缘合会冷风起肉还生。非好因缘会作苦。有钺斧大如半月。彼各各起疾。此本逼迫我。我当还逼迫之。如刈竹[竺-二+韋]虅(钺相破如此)以此怨意死便生。彼黑綖者以綖磔缚。綖磔身已段段截也。此以刀割众生身。热铜鍱遍缠其身。肉血脂流。此间以鞭众生为首。及出家者托言持戒。众檀越施与衣着亦同。此大闇冥恶烟熏倒悬驱吸。烟此间以烟熏众生受此罪。大市者手脚头鼻。为首被截也。坐在市屠罪如此。热铁地热铁火车。狱卒张目唤呼驱使走。此间牛马为首极困苦。抱持他妻令上剑树。极然为首苦此考掠也。由因缘狱卒不被烧。罪者被烧。不可思议行报。问少考掠云何。答少拷掠者。聚大啼哭被炙(修妒路)此三少考掠。彼大聚者畏狱卒无数。千众生入山内。随缘前行。自因缘值火。适还为狱卒所驱。彼两逼迫山俱合似如磨而象河。彼于此磨为首。及轮拶众生肉烂尽。(轮外国轮压油伤众生)或复以热铁臼。五百岁捣。因缘所牵命不尽。彼于此弹指顷。臼瓜拶杀虱为首(臼亦捣伤虫于此须臾臼爪彼报然)彼大啼哭者。一切皆然。山周匝崩。峻恶狱卒无事而恚。何以走不走啼不啼。如是生过。以热铁椎击破首。此间人为重事(外国考囚重者八十轻考三十六)被炙者像如浴室(尖头屋)炽然铜屑地驱使入熬使熟。熟已驱出。彼大身恶狗食其肉。食肉尽风随吹肉。复生寻驱使入。此间养蚕命存煮炙。问云何无考掠处。答无考掠处者。啼哭被炙无分米(修妒路)此无考掠处。彼啼哭大。炽然热铁象龟底极陀。展转相逼大唤呼。以盖覆大苦。于此间焚烧旷泽。作密蛇穴熏穴居者也。彼炙者大多焰相缚。铁山周匝利叉刺炙一面熟。熟已叉自转。或人自转(周匝绕)于此间锥刺人及拔翅甲也。无分米(无分米无不痛)周匝火烧。其城纵广百俞旬。热铜薄覆其上。四门纵广上下。火在其中无空缺处。寻火焰走身体烂尽。无分米不痛。于此间杀父母罗汉。起恶意向如来坏僧。若造十恶行。因缘所牵生彼。此三无考掠处也。因缘地狱彼处处河曲间。石腹间大旷泽中。受种种苦。此因缘地狱。此尽是地狱

问云何畜生。答畜生者。地水虚空行(修妒路)一切无足两足多足(修妒路)畜生地上行。水上行。虚空行。彼地行牛驴骆驼为首。水行鱼摩竭失收摩赖(收深幽反)为首。虚空行鸟及余小虫。一切无足两足多足。无足蛇为首。两足乌为首。多足牛蜂百足为首。彼种种作恶增痴行生此中。问云何饿鬼。答饿鬼无食少食大食(修妒路)此三取要言之。若干种饿鬼。问云何无食。答无食炬焰针臭口(修妒路)炬焰口针口臭口。此无食。彼炬焰口口中焰气还自烧面像。如炬柱。悭贪嫉彼受此苦果也。针口者。腹大如山。口如针孔。虽广见饮食已而不能得。臭口者。如粪臭剧烧死人臭自口。臭内熏五藏。愤胀气出无腹(无腹还小也)念食若干种。受若干苦。此是无食。问云何少食。答少食者。臭针毛咽瘿(修妒路)臭毛针。毛咽瘿。此是少食。或少得不净食。是故少食。彼毛针者。牢坚长头。利毛覆身节。各各不相近(恐相触毛入深也)毛还自刺身。如鹿被利箭。苦值得便食(逢物便啮)臭毛名极臭。毛覆身风吹自毛臭。气起熏鼻发恚意自灭毛。更此苦咽瘿名由己因缘生下转转破瘿臭脓血流而各食之。问云何大食。答大食弃吐残食大飞(修妒路)彼弃吐食有二。故与族终亡者去。(得也无种中此世种亲祀七一亲族则得食也佛答吐也)不故与者。街巷四道所遗落者。去受身如此。彼前弃及吐闻吐声。如被请走食吐以为力。天祠为首。施已。而还夺。因此生彼。彼大飞。阅又。罗刹。厌鬼。畜生。人天作形。(修妒路其人上三至厌鬼亦修妒路也)此是饿鬼火飞鬼。彼像如天。自然住由因缘。或有好衣食而不得食。无量百饿鬼营从。如亲堕狱来。见诸亲大愁苦欲吐。以此为患(如天一也好食二也无量三也)畜生人天。此饿鬼畜生形。人形天形。若干种行所致。此欲界中

问云何色界中答。色界中及念无念乐护行(修妒路)色界名彼无欲。但由禅使然。除嗔恚得柔和色。净如金。此是界义。此及念行无念行。苦乐灭护行也。及念者乐。是故及念除念。是无念除苦乐息也。观疾转高解脱。如御马车。问云何及念。答及念及念。自觉无觉自行(修妒路)及自觉是自觉除。自觉无觉也。乐如是如此禅说自觉初也。无行二也。无觉初二中间。此禅行色界生也。随众生为说禅。问云何自觉生。答自觉者。梵富酸(净师)梵迦夷(净身)梵波梨沙(眷属修妒路也)自觉行禅已生彼中。净师净身净眷属生。已下中上随其乐。大梵无觉生。无觉无行义。问云何无行。答无行者。波栗阿婆(少光)阿波摩那阿婆(无量光也)阿婆嘬罗遮(光音速末反修妒路)无行及念乐生此天。少光无量光光音。此名随所欲。或杂想口语光出少。是故少光。口出光多故言无量。清净无量故言光音(清净口言明净)问已说念乐。云何无念。答无念彼栗多首波(少净)阿波罗摩那(无量净)首波首波讫栗那(修妒路遍净)无念也乐禅俱去(得也)生彼三天。彼少净名少是一义。此是少功俱去少。三禅生少净天。如是少乐报中。中无量净生上生遍净。问云何护行(自守)答护行护乐。无想首陀跋婆(净居也修妒路)护俱去(得也)有三行有想想灭觉相应。彼护乐者鞞疑呵破罗想天(果实天也)首阿跋娑护乐生。是故护彼如上中下果实。知阿先如萨倕(都戈反无想)净居彼果实。第四禅下中上功大生彼(下生无果天中生福光上生果实天也)以此想灭俱生无想天(披罗门谓涅槃者)彼念想识灭。彼想谓结尽。无复垢。唯有色身行身一处(猗灭行往故不免生老故曰行身有四事)彼死起想生来。(披罗门自谓此天为般涅槃知命将终谓圣见欺故生恶道也)问云何净居名。答净居者修提舍(善见天)须提舍那(善好见)鞞首陀(清净天上中下也修妒路也)净居名诸结尽。此功德名耳。问五净居地。何以说三。答清净阿鞞丽舍(卢鸡反)阿答波阿迦贰吒。(一究竟天上之上中下也空定亦上中下三天阿那含生之并八天也修妒路)无所触。无熟一究竟。此三清净知。分清净为三故。有五色说色界

问云何无色界。答无色界。已说上分别无色界。已说彼分别。来生无色界。是无色界。是间正受。然后生彼。如是作已。道果。有如稻穬子成果实。婆素跋陀三法。次三说二度尽

    四阿含暮抄解第九(第三之三也)

问已说阴界。云何为处。答处更乐异学解脱处(修妒路)更乐处名异学处解脱处。此三处依义如天处。若出家殷勤。彼此得睹见恐惧。是故处。问云何是谁处。答功德恶俱(修妒路)彼功德解脱处。恶异学处俱更乐处。此着意而行恶清净意发功德行。问云何更乐处。答更乐处。近着不近着。行不行(修妒路)更乐处近着行不近着行无行行。是义此间因缘说如相应。即是行近着此行。是故近着行如是。不近着行知。问云何近着行。答近着行者。鼻舌更乐(修妒路)鼻舌更乐。此是着行鼻香入鼻内而受香。香是鼻行。虽花在远。花香犹入鼻而受香。香亦是色。若北风香至南而不还北。是故花香入鼻受。味亦如是。味着舌已而受味。不在器中。如是更乐。更乐身根。是亦入行细滑重轻软坚卒寒热(细滑八事)以此以此行着受。是故近着行。问云何不近着行。答眼耳意(修妒路问已下十一字其人着)眼耳意。此三不近着行。问眼亦少着受境界。耳亦如是。耳入蚊蚋声受意。亦无色当云何知不近着行。答以是故不近着说。所谓不近着界受。问云何齐限不近着。答无齐限。此间月在四十千俞旬住受见。或五里处住。随力根见在故近着行。不近着行。但界见受不蜱(逋鸡反)入眼受即离则受如是耳。离受声。不逼耳得受声。是亦随根力受意。无色无有远近。是故不近着行说。问云何无行。答无行己他受无受(修妒路)己受他受无受此无行。彼己受者色为首。他受者及余六色声香味细滑(其人云宜有声)无受墙为首。螺声优钵香为首。等无有行。是故无行。此是余行无有因缘。此是五界无因缘。有是他因缘法义多

问已说无行行更乐处。云何异学处。答异学处者。一处崄伪无义论(修妒路)一处义论。崄伪义论。无义义论。此略要异学处三。一义彼一处义论。名如因提幢幡竿。八人举在中。或有说禘跋达提持来。或言天与谛在中不独举(一人言)虽多无一人不得举(虽多已下更答独举)作如是说。一处义论。何以故义有三前因缘报(一人言也言专前世所为也)现在人所造(其一人言若专前世何用现在所造然也)他喜与财(其一人喜施财天使之言然也)此中因缘至此现一处义论。崄伪义论名如彼因提幢旛竿。或言非人举来唱齐所致。此是义崄伪义无义论。名如因提幢幡竿。此非人举来。问云何一处义论义。答一处己他人所造及能论(修妒路)已人所造有二宿命因缘所造。今命所造彼及宿命所造。当知是因缘受报想天所与。如是义有三。如上说。彼若言因缘人所造。他喜与财作如是说。一义论所造因缘辈无人。所造无反复不可信此辈不。足往来若缘。所作如是。一切无所作如是为首恶。问云何崄伪。答崄伪义众生法。俱根义想(修妒路)崄伪。义论。众生论。法论。俱论。彼众生法相应。众生所作。净不净。若少作众生法所作。此是崄伪义论。非众生作非法所作。非俱所作。(上非上宜有何以故)问云何众生根义想。答众生梵摩末恕婆卢频糅(八臂神也)论(修妒路)众生所作如梵摩所作末恕婆卢(主地神也)所作频糅。所作如是论。不知观梵摩论者。言梵摩造虚空。虚空造风。风作水。水作地。地作草木。众生如是前梵摩作论。此一切是恶。若梵摩作虚空地者。住何所处而作空地也。若展转作者事违。如是为首恶也。末怒婆卢频糅亦尔。问云何法。答法者时微性论(修妒路)时作一切。微作。性作。此三法义论。彼时论名是一切。皆时之所生。是一时皆时之所成熟也。是一切皆时之所亏。是一切皆时之有为(首卢)诵此伪偈彼不相应。一处如上说不足。往来彼于此合(上四事同故)或生意此亦时所作。此不相应。何以故空无所有。时自亦空教他所作不合。如是恶也。微者亦不合。彼无念此事不相应性。亦如是性。若有起非性事。若无者无义。若无义有所起。如是一切有者。性有何差降。若卿生此意性有常。此不相应。无常者不变如是恶也(性者常然也常然则无然不然故曰不变也)

问云何无义。答无义者自然强伏无所有(修妒路)无义论有三。自然论。强伏论。无所有。彼自然论者。自然有生。不有余想。刺如利无有。人利之者以此为首。强伏论名随物欲生。如大水泉源草木枝叶堕中聚作一抟。此是强伏随风来。或吹向北或复东西如是种随所欲起。无所有名空尽无所有。有何相应。何者相应都无所。有此辈尽是。恶何故若自然有。者子不生也。田作水溉灌。以见时为首。若无是者子不得生。是故不自然。一切作所致报

问已说异学处。云何解脱处。欲解脱处想禅诵(修妒路)想禅诵此是解脱处。解脱恶尽彼解脱。此三处依。是义依。此已得解脱想因缘。是义彼想依。辟支佛得解脱前品已说禅此当知彼亦依声闻。而得解脱。问云何诵。答诵者说听讽诵(修妒路)说听讽诵。彼说名随所闻法说。如所闻法受讽诵。随所闻章。而转诵之。问已说讽诵修妒路阿毗昙鼻贰。何故重说。答此亦分作三讽诵。三事得果。说时听时诵时。佛弟子有四谛受生。(戒度也)施受俱来。(施度也)灭受俱来。(禅度也)慧受俱来。(智度也)此如是相应。谛听得解脱施。说得解灭。坐禅得解慧。讽诵得解。是故解脱处义。如是三法相应。观无乱意。欲求无为次第得解脱。解脱义斯慧者。生世尊世。婆素跋陀。三法。次三诵。三法度尽。尽三法度记曰。听我说偈。偈千二百(偈三十二字首卢也偈人读佛则二十七字也梵本四十六叶一叶二十八首卢)

四阿含暮抄解卷下


文殊师利菩萨问菩提经论(一名伽耶山顶经论)

    No. 1531

文殊师利菩萨问菩提经论卷上(一名伽耶山顶经论)

        天亲菩萨造

        元魏天竺三藏菩提流支译

  见诸众生烦恼缚　　起菩提愿为救拔
  如是正觉慈悲尊　　顶礼造论释经故
  我论能尽烦恼怨　　救护诸有断恶道
  如是二种最胜利　　一切外道论中无

此修多罗所摄有九分。一序分。二所应闻弟子成就分。三三昧分。四能观清净分。五所观法分。六起分。七说分。八菩萨功德势力分。九菩萨行差别分

如是我闻。一时婆伽婆。住伽耶城伽耶山顶塔初得菩提。与大比丘众满足千人俱。其先悉是辫发梵志。应作已作所作已办。弃舍重担逮得己利。尽诸有结正智。心得解脱一切心得自在。已到彼岸皆是阿罗汉。诸菩萨摩诃萨无量无边。皆从十方世界来集。有大威德。皆得诸忍诸陀罗尼诸深三昧。具诸神通。其名曰文殊师利菩萨。观世音菩萨。得大势菩萨。香象菩萨。勇施菩萨勇修行智菩萨等而为上首。如是诸菩萨摩诃萨。其数无量。并诸天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等大众围绕

论曰。如是我闻一时等。集法者语。住伽耶城者。示现所住处成就故。伽耶山顶者。示现彼形相大众行住处故。塔者示现为彼能供养者兴供养故。初得菩提者即彼成佛时故。与大比丘众者。以其大故以不增不损故。满足千比丘辫发梵志者。此明学无学比丘。是名听者成就。余者次说诸菩萨行差别。彼菩萨行有二种摄法所摄。何等为二。一者因摄。二者果摄。又伽耶山顶塔者。根本序分。以无量诸佛所住处故。示现彼处诸佛如来集故。此法门者。诸佛如来所摄护故。应闻此修多罗者摄取成就。学无学其先悉是辫发梵志

又无学者有八种德。何等为八。一者所作毕竟。如经应作已作故。二者毕竟过于应作已作。如经所作已办故。三者远离三昧障。如经弃舍重担故。四者舍离所受重担。如经逮得己利故。彼重担者所谓五阴。五者证涅槃。如经尽诸有结故。六者过三界。如经正智心得解脱故。七者依不颠倒受教修行。如经一切心得自在已到彼岸故。以善远离诸烦恼故。八者如实修行四如意足。如经皆是阿罗汉故。又阿罗汉者能受信者。所施物故故名应供。又学有二种何等为二。一者善毕竟持戒学道故。二者如心所求毕竟满足故次说三昧分

经曰。尔时世尊独静无人。入于诸佛甚深三昧。观察法界

论曰。入三昧观察者。示现非是思量境界故。又入三昧者。示现不同声闻辟支佛故。此明非声闻辟支佛境界故已说三昧分。次说能观清净分

经曰。而作是念我得阿耨多罗三藐三菩提。得一切智慧所作已办。除诸重担度诸有险道。灭无明得真明。拔诸箭断渴爱。成法船击法鼓。吹法螺建法幢。转生死种示涅槃性。闭塞邪道开于正路。离诸罪田示于福田

论曰。能观清净者。示现已得菩提故。如经而作是念我得阿耨多罗三藐三菩提故。得菩提者。示现胜彼声闻辟支佛证智故。如经得一切智慧故。彼得一切智慧者。有十七种何等十七。一者本愿满足。如经所作已办故。二者舍离所取重担。如经除诸重担故。又重担者所谓五阴。三者善断一切诸烦恼障。如经度诸有崄道故。四者善断一切智障。如经灭无明故。五者证如实妙法。如经得真明故。六者离一切邪箭。如经拔诸箭故。七者离诸颠。如经断渴爱故。八者成就出世间慧。如经成法船故。九者转妙法轮。如经击法鼓故。十者出无我妙声善能降伏一切诸魔。如经吹法螺故。十一者善能降伏一切外道。如经建法幢故。十二者善断一切诸结因缘。如经转生死种故。十三者说世间出世间妙法。如经示现涅槃性故。十四者善能远离颠倒取相。如经闭塞邪道故。十五者转八圣道。如经开于正路故。十六者善能远离外道福田。如经离诸罪田故。十七者示现三宝福田。如经示于福田故已说能观清净分。次说所观法分

经曰。我今当观彼法。谁得阿耨多罗三藐三菩提。以何等智得阿耨多罗三藐三菩提。何者是所证阿耨多罗三藐三菩提法

论曰。以何等人能证菩提。以何等智能证菩提。何者是所证菩提。观彼三法。于三世中虚妄分别无有实体

经曰。为以身得为以心得。若以身得。身则无知无觉。如草如木如块如影。无所识知四大所造。从父母生其性无常。假以衣服饮食卧具澡浴而得存立。此法必归败坏磨灭

论曰。经言为以身得为以心得者。示现身心不证菩提故。此明何义。以离身心更无实者。如愚痴人虚妄分别。无有如是证菩提者故。以何等人能证菩提。彼法于三世中虚妄分别无实体者。以非身得菩提示现。有八种法示现彼身不证菩提。何等为八。一者无作者。如经若以身得身则无知无觉故。二者虚妄取相成就。如经如草如木如块如影故。三者远离诸想。如经无所识知故。四者以诸因缘和合故生。如经四大所造故。五者体本不净。如经从父母生故。六者念不住。如经其性无常故。七者如危朽物不可常保。如经假以衣服饮食卧具澡浴而得存立故。八者体是不实。如经此法必归败坏磨灭故已说非身得菩提示现。以何等人得菩提者。彼法于三世中虚妄分别无有实体。次说以何等智能证菩提。彼法于三世中虚妄分别无实体者。以非心得菩提示现

经曰。若以心得。心则如幻从众缘生。无处无相无物无所有

论曰。有六种法示现彼心不得菩提。何等为六。一者见颠倒法虚妄诳惑愚痴凡夫。如经心则如幻故。二者依善不善诸因缘生。如经从众缘生故。三者无定住处。如经无处故。四者虚妄分别取相实不可得。如经无相故。五者自性空。如经无物故。六者远行。如经无所有故。已说非心得菩提示现。以何等智得菩提者。彼法于三世中虚妄分别无有实体。次说何者是所证菩提。彼法于三世中虚妄分别无有实体

经曰。菩提者但有名字。世俗故说。无声无色无成无行无入。不可见不可依。去来道断过诸言说。出于三界。无见无闻无觉无著。无观离戏论。无诤无示。不可观不可见。无向无字离言语道

论曰。经言菩提者但有名字世俗故说者。示现可证法但有名。用虚妄分别。其体无实故。彼但有名字世俗故说。有二十三种。何等二十三。一者无事。如经无声故。二者过觉境界。如经无色故。三者诸法体空。如经无成故。四者离诸相。如经无行故。五者过一切世间凡夫境界。如经无入故。六者过识境界。如经不可见故。七者无可依处。如经不可依故。八者不生灭。如经去来道断故。九者过一切世间名字。如经过诸言说故。十者善不善行诸法不可得。如经出于三界故。十一者离见者。如经无见故。十二者过耳识境界。如经无闻故。十三者过意识境界。如经无觉故。十四者不住。如经无著故。十五者如虚空。如经无观故。十六者无为。如经离戏论故。十七者无诸患离诸漏。如经无诤故。十八者过小智境界。如经无示故。十九者无量。如经不可观故。二十者他不能见。如经不可见故。二十一者内心无知。如经无向故。二十二者无物可见。如经无字故。二十三者不可说。如经离言语故

经曰。如是能证菩提者。以何等智证菩提者。所证菩提法者。如是诸法但有名字。但假名说。但和合名说。依世俗名说。无分别分别说。假成无成。无物离物。无取不可说无著。彼处无人证。无所用证。亦无法可证。如是通达是则名为得阿耨多罗三藐三菩提。无异离异无菩提相

论曰。次说云何证菩提者。彼亦但有假名名字。依世俗说。虚妄分别无实体故。彼依世俗名说有六种。何等为六。一者不实分别。如经无分别分别说故。二者体空。如经假成无成故。三者我不可得。如经无物离物故。四者过世间慧。如经无取故。五者过言语道。如经不可说故。六者远离我我所。如经无著故。又经言。彼处无人证无所用证亦无法可证。如是通达是则名为得阿耨多罗三藐三菩提者。此明何义。明能证人明所用证智明所证境界。彼如是法以何等法用妙正智慧。如实知所见所知所证。是名得阿耨多罗三藐三菩提故。又经言。无异离异无菩提相者。此明何义。无异离异二句。明彼证法清净寂静故。无菩提相义如向所说。已说所观事分次起分者。此中复有何义。以三昧事讫故。以说时至故。是故应起。又于此中有二种义。一者以三昧中所观察义。欲为文殊师利说故。二者文殊师利问如来答故。何故如来唯告文殊师利而不告余者。以依对文殊师利说此法故。又复何故唯对文殊师利说此法门。以此所说法门深故。是故告彼深智慧菩萨。又何以故唯文殊师利问。以如来但告文殊师利故。是故文殊师利问随顺义故。彼所发问。以心清净问答清净故。次显说分

经曰。尔时文殊师利法王子在大会中。立佛右面执大宝盖以覆佛上。时文殊师利默知世尊所念如是。即白佛言。世尊。若菩提如是相者。善男子善女人云何于菩提发心住。佛告文殊师利。善男子善女人应如是知菩提相而发心住。文殊师利言。世尊。菩提相者当云何知。佛告文殊师利。菩提相者出于三界。过一切世俗名字语言。过一切向无发心发。灭诸发是发菩提心住。是故文殊师利。诸菩萨摩诃萨过一切发是发心住。文殊师利无发是发菩提心住。文殊师利发菩提心者。无物发住是发菩提心住。文殊师利发菩提心者。无障碍住是发菩提心住。文殊师利发菩提心者。如法性住是发菩提心住。文殊师利发菩提心者。不执着一切法是发菩提心住。文殊师利发菩提心者。不破坏如实际是发菩提心住。文殊师利发菩提心者。不移不益不异不一是发菩提心住。文殊师利发菩提心者。如镜中像如热时焰如影如向如虚空如水中月。应当如是发菩提心住

论曰。彼发清净有九种。何等为九。一者舍一切戏论。如经文殊师利。无发是发菩提心住故。二者舍取诸法。如经文殊师利发菩提心者。无物发住是发菩提心住故。三者如虚空。如经文殊师利发菩提心者。无障碍住是发菩提心住故。四者寂静。如经文殊师利发菩提心者。如法性住是发菩提心住故。五者舍取常无常相。如经文殊师利发菩提心者。不执着一切法是发菩提心住故。六者不毁道不舍道。如经文殊师利发菩提心者。不破坏如实际是发菩提心住故。七者离谤离着。如经文殊师利发菩提心者。不移不益不异不一是发菩提心住故。八者入一切法一相。如经文殊师利发菩提心者。如镜中像如热时焰如影如响如虚空如水中月。应当如是发菩提心住故。又如实修行般若波罗蜜。余四句过三界等者。如前所说应知。已显说分。次说菩萨功德势力分

经曰。尔时会中有天子名月净光德。得不退阿耨多罗三藐三菩提心。问文殊师利言。诸菩萨摩诃萨。初观何法故行菩萨行。依何法故行菩萨行。文殊师利答言。天子。诸菩萨摩诃萨行。以大悲为本为诸众生。天子又问。文殊师利。诸菩萨摩诃萨大悲。以何为本。文殊师利答言。天子。诸菩萨摩诃萨大悲。以直心为本。天子又问。文殊师利。诸菩萨摩诃萨直心。以何为本。文殊师利答言。天子。诸菩萨摩诃萨直心。以于一切众生平等心为本。天子又问。文殊师利。诸菩萨摩诃萨于一切众生平等心。以何为本。文殊师利答言。天子。诸菩萨摩诃萨。于一切众生平等心。以无异离异行为本。天子又问。文殊师利。诸菩萨摩诃萨无异离异行。以何为本。文殊师利答言。天子。诸菩萨摩诃萨无异离异行。以深净心为本。天子又问。文殊师利。诸菩萨摩诃萨深净心。以何为本。文殊师利答言。天子。诸菩萨摩诃萨深净心。以阿耨多罗三藐三菩提心为本。天子又问。文殊师利。诸菩萨摩诃萨阿耨多罗三藐三菩提心。以何为本。文殊师利答言。天子。诸菩萨摩诃萨阿耨多罗三藐三菩提心。以六波罗蜜为本。天子又问。文殊师利。诸菩萨摩诃萨六波罗蜜。以何为本。文殊师利答言。天子。诸菩萨摩诃萨六波罗蜜。以方便慧为本。天子又问。文殊师利。诸菩萨摩诃萨方便慧。以何为本。文殊师利答言。天子。诸菩萨摩诃萨方便慧。以不放逸为本。天子。又问。文殊师利。诸菩萨摩诃萨不放逸。以何为本。文殊师利答言。天子。诸菩萨摩诃萨不放逸。以三善行为本。天子又问。文殊师利。诸菩萨摩诃萨三善行。以何为本。文殊师利答言。天子。诸菩萨摩诃萨三善行。以十善业道为本。天子又问。文殊师利。诸菩萨摩诃萨十善业道。以何为本。文殊师利答言。天子。诸菩萨摩诃萨十善业道。以持戒为本。天子又问。文殊师利。诸菩萨摩诃萨持戒。以何为本。文殊师利答言。天子。诸菩萨摩诃萨持戒。以正忆念为本。天子又问。文殊师利。诸菩萨摩诃萨正忆念。以何为本。文殊师利答言。天子。诸菩萨摩诃萨正忆念。以正观为本。天子又问。文殊师利。诸菩萨摩诃萨正观。以何为本。文殊师利答言。天子。诸菩萨摩诃萨正观。以坚念不忘为本

论曰。诸菩萨摩诃萨功德势力有二种。何等为二。一者如心所求一切满足。二者无障碍乐说辩才说法。如心所求一切满足者。以起上上胜胜法故。彼起上上胜胜法者。有十四种。何等十四。一者受教不忘。如经天子又问文殊师利。诸菩萨摩诃萨正观以何为本。文殊师利答言。天子诸菩萨摩诃萨正观。以坚念不忘为本故。二者善取正教观有为法。如经天子又问文殊师利。诸菩萨摩诃萨正忆念以何为本。文殊师利答言。天子诸菩萨摩诃萨正忆念。以正观为本故。三者无彼处过。如经天子又问文殊师利。诸菩萨摩诃萨持戒以何为本。文殊师利答言。天子诸菩萨摩诃萨持戒。以正忆念为本故。四者不随顺诸过。如经天子又问文殊师利。诸菩萨摩诃萨十善业道以何为本。文殊师利答言。天子诸菩萨摩诃萨十善业道。以持戒为本故。五者善修十善业道。如经天子又问文殊师利。诸菩萨摩诃萨三善行以何为本。文殊师利答言。天子诸菩萨摩诃萨三善行。以十善业道为本故。六者身口意业三法清净。如经天子又问文殊师利。诸菩萨摩诃萨不放逸以何为本。文殊师利答言。天子诸菩萨摩诃萨不放逸。以三善行。为本故。七者戒清净。如经天子又问文殊师利。诸菩萨摩诃萨方便慧以何为本。文殊师利答言。天子诸菩萨摩诃萨方便慧。以不放逸为本故。八者随顺利益一切众生。如经天子又问文殊师利。诸菩萨摩诃萨六波罗蜜以何为本。文殊师利答言。天子诸菩萨摩诃萨六波罗蜜。以方便慧为本故。九者满足一切助菩提法。如经天子又问文殊师利。诸菩萨摩诃萨阿耨多罗三藐三菩提心以何为本。文殊师利答言。天子诸菩萨摩诃萨阿耨多罗三藐三菩提心。以六波罗蜜为本故。十者不疲倦。如经天子又问文殊师利。诸菩萨摩诃萨深净心以何为本。文殊师利答言。天子诸菩萨摩诃萨深净心。以阿耨多罗三藐三菩提心为本故。十一者业果清净。如经天子又问文殊师利。诸菩萨摩诃萨无异离异行以何为本。文殊师利答言。天子诸菩萨摩诃萨无异离异行。以深净心为本故。十二者修行清净。如经天子又问文殊师利。诸菩萨摩诃萨于诸众生平等心以何为本。文殊师利答言。天子诸菩萨摩诃萨于诸众生平等心。以无异离异行为本故。十三者作利益一切众生清净。如经天子又问文殊师利。诸菩萨摩诃萨直心以何为本。文殊师利答言。天子诸菩萨摩诃萨直心。以于一切众生平等心为本故。十四者心清净。如经天子又问文殊师利。诸菩萨摩诃萨大悲以何为本。文殊师利答言天子诸菩萨摩诃萨大悲。以直心为本故。又经言。尔时会中有天子名月净光德。得不退阿耨多罗三藐三菩提心。问文殊师利言。诸菩萨摩诃萨。初缘何法故行菩萨行。依何法故行菩萨行。文殊师利答言。诸菩萨摩诃萨行。大悲为本为诸众生。如是等修多罗。从后向前解释应知。已说如心所求一切满足。次说无障碍乐说辩才说法

经曰。天子又问。文殊师利。诸菩萨摩诃萨有几种心。能成就因能成就果。文殊师利答曰。天子。诸菩萨摩诃萨有四种心。能成就因能成就果。何等为四。一者初发心。二者行发心。三者不退发心。四者一生补处发心。复次天子。初发心如种种子。第二行发心如芽生增长。第三不退发心。如茎叶华果初始成就。第四一生补处发心。如果等有用。复次天子。初发心如车匠集材智。第二行发心。如斫治材木净智。第三不退发心。如安施材木智。第四一生补处发心。如车成运载智。复次天子。初发心如月始生。第二行发心如月五日。第三不退发心如月十日。第四一生补处发心如月十四日。如来智慧如月十五日。复次天子。初发心能过声闻地。第二行发心能过辟支佛地。第三不退发心能过不定地。第四一生补处发心安住定地。复次天子。初发心如学初章智。第二行发心如差别诸章智。第三不退发心如算数智。第四一生补处发心如通达诸论智

复次天子。初发心从因生。第二行发心从智生。第三不退发心从断生。第四一生补处发心从果生。复次天子。初发心因摄。第二行发心智摄。第三不退发心断摄。第四一生补处发心果摄。复次天子。初发心因生。第二行发心智生。第三不退发心断生。第四一生补处发心果生。复次天子。初发心因差别分。第二行发心智差别分。第三不退发心断差别分。第四一生补处发心果差别分。复次天子。初发心。如取药草方便。第二行发心如分别药草方便。第三不退发心。如病服药方便。第四一生补处发心。如病得差方便。复次天子。初发心。学法王家生。第二行发心。学法王法。第三不退发心。能具足学法王法。第四一生补处发心。学法王法能得自在

论曰。无碍乐说辩才说法。有四种发菩提心摄取十地。以种种差别说故。彼种种差别有十二句。经言。天子又问。文殊师利。诸菩萨摩诃萨有几种心。能成就因能成就果。文殊师利答言。天子。诸菩萨摩诃萨有四种心。能成就因能成就果。何等为四。一者初发心。二者行发心。三者不退发心。四者一生补处发心者。初发心。能与第二行发心作因第二行发心。能与第三不退发心作因。第三不退发心。能与第四一生补处发心作因。此句明上上因胜胜不失故。又经言。复次天子。初发心如种种子。第二行发心如芽生增长。第三不退发心如茎叶华果初始成就。第四一生补处发心如果等有用等者。示现从清净因成就清净果故。又经言。复次天子。初发心如车匠集材智者。以依诸愿则能摄取一切佛法故。第二行发心如斫治材木净智者。以成就清净戒故。第三不退发心如安施材木智者。以依慧方便修一切行皆相应故。第四一生补处发心如车成运载智者。以不舍先许重担故。又经言。复次天子。初发心如月始生。第二行发心如月五日。第三不退发心如月十日。第四一生补处发心如月十四日。如来智慧如月十五日等者。以示现上上大力清净故。又经言。复次天子。初发心能过声闻地者。以初地前菩萨利根。观察一切菩提分法故。第二行发心能过辟支佛地者。以初地前菩萨依般若胜智。能集诸菩萨无量行故。第三不退发心能过不定地者。此已入初地得证智故。又过声闻辟支佛地者。以过一切功用行故。第四一生补处发心安住定地者。以善住王子地故。又经言。复次天子。初发心如学初禅智者。以观下地法故。第二行发心如差别诸章智者。以智慧增长差别故。第三不退发心如算数智者。以方便智能数一切法故。第四一生补处发心如通达诸论智者。以得证智故。又经言。复次天子。初发心从因生者。以自性清净本来成就故。第二行发心从智生者。以摄取世间出世间闻慧方便故。第三不退发心从断生者。以过一切世间戏论故。第四一生补处发心从果生者。以自然成就一切行故。又经言。复次天子。初发心因摄者。以信行助道淳熟故。又以观初地境界故。第二行发心智摄者。以依境界淳熟观功用行故。第三不退发心断摄者。以依修行境界未得佛法观故。第四一生补处发心果摄者。以依果淳熟随所有佛国土。应成佛处即成佛故。又经言。复次天子。初发心因生者。以不颠倒修行善根性故。第二行发心智生者。以不颠倒法究竟性故。第三不退发心断生者。以不颠倒修行性故。第四一生补处发心果生者。以得心自在故。又经言。复次天子。初发心因差别分者。以摄取无量善根故。第二行发心智差别分者。以无量无边法门毕竟究竟故。第三不退发心断差别分者。以入无量三昧门故。第四一生补处发心果差别分者。以无量神通奋迅随意自在用故。又经言。复次天子。初发心如取药草方便者。以摄取对治烦恼病法故。第二行发心如分别药草方便者。以知对治烦恼病随相应药故。第三不退发心如病服药方便者。以依知诸方便随相应受用故。第四一生补处发心如病得差方便者。以烦恼病灭故。又经言。复次天子。初发心学法王家生者。以降伏一切声闻辟支佛故。第二行发心学法王法者。以学一切得胜处故。第三不退发心能具足学法王法者。以得修道胜果故。第四一生补处发心学法王法能得自在者。以于一切法中能得自在无障碍故

文殊师利菩萨问菩提经论卷上文殊师利菩萨问菩提经论卷下(一名伽耶山顶经论)

        天亲菩萨造

        元魏天竺三藏菩提流支译

论曰。已说菩萨功德势力分次说菩萨行差别分

经曰。尔时大众中有天子名定光明主。不退阿耨多罗三藐三菩提心。时定光明主天子。问文殊师利法王子言。何等是诸菩萨摩诃萨毕竟略道。诸菩萨摩诃萨以是略道。疾得阿耨多罗三藐三菩提。文殊师利答言。天子。诸菩萨摩诃萨略道有二种。诸菩萨摩诃萨是二道。疾得阿耨多罗三藐三菩提。何等为二。一者方便道。二者慧道。方便者知摄善法。智慧者如实知诸法智。又方便者观诸众生。智慧者离诸法智。又方便者知诸法相应。智慧者知诸法不相应智。又方便者观因道。智慧者灭因道智

论曰。法主世尊亲在众中。何故乃问文殊师利。以为示现诸菩萨摩诃萨功德故。此以何义。以诸众生于菩萨所起轻慢心。令生尊重恭敬心故。诸菩萨摩诃萨行差别有二种道。何等为二。一者因清净道。二者功德清净道。因清净道者。以示现胜因清净故。彼胜因清净者。以四种发心说。何等为四。一者说助清净道二者说功德智道。三者说实际证道。四者说如实修行道。功德清净道者有八种。何等为八。一者摄取智教化一切众生。如经又方便者知摄善法智故。二者能忍一切众生诸不善行。如经慧者如实知诸法智故。三者集诸白净法。如经又方便者观一切众生智故。四者观一切菩提分法。如经慧者离诸法智故。五者知诸法和合相。如经又方便者知诸法相应智故。六者知诸法不同相。如经慧者知诸法不相应智故。又慧者知诸法不相应智者。以种种愿故。七者如实知可化众生。如经又方便者观因道智故。八者集种种助道。如经慧者灭因道智故。已说功德清净道。次说因清净道

经曰。又方便者。知诸法差别智慧者。知诸法无差别智。又方便者庄严佛土智慧者。庄严佛土平等无差别智。又方便者入众生诸根行。智慧者不见众生智。又方便者得至道场。智慧者能证一切佛菩提法智

论曰。因清净道亦有八种。何等为八。一者观善不善法。如经又方便者知诸法差别智故。二者离诸因缘一切法根本。如经慧者知诸法无差别智故。三者离一切障碍。如经又方便者庄严佛土智故。四者断一切和合。如经慧者庄严佛土平等无差别智故。五者如实知。如经又方便者入众生诸根行智故。六者入一法门。如经慧者不见众生智故。七者如实知一切凡夫虚妄分别。如经又方便者得至道场智故。八者证寂静界。如经慧者能证一切佛菩提法智故

经曰。复次天子。谓菩萨摩诃萨复有二种略道。诸菩萨摩诃萨以是二道。疾得阿耨多罗三藐三菩提。何等为二。一者助道。二者断道。助道者五波罗蜜。断道者般若波罗蜜。复有二种略道。何等为二。一者有碍道。二者无碍道。有碍道者五波罗蜜。无碍道者。般若波罗蜜。复有二种略道。何等为二。一者有漏道。二者无漏道。有漏道者五波罗蜜。无漏道者般若波罗蜜。复有二种略道。何等为二。一者有量道。二者无量道。有量道者取相分别。无量道者不取相分别。复有二种略道。何等为二。一者智道。二者断道。智道者谓从初地乃至七地。断道者谓从八地乃至十地

论曰。复有二种略道何等为二。一者功德道。二者智道。功德道者集种种善根。如经助道者五波罗蜜故。智道者通达一切法。如经断道者般若波罗蜜故。又经言。复有二种略道。何等为二。一者有碍道。二者无碍道。有碍道者五波罗蜜者。以行三界故。此初地已前。无碍道者般若波罗蜜者。以过三界入初地证智故。又经言。复有二种略道。何等为二。一者有漏道。二者无漏道。有漏道者五波罗蜜者。以成就世间果故。此初地已前。无漏道者般若波罗蜜者。以成就出世间果故。此已得出世间智故。又经言。复有二种略道。何等为二。一者有量道。二者无量道。有量道者取相分别者。以遍取识境界故。无量道者不取相分别者。以过识境界不见遍取故。又经言。复有二种略道。何等为二。一者智道。二者断道。智道者谓从初地乃至七地者。以如实知有为界故。断道者谓从八地乃至十地者。以如实知无为界故

经曰。尔时会中有菩萨摩诃萨名勇修行智。问文殊师利法王子言。何谓菩萨摩诃萨义。何谓菩萨摩诃萨智。文殊师利答言。善男子。义名不相应。智名相应。勇修行智菩萨言。文殊师利。何谓义名不相应。何谓智名相应。文殊师利言。善男子。义名无为。彼义无有一法共相应。无有一法不共相应。何以故。以无变无相故。义者无有一法共相应。无有一法不共相应。以本不成就义故。是故无有一法共相应。无有一法不共相应义者。不移不益无有一法共相应。无有一法不共相应故

论曰。经言。善男子。义名不相应智名相应者。示现实际有四种。又经言。善男子义名无为。彼义无有一法共相应。无有一法不共相应。何以故。以无变无相故者。以离诸无常过故。是故经言。义者无有一法共相应。无有一法不共相应故。以自体性住故。如经以本不成就义故。是故经言。无有一法共相应。无有一法不共相应故。以常真如法界实体住故。是故经言。义者不移不益。无有一法共相应。无有一法不共相应故。又无有一法不移不益者。以法界不增不减故

经曰。善男子。智者名道。道者心共相应非不相应。善男子。以是义故。智名相应非不相应。复次善男子。智名断相应。是故善男子。智名相应法非不相应法。复次善男子。智名善观五阴十二入十八界十二因缘是处非处。善男子。以是义故。智名相应非不相应

论曰。经言。善男子智者名道。道者心共相应非不相应者。自此以下次说为证法界。有三种句六种十法。此明何义。以何等智云何证。为何义何处住能证法界。以何等智者。以三种句六种十法示现。云何三种句示现何等智。智者谓道。道者心相应法非不相应法。是故经言。善男子。以是义故智名相应非不相应故。又智共眷属能证法界。何以故。以心清净故道清净。以道清净故心清净故。又经言。复次善男子智名断相应。是故善男子智名相应法非不相应法者。以递共依止故。又经言。复次善男子。智名善观五阴十二入十八界十二因缘是处非处。善男子。是故智名相应非不相应者。以如实知可知境界故。已说三种句。次说六种十法。初说十种智

经曰。复次善男子。诸菩萨摩诃萨有十种智。何等为十。一者因智。二者果智。三者义智。四者方便智。五者慧智。六者摄智。七者波罗蜜智。八者大悲智。九者教化众生智。十者不着一切法智。善男子。是名诸菩萨摩诃萨十种智

论曰。经言。诸菩萨摩诃萨有十种智。何等为十。一因智者。以善知无始世来解脱种子故。二果智者。以如实知无始世来种种业报故。三义智者。以善知自利利他故。四方便智者。以能增长微少善根令无量故。五慧智者。以能观察善不善法故。六摄智者。以摄取法施资生施故。七波罗蜜智者。以善知成就种种善根故。八大悲智者。以依善根能起善行故。九教化众生智者。以善观察时非时故。十不着一切诸法智者。以离二边修行中道故。如经善男子是名诸菩萨摩诃萨十种智。已说初十种智。次说第二十种发

经曰。复次善男子。诸菩萨摩诃萨有十种发。何等为十。一者身发。欲令一切众生身业清净故。二者口发。欲令一切众生口业清净故。三者意发。欲令一切众生意业清净故。四者内发。以不虚妄分别一切诸众生故。五者外发。以于一切众生平等行故。六者智发。以具足佛智清净故。七者清净国土发。以示一切诸佛国土功德庄严故。八者教化众生发。以知一切烦恼病药故。九者实发。以成就定聚故。十者无为智满足心发。以不着一切三界故。善男子。是名诸菩萨摩诃萨十种发

论曰。经言。诸菩萨摩诃萨有十种发。何等为十。一者身发。欲令一切众生身业清净故。二者口发。欲令一切众生口业清净故。三者意发。欲令一切众生意业清净故者。以为远离身口意业一切恶行。发大精进故。四者内发。以化一切众生令学彼处故。不虚妄分别一切众生故者。以不着诸法故。五者外发。于一切众生平等行故者。以远离憎爱故。六者智发。以具足佛智清净故者。以平等教化一切众生故。七者清净国土发。以示一切佛国土功德庄严故者。以闻慧智不颠倒求法故。八者教化众生发。以知一切烦恼病药故者。以于一切法中得自在故。九者实发。以成就定聚故者。以如实知心使随相应说法故。十者无为智满足心发者。以发实法故。不着一切三界故者。以心不着虚妄法故。又实不实心离虚妄取相故。如经善男子是名诸菩萨摩诃萨十种发已。说第二十种发。次说第三十种行

经曰。复次善男子。诸菩萨摩诃萨有十种行。何等为十。一者波罗蜜行。二者摄事行。三者慧行。四者方便行。五者大悲行。六者求助慧法行。七者求助智法行。八者心清净行。九者观诸谛行。十者于一切爱不爱事不贪着行。善男子。是名诸菩萨摩诃萨十种行

论曰。经言。诸菩萨摩诃萨有十种行。何等为十。一波罗蜜行者。以助菩提法满足故。二摄事行者。以能教化诸众生故。三慧行者。以如实观生灭法故。四方便行者。以如实知一切法故。五大悲行者。以心不求证涅槃故。六求助慧法行者。以为得四无畏故。七求助智法行者。以为自然得一切法故。八心清净行者。以于一切法中无疑惑故。九观诸谛行者。以入第一义谛故。十于一切爱不爱事不贪着行者。如前所说离憎爱故。如经善男子是名诸菩萨摩诃萨十种行。已说何等智。次说云何证。第四十一种无尽观示现

经曰。复次善男子。诸菩萨摩诃萨有十一种无尽观。何等为十一。一者身无尽观。二者事无尽观。三者烦恼无尽观。四者法无尽观。五者爱无尽观。六者见无尽观。七者助道无尽观。八者取无尽观。九者不着无尽观。十者相应无尽观。十一者道场智性无尽观。善男子。是名诸菩萨摩诃萨十一种无尽观

论曰。经言。诸菩萨摩诃萨有十一种无尽观。何等为十一。一身无尽观者。以如实观圣非圣有为无为身故。二者事无尽观者。以如实观实不实义故。三烦恼无尽观者。以如实观净染法故。四法无尽观者。以如实观上中下一切诸法故。五爱无尽观者。以如实观善不善法故。六见无尽观者。以如实观颠倒不颠倒见故。七助道无尽观者。以如实观种种门修集善根回向大菩提故。八取无尽观者。以如实观无边众生界故。九者不着无尽观者。不着义如向所说。十相应无尽观者。以如实观是义非义故。十一道场智性无尽观者。以随众生信示现坐道场故。如经善男子是名诸菩萨摩诃萨十一种无尽观。已说云何证。次说为何义。第五十种对治法示现

经曰。复次善男子。诸菩萨摩诃萨有十种对治法。何等为十。一者对治悭贪心。雨布施雨故。二者对治破戒心。身口意业三法清净故。三者对治嗔恚心。修行清净大慈悲故。四者对治懈怠心。求诸佛法无疲倦故。五者对治不善觉观心。得禅定解脱奋迅自在故。六者对治愚痴心。生助决定慧方便法故。七者对治诸烦恼心。生助道法故。八者对治颠倒道。集实谛助道生不颠倒道故。九者对治不自在心。法时非时得自在故。十者对治有我相。观诸法无我故。善男子。是名诸菩萨摩诃萨十种对治法

论曰。经言。诸菩萨摩诃萨有十种对治法者。以十波罗蜜清净故。何等为十。一者檀波罗蜜清净。如经对治悭贪心。雨布施雨故。二者尸波罗蜜清净。如经对治破戒心。身口意业三法清净故。三者羼提波罗蜜清净。如经对治嗔恚心。修行清净大慈悲故。四者毗离耶波罗蜜清净。如经对治懈怠心。求诸佛法无疲惓故。五者禅波罗蜜清净。如经对治不善觉观心。得禅定解脱奋迅自在故。六者般若波罗蜜清净。如经对治愚痴心。生助决定慧方便法故。七者方便波罗蜜清净。如经对治诸烦恼心。生助道法故。八者愿波罗蜜清净。如经对治颠倒道。集实谛助道生不颠倒道故。九者力波罗蜜清净。如经对治不自在心。法时非时得自在故。十者智波罗蜜清净。如经对治有我相。观诸法无我故。如经善男子是名诸菩萨摩诃萨十种对治法故。已说为何义。次说何处住。第六十种寂静地示现

经曰。复次善男子。诸菩萨摩诃萨有十种寂静地。何等为十。一者身寂静。以离三种身不善业故。二者口寂静。以清净四种口业故。三者心寂静。以离三种意恶行故。四者内寂静。以不着自身故。五者外境界寂静。以不着一切法故。六者智功德寂静。以不着道故。七者胜寂静。以如实观圣地故。八者未来际寂静。以彼岸慧助行故。九者所行世事寂静。以不诳一切众生故。十者不惜身心寂静。以大慈悲心教化一切众生故。善男子。是名诸菩萨摩诃萨十种寂静地

论曰。经言。诸菩萨摩诃萨有十种寂静地。何等为十。一者身寂静。以离三种身不善业道故。二者口寂静。以清净四种口业故。三者心寂静。以离三种意恶行故者。以三种戒善清净故。四者内寂静。以不着自身故者。以离邪我见故。五者外境界寂静。以不着一切法故者。以离常无常法故。六者智功德寂静。以不着道故者。以不著有物无物故。七者胜寂静。以如实观圣地故者。以不见声闻辟支佛地。如实观察诸佛菩萨圣地故。八者未来际寂静。以彼岸慧助行故者。以远离一切虚妄取相故。九者所行世事寂静。以不诳一切众生故者。以如实知世谛第一义谛。不颠倒说法故。十者不惜身心寂静。以大慈悲心教化一切众生故者。以为教化众生。一切处生不疲倦故。如经善男子是名诸菩萨摩诃萨十种寂静地。已说证法界。自此已下次说诸菩萨摩诃萨随顺如实修行义

经曰。复次善男子。诸菩萨摩诃萨。如实修行得菩提。非不如实修行得菩提。善男子。云何名为诸菩萨摩诃萨如实修行。善男子。如实修行者如说能行故。不如实修行者。但有言说不能如实修行故。复次善男子。诸菩萨摩诃萨复有二种如实修行。何等为二。一者智如实修行道。二者断如实修行道。善男子。是名诸菩萨摩诃萨二种如实修行。复次善男子。诸菩萨摩诃萨。复有二种如实修行。何等为二。一者调伏自身如实修行。二者教化众生如实修行。善男子。是名诸菩萨摩诃萨二种如实修行。复次善男子。诸菩萨摩诃萨。复有二种如实修行。何等为二。一者功用智如实修行。二者无功用智如实修行。善男子。是名诸菩萨摩诃萨二种如实修行。复次善男子。诸菩萨摩诃萨复有二种如实修行。何等为二。一者善知分别诸地如实修行。二者善知诸地无差别方便如实修行。善男子。是名诸菩萨摩诃萨二种如实修行。复次善男子。诸菩萨摩诃萨。复有二种如实修行。何等为二。一者离诸地过如实修行。二者善知地地转方便如实修行。善男子。是名诸菩萨摩诃萨二种如实修行复次善男子。诸菩萨摩诃萨。复有二种如实修行。何等为二。一者能说声闻辟支佛地如实修行。二者善知佛菩提不退转方便如实修行。善男子。是名诸菩萨摩诃萨二种如实修行

论曰。经言。复次善男子。诸菩萨摩诃萨。如实修行得菩提。非不如实修行得菩提。善男子。云何名为诸菩萨摩诃萨如实修行。如实修行者如说能行故。不如实修行者。但有言说不能如实修行故者。以如所说如是修行。以不违先言故。又经言。复次善男子。诸菩萨摩诃萨复有二种如实修行。何等为二。一者智如实修行道。二者断如实修行道。善男子。是名诸菩萨摩诃萨二种如实修行者。以如实知证声闻辟支佛智。而不取彼处以为究竟故。又经言。复次善男子。诸菩萨摩诃萨复有二种如实修行。何等为二。一者调伏自身如实修行者。以自取妙道如实修行故。二者教化众生如实修行者。以化余众生令入正道如实说法故。如经善男子是名诸菩萨摩诃萨二种如实修行故。又经言。复次善男子。诸菩萨摩诃萨。复有二种如实修行。何等为二。一者功用智如实修行者。以作心行菩萨行功用智故。二者无功用行智如实修行者。菩萨于修道中住。以无作心行菩萨行无功用行智故。如经善男子是名诸菩萨摩诃萨二种如实修行故。又经言。复次善男子。诸菩萨摩诃萨复有二种如实修行。何等为二。一者善知分别诸地如实修行者。以善智慧方便故。二者善知诸地无差别方便如实修行者。以入一相故。如经善男子是名诸菩萨摩诃萨二种如实修行故。又经言。复次善男子。诸菩萨摩诃萨复有二种如实修行。何等为二。一者离诸地过如实修行者。以离二边故。二者善知地地转方便如实修行者。以修行善法不休息精进故。如经善男子是名诸菩萨摩诃萨二种如实修行故。又经言。复次善男子。诸菩萨摩诃萨复有二种如实修行。何等为二。一者能说声闻辟支佛地如实修行者。以善学一切法故。二者善知佛菩提不退转方便如实修行者。以证真如法如实知修行方便故。如经善男子是名诸菩萨摩诃萨二种如实修行

经曰。善男子。诸菩萨摩诃萨。有如是等无量无边如实修行。诸菩萨摩诃萨应如是学如实修行。诸菩萨摩诃萨若能如是如实修行者。速得阿耨多罗三藐三菩提。不以为难

论曰。修行四种胜因。成就四种胜果及余如实修行故。彼胜果者诸如来智。于一念中知三世事。皆相应故

经曰。尔时佛赞文殊师利法王子言。善哉善哉。文殊师利。汝今善能为诸菩萨摩诃萨。说本业道。诚如汝所说

论曰。善哉者以不颠倒说法故。随顺如来所说法故

经曰。说是法时十千菩萨得无生法忍。文殊师利法王子等。一切世间天人阿修罗等。闻佛所说皆大欢喜信受奉行

论曰。有三种义是故欢喜。何等为三。一说者清净。以于诸法得自在故。二所说法清净。以如实证知清净法体故。三依所说法得果清净。以得净妙境界故。如经皆大欢喜信受奉行故

文殊师利菩萨问菩提经论卷下


无量寿经优波提舍愿生偈

    No. 1524

无量寿经优波提舍愿生偈

        婆薮槃豆菩萨造

        元魏天竺三藏菩提流支译

  世尊我一心　　归命尽十方
  无碍光如来　　愿生安乐国
  我依修多罗　　真实功德相
  说愿偈总持　　与佛教相应
  观彼世界相　　胜过三界道
  究竟如虚空　　广大无边际
  正道大慈悲　　出世善根生
  净光明满足　　如镜日月轮
  备诸珍宝性　　具足妙庄严
  无垢光焰炽　　明净曜世间
  宝性功德草　　柔软左右旋
  触者生胜乐　　过迦旃邻陀
  宝华千万种　　弥覆池流泉
  微风动华叶　　交错光乱转
  宫殿诸楼阁　　观十方无碍
  杂树异光色　　宝栏遍围绕
  无量宝交络　　罗网遍虚空
  种种铃发响　　宣吐妙法音
  雨华衣庄严　　无量香普熏
  佛慧明净日　　除世痴闇冥
  梵声语深远　　微妙闻十方
  正觉阿弥陀　　法王善住持
  如来净华众　　正觉华化生
  爱乐佛法味　　禅三昧为食
  永离身心恼　　受乐常无间
  大乘善根界　　等无讥嫌名
  女人及根缺　　二乘种不生
  众生所愿乐　　一切能满足
  故我愿往生　　阿弥陀佛国
  无量大宝王　　微妙净花台
  相好光一寻　　色像超群生
  如来微妙声　　梵响闻十方
  同地水火风　　虚空无分别
  天人不动众　　清净智海生
  如须弥山王　　胜妙无过者
  天人丈夫众　　恭敬绕瞻仰
  观佛本愿力　　遇无空过者
  能令速满足　　功德大宝海
  安乐国清净　　常转无垢轮
  化佛菩萨日　　如须弥住持
  无垢庄严光　　一念及一时
  普照诸佛会　　利益诸群生
  雨天乐花衣　　妙香等供养
  赞佛诸功德　　无有分别心
  何等世界无　　佛法功德宝
  我皆愿往生　　示佛法如佛
  我作论说偈　　愿见弥陀佛
  普共诸众生　　往生安乐国

无量寿修多罗章句我以偈总说竟

论曰。此愿偈明何义。观安乐世界。见阿弥陀佛。愿生彼国土故。云何观。云何生信心。若善男子善女人。修五念门成就者。毕竟得生安乐国土。见彼阿弥陀佛。何等五念门。一者礼拜门。二者赞叹门。三者作愿门。四者观察门。五者回向门。云何礼拜。身业礼拜阿弥陀如来应正遍知。为生彼国意故。云何赞叹。口业赞叹。称彼如来名。如彼如来光明智相。如彼名义。欲如实修行相应故。云何作愿。心常作愿。一心专念毕竟往生安乐国土。欲如实修行奢摩他故。云何观察。智慧观察。正念观彼。欲如实修行毗婆舍那故。彼观察有三种。何等三种。一者观察彼佛国土功德庄严。二者观察阿弥陀佛功德庄严。三者观察彼诸菩萨功德庄严。云何回向。不舍一切苦恼众生。心常作愿回向为首成就大悲心故。云何观察彼佛国土功德庄严。彼佛国土功德庄严者成就不可思议力故。如彼摩尼如意宝性。相似相对法故。观察彼佛国土功德庄严者。有十七种事应知。何者十七。一者清净功德成就。二者量功德成就。三者性功德成就。四者形相功德成就。五者种种事功德成就。六者妙色功德成就。七者触功德成就。八者庄严功德成就。九者雨功德成就。十者光明功德成就。十一者声功德成就。十二者主功德成就。十三者眷属功德成就。十四者受用功德成就。十五者无诸难功德成就。十六者大义门功德成就。十七者一切所求功德成就。清净功德成就者。偈言观彼世界相胜过三界道故。量功德成就者。偈言究竟如虚空广大无边际故。性功德成就者。偈言正道大慈悲出世善根生故。形相功德成就者。偈言净光明满足如镜日月轮故。种种事功德成就者。偈言备诸珍宝性具足妙庄严故。妙色功德成就者。偈言无垢光焰炽明净曜世间故。触功德成就者。偈言宝性功德草柔软左右旋触者生胜乐过迦旃邻陀故。庄严功德成就者。有三种应知。何等三。一者水。二者地。三者虚空。庄严水者。偈言宝华千万种弥覆池流泉微风动华叶交错光乱转故。庄严地者。偈言宫殿诸楼阁观十方无碍杂树异光色宝栏遍围绕故。庄严虚空者。偈言无量宝交络罗网遍虚空种种铃发响宣吐妙法音故。雨功德成就者。偈言雨华衣庄严无量香普熏故。光明功德成就者。偈言佛慧明净日除世痴闇冥故。妙声功德成就者。偈言梵声语深远微妙闻十方故。主功德成就者。偈言正觉阿弥陀法王善住持故。眷属功德成就者。偈言如来净华众正觉华化生故。受用功德成就者。偈言爱乐佛法味禅三昧为食故。无诸难功德成就者。偈言永离身心恼受乐常无间故。大义门功德成就者。偈言大乘善根界等无讥嫌名女人及根缺二乘种不生故。净土果报离二种讥嫌过应知。一者体。二者名。体有三种。一者二乘人。二者女人。三者诸根不具人。无此三过故。名离体讥嫌。名亦三种。非但无三体。乃至不闻二乘女人诸根不具三种名故。名离名讥嫌。等者。平等一相故。一切所求功德满足成就者。偈言众生所愿乐一切能满足故。略说彼阿弥陀佛国土庄严十七种功德。示现如来自身利益大功德力成就利益他功德成就故。彼无量寿佛土庄严。第一义谛妙境界。十六句及一句次第说。应知

云何观佛功德庄严成就。观佛功德庄严成就者。有八种应知。何等八种。一者座庄严。二者身庄严。三者口庄严。四者心庄严。五者众庄严。六者上首庄严。七者主庄严。八者不虚作住持庄严

何者座庄严。偈言无量大宝王微妙净华台故。何者身庄严。偈言相好光一寻色像超群生故。何者口庄严。偈言如来微妙声梵响闻十方故。何者心庄严。偈言同地水火风虚空无分别故。无分别者。无分别心故。何者众庄严。偈言天人不动众清净智海生故。何者上首庄严。偈言如须弥山王胜妙无过者故。何者主庄严。偈言天人丈夫众恭敬绕瞻仰故。何者不虚作住持庄严。偈言观佛本愿力遇无空过者能令速满足功德大宝海故。即见彼佛未证净心菩萨。毕竟得平等法身。与净心菩萨无异。净心菩萨与上地诸菩萨。毕竟同得寂灭平等故。略说八句。示现如来自利利他功德庄严次第成就应知

云何观菩萨功德庄严成就。观菩萨功德庄严成就者。观彼菩萨。有四种正修行功德成就应知。何等为四。一者于一佛土身不动摇。而遍十方种种应化。如实修行常作佛事。偈言安乐国清净常转无垢轮化佛菩萨日如须弥住持故。开诸众生淤泥华故。二者彼应化身。一切时不前不后。一心一念放大光明。悉能遍至十方世界。教化众生。种种方便修行所作。灭除一切众生苦故。偈言无垢庄严光一念及一时普照诸佛会利益诸群生故。三者彼于一切世界无余。照诸佛会大众无余。广大无量供养恭敬赞叹诸佛如来。偈言雨天乐华衣妙香等供养赞佛诸功德无有分别心故。四者彼于十方一切世界无三宝处。住持庄严佛法僧宝功德大海。遍示令解如实修行。偈言何等世界无佛法功德宝我皆愿往生示佛法如佛故

又向说佛国土功德庄严成就。佛功德庄严成就。菩萨功德成就。此三种成就愿心庄严。略说入一法句故。一法句者。谓清净句。清净句者。谓真实智慧无为法身故。此清净有二种应知。何等二种。一者器世间清净。二者众生世间清净。器世间清净者。向说十七种佛国土功德庄严成就。是名器世间清净。众生世间清净者。如向说八种佛功德庄严成就。四种菩萨功德庄严成就。是名众生世间清净。如是一法句。摄二种清净应知

如是菩萨奢摩他毗婆舍那广略修行。成就柔软心。如实知广略诸法。如是成就巧方便回向。何者菩萨巧方便回向。菩萨巧方便回向者。谓说礼拜等五种修行所集一切功德善根。不求自身住持之乐。欲拔一切众生苦故。作愿摄取一切众生。共同生彼安乐佛国。是名菩萨巧方便回向成就。菩萨如是善知回向成就。远离三种菩提门相违法。何等三种。一者依智慧门不求自乐。远离我心贪着自身故。二者依慈悲门。拔一切众生苦。远离无安众生心故。三者依方便门。怜愍一切众生心。远离供养恭敬自身心故。是名远离三种菩提门相违法故。菩萨远离如是三种菩提门相违法。得三种随顺菩提门法满足故。何等三种。一者无染清净心。不以为自身求诸乐故。二者安清净心。以拔一切众生苦故。三者乐清净心。以令一切众生得大菩提故。以摄取众生生彼国土故。是名三种随顺菩提门法满足应知

向说智慧慈悲方便三种门。摄取般若。般若摄取方便应知

向说远离我心不贪着自身。远离无安众生心。远离供养恭敬自身心。此三种法远离障菩提心应知

向说无染清净心。安清净心。乐清净心。此三种心略一处。成就妙乐胜真心应知

如是菩萨智慧心方便心无障心胜真心。能生清净佛国土应知。是名菩萨摩诃萨随顺五种法门所作随意自在成就。如向所说。身业口业意业智业方便智业。随顺法门故。复有五种门渐次成就五种功德应知。何者五门。一者近门。二者大会众门。三者宅门。四者屋门。五者园林游戏地门。此五种门。初四种门。成就入功德。第五门成就出功德。入第一门者。以礼拜阿弥陀佛为生彼国故。得生安乐世界。是名入第一门

入第二门者。以赞叹阿弥陀佛随顺名义称如来名依如来光明想修行故。得入大会众数。是名入第二门

入第三门者。以一心专念作愿生彼。修奢摩他寂静三昧行故。得入莲华藏世界。是名入第三门

入第四门者。以专念观察彼妙庄严修毗婆舍那故。得到彼处受用种种法味乐。是名入第四门。出第五门。以大慈悲观察一切苦恼众生。亦应化身回入生死园烦恼林中。游戏神通至教化地。以本愿力回向故。是名出第五门。菩萨入四种门。自利行成就应知。菩萨出第五门。利益他回向行成就应知。菩萨如是修五门行自利利他。速得成就阿耨多罗三藐三菩提故

无量寿经论一卷大乘善根界　天台智者即曰界字乃男字之错。则宜改作。而诸疏家皆作界字。故今存之


遗教经论

    No. 1529

遗教经论一卷

        天亲菩萨造

        真谛三藏译

  顶礼三世尊　　无上功德海
  哀愍度众生　　是故我归命
  清净深法藏　　增长修行者
  世及出世间　　我等皆南无
  我所建立论　　解释佛经义
  为彼诸菩萨　　令知方便道
  以知彼道故　　佛法得久住
  灭除凡圣过　　成就自他利

此修多罗中。建立菩萨所修行法有七分。一序分。二修集世间功德分。三成就出世间大人功德分。四显示毕竟甚深功德分。五显示入证决定分。六分别未入上上证为断疑分。七离种种自性清净无我分

释迦牟尼佛。初转法轮度阿若憍陈如。最后说法度须跋陀罗。所应度者皆已度讫。于娑罗双树间将入涅槃。是时中夜寂然无声。为诸弟子略说法要

论曰。初序分。修多罗显示利益成就毕竟故。是中成就毕竟有六种功德。一法师成就毕竟功德。二开法门成就毕竟功德。三弟子成就毕竟功德。四大总相成就毕竟功德。五因果自相成就毕竟功德。六分别总相成就毕竟功德

初成就毕竟有三种相。一总相。二别相。三总别相。总相者。如经牟尼故。别相者。如经释迦故。总别相者。佛故。是中释迦者。示现化众生巧便故。复家姓尊贵故。牟尼者。一切诸佛功德故。复示自体清净故。开法门成就毕竟功德者。有二白净法句。一道场白净法句。二涅槃白净法句。此二白净法前后二句。说示转说义应知。道场白净法者。如经初转法轮故。涅槃白净法句者。如经最后说法故。弟子成就毕竟功德者。示能受持二种白净法门故。成就自利益行故。显现如来快说法门功德故。如经度阿若憍陈如故。度须跋陀罗故。此二句修多罗示八种成就故

云何为八。谓二种受持成就故。二种白净法门成就故。二种自利益行成就故。二种快说法门功德成就故。大总相成就毕竟功德者。二八成就总故。如经所应度者皆已度讫故。因果自相成就毕竟功德者。有四种自相。一因自相。如经娑罗双树间故。二因共果自相。如经将入涅槃故。三总自相。如经是时中夜故。四果自相。如经寂然无声故。于中总自相者。远离二边故。成就二种中道故。一者正觉中道。二者离正觉中道。是中离正觉中道者。即果自相应知。此果有二种。一者自性无说离念涅槃果。二者远离觉观涅槃果故。分别总相成就毕竟功德者。分别人法二位差别故。人位差别者。上首眷属差别故。如经为诸弟子故。法位差别者。世间出世间法等故。如经略说法要故。已说序分。次说修集世间功德分。此功德有三。一者修集对治邪业功德。二者修集对治止苦功德。三者。修集对治灭烦恼功德

对治邪业功德者

经曰。汝等比丘。于我灭后。当尊重珍敬波罗提木叉。如闇遇明贫人得宝。当知此则是汝太师。若我住世。无异此也

论曰。此修多罗中。每说比丘者。示现远离相故。复示摩诃衍方便道。与二乘共故。又于四众亦同远离行故。于我灭后者。此言示现遗教义故。不尽灭法故。以不尽法清净法身。常为世间作究竟度故。如经当尊重珍敬波罗提木叉故。此木叉亦是毗尼相顺法故。复是诸行调伏义故。如来不灭法身自体解脱说波罗提木叉。依此法身。得度二种障故。一者有烦恼暗障。二者空无善根障。得度烦恼暗障者。如盲得眼。相似法故。如经如暗遇明故。得度空无善根障者。满足财宝相似法故。如经贫人得宝故。余者示现波罗提木叉。是修行大师故。如经当知此则是汝大师故。又示住持利益人法相似故。如经若我住世无异此也故。依根本清净戒已说。次说方便远离清净戒

经曰。持净戒者。不得贩卖贸易安置田宅畜养人民奴婢畜生一切种殖及诸财宝。皆当远离如避火坑。不得斩伐草木垦土掘地。合和汤药占相吉凶仰观星宿推步盈虚历数算计皆所不应。节身时食清净自活。不得参豫世事通致使命。咒术仙药结好贵人。亲厚媟慢皆不应作。当自端心正念求度。不得包藏瘕疵显异惑众。于四供养知量知足。趣得供事不应蓄积

论曰。此中方便远离净者。护根本净戒故。如经持净戒者故。云何护根本。何者是根本。护根本者。今说二种。何等为二。一者不同凡夫增过护。二者不同外道损智护。不同凡夫增过护者。有十一事。一者方便求利增过。如经不得贩故。二者现前求利增过。如经不得卖故。三者交易求利增过。如经不得贸易故。若依世价无求利心。不犯卖买。法式如毗尼中广说。四者所居业处。求多安隐增过。如经不得安置田宅故。五者眷属增过。如经不得畜养人民故。此示外眷属非同意者。何故不但言人。而复说民者。以其同在人中。于善法不了畜生之属故。六者难生卑下心增过。如经不得畜奴婢故。七者养生求利增过。如经不得畜生故。八者多事增过。如经不得一切种植故。九者积聚增过。如经及诸财宝故。十者不觉增过。如经皆当远离如避火坑。十一者不顺威仪及损众生增过。如经不得斩伐草木垦土掘地故。此十一种增过事。修行菩萨宜速远离不应亲近。避大火聚相似法故。如经皆当远离如避火坑故。不同外道损智护者。谓世间分别见故。此分别见有五句十种分别。如经合和汤药乃至皆所不应故。遮异见故。何者是根本者。此示根本有二种。一者行法根本故。二者行处根本故。行法根本者。波罗提木叉故。行处根本者。身口意故。于身口意行处。行波罗提木叉故。节身时食等。示现身口意行处。波罗提木叉故。修行菩萨当知三处波罗提木叉。无复有余解脱故。身处波罗提木叉。有五种解脱三种障对治二种不应作不作故。一者他求放逸障。此障对治。如经节身故。二者内资无厌足障此障对治。如经时食故。三者共相追求障。此障对治。如经清净自活故。四者自性止多事。如经不得参豫世事故。五者自性尊重。不作轻贱事。如经不得通致使命故。后二句示现不应作不作。云何五种身解脱。一者外缘身解脱。二者内缘身解脱。三者自相缘身解脱。四者众事缘身解脱。五者远离异方便缘身解脱。五种解脱中。初句总余句别应知。口处波罗提木叉者。有二种邪语不应作不作。一者依邪法语。有二种不应作。一邪术恼众生语。二依邪药作世辩不正语。如经咒术仙药故。二者依邪人语。亦二种不应作。一者与族姓同好。多作鄙呓语。二者亲近族姓。多作我慢语。如经结好贵人亲厚媟慢皆不应作故。意处波罗提木叉者。有六句说三种障。对治三种不应作不作。一者多见他过障。犯自净心故。此对治。如经当自端心故。二者邪思惟障。不能自度下地故。此对治。如经正念求度故。三者于受用众具中无限无厌足障。此对治。第五句于四供养知量知足故。此供养有二种。一者于身分中供养。谓饮食衣服卧具汤药供养身分故。二者于心分中供养。谓不共心供养。无厌足心供养。二事相违心供养。等分心供养。此四种心供养。痴乱众生常受用故。不知节量故。若入三昧分者知量故。若入道分者知足故。三种不应作不作者。一不污净戒不受持心垢故。如经不得包藏瑕疵故。二者远离。无缘显己胜行。令他不正解故。如经显异惑众故。三者远离贪覆心贮积众具故。如经趣得供事不应蓄积故。已说从根本戒。次说根本戒与从戒俱解脱。能生诸功德故

经曰。此则略说持戒之相。戒是正顺解脱之本故。名波罗提木叉依。因此戒。得生诸禅定及灭苦智慧

论曰。从戒是戒相故。不可广说显示略说应知。如经此则略说持戒之相故。戒是正顺者。此言示现从戒义故。于此彼处说从有二种。一者从根本戒。二者从根本所起成就戒。从根本戒者。示现顺根本无作。波罗提木叉如向已说故。从根本所起成就戒者。示现后际解脱因。中际从戒生故。如经解脱之本故。戒是解脱体能正度故。如经故名波罗提木叉故。此言示现能度身口意恶。彼岸成就三业解脱故。能生诸功德者。示现有色解脱功德无色解脱功德。彼二相顺相违解脱功德。皆从彼生故。如经依因此戒得生诸禅定及灭苦智慧故。次说劝修戒利益故

经曰。是故比丘。当持净戒。勿令毁缺。若人能持净戒。是则能有善法。若无净戒。诸善功德皆不得生。是以当知戒为第一安隐功德住处

论曰。云何劝修戒利益。于中有五种劝。一者劝不失自体。如经当持净戒故。二者劝不舍方便。如经勿令毁缺故。三者劝远离诸过身口意业。常集功德故。如经若人能持净戒是则能有善法故。四者劝知多过恶于身口意中。一切时不能生功德故。如经若无净戒诸善功德皆不得生故。五者显示持戒菩萨。于所修行三种戒中。有如是得失者。我当住安隐处。不住不安隐处故。如经是以当知戒为第一安隐功德住处故。此言正示现劝修利益胜义故。已说修集对治邪业功德。次说对治修集止苦功德。是中苦有三种。一者根欲放逸苦。二者多食苦。三者懈怠睡眠苦。是三种苦三昧乐门对治应知。云何根欲放逸苦对治

经曰。汝等比丘。已能住戒。当制五根。勿令放逸入于五欲。譬如牧牛之人执杖视之。不令纵逸犯人苗稼。若纵五根非唯五欲。将无崖畔不可制也。亦如恶马不以辔制。将当牵人坠于坑陷。如被劫害苦止。一世。五根贼祸殃及累世。为害甚重不可不慎。是故智者制而不随。持之如贼不令纵逸。假令纵之。皆亦不久见其磨灭

论曰。根放逸苦者。是苦因苦果故。依戒净三昧方便。摄念对治故。如经已能住戒当制五根故。何故但说五根。示现色非色别故。复示意根中有五根。二种对治故。云何二种。一者动念对治故。二者不动对治故。戒念护根利益相似法故。如经勿令放逸乃至犯人苗稼故。身戒清净故。种种色不放逸。牧牛相似法故。正念成就故。种种心不行执杖相似法故。以戒念成就故。三昧方便及正受功德无减无失故。不犯苗稼相似法故。复示无戒念失上上损心故。气分成就难对治故。如经若纵五根非唯五欲。将无崖畔不可制也故。次说无对难对治。恶马相似法故。如经亦如恶马不以辔制将当牵人坠于坑陷故。复示过重相似不相似。又因果深苦无量世故。示现先际中慎故。如经如被劫害苦止一世五根贼祸殃及累世为害甚重不可不慎故。向说戒念护。今说智护故。智者三昧观故。彼是三昧重障故。如经是故智者制而不随故。护彼如害命者。相似法故。如经持之如贼不令纵逸故。重者既如是。轻者云何制。是中轻者。谓细相习障故。于此处有时则有。无时则无故。不作意起故。如经假令纵之故。势无自立故。如经皆亦不久故。性是无对不相见故。如经见其磨灭故。是中云何立见示现依见时说故。彼无见故灭见故。次说欲放逸苦对治

经曰。此五根者心为其主是故汝等当好制心。心之可畏甚于毒蛇恶兽怨贼。大火越逸。未足喻也。动转轻躁但观于蜜不见深坑。譬如狂象无钩猿猴得树腾跃踔踯难可禁制。当急挫之无令放逸。纵此心者丧人善事。制之一处无事不办。是故比丘。当勤精进折伏汝心

论曰。是中欲苦者。心性差别故。亦是苦因苦果故。示现种种色苦。依彼而有故。如经此五根者心为其主故应知。自他生过故。勤遮故。如经是故汝等当好制心故。何故勤遮。示现此心三昧障法故。何者是三昧相。云何障法相。三昧相者有三种。一者无二念三昧相。二者调柔不动三昧相。三者起多功德三昧相故。障法相者亦有三种。一者心性差别障。二者轻动不调障。三者失诸功德障。心性差别障者。如经心之可畏甚于毒蛇恶兽怨贼大火越逸未足喻也故。是中差别者。贪等四种差别故。修无二念三昧者。于此差别处可畏应知。四种譬喻相似法故。复示不相似法大可畏故。轻动不调障者。如经动转轻躁如是等故。于中动转者。示现诸根中转识动故。复速疾故。猿猴相似法故。但观于蜜者。示现有翳不见未来故。深坑者。障碍义故。是障碍有二种。一者生处障碍。二者修一切行时困苦不能成就障碍。狂象相似法故。急挫者。示现抑入无动处故。无令放逸者。显示摄入调伏聚故。失诸功德障者。如经纵此心者丧人善事故。无二念三昧相者。如经制之一处故。起多功德三昧相者。如经无事不办故。调柔不动三昧相者。如经当勤精进折伏汝心故。已说根欲苦对治。次说多食苦对治

经曰。汝等比丘。受诸饮食当如服药。于好于恶勿生增减。趣得支身以除饥渴。如蜂采花但取其味不损色香。比丘亦尔。受人供养趣自除恼。无得多求坏其善心。譬如智者筹量牛力所堪多少。不令过分以竭其力

论曰。多食者三昧障故。食有二种。何等为二。一者身食。二者心心数法食。若多段食难止息故。去禅定远故。是心心数法食者。欲界相违法中。方便对治故。复有第一义心三昧中尽故。成就无食三昧故。如是二种三昧。有六种功德成就。何等为六。一者受用对治功德成就。二者平等观功德成就。三者究竟对治功德成就。四者显示平等观功德相似成就。五者不虚受功德成就。六者知时功德成就。此六种功德显示成就二种三昧。第一第五第六功德成就。显示少食三昧故。余者三种功德成就。显示无食三昧故。受用对治功德成就者。如经汝等比丘受诸饮食当如服药故。平等观功德成就者。如经于好于恶勿生增减故。究竟对治功德成就者。如经趣得支身以除饥渴故。此示平等法身摄平等观。究竟无饥渴故。显示平等观功德相似成就者。如经如蜂采花但取其味不损色香比丘亦尔故。是中不损者。示现非坏法观故。不虚受功德成就者。如经受人供养趣自除恼故。知时功德成就者。如经无得多求坏其善心故。多求者。示现心心数法多三昧功德不现前故。筹量牛力等。示知时相似法故。示现知时有二种。一者方便时计挍故。二者成就时相应故。示多食过故。已说多食苦对治。次说懈怠睡眠苦对治

经曰。汝等比丘。昼则勤心修集善法无令失时。初夜后夜亦勿有废。中夜诵经以自消息。无以睡眠因缘令一生空过无所得也。当念无常之火烧诸世间。早求自度勿睡眠也。诸烦恼贼常伺杀人甚于怨家。安可睡眠不自惊悟。烦恼毒蛇睡在汝心。譬如黑蚖在汝室睡。当以持戒之钩早摒除之。睡蛇既出乃可安眠。不出而睡。是无惭人。惭耻之服于诸庄严最为第一。惭如铁钩。能制人非法。是故比丘。常当惭耻勿得暂替。若离惭耻。则失诸功德。有愧之人。则有善法。若无愧者。与诸禽兽无相异也

论曰。懈怠睡眠苦对治者。不疲惓思惟对治故。是中何故懈怠睡眠共说障法。示现懈怠者。谓心懒堕故。睡眠者身闷重故。此二相顺共成一苦故。五种定障中共说故。于中起睡眠有三种。一从食起。二从时节起。三从心起。若从食及时节起者。是阿罗汉眠。以彼不从心生故。无所盖故是三种睡眠中。初二种以精进对治。无有时节故。无始来未曾断故。复示圣道难得故。如经汝等比丘昼则勤心修习善法无令失时。初夜后夜亦勿有废。中夜诵经以自消息。无以睡眠因缘令一生空过无所得也故自余修多罗。示现第三从心起睡眠对治故。是中对治有二种。一者思惟观察对治。观诸生灭坏五阴故。如经当念无常之火烧诸世间故。复示求禅定智慧度所度故。如经早求自度勿睡眠也故。复次观察阴界入等常害故。是中可畏求自正觉故。如经诸烦恼贼常伺杀人甚于怨家。安可睡眠不自惊悟故。二者净戒对治。谓禅定相应心戒故。六种境界心安住自心故。可畏如蛇相似法故。如经烦恼毒蛇睡在汝心譬如黑蚖在汝室睡故。净心戒对治故。如经当以持戒之钩早摒除之故。复示远离故。安隐故。如经睡蛇既出乃可安眠故。次说下地相似安隐无对治故。如经不出而眠是无惭人故。又示治法胜能令自地清净庄严。亦令他地无过故。如经惭耻之服于诸庄严最为第一惭如铁钩能制人非法故。是中最为第一者。示现胜余戒庄严故。是故比丘等为明何义。示现劝修胜庄严故。常修故。复示远离者。损自地故。如经若离惭耻则失诸功德故。复示有无得失故。如经应知。已说修集对治止苦功德。次说修集对治灭烦恼功德。于中有三种障对治。示道义应知

经曰。汝等比丘。若有人来节节肢解。当自摄心不令嗔恨。亦当护口勿出恶言。若纵恚心则自妨道失功德利。忍之为德持戒苦行所不能及。能行忍者。乃可名为有力大人。若其不能欢喜忍受恶骂之毒如饮甘露者。不名入道智慧人也。所以者何。嗔恚之害破诸善法坏好名闻。今世后世人不喜见。当知嗔心甚于猛火。常当防护无令得入。劫功德贼无过嗔恚。白衣受欲非行道人。无法自制嗔犹可恕。出家行道无欲之人。而怀嗔恚甚不可也。譬如清冷云中而霹雳起火非所应也

论曰。是中初障对治者。嗔恚烦恼障对治故。示现堪忍道故。修行菩萨住堪忍地中。能忍种种诸苦恼故。无轻重对治故。如经汝等比丘若有人来节节肢解当自摄心无令嗔恨故。此示幻化法身成就故。又复口行清净常作软语故。如经亦当护口勿出恶言故。复说自他利道德障法故。如经若纵恚心则自妨道失功德利故。显示功德智慧二种心行净故。挍量胜诸眷属行故。如经忍之为德持戒苦行所不能及故。于中行者三昧功德苦对治故。三种业清净。及挍量胜相示行安苦道应知。次说真如观清净。显示安乐道故。成就观智大人力故。如经能行忍者乃可名为有力大人故。又显示不入丈夫力成就者。无智慧观故。依相违显胜应知。如经若其不能欢喜忍受乃至智慧人也故。是中不欢喜者。无信入观故。恶骂之毒者。示无生法门相中不如法受故。甘露者。示无生法自体相相似法故。于中道者。示智慧自体故。复说过患事常护故。如经所以者何如是等故。于中诸善法者。自利智慧相故。好名闻者。利他善法名称功德故。人不喜见者。自他世无可乐果报故。于中防护有二种。何等为二。一者护自善法如防火。相似法故。二者护利他功德防护贼。相似法故。复示世间功德违顺法中有受用故。未毕竟相违故。如经白衣受欲非行道人无法自制嗔犹可恕故。于中无法者。无白净法对治故。次示出世间道。于世间受用二法中。一向相违故。如经出家行道无欲之人而怀嗔恚甚不可也故。余者显示道分中不应有。相似法故。如经譬如清冷云中霹雳起火非所应也故。次说第二烦恼障对治道

经曰。汝等比丘当自摩头。已舍饰好着坏色衣执持应器。以乞自活自见如是。若起憍慢当疾灭之。增长憍慢尚非世俗白衣所宜。何况出家入道之人为解脱故。自降其身而行乞也

论曰。第二烦恼障对治道者。示现自无尊胜心成就。轻贱身心行故。远离贡高烦恼故。于中有七句行远离。一者于上上尊胜处。最先折伏故。常应自知故。如经汝等比丘当自摩头故。二者于余处庄严不受用故。如经已舍饰好故。三者于衣服处对治为好故。如经着坏色衣故。四者自己受用具常自持故。如经执持应器故。五者于内外受用事。不作余生过方便故。及自调伏故。如经以乞自活故。六者智慧成就常自观察故。如经自见如是故。七者对治成就远离微起故。如经若起憍慢当疾灭之故。余者明何义故。示现挍量。自降伏者。不应起憍慢故。障碍先后际功德故。如经增长憍慢尚非世俗如是等故。次说第三障对治

经曰。汝等比丘谄曲之心与道相违。是故宜应质直其心。当知谄曲但为欺诳。入道之人则无是处。是故汝等宜当端心以质直为本

论曰。第三障对治者。示现根本直心。远离谄曲烦恼障故。于口意中自违违彼故。如经汝等比丘谄曲之心与道相违故。复示违道障对治故。如经是故宜应质直其心故。又复相违法。道分时中不应有故。如经当知谄曲但为欺诳入道之人则无是处故。是中欺诳者。心口俱时不实用故。余者示现直心。是道心本故。如经是故汝等宜当端心以质直为本故。已说修集世间功德分。次说修集出世间大人功德分。大人功德分有八种。一切大人常用此以自觉察故。长养成就方便毕竟故

经曰。汝等比丘当知多欲之人。多求利故苦恼亦多。少欲之人无求无欲则无此患。直尔少欲尚应修集。何况少欲能生诸功德。少欲之人则无谄曲以求人意。亦复不为诸根所牵。行少欲者心则坦然无所忧畏。触事有余常无不足。有少欲者则有涅槃。是名少欲

论曰。是中第一大人。成就无求功德。知觉多欲过故。于中说所知觉有五种相。一者知觉障相。谓烦恼业苦三种障故。如经汝等比丘当知多欲之人多求利故苦恼亦多故。此示回转不息故。二者知觉治相成就。远离三种妄想故。如经少欲之人无求无欲则无此患故。三者知觉因果集起相。成就无量行故。如经直尔少欲尚应修集何况少欲能生诸功德故。四者知觉无诸障毕竟相三障毕竟故。如经少欲之人则无谄曲以求人意。亦复不为诸根所牵故。五者知觉果成就相。般若等三种功德果成就故。如经行少欲者心则坦然无所忧畏触事有余常无不足有少欲者则有涅槃是名少欲故。复次说第二大人知觉功德

经曰。汝等比丘。若欲脱诸苦恼当观知足。知足之法即是富乐安隐之处。知足之人。虽卧地上。犹为安乐。不知足者。虽处天堂亦不称意。不知足者虽富而贫。知足之人虽贫而富。不知足者常为五欲所牵。为知足者之所怜愍。是名知足

论曰。第二大人知觉功德者。成就知足行故。对治苦因果故。如经汝等比丘若欲脱诸苦恼当观知足故。是中恼者。示现烦恼过从苦生故。复说清净因果成就治法故。如经知足之法即是富乐安隐之处故。若如是者二种知觉云何差别。此中示现初知觉者。远离他境界事故。知足者。于自事中远离故。复次有三种差别。示现知足不知足故。一者于何等何等处。受用差别故。二者于何等何等事。受用差别故。三者于何等何等法中。无自利有自他利差别故。如经知足之人虽卧地上如是等。如经应知。次说第三大人远离功德

经曰。汝等比丘。欲求寂静无为安乐。当离愦闹独处闲居。静处之人帝释诸天所共敬重。是故当舍己众他众。空闲独处思灭苦本。若乐众者则受众恼。譬如大树众鸟集之则有枯折之患。世间缚着没于众苦。如老象溺泥不能自出。是为远离

论曰。第三大人远离功德。于中三门摄义应知。一者自性远离门。体出故。二者修习远离门。方便出故。三者受用诸见门。常缚故。自性远离门者。示现四种对治。一者我相执着障。此障对治。如经汝等比丘若求寂静无为安乐故。于中寂静者。示法无我空故。无为者。无相空故。安乐者。无取舍愿空故。二者我所障五众乱起无次第故。此障对治。如经当离愦闹故。三者彼二无相障。此障对治。如经独处闲居故。四者无为首功德障。以其天可重法故。此障对治。如经静处之人帝释诸天。所共敬重故。修习远离门者。远离我我所不复集生故。如经是故当舍己众他众故。方便慧成就。如法如住故。如经空闲独处故。善择智成就远离起因故。如经思灭苦本故。受用诸见门者。乐集我我所生起自他心境相恼故。如经若乐众者则受众恼故。诸见集生生已自害大树相似法故。如经譬如大树众鸟集之则有枯折之患故。复示无出离相烦恼业染生故。老象溺泥相似法故。如经世间缚着没于众苦如老象溺泥不能自出是为远离故。次说第四大人不疲惓功德

经曰。汝等比丘。若勤精进则事无难者。是故汝等当勤精进。譬如小水常流则能穿石。若行者之心数数懈废。譬如钻火未热而息。虽欲得火火难可得。是名精进

论曰。是中不疲惓者。示现不同外道精进故。于一切法一切行善趣故。成就不退转故。如经汝等比丘若勤精进则事无难者故。以能成就不退。须修习长养故。如经是故汝等当勤精进故。复以譬喻显示不休息。精进成就有力故。如经譬如小水常流则能穿石故。次说懈怠过。不能常精进念处退失。不成就心慧故。依譬喻显示应知。如经若行者之心数数懈废如是等故。次说第五大人不忘念功德

经曰。汝等比丘。求善知识求善护助。无如不忘念者。若有不忘念者。诸烦恼贼则不能入。是故汝等常当摄念在心。若失念者则失诸功德。若念力坚强。虽入五欲贼中不为所害。譬如着铠入阵则无所畏。是名不忘念

论曰。第五大人不忘念功德者。示现是一切行上首故。能破无始重怨故。于中一切行者。略说三种。一者求闻法行。如经汝等比丘求善知识故。二者内善思惟行。如经求善护故。三者求如法修行。如经求善助故。复示此等行中为首为胜故。如经无如不忘念者故。能遮无始重怨。不害三种善根故。如经若有不忘念者诸烦恼贼则不能入故。烦恼者。示心相中惑乱故。贼者从外集生过故。复示劝修令初后念成就。示现遮无始终心故。如经是故汝等常当摄念在心故。无始终故失念成就多过故。如经若失念者则失诸功德故。又成就多功德随顺世间门集诸行故。如经若念力坚强虽入五欲贼中不为所害故。念力强故。勇健无畏入阵。相似法故。如经譬如着铠入阵则无所畏是名不忘念故。次说第六大人禅定功德

经曰。汝等比丘。若摄心者心则在定。心在定故能知世间生灭法相。是故汝等常当精勤修集诸定。若得定者心则不散。譬如惜水之家善治提塘。行者为智慧水故。善修禅定令不漏失。是名为定

论曰。大人禅定功德者。谓八种禅定等。因摄念生故。如经汝等比丘若摄心者心则在定故。云何摄心能生禅定。示现摄遍所行处。心行对治缘故。次及中软取事。心行对治缘故。此三种缘处对治成时。则近禅定故。禅定成就。有方便果用故。如经心在定故能知世间生灭法相故。又懈怠无修集。方便障故。如经是故汝等常当精勤修集诸定故。是中懈怠有三种。一者不安隐懈怠。二者无味懈怠。三者不知恐怖懈怠。云何修集一一对治。示现精进修集节量食卧。及调阿那波那故。精勤修集觉知诸定。有通慧功德及尽苦原故。大希有事故。精进修集观察生老病死苦及四恶趣苦。我未能离故。是三障对治故。复修习功德成就。无所对治故。如经若得定者心则不散故。又以譬喻示善修功德。上上增长故。如经应知。次说第七大人智慧功德

经曰。汝等比丘。若有智慧则无贪着。常自省察不令有失。是则于我法中能得解脱。若不尔者既非道人。又非白衣无所名也。实智慧者。则是度老病死海坚牢船也。亦是无明黑暗大明灯也。一切病者之良药也。伐烦恼树之利斧也。是故汝等。当以闻思修慧而自增益。若人有智慧之照。虽是肉眼而是明见之人也。是为智慧

论曰。是中智慧功德者。于真实义处障及世间事处障能远离故。如经汝等比丘若有智慧则无贪着故。于一切时常修心慧故。以其难得故。如经常自省察不令有失故。复示难得能得于第一义处远离故。如经是则于我法中能得解脱故。复示非自性慧不入出世及世间中故。非施设故。如经若不尔者既非道人又非白衣无所名也故。又以四种譬喻。显示四种功德。闻思修证故。如经应知。言实智慧者示实能对治故。于四种功德中。第四功德自利益最胜义故。又四种修学功德。于分内处而有觉照故。如经若人有智慧之照虽是肉眼而是明见人也是为智慧故。已说长养方便功德。次说大人成就毕竟功德

经曰。汝等比丘。若种种戏论其心则乱。虽复出家犹未得脱。是故比丘当急舍离乱心戏论。若汝欲得寂灭乐者。唯当速灭戏论之患。是名不戏论

论曰。大人成就毕竟功德者。示现自性远离。非对治法故。四种差别智障法分别可分别故。如经汝等比丘若种种戏论其心则乱故。修道智非自性故。如经虽复出家犹未得脱故。余者二句劝修远离。成就无戏论故。一者有对相远离。有彼彼功德相故。如经是故比丘当急舍离乱心戏论故。二者无对相远离。无彼彼功德相故。如经若汝欲得寂灭乐者唯当速灭戏论之患故。示现行成就体性异故。如经是名不戏论故。已说成就出世间大人功德分。次说显示毕竟甚深功德分

经曰。汝等比丘。于诸功德常当一心舍诸放逸如离怨贼。大悲世尊所欲利益皆已究竟。汝等但当勤而行之。若于山间若空泽中。若在树下闲处静室。念所受法勿令忘失。常当自勉精进修之。无为空死后致有悔。我如良医知病说药。服与不服非医咎也。又如善导导人善道。闻之不行非导过也

论曰。显示毕竟甚深功德者。有二种毕竟。显示二种甚深功德故。一者如来分别说法毕竟功德。显示非分别说法甚深功德常说故。二者修行菩萨。修世间功德毕竟。显示余者甚深功德常修故。此二种修行功德如上。一一种中各修二种功德应知。是中常修功德者。第一义心修故。如经汝等比丘于诸功德常当一心故。远离一心相似相违行如怨故。如经舍诸放逸如离怨贼故。无限齐大悲常利益限齐毕竟故。如经大悲世尊所欲利益皆已究竟故。次复广说常修功德。有七种修相。一者云何修。示现常勤行故。如经汝等但当勤而行之故。二者于何处修。示无事处故。如经若于山间若空泽中若在树下闲处静室故。三者何所修。示修真实无二念法故。如经念所受法故。四者何故修。修令现前故。如经勿令忘失故。五者以何方便修。如经常当自勉精进修之故。六者于相似法处苏息。远离上上心故。如经无为空死故。七者于晚时自知有余悔不及事故。如经后致有悔故。次广说如来分别说法功德毕竟。示现二种毕竟相。一者说化法毕竟。相应无余故。如经我如良医知病说药服与不服非医咎也故。二者与念毕竟。度法相应无余故。如经又如善导导人善道。闻之不行非导过也故。是中服与不服等。示现如来于二种毕竟中无过失故。不负众生世间法故。次说显示入证决定分

经曰。汝等。若于苦等四谛。有所疑者可疾问之。无得怀疑不求决也。尔时世尊如是三唱人无问者。所以者何。众无疑故。时阿[少/兔]楼驮观察众心。而白佛言。世尊。月可令热日可令冷。佛说四谛不可令异。佛说苦谛实苦不可令乐。集真是因更无异因。苦若灭者即是因灭。因灭故果灭。灭苦之道实是真道更无余道。世尊。是诸比丘于四谛中决定无疑

论曰。入证决定者。示现于所证法中成就决定无所疑故。是中有三门摄义。示现决定无疑。一者方便显发门。二者满足成就门。三者分别说门。方便显发门者。示现于诸实法处显发故。以彼法是修行者当观察及依之起行故。如经汝等若于苦等四谛故。于四谛中有作无作法。示现有疑无疑分齐故。如经有所疑者可疾问之无得怀疑不求决也故。疾问者示二种将毕竟故。如向已说二种毕竟事故。无得怀疑者。于见无作谛处及修行有作谛处。彼二相违处皆不得疑故。满足成就门者。有三种示现。一者示现法轮满足成就三转实法故。如经尔时世尊如是三唱故。二者示现证法满足成就。如经人无问者故。三者示现断功德满足成就。如经所以者何众无疑故。分别说门者。示现彼众上首。知大众心行成就决定。复了知所证实义故。分别说彼彼事答如来故。如经时阿[少/兔]楼驮观察众心如是等故。日月冷热者。示于四谛中违顺观行不可异故。实苦不可令乐者。以佛说故苦乐各实不变异故。更无异因者。示苦灭各自因故。复示灭道同是自性观故。决定者。苦乐因果入行决定故。无疑者。无异无余义故。已说显示入证决定分。次说分别未入上上证为断疑分

经曰。于此众中所作未办者。见佛灭度当有悲感。若有初入法者。闻佛所说即皆得度。譬如夜见电光即得见道。若所作已办已度苦海者但作是念。世尊灭度一何疾哉

论曰。分别未入上上证者。有三种分别。显示未入上上法故。一者于有作谛修分时中。未入上上法故。如经于此众中所作未办者见佛灭度当有悲感故。二者于无作谛见道时中速决定故。示现不同修分法故。去上上法转远故。如经若有初入法者闻佛所说即皆得度故。复以譬喻示现见道速决定义应知。如经譬如夜见电光即得见道故。三者于彼二相违无功用无学道中。于上上法界。有微细疑故。复有异义。于自地中见佛速灭故。如经若所作已办已度苦海者但作是念世尊灭度一何疾哉故。次说为断彼彼疑故

经曰。阿[少/兔]楼驮。虽说众中皆悉了达四圣谛义。世尊欲令此诸大众皆得坚固。以大悲心复为众说。汝等比丘勿怀悲恼。若我住世一劫会亦当灭。会而不离终不可得。自利利人法皆具足。若我久住更无所益。应可度者若天上人间皆悉已度。其未度者皆亦已作得度因缘。自今已后我诸弟子展转行之。则是如来法身常在而不灭也

论曰。是中断疑者。断彼胜分疑故。于自地中先所成就故。如经阿[少/兔]楼驮虽说众中皆悉了达四圣谛义故。复令上上成就。于彼所得究竟不退故。是如来悲心淳至故。不护上上法故。如经世尊欲令此诸大众皆得坚固以大悲心复为众说故。云何说。说有为功德。自他俱灭故。自他者说听差别故。如经汝等比丘勿怀悲恼若我住世一劫会亦当灭会而不离终不可得故。复说法门常住不灭故。如经自利利人法皆具足故。又说他利事。毕竟无复所作故。如经若我久住更无所益故。又说于彼彼众中自利事。毕竟无复所作故。如经应可度者若天上人间皆悉已度故。又说未修集者。依不灭法门。能作得度因缘故。如经其未度者皆亦已作得度因缘故。复有异义于上上法中未得度者。依常住法门度故。又说住持不坏功德于中有二。一者于因分中住持。不坏常修故。不断修故。如经自今已后我诸弟子展转行之故。二者于果分中住持。不坏常显故。如经则是如来法身常在而不灭也故。此二种住持不坏功德。示现上上法能断疑应知。次重说有为功德无常相故

经曰。是故当知世皆无常。会必有离勿怀忧也。世相如是。当勤精进早求解脱。以智慧明灭诸痴暗。世实危脆无牢强者。我今得灭如除恶病。此是应舍罪恶之物。假名为身。没在老病生死大海。何有智者得除灭之。如杀怨贼而不欢喜

论曰。是中何故重说有为功德无常相者。示现于此处劝修世间生厌离行故。于有为相中得脱故。如经是故当知世皆无常乃至早求解脱故。又示无我如实观成就。能灭我我所见根本故。如经以智慧明灭诸痴暗故。阴等诸法实不实故。如经世实危脆无牢强者故。又示如来是度世大师为成可患故。如经我今得灭如除恶病故。又说异可厌患相唯智能灭故。示现劝修智灭对故。得无对法现前故。如经此是罪恶之物如是等故。次说离种种自性清净无我分

经曰。汝等比丘。常当一心勤求出道。一切世间动不动法。皆是败坏不安之相。汝等且止勿得复语。时将欲过我欲灭度。是我最后之所教诲

论曰。是中种种自性者。于五阴法中。作种种见患故。妄想自性障故。此障对治。如经汝等比丘常当一心故。复以一心如实慧难可得故。如经勤求出道故。又示除如实慧所有相对法悉无常故。示现名相等法应知。如经一切世间动不动法皆是败坏不安之相故。于中动不动者。谓三界相静乱差别故。清净无我者。示现于甚深寂灭法中寂灭故。如经汝等且止如是等故。且止勿语者。劝示三业无动故。是寂灭无我相应器故。最后教诲者。正显遗教义故。是遗教义于住持法中胜。以其遗教故

遗教经论


转法轮经忧波提舍(有释论无经本)

    No. 1533

    转法轮经忧波提舍翻译之记

转法轮经。如来初说。忧波提舍义门之名。天亲菩萨之所开示。佛说为谁。憍陈如等。义行此方。必主其人。魏骠骑大将军开府仪同三司御史中尉勃海高仲密。善求义方。选真简伪。故请法师毗目智仙。并其弟子瞿昙流支。于邺城内在金华寺。出此义门忧波提舍。兴和三年岁次大梁建酉之月朔次庚子十一日译。三千九百四十二言。沙门昙林对译录记

转法轮经忧波提舍(有释论无经本)

        天亲菩萨造

        元魏天竺三藏毗目智仙译

如是我闻。一时婆伽婆。住王舍城耆阇崛山中。与大比丘僧大菩萨众俱。尔时世尊告智员大海乐说辩才菩萨言。智员大海乐说辩才。有二种住持如来转法轮。何等为二。一者众生住持。二者法住持。智员大海乐说辩才。此二种住持如来转法轮。乃至尽此修多罗说

此正法轮胜修多罗。以何义故。彼牟尼王不可思议不可称不可说不可量不可喻如虚空不断不常顺入因缘。寂静胜寂静最胜寂静第一寂静如实谛不虚妄。如来转无上法轮。说此修多罗。如来弟子声闻之人声闻弟子诸仙人等之所赞叹。此因缘故我今解释。云何解释。无量功德大牟尼王。何故转此不可思议不可称量第一寂静善无垢轮。一以何义故。名胜修多罗。二以何义故名为世尊(本元少第三法)。四如来何故。在王舍城耆阇崛山。二种住持转此法轮不在余处。五以何义故名为如来。六以何义故名为法轮。七又复世尊几转几行而转法轮。八又复世尊此中说转。何故如来不生法门说一切法不转不回。应如是知毕竟不起。若此转者。云何得避彼修多罗。彼修多罗则不须避。九又若此说众生住持法。住持者云何。般若波罗蜜中。如来告彼须菩提言。如来设复经劫说言众生。众生颇有众生生灭不耶。须菩提言。不也世尊。一切众生无始来净。如来复于无垢名称修多罗说。若住法想。此则大病。若众生法皆不可得。然则世尊何所住持而转法轮。此须解释。十又复世尊以何义故。舍彼宽博种种胜妙华树庄严无量胜人多众集处。于波罗奈少人众处。在波吒离树影荫下鹿苑之中。而转法轮。此之因缘亦须解释。十一又复世尊何处初坐而转法轮。十二又复世尊转法轮时。几许众生舍恶行善。十三以要言之示现云何众生住持及法住持。十四此皆是难

自下解释。彼法今说。以何义故。彼最第一无垢广博不可称量不可思议不可破坏。甚深不动正觉。世尊已说此经。又复今说胜无垢广博。不可称誉三界众生所赞。世尊何故说此不可称量离一切过胜修多罗。此义今释。世尊恐彼会中有天阿修罗人龙及夜叉鸠槃茶等。闻转法轮心生疑惑。不知世尊几种住持而转法轮。世尊观察众生疑心。为断彼疑。是故为说二种住持。而转法轮。此义云何。偈言

  世间人及天　　疑心观法主
  为断疑义故　　说此修多罗

又复世尊有大悲力饶益众生故说此经。云何世尊大悲力说此义。今说世尊如是于诸众生知无众生。诸法皆如乾闼婆城。如是知已众生住持及法住持。已转法轮。此义云何。偈言

  知世间无我　　如幻乾闼婆
  众生法住持　　如来大悲说

示现自力故能说义。世间更无能住持者。唯佛能作二种住持。更无有人能转法轮。如我转者又复有义。偈言

  非是天宫殿　　非阿修罗舍
  非人处龙宫　　有如是众生
  第一不可称　　离过灭三苦
  天人恭敬礼　　善转第一轮

又无量苦无量具足。然后乃得阿耨多罗三藐三菩提故。始行菩萨若闻是已心生怯弱。如来为欲除彼怯弱。示现此义无垢净觉。若无量苦无量具足。得阿耨多罗三藐三菩提。无量功德示此法轮。偈言

  金珠真珠等　　妻子国城施
  头分眼骨髓　　手足等施胜
  种种苦持戒　　希有得佛身
  功德不可称　　为疑怯者示

佛增上意观众生心。无量功德而转法轮。又复未发菩提心人。声闻缘觉乘。欲入涅槃舍。大乘住。持此义示现。又复胜意。若有声闻缘觉等乘入涅槃舍。则不复转无上法轮。偈言

  小心离悲等　　欲入二涅槃
  牟尼说此经　　令住第一乘

又此福人欢喜饶益。此义示现。一切世间最胜无比转法轮师无如我师。偈言

  若已归依佛　　今归当复归
  牟尼喜彼人　　说此修多罗

若余依止外道之人将引饶益。此义示现。无垢功德庄严妙身而转法轮。汝师非比。汝师不能令汝获得无漏善法。偈言

  依止恶智识　　如来见世间
  为引彼人故　　为说此经宝

一切智慢寂静饶益。示现此义。我一切智。今者新转无上法轮。云何汝是一切智人。偈言

  佛初转法轮　　能除断常倒
  不能转净轮　　彼非一切智

求广胜果无上福田饶益。示现不可思议果报能与。若有能转无上法轮。布施彼者得大果报。偈言

  若有人能转　　无上正法轮
  少施如是人　　得无比果报

又菩萨行得果饶益。示现此义。世尊说言。我此法轮能大饶益。已行无量亿那由他百千苦行。能舍难舍。譬如抒海心不休息。又言本生。作摩那婆身。及妻子我皆舍施。又言本生。作梵得王。所爱二子我舍布施。心不生悔。又言本生。作善牙王最端正。女人中胜妙。名孙陀利。施婆罗门。又言本生。作德藏王得陀罗尼。我七千年未一胁卧。又言本生。作不思议功德宝德王之太子。童子之身。一切论义我皆已得。为众生说。又言本生。作身汁仙。割身手足不生嗔恨。为说忍法。又言本生。作月光王。舍头布施不生嗔恨。又言本作。一切众生所喜见王童子之身。我十二年食香烧身供养佛法。心不生悔。又言本作。疗病王身。已疗一切阎浮提人一切病苦。如是种种无量苦恼皆悉已作有大饶益。我已证得如是菩萨种种苦行得果示现示现饶益。世尊已说此修多罗。偈言

  若如是初因　　苦行广舍身
  贫穷乞丐者　　随所应施与
  离一切诸过　　第一寂静轮
  说不毁第一　　是故我今转

以何义故名世尊者。堪受供养故名世尊。更有余义。如菩提心忧波提舍。彼中示现

如来何故在王舍城耆阇崛山。二种住持转于法轮。不余处者难不相应。随在何处此难无穷。世尊若在余处游行。亦有此难。是则无穷。更有余义。如菩提心忧波提舍。彼处示现。以何义故名如来者。彼义今说。如实而来故名如来。何法名如涅槃名如。众生与法彼二不如。如世尊说。诸比丘。第一圣谛不虚妄法名为涅槃。知故名来。异声论界知字论界。如世人说。此人来生。此明何义。此明智慧具足。来义如是。涅槃名如。知解名来。正觉涅槃故名如来。又空无相无愿名如。如彼一切行故名如来。又四圣谛此名为如。非余人见彼一切行故名如来。又复一切如是佛法此名为如。彼来此人故名如来。又复如名六波罗蜜。布施持戒忍辱精进禅定般若。正觉彼来故名如来。实舍寂慧安住是如。如彼无上正遍知来故名如来。一切如是菩萨诸地。欢喜离垢明焰难胜现前远行不动善慧法云等十。此名为如。如彼无上正遍知来故名如来。如八道来故名如来。以有般若波罗蜜足方便足来故名如来。或名如去。言如去者。或以如说故名如去。又如去者。去不复来故名如去。以何义故名法轮者。彼义今说法体是轮故名法轮。譬如世间铜体是瓶故名铜瓶。木体为轮故名木轮。此亦如是。法体为轮故名法轮。如是示现。何者是法。谓三十七菩提分法。此法是轮故名法轮。又一切法自体觉义是法轮义。又一切法胜庄严义。又取舍义。如是等义名为法轮。舍何等物谓舍有为。取何者物谓取涅槃。又能破坏一切烦恼。是故名轮。如时运轮法王治轮如轮王轮。一切世间光明照轮如星宿轮。又说法轮。不断常轮。二边不定。又不生轮。如因缘生。又不二轮。如眼与色。乃至意法不二应知。不可得轮。以三世法不可得故。又复空轮。离诸见故。又无相轮。观一切相离诸相故。又无愿轮。离三界故。一切分别不别异轮。以一切法不分别故

世尊复于阿那婆达多龙王修多罗中告龙王言。贤面龙王。又法轮者。实不坏行如是名轮。三世等故。无自体轮。以离有无二种见故。又复离轮。身无染故。又不着轮。以离心意意识等故。无处所轮。以舍一切有行生故。又复实轮。大实见故。又复谛轮。正修不坏故。又不尽轮。示不尽故。又法界轮以一切法皆悉行故。又实际轮以前后际非际轮故。又如如轮诸法自体无自体故。已无为轮一切疑虑观察定故。又复常轮圣性集故。又复空轮不见内外一切物故。又无相轮以一切相不分别故。又无愿轮以一切法不攀缘故。又无为轮一切言语所说。皆空不可说故。如是世尊所说法轮。此等皆是法论之义

又复世尊几转几行。转法轮者。彼义今说。法轮三转有十二行。此苦圣谛。此集圣谛。此灭圣谛。此苦灭道圣谛。此第一转。此苦圣谛应知。此苦集应断。此苦灭应证。此苦灭道应修。此第二转。此苦圣谛已知。此苦集已断。此苦灭已证。此苦灭道已修。此第三转。此说三转如是。苦智集智灭智道智如是。苦谛有三转智如是。集谛如是灭谛如是。道谛有三转智。彼如是说有十二行。何以故。如是异行于苦谛中有三转智。异行集谛异行灭谛异行道谛。皆三转智。此如是说有十二行

所言苦者谓之五阴。五阴苦相是名为苦。彼苦相空通达此空。是名苦智圣谛。彼五阴因爱使见因是名为集。若不分别不分别不取不触爱因见因是名集智圣谛。若彼五阴毕竟尽灭。前际不来后际不去中际不得。是名为灭。彼如是知是名灭智圣谛。若道得已攀缘苦智集智灭智。彼平等相彼不二智。是名苦灭道智圣谛。又复何故非少非多。说彼圣谛如是。分别此则无穷。又复如是知四圣谛则得解脱。所谓知苦苦因苦灭后得方便。如是四圣谛。此如是义次第而说。又平等相何者。名圣谛不虚妄法。以不虚妄故名为谛。各各自相皆不虚妄。如是不虚妄法是平等相。又复胜相何者。胜相苦逼迮相集能生相灭寂静。相道者出相。又十二行若逆若顺。有十二分因缘生转。又复广普修多罗说正分别能分别。不善观察生于无明。非有生法如是乃至大苦聚集。彼有及灭如是。法轮十二行转居邻。若知三宝具足

又复世尊此中说转。何故如来不生法门说一切法。不转不回应如是知。毕竟不起如是次第。彼义今释。彼真谛说此世谛说。又此时说。又此为治信受故说此义。已说是故今说。又复此为初业菩萨故如是说。得大地人如是不诤

若众生法皆不可得。然则世尊何所住持而转法轮。彼义今释。佛以大悲不取众生亦不取法。而常住持众生及法已转法轮。又复世尊于龙王问修多罗说。如虚空转名法轮转。又复此是世尊方便。诸法无名以名字说。是故偈言

  一切法无名　　设名以名法

世尊法尔不取众生。而治众生为之说法。虽不取法而常广说一切诸法。又复般若波罗蜜经。无垢名称修多罗说。为知真谛故说世谛。如是无过。又复世尊以何义故。舍彼宽博种种胜妙华树庄严无量胜人多众集处。于波罗奈少人众处。在波吒离树影荫下鹿苑之中而转法轮。彼义今释。世尊往昔已于彼处。六十千亿那由他会广行布施。又于彼处已曾供养六十千亿那由他佛。又于彼处已有九十一亿千佛转于法轮。彼处常饶寂静仙人。有如是等诸大功德。是故世尊在于彼处而转法轮。此义已释今复更说。又广普经有偈说言

  我六十千亿　　那由他会施
  供六十千亿　　那由他诸佛
  波罗奈处胜　　有胜旧仙人
  第一天龙等　　常赞说法处
  九十一亿前　　我忆无上胜
  于此妙林中　　转无上法轮
  此有那由他　　寂静胜仙人
  常在鹿苑中　　故名仙人处
  如是胜林中　　转无上法轮

如是已转又为法人如是已转

又复世尊。何处初坐而转法轮。彼义今释。世尊坐彼大圆殿处无量清净妙色珍宝

庄严师子座上而转法轮。此何处说。广普经中如是说言。诸比丘有诸地天。知波罗奈欲转法轮有大饶益。置大圆殿种种庄严广博严丽。其殿纵广七百由旬。虚空诸天以盖幢幡而为庄严。于上空中欲界天子。八十四千师子之座奉施如来。施如来已一一请言。唯愿如来坐我此座而转法轮。一一天子各见世尊坐其所施师子座上而转法轮。世尊如是满足一切诸天子意

又复世尊转法轮时。几许众生舍恶行善。彼义今释。憍陈如等有五比丘。复有诸天六十亿数。复色界天八十亿数。复有八十四千亿人。此何处说。彼广普经有偈说言

  阿若居邻等　　如是五比丘
  六十亿诸天　　皆得法眼净
  八十亿色天　　净无上法眼
  净胜法眼人　　八万四千亿

以要言之。众生住持示说众生法。住持者示现说法。又复有义。众生住持示现。令知众生心行八万四千法。住持者示现令知八万四千法聚光明多所饶益。又复有义。众生住持此为示现。众生平等法住持者。示法平等。又复此二世谛示现

转法轮经优波提舍一卷


阿毗达磨藏显宗论

    No. 1563

阿毗达磨藏显宗论卷第一

        尊者众贤造

        三藏法师玄奘奉　诏译

    序品第一

  诸有遍于一切法　　最极难知自共相
  独能悟解无邪乱　　是一切智今敬礼
  我以顺理广博言　　对破余宗显本义
  若经主言顺理教　　则随印述不求非
  少违对法旨及经　　决定研寻誓除遣
  已说论名顺正理　　乐思择者所应学
  文句派演隔难寻　　非少劬劳所能解
  为撮广文令易了　　故造略论名显宗
  饰存彼颂以为归　　删顺理中广决择
  对彼谬言申正释　　显此所宗真妙义

论曰。既非遍智。云何能知。此佛世尊是一切智。能于诸法最极难知。自共相中觉无邪乱。虽非遍知而亦能知。如佛教行定得果故。如有智者善鉴良医。如世有医。先审病者风热淡等所起疾源。复如实观性习二体。年时处等种种不同。为欲蠲除说授方药。诸有患者能顺服行。痼疾渐除身安日益。智者寻验知实良医。于诸方药具净遍智。如是世尊知所化者贪嗔痴等烦恼病源。复如实观本性修集二善种子胜解随眠。及彼堪能自圆满等。为欲令彼暂永灭故。说授伏除二道方药。诸所化者能顺服行。若别若通对治道药。无始数习增盛坚牢。诸烦恼病渐渐除遣。贪等灭得于自身中。随道浅深倍倍增胜。由斯仰测知我大师灭一切冥具一切智。故赞颂者颂赞佛言

  谁能如尊善分别　　随眠境界自共相
  无量无边诸品类　　如应宣说利有情
  谁能渐次顺修行　　不得成于胜利乐
  无智不能顺圣教　　岂无验过在如来

有于思择增上慢人。谓佛世尊非一切智。于所请问别异而答。谓作是言。此不应记诸别异答。无知起故。又于前际说不可知。此即自显是无知故。又不先觉孙陀利缘及纵彼朋造诸恶故。又于战遮婆罗门女所起谤毁不能遣故。又先听许提婆达多于佛法中而出家故。又于外道嗢达洛迦先自不知命存亡故。又不预定波吒厘城当有如斯难事起故。又不悬记自佛法中当有部执十八异故。又说诸业有不定故。外道谤词略述如是。彼诸外道固执在怀。一切智尊虽设种种善权化导。而未能令于正等觉生净信解。具胜福慧求真理人。方能测量一切智海。今我勇锐发正勤心。如理顺宜且少开悟。言于请问别异而答。谓作是言。此不应记诸别异答无知起者。此不应理。其所立因非决定故。且应详审。为佛世尊于所请问。由无知故言不应记。为观问者怀聪睿慢。非卒能令如理信解。故虽了达而不为记。如有矫问。诸石女儿为黑为白。终不为记。岂别有方能祛彼疾。如是外道执我为真。矫问如来死后为有为无等事。世尊告言。此不应记。佛意说我实无有故不应记别。此显若法都非实有。不应于中为差别问。或佛世尊善权方便。为令调伏故不为记。此不为记是调伏因。非由无知作别异答。又不应谓佛无辩才。彼问论道所不摄故。若彼所问论道摄者。佛不为记可无辩才。非于此中如理难问少分可得。何容乃谓佛无辩才。又听法者心不殷故。执我见故。根未熟故。世尊无方可令信解。故于所问置而不记。故不应以不记所问谓大仙尊非一切智。言于初际说不可知。此即自显是无知者。此亦非理。无法不应为智境故。于有法境智若不生。可谓如来非一切智。本无初际智何所知。无故不知。岂成无智。若尔何故不但说无。此说不容更立因故。若谓应立不可知因。此亦不然。非决定故。或法虽有缘阙不知。故不可知非无因性。若立无性为不知因。即毕竟无可为同喻。为容因故说不可知。若谓无因有不成失。此不应理。非不成故。生死初际若定非无。即初际身无无因起。初无因者后亦应无。以先后身无异因故。若许尔者。即诸所行净不净业皆应无果。既不许然。即先所立初际无故。非不成因。若谓生死无初际故应如虚空无后际者。亦不应理。外种同故。如外谷麦后因前生。虽无初际。遇火水等诸烧烂缘而永坏灭。如是生死烦恼业因展转相生。虽无初际。而由数习贪嗔痴等对治力故。生死诸蕴毕竟不生。即为后际。空无生故。后际可无生死有生。岂无后际现见生法。定有终时。生死既生。理必归灭。故说初际是不可知无故为因。其义善立。故不应以不知初际。谓佛世尊非一切智。言不先觉孙陀利缘及纵彼朋造诸恶者。此亦非理。虽先觉知。为避多过故不自显。若佛先言。我无此事。为此事者自是余人。即彼朋流恶心转盛。诸中庸者咸共怀疑。如是过愆为佛为彼。又大人法不显他非。佛是大人岂扬他恶。又显彼恶令无量人憎背世尊障入正法。又佛观见自身他身。有招谤毁短寿定业。又为开慰末世苾刍。佛观当来正法将没。多闻持戒众望苾刍。少有不遭谤毁而死。为欲令彼自开慰言。我大仙尊。一切烦恼过失习气。皆永拔根名称普闻。至色究竟尚被嚣谤。况我何人因此心安修诸善业。由观如是得失决定。是故世尊不先自显。又过七日其事自彰。显佛尊高过归外道。故不应以不自显因谓佛世尊非一切智。即由此故应知已释。不自披遣战遮谤因。所以听许提婆达多于佛法中而出家者。此有深意。佛观彼人。不出家者。定当得作力转轮王。害无量人灭坏佛法。蹎坠恶趣难有出期。由度出家殖深善本。非出家者所不能殖。为护多人令无损害。及遮众恶故许出家。言于外道嗢达洛迦先自不知命存亡者。此亦非理。念即知故。非于余境余识生时。即能了知所余识境。佛心先在说法事中。未观彼人命存亡事。后欲知彼才举心时。即如实知其命已过。若欲知彼而不能知。可谓如来非一切智。心属余境此境未缘。即谓无知。斯不应理言不预定波吒厘城当有如斯难事起者。亦不应理。密预定故。先密意说。若免脱余。余复为余之所损害。谓佛先觉若守护余。余必为余之所损害。于三难事各令自守。余不能损。故密意说。此即预定难事必然。何谓世尊非一切智。言不悬记自佛法中当有部执十八异者。此亦非理。已悬记故。如说当来有苾刍众。于我言义不善了知。部执竞兴互相非毁。世尊于此略说内外二种防护。内谓应如黑说大说。契经所显观察防护。外谓应如六可爱法。契经所说敛摄防护。又见集法契经中言。于我法中当有异说。所谓有说唯金刚喻定。能顿断烦恼。或说择灭涅槃二法为体。或说不相应行无别实物。或说表业尚无。况无表业。或说一切色法大种为体。或说前后相似为同类因。或说色处唯用显色为体。或说触处唯用大种为体。或说唯有触处是有对碍。或说触处身处是有对碍。或说唯五外处是有对碍。或说眼识能见。或说和合能见。或说意界法界俱常无常。或说一切色法非刹那灭。或说不相应行有多时住。或说无想灭定皆现有心。或说等无间缘亦通色法。或说一切色法无同类因。或说异熟生色断已更续。或说傍生饿鬼天趣亦得别解脱戒。或说心无染污亦得续生。或说一切续生皆由爱恚。或说律仪不律仪分受亦全受。或说傍生饿鬼有无间业。或说无间解脱二道俱能断诸烦恼。或说意识相应善有漏慧非皆是见。或说身边二见皆是不善亦他界缘。或说一切烦恼皆是不善。或说无乐舍受。或说唯无舍受。或说无色界中亦有诸色。或说无想天殁皆堕恶趣。或说一切有情无非时死。或说诸无漏慧皆智见性。或说无有去来一切现在别别而说。或说色心非互为俱有因。或说羯剌蓝位一切色根皆已具得。或说诸得顶法者皆不堕恶趣。或说诸善恶业皆可转灭。或说诸无为法非实有体。或说诸世间道不断烦恼。或说唯赡部洲能起愿智。无诤无碍重三摩地。或说心心所法亦缘无境。诸如是等差别诤论。各述所执数越多千。师弟相承度百千众。为诸道俗解说称扬。我佛法中于未来世当有如是诤论不同。为利为名恶说恶受。不证法实颠倒显示。即于此部过现当来亦有如是诤论差别。世尊如是分明悬记。而诸弟子不顾圣言。各执所宗互相非毁。过属弟子岂在世尊。不可由斯谤一切智言。说诸业有不定者。理亦不然。有此业故。定应许有能感异熟不定业性。此若无者。修道断结则为唐捐。以一切业定得果故。不应由此所说诸因。或复余因谤一切智。世尊成就不可思议希有功德高广名称。非理毁谤获罪无边。诸有智人皆应信佛。具一切智故先敬礼

    辩本事品第二之一

  诸一切种诸冥灭　　拔众生出生死泥
  敬礼如是如理师　　对法藏论我当说

论曰。诸言虽总而别有所观。别何所观。谓俱利德满。智断具故。自利德满。恩德备故。利他德满。此即一切智能拔济有情。一切种冥皆永灭故智德圆满。诸境界冥亦永灭故断德圆满。授正法手拔众生出生死泥故恩德圆满。声闻独觉虽灭诸冥。以染无知毕竟断故。非一切种阙能永灭。不染无知殊胜智故。非具一切智。不能拔有情。冥谓翳膜能蔽净眼。如是无知障真见故。冥惑昏闇能遮色像。如是无知覆实义故。诸有殊胜治道生时。令永不生。故称为灭。谓灭一切品诸境冥故。言一切种诸冥灭拔众生出生死泥者。由彼生死是诸有情无始时来沉溺处故。难可出故。所以譬泥。众生于中沦没无救。诸有成就巧智大悲。授如应言拔济令出。敬礼如是如理师者。稽首具前自他利德。能说如理圣教大师。意乐随眠智等阙故。声闻独觉非如理师。唯佛世尊具如是德。故是前总诸言所观为正流通。彼所立教。故先赞礼如理教师。以赞礼言灭诸恶障。标嘉瑞已许发论端。故言我当说对法藏。何谓对法。颂曰

  净慧随行名对法　　及能得此诸慧论

论曰。净谓无漏。慧谓择法。此即总摄无漏慧根。何缘得知。唯无漏慧名为对法。以佛世尊恣天帝等所请问故。如契经说。我有甚深阿毗达磨及毗柰耶。恣汝请问。是许天帝请问圣道及此圣道所证果义。恣伐蹉类契经亦尔。复以何缘唯无漏慧名为对法。由此现观诸法相已不重迷故。岂不现观非唯慧能。是则对法应非唯慧。正觉谛理说名现观。故现观用唯慧非余。又现观中慧为最胜。具三能故独称对法。然此对法非不待余。故慧随行亦名对法。即慧眷属名曰随行。眷属者何。谓慧随转色受想等诸心所法生等及心。如是总说无漏五蕴。名为对法。此则胜义阿毗达磨。若说世俗阿毗达磨。即能得此诸慧诸论。此谓前所得无漏慧根诸慧。谓能得世间三慧即是世间殊胜修慧思慧闻慧。及彼随行依所得近远说三慧次第。非离如是慧及随行无漏慧根可能证得。是能得此胜方便故。同无漏慧受对法名。如慈方便亦名慈等。论谓能得。此发智等诸论是无漏慧胜资粮故。亦名对法。如业异熟漏等资粮亦名业等。前诸慧言亦摄生得。唯生得慧能正诵持对法论故。亦名对法。岂不此论是无漏慧胜资粮故。亦名对法。何乃别名对法。俱舍颂曰

  摄彼胜义依彼故　　此立对法俱舍名

论曰。藏谓坚实犹如树藏对法实义皆入此摄。此论是彼对法之藏。即是对法之坚实义藏。或所依犹如刀藏。谓彼对法是此所依引彼义言造此论故。此论以彼对法为藏。即以对法为所依义。彼何因说谁复先说。虽不应问说对法人。佛教依法不依人故。而为开示说对法因。彼能说人亦应显了。颂曰

  若离择法定无余　　能灭诸惑胜方便
  由惑世间漂有海　　为寂大师说对法

论曰。由离择法无胜方便。能灭世间引苦诸惑。故世尊言。若于一法未达未知。我终不说能正尽苦。世间未灭诸烦恼故。于三有海生死轮回。为令世间修习择法。永寂三有生因烦恼。是故大师先自演说阿毗达磨。佛若不说。舍利子等诸大声闻。亦无有能于诸法相如理思择。然佛大师随所化者。性差别故处处散说。尊者迦多衍尼子等诸大声闻。以妙愿智观过去佛所说法教。如其所应安置结集。如大尊者迦叶波等共所结集律及契经。经律二藏随文结集。唯对法藏随义结集。如说诸有结集义言。于律及经彼为殊胜。随佛圣教结集对法是佛所许得佛说名。何等名为所思择法。世尊依彼说对法耶。颂曰

  有漏无漏法　　除道余有为
  于彼漏随增　　故说名有漏
  无漏谓道谛　　及三种无为
  谓虚空二灭　　此中空无碍
  择灭谓离系　　随系事各别
  毕竟碍当生　　别得非择灭

论曰。说一切法略有二种。一者有漏。二者无漏。此则总说。次当别解。除道圣谛余有为法。是名有漏。此复云何。谓五取蕴色。乃至识。如说云何名色取蕴。谓有漏色随顺诸取。广说乃至。识亦如是。何缘取蕴名为有漏。以于其中漏随增故。有身见等诸烦恼中立漏名想令染污心常漏泄故。与漏相应。及漏境界随增漏故。名漏随增。随增眠义后当广辩。由此应知已遮一切。不同界地及无漏缘烦恼境界随眠有漏。彼此展转不随增故。非相对立。如是二名有漏无漏。复有何相。如世尊言。有漏法者。谓所有色随顺诸取。是能增益诸有取义广说乃至。识亦如是。与此相违是无漏法。有漏无漏略相如是。或有漏者。谓堕世间。若出世间名为无漏。世间所摄名堕世间。谓处世间不出为义。依苦谛体立世间名。故契经说。吾当为汝宣说世间及世间集。又五取蕴名苦有漏。故知有漏。谓堕世间。宁知堕世间皆是有漏法。如世尊说。吾当为汝宣说有漏及无漏法。有漏法者。谓诸所有眼诸所有色。诸所有眼识。诸所有眼触。诸所有眼触为缘内所生。或乐受或苦受或不苦不乐受。如是乃至。堕世间意。堕世间法。堕世间意识。堕世间意触。广说乃至。名有漏法。无漏法者。谓出世间意。出世间法。出世间意识。出世间意触。广说乃至。名无漏法。依此圣教及由正理。知堕世间皆是有漏。已辩有漏及有漏因。云何无漏。谓道圣谛及三无为。名为无漏。道圣谛者。谓非有漏色等五蕴。三无为者。谓即虚空择非择灭。此虚空等及道圣谛。名无漏因。次前已说其道圣谛后当广辩。于略所说三无为中。虚空但以无碍为性。于中诸法最极显现。无障为相。故名虚空。谓诸大种及造色聚。一切不能遍覆障故。或非所障亦非能障。故说虚空。无障为相。择灭即以离系为性。择谓如理勤所成慧。于四圣谛各别行相。如理思择。故名为择。由择所得诸有漏法永离系性。此定能碍诸系得生。故名择灭。或有是灭而非离系。为简彼故说离系言。有作是言。诸所断法同一择灭。无同类故阿毗达磨。诸大论师咸作是言。随系事别。所以者何。此若一者。修余治道有无用过。若诸所断同一择灭。证得苦法智忍所断烦恼灭时。余烦恼灭为证得不。若证得者。修余治道便为无用。若不证得。是则一物证少非余。与理相违有分过故。由是定应许离系事随系事量。不违正理。无同类者。谓此择灭自无同类因。亦非他因。故永碍当生得非择灭。择即前说如理成慧。不由此慧有法永遮。未来法生名非择灭。如眼与意专一色时。余色诸声香味触等。念念谢往对彼少分。意处法处得非择灭。以五识身及与一分意识身等于已灭境终不能生缘俱境故。由彼生用系属同时所依缘故。若法能碍彼法生用此法离慧。定碍彼法令住未来永不生故名非择灭。非唯缘阙便永不生。后遇同类缘彼复应生故。谓若先缘阙彼法可不生。后遇同类缘。何障令不起。前说除道。余有为法。是名有漏何谓有为。颂曰

  又诸有为法　　谓色等五蕴
  亦世路言依　　有离有事等

论曰。老病死等灾横差别。隐积损伏故名为蕴。为别戒等故言色等。戒等五蕴不能具摄。一切有为色等五蕴具摄有为。故此偏说言有为者。众缘聚集共所为故。未来未起。何谓有为。如所烧薪。是彼类故。诸不生法不越彼类。虽永不起而说有为。彼彼经中。世尊随义名世路等。彼复云何。谓诸有为亦名世路。色等五蕴生灭法故。未来现在过去路中而流转故。或为无常所吞食故。名为世路。诸不生法众缘阙故。虽复不生是彼类故。立名无失。诸有为法亦名言依。言谓言音。或谓能说此言远近所托名依。即义与名总说依故。以名依义言复依名。是故言依总摄名义。如是名义具摄五蕴。故契经说。言依有三无四无五。由比善释品类足论。彼说言依五蕴所摄。依是因义无为无果。故非言依。又若聚中三事可得。谓语依义说名言依。无为聚中唯有其义。无语依故不名言依。有说无为有依有义。但阙语故不名言依。又诸有为与能言体有俱起义。无为不然。诸有为法亦名有离。离谓永离即是涅槃。得已不还。堕生死故。有彼离故。说名有离。如有财者名为有财。此虽有为而非一切。以无漏道无择灭故。又涅槃时亦舍圣道。故名有离。以说圣道犹如船筏亦应断故。如契经言。法尚应断。何况非法。诸有为法亦名有事。事谓所依。或是所住。即是因义。果依于因。从因生故。如子依母。或果住因能覆因故。如人住床。是因为果所映蔽义。因果前后故。及细粗性故。此有事故。说名有事。喻如前说。如是等类说有为法。诸名差别于此所说有为法中。颂曰

  有漏名取蕴　　亦说为有诤
  及苦集世间　　见处三有等

论曰。前说除道余有为法。名为有漏。已辩其体。今为显彼名想不同及差别义故复重说。已说一切有为名蕴。今说有漏名为取蕴。义准无漏但得蕴名唯诸漏中立取名想。以能执取三有生故。或能执持引后有业。故彼诸漏说名为取。色等五蕴从取生故。或生取故。名为取蕴。如草糠火。如花果树。诸有漏法亦名有诤。谓烦恼中立诤名想。扰动善品故。损害自他故。蕴与诤俱。或诤蕴俱而得生起。故名有诤。此意显示诤之与蕴非随阙一余可得生。及者显余有漏名想。谓或名苦。即五取蕴。是诸逼迫所依处故。自性粗重不安隐故。或名为集。即彼种类能为因故。能集成故。谓从取蕴取蕴集成。或名世间可毁坏故。如世尊说。性可毁坏。故名世间。非诸圣道性可毁坏。亦名世间。由此中无对治坏故。或名见处。萨迦耶等五见住中随增眠故。由彼诸见于有漏法一切种时相无差别。坚执无动随增眠故。体用增盛。故复别说。贪等痴疑则不如是。以彼贪等有一切种无一切时。痴一切时非无差别。疑无差别。而不坚执。是故有漏。不说彼处。或名三有。有因有依三有摄故。等言为摄名有染等。如是等类是有漏法。随义别名

说一切有部显宗论卷第一阿毗达磨藏显宗论卷第二

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩本事品第二之二

如上所言。色等五蕴名有为法。色蕴者何。颂曰

  色者唯五根　　五境及无表

论曰。此中色言显色蕴义。五根谓眼耳鼻舌身。五境谓色声香味触。眼等所摄所行名境。及无表者。谓法处色。唯者唯此所显十处。一处少分名为色蕴。如是诸色其相云何。颂曰

  彼识依净色　　名眼等五根

论曰。彼谓前说眼等五根。识即眼耳鼻舌身识。依者眼等五识所依。如是所依净色为体。如是即显眼等五识。所依净色名眼等根。故薄伽梵于契经中说眼等根净色为相。本论亦说。云何眼根。眼识所依净色为性。如是广说诸圣教中。以根别识不以境界。故知彼言显根非境。有说。彼者是境非根。而无意识。缘色等故。名色等识。彼识所依。名眼等过。由净色言所简别故。已辩根相。当辩境相。颂曰

  色二或二十　　声唯有二种
  味六香四种　　触十一为性

论曰。言色二者。是二种义。谓显与形。此中显色有十二种。形色有八。故或二十。显十二者。谓青黄赤白烟云尘雾影光明闇。于十二中青等四种是正显色。云等八种是此差别。其义隐者。今当略释。地水气腾说之为雾。障光明起于中余色可见名影。翻此为闇。日焰名光。月星火药宝珠电等诸焰名明。形色八者。谓长短方圆高下正不正。此中正者。谓形平等。形不平等名为不正余色易了。故今不释。已说色处。当说声处。能有呼召。故名为声。或唯音响。说之为声。善逝圣教咸作是说。声是耳根所取境界。是四大种所造色性。此声二种。谓有执受。或无执受。大种为因执受大种。谓现有情长养等流异熟地等。与此相违名无执受。由此所发为二种声。色等亦应作如是说。然由声处自性难知。故但就因说有二种。无一声性以有执受。及无执受大种为因。二四大种各别果故。非二四大同得一果为俱有因成过失故。虽二大种有相扣击。而俱为因各别发声。据自依故不成三体。虽有手鼓相击为因。发生二声而相映夺。随取一种相别难知。是故声处唯有二种。已说声处。当说味处。越次说者显彼境识。生无定故味谓所啖。是可尝义。此有六种。甘酢碱辛苦淡别故。已说味处当说香处。香谓所嗅。此有四种。好香恶香等不等香有差别故。等不等者。增益损减依身别故。有说。微弱增盛异故。本论中说。香有三种好香恶香及平等香。若能长养诸根大种。名为好香。与此相违名为恶香。无前二用名平等香。或胜福业增上所生。名为好香。若胜罪业增上所生。名为恶香。若四大种。增上所起。名平等香已说香处。当说触处。触谓所触十一为性。即十一实以为体义。谓四大种及七造触。滑性涩性重性轻性。及冷饥渴有差别故。此中能触所触者谁。应知都无能触所触。相触则失。刹那性故。但于身识所依所缘无间生时。立触名想。依此根识得彼境时。假说此根能触彼境。触非身识所依止故。不说彼触能触身根。触与身根极相邻近。故说所触能触非余。色等虽非所触法性。所依坏故而亦有损。已说境相。唯余无表此今当辩。颂曰

  作等余心等　　及无心有记
  无对所造性　　是名无表色

论曰。言作等者。等取离作无对造色。略有二种。一者依表。二者依心。依表起者复有二种。谓与作俱转。及作息随转。为摄如是无表差别体相无遗。故说作等。言余心等者。等取同类心。谓善心作近因等起或俱有因。彼所发善无对造色不善无记名余心。善心名同类。不善心作近因等起。所发不善无对造色善及无记名余心。不善名同类。及无心者即心灭位。谓定非生。生位无故。及言乘上及此非余。于三位中此容随转。谓定唯等不善兼余散善通于三位转故。言有记者。谓善不善可记为爱非爱品故。言无对者。非极微故。所造性者。不简大种。以大种性非无对故。但简非色。显是色性即五蕴中色蕴摄故。是者是前所说诸相。具前诸相名无表色。如是已辩无表色相。于中所说大种所造。大种云何。颂曰

  大种谓四界　　即地水火风
  能成持等业　　坚湿暖动性

论曰。此诸大种何缘名界。一切色法出生本故。亦从大种大种出生。诸出生本世间名界。如金等矿名金等界。或种种苦出生本故。说名为界。喻如前说。有说。能持大种自相及所造色。故名为界。如是诸界亦名大种。何故言种。云何名大。种种造色差别生时。彼彼品类差别能起。是故言种。由四大种有差别故。造色差别。有说。有情业增上故。无始时来未尝非有。是故言种。由四大种总相种类无间绝故。或法出现即名为有。生长有性。是故言种。即是生长诸法有性。或是生长有情身义。或能显了十种造色是故言种。由此势力彼显了故。所言大者。有大用故。言大用者。谓诸有情根本事中。如是四种有胜作用。依此建立识之与空。乃得说为有情根本。又于诳惑愚夫事中。此四最胜。故名为大。如桥贼中事业胜者。别余故名大桥大贼。又此四种。普为一切余色所依。广故名大。有说。一切色等聚中坚等具有。故名为大。风增聚中阙于色等火增聚中阙于昧等。色界诸聚香味俱无。青等聚中阙于黄等。滑等聚中阙于涩等。声等不定。是故唯此四种名大。此四大种虽常和合恒不相离。而非处同。云何得知恒不相离。入胎大造经等说故。又理应然。何等为理。谓石等中现有能摄生火增坠三业可得。故知于此有水火风恒不相离。于水聚中现有持船暖性流动三业可得。故知于此有地火风恒不相离。于火焰中现有任持摄聚击动三业可得。故知于此有地水风恒不相离。于风聚中现有能持起冷暖触三业可得。故知于此有地水风恒不相离。复云何知如是四界。由此因缘恒相随逐。由此能成持等业故。谓地等界如次能成。持摄熟长四种事业。由此因缘于诸色聚。若有持等四业可得。即知此中有地等界互不相离。应知此中言能长者。谓能安布。云何安布。谓令增盛或复流漫。为能持等四业即是界自相耶。不尔云何。如是四界随其次第坚湿暖动以为自相。应知此中说性显体。为明体性不相离故。动谓能引大种造色。令其相续生至余方。何故虚空不名大种。彼大种相不成立故。能损益故。立大种名。虚空不然。故非大种。或于诸法生灭位中性无差别故。非大种现见大种。种等位中其相转变成芽等缘。方令芽等诸位得起。虚空无为则不如是性相常故。作用都无。既不能生。故非大种。又诸大种非一非常。自相众多果别无量。虚空自性是一是常。相无差别。全无有果。非无别因。生有别果。是故虚空不名大种。若谓余因有差别故能助虚空生别果者。即此别因能生别果。何用执此虚空为因。为地等界即地等耶。不尔云何。颂曰

  地谓显形色　　随世想立名
  水火亦复然　　风即界亦尔

论曰。地言唯表显形色处。岂不总地四处合成。何故但言显形为地。此中虽有香味触三。而随世想故作是说。由诸世间相示地者以显形色而相示故。虽诸世间亦于香等起地言说谓作是言。我今嗅地尝地触地。而显形色。于地水火能通表示。是故偏说。世不多言我嗅于水。亦不多说嗅尝于火。虽言触地等而即地等界。是故地中虽有香等。而形与显胜故偏说。又显形色表示二界地等无异。是故偏说。若尔显形表示衣等胜香等故。亦应偏说。世起名想无有决定。故随世间差别而说。此随多分世想立名。生等非显声非相续。故不说为地等衣等。如地但用显形为体水火亦然。随世想故。由世现见水青长等。故说显形为水自性。世亦现见火赤长等。故说显形为火自性。然即色触转变生时。名火焰炭。是假非实。无一实物。身眼得故。如是地等与界差别。风即界者。世间于动立风名故。风界无别。岂不世间于显形色亦生风想。世间现以黑风团风而相示故。有通此难。故说言示是如地等与界别义。古昔诸师咸作是说。地于中杂故见如此。为显其风即是风界。故复言尔。尔者定义。此二说中前说为胜。遍处不净无差别故。不净唯缘色处境故。颂曰

  此中根与境　　即说十处界

论曰。已说实物根境无表为色蕴性。此中根境亦即说为十处十界。于处门中立为十处。谓眼处等。于界门中立为十界。谓眼界等。已说色蕴并立处界。当说受等三蕴处界。颂曰

  受领纳随触　　想取像为体
  四余名行蕴　　如是受等三
  及无表无为　　名法处法界

论曰。随触而生。领纳可爱及不可爱。俱相违触名为受蕴。领纳即是能受用义。云何此受领纳随触。谓受是触邻近果故。此随触声为显因义。能顺受故如随相言。相谓表彰。即能显示。因能显果。故立相名。此随相言。是顺因义。受能领纳。能顺触因。是故说受领纳随触。如世尊言。顺乐受触顺苦受触及顺不苦不乐受触。即是顺生乐受等义。领纳随触名自性受。领纳所缘亦是受相。与一境法别相难知。一切皆同领纳境故。以心心所执受境时。一切皆名领纳自境。是故唯说领纳随触。名自性受别相定故。领纳所缘名执取受。非此所辩相不定故。二受差别如顺正理及五事论广辩应知。此总说三。别说为六。世及所依有差别故。第三想蕴其体是何。此于所缘取像为体。谓于一切随本安立青长等色。琴贝等声。生莲等香。苦辛等味。滑涩等触。生灭等法。所缘境中如相而取。故名为想。此想就世总说为三。若就所依别说为六。第四行蕴其体是何。此用四余诸行为体谓除前说色受想三。及除当说识为第四。余有为法名为行蕴。此有相应及不相应思等得等如其次第。契经唯说。六思身者。由最胜故。所以者何。思是业性为因感果。其力最强。故世尊说。若能造作有漏有为名行取蕴。不可唯说思为行蕴。立总名故如法处界。若异此者应但名思。一法成故。如受想蕴。此中意显。如外第六。法处界声。立总名故。总摄十一十七处界不摄多法。如是行声。立总名故。总摄四蕴不摄多行。故知行蕴体不唯思。如是行蕴非尽有依。故唯约世总说三种。如前分别色蕴体已。便约处界二门建立如是。此中辩受想行三蕴体已。亦应建立为处及界。谓此三蕴及无表色并三无为。如是七法。于处门中立为法处。于界门中立为法界。第五识蕴自性处界其相云何。颂曰

  识谓各了别　　此即名意处
  及七界应知　　六识转为意

论曰。识谓了者。是唯总取境界相义。各各总取彼彼境相。名各了别。谓识唯能总取境相。非能取彼境相差别。如世尊言。了者名识。有余师说。唯于法性。假说作者。为遮离识有了者计。何处复见唯于法性。假说作者。现见说影。能行动故。此于异处无间生时。虽无动作而说作者。识亦如是。于异境界相续生时。虽无动作而说了者。谓能了境故亦无失。云何知然。现见余处遮作者故。如世尊告颇勒具那。我终不说有能了者。复有说言。刹那名法性。相续名作者。自意所立思缘起中。当更显示。此识约世总说为三。就所依根别分为六。应知即此所说识蕴。于处门中立为意处。于界门中立为七界。及声显一析为二门。显一一识体分处界。七界者何。六识及意。谓眼识界至意识界。即此六识转为意界。此别建立蕴处界门。应知遍摄诸法皆尽。此中应思。若即识蕴名七心界。前说识蕴。就所依根别分为六。今离六识。说何等法复名意界。更无异法即于此中。颂曰

  由即六识身　　无间灭为意

论曰。即六识身无间灭已能生后识。故名意界。时分异故别立无失。犹如子果立为父种。若尔界体应唯十七或唯十二。更相摄故。何缘建立十八界耶。颂曰

  成第六依故　　十八界应知

论曰。如五识界别有眼等五界为依。第六意识无别所依。如离所缘识无起义离依亦尔。识不得生。为成此依故说意界。如是所依能依境界。应知各六界成十八。如何已灭名现识依。是现识生邻近缘故。如虽有色而要依眼眼识得生。如是虽有所缘境界。而后识生要依前念无间灭意。是故前言无间灭者。为遮前念有间灭心。虽先开避而未生故。由此无间已灭六识为现识依。说为意界。或现在识正成依用。过去已成等无间缘。亦于现在能取果故。虽依彼生而非随彼。故心依心不名心所。心所品类必随心故。已释诸蕴取蕴处界。当于此中思择摄义。诸蕴总摄一切有为。取蕴唯摄一切有漏。处界总摄一切法尽。五蕴无为名一切法。别摄如是。应辩总摄。颂曰

  总摄一切法　　由一蕴处界
  摄自性非余　　以离他性故

论曰。一蕴谓色。一处谓意。一界谓法。此三总摄五蕴无为。总是集义。置总言者。令知总三勿谓各一。有余部执。摄谓摄他。处处说言余摄余故。此执非理。无定因故。若有定因非摄他故。我部诸师说自性摄。如是所立摄自性言。是究竟说。不待他故。摄不待因是真实摄。诸法恒时摄自性故。复云何知不摄他性。以一切法离他性故。谓眼根性离耳等性。彼离于此而言此摄。理必不然。故知诸法唯摄自性。如是眼根唯摄色蕴。眼处眼界苦集谛等。是彼性故。不摄余蕴。余处界等离彼性故。如是余法随应当思眼耳鼻根各依二处。何缘界体数不成多。合二为一。故唯十八。何缘合二为一界耶。颂曰

  类境识同故　　虽二界体一

论曰。眼耳鼻根虽各二处。类等同故合为一界。言类同者。同眼类故。言境同者。同色境故。言识同者。眼识依故。耳鼻亦然。故立一界。界体既一。处何缘二。颂曰

  然为令端严　　眼等各生二

论曰。为所依身相端严故。界体虽一而两处生。若眼耳根处唯生一。鼻无二穴。身不端严。此释不然。驼猫鸱等。如是丑陋何有端严。是故诸根各别种类。如是安布差别而生。此待因缘如是差别。因缘有障或不二生。言为端严各生二者。此有别义。非为严身。此端严声显增上义。作用增上。故说端严。若眼等根各阙一处。见闻嗅用皆不明了。各具二者明了用生。是故三根各生二处。为严胜用。非为严身。何故世尊于所知境以蕴处界三门说耶。由此三门义各别故。此蕴处界别义者何。颂曰

  聚生门种族　　是蕴处界义

论曰。积聚义是蕴义。生门义是处义。种族义是界义。何缘故知聚义是蕴。由契经说。诸所有色。若过去若未来若现在。若内若外。若粗若细。若劣若胜。若远若近。如是一切略为一聚。说名色蕴。乃至识蕴广说亦然。由此故知聚义是蕴。若以聚义释蕴义者。蕴应非实。聚是假故。此难不然。于聚所依立义言故。非聚即义。义是实物。名之差别。聚非实故。聚义者何。谓聚之义。聚之义者。谓聚所依。此释显经有大义趣。谓如言聚。离聚所依无别实有聚体可得。如是言我。色等蕴外不应别求实有我体。蕴相续中假说我故。如世间聚我非实有。蕴若实有经显何义。勿所化生知色等法三时品类无量差别各是蕴故。蕴则无边便生怯退。谓我何能遍知永断此无边蕴。为策励彼。蕴虽无边而相同故总说为一。又诸愚夫于多蕴上生一合想现起我执。为令彼除一合想故。说一蕴中有众多分。不为显示色等五蕴多法合成是假非实。又一极微三世等摄。以慧分析略为一聚。蕴虽即聚而实义成。余法亦然。故蕴非假。又于一一别起法中亦说蕴故。蕴定非假。如说俱生。受名受蕴。想名想蕴。余说如经。于一切时和合生故。蕴虽各别而聚义成。何缘故知门义是处。由训词故。处谓生门。心心所法于中生长。故名为处。是能生长彼作用义。如契经说。梵志当知。以眼为门唯为见色。此经唯证门义有六。然心心所有十二门。故契经说。眼及色为缘生于眼识。三和合触俱起受想思。乃至广说何缘故知族义是界。与世种族义相似故。如一山中有诸雄黄雌黄赤土安膳那等众多种族。说名多界如是一身或一相续有十八类。诸法种族名十八界。如雄黄等展转相望体类不同。故名种族。如是眼等展转相望体类不同。故名种族。由义相似得为同喻若尔意界望六识身无别体类。不应别立所依能依。体类别故无斯过失。何故世尊说蕴处界三门差别虽佛世尊意趣难解而审思忖。颂曰

  愚根等三故　　说蕴处界三

论曰。所化有情愚根等三故佛随宜为说蕴处界三。等言为明乐位过病等。三言为显一一各有三。所化有情愚有三种。有愚心所总执为我。有唯愚色。有愚色心。根亦有三。谓利中钝。乐谓胜解。此亦三种。谓乐略中。及广文故位谓弟子。已过作意。已熟习行。初修事业。三位别故过谓有情。怀我慢行。执我所随。迷识依缘。三过别故。病谓所化恃命财族而生憍逸。三病异故。由此等缘如其次第。世尊为说蕴处界三。何故世尊诸心所内别立受想为二蕴耶。颂曰

  诤根生死因　　及次第因故
  于诸心所法　　受想别为蕴

论曰。世间诤根略有二种谓贪着欲及贪着见。初因受起。后由想生。味受力故贪着诸欲。倒想力故贪着诸见。又生死法以受及想为最胜因耽乐受故。执倒想故。爱见行者生死轮回。由此二因及后当说次第因故。应知别立受想为蕴。其次第因次后当辩。及声兼显诸心所中。唯此受想能为爱见。二杂染法生根本故。各别显一。识住名故。依灭此二。立灭定故。诸如是等多品类因。何故说无为在处界非蕴。颂曰

  蕴不说无为　　义不相应故

论曰。诸无为法若说为蕴。立在五中或为第六。皆不应理。义相违故。所以者何。彼且非色乃至非识。故非在五。聚义是蕴。非无为法。如彼色等有过去等。品类差别可略一聚。名无为蕴。故非第六。又无为法与颠倒依及断方便义相违故说有漏蕴显颠倒依。说无漏蕴显断方便。无为于此两义都无。义不相应。故不立蕴。已辩诸蕴废立因缘。当辩次第。颂曰

  随粗染器等　　界别次第立

论曰。五蕴随粗随染器等及界别故次第而立。随粗立者。五中最粗。所谓色蕴有对碍故。五识依故。六识境故。五中初说四中最粗。所谓受蕴虽无形质。而行相用易了知故。四中初说三中最粗。所谓想蕴取男女等行相作用易了知故。三中初说二中粗者。所谓行蕴贪等现起行相分明易了知故。二中初说识蕴最细故最后说随染立者。谓从无始生死已来。男女于身更相染爱由显形等。故初说色。如是色爱由耽受味。故次说受此耽受味由想颠倒。故次说想。此想颠倒由烦恼力。故次说行。此烦恼力依能引发后有识生。故后说识。随器等者。谓色如器。受所依故。受类饮食。增益损减有情身故想同助味。由取怨亲中平等相助生受故。行似厨人。由思贪等业烦恼力。爱非爱等异熟生故。识喻食者。有情本中为主胜故识为上首。受等生故。即由此理。于受想等随福行中。但说识为随福行者。又由此理说行缘识。由此复告阿难陀曰。识若无者不入母胎。心杂染故有情杂染。心清净故有情清净。于受想等俱起法中。如是等经但标主识。随界别者。谓欲界中色最为胜。诸根境色皆具有故。色界受胜。于生死中诸胜妙受具可得故。三无色中想最为胜。彼地取相最分明故。第一有中行最为胜。彼思能感最大果故。此即识住。识住其中。显似世间田种次第。是故诸蕴次第如是。由此五蕴无增减过。即由如是诸次第因。于心所中别立受想。谓受与想于心所中相粗生染类食同助。二界中强故别立蕴。已随本颂。且就转门说次第因。四种如是当就还门复说一种。谓入佛法有二要门。一不净观。二持息念。不净观门观于造色。持息念门念于大种。要门所缘。故先说色。由此观力分析色相。刹那极微展转差别。如是观时。身轻安故心便觉乐。故次说受。受与身合定为损益。损益于我理必不成。由斯观解我想即灭法想便生。故次说想。由此想故达唯有法烦恼不行。故次说行。烦恼既息心住调柔有所堪能。故次说识。已说顺次。逆次应说。恐厌繁文。故应且止

说一切有部显宗论卷第二阿毗达磨藏显宗论卷第三

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩本事品第二之三

如是已说诸蕴次第。于界处中应先辩说六根次第。由斯境识次第可知。眼等何缘如是次第。颂曰

  前五境唯现　　四境唯所造
  余用远速明　　或随处次第

论曰。于六根中眼等前五唯取现境。是故先说。意境不定三世无为。或唯取一。或二三四。是故后说。境决定者。用无杂乱其相分明。所以先说。境不定者。用有杂乱相不分明。所以后说。所言四境唯所造者。前流至此五中前四境唯所造。是故先说。身境不定大种造色俱为境故。所以后说。或时身根唯取大种。或时身根唯取所造。或时身根俱取二种。是故身识。有说。极多缘五触起。谓四大种滑等随一。有说。极多缘十一起。余谓前四。如其所应用远速明。是故先说。谓眼耳根取远境故。在二先说。二中眼用远故先说。如远丛林风等所击现观摇动不闻声故。又眼用速先远见人。撞击钟鼓后闻声故。鼻舌两根用俱非远。先说鼻者。由速明故。如对香美诸饮食时。鼻先嗅香舌后尝味。如是且约境定不定用远速明辩根次第。或于身中随所依处安布上下说根次第。传说身中眼处最上。又显在面。是故先说。耳鼻舌根依处渐下。身处多下意无方处。有即依止五根生者。故最后说。岂不理实。鼻根极微。住鼻頞中。非居眼下。如说三根横作行列处无高下。如冠花鬘。理实应尔。然经主意。就根依处假说如此。经主或言。似通余释。故今于此别作颂文

  前五用先起　　五用初二远
  三用初二明　　或随处次第

于六根中。眼等前五于色等境先起作用。意后方生。是故先说。如本论言色等五境。五识先受意识后知。为自识依及取自境。应知俱是眼等功用。于五根中初二用远境不合故。所以先说。二中眼用复远于耳。引事如前。是故先说。鼻等三用初二分明。故鼻居先舌次身后。如鼻于香能取微细。舌于甘苦则不如是。如舌于味能取微细。身于冷暖则不如是。随处次第释不异前。如是已说处界次第。即于此中应更思择。何缘十处体皆是色。惟于一种立色处名。又十二处体皆是法。唯于一处立法处名。颂曰

  为差别最胜　　摄多增上法
  故一处名色　　一名为法处

论曰。虽十二处十色皆法。而为差别一立总名。言差别者。谓各别处。若色法性等故名同。是则处名应二或一。诸弟子等。由此总名唯应总知。不了别相。为令了知境及有境种种差别。故立异名。由是如来于其声等眼等色上立别义名。色处更无别义名故。总名即别。如能作因诸立别名。为显别义。此显别义。故即别名。法处亦尔。言最胜者。由二因缘。唯色处中色相最胜。一有见故可示在此在彼差别。二有对故。手等触时即便变坏。又多种故。三眼境故。世共于此立色名故诸大论师。非于声等立色名故。唯一名色于法处中摄受想等众多法故。应立通名。若离通名。云何能摄多别相法同为一处。又于此中摄多品类。法名诸法。故立法名。谓择法觉支法智法随念法证净法念住法无碍解法宝法归。此等法名有无量种。一切摄在此法处中。故独名法。又增上法。所谓涅槃。此中摄故。独名为法。诸契经中有余种种蕴及处界名想可得。皆在此摄。如应当知。且辩摄余诸蕴名想。颂曰

  牟尼说法蕴　　数有八十千
  彼体语或名　　此色行蕴摄

论曰。有说。佛教语为自体。彼说法蕴皆色蕴摄。语用音声为自性故。有说。佛教名为自体。彼说法蕴皆行蕴摄。名不相应行为性故。语教异名。教容是语。名教别体教何是名。彼作是释。要由有名乃说为教。是故佛教体即是名。所以者何。诠义如实。故名佛教。名能诠义。故教是名。由是佛教定名为体。举名为首以摄句文。齐何应知诸法蕴量。颂曰

  有言诸法蕴　　量如彼论说
  或随蕴等言　　如实行对治

论曰。有诸师言。八万法蕴一一量等法蕴足论。谓彼一一有六千颂。如对法中法蕴足论。或说法蕴随蕴等言。一一差别数有八万。谓蕴处界缘起谛食静虑无量无色解脱胜处遍处觉品神通无诤愿智无碍解等。一一教门名一法蕴。如实说者。所化有情有贪嗔痴我慢身见及寻思等八万行别。为对治彼八万行故。世尊宣说八万法蕴。谓说不净慈悲缘起无常想空持息念等诸对治门。此即顺显随蕴等言。无蕴等言不为对治有情病行唐捐而说。如彼所说八万法蕴。皆此五中二蕴所摄。如是余处诸蕴处界类亦应然。颂曰

  如是余蕴等　　各随其所应
  摄在前说中　　应审观自相

论曰。余契经中诸蕴处界。随应摄在前所说中。如此论中所说蕴等。应审观彼一一自相。且诸经中说余五蕴。谓戒定慧解脱解脱智见五蕴。彼中戒蕴此色蕴摄。是身语业。非意思故。彼余四蕴此行蕴摄。是心所法。非受想故。又诸经说十遍处等。前八遍处及八胜处。无贪性故此法处摄。若兼助伴五蕴性故。即此意处法处所摄。后二遍处空无边等四无色处四蕴性故。亦此意处法处所摄。五解脱处慧为性故。此法处摄。若兼助伴即此声意法处所摄。复有二处。谓无想有情天处。及非想非非想处。初处即此十处所摄。无香味故。后处即此意法处摄。无色性故。又多界经说界差别有六十二。应随其相当知摄在十八界中。且彼经中所说六界。地水火风四界已辩。空识二界未辩其相。如是二界其相云何。颂曰

  空界谓窍隙　　体即是光闇
  识界有漏识　　有情生所依

论曰。内外窍隙名为空界。窍隙是何。即是光闇。谓窗指等光闇窍隙。显色差别名为空界。应知此界体是实有。说内外故。如地界等此离虚空其体别有。由契经故其理极成如契经言。虚空无色无见无对。当何所依。然藉光明虚空显了。又说于色得离染时断虚空界。故知别有。已说空界。诸有漏识名为识界。何故不说无漏识耶。彼与此义不相应故。由无漏法于有情生断害坏等差别转故。非生所依。如是六界于有情生生养长因差别转故。是生所依。生因谓识界续生种故。养因谓大种生依止故。长因谓空界容受生故。持有情生故名为界。彼经六界此九界摄。余随所应当观摄义。故诸余界十八界摄。如是已说余蕴处界皆在此中。蕴处界摄今当显示。蕴处界三有见等门义类差别。界中具显根境识故。诸门义类易可了知。故今且约十八界辩。由斯蕴处义类已成。于前所说十八界中。几有见几无见。几有对几无对。几善几不善几无记。颂曰

  一有见谓色　　十有色有对
  此除色声八　　无记余三种

论曰。十八界中一是有见。所谓色界。云何说此名有见耶。由二义故。一者此色定与见俱。故名有见。由色与眼俱时转故。如有伴侣。二者此色可有示现。故名有见。可示在此在彼别故。如有所缘。有说。此色于镜等中有像可现。故名有见可示如彼此亦尔故。不可说声有谷响等。应成有见不俱生故。由说此相。余界无见义准已成。如是已说有见无见。唯色蕴摄十界有对。对是碍义。此有彼碍故名有对。此复三种。境界所缘障碍别故。境界有对。谓眼等根心及心所。诸有境法与色等境和会被碍。得有对名。所缘有对。谓心心所于自所缘和会被碍。得有对名。境界所缘复有何别。若于彼法此有功能。即说彼为此法境界。如人于彼有胜功能。便说彼为我之境界。心心所法执彼而起。彼于心等名为所缘。若法所缘有对。定是境界有对。心心所法境界。若无取境功能。定不转故。有虽境界有对。而非所缘有对。谓五色根非相应法。无所缘故。云何眼等于自境界所缘转时。说名有碍。越彼于余此不转故。或复碍者。是和会义。谓眼等法于自境界及自所缘和会转故。有说。若法唯于彼转不能越彼。故名有碍。障碍有对。谓可集色自于他处被障不生。如手石等更相障碍。或于自处。障碍他生。唯极微色更相障故。可说名为障碍有对。此中唯辩障碍有对。故但言十。碍义胜故。何等为十。谓极微成十有色界唯有色故。法界贯通有色无色。彼色一向非极微成。除此所余十名有色。色蕴摄故。说十有色名为有对。义准说余名为无对。言有色者。谓除无表余色蕴摄。变碍名色。有变碍义。故名有色。有说。色者谓能示现在此彼言此有彼言。故名有色有说。诸色有自体故名为有色。称说易故。唯于色体说有色言。如是已说有对无对。于此所说十有对中。除色及声余八无记。言无记者。不可记为善不善故。应赞毁法可记说在黑白品中。名为有记。若于二品皆所不容。体不分明名无记法。其余十界通善等三。即是七心色声法界。善谓舍恶。是违恶义。或复善者名慧摄受。谓若诸法慧所摄受。或摄受慧。皆名为善。或复善者。是吉祥义。能招嘉瑞如吉祥草。翻此即释不善名义。色声二界。善心等起即名为善。恶心等起名为不善。余是无记。其七心界。若无贪等相应名善。贪等相应名为不善。余名无记。法界所摄品类众多。无贪等性相应等记择灭名善。若贪等性相应等起。名为不善。余名无记。已说善等。十八界中几欲界系。几色界系几无色界系。颂曰

  欲界系十八　　色界系十四
  除香味二识　　无色系后三

论曰。系谓系属。即被缚义。欲界所系具足十八。色界所系唯十四种。除香味境及鼻舌识。除香味者。段食性故。离段食欲方得生彼。除鼻舌识。无境界故。非无境界少有识生。若尔于彼亦应无触。非食性触于彼得有。触界于彼无成食用有成余用。所谓成身。若不尔者大种应无。则诸所造亦应非有。便同无色。何名色界。又于彼触有成外用。谓成宫殿及衣服等。虽离食欲触有别用。香味不然。故彼非有。无色界系唯有后三。所谓意法及意识界。要离色染于彼得生。故无色中无十色界。依缘无故五识亦无。故唯后三无色界系。已说界系。十八界中。几有漏几无漏。颂曰

  意法意识通　　所余唯有漏

论曰。次前意法及意识三。一切皆通有漏无漏。谓除道谛及三无为。余意等三皆是有漏。道谛所摄及三无为。如其所应三皆无漏。唯通有漏。谓余十五道谛无为所不摄故。如是已说有漏无漏。十八界中几有寻有伺。几无寻唯伺。几无寻无伺。颂曰

  五识有寻伺　　后三三余无

论曰。眼等五识有寻有伺。由与寻伺恒共相应。此五识身恒与寻伺共相应者。五识唯在寻伺所随地中有故。非于欲界初静虑中心心所法。除寻与伺。有一不与寻伺俱故。意法意识名为后三。根境识中各居后故。此后三界皆通三品。意界意识界及相应法界。除寻与伺。若在欲界初静虑中有寻有伺。静虑中间无寻唯伺。从此已上无寻无伺。法界一切非相应法。静虑中间伺亦如是。于彼上地无寻伺故。非相应故。彼无寻故。自体自体不相应故。寻一切时无寻唯伺。自体自体不相应故。此常与伺共相应故。伺在欲界初静虑中。三品不收应为第四。然法少故颂中不说。余十色界寻伺俱无。常与寻伺不相应故。此中乘便应更思量。若五识身有寻有伺。寻即分别。如何许彼无分别耶。颂曰

  说五无分别　　由计度随念
  以意地散慧　　意诸念为体

论曰。分别有三。一自性分别。二计度分别。三随念分别。由五识身虽有自性。而无余二。说无分别。如一足马名为无足。故虽有一而得名无。岂不意识有唯一种。分别相应由依意识。总类具三说有分别。自性分别体唯是寻。后心所中自当辩释。余二分别如其次第。意地散慧诸念为体。散言简定意识相应。散慧名为计度分别。定中不能计度境故。非定中慧能于所缘。如此如是计度而转。故于此中简定取散。若定若散意识相应诸念名为随念分别。明记所缘用均等故。五识虽与念慧相应。择记用微故唯取意。夫分别者。推求行相。故说寻为自性分别。简择明记片似顺寻。故分别名亦通慧念。由此三行差别摄持。皆令于境明了转异。于已了境遮简行生。故分别名不通于想。于未了境不能印持。故分别名不通胜解。若在欲界及初静虑。不定意识具三分别。若初静虑在定意识及上散心。各二分别。上地意识若在定中及五识身。各一分别。如是已说有寻伺等。十八界中几有所缘。几无所缘。几有执受。几无执受。颂曰

  七心法界半　　有所缘余无
  前八界及声　　无执受余二

论曰。六识意界及法界摄诸心所法名有所缘。有所缘故。如人有子。所缘所行及与境界名义差别。余十色界及法界摄不相应法名无所缘。义准成故。应知五识无分别故。缘实极微和集为境。不缘和合非和合名别目少法可为无分别识所取境成。于多法中起一增语。言说转故名为和合。五识不缘增语为境。是故和合非五所缘。如是已说有所缘等。十八界中九无执受。何等为九。谓前所说七有所缘并全法界。此八及声皆无执受。颂中及言具含二义。一显总集。谓八及声总无执受。二显异门。谓余师说。不离根声亦有执受。余九通二。谓五色根色香味触。云何通二。眼等五根。住现在世名有执受。过去未来名无执受。色香味触。住现在世不离五根名有执受。过去未来及住现在非不离根名无执受。是故九界各通二门。何等名为有执受相。本论中说。己身所摄名有执受。此复云何。谓心心所执为己有。即心心所共所执持。摄为依处名有执受。损益展转更相随故。若尔色等即应一向名无执受。心心所法不依彼故。非根性故。不尔色等若不离根虽非所依。而是心等之所亲辅。故无此失。如是已说有执受等。十八界中几大种性。几所造性。几可积集。几非积集。颂曰

  触界中有二　　余九色所造
  法一分亦然　　十色可积集

论曰。触界通二。一者大种。二者所造。此二如前十一触释。非唯大种总摄触界。各别处经说触处中摄造色故。余九色界唯是所造。谓五色根色声香味。法界一分亦唯所造。此复云何。谓无表色。依大种生故名所造。然声为显定无一界。唯大种性。余七心界法界一分。除无表色。俱非二种。义准已成。离大种外别有所造。各别处经即为诚证。如是已说大种所造。十八界中五根五境十有色界。是可积集。以是极微体可聚故。名可积集。义准余八。非可积集。体非极微不可聚故。如是已说可积集等。十八界中几能斫几所斫。几能烧几所烧。几能称几所称。如是六问今应总答。颂曰

  谓唯外四界　　能斫及所斫
  亦所烧能称　　能烧所称诤

论曰。色香味触成斧薪等。此即名为能斫所斫。唯者定义。意显斫等。决定是外四界。非余及言为显。能斫所斫俱通四界。即诸色聚相逼续生。异缘分隔令各续起。名能所斫刹那性故。理实都无能斫所斫。此所斫义身根等无非诸色根异缘分隔可令成二。各相续起。支分离身。则无根故。又身根等亦非能斫。净妙相故。如珠宝光。此等义言唯言所显。如能斫所斫体唯外四界。所烧能称其体亦尔。谓唯外四界名所烧能称。身等色根净妙相故。亦非二事。如珠宝光。声非色等相续俱转。有间断故。六义皆无能烧所称。有异诤论。谓或有说。能烧所称体亦如前。唯外四界。或复有说。唯有火界。可名能烧所称唯重。如是已说能所斫等。十八界中几异熟生。几所长养。几是等流。几有实事。几一刹那。如是五问。今应总答。颂曰

  内五有熟养　　声无异熟生
  八无碍等流　　亦异熟生性
  余三实唯法　　刹那唯后三

论曰。内五谓眼耳鼻舌身。有异熟生。及所长养遮等流性。是故不说。虽眼等根亦等流性。以有同类因则是等流果。由离异熟所长养外无等流性。是故应遮如离长养有异熟生。离异熟生有所长养。非离此二有别等流。为辩异门废总论别熟谓成熟。离因而熟。故名异熟。异熟体生名异熟生。或是异熟因所生故。名异熟生。略去中言。故作是说。譬如牛车。或所造业至得果时变而能熟。故名异熟。果从彼生名异熟生。或于因上假立果名。如于果上假立因名。如说六触处。即是所造业。饮食资助眠睡等持胜缘所益。名所长养。饮食等缘于异熟体。唯能摄护不能增益。别有增益。名所长养。应知此中长养相续。常能护持异熟相续。犹如外廓防援内城。既说声界无异熟生。义准非无等流长养。何缘声界非异熟生。数数间断复还生故。异熟生色无如是事。非随欲乐异熟果生。声随欲生。故非异熟。八无碍者。七心法界。此有等流异熟生性。若非异熟。同类遍行因所生者。名等流性。若异熟因所生起者。名异熟生。余谓余四色香味触。皆通三种。谓异熟生等流长养。实唯法者。实谓无为。以坚实故。此法界摄。故唯法界独名有实。意法意识名为后三。于六三中最后说故。唯此三界有一刹那。谓初无漏苦法忍品。非等流故名一刹那。此说正现行。亦非等流者。余有为法无非等流。唯初无漏五蕴刹那。无同类因而得生起。余有为法无如是事。等无间缘势力强故。前因虽阙而此得生。等无间缘势力强者。与初圣道品类同故。无量善法所长养故。与初圣道性相等故。为此广修诸加行故。苦法忍相应心。名意界意识界。余俱起法名为法界。如是已说异熟生等。今应思择。若有眼界先不成就今得成就。亦眼识耶。若眼识界先不成就今得成就。亦眼界耶。如是等问今应略答。颂曰

  眼与眼识界　　独俱得非等

论曰。独得者。谓或有眼界先不成就今得成就非眼识。谓生欲界渐得眼根。及无色殁生二三四静虑地时。或有眼识先不成就今得成就非眼界。谓生二三四静虑地眼识现起。及从彼殁生下地时。俱得者。谓或有二界先不成就今得成就。谓无色殁生于欲界及梵世时。非者俱非。谓除前相。等者。摄余所未说义。此复云何。谓若成就眼界。亦眼识界耶。应作四句。第一句者。谓生二三四静虑地眼识不起。第二句者。谓生欲界未得眼根。或得已失。第三句者。谓生欲界得眼不失。及生梵世若生二三四静虑地。眼识现前第四句者。谓除前相。如是眼界与色界。眼识与色界。得及成就如理应思。由斯理路例应思择。后五种三得与成就并互相望及舍不成。如毗婆沙。广文示现恐词繁杂。故今不述。如是已说得成就等。十八界中几内几外。颂曰

  内十二眼等　　色等六为外

论曰。六根六识十二名内。外谓所余色等六境。虽无实我而内义成。已说内外。十八界中几同分几彼同分。颂曰

  法同分余二　　作不作自业

论曰。法同分者。谓一法界唯是同分。今应先辩境同分相。若境与识定为所缘。且如法界与彼意识定为所缘。是不共故。识于其中已生生法。此所缘境说名同分。意能遍缘一切境故。于三世境及非世中。无一法界不于其中已正当生。无边意识二念意识。即能普缘一切法故。由是法界恒名同分。余二者。谓余十七界。皆有同分及彼同分。何名同分彼同分耶。谓作自业。不作自业。若作自业名为同分。不作自业名彼同分。如何眼等说为同分彼同分耶。且同分眼说有三种。谓于色界已正当见。彼同分眼说有四种。谓此相违及不生法。如眼耳鼻舌身亦然。各于自境应说自用。意界同分说有三种。谓于所缘已正当了。彼同分意唯有一种。谓不生法。色界同分说有三种。谓眼所见已正当灭。彼同分色说有四种。谓此相违及不生法。广说乃至触界亦尔。各对自根应说自用。眼等六识依生不生。立二分故。如意界说。眼若于一是同分。于余一切亦同分。此若于一是彼同分。于余一切亦彼同分。广说乃至意界亦尔。色即不然。于见者是同分。于不见者是彼同分。复有何缘说眼同分及彼同分。异于色耶。容多有情同见一色无用一眼二有情观。声如色说。是共境故。香味触三如内界说。非共境故。然诸世间依假名想。有言。我等同嗅此香。同尝此味。同觉此触。云何同分彼同分义。分谓交涉。同有此分。故名同分。云何交涉。谓根境识更相交涉。即是展转相随顺义。或复分者。是已作用更相交涉。故先说言。若作自业名为同分。或复分者。是所生触依根境识交涉生故。同有此分。故名同分。即同有用同有触义。与此相违名彼同分。由非同分与彼同分种类分同名彼同分。云何与彼种类分同。谓此与彼同见等相同处同界。互为因故。互相属故。互相引故。种类分同

说一切有部显宗论卷第三阿毗达磨藏显宗论卷第四

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩本事品第二之四

已说同分及彼同分。十八界中几见所断。几修所断。几非所断。颂曰

  十五唯修断　　后三界通三
  不染非六生　　色定非见断

论曰。言十五者。谓十色界及五识界。唯修断者。此十五界唯修所断。后三界者意界法界及意识界。于六三中最后说故。通三者。各通三。八十八随眠及彼相应法并彼诸得。若彼生等诸俱有法。皆见所断。所余有漏皆修所断。一切无漏皆非所断。为定斯义复言不染。非六生色定非见断。言不染者。谓有漏善无覆无记。非六生者。六谓第六。即是意处。异此而生名非六生。是从眼等五根生义。即五识等。色谓有漏染不染色。如是三类定非见断。且不染法及诸色法。非见断者。缘彼烦恼究竟断时。方名断故。断义云何。略有二种。一离缚断。二离境断。离缚断者。如契经言。于无内眼结如实了知我无内眼结。离境断者。如契经说。汝等苾刍若能于眼断贪欲者。是则名为眼得永断。阿毗达磨诸大论师。依彼次第立二种断。一自性断。二所缘断。若法是结及一果等对治生时。于彼得断名自性断。由彼断故。于所缘事便得离系。不必于中得不成就。名所缘断。此中一切若不染污有漏无色若有漏色及彼诸得生等法。上有见所断及修所断诸结所系。如是诸结渐次断时。于一一品各别体上起离系得时。彼诸结及一果等。皆名已断。彼不染污有漏无色及有漏色并彼诸得生等法上诸离系得。尔时未起。未名为断。由彼诸法唯随彼地最后无间道所断故。非诸见道能随地别渐次离欲。云何能断不染等法非六生法。非见断者。缘色等境外门转故。如是已说见所断等。十八界中几是见几非见。颂曰

  眼法界一分　　八种说名见
  五识俱生慧　　非见不度故
  眼见色同分　　非识见因故
  识类无别故　　不观障色故

论曰。眼全是见法界一分。八种是见。余皆非见何等为八。谓身见等五染污见。世间正见。有学正见。无学正见。于法界中此八是见。所余法界及余十六。一切非见。一切法中唯有二法。是见自体。有色法中唯眼是见。无色法中行相明利。推度境界内门转慧。是见非余。此中眼根如前已说。世共了故。观照性故。闇相违故。用明利故。说眼名见。五染污见随眠品中当辩其相。世间正见。谓意识相应善有漏胜慧。有学正见。谓有学身中一切无漏慧。无学正见。谓无学身中决度无漏慧。一正见言具摄三种。别开三者。为显异生学无学地三见别故。又显渐次修习生故。如是诸见总类有五。一无记类。二染污类。三善有漏类。四有学类。五无学类。无记类中眼根是见。耳等诸根一切无覆无记慧等悉皆非见。染污类中五见是见。余染污慧悉皆非见。谓贪嗔慢不共。无明疑俱生慧。余染污法亦皆非见。有学类中无慧非见。但余非见。无学类中尽无生智及余非见。余无学慧一切是见。善有漏类中。唯意识相应善慧是见。余皆非见。有余师说。意识相应善有漏慧亦有非见。谓五识身所引发慧。发有表慧。命终时慧。又于此善有漏类中。五识俱生慧亦非见。何缘如是所遮诸慧皆非见耶。不决度故。唯有如前所说慧相。是见自体。谓无色中行相明利推度境界内门转慧。是见非余。唯此相慧有决度能。于所缘境审虑转故。非所遮慧能于所缘审虑决度。是故非见。言决度者。谓于境界审虑为先决择究竟。非五识身相应诸慧。于已了境能审了知。以能推寻应非应理差别而转。故名决度。意识中慧。能于境界审虑为先决择究竟。可名为见。其五识身无分别故。彼相应慧无此功能。故不名见。若尔眼根既无此相。应不名见。岂不先说。世共了故。观照性故。闇相违故。用明利故。眼亦名见。契经亦言。眼见诸色。故说眼根能见诸色。若眼见者。何不同时得一切境。无斯过失。许少分眼。能见色故。少分者何。谓同分眼同分眼根。如前已说。识所住持乃成同分。非一切根同时自识。各所住持。故无斯咎。若尔即应彼能依识是见非眼。要眼识生方能见故。不尔眼识力所住持。胜用生故。如依薪力胜用火生。若见色用是识生法。此见色用。离眼应生。由识长益俱生大种。令起胜根能见众色。故不应说能依识见。谁有智者当作是言。诸有因缘能生了别。如是了别即彼因缘。识是见因。故非见体。又眼识体与耳等识无差别故。定非见体。眼识与彼耳等诸识有何差别而独名见。故执识见定为非理。复有余师。以别道理成立眼识定非是见。谓不能观被障色故。现见壁等所障诸色则不能观。若识见者。识无对故。壁等不碍应见障色。是故眼等取境义成。谓能见闻嗅尝觉了。如是见用总相已成。今更应思见用别相。于所见色。为一眼见。为二眼见。非二眼中随闭一眼。或一眼坏即令余眼无见功能。故知一眼亦能见色。若彼二眼不坏俱开。则二眼根同时见色。一眼见色义显易成。俱见难成。故应辩释。颂曰

  或二眼俱时　　见色分明故

论曰。或时二眼俱能见色。何缘定知。见分明故。以闭一眼。于色根续见不分明。开二眼时。即于此色见分明故。若二眼根前后见者。虽开二眼而但一见。如一眼闭见色不明。开二眼时亦应如是。如开二眼见色分明。一眼闭时亦应如是。既不如是。定知有时二眼俱见。依性一故。眼设百千尚生一识。况唯有二。如是所说眼等诸根正取境时。为至不至。何缘于此而复生疑。现见经中有二说故。如世尊说。有情眼根爱非爱色之所拘碍。非不相至。拘碍义成。又世尊说。彼以天眼观诸有情。广说乃至。或远或近。非于至境可立远近。由此二说故复生疑。根境相至其义不定。若就功能到境名至。则一切根唯取至境。若就体相无间名至。颂曰

  眼耳意根境　　不至三相违

论曰。眼耳意根取非至境。眼于远近俱时取故。又不能取邻逼境故。又亦能取颇胝迦等所障色故。又于所见有犹豫故。又眼无容至远境故。取非至境。耳根亦唯取非至境。方维远近声可了故。又取远近声有了不了故。又取远近声犹豫决定故。意根亦唯取非至境。不取俱有相应法故。又无色故非能有至。是故意根取非至境。余三鼻等与上相违。谓鼻舌身唯取至境。岂不极微非互相触。若诸极微遍体相触。即有实物体相杂过。若触一分成有分失。如何鼻等取至境耶。今观至义。谓境与根邻近而生方能取故。由此道理。说鼻舌身唯取至境。如言眼睑筹等至色眼不能见。非眼睑等要触眼根方得名至。但眼睑等邻近根生。即名为至。由不能见如是至色。故说眼根取非至境。如眼等根取非至境。然不能取极远境界。鼻等亦然。虽取至境而不能取极近境界。但由香等邻近根生。故说三根取至无过。非鼻香等根境极微展转相触非所触故。又是障碍有对性故。触即有失。为显此义复应研究。设有难言。若诸极微互不相触。如何抚击得发音声。今此岂同鸺鹠子等要由合德方乃生声。而为此难。然物合时理不成故。不应许有合德生声。若尔云何得有声发。于此真实圣教理中。离合系名唯依大种。谓有殊胜。二四大种离合生时。得彼名故。此位大种是声生因。唯此俱生声是耳境。此有何失。彼不忍受。我不忍受。亦有因缘。谓诸极微既不相触。彼此大种合义岂成。邻近生时即名为合。岂待相触方得合名。又汝不应踌躇此义。此彼大种定不相触。所以者何。是所触故。非能触故。诸色蕴中。唯有触界名为所触。唯有身根名为能触。此外触义更不应思。若谓所触亦能触者。应许身根亦是所触。则境有境便应杂乱。若谓此二无杂乱失。身识所缘所依别故。岂不由此转成杂乱。谓若身根亦所触者。何缘不作身识所缘。若许触界亦能触者。何缘不作身识所依。是故所言此彼大种定不相触。其理极成。若尔身根及与触界。如何能触所触得成。根境极微邻近生故。岂不一切鼻舌身根。皆取至境无差别故。则应能触通鼻舌根。所触亦应兼于香味。此难非理。邻近虽同而于其中有品别故。又滑涩等世间共起。所触想名对彼身根说名能触。故无有过。余广决择如顺正理。今应观察眼等诸根。为于自境唯取等量速疾转故。如旋火轮见大山等。为于自境通取等量不等量耶。颂曰

  应知鼻等三　　唯取等量境

论曰。前说至境。鼻等三根应知唯能取等量境。如鼻舌身根极微量。香味触境极微亦然。相称合生鼻等识故。岂不鼻等三根极微。有时不能遍取香等。何故乃说唯取等量。以非鼻等三根极微于香等微能取过量。故说唯能取等量境。非无少分三根极微。亦能取于少分三境。随境微量至根少多。尔所根微能起作用。眼耳不定。谓眼于色有时取小如见毛端。有时取大。如暂开目见大山等。有时取等。如见蒲桃野枣果等。耳根亦取蚊雷琴声小大等量。意无质碍不可辩其形量差别。颂中应知言。兼劝知此义。今乘义便复应观察。云何眼等诸根极微。安布差别不可见故。虽难建立。而有对故。住方处故。和集生故。定应说其安布差别。眼根极微居眼星上。对向自境傍布而住。如香菱华清澈膜覆令无分散。有说。重累如丸而住。体清澈故。如秋泉池不相障碍。耳根极微居耳穴内旋环而住。如卷桦皮。鼻根极微居鼻頞内背上面下。如双爪甲。此初三根横作行度无有高下。如冠华鬘。舌根极微布在舌上。形如半月当舌形中。如毛端量。非为舌根极微所遍。身根极微遍住身分。如身形量。女根极微形如鼓[壺*桑]。男根极微形如指[韋*沓]。眼根极微有时一切皆是同分。有时一切皆彼同分。有时一分是彼同分。余是同分。乃至舌根极微亦尔。身根极微定无一切。皆是同分。乃至极热奈落迦中。猛焰缠身犹有无量身根极微是彼同分。故如是说。设遍发识身应散坏。以无根境各一极微为所依缘。能发身识五识决定。积集多微方成所依。所缘性故。云何建立六识所依。为如五识唯缘现在意识通缘三世非世。如是诸识依亦尔耶。不尔云何。颂曰

  后依唯过去　　五识依或俱

论曰。由六识身无间灭已。皆名为意。此与意识作所依根。是故意识唯依过去眼等。五识所依或俱。或言表此亦依过去。谓眼等五是俱所依。过去所依即是意界。如是五识所依各二。第六意识所依唯一。为显颂中依义差别。故复应问。若是眼识所依性者。即是眼识等无间缘耶。设是眼识等无间缘者。复是眼识所依性耶。应作四句。第一句。谓俱生眼根。第二句。谓无间灭心所法界。第三句。谓过去意根。第四句。谓除前所说。乃至身识亦尔。各各应说自根意识。应作顺前句答。谓是意识所依性者。定是意识等无间缘。有是意识等无间缘。非与意识为所依性。谓无间灭心所法界。又五识界如所依根定有过现。彼所缘境。为亦如是。为有别耶。定有差别。已灭未生。非五识境。所以者何。由与所依一境转故。于非现境依不转故。契经既说。眼色为缘生于眼识。乃至广说。何因识起俱托二缘得所依名。在根非境。颂曰

  随根变识异　　故眼等名依

论曰。眼等即是眼等六界。由眼等根有转变故。诸识转异随根增损。有明昧故。非色等变令识有异。以识随根不随境故。依名唯在眼等非余。若尔意识亦随身转。谓风病等损恼身时。意识则乱身安静位。意识明了。何缘彼意识。不以身为依。随自所依。故无此失。谓风病等损恼身时。发生苦受相应身识。如是身识名乱意界。此与苦受俱谢灭时。能为意根生乱意识。与此相违意识明了。是故意识随自所依。随自依言。显随增损明昧差别。非显有记无记等类。何缘所识是境非根。而立识名。随根非境。颂曰

  彼及不共因　　故随根说识

论曰。彼谓前说眼等名依。故立识名。随根非境。依是胜故。及不共者。谓眼唯自眼识所依。色亦通为他身眼识。及通自他意识所取。乃至身触应知亦然。岂不意识境不共故。应名法识。此难非理。通别法名共非遍故。境不具前二种因故。谓通名法非唯不共。别名法界非遍摄识。又别法界虽不共余。而非意识所依根性。是故若法是识所依及不共者。随彼说识。色等不然。故不随彼说色等识。如名鼓声及麦芽等。又此颂文复有余义。彼谓眼等识所随故及不共者。及由眼等是不共故。谓有一生色。发四生眼识。无一生眼根。发二生眼识。况有能发四生识者。如是界趣族类身眼各别发识故名不共。广说乃至身亦如是。岂不余生意根亦发。余生意识非全不发。但不俱时无一生意。一时并发二生意识。可如色等。故作是言。无二况四。如是眼等识所随故。生界趣等别生识故。由此二因随根非境。随身所住眼见色时。身眼色识地为同不。应言此四或异或同。所言同者。谓生欲界。以自地眼见自地色四皆同地。生初静虑。以自地眼见自地色。亦皆同地。非生余地。有四事同。所言异者。谓生欲界。若以初静虑眼。见欲界色。身色欲界。眼识初定。见初定色。身属欲界三属初定。若以二静虑眼。见欲界色。身色欲界。眼属二定。识属初定。见初定色。身属欲界眼属二定。色识初定见二定色。身属欲界眼色二定。识属初定。如是若以三四静虑地眼。见下地色或自地色。如理应知。如是若生四静虑地四事有异。如理应思。余界亦应如是分别。今当略辩此决定相。颂曰

  眼不下于身　　色识非上眼
  色于识一切　　二于身亦然
  如眼耳亦然　　次三皆自地
  身识自下地　　意不定应知

论曰。身眼色三皆通五地。谓在欲界四静虑中。眼识唯在欲界初定。此中眼根望身生地。或等或上终不居下。色识望眼等下非上。下地眼根串见粗色。于上细色无见功能。又下眼根无有胜用。上地自有殊胜眼根。于下地中自有眼识。故下地眼非上识依。色望于识通等上下。色识于身如色于识。谓通自地或上或下。识望于身通自地者。唯生欲界初静虑中。或上地者唯生欲界。或下地者唯生二三四静虑地。色望于身。自下地者自上眼见。若上地者唯上眼见。又以自地眼。唯见自下色。若以上地眼。见自上下色。广说耳界应知如眼。谓耳不下于身声识。非上耳声于识一切二。于身亦然。随其所应广如眼释。鼻舌身三总皆自地。多分同故。香味二识唯欲界故。鼻舌唯取至境界故。于中别者。谓身与触其地必同。取至境故。识望触身或自或下。自谓若生欲界初定。生上三定。谓之为下。应知意界四事不定。谓意界有时与身识法同在一地。有时上下。身唯五地。三通一切。唯生五地。自意自识缘自地法。名意与三同在一地。意界有时在上地者。谓游定时若生欲界。即此从初静虑无间起欲界识。了欲界法。意属上地三属下地。或二三四静虑等无间。起初二三静虑等地识。了初二三静虑等地法。意属上地三属下地。如是若生初静虑等。从上起下如理应知。于受生时无上地意。依下地身必无下地。身根不灭。受上生故。又定无有住异地心。而命终故。如是应知。无下地意依上地身。依上地意受下地身。则不违理。谓从上地意界无间。于欲色界初结生时。意属上地身识下地。彼所了法。或自地或上地或不系。如是应知。依下地意受上地身。亦不违理。于游定时。有下地意依上地身。亦不违理。谓生上地先起下地识身化心。如是识法。亦应广说。复应思择。若欲界眼见欲界色。或色界眼见二界色。尔时彼色可为几种。眼识所识。于此复起几种分别。为令于宗不迷乱故。先总料简。后当别释。应知此中且辩计度及与不定。随念分别遍诸地故。约此二种。一切眼识皆无分别。又善分别能缘一切自上下地。染污分别缘自上地。无记分别缘自下地。随所生地未离彼贪。具有此地三种分别。若离彼贪。唯有此地二种分别。谓除染污非生余地。有初静虑善眼识现在前。由此必定系属生故。生初静虑亦不得依余地眼根起善眼识。非生余地能起余地无覆无记。分别现前。此亦必定系属生故。非此中意唯说一生所起分别。若说一生则生上地。应定无有下地分别。即此生中彼三分别。无容得有现在前故。又上地分别应唯善非无记。前已说因故。通说余生皆得具有。已总料简。次当别释。断善根者。眼见色时。此色染污无覆无记眼识所识。于此复起三种分别。谓善染污无覆无记。不断善根未离贪者。眼见色时。此色三种眼识所识。于此复起三种分别。若诸异生生在欲界。已离欲界贪。未离初定贪。以欲界眼见诸色时。此色是善无覆无记眼识所识。于此复起欲界分别。若退法者具有三种。不退法者唯有二种。谓除染污。以初静虑眼见欲界色时。此色唯是无覆无记眼识所识。于此复起欲界分别。如前应知。于此复起初静虑地二种分别。谓除染污。以初静虑眼见彼地色时。此色唯是无覆无记眼识所识。于此复起欲界分别。若退法者则有二种。谓除无覆。不退法者则唯有善。于此复起初静虑地三种分别。已离初定贪。未离二定贪。以二静虑眼见欲界色时。此色唯是无覆无记眼识所识。于此复起欲界分别。若退法者具有三种。不退法者唯有二种。谓除染污。于此复起初定分别。若退法者则有二种。谓除染污。不退法者则唯有善。于此复起二静虑地二种分别。谓除染污。以二静虑眼见初定色时。此色唯是无覆无记眼识所识。于此复起欲界分别。若退法者则有二种。谓除无覆。不退法者则唯是善。于此复起初定分别。若退法者具有三种。不退法者则唯是善。于此复起三静虑地二种分别。谓除染污。以二静虑眼见二定色时。此色唯是无覆无记眼识所识。于此复起欲界分别。若退法者则有二种。谓除无覆。不退法者则唯有善。初静虑地所起分别。应知亦尔。于此复起二静虑地三种分别。随此所说别释理趣。已离二定贪。未离三定贪。已离三定贪。未离四定贪。已离四定贪。皆应如理一一思择。如说异生生在欲界。如是生在四静虑中。及诸圣者生在五地。随其所应亦当广说。然有差别。谓诸圣者若退不退。皆无缘上染污分别。异地遍行皆已断故。见道功德必无退故。由此方隅例应推究。耳闻声等识及分别傍论已周。应辩正论。今当思择。十八界中谁六识内几识所识。几常几无常。几根几非根。颂曰

  五外二所识　　常法界无为
  法一分是根　　并内界十二

论曰。十八界中色等五界。如其次第眼等五识各一所识。又总皆是意识所识。如是五界。各六识中二识所识。由此准知余十三界一切唯是意识所识。非五识身所缘境故。十八界中无有一界全是常者。唯法一分无为是常。义准无常法余余界。十八界中法界一分并内十二。是根非余。谓五受根。信等五根及命根全三无漏根。各一分是法界所摄。眼等五根如自名摄。女根男根即是身界一分所摄。如后当辩。意根通是七心界摄。后三一分意意识摄。义准所余色等五界法界一分。皆体非根。二十二根如契经说。所谓眼根耳根鼻根舌根身根意根女根男根命根乐根苦根喜根忧根舍根信根勤根念根定根慧根未知当知根已知根具知根。契经建立六处次第。故身根后即说意根。对法诸师依义次第。于命根后方说意根。无缘有缘次第说故。诸门分别易显了故

说一切有部显宗论卷第四阿毗达磨藏显宗论卷第五

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩差别品第三之一

如是因界已列诸根。今于此中应更思择。世尊何故别说根名。在内界全及法一分。以增上义别说为根。彼彼事中得增上故。虽增上义诸法皆有。而极增上方立根名。谁望于谁为极增上。颂曰

  五根于四事　　四根于二种
  五八染净中　　各别为增上

论曰。非一切根总于一事为极增上。眼等五根各于四事有增上用。一庄严身。二导养身。三生识等。四不共事。庄严身者。谓五根中随阙一根身丑陋故。导养身者。谓因见闻避险难故。及于段食能受用故。香味触三皆成段食。如有颂曰

  譬如明眼人　　能避现险难
  世有聪明者　　能离当苦恶
  多闻能知法　　多闻能离罪
  多闻舍无义　　多闻得涅槃

  身由食住　　命托食存　　食已令心
  适悦安泰

生识等者。谓发五识及相应法。随所依根有明昧故。不共事者。谓取自境见闻嗅尝。觉别境故。有说。眼耳于能守护生身法身。如其次第有增上用。前二伽他即为此证。有说。眼耳俱能守护生法二身。亲近善士听闻正法。眼耳各为一增上故。女男命意各于二事有增上用。且女男根二增上者。一有情异。二分别异。有情异者。劫初有情形类皆等。二根生已便有女男形类差别。分别异者。进止言音乳房髻等安布差别。有说。勇怯有差别故。名有情异。衣服庄严有差别故。名分别异。有说。此于染净二品有增上力。故言于二受不律仪。起无间业断善根故。名于染品有增上力。能受律仪入道得果及离欲故。名于净品有增上力。半择迦等无如是事。命根于二有增上者。谓由命故施设诸根及根差别。由此有彼有此无彼无故。或于众同分能续及能持。于无色界要有命根。方有所生处决定故。彼起自地善染污心。或起余心。非命终故。意根于二有增上者。谓能续后有。及自在随行。能续后有者。如世尊告阿难陀言。识若不入母胎中者。精血得成羯罗蓝不。不也世尊。乃至广说。自在随行者。如契经言

  心能导世间　　心能遍摄受
  如是心一法　　皆自在随行

有说。意根于染净品有增上力。故言于二如契经言。心杂染故有情杂染。心清净故有情清净。乐等五受信等八根于染净中有增上力。谓乐等五于染增上贪等随眠所依事故。有说。此于染净二品俱有增上。说为耽嗜。出离依故。乐故心定。苦为信依。六依出离喜及忧舍。契经说故。信等八根于净增上。如契经说。我圣弟子。具信墙堑。具勤势力。具念防卫。心定解脱。慧为刀剑。乃至广说。此中即摄后三根故。彼于净品定有增上。若增上故立为根者。于爱见品诸烦恼中。受想二法有增上用。想应如受亦立为根。又诸烦恼于能损坏善品等中。有增上用。应成根体。又最胜故。建立诸根。一切法中涅槃最胜。何缘不立涅槃为根。又迦比罗语具手足及大便处亦立为根。于语执行及能弃舍。有增上故。如是等事不应立根。由所许根有如是相。颂曰

  心所依此别　　此住此杂染
  此资粮此净　　由此量立根

论曰。心所依者。眼等六根。此内六处是有情本。此相差别由男女根。复由命根此一期住。此成杂染。由五受根此净资粮由信等五此成清净。由后三根。由此立根事皆究竟。不应更立想等为根。诸烦恼中爱过最重。故唯立受与彼为根。爱过重者。以契经说。爱与六处为生因故。又想非见烦恼生因。余因发生颠倒见已。妄分别想持令相续。离正对治不可断坏。故说此想与彼为因。受为爱因。俱通二种。受为过重。烦恼因故。通二因故独立为根。有余师言。想为余法。所映夺故不立为根。谓诸善想正慧映夺。诸染污想颠倒映夺。非增上故不立为根。又诸烦恼亦非增上。受于其中成增上故。唯受于彼可立为根。或损善品坏乐果事。下劣鄙秽如何立根。根是世间增上法故。又于诸法涅槃虽胜。灭诸根故不立为根。如破诸瓶。破非瓶体。又语具等亦不名根。不定杂乱太过失故。不定失者。何等语具立为语根。能发言音名为语具。此即是舌。若尔则应寻伺等法。及能引起语业诸风亦立为根。能发语故。谓寻伺等依唇齿齶咽喉等缘发起言音。非但依舌无异因故。又寻伺等于发言音是胜因故。又诸手腋管弦息等。皆能为因发言音故。不应唯立舌为语根。若谓了色亦由言故。不应独立眼为根者。理必不然。诸生盲人虽闻说色。不了青等差别相故。手于执取不应名根。口等亦能执取物故。足于行动不应名根。蛇鱼等类不由于足有行动故。出大便处于能弃舍不应名根。口等亦能有弃舍故。杂乱失者。彼所立根应成杂乱。口能执取及弃舍故。手足俱有执行用故。有如是等杂乱过失太过失者。彼所立根应无限量。若舌根异语根异者。应许鼻根与息根异。如舌能语鼻通息故。若此于彼少有作用即立为根。是则咽喉齿唇肚等。于诸吞嚼摄持等事。有增上故应立为根。或一切因于生自果。皆增上故应并立根。故迦比罗如童子戏。不应许彼语具等根。已说根义及建立因。当说诸根一一自体。此中眼等乃至男根。前此品中已辩其相。谓彼识依五种净色名眼等根。女男二根从身一分差别而立。命根体是不相应故。不相应中至时当辩。信等体是心所法故。心所法中至时当辩乐等五受三无漏根更无辩处。故今应释。颂曰

  身不悦名苦　　即此悦名乐
  及三定心悦　　余处此名喜
  心不悦名忧　　中舍二无别
  见修无学道　　依九立三根

论曰。身谓身受。依色根故。即五识相应受。言不悦者。是损恼义。于五识俱领触受内。能损恼者名为苦根。所言悦者是摄益义。即五识俱领触受内。能摄益者名为乐根。初静虑中三识俱乐。亦此所摄种类同故。第三静虑意识俱受。能摄益者亦名乐根。彼地更无余识身故。即意俱悦立为乐根。意识俱生悦受有二。在第三定说名为乐。由此地中离喜贪故。除第三定。下三地中说名喜根。有喜贪故。此二心悦摄益义同。行相何殊分为喜乐。由行相转有差别故。若有心悦安静行转。名为乐根。若有心悦粗动行转。名为喜根。或复乐根摄益力胜。喜根摄益则不如是。由此第三静虑地乐。诸圣说为所耽着处。与意识俱能损恼受。是心不悦名曰忧根。已约身心悦不悦受。行相差别立四受根。所言中舍二无别者。中是非悦非不悦义。即不苦乐说名舍根。身心受中此定何受。应言此受通在身心。苦乐何缘各分为二。不苦不乐唯立一根。此在身心无差别故。谓心苦乐多分躁动。苦乐在身则为安住。不苦不乐在身在心。行相无差唯安住故。又心苦乐多分别生。在身不然随境力故。阿罗汉等亦如是生。舍在身心俱无分别。处中行相任运而起。又苦乐受在身在心。于怨于亲行相转异。不苦不乐在身在心。于中庸境行相无异。是故苦乐各分为二。不苦不乐唯立一根。已释乐等诸受根体。三无漏根今次应释。不可一一别说其体。应就三道依九总立。意乐喜舍信等五根。此九三道中即是三无漏。谓在见道意等九法。即是未知当知根体。未知当知行相转故。若在修道意等九法。即是第二已知根体。为欲断除余随眠故。于已知境数复了知。在无学道。意等九法即是第三具知根体。知自己知。故名为知。习知成性故。或能护知故。名为具知。九根相应合成此事。故意等八亦得此名。如是根名虽二十二。而诸根体但有十七。女男二根身根摄故。三无漏根九根摄故。如是已释根体不同。当辩诸门义类差别此二十二根中几有漏几无漏。颂曰

  唯无漏后三　　有色命忧苦
  当知唯有漏　　通二余九根

论曰。次前所说最后三根。体唯无漏。是无垢义。垢之与漏名异体同。七有色根色蕴摄故。名为有色。此有色根命及忧苦一向有漏。九通二者。即前所说三无漏摄。意等九根名为无漏。余意等九是名有漏。有说信等亦唯无漏。此不应理。如世尊言。我若于此信等五根。未如实知是集没味过患出离。未能超此天人世间。乃至广说非无漏法。应作如是次第观察。又佛未转正法轮时。先以佛眼遍观世间。诸有情类有利中软诸根差别。此广决择如顺正理。如是已说有漏无漏。二十二根中。几是异熟。几非异熟。颂曰

  命唯是异熟　　忧及后八非
  色意余四受　　一一皆通二

论曰。且无分别。此诸根中。唯一命根定是异熟。如何此命可无分别。定果命根非异熟故。如是命根亦是异熟。得边际定应果苾刍。于僧众中或别人所施思果故。诸我能感富异熟业。愿皆转招寿异熟果。圣所说故。有说彼由边际定力。引取前生顺不定受。业所感寿令现受用。复有欲令边际定力引前生业残异熟果。忧根及后信等八根皆非异熟。有记性故。经说有业顺忧受者。依受相应言顺无过。如言有触顺乐受等。何缘定知忧非异熟。离欲贪者不随转故。异熟不然。故非异熟。如何定知离欲贪者。忧不随转。忧是无知等流果故。阿罗汉等一切无知皆已断故。诸怨憎相彼无有故。诸阿罗汉离欲贪者。已断欲界诸灾患故。诸怨憎相亦皆无有。又彼相续多欢悦故。离欲贪者。忧不随转。故知忧根。越异熟法余根通二。义准已成。谓七色意根。除忧余四受。十二一一皆通二类。七有色根若所长养。则非异熟。余皆异熟。意及四受若善染污若威仪路。及工巧处并能变化。随其所应亦非异熟。余皆异熟。如是已说是异熟等。二十二根中几有异熟。几无异熟。颂曰

  忧定有异熟　　前八后三无
  意余受信等　　一一皆通二

论曰。如前所说。忧根当知定有异熟。定言意显唯有非无遮非异熟。因无记无漏故。眼等前八及最后三。此十一根定无异熟。八无记故。三无漏故。余皆通二。义准已成。谓意根余四受信等言等取精进等四根。此十一一皆通二类。意乐喜舍若不善善有漏有异熟。若无记无漏无异熟。苦根若善不善有异熟。若无记无异熟。信等五根。若有漏有异熟。若无漏无异熟。如是已说有异熟等。二十二根中几善几不善几无记。颂曰

  唯善后八根　　忧通善不善
  意余受三种　　前八唯无记

论曰。信等五根及三无漏。一向是善。忧根唯通善不善性。意及四受皆通三性。眼等八根唯是无记。如是已说善不善等。二十二根中几欲界系几色界系几无色界系。颂曰

  欲色无色界　　如次除后三
  兼女男忧苦　　并余色喜乐

论曰。欲界除后三无漏根。由彼三根唯不系故。准知。欲界系有余十九根。色界如前除三无漏。亦除男女忧苦四根。准知。十五根亦通色界系。除男女者。色界已离淫欲法故。除此无因须受用故。有说由此身丑陋故。此说不然。阴藏隐密非丑陋故。然佛置彼在男品中。如契经说。无处无容女身为梵。有处有容男为梵者。离欲威猛似男用故。如有称赞大梵王言

  大梵如丈夫　　所得皆已得
  离欲道威猛　　故说为丈夫

除苦根者。色界中无损害事故。苦是损害。业异熟故。有说彼身极净妙故。除忧根者。彼处无有怨憎相故。又奢摩他润相续故。有说色界具离欲智。忧是无知等流果故。无色如前除三无漏女男忧苦。并除喜乐及五色根准知。余八根通无色界系。如是已说欲界系等。二十二根中几见所断。几修所断。几非所断。颂曰

  意三受通三　　忧见修所断
  九唯修所断　　五修非三非

论曰。意喜乐舍一一通三。忧根唯通见修所断。非无漏故。七色命苦唯修所断。有色无染非六生故。非无漏故。信等五根。或修所断。或非所断。通善有漏及无漏故。最后三根唯非所断。皆是无漏无过法故。然契经言。应知圣道犹如船筏。法尚应断。何况非法。此非见修二道所断。入无余依涅槃界位。舍故名断。已说诸门义类差别。当说初得异熟诸根。几异熟根何界初得。须问初得异熟根者。遮无染心能续生故。颂曰

  欲胎卵湿生　　初得二异熟
  化生六七八　　色六上唯命

论曰。欲胎卵湿生初受生位。唯得身与命二异熟根。举胎卵湿显除化生。化生色根无渐起故。此辩异熟不说意舍。时彼定染非异熟故。尔时亦得信等诸根。非异熟故。此中不说。此因化说。不辩三生羯剌蓝位。虽得色等异熟生法。而体非根。故此不说。化生初位得六七八。无形得六。如劫初时。六谓眼耳鼻舌身命。一形得七。如诸天等。二形得八。恶趣容有二形化生。色初得六如欲化生。无形者说上唯命者。谓无色界定生俱胜故名为上。彼初唯得异熟命根。由此证知命根实有。此若非有为得何根。名生无色非善染污。名业果生未受彼生。客现起故。又异熟心无续生理。唯许染心能续生故。过去未来非有论者。尔时三世异熟皆无。生依何说应许实命。为彼生依说异熟根。最初得已。当说最后所灭诸根。何界死时几根后灭。颂曰

  正死灭诸根　　无色三色八
  欲顿十九八　　渐四善增五

论曰。且说染污及无记。心正命终时根灭多。少谓无色界将命终。时命意舍三于最后。灭无色唯有舍受非。余又无色言遮彼有色。有余师说。彼有色故。若不说有实物命根。何异熟断名无色死。若言异熟四蕴断故彼名死者。善染污心现在前位。应亦名死。若言彼地所受异熟犹未尽者。如何不受而有尽期。善染污心现在前位。当言彼受何业异熟。非不现前可名为受。余广决择如顺正理。色界死时八根后灭。谓眼等五及前三根。化生生死根无缺故。欲顿死时。十九八灭。二形十灭。谓女男根及前说八一形九灭。无形八灭。若渐死时。身命意舍四根后灭。此四必无前后灭义。若在三界善心死时。一切位中数各增五。善心必具信等根故。谓于无色增至八根。乃至欲界渐终至九。今复应思。几根能得何沙门果。虽沙门果非根亦得。此辩根故但问诸根。颂曰

  九得边二果　　七八九中二
  十一阿罗汉　　依一容有说

论曰。边谓预流阿罗汉果。中谓一来及不还果。且预流果由九根得。谓意舍信等初二无漏根。此果与向未至地摄。故唯有舍。云何此由已知根得。由离系得与解脱道俱时起故。虽解脱道于沙门果非同类因而是相应。俱有因故。名得无失。或已知根亦为同类因能得预流果。谓转依时如阿罗汉。就容有说。亦无有过。阿罗汉果亦九根得。谓意信等后二无漏。乐喜舍中随取一种。此果及向通九地摄。故于三受随取其一。中间二果一一皆通。七八九得世出世道。次第超越证差别故。且一来果次第证者。依世间道由七根得。谓意及舍信等五根。依出世道由八根得。谓即前七及已知根。倍离欲贪超越证者。如预流果由九根得。证不还果应知亦尔。总例虽然而有差别。全离欲贪超越证者。依地别故三受随一。次第证者。若于第九解脱道中入根本地。依世间道由八根得。喜为第八依出世道由九根得。已知第九若阿罗汉亦九根得。违发智论彼问几根得阿罗汉。答十一故。三受定无俱时起故。但由九得。言十一根。依容有说。谓容有一补特伽罗。从无学位数数退已。由喜乐舍数复还得。非不还果有同此失。次第无容乐根得故。超越无容有退失故。今应思择成就何根。彼诸根中几定成就。颂曰

  成就命意舍　　各定成就三
  若成就乐身　　各定成就四
  成眼等及喜　　各定成五根
  若成就苦根　　彼定成就七
  若成女男忧　　信等各成八
  二无漏十一　　初无漏十三

论曰。命意舍中随成就一。彼定成就如是三根。非此三中有阙成就。皆遍一切地及依故。信等五根遍一切地。非一切依。余十四根二俱非遍。故成舍等。唯定成三。余或成就或不成就。云何成就眼等四根。生色界全欲界少分。身根生在欲色界全。女男生在欲界少分。乐根生在欲下三定及圣生上。喜根生在欲下二定及圣生上。若生欲界。全忧欲贪未离。信等五根若不断善。三无漏根已得未舍。如是诸位各定成就。除此余位定不成就。若成乐根定成就四。谓命意舍乐。若成身根亦定成四。谓命意舍身。余或成就或不成就。若成眼根定成就五。谓命意舍身及眼根。耳鼻舌根应知亦五。前四如眼。第五自根。若成喜根亦定成五。谓命意舍乐及喜根。生第二定未离彼贪。但成第三染污乐受。若成苦根定成就七。谓身命意四受除忧。若成女根定成就八。七如苦说。第八女根。男忧亦八。七如苦说。第八自根。信等亦八。谓命意舍信等五根。若女男俱成。彼定成十五。若成具知根。定成就十一。谓乐喜舍命根意根信等五根及具知根。已知根亦尔。自根第十一。若成未知根。定成就十三。谓身命意四受除忧信等五根及未知根。渐命终位传说深心厌生死故能入见道。如是已说位定成就补特伽罗定成。当说诸极少者成就几根。颂曰

  极少八无善　　成受身意命
  愚生无色界　　成善命意舍

论曰。已断善根名为无善。彼若极少成就八根。谓五受根及身命意。据渐舍命。唯余身根。愚谓异生。未见谛故。彼生无色亦成八根。谓信等五及命意舍。由定数故。及说愚故。善言不滥三无漏根。诸极多者成就几根。颂曰

  极多成十九　　二形除三净
  圣者未离欲　　除二净一形

论曰。诸二形者具眼等根。除三无漏成余十九。无漏名净。离二缚故。若圣有学未离欲贪。成就极多亦具十九。除二无漏。及除一形。二无漏者。谓具知根前二随一。言一形者。无有二形。及与无形得圣法故。因分别界已广辩根诸行俱生今应思择。此中诸行略有二种。有色无色。无色有三。谓心心所不相应行。有色有二。谓是极微及非极微。极微有二。一欲界系。二色界系。欲界极微复有二种一无根聚。二有根聚。此中且辩极微聚色。颂曰

  欲微聚无声　　无根有八事
  有身根九事　　十事有余根

论曰。有对色中最后细分。更不可析名曰极微。谓此极微更不可以余色觉慧分析为多。此即说为色之边际。更无分故立边际名。如一刹那名时边际。更不可析为半刹那。此亦如是。众微和合不可分离。说为微聚。此在欲界无声无根八事俱起。谓四大种色香味触。此若有声即成九事。声及前八。而不说者。显因大种相击故生。非如色等恒时有故。无声有根或九或十。谓身根聚九事俱起。八如前说。第九身根。余根聚中十事俱起。九如身聚。加眼等一。眼耳鼻舌必不离身。依身转故。四根展转相离而生。处各别故。此有根聚若有声生。加所生声成十十一。此有执受大种为因。故与诸根不相离起。不说所以如前应知。色界唯除香味二事。余同欲界。故不别说。所说事言依体依处。皆无有失。所依能依依体依处。差别说故。或唯依体。亦无有失。决定俱生方说有故。形色等体非决定有。光明等中则无有故。或唯依处。亦无有失。为遮多谤别说大种。谓或谤言。大种造色无别有性。或复谤言。无别触处所造色体。或复谤言。非一切聚具四大种。别说大种此谤皆除。然不成多。约类说故。已说有色决定俱生。无色俱生今次当说。颂曰

  心心所必俱　　诸行相或得

论曰。心与心所必定俱生。随阙一时余未尝起。诸行即是一切有为。所谓有色无色诸行。前必俱言。应流至此。谓有色等诸行生时。必与生等四相俱起。言或得者。唯有情法与得俱生。或言显此不遍诸行。于前所说四有为中。广辩色心如前品说。心所等法犹未广辩。今先广辩诸心所法。颂曰

  心所且有五　　大地法等异

论曰。诸心所法且有五品。大地法等有别异故。五品者何。一大地法。二大善地法。三大烦恼地法。四大不善地法。五小烦恼地法。地谓容止处。或谓所行处。若此是彼容止所行。即说此法为彼法地。地即是心大法地故。名为大地。此中若法大地所有。名大地法。谓法遍与一切品类一切心俱生。由此故心非大地法。非心俱生故。彼法是何。颂曰

  受想思触欲　　慧念与作意
  胜解三摩地　　遍于一切心

论曰。于所依身能益能损。或俱相违。领受非爱俱相违触。说名为受。安立执取女男等境。差别相因。说名为想。令心造作善不善无记。成妙劣中性。说名为思。由有思故。令心于境有动作用。犹如磁石势力能令铁有动用。由根境识和合而生。能为受因有所触对。说名为触希求取境。说名为欲。简择所缘邪正等相。说名为慧。于境明记不忘失因。说名为念。引心心所令于所缘有所警觉。说名作意。此即世间说为留意于境印可。说名胜解。胜谓增胜。解谓解脱。此能令心于境无碍自在而转。如增上戒增上定等。令心无乱取所缘境。不流散因名三摩地。委辩自相如五事释。如是已说十大地法。大善法地名大善地。此中若法大善地所有。名大善地法。谓法恒于诸善心有。彼法是何。颂曰

  信及不放逸　　轻安舍惭愧
  二根及不害　　勤唯遍善心

论曰。心浊相违现前忍许。无倒因果各别相属。为欲所依能资胜解。说名为信。专于己利防身语意。放逸相违。名不放逸。正作意转身心轻利。安适之因心堪任性。说名轻安。心平等性。说名为舍。掉举相违如理所引令心不越。是为舍义。趣向如理自法二种。增上所生违爱等流心自在性。说名为惭爱乐修习功德为先。违痴等流厌恶劣法。说名为愧。有说怖畏谪罚恶趣自他谤因。说名为愧。二根者谓无贪无嗔。已得未得境界耽着。希求相违无爱染性。名为无贪。于情非情无恚害意哀愍种子。说名无嗔。与乐损恼有情相违心贤善。性说名不。害于诸已生功德过失守护弃舍。于诸未生功德过失令生不生心无堕性。说名为勤。由有此故。心于如理所作事业坚进不息。说二及言兼摄欣厌。厌谓善心审谛观察无量过患。法实性故。起顺无贪心厌背性。与此相应名厌作意。欣谓善心欣求过患出离对治。此增上力起顺证修心欣尚性。此于离喜未至等地。亦有现行。故非喜受。与此相应名欣作意。诸契经中。喜欣别说从欣生喜。契经说故。诸作是说。劣喜名欣。彼轻安等应同此说。无异因故。何因唯喜说有胜劣。非轻安等故理不然。欣厌行相更互相违。于一心中无容并起。是故于此不正显说。大善地法性不成故。亦有喜根厌行俱转。定无有欣厌行俱转。为表此二定不俱行。说二及言行相违故

说一切有部显宗论卷第五阿毗达磨藏显宗论卷第六

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩差别品第三之二

如是已说大善地法。大烦恼法地名大烦恼地。此中若法大烦恼地所有名大烦恼地法。谓法恒于染污心有彼法是何。颂曰

  痴逸怠不信　　惛掉恒唯染

论曰。云何如是六种名大烦恼地法。以恒唯与诸染心俱。颂言染者。是染心义。又放逸等及与无明。如其次第应知即是前不放逸勤信轻安舍等所治。痴谓愚痴于所知境障如理解。无辩了相说名愚痴。即是无明无智无显。逸谓放逸。于专己利弃舍纵情。名为放逸。怠谓懈怠。于善事业阙减胜能。于恶事业顺成勇悍。无明等流名为懈怠。由此说为鄙劣勤性。勤习鄙秽故名懈怠。不信者谓心不澄净邪见等流。于诸谛宝静虑等至现前轻毁。于施等因及于彼果。心不现许名为不信。惛谓惛沈[夢-夕+登]瞢不乐等所生心重性。说名惛沈。由斯覆蔽心便惛昧无所堪任。瞢愦性故。由是说为轻安所治。心为大种。能生因故。由此为先起身重性。假说惛沈。实非惛沈。彼是身识所缘境故。然此惛沈无明覆故。本论不说为大烦恼地法。有言。彼论说无明名。唯目惛沈相相似故。无明性是大遍行故。是此地法不说而成。有说此名总目二义。掉谓掉举。亲里寻等所生。令心不寂静性。说名掉举。心与此合越路而行。非理作意。失念心乱。不正知。邪胜解。前已说为大地法故。于此地法中虽有而不说。如于大善地法不说无痴善根。唯诸染心恒有此六。如是已说大烦恼地法。大不善法地名大不善地。此中若法大不善地所有名大不善地法。谓法恒于不善心有。彼法是何颂曰

  唯遍不善心　　无惭及无愧

论曰。唯二心所但与一切不善心俱。谓无惭愧。故唯二种名此地法。此二法相如后当显。如是已说大不善地法。小烦恼法地名小烦恼地。此中若法小烦恼地所有名小烦恼地法。谓法少分染污心俱。彼法是何。颂曰

  忿覆悭嫉恼　　害恨谄诳憍
  如是类名为　　小烦恼地法

论曰。类言为摄不忍不乐愤发等义。小是少义。显非一切染污心俱。又无相应。唯修所断。意识俱起无明相应。随烦恼中当释其相。此诸心所皆实有性。非一品类所缘义中。种种行相俱时起故。一体同时如所缘义。差别行相无容有故。然由余法所制伏故。见其相续变异而起。现见清油垢水风等。势力制持灯相续中。便有明昧声动等故。如是已说大地法等品类决定心所差别。复有此余不定心所。恶作睡眠寻伺等类。总说名为不定地法。今应决择。一切心所诸心品中俱生数量。何心品内有几心所。颂曰

  欲有寻伺故　　于善心品中
  二十二心所　　有时增恶作
  于不善不共　　见俱唯二十
  四烦恼忿等　　恶作二十一
  有覆有十八　　无覆许十二
  睡眠遍不违　　若有皆增一

论曰。且欲界中心品有五。谓善唯一不善有二。谓不共无明俱生及余烦恼等俱生。无记有二。谓有覆无记及无覆无记。如是欲界一切心品。决定恒与寻伺相应。故善心品有二十二心所俱生。谓十大地法。十大善地法及不定。二谓寻与伺。此中勤舍应不俱生。行相违故。如进与止。造修委弃。理不同时。契经亦遮。此二俱起。说修二法。时非时故。如契经说。心若惛沈。尔时应修择法勤喜修轻安定舍则为非时。心若掉举。尔时应修轻安定舍修择法勤喜则为非时。俱生无失不相违故。住正理者起如理行不息名勤。即于尔时弃非理行平等名舍。又于如理非理行中。舍如持称进止平等故。舍与勤更相随顺。起善止恶行不相违。若于所缘一取一舍。更相违背。可有此失。不定地法复有二种。一者恶作。二者睡眠。非此二法贯通三界及六识身。有漏无漏。非唯不染。亦非唯染。故善心品非一切时。皆有恶作。但容可有。有时增数至二十三。言恶作者。悔以恶作为所缘故立恶作名。如无相定。有说无相及身念住有处名身。若尔有缘所未作事。心生追悔。应非恶作。不尔未作亦名作故。如追悔言。我先不作如是事业。是我恶作。然此恶作通善不善。不通无记。随忧行故。离欲贪者。不成就故。非无记法。有如是事。然有追变。我须何为。不消而食。我须何为。不画此壁。如是等类。彼心乃至未触忧根。但是省察未起恶作。若触忧根便起恶作。尔时恶作理同忧根。故说恶作有如是相。谓令心戚恶作心品。若离忧根谁令心戚。恶作有四。谓善不善。一一皆依一处起故。若于不善不共心品。应知二十心所俱生。谓十大地法。六大烦恼地法。二大不善地法。并二不定。谓寻与伺。何等名为不共心品。谓此心品唯有无明。无有所余贪随眠等。如不共品邪见见取及戒禁取俱生亦尔。大地法中即慧差别。说名为见。故数不增。颂言唯者。是简别义。谓唯见俱定有二十表。不共品中容有恶作等。谓若恶作是不善者。唯无明俱非余烦恼。贪慢二种欢行转故。嗔外门转行相粗故。非恶作俱。疑不决定。恶作决定故不俱起。有身见等。欢行转故。极猛利故。恶作不尔。然此恶作。依善恶行事处转故。诸见不尔。故不相应。邪见一分虽戚行转。而二因故非恶作俱。是故恶作是不善者。唯无明俱容在不共。忿等亦尔。于四不善贪嗔慢疑烦恼心品。有二十一心所俱生。二十如不共加贪等随一。于前所说忿等相应随烦恼品亦二十一心所俱生。二十如不共加忿等随一。不善恶作相应心品亦二十一心所俱生。谓即恶作等二十一。若于无记有覆心品。唯有十八心所俱生。谓二十中除大不善。欲界无记有覆心者。谓与萨迦耶见及边执见相应。不增见义如前应释。于余无记无覆心品。许唯十二心所俱生。谓十大地法并不定寻伺。有执恶作亦通无记。忧如喜根非唯有记。此相应品便有十三心所俱起。睡眠一切不相违故。于诸心品皆可现行。于善不善无记心品。随何品有即说此增。随其所应当各增数。工巧处等诸无记心。似有勇悍。然非称理。而起加行。故无有勤。又非染污故无懈怠。无信不信类此应知。已说欲界心所俱生诸品定量当说上界。颂曰

  初定除不善　　及恶作睡眠
  中定又除寻　　上兼除伺等

论曰。初静虑中于前所说诸心所法。除唯不善恶作睡眠。余皆具有。唯不善者谓嗔烦恼及无惭愧。除谄诳憍所余忿等。余皆有者如欲界说。中间静虑除前所除。又更除寻余皆具有。第二静虑已上乃至无色界中。除前所除。又除伺等。等者显除谄诳。余皆如前。具有以从欲界乃至梵天。皆有王臣众主等别。故有谄诳。上地皆无。如是已说三界所系诸心心所俱生定量有诸心所。性相似同难知差别。今随宗义辩彼别相无惭无愧。爱之与敬别相云何。颂曰

  无惭愧不重　　于罪不见怖
  爱敬谓信惭　　唯于欲色有

论曰。无惭无愧差别相者。于诸功德及有德者。无敬无崇。无所忌难。无所随属。说名无惭。诸功德者谓尸罗等。有德者谓亲教等。于此二境无敬无崇。是无惭相。即是崇敬能障碍法。或缘诸德说为无敬。缘有德者说为无崇。无所忌难。无所随属。总显前二。或随次第。于所造罪不见怖畏。说名无愧。诸观行者所呵厌法。说名为罪。于所呵厌诸罪业中。不见能招此世他世。讥毁讁罚。非爱难忍。异熟果等。诸怖畏事。是无愧相。即不忌惮罪业果义。不见怖言。欲显何义。为不见彼怖。为见而不怖。前应显无明。后应显邪见。此言不显见与不见为无愧体。但显有法是随烦恼。能与现行无智邪智为邻近因。说名无愧。此略义者。谓能令心于德有德无所崇敬。名曰无惭。于罪现行无所忌惮。名为无愧。有余师说。于诸烦恼不能厌毁。名曰无惭。于诸恶行不能厌毁。说为无愧。有说独处造罪无耻。名曰无惭若处众中造罪无耻。说为无愧。有说现起不善心时于异熟因无所顾眄。名曰无惭。于异熟果无所顾眄。说为无愧。诸不善心现在前位。皆于因果无所顾眄。故一心中二法俱起。由此翻释惭愧异相。若净意乐。为习善人所乐胜业名有惭者。为得善人所乐胜果名有愧者。诸有爱乐胜业胜果。必亦怖于恶因苦果。一切善心现在前位。定于因果皆无迷惑。故惭与愧一心并生。故有余师。以如是义摽于心首。说如是言。于所造罪自观无耻。名曰无惭。观他无耻。说为无愧。谓异熟因当时现起。故名为自。其异熟果后时方有。故说为他。彼义意言。诸造罪者意乐不净。于现罪业及当苦果。皆无顾眄。已说无惭无愧别相。爱敬别者。爱谓爱乐。体即是信。然爱有二。一有染污。二无染污。有染谓贪。无染谓信。信复有二。一忍许相。二愿乐相。若缘是处现前忍许。或即于中亦生愿乐。此中爱者是第二信。或于因中亦立果称。前信是爱。邻近因故。名爱无失。敬谓敬重。体即是惭。谓如前释大善地法中。言心自在性说为愧者。应知即是此中敬体。然复有言。有所崇重故名为敬。由此为先方生惭耻。故敬非惭。彼师应许。无惭耻者。能起恭敬。以执先起敬时未有惭耻故。应无惭耻者能起恭敬。若谓敬时已有惭耻。则不应说由敬为先方生惭耻。若谓敬时非无惭耻。然敬非惭。此亦非理。言敬非惭。无证因故。非敬为先方生惭耻。勿无惭者能起恭敬。又勿有敬而无惭耻。然复确执敬体非惭。但有虚言都无实义。故应敬体是惭差别。谓或有惭名有崇重。此惭差别说名为敬。补特伽罗为境界故。即惭差别得崇重名。夫崇重者是心自在。心自在性已说为惭。谓于心中有自在力。能自制伏有所崇重。故说敬体是惭差别。于诸所尊有所崇重。故名为敬。是境第七。或因第七由于所尊发随属意。即名为惭。此惭即是有所崇重。故此敬体是惭差别。义善成就。即由此证。补特伽罗为境信惭。说名爱敬。非谓以法为境起者。故爱与敬。虽是大善地法所摄。而于无色不立为有。有余师言。信顺亲密而无耽染。说名为爱。瞻望所尊崇重随属。说名为敬。有余师说。亲近善士。因名为爱。不越彼言。因名为敬。复有说者。于和合众见等皆同。故名为爱。于可尊重深心恭事。故名为敬。此爱与敬。欲色界有。无色界无。无依处故。如是已说爱敬别相。寻伺憍慢别相云何。颂曰

  寻伺心粗细　　慢对他心举
  憍由染自法　　心高无所顾

论曰。寻伺别者。谓心粗细。心之粗性。说名为寻。心之细性。说名为伺。若尔寻伺体不异心。经即就心说二性故。此言非理。由不了达经义趣故。经言所有心粗细性名寻伺者。由有此法心起便粗。此法名寻。由有此法心起便细。此法名伺或作异释。故体异心。谓我不言。心之粗性名心粗性。心之细性名心细性。者尔云何依心粗性名心粗性。依心细性名心细性。虽一心中二体可得。用增时别故不相违。如水与酢等分和合。体虽平等而用有增。粗心品中寻用增故。伺用被损有而难觉。细心品中伺用增故。寻用被损有而难觉。若谓酢用一切时增故非喻者。此言非理。我不定说。以酢喻寻水喻于伺。但有用增者。即说如酢故。由是寻伺。虽一心中体具可得。用时别故。而无一心即粗即细。如贪痴性虽并现行。而得说心为有贪行。随何心品有法用增。此法为门。总标心品。诸无色法就用说增。如是已说寻伺别相。慢憍别者。慢谓对他心自举性。称量自他德类胜劣。若实不实。心自举恃陵蔑于他。故名为慢。憍谓染着。自法为先。令心傲逸无所顾性。于自勇健财位戒慧族等法中先起染着。心生傲逸于诸善本无所顾眄。故名为憍。于诸善本无所顾者。谓由心傲。于诸善业不乐修习。是谓慢憍差别之相。如是已说诸心心所品类不同俱生决定差别之相。然心心所于契。经中随义建立种种名相。今当辩此名义差别。颂曰

  心意识体一　　心心所有依
  有缘有行相　　相应义有五

论曰。心意识三体虽是一。而训词等义类有异。谓集起故名心。思量故名意。了别故名识。颇勒具那契经意遣。能了别者非无了别。或种种义故名为心。即此为他作所依止故名为意。作能依止故名为识。或界处蕴施设差别。或复增长相续业生种子差别。如是等类义门有异。故心意识三名所诠义异体一。如心意识三名所诠义异体一。诸心心所名有所依。所缘行相相应亦尔。名义虽殊而体是一。谓心心所。以六内处为所依故。名有所依。以色等境为所缘故。名有所缘。即于所缘品类差别。起行相故。名有行相。平等俱时与他性合。行所缘境故名相应。云何平等。五义等故。谓心心所五义平等。故说相应。所依所缘行相时事皆平等故。事平等者。一相应中如心体一。诸心所法各各亦尔。心所离心别有自性。然譬喻者。说唯有心无别心所心想俱时。行相差别不可得故。又经唯说识入胎故。又说或心或意或识。长夜流转生诸趣故。又说士夫六界摄故。又说我今不见一法速疾回转犹如心故。又说我今不见一法若不修习则不调柔无所堪能犹如心故。又说心远行独行故。又于心所多诤论故。谓或有说心所唯三。或复有说心所唯四。或说有十。或说十四。故唯有识随位而流。说有多种心心所别。如甘[這-言+蔗]汁如倡伎人。故无受等别体可得。然心心所。时境性同。行相无别异相难了。故契经言。心心所法展转相应。若受若想若思若识。如是等法和杂不离。不可施设差别之相。然识与想其相各别。谓于境中。总了名识别取名相。施设名想。以心强故。诸契经中处处偏说如王来等。遮心并起。故说独行。心所难知故多诤论。岂多诤论便拨为无。勿彼此中间亦无便有失。然诸论者。皆信离心别有心所。但于多少数增减中而兴诤论。以经不说数定量故。若执受等是心差别。如何即心可名心所。据何定理说识为心。复以何缘即名心所。若谓诸识体即是心。受等诸法是心体类。心相续中有此法故。名心所者。何故不言所造诸色。即是大种体类差别。即于地等相续位中。有此法故名为所造。此既不尔。彼云何然。离大种外别有所造。如顺正理已广决择。若责何故知心所法决。定离心别有体者。由教理故。如契经言。眼及色为缘生于眼识。三和合触俱起受想思。如是诸法是心种类。依止于心。系属于心。故名心所。此俱生言不说无间。但显心所同时而生。又不容有心体俱生。故知但说心所俱起。无色法中已辩心心所。今次当辩心不相应行。颂曰

  心不相应行　　得非得同分
  无想二定命　　相名身等类

论曰。等者等取。句身文身及和合性。类者显余所计度法。即前种类。谓有计度。离得等有蕴得等性。如是诸法不与心相应故。说名为心不相应行。非如心所与心共一所依所缘相应而起。说心言者。为显此中所说得等。是心种类。诸心所法。所依所缘皆与心同。亦心种类。为简彼故言不相应。诸无为法亦心种类。无所依缘故。亦是不相应。为欲简彼故复言行。此已总标。复应别释。于中且辩得非得相。颂曰

  得谓获成就　　非得此相违
  得非得唯于　　自相续二灭

论曰。得获成就。义虽是一。而依门异。说差别名。得有二种。谓先未得及先已得。先未得得说名为获。先已得得说名成就。应知非得与此相违。谓先未得及得已失。未得非得说名不获。已失非得名不成就。故说异生性名不获圣法。于何法中有得非得。且有为中于自相续有得非得。非他相续及非相续。若蕴堕在自相续中。可有成就不成就故。他相续蕴及非情蕴。必无成就不成就故。然不违害轮王契经。于宝自在名成就故。非成善等可同此说。现于过未无自在故。谓现在者。唯于现在有自在力。非于过未。如转轮王于现七宝有自在力。随意受用增上果故。恒现前故。随乐而转可名成就。善不善法则不决定。且如善法现在前时。彼于去来诸不善法。若离现得有何自在。而名成就不善现前。征善亦尔。况执过未全无体宗。依何如何说名成就。若谓有力。当能生彼。名成就者。理亦不然后有异生。应名圣者。后心无学应是异生。如是等类有众多失。故得非得定有别体。有为唯在。自蕴非余。无为法中唯于二灭有得非得。一切有情无不成就。非择灭者。故对法中有如是说。谁成无漏法。谓一切有情除初刹那。具缚圣者及余一切具缚异生诸余有情。皆成择灭。决定无有成就虚空。以于虚空无有得故。亦无不成就。以无非得故。若法有得亦有非得。若法无得亦无非得。其理决定。依此得故说如是言。色蕴行蕴一得所得。余蕴行蕴说亦如是。有漏无漏一得所得。有为无为一得所得。如是等类如理应思。是已得法。不失因故。是此属彼。智幖帜故。得有此用。故别有体。若谓种子有此作用。理不应然。种与余法体别有无。俱有过故。若体别有。体即是得。但立异名。若体别无。则善不善杂染清净。体应成一。便爱非爱业果杂乱。既尔解脱体亦应无。又契经说。一切白法无余断者。善法还生所执种子应成无用。如世尊说。应知如是补特伽罗。善法隐没恶法出现。有随俱行善根未断。以未断故。从此善根。犹有可起余善根义。彼于后时一切皆断。彼后决定还续善根。故所执种定为无用。非对法者所说诸得是法生因。现见离得已得未得。法亦生故。由此诸师所执随界。熏习功能不失增长。皆已遮遣。义无别故。如是已成得非得性。此差别义。今广应思。且得云何。颂曰

  三世法各三　　善等唯善等
  有系自界得　　无系得通四
  非学无学三　　非所断二种

论曰。三世法得各有三种。谓过去法。有过去得。有未来得。有现在得。如是未来及现在法各有三得。约容有义且作是说。其中差别后当更辩。又善等法得唯善等。谓善不善及无记法。如其次第有善不善无记三得。又有系法得唯自界。谓欲色界无色界法。如其次第唯有欲色无色三得。若无系法得通四种。谓不系法就总种类。具四种得。即三界系及与不系。别分别者。非择灭得通三界系。若择灭得色无色系及与不系。其圣道得唯有不系。又有学法得唯有学。若无学法得唯无学故。学无学法得各有一种。非学非无学法总类得有三。别分别者。全五取蕴及三无为。总名非学非无学法。且五取蕴。及非择灭。并非圣道所证择灭。唯有非学非无学得。若有学道所证择灭得唯有学。若无学道所证择灭得唯无学。又见修所系法。如其次第有见修所断得。非所断法得总有二。别分别者。诸无漏法名非所断。若非择灭及非圣道所证择灭得唯一种。谓修所断。若以圣道所证择灭及道圣谛得唯。一种谓非。所断前言三世各有。三得诸有为法皆定尔耶。不尔云何。颂曰

  无记得俱起　　除二通变化
  有覆色亦俱　　欲色无前起

论曰。无覆无记得唯俱起。无前后生。势力劣故。一切无覆无记法得皆定尔耶。不尔云何。除眼耳通及能变化。谓眼耳通慧及能变化。心势力强故。加行差别所成办故。虽是无覆无记性收而有前后及俱起得。又威仪路四蕴之得。多分世断及刹那断。唯除诸佛马胜苾刍及余善习威仪路者。若工巧处四蕴之得。亦多世断及刹那断。除毗湿缚羯磨天神及余善习工巧处者。唯有无覆无记法得但俱起耶。不尔云何。有覆无记色得亦尔。谓唯色界初静虑染。身语表业得亦如前。但有俱起。虽上品染。而亦不能发无表故。势力微劣。由此定无法前后得。欲界诸色亦定唯有俱起得耶。不尔云何。谓欲界系。善不善色。得无前起。唯有俱生及后起得

说一切有部显宗论卷第六阿毗达磨藏显宗论卷第七

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩差别品第三之三

如是已辩得差别相。非得差别其相云何。颂曰

  非得净无记　　去来世各三
  三界不系三　　许圣道非得
  说名异生性　　得法易地舍

论曰。性差别者。一切非得。皆唯无覆无记性摄。世差别者。过去未来各有三种。谓过去法及未来法。一一各有三世非得。若现在法。唯有过去未来非得。决定无有现在非得。以现在法与不成就不俱行故。有说现法无现非得。性相违故。现可成法。必与得俱。定无非得。不可成法非得亦无。故现在法无现非得。界差别者。三界系法及不系法各三非得。谓欲界系法有三界非得。色无色界系及不系亦尔。定无非得。是无漏者。所以者何。由许圣道非得说名异生性故。如本论言。云何异生性。谓不获圣法。不获即是非得异名。如何无漏法可名异生性。不获何圣法名异生性耶。为总不获一切圣法。为唯不获苦法智忍。有说不获一切圣法。若尔岂不无非异生无一。总成就一切圣法故。若有不获不杂于获是异生性。若杂获者非异生性。故无有失。若尔本论应说纯言。不尔离言见义有故。如说此类食水食风。虽无纯言而亦知彼纯食水风。不杂余故。有说不获苦法智忍。然非后舍复成异生。前已永害彼非得故。何缘故知。别有实法说名非得。以契经中说有成就不成就故。如契经言。若成就六法不成就顺忍。六法如经。若谓未生圣法眼等。相续分位名异生性。彼违契经。如世尊说。如是名为随信行者。入正性离生超越异生地。此异生地即异生性。何缘故知。如得舍故。如得异法故名为入。应舍异法故名为超。非于尔时舍曾所得。眼等诸法少分可知。如得未曾所得圣法。故不可谓。未生圣法。眼等相续即异生性。故别有法。唯异生有。遍诸异生。违圣道得名异生性。其理必然。岂不如圣法即说是圣性。成就此性故名圣者。如是异生法应即异生性。成就此性故名异生。此例不然。以诸圣法唯圣者有。可即圣法说为圣性。诸异生法圣者亦有。如何可立为异生性。若异生法唯异生成。遍异生位可异生性。恶趣无想北俱卢等。不遍异生。余命根等。虽遍异生而圣亦有。傍论已了。今更应思如是非得。何时当舍此法非得。得此法时。或转易地舍此非得。如圣法非得说名异生性。随得圣法时舍三界非得。如是住初无漏心者。于苦法智。展转乃至住金刚喻三摩地者。于阿罗汉所有非得。如其所应随得此法舍此非得。如是乃至阿罗汉果时解脱者。于阿罗汉不时解脱所有非得。得此法时舍此非得。余法非得类此应思。又此非得云何名舍。若非得得断非得非得生。如是名为舍于非得。得与非得虽各有余。得及非得然非无穷。由得势力成就本法。及与得得。得得势力。成就法得。岂成无穷。非得亦应如理思择。非得非得必不俱生。又从下地生上地时。下地非得一切皆舍。从上生下类此应知。由所依力非得转故。如是已辩得非得相。同分者何。颂曰

  同分有情等

论曰。有别实物名为同分。谓诸有情展转类等。本论说此名众同分。一趣等生。诸有情类。所有身形。诸根作用。及饮食等。互相似因。并其展转相乐欲因。名众同分。如鲜净色。业心大种皆是其因。故身形等非唯因业。现见身形。是互相似业所引果。诸根作用及饮食等。有差别故。若谓满业有差别故。此差别者理不应然。或有身形唯由相似引业所起。以众同分有差别故。作用等别若身形等唯业果者。随其所乐作用等事。若舍若行应不得有。此中身形作用乐欲。展转相似。故名为同分是因义。有别实物是此同因。故名同分。如是同分。世尊唯依诸有情说。非草木等。故契经言。此天同分。此人同分。乃至广说。故众同分实有义成。非唯说形色更互相似故。就界趣生处身等别。有无量种有情同分。复有法同分。谓随蕴处界。是众同分依故。非情无有。异生同分。入离生时舍。有情同分。入涅槃时舍。岂不异生性即异生同分。此不应然。作用异故。由彼身形作用乐欲互相似因。名为同分。若与圣道成就相违。是异生因。名异生性。入离生时于众同分亦舍亦得。于异生性舍而不得。同分非色如何得知。有用能生无别事类。由见彼果知有彼故。如见现在业所得果。知有前生曾所造业。又观行者。现证知故。何不许有非情同分。不应如是责。有太过失故。汝亦许有人天等趣胎卵等生。何不亦许庵罗等趣菉豆等生。又佛世尊曾不说故。但应思择。何故世尊唯于有情说有同分。非于草等。复云何知如是同分别有实物。且我于中作如是解。由彼草等无有展转作用乐欲互相似故。于彼不说别有同分。又必因有情草等方生故。唯于有情说有同分。又因先业及现勤勇此法得生。于彼草等二事皆无。故无同分。即由此事证有实物。又木素漆雕画等像及彼真形。虽有色形展转相似。而言一实。由此非唯见彼相似。即言是实。要于相似差别物类。方起实言。故知实有此差别法。此实言说由此法生。又前说故。前说云何。谓见身形是互相似业所引果。诸根作用及饮食等有差别故。是诸同分展转差别。如何于彼更无同分。而起无别觉施设耶。由诸同分是同类事。等因性故即为同类。展转相似觉施设因。如眼耳等。由大种造方成色性。大种虽无余大种造而色性成。此应显成胜论所执总同句义同异句义。若胜论执此二句义。其体非一。刹那非常。无所依止。展转差别。设令同彼亦无多过。非胜论者执眼等根能行色等。即令释子舍如是见别作余解。故彼所难是朋党言。求正理人不应收采。已辩同分。无想者何。颂曰

  无想无想中　　心心所法灭
  异熟居广果

论曰。若生无想有情天中。有法能令心心所灭。名为无想。是实有物。能遮未来心心所法令暂不起。如堰江河。此法一向是无想定所感异熟。由彼无想有情天中无想及色唯是无想定所感异熟果。此定不能引众同分及命根故。以众同分及与命根唯是有心第四静虑所感异熟。彼处余蕴是共异熟。以生无想有情天中多时有心。谓入无想前及出无想后。然无心位时极长故名无想天。无想有情居在何处。居在广果。谓广果天中有高胜处。如中间静虑名无想天。彼以业生等无间缘为任持食。谓由宿业引众同分及命根等。由续生心及无间入无想果心牵引资助故。彼亦有过去触等为任持食。无心位中唯有过去触等为食。现在食无。有心位中二种俱有。彼诸有情由想起故。从彼处殁。殁已决定生于欲界。非余处所。先修定行所感寿量势力尽故。于彼不能更修定故。如箭射空力尽便堕。若诸有情应生彼处。必有欲界顺后受业。如应生彼北俱卢洲。必定应有生天之业已辩无想。二定者何。谓无想定及灭尽定。初无想定。其相云何。颂曰

  如是无想定　　后静虑求脱
  善唯顺生受　　非圣得一世

论曰。如前所说有法能令心心所灭名为无想。如是复有别法能令心心所灭。名无想定。说如是声唯显此定。灭心心所与无想同。由正成办或极成办。故名为定。有余师说。如理等行。故名为定。令心大种平等行故。无想者定。或定无想。名无想定。由厌坏想生此定故。非诸异生能厌坏受。由耽着受而入定故。此定在何地。谓在后静虑。即在第四静虑非余。此不应说。所以者何。此定能感无想异熟。已说无想居广果天。当说广果在后静虑。岂于余地而修彼因。此责不然曾无说故。未曾有处。说无想定。为无想因。岂不前颂说无想为异熟。于彼释中说为无想定果。此亦不然。曾未有颂作如是说。今说乃成。何故此定名异生定。为求解脱修此定故。彼执无想是真解脱。执无想定为出离道为证无想。而修此定一切圣者。不执有漏为真解脱及真出离。故说此定名异生定。前说无想是异熟故无记性摄。不说自成。今无想定一向是善。岂不此是异熟因故善性所摄。不说自成。此于无想有情天中为因能招五蕴异熟。不尔颂中犹未说故。又染无记谁复能遮。若尔此中应言纯善。不尔离言见义有故。此应准前异生性释。或唯言善。已显非余。此定既是异熟因性。为顺何受。唯顺生受非顺现后及不定受。一类诸师作此定执。理顺生受及不定受。所以者何。成此定者。亦容得入正性离生。入已必无现起此定。由约现行说无想定名异生定。非约成就。又许此定。通是此法。外法异生。所得非圣。以诸圣者于无想定如见深坑不乐入故。颂中已说。求解脱言即显此定唯属异生。复言非圣便为无用。此初得时为得几世。此于诸位中如别解脱戒念念别得未曾得故。第一念时非得过去。以无心故不修未来。故初得时唯得一世。谓得现在第二念等。乃至未出亦成过去。出已乃至未舍已来唯成过去。如天眼耳无未来修。唯加行得非离染得。次灭尽定。其相云何。颂曰

  灭尽定亦然　　为静住有顶
  善二受不定　　圣由加行得
  成佛得非前　　三十四念故

论曰。如前无想定。灭尽定亦然。谓如已离第三静虑贪者。有法能令心心所灭。名无想定。如是已离无所有处贪者。有法。能令心心所灭。名灭尽定。如是二定差别相者。前无想定为求解脱厌坏于想。以出离想作意为先。而得证入。今灭尽定为求静住厌坏散动。以止息想作意为先。而得证入。前无想定在色界边地。今灭尽定在无色边地。以在非想非非想处所受生身是最上业所牵引故。说名有顶。或有边际。故名有顶。如树边际说名树顶。唯此地中有灭尽定。何缘下地无此定耶。厌背一切心及边际心断。方能得此胜解脱故。谓由二缘立此解脱。一者厌背一切心故。二者边际心暂断故。若于下地有此定者。便非厌背一切种心以未能厌上地心故。亦不名为边际心断。以上地心犹未断故。应名厌背少分诸心。亦复应名中际心断。于三性中前及此定。俱唯是善。非染无记。非诸圣者厌怖散动取染无记为寂静住。前无想定能顺生受及不定受。今灭尽定通顺生后及不定受。谓约异熟有顺生受。或顺后受及不定受。或全不受。谓若下地起此定已。不生上地便般涅槃。此灭尽定能招有顶四蕴异熟。前无想定唯异生得。此灭尽定唯圣者得。非诸异生能起灭定。彼有自地起灭定障犹未断故。未超有顶见所断惑。于起灭定毕竟无能非诸异生能超有顶见所断惑。故唯圣者得灭尽定。一切圣者得有顶时。皆得如斯灭尽定不。应言不得。由此定非离染得故。由何而得。由加行得。要由加行方证得故。如无想定初证得时。唯得现在。不得过去。不修未来。要由心力方能修故。第二念等乃至未舍亦成过去。世尊亦以加行得耶。不尔云何成佛时得。彼谓世尊尽智时得。岂不尽智于成佛时亦不名得。况灭尽定。以诸菩萨住金刚喻三摩地时名得尽智。得体生时名为得故。于成佛时应说尽智。不由加行而现在前。暂起欲乐现在前时。一切圆德随乐起故。非佛身中所有功德成佛时得。如何可说佛尽智时得灭尽定。由菩萨时永离一切烦恼染故。令佛身中功德得起。故说如来所有功德皆离染得。故彼所言亦有过失。随宜为彼而释通者。谓于近事而说远声。或金刚喻三摩地时。必成佛故亦名成佛。无间刹那定成佛故。且置斯事。世尊曾未起灭尽定得尽智时。如何得成俱分解脱。永离定障故。舍不成就故。于起灭定得自在故。如已起者成俱解脱。西方师说。菩萨学位先起此定。后得菩提。迦湿弥罗国毗婆沙师说。非前起灭定后方生尽智。何因此国毗婆沙师。知尽智前未起灭定。何为不责西方起因。且我迦湿弥罗国说三十四念得菩提故。谓诸菩萨决定先于无所有处已得离贪方入见道。不复须断平地烦恼。三十四念得大菩提。谛现观中有十六念。离有顶贪有十八念。谓断有顶九品烦恼。有九无间九解脱道。如是十八足前十六成三十四。于此中间无容得起不同类心。故于前位决定无容起灭尽定。若于前位起灭尽定。便越期心。然诸菩萨决定不越要期心故。如是善成三十四念得菩提故。为非前因。虽已说二定有多同异相。而于其中复有同异颂曰

  二定依欲色　　灭定初人中

论曰。言二定者。谓无想定及灭尽定。此二俱依欲色二界而得现起。然于此中有说唯在下三静虑入无想定。非在第四。勿因与果极相邻逼。有说亦在第四静虑入无想定。除无想天。以生彼天受彼果故。有余师说。唯在欲界入无想定。非在色界。彼违论文。谓本论言。或有是色有。此有非五行。谓色廛有情。或生有想天。住不同类心。若入无想定。若入灭尽定。或生无想天。已得入无想。是谓是色有。此有非五行。由此证知。如是二定俱依欲色而得现起。是名同相。言异相者。谓无想定。欲色二界皆得初起。灭定初起唯在人中。谓灭尽定唯在人中。得初修起唯人中有。说者释者。及有强盛加行力故。有在人中初修得已。由退为先方生色界。依色界身后复修起。非在无色能入灭定。无所依故。命根必依色心而转。若在无色入灭定者。色心俱无。命根应断。诸蕴展转相依而住故。无有情唯具一蕴。又心心所不相离。故亦无有情唯具三蕴。何因故知。灭定有退。准邬陀夷契经义故。经言。具寿有诸苾刍。先于此处。具净尸罗。具三摩地。具般罗若。能数入出灭受想定斯有是处。应如实知。彼于现法或临终位。不能勤修令解满足。从此身坏超段食天。随受一处意成天身。于彼生已复数入出灭受想定。亦有是处。应如实知。此意成天身。佛说是色界灭受想定。唯在有顶。若得此定必无退者。不应得往色界受生。如是广释二定异相总有六门。谓地加行相续异熟顺受初起有差别。故今应思择。灭尽定中。总灭一切心心所法。何缘唯说灭受想定。厌逆彼二生此定故。谓想与受能为见爱杂染所依故偏厌。逆如是二法多诸过患。如立蕴中已广分别。故偏厌逆入灭尽定。此灭定位决定无心。以一切心皆与受想俱生灭故。如契经说。眼及色为缘生于眼识。三和合触俱起受想思。乃至广说。曾无处言。有第七识。可执彼识离受想生。此经俱言。显同时起。芦束相依为譬喻故。说心心所生缘等故。非此定中唯想受灭。此中亦说。意行灭故。若此定中心不灭者。想受二种亦应不灭。能生彼触应亦有故。由此灭定必无有心。然定后心复得生者。定前心作等无间缘所引摄故。又加行中要期势力所引发故。灭尽定体应知实有。能遮碍心令不生故。若谓定前心遮碍余心者。则应余心毕竟不起。若谓有根身能起余心者。应一切时诸识顿起。说依前心后心起者。以无第二等无间缘。虽有同时所依境界。而无一切境识顿生。若执不待自类因缘待有根身识便起者。彼一切位一切境识。何法为碍起不同时。是故唯应依心心起。非前定心。力能遮碍余心。由此故知。离前心外定有别法能遮碍心由此法故。于无心位。虽有心因而心不起。即此别法名灭尽定。体是有为。实而非假。修观行者。由定前心要期愿力所引发故。令灭尽定势力渐微。至都尽位无遮碍用。意法为缘还生意识。由此准释前无想定及与无想。随其所应已辩二定。命根者何。颂曰

  命根体即寿　　能持暖及识

论曰。命体即寿。故本论言。云何命根。谓三界寿。异名虽尔自体未详。应更指陈。何法名寿。谓有别法。能持暖识。说名为寿。故世尊言

  寿暖及与识　　三法舍身时
  所舍身僵仆　　如木无思觉

若尔此寿何法能持。此寿能持。我说是业。一向是业异熟果故。一期生中常随转故。暖非一向业异熟果。识二俱非。虽有一期常随转处。而非一向是业异熟。故不可说识由业持。是故说寿能持暖识。非非业感。识流转中业有少分能持功用。一同分中异熟生识断而更续。唯寿力持复如何知寿能持暖。要有寿者方有暖故。诸无暖者亦见有寿。故知寿体非暖所持。由此故知。别有实法彼力能持有情暖识。说名为寿。此即命根。如是命根非唯依身。无色亦有故。非唯依心。无心亦有故。若尔依何。依先世业及现同分。其众同分亦准命根。命行寿行有何差别。若生法寿名为命行。不生法寿说为寿行。有作是言。非所弃舍名为命行。是所弃舍名为寿行。复有说言。若神足果名为命行。若先业果名为寿行。复有说者。若明增上生名为命行。无明增上生名为寿行。或有说者。唯离贪者相续所得。名为命行。亦有贪者相续所得。名为寿行。是为命行。寿行差别。已辩命根。何谓诸相。此有四。四者何。颂曰

  相谓诸有为　　生住异灭性

论曰。如是四种是有为相。显彼性故得彼相名。依此说有诸行种类。此中生者。谓有别法。是行生位。无障胜因。由能引摄令其生故。能引摄者。谓彼生时此法能为彼胜缘性。虽诸行起皆得名生。然此生名。但依诸行生位无障胜因而立诸行。必藉前生俱生同类异类缘力故。起思因果。中当广显。示前生同类异类缘。中同类缘强随彼起故。俱生缘内无同类缘。异类缘中有偏胜者。如缘眼色眼识生中。说眼为因。色为缘性。虽随阙一眼识不生而眼识生。随眼非色。是近缘性故说为因。眼识俱生一果诸法。为缘助识力胜非眼。又于俱起一果法中。自有相生力偏胜者。如风望火风助火力。令其炽然世极成故。现见异聚风偏顺火。故可比度同聚必然。是故俱生诸行缘内生力胜者。偏立生名。此生功能。于生初念无漏诸得其相最显。既于此处见有胜能。可比度余。应知亦有。住谓别法。是已生未坏诸行。引自果无障胜因。如诸行生必待别法。为胜因助引果胜用。亦应必待别法为因。非对法者所许诸行。待众因缘体暂有位。对法诸师说为现在。亦说有住。诸行尔时引自果故。又即于此立为作用。世尊亦言。诸行暂住。又说诸色有生住时。此不可言据相续说。一刹那顷亦苦性故。相续必览刹那成故。诸有为相但依相续。前后建立。理必不成。故有别法能为诸行引果作用无障近因。对法诸师说此为住。异谓别法。是一切行自类相续。后异前因不可无因。自然有异。同一识相前后相续。转变无因。理不成故。生无色界受等相续念念变易。此用最显见无色界。有异胜能可比度余。应知亦有。灭谓别法是俱生行。念念灭坏。无障胜因。不可执无为灭相体。无从缘起理不成故。亦不应说有生灭故。又契经言。应知生灭缘无境智。理必非有。故不可说无为灭相。又如生法。由别生生。灭法亦应由别灭灭。总言性者。是实体义。若有为相有四体别。何故契经但说三种。契经为显有为无为德失差别。故不说住。或若有相唯表有为。契经偏说非住相体。唯表有为。常亦有故。非此不说是无住因。余经说行有生灭法。非无异法。此亦应尔。虽有四相随所化宜。隐住说三。而无有失。或此经中已密说住。无唯声故。或此经中住异合说。若不尔者。但应言异为显有为住必兼异。不同无为有住无异。非此经中言住异者。显住即异。但显有为有起有尽有住有异。无为有住无所余三。故诸有为与无为别。由斯对法说诸有为定有四相。理无倾动。此生等相既是有为。应更别有生等四相。若更有相便致无穷。彼更有余生等相故。实许更有然非无穷。所以者何。颂曰

  此有生生等　　于八一有能

论曰。此中有言。兼显定义。意显此有唯四非余。此谓前说四种本相。生生等者。谓四随相。即是生之生生。乃至灭之灭灭。诸行有为。由四本相。本相有为由四随相。世尊何处说随相耶。有契经言。老死起故。此经亦说。定有随相。谓生等相。亦是有为故。生生等相亦起等性故。契经既说。有三有为之有为相。有为之起亦可了知。尽及住异亦可了知。故知此中亦摄随相。又于诸相皆有亦言。故此经中亦说随相。言有为之起。亦可了知者。起即本相生亦表生。生义尽及住异亦可知言类起亦言应如理释。若不尔者。何用亦言。故契经中。于无为法说尚无有起等可知。此意说言。诸无为法尚无生等本相可知。况生生等随相可得。若不尔者。应但说无起等可知不应言尚。又薄伽梵。于契经中说诸有为相复有相故。契经说色有起尽。此复应知。亦有起尽乃至广说。由此故知。相复有相。若尔本相如所相法。一一应有四种随相。此复各四。展转无穷。无斯过失。四本四随。于八于一。功能别故。为亲缘用。名曰功能。谓四本相。一一皆于八法有用。四种随相一一皆于一法有用。其义云何。谓法生时并其自体九法俱起。自体为一。相随相八本相中生。除其自性能为亲缘生余八法。诸法于自体无生等用故。随相生生为亲缘用。于九法内唯生本生。此生一生。多由功能别故生性。既无异功能何有别如受领纳。性虽无异而有功能损益差别。又本相随相境有多少。如五识意识境有少。多谓为亲缘令引自果作用得起。是生功能。本相中住。亦除自性。能为亲缘。住余八法。随相住住。能为亲缘。于九法中唯住本住。谓为亲缘。令法暂住。能引自果。是住功能本相中异。除其自性。能为亲缘。异余八法。随相异异。能为亲缘。于九法中唯异本异。谓为亲缘令引自果作用衰损。是异功能。本相中灭。除其自性。能为亲缘。灭余八法。随相灭灭。能为亲缘。于九法中。唯灭本灭。谓为亲缘令引自果。作用灭坏是灭功能。是故生等相复有相随。相唯四无无穷失

说一切有部显宗论卷第七阿毗达磨藏显宗论卷第八

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩差别品第三之四

虽离所相别有生等。与所相法俱时而起。而无一法一时即生即住即异即灭过失。如体不同用有别故。执所相外无别生等。一一刹那有四相者。如斯过失不可救疗。一法一时功能差别。理不成故。许所相外有别生等。无斯过失。相体不同助缘差别。时分功能理有异故。然有为法分位不同。略有三种。谓引果用。未得正得。已灭别故。此诸有为复有二种。谓有作用及唯有体。前是现在。后是去来。此复一一各有二种。谓彼功能有胜有劣。诸有为法。若能为因引摄自果。名为作用。若能为缘摄助异类。是谓功能。若有别法于未获得引果用时。由遇未得正得已灭。引果用时。外缘摄助。于办自事。发起内缘。摄助功能。是名生相。或复有法。于正获得。引果用时。由遇未得。正得已灭。引果用时。外缘摄助。于办自事。发起内缘。摄助功能。是余三相。于正生位生为内缘起所生法。至已生位此所生法名为已起。于正灭位。住为内缘。安所住法。令引自果至已灭位此所住法名于自果已能引发即正灭位。灭为内缘坏所灭法。至已灭位。此所灭法名为已坏异相亦尔如应当知。有余师说。因要待处。世时位伴。能与果故。生已生时起用差别。谓或有因待处与果。如雨要待云处方生。要赡部洲处金刚座。方证无上正等菩提。或复有因待世与果如异熟因顺解脱分。要在过去方能与果或复有因待时与果。如轮王业要劫增时。方能获得转轮王位。或复有因待位与果。如诸种子至变异位方能生芽。初无漏心及光明等体虽先有。而要未来正生位中能有所作。或复有因待伴与果。如四大种心心所等。要与伴俱能有所作。由斯差别缘起正理。四相起用分位不同。谓正生时生相起用。至已生位住异灭三。同于一时各起别用。如是四相用时既别。故无一法一时即生即住即异即灭过失。又正灭时。此所相法由余住相为胜因故。暂时安住能引自果即于尔时由余异相为胜因故。令其衰损。即于尔时由余灭相为胜因故。令其灭坏。故三一时无相违失。时所相法为名安住。为名衰异。为名坏灭。由能相力。所相一时。所望不同。具有三义。如何异相。即于住时衰损能引自果作用损彼作用。令后果生劣于前因。是异相力。后果渐劣。由因有异。此果复由俱起异相为缘衰损。能令后果更劣于前。如是一切有为相续刹那刹那令后后异。故前前念有异义成。此义既成。应为比量。谓见最后有差别故。前诸刹那定有差别。若尔相续渐增长时异相应无。不见果故。无斯过失。住相尔时由外缘助势力增强。摧伏异故。若生在未来生所生法。未来一切法何不顿生彼能生因。各常合故。此先已辩。先何所辩。谓有别法于未获得引果用时。由遇未得正得已灭。引果用时外缘摄助。于办自事发起内缘摄助功能。是名生相。又作是说。因要待处。世时位伴。方与果故。即依此义说如是言。颂曰

  生能生所生　　非离因缘合

论曰。非离所余因缘和合。唯生相力能生所生。故诸未来非皆顿起。生相虽作俱起近因。能生所生诸有为法。而必应待前自类因及余外缘和合摄助。如种地等差别因缘。助芽等生令生芽等。若尔我等唯见因缘。有生功能无别生相。有因缘合诸法即生。无即不生。何劳生相。故应唯有因缘力生。此责不然。唯许众缘诸法生者。此责同故。谓若唯许未来诸法因缘和合而得生者。此责亦同。未来诸法因缘无别者。何不顿皆生。又因缘中随阙一种。具所余故果亦应生。且如眼根先业所引。虽离大种而亦应生。或应但由大种功力。不由先业眼根得生。或诸眼根随业所引能生大种。无不合时。于一生时。余亦应起。或应大种于眼无能。不见离前眼大种独生故。但应因前眼后眼得生。许大种能生应成无用。又如种子水土等缘。随阙一时芽必不起。故知种等功力极成于眼等生。地等大种能生功力。非所现见。既不现见大种功力。应不为因生于眼等。又汝所执有业种子相续转变。谁为障碍。不能顿生。一切业果。若由缘助业种方能生。应但缘能生。何劳业种。以众缘助业果乃生。众缘若无果不生故。既赖缘助而业种非无。虽藉众缘宁拨无生相。又于眼等诸识生中。处处经言。虽有眼色若离作意眼识不生。然说识生缘眼及色。故不应难。因缘力生。何劳生相。又见初念无漏生时。生能为因起无漏得。得自相有前已极成。应说除生有何别法。能作此得前俱起因。若全无因得不应起。则初无漏应不说成。生相生时为亦别有。俱生因不应言亦有。谓除生体余一果法。云何异灭为生助因。古昔诸师咸作是释。同一果法展转为因。如诸大种更相顺故。复有释言。诸有为法一切皆是生等性故。生等四相一一用时。以此为门余皆助力。是故所说生生所生。非离因缘理善成立。余广决择诸有为相。如顺正理及五事释。已略分别诸有为相。名身等类。其义云何。颂曰

  名身等所谓　　想章字总说

论曰。等者等取句身文身。名句文身。本论说故。诸想总说即是名身。诸章总说即是句身。诸字总说即是文身。言总说者。是合集义。于合集义中说殟遮界故。想者眼耳瓶衣等想。谓于诸法分别取着。共所安立字所发想。如是想身即是名身。谓眼耳鼻舌身意等。章谓章辩。世论者释。是辩无尽带差别章。能究竟辩所欲说义。即是福招乐异熟等。如是章身即是句身谓如有说

  福招乐异熟　　所欲皆如意
  并速证第一　　永寂静涅槃

如是句等。字谓[褒-保+可]阿壹伊等字。如是字身即是文身谓迦佉伽等。有余师说。本论中言。云何多名身。谓名名事等。非彼论师欲辩名等是实有相。而依假合以发问端。是故彼问多名身等者。决定应问名等体实相。思择名等体实相中。何用推征名等假合。又名等三相差别者。谓声所显。能显于义。以共立为能诠定量。显示所解意乐所生。能表所知境界自体。犹如影响。此相是名。若能辩析所知境中广略义门。此相是句。于能说者声已灭位。犹令系念持令不惑传寄余者。此相是文。此中名者。谓随归赴。如如语声之所归赴。如是如是。于自性中名皆随逐呼召于彼。句者即能辩所说义。谓能辩析差别义门。文者谓能有所彰显。依此由此彼彰显故。此即是字。谓令系念无有忘失。或复由此之所任持令无疑惑。或能持彼转寄于余故。有说言如静虑者。方便境相与静虑中所觉了境而为梯蹬。文于名句及义亦尔。名句文身理实皆是不相应行。而经论中说非色法皆为名者。以色相显当体立名。非色相隐从诠立目。义为可说不可说耶。理实应言义不可说。然共施设。闻言解义。因语发名。名显义故。三世等法各有三名。谓去来今三时说故。又一切法无无名者。若有应成非所知境。故薄伽梵说如是言

  名能映一切　　无有过名者
  是故名一法　　皆随自在行

有余师说。义少名多。于一义中有多名故。有余复说。名少义多。名唯一界少分所摄。义则具收十八界故。复有说者。互有少多。谓约界摄义多名少。若依立教义少名多。谓佛世尊。于一一法随义施设无边名故。如贪名爱名火名蛇名蔓名渴名网名毒名泉名河名修名广名针缕等。如是一切。此中经主作如是言。岂不此三语为性故。用声为体。色自性摄。如何乃说为心不相应行。此责非理。所以者何。理教分明。证别有故。教谓经言。语力文力。若文即语别说何为。又说应持正法文句又言依义不依于文。又说伽他因谓阐陀。文字阐陀。谓造颂分量语为体。又契经言。知法知义。法谓名等。义谓所诠。又契经言。文义巧妙。又言应以善说文句读诵正法。恶说文句读诵正法。义即难解。又说如来获得希有名句文身。又说。彼彼胜解文句甚为希有。由此等教证知别有。能诠诸义。名句文身。其体如声。实而非假。理谓现见。有时得声而不得字。有时得字而不得声。故知体别。有时得声不得字者。谓虽闻声而不了义。现见有人粗闻他语而复审问。汝何所言。此闻语声不了义者。都由未达所发文故。如何乃执文不异声。有时得字不得声者。谓不闻声而得了义。现见有人不闻他语睹唇等动知其所说。此不闻声得了义者。都由已达所发文故。由斯理证。文必异声。又见世间隐声诵咒。故知咒字异于咒声。又见世间有二论者。言音相似。一负一胜。此胜负因必异声有。又法与词二无碍解。境界别故知字离声。是故声者。但是言音相无差别。其中屈曲必依加遮吒多波等。要由语声发起诸字。诸字前后和合生名。此名既生即能显义。由斯展转而作是言。语能发名名能显义。故名声异。其理极成。应知此中声是能说。名等所说。义俱非二如是则为无倒建立。此中经主又作是言。非但音声皆称为语。要由此故义可了知。如是音声方称语故。谓能说者。于诸义中已共立为能诠定量。若此句义由名能显。声即能诠。何须名等。何等名为能诠定量。岂不于义共立想名。此即说为能诠定量。谓能说者。于诸义中先共安立如是诸字。定能展转诠如是义。由共安立如是字故。因如是字发如是名。此名即是能诠定量。诸能说者。将发语时。要先思惟如是定量。由此自语或他语时。于所显义皆能解了。故非唯声即能显义要语发字。字复发名。名乃能诠所欲说义。如语发字字复发名。如是应思发句道理。此中经主复作是言。又未了此名如何由语发。为由语显。为由语生。若由语生语声性故。声应一切皆能生名。若谓生名声有差别。此足显义何待别名。若由语显语声性故。声应一切皆能显名。若谓显名声有差别。此足显义何待别名。执声能诠。斯难亦等。谓若声体即能显义应一切声无非能显。若谓能显声有差别。如是差别应即是名。故所推征末为过难。然能说者。以所乐名。先蕴在心。方复思度。我当发起如是如是言。为他宣说如是如是义。由此后时随思发语。因语发字。字复发名。名方显义。由依如是展转理门。说语发名。名能显义。如斯安立其理必然。若不以名先蕴心内。设全发语无定表诠。亦不令他于义生解。又经主言。或应唯执别有文体。即总集此为名等身。更执有余便为无用。此亦非理。无有诸文俱时转故。既不俱转如何总集。或如树等大造合成。非不缘斯别生于影。影由假发而体非假。如是诸文亦应总集。别生名句。而彼名句虽由假发而体非假。若尔即应一切假法。皆可安立为实有性。无如是失。于一字中亦有名故。无有假法揽一实成。故假与名义不相似。既于一字亦得有名。此名如何知离字有。如是一字如无义字无有所诠。依此为缘别有名起。方能表义。然极相近。别相难知。如壁上光二色难辩。若许即声。由先契约宣唱差别。能表于义说为名等。斯有何失。此亦不然。能诠契约即声差别。理不成故。若共所立能诠契约即声差别者。应如色差别非共立契。亦可了知。非青与黄二色差别。要共立契然后可知。虽二色中先不共立差别契约。而彼青黄非异色故。眼识得已意识即能。随分别知此彼差别。又理不应。于契约上复作契约。故不应言能诠契约。虽不异声而先不共立契约者。虽复得声而更待余立契约故。未能了别。此望余声有差别相。又若所立契即声差别者。于有义声及无义声。所有差别虽先未共立差别契应亦了知。谓于一声有此差别。于余声上此差别无。先未共立差别契者。得二声时虽不了义。然应如彼二色差别。即能了达有契约声无契约声差别之相。故知别有名句文身。缘声而生能显了义。又经主说。诸刹那声不可聚集。亦无一法分分渐生。如何名生可由语发。又自释言。云何待过去诸表刹那。最后表刹那能生无表。复自难言。若尔最后位声乃生名。但闻最后声应能了义。若作是执。语能生文。文复生名。名方显义。此中过难应同前说。以诸念文不可集故。语显名过。应例如生。又文由语若显若生。准语于名皆不应理。此难违害自所禀宗。彼说去来皆无自体。声前后念不可顿生。如何成文成名成句。若前前念传传相资最后刹那成文名句。但闻最后应了义成。又无相资去来无故。既恒一念如何相资。既无相资前后相似。后如初念应不能诠。闻后如初应不了义。故彼所执前后相资。声即能诠理不成立。我宗三世皆有非无。故后待前能生名等。虽最后念名等方生。而但闻彼不能了义。由不具闻。如先共立。名等契约。能发声故。然闻一声亦有了者。由串习故。依此比余。故经主言。破彼非此毗婆沙说。名句文三各有三种。名三种者。谓名名身多名身。句文亦尔。名有多位。谓一字生。或二字生。或多字生。一字生者。说一字时但可有名。说二字时即谓名身。或作是说。说三字时即谓多名身。或作是说。说四字时方谓多名身。二字生者。说二字时但可有名。说四字时即谓名身。或作是说。说六字时即谓多名身。或作是说。说八字时方谓多名身。多字生中三字生者。说三字时但可有名。说六字时即谓名身。或作是说。说九字时即谓多名身。或作是说。说十二字时方谓多名身。此为门故余多字生。名身多身如理应说。句亦多位。谓处中句。初句后句短句长句。若八字生名处中句。不长不短。故谓处中。三十二字生于四句。如是四句成室路迦。经论文章多依此数。若六字已上生名初句。二十六字已下生名后句。若减六字生名短句。过二十六字生名长句。且依处中句辩三种。说八字时但可有句。说十六字时即谓句身。或作是说。说二十四字时即谓多句身。或作是说。说三十二字时方谓多句身。文即字故。唯有一位。说一字时但可有文。说二字时即谓文身。或作是说。说三字时即谓多文身。或作是说。说四字时方谓多文身。由此理故应作是说。说一字时有名无名身无多名身。无句无句身无多句身。有文无文身无多文身。说二字时有名有名身无多名身。无句等三。有文有文身无多文身。说四字时有名等三。无句等三。有文等三。说八字时有名等三。有句无句身无多句身。有文等三。说十六字时有名等三。有句有句身无多句身。有文等三。说三十二字时。名句文三。各具三种。由此为门。余如理说。复应思惟。如是名等何界所系。为是有情数。为非有情数。为是异熟生。为是所长养。为是等流性。为善为不善。为无记。此皆应辩。颂曰

  欲色有情摄　　等流无记性

论曰。此名等三唯是欲色二界所系。就色界中。有说。唯在初静虑地。有说。亦通上三静虑。随语随身所系别故。若说此三随语系者。说生欲界作欲界语时。语名等身皆是欲界系。彼所说义。或三界系。或通不系。即彼复作初定语时。语及名等初定地系。身欲界系。义如前说。如是若生初静虑地作二地语。如理应思。若生二三四静虑地作二地语。亦如理思。若说此三随身系者。说生欲界或四静虑。名等及身各自地系。语或自地。或他他系。义如前说。此二说中。或言上地亦有名等而不可说。虽有二说然初说善。又名等三有情数摄。非情有为不成就故。能说者成。非所显义。唯成现在。不成去来。又名等三唯等流性。非所长养。非异熟生。而言名等从业生者。是业所生。增上果故。又名等三。唯是无覆无记性摄。故断善者。说善法时。虽成善名等。而不成善法。离欲贪者不成不善。诸无学者不成染污。成能诠名等。非所诠法故。如上所说。余不相应所未说义今当略辩。颂曰

  同分亦如是　　并无色异熟
  得相通三类　　非得定等流

论曰。亦如是言。为显同分。如名身等通于欲色。有情等流无覆无记。并无色言显非唯欲色。言并异熟显非唯等流。是界通三类通二义。云何异熟。谓地狱等及卵生等趣生同分。云何等流。谓界地处种姓族类沙门梵志学无学等所有同分。有余师说。先业所引生。是异熟同分。现在加行起。是等流同分。得及诸相类并通三。谓具刹那等流异熟。非得二定唯是等流。唯言为明非异熟等。所余应说而不说者。命根无想如前说故。余义准前已可知故。谓说得等唯成就故有情数摄义可准知说诸有为有生等故。准知诸相通情非情。余随所应义皆已显。是故于此无劳重说。如是已辩不相应行。前言生相。生所生时。非离所余。因缘和合。此中何法说为因缘且因六种。何等为六。颂曰

  能作及俱有　　同类与相应
  遍行并异熟　　许因唯六种

论曰。本论许因唯有六种不增不减一能作因。二俱有因。三同类因。四相应因。五遍行因。六异熟因。能作因体通一切法。是故前说。俱有因体遍诸有为。故居第二。余同类等。于有为中如其所应各摄少分。随言便稳次第而说。法生所赖故说为因。即亲顺益所生果义。如是六因非佛所说。如何本论自立此名。定无大师所不说义。阿毗达磨辄有所说。经中现无由隐没故。自相可得决定应有。又诸经中所化力故。世尊方便作异门说对法诸师由见少相知其定有。分明结集。故有说言。此六因义说在增一增六经中时经久远其文隐没。尊者迦多衍尼子等。于诸法相无间思求。冥感天仙现来授与。如天授与筏第遮经。其理必然。如四缘义。虽具列在此部经中。而余部中有不诵者。由时淹久多隐没故既见余经有少隐没。故知此处亦非具在。又见经中处处散说。故六因义定应实有。谓如经说。眼色为缘生于眼识。又如经说。二因二缘能生正见。诸如是等即能作因。诸法于他有能作义。由生无障故立此因。如契经说有三道支正见随转。又如经说。三和合触俱起受想思。诸如是等即俱有因。诸行俱时同作一事。由互随转故立此因。如说。如是补特伽罗成就善法及不善法。应知如是补特伽罗善法隐没恶法出现。有随俱行善根未断。以未断故从此善根。犹有可起余善根义。又说。苾刍若于彼彼多随寻伺。即于彼彼心多趣入。无明为因起诸染着。明为因故离诸染着。诸如是等即同类因。过去现在同类诸法。由牵自果故立此因。如契经说。见为根信证智相应。又如经言。若有了别即有了知。在定了知乃为如实非不在定。诸如是等即相应因。心心所相应同作一事。由共取一境故立此因如契经言诸邪见者所有身业语业意业诸有愿求。皆如所见。所有诸行皆是彼类。如是诸法皆悉能招非欣爱乐不可意果。又经说。一切见趣生时。皆以有身见为其根本。若此见生不忍一切。此见能生贪欲嗔恚。诸如是等即遍行因。过去现在见苦集所断疑见无明及相应俱有。于同异类诸染污法。由能引起故立此因。一部为因生五部果故同类外立遍行因。如契经言。若所作业是善有漏。是修所成。于彼处生受诸异熟。又如经言。诸故思业作及增长定招异熟。诸如是等即异熟因。一切不善善有漏法。由招异类故立此因。如是六因佛处处说。诸憎背者迷故不见。诸有智人应勤觉了。又薄伽梵处处经中说有俱生前生因义。依此有彼。有此生故彼生。如次应知。有二因义。又薄伽梵于契经中分明显说二种因义。谓契经言。诸有不敏处无明者。由无明故亦造福行。此经即显有前生因。又契经说。眼色为缘。广说乃至。意法为缘。生痴所生染浊作意。此中意者。痴即无明。希求即爱。爱表即业。此经则显有俱生因。一心中说有展转为因故。非谓此经据相续说。理不成故。同因所起。执不俱生。甚为迷谬。此广决择如顺正理及五事论。应如实知。已略举因。今当广辩。且初能作因相云何。颂曰

  除自余能作

论曰。此能作因略有二种。一有生力。二唯无障。诸法生时唯除自体。以一切法为能作因。由彼生时皆不为障。于中少分有能生力。且如有一。眼识生时。以所依眼为依止因。以所缘色为建立因。以眼识等如种子法为不断因。以相应法为摄受因。以俱有法为助伴因。以耳根等为依住因。此等总说为能作因。于中一分名有力因。以有能生胜功能故。所余诸分名无力因。以但不为障碍住故。因即能作。名能作因。此因有力。能作果故。虽余因性亦能作因。然能作因更无别称。如色处等总即别名。或复此因能作二义。以无障故可名为因。可名非因。不生能故。又能作者。是余亲因。此能助彼名能作因。或此令他能有所作。他即是果。能作之因。名能作因。何缘自体。非自能作因。以能作因于自体无故。谓无障义。是能作因。自于自体恒为障碍。又一切法不待自体。应有恒成损减等故。若有应与现事相违。一法生时余相违法。亦无障住故能为因。非彼与此。有时为因。有时非因。应合正理。故一切法皆能作因。诸法相望皆有障力。而不为障故能为因。若处有一余必无故。无色亦有。时依等定。故彼相望亦有障力。又诸法内。一法生时。如与欲法。余皆无障。由二缘故法不得生。一顺因无。二违缘有。诸法生位。必待胜力各别因缘。及待所余无障而住。增上缘法由能生因有能障因无诸法乃生故。唯由无障碍说一切法名为能作因。非有障力而不为障。与无障力不为障者。于无障时少有差别。俱有无障力同无胜用故。由斯理趣诸法不顿生非如作者皆成杀等业阙胜用缘因等起故。即由此理过去诸法与余二世为能作因。彼二世法还与过去为增上果。未来诸法与余二世为能作因。彼二世法非俱后故。不与未来为增上果。果必由因取故。唯有二因。唯据无障故许通三。现在诸法与余二世为能作因。彼二世中唯未来法为现在果。有为望有为。展转是因果。有为望无为。此非因彼非果。无为望无为。展转非因果。无为望有为。此是因彼非果。由斯故说果少因多。以能作因通一切法。其增上果唯有为故

说一切有部显宗论卷第八阿毗达磨藏显宗论卷第九

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩差别品第三之五

已辩能作因相。俱有因相云何。颂曰

  俱有一果法　　如大相所相
  心心随转等

论曰。若有为法同得一果。可得说此为俱有因。由助彼力得一果故。其相云何。如四大种。更互相望为俱有因。虽有体增体不增者。而皆三一更互为因。自体不应待自体故。亦不应待同类体故。一一大种唯待余三。要四大种异类和集。方有功能生造色故。如是诸相与所相法。心与心随转。亦皆互为因等言为明诸心随转及诸能相亦互为因。是则俱有因。由得一果遍摄有为法。如其所应。然本论中。曾不见说心随转色与心为因。应辩此中造论者意。今我所见彼论意者。若法与心决定俱起。遍一切心。依心而转。即说彼法与所依心展转相望为俱有因。诸心所法非定俱起。或少或多现可得故。身业语业非遍诸心。不定心俱全无有故。生等诸相皆依心转。非互相依。法为上首。生住异灭互相资故。由斯不说彼互为因。又于此中为欲显示但说异类为俱有因。同类互为因不说而成义。又为显示有身语业唯依于心不依于表。故不说彼与心为因。又彼大德意趣难了。诸有智者应更寻思。然于此中有作是计。唯心与色为俱有因。非色与心依心转故。如王臣理胜不因劣。此喻不然。亦相资故心随转法。其体云何颂曰

  心所二律仪　　彼及心诸相
  是心随转法

论曰。一切心所静虑无漏二种律仪。彼法及心之生等相。如是皆谓心随转法。何缘心随相非心随转法。以随相于心非俱有因故。何缘心随相非心俱有因。不由彼力心得生故。彼于一法有功能故。又与心王非一果故。聚中多分非彼果故。若尔云何心能与彼为俱有因。由随心王生等诸位彼得转故。岂不应如大种生等。心亦用彼为俱有因。谓如造色非生等果。生等非不与诸大种为俱有因。此亦应尔。如是所例其理不齐。展转果一果多。非彼果故。非诸造色。是诸大种。展转果中。一果所摄。何容造色。非诸大种生等果故。例此为失。又如前说。前说者何。不由彼力心得生故。然诸大种与生等相。展转力生。故无此失。何缘此法名心随转。颂曰

  由时果善等

论曰。略说由时果等善等。十种缘故名心随转且由时者。谓此与心一生住灭及堕一世。由果等者。谓此与心一果等流及一异熟。由善等者。谓此与心同善不善无记性故。岂不但言一生住灭。即知亦是堕一世中。虽亦即知堕于一世。而犹未了。此法与心过去未来亦不相离。或为显示诸不生法。故复说言及堕一世。若尔但应言堕一世。不尔应不令知定堕一世。岂不等流异熟亦是一果摄。如何一果外说等流异熟耶。实尔。此中言一果者。但摄士用及离系果。岂不此言通故亦摄等流异熟。虽言亦摄非此所明。然士用果总有四种。一俱生。二无间。三隔越。四不生。此显与因非俱有果。为遮唯执与因俱生。和合聚中有士用果。此和合聚互为果故。自非自体士用果故。即显非彼俱起和合。士用果中有一果义。是故别举等流异熟。应知此中时一果一。显俱显共其义有殊。此中心王极少。犹与五十八法为俱有因。谓十大地法彼四十本相心八本随相名五十八法。五十八中除心四随相。余五十四为心俱有因。有余师说。五十八内能为心因。唯十四法。谓十大地法并心四本相。非诸心所生等相力。能为心因如心随相。若尔便违品类足论。如彼论言。或有苦谛。以有身见为因。非与有身见为因。除未来有身见及彼相应法生老住无常。诸余染污苦谛。或有苦谛。以有身见为因。亦与有身见为因。即所除法。彼作是言。我等不诵及彼相应法。应随义理简择论文。方可诵持故。异此便坏俱有因相。或应许随相。亦心俱有因。复有说言。一切同聚皆互相望为俱有因。于同聚中随阙一种。所余诸法皆不生故。此诸说中初说为善。本相与法其力等故。又此俱起和合聚中。有是能转而非随转。谓即心王有唯随转。谓色及心不相应行。有是能转。亦是随转。谓心所法随心转故。能转心不相应行故。有二俱非谓除前相。已辩俱有因相。同类因相云何。颂曰

  同类因相似　　自部地前生
  道展转九地　　唯等胜为果
  加行生亦然　　闻思所成等

论曰。能养能生。或远或近。诸等流果。名同类因。应知此因唯相似法。于相似法非于异类。如善五蕴与善五蕴展转相望为同类因。染污无记应知亦尔。有余师说。净无记蕴五是色果。四非色因。性下劣故。有余师说。五是四果。色非四因。势力劣故。有余师说。色与四蕴相望展转皆不为因。劣异类故。若就位说。有余师言。羯赖蓝位能与十位为同类因。頞部昙等九位一一皆除前位与余为因后。位望前但有缘义。若尔最初羯赖蓝色应无有因。初后老色应无有果。故理不然。复有师言。前生十位一一皆与后生十位。各自类色为同类因。由此方隅一切外分。各然自类如应当说。为诸相似。于相似法皆可得说为同类因。不尔云何自部自地。唯与自部自地为因。是故说言自部自地。部谓五部。谓见苦所断乃至修所断。地谓九地。谓欲界为一静虑无色八。此中欲界见苦所断。还与欲界见苦所断为同类因。如是乃至欲界修所断。还与欲界修所断为因。如说。欲界五部所断。静虑无色各四地中。随其所应皆如是说。此为一切。不尔前生谓唯前生。与后相似生未生法为同类因。是谓圆满同类因相。唯说前生与后生果为同类因。于义便阙。不说与未生为同类因。故唯说过去与未来现在为同类因等。于义亦阙。不说过去有因果故。何故未来无同类因。彼无前后次第义故。岂不诸法于正生时。已能蠲除一切障碍。望未生者得说为前。又异熟因。于未来世亦应非有由异熟果。望异熟因无俱前故。要依前后立同类因。非正生时。已越后位。未有作用。如余未来。过去唯前未来唯后。现通前后。约世定故。过去诸法虽皆是前。而取果时已定前后。非未来法于正生时。作用别余可立前后。要至现在已生位中。方简未来令成后位。以自作用取彼为果。若尔异熟因亦勿未来有此彼非类。所以者何。此同类因与等流果善等无别。若无先后应互为因既互为因。应互为果。互为因果。与理相违。既无理能遮互为果。则应许有果在因先。亦有二心互为因义。是则违害发智等文。彼异熟因与果相别。虽离前后而无上过。故同类因。就位建立。未来非有。若异熟因。就相建立。未来非无。言同类因唯自地者。定依何说。定依有漏。若无漏道展转相望。一一皆与九地为因。谓四静虑及三无色。未至中问。是名九地。余无等引非猛利故。皆不能发无漏圣道。无漏九地互为因者。非系地故。各别地爱不执圣道。为己有故。种类同故。地虽有别亦互为因。然非一切。何者唯与等胜为因。加行生故。初定圣道有依初定。乃至有依无所有处。二定等道应知亦尔。于依自上有。于依下地无。谓依初定。初定圣道。与依九定九地圣道为同类因。即此唯用。依初定道为同类因。不用依上圣道为因。以性劣故。依第二定。初定圣道。除依初定。与依余定九地圣道为同类因。即此唯用。依初二定九地圣道为同类因。非依上地。依第三定初定圣道。除依初二。与依余定九地圣道为同类因。即此唯用。依初二三九地圣道为同类因。非依上地。乃至若依无所有处。初定圣道唯与依此无所有处九地圣道为同类因。即此通用。依九地定九地圣道为同类因。如依九定初定圣道。余定圣道依于九地。随其所应当广思择。又一地摄诸无漏道。亦非一切。为一切因。为等胜因非劣因故。且如已生苦法智忍。还与未来苦。法智忍为同类因。是名为等。又即此忍。复能与后从苦法智至无生智为同类因。是名为胜。如是广说。乃至已生诸无生智。唯与等类为同类因。更无胜故。又诸已生见道修道及无学道。随其次第与三二一为同类因。展转为因。亦不违理。而非胜道。与劣为因前生钝根。种姓修道。与自相续。未来决定。不生利根。种姓见道。为同类因。何理为碍。一切有情各别相续。法尔安立六种种姓。无学望前。应知亦尔。然有差别。谓有前生无学圣道。于自相续后生修道为同类因。无学退已于修道中。可有转生利根义故。然不违害根蕴所说。依同品根密意说故。又依现起有用根说。如说。现起世第一法。若尔一切有情相续。法尔安立三乘菩提。亦应劣为胜乘因性。无斯过去。性极远故。劣乘不可转成胜故随信随法二行圣道。性相邻故。所依一故。设见道中有出观者。亦可转故。三乘圣道无如是事。由此故言。诸钝根道与钝及利为同类因。若利根道唯利道因。如随信行及信胜解时解脱道。随其次第与六四二为同类因。若随法行及见至非时解脱道。随其次第与三二一。为同类因。此亦准前应知不定。诸上地道为下地因。云何名为或等或胜。由因增长及由根故。为但圣道唯与等胜为同类因。不尔云何余世间法加行生者。亦与等胜为因非劣。加行生法其体云何。谓闻所成思所成等。等者等取修所成等。因闻思修所生功德。名彼所成加行生故。唯与等胜为因非劣。如欲界系。闻所成法。能与自界闻思所成为同类因。非修所成。因欲界无。故思所成法与思所成为同类因。非闻所成因以彼劣故。若色界系闻所成法。能与自界闻修所成为同类因。非思所成。因色界无。故修所成法。唯与自界修所成法为同类因。非闻所成因以彼劣故。无色界系修所成法。唯与自界修所成法为同类因。非闻思所成因以无故劣故。此闻思修所成诸法各有九品。谓下下等。若下下品为九品因。下中八因乃至上上唯上上因。除前劣故。生得善法与加行善为同类因。非加行善为生得因。以彼劣故。又生得善亦有九品。一切相望展转为因。容一一后皆现前故。定一心中得一切故。然由现行异熟九品。可施设有九品差别。染污九品准此应知。复由对治有九品故。无覆无记总有四种。谓异熟生威仪路工巧处化心俱品。随其次第能与四三二一为因。有说。一切皆互为因。同一缚故。此说非理。勿有暖等互为因。故又欲界化心有四静虑果。非上静虑果下静虑果因。非加行因得下劣果。勿设劬劳无所获故。同类因相义类寔繁。随力决择如顺正理。已辩同类因相。相应因相云何。颂曰

  相应因决定　　心心所同依

论曰。唯心心所是相应因。岂不此中无简别故。时境行相别亦相应。设简别言此三同者。异身同瞩应说相应。故说同依总遮斯难。谓要同依心心所法。方得更互为相应因。此中同言显所依一。谓若眼识用此刹那。眼根为依。相应受等亦即用此眼根为依。乃至意识及相应法。同依意根应知亦尔。今应思择眼耳等根所依性同。何缘说彼能依之识。所依各异。何劳致问。诸识所依依性虽同而类别故。若尔何故知同依言。唯就俱生刹那依义说眼识等同一所依。非就长时种类依义。说诸眼识同一所依。又无间依种类同故。应眼等识为相应因。是故颂中应如是简。谓心心所同时同依。故彼释中自摄二义。谓若眼识用此刹那眼根为依。乃至广说。颂中既阙同时之言。如何得知此同依者。非一种类是一刹那。若谓释中摄故无过。应所造颂不说同依。但说相应因。决定心心所。又相应言足遮诸难。非时依异可有相应。俱有相应二因何别。且相应因法亦俱有因。有俱有因法非相应因。谓随转色生等诸行。若相应因即俱有因。此中二因义有何别。非相应因即俱有因。由此二因义各异故。然即一法是相应因。亦俱有因。义差别者。不相离义是相应因。同一果义是俱有因。又展转力同生住等是俱有因。若展转力同缘一境是相应因。由互为果立俱有因。由五平等立相应因。其中阙一余不得有。是故极成互为因义。已辩相应因相。遍行因相云何。颂曰

  遍行谓前遍　　为同地染因

论曰。遍行因者。谓前已生遍行随眠及俱品法。与后同地自部他部诸染污法为遍行因。何等名为遍行品法。随眠品中当广分别。此因势力越同类因势力而转故别建立。亦为余部染法因故。由此势力余部烦恼及彼眷属亦生长故。于自部摄诸烦恼中。同类遍行二因何别。由有身见诸爱得生。诸爱亦能生有身见。二差别相如何可知。自部二因亦有差别。谓执我故。能令诸爱生起坚固增广炽盛。我见遍缘诸爱境故。爱令我见生起坚固。而不能令增广炽盛。不能遍缘我见境故。由诸遍惑展转相望。皆能遍缘所缘境故。一一遍惑皆互能令生起坚固增广炽盛。故此二因非无差别。一时一品能为同类遍行二因有何差别。虽同时取二等流果。而自部果增盛非余。由二因门所长养故。唯生自部二因何别。无遍行因唯生自部。谓遍行法正现前时。俱时有力取五部果。于自部果亦有差别。生起坚固由同类力。增广炽盛由遍行力。应知过现遍行随眠。为五部因能缘五部。亦是五部之所随增。彼相应法除所随增。生等复除能缘五部。彼诸法得非遍行因。或前后故。性疏远故。非一果故。有遍行随眠非遍行因等。余广决择如顺正理。已辩遍行因相。异熟因相云何。颂曰

  异熟因不善　　及善唯有漏

论曰。唯诸不善及善有漏。是异熟因。异熟法故。随其所应。此因能感异熟果故名异熟因。颂中及声显此因与果性相虽异而品类无杂。唯言为遮异熟因体摄诸因义。有说。诸果皆名异熟。彼异熟因亦应遍摄。恐如彼计故说唯言。何缘定知。唯不善法及善有漏。是异熟因。契经说故。谓契经说有黑黑异熟业。有白白异熟业有黑白黑白异熟业。有非黑非白无异熟业。能尽诸业。又契经言。现见领受悦意异熟。或复领受悲号异熟。由善不善。又说我遭身业等。损谓苦受。生受苦异熟。复言我遇身业等。益谓乐受。生受乐异熟。如斯等证其类极多。何缘无漏不招异熟。无爱润故。如贞实种无水润沃。又无漏法既非系地。如何能招系地异熟。何缘无记不招异熟。由力劣故。如朽败种。余善不善能招异熟。如有水润诸贞实种。此异熟因总说有二。一能牵引。二能圆满。且众同分及与命根。非不相应行。独所能牵引。故契经说。业为生因。生即命根。及众同分。余色心等。非定遍故。又品类足说诸命根是业异熟。非是业故。非心随转身语二业。亦不能引命众同分。经言。劣界思业所引。应知劣界即是欲有。此说欲有命众同分。唯意业感非身语业。身语表业有多极微。一心所起唯一能引。命众同分。余无此能。不应理故。若许同时共感一果。即应更互为俱有因。有对造色为俱有因。非宗所许。此非展转力所生故。亦非次第。一一极微引命同分。一心起故。非一心起。无异功能。别引生后。而无过失。非为满业。亦有斯过于一生中各别能取圆满果故。依此无表亦同此释。多远离体一心起故。不许互为俱有因故。经说。杀生若修若习若多修习生。那落迦。论说。破僧妄语恶业感无间狱一劫寿者。此举所起显能起思。思业非色难知相故。于欲界中有时一蕴为异熟因共感一果。谓有记得及彼生等。有时二蕴为异熟因共感一果。谓善不善色及生等。有时四蕴为异熟因共感一果。谓善不善心心所法及彼生等。欲界无有随心转色。故无五蕴为异熟因共感一果。于色界中有时一蕴为异熟因共感一果。谓有记得无想等至及彼生等。有时二蕴为异熟因共感一果。谓初静虑善有表业及彼生等。非于第二静虑已上有诸表业。无能起故。有时四蕴为异熟因共感一果。谓无随转色善心心所法及彼生等。有时五蕴为异熟因共感一果。谓有随转色诸心心所法及彼生等。无色界中有时一蕴为异熟因共感一果。谓有记得灭尽等至及彼生等。有时四蕴为异熟因共感一果。谓一切善心心所法。如是总有九异熟因。谓三界中。如数次第。三四二种品类差别。有业唯感一处异熟。谓感法处即命根等。若感意处定感二处。谓意与法。若感触处应知亦二。谓触与法。若感色处定感三处。谓色触法。若感香味应知亦三。谓自触法。若感身处定感四处。谓身色触法。若感眼处定感五处。谓眼身色触法。感耳鼻舌应知亦五。谓自为一身色触法。有业能感六七八九十十一处。声非异熟故此不论。业或少果或多果。故如外种果或少或多。有一念业多念异熟。无多念业一念异熟。勿设劬劳果减因故。有一世业三世异熟。无二世业一世异熟。招感异熟势力法尔。善恶为因感无记故。然异熟果无与业俱。非造业时即受果故。又业现在果非即熟法。受业门理必决定故。亦非无间。由次刹那等。无间缘力所引故。刹那正起力难制故。又异熟因感异类果。必待相续方能办故。所余决择如顺正理。如是已辨六因相别。此说三世定义云何。颂曰

  遍行与同类　　二世三世三

论曰。遍行同类唯居过现未来世无。理如前说。相应俱有异熟三因。于三世中皆悉遍有。颂既不说能作因所居义。准应知通三世非世。不可说彼定时分故。已辨六因相别世定。必应对果建立因名。何等名为因所对果。颂曰

  果有为离系　　无为无因果

论曰。果略有五。后当广辩。今且总标。有为离系。故本论说。果法云何。谓诸有为及与择灭。岂不择灭许是果故。必应有因。非无有因可说为果。曾未见故。我亦许道为证得因。经说。此为沙门果故。此六因内从何因得我说此果非从六因。前说六因生所赖故。若尔应许此证得因。离前六因别为第七。我宗所许如汝所言。岂不所宗有如是诵。涅槃是果而无有因。虽有此诵于义无失。谓诸世间于设功用所欣事办共立果名。死于士夫极为衰恼。故于不死事最所欣。如是所欣由道功用所证得故。说名为果。言无因者。道于所得择灭无为非六因故。择灭于道非所生果。是所证果道于择灭非能生因是能证因。故道与灭更互相对。因果是非不可定执。若道于灭为证得因。是则但应得为道果。谁言道果定非灭得。道于灭得为同类因。或亦说为俱有因故。然此非圣正所求果。圣不求有为而修圣道。故道于灭得为能生因。道于灭体为能证因。既许无为是能作因。应许无为有增上果。以不障故立能作因。非能生故无增上果。由如是理如有为法建立因果。无为不然。是故择灭。是因无果。是果无因。余二无为是因非果。无因无果理极成立。于当所辩异熟等流。离系士用及增上果。如是五果对前六因。当言何果何因所得。颂曰

  后因果异熟　　前因增上果
  同类遍等流　　俱相应士用

论曰。于五果中第三离系。非生因得。故此不论且辩六因得余四果。言后因者。谓异熟因。于因颂中最后说故。初异熟果此因所得。有言。异熟从异熟生。故此不应名无异熟。彼言非理。同类异熟二因所生义各别故。谓前异熟为同类因。生后异熟为等流果。即后异熟由先业成。能成诸业名异熟因。所成异熟即异熟果。二因体异。二果义分。因果类殊无相杂过。然异熟体如熟饮食。于生异熟无胜功能。故唯不善及善有漏。是异熟因名有异熟。言前因者。谓能作因。于因颂中最初说故。后增上果此因所得。增上之果名增上果。唯无障住有何增上。即无障住说为增上。又于诸法生灭位中。亦有展转增上势力同类遍行得等流果。果似因故名为等流。如是二因果相相似故因虽二其果唯一。俱有相应得士用果。非越士体有别士用。即此所得名士用果。此士用名为目何法。即目诸法所有功能。如是冥符后颂文说。若因彼力生是果名士用。此中士用士力士能。士之势分义皆无别。诸法功能如士用故。名为士用。如勇健人。似师子故名为师子。俱士用果。定有又胜。故说相应。俱有因得。无间隔越。或有或无。设有非胜。又滥余果。是故不言余因所得

说一切有部显宗论卷第九阿毗达磨藏显宗论卷第十

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩差别品第三之六

已辩因果相对决定。今当正辩果相差别。异熟等果其相云何。颂曰

  异熟无记法　　有情有记生
  等流似自因　　离系由慧尽
  若因彼力生　　是果名士用
  除前有为法　　有为增上果

论曰。唯于无覆无记法中有异熟果。若尔则应非有情数亦是异熟。为欲简彼说有情言。唯于有情有异熟故。若尔于彼有情数中。长养等流应是异熟。又为简彼说有记生。一切不善及善有漏。能记异熟。故名有记。从彼后时异熟方起。非俱无间名有记生。如是名为异熟果相。岂不异熟。亦以前位异熟果体为同类因。是前异熟等流果故。则应亦说从无记生。是等流性如何乃说。从有记生非等流性。无如是失。异熟果体由同类因相有杂乱。由异熟因相无杂乱。是故但说从有记生。由此准知非等流性。以等流果与因相似有杂乱故。若异熟果与因相别无杂乱故。何故非情非异熟果。共业所得共受用故。大梵住处诸大梵共感。余可于中有受用理故。多有情业如何共感一非情果。自类因一业缘有多。亦无有过。又见少业能生多果。如何少果非多业生。能作因业。果少果多俱无所妨。异熟因力即不如是。果非共故。共果数招。非顺熟义是故异熟不摄非情。似自因法名等流果。谓似同类遍行二因。如同类因。善染无记等流果性。其相亦尔。如遍行因。唯是染污等流果性。其相亦尔。岂不俱起士用果性。亦似自因。如何可言。似自因法名等流果。无等流果不似自因。有士用果与自因异。故似自因名等流果。定无滥彼士用果失。岂不亦有等流异因。如遍行因望异部果。染性同故名似自因。士用果性有与因别。又以因者。谓果与因具二相似。一体二性。体谓受等。性谓善等。若于俱起士用果中。其性虽同而体必异。无二受等俱时生故。若于后起士用果中。性之与体皆容有异。故不可说果定似因。其等流果性必似因。于其体中亦容有似。故唯此果说似自因。然此二因互有宽狭。故别建立果望自因。俱必相似故合立一。由慧尽法名离系果。灭故名尽。择故名慧。即说择灭名离系果。由择为因离诸系缚。证得此灭故名为果。若法因彼势力所生。即说此法名士用果。此有四种。如前已说。言俱生者。谓同一时更互为因力所生法。言无间者。谓次后生如世第一法生苦法智忍。言隔越者。谓隔时生。如农夫等于谷麦等。言不生者。所谓涅槃。无间道力彼得生故。此既不生如何可说。彼力生故名士用果。现见于得亦说生名。如说。我财生是我得财义若无间道断诸随眠。所证择灭。名离系果及士用果。若无间道不断随眠。所证择灭。唯士用果非离系果。历诸位说如顺正理。诸有为法除在前生。是余有为之增上果。必无少果在因前生。果若前生后因无用。应未来法毕竟不生。士用增上二果何别。士用果名唯对作者。增上果名兼对受者。于上所说六种因中。何位何因取果与果。颂曰

  五取果唯现　　二与果亦然
  过现与二因　　一与唯过去

论曰。五因取果。唯于现在定非过去。彼已取故。亦非未来。无作用故。言取果者。是能引义。谓引未来令其生等。于同体类。能为种子。于异体类由同一果。于非一果。由同性类。于异性类。而由有是。自聚相续。是故一切皆名能引。如是能引名为取果。此取果用。唯现在有。非于去来。唯此可名有为作用。相应俱有异熟三因。皆说功能名为作用。果异因故。二俱时故。所言五者。简能作因。然能作因。能取果者。定唯现在。与通过现。应如同类。遍行二因。但非一切。有增上果。可取或与故此不说。如何此因唯现取果。如本论说。过去诸法为等无间能生二心。若出无想灭尽定心。由入二定心现在时取者。则应二定永不现前。等无间缘。取与俱故。无如是事。入二定心唯现在时。能取二定及出心果。然由二定是正所求必应先起。由此为障令出定心。非于入心无间即起。据与果义说过去生二心。此义于后当更分别。故能作因如同类遍行。总取未来为自增上果。然或有说。此能作因。取果与果俱通过现。理不应然。取果作用唯现有故。俱有相应与果亦尔。唯于现在。由此二因取果与果必俱时故。同类遍行二因与果通于过现。能作因中诸有果者。应同此说。然非一切皆容有果。故此不论。同遍二因。有等流果。无间生者。即现在时。于无间果亦取亦与。此果已生二因已灭。名已取与。若此二因灭至过去。其等流果方至生时。则此二因。于生位果。先取今与。言与果者。谓此诸因正与彼力令其生等。其能作因正居现在。彼增上果有现已生。如眼根等生眼识等。有无间生。如世第一法等生苦法智忍等。有隔越生。如顺解脱分善根等生三乘菩提尽智等。有缘无缘善不善等。诸同类因。取果与果。时有同异。有四句等。如顺正理广说应知。异熟与果唯于过去。由异熟果。无与因俱。或无间故。西方诸师说五果外别有四果。一加行果。二安立果。三和合果。四修习果。此皆士用增上果摄。由是故说果唯有五。辩因果已复应思择。此中何法几因所生。应知此中法略有四。谓染污法异熟生法。初无漏法。三所余法。余法者何。谓除异熟余无记法。除初无漏诸余善法如是四法。颂曰

  染污异熟生　　余初圣如次
  除异熟遍二　　及同类余生
  此谓心心所　　余及除相应

论曰。诸染污法除异熟因余五因生。由异熟因所生诸法非染污。故异熟生法除遍行因余五因。生由遍行因所生诸法唯染污故。三所余法双除异熟遍行二因。余四因生由所余法非异熟性故。及非染污故。初无漏法及除同类。及言为显。亦除异熟遍行二因。余三因生。由初无漏无有前生同类法故。及是善故。如是四法。为说何等。应知唯说心及心所。若尔所余不相应行及色四法。复几因生。如心心所。除因外及除相应。应知余法。从四三二。余因所生。谓染污色。不相应行。如心心所除异熟因及除相应。余四因生异熟生色不相应行。如心心所除遍行因及除相应。余四因生三所余色不相应行。如心心所双除异熟遍行二因及除相应。余三因生初无漏色不相应行。如心心所除前三因及除相应。余二因生一因生法决定无有。今应思择一切法中。何法能为几因自性。谓或有法具足能为六因自性。次第乃至有法能为一因自性。此中有法具足能为六因性者。谓诸过现不善遍行心心所法。有法能为五因性者。谓诸过现不善非遍心心所法。或无记遍心心所法。或善有漏心心所法。或不善遍不相应行。有法能为四因性者。谓诸过现不善色法。或善有漏色心不相应行。或不善非遍心不相应行。或无记遍。不相应行。或无记非遍心心所法。或诸无漏心心所法。或诸未来不善善有漏心心所法。有法能为三因性者。谓诸过现无记色法。或无记非遍心不相应行。或无漏色不相应行。或未来不善及善有漏色心不相应行。或无记无漏心心所法。有法能为二因性者。谓诸未来无记无漏色心不相应行。有法能为一因性者。谓无为法无法非因有法非果。所谓虚空及非择灭。复应思择。如是六因自性相望有纯有杂且能作因。对俱有因为顺后句。谓俱有因必杂能作。有纯能作。非俱有因。谓无为法。又能作因对同类因亦顺后句。谓同类因必杂能作。有纯能作。非同类因。谓未来法及无为法。又能作因对相应因亦顺后句。谓相应因必杂能作。有纯能作。非相应因。谓诸色法不相应行及无为法。又能作因对遍行因亦顺后句。谓遍行因。必杂能作。有纯能作。非遍行因谓未来法。过去现在非遍行法及无为法。又能作因对异熟因亦顺后句。谓异熟因必杂能作有纯能作非异熟因。谓无记法及无漏法。若俱有因对同类因为顺后句。谓同类因必杂俱有。有纯俱有非同类因。谓未来法。又俱有因对相应因亦顺后句。谓相应因必杂俱有有纯俱有非相应因。谓诸色法不相应行。又俱有因对遍行因亦顺后句。谓遍行因必杂俱有。有纯俱有非遍行因。谓未来法过去现在非遍行法。又俱有因对异熟因亦顺后句。谓异熟因必杂俱有。有纯俱有非异熟因。谓诸有为中无记无漏法。若同类因对相应因应作四句。第一句者。谓过去现在色不相应行第二句者。谓未来世心心所法。第三句者。谓过现世心心所法。第四句者。谓未来色不相应行及无为法。又同类因对遍行因为顺后句。谓遍行因必杂同类。有纯同类非遍行因。谓过现世非遍行法。又同类因对异熟因应作四句。第一句者。谓过去现在无记无漏法。第二句者。谓未来不善及善有漏法。第三句者。谓过现不善及善有漏法。第四句者。谓未来世无记无漏及无为法。若相应因对遍行因应作四句。第一句者。谓未来世心心所法。过现非遍心心所法。第二句者。谓过去现在遍不相应行。第三句者。谓过去现在遍心心所法。第四句者。谓诸色法未来一切不相应行。过现非遍不相应行。及无为法。又相应因对异熟因亦作四句。第一句者。谓无记无漏诸心心所法。第二句者。谓不善善有漏色不相应行。第三句者谓不善善有漏诸心心所法。第四句者。谓无记无漏色不相应行及无为法。若遍行因对异熟因应作四句。第一句者。谓过去现在无记遍行法。第二句者。谓未来不善及善有漏法。过现善有漏不善非遍法。第三句者。谓过去现在不善遍行法。第四句者。谓未来世无记无漏法。过现无漏无记非遍法及无为法。又应思择如是六因。色非色等诸门差别。谓六因中相应遍行。二因非色。余之四因通色非色。有见无见有对无对。应知亦尔。又六因中唯相应因但相应法。余通相应不相应法。有所依无所依。有发悟无发悟。有行相无行相。有所缘无所缘。应知亦尔。又六因中遍行异熟二因唯有漏。余之四因通有漏无漏。又六因中能作一因通有为无为。余之五因一向是有为。又六因中遍行一因唯是染余之五因通染及不染。有罪无罪黑白有覆无覆顺退不顺退。应知亦尔。又六因中异熟一因唯有异熟。余之五因通有异熟及无异熟。又六因中能作一因通三世非世。俱有相应异熟三因皆通三世。同类遍行二因唯通过去现在。又六因中遍行一因不善无记。异熟一因通善不善。余之四因皆通三性。又六因中遍行异熟通三界系。余之四因通三界系及通不系。又六因中遍行异熟二因。唯是非学非无学。余之四因皆通三种。又六因中遍行一因唯见所断。异熟一因通见修所断。余之四因通见修所断及非所断。又六因中能作一因通四谛摄及非谛摄。遍行异熟二因唯通苦集谛摄。余之三因通苦集道三谛所摄。又六因中相应遍行唯四蕴摄。俱有同类异熟三因通五蕴摄。能作一因通五蕴摄及非蕴摄。又六因中相应遍行意法处摄。异熟一因色声意法四处所摄。余之三因十二处摄。又六因中遍行一因意法意识三界所摄相应一因通七心界法界所摄。异熟一因通色声界及七心界法界所摄。余之三因十八界摄。此等因果诸差别相。非一切智无能遍知。已随我等觉慧所行。因果义中略辩其相。为重明了思择诸缘。何谓诸缘。颂曰

  说有四种缘　　因缘五因性
  等无间非后　　心心所已生
  所缘一切法　　增上即能作

论曰。于何处说。谓契经中如契经中说四缘性。谓因缘性。等无间缘性。所缘缘性。增上缘性。此中缘性即是四缘。如四所居即所居性为显种类故说性言。意辩诸缘随事差别。有无量体。然括其义无非摄入四种类中。谓一切缘无过此性。于六因内除能作因。所余五因是因缘性。如本论说。何谓因缘。谓一切有为法。论既不说亦摄无为。故立五因为因缘性。无为何故不立因缘。此如前释。唯无障住立能作因。非余因摄。虽诸法性本有非无。而作用成必待因力。如诸造色体本非无。而功用成必因大种。因中胜者。其唯五因。如造色因胜者无五。非后已生心心所法。一切总说等无间缘谓除阿罗汉最后心心所。诸余已生心心所法。无不皆是等无间缘。为简未来及无为法。说已生言。为简诸色不相应行说心心所。何故等无间缘唯心心所。此与等无间缘义相应故。此缘生法等而无间。依此义立等无间名。谓一相续必无同类二法俱生。故说名等。此缘对果无同类法中间为隔。故名无间。若说此果无间续生名无间者。出无想等心等望前应非无间。或无等法于中间起名等无间。是二中间无容得有等法生义。或前俱生心心所品。等与无间后品为缘。非唯同类名等无间。何故一身心心所法。无有同类二体俱生。等无间缘无第二故。何缘无二等无间缘。一一有情一心转故。何缘一一但一心转。心于余境正驰散时。于余境中不了知故。又心在定专一境时。余境散心必不生故。又一相续若有多心。应无有能调伏心者。又若一身多心并起。为境各别为共相应若共相应。一境一相无差别故。俱起唐捐。若境各别即应染净善恶俱生。便无解脱。复有至教证一有情。唯有一心相续而转。谓契经说。受乐受时。彼于尔时二受俱灭。又契经说。心为独行。云何定知心心所法生时必藉等无间缘。由契经说。及彼能生作意正起现见觉慧定。由觉慧为先故生。若异此者。何理能遮。本无有情今时欻起。诸阿罗汉最后心心所。何缘故说非等无间缘。由彼不能牵后果故。此复何故无牵果。能以于尔时余缘阙故。许余缘阙故后识不生有牵后果能。斯有何咎。若能牵后应如前位。心心所法亦能与果。若缘阙故与果义无。应由阙缘不能牵果。或正灭时心心所法能牵能与在正生位等无间法处名等无间缘。诸阿罗汉最后心等。于正灭位。无有正生等无间法。故不可说等无间缘。若尔无想及二定前。心心所法于正灭位正生位中无心心所。应不可说等无间缘。彼定当生故亦名等无间。不相应隔不得即生。既定当生说生无咎。同类因等取果无定。是故不应以彼例此。何故未来心心所法。全不许立等无间缘。等无间缘前后所显。未来未有前后决定。若彼已有前后决定。修正加行则为唐捐。异熟因果虽前后定。而就相立不据前后。故通未来不可为例。若未来世无定前后。如何世尊记当时分。诸佛德用不可思议。因果曾当皆能现见。有说。现在有情身中。各有未来因果先相。佛因观此便知未来。证见分明非占相智佛。于此等尔焰稠林。理有所因方能证见。非一切智便无所因。于色等境能有作用。何缘诸色不相应行。俱不建立等无间缘。以一身中同类并起。或多或少非等无间。若尔命根无二俱起。何不许托等无间缘。宿业力生非前命引。虽心心所有先业生。而托境根不可为例又不决定是异熟生。然毗婆沙说心心所依缘行相皆有拘碍。由斯故立等无间缘。色不相应无如是事。非唯开避建立此缘。亦据牵生立此缘体。故极微等虽前避后后方得生。而非此缘。心等相生有定不定。故知亦据有力牵生。此定不定如顺正理。诸心心所自因力生。前无间灭有何作用。谓诸根境虽现和合。而无识等同类并生。故知前心无间灭位。有力牵后心等令生。色不相应无如是事。如说。云何心等无间法。谓心无间。余心心所法。已生正生及无想定。乃至广说。此已生言摄过现世。正生言摄未来生时。若尔便应第二念等。定及出定心。非心等无间。入心无间彼未生故。彼后正生时名心等无间。中间不隔等无间缘。故后望前亦名无间。又必当起亦名生时。果被取已必当生故。若尔违害见蕴论文。如彼问言。若法与彼法为等无间。或时此法与彼非等无间耶。彼即答言。若时此法未至已生。有何违害。等无间定要至已生。然于此中有二种释。并无违害。若时此法未已生者。此法是何为前为后。如世第一法生苦法智忍为世第一法。未至已生时非与苦法智忍为等无间。若至已生位。为等无间耶。为苦法智忍。未至已生时非与世第一法为等无间。若至已生位为等无间耶。若执前者。有心位可尔。无心位如何。谓无心定。入心已生。不可即与第二念等。定及出心。为等无间。若入定心至已生位。即与彼诸法为等无间者。等无间缘果法被取。必无有物能碍其生。则彼一切皆应顿起。若入心后出心即生。是则二定永应不起。若执后者。苦法智忍未已生时。应不与彼世第一法为等无间。然必应许苦法智忍在正生时。即名与彼世第一法为等无间。此中一类许可前执。然见蕴文约有心位。说等无间故无前失。或言设约无心位辩此失亦无。谓入定心居现在位。顿取诸定及出心果。亦与最初刹那定果。灭入过去。随后诸定。及出定心。一一生时与果非取先已取故。岂不一切等无间缘。无有异时。取果与果。此责非理。取果必顿。与果有渐。故无有失。但应责言。同一心果。何缘诸定及出定心。前后而生不俱时起。正所求者理必前生。谓入定心顺求于定。故心无间定必前生。若尔何缘诸刹那定前后而起。诸刹那定俱生无用。故不俱生。由前加行势力所引。故多念定长时续生。非多刹那定俱起用。一刹那定所不能为。故不顿生。犹如识等。然诸念定是等无间。不可说为等无间缘。若法由前心等引起。同一种类必不俱生。生已复能引后令起。可名等无间及等无间缘。诸定虽由前心等引。同一种类必不俱生。然其生已不能引后。可名等无间。非等无间缘。是故设约无心位辩。亦无有失。诸作是说。入二定心灭入过去。方能渐取第二念等定及出心。彼入定心应非过去。夫取果者是牵果能。诸牵果能是行作用。依行作用立三世别。若有作用非现在者。岂不便坏世别所依。诸有释言。过去眼等。于色等境。无有见闻嗅尝觉等。各别作用故非现在。彼释不然。应共审决眼等作用。为是于境见等功能为牵果用。若是于境见等功能。便于闇中现在眼等。未生已灭眼等何殊。而不说为未来过去。闇中眼等。虽无见闻嗅尝等用。而皆现有。牵果功能。可名作用。约有此用皆名现在。所余取境与果等用。皆非作用但是功能。如是功能三时容有。辩三世处当具思择。又过去世诸心心所。于所缘等不能为碍。故不能作此缘取果。复有一类许可后执。岂不苦法智忍在正生时。即与世第一法为等无间。理实应尔。然此中说等无间缘。要至已生此缘方立。故无有过。如是二释未已生言。于我义宗并无违害。所缘缘性即一切法。离心心所所缘境外。决定更无余法可得。以一切法是心心所生所攀附故曰所缘。即此所缘是心心所。发生缘故名所缘缘。一切法者即十二处。谓眼耳鼻舌身意识及相应法。随其次第以诸色声香味触法为所缘境。六根唯是意识所缘。何缘故知。经言多法生意识故。又眼等根皆非五识境所摄故。所识所知遍诸法故。五识所缘唯实非假。意识所缘通于假实。诸心心所缘有非无。破斥余宗如顺正理。然心心所所缘境定。谓眼识等于所缘色。乃至意识等于所缘诸法。此心心所于所缘定。为处为类为约刹那。有说。约处。谓眼识等唯缘色处。余随所应各说自境。勿于一境。多心心所。住不生法。故余非定。且眼识等于诸色中。随遇何色即缘之起。若尔如何青黄等觉体不杂乱。有避此失说约处类。非约刹那。若尔如何青黄等觉体不杂乱。如是应说处类刹那三皆决定。岂不一境。多心心所。住不生法。此无有失。未来世宽岂不容受。又心心所于自所缘。前所觉知后能随忆。且五识等境。意识等随忆。五识等不能随忆。前觉境一念缘故。无分别故。意有二种。谓染不染。随一觉知。二能随忆。复有三种。善染无记。随一觉知。三能随忆复有四种。谓善不善有覆无记。无覆无记。随一觉知。四能随忆复有五种。谓见苦所断乃至修所断。见苦见集及修所断。随一觉知。五能随忆。见灭见道。所断觉知。四能随忆。各除他一。广说乃至。有十二种。谓欲界四上界各三及学无学。欲善觉知十二随忆。不善色善觉知亦尔。欲覆无覆无记觉知八能随忆。除色有覆及无色三。色覆觉知。十能随忆。除欲有覆无覆无记。无色界善觉知亦尔。色界无覆无记觉知。十能随忆。除无色界有覆无覆。无色有覆无覆觉知九能随忆。除欲有覆欲色无覆。有学觉知十一随忆。除欲有覆无学觉知退法如学。若不退法七能随忆。除学及除三界四染二十心等诸门差别。觉知随忆如理应思增上缘性即能作因。以能作因。因义细故。无边际故。摄一切法。若此于彼不碍令生。是能作因。增上缘义。对三缘义。此类最多。所作寔繁。故名增上。岂不增上摄法普周。宁复对三。言此增上。非对三体。立增上名。何者对三义用而立。诸缘义用互不相通。诸缘体性更互相杂。如增上缘义类无量。所作繁广。余三不然。故此独摽增上缘称。为摄五因。及三缘性。所不摄义。立能作因。及增上缘。由此二种义类最广。故立通名。譬如行蕴。法界法处。法宝法归。法念住等。有余师说。此增上缘体类最多故名增上。所缘缘性虽遍诸法而作所缘。不通俱有。由位狭故废增上名。有余复说。所生广故名增上缘。谓一切法。唯除自体。遍能生起。一切有为。如一刹那眼识生位。除其自性用一切法为增上缘。余生亦尔。此缘体用其量无边。如契经中。说世自法三增上者。止恶行善。所观因故。立增上名。谓境现前烦恼将起。随观彼一恶止善行。于止行中得增上故。契经且说。增上有三。非余于余无增上义

说一切有部显宗论卷第十阿毗达磨藏显宗论卷第十一

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩差别品第三之七

缘与因义差别云何。有说。因缘遍不遍异。初四二缘摄六因故。二三二缘非因摄故。六因四缘体。虽无别而义有异。且等无间及所缘缘。既非因摄。故知余二义亦有殊。缘义等故。与因皆别故。有总辩因缘异。言因谓能生。缘能长养。犹如生养二母差别。又缘摄助因方能生。生已相续。缘力长养故。或有说。因唯有一缘乃众多。犹如种子粪土等异。又因不共。共者是缘。如眼如色。又作自事名因。若作他事名缘。如种粪等。又能引起名因。能任持者名缘。如花如带。又近名因。远者名缘。如珠如日。又因能生。缘者能办。如酪出生酥人钻器能办。又正有义名因。能助显发名缘。如字界字缘。于义有差别。如斯等类差别众多。是故因缘别立名想。此总意显因亲缘疏。故因缘中亲疏数广。已随理教略辩诸缘。如是诸缘显法生灭以为作用。应说何缘于何位法而兴作用。颂曰

  二因于正灭　　三因于正生
  余二缘相违　　而兴于作用

论曰。前说五因为因缘性。二因作用于正灭时。正灭时言显法现在。灭现前故名正灭时。俱有相应二因。于法灭现前位而作功能。此位二因作功能者。谓俱生品。随阙一时作用。皆无不能取境于现在位。如是二因虽俱一时取果与果。而今但约与果功能。所言三因于正生者。谓未来法于正生位生现前故。名正生时。同类遍行异熟三种法。正生位而作功能。故有说言。等流异熟二果因力牵引令生同类遍行。容有无间等流果起可言彼果于正生时因兴作用。异熟因果必隔远时。其因久灭果方正起。如何作用在果生时。非过去时可有作用。此言作用意显功能。二相别中已曾思择。其因虽灭经无量时。而有功能令自果起。由不共故。自果生时作用虽无。而于自果与功能上立作用名。唯取果功能乃名真作用余名作用皆是假说。已说因缘二时作用。二缘作用与此相违。等无间缘于法生位而兴作用。以彼生时前心心所引开避故。若所缘缘能缘灭位而兴作用。以心心所要现在时方取境故。其增上缘法生灭位皆无障住。故彼作用一切无遮。今应思择。俱有相应及所缘缘。若法生已方兴作用。何须立此二因一缘。若执因缘要有作用。方许立为因缘性者。则未来世应无因缘。然宗所许不应为难。若尔云何说有作用。若离如是二因一缘。正灭位中所引诸法。应无作用取境功能。若作用无亦名缘者。诸阿罗汉最后心等。亦应可立等无间缘。此责非理。前已辩故。说所缘缘非要由有作用方立。何相关涉。而将例彼等无间缘。彼缘要由开避牵引。故唯现在正可安立。于未来世定无彼缘。于现在时曾有作用。故虽过去亦可安立。其所缘缘非唯现在。但有体性皆可成缘。不必要由作用而立。唯于少分少分成缘。得作用名非于一切。云何知有体方得成缘。所缘体若无觉不生故。若所缘缘要有作用后法无为。应有前果。或此作用非据亲生诸果而立。但据诸法起用所凭说为作用。故后无为无前果失。应言何法由几缘生。颂曰

  心心所由四　　二定但由三
  余由二缘生　　非天次第故

论曰。此中由言为显故义。谓心心所。四缘故生。其所缘缘。除生心等无别有用。谓六识身及相应法。随其所应以色等五及一切法为所缘缘。心等因缘具五因性。前生自类开避引发。是谓心等。等无间缘此增上缘。即一切法。各除自性随其所应。岂不一缘二因作用。非于彼法生时即有。如何心等四缘故生。如何因缘具五因性。虽法灭位作用方成。而法生时非无功力。离此彼法必不生故。以心心所必仗所缘及托二因方得生故。若法与彼法为所缘。或因无暂时非本论说故。二无心定三缘故生。除所缘缘。非能缘故。此因缘者但有二因。一俱有因。谓二定上生等诸相。二同类因谓前已生自地善法。等无间缘。谓入定心及相应法。增上缘者。谓如前说。岂不无想亦三缘生。是心心所等无间故。亦应说为心等无间。但非心等加行引生故。于此中废而不说。或此无想但声所显。非如二定相对立故。二定何缘。是心等无间而不说。是心等无间缘。由心等力所引生故。如心心所生必系属前心灭故。非如色法可与余心俱时转故。非如得等可有杂乱俱现前故。非如生等。是余伴故。然心方便加行引生故。可说为心等无间与心等起。定相违害故。非心等等无间缘。又为此缘理相违故。谓修行者厌恶现行心心所法入无心定。若无心定复为此缘引心心所。则修行者应于此定无乐起心。为离现行心心所法入无心定。此复引生心心所法。不应正理。故非心等等无间缘。二定刹那前望于后。何缘不立等无间缘。诸念皆由心等引故。非由前念引后令起。若前能引后最后应无果。亦不可说此引出心。已说违心非心缘故。又出定心入心果故。入心无间出心未生。如何说彼为等无间。无等无间缘于中为隔故无间等无间二义有差别前心等力引后法生。后法名为前等无间。刹那无隔立无间名。是故二言其义各别故作是说。若法与心为等无间。彼法亦是心无间耶。应作四句。第一句者。谓无心定出心心所。及第二等诸定刹那。第二句者。谓初所起诸定刹那。及有心位诸心心所生住异灭。第三句者。谓初所起诸定刹那。及有心位心心所法。第四句者。谓第二等诸定刹那。及无心定出心心所生住异灭。若法与心为等无间。与无心定为无间耶。应作四句。谓前第三第四句为今第一第二句。即前第一第二句为今第三第四句。余不相应及诸色法。皆因增上二缘所生。复云何知世间诸法。唯如上说因缘所生。非自在天我胜性等一因所起。由次第故。谓诸世间若自在等一因生者。则应一切俱时而生非次第起。因现有故。何法为障令不俱生。现见诸法次第而起。故知非但一因所生。若执世间随自在欲前后差别故非顿起。是则应许非一因生。亦许欲为法生因故。此欲前后生灭差别理亦不成。因无异故。非因无异果有差别。要待异因果方别故。或差别故。应许顿生。所因前后无差别故。是则诸法亦应顿生。谁能为障令不顿起。若自在欲更待余因。前后次第差别生者。应所因法复待余因。则所待因应无边际。因无边故无始义成。不越释门因缘正理。徒异名说自在为因。又无用故。不应妄执世间诸法自在为因。非自在天作大功力。生世间法少有所用。故不应谓自在为因。若为发生自欢喜者。但应发喜何用生余。若喜离余方便不发。是则彼喜余方便生。自在于斯应非自在。于喜既尔余亦应然。差别因缘不可得故。或余方便应余方便生。何用计从自在天所起。若余方便离余方便生喜。亦应非余方便所起。或生苦具逼害有情。为发自喜。咄哉何用事斯暴恶自在天为。又信世间唯从自在一因所起。则拨世间现见罪福诸士用果。若言自在待余罪福助发功能方成因者。但是朋敬自在天言。离所余因缘不见别用故。时地水等种种因缘。于芽等生现有功力。芽等随彼成有无故。于芽等生除彼功力不见别用。故不应计世间法起自在为因。自在既然。我胜性等亦应准此如应思择。故无有法唯一因生。但从如前所说种种因缘所起。其理极成。既言色法因及增上二缘所生。大种所造总名为色。于中云何大种所造。自他相望互为因缘。颂曰

  大为大二因　　为所造五种
  造为造三种　　为大唯一因

论曰。初言大为大二因者。是诸大种更互相望。但为俱有同类因义。俱起前生为因别故。谓随阙一余不生故。更互相望有俱有因。性类虽别而同一事。更相顺故。有同类因。大于所造能为五因。何等为五。谓生依立持养别故。虽同时生而随转故。如互起影灯焰发明。大于所造得成因义。如是五因但是能作因之差别。大望所造为余五因。理不成故。非一果故。非俱有因非相应因。不相应故。非染污故。非遍行因非异熟因。无记性故。非同类故。非同类因。问答决择如顺正理。又本论中亦有文证。大望造色无五种因。如说。有色处非无记为因。亦非无记谓善色处。若尔应与经论相违。如契经言。因四大种施设色蕴。本论亦言。四大所造因增上等。俱不相违。据生因等五因说故。大与所造为生因者。从彼起故。如母生子为依因者。随彼转故。如臣依王为立因者。能任持故。如地持物为持因者。由彼力持令不断故。如食持命为养因者。能增长故。譬如树根水所润沃。如是则显大与所造为起变持住长因性。或生因者。一切大种生所造色。非离诸大种有造色生故。造色生已。同类相续不断位中。火为依因。能令干燥不烂坏故。水为立因。能为浸润令不散故。地为持因。能任持彼令不坠故。风为养因。能引发彼令增长故。如是大种虽与所造无俱有等五种因义。而有生等五种别因。故与经论无相违失。诸所造色自互相望。但有三因。所谓俱有同类异熟。据所造类容有三因非一切。有俱有因者。谓随心转。身语二业七支相望展转为因。同类因者。一切前生于后同类。异熟因者。谓诸不善及善有漏身语二业。能招异熟眼等色等。所造于大但为一因。谓异熟因。身语二业能招异熟四大种。故已辩诸法尔所缘生。当随宗委辩等无间缘义。前虽总说诸心心所已生。除最后为等无间缘。未决定说何心无间有几心生。复从几心有何心起。今当定说心有多种。如何依彼可定说耶。且略说心有十二种。云何十二。颂曰

  欲界有四心　　善恶覆无覆
  色无色除恶　　无漏有二心

论曰。且于欲界有四种心。谓善不善有覆无记无覆无记。色无色界各有三心。谓除不善余如上说。如是十种说有漏心。若无漏心唯有二种。谓学无学合成十二。此十二心互相生者。颂曰

  欲界善生九　　此复从八生
  染从十生四　　余从五生七
  色善生十一　　此复从九生
  有覆从八生　　此复生于六
  无覆从三生　　此复能生六
  无色善生九　　此复从六生
  有复生从七　　无覆如色辩
  学从四生五　　余从五生四

论曰。欲界善心无间生九。谓自界四色界二心。于入定时及续生位。如其次第生善染心。生何善心。复何地摄。此于初位生加行心。若于后时生离欲得。随顺住故无容起彼。生得善心生在此间。不能令彼起现前故。有说。彼心未至地摄。有言。亦摄在初静虑。有说。亦在静虑中间。尊者瞿沙作如是说。乃至亦在第二静虑。如超定时隔地而起。有作是说。非等引心。无力能牵隔地心起。是故彼说理定不然。及无色一于续生位欲善无间生彼染心。并学无学随顺住故。欲善无间必定不生。色无色缠无覆无记。彼皆系属自界心故。亦定不生无色界善。以彼于此四远远故。一所依远。二行相远。三所缘远。四对治远。即此复从八无间起。谓自界四色界二心。于出定时从彼善起。被初静虑染定恼时。从彼染心生于欲善。求依下善为防退故。及学无学谓出观时。染谓不善有覆无记。二各从十无间而生。谓自界四色无色六。于续生位上界六心。皆可命终生欲二染。必无无漏生染污心。故此非从学无学起。即此无间能生四心。谓自界四余无生理。必无下地染心无间能生上地及无漏心。余谓欲缠无覆无记此心从五无间而生。谓自界四及色界善。欲界化心从彼生故。即此无间能生七心。谓自界四及色界二。善与染污。于入定时欲界化心还生彼善。于续生位欲界无覆生彼染心。并无色一。于续生位此无覆心能生彼染。如是已辩欲界四心无间从生能生决定。色界善心无间生十一。谓除无色无覆无记心异熟生心属自界故。即此复从九无间起。谓除欲界二染污心。及除无色无覆无记。有覆从八无间而生。除欲二染及学无学。即此无间能生六心。谓自界三欲善不善有覆无记。无覆从三无间而起。谓唯自界余无生理。即此无间能生六心。谓自界三欲无色染。已辩色界三心相生。无色界善无间生九。谓除欲善欲色无覆。即此从六无间而生。谓自界三及色界善。并学无学有覆无间能生七心。谓自界三及色界善欲色界染。即此亦从七无间起。谓除欲色染及学无学心无覆。如色说从三无间生。谓自界三余皆非理。即此无间能生六心。谓自界三及欲色染。已辩无色三心相生。学心从四无间而生。谓即学心及三界善。即此无间能生五心。谓前四心及无学一。非三界染。互相违故。非诸无覆。不明利故。余谓无学从五无间生。谓三界善及学无学二。即此无间能生四心。谓三界善及无学一。不生学心彼非果故。非染无覆如前说故。说十二心互相生已。云何分此为二十心。颂曰

  十二为二十　　谓三界善心
  分加行生得　　欲无覆分四
  异熟威仪路　　工巧处通果
  色界除工巧　　余数如前说

论曰。三界善心各分二种。谓加行得生得别故。欲界无覆分为四心。一异熟生。二威仪路。三工巧处。四通果心。色无覆心分为三种。除工巧处。上界都无造作种种工巧事故。无色界无行等事故。无威仪路。无摄受支三摩地故。亦无通果。依如是理欲界有八。色界有六。无色有四。学无学心合为二十。如是二十互相生者。且说欲界八种心中加行善心无间生十。谓自界七除通果心。自类静定无间生故。及色界一加行善心并学无学。即此复从八无间起。谓自界四二善二染。及色界二加行有覆。并学无学生得善心无间生九。谓自界七除通果心。及色无色有覆无记。即此复从十一心起。谓自界七除通果心。及色界二加行有覆。并学无学二染污心无间生七。谓自界七除通果心。即此复从十四心起。谓自界七除通果心。及色界四除加行善与通果心。并无色三除加行善。异熟威仪无间生八。谓自界六除加行善与通果心。及色无色有覆无记。即此复从七无间起。谓自界七除通果心。工巧处心无间生六。谓自界六除加行善与通果心。果此复从七无间起。除通果心。从通果心无间生二。谓自界一即通果心。及色界一即加行善。即此亦从二无间起。谓即前说自色二心。说欲界心互相生已。次说色界六种心中从加行善心无间生十二。谓自界六及欲界三。加行生得与通果心。并无色一加行善心学无学心。即此复从十无间起。谓自界四除威仪路与异熟生。及欲界二加行通果。并无色二加行有覆。学无学心生得善心无间生八。谓自界五除通果心。及欲界二不善有覆。并色界一有覆无记。即此复从五无间起。谓自界五除通果心。有覆无记无间生九。谓自界五除通果心。及欲界四二善二染。即此复从十一心起。谓自界五除通果心。及欲界三生得善心威仪异熟。并无色三除加行善。异熟威仪无间生七。谓自界四除加行善与通果心。及欲界二不善有覆。并无色一有覆无记。即此复从五无间起。谓自界五除通果心。从通果心无间生二。谓自界二加行通果。即此亦从二无间起。谓即前说自界二心。说色界心互相生已。次说无色四种心中加行善心无间生七。谓自界四及色界一。加行善心并学无学。即此复从六无间起。谓自界三唯除异熟。及色界一加行善心。并学无学生得善心无间生七。谓自界四及色界一有覆无记。并欲界二。不善有覆。即此复从四无间起。谓自界四。有覆无记无间生八。谓自界四。及色界二加行有覆。并欲界二不善有覆。即此复从十无间起。谓自界四及色界三。生得异熟与威仪路。并欲界三。名如色说。异熟生心无间生六。谓自界三除加行善。及色界一有覆无记。并欲界二不善有覆。即此复从四无间起。谓自界四。说无色心互相生已。次说无漏二种心中从有学心无间生六。谓通三界加行善心。及欲生得并学无学。即此复从四无间起。谓三加行及有学心。从无学心无间生五。谓前有学所生六中除有学一。即此复从五无间起。谓三加行及学无学。复有何缘加行无间。能生异熟工巧威仪。非彼无间生加行善。且异熟生由先业力所引发故。势力羸劣。非作功用所引发故。不能引起加行善心。故彼不能生加行善。出心不由功用转故。加行无间生彼无违。工巧威仪势力羸劣。乐作功用。引发工巧及威仪故。不能引起加行善。心出心不由功用转故。加行无间生彼无违。若尔染心不应无间生加行善。染着境界违背善故。势力劣故。无斯过失厌倦烦恼数数现前。作是思惟。说何方便令无义聚止息不行。便如实知起过失境能生功德。脱我当起烦恼现前。寻复觉知起善防护。由斯愿力能起加行。无始时来数习染故。势力不劣。故染无间生加行善。欲界生得行相明利。非胜功用之所引发。以明利故。可有从彼。学无学心色界加行无间而起。非胜功用所引发故。不能从此引生彼心。色无色界生得善心不明利故。非胜功用所引发故。非学无学他界加行无间而起。亦非从此引生彼心。又欲生得以明利故。可从色染无间而生。能为防护色界生得不明利故。非无色染无间而起。作意有三。谓自共相胜解作意。有差别故。云何名为自相作意。谓观诸色变碍为相。乃至观识了别为相。如是等观相应作意。云何名为共相作意。谓十六行相应作意。云何名为胜解作意。谓不净观及四无量有色解脱胜处遍处。如是等观相应作意。如是三种作意无间圣道现前圣道无间亦能具起三种作意。若作是说。便顺此言不净观俱行修念等觉分。有余师说。唯从共相作意无间圣道现前。圣道无间方能具起三种作意。若尔何故契经中言。不净观俱行修念等觉分。由不净观调伏心已。方能引生共相作意。从此无间圣道现前。依此展转密意而说。故无有过。有余复言。唯从共相作意无间圣道现前。圣道无间亦唯能起共相作意。此言有失。所以者何。依未至等三地证入正性离生。圣道无间可生欲界共相作意。以欲界中共相作意去彼圣道非极远故。若依第二第三第四静虑证入正性离生。圣道无间起何作意。非起欲界共相作意。以极远故。又于彼地无容有故。以非彼地已有曾得。共相作意异于曾得顺决择分。非诸圣者顺决择分可复现前。非得果已可重发生加行道故。彼今应说。此圣道后起何共相作意现前。岂不系属顺决择分。亦修彼类共相作意。如观诸行皆是无常。观一切法皆是无我。涅槃寂静圣道无间引彼现前。此救非理。系属加行所修作意。非得果后可引现前。是彼类故。前说圣道无间通三作意现前。于理为善。若依未至定得阿罗汉果。后出观心。或即彼地或是欲界。依无所有处得阿罗汉果。后出观心。或即彼地或是有顶。若依余地得阿罗汉果。后出观心唯自非余地。于欲界中有三作意。一闻所成。二思所成。三生所得。色界亦有三种作意。一闻所成。二修所成。三生所得。无思所成。举心思时即入定故。无色唯有二种作意。一修所成。二生所得。欲界闻思作意无间圣道现前。圣道无间具起三种作意现前。以诸圣道起必系属加行道故。非生得善作意无间圣道现前。色界闻修作意无间圣道现前。圣道无间亦唯起彼二种作意。无色唯修作意无间圣道现起。圣道无间亦唯起修不起生得。若生第二静虑已上。起初静虑三识身时。诸有未离自地染者。彼从自地善染无记。作意无间三识现前。三识无间还生自地三种作意。诸有已离自地染者。除染作意。唯善无记作意无间三识现前。三识无间亦唯起此二种作意。于前所说十二心中。何心现前。几心可得。颂曰

  三界染如次　　得七六二种
  色善二学三　　二无余自得

论曰。欲界染心正现前位。十二心内容得七心。色界染心正现前位。十二心内容得六心。无色染心正现前位。十二心内容得二心。为一刹那应言不尔。谓起欲界染污心时。或界退还。或续善本。或退胜德。于此三位随容有数。总得七心界退还时。得自界四并色界染。亦容可得。续善本位得自善心。以疑心中续善根故。退胜德位三界染心及有学心。皆容可得。若起色界染污心时。或界退还。或退胜德随容有数。总得六心界退还时。得自三种。及得欲界无覆无记。谓通果心退胜德位。色无色界二染污心。及有学心皆容可得。若起无色染污心时。顿得二心。谓学自染。此中唯有退胜德位。色界善心正现前位。十二心内容得二心。谓自善心无覆无记。由升进故。若有学心正现前位。十二心内容得三心。谓有学心及色无覆并无色善。若初证入正性离生尔时学心即名为得。若以圣道离欲界染。最后所起解脱道时得色无覆。若以圣道离色界染得无色善。此中离言非究竟离。以于色染未全离时。无色善心已可得故。二谓欲色无覆无记。此二心中都无所得。余谓前说染等心。余谓无色界无覆无记。欲无色善及无学心。不说彼心正现前位得心差别。应知彼心正现前位。唯自可得诸所言得。据此类心先无所成。今创得故

说一切有部显宗论卷第十一阿毗达磨藏显宗论卷第十二

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩缘起品第四之一

已依三界辩得心等诸法差别今应思择三界是何处别有几颂曰

  地狱傍生鬼　　人及六欲天
  名欲界二十　　由地狱洲异
  此上十六处　　名色界于中
  初二二三三　　第四静虑八
  无色界无处　　由生有四种
  依同分及命　　令心等相续

论曰。那落迦等下四趣全。及天一分眷属中有。并器世间。总名欲界。天一分者。谓六欲天。一四大王众天。二三十三天。三夜摩天。四睹史多天。五乐变化天。六他化自在天。如是欲界地狱趣等。并器世间总有十处。地狱洲异分为二十。八大地狱名地狱异。一等活地狱。二黑绳地狱。三众合地狱。四号叫地狱。五大叫地狱。六炎热地狱。七大热地狱。八无间地狱。言洲异者。谓四大洲。一南赡部洲。二东胜身洲。三西牛货洲。四北俱卢洲。如是十二并六欲天傍生饿鬼处成二十。若有情界从自在天至无间狱。若器世界乃至风轮皆欲界摄。已说欲界并处不同。此欲界上处有十六。谓初静虑处唯有二。二三各有三。第四独有八。器及有情总名色界。言初静虑处有二者。一梵众天。二梵辅天。第二静虑处有三者。一少光天。二无量光天。三极光净天。第三静虑处有三者。一少净天。二无量净天。三遍净天。第四静虑处有八者。一无云天。二福生天。三广果天。并五净居处合成八。五净居者。一无繁天。二无热天。三善现天。四善见天。五色究竟天。此十六处诸器世间并诸有情。总名色界。何缘大梵及无想天。无寿量等殊不别建立。不应别立大梵一故。要依同分立天处名。非一梵王可名同分。虽寿量等与余不同。然由一身不成同分。故与梵辅合立一天。高下虽异然地无别。无想有情与彼广果。寿身量等无差别故。亦无异因。故不可立为第四处。无色界中都无方处。以无色法去来无表。皆无方所理决定故。但异熟生胜劣差别。说有四种。一空无边处。二识无边处。三无所有处。四非想非非想处。如是四种名无色界。由生胜劣非由方所。以于是处得彼定者命终即于是处生故。复从彼殁生欲色时。即于是处中有起故。由渐离欲渐得彼定。及生劣胜次第如是。随生因力果少多故。于无色界受生有情。以何为依心等相续。何缘于此欻复生疑。以诸法中都无有我。心心所法在欲色界。依托色身可相续转。于无色界既无色身。心等应无相续转义。为显彼有依故作是说。依同分及命心等相续。及声摄余不相应行。谓得及非得异生性生等法转所赖故名为依。心等转时要托彼故。眼等四识一一皆用无间灭意及自色根为其所依。及为依性。以自色根所依大种身根及大同分命根得等生等但为依性。身识即用意及身根。为其所依及为依性。但以身根所依大种同分命根。得等生等为其依性非为所依。意识但以无间灭意为其所依。及为依性。身根及大同分命根。得等生等但为依性。如是欲色有情心等。依色同分命等相续。无色有情以无色故。但依同分及命根等心等相续。非无有依。依与所依二相别者。要由彼有此方得转。无则不转是为依相。定有彼相及随变者。是谓为依及所依相。虽彼诸法为心等依。而或有时心等不转。此由别法为障碍故。心等转位必有彼依。故彼得为心等依相。现见心等于死身内毕竟不生。于生身中虽暂时灭。而定当起。故彼色等依相极成。由此故知。色声香等于心心所不能为依。以外事中有色声等。然心心所曾不转故。心等不随无间灭意定有转变。如何可说。彼为所依。夫随变者。谓令改易。由前意灭。后心等起。何非所依。非同分等为心等依。如眼等根无间灭意。故所依相与依相别。如是欲色诸有情心。四蕴俱生灭为依性。唯一色蕴得为所依。酒等恼时心虽转变。而无意识色为所依。夫成所依定能生变。意识非定随色变生。以无色时心亦有故。可为依性非作所依。是故六识在欲色界。得以四蕴为俱生依。无色意识以无色故。彼俱生依唯通三蕴。若尔何故但言无色心等依于同分及命。此说定同无乱依故。谓心心所虽互为依而非定同。不自依故亦非无乱。在此地生。乱起自他心心所故。同分及命心等同依。又此地生唯此地故。依此设起不同地心。由此还令自地心起。唯依此二名此地生。牵引业生无间断故。由斯说是同不乱依。心等不然。故略不说。若无此二余地四蕴现在前时。尔时有情应名余地非此地摄。自地先业所牵引果不相续故。然不应许。是故当知。如欲色界身同分命为心等依。虽或有时异地心起。而依身等。于此生中后定当牵自地心起。如是无色虽无有身。心等定依同分及命。故颂偏说。同分命根此是牵引。业异熟故。是余异熟相续住因。譬如树根茎等依住。现见诸树叶枝茎等。虽同种生而依根住。是故不应谓眼根等唯依业住无别有依。由斯已释。生无色界业生心等须别依因。故本论中不作是说。心转即用受等为依。即由此因得非得等。及声总显不说别名。谓彼非唯业所生故。设业生者非恒续故。由此总说名为识缘。不说受等为识依性。如何彼法为心等依。谓彼若无自地心等必不生故。犹如身等。或由彼是无乱因故。非生上地成就下善。又无成异地异生性等。故彼为依性其理极成。有余师言。如坑堑等。虽无风等灯焰不生。彼法若无心等不起。故知心等用彼为依。或有门人作是征请。不相应行应如色身。亦能为依生意识等。故但为说不相应行为心等依。非无色界俱生四蕴无相依义然于此中心与受等为所依性。非彼受等为心所依。非所随故。要心总了境界相时。受等方能取差别相。故彼随心心非随彼。然心心所名互相随。互随转者。同一果故。何缘不说欲色界中此二为依心等相续。而但说彼依于色身。欲色界中身同分等。虽恒相续。皆能为依而身粗显。是故偏说。或为成立同分命根离身别有。故作是说。非于无色或余地中业生心等恒现前故。或显同分及命根等亦依身转。故作是说。虽彼与身互相依止。而身胜故偏说为依。岂不命根为身依性亦是殊胜。命根若无。身根等法皆不转故。虽无命根彼皆不转。而身多为灾横等缘。命等随身亦有损益。故身与彼为依义胜。即由此义对法诸师。说无色中以无身故。同分命等更互相依。如本论说云何欲界。谓有诸法欲贪随增。色无色界亦复如是。为显诸法三界现行。非皆彼系。故作是说。虽诸烦恼皆所随增。贪多现行故偏说一。言欲贪者。谓欲界贪。色无色贪亦复如是。欲所属界说名欲界。如是类释上二界名。又欲之界名为欲界。由此界能任持欲故。色无色界应知亦然。若界有色而无定者。是名欲界。若界有色亦有定者。是名色界。若界无色而有定者。是无色界。三界为一为复有多。三界无边如虚空量。故虽无有始起有情无量无边。佛兴于世一一化度无数有情。令证无余般涅槃界而不穷尽。犹若虚空世界当言云何安住当言傍住。故契经言。譬如天雨滴如车轴。无间无断从空下注。如是东方无间无断。无量世界或坏或成。如于东方南西北方亦复如是。不说上下。有说亦有上下二方。余部经中说十方故。色究竟上复有欲界。于欲界下有色究竟。如是展转世界无边。若有离一三界贪时。一切三界贪皆灭离。依初静虑起通慧时。所发神通但能往至自所生界。梵世非余。所余通慧应知亦尔。勿有于境太过失故。已说三界。趣复云何。何处几种。颂曰

  于中地狱等　　自名说五趣
  唯无覆无记　　有情非中有

论曰。于三界中随其所应说有五趣。如自名显。谓前所说地狱傍生鬼及人天。是名五趣。唯于欲界有四趣全。三界各有天趣一分。为显有界非趣所摄。故三界中说有五趣。善染无记有情无情及中有等。皆是界性。趣体唯摄无覆无记。及与有情而非中有。言趣体唯摄无覆无记者。唯异熟生为趣体故。由此已释趣。唯有情无情中无异熟生故。趣体唯摄无覆无记。如七有经定应信受。经说七有。谓地狱有。傍生有。饿鬼有。天有人有。业有中有。此中业有是五趣因。简趣异因。是故别说。此经为显趣体唯摄无覆无记。故简异因。理亦应然。若善染法是趣体者。趣应杂乱。一趣身中多趣惑业。皆可现起及成就故。业如中有俱别说故。是趣因故定非趣摄。非如见浊。有处说见是烦恼故。无处说业是趣体故。不可为例。唯异熟生是诸趣体。何缘证知。契经说故。经说。舍利子作是言。具寿。若有地狱诸漏现前故造作增长。顺地狱受业。彼身语意曲秽浊故。于那落迦中受五蕴异熟。异熟起已名那落迦。除五蕴法彼那落迦都不可得。此中既说。除异熟生色等五蕴无别地狱。异熟起已名那落迦。故知趣体唯是异熟。发地狱业名地狱漏。招地狱生名地狱业。非此漏业即地狱体论说五趣。一切随眠所随增者依。趣及趣能结生心说。故无失中有非趣何。缘故知由经论理为。定量故。且由经者。谓七有经别说五趣因方便故。言由论者。施设论说。四生摄五趣。非五摄四生。不摄者何。所谓中有法蕴论说。眼界云何。谓四大种所造净色。是眼眼根眼处眼界。地狱傍生鬼人天趣。修成中有。言由理者。趣谓所往中有不应是所往处。由此能往所往趣故。又彼即于死处生故。非所往处故非趣摄。若尔无色亦应非趣死处生故。不尔。无色死处即生不往余处。中有虽是死处即生。然往余处故非趣体。言中有者。谓中有地死生中间决定有故。生有无间容起死有。故无本有名中有过。或容彼在异类二生中间起故。名为中有。不可说在二趣中间。故名中有。对执中有是趣摄宗因不成故。于前所说诸界趣中。如其次第识住有七。其七者何。颂曰

  身异及想异　　身异同一想
  翻此身想一　　并无色下三
  故识住有七　　余非有损坏

论曰。谓若略说。欲界人天并及下三静虑无色。此七生处是识住体。若广分别应随契经。有色有情身异想异。如人一分。天是第一识住一分。天者谓欲界天及初静虑。除劫初起。言有色有情者。是成就色身义。言身异者。谓彼色身种种显形状貌异故。彼由身异或有异身。故彼有情说名身异。言想异者。谓彼苦乐不苦不乐想差别故。彼由想异或有异想。或习异想以成其性。故彼有情说名想异。有色有情身异想一如梵众天。谓劫初起。是第二识住。所以者何。以劫初起彼梵众天同生此想。我等皆是大梵化生。大梵尔时亦生此想。是诸梵众皆我化生。何缘梵众同生此想。由见梵王处所形色及神通等皆殊胜故。又观大梵先时已有己及余天后方生故。彼不能见从上地殁依初静虑发宿住通。不能了知上地境故。何缘大梵亦生此想。彼才发心众便生故。谓己所化非速殁故。或愚业果感赴理故。或见己身形状势力寿威德等过余众故。由是缘故。梵众梵王身虽有殊而生一想。言身异者。初静虑中有表无表寻伺多识。为因感身有差别故。安立众生身有异故。有色有情身一想异。如极光净天。是第三识住。此中举后兼以摄初。应知具摄第二静虑。若不尔者。彼少光天无量光天何识住摄。彼二既有第三识住相。无缘可说非识住所收。故知此中依举显理说诸识住。非但如言彼天中无有表业等。为因所感差别身形。故言身一。此显同处身相无异。非说处别。第二静虑喜舍二想杂乱现前。故言想异。由彼天众厌根本地。喜根已起。近分地舍根现前厌近分地。舍根已起。根本地喜根现前譬如有人。于诸饮食若素若腻欣厌互增。有色有情身一想一。如遍净天。是第四识住。言身一者。释义如前。唯有乐想故名想一。遍净天乐寂静微妙。常生欣乐无起厌时。是故无由近分交杂。故唯依此立想一名。初静虑中由染污想。故言想一。以于非因起戒禁取执为因故。第二静虑由二善想。故言想异。由等至力二受交参而现前故。第三静虑由无记想。故言想一。纯一寂静异熟乐受而现前故。下三无色名别如经。即三识住是名为七。释三无色如顺正理。此中何法名为识住。谓彼所系五蕴四蕴识于其中乐住着故。有余师说。唯有情数得识住名。契经说故。为显诸识所住着事。故契经说七识住名。由此余处非识住摄。以彼处识有损坏故。识于其中不乐住着。余处者何。谓诸恶处。第四静虑及有顶天。云何于中识有损坏。损坏识法于中有故。何等名为损坏识法。谓诸恶处有重苦受能损于识。第四静虑有无想定及无想事。有顶天中有灭尽定。能坏于识令相续断。复说若处余处有情心乐来止。若至此处不更求出。说名识住。于诸恶处二义俱无。第四静虑心恒求出。谓诸异生求入无想。若诸圣者乐净居等。若净居天乐证寂灭。有顶昧劣故非识住。有说。若识爱力执受安住其中。说名识住。一切恶处净居天等。业力执受安住其中。无想有情及有顶处。见力执受安住其中。由是皆非识住所摄。有余复说。众生有三。所谓乐着诸境乐想。乐着境者。人及欲天。乐着乐者。下三静虑。乐着想者。下三无色。唯于此处立识住名。余无此三。故非识住。相承说者。若处具有见修所断。及无断识立识住名。异此便非识住所摄。欲界无定就所依说。有无漏识。非想有定就自性说。无无漏识。或欲人天。一身容有具三识义。非想不尔。第四静虑虽具三识。而五处全一处少分。不具三识。故少从多不立识住。是故识住数唯有七。如是解释七识住已。因兹复辩九有情居。其九者何。颂曰

  应知兼有顶　　及无想有情
  是九有情居　　余非不乐住

论曰。前七识住及第一有无想有情是名为九。诸有情类唯于此九欣乐住故。立有情居。谓诸有情自乐安住。所依色等实物非余。以诸有情是假有故。然诸实物是假所居。故有情居唯有情法。以有情类于自依身爱住增强。非于处所。又于处所立有情居。则有情居应成杂乱。居无杂乱唯有内身。故有情居唯有情法。既言生已名有情居。知有情居不摄中有。又诸中有非久所居。故诸有情不乐安住。又必应尔。由本论说。为显生处立有情居。于生死中为显诸识。由爱住着建立识住。显诸有情于自依止爱乐安住。立有情居。故此二门建立差别。有顶无想既非识住。如何可说为有情居。此责不然。义各异故。由此二处有坏识法。识不乐居故非识住。然彼二处成有情身。有情乐居故九所摄。谓若有处余乐来居不乐迁动。有情居摄。余处皆非不乐住故。言余处者。谓诸恶处第四静虑除无想天。恶处皆非有情居者。谓非余处有乐来居。亦无住中。不乐迁动。第四静虑除无想天。所余皆非有情居者。虽从余处有乐来居。然非住中不乐迁动。谓广果等。若诸异生乐入无想。若诸圣者乐入净居或无色处。净居天处乐入涅槃。故彼皆非有情居摄。因七识住。已辩有情居余契经中。复说四识住。其四者何。颂曰

  四识住当知　　四蕴唯自地
  说独识非住　　有漏四句摄

论曰。如世尊言。识随色住。广说乃至。识随行住。此四识住其体云何。谓唯除识有漏四蕴。又此唯在自地非余。非识乐随余地蕴住。虽依余地蕴识亦现前。而余地蕴中识不乐住。喜爱润识令于蕴中增长广大。契经说故。非于余地色等蕴中喜爱能润识令增长广大。故余地蕴非识住摄。又自地中唯有情数唯自相续。立为识住。非非情数。他相续中识随乐住如自相续。有余师说。彼亦识住。以于其中喜爱润识亦令增长及广大故。已依自宗建立识住。当说建立识住因缘。此中云何识非识住。又此识住其义云何。谓识于中由喜爱力。摄为所住及为所著。是识住义。识随色住住。色着色。契经说故。若尔识蕴应成识住。世尊亦说。于识食中有喜有染。有喜染故识住其中。识所乘御理应如是。唯说四者为令于识除我见心。故于识中不说识住。如说莎底契经中言。我达世尊所说法教。驰流生死唯识非余。识谓世尊异名说我。为欲除灭彼我见心。显识依他体非是我我所依性。非谓能依。故识住门唯说有四。实非识住。但四非识。今谓世尊所说识住唯色等四。不言识者。由但色等于三时中与续有识为助伴故。谓唯色等与识俱生。过未亦能为识助伴。令续有识生死驰流。识则不尔。故非识住。且眼等根及俱色等。与俱生识为所依依。已灭未生但为识境。是故色蕴于三时中望续有识。能为助伴。现在受等与识俱生。为俱有因。一分与识同缘一境有助伴用。已灭未生俱为识境。是故受等亦于三时望续有识能为助伴。识虽过未望续有识少有助能。而俱生中全无助力。不俱起故。色等望识具二助能。识唯去来故非识住。故非情数及他身中。色等四蕴亦非识住。由彼望识但为所缘。不具二门助伴用故。住谓所住。是续有识引自果时能为依义住或所著。是续有识引自果时能为境义。自身色等可有与识同一境义。设不同境然能为依。具二助能故立识住。非有情数他身色等。则不如是。故非识住。如何定知识住道理如是安立。契经说故。如世尊言。有四依取所缘识住。识随色住。住色着色。是识与色或俱时生依于色住。或于色境缘而生着。何缘生着。前说于中喜爱润故。如是乃至识随行住。皆应广说。曾无有说识随识住。随谓亲附。或谓邻近。去来定说为疏远故。现在色等亲近于识。与识俱生名识随住。定无有识与识俱生。故不应言识随识住。由此经故。唯余四蕴与续有识为伴义成。有四依取。世尊说故。言依取者。谓色等四为生死依。烦恼所取或即为依摄取众苦。由是无漏非住理成。唯说依取为识住故。无漏色等灭依取故。即彼经说。苾刍当知。若于色界已得离贪。于所随色意生系断。此系断故。即能缘识无复住着。增长广大。广说受等。三界亦然。即由此经义准三世。色等四蕴皆识住摄。为显色等与识异故。我所承宗作如是说。若法与识可俱时生。识所乘御如人船里。此法可说识住非余。如是所言。意简识住与识类别。非为欲遮去来色等言非识住。虽许去来亦识住摄。而非情数非识住收。现在与识尚为疏远。况在去来可名识住。自身色等虽在去来与识疏远。而于现在与续有识极相亲近。由种类同亦名识住。如现在世异心无心两位自身色行二蕴。去来色等理亦应然。具二助能相不失故。由此色等自相续中三世所摄。皆名识住。七四识住皆唯有漏。为十摄四。四摄七耶。非遍相摄。可为四句。有七非四。乃至广说。第一句者。谓七中识。第二句者。谓诸恶处。第四静虑及有顶中除识余蕴。第三句者。七中四蕴。第四句者。谓除前相七中有识。四中无者。由此二门建立异故。若法与识互为因果。识乐随转立七识住。若法与识可俱时生能为助伴。立四识住。由所化生禀性差别。故说七四识住不同。或乐别缘。或乐总了。或乐遍了诸法自相。或于自相不乐遍知。或耽着爱或耽着见。或有自相烦恼力强。或有共相烦恼力强。或乐境界。或乐生死。如是等类性别无边。已说识住。于前所说诸界趣中。应知其生略有四种。其四者何。颂曰

  于中有四生　　有情谓卵等
  人傍生具四　　地狱及诸天
  中有唯化生　　鬼通胎化二

论曰。前所说界通情非情。趣唯有情。然非遍摄。生唯遍摄故说有情。无非有情名众生故。然有情类卵生胎生湿生化生。是名为四。生谓生类。诸有情中虽余类杂而生类等。言生类者。是众生义。若尔界趣应亦名生。不尔。界通情非情故。趣虽有情而非遍故。此唯情遍独立生名。所承诸师咸作是释。缘业合起故说为生。谓诸有情有卵胎湿三缘和合别别而生。有无别缘唯业力合。五蕴四蕴如应顿生。彼业力强不待缘故。今释一切皆业合生。佛说有情业所生故。有业生果待卵等缘方有差别。有业生果不待外缘自有差别。若说一切皆业合生。如何说为卵胎生等。不可卵等从业合生名卵等生。彼非情故。不说一切唯业合生。不说卵等体生由业。但说一切皆业合生。业合生时有缘卵等。从缘摽别名卵等生。若说业生名应非别。言卵生者。谓诸有情生从卵[穀-禾+卵]。如鹅雁等。言胎生者。谓诸有情生从胎藏。如象马等。言湿生者。谓诸有情从皮肉骨牛粪油滓水等和合暖润气生。如虫飞蛾蚊蚰蜒等。言化生者。谓诸有情不待三缘无而欻有。具根无缺支分顿生。如那落迦天中有等。化生体兼五蕴四蕴。余三但用五蕴为体。有说。皆通异熟长养。有说。一切体唯异熟随于何趣各具几生。且人傍生。各具四种。人卵生者。谓如世罗。邬波世罗生从鹄卵。鹿母所生三十二子。给孤独女二十五子。般遮罗王五百子等。人胎生者。如今世人。人湿生者。如曼驮多遮卢邬波遮卢鸽鬘庵罗卫等。人化生者。唯劫初人。此四生人皆可得圣。得圣无受卵湿二生。以圣皆欣殊胜智见。卵湿生类性多愚痴。或诸卵生生皆再度。故飞禽等世号再生。圣怖多生故无受义。湿生多分众聚同生。圣怖杂居故亦不受。傍生三种现所共知。化生如龙妙翅鸟等。一切地狱诸天中有。皆唯化生。有说。饿鬼唯化生摄。有说。饿鬼亦有胎生如饿鬼女白目连曰

  我夜生五子　　随生皆自食
  昼生五亦然　　虽尽而无饱

于四生内何者最多。有说。湿生。现见多故设有肉等聚广无边。下越三轮上过五净。容遍其量顿变为虫。是故湿生多余三种。有余师说。化生最多。谓二趣全三趣少分及诸中有。皆化生故。一切生中何生最胜。应言最胜唯是化生。支分诸根圆具猛利。身形微妙故胜余生。若尔何缘后身菩萨得生自在。不受化生见受胎生。有大利故。谓引亲属入正法故。令所化生练磨心故。令余族类生尊敬故。息诸外道谤为幻故。留遗身界饶益他故。又与化生时不同故。问答决择如顺正理

说一切有部显宗论卷第十二阿毗达磨藏显宗论卷第十三

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩缘起品第四之二

前说地狱诸天中有唯是化生。何谓中有。此何缘故非即名生。颂曰

  死生二有中　　五蕴名中有
  未至应至处　　故中有非生

论曰。死后生前有自体起。具足五蕴为至生处。在二有中故名中有。如何此有体有起殁而不名生。又此有身为从业得。为自体有。从业得者。此应名生。业为生因。契经说故。自体有者。此应无因。则同无因外道论失。是故中有应即名生。生谓当来所应至处。依所至义建立生名。此中有身体虽起殁而未至彼。故不名生。体谓此中异熟五蕴。此但名起不说为生。死生有中暂时起故。或复生者是所趣义。中有能趣所以非生。所趣者何。谓业所引异熟五蕴。究竟分明以业为生因。契经说故。此应名生者。其理不然。不说业为因皆名为生。故契经说。有补特伽罗。已断生结起结未断。广说四句。由是准知。有顺中有非生有业。此业所得不说为生。故与彼经无相违失。此既与生同一业引。如何中有名起非生岂不前说所至所趣乃说为生。中有不尔。又一业果多故无失。如一念业有多念果。一无色业色无色果。如是一业所引之果。有生有起理何相违。破余部执说有中有。理教相违。如顺正理应理者说。定有中有由理教故。理教者何。颂曰

  如谷等相续　　处无间续生
  我宗许像生　　其中亦无间
  不成故非譬　　是一类所许
  彼所说非理　　能生余像故
  有相相应故　　非恒可得故
  能障余色故　　无分别境故
  一处无二并　　由谓如是得
  非光二像生　　不等故非譬
  从一生多故　　非相续二生
  圣说健达缚　　及五七经故

论曰。且由理故中有非无。中有若无。应定非有从余处殁余处续生。未见世间相续转法。处虽有间而可续生。既许有情从余处殁生于余处。则定应许中间连续中有非无。譬如世间谷等相续。现见谷等余处续生。必于中间处无间断。故有情类相续亦然。刹那续生处必无间。是故中有实有义成。岂不世间亦见有色处虽间断而得续生。如镜等中从质生像。死生二有理亦应然。我许质依中间有物连续无断诸像方生。故于其中亦无间断。谓月面等大种。恒时法尔能生。清妙大种无间遍至。现对所依在所皆生似本像色依若清彻像显易知。依若粗秽像隐难了。虽二中间亦有像色。由清妙故在依方显。如日光等。虽复遍生在壁等依方现可见。如何知像连质而生。中间有隔像不生故。谓若月等中无连续。于水等中能生像者。中间有隔像亦应生。如彼所宗执无中有。余处蕴灭余处蕴生。又像形容屈申俯仰。及往来等随本质故。由斯证像连质而生。不可引为遮中有喻。然经主等一类诸师。许像不成故非譬者。彼说非理。像非不成。对别现生如是像故。犹如此像本质所依。谓镜等中镜等现质为依缘故。有随所依本质像起分明可得。像所缘质实有极成。此像为缘于别镜。等亦有随质所依像起分明可得。故知前像缘起像故实有义成。由是应知诸像实有。此若无者余像何缘。若言前像所缘本质为此缘者。理亦不然。前质不对后所依故。后像不随前质起故。谓后所依唯对前像不对前质。如何可说前质为缘现于后像。曾未见有背镜等质于镜等中为缘现像。由斯后像不随前质。但随前像其理极成。复如何知像体实有。由像不越实有相故。谓若不越眼等识境。皆是实有后当成立。像既可见故知实有。又像有时而可得故。此若无者。应一切时定不可得。或常可得。若谓有时可不可得。由所待缘合不合者。是则应知余有为法。于缘合位实有义成。又像能遮余色生故。谓像能碍余像色生。于自所居障余生故。又无分别识所缘故。谓五识身所缘境界实有极成。然像既通眼识所得。故知实有。若法随具如前相者。当知彼法实有极成。此像既然。故知实有。然经主等立像无因。谓一处所无二并故。彼谓一处镜色及像并见现前。二色不应同处并有。依异大故。又挟水上两岸色形。同处一时俱现二像。居两岸者互见分明。曾无一处并见二色。不应谓此二色俱生。又影与光未尝同处。然曾见镜悬置影中。光像显然现于镜面。不应于此谓二并生。或言一处无二并者。镜面月像谓之为二。近远别见如观井水。若有并生如何别见。故知诸像于理实无。今观彼因不能遣像。由谓如是而可得故。且彼所说一处镜像并见现前。二色不应同处并有。依异大故。此非定因。同处壁光俱可取故。虽壁光色异大为依。而于一时同处可取。不可亦拨在壁光无。由此例知镜像俱有。故彼所说非遣像因。若谓光依日轮大种故无过者。理亦不然。暖触如光近可取故。又日光色应无依因。许离所依能依转故。如是镜像二色所依。大种虽殊而可同处。故彼所说依异大故。因证一处不同成不定失。又镜像色俱有对故。必不同处。如何乃说一处镜像并见现前。若言处异不可得者。如壁光色处虽不同而可同取。谓彼像色极清妙故。不能掩蔽所余诸色。由镜与像最极相邻起增上慢。谓同处取。如云母等与所隔色若极相邻便谓同处。又如光壁虽处有殊以极相邻谓为同处。言于一水两岸形色现像同时各别见者。此亦非是。证像无因缘合差别如是见故。谓一水上非一像生。清妙处邻不相掩蔽。见缘合者则能见之。若阙见缘则不能见。若都无像所见是何。应同余处都无见理。如于一处筹画为文。向光背光有见不见。岂不同见则无有体。言影与光未常同处。然曾见镜悬置影中。光像显然现于镜者。此亦非理。非所许故。谓悬二镜置影光中。所现二像非实光影。如色彼触不可得故。若尔明了所见是何。谓随壁等光影二质。于二镜面有不相违。光影像起非光影色。如有情像体非有情。故光影像体非光影。虽同处现而不相违。又彼所宗影非实物。既无实体何所相违。非无体中可有违害。故约彼执违义亦无。则所说因俱非所许。又言镜像近远别见。故知诸像理实无者。亦非证因。二像生故。所以者何。空界月像同依镜等而发生故。谓空界色与彼月轮。次第安布近远差别。是见依像处差别因。空界是有色处所摄。辩本事品已略成立。故与月轮于镜等上各能生像。由所生像与质相同。故见与依处似差别。或由如是见缘和合。非远近中令见远近。如观彩画锦绣等文。无高下中见有高下。由月远故。见像亦然。如满月轮见像无缺。由如是理破彼诸因。故彼诸因不能遣像。大德喜慧亦以多同证像非有。同经主者。如经主破。有不同者。顺正理中已广别破。今更略述。彼作是言。镜等诸像皆非实色。一分遍生俱非理故。谓藉月轮为因引发。依水一分或复遍依。生像实色二皆非理。依水一分理且不然。无定因故。遍随转故。遍亦不然。分限见故。又量无差。见动作故。谓一天授背趣镜时像现。量无差见往来用别。于一实色无容有此。若尔于彼所见是何。本质为缘生眼识故。如缘眼色眼识得生。如是缘于眼及镜等。对镜等质眼识得生。实见本质谓见别像。今谓彼因亦不遣像。且彼所说。一分遍生俱非理故。非实色者。理不应然。余亦同故。谓许缘于眼及镜等对镜等质眼识生者。如是二种征责亦同。一分与遍俱非理故。谓还见本质藉镜等为缘。一分或遍二皆非理。且非镜等一分为缘。无定因故。历余方所皆能现前为见缘故。亦非镜等遍能为缘。所见分明有分限故。然我不许月等为因水等一分为依生像。但质与依无隔相对。依中法尔有质像生。何容像生但依一分。如何知像遍所依生。现见多人别长渠侧。各见月像对自面故。若尔何故一不见多。如是见缘不和合故。虽一切处有月像生。而但现前见缘和合。故于一分可见非余。傍阙明缘闇所隔故。有余师释。像色轻微正近可观。横远难见。或复渐次一亦见多。故于此中不应为难。然见月像有分限者。以彼本质有分限故。现像必随所依本质。或无分限。本质为缘于水上生无分限像。犹如于水现空相青。是故本质有分限故。虽一切处有月像生。而见分限亦无有过。或复如说。镜等为缘还见现前本质相者。虽复一分或遍为缘。皆不应理。然见本质决定应许镜等为缘。生像亦然。何劳征难。又彼所说。其量无差见动作故像非实者。理亦不然。如前说故。谓虽别有实像色生。而像必随所依本质。故量虽等而随所应。于所依上如其本质。有显形动三种像生。像随所依及本质故。虽无动作而似往来。及余运动三用可得。如是动相。或由本质余方运转无间生故。或由所依随持者等有动摇故。或由观者自有动摇。谓像转故。如是诸像不越所依。分量处所随本质等。见有往来及余动相。又彼所说。本质为缘生于眼识还见本质。理定不然。于镜等中无本质故。非余处法余处可取。世极成故。又所取像形量显色异本质故。若谓藉缘力所改转虽即是彼而现有异。此亦不然。互相违故。理不成故。谓若即彼不应现异。既现有异不应即彼。即彼现异更互相违。又现有异而言即彼。理不成立太过失故。谓老等位亦应可执。即是先时羯逻蓝等。由缘力转。故现有异等尔劬劳。何不即信藉众缘力有别像生。而计藉缘还见本质。经主于此亦作是言。然诸因缘和合势力。虽无有像令如是见。以诸法性功能差别难思议者。彼何不谓质镜等缘和合势力别能生像故如是见。以说法性功能差别难思议故。又和合名非名实法。如何可执有势力耶。又执多缘合成一力。如何说诸法有差别功能。是故应如功能差别。眼及色等为缘别引功能差别眼识令生。如是亦由功能差别。质及镜等为缘别引功能差别像色令生。由此证成诸像实有。非像无故为喻不成。但由非等坏随质故。谓见诸像坏随本质。生有亦随死有灭者。有情相质便有断过。又诸像生似本质故。谓月等像定似本质。从牛等死有应唯牛等生。既不许然故喻非等。又从一质生多像故。谓随质依生诸像位可从一质。随对镜等众多所依遍生多像。非从一蕴相续死有。多蕴相续生有俱生。故像于斯非为等喻。又质与像非相续故。谓质与像非一相续。像与本质俱时有故。诸相续者必不俱生。像质俱生故非相续。有情相续前后无间。于此处死余处续生。但应引谷为同法喻。像非等故为喻不成。又所现像由二生故。谓二缘故诸像得生。一者本质。二者镜等。世间现见生有不尔。所以者何。生有如像死有如质。更有何法如像所依。故所引喻与法非等。若精血等如像所依。理亦不然。非有情故。又于空等欻尔化生。于中执何如像依处。若谓唯识相续流转。连续死生其义已立。执色相续复何所成。此不应理。诸有于色未得离贪。离色唯心相续流转理不成故。若心离色可相续流。则应受生定不取色。故心相续必与色俱。方能流转往受生处。又契经说。唯缚而生。唯缚而死。唯由被缚从此世间往于他世。圣说一切未离色贪。无不皆被色缚所缚。故无唯识相续流转。亦不可计前本有色即能相续往后生处。现见死处身丧灭故。由此应知。别有色往。是故中有定有理成。眼耳意识取非至境。故住于此远取月轮。遥念他邑说远行等。非心离色能趣余方。如是已明像连质起。死生处隔同喻不成。由此亦遮响声为喻。以声与彼谷等中间有物相续传生响故。谓本发声所依大种。传生妙大种。遍至谷等中。所在击生似本声响。中间虽有声响相续。或散微故而不可闻。若于中间触崖谷等。即便聚积亦可得闻。云何知然。异时闻故。岂非不许诸声相续转入耳闻。如何言声展转相续遇缘发响。此责不然。我不遮故。谓声相续转非我所遮。唯转入耳闻非我所许。诸有大种发声缘处。展转相击皆有声生。在可闻缘声方可取。于中先取本质处声。于后乃闻异处生响。无同外道至根闻过。若唯能取逼耳生声。应不遥闻异方声响。及应不了远近声别。如无色殁欲色色生中无连续。如是亦应死生二有中无连续。此责非理。从无色殁生有色时。有连续故。谓无色殁生欲色时。即由是处大种和合。从顺后受业有异熟色生。故彼色生非无连续。或总相续无间断故。谓无色蕴无间无断为缘引发欲色蕴故。有余复言。犹如尺蠖前安前足后足后移。如是死生方所虽隔。先取后舍得至余方。中有何用。如是便有非二有情二趣二心俱行过失。又尺蠖身中无间绝。死生间绝如何为喻。有余复言。死生二有虽隔而至如意势通。此亦不然。非所许故。异此余类。此殁彼生中间隔绝应成通慧。若尔此应是行差别。实尔细故难可了知。谓一刹那不应为难又有别理中有非无。现见刹那无间生者。决定方所无间生故。若谓如从无色界殁生有色界色初起时。昔色与今方所无间。刹那有间而得续生。亦应下界死生有色刹那无间处有间生。此亦不然。不了宗故。谓于昔者从欲色殁生无色时色身灭处。今从彼殁生欲色时。即前色身灭处无间引今色起。非我所宗。是故此中刹那处所。俱非邻近不应为喻。又若刹那邻近生者处所定尔。非犹豫故。又中有身净天眼者现前可得。故如是说。诸中有身极净天眼之所能见。又彼尊者阿奴律陀亦言。具寿。我观佛化其量最多。非诸中有。是故中有决定非无又圣教说有中有故。谓契经言。有有七种。即五趣有业有中有。又经说有健达缚故。如契经言。入母胎者要由三事俱现在前。一者母身是时调适。二者父母交爱和合。三健达缚正现在前。除中有身。有何别物名健达缚正现在前。又经说有五不还故。谓世尊说有五不还。一者中般。二者生般。三无行般。四有行般。五者上流般。中有若无何名中般。若谓欲色二界中间得般涅槃名中般者。不生二界中有复无。何有有情于中趣般。若谓于彼有天名中。理必不然。无圣言故。谓于余部亦无契经说有中天唯凭自执。又契经说有七善士趣故。谓于前五中般分三。由处及时远近中故。譬如札火小星迸时才起近即灭。初善士亦尔。譬如铁火小星迸时起至中乃灭。二善士亦尔。譬如铁火大星迸时远未堕而灭。三善士亦尔。若无中有此依何立。非彼所执别有中天。有此处时三品差别。乘兹立破如顺正理。是故中有实有极成。若拨言无是邪见摄。已广成立中有非无。今复应思。当往何趣。所起中有形状如何。与所趣生为同为异。颂曰

  此一业引故　　如当本有形
  本有谓死前　　居生刹那后

论曰。业有二种。一牵引业。二圆满业。中生二有牵引业同。圆满业异。引业同故。此中有形与当本有其状相似。如印所印文像无别。欲中有量虽如小儿年五六岁。而根明利。有余师说。欲界中有皆如本有盛年时量。有言。菩萨中有可然。非余有情中有可尔。菩萨中有如盛年时。形量周圆具诸相好。故住中有将入胎时。照百俱胝四大洲等。有说。中有皆生门入。非破母腹而得入胎。理实中有随欲入胎。非要生门。无障碍故。色界中有其量周圆。其身微妙如彼本有。又彼中有与衣俱生。惭愧增故。欲界中有多分无衣。无惭愧故。唯除菩萨及鲜白尼。本愿力故。有余师说。唯除此尼。施僧袈裟发胜愿故。从兹世世有自然衣。恒不离身随时改变。乃至最后般涅槃时。即以此衣缠尸焚葬。收其遗骨起窣堵波。亦有衣形周匝缠绕。菩萨所起一切善法。皆唯回向无上菩提。我等所宗许二俱有。所似本有其体是何。在死有前生有后蕴。总说有体通诸有漏。于中有情位分四种。一者中有。义如前说。二者生有。谓于诸趣结生刹那。三者本有。除生刹那死前余位。四者死有。谓最后念。若有于色未得离贪。此有无间中有定起。即于一生位别分四。岂不诸有中有最初。则本有名应目中有。非目中有以当无间生等三有。非彼果故。若位容有生当无间。中等诸位可名本有。望余生诸位立本有名。非立此名望一生三位。又此无间定生彼有。此有望彼立本有名。又本有名目正所趣。余三不尔。不得此名。已说形量。余义当辩。颂曰

  同净天眼见　　业通疾具根
  无对不可转　　食香非久住
  倒心趣欲境　　湿化染香处
  天首上三横　　地狱头归下

论曰。此中有身是何眼境。为同类眼净天眼见。谓中有身唯同类眼。及余修得净天眼见。非不同类不净天眼之所能观。极微细故。生得天眼尚不能观。况余能见。以说若有极净天眼方能见彼中有身故。有说。地狱傍生饿鬼人天中有。如其次第。各除后后见自及前。为有能遮中有行不。上至诸佛亦不能遮。以诸通中业通疾故。中有成就最疾业通。故契经言。中有业力最为强盛。一切有情一切加行。无能遮抑凌虚自在。是谓通义。通由业得名为业通。此通势用速故名疾。中有具此最疾业通。诸通速行无能胜者。依此故说。业力最强。随地诸根中有皆具。虽言中有如本有形。而初异熟最胜妙故。又求有故无不具根。曾闻析破炎赤铁团。见于其中有虫居止。故知中有无对义成。对谓对碍。此金刚等所不能遮故名无对。此界趣处皆不可转。谓定无有色中有没欲中有生。亦无翻此。此与生有一业引故。应知趣处不转亦然。此中有身资段食不。且知欲界中有食香。随福多福少香有好有恶。由斯故得健达缚名。诸字界中义非一故。此頞缚界虽正目行。而于其中亦有食义。以食香故名健达缚。而音短者如设建途及羯建途。略故无过。有说。中有身赖香持。以寻香行名健达缚。如是中有为住几时。此中有身定非久住。生缘未合非久如何。大德释言。常途非久。缘未合者容住多时。由彼命根非别业引。有余师说。此但少时。以中有中恒求生故。若于父母俱定不移。虽住远方业令速合。若于父母随一可移。虽极清贞诃厌欲者。而于异境起染现行。诸起染定时令非时亦起。或寄相似余类中生。谓驴等身似于马等。非由所寄同分有殊便失中生。一业所引生缘虽别。所引一故。设许转受相似类生。由少类同亦无有过。又界趣处若不全移。虽少类殊亦无有失。以界趣处业定不移。余外生缘转亦无过。或业种类差别无边。唯佛世尊方能究达。正结中有为以何心。以染污心。譬如生有。将结生有方便如何。住中有中为至生处。由心颠倒驰趣欲境。彼宿业力所起眼根。虽住远方。能见生处父母交会而起倒心。若当为男于母起爱于父起恚。女则相违由是因缘男女生已。于母于父如次偏朋。故施设论有如是说。时健达缚于二心中随一现行。谓爱或恚。彼由起此二种倒心。便谓己身与所爱合。所憎不净泄至胎时。谓是己有便生喜慰。当生喜位名入母胎。取最后时所遗精血二三滴许。成羯剌蓝。精血相依无间而住。中有蕴灭生有蕴生。生有色生正因中有。父母精血但作生缘。如种生芽依地粪等。非有情色无情为因。若男处胎依母右胁向背蹲坐。若女处胎依母左胁向腹而住。女男惯习左右事故。宿自分别力使然故。无欲中有非女非男。以中有身不阙根故。入母胎后或作不男。此说欲界胎卵二生。湿化二生染于香处。若湿生者染香故生。谓远嗅知生处香气。便生爱染往彼受生。随业所应香有净秽。若化生者染处故生。谓远观知当所生处。便生爱染往彼受生。随业所应处有净秽。生地狱者亦由业力。或见身遇冷雨寒风。或见身遭热风猛焰。冷侵热逼酷毒难忍。希遇温凉冀除所厄。见热地狱热焰炽然。寒地狱中寒风飘鼓。便生爱染驰躬投赴。有说。由见先造业时己身伴类。爱慕驰往。往何趣中有何相赴生处。且天中有首正上升。如人直身从坐而起。人等三趣中有横行。如鸟飞空。往余洲处地狱中有。头下足上颠坠其中。故伽他说

  颠坠于地狱　　足上头归下
  由毁谤诸仙　　乐寂修苦行

无色界中无往来故。无彼业故。必无中有。若命终处即受生者。由有业故亦有中有。然此中有有决定相。谓无未离欲色界贪。生有不从中有后起。亦无中有与所趣生非一业引。亦无中有能入无心可为身证俱分解脱及起世俗不同分心。住中有中无转根义。亦无能断见所断惑。及无断欲界修所断随眠。所余决择如顺正理。一切中有皆起倒心入母胎不。不尔。云何。契经中说入胎有四。其四者何。颂曰

  一于入正知　　二三兼住出
  四于一切位　　及卵恒无知
  前三种入胎　　谓轮王二佛
  业智俱胜故　　如次四余生

论曰。有诸有情多修福慧。故死生位念力所持。心想分明正知无乱于中或有正知入胎。或有正知住胎兼入。或正知出兼知入住。兼言为显后必带前。有诸有情福慧俱少。入住出位皆不正知。前不正知后位必尔。如是所说四种入胎。具摄一切入胎皆尽。顺结颂法如是次第。然契经中次第不尔。如是四种且说胎生。有愚不愚分位差别。诸卵生者入胎等位。皆恒无知。如何卵生从卵而出言入胎等。此据当来立名无失。如世间说造钏织衣。或说卵生曾入胎等。依今说昔亦无有过。何缘入胎不正知者。于住出位必不正知。劣悟胜迷理无容故。谓将入位支体诸根具足无损。强胜明利尚不正知。况住出时支根损缺。羸劣闇昧而能正知。理无容故。住正知者。由入胎时胜正知因一力引故。出正知者。由入住时胜正知因二力引故。又前三种入胎不同。谓转轮王独觉大觉。如其次第初入胎者。谓转轮王。入位正知非住非出。二入胎者。谓独胜觉。入住正知非于出位。三入胎者谓无上觉。入住出位皆能正知。此初三人以当名显。复有差别如次应知。业智及俱三种胜故。第一业胜。宿世曾修广大福故。第二智胜。久习多闻胜思择故。第三俱胜。旷劫修行胜福慧故。除前三种余胎卵生。福智俱劣合成第四。有说。此四皆辩菩萨。谓最后有即是第三。睹史多天前生第二。遇迦叶波佛。次前生为初。自此已前皆是第四。或复初二三无数劫。如其次第前三入胎。自此已前皆是第四。岂不续有定是染心何容正知。入母胎藏正知正念说根律仪。夫根律仪决定是善。无斯过失。一切正知皆善性摄。非所许故。异此应无正知妄语。或入胎位据相续说。非唯正结生有刹那。于此位中善多染少。从多分故说为正知。或令于彼发起恭敬。于不迷乱立正知名。谓如实知此是我父此是我母故名正知。云何第三后有菩萨。于戒果等皆明了知。而入胎时有如是事。无始惯习率尔起心。斯有何过。或唯发起亲爱染心。无非法爱。所余问答如顺正理。此中应说。谁往入胎。何故问谁。以无我故。谓若无我为复说谁。从此世间乘中有蕴。往趣他世入住出胎。是故应有内用士夫。从此世间往入胎等。为遮彼故。颂曰

  无我唯诸蕴　　烦恼业所为
  由中有相续　　入胎如灯焰
  如引次第增　　相续由惑业
  更趣于余世　　故有轮无初

论曰。无有实我能往入胎。所以者何。如色眼等自性作业。不可得故。世尊亦遮所执实我。是作受者能往后世。故世尊言。有业有异熟作者不可得。谓能舍此蕴及能续余蕴。乃至广说。破四我执如顺正理。若尔外道于何所缘而起我执。虽离诸蕴无别我性为执所缘。然唯诸蕴为境起执。如契经说。诸有执我等随观见。一切唯于五取蕴起。虽无如彼外道所说真实我性。而有圣教随顺世间所说假我。既无实我。依何假说。虽无实我。而于诸蕴随顺世间假说为我。何缘知说我唯托蕴非余。以染及净法唯依蕴成故。谓我实无。且杂染法但依诸蕴刹那相续。由烦恼业势力所为。中有相续得入母胎。譬如灯焰刹那相续转至余方。诸蕴亦尔。且于欲界若未离贪。内外处为缘起非理作意。贪等烦恼从此而生。劣中胜思及识俱起。起已能牵当非爱果。亦为无间识等生缘。无间识等观同异类前俱生缘而得起时。或善或染或无记性。起已复能引自当果。及为无间识等生缘。如是为缘后后次第能牵二果。随应当知。此蕴相续领纳先世惑业所引寿量等法。彼异熟势至穷尽时。死识与依俱至灭位。能为中有识等生缘。中有诸蕴由先惑业。如幻相续往所生处。至母腹内中有灭时。复能为缘生生有蕴。譬如灯焰虽刹那灭而能前后。因果无间展转相续得至余方。故虽无我蕴刹那灭。而能往趣后世义成。即此诸蕴如先惑业。势力所引次第渐增。于一期中展转相续。复由惑业往趣余世。现见因异果必有殊。故诸引业果量非等。寿果长短由业不同。随业增微所引寿命与身根等。展转相依。于羯逻蓝頞部昙等后后诸位渐渐转增。何等名为羯逻蓝等。谓蕴相续转变不同。如是渐增至根熟位。观内外处作意等缘。和合发生贪等烦恼。造作增长种种诸业。由此惑业。复有如前中有相续转趣余世。应知如是有轮无初。谓惑为因能造诸业。业为因故而能引生。生复为因起于惑业。从此惑业更复有生。故知有轮旋环无始。若执有始始应无因。始既无因余应自起。无异因故。现见相违。由此定无无因起法。无一常法少能为因。破自在中已广遮遣。是故生死决定无初。犹如谷等展转相续然有后边。由因尽故。如种等尽芽等不生。生死既无究竟清净。故染及净唯依蕴成。执有实我便为无用

说一切有部显宗论卷第十三阿毗达磨藏显宗论卷第十四

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩缘起品第四之三

已辩内外羯剌蓝等种等道理因果相续。应知此即说名缘起。如是缘起其相云何。颂曰

  如是诸缘起　　十二支三际
  前后际各二　　中八据圆满

论曰。非诸缘起唯有十二。云何知然。如本论说。云何为缘起。谓一切有为。然契经中辩缘起处。或时具说十二有支。如胜义空契经等说。或说十一。如智事等经。或唯说十。如成喻经等。或复说九。如大缘起契经中说。或说有八。如契经言。诸有沙门或婆罗门。不如实知诸法性等。诸如是等所说差别。何缘论说与经有异。论随法性经顺化宜。故契经中分别缘起。随所化者机宜异说。或论了义经义不了。或论通说有情无情。契经但依有情数说。依有情故染净得成。佛为有情开显此二。但为此事佛现世间。故契经中依有情说。为欲成立大义利故。分别缘起诸有支中具无量门义类差别。今且略辩。三生分位无间相续有十二支。一无明二行三识四名色五六处六触七受八爱九取十有十一生十二老死。言三际者。一前际。二后际。三中际。即是过未及现三生。云何十二支于三际建立。谓前后际各立二支。中际八支。故成十二。无明行在前际。谓过去生。生老死在后际。谓未来生。所余八在中际。谓现在生。前际二因所招五果。后际二果所待三因。非诸一生皆具此八。据圆满者。说有八支。圆满者何。谓支无缺。或由圆满惑业所招。谓先增上惑业所引。此中意说。补特伽罗历一切位名圆满者。非诸中夭及色无色羯剌蓝等。诸位阙故。世尊但约欲界少分补特伽罗说具十二。如大缘起契经中说。佛告阿难。识若不入胎得增广大不。不也世尊。乃至广说。是故若有补特伽罗。于次前生造无明行。具招现在识等五支。复于现生造爱取有。招次后世生等二支。应知此经依彼而说。若依一切补特伽罗立诸有支便成杂乱。谓彼或有现在五支。非次前生无明行果。及次后世生老死支非现在生爱取有果。彼皆非此经意所明。勿见果因相去隔绝。便疑因果感赴无能。应知缘起支略唯二。分前后际如次七支五支。以果与因属因果故。或因与果五支七支。以因摄因果摄果故。谓现爱取即过无明。现在有支即过去行。现在世识即未来生。余现四支即当老死。是名因果二分差别。既说三际立十二支。谓无明行。乃至广说。此中何法名为无明。乃至何法名为老死。颂曰

  宿惑位无明　　宿诸业名行
  识正结生蕴　　六处前名色
  从生眼等根　　三和前六处
  于三受因异　　未了知名触
  在淫爱前受　　贪资具淫爱
  为得诸境界　　遍驰求名取
  有谓正能造　　牵当有果业
  结当有名生　　至当受老死

论曰。于宿生中诸烦恼位。至今果熟总谓无明。何故无明声总说烦恼。与牵后有行为定因故。业由惑发能牵后有。无惑有业后有无故非牵后有。诸行生时贪等于中皆有作用。彼行起位定赖无明。故无明声总说烦恼。若尔何故唯前生惑总谓无明。此生不尔。唯前生惑似无明故。贪等烦恼未得果时。势力无亏说为明利。若得果已。取与用亏不名明利。无明势力设未亏损亦非明利。彼现行时亦难知故。前生诸惑至于今生。已得果故势力亏损。其相不明似无明品。故唯前世惑可说无明声。非于行中亦应同此说。假立名想。唯于同类故。于宿生中福等业位。至今果熟总名为行。初句位言流至老死。福等诸业相。业品当广辩。何缘此宿业独名为行。名随义立故。其义云何。谓依众缘和合已起惑展转力和合已生。又能为缘已令果和合。或此和合已能为果缘。是谓行名所随实义。宿生中业果今熟者。行相圆满独立行名。由此已遮来生果业。以彼业果仍未熟故。相未圆满不立行名。岂不一切已与自果异熟因体皆具此相。即应一切皆立行名。此体是何。谓诸非业及业前生。已得果者虽有此理。而就胜说业为异熟因。牵果最胜故。现在生业果粗显易知故因。此能信知过去生果业。是故唯此独立行名。虽一切因已与果者总应名行。然此唯说能招后有诸异熟因。故无行名不遍相失。是故成就唯宿生中感此生业独名为行。于母胎等正结生时。一刹那位五蕴名识。此刹那中识最胜故。此唯意识。于此位中五识生缘。犹未具故。识是何义。谓能了者。佛说能了者名识取蕴故。颇勒具那契经中说。我终不说有能了者。此不说言表不显义。意为遮有自在无缘不依他成我为了者。不遮识是能了者性。胜义空经遮别作者。许诸行体是作者故。结生识后六处生前。中间诸位总称名色。岂不已生身意二处。应言此在四处生前此难不然。未圆胜故。谓前二位处犹减劣。六处位中处方圆胜。又六处位身意二根方全分得。具现行故。谓要支开位方得男女根。尔时诸识身乃容皆现起。故身意处六处位中。方全分得及具现起。由斯故说六处生前是名色位。此说为善。从生眼耳鼻舌四根。三和合前说名六处。谓名色后六处已生。乃至根境识未具和合位。下中上品次第渐增。于此位中总名六处。岂于此位诸识不生。而得说三未具和合。且无一位意识不生。名色位中身识亦起。况六处位言无三和。所余识身亦容得起。然非恒胜故。未立三和名。于此位中唯六处胜。故约六处以标位别。薄伽梵说。根境识三具和合时说名为触。谓未能了三受因异。但具三和。彼位名触。触差别义后当广辩。已了三受因差别相。未起淫贪。此位名受。谓已能了苦乐等缘。淫爱未行。说名受位。受差别义后当广辩。贪妙资具淫爱现行未广追求。此位名爱妙资具者。谓妙资财。贪此及淫总名为爱。广辩爱义如随眠品。为得种种可意境界周遍驰求。此位名取。取有四种。谓欲及见戒禁我语。取差别故。以能取故说名为取。即诸烦恼作相想业。谓欲界系烦恼随烦恼除见名欲。取如马等车。三界四见名为见取。彼戒禁取名戒禁取。色无色界系烦恼随烦恼。唯除五见名我语取。如是诸取随眠品中当广分别。无明不立为别取者。自力无明不猛利故。非解性故。相应无明他烦恼力令能取故。离余见立戒禁取者。于能集业力最胜故。于集业门力齐四见。由此一见令业炽然。乘违圣道远离解脱。故戒禁取别立取名。以诸取名表执取义。虽烦恼类皆能执取。而其二取执取义胜。故唯此二俱得取名。以二于他最坚执故。然于此二戒禁取强。如所蔽执炽然行故。由是离余别立为取。四见皆以慧为性故。对余烦恼执取义强。摄四简余立为见取。诸余烦恼定不定地有差别故。不善无记因差别故。立余二取。所余决择如顺正理。即由如是取为缘故。驰求种种可意境时。必定引生牵当有业。谓由爱力取增盛时。种种驰求善不善境。为得彼故积集众多。能牵后有净不净业。此业生位总名有支。应知此中由此依此能有当果。故立有名。有有二种。谓业异熟。今于此中唯取业有辩当生果。近因性故取为缘有。契经说故。唯诸业有取为缘故。如前际行无明为缘。取为缘生后际业有。正结生有位即立为生支。如此生中行为缘故。初结生位名为识支。如是来生有为缘故。初结生位名为生支。此位此名正所须故。谓于现世识用分明。未来世中生用最显。随自用显以立支名。或余经中说生苦故。为造天趣后有业者。令生厌舍故说为生。或显后有业皆能招苦果。为令不造故说为生。由是余经说生等苦毕竟寂灭名般涅槃。是故生名显在当果。此生支后至当受。支中间诸位。总名老死。即如现在名色六处触受四支。于当来生如是四位名为老死。为令厌舍欣当有心。以老死名显当过患。故契经说。五取蕴生应知即是老死起义。所余决择如顺正理。又诸缘起差别说四。一者刹那。二者远续。三者连缚。四者分位。有余复说显法功能。此中刹那。谓因与果俱时行也。如契经说。眼及色为缘生于眼识等。又契经说。眼色为缘生痴所生染浊作意。此中所有痴即无明。痴者希求。即名为爱。爱者所发。表即名业。故一刹那有缘起义。有余师说。一刹那中具十二支。实有俱起如贪俱起。发业心中痴谓无明。思即是行。于诸境事了别名识。识俱三蕴总称名色。有色诸根说为六处。识相应触名为触。识相应受名为受。贪即是爱。与此相应诸缠名取。所发身语二业名有。如是诸法起即名生。熟变名老。灭坏名死。此广决择如顺正理。远续缘起。谓前后际。有顺后受及不定受。业烦恼故无始轮转。如说有爱等本际不可知。又应颂言

  我昔与汝等　　于四种圣谛
  不如实见故　　久流转生死

连缚缘起。谓同异类因果无间相属而起。如契经说。无明为因生于贪染。明为因故无贪染生。又契经说。从善无间染无记生。或复翻此分位缘起。谓三生中十二五蕴。无间相续显法功能。谓如经说业为生因爱为起因。如是等类功能差别。于此五种缘起类中。世尊说何。颂曰

  佛依分位说　　从胜立支名

论曰。佛依分位说诸缘起。若支支中皆具五蕴何缘但立无明等名。以诸位中无明等胜。故就胜立无明等名。谓若位中无明最胜。此位五蕴总名无明。乃至位中老死最胜。此位五蕴总名老死。故体虽总名别无失。如是前位五蕴为缘。总能引生后位五蕴。随所应说一切一切。经主妄谓上义为非。所以者何。经异说故。如契经说。云何为无明。谓前际无智。乃至广说。此了义说。不可抑令成不了义。故前所说分位缘起。经义相违。此无所违如标释故。谓虽有贪等亦为行缘而但标无明。观别因故。又虽十二处皆为触缘。而由观别因但标六处。又虽想等亦用触为缘。而观别因但摽触缘受。诸如是等其类寔多。如观别因但摽少分。亦即由此唯释所标。如何执斯为了义说。此广决择如顺正理。何缘于三际建立缘起支。颂曰

  于前后中际　　为遣他愚惑

论曰。依有情数立十二支。为三际中遣彼愚惑。彼于三际愚惑者何。如契经言。我于过去世为曾有非有。何等我曾有。云何我曾有。我于未来世为当有非有。何等我当有。云何我当有。于现在世何等是我。此我云何。我谁所有。我当有谁。为除如是三际愚惑。故经唯说。有情缘起三际缘起如前已说。谓无明行及生老死并识至受。故契经说。若有苾刍。于诸缘起缘已生法。能以如实正慧观见。彼必不于三际愚惑。谓我于过去世为曾有非有等。是故为除三际愚惑。唯依有情数立三际缘起。虽有十二支而三二为性。三谓惑业事。二谓果与因。其义云何。颂曰

  三烦恼二业　　七事亦名果
  略果及略因　　由中可比二

论曰。前际因无明。后际因爱取。如是三种烦恼为性。前际因行。后际因有。如是二种以业为性。前际识等五。后际生老死。如是七名事。或业所依故。如是七事即亦名果。义准余五即亦名因。以烦恼业为自性故。何缘中际广说因果。后际略果。前际略因。中际易知应广说二。前后难了各略说一。由中比二具广已成。故不别说。说便无用。如何别立爱取二支。由初念爱以爱声说。即此相续增广炽盛。立以取名。相续取境转坚猛故。一一境中各有初爱。合成多念故唯说二刹那。何缘现在诸烦恼位。偏说于爱非余烦恼。于爱易了爱味过患。余烦恼中此相难了。爱是能感后有胜因。世尊偏说令知过患。云何当令勤求治道。故唯说爱刹那相续二位差别。非余烦恼。然取名通总摄诸惑。若此缘起唯十二支。老死无果。离修对治道。生死应有终。无明无因。无明是初故。生死应有始。或应更立余缘起支。余复有余成无穷过。又佛圣教应成缺减。然不应许。此难不然。未了所说缘起理故。此缘起理云何应知。颂曰

  从惑生惑业　　从业生于事
  从事事惑生　　有支理唯此

论曰。唯声正显有支数定。并显业与惑或俱惑后生是惑生惑时业俱或后义。由如是理总摄有支。即已善通前所设难。从惑生惑。谓爱生取。从惑生业。谓取生有无明生行。从业生事。谓行生识及有生生。从事生事。谓从识支生于名色。乃至从触生于受支。及从生支生于老死。从事生惑。谓受生爱。由立有支其理唯此。已成老死为事惑因。老死即如现四支故。及成无明为事惑果。无明即如现爱取故。岂假更立余缘起支。故经言如是纯大苦蕴集。是前后二际更相显发义。是故无有老死无明。无果无因有终始过。于此定摄因果义周。无更立支成无穷过。由佛遍说因果无遗。故无圣教成缺减失。如世尊言。吾当为汝说缘起法。缘已生法此二何异。诸师种种释此二句。如顺正理。决定义者。颂曰

  此中意正说　　因起果已生

论曰。诸支因分说名缘起。所以者何。由此为缘能起果故。以于因果相系属中说缘起故。此缘起义。但以缘声而成立故。如契经说。云何缘起谓依此有彼有。及此生故彼生。谓无明缘行至生缘老死。如是说已。复作是言。此中法性乃至最后无颠倒性。是名缘起。何等名为此中法性。谓于因果相系属中。有因功能皆名法性。要有因故因果方有。更相系属非无有因。如是性言显能生义。唯有为法性得此法性名。虽此经中非正显示于因果相属因性名缘起。而以缘声显缘起义故知因性得缘起名。以缘声但于能显义转故。因能显果故说名缘。由是阿罗汉最后心心所非等无间缘。无所显果故。即由此义证缘起名。定于因果相属中立。故佛于彼胜义空经说此中法假。谓无明缘。行广说乃至生缘老死。以非胜义故立假声。即目因果更相属义。诸支果分说缘已生。所以者何。由此皆从缘已生故。果是诸法成办名故。要已生法此义成故。涅槃成办由得已生。故彼亦由已生名果。或复于此说缘起门。涅槃于中无容为难。若有为法果义决定。是此所明如沙门果。诸过现法果义决定名缘已生。法在未来果义非定。废而不说。此略义者。是起法性说名缘起。过现诸法名缘已生。果义定故。谓于因果相系属中。据为因分说名缘起。定为果者名缘已生。又此中因名缘起者。以能为缘起诸果故。于此中果法名缘已生者。以过去现在离缘不生故。如是一切二义俱成。诸支皆有因果性故。虽因果性实体无别。而义建立非不极成。以所观待有差别故。犹如因果父子等名。然此契经说有密意。阿毗达磨无密意说。何等名为此经密意。谓薄伽梵密显生死无始有终说斯二句。言缘起者。显生死流无始时来旋环无断。故说逆顺诸支相生。缘已生言为显生死若得对治有终尽期。谓若有缘后更续起。如其缘阙后不续生。由是经言作苦边际。又经中说。缘起是假。因果相属无自性故。说缘已生其体是实。是彼依故。如瓶所依。阿毗达磨说二皆实。因果二体俱实有故。且置斯事。复应广释无明名色触受四支。所以者何。行有爱取辩业惑品当广释故。识与六处辩本事品已广释故。且无明义其相云何。为是明无为非明摄。若取前义无明应是无。若取后义。应眼等为体。如是二种理皆不然。俱非所许。故无有过。既俱不许。所许云何。许有别物。别物者何。颂曰

  明所治无明　　如非亲实等

论曰。如诸亲友所对冤敌。亲友相违名非亲友。非异亲友。所余一切中平等类。非亲友无。谛语名实。此所对治虚诳言论。名为非实非异于实。所余一切色香等类。亦非实无。等言为显非天非白非法非爱非义事等。阿素洛等天等相违。得非天等名。非异无天等如是无明别有体实。是明所治非异非无。云何知然。犹如识等说从缘有。为他缘故。复有诚证。颂曰

  说为结等故　　非恶慧见故
  与见相应故　　说能染慧故

论曰。经说无明以为结缚。随眠及漏扼瀑流等非余眠等及体。全无可得说为结缚等事。故有别法说名无明。如恶妻子名无妻子。如是恶慧应名无明。彼非无明有是见故。诸染污慧名为恶慧。于中有见故非无明。见是推寻猛睿决断。不可说彼名为愚痴。若尔无明应是非见。诸染污慧此亦非理。以许无明见相应故。无明若是慧应见不相应。无二慧体共相应。故不可说见非无明。俱非不愚痴见成倒。故又说无明能染慧。故如契经说贪欲染心令不解脱无明染。慧令不清净。非慧还能染于慧体。如贪异类能染于心无明亦应异慧能染。亦不可说无明与慧虽不相应而能为染。如贪为染必与心俱。心心所法无发起染。但有自性相应染故。不可自体自体相应。是故无明定非恶慧。经主于此假作救言。如何不许诸染污慧间杂善慧令不清净说为能染。此救不然。诸无漏慧应被染故。又无染慧杂有染慧。应令有染转成无染。能治力强非所治故。又彼善慧正现行时染定非有。诸染污慧正现行时善定非有。说谁能染。复染于谁。若许有非有能互相染。则毕竟应无得解脱义。若灭熏习便解脱者。熏习理无当何所灭。故说无明。能染慧故。非慧为性。理无倾动。若有别法说名无明。应说以何为别法性。且有别法。谓不了知此即无明。何劳推究。应定何法名不了知。方可说为无明自性。唯薄伽梵于一切法正知正说若性若相。余唯总了何苦推征。然我于斯见如是相。谓有别法能损慧能。是倒见因障观德失。于所知法不欲行转。蔽心心所是谓无明。如何定知此有别法。以如贪欲说永离故。谓契经言。离贪欲故心便解脱。离无明故慧得解脱。又此如明说为因故。谓契经说。无明为因起诸杂染。明为因故离诸杂染。又说如邪见有近对治故。谓契经说。诸邪见断由正见生。诸无明离由明慧起。又契经说。是一法故。谓契经说。若有苾刍能断一法。我正记彼所作已办。即是无明。又说如闇有对治故。如伽他说

  诸有能断愚　　于所愚不惑
  彼转灭愚惑　　如日出除闇

是故无明定有别法。无知为体非但明无。然此无知略有二种。谓染不染。此二何别。有作是说。若能障智是染无知。不染无知唯智非有。今详二种无知相别谓由此故立愚智殊。如是名为染无知相。若由此故或有境中智不及愚。是第二相。又若断已佛与二乘皆无差别。是第一相。若有断已佛与二乘有行不行。是第二相。又若于事自共相愚。是名第一染无知相。若于诸法味势熟德数量处时同异等相。不能如实觉。是不染无知。此不染无知即说名习气有古师说。习气相言有不染污心所差别。染不染法数习所引。非一切智相续现行。令心心所不自在转。是名习气。非唯智无。无法无容能为因故。亦不应说有如是类心及心所总名习气。不染无知前已说故。谓此无知为自性住心等为体。为有差别。若自性住心等为体。佛亦应有不染无知。若有差别。能差别者。可是无知非所差别。现见善等品类差别。心心所中必有别法为能差别。非即一切。如善品中必有信等。不善品中有无惭等。染污品中有放逸等。如是等类心心所中。必有别法能为差别。故知此中亦有别法能为差别者是不染无知。今详彼言有太过失。诸异生等心心所法。皆不如实觉味势熟等相。然不见生余心所故。又一一念彼心心所差别而生。应念念中各有别别无知法起。若谓有异相令无知差别。即此足能差别心品。何须别计不染无知。是故即于味势熟等不勤求。解慧与异相法俱为因引生后同类慧。此慧于解又不勤求。复为因引生不勤求解慧。如是展转无始时来。因果相仍习以成性。故即于彼味等境中。数习于解无堪能智。此所引劣智名不染无知。即此俱生心心所法总名习气。理定应然。或诸有情有烦恼位。所有无染心及相续。由诸烦恼间杂所熏。有能顺生烦恼气分。故诸无染心及眷属。似彼行相差别而生。由数习力相继而起。故离过身中仍名有习气。一切智者永断不行。然于已断见所断位通染不染。心相续中有余顺生烦恼习性。是见所断烦恼气分。于中染者说名类性。金刚道断皆不现行。若不染者名见所断烦恼习气。亦彼道断由根差别有行不行。若于已断修所断位。唯于不染心相续中有余顺生烦恼习性。是修所断烦恼气分。名修所断。烦恼习气是有漏故。无学已断。随根胜劣有行不行。世尊已得法自在故。彼如烦恼毕竟不行。故佛独称善净相续。即由此故行无误失。得不共法三念住等。又由此故密意说言。唯佛独名得无学果

说一切有部显宗论卷第十四阿毗达磨藏显宗论卷第十五

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩缘起品第四之四

已辩无明。当辩名色。色已广辩。名相云何。颂曰

  名无色四蕴

论曰。佛说无色四蕴名名。何故名名。能表召故。谓能表召种种所缘。若尔不应全摄无色不相应法。无所缘故。不尔表召唯在无色如释色名所说无过。又微细故。彼彼义中随理立名。标以名称非无表等。亦可称名。以彼所依现量得故。又于一切界地趣生。能遍趣求故立名称。非无漏无色不得名。名虽非此所明而似此故。又于无色随说者情。总说为名不劳征诘。余广决择如顺正理。已辩名相。触相云何。颂曰

  触六三和生

论曰。触有六种。所谓眼触乃至意触。此复是何。三和所生。谓根境识三和合故。有别触生。虽第六三有各别世。而因果相属故和合义成。或同一果是和合义。虽根境识未必俱生。而触果同故名和合。触体别有。大地中已成。虽三和生而定识俱起。以如识说二缘生故。谓契经说。内有识身及外名色。二二为缘诸触生起。乃至广说。有识身言显六内处。外名色言显六外处。此义必然。伽他说故。如伽他说。眼色二等。又经说识触俱名色为缘。生缘既同时岂前后。缘具必起无能障故。由此即证眼等触所生受等。诸法眼等识俱起。与眼识等生因同故。由此经言。是受是想是思是识。如是诸法相杂不离。故识触俱理极成立。即前六触复合为二。其二者何颂曰

  五相应有对　　第六俱增语

论曰。眼等五触说名有对。以有对根为所依故。唯有对法为境界故。第六意触说名增语。增语谓名。名是意触所缘长境。故偏说此名增语触。意识通用名义为境。五不缘名故说为长。如说眼识。但能了青不了是青。意识了青亦了是青。乃至广说。故有对触名从所依境。就所长境立增语触名。有说意识名为增语。于发语中为增上故。有言意识语为增上。方于境转。五识不然。是故意识独名增语。与此相应名增语触。故有对触名从所依境。就相应主立增语触名。即前六触随别相应复成八种。颂曰

  明无明非二　　无漏染污余
  爱恚二相应　　乐等顺三受

论曰。明无明等相应成三。一明触。二无明触。三非明非无明触。此三如次应知即是无漏染污余相应触。余谓无漏及染污余。即有漏善无覆无记。染污触中一分数起。依彼复立爱恚二触。爱恚随眠共相应故。总摄一切。复成三触。一顺乐受触。二顺苦受触。三顺不苦不乐受触。云何顺受触。是乐等受所领故。或能为受行相依故。名为顺受。如何触为受所领行相依。行相极似触依触而生故。又与乐等受相应故。或能引生乐等受故。名为顺受。如是合成十六种触。已辩触相。受相云何颂曰

  从此生六受　　五属身余心
  此复成十八　　由意近行异

论曰。从前六触生于六受。谓眼触所生受。至意触所生受。此合成二。一者身受。二者心受。六中前五说为身受。依色根故。意触所生说为心受。但依心故。即于所说一心受中。由意近行异。复分成十八。云何十八意近行耶。谓忧喜舍各六近行。此复何缘立为十八。由三领纳唯意相应。六境有异故成十八。非一受体意识相应。境异成六领纳异故。意近行名为目何义。喜等有力能为近缘。令意于境数游行故。若说喜等意为近缘于境数行名意近行。即应想等亦得此名。与意相应由意行故。若唯意地有意近行。岂不违经。如契经言。眼见色已。于顺喜色起喜近行。乃至广说。此不相违。如依眼识引不净观。此不净观唯意地摄。然契经言。眼见色已。随观不净具足安住。此亦如是。依五识身所引意地喜等近行。故作是说。由彼经言眼见色已乃至广说。故意近行五识所引意识相应。不应为难。何缘身受非意近行。与意近行非同法故。以意近行唯依意识。故名为近。分别三世等自相共相境。故名为行。一切身受与此相违。故非意近。亦不名行。岂不身受亦有此相。身受领纳色等境已。意识随行。由身受力意识于境数游行故。此亦不然。已说相故。谓诸身受不依意识。无分别故。由彼不能分别境界功德过失。故非彼力令意于境数数游行。又不定故。谓身受后非决定有意识续生。意受俱时必有意识。故唯意受名意近行。又生盲等类虽无见已乃至触已。而有近行故。第三静虑有意地乐。亦应摄在意近行中。此责不然。初界无故。又凝滞故。谓欲界中无意地乐。第三静虑虽有不立。又彼地乐凝滞于境。近行于境。数有推移不滞一缘方名行故。又无所对苦根所摄意近行故。若尔应无舍意近行。无所对故。不尔忧喜即舍对故。第三静虑意地乐根。无自根本地舍根为对故。然无近分等。无舍等近行失。以于初界中有同地所对故。或复容有不容有故。谓意舍等容有同地所敌对法。意乐定无同地敌对。故无有失。诸意近行中几欲界系。欲界意近行。几何所缘。色无色界为问亦尔。颂曰

  欲缘欲十八　　色十二上三
  二缘欲十二　　八自二无色
  后二缘欲六　　四自一上缘
  初无色近分　　缘色四自一
  四本及三边　　唯一缘自境

论曰。欲界所系具有十八。缘欲界境其数亦然。缘色界境唯有十二。除香味六。彼无境故。缘无色境唯得有三。彼无色等五所缘故。缘不系境。亦唯有三。说欲界系已。当说色界系。初二静虑唯有十二。谓除六忧。若说所缘定无染污能缘下境。善缘欲境亦具十二。除香味四。余八自缘。二缘无色。谓法近行缘不系法亦唯二种。三四静虑唯六。谓舍缘欲界境。善亦具六除香味二。余四自缘。一缘无色。谓法近行缘不系法。亦唯一种。说色界系已。当说无色系。空处近分唯有四种谓舍但缘色声触法。缘第四静虑亦具有四种。此就许有别缘者说。若执彼地唯总缘下。但有杂缘法意近行缘无色界。唯一谓法。缘不系法亦唯一种。四根本地及上三边。唯一谓法。亦缘目地。无色根本不缘下故。彼上三边不缘色故。不缘下义如后当辩。此缘不系亦唯有一。诸意近行通无漏耶。颂曰

  十八唯有漏

论曰。无有近行通无漏者。所以者何。增长有故。无漏诸法与此相违。有说近行有情皆有。无漏不然故非近行。有说圣道任运而转。故顺无相界。故非近行体。近行与此体相违故。谁成就几意近行耶。谓生欲界若未获得色界善心。成就一切初二定八三四定四无色界一。所成上界皆不下缘。唯染污故。若已获得色界善心。未离欲贪。成欲一切初静虑十。舍具六种。未至地中善心得缘香味境故。喜唯有四。以但有染不缘下故。岂不意近行眼等识所引。彼既无鼻舌二识。应无缘香味近行。此责不然。生盲聋等自性生念。及在定中皆应无有色等近行。故非一切五识所引。成二定八三四静虑无色如前。已离欲贪。若未获得二定善心。彼成欲界初定十二。谓除六忧二静虑等。皆如前说。若已获得二定善心。于初定贪未得离者。成二定十。谓喜但四。唯染污故。舍具六种。已获得彼近分善故。余如前说。由此道理余准应知。若生色界唯成欲界一舍法近行。谓通果心俱。云何获得诸意近行。谓离欲贪前八无间八解脱道。获得初定近分地中六舍近行。第九无间解脱道中。获得欲界通果心俱法舍近行。获得初定十二近行。此初定言兼摄眷属。由此理趣离上地染。如应当知。然有差别。谓离第四静虑贪时。第九无间及解脱道。必不获得自地下地。通果心俱法舍近行。离空处等诸地贪时。一切无间及解脱道。唯获得一法舍近行。得无学时获得欲界。初二静虑十二近行。三四静虑六舍近行。空无边处四舍近行。上地各一法舍近行。于受生位从上地没生下地时。获得当地所有近行。生诸静虑亦兼下地舍法近行。是即喜等十八意行。由为耽嗜出依别故。世尊说为三十六师句。此差别句能表大师。是师幖帜故名师句。如是诸句唯佛大师能知能说。余无能故。耽嗜依者。谓诸染受。出离依者。谓诸善受无覆无记。顺善染故。随应二摄更不别说。此三十六界地定者。谓欲界中具三十六。初二静虑唯有二十。谓耽嗜依八出离依。十二三四静虑唯有十种。谓耽嗜依四及出离依。六空处近分若许别缘。便有五种。谓耽嗜依一出离依四。若执唯总缘但有二种。谓耽嗜依一出离依一。无色根本及上三边各唯有二。如前应知。此约界地所缘定者。欲缘欲境具三十六。缘色界境唯二十四。除缘香味二依各六。缘无色境唯有六种。谓法近行二依各三。缘不系境亦唯此六。由此道理色无色界。缘境差别如应当思。所余有支何缘不说。颂曰

  余已说当说

论曰。所余有支或有已说。或有当说。如前已辩。若尔何缘更兴此颂。为于后颂遮广释疑。由后颂中说烦恼等。勿有于此生如是疑。前已广明四支义讫。次应广释其余有支。为显后文依惑业事。寄喻总显十二有支。故轨范师更兴此颂。如前已说十二有支。略摄唯三。谓惑业事。此三用别。其喻云何。颂曰

  此中说烦恼　　如种复如龙
  如草根树茎　　及如糠裹米
  业如有糠米　　如草药如花
  诸异熟果事　　如成熟饮食

论曰。如何此三种等相似。如从种子芽叶等生如是从烦恼生烦恼业。事如龙镇池水恒不竭。如是烦恼得相续镇生池。令惑业事流注无尽。如草根未拔苗剪剪还生。如是烦恼根。未以圣道拔。令生苗稼断断还起。如从树茎频生枝花果。如是从惑数起惑业事。如糠裹米能生芽等非独能生。烦恼裹业能感后有非独能感。如米有糠能生芽等。业有烦恼能招异熟。如诸草药果熟为后边。业果熟已更不招异熟。如花于果为生近因。业为近因能生异熟。如熟饮食但应受用。不可转生成余饮食。异熟果事既成熟已。不能更招余生异熟。若诸异熟复感余生。余复感余应无解脱。已辩缘起。即于此中就位差别。分成四有。中生本死如前已释。善等差别三界有无。今当略辩。颂曰

  于四种有中　　生有唯染污
  由自地烦恼　　余三无色三

论曰。于四有中生有唯染。决定非善无覆无记。由何等惑一切烦恼。诸烦恼染诸生有耶。不尔。云何。但由自地。谓生此地。唯由此地中一切烦恼生。有成染污。诸烦恼中无一烦恼于结生位无润功能。然诸结生唯烦恼力。非由缠垢。所以者何。以自力行悔覆缠等。要由思择方现起故。然此位中身心昧劣。要任运惑方可现行。唯有随眠数习力胜。故诸烦恼能数现行。于结生时任运现起。诸缠及垢数习力劣。非不思择而得现前。是故结生非诸缠垢。故唯自地诸烦恼力。染污生有理极成立。余中有等一一通三。谓彼皆通善染无记。应知中有初续刹那。亦必染污犹如生有。如是四有何界所系。欲色具四。无色唯三。非无色业感中有果。如顺正理。已具思择。有情于此四种有中由何而住。颂曰

  有情由食住　　段欲体唯三
  非色不能益　　自根解脱故
  触思识三食　　有漏通三界
  意成及求生　　食香中有起
  前二益此世　　所依及能依
  后二于当有　　引及起如次

论曰。经说世尊自悟一法正觉正说。谓诸有情一切无非由食而住。何等为食。食有四种。一段二触三思四识。段有二种谓细及粗。细谓中有食。香为食故。及天劫初食。无变秽故。如油沃沙散入支故。或细污虫婴儿等食。说名为细。翻此为粗。如是段食唯在欲界。离段食贪生上界故。非上界身依外缘住。色界虽有能益大种而非段食。如非妙欲。如色界中虽有微妙色声触境。而不引生增上贪故。不名妙欲。如是虽有最胜微妙能摄益触。而毕竟无分段吞啖。故非段食。虽非段食摄。而非无食义。如喜虽非四食中摄。而经说为食。以有食义故。如契经言。我食喜食。由喜食久住。如极光净天。然段食体有十三事。以处总收唯有三种。谓唯欲界香味触三。一切皆为段食自体。可成段别而吞啖故。谓以口鼻分分受之。以少从多故作是说。虽非吞啖但能益身令得久住。亦细食摄。犹如影光炎凉涂洗。又劫初位地味等食。亦名段食。分段受故。又诸饮等亦名段食。皆可段别而受用故。色处名段不名为食。以不能摄益自所对根故。夫言食者。摄益诸根及诸大种。色处无力摄益自根及诸大种。是不至取根所行故。以契经说。段食非在手中器中可成食事。要入鼻口牙齿咀嚼。津液浸润进度喉筒。堕生藏中渐渐消化。味势熟德流诸脉中。摄益诸虫乃名为食。尔时方得成食事故。若在手器以当为名。如天授名那落迦等。虽彼分段总得食名。而成食时唯香味触。尔时唯此为根境故。又如何知色处非食身内摄益根大功能。如香味触不别见故。尔时不生彼境识故。生自识时尚不损益自根大种。况入身已不生自识能为食事。见日月轮等能损益眼根。是触功能非形显力。岂不苦乐与识俱生。此二能为损益事故。色处于眼亦为损益。理不应然。眼与明等应成食故。然彼为境顺苦乐触能为食事。色处不然。见安缮那筹等诸色眼不增损。要至眼中眼方增损。是故段食定非色处。若尔何故于契经中称赞段食具色香味。为令欣乐兼赞助缘。如亦赞言恭敬施与。岂即恭敬亦名段食。然成段食具正助缘。又举色相表香味触。亦妙可欣故作是说。是故食体唯香味触。非色不能益自根解脱故。夫名食者。必先资益自根大种。后乃及余。饮啖色时于自根大尚不为益。况能及余。由彼诸根境各别故。有时见色生喜乐者。缘色触生是食非色。又不还者及阿罗汉解脱食贪。虽见妙食而不生喜。无所益故。已说段食界系及体触思识三。次当显示触谓根境识三和所生。心所缘起中已广思择。思谓意业。识谓了境。此三唯有漏。通三界皆有。如是四食体总有十六事。唯后三食说有漏言。显香等三不滥无漏。何缘无漏触等非食。食谓能牵。能资诸有可厌可断爱生长处。无漏虽资他所牵有。而自无有牵有功能。非可厌断爱生长处。故不建立在四食中。即由此因望他界地。虽有漏法亦非食体。他界地法虽亦为因能资现有。而不能作牵后有因。故不名食。诸无漏法现在前时。虽能为因资根大种。而不能作牵后有因。虽暂为因资根大种。而但为欲成己胜依。速趣涅槃永灭诸有。自地有漏现在前时。资现令增能招后有。由此已释段食为因招后有义。谓触等食牵后有时。亦牵当来内法香等现内香等。资触等因令牵当有。亦能自取当来香等为等流果是故段食与后有因同一果故。亦能牵有故名为食。然香味触体类有三。谓异熟生等流长养。由外香等觉发身中内香味触令成食事。故所说食其理定成。如契经说。食有四种。能令部多有情安住。及能资益诸求生者。言部多者。显已生义。诸趣生已皆谓已生。复说求生。为何所目。此目中有。由佛世尊以五种名说中有故。何等为五。一者意成。从意生故。是牵引业所引果义。若尔此应有太过失。不尔。中有不揽外缘精血等物以成身故。二者求生。多喜寻察当生处故。生谓生有。中有多求趣生有处。三者食香。身资香食往生处故。四者中有。死生二有无间有故。五者名起。死有无间支体无缺。身顿起故。或复对向当生决定。暂时起故。何缘说食唯有四种。一切有为皆有食用。经说涅槃亦有食故。如契经说。涅槃有食。所谓觉支。虽诸有为皆有食用。而就胜说。谓大仙尊为所化者。就资有胜唯说四食。谓初二食能益此身所依能依。后之二食能引当有。能起当有。如次资益引起名色。二种有身故立四食。所依谓色即有根身。能依谓名即心心所。此中段食资益所依。以有根身由此住故。此中触食资益能依。以心心所由此活故。如是二食于已生有资益功能最为殊胜。思为引业识为种子。引起当有。谓由业故能引当来名色二有。业既引已爱润识种。能令当有名色身起。故契经说。业为生因爱为起因。如是二食于未生有引起功能最为殊胜。故唯说此四种为食。此四食中后二如生母。生未生故。前二如养母。养已生故。余广决择如顺正理。今更应思前释四有。死生二有唯一刹那。于此时中何识现起。此识复与何受相应。定心无心得死生不。住何性识得入涅槃。于命终时识何处灭。断末摩者其体是何。颂曰

  断善根与续　　离染退死生
  许唯意识中　　死生唯舍受
  非定无心二　　二无记涅槃
  渐死足齐心　　最后意识灭
  下人天不生　　断末摩水等

论曰。断善续善离界地染。从离染退命终受生。此六位中唯许意识。皆是意识不共法故。五识于此无有功能。生言兼摄中有初念。意识虽具三受相应。而死生时唯有舍受非苦乐受。性不明利顺死生时苦乐二受。性极明利不顺死生。非明利识有死生义。以死生时必昧劣故。由此故说。下三静虑唯近分心有死生理。以根本地无舍受故。虽说在意识得有死生。而非在定心有死生理。非界地别有死生故。设界地同极明利故。由胜加行所引发故。又在定心能摄益故。必由损害方有命终。诸在定心非染污故。必由染污方得受生。异地染心亦摄益故。无命终理加行起故无受生理。异地染心必胜地摄。无容乐往劣地受生。异地无记。以非染污加行起故。亦无生死亦非无心。有死生义理相违故。死有二种。或他所害。或任运终。处无心位他不能害。有殊胜法任持身故。处无心位非任运终。入心定能引出心故。谓入心作等无间缘。取依此身心等果法。必无有别法能碍令不生。若所依身将欲变坏。必定还起属此身心。方得命终更无余理。又有契经证非无心命终故契经说。无想有情由想起已从彼处殁。非无心位可得受生。必由胜心现所引故。住昧劣位而受生故。离起烦恼无受生故。亦有契经证非无心受生。故契经言。识若不入母胎中者。名色得成羯剌蓝不。乃至广说。然死有心虽通三性。而阿罗汉必无染心。虽有善心及二无记。而强盛故不入涅槃。入涅槃心唯二无记。谓威仪路或异熟生。若说欲界有舍异熟入涅槃心。通二无记。若说欲界无舍异熟入涅槃心。但威仪路。必无离受而独有心。劣善何故不入涅槃。以彼善心有异熟故。诸阿罗汉厌背未来诸异熟果。入涅槃故。若尔住异熟应不入涅槃。不尔。已简言厌背未来故。何不厌背现在异熟。知依现异熟永断诸有故。依现异熟证无学果。知彼有恩不深厌患。诸阿罗汉深厌当生。故命终时避彼因善。唯二无记势力劣故。顺于昧劣相续断心。故入涅槃唯二无记。眼等诸识虽依色根而无方所。况复意识。然约身根灭处说者。若顿死者。意识身根欻然总灭。非有别处。若渐死者。往下人天于足齐心如次识灭。谓堕恶趣说名往下。彼识最后两足处灭。若往人趣识灭于齐。若往生天识灭心处。诸阿罗汉说名不生。彼最后心亦心处灭。有余师说。彼灭在顶。正命终时于足等处身根灭故。意识随灭。临命终时身根渐减。至足等处欻然都灭。如以少水置炎石上。渐减渐消一处都尽。必无同分相续为因能无间生所趣后有。唯渐命终者。临命终时有为断末摩。苦受所逼无有别物。名为末摩。然于身中有别处所。风热炎盛所逼切时。极苦受生即便致死。得末摩称。如有颂曰

  身中有别处　　触便令命终
  如青莲花须　　微尘等所触

若水火风不平缘合。互相乖反或总或别。势用增盛伤害末摩。如以利刀分解支节。因斯引发极苦受生。从此须臾定当舍命。由兹理故名断末摩。非如斩薪说名为断。如断无觉故得断名。好发语言讥刺于彼。随实不实伤切人心。由此当招断末摩苦。何缘地界非断末摩。以无第四内灾患故。内三灾患。谓风热痰水火风增随所应起。有说此似外器三灾。此断末摩天中非有。然诸天子将命终时。先有五种小衰相现。一者衣服严具绝可意声。二者自身光明欻然昧劣。三者于沐浴位水渧着身。四者本性嚣驰今滞一境。五者眼本凝寂今数瞬动。此五相现非定命终。遇胜善缘犹可转故。复有五种大衰相现。一者衣染埃尘。二者花鬘萎萃。三者两腋汗出。四者臭气入身。五者不乐本座。此五相现决定命终。设遇强缘亦不转故。世尊于此有情世间生住殁中建立三聚何谓三聚。颂曰

  正邪不定聚　　圣造无间余

论曰。一正性定聚。二邪性定聚。三不定性聚。何名正性。谓世尊言。贪无余断。嗔无余断。痴无余断。一切烦恼皆无余断。是名正性。何故唯断说名正性。谓此永尽邪伪法故。又体是善常。智者定爱故。世尊亦说。圣道名正性。经说趣入正性离生故。何名邪性。谓有三种。一趣邪性。二业邪性。三见邪性。即是恶趣五无间业。五不正见如次为体。于二定者学无学法。五无间业如其次第。定趣离系地狱果故。成就此者得此聚名。即名为圣。造无间者。正脱已脱。烦恼缚故说名为圣。圣是自在离系缚义。或远众恶。故名为圣。获得毕竟离系得故。或善所趣。故名为圣。中无间隔。故名无间。好为此因故名为造。正邪定余名不定性。彼待二缘可成二故。非定属一得不定名

说一切有部显宗论卷第十五阿毗达磨藏显宗论卷第十六

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩缘起品第四之五

如是已辩有情世间器世间今当辩。颂曰

  安立器世间　　风轮最居下
  其量广无数　　厚十六洛叉
  次上水轮深　　十一亿二万
  下八洛叉水　　余凝结成金
  此水金轮广　　径十二洛叉
  三千四百半　　周围此三倍

论曰。此百俱胝四大洲界。如是安立同坏同成。谓诸有情法尔修得诸静虑故。下命终已生第二等静虑地中。下器世间三灾所坏。经久远已依下空中。由诸有情业增上力。有微风起。后后转增蟠结成轮。其体坚密。假设有一大诺健那。以金刚轮奋威悬击。金刚有碎风轮无损。如是风轮广无数。厚十六亿踰缮那。又诸有情业增上力。起大云雨澍风轮上。滴如车轴积水成轮。如是水轮于未凝结位。深十一亿二万踰缮那。广称风轮。有言狭小有情业力持令不散。如所食饮未熟变时。终不移流堕于熟藏。有余师说。由风所持令不傍流。如篅持谷。有情业力引别风起。搏击此水上结成金。如熟乳停上凝成膜。故水轮减。唯厚八洛叉。余转成金。厚三亿二万。二轮界别有百俱胝。一一二轮广量皆等。谓径十二亿三千四百半。周围其边数成三倍。谓周围量成三十六亿一万三百五十踰缮耶。已辩三轮。山今当辩。颂曰

  苏迷卢处中　　次踰健达罗
  伊沙驮罗山　　朅地洛迦山
  苏达黎舍那　　頞湿缚羯拏
  毗那怛迦山　　尼民达罗山
  于大洲等外　　有铁轮围山
  前七金所成　　苏迷卢四宝
  入水皆八万　　妙高出亦然
  余八半半下　　广皆等高量

论曰。于金轮上有九大山。妙高山王处中而住。余八周匝绕妙高山。于八山中前七名内。第七山外有大洲等。此外复有铁轮围山。周匝如轮围四洲界。持双等七唯金所成。妙高山王四宝为体。谓四面如次北东南西。金银吠琉璃颇胝迦宝。随宝威德色显于空。故赡部洲空似吠琉璃色。如是宝等从何而生。从诸有情业增上力。复大云起雨金轮上。滴如车轴。经于久时积水奔涛。深踰八万。猛风钻击宝等变生。如是变生金宝等已。复由业力引起别风简别宝等。摄令聚集。成山成洲。分水甘碱。令别成立内海外海。云何一类水别类宝等生。雨水能为异类宝等种所依藏。复为种种威德猛风之所钻击。生众宝等。故无有过。如是九山住金轮上。没水量皆等八万踰缮那。苏迷卢山出水亦尔。如是则说。妙高山王从下金轮上至其顶。总有十六万踰缮那。其余八山出水高量。从内至外半半渐卑。谓初持双出水四万。乃至最后铁轮围山出水三百一十二半。如是九山一一广量。各各与自出水量同。已辩九山。海今当辩。颂曰

  山间有八海　　前七名为内
  最初广八万　　四边各三倍
  余六半半狭　　第八名为外
  三洛叉二万　　三千二百余

论曰。妙高为初。轮围为后。中间八海。前七名内。七中皆具八功德水。一甘二冷三软四轻五清净六不臭七饮时不损喉八饮已不伤腹。如是七海。初广八万。约持双山内边周量。于其四面数各三倍。谓各成二亿四万踰缮那。其余六海量半半狭。谓第二海量广四万。乃至第七量广一千二百五十。此等不说周围量者。以烦多故。准前知故。第八名外。碱水盈满。量广三亿二万三千及二百八十七踰缮那半。八十七半余声所显。已辩八海。当辩诸洲形量有异。颂曰

  于中大洲相　　南赡部如车
  三边各二千　　南边有三半
  东毗提诃洲　　其相如半月
  三边如赡部　　东边三百半
  西瞿陀尼洲　　其相如满月
  径二千五百　　周围此三倍
  北洲如方座　　四面各二千
  中洲复有八　　四洲边各二

论曰。于外海中大洲有四。谓于四面对妙高山。南赡部洲。北广南狭三边量等。其相如车。南边唯广。三踰缮那半。三边各有二千踰缮那。唯此洲中有金刚座。上穷地际下据金轮。诸最后身菩提萨埵。将登无上正等菩提。皆坐此座上起金刚喻定。以无余依及余处所有坚固力能持此定。东胜身洲。东狭西广三面量等。形如半月。东三百五十。三边各二千。此东洲东边广南洲南际。故东如半月。南赡部如车。西牛货洲形如满月。径二千五百。周围七千半。北俱卢洲形如方座。四边量等。面各二千。周围八千踰缮那量。随自洲相人面亦然。复有八中洲。是大洲眷属。谓四大洲侧。各有二中洲。赡部洲边二中洲者。一遮末罗洲。二筏罗遮末罗洲。胜身洲边二中洲者。一提诃洲。二毗提诃洲。牛货洲边二中洲者。一舍搋洲。二嗢怛罗漫怛理拏洲。俱卢洲边二中洲者。一矩拉婆洲。二憍拉婆洲。此一切洲皆人所住。由下劣业增上所生。故住彼人身形卑陋。有余师说。遮末罗洲罗刹娑居。余皆人住。辩诸洲已。无热恼池何方几量。颂曰

  此北九黑山　　雪香醉山内
  无热池纵广　　五十踰缮那

论曰。至教说此赡部洲中。从中印度渐次向北。三处各有三重黑山。有大雪山在黑山北。大雪山北有香醉山。雪北香南有大池水。名无热恼。出四大河。从四面流趣四大海。一殑伽河。二信度河。三徙多河。四缚刍河。无热恼池纵广正等。面各五十踰缮那量。八功德水盈满其中。非得通人难至其所。于此池侧有赡部林。树形高大其果甘美。依此林故名赡部洲。或依此果以立洲号。复于何处置捺落迦。何量有几。颂曰

  此下过二万　　无间深广同
  上七奈落迦　　八增皆十六
  谓煻煨屎粪　　锋刃烈河增
  各住彼四方　　余八寒地狱

论曰。此赡部洲下过二万有阿鼻旨大奈落迦。深广同前。谓各二万。故彼底去此四万踰缮那。何缘唯此洲下有无间狱。唯于此洲起极重恶业故。刀兵等灾唯此有故。唯此洲人极利根故。以无乐间立无间名。所余地狱中。虽无异熟乐而无大过失。有等流乐故。有说无隙立无间名虽有情少而身大故。有说于中受苦无间。谓彼各为百钉钉身。于六触门恒受剧苦。居热铁地铁墙所围。猛焰交通曾无暂歇。身遭热逼苦痛难任。虽有四门远观开辟。而走求出便见关闭。所求不遂荼毒怨伤。以己身薪投赴猛火焚烧支体骨肉燋然。恶业所持而不至死。余七地狱在无间上重垒而住。其七者何。一者极热。二者炎热。三者大叫。四者号叫。五者众合。六者黑绳。七者等活。有说此七在无间傍。外内自他身诸支节。皆出猛火互相烧害。热中极故名为极热。火随身转炎炽周围。热苦难任故名炎热。剧苦所逼发大酷声。悲叫称怨故名大叫。众苦所逼异类悲号。怨发叫声故名号叫。众多苦具俱来逼身。合党相残故名众合。先以墨索拼量支体。后方斩锯故名黑绳。众苦逼身数闷如死。寻苏如本故名等活。谓彼有情虽遭种种斫刺磨捣。而彼暂遇凉风所吹寻苏如本。等前活故立等活名。八奈落迦增各十六。谓四门外各有四增。以非皆异名但标其定数。故薄伽梵说此颂言

  此八奈落迦　　我说甚难越
  以热铁为地　　周匝有铁墙
  四面有四门　　关闭以铁扇
  巧安布分量　　各有十六增
  多百踰缮那　　满中造恶者
  周遍焰交彻　　猛火恒洞燃

此十六中受苦增剧。过本地狱故说为增。或于此中受种种苦。苦具多类故说为增。或地狱中遍受苦已。重遭此苦故说为增。有说有情出地狱已。数复遭苦故说为增。门各四增其名何等。煻煨屎粪锋刃烈河。门门四增名皆相似。煻煨增者。谓此增中煻煨。没膝。其量宽广多踰缮那。有情游中才下其足。皮肉与血俱燋烂坠。举足还生平复如本。尸粪增者。谓此增中尸粪泥满。搓濑臭涩深没于人。又广于前煻煨增量。于中多有娘矩吒虫。[此/朿]利如针身白头黑。有情游彼皆为此虫钻皮破骨[口*(一/巾)]食其髓。锋刃增者。谓此增中复有三种。一刀刃路。谓于此中仰布刀刃以为大道。有情游彼才下足时。皮肉与血俱断碎坠。举足还生平复如本。二剑叶林。谓此林上纯以铦利剑刃为叶。有情游下风吹叶坠斩刺支体骨肉零落。有乌驳狗扑令僵仆。啮首咬足[齒*可]颈擘腴。爴腹掐心摣掣食啖。三铁刺。林谓此林内铁树高耸。量过百人。有利铁刺长十六指。有情被逼上下树时。其刺铦锋下上劖刺。有铁[此/朿]鸟探啄有情。眼精心肝争竞而食。刀刃路等三种虽殊而铁杖同。故一增摄。烈河增者。谓此增河其量深广。热碱烈水盈满其中。有情溺中。或浮或没。或逆或顺或横或转。被蒸被煮骨皮糜烂。如大镬中满盛灰汁。置麻米等猛火下燃。麻等于中上下回转。举体糜烂有情亦然。设欲逃亡。于两岸上有诸狱卒。手执刀枪御捍令回。无由得出。复有狱卒张大铁网。漉诸有情置于岸上。洋铜灌其口令吞热铁丸。众苦备经还掷河内。此河如堑前三似园。围绕庄严诸大地狱。已说有八热奈落迦。寒奈落迦亦有八种。何等为八。一頞部陀。二尼剌部陀。三頞哳吒。四曤臛婆。五呼呼婆。六嗢钵罗。七钵特摩。八摩诃钵特摩。此中有情严寒所逼。随身声疮变立差别想名。谓二三三如其次第。此寒地狱在绕四洲轮围山外极冥闇所。于中恒有凄劲冷风。上下冲击纵横旋拥。有情游此屯聚相依。寒酷切身肤皮疱裂。身战僵鞕各出异声。疮开剖坼如三花相。多由谤贤圣招如是苦果。有说此在热地狱傍。以赡部洲上尖下阔形如谷聚故得包容。是故大海渐深渐狭。十六大狱皆诸有情增上业感。余孤地狱或多二一各别业招。或近江河山间旷野。或在地下空中余处。无间大热及炎热三。于中皆无狱卒防守。大叫号叫及众合三。少有狱卒。琰魔王使时时往来巡捡彼故。其余皆为狱卒防守。有情无情异类狱卒。防守治罚罪有情故。火不焚烧。有情卒者。彼身别禀异大种故。或由业力所遮隔故。一切地狱身形皆竖。初同圣语。曾闻有以圣语告言。汝在人中不观欲过。又不承敬梵志沙门。是故于今受斯剧苦。彼闻领解生惭悔心。后不分明。苦所逼故。诸地狱器安布如是。傍生所止谓水陆空。生类显形无边差别。其身行相少竖多傍。本住海中后流五趣。初同圣语后渐乖讹。诸鬼本住琰魔王国。从此展转散趣余方。此赡部洲南边直下。深过五百踰缮那量。有琰魔王都。纵广量亦尔。鬼有三种谓无少多财无财复三。谓炬针臭口。少财亦有三。谓针臭毛瘿多财亦有三。谓希祠弃大势广释此。九如顺正。理然诸鬼中无威德者唯三洲有。除北俱卢。若有威德天上亦有。赡部洲西渚有五百。于中有二唯鬼所居。渚各有城。二百五十。有威德鬼住一渚城。一渚城居无威德鬼。诸鬼多分行竖而行。于劫初时皆同圣语。后随处别种种乖讹。日月所居量等义者。颂曰

  日月迷卢半　　五十一五十
  夜半日没中　　日出四洲等
  雨际第二月　　后九夜渐增
  寒第四亦然　　夜减昼翻此
  昼夜增腊缚　　行南北路时
  近日自影覆　　故见月轮缺

论曰。日月众星依何而住。依风而住。谓诸有情业增上力共引风起。绕妙高山空中旋环。运持日等令不停坠。彼所住去此几踰缮那。持双山顶齐妙高山半。日等径量几踰缮那。日五十一。月唯五十。星最小者半俱卢舍。最大者。十六踰缮那。四洲日月各有别耶。不尔。四洲同一日月俱时四处作所作耶。不尔。云何夜半日没日中日出四洲时等。俱卢赡部牛货胜身隔妙高山相对住故。若俱卢夜半即赡部日中。胜身日没牛货日出。若牛货日中即胜身夜半。赡部日没俱卢日出。此略义者。随何洲相对日中月中。余二洲随应西没东出。第三洲处夜中昼中。由是若时胜身牛货如其次第日中月中。尔时光明四洲皆有。然光作事在东南洲。于西北洲唯明作事。俱见两事在北南洲。谓赡部洲。见日出月没。见月出日没。谓俱卢洲。东胜身洲。唯得见日唯得见月。谓牛货洲。如是所余例应思择。何缘昼夜有减有增。日行此洲路有别故。从雨际第二月后半第九日夜渐增。从寒际第四月后半第九日夜渐减。昼增减位与此相违。夜渐增时昼便渐减。夜渐减位昼即渐增。昼夜增时。一昼夜增几增一腊缚昼。夜减亦然。日行此洲向南向北。如其次第夜增昼增。何故月轮于黑半末白半初位见有缺耶。世施设中作如是释。以月宫殿行近日轮。月被日轮光所侵照。余边发影自覆月轮。令于尔时见不圆满。理必应尔。以于尔时亦见不明全月轮故。由是日没月便出时。相去极遥。见月圆满日等宫殿。何有情居四大王天所部天众是诸天众。唯住此耶。若空居天唯住如是日等宫殿。若地居天住妙高山。诸层级等有几层。级其量云。何何等诸天住何层。级颂曰

  妙高层有四　　相去各十千
  傍出十六千　　八四二千量
  坚手及持鬘　　恒憍大王众
  如次居四级　　亦住余七山

论曰。苏迷卢山有四层级。始从水际尽第一层。相去十千踰缮那量。如是乃至从第三层。尽第四层亦十千量。此四层级。从妙高山傍出围绕。尽其下半。最初层级出十六千。第二第三第四层级。如其次第八四二千。住初层天名为坚手。持鬘居第二。恒憍处第三。四大天王及诸眷属。各一方面住第四层。坚手等三天皆四王众摄。持双山等七金山上。亦有四王所部村邑。是名依地住四大王众天。于欲天中此天最广。三十三天住在何处。颂曰

  妙高顶八万　　三十三天居
  四角有四峰　　金刚手所住
  中宫名善见　　周万踰缮那
  高一半金城　　杂饰地柔软
  中有殊胜殿　　周千踰缮那
  外四苑庄严　　众车粗杂喜
  妙地居四方　　相去各二十
  东北圆生树　　西南善法堂

论曰。三十三天住迷卢顶。其顶四面各二十千。若据周围数成八万。有余师说。面各八十千与下际四边其量无别。山顶四角各有一峰。其高广量各有五百。有药叉神名金刚手。于中止住守护诸天。于山顶中有宫名善见。面二千半。周万踰缮那。金城量高一踰缮那半。其地平坦。亦真金所成。俱用百一杂宝严饰。地触柔软如妒罗绵。于践蹑时随足高下。是天帝释所都大城。城有千门严饰壮丽门有五百青衣药叉。勇健端严踰缮那量。各严铠仗防守城门。于其城中有殊胜殿。种种妙宝具足庄严。蔽余天宫故名殊胜。面二百五十。周千踰缮那。是谓城中诸可爱事。城外四面四苑庄严。是彼诸天共游戏处。一众车苑。谓此苑中随天福力种种车现。二粗恶苑。天欲战时随其所须甲仗等现。三杂林苑。诸天入中所玩皆同俱生胜喜。四喜林苑。极妙欲尘杂类俱臻历观无厌。如是四苑形皆畟方。一一周千踰缮那量。居中各有一如意池。面各五十踰缮那量。八功德水弥满其中。随欲妙花宝舟好鸟。一一奇丽种种庄严。四苑四边有四妙地。中间各去苑二十踰缮那。地一一边量皆二百。是诸天众胜游戏所。诸天于彼捔胜欢娱。城外东北有圆生树。是三十三天受欲乐胜所。蟠根深广五十踰缮那。耸干上升枝条傍布。高广量等百踰缮那。挺叶开花妙香芬馥顺风薰满百踰缮那。若逆风薰犹遍五十。城外西南角有大善法堂。三十三天时集详辩。制伏阿素洛等如法不如法事。如是已辩三十三天所居外器。余有色天众所住器云何。颂曰

  此上有色天　　住依空宫殿

论曰。从夜摩天至色究竟。所住宫殿皆但依空。有说空中密云弥布如地。为彼宫殿所依外器。世间至色究竟上无色故不可施设。如是所说诸天众中。颂曰

  六受欲交抱　　执手笑视淫

论曰。梵众天等由对治力。于诸欲法皆已远离。唯六欲天受妙欲境。六欲天者。一四大王众天。谓彼有四大王及所领众。或彼天众事四大王。是四大王之所领故。二三十三天。谓彼天处是三十三部诸天所居。妙高山顶四面各有八部天众。中央有一。即天帝释。故三十三。三夜摩天。谓彼天处时时多分称快乐哉。四睹史多天。谓彼天处多于自所受生喜足心。五乐变化天。谓彼天处乐数化欲境于中受乐。六他化自在天。谓彼天处于他所化欲境自在受乐。六中初二依地居天。形交成淫与人无别。然风气泄热恼便除。非如人间有余不净。夜摩天众才抱成淫。俱起染心暂时相抱。热恼便息。唯一起染。虽受抱乐而不成淫。若俱无染心。虽相执抱如亲相敬爱。而无过失。睹史多天但由执手热恼便息。乐变化天唯相向笑便除热恼。他化自在相视成淫。如是后三俱一无染。成淫乐爱差别如前。后二天中唯化资具。若异此者俱染不成。实并形交方成淫事。施设所说显时不同。由上诸天欲境转妙。贪心转重身触有殊。故经少时数成淫事。不尔天欲乐应少于人中。随彼诸天男女膝上。有童男童女欻尔化生。即说为彼天所生。男女初生天众身量云何颂曰

  初如五至十　　色圆满有衣

论曰。且六欲诸天。初生如次。如五六七八九十岁。人生己身形速得圆满。色界天众于初生时。身量周圆具妙衣服。一切天众皆作圣言。谓彼言词同中印度。然不由学自解典言。欲生乐生云何差别。颂曰

  欲生三人天　　乐生三九处

论曰。欲生三者。有诸有情乐受现前诸妙欲境。彼于如是现欲境中自在而转。谓全人趣及下四天。有诸有情乐受自化诸妙欲境。彼于自化妙欲境中自在而转。谓唯第五乐变化天。有诸有情乐受他化诸妙欲境。彼于他化妙欲境中自在而转。谓第六他化自在天。此欲生三依何建立。依受如生现前欲境故。依受如乐自化欲境故。依受如乐他化欲境故。又依所受下中上境故。又依受用有罪有劳现前欲境故。依乐受用无罪有劳自化欲境故。依乐受用无罪无劳他化欲境故。乐生三者。三静虑中于九处生受三种乐。以彼所受有乐异熟无苦异熟。故名乐生。此乐生三依何建立。依多安住离生喜乐定生喜乐离喜乐故。或依三种灾所及故。或依寻喜乐增上故。或依身想异无异故。所说诸天二十二处。上下相去其量云何。颂曰

  如彼去下量　　去上数亦然

论曰。一一中间踰缮那量。非易可数。但可总举。彼去下量去上例然。随从何天去下海量。彼上所至与去下同。谓妙高山从第四层级去下大海四万踰缮那。上去三十三天亦如去下海量。如三十三天去下大海。上去夜摩天其量亦尔。如是乃至。如善见天去下大海。从彼上去色究竟天其量亦尔。如是悬远多踰缮那。如明眼人暂见色顷。世尊能以意势神通运。身往来自在无碍。故佛神力不可思。议。于下处生升上见不。颂曰

  离通力依他　　下无升见上

论曰。如四大王天众升见三十三天。非三十三等天升见夜摩天等。然彼若得定所发通。一切皆能升见于上。或依他力升见上天。谓得神通及上天众。引接往彼随其所应。或上天来下亦能见。若上界地来向下时。非下化身下眼不见。非其境界故。如不觉彼触故。上界地来向下时。必化下身为令下见。依地居天已说处量。夜摩天等处量云何。有说四天如迷卢顶。有说此四上倍倍增。有余师言。初静虑地宫殿依处等一四洲。第二静虑等小千界。第三静虑等中千界。第四静虑等大千界。有余师言。下三静虑如次量等小中大千。第四静虑量无边际。齐何量说小中大千。颂曰

  四大洲日月　　苏迷卢欲天
  梵世各一千　　名一小千界
  此小千千倍　　说名一中千
  此千倍大千　　皆同一成坏

论曰。千四大洲乃至梵世。如是总说为一小千。千倍小千名一中千界。千中千界总名一大千。如是大千同成同坏。中有情类成坏亦同

说一切有部显宗论卷第十六阿毗达磨藏显宗论卷第十七

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩缘起品第四之六

如外器量别。身量亦尔耶。亦尔云何。颂曰

  赡部洲人量　　三肘半四肘
  东西北洲人　　倍倍增如次
  欲天俱卢舍　　四分一一增
  色天踰缮那　　初四增半半
  此上增倍倍　　唯无云减三

论曰。赡部洲人身多长三肘半。于中少分有长四肘。东胜身人身长八肘。西牛货人长十六肘。北俱卢人三十二肘。欲界六天最下身量。一俱卢舍四分之一。如是后后一一分增。至第六天身一俱卢舍半。色天身量初梵众天半踰缮那。梵辅全一。大梵一半。少光二全。此上余天皆增倍倍。唯无云减三踰缮那。谓无量光天倍增二至四。乃至色究竟增满万六千。身量既殊寿命别不。亦有云何。颂曰

  北洲定千年　　西东半半减
  此洲寿不定　　后十初叵量
  人间五十年　　下天一昼夜
  乘斯寿五百　　上五倍倍增
  色无昼夜殊　　劫数等身量
  无色初二万　　后后二二增
  少光上下天　　大全半为劫

论曰。北俱卢人定寿千岁。西牛货人寿五百岁。东胜身人寿二百五十岁。南赡部人寿无定限。劫后增减或少或多。少极十年。多极八万。于劫初位人寿叵量。非百千等所能计故。已说人间寿量长短。要先建立天上昼夜。方可算计天寿。短长。天上云何建立昼夜。人五十岁为六天中最在下天一昼一夜。乘斯昼夜。三十日为月。十二月为岁。彼寿五百年。上五欲天渐俱增倍。谓人百岁为第二天一昼一夜。乘斯昼夜成月及年。彼寿千岁。夜摩等四随次如人。二四八百千六百岁为一昼夜。乘斯昼夜成月及年如次。彼寿二四八千万六千岁。已说六天寿量长短。色天无有昼夜差别。但以劫数知寿短长。彼劫寿短长与身量数等。谓若身量半踰缮那。寿量半劫。若彼身量一踰缮那。寿量一劫。乃至身量长万六千。寿量亦同万六千劫。已说色界天寿短长。无色四天从下如次。寿量二四六八万劫。上所说劫为定依何。为坏为成为中为大。少光已上大全为劫。自下诸天大半为劫。即由此故说大梵王过梵辅天寿一劫半。空成住坏各二十中总八十中为一大劫。取成住坏总六十中。为大梵王一劫半寿。故以大半四十中劫。为下三天所寿劫量。已说善趣寿量短长。恶趣云何。颂曰

  等活等上六　　如次以欲天
  寿为一昼夜　　寿量亦同彼
  极热半中劫　　无间中劫全
  傍生极一中　　鬼月日五百
  頞部陀寿量　　如一婆诃麻
  百年除一尽　　后后倍二十

论曰。恶趣亦无如人昼夜。然其寿量比况可知。四大王等六欲天寿。如其次第为等活等六奈落迦一昼一夜。寿量如次亦同彼天。谓四大王寿量五百。于等活地狱为一昼一夜。乘此昼夜成月及年。以如是年彼寿五百。乃至他化寿万六千。于炎热地狱为一昼一夜。乘此昼夜成月及年。彼寿如斯万六千岁。极热地狱寿半中劫。无间地狱寿一中劫。傍生寿量多无定限。若寿极长亦一中劫。谓难陀等诸大龙王。故世尊言。大龙有八。皆住一劫能持大地。鬼以人间一月为一日。乘此成月岁。寿五百年。寒那落迦云何寿量。世尊寄喻显彼寿言。如此人间佉梨二十。成摩竭陀国一麻婆诃量。有置苣蕂平满其中。设复有能百年除一。如是苣蕂易有尽期。生頞部陀寿量难尽。此二十倍为第二寿。如是后后二十倍增。是谓八寒地狱寿量。此诸寿量有中夭耶。颂曰

  诸处有中夭　　除北俱卢洲

论曰。诸处寿量皆有中夭。唯北俱卢定寿千岁。此约处说非别有情。有别有情不中夭故。如顺正理举彼有情。如是已就踰缮那等。辩器世间身量差别。就年等辩寿量有殊。二量不同未说应说。建立此等无不依名。前二及名未详极少。今应先辩三极少量。颂曰

  极微字刹那　　色名时极少

论曰。以胜觉慧分析诸色至一极微。故一极微为色极少。不可析故。如是分析诸名及时。至一字刹那。为名时极少。一字名者如说掉名。一刹那量如顺正理。如是已辩三极少量。前二量殊今次应辩。踰缮那等其量云何。颂曰

  极微微金水　　兔羊牛隙尘
  虮虱麦指节　　后后增七倍
  二十四指肘　　四肘为弓量
  五百俱卢舍　　此八踰缮那

论曰。极微为初。指节为后。应知后后皆七倍增。谓七极微为一微量。积微至七为一金尘。积七金尘为水尘量。水尘积至七为一兔毛尘。积七兔毛尘为羊毛尘量。积羊毛尘七为一牛毛尘。积七牛毛尘为隙游尘量。隙尘七为虮。七虮为一虱。七虱为穬麦。七麦为指节。三节为指。世所极成。是故于颂中不别分别。二十四指横布为肘。竖积四肘为弓。谓寻竖积五百弓为一俱卢舍。毗奈耶说。此是从村至阿练若中间道量。八俱卢舍为踰缮那。已说极微渐次积集成微。乃至一踰缮那。然许极微略有二种一实二假。其相云何。实谓极成色等自相。于和集位。现量所得。假由分析比量所知。谓聚色中以慧渐析。至最极位。然后于中辩色声等极微差别。此析所至名假极微。令慧寻思极生喜故。此微即极。故名极微。极谓色中析至究竟。微谓唯是慧眼所行。故极微言显微极义。以何为证知有极微。以阿笈摩及理为证。阿笈摩者。谓契经说。诸所有色或细或粗。细者谓极微。更不可析故。余有对色说名为粗。又伽他言

  黑白等诸色　　皆有细有粗
  细者谓最微　　粗者谓对色

由此诚证定有极微。又毗奈耶作如是说。七极微集名一微等。如是名教。其理者何。谓如积集有情身色。至色究竟有量最粗。准此亦应分析诸色。有究竟处名一极微。云何知尔。以何析法分析至穷。犹有余故。谓世现见。以余聚色析余聚色。有细聚生析析至穷。犹有余分。可为眼见更不可析。如是聚色不能析处。亦如粗聚有可析理。谓彼可以觉慧分析。如以聚色析聚至穷。慧析至穷应有余在。可为慧见更不可析。此余在者即是极微。是故极微其体定有。此若无者聚色应无。聚色必由此所成故。如是已说踰缮那等。应辩年等。其量云何。颂曰

  百二十刹那　　为怛刹那量
  腊缚此六十　　此三十须臾
  此三十昼夜　　三十昼夜月
  十二月为年　　于中半减夜

论曰。刹那百二十为一怛刹那。六十怛刹那为一腊缚。三十腊缚为一牟呼栗多。三十牟呼栗多为一昼夜。此昼夜有时增有时减有时等。三十昼夜为一月。总十二月为一年。于一年中分为三际。谓寒热雨。各有四月。十二月中六月减夜。以一年内夜总减六。如是已辩刹那至年。劫量不同。今次当辩。颂曰

  应知有四劫　　谓坏成中大
  坏从狱不生　　至外器都尽
  成劫从风起　　至地狱初生
  中劫从无量　　减至寿唯十
  次增减十八　　后增至八万
  如是成已住　　名中二十劫
  成坏坏已空　　时皆等住劫
  八十中大劫　　大劫三无数

论曰。言坏劫者。谓从地狱有情不复生至外器都尽。坏有二种。一趣坏。二界坏。复有二种。一有情坏。二外器坏。然坏与成总分四品一者正坏。二坏已空。三者正成。四成已住。言正坏者。谓此世间过于二十中劫住已。从此复有等住二十坏劫便至。坏劫将起住此洲人寿量八万。若时地狱有情命终。无复新生为坏劫始。乃至地狱无一有情。尔时名为地狱已坏。诸有地狱定受业者。业力引置他方狱中。由此准知傍生鬼趣。时人身内无有诸虫。与佛身同傍生坏故。有说二趣于人益者。坏与人俱。余者先坏。如是二说前说为善。若时人趣此洲一人。无师法然得初静虑。从静虑起唱如是言。离生喜乐甚乐甚静。余人闻已皆入静虑。命终并得生梵世中。乃至此洲有情都尽。是名已坏赡部洲人。广西二洲例此应说。北洲命尽生欲界天。由彼钝根无离欲故。生欲天已静虑现前。转得胜依方能离欲。乃至人趣无一有情。尔时名为人趣已坏。若时天趣欲界六天。随一法然得初静虑。乃至并得生梵世中。尔时名为欲天已坏。如是欲界无一有情。名欲界中有情已坏。若时梵世随一有情。无师法然得二静虑。从彼定起唱如是言。定生喜乐甚乐甚静。余天闻已皆入彼静虑。命终并得生极光净天。乃至梵世中有情都尽。如是名已坏有情世间。唯器世间空旷而住。余方世界一切有情。感此三千世界业尽。此边渐有七日轮现。诸海干竭众山洞燃。洲渚三轮并从焚燎。风吹猛焰烧上天宫。乃至梵宫无遗灰烬。自地火焰烧自地宫。非他地灾能坏他地。由相引起故作是言。下火风飘焚烧上地。谓欲界火猛焰上升。为缘引生色界火焰。余灾亦尔。如应当知。如是始从地狱渐减乃至器尽。总名坏劫。所言成劫。谓从风起。乃至地狱始有情生。谓此世间灾所坏已。二十中劫唯有虚空。过此长时次应复有。等住二十成劫便至。一切有情业增上力。空中渐有微细风生。是器世间将成前相。风渐增盛成立如前。所说风轮水金轮等。然初成立大梵天宫。乃至夜摩宫后起风轮等。是谓成立外器世间。器有坏成由有情力。若有情类久集上天。此器世间必应渐起。令福减者散下居故。谓极光净久集有情。天众既多居处迫迮。诸福减者应散下居。此器世间理应先起。故劫坏位有情上集。于劫成时有情下散。由罪福减及福罪增集散旋环。理应如是。既已成立此器世间。初一有情极光净殁生大梵处空宫殿中。后诸有情亦从彼殁有生梵辅。有生梵众。有生他化自在天宫。渐渐下生乃至人趣。俱卢牛货胜身赡部。后生饿鬼傍生地狱。法尔后坏必最初成。若初一有情生无间狱。二十中成劫应知已满。此后复有二十中劫。名成已住次第而起。谓从风起造器世间。乃至后后有情渐住。初一有情极光净殁生大梵宫者。即为大梵王。诸大梵王必异生摄。以无圣者还生下故。上二界无入见道故。即由此故无。一有情无间二生为大梵义。既说大梵最后命终。极光净天寿八大劫。二十中劫世界还成。如何梵王生极光净受少寿量还从彼殁。虽彼非无有中夭义。而广大福方生彼天。八大劫寿中。始经少分。二十中劫顷宁即命终。以此观知余来生此。此洲人寿经无量时。至住劫初寿方渐减。从无量减至极十年。即名为初一住中劫。此后十八皆有增减。谓从十年增至八万。复从八万减至十年。尔乃名为第二中劫。次后十七例皆如是。于十八后。从十岁增至极八万岁。名第二十劫。一切劫增无过八万。一切劫减唯极十年。十八劫中一增一减。时量方等初减后增。故二十劫时量皆等。此总名为成已住劫。所余成劫及坏已空。虽无减增二十差别。然由时量与住劫同。准住各成二十中劫。成中初劫起器世间。后十九中有情渐住。坏中后劫灭器世间前十九中有情渐舍。如是所说成住坏空。各二十中积成八十。总此八十成大劫量。诸劫唯用五蕴为体。除此时体。不可得故。经说三劫阿僧企耶精进修行得成佛者。于前所说四种劫中。积大劫成三劫无数。谓从初种大菩提种。经三大劫阿僧企耶。方乃得成大菩提果。既称无数。何复言三。有释此言。诸善算者依算计论。算至数穷初不能知。名一无数。如是无数积至第三。余复释言。六十数内别有一数。立无数名。谓有经中说六十数。此言无数当彼一名。积此至三名三无数。非诸算计不能数知。菩萨经斯三劫无数。方乃证得无上菩提。如是已辩劫量差别。诸佛独觉出现世间。为劫增时。为劫减位颂曰

  减八万至百　　诸佛现世间
  独觉增减时　　麟角喻百劫

论曰。从此洲人寿八万岁。渐减乃至寿极百年。于此中间诸佛出现。何缘增位无佛出耶。有情乐增难教厌故。多行妙行故。少有堕三涂。减百年时何故无佛。见于如是寿短促时。不能具成佛所作故。谓一切佛出现世间。决定舍于第五分寿。从定所起命行依身。非于尔时所化乐见以设出世为佛事少。故于尔时佛不出世。经主于此作是释言。五浊极增难可化故。岂不今世人减百年。五浊虽增而有能办。入正决定离欲得果。佛唯为此出现世间。故彼所言非为善释。非百年位佛出世时。一切皆能遵崇圣教。入正决定离欲得果。可言减百一分不能办斯佛事。故无佛出。然于减百设佛出世。亦有一分能遵教等如百年时。佛何不出。若谓减百堪化有情。以极少故佛不出者。是则应说前所立因。不能具成佛所作故。虽于减百五浊极增。不能具成佛所作事。由斯故佛不出世间。不出亲因非彼所说。言五浊者一寿浊。二劫浊。三烦恼浊。四见浊。五有情浊。云何浊义。极鄙下故。应弃舍故。如滓秽故。岂不寿劫有情浊三互不相离。见浊即用烦恼为体。五应不成理实应然。但为次第显五衰损极增盛时。何等名为五种衰损。一寿命衰损。时极短故。二资具衰损。少光泽故。三善品衰损。欣恶行故。四寂静衰损。展转相违成諠诤故。五自体衰损。非出世间功德器故。为欲次第显此五种衰损不同。故分五浊。独觉出现通劫增减。然诸独觉有二种殊。一者部行。二麟角喻。部行独觉先是声闻。得胜果时转名独胜。有余说彼先是异生。曾修声闻顺决择分。今自证道得独胜名。麟角喻者。谓必独出二独觉中麟角喻者。要百大劫修菩提资粮。然后方成。麟角喻独觉。部行独觉。修因时量减百大劫。时无定限。言独觉者。谓现身中离禀至教。唯自悟道以能自调。不调他故。何缘独觉言不调他。非彼无能演说正法以彼亦得无碍解故。又能忆念过去所闻诸佛言词堪为他说。得极远境宿住智故。又不可说彼无慈悲。为摄有情现神通故。又不可说无受教机。尔时有情亦有能起世间离欲对治道故。虽有此理而今测量。彼知尔时有情根欲。入见谛等不藉他教。故不说法以调伏他。除此所余摄有情事。无劳设教现通即成。又诸独觉阙力无畏。对于我论坚执众中。欲说无我心便怯劣。故不说教以调伏他。轮王出世为在何时。几种几俱何威何相。颂曰

  轮王八万上　　金银铜铁轮
  一二三四洲　　逆次独如佛
  他迎自往伏　　诤阵胜无害
  相不正明圆　　故与佛非等

论曰。从此洲人寿无量岁。乃至八万岁有转轮王生。减八万时有情富乐寿量损减非其器故。王由轮宝旋转应导威伏一切。名转轮王。施设足中说有四种。金银铜铁轮应别故。如其次第胜上中下。逆次能王领一二三四洲谓铁轮王王一洲界。铜轮王二。银轮王三。若金轮王王四洲界。契经就胜但说金轮故契经言。若王生在刹帝利种绍洒顶位。于十五日受斋戒时。沐浴首身受胜斋戒。升高堂殿臣僚毂翼。东方欻有金轮宝现。其轮千辐具足毂辋。众相圆净非匠所。成舒妙光明来应王所。此王定是转金轮王。转余轮王。应知亦尔。轮王如佛无二俱生。故契经言。无处无位非前非后。有二如来应正等觉出现于世。有处有位唯一如来。如说如来。轮王亦尔。应审思择此唯一言。为据一三千。为约一切界。应说一切界无差别言故谓无经说唯此世间。又无经言唯一世界。如何不说而能定知。唯据一三千。非约一切界。若尔何故梵王经说。我今于此三千大千诸世界中得自在转。彼有密意。谓若世尊不起加行唯能观此三千大千。若时世尊发起加行。无边世界皆天眼境。天耳通等例此应知。若不许然佛于余界何缘无有自在化能为阙大悲为智有碍。阙大悲者。经不应言。如来悲心普覆一切。智有碍者。经不应言。无一尔焰佛智不转。若佛智悲遍于一切无碍无阙。则应说法普能济度一切有情。无边界中如来皆有不思议力能普化故。余广决择如顺正理。如是所说四种轮王威定诸方亦有差别。谓金轮者。诸小国王各自来迎作如是请。我等国土宽广丰饶。安隐富乐多诸人众。唯愿天尊亲垂教敕。我等皆是天尊翼从。若银轮王。自往彼土威严近至彼方臣伏。若铜轮王。至彼国已宣威竞德彼方推胜。若铁轮王。亦至彼国现威列阵克胜便止。一切轮王皆无伤害。令伏得胜已各安其所居劝化令修十善业道。故轮王死多得生天。经说轮王出现于世。便有七宝出现世间。如是轮王非唯有七宝与余王别。亦有三十二大士相殊。若尔轮王与佛何异。佛大士相处正明圆。王相不然故有差别。言处正者。谓于佛身众相无偏。得其所故。言明了者。谓于佛身相极分明能夺意故。言圆满者。谓于佛身众相周圆无缺减故。劫初人众为有王无。颂曰

  劫初如色天　　后渐增贪味
  由惰贮贼起　　为防雇守田

论曰。劫初时人皆如色界。极光净没来生人间。经于久时渐有王出。故契经说。劫初时人有色意成。支体圆满诸根无缺。形色端严身带光明。腾空自在饮食喜乐。长时久住。有如是类地味渐生。其味甘美其香郁馥时有一人禀性耽味。嗅香起爱取尝便食。余人随学竞取食之。尔时方名初受段食。资段食故身渐坚重。光明隐没黑闇便生。日月众星从兹出现。由渐耽味地味便隐。从斯复有地皮饼生。竞耽食之。地饼复隐。尔时复有林藤出现。竞耽食故林藤复隐。有非耕种香稻自生。众共取之以充所食。此食粗故残秽在身。为欲蠲除便生二道。因斯遂有男女根生。由二根殊形相亦异。宿习力故。相视遂生非理作意行非梵行。人中欲鬼初发此时。尔时诸人。随食早晚随取香稻。无所贮积。后时有人禀性懒堕。长取香稻贮拟后食。余人随学渐多停贮。由此于稻生我所心。各纵贪情多收无厌。故随收处无复再生。遂共分田虑防远尽。于己田分生吝护心。于他分田有怀侵夺。劫盗过起始于此时。为欲遮防共聚详议铨量众内一有德人。各以所收六分之一。雇令防护封为田主。因斯故立刹帝利名。大众钦承恩流率土。故复名大三末多王。自后诸王此王为首。时人或有情厌居家。乐在空闲精修戒行。因斯故得婆罗门名。后时有王贪吝财物。不能均给国土人民。故贫匮人多行贼事。王为禁止行轻重罚。为杀害业始于此时。时有罪人心怖刑罚。覆藏其过异想发言。虚诳语生此时为首。于劫减位有小三灾。其相云何。颂曰

  业道增寿减　　至十三灾现
  刀疾饥如次　　七日月年止

论曰。从诸有情起虚诳语。诸恶业道后后转增。故此洲人寿量渐减。乃至极十小三灾现。故诸灾患二法为本。一贪美食。二性懒堕。此小三灾中劫未起。三灾者。一刀兵。二疾疫。三饥馑。谓中劫末十岁时人。为非法贪染污相续。不平等爱映蔽其心。邪法萦缚嗔恚增上。相见便起猛利害心。如今猎师见野禽兽。随手所执皆成利刀。各骋凶狂互相残害。又中劫末十岁时人。由具如前诸过失故。非人吐毒疾疫流行。遇辄命终难可救疗。又中劫末十岁时人。亦具如前诸过失故。天龙忿责不降甘雨。由是世间久遭饥馑。既无支济多分命终。若有人能一日一夜持不杀戒。以一药物起殷净心奉施僧众。以一抟食奉施众僧。决定不逢此三灾起。此三灾起各经几时。刀兵灾起极唯七日。疾疫灾起七月七日。饥馑七年七月七日。度此便止人寿渐增。东西二洲有似灾起。谓嗔增盛身力羸劣数加饥渴。北洲总无。何等名为大三灾相。颂曰

  三灾火水风　　上三定为顶
  如次内灾等　　四无不动故
  然彼器非常　　情俱生灭故
  要七火一水　　七水火后风

论曰。此大三灾逼有情类。令舍下地集上天中。初火灾兴由七日现。有说如是七日轮行。犹如雁行分路旋运。有说如是七日轮行。上下为行分路旋运。中间各相去五千踰缮那次水灾兴由降瀑雨。有作是说。从三定边空中欻然雨热灰水。有余复说。从下水轮起沸涌水上腾漂浸。如实义者。即此边生后风灾兴由风相击。有作是说。从四定边空中欻然飘击风起。有余复说。从下风轮起冲击风上腾飘鼓。此如实义。准前应知。若此三灾坏器世界。乃至无有细分为余。后粗物生谁为种子。岂不即以前灾顶风为缘引生风为种子。或先所说。由诸有情业所生风能为种子。风中具有种种细物。为同类因引粗物起。或诸世界坏非一时。有他方风具种种德来此为种。亦无有过。故化地部契经中言。风从他方飘种来此。如先所说前灾顶风。此中何灾。以何为顶。火水风如次上三定为顶。故世尊说。灾顶有三。若时火灾焚烧世界。以极光净为此灾顶。若时水灾浸烂世界。以遍净天为此灾顶。若时风灾飘散世界。以广果天为此灾顶。随何灾力所不及处。即说名为此灾之顶。何缘下三定遭火水风灾初二。三定中内灾等彼故。谓初静虑寻何为内灾。能烧恼心等外火灾。故第二静虑喜受为内灾。与轻安俱润泽如水故。遍身粗重由此皆除故。经说苦根第二静虑灭。以说内心喜得身轻安故。此地喜盛。余地所无。故外水灾极至于此。第三静虑动息为内灾。息亦是风等外风灾。故若入此静虑有如是内灾生。此静虑中遭是外灾坏。故初静虑内具三灾。外亦具遭三灾所坏。第二静虑内有二灾。故外亦遭二灾所坏。第三静虑内唯一灾。故外但遭一灾所坏。第四静虑无有外灾。以彼定无内灾患故。由此佛说。彼名不动。内外三灾所不及故。若尔彼地器应是常。不尔与有情俱生俱灭故。谓彼天处无总地形。但如众星居处各别。有情于彼生时死时。所在天宫随起随灭。是故彼器体亦非常。所说三灾云何次第。要先无间起七火灾。其次定应一水灾起。此后无间复七火灾。度七火灾还有一水。如是乃至满七水灾。复七火灾后风灾起。如是总有八七火灾一七水灾一风灾起。水风灾起皆从火灾。从水风灾必火灾起。故灾次第理必应然。何缘七火方一水灾。极光净天寿势力故。谓彼寿量极八大劫。故至第八方一水灾。由此应知要度七水八七火后乃一风灾。由遍净天寿势力故。谓彼寿量六十四劫。故第八火方一风灾。如诸有情修定渐胜。所感异熟身寿渐长。由是所居亦渐久住。外由内感理必应然

说一切有部显宗论卷第十七阿毗达磨藏显宗论卷第十八

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩业品第五之一

此中一类随顺造恶。怯难论者作如是言。如上所陈。诸内外事多种差别非业为因。现见世间果石等物众多差别无异因故。谓从一种有多果生。无种为先有石等异。为对彼执故立宗言。颂曰

  世别由业生　　思及思所作
  思即是意业　　所作谓身语

论曰。定由有情净不净业。诸内外事种种不同。云何知然。见业用故。谓世现见爱非爱果。差别生时定由业用。如农夫类由勤正业有稼穑等可爱果生。有诸愚夫行盗等业。便招非爱杀缚等果。复见亦有从初处胎不由现因有乐有苦。既见现在要业为先。方能引得爱非爱果。知前乐苦必业为先。故非无因。诸内外事自然而有种种差别。别所由业其体是何。谓心所思及思所作。故契经说。有二种业。一者思业。二思已业。思已业者。谓思所作。即是由思所等起义。应知思者即是意业。思所作者即身语业。如是二业于契经中。世尊说为三。谓身语意业。如是三业随其次第。由所依自性等起故建立。此中已说意业自性。谓即是思。思如前辩。身语二业自性云何。颂曰

  此身语二业　　俱表无表性

论曰。应知如是所说诸业中。身语二业俱表无表性。故本论言。云何身业谓身所有。表及无表。云何语业谓语所有表及无表。复有何缘。唯身语业表无表性。意业不然。以意业中无彼相故。谓能表示故名为表。表示自心令他知故。思无是事故不名表。由此但言。身语二业能表非意。意无表故无表亦无。以无表名遮相似故。是表种类。然不能表立无表名。顺正理中别释无理。谓无相续所依心故。为身语动是表业耶。不尔云何。颂曰

  身表许别形　　非行有为法
  有刹那尽故　　应无无因故
  生因应灭故　　无决定因故
  地等无异故　　了相有别故
  取不待余故　　相违因别故
  有灭不灭故　　许别有微故
  非二根取故　　彼定意境故
  分别坚等已　　长等智方生
  一面触多生　　比知有长等
  于多触聚中　　定有长等故
  同故过同故　　语表许言声

论曰。发毛等聚总名为身。于此身中有心所起。四大种果形色差别。能表示心名为身表。如思自体。虽刹那灭而立意业。于理无违。如是身形立为身业。不立显色及大种等为身表者。表通三性。此等皆唯无记性故。又显色等不随作者。欲乐生故。又设离心亦得生故。表必待心方得生故。若大种等一心所生。如体有差别。法亦应尔故。然不可谓一心所生有差别体成差别性。复云何知身语二业有善不善。契经说故。如契经言。诸有染污眼耳所识法。彼具寿为非诸有清净眼耳所识法说亦如是。复云何知四大种等唯无记性。亦由经说。如契经言。或有一类身住十年。乃至广说说心意识异灭异生。故大种等唯无记性。虽诸行法因果无间。异方生时。约世俗说名为行动。亦名表业。而身表业必是胜义。非一切行实有行动。以有为法有刹那故。非诸行体转至余方。乃有灭义。以有为法是处才生即还谢灭。刹那何谓。谓极少时此更无容前后分析。时复何谓。谓有过去未来现在分位不同。由此数知诸行差别。于中极少诸行分位。名为刹那。故如是说。时之极促故名刹那。此中刹那但取诸法有作用位。谓唯现在。即现在法有住分量。名有刹那。如有月子。或能灭坏故名刹那。是能为因灭诸法义。谓无常相能灭诸法。此俱行法名有刹那。复如何知诸有为法皆刹那灭必不久住。以诸有为后必尽故。现有灭法。有待客因。既不待客因才生已即灭。若初不灭后亦应然以后与初主因等故。既见后有尽。知前念念灭。若谓不然。世现见故。谓世现见薪等先有。由后与火客因合时。便致灭无不复见故。定无余量过现量者。故非诸法灭皆不待客因。岂不应如铃声灯焰。如彼声焰虽离手风。刹那刹那由主因灭。而手风合余不更生。后声焰无不复可取。如是薪等由主灭因。令念念灭后与火合。便于灭位不作余因。以后不生不复可取。是故此义由比量成。非现量得。何谓比量。谓应如生无无因故。以有为法不见不待客主二因而得生者。谓羯剌蓝芽墙识等。必待精血水土根等外缘资助。然后得生。若待客因薪等灭者。则有为法应并如生。要待客因然后得灭。而世现见觉焰音声。不待客因由主因灭故一切行灭。皆不待客因。由此诸有为才生已即灭。灭因常合故。刹那灭义成。又若薪等灭火合为因。于熟变生中有下中上。应生因体即成灭因。所以者何。谓由火合能令薪等有熟变生。中上熟生下中熟灭。即生因体应成灭因。然理不应。因彼此有即复因彼此法成无。若谓焰生不停住故无斯过者。理亦不然。体类不殊无决定理。能为生灭二种因故。且于火焰差别生中。容计能生能灭因异。于地水酢灰雪日合。能令薪等熟变生中。如何计度生灭因异。故诸法。灭不待客因。但由主因令诸法灭。由如是理证。刹那灭义成是故有为皆无行动。无行动故。所说身表是形差别。其理极成。云何知形显外别有。以形与显了相别故。若形即用显色为体。了相于中应无差别。既有长白二了相异。故于显外别有形色。现见有触同根所取。了相异故体有差别。如坚与冷或暖与坚。如是白长虽同根取。而了相异故体应别。是故显形其体各异。又诸形色体必非显。以不待显能取形故如不待余显有余显觉生。二显相望各别有体。既有形觉不待显生。故知显形定别有体。又相违因有差别故非体无异可有与此。与彼相违二因差别。若必不并说名相违。相违即因二法有此。相违因异。故体应别。现见世间。相违因异。体必有别。如心受等。同种类法必不并故。虽显与形同居一聚。而见形显有坏有存。故知相违因有差别。非体无异。可由相违因有差别有存有坏。是故形显体别义成。然心受等虽有差别相违因义。而互为因方得生故。存坏必等。又显与形有灭不灭。故知二法体别理成。现见世间名别体一。定无一灭一不灭义。如即火界亦名为暖。既见显形虽同一聚。而有一灭一不灭时。故知显形定别有体。若谓形色无别极微如显极微故非实者。亦不应理。许形极微如显有故。非不实有。如诸显色。一一极微。无独起理。设有独起。以极细故非眼所得。于积集时眼可得故。证知定有显色极微。形色极微亦应如是。宁独不许有实极微诸有对色所积集处。皆决定有极微可得。既于聚色差别生中。有形觉生犹如显觉。是故定应别有如种。能成长等形色极微。非显极微即成长等。假所依坏。假必坏故。以假用实为自体故。若显极微成粗显色及形色者。则一聚中显色坏时。形亦应坏。所依一故。如诸显色。既见显坏形色犹存。故知显形所依各别。所依既别。体别理成。经主此中作如是难。若谓实有别类形色。则应一色二根所取。谓于色聚长等差别眼见身触俱能了知由此应成二根取过。理无色处二根所取。然如依触取长等相。如是依显能取于形。此难不然。非许长等诸假形色二根取故。以彼长等诸假有法。定是意识所缘境故。一切假有唯是意识所缘境界。如前已辩能成长等如种极微。如是安布说为长等。是无分别眼识所取。非身能取。如是形色如依身根。了坚湿等。了长短等。不如是故。以非闇中了坚湿等。即于彼位或次后时。即能了知长短等相。要先分别坚等相已。然后长等比智方生。故长等形非身根境。谓于一面触多生中。依身根门分别触已。方能比度知触俱行。眼识所牵意识所受。如是相状差别形色。如见火色及嗅花香。能忆俱行火触花色。经主于此复作是言。诸有二法定不相离。故因取一可得念余。无触与形定不相离。如何取触能定忆形。此亦非理。现见世间诸触聚中有形定故。谓形于触虽无定者。而于一面多触生中定有长色。于一切处触遍生中定有圆色。如是等类随应当知。是故所引同喻成立。又此与彼义应同故。谓暖触于色及白色。于香亦无有定如形于触。不应因彼火色花香。便能念知火触花色。故非由此能遮遣形。异于显色别有体义。又显同形应有过故。谓眼喉中亦得烟触。或时以鼻嗅彼烟香。因此了知烟中显色。亦应显色二根所取。非实物有如依身根。了诸触已知长等相。是故身表是别形色。实有义成。语表业云何。谓言声为体。离声无别语能表故。非如身意离业别有。以语业名依体立故。如是已辩二表业相。无表业相初品已辩。定应许此是实有性。所以者何。颂曰

  说三无漏色　　增非作等故

论曰。以契经说色有三种。此三为处摄一切色。一者有色有见有对。二者有色无见有对。三者有色无见无对。除无表色。更复说何为此中第三无见无对色。由是无表实有理成。又契经中说。有无漏色。如契经说。无漏法云何。谓于过去未来现在诸所有色不起爱恚。乃至识亦然。是名无漏法。除无表色。何法名为此契经中诸无漏色十有色界。佛于经中一向说为有漏性故。由此无表实有理成。又契经说。有福增长。如契经言。诸有净信若善男子或善女人。成就有依七福业事。若行若住若寐若觉。恒时相续。福业渐增福业续起。无依亦尔。除无表业。若起余心或无心时。依何法说福业增长。无依福中。既无表业。宁有无表谁言此中。无有表业。理应有故。谓闻某处某方邑中现有如来或弟子住生欢喜故福常增者。彼必应有增上信心。遥向彼方敬申礼赞。起福表业及福无表。而自庄严希亲奉觐。故依无表说福增长。又非自作但遣他为。若无无表业。不应成业道。以遣他表非彼业道摄。此业未能正作所作故。使作所作已。此性无异故。然由先表及能起思为加行故。后时教者虽起善心。多时相续仍有不善。得相续生使所作成。时有力能引如是类大种及造色生。此所造色生。是根本业道。即彼先表及能起思现在前时为因。能取今所造色为等流果。于今正起无表色时。彼在过去能与今果。唯彼先时所起思业。于非爱果为牵引因。彼业道生能为助满。令所引果决定当生。无表若无此应非有。又若无无表。应无八道支。以在定时语等无故。由此无表实有理成。此无表名。为目何体。目远离体。远离非作非造。无表一体异名。非唯遮作即名无表。如世间说非婆罗门。世共了知别目一类。业为因故。如彩画业。此无表色亦立业名。因表因思而得生故。为诸无表皆二力生。不尔云何唯欲界系。所有无表可由强力二因所生。以欲界思非等引故。离身语表无有功能。发无表业静虑俱思定力持故。不待于表有胜功能发无表业。由此无表虽无作相。作为因故亦得业名。无表与表俱所造色。所依大种为异为同。颂曰

  此能造大种　　异于表所依

论曰。无表与表虽有俱生。然能生因大种各异。粗细两果因必异故。生因和合有差别故。一切所造色多与生因大种俱生。然现在未来。亦有少分。因过去者。少分者何。颂曰

  欲后念无表　　依过大种生

论曰。唯欲界系初刹那后。所有无表从过大生谓欲界所系。初念无表与能造大种俱时而生。此大种生已。能为一切未来自相续无表生因。此与初刹那无表俱灭已。第二念等无表生时。一切皆是前过去大种所造。此过大种为后后念无表所依能引发故。与后后念无表俱起。身中大种但能为依。此大种若无。无表不转故。如是前俱二四大种。望后诸无表。为转随转因。譬如轮行因手依地。手能引发地但为依。前俱大种应知亦尔。大种通五地。身语业亦然。何地身语业。何地大种造。颂曰

  有漏自地依　　无漏随生处

论曰。身语二业略有二种。一者有漏。二者无漏。若有漏者。五地所系。欲界所系。身语二业。唯欲界系。大种所造。如是乃至第四静虑身语二业。唯是彼地大种所造。若无漏者。依五地身随生此地应起现前。即是此地大种所造。以无漏法不堕界故。必无大种是无漏故。由所依力无漏生故。表无表业其类是何。复是何类大种所造。颂曰

  无表无执受　　亦等流情数
  散依等流性　　有受异大生
  定生依长养　　无受无异大
  表唯等流性　　属身有执受

论曰。今此颂中先辩无表。诸无表业略有二种。定不定地有差别故。然其总相皆无执受。与有执受相相违故。唯善不善故。非异熟生。无极微集故。非所长养。有同类因故。有是等流。亦言为显有刹那性。谓初无漏俱生无表。待识生故有情数摄。若就差别分别所依。不定地中所有无表。等流有受异大种生。异大生言。显身语七一一是别大种所造。定生无表差别有二。谓诸静虑无漏律仪。此二俱依定所长养。无受无异大种所生。无异大言。显此无表七支同一具四大种所造。应知有表唯是等流。此若属身是有执受。余义皆与散无表同。谓有情数及依等流。有受别异四大种起。何缘散地所有无表能造大种。唯等流性定地无表所长养生。以殊胜心现在前位必能长养大种诸根。故定心俱必有殊胜长养大种。能作生因造定心俱。所有无表散地无表。因等起心不俱时故。在无心位亦有起故。所依大种唯是等流。因等起心不能长养。能生无表诸大种故。若尔散地无表所依。谁等流果。有作是说。是次前灭大种等流。能造无对所有大种。非造有对大种等流。果有细粗。种类别故。如是说者。从无始来。定有能造无对造色。已灭大种为同类因。能生今时等流大种。造有表业。大种亦应是无始来同类大种之等流果。非从异类。定生无表所依大种无执受者。定心果故。必无爱心。执此大种。以为现在内自体故。又此大种无有其余执受相故。名无执受。散地无表所依大种有执受者。散心果故。以有爱心执为现在内自体故。如显色等所依大种系属依身而得生故。亦可毁坏。外物触时可生苦乐。何缘定心所生无表。是无别异大种所生。散无表生依别异大。定生无表七支相望展转力生同一果故。唯从一具四大种生。散此相违故依异大。若散无表同一生因。随越一时应越一切。定生无表七支相望。生因既同。必顿舍故。岂不如对一切有情相续所生远离杀戒。虽同一具大种所生。非越一时顿越一切。七支相对。理亦应然。此例不然。彼虽一具大种所造。然其所对一一有情相续异故。若七支戒无异大生。所对有情相续既一。何缘越一非越一切。是故此彼为例不齐。若尔此应同命根理。如命根体为具身依。身不具时亦为依止。故身虽缺随有余根。命犹能持令不断坏。如是一具大种为因。能生七支具不具果。故支虽缺随有余支。大犹能持令不断坏。此亦非例。以彼命根先与缺身俱时而起。中间有与具身俱生。后缺减时复有俱起。故于具缺各别任持。大种不然。一具大种为一相续。无表生因若与七支为生因者。未常暂与缺支俱生。如何缺一时。持余令不断。即由此理从无贪等为因所生离杀等戒。虽有对一有情相续而越一时。非越一切。以是各别大种果故。大种别者。果类别故。虽对别异有情相续发多无贪所生无表。而但一具大种为因。以所生果类无别故。由是若对一有情身。一具七支生因同者。则随越一应越一切。前所设难其理善成。故散七支依别大种。如天眼起非坏本形。表色生时理亦应尔。故虽身表在身中生。而无异熟色断已更续过。亦无一具大种聚中有二形色俱时起过。以诸身表别有等流大种新生为所依故。随依身分表色生时。此一分身应大于本。大及形色极微增故。然不现见其理如何。有释此言。以表及大相微薄故。如染支体。然不见有大相可得。有说身中有孔隙故。虽得相容纳而不大于本。已辩业门略有二种。谓思思已业差别故。复有三种。谓身语意业差别故。复有五种。谓身语二各表无表及思唯一业差别故。如是五业性及界地建立云何。颂曰

  无表记余三　　不善唯在欲
  无表遍欲色　　表唯有伺二
  欲无有覆表　　以无等起故

论曰。无表唯通善不善性无有无记。所以者何。是强力心所等起故。无记心劣无有功能。为因等起引强力业。令于后后余心位中及无心时亦恒续起。所言余者。谓二表及思三。谓皆通善不善无记。于中不善在欲非余。有不善根无惭愧故。善及无记随其所应。三界皆有不别遮故。欲色二界皆有无表。决定不在无色界中。以无色界中有伏色想故。厌背诸色入无色定。故彼定中不能生色。或随何处有身语转。唯是处有身语律仪。无色界中无身语转。故彼无有身语律仪。毗婆沙师作如是说。为治恶戒故起尸罗。唯欲界中有诸恶戒。无色于欲具四种远。一所依远。二行相远。三所缘远。四对治远。所依远者。谓于等至入出位中。等无间缘为所依体无容有故。行相远者。谓无色心毕竟无能。于欲界法作苦粗等诸行相故。所缘远义。类此应知。由无色心但能以下第四静虑有漏诸法。为苦粗等行相所缘。对治远者。谓若未离欲界贪时。必定无容起无色定。能为欲界恶戒等法。厌坏及断二对治故。非不能缘可能厌坏。故无色界无无表色。表色唯在二有伺地。谓通欲界初静虑中。非上地中可言有表。说有伺者。为显一切初静虑中遍有表业。若于上地表业全无。语表既无。何有声处。有外大种为因发声不遮外声。故无有失。有余师说。上三静虑亦有无覆无记表业。理必应然。上三地中起三识身。既无有失。如何不起发表业心。然善染心上不起下。下善下染劣故断故。由是生上无善染表。前说为善。所以者何。虽彼现前非彼系故。有覆无记表欲界定。无唯初静虑中可得说有。曾闻大梵有诳谄言。谓自众中为避马胜所征问故矫自叹等。复以何缘二定以上都无表业。于欲界中无有有覆无记表业。以无发业等起心故。有寻伺心能发表业。二定以上都无此心。虽起下地心发身语表。然如识身等非上地系。又发表心唯修所断。见所断惑内门转故。以欲界中决定无有有覆无记修所断惑。是故表业上三地都无。欲界中无有覆无记表。为但由等起令诸法成善不善性等。不尔云何由四种因成善性等。一由胜义。二由自性。三由相应。四由等起。何法何性。由何因成。颂曰

  胜义善解脱　　自性惭愧根
  相应彼相应　　等起色业等
  翻此名不善　　胜无记二常

论曰。胜义善者。谓真解脱。以安隐义。说名为善。谓涅槃中众苦永寂。最极安隐犹如无病。此由胜义安立善名。是故涅槃名胜义善。或真解脱是胜是义。得胜义名。胜谓最尊无与等者。义谓别有真实体性。此显涅槃无等实有。故名胜义。安隐名善。是善常故。自性善者。谓惭愧根。以有为中唯惭与愧。及无贪等三种善根。不待相应及余等起。体性是善犹如良药。相应善者。谓彼相应。以心心所要与惭愧善根相应方成善性。若不与彼惭等相应。善性不成。如杂药水。等起善者。谓身语业。生等及得二无心定。以是自性及相应善所等起故。立等起名。如良药汁所引生乳。因异类心亦起诸得。如因静虑得通果心。胜无记心现在前故。得诸染法。胜染污心现在前故。得诸善法。此等如何成善等性。以就彼法俱生得故。密作是言。非异类心不作缘起。故无有失。虽异类心亦为缘起。而成善等。非待彼心。或复因彼诸得等起。即待彼故成善等性。故得由等起成善等性异。如说善性四种差别。不善四种与此相违。云何相违。胜义不善。谓生死法。由生死中诸法皆以苦为自性极不安隐犹如痼疾。自性不善。谓无惭愧三不善根。由有漏中唯无惭愧及贪嗔等三不善根不待相应及余等起。体是不善。犹如毒药。相应不善。谓彼相应。由心心所法要与无惭愧不善根相应方成不善性。异则不然如杂毒水。等起不善。谓身语业生等及得。以是自性相应不善所等起故。如毒药汁所引生乳。若尔应无一有漏法。是无记或善皆生死摄故。一切皆应是不善摄。虽据胜义。理实应然。而于此中约异熟说。诸有漏法若不能记异熟果者。立无记名。于中若能记爱异熟。说名为善。如善不善既有胜义。亦有胜义无记法耶。亦有。云何。谓二常法。以非择灭及太虚空。更无异门。唯无记性。是故独立胜义无记。无别自性相应等起。无一心所。唯无记性与无记心偏相应故。设方便立自性等三。亦摄不尽。无记多故。由是无记唯有二种。一者胜义。二者自性。有为无记是自性摄。不待别因成无记故。无为无记是胜义摄。以性是常无异门故。若等起力。令身语业成善不善。此身语业所依大种例亦应然。俱从一心所等起故。此难非理。以作者心本欲起业非大种故。谓无作者。于大种中发起乐欲。我当引发如是种类大种现前。由此为门善恶心起。又世现见身语二业待心而生。未曾见有身语二业离心而起。然四大种离心亦生。故知彼法非待心起。又如眼等不待心生。其性便无善等差别。如是大种不待心生。故理亦无善等差别。若尔诸得及生等相。应无等起善等差别。以非本心所欲起故。无心位中亦现起故。此难非理。由法势力安立善等差别成故。谓得四相依法而立。非如大种无待自成。有为法中无有一法不待心力成善不善。是故诸得及生等相。如所属法。要由心力成善等性。其理善成。生已离心。虽相续转。亦无有过。即是前心势力所引。令其转故。随定无表定等力生。理亦应成。等起善性。天眼天耳应善性摄。以是善心所等起故。此难非理。以彼二通解脱道心。是无记故。彼二与道俱时生故

说一切有部显宗论卷第十八阿毗达磨藏显宗论卷第十九

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩业品第五之二

如上所言。由等起力身语二业成善不善。等起有几。何等起力令身语业成善不善。等起相望差别云何。颂曰

  等起有二种　　因及彼刹那
  如次第应知　　名转名随转
  见断识唯转　　唯随转五识
  修断意通二　　俱非修所成
  于转善等性　　随转各容三
  牟尼善必同　　无记随或善

论曰。身语二业等起有二。谓因等起。刹那等起。在先为因故。彼刹那有故。如次初名转。第二名随转。谓因等起。将作业时。作是思惟。我今当作如是如是所应作业。能引发故说名为转。刹那等起。正作业时。与先转心所引发业俱时行故说名随转。若无随转。虽有先因为能引发。如无心位。或如死尸。表应不转。随转于表有转功能。无表不依随转而转。无心亦有无表转故。如上所言。见所断惑。内门转故不能发表。若尔何缘薄伽梵说。由邪见故。起邪思惟邪语邪业及邪命等。此不相违。见所断识。于发表业但能为转。于能起表寻伺生中。为资粮故不为随转。于外门心正起业时。此无有故由此故说。见所断心为因等起。发身语业定不能为。刹那等起。见所断识虽能思量。而无功能动身发语。然于动发一表业中。容有多心思量动发。唯后一念与表俱行。异此表应非刹那性。见所断识虽能为转发有表业。然非表业。于此识后无间即生。内门转心不能引起。与身语表俱行识故。若异此者。见所断心。亦应于表业为刹那等起。以修所断加行意识能无间引表俱行心。亦与表俱行为刹那等起。故见所断虽能为因引诸表业。离修所断因等起心。表俱行心无容得起是故欲界无有有覆无记表业。然契经中。但据展转为因等起。密作是言。由邪见故起邪语等。阿毗达磨据彼不能无间引生表俱行识。故密意说。见所断心。内门转故。不能发表。是故经论理不相违。又见所断若发表色。此色则应是见所断。色非见断前已成立。若五识身唯作随转。无分别故。外门转故。修断意识有通二种。有分别故。外门转故。由此应成四句分别。有转非随转。谓见所断心。有随转非转。谓眼等五识。有转亦随转。谓修所断一分意识。有非转随转。谓余一切修所成识。以修所成无分别故。异熟生识亦为随转。如顺正理成立此义。转随转识性必同耶。不尔。云何。谓前转识若是善性。后随转识通善等三。不善无记为转亦尔。唯牟尼尊转随转识。多分同性少有不同。谓转若善心随转。亦善转。心若无记随转亦然。于续刹那定无迷故。而或有位善随无记转。曾无有时无记随善转。以佛世尊于说法等心或增长无萎歇故。既说善等转随转各三。准此标释中足为明证。所发诸业成善恶等。随因等起非随刹那异此善心所引发业。既与不善无记心俱。何理能遮成恶无记。是则应有从别思惟为因引生别性类业。如是勤励。欲为善者。翻有不善无记业生。或此相违便乖正理。故业成善等定由转力。非由随转力。其理善成。然随定心诸无表业。与俱时起心一果故。由随转力善性得成。定属此心而得生故。辩业界地傍论已周。复应辩前表无表相。颂曰

  无表三律仪　　不律仪非二

论曰。应知无表略说有三。一者律仪。二不律仪。三者非二。谓非律仪非不律仪。能遮能灭恶戒相续。故名律仪。如是律仪差别有几。颂曰

  律仪别解脱　　静虑及道生

论曰。律仪差别略有三种。一别解脱律仪。谓欲界戒。二静虑生律仪。谓色界戒。三道生律仪。谓无漏戒。初律仪相差别云何。颂曰

  初律仪八种　　实体唯有四
  形转名异故　　各别不相违

论曰。别解脱律仪相。差别有八。一苾刍律仪。二苾刍尼律仪。三正学律仪。四勤策律仪。五勤策女律仪。六近事律仪。七近事女律仪。八近住律仪。如是八种律仪相差别。总名第一别解脱律仪。此中依能修离恶行及离欲行补特伽罗。安立前五律仪差别。以如是类补特伽罗乃至命终能离杀等诸恶行故。及能远离非梵行故。次复依能修离恶行非离欲行补特伽罗。安立尽形在家二众律仪差别。以如是类补特伽罗乃至命终能离杀等诸恶行故。不能远离非梵行故。由是经中但作是说。离欲邪行非非梵行。后复依能修非全离恶行欲行补特伽罗。安立在家一昼一夜律仪差别。以如是类补特伽罗不能全离恶行诸欲为令渐习全离恶行及诸欲行方便住故。虽名有八。实体唯四。一苾刍律仪。二勤策律仪。三近事律仪。四近住律仪。唯此四种别解律仪。皆有体实相各别故。所以者何。离苾刍律仪无别苾刍尼律仪。离勤策律仪无别正学勤策女律仪。离近事律仪无别近事女律仪。云何知然。由形改转体。虽无舍得而名有异故。形谓形相。即男女根。由此二根男女形别。但由形转令诸律仪名为苾刍苾刍尼等。谓转根位令本苾刍律仪名苾刍尼律仪。或苾刍尼律仪名苾刍律仪。令本勤策律仪名勤策女律仪。或勤策女律仪及正学律仪名勤策律仪。令本近事律仪名近事女律仪。或近事女律仪名近事律仪。非转根位有舍先得得先未得律仪因缘。故四律仪非异三体。若从近事律仪受勤策律仪。复从勤策律仪受苾刍律仪。此三律仪为由增足远离方便立别别名如只双金钱及五十二十为体各别具足顿生。三种律仪体不相杂。其相各别具足顿生。三律仪中具三离杀。一一离杀其体各异。余随所应当知亦尔。由因缘别故体不同。如如求受多种学处。如是如是能离多种。高广床座饮诸酒等憍逸处时。即离众多杀等缘起。以诸远离依因缘发。故因缘别远离有异。若无此事舍苾刍律仪。尔时则应三律仪皆舍。前二摄在后一中故。既不许然故三各别。然此三种互不相违。于一身中俱时而转。非由受后舍前律仪。勿舍苾刍戒便非近事等。先已舍彼二律仪故。近事近住勤策苾刍四种律仪云何安立。颂曰

  受离五八十　　一切所应离
  立近事近住　　勤策及苾刍

论曰。应知此中如数次第。依四远离立四律仪。谓受离五所应离法。建立第一近事律仪。何等为五所应离法。一者杀生。二不与取。三欲邪行。四虚诳语。五饮诸酒。若受离八所应离法。建立第二近住律仪。何等为八所应离法。一者杀生。二不与取。三非梵行。四虚诳语。五饮诸酒。六涂饰香鬘舞歌观听。七坐卧高广严丽床座。八食非时食。若受离十所应离法。建立第三勤策律仪。何等为十所应离法。谓于前八涂饰香鬘舞歌观听开为二种。复加受畜金银等宝以为第十。为引怖怯众多学处。在家有情显易受持。故于八戒合二为一。如为佛栗氏子略说学处有三。若受离一切应离身语业。建立第四苾刍律仪。别解脱律仪众名差别者。颂曰

  俱得名尸罗　　妙行业律仪
  唯初表无表　　名别解业道

论曰。以清凉故。名曰尸罗。此中尸罗是平治义。戒能平险业。故得尸罗名。智者称扬故名妙行。或修行此得爱果故。所作自体故名为业。亦名律仪。如前已释如是应知。别解脱戒。通初后位无差别名。唯初刹那表及无表。得别解脱及业道名。谓受戒时。初表无表别别弃舍种种恶故。依初别舍义。立别解脱名。或初所应修。故名别解脱。或彼初起最能超过。如狱险恶趣。故名别解脱。即初刹那表与无表。亦得名为根本业道。初防身语畅思业故。从第二念乃至未舍。不名别解脱。名别解律仪不名业道。但名后起。已辩安立差别律仪。当辩律仪成就差别。谁成就何律仪。颂曰

  八成别解脱　　得静虑圣者
  成静虑道生　　后二随心转

论曰。八众皆成就别解脱律仪。谓从苾刍乃至近住。静虑生者。谓此律仪。由从或依静虑生故。若得静虑者。定成此律仪。静虑眷属亦名静虑道生。律仪圣者皆成就此。复二种谓学及无学。于前所说三律仪中。静虑道生随心而转。非别解脱。所以者何。异心无心亦恒转故。静虑无漏二种律仪。亦名断律仪。依何位建立。颂曰

  未至九无间　　俱生二名断

论曰。未至定中九无间道。俱生静虑无漏律仪。以能永断欲缠恶戒。及能起惑名断律仪。唯未至定中。有断对治故。由此但摄九无间道。此中尸罗灭恶戒故。由此或有静虑律仪。非断律仪。应作四句。第一句者。除未至定九无间道。所余有漏静虑律仪第二句者。依未至定九无间道无漏律仪。第三句者。依未至定九无间道有漏律仪。第四句者。除未至定九无间道。所余一切无漏律仪。如是或有无漏律仪。非断律仪。应作四句。谓前四句逆次应知。若尔世尊所说略戒

  身律仪善哉　　善哉语律仪
  意律仪善哉　　善哉遍律仪

又契经说。应善守护。应善安住眼根律仪。此意根律仪。以何为自性。此二自性非无表色。若尔是何。颂曰

  正知正念合　　名意根律仪

论曰。意根律仪一一各用正知正念合为自体。故契经说。眼见色已不喜不忧。恒安住舍正知正念。如是乃至意了法已。列别名已。重说合言。遮谓二律仪。如次二为体。今应思择表及无表。谁成就何。齐何时分。且辩成无表律仪不律仪。颂曰

  住别解无表　　未舍恒成现
  刹那后成过　　不律仪亦然
  得静虑律仪　　多恒成过未
  圣初除过去　　入定道成中

论曰。住别解脱补特伽罗。从初刹那乃至未遇舍学处等诸舍戒缘。恒成现世。此别解脱律仪无表。初刹那后亦成过去。前未舍言遍流至后。如说安住别解律仪。住不律仪应知亦尔。谓从初念乃至未遇受律仪等舍恶戒缘。恒成现世。恶戒无表。初刹那后亦成过去。诸有获得静虑律仪。乃至未舍来。多恒成过未。前生所失过去定律仪。今初刹那必还得彼故。以顺决择分所摄定律仪。初刹那中不成过去。余生所得命终时舍。今生无容重得彼法。为简彼法。故说多言。无漏律仪。一切圣者多成过未。唯初刹那不成过去。此类圣道先未生故。昔曾未得创得名初。先得已失今创得时亦得过去。已曾生者。初刹那后乃至未舍。亦成过去未来成就。乃至未般无余涅槃。若入静虑及无漏道。如次成现在静虑道律仪。非出观时有成现在。定道无表随心转故。散心现前必无彼故。已辩安住善恶律仪。住中云何。颂曰

  住中有无表　　初成中后二

论曰。言住中者。谓非律仪非不律仪。彼所起业不必一切皆有无表。若有无表即是善戒。或是恶戒种类所摄。或非二类。彼初刹那但成中世。谓成现在。此是过去未来中故。初刹那后未舍以来。恒成过现二世无表若有安住律不律仪。亦有成恶善无表不。设有成者为经几时。颂曰

  住律不律仪　　起染净无表
  初成中后二　　至染净势终

论曰。若住律仪。由胜烦恼作杀缚等诸不善业。由此便发不善无表住不律仪。由淳净信作礼佛等诸胜善业。由此亦发诸善无表。乃至此二心未断来。所发无表恒时相续。然其初念唯成现在。第二念等通成过现。已辩成无表。成表业云何。颂曰

  表正作成中　　后成过非未
  有覆及无覆　　唯成就现在

论曰。一切安住律不律仪及住中者。乃至正作诸表业来恒成现表。初刹那后至未舍来恒成过去。必无成就未来表者。不随心色势微劣故。诸散无表亦同此释。有覆无覆亦无记表。定无有能成就过未。法力劣故。唯能引起法俱行得。得力劣故。不能引生自类相续可法灭已追得言成。亦无功能逆得当法。岂不此表如能起心。亦应有成去来世者。此表力劣。由彼劣故此责非理。所起劣于能起心故。所以然者。如无记心能发表业。所发表业不生无表。故知所起劣能起心。如律仪名既有差别。不律仪号亦有别耶。亦有。云何。颂曰

  恶行恶戒业　　业道不律仪

论曰。此恶行等五种异名。是不律仪名之差别。是诸智者所诃厌故。果非爱故立恶行名。障净尸罗故名恶戒。身语所造故名为业。根本所摄能畅业思。业所游路故名业道。不静身语名不律仪。然业道名唯目初念。通初后位立余四名。今应思择。若成就表亦无表耶。应作四句。颂曰

  成表非无表　　住中劣思作
  舍未生表定　　成无表非表

论曰。唯成就表非无表者。谓住非律非不律仪。劣善恶思造善造恶。身语二业唯能发表。此尚不能发无表业。况诸无记思所发表。除有依福及成业道。彼虽劣思起亦发无表故。唯成无表。非表业者。谓得静虑补特伽罗。今表未生先生已舍。俱成非句。如理应思。如是建立表与无表及成就已。于中律仪三种差别云何而得。颂曰

  定生得静虑　　彼圣得道生
  别解脱律仪　　得由他教等

论曰。静虑律仪与心俱得。若得有漏近分根木。静虑地心静虑律仪。尔时便得彼心俱故。从无色界没生色界。时随得彼地中生得静虑即亦得彼俱行律仪。无漏律仪亦心俱故。若得无漏近分根本。静虑地心。尔时便得彼声为显。前静虑心复说圣言。简取无漏六静虑地。有无漏心。谓未至中间及四根本。定非三近分。如后当辩。别解脱律仪。由他教等得。能教他者说名为他。从如是他教力发戒。故说此戒由他教得。此复二种。谓从僧伽补特伽罗有差别故。从僧伽得者。谓苾刍苾刍尼及正学戒。从补特伽罗得者。谓余五种戒。诸毗奈耶毗婆沙师。说有十种得具戒法。为摄彼故复说等言。何者为十。一由自然。谓佛独觉自然。谓智以不从师证此智时得具足戒。二由佛命善来苾刍。谓耶舍等由本愿力佛威加故。三由得入正性离。生谓五苾刍由证见道得具足戒。四由信受佛为大师。谓大迦叶。五由善巧酬答所问。谓苏陀夷。六由敬受八尊重法。谓大生主。七由遣使。谓法授尼。八由持律为第五人。谓于边国。九由十众。谓于中国。十由三说归佛法僧。谓六十贤部共集受具戒。此中或由本愿力故。或阿世耶极圆满故。或薄伽梵威所加故。随其所应得具足戒。如是所说别解律仪。应齐几时要期而受。颂曰

  别解脱律仪　　尽寿或昼夜

论曰。七众所依别解脱戒。唯应尽寿要期而受。近住所依别解脱戒唯一昼夜要期而受。此时定尔何因故然。非毗奈耶。相应义理。非一切智者能测量其实。有余师说。世尊觉知戒时边际但有二种。一寿命边际。二昼夜边际。重说昼夜为半月等。故佛但说二受戒时。以佛经中唯说昼夜。故对法者亦作是言。近住律仪唯昼夜受。必应有法能为障碍令过昼夜彼戒不生。故佛经中唯说昼夜。不说或五或十等时。然有说言。佛观所化根难调者。且应授与一昼夜戒非无过此。依何理教作如是言。过此戒生不违理故。复减于此何理相违。谓所化根有难调者。已许为说昼夜律仪。何不为调渐难调者。说唯一夜一昼须臾。以难调根有多品故。然曾不说由此知有近住定时。若减若增便不发戒。世尊观是。故唯说此。依何边际得不律仪。颂曰

  恶戒无昼夜　　以非如善受

论曰。要期尽寿造诸恶业。得不律仪非一昼夜。如近住戒。所以者何。以此非如善戒受故。谓必无有立限对师。受不律仪如近住戒。我一昼夜定受不律仪。此是智人所诃厌业故。虽亦无有立限对师。我当尽形造诸恶业。而由发起坏善意乐。欲永造恶得不律仪。非起暂时造恶意乐。无师而有得不律仪。故不律仪无一昼夜。然近住戒功德可欣。由现对师要期受力。虽无毕竟坏恶意乐。而于一昼夜。得近住律仪。故得不律仪与得律仪异。说一昼夜近住律仪。欲正受时当如何受。颂曰

  近住于晨旦　　下座从师受
  随教说具支　　离严饰昼夜

论曰。近住律仪于晨旦受。谓受此戒要日出时。此戒要经一昼夜故。诸有先作如是要期。我当恒于月八日等决定受此近住律仪。若旦有碍缘。斋竟亦得受。言下座者。谓在师前居卑劣座身心谦敬。身谦敬者。或蹲或跪曲躬合掌。唯除有病。心谦敬者。于施戒师心不轻慢。于三宝所生极尊重殷净信心。以诸律仪从敬信发。若不谦敬不发律仪。此必从师无容自受。以后若遇诸犯戒缘。由愧戒师能不违犯。谓彼虽阙自法增上。由世增上亦能无犯。受此律仪应随师教。受者后说勿前勿俱。如是方成从师教受。异此授受二俱不成。具受八支方成近住。随有所阙近住不成。诸远离支互相属故。由是四种离杀等支。于一身中可俱时记。以诸远离相系属中或少或多相差别故。受此戒者心离严饰。憍逸处故。常严身具不必须舍。缘彼不能生其憍逸。如新异故。受此律仪心须昼夜。谓至明旦日初出时。经如是时戒恒相续。异此受者。虽生妙行不得律仪。然为令招可爱果故。亦应为受。言近住者。谓此律仪近阿罗汉住。以随学彼故。有说此近尽寿戒住。有说此戒近时而住。如是律仪或名长养。长养薄少善根有情。令其善根渐增多故。何缘受此近住律仪。必具八支非增非减。颂曰

  戒不逸禁支　　四一三如次
  为防诸性罪　　失念及憍逸

论曰。八中前四是尸罗支。谓离杀生至虚诳语。由此四种离性罪故。次有一种。是不放逸支。谓离饮诸酒生放逸处。虽受尸罗若饮诸酒。则心放逸毁犯尸罗。醉必不能护余支故。后有三种。是禁约支。谓离涂饰香鬘乃至食非时食。以能随顺厌离心故。厌离能证律仪果故。何缘具受如是三支。若不具支便不能离性罪失念憍逸过失。谓初离杀至虚诳语。能防性罪离贪嗔痴所起杀等诸恶业故。次离饮酒能防失念。以饮酒时能令忘失应不应作诸事业故。则不能护余远离支。后离余三能防憍逸。以若受用种种香鬘高广床座习近歌舞心便憍举寻即毁戒。由离彼故心便离憍。谓香鬘等若恒受用。尚顺憍慢为犯戒缘。况受新奇曾未受者。故一切种皆应舍离。若有能持依时食者。以能遮止恒时食故。便忆自受近住律仪。能于世间深生厌离。若非时食二事俱无。数食能令心纵逸故。由此大义故具受三。于此八中离非时食是斋亦斋支。所余七支是斋支非斋。如正见是道亦道支。余七支是道支非道。为唯近事得受近住。为余亦有受近住耶。颂曰

  近住余亦有　　不受三归无

论曰。诸有未受近事律仪。一昼夜中归依三宝。说三归已受近住戒。彼亦受得近住律仪。异此则无。除不知者。由意乐力亦发律仪。岂不三归则成近事。如契经说。佛告大名。诸有在家白衣男子男根成就。归佛法僧起殷净心。发诚谛语自称我是邬波索迦。愿尊忆持慈悲护念。齐是名曰邬波索迦。此不相违受三归位未成近事。所以者何。要发律仪成近事故

说一切有部显宗论卷第十九阿毗达磨藏显宗论卷第二十

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩业品第五之三

于何时发近事律仪。颂曰

  称近事发戒　　说如苾刍等

论曰。起殷净心发诚谛语。自称我是邬波索迦。愿尊忆持慈悲护念。尔时乃发近事律仪。称近事等言。方发律仪故。以经复说我从今者。乃至命终护生言故。若离称号但受三归成近事者。自称我是近事等言。便为无用。依何义故说护生言。别解律仪护生得故。或为救护自生命缘。亦不毁犯如来禁戒。诸异生类将受律仪。亦有如斯坚固意乐。乃至为救自生命缘。终不亏违所受学处。如斯誓受世现可得。然有别诵。言舍生者。此言意说。舍杀生等。略去杀等。但说舍生。彼虽已得近事律仪。为令了知所应学处。故复为说离杀生等五种戒相。令识坚持。如得苾刍具足戒已。说重学处令识坚持。勤策亦然。此亦应尔是故近事必具律仪。非受三归即成近事。颂曰

  若皆具律仪　　何言一分等
  约能持故说

论曰。此中憎嫉对法义者。心不生喜复设是难。若诸近事皆具律仪。何缘世尊言有四种。一能学一分。二能学少分。三能学多分。四能学满分。岂不由此且已证成。非唯三归即成近事。谓若别有但受三归即成近事。如是近事非前所说。四种所收应更说有第五近事。此于学处全无所学。亦应说为一近事故。佛观近事非离律仪。故契经中唯说四种。虽诸近事皆具律仪。然约能持故说四种。谓虽具受五支律仪。而后遇缘或便毁缺。其中或有于诸学处能持一分。乃至或有具持五支。故作是说。能持先所受。故说能学言。不尔应言受一分等。故此四种但据能持。然经主言。约持犯戒说一分等。尚不应问。况应为答。谁有已解近事律仪。必具五支而不能解。于所学处持一非余。乃至具持名一分等。由彼未解近事律仪。受量少多故应请问。凡有几种邬波索迦。能学学处。答言。有四邬波索迦。谓能学一分等犹未能了。复问。何名能学一分。乃至广说。此全无理。唯对法宗所说理中应问答故。虽知近事必具律仪。而未了知随犯一种为越一切为一非余。由有此疑故应请问。诸部若有未见此文。于此义中迄今犹诤。若异此者。佛经数言。邬波索迦具五学处。谁有于此已善了知。而复怀疑问受多少。设许尔者。疑问相违。谓彼本疑受量多少。而问有几能学学处。答学一分等。岂除本所疑。故彼义中不应问答。经主于此不正寻思。于诤理中怀朋党执。翻言对法所说义中。问尚不应况应为答。若阙律仪亦名近事。苾刍勤策阙亦应成。然经主言。何缘不许。由佛教力施设不同。虽阙律仪而成近事。苾刍勤策必具律仪。此率己情无经说故。世尊何处说离律仪亦成近事。非苾刍等曾闻经部有作是执。亦有无戒勤策苾刍。彼执应同布剌拏等诸外道见。非佛法宗一切律仪品类等不品类非等有三品故。下中上别随何故成。颂曰

  下中上随心

论曰。八众所受别解脱律仪。随受心力成上中下品。由如是理。诸阿罗汉或有成就下品律仪。然诸异生或成上品。诸有归依佛法僧者。为归何等。颂曰

  归依成佛僧　　无学二种法
  及涅槃择灭　　是说具三归

论曰。如本论言。归依佛者为归何法。谓若诸法妙有现有。由想等想施设言说。名为佛陀。归此能成佛无学法。言谓若者。即是总摽。当所说义言诸法者。即是显示无我增言。妙有言显妙有性合。现有即明现可得义。或妙德合故名妙有。现有即显是所知性。想等想等是名差别。觉一切法一切种相不藉他教。故名佛陀。或此圆成智等众德自然开觉。故名佛陀。或佛陀名显彼有觉。如质碍物名有质碍。或佛陀名显彼能说。己所证觉以开觉他。如婆罗门问经广说。能成佛者。显彼诸法与佛施设。为建立因。如何此中于无量法而总建立摽一佛名。如依众多和合人上立一僧宝一胜所归。又于众多无漏道上立一道蕴。无有过失。或先已说。先说者何。谓想等想施设言说。即佛相续无学法中。立一佛名无别一佛。能成佛法为是何等。谓尽智等及彼眷属。由得彼法能觉一切。以彼胜故身得佛名。非色等身前后等故。为归一佛一切佛耶。理实应言归一切佛。以诸佛道相无异故。僧伽差别略有五种。一无耻僧。二哑羊僧。三朋党僧。四世俗僧。五胜义僧。无耻僧者。谓毁禁戒而被法服补特伽罗。哑羊僧者。谓于三藏无所了达补特伽罗。譬如哑羊无辩说用。或言哑者。显无说法。能复说羊言显无听法用即显。此类补特伽罗于三藏中无听说用。朋党僧者。谓于游散营务斗诤。方便善巧结构朋党补特伽罗。此三多分造非法业。世俗僧者。谓善异生。此能通作法非法业。胜义僧者。谓学无学法及彼所依器补特伽罗。此定无容造非法业。五中最胜。是所归依。如赞归依伽他中说

  此归依最胜　　此归依最尊
  必因此归依　　能解脱众苦

于如是法补特伽罗二胜义僧中。迦多衍尼子意但以法为所归僧。故本论中作如是说。归能成僧学无学法。僧有多种。谓有情人声闻福田及圣僧等。佛于此内非声闻僧。可是余僧自然觉故。今所归者是声闻僧。理实通归诸佛弟子。以诸僧道相无异故。然契经说。当来有僧汝应归者。彼经但为显示当来现见僧宝归依于法谓归爱尽离灭涅槃。如是一切是烦恼断。名之差别。或有谓爱味着门转不应弃舍。故寄爱名。通显一切烦恼永尽。爱与余烦恼同一对治故。言爱尽者。谓见所断诸爱永断。故预流者此爱尽时。便自记别诸恶趣尽。谓我已尽那落迦等。所言离者。谓欲界中诸所有贪多分已断。即是已薄欲界贪义。灭谓欲界诸爱全断。此地烦恼当于尔时决定无能系缚义故。言涅槃者。谓色无色诸爱永断。由此尽时诸所有苦皆永寂故。此则显示四沙门果。或此四种如其次第显三界爱断及永般涅槃。或爱尽者。三界爱断。所言离者。除爱所余诸烦恼断。所言灭者。显有余依般涅槃界。言涅槃者。显无余依般涅槃界。此中何法是所归依。能归是何。归依何义。所归依者。谓灭谛全道谛一分。除独觉乘菩萨学位无漏功德。何缘彼法非所归依。彼不能救生死怖故。谓诸独觉不能说法教诫。诸有情令离生死怖。菩萨学位不起期心。故亦无能教诫他义。故彼身中学无学法。不能救护非所归依。有余师言。不和合故。不显了故。如其次第独觉菩萨非所归依。缘彼亦生无漏意净。故彼亦是证净境摄。此中能归语业为体。自立誓限为自性故。若并眷属五蕴为体。以能归依所有言说由心等起。非离于心。如是归依救济为义。他身圣法及善无为。如何能为自身救济。以归依彼能息无边生死苦轮大怖畏故。三所归依有差别者。佛唯无学。法二俱非。僧体贯通学与无学。又佛体是十根少分。僧通十二。法体非根。择灭无为非根摄故。又归依佛。谓但归依一有为沙门果。归依法者。谓通归依四无为沙门果。归依僧者。谓通归依四有为沙门果及四果能趣向。又佛譬如能示导者。法如安隐所趣方域。僧如同涉正道伴侣。应求此等三差别因。应思何缘于余律仪处立离非梵行为其所学。唯于近事一律仪中。但制令其离欲邪行。颂曰

  邪行最可诃　　易离得不作

论曰。唯欲邪行极为能观。此他世者共所诃责。以能侵毁他妻等故。感恶趣故。非非梵行。又欲邪行易远离故。诸在家者耽着欲故离非梵行难可受持。观彼不能长时修学。故不制彼离非梵行。谓无始来数习力故。淫欲烦恼数起现行。诸在家人随顺欲境。数易和合抑制为难。故不制彼令全远离。又诸圣者于欲邪行一切定得不作律仪。经生圣者亦不行故。离非梵行则不如是。故于近事所受律仪。但为制立离欲邪行。若异此者经生有学。应不能持近事性戒。若诸近事后复从师。要期更受离非梵行。得未曾得此律仪不。有余师说。得此律仪然不由斯方成近事。亦不由此失近事名。亦非先时戒不圆满有说不得未得律仪然获最胜杜多功德名。获最胜远离法者。谓能远离淫欲法故。由此若能远离妻室净修梵行。功不唐捐。若有先时未取妻妾。普于有情类受近事律仪。于后取时宁非犯戒。今非他摄故。如用属己财。谓于今时以咒术力或财理等种种方便。摄彼属己不系于他。如何难令于彼犯戒。又有别理今取彼时。于前律仪无所违犯。颂曰

  得律仪如誓　　非总于相续

论曰。诸受欲者受近事戒。如本受誓而得律仪。本受誓云何。谓离欲邪行。于他所摄诸女人所起他摄想而行非法。如是乃名犯欲邪行。非于一切有情相续先立誓言。我当于彼离非梵行而得律仪。云何今时可名犯戒。既如本誓而得律仪。今正随行如何名犯。先取妻妾后受律仪。于自妻等亦发此戒。以近事等别解律仪。一切有情处所得故。若异此者。于自妻妾非处非时非支非礼。亦应不犯欲邪行戒。于旧所受既有犯者。于新所受应有不犯。故不应为如先所难。何缘于四语业道中立离虚诳语。为近事学处。非立离余离间语等。亦由前说三种因故。谓虚诳语最可诃故。诸在家者易远离故。一切圣者得不作故。复有别因。颂曰

  以开虚诳语　　便越诸学处

论曰。越诸学处被检问时。若开虚诳语。便言我不作。因斯于戒多所违越。故佛为欲令彼坚持。于一切律仪。皆遮虚诳语。云何令彼缘力犯戒时。寻即生惭如实自发露。何缘一切离性罪中。立四种为近事学处。然于一切离遮罪中。于近事律仪。唯遮离饮酒。颂曰

  遮中唯离酒　　为护余律仪

论曰。诸饮酒者心多纵逸不能守护诸余律仪。故为护余令离饮酒谓饮酒已。于恶作说别悔堕落。众余他胜五部罪中不能防守。或有是处。由此普于诸学处海扰乱违越。由此世尊知饮诸酒是起一切性罪因故。能损正念及正智故。能引破戒破见愚故。于一切种离遮罪中。唯说此为近事学处。故离饮酒虽遮戒摄。而于一切立学处中。与离性罪相随而制别解脱律仪从何而得。复从何而得余二律仪。颂曰

  从一切二现　　得欲界律仪
  从根本恒时　　得静虑无漏

论曰。欲界律仪谓别解脱。此从一切根本业道。及从前后近分而得。从二得者。谓从二类。即情非情。性罪遮罪。于情性罪。谓杀等业遮谓女人同室宿等。非情性罪。谓盗外财。遮谓掘地断生草等。从现得者。谓从现世蕴处界得。非从去来由此律仪有情处转。去来非是有情处故。有情处者。谓诸有情及诸有情所依止处现蕴处界内者即是有情所依。外者名为有情所止。非过未故。若得静虑无漏律仪。应知但从根本业道。以定中唯有根本业道故。非从前后近分而得。以在定位唯有根本。在不定位中无此律仪故。从有情数所发遮罪。尚不得此二种律仪。况从非情所发遮罪。从恒时者。谓从过去现在未来。蕴处界得如与此戒。为俱有心由此不同。应作四句。有蕴处界从彼唯得。别解律仪非余二等。第一句者。谓从现世前后近分及诸遮罪。第二句者。谓从去来根本业道。第三句者。谓从现世根本业道。第四句者。谓从去来前后近分于业道等处置业道等声以业道等声说彼依处故。若异此者。则应但说防护未来律仪。但能防未来罪令不起故。非防过现已灭已生律仪。于彼无防用故诸有获得律不律仪。从一切有情支因皆等不非一切等其相云何颂曰

  律从诸有情　　支因说不定
  不律从一切　　有情支非因

论曰。律仪定由调善意乐。普缘一切有情方得。非少分缘恶心随故。支因不定。支谓业道。且于别解诸律仪中有从一切。支谓苾刍戒有从四支得。谓余律仪许因不同。略有二种。一无贪等三种善根。二下中上等起心别。就初因说一切律仪。由一切因一心有故。就后因说一切律仪。名由一因。以下品等不俱起故。此中且就后三因说。或有一类住律仪者。于一切有情得律仪。非一切支。非一切因。谓以下心或中或上受近事勤策戒。或有一类住律仪者。于一切有情得律仪。由一切支。非一切因。谓以下心或中或上受苾刍戒。或有一类住律仪者。于一切有情得律仪。由一切支及一切因。谓以三心受近事勤策苾刍戒。或有一类住律仪者。于一切有情得律仪。由一切因。非一切支。谓以三心受近事近住勤策戒。无有不遍于诸有情。得律仪者已说因故。非于一分诸有情所誓受律仪恶心全息。今应思择。于佛乃至蚁子身上所得律仪为有别不。若有别者。趣不定故。于诸有情所得律仪应有增减。若无别者。何缘杀人犯他胜罪。杀非人者。唯犯粗恶。若杀傍生犯堕落罪。非有情境身差别故。令所受戒亦有差别。然罚罪业有差别者。应知但由别加行故。杀人加行与杀非人。乃至杀蚁皆有差别。由总意乐建立律仪。谓普于有情无有差别。起调善意乐求得律仪。非于一有情不舍恶意乐而可求得别解律仪。故得律仪无有差别。以得律仪者必不别观补特伽罗支处时缘故。谓定不作如是别观。于某有情我离杀等。于某支戒我定能持。于某方域我离杀等。我唯于彼一月等时。除战等缘能离杀等。如是受者不得律仪。但得律仪相似妙行。是故无有。由诸有情身差别故。戒有差别。又于自身不得根本业道所摄别解律仪。勿思法等。由自杀害成无间等所摄罪业。得眷属摄。于理无遮。谓离最初。众余罪等。又此所受别解脱律仪。通于一切能不能境得。非唯于能境得此律仪。要普于有情起无损恼。意乐无别方可得故。若谓不然。于睡闷等皆不可杀故应不得律仪。若谓彼觉得本心已还可杀者。此亦应然。以非所能有可改易。为能境已还可杀故。有作是说。若唯于能得此律仪。应有增减。以所能境与非所能二类有情有转易故。此不成难。境转易时无此律仪。得舍因故。谓所能境及非所能。后转易为不能能境。无理令彼舍得律仪。总于所能得律仪故。若必欲令能不能境有转易故戒有舍得。则成律仪增减过者。岂不有草本无而生。有诸有情永入圆寂。由此应有舍得律仪。亦不离前戒增减失。是故前说于理无过。又于过去一一如来。及所化生入圆寂故。后佛于彼不得律仪。有后律仪减于前失。律仪非对一一有情。各异相续别发得故。又前后佛戒支等故。谓诸律仪随无贪等。为因差别生别类支。一一类支各一无表。总于一切有情处得。如是无表既无细分。不可分析为少为多。如何言有后减前失。又一切佛遍于有情。具一切支律仪无表。以支数等无差别故。无后佛戒减于前失。又佛功德皆平等者。非约有漏。不尔一身前后位别。亦有增减。况望他身无增减失。已说从彼得诸律仪。得不律仪。定从一切有情业道无少分境及不具支不律仪者。此定无有由一切因。下品等心无俱起故。若有一类由下品心得不律仪。后于异时由上品心断众生命。彼但成就下不律仪。亦成杀生上品表等。中品上品例此应知。此中应思。于屠羊等事有唯受一得不律仪。不应言亦有受一事得。若尔何故无从一切因得不律仪。如得律仪者。虽于杀等差别表中先已受一后更别受。而不律仪非更新得。谓先总望一切有情。起无所遮损害意乐。为活命故受不律仪。彼于今时复何所得。故此无有从一切因。然律仪中有从近事受勤策戒。勤策复受苾刍律仪。别别受时。所受业道眷属异故。随要期异得先未得。由此可得从一切因。此中何名不律仪者。谓诸屠羊屠鸡屠猪捕鸟捕鱼猎兽劫盗魁脍典狱缚龙煮狗及罝弶等。等言类显谗构讥刺。伺求人过喜说他非。非法追求以活命者。及王典刑罚断罪弹官等但恒有害心。名不律仪者。由如是种类住不律仪故。有不律仪故。行不律仪故。巧作不律仪故。数习不律仪故。名不律仪者。言屠羊者。谓为活命要期尽寿。恒欲杀羊。余随所应当知亦尔。诸屠羊者。唯于诸羊有损害心。非于余类。宁于一切得不律仪。遍于有情界得诸律仪。其理可尔。由普欲利乐胜阿世耶而受得故。非屠羊等。不律仪人。于己至亲有损害意。乃至为救自身命缘。亦不欲杀。如何可说普于一切得不律仪。此亦可然。不律仪者。普于有情境。善意乐坏故。虽无是处而假说言。设诸有情及父母等。一切皆作羊像现前。屠者遍缘皆有害意。谓彼久习不律仪心。乃至己亲亦无所顾。为活命故。设己至亲现变为羊。尚有害意。况命终后实受羊身。于彼能无杀害意乐。不律仪者受恶戒时。必起如斯凶勃意乐。设我母等身即是羊。我亦当杀。况余生类由此意乐得不律仪。异此但应得处中罪。由此虽了亲现非羊。而亦有害心故。遍得恶戒。虽无圣者当作羊身。而同至亲亦有害意。经主于此作是例言。若观未来羊等自体。于现亲等得不律仪。羊等未来有亲等体。即于彼体无损害心。应观未来至亲等体。于现羊等不得恶戒。如是等例于理不齐。无善意乐故。有恶意乐故。谓彼正受不律仪时。无正思惟调善意乐。我当不害一切有情。有邪思惟凶勃意乐。我当普害一切有情。事虽主羊而心宽遍。是故容有观未来羊。于现圣亲亦发恶戒。非观来世圣及至亲。于现羊身不发恶戒。或无劳诤理应同许。且如有一受屠羊人。虽一生中不与不取。于己妻妾住知足心。哑不能言无语四过。而因羊坏善阿世耶具得七支不律仪罪。如是于亲等虽无害心。而善阿世耶因羊坏故。遍有情界得不律仪。若先要期受善学处。后不全损善阿世耶。由遇别缘唯受杀者。得处中罪非不律仪。但得不律仪必应全损善阿世耶。故具得七支。若有例言。如受善戒有支不具。此亦应尔。谓如有受近事近住。勤策律仪虽不具支。而亦得彼缺支摄戒。受不律仪亦应如是。此例非等律仪不律仪。用功不用功得有异故。谓诸善戒要藉用功。善阿世耶方能受得。以难得故理数必应。非受一时总得一切。若诸恶戒不藉用功。恶阿世耶便能受得。非难得故理数必应。随受一时总得一切。以于欲界不善力强。恶阿世耶任运而起。造诸重恶不待用功。善阿世耶易毁坏故。随受一种便总得余。善则不然故例非等。现见秽草不用功生。要设劬劳嘉苗方起。又如有受不律仪人。作是要期。我于尽寿每昼或夜半月月等。一度屠羊等。亦得不律仪。由不律仪易受得故。以于欲界不善力强。虽不恒为而得恶戒。诸有欲受出家律仪。若作要期。我于尽寿每昼或夜半月月等。一度离杀等。不得善律仪。由善律仪难受得故。以于欲界善法力劣。若不恒持不得善戒。此亦应尔。为例不齐。已说从彼得不律仪。得不律仪及余无表。如何方便未说当说。颂曰

  诸得不律仪　　由作及誓受
  得所余无表　　由田受重行

论曰。不律仪人总有二种。一者生在不律仪家。二生余家后受此业。诸有生在不律仪家。若初现行杀等加行。是人由作得不律仪。若生余家后方立誓。谓我当作如是事业。以求财物养活自身。初立誓时便发恶戒。是人由受得不律仪。由三种因得余无表。余无表者。谓非律仪。非不律仪处中摄故。由三因者。一者由田。谓于如斯有德田所。初施园林等善无表便生。如说有依诸福业事。二者由受。谓自要期言。我从今若不供养佛及僧众不先食等。或作誓限。于斋日月半月每年常施食等。由此有善无表续生。三由重行。谓起如是殷重作意。行善行恶。谓淳净信。或猛利缠造善恶时。能发无表长时相续。乃至信缠势力终尽。如前已说

说一切有部显宗论卷第二十阿毗达磨藏显宗论卷第二十一

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩业品第五之四

如是已说得律仪等。舍律仪等今次当说。且云何舍别解脱律仪。颂曰

  舍别解调伏　　由故舍命终
  及二形俱生　　断善根夜尽
  有说由犯重　　余说由法灭
  迦湿弥罗说　　犯二如负财

论曰。调伏声显律仪异名。由此能令根调伏故。由五缘舍别解律仪。一由故舍。谓于律仪由阿世耶。不怀欣慕。为舍学处。对有解人发起相违表业差别。非但由起舍学处心。如得律仪心无能故。又在梦中舍不成故。非但由起表业差别。忿癫狂等舍不成故。非但由二对傍生等。起心发表舍不成故。二由命终。谓众同分。增上势力得律仪故。三由依止二形俱生。谓身变时心随变故。又二形者。非增上故。四由断灭所因善根。谓表无表业等起心断故。是此律仪因缘断义。舍尽寿戒。由上四缘近住律仪。亦由夜尽谓近住戒。由上四缘及夜尽舍过期限故。夜尽者。谓明相出时。诸轨范师多分共许。如是五种舍律仪缘。有余部师执随犯一感堕重罪舍出家戒。有余部执正法灭时别解律仪无不皆舍。以诸学处结界羯磨所有圣教皆息灭故。对法诸师作如是说。尔时虽无得未得律仪。而先得律仪无有舍义。迦湿弥罗国毗婆沙师蕴理教于心作如是说。非犯随一根本罪时。一切律仪皆有舍义。然犯重者有二种名。一名具尸罗。二名犯戒者。若于所犯应可悔除。发露悔除。唯名具戒。如有财者。负他债时。名为富人。及负债者。若还债已。但名富人。此亦应然。故非舍戒。静虑无漏二律仪等。云何当舍。颂曰

  舍定生善法　　由易地退等
  舍诸无漏善　　由得果退失

论曰。诸静虑地所系善法由二缘舍。一由易地。谓上下生。二由退失。谓退胜定。舍众同分及离染时。亦舍暖等及退分定。为摄此故复说等言。如舍色善由易地退。及离染三无色亦尔。舍无漏善由二种缘。一由得果总舍前道。二由退失舍诸胜道。此或是果。或胜果摄。我于此中应少分别。若舍见道及道类智。当知但由得果非退。道类智果摄。亦必无退故。退所练根亦有退义。若不动法无学俱无。所余无漏容具二种。如是已说舍诸律仪不律仪云何舍。颂曰

  舍恶戒由死　　得戒二形生

论曰。诸不律仪由三缘舍。一者由死舍所依故。众同分力得律仪故。二由得戒。谓若受得别解律仪。或由获得静虑律仪。恶戒便舍。对治力胜舍不律仪。三由相续二形俱起。以于尔时所依变故。不律仪者。受近住戒。至夜尽位舍律仪时。为得不律仪。为名处中者。有余师说。得不律仪恶阿世耶非永舍故。如停热铁赤灭青生。有余师言。若不更作无缘令彼得不律仪。以不律仪依表得故。前说应理。先受戒时恶阿世耶非永舍故。依前表业恶戒还起。处中无表舍复云何。颂曰

  舍中由受势　　作事寿根断

论曰。处中无表舍由六缘。一由受心断坏故舍。谓先誓受。恒于某时敬礼制多。及赞颂等。今作是念。后不更为。彼阿世耶从兹便息。由彼弃舍本意乐故。或复别作势用增强。与先现行。相违事业。本意乐息。无表便断。二由势力断坏故舍。谓由净信。烦恼势力所引无表。彼二限势。若断坏时。无表便舍。如所放箭及陶家轮。故轨范师作如是说。由等起力所引发故。虽舍加行及阿世耶。无表或容尽寿随转。乃至发起极猛利缠。捶击禽兽应知亦尔。或先立限齐尔所时。今限势过无表便断。三由作业断坏故舍。谓虽不舍根本受心。然更不为所受作业。唯除忘念而不作者。以此无表期加行生。绝加行时无表便舍。四由事物断坏故舍。谓所舍施制多园林。及所施为罝网等事。本由彼事引无表生。彼事坏时无表便舍。五由寿命断坏故舍。谓所依止有转易故。六由依根断坏故舍。谓起加行断善恶时各舍彼根所引无表。非至断善。得静虑时方舍处中善恶无表。以羸劣故。起加行时便舍处中善恶无表。所言根者通善恶根。所说断言是断加行。欲非色善及余一切非色染法舍复云何。颂曰

  舍欲非色善　　由根断上生
  由对治道生　　舍诸非色染

论曰。欲界一切非色善法舍由二缘。一断善根。二生上界。应言少分亦离染舍。如忧根等非色善法。三界一切非色染法舍由一缘。谓起治道。若此品类能断道生。舍此品中惑及助伴。何有情有善恶律仪。颂曰

  恶戒人除北　　二黄门二形
  律仪亦在天　　唯人具三种
  生欲天色界　　有静虑律仪
  无漏并无色　　除中定无想

论曰。唯于人趣有不律仪。然除北洲唯三方有。于三方内复除扇搋及半择迦。具二形者律仪亦尔。谓于人中除前所除。并天亦有。故于二趣容有律仪。然唯人中具有三种。谓别解脱静虑无漏。若生欲天及生色界。皆容得有静虑律仪。然无想天但容成就。生无色界彼俱非有。无漏律仪亦在无色。谓若生在欲界天中及生色界中。除中定无想。皆容得有无漏律仪。生无色中唯得成就。以无色故。必不现起。无漏上生。得成下故。已辩诸业性相不同。当释经中所摽诸业。且经中说业有三种。善恶无记。其相云何。颂曰

  安不安非业　　名善恶无记

论曰。诸安隐业说名为善。能得可爱异熟涅槃。暂永二时济众苦故。不安隐业名为不善。由此能招非爱异熟。极能遮止趣涅槃故。非前二业立无记名。不可记为善不善故。是非安隐不安隐义。又经中说。业有三种。福非福等。其相云何。颂曰

  福非福不动　　欲善业名福
  不善名非福　　上界善不动
  约自地处所　　果业无动故

论曰。欲界善业说名为福。非福相违招爱果故。诸不善业说名非福。招非爱果违福业故。上二界善说名不动。岂不世尊说下三定皆名有动。圣说此中有寻伺喜乐受动故。由下三定有寻伺等灾患未息故立动名。不动经中据能感得不动异熟故名不动。如何有动定招无动异熟。虽此定中有灾患动。而业对果非如欲界有动转故。立不动名。谓欲界中余趣处满业。由别缘力可异趣处受。以或有业能感外内。财位形量色力乐等。于天等中此业应熟。由别缘力所引转故。于人等中此业便熟。色无色界余地处业。无容转令异地处受。业果处所无改动故。等引地摄无散动故。依如是义立不动名。应知此中由于因果相属愚故。造非福业。以非福业纯染污故。要依粗重相续无明。由此无明现在前位。不能解信因果相属。是故发起诸非福行。由真实义愚故造福及不动业。真实义者。谓四圣谛。若于彼愚诸异生类。于善心位亦得间起。由此势力令于三界不如实知其性皆苦起。福不动行为后有因。若已见谛者则无是事。乘先行力渐离染时。如次得生欲色无色。又经中说。业有三种。顺乐受等。其相云何。颂曰

  顺乐苦非二　　善至三顺乐
  诸不善顺苦　　上善顺非二
  余说下亦有　　由中招异熟
  又许此三业　　非前后熟故
  顺受总有五　　谓自性相应
  及所缘异熟　　现前差别故

论曰。诸善业中。始从欲界至第三静虑名顺乐受业。以诸乐受唯至此故。诸不善业名顺苦受。第四静虑及无色善业。说名为顺不苦不乐受。此上都无苦乐受故。非此诸业唯感受果。应知亦感彼受资粮。受及资粮。此中名受。随所化欲。总立受名。下诸地中为亦许有。顺非二业。为决定无。有余师言。下地亦有顺非二业。以定中间既无苦乐应无业故。又更有证。谓本论说颇有三业非前非后受异熟耶。曰有。谓顺乐受业色。顺苦受业心心所法。顺不苦不乐受业心不相应行。乃至广说。由此证知下地亦有顺非二业。非离欲界有此三业。俱时熟故。此俱非定证。然于下地中理应定有顺非二业。如顺正理广辩应知。此业为善为不善耶。有作是言。是善而劣。又不可别示。而可总言。于诸善业中。或有一类能感乐受及受资粮。或有一类能感非二。应知此业能益乐受。名顺乐受。如顺马处。或复此业能受于乐。名顺乐受。如顺浴散。顺余受业应知亦然。此业非唯感受异熟。如何总得顺受业名。诸业为因所感异熟。皆似于受。得受名故。所以者何。彼皆如受为身损益及平等故。如水火等。于树枝等为益为损。为等义成。又顺受多略说有五。一自性顺受。谓诸受体。如契经说。受乐受时如实了知受于乐受。乃至广说。二相应顺受。谓一切触。如契经言。顺乐受触。乃至广说。三所缘顺受。谓一切境如契经言。眼见色已唯受于色不受色贪。乃至广说。由色等是受所缘故。四异熟顺受。谓感异熟业。如契经说。顺乐受业。乃至广说。五现前顺受。谓现行受。如契经说。受乐受时二受便灭。乃至广说。非此乐受现在前时。有余受能受此乐受。但据乐受自体现前。即说名为受于乐受。由所顺受有多种故。虽业异熟非皆是受。而可总立顺受业名。谓诸善业为因所感色不相应。能为所缘生乐受故。是诸乐受所领纳故。可爱异熟顺乐受故。亦名乐受。由此善业所招诸果。虽非乐受顺乐受故。招彼业名。顺乐受业。顺苦非二。理亦应然。如是三业。有定不定其相云何。颂曰

  此有定不定　　定三顺现等
  或说业有五　　余师说四句

论曰。此上所说顺乐受等。应知各有定不定异。非定受故立不定名。谓顺乐业非必定熟。若熟必应受乐异熟。顺余二业说亦如是。定复有三。一顺现法受。二顺次生受。三顺后次受。此三定业定感异熟。并前不定总成四种。或有欲令不定受业。复有二种。谓于异熟有定不定。并定业三合成五种。譬喻者说业有四句。一者有业。于时分定异熟不定。谓顺现等三非定得异熟。二者有业。于异熟定时分不定。谓不定业定得异熟。三者有业。于二俱定。谓顺现等定得异熟。四者有业。于二俱不定。谓不定业非定得异熟。彼说诸业总成八种。谓顺现受有定不定。乃至不定亦有二种。于此所说业差别中。颂曰

  四善容俱作　　引同分唯三
  诸处造四种　　地狱善除现
  坚于离染地　　异生不造生
  圣不造生后　　并欲有顶退

论曰。此中唯显顺乐等业。于现等时有定不定。释经所说顺现受等四业相殊。故定业中分为三种。并不定业合而为四。是说为善。理必无有。异熟不定。时分定业。时定唯是。异熟定中。位差别故。非离异熟别有时体。如何时定非异熟耶。此中但依异熟定业。得果位差别。立顺现等故。颇有四业俱时作耶。容有云何遣三使已。自行邪欲俱时究竟。顺现受等。四种业中。几业有能引众同分。唯三能引。除顺现业。以顺现业必依先业所引同分而得起故。即于现生必与果故。何界何趣能造几业。诸界诸趣或善或恶。随其所应皆容造四。总开如是。若就别遮。捺落迦中。善除顺现。无爱果故。余皆得造。不退姓名坚。彼于离染地。若异生类除顺生受可造余三。圣者双除顺生后受。可造余二异生不退。若离彼染。无容于彼无间受生。故彼应除顺生受业。于上界没必还生下。故容造彼顺后受业。圣者不退。若离彼染必无容有于彼更生。故彼双除顺生顺后。随所生地容造顺现。受造不定业。一切处无遮。然诸圣者。若于欲界及有顶处已得离染。虽有退堕。而亦不造顺生后业。从彼退者。必退果故。诸退果已。必不命终。还得本果。住中有位。亦造业耶。亦造云何。颂曰

  欲中有能造　　二十二种业
  皆顺现受摄　　类同分一故

论曰。于欲界中住中有位。容有能造二十二业。谓中有位及处胎中。出胎以后各有五位。胎中五者。一羯剌蓝。二頞部昙。三闭尸。四键南。五钵罗奢佉。胎外五者。一婴孩。二童子。三少年。四中年。五老年。此十一位一生所摄。住中有位能造中有定不定业。乃至能造老时二业。应知亦尔当知如是中有所造。十一种定业皆顺现受摄。由类同分无差别故。谓此中有位与自类十位。一众同分一业引故。由此不别说顺中有受业。即顺生等业所引故。类同分者。谓人等类非趣非生。以约趣生中有生有同分异故。诸定受业其相云何。颂曰

  由重惑净心　　及是恒所造
  于功德田起　　害父母业定

论曰。若所造业由重烦恼。或淳净心。或常所作。或于增上功德田起。功德田者。谓佛法僧。或增上补特伽罗。谓证世出世胜德。于此田所虽无重惑。及淳净心亦非常行。若善不善所起诸业。或于父母设起下缠行损害事。如是一切皆定业摄。有余师说。若以猛利意乐所造。或有造已起欢喜心。或一切时数数惯习。或胜愿力事力所起业皆决定现法果业。其相云何。颂曰

  由田意乐胜　　及定招异熟
  得永离地业　　定招现法果

论曰。由田胜者。闻有苾刍于僧众中作女人语。彼须臾顷转作女人。此等传闻其类非一。由意乐胜者。闻有扇搋救脱诸牛黄门事故。彼须臾顷转作丈夫。此等传闻事亦非一。或有余业亦得现果。谓生此地永离此地染。于此地中诸善不善业必应现受。不重生故。如阿罗汉及不还者。未离染时已造彼业今离染故成现法受彼是何业。谓异熟定。应知此中所说业者。是异熟定非时定业。若有余位顺定受业。彼必定无永离染义。必于余位受异熟果。若于异熟亦不定者。永离染故不受异熟。诸不还者及阿罗汉。于欲三界设退起染。必不生下定涅槃故。异熟定业皆成现受。余随所应类此当说。何田起业定即受耶。颂曰

  于佛上首僧　　及灭定无诤
  慈见修道出　　损益业即受

论曰。于如是类功德田中。为善恶业定即受果。功德田者。谓佛上首僧。约补特伽罗差别有五。一从灭定出。谓此定中得心寂静。此定寂静似涅槃故。若从此定初起心时。如入涅槃还复出者。胜静功德庄严其身。为殷净心生长依处。二从无诤出。谓此定中已能永拔一切烦恼灾患相续。有缘一切有情为境。所起无边增上意乐。无诤功德积集熏身。从此出时彼心相续。不为一切世间定心及不定心之所胜伏。是福非福近果胜田三从慈定出。谓此定中有缘无量有情为境。利益安乐增上意乐积集熏身。出此定时有为无量最胜功德所熏修身。相续而转能生胜业。四从见道出。谓此道中能超一分无始流转所不能超三界轮回生死根本。从此道出有胜净身。相续而生能生胜业。五从修道出。谓此道中能超一分生死根本。余如前说。从如是一一初出位中。乘前所修胜功德势心。犹反顾专念不舍。诸根寂静特异于常。世出世间定不定福。无能胜伏映夺彼者。故说此五名功德田。若有于中为损益业。此业必定能招即果。若从余定余果出时。由前所修定非殊胜。修所断惑未毕竟尽。故彼相续非胜福田。异熟果中受最为胜。今应思择。于诸业中。颇有唯招。心受异熟。或招身受。非心受耶。亦有云何。颂曰

  诸善无寻业　　许唯感心受
  恶唯感身受　　是感受业异

论曰。善无寻业。谓从中定乃至有顶所有善业。于中能招受异熟者。应知但感心受非身。于彼地中无身受故。身受必定与寻相应。非无寻业感有寻果。诸不善业能感受者。应知但感身受非心。以不善因苦受为果。意地苦受决定名忧。忧受必非异熟果摄。故不善业唯感身受。若执忧根定非异熟。诸有情类所发心狂。在何识中。何因所感。依何处起。非异熟耶。颂曰

  心狂唯意识　　由业异熟生
  及怖害违忧　　除北洲在欲

论曰。有情心狂唯在意识。若在五识必无心狂。以五识身无分别故。由何因故有情心狂。由诸有情业异熟起。由何等业异熟起耶。谓由彼用药物咒术令他心狂。或复令他饮非所欲。若毒若酒。或现威严怖禽兽等。或放猛火焚烧山泽。或作坑阱陷坠众生。或余事业令他失念。由此业因于当来世。感得异类大种异熟。由彼势力令心发狂。由此心狂体非异熟。善恶心等皆容狂故。由斯但说业异熟生。谓恶业因。感不平等。异熟大种。依此大种心便失念。故说为狂。如是心狂对于心乱。应作四句。狂非乱者。谓诸狂者不染污心。乱非狂者。谓不狂者诸染污心。狂亦乱者。谓诸狂者诸染污心。非狂乱者。谓不狂者不染污心。有情心狂。为但由此更由四种。其四者何。一由惊怖。谓非人等现可怖形来相逼迫。有情见已遂致心狂。二由伤害。谓因事业恼非人等。由彼嗔故伤其支等遂致心狂。有情身中有别支节。若被打触心即发狂。三由乖违。谓由身内风热淡界互相违反。大种乖适故致心狂。四由愁忧。谓因丧失亲爱等事。愁毒缠怀心遂发狂。如婆私等。何有情类有此心狂。除北俱卢。所余欲界。诸有情类容有心狂。谓欲天心尚有狂者。况人恶趣得离心狂。地狱恒狂。众苦逼故。欲界诸圣唯除诸佛。大种乖适容有心狂。一切如来心无狂乱。无渐舍命无破音声。亦无发白面皱等事。以极淳净妙业所生。又经中说业有三种。谓曲秽浊。其相云何。颂曰

  说曲秽浊业　　依谄嗔贪生

论曰。身语意三各有三种。谓曲秽浊。如其次第应知依谄嗔贪所生。谓依谄生身语意业。名为曲业。谄曲类故。实曲谓见。故契经言。实曲者何。谓诸恶见谄是彼类。故得曲名。从谄所生身语意业。曲为因故。果受因名。是故世尊说彼为曲。若彼嗔生身语意业。名为秽业。嗔秽类故。嗔名秽者。谓嗔现前如热铁丸。随所投处便能烧害自他身心。诸烦恼中为过最重。故薄伽梵重立秽名。是诸秽中之极秽故。从嗔所生身语意业。秽为因故。果受因名。是故世尊说彼为秽。若依贪生身语意业名为浊业。贪浊类故。贪名浊者。谓贪现前染着所缘。是染性故。从彼生等准前应释。又真直道。谓八圣支。能障彼生三业名曲。真实无病。谓求涅槃。障证彼因三业名秽。依外道见。于佛教中。障净信心。不信名秽。以能扰浊净信心故。从彼所起三业名浊。又堕断常违处中行。从彼所起身语意业违直道义故立曲名。由损减见所起诸业能秽净法故立秽名。秽名必依极秽义故。萨迦耶见所起诸业。能障无我真实净见。依障净义故立浊名。又经中说业有四种。谓或有业黑黑异熟或复有业白白异熟。或复有业黑白黑白异熟。或复有业非黑非白无异熟。能尽诸业。经虽略示而不广释。今应释彼。其相何云。颂曰

  依黑黑等殊　　所说四种业
  恶色欲界善　　能尽彼无漏
  应知如次第　　名黑白俱非

论曰。佛依业果性类不同。所治能治殊。说黑黑等四。诸不善业一句名黑。以具染污黑不可意黑故。异熟亦黑。不可意故。色界善业一向名白。不为一切不善烦恼及不善业所陵杂故。异熟亦白。是可意故。非无色者多阙减故。欲界善业。名为黑白。恶所杂故。异熟亦黑白。非爱果杂故。此黑白名依相续立。非据自体互相违故。欲界恶强非善陵杂。故恶业果得纯黑名。诸无漏业能永断尽前三业者。名第四业。此无漏业。非染污故。得非黑名。非顺爱故。又不能感白异熟故。说名非白。然大空经说无学法是纯白者。以无学法。于超诸染。身中可得。非如学法。非超诸染。身中可得。诸无漏业。为皆能尽前三业不。不尔云何。颂曰

  四法忍离欲　　前八无间俱
  十二无漏思　　唯尽纯黑业
  离欲四静虑　　第九无间思
  一尽杂纯黑　　四令纯白尽

论曰。于见道中四法智忍。及于修道离欲染位。前八无间圣道俱行。有十二思唯尽纯黑。离欲界染第九无间圣道俱行。一无漏思双令黑白。及纯黑尽此时总断。欲界善故亦断第九。不善业故离四静虑。一一地染。第九无间道俱行无漏思。此四唯令纯白业尽。所余诸业无异熟故。非所明故于此不论。故于此中唯说十七与无间道俱行圣思能永尽前三有漏业。虽尽诸业是圣慧解。然于此中说近对治。虽身语业亦近治三。非慧相应故此不说何缘诸地有漏善业。唯最后道能断非余。以诸善法非自性断。已断有容现在前故。然由缘彼烦恼尽时。方说名为断彼善法。尔时善法得离系故。由此乃至缘彼烦恼余一品在断义不成。善法尔时犹被缚故。颂曰

  有说地狱受　　余欲业黑杂
  有说欲见灭　　余欲业黑俱

论曰。第一第三皆有异说有余师说。顺地狱受及欲界中顺余受业。如次名为纯黑杂业。谓地狱异熟唯不善业感。故顺彼受名纯黑业。唯除地狱。余欲界中异熟皆通善恶业感。故顺彼受名黑白业。如是所说前已遮遣。谓善无能杂不善故。有余师说。欲见所断及欲界中所有余业。如次名为纯黑俱业。谓见所断无善杂故名纯黑业。欲修所断有善不善故名俱业。此亦非理。二所断中俱有业不能感异熟果故。若谓此中所说三业据有异熟说非无异熟者。不应简言欲见所灭。又强力业理必不应。为力劣者之所陵杂。是故不应说修所断诸不善业亦得离名。亦不应言欲界有善力胜不善。陵伏恶业非所许故。所以者何。以欲界善非数行故。无有能感一劫果故

说一切有部显宗论卷第二十一阿毗达磨藏显宗论卷第二十二

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩业品第五之五

又经中说有三牟尼。又经中言有三清净。俱身语意。相各云何。颂曰

  无学身语业　　即意三牟尼
  三清净应知　　即诸三妙行

论曰。无学身业名身牟尼。无学语业名语牟尼。即无学意名意牟尼。非意牟尼意业为体。何缘唯说色识蕴中有是牟尼。非于余蕴。有余师说。举后及初类显中间。亦有此义。如实义者。胜义牟尼。唯心为体。故契经说。心寂静故有情寂静。此心牟尼。由身语业离众恶故。可以比知。意业于中无能比用。唯能所比合立牟尼。何故牟尼唯在无学。以阿罗汉是实牟尼。诸烦恼言永寂静故。诸身语意三种妙行。名身语意三种清净。无漏妙行永离恶行烦恼垢故。可名清净。有漏妙行犹为恶行烦恼垢污。如何清净。此亦暂时能离恶行烦恼垢故得清净名。或此力能引起无漏胜义清净故立净名。若谓此亦能引烦恼垢故。谓作烦恼等无间缘是则不应名清净者。此亦非理。善心起时。非为染心起加行故。染心无间无漏不生。有漏善心能引无漏。故有漏善得清净名。顺无漏心能除秽故。说此二者。为息有情。计邪牟尼。邪清净故。又经中说有三恶行。又经中言有三妙行。俱身语意。相各云何。颂曰

  恶身语意业　　说名三恶行
  及贪嗔邪见　　三妙行翻此

论曰。一切不善身语二业加行后起。及与根本并不善思。如次名身语意恶行。然意恶行复有三种。谓非意业贪嗔邪见。岂不契经。亦说贪等名为意业。如何今说贪嗔邪见非意业邪。是业资粮故亦名业。如漏资粮亦名漏等。是诸圣贤所诃厌故。又能感得非爱果故。此行即恶故名恶行。三妙行者翻此应知。谓一切善身语二业加行后起。及与根本并诸善思。如次名身语意妙行。然意妙行复有三种。非业无贪无嗔正见。智所赞故。感爱果故。此行即妙。故名妙行。正见邪见虽非益损他。而为彼本故亦成善恶。又经中言。有十业道。或善或恶。其相云何。颂曰

  所说十业道　　摄恶妙行中
  粗品为其性　　如应成善恶

论曰。于前所说恶妙行中。若粗显易知。摄为十业道。如应若善摄前妙行。不善业道摄前恶行。不摄何等妙恶行耶。加行后起等。彼非粗显故。且于不善十业道中。若身恶行令他有情失命失财失妻妾等。说为业道。令远离故。若语恶行过失尤重。说为业道。令远离故。若意恶行重贪嗔等。说为业道。令远离故。加行后起及余过轻。并不善思皆非业道。善业道中身善业道。于身妙行不摄一分。谓加行后起及余善身业。即离饮酒断草施等。语善业道于语妙行不摄一分。谓爱语等意善业道。于意妙行不摄一分。谓诸善思。十业道中前七业道。为皆定有表无表耶。不尔云何。颂曰

  恶六定无表　　彼自作淫二
  善七受生二　　定生唯无表

论曰。七恶业道中六定有无表。谓杀生等。除欲邪行。非如是六。若遣他为。至根本时有表生故。若有自作彼六业道。则六皆有表无表二谓起表时彼便死等后方死等与遣使同。根本成时唯无表故。唯欲邪行必具二种。要是自身所究竟故。非遣他作如自生喜。七善业道。若从受生必皆具二。谓表无表。受生尸罗必依表故。静虑无漏所摄律仪。名为定生。此唯无表。但依心力而得生故。加行后起如根本耶。不尔云何。颂曰

  加行定有表　　无表或有无
  后起此相违

论曰。业道加行必定有表。此位无表。或有或无。若猛利缠淳净心起。则有无表。异此则无。后起翻前定有无表。此位表业。或有或无。第二刹那无表为始。名为后起。故此定有。若于尔时起随前业。则亦有表。异此便无于此义中建立业道。加行根本。后起异相。如顺正理广辩应知。又契经说。苾刍当知。杀有三种。一从贪生。二从嗔生。三从痴生。乃至邪见有三亦尔。岂诸业道于究竟时皆由三根。佛作是说。非诸业道于究竟时皆由三根。加行有异。云何有异。颂曰

  加行三根起　　彼无间生故
  贪等三根生

论曰。不善业道加行生时。一一由三不善根起。依先等起故作是说。杀生加行由贪起者。如有贪彼齿发身分。或为得财。或为戏乐。或为拔济亲友自身。从贪引起杀生加行。从嗔起者。如为除怨发愤恚心起杀加行。从痴起者。如波剌斯作如是说。父母老病。若令命终便生胜福。以令解脱现在众苦。新得胜身明利根故。又谓是法祠中杀生。又诸王等依世法律。诛戮怨敌除剪凶徒。谓成大福起杀加行。又外道言。蛇蝎蜂等为人毒害。杀便获福。羊鹿水牛及余禽兽。本拟供食故杀无罪。又因邪见杀害众生。此等加行皆从痴起。余六加行从三根生。如顺正理广辩其相贪等加行如何从三。以从三根无间生故。谓从贪等三不善根。无间各容生三业道。由此已显从贪嗔痴无间相应生三加行。依无间义亦生业道。已说不善从三根生。善复云何。颂曰

  善于三位中　　皆三善根起

论曰。诸善业道所有加行根本后起。皆从无贪无嗔无痴善根所起。以善三位皆是善心所等起故。善心必与三种善根共相应故。此善三位其相云何。谓远离前不善三位。所有三位应知是善。且如勤策受具戒时。来入戒坛礼苾刍众。至诚发语请亲教师。乃至一白二羯磨等。皆名为善业道加行。第三羯磨竟。一刹那中。表无表业。名根本业道。从此以后至说四依。及余依前相续随转。表无表业皆名后起。如先所说。非诸业道。于究竟位。皆由三根。应说由何根究竟何业道。颂曰

  杀粗语嗔恚　　究竟皆由嗔
  盗邪行及贪　　皆由贪究竟
  邪见痴究竟　　许所余由三

论曰。恶业道中杀生粗语嗔恚业道。由嗔究竟要无所顾。极粗恶心现在前时。此三成故诸不与取欲邪行贪。此三业道。由贪究竟要有所顾。极染污心现在前时。此三成故。邪见究竟要由愚痴。由上品痴现前成故。虚诳离间杂秽语三。一一许容由三究竟。以贪嗔等现在前时。一一能令此三成故。诸恶业道何处起耶。颂曰

  有情具名色　　名身等处起

论曰。如前所说四品业道。三三一三。随其次第。于有情等四处而生。谓杀等三有情处起。要待有情此业道生。故非唯待外物此业道生。岂不此三亦名色处起。一蕴一念亦得名色名。此三要托诸蕴总故。偷盗等三众具处起。于他有情所受用物。欲摄属己业道方成。虽待有情而众具胜。故说三种托众具成。唯邪见一名色处起。由此拨无名色法故。虽此亦拨涅槃为无。而名色门拨无永灭谓尚无苦况苦涅槃。是故但言名色处起。岂不邪见。亦拨有情。何故但言名色处起。由此缘别名色亦生。但拨有情所依名色。拨能依假不说自成。又圣教中有无有情理必无。名色亦无同有情。拨实为无重故成业道拨无假法轻故非业道。是故不言有情处起。虚诳语等三名身等处起。语体必依名等起故。语虽亦托有情等生。而正亲依名身等起。又杂秽语不待有情。无有不托名身等者。或依不共处立业道无失。粗语虽依名身等起。恐谓唯依外此业道亦成。故说唯依有情处起。又发粗语不假饰词。故不说依名身等起。由何建立杀业道成。谓由加行及由果满。于此二分随阙一时。不为杀生根本罪触。颇有杀者起杀加行及令果满。而彼不为杀罪触耶。曰有。云何。颂曰

  俱死及前死　　无根依别故

论曰。若能杀者。起杀加行定欲杀他。与所杀生俱时舍命。或在前死。彼能杀者业道不成。所以者何。以所杀者命未断故。以能杀者其命已终。别依生故。谓杀加行所依止身今已断灭。虽有别类身同分生非罪依止。此曾未起杀生加行成杀业道。理不应然。若有多人集为军众欲杀怨敌。或猎兽等。于中随有一杀生时。何人得成杀生业道。颂曰

  军等若同事　　皆成如作者

论曰。于军等中若随有一。作杀生事如自作者。一切皆成杀生业道。由彼同许为一事故。如为一事展转相教。故一杀生。余皆得罪。若有他力逼入此中。因即同心。亦成杀罪。唯除若有立誓要期。救自命缘亦不行杀。无杀心故不得杀罪。今应别辩十业道相。谓齐何量名为杀生。乃至齐何名为邪见。且先分别杀生相者。颂曰

  杀生由故思　　他想不误杀

论曰。要由先发欲杀故思。于他有情。他有情想。作杀加行。不误而杀。谓唯杀彼不漫杀余。齐此名为杀生业道。有怀犹豫为杌为人。设复是人。为彼非彼。因起决志。若是若非我定当杀。由心无顾。若杀有情亦成业道。如是业道若定若疑。但具杀缘皆有成理。于刹那灭行杀罪如何成。以起恶心行杀加行。令所杀者。现命灭时。不能为因。引同类命。障应生命。令永不生。故名杀生。由斯获罪。已分别杀生。当辩不与取。颂曰

  不与取他物　　力窃取属己

论曰。前不误等言如应流至后。谓要先发欲盗故思。于他物中起他物想。或力或窃。起盗加行。不误而取。令属己身。齐此名为不与取罪。若有盗取窣堵波物。于佛得罪。佛将涅槃总受世间所施物故。盗亡僧物已作羯磨。于界内僧得偷盗罪。羯磨未了于一切僧。若盗他人及象马等。出所住处业道方成。已辩不与取。当辩欲邪行。颂曰

  欲邪行四种　　行所不应行

论曰。总有四种行不应行。皆得名为欲邪行罪。一于非境。谓他所护。或母或父或父母亲。乃至或失所守护境。二于非道。谓设己妻口及余道。三于非处。谓于制多寺中迥处。四于非时。谓怀胎时。饮儿乳时。受斋戒时有说若夫许受斋戒而有所犯。方谓非时。既不误言亦流至此。若于他妇谓是己妻。或于己妻谓为他妇。道非道等但有误心。虽有所行而非业道。若于此他妇作余他妇想行非梵行。有说亦成。加行受用时并于他境故。有说如杀业道不成加行。究竟时前境各别故。苾刍尼等如有戒妻若有侵陵亦成业道。已辩欲邪行当辩虚诳语。颂曰

  染异想发言　　解义虚诳语

论曰。说听力故成虚诳语。谓于所说异想发言。及所诳者解所说义。染心不误方成业道。所诳未解。杂秽语收语多字成。要最后念表无表业。方成业道。或随所诳解义即成。前字俱行皆此加行。此中解义据所诳者能解名解。非正解义。齐何名为能解正解。前谓解者。住耳识时。后谓正能分别其义。若正解义义意识知。语表耳识俱时灭故。应此业道。唯无表成。是故理应。善义言者。住耳识住。业道即成。能诳具足表无表故。有言所诳随解不解。但异想说业道即成。不尔此同离间语故。随忍不忍要解方成。经说诸言略有十六。谓于不见不闻不觉不知事中言实见等。所见等中言不见等。如是八种名非圣言。不见等中言不见等。所见等中言实见等。如是八种名为圣言。何等名为所见等相。颂曰

  由眼耳意识　　并余三所证
  如次第名为　　所见闻知觉

论曰。若境由眼耳意余识所证如次名所见等。鼻舌身根取至境故总名为觉。余经定说三根所取为所觉故。经言大母。汝意云何。诸所有色非汝眼见。非汝曾见。非汝当见。非希求见。汝为因此起欲起贪起亲起爱起阿赖耶起尼延底起耽着不。不尔大德诸所有声。非汝耳闻。广说乃至。诸所有法非汝意知。广说乃至。不尔大德复告大母。汝于此中应知所见。唯有所见。应知所闻。所觉所知。唯有所闻所觉所知。此经既于色声法境。说为所见所闻所知。准此于余定立所觉。若不许尔所觉是何。又香等三所见等外。于彼三境应不起言。已辩虚诳语。当辩余三语。颂曰

  染心坏他语　　说名离间语
  非爱粗恶语　　诸染杂秽语
  余说异三染　　佞歌邪论等

论曰。若染污心发坏他语。若他坏不坏。俱成离间语。解义不误流至此中。若以染心发非爱语。毁訾于他名粗恶语。前染心语流至此故。解义不误亦与前同。一切染心所发诸语名杂秽语。皆杂秽故。唯前语字流至此中。有说异前三余染心所发。佞歌邪论等。方杂秽语。收佞谓苾刍邪求名利发谄爱语。歌谓倡伎染心悦他作诸谄曲。及染心者讽吟相调。邪论者谓胜数明等。述恶见言等。谓染心所发悲叹及戏论语。轮王现时歌咏等语。随顺出离与染相违。故彼皆非杂秽语摄。有说彼有嫁娶等言。杂秽语收非业道摄薄尘类故。不引无表。非无无表可业道摄已辩三语。当辩意三。颂曰

  恶欲他财贪　　憎有情嗔恚
  拨善恶等见　　名邪见业道

论曰。于他财物非理耽求欲令属己。或力或窃。如是恶欲名贪业道。于有情类起憎恚心。欲为逼迫名嗔业道。于善恶等恶见拨无。此见名为邪见业道。举初摄后。故说等言。具足应如契经所说。谤因谤果二世尊等总十一类。邪见不同。谓无施与。乃至广说。如是已辩十业道相。依何义释诸业道名。颂曰

  此中三唯道　　七业亦道故

论曰。十业道中。后三唯道业之道故立业道名。彼相应思说名为业。彼转故转。彼行故行。如彼势力而造作故。前七是业。身语业故。亦业之道。思所游故。由能等起身语业思。托身语业为境转故。业业之道立业道名。故于此中言业道者。具显业道业业道义。虽不同类而一为余。世记论中俱极成故。或业之道故名业道。亦业亦道故名业道。具足应言业道业道。以一为余但言业道。善业道义类此应知。加行后起应名业道。思亦缘彼为境转故。理亦应说。而不说者。为本依本彼方转故。先说粗品为业道故。内外增减随根本故。一切恶业道皆现善相违断诸善根。由何业道断续善根。差别云何。颂曰

  唯邪见断善　　所断欲生得
  拨因果一切　　渐断二俱舍
  人三洲男女　　见行断非得
  续善疑有见　　顿现除逆者

论曰。恶业道中唯有上品。圆满邪见能断善根。若尔何缘本论中说。云何上品诸不善根。谓诸不善根能断善根者。或离欲位最初所除。由不善根能引邪见。故邪见事推在彼根如火烧村。火由贼起。故世间说被贼烧村。何等善根为此所断。谓唯欲界生得善根。色无色善先不成故。施设足论说。断三界善者依上善根。得更远说令此相续。非彼器故。何缘唯断生得善根。加行善根先已退故。此断善根。何因何位。谓有一类成极暴恶意乐随眠。后逢恶友缘力所资转复增盛。故善根减不善根增。后起拨因拨果邪见。令一切善皆悉隐没。由此相续离善而住。此因此位断诸善根邪见有二。谓自界缘。及他界缘。或有漏缘及无漏缘。谁能断善。应言一切能断善根。九品善根为可顿断。如见道断见所断耶。不尔云何。谓渐次断。九品邪见九品善根。顺逆相望渐次断故。如修道断修所断惑。既如修道断所断惑。理于中间通起不起。诸律仪果有从加行。有从生得。善心所生。随舍彼因。即便舍彼。为在何处。能断善根。人趣三洲非在恶趣。染不染慧不坚牢故亦非天趣。现见善恶诸业果故。言三洲者。除北俱卢。彼无极恶阿世耶故。如是断善依何类身。唯男女身。志意定故。为何行者能断善根。唯见行人非爱行者。诸见行者。恶阿世耶极坚深故。诸爱行者。恶阿世耶极躁动故。由斯理趣遮扇搋等。又此类人如恶趣故。此善根断。其体是何。善断应知非得为体。以重邪见现在前时。能令善根成就得灭。不成就得相续而生。故断善体。即是非得。前已成立非得实有。善根断已。由何复续。由疑有见。谓续善位。或由因力。或依善友。有于因果欻复生疑。所招后世为无为有。有于因果欻生正见。定有后世。先执是邪。尔时善根成就得还。起不成就。得灭名续。善根九品。善根顿续。渐起如顿。除病气力。渐增于现身中能续善不。亦有能续。除造逆人。有余师言。断见增者。亦非现世。能续善根依彼二人。经作是说彼定于现法不能续善根。彼人定从地狱将殁。或即于彼将受生时。能续善根。非余位故。言将生位。谓中有中。将殁时言谓彼将死。若由因力彼断善根。将死时续。若由缘力彼断善根。将生时续。由自他力应知亦尔。又意乐坏非加行坏。断善根者。现世能续。若二俱坏断善根者。要身坏后方续善根。见戒相对应知亦尔。非劫将坏及劫初成。有断善根相续润故。断善邪见四句差别。断善邪见破僧妄语。当知定招无间异熟。已乘义便辩断善根。今应复明本业道义。所说善恶二业道中。有几并生与思俱转。颂曰

  业道思俱转　　不善一至八
  善总开至十　　别遮一八五

论曰。于诸业道思俱转中。且不善与思。从一唯至八。一俱转者。谓离所余贪等三中。随一现起。若先加行所造恶业。贪等余染及不染心。现在前时。随一究竟。二俱转者。谓行邪行。若自行杀盗杂秽语。或遣他为随一成位。贪嗔邪见随一现前。若先加行所造恶业。贪等余染及不染心。现在前时随二究竟。三俱转者。谓先加行所造恶业。贪等起时随三究竟。若遣一使作杀等一。自行淫等俱时究竟。若自作二如理应思。若先加行所造恶业。贪等余染及不染心。现在前事随三究竟。若起贪等。余染心时。自成业摄。离间虚诳语业等使。作一等如理应思。四俱转者。谓欲坏他说虚诳言。或粗恶语意业道一语业道三。若遣二使自行淫等。若先加行所造恶业。贪等起时随三究竟。如是等类准例应思。五六七俱如理应说。八俱转者。谓先加行作六恶业。自行邪欲俱时究竟。余例应思。后三不俱。故无九十。如是已说不善业道。与思俱转数有不同。善业道与思总开容至十。别据显相遮一八五。二俱转者。谓善五识及依无色。尽无生智现在前时。无散善七。此相应慧。非见性故。无色定俱。无律仪故。三俱转者。谓与正见相应意识现在前时。无七色善。四俱转者。谓恶无记心现在前位。得近住近事勤策律仪。六俱转者。谓善五识现在前时。得上三戒。七俱转者。谓善意识无随转色。正见相应现在前时。得上三戒。或恶无记心现前时。得苾刍戒。九俱转者。谓善五识及依无色。尽无生智现在前时。得苾刍戒。或静虑摄尽无生智。相应意识现在前时。十俱转者。谓善意识无随转色。正见相应现在前时。得苾刍戒。诸许亦用。加行善心。受散律仪。作是通说。或余一切有随转色。正见相应心正起位。别据显相所遮如是。通据隐显则无所遮。谓离律仪有一八五。一俱转者。谓恶无记心现在前时。得一支远离。五俱转者。谓善意识无随转色。正见相应现在前时。得二支等。八俱转者。谓此意识现在前时。得五支等善恶业道。于何界趣处。几唯成就。几亦通现行。颂曰

  不善地狱中　　粗杂嗔通二
  贪邪见成就　　北洲成后三
  杂语通现成　　余欲十通二
  善于一切处　　后三通现成
  无色无想天　　前七唯成就
  余处通成现　　除地狱北洲

论曰。且于不善十业道中。那落迦中三通二种。谓粗恶语。杂秽语。嗔三种皆通现行。成就苦逼相骂故。有粗恶语。怨叹悲叫故有杂秽语身心粗强。[怡-台+龍]戾不调由互相憎。故有嗔恚贪及邪见。成而不行。无可爱境故。现见业果故。无相害法故无杀生。谓彼俱由业尽故死无摄财。女故无盗。淫以无用。故无虚诳语。或虚诳语令他想倒。彼想常倒故无诳语。彼常离故。或无用故。无离间语。北俱卢洲贪嗔邪见皆定成就。而不现行。不摄我所故。身心柔软故。无恼害事故无恶意乐故唯杂秽语。彼通现成。由彼有时染心歌咏寿量定故。无有杀生。无摄财物及女人故。无不与取及欲邪行。无诳心故。无诳虚语。或无用故。常和穆故无离间语。言清美故无粗恶语。除前地狱北俱卢洲。余欲界中十皆通二。谓于欲界天鬼傍生及人三洲。十恶业道皆通成现。然有差别。谓天鬼傍生。前七业道唯有处中摄。无不律仪。人三洲中。二种俱有。已说不善善业道中无贪等三。于三界五趣皆通二种。谓成就现行。身语七支。无色无想。但容成就。必不现行。谓圣有情生无色界。成就过未。无漏律仪。无想有情。必成过未。第四静虑。静虑律仪。然圣随依。何静虑地。曾起曾灭。无漏尸罗。生无色时。成彼过去。若未来世。六地皆成。二处皆无。现起义者。无色唯有。四蕴性故。无想有情无定心故。律仪必托大种定心。二处互无故不现起。余界趣处除地狱北洲七善。皆通现行及成就。然有差别。谓鬼傍生。有离律仪。处中业道。若于色界唯有律仪。三洲欲天皆具二种

说一切有部显宗论卷第二十二阿毗达磨藏显宗论卷第二十三

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩业品第五之六

善恶业道得果云何。颂曰

  皆能招异熟　　等流增上果
  此令他受苦　　断命坏威故

论曰。且先分别十恶业道各招三果。其三者何。异熟等流增上别故。谓于十种。若习若修。若多所作。由此力故生捺落迦。是异熟果。从彼出已来生此间。人同分中受等流果。谓杀生者寿量短促。不与取者资财乏匮。欲邪行者妻不贞良。虚诳语者多遭诽谤。离间语者亲友乖穆。粗恶语者恒闻恶声。杂秽语者言不威肃。贪者贪盛。嗔者嗔增。邪见者痴增上。近增上果亦名等流。此十所招增上果者。谓外所有诸资生具。由杀生故光泽鲜少。不与取故多遭霜雹。稼穑微薄果实希少。欲邪行故多诸尘埃。虚诳语故多诸臭秽。离间语故所居险曲。粗恶语故多诸恶触。田丰荆棘硗确碱卤。杂秽语故时候变改。贪故果少。嗔故果辣。由邪见故果少或无。是名业道增上果别。为一杀业感地狱已。复感短寿外恶果耶。有余师言。即一杀业先受异熟。次近增上。后远增上。故有三果。理实杀时。能令所杀受苦命断坏失威光。令他苦故生于地狱。断他命故人中寿短。先是加行果。后是根本果。根本近分俱名杀生。由坏威光感恶外具。是故杀业得三种果。余恶业道如理应思。由此应准知善业道三果。且于离杀。若习若修若多所作。由此力故生于天中受异熟果。从彼殁已来生人中。受极长寿。近增上果。即复由此感诸外具有大威光。远增上果。余善三果翻恶应说。又契经说。八邪支中分色业为三。谓邪语业命离邪语业。邪命是何。虽离彼无而别说者。颂曰

  贪生身语业　　邪命难除故
  执命资贪生　　违经故非理

论曰。嗔痴所生身语二业。如次唯名邪语邪业。从贪所生身语二业。名邪语邪业。亦说名邪命。以难除故异二别立。贪细能夺诸有情心。极聪慧人犹难禁护。故此对二为极难除。诸在家人邪见难断。以多妄执吉祥等故。诸出家者邪命难除。所有命缘皆属他故。为于正命令殷重修。故佛离前别说为一。有余师执。缘命资具贪欲所生身语二业方名邪命。非余贪生。所以者何。为自戏乐作歌舞等非资命故。此违经故。理定不然。戒蕴经中观象斗等世尊亦立在邪命中。邪受外尘虚延命故。由此非独命资粮贪。所发身语方名邪命。正语业命翻此应知。诸业道中随粗细说先身后语。八道支内据顺相生先语后身。故契经中说寻伺已发语。如前所说。果有五种。何等业有几果。颂曰

  断道有漏业　　具足有五果
  无漏业有四　　谓唯除异熟
  余有漏善恶　　亦四除离系
  余无漏无记　　三除前所除

论曰。道能证断及能断惑。得断道名。即无间道。此道有二种。谓有漏无漏。有漏道业具有五果。等流果者。谓自地中后等若增诸相似法。异熟果者。谓自地中断道所招可爱异熟。离系果者。谓此道力断惑所证择灭无为。士用果者。谓道所牵俱有解脱所修及断。言俱有者。谓俱生法。言解脱者。谓无间生即解脱道。言所修者。谓未来修。断谓择灭。由道力故彼得方起。增上果者。有如是说。谓离自性余有为法。唯除前生。有作是言。断亦应是道增上果。道增上力能证彼故。即断道中无漏道业。唯有四果。谓除异熟。余有漏善。及不善业。亦有四果。谓除离系。异前断道故说为余。次后余言例此应释。谓余无漏及无记业唯有三果。除前所除。谓除前所除异熟及离系。已总分别诸业有果。次辩异门业有果相。于中先辩善等三业。颂曰

  善等于善等　　初有四二三
  中有二三四　　后二三三果

论曰。最后所说。皆如次言。显随所应。遍前门义。且善不善无记三业。一一为因。如其次第对善不善无记三法辩有果数。后例应知。谓初善业。以善法为四果。除异熟。以不善为二果。谓士用及增上。以无记为三果。除等流及离系中不善业。以善法为二果。谓士用及增上。以不善为三果。除异熟及离系。以无记为四果。除离系等流果者。谓见苦所断一切不善业。及见集所断遍行不善业。以欲界中身边见品诸无记法为等流故。后无记业。以善法为二果。谓士用及增上。以不善为三果。除异熟及离系等流果者。谓身边见品诸无记业。以五部不善为等流故。以无记为三果。如不善。已辩三性。当辩三世。颂曰

  过于三各四　　现于未亦尔
  现于现二果　　未于未果三

论曰。过去现在未来三业。一一为因。如其所应。以过去等。为果别者。谓过去业。以三世法各为四果。除离系。现在业。以未来为四果。如前说。以现在为二果。谓士用及增上。未来世业。以未来为三果。除等流及离系。不说后业有前果者。前法定非后业果故。已辩三世。当辩诸地。颂曰

  同地有四果　　异地二或三

论曰。于诸地中随何地业。以同地法为四果。除离系。若是有漏以异地法为二果。谓士用及增上。若是无漏以异地法为三果。除异熟及离系。不堕界故不遮等流。已辩诸地。当辩学等。颂曰

  学于三各三　　无学一三二
  非学非无学　　有二二五果

论曰。学等三业。一一为因。如其次第。各以三法为果别者。谓学业。以学法为三果。除异熟及离系。以无学法为三亦尔。以非二为三果。除异熟及等流。无学业以学法为一果。谓增上。以无学为三果除异熟及离系。以非二为二果。谓士用及增上。非二业。以学法为二果。谓士用及增上。以无学法为二亦尔。以非二为五果。已辩学等。当辩见所断等。颂曰

  见所断业等　　一一各于三
  初有三四一　　中二四三果
  后有一二四　　皆如次应知

论曰。见所断等三业。如次。一一为因。各以三法为果别者初见所断业。以见所断法为三果。除异熟及离系。以修所断法为四果。除离系。以非所断法为一果。谓增上中修所断业。以见所断法为二果。谓士用及增上。以修所断法为四果。除离系。以非所断法为三果。除异熟及等流后非所断业。以见所断法为一果。谓增上。以修所断法为二果。谓士用及增上。以非所断法为四果。除异熟。皆如次者。随其所应。遍上诸门。略法应尔。因辩诸业。应复问言。如本论中所说三业。谓应作业。不应作业。及非应作非不应作。其相云何。颂曰

  染业不应作　　有说亦坏轨
  应作业翻此　　俱相违第三

论曰。有说染污身语意业名不应作。以从非理作意生故。有余师言。诸坏轨则身语意业。设是不染亦不应作。由彼不合世轨则故。谓诸无覆无记身业。若住若行若饮食等。诸有不合世俗礼仪。皆说名为坏轨身业。诸有无覆无记语业坏形言时及作者等。但有不合世俗礼仪。皆说名为坏轨语业。等起前二思名坏轨意业。此及染业名不应作。应作业者与此相翻。俱违前二。是第三业。若依世俗后亦可然。若就胜义前说为善。谓唯善业名为应作。唯诸染业名不应作。无覆无记身语意业名非应作非不应作。然非一切不应作业皆恶行摄。唯有不善。是恶性故得恶行名。以招爱果名为妙行。招不爱果名为恶行。有覆无记虽是不应作而非恶行摄。由此所行决定不能招爱非爱果故。今于此中复应思择。为由一业但引一生。为引多生。又为一生。但一业引为多业引。颂曰

  一业引一生　　多业能圆满

论曰。若依正理应决定说。但由一业唯引一生。此一生言显众同分。以得同分方说名生。若说一生由多业引。或说一业能引多生。如是二言于理何失。且初有失。谓一生中前业果终后业果起业果别故。应有死生。或应多生。无死生理业果终起。如一生故。二俱有过。一本有中应有众多死生有故。或应乃至无余涅槃。中间永无死及生故。何缘定限。一趣处中。有异业果生。便有生死。有异业果起。而无死生。一业果终余业果起。理定应立。有死有生。又许一生定为多种。造作增长业所引故。则应决定无中夭者。或应不受果。而永弃彼业。然先已说。先说者何。谓理必无。时分定业所感异熟。转余时受。又理必无。时分定业非造作增长必受异熟故。若谓有生。由定不定多种业引。或复有生。唯为多种定业所引。故有中夭及有尽寿。此亦不然。时分果业定不定受无决定故。若有一类中年老年。时分果业决定应受。婴孩童子少年果业不定受者。彼复如何。理必无容离前有后。或应前位所有果业。必是定受果故。然于此中无决定理。令前位业决定受果。令后位业受果不定。故无一生多业所引。后亦有失。一业引多生。时分定业应成杂乱故。此无杂乱。如先已辩。故无一业能引多生。若尔何缘尊者无灭。自言我忆昔于一时于殊胜福田一施食异熟。从兹七返生三十三天。七生人中为转轮圣帝。最后生在大释迦家。丰足珍财多受快乐。毗婆沙者。已释此言。一施食为依起多胜思。愿能引位别多异熟生故。作如是言。一施食异熟不应异熟能复感生。但为显依一施食境起多思愿所招异熟分位差别。故作是言。或显初基故作是说。彼由一业感一生中。大贵多财及宿生智。乘斯更造感余生福。如是展转至最后身生富贵家得究竟果。如有缘一迦栗沙钵拏方便勤求息利成千倍。言我本由一迦栗沙钵拏遂至今时成大富贵。是故一业唯引一生。虽言一生由一业引。而许圆满。由多业成。譬如画师先以一色图其形状后填众彩。今于此中。一色所喻。为一类业。为一刹那。若喻一类违此宗理。以非一业。引一生言。可约一类。类必多故。多引一生。不应理故。若言一色喻一刹那。非一刹那能图形状。即所立喻于证无能今见此中喻一类业。如何引业约类得成。引一趣业有众多故。此言意显一类业中。唯一刹那。引众同分。同类异类。多刹那业能为圆满。故说为多。故如一色先图形状后填众彩。此言应理。是故虽有同禀人身。而于其中有具支体。诸根形量色力庄严。或有于前多缺减者。为但由业能引满生。不尔一切业一果法。势力强故。亦引满生。与此相违。能满非引。如是二类。其体是何。颂曰

  二无心定得　　不能引余通

论曰。二无心定。虽有异熟而无势力引众同分。以与诸业非俱有故。一切不善善有漏得亦无势力引众同分。以与诸业非一果故。诸余不善善有漏法。皆容通二。谓引及满。契经中说。重障有三。谓业障烦恼障异熟障。如是三障。其体是何。颂曰

  三障无间业　　及数行烦恼
  并一切恶趣　　北洲无想天

论曰。业障体者。谓五无间。一者害母。二者害父。三者害阿罗汉。四者破和合僧。五者恶心出佛身血。烦恼障体者。谓数行烦恼。下品烦恼。若有数行。虽欲伏除难得其便。由彼展转令上品生难可伏除。故亦名障。上品烦恼若不数行。对治道生易得其便。虽极猛利而非障摄。虽住欲界具缚有情平等皆成一切烦恼。而现行别为障不同。故烦恼中。随品上下但数行者。名烦恼障。异熟障体者。谓三恶趣全及善趣一分。即北洲无想。何故名障。能障圣道及道资粮并离染故。虽有余业能障见道。而可转故非如五逆。毗婆沙说。此五因缘。易见易知。说为业障谓处趣生果及补特伽罗。余障废立如理应思。此三障中烦恼最重。以能发业业感果故。有余师言。烦恼与业二障皆最重。以有此者第二生中亦不可治故。无间何义。此无间业。于无间生必受果故。无余生果业能障故。有说。造逆补特伽罗。从此命终定堕地狱中。无间隔故名无间。三障应知。何趣中有。颂曰

  三洲有无间　　非余扇搋等
  少恩少羞耻　　余障通五趣

论曰。非一切障诸趣皆有。且无间业唯人三洲。非北俱卢余趣余界。于三洲内唯女及男。非扇搋等。如无恶戒。有说。父母于彼少恩。彼于父母少羞耻故。谓彼父母生不具身。爱念又微。故言恩少。彼于父母惭愧亦微。要怀重惭愧。方触无间罪。若有人害非人父母亦不成逆罪。少恩羞耻故。谓彼于子无如人恩。子于彼无如人惭愧。已辩业障唯人三洲。余障应知五趣皆有。然烦恼障遍一切处。若异熟障全三恶趣。人唯北洲。天唯无想。于前所辩三重障中说五无间为业障体。五无间业其体是何。颂曰

  此五无间中　　四身一语业
  三杀一诳语　　一杀生加行

论曰。五无间中。四是身业。一是语业。三是杀生。一虚诳语。根本业道。一是杀生业道加行。以如来身不可害故。破僧无间。是虚诳语。既是虚诳语。何缘名破僧。因受果名。或能破故。若尔僧破其体是何。能所破人谁所成就。颂曰

  僧破不和合　　心不相应行
  无覆无记性　　所破僧所成

论曰。僧破体是不和合性。无覆无记心不相应行蕴所摄。岂成无间。如是僧破因妄语生。故说破僧是无间果。非能破者。成此僧破。但是所破僧众所成。此能破人何所成就。破僧异熟何处几时。颂曰

  能破者唯成　　此虚诳语罪
  无间一劫熟　　随罪增苦增

论曰。能破僧人成破僧罪。此破僧罪诳语为性。即僧破俱生语表无表业。此必无间大地狱中。经一中劫受极重苦。余逆不必生于无间。然此不经一大劫者。欲界无有此寿量故。一中劫时亦不满足。经说。天授人寿四万岁时来生人中证独觉菩提故。然不违背寿一劫。言一劫少分中立一劫名故。现有一分。亦立全名。如言此曰。我有障等。若造多逆。初一已招无间狱生。余应无果。无无果失。造多逆人唯一能引。余助满故。随彼罪增苦还增剧。谓由多逆感地狱中。大柔软身多猛苦具。受二三四五倍重苦。或无中夭受苦多时。如何可言余应无果。谁于何处能破于谁。破在何时经几时破。颂曰

  苾刍见净行　　破异处愚夫
  忍异师道时　　名破不经宿

论曰。能破僧者。要大苾刍。必非在家苾刍尼等。以彼依止无威德故。唯见行人。非爱行者。以恶意乐极坚深故。于染净品俱躁动故。要住净行方能破僧。以犯戒人无威德故。即由此证。造余逆后。不能破僧。以造余逆。及受彼果。处无定故。于斯且举净行为初。类显端严语具圆等。丑陋讷等无破能故。要异处破非对大师。以诸如来不可轻逼。言词威肃对必无能。唯破异生非破圣者。他不能引得证净故。有说得忍亦不可破。由决定忍佛所说故。为含二义。说愚夫言。要所破僧。忍师异佛。忍异佛说。有余圣道应说僧破。在如是时。此夜必和不经宿住。如是名曰破法轮僧。能障佛法轮坏僧和合故。谓由僧坏邪道转时。圣道被遮暂时不转。言邪道者。提婆达多妄说五事为出离道。一者不应受用乳等。二者断肉。三者断盐。四者应被不截衣服。五者应居聚落边寺。众若忍许彼所说时。名破法轮。亦名僧破。何洲人几破法轮僧。破羯磨僧何洲人几。颂曰

  赡部洲九等　　方破法轮僧
  唯破羯磨僧　　通三洲八等

论曰。唯赡部洲人少至九。或复过此能破法轮。非于余洲。以无佛故。要有佛处可立异师。要八苾刍分为二众。以为所破能破第九。故众极少。犹须九人。等言为明过此无限。唯破羯磨通在三洲。极少八人。多亦无限。通三洲者。以有圣教及有出家弟子众故。要一界中僧分二部别作羯磨。故须八人。过此无遮。故亦言等。于何时分容有破僧破羯磨僧。从结界后迄今亦有。至法未灭。破法轮僧。除六时分。何等为六。颂曰

  初后疱双前　　佛灭未结界
  于如是六位　　无破法轮僧

论曰。初谓世尊成佛未久。有情有善阿世耶故。恶阿世耶犹未起故。后谓善逝将般涅槃。圣教增广善安住故。必僧和合。佛方涅槃。有余师言。证法性定故。众咸忧戚故。非初非后。于圣教中戒见二疱若未起位亦无破僧。要见疱生方敢破故。未立止观第一双时。法尔由彼速还合故。佛灭后时他不信受。无有真佛为敌对故。未结界时无一界内。僧分二部可名僧破。于此六位无破法轮。如是破僧诸佛皆有。不尔要有宿破他业。于此贤劫迦叶波佛时。释迦牟尼曾破他众故。且止傍论应辩逆缘。颂曰

  弃坏恩德田　　转形亦成逆
  母谓因彼血　　误等无或有
  打心出佛血　　害后无学无

论曰。何缘害母等成无间非余。由弃恩田坏德田故。谓害父母是弃恩田。如何有恩。身生本故。如何弃彼。谓舍彼恩德田。谓余阿罗汉等具诸胜德及能生故。坏德所依故成逆罪。若有父母子初生时。为杀弃于豺狼路等。或于胎中方便欲杀。由定业力子不命终。彼有何恩弃之成逆。彼定由有不活等畏。于子事急起欲杀心。然弃等时必怀悲愍。数数缘子爱恋缠心。若弃此恩下逆罪触。为显逆罪有下中上。故说弃恩皆成逆罪。或由母等田器法然。设彼无恩但害其命。必应无间生地狱中。诸聪慧人咸作是说。世尊于法了达根源。作如是言。但应深信父母形转杀成逆耶。逆罪亦成。依止一故。设有女人羯剌蓝堕。余女收取置产门中。生子杀何成害母逆。因彼血生者。识托方增故。第二女人但如养母。虽诸所作皆应咨决。而害但成无间同类。故唯人趣结生胜。缘害成害母逆非。唯持养者。若于父母起杀加行。误杀余人无无间罪。于非父母起杀加行。误杀父母亦不成逆。若一加行害母及余。二无表生。表唯逆罪。以无间业势力强故。鸣尊者言。亦有二表。表是积集极微成故。今观彼意表有多微。有逆罪收。有余罪摄。有于阿罗汉无阿罗汉想。亦无决定解。此非阿罗汉。无简别故。害成逆罪。非于父母全与此同。以易识知而不识者。虽行杀害无弃恩心。阿罗汉人无别摽相。既难识是亦难知非。故漫心杀亦成无间。若有害父。父是阿罗汉得一逆罪。以依止一故。然显一逆由二缘成。或以二门诃责彼罪。故告始欠持汝已造二逆。所谓害父杀阿罗汉。若于佛所恶心出血。一切皆得无间罪耶。要以杀心方成逆罪。打心出血无间则无。无决定心坏福田故。若杀加行位。彼未成无学。将死方得阿罗汉果。能杀彼者有逆罪耶无。于无学身无杀加行故。若造无间加行不可转。为有离染及得圣果耶。颂曰

  造逆定加行　　无离染得果

论曰。无间加行若必定成。中间决无离染得果。余恶业道加行中间。若圣道生业道不起。转得相续。定违彼故。非已见谛者。业道罪所触。然我所宗无间加行总说有二。一近二远。近不可转。远有转义。于诸恶行无间罪中。何罪最重。于诸妙行世善业中。何最大果。颂曰

  破僧虚诳语　　于罪中最大
  感第一有思　　世善中大果

论曰。为破僧故发虚诳语。诸恶行中此罪最大。如何此罪虚诳语收。由所发言依异想故。谓彼于法有法想。于非法有非法想。于大师有大师想。于己身有非一切智想。然由深固恶阿世耶。隐覆此想。作别异说。设有不以异想破僧。则不能生劫寿重罪。何缘此罪恶行中最。由此毁伤佛法身故。障世生天解脱道故。感第一有异熟果思。于世善中为最大果。能感最极静异熟故。约异熟果故作是说。如其通就五果说者。是则应说与金刚喻定相应思能得大果。谓此能得异熟果外。诸有为无为四阿罗汉果。虽诸无漏无间道思。皆除异熟。得余四果。然此所得最为殊胜。诸结永断。为此果故。为简此故。说世善言。为唯无间罪定生地狱。诸无间同类亦定生彼。非定无间生。非无间业故。无间同类其相云何。颂曰

  污母无学尼　　杀住定菩萨
  及有学圣者　　夺僧和合缘
  破坏窣堵波　　是无间同类

论曰。言同类者。是相似义。若有于母阿罗汉尼。行非梵行为极污辱。是名害母同类业相。若有杀害住定菩萨。是名害父同类业相。若有杀害有学圣者。是名第三同类业相。若有侵夺僧和合缘。是名破僧同类业相。若有破坏佛窣堵波。是名第五同类业相。有异熟业。于三时中。极能为障。言三时者。颂曰

  将得忍不还　　无学业为障

论曰。若从顶位将得忍时。感恶趣业皆极为障。以忍超彼异熟地故。如人将离本所居国。一切债主皆极为障。若有将得不还果时。欲界系业皆极为障。若有将得无学果时。色无色业皆极为障。此后二位喻说如前。然于此中除顺现受。及顺不定受异熟不定业。并异熟定中非异处熟者

说一切有部显宗论卷第二十三阿毗达磨藏显宗论卷第二十四

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩业品第五之七

如上所言住定菩萨。为从何位得住定名。彼复于何说名为定。颂曰

  从修妙相业　　菩萨得定名
  生善趣贵家　　具男念坚故

论曰。从修能感妙三十二大士夫相异熟果业。菩萨方得立住定名。以从此时乃至成佛。常生善趣及贵家等。生善趣者。谓生人天。由此趣中多行善故。妙可称故立善趣名。于善趣内常生贵家。谓婆罗门。或刹帝利。巨富长者。大婆罗门家。于贵家中根有具缺。然彼菩萨恒具胜根。恒受男身尚不为女。何况有受扇搋等身。生生常能忆念宿命所作善事。常无退屈。谓于利乐一切有情。一切时中。一切方便。心无厌倦名无退屈。由无退屈故说为坚。岂不未修妙相业位。菩提心不退。应立住定名。何故要修妙相业位菩萨方受住决定名。尔时人天方共知故。先时但为诸天所知。或于尔时趣等觉定。先唯等觉决定非余。何相应知修妙相业。颂曰

  赡部男对佛　　佛思思所成
  余百劫方修　　各百福严饰

论曰。菩萨要在赡部洲中。方能造修引妙相业。此洲觉慧最明利故。唯是男子非女等身。尔时已超女等位故。此不应说。于前颂中恒受男身义已显故。造此业时唯现对佛。谓亲见佛不共色身。相好端严种种奇特。有欲引起感此类思。不对如来无容起故。此妙相业唯缘佛思。佛是可欣顺德境故。感妙相业唯思所成。非修所成。不定界故。所感异熟。此所系故。非闻所成。彼羸劣故。亦非生得。加行起故。谓彼唯于三无数劫。修行施等波罗蜜多。圆满身中方可得故。唯是加行非生得善。唯余百劫造修非多。一一妙相百福庄严。此中百思名为百福。谓将造一一妙相业时。先起五十思净治身器。其次方起引一相业。于后复起五十善思。庄严引业令得圆满。五十思者。依十业道。一一业道各起五思。且依最初离杀业道有五思者。一离杀思。二劝导思。三赞美思。四随喜思。五回向思。谓回所修向解脱故。乃至邪见各五亦然。有余师言。依十业道各起下等五品善思。前后各然。如熏静虑。有余师说。依十业道各起五思。一加行净。二根本净。三后起净。四非寻害。五念摄受。复有师言。一一相业。各为缘佛。未曾习思。具百现前。而为严饰。百福一一其量云何。有说。以依三无数劫。增长功德所集成身。发起如斯无对无数。殊胜福德量唯佛知。有说。若由业增上力感轮王位。王四大洲。自在而转。是一福量。有说。若由业增上力得为帝释。王二欲天自在而转。是一福量。有说。唯除近佛菩萨。所余一切有情所修富乐果业。是一福量。有余师言。此量大少。应言世界将欲成时。一切有情感大千土业增上力。是一福量。今薄伽梵昔菩萨时。三无数劫中。各供养几佛。颂曰

  于三无数劫　　各供养七万
  又如次供养　　五六七千佛

论曰。初无数劫中供养七万五千佛。次无数劫中供养七万六千佛。后无数劫中供养七万七千佛。三无数劫。一一满时。及初发心。各逢何佛。颂曰

  三无数劫满　　逆次逢胜观
  然灯宝髻佛　　初释迦牟尼

论曰。言逆次者。自后向前。谓于第三无数劫满。所逢事佛。名为胜观。第二劫满。所逢事佛。名曰然灯。第一劫满所逢事佛。名为宝髻。初无数劫首逢释迦牟尼。谓我世尊初发心位。逢一薄伽梵。号释迦牟尼。彼佛出时正居末劫。灭后正法唯住千年。时我世尊为陶师子。于彼佛所起殷净心。涂以香油。浴以香水。设供养已。发弘誓愿。愿我当作佛一如今世尊。故今如来一一同彼。我释迦菩萨。于何位中何波罗蜜多修习圆满。颂曰

  但由悲普施　　被折身无忿
  赞叹底沙佛　　次无上菩提
  六波罗蜜多　　于如是四位
  一二又一二　　如次修圆满

论曰。菩萨发愿初修施时。未能遍于一切含识施一切物。唯运悲心。彼于后时。惯习力故。悲心转盛。能遍施与一切有情。非一切物。若时菩萨普于一切。能施一切。但由悲心。非自希求。胜生差别。齐此布施波罗蜜多修习圆满。若时菩萨被折身支。虽未离欲贪。而心无少忿。齐此戒忍波罗蜜多修习圆满。若时菩萨勇猛精进。以一伽他经七昼夜。赞底沙佛便超九劫。齐此精进波罗蜜多修习圆满。若时菩萨处金刚座。将登无上正等菩提。次无上觉前住金刚喻定。齐此定慧波罗蜜多修习圆满。理应此位无间方圆。得尽智时。此方满故。别别能到圆德彼岸。故此六名波罗蜜多。契经说有三福业事。一施类福业事。二戒类福业事。三修类福业事。此云何立福业事名。颂曰

  施戒修三类　　各随其所应
  受福业事名　　差别如业道

论曰。三类皆福。或业或事。随其所应。如业道说。谓如分别。十业道中。有业亦道。有道非业。此中有福亦业亦事。有福业非事。有福事非业。有唯是福。非业非事。且施类中身语二业。具福业事三种义名。善故是福。作故亦业。是能等起身语业思。转所依门故亦名事。彼等起思唯名福业。思俱有法唯受福名。戒类既唯身语业性。故皆具受福业事名。修类中慈唯名福事。业之事故。慈相应思。以慈为门。而造作故。慈俱思戒唯名福业。余俱有法惟受福名。悲等准此皆应思择。有说。福业显作福义。谓福加行事显所依。谓施戒修。是福业之事。为成彼三起福加行故。有说。唯思是真福业。福业之事。谓施戒修以三为门福业转故。何法名施。施招何果。颂曰

  由此舍名施　　谓为供为益
  身语及能发　　此招大富果

论曰。虽所舍物及能舍具皆可名施。而于此中所立施名。但依舍具。谓由此具舍事得成。故舍所思是真施体。如所度境不得量名。所立量名依能度具。或为捔胜贮藏称誉。传习随他亲爱亲附。由如是等舍事亦成。然非此中正意所说。为简彼故说为供为益言。于己涅槃唯为供养。于余亦为益彼大种诸根。有行施时但为益彼。具名何谓。谓身语业及此能发。能发谓何。谓无贪俱能起此聚即身语业及能起心。并此俱行总名。施体如有。颂言

  若人以净心　　辍已而行施
  此刹那善蕴　　总立以施名

应知如是施类福业事。回向解脱亦得离系果。而且就近决定为言。但说能招大财富果。依何立此大财富名。以财妙广不可夺故。为何所益而行施耶。颂曰

  为益自他俱　　不为二行施

论曰。施主施时观于二益。一为自益感果善根。二为益他诸根大种。施主有二。一有烦恼。二无烦恼。有烦恼者复有二种。一未离欲贪。二已离欲贪。于此二中各有二种。一诸圣者。二诸异生。此中未离欲贪圣者。及已未离欲贪异生。奉施制多唯为自益。谓自增长二种善根。一者能招大富为果。二者为得上义资粮诸有已离。欲贪圣者。奉施制多。除顺现受不招大富。由彼已能毕竟超彼异熟地故。而容为得上义资粮。是故亦名唯为自益。非此能益他根大种。故不益他。无烦恼者。施他有情唯为益他。谓能益他诸根大种。非自增长。二种善根除顺现受。有烦恼者。施他有情为二俱益。无烦恼者。奉施制多。除顺现受。不为二益。前已总明施招大富。今次当辩施果别因。颂曰

  由主财田异　　故施果差别

论曰。施有差别由三种因。谓主财田有差别故。施差别故果有差别。言主财田有差别者。谓如是类施主财田胜劣与余主财田异。且由施主有差别者。颂曰

  主异由信等　　行敬重等施
  得尊重广爱　　应时难夺果

论曰。或有施主于因果中得决定信。或有施主于因果中心怀犹豫。或有施主率尔随欲。或有施主具净尸罗。或少亏违。或全无戒。或有施主于佛教法具足多闻。或有少闻。或无闻等而行惠施。由施主具信戒闻等。差别功德故名主异。由主异故施成差别。由施差别得果有异。诸有施主具如是德。能如法行敬重等四施。如次便得尊重等四果。谓若施主行敬重施。便感常为他所敬重。若自手施。便能感得于广大财爱乐受用。若应时施。感应时财。所须应时。非余时故。若无损他。施便感资财。不为王火等之所侵坏。由所施财有差别者。颂曰

  财异由色等　　得妙色好名
  众爱柔软身　　有随时乐触

论曰。由所施财或阙或具。色香味触如次便得。或阙或具。妙色等果。谓所施财色具足故。便感妙色香具足故。便感好名。如香芬馥。遍诸方故。味具足故。便感众爱。如味美妙众所爱故。触具足故感柔软身。及有随时生乐受触。若有所阙随应果减。如是亦由具色香等。故名财异。由财异故施体及果。皆有差别。由所施田有差别者。颂曰

  田异由趣苦　　恩德有差别

论曰。由所施田趣苦恩德各有差别。故名田异。由田异故施果有殊。由趣别者。如世尊说。若施旁生受百倍果。施犯戒人受千倍果。由苦别者。如七有依福业事中。先说应施客行病侍。园林常食及寒风等。随时食药。复说若有具足净信男子女人成此所说。七种有依福业事者。所获福德不可取量。今于此中由缘差别。故苦有异。由除受者。差别苦故果有差别。由恩别者如父母师及余有恩如熊鹿等。本生经说诸有恩类。于有恩所起诸恶业。果现可知由此比知。行报恩善。其果必定由德别者。如契经言。施持戒人果百千倍。乃至施佛果最无量。虽皆无量亦有少多如殑伽河大海水滴。如望财施法施为尊。就财施中何为最胜。颂曰

  脱于脱菩萨　　第八施最胜

论曰。若已解脱者施已解脱。田于财施中此最为胜。若诸菩萨。以胜意乐。等欲利乐一切有情。为大菩提而行惠施。虽非解脱施解脱田。而施福中此最为胜。除此更有八种施中。第八施福亦最为胜。八施者何。一随至施。二怖畏施。三报恩施。四求报施。五习先施。六希天施。七要名施。八为庄严。心为资助。心为资瑜伽。为得上义而行惠施。如世尊说。施圣果无量。颇施非圣果亦无量耶。颂曰

  父母病法师　　最后生菩萨
  设非证圣者　　施果亦无量

论曰。如是五种设是异生施者。亦能招无量果。住最后有名最后生。法师四田中。是恩田所摄。一切能感无量果业。上下品类皆平等耶。不尔云何。由六因故。令一切业成轻重品。其六者何。颂曰

  后起田根本　　加行思意乐
  由此下上故　　业成下上品

论曰。后起谓作此业已。或顿或数。随前而作。田谓于彼造善造恶。根本谓根本业道。加行谓引彼身语。思谓由彼业道究竟。意乐谓所有意趣。我应当造如是如是。若有六因皆是上品。此业最重翻此最轻。除此中间非最轻重。如契经言。审思作业。名为造作。亦名增长。何因说业名增长耶。由五种因。何等为五。颂曰

  由审思圆满　　无恶作对治
  有伴异熟故　　此业名增长

论曰。由审思故者。谓审思而作。非率尔思作。亦非全不思。由圆满故者谓齐此量业应堕恶趣。此业圆满名为增长。余唯造作。由无恶作对治故者。谓无追悔无对治业。由有伴故者。谓作不善业。不善为助伴。由异熟故者。谓时设不定。定与异熟善上相违。异此应知唯名造作。如上所说。未离欲等。奉施制多。唯为自益。既无受用者。施福如何成。颂曰

  制多舍类福　　如慈等无受

论曰。非我唯许所舍财物。受者受用施福方成。所许者何。谓诸施福略有二类。一舍二受。舍类福者。谓由善心。但舍资财施福便起。受类福者。谓所施田。受用施物施福方起。于制多所奉施供具。虽无受类有舍类福。然舍类福初舍资财。此福即成。对治贪故。无贪俱思所等起故。舍资财已。随所施田受用。或不施福无失。若不尔者。有施僧伽。或别人等。诸资生具。或彼未用。物便坏失。如是施主物应唐捐。施福不生无当果故。彼既未用福由何生。用福虽无而有受福。制多无受福由何生。复何因证知。福生要由受。不受于彼无摄益故。此非定证所以者何如。修慈等福亦生故。谓修慈定。于诸有情。平等发起与乐意乐。虽无受者亦无摄益。而胜解力有多福生。修悲等定得福亦尔。施制多福类亦应然。于有德田追生胜解。起极尊敬奉施制多。虽无受者亦无摄益。由自心力有多福生。然不唐捐起施敬业。要因起业方起胜思。胜思方能生胜福故。有设难言。于善田所植施业种既爱果生。植在恶田。果应非爱。此难非理。所以者何。颂曰

  恶田有爱果　　果种无倒故

论曰。现见田中种果无倒。从未度迦种。苦果终不生。赁婆种中不生甘果。非由田力种果有倒。然由田过令所植种。或生果少。或果全无。如是虽于恶田植施。而由施主利乐他心。唯爱果生不招非爱。已辩施类。戒类当辩。颂曰

  离犯戒及遮　　名戒各有二
  非犯戒因坏　　依治灭净等

论曰。言犯戒者。谓诸不善色。即从杀生乃至杂秽语。此中性罪立犯戒名。遮谓佛所遮。即非时食等。虽非性罪。而佛为护正法有情别意遮止。受戒者犯亦名犯戒。简性罪故但立遮名。离性及遮俱说名戒。此各有二。谓表无表。以身语业为自性故。戒具四德得清净名。随有所减不名清净。言四德者。一者不为犯戒所坏。言犯戒者。谓审思犯。二者不为彼因所坏。彼因谓贪等烦恼随烦恼。三者依治。谓依念住等。此能对治犯戒及因故。四者依灭。谓依涅槃回向涅槃。非有财故。等言为显复有异说。有说。戒净由五种因。一根本净。二眷属净。三非寻害。四念摄受。五回向寂。已辩戒类。修类当辩。颂曰

  等引善名修　　极能熏心故

论曰。等引善者。谓于定中。等持自性及彼俱有即此名修。极熏心故。修是熏义如花熏麻。谓诸定善于心相续。极能熏习令成德类。非不定善故独名修。前辩施福能招大富。戒修二类。所感云何。颂曰

  戒修胜如次　　感生天解脱

论曰。戒感生天。修感解脱。胜言为显。就胜为言。谓施亦能感生天果。就胜说戒。持戒亦能感离系果。就胜说修。如是持戒亦感大富。就胜说施准例应知。经说。四人能生梵福。一为供养如来驮都。建窣堵波于未曾处。二为供养四方僧伽。造寺施园四事供给。三佛弟子破已能和。四于有情普修慈等。如是梵福其量云何。颂曰

  感劫生天等　　为一梵福量

论曰。有余师说。随福能感一劫生天受诸快乐。齐此名曰一梵福量。由彼所感受快乐时。同梵辅天一劫寿故。以于余部有伽他言

  有信正见人　　修十胜行者
  便为生梵福　　感劫天乐故

已离欲者。修四无量。生上界天。受劫寿乐。若未离欲。建窣堵波。造寺和僧。能勤修习慈等加行。彼亦如修无量根本感劫天乐。有余师说。此如所辩。妙相业中。所说福量。契经说施略有二种。一者财施。二者法施。财施已辩。法施云何。颂曰

  法施谓如实　　无染辩经等

论曰。若能如实为诸有情以无染心辩契经等令生正解。名为法施。说如实言显法施主。于契经等解无颠倒。说无染言。显法施主不希利养恭敬名誉。不尔便为自他俱损。契经等者。等余十一。即显契经乃至论议。言契经者。谓能总摄容纳随顺世俗胜义。坚实理言。如是契经是佛所说。或佛弟子。佛许故说。言应颂者。谓以胜妙缉句言词。随述赞前契经所说。有说。亦是不了义经。言记别者。谓随余问酬答辩析。如波罗衍拏等中辩。或诸所有辩曾当现。真实义言皆名记别。有说。是佛诸了义经。言讽颂者。谓以胜妙缉句言词。非随顺前。而为赞咏。或二三四五六句等。言自说者。谓不因请。世尊欲令正法久住。睹希奇事。悦意自说。妙辩等流。如说。此那伽由彼那伽等。言缘起者。谓说一切起说所由。多是调伏相应论道。彼由缘起之所显故。言譬喻者。为令晓悟所说义宗。广引多门比例开示。如长喻等契经所说。有说此。是除诸菩萨说余本行。能有所证示所化言。言本事者。谓说自昔展转传来。不显说人谈所说事。言本生者。谓说菩萨本所行行。或依过去事起诸言论。即由过去事言论究竟。是名本事。如曼驮多经。若依现在事起诸言论。要由过去事言论究竟。是名本生。如逻刹私经。言方广者。谓以正理广辩诸法。以一切法性相众多非广言词不能辩故。亦名广破。由此广言能破极坚无智闇故。或名无比。由此广言理趣幽博余无比故。有说。此广辩大菩提资粮。言希法者。谓于此中唯说希奇出世间法。由此能正显三乘希有故。有余师说。辩三宝言世所罕闻。故名希法。言论义者。谓于上说诸分义中。无倒显示释难决择。有说。于经所说深义。已见真者。或余智人。随理辩释亦名论议。即此名曰摩怛理迦。释余经义时此为本母故。此又名为阿毗达磨。以能现对诸法相故。无倒显示诸法相故。如是所说十二分教略说应知三藏所摄。言三藏者。一素怛缆藏。二毗柰耶藏。三阿毗达磨藏。如是三藏差别云何。未种善根。未欣胜义。令种欣故。为说契经。已种已欣。令熟相续。作所作故。为说调伏。已熟已作令悟解脱。正方便故为说对法。或以广略清妙文词缀缉杂染及清净法。令易解了名为契经。宣说修行尸罗轨则净命方便名为调伏。善能显示诸契经中深义趣言名为对法。或依增上心戒慧学所兴论道。如其次第名为契经调伏对法。或素怛缆藏是力等流。以诸经中所说义理。毕竟无有能屈伏故。毗柰耶藏是大悲等流。辩说尸罗济恶趣故。阿毗达磨藏是无畏等流。真法相中能善安立。问答决择无所畏故。如是等类三藏不同。毗婆沙中已广分别。前已别释三福业事。今释经中顺三分善。颂曰

  顺福顺解脱　　顺决择分三
  感爱果涅槃　　圣道善如次

论曰。顺福分善。谓感世间。人天等中。爱果种子。由此力故。能感世间。高族大宗。大富妙色。轮王帝释。魔王梵王。如是等类诸可爱果。顺解脱分善。谓安立解脱善阿世耶令无倾动。由此决定当般涅槃。辩此善根自性地等。应知如辩贤圣处说。顺决择分善。谓暖等四。此亦如后辩贤圣处说。如世间所说书印算文数。此五自体云何应知。颂曰

  诸如理所趣　　三业并能发
  如次为书印　　算文数自体

论曰。如理起者。正方便生。三业应知。即身语意。能发即是。能起此三。如其所应。受想等法。此中书印。以前身业。及彼能发五蕴为体。非诸字像。即名为书。所雕印文。即名为印。然由业造字像印文。应知名为此中书印。次算及文。以前语业。及彼能发五蕴为体。后数应知。以前意业及彼能发四蕴为体。但由意思能数法故。应辩圣教。诸法相中。少分异名。令不迷谬。颂曰

  善无漏名妙　　染有罪覆劣
  善有为应习　　解脱名无上

论曰。善无漏法。亦名为妙。胜无记染。有漏法故。诸染污法亦名有罪。是诸智者所呵厌故。亦名有覆。以能覆障解脱道故。亦名为劣。极鄙秽故。应弃舍故。准此妙劣。余中已成。故颂不辩。即有漏善。无覆无记总名为中。诸有为善。亦名应习。余非应习。义准已成。解脱涅槃亦名无上。以无一法能胜涅槃。是善是常。超众法故。涅槃是善。极安隐故。余法有上义准已成。即一切有为。虚空非择灭。不具前说。善常相故

说一切有部显宗论卷第二十四阿毗达磨藏显宗论卷第二十五

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩随眠品第六之一

已辩诸业。契经处处说业感有。然见世间已离染者。虽造善业。而无功能招后有果。故于感有。业应非因。业独为因非我所许。要随眠助方能感有。故缘起教初说随眠。此复何因。随眠有几。颂曰

  随眠诸有本　　此差别有六
  谓贪嗔亦慢　　无明见及疑

论曰。以诸随眠是诸有本。要此所发业。方有感有能。此中有名目三有果。故离染者虽造善业。而无势力招后有果。如是随眠略有六种。谓贪嗔慢无明见疑。颂说亦言显同类义。谓嗔如贪虽有多类。而可总说为一随眠。慢等亦然。故复言亦。或此为显如贪与嗔行相不同。故别建立如是慢等行相虽同。余义有异故亦别立。及言为显释据相违。或显总摄随眠类尽。若诸随眠数唯有六。何缘经说有七随眠。颂曰

  六由贪异七　　有贪上二界
  于内门转故　　为遮解脱想

论曰。即前所说六随眠中分贪为二。故经说七。欲贪有贪相差别故。色无色爱佛说有贪。彼贪多托内门转故。又于上二界有起解脱想。为遮彼执故立有名。以此有言目生身义。既说有贪。在上二界。义准欲界。贪名欲贪。故于颂中不别显。示多缘五欲外门转。故如前所说六种随眠。复约异门建立为十。颂曰

  六由见异十　　异谓有身见
  边执见邪见　　见取戒禁取

论曰。六随眠中见行异为五。余非见五。积数总成十。即前六种。复约异门成九十八。其相云何。颂曰

  六行部界异　　故成九十八
  欲见苦等断　　十七七八四
  谓如次具离　　三二见见疑
  色无色除嗔　　余等如欲说

论曰。六种随眠由行部界门差别故成九十八。谓于六中由见行异建立为十。如前已辩。即此所辩十种随眠。部界不同成九十八。部谓见四谛修所断五部。界谓欲色无色三界。且于欲界五部不同。乘十随眠成三十六。谓见苦谛至修所断。如次有十七八四。即上五部。于十随眠。一二一一。如其次第具离三见。二见见疑。谓见苦谛所断具十。一切皆违见苦谛故。见集灭谛所断各七。离有身见边见戒取见。道谛所断八。于前七增戒取。修所断四。离见及疑。如是合成三十六种前三十二名见所断。才见谛时彼即断故。最后有四名修所断。见四谛已。后后时中。数数习道彼方断故。由此已显。十随眠中。萨迦耶见。唯在一部。谓见苦所断。边执见亦尔。戒禁取通在二部。谓见苦见道所断。邪见通四部。谓见苦集灭道所断。见取疑亦尔。余贪等四各通五部。谓见四谛及修所断。如是总说见分十二。疑分为四。余四各五故欲界中有三十六。此中若见缘苦为境。名为见苦。即是苦法苦类智忍。此二所断总说名为见苦所断。乃至见道所断亦然。数习名修。谓见迹者为得上义。于苦等智数数熏习。说名为修。此道所除名修所断。色无色界五部各除嗔。余与欲同。故各三十一。由是一切正理论师。以六随眠约行部界门差别故立九十八。于此所辩九十八中。八十八见所断。忍所害故。十随眠修所断。智所害故。约界非地。建立随眠。由离界贪。立遍知故。谓四静虑。诸烦恼法性少相似。虽有四地而合说一。于四无色合说亦然。经但说色贪无色贪等故。何缘上界无嗔随眠。彼嗔随眠事非有故。谓于苦受有嗔随增。苦受彼无故嗔非有。又彼相续由定润故。又彼非嗔异熟因故。有说。彼无恼害事故慈等善根所居处故。诸所摄受皆远离故。言八十八见所断等。此见修断为定尔耶。不尔云何。颂曰

  忍所害随眠　　有顶唯见断
  余通见修断　　智所害唯修

论曰。于忍所害诸随眠中。有顶地摄唯见所断。唯类智忍方能断故。余八地摄。通见修断。谓圣者断唯见非修。法类智忍如应断故。若异生断唯修非见。数习世俗智所断故。智所害诸随眠。一切地摄唯修所断。以诸圣者及诸异生。如其所应皆由数习无漏世俗智所断故。如前所辩六随眠中。由行有殊见分为五。名先已列。自体如何。颂曰

  我我所断常　　拨无劣谓胜
  非因道妄谓　　是五见自体

论曰。由因教力。有诸愚夫。五取蕴中。执我我所。此见名为萨迦耶见。有故名萨。众谓迦耶。显此所缘有而非一。即于所执我我所事。执断执常名边执见。以妄执取断常边故。于实有体苦等谛中。起见拨无名为邪见。五种妄见皆颠倒转。并应名邪。而但拨无名邪见者。以过甚故。如说。臭苏恶执恶等。此唯损减。余增益故。于劣谓胜。名为见取。有漏名劣圣所断故。执劣为胜。总名见取。理实应立。见等取名。略去等言。但名见取。或见胜故。但举见名。以见为初取余法故。于非因道谓因道见。一切总说名戒禁取。谓大自在时性。或余实非苦因。妄起因执。道有二种。一增上生道。二决定胜道。投火水等种种邪行。非生天因。妄执为因。名第一道。唯受持戒禁性士夫智等非解脱因。妄执为因。名第二道。如前除等。或戒禁胜。是故但立戒禁取名。应知五见自体如是。若于自在等非因计因。如是戒禁取迷于因义。此见何故非见集断。颂曰

  于大自在等　　非因妄执因
  从常我倒生　　故唯见苦断

论曰。于自在等非因计因。彼必不能观察深理。但于自在等诸蕴粗果义。妄谓是常一我作者。此为上首。方执为因。是故此执见苦所断。谓执我者是有身见。于苦果义妄执为我。故现观苦我执即除。非我智生。非于后位。若有我见。见集等断。于相续中。我见随故。即非我智。应不得生。以见唯法时我见即灭故。非我智起。我见已除然有我见。于自在等相续法中计一我已。次即于彼相续法上起边执见。计度为常。由此应知。于自在等法常我二执唯见苦所断。以非常等诸无漏行见苦谛时二见既灭。于自在等非因计因。随二见生。亦俱时灭。故说计因执唯见苦所断。然于非道计为道中。若违见道强。即见道所断。岂不如计自在等为因执苦为因。唯许见苦断非见集断。如是亦应于非道计道执苦为道。唯许见苦断非见道断。此难不然。以于苦谛见为非常等非彼对治故。谓若有执自在等为因。必先计为无始无终等。故此因执唯见苦断。以非常等想治常等想故。非见苦谛。非常等时。能治非道计为道执。故彼道执非见苦断。由此亦遮见集所断。由见因等非彼治故。谓非于集见因等时。能治非道计为道执。要于道谛见道等时。方能治彼非道道执。故彼道执应见道断。若尔如是非道道执。理必应通见集灭断。谓如邪见拨无真道。后即计此能得清净。此戒禁取许见道断。如是邪见拨无集灭。后亦计为能得清净。彼二戒禁取应见集灭断。此难不然。体不成故。谓戒禁取其体有二。一非因计因。二非道计道。若有计彼谤集邪见能得清净。岂不此见。无断集因。则不应生。以都无心。信有因故。又苦与集无别物故。自在等蕴亦应被拨。若有计彼谤灭邪见能得清净。岂不此见。无证灭用。则不应生。如何拨无。灭谛见后。计灭方便。非不唐捐。如是不成戒禁取体。而言应有。故彼非难。如何非难。见道所断。戒禁取体。亦应不成。以于拨无道谛见后。即计有道。应不成故。谓缘道谛邪见或疑。若拨若疑无解脱道。如何即执此能得永清净。此戒禁取体非不成。以许有于谤道邪见。执为能证永清净道。由彼计为如理解故。谓彼先以余解脱道。蕴在心中。后执非谤。真道邪见。为如理觉。言如理者。彼谓拨疑真解脱道。是不颠倒。以如理故执为净因。由此得成。戒禁取体。彼心所蕴。余解脱道。非见道所断。戒禁取所缘。以彼唯缘自部法故。道有多类。于理无失。若尔见灭所断。戒取体亦应成。与道同故。谓有先以余解脱处蕴在心中。后执谤真解脱邪见为如理觉。以如理故执为净因。如前应成戒禁取体。无如是理。总许解脱。是常是寂。执彼谤心为清净因。理不成故。如许涅槃体实非实。谓若希求解脱方便。彼应必定许有解脱。诸许解脱决定有者。必应许彼体是常寂。若不许尔不应希求。如正法中于涅槃体。虽有谓实谓非实异。而同许彼是常是寂。故于非拨俱见为过。如是若有以余解脱。蕴在心中。彼必总许涅槃常寂。由此不执谤解脱见为如理解。故见灭断戒取定无。又如天授。虽总许有常寂涅槃。而离八支。别计五法。为解脱道。外道所计理亦应然。是故有于八支圣道能谤邪见。谓如理觉。无于谤灭。谓如理解。以戒禁等自体行相。与圣道殊。无谓涅槃。常寂体相。有差别者。是故无灭与道同义。今应思择。非道计道。谓执戒禁为解脱因。或执我见能证解脱。此为见苦断。为见道断耶。若执二俱见苦断者。则见道断应毕竟无。或应说别因。等非道计道。何缘此二见苦所断。所余乃是见道断耶。若执二俱见道断者。应说何故见道断耶。非见道时能了彼境。或了彼自体。或断彼所缘。或应遍知建立理坏。谓若见道所断随眠。能缘见苦所断为境。谁遮遍知建立坏失。如现观位苦智已生。集智未生。见苦所断。犹为见集。所断缘缚。虽以永断未立遍知。如是乃至灭智已生。道智未生。见苦所断。犹为见道。所断缘缚。亦应虽断。未立遍知。然非所许。应辩理趣。我宗说二。俱见苦断。唯见苦所断缘牛戒等故。但计粗果。为彼因故。非许二俱见苦所断。见道所断便毕竟无。非道计道有二类故。一缘戒禁等。二缘亲迷道。缘戒禁等违悟道信。力不如缘亲迷道者。缘戒禁等者。行相极粗故。不远随逐故。意乐不坚故。少设劬劳。即便断灭。缘亲迷道与此相违。由此应知非道计道。诸戒禁取有二类别。一见苦断。二见道断。如前所说常我倒生。为但有斯二种颠倒。不尔颠倒总有四种。一于非常执常颠倒。二于诸苦执乐颠倒三于不净执净颠倒。四于非我执我颠倒。如是四倒。其体是何。颂曰

  四颠倒自体　　谓从于三见
  唯倒推增故　　想心随见力

论曰。从于三见立四倒体。谓边见中唯取常见。以为常倒。诸见取中取计乐净为乐净倒。有身见中唯取我见。以为我倒。如是所说是一师宗。然毗婆沙决定义者。约部分别十二见中。唯二见半是颠倒体。谓有身见苦见取全。边执见中取计常分。断常二见行相互违。故可说言二体各别。诸计我论者即执我。于彼有自在力是我所见。此即我见由二门转。岂不诸烦恼皆颠倒转故。应皆是倒非唯四种。不尔建立倒相异故。何谓倒相。谓具三因。何谓三因。一向倒故。推度性故。妄增益故。增声亦显。体增胜故。非余烦恼。具此三因。谓戒禁取非一向倒。所计容离欲染等故少分暂时得清净故。断见邪见非妄增益。于坏事门此二转故。余部见取非增胜故。所余烦恼非推度故。由此颠倒唯四非余。岂不经中说诸颠倒总有十二。如契经言。于非常计常。有想心见倒。于苦不净。非我亦然。不尔想心非推度故。随见倒力亦立倒名。与见相应行相同故。然非受等。亦如想心。可立倒名。有别因故。谓于非常等。起常等见时。必由境中取常等相。能取相者是想非余。故立倒名。非于受等。又治倒慧亦立想名。谓非常等行中。说为非常等想。由慧与想近相资故。相从立名。受等不尔。由所依力有倒推增取境相成。故心名倒。如契经说。心引世间。于惑瀑流处处漂溺。毗婆沙说。唯想与心可立倒名。世极成故。谓心想倒世间极成。受等不然。故经不说。由此心想随见倒力。立颠倒名。非于受等。如是诸倒唯见苦断。以常颠倒等唯于苦转故。了非常等觉唯缘苦生故。不应后见集灭道时。方舍常乐我净见故。辩见随眠差别相已。为余亦有差别相耶。亦有云何。颂曰

  慢七九从三　　皆通见修断
  圣如杀缠等　　有修断不行

论曰。有愚痴者。先于有事非有事中。校量自他心生高举。说名为慢。由行转异分为七种。一慢。二过慢。三慢过慢。四我慢。五增上慢。六卑慢。七邪慢。于他劣等族朋等中。谓己胜等高举名慢。于他等胜族朋等中。谓己胜等名为过慢。于他殊胜族朋等中。谓己胜彼名慢过慢。于五取蕴执我我所。心便高举名为我慢。于未证得地道断等殊胜德中。谓己证得名增上慢。诸有在家或出家者。于他工巧尸罗等德多分胜中。谓己少劣心生高举名为卑慢。于无德中谓己有德名为邪慢。言无德者。谓诸恶行。违功德故。立无德名。犹如不善。然本论说。慢类有九。类是品类义。即慢之差别。九类者何。一我胜慢类。二我等慢类。三我劣慢类。四有胜我慢类。五有等我慢类。六有劣我慢类。七无胜我慢类。八无等应慢类。九无劣我慢类。此九皆依有身见起。我胜者。是过慢类。我等者是慢类。我劣者是卑慢类。有胜我者。是卑慢类。有等我者。是慢类。有劣我者。是过慢类。无胜我者。是慢类。无等我者。是过慢类。无劣我者。是卑慢类。是故此九从三慢出。谓慢过慢及卑慢。三行次有殊成三三类。无劣我慢类高举如何成。谓有如斯于自所乐胜有情聚。虽于己身知极下劣。而自尊重如呈瑞者。或栴荼罗。彼虽自知世所共恶。然于呈瑞执所作时。尊重自身故成高举。如是七慢何所断耶。有余师言。我慢邪慢唯见所断。余通见修。理实应言七皆通二。故能安隐作如是言。我色等中不随执我。然于如是五取蕴中。有我慢爱。随眠未断。诸修所断。圣未断时。定可现行。此不决定。谓有已断而可现行。如已离欲贪信苦随眠等。有虽未断而定不行。如未离欲贪圣者杀缠等。言杀缠者。谓由此缠发起故思断众生命。等者等取盗淫诳缠。无有爱全有爱一分。无有名何法。谓三界非常。于此贪求名无有爱。由此已简无漏非常。彼定非贪安足处故。有爱一分。谓愿当为蔼罗伐拏大龙王等。虽言为显阿素洛王。北俱卢洲无想天等。此杀缠等虽修所断。而诸圣者定不现行。此不行因如后当释。有我慢等例亦应然。无有爱中亦有见断。随经说故言唯修断。如契经言。一类苦逼作如是念。愿我死后断坏无有无病乐哉。此爱但缘众同分起。何缘圣者有诸慢类。我慢等法而不现起。颂曰

  慢类等我慢　　恶作中不善
  圣有而不起　　见疑所增故

论曰。等言为显杀等诸缠。无有爱全有爱一分。以诸圣者善修空故。善知业果相属理故。此慢类等我慢恶悔。圣虽未断而定不行。又此见疑亲所增故。见疑已断故不复行。谓慢类我慢有身见所增。杀生等缠邪见所增。诸无有爱断见所增。有爱一分常见所增。不善恶作是疑所增。故圣身中虽有未断。而由背析皆定不行。余非见疑亲所增故。圣既成就容可现行。九十八随眠中几是遍行几非遍行。颂曰

  见苦集所断　　诸见疑相应
  及不共无明　　遍行自界地
  于中除二见　　余九能上缘
  除得余随行　　亦是遍行摄

论曰。唯见苦集所断。随眠力能遍行。然非一切谓唯诸见疑彼相应。不共无明非余贪等。见有七见。疑有二疑。相应无明即摄属彼。不共有二。故成十一。如是十一。于诸界地中各能遍行。自界地五部。谓自界地五部法中。遍缘随眠为因生染。是故唯此立遍行名。且约界说言三十三是遍依。何义立不共无明名。如是说者。相杂名为共。此非共故立不共名。即是望余各别为义。如契经说。不共佛僧。此显佛僧二宝各别。以不共行故名不共。无明非余随眠相杂行故。或普名共。即是遍义。此非共故立不共名。与诸随眠不相应故。何故唯于见苦集断诸随眠内有遍行耶。唯此普缘诸有漏法。意乐无别势力坚牢。故能为因遍生五部。见灭见道所断随眠。唯有能缘有漏一分。所缘有别势不坚牢。不能为因遍生五部故。唯前二部有遍行随眠。此遍随眠具三遍义。谓于五部遍缘随眠。及能为因遍生染法。此相应法有二遍义。谓于三义唯阙随眠。此俱有法有一遍义。谓但为因遍生染法。若遍行惑。能缘五部。萨迦耶见。缘见灭道。所断法生。为见何断。若见苦断贪等。亦应缘五部故。唯见苦断。又如见取缘见灭道。所断能缘无漏境者。以彼亲迷。迷灭道故。亦是见灭。见道所断。如是身见亦是亲迷。迷灭道故。应见彼断。或应辩此差别因缘。又如见灭。见道断见。取要由遍知境所缘故断。如是身见例亦应然。或复如身见遍知所缘断。如是见取例亦应然。如是二途宗皆不许。是故所立于理不然。理必应然。义有别故。且初所例。贪等亦应缘五部故。唯见苦断。或且举此反例身见。理亦应通五部摄者。此例非理。贪等亦应一念顿缘五部法故。谓有身见一刹那中顿缘五部。受乃至识。为我我所。理不应言。一念身见体分五部。贪等皆是自相惑故。尚无一念顿缘二部。况能缘五。故例不成。后所例言如见灭道。所断见取身见亦然。俱是亲迷。迷灭道故。应亦见灭。见道断者。亦不应理。萨迦耶见不能称誉。谤彼见故。又所缘竟无分限故。非有身见要先称誉。谤灭道见。方计为我。亦非于境作分限缘。见取必由称誉能谤。灭道邪见方计第一。于所缘境作分限缘。义既有殊。不可为例。然有身见见苦谛时遍知所缘。即全永断。非见取者。此有别因。所缘行解等不等故。谓如三界见苦所断诸蕴非我。乃至修断诸蕴非我。其相亦然。故见苦时非我见起。缘所见苦我见皆除。计胜不然。有于少法。观余少法。计为胜故。由此身见随行见取。虽缘见灭道所断法。生粗故如身见唯见苦断。如缘修道所断法生。谤灭道见随行见取。虽亦缘彼所断法生。而彼望前极微细故。乐净行解所不摄故。亲执不欲灭道无明所引邪见为最胜故。虽见苦位遍知所缘。而要所缘永断方断。是故见取非如身见。唯见苦时即全永断。故所说断差别理成。或缘见灭。见道所断。见取各三。谓见苦集及见灭道随一断故。若于见灭见道所断。执果分胜。是见集断。执因分胜。是见集断。若唯执彼为真实觉。不偏执彼因分果分。随缘何生与彼俱断。故见取断。非如身见。若有身见戒取见取。顿缘五部名为遍行。是则遍行。非唯尔所。以于是处。有我见行。是处必应起我爱慢。若于是处净胜见行。是处必应希求高举。是则爱慢。亦应遍行。此难不然。虽见力起而此二种分限缘故。由此遍行唯有十一。前说十一于诸界地中各能遍行自界地五部。为有他界他地遍行。简彼故言自界自地。亦有他界他地遍行。谓十一中除身边见。所余九种亦能上缘。上言正明上界上地。兼显无有缘下随眠。缘下则应遍知界坏。上境胜故。缘无此失。且欲见苦。所断邪见。谤色无色。苦果为无。见取于中执为最胜。戒取于彼非因计因。疑怀犹豫无明不了。见集所断。如应当说。色缘无色例此应知。准界应思约地分别。然诸界地决定异者。欲界乃至第四静虑。有缘上界上地遍行。三无色中阙缘上界。有顶一地二种俱无。虽有随眠通缘自上。然理无有自上顿缘。以自地中诸境界事。是所缘境亦所随眠。若上地中诸境界事。是所缘境。非所随眠。不可一念。烦恼缘境。有随眠处。有不随眠。勿于相应。亦有尔故。于上界地必顿缘耶。非必顿缘。或别或总。身边见何缘不缘上界地。缘他界地。执我我所及计断常。理不成故。谓非于此界此地中生。他界地蕴中有计为我。执有二我。理不成故。执我不成故执我所不成。所执必依我执起故。边见随从有身见生。故亦无容缘他界地。由此唯九缘上理成。有余师言。身边二见。爱力起故。取有执受。为己有故。以现见法。为境界故。必不上缘。生欲界中若缘大梵。起有情常见为何见摄耶理实应言。此二非见。是身边见。所引邪智。现见蕴中执我常已。于不现见。比谓如斯。谓欲界生。不作是执。我是大梵。亦不执言。梵是我所。故非身见。身见无故。边见亦无。边见必随身见起故。非有余见作此行相。故是身边见所引生邪智为遍行体。唯是随眠。不尔云何。并随行法。谓上所说遍行随眠并彼随行受等生等皆遍行摄。同一果故。然随行中唯除诸得。得与所得非一果故。由是遍行因与随眠相对。具成四句差别。九十八随眠中几缘有漏。几缘无漏。颂曰

  见灭道所断　　邪见疑相应
  及不共无明　　六能缘无漏
  于中缘灭者　　唯缘自地灭
  缘道六九地　　由别治相因
  贪嗔慢二取　　并非无漏缘
  应离境非怨　　清净胜性故

论曰。唯见灭道所断邪见疑。彼相应不共无明。各三成六。能缘无漏。谓见灭道断三邪见二疑。相应无明即摄属彼。不共有二故合成六。如是六种诸界地中能缘灭道。名缘无漏。余缘有漏。不说自成。此无漏缘于一一地各缘几地灭道为境。诸缘灭者缘自地灭。谓欲界系缘灭随眠。唯缘欲界诸行择灭。乃至有顶缘灭随眠。唯缘有顶诸行择灭。诸缘道者。缘六九地。谓欲界系缘道随眠。唯缘六地法智品道。若治欲界。若能治余。诸法智品。皆能缘故。色无色界八地所有。缘道随眠。一一唯能通缘九地类智品道。若治自地。若能治余。诸类智品。皆能缘故。何缘谤苦。谤集邪见。欲界系者。能缘九地。初静虑者。能缘八地乃至有顶。唯缘彼地谤灭邪见。于九地中一一唯能缘自地灭。此有所以。所以者何。谓若有法此地爱所润。此地身见执。为我我所。彼诸法灭。还为此地。见灭所断。邪见所缘。此说意言。若有诸行。此地我爱我见所缘。故由耽着此地行故。若闻说有此地行灭。便起此地邪见拨无。非上行中有下耽着。宁下邪见拨彼灭无。虽界地相望因果隔绝。而九地苦集展转相牵。又依生立因更互为因故。一地邪见容有缘多。灭无相牵及相因理。故谤灭邪见唯缘自地灭。然诸善智悟境理通。容有顿缘多地行灭。诸邪见起于境迷谬。固执所隔不能总缘。何缘邪见缘苦集灭。有通唯别缘道不然。由治有殊互相因故。谓所缘道虽诸地别。而展转相属互为因果。故由此邪见六九总缘。灭不相因唯缘自地。岂不法类二智品道。亦互相因下上邪见。应俱能缘法类品道。如缘苦集诸地无遮。此责不然。非对治故。若尔六地法智品道。应非欲界。邪见总缘。上五地中。法智品道。于欲界法非对治故。未至地亦非全属上地者。非欲治故。治欲者亦非全邪见。如是忍所治故。色无色界谤道邪见。应亦能缘法智品道有法智品道治色无色故。若谓法智非全治彼苦集法智品非彼对治故。亦非全能治色无色不能治彼见所断故。初品法智不能治彼初品烦恼非此所治故。法智品非彼所缘。是则应许色无色邪见不能总缘九地类智品非类智品。总能对治上二界中诸烦恼故。谓非第二静虑地等类智品道。亦能为初静虑地等。烦恼对治。初静虑等。亦非全两节。推征如前说。又缘道谛三界随眠。非苦集灭忍所对治。故谤道见理应无能。下上总缘六九地道。如是过网理实皆无。法类相望种类别故。法类智品治类同故。互相因故。互相缘故。谓法智品道同。是欲界中。缘道谛惑。对治种类。此同类道。由互相因互相缘故。设非对治亦欲缘道烦恼所缘类智品道与法智品虽互相因由对治门种类别故。不相缘故。非欲缘道。烦恼所缘。准此已遮色无色界缘道烦恼亦应能缘。治色无色法智品过。谓于此中。虽有少分法智品道。能治上界少分烦恼。亦互相因而由治门种类别故。与类智品不相缘故。非上缘道烦恼所缘。于九地中类智品道。由一种类展转相因。更互相缘治类同故。虽非对治而可总为上八地中缘道感境。是故如颂所说理成。何故贪嗔慢及二取。见无漏断不缘无漏。以诸欣求真解脱者。于贪烦恼定应舍离。若缘无漏如善法欲。希求涅槃及圣道故。求解脱者不应离贪。又灭道谛应是所断。佛说离贪境名断故。如契经说。汝于色中若能断贪。色亦名断。又于贪境见过失故。方得离贪。若许有贪缘无漏者。应于灭道。见过失时贪方得离。此见非净岂能尽惑。又于贪境见功德故。贪方得生。若许有贪缘无漏者。灭静等行观无漏时贪应增长。如何因此能尽诸惑。既俱不尽惑。生死应无穷。是故知贪不缘无漏。缘怨害事方得生嗔。无漏事中离怨害相。故缘无漏嗔必不生。又嗔随眠其相粗恶。诸无漏法最极微妙。故嗔于彼无容得行。诸慢随眠高举相故。性不寂静。诸无漏法极寂静故不生高举。又生慢者。作是念言。我得此法非无漏法。力能为缘起如是慢。以无漏法能治慢故。二取若能缘无漏者。是则应与正见相同。无漏是真净胜性故。二取既无倒应非见所断。是故二取非无漏缘。若尔有于谤涅槃者。邪见等上起嗔随眠。既称所缘应无有过。于有过法起增背心。正合其仪。应远离故。则应嗔恚。非见灭断。无如是失。愚灭相者。于能谤者。方起嗔故。谓于余处执解脱已。于谤真解脱方起不忍心。是故要愚真灭相者。方于谤灭邪见等上。起极憎背。见灭断嗔。诸有不愚真灭相者。于能谤灭邪见等上。若生厌背非嗔随眠。乃是无贪善根所摄。又如腹内积多病者。为活命故。虽食美食。病所杂故皆成衰损。腹无病者。凡有所食一切于身有益无损。如是若有于非灭中妄谓是灭生贪爱者。相续秽故。于邪见等所起憎嫌。皆说名为缘见灭断。邪见等法所起嗔恚。若有如理于真灭中。知是真灭无贪爱者。相续净故。于能谤灭邪见等中。所生厌背皆无过失。若于知有涅槃正见所起嗔恚。见何所断。此不应责。见所断嗔理必无容。缘善法故。此缘正见定修所断。然已见谛者。此不复行缘。谤灭见贪已永断故。宁不信有缘无漏嗔。岂不此嗔世现知有。谓有外道言涅槃中永灭诸根。是大衰损。故我于此定不欣求。此本非嗔乃是邪见。故本论说。于乐计苦是见灭断。邪见所摄。理必应然。以一切苦至极乐处方得永灭。极乐处者。唯真涅槃。此极乐言显胜义乐。彼不能了此乐相故。又不能知生死过故。耽着诸有不乐出离。故起邪见。非般涅槃。宁执此为缘灭嗔恚

说一切有部显宗论卷第二十五阿毗达磨藏显宗论卷第二十六

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩随眠品第六之二

九十八随眠中。几由所缘故随增。几由相应故随增。颂曰

  未断遍随眠　　于自地一切
  非遍于自部　　所缘故随增
  非无漏上缘　　无摄有违故
  随于相应法　　相应故随增

论曰。遍行随眠差别有二。谓于自界地他界地遍行。不遍随眠差别亦二。谓有漏无漏缘。且遍行中自界地者。普于五部自界地法所缘随增。不遍行中有漏缘者。唯于自部自界地法所缘随增。不遍行中无漏缘者。及遍行中他界缘者。于所缘境无随增义。所以者何。彼所缘境非所摄受及相违故。谓若有法为此地中身见及爱摄为己有。可有为此身见爱地中所有随眠所缘随增理。言随增者。谓诸随眠于此法中随住增长。即是随缚增惛滞义。如衣有润尘随住中。如有润田种子增长。非诸无漏及上地法为诸下身见爱摄为己有故。缘彼下惑非所缘随增。以不随缚增惛滞故。若下地生求上地等。是善法欲。非谓染污。为求离染此欲生故。圣道涅槃及上地法与能缘彼下惑相违。故彼二亦无所缘随增理。如于炎石足不随住。如火焰中鹅不增长。此随眠起。亲由所依。然正起时兼托彼境。如是已辩所缘随增。随何随眠。于相应法。由相应故于彼随增。所说随增。谓至未断。故初颂首摽未断言。由此应知。诸缘无漏他界地烦恼唯相应随增。诸缘有漏自界地遍具有所缘相应随增。去来随眠有随增不。应言定有。能发得故。若异此者。诸异生类无染心位应离随眠。然世尊言。幼稚童子婴孩眠病。虽无染欲而有欲贪随眠随增。故说随增。乃至未断。若彼已断即无所缘。相应随增随眠宁有。彼犹不失随眠相故。谓由对治坏其势力。故不随增。然彼随眠体相不失。故言犹有。或据曾当有此用故。今虽无用亦号随眠。如失国王犹存王号。工匠停作其名尚存。九十八随眠中。几不善几无记。颂曰

  上二界随眠　　及欲身边见
  彼俱痴无记　　所余皆不善

论曰。色无色界一切随眠。四支五支定所伏故。无有势力招异熟果。故彼皆是无记性摄。若谓彼能招异熟果。应上二界有非爱受。染招爱受理不成故。然无圣道成无记失。唯有漏法有异熟故。此种类中无异熟者。方可说为无记性故。身边二见及相应痴。欲界系者亦无记性。颠倒转故。宁非不善。且有身见。顺善行故。违断善故。定非不善。爱慢虽有顺修福行。而由见力引彼令起。又断善时。为强因故背善友故。欲俱不善边执见中执断边者。计生断故。不违涅槃。顺厌离门。故非不善。如世尊说。若起此见我于一切皆不忍受。当知此见不顺贪欲随顺无贪。乃至广说。又世尊说。于诸外道诸见趣中此见最胜。谓我不有。我所亦不有。我当不有。我所当不有。执常边见顺我见生。是无记理如我见说。余欲界系一切随眠。与上相违皆是不善。于此不善诸随眠中。有几能为不善根体。颂曰

  不善根欲界　　贪嗔不善痴

论曰。唯欲界系一切贪嗔及不善痴不善根摄。如其次第。世尊说为贪嗔痴三不善根体。唯不善烦恼为不善法。根名不善根。宗义如是。岂不一切已生恶法皆为后因。非唯三种无越二理。以不善根翻对善根而建立故。何缘不建立不慢等善根。五识身中无恶慢等可翻对故。又具五义立不善根。谓通五部遍依六识。是随眠性发恶身语。断善根时为胜加行。慢等不尔。如不善法有不善根。无记法中有是根不。亦有。云何。颂曰

  无记根有三　　无记爱痴慧
  非余二高故　　外方立四种
  中爱见慢痴　　三定皆痴故

论曰。迦湿弥罗国诸毗婆沙师。说无记根亦有三种。谓诸无记爱痴慧三。一切应知无记根摄。慧根通摄有覆无覆。根是因义。无覆无记慧亦能为因。故无记根摄。此三有力生诸无记。何缘疑慢非无记根。疑二趣转慢高转故。谓疑犹豫二趣动转。故不立根。根坚住故。慢高举相向上而转。故不立根。根趣下故。世间共见根相如是。隐于土下故名为根。是体下垂上生苗义。此三如彼。故亦名根。余非随眠。或无胜用。故不立彼为无记根。外方诸师立此有四。谓诸无记爱见慢痴无记名中。遮善恶故。何缘此四立无记根。以诸愚夫修上定者。不过依托爱见慢三。此三皆依无明力转。故立此四为无记根。彼作是言。无覆无记慧力劣故非无记根。根义必依坚牢立故。由慢力故。诸瑜伽师退失百千殊胜功德。故慢力胜立无记根。此四能生无记染法。诸契经中。说有十四诸无记事。彼为同此非善不善名无记耶。不尔。云何。应舍置故。谓问记论总有四种。其四者何。颂曰

  应一向分别　　反诘舍置记
  如死生殊胜　　我蕴一异等

论曰。等言兼摄有约异门。且问四者。一应一向记二应分别记。三应反诘记。四应舍置记。此四如次。如有问者问死生胜我一异等。记有四者。谓答四问。若作是问。一切生者皆当死耶。应一向记一切生者皆定当死。若作是问。一切死者皆当生耶。应分别记有烦恼者死已当生。无烦恼者死已不生。若作是问。人为胜劣。应反诘记。为何所方。为方诸天。为方恶趣。若言方天。应记人劣。若言方恶趣应记人胜。若作是问。蕴与有情为一为异。应舍置记。有情无实故。一异性不成。如马角等利钝等性。已辩随眠不善无记。今应思择。何等随眠。于何事系。何名为事。事虽非一。而于此中辩所系事。此复有二。谓就依缘及部类辩。就依缘者。谓眼识俱所有随眠。唯于色处为所缘系。于自相应诸心心所。意处法处为相应系。如是乃至。若身识俱所有随眠。唯于触处为所缘系。于自相应诸心心所。意处法处为相应系。若意识俱所有随眠。于十二处为所缘系。于自相应诸心心所。意处法处为相应系。就部类者。谓见苦断遍行随眠。于五部法为所缘系。于自相应诸心心所为相应系。见苦所断非遍随眠。唯于自部为所缘系。于自相应诸心心所为相应系。如是一切随应当说。就三世辩。何等有情。有何随眠。能系何事。颂曰

  若于此事中　　未断贪嗔慢
  过现若已起　　未来意遍行
  五可生自世　　不生亦遍行
  余过未遍行　　现正缘能系

论曰。若有情类于此事中随眠随增名系此事。夫为能系必是未断。故初未断如应遍流。且诸随眠总有二种。一者自相。谓贪嗔慢。二者共相。谓见疑痴。贪嗔慢三是自相惑。诸圣教内屡有明文。且如经言。告衣袋母。汝眼于色若不见时。彼色为缘起欲贪不。不尔大德。乃至广说。又契经说。佛告大母。汝意云何。诸所有色。非汝眼见。非汝曾见。非汝当见。非希求见。汝为因此起欲起贪起亲起爱起阿赖耶起尼延底起耽着不。不尔大德。乃至广说。故此事中有贪嗔慢。于过去世已生未断。现在已生能系此事。以贪嗔慢是自相惑。非诸有情定遍起故。岂不已断系义便无。既说系言已显未断。何缘说此被未来系。复说过去已生未断。此未断言应成无用。无无用过。此未断言显有品别渐次断故。即于此论次下文中。亦说未来意遍行等。谓彼贪等九品不同。修道断时九品别断。有缘此事上品随眠。已起已灭已得永断。彼于此事尚有未来余品随眠。未起未灭未得永断犹能为系。是故本论于此义中虽说未来爱等所系。而于过去说未断言。故未断言深成有用。然过去世此品随眠。得永断时。未来亦断。容有余品未来随眠。能系此事未得永断。以未来世意识相应贪嗔慢三遍缘三世。虽于此事或生不生。但未断时皆名能系。未来五识相应贪嗔。若未断可生。唯系未来世。由此已显五识相应可生随眠。若至过去唯系过去。至现亦尔。义准若与意识相应可生随眠。若至过现未断容系非自世法。非唯意识相应随眠。若在未来能缚三世。诸与五识相应随眠。若定不生亦缚三世。谓彼境界。或在未来。或在现在。或在过去。彼虽已得毕竟不生。而未断时性能系缚所余一切见起无明。去来未断遍缚三世。由此三种是共相惑。一切有情俱遍缚故。若现在世正缘境时。随其所应能缚此事。以何为证知贪等惑缘过去等三世境生即于其中能为系缚。由圣教证。故契经言。欲贪处法总有三种。一者过去欲贪处法。二者未来欲贪处法。三者现在欲贪处法。若缘过去欲贪处法生于欲贪。此欲贪生当言于彼过去诸法系非离系。乃至广说。又契经言。若于过去未来现在所见色中起爱起恚。应知于此非色系眼非眼系色。此中欲贪是真能系。如是等类圣教非一。为有去来于彼说系。应言彼有。有相如何。异毕竟无。及现在有为实为假。应言是实。有实假相云何应知。为境生觉。是总有相。若无所待于中生觉。是实有相。如色受等。若有所待于中生觉。是假有相。如瓶军等。不可定执。过去未来唯是假有。无假依故又无所待。能生觉故。谓缘去来现世三境。如次无待生宿住念。求未来愿了他心智。过去未来既有所说。实有相故决定实有。然实有法复有二种。一有作用。二唯有体。有作用法复有二种。一有功能。二功能阙。由此已释。唯有体者。诸假有法亦有二种。一者依实。二者依假。此二如次如瓶如军。然有功能不名作用。所有作用亦名功能。据别功能前说有阙。以如是理蕴在心中。应固立宗去来定有。由有因果染离染事。自性非虚说为实有。非如现在得实有名。现见世间有同时法。体相虽一而有性殊。如地界等内外性异。受等自他乐等性别。此性与有理定无差。性既有殊。有必有别。由是地等体相虽同而可说为内外性别。受等领等体相虽同。而可说为乐等性别。又如眼等。在一相续清净所造色体相同。而于其中有性类别。以见闻等功能别故。非于此中功能异有可有性等功能差别。然见等功能即眼等有。由功能别故有性定别。故知诸法有同一时体相无差。有性类别。既现见有法体同时。体相无差有性类别。故知诸法历三世时。体相无差有性类别。故过未有与现有异。宁知三世容皆实有。颂曰

  三世有由说　　二有境果故
  说三世有故　　许说一切有

论曰。实有过去未来现在。了教正理俱极成故。现在诸法实有极成。何教理证去来实有。且由经中世尊说故。谓世尊说。过去未来色尚非常。何况现在。若能如是观色非常。则诸多闻圣弟子众。于过去色勤修厌舍。于未来色勤断欣求。现在色中勤厌离灭。若过去色非有。不应多闻圣弟子众于过去色勤修厌舍。以过去色是有。故应多闻圣弟子众于过去色勤修厌舍。若未来色非有。不应多闻圣弟子众于未来色勤断欣求。以未来色是有。故应多闻圣弟子众于未来色勤断欣求。又契经言。业虽过去尽灭变坏。而犹是有。何缘知此。所引契经。说有去来。定是了义曾无余处。决定遮止。犹如补特伽罗等故。谓虽处处说有补特伽罗。而可说为实无有体。又契经等分明遮故。由此说有补特伽罗。所有契经皆非了义。又如经说。应害父母。理亦应是不了义经。以余经言。是无间业。无间必堕捺落迦故。又如经言。诸习欲者无有恶业而不能作。此亦应是不了义经。以余经中遮诸圣者由故思造诸恶业故。如是等类随应当知。非此分明决定说有去来世已。复于余处分明决定遮有去来。可以准知。此非了义。然此决定是了义说。以越余经不了相故。岂不亦有遮去来经。如胜义空契经中说。眼根生位无所从来。眼根灭时无所造集。本无今有有已还去。若未来世先有眼根。则不应言本无今有。此意遮眼来从火轮。或从自性或从自在。眼根灭时还造集彼。为显正义故次复言。本无今有有已还去。因中无果故说本无。或约作用故说今有。又具二缘识方生故。谓契经说。识二缘生。如契经言。眼色为缘生于眼识。如是乃至意法为缘生于意识。若未来世非实有者。能缘彼识应阙二缘。既说二缘能生于识。此则唯说实及假依。为根为境方能生识。二唯用彼为自性故。非无可为二缘所摄。由此知佛已方便遮无为所缘识亦得起。既缘过未识亦得生。故知去来体是实有。又一切识必有境故。谓见有境识方得生。如世尊言。各各了别彼彼境相。名识取蕴所了者何。谓色至法。非彼经说。有识无境。由此应知。缘去来识定有境故。实有去来。又已谢业有当果故。谓先所造善不善业。待缘招当爱非爱果。思择业处已广成立。非业无间异熟果生。非当果生时异熟因现在。若过去法其体已无。则应无因有果生义。或应彼果毕竟不生。由此应知去来实有。诸有处俗及出家人。信有如前所辩三世。及有真实三种无为。方可自称说一切有。以唯说有如是法故。许彼是说一切有宗。余则不然。有增减故。谓增益论者。说有真实补特伽罗。及前诸法。分别论者。唯说有现及过去世未与果业。刹那论者。唯说有现一刹那中十二处体。假有论者。说现在世所有诸法亦唯假有。都无论者。说一切法都无自性皆似空花。此等皆非说一切有。经唯总说一切有者。谓十二处曾不别说。唯现在有无有去来。处处经说去来是有。故说一切有通三世无为。唯执现在少分有论。不应自称说一切有。如说现在唯假有论及都无论。不可自称说一切有。彼亦应尔。由彼所言违背圣教及正理故。为遮实有补特伽罗。及为总开有所知法。佛为梵志说如是言。一切有者唯十二处。是故去来决定实有。如是所许一切有宗。自古师承差别有几。谁所立世最善可依。颂曰

  此中有四种　　类相位待异
  第三约作用　　立世最为善

论曰。尊者法救作如是说。由类不同三世有异。彼谓诸法行于世时。由类有殊非体有异。如破金器作余物时。形虽有殊而体无异。又如乳变成于酪时。舍味势等非舍显色。如是诸法行于世时。从未来至现在。从现在入过去。虽舍得类非舍得体。尊者妙音作如是说。由相有别三世有异。彼谓诸法行于世时。过去正与过去相合。而不名为离现未相。未来正与未来相合。而不名为离过现相。现在正与现在相合。而不名为离过未相。如人正染一妻室时。于余姬媵不名离染。尊者世友作如是说。由位不同三世有异。彼谓诸法行于世时。至位位中作异异说。由位有别非体有异。如运一筹。置一名一。置百名百。置千名千。尊者觉天作如是说。由待有别三世有异。彼谓诸法行于世时。前后相待立名有异。非体非类非相有殊。如一女人待前待后。如其次第名女名母。如是诸法行于世时。待现未名过去。待过现名未来。待过未名现在。此四种说。一切有中傅说最初执法转变。故应置在数论朋中。今谓不然。非彼尊者。说有为法其体是常历三世时法隐法显。但说诸法行于世时。体相虽同而性类异。此与尊者世友分同。何容判同数论外道第二第四立世相杂。故此四中第三最善。以约作用位有差别。由位不同立世有异。如我所辩。实有去来不违法性。圣教所许。若拨去来便违法性。毁谤圣教。有多过失。由此应知。尊者世友所立实有过去未来。符理顺经无能倾动。谓彼尊者作如是言。佛于经中说有三世。此三世异云何建立。约作用立三世有异。谓一切行作用未有。名为未来。有作用时。名为现在。作用已灭。名为过去。非体有殊。此作用名为何所目。目有为法引果功能。即余性生时。能为因性义。若能依此立世有殊。或能作余无过辩异。智者应许名鉴理人。若有由迷立世别理。怖他难故弃舍圣言。或了义经拨为不了。许有现在言无去来。或许唯现仍是假有。或总非拨三世皆无。此等皆违圣教正理。智者应斥为迷理人。然我且依尊者世友。约作用立三世有殊。随己堪能排诸过难。是故三世实有义成。诸有智人应随信学。已辩随眠。于如是位系如是事。复应思择诸事未断。彼必被系耶。设事被系。彼必未断耶。若事未断。彼必被系有事被系。而非未断系非未断。其相云何。颂曰

  于见苦已断　　余缘此随眠
  及前品已断　　余缘此犹系

论曰。且见道位。苦智已生集智未生。见苦所断诸事已断。见集所除遍行随眠若未永断。能缘此者于此犹系。及修道位随何道生。九品事中前品已断。余未断品所有随眠。能缘此者于此犹系。及声兼明前前已断后后未断。皆能系义。何事有几随眠随增。此中但应辩所缘相。谓辩何法何识所缘。则易了知。此所系事定有尔所随眠随增。且法与识数各有几。诸法虽多略为十六。三界五部及诸无漏。能缘彼识名数亦然。此中何法为几识境。颂曰

  见苦集修断　　若欲界所系
  自界三色一　　无漏识所行
  色自下各三　　上一净识境
  无色通三界　　各三净识行
  见灭道所断　　皆增自识行
  无漏三界中　　后三净识境

论曰。若欲界系见苦见集修所断法。各五识缘。谓自界三。即如前说。及色界一。即修所断。无漏第五。皆容缘故。且欲界系见苦断法为自界三。识所缘者。谓欲见苦所断一切。及欲见集所断遍行。欲修所断善无记识。色修所断善识非余。无漏识中。唯法智品见集修断。如应当知。若色界系。即前所说三部诸法各八识缘。谓自下三皆如前说。及上界一即修所断。无漏第八皆容缘故。且色界系。见苦断法为自界三。及上界一识所缘者。准前应知。为下界三。识所缘者。谓欲见苦见集所断上缘相应修断善识。若无漏识唯类智品。见集修断。如应当知。若无色系。即前所说三部诸法各十识缘。谓三界三皆如前说。无漏第十皆容缘故。准色界系如应当知。见灭见道所断诸法。应知一一增自识缘。此复云何。谓欲界系见灭所断为六识缘。五识即如前增欲见灭断见道所断。义准应知。色无色系见灭道断随应为九十一识缘八十如前各增自识。若无漏法为十识缘。谓三界中各后三部。即见灭道修所断识。无漏第十皆容缘故。不委释者。如应当思。应以如前所略建立十六法。识蕴在心中。思择随眠所随增事。恐文烦广略示方隅。且有问言。所系事内眼根有几随眠随增。应观眼根总唯有二。谓欲色界各修所断此随所应欲色修断及彼遍行随眠随增。若有问言。缘眼根识复有几种随眠随增。应观此识总有八种。谓欲色界各有三识。即见苦集所断遍俱及修所断。合而成六。无色界一。即修所断空处近分所摄善识。无漏第八皆缘眼根。且应了知一切无漏。决定不为随眠随增。前七随应欲色各三部。无色修断遍随眠随增。谓欲界系。见苦所断遍行俱识。欲见苦断见集断遍。随眠随增翻此应知。见集断识修所断识。欲修所断及诸遍行。随眠随增准此应知。色界三识。无色善识。能缘第四静虑眼根。无色修断及彼遍行随眠随增。若复有问言。缘缘眼根。识复有几种随眠随增。应观此识有十三种。谓于三界各有四识。除见灭断。合成十二。并诸无漏识能缘缘眼根。此随所应三界四部。除见灭断随眠随增。谓欲界系。见苦所断遍行俱识能缘眼根。此识容为欲见苦断。见集断遍修道所断善无记识。及色界系修断善识。并法智品无漏识缘。此诸能缘缘眼根识。随应欲界见苦见集修道所断。色修所断及彼遍行。随眠随增。余随所应。当如理释。乃至无漏缘眼根识。此识容为三界所系。见道所断无漏缘识。修所断善无漏识缘。此诸能缘缘眼根识。随应三界见道所断。修所断遍随眠随增。若别疏条前十二种。各有尔所随眠随增。应言欲界见苦所断。诸缘缘识。欲见苦断见集断遍随眠随增。翻此应知。见集断识修所断识。欲修所断及诸遍行随眠随增。见道断识欲见道断。及诸遍行随眠随增。然无漏缘唯相应缚。所余但作所缘随增。准此应知。色无色界有差别者。见道断识欲界上界。如次应知缘法类品缘眼根识。余所系事例眼应思。今于此中复应思择。若心由彼名有随眠。彼于此心定随增不。此不决定。谓彼随眠未断随增。非已断故。如本论说。彼于此心或有随增。或不随增。云何随增。谓彼随眠与此心相应。及缘心未断。云何不随增。谓彼随眠与此心相应。已得永断。何等名曰有随眠心。有随眠名依何义立。复由何等名有随眠。且前所言。三界各五部十五种识名有随眠心。如是诸心各有二种。谓遍非遍行。有漏无漏缘。染不染心。有差别故。依二义立有随眠名。一是随眠所随增故。二以随眠为助伴故。由随眠故名有随眠。相应随眠通断未断。所缘唯未断心名有随眠。云何与心相应烦恼。乃至未断于心随增。谓彼随眠能引起得。于心相续能为拘碍。又与来世为同类因。引相续中心等流起故。乃至未断说于心随增。断则不然。无随增义。非由断故。令彼离心。故虽已断而名有彼。以助伴性不可坏故。谓对治力于相续中能遮随眠令不现起。及能遮彼所引起得。于心相续不为拘碍。故说已断。相应随眠。无随增理。非对治力能遮随眠俱行伴性。故彼虽已断心名有随眠。若诸随眠缘心未断。随心断未断于心随增故。恒令心得有随眠名。若彼缘心随眠已断。心不由彼名有随眠。道力令心离随眠故。虽为助伴及能所缘。俱非道力能令相离。而对助伴能所缘疏。故此有名。唯据未断助伴性亲。断亦名有。此中身见相应之心。由所相应无明身见随增伴性。名有随眠。由自部余见集断遍唯随增性名有随眠。所余俱非。故非有彼。其余见苦见集所断遍不遍心。如理应思。见灭所断邪见俱心。由所相应无明邪见随增伴性。名有随眠。由自部摄有漏缘遍唯随增性。名有随眠。所余俱非。故非有彼。其余见灭见道所断。若缘无漏缘有漏心。如其所应例应思择。修道所断贪相应心。由所相应无明及爱随增伴性。名有随眠。由自部余及诸遍行唯随增性。名有随眠。所余俱非。故非有彼。余修所断烦恼俱心。如其所应例应思择。诸修所断不染污心。由自部摄随眠及遍唯随增性。名有随眠。如是所论皆约未断。彼若断已有伴性者。唯由伴性名有随眠。依此义门应作略说。颂曰

  有随眠心二　　谓有染无染
  有染心通二　　无染局随增

论曰。有随眠心总有二种。有染无染心差别故。于中有染所有随眠。若未断时。相应具二所缘唯一。若已断时。相应有一所缘都无。彼无染心所有烦恼。唯未断位名有随眠。断已都无。非助伴故。此缘无染所有随眠。在有心前。或俱时断。断缘染者通前后俱。相应与心必俱时断。故染通二。名有随眠。无染局一。有随增性

说一切有部显宗论卷第二十六阿毗达磨藏显宗论卷第二十七

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩随眠品第六之三

如上所辩十种随眠。次第生时谁前谁后。诸随眠起无定次第。可一切后一切生故。然有一类烦恼现行。前后相牵非无次第。就此一类辩次第者。颂曰

  无明疑邪身　　边见戒见取
  贪慢嗔如次　　由前引后生

论曰。谓彼烦恼次第生时。先由无明于谛不了。不欲观苦乃至道谛。由不了故无观察能。既闻二途便怀犹豫。为苦非苦。乃至广说。若遇邪论便生邪见。拨无苦谛。乃至广说。于取蕴中既拨无苦。因此便起萨迦耶见。从此复执我有断常。随执一边计为能净。于如是计执为第一。见已见德缘之起贪。谓此胜他恃而生慢。于他所起违见生嗔。如执我徒憎无我见。或于己见取舍位中。必应起嗔憎嫌所舍。此依一类辩十随眠。相牵现行前后次第。理实烦恼行次无边。以所待缘有差别故。诸烦恼起由几因缘。此起因缘乃有多种。随粗就胜要唯有三。颂曰

  由未断随眠　　及随应境现
  非理作意起　　说惑具因缘

论曰。由三因缘诸烦恼起。且如将起欲贪随眠。未断未遍知欲贪随眠故。顺欲贪境现在前故。缘彼非理作意起故。余随眠起。类此应知。未断未遍知欲贪随眠者。三缘故说。未断遍知。谓得未断故。对治未生故。未遍知境故。又断有二。一有分断。二无分断。故说未断未遍知言。此说随眠由因力起。顺欲贪境现在前者。谓有实境顺欲贪缠。此若现前欲贪便起。此则说随眠由境界力起。缘彼非理作意起者。谓有如木境界现前及有如钻燧非理作意起。钻境界木欲贪火生。此中何名非理作意。谓于上妙衣服花鬘严具涂香雕妆采饰娇姿所显女想。粪聚起有情想所住持心俱颠倒警觉。名非理作意。此则说随眠由加行力起。若随眠起具三因缘。云何许有阿罗汉退。非阿罗汉随眠未断。且非定许烦恼现前。方得名为阿罗汉退。然此且据从前烦恼无间引生。故说无过。以烦恼生总有二种。一从烦恼无间引生。二次所余非烦恼起。若异此者。善无记心无间不应有烦恼起。此中不据次所余生。是故不应举退为难。或此且据具因缘说。实有唯托境界力生。无有因力。加行力者。即上所说随眠并伴。佛说为漏瀑流轭取。漏谓三漏。一欲漏。二有漏。三无明漏。瀑流有四。一欲瀑流。二有瀑流。三见瀑流。四无明瀑流。轭谓四轭。如瀑流说。取谓四取。一欲取。二见取。三戒禁取。四我语取。如是漏等其体云何。颂曰

  欲烦恼并缠　　除痴名欲漏
  有漏上二界　　唯烦恼除痴
  同无记对治　　定地故合一
  无明诸有本　　故别为一漏
  瀑流轭亦然　　别立见利故
  见不顺住故　　非于漏独立
  欲有轭并痴　　见分二名取
  无明不别立　　以非能取故

论曰。欲界烦恼并缠除痴四十一物。总名欲漏。谓欲界系根本烦恼三十一并十缠。色无色界烦恼除痴五十二物。总名有漏。谓上二界根本烦恼各二十六。色无色界虽复亦有惛沉掉举而缠不应依界分别上界缠少不自在故由是有漏唯说烦恼若缠亦依界分别者。则有漏体有五十六。故品类足作如是言。云何有漏谓除无明。余色无色二界所系结缚随眠随烦恼缠。何缘合说二界烦恼为一有漏。同无记性同一对治同定地故。亦缘色声触为境故。不应唯说于内门转。义准三界十五无明为无明漏体。故颂不别。说何缘唯此别立漏。名为显无明过患胜。故谓独能作生死根本。如契经说。无明为因生于贪染。乃至广说。又如颂言

  诸所有恶趣　　此及他世间
  皆无明为根　　贪欲所等起

今于此中。唯据胜显说一百八诸惑为漏。谓非染污思等恨等非漏所摄。唯此诸惑稽留有情。久住生死。或令流转于生死中。从有顶天至无间狱。用强易了。是故偏说。瀑流及轭体与漏同。然于其中见亦别立。谓前欲漏即欲瀑流及欲轭。如是有漏即有瀑流及有轭。析出诸见为见瀑流及见轭者。以猛利故。谓漂合执义。立瀑流轭取。如余烦恼。但除无明。总互相资能漂合执。诸见亦尔。由猛利故。离余相助。能漂合执。故亦别立瀑流轭取。又诸烦恼皆令众生漂沦染法离诸善品。无解邪解涌泛波涛。漂激众生于善更远。故无明见于此别立。若尔何不别立见漏。令住名漏。如后当说。见不顺彼。义有别故。谓令异生及诸圣者等住生死。故名为漏。诸见无有令圣住能。漏义不全。故不别立。漂合执义圣异生殊。故后三门皆别立见。谓此诸惑能漂异生。容有令离一切善品。漂诸圣者则不可然。漂已能令诸异生类遍与非爱界趣生合。令圣者合则不可然。合已能令诸异生类无不依执。令圣不然。由此三门。异生异圣于中见胜。是故别立。有余师说。见躁利故。于令住义独不能办。故于漏门与余合立。若与余合便有住能。如于调象王系缚生象子。如是已显二十九物。名欲瀑流。谓贪嗔慢各有五种疑四缠十二十八物。名有瀑流。谓贪与慢各十疑八。若足惛掉成三十二。色无色界各有二故。三十六物名见瀑流。谓三界中各十二见十五物名无明瀑流。谓三界无明各有五。应知四轭与瀑流同。四取应知体同四轭。然欲我语各并无明。见分为二与前轭别。即前欲轭并欲无明。三十四物总名欲取。谓贪嗔慢无明各五。疑有四并十缠。即前有轭并二界无明。三十八物总名我语取。谓贪慢无明各十疑有八。若足惛掉成。四十二。于见轭中。除戒禁取。余三十物总名见取。所除六物名戒禁取。由此独为圣道怨故。双诳在家出家众故。何故无明不别立取。依能取义建立取名。然诸无明非能取故。谓不了相说名无明。彼非能取不猛利故。但可与余合立为取。已辩十种随眠并缠经说为漏瀑流轭取。此随眠等名有何义。颂曰

  微细二随增　　随逐与随缚
  住流漂合执　　是随眠等义

论曰。根本烦恼现在前时。行相难知。故名微细。是故圣者阿难陀言。我今不知。于同梵行起慢心不。不说全无。以慢随眠行相微细。彼尚不了慢心有无。况诸异生。余例应尔。有释于一刹那极微亦有随增。故名微细。二随增者。谓于所缘及所相应。皆随增故。如何烦恼有于所缘相应随增。如前已辩。或如怨害伺求瑕隙。及如见毒。应知烦恼于自所缘有随增义。如热铁丸能令水热。及如触毒。应知烦恼于自相应有随增义。二皆同乳母令婴儿随增。乳母能令婴儿增长。及令伎艺渐次积集。所缘相应令诸烦恼相续增长及得积集。言随逐者。谓无始来于相续中起得随逐。言随缚者。极难离故。如四日疟及鼠毒等。有说随缚谓得恒随。如海水行随空行影。由此所说。诸因缘故。十种烦烦立随眠名。依训词门释此名者。谓随流者相续中眠。故名随眠。即顺流者身中安住。增惛滞义。或随胜者相续中眠。故名随眠。即是趣入如实解位。为惛迷义。或有狱中长时随逐。覆有情类故名随眠。何故随眠唯贪等十。非余忿等。唯此十种习气坚牢。非忿等故。稽留有情久住生死。或令流转于生死中。从有顶天至无间狱。由彼相续于六疮门泄过无穷。故名为漏。极漂善品。故名瀑流。于界趣生和合名轭。执取彼彼自体名取。已辩十种随眠并缠。世尊说为漏流轭取。为唯尔所。为更有余。颂曰

  由结等差别　　复说有五种

论曰。即诸烦恼结缚随眠。随烦恼缠义有别故。复说五种。且结云何。颂曰

  结九物取等　　立见取二结
  由二唯不善　　及自在起故
  缠中唯嫉悭　　建立为二结
  或二数行故　　为贱贫因故
  遍显随惑故　　恼乱二部故

论曰。结有九种。一爱结。二恚结。三慢结。四无明结。五见结。六取结。七疑结。八嫉结。九悭结。以此九种于境于生有系缚能。故名为结。如契经言。苾刍当知非眼系色非色系眼。系谓此中所有欲贪。又契经说。诸愚夫类无闻异生。结缚故生。结缚故死。由结缚故。从此世间往彼世间。或有此故令诸有情合众多苦。故名为结。是众苦恼安足处故。此中爱结谓三界贪。此约所依及所缘故。若于违想及别离欲所摄行中。令心憎背名为恚结。慢谓七慢。如前已说。言无明结者。谓三界无知。此约所依。非所缘故。以诸无漏法不堕界。故无明亦用彼为所缘故。见结谓三见。取结谓二取。何缘三见别立见结。二取别立为取结耶。三见二取物取等故。谓彼三见有十八物。二取亦然。故名物等。说此物等于义何益。于结义中见有益故。此言意说。如贪嗔等一一独能成一结事。三见二取各十八物。和合各成一结事故。若异此者。应说五见各为一结。如贪嗔等。故见及取各十八物。共立一结方敌贪等。若尔身见边见见取有十八物。戒取邪见十八亦然。岂非物等。不尔本释其理决定。所以者何。以取等故。三见等所取。二取等能取。所取能取有差别故。谓于诸行执我断常。或拨为无。后起二取。执见第一。或执为净。不杂乱故。本释为善。有说由物及声等故。有说贪著有及财者。见结于彼系用增上。若有贪着涅槃乐者。取结于彼系用增上。疑结谓于四谛犹豫。此异于慧。有别法体。令心不喜说名为嫉。此异于嗔。有别法体。故有释嫉。不耐他荣令心吝着。说名为悭。谓勿令斯舍。离于我。令心坚执故名为悭。何故缠中嫉悭二种建立为结。非余缠耶。若立八缠。应作是释。二唯不善。自在起故。谓唯此二两义具足。余六无一具两义者。无惭无愧虽唯不善。非自在起。悔自在起。非唯不善。余两皆无。若立十缠。应作是释。唯嫉悭二过失尤重。故十缠中立二为结。由此二种数现行故。谓生欲界人天趣中。此嫉与悭数数现起。又二能为贱贫因故。谓生欲界人天趣中。多为贱贫重苦所轭。现见卑贱及诸乏财。乃至极亲亦不敬爱。又二遍显随烦恼故。谓随烦恼总有二种。一戚俱行。二欢俱行。嫉悭遍显如是二相。又此二能恼二部故。谓在家众于财位中。由嫉及悭极为恼乱。若出家众于教行中。由嫉及悭极为恼乱。或能恼天阿素洛众。谓因色味极相扰恼。或此能恼人天二众。如世尊告憍尸迦言。由嫉悭结人天恼乱。或此二能恼自他众。谓由嫉故恼乱他朋。由内怀悭恼乱自侣。故十缠内立二为结。佛于余处依差别门。即以结声说有五种。颂曰

  又五顺下分　　由二不超欲
  由三复还下　　摄门根故三
  或不欲发趣　　迷道及疑道
  能障趣解脱　　故唯说断三

论曰。何等为五。谓有身见戒禁取疑欲贪嗔恚。如是五种于下分法能为顺益。故名下分然下分法略有二种。一下界。谓欲界。二下有情。谓诸异生。虽得圣法而不能超下分界者。由为欲贪嗔恚二结所系缚故。虽离欲贪而不能越下有情者。由为身见戒取疑结所系缚故。诸有情住欲界狱中。欲贪及嗔犹如狱卒。由彼禁约不越狱故。身见等三如防逻者。设有方便超欲界狱。彼三执还置狱中故。顺下分结。由此唯五已见谛者。由欲贪嗔不超下界。其义可尔。唯此但是欲界系故。离欲贪者。见断一切皆令不越下分有情。何故世尊唯说三种。虽有此责而佛世尊略摄门根且说三种。言摄门者。见所断惑类总有三。唯一通二通四部故。说此三种摄彼三门。类显彼故。言摄根者。身见等三。是余三根以边执见见取邪见。如其次第随有身见戒禁取疑三种胜根而得转故。说此三种摄彼三根。故顺下分唯有此五。诸得预流六烦恼断。何缘但说断三结耶。此亦如前摄门根故。虽但有一通于二部。即举彼相以显彼体。由此故说。摄彼三门或有余师作如是释。趣异方者有三种障。一不欲发。谓见此余方功德过失故息心不往。二迷正道。谓虽发趣而依邪路不至彼方。三疑正道。谓不谙悉见有二路人皆数游。便于正道心怀犹豫。此于趣彼为是为非。如是应知。趣解脱者。亦有如是相似三障。谓由身见于蕴涅槃见执我断功德过失。故于解脱不欲发趣。由戒禁取虽求解脱。而迷正路依世间道。徒经辛苦不至涅槃。由疑不能善自观察。见诸邪道有多人修。便于正道心怀犹豫。于趣解脱为是为非。佛显预流永断如是趣解脱障。故说断三。虽见行常亦不趣解脱见世道胜。亦迷失正道。拨无圣道者。亦不信正道。而前三种是后三根。后三必随前三转故。举本摄末但说前三。佛于余经如顺下分。说顺上分亦有五种。颂曰

  顺上分亦五　　色无色二贪
  掉举慢无明　　令不超上故

论曰。如是五种体有八物。掉举等三亦界别故。唯修所断名顺上分。顺益上分故。名顺上分结。要断见所断。彼方现行故。见所断惑未永断时。亦能资彼令顺下分。故要永断见所断惑方现行者。名顺上分。此中既说色无色贪及顺上言。知掉举等亦色无色。非欲界系。品类足论。即作是言。结法云何。谓九结。非结法云何。谓除九结所余法。由此证成。掉举一种少分是结。谓二界系。少分非结。谓欲界系。于少是结。谓圣者。于少非结。谓异生。有位是结。谓已离欲贪。有位非结。谓未离欲贪。由如是等差别不定。品类足论。不说为结。掉举扰恼三摩地故。于顺上分建立为结。即由此理顺上分中。不说惛沈顺等持故。已辩。结缚云何。颂曰

  缚三由三受

论曰。以能系缚。故立缚名。即是能遮趣离染义。结缚二相虽无差别。而依本母说缚有三。一者贪缚。二者嗔缚。三者痴缚。所余诸结品类同故。摄在三中。谓五见疑同痴品类。慢悭二结贪品类同。嫉结同嗔。故皆三摄。又为显示已见谛者余所应作。故说三缚。通缚六识身。置生死狱故。又佛偏为觉慧劣者。显粗相烦恼。故但说三缚。有余师说。由随三受势力所引说缚有三。谓贪多分于自乐受所缘相应二种随增。少分亦于不苦不乐。于自他苦及他乐舍。唯有一种所缘随增。嗔亦多分于自苦受所缘相应二种随增。少分亦于不苦不乐。于自他乐及他苦舍。唯有一种所缘随增。痴亦多分于自舍受所缘相应二种随增。少分亦于乐受苦受。于他一切受唯所缘随增。是故世尊依多分理。说随三受建立三缚。何类贪等遮趣离染。说名为缚。谓唯现行。若异此者皆成三故。则应毕竟遮趣离染。已分别缚。随眠云何。颂曰

  随眠前已说

论曰。随眠有六或七或十或九十八。如前已说。随眠既已说。随烦恼云何。颂曰

  随烦恼此余　　染心所行蕴

论曰。能为扰乱。故名烦恼。随诸烦恼转。得随烦恼名。有古师言。若法不具满烦恼相。名随烦恼。如月不满得随月名然。诸随眠名为烦恼。即此亦得随烦恼名。以是圆满烦恼品故。由此故说。即诸烦恼有结缚。随眠随烦恼缠义。所余染污心所行蕴。随烦恼起随恼心故。得随烦恼名。不得名烦恼。以阙圆满烦恼相故随烦恼名为目几法。经种种说。故有众多。谓愤发不忍及起恶言类。如世尊告婆罗门言。有二十一诸随烦恼。能恼乱心。乃至广说。后当略辩。缠烦恼垢摄者且应先辩。缠相云何。颂曰

  缠八无惭愧　　嫉悭并悔眠
  及掉举惛沈　　或十加忿覆
  无惭悭掉举　　皆从贪所生
  无愧眠惛沈　　从无明所起
  嫉忿从嗔起　　悔从疑覆诤

论曰。根本烦恼亦名为缠。经说欲贪缠为缘故。若异此者。贪等云何可得名为圆满烦恼。然诸论者。离诸随眠。就胜说缠。或八或十。谓品类足说有八缠。毗婆沙宗说缠有十。即于前八更加忿覆。如是十种。系缚含识置生死狱。故名为缠。或十为因起诸恶行令拘恶趣。故名为缠。无惭无愧嫉悭并悔掉举惛沈。如前已辩。令心昧略惛沈相应。不能持身是为眠相。眠虽亦有惛不相应。此唯辩缠。故作是说。于此顿说眠三相者。此三与眠义相顺故。因自反损怨益而生。嗔恚为先心愤名忿。有余师说。因处非处违逆而生。力能令心无顾而转。乃至子上令心愤发说名为忿。隐藏自罪。说名为覆。罪谓可诃。即是毁犯尸罗轨则及诸净命。隐藏即是匿罪欲因有余释言。扪拭名覆。谓内怀恶扪拭外边。是欲令他不觉察义。前说若法从烦恼起。方可建立随烦恼名。此中何法何烦恼起。无惭悭掉举是贪等流。要贪为近因方得生故。无愧眠惛沈是无明等流。此与无明相极相邻近故。嫉忿是嗔等流。由此相同嗔故。悔是疑等流。因犹豫生故。覆有说是贪等流。有说是无明等流。有说是俱等流。诸有知者因爱生故。诸无知者因痴生故即由此相故有说言。心著称誉利养恭敬。不了恶行所招当果。是于自罪隐匿欲因。为爱无明二等流果。随恼心法说名为覆。如是十种从烦恼生。是烦恼等流。故名随烦恼。余烦恼垢其相云何。颂曰

  烦恼垢六恼　　害恨谄诳憍
  诳憍从贪生　　害恨从嗔起
  恼从见取起　　谄从诸见生

论曰。于可毁事决定坚执难令舍因。说名为恼。由有此故。世间说为不可引导。执恶所执于他有情。非全不顾拟重摄受。为损恼因悲障恼心。说名为害。于非爱相随念分别。生续忿后起心结怨名恨。于己情事方便隐匿。矫设谋略诱取他情。实智相违心曲名谄。于名利等贪为先故。欲令他惑邪示现因。正定相违心险名诳。心险心曲相差别者。如道如杖于他于自。因贪因见故有差别。憍相如前已具分别。有余师说从贪所生。恃己少年无病寿等诸兴盛事心傲名憍。有余师言。于自相续兴盛诸行。耽染为先不顾于他。谓己为胜心自举恃。说名为憍。由不顾他与慢有异。如是六种从烦恼生。秽污相粗名烦恼垢。于此六种烦恼垢中。诳憍是贪等流。害恨是嗔等流。恼是见取等流谄是诸见等流。如言阿曲谓诸恶见。故谄定是诸见等流。此六亦从烦恼生故。如缠亦得随烦恼名。已说诸缠及烦恼垢。今次应辩彼断对治。诸缠垢中谁何所断。颂曰

  缠无惭愧眠　　惛掉见修断
  余及烦恼垢　　自在故唯修

论曰。且十缠中无惭无愧。通与一切不善心俱。眠欲界中通与一切意识俱起。惛沉掉举通与一切染污心俱。故五皆通见修所断。余嫉悭悔忿覆并垢。自在起故。唯修所断。唯与修断他力无明。共相应故。名自在起。与自在起缠垢相应所有无明。唯修断故。此诸缠垢谁通何性。颂曰

  欲三二余恶　　上界皆无记

论曰。欲界所系眠惛掉三。皆通不善无记二性。所余一切皆唯不善。即欲界系七缠六垢。上二界中随应所有。一切唯是无记性摄。即谄诳憍惛沉掉举。此诸缠垢谁何界系。颂曰

  谄诳欲初定　　三三界余欲

论曰。谄诳唯在欲界初定。宁知梵世有谄诳耶。以大梵王匿己情事。现相诳惑。马胜苾刍。传闻此唯异生所起。非诸圣者亦可现前。惛掉憍三通三界系。所余一切皆唯在欲。谓十六中五如前辩。所余十一唯欲界系。所说随眠及随烦恼。于中有几唯依意地。有几通依六识地起。颂曰

  见所断慢眠　　自在随烦恼
  皆唯意地起　　余通依六识

论曰。一切见断修断慢眠。随烦恼中自在起者。如是三种皆依意识。依五识身无容起故。所余一切通依六识。谓修所断贪嗔无明。及彼相应诸随烦恼。即无惭愧惛掉及余大烦恼地法所摄随烦恼。即是放逸懈怠不信。依六识身皆容起故。理应通说诸随烦恼。今此且依粗显者说。复应思择。如先所辩。乐等五受根对。今此中所辩一切烦恼随烦恼何烦恼等何根相应。于此先应辩诸烦恼。颂曰

  欲界诸烦恼　　贪喜乐相应
  嗔忧苦痴遍　　邪见忧及喜
  疑忧余五喜　　一切舍相应
  上地皆随应　　遍自识诸受

论曰。欲界所系诸烦恼中。贪喜乐相应。以欢行转遍六识故。嗔忧苦相应。以戚行转遍六识故。无明遍与前四相应。欢戚行转遍六识故。与余烦恼遍相应故。邪见通与忧喜相应。欢戚行转唯意地故。如次先造罪福业故。疑忧相应。以戚行转唯意地故。怀犹豫者。求决定知心愁戚故。余四见慢与喜相应。以欢行转唯意地故。通说皆与舍受相应。以说舍受痴随增故。痴与诸惑遍相应故。烦恼相续至究竟时。取境奢缓起处中欲。渐渐衰微相续便断。尔时烦恼与舍相顺。是故皆与舍受相应。岂不舍根非欢非戚。如何欢戚烦恼相应。如处中人俱无违故。欲界既尔。上地云何。皆随所应遍与自地自识俱起。诸受相应谓若地中具有四识。彼一一识所起烦恼。各遍自识。诸受相应。若诸地中。唯有意识即彼意识所起烦恼。遍与意识。诸受相应上诸地中。识有多少谓初静虑。具四余一受有多少。谓初二三四等如次。具喜乐舍喜舍乐舍。唯舍应知。随诸地中所有烦恼。如应与彼识受相应。何缘二疑俱不决定。而上得与喜乐相应。非欲界疑喜受俱起。以诸烦恼在离欲地。虽不决定亦不忧戚。虽怀疑网无痴情怡。如在人间求得所爱。虽多劳倦而生乐想。有说色界虽复怀疑。而于疑中生善品想。故彼得与喜乐相应

说一切有部显宗论卷第二十七阿毗达磨藏显宗论卷第二十八

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩随眠品第六之四

已辩烦恼诸受相应。今次复应辩随烦恼。颂曰

  诸随烦恼中　　嫉悔忿及恼
  害恨忧俱起　　悭喜受相应
  谄诳及眠覆　　通忧喜相应
  憍喜乐皆舍　　余四遍相应

论曰。随烦恼中嫉等六种。一切皆与忧根相应。以戚行转唯意地故。有余师说。恼喜相应。见取等流。应欢行故。悭喜相应。以欢行转唯意地故。欢行转者。悭相与贪极相似故。谄诳眠覆忧喜相应。欢戚行转唯意地故。欢戚行者。谓或有时以欢喜心而行谄等。或时有以忧戚心行。有余师言。既说诳是贪等流故。但应欢行不应说与忧根相应。是欢等流不应戚故。又正诳时不应戚。故或应说诳是痴等流。憍喜乐相应。欢行唯意故。在第三静虑与乐相应。若在下诸地与喜相应。此上所说诸随烦恼。一切皆与舍受相应。相续断时皆住舍故。有通行在唯舍地故。舍于一切相应无遮。譬如无明遍相应故。余无惭愧惛沉掉举。四皆遍与五受相应。前二是大不善地法摄故。后二是大烦恼地法摄故。说二及声显难及释。谓于恼诳设难如前。理应释言。果因相别。如无惭掉虽贪等流。而与忧苦有相应义。故知所说与受相应。不唯同因但据相别。许有忧戚而行诳者。情有所忧而行诳故。所说烦恼随烦恼中。有依异门佛说为盖。今次应辩盖相云何。颂曰

  盖五唯在欲　　食治用同故
  虽二立一盖　　障蕴故唯五

论曰。如契经言。若说五盖为不善聚。是为正说。所以者何。如是五种纯是圆满不善聚故。其五者何。一欲贪盖。二嗔恚盖。三惛眠盖。四掉悔盖。五疑盖。契经既说盖唯不善。故知唯在欲。非色无色界。由此为证知惛掉疑。体虽皆通欲色无色。而但欲界有得盖名。为显惛沉掉举二种唯欲界者。有立为盖。故与眠悔和合而立。眠悔唯是欲界系故。为显眠悔唯染污者。有得盖名。故与惛沉掉举二种和合而立。惛掉唯是染污性故。疑准前四在欲可知。何缘欲贪嗔恚疑盖。各于一体别立盖名。而彼惛眠掉悔二盖。各于二体合立盖名。欲贪嗔疑食治各别。是故一一别立盖名。由惛与眠及掉与悔。所食能治事用皆同。故体虽殊俱合立一。欲贪盖食谓可爱相。此盖对治谓不净想。嗔恚盖食谓可憎相。此盖对治谓慈善根。疑盖食谓三世。如契经说。于过去世生如是疑。乃至广说。此盖对治。谓若有能如实观察缘性缘起惛眠盖食谓五种法。一[夢-夕+登]瞢。二不悦。三频申。四食不平性。五心昧劣性。此盖对治谓光明想。此盖事用。谓俱能令心性沈昧。掉悔盖食谓四种法。一亲里寻。二国土寻。三不死寻。四随念。昔种种所更笑戏欢娱承奉等事。此盖对治谓奢摩他。此盖事用。谓俱能令心不寂静。由此说食治用同故。惛眠掉悔二合为一。或贪嗔疑是满烦恼。一一能荷一覆盖用。惛眠掉悔非满烦恼。二合方荷一覆盖用。此五名盖。其义云何。谓决定能覆障圣道圣道加行。故立盖名。若尔则应诸烦恼等皆得名盖。一切皆能覆障圣道及加行故。如世尊告诸苾刍言。若为一法所覆障者。则不能了眼是非常。一法谓贪。乃至广说。一一别说如杂事中。何故世尊说盖唯五。理实应尔。然佛世尊于立盖门唯说五者。唯此于五蕴。能为胜障故。谓贪恚盖能障戒蕴。如次令远离欲恶故。惛沉睡眠能障慧蕴。此二俱令远毗钵舍那故。掉举恶作能障定蕴。此俱令远奢摩他故。如是四盖渐次令越出离白法。由此于后令于业果四谛生疑。疑故能令乃至解脱解脱智见皆不得起。故唯此五建立为盖。若尔掉悔盖。应惛眠前说顺戒定慧蕴。次第而说故。不尔此中坏次第者。世尊意欲显别义故。谓契经中佛依正理说惛眠盖。毗钵舍那能治非止。说掉悔盖唯奢摩他能治非观。此依伏断说观止门。别治惛眠掉悔二盖。若依永断此观止门。对治一切用无差别。为显此理故坏次第。何故无明不立为盖。不说成故。如契经说。无明所覆覆即是盖有余师说等荷担者立诸盖中。无明于中所荷偏重。是故不说慢复何缘不立为盖。以有由慢能修胜法。为盖义劣。不立盖中。有余师言。夫为盖者。令心趣下。慢则不然。以能令心趣上法故。诸见何故不立盖中。见诸有情阙非我见者。虽执有我而能离染故。有说诸见性捷利故。不顺盖义。盖性迟钝。随烦恼中余不立盖。准前所说应如理思。上二界惑不立盖者。离三界染初非障故。又彼无记盖唯不善。今应思择诸随眠等。由何而断。由慧观见彼所缘故随眠等断。若尔欲界他界遍行及三界中见灭道断有漏缘惑应无断义。缘苦集谛法智忍生。唯缘欲界苦集谛故。缘灭道谛诸智忍生。唯缘无漏为境界故。无如是失。我许诸惑永断方便有多种故。为有几种。总有四种。何等为四。颂曰

  遍知所缘故　　断彼能缘故
  断彼所缘故　　对治起故断

论曰。断见所断惑。由前三方便。一由遍知所缘故断。谓欲界系见苦集断自界缘惑。色无色界见苦集断所有诸惑。以上二界他界地缘。亦由遍知所缘断故。缘苦集谛类智忍生。俱能顿观三界境故。及通三界见灭道断无漏缘惑。如是诸惑皆由遍知所缘断。故二由断彼能缘故断。谓欲界系他界缘惑。以欲界系见苦集断。自界缘惑能缘于彼。此惑于彼能作依持。依持断时彼随断故。如羸病者却倚而立。去所倚时彼随倒故。如何于彼能作依持。由此于彼能为因故。岂不此即说由害因故断。实尔此彼但是异名。然为止滥故作是说。谓欲界惑自他界缘。皆有此彼互为因义。然无此彼展转相缘。故于此中说能缘断。欲令易了唯他界缘。由断此因彼便随断。三由断彼所缘故断。谓见灭道断诸有漏缘惑。以无漏缘惑能为彼所缘。所缘断时彼随断故。如羸病者杖策而行。去彼杖时彼随倒故。何缘于此所断惑中有断能缘。故说所缘断。如缘欲苦集起现观时有断所缘。故说能缘断。如缘诸灭道起现观时。虽实尔时此彼俱断。而由所断有胜有劣。故胜断时言劣随断。谓若于彼惑所缘中。无漏慧生能为对治。彼惑名胜。所余名劣。何缘彼惑偏得胜名。于彼所缘无漏慧起。专为敌彼发功用故。若许惑断方便有多。有由能缘断故随断。有由所缘断故随断。何故前说由慧观见彼所缘故随眠等断。但应于此先立宗言。永断诸惑由多方便。勿先立宗与后解释。言义各异前后相违。如先立宗后释无异。先据必观惑所缘故。后据于中有差别故。惑先举胜后兼辩劣。正敌对者说名为胜。已说三方便。断见所断惑。断修所断惑。由第四方便。谓彼但由治起故断。以若此品对治道生。即此品中诸惑顿断。如下下品治道起时。上上品惑即皆顿断。至上上品治道起时。下下品惑即皆顿断。如是理趣后当广辩。岂不一切见所断惑断时亦由对治道起。以若此部对治道生。则此部中诸惑断故。理实应尔。然于此中为显三界修所断惑无不皆由九品道断治道决定。故说此言。见所断中唯有顶惑。对治决定如前已辩。惑见所断诸惑断时。方便定三。故就别说。修所断惑能断方便不决定故。就总而说。岂不所明第四方便与前宗义有不相关。谓修位中以灭道智。能断三界修所断惑。慧非见此惑所缘故。此与宗义实不相关。前宗唯辩见所断故。设彼总摄亦不相违。见彼惑所缘此惑治生故。所言对治总有几种。颂曰

  对治有四种　　谓断持远厌

论曰。诸对治门总有四种。一断对治。谓道亲能断诸惑得。即无间道。二持对治。谓道初与断得俱生。即解脱道。由如是道持断得故。令诸惑得不相续生。三远分对治。谓道能令前所断惑得转更成远。即胜进道。于解脱道后所起道名为胜进。乃至后得俱起生等亦得道名。令与惑得相违。诸得相续增故。四厌患对治。谓道随于何界何地中见诸过失深生厌患。即是于彼以种种门观过失义。此唯诸厌作意聚摄。由此势力。设于后时属妙境界亦不贪着。应知多分是加行道非决定故。不说在初说多分言。应知为显无间解脱。胜进道中缘苦集谛者。亦厌患对治。已说惑对治。当辩断惑理。诸惑永断为定从何。为从所缘。为从相应。为从自性。何故生疑。于此三种皆见过故。且不应说断从所缘。谓若此法是彼所缘。未曾有时非所缘故。亦不可说断从相应。谓相应法互为因故。此法无时非因性故。又由此惑令心成染。此心无时成不染故。亦不可说断从自性。谓法无容舍自性故。以断惑时不可令彼所断诸法失所断性。是故应思惑从何断。颂曰

  应知从所缘　　可令诸惑断

论曰。诸惑永断定从所缘。以于所缘遍知力故。令惑永断如前已说。然惑所缘总有二种。谓有系事。及无系事。缘有系事为境诸惑。及从此惑力所引生。不缘此事为境诸惑。如是二惑于一有情现相续中引起诸得。设无染污心现在前此得恒行无有间断。为去来世诸惑果因。如是应知。缘无系事为境诸惑。及因此惑势力所引随从现行。不缘此事为境诸惑。所引起得类亦同前。言为去来惑果因者。谓此诸得现在世时。是过去惑等流性故。说之为果。是未来惑生缘性故。说之为因。然此诸得与断对治等流诸得现行相违。能持去来所得诸惑。故令一切缘此事惑及缘余惑相续而转。缘此事境诸断对治等流起时惑得便绝。所得诸惑于自所缘虽体犹有。而由因果得永绝故。可说名断。以于少境若未遍知缘此境惑。及因此惑力所引起缘余境惑。所引去来惑果因得现相续中无间而转。若于少境得遍知时。惑所引得便不复转。故知惑断定从所缘。如前所言远分对治。一切远性总有几种。颂曰

  远性有四种　　谓相治处时
  如大种尸罗　　异方二世等

论曰。一切远性总有四种。一相远性。如四大种。虽复俱在一聚中生。以相异故亦名为远。二治远性。如持犯戒。虽复俱在一身中行。以相治故亦名为远。三处远性。如海两岸。虽复俱在一大海边。方处隔故亦名为远。四时远性。如去来世。虽复俱依一法上立。时分隔故亦名为远。望何说远。望现在世无间已灭。及正生时与现相邻。如何名远。非眼等境故。或无作用故。无为非时不可为难。虚空体遍二灭遍得。故契经中亦说为近。等声为明举法未尽。已辩烦恼对治差别。修能对治胜进位中。所断诸惑为再断不。所得离系有重得耶。颂曰

  诸惑无再断　　离系有重得
  谓治生得果　　练根六时中

论曰。所断诸惑。由得自分无间道故。便顿永断。离退后时无再断义。断已复断则为唐捐。所得离系虽无随道渐胜进理。而道进时容有重起。彼胜得理以离系得道所摄故。舍得道时彼亦舍得。故诸离系有重得理。此依容有时总有六。谓治道起得果练根。说治生言通目二义。若据住此能证离系。目无间道。若据住此正证离系。目解脱道。言得果者。谓得预流一来不还阿罗汉果。言练根者。谓增进根由此六时得未曾道有舍曾道得离系故。说得果言既无差别。如摄四果应摄练根以转根时必得果故。何劳长说此练根言。为显练根异断惑得果故。得果外说练根无失。然得离系随其所应。有具六时。乃至唯二谓欲界系。见四谛断。及色无色。见三谛断所得离系得具六时。色无色界见道谛断。所得离系得唯五时。由治生时即得果故。说得果已。不说治生。欲界修断五品离系亦五时得。除预流果。第六离系得唯四时。得果治生时无别故。第七八品亦唯四时。得四果中除前二故。第九离系得唯三时。亦治生时即得果故。色无色界修所断中唯除有顶。第九离系所余离系亦唯三时。得果四中除前三故。有顶第九得唯二时。得果治生同一时故。此约钝说。若就利根。前诸位中除练根得。岂不八地容世俗道。断应分二种对治生时得。不尔此说渐次得故。或此唯约无漏得故。若依越次通有漏得则世俗道。八地染中随离少多。入圣道者彼得离系。随其所应有具六时。乃至唯一。以利根故。除练根时。谓欲界中先断五品入见谛者。彼见所断五品离系具六时得。谓有二种。自治生时。及得果时。复四成六。彼修所断五品离系唯五时得。除预流果。先断六品入见谛者。彼见所断六品离系亦五时得。除一如前。彼修所断六品离系。唯世俗道治生时得。必不起彼无漏对治。是一来果向道摄故。非住果时起彼向道。以住胜果不起劣故。先断八品入见谛者。彼见所断八品离系亦五时得。除一如前。彼修所断前六离系唯一时得。如前应知。七八离系唯四时得。谓二治生及二得果。先断九品依未至地入见谛者。彼见所断九品离系亦四时得。如前应知。依根本地入见谛者。彼见所断九品离系亦一时得。如前应知。根本非欲断对治故。若依未至。若依根本。彼修所断九品离系亦一时得。如前应知。必不起彼无漏对治。是不还果向道摄故。先断上七地入见谛者。彼见三谛断七地离系亦四时得。如前应知。见道谛断七地离系唯三时得。谓一治生。及二得果。无漏治生即得果故。彼修所断七地离系唯三时得。谓二治生。及一得果。具离八地入圣道者。见修位中断有顶惑见三谛断离系三时。谓一治生。及二得果。见道谛断离系二时。由治生时即得果故。修断八品离系二时。谓一治生。及一得果。第九离系唯一时得。以治生时即得果故。诸分离染见。修位中进断。所余准此应说。以何因证得后果时重得先时所断离系。由至教故。谓契经中依正证得阿罗汉果。说如是言。应如是知。应如是见。彼从欲漏心得解脱。乃至广说。由此位中亦得欲界厌患对治等无学法智故。知彼离系亦应重得。前言断欲六品九品入见谛者。彼先修断六九离系无无漏得。为永不得。暂不得耶。应决定言。彼永不得。岂不证得阿罗汉时。必得先时见修所断一切离系诸无漏得。若彼先时所断离系有无漏得。今时舍者于彼今应得无漏得。若先无者今时亦无。得离系时唯自治起。及舍劣道得胜时故。诸有先依根本静虑入见谛者。得无学时。宁从欲漏心得解脱。就依未至入见谛者。及次第者。说故无失。即诸离系彼彼位中得遍知名。随胜立故。遍知有二。一智遍知。二断遍知。智遍知者。体即是慧。唯是无漏。断遍知者。体即离系。是智果故。得遍知名。如业解名诠业解果。若尔忍果应非遍知。是智眷属。故名遍知无失。或于后时转成智果。为一一断道所得离系。各立一遍知。为一切断道所得离系。总立一遍知。二俱不然。以有极广极略过故。若尔云何。颂曰

  断遍知有九　　欲初二断一
  二各一合三　　上界三亦尔
  余五顺下分　　色一切断三

论曰。诸断总立九种。遍知唯立九缘。如后当辩。何等名曰九种遍知。且三界系见谛所断烦恼等断。立六遍知。谓欲界系初二部断。立一遍知。次二各一。上界亦然。故合成六。余三界系修道所断烦恼等断。立三遍知。谓欲界系修道所断烦恼等断。立一遍知。应知即是五顺下分。结尽遍知并前立故。色界所系修道所断烦恼等断。立一遍知。应知此即是色爱尽遍知。无色界系修道所断烦恼等断。立一遍知。即一切结永尽遍知。此亦并前合立一故。如是所立九种遍知。应辩于中几何道果。颂曰

  于中忍果六　　余三是智果
  未至果一切　　根本五或八
  无色边果一　　三根本亦尔
  俗果二圣九　　法智三类二
  法智品果六　　类智品果五

论曰。于此九中。且应先辩与忍智道为果差别。忍果有六。谓三界系见断法断六种遍知。智果有三。谓顺下分色爱一切结尽遍知。由此三遍知是修道果故。由此已辩见修道果。与静虑地为果别者。未至静虑果具有九。谓此为依断一切故。根本静虑果五或八。所言五者。毗婆沙师说。根本静虑。非欲断治故。所言八者。尊者妙音说。根本静虑。亦欲断治故。除色无色见道断遍知。道类智时总集遍知故。中间静虑如根本说。岂不依止根本静虑入见谛时。亦修未来依未至地。欲断治道得断治故。亦应证彼欲见断法断无漏离系得。宁说根本唯得五果。此责不然。尔时所修依未至地断对治者。唯色无色断对治故。根本地道既不能为欲断对治。彼现起位如何能修欲断治道。由彼所修未至断治。唯治上界故。果唯五。与无色地为果别者。无色边地果唯有一。谓依空处近分地道。得色爱尽遍知果故。圣依俗道离诸染位。所得断果亦名遍知。以得无漏离系得故。前三根本果亦唯一。谓依无色前三根本。得一切尽遍知果故。由此已辩静虑无色总得遍知。果多少别。与俗圣道为果别者。俗道果二。谓俗道力唯能获得顺下分尽。及色爱尽遍知果故。圣道果九。谓圣道力。乃至能越二有顶故。应知九中二是共果。七不共果。唯圣果故。与法类智。为果别者法智果三。谓法智力能断三界修所断故。类智果二。谓类智力断色无色修所断故。与法类品为果别者。法智品果六。谓即是前法智法忍所得六果。类智品果五。谓即是前类智类忍所得五果。品言通摄智及忍故。法品六中四不共果。三属法忍。一属法智。二是共果。谓最后二双属法类二种智故。类品五中三不共果。皆属类忍。二是共果。谓最后二义如前释。何缘一一道所得断。不各各立为一遍知。以永断时说遍知故。如契经说。吾今为汝宣说遍知。乃至广说。此中何等名为遍知。谓贪永断嗔永断痴永断。乃至广说。说永断言。显所得断都无随缚方名遍知。云何名为有随缚断。云何名为无随缚断。断具三种或四种。缘名无随缚。不具名有。谓或有断。虽得离系得而阙余得故。容还永舍。或复有断。余得虽生未缺坚牢生死之首。以八地染虽数曾离未能缺彼。故还坠恶趣狱。或复有断。虽亦缺彼而余烦恼系缚未除。于永断义未得圆满。或复有断。余缚亦除而犹未能越所属界。以同类惑未断无余。于永断义亦未圆满。如是诸断各有随缚。是故于彼不立遍知。唯九位中三四缘具断无随缚。可立遍知。何谓具缘。颂曰

  得无漏断得　　及缺第一有
  灭双因越界　　故立九遍知

论曰。见断法断具三缘故。便立遍知。修断法断具四缘故。方立遍知。见断法断具三缘者。谓得无漏离系得故。缺有顶故。灭双因故。此中异生虽复亦有离八地染名灭双因。而断非遍知。阙余二缘故。见圣谛位。第二三刹那诸断。虽有无漏离系得。余二缘阙未立遍知。第四五刹那虽亦缺。有顶双因未灭不立遍知。见集断因有未灭故。集法智位欲二部断。具三缘故。得遍知名。后五刹那法类智位。断具三缘故。皆得遍知名。修断法断具四缘者。三缘如上。越界第四。谓诸界中圣未越地。彼所得断唯具二缘。若已越地未越界者。彼所得断犹阙一缘。若越界时四缘方具。随应彼断得遍知名。有说五缘加离俱系义异前。故说双因灭俱系离成。故此不说离成就几遍知。颂曰

  住见谛位无　　或成一至五
  修成六一二　　无学唯成一

论曰。异生位中虽能离染。乃至八地不成遍知。于圣位中依未至定入见谛者。从初乃至集法忍位亦无遍知。至集法智集类忍位唯成就一。至集类智灭法忍位便成就二。至灭法智灭类忍位便成就三。至灭类智道法忍位便成就四。至道法智道类忍位便成就五。依根本定入见谛者。至集类忍亦无遍知。后位随应如理思择。住修道位未离欲者。道类智为初。乃至未得全离欲界染。及离欲退皆成就六。至全离欲以离欲第九解脱道为初。乃至离色界最后无间道先离欲者。从道类智乃至未起色尽道前。唯成一遍知。谓顺下分尽。从色爱尽及无学位。起色缠退。亦一如前。有色爱者。从色爱永尽。先离色者。从起色尽道。至未全离无色爱前。成下分尽。色爱尽二从无学退。起无色缠成二遍知。名如前说。住无学位唯成就一。谓一切结永尽遍知。若依根本入正决定道类智时。彼所有断亦得顺下分断。遍知名者宁许根本果唯有五。遍知唯色无色界见断法。断得彼遍知名故无有失。何缘唯此亦得彼名。以渐次得不还果者。于此断上立彼名故。又先俗道所断下分。今圣道力令永不生故。彼所得断假说为此果。今实不得欲断遍知。何故不还阿罗汉果。总集诸断立一遍知。颂曰

  越界得果故　　二处集遍知

论曰。具二缘故。于所得断总集建立为一遍知。一者越界。二者得果。所言集者。是合一义。若于无色分离染故得预流果。全离染故得阿罗汉。若于欲界分离染故得一来果。全离染故得不还果。若于色界分离全离俱不得果。唯于二处具足二缘。谓得果时亦即越界。故阿罗汉及不还果。集所得断立一遍知。尔时总起一味得故。余二果时得虽一味而未越界。色爱尽时虽是越界无一味得。故于彼位不集遍知。要具二缘方总集故。谁舍谁得几种遍知。颂曰

  舍一二五六　　得亦然除五

论曰。言舍一者。谓从无学及色爱尽全离欲退。言舍二者。谓诸不还从色爱尽起欲缠退。及彼获得阿罗汉时。诸先离欲依根本定入见谛者道类忍时。言舍五者。经主释言。谓先离欲道类智位。此但应说道类忍时。道类智时彼已舍故。夫言得舍据将说故又应简言。依未至定入见谛者。若依根本入见谛者。于欲界断不得无漏。离系得故不得欲界。见断法断三种遍知。非先不得可言今舍。言舍六者。谓未离欲所有圣者得不还时。得亦然者。谓有得一得二得六。言得一者。谓胜进位集法忍等九种位中。及从无学起色缠退。言得二者。谓从无学起无色界诸缠退时。言得六者。谓不还退。无得五者。理无容故。谓先离欲依未至定入见谛者。道类忍时。舍五遍知得不还果。此果若退可得五遍知此。退既无。故无容得。五岂不胜进得圣果时于诸无为更起胜得。乍可名得。宁舍遍知。约断实然。恒成就故。但今且据九遍知中。若得异名本名便失。说名为舍。亦无有过建立遍知。与断别故

说一切有部显宗论卷第二十八阿毗达磨藏显宗论卷第二十九

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩贤圣品第七之一

已辩烦恼。随诸品类虽有无量。而总立为三界五部。诸烦恼断随所系事虽亦无量。而就胜位立九遍知。然断必由道力故得。此所由道其相云何。颂曰

  已说烦恼断　　由见修道故
  见道见圣谛　　修道修九品

论曰。世尊唯说有二烦恼。见修所断有差别故。然诸论中开二为五。即五所断。如前已说。今就略摄唯二如经断彼但由见修道故。见道谓见四圣谛理。修道谓修九品差别。见唯无漏。修通二种。准前已显。故颂不说。所见圣谛其相云何。颂曰

  谛四名已说　　谓苦集灭道
  彼自体亦然　　次第随现观

论曰。佛于经中说谛有四。一苦二集三灭四道。于此论中亦先已说。谓有为法除诸圣道。为果性边皆名苦谛。为因性边皆名集谛。物虽无异数分无失。依彼建立现观位中。诸忍智等行相别故。如四正断出离寻等。择灭无为名为灭谛。学无学法皆名道谛。因前果后理数必然。由此定应列谛名处。苦居集后道在灭前。何故此中果前因后。随现观位次第而说。谓随行者。现观位中。前观前说后观后说。然或有法说次随生。如念住等。或复有法说次随便。如正胜等。何缘现观次第必然。加行位中如是观故。何缘加行必如是观。谓若有法最为逼恼。修加行位理应先观。次求彼因。次求彼脱。后应求彼解脱方便。譬如良医先观病者所患病状。次寻其因。次思病愈。后求良药。故契经言。夫医王者。谓具四德能拔毒箭。一善知病状。二善知病因。三善知病愈。四善知良药。如来亦尔。为大医王。如实了知苦集灭道。故加行位依此次观。现观位中观次亦尔。由加行力所引发故。如纵心诵先所诵文。故列圣谛名随现观。次第现等觉。故立现观名。正觉所缘。故唯无漏。此觉真净。故得正名。此圣谛名为目何义。圣者谛故得圣谛名。谓唯圣者于此四谛能以圣行圣智实观。异生不然。故名圣谛。唯受一分是苦自体。所余并非。如何可言诸有漏行皆是苦谛。颂曰

  苦由三苦合　　如所应一切
  可意非可意　　余有漏行法

论曰。有三苦性。一苦苦性。二行苦性。三坏苦性。诸有漏行如其所应。与此三种苦性合故。皆是苦谛。亦无有失。所以者何。诸有漏行有三可意非可意余。可意者何。谓诸乐受及彼资具。余二类然。此中可意有漏行法。由坏苦合故名为苦。未离染者。于彼坏时。必定应生忧愁等故。以薄伽梵契经中言。诸乐受生时乐住时乐坏时苦。顺乐受诸行如乐受。应知诸非可意有漏行法。由苦苦合故。名为苦苦受。自体及顺苦法现前。必能恼身心故。以薄伽梵契经中言。诸苦受生时苦住时苦坏时乐顺苦受诸行如苦受应知除此所余有漏行法。由行苦合故名为苦。因缘所造皆是非常。有漏非常无非是苦。故有漏法皆是苦性。岂不一切有漏行法据此皆容是行苦性。不应但说非苦乐受。及彼资粮为行苦性。虽有此理。然于此中依不共故。作如是说。此三苦性其体是何。应定判言三受为体。由三受故顺三受法。如应亦得三苦性名。道无漏故非苦性摄。如上所辩。四圣谛中几是世俗。几是胜义。如是二谛其相云何。颂曰

  彼觉破便无　　慧析余亦尔
  如瓶水世俗　　异此名胜义

论曰。诸和合物随其所应。总有二种性类差别。一可以物破为细分。二可以慧析除余法。谓且于色诸和合聚破为细分。彼觉便无名世俗谛。犹如瓶等。非破瓶等为瓦等时。复可于中生瓶等觉。有和合聚。虽破为多彼觉非无。犹如水等。若以胜慧析除余法。彼觉方无。亦世俗谛。非水等被慧析除色等时。复可于中生水等觉。故于彼物未破析时。以世想名施设为彼。施设有故名为世俗。依世俗理说有瓶等。是实非虚名世俗谛。如世俗理说为有故。若物异此名胜义谛。谓彼物觉彼破不无。及慧析除彼觉仍有。名胜义谛。犹如色等。如色等物碎为细分。渐渐破析乃至极微。或以胜慧析除味等。彼色等觉如本恒存。受等亦然。但非色法无细分故。不可碎彼以为细分。乃至极微。然可以慧析至刹那。或可析除余想等法。彼受等觉如本恒存。此真实有故名胜义。以一切时体恒有故。依胜义理说有色等。是实非虚名胜义谛。如胜义理说为有故。由此四圣谛皆胜义谛摄。细分别时觉不舍故。诸世俗谛依胜义理。世俗自体为有为无。若言是有谛应唯一。若言是无谛应无二。此应决定判言是有。以彼尊者世友说言。无倒显义名是世俗谛。此名所显义。是胜义谛名是实物。如先已辩。岂不已言。谛应唯一理实应尔。非胜义空可名谛故。何故立二。即胜义中依少别理立为世俗。非由体异。所以尔者。名是言依。随世俗情流布性故。依如是义应作是言。诸是世俗必是胜义。有是胜义而非世俗。谓但除名余实有义。即依胜义。是有义中。约少分理名世俗谛。约少分理名胜义谛。谓无简别总相所取。一合相理名世俗谛。若有简别别相所取。或类或物名胜义谛。如于一体有漏事中。所取果义名为苦谛。所取因义名为集谛。或如一体心心所法。有具六因及四缘性。由如是理。于大仙尊所说谛中。无有违害。如说一谛更无第二。唯有一道更无余道。此四圣谛总体云何。一切有为及诸择灭。以是烦恼圣道境故。染净因果性差别故。空非择灭有自体故。正见境故亦是谛择。然非烦恼圣道境故。亦非染净因果性故。亦非欣厌所行境故。非觉悟彼得成圣故。不预此中圣谛所摄。何缘烦恼不缘彼生。以彼二法是无漏故。不能违害有漏法故。谓爱但缘有漏为境。欣无漏法违诸有故。不名为爱。是善法欲。若境极能顺生贪爱。此境遍是烦恼所缘。由爱所缘。便于彼灭及彼灭道不欲疑谤空非择灭。与此相违故定不为烦恼境界。岂不于二譬喻等师。缘之亦生不欲疑谤。宁说缘彼烦恼不生。非缘彼生无智疑见障证苦灭及苦灭道。如缘苦等成染污性。如阿罗汉于道路等。亦有无智疑谤现行。岂可说为染污烦恼。是故皆是不染污性。由此说无缘彼烦恼。有说非谤空非择灭。但谤其名不缘其体。此二唯善俗智境界。于苦等谛何不亦然。是故应知前说无失。今应思择。于圣谛中求真见者。初修何行求见圣谛。初业地中所习行仪。极为繁广。欲遍解者。当于众圣所集观行诸论中求。以要言之。初修行者。应于解脱具深意乐。观涅槃德背生死过。先应方便亲近善友。善友能为众行本故。具闻等力得善友名。能品物机如应授法。故近善友名全梵行。行者既为能说正法。善友摄持应修何行。颂曰

  将趣见谛道　　应住戒勤修
  闻思修所成　　谓名俱义境

论曰。诸有发心将趣见谛。应先安住清净尸罗。然后勤修闻所成等。故世尊说。依住尸罗于二法中能勤修习。谓先安住清净戒已。复数亲近诸瑜伽师。随瑜伽师教授诫勖。精勤摄受顺见谛闻。闻已勤求所闻法义。令师教诫所生慧增。渐胜渐明乃至淳熟。非唯于此生喜足心。复于法义自专思择。如是如是决定慧生。自思为因决慧生已。能勤修习诸烦恼等自相共相二对治修。今于此中略摄义者。谓修行者住戒勤修。依闻所成慧。起思所成慧。依思所成慧。起修所成慧此三慧相差别云何。谓如次缘名俱义境。理实三慧。于成满时。一切皆唯缘义为境。尔时难辩三慧相别。故今且约加行位辩。说闻思修缘名俱义。非唯缘名境。有决定慧生。故闻所成慧。不但缘名境。然随师说名句文力故。于义差别有决定慧生。此慧名为闻所成慧。约入方便说但缘名。闻慧成已为知别义。复加精勤自审思择。欲令思择无谬失故。复念师教名句文身。由此后时于义差别生决定慧。名思所成。此加行时。由思义力引念名故说缘俱境。思慧成已等引现前。不待名言证义差别。此决定慧名修所成。故毗婆沙辩三慧相。谓若有慧于加行时。由缘名力引生义解。此所引慧名闻所成。若加行时由思义力引念名解。由此于后生决定慧名思所成。若不待名唯观于义。起内证慧名修所成。此中二慧名所成者。是因闻思力所生义。第三修慧名所成者。是即以修为自性义。如言命器食宝所成诸有欲于修精勤学者。如何净身器令修速成。颂曰

  具身心远离　　无不足大欲
  谓已得未得　　多求名所无
  治相违界三　　无漏无贪性
  四圣种亦尔　　前三唯喜足
  三生具后业　　为治四爱生
  我所我事欲　　暂息永除故

论曰。身器清净略由三因何等为三因。一身心远离。二喜足少欲。三住四圣种。谓若欲令修速成者。要先精勤清净身器。欲令身器得清净者。要先修习身心远离。身远离者。谓远恶朋。心远离者。谓离恶寻。由身心离恶朋寻故。身器清净心易得定。此二由何易可成者。由于衣等喜足少欲。言喜足者。无不喜足。少欲者无大欲。诸有多求资生具者。昼狎恶朋侣。夜起恶寻思。由此无容令心得定。所无二种差别云何。谓于已得妙多衣等。恨不得此倍妙倍多。即于此中显等倍胜。更欣欲故名不喜足。若于未得妙多衣等求得。故名大欲。诸所有物足能治苦。若更多求便越善品。是此中义如契经言。随有所得身安乐者。令心易定及能说法。由此希求治苦物者。是为助道非为过失。故于已得能治苦缘。更求妙多名不喜足。于全未得过量希求。名为大欲。是二别相。喜足少欲能治此故。与此相违应知相别。谓治不喜足不喜足相违。是喜足相能治大欲。大欲相违是少欲相。是于已得能治苦物不更希求。名为喜足。于所未得能治苦物不过量求。名少欲义。喜足少欲界系通三。亦有越三。无漏摄者。谓欲界系善心相应。喜足少欲是欲界系。二界无漏例此应说。所治二种唯欲界系。以何证知。色无色界亦有能治喜足少欲。以现见有生在欲界从色无色等引起时。所治二种现行远故。能治二种现行增故。已说喜足少欲别相。二种通相。所谓无贪以二俱能对治贪故。所治通相。所谓欲贪圣种应知。如能治说。谓亦通三界无漏是无贪。如无色中虽无怨境。而亦得有无嗔善根。故无色中虽无衣等而亦得有无贪善根。如彼不贪身。亦不贪资具。故无色界具四圣种。受欲圣者于圣种中。有阿世耶而无加行。众圣种故名为圣种。圣众皆从此四生故。展转承嗣次第不绝。前为后种世所极成。众圣法身皆从于衣生喜足等力所引起。是圣族姓得圣种名。四中前三体唯喜足。谓于衣服饮食卧具随所得中皆生喜足。此三喜足即三圣种。无贪善根有多品类。于中若治不喜足贪。此乃名为前三圣种。第四圣种。谓乐断修断。谓离系修。谓圣道乐。谓于彼情深欣慕以乐断及修名乐断修。即是欣慕灭及道义。或乐断之修名乐断修。即是欣慕灭之道义。为证惑灭乐修道故。由此能治有无有贪。故此亦以无贪为性。岂不第四亦能治嗔等。则应亦以无嗔等为性。非无此义。然以前三为资粮故。前三唯是无贪性故。此亦自能对治贪故。从显偏说。何缘唯立喜足为圣种。非少欲耶。以少欲者容于衣等物有希求故。谓有意乐性不劣者。于未得境不敢多求。设已得多容求下歇。见喜足者。少有所得尚不更求。况复多得。故唯喜足建立圣种。或为遮止苦行者。欲不说少欲以为圣种。非彼外道心有胜欲。恒有劣欲熏相续故。或随所得生欢喜心不更欣求。名为喜足。断乐欲乐此为最胜。欲界有情多乐欲乐。此乐欲乐违出家心。于离惑中令心闇钝。能障梵行静虑现前。为过最深。喜足能治。故唯喜足建立圣种。非于未得多衣等中起希求时心生欢喜。何况于少。是故少欲于能对治乐欲乐中非最胜故。不立圣种。缘衣服等所生喜足。如何可说是无漏耶。谁言如是喜足是无漏。若尔圣种宁皆通无漏。由彼增上所生圣道。彼所引故从彼为名。故言圣种皆通无漏。不作是言。缘衣服等所有喜足皆通无漏。少欲无漏。准此应释。谓彼增上所生圣道。彼所引故从彼为名。非圣道生缘衣等境。世尊何故说四圣种。以诸弟子舍俗生具及俗事业归佛出家。为彼显示于佛圣法毗柰耶中有能助道生具事业。谓有厌离生死居家。出家求脱有何生具。于随所得衣服等中深生喜足。作何事业深乐断修。异此无能证涅槃故。何缘唯四。不增不减。齐此满足圣生因故。谓圣生因略有二种。一弃舍过。二摄持德。如次即是前三第四。是故唯四。不增不减。或闻思修所成诸善皆是圣种。解脱依故。然为对治四种爱生。是故世尊略说四种。以契经说有四爱生。故契经言。苾刍谛听。爱因衣服。应生时生。应住时住。应执时执。如是爱因饮食卧具。及有无有皆如是说。为治此四故。唯说四圣种。于药喜足何非圣种。不说于彼有爱生故。为治爱生建立圣种。经唯说有四种爱生。是故于药不立圣种。或即摄在前三中故。谓药有在衣服中摄。有在饮食中摄。有在卧具中摄。故于药喜足。不别立圣种。或若于中引憍等过。对治彼故建立圣种。于药无引憍等过生。故圣种无于药喜足。或一切人皆受用者。于彼喜足可立圣种。非彼尊者缚矩罗等曾无有病受用药故。或一切时应受用者。于彼喜足可立圣种。非一切时受用药故。或医方论亦见说有。于药喜足毗柰耶中。方见说有衣等喜足。圣种唯在内法有故。有言虽有于药喜足。而不建立为圣种者。诸药有能顺梵行故。谓世现见乐学戒者。于药喜足障梵行故。或佛为欲暂息永除我我所事欲故说四圣种。谓为暂息我所事欲故说前三圣种为永灭除及我事欲故说第四圣种。我所我执立以欲名。谓为暂时息我所执。故世尊说前三圣种。即于衣等所生喜足及彼增上所引圣道。为永灭除及我事执。故世尊说第四圣种。即乐断修及彼增上所引圣道。皆名圣种。此门意显令有身见暂息永除说四圣种。如是已说将趣见谛所应修行及修行已。为修速成净治身器既集如是圣道资粮。欲正入修由何门入颂曰

  入修要二门　　不净观息念
  贪寻增上者　　如次第应修

论曰。诸有情类行别众多。故入修门亦有多种。然彼多分依二门入。一不净观。二持息念。故唯此二名曰要门。为诸有情入皆由二。不尔如次贪寻增者。为贪增者入依初门。寻增上者入依息念。如非一病一药能除。就近治门说不净观。能治贪病非不治余。息念治寻应知亦尔。然持息念缘无差别微细境故。所缘系属自相续故。非如不净观缘多外境故能止乱寻。既已总说贪寻增者入修如次由前二门。此中先应辩不净观。如是观相云何。颂曰

  为通治四贪　　且辩观骨琐
  广至海复略　　名初习业位
  除足至头半　　名为已熟修
  系心在眉间　　名超作意位

论曰。修不净观正为治贪。然贪差别略有四种。一显色贪。二形色贪。三妙触贪。四供奉贪。对治四贪依二思择。一观内尸。二观外尸。利根初依前。钝根初依后。谓利根者。先于内身皮为边际。足上顶下周遍观察。令心厌患。若钝根者。由根钝故。烦恼猛利难可摧伏。藉外缘力方能伏治。故先明了观察外尸。渐令自心烦恼摧伏。谓彼初欲观外尸时。先起慈心往施身处。观外尸相以况内身。彼相既然。此亦应尔。应修八想伏治四贪。为欲伏治显色贪故。修青瘀想及异赤想。为欲伏治形色贪故。修被食想及分离想。为欲伏治妙触贪故。修破坏想及骸骨想。为欲伏治供奉贪故。修膖胀想及脓烂想。许缘骨琐修不净观。通能伏治如是四贪。以一骨琐中具离四贪境。故应且辩修骨琐观。然于引发诸善根时。补特伽罗。约所修行说有三位。一初习业。二已熟修。三超作意。且观行者欲修如是不净观时。应先系心于自身分。或于足指或于眉间。或鼻頞中或于额等。随所乐处专注不移。为令等持得坚牢故。从入已去名初习业。入言为显最初系心。假想自身足指等处。下至能见钱量白骨。由胜解力渐广渐增。乃至具见全身骨琐。谓于此位诸瑜伽师。假想思惟皮肉烂坠。渐令骨净初量如钱。乃至遍身皆成白骨。彼于此位有多想转。想转言显不舍所缘。数数转生余胜解想。有余师说。观行未成。作意但由想力故转。观行成已便由慧力。此位未成。故由想转。应知此中所言作意。总显一切心心所法。皆由想力相续而转。见全身已复方便入。缘外白骨不净观门。谓为渐令胜解增故。观外骨琐在己身边。渐遍一床一房一寺一园一邑一界一国。乃至遍地以海为边。于其中间骨琐充满。为令胜解渐复增故。于所广事渐略而观。乃至唯观自身骨琐。齐此渐略不净观成。名瑜伽师初习业位。为令略观胜解渐增。于白骨中复除足骨。思惟余骨系心而住。渐次乃至除头半骨。思惟半骨系心而住。齐此转略不净观成。名瑜伽师已熟修位。为令略观胜解自在。除半头骨系心眉间。专注一缘湛然而住。齐此极略不净观成。名瑜伽师超作意位。应知至此不净观成。诸所应为皆究竟故。所缘自在若小若大。应作四句。如理应思。随欲而观伏烦恼故。不名颠倒。得名为善。此不净观。何性几地缘何境。何处生何行相。缘何世为有漏为无漏。为离染得。为加行得。颂曰

  无贪性十地　　缘欲色人生
  不净自世缘　　有漏通二得

论曰。如先所问。今次第答。谓此观以无贪为性。违逆作意为因所引。厌恶弃背与贪相翻。应知此中名不净观。应是慧者理亦不然。观所顺故。谓不净观能近治贪。故应正以无贪为性。贪因净相由观力除。故说无贪为观所顺。诸不净观皆是无贪。非诸无贪皆不净观。唯能伏治显色等贪。方说名为此观体故。此约自性若兼随行。具以四蕴五蕴为性。通依十地。谓四静虑及四近分中间欲界。唯尔所地此容有故。此观唯缘欲界色处境欲界显形为此观境故。若尔何故契经中言。耳根律仪所防护者住不净观。乃至广说。此言为说诸为色贪所摧伏者。彼必由为缘声等贪之所摧伏。故欲摧伏缘色贪者。必先应住耳根律仪。由此方能住不净观。有说此观唯依意识。能引所余违逆行相。故若有住耳根律仪。彼必应先住不净观。此不净观力能遍缘欲界所摄一切色处。若谓尊者阿泥律陀不能观天以为不净。舍利子等于佛色身亦不能观以为不净。如何此观遍缘欲色。此难不然。胜无灭者能观天色为不净故。佛能观佛微妙色身为不净故。由是此观定能遍缘欲色为境。由此已显缘义非名。亦已显成通缘三性。初习业者。唯依人趣能生此观。非北俱卢天趣中无青瘀等故。不能初起先于此起后生彼处。亦得现前此观行相。唯不净转是善性故。体应是净。约行相故。说为不净。是身念住摄。加行非根本。虽与喜乐舍三根相应而厌俱行如苦集忍智随在何世缘自世境。若不生法通缘三世。此观行相非非常等十六行摄。故唯有漏。通加行得及离染得。离彼彼地染。得彼彼定时。亦即获得彼地此观。离染得已。于后后时。亦由加行令得现起。未离染者唯加行得。此中一切圣。最后有异生。皆通未曾。余唯曾得。说不净观相差别已。次应辩持息念。此差别相云何。颂曰

  息念慧五地　　缘风依欲身
  二得实外无　　有六谓数等

论曰。言息念者。即契经中所说阿那阿波那念。言阿那者。谓持息入。是引外风令入身义。阿波那者。谓持息出。是引内风令出身义。如契经说。苾刍当知。持息入者。饮吸外风令入身内。持息出者。驱摈内风令出身外。慧由念力观此为境。故名阿那阿波那念。有余师说。言阿那者。谓能持来。阿波那者。谓能持去。此言意显入息出息有能持义。慧由念观此。故得此念名。辩属身风略有六种。一入息风。二出息风。三发语风。四除弃风。五随转风。六动身风。谓诸有情处胎卵位。先于脐处业生风起。穿身成穴如藕根茎。最初有风来入身内。乘兹口鼻余风续入。此初及后名入息风。此入息风适至身内。有风续出名出息风。如锻金师开槖囊口。自然风入风性法尔。但有孔隙必随入故。入已按之其风还出。入息出息次第亦然。理实此风无入无出。但如是转能损益身。相续道中假名入出。入息转位。能逐身中腐败污垢诸臭秽物。增长火界令身轻举。出息转时。能除郁蒸损减火界令身沉重。发语风者。谓有别风。是欲为先展转所引发语心起所令增盛。生从脐处流转冲喉。击异熟生长养大种。引等流性风大种生。鼓动齿唇舌齶差别。由此势力引起未来。显名句文造色自性。此居口内名语亦业。流出外时但名为语。心生大种其理极成。谓见贪嗔痴心起者。面有润燥乱色异常。又亦传闻怀嗔毒者。面门生焰非有慈心。贪引火生焚身等故。除弃风者。谓有别风。随便路行能蠲二秽。由秽内逼有苦受生。由苦受生发除弃欲。由除弃欲引起风心。此心起风成除弃业。又此风力令身安隐。随转风者。谓有别风。遍随身支诸毛孔转。由此故得随转风名。此不依心但依业力。随身孔隙自然流行。由此能除依孔隙住。腐败污垢诸臭秽物。动身风者。谓有别风。能击动身引起表业。应知此起以心为因。遍诸身支能为击动。因显风义乘辩六风。然于此中正明二息。此中意辩持息念故。此念自性是慧非余。以契经说了知言故。此品念胜故得念名。由念力记持入出息量故。为显缘息定慧得成。由念功能故说为念。并随行性应准前门。此念所依唯通五地。谓依欲界静虑中间及初二三静虑近分。由此但与舍根相应。为对治身修此念故。乐苦等受能顺引发亲里等寻。故对治寻要任运受。现在前位有说下三。根本静虑正在定位。亦有舍受。彼说此念通依八地。上定现前息便无故。此念但缘息风为境。非通缘上所说六风。此念初依欲界身起。唯人天趣。除北俱卢。唯加行得。非离染得。未离染者。定由加行现在前故。非离染得地所摄故。已说皆是近分地摄。非根本故。又此念唯是胜加行引故。不应说此有离染得。此唯真实作意相应。有说亦通胜解作意。正法有情方能修习。外道无有。无说者故。彼不能觉微细法故。此与我执极相违故。彼我执有故此念无。由具六因此相圆满。何等为六。一数。二随。三止。四观。五转。六净。数谓系心数入出息。从一至十不减不增。恐心于境极聚散故。然于此中容有三失。一数减失。二数增失。三杂乱失。复有三失。一太缓失。二太急失。三散乱失。若十中间心散乱者。复应从一次第数之。终而复始乃至得定。凡数息时应先数入。以初生位入息在先。乃至死时出息最后。如是觉察死生位故。于非常想渐能修习。随谓系心随入出息念入出息为短为长为远。至何复还旋返。且念入息为行遍身为行一分。随彼息入行至喉心脐髋髀膝胫腂足指念恒随逐。止谓系念唯在鼻端。或在眉间乃至足指。随所乐处安止其心。观息住身如珠中缕。为冷为暖为损为益观谓观察此息风已。兼观息俱大种造色。及依色住心及心所。具观五蕴以为境界。转谓移转缘息风觉。安置后后胜善根中。谓念住为初。至世第一法。净谓升进入见道等。有余师说。念住为初。金刚喻定为后名转。尽智等方名净息相。差别云何。应知。颂曰

  入出息随身　　依二差别转
  情数非执受　　等流非下缘

论曰。随身生地息彼地摄。以息是身一分摄故。此入出息转。依身心差别。故本论说息依身转亦依心转。随其所应具四缘故。息方得转。依此理说。随所应言。显息必依身心差别。言四缘者。一入出息所依身。二毛孔开。三风道通。四入出息地粗心现前。于此四中随有所阙息便不转。此入出息有情数收。无觉身中息无有故。是虽从外来。而系属内义。此入出息非有执受。以息阙减执受相故。身中虽有有执受风。而此息风唯无执受。此入出息体是等流。是同类因所生果故。身中虽有长养异熟风。而此息风唯是等流性。身增长位息便损减。身损减时息增长故。非所长养。断已于后更相续故。非异熟生。余异熟色无此相故。唯自上地心之所观。非下地心所缘境故。谓生欲界起欲界心。彼欲界身欲界息依欲界心转。即彼心所观。若生欲界起初定心。彼欲界身欲界息依初定心转。即彼心所观。起二三定心皆准前。应说生初静虑起三地心。生二生三起二起自。准生欲界如理应说若生上地起下地心。彼上地身上地息依下地心转。非彼心所观。如是欲界息。四地心所观。初二三定息。如其次第为三二地息地心所观有息地四无息地五。住有息地起无息地心。息必不转住。无息地起有息地心。息亦不转。住有息地起有息地心。随其所应有入出息转所辩持息念成满相。云何应作是言。若观行者。注想观息微细徐流。谓想遍身如筒一穴。息风连续如贯末尼。不能动身不发身识。齐此应说持息念成。有余师言。增长自在所作事辨。名此念成。初增长言。显持息念下中上品次第成立。乃至若时随其所乐。能入能出名为自在。若于此位能摄益身远耽嗜依寻名所作事办。有余师说。若具六相远离三失。或若具足修十六种殊胜行相。齐此应说持息念成。经说息念有十七种。谓念入出息了知我已念入出息短入出息长觉遍身止身行觉喜觉乐觉心行止心行觉心令心欢喜令心摄持令心解脱随观非常随观断随观离随观灭。如是一一皆自了知。此十七中初是总观。后十六种是差别观。约四念住如次应知。各有四门成十六种。如何觉心行可受念住摄。因受果名故无有过。非此中说。心行谓思。应知此中受名心行。谓由耽着乐受味故。便于彼彼境界或生思造作心名为心行。受是思因故。名心行无失。或但能觉受自体者。义准亦于思等自体。次第能觉生住坏相。如尝大海一滴水碱。则亦遍知大海水味。故唯觉受名觉心行。广解一一相。如经释中辩

说一切有部显宗论卷第二十九阿毗达磨藏显宗论卷第三十

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩贤圣品第七之二

如是已说入修二门。由此二门心便得定。心得定已复何所修。颂曰

  依已修成止　　为观修念住
  以自相共相　　观身受心法
  自性闻等慧　　余相杂所缘
  说次第随生　　治倒故唯四

论曰。已修成止以为所依。为观速成修四念住。非不得定者能如实见故。如何修习四念住耶。以自相共相。观身受心法。谓修观者专心一趣。以自共相于身等境。一一别观修四念住。分别此法与所余法有差别义。名观自相。分别此法与所余法无差别义。名观共相。且身念住观自相者。谓观察身诸处别相。观共相者。谓观诸处同是身相。成色相同。或观自相者。谓观身别相。观共相者。谓观察身与余有为皆非常等。受等念住准此应知。此四各三。谓自性等自性谓慧唯闻等三。相杂谓余此俱有法。所缘谓此三慧所缘。何故此三皆名念住。由念令慧得住所缘。念慧相资胜定等故。由此于慧立念住名。此相杂所缘。故亦名念住。何缘故说三种念住。为愚行相资粮所缘三种有情。故说三种。或根胜解分位各三机宜不同。故说三种。三中相杂能断烦恼。非二能断。太减增故。然相杂言亦摄慧体。慧与俱有互相杂故。若言自性应无所待。显有所待说相杂言。唯修所成法念住摄。能断烦恼要在定中。能断惑故缘四五蕴。或缘涅槃能断惑故。法念住中共相作意。能断烦恼自相作意。缘少分境故无此能。四念住内前之三种唯不杂缘。第四通二。然三谛智唯有杂缘能断烦恼。唯灭谛智虽不杂缘。亦断烦恼。身等念住各有三种。缘内外俱有差别故。且身念住有三种中。缘自相续说名为内。缘他身等说名为外。双缘二种说为内外。以有我爱而慢缓者。应观内身犹如外故。或内如前缘无执受。说名为外。缘他相续说为内外。待无执受及待自身。得二名故。或缘根境及俱名三。或缘有情及非情数。通缘二种差别为三。或缘有情外非情数及毛发等。差别为三。以彼皆从内身生故。离根住故具得二名。或缘有情现在名内。缘外非情三世名外。缘情去来说为内外。有情类故。堕法数故。又彼未来当堕情数正堕法数。彼过去时曾堕情数正堕法数。彼不生法是生类故。受等三种一一各三。随其所应准前应释。此四念住说次随生。生复何缘次第如是。生次如是相随顺故。有情多分于诸色中。好受用故不逮胜法。好受用色以何为缘。谓于受中情深欣乐。欣乐于受由心不调。心之不调由诸烦恼。心由信等可令调伏。随观此理四念住生。或随所缘粗细生故。然非由此心最后观法中涅槃极微细故。彼想思等循观受时。准义已能了知其相。同依心起等安危故。有余师说。色可聚散可取可舍。相似相续不净苦等。易了知故。多分缘身生贪等故。男女展转起贪处故。不净观持息念及分别界三入修门一切多缘身为境故。修念住位应最初观。此观为因生轻安触。由轻安触引乐受生。经说身安便受乐故。如是乐受依心而生。净心为因得解脱果。由是受等随次而观。故念住生如是次第。此四念住不增不减。能治净等四颠倒故。观身不净治于不净谓净颠倒。虽净颠倒通缘五蕴。然但观身自性非净。便能总伏。如人已观粪体不净。亦不欣乐从粪所生。如是已观身体不净。亦不欣乐从身所生。由此观身为不净者。于五取蕴皆不欣乐。以有为身净想迷者。彼方欣乐依身所生。是故观身为不净者。于身所起亦不欣乐。如有安住不净观时。虽不亲观声等为境。而于歌等弃如粪秽。如是安住身念住时。虽不亲观受等为境。观身自体为不净故。终不欣乐受等三境。又虽不观色无色境以为不净。而于彼境非不引生不乐行相。是故净倒虽缘五蕴。身念住成便能总伏。后三念住虽各别观。例此应思能总伏理。观受是苦能治于苦。谓乐颠倒。谓若有法真可欣欲。是为乐义。于多过患所杂行中。见有可欣殊胜功德。是名于苦谓乐颠倒。此倒必用耽受为先。以于受中深耽着已。方于一切逼恼所依有漏行中妄生乐想。是故观受为苦性时。便能总伏计乐颠倒。观心非常能治非常谓常颠倒。谓观行者憎厌受故。于所依心见有众多品类差别。引非常观令现在前。便于有为不生常想。故能总伏计常颠倒。观法非我能治非我谓我颠倒。谓有一类。闻我非常心不生喜。遂作是念。谁令此心有多差别。彼即是我。为遮彼计复应谛观。除三所余亦唯是法。便于一切不起我想。故能总伏计我颠倒。或为对治段触识思食。如次建立身等四念住。数唯有四不增不减。如是熟修不净观持息念二加行已。能次第引所缘不杂身受心法念住现前。复于不杂缘法念住。无间引所缘杂法念住生。次应修总缘共相法念住。此法念住其相云何。颂曰

  彼居法念住　　总观四所缘
  修非常及苦　　空非我行相

论曰。杂缘法念住总有四种。二三四五蕴为境别。故唯总缘五名此所修。彼居此中修四行相。总观一切身受心法。所谓非常苦空非我。然于修习此念住时。有余善根能为加行。彼应次第修令现前。谓彼已熟修杂缘法念住。将欲修习此念住时。先应总缘修非我行。次观生灭。次观缘起。以观行者先观诸行从因生灭。便于因果相属观门易趣入故。或有欲令先观缘起。此后引起缘三义观。此观无间修七处善。于七处善得善巧故。能于先来诸所见境。立因果谛次第观察。如是熟修智及定已。便能安立顺现观谛。谓欲上界苦等各别。于如是八随次第观。修未曾修十六行相。彼由闻慧于八谛中初起如斯十六行观。如隔薄绢睹见众色。齐此名为闻慧圆满。思所成慧准此应说。次于生死深生厌患。欣乐涅槃寂静功德。此后多引厌观现前。方便勤修渐增渐胜。引起如是能顺决择。思所成摄最胜善根。即所修总缘共相法念住。从此无间生何善根。颂曰

  从此生暖法　　具观四圣谛
  修十六行相　　次生顶亦然
  如是二善根　　皆初法后四
  次忍唯法念　　下中品同顶
  上唯观欲苦　　一行一刹那
  世第一亦然　　皆慧五除得

论曰。从顺决择胜思所成。总缘共相法念住后。有修所成顺决择分。初善根起名为暖法。是总缘共相法念住差别。如是所起是当所修。能烧烦恼薪。圣道火前相。如钻火位初暖相生。法与暖同故名暖法。此善根起分位长故。能具观察四圣谛境。由此具修十六行相。观苦圣谛修四行相。一非常。二苦。三空。四非我。观集圣谛修四行相。一因。二集。三生。四缘。观灭圣谛修四行相。一灭。二静。三妙。四离。观道圣谛修四行相。一道。二如。三行。四出。此相差别如后当辩。然诸暖法虽缘四谛。而从多分说厌行俱。以起彼时蕴想多故行者修习此暖善根。下中上品渐次增进。于佛所说苦集灭道生随顺信观察诸有。恒为猛盛焰所焚烧。于三宝中信为上首。有修所成顺决择分。次善根起名为顶法。是总缘共相法念住差别。顶声显此是最胜处。如吉祥事至成办时。世间说为此人至顶。谓色界摄四善根中。二是可动。二不可动。可动二中。下者名暖。上者名顶。动中上故。不动二中。下者名忍。于四谛境极堪忍故。上者名为世第一法。世中胜故。犹如醍醐。闲居者言。修此善品其相至顶。故名顶法。此境行相与暖法同。谓观四谛境。修十六行相。如是暖顶二种善根。初安足时唯法念住。后增进位四皆现前。初安足言。显以行相最初游践四圣谛迹。后增进言。显从此后下中上品次第数习。诸先所得后不现前。于彼不生钦重心故。以胜加行引此善根。故已得中不生钦重。然此顶法虽缘四谛。缘三宝信多分现行。此顶善根下中上品。渐次增长至成满时。有修所成顺决择分。胜善根起名为忍法。是总缘共相法念住差别。于四谛理能忍可中此最胜故。又此位忍无退堕故。名为忍法。世第一法。虽于圣谛亦能忍可。无间必能入见道故。必无退堕而不具观四圣谛理。此具观故偏得忍名。故偏说此名顺谛忍。此忍善根安足增进。皆法念住与前有别。此与见道渐相似故。以见道位中唯法念住故。然此忍法有下中上。下中二品与顶法同。谓具观察四圣谛境。及能具修十六行相。上品有异。唯观欲苦与世第一相邻接故。由此义准暖等善根皆能具缘三界苦等义已成立。无简别故。忍下中上如何分别。且下品忍具八类心。谓瑜伽师以四行相观欲界苦名一类心。如是次观色无色苦。集灭道谛亦如是观。成八类心。名下品忍。中忍减略行相所缘。谓瑜伽师以四行相观欲界苦。乃至具足。以四行相观欲界道。于上界道减一行相。从此名曰中品忍初。如是次第渐减渐略行相所缘。乃至极少。唯以二心观欲界苦。如苦法忍苦法智位。齐此名为中品忍满。上忍唯观欲界苦谛。修一行相。唯一刹那。此善根起不相续故。上忍无间有修所成。初开圣道门。世功德中胜。是总缘共相法念住差别。顺决择分摄最上善根。生此即说名世第一法。此有漏故名为世间。是最胜故名为第一。有士用力离同类因引圣道起故名最胜。是故名为世第一法。此如上忍缘欲苦谛。修一行相唯一刹那。如是减略行相所缘。如是如是渐近见谛。故世第一唯缘欲苦。修一行相唯一刹那。谓无间入离生位故。此位决定无相续理。然色界系有九善根。下下下中下上名暖。中下中中中上名顶。上下上中名忍。上上名世第一。暖等四法以何为体。暖等自性皆慧为体。若并助伴皆五蕴摄。定俱必有随转色故。然除彼得勿诸圣者。暖等善根重现前故。然已见谛不许暖等重现在前。已见谛者。加行现前成无用故。此中暖法初安足时。于三谛中随缘何谛。法念住现在修未来四随。一行相现在修未来四。唯修同分非不同分。缘灭谛法念住现在修未来一。随一行相现在修未来四。非初观蕴灭能修缘蕴道后增进位。于三谛中随缘何谛。随一念住。现在修未来四随。一行相现在修未来十六。缘灭谛法念住现在修未来四随。一行相现在修未来十六。此初安足唯修同分者。先未曾得如是种性故。于诸谛中行未广故。后增进位与此相违。故彼能修同分异分。顶初安足。于四谛中随缘何谛。法念住现在修未来四随。一行相现在修未来十六。后增进位于三谛中随缘何谛。随一念住现在修未来四随。一行相现在修未来十六。缘灭谛法念住现在修未来四随。一行相现在修未来十六。忍初安足及后增进。于四谛中随缘何谛。法念住现在修未来四随。一行相现在修未来十六。此依忍类总相而说。差别说者。略所缘时。随略彼所缘。不修彼行相。谓具缘四具修十六。若缘三二一。修十二八四。世第一法缘欲苦谛法念住现在修未来四随。一行相现在修未来四。唯同分修无缘余谛世第一法。是故唯修尔所行相。有余师说。近见道故。似见道故。唯修尔所。谓苦法忍。唯缘欲苦谛修四行相。世第一亦然。已辩所生善根相体。今次应辩彼差别义。颂曰

  此顺决择分　　四皆修所成
  六地二或七　　依欲界身九
  三女男得二　　第四女亦尔
  圣由失地舍　　异生由命终
  初二亦退舍　　依本必见谛
  舍已得非先　　二舍性非得

论曰。此暖顶忍世第一法。四殊胜善根名顺决择分。由下中上及上上品。分为四种。如前已说。决谓决断。择谓简择。决断简择。谓诸圣道。以诸圣道能断疑故。及能分别四谛相故。分谓分段。即是见道。是决择中一分摄故。暖等为缘引决择分。顺益彼故得顺彼名。故此名为顺决择分。如是四种皆修所成。非闻思所成。远决择分故。此四善根皆依六地。谓四静虑未至中间。欲界中无。阙等引故。余上地亦无。见道眷属故。又无色界心不缘欲界故。欲界先应遍知断故。于三界中彼最粗故。此四善根能感色界五蕴异熟为圆满因。不能牵引众同分故。极厌诸有欣圆寂故。或声为显二有异说。谓暖顶二。尊者妙音说。依前六及欲七地。对法诸师不许彼说。非闻思所成。顺决择分故。此四善根依欲身起。人天九处除北俱卢。唯依欲九身容入离生故。除增上忍世第一法。余三善根三洲初起。后生天处亦续现前。所除亦依天处初起。有余师说。若于先时曾已修治此四加行。彼于天处皆得初起。此四善根唯依男女。前三男女俱通得二。第四女身亦得二种勿后得男身。不成暖等故。依男唯得男身。善根圣转至余生。亦不为女故。暖顶忍位容有转形故。二依善根展转为因住。世第一法依女身者能为二因。女得圣已容有转得男身理故。依男身者。但为一因已得女身非择灭故。圣依此地得此善根。失此地时善根方舍。失地言显迁生上地。异生于地若失不失。但失众同分必舍此善根。圣身见道力所资故。此四善根无命终舍。宁知命终舍。唯异生非圣。以本论说卵胎中异生。唯成就身不成身业故。岂不异生先依下地起暖法等。后生上地亦必定舍。暖等善根无如是失。以彼异生尔时舍善根由舍同分故。谓住死有无圣道资。舍诸善根非由上地中有等起。若诸圣者住死有中。由圣道资不舍暖等。但由上地中有等起舍下善根。舍时虽同而所由别。是故异生无失地舍。圣者必无由命终舍。异生命终虽舍忍法。而定无有堕诸恶趣。得恶趣生非择灭故。身是忍法曾所居故。能感恶趣诸业烦恼。不复能在身中行故。如师子窟杂兽不居。初二善根亦由退舍。如是退舍异生非圣。后二异生亦无退舍。依根本地起暖等善根。彼于此生必定得见谛。以根利故。厌有深故。依未至中间起暖等者。于此生不必得入见谛。有余师言。依根本定起暖等者。此生必定得至涅槃。厌有深故。若先舍已后重得时。所得必非先之所舍。由先舍已后重得时。亦大劬劳方得起故。于先所舍不钦敬故。如先已舍别解脱戒。后重受时得未曾得。暖等亦尔。后得非先。若先已得暖等善根。经生故舍。遇了分位善说法师便生顶等。若不遇者。还从本修失退二舍非得为性退舍。必因起过而得失舍。或有由德增进。得此善根有何胜利。颂曰

  暖必至涅槃　　顶终不断善
  忍不堕恶趣　　第一入离生

论曰。四善根中若得暖法。虽有退断善根造无间业堕恶趣等。而无久流转必至涅槃故。若尔何殊顺解脱分。若无障碍去见谛近。此与见道行相同故。是等引摄胜善根故。若得顶法虽有退等。而增毕竟不断善根。观察三宝殊胜功德为门引生净信心故。若得顶已不断善根。如何经说。天授退顶。由彼曾起近顶善根。依未得退密作是说。若得忍法虽命终舍住异生位。而增无退不造无间不堕恶趣。然颂但说不堕恶趣。言义准已知。不造无间业。造无间业者。必堕恶趣故。忍位无退如前已辩。得忍不堕诸恶者。已远趣彼业烦恼故。得恶趣生非择灭故。由下忍力已得一切恶趣无生。由上忍力复得少分生等无生。少分生者。谓卵湿生。由此二生多愚昧故。等言为显处身有惑。处谓无想大梵北洲无想大梵僻见处故。北俱卢洲无现观故。身谓扇搋等。多诸烦恼故。有谓第八等圣必不受故。惑谓见断惑。必不复起故。得世第一法。虽住异生位。而能趣入正性离生。颂虽不言离命终舍。既无间入正性离生。义准已成。无命终舍。何缘唯此能入离生。已得异生非择灭故。能如无间道舍异生性故。此四善根各有三品。由声闻等种性别故。随何种性善根已生。彼可移转向余乘不。颂曰

  转声闻种性　　二成佛三余
  麟喻佛无转　　一坐成觉故

论曰。未殖佛乘顺解脱分。依声闻种性。起暖顶善根。容可转生佛乘暖顶。是经长时方能起义。若起彼忍无向佛乘。以声闻乘加行最久。经六十劫自果必成。菩萨专求利他事故。为欲拔济无边有情。弘誓庄严经无量劫。故往恶趣如游园苑。若不尔者。无成佛义。起忍得一切恶趣非择灭。故起彼忍无向佛乘。断绝众多利他事故。若时菩萨已殖佛乘。顺解脱分为遮恶趣。展转坚摄施戒慧三。尔时无劳起余乘忍。故声闻暖顶可转向佛乘。起忍则无转成佛义。依声闻种性起暖顶忍。三皆可转生独觉乘道。非声闻种性忍法已生于独觉菩提有能障义。故起彼忍亦成独觉。此在佛外。故颂言余。起独觉乘种性暖顶。为有转向余乘理不然。独觉乘总有二种一。麟角喻二。先声闻。若先声闻如声闻说。麟喻及佛俱不可转。以俱一坐成菩提故。第四静虑是不倾动。最极明利三摩地故。堪为麟喻大觉所依。故彼俱依第四静虑。从身念住至尽无生。唯于一坐能次第起。故麟角喻及佛种性。暖等善根皆不可转。颇有初殖顺解脱分。此生即能起顺决择分耶。不尔云何。颂曰

  前顺解脱分　　速三生解脱
  闻思成三业　　殖在人三洲

论曰。顺决择分今生起者。前生必起顺解脱分。诸有创殖顺解脱分。极速三生方得解脱。谓初生殖顺解脱分。次生成熟。第三生起顺决择分。即入圣道。若谓第二生起顺决择分。第三生入圣乃至得解脱。彼言便与前说相违。谓依根本地起暖等者。彼必于此生得入见谛。或彼应许极速二生。谓第二生依根本地起暖等者。彼于现生必入圣道得解脱故。顺解脱分闻思所成。非修所成。诸有未殖顺解脱分者。彼不能殖故。顺解脱分三业为体。最胜唯是意地意业。此思愿力摄起身语。亦得名为顺解脱分。有由少分施戒闻等。便能种殖顺解脱分。谓胜意乐至诚相续。厌背生死欣乐涅槃。与此相违。虽多修善而不能殖顺解脱分。由意业胜殖此善根故。唯人中三方能殖。厌离般若余处劣故有佛出世。若无佛时。俱能种殖顺解脱分。已因便说顺解脱分。入观次第是正所论。于中已明诸加行道。世第一法为其后边。应说从斯复生何道。颂曰

  世第一无间　　即缘欲界苦
  生无漏法忍　　忍次生法智
  次缘余界苦　　生类忍类智
  缘集灭道谛　　各生四亦然
  如是十六心　　名圣谛现观
  此总有三种　　谓见缘事别

论曰。从世第一善根无间。即缘欲界苦圣谛境。有无漏摄法智忍生。此忍名为苦法智忍。宁知此忍是无漏摄。从世第一无间而生。以契经中言世第一无间入正性决定。或正性离生。尔时名超异生地故。此忍既是决定离生一分所摄。定是无漏。从世第一无间而生。说无漏言。为欲简别世第一法。所从世忍此无漏忍。以欲苦法为其所缘。名苦法忍。谓于苦法无始时来。身见所迷执我我所。今创见彼唯苦法性。忍可现前名苦法忍。此能引后苦法智生。是彼智生障之对治。故复名曰苦法智忍。即此名入正性决定。亦复名入正性离生。由此是初入正性决定。亦如初入正性离生故。经说正性。所谓涅槃。或正性言目诸圣道能决趣涅槃。或决了谛相。故诸圣道得决定名。至得决定说名为入。若尔何缘于无漏慧。唯初见谛得决定名。以于尔时于诸谛理初得难毁决定见故。或于尔时望余位道有非一种决定相故。烦恼名生。如契经说。何谓生臭。谓诸烦恼见位初越。故名离生。有说。生言目根未熟。见位初越。故名离生。至得离生。说名为入。舍异生性诸说不同。有言。世第一有言。苦法忍。有言。共舍。由此二种如无间道解脱道故。此忍无间即缘欲苦有法智生名苦法智。于唯是苦法得决断慧故。应知此智亦无漏摄。前无漏言。遍流后故。如缘欲界苦圣谛境。有苦法忍苦法智生。如是复于法智无间。总缘余界苦圣谛境。有类智忍生。名苦类智忍。此忍无间。即缘此境有类智生。名苦类智。最初证知诸法真理。故名法智。此后境智与前相似。故得类名。是后随前而证境义。或从前生故。后得前类名。如世间言子是父类。即是从欲界苦决定觉所生。余界苦决定觉义。如缘苦谛欲界及余生法类忍法类智四缘。余三谛各四亦然。即缘一一有四心义。如是次第有十六心。总说名为圣谛现观。以于三界四圣谛境次第现前如实观故。初习业地于诸谛境多返旋环已淳熟故。今于此位能如是观。余部有言。唯顿现观。彼言既总。理或无违。以谛现观总有三种。其三者何。谓见缘事唯无漏慧于诸谛境如实觉了。名见现观。是即由见分明现前。如实而观四谛境义。即无漏慧。并余相应同一所缘。名缘现观。是即由见等心心所法同。能取所缘四谛境义。即诸能缘并余俱有同一事业。名事现观。是即由见等心心所法并余俱有戒及生相等。于诸谛中同所作义。戒生相等是现观因。于现观中彼有事用。故亦于彼立现观名。如是应知不相应法唯一现观。除慧所余心心所法。有二现观。唯无漏慧具足有三。诸说名为顿现观者。谓于一谛得现观时。于余谛中亦得现观。故于前说顿现观宗。应审推征依何现观。若言依事应赞言善。以于苦谛得现观时。于苦具三。于余唯事。谓初观见苦圣谛时。尽烦恼故即名断集。得择灭故即名证灭。起对治故即名修道。以见苦位于集等三有断证修事现观故。约事现观名顿无失。若言依见应拨言非。此现观必渐诸谛相别故。一见理无多行相故。随彼自相一一谛中。世尊说言。各别见故。已辩现观具十六心。此十六心为依何地。颂曰

  皆与世第一　　同依于一地

论曰。随世第一所依诸地。应知即此十六心依。彼依六地如前已说。谓四静虑未至中间。何缘必有如是忍智。前后次第相杂而起。颂曰

  忍智如次第　　无间解脱道

论曰。十六心中四法类忍名无间道。四法类智。名解脱道。名如前说。能忍可先来未见欲苦初念无漏慧。名苦法忍。以契经中世尊自说。若于此法以下劣慧或增上慧审察忍可。名随信行。随法行故。应知此忍即无间道。何处说此无间道名。经说。一法难可通达。名为无间。心等持故。又世尊说。有苦法智有苦类智乃至广说。非此二智同缘三界苦等境起。如顺理辩。故于苦法忍所见欲苦中决断解生。名苦法智。前忍能断十烦恼得。后智能与彼离系得俱生。经说。智生随于前忍。故知后智名解脱道。从此无间忍色无色。未曾见苦第三刹那。无漏慧生。名苦类忍。是见欲苦忍种类故。次于苦类忍所观上苦中决断解生。名苦类智。忍智如次断烦恼得。名无间道。离系得俱。名解脱道。准前应说。于余三谛准苦应知。故前八忍名无间道。后之八智名解脱道。复以何缘说断对治。名无间道。说离系得俱时起智。名解脱道。无间隔故名为无间。无间即道名无间道。是无同类道能为间隔令于解脱道不为缘义。诸无间道唯一刹那。诸解脱道或相续故。于自所治诸烦恼得已得解脱。与彼断得俱时起道。名解脱道。自所治言欲显何义。苦类忍等诸无间道。亦与他所治离系得俱生。勿彼亦名解脱道故。此十六心皆见谛理。一切皆说见道摄耶。不尔云何。颂曰

  前十五见道　　见未曾见故

论曰。见未曾见四圣谛理。名为见道。故于现观十六心中。前十五心是见道摄。道类忍位于诸谛中见圆满故。至第十六道类智时。虽亦有一先未知谛。而无一谛先未见者。以一切忍皆见性故。由此尔时不名见道。岂不亦见曾未见谛。谓道类智见道类忍。相应俱有一念道故。诸有唯见曾未见者。名为见道。尔时通见曾未曾见。故无此失。或此约谛不约刹那。非尔时观未曾见谛。非于一谛多刹那中未见一刹那可名未见谛。如刈畦稻唯余一科。不可名为此畦未刈。故见未见名为见道。是见道相义善成立。故我宗说现观后边道类智品是修道摄。兼修异境智行相故

说一切有部显宗论卷第三十阿毗达磨藏显宗论卷第三十一

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩贤圣品第七之三

已辩见修二道生异。当依此道分位差别。建立众圣补特伽罗。且依见道十五心位。建立众圣有差别者。颂曰

  名随信法行　　由根钝利别
  具修惑断一　　至五向初果
  断次三向二　　离八地向三

论曰。见道位中圣者有二。一随信行。二随法行。由根钝利别立二名。诸钝根名随信行者。由先信敬力修集加行故。诸利根名随法行者。由先乐观察修集加行故。诸有情类种姓差别。法尔先来如是安住。于诸事业有不乐观。或有乐观能不能转。即二圣者。由于修惑具断有殊立为三向。谓彼二圣。若于先来未以世道断修断惑名为具缚。或先已断。欲界一品乃至五品。至此位中名初果向。趣初果故。言初果者。谓预流果。此于一切沙门果中必初得故。若先已断欲界六品或七八品。至此位中名第二果向。趣第二果故。第二果者。谓一来果。遍得果中此第二故。若先已离欲界九品。或先已断初定一品。乃至具离无所有处。至此位中名第三果向。趣第三果故。第三果者。谓不还果。数准前释。如是随信随法行者。由先具缚断惑有殊。数别各成七十三种。谓于欲界具缚为初。至断九品以为第十。如是乃至无所有处。地地各九为七十三。诸后具缚即前离九。故后七地无别具缚。次依修道道类智时。建立众圣有差别者。颂曰

  至第十六心　　随三向住果
  名信解见至　　亦由钝利别

论曰。即前随信随法行者。至第十六道类智心。名为住果。不复名向。随前三向今住三果。谓前预流向今住预流果。前一来向今住一来果。前不还向今住不还果。阿罗汉果。必无初得。异生无容。离有顶故。见道无容。断修惑故。至住果位。舍得二名。谓不复名随信法行。转得信解见至二名。此亦由根钝利差别。诸钝根者。先名随信行。今名信解。由信增上力胜解显故。诸利根者。先名随法行。今名见至。由慧增上力正见显故。何缘先时断修所断欲一至五。或七八品。初定一品。广说乃至。无所有处。第九品惑。至第十六道类智心。但名预流一来不还果。非一来不还阿罗汉向。颂曰

  诸得果位中　　未得胜果道
  故未起胜道　　名住果非向

论曰。依得圣道建立八圣。故初得果位未得胜果道。以得果心于胜果道所对治惑非对治故。非非彼治现在前时得彼治道。其理决定。又非得果时即有胜果道所断烦恼离系得生。道类忍不能断彼系得故。若道力能断彼系得。此道引彼离系得生。可说此道能证彼灭。以得前果时未得胜果道故。住果者。乃至未起胜果道时。虽先已断修所断惑欲一品等。但名住果不名后向。后于何时得先所断修惑离系无漏得耶。于胜果道现前时得为诸先断。后修断惑入离生位得前果已。此生定起胜果道耶。理必应然。以本论说圣生第四静虑以上无漏乐根定成就故。彼障已断必欣彼故。障已断道易现前故。如是已依先具倍离及全离欲入见谛者。十六心位立众圣别。当约修惑辩渐次生。能对治道分位差别。颂曰

  地地失德九　　下中上各三

论曰。失谓过失。即所治障。德谓功德。即能治道。如先已辩欲修断惑九品差别。上四静虑及四无色。应知亦然。生死无非九地摄故。如所治障。一一地中各有九品。诸能治道无间解脱。九品亦然。失德如何。各分九品。谓根本品有下中上。此三各分下中上别。由此失德各分九品。谓下下下中下上。中下中中中上。上下上中上上品。应知此中下下品道势力能断上上品障。如是乃至上上品道势力能断下下品障。上上品等诸能治德初未有故此德有时上上品等失已无故。应知此中智虽胜惑。未增盛故道名下品。相续中惑虽极难断。细随行故障名下品。依如是理应立譬喻。如浣衣位粗垢先除。于后后时渐除细垢。又如粗闇小明能灭。要以大明方灭细闇。失德相对理亦应然。由此可言白胜黑劣。以刹那顷能治道生拔无始来诸惑根故。已辩失德差别九品。次当依彼立圣者别。且诸有学修道位中。总亦名为信解见至。随位复有多种差别。先应建立都未断者。颂曰

  未断修断失　　住果极七返

论曰。诸住果者。于一切地修所断失。全未断时名为预流。生极七返。七返言显七往返生。是人天中各七生义。极言为显受生最多。非诸预流皆定七返。故契经说。极七返生。是彼最多。七返生义。经说。与此义无差别。诸无漏道总名为流。由此为因趣涅槃故。预言为显最初至得彼预流故。说名预流。此预流名为目何义。若初得道名为预流。则预流名应目第八。若初得果名为预流。则倍离欲全离欲者。至道类智应名预流。此预流名目初得果。然倍离欲全离欲者。至道类智不名预流。约修惑断立彼果故。预流必依遍得果者。初所得果以立名故。一来不还非定初得。唯有此果必初得故。何缘此名不目第八。未具得向果无漏道故。未具得见修无漏道故。未遍至得现观流故。八忍八智名现观流。道类智时皆具至得。是故第八不名预流。由此预流唯是初果。彼从此后欲人天中各受七生。应言十四。何故说彼极受七生。此责不然。七数等故。如七叶树及七处善圣道力故不过七有。中间虽有圣道现前。余业力持不证圆寂。唯依佛出世有别解律仪故。彼第七有。若不遇佛法便在家得阿罗汉果。既得果已必不住家。苾刍威仪法尔成就。虽不会遇前佛所说。而于余命生极厌心。不经久时便入圆寂若于人趣得预流果。人中满七。天准应知。非圣亦有极七返生。相续成熟得涅槃义。然非决定。是故不说。已辩修惑都未断者名预流果极七返生。今次应辩断位众圣。且应建立一来向果。颂曰

  断欲三四品　　三二生家家
  断至五二向　　断六一来果

论曰。即预流者进断修惑。若三缘具转名家家。一由断惑。断欲修惑三四品故。谓或于先异生位断。或今预流进修位断。二由成根。得能治彼无漏根故。谓已成就彼能治道三品四品无漏诸根。三由受生。更受欲有三二生故。谓断三品更受三生。若断四品更受二生。此三二生由异生位。造作及增长。感三二生业。非诸圣者。于圣位中。更能新作。牵后有业。以背生死向涅槃故。由此契经说诸圣者唯受故业更不造新。若三缘中随阙一种阙二全阙不名家家。何故成根。颂中不说预流果后说进断惑成能治彼无漏诸根。义准已成。故不具说。若尔应不说三二生言说。断三四品义已成故。谓已进断三四品惑。决定余有三生二生。故说家家相不圆满。则应于颂更说等声。方可具收家家三相。或应不说三二生言。然颂中言三二生者。以有增进。于所受生。或少或无。或过此故。应知总有二种家家。一天家家。谓欲天趣生三二家而证圆寂。或一天处。或二或三。二人家家。谓于人趣生三二家而证圆寂。或一洲处。或二或三。若有七生。生不满七。非家家位。中间涅槃。何类所摄。摄属七生。七中极声。显极多故。由此已显生未满前得般涅槃。亦是彼摄。根最钝者。具经七生。非诸利根生定满七。宁无断五亦名家家。以断五时必断第六。非一品惑能障得果。犹如一间未越界故。即预流者。进断欲界一品修惑。乃至五品。应知转名一来果向。若断第六成一来果。彼往天上一来人间。而般涅槃名一来果。过此以后更无生故。即由此义证家家中。若天家家。受三生者。人间受二。天上受三受二生者。人一天二。如应例释人中家家。若谓不然。彼一来果有何异彼二生家家。彼贪嗔痴唯余下品。故即一来果名薄贪嗔痴。已辩一来向果差别。次应建立不还向果。颂曰

  断七或八品　　一生名一间
  此即第三向　　断九不还果

论曰。即一来者。进断余惑。若三缘具转名一间。一由断惑。断欲界中修断七品或八品故。二由成根。得能治彼无间解脱无漏根故。三由受生。更受欲有天或人中余一生故。若三缘中随阙一种阙二全阙不名一间。成无漏根。颂中不说及应复说。一生所因。准家家中如应当释。所言间者。是隙异名。谓彼位中由有一隙容一生故未得涅槃。或此间名目间隔义。谓于彼位有余一生为间隔故不证圆寂。有一间者。说名一间。如何有余一品修惑能为障碍令受欲界生。名为一间。未得不还果。若断此品便为超越欲界所系诸业烦恼异熟等流二果地故。彼极为碍容更受生。断六品时未越彼地。故无断五中间受生。现身不能证一来果。即断修惑七八品者。应知亦名不还果向。先断三四七八品惑入见谛者。后得果时即名家家。及一间不。此未名曰家家一间。未得治彼无漏根故。初得果位果道现前。尔时未修胜果道故。要至后位起胜果道。方得名曰家家一间。治彼无漏根尔时方得故。即先成就一来果者。断欲界惑九品尽时。舍一来名得不还果。必不还受欲界生故。此或名为五下结断。此据集断密作是说。必无五结俱时断理。或二或三先已断故。依不还位。诸契经中以种种门建立差别。今次应辩彼差别相。颂曰

  此中生有行　　无行般涅槃
  上流若杂修　　能往色究竟
  超半超遍殁　　余能往有顶
  行无色有四　　住此般涅槃

论曰。此不还者。总说有七。且行色界差别有五。一中般涅槃。二生般涅槃。三有行般涅槃。四无行般涅槃。五者上流。此于中间般涅槃故。说此名曰中般涅槃。如是应知。此于生已。此由有行。此由无行般涅槃故。名生般等。此上流故名为上流。言中般者。谓有一类补特伽罗。已于生结得非择灭。起结不尔。彼于欲界遇逼恼缘之所逼恼。便能自勉修断余结殊胜加行。加行未满遇舍命缘。遂致命终。由起结力受色中有。厌多苦故。乘前起道进断余结。成阿罗汉得般涅槃。言生般者。谓有一类补特伽罗。由先具造顺起生业及增长故。欲界殁已受色界生。由具勤修速进道故。生已不久成阿罗汉。尽其寿量方般涅槃。约有余依说为生般。非才生已便般无余。彼舍寿中无自在故。言有行般无行般者。谓有一类补特伽罗。生已多时方成无学。于中有一勇猛精进。有一禀性慢缓懈怠。如次名为有行无行。谓若一类先欲界中依不息加行三摩地力。断五下分结成不还果。后生色界经于多时。还能进修前种类道成阿罗汉。名有行般。无行般者。与此相违。或色界生经多时已。依止苦行解脱余结名有行般。以彼修习依功用道般涅槃故。与此相违名无行般。岂不中般生般现般所依止行。亦有此故。应立有行无行般名。无如是失。此义虽等而彼各有差别位故。谓中般等虽亦定依苦行乐行解脱余结。而彼各有分位不同。对此名为不共差别。此无如是分位别故。约道不同显其差别。如何以此例彼令同。故于此中所辩无失。由此有说。二差别者。由缘有为无为圣道。如其次第得涅槃故。应知亦无。余同此失。然有经说无行在先。亦有经中先说有行。时既无异随说无违。有行可尊故我先说。言上流者。谓有一类补特伽罗。上流有增。非初生处即证圆寂。谓欲界殁往色界生。未即于中能证圆寂。要转生上方般涅槃。即此上流差别有二。由因及果有差别故。因差别者。此于静虑由有杂修无杂修故。果差别者。色究竟天及有顶天为极处故。谓若于静虑有杂修者。能往色究竟方般涅槃。杂修能感净居果故。即此复有三种差别。全超半超遍殁异故。言全超者。谓色界中从一处殁往色究竟。由彼先在欲界身中。已具杂修四种静虑。遇缘退失上三静虑。以初静虑爱味为缘。命终上生梵众天处。由于先世惯习势力。复能杂修第四静虑。从彼处殁生色究竟。以于色界十六处所最初处殁最后处生顿越中间。是全超义。言半超者。谓色界中。从初天等渐次而殁。下至中间能越一处。方能往趣色究竟天。超而非全。是半超义。言遍殁者。谓于色界爱味多故。一切处生。由彼遍于四静虑地十六处所。一一皆有下等爱味为感生缘。从梵众天一一处所一生殁已。至色究竟方般涅槃。故名遍殁。由此义准。初静虑中大梵所居非是别处。即是第二梵辅天摄。若异此者。大梵所居僻见处故。一导师故。必无圣者。于中受生。遍殁半超应无差别。应知此谓二上流中。由有杂修静虑因故。往色究竟般涅槃者。余于静虑无杂修者。能往有顶方般涅槃。谓彼先无杂修静虑。由于诸定爱味为缘。此殁遍生色界诸处。唯不能往五净居天。色界命终于三无色次第生已。后生有顶方般涅槃。二上流中。前是观行。后是止行。乐慧乐定有差别故。二上流者。于下地中得般涅槃。亦不违理。而言此往色究竟天及有顶天。依极处说。无不还者。于已生处受第二生。由彼于生容求胜进非等劣故。唯欲界殁往色界生。有中有中般涅槃者。非色界殁生色界者。以色界中无灾害故。若本有位有余障缘不得涅槃。中有亦尔。中有薄劣非本有故。又彼若有应属上流。中般上流应无差别。谓定无有差别因缘。可作是言。唯欲界殁受色中有便般涅槃。得中般名。非色界殁。何缘有学未离欲贪。无中有中般涅槃者。欲界中有依身微劣。于多事业无堪能故。住本有位于欲界法尚难越度。况中有中能越欲界。至得应果。多事业者。谓越三界。及永断除二种烦恼。并得二三沙门果证。住中有位无如是能。又此有前未曾数习。九品差别烦恼治故。又不还果等。非中有身得。断增上惑所证得故。离三界染极为难故。无欲中有能般涅槃。色界中有与此皆异。故有于中得涅槃者。又此地中有得般涅槃。唯起此地中所有圣道。初静虑地中有位中般涅槃者。唯起自地根本静虑圣道现前。非未至中间。难令现前故。在中有位依身微劣。要易起者。方能现前。此五名为行色界者。行无色者差别有四。谓在欲界离色界贪。从此命终生于无色。此中差别唯有四种。谓生般等有差别故。此并前五成六不还。复有不行色无色界即住于此能般涅槃。名现般涅槃。并前六为七。或应总立九种不还。谓现涅槃分为二种。一于先位善辩圣旨。二临终时方能善辩。于上流内亦分二种。一行色界。二行无色。并前四为八。足转生成九。言转生者。谓于前生已得预流。或一来果。于今生内方得不还。前现般言。唯目现世。初得入圣至涅槃者。或不还者。由根差别。随其所应分成九种。或行色界。五不还中。复有异门。分成九种。颂曰

  行色界有九　　谓三各分三
  业惑根有殊　　故成三九别

论曰。即行色界五种不还。总立为三。各分三种。故成九种。何等为三。中生上流有差别故。云何三种。各分为三。中般涅槃分为三者。初起至远近当生处。得般涅槃有差别故。生般涅槃分为三者。才生有行无行异故。此皆生已得般涅槃。是故并应名为生般。于上流中分为三者。全超半超遍殁异故。然诸三种一切皆由速非速经久得般涅槃故。分为九种。不相杂乱。如是三种九种不还。由业惑根有差别故。有速非速经久差别。且总成三。由先所集顺起生后业有异故。如其次第。下中上品烦恼现行有差别故。及上中下根有异故。此三一一如其所应。亦业惑根有差别故。各有三别。故成九种。谓初二三由惑根别各成三种。非由业异。后三亦由顺后受业有差别故分成三种。故说如是行色不还。业惑根殊成三九别。若尔何故诸契经中佛唯说有七善士趣。颂曰

  立七善士趣　　由上流无别
  善恶行不行　　有往无还故

论曰。中生各三上流为一。经依此立七善士趣。何故前二各分为三。第三上流唯立为一。以上行故名为上流。由此义同但立为一。前之二种虽亦义同。然为其中别相难了。欲令易了故各分三。上流有三相别易了。无烦于彼更别建立。又前二别唯有示所。易显示故各分为三。第三上流别义多种。卒难显示。故总立一。谓初中般唯在将生。根惑品殊故分三种。第二生般唯在已生。亦根惑殊故分三种。上流通有将生已生。将生上流复有二种。谓于静虑杂不杂修。已生上流分二亦尔。复于如是二上流中。若无杂修容生二界。若有杂修唯生一界。生一界者复分为三。全超半超遍没异故。于半超内差别有多。由此上流别相烦广。若一一辩难可周悉。故依等义总立上流。中生位中差别义少。易显了故分之为六。虽彼一一亦有同义。而等第三。于上流中虽有异义。而等前二。为相影显故唯立七。唯此已断欲贪嗔等。非善士法及与无学。大善士果极相近故。经唯说此名善士趣。非谓预流及一来者都不可说名善士趣。佛亦说彼名善士故。如契经言。云何善士。谓若成就有学正见。乃至成就有学正定往上名趣。谓趣上果及趣上生。故唯说七。或唯此七皆能行善不行不善。余则不然。又唯此七往上界生不复还来。余则不尔。故但依此立善士趣。诸在圣位曾经生者。亦有此等差别相耶。不尔云何。颂曰

  经欲界生圣　　不往余界生
  此及往上生　　无练根并退

论曰。若在圣位经欲界生。必不往生色无色界。由彼证得不还果已。定于现身般涅槃故。若于色界经生圣者。容有上生无色界义然天帝释作如是言。曾闻有天名色究竟。我后退落当生彼者。由彼不了对治相故。即此已经欲界生者。及已从此往上界生。诸圣必无练根及退。以曾经生于自相续蕴积圣道极坚牢故。及得殊胜所依身故。前说上流杂修静虑为因能往色究竟天。先应杂修。何等静虑由何等位知杂修成。复为何缘杂修静虑。颂曰

  先杂修第四　　成由一念杂
  为受生现乐　　及遮烦恼退

论曰。诸欲杂修四静虑者。必先杂修第四静虑。以彼等持最堪能故。诸乐行中彼最胜故。谁于静虑能杂熏修。唯诸圣者通学无学。学位唯通信解见至。于无学位通时非时。必先三洲杂修静虑。退生色界亦能杂修。退已练根成见至姓。从欲界没生色界中乘前复能杂修静虑。故六种姓皆有上流。于杂修时作何方便。彼必先入第四静虑。多念无漏相续现前。从此引生多念有漏。后复多念无漏现前。如是旋环后后渐减。乃至最后二念无漏。次引二念有漏现前。无间复生二念无漏。名杂修定。加行成满。从此以后不由功力。任运唯从一念无漏。引起一念有漏现前。无间复生一念无漏。如是有漏中间刹那。前后刹那无漏杂故。名杂修定根本圆成。如是杂修第四定已。乘此势力随其所应。亦能杂修下三静虑。杂修静虑五蕴为体。然于此中诸世俗智。是四法四类八智所杂修。略有三缘杂修静虑。一为受生。二为现乐。三为遮止。起烦恼退。诸不还中。若见至姓为前二缘。若信解性具为三缘。阿罗汉中。不时解脱但为现乐。时解脱者为后二缘。若杂修静虑为生五净居。何缘净居处唯有五。颂曰

  由杂修五品　　生有五净居

论曰。由杂熏修第四静虑有五品故。净居唯五。何谓五品。谓下中上上胜上极。品差别故。此中初品。三心现前便得成满。谓初无漏。次起有漏。后起无漏。第二中品。六心现前方得成满。谓二有漏。为四无漏之所杂修。如是所余随其次第有九十二十五念心。如应现前方得成满。如是五品杂修为因。如次能招五净居果。如是十五有漏无漏心。皆是先来未曾得今得。有余师说。初五无漏是从先来未得今得。余十皆是曾所得心。前五现前时已未来修故。有不起定。杂修成满。有要数起。方得圆成。有余师言。由信等五次第增上感五净居。诸感净居由杂修力。亦由业力相资助故。然唯有漏感彼异熟。非无漏力弃背有故。经说不还有名身证。依何胜德而立此名。颂曰

  得灭定不还　　转名为身证

论曰。有灭定得。名得灭定。即不还者。若于身中有灭定得。转名身证。谓不还者。由身证得似涅槃法。故名身证。如何说彼但名身证。以无心故。依身生故。以身俱生得势力故。彼已灭位犹名得彼。何缘佛说有学福田。身证不还不预其数。谓世尊告给孤独言。长者当知。福田有二。一者有学。二者无学。有学十八。无学唯九。何等名为十八有学。谓预流向果。一来向果。不还向果。阿罗汉向。随信法行。信解见至。家家一间。中生有行无行上流。是名十八。何等名为九种无学。谓退思护安住堪达不动不退慧俱解脱。是名为九。理亦应说。而不说者。以佛观见有学无学。由断及根有殊胜故。能生胜果名为福田。然诸不还所得灭定。是有漏故。不可说言。自性解脱。故名清净。彼所依身。犹有烦恼。未永断故。不可说言。相续解脱。故名清净。故不约成彼立有学福田。无学位中有漏功德。虽非自性解脱所收。相续解脱故名清净。由此亦能生殊胜果。是故约定及根差别。说九应果皆名福田。已辩不还粗相差别。若细分析数成多千。此中且依行色界五。约诸地等五门分别。谓五约地数成二十。四定地中各五种故。五约种姓数成三十。六种姓中各五种故。五约生处数成八十。十六处中各五种故。五约种姓根数成九十。谓退法种姓下中上根有差别故。数成十五。乃至不动种姓亦然。五约地种姓数成百二十。谓四地中各三十故。五约地种姓根数成三百六十。谓四地中各九十故。五约生处种姓数成四百八十。谓十六处各三十故。五约生处种姓及根数成一千四百四十。谓十六处各九十故。五约离染处种姓根。积数总成一万二千九百六十不还差别。谓以离染九品不同。乘前一千四百四十

说一切有部显宗论卷第三十一阿毗达磨藏显宗论卷第三十二

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩贤圣品第七之四

已辩第三向果差别。次应建立第四向果。颂曰

  上界修惑中　　断初定一品
  至有顶八品　　皆阿罗汉向
  第九无间道　　名金刚喻定
  尽得俱尽智　　成无学应果

论曰。即不还者。进断色界及无色界修所断惑。从断初定一品为初。至断有顶八品为后。应知转名阿罗汉向。即此所说阿罗汉向中。断有顶惑第九无间道。亦说名为金刚喻定。此定坚锐喻若金刚。无一随眠不能破故。先已破故。不破一切。实有能破。一切功能。虽见道中亦有能断。有顶烦恼无漏对治。而见断惑可为一品。顿断九品势力劣故。又无事惑易可断故。能治不立金刚喻名。此中所明金刚喻定。能治一切有事惑中最后微微极难断品。故知能破一切随眠。由此力能一刹那顷。证一切惑断。无漏离系得。如是所说金刚喻定。唯与六智随一相应。谓四类智灭道法智。缘四圣谛十六行相。通依九地。义准已成。故此差别说有多种。且未至摄有五十二。谓苦集类智观有顶苦集作非常等因等行相。与彼相应差别成八。灭道法智观欲灭道作灭静等道等行相。与彼相应差别亦八。灭类智于八地灭一一别观作四行相。与彼相应成三十二。道类智于八地道。一切总观作四行相。与彼相应差别成四。以治八地类智品道。同类相因。必总缘故。灭唯别缘。道则不尔。于随眠品已具成立。如未至摄有五十二。中四静虑。应知亦然。空无边处有二十八。谓除灭道法智品八。及除观下四地灭谛。各四行相。相应十六。以依无色必无法智。及缘下灭类智品故。缘下地道于理无遮。道必总缘前已释故。余如前故有二十八。识无边处有二十四。无所有处唯有二十。谓彼于前复除观下灭圣谛境四八行相。随其次第准前应释。诸有欲令三无色地。有缘下地灭类智者。彼作是说。空无边处加前十六。识无边处加前二十。无所有处加二十四。如是总说。依无色地金刚喻定七十二种或复说有百三十二。有余师说。道类智品于八地道亦各别观。故前六地各有八十。空无边处唯有四十。识无边处有三十二。无所有处有二十四。复有欲令灭类智品。于八地灭有别总观。故前六地中各百六十四。空无边处唯五十二。识无边处有三十六。无所有处有二十四。彼俱非理。道必总缘。灭唯别缘。因有无故。尊者妙音作如是说。金刚喻定总有十三。谓断有顶见修断惑无间道摄十三刹那。此亦不然。以四类忍前八无间道非极上品故。此定既能断有顶地第九品惑。能引此惑尽得俱行。尽智令起金刚喻定。是断惑中最后无间道所生尽智。是断惑中最后解脱道故。说此定所引生智与第九品尽得俱起。或此尽言显一切尽。谓第九品及所余惑。皆得择灭。故名为尽。金刚喻定能引诸惑。尽得俱行尽智令起。此与一切烦恼尽得。最初俱生故名尽智。有余师说。惑尽身中此最初生。故名尽智。如是尽智至已生时。便成无学阿罗汉果。已得无学应果法故。为得别果所应修学。此无有故得无学名。岂不无学亦希别果。以无学者亦转根故。此难不然。如先有学求得别果。此不然故。既说尽智至已生时便成无学阿罗汉果。义准尽智未已生时。前七圣者皆名有学。为得别果勤修学故。住本性位。何名有学。学意未满故。学得常随故。何故无学名阿罗汉。诸自利行修学已成。唯应作他利益事故。如契经说。不自调伏能调伏他。无有是处。或是一切有学异生。所应供养故名应果。学法云何。谓有学者。无漏有为法。无学法云何。谓无学者。无漏有为法。诸无为法虽是无漏。而不名为学无学法。以有得者异生等身亦成就故。若无得者都不系属学无学故。如是有学及无学者。总成八圣补特伽罗。行向住果各有四故。名虽有八事唯有五。谓住四果及初果向。以后三果向不离前果故。此依渐次得果者说。若倍离欲全离欲者。住见道中名为一来。不还果向。非前果摄。修道即通有漏无漏。何道能离何地染耶。二道现前离诸地染。各引几种离系得耶。颂曰

  有顶由无漏　　余由二离染
  圣二离八修　　各二离系得

论曰。有顶地中所有烦恼。唯无漏道能令永离。此于有漏势力增强。自上地等皆能治故。唯于次上近分地中。起世俗道。能治下惑。有顶地惑。既无上地。故无有漏。能离彼染。诸世俗道。不治自惑。是自随眠。所随增故。不治上惑。势力劣故余八地中所有烦恼。通由二道能令永离。皆有上边世俗道故。皆有自下无漏道故。圣用有漏无漏二道。离下八地修所断时。各具引生二离系得。有漏无漏二种断道。于八地中所作同故。由此有学离八修断。世出世道随一现前。各未来修世出世道。此总相说。以无漏道离上七地前八品时。不修上边。世俗道故。唯有无漏一离系得。离第九品。方可具二。或应许得离道而修。或应断染时许依下修上。既说圣者。二离八修。各能引生。二离系得。准知圣者。离有顶修及见断时。用无漏道唯引无漏。离系得生亦不未来。修世俗道与世俗道。不同事故。异生离八。用有漏道唯引有漏。离系得生亦不未来。修无漏道未入圣故。不说自成。有余师言。以无漏道离下八地修断染时。何缘知亦生有漏离系得有舍无漏得烦恼不成故。谓有学圣。以无漏道离彼染时。若不引生同治有漏离系得者。则以圣道具离八地。后依静虑得转根时。顿舍先来诸钝圣道。唯得静虑利果圣道。上惑离系应皆不成。是则还应成彼烦恼。然非所许。故具二得。此证不然。不决定故。如分离有顶得转根时。及异生上生不成惑故。此二虽无烦恼断得。而胜进故遮惑得生。彼亦应然。故证非理。由此但可作如是言。二道于中所作同故。随一现起引二得生。不可说言为成断故。已辩离染由道不同。今次应辩由地差别。由何地道离何地染。颂曰

  无漏未至道　　能离一切地
  余八离自上　　有漏离次下

论曰。诸无漏道通依九地。谓四静虑未至中间及三无色。若未至摄能离欲界。乃至有顶余八地摄。随其所应各能离自及上地染。不能离下。未离下时上道必无现在前故。诸有漏道一切唯能离次下地。非自地等自地烦恼所随增故。势力劣故。先已离故。诸依近分离下地染。如无间道皆近分摄。诸解脱道亦近分耶。不定云何。颂曰

  近分离下染　　初三后解脱
  根本或近分　　上地唯根本

论曰。诸道所依近分有八。谓四静虑无色下边所离有九。谓欲八定初三近分离下三染。第九解脱现在前时。或入根本。或即近分。上五近分各离下染。第九解脱现在前时。必入根本。非即近分。近分根本等舍根故。下三静虑近分根本受根异故。有不能入。转入异受。少艰难故。离下染时必欣上故。若受无异必入根本。诸出世道无间解脱。前既已说缘四谛境十六行相。义准自成。世道缘何作何行相。颂曰

  世无间解脱　　如次缘下上
  作粗苦障行　　及静妙离三

论曰。世俗无间及解脱道。如次能缘下地上地。为粗苦障及静妙离。谓诸无间道缘自次下地诸有漏法作粗苦等。三行相中随一行相。若诸解脱道缘彼次上地诸有漏法作静妙等。三行相中随一行相。约容有说二道各三。非诸有情于离染位。无间解脱皆各具三。诸下地中由多掉举。寂静微劣故名为粗。虽大劬劳暂令掉举势用微劣。仍不能引美妙乐生故名为苦。有极多种灾害拘碍。及能覆障令无功能。见出离方故名为障。诸上地中不作功用。掉举微劣故名为静。不设劬劳掉举微劣。引生胜乐故名为妙于下地中所有灾害。能决定见心不生欣。及能趣彼故名为离。应知此中已兼显示无间解脱。行相各三。相翻而生。如其次第。谓无间道缘下为粗。解脱道中缘上为静。余相翻起如次应知。然离染时起则不定。世俗无间及解脱道。能离下等九品染故。应知亦有九品差别此中异生。离欲界染九无间道。粗等三行随一现前。各未来修粗等三行。八解脱道静等三行。随一现前各未来修。粗等六行后解脱道。现在未来所修如前。八解脱道与前别者。复修未来。初静虑摄。无边行相。如是乃至离无所有染。无间解脱道所修应知。若诸圣者。以世俗道。离欲界染九无间道。粗等三行随一现前。各于未来修十九行。谓粗等三有漏无漏。十六圣行八解脱道。静等三行随一现前。各未来修二十二行。谓前十九加静等三。后解脱道现在未来。所修如前。八解脱道与前别者。复修未来初静虑摄。无边行相离初定染。九无间道粗等三行。随一现前各于未来。修十九行。谓粗等三及唯无漏十六圣行。此十六行是下地摄。以上地边无圣行故。后修圣行准此应知。八解脱道静等三行。随一现前各未来修二十二行。谓前十九加静等三。后解脱道现在未来。所修如前八解脱道。与前别者。复修未来二静虑摄。无边行相。如是乃至离无所有染。无间解脱道所修应知。有余师言。异生圣者。离欲无间解脱道中。亦修不净息念慈等。离余上地所修如前。初静虑边善根广故。修如是行上诸定边。善根少故。所修如前。又欲界中有多烦恼。为欲断彼修多对治。上地不然故修治少。离欲界染九无间道。未来所修粗等三行。唯缘欲界八解脱道。未来所修粗等三行。通缘欲界及初静虑静等三行缘初静虑。后解脱道未来所修。粗等三行通缘三界。静等三行缘初静虑乃至有顶。离初定染。九无间道。未来所修。粗等三行。缘初静虑。八解脱道。未来所修。粗等三行缘初二定。静等三行缘第二定。后解脱道。未来所修。粗等三行。通缘三界。静等三行缘第二定乃至有顶。离二静虑三静虑染。随其所应皆准前说。离四定染九无间道。未来所修粗等三行。缘第四定八解脱道。未来所修粗等三行。缘第四定及缘空处。然非一念。以界别故。静等三行唯缘空处。后解脱道。未来所修。粗等三行。静等三行皆缘空处乃至有顶。离空处染。九无间道。未来所修。粗等三行唯缘空处。八解脱道。未来所修。粗等三行缘空识处。静等三行唯缘识处。后解脱道。未来所修。粗等三行。静等三行。俱缘识处乃至有顶。离识处染。无所有染。随其所应皆准前说。何缘最后。解脱道中。未来所修。粗等三行。静虑摄者。通缘三界。无色摄者。唯自上缘。诸静虑中。有遍缘智。无色根本。必不下缘。故二所修所缘有别。傍论已了。应辩本义。本说诸位善根相生。前既。已说金刚喻定。无间必有尽智续生。尽智无间有何智起。颂曰

  不动尽智后　　必起无生智
  余尽或正见　　此应果皆有

论曰。先不动法诸阿罗汉。尽智无间无生智起。此智是彼本所求故。必与尽智俱时而得。谓彼求得顺记所解。若无便有入涅槃障。诸阿罗汉共得智时。即亦志求得无生智。然其尽智理应先起。是因位中先所求故。先不动法金刚定后得无生智而未现前尽智无间方得现起。除先不动余阿罗汉。尽智无间有尽智生。或即引生无学正见。非无生智。后容退故。谓若先是时解脱性。虽于因位双求二种。而至极果容有退故。金刚喻定正灭位中。不得无生唯得尽智。故尽智后尽智现前。或即引生无学正见。先不动法无生智后。有无生智起。或无学正见。此无学见一切应果之所共有。犹如尽智。故金刚定正灭位中。一切皆得无学正见。然此正见非正所求。故尽无生二智无间。或有即起。或未现前。于此位中总略义者。若先不动。初起尽智。唯一刹那。次无生智。亦一刹那。或有相续。若时解脱。初起尽智或一刹那。或有相续。此二所起无学正见。皆无决定刹那相续。如前说彼。非正求故。如说沙门及沙门果。何谓沙门性。此果体是何。果位差别总有几种。颂曰

  净道沙门性　　有为无为果
  此有八十九　　解脱道及灭

论曰。言沙门者。能永息除诸界。趣生生死魑魅或能勤励息诸过失令永寂静。故名沙门。如薄伽梵自作是释。以能勤劳息除种种。恶不善法离染过失。广说乃至。故名沙门。沙门所有名沙门性。此即沙门所修熏法。熏是排遣生臭惑义。即以无漏圣道为体。非世俗道。以能无余究竟静息诸过失故。由此异生。虽能已断无所有处染而非真沙门。以诸过失尚有余故。暂时静息。非究竟故。既无漏道。是沙门性。通以有为无为为果。故沙门果体通有为无为。此果佛说总有四种。谓初预流后阿罗汉。道类智品。是谓有为。预流果体。见断法断。是谓无为预流果体。道类智品。或离欲界。第六无漏解脱道品。是谓有为。一来果体。见断法断。及欲界系修所断中。前六品断是谓无为。一来果体。道类智品。或离欲界第九无漏解脱道品。是谓有为。不还果体。见断法断。欲修断断。是谓无为。不还果体。尽智无生智。无学正见品。是谓有为。阿罗汉果体。三界见修所断法断。是谓无为。阿罗汉果体。然薄伽梵。于契经中。但说无为沙门体。果如说云何名预流果。谓断三结。乃至云何阿罗汉果。谓已永断贪嗔痴等。应知断言兼前断说。何缘于彼但说无为。以此无为唯是果故。谓诸择灭唯沙门果。道通沙门。故略不说。或以无为法是果非有果。道通二种。故略不说。或无为法离有为过。为令欣乐。是故偏说。或此唯说无为果经。是有余言。不应封执谓此唯说三结断等。不遍说余烦恼断故。如契经说。心速回转精进能证无上菩提。超段食想越诸色想。没有对想。非余不然。应知此经亦复如是。如由别意唯说无为为沙门果。亦由别意说沙门果。唯有四种。若废别意直论法相。即沙门果有八十九。皆解脱道。择灭为性。谓为永断三界烦恼。有八十九。无间道起。见道所摄。其数有八。法类智忍。各有四故。修道所摄有八十一。九地各九无间道故。此八十九唯沙门性。此沙门性无间所生。八十九解脱道。亦有为沙门果。是彼等流士用果故。即诸无间所断惑断。八十九诸择灭唯无为沙门果。是彼离系士用果故。彼能断此得障得故。岂不沙门性亦摄解脱道诸无间道。亦彼等流士用果故。应无间道亦是有为沙门果摄。不尔且非诸无间道一切皆是解脱道果。虽有是者而但可言。无间道力解脱道起。彼力能断此起障故。彼道无间此必生故。非解脱道力引无间道起。此不能断彼障故。非此无间彼必生故。谓虽亦有无间而生。而不皆然。及非此力。谓有余时。余加行力所引起故。或有毕竟不复生故。无相类失。何故契经说沙门果非八十九唯说四耶。岂不已言。经有别意。有何别意。且有释言。唯四位中诸观行者。分明欢悦觉慧生故。谓唯四位极可信非余设有退失未死还得故。有余复言。唯此四位如次能越恶趣。彼因人天趣生所显示故。唯上中品贪等势力。往恶趣生。非下品故。或有本有二。谓欲界有顶。二越有顶。二越欲界。故唯立四为沙门果。或诸烦恼总有二类。一者无记。二者不善。初越二种。后越无记。一来不还唯越不善。以恶难越。故唯立四。有余师言。非薄伽梵于八十九不现证知。然唯说四沙门果者。颂曰

  五因立四果　　舍曾得胜道
  集断得八智　　顿修十六行

论曰。若断道位具足五因。佛于经中建立彼断。及与断得俱时而生。净解脱道为沙门果。言五因者。一舍曾道。谓舍先得果向道故。二得胜道。谓得果摄殊胜道故。三总集断。谓一果得总得先来所得断故。四得八智。谓一时中总得四法四类智故。五能顿修十六行相。谓能顿修非常等故。住四果位皆具五因。余位不然。故唯说四。若唯净道是沙门性。有漏道力所得二果。如何亦是沙门果摄。颂曰

  世道所得断　　圣所得杂故
  无漏得持故　　亦名沙门果

论曰。且无漏道。所得择灭。沙门果摄。其理极成。得二果时。诸世俗道所得择灭。体数甚少。与多圣道所得择灭。总一得得共成一果。是故于此以少从多。俱说名为沙门果体。谓世俗道得二果时。此果非唯以世俗道所得择灭为断果性。兼以见道所得择灭。于中相杂总成一果。同一果道得所得故。由此契经言。云何一来果。谓断三结薄贪嗔痴。云何不还果。谓断五下结故。世俗道所得择灭。与无漏道所得杂故。以少从多名沙门果。又世俗道所得择灭。无漏断得所任持故。由此力所持退不命终故。无漏断得印所印故。亦得名为沙门果体。如故人物王印所印。不复名为能集者物。此亦应尔。故亦名沙门果。有余师说。此灭当为金刚喻定。真沙门果。故亦得立沙门果名。此灭虽非彼离系果。是彼士用果名彼果无失。有余复说。由此无为因沙门性增上力得。是故亦应名沙门果。以世俗道断烦恼时。亦修治彼沙门性故。如是已说。依世俗道断修所断得二果时。所得择灭名沙门果。然沙门果酬沙门性。此沙门性如前已说。即此复有差别名耶。亦有云何。颂曰

  所说沙门性　　亦名婆罗门
  亦名为梵轮　　真梵所转故
  于中唯见道　　说名为法轮
  由速等似轮　　或具辐等故

论曰。依世俗理。则诸沙门异婆罗门。如契经说。应施沙门婆罗门等。依胜义理。则诸沙门即婆罗门。如契经说。此初沙门乃至第四。在正法外无真沙门及婆罗门。乃至广说。以能遣除恶不善法。与勤止息相极相似。故沙门体即婆罗门。如说能遣除恶不善法。广说乃至。故名婆罗门。即婆罗门性亦名为梵轮。是真梵王力所转故。佛与无上梵德相应。是故世尊独应名梵。由契经说。佛亦名梵。亦名寂静。亦名清凉。寂默冲虚萧然名梵。佛具此德。故立梵名。既自觉悟为令他觉。转此授彼故名梵轮。即梵轮中唯依见道。世尊有处说名法轮。以阿若多憍陈那等五苾刍众见道生时。地空天神即传宣告。世尊已转正法轮故。如何见道说名为轮。以速行等似世轮故。如圣王轮旋环不息。速行舍取能伏未伏。镇压已伏上下回转。见道亦尔。故名法轮。谓圣王轮旋环不息。见道亦尔。无中歇故。如圣王轮行用速疾。见道亦尔。各一念故。如圣王轮取前舍后。见道亦尔。舍苦等境取集等故。此则显示见四圣谛必不俱时。如圣王轮降伏未伏镇压已伏。见道亦尔。能见未见能断未断。已见断者无速退故。如圣王轮上下回转。见道亦尔。观上苦等已观下苦等故。由此见道独名法轮。尊者妙音作如是说。如世间轮有辐毂辋。八支圣道似彼名轮。谓正见正思惟正勤正念似世轮辐。正语正业正命似毂。正定似辋。故名法轮。毗婆沙师本意总说一切圣道皆名法轮。以说三转三道摄故。于他相续见道生时。已至转初故名已转。然唯见道是法轮初。故说法轮。唯是见道。诸天神类。即就最初。言转法轮。不依二道。然诸师多说见道名法轮。以地空天神唯依此说故。曾无说三道皆名法轮故。唯见道具前所说轮义故。虽诸见道皆名法轮。而憍陈那身中先转故。经说彼见道生时名转法轮。非余不转。憍陈那等见道生时。说名世尊转法轮者。意显彼等得转法轮本由世尊。故推在佛。令所化者生尊重故。如是即说如来法轮。转至他身故名为转。若异此者。天神应说菩提树下佛转法轮。不应唱言。世尊今在婆罗痆斯国转无上法轮。故转授他。此中名转。有说此教名为法轮。转至他身令解义故。此但方便非真法轮。如余杂染无胜能故。此中思释四沙门果。何沙门果依何界得。颂曰

  三依欲后三　　由上无见道
  无闻无缘下　　无厌及经故

论曰。前三果但依欲界身。得后阿罗汉果依三界身。前之二果未离欲故。非依上得。理且可然。第三云何非依上得。已离欲者。亦可得故。由理教故。且理云何。依上界身。无见道故。非离见道。已离欲者。可有超证。不还果义。何缘上界身必不起见道。且依无色无容听闻无我教故。离闻此教。必定无容入见道故。又彼界生不缘下故。见道先缘欲界苦故。由此无色非见道依。依色界身无胜厌故。非离胜厌能入见道。谓欲界中有诸苦受。为生少乐多藉劬劳。人天中生寿量短促。乏财多病。亲友乖离。违境既多。厌心增胜。若生色界。与此相违。谓彼异生耽胜定乐。长寿无病无贫无离。违境既无。厌心微劣。非厌微劣。能入见道。能引见道。胜厌无故。依色界身不起见道。不应言彼都无有厌。以生彼者。现有厌故。如契经说。勿怖大仙。彼焰必无来近此理。烧梵宫已于彼当灭。此中怖声唯目厌体。又于余处有伽他曰

  闻诸长寿天　　具妙色令誉
  而心怀怖厌　　如鹿对师子

此怖厌言。显怖即厌。实怖与厌。相差别者。谓瞩彼相恐为衰损。心生惊怯故名为怖。若观彼相心不欣欲。情乐弃舍故名为厌。欲界具二。上界唯一。又此二体差别云何。不审察为先心惊掉名怖。若审察为先心不乐名厌。或引愚痴心怯名怖。若引弃舍心背名厌。有余师说。恐为衰损心欲损舍是名为怖。欲损舍故于彼境中心不生欣。是名为厌。此经怖言。是恐坏义。如说掷来勿怖其破。由此理证上界无见道教复云何。由契经说故。经言有五补特伽罗。此处通达。彼处究竟。所谓中般乃至上流。此通达言。唯目见道是证圆寂。初加行故。经既不言彼处通达。故知见道上界定无

说一切有部显宗论卷第三十二阿毗达磨藏显宗论卷第三十三

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩贤圣品第七之五

已说学位预流果等有多差别。为阿罗汉亦有多种差别相耶。亦有云何。颂曰

  阿罗汉有六　　谓退至不动
  前五信解生　　总名时解脱
  后不时解脱　　从前见至生

论曰。于契经中说阿罗汉。由种性异故有住种。一者退法。二者思法。三者护法。四安住法。五堪达法。六不动法。然余经说无学有九。谓初退法。后俱解脱。彼不退法此不动摄。彼二解脱通此六摄。故阿毗达磨唯说有六种。言退法者。谓彼获得如是类根。安住此根。与退缘会。便退所得。无退缘者。便般涅槃。或有精勤进得胜性。遇缘多退故名退法。言思法者。谓有获得。如是类根。安住此根。念力坚固。多住厌观。恐失胜德。为自励心。多思害己。故名思法。言护法者。谓有一类。恒于时爱心解脱中系念现前。专精防护不放逸住。故名护法。安住法者。谓离胜退缘。虽不自防。而亦能不退。离胜加行。亦不练根。多住处中。故名安住。堪达法者。谓性堪能好修练根。速达不动能亲证利。故名堪达。不动法者。谓有一类。根性殊胜志不怯弱。所获功德遇胜退缘亦必不退。故名不动。有余复释此六异相。谓六种性先学位中。初二阙恒时及尊重加行。然至无学。思法小勤。护法唯有恒时加行。安住唯有尊重加行。堪达具二而是钝根。不动具二而是利根。有作是言。退法必退。乃至堪达必达不动。若不尔者立名唐损。彼执欲界具足有六。色无色界中唯安住不动。彼无退失。自害自防及修练根。故唯有二。理实无定。然退应果。唯从先来退种性退。乃至得不动唯堪达。所能立退等名。约容有说故。六阿罗汉通三界皆有。六中前五从信解生。即此总名时爱心解脱。以一切时爱心解脱故。亦说名为时解脱者。谓待时处补特伽罗。资具等合时方得解脱故。以所依止功能薄劣。要待胜时。方解脱故。或复一切胜定现前。要待胜时。是此时义。离系缚故名为解脱。此即待时及解脱义。略初言故。如言酥瓶。不动法性。说名为后。即此名为不动心解脱。彼心解脱非惑所动故。亦说名为不时解脱。以不待时得解脱故。或复胜定随处随时随所遇缘随欲便起离系缚故名为解脱。即不待时及解脱义。有余释此二差别言。以于暂时得解脱故。名时解脱。后容退故。以能毕竟得解脱故。名不时解脱。后无容退故。此从前位见至性生。如是所明六阿罗汉所有种性。为是先有。为后方得。不定云何。颂曰

  有是先种性　　有后练根得

论曰。退法种性必是先有。思法等五亦有后得。谓有先来是思法性。乃至不动有先退法。练根成思至不动等。多种差别如理应思。如是六种阿罗汉中。唯前五种容有退义。谁从何退为性为果。颂曰

  四从种性退　　五从果非先

论曰。不动种性必无退理。故唯前五容有退义。于中后四有退种性。退法一种无退性理。由此种性最居下故。五种皆有从果退理。虽俱有退然并非先。谓无学位中从退法种性。修练根行转成思等。此四皆有退性果义。退法种性。虽必先得而是退法。故容退果。诸学位中从退法性。修练根行转成思等。及得学果皆容退失。诸无学者。先学位中所住种性。彼从此性必无退理。学无学道所成坚故。诸有学者。先凡位中所住种性。彼从此性亦无退理。世出世道所成坚故。二先位中住思等性必无有退。此所得果。此性二道所成坚故。彼从思等。修练根行转得护等。虽可退性转所得性。进得学果亦有退义。由此种性。非二道成。不坚牢故。若就四果辩退果义。虽五种性皆可退果。而先所得必无有退。谓四果中。先所得者。即预流等。前三随一。从此先果必无退义。是断见惑所得果故。圣断见惑必无退故。何缘见惑圣断无退。以彼不缘所执事故。谓见所断烦恼现行。无不皆由我见势力。以彼烦恼起我见为根故。由此见惑不缘所执。以所执事都无体故。然有所缘谛为境故。彼所执事都无种子。于所缘境极乖违故。圣者相续。真无我解恒所随故。虽暂失念而必无容重执有我。以见所断依我事生。故圣断已必无退义。修所断惑虽颠倒转。而非无种有所执事。谓于色等染着憎背。高举不了行相转时。于色等中非无少分。净妙怨害高下甚深。故非境中极乖违转。由此圣者有时失念。执净妙等相退起修断惑。又见断惑迷于谛理。执我等相。谛理中无。理定可依。圣见无退。修所断惑迷粗事生。事变难依。有失念退。又见断惑要审虑生。圣审虑时必不起惑。修所断惑非审虑生。圣失念时容有退义。由此无退。先所得果。此中无学退法有三。一增进根。二退住学。三住自位而般涅槃。思法有四。三如前说。更加一种退住退性。余三如次有五六七。应知后后一一增故。何缘练根成思等者。退彼应果住学位时。住先退性非所退者。得思等道今已舍故。岂不学位转成思等。得应果时。虽舍所得。学思等道。而住应果。思等种性。此亦应然。此例不齐。以彼学道摄彼无学道为等流果故。非无学位所舍思等。与此学道为同类因。可能引学思等种性。故应退住先所舍者。有余于此别立证因。谓若退住。所退种性。得胜种性。故应是进非退此非证因。若无二义可有是进。非退过故。然得胜性虽可名进而起惑故亦名为退。由此彼难于理无失。又彼退起障涅槃法。圣欣涅槃过于圣道。设得胜性退涅槃故。但应名退不应名进。复以何缘诸阿罗汉等。离有顶染同不受后生。然于其中有于烦恼。证不生法而非一切。有说由根有差别故。此释非理。以契经说。退不退法根品同故。如说五根增上猛利。极圆满故名俱解脱。然有俱解脱是退种性故。非根胜故。证惑不生。若尔由何种性别故。六种种性。唯应果有余亦有耶。修习练根唯无学位。余位亦有。颂曰

  学异生亦六　　练根非见道

论曰。有学异生种性亦六。六种应果彼为先故。由所安住种性差别。故有断惑。后生不生。定于何时于所断惑证不生法。谓得能止此类烦恼殊胜道时。若尔此不生应是择灭非非择灭。若是非择灭则非择灭应是道果。如是便与圣教相违。如说云何非果法。谓非择灭及虚空无。此不生成择灭失。以胜道转非为此故。既非所为故非道果。今详由道所证不生。定不由根。皆应得故。但由殊胜种性力得。故不动者。惑必不生。非唯无学有增进根。有学异生亦有此义。唯非见道能修练根。此位无容起加行故。谓见道位速疾运转。无暇于中更修余事。唯于信解异生位中。能修练根如无学位。如说不动退现法乐。如何不动法。亦许有退义。无相违过。所以者何。颂曰

  应知退有三　　已未得受用
  佛唯有最后　　利中后钝三

论曰。应知诸退总有三种。一已得退。谓退已得殊胜功德。二未得退。谓未能得应得功德。三受用退。谓诸已得殊胜功德不现在前。三中前二非得为体。第三唯彼不现在前。此三退中世尊唯有一受用退。以有决定所作事业牵引其心。虽有所余无量希有不共佛法。无暇起故。除佛世尊余不动法。具有未得及受用退。谓于殊胜无诤定等应得功德。未能得故有未得退。有余事业牵引其心。已得功德无暇起故。有受用退。余五种性容具有三。亦容退失已得德故。约受用退说不动法。退现法乐无相违过。诸阿罗汉既许退果。为更生不。彼于退位带惑命终应更受生。诸住果时所不作事。退时作不。彼既起惑。应有更为果相违事。无如是过。所以者何。颂曰

  一切从果退　　必得不命终
  住果所不为　　惭增故不作

论曰。无从果退中间命终。退已须臾必还得故。若有寿量将临尽者。必无退理。无失念故。要有余寿方有退理。退已不久必还证得。如契经说。苾刍当知。如是多闻诸圣弟子。迟失正念。速复还能令所退起。尽没灭离。若谓不然。修梵行果。应非安隐。可委信处。又住果位所不应为。违果事业由惭增故。虽暂失念烦恼现行。如住果时必无作理。如高族者暂失位时。不等凡庸造鄙下业。又谁有退谁无退耶。修不净观入圣道者。容有退失。修持息念入圣道者。必无退失。尊重止观无贪痴增。如次应知有退无退。何界何趣容有退耶。唯欲界人。三洲有退。六欲天处得圣果者。有说利根故无有退。以有胜智能制伏心。令背妙境入圣道故。有说退者由阙资缘。或所依身不平等故。六欲天处二事并无。虽有钝根随信行性。生彼得圣亦无退理。诸有退者。为起惑退。为先退已惑方现前。或有欲令由起惑退。品类足论当云何通。如彼论说。欲贪随眠由三处起。一欲贪随眠未断遍知故。二顺彼缠法正现在前故。三于彼正起非理作意故。乃至广说无相违失。所以者何。烦恼现前略有二种。已断未断有差别故。此中偏说未断起者。又烦恼起略有二门。染不染心无间起故。此中偏说染无间者。或烦恼起总有三缘。然烦恼生所藉不定。或有唯藉境界力生或藉境因。或兼加行。此约具者。故说由三。或起惑时三缘必具。非理作意正起现前。所断随眠必还成故。何心无间起惑退耶。且从无学起惑退者。若起色缠无色缠退。唯从自地顺退分定。相应善心无间而起。非住欲界有上地摄。无覆无记心现在前。唯除通果心。然无从彼退。岂不顺退分。各于自地离染时舍。如何无学者未退起惑。彼心现前理实如是。然顺住分品类有三。一少顺退。二少顺进。三守自位。前言自地顺退分定。即顺住分中少分顺退者。少顺退故得顺退名。然此定心与守自位多相涉故。顺住分摄。诸有未失顺退分者。彼心无间烦恼现前。若舍彼心从顺住摄。少顺退者起烦恼退。故于文义无所相违。若起欲缠而退失者。从自地善无覆无记。二心无间皆容现前。诸从学位起惑退者。起色无色烦恼退时。若先全离此地染者。唯从此地顺退分定相应善心无间而起。若未全离此地染者。从此地摄善及染污二心无间皆容现前。起欲界缠而退失者。若先全离欲界系染。从自地善无覆无记二心无间皆容现前。若未全离欲界染者。从欲善染无覆无记三心无间皆容现前。若未现前获得清净。静虑无色必无能起。色无色缠退失所得。彼惑从彼无间起故。但起欲缠退失所得。若现前得清净静虑。犹未现前得净无色。必无能起无色缠退。起欲色缠退失所得。若已现前获得清净静虑无色。通起欲色无色界缠退失所得。诸有退失先所得时。若起上缠。现在前退。不失下善。不成下惑。若起下缠现在前退。定失上善。定成上惑。复有欲令要先退已。后时对境惑方现前。施设足论当云何释。如彼论说。无色三缠。一一现起退无色尽住色尽中。识身足论复云何释。如彼论说。无色界系染心现前。舍无学善续有学善。退无学心住有学心。此俱不相违。依觉时说故。谓先虽退而未觉知。后起惑时方自觉退。如有先诵四阿笈摩。中废多时虽忘不觉。后诵不得。方自知忘。此亦应然。故无违失。住何心退后起惑耶。住欲界中。无覆无记。威仪工巧。异熟生心。退已后时方能起惑。然此欲界系无覆无记心。或有总违三界烦恼。此心正起无有退得三界惑义。或有但违欲色烦恼。此心正起容有退得无色惑义。或有但违欲界烦恼。此心正起容有退得三界惑义。或有不违三界烦恼。此心正起容有退得三界惑义。一切退已。随其所应起惑前心。皆如上说。于此二说。前说为善。如上所言。有练根得今应思择。诸圣练根有几无间几解脱道。用有漏道为无漏耶。依何身依何地。颂曰

  练根无学位　　九无间解脱
  久习故学一　　无漏依人三
  无学依九地　　有学但依六
  舍果胜果道　　唯得果道故

论曰。求胜种性修练根者。无学位中转一一性。各九无间九解脱道。如得应果。所以者何。彼钝根性由久惯习。非少功力可能令转学无学道所成坚故。有学位中转一一性。各一无间一解脱道。如得初果。非久习故。彼加行道诸位各一学无学位修练根时。皆渐次修。后后种性。得胜种性方舍前劣。故诸无学修练根时。加行无间前八解脱。如应皆是退法等收。第九解脱是思法等。诸有学者修练根时。加行无间是退等摄。解脱道时名思法等。我所承禀诸大论师。咸言练根皆为遮遣。见修断惑力所引发。无覆无记无知现行。故学位中修练根者。正为遮遣见惑所发。无学位中修练根者。正为遮遣修惑所发。如如断彼能发惑时。所起无间解脱多少。如是如是断彼所发。无知现行道数亦尔。是故无学修练根时。用九无间九解脱道。学位练根二道各一。然见修惑所发无知。随所障殊有多品类。故转退等成思等时。诸道现前各有所遣。由此无有超得胜性。有余师说。一切练根皆一加行无间解脱。前说为善。理如前故。如是无间及解脱道。一切唯是无漏性摄。圣者必无用有漏道而转根理。以世俗法体非增上无堪能故。一切加行皆通二种。如是所说但据现行。兼未来修复有差别。谓无学位修练根时。加行未来亦通修二。九无间道及八解脱。未来所修亦唯无漏。第九解脱未来修二。兼修三界所有功德。与初尽智所修同故。若有学位修练根时。加行未来亦通修二。无间解脱未来所修。亦唯无漏。如得初果。然无学位修练根时。道数所修如断有顶。若有学位修练根时。道数所修如断上界。见道所断。由彼但与邻得果时。道相似故。学无学位修练根时。加行皆通曾未曾得。无间解脱唯是未曾。一切皆通法智类智。修练根者唯人三洲。唯依此身有怖退故。以何等故名为练根。调练诸根令增长故。谓道力故令根相续。舍下得中。舍中得上。渐渐增胜。名为练根。故练根名目转根义。虽八解脱渐得胜根。而由本心求胜性故。未得胜性不舍前劣。如得后果方舍前向。如在圣位种性有六。能修练根。于见道前。暖等加行应知亦尔。有差别者。若圣位中得胜种性必舍前劣。暖等位中修练根者。但得胜性劣性不行。名为转根。非舍劣得。无学练根。通依九地。谓四静虑未至中间及三无色。唯此九地有无漏道。余地无故。有学练根唯依六地。除三无色。所以者何。以转根者。容有舍果及胜果道。所得唯果。非胜果道。心欣果故。无有学果。无色地摄。故学练根。但依六地。设许学位依无色练根定。是不还住。胜果道位。无不还果。无色地摄。故不依无色修练根得果。以初二果唯未至摄。不还唯通六地摄故。有说唯有住果练根。勿有舍多得少过故。无如是过。以练根者心期胜果不求多故。由此学位修练根者。若住果道加行等三。皆果道摄若住胜道加行。无间胜果道摄。解脱道果道摄。住无学位修练根者。加行等三唯果道摄。诸住果位修练根时。舍果得果住胜道位。修练根时舍二得果。又诸圣位修练根时。与本得果地同或异。谓初二果依地必同。彼此俱依未至地故。不还应果依地不定。或依本地。或上或下。有差别者。若诸不还依下练根不得上果。阿罗汉不尔。如本得果故。分断有顶结。练根得果时。虽舍彼断不成彼结。如异生者生上七地。随应舍下断。而不成下结。俱是进时。非退时故。诸无学位补特伽罗。总有几种。由何差别。颂曰

  七声闻二佛　　差别由九根

论曰。居无学位圣者有九。谓七声闻及二觉者。退法等五不动分二。后先别故名七声闻。独觉大觉名二觉者。由下下等九品根异。令无学圣成九差别。有学无学补特伽罗。一切总收无过七种。一随信行。二随法行。三信解。四见至。五身证。六慧解脱。七俱解脱。依何立七。事别有几。颂曰

  加行根灭定　　解脱故成七
  此事别唯六　　三道各二故

论曰。依加行异立初二种。谓依先时随信他语及自随法。能于所求一切义中修加行故。立随信行随法行名。依根不同立次二种。谓依钝利信慧根增。如次名为信解见至。依得灭定立身证名。由身证得灭尽定故。依解脱异立后二种。谓依唯慧离烦恼障者立慧解脱。依兼得定离解脱障者立俱解脱。此名虽七事别唯六谓见道中有二圣者。一随信行。二随法行。此至修道别立二名。一信解。二见至。此至无学复立二名。谓时解脱。不时解脱。然唯应说有二圣者。随信随法行有异故。即此二种随道差别。虽立异名而无别体。如是所说补特伽罗。以根性道离染依别。诸门分析数成多千。且如最初一随信行。根故成三。谓下中上。性故成五。谓退法等。道故成十五。谓八忍七智。离染故成七十三。谓具缚离八地染。依身故成九。谓三洲欲天。若根性道离染依身相乘合成一亿四万七千八百二十五种。随法行等如理应思。如是等门差别无量。若欲委细一一分别。施功甚多。所用极少。故我于此略示方隅。有智学徒应广思择。前说依解脱立后二种。立后二种相由何应知。颂曰

  俱由得灭定　　余名慧解脱

论曰。诸阿罗汉得灭定者名俱解脱。由慧定力双脱烦恼解脱障故。所余未得灭尽定者名慧解脱。但由慧力于烦恼障得解脱故。何等名为解脱障体。诸阿罗汉心已解脱。而更求解脱为解脱彼障。谓于所障诸解脱中。有劣无知无覆无记性能障解脱。是解脱障体。于彼彼界得离染时。虽已无余断而起解脱。彼不行时方名解脱。彼有余师说。此解脱障即以于诸定不自在为体。有余师说。此解脱障即以诸定不得为体。有余师说。于彼加行。不勤求故。不听闻故。不数习故。解脱不生。即此名为解脱障体。初说应理。所以者何。必有少法力能为障。令彼于定不自在转。若不尔者。彼有何缘于诸定中不得自在。不得定者必有所因。不可说言即因不得。自体不应还因自故。或烦恼障亦应可说。即以应果不得为性。彼既不然。此云何尔。阿罗汉果亦由于加行不勤求等故体不得生。岂便无别烦恼障体。故后三说皆不应理。又无漏心亦有从此名得解脱。由约在身及约行世说解脱故。谓要解脱解脱障时。方起在身及行世故。诸阿罗汉有名同者。根亦同耶。应作四句。第一句者。慧解脱中有时解脱不时解脱。俱解脱中有二亦尔。第二句者。时解脱中有慧解脱有俱解脱。不时解脱有二亦尔。第三句者。慧解脱中二时解脱自互相望。二不时解脱俱解脱亦尔。第四句者。慧解脱中取时解脱。俱解脱中不时解脱。展转相望。与此相违应知亦尔。如世尊说。五烦恼断。不可牵引。未名满学。学无学位。各由几因。于等位中。独称为满。颂曰

  有学名为满　　由根果定三
  无学得满名　　但由根定二

论曰。学于学位独得满名。要具三因。谓根果定。故见至身证独得名为满。少有阙者尚非满学。况一切阙而得满名。何等名为少有阙者。谓信解得灭定。或见至不还未得灭尽定。或见至未离欲。或信解不还未得灭尽定。何等名为一切阙者。谓信解未离欲有许少阙亦得满名。彼作是言。有有学者。但由根故亦得满名。谓诸见至未离欲染。有有学者。但由果故亦得满名。谓信解不还未得灭尽定。有有学者。由根果故亦得满名。谓见至不还未得灭尽定。有有学者。由果定故亦得满名。谓诸信解得灭尽定。有有学者。具由三故独得满名。谓诸见至得灭尽定。无有学者。但由定故及根定故亦得满名。此不可依。如何有学于诸有学胜功德中。犹未具证而许名满。故如前说理定可依。无学位中无非果满。故不由果建立满名。自位相望独名满者。要具二种。谓根与定。故唯不时俱解脱者。望余无学独得满名。随阙一者尚非满无学。何况双阙得满无学名。何等名为随阙一者。谓时解脱得灭尽定。或不时解脱不得灭尽定。何等名为双阙二者。谓时解脱不得灭定。有许阙一亦得满名。此不可依。理如前说。如契经说。二阿罗汉。一具三明。二不退法。于前所说诸应果中。二阿罗汉何应果摄。且不退法摄在不动。然此不动差别有二。一者唯能不退应果。二者不退一切胜德。此中第一但名不动。如思法等由练根得。仍有退失阿罗汉果。此异彼故得不动名。然于应果一切胜德。犹可退失不名不退。第二亦无退诸胜德。故经于彼立不退名。以不动中于胜功德有可退者。是故契经于不动内立不退法。具三明者。有言此摄在慧解脱俱解脱中。通未已得灭尽定故。有言唯在俱解脱摄。宿住死生明依本静虑故。起本静虑者。名俱解脱故。今详经意慧俱解脱。若圆满者。其体各异。未起根本。已得灭尽。为悬隔故。不圆满者。二体相杂。随说皆通。然欲简别令无杂者。应就灭定未得得说。以慧解脱无得灭定。根本静虑虽不现行。然于未来必成就故。由此可说具三明者。理通摄在二解脱中。广说诸道差别无量。谓世出世见修道等。今应思择。于诸道中。略说有几。可能遍摄。颂曰

  应知一切道　　略说唯有四
  谓加行无间　　解脱胜进道

论曰。加行道者。谓此无间。无间道生。无间道者。谓此能灭所应断障。解脱道者。谓已解脱所应断障最初所生。胜进道者。谓除无间加行解脱所余诸道。何义名道。谓寻求依。依此寻求涅槃果故。由此一切修苦智等。无不皆为寻求涅槃。或此道名目涅槃路。三乘贤圣涉此夷途。速达二种涅槃界故。道于余处立通行名。以于谛中能善通达。复能速往涅槃城故。此有几种。依何建立。颂曰

  通行有四种　　乐依本静虑
  苦依所余地　　迟速钝利根

论曰。经说通行总有四种。一苦迟通行。二苦速通行。三乐迟通行。四乐速通行。此四通行有差别者。依地依根建立异故。云何依地建立差别。谓依根本四静虑中所生圣道。名乐通行。任运转故。如乘船筏。任运转者。由此地中止观双行无增减故。又此诸地所有等持。摄受五支四支成故。依余无色未至中间所生圣道名苦通行。虽道非苦。苦受相应艰辛转故亦名为苦。如依陆路乘马等行。艰辛转者。由此地中止观虽俱而增减故。谓无色地观减止增。未至中间观增止减。又此诸地所有等持。不摄五支四支成故。有余师说。未至地道难可成办。故立苦名。谓有先来都未得定。多起功用方得现前。此既现前为胜加行。根本静虑易起故乐。静虑中间同一地摄。异心品灭异心品生。极为艰辛。故亦名苦。譬如以木析木极难。谓一地中有寻有伺。粗心品灭。无寻唯伺。细心品生。多用功力。诸无色定亦甚难成。故亦名苦。极微细故。谓无色定行相眇然。不易测量。修难成办。又从静虑起无色时。五蕴定灭。四蕴定起。极为难办。故立苦名。云何依根建立差别。谓即苦乐二通行中。钝根名迟。利根名速。二行于境通达稽迟说名迟通。翻此名速。或迟钝者所起通行名迟通行。速此相违。或趣涅槃有迟有速。由根钝利。如后当辩。此行五蕴四蕴为性。由依色定无色定别。而名通者。显慧胜故。如见道位。虽具五蕴。以慧胜故。偏立见名。如见道边诸世俗智金刚喻定。亦以五蕴四蕴为体。立智定名。然有经中说四通行五根为性。亦就胜说。慧胜中胜。故立通名。虽有中根即利钝摄。以利钝中有非极故。然向所言由根利钝。于趣圆寂有速有迟。此据等修勤加行说。若不据等。则钝利根。趣向涅槃迟速不定。又契经说。有现法迟身坏速等四句差别。此约加行有勤不勤。不约转根及有退说。以诸圣者若已经生不退不转根不生上界故。大觉独觉到究竟声闻。依何通行入圣证极果。大觉唯依乐速通行。谓以第四静虑为依。由极利根入正决定证得无上正等菩提。于独觉中。麟角喻者。如大觉说。余则不定。于到究竟二声闻中。舍利子依苦速通行。及乐速通行。入圣证极果。彼依未至入正决定。依弟四定得漏尽故。目连唯依苦速通行。谓依未至入正决定。依无色定得漏尽故。二圣先来乐慧乐定。故证极果。依色无色。许到究竟诸大声闻法尔唯应渐次得果。故彼入圣道皆依未至地

说一切有部显宗论卷第三十三阿毗达磨藏显宗论卷第三十四

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩贤圣品第七之六

道亦名为菩提分法。此有几种。名义云何。颂曰

  觉分三十七　　谓四念住等
  觉谓尽无生　　顺此故名分

论曰。经说觉分有三十七。谓四念住。四正断。四神足。五根。五力。七等觉支。八圣道支。尽无生智说名为觉。随觉者别立三菩提。一声闻菩提。二独觉菩提。三无上菩提。无智睡眠皆永断故。及如实知已作已事不复作故。此二名觉。三十七法顺趣菩提。是故皆名菩提分法。此三十七体各别耶。不尔。云何。颂曰

  此实事唯十　　谓慧勤定信
  念喜舍轻安　　及戒寻为体

论曰。此觉分名。虽三十七。实事唯十。即慧勤等。谓四念住慧根慧力择法觉支正见。以慧为体。四正断精进根精进力精进觉支正精进以勤为体。四神足定根定力定觉支正定。以定为体。信根信力。以信为体。念根念力念觉支正念。以念为体。喜觉支。以喜为体。舍觉支以行蕴摄舍为体。轻安觉支以轻安为体。正语正业正命以戒为体。正思惟以寻为体。如是觉分实事唯十。前五即是信等五根。由境等殊分为三十。更加喜舍轻安戒寻戒分为三。复总成七。并前合成三十七种。毗婆沙师说有十一。身业语业不相杂故。戒分为二。余九同前。念住等三名无别属。如何独说为慧勤定。颂曰

  四念住正断　　神足随增上
  说为慧勤定　　实诸加行善

论曰。四念住等三品善法。体实遍摄诸加行善。然随同品增上善根。如次说为慧勤及定。何缘于慧立念住名。慧由念力持令住故。何故说勤名为正断。于正修习断修位中。此勤力能断懈怠故。或名正胜。于正持策身语意中。此最胜故。何缘于定立神足名。诸灵妙德所依止故。何缘信等立根力名。以增上故。难屈伏故。何缘此五先说为根后名为力。由此五法依下上品分先后故。又依可屈伏不可屈伏故。下品信等势用劣故。犹为所治同类屈伏。上品翻此故得力名。所说觉支为有何义。能觉悟义名为觉支。若尔觉支唯应有一。不尔念等是择法分。皆顺择法从胜为名。或觉之支是觉支义。若尔应许觉支唯六。不尔择法是觉亦觉支。所余六种是觉支非觉。所说道支为有何义。寻求依义名为道支。若尔道支唯应有一。不尔余七是正见分。皆顺正见从胜为名。或道之支是道支义。若尔应许道支唯七。不尔正见是道亦道支。所余七种是道支非道。当言何位何觉分增。颂曰

  初业顺决择　　及修见道位
  念住等七品　　应知次第增

论曰。初修业位说念住增。谓此位中。为息颠倒。由念势力。于身等境。自相共相。能审了知。坏二种愚。慧用胜故。于暖法位说正断增。谓此位中见生死过涅槃功德。遂能勇猛发勤精进。不坠生死速趣涅槃。勤用胜故。于顶法位说神足增。谓此位中能制心识。趣不退位。终不匮乏。信等善根。定用胜故。于忍法位说五根增。谓此位中永息恶趣终不退堕。速入离生。增上义成。根义胜故。世第一位说五力增。谓此位中不为烦恼之所屈伏。力义胜故。虽忍位中亦容如是。然非决定。是故不说。或此位中不为一切余异生法之所屈伏。故于此位力义偏增。修道位中近菩提位。助觉胜故说觉支增。或此位中断九品惑。数数觉故觉支义增。见道位中所有道义。皆具足故说道支增。谓寻求依及通往趣。二义具故说名为道。见道位中二义最胜。谓见道位圣慧初生。如实寻求谛理胜故。又于此位不起期心。能速疾行往趣胜故。随数增故。于契经中。先七后八。非修次第。有余于此立次第言。行者最初由慧势力。于身等境自相共相。如实了知导起众善。如有目者将导众盲。是故最初说四念住。由四念住了众境已。于断恶修善能发起正勤。故于第二说四正断。由正勤力令相续中。过失损减功德增盛。于殊胜定方能修习。是故神足说在第三。胜定为依。便令信等与出世法为增上缘。由此五根说为第四。根义既立能招恶趣恶业烦恼不能屈伏。由此五力说为第五。力义既成能如实觉四圣谛境无疑虑故。说七觉支在于第六。既如实觉四圣谛境。厌舍生死欣趣涅槃。故说道支以为第七。于中一一辩其次第。如释经论应正思求。今此论中思择法相。于次第理无劳烦述。三十七觉分中几唯无漏几通二种。颂曰

  七觉八道支　　一向是无漏
  三四五根力　　皆通于二种

论曰。此中七觉八圣道支唯是无漏。唯于修道见道位中方建立故。谓修道位七觉支增。邻近菩提。谓治有顶。故觉支体一向无漏。一切觉分皆助菩提。唯此独标觉支名者。以最邻近菩提果故。由此理趣证七觉支。应知但依治有顶说。此为上首类治下地。唯于无漏立觉支名。若不许然宁不通二。或于一切菩提分中。依近菩提立觉支号。道中修道位近菩提。性近菩提唯是无漏。故无漏修道方立觉支名。见道位中八道支胜。故此一向无漏性摄。虽正见等亦通有漏。然彼不得圣道支名。圣道支名目无漏故。又诸论者。许觉分法觉支后说。定是无漏。若说在前。便通二种。既觉支后方说道支。故八道支一向无漏。所余通二。义准已成。谓觉分中前位增者。彼于后位势用亦增。后位增者非于前位。故毗婆沙作如是说。从初业位至尽无生念位常增。乃至广说。此三十七何地有几。颂曰

  初静虑一切　　未至除喜根
  二静虑除寻　　三四中除二
  前三无色地　　除戒前二种
  于欲界有顶　　除觉及道支

论曰。初静虑中具三十七。于未至地除喜觉支。于下地法犹怀疑虑未能保信。故不生喜。又未至定初现前时。未能断除下地烦恼。后虽已断而类同前。故起彼时皆无有喜。有说一切近分地道。皆力励转故无喜义。第二静虑除正思惟。彼静虑中已无寻故。由契经说。彼地无寻。彼上等持转寂静故。由此二地各三十六。第三第四静虑中间双除喜寻。各三十五。前三无色。除戒三支。并除喜寻。各三十二。欲界有顶除觉道支。无无漏故。各二十二。如是诸地随其所应。觉分现前少多无定。谓随位别后必兼前。可一体上义分多种。故有多种俱时起义。唯四念住必不俱生。以约所缘分为四故。尚无二慧俱时而生。况有一时四慧并起。不可一慧约境分多。以若总缘法念住摄。必无一慧于一刹那缘四境生四行相故。由此理趣初静虑中。总而言之具三十七。然于一念顷现在前。极多但容有三十四。如是未至第二静虑。极多但容有三十三。三四中间极三十二。前三无色极二十九。欲界有顶极唯十九。一切皆除三念住故。其中减者随位应思。何故心王不立觉分。理亦摄在念住等中。彼实摄诸加行善故。然不别立如慧等者。心于杂染清净分中。势用均平无所偏党。觉分唯在清净分中。势用增强。是故不立。有余师说。觉分多缘诸法共相。心王多分缘自相生。是故不立。有余复说。修习觉分本为对治一切烦恼。然诸烦恼心所非心。故能治法非心唯所。障治相翻。而建立故。有说觉分辅佐于觉。觉是心所慧为体故。不可心王辅佐心所。如王不可辅佐于臣。所以心王不立觉分。有余师说。心导世间于界趣生轮回无绝。修习觉分为断生死。由此心王不立觉分。有余师说。无始时来心为众多烦恼杂染。驰散诸境[怡-台+龍]戾难调。为调伏心修习觉分。非所调伏即是能调。是故心王不立觉分。何缘诸大心所法中。唯立四法为菩提分。实总摄在念住等中。彼实摄诸加行善故。然别建立念定慧者。由此三种顺清净品。势用增强可立觉分。想思触欲。于染分中势用增强。故不别立。于假想观胜解偏增。觉分唯摄顺真实观。由此胜解非觉分摄。有余师说。至无学位胜解方增。经但立为无学支故。菩提分法有学位增。由此为因。力能引起三菩提故。所以胜解非觉分摄。作意势力能发动心。令于所缘易脱不定。觉分于境。审谛观察。令心专一。与彼相违。是故作意非觉分摄。若尔宁立寻为觉分。寻于境界虽策发心。而欲令心推求至理。非令于境浮飘易脱。于谛观察有策发能。说此力能策正见故。由此作意不可例寻。有余师言。若染若净初取境位。作意力增说为非理。如理作意至境相续。彼势力微故不立为烦恼觉分。烦恼觉分要于至境相续位中方增盛故。受于杂染清净分中。势用俱增故立觉分。由此流转缘起支中立为受支。及于还灭菩提分中立喜觉支。有余师说。受于杂染虽是增上。而与净品作饶益事。亦有功能。如旃荼罗性虽鄙劣。能与豪族作饶益事。故于静虑为饶益支。菩提分中立觉支号。何缘三受皆通无漏。觉分唯喜。非余二耶。觉分所为行相猛利。乐舍行相。迟钝故非。有余师言。乐舍二受为轻安乐。行舍所覆相不明了。是故不立。何缘大善心所法中。唯立四法为菩提分。实亦总是念住等摄。彼实总摄加行善故。然别立信勤安舍者。由此四种顺觉强故。如何此四顺觉用强。发趣菩提信为上首。将修众行信为初基。清净果因以信为本。若无信者修趣不成。故立信根以为觉分。有余师说。如清水珠置浊水中。水便澄洁。令诸有目鉴众色像。如是以信置心品中。能令俱生心品澄净。由此能见四圣谛理。渐次增长成三菩提。故信最应立为觉分。勤于众行遍能策发。令其速趣三乘菩提。若无正勤。虽已发趣。中间懈废终无所成。是故立勤以为觉分。有余师说。无始时来所以不能见四圣谛。都由懈怠不乐听闻。如理思惟四圣谛理。勤能治彼令乐听闻。如理思惟四谛理故。能见四谛速证菩提。故勤亦应立为觉分。轻安息务令心调适。行舍正直令心平等。故能增长诸出世行。令其速趣三乘菩提。故立安舍以为觉分。有余师说。无始时来惛掉乱心不见谛理。由此不证三乘菩提。轻安舍惛行舍止掉。由斯见谛速趣菩提。故此亦应立为觉分。若尔惭愧自性善摄。于众善品得白法名。亦应立为菩提分法。彼不应立。以无惭愧。唯与一切恶心相应。于散戒中为胜障碍。于见谛理为障力微。与彼相违名为惭愧。自性善摄得白法名。虽于散戒有胜功力。而于定善为助力微菩提分中取顺定善。助觉谛理故彼不立。若尔应立无贪无嗔。彼是善根。自性善故。亦不应立。以诸贪嗔六识相应。遍通五部是随眠性。发粗恶业为胜加行。断灭善根障散善强违见谛劣。翻彼故立无贪无嗔。得善根名自性善摄。于散善业功力虽强。助定善中势用微劣。菩提分法取顺定善。助觉谛理故彼不立。若尔不放逸应立为觉分。不放逸故众行皆成。佛每劝令修不放逸。亦不应立。于散位中。放逸令心驰散五欲。能违施等。散善用强。非定位中此障用胜。翻对彼故。立不放逸。但于五欲能防护心。令不驰散专修施等。故于散善力用虽强。助定善中势用微劣。菩提分法取顺定善。助觉谛理。故彼不立。若尔不害应立觉分。害能逼恼无量有情堕三恶趣。彼能治故。亦不应立。害缘事生。恼诸有情。障修散善。不害翻此。助定力微。故亦不应立为觉分。有余师说。大善法中若所治强自性胜者。立为觉分。余则不然。所治强者。谓与一切染心相应。自性胜者。谓助见谛。如先所说信勤安舍具足二义惭愧等六无具二者。谓惭等五二义并无。不放逸一种唯阙自性胜。何缘欣厌非觉分耶。理实亦是念住等摄。彼实总摄加行善故。然不别立为觉分者。由此二种行相相违。俱不遍缘四圣谛境。无一地位容恒现前心品狭少。是故不立。有余师说。夫欣厌者。由慧观境势力引生。觉分谓能顺生觉慧。义相违故不应别立。何缘寻伺二种。皆容有加行善及有无漏。而于觉分一是一非。实亦俱通。义如前说。然别立寻不立伺者。寻于圣道策正见强。由彼起时行相猛利。寻求谛理有助见能。立为道支。伺则不尔。以行相起极微劣故。有余师说。二俱行时寻行相粗映蔽于伺。唯伺起位行相转微。故觉分中不别立伺。策发正见自有正勤。何更立寻以为觉分。勤策正见有异于寻。故道支中应并建立。谓勤策彼令速进修。寻力策令速观圣谛。何缘表业不立觉分。觉分唯是顺定善法。心俱无表有胜顺能。表业不然。是故不立。何缘不立不相应行以为觉分。彼于助觉无别胜能。不相应故。非如无表虽不相应而于道轮有为毂用。故于觉分不别建立。有余师说。二无心定。能灭心故。与觉相违。四相及得。于所相成有迁成用。此于染净起用平等。菩提分法顺净用增。故不别立。何缘不立信为觉及道支。初发趣时信用增上。已入圣位立觉道支。信于尔时势用微劣。故不立在觉道支中。何缘于觉支立喜轻安舍。非亦立彼在道支中。彼偏顺觉不顺道故。云何顺觉。且修道中。地地各修九品胜觉。如如于谛数数觉悟。如是如是发生胜喜。由生胜喜复乐观谛。如人掘地获宝生喜。由生喜故复乐更掘。故喜于觉随顺力增。要由轻安息诸事务。及由舍力令心平等。方能于境审谛觉察。故立安舍在觉支中。云何此三不顺于道。速疾运转是圣道义。此于速运少有相违。并能令心安隐住故。何缘于道立寻戒支。于觉支中非亦立彼。彼偏顺道不顺觉故。云何顺道。且见道中寻策正见。令于上下八谛境中速疾观察。戒能为毂成见道轮。令于谛中速疾回转。故寻及戒俱立道支。此复云何不顺于觉。且寻于谛不寂静转。于圣谛理寻求相故。觉已见谛安静而转。故寻于觉少有相违。觉是相应。有所缘境。有依有行。戒此相违。故于觉支不建立彼。通运名道。不可为例。何缘觉分不摄圣种。分别论者。许觉分摄。故彼宗建立四十一觉分。我许摄在念住等中。而不立为别觉分者。以诸觉分在家出家俱能受行及有欣乐。圣种唯有诸出家人受行欣乐。在家有乐必无受行。故不别立。有余师说。若许圣种总是无贪。如前已释。若许第四体即是勤。在觉分中无劳征诘。何缘证净非觉分摄。实亦摄在念住等中。而不立为别觉分者。以诸觉分进修义增。数习方能证菩提故。四种证净证得义增。见圣谛时渐顿得故。由此证净非觉分摄。有余师说。此即信戒随应亦在觉分中摄。修觉分时必获证净。此有几种。依何位得。实体是何法。有漏无漏耶。颂曰

  证净有四种　　谓佛法僧戒
  见三得法戒　　见道兼佛僧
  法谓三谛全　　菩萨独觉道
  信戒二为体　　四皆唯无漏

论曰。经说证净总有四种。一于佛证净。二于法证净。三于僧证净。四圣戒证净。且见道位见三谛时。一一唯得法戒证净。见道谛位兼得佛僧。谓见苦时得圣爱戒及法证净。于何等法如何而得法证净耶。谓唯于苦达唯有法。无实有情生决定信。如是次第见集谛时。亦唯如前得二证净。达唯集法能为苦因。无内士夫生决定信。从此无间见灭谛时。亦唯如前得二证净。达唯灭法是真涅槃。诚可遵求生决定信。从此次后见道谛时。兼于佛僧得二证净。于佛相续诸无学法得佛证净。于僧相续学无学法得僧证净。兼言为显见道谛时。亦得圣戒及法证净。达唯道法是证灭因。诚可遵求生决定信。然所信法略有二种。一别二总。总通四谛。别唯三谛。全菩萨独觉道。菩萨道者。唯有学法。独觉道者。通学无学。若无漏信缘别法生。名不杂缘。于法证净。若无漏信兼缘佛僧。名为杂缘。于法证净。故见三谛唯得二种。见道谛时具足得四。见道谛位为于现前得佛法僧三证净不。非皆现得见道谛时。现行总缘诸道谛故。应知现在惟有杂缘一法证净。乘此势力修得未来多刹那信。于中有别缘佛法僧。或有总缘二三宝者。诸别缘者名三证净。诸总缘者法证净摄。道类智时修八智故。亦得三谛。法戒二种。道法忍等。三刹那中。未来唯修。道谛四种。由所信别故名有四。应知实事唯有二种。谓于佛等三种证净。以信为体。圣戒证净。以戒为体。故唯有二。若七支戒实唯一者。如何觉分中实事有十一。应唯有十种。或十六或多。以觉分中身语二业。说有差别及相有异正命一种虽有别说。离身语业无别体相。依有别相。前觉分中。说言实事。有十一种。虽身语业。一一有多然种类同。故各立一。如四念住。前三证净。谓慧与信。若不杂缘。随所缘别。虽有多种。而类同故。各立为一。此亦应然。今证净中。依身语业。圣戒相等。及契经中。同说不缺不穿等故。总立为一。随身语业类别分二。圣戒相同总立为一。故二与一无相违过。为依何义立证净名。如实觉知四圣谛理。故名为证。正信三宝及妙尸罗。俱名为净。由证得净立证净名。正信是心清净相摄。可名为净。尸罗不是清净相摄。宁立净名。此四皆是清净相摄。离不信垢破戒垢故。又此四种唯无漏故。离垢无漏故立净名。此四何缘次第如是。余三以佛为根本故。佛于正说有功能故。于彼证净立在最初。正说功能由悟法故。于彼证净立为第二。现观法藏唯圣僧故。于彼证净立为第三。观法藏能依圣戒故。圣戒证净立在最后。有言佛是正说法师。是故最初立佛证净。佛何所说爱尽涅槃。是故第二立法证净。为谁说法为向果僧。是故第三立僧证净。僧依圣戒而得建立。是故第四立戒证净。有说此四犹如导师。道路商侣及所乘乘。故说此四次第如是。经言学位成就八支。无学位中具成就十。学位亦成正脱正智。何缘于彼不建立支。正脱正智以何为体。颂曰

  学有余缚故　　无正脱智支
  解脱为无为　　谓胜解惑灭
  有为无学支　　即二解脱蕴
  正智如觉说　　谓尽无生智

论曰。有学位中尚有余缚。未解脱故无解脱支。非离少缚可名脱者。非无解脱体可立解脱智。故有学位不立二支。谓立支名依胜助用。在有学位既有余缚。虽有解脱无胜助用。况胜解脱故。彼胜智亦无。故此二支非在有学。无学已脱一切缚故。依内解脱生二智故。有胜助用理可立支。有学不然。故唯成八。解脱体有二。谓有为无为。有为解脱胜解为体。无为解脱惑灭为体。前复有二。谓学无学。依七圣身说名为学。依第八圣立无学名。唯有为中无学解脱。可得建立为解脱支。惑灭无为无支用故。支摄解脱复有二种。谓时不时。有差别故。有说慧心有差别故。应知此二即解脱蕴。如是已说正解脱体。正智体者谓离正见。如前觉说。即尽无生。前名菩提。今名正智。所言无学心解脱者。心于何位正解脱耶。为于未来现在过去。颂曰

  无学心生时　　正从障解脱

论曰。如本论说。初无学心。未来生时。从障解脱。且应思择。本论此文。说未来言。应成烦重。说生时言。义已显故。此责不然。随问答故。谓先问者问无学心于何世中正得解脱。是故今答言在未来。恐彼谓通未来一切。复为简别言是生时。或但应言生时解脱。然或有谓生时是现在。为遮彼故言未来生时。现是已生。非生时故。或就相续立解脱名。则一切未来皆名正解脱。若就行世立解脱名。则唯生时名正解脱。为别显二义。说未来生时。诸烦重言。必显别义理应推究。无容非拨。依如是义故有颂言

  文于义已足　　而复说余言
  非无义有文　　应思求别义

虽于此位诸所有蕴皆得解脱。而但说心。然不可言有缺减失。以心所等随从心故。染净法中心为主故。虽无有我。而可于心假说缚者脱者等故。若已说胜义已说余。或于此中如举喻法。举心一法令类思余。虽诸学心亦于生位从障解脱。而论但说初无学心生时脱者。据无余断证解脱故。又此唯说纯解脱故。此中有心是自性解脱。非相续解脱。应作四句。有学无漏无学世俗。无学无漏余世俗心。如次应知四句差别。此中虽举正生刹那。而实未来皆得解脱。与正生者生障同故。依此势力所修未来世俗善根。亦得解脱。依净相续彼得生故。为重显示初无学心未来生时从障解脱。是故本论复作是言。谓无间道现趣已灭。及解脱道现趣已生。尔时无学心名从障解脱。无间道者谓金刚定。并定眷属。临过去位立以现名。次后施设过去名故。趣已灭者显在正灭。邻次必入已灭位故。解脱道者谓初尽智并智眷属。临现在位立以现名。次后施设现在名故。趣已生者显在正生。邻次必入已生位故。言尔时者。谓正灭生时。无学心者初尽智俱趣。从障解脱者。非唯烦恼障。色无色界感生果业。亦是尔时所脱慞故。此业亦障阿罗汉得。由此古昔诸大论师。咸作是言。业于得忍不还应果。极为障碍。作如是释本论所言。则已释经心解脱义。道于何位令生障断。颂曰

  道唯正灭位　　能令彼障断

论曰。唯言为显正灭非余。如生未生道俱解脱。非灭已灭俱令障断。宁知正灭位能断障非余。以说道正生正从障脱故。道未生位未得解脱。道已生位已得解脱。俱不可立正解脱名。若道正灭时不能断障。如何道生位得正脱名。故正灭时道能断障。于前后位断用定无如何未生亦名解脱。与正生者生障同故。如世现见开水路时。近水远水皆言离障。如是既见能断惑道身中已生。亦应可说近心远心皆得解脱或如正起初无学心。有得正生名正解脱。如是彼类未来所修。无漏心等有得起故。定不生法。尚得名为正得解脱。况当生者。此中所说正解脱言显已解脱心今正得解脱如是所说岂不相违。已解脱言据自性解脱。今解脱言据从障解脱。所望各异。何义相违。或已解脱言。据本有解脱据在身行世。说今解脱言。由此所言无相违失。诸行世者皆解脱耶。不尔。要勤破生障者有余师说。正解脱时。亦得名为心已解脱。性是已舍烦恼障故。理必应然。以解脱道依无烦恼相续转故。已出障故名已解脱。今行世故名今解脱。由此所说互不相违。经说心从贪。今得解脱此。所言解脱其义云何。为是令心与贪相离。为令贪性不复缘心。心名有贪。为相应故。为所缘故。为得随故。若相应故。应唯染心。名得解脱。便违自宗。说离贪心得解脱故。又若此法与彼相应。必定无容令此离彼。心应毕竟不解脱贪。若所缘故。应染污心亦得解脱。理不应说贪相应心名为解脱。又彼贪性若缘此心。无暂不缘及余缘义。如何可说心脱彼贪。若得随故。应有学心亦名有贪。依止贪得所随相续而现起故。正理论者作如是言。唯离贪心今得解脱。何等名曰有贪离贪二种心相。谓心若与贪相应者名有贪心。若不相应亦不为贪。同类因者名离贪心。乃至有痴离痴亦尔。既说离贪心得解脱。即立解脱唯不染心。然不染心总有四种。谓有漏中分善无记。及无漏中分学无学。言离贪心今解脱者。今解脱有二。谓行世相续诸有漏心。一切皆有相续解脱。加行得者亦许兼有行世解脱。诸无漏心。一切皆有行世解脱。无学摄者。亦许兼有相续解脱。如契经中。说有三界。谓断离灭。于前所说二解脱中。此何为体。如是三界。差别云何。颂曰

  无为说三界　　离界唯离贪
  断界断余结　　灭界灭彼事

论曰。断等三界即分前说。无为解脱以为自体。然三界体约假有异。若就实事则无差别。云何名为约假有异。谓离贪结名为离界。断余八结名为断界。灭余一切贪等诸结所系事体名为灭界。何缘三界如是差别。谓有漏法总略有三。一者能系而非能染。二者能系亦是能染。三者非二顺系染法。断此三法所证无为。如次名为断等三界。有余师说。唯断能系。别有无为。断余不尔。彼说能系有缘八结。有缘爱结。有缘余事。断此三种所证无为。如次名为断等三界。有余师说。唯断能染别有无为。断余不尔。彼师说爱有缘八结。有缘爱结。有缘余事。断此三种所证无为。如次名为断等三界。随所系事别得择灭。故三说中初说为善。准此已释诸契经中断离灭想三相差别。或初业地我当断想。名为断想。若离染地我正断想。名为离想。若已办地我已断想。名为灭想。或于已受蕴重担中。见不舍过起欲舍想。名为断想。以舍与断名差别故。若于余蕴不复生中。见胜功德起欲求想。名为灭想。不生与灭名差别故。既得离染清净相续。于诸蕴法无所顾恋。于般涅槃见静妙想。名为离想。无恋与离名差别故。若事能厌必能离耶。不尔。云何。颂曰

  厌缘苦集慧　　离缘四能断
  相对互广狭　　故应成四句

论曰。唯缘苦集所起忍智。说名为厌。余则不然。四谛境中所起忍智。能断惑者皆得离名。广狭有殊故成四句。有厌非离。谓缘苦集不令惑断所有忍智缘厌境故。非离染故。应知此中先离欲染后见谛者。苦集法忍及见道中苦智集智。但名为厌。缘厌境故。忍不名离。惑先断故。智不名离。非断治故。并修道中加行解脱。胜进道摄。苦智集智。但名为厌。缘厌境故。不名为离。非断治故。有离非厌。谓缘灭道能令惑断所有忍智能离染故。缘欣境故。应知此中未离欲染。入见谛者灭道法忍。及诸所有灭道类忍。并修道中无间道摄灭智道智。但名为离。是断治故。不名为厌。缘欣境故。有厌亦离。谓缘苦集能令惑断所有忍智。应知此中未离欲染入见谛者。苦集法忍及诸所有苦集类忍。并修道中无间道摄苦智集智。有非厌离。谓缘灭道不令惑断所有忍智。应知此中先离欲染后见谛者。灭道法忍及见道中灭智道智。并修道中加行解脱。胜进道摄灭智道智

说一切有部显宗论卷第三十四阿毗达磨藏显宗论卷第三十五

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩智品第八之一

如是已依诸道差别。建立贤圣补特伽罗。所依道中作如是说。正见正智名无学支。故于此中应审思择。为有慧见非智。及有慧智非见而别建立见智二支。亦有。云何。颂曰

  圣慧忍非智　　尽无生非见
  余二有漏慧　　皆智六见性

论曰。慧有二种。有漏无漏。唯无漏慧立以圣名。此圣慧中八忍非智性。所以者何。非决断性故。唯决断义是智义故。如何八忍不能决断。自所断疑得随相续生故。或求见境意乐止息。加行奢缓说名为智。诸忍正起推度意乐。加行猛利故非智摄。而名见者。推度性故。尽及无生二智非见性。推度意乐一向止息故。所起加行极奢缓故。而名智者。决断性故。所余皆通智见二性。已断自疑推度性故。谓前八忍。尽无生余。有学八智无学正见。一一皆通见智性摄。岂不忍余诸无间道亦自所治惑得随生。无非正起。推度意乐加行猛利应非智摄。尽无生余解脱道等此相违故。皆应非见。此难不然。余无间道无自品疑得随相续生故。有漏无间不行谛理。与断疑得非亲违故。又彼唯见曾所见境。非如八忍。极违智故。余解脱等非全息求。所起加行非极奢缓。以皆于后有所作故。由此一切皆通二种。并具推度决断用故。诸有漏慧皆智性摄。于中唯六亦是见性。谓五染污见世正见为六。有余师说。能发身语五识所引。及命终时意识相应善有漏慧。亦非见性。外门转故。如能引故。势力劣故。此亦不然。不应许故。非决定故。契经说故。谓不应许。唯内门转。方是见性。勿圣慧中外身念住非见性摄。然契经说。于外身循身观是见性摄。亦非决定。如五识身所引意识。如是性转。以彼善等所引意识有时亦是不善等故。由此不应所引意识同能引五识是无分别性。如契经说。有命终时得正见俱。善心心所故说所有。意地善慧皆见性摄。于理为善。如是所说。圣有漏慧。皆择法故。并慧性摄。智有几种。相别云何。颂曰

  智十总有二　　有漏无漏别
  有漏称世俗　　无漏名法类
  世俗遍为境　　法智及类智
  如次欲上界　　苦等谛为境

论曰。智有十种摄一切智。一世俗智。二法智。三类智。四苦智。五集智。六灭智。七道智。八他心智。九尽智。十无生智。如是十智总唯二种。有漏无漏性差别故。如是二智相别有三。谓世俗智法智类智。前有漏智总名世俗。瓶衣等物性可毁坏。显在俗情故名世俗。此智多取世俗境故。多顺世间俗事转故。从多建立世俗智名。非无取胜义。顺胜义事转。然是爱境。无胜功能息内众惑。故非无漏。惑覆出世引发世间。得世俗名。体即无智。智随属彼。得彼智名。意显此名目有漏智。有说诸趣名为世俗。此智多是往诸趣因。从果为名名世俗智。有说此智无始时来。生死身中显现而转。由此故立世俗智名。或诸有中随流无绝。名世俗智。以一切时随顺诸有。相续转故。或复此智于一切境。能遍映发得世俗名。独能遍缘一切法故。后无漏智分为二种。法类二名所目别故。此二名义如前已释。是名二智相别成三。定心相应圣行相转。有漏无漏二智何别。无漏于境行相明利。彼有漏智与此相违。如朅地罗余木二炭。于所烧炼势用不同。及胜劣香能熏用别。炎铁草火热势有殊。二智相望差别亦尔。或俗智后起增上慢。无漏不然。故有差别。又世俗智与法类智。境有宽陜故有差别。谓世俗智遍以一切有为无为为所缘境。以契经说有善俗智能遍知苦。广说乃至。遍知虚空非择灭故。亦有以非我行相总缘一切法为境。以契经说诸行非常一切法非我涅槃寂静故。法智但缘欲界四谛。类智能通缘上二界四谛。由此三智境有差别。即于如是三种智中。颂曰

  法类由境别　　立苦等四名
  皆通尽无生　　初唯苦集类

论曰。法智类智由境差别。分为苦集灭道四智。何缘俗智亦缘苦等。作苦等行相。而非苦等智。由彼先以苦等行相观苦等已。后时复容观苦等境为乐等故。又得如是世俗智已。后缘谛疑容现行故。如是六智若无学摄。非见性者。名尽无生。此二初生唯苦集类以缘苦集六种行相。缘有顶蕴为境界故。金刚喻定若缘苦集。与此境同。缘灭道异。若尔岂不至教相违。如说于尽有初智生。从此无间能自了达。无违教失。此于尽言是有第七声。非境第七故。谓有烦恼无余尽故。有初智生非此智生。缘尽为境。何所违害。彼言意显。有惑身中无此智生。要有惑尽。于前所说九种智中。颂曰

  法类道世俗　　有成他心智
  于胜地根位　　去来世不知
  法类不相知　　声闻麟喻佛
  如次知见道　　二三念一切

论曰。有法类道及世俗智。成他心智。余则不然。岂不道智离法类无。应但言二成他心智。理实如是。为显他心智但知同类境。故作是言。谓为显成此法类智。知他无漏心心所法。是道智摄。非苦集智。以无漏智决定不能知他有漏心心所故。他身无漏心心所法。细故胜故。非己有漏他心智境。其理可然。何缘己身无漏他心智。不能知他有漏心心所。于有漏境无漏智生。行相所缘异此智故。谓无漏智缘有漏时。必是总缘厌背行相。是故决定不能别缘他心心所成他心智。以诸圣智缘有漏时。必于所缘深生厌背。乐总弃舍不乐别观。缘无漏时生欣乐故。既总观已亦乐别观。如有见闻非所爱事。总缘便舍不乐别缘。于所爱中则不如是。总见闻已亦乐别缘。是故于他有漏心等。必无圣智一一别观。成缘有漏心无漏他心智。以他心智决定于他心心所法别别知故。岂不亦有。三念住摄。苦集忍智。虽有而非。但缘一法。缘多体故。又他心智有决定相。谓不知胜去来二世。并法类品不互相知。胜复有三。谓地根位。地谓下地。智不知上地心。义唯能知自地下地。根谓信解时。解脱根知。不知见至不时解脱心。位谓不还声闻应果独觉大觉。前前位智不知后后胜位者心。义唯能知自下根位。然他心智及所知境。根地既殊知亦有异。所知有漏心心所法。曾未曾得各有十五。谓欲四静虑各下中上根。能知但除欲界三品。曾未曾得各有十二。所知无漏及彼能知。皆除欲三各有十二。且诸有漏曾未曾得。下根所摄他心智生。随其所应能知下地三根心品自地下根。中品亦知自地中品。上品总了自下地三。无漏下根他心智起。唯知自地下地下根。中亦知中。上兼知上。何缘有漏无漏智生。知下地心多少有异。有漏三品可一身成。无漏随根立圣差别。尚无有一成二品根。况有成三。故有差别。如何说一补特伽罗成九品道断九品惑。此道差别非根有异。由因渐长后道转增。如次能令多品惑断或诸种性各有九品。成一九品。必不成余。故前后言无相违失。故依上地起下根心。有上根心依下地起。地根互胜必不相知。地位位根相对亦尔。此他心智不知去来。本为知能缘心心所法故。法类二品不互相知。此二如次以欲上界全分对治为所缘故。此他心智见道中无。总观谛理极速转故。然皆容作他心智境。三乘圣者起此智时。中下二乘必须加行。声闻加行或上或中。麟喻但须下品加行。佛无加行随欲现前。若诸有情将入见道。声闻独觉预修加行。为欲知彼见道位心。彼诸有情入见道位。声闻法分。加行若满。知彼见道。初二念心。若为更知。类分心故。别修加行。至加行满。彼已度至第十六心。虽知此心非知见道。是故说彼唯知二念。麟喻法分加行若满。知彼见道初二念心。若为更知类分心故。别修加行。至加行满。知彼第八集类智心。有余师言。知第十五。有说麟喻知四刹那。谓初二心第八十四。此言应理。所以者何。许从知初二念心已。唯隔五念知第八心。若复更修法分加行。经五念顷加行应成。何不许知第十四念。有余亦说。知四刹那。谓初二心第十一二。佛于一切殊胜功德。随欲现前。心自在故。于十五念能次第知。以佛世尊三无数劫精勤修习无量资粮。故获难思殊胜妙智。具大势用随欲能知。虽此智生亦知心所。然修加行本为知心。如空处等名他心智。胁尊者曰。引此智生。要先知心后方知所。从初但立他心智名。引此智时修何加行。先应观察身之显形。所乐言音表心差别。谓彼行者初修业时。为欲审知他心差别。先审观察自身显形。所乐言音因何有别。遂知显等差别由心。次复审观他身显等。亦由心异有差别生。由此后时离欲身意。调柔清净引胜定生。依定发生有威德智。此智真实照见他心。如明珠中种种色缕。差别之相了然可得。是名修世俗他心智加行。若修无漏他心智时。以观非常等苦智为加行。此加行位通缘色心。至成满时缘心非色。又加行位缘自他心。至成满时缘他非自。尽无生智二相何别。颂曰

  智于四圣谛　　知我已知等
  不应更知等　　如次尽无生

论曰。如本论说。云何尽智。谓无学位。若正自知。我已知苦。我已断集。我已证灭。我已修道。由此所有智见明觉解慧光观。是名尽智。云何无生智。谓正自知我已知苦不应更知。广说乃至我已修道不应更修。由此所有。广说乃至。是名无生智。由本意乐二智转时。力能引起如是解智。非于无漏二智转时。作如是解无分别故。谓出二智后得智中。方作如是二类分别。此二分别二智后生。是尽无生力所引故。此二俗智是彼士用果故。举二果表二智差别。理必应然。说由此故。依为此义。说由此声。即是为此所有智义。不尔应言。如是所有诸观行者。本修行时定起如斯要期意乐。谓我当证阿罗汉时。要应起此自审察智。故今出观此智必生。为令此生所起之智。随应建立尽无生名。即后智生所依止义。故言此释理必应然。如是十智互相摄者。谓世俗智摄一全一少分。法类智各摄一全七少分。苦集灭智各摄一全四少分。道智摄一全五少分。他心智摄一全四少分。尽无生智各摄一全六少分。何缘二智建立为十。颂曰

  由自性对治　　行相行相境
  加行办因圆　　故建立十智

论曰。由七缘故立二为十。一自性故立世俗智。以世俗智为自性故。二对治故立法类智。全能对治欲上界故。三行相故立苦集智。此二智境体无别故。四行相境故立灭道智。此二行相境俱有别故。五加行故立他心智。非此不知他心所法。本修加行为知他心。虽成满时亦知心所。而约加行故立他心智名。加行如前已具分别。六事办故建立尽智。事办身中定初生故。七因圆故立无生智。一切圣道为因生故。谓有尽智非无生智为因故生。无无生智不以尽智为因故起。如上既言法智类智。全能对治欲上界法。为有少分治上欲耶。颂曰

  缘灭道法智　　于修道位中
  兼治上修断　　类无能治欲

论曰。修道所摄灭道法智。兼能对治上界修断。望欲界法四谛法智全能对治。于欲见断法智亦为持对治故。能治所治皆得全名。望上俱缺俱名少分。何缘唯有灭道法智。兼治上界。非苦集耶。所缘寂静出离同故。谓欲上灭及能治道。展转相望相无别故。以诸择灭皆善皆常一切圣道皆能出离。所缘苦集欲上不同。少多细粗上下别故。又苦集智。缘所厌境。无容厌彼。于此离贪。理厌此地时。断此地烦恼。若许异厌异离贪。应异离贪异解脱。若许不厌色无色界而能离彼界贪。习厌离贪。理则应坏。灭道二智。不缘厌境。缘下治上。亦无过失。又如不净观及欣涅槃欲。谓不净观缘欲界境。唯能令心厌背欲界。欣涅槃欲现在前时。普能令心厌背三界。如是缘欲苦集智生。唯能令心离欲界染。缘欲界法灭道智生。普能令心离三界染。故许灭道法智品增。乃至得成金刚喻定。由此大圣妙善了知。依全治门立法类智。法智少分有治上能。类智必无。能治欲界。要于自界所作已周。方可兼为他界所作。非诸类智。己事成时。他事未成。有须助义。故无类智。治欲界法。岂不第十六道类智生。乘此便则能治欲界惑将断欲惑。类智不行。设许现行。由自界障所拘碍故。必无势力。能助成他。法智所作。由此类智无能治欲。于此十智中谁有何行相。颂曰

  法智及类智　　行相俱十六
  俗智此及余　　四谛智各四
  他心智无漏　　唯四谓缘道
  有漏自相缘　　俱但缘一事
  尽无生十四　　谓离空非我

论曰。法智类智一一具有非常苦等十六行相。十六行相后当广释。世智有此及更有余。能缘一切法自共相等故。谓世俗智。或有具作十六行相。如于暖顶忍等位中。或有不具。如世第一重三摩地及现观边世俗智等。或有别作非圣行相。如不净观息念慈等。诸世俗智行相无边。苦等四智一一各有缘自谛境四种行相。他心智中。若无漏者。唯有缘道四种行相。此即道智一分摄故。若有漏者。取自所缘心心所法自相境故。如境自相行相亦尔。故此非前十六所摄。如是二种于一切时。一念但缘一事为境。谓缘心时不缘心所。缘受等时不缘想等。若尔何故薄伽梵说。如实了知有贪心等。非俱时取贪等及心。如不俱时取衣及垢。如何他心智有行相所缘。而说不观所缘行相。以不观他心所缘行相故。谓但知彼有染等心。不知彼心所染色等。亦不知彼能缘行相。不尔他心智应亦缘色等。又亦应有能。自缘失无漏。他心智应缘苦等境。是则亦应许空无相相应。既不许然。知不观二。诸他心智有决定相。谓唯能取欲色界系及非所系他相续中现在同类心心所法。一实自相为所缘境。空无相不相应。尽无生所不摄。不在见道。无间道中。余所不遮。如应容有。尽无生智除空非我。各具有余十四行相。由与出观心转相违。故在观中无二行相。谓从二智出观后时。必自了知我生尽等。此中意说尽无生智。虽是胜义而涉世俗。我生尽等是世俗故。空非我是胜义必涉胜义。此观后决了知空非我故。由此二智。离空非我。为有无漏。越此十六更是所余行相摄不。颂曰

  净无越十六　　余说有论故

论曰。对法诸师有一类说。无越十六无漏行相。离此所余不可得故。岂不有说尽无生智。必自了知我生尽等。此不相违。前已说故。谓前已说无漏观后世俗智中。作此行相非无漏智。此行相转由尽无生。引起俗智推功于本。言彼了知。故许此智离空非我。本意乐力令此二智后必引生我生尽等。非由观内此行相转。令于后时起此行相。我等行相观内虽无。而由不遇自证解脱。义言此位必已应有。我生尽等行相势分。由先世俗行相引生。能引后时世俗行相。故离十四无尽无生。若谓此应言离十六无者。此不应理。除十四余有尽无生。非极成故。谓离十四。有依密说。计我生尽等。为尽无生智。遮彼故说离十四无。余不极成。宁对遮此。若尔既有无漏他心智。应越十六有无漏行相谓他心智皆以一实自相为境。道等行相皆以聚集共相为境。彼此既殊。知离十六决定别有。无漏行相。非定许故。所难不然。谓我所宗非决定许。共相行相但缘聚集。许有受心二念住故。如观一受体是非常。此智生时以共相行相。观一实自相为境极成。如是宁不许无漏他心智。以共相行相缘一实自相。谓知他心是真道等。即缘一实是道等相。若谓应如受心念住总缘三世所有受心为非常等共相行相。无漏他心智亦总缘三世他无漏心等为道等行相。便违自宗。他心智起。唯缘现在一实自相。此亦不然。加行异故。此智加行。为欲知他。现能缘心。有贪等别。修非常等。念住加行。为总厌背。诸有漏法。由前加行势力有殊。至成满时现总缘别。是故无有应相例过。若谓非常非受自体。故应观受为非常时。非缘一实自相为境。宁可引此喻他心智。则彼应许受非非常。不应于受起非常观。如受与心其体各别。必定无有观受为心。虽即观受以为非常。而无一物有多体过。领纳非常体无别故。如损益等非离领纳。所余行相。余法亦然。若尔应与至教相违。如说于身住循身观。应言法智。乃至广说。又说观老死。应言是四智。俱不相违。且初所说非显法智等。离十六行相住循身观。观身为身。但如实观为非常等。我先已许共相行相。亦以一实自相为境。故彼所说于我无违。后老死声总目取蕴。观五取蕴为非常等。是四智摄。何所相违。若尔如说受乐受时。如实了知受于乐受。如何是法类世俗道智摄。此应思择受现在时。必不了知不自缘故。亦不可说了知去来。去来不名受乐时故而契经说。受乐受时。如实了知受于乐受。故知此说别有密意。释此密意。如尽无生。谓出观后时。方起此行相。故无漏行相越十六外。无有一类言有越十六。本论说故。如本论言。颇有不系心能了别欲界系法耶。曰能了别。谓非常故。苦故。空故。非我故。因故。集故。生故。缘故。有是处。有是事。如理所引了别。此证不成。迷论意故。论显不系行相众多。于中有缘欲界系者。依容有说。有是处言。有是事言。显无颠倒。即由此故。余无此言。谓彼论中。复作是说。颇有见断心能了别欲界系法耶。曰能了别。谓我故。我所故。断故。常故。无因故。无作故。损减故。尊故。胜故。上故。第一故。能清净故。能解脱故。能出离故。惑故。疑故。犹豫故。贪故。嗔故。慢故。痴故。不如理所引了别。除此无容有余行相。由此不说有是处言。由皆颠倒转。不言有是事。故净行相无越十六。理教无违。不可倾动。所言行相有十六者。为但名别实亦有异。何谓行相能行所行。颂曰

  行相实十六　　此体唯是慧
  能行有所缘　　所行诸有法

论曰。有说行相名虽十六实事唯七。缘苦谛境治四倒故。名实俱四。缘三谛境。名四实一。如是说者实亦十六。所治所行相有别故。言所对治相有别者。为治常见故修非常行相。为治乐诸行故修苦行相。为治我所见故修空行相。为治我见故修非我行相。为治无因论故修因行相。为治自在等一因论故修集行相。为治转变因常因论故修生行相。为治知为先能生论故修缘行相。为治归自在为涅槃论显诸蕴永灭是涅槃故修灭行相。为治执自体所有解脱是杂染惑苦不正见故修静行相。为治执涅槃如被咒诅遂致殄灭是弊坏论故修妙行相。为治执解脱还退见故修离行相。为治执无解脱道故修道行相。为治苦行是真道见及谤真道是邪论故修如行相。为治不修道生死自净及世间离染是真道故修行行相。为治尝遭不永离染道所诳惑于真圣道亦不敬故修出行相。言所行境相有别者。苦圣谛有四相。一非常。二苦。三空。四非我。有生灭故非常。逼迫性故违圣心故苦。无主宰故空。违我相故非我。集圣谛有四相。一因。二集。三生。四缘。能生法故因。有多种故集。恒孳产故生。各别助故缘。灭圣谛有四相。一灭。二静。三妙。四离。息众苦故灭。三有为相三火灭故静。有余师说。众苦息故静。如说苾刍诸行皆苦。唯有涅槃最为寂静。善故常故妙。一切灾患永解脱故。极安隐故离。道圣谛有四相。一道。二如。三行。四出。能通寻求诸法性相至解脱故道。无倒转故如。如实趣故行。有余师说。定能趣故行。如说此道能至清净。余见必无至清净理。一向趣故。决能至故出。如是所治及所行境。相有别故实有十六。如是行相以慧为体。谓唯诸慧。于境相中简择而转名为行相。岂不心心所皆名有行相。如是无慧与慧相应。如何可言慧有行相。非有行相。唯慧相应心等。皆名有行相者。是心心所等。于所缘品类相中有能取义。若依唯慧得行相名。则慧之余心心所法。与行相等名有行相。如等漏故得有漏名。是与漏体同对治义。如是所余心心所法等与行相。行于所缘。是俱时行。无前后义。或心心所有行相者。多如已知根。总名有行相。或依无间。亦说有声。如有所依故无有过。谓如心心所皆名有所依。意识相应诸心所法。与所依识亦俱时生。识之所依唯无间灭。有行相理应知亦然。无间灭慧于现何能。此于现有能如无间灭意。若尔应受等得有受等名。许亦无违。然非所辩。慧及诸余心心所法。有所缘故。皆是能行。此能行名。应唯目慧。行相体故。余心心所。既非行相。宁是能行。若谓所余名能行者。以与行相相应起故。是则慧等与受相应。应名能受。虽有此语而理不然。谓慧异门称为行相。能行即是取境别名。非能行言偏为诠慧。宁以受等体非行相。便作是难。应非能行。如于境中慧能简择。便许说慧名为能行。既于境中想能取像。识能了等。宁非能行。故能行名。通目取境。故应受等亦是能行。所行名通一切有法。若实若假皆所行故。由此三门体有宽陜。慧通行相能行所行。余心心所唯能所行。诸余有法唯是所行。其理善成不可倾动。已辩十智行相差别。当辩性摄依身依地。颂曰

  性俗三九善　　依地俗一切
  他心智唯四　　法六余七九
  现起所依身　　他心依欲色
  法智但依欲　　余八通三界

论曰。如是十智三性摄者。谓世俗通三性。余九智唯是善。依地别者。谓世俗智通依欲界乃至有顶。他心智唯依四根本静虑。不依近分静虑中间。此智所缘极微细故。彼地道力微劣不能了达他相续中现在微细心心所法。亦不依无色无此加行故。又通性故。余地非依五。通所依止观等故。法智通以六地为依。谓未至中间四根本静虑。不依余近分。彼唯有漏故。亦不依无色。此缘欲界故。所余七智九地为依。谓下三无色及前说六地。总说如是。然有差别。谓此所说七种智中类智决定依九地起。苦集灭道尽无生智。苦法智摄。六地为依。类智摄者。通依九地。依身别者。谓他心智。依欲色界俱可现前。不依无色。彼自无故。不起下地他心智者。此智随转色。彼无容起故。法智但依欲界身起。非上二界入出此智。诸有漏心唯欲有故。又法智随转色所。依大种唯欲系故。又此能治起破戒惑。破戒唯欲非上界故。余八智现起通依三界身。已辩性地身。当辩念住摄。颂曰

  诸智念住摄　　灭智唯最后
  他心智后三　　余八智通四

论曰。灭智摄在法念住中。他心智后三摄。所余八皆通四。如是十智展转相望。一一当言几智为境。颂曰

  诸智互相缘　　法类道各九
  苦集智各二　　四皆十灭非

论曰。法智能缘九智为境。除类智。类智能缘九智为境。除法智。道智能缘九智为境。除世俗智。非道摄故。苦集二智。一一能缘二智为境。谓世俗智及有漏他心智。世俗他心尽无生智。此四皆缘十智为境。灭智不缘诸智为境。唯以择灭为所缘故。十智所缘总有几法。何智几法为所缘境。颂曰

  所缘总有十　　谓三界无漏
  无为各有二　　俗缘十法五
  类七苦集六　　灭缘一道二
  他心智缘三　　尽无生各九

论曰。十智所缘总有十法。谓有为法分为八种。三界所系无漏有为。各有相应不相应故。无为分二种。善无记别故。俗智总缘十法为境。法智缘五。谓欲界二无漏道二及善无为。类智缘七。谓色无色无漏道六及善无为。苦集智各缘三界所系六。灭智缘一。谓善无为。道智缘二。谓无漏道。他心智缘欲色无漏三相应法。尽无生智缘有为八及善无为。颇有一念智缘一切法不。不尔。岂不非我观智知一切法皆非我耶。此亦不能缘一切法。不缘何法此体是何。颂曰

  俗智除自品　　总缘一切法
  为非我行相　　闻思修所成

论曰。以世俗智观一切法为非我时。犹除自品。自品谓自体相应俱有法。何故不缘自体为境。诸对法者立此因言。诸法必无待自体故。即由此理不缘相应。以与相应一境转故。许缘相应者。便应许自缘。亦不能缘俱有法者。以俱有法极相近故。如眼不见扶眼根色。契经亦说。一刹那智不能顿知一切法境。如契经说。无有沙门婆罗门等。于一切法顿见顿知。义准唯渐此智唯是欲色界摄。无色界中虽有此类。而缘法少。非此所明。此通闻思修所成慧。皆能除自品缘一切法故。已辩所缘。复应思择。谁成就几智耶。颂曰

  异生圣见道　　初念定成一
  二定成三智　　后四一一增
  修道定成七　　离欲增他心
  无学钝利根　　定成九成十

论曰。诸异生位及圣见道。第一刹那定成一智。谓世俗智。第二刹那定成三智。谓加法苦。第四六十十四刹那。如次后后增类集灭道智。诸未增位成数如前。故修位中亦定成七。如是诸位。若已离欲。各各增一。谓他心智。唯除异生生无色者。然异生位及见道中。唯可成就俗他心智道类智时具成二种。尔时初得不还果故。兼得无漏以成果体。余修位中皆具成二。生无色者便舍世俗。诸时解脱定成九智。谓加尽智。不时解脱定成就十。谓增无生

说一切有部显宗论卷第三十五阿毗达磨藏显宗论卷第三十六

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩智品第八之二

于何位中顿修几智且应思择。何谓为修。谓习善有为令圆满自在。非染无记者无胜爱果故。非善无为者。不在相续故。又无为无果故。已辩修义。本问应答。且于见道十五心中。颂曰

  见道忍智起　　即彼未来修
  三类智兼修　　现观边俗智
  不生自下地　　苦集四灭后
  自谛行相境　　唯加行所得

论曰。见道位中随起忍智。皆即彼类于未来修。然具修自谛诸行相念住。何缘见道唯同类修。所作所缘俱定别故。有说此种性先未曾得故。唯苦集灭三类智时。能兼修未来现观边俗智。于一一谛现观后边。方能兼修。故立斯号。由此余位未能兼修。自谛所为未圆满故。有言若此于法智位修。应说名为现观中俗智。经不应立现观边名。三位所修何胜何劣。若据相续后胜于前。因增长身起彼得故。若就界说。上皆胜下。故前所修色界系者。界胜身劣。后位所修欲界系者。界劣身胜。此有四句。如理应思。道类智时何不修此。此智唯是见道眷属。彼修道摄。故不能修。此意说言。修七处善为种子故。见道得生。故见道生时说彼为眷属。或世俗智从无始来。于三谛中曾知断证。未曾修道。故今不修。或由今时见真道故。伪道羞避。故非所修。或现观边方修此智。道无边故此位不修。谓三谛中依事现观容一行者。总得其边必无有能。遍修道者。异根性道不能修故。于自根性虽容得修。百千分中不起一故。虽见道位未遍断集未遍证灭。而于当位断集证灭其事已周。道类智时迷道谛惑。诸对治道亦不遍修。以种性根有多品故。由此于三谛。世尊说边声。如契经中。说有身边。有身集边。有身灭边。曾无经说有身道边。无能修道至边际故。此世俗智是不生法。于一切时无容起故。此起依身定不生故。谓随信行随法行身。容有为依引此智起。在见道位此无容生。故此依身住不生法。依不生故此必不生。若尔依何说有修义。依得修故说名为修。谓于尔时起得自在。余缘障故体不现前。即由此因说名为得。以证彼得起自在故。以有诸法得即现前。如尽智等。或有诸法先得后现前。如无生智等。或有诸法得永不现前。如此智等。或有诸法不得而现前。如外色等。无有情数法不得而现前。故虽不生而有修义。随于何地见道现前。能修未来自地下地。谓此俗智七地为依。即未至中间四静虑欲界。若依未至见道现前。能修未来一地见道。二地俗智至依第四见道现前。能修未来六地见道。七地俗智苦集边修四念住摄。灭边修者唯法念住。随于何谛现观边修。即以此行相缘此谛为境。谓若苦谛现观边修。即以缘苦四种行相。若欲界系缘欲界苦。色界系者缘上苦谛。若于集谛现观边修。即以缘集四种行相。若欲界系缘欲界集。色界系者缘上集谛。若于灭谛现观边修。即以缘灭四种行相。若欲界系缘欲界灭。色界系者缘上灭谛。此世俗智唯加行得。即由见道加行得故。欲界摄者是思所成。色界摄者是修所成。非闻所成。彼微劣故。智增故立智名。若并随行。以欲四蕴色界五蕴为其自性。次于修道离染位中。颂曰

  修道初刹那　　修六或七智
  断八地无间　　及有欲余道
  有顶八解脱　　各修于七智
  上无间余道　　如次修六八

论曰。修道初念。谓第十六道类智时现修二智。谓道及类名异非体。未离欲者未来修六。谓法及类苦集灭道。离欲修七。谓加他心有顶治故。不修世俗。先已离欲入圣道者。何缘见道中不修他心智。以他心智游观德摄。依容豫道方有修义。见道位中为观谛理。加行极速。故不能修。无间道中义亦同此。今第十六道类智时。容豫道收。故修此智。断欲修断。九无间道。八解脱道俗四法智。随应现修。断上七地。诸无间道。四类世俗。灭道法智。随应现修。断欲加行。有欲胜进。俗四法类。随应现修。此上未来皆修七智。谓俗法类苦集灭道断有顶地。前八解脱四类二法随应现修。此于未来亦唯修七。然除世俗。加他心智。断有顶地九无间道四类二法随应现修。未来修法类苦集灭道。六断欲修断。第九解脱俗四法智随应现修。断上七地诸解脱道四类世俗。灭道法智随应现修。断欲修断第九胜进。断上八地诸加行道。俗四法类。随应现修断上七地。有顶八品诸胜进道。俗四法类及他心智。随应现修。先所修通容现前故。此上未来皆修八智。谓俗法类四谛他心。四类不能断欲界染。苦集二法非上对治。何缘起彼治。此智未来修。若许兼修非对治者。离有顶染等。应兼修世俗。此难非理。唯同对治。于未来修。非所许故。谓亦许有相属故修。如见道中修世俗智。或由因力相资故修。如断欲时。兼修四类。断上染位。修苦集法。若断欲染。不修类智。断上不修。苦集二法。则渐次得不还果者。应无容起类智现前。阿罗汉应无起苦集法智先所得者。皆已舍故。先未得者非所修故。由约种类。若先已得为同类因。力引等流智生。此智由先彼智引故。于彼智类复能为因。故此智生。因力资彼。虽非同治。亦未来修。次辩离染得无学位。颂曰

  无学初刹那　　修九或修十
  钝利根别故　　胜进道亦然

论曰。无学初念。谓断有顶第九解脱。苦集类尽随应现修。缘有顶故胜进九十随应现修。未来随应修九修十。谓钝根者唯除无生。利根亦修无生智故。次辩余位修智多少。颂曰

  练根无间道　　学六无学七
  余学六七八　　应八九一切
  杂修通无间　　学七应八九
  余道学修八　　应九或一切
  圣起余功德　　及异生诸位
  所修智多少　　皆如理应思

论曰。学位练根诸无间道四法类智随应现修。未来修六。四谛法类似见道故不修。世俗能断障故不修。他心诸解脱道四法类智随应现修。未离欲者未来修六四谛法类。已离欲者。未来修七。谓加他心。有余师言。解脱道位亦修世俗诸加行道。俗四法类随应现修。未离欲者未来修七。已离欲八。谓加他心诸胜进道。若未离欲俗四法类。随应现修。未来亦七。若已离欲。俗四法类及他心智随应现修。未来亦八。无学练根诸无间道四类二法。随应现修。未来修七。四谛法类尽。不修世俗。如治有顶。故五前八解脱四类二法。随应现修。未来修八。四谛法类。他心及尽四第九解脱苦集类尽随应现修。未来修九。最后解脱苦集类尽。随应现修。未来修十。诸加行道。现修如学未来修九。诸胜进道。钝者九智。随应现修。未来亦九。利者十智。随应现修。未来亦十。学位杂修诸无间道四法类俗。随应现修。未来修七。诸解脱道唯四法类。加行增俗诸胜进道。又加他心随应现修。未来皆八。无学杂修诸无间道。现修如学。未来所修。钝八利九。诸解脱道唯四法类。加行增俗。随应现修。未来所修。钝九利十。诸胜进道。与练根同。学位修通五无间道。现修俗智。未来修七。宿住神境。二解脱道。五加行道。现修俗智。他心解脱。法类道俗。及他心智。一切胜进。并苦集灭。随应现修。此上未来。皆修八智。无学修通五无间道。现修如学。未来所修。钝八利九。解脱加行。现修如学。未来所修。钝九利十。诸胜进道与练根同。天眼天耳二解脱道无记性故。不名为修。圣起所余四无量等。修所成摄。有漏德时。现在皆修一世俗智。有学未来。未离欲七。已离欲八。无学未来。钝九利十。除微微心。此于未来唯修俗故。若起所余无漏功德静虑摄者。四法类智随应现修。无色摄者。唯四类智随应现修。未来所修同前有漏。异生离染现修俗智。断欲三定。第九解脱。及依根本。四静虑定。起胜进道。离染加行。未来修二。谓加他心。所余未来。唯修世俗。修五通时。诸加行道。二解脱道。现修俗智。一解脱道。现俗他心。诸胜进道。二随应现。未来一切皆修二种。五无间道。现未唯俗。依本静虑。修余功德。皆现修俗。未来修二。唯顺决择分。必不修他心。以是见道近眷属故。依余地定修余功德。皆唯世俗现未来修。诸未来修为修几地。诸所起得皆是修耶。颂曰

  诸道依得此　　修此地有漏
  为离得起此　　修此下无漏
  唯初尽遍修　　九地有漏德
  生上不修下　　曾所得非修

论曰。诸道依此地。及得此地时。能修未来此地有漏谓。依此地世俗圣道现在前时。未来唯修此地有漏。以有漏法系地坚牢难修余故。随依何地离下地染。第九解脱现在前时。亦修未来所得上地根本近分有漏功德。离下地缚必得上故。圣为离此地。及得此地时。并此地中诸道现起。皆能修此及下无漏。谓随何地有漏无漏。加行等道正现在前。为欲断除此地烦恼。未来修此及下无漏。下于上染同能治故。虽下圣道断烦恼时。诸上地边有能同治。然由有漏系地坚牢。未离下时未能修彼。有说亦修彼起彼断得故。随依何地离下地染。第九解脱现在前时。亦修未来所得上地及诸下地无漏功德。随起此地世俗圣道现在前时。未来皆修此及下地无漏功德。唯初尽智现在前时。力能遍修九地有漏意地所摄闻思修所成不净观等无量胜功德。谓随何地尽智现前。通修未来自上下地。何缘唯此初尽智时。力能遍修诸有漏德。创能殄灭无始时来一切善根烦恼怨故。如有摧伏国所共怨。一切俱来庆赖称善。又烦恼缚断无余故。如能缚断所缚气通。又彼心王登自在位。一切善法起得来朝。譬如大王登祚灌顶。一切境土皆来朝贡。然此生上必不修下。谓身在欲得阿罗汉。通修三界九地善根。至生有顶唯修一地。初尽智言。显离有顶及五练根位第九解脱道。皆舍前道创得果故。于见道位三类智边。虽亦能修自下俗智。先已说故此不复论。诸所言修。唯先未得。今起今得。是能所修。谓若先时未得今得。用功得者方是所修。若法先时曾得弃舍。今虽还得而非所修。非设劬劳而证得故。若于先时未得而起。极用功起势力胜故。此方能修未来功德。若先已得今起现前。彼不能修未来功德。非多功起势力劣故。修用止息故。不能修未来。若曾得现前。能修未来者。则薄伽梵得尽智时。应未具修一切功德。为具证得应更进修。便同二乘功德不满。为唯约得说名为修。不尔云何修有四种。一得修。二习修。三对治修。四除遣修。如是四修依何法立。颂曰

  立得修习修　　依善有为法
  依诸有漏法　　立遣修治修

论曰。诸未曾得功德现前。及得未来所余功德。杂修得故皆名得修。曾得未曾功德现起。现修习故皆名习修。此二但依善有为立。未来唯得现具二修。于身等法得能治故。所治身等名对治修。故于身等得对治时。即说名为修于身等。余有漏法类亦应然。缘身等境烦恼断故。说身等法名除遣修。故缘身等烦恼断时。亦说名为修于身等。余有漏法例亦应然。此二但依有漏法立。故有漏善具足四修。无漏有为余有漏法。如次各具前后二修。有于此中约当修义。分别诸法具修多少。有法具四。名为当修。有法具三。有法具二。有法具一。有法全无。谓善有漏未永断时。可得可生具足四种。此未永断故。当具治遣修。以可得故当具得修。是可生故当具习修。已得可生具三。除得可得。不生具三。除习已得。不生及不可得已生具二。谓治遣修染及无记。未断亦尔。若善有漏已永断时。可得可生具得习二。可得不生具一。谓得已得可生具一。谓习有为无漏应知亦尔。除前所说皆是全无。谓无漏法中已得不生等。若不生法不住身中。但由得故即名修者。应许择灭亦名为修。无差别故。此难非理。彼同类法住身中故。谓不生法虽不住身。同类住身名修无失。又彼由得为果住故。谓未来世不生善法。由令得生表为果住。义言我等阙缘不生。非谓今时不蒙招引。择灭异此。不可为例。又未来世不生善法。亦有因力摄益现身。择灭不然。故无修义。又由择灭唯是果故。谓修本为获得胜果。灭非有果。故不应修。又由择灭无增减故。谓可修法依下至中依中至上。择灭不尔。于修无用。故不可修。如是已辩诸智差别。智所成德今当显示。于中先辩佛不共德。且初成佛尽智位修。不共佛法有十八种。何谓十八。颂曰

  十八不共法　　谓佛十力等

论曰。佛十力四无畏三念住及大悲。如是合名为十八不共法。唯于诸佛尽智时修。余圣所无。故名不共。且佛十力差别云何。颂曰

  力处非处十　　业八除灭道
  定根解界九　　遍趣九或十
  宿住死生俗　　尽六或十智
  宿住死生智　　依静虑余通
  赡部男佛身　　于境无碍故

论曰。佛十力者。一处非处智力。具以如来十智为性。知一切法自性功能。理定是有。名为处智。知一切法自性功能。理定非有。名非处智。此智通缘情非情境。与一切智皆不相违。恐于略说少功难悟。故复此中析出余九。二业异熟智力。八智为性。除灭道智谓善分别如是类业感如是类诸异熟果。无挂碍智。名业异熟智力。或说名为自业智力。谓善分别如是类果是自所造业力所招。非妻子等所能与夺。如是类业必招自果。不可贸易。无挂碍智。名自业智力。三静虑解脱等持等至智力。四根上下智力。五种种胜解智力。六种种界智力。如是四力皆九智性。唯除灭智。谓如实知诸静虑等自性名得方便摄持味净无漏顺退住进决择分等。无挂碍智。名静虑等智力。静虑等相。定品当辩。若如实知诸有情类。能逮胜德根品差别。无挂碍智。名根上下智力。虽有中根而待胜劣。是劣胜摄。故不别显。此中根名为目何法。谓目信等断善根者。总相续中亦有去来。信等善法或目意等。若如实知诸有情类喜乐差别。无挂碍智名种种胜解智力。喜乐胜解名差别故。若如实知诸有情类前际无始数习所成志性随眠及诸法性种种差别。无挂碍智。名种种界智力。应知此中界与志性随眠法性。名之差别。如是四力并缘有为。故十智中惟摄九智。七遍趣行智力。或声显此义有二途。若谓但缘诸能趣道九智除灭。若谓兼缘道所趣果十智为性。谓如实知生死因果。及知尽道。无挂碍智。名遍趣行智力。八宿住随念智力。九死生智力。如是二力皆俗智性。此二力相有差别故。谓如实知自他过去宿住差别。无挂碍智。名第八力。若如实知诸有情类于未来世诸有续生。无挂碍智。名第九力。广辩此二如六通中。十漏尽智力。或声亦显义有二途。若谓但缘漏尽为境。六智除道苦集他心。若谓兼缘漏尽方便十智为性。理应如是。以辩相中言于尽及为尽。无挂碍智。二种俱名漏尽智力。此后三力即是三通。以六通中此三殊胜。在无学位立为三明。在如来身亦名为力。神境天耳设在佛身亦无大用。故不名力。且如天眼能见有情善恶趣中异熟差别。由此能引殊胜智生。亦正了知能感彼业。由此建立死生智名。神境天耳无此大用。是故彼二不立为力。然不别说他心力者。义已摄在根等力中。以他根等中有心心所故。又薄伽梵具一切智。于工论等亦得自在。而于佛事齐此已成。余智于中无别胜用。是故虽有亦不别说。唯依遍觉十种所知。佛所应为皆圆满故。何等名曰十种所知。谓诸法中因非因义。多分散地业果差别。定地功德品类不同。所化有情根解界异。所治能治因果差别。前际后际经历不同。离染不续方便有异。但由觉此佛事已成。余设有无。不致益损。故唯十种得名为力。又佛观察所化有情。设教应机唯须十智。谓由初智观所化生。于诸乘中堪无堪异。由第二智观所化生。于相续中业障差别。由第三智观所化生。于静虑等有味无味。烦恼为障。轻重差别。由知此二因。亦知异熟障。由第四智观所化生。趣清净品功能差别。由第五智观所化生。于证净品加行差别。由第六智观所化生。于证净品禀志性别。由第七智观所化生。诸所施为有益无益。种种差别正观修止。由弟八智观所化生。过去世中所集差别。由弟九智观所化生。当来世中结生差别。由弟十智观所化生。所证解脱方便有异。于此十智若随阙一。便不具足化有情事。多复无用。故不增减。已辩自性。依地别者。第八第九依四静虑。余八通依十一地起。欲四静虑未至中间。并四无色名十一地。诸胜德地总有尔所。已辩依地依身别者。皆依赡部男子佛身。唯此堪为力所依故。如是十智二乘亦有。何故在佛方受力名。夫受力名。谓无碍转。佛智于境。无碍转故得名为力。余则不然。以诸二乘尚不能见诸有情相续顺解脱分善。况复能知所余深细。如舍利子舍求度人。不能观知鹰所逐鸽。前后二际生多少等。大目干连不能观见业风所引诸鬼差别。是故二乘天眼通等。观界远近与佛有殊。非无碍故。不名为力。二乘与佛漏尽既同。彼智何缘唯佛名力。唯世尊有遍达有情一切漏尽别相智故。谓薄伽梵于诸有情一切漏尽品类差别智无挂碍。二乘不然。是故力名唯属于佛。又唯诸佛智猛利故。如何猛利佛智力能。速断烦恼并习气故。如强弱力补特伽罗执利钝刀斩截草等。诸有情类蕴相无别。佛如何观有种种界。诸有情类蕴相虽同。而于其中非无差别。谓彼诸蕴体虽无异。而有无量品类不同。佛如量知都无挂碍。故世尊得有种种界智力。或诸如来名称高远。希有智慧妙用无边。唯佛能知非余所测。于余所了无别相中。何怪如来能知别相。已辩诸佛心力方隅。当辩菩萨时亦所成身力。颂曰

  身那罗延力　　或节节皆然
  象等七十增　　此触处为性

论曰。佛生身力等那罗延。有余师言。佛身支节一一皆具那罗延力。理实诸佛身力无边犹如心力能持无上正等菩提大功德故。大觉独觉及转轮王。支节相连如其次第。似龙幡结连锁相钩。故三相望力有胜劣。那罗延力其量云何。十十倍增象等七力。谓凡象香象摩诃诺健那钵罗塞建提伐浪伽遮怒罗那罗延。后后力增前前十倍。有说前六十十倍增敌那罗延半身之力。此力千倍成那罗延。有余师说。此量如千蔼罗伐拏天象王力。此象王力其量云何。三十三天将游戏苑。象王知已化作诸头。种种庄严往天宫所。诸天眷属数有多千。乘已腾空如持桦叶。速至戏苑随意欢娱。天大象王力势如是。此力千倍等那罗延。于诸说中唯多应理。如是身力触处为性。此应总是诸触差别。有说唯是大种差别。有说是造触离七外。有有说力是重劣者是轻。如是名为佛生身力。佛四无畏相别云何。颂曰

  四无畏如次　　初十二七力

论曰。佛四无畏。如经广说。一正等觉无畏。十智为性。犹如初力。二漏永尽无畏。六十智性。如第十力。三说障法无畏。八智为性。如第二力。四说出道无畏。九十智性。如第七力。何缘诸佛无畏唯四。但由此量显佛世尊自他圆德俱究竟故。谓初无畏显佛世尊自智圆德。第二无畏显佛世尊自断圆德。此二显佛自利德满。为显世尊利他圆德。是故复说后二无畏。第三无畏遮行邪道。第四无畏令趣正道。谓佛处处为诸弟子说障法令断除。即是令修断德方便。又于处处为诸弟子说出道令正行。即是令修智德方便。此二显佛利他德满。但由此四随其所应显佛自他智断圆德。至究竟故。唯立四种。如何可说无畏即智应言无畏。是智所成。理实应然。但为显示无畏。以智为亲近因。是故就智出无畏体。夫无畏者。谓不怯惧。由有智故不怯惧他。故智得为无畏因性。唯佛四妙智。是四无畏因。谓诸如来于一切法一切相妙智。是初无畏因。若诸如来一切烦恼并习气断妙智。是第二无畏因。若诸如来知弟子众有损有益妙智。是后无畏因。或无畏体即四妙智。怯惧名畏。此即于法无所了达。怀恐怖义。智于此畏有近治能。与畏相违。故名无畏。岂不非无智即是畏体。如何说智体即是无畏。此责不然。智与多法为近治故。如即无疑。谓智如能近治无智。亦于怖畏有近治能。故得智名。亦名无畏。如治无智亦能治疑。故得智名。亦名决定。所治无智虽不即疑。而智无疑。名二体一。如是无智虽与畏殊。而无畏名即目智体。一善能断多恶法故。有说无智亦摄畏体。故于此中不应为难。力与无畏有何差别。此无差别体俱智故。然于智体别义名力。复依别义立无畏名。谓不屈因说名为力。不怯惧因说名无畏。或初安立说名为力。立已不动说名无畏。或非他伏说名为力。能摧伏他说名无畏。有余师说。譬如良医遍达医方。说名为力。善疗众疾说名无畏。有说骁健说名为力。勇悍不怯说名无畏。如是二种义亦有别。谓成办事义是力义。不怯惮义是无畏义。佛三念住相别云何。颂曰

  三念住念慧　　缘顺违俱境

论曰。佛三念住如经广说。诸第子众一向恭敬。能正受行。如来缘之不生欢喜。舍而安住正念正知。是谓如来第一念住。诸第子众唯不恭敬。不正受行。如来缘之不生忧戚。舍而安住正念正知。是谓如来第二念住。诸弟子众一类恭敬。能正受行一类不敬不正受行。如来缘之不生欢戚。舍而安住正念正知。是谓如来第三念住。虽有所化不敬受行。而佛世尊亦雨法雨。由此方便彼于余时。或余有情入正法故。非前说四。今复说三。可总说言念住有七。今三摄在前四中故。谓在缘外法念住摄。然此三种体通念慧。谓由安住正念正知。于三境中不生欢戚。不可见有诸大声闻。于三境中不生欢戚。便谓此三种非佛不共法。唯佛于此并习断故。善达有情种性别故。或弟子众随属如来。有顺违俱应甚欢戚。佛能不起。可谓希奇。非属诸声闻。不起非奇特。故唯在佛得不共名。诸佛大悲云何相别。颂曰

  大悲唯俗智　　资粮行相境
  平等上品故　　异悲由八因

论曰。如来大悲俗智为性。普缘一切有情为境。作苦苦等三行相故。非无漏智。有如是理。此大悲名。依何义立。依五义故。此立大名。一由资粮故大。谓大福德智慧资粮所成办故。二由行相故大。谓此力能于三苦境作行相故。三由所缘故大。谓此总以三界有情为所缘故。四由平等故大。谓此等于一切有情作利乐故。五由上品故大。谓最上品更无余悲。能齐此故。有余师说。由大加行所证得故。唯大士身所成就故。入大功德珍宝数故。能拔有情大苦恼故。立大悲名。悲与大悲有何差别。此二差别由八种因。一由自性。无嗔无痴自性异故。二由依身。通余唯佛依身异故。三由行相。一苦三苦行相异故。四由所缘。一界三界所缘异故。五由依地。通余第四静虑异故。六由证得。离欲有顶证得异故。又悲为先。离染时得。唯离染得。有差别故。七由救济希望事成。救济异故。八由哀愍平等不等。哀愍异故。有余师说。诸佛大悲远细遍随。能普饶益。声闻等类。所起悲心。不能悲愍色无色界。佛于上界起极悲愍。心过于二乘。悲愍无间狱。已辩佛德异余有情。诸佛相望法皆等不。颂曰

  由资粮法身　　利他佛相似
  寿种性量等　　诸佛有差别

论曰。由三事故诸佛皆等。一由资粮等圆满故。二由法身等成办故。三由利他等究竟故。由寿种性身量等殊。诸佛相望容有差别。寿异谓佛寿有短长。种异谓佛生刹帝利婆罗门种。姓异谓佛姓乔答摩迦叶波等。量异谓佛身有小大。等言显诸佛法住久近等如是有异。由出世时所化有情机宜别故。诸有智者思惟如来三种圆德深生爱敬。其三者何。一因圆德。二果圆德。三恩圆德。初因圆德复有四种。一无余修。福德智慧二种资粮修无遗故。二长时修。经三大劫阿僧企耶修无倦故。三无间修。精勤勇猛刹那刹那修无废故。四尊重修。恭敬所学无所顾惜修无慢故。次果圆德亦有四种。一智圆德。二断圆德。三威势圆德。四色身圆德。智圆德有四种。一无师智。二一切智。三一切种智。四无功用智。断圆德有四种。一一切烦恼断。二一切定障断。三毕竟断。四并习断。威势圆德有四种。一于外境化变住持自在威势。二于寿量若促若延自在威势。三于空障极远速行小大相入自在威势。四令世间种种本性法尔转胜希奇威势。威势圆德复有四种。一难化必能化。二答难必决疑。三立教必出离。四恶党必能伏。色身圆德有四种。一具众相。二具随好。三具大力。四内身骨坚越金刚。外发神光踰百千日。后恩圆德亦有四种。谓令永解脱三恶趣生死。或能安置善趣三乘。总说如来圆德如是。若别分折则有无边。唯佛世尊能知能说。要留命行经多大劫阿僧企耶说乃可尽。如是则显佛世尊身具有无边殊胜奇特因果恩德如大宝山。有诸愚夫自乏众德。虽闻如是佛功德山及所说法。不能信重。诸有智者闻说如斯。生信重心彻于骨髓。彼由一念极信重心。转灭无边不定恶业。摄受殊胜人天涅槃。故说如来出现于世。为诸智者无上福田。依之引生不空可爱。殊胜速疾究竟果故。如薄伽梵自说。颂言

  若于佛福田　　能殖少分善
  初获胜善趣　　后必得涅槃

说一切有部显宗论卷第三十六阿毗达磨藏显宗论卷第三十七

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩智品第八之三

已说如来不共功德。共功德今当辩。颂曰

  复有余佛法　　共余圣异生
  谓无诤愿智　　无碍解等德

论曰。世尊复有无量功德。与余圣者及异生共。谓无诤愿智无碍解通静虑无色等至等持无量解脱胜处遍处等。随其所应。谓前三门唯共余圣。通静虑等亦共异生。虽佛身中一切功德行相清净殊胜自在与声闻等功德有殊。然依类同。说名为共。且共余圣三功德中。无诤云何。颂曰

  无诤世俗智　　后静虑不动
  三洲缘未生　　欲界有事惑

论曰。有阿罗汉忆昔多生。受杂类身发自他惑。由斯相续受非爱果。便作是念。有烦恼身缘之起惑。尚招苦果。况离烦恼具胜德身。思已发生如是相智。由此方便令他有情不缘己身生贪嗔等。此智但以俗智为性。缘他未来修断惑故。非无漏智此行相转。若无诤体是智所摄。如何说习无诤等持。此不相违。一相应品。有多功德。随说一故。如一山中有种种物。随举一种以标山名。理应无诤。是智所摄。护他相续当来惑生。巧便为先事方成故。然一切诤总有三种。蕴言烦恼。有差别故。蕴诤谓死。言诤谓斗。烦恼诤谓百八烦恼。由此俗智力。能止息烦恼诤。故得无诤名。此智但依第四静虑。违苦因故。第四静虑乐通行中最为胜故。不动应果能起非余。余尚不能自防起惑。况能止息他身烦恼。此唯依止三洲人身。非北及余。性猛利故。缘欲未起有事惑生。勿令他惑缘我生故。诸无事惑不可遮防。内起随应总缘境故。已辩无诤。愿智云何。颂曰

  愿智能遍缘　　余如无诤说

论曰。以愿为先引妙智起。如愿而了。故名愿智。此智自性地种姓身与无诤同。但所缘别。以一切法为所缘故。如何愿智能知未来。审观过现而比知故。如观稼穑有盛有微。比知其田有良有薄。若尔何故立愿智名。有学异生亦能知故。不尔所知定不定故。而闻传说诸大声闻记未来事有不定者。非起愿智有此谬知。余俗智观所记别故。或彼所记无不定失但观于始不观终故。如先降雨未至地间。为罗怙罗之所承弃。先所怀孕其实是男。彼于后时转形成女。王舍城鬼初战得胜。后为广严诸鬼摧伏。人欲相伐鬼先战故。或实愿智方见未来。然加行时先起比智。观过现世准度未来。引愿智生方能真见。即由此故能知无色。谓先观彼因行等流。有比智生引真愿智。或观欲色死生时心。比度而知所生从处。引生愿智方能实知。或比智知亦无有失。以证比智所缘必同。若比不知如何能证。是则愿智应不可言力能遍缘三界三世。不时解脱诸阿罗汉。欲于彼境正了知时。先作要期。愿我知彼。后入边际第四静虑。以为加行。从此无间如先愿力引正智起。于所期境皆如实知。边际定言。如后当释。此愿智力能知过去。与宿住智差别云何。愿智通知自相共相。诸宿住智知共非余。知共相中亦有差别。愿智明了。宿住不然。于现所缘对他心智。辩差别相如理应思。已辩愿智。无碍解云何。颂曰

  无碍解有四　　谓法义词辩
  名义言说道　　无退智为性
  法词唯俗智　　五二地为依
  义十六辩九　　皆依一切地
  但得必具四　　余如无诤说

论曰。诸无碍解总说有四。一法无碍解。二义无碍解。三词无碍解。四辩无碍解。此四总说如其次第。以缘名义言及说道。不可退转智为自性。谓无退智缘能诠法名句文身立为第一。趣所诠义。说之为名。即是表召法自性义辩所诠义。说之为句。即是辩了法差别义。不待义声独能为觉生所依托。说之为文。即是迦遮吒多波等。理应有觉不待义声。此觉不应无所缘境。此所缘境说之为文。文谓不能亲目于义。但与名句为诠义依。此三能持诸所诠义及轨生解。故名为法。即三自性。说之为身。自性体身名差别故。三与声义极相邻杂。为境生觉别相难知。故说身言显有别体。若无退智缘一切法。所有胜义立为第二义。即诸法自相共相。虽名身等亦是义摄。而非胜义有多想故。谓有如义有不如义。有有义有无义。有依假转有依实转。了此无间。或于后时诸所度量。名为胜义。为欲显示义无碍解。所缘之境非语及名。故此所缘说为胜义。谓此但取依语起名。名所显义非取泛尔。心之所行说名为义。若无退智缘诸方域。俗圣言词立为第三。即能了知世语典语。于诸方域种种差别。若无退智缘应正理无滞碍说。及缘自在定慧二道立为第四。即于文义能正宣扬无滞言词。说名为辩。及诸所有已得功德。不由加行任运现前自在功能。亦名为辩。此能起辩立以辩名。了辩及因智。名辩无碍解。即前所说能正宣扬善应物机不违胜义。所有言说名应正理。即前所说无滞言词。不待处时及有情等。辩析自在名无滞碍。即上所言已得功德。不由加行任运现前。名为自在。定慧二道又能所诠相符会智名初二无碍解。谓达此名属如是义。及达此义有如是名。名能所诠相符会智达时作等加行言词。名第三无碍解。达所乐言说及自在道因。名第四无碍解。又色等六所知谓义。即此善等有为无为色非色等差别谓法。即诠此二言说谓词。三智即前三无碍解。即缘三种无挂碍智。名第四无碍解。又达世俗胜义二谛。名初二无碍解。此即行者自利圆德。能善宣说如是二谛。名第三无碍解。于此善巧问答难通。名第四无碍解。此即行者利他圆德。有说愚痴犹豫散乱。是于宣辩有滞碍因。由解脱此三。得现法乐住。及由此故利他行成。此智名为辩无碍解。若得如是定能宣说。符会正理无滞言词。及得现前自在功德。又于名等胜义言词。无滞说中各得善巧。如次建立四无碍解。前三善巧说名为因。由境不同故有差别。第四名果能说无滞。又由四分利他事成。谓巧于文了达于义。妙闲声韵定慧自在。故无碍解建立有四。此即总说无碍解体。兼显四种所缘差别。契经略举此数及名。诸对法中广显其相。又经列此先义后法。诸对法中先法后义。此为显示二智生时。或义因名或名因义。故经与论作差别说。谓听法者先分别名。既正知名次寻其义。正知义已欲为他说。次必应求无滞说智。依此次第故名在先。然此四中义智最胜。余是助伴。故义在先。谓于义中若正了达。次应方便寻究其名。既已知名欲为他说。次应于说求巧便智。是故此四次第如是。辩无碍解若缘说时。何异第三词无碍解。第三了达训释言词。如有变碍。故名色等。此达应理无滞碍说。有说词诠诸法自性。辩能显示诸法差别。有说于法直说名词。展转无滞分折名辩。缘此二种三四有别。四中法词俗智为性。非无漏智。缘名身等及世言词事境界故。法无碍解通依五地。谓依欲界。四本静虑上地中无名身等故。彼不别缘下名等故。词无碍解唯依二地。谓依欲界初本静虑。上诸地中无寻伺故。彼地必无自语言故。此因非理。所以者何。非发语智名无碍解。勿无碍解定中无故。由此不应作如是说。无寻伺故上地中无。无斯过失。因义异故。何谓因义。谓此意言。寻伺二法能发语故。相不寂静自性粗动。上无此故寂静微细。词无碍解缘外言词。亦不寂静粗动类摄。是故此解上地中无。初静虑中亦有寻伺。故于定内亦有此解。由此极成但依二地义无碍解十六智性。谓若诸法皆名为义。则十智性。若唯涅槃名为义者。则六智性。谓俗法类灭尽无生。辩无碍解九智为性。谓唯除灭缘说道故。此二通依一切地起。谓依欲界乃至有顶。辩无碍解于说道中许随缘一皆得起故。通依诸地。亦无有失。然于其中但缘说者。唯依二地与第三同。有说尽无生非无碍解摄。以无碍解是见性故。彼说第二或四或八。第四唯七。准上应知。此四应知。如四圣种。随得一种必具得四。非不具四可名为得。随欲现起或具不具。有余师言。有不具得无理得一必令得四。有说此四无碍解生。如次串习算计佛语。声明因明为前加行。若于四处未得善巧。必不能生无碍解故理实一切无碍解生。唯学佛语能为加行要待前生久。习名等四种善巧。今乃能修。无碍解名释有多义。谓于彼彼境领悟无碍。名无碍解。或于彼彼境决断无碍。名无碍解。或于彼彼境正说无碍。名无碍解。有余师说。于境现前无颠倒智。名无碍解。此四依地自性所缘与无诤别。前来已辩种性依身如无诤说。谓不动种性依三洲人身。如是所说无诤智等。颂曰

  六依边际得　　边际六后定
  遍顺至究竟　　佛余加行得

论曰。无诤愿智四无碍解。六种皆依边际定得。边际定力所引发故。边际静虑体有六种。前六除词余五少分。及除此外复更有余加行所得。上品静虑名边际定。故成六种词无碍解。虽依彼得而体非彼静虑所摄。边际名但依第四静虑故。此一切地遍所随顺故。增至究竟故得边际名。由此不应亦通余地。云何此名遍所随顺。谓正修学此静虑时。从初静虑次第顺入。乃至有顶。复从有顶次第逆入。至初静虑。从初静虑次第顺入。展转乃至第四静虑。名一切地遍所随顺。云何此名增至究竟。谓专修习第四静虑。从下至中从中至上。如是三品复各分三。上上品生名至究竟。如是静虑得边际名。此中三乘非无差别。而各于自得究竟名。此中边名显无越义余无越此。故名为边际言。为显类义极义。如说四际及实际言。如是二言显此静虑是最胜类定中最极。殊胜功德多此引生。乐通行中此最胜故。如是所说无诤智等。除佛余圣唯加行得。非离染得。非皆得故。唯佛于此亦离染得。诸佛功德初尽智时。由离染故一切顿得。后时随欲能引现前。不由加行。以佛世尊于一切法自在转故。已辩前三唯共余圣德于亦共凡德且应辩通。颂曰

  通六谓神境　　天眼耳他心
  宿住漏尽通　　解脱道慧摄
  四俗他心五　　漏尽通如力
  五依四静虑　　自下地为境
  声闻麟喻佛　　二三千无数
  未曾由加行　　曾修离染得
  三身一余三　　一法后法四
  天眼耳无记　　余四通唯善

论曰。通有六种。一神境智证通。二天眼智证通。三天耳智证通。四他心智证通。五宿住随念智证通。六漏尽智证通。虽六通中第六唯圣。然其前五异生亦得依总相说亦共异生。如是六通解脱道摄。慧为自性。如沙门果。解脱道言显出障义。胜进道中亦容有故。如是通慧无间道无。此位定遮他心智故。勿阿罗汉舍无间道即名亦舍漏尽通故。除他心漏尽。余四俗智摄。他心通五智摄。谓法类道世俗他心漏尽通如力说。谓或六或十智。由此已显漏尽智通。依一切地缘一切境。前之五通依四静虑。不依无色近分中间。彼无五通所依定故。要摄支定是五通依。非漏尽通亦不依彼。诸地皆能缘漏尽故。不待观色为加行故。前三通境无色不能缘。由此三通但别缘色故。修他心通色为门故。修宿住通渐次忆念。分位差别方得成满。于加行中必观色故。依无色地无如是能。若尔中间及五近分。亦容缘色应有五通。不尔由前所说因故。谓摄支定是五通依。若不摄支等持劣故。又彼止观随一减故。若尔何缘有漏尽通。乐苦迟速地。皆能尽漏故。五是别修殊胜功德。要殊胜地方能发起。修神境等前三通时。思轻光声以为加行。成已自在随所欲为。诸有欲修他心通者。先审观己身心二相。前后变异展转相随。后复审观他身心相。由此加行渐次得成。成已不观自心诸色于他心等能如实知。诸有欲修宿住通者。先自审察次前灭心。渐复逆观此生分位。前前差别至结生心。乃至能忆知中有前一念名自宿住。加行已成为忆念他加行亦尔。此通初起。唯次第知。惯习成时。亦能超忆诸所忆事。要曾领受忆净居者。昔曾闻故。从无色殁来生此者。依他相续初起此通。所余亦依自相续起。如是五通境唯自下。且如神境随依何地。于自下地行化自在。于上不然势力劣故。余四亦尔。随其所应。是故无能取无色界。他心宿住为二通境。即此五通于世界境。作用广陜诸圣不同。谓大声闻麟喻大觉。不极作意如次能于一二三千诸世界境。起行化等自在作用。若极作意。如次能于二千三千无数世界如是五通。若有殊胜势用猛利从无始来曾未得者。由加行得。若曾串习无胜势用及彼种类。由离染得。若起现前皆由加行。佛于一切皆离染得。随欲现前不由加行。三乘圣者后有异生。通得曾得未曾得者。所余异生唯得曾得。约四念住辩六通者。约境约体二义有殊。有说二通即天眼耳。所余四种以慧为性。彼说眼耳通是身念住境。余四皆是法念住境。然实六种皆慧为性。经说皆能了达境故。由此皆是法念住境。若约体辩。则六通中前三唯身。但缘色故。谓神境通缘外四处。天眼缘色。天耳缘声。若尔何缘说死生智。知有情类由现身中成身语意诸恶行等。非天眼通。能知此事有别胜智。是通眷属依圣身起。能如是知。是天眼通力所引故。与通合立死生智名。他心智通三念住摄。谓受心法缘心等故。宿住智通法念住摄。虽契经说念曾领受苦乐等事。是忆前生苦乐等受。所领众具即是杂缘。法念住摄漏尽如力或法或四。若约善等分别六通。有余师言。六皆是善。而实眼耳唯无记性。余之四通一向是善。经主于此作是释言。天眼耳通无记性摄。是眼耳识相应慧故。此释不然。六通皆是解脱道摄。眼耳二识是解脱道。理不成故。应作是说。四静虑中有定相应胜无记慧。能引自地胜大种果。此慧现前便引自地天眼天耳令现在前。为所依根发眼耳识。故眼耳二识相应慧非通。但可说言是通所引。如契经说无学三明。彼于六通以何为性。颂曰

  第五二六明　　治三际愚故
  后真二假说　　学有闇非明

论曰。有三明者。一宿住智证明。二死生智证明。三漏尽智证明。如其次第以无学位摄。第五二六通为其自性。六中三种独名明者。如次对治三际愚故。谓宿住通治前际愚。死生智通治后际愚。漏尽智通治中际愚。是故此三独摽明号。又宿住通忆念前际自他苦事。死生智通观察后际他身苦事。由此厌背生死众苦。起漏尽通观涅槃乐。故唯三种偏立为明。又此三通如次能舍常断有见。故立为明。又此能除有有情法三种愚故。偏立为明。有余师言。宿住能见过去诸蕴。展转相因次第传来都无作者。由此能引空解脱门。死生能观有情生死。下上旋转犹如灌轮。故不希求三有果报。由此能引无愿解脱门。厌离为门谛无相法。故起漏尽无相解脱门。是故三通独摽明号。此三皆名无学明者。俱在无学身中起故。于中最后容有是真通无漏故。余二假说体唯非学非无学故。由此最后得无学名。自性相续皆无学故。前之二种得无学名。但由相续不由自性。如施设论作如是言。有等持相应。无覆无记慧。不由善故。及无漏故。得立圣名。由圣身中此可得故。说名为圣。此亦应尔。故名无学。有学身中有愚闇故。虽有前二不立为明。虽有暂时伏灭愚闇后还被蔽。不可立明。要闇永无。方名明故。契经中说。示导有三。彼于六通以何为性。颂曰

  第一四六导　　教诫导为尊
  定由通所成　　引利乐果故

论曰。三示导者。一神变示导。二记心示导。三教诫示导。如其次第以六通中第一四六为其自性。唯此三种引所化生。令初发心最为胜故。能示能导立示导名。三示导中教诫最胜。定由通所成故。定引利乐果故。谓前二导咒等亦能。不但由通故非决定。如有咒术名健驮梨。持此便能腾空自在。或有药草具胜功能。若服若持飞行自在。复有咒术名伊刹尼。持此便能知他心念。或由观相听彼言音。亦能了知他心所念。教诫示导除漏尽通。余不能为。故是决定。或前二导外道亦能。第三不然。故名决定又前二导。有但令他暂时回心。不能引得毕竟利益及安乐果。教诫示导。亦定令他引当利益及安乐果。以能如实方便说故。由此教诫最胜非余。神境二言为目何义。颂曰

  神体谓等持　　境二谓行化
  行三意势佛　　运身胜解通
  化二谓欲色　　四二外处性
  此各有二种　　谓似自他身

论曰。神名所目唯胜等持。由此能为神变事故。而契经说。神果名神。意为举粗以显细故。又显胜等持是彼近因故。然神变事体实非神。诸神变事说名为境此有二种。谓行及化行复三种。一者运身。谓乘空行犹如飞鸟。二者胜解。谓极远方作近思惟。便能速至。若于极远色究竟天作近思惟。即便能至。本无来去。何谓速行。此实亦行。但由近解行极速故。得胜解名。或世尊言。静虑境界不思议故。唯佛能了。三者意势。谓极远方举心缘时。身即能至。此势如意。得意势名。如心取境顿至色究竟故。于此三中意势唯佛。运身胜解亦通余乘。谓我世尊神通迅速。随方远近举心即至。由此世尊作如是说。诸佛境界不可思议。如日舒光。蕴流亦尔。能顿至远。故说为行若谓不然。此没彼出中间即断。行义应无。或佛威神不思议故。举心即至不可测量。故意势行唯世尊有。胜解兼余圣。运身并异生。化复二种。谓欲色界。若欲界化外四处除声若色界化唯二谓色触以色界中无香味故。此二界化各有二种。谓属自身他身别故。身在欲界化有四种。在色亦然。故总成八。虽生在色作欲界化。而无色界成香味失。化作自身唯二处故有说亦化四。如衣等不成。非神境通能起化事。要此通果诸能化心。此能化心有几何相。颂曰

  能化心十四　　定果二至五
  如所依定得　　从净自生二
  化事由自地　　语通由自下
  化身与化主　　语必俱非佛
  先立愿留身　　后起余心语
  有死留坚体　　余说无留义
  初多心一化　　成满此相违
  修得无记摄　　余得通三性

论曰。能变化心总有十四。谓依根本四静虑生。初静虑生唯有二种。一欲界摄。二初静虑。第二第三第四静虑如其次第有三四五。无上依下。下地劣故。上下地系一静虑果所依行等地有胜劣。一地系上下静虑果地。虽等所依行胜劣下系上果下果上系如次地劣胜所依行胜劣。如得静虑化心亦然。果与所依俱时得故。然得静虑总有三时。离染受生加行异故。谓离下染得上静虑时。亦得此定所引化心果。从上地殁生色界时及由加行起胜功德。但有新得所依静虑。亦兼得彼所引化心。依欲界身得阿罗汉。及练根位得应果时。十四化心一时总得。乃至身在第四静虑。得阿罗汉得五化心。无从化心直出观义。此从净定及自类生。能无间生自类净定。故唯从二生二非余。唯自地化心。起自地化事。化所发语由自下心。谓欲初定化唯自地心语上化起语自初定心彼地自无起表心故。若生欲界第二定等。化事转时如何起表。非威仪路工巧处心依异界身而可现起彼必依止自界身故。此无有过。引彼界摄。大种现前为所依故。谓引色界大种现前。与欲界身密合而住。依之起彼能发表心无定地表心依散地身过。或起依定能发表心如依定生天眼耳识。若一化主起多化身。要化主语时诸化身方语言音诠表一切皆同。故有伽他作如是说

  一化主语时　　诸所化皆语
  一化主若默　　诸所化亦然

此但说余。佛则不尔。诸佛定力最自在故。与所化语容不俱时。言音所诠亦容有别。若上三地所化语时。初定表心现前发者此心起位已出化心。应无化身化如何语。由先愿力留所化身。后起余心发语表业。故无化语阙所依过。非唯化主命现在时。能留化身令久时住。亦有令住至命终后。即如尊者大迦叶波。留骨琐身至慈尊世。唯坚实体可得久留。异此饮光应留肉等。有余师说。愿力留身。必无有能令至死后。圣大迦叶留骨琐身。由诸天神持令久住。初习业者由多化心要附所依起一化事习成满者。由一化心能不附所依起众多化事。总有二类能变化心。一修所成。二生得等。所起化果亦如彼说。修所成化摄处如前。不能化为有情身故。生所得等。于欲界中化为九处色界化七。依不离根言化九等。理实无有能化作根修果无心余化容有修果起表。由化主心余容自心起身语表修果饮食。若为资身必在化主身中消化。若为余事吞金石等。或即住彼化事身中。或随所宜置在别处。余化饮食。随住所依。修果化心。唯无记性。余通三性。谓善恶等如天龙等。能变化心。彼亦能为自他身化。天眼耳言。为目何义。为目慧体。为目色根。若慧不应名天眼耳。若色根者。不应名通。此前已说。前何所说。谓说根本四静虑中有定相应。胜无记慧名为天眼。及天耳通。此所引生胜大种果。名天眼耳。其体是何。颂曰

  天眼耳谓根　　即定地净色
  恒同分无缺　　取障细远等

论曰。此体即是天眼耳根。谓缘声光为加行故。依四静虑于眼耳边引起彼地微妙大种所造净色眼耳二根。见色闻声名天眼耳。如是眼耳何故名天。体即是天定地摄故。极清净故。立以天名。由此经言。天眼耳者。无有皮肉筋缠血涂。唯妙大种所造净色。然天眼耳种类有三。一修得天。即如前说。二者生得。谓生天中。三者似天。谓生余趣。由胜业等之所引生能远见闻似天眼耳。如藏臣宝。菩萨轮王诸龙鬼神及中有等修得眼耳。过现当生恒是同分。以至现在必与识俱能见闻故。处所必具无医无缺。如生色界。一切有情能随所应取被障隔极细远等诸方色声。故于此中有如是颂曰

  肉眼于诸方　　被障细远色
  无能见功用　　天眼见无遗

前说化心修余得异神境等五各有异耶。亦有云何。颂曰

  神境五修生　　咒药业成故
  他心修生咒　　又加占相成
  三修生业成　　除修皆三性
  人唯无生得　　地狱初能知

论曰。神境智类总有五种。一修得。二生得。三咒成。四药成。五业成。曼驮多王及中有等诸神境智。是业成摄。有余师说。神境有四。即前作三变化为一。言变化者。如契经言。分一为多。乃至广说。他心智类总有四种。前三如上。加占相成。余三各三。谓修生业。除修所得。皆通善等。非定果故。不得通名。人中都无生所得者。余皆容有随其所应。本性生念业所成摄。人由先业能忆过去。于地狱趣初受生时。唯以生得他心宿住。知他心等及过去生。苦受逼已更无知义。彼忆过去以何证知如契经言。彼自忆念。我等过去曾闻他说诸欲过失而不厌离。故于今时受斯剧苦。彼唯能忆次前一生。余趣随应恒有知义。傍生知过去如螺声狗等鬼知过去。如有颂言

  我昔集众财　　以法或非法
  他今受富乐　　我独受贫苦

天知过去。如有颂曰

  我施逝多林　　蒙大法王住
  贤圣僧受用　　故我心欢喜

又契经说。诸生天者。初生必起三种念言。我从何殁。今生何处。乘何业故来生此间。故知诸天能忆过去

说一切有部显宗论卷第三十七阿毗达磨藏显宗论卷第三十八

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩定品第九之一

如是已辩诸智差别。次当分别智所依定。唯诸静虑能具为依。故于此中先辩静虑。或于先辩。共功德中已辩智所成无诤等功德。余所成德今次当辨。于中先辩所依止定。且诸定内静虑云何。颂曰

  静虑四各二　　于中生已说
  定谓善一境　　并伴五蕴性
  初具伺喜乐　　后渐离前支

论曰。一切功德多依静虑。故应先辩静虑差别。此总有四种。谓初二三四。岂诸静虑无如慈等不共名想。而今但就初等四数建立别名。此中非无不共名想。然无唯遍摄一地名。以诸静虑各有二种。谓定及生有差别故。诸生静虑如先已说。谓第四八。初二余三。无有别名。总诠一地。诸定静虑总相无别。谓此四体总而言之。皆善性摄心一境性。以善等持为自性故。若并助伴五蕴为性。此二既同难知差别。相虽无别而地有异。为显地异就数标名。故说为初。乃至第四。此中经主自兴问答。何名一境性。谓专一所缘。彼答非理。眼意二识若同一所缘。应名一境性。故于此处应求别理。谓若依止一所依根专一所缘名一境性。岂不一念无易所缘。应一切心中皆有一境性。理实皆有一一刹那。心心所法一境转故。然非一切皆得定名。以于此中说一境性但为显示由胜等持令善心心所相续而转故。若尔即心依一根转。引缘自境余心续生。此即名为心一境性。应离心外无别等持。此难不然。前已说故。谓先广辩心所法中。已辩等持离心别有。谓若心体即三摩地。令心作等亦应无别。差别因缘不可得故。如是等难具显如前。故非即心名三摩地。依何义故立静虑名。由依此寂静方能审虑故。审虑即是实了知义。如说心在定。能如实了知。审虑义中置地界故。此论宗审虑。定以慧为体。依训释理。此是凝寂思度境处得静虑名。定令慧生无浊乱故。有说此定持胜遍缘。如理思惟故名静虑。胜言简欲界遍缘。简无色如理思惟。简异颠倒能持。此定是妙等持。此妙等持名为静虑。此言显示止观均行。无倒等持方名静虑。若尔染污宁得此名。由彼亦能邪审虑故。于相似处亦立此名。如世间言朽败种等。故无一切名静虑失。若善性摄心一境性。并伴立为四静虑者。依何相立。初二三四具伺喜乐。建立为初。谓若位中善一境性。具与寻伺喜乐相应。如是等持名初静虑。颂中但说与伺相应。已显与寻亦相应义。以若有伺与喜乐俱。必无与寻不相应故。为显第二除伺建立。故颂但说具伺非寻。异此应言具寻喜乐。举寻有伺不说自成。渐离前支立二三四。离伺有二离二有乐。具离三种如其次第。故一境性分为四种。已辩静虑。无色云何。颂曰

  无色亦如是　　四蕴离下地
  并上三近分　　总名除色想
  无色谓无色　　后色起从心
  空无边等三　　名从加行立
  非想非非想　　昧劣故立名

论曰。此与静虑数自性同。谓四各二。生如前说。即世品说。由生有四。定无色体。总而言之。亦善性摄心一境性。依此故说。亦如是言。然助伴中此除色蕴。无色无有随转色故。虽一境性并伴无差。离下地生故分四种。谓若已离第四静虑生立空无边处。乃至已离无所有处生立非想非非想处。离名何义。谓由此道解脱下地惑。是离下染义。即此四根本。并上三近分。总说名为除去色想。空处近分未得此名。缘下地色起色想故。非缘下色想可立除色名。若尔何缘大种蕴说除去色想是第四定。彼缘欲界住自身中所有诸色渐除去故。非无色界可有此想。是除色想前加行故。立根本名。亦无有失。依何义故立无色名。依彼都无一切色义。后殁生下色从心生。现见世间色非色法。亦有展转相依起故。谓心异故色差别生。色根有别识生便异。故从无色将生下时。顺色生心相续而住。由彼势力引下色生。然不可言唯从彼起。亦以先世色俱行心相续为缘久已灭色为自种子今色方起许同类因通过现故诸阿罗汉般涅槃已。诸蕴相续无余断故。现无少分诸蕴生缘。不可例同从无色殁。如是已释无色总名。何故别名空无边等。且前三种名从加行。修加行位思无边空及无边识无所有故。若由胜解思惟无边。空加行所成名空无边处。谓若有法虽与色俱。而其自体不依属色。诸有于色求出离者。必应最初思惟彼法。谓虚空体虽与色俱。而待色无方得显了。外法所摄其相无边。思惟彼时易能离色。故加行位思惟虚空。成时随应亦缘余法。但从加行建立此名。若由胜解思惟无边。识加行所成名识无边处。谓于纯净六种识身能了别中。善取相已安住胜解。由假想力思惟观察无边识相。由此加行为先所成。随其所应亦缘余法。但从加行建立此名。若由胜解舍一切所有加行所成名无所有处。谓见无边行相粗动。为欲厌舍起此加行。是故此处名最胜舍。以于此中不复乐作无边行相。心于所缘舍诸所有寂然住故。由想昧劣立第四名。谓此地中想不明胜如无想故。得非想名。而想非全无。故名非非想。此地犹有昧劣想故。此言显示有顶地想。非如下七地故得非想名。非如三无心故名非非想。岂不有顶加行位中。诸瑜伽师亦作是念。诸想如病如箭如痈。无想天中如痴如闇。唯有非想非非想天。与上相违寂静美妙。宁此不就加行立名。理实应然。以观行者必先厌想及无想故。然或有问。行者何缘修加行时作如是念。必应举此为酬问因。故说立名。由想昧劣。此四无色皆言处者。以是诸有生长处故。谓此四处为有无有。生长种种业烦恼故。为破妄计彼是涅槃。故佛说为生长有处。已辩无色。等至云何。颂曰

  此本等至八　　前七各有三
  谓味净无漏　　后味净二种
  味谓爱相应　　净谓世间善
  此即所味着　　无漏谓出世

论曰。此上所辩静虑无色根本等至总有八种。于中前七各具有三。有顶等至唯有二种。此地昧劣是生死根。在诸地边无无漏故。初味等至谓爱相应。爱能味着故名为味。彼相应故此得味名。爱相应言依自性说。此以等持为自性故。若并助伴应作是言。爱俱品法名味等至。此但取爱一果品法。净等至名目世善定。离惑垢故与无贪等。诸白净法共相应故。此是善故与味有殊。是有漏故与无漏别。此即是前所味着境。此无间灭彼味定生。缘过去净深生味着。尔时虽名出所味定。于能味定得名为入。诸从定出总有五种。一出地。二出刹那。三出行相。四出所缘。五出种类。从初静虑入第二等。名为出地。于同一地行相所缘相续转位前念无间入于后念名出刹那从非常行相入苦行相等。名出行相。从缘色蕴入缘受等。名出所缘。从有漏入无漏。从不染污入染污等。名出种类。依出种类此中说言。从所味出入能味定。岂不二言更相违反。能味是爱非所入定。所入是定不名能味。如何可言入能味定。无相违过。现见相应。随举一名说俱品故。如劝长者作意记别。互相杂故俱得二名。由爱相应等持名味。等持力故爱得定名。故无二言更相违过。有说定爱相续现前。诸后刹那缘前为境。所味即是前灭刹那。后生刹那说名能味。此能味爱现在前时。缘过去境不缘现在。自性相应及俱有法。以必不观自性等故。不缘未来未曾领故。于所缘境专注不移。方名为定。爱相应定亦专一境。故得定名。余惑相应则不如是。谓余烦恼于自所缘。不能令心专注如爱。故三摩地若与爱俱专注一缘与善相似无漏定者。谓出世定爱不缘故。非所味着。如是所说八等至中。静虑摄支非诸无色。以诸无色极寂静故。谓瑜伽师乐修善品。若于广大功德聚中。别建立支精勤修习。若诸无色寂静增故。心心所法昧劣而转。是故于彼不建立支。或彼地中等持偏胜。非一偏胜可立支名。要多法增方名支故。由此静虑独得立支。定慧均行多法增故。由此近分亦不立支。色近分中唯慧增故。有余师说。若诸地中有别心所。无余断灭。方于此地立支非余。初静虑中忧苦断灭。第二静虑寻伺无余。第三灭喜。第四断乐。无色地中虽总渐减。而无随地无余断灭。此释未能遣他疑问。何缘唯此方建立支。是故应如前释为善。于四静虑各有几支。颂曰

  静虑初五支　　寻伺喜乐定
  第二有四支　　内净喜乐定
  第三具五支　　舍念慧乐定
  第四有四支　　舍念中受定

论曰。唯净无漏四静虑中初具五支。一寻二伺三喜四乐五心一境性。心一境性是定异名。定与等持体同名异。故言定者。即胜等持。此中说为心一境性。第二静虑唯有四支。一内等净二喜三乐四心一境性。第三静虑具有五支。一行舍。二正念。三正慧。四受乐。五心一境性。第四静虑唯有四支。一行舍清净。二念清净。三非苦乐受。四心一境性。何缘初三支各具五。第二第四唯各四支。各唯尔所堪立支故。或由欲界多诸恶法。及妙五欲难断难舍。第二静虑有动地喜。其相动涌喜中之极。引五部爱难舍难断。为对治彼故。初三各五支。初三不然。故余各四。或为随顺超等至法。谓最初起超等至时。入异类难入同类易。然超等至初起位中。或从初入三。或从二入四。故二第四各唯四支。初及第三各具有五。后起则易。故上无支。静虑支名既有十八。于中实事总有几种。颂曰

  此实事十一　　初二乐轻安
  内净即信根　　喜即是喜受

论曰。此支实事唯有十一。谓初五支即五实事。第二静虑三支如前。增内净支足前为六。第三静虑等持如前。增余四支足前为十。第四静虑三支如前。增非苦乐支足前为十一。何缘心等非静虑支。此应准前菩提分辩。有异彼者今略分别。受中立三。非忧苦者。忧苦唯是欲界摄故。三受随地为利益支。顺定用强故皆支摄。何缘精进非静虑支。诸静虑支顺自地胜。精进顺上故不立支。或静虑支适分安乐。精进求胜策励疲苦。寻伺二种能助等持。制策于心令离粗细。对治欲恶故并立支。何缘无表非静虑支。诸静虑支助定住境。彼不缘境故不立支。故静虑支随地差别。虽有十八。而于实事种类中求。应唯九种。然受相异故分十一。由此故说。有无初支。非第二支。应作四句。第一句。谓寻伺。第二句。谓内净。第三句。谓喜乐等持。第四句。谓除前余法余支相对。如理应思。此中支名为目何义。目显成义。何所显成。谓显成此是初静虑乃至。此是第四静虑。或此支名目随顺义。如枸橼等名为余支。谓十八支各顺自地。或资具义说名为支。如祠祀支即牛马等。谓寻伺等展转相资。毗婆沙师显静虑地等持最胜。故作是说。三摩地是静虑亦静虑支。寻伺等是静虑支非静虑。宁知静虑地等持最胜耶。以契经中作如是说。于四静虑应知定根。然于相成及相防护。义相似故作如是言。如四支军。亦无有失如王与众。虽互相资而于其中。王最为胜。岂不三定乐体是同。则静虑支应无十一。第三定乐以受为体。初二静虑乐即轻安。故静虑支实有十一。轻安行舍遍四静虑。何缘初二唯立轻安。后二地中唯立行舍。以此于彼偏随顺故。谓欲界中有诸恶法。初静虑地有寻伺想。能逼恼心犹如毒箭。初二离彼。故轻安增。第二静虑喜极动涌。第三静虑乐受极增。二俱能为爱胜生处。三四弃彼故行舍增。或欲及初有色根识。所引粗重甚于余地。初二离彼故轻安增。三四地中离粗重远。寂静转胜故行舍增。谓轻安乐如初舍担。若更易地气分微薄。故唯初二建立轻安。三四地中任运而转。寂静转胜故立行舍。或初二定有轻安缘。喜与轻安为胜缘故。如契经说。喜故轻安。三四定中无喜缘故。轻安微劣不立为支。行舍轻安互相覆蔽。若处有一第二便无。轻安治沈其相飘举。行舍治掉其相寂止。故安与舍互相覆蔽。何理为证知三乐支。二是轻安第三是受。已说于彼偏随顺故。谓第三定乐非轻安。安非彼支。次前已说初二定乐。必非乐受是身心受俱非理故。谓初二乐必非身受。正在定中无五识故。亦非心受应即喜故。要离喜爱余地心悦。方可异前立为乐受。喜即喜受。于一心中二受俱行。不应理故。若谓喜乐更互现起。无斯过者。理亦不然。说具五支及四支故。若谓五四。约容有说。不必俱行。亦不应理。应有有寻无伺定故。然经但说有三等持有寻有伺。乃至广说。若静虑支非必俱起。何缘不说有有寻无伺定。又于欲界初静虑中。亦应具有三三摩地。是则违害契经所说。今应思择。第三定中意地悦受。既得喜根应名为喜。何故名乐。此名为乐。亦有所因。以诸喜根不寂静故。谓喜动涌扰乱定心。如水波涛涌泛漂激。初二静虑意地悦受。有如是相故得喜名。第三定中此心悦受。其相沉静转得乐名。故此定中舍用增上。弃舍喜故立行舍支。第四定中复弃舍乐。故彼行舍得名清净。何缘念慧诸地皆有。而念唯在上二静虑。慧在第三定。方得立为支。随其所应偏随顺故。谓喜与乐于三有中是诸有情极所耽味。第三静虑所味中极。有生死中最胜乐故。理应立慧观察厌舍。若无慧者。自地善根尚不能成。况进求胜。为治如是自地过失。第三静虑立慧为支。余地不然故不立慧。第二静虑有最胜喜。轻躁娆乱如逻刹私。第三定中有最胜乐。如天妙欲极为难舍。第三四定由行舍支。随其所应虽已弃舍。而恐退起立念遮防。余地不然故不立念。然第三念势用坚强。非唯助舍亦能助慧。通能防备自他地失。第四不尔无自失故。由此第四不立慧支。或初二定寻喜飘动。虽有念慧防照用微。第四定中二舍所蔽。顺无明故慧用不增。故慧唯三念通上二。或第三定乐过甚微。不立慧支。无能照察。若不照察则无厌求。自地过患上地功德。然下寻喜上色过粗。虽照厌求未为奇特。故余三地慧不立支。以第三定中乐过难觉故。佛说圣者应说应知。由此定中慧用最胜。能知细过故立为支。虽第四边慧亦能了。而但总相未为奇特。谓彼与乐系地不同。是离染道总观下过。非如自慧同一系缚。能别观失方谓希奇。故自立支上慧不尔。又诸已得第三静虑。于第四边非皆自在故于将离乐受染时。彼慧无容立为支体。故唯三定立慧为支。然正了时及初已离。皆应防守须立念支。何故轻安立为支体。以初二定轻安用增。触前所无殊胜位故。由此势用精勤不舍。能令相续有所堪能。能助等持令牵胜德。有殊胜用故立为支。内等净名为目何法。目寻伺息体即信根。谓若证得第二静虑。则于定地亦可离中。有深信生名内等净。故虽诸地皆有信根。而可立支。唯第二定。以今创信诸定地法与散地法俱可离故。又初静虑寻伺识身。如热淤泥信不明净。后二静虑行舍用增。映夺信根故无内净。谓由警觉信力方增。舍此相违故能映夺。信是净相故立净名。如清水珠令心净故。内心平等为缘故生由此信根名内等净。或第二定所有功德。平等为缘引生此净。由此建立内等净名。非唯寻伺静息为体。此等皆是心所摄故。如受想思别有实体。有余部说。喜非喜受。喜是行蕴。心所法摄三定中乐。皆是喜受。故喜喜受其体各异。非三定乐可名喜受。二阿笈摩分明证故。如辩颠倒契经中说。渐无余灭忧等五根。第三定中无余灭喜。于第四定无余灭乐。又余经说。第四静虑断乐断苦先喜忧没。故第三定必无喜根。由此喜受是喜非荣。如先所说八等至中。前七各三。第八有二。谓染污定如何知有。此由契经及论说故。谓契经说净无漏定。已犹言世尊。未说一切定。故知有余染定未说。本论亦说。于诸静虑自地一切随眠随增。由此等文知有染定。故说静虑总有二种。由定及生有差别故。定复有二。谓染不染。不染复二种。谓净及无漏。无漏复二。谓学无学。如是差别理有众多。染静虑中为有支不。有非一切。何定无何。颂曰

  染如次从初　　无喜乐内净
  正念慧舍念　　余说无安舍

论曰。且有一类随相说言。初染中无离生喜乐。非离烦恼而得生故。虽染污定亦喜相应。非因离生故非支摄。此不唯说离欲生喜。亦说因离自地染生。以契经中先作是说。离诸欲恶不善法已。复作是言。离生喜乐。此中重说。离生言者。为显亦有喜离自地惑生。为显喜支唯是善性。故薄伽梵与乐合说。轻安相应必是善故。由此染定必无喜支。故初染支唯有三种。第二染中无内等净。彼为烦恼所扰浊故。虽诸世间说有染信。而不信摄故不立支。乐是轻安唯善性摄。例同初定故不重遮。故此染支唯有二种。第二染定许有喜支。初染中无。以何为证。以初定喜说从离生。第二中无离生言故。第三染中无正念慧。彼为染乐所迷乱故。染污定中虽有念慧。而得失念不正知名。故此二支染中非有。行舍唯是大善法摄。例同第四故此不遮。故此染支唯有二种。第四染中无舍念净。彼为烦恼所染污故。由此第四染唯二支。有余师说。初二染定但无轻安。后二染中但无行舍。大善摄故。彼说染中喜信念慧。皆是支摄。皆通染故。契经中说。三定有动第四不动。依何义说。颂曰

  第四名不动　　离八灾患故
  八者谓寻伺　　四受入出息

论曰。下三静虑名有动者。有灾患故。第四静虑名不动者。无灾患故。灾患有八。其八者何。寻伺四受入息出息。此八灾患第四都无。故佛世尊说为不动。然经唯说第四静虑。不为寻伺喜乐动者。经密意说。论依法相。以薄伽梵有处说言。断乐断苦先喜忧没。具足安住第四静虑。又说彼定身行俱灭。入息出息名为身行。故知此定非唯独免。寻伺喜乐四动灾患。有余师说。第四静虑如密室灯。照而无动。故名不动。喻经说故。寻伺何过而求静息。此能令心于定境界虽恒系念而不寂静。如树枝条依茎而住。与风合故动摇不息。诸瑜伽师。虽不愿乐于境行相心速易脱。而寻伺力令彼驰流。故于定中寻伺有过。喜乐于定亦能鼓动。唯此四种与定相应。而能动心。故经偏说。然实二息忧苦二受亦能鼓动。故论说八。寻伺二法既有此过。不应说在静虑支中。经但应言。寻伺寂静何容亦说有寻有伺。为显寻伺虽定相应而于定中能为灾患。不说不了。故定应说。或此于定初作资粮。作欲恶寻远分治故。后于胜定方为灾患。故说寻伺功不唐捐。舍有行仪方便法尔。设是所舍初必应依。如欲渡河先依船筏后至彼岸。理应总舍。故契经言。依色出欲。依无色出色。依道出无色。若得涅槃亦出圣道。此二容有与一心俱。如胜劣风与一枝合。若此二业谓能鼓动。如何说此与定相应。粗浅定心寻伺所策。方能出离欲界粗染。故此得与初定相应。由此相应未为清净。如灯与日俱见色缘。灯细闇俱照不明了。日光离闇照用分明。如是应知。初静虑定虽作自事而寻伺俱未照而无动如第四静虑。若寻在定能动乱心。无漏定俱亦为灾患。何缘建立为一道支。已说彼能策正见故。行者于定未惯习时。不能了知此为灾患。故于此地不欲厌舍。若已惯习便能觉知。初静虑中有此灾患。如水澄净便见池中。潜虫下鱼能为浊乱。行者既见初静虑中。寻伺二法能为动乱。便于一地总生厌舍。谓此粗浅理应舍故。于初静虑寻伺既然。于上地中喜等亦尔。如定静虑诸受差别。生亦尔不。不尔云何。颂曰

  生静虑从初　　有喜乐舍受
  及喜舍乐舍　　唯舍受如次

论曰。生静虑中初有三受。一者喜受。意识相应。二者乐受。三识相应。三者舍受。四识相应。第二有二。谓喜与舍意识相应无有乐受。无余识故。心悦粗故。第三有二。谓乐与舍意识相应。第四有一。谓唯舍受。意识相应是谓定生。受有差别。上三静虑无三识身。及无寻伺。如何生彼能见闻触及起表业。非生彼地无眼识等但非彼系。所以者何。颂曰

  生上三静虑　　起三识表心
  皆初静虑摄　　唯无覆无起

论曰。生上三地起三识身。及发表心皆初定系。生上起下如起化心。故能见闻触及发表。此四唯是无覆无记。不起下染。已离染故。不起下善。以下劣故

说一切有部显宗论卷第三十八阿毗达磨藏显宗论卷第三十九

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩定品第九之二

如是别释。静虑事已。诸等至得云何。颂曰

  全不成而得　　净由离染生
  无漏由离染　　染由生及退

论曰。八本等至随其所应。若全不成而获得者。诸净等至由二因缘。一由离染。谓在下地离下染时。二由受生。谓从上地生自地时。下七皆然。有顶不尔。唯由离染无上地故。无从上地于彼受生。此中但说本等至者。以诸近分未离染时。有全不成。由加行得。遮何故说。全不成言。为遮已成。更得少分。如由加行得净本等至及由退。故得彼顺退分。即依此义作是问言。颇有净定。由离染得。由离染舍。由退得。由退舍。由生得。由生舍耶。曰有。谓顺退分。且初静虑顺退分摄。离欲染时得。离自染时舍。退离自染得。退离欲染舍。从上生自得。从自生下舍。余地所摄。应如理思。无漏但由离染故得。谓圣离下染得上地无漏此亦但据全不成者。若先已成。余时亦得。谓尽智位得无学道。于练根时得学无学。余加行及退。皆如理应思。虽有由入正性离生获得根本无漏等至。而非决定。以次第者。尔时未得根本定故。此中但论决定得者圣离下染必定获得。上地根本无漏定故。染由受生及退故得。谓上地没生下地时。得下地染。及于此地离染退时得此地染。无由离染及加行得。如是二时能舍染故。何等至无间。有几等至生颂曰

  无漏次生善　　上下至第三
  净次生亦然　　兼生自地染
  染生自净染　　并下一地净
  死净生一切　　染生自下染

论曰。无漏次生自上下善善言具摄净及无漏。极相违故必不生染。然于上下各至第三远故。无能超生第四故。于无漏七等至中。从初静虑无间生六。谓自二三各净无漏。无所有处无间生七。谓自下六上地唯净。第二静虑无间生八。谓自上六并下地二识。无边处无间生九。谓自下六并上地三。第三四空无间生十。谓上下八并自地二。类智无间能生无色。法智不然。依缘别故。从净等至所生亦然。而各兼生自地染污。故有顶净无间生六。谓自净染下净无漏。从初静虑无间生七。无所有八。第二定九。识处生十。余生十一。从染等至生自净染。并生次下一地净定。谓为自地烦恼所逼。于下净定亦生尊重。故有从染生次下净。极相违故不生无漏。若于染净能正了知。可能从染转生下净。是则此净还从净生。以正了知是净摄故。非诸染污能正了知。如何彼能从染生净。先愿力故。谓先愿言。宁得下净。不须上染。先愿势力随相续转。故后从染生下净定。如先立愿方趣睡眠。至所期时便能觉寤。如是所说净染生染。但约在定净及染说。若生净染生染不然。谓命终时从生得净。一一无间生一切染。若从生染一一无间能生自地一切下染不生上者。未离下故。所言从净生无漏者。为一切种皆能生耶。不尔云何。颂曰

  净定有四种　　谓即顺退分
  顺住顺胜进　　顺决择分摄
  如次顺烦恼　　自上地无漏
  互相望如次　　生二三三一

论曰。诸净等至总有四种。一顺退分摄。二顺住分摄。三顺胜进分摄。四顺决择分摄。地各有四。有顶唯三。由彼更无上地可趣故。彼地无有顺胜进分摄。于此四中唯第四分能生无漏。所以者何。由此四种有如是相顺退分。能顺烦恼顺住分。能顺自地顺胜进分。能顺上地顺决择分。能顺无漏。故诸无漏唯从此生。有余师言。顺退分者住彼可退。顺住分者住彼不退。亦不胜进顺胜进分者住彼能胜进。顺决择分者住彼起圣道。有言住彼顺通达谛。由此无间能入离生。应知此中决定义者。谓诸圣道必此无间生。非此无间必能生圣道。若异此者。是则应说唯世第一法名顺决择分。有余师言。顺退分者。与诸烦恼下上相杂。染净展转现在前故。顺住分者。能以种种粗等行相弃背下地静等行相摄受自地。顺胜进分者。观自地过上地功德。顺决择分者。如暖顶忍世第一法无漏无间何分现前。有说通三。除顺退分。理实唯二。谓后二种诸有修习超等至等。唯顺决择最坚胜故。诸瑜伽师作如是说。若观行者。于自地定。不善通达不恒安住。于上地定。不能欣求。数数现行顺下地想。彼之等持名顺退分。或由自地离染退得名顺退分。成就此定补特伽罗名为退者。如成牛行说名为牛。凶勃难回说名牛行。于自地定耽着不舍。于上地定不能欣求。彼之等持名顺住分。于自地定虽能多住。而不耽着。于上地定欣乐牵引。彼之等持名顺胜进分。于自上定皆不耽着多住厌想。为欲令断彼之等持。名顺决择分。诸有安住顺退分者。于广大果心多系缚。诸有安住顺住分者。数住自定不能上求。诸有安住顺胜进者。能展转求所余胜定。然胜进分总有二种。一者自地殊胜功德。二者上地殊胜功德。若能牵引彼名顺胜进分。此有二类。或厌或欣。诸有安住顺决择者。乐断诸有乐修无漏。是名安住。四分者别。若顺烦恼名顺退分。诸阿罗汉宁有退理。非彼犹有顺退分定。可令现行离染舍故。虽有此难而实无违。谓顺住中有顺退者。亦得建立顺退分名。从彼有退如先已说。此四相望互相生者。初能生二。谓顺退住。第二生三。除顺决择。第三生三。除顺退分。第四生一。谓自非余。有说亦生顺胜进分。如上所言。净及无漏。皆能上下超至第三。行者如何修超等至。加行成满差别云何。颂曰

  二类定顺逆　　均间次及超
  至间超为成　　三洲利无学

论曰。本善等至分为二类。一者有漏。二者无漏。往上名顺。还下名逆。同类名均。异类名间。相邻名次。越一名超。谓观行者修超定时。先于有漏八地等至。顺逆均次现前数习。次于无漏七地等至。顺逆均次现前数习。次于有漏无漏等至。顺逆间次现前数习。次于有漏顺逆均超现前数习。次于无漏顺逆均超现前数习。是名修习超加行满。后于有漏无漏等至。顺逆间超名超定成。此中超者。谓顿超二。一者超地。二者超法。唯能超一故至第三。远故无能超入第四。修超等至唯欲三洲。除北俱卢。然通男女。不时解脱诸阿罗汉。要得无诤妙愿智等。边际定者能超非余。定自在故。无烦恼故。时解脱者。虽无烦恼定不自在。诸见至者虽定自在。有余烦恼。故皆不能修超等至。胜解作意不能无间修超等至势力劣故。此诸等至依何身起。颂曰

  诸定依自下　　非上无用故
  唯生有顶圣　　起下尽余惑

论曰。诸等至起依自下身。依上地身无容起下。上地起下无所用故。自有胜定故。下势力劣故。已弃舍故。可厌毁故。总相虽然。若委细说。圣生有顶必超无漏。无所有处为尽自地。所余烦恼自无圣道。欣乐起故唯无所有。最邻近故起彼现前尽余烦恼。离无漏道必无有能。断彼余惑成阿罗汉。是故有顶无漏无所有处依九地身。有漏无所有处依八地身。有漏无漏识无边处依七地身。空无边处依六地身。乃至初定依二地身。谓自及欲若成就依有漏如起无漏一切依九地身诸等至中谁缘何境。颂曰

  味定缘自系　　净无漏遍缘
  根本善无色　　不缘下有漏

论曰。味定但缘自地有漏法。以有漏法是所系事故。所系言显是三有摄。不缘无漏法。爱行相转故。若爱无漏应非烦恼。不缘上地法。爱界地别故。不缘下地法。已离彼贪故。净及无漏俱能遍缘自上下地。有为无为皆为境故。有差别者。无记无为非无漏境。唯有于法说能遍缘无非所缘。前已说故根本地摄。善无色定不缘下地诸有漏法。以下地法不寂静故。本善无色极寂静故。由此理故经于无色皆言超越一切下地。于诸静虑不如是说。以本无色不缘下系。是故于下说超越言。诸静虑中有遍缘智。故于下地不言超越。既说超越色想等言。故知但依超所缘说。若此超越为显离系。应说超一切。非唯色想等。又静虑中应言超越。自上地法无不能缘。虽亦能缘下地无漏。而但缘类不缘法品。以但能缘自全治故。法非全治。如先已说。又法品道于无色界。虽能对治是客非主。亦不能缘下地法灭。既遮无色根本缘下义准近分有缘下能彼无间道必缘下故。味净无漏三等至中。何等力能断诸烦恼。颂曰

  无漏能断惑　　及诸净近分

论曰。诸无漏定皆能断惑。本净尚无能。况诸染能断。谓本净定不能断下。已离染故不能断上。以胜己故。不能断自与自地惑。同一缚故。又自于自非对治故。若净近分亦能断惑。以皆能断次下地故。中间摄净亦不能断。近分有几何受相应。于味等三为皆具不。颂曰

  近分八舍净　　初亦圣惑三

论曰。诸近分定亦有八种。与八根本为入门故。一切唯一舍受相应。作功用转故。未离下怖故。此八近分皆净定摄。唯初近分亦通无漏。皆无有味离染道故。上七近分无无漏者。于自地法不厌背故。唯初近分通无漏者。于自地法能厌背故。此地极邻近。多灾患界故。以诸欲贪由寻伺起。此地犹有寻伺随故。若尔何缘毗婆沙说。诸近分地有结生心。非无染心有结生理。故应近分。有味相应。今于此中遮有定染不遮生染。故不相违。或有余师作如是说。初近分定亦有定染。未起根本。亦贪此故。由此未至具有三种。中间静虑与诸近分。为无别义为亦有殊。义亦有殊。谓诸近分是离染道。入根本因。中间不然。复有别义。颂曰

  中静虑无寻　　具三唯舍受

论曰。初本近分寻伺相应。上七定中皆无寻伺。唯中静虑有伺无寻。故彼胜初未及第二。依此义故立中间名。由此上无中间静虑。一地升降无如此故。谓中间定初静虑摄。而有差别。谓此减寻上立中间。减何成异。故中间定初有上无。岂不契经说七依定。宁知别有未至中间。由有契经及正理故。且有未至。如契经言。诸有未能入初定等。具足安住而由圣慧。于现法中得诸漏尽。若无未至圣慧依何。又苏使摩契经中说。有慧解脱者。不得根本定。岂不依定成慧解脱。由此证知。有未至定。有中间定。如契经说。有寻伺等三三摩地。经说初定与寻伺俱。第二等中寻伺皆息。若无中静虑。谁有伺无寻。以心心所渐次息故。理应有定有伺无寻。又大梵王是世界主。离中间定谁为胜因。由此证知。有中间定。然佛不数说有未至中间。以二即初静虑摄故。说初静虑即已说彼唯初近分名未至者。为欲简别余近分故。非此近分乘先定起。又非住此已起爱味。依如是义立未至名。非上定边亦名未至。皆乘先定势力引生。及住彼时已起味故。毗婆沙者作如是说。未至本地立未至名。是本地德未现前义。此中间定具味等三。以别系属一生处故。谓极修习中间定者。未来当在大梵处生。故亦具三。如根本定。非根本地起爱贪。彼如所味有别能味亦别故。此有胜德可爱味故。无漏定生亦渐减故。此亦一向舍受相应。无三识身故无乐受。无喜受者已不共初。然于初贪未能离故。又由自勉功用转故。由此说为苦通行摄。非忧苦者已出欲故。由此一向舍受相应。此定能招大梵处果。多修习者为大梵故。已辩等至。云何等持。经说等持总有三种。一有寻有伺三摩地。二无寻唯伺三摩地三无寻无伺三摩地。如是三种相别云何。颂曰

  初下有寻伺　　中唯伺上无

论曰。前来因事屡辩此三。今于此中略显别相。有寻有伺三摩地者。谓与寻伺相应等持。此初静虑及未至摄。无寻唯伺三摩地者。谓唯与伺相应等持。此即中间静虑地摄。无寻无伺三摩地者。谓非寻伺相应等持。此从第二静虑近分乃至非想非非想摄。契经复说三种等持。一空三摩地。二无愿三摩地。三无相三摩地。如是三种相别云何。颂曰

  空谓空非我　　无相谓灭四
  无愿谓余十　　谛行相相应
  此通净无漏　　无漏三脱门

论曰。空三摩地。谓空非我二种行相相应等持。故说空等持近治有身见。身见亦有二行相故。谓空行相近治我所见。非我行相近治我见。观法非我。名非我行相观。此中无我。名空行相。由此空行相。近治我所见。以此中都无我。故此法非我所。无相三摩地。谓缘灭谛四种行相相应等持。涅槃离诸相故名无相。缘彼三摩地。得无相名。相略有十。谓色等五。男女二种。三有为相。或复相者。是因异名。涅槃无因故名无相。或相谓世蕴上中下。涅槃异彼故名无相。无愿三摩地。谓缘余谛十种行相相应等持。十行相者。谓苦非常因集生缘道如行出。如是空等三三摩地。三摩地相虽无差别。而依对治意乐所缘。如其次第建立三种。由意乐故不愿三有。理且可然有过患故。宁由意乐不愿圣道。以诸圣道依属有故。若尔何用修习圣道。以是涅槃能趣因故。非离圣道有得涅槃。为求涅槃故修圣道。道如船筏必应舍故。亦由意乐不愿圣道故。缘道行相亦得无愿名。以本期心厌有为故。空非我相非所厌舍。以与涅槃相相似故。由此二行相。虽缘可厌法。不取可厌相。不得无愿名。此三等持通净无漏。世出世间等持摄故。世间摄故。通十一地。出世摄者。唯通九地上七定边无胜德故。于中无漏者名三解脱门。能与涅槃为入门故。非诸有漏法是真解脱门。性住世间违解脱故。三三摩地缘境别者。若有漏空缘一切法。若无漏空唯缘苦谛。无愿能缘苦集道谛。无相唯缘灭谛为境。三三摩地念住别者。无相唯法。余皆通四。契经复说三重等持。一空空三摩地。二无愿无愿三摩地。三无相无相三摩地。如是三种相别云何。颂曰

  重二缘无学　　取空非常相
  后缘无相定　　非择灭为静
  有漏人不时　　离上七近分

论曰。此三等持缘前空等取空等相。故立空空等名。空空等持缘前无学空三摩地取彼空相。空相顺厌。胜非我故。谓彼先起无学等持。于五取蕴思惟空相。从此后起殊胜善根相应等持。缘前无学空三摩地思惟空相。于空取空。故名空空。如烧死尸以杖回转。尸既尽已杖亦应烧。如是由空烧烦恼已。复起空定厌舍前空。重空等持空行相后。起即复还与空行相相应。唯此最能顺厌舍故。非我行相则不如是。见非我者。于诸有为法起厌背心不如见空故诸有已见诸法非我而于诸有犹生乐者。以于诸行中不审见空故。由此空定虽二行相俱。而但名空不说为非我。空于厌舍极随顺故。无愿无愿缘前无学无愿等持。取非常相。谓彼先起无学等持。于五取蕴中思惟非常相。从此后起殊胜善根相应等持。缘前无学无愿三摩地思惟非常相。于无愿不愿名无愿无愿。举喻显示。如前应知。重无愿等持非常行相后起。即复还与非常行相相应。唯此可能缘厌道故。非苦行相能缘圣道。圣道非苦趣苦灭故。苦法不能趣苦寂灭。亦非因等四能缘圣道。以圣道不能令苦续故。非道等四者此厌舍道故。非欣行相能为厌舍。岂不如无愿不愿圣道而作道等四。此亦应然。此例不然。无愿正厌有兼于圣道起不愿心故。谓前无愿正厌于有。圣道依有故兼不愿。虽圣意乐说不愿道。而于圣道非正憎厌。故亦能作道等四种。无愿无愿正憎厌道。故以非常观道过失。道等行相无容厌道。是故于此不作彼四。无相无相即缘无学。无相三摩地非择灭为境。以无漏法无择灭故。但取静相非灭妙离。谓彼先起无学等持。于择灭中思惟静相。从此后起殊胜善根相应等持。即缘无学无相三摩地非择灭为境。思惟静相。于无相灭复观为无相。名无相无相。举喻显示。如前应知。重无相等持静行相后起。即复还与静行相相应。唯此能观非择灭故。非妙行相境无记故。非离行相以虽证得。彼非择灭犹缚随故。非灭行相。以非择灭非永解脱一切苦故。又若观灭滥非常故。所言静者。唯显止息。故非择灭得有静相。以修圣道经久劬劳。于彼息中便生乐想。故重无相取静非余。重三等持唯是有漏。以于圣道生厌舍故。非无漏定厌舍圣道。二缘圣道取空非常。理可名为厌舍圣道。无相无相但缘无为作静行相。何名厌道。此欣无学无相等持不转之因。故名厌道。谓彼定起义作是言。无相等持不生为善。此既欣赞圣道不生。如何不名厌舍圣道。前无相定非此所缘。如何此名无相无相。或应许此定不缘非择灭。但缘无学无相不生。此亦不然。准前释故。谓缘无相之非择灭。此非择灭亦离诸相。缘无相无相故。得无相无相名。缘无相境作静行相。是故此定从境立名。唯三洲人能起此定。通依男女。以依女身亦能自在延促寿故。唯无学位。以有学者但欣圣道未能厌故。此亦非一切。唯不时解脱。以时解脱爱圣道故。依十一地除上七边。以上七边无胜德故。若在欲界从未至摄。圣道后起若在有顶。无所有摄圣道后生。余皆自地圣道后起。就总类说。此从法类苦灭四智无间而生。若就别说。欲界摄者非类后生。上界摄者非法后起。前二非灭后起第三非苦。后生余行相。后起此定故。应得此者。皆尽智时由离染得。后由加行方起现前。唯我世尊不由加行。顺趣解脱起此现前。于道尚厌岂欣诸有。此后亦起圣道现前。然厌道故非无间起。欲界摄者是思所成。余修所成依定起故。契经复说四修等持。一为住现法乐修三摩地。二为得胜知见修三摩地。三为得分别慧修三摩地。四为诸漏永尽修三摩地。如是四种相别云何。颂曰

  为得现法乐　　修诸善净虑
  为得胜知见　　修净天眼通
  为得分别慧　　修诸加行善
  为得诸漏尽　　修金刚喻定

论曰。如契经说。有修等持。若习若修若多所作。得现乐住。乃至广说。善言通摄净及无漏。修诸善静虑。得住现法乐。而经但说初静虑者。于中乐想最增盛故。谓超欲界众多过失。故于此中乐想增盛。如游砂碛热渴疲劳。创饮浊水亦为胜乐。或圣道乐此具有故。谓具一切菩提分法四沙门果九断遍知三界对治。又诸定首诸定乐因。是故偏说。岂不经说。如是苾刍。住此先受离生喜乐。后生梵众受乐同此。何故不言住后法乐。详此唯说现法乐者。为令弃舍乐现欲乐。说现定乐令其欣乐。或现乐住是后乐依。但说所依能依已显。如契经说。先住此间入诸等至。后方生彼或现法乐。三乘皆住后乐不定。是故不说。谓或退堕。或上受生。或般涅槃。便不住故。虽诸静虑即现法乐。依近分故说为得言。修近分力得根本故。或即依现乐说为得言。如言身子体。故无有过。有说。此定佛依自说。如说菩萨居赡部林。起初世间依无漏定。能引一切有情共乐。由此不说后法乐住。即由此故亦但说初。菩萨尔时唯得初故。若依诸定修天眼通。便能获得殊胜知见。此依何义立知见名。本静虑中有遍照智。此遍照故。立以见名。见体即知。故名知见。眼根名见。世所极成。为简异彼。以知摽见。或即此见决断所缘。故名为知。即亦名见。谓本静虑是乐行道。不多劬劳而现前故。不劬劳故其体坚牢。由体坚牢故用决定。用决定故立以知名。见义如前。故名知见。为知为见。修此等持即是为求决定照义。此亦善逝依自而说。谓为显佛以天眼通观诸有情死生险难。方为拔济起静虑等。故为知见修天眼通。有余师言。为欲胜伏诸随烦恼起胜知见。起此胜知见不离光明想。此光明想引天眼通。由天眼通得胜知见。若修三界诸加行善及无漏善得分别慧。谓从欲界乃至有顶。诸闻思修所成善法。及余一切无漏有为。总说名为加行善法。修此善法能引慧生。于诸境中差别而转。故言修此得分别慧。如说善逝住二寻思。能如实知诸受起等。此显修善得分别慧。说加行言为简生得。非修习生得。得未曾得故。若修金刚喻定。便得诸漏永尽。谓若修习第四静虑金刚喻定并随转法。便能获得诸漏永尽。第四静虑佛依自说。无上菩提依此得故。金刚喻定顿证漏尽引尽智生。是故偏说。有说。一切有顿断治。第四静虑皆此所摄。此经所说。若习若修若多所作。义差别者。为欲显示习修得修。所治更远如其次第

说一切有部显宗论卷第三十九阿毗达磨藏显宗论卷第四十

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩定品第九之三

如是已辩所依止定。当辩依定所起功德。诸功德中先辩无量。颂曰

  无量有四种　　对治嗔等故
  慈悲无嗔性　　喜喜舍无贪
  此行相如次　　与乐及拔苦
  欣慰有情等　　缘欲界有情
  喜初二静虑　　余六或五十
  不能断诸惑　　人起定成三

论曰。无量有四。一慈。二悲。三喜。四舍。言无量者。无量有情为所缘故。此四能引无量福故。无量爱果此为因故。有说。此能违无量戏论故。贪等诸惑皆名戏论。何缘无量四无增减。对治四种多行障故。如契经说。若习若修若多所作。慈能断嗔。悲能断害。喜断不欣慰。舍断欲贪嗔故唯有四。嗔谓心所。欲杀有情。欲恼有情。心所名害。耽着境界。于诸善品不乐住因。名不欣慰。于妙欲境起染欣乐情无厌足。名为欲贪。此中慈悲无嗔为性。若尔此二有何差别。性虽无别。然慈能治杀有情嗔欢行相转。悲能对治恼有情嗔戚行相转。是谓差别。如苦与乐。领纳虽同而损益殊。故体有别。苦乐体别如先已辩。慈悲二种差别亦然。有作是言。悲是不害。近治害故。理实如是。但害似嗔以嗔名说悲之行相。亦似无嗔立无嗔名。实是不害。诸古师说。喜即喜受。何缘观行者。尔时喜受生。若缘与乐与慈无异。若缘拔苦应与悲同。又契经言。欣故生喜。喜即喜受。如先已辩。此喜行相与彼欣同。喜故生喜。义有何异。若言下上义有异者。轻安与乐义亦应然。差别因缘不可得故。又违本论。云何名喜。谓喜喜相应受想行识等。此中意显喜俱品法喜增上故。总立喜名非受。受俱其理决定。若喜即喜受。何言与受俱。若言对法以理为量。应如无过诵本论文。此亦不然。理为量论。要有经证方可定文。若与经违理必可坏。不应随意辄改论文。是故此喜定非喜受。以欣为体或即无贪。谓别有贪是恶心所。于有情类作是思惟。云何当令诸所有乐彼不能得皆属于我。喜能治彼。故是无贪。此与喜根必俱行故。三地可得如悔忧俱喜亦无贪。分明相者。于他盛事心不贪着。知他获得深生欣慰。心热对治说名为喜。故知此喜亦无贪性。舍无量体唯是无贪。此与第三有差别者。离爱恚相等缘有情。如创入林等生树觉。平等行因说名为舍。若舍无量亦能治嗔。宁唯无贪与慈何异。又许此舍正治欲贪。与不净观有何差别。且舍与慈有差别者。慈能对治嗔所引嗔。无嗔为体。舍能对治贪所引嗔。无贪为体。岂不如舍无贪为性。亦能对治贪所引嗔。如是许慈无嗔为性。亦应能治嗔所引贪。此难不然。行相违故。谓舍行相双违贪嗔。舍亲非亲差别相故。从此爱恚俱不生故。即由此故舍唯无贪。正能治贪兼治嗔故。慈之行相违嗔非贪。于诸有情与乐转故。由此慈舍虽俱违嗔。而慈顺贪舍能违害。是故此二极有差别。或修舍者。治非处嗔慈治处嗔。故有差别。不净与舍如次能治淫贪余贪。故有差别。此四无量非损益他。何缘唯善非无记性。能近对治贪嗔等故。爱非爱相不能引故。力能令心自在转故。慈等体相已略分别。此阿世耶有差别者。观有情类如己谓慈。乐有情类离苦谓悲。于他兴盛欣慰谓喜。于亲怨相不思谓舍。又不观他有损有益。等观一切如友谓慈。于遭苦者哀愍谓悲。由胜解力想有情类。得益离损欣慰谓喜。于有情相等观谓舍。此四行相有差别者。云何当令诸有情类得如是乐。如是思惟入慈等至。云何当令诸有情类离如是苦。如是思惟入悲等至。诸有情类得乐离苦岂不快哉。如是思惟入喜等至。诸有情类平等平等无有亲怨。如是思惟入舍等至。如是所愿竟无有成。岂不唐捐修定功力。能伏嗔等宁谓唐捐。应是颠倒何能伏惑。愿得乐等宁谓颠倒。谓此不言已得乐等。但由胜解愿诸有情。当得乐等能伏诸惑。故修此四功不唐捐。于定蕴中说四行相。云何令等具如前说言。如是思惟入某等至者。此言若说等无间缘。慈等应无无间生理。别别思惟所引起故。若俱生者入言相违。初业位中别加行引。至成满位亦有俱生。定蕴就初说入无过。且慈无量愿得何乐。有说。愿得第三定乐。诸受乐中此最胜故。若自未证由闻故知。有说。愿得涅槃妙乐。于诸乐中此最胜故。有说。愿得阿罗汉乐。此已解脱诸烦恼故。初修业者。未证此乐。未现证故。不能运心。但缘己身随所证乐。及他所证现可知者。愿诸有情同证此乐。故但缘现如理所生。无染污乐愿他同受。若于所受已舍苾刍。设未获得真实对治。亦处空闲受远离乐。力能映夺天帝等喜。如五乐等伽他中说。又住远离勤修善者。定有善得念念恒流。如大海水遍满相续。喜轻安乐。由此引生。以无吝心缘如是乐。愿诸含识一切同受。皆缘欲界有情为境。能治缘彼嗔等障故。谓于欲界有怨亲中三聚有情能生嗔等。于中有舍怨亲等相。便能伏除嗔等烦恼。是故此境唯欲有情。必不能缘色无色界。大悲体是无痴善根。由此力能通缘三界。若四无量唯缘有情。何故经言。思一方等。此由胜解总缘器中一切有情。故无有失。此四通在欲色。界系。以契经说无量能招梵释轮王殊胜果故。品类足论依修所成说七智知。色界修断及彼遍行随眠随增。有余师言。此四无量加行通欲。本唯色界。此四无量依地别者。若喜即喜。唯修所成。彼应说喜唯初二定。以于余地无喜根故。若喜异喜。通思所成。彼应说喜通依七地。与乐舍受亦相应故。有余说。喜唯喜受俱。彼应说喜唯通三地。或应如颂唯二非余。慈悲舍三通依六地。谓四静虑未至中间。或有欲令唯依五地。谓除未至是容豫德。已离欲者方能起故。有说。此四唯欲及初得无量名。余地不尔。经说无量名梵住故。又说修无量生梵世故。又说招梵释轮王果故。有说。随应通依十地。谓欲四本近分中间。若悲亦依下三静虑。如何得与喜乐相应。悲缘苦有情戚行相转故。此如无漏厌作意生。是故通依下三静虑。彼真实作意能顺生欣。喜乐相应可无有过。此胜解作意。不顺生欣。如何可言与彼相似。疑是戚性不顺生欣。如何许疑喜乐俱起。胜解作意应与彼同。然此于欣极相随顺。力能引生真作意故。疑则不尔。极违真故。彼尚相应。此宁不许。此胜解作意理应违欣有欢戚处中行相别故。悲既戚行相转。应非喜乐相应。勿二行相俱时转故。若尔应不许与舍受相应。舍受处中行相转故。既非不许舍受相应与喜乐俱理定应许。勿全不与受相应故。虽言此四能治嗔等。而不能断诸烦恼得。胜解作意相应起故。真实作意方能断惑。又此唯缘有情境故。缘法作意方能断惑。又此唯缘现在境故。通缘三世或缘非世方能断惑。又解脱道方可得故。要无间道方能断惑。有作是说。有漏根本静虑摄故。此因有失。不应说三。依六地故。未至中间此应无故。经何故说。此断嗔等亦不相违。断有二故。或由此力引断道故。谓伏嗔等引断道生。是故经中说断嗔等。若尔何故契经中说。由善修慈住不还果。此中圣道以慈名说。如于余处说想名等。或依圣者先得慈心。后数修行得离欲说。或依为得修所成慈精进修行得离欲说。有说。此四依欲色身。无色不缘怨亲等故。修此必应先缘彼故。如实义者。唯依欲身。于欲界中唯人能起。若说喜非喜成一必具四。若喜即喜受成一定成三生第三定等唯不成喜故。初欲引起四无量时。先于有情分为三品。所谓亲友处中怨仇。三各分三。谓上中下。上亲友者。谓生法身赖彼重恩舍便难住。中亲友者。谓财法交极相亲爱。下亲友者。谓唯财交亦相亲爱。上处中者。谓于自昔曾不见闻。中处中者。谓虽见闻而不交往。下处中者。谓虽交往而离恩怨。上怨仇者。谓夺名誉命及至亲。中怨仇者。谓夺己身命缘资具。下怨仇者。谓夺亲友命缘资具。于诸有情分品别已。初修慈者。先于上亲发起清净与乐胜解。若由无始数习所成恶阿世耶令心刚强。少遭逼恼便怀深恨。缘此还息与乐胜解。复应策励思其重恩。于彼复生与乐意乐。数习力故恨意永亡。与乐胜解相续无替。此既成已。于中下亲。亦渐次修如是胜解。于亲三品既得等心。次总于处中下中上怨所。渐次修习与乐意乐。乃至最后于上怨亲得平等心都无升降。齐此名曰修慈成满。修悲及喜。例此应说。谓观三苦遍逼有情。不应于中复加以苦。但应如己勤加济拔。渐次修习欲济拔心。乃至怨亲等无升降。齐此名曰修悲成满。想诸有情得乐离苦。深生欣慰如己无差。齐此名曰修喜成满。初修舍者先舍处中。非先舍怨亲。恚爱难舍故。又处中品顺舍力增。于中如前。先舍上品。次舍中下。及与怨亲从下至中。从中至上。先舍怨者。以亲难舍故。如契经说。贪难断非嗔。如是渐次修习于舍。至上亲友等上处中。普于有情舍差别相。齐此名曰修舍成满。若于有情乐求功德。彼于慈等能速修成。非于有情乐求过者。以断善者有德可录。麟喻独觉有失可取。先福罪果现可见故。已辩无量。次辩解脱。颂曰

  解脱有八种　　前三无贪性
  二二一一定　　四无色定善
  灭受想解脱　　微微无间生
  由自地净心　　及下无漏出
  三境欲可见　　四境类品道
  自上苦集灭　　非择灭虚空

论曰。解脱有八。一内有色想观外色解脱。二内无色想观外色解脱。三净解脱身作证具足住。四无色定为次。四解脱灭受想定为第八解脱。八中前三无贪为性。近治贪故。然契经中。说想观者想观增故。如宿住念除去色想。三中初二不净相转。作青瘀等诸行相故。第三解脱清净相转。作净光鲜行相转故。三并助伴皆五蕴性。初二解脱一一通依。初二静虑能治欲界初静虑中显色贪故。初二通摄近分中间。五地皆能起初二故。欲及初定有显色贪。由现识身所引起故。为解脱彼初二定中建立初二不净解脱。二三定中眼识无故。亦无所引缘显色贪。故三四定中无不净解脱。初二解脱相似善根。虽欲界中亦容得有而为欲界贪所陵杂。故不建立二解脱名。三四定中虽亦得有。去所治远势力微劣。又乐净伏。故不得名。第三解脱依后静虑。离八灾患心澄净故。第四并近分立后静虑名。相似善根下地虽有非增上故。不名解脱。欲界欲贪所陵杂故。初二定中不净伏故。第三定中乐所迷故。又并八灾所扰乱故。次四解脱如其次第。以四无色定善为性。非无记染非解脱故。亦非散善性羸劣故。彼散善者如命终心。有说。余时亦有散善。唯生得善无闻思故。诸近分地九无间道八解脱道。亦非解脱。不背下地故。缘下道杂故。又未全脱下地染故。契经说。彼超过下故有说。近分诸解脱道。亦名解脱。背下地故。然于余处唯说根本者。以近分中非全解脱故。第八解脱即灭尽定。厌背受想而起此故。或总厌背有所缘故。微微心后此定现前。前对想心已名微细。此更微细故曰微微。次如是心入灭尽定。谓有顶地心有三品。即想微细及微微心。由上中下品类别故。要下品后灭定现前。故次微微入灭尽定。从灭定出。或起有顶净定心。或即能起无所有处无漏心。如是入心唯是有漏。通从有漏无漏心出。八中前三唯以欲界色处为境。有差别者。二取不净。一取净相。违欲贪故。虽倒而善或少称境。非颠倒摄。缘少思多名假胜解。引圣道故亦名真实。次四解脱。各以自上苦集灭谛。及一切地类智品道。彼非择灭及与虚空为所缘境。无色解脱弃背下地。故并不缘下地苦集。行相别者。初二不净。第三唯净。俱非十六。无色解脱摄本定故。所作行相十六或非念住。俱者初三解脱身念住俱。次四解脱通四念住。智相应者。初三第七唯世俗智。第四五六八智相应。根相应者。初三解脱喜舍相应。次五解脱唯舍相应。世差别者。皆通三世。缘世别者。初三解脱已生可生。各缘自世。不生缘三。次四解脱缘三非世。三性别者。皆唯善性。缘性别者。初三解脱通缘三性。次四解脱缘善无记。学等别者。初三后二唯是俱非。中三解脱皆通三种。缘学等者。初三解脱但缘俱非。四缘三种。见断等者。初三后二唯修所断。中三有漏修断余非。缘见断等者。初三缘修断。次四解脱各通缘三缘。自身等者。初缘自他身。次二缘他四缘三种。得差别者。第八第三唯未曾得。余六通二。通二谓圣内法异生外法异生唯是曾得。多因缘故得解脱名。谓已解脱此方生故。或此力能引解脱故。或是种种解脱性故。或与解脱胜解俱故。此诸解脱依男女身。圣者异生皆能修起。唯灭尽定但依圣身。于圣身中通学无学。此八解脱何有情起。若于所缘恒求对治。是贪爱行乐修多道。如是有情能起解脱。行者何为修解脱等。为令烦恼转更远故。为于等至得自在故。既得自在。便能引发无诤等德及圣神通。由此便能转变诸境起留舍等种种事业。已辩解脱。次辩胜处。颂曰

  胜处有八种　　二如初解脱
  次二如第二　　后四如第三

论曰。胜处有八。内有色想观外色少。若好若恶于此诸色。胜知胜见有如是想。是名为初。内有色想观外色多。广说乃至。是名第二。内无色想观外色少。广说乃至。是名第三。内无色想观外色多。广说乃至。是名第四。内无色想。观外色青。青显青现青光。譬如乌莫迦花。或如婆罗痆斯深染青衣。于此诸色胜知胜见有如是想。是名第五。内无色想。观外色黄。黄显黄现黄光。譬如羯尼迦花。或如婆罗痆斯深染黄衣。广说乃至。是名第六。内无色想。观外色赤。赤显赤现赤光。譬如槃豆时缚迦花。或如婆罗痆斯深染赤衣。广说乃至。是名第七。内无色想。观外色白。白显白现白光。譬如乌沙斯星。或如婆罗痆斯极鲜白衣。广说乃至。是名第八。能制伏境故名胜处。谓虽一切所缘色境。清净光华美妙具足。而善根力悉能映蔽。譬如仆隶虽服珍奇。而为其主之所映蔽。或于是处转变自在。不随起惑故名胜处。胜于处故立胜处名。或此善根即名为处。处能胜故立胜处名。前四胜处自性地等。如次同前初二解脱。谓初二胜处是初解脱果。次二胜处是第二果。彼为资粮能入此故。后四胜处自性地等。应知如前第三解脱。以净解脱为此四因。彼为资粮能入此故。前三解脱于诸色中。但能总取不净净相。今八胜处于诸色中。分别少多青等异相。故前解脱但于色中。弃背欲贪及不净想。今八胜处能于所缘分折制伏令随心转。由此证知第三解脱。总取净相故立一名。八胜处中后四胜处。差别取故分为四种。若净解脱亦差别缘。取净性同立为一者。后四胜处应亦立一。差别因缘不可得故。已辩胜处。次辩遍处。颂曰

  遍处有十种　　八如净解脱
  后二净无色　　缘自地四蕴

论曰。遍处有十。谓周遍观地水火风青黄赤白及空与识二无边处。经于此处皆言一想。上下及傍无二无量。于一切处无间无隙。周遍思惟故名遍处。遍于处故立遍处名。或此善根即名为处。行相遍故立遍处名。此中地等显示所缘。所说遍言显示行相。行相虽等而所缘别。是故遍处分为十种。经言一者。显此等至思惟一类境相现前。想言显是胜解作意。若异此者应言一知。上下傍言显意流转。言无二者。显无间隙。无量言显胜解无边。由胜等持磨莹力故。令观行者心自在生。能于所缘周遍观察。何故唯十得遍处名。此上更无遍行相故。唯第四定空识无边。可得说有无边行相前八遍处如净解脱。自性皆是无贪善根。若并助伴皆五蕴性。后四胜处加行引生。故与彼同。如净解脱。又如净解脱。依第四静虑。及缘欲界色处为境。如何地等亦名色处。地地界等有差别故。显形名地等。如先已说故。说地等遍处不言地界等。故前八种但缘色处。风与风界既无差别。如何可言亦缘色处。此难非理。以诸世间亦说黑风团风等故。由此前八缘色理成。后二遍处如次。空识二净无色为其自性。各缘自地四蕴为境。此解脱等三门功德。为由何得。依何身起。颂曰

  灭定如先辩　　余皆通二得
  无色依三界　　余唯人趣起

论曰。第八解脱如先已辩。以即是前灭尽定故。余解脱等通由二得。谓由离染及加行得。以有曾习未曾习故。前八遍处初修习时。皆以眼识为其加行。空处遍处初修亦尔。以初必缘空界色故。由胜解力后成满时。通缘自地四蕴为境识处遍处初修习时。但以意识为其加行。以初必缘识为境故。由胜解力后成满时。亦缘自地四蕴为境。四无色解脱。二无色遍处。一一通依三界身起。然其初起多依下地。依自下地皆容后起。唯无所有亦依上地。所余一切依欲界身。唯在人中三洲除北。余慧力劣无圣教故。治欲贪故。上二界无。有说。初起唯依人趣。要由教力所引起故。人中有教天趣中无。设有着乐不能初起。故人初起退生欲天。由宿习力有后起义。复以何缘第三静虑有通无量等无解脱等耶。无解脱缘前已具辩。解脱无故胜处亦无。解脱为门入胜处故。胜处无故遍处亦无。胜处为门入遍处故。又第三定耽着妙乐。于生死中此乐胜故。不能发起解脱等三。此三皆欲背生死故。通无量等随顺于乐。故依此定亦能修起。此解脱等三门功德。若随得一得一切不。此不皆尔。其义云何。得后必前。前非必后。谓得遍处必具得三。得胜处者。必得解脱。遍处不定。或得或无。若得解脱。余二不定。以入遍处胜处为门。解脱为门入胜处故。此解脱等差别云何。唯能弃背名为解脱。兼析所缘名为胜处。加无边解得遍处名。此三善根渐次修故。有余师说。此三善根由下中上。故有差别。谓能弃舍胜伏所缘。行相无边有劣胜故。有余师说。解脱唯因。遍处唯果。胜处通二。今应思择。上二界中说者既无。何缘起定。颂曰

  二界由因业　　能起无色定
  色界起静虑　　亦由法尔力

论曰。生上二界总由三缘。能进引生色无色定。一由因力。谓于先时近及数修为起因故。二由业力。谓先曾造感上地生。顺后受业彼业异熟。将起现前势力能令进起彼定。以若未离下地烦恼。必定无容生上地故。三法尔力。谓器世界将欲坏时。下地有情法尔能起上地静虑。以于此位所有善法。由法尔力皆增盛故。诸有生在上二界中起无色定。由因业力。非法尔力。无云等天不为三灾之所坏故。生在色界起静虑时。由上二缘及法尔力。若生欲界起上定时。一一应知加由教力。由教力者。谓人三洲。天亦闻教。微故不说。前来分别诸胜法门。皆为弘持世尊正法。何谓正法。当住几时。颂曰

  佛正法有二　　谓教证为体
  有持说行者　　此便住世间

论曰。世尊正法体有二种。一教二证。教谓契经。调伏胜法。证谓三乘。诸无漏道。若证正法住在世间。此所弘持教法亦住。理必应尔。现见东方证法衰微教多隐没。北方证法犹增盛故。世尊正教流布尚多。由此如来无上智境。众圣栖宅。阿毗达磨无倒实义。此国盛行。非东方等。所能传习此二正法。依持者。住持者。谓何谓说行者。若教正法依说者住。证正法住。唯依行者。然非行者。唯证法依。教法亦应依行者故。谓有无倒修行法者。能令证法。久住世间。证法住时教法亦住。故教法住由说行者。但由行者令证法住。故佛正法随说行人。住尔所时便住于世。阿毗达磨此论所依。此摄彼中真实要义。彼论中义释有多途。今此论中依何理释。颂曰

  迦湿弥罗议理成　　我唯依彼释对法
  或有差违是我失　　判法正理在牟尼

论曰。迦湿弥罗国毗婆沙师议。阿毗达磨理善成立。我唯依彼释对法宗。故于颂中自述本意。谓依此国诸善逝子议对法理大毗婆沙。发起正勤如理观察。为令正法久住世间。饶益有情故造斯论。唯言为显更无异途。一切皆依毗婆沙故。然诸法性广大甚深。如实说者甚为难遇。自惟觉慧极为微劣。又惰遍求如实说者。故于广论所立理中。或有差违。是我过失。诸法正理广大甚深。要昔曾于无量佛所亲近修习真智资粮。方于智境一切无惑。麟喻独觉尚于法相不能决判。况诸声闻。彼所证法随他教故。由此决判诸法正理。唯在真实大牟尼尊。是故定知阿毗达磨真是佛说。应随信受。无倒修行。勤求解脱

  大觉所行真妙义　　唯随对法正理钩
  诸善逝子能证知　　定非自执所迷者
  诸欲证知真妙义　　要依正理了义经
  非唯执教所堪能　　应亦摽心于正理
  故顺佛言正理论　　及顺正理阿笈摩
  足能为证妙义依　　何用固求邪难论
  智者但能依此教　　可无损坠不由余
  故判法义真不真　　唯大觉尊为定量

说一切有部显宗论卷第四十


阿毗达磨大毗婆沙论

    No. 1545 [No. 1546, cf. Nos. 1543, 1544, 1547]

阿毗达磨大毗婆沙论卷第一

        五百大阿罗汉等造

         三藏法师玄奘奉　诏译

     阿毗达磨发智大毗婆沙论序

问谁造此论。答佛世尊。所以者何。以一切种所知法性甚深微妙。非佛世尊一切智者。谁能究竟等觉开示。若尔此中谁问谁答。或有说者。尊者舍利子问。佛世尊答。复有说者。五百阿罗汉问。佛世尊答。有作是说。诸天神问。佛世尊答。有余师说。化苾刍问。佛世尊答。所以者何。诸佛法尔所知法性。于诸世间定应开示。然无问者。尔时世尊化作苾刍。形容端正众所乐见。剃除须发服僧伽胝。令彼请问佛世尊答。犹如征问义品因缘。问若尔此论何故传言。尊者迦多衍尼子造。答由彼尊者受持演说广令流布。是故此论名称归彼。然是佛说。复有说者。此论即彼尊者迦多衍尼子造。问岂不前言以一切种所知法性甚深微妙。非佛世尊一切智者谁能究竟等觉开示。云何彼尊者能造此论耶。答以彼尊者亦有微妙甚深猛利善巧觉慧。善知诸法自相共相。通达文义及前后际。善解三藏离三界染成就三明。具六神通及八解脱。得无碍解。获妙愿智。曾于过去五百佛所。积修梵行发弘誓愿。我于未来释迦牟尼佛般涅槃后造阿毗达磨。故如是说。一切如来应正等觉弟子众中。法尔皆有二大论师任持正法。若在世时如尊者舍利子。若般涅槃后如尊者迦多衍尼子。故彼尊者以愿智力观法所益而造此论。问若尔佛说阿毗达磨。何者是耶。答世尊在世于处处方邑。为诸有情以种种论道。分别演说阿毗达磨。佛涅槃后或在世时。诸圣弟子以妙愿智。随顺纂集别为部类。是故尊者迦多衍尼子佛去世后。亦以妙愿智随顺纂集造发智论。谓于佛说诸论道中安立章门。摽举略颂造别纳息制总蕴名。谓集种种异相论道。制为杂蕴。集结论道制为结蕴。集智论道制为智蕴。集业论道制为业蕴。集大种论道制为大种蕴。集根论道制为根蕴。集定论道。制为定蕴。集见论道制为见蕴。犹如一切邬拖南颂。皆是佛说。谓佛世尊于处处方邑。为种种有情随宜宣说。佛去世后大德法救。展转得闻随顺纂集制立品名。谓集无常颂立为无常品。乃至集梵志颂立为梵志品。此亦如是。阿毗达磨本是佛说。亦是尊者随顺纂集。又若佛说若弟子说不违法性。世尊皆许苾刍受持。故彼尊者展转得闻。或愿智力观察纂集。为令正法久住世故制造此论

复次诸佛出世皆说三藏。谓素怛缆。毗奈耶。阿毗达磨。如是三藏有何差别。或有说者。无有差别。所以者何。一切佛教从一智海之所生故。随一觉池之所出故。等力无畏所摄受故。同一大悲所等起故。复有说者。亦有差别。且名即差别。谓此名素怛缆。此名毗奈耶。此名阿毗达磨。复次依处亦有差别。谓若依增上心论道是素怛缆。若依增上戒论道是毗奈耶。若依增上慧论道是阿毗达磨。问于一切中一切可得。谓素怛缆中亦有依增上戒增上慧论道。毗奈耶中亦有依增上心增上慧论道。阿毗达磨中亦有依增上心增上戒论道。如是三藏应无差别。答依增胜说。谓素怛缆中依增上心论道增胜。毗奈耶中依增上戒论道增胜。阿毗达磨中依增上慧论道增胜。有作是说。素怛缆中依增上心论道是素怛缆。依增上戒论道即毗奈耶。依增上慧论道即阿毗达磨。毗奈耶中依增上戒论道是毗奈耶。依增上心论道即素怛缆。依增上慧论道即阿毗达磨。阿毗达磨中依增上慧论道是阿毗达磨。依增上心论道即素怛缆。依增上戒论道即毗奈耶。故由依处亦有差别。复次所显亦有差别。谓素怛缆次第所显。谓素怛缆中应求次第。何故世尊此品无间宣说彼品若毗奈耶缘起所显谓毗奈耶中。应求缘起。世尊依何缘起制立彼彼学处。阿毗达磨性相所显。谓阿毗达磨中应求诸法真实性相。不应求彼次第缘起。或前或后或无缘起俱无过失。复次等流亦有差别。谓素怛缆是力等流。毗奈耶是大悲等流。阿毗达磨是无畏等流。复次所说亦有差别。谓种种杂说是素怛缆。说诸学处是毗奈耶。分别诸法自相共相是阿毗达磨

复次所为亦有差别。谓未种善根者令种善根故说素怛缆。已种善根者令相续成熟故说毗奈耶。相续已成熟者令得正解脱故说阿毗达磨

复次分位亦有差别。谓依始业位说素怛缆。依已串习位说毗奈耶。依超作意位说阿毗达磨

复次进趣亦有差别。谓未入正法令入正法故说素怛缆。已入正法令受持学处故说毗奈耶。已受持学处令通达诸法真实相故说阿毗达磨。是故三藏亦有差别

问何故尊者造此论耶。答为饶益他故。谓彼尊者作是思惟。云何当令诸有情类于佛圣教无倒受持。精进思惟筹量观察。由此无量烦恼恶行不现在前。便得悟入甚深法性。故造斯论。譬如有人为饶益他故于黑闇处然大明灯。令有目者见种种色。尊者亦尔为饶益他于佛灭后制造此论。令有智者入深法性。又如诸佛为饶益他。开示演说十二分教。一契经二应颂三记别四讽颂五自说六缘起七譬喻八本事九本生十方广十一希法十二论议。所以者何。诸有情类。虽有因力若无缘力而觉发者。终不能修胜进之行。要遇缘力乃能修行。譬如池中虽有种种嗢钵罗等众妙莲华。若日月光不照触者。则不开发出种种香。要日月光之所照触。乃得随类开发出香。又如闇中有种种物。若无灯照终不可见。要假灯照乃得见之。有情亦尔。虽有因力若无缘力。广说如前。如有颂言

  譬如闇室中　　虽有种种物
  无灯闇所隐　　有目不能见
  如是虽有智　　不从他闻法
  是人终不能　　分别善恶义
  譬如有目者　　因灯见众色
  有智依多闻　　能别善恶义
  多闻能知法　　多闻离不善
  多闻舍无义　　多闻得涅槃

又如经说。有二因缘。能生正见。一外闻他法音。二内如理作意。又契经说。有四法人多有所作。一亲近善友。二从他闻法。三如理作意。四法随法行。复有经言。若我弟子一心属耳听闻正法能断五盖。及能修行七觉分满。故如诸佛为饶益他说十二分教。如是彼尊者为饶益他制造此论。复次为破无明闇故。如灯破闇能发光明。阿毗达磨亦复如是。破无明闇发智慧明。故彼尊者制造此论。复次为显无我像故。譬如镜面极善磨莹。种种色像皆于中现。阿毗达磨亦复如是。分别诸法自相共相。令无我像分明显现。故彼尊者制造此论。复次为度生死河故。如牢船筏百千众生依之无畏从河此岸渡至彼岸。阿毗达磨亦复如是。无数诸佛及诸有情。依之无畏。从生死此岸。至涅槃彼岸。故彼尊者制造此论。复次为照契经等故。如人执灯入诸闇室。能见众色而无迷乱。如是行者以阿毗达磨照契经等义而无迷惑。故彼尊者制造此论。复次为观察善等诸法故。如别宝人能善观察金刚等宝。阿毗达磨亦复如是。能善分别善等诸法。故彼尊者制造此论。复次为显阿毗达磨。诸大论师不倾动故。如妙高山踞金轮上一切猛风摇鼓飘击不能倾动。阿毗达磨诸大论师。亦复如是。住净尸罗。诸恶见者轻毁邪论不能摧伏。故彼尊者制造此论。复次尊者以三因缘制造此论。一为增益智故。二为开觉意故。三为遮计我故。增益智者。谓于内外诸经论中。令智增益无有能如阿毗达磨。开觉意者。谓诸有情无明所昏。如睡未觉不能了知。何者是遍行。何者非遍行。何者自界缘。何者他界缘。何者有漏缘。何者无漏缘。何者有为缘。何者无为缘。云何为摄。云何相应。云何因。云何缘。谁成就。谁不成就。何者顺前句。何者顺后句。何者四句。何者如是句。何者不如是句。于如是等所知境中。令诸有情开发觉意。无有能如阿毗达磨。遮计我者。尊者所造阿毗达磨。未曾说有补特伽罗。恒显诸行空无有我。以如是等种种因缘。故彼尊者制造此论

问阿毗达磨。自性云何。答无漏慧根。以为自性。一界一处一蕴所摄。一界者谓法界。一处者谓法处。一蕴者谓行蕴。若兼相应及取。随转三界二处五蕴所摄。三界者谓意界法界意识界。二处者谓意处法处。五蕴者谓色蕴乃至识蕴。如契经说。此药叉天于长夜中其心质直无有谄诳。诸有所问皆为了知不为娆乱。我以甚深阿毗达磨恣彼意问。此中何者甚深阿毗达磨。谓无漏慧根

又契经说。此筏蹉氏及善贤外道并梵寿婆罗门。皆于长夜其性质直无谄无诳。诸有所问皆为了知不为娆乱。我以甚深阿毗达磨恣彼意问。此中何者甚深阿毗达磨。谓无漏慧根。又如佛告西儞迦言。我有甚深阿毗达磨。难见难觉不可寻思非寻思境。唯有微妙聪睿智者。乃能知之。非汝浅智之所能及。所以者何。汝于长夜异见异忍异欲异乐。此中何者甚深阿毗达磨。谓空无我及如实觉。所以者何。以彼外道恒妄计我。空无我性非彼所及。又如佛告邬陀夷言。汝是愚夫盲无慧目。云何乃与上座苾刍共论甚深阿毗达磨。此中何者甚深阿毗达磨。谓灭定退及如实觉。又如佛告阿难陀言。我有甚深阿毗达磨。谓诸缘起。难见难觉不可寻思非寻思境。唯有微妙聪睿智者。乃能知之。此中何者甚深阿毗达磨。谓因缘性及如实觉。又契经说。我有甚深阿毗达磨。谓缘性缘起此处甚深难见难觉。不可寻思非寻思境。唯有微妙聪睿智者。乃能知之。复有甚深阿毗达磨。谓一切依皆永舍离。爱尽离染寂灭涅槃。此最甚深难见难觉。广说如前。此中何者甚深阿毗达磨。谓因缘性及彼寂灭并如实觉。又如佛告阿难陀言。复有甚深阿毗达磨。谓有余法相似甚深我于其中自觉正说。此中何者甚深阿毗达磨。谓诸见趣及如实觉。又契经说。我有甚深阿毗达磨。谓一切法甚深故难见。难见故甚深。此中何者甚深阿毗达磨。谓一切法性及如实觉。虽此等经中随别意趣作种种异说。然阿毗达磨胜义自性唯无漏慧根。即由此故发起世间修所成慧。谓暖顶忍世第一法。以能别观四圣谛故。亦得名为阿毗达磨。又由此故发起殊胜思所成慧。谓不净观持息念等。以能别总观诸蕴故。亦得名为阿毗达磨。又由此故发起殊胜闻所成慧。分别诸法自相共相建立诸法自相共相。害实物愚及所缘愚。以于诸法不增减故。亦得名为阿毗达磨。又由此故发起殊胜生处得慧。以于三藏十二分教能受能持思量观察不谬转故。亦得名为阿毗达磨。复由如是资粮摄持无漏慧根转得明盛。是故亦名阿毗达磨

问若阿毗达磨唯无漏慧根为自性者。何故此论复名阿毗达磨。答阿毗达磨具故亦名阿毗达磨。如处处经中于彼彼具立彼彼名。此亦如是。谓如于乐具立以乐名。如伽他说

  食所乞食乐　　衣随得衣乐
  经行山林乐　　栖隐岩窟乐

饮食衣等体实非乐。胜义乐者谓诸乐受。或有说者。亦轻安乐。然衣食等是乐具故。于伽他中亦说为乐。又如于垢具立以垢名。如伽他说

  女是梵行垢　　女损害众生
  苦梵行所净　　非由水能洗

女实非垢。胜义垢者谓贪嗔痴。然伽他中说女为垢。是垢具故。又如于漏具立以漏名。如说七漏是损害是烧然是苦恼。根等实非漏。是漏具故立以漏名。胜义漏唯三。谓欲漏有漏无明漏。又如于随眠具立随眠名。如契经说。苾刍当知。色是随眠随增随死。若随增即随死。若随死即随取。若随取即随缚。色非随眠。胜义随眠唯有七种。然经说色是随眠者。随眠具故。又如于味具立以味名。如契经说。苾刍当知。眼味妙色。色是魔钩。眼实非味。胜义味者谓所生爱。然契经说。眼味色者是味具故。又如于欲具立以欲名。如契经说。欲者是何。谓五妙欲。又如颂言

  如是五妙欲　　可爱可欣乐
  可意欲所牵　　能令心染着

色等非欲。胜义欲者。谓于彼爱然经颂说。彼是欲者是欲具故。又如于退具立以退名。如契经说。有五因缘令时解脱阿罗汉退。一营事业。二乐戏论。三和诤讼。四好远行。五遇长病。非营事等是能退体。胜义退者。谓一切不善有覆无记法。然契经中说营事等是能退者。谓退具故。又于业具立以业名。如契经说。有三种意。故思恶不善业。若作增长感非爱异熟。谓贪欲嗔恚邪见。非贪欲等是实意业胜义意业。谓意俱思。然契经中名意业者。谓是不善意业具故。又如于异熟因具立异熟因名。如彼尊者无灭所说。我由一食异熟因故。七生天上七生人中。于最后身得尽诸漏。非即一食是异熟因。胜义异熟因者。谓诸不善善有漏法。然彼尊者即说一食为异熟因。是彼具故。如于此等处处经中以彼彼名说彼彼具。此论亦尔。是阿毗达磨具故亦名阿毗达磨。如是胜义阿毗达磨自性。唯是无漏慧根。一界一处一蕴所摄。若兼相应及取随转三界二处五蕴所摄。余资粮等皆是世俗阿毗达磨。是名阿毗达磨自性。如说自性我物自体相分本性。应知亦尔

已说自性。所以今当说。以何义故名阿毗达磨。阿毗达磨诸论师言。于诸法相能善决择能极决择故。名阿毗达磨。复次于诸法性能善觉察能善通达故。名阿毗达磨。复次能于诸法现观作证故。名阿毗达磨。复次法性甚深能尽原底故。名阿毗达磨。复次诸圣慧眼由此清净故。名阿毗达磨。复次能善显发幽隐法性故。名阿毗达磨。所知法性无始幽隐。离此无有能显发故。复次所说法性无有乖违故。名阿毗达磨。若有能于阿毗达磨自相共相极善串习。必无有能如法问难。令于法性有少违故。复次能伏一切外道他论故。名阿毗达磨。阿毗达磨诸大论师。邪徒异学无能敌故。尊者世友作如是说。常能决择契经等中诸法性相故。名阿毗达磨。复次于十二支缘起法性善觉了故。名阿毗达磨。复次以能现观四圣谛法故。名阿毗达磨。复次善说修习八圣道法故。名阿毗达磨。复次能证涅槃故。名阿毗达磨。复次能于诸法以无量门数数分别故。名阿毗达磨。大德说曰。于杂染清净系缚解脱流转还灭法。以名身句身文身次第结集安布分别故。名阿毗达磨。胁尊者言。此是究竟慧。此是决断慧。此是胜义慧。此是不谬慧故名阿毗达磨。尊者妙音作如是说。求解脱者修正行时。能为分别所未了义。谓此是苦此是苦因。此是苦灭此是趣灭道。此是加行道。此是无间道。此是解脱道。此是胜进道。此是向道。此是得果。能正分别如是等义故。名阿毗达磨。法密部说。此法增上故。名阿毗达磨。如有颂言

  慧于世间尊　　能决择趣向
  以正了知故　　老死尽无余

化地部说。慧能照法故。名阿毗达磨。如契经说。一切照中我说慧照最为上首。譬喻者说。于诸法中涅槃最上。此法次彼故。名阿毗达磨。声论者言。阿谓除弃。毗谓决择。此法能除弃决择故。名阿毗达磨。何所除弃。谓结缚随眠随烦恼缠。何所决择。谓蕴界处缘起。谛食及沙门果菩提分等。尊者佛护作如是说。阿毗者。是助言显现前义。此法能引一切善法。谓诸觉分皆现在前故。名阿毗达磨。尊者觉天作如是说。阿毗者。是助言显增上义。如增上慢者名阿毗慢。增上觉者。名阿毗觉。增上老者名阿毗老。此亦如是。此法增上故。名阿毗达磨。尊者老受作如是说。阿毗助言显恭敬义。如恭敬稽首者名阿毗稽首。恭敬供养者名阿毗供养。此亦如是。此法尊重可恭敬故。名阿毗达磨

问何故此论名发智耶。答诸胜义智。皆从此发此为初基。故名发智。复次此论应名智安足处。诸胜义智此为根本依此而立。是故名为智安足处。复次诸勇健智此最能发。发勇智缘故名发智。复次诸智彼岸依此能到故名发智。开发诸法自相共相。无有能如此论者故。复次世出世智。皆依此发智之妙门故名发智

问此论胜利其相云何。答随顺解脱断除系缚。顺空无我违我我所。显无我理遮数取趣开觉意息昏迷。遣愚痴生智慧。断疑网与决定。背杂染向清净。诃流转赞还灭。舍生死得涅槃。摧破一切外道邪论。成立一切佛法正论。此论胜利其相如是

说一切有部发智 大毗婆沙论卷第一

显庆元年七月廿七日于长安大慈恩寺翻经院三藏法师玄奘奉　诏译
弘法寺沙门嘉尚笔受
大慈恩寺沙门明珠证义
大慈恩寺沙门惠贵证义
大慈恩寺沙门法祥证义
西明寺沙门慧景证义
大慈恩寺沙门神泰证义
大慈恩寺沙门普贤证义
大慈恩寺沙门善乐证义
大慈恩寺沙门迻玄缀文
大慈恩寺沙门静迈缀文
西明寺沙门慧立缀文
西明寺沙门玄则缀文
大慈恩寺沙门义褒正字
大慈恩寺沙门玄应正字
西明寺沙门神察执笔
大慈恩寺沙门辩通执笔
同州魏伐寺沙门海藏笔受
大慈恩寺沙门神昉笔受
西明寺沙门嘉尚笔受
大慈恩寺沙门大乘光笔受

夫物情斯感。资于教悟。大圣贻则。寔启疑徒。而先匠译辰。篾尔无纪。爰使后学积滞疑怀。今故具书。以彰来信。愿传写之俦。与余同志。庶几弥劫。永无惑焉

大唐中大夫内侍护军佛弟子观自在。敬写西域新翻经论。愿毕此余生。道心不退。庶以流通未闻之所。窃以佛日西沈。正法玄谢。慧流东渐。像教方传。希世之符。奥义宣于贝叶。非常之宝。至赜发于龙宫。挹其冲源。截暴河而遐逝。游其玄阃。出朽宅而长驱。玄奘法师者。释门之龙象。振旦之鹙鹭。逾葱山而励学。赍梵文而旋止。杀青甫就永事。流通士方涯多。幸预闻正法。植因或爽。禀质不全。今罄兹寸禄。缮斯奥旨。片言只字。具经心目。亲蒙口决。庶无乖舛。以斯福祉。奉福

太宗文皇帝。即御　皇帝王公卿士。六姻亲族。凡厥黎庶。及跂行喘息。平等熏修。乘此胜基。方升正觉阿毗达磨大毗婆沙论卷第二

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中世第一法纳息第一之一

云何世第一法。如是等章及解章义既领会已。次应广释。问何故作此论。答为欲分别契经义故。谓契经中佛世尊说。若有一类于诸行中不能如理思惟。能起世第一法。无有是处。若不能起世第一法。能入正性离生。无有是处。若不能入正性离生。能得预流一来不还阿罗汉果。无有是处。若有一类于诸行中。能如理思惟起世第一法。斯有是处。乃至广说。契经虽说世第一法名。而不广辩世第一法义。契经既是此论依处。彼所不显示者。今应广分别之。由是因缘故作斯论。问何故作论依契经耶。答彼作论者意欲尔故。随彼意欲而作此论。不违法性何烦征诘。复次一切阿毗达磨。皆为解释契经中义。以广分别诸经义故。乃得名为阿毗达磨。故彼尊者于诸经中纂集种种不相似义。分别解释立为杂蕴。乃至纂集种种见趣。分别解释立为见蕴。然于所立八种蕴中。皆具分别一切法相。问何故尊者论初先说世第一法。为顺次第说诸功德。为逆次第说诸功德。为依顺决择分先后次第而说耶。设尔何失。若顺次第说诸功德者。应先说不净观或持息念等。次说念住。次说三义观。次说七处善。次说暖次说顶次说忍。然后应说世第一法。若逆次第说诸功德者。应先说阿罗汉果次说不还次说一来次说预流次说见道。然后应说世第一法。若依顺决择分先后次第而说者。应先说暖次顶次忍。然后应说世第一法。如尊者妙音生智论说。云何暖。云何顶。云何忍。云何世第一法。若不依此三种次第即所造论有杂乱失。如佛在世尊者大迦多衍那。成就无边希有功德。于无量法自相共相。无障碍智随欲现前。勇猛精进恒无断绝。已能善入阿毗达磨文义大海无边觉慧。不可倾动如妙高山。为大论王能伏他论。自所立论无能当者。今尊者迦多衍尼子亦复如是。何故造论。先说世第一法耶。答诸师于此种种异说。谓或有说。今于此中非顺次第说诸功德。非逆次第说诸功德。亦不依彼顺决择分先后次第而说。但作论者意欲尔故。随彼意欲而作此论。不违法相何烦征诘。有作是说。阿毗达磨性相所显非如契经宁求次第。阿毗达磨以广论道决择诸法真实性相。此既繁杂。不应于中求其次第。若求次第文但增繁于义无益。复有说者。不应诘问作论者意。以经先说世第一法。广说如前。今此论师依经造论。故亦先说世第一法。问置作论者。何故经中世尊先说世第一法。答观所化者分齐说故。谓佛观所化者。已得下中品忍。未得上品忍。及世第一法。欲令得故说如是言。若有一类于诸行中不能如理思惟能起世第一法。无有是处。乃至广说。此中如理思惟显上品忍。世第一法正说自名。故佛世尊观所化者修行分齐作如是说。或有说者。为止于此多诽谤故。谓他于此世第一法起多诽谤。是故先说。多诽谤者。谓于自性及于名界现前退中皆起诽谤。于自性起诽谤者。谓或有说。信等五根以为自性。于名起诽谤者。谓或有说。此名种性地法。不应名世第一法

于界起诽谤者。谓或有说。此是欲色界系。或复有说。此色无色界系。或复有说。此是三界系。或复有说。此是三界系及不系。或复有说。此非三界系亦非不系。于现前起诽谤者。谓或有说。此法多念相续现前。于退起诽谤者。谓或有说。此法可退。为止如是种种诽谤。是故先说世第一法。有余师说。诸有漏法皆不牢固。如粪扫淤泥。谁于此中牢固最胜。譬如醍醐。谓世第一法。是故先说。有说。此法随顺无我。是故先说。谓此论中赞叹出离解脱涅槃随顺无我。非如外典赞叹受用诸欲乐具随顺我执。世第一法有法声故。既顺无我与此论同。非如暖等无有法声不同此论随顺无我。故此先说世第一法。有说。此法世法中胜。是故先说。谓诸论中此论最胜。世第一法世法中胜与此论同。是故先说。有说。若有住此法时。名佛出世真实利益。彼于尔时得无障碍受用胜义圣法财故。谓佛出世众生入法。凡有二种。一者世俗。二者胜义。世俗者。谓剃除须发被以法服正信出家。胜义者。谓世第一法无间引生苦法智忍。世俗入法有二种过。一者破戒。二者归俗。胜义入法无如是过。随其种性自在证得自乘功德。无退失故。有说。若有住此法时。无始时来圣道门闭。今创能开。舍未曾舍诸异生性。得未曾得所有圣道。是故先说世第一法。有说。若有住此法时。舍异生名得圣者名。舍异生数得圣者数。舍异生分齐得圣者分齐。舍异生种性得圣者种性。是故先说世第一法。有说。若有住此法时。得心不得心因。得明不得明因。得受不得受因。余心所亦尔。是故先说世第一法

有说。若有住此法时。舍曾习缘得未曾习缘。舍共得不共。舍世间得出世间。舍有爱味得无爱味。舍耽嗜依得出离依。是故先说世第一法。有说。为断疑异生性。是故先说世第一法。谓或有疑此异生性既无有始应亦无终。今显其有终即世第一法。有说。若有住此法时。异生过患。异生变异。异生虚诳。异生刚强。悉不复起。暖顶忍位或有起者。是故先说世第一法。有说。异生起此法已。要至非异生位。方得命终。如异生非异生如是。未见谛已见谛。未得果已得果。未入正性离生。已入正性离生。未起现观已起现观。住不定聚。住正定聚。无圣道有圣道。无证净有证净应知亦尔。暖顶忍等即不决定。是故先说世第一法。有说。若有起此善根。唯一刹那必无停滞。暖等不尔。是故先说世第一法。有说。若有住此法时。异生身中念住等行修至究竟。暖等不尔。是故先说世第一法。有说。若有住此法时。说名最初有漏。心断无漏心续。余位不尔。是故先说世第一法。有说。此法能令异生可倾动。身而不倾动。是故先说。如妙高山踞金轮上四方猛风不能倾动。如是异生安住此法。四倒恶见不能倾动。余异生位即不如是。有说。此法犹如明相能表始终。是故先说。谓如明相表昼分始及夜分终。世第一法亦复如是。显圣道始及异生终。如表始终。如是能表正度已度。趣入已出加行究竟。应知亦尔。余位不然。有说。显此住同法中能有异相。是故先说。谓世第一法虽苦谛摄。而无间引生初灭苦道。虽有世间流转老死萨迦耶摄。而能引生初灭彼道。暖等不然。有说。显此虽是世间缘。而能无间引初出世缘。余位不尔。是故先说。如世间出世间缘如是。有垢无垢。有过无过。有毒无毒。有浊无浊。有身见事无身见事。有颠倒事无颠倒事。有爱事无爱事。有随眠事无随眠事缘。应知亦尔。是故先说。有说。若有住此法时。有势有力能有所作犹如健夫。谓于尔时无间引起圣初止观。及起圣见慧首创冠余觉支鬘。余位不尔。是故先说世第一法。有说。此法其用最胜。能舍异生性得圣性。舍邪性得正性。无间能入正性离生。余法不然。是故先说世第一法。有说。行者住此法时。能舍轻动过妒罗绵柳叠絮等诸异生性。能于圣教安住不动如天帝幢。是故先说世第一法。有说。行者住此法时。舍无始来令心心所成不质直烦恼恶见。得未曾得令心心所成质直性无漏圣道。有说。行者住此法时。舍五补特伽罗同分。谓五无间者。得八补特伽罗同分。谓四向四果。是故先说世第一法。有作是言。世第一法。由三事故论先说之。一顺经说。二止多谤。三此刹那得初圣果。顺经止谤如前广说。即此刹那得初圣果者。谓彼与世第一法为无间士用果。以如是等诸因缘故。此论先说世第一法

有余师言。尊者于此依逆次第宣说诸法。问若尔此论即应先说阿罗汉果。次说不还。次说一来。次说预流。次说见道。然后应说世第一法。何故先说世第一法耶。答此中逆说异生身中净染诸法。非说一切初说。云何世第一法。广说乃至。云何为暖。此则逆说异生身中清净品法。次作是说。此二十句萨迦耶见。广说乃至。若无有见此则宣说异生身中杂染品法。此二品法谁能了知。谓无我智。是故第二智纳息中作如是说颇有一智知一切法。乃至广说。此无我智何由而生。谓觉缘起。是故第三纳息作如是说。一补特伽罗此生十二支缘起。乃至广说。此缘起觉何由而起。谓爱及敬。是故第四纳息作如是说。云何爱。云何敬。乃至广说。如是爱敬何因而生。谓惭及愧。是故第五纳息作如是说。云何惭。云何愧。乃至广说。如是惭愧何由而有。为解法相。是故第六纳息作如是说。色法生老无常。乃至广说。此解法相何由而得。谓舍无义修习有义。是故第七纳息作如是说。诸修劣苦行当知无义俱。乃至广说。谁舍无义修习有义。谓能正思正思惟者。是故第八纳息作如是说。云何思。云何思惟。乃至广说。杂蕴法觉由何明净。谓由结断。是故次说第二结蕴。如是结断由何而证。谓由诸智。是故次说第三智蕴。谁能生起断结诸智。谓无业障补特伽罗。是故次说第四业蕴。诸业多分依谁而生。谓四大种。故次第五说大种蕴。大种所造胜者是何。谓眼等根。是故次说第六根蕴。诸根清净由何势力。谓得诸定。是故次说第七定蕴。有得定已起邪推求。便复引生诸恶见趣。为令识相能速断除。故最后说第八见蕴。虽于如是一一蕴中具摄诸法。而随增胜制立蕴名。故作是说。由逆次说异生身中净染诸法非说一切。是故先说世第一法

云何世第一法。答若心心所法为等无间入正性离生。是谓世第一法。有作是说。若五根为等无间入正性离生。是谓世第一法

问谁作此说。答是旧阿毗达磨者说。问彼何故作此说。答为遮余部故作是说。不必唯说五根为性。谓分别论者执信等五根唯是无漏。一切异生悉不成就。问彼部何故作此执耶。答彼由契经故作此执。谓契经说。若有五根增上猛利。平等圆满多修习故。成阿罗汉诸漏永尽。从此减下成不还者。次复减下成一来者。次复减下成预流者。若全无此信等五根。我说彼住外异生品。由此经故彼执五根唯是无漏。为遮彼意故旧阿毗达磨者说。世第一法以五根为自性。世第一法在异生身。故知五根亦通有漏异生。定不成有为无漏故。问若执五根体唯无漏。有何过失。答便违契经。如契经说。我若于此信等五根。未如实知。是集是没是味是过患是出离。未能超此天人世间及魔梵等。乃至未能证得无上正等菩提。乃至广说。非无漏法可作如是品类观察。分别论者作如是言。世尊此中说自相观。谓我于此信等五根。未如实知集等自相。未能超此天人世间及魔梵等。乃至广说。云何观无漏是集自相耶。谓此必因亲近善士。听闻正法如理作意。法随法行而集起故。云何观此是没自相。谓要未知当知根没已知根起。已知根没具知根起故。云何观此是味自相。谓此亦是爱所缘故。若尔无漏爱所系耶。不尔。如仁许无漏法是烦恼境而非所系。我宗亦然。爱缘无漏而不能系。斯有何失。云何观无漏是过患自相。谓观无漏是无常故。云何观无漏是出离自相。谓涅槃时必弃舍故。如契经说。般涅槃时一切有为皆悉弃舍。彼言非理。所以者何。谓此经说。我若于此信等五根。未如实知是集没味过患出离。未能证得诸漏永尽无上菩提。非自相观能尽诸漏。故彼所说决定非理。由此五根非唯无漏。又执五根唯无漏者。复违经说。如契经说。唯愿世尊演说法要。所以者何。有诸有情处在世间。或生或长。有利根者。有中根者。有软根者。乃至广说。又契经说。苾刍当知。我昔未转正法轮时。曾以佛眼观诸有情处在世间。或生或长有利中软诸根差别。善容貌善调伏薄尘垢。若不闻法。退失胜利信等五根。若唯无漏应利根者是阿罗汉。中根者是不还。软根即是一来预流。若尔世尊未转法轮应已名转。一切圣者于诸世间已充满故。复转法轮应成无用。分别论者作如是言。此中根名说所依处不说根体。于我何违。彼如是言亦不应理。违余经故。谓余经说

生闻梵志往世尊所而白佛言。乔答摩尊说根有几。佛言。我说二十二根。所谓眼根。乃至广说。彼经岂亦说根所依。彼此二经根声不异。一谓根体。一谓所依。非所极成。是自妄执。故定应许信等五根亦通有漏。问若通有漏。彼所引经当云何释。答信等五根实通有漏。彼经一向说无漏者。所以者何。依无漏根建立圣者有差别故。有说。彼经唯说圣道。所以者何。圣者差别依圣道说非世俗故。问彼经又说。若全无此信等五根。我说彼住外异生品。复云何通。答断善根者名外异生。谓诸异生总有二种。一内二外。不断善根。说名为内。断善根者。说名为外。彼经意说。若全无此信等五根。我说名为断善根者。故所引经于我无失。或说。此是经部所说。谓经部师。亦为遮遣分别论者。如前所执故作是言。世第一法五根为性。非唯尔所

有说。此是犊子部宗。彼部师执世第一法信等五根以为自性。唯此五根是自性善。余杂此故。亦得善名。由此五根建立一切贤圣差别不由余根。如契经说。若有五根增上猛利。平等圆满多修习故成俱解脱。从此减下成慧解脱。次复减下成身证。次复减下成见至。次复减下成信解。次复减下成随法行。次复减下成随信行。问今此论宗与犊子部。何相关预而叙彼说答为令疑者得决定故。谓彼与此所立义宗。虽多分同而有少异。谓彼部执世第一法唯以信等五根为性。诸异生性一向染污。谓欲界系。见苦所断。十种随眠为自性故。随眠体是不相应行。涅槃有三种。谓学无学非学无学。立阿素洛为第六趣补特伽罗。体是实有。彼如是等若六若七与此不同。余多相似勿有疑。彼与此皆同故。叙彼宗遮显有异。今应问彼。若唯五根是自性善。所余善法自性是何。若谓彼是不善无记杂五根故亦名善者。如是五根与彼相杂。何故不名不善无记。然信等五与所余法。同一所依。同一行相。同一所缘。一起一住。一灭一果同一等流。同一异熟。而言五根是自性善。余相杂故假立善名。但顺妄情不应正理。勿有此过。故应说言世第一法根非根性

尊者法救作如是言。诸心心所是思差别。故世第一法以思为自性。尊者觉天作如是说。诸心心所体即是心。故世第一法以心为自性。彼二尊者作如是言。信等思心前后各异无一并用。信等五根为等无间。入见道者。约容有义故作是言。信等五根能入见道。谓或有用信思信心为等无间入于见道。乃至或用慧思慧心为等无间入于见道若尔应用不相应法为等无间入于见道。彼作是言。许亦何失。如仁宗说心体前后。虽不相应而有所缘能为无间入于见道。我宗亦尔。信等思心虽复自体无相应义。而有所缘。能为无间入于见道。斯有何失。有大过失。所以者何。若信思心为等无间入见道者。既无精进及念定慧。应有懈怠忘念散乱恶慧能入见道。如是乃至若慧思心为等无间入见道者。既无有信精进念定。应有不信懈怠忘念散乱能入见道。如是岂不成大过失

为遮如是种种异执故复说言。于此义中若心心所法。为等无间入正性离生。是谓世第一法。于此义中者。谓于此不颠倒。此宗此论。此蕴此纳息此品类。此顺契经。我及诸余。同梵行者。所许义中如是。尊者迦多衍尼子。欲显自宗世第一法以根非根相应俱有心心所法为其自性

问世第一法。与苦法智忍为等无间缘名入见道。为此灭已方名为入。为此住位即名入耶。若此灭已方名入者。何故此中不言已入。若此住位即名入者。异生圣者应成杂乱。有作是言。灭已名入。问若尔此文应说已入。尔时见道名已生故。答应言已入而说入者。此于究竟说加行声。如今来声说已来事。如世间说。大王今者从何处来。彼虽已来而说今来。此亦如是。又如已断而说今断。如契经说断乐断苦。乃至广说。离欲染时。苦根已断。今离第三静虑。染乐根断时。乃说为断。岂非已断而说今断。又如已解脱而说今解脱。如契经说。心解脱欲漏有漏无明漏。离欲染时心于欲漏已得解脱。今离非想非非想处染。心于有漏无明漏得解脱时。乃说为解脱。亦于已解脱而说今解脱。又如已受而说今受。如契经说。受乐受时如实知受乐受乃至广说。彼亦已受而说今受。非于受时可了知故。此亦如是。虽是已入而说今入。有余师说。此文应言无间而入正性离生。彼言无理。等无间入无间。而入义有何异。如是说者。世第一法。住时名入。问若尔异生应即圣者。入圣道故。答无如是过。世第一法至住位时。苦法智忍在正生位。未成就故不名圣者。苦法智忍虽未已生。以在正生名等无间。世第一法尔时为彼等无间缘。故名为入。由此故说。若心心所法为等无间入正性离生。是谓世第一法。问若心心所法。已入正性离生。或当得入。亦是世第一法不。答亦是。问若尔此中何故不说。答若说正入。当知则说已入当入。若说现在。当知则说过去未来。其相一故。思心差别论者作如是言。若信思心为等无间入见道者。唯信思心但为同类等无间缘。如是乃至。若慧思心为等无间入见道者。唯慧思心但为同类等无间缘。相似相续论者作如是言。心心所法但为同类等无间缘。谓心与心非心所。心所与心所非心。诸心所中。受与受非余。想等亦尔。然诸心所非恒相应。遇别缘起。谓若欣前境起乐受。若厌前境起苦受。若于境中庸。起不苦不乐受。若欲有所领纳生受。若欲取像生想。若欲有所作生思。乃至若欲有所决择生慧。故诸心所非恒相应。若尔已起心心所法。应不皆作等无间缘。彼作是言。一切能作等无间缘。然非无间。如仁宗许。出无想时。虽五百劫无心心所。而用入位心心所法。为今出位等无间缘。我宗亦尔。虽同类法多时间断而前为后等无间缘。斯有何失。彼言无理。所以者何。有心无心义各别故。又相应法。有即与果有未与果。不应理故。未生心等。非等无间。预作彼缘不应理故。又彼违害品类足说如说云何心等无间法。谓心无间余心心所法。或已生或正生。及无想定灭尽定。或已生或正生。又若尔者复有别过。谓若从有寻有伺地心心所法无间。无寻唯伺地。或无寻无伺地。心心所法现在前。前地已起心心所法。应非后地等无间缘。不相似故。乃至若从无寻无伺地。心心所法无间。无寻唯伺地。或有寻有伺地。心心所法现在前。说亦如是。善不善无记等心心所法展转无间。其过亦尔。前若非后等无间缘。后既无缘。应不得起。若谓后起由前隔越。同类诸法等无间缘。此亦不然。在有心位隔越为缘。不应理故。又初无漏。及无始来曾所未起殊胜有漏。彼既无有前起。同类等无间缘应不得起。又彼所言有大过失。谓贪无间应常起贪。无时伏贪起不净观。若嗔无间应常起嗔。无时伏嗔起慈悲观。若痴无间应常起痴。无时伏痴起因缘观。起我见等如理应知。执异类起无近缘故。又此胜善曾未起故。是则善心无由得起。若尔则无得解脱义。勿有如是种种过失

是故应许前生心聚为后生聚等无间缘。若等不等。前于后生开避力同。如谷豆聚。问世第一法。现在前时。所修未来心心所法。彼法亦是世第一法不。有说。彼非世第一法。所以者何。以此中说若心心所法为等无间。入正性离生。是谓世第一法。彼未来者。既不能作等无间缘。是故彼非世第一法。又彼若是世第一法。则世第一法应有多心。便违后文。世第一法。应言一心非众多心。如是说者。彼法亦是世第一法若彼法非世第一法。便与智蕴所说相违。如说若有未曾得道现在前时。修余未来彼种类道。若执彼非世第一法。云何名为彼种类道。问彼不能作等无间缘。如何可名世第一法。答彼虽不作等无间缘。而能随顺由起得故。譬如苾刍与僧欲法。谓如僧众布洒他时。有诸苾刍虽不在众。由与欲故得布洒他。诸余僧事亦得成立。如是未来所修种类。虽不能作等无间缘。而起自得显相随顺。设彼不起显相顺得。此不能作等无间缘。此能为缘由彼顺力。彼于圣道起不碍力强故。问若彼亦是世第一法。此中本论何故不说。答应说而不说者。当知此义有余。复次若有能作等无间缘。此中即说。彼不能作等无间缘。是故不说。复次若行世者此中说之。彼不行世是故不说。复次若能取果与果此中说之。彼不能取果与果。是故不说。复次若因长养得而亦在身者。此中说之。彼虽因长养得而不在身。是故不说。复次若有势力能修未来。此中即说。彼无修力故不说之。复次若心彼因彼心此果。此中即说彼法不尔。故不说之。复次若法酬因。亦能取果在身缘境。此中即说。彼法不尔故不说之。复次若具二修此中即说。彼唯得修无行修义。故不说之。复次若有作用此中说之。彼无作用。是故不说。问若尔何故此后文说世第一法非多心耶。答彼说现世有作用者。唯有一心非说一切。若说一切实有多心。未来世中有多品类种类同故。虽非所修尚得名为世第一法。况所修者而非是耶。故有问言。颇有相应世第一法而不与苦法智忍作等无间缘耶答有。谓即未来所修种类。问世第一法。随转色心不相应行。为是世第一法不。有作是说。彼非世第一法。由此中言若心心所法。为等无间入正性离生。是谓世第一法。彼不能作等无间缘。是故不名世第一法。如是说者。彼法亦是世第一法。问彼既不作等无间缘。云何得名世第一法。答彼虽不作等无间缘而能随顺。由彼与此心心所法。一起一住一灭。一果一等流一异熟。极亲近故。问若尔此中何故不说。答应说而不说者。当知此义有余。复次若法能作等无间缘。此中即说。彼法不尔。故不说之。复次若法因长养得而有所缘。此中即说。彼法不尔。故不说之。复次若法相应。有所依有行相。有所缘有警觉。此中说之。彼法不尔。是故不说。故有问言。颇有现在世第一法非苦法智忍等无间缘耶答有。谓此随转色。心不相应行

说一切有部发智 大毗婆沙论卷第二阿毗达磨大毗婆沙论卷第三

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中世第一法纳息第一之二

问已知世第一法。随转生住老无常。亦是世第一法。彼得为亦是世第一法不。设是或非俱有何失。若彼得亦是世第一法者。得圣果已。顺决择分应重现前。若彼得非世第一法者。何故沙门果得。是沙门果。而世第一法得。非世第一法耶。答彼得定非世第一法。得圣果已。顺决择分不重起故。问何故沙门果得。是沙门果。而世第一法得。非世第一法耶。答沙门果成就所显故。沙门果得是沙门果。世第一法等无间缘所显。彼得既非等无间缘。亦不随顺如彼生等。故彼得非世第一法。暖顶忍得。亦非暖等勿得圣已重现前故。有作是说。彼得亦是世第一法。问若尔得圣果已。顺决择分应重现前。答许彼一分现前亦无有过。谓相应者不重现前。不相应者有重现前。暖顶忍得亦复如是。有余师说。彼俱起得亦是世第一法。后起者非故无前失。暖等亦尔。评曰。若彼俱起若后起得。一切皆非世第一法。种类同故。暖等亦尔。是故初说于理为善。问何故世第一法。生住老无常。亦是世第一法而得非耶。答生等与彼同一果。相随行不相离。常和合无前无后。相与所相未尝相离。由此亦是世第一法。得与彼法不同一果。不相随行。性相离不和合。或前或后。得与所得有时相离。譬如树皮或时离树。是故得非世第一法。暖顶忍得亦复如是

问世第一法为几念住。答现在唯一。杂缘法念住未来具四。似见道故。问世第一法为几缘。答为四缘。谓因等无间所缘增上缘。为因缘者。谓与彼相应俱有同类等法为因缘。为等无间缘者。谓与苦法智忍为等无间缘。为所缘缘者。谓与能缘此心心所法为所缘缘。为增上缘者。谓除自性。与余一切有为法为增上缘。问世第一法有几缘。答有四缘。有因缘者。谓此相应俱有同类等法。有等无间缘者。谓已生增上忍。有所缘缘者。谓欲界五蕴。有增上缘者。谓除自性余一切法

问文虽不说义必应有。云何出世第一法耶。答苦法智忍是。谓此能持一切圣道故。有余师说。金刚喻定是。谓此能得一切结尽遍知果故。有作是说。初尽智是。谓此能持一切无学法故。或有说者。阿耨多罗三藐三菩提是。谓于一切有为法中此最胜故。复有说者。涅槃界是。谓于一切有为无为法中此最胜故。有说。阿罗汉最后圣道刹那是。谓如异生位最后刹那心名世第一法。如是阿罗汉最后刹那无漏心。名出世第一法。有说。阿罗汉最后心是。谓如异生位最后心是世第一法。如是阿罗汉最后心。是出世第一法。评曰。彼不应作是说。以阿罗汉最后心非出世法故。此诸说中初说为善。由此能任持一切圣道故

何故名世第一法。乃至广说。问何故作此论。答前虽说世第一法自性。而未说彼立名因缘。今欲说故。譬如有人世称最胜。理应说。彼立名因缘。为以族姓。为色为力富贵眷属名最胜耶。此亦如是故作斯论。何故名世第一法。答如是心心所法。于余世间法。为最为胜。为长为尊。为上为妙。故名世第一法。此心心所。于余世法为都胜故说名第一。为分胜故名第一耶。设尔何失。若都胜故名第一者。此岂能胜现观边世俗智。然现观边所修世俗智。是见道眷属随属。见道慧力殊胜。此法不尔。又此岂胜杂修静虑。然彼等至及所感生。不共异生。此法不尔。又此岂胜初尽智时所修善根。然修彼时离一切障所依清净。此法不尔。又此岂胜空空。无愿无愿。无相无相。三三摩地。然彼尚能厌恶圣道。况于有漏。此法不尔。若分胜故名第一者。暖顶忍等应亦名第一。各胜彼彼下位善根故。有作是说。此法都胜故名第一。然约能开圣道门说。非据一切。谓现观边世俗智等。虽有如前所说胜事。然皆无力开圣道门。此法独能。是故都胜。或有说者。此法于余一切事胜故名第一。谓现观边世俗智等。所有胜事皆由此成。所以者何。彼诸胜事若无此法开圣道门。体尚不修。况有胜用。要由此法开圣道门。方修彼体乃有胜用。彼诸胜事既由此成。故此于余一切事胜。有余师说。此法分胜故名第一。问若尔暖等应亦名第一。各胜彼彼下位善根故。答彼于二分中俱非最胜故。谓世善法总有二分。一依异生。二依圣者。世第一法。虽于圣者世俗智等不名最胜。而于异生。所得静虑。无量解脱。胜处遍处。乃至所得第一。有思及不净观。持息念诸念住。三义观七处善。暖顶忍中。皆悉最胜。暖等不尔。故此独称世第一法。问此何义故名第一耶。答此最胜故。能引第一故。得第一果故。趣第一性故。是第一义。有作是说。此能摧伏第一有故是第一义。有余师说。此是异生最后心故。如高幢顶更无有上。是第一义

问此中所说。为最为胜。为长为尊。为上为妙。有何差别。或有说者。无有差别。皆是赞述第一义故。复有说者。亦有差别。且名则差别。谓此名最。乃至名妙。复次对诸善根亦有差别。谓此对闻所成名为最。对思所成名为胜。对不净观持息念念住等名为长。对暖名为尊。对顶名为上。对忍名为妙。复次约所依地亦有差别。谓此依未至定名为最。依初静虑名为胜。依静虑中间名为长。依第二静虑名为尊。依第三静虑名为上。依第四静虑名为妙。复次依义不同。亦有差别。谓此至边顶故名为最。上品摄故名为胜。作吉祥故名为长。体升进故名为尊。性坚牢故名为上。满所愿故名为妙。复次体用有异。亦有差别。谓此能作苦法智忍等无间缘。故名为最。超过一切异生善根故名为胜。映夺一切世俗善根。故名为长。能逮胜德。故名为尊。无二分故名为上。似无漏故名为妙。复次相用有异。亦有差别。谓是异生最后心。故犹如树端名为最。能开圣道门。故名为胜。根猛利故名为长。以于一切顺决择分此最上。故名为尊。折伏一切烦恼冤。故名为上。引爱果故名为妙。有余师说。如是六句。以后释前。故有差别。谓此最故名第一。胜故名最。长故名胜。尊故名长。上故名尊。妙故名上。由此故名世第一法

复次如是心心所法。为等无间。舍异生性得圣性。舍邪性得正性。能入正性离生。故名世第一法。舍异生性者。谓此心心所法能舍异生性。问谁正能舍异生性耶。为世第一法。为苦法智忍。设尔何失。若世第一法正能舍异生性者。云何住彼能舍彼耶。若苦法智忍正能舍异生性者。此在何位。为生时舍为灭时舍。若生时舍者。云何未来能有所作。若灭时舍者。彼性已舍。复何所舍。有作是说。世第一法。正能舍异生性。问此既是异生法。云何住彼而能舍彼。答住彼舍彼亦无有过。如调御者乘象调象。乘马调马。乘船御船。乘车御车。如胜怨士升怨害怨。如伐树人升树伐树。世第一法亦复如是。依异生性而能舍之。或有说者。苦法智忍正能舍异生性。谓正生时舍异生性。于正灭位能断欲界见苦所断十种随眠。如灯生时发明破闇。灭时烧炷热器尽油。问云何未来能有所作。一法二用。理岂应然。答于义无违许亦何失

谓一切法。能于未来有作用者。总有三类。一者内法。如苦法智忍。二者外法。如日等光明。三者内外法。如诸生相。一灯多用世所共知。苦法智忍二用何失。有余师言。世第一法苦法智忍。更互相资舍异生性。谓世第一法。与异生性虽恒相违。而力劣故不能独舍。由此引生苦法智忍。共相助力舍异生性。譬如羸人依因健者。更相助力能伏怨家。由此因缘。世第一法如无间道。苦法智忍如解脱道。舍异生性。是故世第一法。与异生性成就得俱灭。苦法智忍。与异生性不成就得俱生。得圣性者。谓此心心所法。能得苦法智忍。以能任持一切圣法。故且说彼以为圣性。又余圣道虽亦圣性摄。然非此所得故不说之。有说。见道皆是圣性。有余师说。一切圣道皆是圣性。若不尔者。修道无学道中应不成就圣性。是则不应名为圣者。问世第一法。唯能引得苦法智忍。于苦法智尚不能得。况能得余。云何乃言此得圣性。答一切圣道能成圣者。皆名圣性。种类同故世第一法得彼一分。亦名为得。如说烧衣

舍邪性者。谓此心心所法。能舍三种邪性。一业邪性。二趣邪性。三见邪性。业邪性者。谓五无间业。趣邪性者。谓三恶趣。见邪性者。谓五颠倒见。问于此位中。业趣邪性先不成就。道类智时。舍见邪性。乃得究竟。如何可说此位能舍三邪性耶。答由三缘故此位名舍。一由不作故名舍。谓业邪性。二由不往故名舍。谓趣邪性。三由不行故名舍。谓见邪性。问增上忍时三缘已具。何故此位乃说舍邪。答今破彼依故说舍彼。问何谓彼依。答无覆无记异生性。是谓诸烦恼依异生性。害诸有情。令于生死受诸苦故。如师子王。依止无覆无记窟穴。能害种种傍生等类。世第一法。能舍彼依异生性故。说名舍彼。有余师说。苦法智忍。是彼对治。世第一法。引之令生。故说舍彼。问业趣邪性是修所断。苦法智忍如何能治。答苦法智忍。能为五种对治。谓舍断持不作不往对治。舍对治者。谓此能舍异生性故。断对治者。谓此能断欲界见苦所断十随眠故。持对治者谓此能持一切后位诸圣道故。不作对治者。谓此能令毕竟不作五无间故。不往对治者。谓此能令毕竟不往三恶趣故。得正性者。谓此心心所法。能得苦法智忍。以能任持一切正法。故且说彼以为正性。又余圣道虽亦正性摄。然非此所得故不说之。有说。见道皆是正性。有余师说。一切圣道皆是正性。若不尔者。修道为学道中。应不成就正性。是则不应名为圣者。问世第一法。唯能引得苦法智忍。于苦法智尚不能得。况能得余。云何乃言此得正性。答一切圣道离颠倒故。皆是正性。种类同故。世第一法得彼一分亦名为得。如说烧衣

能入正性离生者。谓此心心所法。能入见道。问一切圣道。皆是正性亦是离生。何故此中独说见道。答一切烦恼或诸贪爱。令诸善根不得成熟。及令诸有润合起过。虽皆名生而见所断。于此所说生义增上。见道能为毕竟对治。是故见道独说离生。诸不正见。要由见道。能毕竟断故名正性。世第一法无间引起。故说能入正性离生。复次一切烦恼或诸贪爱。能令善根不得成熟。及令诸有润合起过。皆名为生。见道起已摧彼势力。令不复为增上生过。由此见道独名离生。入正性言义如前说。由此义故尊者妙音作如是说。诸有情类善根成熟能入见道。是故见道名为离生。复次见所断惑。令诸有情堕诸恶趣受诸剧苦。譬如生食久在身中。能作种种极苦恼事。是故此惑说名为生。见道能灭故名离生。入正性言。亦如前说。复次有身见等刚强难伏。如兽[怡-台+龍]悷故说名生。见道能灭故名离生。入正性言亦如前说。复次此中生名显异生性。能起暴恶诸惑业故。见道舍彼故说离生。余如前说。复次见修所断诸烦恼聚。展转相助引无穷生。见道起已摧彼势力。令不能招无穷生过。是故见道独谓离生。余如前说。复次异生身中。烦恼恶业极不调顺。故说为生。诸瑜伽师于此沦没。见道拔彼置圣位中。故名离生。余如前说。复次见所断惑。犹如根栽。生无穷过。见道永拔。故名离生。余如前说。有余师说。此文应言入正性决定。所以者何。谓于此时从不定聚出入正定聚故。复次行者尔时舍邪定聚所依异生性入正定聚所依见道。是故名为入正性决定。复次行者尔时舍五同分入八同分。五同分者。谓诸异生所有同分。依彼能造五无间故。八同分者。谓诸圣者。所有同分依彼能得四向果故。彼于尔时舍邪定分入正定分。是故名入正性决定。复次所入见道非邪定聚。故名正性。非不定聚故名决定。有作是言。此声显入正性任持。以此尼夜摩声亦显任持义故。如牛马等。所防飤处。任持彼类不令放逸。诸瑜伽师亦复如是。住见道已终不放逸故。说世第一法名入正性任持。譬喻部师作如是说。此声显入正性离系。以夜摩声。亦显系义尼。谓遮止亦显离义。一切圣道永离系缚。名尼夜摩。余如前说。声论者言。此声显入正性不往。以夜摩声亦显往义尼。谓遮止亦显不义。诸瑜伽师。得圣道已。毕竟不往不善士趣。是故圣道名尼夜摩。余如前说。或有说者。此文应言入正性如理。一切圣道。与理相应。故名如理。余如前说。复有说者。此文应言从平等位入于正性。平等位即是世第一法时。正性言显示苦法智忍等。世第一法。能从自位入于见道。故名为入。问诸平等者。亦正性耶。答此应作顺后句。谓诸正性皆是平等。有是平等而非正性。此体即是世第一法。问何故世第一法。是平等非正性耶。答无始时来。心心所法。由诸烦恼恶行倒见所恼乱故成不正直。世第一法。伏除彼故令心心所转成正直。故名平等。然是有漏有随眠故不名正性。复次佛及独觉声闻种姓。同于此位。住上上品。故名平等。余如前说。复次现行等故。说名平等。谓诸行者于此位中。皆一刹那而现行故。复次世第一法。处在中位。如悬称绳故名平等。如称称物绳悬其中。若轻重有偏则低昂不等。世第一法亦复如是。处在圣者异生中间若苦法智忍已生。则偏住圣者品。若增上忍正灭。则偏住异生品。是故唯此是平等位。问尔时犹是异生位摄。何故乃名住平等位。答尔时虽在异生位中。而背异生趣求圣位。故名平等。余则不然。复次世第一法与苦法智忍。有四事等故。名为平等。一者地等。谓依此地起苦法智忍。即依此地世第一法。二者根等。谓若苦法智忍。与此根相应。世第一法相应亦尔。三者行相等。谓若此行相苦法智忍。即此行相世第一法。四者所缘等。谓若缘此境起苦法智忍亦即缘此境起世第一法。尊者世友作如是说。有诵名入正性离生。谓诸圣道永灭颠倒故名正性。离隔生故复名离生。谓无始来见修所断二分烦恼展转和合。作诸恶事性刚强故说名为生。见道起已断彼一分。令彼展转永乖离故。世第一法为此一分等无间缘故名为入。有诵名入正性决定。谓见道位无漏相续。必无余隔故名决定后位不然。余如前说

世第一法。当言欲界乃至广说。问何故作此论答虽已说彼立名因缘。而未分别在何界系今欲分别。如人言胜已说胜因。而未知彼所居国邑。此亦如是故作斯论。复次为止他宗差别执故。谓大众部执。世第一法通欲色界系。所以者何。彼谓若地有现观边诸世俗智。此地即有世第一法。若犊子部执。世第一法通色无色界系。所以者何。彼谓若地有诸圣道。此地即有世第一法。若化地部执。世第一法通三界系。所以者何。彼谓若地有尽智时。所修善根。此地即有世第一法。若法密部执。世第一法通三界系及不系。所以者何。彼谓如是世第一法既名世故通三界系。名第一故亦通不系。即彼部中复有别执。世第一法非三界系亦非不系。所以者何。彼谓如是世第一法。名第一故非三界系。以名世故亦非不系。为止如是他宗别执显示己宗故作此论。世第一法。当言欲界系色界系无色界系耶。答应言色界系。此即显示世第一法唯色界系。虽有此言而更应说其所以。何故此法不应言欲界系耶。答非以欲界道能断盖制缠。令欲界缠不复现起。乃以色界道能断盖制缠。令欲界缠不复现起。若以欲界道能断盖制缠。令欲界缠不复现起。如是世第一法。应言欲界系。然非以欲界道能断盖制缠。令欲界缠不复现起。乃以色界道能断盖制缠。令欲界缠不复现起。是故世第一法。不应言欲界系。此中断制不复现起言。显示毕竟断制不起义。以欲界道不能毕竟断盖制缠令不复起。是故无有世第一法。色界不然故于彼有。问何故欲界。无有毕竟断制不起道。而色界有耶。答欲界非定地。非修地非离染地。是故无有毕竟断制不现起道。色界是定地。是修地是离染地。故有此道。复次欲界。不善根强善根弱故无此道。色界善根强无不善根故有此道。复次欲界不善胜因长养。善不尔故。色界善法胜因长养。无不善故。复次欲界不善如主有力。善法如客无势力故。色界善法如主有力。无不善故。复次欲界不善能断善根。善不尔故。色界善法断不善根。无不善故。复次欲界威仪不相敬难如夫妻故。色界威仪共相敬难如母子故。复次欲界威仪无所忌惮。譬如王子与长者子。同囹圄故。色界威仪有所忌惮。譬如王子与执恶子。同囹圄故。复次欲界善根。与欲界惑。必同一缚无力断彼。如人被缚不能自解况能害他。此亦如是。色界善根与色界惑。有不同缚地有别故。尚能断自界况不能断下复次欲界善根必为欲界爱所染着不能永弃。如人亲友虽劣不舍。色界善根。有非色界爱。所染着地有别故。于自界爱尚能永断。况不能断下地诸爱。复次以有漏道断烦恼时。欣修自地厌断于下。欲界无下可厌断故。无有能毕竟断制不起道。色界有下可厌断故。得有能毕竟断制不起道。有余师说。此中断制不起言。显示暂时断制不起义。以欲界道尚不能暂时断盖制缠令不复起。况能毕竟。是故无有世第一法。色界不然。故于彼有如暂时断制不起。毕竟断制不起。如是有片无片。有影无影。有随缚无随缚。摧枝干拔根本。伏缠垢害随眠。应知亦尔。问欲界可无毕竟断制不起道。岂亦无暂时断制不起道耶。答虽有此道。而不可信。所以者何。以不坚牢不久住不流注。非增上不相连续。不久随转。心于所缘速取速舍。无胜势力伏诸烦恼。故不能入正性离生。如池水上有浮萍等。虾蟆小石投掷其中。虽初暂离后即随合。如是欲界。虽有暂时断盖等道。而不可信。广说如前。于色界中。非唯有彼毕竟断制不现起道。而亦有彼暂时断制不现起道深可保信。所以者何。以彼道坚牢。久住流注增上。相连续久随转。心于所缘不速取舍。有胜势力伏诸烦恼。故能趣入正性离生。如池水上有浮萍等。龙象大石投入其中。经久离散。难可还合。如是色界亦有暂时断盖等道。而可保信。广说如前。是故应知欲界无有断盖等道。色界不尔。由此应言世第一法唯色界系。非欲界系。问世第一法。不能断结。何故乃言若以欲界道能断盖制缠。令欲界缠不复现起。如是世第一法。应言欲界系等。答世第一法。虽不断结而此善根胜妙第一。在深远处。宜应与彼能断结道。同在一地。是故应以此道证之。复次世第一法。引生见道定与见道同在一地。见道既能断诸烦恼。故断结道可为此证。复次世第一法。既于欲界极生厌患。应与能治欲界惑道。同在一地。故可引彼。证此法有。问若尔世第一法唯应在未至地。唯未至地能断欲界诸烦恼故。上地应无。答对治有二种。一断对治。二厌坏对治。未至地。于欲界具二对治。上五地于欲界虽无断对治。而有厌坏对治故。彼亦有世第一法。尊者妙音作如是说。色界六地于欲界惑。皆得具有二种对治。上五地道非不能断。由未至地先已断故。虽有断力而无可断。譬如六人。同一冤家。而共议言随于何处。获者便害。于中一人先获害之。其余五人虽有害力而无可害。又如六人各持一灯。相与次第入一闇室。初灯入时诸闇皆破。余虽有力无闇可除。又如日光初中后分。无不皆与夜闇相违。日初出时。破闇皆尽。余虽有力无闇可破。如是六地。于欲界惑虽皆能断。广说如前。问云何得知。色界六地。于欲界惑具二对治。彼作是言。依上五地入见道者。于欲界断分别作证。别起无漏离系得故。若上五地于欲界惑。无断对治此事应无。评曰。不应作如是说。彼于欲界烦恼毕竟。无有能断者故。谁言彼地有无漏得。于欲界断分别作证。而复引彼证此义耶。是故前说于理为善。问因论生论。世第一法。何故不能断诸烦恼。答世第一法彼于尔时善根微小。法身未长而有威势。以善根微小法身未长故不能断惑。有威势故不为烦恼之所摧伏。如师子子身小未长而有威势。以身小未长故不能害兽。有威势故不为诸兽之所侵害。或有说言。世第一法唯一刹那故不能断。问苦法智忍亦一刹那云何能断。答苦法智忍。虽一刹那而有相续起故能断惑。世第一法无如是事故不能断。有余师言。世第一法。加行道摄故不能断。要无间道方能断故。于此义中复有分别。问何缘世第一法。唯在色界系耶。答以彼色界能为三道三地三根等无间缘。又能引发初法智品次类智品。余界不然。故世第一法唯是色界系。问世第一法何缘定非欲界系耶。答欲界非定界非修界非离染界。要定界修界离染界。乃有世第一法故。复次欲界是卑贱界是粗重界是下劣界。要尊胜界。细轻界。胜妙界。乃有世第一法。复次若世第一法是欲界系者。便有能缘自性过故。谓彼若是欲界系者。为缘自性。为不能缘。若缘自性有违理失。自性不能取自性故。若不能缘便违本论。如后文说。若缘此法起苦法智忍。即缘此法起世第一法。苦法智忍。遍缘欲界五蕴为境。此亦应然。是故世第一法。决定非欲界系

说一切有部发智大毗婆沙论卷第三阿毗达磨大毗婆沙论卷第四

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中世第一法纳息第一之三

何故此法。不应言无色界系耶。答入正性离生。先现观欲界苦为苦。后合现观色无色界苦为苦。圣道起先辨欲界事。后合办色无色界事。若入正性离生。先现观无色界苦为苦。后合现观欲色界苦为苦。圣道起先办无色界事。后合办欲色界事。如是世第一法。应言无色界系。然入正性离生。先现观欲界苦为苦。后合现观色无色界苦为苦。圣道起先辨欲界事。后合办色无色界事。是故世第一法。不应言无色界系。此中入正性离生。先现观欲界苦为苦。后合现观色无色界苦为苦者。谓见道中。先别现观欲界苦谛。为苦行相。后合现观色无色界苦谛为苦行相。问见道位中。具观四谛。何故但说观苦谛耶。答见道位中。先观苦谛。以相粗显是故偏说。问四种行相。皆现观苦。何故但说苦行相耶。答理应具说而不说者。当知此中是有余说。有说此文但应作如是说。先现观欲界苦。后合现观色无色界苦。不应言为苦。而复言为苦者有何意耶。答四行相中。苦最居首故且说苦类显余三。有说以苦行相久远所传。过去如来应正等觉。皆于谛首标苦名故。有说以苦行相。唯属苦谛故偏说之。非常行相通属三谛。空非我行相属一切法故。有说此苦行相。能违诸有能弃生死。胜余行相顺厌心故。乃至婴儿虽得种种上妙饮食。适欲食时有人语言。此食有苦即便弃舍。是故偏说。有说以苦行相易可信受。谓内外道老少愚智皆信有苦。是故偏说。有说苦相粗显易以智知才说即了。是故偏说。如智于所知。觉于所觉。行相于所行。根于根义。能缘于所缘。应知亦尔。问何故行者。见道位中。先现观欲界苦。后合现观色无色界苦耶。答粗细异故。谓欲界苦粗易可观察故先现观色无色界苦。细难可观察故后现观。如习射人先射粗物后射毛端。此亦如是。问若尔色界苦粗无色界苦细。何故行者俱时现观。答以观行者。于定不定二界差别起现观故。谓欲界苦不定界摄故别现观。色无色界苦俱定界摄故合现观。如定不定界。修不修界。离染不离染界。应知亦尔。有说欲界苦于观行者。现为逼恼犹如重担故先现观。色无色界苦。于观行者。则不如是故后现观。有说欲界苦是观行者现所执受故先现观。色无色界苦。则不如是故后现观。有说欲界苦于观行者现生痛恼故先现观。色无色界苦不尔故后现观。有说欲界苦行者现见故先现观。色无色界苦不尔故后现观。问若色无色界苦不现见者。行者云何于彼现观。答现见有二种。一执受现见。二离染现见。彼观行者于欲界苦具二现见。于色无色界苦但有离染现见。犹如商人有财两担。一自担之。二使人担。于自所担。具二现见。谓轻重现见及财物现见。于他所担唯有一种财物现见。此亦如是。有说欲界苦近故先现观。色无色界苦远故后现观。如近远与身俱不与身俱。在自身在他身亦尔。有说欲界苦有三种。谓善不善无记故先现观。色无色界苦。但有二种。谓善无记故后现观。有说修观行者将入圣时。必成就欲界异生性。不成就色无色界异生性。现观法尔于成就者先起。于不成就者后起。有说见欲界苦时断二种结。谓不善无记故先现观。见色无色界苦时唯断无记结故后现观。如不善无记。有异熟无异熟。生二果生一果。无惭无愧相应。无惭无愧不相应。当知亦尔。有说如异生位。谤苦谛时。先谤欲界苦。后谤色无色界苦。今入圣位信苦谛时。亦先信欲界苦。后信色无色界苦。如谤信迷悟疑决。应知亦尔。是故于欲界苦先别现观。于色无色界苦后合现观

圣道起先办欲界事。后合办色无色界事者。谓见道中。先别办于欲界所应作事。后合办于色无色界所应作事。问现观办事。有何差别。有作是言。此无差别现观即是所办事故。故有说者。亦有差别且名即差别。谓此名现观。此名办事。复次通达所缘是现观。断诸烦恼是办事。复次现观者谓智现观。办事者谓事现观。复次现观者谓智遍知。办事者谓断遍知。如智遍知。断遍知智作证。得作证。明解脱道道果。应知亦尔。复次现观者。谓无间道所作。办事者。谓解脱道所作。如无间道所作。解脱道所作。断系得证离系。得除过失修功德。出下贱入胜妙。舍无义得有义。尽爱膏油受无热乐。应知亦尔。复有说者。刹那是现观。相续是办事。如刹那相续入数。入应知亦尔。若入正性离生等者。反举非理。顺成是义。问如于色界苦非先现观。而世第一法是色界系。如是于无色界苦。虽非先现观。何妨世第一法是无色界系。答以色界中有遍缘智。能缘自地及缘上下。故于色界苦。虽非先现观而世第一法。得是色界系。无色界中无遍缘智。虽缘自上而不缘下。故世第一法非无色界系

复次入无色定。除去色想。非除色想能知欲界。若缘此法起苦法智忍。即缘此法起世第一法。问此中复次理不应说。应但说言入无色定除去色想。乃至广说。所以者何是一门故。有余于此以义正文应作是言。何故此法不应言无色界系。答入无色定除去色想。乃至广说。所以者何。此于所问义是根本答。故应作是说。而不说者。有何意耶。答夫设言论法有二种。一者方便。二者根本。先所说者。是方便言论。今所说者。是根本言论。根本异方便故。复次言方便法在前故。应如文说。有作是说。论道有二。一者开纵。二者遮夺。此中前门。是开纵论道。后门是遮夺论道。由此本文于义无失。有余师说。此中前门显苦法智忍但缘欲界。后门显世第一法与苦法智忍同一所缘故。彼定非无色界系。以无色定有除色想。必不缘下有漏色故。除色想定。在四无色及彼上三近分地摄。问有多处说。除色想言。谓此处说入无色定。除去色想。乃至广说。大种蕴说。云何除色想。谓有苾刍。起如是胜解。乃至广说。波罗衍拏。亦作是说

  诸有除色想　　能除一切身
  于内外法中　　无有不见者

众义品中。亦作是说

  于想有想非即离　　亦非无想非除想
  如是平等除色想　　无有染着彼因缘

如是诸说。义有何异。答此蕴中说。不缘下地流转诸色名除色想。大种蕴说。遣积集色令不现前名除色想。波罗衍拏众义品说。断色界爱名除色想。有说此处除色想者通四念住。大种蕴说除色想者。唯身念住。波罗衍拏众义品说。除色想者。唯法念住有说此处除色想者。在七地摄谓四无色上三近分大种蕴说。除色想者。在第四静虑摄。波罗衍拏众义品说除色想者。亦在七地摄。谓未至中间四静虑。空无边处近分。有作是言。大种蕴说除色想者。是不共唯内道有故。余三是共。有余师说。此蕴所说除色想者。是共内外道俱有故。余三是不共。如是名为诸说义异

于此义中。复有分别。问何缘世第一法。非无色界系耶。答非田等故。谓无色界于世第一法。非田非器非地。不能生长世第一法。故于彼无。复次若地有余顺决择分。彼地可有世第一法。无色界无余顺决择分。是故无有世第一法。复次若定。容有遍观三界四谛善根。彼定可有世第一法。于无色定无此善根。是故无有世第一法。复次若定容有缘一切法无我行相。彼地可有世第一法。无色定中无此行相。是故无有世第一法。复次若地。能修现观边世俗智。彼地可有世第一法。无色地中无如是事。故彼无有世第一法。复次若地有见道。可有世第一法。无色界中无有见道。是故无有世第一法。问因论生论。何故无色界无见道耶。答如前所说无世第一法因亦为此证。复有别义。谓无色界奢摩他增故。要毗钵舍那增地。能有见道。有余于此双遮二界。谓欲界极粗故。无色界极细故。俱无世第一法。复次欲界善根极羸劣故。无色界善根极沈昧故。俱无世第一法。复次欲界极喧动故。无色界极寂静故。俱无世第一法。复次若地。有遍缘智及断结道。彼地容有世第一法。欲界虽有遍缘智。而无断结道。无色界虽有断结道。而无遍缘智。是故俱无世第一法。问颇有二圣者。同生一处。于世第一法。一成就。一不成就耶。答有。谓一依初静虑。入正性离生。一依第二静虑。入正性离生。彼俱命终生第二静虑。依初静虑者。不成就世第一法。越地舍故。依第二静虑者。犹成就世第一法。生自地故。问颇有二阿罗汉。俱在欲界于世第一法。一成就。一不成就耶。答有。谓一依初静虑。入正性离生。一依第二静虑。入正性离生。彼俱命终。生第二静虑中。有未离欲界。俱得阿罗汉果。依初静虑者。不成就世第一法。越地舍故。依第二静虑者。成就世第一法。生自地故

世第一法。当言有寻有伺。乃至广说。问何故作此论。答虽已说彼在色界系。而未分别彼在何地。今欲分别。如已知人所居国邑。而未知彼所居宅等。此亦如是故作斯论。复次为令疑者得决定故。谓先说言。世第一法。唯色界系。然色界中。有三种地。一有寻有伺地。二无寻唯伺地。三无寻无伺地。而未显示世第一法定在何地。有诸善根唯在有寻有伺地。如词无碍解。有诸善根。唯在无寻无伺地。如净解脱。后四胜处。前八遍处。有诸善根。在有寻有伺。及无寻无伺地。如喜无量。有说。亦如初二解脱。前四胜处。勿有生疑。世第一法。唯在一地。或在二地。今成立彼定在三地。故作此论。世第一法。当言有寻有伺。无寻唯伺。无寻无伺耶。答应言或有寻有伺。或无寻唯伺。或无寻无伺。问何故显示世第一法在三地耶。答为止余部执。此善根唯在一地。谓或有执。世第一法。唯有寻有伺。有相有警觉。非等引属异生缘诸行。唯有寻有伺者。思构转故。有相者缘名起故。有警觉者。有功用故。非等引者相续转故。属异生者。异生得故。缘诸行者。缘有为故。为止彼执。显此善根。通在三地。云何有寻有伺。答若依有寻有伺三摩地。入正性离生。彼所得世第一法。谓依未至及初静虑。入正性离生者。所得世第一法。问此中依言。欲显何法。有作是说。此俱生定说名为依。谓世第一法。相应定以依声说。此俱生依。有成文证。如智蕴说。若依空三摩地。入正性离生。彼于苦法智忍相应定。以依声说。此亦如是。有余师说。此等无间缘定。说名为依。谓增上忍相应定。以依声说。如是说者。即彼三地。说名为依。后所说依。应知亦尔。云何无寻唯伺。答若依无寻唯伺三摩地。入正性离生。彼所得世第一法。谓依静虑中间。入正性离生者。所得世第一法。云何无寻无伺。答若依无寻无伺三摩地。入正性离生。彼所得世第一法。谓依第二第三第四静虑。入正性离生者。所得世第一法

若依未至定。入正性离生。彼修一地。见道一地。世第一法。二地现观边世俗智。若依初静虑。入正性离生。彼修二地。见道一地。世第一法。三地现观边世俗智。若依静虑中间。入正性离生。彼修三地。见道一地。世第一法。四地现观边世俗智。若依第二静虑入正性离生。彼修四地。见道一地。世第一法。五地现观边世俗智。若依第三静虑。入正性离生。彼修五地。见道一地。世第一法。六地现观边世俗智。若依第四静虑。入正性离生。彼修六地。见道一地。世第一法。七地现观边世俗智。有余师说。若依初静虑。入正性离生彼修二地。见道二地。世第一法。三地现观边世俗智。若依静虑中间。入正性离生。彼修三地。见道三地。世第一法。四地现观边世俗智。所以者何。以彼三地。皆一地故。一随眠故。此中善法互为因故。依余地如前说。评曰彼不应作是说。所以者何。若作是说。则依静虑中间。入正性离生者。应得二地世第一法。谓有寻有伺。及无寻唯伺。若尔便违此文。所说云何。有寻有伺。若依有寻有伺三摩地。入正性离生。彼所得世第一法。云何无寻唯伺。若依无寻唯伺三摩地。入正性离生。彼所得世第一法。勿有此过。是故前说于理为善。问何故见道。修自他地。世第一法。唯修自地耶。答见道无漏解脱离系。世第一法不如是故。复次见道虽在地而不堕界。世第一法在地亦堕界故。复次见道由三缘故修。一因长养故。二同办事故。三同对治故。因长养者。谓六地见道。展转为因。同办事者。谓上地见道。所应作事。下地见道。亦能办之。同对治者。谓上地见道。所对治惑。下地见道。亦能对治。修道亦以如上所说三缘故修自地他地。因长养者。谓九地修道。展转为因。又如法智离欲界染。亦修类智。此但由一缘谓因长养故。同办事者。谓上地修道所应作事。下地修道亦能办之。又如苦智所应作事。乃至道智。亦皆能办。同对治者。谓上地修道所对治惑。下地修道亦能对治。又如一念此智现前。能于未来修无量念。世第一法。非因长养。诸地不能互为因故。亦非同办事。于烦恼断。不能证故。亦非同对治。以不能永断诸烦恼故。复次世第一法。系属相续。见道不如是故。复次世第一法。能办异熟。见道不如是故。复次世第一法。为爱所系。见道不如是故。复次世第一法。有垢有过。有毒有刺。有染有浊。见道不如是故。复次世第一法依异生身。异生身法不修他地。见道唯依圣者身。圣者身法修自他地故。问世第一法。与现观边诸世俗智。同是有漏。何故彼智。自他地修。世第一法。唯修自地。答现观边世俗智。是见道眷属。依见道修。如见道修自他地。彼智亦尔世第一法。不如是故。复次现观边世俗智。依圣者身。圣者能修自地他地。世第一法。不如是故。复次现观边世俗智。依随信随法行身。彼能具修自地他地。世第一法。不如是故。复次现观边世俗智。有冤敌无势力。有冤敌故。自他地修。无势力故依他力修。世第一法。无冤敌有势力。无冤敌故。唯修自地。有势力故。依自力修。复次现观边世俗智。不用功得。随见道力。自他地修。世第一法。用功而得。是故唯能修于自地

问何故六地。所起见道。上能修下。下不修上。答上地法胜。现在前时。则能修下。下地法劣。现在前时。不能修上。如劣朝胜非胜朝劣。此亦如是。复次下地力劣依上而修。如力劣人依附强者。上地力胜不依下修。如力胜人不依附劣。复次下地属上故。上能修下。上地不属下故。下不能修上。如人属他受他驱使。不属他者他不能役。复次若依上地。入正性离生。彼于下地已得离染故能修下。若依下地入正性离生。彼于上地未得离染。设已离染不得自在。以不依彼入正性离生故。由此下地不能修上。复次若于上地。入正性离生。彼于下地已得故能修。若依下地入正性离生。彼于上地未得故不修。设已得者而不自在。以不依彼入正性离生故。复次下地求上故上修下。上地不求下故下不修上。复次下地能断上故。上能修下。上地不断下故下不修上。复次下能办上事故。上须修下。上不能办下事故下不修上。复次犹如六种守护法故。谓三十三天。惧阿素洛。安布六军而自守护。一依海住龙。二坚手天。三持鬘天。四恒憍天。五四大王众天。六三十三天。若阿素洛。从自宫出。欲与诸天兴战诤时。依海住龙。先与战诤。若龙能胜阿素洛者。余五天军无事而住。若不能胜。坚手天军即助其力。若二能胜。余四天军无事而住。若不能胜。持鬘天军复助其力。若三能胜。余三天军无事而住。若不能胜。恒憍天军复助其力。若四能胜。余二天军无事而住。若不能胜。四大王军复助其力。若五能胜。三十三天无事而住。若不能胜。三十三天与前五军。相助战诤。令阿素洛退败驰走。如是见道。为欲对治见所断惑安布六地。一未至定乃至第六。第四静虑若依未至定入正性离生。未来唯修一地。见道即能永断见所断惑。其余五地无事而住。若依初静虑入正性离生。未来便修二地。见道相助永断见所断惑。其余四地无事而住。若依静虑中间入正性离生。未来便修三地。见道相助永断见所断惑。其余三地无事而住。若依第二静虑入正性离生。未来便修四地。见道相助永断见所断惑。其余二地无事而住。若依第三静虑入正性离生。未来便修五地。见道相助永断见所断惑第四静虑无事而住。若依第四静虑入正性离生。未来便修六地。见道相助永断见所断惑。故依上地能修于下。依彼下地不能修上。复次犹如依山六重池故。谓从山顶乃至于下。有六泉池连次流注。其最上水流遍六池。第二遍五第三遍四。乃至第六唯遍一池。如是六地所起见道。上能修下下不修上

问颇有世第一法。或寻相应非伺。或伺相应非寻。或寻伺俱相应。或寻伺俱不相应耶。答有寻相应非伺者。谓未至定初静虑伺。伺与自性不相应故。伺相应非寻者。谓寻及静虑中间除伺。余心心所法。寻伺俱相应者。谓未至定初静虑中除寻伺。余心心所法。寻伺俱不相应者。谓静虑中间伺。及上三静虑心心所法。并一切随心转色。心不相应行。问颇有世第一法。非有寻有伺。非无寻唯伺。非无寻无伺耶。答有。谓未至定初静虑伺。彼非有寻有伺。所以者何。如品类足说。云何有寻有伺法。答若法寻伺相应。彼伺虽寻相应而非伺故。亦非无寻唯伺。所以者何。如品类足说。云何无寻唯伺法。答若法伺相应非寻。彼伺唯寻相应非伺故亦非无寻无伺。所以者何。如品类足说。云何无寻无伺法。答若法寻伺不相应。彼伺唯伺不相应非寻故。问颇有世第一法。寻伺不相应。非非伺耶。答有。谓静虑中间伺。彼虽寻伺不相应。而非非伺。所以者何。伺自性故。问颇有世第一法。在有寻有伺地与伺相应非寻耶。答有。谓寻彼唯与伺相应故。问颇有世第一法。在无寻有伺地。是相应法。非伺相应耶。答有。谓静虑中间。伺彼与自性。不相应故。问颇有世第一法在有寻有伺地。而有三种。谓有寻有伺。无寻唯伺。无寻无伺耶。答有有寻有伺者。谓未至定。及初静虑。除寻伺。余心心所法。无寻唯伺者谓寻。无寻无伺者。谓随心转色。心不相应行。问颇有世第一法。在无寻唯伺地。而有二种。谓无寻唯伺。无寻无伺耶。答有无寻唯伺者。谓静虑中间除伺。余心心所法。无寻无伺者。谓彼地伺。及随心转色。心不相应行

世第一法。当言乐根相应。乃至广说。问何故作此论。答虽已说彼依地差别。而未分别与何相应。今欲分别。如已知人所居宅等而未知彼朋友伴侣。此亦如是。故作斯论。有作是说。虽已显示世第一法通在三地。而未说彼通在六地。今显彼与三根相应。欲令知彼通在六地。分明现见如掌中果。由是因缘故作此论。世第一法。当言乐根相应。喜根相应。舍根相应耶。答应言或乐根相应。或喜根相应。或舍根相应。先已说彼非欲界系。即知不与忧苦相应。是故唯依三根作论。虽总说彼三根相应。而未显示相应差别。故应复说差别之相。云何乐根相应。答若依第三静虑。入正性离生。彼所得世第一法。然第三静虑。世第一法。或乐根相应。或不相应。乐根相应者。谓除乐根。余心心所法。不相应者。谓即乐根。及随心转色。心不相应行。今且说余心心所法。故说彼与乐根相应。云何喜根相应。答若依初二静虑。入正性离生。彼所得世第一法。然初二静虑世第一法。或喜根相应。或不相应。喜根相应者。谓除喜根。余心心所法。不相应者。谓即喜根。及随心转色。心不相应行。今。且说余心心所。故说彼与喜根相应。云何舍根相应。答若依未至第四静虑。入正性离生。彼所得世第一法。问何故不说静虑中间。答此文应作是说。若依未至静虑中间第四静虑。入正性离生。彼所得世第一法。而不尔者。有何意耶。答已说未至应知。亦说静虑中间。所以者何。以未至声亦显彼故。俱是未至根本地故。如大种蕴说。大种依何定灭。答依四或未至故。然此三地。世第一法。或舍根相应。或不相应。舍根相应者。谓除舍根。余心心所法。不相应者。谓即舍根。及随心转色。心不相应行。今且说彼余心心所。故说彼与舍根相应。问颇有世第一法。不与乐根喜根舍根相应耶。答有。谓彼随心转色。心不相应行。问颇有世第一法是相应法而不与乐喜舍根相应耶。答有。谓即三根。以彼不与自性他性根相应故

说一切有部发智大毗婆沙论卷第四阿毗达磨大毗婆沙论卷第五

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中世第一法纳息第一之四

世第一法。当言一心多心耶。乃至广说。问何故作此论。答虽已说彼相应差别。而未显示现前多少。今欲显示唯一刹那。故作斯论复次为欲遮遣他宗义故。如分别论者执。世第一法。相续现前。彼说相续总有三种。一时相续。二生相续。三相似相续。世第一法。虽无前二。而有后一。今欲遮遣彼所执义显世第一法唯一念现前。复次为令疑者得决定故。谓先已说。若心心所法。为等无间入正性离生。是谓世第一法。勿有生疑。如心所法既有多种心亦应然。为令彼疑得决定故。显心所法虽有多种而心唯一。由此因缘。故作斯论。世第一法当言一心多心耶。答应言一心。问如前已说。未来修者。亦得名为世第一法。是则此法应有多心。而言一心斯有何意。答此中但说现在前者故言一心。问今于此中何故不说未来修者。答应说而不说者。当知此义有余。此中复有多复次释。前已说故今不说之。虽说一心而未释义。何故此法非多心耶。非但有言义则可了。答从此心心所法无间。不起余世间心唯起出世心。世间心者谓有漏堕有心。即所遮止第二念等世第一法。出世心者。谓无漏断有心。即所引起苦法智忍相应之心。若当起余世间心者。为劣为等为胜。无有是处。为分别故假设斯问。劣等胜者。对前刹那。但有三故。若当劣者应不能入正性离生。何以故。非以退道能入正性离生故。谓非衰退萎悴坠落破坏之道能入正性离生。要以胜进增盛勇猛坚固之道。能入正性离生故。若当等者。亦不能入正性离生。何以故。先以此类道不能入正性离生故。谓此初后品类。相似如初刹那。有障碍有留离。无势力故。不能入正性离生。后诸刹那亦应如是如初刹那。不能无间引起圣道。后诸刹那亦应如是。品类同故。则应究竟不能证入正性离生。如是应无解脱出离。若当胜者。先应非世第一法。后方是世第一法。以世第一法声。显最胜等义故。问先者既非世第一法。为是何法。答是增上忍。问何故见道唯胜加行无间。引生于修道。中引生圣道。通劣等胜。答以见道是未曾得道。要多功用。加行作意。方能现前。是故唯胜加行。引起修道。既是本曾得道。不多功用。加行作意而现在前。故劣等胜皆能引起。然世第一法与第一法。为因缘增上缘。因缘者有三因。谓相应因。俱有因。同类因。此是总说。若别说者。过去与过去为二因。谓相应俱有。与未来为一因。谓同类未来与未来为二因。谓相应俱有。现在与现在为二因。谓相应俱有。与未来为一因。谓同类增上缘者。谓不碍生及唯不障

世第一法。当言退不退耶。乃至广说。问何故作此论。答虽已说彼一心非多。而未分别为退不退。今欲分别故作此论。复次为止他宗显正义故。谓或有执。世第一法亦有退者。为止彼意。显示此法决定不退故作斯论。世第一法当言退不退耶。答应言不退。虽有此说应更显示不退因缘。非但有言义便显了。何故此法定不退耶。答世第一法。随顺谛趣向谛临入谛。此彼中间。无容得起不相似心。令不得入圣谛现观。问云何名为随顺谛。趣向谛。临入谛耶。有说此中现观说名为谛。谓世第一法。随顺现观。趣向现观。临入现观。有说此中道谛说名为谛。谓世第一法。随顺道谛。趣向道谛。临入道谛。有说此中见道说名为谛。谓世第一法。随顺见道。趣向见道。临入见道。有说此中苦谛说名为谛。谓世第一法。随顺苦谛。趣向苦谛。临入苦谛。有说此中苦法智忍名谛。谓世第一法。随顺苦法智忍。趣向苦法智忍。临入苦法智忍。然于此中随顺有二。一趣向随顺。二临入随顺。世第一法。于苦法智忍。具二随顺。为等无间缘。引生彼故。此彼中间。无容得起不相似心者。谓此世第一法。彼苦法智忍中间。无容得起有漏堕有不相似心。令不得入圣谛现观者。谓令苦法智忍不得现前。问世第一法。既是有漏与无漏心。可不相似。何故乃说有漏堕有心名不相似。无漏断有心名相似耶。答世第一法。厌恶有漏。趣向无漏。故说有漏名不相似。无漏名相似。背此向彼故。犹如有人为自亲里之所苦恼。依附他人以为救护。于自亲里作他人想。于他人处作亲里想。此亦如是。复有说者。世第一法。以与苦法智忍同办一事。谓舍异生性等。故说有漏。名不相似。无漏名相似。同办一事故。为于前义。乃至愚夫。亦能解了。故说现喻。譬如壮士渡河渡谷渡山渡崖。中间无能回转。彼身还至本处。或往余处。先所发起。增上身行未至所趣。必不止息。世第一法亦复如是。随顺谛。趣向谛。临入谛。此彼中间。无容得起不相似心。令不得入圣谛现观。此中渡河者。谓从此岸往趣彼岸。渡谷者。谓从此边往趣彼边渡山者。谓从此峰往趣彼峰渡崖者。谓从高趣下。或如有人。从屋[木*脊]堕。未至地顷。便起是心。我当腾踊却还本处。彼如意不无如是事。假使彼人。或以神力。或以咒术。或以药物。还至本处。可有是事。然从世第一法。未至苦法智忍。中间能起不相似心。令不得入圣谛现观。无有是处。为令此义转得明了。故今复举第二现喻。如赡部洲。有五大河。一名殑伽。二名阎母那。三名萨落瑜。四名阿氏罗筏底五名莫醯。如是五河。随顺大海。趣向大海。临入大海。中间无能回转。彼流还至本处。或往余处。彼决定能流入大海。世第一法。亦复如是。随顺谛。趣向谛。临入谛。彼此中间。无容得起不相似心。令不得入圣谛现观。问前喻今喻。有何差别。又前于义。有何不尽而更须说第二喻耶。有说。二喻于义无别。欲令前喻所显义理转复增明。故说今喻。有说。二喻亦有差别。前喻为遮不如理事。后喻为显如理事故。复次前以内分具足为喻后以外分具足为喻。复次前喻为止内分留难。后喻为止外分留难。如五大河流入大海。无能回彼还至本处谓令还入无热恼池。无能转彼往趣余处。谓使傍流或左或右。前喻回转准此应知。彼五大河未入海顷。颇有能令不入海不。无如是事。假使有人。或以神力。或以咒术。或以药物。令至本处。可有是事。然世第一法。未至苦法智忍。中间能起不相似心。令不得入圣谛现观。无有是处。尊者造此发智论时。住在东方。故引东方。共所现见。五河为喻。而实于此赡部洲中。有四大河眷属各四。随其方面流趣大海。谓即于此赡部洲中。有一大池名无热恼。初但从彼出四大河。一名殑伽。二名信度三名缚刍四名私多。初殑伽河。从池东面金象口出右绕池一匝流入东海。次信度河。从池南面银牛口出。右绕池一匝流入南海。次缚刍河。从池西面吠琉璃马口出。右绕池一匝流入西海。后私多河。从池北面颇胝迦师子口出。右绕池一匝流入北海。殑伽大河。有四眷属。一名阎母那。二名萨落瑜。三名阿氏罗筏底四名莫醯。信度大河。有四眷属。一名毗[竺-二+跛]奢。二名蔼罗筏底。三名设呾荼卢。四名毗呾婆多。缚刍大河。有四眷属。一名筏刺弩。二名吠呾刺尼。三名防奢。四名屈蠢婆。私多大河。有四眷属。一名萨梨。二名避魔。三名捺地。四名电光。如是且说有大名者。然四大河。一一各有五百眷属。并本合有二千四河。随其方面流趣大海。如是所说。二千四河未入海顷。颇有能令不入海不。无如是事。假使有人。或以神力。或以咒术。广说乃至。令不得入圣谛现观。无有是处

复次世第一法。与苦法智忍作等无间缘。无有一法速疾回转过于心者。可于尔时能作障碍令不得入圣谛现观。是故此法决定不退。此中复次难释如前。谓此前文但是方便开纵论道。今所说者乃是根本遮夺论道故。应言复次及如本文说。此中意说。世第一法。与苦法智忍。作等无间缘。此正灭位取果与果。彼苦法智忍次必现前。若法与彼法为等无间缘。正灭位中取果与果。若法若有情若咒术。若药物若佛若独觉。若到彼岸。诸声闻等。能作障碍。使第二念不现前者。无有是处。此中所言。无有一法速疾回转过于心者。应知即是苦法智忍相应之心。此心必定速疾现前。无有余法速疾回转过于此故。如世尊说苾刍当知。我不见一法速疾回转犹如心者。乃至广说。彼契经文。如后定蕴当广分别。以佛说心速疾回转过余法故。世第一法无间刹那。苦法智忍必现在前。是故此法决定不退

于此义中复有分别。问何缘世第一法定不退耶。答加行广大故。安足坚牢故。加行广大者。谓彼所习施戒闻思修所成善。悉以回向解脱涅槃心无所著。施者即是庄严心施。戒者即是别解脱戒。闻所成者。谓于圣教决择文义思所成者。谓不净观持息念。念住三义观七处善。修所成者。谓暖顶下中忍。安足坚牢者谓增上忍。由世第一法。加行广大。安足坚牢。故定不退。复次以此法后总证三界见所断断。非于三界见所断断有还退者。是故不退。复次以此法后总证非想非非想地见所断断。非于非想非非想地见所断断有还退者。是故不退。复次以此法后必起忍智。非于忍智有还退者。是故不退。复次以此法后必起见道以为重镇决定无有退。见道者是故不退。问因论生论。何缘见道定不退耶。答以彼见道是速疾道无留难道。非中起道是故不退。复次以彼行者堕在见道。大法駃流为流[漂*寸]激无容可退。其心慢缓方可退故。如人堕在山谷暴流为流所[漂*寸]无得暂住。行者亦尔是故不退。复次退者多起烦恼现前。住见道时无覆无记。有漏善心尚不得起。何况得起烦恼之心。是故不退。复次以住见道。总证三界见所断断。非于三界见所断断有还退者。是故不退。复次以住见道总证非想非非想地见所断断。非于非想非非想地见所断断有还退者。是故不退。复次若从见道有还退者。应见谛已还不见谛。应得果已还不得果。应现观已还不现观。应入正性离生已。还不入正性离生。应成圣者已还作异生。应住定聚已还住不定聚。勿有如是众多过失。是故见道决定不退。有作是说。以此善根唯一刹那无有能退半刹那者。是故不退。或有说者。以此善根似无间道。非住无间道可有退者。是故不退。复有说者。以此善根是顺胜分。非住顺胜分可有退者。是故不退。然有三种顺决择分。一顺退分。二顺住分。三顺胜分。谓顺退者。名顺退分。若顺住者。名顺住分顺胜进者。名顺胜分。暖具三种。顶亦具三。有说。唯二除顺住分。以顶位是进退际故。忍亦有二。除顺退分。世第一法。唯顺胜分。是故此位定无退理问此中三分。一切皆是顺决择分善根所摄。与后定蕴所说四分有何差别。答所依各异。谓此但依随顺见道。总立一种顺决择分。于中义别复开三种。后定蕴中。总依有漏修所成善。建立四分。若顺退者。名顺退分。若顺住者。名顺住分。若顺胜进者。名顺胜进分。若顺圣道者。名顺决择分。是故此彼所依各异

问颇有世第一法。缘有所缘法耶。缘无所缘法耶。缘有所缘法。亦缘无所缘法耶。非缘有所缘法。亦非缘无所缘法耶。答有缘有所缘法者。谓若世第一法。缘心心所法。缘无所缘法者。谓若世第一法。缘色心不相应行。缘有所缘法。亦缘无所缘法者。谓若世第一法。缘心心所法。及缘色心不相应行。非缘有所缘法。亦非缘无所缘法者。谓随心转色。及随心转心不相应行。世第一法。问颇有住一刹那顷。当得缘有所缘法。世第一法耶。缘无所缘法。世第一法耶。缘有所缘法。亦缘无所缘法。世第一法耶。非缘有所缘法。亦非缘无所缘法。世第一法耶。答有。谓住增上忍时。当得如上所说四句。世第一法。问颇有住一刹那顷。当得世第一法非彼所缘耶。当得彼所缘非世第一法耶。当得世第一法及彼所缘耶。不当得世第一法。及彼所缘耶。答有。住增上忍时。应作此四句。且依未至定。入正性离生者。住增上忍时。当得世第一法。非彼所缘者。谓未至定所摄。世第一法中。除缘当现在前。所依世第一法。诸缘所余境。世第一法。当得彼所缘。非世第一法者。谓上五地所摄。世第一法中。缘当现在前。所依世第一法。当得世第一法。及彼所缘者。谓未至定所摄。世第一法中。缘当现在前。所依世第一法。不当得世第一法及彼所缘者。谓上五地所摄。世第一法中。除缘当现在前。所依世第一法。诸缘所余境。世第一法。如依未至定。入正性离生者。住增上忍时。作此四句。依上五地入正性离生者。住增上忍时。应知亦尔。问颇有成就世第一法。不成就彼离系得耶。答应作四句。成就世第一法。不成就彼离系得者。谓若依此地。入正性离生。彼未离此地染。成就彼离系得。不成就世第一法者。谓若依此地。入正性离生。彼命终生上地。成就世第一法。亦成就彼离系得者。谓若依此地入正性离生。彼已离此地染。不命终生上地。不成就世第一法。亦不成就彼离系得者。谓若未能入正性离生位。有余依彼有漏离系得。作如是言问颇有圣者。成就世第一法。不成就彼离系得耶。答应作四句。成就世第一法。不成就彼离系得者。谓若依此地入正性离生。彼未离此地染。成就彼离系得。不成就世第一法者。谓若依此地入正性离生。彼命终生次上地。成就世第一法。亦成就彼离系得者。谓若依此地入正性离生。彼已离此地染。不命终生上地。不成就世第一法。亦不成就彼离系得者。谓若依此地入正性离生。彼命终超次上地。生余上地有余依一切世第一法。及彼一切离系得。作如是言。问颇有成就世第一法。不成就彼离系得耶。答应作四句。第一句者。谓若依未至定。或初静虑。静虑中间。入正性离生。彼未离初静虑染。第二句者。谓若依此地入正性离生。彼命终生上地。若未得世第一法。生欲色界已。离初静虑染。及生空无边处。第三句者。谓若依此地入正性离生已。离初静虑染。不命终生上地。第四句者。谓除前相

尊者此中。七门分别。世第一法。谓初云何世第一法。乃至第七世第一法。当言退不退耶。于中前三门是根本论。后四门是因生论。世第一法。由此七门。分别显示。极为明了

云何顶乃至广说。问先应说暖。后方说顶。如何于此先说顶耶。答如前已说。此中逆说。异生身中净染诸法。故先说顶后方说暖。问若尔此中应先说忍。何故于此超说顶耶。答先已说忍而不彰显。谓先已说若当胜者。先应非世第一法。后方是世第一法。先者是何。谓增上忍。既已说忍。故今说顶。问尊者何故覆相说忍。而不彰显广说忍耶。答亦应彰显广说忍相。谓云何忍何故名忍。忍当言何界系。及因生论。皆应广说。而不说者。有何意耶。答是作论者意欲尔故。谓作论者。随自意欲。或显或隐。或广或略。而作此论。不应征诘。尊者此中彰显广说世第一法。隐略说忍。于顶及暖显略而说。有余师说。若契经中。显了说者。尊者于此彰显而说。忍于经中不显了说。是故于此覆相说之。问岂不经中显了说忍。如世尊说。若有一类成就六法。于现法中。必不能得远尘离垢。于诸法中生净法眼。云何六法。一不乐闻法。二虽闻说法而不嘱耳。三虽嘱耳听。而不安住奉行教心。四于未证善法不勤求证。五于已证善法不勤守护。六不成就顺忍。应知白品与此相违。忍于此经既彰显说。尊者何故覆相说耶。彼作是言。经中虽说顺忍。而不说顺谛忍。故非显说。问顺忍顺谛忍。有何差别。义无异故。应知前说为善。问因论生论。何故此忍独名顺谛。非暖顶耶。答亦应说顺谛暖顺谛顶。而不说者。当知此是有余之说。义皆有故。复次言顺谛者。谓极随顺圣谛现观。忍极随顺圣谛现观。暖顶不尔故偏说忍。复次忍邻近见道。暖顶不尔故。复次忍与见道相似。暖顶不尔故。谓见道位唯法念住。恒现在前忍位亦尔暖顶不然。谓彼初位虽但起法念住。而增进位。亦得起余三念住故。复次忍位。必有不出意乐趣入圣道。暖顶不尔故。复次修观行者。于忍位中乐别观谛。于顶位中乐别观宝于暖位中乐别观蕴故。复次暖止缘谛下愚。顶止缘谛中愚。忍止缘谛上愚故。复次暖止缘谛粗愚。顶止缘谛中愚。忍止缘谛细愚故。复次暖起缘谛下明顶起缘谛中明。忍起缘谛上明故。复次暖起缘谛粗明。顶起缘谛中明。忍起缘谛细明故。复次暖得缘谛下信。顶得缘谛中信。忍得缘谛上信故。复次暖得缘谛粗信。顶得缘谛中信。忍得缘谛细信故。复次以忍位中。或时以十六行相。观察圣谛。或时以十二行相。观察圣谛。或时以八行相。观察圣谛。或时以四行相。观察圣谛。暖顶位中。但以十六行相。观察圣谛故。复次以忍位中无杂作意。暖顶位中有杂作意故。谓暖顶位。数数复起欲界善心观欲界苦。为间杂已。复能引此善根现前。忍位不尔。复次以忍位中唯别作意别观诸谛。暖顶位中不如是故。谓暖顶位。虽别作意别观诸谛。而于中间。修总行相总观诸谛。谓观一切有漏皆苦。观一切行皆是无常。观一切法皆空无我。唯观涅槃是真寂静。复次以忍位中有时相续。有一刹那观察圣谛。暖顶位中唯有相续观圣谛故。复次以忍位中渐略观谛。极能随顺。趣向涅槃。如适他方。以多贸少。暖顶位中不如是故。以如是等种种因缘。忍名顺谛。暖顶不尔。问世第一法。何故不立顺谛名耶。答虽复此位一切皆胜。而于四谛不遍观察故。不建立顺谛之名

问忍为几念住。答现在唯一。杂缘法念住。未来具四似见道故。问忍为几缘。答为四缘。谓因等无间所缘增上缘。为因缘者。谓与彼相应俱有同类等法为因缘。为等无间缘者。谓与世第一法为等无间缘。为所缘缘者。谓与能缘此心心所法为所缘缘。为增上缘者。谓除自性与余一切有为法为增上缘。问忍有几缘。答有四缘。有因缘者。谓此相应俱有同类法。有等无间缘者。谓已生顶。有所缘缘者谓四圣谛。有增上缘者。谓除自性余一切法。问忍当言何界系。答应言唯色界系。问忍当言有寻有伺。无寻唯伺。无寻无伺耶。答应言三种。问忍当言乐根相应。喜根相应。舍根相应耶。答应言三根相应。问忍当言一心多心耶。答应言或多心或一心。以增上忍一刹那故。问忍当言退不退耶。答应言不退。如是等义。依上所说。世第一法。如理应知

问缘何谛忍后入正性离生耶。有作是说。缘道谛忍后入正性离生问若尔云何所缘行相。不成倒错。若倒错者。云何不与入正性离生而作留难。答此于所缘行相。虽有倒错。而于入正性离生不作留难。所以者何。已串习故。谓修行者于此串习已成径路自在现前。如见道中。缘欲界忍智。后缘有顶忍智现在前。缘有顶忍智。后缘欲界忍智现在前。缘苦谛行相。后缘集谛行相现在前。缘集谛行相。后缘灭谛行相现在前。此等所缘行相。虽有倒错。而于现观不作留难。已串习故此忍亦尔。若作是说。缘道谛忍。后入正性离生者。则有三心。同一所缘。同一行相。谓世第一法。苦法智忍。苦法智相应二心。同一行相。不同一所缘。谓苦类智忍。苦类智相应二心。同一所缘。不同一行相。谓集法智忍。集法智相应余心。不同一所缘。不同一行相。如是说者。缘苦谛忍。后入正性离生。所以者何。见道是无漏善根。有大势力。虽所缘行相有倒错。而于现观不作留难。忍是有漏善根。无大势力。若所缘行相有倒错者。则于入正性离生便作留难。故修行者住忍位中。所缘行相。先广后略。由此得入正性离生。谓彼先以四行相观欲界苦。次以四行相观色无色界苦。次以四行相。观欲界诸行因。次以四行相。观色无色界诸行因。次以四行相。观欲界诸行灭。次以四行相。观色无色界诸行灭。次以四行相。观欲界诸行道。后以四行相。观色无色界诸行道。齐此名下忍。从此以后。渐渐略之。谓复以四行相。先观欲界苦。次观色无色界苦。乃至最后观欲界诸行道。渐次略去色无色界诸行道。复以四行相。先观欲界苦。次观色无色界苦。乃至最后观色无色界诸行灭。渐次略去一切诸行道复以四行相。先观欲界苦。次观色无色界苦。乃至最后观欲界诸行灭。渐次略去色无色界诸行灭。复以四行相。先观欲界苦。次观色无色界苦。乃至最后观色无色界诸行因。渐次略去一切诸行灭。复以四行相。先观欲界苦。次观色无色界苦。后观欲界诸行因。渐次略去色无色界诸行因。复以四行相。先观欲界苦。后观色无色界苦。渐次略去一切诸行因。复以四行相。观欲界苦。渐次略去色无色界苦。彼于欲界苦。以四行相。相续观察。复渐略之。至一行相二刹那观察。如苦法智忍及苦法智。齐此名中忍。彼复于欲界苦。一刹那观察如苦法智忍。此名上忍。从此无间复一刹那观欲界苦。名世第一法。从此无间生苦法智忍。展转乃至。生道类智。譬如有人。欲从己国适于他国。多有财产不能持去。遂以易鋀犹嫌其多。复以易金犹嫌金重。复以贸易大价宝珠。持此宝珠随意所往。行者亦尔。先广观察上下诸谛。后渐略之。乃至唯以一刹那心。观欲界苦。次生世第一法。次生苦法智忍。展转乃至生道类智。若如是说缘苦谛忍。后入正性离生。则有四心。同一所缘。同一行相。谓增上忍。世第一法。苦法智忍。苦法智相应二心。同一行相。不同一所缘。谓苦类智忍。苦类智相应。二心同一所缘。不同一行相。谓集法智忍。集法智相应余心。不同一所缘。不同一行相问世第一法。亦如忍有三品耶。答一相续中则无。多相续中则有。谓佛种性是上品。独觉种性是中品。声闻种性是下品。依六种性。三根说亦尔

说一切有部发智大毗婆沙论卷第五阿毗达磨大毗婆沙论卷第六

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中世第一法纳息第一之五

云何顶。答于佛法僧生小量信。问何故名顶。答如山顶故。谓如山顶人不久住。若无诸难便过此山。更至余山。若有诸难即还退下。如是行者。至顶位中必不久住。若无诸难便进至忍。若有诸难还退住暖。有说此应名为下。顶以在最下。顺决择分。暖法上故。有说此顶应名为中。以在下暖上忍中故。尊者妙音作如是说。顺决择分总有二种。一欲界系。二色界系。欲界系中。下者名暖。上者名顶。色界系中。下者名忍。上者名世第一法。此于欲界顺决择分中胜故名顶。彼不应作是说此四皆是。定地修地。行圣行相。色界法故。应作是说。顺决择分总有二种。一可退二不可退。可退中下者名暖。上者名顶不可退中。下者名忍。上者名世第一法。此于可退顺决择分中胜故名顶。问何故此信名小量耶。尊者妙音作如是说。欲界名小。以下劣故。此在欲界故名小量。有说此信应名异量。量谓决定信顺印可。故名为量。暖是第一顶是第二。此异于前。故名异量。有说此信应名少量以顶位中不久住故。如露悬枝不久停住。应作是说。此顶但应名小量信。在可退位乐观宝故。此中于佛僧生小量信者。说缘道谛信。于法生小量信者。说缘灭谛信。问此顶善根具以十六行相。缘四圣谛。何故此中但说缘灭道谛非苦集耶。答依胜说故。谓四谛中灭道是胜出生死故。复次灭道二谛清净无垢离过微妙。是可信事。是生信处。是所归依。是故偏说。复次灭道二谛。非唯可信亦是可求。难可证得极可欣故。苦集不尔是故不说。复次为受化者生信乐故。若佛为彼说苦集谛。便作是念。我无始来。为此鄙劣。烦恼恶行。及所得果。扰乱逼迫。宁可信乐。若说灭道。便深信乐。不欲舍离。故于此中。偏说灭道。有说于佛僧。生小量信者。说缘道谛信。于法生小量信者。说缘三谛信。以顶具缘四圣谛故。问缘灭道谛可尔。是可信事。是生信处。是所归依。应信乐故。缘苦集谛云何可尔。烦恼恶行及所得果。犹如粪秽深可厌患。不应于中生信乐故。答信有二种。一者信可。二者信乐。于灭道谛具二种信。于苦集谛虽无信乐。而有信可。故缘苦集亦生于信。如人掘地求水宝等。具二种信。一者信可。谓信地中有水宝等故。二者信乐。谓信水等是可欣乐故。胁尊者言。为厌患苦集故。称赞灭道。谓此灭道寂静美妙。止息对治下劣鄙秽苦集法故。如人风雨所逼恼故称赞舍宅。故于四谛皆可生信。然于道谛。亦非一切具二种信。谓随信行者。于随法行道具二种信。谓信可彼信乐彼故。随法行者。于随信行道。唯有一信。谓虽信可彼。而不信乐彼故。信胜解者。于见至道。具二种信见至者于信胜解道。唯有一信。时解脱者。于不时解脱道。具二种信。不时解脱者。于时解脱道。唯有一信。佛于佛道具二种信。于二乘道唯有一信。独觉于二道具二种信。于声闻道唯有一信。声闻于三道皆具二信。此中尊者。欲令前义得成立故。复引契经。如世尊为波罗衍拏摩纳婆说

  若于佛法僧　　生起微小信
  儒童应知彼　　名已得顶法

问此顶善根。十六行相。观四圣谛。何故世尊。为摩纳婆。说信三宝。答彼于三宝。愚惑不信。然三宝希有。难可值遇。欲令信解。故为说之。有说彼摩纳婆为苦所逼。欲求出要来诣佛所。说是颂言

  为苦所逼诸众生　　不知出要来诣佛
  唯愿为说除众患　　如热所逼入凉池

出苦之要无过三宝。故佛为说于三宝信。有说欲令所化于佛法中深生信重。故佛为说于佛法僧生微小信。若佛为说四圣谛者。所化有情便作是念。我等何用信重如是烦恼恶行颠倒见趣及所得果苦集谛为。若佛为说佛法僧宝。彼便踊跃深生信重。有说随修行者乐别观故。谓修行者于暖位中乐别观蕴。于顶位中乐别观宝。于忍位中乐别观谛。故于顶位说信三宝

如世尊告阿难陀言。吾今为汝等。说顶及顶堕。谓圣弟子。于五取蕴。起作有为缘生法中。思量观察。此是无常苦空无我。彼即于如是思量观察时。有忍有见。有欲乐有行解。有见审虑忍。如是名为顶。问何故世尊。为波罗衍拏。说信为顶。为诸新学苾刍。说慧为顶耶。答佛善知法相。及善知根器。应为说者即为说之。余无此能故不应问

复次波罗衍拏。住初业地未串习所作。未得奢摩他未入圣教。未修渐次。诸有所作皆藉他缘。闻他天神赞佛功德。于佛生信来诣佛所尔时世尊。依顶等流说信为顶。新学苾刍与彼相违。是故为说顶之自性。复次佛随所阙而为说故。谓波罗衍拏。有慧阙信故为彼说信为顶。新学苾刍有信阙慧故。为彼说慧为顶复次为止谄曲及愚痴故。谓波罗衍拏是婆罗门种。虽有智慧而阙净信。无信之慧增长谄曲。为止彼谄曲故说信为顶。新学苾刍是释迦种。虽有净信而阙智慧。无慧之信增长愚痴。为止彼愚痴故说慧为顶。复次世尊所化有利根者。有钝根者。为利根者说信为顶。为钝根者说慧为顶。如利根钝根。因力缘力。内分力外分力。内如理作意力。外从他闻法力。无痴增相续力。无贪增相续力。应知亦尔

云何顶堕。乃至广说。问何故此中。但说顶堕。不说暖耶答应说而不说者。当知此义有余。复次说胜有堕。已显劣故。谓顶善根是胜尚退。况暖善根劣而无退。有说不应诘问。尊者不说暖退因缘。所以者何。契经说故。谓契经中。但说顶堕。不说暖堕。尊者依经。而造此论故不应责。有说从顶退时。生大忧恼。退暖不尔。故不说之。谓如有人见宝伏藏。满中珍宝见已欢喜作是思惟。我今永绝贫穷根本。适欲取时忽然还灭。彼人尔时生大忧恼。如是行者住顶位中自念不久。入于忍位永舍恶趣。生大欢喜后退此顶。还住暖时生大忧恼。失胜利故。设从暖位进得顶时。彼犹未能永舍恶趣。故从彼退不大忧恼。有说住顶位时多诸留难住暖不尔。是故偏说。故如是说。于三时中诸业烦恼。极与行者而作留难。一从顶入忍时能感恶趣诸业烦恼极为留难。义言行者若入忍位定不复受诸恶趣生。我于谁身受异熟果。二圣者离欲染时。能感欲界诸业烦恼极为留难。义言行者。若离欲染于欲界生。定不复受我于谁身受异熟果。三得阿罗汉果时。能感后有诸业烦恼极为留难。义言行者若得阿罗汉果。定不复受一切生死。我于谁身受异熟果。有说顶不久住是进退际故。暖位不尔故不说暖堕。有说住顶位时将获大利。犹如圣者得不堕法得忍。异生亦复如是。如室路拏二十俱胝九十一劫不堕恶趣。从顶退时失此大利。故说顶堕。退暖不尔故不说之

云何顶堕。答如有一类。亲近善士听闻正法。如理作意信佛菩提法。是善说增修妙行。色无常。受想行识无常。善施设苦谛。善施设集灭道谛。彼于异时。不亲近善士。不听闻正法。不如理作意。于已得世俗信。退没破坏移转亡失。故名顶堕。问何故作此论。答前虽说顶自性。而未说顶云何得云何舍。今欲说之故作此论。亲近善士者。谓亲近善友。听闻正法者。谓属耳听闻。如理所引。诃毁流转。赞叹还灭。顺瑜伽法。如理作意者。谓自内正解信佛菩提法。是善说增修妙行者。显信三宝。色无常受想行识无常者。显信五蕴。善施设苦谛。善施设集灭道谛者。显信四谛。此中信佛菩提。乃至信善施设道谛。皆共显示法随法行。此及前三。即是显示四预流支。是名得顶。问佛为何等所化有情。于顶位中显示三宝。复为何等显示五蕴。又为何等显示四谛。答为愚宝者显示三宝。为愚蕴者显示五蕴。为愚谛者显示四谛。复次为初业者显示三宝为已串习者显示五蕴。为已超作意者显示四谛复次为钝根者显示三宝。为中根者显示五蕴。为利根者显示四谛。复次为疑行者显示三宝。为我慢行者显示五蕴。为诸邪见损觉慧者显示四谛。有作是说。为乐广者显示三宝。为乐略者显示四谛。为乐广略者显示五蕴。是名三种所为差别。已说得顶。云何舍顶。彼于异时者。谓彼散乱时。不亲近善士者。谓亲近恶友。不听闻正法者。谓作意听闻非理所引。赞叹流转诃毁还灭。违瑜伽法。不如理作意者。谓自内邪解。于已得世俗信。退没破坏。移转亡失者。谓于已得即顶位中。顶等流世俗信。退没破坏。移转亡失

此中尊者。欲令顶堕义得成立故。复引契经为证。如佛即为波罗衍拏摩纳婆说

  若人于如是　　三法而退失
  我说彼等类　　应知名顶堕

问何等名为顶堕自性。答顶堕自性是不成就。无覆无记心不相应行蕴所摄。有说信时名得顶。不信时名顶堕。如是则说。不信为顶堕自性。有说诸烦恼缠。能令顶堕。如是则说诸染污法。为顶堕自性。有说若法随顺退彼法。名顶堕。如是则说一切法为顶堕自性。以退顶时一切法皆是退顶。增上缘故。譬喻者言。此但假说无实自性。谓相续中。先成就顶。今时退失。说为顶堕。如何求觅顶堕自性。如人有财名为富者。若贼劫去即名贫人。他问汝贫以何为性。彼答我昔多有珍财。今被劫去唯名贫者。当有何性。又如有人先着衣服。后贼夺去即便露形。他问汝今露形以何为性。彼答我先有衣。今贼夺去。唯露形住。当有何性。又如有人衣服破坏。他问汝衣破坏以何为性。彼答我衣本完今已破坏。唯名衣破。当有何性。如是行者先成就顶今时退失。说名顶堕无别自性。评曰初说为善。此即摄在。复有所余如是类法。不相应中。不相应行有多种故

云何暖乃至广说。问何故名暖。答智于境转。故有胜智。暖生能烧诸烦恼薪。故名为暖犹如钻火。上下相依有火。暖生能烧薪等。有说诸有相依故。有堕有智暖生。能令诸有皆悉萎悴。故名为暖。犹如夏时聚花为[卄/積]。花生暖气还自萎悴。又如夏时积聚粪壤。中生暖气还自腐烂。有说诸蕴相依故。有堕蕴智暖生。能烧蕴林令其永灭。故名为暖。如竹[竺-二+韋]等相摩暖生。能烧彼林令为灰烬。尊者妙音作如是说。依求解脱有善根生。是圣道日前行前相。故名为暖。如日将出明相先现。复次依求解脱有善根生。是圣道火前行前相。故名为暖。如火将然烟为前相

云何暖。答若于正法毗奈耶中。有少信爱。即信名爱故名信爱。于正法中。有信爱者。说缘道谛信。于毗奈耶中。有信爱者。说缘灭谛信。问此暖善根。具以十六行相。缘四圣谛。何故此中。但说缘灭道谛非苦集耶。答依胜说故。谓四谛中灭道是胜。出生死故。余如顶中广说。有说于正法中。有信爱者。说缘三谛信。于毗奈耶中。有信爱者。说缘灭谛信。以暖具缘四圣谛故。问缘灭道谛可尔。是可信事。是生信处。是所归依。应信爱故。缘苦集谛。云何可尔。烦恼恶行及所得果。犹如粪秽深可厌患。不应于中生信爱故。答信有二种。一者信可。二者信爱。于灭道谛具二种信。于苦集谛虽无信爱而有信可。故缘苦集亦生于信。余广说如顶。问诸于正法毗奈耶中。有少信爱者。彼皆得暖耶。答不尔。所以者何。暖是色界定地修地。十六行相所摄善根。此中说有如是信爱。非余信爱故言不尔

此中尊者。引经为证。如世尊为马师井宿二苾刍说。此二愚人。离我正法及毗奈耶。譬如大地去虚空远。此二愚人。于我正法毗奈耶中。无少分暖。此经文句。虽已隐没。而作论者以愿智力引之为证。问此暖善根殊胜微妙住寂静地。世尊何故名少分耶。答此于所余顺决择分。最微小故得少分名。有说此于正法毗奈耶中。观事不共微小善根。后边生故说名少分。问诸有未得暖善根者。皆如此二被诃摈耶。答不尔。所以者何。世尊所化。总有三种。一于佛法有意乐。二于佛法息意乐。三于佛法无意乐。此二苾刍于佛正法。全无意乐故佛诃摈。诸如是类亦被诃摈。非余未得暖善根者。有说此二苾刍舍离亲爱归佛出家。然于正法毗奈耶中。全无信爱可以摄受故佛诃摈。非余未得暖善根者。即彼经中。世尊先告马师井宿二苾刍言。吾当为汝说四句法。汝欲知不当恣汝意。二苾刍言。我今何用。知尊法为。问此中何者是四句法。有说四圣谛是。所以者何。彼不见谛造恶行故。有说四念住是。所以者何。彼由颠倒造恶行故。有说四正断是。所以者何。彼由懈怠造恶行故。有说四神足是。所以者何。彼阙胜德造恶行故。有说四圣种是。所以者何。彼贪利养造恶行故。有说四沙门果是。所以者何。彼实未得四沙门果。而称我得造恶行故。有说四无量是。所以者何。彼由贪嗔嫉妒增上。造恶行故。有说四静虑是。所以者何。彼由欲界烦恼增上造恶行故。有说四善巧是。谓界善巧。处善巧。缘起善巧。处非处善巧。所以者何。彼愚因果造恶行故。有说即四种顺决择分善根是。所以者何。佛说彼二人无少分暖故。有说即增一阿笈摩中。四法迹是。一无贪法迹。二无嗔法迹。三正念法迹。四正定法迹。有说即杂阿笈摩中。四句法是。如彼颂言

  贤圣法中善言最　　二常爱言远不爱
  三常实言离虚诳　　四常法言远非法

如是说者。四圣谛是彼愚谛理背圣教故。问佛深知彼不堪受法。如何以法而恣彼耶。答佛欲自显无过失故。勿有谓彼无教化者。故造恶行而自毁坏。是以如来举手告言。诸教化事我皆能作。而汝不受自行邪行。以自损坏非我过也。有说为止释种不信心故。若不以法而恣彼者。无量释种生不信心。云何义成。于自亲族心怀悭嫉不欲教化。将恐彼人与己相似。由佛以法而恣彼意。是诸释种不信心息。有说为止外道诽谤业故。若不以法而恣彼者。无量外道便诽谤言。云何名为得大悲者。若诸弟子随顺恭敬便为说法。若诸弟子违逆不敬则不教化。由佛以法而恣彼意。是诸外道诽谤便息。有说令彼证知过在己故。佛以软语而责彼言。汝本及今恒造恶行。我常教化都不信受。今复为汝欲说法要汝言何用知尊法为。汝之过失汝自为证。有说令彼后时种善根故。佛知彼二。今虽不能受我正法。而命终已生龙趣中。便自忆念昔大悲者。恣我正法而我不受。今生恶趣受诸苦恼。由此便起悔俱善根。以此因缘速脱恶趣。有说为护佛法令不坏故。佛知彼二。从此命终当生龙趣。剧苦所逼作是念言。我从何没来生于此。即自忆念从人中来。复自念言。昔作何业。便自观见昔曾出家不能正行堕在此处。次作是念佛不化我故令我今生此恶处。便起嗔恨欲来人中。破窣堵波坏僧伽蓝。杀诸苾刍苾刍尼等。令如来法殄灭无余。当于尔时佛神力故。有如来像住立其前。而告之言。马师井宿。吾当为汝说四句法。汝欲知不当恣汝意。时二毒龙即便自忆。昔佛亦作如是告我。我时不受是我自咎非如来过。由此因缘嗔缠遂息。生大惭愧护持佛法。由如是等种种因缘。佛以正法而恣彼意。问何故二人作如是说我今何用知尊法为。答彼二自知造诸恶行。非正法器故说是言。彼自思惟于生天论。我尚非器况极微细解脱论耶。有说彼二自知。数犯禁戒。恶行烦恼。损坏相续。焦塼瓦等可令生芽。我等闻法生解脱芽。无有是处故作是说。我今何用知尊法为。有说彼二自知。造作增长恶趣定业故作此言。有说彼二身中恶相现故。谓彼自见于十指端有十道水将欲流出。便作是念我等决定当生龙中。于如是时。何用更知世尊正法。故作是说何用知为。有说佛记彼二。已种独觉菩提善根。于当来世定成独觉。彼作是念我等现世。终不能入正性离生得果漏尽。故作是说。我今何用知尊法为

由此世尊复作是说。此二愚人。离我正法及毗奈耶。譬如大地去虚空远。此二愚人。于我正法毗奈耶中无少分暖。若诸弟子能以财食供给其师。而共住者。尚不应以粗言拒逆。况彼不能以此同住。而作如是违戾语耶。问有多种毗奈耶。谓时毗奈耶。方毗奈耶。种性毗奈耶。家毗奈耶。明毗奈耶。罚罪毗奈耶。犯毗奈耶。圣毗奈耶。贪毗奈耶。嗔毗奈耶。痴毗奈耶。此中意说何毗奈耶。有作是说。此中说罚罪毗奈耶。或有说者。此中说犯毗奈耶。复有说者。此中说圣毗奈耶。如是说者。此中说贪嗔痴毗奈耶。问何故尊者。七门分别。世第一法。顶唯二门。忍之与暖但说自性。答是作论者。意欲尔故。随彼意欲而作此论。或略或广不应征诘。复次如以七门分别世第一法亦应以七门分别余三。如西方尊者以十七门总分别四种顺决择分。此亦应尔。总以七门分别四种。而不尔者。当知此是有余之说。复次世第一法。微细难见难可觉知。以不分明不现见故。七门分别。余三不尔故略说之。复次世第一法。多诸诽谤。故以七门分别遮止。余三不尔故略分别。复次世第一法。唯一刹那。其相难了须广分别。余三相续故略说之

如是四种顺决择分。谓暖顶忍世第一法。问如是四种自性云何。答皆以五蕴为其自性。尊者妙音作如是说。顺决择分有欲界系。有色界系。欲界系中下者名暖。上者名顶。此二自性唯有四蕴。欲界中无随转色故。色界系中下者名忍。上者名为世第一法。此二自性皆具五蕴。色界中有随转色故。如是说者。此四善根皆是色界。定地修地。行圣行法故四自性皆具五蕴。问若此四种。皆色界系。云何建立四种别耶。答此四善根。虽同色界。而有可动。有不可动。有有留难。有无留难。有可断有不可断。有可虑有不可虑。有可退有不可退诸可动有留难。可断可虑可退。中下者名暖。上者名顶。诸不可动无留离。无断无虑不可退。中下者名忍。上者名为世第一法。故此四种虽同色界系。五蕴为自性而有差别如说自性。我物自体相分。本性亦尔。已说自性当说所以。问此何故名顺决择分。答决择者。谓圣道。如是四种。是顺彼分。顺彼分中。此四最胜。是故名为顺决择分。即此四种亦名行谛。亦名修治。亦名善根。行谛者。谓以无常等十六行相游历四谛故修治者。谓为求圣道修治身器除去秽恶引起圣道故。犹如农夫为求子实修治田地除去秽草此亦如是。善根者。谓圣道涅槃。是真实善。此四与彼为初基本。为安足处故名为根。问此四善根。为有几品。答总有三品。谓下中上。暖是下品。顶是中。品。忍及世第一法是上品。有说暖有二品。谓下下下中。顶有三品。谓下上中下中中。忍有三品。谓中上上下上中。世第一法唯一品谓上上。若以三品摄之。暖唯下品。顶下中品。忍中上品。世第一法。唯是上品。尊者妙音说曰。暖有三品。顶有六品。忍有八品。世第一法唯上上品。若以三品摄之。暖唯下品。顶下中品。忍通三品。世第一法唯是上品。尊者觉天说曰。暖有三品。谓下下下中下上。顶有三品。谓中下中中中上。忍有二品。谓上下上中。世第一法。唯一品谓上上。若以三品摄之如初说。尊者世友说曰。暖有三品。谓下下下中下上。顶有二品。谓中下中中。忍有三品。谓中上上下上中。世第一法唯一品谓上上。若以三品摄之。暖唯下品。顶唯中品。忍中上品。世第一法唯是上品。问此四善根有何差别。答所说品异。即是差别。复次名亦差别。谓此名暖。乃至此名世第一法。复次念住。为等无间名暖。暖为等无间名顶。顶为等无间。名忍。忍为等无间。名世第一法。如等无间无间趣入。加行亦尔。复次乐别观蕴名暖。乐别观宝名顶。乐别观谛名忍。由此发生世第一法。复次暖止缘谛下愚。顶止缘谛中愚。忍止缘谛上愚。由此发生世第一法。复次暖止缘谛粗愚。顶止缘谛中愚。忍止缘谛细愚。由此发生世第一法。复次暖生缘谛下明。顶生缘谛中明。忍生缘谛上明。由此发生世第一法。复次暖生缘谛粗明。顶生缘谛中明。忍生缘谛细明。由此发生世第一法。如生明生信亦尔。是谓差别

顺决择分善根中。暖亦得亦舍。得者由加行故。舍者或由退故。或由越界地故。或由舍众同分故。舍此暖已。亦作无间业。亦断善根。亦堕恶趣。有何胜利。能与涅槃作决定因。谓得暖者。如吞钩鱼。已得决定涅槃法故。顶亦得亦舍。得者由加行故。舍者或由退故。或由越界地故。或由舍众同分故。舍此顶已。亦作无间业。亦堕恶趣。复有何胜利。谓能毕竟不断善根。问若尔天授应未得顶。彼起邪见断善根故。伽他所说。当云何通。如说

  愚夫众所识　　是名为失利
  白法皆灭坏　　应知从顶堕

此颂世尊。为天授说。是则天授。从顶退已。而断善根。云何乃言。舍此顶已。必不断善。答依未得退说顶堕言。提婆达多。已修得暖。不久得顶。著名利故还退失暖。复断善根于顶应得而不得故。说名顶堕非已得退。有作是说。世尊如顶于佛作恶。而堕恶趣。故名顶堕。有余师说佛法如顶。彼坏佛法便自退落。故名顶堕。忍亦得亦舍。得者由加行故。舍者或由越界地故。或由舍众同分故。不由退故。复有何胜利。谓毕竟不退。不作无间业。不堕恶趣。世第一法。亦得亦舍。得者由加行故。舍者由越界地故。不由退故。亦不由舍众同分故。复有何胜利。能为等无间。入正性离生。有余师说。暖亦得亦舍如前说。舍此暖已。亦作无间业。亦堕恶趣。有何胜利。能与涅槃作决定因。及能毕竟不断善根。若尔天授应未得暖。彼起邪见断善根故。顶亦得亦舍如前说。舍此顶已亦堕恶趣。复有何胜利。不作无间业。忍亦得亦舍如前说。复有何胜利。毕竟不退。不堕恶趣。不执着我。问若尔邬波离室利鞠多。指鬘谛语等。应未得忍。彼执有我。抗拒佛故。答彼欲论议。假立有我。实不执着。世第一法。得舍等事。皆如前说

说一切有部发智大毗婆沙论卷第六阿毗达磨大毗婆沙论卷第七

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中世第一法纳息第一之六

西方尊者以十七门分别此四如彼颂言

  意趣依因所缘果　　等流异熟及胜利
  行相二缘慧界定　　寻等根心退为后

问暖有何意趣。答先所修集。一切善根。谓从布施。乃至七处善。皆以回向解脱。是其意趣。问暖依何而起。答依自地定。问暖以何为因。答前生自地同类善根。问暖谁为所缘。答四圣谛。问暖以何为果。答以顶为近士用果。问暖谁为等流。答后生自地同类善根。问暖谁为异熟。答色界五蕴。问顺决择分。亦能牵引众同分不。有说不能。所以者何。厌背有故。谓此善根。厌背诸有于众同分。但能圆满不能牵引。有说亦能。谓此善根。虽厌背有。而能牵引。随顺圣道。众同分果。谓此所招众同分果。增上炽盛。微妙殊胜。无有灾横顺胜善品。问暖有何胜利。答能与涅槃作决定因。有说得暖定不断善。问暖有几行相。答十六行相。问暖为缘名为缘义。答名义俱缘。问暖为闻所成。为思所成。为修所成。答唯修所成。问暖为欲界系。为色界系。为无色界系。答唯色界系。问暖为在定。为不在定。答唯在定。问暖为有寻有伺。为无寻唯伺。为无寻无伺。答具三种。问暖为乐根相应。为喜根相应。为舍根相应。答三根相应。问暖为一心。为多心。答多心。问暖为可退。为不可退。答可退。顶意趣者。谓从布施。乃至暖果者。以忍为近士用果。胜利者。不断善根。有说亦不作无间业。余如暖说。忍意趣者。谓从布施。乃至顶果者。以世第一法。为近士用果。胜利者不退。不作无间业。不堕恶趣。有说亦不执我。余如顶说。世第一法意趣者。谓从布施。乃至忍所缘者。唯苦谛果者。以苦法智忍。为近士用果。胜利者。为等无间入正性离生。行相者。苦谛四行相。一心多心者。当言一心。余如忍说。初暖缘三谛。法念住现在修未来。修四念住。一行相现在修未来。修四行相俱同类修。非不同类缘灭谛。法念住现在修未来。亦唯修法念住。一行相现在修未来。修四行相亦同类修。非不同类。所以者何。非初观蕴灭能修缘蕴道。故增长暖。缘三谛四念住随一。现在修未来。修四念住此同类修。亦不同类。一行相现在修未来。修十六行相。缘灭谛。法念住现在修未来。修四念住。一行相现在修未来。修十六行相。问何故初暖。唯同类修非不同类。增长暖能修同类不同类耶。答初暖未曾得种性。初学观谛故。唯修同类。增长暖已曾得种性。串习观谛。故同类修亦不同类。初顶缘四谛。法念住现在修未来。修四念住。一行相现在修未来。修十六行相。增长顶。缘三谛四念住随一。现在修未来。修四念住。一行相现在修未来。修十六行相缘灭谛。法念住现在修未来。修四念住。一行相现在修未来。修十六行相。初及增长忍缘四谛。法念住现在修未来。修四念住。一行相现在修未来。修十六行相。问何故忍初及增长皆唯法念住现在修。暖顶不尔。答忍近见道。与见道相似。如见道中。唯起法念住。忍亦如是。尊者妙音作如是说。初忍及增长忍。如初暖及增长暖说。于色界善根。未曾得种性。及已曾得种性故。彼不应作是说。此四善根。皆是色界修所成故。忍近见道。如见道起法念住故。问增长忍一切时。修十六行相耶。答不尔或时十六。或时十二或时八或时四。所以者何。如如渐次略所缘谛。如是如是略修行相。由此渐能近于见道。如见道故。世第一法。法念住现在修未来。修四念住。一行相现在修未来。修四行相。唯同类修。非不同类。问世第一法。已曾得种性。串习观谛。何故但修同类。非异类耶。答世第一法。唯有尔所行相可修。无余行相。如人唯有一衣。夺已更无可夺。此亦如是故不应问。复次世第一法。邻逼见道。似见道故。复次世第一法。开见道门。导生见道。如见道故。问初暖顶忍于四圣谛。为相续观。为不相续。有说相续。如见道中十五心顷。于四圣谛相续现观。此亦如是。有说不相续。谓观欲界苦圣谛已。即便止住。次起加行。观色无色界苦圣谛已。复便止住。余谛亦尔。如是说者。此不决定。或相续观或不相续。随彼加行。势力转故。问何等作意无间。引起暖耶。答色界定。修所成行相摄。有厌离有渴仰。有恶贱有思慕。作意无间引起暖。暖无间引起顶。顶无间引起忍。忍无间引起世第一法。问已离欲染者可尔。未离欲染者云何。答欲界亦有似彼作意。思所成行相摄。有厌离有渴仰。有恶贱有思慕。未离欲染者。此作意无间引起暖。余如前说。问修暖满已将欲起顶。遂便命终。彼余生中。为即起顶。为从本起。答若遇明师。随彼应起。分齐说者。即能起顶。若不尔者还从本起。然能速起。非如初修。问若余生中即起顶者。从何作意无间起耶。答如起暖时所有作意。如说从暖起顶。从顶起忍亦尔。问若尔何故。说暖无间起顶。顶无间起忍耶。答依一身中相续起者作如是说。然非一切。问若退暖已还生暖时。为得先时曾得暖不。答应言不得随尔所度。退已还生。即尔所度。新新而得。所以者何。极难得故。未曾习故。用功成故。如别解脱戒。随尔所度。舍已复受。即尔所度。新新而得。此亦如是。如说暖顶亦尔。依根本静虑所起暖顶。亦必不退。以所依定自在坚牢故。依未至定静虑中间所起暖顶。则不决定。以可退故。问暖顶忍位。依下生中。依中生上。中上品后。起下中不。答决定不起。所以者何。居胜进位于先所得不欣尚故。问起暖以后为离染不。有作是说。不乐离染。所以者何。彼宁起顶。不乐发起第一有思。况下地定。如是说者。此则不定。若彼行者。自知有力能生顶者。即便起顶。若知无力能生顶者。则求离染。所以者何。若得离染。当生胜处。离下界故

暖顶忍等。种类差别。有七十三。其事云何。谓于欲界染具离。有十具缚。为一离一品染。乃至离九。并前为十。于初静虑染。离一乃至离九为九。无别具缚。即是欲界第十摄故。后位亦尔。如是乃至。于无所有处染。离一乃至离九为九。于此诸位。所起暖等。有七十三种类差别。问随一所起。与余所起。为一为异。有说是一。问若尔何故。说七十三种类差别。答体虽是一而位有异。依位差别。故说尔所。有说各异。谓具缚者。所起异离一品者所起异。广说乃至。离无所有处。第九染者所起异。然具缚者。于具缚者。所起暖等。亦得亦在身。亦成就亦现在前。于离缚者。所起暖等。不得不在身。不成就不现在前。离欲界一品染者。于离欲界一品染者。所起暖等。亦得亦在身。亦成就亦现在前。于具缚者。所起暖等。得而不在身不成就不现在前。于余所起。不得不在身。不成就不现在前。广说乃至。离无所有处第九品染者。于自所起暖等亦得。亦在身亦成就。亦现在前。于余所起暖等。得而不在身。不成就不现在前

依根本静虑。起暖等者。现身必入正性离生。所以者何。彼由圣道。引暖等故。依未至定静虑中间。起暖等者。此则不定。所以者何。彼由暖等。引圣道故。问若依此地。起顺决择分。即依此地。入正性离生耶。有作是说。若依此地。起顺决择分。即依此地。入正性离生。如是说者。此则不定。或即依此地。或复依余地。或即依此地者。谓声闻种性。若依未至定起暖。即依此地起顶忍世第一法。入正性离生。乃至若依第四静虑起暖。即依此地起顶忍世第一法。入正性离生。或复依余地者。谓声闻种性。若依未至定起暖。彼依初静虑。起暖顶忍世第一法。入正性离生。乃至第四静虑亦尔。若依未至定起暖顶。彼依初静虑。起顶忍世第一法。入正性离生。乃至第四静虑亦尔。若依未至定。起暖顶忍。彼依初静虑。起忍世第一法。入正性离生。乃至第四静虑亦尔。有说若依未至定起暖。彼依初静虑。起顶忍世第一法。入正性离生。乃至第四静虑亦尔。若依未至定起暖顶。彼依初静虑。起忍世第一法。入正性离生。乃至第四静虑亦尔。若依未至定。起暖顶忍彼依初静虑。起忍世第一法。入正性离生。乃至第四静虑亦尔。有说若依未至定起暖。彼依初静虑起暖顶忍世第一法。入正性离生。乃至第四静虑亦尔。若依未至定起暖顶。彼依初静虑。起暖顶忍世第一法。入正性离生。乃至第四静虑亦尔。若依未至定起暖顶忍。彼依初静虑。起暖顶忍世第一法。入正性离生。乃至第四静虑亦尔。问顺决择分。中上品后。不起下中。云何今时作如是说。答同地不起。异地得起。如是等说声闻种性。问菩萨云何。有作是说菩萨若依未至定起暖。依初静虑乃至第三静虑。起暖顶忍。依第四静虑。起暖顶忍世第一法。入正性离生。若依未至定起暖顶。依初静虑乃至第三静虑。起暖顶忍。依第四静虑。起暖顶忍世第一法。入正性离生若依未至定。起暖顶忍。依初静虑乃至第三静虑。亦起暖顶忍。依第四静虑。起暖顶忍世第一法。入正性离生。问顺决择分。中上品后。不起下中。云何今时。作如是说。答同地不起。异地得起。有说声闻不起。菩萨能起。有余为离如是过失。作如是言。菩萨若依未至定起暖。乃至第四静虑亦尔。若依未至定起顶。乃至第四静虑亦尔。若依未至定起忍。乃至第四静虑亦尔。即依第四静虑。起忍世第一法。入正性离生。如是说者。菩萨唯依第四静虑。起暖顶忍世第一法。入正性离生。所以者何。菩萨一切殊胜功德。唯依第四静虑引起。谓从不净观。乃至无生智。问独觉云何。答麟角喻独觉。如菩萨说部行独觉不定。如声闻说。问菩萨昔余生中。曾起顺决择分善根不。设尔何失。若曾起者何故说言。菩萨所有殊胜善根。谓从不净观。乃至无生智。皆一坐得。若不起者。菩萨九十一劫。不堕恶趣。是谁威力耶。有作是说。菩萨昔余生中。曾起顺决择分。由忍力故。九十一劫。不堕恶趣。问若尔何故说言。菩萨善根皆一坐得。答昔所起者。是他种性。非自种性。一坐得者。说自种性。故不相违。有说不起。所以者何。菩萨善根。不经历世。菩提树下。一坐得故。问若尔菩萨。九十一劫。不堕恶趣。是谁力耶。答能障恶趣。不必要由顺决择分。所以者何。或施或戒或闻或思。或暖或顶。能障恶趣。若钝根者。得忍方能。然诸菩萨行一施时。亦摄戒慧。行一戒时。亦摄施慧。行一慧时。亦摄施戒。由此能障那庾多恶趣。况三恶趣而不能障耶。如是说者。菩萨所有殊胜善根。谓从不净观。乃至无生智。皆此生中依第四静虑一坐引起。尚非此生余位何况前生。麟角喻独觉亦尔。部行独觉善根不定。如声闻说

暖顶忍世第一法。各有六种种性差别。谓退法种性思法护法。住法堪达不动法种性。此中转退法种性暖。起思法种性暖。乃至转堪达种性暖。起不动法种性暖。转声闻种性暖。起独觉或佛种性暖转独觉种性暖。起佛或声闻种性暖。佛种性暖定不可转。如说暖说顶亦尔。转声闻种性忍。起独觉种性忍。非转声闻独觉种性忍。能起佛种性忍。所以者何。忍违恶趣。菩萨发愿生恶趣故。亦非转独觉种性忍。能起声闻种性忍。所以者何。忍不退故。有说转声闻种性暖顶忍。能起独觉种性暖顶忍。若起独觉种性暖顶。亦不能起余乘暖顶。所以者何。独觉善根。始从不净观。乃至无生智。一坐得故。评曰彼不应作是说。所以者何。麟角喻独觉种性。善根虽一坐得。部行独觉种性不定如声闻说。故世第一法。六种种性。及三乘种性。皆不可转。一刹那故

问顺决择分。何处起耶。答欲界能起。非色无色界。于欲界中人天能起。非三恶趣。胜善根故。人中三洲能起非北俱卢。天中虽能起。而后起非初。谓先人中起已。后退生欲天中。由先习力续复能起。问何故天中不能初起。答彼处无胜厌离等作意故。问恶趣中有胜厌离等作意。何故不起此善根耶。答恶趣中无胜依身故。若有胜厌离等作意。亦有胜依身者。则能初起此类善根。欲天中虽有胜依身。而无胜厌离等作意。恶趣中虽有胜厌离等作意。而无胜依身。人中具二。故能初起。问色无色界。何故不起此善根耶。答若处能入正性离生彼处能起。色无色界既不能入正性离生。故不能起。问因论生论。何故色无色界。不能入正性离生耶。答非田非器。乃至广说。复次若处能起忍智彼处能入正性离生。色无色界虽能起智。而不起忍故不能入正性离生。复次若处能起法智类智。彼处能入正性离生。色无色界虽起类智。而不起法智故不能入正性离生。复次若处有胜依身及有苦受。彼处能入正性离生。色无色界虽有胜依身。而无苦受故。不能入正性离生

问此暖顶忍世第一法。依何身起。答依男女身。问依女身得女身所起暖为。亦得男身所起暖耶。答得。如得暖。得顶忍亦尔。问依男身得男身所起暖为。亦得女身所起暖耶。答得如得暖。得顶忍亦尔。女身于女身所起暖。亦得亦在身。亦成就亦现在前。于男身所起暖得。而不在身成就。不现在前。如说暖说顶忍亦尔。男身于男身所起暖。亦得亦在身。亦成就亦现在前。于女身所起暖。得而不在身成就。不现在前。如说暖说顶忍亦尔。女身所起暖。与女身所起暖为因。与男身所起暖亦为因。如说暖说顶忍亦尔。男身所起暖。与男身所起暖为因。不与女身所起暖为因。所以者何。胜非劣因彼是劣故。如说暖说顶忍亦尔。问依男身。起顺决择分善根已。更可受女身不。答更可受。唯前三非世第一法。所以者何。一刹那故。问起顺决择分善根已。更可受扇搋半择迦。无形二形身不。答更可受。唯暖顶非余。所以者何。若得忍已。便违恶趣。彼扇搋等身形鄙陋。是人中恶趣。若得忍等殊胜善根。必更不受彼类身故。问得忍异生。于命终位。既舍众同分亦舍忍不。设尔何失。若舍者应堕恶趣。何故乃言若得忍者不堕恶趣。又若舍者。何故异生命终时舍。圣者不然。若不舍者。何故业蕴。及大种蕴。俱不说耶。如说异生住胎藏等。但成就身。不成就身业。答此应言舍。有说不舍。有说不定。或舍不舍。此中一一。广释所以。如后业蕴害生纳息中说。如是说者。异生命终定舍于忍。善根劣故。异生依此地。起此类善根。若有命终还生此地。舍同分故。尚决定舍况此善根。是色界法。经欲界生。而当不舍。问修暖加行其相云何。答以要言之。三慧为相。谓闻所成慧。思所成慧。修所成慧。问云何修习闻所成慧。答修观行者。或遇明师。为其略说诸法要者。唯有十八界。十二处五蕴。或自读诵素怛缆藏。毗奈耶藏。阿毗达磨藏。令善熟已作如是念。三藏文义甚为广博。若恒忆持令心厌倦三藏所说要者。唯有十八界十二处五蕴。作是念已。先观察十八界。彼观察时立为三分。谓名故自相故共相故。名者谓此名眼界乃至此名意识界。自相者。谓此是眼界自相。乃至此是意识界自相。共相者。谓十六行相。所观十八界。十六种共相。彼缘此界修智修止。于十八界修智止已。复生厌倦作如是念。此十八界即十二处。故应略之入十二处。谓十色界。即十色处。七心界即意处。法界即法处。彼观察此十二处时。立为三分。谓名故自相故共相故。名者谓此名眼处。乃至此名法处。自相者。谓此是眼处自相。乃至此是法处自相。共相者。谓十六行相。所观十二处。十六种共相。彼缘此处修智修止。于十二处修智止已。复生厌倦作如是念。此十二处。除无为即五蕴故。应略之入于五蕴谓十色处。及法处所摄色即色蕴。意处即识蕴。法处中受即受蕴。想即想蕴。余心所法不相应行即行蕴。彼观察此五蕴时。立为三分。谓名故自相故共相故。名者谓此名色蕴。乃至此名识蕴。自相者。谓此是色蕴自相。乃至此是识蕴自相。共相者。谓十二行相。所观五蕴。十二种共相。彼缘此蕴修智修止。于五蕴修智止已。复生厌倦作如是念。此五蕴并无为。即四念住故。应略之入四念住。谓色蕴即身念住。受蕴即受念住。识蕴即心念住。想行蕴并无为。即法念住。彼观察此四念住时。立为三分。谓名故自相故共相故。名者谓此名身念住。乃至此名法念住。自相者。谓此是身念住自相。乃至此是法念住自相。共相者。谓十六行相。所观四念住。十六种共相。彼缘此念住。修智修止。于四念住修智止已。复生厌倦作如是念。此四念住。除虚空非择灭。即四圣谛故。应略之入四圣谛。谓有漏法果分即苦谛。因分即集谛。择灭即灭谛。对治即道谛。彼观察此四圣谛时。立为三分。谓名故自相故共相故。名者谓此名苦谛。乃至此名道谛自相者。谓此是苦谛自相。乃至此是道谛自相。共相者。谓四行相。所观苦谛四种共相。一苦二非常三空四非我。四行相所观集谛。四种共相。一因二集三生四缘。四行相所观灭谛。四种共相。一灭二静三妙四离。四行相所观道谛。四种共相。一道二如三行四出。彼缘此谛修智修止。于四圣谛修智止时。如见道中。渐次观谛。谓先别观欲界苦。后合观色无色界苦。先别观欲界集。后合观色无色界集。先别观欲界灭。后合观色无色界灭。先别观欲界道后合观色无色界道。如是观察四圣谛时。犹如隔绢观诸色像。齐此修习闻所成慧。方得圆满。依此发生思所成慧。修圆满已。次复发生修所成慧。即名为暖。暖次生顶。顶次生忍。忍次生于世第一法。世第一法次生见道。见道次生修道。修道次生无学道。如是次第善根满足

善根有三种。一顺福分。二顺解脱分。三顺决择分。顺福分善根者。谓种生人生天种子。生人种子者。谓此种子。能生人中高族大贵。多饶财宝眷属圆满。颜貌端严身体细渜乃至或作转轮圣王。生天种子者。谓此种子。能生欲色无色天中。受胜妙果。或作帝释魔王梵王。有大威势多所统领。顺解脱分善根者。谓种决定解脱种子。因此决定得般涅槃。顺决择分善根者。谓暖顶忍世第一法。此中应广分别顺解脱分善根。问此善根以何为自性。答以身语意业为自性。然意业增上。问此善根为在意地。为五识身。答在意地。非五识身。问此善根为加行得为离染得。为生得耶。答唯加行得。有说。亦是生得。评曰。前说者好。加行起故。问此善根为闻所成。为思所成。为修所成耶。答闻思所成非修所成。有说亦是修所成。评曰。前说者好。唯欲界系故。问此善根于何处起。答于欲界起非色无色界欲界中人趣起非余趣。人趣中三洲起非北俱卢。问此善根于何时种。答佛出世时。要有佛法方能种故。有余师说。虽无佛法。若遇独觉。亦能种此善根。问此善根依何身起。答亦依男身亦依女身。问为因何事种此善根。答或因施。或因戒或因闻。而不决定。所以者何。意乐异故。谓或有人因施一抟食。或乃至一净齿木。即能种殖解脱种子。如战达罗等。彼随所施皆作是言。愿我因斯定得解脱。或有虽设无遮大会而不能种解脱种子。如无暴恶等。彼随所施皆求世间富贵名称。不求解脱。或有受持一昼一夜八分斋戒。即能种殖解脱种子。或有受持尽众同分别解脱戒。而不能种解脱种子。或有读诵四句伽他。即能种殖解脱种子。或有善通三藏文义。而不能种解脱种子。问谁决定能。种此顺解脱分善根。答若有增上意乐。欣求涅槃。厌背生死者。随起少分施戒闻善。即能决定种此善根。若无增上意乐。欣求涅槃。厌背生死者。虽起多分施戒闻善。而亦不能种此善根。问若有种殖此善根已。为经久如能得解脱。答若极速者。要经三生。谓初生中种此种子。第二生中令其成熟。第三生中即能解脱。余则不定。谓或有人种顺解脱分善根已。或经一劫。或经百劫。或经千劫流转生死。而不能起顺决择分。或复有人。起顺决择分善根已。或经一生。或经百生。或经千生流转生死。而不能入正性离生。顺解脱分。亦有六种。谓退法种性。乃至不动。法种性。转退法种性顺解脱分。起思法种性顺解脱分。乃至转堪达种性顺解脱分。起不动法种性顺解脱分。转声闻种性顺解脱分。起独觉及佛种性顺解脱分。转独觉种性顺解脱分。起声闻及佛种性顺解脱分。若起佛种性顺解脱分已。则不可转极猛利故。问暖加行中有生灭观。此生灭观加行云何。答诸瑜伽师。将观生灭。先取内外兴衰相已。还所住处。调适身心。观一期身前生后灭。次观分位。次年次时次月。次半月次一昼夜。次牟呼栗多。次腊缚。次怛刹那。次复渐减。乃至于一切有为法。观二刹那生二刹那灭。齐此名为加行成满。次复于有为法。观一刹那生一刹那灭。此则名为生灭观成。问此生灭观。观生灭时。为一心观。为二心观。若一心观者。为作一解。为作二解。若作一解者。如观生为生。亦应观灭为生。观生为生可名正观。观灭为生应是邪观。如观灭为灭亦应观生为灭。观灭为灭可名正观。观生为灭应是邪观。如何一解。亦正亦邪。若作二解者。应有二体。一心二体。无有是处。若二心观者。一心观生。一心观灭。应无生灭观。云何名为生灭观耶。答二刹那顷。一心观生。一心观灭。依相续说名生灭观。不依刹那。故无有失。有说。一心双观生灭。而无如前所说过失。以见生时比知有灭。以有生法。必有灭故。若见灭时比知有生。以有灭法必有生故。评曰。彼说非理。云何一心可有二解。现比二量体不同故。前说为善。问此生灭观。为胜解作意。为真实作意。有说。真实作意。问若尔诸行实无来去。见有来去云何真实。答此观未成见有来去。成时但见生灭。不见有去来相。如舞独乐。缓见来去急则不见。旋火轮喻。陶家轮喻。应知亦尔。有说。胜解作意。问若尔伽他所说。当云何通。如说

  若有知见能尽漏　　若无知见云何尽
  若能观蕴生灭者　　是则解脱烦恼意

非胜解作意能断烦恼。答依传因说。如子孙法。谓胜解作意。引生真实作意。由真实作意。断诸烦恼。故不相违

说一切有部发智 大毗婆沙论卷第七阿毗达磨大毗婆沙论卷第八

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中世第一法纳息第一之七

此二十句。萨迦耶见。几我见几我所见。乃至广说。问何故作此论。答为欲分别契经义故。谓诸经中。佛说有二十句萨迦耶见。尊者舍利子。于池喻经中。虽略分别此二十句萨迦耶见。而皆未说几是我见几我所见。彼经是此论所依根本。彼所未说者。今欲说之故作斯论。复次为止他宗显正义故。谓譬喻者。作如是说。萨迦耶见无实所缘。彼作是言。萨迦耶见计我我所。于胜义中无我我所。如人见绳谓是蛇。见杌谓是人等。此亦如是故无所缘。为止彼执。显示此见实有所缘。故作斯论。问于胜义中无我我所。云何此见实有所缘。答萨迦耶见。缘五取蕴计我我所。如缘绳杌谓是蛇人。行相颠倒非无所缘。以五取蕴是实有故。此二十句萨迦耶见。几我见几我所见耶。答五我见。谓等随观色是我。受想行识是我。十五我所见。谓等随观我有色。色是我所。我在色中。我有受想行识。受想行识是我所。我在受想行识中。问如我见行相。缘五取蕴。有五我所见行相。缘五取蕴亦应有五。何故乃说有十五耶。答我见行相。缘五取蕴无差别故。但有五种。我所见行相。缘五取蕴有差别故。有十五种。谓我众具于一一蕴。皆有三种差别相故。然此萨迦耶见。或应说一。谓五见中萨迦耶见。或应说二。谓我我所行相差别。说为我见及我所见。或应说三。谓欲色无色三界别故。或应说五。谓缘五蕴有差别故。或应说六。谓于三界各有我见我所见故。或应说九。谓从欲界乃至非想非非想处。九地别故。或应说十。谓缘五蕴各有我见我所见故。或应说十二。谓缘十二处有差别故。或应说十八。谓于九地各有我见我所见故。又缘十八界有差别故。或应说二十。谓分别缘蕴。我具行相差别。不分别所起处。如等随观。色是我我有色。色是我所。我在色中。受想行识亦尔。五蕴各四故有二十。或应说二十四。谓缘十二处。各有我见我所见故。或应说三十六。谓缘十八界。各有我见我所见故。或应说四十八。谓分别缘处。我具行相差别。不分别所起处。如等随观。眼处是我我有眼处。眼处是我所。我在眼处中。余十一处亦尔。十二处各四故有四十八。或应说六十五。谓分别缘蕴。我具行相差别。亦分别所起处。如等随观。色是我受是我。璎珞是我。僮仆是我器。如受有三。想行识亦尔。四三十二并观色是我。总有十三。如观色是我有十三。受想行识亦尔。五种十三。为六十五。或应说七十二。谓分别缘界。我具行相差别。不分别所起处。如等随观。眼界是我我有眼界。眼界是我所。我在眼界中。余十七界亦尔。十八界各四故有七十二。或应说四百八。谓分别缘处。我具行相差别。亦分别所起处。如等随观。眼处是我。色处是我。璎珞是我。僮仆是我器。如色处有三。余十处亦尔。十一种三。有三十三。并观眼处是我。总有三十四。如观眼处是我有三十四。余十一处亦尔。十二种三十四。为四百八。或应说九百三十六。谓分别缘界。我具行相差别。亦分别所起处。如等随观。眼界是我。色界是我。璎珞是我。僮仆是我器。如色界有三。余十六界亦尔。十七种三。有五十一。并观眼界是我。总有五十二。十八种五十二。为九百三十六。如是缘蕴行相。界地分别。缘处行相。界地分别。缘界行相。界地分别。若以相续。若以世若以刹那。分别则有无量萨迦耶见。此中且说分别缘蕴我具行相差别。不分别所起处故。但有二十句萨迦耶见。问何故此中但依缘蕴。说二十句萨迦耶见。非界处耶。答彼作论者。意欲尔故。乃至广说。复次亦应依界处说。而不说者。当知此义有余。复次蕴在初故且依蕴说。界处不尔。复次此中。不应问作论者。以作论者依经造论。佛于经中但依蕴说萨迦耶见有二十句。故作论者依之造论问若尔置作论者。应问。何故世尊。但依蕴说萨迦耶见有二十句。非界处耶。答观所化故。谓佛观察所化有情。若依蕴说萨迦耶见有二十句。便得解了能办所作。非依界处。设依界处。彼得解了能办所作。佛亦说之。但不如是。故不为说。复次萨迦耶见多缘蕴。非界处故偏说之。问何故此中。但说萨迦耶见有二十句。不说余见耶。答彼作论者。意欲尔故。乃至广说。复次应知此中是有余说。谓亦应说边执见有二十。邪见有八十。见取亦尔。戒禁取有四十。而不说者当知有余。复次萨迦耶见。于五见中最为上首。是以偏说。复次萨迦耶见。是十种空近所对治。所以偏说。十种空者。谓内空。外空。内外空。有为空。无为空。散坏空。本性空。无际空。胜义空。空空。问二十句者。句是何义。答是自性义。谓此见有二十自性。问等随观色是我。受想行识是我者。云何等随观色是我。受想行识是我耶。答诸所有色。若四大种。若四大种所造。彼一切等随观是我。乃至识随所应当说。问萨迦耶见。唯有漏缘非无漏。自界地缘非他界地。自界地中亦非一切一时而缘。何故言彼一切等随观是我耶。答此一切言是少分一切。非一切一切。故无有失。复次此一切言。依自所行境界而说。是以无过。问颇有于一蕴执我我所耶。答有。谓色蕴行蕴中。各有多法。执一为我。余为我所。受想识蕴。虽无多类。而有种种差别自性。是故亦得计一为我余为我所。等随观我有色。乃至广说者。云何等随观我有色。答于余四蕴。展转随执一是我已。然后于色执为我有。如人有财有璎珞等。云何等随观色是我所。答于余四蕴。展转随执一是我已。然后于色执为我所。如人有侍有僮仆等。云何等随观我在色中。答于余四蕴。展转随执一是我已。然后于色执为我器我处。其中如油在麻中。腻在抟中。蛇在箧中。刀在鞘中。酥在酪中。血在身中等。如等随观色有此三种。乃至等随观识应知亦尔。问执受等是我在于色中。是事可尔。以色是粗受等细故。执色是我在受等中。云何可尔。以粗法不应在细中故。胁尊者言。理不应责无明者愚盲者堕坑。有余师说。若执色是我在受等中者。彼执色细受等是粗是故尊者世友说曰。遍四大种造色身中。随与触合皆能生受。此说何义。此说身中遍能起触。亦遍生受。彼作是念。从足至顶既遍有受。故知色我在于受中。大德说曰。一切身分皆能生受。彼作是念。受遍身有身之一分。是我非余。是故受中得容色我。如受乃至识亦如是。问为有缘一极微起萨迦耶见不。设尔何失。若有者此应是正见非萨迦耶见。所以者何。要真实行智。方见极微故。若无者六法论说。当云何通。如彼论说。极微是常各别住故。此各别住。非无常因。是故极微决定常住。彼说云何。证此见缘极微。彼说边执见缘极微为境。证有身见亦缘极微。身边二见所缘一故。答无缘一极微起萨迦耶见。问若尔六法论说当云何通。答彼论所说不顺正理。不可引证此缘极微。谓彼论中更说多种不顺理因。不可为证。有余师说。有缘一极微起萨迦耶见。问若尔此应是正见非萨迦耶见。答此约所缘故说有。非约现起故说有。评曰。彼说非理。所以者何。如何此见。能住所缘。而不能起。是故前说于理为胜。问为有俱时总缘五蕴执为我不。设尔何失。若有者六法论说。当云何通。如彼论说。我体唯一无有五种。若有俱时总缘五蕴执为我者。我应有五。然蕴自相五种各别。彼所执我相无差别。以所执我无有细分。无差别相。常住不变。生老病死不能坏故。若无者谛语经说当云何通。如彼经说。谛语外道白佛言。乔答摩。我说色是我。受想行识是我。有作是说。无有俱时总缘五蕴执为我者。问若尔六法论说。便为善通。谛语经说当云何通。答彼憍慢故作非理说。实无此执。复次彼欲试佛故作如是不顺理言。谓彼闻佛有胜智见。心不定信。作是念言。我今当试有此事不。故作是说。复次彼心惊怖故。作如是不顺理说。谓彼先设多种方便。来诣佛所欲兴论议。既是世尊身有殊胜大论师相。谓颔轮如师子。眼睫如牛王。其牙纤利具四十齿。梵音深妙。令人乐闻。彼见是已恐堕负处生大怖畏故作是说。复次佛威神力映蔽彼心。故作如是不顺理说。谓彼外道为论议故来诣佛所。既见世尊威德炽盛。梵释护世尚不能睹。见已惊惶故作是说。复次天龙药叉。威神力故。令作如是不顺理说。谓有信佛天龙药叉。作如是念。此恶外道结构言词欲恼乱佛。当以势力扰乱其心。令违理说速堕负处。如邬波梨欲来骂佛。天神威力扰乱其心。翻成赞叹。此亦如是。复有说者。有于一时总缘五蕴而起我执。问若尔谛语经说便为善通。六法论说当云何通答彼于五蕴起一合想。执为一我故无有失。问若尔彼执何为我所。答若执内蕴为我。彼执外蕴为我所。若执外蕴为我。彼执内蕴为我所。故亦无失。问有五蕴外执有我不。设尔何失。若有者。契经所说当云何通。如契经说。诸有沙门或婆罗门。施设有我。一切皆缘五聚蕴起。若无者。云何说有第六我见。答无五蕴外执有我者。问若尔云何说有第六我见。答于思行蕴所起我见。于余行蕴所起我见。各别建立故有六种。问梵网经说。六十二见趣。一切皆以有身见为本。师子吼经说。诸有沙门或婆罗门。多种异见皆依二见。谓依有见及无有见。此二经说有何差别。答依等起故说诸见趣以有身见为本。依推求故说诸异见。依有无有见。复次萨迦耶见。能引发诸见趣。有无有见能守护诸异见。是谓二经所说差别。若非常常见。于五见何见摄。何见所断。乃至广说。问何故作此论。答此诸见趣于生死中。与诸有情作大系缚。作大衰患作大损伏。由有此故。令诸有情数于欲界色无色界受多苦恼轮转生死。远离慧明入母胎藏。住在生藏熟藏中间受诸迫迮。如重罪人禁在囹圄。欲令有情觉知如是见趣过失勤求解脱。故作此论。犹如世间系缚衰患损伏之处。人若不知不能远避。人若知之即能远避。此亦如是。此论杂蕴智蕴见蕴。皆以二事寻求见趣。一以自性。二以对治。以自性者。谓如是见于五见何见摄。以对治者。谓如是见。何见所断。生智论中。亦以此二事。寻求见趣。如彼论说外道谤佛言。沙门乔答摩。是大幻者诳惑世间。然世尊道已超于幻。彼言。是幻者是谤道邪见。见道所断。谤道邪见者。显彼自性。彼谤世尊超幻道故。见道所断者。显彼对治道。忍智生永断彼故。又彼论说。有作是言。世尊何故。悭阿罗汉。然世尊道已超于悭。彼言。是悭者是谤道邪见见道所断。此中二事如前应知。又于问论梵网经中。复以一事寻求见趣。谓如是见由何而起。如是总说。便以三事。寻求见趣。一以自性。二以对治。三以等起。胁尊者言。不应如是寻求见趣。如不应责无明者愚盲者堕坑。评曰。应以三事寻求见趣。所以者何。若以三事寻求见趣。则具缚异生。亦毕竟不起。如以圣道永断遍知。此中应广说实法师因缘。谓昔在此迦湿弥罗国中。有一阿练若处。诸瑜伽师。共会一处。论说诸见。作如是言。圣者于此无量过患。诸恶见趣。永不现行。甚为希有。时彼众内。有一法师。名达腊婆。谓众人曰。圣者于此诸恶见趣。已断遍知。永不现前。有何希有。如我今者。具缚异生。以此三事。寻求见趣。设我后际流转生死。如前际来。所经劫数。于此见趣更不现行。乃为希有。尔时众中有阿罗汉。作如是念。具缚异生。乃能于此贤圣众中。作师子吼。甚为希有。吾当后时验彼所言。为实非实。然所积财必归于尽。一切高贵必当堕落。一切合会必当别离。一切寿命必归于死。此实法师。后命终已。还生本国婆罗门家。彼阿罗汉天眼见之。数往其家而问安不。如是荏苒至年长大。时阿罗汉为试验之。取彼严具而问之言。此是谁许。彼默不答。其母谓曰。儿今何故不答师问。彼白母言。师所问者。世间所无当云何答。母曰。世间无何等物。彼言。无我。所以者何。以一切行皆无我。无有情无命者。无补特伽罗。无生者无养育者。无作者无受者。唯空行聚故不应答。时阿罗汉闻已叹言。甚为希有。虽经生死。而诸见趣犹不现行。汝于前世贤圣众中作师子吼。具缚异生。若以三事寻求见趣。设经多劫亦不现前。斯言有实。是故应以所说三事寻求见趣。有大饶益

若非常常见。于五见何见摄。何见所断。答边执见常见摄。见苦所断。问何谓非常。答诸有为法。问何缘外道计彼为常。答由二缘故。一见诸色法相似相续故。二见心心所法忆本事故。见诸色法相似相续故者。谓彼外道见老时色似小时色。见今日色似昨日色。便作是念。即小时色转至老时。即昨日色转至今日。见心心所法忆本事故者。谓彼外道见小时所作所习所受。老时能忆见。昨日所作所习所受。今日能忆便作是念。老时心心所法。即小时心心所法。今日心心所法。即昨日心心所法。由此二缘故彼外道于五取蕴妄计为常。尊者世友作如是说。彼诸外道于五取蕴相似相续覆故。不知非常威仪。将摄覆故不知是苦。薄皮庄饰覆故。不知不净作用。我执覆故不知无我。由此外道起常等见。此中边执见常见摄者显彼自性。此于常断二边执中常边摄故。见苦所断者。显彼对治。见苦谛时永断彼故。谓于苦谛忍智。若生如是种类。不正寻思不正分别。颠倒见不平等取。永断止息。如草端露日照则销。彼亦如是以迷苦生见苦便断。问善说法者。亦说诸法常有实体性相我事。何故所见不名为恶。外道亦然。独称恶见。答善说法者。虽说诸法有实体等。而无作用。外道所说兼有作用。有说。善说法者。唯说诸法暂起作用。彼说诸法数起作用。有说。善说法者。宣说诸法为生所生。为老所老。为灭所灭。彼说诸法非生所生。非老所老。非灭所灭。有说。善说法者。宣说诸法流转三世。彼说诸法不经于世。有说。善说法者宣说诸法。依因托缘和合而生。彼说诸法非因缘生。有说。善说法者。宣说诸法生灭相应。有因有缘有为相合。彼说不尔。由如是等种种因缘。善说法者。所见非恶。外道所起独称恶见。问若于非常起常见者。决定诽谤无常因缘。彼见云何不名邪见。答无行相转立邪见名。彼见不然故非邪见。有说。坏实事者立邪见名。彼乃增益故非邪见。问何故此见名边执见。答执常边故断常乖中俱名为边。执二边见名边执见。如世尊告迦多衍那。若以正智观世是集。言无所有则更不行。无所有者即是断见。若以正智观世是灭。言有所有则更不行。有所有者即是常见。谓观有情未来蕴起故非是断。现在蕴灭故非是常。复次起我见者。犹是边鄙世所诃责。况复于我执有断常。此执边鄙极可诃故名边执见

若常非常见。于五见何见摄。何见所断。答邪见摄。见灭所断。问何谓为常。答寂灭涅槃。问何缘外道计彼非常。答外道执有四种解脱。一名无身。二名无边意。三名净聚。四名世间窣堵波。无身者。谓空无边处。无边意者。谓识无边处。净聚者。谓无所有处。世间窣堵波者。谓非想非非想处。然四无色虽久还退。彼作是念。我等解脱既有退堕。当知释种所说涅槃亦有退堕。故于涅槃起非常见。此中邪见摄者。显彼自性。以彼拨无常涅槃故。见灭所断者。显彼对治。见灭谛时永断彼故。余如前说。问为有邪见。能于寂灭涅槃。起非常行相不。设尔何失。若有者品类足说。当云何通。如彼说。云何邪见。谓谤因谤果。谤作用坏实事。诸忍乐慧观见。若无者此中所说。当云何通。如说。若常非常见邪见摄。见灭所断。答应作是说。有此邪见。问品类足说当云何通。答彼说邪见行相不尽。谓有所余烦恼行相。彼不说故。有说。摄在彼所说中。谓谤因者谤集谛。谤果者谤苦谛。谤作用者谤道谛。坏实事者谤灭谛。有说。谤因谤果谤作用者。各谤三谛。坏实事者。唯谤灭谛。有余师说。无此邪见。问此中所说。当云何通。答涅槃中有常相。若谤无涅槃。亦谤此常相。如指中有四处。若拨无指。亦拨四处。有说。义准故作是说。谓诸外道唯执有蕴是常住法。涅槃非蕴是故义准。彼定拨无。由此说有常非常见。然无邪见。能于寂灭涅槃。实起无常行相

若苦乐见。于五见何见摄。何见所断。答取劣法为胜。见取摄。见苦所断。问何谓为苦。答诸有漏法。问何缘外道计彼为乐。答愚于少时适意事故。如疲暂息。寒暂得暖。热暂得冷。饥暂得食。渴暂得饮。便作是念。我今受乐。然诸蕴中。有少分乐如量而取亦非颠倒。外道于中增益而取同究竟乐。故成颠倒。此中取劣法为胜。见取摄者显彼自性。取苦苦等为妙乐故。见苦所断者显彼对治。见苦谛时永断彼故。余如前说。问何故取苦为乐名为见取。取无常为常非见取耶。答取苦为乐者。一向取劣法为胜故。名见取。取无常为常者。非一向取劣法为胜故非见取。以常法中胜不胜法同为一聚。如虚空非择灭。是无记故不名胜法。复有说者。于诸蕴中有少分乐。由观彼故取苦为乐名为见取。非诸蕴中有少分常可观彼故。取无常为常亦名见取。所以者何。色等五蕴刹那性故。体虚幻故。暂时住故。临灭坏故。如说。云何灭时法。谓现在法。故取无常为常住者。名边执见。不名见取。若乐苦见。于五见何见摄。何见所断。答邪见摄。见灭所断。问何谓为乐。答胜义乐唯涅槃。问何缘外道谓涅槃苦。答彼作是说。一根坏时。尚生于苦。况涅槃中诸根皆坏。是故涅槃必是极苦。对彼尊者世友说言。根是苦因。若一根在犹能生苦。况有多根。唯涅槃中诸根皆灭。无苦因故乃是极乐。此中邪见摄者显彼自性。谤涅槃故。见灭所断者。显彼对治。见灭谛时永断彼故。余如前说。问道谛亦乐。如契经说。道依资粮。涅槃依道。由道乐故。得涅槃乐。何故唯说见灭所断。答应知此中是有余说。谓应说言。若乐苦见是邪见摄。此有二种。若谓灭为苦见灭所断。若谓道为苦见道所断。而不说者有别意趣。谓无漏道虽亦是乐而属二分。属乐分者得涅槃故。属苦分者是无常故。如契经说。无常故苦。复有说者。道谛非乐。得涅槃故假说为乐。如说。由乐至乐涅槃。故此唯说见灭所断。问为有邪见能于涅槃起苦行相不。设尔何失。此中难通。广如前非常说

若不净净见。于五见何见摄何见所断。答取劣法为胜见取摄。见苦所断。问何谓不净。答诸有漏法。问何缘外道计彼为净。答愚于少时鲜净事故。如治发爪口齿皮等。令显形色暂时鲜净。便作是念。我身清净。然诸蕴中有少分净。如量而取亦非颠倒。外道于中增益而取。同究竟净故成颠倒。此中取劣法为胜。见取摄者显彼自性。取粪秽等为真净故。见苦所断者显彼对治。见苦谛时永断彼故。余如前说。问现见九孔不净常流。如何外道执身是净。答彼作是念。已流出者。虽是不净未流出者必应是净。如坚叔迦树花红赤似肉。野干蹲下望之作如是念。我于今者定当食肉。须臾彼花有堕地者。便走嗅之乃知非肉。复作是念。已堕地者虽非是肉。余未堕者必应是肉。外道亦尔。无明所迷故作是执。诸有漏法由二义故。说名不净。一由烦恼。二由境界。诸染污法具由二义。不染污法但由境界。问若尔云何有漏善法亦名清净。答少分净故。谓彼虽是有垢有过有毒有浊。而违烦恼不杂烦恼坏烦恼故。复有说者。诸无漏法是胜义净。有漏善法牵引顺彼故亦名净。问善说法者。于有漏法亦说有净。如三净业而不名恶。何故外道说彼为净便名恶见。答善说法者。唯说妙行为净。外道总说妙行恶行为净。复次善说法者唯说善根为净。外道总说善不善根为净。复次善说法者唯说对治。结缚随眼。随烦恼缠诸法为净。外道亦说结等为净。复次善说法者。说有漏法有少分净。外道说彼为究竟净。是故外道所说是恶。善说法者不名恶见

若净不净见。于五见何见摄。何见所断。答邪见摄。此有二种。若谓灭为不净见灭所断。若谓道为不净见道所断。问何谓为净。答灭道二谛。问何缘外道计灭道谛为不净耶。答彼说烦恼是真不净。圣道断之便成不净。道所得灭亦成不净。如以刀水割洗秽物。便成不净。以此刀水割洗余物。亦成不净。灭道亦然故应不净。此中邪见摄者显彼自性。诽谤灭道是不净故。见灭道所断者显彼对治。见灭道时永断彼故。余如前说。问为有见能于灭道二谛起不净行相不。设尔何失。此中难通广如前说

说一切有部发智大毗婆沙论卷第八阿毗达磨大毗婆沙论卷第九

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中世第一法纳息第一之八

若非我我见。于五见何见摄。何见所断。答有身见摄。见苦所断。问何谓非我。答一切法。问何缘外道于彼计我。答愚去来等作用事故。彼作是念。若无我者。谁去谁来。谁住谁坐。谁屈谁申。谁起谁卧。谁见闻嗅尝触忆识。以有我故有此等事。故诸外道于彼计我。此中有身见摄者显彼自性。于五取蕴执有我故。见苦所断者显彼对治。见苦谛时永断彼故。余如前说。问萨迦耶见有二行相。谓我行相。我所行相。即是我见我所见摄。何故此中唯说我见非我所见。答是作论者意欲尔故乃至广说。有作是说。亦应说彼而不说者。应知此中是有余说。复有说者。此中已说我见故应知亦说我所见。所以者何。以有我故得有我所。以有我见故得有我所见。以有己见故得有己所见。以有五我见故。得有十五我所见。以有我爱故得有我所爱。以有我愚故得有我所愚。有余师说。我见是根本是颠倒性故。此中偏说。我所见非根本。非颠倒性故此中不说。问善说法者。亦说诸法常有实体性相。我事而非恶见。何故外道说有实我便是恶见。答我有二种。一者法我。二者补特伽罗我。善说法者。唯说实有法我。法性实有。如实见故不名恶见。外道亦说。实有补特伽罗我。补特伽罗非实有性。虚妄见故名为恶见。问何故不说我非我见。答我实非有。若见非我便为正见。此中唯说诸恶见趣。是故不说我非我见。若非因因见。于五见何见摄。何见所断。答非因谓因戒禁取摄。见苦所断。问何谓非因。答自在天等不平等因。问何缘外道非因谓因。答亲近恶友。闻说自在自性士夫时方空等生诸法故。如农夫等秋多收实。便作是言。私多未度天等所与。若生男女。复作是言。是难陀等天神所与。信自在者。若生男女。便作是言。毗瑟拏天。矩陛罗等天神所与。如是等类非因计因。然有情数各别业生。非有情数共业所生。非自在等邪因所生。此中非因谓因。戒禁取摄者。显彼自性。执非亲正因为亲正因故。然戒禁取略有二种。一非因计因。二非道计道。此中但说非因计因。见苦所断者显彼对治。见苦谛时永断彼故。余如前说。问何故此见非见集断。答果处转故。问非因谓因者。亦谤诸法因。何故此见非邪见摄。答无行相转名为邪见。此有行相转故不名邪见。复有说者。坏实事转名为邪见。此乃增益转故不名邪见。尊者世友作如是言。若拨无因名为邪见。此非因计因故不名邪见。于非正因谓正因故

若因非因见。于五见何见摄。何见所断。答邪见摄。见集所断。问何谓为因。答业烦恼等。问何缘外道执内外事无因而生。答不了内外缘起法故。彼作是念。谁掘河海。谁积山原。谁纤棘刺。谁画禽兽。准此一切皆无因生。故彼颂言

  谁掘河海积山原　　谁纤棘刺画禽兽
  世无自在能作者　　故知一切皆无因

此中邪见摄者。显彼自性。诽谤诸法所从因故。见集所断者。显彼对治。见集谛时永断彼故余如前说。问何故此中谤因邪见见集所断。见蕴中说谤因邪见见集道断。答是作论者意欲尔故乃至广说。复次此非了义说。彼是了义说。此有余意趣。彼无余意趣。此说有余缘彼说无余缘。此说依世俗。彼说依胜义。复次此说少分因。彼说一切因。此唯说苦因。彼说苦及非苦因。此唯说颠倒因。彼说颠倒及非颠倒因。此唯说生果因。彼说生果不生果因。复次谤集邪见拨无因体亦拨因义。谤道邪见唯拨因体不拨因义。言涅槃无因是正非邪故。此中唯说谤因邪见故。见集所断非见道所断。若有无见于五见何见摄。何见所断。答邪见摄。此有四种。若谓无苦见苦所断。若谓无集见集所断。若谓无灭见灭所断。若谓无道见道所断。问何谓为有。答四圣谛。问何缘外道拨无四谛。答彼执有我故便拨无四谛。彼作是言色等五蕴是我非苦。便拨苦谛。我无有因便拨集谛。我常不灭便拨灭谛。我无对治便拨道谛。如善说法者。知色等五蕴是苦非我便信苦谛。此苦有因便信集谛。此苦可灭便信灭谛。苦有对治便信道谛。此中邪见摄者。显彼自性。拨无实有四圣谛故。此有四种。广说乃至。若谓无道。见道所断者。显彼对治。见四谛时永断彼故。余如前说应知此中谤苦谛者。有二种谤。一谤物体。二谤果义。谤集谛者。有二种谤。一谤物体。二谤因义。谤灭谛者。唯谤物体不谤果义。有作是说。亦谤果义。谤道谛者。唯谤物体不谤因义。有作是说。亦谤因义。有作是说。亦谤因果。有作是说。谤道谛者。唯谤作用。问何故邪见不缘虚空及非择灭。答若法是蕴是蕴因。是蕴灭是蕴对治。邪见则缘虚空非择灭。非蕴非蕴因。非蕴灭非蕴对治故彼不缘。复次若法是苦是苦因。是苦灭是苦对治。邪见则缘。虚空非择灭。非苦非苦因。非苦灭非苦对治故彼不缘。如苦苦因等。应知病痈箭恼重担及彼因等亦尔。复次若法是杂染清净事。邪见则缘。虚空非择灭非杂染清净事故彼不缘。复次若法是无漏正见所缘。邪见则缘。虚空非择灭非无漏正见所缘故彼不缘。如无漏正见对治邪见。应知无漏智明决定信等对非智等亦尔。复次若法如此岸彼岸中流船筏。邪见则缘。虚空非择灭非如此岸彼岸中流船筏故彼不缘。复次若法有因果义。邪见则缘。虚空非择灭无因果义故彼不缘。复次若法是欣厌事。邪见则缘。虚空非择灭非欣厌事故彼不缘。复次若法能为损益。邪见则缘。虚空非择灭不能损益故彼不缘。问拨无虚空非择灭者为缘何法。答即缘虚空非择灭名。所以者何。拨无彼者无深重心。如谤杂染清净事故。问此是何智。答此是欲界修所断中。无覆无记邪行相智。然诸有者。有说二种。一实物有。谓蕴界等。二施设有。谓男女等。有说三种。一相待有。谓如是事。待此故有。待彼故无。二和合有。谓如是事。在此处有在彼处无。三时分有。谓如是事。此时分有彼时分无。有说五种。一名有。谓龟毛兔角空花鬘等。二实有。谓一切法各住自性。三假有。谓瓶衣车乘军林舍等。四和合有。谓于诸蕴和合施设补特伽罗五相待有。谓此彼岸长短事等

若无有见于五见何见摄。何见所断。答此非见是邪智。问此若非见云何乃言若无有见。有作是说。此中应言若无有见于五见何见摄。何见所断。答有身见摄。见苦所断。复有说者。此中应言若无有慧。于五见何见摄。何见所断。答此非见是邪智。或有说者此中应言。若无有见此非见。五见中不说故。如是说者。应如文说。所以者何。为问答故。为成问答。虽无此理。而作是说。如十门品作是问言。三无漏根诸无为法。是几随眠之所随增。答言。无有随眠随增。此亦如是。问此邪智是何。答此是欲界修所断中。无覆无记邪行相智。如于杌起人想。及于人起杌想。于非道起道想。于道起非道想。如是等有余师说。如是邪智。亦有染污能起慢类。梵王住此作如是言。我是大梵诸梵中尊。我能造化能生世间。为世间父。此说非理。所以者何。见所断心不能发起身语业故。由此前说于理为善。谓是欲界修所断中无覆无记邪行相智。问若尔智蕴所说。当云何通。如说。云何邪智。谓染污慧。答邪智有二种。一染污。二不染污。染污者无明相应。不染污者无明不相应。如于杌起人想等。染污者声闻独觉俱能断尽亦不现行。不染污者。声闻独觉虽能断尽而犹现行。唯有如来毕竟不起。烦恼习气俱永断故。由此独称正等觉者。染污邪智。由胜义故名为邪智。不染污者。由世俗故得邪智名。非由胜义。烦恼邪法不相应故。后智蕴中所说邪智是胜义者。今说世俗故不相违

     发智大毗婆沙论 杂蕴第一中智纳息 第二之一

颇有一智知一切法耶。如是等章及解章义。既领会已。次应广释。问何故作此论。答为止他宗显己义故。谓或有执。心心所法能了自性。如大众部彼作是说。智等能了为自性故。能了自他。如灯能照为自性故。能照自他。或复有执。心心所法能了相应。如法密部彼作是说。慧等能了相应受等。或复有执。心心所法。能了俱有。如化地部彼作是说。慧有二种。俱时而生。一相应。二不相应。相应慧知不相应者。不相应慧知相应者。或复有执。补特伽罗能了诸法。如犊子部彼作是说。补特伽罗能知非智。为止如是他宗异执显自所说。诸心心所。不了自性。相应俱有。补特伽罗性不可得。故作斯论。复次勿为止他及显己义。然诸法相。理应分别。饶益有情故造斯论。颇有一智知一切法耶。答无。若此智生一切法非我。此智何所不知。答不知自性及此相应俱有诸法。此中不知自性者。即止大众部执。不知相应诸法者。即止法密部执。不知俱有诸法者。即止化地部执。言智能知。即止犊子部执。又于此中有问有答。有难有通。颇有一智知一切法。耶者是问。答无者是答。若此智生一切法非我。此智何所不知者是难。答不知自性及此相应俱有诸法者是通。问此中谁问谁答。谁难谁通。答分别论者问。应理论者答。分别论者难。应理论者通。有说。弟子问师答。弟子难师通。有说。此中无别现问难者。但本论师。为辩法相假设宾主。此中一智者。谓一刹那智。由此不知自性。相应俱有诸法。若作是问。于十智中。颇有一智知一切法耶。应答言有。谓世俗智。如是问于九八七六五四三二智中。颇有一智知一切法耶。答有。谓世俗智。若即于此世俗智中。作如是问。颇二刹那顷知一切法耶。答有。谓此智初刹那顷。除其自性相应俱有。余悉能知。第二刹那。亦知前自性相应俱有法。故答言有。今此唯问一刹那智。故答言无。问何缘自性不知自性。答勿有因果。能作所作。能成所成。能引所引。能生所生。能属所属。能转所转。能相所相。能觉所觉。无差别过。是故自性不知自性。有说。自性于自性。无益无损。无养无害。无成无坏。无增无减。无聚无散。无因无等无间。无所缘。无增上。诸法自性。不观自性。但于他性能作诸缘。是故自性不知自性。有说。世间现见。指端不自触。刀刃不自割。瞳子不自见。壮士不自负。是故自性不知自性。尊者世友说曰。何故自性不知自性。答非境界故。复次若自性知自性者。世尊不应安立二缘生于六识。谓眼及色为缘生眼识。乃至意及法为缘生意识。复次若自性知自性者。世尊不应安立三和合触。谓眼及色为缘。生眼识三和合故。触乃至广说。复次若自性知自性者。世尊不应安立邪见。谓彼邪见若能自知我是邪见便为正见。如说。邪见若能自观是邪见者。应名正见非谓邪见。复次若自性知自性者。不应建立恶心遍体皆是不善。以了自体非邪僻故。复次若自性知自性者。不应建立能取所取。能知所知。能觉所觉。境有境。行相所缘。根根义等。复次若自性知自性者。则四念住应无差别。以身念住即法念住。乃至心念住即法念住故。复次若自性知自性者。四圣谛智应无差别。以苦智即道智。乃至灭智即道智故。复次若自性知自性者。则宿住随念智应不说有。以彼即知现世事故。复次若自性知自性者。则他心智应不说有。以彼亦知自心所故。大德说曰。若自性知自性者。则应不知他性。于自性转故。若自性知他性者。则应不知自性。于他性转故。若知自性及他性者。云何而知。如知自性是自性。知他性亦尔耶。如知他性是他性。知自性亦尔耶。若如知自性是自性。知他性亦尔者。则知自性是自性。可是正。知他性是自性应是邪。若如知他性是他性。知自性亦尔者。则知他性是他性。可是正知自性是他性应是邪。若尔应无邪正二智体相差别若一时知自性是自性。知他性是他性者。则应一智有二解用。解用别故体亦应别。体既各别。应非一智。一有情身二智并起不应正理勿有此失。是故自性不知自性。问若尔大众部所说喻云何通。答不必须通。彼非素怛缆毗奈耶阿毗达磨摄故。又不可以世俗现喻难贤圣法。贤圣法异世俗法异故。若必须通。应说喻过。喻既有过。所喻不成。如灯无根无所缘虑非有情数。智亦应尔。如灯是色极微所成。智亦应尔。既不如是。云何为喻。又彼许灯是照性不。若是照性复何须照。若非照性体应是闇不应名灯。破闇名灯宁非照性。故不应执灯能自照。由此所喻。亦不得成。问何缘不知相应诸法。答同一所缘。俱时转故。谓一有情心心所法。于一境界俱时而转。理无展转互相缘义。譬如多人集在一处。或同观下。或共观空。理必不能互相见面。心心所法亦复如是。若智能知相应受者。彼受为能缘自体不。若缘自体。则有前说缘自性过。若不能缘。则心心所应俱时起。不同所缘勿有此失。故不能知相应诸法。问何缘不知俱有诸法。答极相近故。如筹沾取安缮那药置于眼中。极相近故眼不能见此亦如是。问何等名为俱有诸法。答此随转色。及此随转不相应行。西方诸师作如是说。与慧俱生诸蕴相续。自身摄者是俱有法。彼说非理。所以者何。若尔眼识应不能取自身诸色。余识亦尔。彼作是说。五识能取自身中境意识不能。若尔意识应不能取一切境界便为非理。复有余过。苦法智忍应不现观自身俱生诸蕴相续。若尔便为于自谛境少分现观。彼作是言。苦法智忍于自谛境少分现观。亦无有失。苦法智生尽现观故。如道法智忍于自谛境。虽少分现观而无有失。道法智生尽现观故。彼言非理。所以者何。苦道现观义各异故。谓欲界系见道所断。一一邪见总谤一切法智品道。道法智忍。设唯于一法智品道得现观者。亦能总断能谤邪见。况除自性相应俱有。余并现观萨迦耶见。于五取蕴。执我我所。或总或别。苦法智忍。若于自谛不尽现观。应有别缘萨迦耶见。尔时不断不现观彼所执境故。萨迦耶见。若不断尽彼为上首见苦所断诸余烦恼。亦应不断。若尔不应名于自谛得真现观。若于苦谛不得现观。于集灭道亦应不得。如是便无究竟解脱。勿有此过故不应说苦法智忍。不观自身俱生诸法。又若尔者。便与本论前说相违。如说。若缘此法起苦法智忍。即缘此法起世第一法。世第一法既能总缘欲界五蕴。苦法智忍何为不能。是故应知前说为善。问补特伽罗何缘不知。答彼如兔角不可得故。谓一切法无我有情补特伽罗。命者生者能养育者。作者受者。唯空行聚。是故无有补特伽罗。能知诸法

颇有一识了一切法耶。乃至广说。问何故作此论。答为止他宗显己义故。谓或有执。识即是智唯长一字所谓毗字。为止彼宗显识与智其体各别。如契经言。智相应识。或执六识各别所缘。如五识身所缘各别。如是意识但缘法处。为止彼宗显示意识缘十二处。如契经说。一切皆是意识所缘。或有执智缘一切法识不能尔。为止彼宗显识与智俱能总别缘一切法。或有执智缘自相共相。识唯缘自相。为止彼宗显智与识俱缘二相。或有执智缘同分不同分境。识唯缘同分境。为止彼宗显智与识俱缘二分。或有执智缘三世境及非世境。识唯缘现在境。为止彼宗显智与识俱缘三世及非世境。或有执智通缘五蕴及非蕴境。识唯缘色。为止彼宗显智与识俱缘五蕴及非蕴境。或有执智缘自相续及他相续。识唯缘自相续。为止彼宗显智与识俱缘自他。或有执智缘内外处。识唯缘外处。为止彼宗显智与识俱缘内外。或有执智缘有漏无漏。识唯缘有漏。为止彼宗显智与识俱缘二种。或有执智缘有为无为。识唯缘有为。为止彼宗显智与识俱缘二种。或有执智唯是道支。识唯是有支。如犊子部。以契经说正见是道。支行缘识故。为止彼宗显智与识俱通二支。但随强说。或有执智与识不俱。如譬喻者。为止彼宗显智与识有俱时生。由此因缘故造斯论

问何故此中智后说识。答是作论者意欲尔故乃至广说。有说。此是经论旧法。谓契经说。尊者摩诃俱瑟耻罗。往诣尊者舍利子所。先问。智者何故名智。后问识者何故名识。舍利子言。能知故名智。能了故名识。品类足论先说所知后说所识。先说智门后说识门。达磨难提亦作是说。若于是处有智识转。当知必有胜事成办。故此亦于智后说识。有说。俱是根本法故。谓一切清净品中智为根本。一切杂染品中识为根本。清净品胜是故前说。有说。俱是上首法故。如契经说。明为上首无量善法皆得生长。识为上首诸杂染法皆得生长。诸善法胜是故前说。有说。俱是所依趣故。如契经说。应依趣智不依趣识。又说。五根各别所行。各别境界。意根于彼所行境界俱能领受。意根皆为彼所依趣。智依趣胜是故前说。有说。俱是有所缘故。十二处中二有所缘。谓意处法处。此中说智。即总显有所缘法处。说识即显意处法处法多。是故前说。有说。此中说心心所法故。谓若说智则总显诸心所法。若说识则显心心所法多。是故前说

颇有一识了一切法耶。答无。若此识生一切法非我。此识何所不了。答不了自性及此相应俱有识法。此中破执。问答难通释本文等准前应说。问此中所说缘一切法。非我行相。由何契经知有如是缘一切法非我行相耶。答如契经说

  若时以慧观　　一切法非我
  尔时能厌苦　　是道得清净

由此契经。知有如是缘一切法非我行相。问此经为说缘一切法非我行相。为说缘苦谛非我行相耶。设尔何失。若说缘一切法非我行相者。云何复言尔时厌苦。若说缘苦谛非我行相者。云何说观一切法非我。有作是言。此经中说缘一切法非我行相。问云何复言尔时厌苦。答此颂前半。说缘一切法非我行相。后半说缘苦谛非我行相。有说。前半说修观时。后半说现观时。有说。前半说闻思修所成慧。后半唯说修所成慧。有说。前半说有漏慧。后半说无漏慧。如有漏无漏。世间出世间。有味无味。耽嗜依出离依。堕界不堕界。顺取非顺取。应知亦尔。有说。前半说同相作意。后半说别相作意。有余师说。此经但说缘苦谛非我行相。问云何说观一切法非我。答一切有二种。谓一切一切。少分一切。此中但说少分一切。余处亦说少分一切。如世尊说。一切炽然。非无漏法有炽然义。此中亦尔。此中虽不说缘一切法非我行相。而余经说。如世尊说。一切行无常。一切法无我。涅槃寂静。评曰。随有经证。或无经证。然决定有缘一切法非我行相。谓瑜伽师。于修观位起此行相。故此中说。问亦有空行相。能缘一切法。此中何故不说耶。答是作论者意欲尔故。乃至广说。有说。应说而不说者。当知此义有余。有说。非我行相其义决定。是故偏说。谓空行相义不决定。以一切法有义故。空约他性故。有义故。不空约自性故。非我行相无不决定。以约自他俱无我故。由此尊者世友说言。我不定说诸法皆空。定说一切法皆无我。问若非我行相。与空行相。俱能缘一切法者。此二行相有何差别。答非我行相对治我见。空行相对治我所见。如对治我见我所见。对治己见己所见。五我见十五我所见。我行相我所行相。我执我所执。我爱我所爱。我愚我所愚。应知亦尔。有说。观蕴非我。是非我行相。观蕴中无我。是空行相。如观蕴非我蕴中无我。观界界中。观处处中。应知亦尔。有说。于非有观非有。是非我行相。于有观非有。是空行相。有说。于无观无。是非我行相。于有观无。是空行相。有说。观自性空。是非我行相。观所行空。是空行相。有说。观体不自在。是非我行相。观内无士夫。是空行相。是谓二种行相差别。问何故有漏非我行相。缘一切法。无漏非我行相。唯缘苦谛耶。答有漏非我行相。非烦恼对治故。能缘一切法。无漏非我行相。是烦恼对治故。不缘一切法。非一切法顺烦恼性故。有说。有漏非我行相。非颠倒对治故。能缘一切法。无漏非我行相。是颠倒对治故。不缘一切法。非一切法顺颠倒性故。有说。有漏非我行相。无分齐缘故。若缘一切法。无漏非我行相。有分齐缘故。不缘一切法。缘我见境为非我故。有说。有漏非我行相。修观时胜故。能缘一切法。以修观时观一切法为非我故。无漏非我行相。现观时胜故不缘一切法。以现观时但缘苦谛为非我故。现观位中别观谛故。由此因缘。有漏非我行相。能缘一切法。无漏非我行相。但缘苦谛。问有漏非我行相。亦不能缘一切法。以不能缘自性相应俱有法故。云何乃言缘一切法。答依多分说故无有过。谓所缘者犹如大地。四大海水。苏迷卢山。太虚空量所。不缘者。犹如芥子大海一渧。妙高一尘。虚空蚊处。故无有失。有说。以此有漏非我行相。二刹那顷缘一切法。故作是说。非如无漏非我行相。虽多刹那。亦不能缘一切法尽。有说。有漏非我行相。一刹那顷。亦缘一切所应。缘法自性。相应俱有诸法。非所缘故。不应为责。由此因缘。如是有漏非我行相。虽言一切法皆非我。而非颠倒

说一切有部发智大毗婆沙论第九卷阿毗达磨大毗婆沙论卷第十

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中智纳息第二之二

问缘一切法非我行相。自体是何。答慧为自体。如自体我物相分。自性亦尔。已说自体。所以今当说。问何故名为缘一切法非我行相。答此慧行一切法起非我相故。名缘一切法非我行相。界者此行相。唯欲色界无色界中。亦有此行相而不能缘一切法。后当广说。地者此行相在七地谓欲界未至静虑中间。及根本四静虑。此则总说。若别说者。闻所成慧。唯在五地。谓欲界四静虑。思所成慧唯在欲界。修所成慧唯在六地。谓前说七地中除欲界。四无色地。亦有此行相。而不能缘一切法。谓空无边处。非我行相。缘四无色。彼因彼灭。一切类智品道。及四无色非择灭。一切类智品道。非择灭并一切虚空无为。或欲令是一物。或欲令是多物。此行相尽能缘。识无边处非我行相。缘上三无色。彼因彼灭。一切类智品道。及上三无色非择灭。一切类智品道。非择灭并一切虚空无为。或欲令是一物。或欲令是多物此行相尽能缘。无所有处非我行相。缘上二无色。彼因彼灭。一切类智品道。及上二无色非择灭。一切类智品道非择灭。及一切虚空无为。或欲令是一物。或欲令是多物。此行相尽能缘非想非非想处。非我行相。缘非想非非想处。彼因彼灭。一切类智品道。及非想非非想处非择灭。一切类智品道。非择灭并一切虚空无为或欲令是一物。或欲令是多物。此行相尽能缘。有余师说。空无边处非我行相。缘五地非择灭。谓四无色第四静虑。余如前说。乃至非想非非想处非我行相。缘二地非择灭。谓彼自地无所有处。余如前说。评曰。应知此中前说者好。问何故无色地。无缘一切法。非我行相耶。答若地中有顺决择分。及彼加行相似善根。彼地可有缘一切法。非我行相。无色不尔故彼地无。有说。若地中有行谛善根。彼地可有如是行相。无色不尔。有说。若地中有现观边世俗智。彼地可有如是行相。无色不尔。有说。若地中有见道及见道加行。彼地中有如是行相。无色不尔。有说。若地观胜有此行相无色止胜故彼地无。所依者。此非我行相。依欲色界身。初起依欲界身。行相者。作非我行相。所缘者。缘一切法。念住者。是杂缘法念住。智者是世俗智。三摩地俱者非三摩地俱。根相应者三根相应。谓乐喜舍。问亦有善忧根能缘一切法。何故此行相非彼相应。答互相违故。谓此欢行相转。彼戚行相转。故不相应。世者此行相堕三世。缘三世及离世。善不善无记者。是善缘三种三界。系不系者。欲色界系。缘三界系及不系。学无学。非学非无学者。是非学非无学。缘三种见所断修所断。不断者是修所断缘三种。缘名缘义者。名义俱缘。缘自相续他相续。非相续者。三种俱缘。闻思修所成者。通三种。加行得。离染得。生得者。可言通三种。此则总说。若别说者。欲界闻思所成非我行相。唯加行得。色界闻所成非我行相。可言加行得可言生得。云何可言加行得。谓若此间于自共相善。修习者生彼便得。若不尔者生彼不得。云何可言生得。谓虽此间善修习已。若未生彼终不能得。生彼方得。彼闻所成非我行相。必依此间所修加行。生彼得故。色界修所成非我行相。是加行得及离染得。亦可言是生得。问若欲界没。生第二静虑。第二静虑没生初静虑。彼得初静虑非我行相不。答若先善修习者得。不尔者不得。乃至生第四静虑亦尔。问若欲界没。生无色界。无色界没。生初静虑。彼得初静虑非我行相不。有说。不得。以极远故。如是说者。若先善修习者得。不尔者不得。乃至生第四静虑亦尔。问若初静虑没。生第二静虑。第二静虑没。生初静虑。彼得初静虑非我行相不。答若先善修习者得。不尔者不得。生余地亦尔。问何等补特伽罗得此行相。为但圣者。为通异生。有作是说。唯圣者得。非诸异生。如是说者。异生亦得。问异生有二种。谓内法外法。何等异生得此行相。有作是说。内法者得。非外法者。彼着我故。不能修习空无我见。如是说者。外法异生亦得此行相。然与内别。谓内法者。亦加行得亦生得。亦得亦在身亦成就。亦现在前。外法异生。唯生得而不在身成就。不现在前。以着我故。问云何起非我行相耶。答若生欲界。起欲色界非我行相。俱能缘一切法。若生初静虑。起初静虑非我行相。不定者亦能缘一切法。定者唯缘从初静虑乃至有顶。起上三静虑非我行相。亦唯能缘从初静虑乃至有顶。若生第二静虑。起第二静虑非我行相。不定者能缘一切法。定者唯缘从第二静虑乃至有顶。起第三第四静虑非我行相。亦唯能缘从第二静虑乃至有顶。若生第三第四静虑。如理应说。若生欲界色无色界。起无色界非我行相。缘法分齐如前已说。问欲色二界非我行相。何者缘法多耶。答色界非我行相。若不定者。所缘法与欲界等。若定者则所缘法少于欲界。谓不能缘自随转色。欲界非我行相。无随转色故。能缘一切色故。有说。言有身念住。缘一切色无有受心。法念住缘一切受心法。问此缘一切法非我行相。为有漏为无漏耶。答是有漏非无漏。所以者何。有世俗非我行相。尚不能缘一切法。如顺决择分。何况无漏非我行相。能缘一切法耶。以此行相别谛缘故。如诸邪见尚无一时缘二谛者。况缘多耶。如所对治能对治亦尔。问有漏非我行相。能断烦恼不。答不能断。问若尔圣者何故起耶。答令根转利入圣道故。复次由四缘故圣者起之。一为现法乐住故。二为观本所作故。三为游戏功德故。四为受用圣财故。问此非我行相。为欣作意俱。为厌作意俱耶。设尔何失。若欣作意俱者。云何缘可厌法。若厌作意俱者。云何缘可欣法。答应作是说。欣作意俱。问若尔云何缘可厌法。答彼瑜伽师。于可欣法生欣尚故。设于无量可厌聚中。有一可欣则生欣乐。何况多耶。如铜钱聚上置一金钱。便于此聚总生欣乐。此亦如是。故无有失

颇有二心展转相因耶。乃至广说。问何故作此论。答为止他宗显己义故。谓或有执。因缘无体。为止彼宗欲明因缘实有体性。或复有执。一补特伽罗。有二心俱生。如大众部。为止彼宗明一补特伽罗无二心俱生。或有外道。引世现喻执后为前因。彼作是说。现见泉涌。后逼于前。令其涌泒。此中后水为前水因。如是诸法行三世时。未来世逼令入现在。现在世逼令入过去。故未来世为现在因。现在复与过去为因。为止彼宗欲明后法非前法因。若是因者。便违内外缘起诸法。违内法缘起者。谓应行缘无明。乃至老死缘生。父母因子。眼色因眼识。乃至意法因意识。又应羯逻蓝因頞部昙。乃至壮因于老。如是等违外法缘起者。谓应种子因芽。乃至花因于果。如是等复有大过。谓应未造业而受果。受果已方造业。其事云何。应先受苦乐异熟。后造善恶业。先得律仪不律仪果。后受律仪不律仪戒。先堕地狱后造无间。先作轮王后造彼业。先得无上正等菩提。然后乃修六到彼岸。若未作业先受根者。应已作业而便失坏。是则应无解脱出离。是故不可后为前因。由此因缘故作斯论。颇有二心展转相因耶。答无。所以者何。无一补特伽罗非前非后。二心俱生。又非后心为前心因。此中无者。即止拨无因缘实体。谓无二心展转相因。然有余法互为因义。无一补特伽罗等者。即止大众部执。一补特伽罗有二心俱生。一补特伽罗者。遮多补特伽罗。非前者遮过去。非后者遮未来。此则显示一补特伽罗现在一刹那顷无有二心。有别诵言。非曾非当非现一补特伽罗二心俱生。此则显示一补特伽罗三世。一刹那顷皆无二心。又非后心为前心因者。此即止外道执后为前因。显示后法非前因义。此中俱依五因作论故答言无。若依六因应答言有。以能作因皆遍有故。无一补特伽罗等者。遮相应俱有因义。又非后心为前心因者。遮同类遍行异熟因义。皆不遮者。谓能作因。如说二心无互为因义。如是二受二想。二思二触。二作意二胜解。二欲二念。二定二慧等。诸心所法二眼。乃至二身等诸色法。二命根二众同分等。心不相应行法同类。皆无互为因义

颇有二心。展转相缘耶。乃至广说。问此中不应先作此论。应先作此论。何故无一补特伽罗。乃至广说。所以者何。先说无一补特伽罗。非前非后二心俱生。虽作是说。而未说其因缘。故次应说。何故无一补特伽罗。乃至广说。而不先作是说者。有何意耶答是作论者意欲尔故。乃至广说。有说。阿毗达磨为显诸法性相故说。不应求其次第。但不违法相。若先若后。俱不应责。有说。论有二种。一根本论。二傍生论。此中颇有二心。展转相因相缘等者。是根本论。何故无一补特伽罗等者。是傍生论。二根本论。理应先说。一傍生论理应后说。故此先说。颇有二心展转相缘耶。乃至广说。问何故作此论。答欲令疑者得决定故。谓前说无二心展转相因。勿谓亦无二心展转相缘。为除此疑。显有二心展转相缘。复有说者。为止拨无所缘缘体者。意显所缘缘体性实有。故作斯论

颇有二心展转相缘耶。答有。如有心起无未来。心即思惟。此起第二心。乃至广说。问此中但应总答言。有不应更说。如有等言。所以者何。如说若法与彼法为所缘。此法与彼法。有时非所缘耶。答无。时非所缘故。答虽总言有于义已足。而为饶益诸弟子等。令得明了故复重说。如有等言。如有心起无未来。心即思惟。此起第二心者。谓先起一刹那邪见。或唯谤未来邪见聚。或总谤未来有漏诸蕴。后起第二刹那邪见。或唯谤过去邪见聚。或总谤过去诸蕴。彼二邪见。相应心展转相缘。如邪见后生邪见于彼谤无。如是邪见后生有身见。于彼执我我所。边执见计。断常见取执。第一戒禁取执能净疑犹豫贪染。恚憎慢自举无明不了。又邪见后或生正见。于彼起非常苦空非我。因集生缘。是有是实是性是分。有因有起。有处有事行相。或生无覆无记心。于彼起非如理。非不如理行相。是名邪见。相应心与诸有漏心。展转相缘。如邪见心余染污心应知亦尔。此中且说邪见为门。同染污故。如有心起有未来。心即思惟此起第二心。问何故复作此论。答前说邪见心。与有漏心展转相缘。今欲说正见心。与有漏心展转相缘。故作此论。谓先起一刹那正见或唯于未来正见聚。或总于未来有漏诸蕴。起有行相。后起第二刹那正见。或唯于过去正见聚。或总于过去有漏诸蕴。起非常等行相。如正见后生正见。于彼起非常等行相。如是正见后或生邪见。于彼谤无有身见。执我我所。广说乃至无明不了。又正见后或生无覆无记心。于彼起非如理非不如理行相。是名正见。相应心与诸有漏心。展转相缘。如正见心。无覆无记心应知亦尔。同不染故。如有心起无未来道。心即思惟此起第二心。问何故复作此论。答前说邪见心。与有漏心。展转相缘。今欲说邪见心。与无漏心展转相缘。故作此论。谓先起一刹那邪见谤未来道。后入正性离生。起苦忍苦智。或集忍集智。于彼过去邪见聚。起非常苦空非我。因集生缘行相。如是二心展转相缘。应知此中遮刹那遮流注。不遮时分。不遮众同分。不遮无始以来。遮刹那者。谓必无有前刹那起邪见谤圣道。第二刹那即能入正性离生故。遮流注者。谓必无有一流注中。先起邪见谤圣道。后即能入正性离生。不遮时分者。谓初日分时。起邪见谤圣道。中日分时。即能入正性离生。中日分时。起邪见谤圣道。后日分时。即能入正性离生。夜三分亦尔。如是昼夜半月月时年诸位皆悉不遮。况众同分。无始已来。如邪见疑无明应知亦尔。同缘道故。如有心起有未来道。心即思惟此起第二心。问何故复造此论。答前说正见心。与有漏心展转相缘。今欲说正见心。与无漏心展转相缘。故造斯论。谓先起一刹那正见。或唯于未来无漏心。或总于未来无漏诸蕴。起有行相。后起圣道。或惟于过去正见聚。或总于过去有漏诸蕴。起非常苦空非我。因集生缘行相。如是二心展转相缘。应知此中诸有欲令唯共相作意无间起圣道者。彼遮刹那。不遮流注等。遮刹那者。此有未来道心行相。是自相作意故。诸有欲令二种作意无间皆起圣道者。彼亦不遮刹那。如有二知他心者。彼二心展转相缘。问何故复作此论。答前说自相续心。与自相续心展转相缘。今欲说自相续心。与他相续心展转相缘。故作斯论。问此中说何等二知他心者。彼二心互相缘耶。答此中说根等地等道等。二知他心者。彼二心展转相缘。根等者。谓同利根中根软根。地等者。谓同依初静虑。乃至同依第四静虑。道等者。谓同有漏。同无漏。同法智品。同类智品。同学同无学。问彼二心云何相缘。答但缘彼心。非彼心所缘及能缘行相。若缘彼心所缘及能缘行相者。则有自缘之过。问亦有余智俱心展转相缘。何故但说他心智俱。答是作论者。意欲尔故。乃至广说。有说。应说而不说者。当知此义有余。有说。此中但说明了不杂易可知者。余智不尔。问有多种他心智。此中为说何者。答说加行得离染得者。问何故不说余耶。答是作论者意欲尔故。乃至广说。有说。应说而不说者。当知此义有余。有说。此中但说名义胜者。谓加行得。离染得者。是修所成。通慧所摄四支五支。胜静虑果。有说。此智于境无有谬失。余则不尔。是以不说。今因此文动尔焰海。如说。二心展转相缘。应知受等诸心所法相缘亦尔。又亦应说部界善等诸心相缘。部者。谓见苦所断心。与见苦集修所断心展转相缘。见集所断心。与见苦集修所断心。展转相缘。见灭所断。有漏缘心展转相缘。见道所断。有漏缘心展转相缘。见道所断。无漏缘心与无漏心。展转相缘。应知无漏心亦展转相缘。修所断心展转相缘。修所断心与无漏心展转相缘。应知修所断心。与见苦集所断心展转相缘者。谓善无覆无记。与无漏心。展转相缘者唯善。界者欲界心。与欲色界及不系心。展转相缘。色界心与色无色界及不系心。展转相缘。无色界心。与无色界及不系心。展转相缘。应知无色界心。与色界心展转相缘者。谓空无边处近分。善等者。谓善不善无记心。各与三种心。展转相缘。唯除不善异熟。以彼唯在五识身故。余无覆无记心。有展转相缘义。又此中所说。邪见谤因谤果者。有四句差别。谓或依因谤果。或依果谤因。或不依因谤果。或不依果谤因。依因谤果者。如说。妙行恶行无果异熟。依果谤因者。如说。一切士夫补特伽罗所受苦乐无因无缘。不依因谤果者。如说。无有化生有情。不依果谤因者。如说。无有妙行恶行

问缘有四种。此中何故但说因及所缘。非余二耶。答是作论者意欲尔故。乃至广说。有说。应说而不说者。当知此义有余。有说。彼二亦在此所说中。谓若说因缘。应知已说等无间缘。如无二心展转为因。亦无二心展转为等无间故。若说所缘缘。当知已说增上缘。如有二心展转为所缘。亦有二心展转为增上故。何故无一补特伽罗。乃至广说。问何故复作此论。答为止他宗显己义故。谓或有执。等无间缘。体非实有。为遮彼意。欲显实有等无间缘。或有执。一补特伽罗二心俱生为重遮彼显唯一心。有说。此文是傍生论。前说无一补特伽罗。非前非后。二心俱生。未说所以。今欲说之。故作斯论。何故无一补特伽罗。非前非后二心俱生。答无第二等无间缘故。谓心心所法生必依止等无间缘。既无第二等无间缘。故必无一补特伽罗。非前非后二心俱生。此复应问。何故无第二等无间缘。故复答言。有情一一心相续转故。谓有情心。法尔一一相续而转。无二无多。此是展转更相答义。有说。此文重答前问谓先问言。何故无一补特伽罗。非前非后二心俱生。今重答言。有情一一心相续转。谓一一有情由法尔力。但有一心相续而转。所以者何。未来心聚。必由现在和合故生。不和合则不生。现在但有一和合故。令未来心一一而起。犹如多人经于狭路。一一而过尚无二并。何况有多。又如牛羊圈门狭小一一而出。无二无多。如是有情未来心聚。依现和合一一而生。设现在世有多和合。为开次者。则应一时有多心起。但无此事故一一生。又由和合有先后故。假使先有修道和合。后见道者则应修道。先见道生但无此事故。先起见道。由此无一补特伽罗。非前非后。二心俱生。于此义中复有分别。谓何故无一补特伽罗。非前非后二心俱生。尊者世友说曰。于一刹那身。唯有一心。依彼转故无有二。复次于一刹那命根唯一心。依彼转故无有二。复次于一刹那。唯有一类众同分心。依彼转故无有二。大德说曰。法生时和合唯一无二。不可一和合有二果生故。一刹那心唯有一。复有说者。若有二心俱生。则应不可调伏。如今一心刚强[怡-台+龍]悷。犹难调伏况二心耶。若心不可调伏。则无得解脱义。故一相续无二心俱。或有说者。若一相续二心俱生。则有杂染清净。俱时起过。谓一心杂染。一心清净。如是则无得解脱理。又应一时生善恶趣。复次若一相续二心俱生。何妨有三。若有三者。应一时受三界异熟。是则界坏亦无解脱。复次若一相续三心俱生。何妨有四。若有四者。应一时受四生异熟。是则生坏亦无解脱。复次若一相续四心俱生。何妨有五。若有五者。应一时受五趣异熟。是则趣坏亦无解脱。复次若一相续五心俱生。何妨有六。则应一时六识俱起应一时取一切境界。复次若一相续六心俱生。何妨有百。若有百者何妨有千。乃至何妨无数俱起。若尔诸法从未来世。应一时生。于现在世一时而灭。是则应无未来现在。以观未来现在故。说有过去。未来现在无故过去亦无。若无三世则无有为。若无有为则无无为。如是则一切法皆无。是为大过。是故无有二心俱生。有余师说。若一相续二心俱生。则应受等诸心所法亦二俱生。则一刹那应有十蕴。则有情坏。有情坏故所依身坏。所依坏故则五部坏。五部坏故则对治坏。对治坏故则遍知坏。遍知坏故沙门果等一切皆坏。勿有此过。故一相续无二心俱。问如一刹那有多心所。而无前过心亦应尔。尊者世友说曰。心所虽多而与心同一。等无间缘之所引起。如心是一受等亦一。故无有过。大德说曰。心与受等一和合生。如心是一受等亦一。故无有过。复有说者。心与受等一作意生。如心是一受等亦一。虽皆名心所而体类各异。故无有失

问如前所说。等无间缘自体是何。答除阿罗汉最后心心所法。诸余过去现在心心所法。是谓等无间缘自体。问何故阿罗汉最后心心所法。非等无间缘耶。答彼心心所法。若是等无间缘者。彼后应有心心所法生。若尔便无究竟解脱。有余师说。彼亦是等无间缘。彼后心心所法不生者。有余缘故。非彼为碍。设当生者亦与作缘。犹如意根意界意处。彼不应作是说。所以者何。等无间缘依作用立。若法与彼法作等无间缘。无法无有情。无咒术无药物等。能为障碍令彼不生。意根界处。依根相故立。虽后识不生。而有根等相故。得名根等问何故阿罗汉最后心有意根等相而无等无间缘相耶。答意根界处。不必观于后法。故立观心所等。亦得名故。等无间缘。观后法立后不生故。不说为缘。复次不生法中。有意识相。故最后心是意根等。不生法中无等无间相。以杂乱住故。是以最后心等。不立等无间缘。问等无间缘。以何为相。答体即是相。相即是体。不应离体别求其相。尊者世友说曰。能开避义。是等无间缘相。复次与次第义。是等无间缘相。复次与作用义。是等无间缘相。复次能生心义。是等无间缘相。复次能引发心义。是等无间缘相。复次能警觉心义。是等无间缘相。复次能令心相续义。是等无间缘相。大德说曰。能引生无间心义。是等无间缘相。尊者婆末罗说曰。能令未已生心续已生心义。是等无间缘相。阿毗达磨者说曰。能令各别自相法无间生义。是等无间缘相。各别自相法者。谓受想等心所。及心自相各别。俱时而生无容有二。有余师说。令相似法无间生义。是等无间缘相。已说体相。所以今当说。问何故名曰等无间缘。答此缘能引等无间法。是故名曰。等无间缘

问前后刹那。诸心所法。或多或少。云何名等。如欲界心所多非色界。色界心所多非无色界。善心所多非不善。不善心所多非无记。有漏心所多非无漏。如何可说此缘能引等无间法耶。答。依事等说。不依数等。故无有过。若一心中。有一想二受等者可不名等。以一心中受等心所随所应生。各唯有一。是故名等。问为心但与心。受等但与受等。作等无间缘。为不尔耶。相似相续沙门说曰。心但与心作等无间缘。受等亦尔。各与自类作等无间缘。彼不应作是说。所以者何。若必尔者。应善心还生善心。不善心还生不善心。无记心还生无记心。贪心还生贪心。恚心还生恚心。痴心还生痴心。如是便无究竟解脱。又诸心所。或少或多。少生多时。便应缘阙。多生少时。便应果减。如是则一心聚中。有从缘生。有不从缘生。有作缘者。有不作缘者。又无漏心聚。应无缘而生。应作是说。心与心亦与受等。受与受亦与心等。作等无间缘。余心所亦尔

问为心与心。作近等无间缘非受等。受等与受等。作近等无间缘非心等。为不尔耶。相似相续沙门说曰。心与心作近等无间缘非受等。受等与受等。作近等无间缘非心等。彼不应作是说。所以者何。前已说能开避义是等无间缘相。开避义中。无远近故。应作是说。前生心聚与后生心聚。作等无间缘。无有差别。如豆等聚

说一切有部发智大毗婆沙论卷第十阿毗达磨大毗婆沙论卷第十一

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中智纳息第二之三

问未来世中有等无间缘不。设尔何失。若有者未来诸法应次第住。修正加行应成无用。所以者何。若法在此无间而住。彼法从此无间必生。修正加行复何所用。又应无有伏诸烦恼生对治义。如是便无究竟解脱。见蕴所说复云何通。如说。若法与彼法作等无间。或时不与彼法作耶。答若时此法未至已生。若无者何故世第一法无间。唯生苦法智忍。不生乃至尽无生智。八分经说。复云何通。如说。如是补特伽罗作此业已。或十三劫。或十四劫。或乃至二十劫。不堕恶趣。又云何建立。顺现法受。顺次生受。顺后次受。三种业耶。答未来无有等无间缘。问若尔何故世第一法无间。唯生苦法智忍。不生乃至尽无生智耶。答此名数定。非事相定。所以者何。苦法智忍。在六地未知何地者。当生三根相应。未知何根相应者。当生有四行相。未知何行相。当生无量刹那。未知何刹那当生故。乃至住增上忍时。苦法智忍。唯于三事定。谓地定根定行相定。于二事犹不定。谓刹那不定。等无间缘不定。若住世第一法时。于五事皆定。复次不必要有等无间缘。诸法次第相续而起。所以者何。若法依属彼法。从彼法后无间得生。余则不尔。犹如外物虽无等无间缘。而相依属前后次第生起。如种芽茎枝条花果。依属彼者。彼无间生。余则不尔。如是内法在未来世。虽无等无间缘。而依属彼者彼无间生。余则不尔。苦法智忍。依属世第一法。苦法智等则不如是。是故世第一法无间。唯生苦法智忍。不生乃至尽无生智。复次未来法生。依现在法。若现在法和合。彼则得生。若不和合彼则不生。虽无是处为分别故。假使修道生缘先合。亦应先生。然无是事。唯苦法智忍。依世第一法和合而生。苦法智等依余和合。是故世第一法无间。唯生苦法智忍。不生乃至尽无生智。问八分经等。复云何通。有说。世尊依过去现在。比知未来。故作是说。谓世尊观过去现在。如是种类补特伽罗。造如是业。尔所劫中不堕恶趣。如是种类补特伽罗。造如是业现世受果。造如是业次生受果。造如是业后次受果。由此现见。如是种类补特伽罗。造如是业比知当来。尔所劫中不堕恶趣。如是种类补特伽罗。造如是业当现受果。造如是业当生受果。造如是业当后受果。有余师说。有情身中有如是相。是不相应行蕴所摄。世尊观彼。便知如是补特伽罗于未来世。尔所劫中不堕恶趣。亦知如是补特伽罗所造诸业。或当现受。或当生受。或当后受。评曰。不应作如是说。若作是说。便显世尊于未来事唯有比量智无现量智。此不应理。应作是说。佛知未来是现非比。谓佛智见明净猛利。未来诸佛。虽杂乱住无有次第。而能现知。如是种类补特伽罗。造如是业。于未来世尔所劫中不堕恶趣。如是种类补特伽罗。造如是业。或当现受。或当生受。或当后受。明了无谬。有余师说。未来亦有等无间缘。问若尔未来诸法应次第住。修正加行应成无用。又应无有伏诸烦恼生对治义。如是便无究竟解脱。答未来诸法虽有等无间缘性相定。而无前后次第定。谓心心所未已生位。有应从彼无间生法而无前后次第行列。至已生位。有应从彼无间生法。亦有前后次第行列。如多沙门。若杂乱住虽大小已定。而行列未定。若次第住大小亦定。行列亦定。此亦如是故无有失。修正加行非成无用。一心无间有二心故。谓未来世一心无间。有二心住一善二染。若现在世修正加行。则善心生染心不生。若现在世起邪加行。则染心生善心不生。如一种后二事应生一芽二灰。若芽缘和合则芽生灰不生。若灰缘和合则灰生芽不生。此亦如是。由此亦有伏诸烦恼生对治义。渐次便证究竟解脱。问见蕴所说复云何通。如说。若法与彼法作等无间。或时不与彼法作耶。答若时此法未至已生。答彼依前后次第定说。不依为缘性相定说。故不相违。评曰。应作是说。未来无有等无间缘。所以者何。等无间缘不杂乱住。未来世法杂乱住故。等无间缘次第而住。未来世法无次第故。等无间缘依开避义。立未来世法。无开避义故。复次若未来有等无间缘则。欲修善者应常作善。欲作恶者应常作恶。然今现见欲修善者。后便作恶。如天授等。欲作恶者后便作善。如指鬘等。故未来世决定无有等无间缘

问何故色法非等无间缘。答若法相应。有所依有行相。有警觉有所缘。彼法可立等无间缘。色法不尔故。非等无间缘。有说。等无间缘现前无乱。色法有乱故。非等无间缘。谓一刹那。起欲界色及色界色。或一刹那。起欲界色及不系色。或一刹那。起色界色及不系色。尊者世友说曰。一异熟色相续未灭。有长养色及等流色。复相续生多类俱生。故非等无间缘。大德说曰。以诸色法少无间生多。多无间生少故。非等无间缘。少无间生多者。如夏雨时。少云无间起无量云。遍覆虚空。从小树子生极高大诺瞿陀树。从小羯刺蓝生广大身色。多无间生少者。如大草聚烧为少灰。问若尔心所法亦多无间生少。少无间生多。应不建立等无间缘。多无间生少者。如从有寻有伺地。入无寻无伺地。少无间生多者。如从无寻无伺地入有寻有伺地。答此依同地前后数等说。不依异地故无有失。有说。此依同类前后数等说。不依异类故无有失。谓一心中。若一受等无间二受等生。二受等无间一受等生。可有此失。然无是事故与色别。以诸色法同类极微。于一聚中众多俱起。故不可立等无间缘。心心所法无如是事

问何故不相应行。非等无间缘。答若法相应。有所依有行相。有警觉有所缘。彼法可立等无间缘。不相应行不尔。故非等无间缘。有说。等无间缘现前无乱。不相应行现前有乱。故非等无间缘。谓一刹那。有起三界及不系。不相应行故。余随所应。如前广说。品类足论。有如是言。云何心等无间法。答若心等无间。余心心所法。已生正生。及无想定灭尽定。已生正生。是谓心等无间法。问彼何故不说无想异熟耶。有说。应说而不说者。当知此义有余。有说。二无心定。有加行有功用。勤劳而得故彼说之。无想异熟与此相违。故彼不说。有说。二无心定是善故说。无想异熟无覆无记故不说之。有说。若由心力无间引起。不杂乱者。可名为心等无间法。无想异熟是异熟因力所引起。任运而转。非入彼心势力所引。故不名心等无间法。问若尔异熟心心所法。亦异熟因力所引起。任运而转。应不名心等无间法。答自类相引有胜势力。不同彼故。俱是相应有所依等。说名自类。问何故二无心定。是心等无间法。而非心等无间缘耶。答彼由心加行功用。勤劳所引得故。名心等无间法。与心相违遮断心故。非心等无间缘。有说。彼由心势力所引起。故名心等无间法。不相应无所依。无行相无警觉。无所缘故。非心等无间缘。有说。彼由心势力得增长。有作用故。名心等无间法。损减心令不起作用故。非心等无间缘。问何故二无心定。前后相似无乱续生。而前非后等无间缘。答由入定心势力所引。不由前念力所引生。故前非后等无间缘。问若尔异熟心心所法。由异熟因势力引起。任运而转。前应非后等无间缘。答心心所法。是相应有所依。有行相有警觉。有所缘故。前念于后有胜势力。引发开避。故皆是后等无间缘。不相应行与此相违。不可为例。问入出无想灭尽定。心中间或经半劫一劫。云何可说等无间耶。答中间无余心为隔故。谓入出心相去虽远。中间更无余心所间。故后于前名等无间。犹如二人共涉远路。一前一后相远而行。有人问言。汝有伴不。彼答言有。次后而来。二人中间虽有禽兽。无人为隔故言次后。此亦如是。无心为隔名等无间。问若法是心等无间。亦是心无间耶。答应作四句。有法是心等无间。非心无间。谓除初刹那二无心定。及有心位心心所法。诸余相续。二无心定及出定心心所法。有法是心无间。非心等无间。谓初刹那二无心定。及有心位心心所法。生老住无常。有法是心等无间亦是心无间。谓初刹那二无心定。及有心位心心所法。有法非心等无间亦非心无间。谓除初刹那二无心定。及有心位心心所法。生老住无常。诸余相续二无心定。及出定心心法生老住无常。问若法是心等无间。亦是无心定无间耶。答应作四句。有法是心等无间。非无心定无间。谓初刹那二无心定。及有心位心心所法。有法是无心定无间。非心等无间。谓除初刹那。二无心定。及有心位心心所法。生老住无常诸余相续。二无心定。及出定心心所法。生老住无常。有法是心等无间。亦是无心定无间。谓除初刹那二无心定。及有心位心心所法。诸余相续二无心定。及出定心心所法。有法非心等无间。亦非无心定无间。谓初刹那二无心定。及有心位心心所法。生老住无常

有三种作意。谓自相作意。共相作意。胜解作意。自相作意者。思惟色是变碍相。受是领纳相。想是取像相。行是造作相。识是了别相。地是坚相。水是湿相。火是暖相。风是动相。如是等。共相作意者。如十六行相等。胜解作意者。如不净观持息念。无量解脱胜处遍处等。问此三种作意。几种无间。圣道现在前。圣道无间。几种现在前耶。有说。三种无间。圣道现在前。圣道无间。三种现在前。如是善通契经所说。不净观俱行。修念等觉支。依止厌依止离依止灭。回向于舍。此中俱声。显无间义。有说。二种无间。圣道现在前。除自相作意圣道无间。三种现在前。有说。唯共相作意无间。圣道现在前。圣道无间。三种现在前。问契经所说。当云何通。如说。不净观俱行修念等觉支。答依展转因故作是说。如子孙法转相生故。谓胜解作意。引起共相作意。共相作意。引起圣道。有说。共相作意无间。圣道现在前。圣道无间。共相作意现在前。问若尔依未至定。入正性离生者。出圣道时。可起欲界共相作意。若依上地。入正性离生者。出圣道时。彼欲界心既不得起。以极远故。复未得色界共相作意。彼虽已得顺决择分。而圣道后不复现前。彼以何等共相作意。出圣道耶。答彼于顺决择分中间。已修得如是行相。谓一切行非常。一切法非我。涅槃寂静等。今出圣道起彼作意。评曰。彼不应作是说。如前说者好。谓三种无间。圣道现在前。圣道无间三种现在前

复次欲界有三种作意。谓闻所成作意。思所成作意。生得作意。色界有三种作意。谓闻所成作意。修所成作意。生得作意。无色界有二种作意。谓修所成作意。生得作意。无漏有一种作意。谓修所成作意。此中欲界。唯思所成无间。圣道现在前。圣道无间。三种现在前。色界唯修所成无间。圣道现在前。圣道无间。二种现在前除生得。无色界唯修所成无间。圣道现在前。圣道无间。亦唯修所成现在前。问何故圣道无间。欲界生得现在前。非色无色界生得耶。答欲界生得猛利。色无色界。生得不猛利故。若依未至定。得阿罗汉果。彼或以欲界心出圣道。或以未至定心出圣道。若依无所有处。得阿罗汉果。彼或以无所有处心出圣道。或以非想非非想处心出圣道。若依余地。得阿罗汉果。彼唯以自地心出圣道

复次初静虑有三种。谓味相应净无漏。如是乃至无所有处。皆有三种。非想非非想处。但有二种。谓除无漏。此中味相应无间。二种现在前除无漏。净无间三种现在前。无漏无间二种现在前。除味相应净初静虑。复有四种。谓顺退分。顺住分。顺胜进分。顺决择分。如是乃至。无所有处。皆有四种。非想非非想处。唯有三种。除顺胜进分。此中顺退分无间。二种现在前。谓顺退分。及顺住分。顺住分无间。三种现在前。谓除顺决择分。顺胜进分无间。三种现在前。谓除顺退分。顺决择分无间。二种现在前。谓顺决择分。及顺胜进分。问若生第二第三第四静虑。起初静虑诸识身时。几心无间入几心出耶。答随所生地。若未离染者。三种心无间。彼诸识身现在前。彼诸识身无间。三种心现在前。谓善染污。无覆无记。若已离染者。二种心无间。彼诸识身现在前。彼诸识身无间。二种心现在前。谓除染污

有十二心欲界四。谓善不善。有覆无记。无覆无记。色无色界各三。谓前四中除不善。无漏有二。谓学无学。问此十二心。一一无间生几心。复从几心无间生耶。答欲界善心无间生九心。谓欲界四。色界二。善有覆无记。无色界一。有覆无记。及学无学心。此心复从八心无间生。谓欲界四。色界二善有覆无记。及学无学心。不善心无间生四心。谓欲界四心。此心复从十心无间生。谓欲界四。色无色界各三心。如不善心。欲界有覆无记心亦尔。欲界无覆无记心无间生七心。谓欲界四。色界二善有覆无记无色界一。有覆无记心。此心复从五心无间生。谓欲界四。及色界一善心。色界善心无间。生十一心。谓十二心中。除无色界无覆无记心。此心复从九心无间生。谓色界三。欲界二善无覆无记。无色界二。善有覆无记。及学无学心。色界有覆无记心无间生六心。谓色界三。欲界三除无覆无记心。此心复从八心无间生。谓色无色界各三。欲界二善无覆无记心。色界无覆无记心无间生六心。谓色界三。欲界二不善有覆无记。无色界一有覆无记心。此心复从三心无间生。谓色界三心。无色界善心无间生九心。谓无色界三。欲界二不善有覆无记。色界二善有覆无记。及学无学心。此心复从六心无间生。谓无色界三。色界一。善及学无学心。无色界有覆无记心无间生七心。谓无色界三。欲界二。不善有覆无记。色界二。善有覆无记心。此心复从七心无间生。谓无色界三。欲色界各二。善无覆无记心。无色界无覆无记心无间生六心。谓无色界三。欲界二。不善有覆无记。色界一。有覆无记心。此心复从三心无间生。谓无色界三心。学心无间生五心。谓三界善。及学无学心。此心复从四心无间生。谓三界善及学心。无学心无间生四心。谓三界善及无学心。此心复从五心无间生。谓三界善及学无学心有二十心。欲界八。谓加行善。生得善。不善有覆无记。威仪路工巧处异熟生通果心。色界六。谓前八心中。除不善及工巧处。无色界四。谓加行善。生得善。有覆无记。异熟生心。无漏二。谓学无学心。问此二十心。一一无间生几心。复从几心无间生耶。答欲界加行善心无间生十心。谓欲界七除通果心。色界一加行善。及学无学心。此心复从八心无间生。谓欲界四。除无覆无记四。色界二。加行善有覆无记及学无学心。有余师说。此心复从十一心无间生。谓前八及欲界。威仪路工巧处异熟生心。所以者何。以熟修习加行善心者。从自界威仪路工巧处。异熟生心无间。亦现在前。欲界生得善心无间生九心。谓欲界七除通果心。色无色界各一。有覆无记心。此心复从十一心无间生。谓欲界七。除通果心。色界二。加行善有覆无记。及学无学心。不善心无间生七心。谓欲界七除通果心。此心复从十四心无间生。欲界七。除通果心。色界四。除加行善及通果心。无色界三。除加行善心。如不善心。欲界有覆无记心亦尔。欲界威仪路心无间生八心。谓欲界六。除加行善及通果心。色无色界各一。有覆无记心。有余师说。此心无间生九心。谓前八及欲界加行善心。熟修习者能现前故。此心复从七心无间生。谓欲界七。除通果心。如欲界威仪路心。欲界异熟生心亦尔。工巧处心无间生六心。谓欲界六除加行善及通果心。有余师说。此心无间生七心。谓前六及欲界加行善心。熟修习者能现前故。此心复从七心无间生。谓欲界七。除通果心。欲界通果心无间生二心。谓欲界通果。及色界加行善心。此心复从二心无间生。谓欲界通果。及色界加行善心。色界加行善心无间生十二心。谓色界六。欲界三。加行善生得善通果。无色界一。加行善及学无学心。此心复从十心无间生。谓色界四。除威仪路异熟生心。欲界二。加行善通果心。无色界二。加行善有覆无记。及学无学心。色界生得善心。无间生八心谓色界五。除通果。欲界二。不善有覆无记。无色界一。有覆无记心。此心复从五心无间生。谓色界五。除通果心。色界有覆无记心。无间生九心谓色界五。除通果。欲界四。加行善。生得善。不善有覆无记心。此心复从十一心无间生。谓色界五。除通果。欲界三。生得善威仪路异熟生。无色界三。除加行善心。色界威仪路心无间生七心。谓色界四。除加行善通果心。欲界二。不善有覆无记。无色界一。有覆无记心。此心复从五心无间生。谓色界五。除通果心。如色界威仪路心。色界异熟生心亦尔。色界通果心无间生二心。谓色界加行善。及通果心。此心复从二心无间生。谓色界加行善。及通果心。无色界加行善心无间生七心。谓无色界四。色界一。加行善及学无学心。此心复从六心无间生。谓无色界三。除异熟生色界一。加行善及学无学心。无色界生得善心无间生七心。谓无色界四。欲界二。不善有覆无记。色界一。有覆无记心。此心复从四心无间生。谓无色界四心。无色界有覆无记心无间生八心。谓无色界四。欲界二。不善有覆无记。色界二。加行善有覆无记心。此心复从十心无间生。谓无色界四。欲色界各三。生得善威仪路异熟生心。无色界异熟生心无间生六心。谓无色界三。除加行善心。欲界二不善有覆无记。色界一。有覆无记心。此心复从四心无间生。谓无色界四心。学心无间生六心。谓欲界二。加行善生得善。色无色界各一。加行善及学无学心。此心复从四心无间生。谓三界各一。加行善及学心。无学心无间生五心。谓欲界二。加行善生得善。色无色界各一。加行善及无学心。此心复从五心无间生。谓三界各一。加行善及学无学心

补特伽罗既不可得。又无前心往后心。理何缘能忆本所作事。乃至广说。问何故作此论。答为止他宗显己义故。谓或有执补特伽罗。自体实有。如犊子部。彼作是说。我许有我。可能忆念本所作事。先自领纳今自忆故。若无我者。何缘能忆本所作事。或复有执。物性相隐。如说。诸法相隐。外道彼作是说。诸有为法有昼夜分。互相藏隐夜时昼入。夜中昼性。虽在而不显现。昼时夜入。昼中夜性。虽在而不显现。如是可能忆本所作。昼夜分中。有夜昼故。夜昼时所作。昼夜时能忆。若不尔者。何缘能忆本所作事。或复有执物性相变。如说。诸法相变。外道彼作是说。即羯刺蓝位变作。頞部昙位。乃至即坚固位变作。衰老位。如即青叶变作黄叶。如是可能忆本所作。以前后位体无异故。前位所作后位能忆。若不尔者。何缘能忆本所作事。或复有执。物性相往。如说。诸法相往。外道彼作是说。羯刺蓝往。入頞部昙位中。乃至坚固往。入衰老位中。如是可能忆本所作。以后位中有前法故。前位所作后位能忆。若不尔者。何缘能忆本所作事。问物性相变相往。外道二执何别。答相变外道执。即前位变作后位。后位中无前位。相往外道执。前位往后位既至后位其相不坏。即与后位俱时增长。有作是说相变外道执。后与前不一不异。相往外道执。后与前亦一亦异。或复有执。觉性是一。如说前后。一觉论者。彼作是说。前作事觉。后忆念觉。相用虽异其性是一。如是可能忆本所作。以前后位觉体一故。前位所作后位能忆。若不尔者。何缘能忆本所作事。或复有执。意界是常。如执意界是常论者。彼作是说。六识虽生灭而意界是常。如是可能忆本所作。六识所作事。意界能忆故。若不尔者。何缘能忆本所作事。或复有执。蕴有二种。一根本蕴。二作用蕴。前蕴是常。后蕴非常。彼作是说。根本作用二蕴虽别。而共和合成一有情。如是可能忆本所作。以作用蕴所作事。根本蕴能忆故。若不尔者。何缘能忆本所作事。或复有执。前心往告后心。我作是事汝可忆持。彼作是说。心细冥通。前有所作必告后知。如是可能忆本所作。若不尔者。何缘能忆本所作事。然过殑伽沙数诸佛及佛弟子虽不说有补特伽罗。亦不说有物性相隐相变相往。一觉性意界常。根本蕴异作用蕴异。前心往告后心。而说有能忆本所作。此义决定。微细甚深难可觉了。为欲显示如是决定。微细甚深。难可觉了。诸法性相。及止他宗不如理说。故作斯论。问此中应具说补特伽罗既不可得。亦无物性相隐相变相往。一觉性意界常。根本蕴异作用蕴异。前心往告后心理。何缘能忆本所作事。何故但说补特伽罗既不可得。又无前心往后心理。答此中说补特伽罗不可得者。别遮初一补特伽罗论。又无前心往后心理者。总遮后七论。有说。此中说补特伽罗既不可得者。遮第一补特伽罗论。又无前心往后心理者。遮第八前心往告后心论。既遮初后。应知。已遮中间六论。谓本论师略举初后。令诸弟子易受持故

说一切有部发智大毗婆沙论卷第十一阿毗达磨大毗婆沙论卷第十二

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中智纳息第二之四

补特伽罗既不可得。又无前心往后心理。何缘能忆本所作事。答有情于法由串习力。得如是同分智。随所更事能如是知。问前说无有补特伽罗。今何复言有情于法。答前依圣想名示现。今依世想名示现。前依圣言说示现。今依世言说示现。前依胜义。今依世俗。有说。为顺文故。若说法于法于义虽顺。于文不顺。若说有情。于法文义俱顺。依世俗理有有情故。有说为生解故。若说法于法弟子不了。谁能忆谁若说有情于法。弟子便了有情忆法。有情于法由串习力。得如是同分智者。谓有情智于所知法。决定串习。随欲自在前后相似。故名同分。随所更事能如是知者。谓随本所见。随本所受能如是忆。有说。此文应作是说。随所有事能如是知。谓随本所有体。所有相。所有我。所有物。所有性。所有分。能如是忆。有说。此文应作是说。随所住事能如是知。谓随本所住显色。随本所住形色等。能如是忆。为令此义得分明故。引世现喻。谓如有二造印者。能了自他所造印字。虽彼二人不往相问。汝云何造此字。亦不相答我如是造此字。而彼二人由串习力。得如是同分智。能了自他所造印字。有情亦尔。由串习力。乃至广说。此中能书者皆名造印者。如彼二人虽不相问亦不相答。而由串习力得如是同分智。能了自他所造印字。乃至海外书来亦能读知。有情亦尔。虽无真实补特伽罗。亦无前心往后心理。而由串习力得如是同分智。随所更事能如是知。复令此义重分明故。引第二喻。又如有二知他心者互相知心。虽彼二人不往相问。汝云何知我心。亦不相答。我如是知汝心。而彼二人由串习力。得如是同分智互相知心。有情亦尔。由串习力。乃至广说。此中知他心者。谓得他心通者。如彼二人虽不相问亦不相答。而由串习力。得如是同分智互相知心。乃至百踰缮那外亦相知心。有情亦尔。虽无真实补特伽罗。乃至广说。问若异心所更异心能忆者。云何不天授所更祠授能忆。祠授所更天授能忆耶。答彼相续异故。前心后心相续无异。不应为难。有说。彼心相望无因义故。前心能与后心为因。不应为难。有说。彼二身心不相属故。前后身心既相继属。故先所更后能记忆。问若心相属即能忆者。何不见异牛而忆是前牛。答若于曾受。今见相似则能记忆。若虽曾受。今见不相似便不能忆。日初分所更日后分能忆。日后分所更日初分能忆。前后所见身相似故

复次一切心心所法。于所缘定安住所缘。此于所问是胜义根本。答所以者何。如见蕴说。若法与彼法作所缘。或时不与彼法作耶。答无时非所缘。以心心所于所缘定。安住所缘不可移转。是故能忆本所作事。谓于一所缘有无量心心所聚。转此一所缘如以此理趣以此性类以此法式。与一心心所聚作所缘事。与余无量心心所聚。作所缘事亦尔。如一心心所聚。以此理趣以此性类以此法式。领受此所缘。余无量心心所聚。领受此所缘亦尔。譬如一人而有百子。此一人如于一子作父事。于余子亦尔。如一子于父作子事。余子于父亦尔。此中眼识及相应法于色所缘定。乃至意识及相应法。于一切法所缘定。此色与眼识及相应法。为所缘者。无时非所缘。乃至此法与意识及相应法。为所缘者。无时非所缘。以一切心心所法。各能领受自所缘故。由此无有余心聚所更。余心聚能忆。问云何心心所法。于所缘定为于处定。为于青等定。为于刹那定耶。此中有说。唯于处定。所以者何。勿有无量心心所法。住不生法中故。问云何于处定。答眼识及相应法于色处定。乃至身识及相应法于触处定。意识及相应法于法处等定。如一眼识。若遇青色和合现前则缘青起。若遇黄等和合现前则缘黄等起。如是余识于自所缘亦唯处定。彼不应作是说。所以者何。若尔者。应一觉有多了性。一法多体不应道理。识身论说复云何通。如说。过去眼识唯缘过去色。非未来现在。有余欲避知是过失。说心心所法于所缘处定。亦于青等定非于刹那定。所以者何。勿有无量心心所法。住不生法中故。问云何亦于青等定耶。答缘青等心心所其体各异。若遇青色和合现前则生。缘青心心所法。若遇黄等和合现前则生。缘黄等心心所法。彼亦不应作如是说。所以者何青有多种。谓青根青茎青枝青叶青花青果。黄等亦尔。应缘根等觉即是缘茎等觉。若尔一觉有多了性。一法多体不应道理。亦与识身论所说相违如前说。如是说者心心所法于三事定。问若尔则应无量心心所法。住不生法中。答斯有何过。未来世宽无容处耶。然彼本来已有住处。故不应难。问心心所法。如于所缘定。于所依亦定不。设尔何失。若于所依亦定者。何故此中但说于所缘定。不说于所依定耶。品类足说复云何通。如说。云何有俱有法。答一切有漏法。及有漏法俱生无漏法。若于所依不定者。何故于所缘定。于所依不定耶。答于所依亦定。然心心所法。在未来世与所依远。现在则俱。过去复远。有说。在未来世与所依远。现在过去与所依俱。有说。三世皆与所依俱。问若尔。何故此中不说。答此中但欲说忆本所作。所忆者。是所缘非所依故。问品类足说复云何通。答彼文应作是说。云何有俱有法。答一切有为法。而不作是说者。彼文显示有用圣道。不说无用故不相违。有说彼文显示圣道。依他力得依他力起。故但说与有漏法俱生者。问若心心所法。于所缘定于所依亦定者。彼于何位取所缘耶为于生时为于灭时。设尔何失。若生时者生时在未来。云何未来法能有所作。若灭时者。灭时诸法衰退散坏。云何此位能取所缘。答应言灭时。问云何衰退散坏之法能取所缘。答诸有为法性羸劣故。不自依故。依他转故。无作用故。不自在故。随于何位。若遇所依。所缘和合即于彼位。能取所缘。唯于灭时有此和合。有说生时是未来世。未来诸法无作用故。不能取所缘灭时是现在世。现在诸法有作用故能取所缘。若灭时不取所缘者。则心心所法毕竟不能取于所缘。勿有斯过。故于灭时能取所缘

又以受意为因力强。念便不忘。应知此中前生心聚以意声说。后生心聚以念声说。然受意有二种。一受行相意。二受所缘意。且如于增上忍有二心。受彼行相不受彼所缘。谓苦类智忍苦类智相应有二心。受彼所缘不受彼行相。谓集法智忍集法智相应有三心。受彼行相亦受彼所缘。谓世第一法苦法智忍苦法智相应。余心不受彼行相。亦不受彼所缘谓余忍智相应。如于增上忍于余心。随应广说亦尔。受行相所更受所缘能忆。受所缘所更受行相能忆。复有二种意。一染污。二不染污。一一所更二种。能忆复有三种意。谓善不善无记。一一所更三种能忆。复有四种意。谓善不善有覆无记无覆无记。一一所更四种能忆。复有四种意。谓彼因彼等无间彼所缘彼增上。一一所更四种能忆。复有五种意。谓见苦所断乃至修所断。此中见苦所断所更五种能忆。见集修所断所更亦尔。见灭所断所更四种能忆。除见道所断。见道所断所更四种能忆。除见灭所断。复有五种意。谓善不善有覆无记。如理所引无覆无记。不如理所引无覆无记。此中有说。善所更二种能忆。谓善如理所引无覆无记。如理所引无覆无记所更亦尔。不善所更三种能忆。谓不善有覆无记。不如理所引无覆无记有覆无记。不如理所引无覆无记所更亦尔。如是说者。一一所更五种能忆。复有六种意。谓眼识乃至意识。五识所更意识能忆。意识所更六识能忆。复有十二种意。欲界有四。谓善不善有覆无记无覆无记。色界有三。谓前四除不善。无色界亦尔。无漏有二。谓学无学。欲界善所更十二种能忆。不善色界善所更亦尔。欲界有覆无记所更八种能忆。谓除色界有覆无记无色界三。欲界无覆无记所更亦尔。色界有覆无记所更十种能忆。除欲界二无记。无色界善所更亦尔。色界无覆无记所更十种能忆。除无色界二无记。无色界有覆无记所更九种能忆。除欲界二无记及色界无覆无记。无色界无覆无记所更亦尔。学所更十一种能忆。除欲界有覆无记。无学所更若退法者如学说。若不退法者七种能忆。除学及四染污。由前受意为因力强。于彼所缘引生后念。不忘者。谓心不狂乱非苦所逼。尊者世友说曰。由三因缘忆本所作。一善取前相故。二同分相续现行故。三不失念故。由此虽无补特伽罗。亦无前心往后心理。而能忆念本所作事

何缘有情忘而复忆。答有情同分相续转时。于法能起相属智见。此中忘者是失念义。非不念义。所以者何。无有少法名不念故。同分有三种。谓加行同分所缘同分。随顺同分。加行同分者。如有先诵素怛缆藏。中间忘失。后因如前所作加行还得记忆。先诵毗奈耶阿毗达磨藏亦尔。如是先起不净观。中间忘失。后因如前所作加行还得记忆。先起持息念界方便亦尔。曾闻有婆罗门子。先诵得四吠陀书。中间忘失。复温诵之尽其方便不能通利。便往师所具述因缘。师即问言。汝先诵时以何加行。答言。本时手绳口诵。师言。汝当如本加行。彼随师教一切皆忆。所缘同分者。如有先见如是园林泉池山谷经行处等。中间忘失。后见相似园林等时一切皆忆。随顺同分者。如得随顺饮食衣服卧具房舍说法人等。则能忆念先所更事。曾闻有一苾刍。先诵得四阿笈摩。中间忘失。复温诵之尽其方便不能通利。便往尊者阿难陀所。问其因缘。尊者答言。汝今可往以油涂身温室洗浴。求诸随顺衣服饮食卧具房舍说法人等。苾刍依教悉还通利。如是同分相续转时。于法能起相属智见。问起谁相属。答三种同分有异。诵言于法能起连续智见。即是起长时流注相续智见义。复有诵云。于法能起次第智见。即是起彼彼周遍行列智见义。复有诵言。于法能起无碍智见。即是起无滞无著无断智见义。复有诵言。于法能起无障智见。即是起离障伏所治胜怨敌智见义。又以受意为因力强念便不忘。应知此中前生心聚以意声说。后生心聚以念声说。受意言如前释。由前受意为因力强。于彼所缘。引生后念。中间虽忘而后复忆。不忘言如前释

何缘有情忆而复忘。答有情异分相续转时。于法不起相属智见。此中忘者。是失念义。广说如前。异分有三种。谓加行异分。所缘异分。随顺异分。加行异分者。如有先诵素怛缆藏。中间忘失。舍之复诵毗奈耶。或阿毗达磨藏。后皆不忆。先诵毗奈耶阿毗达磨藏亦尔。如是先起不净观。中间忘失。舍之复起持息念。或界方便后皆不忆。先起持息念界方便亦尔。所缘异分者。如有先见如是园林泉池山谷经行处等。中间忘失。后更不见彼相似相。于前所更不复能忆。随顺异分者。如有不得随顺饮食衣服等事。于前所更不能复忆。如是异分相续转时。于法不起相属智见。问不起谁相属。答三种同分此中亦有四种异诵。与前相违应广说。又以受意为因力劣念便忘失。应知此中前生心聚以意声说。后生心聚以念声说。受意言如前释。由前受意为因力劣。于彼所缘不生后念。中间虽忆而后复忘。忘者谓心狂乱苦受所逼。尊者世友说曰。由三因缘念便忘失。一不善取前相故。二异分相续现行故。三失念故。复作是说。由八因缘念便忘失。一者生时生苦所逼故念便忘失。二者死时死苦所逼故。三者余语多现行故。四者根钝依余智故。五者生非爱趣苦受所逼故。六者五根于境驰散不息多放逸故。七者重烦恼障数现行故。八者不数修定心散乱故。念便忘失

问何等智所更念有忘失。闻所成耶。思所成耶。修所成耶。生得等耶。有说。闻思所成及生得等所更念有忘失。非修所成。定力所持无忘失故。有说。修所成所更亦有忘失。身羸弱故。谓有得定身羸弱者。心亦羸弱故。彼所更亦有忘失。问何处有忘念耶。答在欲界。非色无色界。于五趣中皆有忘念。有说地狱无有忘念。以恒忘故。问何等补特伽罗有忘念耶。答异生圣者皆有忘念。圣者中预流一来不还阿罗汉独觉。皆有忘念。唯除世尊。以佛成就无忘失法故。云何知然。答经为量故。如说。舍利子假使诸苾刍众。以床座舁我行经百年。欲令如来无上慧辩。有少退失无有是处。故知佛具无忘失法

如象迹喻。契经中说。舍利子言。若内意处不坏外法处。现前及能生作意正起。尔时意识生。问意云何坏。答有三种坏。一暂时坏。二尽众同分坏。三究竟坏。暂时坏者。谓善心无间。不善无记心现前。尔时名为善心暂坏。乃至无记心无间。善不善心现前。尔时名为无记心暂坏。如是欲界心无间。色界不系心现前。尔时名为欲界心暂坏。乃至不系心无间三界心现前。尔时名为不系心暂坏。若入无想灭尽等至。尔时名为一切心暂坏。尽众同分坏者。谓断善根者。善心有尽众同分坏。离欲染异生不善心。有尽众同分坏如是等。究竟坏者。谓苦智已生集智未生。三界见苦所断心究竟坏。乃至灭智已生道智未生。三界见苦集灭所断心究竟坏。预流者三界见所断心究竟坏。不退法一来者。三界见所断及欲界修所断六品心究竟坏。不退法不还者。三界见所断及欲界修所断染污心究竟坏。不退法阿罗汉。三界见修所断染污心究竟坏。不退法异生离欲染者。欲界染污心究竟坏。乃至离无所有处染者。八地染污心究竟坏。尊者世友说曰。意若遇和合缘不名为坏。若不遇和合缘则名为坏。复作是说。意若不为相违因所障不名为坏。若为相违因所障则名为坏

何缘祭祀饿鬼则到非余趣耶。乃至广说。问何故作此论。答为释经故。如契经说。生闻婆罗门来诣佛所。白佛言乔答摩。我有亲里命过欲施其食。彼为得我食不。世尊告言。此事不定。所以者何。诸有情类有五趣别。若汝亲里生地狱中。食地狱食。以自存活。彼不能受汝食。生傍生趣天趣人趣。亦复如是。若汝亲里生鬼趣中。则能受汝所施饮食。婆罗门言。若我亲里不生鬼趣。所施饮食谁当受之。佛语彼言。饿鬼趣中。无汝亲里无有是处。乃至广说。彼经虽作是说。而不说何缘祭祀饿鬼则到非余。彼经是此论所依根本。彼所不说者。今应说之。故作斯论。问彼婆罗门。何故不问佛何缘祭祀饿鬼则到非余。答有二缘故。谓彼或是利根或是钝根。若是利根自能解了不须问佛。若是钝根不能生疑故不问佛。问何故世尊。不为彼说唯施饿鬼则到因缘。答亦二缘故。谓彼或是利根或是钝根。若是利根自能解了不须佛说。若是钝根非法器故。佛不为说

何缘祭祀饿鬼则到非余趣耶。答彼趣法尔得如是处。事生我分。是故祭祀则到非余。此中问意此趣为以下贱故到。为以高贵故到。设尔何失。若以下贱故到者。则祭祀地狱傍生彼亦应到。若以高贵故到者。则祭祀人天彼亦应到。此中答意不以下贱故到。亦不以高贵故到。然由二缘。一由彼趣法尔故。二由业异熟故。于中先显示彼趣法尔。谓彼鬼趣法尔得如是处。事生我分。是故祭祀则到非余。欲令此义得分明故。引世现喻。如鹅雁孔雀鹦鹉舍利命命鸟等。虽如意自在飞翔虚空。而神力威德不大于人。然彼趣法尔得如是处。事生我分能飞翔虚空。鬼趣亦尔。由法尔力祭祀则到。余趣不尔。谓如傍生趣中鹅雁孔雀等。由趣法尔力能飞翔虚空久住。游戏人离神足咒术药草。欲住虚空去地四指。经须臾顷犹无能者。然彼神力威德不胜于人。饿鬼亦尔。由趣法尔力。祭祀则到非余。欲令前义重分明故。引第二喻。又如一类那落迦。能忆宿住亦知他心。一类傍生。一类饿鬼。能忆宿住亦知他心。及起烟焰。兴云致雨作寒热等。虽能作是事。而神力威德不大于人。然彼趣法尔得如是处。事生我分能作是事。鬼趣亦尔。由法尔力祭祀则到。余趣不尔。此中一类那落迦。能忆宿住者。如契经说。地狱众生作如是念。大德沙门婆罗门等。观欲将来能作过患。是大怖畏。恒为我等说断欲法。我等虽闻而不能断。今因欲故受大苦恼。又作是念。我等昔于净行沙门婆罗门等作邪恶行。由彼为因今受此苦。问彼于何时能作是念。答于初生时非中后时。所以者何。彼初生时未受苦痛。能作是念。若受苦痛。今生所受尚不能忆。况先所受。问彼住何心能作是念。善耶。染污耶。无覆无记耶。答三种皆能。问何无覆无记。答威仪路非工巧处。彼无工巧事故。非异熟生。彼异熟心是五识故。问彼如是念。为在意地为五识身。答在意地非五识身。五识中无此分别故。问彼如是念为忆几生。答彼唯忆一生。谓所从没来生此者。有说。能忆多生乃至五百。亦知他心者。谓地狱中有生处得知。能知他心。然无事可显。问彼于何时能知他心。答唯初生时。所以者何。若受苦痛心便闷乱故。问彼住何心知他心耶。答住三性心皆能知。问何无覆无记。答威仪路非工巧处。异熟生如前说。问为在意地为五识身。答在意地非五识身。以五识身缘色法故。一类傍生能忆宿住者。如契经说

婆罗门告饷佉狗言。若是我父刀提耶者。可升此座。彼便升之。复语之言。若是我父刀提耶者。可食此饭。彼便食之。又复告言。若是我父刀提耶者。汝命终时所藏财宝。今可示我。彼便示之。问何时能忆宿住事耶。答初中后时并皆能忆。问住何心忆。答住三性心。问何无覆无记。答威仪路。工巧处。异熟生。皆能忆。问此在何识。答在意地非五识身问能忆几生。有说。唯能忆一生。谓所从没来生此者。有说。能忆多生乃至五百。云何知然。传说。有一女人置儿一处。有缘他行。须臾有狼负其儿去。众人捕逐而语之言。汝今何缘负他儿去。狼言。此女五百生来常杀我子。我亦于其五百生中常杀其子。若彼能舍旧怨嫌心。我亦舍之。女言。已舍。狼观此女口虽言舍而心不舍。即便断其子命而去。亦知他心者。谓傍生趣亦知他心。即如彼狼知女心事。问何时能知。答三时皆知。问住何心知。答住三性心。问何无覆无记。答威仪路工巧处异熟生皆能知。问此在何识。答在意地非五识。一类饿鬼能忆宿住者。如伽他说

  我昔集资财　　以法或非法
  他今受富乐　　我独受贫苦

问何时能忆。答三时皆能。问住何心忆。答住三性心。问何无覆无记。答三种如前说。问此在何识。答在意地非五识身。问能忆几生。答乃至五百。云何知然。传闻。有一女人为鬼所执。羸困欲死。咒师语言。汝今何故恼他女人。鬼言。此女五百生来常害我命。我亦于其五百生中常害彼命。彼若能舍旧怨嫌心。我亦舍之。女言。已舍。鬼观此女口虽言舍而心不舍。便害而去。亦知他心者。即如彼鬼知女心事。问何时能知。答三时皆能。问住何心知。答住三性心。问何无覆无记。答三种如前说。问此在何识。答在意地非五识。及起烟焰兴云致雨。作寒热等者。此唯傍生趣能非余趣。傍生趣中唯龙能。非余类。问若尔。经说当云何通。如说。有天能兴云。有天能降雨。有天作寒热。有天起风雷。答应知彼经说龙为天。如余经说

佛告阿难。汝看天雨为不雨耶。彼亦于龙以天声说。问起烟焰等。为多龙作。为一龙耶。答一龙亦能。问若尔何故经作是说。有天能兴云有天能致雨。乃至广说。答随别所乐故作是说。谓或有龙。唯乐兴云。或复有龙。唯乐致雨。余亦如是。此中烟焰云雨等事。是龙加行所引发故。唯是彼龙近士用果。若从龙宫所流出水。非彼加行所引发故。是一切有情共增上果。如地狱等由趣法尔力。虽有如上所说事。而神力威德不大于人。鬼趣亦尔。由趣法尔力。祭祀则到非余。复有说者。五趣皆有法尔胜事。谓地狱趣异熟色等断已还续。余趣不尔。傍生趣中有能飞空兴云雨等。饿鬼趣中祭祀则到。人趣能受善戒恶戒。修胜品善。勇猛强记智力深远。天趣中欲天。随其所须应念则至。色无色天有胜生胜定。复有说者。诸方亦有法尔胜事谓支那国虽奴仆等。皆衣缯绢。余方贵胜所不能得。印度等国乃至贫贱皆衣[疊*毛]衣。余方贵人亦不能得。迦湿弥罗国中秋时牛颈系郁金花鬘余方胜人所不能得。北方贫人饮葡萄酒余方富者亦不能得。如诸方有法尔胜事。饿鬼亦尔祭祀则到。有说。诸趣法尔有异。谓四趣中一一皆有生处得智。唯人趣无三恶趣有。如前广说。天趣有能忆宿住者。如伽他说

  我施誓多林　　蒙大法王住
  贤圣僧受用　　故我心欢喜

彼亦知他心。而无现事可说何时忆知等。如傍生鬼随应广说。问此生处得智为忆知几趣。有说各唯自忆知。有说地狱唯忆知地狱。傍生忆知二趣。饿鬼忆知三趣。天忆知五趣。问若傍生不知天者。施设论说当云何通。如说。善住龙王等知帝释心念。乃至广说。答此是比知非现知故无相违过。如是说者此事不定。如狼及鬼忆知人故。问何故人趣无此智耶。答非田非器。乃至广说。复次人趣有瞻相智。睹言相智。本性念生智。妙愿智等。覆蔽彼故。如生处得智。余趣皆有唯人趣无。如是祭祀。唯鬼趣到。余趣不尔。如是已显示由趣法尔力。祭祀饿鬼则到非余。今当显示由业异熟。复次有人长夜起如是欲。如是爱乐我当娶妇。为儿娶妇。为孙娶妇。令生子孙绍继不绝。我命终已若生鬼趣。彼念我故当祭祀我。由彼长夜有此欲乐。是故祭祀则到非余。谓彼由起如是欲乐。引发诸业生鬼趣中。是故祭祀则到非余。如诸聚落城邑中人。或为子孙不断绝故。或为财产转增盛故。或为富名久流传故。以法非法集诸财宝牛羊等物。于己亲属尚不欲与。况施他人。彼由悭贪缠缚心故。舍人同分生鬼趣中。于自舍宅水窦厕溷不净处住。彼有亲属追恋生苦。作是念言。彼集财产自不受用。亦不施人。今生何所。遂集亲里。请诸沙门婆罗门等。设大施会。愿此资彼舍苦受乐。尔时饿鬼于自住处。见如是事。于自亲里生眷属想。于其财物生己有想。即时欢喜。于福田所。生信敬心。于其所作起随喜心。便离重苦。由此因缘祭祀则到。问若尔何故。不名他作业他受果耶。答不尔。彼于尔时。由生敬信随喜心故。见施功德悭贪过失。由此增长舍相应思。成顺现受业得现法果故。尊者世友说曰。今所受果是先业所引。先业有障以今业除之故。无他作业他受果失。谓彼饿鬼先世已造感饮食业。但由悭贪障蔽心故。于所饮食起倒想见不得受用。然彼饿鬼有二种。一乐净。二乐不净。彼乐净者。以悭贪故河见非河。水见为血。所有饮食见为不净。乐不净者。河见干枯。水见无水。满饮食器悉见为空。若彼亲里为设施会。彼便信敬起随喜心。见施功德。悭贪过失舍相应思。得增长故除想见倒。彼乐净者。见河是河。见水澄清。于诸饮食皆见净妙。乐不净者。见河盈溢见水是水。见饮食器悉皆盈满。故彼亲里祭祀则到。有作是说。彼先世亦有感饮食业。但由悭贪所覆蔽故。今时感得怯劣身心。诸饮食处必有大力鬼神守护。彼怯劣故不能得往。设复得往亦不敢食。若彼亲里为设施会。广说乃至舍相应思。得增长故。令彼身心转得强胜。由此能至有饮食处。食其饮食。由此因缘祭祀则到。是故无有他作业他受果失。大德说曰。彼先虽造感饮食业。以微劣故未能与果。若彼亲里为设施会。广说乃至舍相应思得增长故。先所作业便能与果。故彼亲里祭祀则到。由此无有他作业他受果失。问舍相应思得增长已。为但感资具为亦感得胜身心耶。答二种俱得。胜身心者。舍劣色香味触。得胜色香味触。舍无威德得有威德。感资具者。谓得饮食衣服园林宅舍等事。问若生余趣亲里为其修福业者。彼亦得不。答若彼亦能生于信。敬随喜之心。令舍俱思得增长者。亦得其福。问若尔。此中何故不说。答应说而不说者。当知此义有余。有说。此中从多分说。谓饿鬼中多有是事。余趣不尔故。有说。鬼趣多有。如是业故。谓造此业者。多生鬼趣故。有说鬼趣于人常希求故。有说。鬼趣饥渴所逼。于一切处常有希望。是故偏说。此中应辨五趣义。如定蕴当广分别

说一切有部发智大毗婆沙论卷第十二阿毗达磨大毗婆沙论卷第十三

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中智纳息第二之五

当言一眼见色。二眼见色耶。乃至广说。问何故作此论。答为止他宗显己义故。谓或有执眼识见色。如尊者法救。或复有执眼识相应慧见色。如尊者妙音。或复有执和合见色。如譬喻者。或复有执一眼见色。如犊子部。为止如是他宗异执。显示己宗二眼见色。故作斯论。所以者何。若眼识见色者。识应有见相。然识无见相故不应理。若眼识相应慧见色者。耳识相应慧亦应闻声。然慧无闻相故不应理。若和合见色者。应一切时见色。以无时不和合故亦不应理若一眼见色非二眼者。身诸分亦应不俱时。觉触如身根两臂相去虽远而得俱时觉触生一身识。两眼亦尔。相去虽远。何妨俱时见色生一眼识。问若眼见色者。余识俱时何故不见。又无识时亦应见色。答眼有二种。一者识合。二者识空。识合者能见识空者不能见。故无有失。复次所以作此论者。欲令疑者得决定故。谓诸有情两眼相去。或半麻一麻半。麦一麦半。指一指半。搩手一搩手半。弓一弓半。俱卢舍一俱卢舍半。踰缮那一踰缮那。或复乃至百踰缮那。如大海中有大身众生。或长百踰缮那。乃至或长二千一百踰缮那。如曷逻呼。阿素洛王身量极大。又如天趣色究竟身。一万六千踰缮那量。此等二眼相去甚远。或有生疑。云何眼识依之而转。为二眼识。俱时各依一眼生耶。为一眼识。依一眼生已。复依第二眼转耶。为一眼识分为二分。于二眼处各半生耶。为一眼识。如横一物通二眼耶。若二眼识俱时各依一眼生者。应一有情二心俱转此不应理。若一眼识依一眼生已。复依第二眼转者。则应一法二刹那住然无是事。若一眼识分为二分。于二眼处各半生者。则应一法体有二分。然一切法体无细分。若一眼识如横一物通二眼者。则应一识亦是眼识亦是身识。二眼中间依身根故。然五识身所依各异所缘各异。不应一识二依二缘。欲令此疑得决定故。显虽无有二眼识俱。乃至无一识横通二眼。然其非不依于二眼一眼识生。二眼虽隔百踰缮那亦无有过。如是理趣微细甚深难可觉了。今欲显斯甚深理趣故作斯论

当言一眼见色二眼见色耶。答应言二眼见色。问云何二眼相去甚远。一识依之令俱见色。答俱是眼识所依根故。设有百眼一一相去百踰缮那。亦可依之生于一识。令俱时见。如迦遮器有百小轮。一面对之百面像现。如是一识依多眼生。令俱时见其义亦尔。应知此中眼见色者。遮法救等三种异执。二眼见者。遮犊子部。一眼见色。所以者何。若合一眼起不净识。开二眼时起净识故。设合一眼起如是识。开二眼时亦起此识。则不应言二眼见色。然合一眼起不净识。开二眼时便起净识。是故应言二眼见色。非但立宗义即成立。故复问答。显示此因起净识者。谓于多境明白显了。与此相违名不净识。如合覆损破坏亦尔。覆谓以手以衣以叶以余物覆。损谓垢烟尘等所损。破谓诸膜诸翳所破。坏谓枯烂挑出自脱虫食等坏。覆等如合起不净识。与此相违便起净识。此随所依说净不净依世俗理。若依胜义。善识名净染名不净。由此对眼应作四句。有眼净识不净。谓依具眼起染眼识。有识净眼不净。谓依不具眼起善眼识。有眼识俱净。谓依具眼起善眼识。有眼识俱不净。谓依不具眼。起染眼识。如眼见色耳闻声鼻嗅香亦尔。俱有二处与眼同故。问何故眼耳鼻各有二处。而舌身唯有一耶。答诸色根处为庄严身。若有二舌是鄙陋事。世便嗤笑。云何此人。而有二舌如似毒蛇。若有二身亦是鄙陋。世所嗤笑。云何一人。而有二身如两指并。问眼耳鼻处何故唯二不增不减。胁尊者言。一切生疑故不应责。谓若增减亦复生疑。云何此三各唯尔所。然各二处不违法性。有说。根处为庄严身。若减若增身便丑陋。有说。色根为生净识。若当三识依二处生则明不乱。增便识乱减则不明。有说。色根为取自境各唯有二。取境事足减则不明增便无用。问何故二眼二耳二鼻。合立一界一处一根。答作用一故。谓虽有二处而共发一识共取一境。如身众分处所虽多作用同故。但立一界一处一根此亦如是

眼有二种谓长养异熟生。无别等流不可得故。问颇唯有长养眼无异熟生。或唯有异熟生眼无长养耶。答无异熟生眼离长养眼。如人重人如墙重墙长养。防护异熟亦尔。然有长养眼离异熟生眼如从无眼得天眼者。问为长养眼见色多为异熟生耶。答长养眼见色多非异熟生。以天眼根是长养故。然约时分二眼胜劣应作四句。有长养眼胜非异熟生。如幼年时尔时异熟相续小故。有异熟生眼胜非长养眼。如老病时尔时长养相续小故。有二眼俱胜如盛年时。有二眼俱不胜谓除前位。约有情相续二眼胜劣亦应作四句。有长养眼胜非异熟生。如有富贵者。异熟生眼劣资缘多故长养眼胜。有异熟生眼胜非长养眼。如有贫贱者。异熟生眼胜乏资缘故长养眼劣。有二眼俱胜。如有富贵者异熟生眼胜。资缘多故长养亦胜。有二眼俱不胜。如有贫贱者。异熟生眼劣。乏资缘故长养亦劣。又长养眼有二种。谓善法所长养。不善法所长养。问为善法所长养眼见色胜。为不善法所长养眼胜耶。答善法所长养眼见色胜。如修得天眼是善法所长养故。异熟生眼亦有二种。谓善业异熟不善业异熟。问为善业异熟眼见色胜。为不善业异熟眼见色胜耶。答善业异熟眼见色胜。如菩萨转轮王等眼。是善业异熟故。若约相续。或有不善业异熟眼见色胜。非善业异熟眼。如龙王等眼见色胜人。如眼耳鼻舌身亦尔。意有三种谓异熟生等流刹那。刹那者谓苦法智忍相应。色有三种。谓异熟生长养等流。如色香味触亦尔。声有二种。谓长养等流。无异熟生有间断故。法有四种。谓异熟生等流刹那及实事。实事者谓诸无为

问眼根极微云何而住。为傍布住为前后住耶。设尔何失。若傍布住者云何风吹不散。若前后住者云何前不障后耶。有作是说。黑瞳子上傍布而住。对外色境如胡荽花。或如满器水上散糗。问若尔。何缘风吹不散。答净色覆持故吹不散。有余师说。黑瞳子中前后而住。问若尔。何故前不障后。答体清净故不相障碍。谓如是类所造净色。虽多积集而不相障。如秋池水以澄净故。细针堕中而亦可见。耳根极微住耳孔中。鼻根极微住鼻孔中。如是三根绕头而住如冠花鬘。舌根极微住在舌上犹如半月。然于其中如毛端量无有舌根。身根极微随身内外次第而住。复有余师。以喻显示诸根极微次第住相。眼根极微黑瞳子上如药杵头。耳根极微住耳孔中犹如灯器。鼻根极微住鼻孔中犹如人爪。舌根极微住在舌上犹如剃刀。身根极微随身而住。犹如戟槊。女根极微住女形中犹如鼓[壴*桑]。男根极微住男形上犹如指环。佛于经中。亦以此喻说诸根相。眼根极微。有时一切是同分。有时一切是彼同分。有时一分是同分一分是彼同分。如眼根极微。耳鼻舌根极微亦尔。身根极微。有时一切是彼同分。有时一分是同分一分是彼同分。必无一切是同分时。问若举身入冷水池中。或镬汤中。若在地狱山所硙磨身如烂叶。或十三种猛焰缠身。尔时岂非一切同分。答尔时亦有彼同分者。假使一切身根极微。皆生身识身便散坏。以五识身皆依积聚。缘积聚故。问眼等六根几能取至境。几能取不至境耶。答至有二种。一为境至。二无间至。若依为境至说。则六根皆取至境。若依无间至说。则三取至境。谓鼻舌身。三取不至境。谓眼耳意。问若尔。何故耳闻近声如耳门边声。而眼不见近色如药杵头色耶。尊者世友说曰。虽俱取不至境。而根法尔有能取近境。有不能取近境。故不应难。有说。若声逼近耳根。如药杵头近眼根者亦不能闻。耳门边声去耳尚远故得闻之。以耳根极微在耳孔中故。大德说曰。眼因明故能见色。色若逼近则碍于明故不能见。耳因空故能闻声。声虽逼近而不碍空故能闻之。由此而说眼因明增故见色。耳因空增故闻声。鼻因风增故嗅香。舌因水增故尝味。身因地增故觉触。意因作意增故能了法。问何故三根能取至境。三根不能取至境耶。答以眼识依自界。缘自界他界耳识亦尔。意识依自界他界。缘自界他界。余三识依自界缘自界故。复次眼识依同分缘同分彼同分。耳识亦尔。余四识依同分缘同分。此依现在识说。复次眼识依自地他地缘自地他地。耳身意识亦尔。余二识依自地缘自地。复次眼识依无记缘三种。耳识亦尔。意识依三种缘三种。余三识依无记。缘无记。复次眼识依近缘近远耳识亦尔。意识依近远缘近远。余三识依近缘近。所以者何。乃至三根未与境无间而住。三识必不得生故。复次眼识或依小而缘大如见大山。或依大而缘小如见毛端。或依缘等如见葡萄果。耳识亦尔。意识所依虽不可施设大小而所缘。或小或大。余三识所依缘等随依尔所鼻舌身极微。即缘尔所香味触极微故。复次眼耳意三识。依非业缘业非业。余三识依非业缘非业。复次眼耳意三识。依非妙行恶行。缘妙行恶行及俱非。余三识。依非妙行恶行缘非妙行恶行。如妙行恶行。善戒恶戒律仪不律仪表非表亦尔。问颇有一极微为所依。一极微为所缘。生眼等五识不。答无。所以者何。眼等五识依积聚缘积聚。依有对缘有对。依和合缘和合故。问若尔所法俱生。即尔所法俱灭刹那后必不住。如何可言鼻嗅香舌尝味身觉触耶。答若缘彼法鼻舌身识生即说彼法是鼻舌身识所了别。即说名为鼻舌身根所嗅尝觉故无有失。问眼等。五根处有筋骨血肉耶。答无。以诸色根是清净大种所造故。而经说色根处有筋骨血肉者。是根中间色香味触近根处故。说名为有。而实根处无筋骨等

色处有二十种。谓青黄赤白长短方圆高下正不正。云烟尘雾影光明闇。有说色处有二十一。谓前二十及空一显色。如是诸色或有显故可知非形故。谓青黄赤白影光明闇及空一显色。或有形故可知非显故。谓身表业。或有显形故可知。谓余十二种色。若非显形故可知者无也。问为缘一色生于眼识。为缘多色生眼识耶。若缘一色生眼识者。此云何通。如说。眼识缘五色缕。若缘多色生眼识者。则一眼识有多了性。了性多故应有多体。一法多体与理相违。有说。但缘一色生于眼识。问此云何通。如说。眼识缘五色缕。答多色和合共生一色。见一色时言见多色。尊者世友说曰。非一眼识顿取多色生。速疾故非俱谓俱。是增上慢。如旋火轮非轮谓轮。是增上慢。有说。亦缘多色生一眼识。问应一眼识。有多了性。乃至广说。答若别分别则缘一色生一眼识。若不别分别则缘多色生一眼识。大德说曰。若不明了取色差别。则缘多色亦生一识。如观树林总取叶等。问为有一青极微不。答有。但非眼识所取。若一极微非青者。众微聚集亦应非青。黄等亦尔。问为有长等形极微不。答有但非眼识所取。若一极微非长等形者。众微聚集亦应非长等形。复次有色极细故。不见非非境故。如减七微色处有色非境故。不见非极细故。如除色处余积集色有色极细故。不见亦非境故。如除色处。余极微色。有色非极细故。不见亦非非境故。如药杵头逼眼瞳子。复次有色极远故。不见非非境故。如四大王众天等。住自宫时。彼虽是人眼境而远故。不见有色非境故。不见非极远故。如梵众天等来至人间虽近不见有色极远故。不见亦非境故。如梵众天等住自宫时。人眼不见有色非极远故。不见亦非非境故。如药杵头逼眼瞳子。尊者世友说曰。由四缘故。虽有色而不见一极近故。如逼瞳子药杵头色二极远故。如住此间波吒梨色三极细故。如减七微色四有障故。如壁外等色数论者说由八缘故。虽有色而不见。谓极远故。极近故。根坏故。意乱故。极细故。有障故。被胜映夺故。相似所乱故

声处有八种。谓执受大种因声。非执受大种因声。此各有二。谓有情名声。非有情名声。此复各有可意不可意别故成八种。有作是说。执受大种因声。非执受大种因声。各有可意不可意别。有情数大种因声。非有情数大种因声。亦各有可意不可意别故成八种。问为缘一声生于耳识。为缘多声生耳识耶。若缘一声生耳识者。云何一时闻五乐声。及一时闻多人诵声。若闻多声生耳识者。则一耳识有多了性。乃至广说。有说。但缘一声生于耳识。问云何一时闻于五乐及多人诵声。答多声和合共生一声。闻一声时言闻多声。尊者世友说曰。非一耳识顿取多声生。速疾故非俱谓俱。乃至广说。有说。亦缘多声生一耳识。问应一耳识有多了性。乃至广说。答若别分别则缘一声生一耳识。若不别分别则缘多声生一耳识。大德说曰。若不明了取声差别。则缘多声亦生一识。如闻军众喧杂之声。香处有四种。谓好香恶香平等香不平等香。问为缘一香生于鼻识。为缘多香生鼻识耶。若缘一香生鼻识者。云何一时嗅百和香。若缘多香生鼻识者。则一鼻识有多了性。乃至广说。有说。但缘一香生于鼻识。问云何一时嗅百和香。答多香和合共生一香。嗅一香时言嗅多香。尊者世友所说如前。有说。亦缘多香生一鼻识。问应一鼻识有多了性。乃至广说。答若别分别则缘一香生一鼻识。若不别分别则缘多香生一鼻识。大德所说如前。应知

味处有六种。谓甘酢碱辛苦淡。问为缘一味生于舌识。为缘多味生舌识耶。若缘一味生舌识者。云何一时尝百味丸。若缘多味生舌识者。则一舌识有多了性。乃至广说。有说。但缘一味生于舌识。问云何一时尝百味丸。答多味和合共生一味。尝一味时言尝多味。尊者世友所说如前。有说。亦缘多味生一舌识。问应一舌识有多了性。乃至广说。答若别分别则缘一味生一舌识。若不别分别则缘多味生一舌识。大德所说如前。应知。问若尝味时为舌识先起。为身识耶。答随彼境增彼识先起。若二境等舌识先生。以诸有情贪味增故

触处有十一种。谓四大种滑性涩性轻性重性冷性饥性渴性。问为缘一触生于身识。为缘多触生身识耶。有说。但缘一触生于身识。谓或缘坚性。乃至或缘渴性。有说。乃至有缘五触生一身识。谓滑性及四大种。乃至渴性及四大种。有说。乃至有缘十一种触生一身识。如乃至有缘二十种色生一眼识。问云何身识缘共相境。以五识身缘自相故。答自相有二种。一事自相。二处自相。若依事自相说者。五识身亦缘共相。若依处自相说。则五识唯缘自相故不相违。问于嗅尝觉香味触时。为嗅尝觉执受香等。为嗅尝觉非执受香等耶。若嗅尝觉执受香等者。云何名受用施主所施。又应一切时有嗅尝觉。若嗅尝觉非执受香等者。外香味触于内香味触。都无有因。云何受用。有说。嗅尝觉执受香味触。问云何名受用施主所施。又应一切时有嗅尝觉。答外香味触于内香味触。是觉发因故无有失。有说。嗅尝觉非执受香味触。问外香味触于内香味触。都无有因。云何受用。答如声故无失。有说。于执受非执受香味触俱嗅尝觉然不一时。问内香味触既无增减。云何嗅尝觉耶。答由外缘故亦有增减

法处有七种。谓前四蕴及三无为。于色蕴中取无表色。三无为者。谓虚空择灭。非择灭。问为缘一法生意识。为缘多法生意识耶。答缘一缘多俱生意识。又所缘法非唯七种。即前七种。及诸余法皆能顿缘。唯除自性相应俱有。问曾闻菩萨六根猛利。云何于境知猛利耶。答菩萨宫边有无灭舍。彼于舍内然五百灯。菩萨尔时住自宫内。不见灯焰但见其光。即知彼灯数有五百。于中若有一灯涅槃即记之言一灯已灭。是名菩萨眼根猛利。无灭舍中有五百妓一时奏乐。菩萨尔时不见彼妓但闻乐声。即知其中作五百乐。若一弦断或一睡眠。即记之言今减尔所。是名菩萨耳根猛利。菩萨宫内烧百和香。菩萨嗅之知有百种。彼合香者欲试菩萨。于百种中或增或减。菩萨嗅已即记之言。此于先香增减尔所。是名菩萨鼻根猛利。菩萨食时侍者常以百味丸进。菩萨尝之即知其中百味具足。时造食者欲试菩萨。于百味中或增或减。菩萨尝已即知其中增减尔所。是名菩萨舌根猛利菩萨浴时侍者即以洗浴衣进。菩萨触之即知织者。或进衣者有如是病。是名菩萨身根猛利。菩萨善知诸法自相及与共相。而无挂碍是名菩萨意根猛利

诸过去彼一切不现耶。乃至广说。问何故作此论。答为止他宗显己义故。谓或有说过去未来无实体性。现在虽有而是无为。欲止彼意显去来有现是有为。故作斯论。诸过去彼一切不现耶。答应作四句。过去有二种。一世过去。二瑜伽过去。不现亦有二种。一世不现。二覆障不现。此中俱依二种作论。过去不现互有广狭。故作四句。有过去非不现。谓如具寿邬陀夷言

  一切结过去　　从林离林来
  乐出离诸欲　　如金出山顶

邬陀夷经是此根本。如说。世尊住室罗筏鹿母堂中。于日后分从静定出将邬陀夷往东池所。着衬身衣入池洗浴。时彼尊者为佛揩身。然邬陀夷于佛昔日为菩萨时。常随供侍。今见佛身光明赫弈。胜菩萨时欢喜敬爱。合掌白佛。我今欲以龙喻之颂赞叹世尊。唯愿听许。佛言。欲说随意说之。时邬陀夷便说此颂。一切结过去者。谓佛解脱一切烦恼。从林离林来者。林谓居家世尊从家。舍于家法趣非家来。乐出离诸欲者。欲有二种。一烦恼欲。二众具欲。佛于此二身心不染故名出离乐。谓于中爱乐而住。如金出山顶者曰名为金山顶即是日所出处。如日初出山顶之时光明遍照。佛从烦恼随烦恼出亦复如是。有说。山顶者是山顶云。如日从云出时光明遍照。佛亦如是。有说山顶者是山顶黑砂。金谓金砂。犹如金砂从黑砂出。光明照耀。佛亦如是。从烦恼出力无畏等。光明照耀。是谓过去。非不现过去者。是第二过去。非不现者。非二种不现。佛身现在而显现故。有不现非过去。谓如有一。或以神通。或以咒术。或以药物。或以如是生处得智。有所隐没令不显现。或以神通者。谓神通力令不显现。如契经说。梵王白佛。我欲隐身。佛言。可尔。时彼大梵隐入地中。佛便指之彼岂非汝。梵王念言。此由近故。即渡大海入妙高山腹中而住。世尊复指汝住此耶。梵又念言。此由粗故。即便化作极微细身。入佛白毫宛转中住。佛既知已舒毫现之。时大梵王极怀愧耻。佛便告曰。吾当隐身。尽汝所能试知吾不。梵王敬诺。时佛即入如是等持。放大光明遍梵宫处。亦令梵世闻大音声。诸梵梵王莫知佛处。问佛住何处令彼不知。有说。梵王髻中而住。有说。化作极微妙身。有说。化身令不显现。有说。化作障色障之。有说。静虑静虑境界。佛佛境界皆不思议。故不可知佛身所在。又如尊者大目干连。入如是等持即于坐所而自隐蔽。令提婆达多对目不见如是等类。或以咒术者。谓咒术力令不显现。如诸仙人所结咒术。有受持者。随所隐没能令不现。或以药物者。谓药物力令不显现。如有药物具大神用。若有执持随所隐没亦令不现。如毕舍遮宫畔荼等。或以如是生处得智者。谓彼智力令所隐没不复显现。此中有说。地狱虽有生处得智。而不能令身不显现。彼若能者终不须臾住彼受苦。有作是说。彼虽不能于狱卒边令身不现。而能于余令身不现。傍生饿鬼天亦有此生处得智。令身不现。唯人趣无。问此神通等四种力中。谁能于谁令不显现。答神通能于一切不现以最胜故。问谁神通于谁能令不现。答佛于一切能令不现。独觉除佛于余一切能令不现舍利子除佛独觉于余不现。目干连除佛独觉及舍利子。于余不现。乃至钝根者除利根者。于余不现。咒术除神通。于余能不现问何咒术于何能令不现。答有圆满咒术有不圆满咒术。有殊胜咒术有不殊胜咒术。圆满殊胜者。于一切皆能不现。不圆满不殊胜者。除圆满殊胜于余不现。药物除神通咒术于余能不现。所以者何。由咒术力。能致药物非药物力能致咒术故。问何药于何能令不现。答胜药于劣能令不现。生处得智。除前三种于余不现以最劣故。问此谁于谁能令不现。有说。地狱唯于地狱能令不现。乃至天唯于天能令不现。有说。地狱唯于地狱能令不现。傍生于二饿鬼于三天。于五趣能令不现。如是说者地狱能于五趣不现。乃至天亦能于五趣不现。是谓不现非过去。不现者是第二不现。非过去者非二种过去。以所隐没住现在故。有过去亦不现。谓所有行已起等起。已生等生已转现转。已集已现已过去。已尽灭已离变。是过去过去分过去世摄。如是诸句皆共显示过去诸行。过去者是世过去。不现者是世不现。有非过去亦非不现。谓除前相。此中相声于所名转。谓若法是前三句。名所显者皆悉除之。余未显者作第四句。此复云何。谓除一切过去世法现在佛身及所隐没。取余现在一切未来及无为法。问如后尽灭亦约结断而作四句。何故此中不约结断。作四句耶。答有处说结断。名尽名灭。无处说结断名不现故

说一切有部发智大毗婆沙论卷第十三阿毗达磨大毗婆沙论卷第十四

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中智纳息第二之六

诸过去彼一切尽耶。答应作四句。过去有二种。如前说。尽亦有二种。如过去说。此中俱依二种作论。过去与尽互有广狭。故作四句。有过去非尽。谓如具寿邬陀夷言。一切结过去。乃至广说。过去者是第二过去。非尽者非初尽。佛身现在已断尽故。有尽非过去。谓如佛言。此圣弟子已尽地狱。已尽傍生。已尽饿鬼。已尽所有险恶趣坑。问此中已尽地狱者。显圣弟子已尽地狱。已尽傍生者。显此已尽傍生。已尽饿鬼者。显此已尽饿鬼。已尽所有险恶趣坑者。显此更何所尽耶。答即显上三然前广后略。前别后总前渐后顿。前分别后不分别。有说。已尽地狱傍生饿鬼者。显此已尽三恶趣自性。已尽所有险恶趣坑者。显此已尽彼中有。有说。已尽地狱等者。显已尽地狱等。已尽所有险恶趣坑者。显已尽人中扇搋半择迦无形二形。彼是人中险恶趣坑故。有说。前显已尽地狱傍生饿鬼。后显已尽住不律仪。彼当堕险恶趣坑故有说。前显已尽地狱傍生饿鬼。后显已尽造五无间业。彼无间生堕地狱故。有说前显已尽地狱傍生饿鬼。后显已尽断善根者。以断善者如险恶趣坑故。若不续善根死必堕地狱故。有说。前显已尽地狱等果。后显已尽地狱等因。如契经说。汝等苾刍。若见行身语意恶行者。应知已见地狱或余恶趣。有说。前显已尽地狱傍生饿鬼。后复言已尽所有险者。重显已尽地狱。以地狱中无善果故。恶趣者重显已尽饿鬼。彼常贫穷乏资缘故。坑者重显已尽傍生。身心堕彼难可出故。有成劫时生。彼坏劫时方命终故。有说。前显已尽地狱傍生饿鬼。后复言已尽所有险恶趣坑者。皆重显已尽三恶趣果。谓三恶趣皆是极险。众恶所趣所堕坑故。问今地狱中犹有种种镬汤炉炭。及狱卒等无量苦具。如何言尽耶。答不往不生故说为尽。谓圣弟子不复往彼处。不复生彼蕴界处故。此已得彼非择灭故。问亦有异生得地狱等非择灭者。何故但说圣弟子耶

答诸圣弟子皆已尽故。异生品中有未尽者。是故不说。问诸圣弟子亦尽人天。何故但言尽地狱等。答此中但说一切尽者。诸圣弟子于人天趣。有未尽者故不说之是谓尽。非过去尽者是第二尽。非过去者非初过去。有过去亦尽。谓所有行已起等起。乃至广说。此皆显示过去诸行。过去者是世过去尽亦尔。有非过去亦非尽谓除前相。此中相声义如前释广说。乃至此复云何。谓除一切过去世法现在佛身。未来圣弟子地狱等蕴界处。取余现在一切未来及无为法。作第四句

复次若依结断说者。此中依言显所凭义。前四句中。依世尽及不生尽说尽言。今四句中。依断烦恼得择灭尽。建立尽名。有结过去非尽。谓结过去。未断未。遍知未灭未变吐。未断者未立断遍知。未遍知者未立智遍知。未灭者未得择灭。未变吐者未弃彼得。有说。未断者未以无间道断。未遍知者未以解脱道遍知。未灭者未证彼离系得。未变吐者未舍彼系得。有说。此四句皆显未弃舍义。此复云何。谓诸异生若具缚者。过去三界见修所断结。已离欲染未离初静虑染者。过去八地见修所断结。乃至已离无所有处染者。过去一地见修所断结。若圣者具缚入正性离生位。苦法智忍时过去三界见修所断结。苦法智已生苦类智未生。过去色无色界见苦所断。乃至三界见集灭道修所断结。乃至道法智已生道类智未生。过去色无色界见道所断。及三界修所断结。预流者过去三界修所断结。一来者过去欲界修所断三品。及色无色界修所断结。不还者若未离初静虑染。过去八地修所断结。乃至若已离无所有处染。过去一地修所断结。是谓结过去非尽。有结尽非过去。谓结未来已断已遍知已灭已变吐。已断者已立断遍知。已遍知者已立智遍知。已灭者已得择灭。已变吐者已弃彼得。有说。已断者已以无间道断。已遍知者已以解脱道遍知。已灭者已证彼离系得。已变吐者已舍彼系得。有说。此四句皆显已弃舍义。此复云何。谓阿罗汉未来三界见修所断结。若不还者已离无所有处染。未来三界见所断。及八地修所断结。乃至未离初静虑染者。未来三界见所断。及一地修所断结。若一来者未来三界见所断。及欲界六品修所断结。若预流者未来三界见所断结。若随信随法行。道法智已生道类智未生。未来三界见苦集灭所断。及欲界见道所断结。乃至苦法智已生苦类智未生。未来欲界见苦所断结。若诸异生已离无所有处染。未来八地见修所断结。乃至已离欲染未离初静虑染。未来一地见修所断结。是谓结尽非过去。有结过去亦尽。谓结过去已断已遍知已灭已变吐。已断等言如前广说。此复云何。谓阿罗汉过去三界。见修所断结。广说乃至。若异生已离欲染未离初静虑染。过去一地见修所断结。是谓结过去亦尽。有结非过去亦非尽。谓结未来未断未遍知未灭未变吐。及结现在未断等言如前广说。此复云何。谓诸异生若具缚者。未来三界见修所断结。广说乃至。若不还者已离无所有处染。未来一地修所断结。及一切现在结。是谓结非过去亦非尽。诸过去彼一切灭耶。答应作四句。过去有二种。如前说。灭亦有二种。一世灭。二隐没灭。此中俱依二种作论。过去与灭互有广狭。故作四句。有过去非灭。谓如具寿邬陀夷言。一切结过去。乃至广说。过去者是第二过去。非灭者非二种灭。佛身现在非隐没故。有灭非过去。谓依世俗小街小舍小器小眼。言是灭街乃至灭眼。谓东方人见小街等说言此灭。即依此义可作是言。颇有眼灭能见色耶。答有。谓现在世同分小眼是谓灭。非过去灭者是第二灭。非过去者非初过去。有过去亦灭。谓所有行已起等起。乃至广说。此皆显示过去诸行。过去者是世过去灭亦尔。有非过去亦非灭。谓除前相。此中相声亦如前说。广说乃至。此复云何。谓除一切过去世法。现在佛身及小街等。取余现在一切未来及无为法。作第四句。复次若依结断说者。此中依言义如前说。前四句中依世灭及隐没灭说灭言。今四句中依断烦恼得择灭灭建立灭名。有结过去非灭。谓结过去未断未遍知。未灭未变吐。广说乃至。有结非过去亦非灭。谓结未来未断未遍知未灭未变吐及结现在。此中一切义如前说

如是所说五四句中。前三四句依世施设及圣施设说。依世语言。及圣语言说。依世俗及胜义说。依契经及现见说。后二四句唯依圣施设圣语言胜义契经说。问后二四句中。何故但说结不说结法耶。答彼作论者。意欲尔故。乃至广说。有说应说而不说者。当知此义有余。有说。已说结。当知亦已说结法。所以者何。依结立结法故。又同一对治故。有说。诸结自性断。断已不成就。是故说之。结法不定是故不说。有说。诸结多诸过失。坚牢难断难破难越是故说之。结法不尔是故不说。有说。诸结与圣道相违。结法不尔。以善有漏。能与圣道相入出故。无覆无记能与圣道为依止故。然与结相杂故。亦是圣道所断。如灯破闇时亦损炷等。王破他军时亦损自众。有说。诸结是结亦是结法。是故说之。结法非结是故不说。如结结法。缚缚法。随眠随眠法。随烦恼随烦恼法。缠缠法。垢垢法。应知亦尔。若于苦生疑此是苦耶。此非苦耶。乃至广说。问何故作此论。答为欲分别契经义故。如契经说。有因论婆罗门。来诣佛所作如是问。沙门乔答摩。疑甚为希有难度非易度。世尊告言。如是如是。婆罗门疑甚为希有难度非易度。所以者何。有古昔婆罗门造明论者。造咒术者上首有十。一頞瑟搩迦。二婆莫迦。三婆莫提婆。四毗湿缚蜜多罗。五阇莫铎耆尼。六鸯耆罗。七跋罗堕阇。八婆死瑟搋。九迦叶波。十勃栗瞿。如是等诸婆罗门。世虽尊敬皆不度疑而命终。是故知疑甚为难度。契经虽作是说而不广分别。彼经是此论所依根本。彼所不说者。今应说之。故作斯论。若于苦生疑。此是苦耶。此非苦耶。当言一心多心耶。答应言多心。谓此是苦耶。是一心。此非苦耶是第二心。于集灭道生疑亦尔。此中邪声显成疑义。若但说此是苦。便成正见。此非苦便成邪见。乃至于道亦尔。由说邪声故成疑义。如是于苦乃至于道。各有二心总成八心。此说极速。于四圣谛次第疑者有此八心。如现观时。从苦法智忍。乃至道类智十六刹那。有说。此八非八刹那。以一一心生灭速疾。若作是念。此是苦耶。中间已经百千生灭。余心亦尔。但本论师欲令弟子易解了。故说多刹那以为一心。行相等故。颇有一心。有疑无疑耶。乃至广说。问何故作此论。答为令疑者得决定故。谓阿毗达磨者说一心聚。有多法俱。生于中有是犹豫谓疑。有是决定谓慧。有非犹豫非决定谓余心所。勿有生疑即有疑心。是无疑心。即无疑心。是有疑心为令此疑得决定故。显有疑心异无疑心异故作斯论。颇有一心有疑无疑耶。答无。问此言。为约心聚。为约所缘说耶。若约心聚说者。则一心聚中有是疑有非疑。如前已说。何故言无。若约所缘说者。则于一佛心有有疑。谓异生有无疑。谓圣者亦不应言无。何故答言无也。答此约心聚故答言无。谓诸心聚若有疑者名有疑心。若无疑者名无疑心。是故有疑心异无疑心异。然此中说无疑心者。于四圣谛或了是有或拨为无。非但与疑不相应起。所以者何。谓于苦谛。若言此是苦耶。此心有疑。若言此是苦。此心无疑。若言此非苦耶。此心有疑。若言此非苦。此心无疑。于集灭道应知亦尔。应知此中有十六心。于四圣谛各有四故。谓八是疑。四是正见。四是邪见。前四种疑引四正见。后四种疑引四邪见。谓此是苦等是正见。此非苦等是邪见故。问何等补特伽罗疑能引生正见。何等补特伽罗疑能引生邪见。答若好与此法共住者。彼疑引生正见若好与外道共住者。彼疑引生邪见。复次若乐习内论者。彼疑引生正见。若乐习外论者。彼疑引生邪见。复次若爱亲近善士听闻正法者。彼疑引生正见。若爱亲近不善士听闻不正法者。彼疑引生邪见。复次若因力加行力不放逸力增上者。彼疑引生正见。若因力加行力不放逸力非增上者。彼疑引生邪见

如契经说。有三种冥身。谓于三世疑惑犹豫。问冥身自性应是无明。何故说疑。答彼相似故。谓诸烦恼中无有不了。行相与无明相似犹如疑者。是故说疑。有说。冥身自性实是无明。疑是无明依处舍宅是故说疑。如施设论说。疑是无知依处舍宅故。有说。疑与无明亲近住故。谓若有疑处必有无明。如世于亲说彼是我是。故说疑。有说。疑与无明相类同故。谓彼于境俱不决定二分而转是故说疑。有说。彼经为成不成法故。谓无明为冥身自性。不说自成而疑亦有冥身之义。然不显了是故偏说。问世尊何故但说缘世疑为冥身。不说缘无为疑耶。答应说而不说者。当知此义有余。有说。彼经依多分说。谓多缘世起此冥身。少缘无为是以不说。有说。有为粗显于中生疑。圣所诃责说为冥者。无为微细难可觉了于中生疑。圣不诃责是以不说。如昼颠蹶为世所诃说为盲者。夜分颠蹶世则不诃。彼亦如是。有说。外道于世起增上愚。疑惑犹豫是故偏说。如契经言。我于过去。为曾有为非曾有。何所曾有。云何曾有。我于未来为当有为非当有。何所当有。云何当有。于内犹豫此物是何。此物云何。当何所有。如是有情生从何来。没往何所。外道于世数。起如是增上犹豫。是故偏说。有说。若愚若智内道外道。世间论者乃至童竖皆知有世。谓彼皆了有去来今。而于中疑甚为盲冥故说冥身。涅槃离相极难觉了。虽猛利智犹不能穷。故于彼疑此中不说。有说。佛观未来。有诸弟子拨无过未。故说于世起疑惑者名为冥身

如契经说。有五种心栽。一者疑佛。二者疑法。三者疑戒。四者疑教。五者嗔僧。如彼经说。有五心栽。云何为五。谓于大师及法戒教疑惑犹豫。不悟入不信解不害心栽。于佛所赞叹有智同梵行者。嗔恚毁骂陵辱触恼不害心栽。问此五心栽以何为体。答疑嗔为体。前四是疑第五是嗔。问嗔可尔。疑云何。如契经说。栽有三种。谓贪嗔痴。品类足论亦作是说。嗔云何。谓于有情。作损害作栽檗无处说疑为栽自性。此中何以说耶。答彼相似故谓诸烦恼中。无有非栽自性而作栽事。犹如疑者。如施设论说。疑覆蔽心。令心刚强作栽檗事。尚不令心得邪决定。况正决定。譬如良田若不耕垦。即便坚硬多诸株杌。秽草不植。何况嘉苗。有说。疑与嗔恚行相所对。俱相似故说为心栽。行相相似者。俱戚行相转故。所对相似者。俱对欢行相故。问何故疑佛说为心栽。非疑僧耶。答不应生处而妄生者说名心栽。佛无一切恶行过失。而生猜疑是名非处。于法戒教应知亦尔。僧有少分恶行过失。而猜疑者是应处起不名心栽。问何故嗔僧说名心栽。非嗔佛耶。答僧有少分恶行过失。缘之生嗔性必尤重故名心栽。佛无一切恶行过失。生嗔则轻是故不说。于法戒教应知亦尔。有余师说。于非重过施设心栽。于僧生疑其过则重。以应处起难可断故不名心栽。佛无诸过而能缘之生嗔性必尤重难断亦非心栽。于法戒教亦复如是

云何多名身。乃至广说。问何故作此论。答是作论者意欲尔故。乃至广说。有说。为欲分别契经义故。如契经说。苾刍当知如来出世。便有名身句身文身。出现世间。虽作是说而不分别。云何名身句身文身。今欲分别故作斯论。有说。为令疑者得决定故。谓此论中分别种种甚深妙义。或有生疑论者。于义虽得善巧。而于其文或不善巧为令此疑得决定故。显于文义俱得善巧故作斯论。有说。为止他宗显己义故。谓或有执名句文身。非实有法如譬喻者。或复有执名句文身。声为自性如声论者。为止彼执显名身等是实有法。是不相应行蕴所摄故作斯论。有说。欲显世尊三无数劫。所设劬劳有大果故。谓佛过去无量劫前应得灭度。所以经于三无数劫修习。百千难行苦行。但为利他。夫利他者。必于名身句身文身。皆得善巧。以善巧故。能为他说蕴界处等。令得涅槃究竟饶益是名大果。有说。为欲建立三种菩提增上缘故。谓若以上品觉慧。觉名句文身名佛菩提。若以中品觉慧。觉名句文身名独觉菩提。若以下品觉慧。觉名句文身名声闻菩提。有说。欲显佛是无量无边说法者故。谓佛善达名句文身。能为众生说法无尽。有说。欲显世尊异独觉故。谓佛独觉皆不由师自能觉悟。而于名等唯佛善知。独觉不尔。有说。为欲照了杂染清净。二法性相令他知故。谓名身等是能照了染净根本。若无名等杂染清净不可显示。有说。欲显于名身等观察。不观察者引大义利大衰损故。谓修行者。若能观察名句文身则能制伏。犹如积山烦恼恶行。虽遭骂辱能堪忍故。若不观察名句文身。则烦恼恶行如河流不绝。如骂太子毗卢释迦言。婢子何以升我释种堂。彼以不能观察如是四五字故。牵引无量百千众生堕大地狱。问彼修行者得他骂时。云何观察令嗔不起。答所言阿俱卢舍缦者。是为骂我。若除阿字但是唤我。若除缦字直是骂声。若二字俱除直名为唤。彼修行者得他骂时。便审观察此诸字中。若无阿者便是唤我何为生嗔。若无缦者但有骂声。不关于我何由得嗔。若二字俱无直名为唤。于我何苦而得生嗔。复次行者得他骂时。便审观察如是诸字。此方是骂他方是赞。我若于此生嗔生忧。若于他方生贪生喜。则常忧常喜常嗔常贪。谁有疲苦与我比者。由此观察便不生嗔。复次行者得他骂时。便审观察有赞我者更无别字。但于骂我诸字之中。颠倒次比此赞与骂既不决定。不应于中生忧生喜。由此于骂不生嗔心。复次行者得他骂时。应审观察如是语业。谁所成就。为是骂者。为是我身。即知此是骂者成就。便作是念。彼为自骂何关于我。故不生嗔。复次行者得他骂时。便观骂者身中诸法。骂我法多不骂法多。即知骂法唯摄一界。一处一蕴少分。不骂法摄十七界。一界少分十一处一处少分。四蕴一蕴少分。作如是念。彼骂我者。骂我法少不骂法多。何为忘多于少生恚。复次行者得他骂时。应观一字一刹那顷。必不成骂。无有多字多念俱生。前字生时后字未起。后字若生前字已灭。都无骂理但妄分别。谓之为骂故不应嗔。复次行者得他骂时。应观我身及能骂者。皆念念灭适欲分别。骂者及我皆已灭无。谁复于谁应生嗔恨。由此观察故不生嗔。复次行者得他骂时。应观诸行离我我所。作者受者皆不可得。唯空行聚何为生嗔。有说。所以作此论者。为显此论文义具故。谓此论中分别诸法自相共相。名为义具。此中分别名句文身名为文具。有说。为显名句文身有大用故。谓由名等显示分别蕴界处等。无量义门。及能赞述佛法僧宝无边功德。由如是等种种因缘。故作斯论

云何多名身。答谓多名号异语增语想等想假施设。是谓多名身。此中论者于文善巧。以多文句共显一名。皆是名之差别名故。问此中何故问多名身。而不问名及名身耶。答是作论者意欲尔故。乃至广说。有说。应问而不问者。当知此义有余。有说。名与名身。二俱摄在多名身中。问多名身则为都问。有说。此是契经所说。不应问。作论者。契经但问多名身故。论者于中不能增减。问若尔。何故问多名身。而答以名。答名是根本。名满名身。名身复满多名身故。有说。依展转因故作是说。如子孙法。谓依名有名身。依名身有多名身故。问名体是何。答是不相应行蕴所摄。文句亦尔。问何故名名。答名者名为随名。为名名为合随者。如其所作即往相应。名者为此义立。如求便应合者。随造颂转令与义会。此中名具三义故名为名。心心所法有随有名。而无合义故不名名。余不相应色无为法。有随有合而无名义故亦非名。问名身者是何义。答是二名聚集义。是故一名不名名身。问多名身是何义答是多名聚集义。如一象二象不名多象身。要众多象名多象身。马等亦尔。句身多句身文身多文身亦复如是。此中有名。有名身。有多名身。有一字所起名。有二字所起名。有多字所起名。一字所起名中。于一字但有名于二字有名身多名身者。有欲令依三字。有欲令依四字。二字所起名中。于二字但有名于四字有名身多名身者。有欲令依六字。有欲令依八字。三字所起名中。于三字但有名于六字有名身多名身者。有欲令依九字。有欲令依十二字。四字所起名中。于四字但有名于八字。有名身多名身者。有欲令依十二字。有欲令依十六字。以此为门余多字名应知亦尔。有余师说。一字所起名中。于一字一呼但有名。即于此字再呼有名身。即于此字或三呼或四呼有多名多身。于二字所起名等应知亦尔

云何多句身。答诸句能满未满足义。于中连合是谓多句身。为成此义引经为证。如世尊说

  诸恶莫作　　诸善奉行　　自净其心
  是诸佛教

如是四句各能满足。未满足义于中连合。是谓多句身。如是四句一一能满。各自句中。未满足义于中连合者。于四句中一一各别。连合诸字显未满义。或复连合诸句。显成颂义为多句身。一一句中有标有释。谓诸恶者是标。莫作者是释。乃至是诸佛者是标。教者是释。故此颂中有四事满。一标二释三句四颂。若说诸恶于标名满。于释于句于颂未满。复说莫作于标释句三种名满。于颂未满。复说诸善若于总颂摽释句满。若于别句摽满非余。乃至复说是诸佛者若于总颂摽释句满。若于别句摽满非余。复说教者一切皆满。此颂处中不长不短八字为句。三十二字为颂。诸经论颂多依此法。计书写数亦依此法。又从六字乃至二十六字皆得为句。然六字者名为初句。二十六字者名为后句。减六字者名短句。过二十六字者名长句

云何多文身。答诸字众是谓多文身。为成此义引经为证。如世尊说

  欲为颂本　　文即是字　　颂依于名
  及造颂者

此中欲者。是欲造颂欣喜爱乐。为颂本者此欲是颂因集生缘。文即是字者。巧便显了故名为文。此即是字无转尽故。此即显示能显颂文以字为体。颂依于名者。颂是假有依名而立。亦依文句且说依名。此中依言如林依树。及造颂者。思惟观察作诸伽他名造颂者。颂依造者如蛇依穴水依于泉。乳依乳房与依名异

应知。此中有名有名身有多名身。有句有句身有多句身。有文有文身有多文身。于一字有名无名身无多名身。无句无句身无多句身。有文无文身无多文身。于二字有名有名身无多名身。无句无句身无多句身。有文有文身无多文身。于四字有名有名身有多名身。无句无句身无多句身。有文有文身有多文身。于八字有名有名身有多名身。有句无句身无多句身。有文有文身有多文身。于十六字有名有名身有多名身。有句有句身无多句身。有文有文身有多文身。于三十二字有名有名身有多名身。有句有句身有多句身。有文有文身有多文身。由此为门于诸字众。所说多少如理应知

说一切有部发智大毗婆沙论卷第十四此卷宋本第十六幅末。便不生嗔复次行者得(之下)所起名中(之上)脱他骂时便审观察(乃至)依二十字四字等六十八行文今依二本足阿毗达磨大毗婆沙论卷第十五

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中智纳息第二之七

问名为随语地系。为随补特伽罗地系耶。有说。名随语地系。彼作是说。生欲界者。若作欲界语。彼欲界身。欲界语。欲界名。所说义或三界系或不系。若作初静虑语。彼欲界身初静虑语。初静虑名。所说义如前说。生初静虑者。若作初静虑语彼初静虑身。初静虑语。初静虑名。所说义如前说。若作欲界语彼初静虑身。欲界语欲界名。所说义如前说。生第二第三第四静虑者。若作欲界语。彼第二第三第四静虑身。欲界语欲界名。所说义如前说。若作初静虑语。彼第二第三第四静虑身。初静虑语初静虑名。所说义如前说。问若尔者。上三静虑为有名不。有说。无。有说。有。而不可说。评曰。彼不应作是说。宁说无不应说有。而不可说以无用故。有说。名随补特伽罗地系。彼作是说。生欲界者。若作欲界语。彼欲界身欲界语欲界名。所说义如前说。若作初静虑语。彼欲界身初静虑语。欲界名。所说义如前说。生初静虑者。若作初静虑语。彼初静虑身初静虑语。初静虑名。所说义如前说。若作欲界语。彼初静虑身欲界语初静虑名。所说义如前说。生第二第三第四静虑者。若作欲界语。彼第二第三第四静虑身。欲界语。第二第三第四静虑名。所说义如前说。若作初静虑语。彼第二第三第四静虑身。初静虑语。第二第三第四静虑名。所说义如前说。问若尔者。无色界为有名不。有说。无。有说。有。而不可说。评曰彼不应作是说。宁说无不应说有。而不可说以无用故。如说名。文句亦尔

问名等为是有情数。为非有情数耶。答是有情数。问名等为有执受。为无执受耶。答无执受。问名等为是长养。为是等流。为是异熟生耶。答是等流。非长养非异熟生。问若名等非异熟生。契经云何通。如说。佛告阿难。我亦说。名从业生是业果。答名亦是业增上果故作如是说。谓作好业亦得好名。然非异熟。问名等为善。为不善。为无记耶。答无记。非造业者故。思起故。如四大种

问谁成就名等。为能说者为所说耶。设尔何失。若能说者则阿罗汉。应成就染污法。离欲染者应成就不善法。异生应成就圣法。断善根者应成就善法。以阿罗汉等亦说染污等法故。若所说者。则外事及无为亦应成就名等。以彼亦是所说法故。答唯能说者成就名等。问若尔后难善通。前难云何通。答阿罗汉等虽成就染污等名。而不成就染污等法。以染污等名皆是无覆无记法故

问一刹那心能起一语。一刹那语能说一字耶。答佛一刹那心能起一语。一刹那语能说一字。声闻独觉一刹那心能起一语。一刹那语不能说一字。彼说[褒-保+可]时必经多刹那故。由此唯佛。其言捷利声韵无过词辩第一。问三世诸法一一各有三世名耶。答有。过去诸法有过去名者。如过去佛。以如是名。说过去法过去诸法。有未来名者。如未来佛。以如是名。说过去法过去诸法。有现在名者。如现在佛。以如是名。说过去法未来现在法。广说亦尔问一切名皆能显义耶。答一切名皆能显义。问若以此名显断常。第二头第三手第六蕴。第十三处第十九界等。此名何所显耶。答此名即显断常等想。问若以此名显诸法无我。此名何所不显耶。有说。除其自性及俱有法。余悉能显。有说。唯除自性余悉能显。有说。唯除四字余悉能显有说。一切悉显。谓于此中萨能显婆。婆能显萨。达能显磨。磨能显达。是故此中。虽显一切而无自性显自性失。问名之与义何者多耶。答义多名少。所以者何。义摄十七界一界少分十一处一处少分四蕴一蕴少分。名摄一界一处一蕴少分。有说。名多义少。所以者何。以一一义有多名故。如古所制尼健荼书。一一义有千名。次后略之。于一一义唯留百名。今一一义唯留十名。又说法者以无量名说一义故。如是说者义多名少。所以者何。名亦义故。设名非义义犹为多。以摄十七界一界少分。乃至广说。况名亦是义。是余名所显故。是则义摄十八界十二处五蕴。名但摄一界一处一蕴少分。问若名亦是义者。名义有何差别。答能显是名所显是义。复次名是非色。义通色非色。名唯无见。义通有见无见。名唯无对。义通有对无对。名唯有漏。义通有漏无漏。名唯有为。义通有为无为。复次名唯无记。义通善不善无记。名唯堕三世。义通堕三世及离世。名唯欲色界系。义通三界系及不系。名唯非学非无学。义通学无学非学非无学。名唯修所断。义通见修所断及不断。复次名唯不染污。义通染污不染污。如染污不染污。有罪无罪。有覆无覆是退非退。黑法白法亦尔。复次名无异熟。义通有异熟无异熟。名非异熟。义通异熟非异熟。名不相应。义通相应不相应。如相应不相应。有所依无所依。有所缘无所缘。有行相无行相。有警觉无警觉亦尔。复次名唯苦集谛摄。义通四谛及非谛摄。由如是等。名义差别。问义为可说。为不可说耶。设尔何失。若可说者。说火应烧舌。说刀应割舌。说不净应污舌。说饮应除渴。说食应除饥。如是等。若不可说者。云何所索不颠倒耶。如索象应得马。索马应得象。如是等。契经所说复云何通。如说。我所说法初中后善。文义巧妙。答义不可说。问若尔前难善通。云何所索不颠倒耶。答劫初时人。共于象等假立名想。展转传来。故令所索而不颠倒。有说。语能起名名能显义。语虽不能亲说得义而依展转。如子孙法故于象等所索无倒。问契经所说复云何通。如说。我所说法初中后善。文义巧妙。尊者世友作是释言。语能起文文能显义。故作是说。复作是言。为异外道故作是说。谓诸外道所说法。或少义或无义。世尊所说有义多义。是故说言。我所说法文义巧妙。复作是说。外道所说文义相违。世尊所说文义相顺。欲显异彼故作是说

问名句文身是不相应行蕴所摄。何故佛说四蕴名名。答佛于有为总立二分。谓色非色。色是色蕴。非色即是受等四蕴。非色聚中。有能显了一切法名。故非色聚总说为名。有说。色法粗显即说为色。非色微隐。由名显故说之为名。然实名等唯不相应行蕴所摄。名有六种。一功德名。二生类名。三时分名。四随欲名。五业生名。六摽相名。功德名者谓依功德立名。如解。或诵素怛缆者名为经师。若解或诵毗奈耶者名为律师。若解。或诵阿毗达磨者名为论师。得预流果名为预流。乃至得阿罗汉果名阿罗汉。如是等。生类名者。谓依生类立名。如城市生者名城市人。村野生者名村野人。刹帝利种中生者名刹帝利。乃至戍达罗种中生者。名戍达罗。如是等。时分名者。谓依时分立名。如童稚时名为童子。乃至衰老时名为老人。如是等。随欲名者。谓随乐欲立名。如初生时。或父母等。或沙门等。为其立名。如是等。业生名者。谓依作业立名。如善画者名为画师。锻金铁者名金铁师。如是等。摽相名者。谓依摽相立名。如执杖者名执杖人。执盖者名执盖人。如是等。复次名有四种。一假想名。二随用名。三彼益名。四从略名。假想名者。如贫贱者名为富贵。如是等。随用名者。如腹行者名腹行虫。如是等。彼益名者。如天神边求得者名为天授。因祠祀而得者名为祠授。如是等。从略名者。如具五功德者名为五德。系属王者名曰王人。如是等。复次名有二种。一生名。二作名。生名者。如刹帝利婆罗门等。作名者。如父母等所为立名。有说。生名者谓初生时父母等所立名。作名者。谓于后时亲友知识所为立名。复次名有二种。一有相名。二无相名。有相名者。如无常苦空无我等。无相名者。如我人有情意生等。若佛出世则有相名多无相名少。若不出世则无相名多有相名少。问火名为是有相。为是无相。答若云尸弃是有相名。若云阿耆尼。是无相名。复次名有二种。一共名。二不共名。不共名者。如佛法僧蕴界处等。共名者。谓余世间共所立名。有余师说。无不共名。以一法可立一切名。一切法可立一名故。名皆是共如共不共名。曾未曾名亦尔。复次名有二种。一定名。二不定名。定名者。如苏迷卢大海洲渚等。不定名者。谓余世间随共立名。有余师说。无决定名。所以者何。苏迷卢等。边方亦为作种种名。此方文颂亦作余名。如是说者苏迷卢等有决定名。劫初成时苏迷卢等名已定故。问前劫坏时一切失坏。今劫成已谁传彼名。答有诸仙人得宿住智。忆前劫事复传彼名。或劫初人由法尔力。心想欻有彼名现前。问诸所有名。为皆先有展转传说为新立耶。答苏迷卢等诸名先有。余名不定。或有新立。复次名有二种。一者诠体。二者诠用。诠体名者。如盆中果舍中人等。诠用名者。如刈者诵者等。有说。诠体名者。如坚湿暖动等。诠用名者。如持摄熟长等。有说。诠体名者谓诸恶等。诠用名者。谓莫作等。问名为有边际不。有作是说。名无边际法无边故。于一一法有多名故。复有说者。名有边际。唯佛能知余无知者。以佛能知名边际故名一切智。有说。佛及独觉知名边际。余不能知。有说。佛及独觉到彼岸声闻知名边际。余不能知。评曰。初说为善。唯佛能知名之边际。余皆无有一切智故。问有佛无佛世间恒有名句文身。何故经言。如来出世。便有种种多名身等出现世间。答依不共名故作是说。如佛法僧蕴界处等。唯佛出世方。有此名。有作是说。唯佛出世。有顺解脱顺空无我。违生死苦违我我所。断诸见生觉意。背烦恼向出要。止愚痴生智慧。断犹豫生决定。厌生死乐涅槃。毁外道赞正法。诸如是等。名句文身出现于世。余时不尔故作是说。如契经说。有三种言依。无第四第五。云何为三。谓依过去说曾诸法。依未来说当诸法。依现在说今诸法。问言依以何为自性。答品类足说言。依十八界十二处五蕴所摄

问言即是语彼依是名。但应一界一处一蕴所摄。何故言十八界十二处五蕴所摄耶。答彼论应说。言依一界一处一蕴所摄。而言十八界十二处五蕴所摄者。依展转因故作是说。谓语依名转名依义转。义是言展转依义中。具有十八界十二处五蕴故。说者听者皆为于义。是故彼论依展转因。说言依自性。有说言依是名及所说义。是故具有十八界等。以言依名及义转故。问何故但依三世法说三言依。不依无为法说言依耶。答亦应说无为法是言依。而不说者当知此义有余。有说。无为摄在现在品中。以现在法得无为故。有说。言多分依有为法转故。无为法不说言依。有说。为止有情增上愚故说三言依。于有为法所起无明多增上故。有说。有情多于三世犹豫故。佛为说三种言依。有说。为止外道执有我故说三言依。谓外道言若无我者。我言何依故。佛为说三种言依。我言但依三世起故。有说为止拨无去来二世。并止现在是无为执说三言依。依是有体有用法故无必无体。无为无用故非言依。有说有为法粗多信是有。易起言说故立言依。无为法细少信是有难起言说。故非言依。尊者世友作如是说。有为无为分为二聚。若彼聚中三事可得。谓语名义立为言依。无为聚中虽得有义。而无余二故非言依。大德说曰。若法有用取果与果可立言依。无为无用是故不说。胁尊者言。有为诸法与言可有俱时转义故立言依。无为不然是故不说。问若依过去说未来现在法。依未来说过去现在法。依现在说过去未来法。彼是何等言依摄耶。有作是说彼不摄在三言依中。复有说者。若依过去说未来现在。即摄在过去中。乃至若依现在说过去未来。即摄在现在中。有余师说。若依过去说未来现在。未来者摄在未来。现在者摄在现在乃至。若依现在说过去未来。过去者摄在过去未来者。摄在未来前说言依义为体故。问若于一时顿说二世。或复三世何言依摄。有作是说彼不摄在三言依中。复有说者随能显名。在何世摄。即说摄在彼世言依。有余师说。随所显义在何世摄。即说摄在彼世言依。前说言依义为体故。问契经但说有三种言依于义已足。何故复说无第四第五。答无第四者遮第四世。恐有执有第四世故。无第五者遮无为法。恐执无为是言依故。有说二言郑重遮止。欲令所说义决定故。契经依世建立言依故。说有三无四无五。若依如理作意建立言依。应说有一无第二第三。无第二者遮有第二如理作意。无第三者遮如理作意所不摄法。若依止观建立言依。应说有二无第三第四义如前说。若依三解脱门建立言依。应言有三无第四第五义如前说。若依四圣谛建立言依。应说有四无第五第六义如前说。若依五蕴建立言依。应说有五无第六第七义如前说。若依六随念建立言依。应说有六无第七第八义如前说。若依七等觉支建立言依。应说有七无第八第九义如前说。若依八圣道支建立言依。应说有八无第九第十义如前说。若依九次第定建立言依。应说有九无第十第十一义如前说。若依如来十力建立言依。应说有十无第十一第十二义如前说。如是若依余法建立言依应如理说。此经依世建立言依。故但说三无四无五。即此经中作如是说。应以四事观察补特伽罗。知彼具寿为可与语为不可与语。云何为四。一者处非处。二者智论。三者分别。四者道迹。若于此四善安住者。彼可与语。与此相违不可与语。问如是四事有何差别。答不善安住处非处者。谓不如实知是处非处。不善安住智论者。谓不如实知智及尔焰。不善安住分别者。谓不如实知世俗胜义。不善安住道迹者。谓不如实知趣苦集行及趣苦灭行。有说不善安住处非。处者。谓不如实知眼色为缘生眼识乃至意法为缘生意识是处耳等为缘生眼识。乃至眼等为缘生意识非处。不善安住智论者。谓不如实知十智差别。不善安住分别者。谓不如实知了义经及不了义经。不善安住道迹者。谓不如实知四种行迹。有说不善安住处非处者。谓不如实知有理无理。不善安住智论者。谓不如实知圣者正论。不善安住分别者。谓不如实知假设言论。不善安住道迹者。谓不如实知他言句义。前中后别而辄酬对。有说不善安住处非处者。谓不能如实立所立宗。不善安住智论者。谓不能堪受他所问难。不善安住分别者谓不善了知诡诳真实。不善安住道迹者。谓不能成办增上觉慧。有说不善安住处非处者。谓于自宗他宗。不善安住而有所说。不善安住智论者。谓不了知他以量为先有所诘难。不善安住分别者。谓不了知他前后次第相应言论。不善安住道迹者。谓不能满足所求胜事。有说不善安住处非处者。谓不善了知现非现量。不善安住智论者。谓于先所闻坚执不舍。不欲观察前后德失。不善安住分别者。谓于他正说心怀犹豫。如不能决是饭是酥。不善安住道迹者。谓不了知现比至教为先问难。胁尊者言。不善安住处非处者。谓于所知境不善了知。不善安住智论者。谓于能知智不善了知。不善安住分别者。谓于邪正教不善了知。不善安住道迹者。谓于邪正行不善了知。尊者僧伽筏苏说曰。不善安住处非处者。谓于多界经中所说。处非处义不善了知。不善安住智论者。谓于四十四智七十七智事不善了知。不善安住分别者。谓于杂染清净不善了知。不善安住道迹者。谓于趣色灭行乃至趣识灭行不善了知。与上相违名善安住

即此经中复作是说。应以四事观察补特伽罗。知彼具寿为可与语为不可与语。云何为四。一者应一向记问。二者应分别记问。三者应反诘记问。四者应舍置记问。若于此四如应记者彼可与语。与此相违不可与语。云何名应一向记问。此问应以一向记故。谓有问言如来应正等觉耶。法善说耶僧妙行耶。一切行无常耶。一切法无我耶。涅槃寂静耶。应一向记此皆如是。问何故此问应一向记。答此问能引义利能引善法。随顺梵行能发觉慧能得涅槃。是故此问应一向记。云何名应分别记问。此问应以分别记故。谓有请言为我说法。应告彼言法有多种。有过去有未来有现在。有善有不善有无记。有欲界系有色界系有无色界系。有学有无学有非学非无学。有见所断有修所断。有不断欲说何者。云何名应反诘记问。此问应以反诘记故。谓有问言为我说法。应反诘言法有众多。汝问何者众多法者。谓过去等如前广说。问应分别记论。应反诘记论有何差别。答答意虽无差别而问意有异。谓彼问者有为知解故问。有为触恼故问。若为知解故问。应告彼言法有多种。有过去有未来有现在广说乃至。有见所断有修所断有不断欲说何者。若言为我说过去法。应告彼言过去法亦有多种。有善有不善有无记欲说何者。若言为我说善法。应告彼言善法亦有多种。有色有受想行识欲说何者。若言为我说色法。应告彼言色法亦有多种。有离杀生乃至有离杂秽语欲说何者。若言为我说离杀生。应告彼言离杀生有三种。谓从无贪生。从无嗔生。从无痴生。欲说何者。若言为我说从无贪生。应告彼言无贪生者复有二种。谓表无表欲说何者。若为知解故发问者。则应如是分别而答。若为触恼故问。应反诘言法有众多汝问何者不。应为说有过去乃至有不断。若言为我说过去法。应反诘言过去法多汝问何者不。应为说善不善无记。若言为我说善法。应反诘言善法亦多汝问何者不。应为说色乃至识。若言为我说色法。应反诘言色法亦多汝问何者不。应为说离杀生乃至离杂秽语。若言为我说离杀生。应反诘言离杀生亦多汝问何者不。应为说从无贪生乃至从无痴生。若言为我说从无贪生应反诘言从无贪生亦有众多汝问何者不。应为说表及无表。若为触恼故发问者。则应如是总相反诘。令彼问尽或令自答。如有为知解故问。有为触恼故问。如是有为求善故问。有为试他觉慧浅深故问。有为求义故问。有为摧他故问。有质直故问。有谄曲故问。有柔和故问。有憍傲故问应知亦尔。如是名为分别反诘。二论差别。云何名应舍置记问。此问应以舍置记故。谓有外道来诣佛所。白佛言。乔答摩。世间常耶乃至广说。四句世间有边耶乃至广说四句。世尊告曰。皆不应记。问何故世尊不答此问。答彼诸外道执有实我名为世间。来诣佛所作如是问。佛作是念实我定无。若答言无彼当作是言。我不问有无。若答言常或无常等。便不应理实我本无。如何可说常无常等。如有问他此石女儿。恭敬孝顺及爱语不。彼作是念石女无儿。若答言无彼当作是言。我不问有无。若我答言恭敬孝顺及爱语者。便不应理石女无儿。如何可说有恭敬等。此亦如是所问。非有非真非实不应道理故佛不答。复有外道来诣佛所。白佛言乔答摩。命者即身为异身耶。世尊告曰。俱不应记问。何故世尊不答此问。答彼诸外道执有实我名为命者。来诣佛所作如是问。佛作是念。实我定无。若答言无彼当作是言。我不问有无。若我答言即身。或异便不应理。实我本无。如何可说与身一异。如有问他兔角牛角为相似不。彼作是念兔角本无。若答言无。彼当作是言。我不问有无。若我答言相似或不相似。便不应理。兔角本无。如何可说与牛角相似不相似耶。此亦如是所问。非有非真非实。不应道理故佛不答。复有外道来诣佛所白佛言。乔答摩。如来死后为有为无乃至四句。世尊告曰。皆不应记。问何故世尊不答此问。答彼诸外道执有实我名为如来。彼执此我本无。而有问。佛死后为有为无乃至广说。佛作是念。如是本无今有。实我毕竟无体。若答此我今尚是无。彼当作是言。我不问今有无。若我答言死后有等便不应理。如是实我今尚是无。如何可说死后有等。所问非有非真非实。不应道理故佛不答。复有外道来诣佛所白佛言。乔答摩。自作自受耶。世尊告曰此不应记。问何故世尊不答此问答彼诸外道执有实我自作自受。佛说无我故不应答义如前说。彼复问言他作他受耶。世尊告曰此不应记。问何故世尊不答此问。答彼诸外道执有实我名自在天等。彼能作我受果。佛说无我故不应答义如前说。彼复问言自他作自受耶。世尊告曰此不应记。问何故世尊不答此问。答彼诸外道执有实我名为自他。佛说无我故不应答义如前说。彼复问言非自他作无因而生。无作无受耶。世尊告曰此不应记。问何故世尊不答此问。答世尊常说果从因生。自作自受故不应答。问何故于彼外道诸问应舍置耶。答彼问不引义利不引善法。不顺梵行不发觉慧不得涅槃。是故彼问皆应舍置。问前三有答可名为记。第四无答云何名记。答佛虽告言此不应记。而实已与答理相应。是根本答故亦名记。令彼问者得正解故。或有默然于理得胜。况酬彼问而非记耶。昔有外道名扇帙略。聪明广学。是大论师为论议故。来入迦湿弥罗国。尔时此国有阿罗汉名筏素罗。三明六通具八解脱。学穷内外恒住波利质呾罗林中。时扇帙略为捔论故。来诣其所共相问讯。种种慰劳在一面坐。白言苾刍。欲相捔论。尊者与我谁先立宗。筏素罗言我是旧住应先立宗。但汝远来稍当疲倦随意先立。时扇帙略便立宗言。一切立论皆有报答。觉慧若尽其论乃穷。时筏素罗默然而住。彼扇帙略与诸弟子欢喜而起唱如是言。今此苾刍已堕负处。时筏素罗告彼弟子。汝师若是扇帙略者。不久当悟谁堕负处。彼诸弟子闻之嗤笑随逐其师。从林而出。时扇帙略寻即思惟。何故沙门作如是说乃便自悟。我立论言一切立论皆有报答。苾刍默然是我堕负深生惭赧。告弟子言吾所立论今已堕负。可与汝等驰还忏谢。弟子白言何名堕负。时扇帙略具为述之。弟子报言。已对大众得胜而来。何须复往忏谢取辱。其师报曰。我宁于智者边。受劣不能于愚者边取胜。即与弟子还入林中。到尊者所顶礼双足。作如是言尊者得胜。我已堕负尊者是师我是弟子。从今以后请常教诲。如是默然于理得胜。况酬彼问而不名答。是故四种皆名为记

说一切有部发智大毗婆沙论卷第十五阿毗达磨大毗婆沙论卷第十六

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中智纳息第二之八

如佛世尊诃诸弟子。称言痴人乃至广说。问何故作此论。答欲令疑者得决定故。谓佛世尊爱恚永断违顺平等。拔诤论根灭憍慢本。视诸珍宝犹如瓦砾。于一切法觉照无遗。无相似爱及恚慢等。诸烦恼习已永断故。非如独觉及诸声闻。虽断烦恼而有余习。贪爱习者如尊者阿难。怜诸释种嗔恚习者如尊者毕陵伽筏蹉。语殑伽神言小婢止流吾今欲渡。憍慢习者如尊者舍利子弃掷医药。愚痴习者如尊者笈房钵底。食前咳气知食未销不知后苦。而复更食。如是等事其类甚多。世尊虽无烦恼余习。而或时有似爱等言。似爱言者如世尊说善来苾刍。能善出家犹具禁戒。似恚言者如世尊说。汝是释种婢子释种是汝大家。似慢言者如世尊说。我是如来应正等觉。成就十力得四无畏。似痴言者如世尊说。大王今者从何处来。告阿难言看天雨不。园中何故高声大声。或有生疑世尊已断诸烦恼习。云何复有如是等类似烦恼言。欲令彼疑得决定解故作斯论。释其因缘如此痴言彼亦尔故。问何故佛说似爱等言。答护所化田饶益彼故。谓世尊说似爱言者。欲令天授所破苾刍身心安隐及除疑故。谓提婆达多贪名利故破坏僧已。尊者舍利子及大目干连化使还来。彼诸苾刍深生羞耻。身心战掉复生疑惑。我随天授不失戒耶。闻世尊说善来苾刍能善出家犹具禁戒。战掉疑惑二事皆除。若佛尔时不作此语。彼怀愧恼吐血命终。又世尊说似恚言者。摧彼梵志憍慢幢故。谓彼梵志庵婆瑟吒。不量母卑而怀憍傲。障他出家当堕恶趣。由佛诃彼傲佷心摧。次第二身得生天上见四圣谛。又由诃彼补色羯罗娑利梵志。得入佛法逮殊胜果。又世尊说似慢言者。为令不知佛功德者知已归依修胜行故。又世尊说似痴言者。为开彼王谈论道故。为解阿难睡闷心故。又欲生彼乐静心故。佛说此等似烦恼言。皆为有情获利乐故。今诃弟子称言痴人。亦为利生如后当说。问何缘独觉及诸声闻。虽断烦恼而有余习佛不尔耶。答声闻独觉慧不猛利。虽断烦恼而有余习。如世常火虽有所烧而余灰烬。佛慧猛利断诸烦恼令无余习。如劫尽火随所烧物无余灰烬。由前所说种种因缘故作斯论

如佛世尊诃诸弟子。称言痴人此有何义。答是诃责语。谓佛世尊诃责弟子称言痴人。如今亲教及轨范师。若有近住依止弟子。起诸过失便诃责言。汝为愚痴不明不善世尊亦尔。诃诸弟子称言痴人。此中论文总有二分。一者释佛诃弟子义。二者释佛诃彼因缘。前所举文即是初分。如今亲教及轨范师。为遮弟子所起过失。或如父母遮防子过。有所诃责皆为饶益。无有恶心佛亦如是。谓佛所化略有四种。一宜赞叹。二宜诃责。三宜舍置。四宜因他。宜赞叹者。如佛赞叹俱胝耳等。宜诃责者。如佛诃责邬陀夷等。宜舍置者。如置无衣迦叶波等。如佛告彼婆罗门言。今非其时未可答汝。宜因他者。如佛为五苾刍转正法轮。尔时八万诸天皆得圣道。佛为频毗婆罗王说法。尔时亦有八万诸天。及摩揭陀九万二千人皆得圣道。佛为帝释说法。尔时亦有八万诸天得入圣道。佛为罗怙罗说法。尔时亦有六万诸天一时得道。诸如是等其类甚多。是故世尊应以诃责。而入道者必诃责之。有说。世尊大悲所逼故。常求觅利他方便。若不诃骂提婆达多汝是愚痴食涕唾者。则引无量愚痴众生作诸恶事。又复数数触恼世尊。若不毁呰无比女人。汝身秽恶不净充满。即彼欲心无由止息。故诃弟子称言痴人。有说世尊所以诃责诸弟子者。欲使未种善根者能种善根。已种善根未成熟者速能成熟。若已成就未解脱者速得解脱。若不诃责失此善利。故佛为此称言痴人。问言痴人者是何义耶。为从痴生故说为痴人。为现行痴故说为痴人。设尔何失。若从痴生故名痴人者。亦从贪恚慢见等生。世尊何故唯言痴人。若现行痴故名为痴人。契经不应说阿罗汉亦名痴人。如契经说远去痴人勿我前住。又世尊责邬陀夷言。痴人无眼云何乃与上座苾刍竞甚深义。又余烦恼亦有现行。何故唯说痴人非余。有作是说。从痴生故名为痴人。问若尔亦从贪恚慢见等生。世尊何故唯言痴人。答痴遍行故。若佛知诃阿罗汉等以为痴人。于物有益即亦诃彼阿罗汉身亦痴生故。如契经说。无明所覆爱结所系。愚夫感得有识之身智者亦尔。阿罗汉等说为智者。有余师说。现行痴故名为痴人。问若尔契经不应说阿罗汉亦名痴人。答且契经说远去痴人勿我前住者。是诵者谬诵应如是说。远去苾刍勿我前住。世尊临欲般涅槃时。尊者白净在佛前住以扇扇佛。时有无量长寿诸天来诣佛所。嫌彼尊者当佛前住遮蔽我等。不见世尊而使我等失最后利。佛知彼意便作是言。远去苾刍勿我前住。又世尊责邬陀夷言。痴人无眼云何乃与上座苾刍竞甚深义者。亦不相违以邬陀夷尔时未得阿罗汉果。或言异生或言有学。有余师说。阿罗汉等亦现行痴。不染无知犹未断故。问诸余烦恼亦有现行。何故唯说痴人非余。答前已说言痴遍行故。随起何地无明现前。则痴人名依彼而立。由此义故佛诃弟子称言痴人

何故世尊诃诸弟子称言痴人。答彼于世尊教诫教授。不随义行不随顺不相续。此下论文即第二分。释佛诃彼痴人因缘。教诫教授总显佛语。能正行者名随义行。彼诸弟子不能正行故名不随义行。有说。如应行者名随义行。彼诸弟子不如应行故名不随义行。不随顺者于佛圣教不能随顺修功德故。不相续者不能长时流注相续修功德故。问教诫教授有何差别。答遮无利益故名教诫。与有利益故名教授。复次教住正念故名教诫。教住正知故名教授。复次令修有表故名教诫。令修无表故名教授。复次令修奢摩他故名教诫。令修毗钵舍那故名教授。复次令修圣道故名教诫。令得圣果故名教授。复次令修世间善法故名教诫。令修出世善法故名教授。是谓教诫教授差别。复次彼于圣教作愚痴事。空无有果无出无味无有胜利。违越佛教于诸学处不能受学。故佛诃彼称言痴人此中圣教意显圣道。问彼云何于圣道作愚痴事耶。答彼不能令圣道成愚痴事。但彼相续增长愚痴障碍圣道。有说亦令圣道成愚痴事。谓令成远不得自在不现行故。有说。为断愚痴佛说圣教。彼闻圣教不断愚痴转更增长。是故说彼于佛圣教作愚痴事。空者显彼无圣道胎。如女身中不任怀孕。空无子故说名石女。彼亦如是。虽闻佛教不能摄受圣道胎故。佛于彼身无士用果。虚弃功用故名为空。无有果者无有等流及解脱果。无出者无士用果。复次出者谓得彼于佛法无所得故说名无出。无味者彼于佛法无出家味无寂静味。无圣道味无寂灭味故名无味。无胜利者果名胜利。彼不得果故无胜利。复次有二失故名无胜利。譬如良医愍诸有疾四方求药。得已与之病者轻贱投之粪壤。彼有二失。一者自疾不得除愈。二者良医功为虚弃。世尊亦尔。三无数劫修习百千难行苦行。为诸有情求圣法药。得已为说彼闻轻贱不自服行用求名利。彼有二失。一者不除自烦恼病。二者令佛唐捐其功。违越佛教者违越世尊圣教理趣。于诸学处不能受学者。不能修行法随法行。复次彼于圣教作愚痴事者。彼断圣教不令相续故。谓佛为彼说无上法。若闻正行转为他说他。复正行更为余说。如是展转饶益无穷。乃名如来圣教不绝。彼闻圣教不能正行。亦复不能转为他说自既无益复不利他。名断圣教不令相续。由此说名作愚痴事。空者自身非法器故。无有果者令佛期心无有果故。谓佛欲令众生闻法脱生死苦。彼闻法已不能修行离苦方便。是故令佛期心无果。无出者彼不能得本出家时所求胜事谓净持戒。无味者无静虑味。无胜利者无无倒慧。违越佛教者谓不得涅槃。佛为众生得涅槃乐说正法教。彼不能证故名违越。于诸学处不能受学者。佛所施设种种学处不能受学。有虽受学不能恒修。如婆柁梨过雨四月方能受学。一坐食法有虽恒修而不圆满。俱名不能受学学处。由此因缘佛诃弟子称言痴人

有六因谓相应因乃至能作因。问何故作此论。答为止无因恶因论故。谓诸外道或执诸法无因而生。或复执有不平等因。为止彼意显诸法生决定有因非不平等。有作是说有执因缘非实有物如譬喻者。为止彼意显示因缘。若性若相皆是实有。复有说者欲以六因显示四果。令其明了如观掌内阿摩洛迦。谓以相应俱有二因显士用果。以同类遍行二因显等流果。以异熟因显异熟果。以能作因显增上果。由此因缘故作斯论。然此六因非契经说。契经但说有四缘。性谓因缘性广说乃至增上缘性。今欲以因分别缘故说此六因。问为因摄缘缘摄因耶。答互相摄随其事。谓前五因是因缘能作因是余三缘。有作是说缘摄因非因摄缘。谓前五因是因缘能作因。是增上缘。等无间缘。及所缘缘非因所摄。复有说者六因亦是契经所说。谓增壹阿笈摩增六中说。时经久远其文隐没。尊者迦多衍尼子等。以愿智力观契经中说六因处。撰集制造阿毗达磨。是故于此分别六因。曾闻增壹阿笈摩经。从一法增乃至百法。今唯有一乃至十在余皆隐没。又于增一乃至十中。亦多隐没在者极少。曾闻尊者商诺迦衣大阿罗汉。是尊者阿难陀同住弟子。是大德时缚迦亲教授师。彼阿罗汉般涅槃时。即于是日有七万七千本生经一万阿毗达磨论隐没不现。一论师灭尚有尔所经论隐没。况从彼后迄至于今。若百若千诸论师。灭经论随没数岂可知。故此六因是契经说。有余师说如是六因。虽无一经。次第具说。然于诸经处处散说。谓契经说是名见为根信证智相应。如是等经说相应因。又契经说。眼及色为缘生眼识三和合故。触俱起受想思如是等经说俱有因。又契经说。如是补特伽罗成就善法及不善法。善法隐没恶法出现。有随俱行善根未断以未断故。从此善根犹有可起余善根义。彼于当来有清净法。如是等经说同类因。又契经说。诸邪见者。所有身业语业意业。诸有愿求皆如所见。所有诸行皆是彼类如是诸法皆悉能招非欣爱乐不可意果。如是等经说遍行因。又契经说无处无容身语意恶行受可爱异熟。有处有容彼受不可爱异熟。如是等经说异熟因。又契经说。二因二缘能生正见。谓他音声及内如理作意。如是等经说能作因。故此六因是佛所说。是故尊者依经作论

云何相应因乃至广说。问何故作此论。答为止他宗显正理故。谓或有执心心所法。前后而生非一时起。如譬喻者。彼作是说。心心所法依诸因缘前后而生。譬如商侣涉崄隘路。一一而度无二并行。心心所法亦复如是。众经和合一一而生。所待众缘各有异故。阿毗达磨诸论师言。心心所法有别因故。可说众缘和合有异有别因故。可说众缘和合无异。谓心心所各各别。有生住异灭和合而生。是故可说和合有异。同依一根同缘一境而得生故。可说一切和合无异。是故一切心心所法。随其所应俱时而起。或复有执诸法各与自性相应非与他性。彼作是说相喜乐义是相应义。无法与法共相喜乐。犹如自性与自性者。阿毗达磨诸论师言。二事和合可说相应。非于一物有相应义。亦无自体喜乐自体。能缘所缘有差别故。或复有执自性于自性非相应非不相应彼作是说要与他合方名相应。自于自性无他义故不名相应。互相喜乐是相应义。自于自性深喜乐故非不相应。阿毗达磨诸论师言。无有自性喜乐自性义如前说

或复有执。力任持义是相应义。彼作是说若法由彼法力任持生。此法与彼法相应。是故心与心相应心力持心令得生故。心所法与心相应。心力持彼令得生故。心不与心所法相应。非彼力持而得生故。心所法不与心所法相应。非互相持而得生故。阿毗达磨诸论师言。心与心所心所与心。心所皆展转力持而得生故。更互相应一身二心不并起故。无相应义。为遮此等种种异执。显示正理故作斯论。云何相应因。答受与受相应法为相应因。受相应法与受为相应因想思触作意欲胜解念三摩地。慧与慧相应法为相应因。慧相应法与慧为相应因。是谓相应因。问此中何故不说心耶。答是作论者意欲尔故乃至广说。或有说者。亦应说心而不说者。应知此中是有余说。说六因义皆不尽故。若作尽理无余说者。应作是说。云何相应因。谓一切心心所法。云何俱有因。谓一切有为法。云何同类因。谓一切过去现在法。云何遍行因。谓一切过去现在遍行随眠。及彼相应俱有法。云何异熟因。谓一切不善及善有漏法。云何能作因。谓一切法。有作是说设作是说亦不尽理。不知何位谁与谁为因故。若说此中是有余说于理为胜。诸作论者略标少法为根本故。有余师说。心已说在此所说中。谓受相应慧相应法亦摄心故。问何故不说心之自相。答平等相似是相应义。心胜如王是故不说。如伽他言

  第六增上王　　染时染自取
  不染而有染　　染者谓愚夫

复有说者。以三摩地。有说即心说三摩地。即已说心故不别说。问何故但说十大地法。为相应因非余法耶。答是作论者意欲尔故乃至广说。有说应说而不说者当知此义有余。有说若法一切界一切地一切趣。一切生一切种一切心。可得者此中说之。余法不尔故此不说。问大地法是何义。答大者谓心如是十法。是心起处大之地故名为大地。大地即法名大地法。有说心名为大体用胜故。即大是地故名大地。是诸心所所依处故。受等十法于诸大地。遍可得故名大地法。有说受等十法遍诸心品故名为大。心是彼地故名大地。受等即是大地所有名大地法。问何故名心所。答是心所有故。问何故心心所法展转为相应因。答展转为因故。展转力生故。展转相引故。展转相养故。展转相增故。展转相依故。如二芦束相依而住。多绳相合能牵大木。多人连手能渡大河。有为诸法性羸劣故。展转相依方办事业义。问受言汝若离想能纳境耶。答言不能。余心心所为问亦尔。问相应因以何为自性。答一切心心所法即摄三蕴一蕴少分。一处一处少分七界一界少分。已说自性所以今当说。问相应是何义。答等义是相应义。问诸心所法或多或少。谓善心多不善心少。不善心多有覆无记心少。有覆无记心多无覆无记心少。欲界心多色界心少。色界心多无色界心少。有漏心多无漏心少。云何等义是相应义。答依体等义说名为等。若一心中二受一想可不名等。然一心中一受一想余亦如是。故说等义是相应义。复次等不相离是相应义。复次等不别异是相应义。复次等运转义是相应义。如车转时众分皆转共办一事。如是心车于境转时。心所亦转共成一事故名相应。复次等所作义是相应义。如秋鸽等一时诣场一时食一时起。非前非后心心所法亦复如是。一时趣境一时受境一时舍境故名相应。复次等相顺义是相应义。如人相顺即名相应。心心所法相顺亦尔。复次等和合义是相应义。如水乳合说名相应。心心所法和合亦尔。雾尊者曰。四事等故说名相应。一时分等谓心心所同一刹那而现行故。二所依等谓心心所同依一根而现行故。三所缘等谓心心所。同缘一境而现行故。四行相等谓心心所。同一行相而现行故

复次五事等故说名相应。即前四事及物体等。谓心心所各唯一物。和合而起故名相应。复次如束芦义是相应义。如一一芦不能独立。要多共束方能得住。心心所法亦复如是。要多相依方能行世。取果与果及取所缘。复次如合索义是相应义。如一一缕不能牵材木。多缕相合乃有牵用。心心所法亦复如是。广如前说。复次如连手义是相应义。如河漂急独不能渡。多人连手乃能渡之。心心所法亦复如是。广如前说。复次如商侣义是相应义。如多商人共为伴侣能过险路。心心所法亦复如是广说如前。尊者世友作如是说。相引生义是相应义。问若尔眼识意识亦互相引彼相应耶。答彼所依异若同所依互相引者乃是相应。复次不相离义是相应义。问若尔四大种亦不相离彼相应耶。答彼无所依。若有所依亦不相离乃是相应。复次有所缘义是相应义。问若尔六识皆有所缘彼相应耶。答彼所依异。若同所依有所缘者乃是相应。复次同所缘义是相应义。问若尔五识各与意识同一所缘应说相应。又多眼识应说相应。如多有情共观初月等。答彼所依异。若同所依同所缘者。乃是相应。复次常和合义是相应义。问若尔寿暖识三亦常和合彼相应耶。答不尔寿暖二法无所依故。若有所依亦常和合乃是相应。复次恒俱生义是相应义。问若尔四大种恒俱生彼相应耶。答彼无所依若有所依。恒俱生者乃是相应。复次俱生住灭是相应义。问若尔随心转色随心转心。不相应行亦俱生住灭彼相应耶。答彼无所依。若有所依俱生住灭乃是相应。复次同一所依同一所缘。同一行相转义是相应义。问云何知然。答宁知不然。复次同作一事义是相应义。问若尔诸忍与智同作一事彼相应耶。答彼不俱生。若俱时生同作一事乃是相应。大德说曰。同伴侣义是相应义。识与心所互相容受俱时而生。同取一境乃是相应。尊者妙音作如是说。所依所缘行相所作一切同义是相应义。所以者何。诸有为法性羸劣故。展转力持方能起作。曾不见有一大地法。独起作故。此相应因。定通三世有士用果

云何俱有因乃至广说。问相应俱有二因何异。有说无异。一刹那受与想等法为二因故。是故于此应作是说。若相应因即俱有因。有俱有因非相应因。谓不相应俱有因是。如是说者二因有异。虽依一法而义别故。问若尔二因有何差别。答名即差别谓名相应因名俱有因。复次为伴侣义是相应因。同一果义是俱有因。复次同一所依一行相一所缘义是相应因。同一生一老一住一灭一果一等流一异熟义是俱有因。复次如执杖义是相应因。如执杖已有所作义是俱有因。复次如连手义是相应因。如连手已渡暴河义是俱有因。复次相随顺义是相应因。不相离义是俱有因。云何俱有因。答心与心所法为俱有因。心所法与心为俱有因。问何故前相应因中不说心。今俱有因中即说心耶。答平等义是相应因义。心王是胜与心所法。等义不显故不说心。办一事义是俱有因义。心心所法办事义同故今说心。此中心者即一切心。心所法者亦一切心所法。如其所应展转为俱有因。心与随心转身业语业为俱有因。随心转身业语业者。谓静虑律仪无漏律仪。问何故此中不说随心转身业语业与心为俱有因耶。答是作论者意欲尔故乃至广说。有说。应说而不说者当知此义有余。前说此中所说因义皆不尽故。有说。此中初后广说中间略说。义准可知是故不说。有余师说心于随心转身语业能为因。不随其事转以是胜故。随心转身语业于心随其事转。不能为因以是劣故。如王于臣能与爵禄不随其事转。臣于王随其事转。不能与爵禄此亦如是。评曰。心与随心转身语业展转为俱有因。所以者何。同一果故办一事故。问若尔此中何故不说。答由前说三因故

心与随心转。不相应行为俱有因。随心转不相应行与心为俱有因。问何等随心转不相应行。与心展转为因耶。答心心所法及随心转身语业生老住无常与心展转为因。此中有说。心与自生老住无常为俱有因。唯自生住与心为俱有因。非老无常以能增益说名为因。老与无常衰灭法故不名为因。有说心与自生老住无常为俱有因。自生老住无常与心为俱有因。皆互相助办一事故。有说心与心心所法及随心转身语业。生老住无常为俱有因。唯心生老住无常。与心为俱有因非余生等。评曰。应作是说。心与心心所法及随心转身语业。生老住无常展转为俱有因。云何知然品类足说。云何心俱有因法。谓一切心所法道俱有戒定俱有戒。及心彼诸法生老住无常。问若尔品类足说复云何通。如说或有苦谛以有身见为因。非与有身见为因。谓除过去现在见苦所断随眠。及彼相应苦谛。除过去现在见集所断遍行随眠。及彼相应苦谛。除未来有身见相应苦谛。除未来有身见生老住无常。诸余染污苦谛。答品类足论应作是说。除过去现在见苦所断随眠。及彼相应俱有等苦谛。除过去现在见集所断遍行随眠。及彼相应俱有苦谛。除未来有身见相应苦谛。除未来有身见及彼相应法。生老住无常诸余染污苦谛。应作是说而不说者。当知彼是有余之说

复次俱生四大种展转为俱有因。是谓俱有因。此中有欲令四大种体无偏增者。彼作是说地大种与三大种为俱有因。三大种与地大种为俱有因。乃至风大种亦尔。有说令四大种体有偏增者。彼作是说。地大种与四大种为俱有因。四大种与地大种为俱有因。所以者何。地大种有多体。于中一与多为俱有因。多与一为俱有因故。乃至风大种亦尔。评曰。应作是说。四大种体若有偏增若无偏增。地为三俱有因。三为地俱有因。所以者何。地不观地生所造色。以一切法不观自性及同类体为他因故。乃至风大种亦尔。问未生四大种亦是俱有因不。答亦是俱有因堕因义故。有因相故。有说彼非俱有因。此中但说俱生。四大种展转为俱有因故。评曰。应作是说。生未生四大种皆展转为俱有因。此中生言说可生义。或生相合如品类足说。云何因所生法。谓一切有为法。如彼生言说生未生此亦如是。问所造色为有俱有因不。答有一切有为法。皆有生等相为俱有因故。问所造色与所造色为俱有因不。答有为俱有因。如随心转所造色。问有对造色与有对造色为俱有因不。答无。有说。亦有如眼根等。有多极微俱生展转为俱有因。评曰。彼不应作是说。如前说者好。所以者何。同一果义是俱有因义。彼非同一果故。然一切心皆有随转。诸心所法及生等相。非一切心皆有随转身语业色。随心转义总有十种。谓一起一住一灭一果一等流一异熟。善则善不善则不善。无记则无记随一世中。一果者谓离系果。一等流者谓等流果。一异熟者谓异熟果。随法别说此十多少根蕴当说。问随转自性是何。答四蕴五蕴。欲界无色界四蕴无随转色故。色界五蕴有随转色故。已说自性所以今当说。问何故名随转。答相随顺义是随转义。相摄益义是随转义。办一事义是随转义。随心转法义语心言汝所作事。我亦作之心心所法展转相望。由五事故说名随转。谓所依故所缘故。行相故果故异熟故。心与随心转色心不相应行。展转相望由二事故说名随转。谓果故异熟故

说一切有部发智大毗婆沙论卷第十六阿毗达磨大毗婆沙论卷第十七

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中智纳息第二之九

问身语业何等随心转。何等不随心转耶。答色界戒及无漏戒随心转。欲界戒及余身语业不随心转。问何故欲界戒不随心转耶。答欲界于彼随心转戒。非田非器乃至广说。复次欲界非定界非修地非离染地故。无如是道戒可随转。色界是定界是修地是离染地故。有如是道戒可随转。复次欲界戒义。问欲界心言汝能为我。断破戒及起破戒烦恼不若能者我随汝转欲界心义。答欲界戒言我不能戒义。言若不能我何为随汝转如人怖怨。问他人曰。汝能为我作救护不。若能者当依止汝随汝而转他。答不能彼便语言汝若不能。我何为依止。汝随汝转此亦如是。问色界善心一切皆有随转戒不。答非一切有。谓初静虑有六善心无随转戒。一善眼识。二善耳识。三善身识。四死时善心。五起表善心。六闻所成慧相应善心。第二第三第四静虑。有二善心无随转戒。谓死时善心及闻所成心。问何故无色界无随转戒耶。答彼界于戒非田非器乃至广说。复次戒是色一分摄。彼界无色故亦无戒。复次戒是大种所造。彼无大种故亦无戒。问如虽无无漏大种而有无漏戒。如是彼界虽无大种何妨有戒耶。答无漏戒非大种力故成无漏。但由心力随无漏心所等起故。有漏戒由大种力系属界地故不相似。复次戒者对治破戒及起破戒烦恼。无色界道不能对治。破戒及起破戒烦恼故彼无戒。问因论生论何故无色界道。不能对治破戒及起破戒烦恼耶。答彼唯欲界。无色于欲有四事远故无对治。四事远者。一界地远。二所依远。三所缘远。四对治远。问若尔第二第三第四静虑。亦无破戒及起破戒烦恼。对治彼应无戒。答对治有二种。一断对治。二厌坏对治。上三静虑于破戒及起破戒烦恼。虽无断对治而有厌坏对治。如世尊说。圣弟子入不动心解脱。能断不善修习善法。非彼身中犹有不善可断。然依过患对治故作是说。无色界于破戒及起破戒烦恼。无断对治亦无厌坏对治是故无戒

随心转戒总有二种。一道俱有戒。二定俱有戒。道俱有戒者谓无漏戒。定俱有戒者谓色界戒。若是道俱有戒彼非定俱有戒。若是定俱有戒彼非道俱有戒。有作是说道俱有戒谓无漏戒。定俱有戒谓一切有漏无漏随心转戒。彼作是说。一切道俱有戒皆是定俱有戒。或是定俱有戒而非道俱有戒。谓有漏随心转戒。有余师说。道俱有戒谓无漏戒。定俱有戒谓根本静虑有漏无漏戒。依如是说应作四句。有是道俱有戒非定俱有戒。谓近分地诸无漏戒。有是定俱有戒非道俱有戒。谓根本地诸有漏戒。有是道俱有戒亦是定俱有戒。谓根本地诸无漏戒。有非道俱有戒亦非定俱有戒。谓近分地诸有漏戒。彼师依得复作四句。有得道俱有戒非定俱有戒。谓未离欲染入正性离生十六心顷。若已离欲染依未至定入正性离生。见道十五心顷。若诸圣者为离欲染起加行道。九无间道八解脱道。若未离欲染信胜解炼根。作见至所有加行。无间解脱道。若诸圣者未离欲染依未至定。起无量不净观持息念及念住等。如是等时得道俱有戒非定俱有戒。有得定俱有戒非道俱有戒。谓诸异生离欲染一切最后解脱道。即彼为离初静虑染依初静虑起加行道。及一切最后解脱道。即彼为离第二静虑染依第二静虑起加行道。及一切最后解脱道。即彼为离第三静虑染。依第三静虑起加行道。及最后解脱道。即彼为离第四静虑染。依第四静虑起加行道。若诸异生依根本静虑。引发诸通起加行道。五无间道三解脱道。若起无量不净观持息念念住暖顶忍世第一法。初三解脱八胜处前八遍处。及无色界殁生色界时。色界上地殁生下地时。如是等时。得定俱有戒非道俱有戒。有得道俱有戒亦得定俱有戒。谓已离欲依未至定。入正性离生道类智时。若依上地入正性离生十六心顷。若诸圣者离欲染最后解脱道。即彼为离初静虑乃至非想非非想处染。诸加行道九无间道九解脱道。已离欲染信胜解练根。作见至所有加行无间解脱道时。解脱阿罗汉练根作不动诸加行道。九无间道九解脱道。若杂修初静虑乃至第四静虑时。若诸圣者引发诸通起加行道。五无间道三解脱道。若诸圣者已离欲染依未至定。等起无量解脱胜处遍处。不净观持息念及诸念住。若起无碍解边际定无诤愿智。空空无愿无愿无相无相想微细心。如是等时得道俱有戒亦得定俱有戒。有不得道俱有戒亦不得定俱有戒。谓诸异生为离欲染。起加行道九无间道八解脱道。依未至定静虑中间起暖顶忍世第一法。若诸异生依第二第三第四静虑近分。为离初第二第三静虑染。起加行道九无间道八解脱道。若诸异生依空无边处乃至非想非非想处近分。为离第四静虑乃至无所有处染。起加行道九无间道九解脱道。若诸异生未离欲染。或已离欲染。依未至等诸近分定。或无色定起无量解脱胜处遍处。及不净观持息念并念住等诸功德时。若诸圣者依未至等诸近分定。起有漏无漏成就诸功德时。依无色定起有漏无漏成就诸功德时。一切不定及无心位如是等时。不得道俱有戒亦不得定俱有戒。彼师依舍复作四句。有舍道俱有戒非定俱有戒。谓得预流果或一来果。或渐次者得不还果。未离欲染信胜解练根。得见至从一来果一来胜果道。及预流果预流胜果道退时。从预流果退时者。谓从练根所得果退。如是等时舍道俱有戒非定俱有戒。有舍定俱有戒非道俱有戒。谓诸异生从离欲染。乃至从离第三静虑染退。若诸异生及诸圣者。欲色界殁生无色界。若色界殁生欲界。若诸异生从根本地胜功德退。如是等时舍定俱有戒非道俱有戒。有舍道俱有戒亦舍定俱有戒。谓诸圣者从离欲染。乃至从离非想非非想处染退。若依四静虑及静虑中间得不还果。若得阿罗汉果已离欲染。信胜解练根得见至时。解脱阿罗汉练根得不动。从不还果不还胜果道。及阿罗汉果阿罗汉胜果道退时。如是等时舍道俱有戒亦舍定俱有戒。有不舍道俱有戒亦不舍定俱有戒。谓除前相诸余位。彼依成就复作四句。有成就道俱有戒非定俱有戒。谓未离欲染圣者。有成就定俱有戒非道俱有戒。谓诸异生生欲界已离欲染。若诸异生生色界有俱成就。谓诸圣者生欲界已离欲染。若诸圣者生色无色界有俱不成就。谓诸异生未离欲染。若诸异生生无色界。依不成就亦作四句。谓次前第二句为今第一句。次前第一句为今第二句。次前第四句为今第三句。次前第三句。为今第四句。一切律仪总有四种。一别解脱律仪。二静虑律仪。三无漏律仪。四断律仪。别解脱律仪者谓欲界戒。静虑律仪者谓色界戒。无漏律仪者谓无漏戒。断律仪者谓离欲界染。九无间道中所有静虑无漏戒广说。此四律仪。如业蕴害生纳息

暖随转戒。于破戒为舍对治持对治远分对治。顶忍世第一法见道修道中。道类智随转戒于破戒。但为持对治远分对治。离欲界染加行道随。转戒于破戒为舍对治持对治远分对治。初无间道随转戒于破戒。但为持对治远分对治。于起破戒烦恼。但为断对治舍对治。七无间道随转戒于破戒。但为持对治远分对治。于起破戒烦恼。为断对治舍对治持对治远分对治。第九无间道随转戒于破戒。为断对治持对治远分对治。于起破戒烦恼。为断对治舍对治持对治远分对治。九解脱道随转戒及余。后时乃至尽智无生智。无学正见随转戒。于破戒及起破戒烦恼。但为持对治远分对治。问法智品道能断破戒及起破戒烦恼。可有随转戒。类智品道无此功能。云何亦有随转戒耶。尊者世友说曰。类智品道于彼虽无断对治舍对治。而有持对治远分对治故。复次法智品道与类智品道展转为因。展转相续展转相属展转相生故。有余师说。类智品道。亦能断破戒及起破戒烦恼。然法智品道先断彼故。今无所断故亦有随转戒。譬如多人共一怨家一人已害。余无所害非无害能此亦如是。大德说曰。若法智品道有随转戒。类智品道无随转戒者则应律仪。唯于能处转不于不能处转。然诸律仪通于能处不能处转。是故法智类智品道俱得有随转戒。问欲界色界何者戒多。有作是说欲界戒多。所以者何。欲界戒于根本业道及加行后起处得。色界戒唯于根本业道处得。欲界戒离性罪及离遮罪故得。色界戒唯离性罪故得。如是说者色界戒多。所以者何。且未至定所摄戒尚多欲界。有无量功德对治彼故。况复更有上地余戒。问有漏无漏何者戒多。有作是说。有漏戒多。所以者何。有漏戒摄二律仪一律仪少分无漏戒摄一律仪一律仪少分。复次有漏戒摄二界一界少分二处一处少分。无漏戒但摄一界一处少分。如是说者无漏戒多。所以者何。且苦法智忍随转戒尚多有漏。有无量功德对治彼故。况复更有上位余戒。问苦法智忍与苦法智乃至尽智无生智。无学正见诸随转戒。何者为多。有作是说。苦法智随转戒。于苦法智忍随转戒一倍为多。如是展转乃至无学正见随转戒。于无生智随转戒一倍为多。复有说者如苦法智忍随转戒。如是苦法智随转戒。乃至道类智随转戒亦尔离欲界染诸加行道。九无间道九解脱道。诸随转戒后后转多。所以者何。如如渐断破戒及起破戒烦恼。如是如是戒渐增多上诸位戒前后相似。如是说者苦法智忍随转戒。与苦法智乃至无学正见随转戒等无有异。所以者何。同于身语七支转故。问若尔施设论说当云何通。如说苦法智于苦法智忍为胜。乃至尽智于金刚喻定为胜。答依因长养故作是说。谓苦法智忍唯一刹那因所长养。苦法智二刹那因之所长养。乃至尽智无量刹那因所长养。彼说品胜不说戒多。问声闻与佛何者戒多。有作是说声闻戒多。所以者何。声闻戒依二界身。佛戒但依欲界身。复次声闻戒依二趣身。佛戒但依人趣身。如是说者佛戒多。所以者何。且力无畏随转戒尚多一切声闻独觉。况复更有无量无边殊胜功德诸随转戒。问诸佛世尊有百年位。证得无上正等菩提。有乃至于八万岁位。若百年位得菩提者。亦得八万身中戒不。设尔何失。若得者云何此身得异身戒。若不得者施设论说当云何通。如说一切如来应正等觉皆悉平等。答应言亦得。问若尔云何此身得异身戒。答若依此身得异身戒。亦无有失相续一故。然百年位得菩提者。于百年位随心转戒亦得。亦在身亦成就亦现在前于八万岁位随心转戒得。而不在身成就不现在前。八万岁位得菩提者。于八万岁位随心转戒。亦得亦在身亦成就亦现在前。于百年位随心转戒得。而不在身成就不现在前。有说不得。问若尔施设论说当云何通。答由三事等故名平等。一修行等。谓如一佛于三无数劫。修六波罗蜜多得圆满故。证得无上正等菩提。余佛亦尔故名平等。二利益等。谓如一佛出现于世度无量百千那庾多众生令般涅槃。余佛亦尔故名平等。三法身等。谓如一佛成就十力四无所畏大悲三念住。十八不共法等无边功德。余佛亦尔故名平等。复次根等故名平等。诸佛皆住上品根故。复次戒等故名平等。诸佛皆得上品戒故。复次地等故名平等。谓如一佛依第四静虑。证得无上正等菩提。余佛亦尔故名平等。问得阿罗汉果时。得几地身随心转戒。西方诸师作如是说。得二十六处身随心转戒。谓欲界九色界十七。迦湿弥罗国诸论师言。得二十五处身随心转戒。以大梵天无别处故。是未来修非皆现起。谓欲色界随何地身得无学果。即彼地身随心转戒。亦未来修亦得现起。所余地身随心转戒。虽未来修而不现起。无彼异熟所依身故。生无色界得无学果。虽得彼戒而不现起。生上不起下地定故。问依自地身能起自地一切戒不。答不能尽起。所以者何。恶法尚无能尽起者。况诸功德加行生故。问何故圣者生无色界。成就道俱有戒非定俱有戒耶。答有漏法系属界地。非上界者生上便失无漏不尔。复次有漏法胜劣随地。生上厌下无所用者。必不成就无漏不尔。是故圣者生无色界。唯得成就道俱有戒。傍论已了应复正论

问俱有因以何为自性。答一切有为法已说自性。所以今当说。问何故名俱有因。俱有是何义。答不相离义是俱有义。同一果义是俱有义。相随顺义是俱有义。此俱有因定通三世有士用果

云何同类因乃至广说问何故作此论。答为止他宗显正理故。谓或有执过去未来非实有体。或执现在是无为法。或执自类为同类因。谓心唯与心。受唯与受余法亦尔。为止如是种种异执。显示实有过去未来。及现在世是有为法并自他类为同类因故作此论。云何同类因。答前生善根与后生自界善根。及相应法为同类因。过去善根与未来现在自界善根。及相应法为同类因。现在善根与未来自界善根。及相应法为同类因。问此中何故不说过去与过去为同类因耶。答前生与后生言已说彼故。问何缘不说过去自名。答欲显后法非前因故。若说过去与过去为同类因。或有生疑过去后法亦为前法因。若说前生与后生为同类因此疑便息。有说此文欲显过去有前后义。若说过去与过去为同类因。或有生疑过去诸法同时展转为同类因。若说前生与后生为同类因此疑便息。问何故前生等唯说善根。后生等兼说相应法耶。答是作论者意欲尔故。乃至广说。有说。前生等亦应说相应法而不说者。当知此是有余之说。有说。此文为遮相似相续沙门意故彼作是说善根唯与善根为因。善根相应法唯与善根相应法为因。为遮彼意显示善根与善根为因。亦与相应法为因。善根相应法与善根相应法为因。亦与善根为因。故作是说。问此中何故唯说善根及相应法非余法耶。答就胜说故。谓善法中善根最胜。彼相应法极相邻近故偏说之。不善无记应知亦尔。自界者谓欲界。唯与欲界为同类因。色无色界应知亦尔。如说自界自地亦尔。系缚别故。谓初静虑唯与初静虑为同类因。乃至非想非非想处应知亦尔。有余师说。如说自界自地自处亦尔。谓那落迦唯与那落迦为同类因。乃至色究竟天应知亦尔。评曰。彼不应作是说。若作是说则五净居处。初刹那起。应无同类因。无始时来未生彼故。应作是说同地异处。所起烦恼展转相缚。随类展转为同类因。然除异部五部随眠。系缚分剂有差别故。复说过去等者。欲显过去未来体是实有现在是有为故。如善根不善无记根亦尔。差别者。不善中除自界是谓同类因。问何故不善除自界耶。答以不善根无异界故。若说自界无所简别。有说不善中。亦应说自界以自界声亦说自部。谓见苦所断唯与见苦所断为同类因。乃至修所断应知亦尔问若尔此中但应说如善根不善无记根亦尔不应复说差别等言。答若但作如是说。或有生疑如无记根通三界不善根亦尔故。复须说差别等言。问此中何故。不说前生等不善根。与后生等无记根。及相应法为同类因。前生等无记根与后生等不善根。及相应法为同类因耶。答是作论者意欲尔故。乃至广说。有说应说而不说者。当知此义有余。有说若作是说。或有生疑不善根亦通三界。或无记根唯在欲界。或复生疑因少果多。或因多果少是故不说。文虽不说而义实有。自部互为同类因故。问未来世中有同类因不。设尔何失若有者此中何故不说。谓此中但说前生与后生为同类因。过去与未来现在为同类因。现在与未来为同类因而不说未来与未来为同类因。又若有者应有二心展转为因便违前说。若无者此论见蕴当云何通。如说若法与彼法为因。或时此法与彼非因耶。答无时非因若法已生是同类因。若未已生非同类因。是则若法与彼法为因。或时此法与彼非因。云何答言无时非因。又若无者品类足论复云何通。如说云何非心为因法。答已入正性离生补特伽罗。初无漏心及余异生。定当入正性离生者。初无漏心然彼异生。未来所有无漏心皆非心为因。何故但说彼初无漏心耶。又若无者品类足论复云何通。如说或有苦谛以有身见为因。非与有身见为因。除未来有身见及彼相应苦谛。诸余染污苦谛。或有苦谛以有身见为因。亦与有身见为因即所除法。若未来有身见不与未来有身见为因。何故言除未来有身见。及彼相应苦谛耶。又若无者识身足论复云何通。如说于过去染污眼识。所有随眠彼于此心。或能为因非所随增。或所随增不能为因。或能为因亦所随增。或不能为因亦非所随增。且能为因非所随增者。谓诸随眠在此心。前同类遍行即彼随眠。若不缘此设缘已断。及此相应随眠已断为所随增不能为因者。谓诸随眠在此心后。同类遍行即彼随眠。缘此未断能为其因。亦所随增者。谓诸随眠在此心前。同类遍行即彼随眠缘此未断。及此相应随眠未断不能为因。亦非所随增者。谓诸随眠在此心后。同类遍行即彼随眠。若不缘此设缘已断。若所余缘若他随眠。若不同界遍行随眠。如彼过去染污眼识。未来染污眼识亦尔。过去四句其理可然。未来如何可作四句。若有前后如何无因。又若无者施设足论复云何通。如说诸法四事决定。所谓因果所依所缘。若未来世非同类因生已乃是云何决定。又若无者则应无因而有因。亦应无果而有果。便坏所宗。答应作是说未来世中无同类因。以彼无故此中不说。亦无二心互为因过。问此论见蕴当云何通。如说若法与彼法为因乃至广说。有说彼依俱有因作论。以俱有因遍有为法。亲能办果通三世故。有说彼依相应俱有二因作论。以此二因俱遍三性。亲能办果通三世故。有说。彼依相应俱有异熟三因作论。以此三因亲能办果通三世故。有说。彼依相应俱有异熟能作四因作论。以此四因通三世故。有说。彼依五因作论。除能作因遍一切法皆不遮故。此中有说。除遍行因体用狭故。应说彼依六因作论。因名所表通六因故。问若法已生是同类因或遍行因。若未已生非同类因非遍行因。是则若法与彼法为因。或时此法与彼非因云何。答言无时非因。答依最后位密作是答。谓若法于此位定能作同类因。或遍行因从是以后。无时非因故作是说。问若尔见蕴复云何通。如说若法与彼法为等无间。或时此法与彼非等无间耶。答若时此法未至已生。此中亦应依最后位。密作是答。无时非等无间。谓若法于此位定能作等无间。从是以后无时非等无间。何故不作如是说耶。答亦应作如是说。而不说者有别意趣。为现异相异文说故。若以异相异文而说义则易解。复次为现二门二略二灯二明。二炬二光。二曜二影文故。如同类因依最后位。密作是说无时非因。等无间缘亦应依此位。密作是说无时非等无间。如等无间缘依一切位说。若时此法未至已生同类因。亦应依一切位作如是说。二文相影俱通二义。问品类足论复云何通。如说云何非心为因法乃至广说。答彼唯说毕竟非心为因法。虽彼未入正性离生者。诸无漏心皆非心为因。然彼若入正性离生。唯有初无漏心是非心为因。余心无不以心为因。有余师说。彼文不辩同类因义。何者唯辩二种异生。谓有般涅槃法及无般涅槃法。文虽不举无涅槃法。义准理门显示知有。谓彼既说有余异生决定当入正性离生。由此义准亦有异生决定不入正性离生。此则名为无涅槃法。即无涅槃法名非心为因。问品类足论复云何通。如说或有苦谛。以有身见为因。乃至广说。答彼论但说除未来有身见相应苦谛。无及彼言设作是说是诵者谬。问识身足论复云何通。如说于过去染污眼识所有随眠。乃至广说。答彼于未来应作三句。除所随增不能为因彼无后故。然说未来如过去者有别意趣。谓正生时必入现在定为同类。或遍行因望余未起可说为前。对此可说余名后故有余师说。彼说未来亦有四句。不说未来有心前后。同于过去且能为因。非所随增者。谓此相应随眠已断为所随增。不能为因者。谓有同类遍行随眠。在未来世于未来世染污眼识缘而未断能为其因。亦所随增者。谓此相应随眠未断不能为因。亦非所随增者。谓有同类遍行随眠在未来世。若不缘此设缘已断。若所余缘若他随眠。若不同界遍行随眠。问施设足论复云何通。如说诸法四事决定。乃至广说。答因者四因。谓相应俱有异熟能作因。果者三果。谓士用异熟增上果。所依者六种所依。谓眼耳鼻舌身意。所缘者六种所缘。谓色声香味触法。如是四事三世决定故不相违。问若未来世无同类因。及遍行因过现乃有。则应无因而有因。亦应无果而有果。如是便坏三世有宗。答许亦无失约位非体。以和合作用位果非体果。然位与体非即非离。体虽恒有而位非恒。故同类因及遍行因。本无今有亦无有失。有余师说。未来世中有同类因。问若尔后说六难善通。此中论文何故不说。答应说而不说者当知此义有余。所说六因皆有余故。复次若同类因有力能取果与果者。此中说之未来同类因。无力不能取果与果是故不说。复次若同类因已现在已和合。已有作用。荷负担者此中说之。未来同类因无如是事。是故不说。复次若同类因。已行世相显了者此中说之。未来同类因。未行世相不显了是故不说。问若未来世有同类因。应有二心互为因过。答如四行相各有系属。余法亦然故无斯过。谓未来世无常行相。有四行相应无间生。彼是所修系属。于此无常行相与彼为因。彼非此因系属此故。无常行相起必居前。苦空无我行相亦尔。余有为法类此应知。故无二心互为因过。若作是说有依第四静虑得阿罗汉果。能修未来九地无漏。所修无漏皆系属此。后起余地圣道现前。更不能修未来无漏。无余圣道系属此故。应在过现非同类因是则违害。此中所说前生善根与后生者为同类因。乃至广说勿有此失。故未来世无同类因于理为善

问色法为有同类因不。外国诸师有作是说。一切色法无同类因。但藉余缘和合力起现见凿地深踰百肘。从彼出埿日曝风吹。后逢天雨即便生草。又复现见屋脊山峰。先无种子亦生草树。故知色法无同类因。问若尔此论大种蕴说当云何通。如说过去大种造色。与未来等大种造色为因增上。答我于他论何事须通。若必须通应作是说。增上缘力有近有远。有在此身有在余身。若近在此身者说名为因。若远在余身者说名增上。迦湿弥罗国诸论师言。色法亦有同类因。唯除初无漏色。问若尔虽通大种蕴说。彼所引事当云何通。答所出埿中先有种子。余缘阙故草未得生。后遇众缘即便生草。又彼埿聚屋脊山峰。草树生者风吹鸟衔。种子来至故得如是

说一切有部发智大毗婆沙论卷第十七阿毗达磨大毗婆沙论卷第十八

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中智纳息第二之十

有余师说。色法虽有同类因。而在此身非余身。相似为因非不相似如此身羯剌蓝位。与此身羯剌蓝位为同类因。与余位作缘非因。乃至此身老位与此身老位为同类因。与余位作缘非因。若作是说于位位中。初色无因后色无果。有作是说色法虽有同类因。而在此身非余身相似为因亦不相似。如此身羯剌蓝位与此身羯剌蓝位。乃至老位为同类因。此身頞部昙位与此身頞部昙位。乃至老位为同类因。与羯剌蓝位作缘非因。乃至此身老位与此身老位为同类因。与前诸位作缘非因。若作是说羯剌蓝位初色无因。老位后色无果。或有说者色法虽有同类因。在此身亦在余身。而相似为因非不相似。如此身羯剌蓝位与此身及余身。羯剌蓝位为同类因。与余位作缘非因。乃至此身老位。与此身及余身老位为同类因。与余位作缘非因。复有说者色法虽有同类因在此身。亦在余身相似为因亦不相似。而与前位非同类因。如此身羯剌蓝位。与此身羯剌蓝位。乃至老位为同类因。亦与余身羯剌蓝位乃至老位为同类因。此身頞部昙位。与此身頞部昙位乃至老位为同类因。亦与余身頞部昙位乃至老位为同类因。与羯剌蓝位作缘非因。乃至此身老位与此身老位为同类因。亦与余身老位为同类因。与前诸位作缘非因。或复有说。色法虽有同类因。在此身亦在余身相似为因亦不相似。而与此身前位非因。如此身羯剌蓝位。与此身羯剌蓝位乃至老位为同类因。亦与余身羯剌蓝位乃至老位为同类因。此身頞部昙位。与此身頞部昙位乃至老位为同类因。亦与余身羯剌蓝位乃至老位为同类因。与此身羯剌蓝位作缘非因。乃至此身老位与此身老位为同类因。亦与余身羯剌蓝位乃至老位为同类因。与此身前诸位作缘非因评曰应作是说。余身十位一一皆与余身十位。及此身十位为同类因。此身十位一一。皆与此身十位及余身十位为同类因。后位已生法与前位不生法亦为同类因故。如是外分诸色相望。为同类因如理应说

复次善五蕴展转为同类因。染污五蕴展转为同类因。无覆无记五蕴。亦展转为同类因。性类等故。有说无覆无记四蕴。与无覆无记色蕴为同类因。无覆无记色蕴。不能与无覆无记四蕴为同类因势力劣故。有说无覆无记色蕴。与无覆无记四蕴为同类因。无覆无记四蕴。不与无覆无记色蕴为同类因。胜法不为劣法因故。有说。无覆无记四蕴。不与无覆无记色蕴为同类因。无覆无记色蕴。亦不与无覆无记四蕴为同类因。势用羸劣类各别故。无覆无记四蕴展转为同类因。无覆无记复有四种。一异熟生。二威仪路。三工巧处。四通果品。如次能与四三二一为同类因。有余师说。此四展转为同类因。同一系缚同一性故。评曰彼不应作是说。勿加行善互为因故前说为善。染污法有九品。谓下下下中下上。中下中中中上。上下上中上上。九品展转为同类因。问若尔云何有九品。答由对治有九品故。染污法亦有九品。谓修下下道对治上上烦恼。乃至修上上道对治下下烦恼。复次。以现行故亦有九品。谓诸烦恼现在前时。或是下下品。乃至或是上上品。诸不善者亦由异熟。有九品故建立九品。善法有二种。一生得善。二加行善。生得善与生得善为同类因。亦与加行善为同类因。加行善与加行善为同类因。非生得善以彼劣故。有说。此二善法展转为同类因。同一系缚同一性故。评曰彼不应作是说。勿修加行退趣劣法。是故前说于理为善。有说。善法有三种。一加行善。二离染善。三生得善。此中生得与三种为同类因。离染善与二种为同类因。非生得彼劣故加行善与加行善为同类因。非余二俱劣故。生得善法复有九品。谓下下乃至上上。九品展转为同类因。问若尔云何有九品。答由现行有九品故。复次由异熟有九品故。离染善及加行善亦俱有九品。谓下下乃至上上。此中下下与九品为同类因。下中与八品为同类因。乃至上上唯与上上为同类因。此二唯与等胜为因非劣法故。加行善法复有三种。一闻所成。二思所成。三修所成。闻所成善与三种为同类因。思所成善唯与思所成善为同类因。非闻所成彼劣故。非修所成异界故。修所成善唯与修所成善。为同类因。非闻所成彼劣故。非思所成彼亦劣故。及异界故。修所成善复有四种。谓暖顶忍世第一法。如次能与四三二一。为同类因义如前说。欲界通果心有四种。谓初静虑果乃至第四静虑果。如是四种如次能与四三二一为同类因。有说。此四非互为因如静虑故。有说。此四展转为因。同一系缚同一性故。评曰。初说为善。同一地故加行生故

初静虑等诸通果心应知亦尔。问初静虑有诸识身。有变化心互为因不。答诸识身与变化心为同类因。变化心不与识身为同类因。以彼劣故依前诸义应作问答。颇有前生法非后生法同类因不。答有。谓不同界。颇有同界前生法非后生法同类因不。答有。谓不同地。颇有同地前生法非后生法同类因不。答有。谓有漏于无漏无漏于有漏。颇有有漏前生法非有漏后生法同类因不。答有。谓不同部。或不同性。或胜于劣。前生无漏于后生无漏。非同类因者谓胜于劣

问诸同类因若与果者亦取果耶。答若与果者。定亦取果。若不取果。云何与果。或有取果而不与果。谓阿罗汉最后诸蕴。此则总说若别说者。依善不善有覆无记无覆无记。有多四句。问善同类因若时取果亦与果耶。答应作四句。有时取果非与果。谓断善根时最后所舍得。有时与果非取果。谓续善根时即住过去所舍善得。有时取果亦与果。谓不断善根于所余位。有时不取果亦不与果。谓除前相。问不善同类因。若时取果亦与果耶。答应作四句。有时取果非与果。谓离欲染时最后所舍得。有时与果非取果。谓退离欲染时即住过去所舍不善得。有时取果亦与果。谓未离欲染于所余位。有时不取果亦不与果。谓除前相。问有覆无记同类因。若时取果亦与果耶。答应作四句。有时取果非与果。谓离非想非非想处染时最后所舍得。有时与果非取果。谓退离非想非非想处染时。即住过去所舍有覆无记得。有时取果亦与果。谓未离非想非非想处染于所余位。有时不取果亦不与果。谓除前相。问无覆无记同类因。若时取果亦与果耶。答若时与果必亦取果。有时取果非与果。谓阿罗汉最后诸蕴。已依成就分别取果与果差别。今依现行分别取果与果差别。复次已依不相应法。分别取果与果差别。今依相应法分别取果与果差别。问善同类因。若时取果亦与果耶。答应作四句。有时取果非与果。谓善心无间不善无记心现在前。有时与果非取果。谓不善无记心无间善心现在前。即住过去所间善心。有时取果亦与果。谓善心相续无间断位有时不取果亦不与果。谓除前相。问不善同类因。若时取果亦与果耶。答应作四句。有时取果非与果。谓不善心无间善无记心现在前。有时与果非取果。谓善无记心无间不善心现在前。即住过去所间不善心。有时取果亦与果。谓不善心相续无间断位。有时不取果亦不与果。谓除前相。问有覆无记同类因。若时取果亦与果耶。答应作四句。有时取果非与果。谓有覆无记心无间。善不善无覆无记心现在前。有时与果非取果。谓善不善无覆无记心无间。有覆无记心现在前。即住过去所间有覆无记心。有时取果亦与果。谓有覆无记心相续无间断位。有时不取果亦不与果。谓除前相。问无覆无记同类因。若时取果亦与果耶。答应作四句。有时取果非与果。谓无覆无记心无间。善染污心现在前。有时与果非取果。谓善染污心无间。无覆无记心现在前。即住过去所间无覆无记心。有时取果亦与果。谓无覆无记心相续无间断位。有时不取果亦不与果。谓除前相。已依相续分别取果与果差别。今依刹那分别取果与果差别。谓一刹那心后。有二十刹那心无间而起。于中得作四句。且善同类因第一句者。谓上首刹那善心现在前时。除初刹那善心望后十九刹那善心。第二句者。谓后十九刹那善心现在前时。即住过去上首善心。第三句者。即上首善心现在前时。望初刹那善心。第四句者。谓除前相。如善同类因四句。不善有覆无记无覆无记同类因。随其所应四句亦尔

颇有一刹那顷。或得同类因不得彼因。或得彼因不得同类因。或得同类因亦复彼因。或不得同类因亦不得彼因耶。答有谓从上沙门果退住预流果时。有此四句。得同类因不得彼因者。谓尔时得过去初刹那道类智。而不得彼因以不得见道故。得彼因不得同类因者。谓尔时得过去预流果。而不得过去预流胜果道。以预流胜果道用预流果为因。与上沙门果作同类因故。得同类因亦得彼因者。谓尔时得过去。除初刹那诸余刹那相续预流果。不得同类因亦不得彼因者。谓除前相。问颇有一刹那顷。或知同类因不知彼所缘。或知彼所缘不知同类因。或知同类因亦知彼所缘。或不知同类因亦不知彼所缘耶。答有。谓住见道道法智时。有此四句。知同类因不知彼所缘者。谓尔时知过去缘苦集灭三法智品。知彼所缘不知同类因者。谓知未来四法智品。知同类因亦知彼所缘者。谓知过去道法忍品。不知同类因亦不知彼所缘者。谓除前相

问同类因力有增减不。答有谓若久习因力便增。若不久习或遭损害因力便减。且不善中因力增者。如具寿迷只迦。曾一林中修习静虑坐一树下。欲寻现起心生厌患。便舍此处坐余树下。恚寻复起心生厌患。复舍此处坐余树下。害寻复起。由彼具寿曾于此地作大国王。若于是处五乐自娱受诸欲乐。今坐其处便起欲寻。若于是处斩截众生头耳手足。今至其处便起恚寻。若于是处役使众生。作诸事业系缚鞭打。今至其处便起害寻。尊者阿难入城乞食。摩登伽女见。已生贪。随逐瞻观不能舍离。此女过去五百生中作阿难妇。故今暂见便起欲寻随逐不舍。诸如是等皆由过去因力增上。或有现在习诸烦恼因力增上。同类异类展转相生。如不善法。善无记法应知亦尔。如尸拔罗久习施故。才生便告父母等言。今此家中有何财宝。我欲持施一切贫穷。诸如是等广如经说

问同类因以何为自性。答过去现在一切有为法已说自性。所以今当说。问何故名同类因同类是何义。答种类等义是同类义界地等义是同类义。部类等义是同类义。此同类因唯通过去现在二世。有等流果云何遍行因乃至广说。问何故作此论。答为止他宗显正理故。谓或有执。一切烦恼皆是遍行。为止彼执。显诸烦恼有是遍行有非遍行或复有执。五部烦恼。皆有是遍行有非遍行。为止彼执。显唯见苦集所断烦恼。有是遍行有非遍行。或复有执。见苦集所断一切烦恼皆是遍行见灭道所断一切烦恼皆无漏缘。为止彼执。显见苦集所断烦恼。有是遍行有非遍行。见灭道所断烦恼。有有漏缘有无漏缘。或复有执。若诸烦恼通三界者皆是遍行。为止彼执显诸烦恼通三界者。有是遍行有非遍行。或复有执。遍行有二。一者无明。二者有爱。如譬喻者彼作是说。缘起根本名为遍行。无明是前际缘起根本。有爱是后际缘起根本故是遍行。为止彼执显无明有是遍行有非遍行。有爱一向非遍行。或复有执。若诸烦恼通五部者名为遍行。即是无明及贪嗔慢。为止彼执显无明有是遍行有非遍行。贪嗔慢一向非遍行。或复有执。五法是遍行。谓无明爱见慢及心。如分别论者。故彼颂言

  有五遍行法　　能广生众苦
  谓无明爱见　　慢心是为五

为止彼执显无明见有是遍行有非遍行。余三一向非遍行。为止此等种种异执显示正理故作斯论

云何遍行因。答前生见苦所断遍行随眠。与后生自界见集灭道。修所断随眠及相应法为遍行因。过去见苦所断遍行随眠与未来现在自界见集灭道。修所断随眠及相应法为遍行因。现在见苦所断遍行随眠与未来自界见集灭道。修所断随眠及相应法为遍行因。如见苦所断见集所断亦尔。是谓遍行因。问此中何故。不说过去与过去为遍行因耶。答前生与后生言已说彼故。问何缘不说过去自名。答欲显后法非前因故。若说过去与过去为遍行因。或有生疑过去后法亦为前法因。若说前生与后生为遍行因。此疑便息。有说。此文欲显过去有前后义。若说过去与过去为遍行因。复有生疑过去诸法。同时展转为遍行因。若说前生与后生为遍行因。此疑便息。问自部于自部有遍行因不。设尔何失若有者此中何故不说。若无者何故。于他部有自部无耶。答应说亦有。问若尔此中何故不说。答亦应说而不说者有别意趣。为欲成立不成义故。谓于自部有遍行因。不说自成故不须说。若于他部有遍行因。其义不成是故须说。有说。为显无杂遍行因故。谓于自部有二种因。谓遍行因及同类因。其义杂乱是故不说。若于他部唯有一因。谓遍行因义无杂乱是故偏说。复次为显无杂增长门故。谓于自部二门增长。谓同类因门及遍行因门。其义杂乱是故不说。若于他部唯一门增长。谓遍行因门义无杂乱是故偏说。问何故前生等唯说随眠。后生等兼说相应法耶。答前生等亦应说相应法而不说者。当知。此是有余之说。复次为遮相似相续沙门意故。彼作是说遍行随眠。唯与随眠为遍行因。彼相应法唯与随眠相应法为遍行因。为遮彼意显遍行随眠。与随眠及相应法为遍行因。彼相应法与随眠相应法及随眠为遍行因。故作是说。问遍行随眠。于诸随眠俱有法等亦是遍行因不。设尔何失。若亦是者此中何故不说。若非者何故于相应法是而于俱有法等非耶。答应说亦是。以与一切染污法皆为遍行因故。问若尔此中何故不说。答彼相应法与彼随眠同一所缘同一行相。极相邻近是故说之生等不尔是故不说。自界者。谓欲界唯与欲界为遍行因。色无色界应知亦尔。如说自界自地亦尔系缚别故。谓初静虑唯与初静虑为遍行因。乃至非想非非想处应知亦尔于自地中处别部别。亦得展转为遍行因系缚同故。复说过去等。欲显过去未来体是实有。现在是有为故。如说见苦所断见集所断。亦尔体类同故

问遍行随眠以何为自性。答欲界有十一。谓见苦所断五见疑无明。见集所断邪见见取疑无明。色无色界各有十一应知亦尔。此中无明者。谓五见疑相应及不共无明。品类足说。九十八随眠中。三十三是遍行。六十五非遍行。问见苦集所断无明。有是遍行有非遍行。何故彼说三十三是遍行六十五非遍行耶。答西方尊者所诵本言。九十八随眠中二十七是遍行。六十五非遍行。六应分别。谓见苦集所断无明。有是遍行有非遍行。云何是遍行。谓见苦集所断。非遍行随眠不相应。无明云何非遍行。谓见苦集所断。非遍行随眠相应无明。如是所说于义为善。若作是说云何是遍行。谓见苦集所断遍行。随眠相应无明。则便不摄不共无明。是故彼说于义为善。问若尔何故。迦湿弥罗国诸师不作此诵。答亦应作此诵。而不尔者有别意趣。以彼多分是遍行故。谓见苦所断。有十无明。七是遍行即五见疑相应及不共无明。三非遍行即贪嗔慢相应无明。见集所断有七无明。四是遍行即二见疑相应及不共无明。三非遍行即贪嗔慢相应无明。又此国诵三十三是遍行。六十五非遍行者。无明皆说不共无明。唯遍非遍自力起故。相应无明有八十三。谓二十七遍行及五十六非遍行。随眠相应彼随他力。现在前故说所相应。即亦说彼性不定故不别说之。已说自性。所以今当说。问何故名遍行随眠遍行是何义。答一切缘义是遍行义。缘力持义是遍行义。缘力持者能广缘故。复次本来一切。一切一切起故名为遍行。初一切者。谓无始来具起九品。中一切者。谓无始来一切有情无不皆起。后一切者。谓无始来普缘一切有漏事起故。施设论作如是说。无有异生从长世来。于有漏法不执为我。或执我所。或执断常。或拨为无。或执为净解脱出离。或执为尊最胜第一。或起疑惑犹预。或起愚闇无知。是故本来一切一切一切起故。名为遍行。复次若法一刹那顷现在前时。能缘五部为五部因。令五部法于所缘愚。名为遍行。问遍行随眠。云何令彼无漏缘法于所缘愚。答若执我等法尔便谤。我灭对治先于中愚。然后于彼拨为无故。复次若法一刹那顷。现在前时。能缘五部为五部因。于五部法皆悉随增名为遍行

问遍行随眠相应俱有法。亦是遍行因不。设尔何失。若亦是者何故但说三十三是遍行。若非者何故相应俱有法。有是遍行因有非遍行因耶。有作是说彼非遍行因。问若尔何故相应俱有法。有是遍行因有非遍行因。答如相应俱有法。有是随眠有非随眠。如是相应俱有法。有是遍行因有非遍行因。复有何过。评曰应作是说。彼亦是遍行因因义通故。相应俱有同一果故。问若尔何故但说三十三是遍行耶。答彼说但欲分别。九十八随眠中。几是遍行几非遍行。不为总说遍行因义故不相违。复次遍行随眠具三事故名为遍行。一于五部法遍随增故。二于五部法遍能缘故。三于五部法遍为因故是以偏说。彼相应法但有二事除遍随增。彼俱有法但有一事。谓遍为因故彼不说。问遍行随眠等得亦是遍行因不。尊者僧伽筏苏说曰。若遍行得非遍行者。非遍行得应是遍行。故遍行得亦是遍行因。彼难非理。如色得既非色非色得。岂是色。故遍行得非遍行因于理为善。问何故遍行生等诸相。是遍行因彼得非耶。答生等诸相与遍行法同一果。常相随不相离无前后极亲近故。亦是遍行因得。与遍行不同一果。不常相随非不相离。或前或后非极亲近。如皮于树是故彼得非遍行因

问何故唯于见苦集所断法。立有遍行随眠。非于见灭道所断法耶。旧阿毗达磨师说曰。此是彼族类故谓见苦集所断诸法。是遍行随眠族姓根本生地舍宅。非见灭道所断诸法。有说。此中随眠极坚牢故。谓见苦集所断随眠。皆同一意同一所作。故极坚牢。以坚牢故于中可立遍行随眠。见灭道所断法不同一意。事业各异故极羸劣。极羸劣故。于中不立遍行随眠。如城邑人若同一意同一事业。则城邑主及余怨敌不能降伏。若彼诸人不同一意事业各异。则被降伏此亦如是。有说。此中我见所任持故。谓于是处若有我见。则有漏法相续炽盛可立遍行。见集所断虽无我见而有长养。我见诸法非见灭道所断法中有如是事。有说。遍缘有漏因果事故。谓见苦集所断随眠。俱能遍缘有漏因果故立遍行。余则不尔。有说。此于所缘定增长故。谓见苦集所断随眠皆缘有漏。随缘有漏随渐增长。如人观月增益眼根若见灭道所断随眠。或缘有漏或缘无漏。缘无漏者随有所缘随渐损减。如人观日损减眼根以不定故。于此不立遍行随眠。有说。此有二种随眠事故。谓见苦集所断随眠。俱由二门作随眠事。一由所缘。二由相应。见灭见道所断随眠。或由二门作随眠事。或唯相应不决定故。不可建立遍行随眠。有说。此中决定安二足故义如前说。有说。四部皆有二种道故。谓见苦集所断部中。有是遍行有非遍行

于见灭道所断部中。有有漏缘有无漏缘故不应责有说。一切随眠堕此二故。谓诸随眠一切皆堕苦集谛摄故。唯此有遍行随眠。有说若见苦集有漏果因。则见灭道所断诸法根本羸劣。故彼不立遍行随眠。有说。不应责故。谓遍行随眠者定能遍缘。非见灭道所断法中有遍缘者

问何故见苦集所断。贪嗔慢非遍行耶。答以彼皆无遍行相故。谓遍行者能缘一切彼三不尔。有说此三自相烦恼摄故。谓要共相烦恼摄者可立遍行。云何此三皆是自相烦恼所摄。谓起贪者或于彼身不于此身。或于此身不于彼身。于诸身分亦各别起嗔慢亦尔。故是自相有身见等。一刹那中总于一界一趣生等。或执为我或执我所。或复乃至愚闇无知故是共相。有说。难炽盛故。谓贪嗔慢难可炽盛。要依妻财怨仇卑敌方炽盛故。遍行随眠易可炽盛。任运相续如河流故。有说。见疑无明能缘四谛。于中可立遍行随眠。贪嗔慢三无如是事。是故不立遍行随眠。问何故见灭道所断贪嗔慢。见取戒禁取非无漏缘耶。答不应诃责故。无怨害相故性柔和故。最胜故。清净故。是以贪等非无漏缘

欲界有十一遍行随眠。九通他界缘二唯自界缘。谓有身见及边执见。问何故此二见不缘他界耶。答唯有尔所缘境力故。复次此二见唯于粗法转故。谓此二见唯于粗显。现见诸蕴执我我所。及计断常。若生欲界于色无色界。微细诸蕴不能现见。故不执为我我所等。问若尔生色界者现见欲界粗显诸蕴。何不执为我我所等。答已离染故。谓生色界者。于欲界蕴已得离染故。虽现见而不执为我我所等。复次上地烦恼不缘下故。问因论生论何故上地烦恼不缘下耶。答已离彼染故。谓要已离下地染者。方起上地烦恼现前。于下地法既已离染。上地烦恼宁复缘彼。问如何得知要离下染。上地烦恼方得现前。答如施设论说。有六种非律仪。谓三界系各有二种。一相应二不相应。欲界相应非律仪现在前时。六非律仪成就四非律仪亦现在前。谓欲界二色无色界各不相应。色界相应非律仪现在前时。四非律仪成就。三非律仪亦现在前。谓色界二无色界不相应。无色界相应非律仪现在前时。二非律仪成就。亦现在前。谓无色界二。此中染法名非律仪。由此故知要离下染上地烦恼方现在前。问何故欲界烦恼能缘色无色界。彼二界烦恼不能缘欲界耶。答欲界是不定界。非修地。非离染地。不能摄伏自界随眠。故得越缘色无色界。色无色界是定界是修地是离染地。能善摄伏自界随眠。故彼不能越缘下地。如人不能摄伏妻妾。便得与他作非法事。若善摄伏乃至不能。以眼顾眄况为非法。此亦如是。复次生欲界者于上二界诸蕴。犹预为是苦耶为非苦耶。为是集耶为非集耶。是第一耶非第一耶。是清净耶非清净耶。由不了故欲界烦恼得缘上界。若生上地于下诸蕴已现见故无有犹预。故上烦恼不缘下地。复次若色无色界烦恼缘欲界者则应随增。若随增者界应杂乱。故彼烦恼不缘欲界。问如欲界烦恼虽缘上界而不随增。上界烦恼何故不尔。答上界蕴胜欲界烦恼虽缘彼起而不随增。欲界蕴劣上界烦恼。若缘此起即便随增。如下劣人于尊胜者。虽能现见而不能损害。若尊胜者见下劣人便能损害。此亦如是。色界亦有十一遍行随眠。九通他界缘。二唯自界缘。无色界亦有十一遍行随眠。皆是自界缘无他界缘者。无上界故不缘下故。有说亦有他界缘者。然能缘定非现起定。评曰。彼不应作是说。既无上界可缘如何有能缘定。是故说无于理为善。初静虑乃至无所有处皆有十一遍行随眠。九通他地缘。二唯自地缘。非想非非想处亦有十一遍行随眠。皆唯自地缘。无上地故不缘上故。有说亦有他地缘者。然能缘定非现起定。评曰。彼不应作是说既无上地可缘。如何有能缘定。是故说无于理为善

说一切有部发智大毗婆沙论卷第十八阿毗达磨大毗婆沙论卷第十九

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中智纳息第二之十一

欲界见苦集所断邪见。能缘三界苦集而非一时。谓异刹那缘欲界。异刹那缘色无色界。问何故不一刹那顷顿缘三界。若苦若集耶。答彼缘欲界亦随增。缘色无色界不随增故。问彼何故缘欲界亦随增。缘色无色界不随增耶。答欲界是彼随增处。色无色界非彼随增处故。复次欲界是彼居宅。色无色界非彼居宅故。复次欲界有彼等流异熟果。色无色界无彼等流异熟果故。复次欲界有彼五部遍行果。色无色界无彼五部遍行果故。复次欲界无彼毕竟对治。色无色界有彼毕竟对治故

复次若彼一刹那顷顿缘三界若苦若集者。云何而缘为如缘欲界即随增缘色无色界亦尔耶。为如缘色无色界不随增。缘欲界亦尔耶。设尔何失。若如缘欲界则随增。缘色无色界亦尔者界应杂乱。若如缘色无色界不随增。缘欲界亦尔者则不应理。以无烦恼缘自界法而有不具所缘相应二随增者。缘自地法必具所缘相应缚故。若一刹那顿缘三界若苦若集。于所缘境有随增有不随增者。亦应于相应法有随增有不随增。是则违此因理亦坏相应法。勿有此失。故别时缘自界他界理善成立。如是初静虑见苦集所断邪见。能缘八地苦集而非一时。谓异刹那缘初静虑。异刹那缘上七地。如是乃至无所有处见苦集所断邪见。能缘二地苦集而非一时谓异刹那缘自地。异刹那缘上地。非想非非想处见苦集所断邪见。唯缘自地苦集。欲界见灭所断邪见唯缘欲界诸行灭。问何故欲界见苦集所断邪见能缘三界苦集。欲界见灭所断邪见唯能缘欲界诸行灭耶。胁尊者曰。若法欲界爱所耽着身见执为我我所者。此诸法灭应为欲界见灭所断邪见所缘。非彼烦恼能缘他界此亦如是。有说苦集是有为法自地他地展转相引。故彼邪见能缘他地。灭谛无为自地他地无相引义。故彼邪见不缘他地。如是初静虑见灭所断邪见。唯缘初静虑诸行灭。乃至非想非非想处。见灭所断邪见。唯缘非想非非想处诸行灭。欲界见道所断邪见唯缘欲界诸行对治。问何故欲界见苦集所断邪见能缘三界苦集。欲界见道所断邪见唯能缘欲界诸行对治耶。胁尊者曰。若法欲界爱所耽着身见执为我我所者。此法对治应为欲界见道所断邪见所缘。非彼烦恼能缘他界此亦如是。有说欲界见苦集所断邪见所缘非对治故能缘他地。欲界见道所断邪见所缘即对治故不能缘他地对治。此中有说。欲界见道所断邪见。唯缘未至定法智品道。唯彼是此断对治故。评曰。应作是说。能缘六地法智品道种类同故。俱是欲界坏对治故。如是初静虑见道所断邪见。能缘九地类智品道。乃至非想非非想处见道所断邪见。能缘九地类智品道。问何故见灭所断邪见唯能缘自地诸行灭。见道所断邪见能缘六地法智品道。或缘九地类智品道耶。答自他地灭非展转因。多地圣道互为因故。问若尔法类品道亦互为因。何故见道所断邪见不总缘耶。有说见道所断邪见亦能总缘法类品道。互为因故。法智品道亦能对治上二界故。评曰。彼不应作是说。类智品道于欲界法非对治故。法智品道于上二界虽为对治而非初非全故。又法类品种类品别故。有说九地类智品道是上八地断对治者。即为彼地见道所断邪见所缘非余地道。评曰。彼不应作是说。以能对治有多种故。又类智品展转为因种类同故

问一刹那随眠不能遍缘一切。亦无遍随增理。何故名遍行耶。答依彼种类相续而说故无有过。然遍行随眠对遍行因应作四句。有遍行随眠非遍行因。谓未来遍行随眠。有遍行因非遍行随眠。谓过去现在遍行随眠相应俱有法。有遍行随眠亦遍行因。谓过去现在遍行随眠。有非遍行随眠亦非遍行因。若不依彼种类说者。应作是说谓除前相。若即依彼种类说者应言未来遍行随眠相应俱有法。问一切染污法皆以见所断法为因不。设尔何失。若一切染污法皆以见所断法为因者。未断亦作因已断亦作因。未断已断有何差别。又若尔者。何故圣者修所断染污法。有起有不起耶。不起者。谓无有爱诸慢类极嗔缠。起者谓余贪嗔慢无明。又若尔者。识身论说当云何通。如说颇有不善法。唯以不善为因耶。答有。谓圣者退离欲染时。初染污思现在前。若一切染污法。不皆以见所断法为因者。品类足论当云何通。如说。云何见所断为因法。谓一切染污法。及见所断法异熟。又若尔者。复违彼说。云何无记为因法。谓无记有为法。及一切不善法。又若尔者。复违彼说。或有苦谛以有身见为因。非与有身见为因。谓除过去现在见苦所断。广说乃至除未来有身见及彼相应法。生老住无常诸余染污苦谛等。又若尔者。识身论说当云何通。如说。不善眼识。乃至不善意识。皆以不善无记为因。答应作是说。一切染污法。皆以见所断法为因。问若尔未断已断俱能为因。有何差别。答名即差别。谓前未断位名未断因。后已断位名已断因。复次前位未为对治所坏。后位虽亦为因。而已为对治所坏。复次前位于自身中能障圣道。后位虽亦为因。而于自身中不障圣道。复次前位于自身中。能起如烟焰得。后位虽亦为因。而于自身中不复能起如烟焰得。复次前位于自身中。作可诃厌事及垢秽事。后位虽亦为因。而于自身中不复能作可诃厌事及垢秽事。复次前位于自身中。能办所应作事。后位虽亦为因。而于自身中不复能办所应作事。复次前位于自身中。能办同类因遍行因事。后位虽亦为因。而于自身中不复能办同类因遍行因事。复次前位于自身中。能办等流果异熟果。后位虽亦为因。而于自身中不复能办等流果异熟果。复次前位于自身中。能取果与果。后位虽亦为因。而于自身中不复能取果与果。是名未断已断差别。问若尔何故圣者修所断染污法。有起有不起耶。答见所断法与彼或为相续近因。或为不相续远因。若与彼为相续近因者。圣者不起。若与彼为不相续远因者。圣者犹起。复次若已得彼非择灭者。圣者不起。若未得彼非择灭者。圣者犹起。复次彼起定依异生性者。圣者不起。若不定者。圣者犹起。复次彼起定能障圣性者。圣者不起。若不尔者。圣者犹起。问何故圣者不起无有爱耶。答彼是断见所长养故。次断见后现在前故。一切圣者断见已断故彼不起。问何故圣者不起诸慢类耶。答彼是身见所长养故。次身见后现在前故。一切圣者身见已断故彼不起。问何故圣者不起极嗔缠耶。答彼是邪见所长养故。次邪见后现在前故。一切圣者邪见已断故彼不起。问若尔识身论说当云何通。如说。颇有不善法。唯以不善为因耶。答有。乃至广说。答彼依未断因说故不相违。谓彼初起不善思有二种因。一已断。二未断。彼论但依未断因说。复次彼依不善因说故不相违。谓彼初起不善思有二种因。一不善。二无记。彼论但依不善因说。复次彼依自部因说故不相违。谓彼初起不善思有二种因。一自部。二他部。彼论但依自部因说。复次彼依非遍行因说故不相违。谓彼初起不善思有二种因。一遍行。二非遍行。彼论但依非遍行因说。复次彼依不共因说故不相违。谓彼初起不善思有二种因。一共。二不共。彼论但依不共因说。问圣者先未离欲染时。彼染污思亦以不善为因。何故彼论说后退时。答尔时彼思先不成就今得成就。先无缚今有缚。先死今生。是故偏说。问后起染污思亦以不善为因。何故彼论但说初起。答尔时彼得先断今续。先无用今有用。先死今生。是故偏说。有作是说。一切染污法。不皆以见所断法为因。问若尔。品类足论识身论说。当云何通。答彼总相说。若别说者。应作是言。有染污色。以见所断法为因。非一切染污色。乃至有染污识。以见所断法为因。非一切染污识。评曰。彼不应作是说。以彼论说一切染污法皆以见所断法为因故。一切不善法皆以无记为因故。诸余染污苦谛等皆以有身见为因故。不善六识皆以不善无记为因故。前说为善。尊者设摩达多分别染法有异。彼作是说。有见苦所断法。唯以见苦所断为因。有见苦所断法唯以见集所断为因。无二为因。见集所断法亦尔。实无是处分别故说。假使圣者现观苦已未现观集。从圣道起见集所断法唯以见集所断为因者。得起现前见集所断法以见苦所断为因者。不起现前。因已断故。有见灭所断法唯以见灭所断为因。有见灭所断法唯以见苦所断为因。有见灭所断法唯以见集所断为因。有见灭所断法唯以见苦集所断为因。无三为因。见道所断修所断染污法亦尔。实无是处分别故说。假使圣者现观灭已未现观道。从圣道起见道所断法唯以见道所断为因者。得起现前。见道所断法唯以见苦集所断为因者。不起现前。因已断故。如是圣者于修道中。修所断染污法唯以修所断为因者。得起现前。修所断染污法。唯以见苦集所断为因者。不起现前因已断故。然诸圣者离欲染时欲界修所断染污法。若唯以修所断为因。若唯以见苦集所断为因。合为一聚九品渐断。彼后退时欲界修所断染污法。唯以修所断为因者还成就唯以见所断为因者不成就。因已断故。又于尔时唯以修所断为因。修所断染污法中未来者还成就。过去者不成就。彼后无容起现前故。评曰。彼不应作是说。云何同一对治所断烦恼。彼后退时有还成就有不成就。又不能通品类足论识身论说。是故如前所说为善

问爱于诸界诸地诸部皆等隔绝。何故遍行随眠能于他部随增非他界地。答遍行随眠于他部法。有等流果或异熟果故能随增。于他界地无等流果及异熟果故不随增。复次自地他部粗细相似故能随增。上地细故不能随增。问遍行异熟与不遍行异熟展转为因不。有作是说。遍行异熟与不遍行异熟为因。不遍行异熟不皆与遍行异熟为因。如遍行随眠与不遍行随眠为因。他部不遍行随眠不能与遍行随眠为因异熟亦尔。评曰。彼不应作是说。随眠法异。异熟法异。随眠有五部异熟唯修所断故。应作是说。遍行异熟与遍行异熟为因。亦与不遍行异熟为因。不遍行异熟与不遍行异熟为因。亦与遍行异熟为因。同地同部性类等故

问遍行因以何为自性。答一切过去现在遍行随眠。及彼相应俱有诸法。已说自性。所以今当说。问何故名遍行因。遍行是何义。答遍为因义是遍行义。复次能遍缘义是遍行义。复次遍随增义是遍行义。此遍行因唯通过去现在二世有等流果

云何异熟因。乃至广说。问何故作此论。答为止他宗显正理故。谓或有执离思无异熟因。离受无异熟果。如譬喻者。为止彼执显异熟因及异熟果俱通五蕴。或复有执。唯心心所有异熟因及异熟果。如大众部。为止彼执显此因果。亦通诸色不相应行。或复有执。唯心心所及诸色法。有异熟因及异熟果为止彼执显此亦通不相应行。或复有执。诸异熟因要舍自体其果方熟。彼作是说。诸异熟因要入过去方与其果。过去已灭故无自体。为止彼执显异熟因至果熟位犹有实体。或复有执。诸异熟因果若未熟其体恒有。彼果熟已其体便坏。如饮光部彼作是说。犹如种子芽若未生其体恒有芽生便坏。诸异熟因亦复如是。为止彼执显异熟因。果虽已熟其体犹有。或复有执。所造善恶无苦乐果如诸外道。为止彼执显善恶业有苦乐果。故作斯论。云何异熟因。答诸心心所法。受异熟色心心所法心不相应行。此心心所法与彼异熟为异熟因。此中诸心心所法者。谓一切不善善有漏心心所法。此言亦摄彼随转色。不相应行与心心所同一果故。异熟色者。谓色蕴。即眼等五根色香味触。心者。谓识蕴。即眼等六识。心所法者。谓三蕴。即受想思等。心不相应行者。谓行蕴。即命根众同分等。此显异熟因及异熟果俱通五蕴

复次诸身语业。受异熟色心心所法心不相应行。此身语业与彼异熟为异熟因。问随心转身语业心一果故。如前已说。此中复言身语业者。说何法耶。答善不善表及依表业所生无表不随心转身语二业。此定能招异熟果故。有说。此中说身语表及此刹那所生无表同一果故。彼说非理。身语表业与彼俱生。身语无表非同一界。彼不互为俱有因故。有说。表业与依表生身语无表虽非一果。而定俱时受异熟果一心起故。彼说非理。展转相望非俱有因。如何定说同一刹那受异熟果。然表无表展转不为俱有因故异熟果别。于表业中七支等异。一一各别招异熟果。一一支等有多极微。一一极微有三世别。于一一世有多刹那。一一刹那异熟果别非俱有因故。无表业亦尔。前随心转七支无表能展转为俱有因故同异熟果。此中所说表无表业。则亦摄彼随转生等同一果故所受异熟如前应知

复次诸心不相应行受异熟色心心所法心不相应行。此心不相应行与彼异熟为异熟因。是谓异熟因。问诸心心所表无表业随转生等。如前已说。同一果故。今复说何不相应行。答今说无想定灭尽定一切不善善有漏得及彼随转生等诸相。前未说故。问无想定受何异熟果耶。有说。无想定受无想及色异熟果。彼命根众同分异熟。是第四静虑有心业果。彼余蕴异熟是共果。有说无想定受无想及色异熟果。彼命根异熟是第四静虑有心业果。彼余蕴异熟是共果。有说。无想定受无想及色异熟果。彼余蕴异熟是共果。有说。无想定唯受无想异熟果彼余蕴异熟是共果。问若命根亦是非业异熟果者。品类足论当云何通。如说。一法是业异熟而非业谓命根。答一切命根唯是异熟。一切异熟由业故显。依此密意故作是言。而实命根亦非业感。复次彼论依世俗说不依胜义。谓诸世间见短寿者即言。是人作短寿业。见长寿者即言。是人作长寿业。有说。无想天处无心时亦受第四静虑有心业果。有心时亦受无想定果。问若无心时亦受有心果。有心时亦受无心果者。云何因果不颠倒耶。答如有色业亦受无色果。无色业亦受有色果。而无因果颠倒过失。此亦如是。尊者设摩达多说曰。无想定受无想及众同分异熟果。彼命根及色异熟。是第四静虑有心业果。彼心心所及余心不相应行。皆非异熟。评曰。彼不应作是说。异熟众同分是业果故。彼心心所及余心不相应行亦有是异熟者。故尊者佛陀提婆说曰。无想定受无想异熟果。彼命根众同分。是第四静虑有心业果。彼余蕴异熟是共果。评曰。彼不应作是说。眼等五根是业果故。应作是说。无想异熟唯是无想定果。彼命根众同分及五色根异熟。唯是第四静虑有心业果。彼余蕴异熟是共果。问灭尽定受何异熟果耶。答受非想非非想处四蕴异熟果。除命根众同分。彼唯是业果故。问诸得受何异熟果耶。答诸得受色心心所法心不相应行异熟果。色者谓色香味触。非五色根。彼业果故。心心所法者谓苦受乐受不苦不乐受。及彼相应法心不相应行者。谓诸得生老住无常。尊者僧伽筏苏说曰。得亦能受眼等五根及命根众同分异熟果。彼作是说。虽一一得无力能引众同分等众得聚集则能引彼然彼唯感愚钝之身。如蚯蚓等得所感色九处除声。心心所法通三受聚不相应行。谓众同分命根诸得生住异灭。评曰。彼不应作是说。诸得相望非俱有因。设集俱胝复何所益。非一果故不能共引众同分等。尊者妙音作如是说。得不能引众同分等。诸业引得众同分等时于眼等根处。但能感得色香味触。评曰。彼不应作是说。勿无色界得无异熟果故。是以应知初说为善

问品类足说。云何异熟因。谓一切不善善有漏法。与此论所说异熟因。有何差别。答此不了义彼是了义。此有余意彼无余意。此有余因彼无余因。此依世俗彼依胜义。此有影显彼无影显。复次此说已生异熟因。彼说已生未生异熟因。此说与果异熟因。彼说与果未与果异熟因。复次此说新业果。彼说新旧业果。复次此说过去异熟因。彼说三世异熟因。复次此说正与果异熟因。彼说已正当与果异熟因。是谓此说彼说差别。问何故此中但说正与果异熟因耶。答正与果者其相显故。复次彼果现前施设五趣诸有情故。复次尔时此因用究竟故以正与果。显示当与已与果因。于义便故。此中但说正与果因

复次欲界中有四蕴异熟因得一果。谓善不善心心所法及彼生等。有二蕴异熟因得一果。谓善不善身业语业及彼生等。有一蕴异熟因得一果。谓得及彼生等。色界中有五蕴异熟因得一果。谓有随转色心心所法及彼生等。有四蕴异熟因得一果。谓无随转色善心心所法及彼生等。有二蕴异熟因得一果。谓善身语表及彼生等。有一蕴异熟因得一果。谓得无想定及彼生等。无色界中有四蕴异熟因得一果。谓善心心所法及彼生等。有一蕴异熟因得一果。谓得灭尽定及彼生等。复次有业唯受一处异熟。谓得命根众同分业。彼业唯受法处异熟。有业唯受二处异熟。谓得意处业。彼业唯受意处法处异熟。得触处业亦受二处异熟。谓触处法处。得身处业受三处异熟。谓身处触处法处。得色香味处业亦尔。各受自处触处法处异熟。得眼处业受四处异熟。谓眼处身处触处法处。得耳鼻舌处业亦尔谓各受自处身处触处法处异熟。有余师说。一切大种皆生色声。欲界诸色不离香味。彼作是说。得眼处业受七处异熟。谓眼处身处及色香味触法处异熟。得耳鼻舌处业亦尔。谓各受自处身处及色香味触法处异熟。得身处业受六处异熟。谓身处及色香味触法处异熟。得色处业受五处异熟。谓色香味触法处异熟。得香味触处业亦尔。谓各受色香味触法处异熟。如是所说是定得者。不定得者其数不定。然有业能受八处异熟。有业能受九处异熟。有业能受十处异熟。有业能受十一处异熟。皆除声处。问何故有业能受多处异熟。有业能受少处异熟耶。答若业有种种功能得种种果者。受多处异熟。若业无种种功能不得种种果者。受少处异熟。如外种子有种种功能得种种果者。如稻甘蔗葡萄藕等。无种种功能不得种种果者。如素酌迦多罗子等。谓泽中有草名素酌迦。一种一茎而高数尺。上有少叶其形如盖。有多罗树高逾百肘。上亦少叶其形如盖。质干虽长果实甚少。业亦如是。然一世业得三世果。无三世业得一世果。一刹那业得多刹那果。无多刹那业得一刹那果。业善不善果无记故。如所生果不减因故

问诸造业者为先造引众同分业。为先造满众同分业耶。有作是说。先造引业后造满业。若先不引后无所满。犹如画师先作摸位后填众彩。此亦如是。有余师说。先造满业后造引业。如菩萨先于三无数劫造满业已。后于百大劫中方造引业。如是说者。此则不定。或有先造引业后造满业。或有先造满业后造引业。随造业者意乐起故

复次有三种受异熟业。一顺现法受业。二顺次生受业。三顺后次受业。顺现法受业者。若业此生造作增长。即于此生受异熟果。非于余生。顺次生受业者。若业此生造作增长。于次后生受异熟果。非于余生。顺后次受业者。若业此生造作增长。于第三生或第四生以后。如次受异熟果。然异熟声说多种义。有处等流说名异熟。如说受是爱支异熟。有处长养说名异熟如说饮食及诸医药得乐异熟有处梦事说名异熟如说梦见如是如是种类异熟。有处丰俭说名异熟。如说。星宿在此路行。当有如是丰俭异熟。有处梵王说名异熟。如说大仙我且未去观此光明有何异熟。有处异熟说名异熟。如此中说色等异熟果名为异熟。熟有二种。一者同类。二者异类。同类熟者。即等流果。谓善生善。不善生不善。无记生无记。异类熟者。即异熟果。谓善不善生无记果。此无记果从善不善异类因生故名异熟。问若异类而熟名异熟果者。何故恶趣名非熟耶。答彼亦异熟。然下贱故说名非熟。如有下贱村城等物名非村等。复次过熟故名非熟。如拙陶师烧诸瓦器。多费薪草器皆燋融。不任贸用亦名非熟。恶趣亦尔。苦果太过故名非熟。复次于彼无善异熟故名非熟。问傍生鬼趣亦受善果。如何恶趣皆名非熟。答彼善果少故亦名无。如少水河亦名无水。复次彼趣虽有善果。而不能修余胜善法。故名非熟。譬如农夫收获鲜少亦名非熟。而实恶趣有异熟果

问何故不善善有漏法有异熟果。无记无漏法无异熟果耶。答自性众缘有具有阙三种不同。如外种故。如坚实种置良田中。以水溉灌覆之粪坏。因缘力具即便生芽。如是不善善有漏法自性坚实。置有田中溉之爱水覆以余结。因缘力具便生有芽。如坚实种置于仓中。水粪缘阙不能生芽。如是无漏善有为法体虽坚实。而阙爱水余结润覆有芽不生。如朽败种虽置良田以水溉灌覆之粪坏。而因力阙不能生芽。如是无记诸有为法。虽以爱水余结润覆。而体羸劣有芽不生。问复何缘故诸无漏法无异熟果。答非田非器。乃至广说。复次若法能令诸有诸趣生老病死恒相续者有异熟果。无漏能令诸有诸趣生老病死究竟断故无异熟果。复次若法能令诸有诸趣渐增长者有异熟果。无漏能令诸有诸趣渐损减故无异熟果。复次若法是苦诸有世间生老病死趣集行者有异熟果。无漏是苦诸有世间生老病死趣灭行故无异熟果。复次若法是身见事是颠倒事。是贪爱事是随眠事。有垢有毒有秽有浊。随苦集谛堕三有者有异熟果。诸无漏法不同彼故无异熟果。复次若无漏法有异熟者。则为胜因得下劣果。因是无漏善有为法。果是有漏无记法故。复次若无漏法有异熟者。则为圣道令有相续。圣道续有与理相违。复次若无漏法有异熟者。何处当受。若在欲界则不应理。无漏法非欲界系故。如色无色界业。若在色界亦不应理。无漏法非色界系故。如欲无色界业。若在无色界亦不应理。无漏法非无色界系故。如欲色界业。若在三界外亦不应理。以三界外无别处故。复次无漏圣道对治异熟及异熟因。若复能感异熟果者。复须对治对治此者。是无漏故。复感异熟为对治彼复修圣道。即彼圣道复感异熟。如是展转便为无穷。是则应无解脱出离勿有此过。故无漏法无异熟果。复次若无漏法感异熟者。则应毕竟不得涅槃。圣者不应精勤修习。是招生死轮转法故。由此无漏无异熟果。问复何缘故诸无记法无异熟果。答非田非器。乃至广说。复次若无记法有异熟果。此异熟果为是无记为善不善。若是无记。何故名异熟非异类熟故。若善不善亦非异熟。以异熟果是无记故。复次若无记法有异熟者。此异熟果是无记故应有异熟。即彼异熟复应能感余异熟果。如是展转便为无穷。是则应无解脱出离。勿有此过故无记法无异熟果。由如是等种种因缘。唯诸不善善有漏法。是异熟因

说一切有部发智大毗婆沙论卷第十九阿毗达磨大毗婆沙论卷第二十

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中智纳息第二之十二

问一刹那业为但能引一众同分。为亦能引多众同分耶。设尔何失。若一刹那业但能引一众同分者。施设论说当云何通。如说有诸众生曾在人中。或作国王或作大臣。具大势力非理损害无量众生。税夺资财供给自身及诸眷属。由是恶业死堕地狱。经无量时受大苦恼。从彼舍命复由残业生大海中。受恶兽身其形长大。啖食无量水陆众生。亦为无量众生唼食。遍着其体如拘执毛。既受苦痛不能堪忍。以身揩突颇胝迦山在彼身虫俱被残害。遂令海水纵广百千踰缮那量皆变成血。又若尔者。尊者无灭所说本事复云何通。如说。具寿。我以一食施福田故。七生天上作大天王。七生人中为大国主。又若尔者。大迦叶波所说本事复云何通。如说。具寿。我以一器稗子米饭施福田故。千返生彼北俱卢洲自然衣食。千返生彼三十三天受大快乐。又若尔者。盐喻经说复云何通。如说。一类补特伽罗造作增长尔许恶业有应地狱受者。或现法受。有应现法受者往地狱受。若一刹那业亦能引多众同分者施设论说当云何通。如说。由业种种差别势力。施设诸趣种种差别。由趣种种差别势力。施设诸生。种种差别。由生种种差别势力。施设异熟种种差别。由异熟种种差别势力。施设诸根种种差别。由根种种差别势力。施设补特伽罗种种差别。又若尔者。通达经说复云何通。如说。云何应知诸业差别。谓别业生地狱。别业生傍生。别业生饿鬼。别业生天上。别业生人中。又若尔者。云何建立顺现法受等三业差别。又若尔者。施设论说复云何通。如说。造作增长上杀生业。身坏命终堕无间狱。中生余处下复生余。乃至广说。答应作是说。一刹那业唯能引一众同分。问若尔。施设论说当云何通。如说。有诸众生曾在人中。乃至广说。答由残业者由别趣业。谓彼人中造作增长地狱傍生二恶趣业。地狱中受地狱业已。残傍生业生大海中。故此残声非望一业。问尊者无灭所说本事复云何通。如说。具寿。我以一食施福田故。乃至广说。答彼显初因故作是说。谓彼先以一食施故。生富贵家多饶财宝。由宿生念或本愿力。复以百千财食布施。如是展转经于多生。常好布施受大富乐。彼依初因故作是说。譬如农夫以少种子多年种殖。展转增长至百千斛。唱如是言。我殖少种今获百千。又如商客以一金钱多时贸易至于千万。唱如是言。我用一钱经求滋息。今至千万。此等皆依最初因故作如是说。尊者亦尔。复次或彼尊者于一生中先施一食后复数施。由此引发多人天因。彼依最初故作是说。复次或彼尊者施一食时起多思愿。由此引得天上人中多异熟果。复次或彼尊者因施一食。起下中上三品善业。由下业故生在人中得为人主。由中业故生于天上复作天王。由上业故于最后身生释氏家。多饶财宝出家修道成阿罗汉。由此理趣则已释通大迦叶波所说本事。问盐喻经说复云何通。如说。一类补特伽罗。乃至广说。有作是说。彼说二人造二种业感二异熟。谓有二人俱害生命。一不勤修身戒心慧。彼少福故往地狱中受此业异熟果。一能勤修身戒心慧。彼多福故即于人中受此业异熟果。问经言尔许。说何义耶。答若少若等若相似故说名尔许。有余师说。彼说一人造二种业感二异熟。谓有一人害二生命。一业能引地狱异熟。一业能引人中异熟。彼若不修身戒心慧。便往地狱受别业异熟果若能勤修身戒心慧。即于人中受别业异熟果。复有说者。彼说一人造一种业感二异熟。谓有一人害一生命。此业能引地狱异熟。兼复能引人中异熟。彼若不修身戒心慧。便往地狱受异熟果。人中异熟果住不生法中。若能勤修身戒心慧。即于人中受异熟果。地狱异熟果住不生法中。评曰。彼不应作是说。勿有业坏趣坏过故。业坏者。谓一业亦是地狱业亦是人业。趣坏者。应一异熟亦是地狱趣亦是人趣果似因故。应作是说。彼说一人造一种业感一异熟。谓有一人害一生命。此业能引地狱异熟。彼若不能精勤修道成阿罗汉。便往地狱受此业果。彼人若能精勤修道成阿罗汉。便能引取地狱苦事。人身中受此业。不能引众同分。引众同分业不可寄受故。由此尊者世友说言。颇有能引地狱苦事人中受不。答曰有能。谓若证得阿罗汉果殊胜定慧薰修身故能为此事。非诸有学及诸异生能为此事。譬如厨人以水渍手虽探热饭而不被烧。若不渍手即便被烧。此亦如是。故唯无学能为此事。有余师说。一刹那业亦能引多众同分。问若尔。前难善通。后难云何通耶。答有情造业品类不定。有所造业杂乱可转。有所造业不杂乱不可转。若杂乱可转者。如前所引。若不杂乱不可转者。如后所引。如是前后二难俱通。评曰。彼不应作是说。勿有业坏趣坏过故。应作是说一刹那业唯能引一众同分

复次但由不善引众同分业生地狱中。既生彼已唯受不善法异熟色心心所法不相应行。色者九处除声。心心所法者苦受及相应法。不相应行者。命根众同分得生老住无常。但由不善引众同分业。生傍生鬼趣中。既生彼已受善不善法异熟。色心心所法不相应行不善法异熟。色者。九处除声。心心所法者。苦受及相应法。不相应行者。命根众同分得生住老无常。善法异熟色者。四处。谓色香味触。心心所法者。乐喜舍受及相应法。不相应行者。得生老住无常。有余师说。善法于傍生鬼趣无异熟色。唯有异熟心心所法不相应行。问若尔。何故现见傍生鬼趣中。有形色妙好或丑陋耶。答彼不善业。或有以善业为眷属。或有以不善业为眷属。若以善业为眷属者。形色妙好。善伏不善弊恶力故。若以不善业为眷属者形色丑陋。不善增彼弊恶力故。评曰。善业于彼傍生鬼趣。亦能感异熟色。于理无违。是故应知初说为善。但由善引众同分业。生欲界人天中。既生彼已受善不善法异熟。色心心所法不相应行。善法异熟色者。九处除声。心心所法者。乐喜舍受及相应法。不相应行者。命根众同分得生老住无常。不善法异熟色者。四处。谓色香味触。心心所法者。苦受及相应法。不相应行者。得生老住无常。有余师说。不善法于人天趣无异熟色。唯有异熟心心所法不相应行。问若尔。何故现见人天趣中有形色丑陋或妙好耶。答彼善业。或以不善业为眷属。或以善业为眷属。若以不善业为眷属者。形色丑陋。不善伏善美丽力故。若以善业为眷属者。形色妙好。善业增彼美丽力故。评曰。应知此中初说为善。不违理故。问现见人中有二形者。彼为是善业异熟。为是不善业异熟耶。有作是说。彼是不善业异熟。有余师说。如处如时一形生者。是善业异熟。非处非时第二形生者。是不善业异熟评曰。应作是说。彼二形者男女根体。是善业。异熟。于彼处所色香味触。是不善业异熟。但由善引众同分业生色界中。既生彼已唯受善法异熟。色心心所法不相应行。色者七处除声香味。心心所法者乐喜舍受及相应法。不相应行者命根众同分无想事得生老住无常。但由善引众同分业生无色界。既生彼已唯受善法异熟。心心所法不相应行。心心所法者。舍受及相应法。不相应行者。命根众同分得生老住无常

复次有作是说。但由上品不善引众同分业生地狱中。既生彼已唯受彼上品不善法异熟果。但由中品不善引众同分业生傍生趣。既生彼已唯受彼中品法异熟果。但由下品不善引众同分业生鬼趣中。既生彼已唯受彼下品法异熟果。有余师说。但由上品不善。引众同分业生地狱中。既生彼已受彼上中二品不善法异熟果。傍生鬼趣如前说。或复有说。但由上品不善引众同分业生地狱中。既生彼已受彼三品不善法异熟果。但由中品不善引众同分业生傍生趣。既生彼已受彼中下二品法异熟果。鬼趣如前说。或有说者。但由上品不善引众同分业生地狱中。既生彼已受彼三品不善法异熟果。但由中品不善引众同分业生傍生趣。既生彼已受彼三品法异熟果。但由下品不善引众同分业生鬼趣中。既生彼已受彼下中二品法异熟果。复有说者。但由上品不善引众同分业生地狱中。既生彼已受彼三品不善法异熟果。但由中品不善引众同分业生傍生趣。既生彼已受彼三品法异熟果。但由下品不善引众同分业生鬼趣中。既生彼已受彼三品法异熟果。评曰应作是说。有三品不善引地狱趣众同分业随由一种生地狱中。既生彼已随其所应受彼三品不善法异熟果。有三品不善引傍生趣众同分业随由一种生傍生趣。既生彼已随其所应。受彼三品法异熟果。有三品不善引鬼趣众同分业随由一种生鬼趣中。既生彼已随其所应受彼三品法异熟果

复次有作是说。但由欲界上品善引众同分业生他化自在天。既生彼已唯受彼上品法异熟果。但由欲界中品善引众同分业生下五天。既生彼已唯受彼中品法异熟果。但由欲界下品善引众同分业生人趣中。既生彼已唯受彼下品法异熟果。问若由下品善业生人趣中。受下品法异熟果者。菩萨善业亦人中受云何上品。又菩萨善业与他化自在天善业。有何差别。答所说欲界下品善业人中受者除菩萨业。故作是说。非说一切。有余缘故菩萨业胜。以菩萨身是力无畏等无边功德所依止故。他化自在天身无如是事。有余缘故他化自在天业胜。以彼天身清净微妙如灯焰故。菩萨生身犹有种种便利不净。有余师说。但由欲界上品善引众同分业生他化自在天。既生彼已受彼上中二品法异熟果。下五天人趣如前说。或复有说。但由欲界上品善引众同分业生他化自在天。既生彼已受彼三品法异熟果。但由欲界中品善引众同分业生下五天。受彼下中二品法异熟果。人趣如前说。或有说者。但由欲界上品善引众同分业生他化自在天。既生彼已受彼三品法异熟果。但由欲界中。品善引众同分业生下五天。既生彼已受彼三品法异熟果。但由欲界下品善引众同分业生人趣中。既生彼已受彼下中二品法异熟果。复有说者。但由欲界上品善引众同分业生他化自在天。既生彼已受彼三品法异熟果。但由欲界中品善引众同分业生下五天。既生彼已受彼三品法异熟果。但由欲界下品善引众同分业生人趣中。既生彼已受彼三品法异熟果。评曰。应作是说。有三品善引他化自在天众同分业。随由一品生他化自在天。既生彼已随其所应受彼三品法异熟果。有三品善引下五天众同分业。随由一品生下五天。既生彼已随其所应受彼三品法异熟果。有三品善引人趣众同分业。随由一品生人趣中。既生彼已随其所应受彼三品法异熟果

复次有三品善引初静虑无别异众同分业。随由一品生初静虑。既生彼已随其所应受彼三品无别异善法异熟果。但由下品善引第二静虑众同分业生少光天。既生彼已唯受彼下品善法异熟果。但由中品善引第二静虑众同分业生无量光天。既生彼已唯受彼中品善法异熟果。但由上品善引第二静虑众同分业生极光净天。既生彼已唯受彼上品善法异熟果但由下品善引第三静虑众同分业生少净天。既生彼已唯受彼下品善法异熟果。但由中品善引第三静虑众同分业生无量净天。既生彼已唯受彼中品善法异熟果。但由上品善引第三静虑众同分业生遍净天。既生彼已唯受彼上品善法异熟果。但由下品善引第四静虑众同分业生无云天。既生彼已唯受彼下品善法异熟果。但由中品善引第四静虑众同分业生福生天。既生彼已唯受彼中品善法异熟果。但由上品善引第四静虑众同分业生广果天。既生彼已唯受彼上品善法异熟果。但由下品杂修静虑引第四静虑众同分业生无烦天。既生彼已唯受彼下品杂修静虑法异熟果。但由中品杂修静虑引第四静虑众同分业生无热天。既生彼已唯受彼中品杂修静虑法异熟果。但由上品杂修静虑引第四静虑众同分业生善现天。既生彼已唯受彼上品杂修静虑法异熟果。但由上上品杂修静虑引第四静虑众同分业生善见天。既生彼已唯受彼上上品杂修静虑法异熟果。但由上极品杂修静虑引第四静虑众同分业生色究竟天。既生彼已唯受彼上极品杂修静虑法异熟果。有三品善引空无边处无别异众同分业。随由一品生空无边处。既生彼已随其所应。受彼三品善法异熟果。有三品善引识无边处无别异众同分业。随由一品生识无边处。既生彼已随其所应。受彼三品善法异熟果。有三品善引无所有处无别异众同分业。随由一品生无所有处。既生彼已随其所应。受彼三品善法异熟果。有三品善引非想非非想处无别异众同分业。随由一品生非想非非想处。既生彼已随其所应。受彼三品善法异熟果。问何故初静虑三品善业受无别异异熟果。上三静虑三品善业受有别异异熟果耶。答初静虑中有众有主杂乱而住。上三静虑无此事故。有余师说。初静虑中有寻有伺有诸识身及起自地身语表业。上三静虑无此事故

复次欲界中不善业有一劫异熟果。善业不尔。欲界中不善业有五趣异熟果。善业不尔。问何故欲界中不善业有一劫异熟果。善业不尔耶。答欲界是不定界。非修地。非离染地。不善业胜。善业劣故。复次欲界中。不善法难断。难破。难可越度。善不尔故。复次欲界中不善根强。善根弱故。复次欲界中。不善如主。善如客故。复次欲界中不善法因常增长。善因不尔故。复次欲界中。不善根能断善根。善根不能断不善根故。复次欲界中威仪杂乱。犹如夫妻。不善法增善法减故。复次欲界中威仪无杂。如旃荼罗子与贼子同囚。不善法增善法减故。复次欲界中无器可受善业。一劫异熟故。问岂无洲渚妙高山王七金山等一劫器耶。答彼是增上果非异熟果。今依异熟果故作是说。复次欲界善业极增上者。亦有能感一劫异熟。如是善业要离非想非非想处第九品得。已离染业定不能引众同分果。是故欲界无善能受一劫异熟。复次诸善法中。最上品者谓无漏善。彼无异熟。有漏善中最上品者。谓有顶善。彼非欲界。是故欲界善业无有一劫异熟。不善业中最上品者。谓引无间众同分业。是故彼有一劫异熟。问何故善业极增上者能感有顶八万大劫。不善唯感一中劫耶。答善业多界多地修习。诸不善业不如是故。问何故欲界中不善业有五趣异熟果。善业不尔耶。答前来所说皆是此因。谓欲界中不善业胜。此中复有一不共因。谓欲界是不善田故。如有恶田嘉苗难殖秽草易生。欲界亦尔。善业难茂不善易生。故不善业于一趣全四趣少分受异熟果。善业唯于四趣少分受异熟果。有余师说。善与不善互有胜事故不应责。谓不善业五趣受果不遍三界。善业遍于三界受果不遍五趣。俱胜事者。谓善恶业俱遍四生受异熟果。又俱能受五蕴异熟

如契经说。业是眼因。阿毗达磨说大种是眼因。即彼复说眼是眼因。问如是三说。岂不相违。答无相违失。谓依异熟因故。契经中说。业是眼因。依生因。依因住因持因养因故。阿毗达磨说大种是眼因。依同类因故。即彼复说眼是眼因。问若大种及眼亦是眼因。何故契经唯说业是眼因。答业是本故。如说。由业种种差别势力。施设诸趣种种差别。乃至由根种种差别势力。施设补特伽罗种种差别。复次业是有情差别因故。谓由业故有情好丑贵贱差别。复次业是七众差别因故。谓由业故有苾刍等轨范差别。复次业能分别爱非爱果有差别故。复次业是愚智能表相故。复次业印众生令差别故。复次诸根差别由业别故。如芽差别由种别故。复次诸有情类寿量增减进退兴衰皆由业故。复次诸界诸趣诸生差别皆由业故。由如是等种种因缘。契经但说业是眼因

如契经说。于杀生罪数习广布。当堕地狱傍生鬼趣。后生人中寿量短促。问为由此业堕诸恶趣。即由此业寿短促耶。有作是说。由此恶业堕诸恶趣。即由此业还来人中寿量短促。彼经不说有别因故。复有说者。由杀生加行堕诸恶趣。由杀生根本后生人中寿量短促。复有说者。堕诸恶趣是杀生异熟果。后生人中寿量短促。是杀生等流果。复有说者。由害生命堕诸恶趣。由食彼肉后生人中寿量短促。复有说者。害生命者有二过失。一者生彼非爱苦受。二者断彼所爱寿量。由生彼非爱苦受故堕诸恶趣。由断彼所爱寿量故后生人中寿量短促。尊者世友说曰。人中寿量短者。非杀业异熟果。以人天趣命等八根是异熟者。唯是善业异熟果故。然造业者昔在人中先造能引人寿量业。次后复造害生命业。此业与前作损害事。前业应受二十年寿。由后损害但受十年。故人寿短促非彼异熟果。如契经说。十岁时人由能受行善业道故。所生男女寿二十岁。问无他造业他受果理。何故十岁父母修善。令所生子寿二十岁。尊者世友作如是言。即十岁人共修善故。命终转作二十岁子。故无他作他受过失。大德说曰。业异熟果各别决定。谓二十岁业感二十岁果。乃至八万岁业感八万岁果。然由父母修善业故。令子所造业能与果。虽无他作业他受果理。而有互为缘业与果义。问十岁时人不杀生等成业道不。有作是说。彼非业道但共立制不害生等。无增上心决意受持不杀等故。有余师说。亦是业道彼亦专心展转相对受远离故

复次施设论说。有四种死。一寿尽故死非财尽故。如有一类有短寿业及多财业。彼于后时寿尽故死非财尽故。二财尽故死非寿尽故。如有一类有少财业及长寿业。彼于后时财尽故死非寿尽故。三寿尽故死及财尽故。如有一类有短寿业及少财业。彼于后时寿尽故死及财尽故。四非寿尽故死亦非财尽故。如有一类有长寿业及多财业。彼于后时虽财与寿二俱未尽。而遇恶缘非时而死。作彼论者。显有横死故作是说。佛虽财寿俱未尽故而般涅槃。然非横死。边际定力所成办故。功德威势未穷尽故。诸余有情于命终位威势穷尽。佛不如是

复次施设论说。颇有不受顺现法受业异熟。而受顺次生受业及顺后次受业异熟耶。答有。谓顺现法受业异熟不现在前。顺次生受业及顺后次受业异熟现前。颇有不受顺次生受业异熟。而受顺现法受业及顺后次受业异熟耶。答有。谓顺次生受业异熟不现在前。顺现法受业及顺后次受业异熟现前。颇有不受顺后次受业异熟。而受顺现法受业及顺次生受业异熟耶。答有。谓顺后次受业异熟不现在前。顺现法受业及顺次生受业异熟现前。此要证得阿罗汉果。方有是事非不得者。问有学异生亦应有如是事。何故彼论但说阿罗汉耶。答唯阿罗汉有胜定慧薰修身故有如是能。有学异生无如是事。复次唯阿罗汉能善知自业有近有远有可转有不可转。诸可转者以修力转之。若不可转者引现前受无后有故。譬如有人欲适他国所有债主悉来现前彼人即便回转酬偿。此说满业可有是事众同分业不并受故。又一相续无断续故。有余师说。有业前生虽受异熟而有余残。今时证得阿罗汉果以胜修力及决择力引现前受。唯阿罗汉有如是能故彼偏说

问异熟因以何为自性。答一切不善善有漏法。已说自性。所以今当说。问何故名异熟因。异熟是何义。答异类而熟是异熟义。谓善不善因以无记为果。果是熟义如前已说。此异熟因定通三世。有异熟果

云何能作因乃至广说。问何故作此论。答为止他宗显正理故。谓或有执。诸法生时无因而生如诸外道。为止彼执显诸法生决定有因。或复有执。诸法生时虽由因生。而诸法灭时不由因灭如譬喻者。为止彼执显诸法生灭无不由因。或复有执。唯有为法是能作因非无为法。为止彼执显无为法亦能作因。或复有执。诸能作因皆有作用取果与果。为止彼执显能作因亦有不能取果与果。但不为障亦立为因。或复有执。自性于自性亦是能作因。为止彼执显自性于自性非能作因。或复有执。诸无为法亦有能作因。为止彼执显有为法有能作因非无为法。或复有执后法于前非能作因。为止彼执显能作因于前于后及俱诸法皆能为因。为止此等种种异执显示正因故作斯论

云何能作因。答眼及色为缘生眼识。此眼识以彼眼色彼相应法彼俱有法。及耳声耳识鼻香鼻识舌味舌识身触身识意法意识。有色无色有见无见有对无对有漏无漏有为无为等。一切法为能作因除其自性。如眼识耳鼻舌身意识亦尔。是谓能作因。此中彼相应法彼俱有法者。谓眼识相应俱有诸法。问前眼色等六二门法。或六三门法。善标善释施设显示一切法体为能作因其义已足。何故复说有色无色等五二法耶。答前是广说后是略说。前是别说后是总说。前是分别说后是不分别说。前是渐说后是顿说。如是显示其义明了。问此中何故不但说言云何能作因答一切法。答若作是说应自性与自性作能作因。问若尔何故不作是说。云何能作因答一切法除其自性。答若作是说应无为亦有能作因无简别故。问若尔何故不作是说。云何能作因答一切有为法除其自性。答若作是说。应无为法非能作因。问何故此中但说六识以所余法为能作因非余有为法耶。答识于诸法最为胜故。此中六因皆就胜说并不尽理。问若尔眼识除其自性余一切法是能作因。何故此中先说眼色次说彼相应俱有法。后说耳等一切法耶。答眼色与眼识作所依所缘能作因义势用强故。相应俱有法与眼识作能作因势用亲故。耳等不尔是故后说。问何故自性于自性非能作因耶。答若自性于自性为能作因者。则应因果能作所作能生所生能引所引能相所相能转所转能续所续皆无差别因果等。二既有差别故于自性非能作因。复次自性于自性无益无损无增无减无成无坏无进无退故非能作因。复次自性于自性非因。非等无间。非所缘。非增上故非能作因。复次若自性于自性为能作因。便违世间诸现见事。谓指端不自触。眼不自见。刀不自割。诸有力人不能自负如是一切。复次自性于自性无有自在无观待故非能作因。复次自性不依自性故非能作因。如人依杖得起。去杖便倒。自性于自性无如是义。复次无障碍分是能作因。诸法自性障碍自性故非能作因。障碍有二种。一者世俗如人在床障阂余者。二者胜义。如自性障碍自性令不自在。复次若自性于自性为能作因。应说无明缘无明等非无明缘行等。应说眼识为缘生眼识等非眼色为缘生眼识等。是故自性于自性非能作因其义决定

说一切有部发智大毗婆沙论卷第二十阿毗达磨大毗婆沙论卷第二十一

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中智纳息第二之十三

能作因体即增上缘。俱一切法为自性故。然义有异。谓多胜义是增上缘义。不障碍义是能作因义。问若多胜义是增上缘义。则所缘缘亦应名增上。彼体亦摄一切法故。如品类足论辩。此二缘俱以一切法为自性故。答若依相续则此二缘宽狭相似。若依刹那则增上缘体义多胜。谓缘一切法非我行相现在前时。一切法中非所缘者。谓此自性相应俱有。非增上者唯此自性。由此相应俱有诸法。是此增上非所缘故。问若不障碍义是能作因义者。则能作因体应不摄一切法。谓一有情若有一趣蕴界处起。即此有情更无第二蕴界处生。若依一眼一眼识生。于中更无第二识起。如于一处。若有一树无第二树。若有一舍无第二舍。如是诸法互相障碍。云何此因摄一切法。答虽有此事而理无违。谓一有情若有一趣蕴界处起义。语诸余蕴界处曰。我于汝等不为障碍随汝等生。设我与汝为障碍者。汝等于彼则不得生。若依一眼眼识现前。此识义语余眼识言。我于汝等不为障碍随汝等生。设我与汝为障碍者。汝等于彼不得现前。树及舍喻准此应说。又即于彼为障碍者。彼若生时亦不为碍。是故一法将欲生时。余一切法皆不为碍。设有一法障碍彼者。彼法尔时应不得起故。不障碍义是能作因义。而能作因摄一切法。问因缘和合故诸法生。因缘和合故诸法灭。因缘无有不和合时。诸法云何不恒生灭。尊者世友作如是言。一生和合故诸法生。一灭和合故诸法灭。生灭和合无二无多。诸法云何恒生恒灭。复作是言。因缘和合诸法生已。次后相续无量刹那。连注覆压不能复起。如人堕崖复为上土续续覆压。彼人尔时尚不能动况得起耶。大德说曰。和合因缘既唯暂有。云何诸法恒生灭耶。尊者觉天作如是说。诸法生灭各唯一时。应有作用生已复生。灭已复灭便为无用。是故诸法生灭非恒。问因缘和合生诸法时。因缘功能为多为一。若言唯一云何依多。若言有多云何和合。答可说为一可说为多。办一事故依多体故。复次因缘功能相随顺故。可说为一生多法故可说为多。复次因缘功能同令诸法起作用故可说为一。起色受等作用别故可说为多。若彼功能无多种者。所起作用色非色等应无差别。是故诸法因缘功能。不可定言是多是一。问如有因缘故诸法得生。亦有因缘故诸法灭耶。譬喻尊者作如是说。生待因缘灭则不尔。如人射时发箭须力堕则不然。如陶家轮转时须力止则不尔。阿毗达磨诸论师言。诸法生灭俱待因缘以灭与生皆是用故。问前所说喻当云何通。答不必须通非三藏故。然凡圣法异不可例同。又箭与轮亦由因堕止。箭堕因者谓排楯的等。设无余因则弯弓等亦是其因。若不先射今何由堕。轮止因者谓手杖等。设无余因则能转者亦是其因。若先不转今何由止。问若排手等障碍箭轮令其堕止。如何与彼为能作因。答排手等物障彼行转。非碍堕止为能作因于理何失。问若法生灭俱待因缘。生灭因缘一切时有。何不生时亦灭灭时亦生耶。尊者世友作如是说。生灭两时和合各异。是故生时无灭灭时无生。不可一因有二果故。复作是说。生时因缘随顺彼法。灭时因缘违害彼法。虽彼因缘前后体一。而益损用时分不同。犹如苾刍解安居已。携持衣钵游历诸寺。有贼见之先申礼敬恭顺随逐。后至旷野夺其衣钵陵辱而去。生灭因缘亦复如是。大德说曰。生灭两事既互相违如何俱有。尊者妙音作如是说。诸法生时未有作用当何所灭。诸法灭时已有作用复何所生

问一法既与多法为能作因。多法亦与一法为能作因。一法与多法为能作因时。为如一法与多法为因。为如多法与多法为因耶。多法与一法为能作因时。为如多法与一法为因。为如一法与一法为因耶。设尔何失此一法与多法为能作因时。若如一法与多法为因者。云何不因一故果亦成一。若如多法与多法为因者。云何不果多故因亦成多。此多法与一法为能作因时。若如多法与一法为因者。云何不因多故果亦成多。若如一法与一法为因者。云何不果一故因亦成一。答应作是说。一法与多法为能作因时。亦如多法与一法为因。多法与一法为能作因时。亦如一法与多法为因。问若尔一应成多多应成一。答我说一亦成多多亦成一。此依作用不依实体。我说诸因以作用为果非以实体为果。又说。诸果以作用为因非以实体为因。诸法实体恒无转变非因果故。然无为法名能作因。但不为障非能办果

复次有为法与有为法为能作因。亦以彼为增上果。有为法不与无为法为能作因。亦不以彼为增上果。无为法不与无为法为能作因。亦不以彼为增上果。无为法与有为法虽为能作因。而不以彼为增上果。以无取果与果用故。问何故有为法有因有果。无为法无因无果耶。答有为法流转世故有因有果。无为不尔故无因果。如远行者须具资粮能有所至非不行者。复次有为法有作用故有因有果。无为不尔故无因果。如营务者须备作具能有所成非不营者。复次有为法有生灭故有因有果。无为不尔故无因果。复次有为法有和合故有因有果。无为不尔故无因果。复次有为法有三相故有因有果。无为不尔故无因果。复次有为法性羸劣故有因有作用故有果。如羸劣者依他而住非勇健者。无为不尔故无因果。复次有为法如王如王眷属。如富贵者如富贵者眷属如因陀罗如因陀罗眷属。故有因有果。无为不尔故无因果。问有为法不生者为有为法为留难故令彼不起。为无为法为留难故彼不生耶。答以有为法为留难故令彼不起非无为法。无为与彼为能作因于一切时不障碍故。如注水渎水若不流自为余因非渎为障。问无为法与有为法为能作因及增上缘时。何者为胜为缘彼者为余法耶。答等无差别如两豆聚。若无为法与有为法为所缘缘有是有非

复次过去法与过去法为能作因。亦以彼为增上果。过去法与未来现在法为能作因。亦以彼为增上果。义言我若不与汝为近能作因者汝则无因。然有为法无无因者。未来法与未来法为能作因。亦以彼为增上果。未来法与过去现在法为能作因。然不以彼为增上果。所以者何。果与因俱或在后故。义言我若不与汝为近能作因者汝则无果。然有为法无无果者。现在法与现在法为能作因。亦以彼为增上果。现在法与未来法为能作因。亦以彼为增上果。义言我若不与汝为近能作因者汝则无因。然有为法无无因者。现在法与过去法为能作因。然不以彼为增上果。果与因俱或在后故。义言我若不与汝为近能作因者汝则无果。然有为法无无果者。问何故后法与前法为能作因。而前法非后法增上果耶。答不障碍义是能作因义。后法于前法不障碍故得为能作因。果必是因力所取与。后法于前无取与力故前法非后果。如有为法以无为法为能作因而非彼果。彼无取果与果力故

复次善法与善法为能作因。亦以彼为增上果。善法与不善无记法为能作因。亦以彼为增上果。不善法与不善法为能作因。亦以彼为增上果。不善法与善无记法为能作因。亦以彼为增上果。无记法与无记法为能作因。亦以彼为增上果。无记法与善不善法为能作因。亦以彼为增上果。如善不善无记法展转为能作因及增上果。如是三界系不系法。学无学非学非无学法。见所断修所断不断法。有色无色法。有见无见法。有对无对法。有漏无漏法。相应不相应法等。应知亦尔

复次有善法与善法为近能作因。如由善业生乐善家。生已复能多修妙行。有善法与不善法为近能作因。如由善业生富贵家。生已放逸多造恶行。有不善法与不善法为近能作因。如由不善业生不律仪家。生已复造众多恶行。有不善法与善法为近能作因。如由不善业身遭病恼或失财位。心生厌悔修诸妙行。有内法与内法为近能作因。如一有情供多人众。有内法与外法为近能作因。如诸农夫种殖稼穑。有外法与外法为近能作因。如水粪等生长苗稼。有外法与内法为近能作因。如饮食等长养有情。有一趣法与五趣法为近能作因。如有多人食一羊肉身强盛已有作善业有作恶业。作善业者得生人天作恶业者堕三恶趣

问若一有情害生命时一切有情不障碍。彼无不与彼为能作因。何不一切俱得杀罪。答彼能杀者起杀加行。亦令果满故得杀罪。余不尔故不得杀罪。复次彼起恶心亦断他命故得杀罪。余不尔故不得杀罪。余业道等准此应知。问诸外财物一切有情共业所起。何故盗者唯于财主得罪非余。答财主于财摄受守护余则不尔。是故盗者唯于财主得罪非余。复次财主于财作己有想。盗者于彼作财主想。故唯于彼得罪。非余。复次若财物于彼是士用果及增果者于彼得罪。财物于余一切有情是增上果非士用果。是故于彼不得盗罪。问士用果与增上果有何差别。答作功力得者是士用果。不障碍得者是增上果。复次财物于作者是士用果。于用者是增上果。如诸果实于种殖者。是士用果亦增上果。于食用者唯增上果。如诸财物于营求者。是士用果亦增上果。于受用者唯增上果

问此器世界苏迷卢山洲渚等物一切有情共业所起。于中若有般涅槃者。何故此物不减少耶。尊者世友作如是说。若物是彼士用果及近增上果者亦有减少。苏迷卢等但是彼远增上果故无减少。复作是说。苏迷卢等一切有情共业所起。假使此中一有情在。由彼业力所任持故亦不减少。况有无量无边有情未得灭度。如富贵者虽已命终。而彼宫殿园林象马不随隐没。是余有情业力持故。此亦如是。复作是说。此中虽有无量有情得般涅槃及生他处。复有无量无边有情来生此界。由彼业力故不减少。尊者觉天作如是说。此是过去业力所持故无减少。问如转轮王于四洲渚皆得自在是何果耶。答自身威势是异熟果。所统领物是增上果。彼于过去修习增上自身众具诸善业故今得如是二殊胜果

复次有三种增上。一自增上。二世增上三法增上。自增上者。如有一类烦恼未断恶境现前。而为自护不起恶业勿我由斯堕诸恶趣。世增上者。如有一类烦恼未断恶境现前。护世间故不起恶业勿我由斯为世讥毁。有作是说。勿由我故世间有情造诸恶业。法增上者。如有一类烦恼未断恶境现前。为护法故不起恶业勿由我故令诸世间轻毁正法。此三即是近能作因。问何故此三说名增上。答以于善法不障碍故。是善亲近增上缘故。问能作因力有增减不。答有。如多人众挽大木时。中有尽力不尽力者。其尽力者能作因增。不尽力者能作因减。如彼挽木竖刹牵船转石等时应知亦尔。如内于外若外于内。外内自望亦复如是。问能作因与增上果何者为多。答能作因多增上果少。以能作因摄一切有为无为法。增上果唯摄有为法故。由此故说颇有法于法非能作因耶。答有。谓自性于自性。颇有法于他性非能作因耶。答有。谓有为于无为及无为于无为

问能作因以何为自性。答一切法。已说自性。所以今当说。问何故名能作因能作是何义。答不障碍义是能作义。有所办义是能作义。此能作因定通三世及离世法有增上果。如是已显六因自性。今当复显六因相杂不相杂义。问若法是相应因彼亦是俱有因耶。答若法是相应因彼亦是俱有因。有法是俱有因彼非相应因。谓有为不相应法。问若法是相应因彼亦是同类因耶。答应作四句。有法是相应因非同类因。谓未来相应法。有法是同类因非相应因。谓过去现在不相应法。有法是相应因亦同类因。谓过去现在相应法。有法非相应因非同类因。谓未来不相应法及无为法。问若法是相应因彼亦是遍行因耶。答应作四句。有法是相应因非遍行因。谓除过去现在遍行随眠及彼相应法诸余相应法。有法是遍行因非相应因。谓过去现在遍行随眠及彼相应法生住老无常。有法是相应因亦遍行因。谓过去现在遍行随眠及彼相应法。有法非相应因非遍行因。谓除过去现在遍行随眠及彼相应法。生老住无常诸余不相应法。问若法是相应因彼亦是异熟因耶。答应作四句。有法是相应因非异熟因。谓无记无漏相应法。有法是异熟因非相应因。谓不善善有漏不相应法。有法是相应因亦异熟因。谓不善善有漏相应法。有法非相应因非异熟因。谓无记无漏不相应法。问若法是相应因彼亦是能作因耶。答若法是相应因彼亦是能作因。有法是能作因彼非相应因。谓不相应法。问若法是俱有因彼亦是同类因耶。答若法是同类因彼亦是俱有因。有法是俱有因彼非同类因。谓未来法。问若法是俱有因彼亦是遍行因耶。答若法是遍行因彼亦是俱有因。有法是俱有因彼非遍行因。谓除过去现在遍行随眠及彼相应俱有法诸余有为法。问若法是俱有因彼亦是异熟因耶。答若法是异熟因彼亦是俱有因。有法是俱有因彼非异熟因。谓无记无漏有为法。问若法是俱有因彼亦是能作因耶。答若法是俱有因彼亦是能作因。有法是能作因彼非俱有因。谓无为法。问若法是同类因彼亦是遍行因耶。答若法是遍行因彼亦是同类因。有法是同类因彼非遍行因。谓除过去现在遍行随眠及彼相应俱有法诸余过去现在法。问若法是同类因彼亦是异熟因耶。答应作四句。有法是同类因非异熟因。谓过去现在无记无漏法。有法是异熟因非同类因。谓未来不善善有漏法。有法是同类因亦异熟因。谓过去现在不善善有漏法。有法非同类因非异熟因。谓未来无记无漏法及无为法。问若法是同类因彼亦是能作因耶。答若法是同类因彼亦是能作因。有法是能作因彼非同类因。谓未来法及无为法。问若法是遍行因彼亦是异熟因耶。答应作四句。有法是遍行因非异熟因。谓过去现在无记遍行随眠及彼相应俱有法。有法是异熟因非遍行因。谓除过去现在不善遍行随眠。及彼相应俱有法。诸余不善善有漏法。有法是遍行因亦异熟因。谓过去现在不善遍行随眠及彼相应俱有法。有法非遍行因非异熟因。谓除过去现在无记遍行随眠及彼相应俱有法。诸余无记及无漏法。问若法是遍行因彼亦是能作因耶。答若法是遍行因彼亦是能作因。有法是能作因彼非遍行因。谓除过去现在遍行随眠及彼相应俱有法诸余一切法。问若法是异熟因彼亦是能作因耶。答若法是异熟因彼亦是能作因。有法是能作因彼非异熟因。谓无记及无漏法

问此六因几是色几非色。答二唯非色。谓相应遍行因余通色非色。如色非色有见无见有对无对有执受无执受。是长养非长养是大种非大种是造色非造色亦尔。问此六因几有漏几无漏。答二唯有漏谓遍行异熟因。余通有漏无漏问此六因几有为几无为。答五唯有为一通有为无为谓能作因。问此六因几过去几未来几现在。答三通三世谓相应俱有异熟因。二唯过去现在谓同类遍行因。一通三世亦离世谓能作因。问此六因几善几不善几无记。答一唯不善无记谓遍行因。一唯善不善谓异熟因。余通三种。问此六因几欲界系几色界系几无色界系。答二唯三界系谓遍行异熟因。余通三界系及不系。问此六因几学几无学几非学非无学。答二唯非学非无学。谓遍行异熟因。余通三种。问此六因几见所断几修所断几不断。答一唯见所断谓遍行因。一唯见所断修所断谓异熟因。余通三种。问此六因几染污几不染污。答一唯染污谓遍行因。余通二种。如染污不染污有罪无罪黑白有覆无覆退非退亦尔。问此六因几有异熟几无异熟。答一有异熟谓异熟因。余通二种。问此六因几是异熟几非异熟。答二非异熟谓遍行异熟因。余通二种。问此六因几相应。几不相应。答一唯相应谓相应因。余通二种。如相应不相应。有所依无所依。有所缘无所缘。有行相无行相。有警觉无警觉。有等无间无等无间亦尔。问此六因几是四谛摄几非四谛摄。答二唯苦集谛摄谓遍行异熟因。三唯苦集道谛摄谓相应俱有同类因。一通四谛及非谛摄谓能作因。问此六因几是五蕴摄几非五蕴摄。答二唯四蕴摄除色蕴谓相应遍行因。三通五蕴摄谓俱有同类异熟因。一通五蕴及非蕴摄谓能作因。问此六因几何处摄。答二唯意法处摄谓相应遍行因。一唯色声意法处摄谓异熟因。三通十二处摄谓俱有同类能作因。问此六因几何界摄。答一唯意法意识界摄谓遍行因。一唯七心法界摄谓相应因。一唯色声七心法界摄谓异熟因。三通十八界摄谓俱有同类能作因

问如是六因谁有何果。答相应俱有因有士用果。同类遍行因有等流果。异熟因有异熟果。能作因有增上果。其解脱果是道所证非因所得。问如是六因何时取果何时与果。答相应俱有因现在取果现在与果。一刹那取果一刹那与果。取一刹那果与一刹那果。同类遍行因现在取果。过去现在与果。一刹那取果。多刹那与果。取多刹那果。与多刹那果。异熟因现在取果过去与果。一刹那取果多刹那与果。取多刹那果与多刹那果。能作因有作是说。现在取果过去现在与果。一刹那取果多刹那与果。取多刹那果与多刹那果。有余师说。此能作因过去现在取果过去现在与果。多刹那取果多刹那与果。若取果时即能与果余如前说。若能觉了如是六因即于四果分明照察如观掌中余甘子等

复次诸法作用必假因缘因已广辩。次应说缘。缘有四种。如施设论及见蕴辩。然施设论作如是说。有法是因缘彼亦是等无间缘亦是所缘缘亦是增上缘。乃至有法是增上缘彼亦是因缘亦是等无间缘亦是所缘缘。问一切法中有能作四缘者如心心所法。有能作三缘者如色心不相应行。有能作二缘者如无为法。何故彼说有法是因缘彼亦是等无间缘乃至广说耶。答彼依容有故作是说。谓诸法中有心心所具四缘性不说一切皆作四缘。若尽理者应作是说。问若法是因缘彼亦是等无间缘耶。答若法是等无间缘彼亦是因缘。有法是因缘。彼非等无间缘。谓除过去现在非最后心心所法余一切有为法。问若法是因缘彼亦是所缘缘耶。答若法是因缘彼亦是所缘缘。有法是所缘缘彼非因缘谓无为法。问若法是因缘彼亦是增上缘耶。答若法是因缘彼亦是增上缘。有法是增上缘彼非因缘谓无为法。问若法是等无间缘彼亦是所缘缘耶。答若法是等无间缘彼亦是所缘缘。有法是所缘缘彼非等无间缘。谓除过去现在非最后心心所法余一切法。问若法是等无间缘彼亦是增上缘耶。答若法是等无间缘彼亦是增上缘。有法是增上缘彼非等无间缘。谓除过去现在非最后心心所法余一切法。问若法是所缘缘彼亦是增上缘耶。答如是。问若于一法具四缘者应但一缘云何立四。答依作用立不依物体。一物体中有四用故。谓一刹那心心所法引起次后刹那同类心心所故立为因缘。即此开避。次后刹那心心所法令得生故。立为等无间缘。即此能为次后刹那心心所法所取境故。立为所缘缘。即此不障碍次后刹那心心所法令得生故。立为增上缘。此中因缘如种子法。等无间缘如开导法。所缘缘如任杖法。增上缘如不障法。如是等过去现在非最后心心所法具四缘性。余有为法有三缘性。三无为法有二缘性。皆依义说不依物体。一物体中有多义故如诸法中有能作。六因者。谓过去现在不善遍行随眠及彼相应法有能作。五因者。谓过去现在无记遍行随眠及彼相应法。或过去现在不善遍行随眠及彼相应法生老住无常。或过去现在非遍行不善善有漏心心所法有能作。四因者。谓过去现在无记遍行随眠及彼相应法生老住无常。或过去现在非遍行不善善有漏色心不相应行。或过去现在无漏心心所法。或过去现在非遍行无记心心所法。或未来不善善有漏心心所法有能作。三因者。谓过去现在非遍行无记色心不相应行。或过去现在无漏色心不相应行。或未来不善善有漏色心不相应行。或未来无记无漏心心所法有能作。二因者。谓未来无记无漏色心不相应行有能作。一因者。谓无为法如一。有为有多。因义互不相违。缘亦应尔。问若尔因缘有何差别。尊者世友作如是言。无有差别。因即是缘缘即是因。如契经说二因二缘能生正见。谓他言音及内如理作意。又如大因缘经说

佛告阿难。老死支有如是由。有如是因有如是集。有如是生。有如是缘。谓生支是也。故知因缘无有差别。复作是说。若有此则有彼此是彼因亦是彼缘。问由有瓶故得有瓶觉岂此瓶觉唯瓶为因。答非但有瓶则有瓶觉以无瓶时亦有瓶觉。虽有瓶时无瓶觉故然有和合故得有瓶觉。是故和合是瓶觉因缘。有作是说。和合是因此和合因说名为缘。问若一一别不名为因。众事和合亦应非因。答如一一别不名和合。众事聚集即名和合。故一一别不名为因众事和合得名为因。复有说者。同类是因异类是缘。如火于火麦于麦等说名同类。问麦于麦芽有何同类。若同称麦名同类者。应田水等大种同故亦名同类。则田水等应是麦因。复有说者。近者是因远者是缘。问若尔因与等无间缘应无差别。又善心无间起不善。或无记心应是因非缘。复有说者。不共是因共者是缘。问若尔眼于眼识应是因非缘以不共故。又麦于芽灰应是缘非因以是共故。复有说者。能生者是因随能生者是缘。问若尔生支于老死应非缘随顺生支有等于老死应非因。复有说者。能长养自相续者是因。能长养他相续者是缘。问若尔缘自相续所起善心唯长养自相续应是因非缘大德说曰。转是因随转是缘。近是因远是缘。如近远在此在彼。和合不和合。在此身在余身。应知亦尔。问若尔同类随转应是缘非因无明缘行等应是因非缘。故因缘体虽无差别而义有异。谓因义亲。缘义是疏。为表此义说因有六。说缘有四若不尔者名数应同

说一切有部发智大毗婆沙论卷第二十一阿毗达磨大毗婆沙论卷第二十二

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中智纳息第二之十四

诸心由随眠故名有随眠心。彼随眠于此心随增耶。乃至广说。问何故作此论。答为止他宗显正理故。谓或有执。但有一心如说一心相续论者彼作是说。有随眠心无随眠心。其性不异圣道现前。与烦恼相违不违心性。为对治烦恼非对治心。如浣衣磨镜炼金等物。与垢等相违不违衣等。圣道亦尔。又此身中若圣道未现在前。烦恼未断故心有随眠。圣道现前烦恼断故心无随眠。此心虽有随眠无随眠时异。而性是一。如衣镜金等未浣磨炼等时。名有垢衣等。若浣磨炼等已。名无垢衣等。有无垢等时虽有异。而性无别。心亦如是。为止彼执显有随眠心与无随眠心其性。各异。或复有执。随眠不于所缘随增。亦不于相应法有随增义。如譬喻者彼作是说。若随眠于所缘随增者于他界地及无漏法亦应随增。是所缘故如自界地。若于相应法有随增义者。则应未断已断一切时随增。相应毕竟不相离故犹如自性。为止彼执。显诸随眠于所缘相应俱有随增义。谓于自界地有漏法及相应法乃至未断恒随增故。或复有执。随眠唯于补特伽罗有随增义。如犊子部彼作是说。补特伽罗名有随眠及无随眠。非心等法。补特伽罗有缚解故。为止彼执显唯心等有缚有解名有随眠及无随眠。非数取趣毕竟无故。为止此等他宗及显无颠倒理故作斯论

诸心由随眠故名有随眠心。彼随眠于此心随增耶。答或随增或不随增。云何随增。谓彼随眠与此心相应未断及缘此心。云何不随增。谓彼随眠与此心相应已断。此中诸心者有五部心。谓见苦所断心。乃至修所断心随眠者有五部随眠谓见苦所断随眠。乃至修所断随眠。由二事故名有随眠心。一由随眠于此心有随增性。二由随眠于此心有同伴性。谓见苦所断心于见苦所断随眠。由二事故名有随眠心。于见集所断随眠由一事故名有随眠心。谓随增性。于余随眠无二事故非有随眠心。见集所断心于见集所断随眠由二事。故名有随眠心。于见苦所断随眠由一事故名有随眠心。谓随增性。于余随眠无二事故非有随眠心。见灭所断心于见灭所断随眠由二事故名有随眠心。于见苦集所断随眠由一事故名有随眠心。谓随增性。于余随眠无二事故非有随眠心。见道所断心于见道所断随眠由二事故名有随眠心。于见苦集所断随眠由一事故名有随眠心。谓随增性。于余随眠无二事故非有随眠心。修所断心于修所断随眠由二事故名有随眠心。于见苦集所断随眠由一事故名有随眠心。谓随增性。于余随眠无二事故非有随眠心。复次见苦所断心有二种。一遍行随眠相应心。二非遍行随眠相应心。见集所断心亦尔。见灭所断心有二种。一有漏缘随眠相应心。二无漏缘随眠相应心。见道所断心亦尔。修所断心有二种。一染污心。二不染污心。见苦所断遍行随眠相应心。于见苦所断遍行随眠由二事故名有随眠心。于见苦所断非遍行随眠及见集所断遍行随眠由一事故名有随眠心。谓随增性。于余随眠无二事故非有随眠心。见苦所断非遍行随眠相应心。于见苦所断非遍行随眠由二事故名有随眠心。于见苦集所断遍行随眠由一事故名有随眠心。谓随增性。于余随眠无二事故非有随眠心。见集所断遍行随眠相应心。于见集所断遍行随眠由二事故名有随眠心。于见集所断非遍行随眠及见苦所断遍行随眠由一事故名有随眠心。谓随增性。于余随眠无二事故非有随眠心。见集所断非遍行随眠相应心。于见集所断非遍行随眠由二事故名有随眠心。于见苦集所断遍行随眠由一事故名有随眠心。谓随增性。于余随眠无二事故非有随眠心。见灭所断有漏缘随眠相应心。于见灭所断有漏缘随眠由二事故名有随眠心。于见苦集所断遍行随眠由一事故名有随眠心。谓随增性。于余随眠无二事故非有随眠心。见灭所断无漏缘随眠相应心。于见灭所断无漏缘随眠由二事故名有随眠心。于见灭所断有漏缘随眠及见苦集所断遍行随眠由一事故名有随眠心。谓随增性。于余随眠无二事故非有随眠心。见道所断有漏缘随眠相应心于见道所断有漏缘随眠由二事故名有随眠心。于见苦集所断遍行随眠由一事故名有随眠心。谓随增性。于余随眠无二事故非有随眠心。见道所断无漏缘随眠相应心。于见道所断无漏缘随眠由二事故名有随眠心。于见道所断有漏缘随眠及见苦集所断遍行随眠由一事故名有随眠心。谓随增性。于余随眠无二事故非有随眠心。修所断染污心于修所断随眠由二事故名有随眠心。于见苦集所断遍行随眠由一事故名有随眠心。谓随增性。于余随眠无二事故非有随眠心。修所断不染污心于修所断随眠及见苦集所断遍行随眠由一事故名有随眠心。谓随增性。于余随眠无二事故非有随眠心。复次欲界见苦所断心有十种。谓五见疑爱恚慢不共无明相应心。见集所断心有七种。谓二见疑爱恚慢不共无明相应心。见灭所断心亦尔。见道所断心有八种。谓三见疑爱恚慢不共无明相应心。修所断心有五种。谓爱恚慢不共无明相应心及不染污心。谓善有漏无覆无记。有身见相应心于有身见及彼相应无明由二事故名有随眠心。于余见苦所断随眠及见集所断遍行随眠由一事故名有随眠心。谓随增性。于余随眠无二事故非有随眠心。如是乃至见苦所断慢相应心应知亦尔。见苦所断不共无明相应心。于见苦所断不共无明由二事故名有随眠心。于余见苦所断随眠及见集所断遍行随眠由一事故名有随眠心。谓随增性。于余随眠无二事故非有随眠心。见集所断心应知亦尔。见灭所断邪见相应心。于见灭所断邪见及彼相应无明由二事故名有随眠心。于见灭所断有漏缘随眠及见苦集所断遍行随眠由一事故名有随眠心。谓随增性。于余随眠无二事故非有随眠心。见灭所断疑相应心应知亦。尔见灭所断见取相应心。于见灭所断见取及彼相应无明由二事故名有随眠心。于余见灭所断有漏缘随眠及见苦集所断遍行随眠由一事故名有随眠心。谓随增性。于余随眠无二事故非有随眠心。见灭所断爱恚慢相应心应知亦尔。见灭所断不共无明相应心。于见灭所断不共无明由二事故名有随眠心。于见灭所断有漏缘随眠及见苦集所断遍行随眠由一事故名有随眠心。谓随增性。于余随眠无二事故非有随眠心。见道所断心应知亦尔。随所断爱相应心。于修所断爱及彼相应无明由二事故名有随眠心。于余修所断随眠及见苦集所断遍行随眠由一事故名有随眠心。谓随增性。于余随眠无二事故非有随眠心。修所断恚慢相应心应知亦尔。修所断不共无明相应心。于修所断不共无明由二事故名有随眠心。于余修所断随眠及见苦集所断遍行随眠由一事故名有随眠心。谓随增性。于余随眠无二事故非有随眠心。修所断不染污心于修所断随眠及见苦集所。断遍行随眠由一事故名有随眠心。谓随增性。于余随眠无二事故非有随眠心。如说欲界。色无色界应知亦尔。是谓此处略毗婆沙。如是所说三界五部随眠于此三界五部有随眠心。若未断则随增互相随顺而增长故随眠于心增缚事故。若已断则不随增不相随顺非增长故随眠于心无缚事故。然未断位心于相应所缘随眠俱得建立有随眠名。已相应者具二事故。缘缚心者但随增故。若已断位此心唯于相应随眠可得建立有随眠名。非彼先来缘缚心者无随增故。相应随眠于心犹有同伴性故。问何故心于相应随眠已断未断俱得建立有随眠名。于所缘随眠唯未断位可得建立有随眠名非已断位耶。答前来已说心于随眠由二事故名有随眠一随增性。二同伴性。相应随眠若未断位由二事故心于彼立有随眠名。若已断位彼于此心虽无随增性而有同伴性故犹可立有随眠名。所缘随眠若未断位于心唯有随增性故心于彼立有随眠名。若已断位二事俱无故心于彼不复可立有随眠名。问若相应随眠于相应心若未断位有随增性及同伴性。若已断位虽无随增性而有同伴性心恒于彼名有随眠者。所缘随眠于所缘心若未断位有随增性及所缘性。若已断位虽无随增性而有所缘性。何故心于彼不恒建立有随眠名。答相应随眠于相应心极相亲近众事皆等不可相离如羊与皮故断未断恒名相有。所缘随眠与所缘心非极亲近众事不等未尝和合。若未断时由随增性可说相有。若已断位极疏远故不说相有。此中有名依亲强立。非如立有所缘等名。尊者世友作如是说。相应随眠染污心故。所缘随眠不如是故。复次相应随眠不离心故。所缘随眠不如是故。复次相应随眠覆蔽心故。所缘随眠不如是故。复次相应随眠随心转故。所缘随眠不如是故。复次相应随眠扰乱心故。所缘随眠不如是故。复次相应随眠与相应心同一所依同一所缘同一行相同一果同一等流同一异熟。俱生俱住俱异俱灭。极亲近故。所缘随眠不如是故。大德说曰。相应随眠令相应心刚强[怡-台+龍]悷。智者诃厌难可出离。所缘随眠于所缘心无此事故。尊者妙音作如是说。相应随眠令相应心发起染污如烟焰得障碍圣果。所缘随眠于所缘心无此事故。尊者觉天作如是说。相应随眠令相应心于所缘境迷谬不了。所缘随眠于所缘心无此事故。由如是等种种因缘相应随眠断未断位恒令心得有随眠名。所缘随眠唯未断位可令心得有随眠名。若已断位则不名有。设随眠于心随增此心但由彼随眠故名有随眠心耶答或由彼非余。或由彼及余。云何由彼非余。谓此心未断。云何由彼及余。谓苦智已生集智未生。若心见苦所断见集。所断随眠所缘。此中由彼非余者。谓有随眠心但由彼于心随增随眠故名有随眠心。非由余于心不随增随眠故名有随眠心。谓此心未断者。若心未断必但由彼于心随增随眠故名有随眠心。非由余于心不随增随眠故名有随眠心。有说。此文应作是说。谓具缚者诸染污心。彼不应作是说。以具缚者不具缚者有染污心无染污心皆可尔故。但应作是说。谓此心未断诸未断心名有随眠。但由于心随增随眠非由余故。由彼及余者。谓有随眠心由彼于心随增随眠故名有随眠心。及由余于心不随增随眠故名有随眠心。谓苦智已生乃至广说者。见苦所断有随眠心。尔时由彼见集所断。于心随增遍行随眠故名有随眠心。及由余见苦所断。于心不随增相应随眠故名有随眠心。如是即说见苦所断心。于此位中由彼他部于心随增随眠故。及由余自部于心不随增随眠故名有随眠心。问何故此中他部随眠名彼。自部随眠名余。答以先问言设随眠于心随增此心但由彼随眠故名有随眠心耶。故今答言见苦所断心于此位中非但由彼见集所断于此心随增遍行随眠故名有随眠心。亦由余见苦所断。于此心不随增相应随眠故名有随眠心。如是即说正所问者名彼。非正所问者名余。他部随眠尔时未断。由随增故是正所问。自部随眠尔时已断。不随增故非正所问。有说。自部随眠尔时转至异前位故说之为余。谓前未断今已断故。有说。自部随眠先得自在随欲所作。今已断故不得自在。无所能作故说为余。有说。自部随眠本来成就。今不成就故说为余。有说。自部随眠今为圣道究竟断灭异昔来故说之为余。有说。自部随眠已为圣道简别顿断。不同昔来与余四部同时渐断故说为余。问修所断心亦有此义。谓断一品乃至八品已断染心。由彼未断及余已断名有随眠。何故不说。答是作论者意欲尔故。乃至广说。复次应说而不说者。当知此义有余。复次若异部为彼异部为余者。此中说之修所断心。虽有此义而自部为彼自部为余故此不说。复次此中但说断已毕竟不复退者修所断心。虽有此义而彼断已。或有复退故不说之

问诸随眠云何于所缘随增云何于相应随增耶。西方诸师作如是说。为系缚性故。于所缘随增。为同伴性故。于相应随增。迦湿弥罗国诸论师言。于所缘境各别行相随执增益故。名于所缘随增。于相应法令同自过随顺增益故。名于相应随增。有余师说。诸随眠于所缘随增如于相应。于相应随增如于所缘。问若尔品类足论当云何通。如说。云何欲贪随眠随增。谓可爱可乐可喜可意。彼于相应无能缘义。云何亦说有可爱等。答彼显贪相。谓欲贪随眠有可爱等相故作是说。不显所缘相应异相。尊者世友作如是说。由四事故说诸随眠有随增义。一堕恶意故。如大众中一人造恶令彼多人皆堕恶意。如是于一相应品中起一随眠。即令此品心心所法皆堕恶意。二如火热故。如置热铁小水器中。其器及水无不皆热。如是于一心品法中起一烦恼。即令一切心心所法皆成热恼。三如烟等故。如烟尘垢所著衣服皆成秽恶。如是心品有一随眠皆成染污。四可毁厌故。如僧众中有一犯罪众皆受责。如是心品有一随眠皆可毁厌如于相应。有此四事说名随增。于所缘境亦增此四故名随增。谓若所缘增长此四即说烦恼于彼随增。问过去未来随眠亦随增不。答彼亦随增。若彼随眠不随增者。不染污心现在前位应无随眠。便违经说。如说。佛告结鬘母言。婴孩小儿仰腹而卧。尚不能了欲境胜劣。况复能起欲贪缠心。然被欲贪随眠系缚。问过去未来既无作用。云何可说随眠随增。答彼能起。得现在前故。如火不现而能起烟。尊者妙音作如是说。彼虽无有取境作用。而于所缘及相应法有如现在系缚功能故。彼随眠有随增义。尊者设摩达多说曰。由五事故可说过去未来随眠有随增义。一者彼因未尽故。二者彼得未断故。三者未转彼所依故。四者未了彼所缘故。五者未得彼对治故。诸心由随眠故名有随眠心。彼随眠于此心当断耶。答或当断或不当断。云何当断。谓彼随眠缘此心。云何不当断。谓彼随眠与此心相应。此中显示随眠于所缘境可说当断非于相应。谓于所缘。可制烦恼令不现起造诸过失。非于相应可制烦恼令不复与心等相应故。于所缘可说当断非于相应。有说。此文应作是说。云何当断。谓彼随眠缘此心未断。云何不当断。谓彼随眠缘此心已断及与此心相应。彼说非理。所以者何。前问诸心由随眠故名有随眠心。彼随眠于此心当断不。今但应说。云何当断。谓彼随眠缘此心于义已足。何须更说未断。若彼已断心不由彼名有随眠便非所问。是故不须更说未断。又缘此心已断及言理不应说缘心随眠。若已断者便非所问故。但应说。云何不当断。谓彼随眠与此心相应其义已足。然此中说诸随眠于所缘可断非于相应者。依心名有随眠义说。不依随增义说。以随增义俱可断故

诸随眠因何当断。答因所缘前所显义今现其文。谓诸随眠由对治力令彼于境不复起过。可说当断。如人制子不令复入酒舍淫舍博戏舍等。若令随眠离相应法无有是处。是故说彼于相应法无有断义

汝说随眠因所缘当断耶。答如是。若尔诸随眠见灭道所断有漏缘彼随眠因何当断。若言此断彼断俱不应理。答见灭道所断无漏缘随眠因所缘故断。由此断故彼亦断。此中意说。要因慧见烦恼所缘随眠方断。为成此理。问答难通。汝说随眠因所缘当断耶者。是问前虽略说而未审定。若不审定他宗所许说他过失无有是处。答如是者是答要因慧见烦恼所缘随眠方断。其理决定。更无异趣故言如是。若尔诸随眠见灭道所断有漏缘彼随眠因何当断。若言此断。彼断俱不应理者。是难彼难意。言见灭道所断有漏缘随眠因何当断。若言因慧见此苦集故得断者。其理不然。见苦集时此未断故。若言因慧见彼灭道故得断者。理亦不然。灭道非此所缘境故。答见灭道所断无漏缘随眠因所缘故。断由此断故彼亦断者是通。此通意言见灭道所断有漏缘随眠依止无漏缘随眠故而得生长。见灭道时此无漏缘随眠断故。彼见灭道所断有漏缘随眠亦随断。如羸病人依杖而立。去杖便倒。此亦如是。问前定宗言要因慧见烦恼所缘随眠方断。今乃通言所缘断故能缘随断。岂不相违。答无相违失。慧见所缘随眠尚断。况所缘断而不断耶。如果依树动树尚堕况树倾倒而果不落。此亦如是。又前所说要因慧见烦恼所缘随眠方断者。不说要因慧见所断烦恼所缘随眠方断。但说要因慧见所有烦恼所缘随眠方断故不相违。谓因慧见无漏缘烦恼所缘灭道故。见灭道所断有漏缘随眠亦断。由此理趣苦集法忍能断缘上遍行随眠。修道位中灭道二智。能断九地修所断惑。有余师说。因所缘故随眠断者。意显烦恼所缘断故随眠方断。为成此理问答难通。汝说随眠因所缘当断耶。答如是。若尔诸随眠见灭道所断无漏缘彼随眠因何当断。若言此相应断故断者。其理不然。前说随眠非于相应可说断故。若言彼所缘断故断者。理亦不然。所缘灭道无诸过失不可断故。答见灭道所断有漏缘随眠断故此亦随断。问前定宗言。所缘断故随眠方断。今说能缘烦恼断故随眠方断。岂不相违。答无相违失。谓无漏缘随眠依有漏缘随眠而得生长。由彼任持此得相续故。彼断持此亦随断。如树茎等依根而住。若断其根茎等随倒。此亦如是。彼说非理。违前宗故。此本论文难通异故。有所缘断时能缘未断故。有能缘断时所缘未断故。或复有说。因所缘故随眠断者。意说要因有所缘道随眠方断。彼说非理。以世尊说如是八支圣道能断过去未来现在众苦。弃舍变吐尽离染灭寂静涅槃。是故应说。有所缘道无所缘道俱能断惑。又于后说。若难若通俱不相应故彼非理。尊者设摩达多说曰。由四事故诸随眠断。一由所缘断故。如见灭道所断有漏缘随眠。二由能缘断故。如他界缘随眠。三由俱缘断故。如见苦集所断非遍行随眠。四由得对治故。如余随眠随得对治彼则随断。尊者世友作如是说。由五事故诸随眠断。一见所缘故断。如无漏缘随眠及缘自界遍行随眠。二所缘断故断。如见灭道所断有漏缘随眠。三能缘断故断。如缘他界遍行随眠。四俱缘断故断。如见苦集所断不遍行随眠。五得对治故断。如修所断随眠

设随眠于心当断。此心但由彼随眠故名有随眠心耶。答或由彼非余。或由彼及余。云何由彼非余。谓心不染污修所断。云何由彼及余。谓心染污。此中不染污者简异染污。修所断者简异无漏。谓有漏善心及无覆无记心。此心由彼者。由缘此心随增随眠故名有随眠心。非余者。非由相应随眠故名有随眠心。此心相应无随眠故。染污心由彼者。由缘此心随增随眠故名有随眠心。及余者及由余相应随眠故名有随眠心。问何故此中所缘随眠说彼相应随眠说余。答以先问言设随眠于心当断。此心但由彼随眠故名有随眠心耶。前说随眠唯于所缘有当断义非于相应。是故彼言。唯说当断所缘随眠。即此随眠是正所问故说为彼。相应随眠非正所问故说为余。问何故复作如是问答。答为令疑者得决定故。谓或有疑唯当断者。心由彼故名有随眠。相应随眠不当断故。心不由彼名有随眠。欲令此疑得决定故。显染污心亦由彼故名有随眠。或复有疑。相应随眠亦当可断故。今复显相应随眠无当断义。或复有疑心于随眠名为有者。但依随增性故。今复显示依同伴性。谓无染污心但依随增性名有随眠。若染污心俱依二性

颇有随眠断而慧不见彼所缘耶。答应作四句。有随眠断而慧不见彼所缘。谓诸异生离欲界乃至无所有处染时。断上地缘及无漏缘随眠。若诸圣者现观欲界苦集谛时。断他界缘随眠。现观灭道谛时。断见灭道所断有漏缘随眠。以灭道智离修所断一切随眠。有慧见彼所缘而随眠不断。谓诸异生离欲界乃至无所有处染时。前后诸品所断随眠。离初静虑乃至无所有处染时。欲界乃至识无边处所有他地缘随眠。若诸圣者现观色无色界苦集谛时。欲界所有他界缘随眠。现观苦谛时。见集所断自界缘随眠。见灭道所断有漏缘随眠及修所断一切随眠。现观集谛时。见苦所断自界缘随眠。见灭道所断有漏缘随眠及修所断一切随眠。以苦集智及世俗智离修所断染时。见所断有漏缘随眠及前后品修所断随眠以灭道智离修所断染时。无漏缘随眠。及余一切异生圣者。不断烦恼而见烦恼所缘境时。一切随眠。有随眠断慧亦见彼所缘。谓诸异生离欲界乃至无所有处染时。所有自地缘自品随眠。若诸圣者现观苦集谛时。见苦集所断自界缘随眠。现观灭道谛时。见灭道所断无漏缘随眠。以苦集智及世俗智。离修所断染时。自地自品修所断随眠有随眠不断慧亦不见彼所缘。谓除前相

颇有一刹那顷随眠断而慧不见彼所缘耶。答应作四句。然有多位。谓苦集法智忍及灭道法类智忍位皆有四句。苦法智忍位四句者。第一句。谓欲界见苦所断他界缘随眠第二句。谓欲界见集所断自界缘随眠。见灭道所断有漏缘随眠。及修所断随眠。第三句。谓欲界见苦所断自界缘随眠。第四句。谓除前相。集法智忍位随其所应四句亦尔。灭道法类智忍位。若先异生位中分离欲界染。及于上七地或分或全离者。得作四句。且灭法智忍位四句者。第一句。谓欲界见灭所断先所未离有漏缘随眠第二句。谓欲界见灭所断先所已离无漏缘随眠。第三句。谓欲界见灭所断先所未离无漏缘随眠。第四句。谓欲界见灭所断先所已离有漏缘随眠。或除前相。灭类智忍及道法类智忍位。随其所应四句亦尔。若诸异生离欲界乃至无所有处染时。一一无间道中皆得作四句。第一句。谓自品他地缘随眠。第二句谓前后品自地缘随眠。第三句。谓自品自地缘随眠。第四句。谓前后品他地缘随眠或除前相。颇有于烦恼断得而不舍舍而不得亦得亦舍不得不舍耶。答有。得而不舍者。谓诸异生离欲界乃至无所有处染时。若诸圣者断烦恼时除得果位。舍而不得者。谓诸异生从离染退下地没生二定以上。上二界没生欲界时。若诸圣者向中退断。亦得亦舍者。谓诸异生上地没生初定以上。若诸圣者练根得果。及退果时。不得不舍者。谓除前相

说一切有部发智大毗婆沙论卷第二十二阿毗达磨大毗婆沙论卷第二十三

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中智纳息第二之十五

颇有于随眠灭身作证而慧不见彼灭耶。答应作四句。有于随眠灭身作证而慧不见彼灭。谓诸异生离欲界乃至无所有处染时。所有自地自品诸随眠灭。若诸圣者苦现观时。见苦所断诸随眠灭。集现观时见集所断诸随眠灭。道现观时见道所断诸随眠灭。修道位中以苦集道及世俗智随其所应。离欲界乃至非想非非想处染时。所有自地自品修所断诸随眠灭。若以苦集道及世俗智随其所应得果及练根成时所证已断诸随眠灭。有慧见彼灭而身不作证。谓灭现观时见苦集道及修所断诸随眠灭。修道位中若以灭智离欲界乃至非想非非想处染时。除得果位。随现所观已断未断诸随眠灭。及余一切异生圣者不证择灭而见灭时。即彼所见诸随眠灭。有于随眠灭身作证慧亦见彼灭。谓灭现观时见灭所断诸随眠灭。修道位中若以灭智离欲界乃至非想非非想处染时。所证所观诸随眠灭若以灭智练根成时。所证所观诸随眠灭。有于随眠灭身不作证慧亦不见彼灭。谓除前相

颇有一刹那顷于随眠灭身作证而慧不见彼灭耶。答应作四句。谓以灭法智得一来果时。有于随眠灭身作证而慧不见彼灭。谓尔时色无色界见所断诸随眠灭。有慧见彼灭而身不作证。谓欲界修所断后三品诸随眠灭。有于随眠灭身作证慧亦见彼灭。谓欲界一切见所断及修所断前六品诸随眠灭。有于随眠灭身不作证慧亦不见彼灭。谓色无色界修所断诸随眠灭。如以灭法智得一来果时。一刹那顷有四句。如是以灭智预流一来或不还者转根时。一刹那顷皆得作四句

云何因境断识。答苦智已生集智未生。若心见集所断见苦所断缘。是谓因境断识。此中若识因断境断。自体未断名因境断识。诸有欲令遍行随眠及彼相应俱有诸法于自部非遍行因者。彼作是说。苦智已生集智未生。若心见集所断见苦所断缘。此心因全断境全断。自体未断故名因境断识。尔时若心见集所断见集灭道修所断缘。此心因虽全断而境未断故。非因境断识。尔时若心见集所断见苦集灭道修所断缘。此心因虽全断而境有断有未断故。非因境断识。诸有欲令遍行随眠及彼相应俱有诸法亦作自部遍行因者。彼作是说。苦智已生集智未生。若心见集所断见苦所断缘。此心自部因虽未断而他部因全断境全断。自体未断故名因境断识。尔时若心见集所断见集灭道修所断缘。此心因有断有未断境未断故非因境断识。尔时若心见集所断见苦集灭道修所断缘。此心因境俱有断有未断故非因境断识。已显因境断识自性。次应显彼随眠随增。问于此识有几随眠随增耶。答十九。问一心耶。答不尔。其事云何。谓未离欲染。苦法智已生集法智未生。若心欲界见集所断见苦所断缘。此因境断识。欲界见集所断七随眠随增。四于此识相应所缘随眠随增。谓邪见见取疑无明。三于此识唯有所缘随眠随增。谓爱恚慢。已离欲染未离色染。苦类智已生集类智未生。若心色界见集所断见苦所断缘。此因境断识。色界见集所断六随眠随增。四于此识相应所缘随眠随增。如欲界说。二于此识唯有所缘随眠随增。谓爱慢。问未离欲染者亦可尔。何故说已离欲染耶。答此中说。容现行者要离下地染。上地烦恼方得现行故作是说。已离色染。苦类智已生集类智未生。若心无色界见集所断见苦所断缘。此因境断识。无色界见集所断六随眠随增。四于此识相应所缘随眠随增。二于此识唯有所缘随眠随增。如色界说。此中有诵已离色染未离无色染。彼不应诵说。集类智未生已显未离无色染故。问修所断中亦可建立因境断识。谓已断上上品乃至下中品者。所未断八品乃至一品心。此心缘前已断一品乃至八品。前一品乃至八品因已断故。亦应名为因境断识。何故不说。答亦应说而不说者。当知此义有余。复次若异部识异部为因异部为境而因境断体未断者。此中说之。修所断心自部为因自部为境。虽因境断而不说为因境断识。复次此中因者说遍行因。唯染污故余因不定。此中识者唯说随眠相应诸心唯染污故。由此所说因境断识。唯在三界见集所断

问何故因后说随眠耶。答以阿毗达磨藏义应以十四事觉知。谓六因四缘摄相应成就不成就若以如是十四事。觉知阿毗达磨无错谬者。名阿毗达磨师。非但诵持文者。有余师说。应以七事觉知阿毗达磨藏义。谓因善巧缘善巧。自相善巧。共相善巧。摄不摄善巧。相应不相应善巧成就不成就善巧。若以如是七事觉知阿毗达磨无错谬者。名阿毗达磨师非但诵持文者。是故因后说诸随眠于义无失

    大毗婆沙论杂蕴第一中补特伽罗纳息第三之一

一补特伽罗。于此生十二支缘起。几过去几未来几现在。如是等章及解章义既领会已。次应广释。问何故作此论。答为止他宗显正义故谓或有执过去未来体非实有。现在虽有而是无为。为止彼宗显过去未来体是实有。现在是有为世所摄故。或复有执。缘起是无为如分别论者。问彼因何故作如是执。答彼因经故。谓契经说。如来出世若不出世法住法性。佛自等觉为他开示乃至广说。故知缘起是无为法。为止彼宗显示缘起是有为法堕三世故。无无为法堕在三世。问若缘起法非无为者。如何会释彼所引经。答经说因果决定义故。谓佛出世若不出世。无明决定是诸行因。诸行决定是无明果。如是乃至生决定是老死因。老死决定是生果。法住法性是决定义。非无为义。经意如是。若不尔者。契经亦说。如来出世若不出世。法住法性色常色相。乃至识常识相。地常坚相乃至风常动相。喝梨德鸡常是苦味。羯竹迦卢呬尼常是辛味。岂五蕴等亦是无为。彼既有为。缘起亦尔。谓五蕴等自相决定说如是言。缘起亦依因果决定。作如是说。为止如是他宗异执显示正理故作斯论

此中论者所发论端应辩五事。一者何故唯说一补特伽罗。二者说何等一补特伽罗。三者何故唯说此生。四者说何等此生五者说何等现在。何故唯说一补特伽罗者。为避论文烦广失故。若说一切补特伽罗论文烦广亦为无用。说一则知余亦尔故。说何等一补特伽罗者。若有遍历此十二支如陟梯蹬。是此所说。谓若过去起无明行。引得现在识名色六处触受。复于现在起爱取有。引得未来生老死者。是此所说一补特伽罗。若有过去起无明行。引得现在识乃至受。现在不复起爱取有引得未来生老死者。非此所说。如智蕴说。成就八支名学行者。何等学者是彼所说。若有遍历三摩钵底如陟梯蹬。是彼所说。谓若先入有寻有伺定。次入无寻无伺定。次入无色定。次入灭尽定。出灭尽定起有漏心现在前者。彼中说之。若有先入有寻有伺定。次入无寻无伺定。次入无色定。次入灭尽定。出灭尽定起无漏心现在前者。非彼所说。又如经说。先见女人形容端正少壮充悦。次复见彼衰老羸瘦。次复见彼重病困苦。次复见彼死经一日乃至七日。次复见彼膖胀脓烂。次复见彼骨节分离无血肉等。后复见彼骸骨腐烂如鸠鸽色。若有女人遍经如上所说诸位。是彼经说。若不尔者非彼所说。此中亦尔。但说遍历十二支者不说其余。何故唯说此生者。说现在生则知过去未来亦尔故不说余。说何等此生者。一众同分说为此生。说何等现在者。说众同分现在。不说刹那现在及分位现在

一补特伽罗于此生十二支缘起几过去几未来几现在耶。答二过去。谓无明行。二未来。谓生老死。八现在。谓识名色八处触受爱取有。问此十二支过去未来现在皆具。何故但说过去未来各有二支现在有八。答无慧眼者以现在因推未来果。以现在果推过去因。可知亦有故作是说。以现在因者。谓爱取有。推未来果者谓生老死。以现在果者。谓识名色六处触受。推过去因者。谓无明行。世尊欲令无慧眼者。以现因果推有去来。由此即能办所作事。过去世果未来世因。由此为门亦可知有。故此论者但作是说。复次说有过去二支即遮生死本无今有执。说有未来二支即遮生死有已还无执。说有现在八支成立生死因果相续。如是如来化事已满故作是说。复次说有过去二支即遮常见。说有未来二支即遮断见。说有现在八支即显中道。如是如来化事已满故作是说。复次说有过去二支即显生死有因。说有未来二支即显生死有果。说有现在八支即显因果相续。由此有情能办所作故作是说。复次说有过去二支除前际愚。说有未来二支除后际愚。说有现在八支除中际愚。由此有情能办所作故作是说。复次此中但说一生因果。余生因果义准可知。故作是说

品类足论作如是言。云何缘起法。谓一切有为法。问此与彼论所说何异。答此说不了义。彼说是了义。此是有余说。彼是无余说。此说有密意。彼说无密意。此说有别因。彼说无别因。此说是世俗。彼说是胜义。此唯说有情数缘起法。彼通说有情数非有情数缘起法。此唯说有根缘起法。彼通说有根无根缘起法。此唯说有心缘起法。彼通说有心无心缘起法。此唯说执受缘起法。彼通说执受非执受缘起法。复次缘起有四种。一刹那。二连缚。三分位。四远续。此说分位远续。彼说刹那连缚。问何故此论唯说有情数缘起法耶。答是作论者意欲尔故。乃至广说。复次不应责此作论者意。以作论者依经作论。契经唯说有情数缘起法故此亦尔。问因论生论。何故世尊唯说有情数缘起法耶。答观所化故。谓佛观彼所化有情宜闻。唯说有情数缘起法。则能解了办所作事故作是说。复次顺有支故。谓有情数随顺有支其义最胜。有情数法从无始来轮转三有相续不绝。有义最胜说名为有。有情数法随顺此有故名有支。是故世尊唯说有情数缘起法。此论依彼亦唯说有情数缘起法。复次诸有情类从无始来轮转生死受大苦恼。皆由迷执有情数法。是故世尊但为开示有情数缘起法。此论依彼故作是说

问如是缘起自性是何。答五蕴四蕴是此所说缘起自性。谓欲色界五蕴为自性。若无色界四蕴为自性。如说。自性我物相分本性亦尔。已说自性。所以今当说。问何故名缘起。缘起是何义。答待缘而起故名缘起。待何等缘。谓因缘等。或有说者。有缘可起故名缘起。谓有性相可从缘起。非无性相非不可起。复有说者。从有缘起故名缘起。谓必有缘此方得起。有作是说。别别缘起故名缘起。谓别别物从别别缘和合而起。或复有说。等从缘起故名缘起。问有法从四缘生。谓心心所有法从三缘生。谓灭尽无想定有法从二缘生。谓一切色及余不相应行。云何等从缘起故名缘起耶。答即以此事故名为等。谓应从四缘生者。皆四缘生非三非二。应从三缘生者。皆三缘生。非四非二。应从二缘生者。皆二缘生非三非四。是故名等。复次依增上缘故说为等。谓一一法于正起时各除自性。余一切法皆与彼为增上缘故。复次皆同时生故说为等。如说。一切有情心等生等住等灭。复次皆一刹那故说为等。复次一切皆有此十二支。从无始来乃至证得无学果位故说为等。问诸有情类或有前般涅槃者。或有后般涅槃者。如何可说缘起法等。答皆具十二故说为等。复次皆得涅槃方舍缘起故说为等。复次缘起总相无始无终。一切有情同有此法故说为等。复次前般涅槃者。于缘起法前少后多。后般涅槃者。于缘起法前多后少故说为等。谓诸有情皆有无量过去未来诸缘起法。虽行世者有少有多而其体数一切皆等

如契经说。彼告苾刍。吾当为汝说缘起法及缘已生法。问缘起法与缘已生法差别云何。有作是言。无有差别所以者何。品类足论作如是言。云何缘起法。谓一切有为法。云何缘已生法。谓一切有为法。故知此二无有差别。有余师说。亦有差别。谓名即差别。此名缘起法彼名缘已生法故。复次因名缘起法。果名缘已生法。如因果。如是能作所作。能成所成。能生所生。能转所转。能起所起。能引所引。能续所续。能相所相。能取所取。应知亦尔。复次前生者名缘起法。后生者名缘已生法。复次过去者名缘起法。未来现在者名缘已生法。复次过去现在者名缘起法。未来者名缘已生法。复次无明名缘起法。行名缘已生法。乃至生名缘起法。老死名缘已生法。胁尊者言。无明唯名缘起法。老死唯名缘已生法。中间十支亦名缘起法。亦名缘已生法。尊者妙音作如是说。过去二支唯名缘起法。未来二支唯名缘已生法。现在八支亦名缘起法。亦名缘已生法。尊者望满说有四句。有缘起法非缘已生法。谓未来法。有缘已生法非缘起法。谓过去现在阿罗汉最后五蕴。有缘起法亦缘已生法。谓除过去现在阿罗汉最后五蕴。诸余过去现在法。有非缘起法亦非缘已生法。谓无为法。集异门论及法蕴论俱作是说。若无明生行。决定安住不杂乱者。名缘起法。亦名缘已生法。若无明生行。不决定不安住而杂乱者。名缘已生法。非缘起法。乃至生除老死应知亦尔。尊者世友作如是说。若法是因名缘起法。若法有因名缘已生法。复次若法是和合名缘起法。若法有和合名缘已生法。复次若法是生名缘起法。若法有生名缘已生法。复次若法是起名缘起法。若法有起名缘已生法。复次若法是能作名缘起法。若法有能作名缘已生法。大德说曰转名缘起法。随转名缘已生法。尊者觉天作如是说。诸法生时名缘起法。诸法生已名缘已生法。契经所说缘起法缘已生法如是差别

此中但说时分缘起。谓十二位立十二支。一一支中各具五蕴。尊者设摩达多说曰。一刹那顷有十二支。如起贪心害众生命。此相应痴是无明。此相应思是行。此相应心是识。起有表业必有俱时名色。诸根共相伴助即是名色及与六处。此相应触是触。此相应受是受。贪即是爱。即此相应诸缠是取。所起身语二业是有。如是诸法起即是生。熟变是老。灭坏是死。嗔痴心杀有十一支无爱支故。虽有此理而此中说时分缘起。依十二位立十二支。一一支中各具五蕴非刹那顷有十二支。然识身论复作是说。于可爱境由无知故起贪着时。此中无知是无明。有贪著者是行。了别境者是识。识俱诸蕴是名色。名色所依诸根是六处。六处和合是触。能领触者是受。欣所受者是爱。爱增广是取。引后有业是有。诸蕴起是生。诸蕴熟变是老。诸蕴灭坏是死。内热是愁。哀泣是悲。五识相应不平等受是苦。意识相应不平等受是忧。心燋是恼。乃至广说。问前说后说有何差别。答前说是一心。后说是多心。前说是刹那。后说是相续。是谓差别。彼论虽说多心相续十二有支而不同此。以彼所说十二有支多是别法。或同时起。此论所说十二有支皆具五蕴时分各异。施设论说。云何无明。谓过去一切烦恼。彼不应作是说。若作是说则舍自相。应作是说。云何无明。谓过去烦恼位。云何行。谓过去业位。云何识。谓续生心及彼助伴。云何名色。谓结生已未起眼等四种色根。六处未满中间五位。谓羯剌蓝頞部昙。闭尸。键南。钵罗奢佉。是名色位。云何六处。谓已起四色根。六处已满即钵罗奢佉位。眼等诸根未能与触作所依止。是六处位。云何触。谓眼等根虽能与触作所依止。而未了知苦乐差别。亦未能避诸损害缘。触火触刀食毒食粪。食淫具爱犹未现行是触位。云何受。谓能别苦乐。亦能避损害缘。不触火触刀不食毒食粪。虽已起食爱而未起淫及具爱。是受位。云何爱。谓虽已起食爱淫爱及资具爱。而未为此四方追求不辞劳倦。是爱位。云何取。谓由三爱四方追求。虽涉多危崄而不辞劳倦。然未为后有起善恶业。是取位。云何有。谓追求时亦为后有起善恶业。是有位。云何生。谓即现在识位。在未来时名生位。云何老死。谓即现在名色六处触受位。在未来时名老死位。复次有说。无明有二种。一杂事二不杂事。复有二种。一显事二不显事。无明缘行亦有二种。一思业二思已业。行缘识亦有二种。一与悔俱。二不与悔俱。识缘名色亦有二种。一可爱趣摄二不爱趣摄名色缘六处亦有二种。一长养。二异熟。六处缘触亦有二种。一有对触。二增语触。触缘受亦有二种。一身受。二心受。受缘爱亦有二种。一淫欲爱。二资具爱。爱缘取亦有二种。一见门转。二爱门转。取缘有亦有二种。一内门转。二外门转。有缘生亦有二种。一刹那生。二众同分生。生缘老死。老有二种。一眼所见老。二慧所见老。死有二种。一刹那死。二众同分死

如契经说。佛告苾刍。我昔持草诣菩提树。到已敷设结跏趺坐。顺逆观察十二缘起。依此有故彼有。此生故彼生。谓无明缘行乃至生缘老死。老死缘愁悲苦忧恼。问云何菩萨顺逆观察十二缘起耶。答若以因推果名顺观察若以果推因名逆观察。复次若从细入粗名顺观察。若从粗入细名逆观察。如粗细如是可见不可见。现见非现见。显了非显了。应知亦尔。复次若因近观远名顺观察。若因远观近名逆观察。如近远如是在此在彼。现前不现前。此众同分。彼众同分。应知亦尔。问此经中说无明缘行。何故不说无明因行耶。答余经亦说无明因行。如大因缘法门经说。佛告阿难。老死有如是因。有如是缘。有如是绪。谓生如说生为老死因。乃至说无明为行因。问一经虽说无明因行。而多经说无明缘行。有何意耶。答若说无明因行则但说染污行。若说无明缘行则通说染污不染污行。复次若说无明因行则但说罪行。若说无明缘行则通说罪福不动行。复次若说无明因行则但说因缘。若说无明缘行则通说四缘。故多经说无明缘行。问何故但说无明缘行而不说行缘无明。答亦应说行缘无明而不说者。当知是有余说。复次无明缘行势力随顺亲近强胜。行缘无明则不如是。复次无明缘行其义决定。行缘无明则不如是。以阿罗汉有漏业不生无明故。复次行缘无明由无明力。如契经说。非理作意由痴生故能引无明。是故但说无明缘行。复次行于无明但有缘义。无明于行有因有缘。是故但说无明缘行。复次此经中说。时分缘起前位诸蕴说名无明。后位诸蕴说名为行。前因后果展转相引。是故不说行缘无明。问无明为缘通生十二。何故但说无明缘行。答亦应说余而不说者。当知此是有余之说。复次无明缘行势用随顺。余则不尔复次无明缘行势用强胜。余则不尔。复次无明于行能作近缘。是故偏说。于识等十但作远缘。是故不说。如近远在此在彼。现前不现前。此众同分余众同分亦尔。复次无明与行作不共缘。是故偏说。与识等十但作共缘。是故不说。复次此经中说。时分缘起前后次第展转相生。若说无明缘无明便无前后。若说无明缘识等便非次第。是故但说无明缘行。问此经中说行缘识。有余处说名色缘识。余处复说二缘生识。如是三种有何差别。答行缘识说业差别。名色缘识说识住差别。二缘生识说所依所缘差别。复次行缘识说初引时。名色缘识说引已守护时。二缘生识说守护已增长时。复次行缘识说续生时。名色缘识说续生已安住时。二缘生识说安住已领纳境时。复次行缘识说业名色。名色缘识说异熟名色。二缘生识说所依所缘名色。复次行缘识说恶趣识。名色缘识说欲界人天识。二缘生识说色无色界识。胁尊者言。行缘识说中有识。名色缘识说生有识。二缘生识说本有识。有余师说。行缘识说染污识名色缘识及二缘生识说染污不染污识。如染污不染污。有覆无覆。有罪无罪。退不退。应知亦尔。复有说者。行缘识说缘支位识。名色缘识说名色支位识二缘生识说六处支及后位识。问此经中说。识缘名色。余处复说名色缘识此二种何差别。答识缘名色显识作用。名色缘识显名色作用。复次识与名色更互为缘如二束芦相依而住。如象马船与乘御者展转相依得有所至。识与名色亦复如是。识为缘故名色续生名色为缘识得安住。故说此二更互为缘复次识缘名色说初续生时。名色缘识说续生后位。复次识缘名色说续生时识能生名色。名色缘识说续生后识依名色住。复次识缘名色说所生名色。名色缘识说能生名色。复次识缘名色依前后说。名色缘识依同时说。问此经中说名色缘六处应不遍说四生有情。谓胎卵湿生诸根渐起可说名色缘六处。化生有情诸根顿起。云何可说名色缘六处。但应说识缘生六处。有作是说。此经但说欲界三生。不说上界化生。亦无有失。应作是说。此经通说三界四生。谓化生者初受生时。虽具诸根而未猛利。后渐增长方得猛利。未猛利时初刹那顷名识支。第二刹那以后名名色支。至猛利位名六处支。是故此经无不遍失。问六处即在名色中摄。何故说名色缘六处耶。答此前已说。未起眼等四色根时名名色位。四根起已具六处故名六处位。化生虽复六根顿起。而未猛利名名色位。猛利以后名六处位。故无有失。问此经中说六处缘触。有余处说。名色缘触。余处复说二缘生触。如是三种有何差别。答六处缘触显触所依。谓显一切外物和合必因于内。内法胜故但说所依故此经说。六处缘触名色缘触。显触自性二缘生触。显触所依及所缘别复次六处缘触说恶趣触。名色缘触说欲界人天触。二缘生触说色无色界触。复次六处缘触说分位触。名色缘触说现在触。二缘生触说三和触。复次六处缘触说触位触。名色缘触说前位触。二缘生触说后位触。问触受俱起。何故此经但说触缘受。不说受缘触耶。答二虽俱起而触缘受非受缘触随顺胜故。谓触于受随顺力胜非受于触。如灯与明虽复俱起而明因灯在灯因明。此亦如是。复次此经中说分位缘起。前位名触后位名受。故不应责。问何故前位诸蕴名触。后位诸蕴名受耶。答前位未能分别苦乐境界差别。但乐触对种种境界。故说为触。后位能了苦乐境界。避危就安故说为受复次前说触受虽复俱起而触于受随顺力胜故。触为受因。非受为触因。因前果后其理必然。不应为责。问何故触顺受胜非受顺触胜耶。答要因触境方受违顺非受违顺方乃触境。故触于受随顺为胜非受于触随顺为胜。此依缘起理趣而说。不依相应俱有因说

说一切有部发智大毗婆沙论卷第二十三阿毗达磨大毗婆沙论卷第二十四

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中补特伽罗纳息第三之二

问乐受及不苦不乐受与爱为缘是事可尔。爱着此受四方追求可意事故。如何苦受亦与爱为缘。而此经总说受缘爱耶。尊者世友作如是说。苦作爱缘胜余二受。故世尊说苦受所逼便爱乐具。爱乐具故便于乐受起贪随眠。相续增长。有余师说。三受与爱皆作胜缘。乐受义言我能起爱令有相续胜余二受。谓有情类贪着我故。四方追求造善恶行。由此诸有相续无穷。苦受义言我能起爱。令有相续胜余二受。谓诸有情为我所逼贪爱乐受。四方追求造善恶行。由此诸有相续不绝。不苦不乐受义言我能起爱。令有相续胜余二受。谓于欲界下三静虑我尚起爱造善恶行。令有相续。况于上地无苦乐处而不能耶。胁尊者言。三受皆能为缘起爱。识身论说。若有三受未断未知。能起诸爱引众苦果。故知三受皆是爱缘。问云何三受皆能起爱。答爱有五种。一和合爱。二不和合爱。三别离爱。四不别离爱五愚爱。乐受未生起和合爱。乐受已生起不别离爱。苦受未生起不和合爱。苦受已生起别离爱。不苦不乐受未生起和合爱。不苦不乐受已生起不别离爱。于中多分生长愚爱。问爱即取摄。何故此经说爱缘取。答初生爱位以爱声说。增广爱位以取声说。复次下品名爱上品名取。故无有失。问受缘爱爱缘取。此二种何差别。答若爱以受为因名受缘爱。若爱以爱为因名爱缘取。复次若爱是受果名受缘爱。若爱是爱果名爱缘取。如因果生。所生养所养增所增引所引转随转。应知亦尔。复次若爱为爱因名受缘爱。若爱为业因名爱缘取。复次若爱以爱为果名受缘爱。若爱以业为果名爱缘取。如因果生。所生养所养增所增引所引转随转应知亦尔。问何故前际缘起无明为初。后际缘起爱为初耶。答此二烦恼俱是本故。谓无明是前际本。有爱是后际本。复次。前际烦恼位已灭坏故难可了知。故说无明。后际烦恼位正现在前。求当有故说名为爱。复次。无明有七事故。说在前际缘起之初。一该五部。二遍六识。三通三界。四是随眠性。五能起重身语业。六与断善根作胜加行。七是遍行性。爱唯有六事故。说在后际缘起之初。谓前七事中除遍行性。复次。无明有三事故。说在前际缘起之初。一常为元首。二与一切烦恼相应。三是遍行性。爱于后有能引胜故。说在后际缘起之初。复次无明有四事故。说在前际缘起之初。一有漏无漏缘。二有为无为缘。三是遍行非遍行。四自界他界缘。爱唯有漏缘有为缘。非遍行自界缘故。说在后际缘起之初。更有余义。后当广说。取缘有者。若有烦恼。复能发业牵后有果。非无烦恼有缘生者。若有能引后有诸业。后有当生非无引业。生缘老死者。谓若有生便有老死。问何故三有为相中生独立一支。老死共立一支耶。胁尊者曰。世尊于法功能差别能善了知。余无此能故。于此事不须征诘。复有说者。诸法生时生有作用。故独立支。诸法灭时老死无常俱有作用。故合立支。有余师说。生令诸法相续增长。故独立支。老死令诸法不相续不增长。故合立支。或复有说。生令诸法和合作用。故独立支。老死令诸法离散无用。故合立支。尊者世友作如是说。生令诸法从未来入现在。故独立支。老死令诸法从现在入过去。故合立支。尊者妙音作如是说。生作用胜独办一事。故独立支。老死作用劣共办一事。故合立支。如强力人独办一事。劣则不尔。问病何故不立有支。答无有支相故。复次。若法一切时。一切处。一切有者。立有支。病非一切时。非一切处。非一切有。故不立有支。如尊者薄矩罗说。我于佛法出家。年过八十尚不忆有少头痛。况余身病。彼在欲界赡部洲生。尚无少病。况余界余处。病不遍故不立有支。问此契经说老死缘愁悲苦忧恼。何故愁等不立有支。答无支相故。谓愁等五散坏有支。如霜雹等害诸苗稼。复次愁等非一切时。非一切处。非一切有。犹如疾病。是故愁等不立有支。问此愁等五不应但说老死为缘。以无明等十二有支为缘生故。答此经应说无明缘行及愁等五乃至。生缘老死及愁等五。而不说者是有余说。复次应知此经以终显始。老死为缘既生愁等。应知乃至无明亦尔。复次老死位中多起愁等。是故偏说。复次。老死位中。所起愁等多是上品。是故偏说。复次。造恶业者。毁净戒者。于此住中多生愁等。是故偏说。如契经说。若男若女造身语意三种恶行。或破尸罗。临命终时恶趣相现。如日欲暮大山峰影来覆其身。当于尔时。身心惊怖生大苦恼。乃至广说。是故但说老死为缘。问无明为有因不。老死为有果不。设尔何失。若有者。缘起支应有十三或十四。若无者。无明无因老死无果。应是无为。答应作是说。无明老死虽有因果。而非有支。故无十三十四支失。无明因者。谓不如理作意。老死果者。谓愁悲苦忧恼复有说者。无明有因。谓前无明。老死有果。谓后老死。过去未来无明老死有多刹那。故无十三十四支失。有余师说。无明有因。谓前老死。老死有果。谓后无明。以现在爱取即过去无明。现在名色六处触受即未来老死。若说受缘爱即说老死缘无明。犹如车轮上下回转。终而复始。如是有支无始相续。虽有因果而无十三十四支失

复次世尊为受化者。施设缘起少多不定。谓或有处说一缘起。谓一切有为法总名缘起。如说。云何缘起。谓一切有为法。或复有处说二缘起。谓因与果。或复有处说三缘起。谓三世别。或烦恼业及事为三。无明爱取说名烦恼。行有是业。余支是事。或复有处说四缘起。谓无明行及生老死。现在八支摄入四种。谓爱取入无明。有入行。识入生。名色六处触受入老死。或复有处说五缘起。谓爱取有及生老死。前际七支摄入此五。谓无明入爱取。行入有。识入生。名色六处触受入老死。或复有处说六缘起。谓三世中各有因果。或复有处说七缘起谓无明行识名色六处触受。后际五支摄入此七。谓爱取入无明。有入行。生入识。老死入名色六处触受。或复有处说八缘起。谓现在八支。过去未来四支摄入此八。谓无明入爱取。行入有。生入识。老死入名色六处触受或复有处说九缘起。如大因缘法门经说。或复有处说十缘起。如城喻经说。或复有处说十一缘起。如智事中说。或复有处说十二缘起。如余无量契经中说

复次。此十二支缘起法。即烦恼业苦展转为缘谓烦恼生业。业生苦。苦生苦。苦生烦恼。烦恼生烦恼。烦恼生业。业生苦。苦生苦。烦恼生业者。谓无明缘行业生苦者。谓行缘识。苦生苦者。谓识缘名色。乃至触缘受。苦生烦恼者。谓受缘爱。烦恼生烦恼者。谓爱缘取。烦恼生业者。谓取缘有。业生苦者。谓有缘生。苦生苦者。谓生缘老死

复次。此十二支缘起法。有二续三分。二续者。谓识与生能续生故。三分者。谓烦恼业事。无明爱取是烦恼。行有是业。余支是事。有余师说。二续者。谓行有续后有故。三分者。谓三世。又十二支。摄为三聚。谓烦恼业苦如名三聚。亦名三集三有三道。随相应知

复次。此十二支缘起法。有根有茎有枝有叶有花有果。犹如大树。此中根者谓无明行。茎者谓识名色。枝者谓六处。叶者谓触受。花者谓爱取有。果者谓生老死。此十二支缘起法树。或有花有果。或无花无果。有花有果者。谓异生及学。无花无果者。谓阿罗汉。问此十二支缘起法。几刹那。几相续。答二刹那。谓识与生。余皆相续。问此十二支缘起法。几染污。几不染污。有作是说。五染污。谓无明识爱取及生。余通染污不染污。评曰。彼不应作是说。此中说分位缘起故。应作是说。一切皆通染污不染污。前所说五支中。心心所法唯是染污。余通染污及不染污。有作是说。识生二支心心所法定是染污。余皆不定。问此十二支缘起法。几是异熟。几非异熟。有作是说五非异熟。七是异熟。评曰。彼不应作是说。此中说分位缘起故。应作是说。一切皆通异熟非异熟。然无明识爱取生时。心心所法定非异熟。余通二种。有作是说。识生二支心心所法定非异熟。余皆不定。问此十二支缘起法。几有异熟。几无异熟。有作是说。行有二支定有异熟。余通二种。评曰。彼不应作是说。此中说分位缘起故。应作是说。一切皆通二种。问此十二支缘起法。几欲界。几色界。几无色界。有作是说。欲界具十二支。色界有十一支除名色。无色界有十支。除名色六处。色界应作是说。识缘六处彼无未起四根时故。无色界应言识缘触。彼无有色及五根故。评曰。应作是说。三界皆具十二有支。问色界生时诸根顿起。云何有名色位。无色界无色无五根。云何有名色。六处位耶。答色界五根虽定顿起。而生未久。根不猛利。尔时但是名色支摄。无色界虽无色及五根。而有名及意根。彼应作是说。识缘名。名缘意处。意处缘触。是故三界皆具十二

复次。相似有支还令相似有支相续。谓欲界有支还令欲界有支相续。色无色界有支亦尔。唯除受位。此位或能令不相似有支相续。谓生欲界若未离欲染。起欲界爱取有现在前。引未来生老死。彼有现在一爱一取一有未来一生一老死。若已离欲染。未离初静虑染。起初静虑爱取有现在前引未来生老死。彼有现在二爱二取二有未来二生二老死。如是乃至已离无所有处染未离非想非非想处染。起非想非非想处爱取有现在前引未来生老死。彼有现在九爱九取九有未来九生九老死。彼欲界殁生非想非非想处。昔时非想非非想处。现在爱取今为过去无明。现在有今为过去行。未来生今为现在识。未来老死今为现在名意触受。昔时余地若现在若未来诸支。今非过去非未来非现在所以者何。因果展转相比说有。彼地因果俱不成就故。非过去未来现在。彼非想非非想处殁生无所有处。昔时无所有处。现在爱取今为过去无明。现在有今为过去行。未来生今为现在识。未来老死今为现在名意触受。昔时余地若现在若未来诸支。今非过去非未来非现在。所以者何。因果展转相比说有。彼地因果俱不成就故。非过去未来现在。彼无所有处殁展转乃至还生欲界。昔时欲界。现在爱取今为过去无明。现在有今为过去行。未来生今为现在识。未来老死今为现在名色六处触受。昔时余地若现在若未来诸支。今非过去非未来非现在。所以者何。因果展转相比说有。彼地因果俱不成就故。非过去未来现在

复次。若生欲界诸根成就能造能引后有业者。彼无明位现在前时。一支现在谓无明。余支未来。从无明位至行位时。二支现在谓无明行。余支未来。从行位至识位时。二支过去谓无明行。一支现在谓识。余支未来。从识位至名色位时。二支过去谓无明行。二支现在谓识名色。余支未来。如是乃至从取位至有位时。二支过去谓无明行。八支现在谓识乃至有。二支未来谓生老死。从有位至生位时。十支过去谓无明乃至有。一支现在谓生。一支未来谓老死。从生位至老死位时。十支过去谓无明乃至有。二支现在谓生老死。尊者望满作如是言。无明行位现在前时。二支现在谓无明行。十支未来。八在次后生谓识乃至有。二在第三生谓生老死。生老死位现在前时。二支现在谓生老死。十支过去。八在次前生谓识乃至有。二在第三生谓无明行。识等八位现在前时。八支现在谓识乃至有。二支过去谓无明行。二支未来谓生老死。如说生欲界。说生色无色界应知亦尔。复次。诸契经中。佛为所化说缘起法。或因为门。或果为门。或俱为门。问为何所化。以因为门。说缘起法。乃至为何所化。以俱为门。说缘起法。答为愚因者。以因为门说缘起法。为愚果者。以果为门说缘起法。为愚因果者。以俱为门说缘起法。复次为初修业者。以果为门说缘起法。为超作意者。以因为门说缘起法为已串习者以俱为门说缘起法。复次为乐略者。以因为门说缘起法。为乐广者。以果为门说缘起法。为乐广略者。以俱为门说缘起法。复次为利根者。以因为门说缘起法。为钝根者。以果为门说缘起法。为中根者。以俱为门说缘起法。问若为钝根者以果为门说缘起法。彼便得解者。后身菩萨。于诸有情根最为胜。何因缘故以果为门观缘起法。答过去菩萨过殑伽沙数。皆以果为门观缘起法。未来亦尔。故今菩萨住最后身。亦作是观。复次菩萨亦观无明缘行展转乃至生缘老死。如是顺观多于二乘或复有时修习逆观。故不可说唯果为门。复次菩萨现见老病死苦。作是思惟。此老病死何缘而有。知由生有。复思惟。生何缘而有。知由有有。乃至广说。由先见果故作是观。复次有净居天。为发菩萨厌有心故现老病死。菩萨见已厌有出家。既出家已随先所见。以果为门观缘起法。复次顺现观故。谓菩萨后谛现观时先观苦谛。今学现观故先观果。复次先作是说。为初修业者以果为门说缘起法。菩萨亦是初修业者。故果为门观缘起法。菩萨虽复无量劫来修缘起观。而最后身创起此故名初修业。复次菩萨往劫初修业时。以果为门观缘起法。今虽串习如本修时。以果为门观缘起法。如人于树虽数上之后。若上时还从根上。复次欲现焚烧生死树故。如人烧树。先焚枝叶后及其根。菩萨亦尔。以果为门观缘起法。随所观处令永不生。胁尊者言。不以菩萨以果为门观缘起故便名钝根。然观行者总有二种一随爱行。二随见行。随爱行者。以果为门观缘起法。依无愿三摩地入正性离生。随见行者。以因为门观缘起法。依空三摩地入正性离生。唯除菩萨。菩萨虽是随爱行者以果为门观缘起法。而能依空三摩地。入正性离生。故有问言。颇有随爱行者。以果为门观缘起法。而依空三摩地入正性离生耶。答有如诸菩萨

如契经说。佛告苾刍。我未证得三菩提时。独居静处作是思惟。世间众生虽恒为生老死苦之所逼害。而不能如实了知出离彼法。复作是念。谁有故老死有。此老死谁为缘。作是念已便起现观。生有故老死有。此老死生为缘。复作是念。谁有故生有。此生谁为缘。作是念已便起现观。有有故生有。此生有为缘。如是乃至复作是念。谁有故名色有。此名色谁为缘。作是念已便起现观。识有故名色有。此名色识为缘。复作是念。谁有故识有。此识谁为缘。作是念已便起现观。名色有故识有。此识名色为缘。便作是念。我齐此识心应转还。所以者何。名色缘识。识缘名色。名色缘六处。乃至广说。问菩萨观此缘起法时。未得见道真无漏慧。云何得说起现观耶。答尔时未得真实现观。由世俗智现见缘起。似现观故立现观名。问菩萨何故逆观缘起。唯至于识心便转还为智力穷。为尔焰尽。设尔何失。若智力穷。不应正理。菩萨智见无边际故。若尔焰尽。理亦不然。行与无明犹未观故。答应作是说。非智力穷。非尔焰尽。但由菩萨于行无明先已观故。谓先观有即已观行先观爱取已观无明。问先观老死已观名色六处触受。先观生已观识。于名色等应不重观。答先略后广。先总后别。无重观失。问若尔生识无广略异。何为重观。答厌畏生故再观无失。谓我世尊先菩萨位厌老病死。逾城出家。作是思惟。此老死苦由谁而有。即便现见由续生心。复思此心由谁而起。即知由业。复思此业从何而生。知从烦恼。复思烦恼依谁而生。即知依事。复思此事由谁而转。即知此转由结生心。菩萨尔时便作是念。一切过患皆由此心。故于此心深生厌异。虽无广略而更重观。齐识转还义属于此。问无明既略何为不观。答隔行支故。谓观缘起必依次第。不可越行而观无明。有作是说。先观有缘生时已观业名色。后观名色缘识时即观异熟名色。若复观行缘识。亦观业名色。与前不异故不重观。有余师说。先观有缘生时。已观远缘。后观名色缘识时。即观近缘。若复观行缘识。亦观远缘。与前不异故不重观。如近远。在此在彼现前不现前此众同分余众同分。应知亦尔。或有说者。先观有缘生时已观前生缘。后观名色缘识时即观俱生缘。若复观行缘识亦观前生缘。与前不异故不重观。复有说者。先观有缘生时已观转缘。后观名色缘识时即观随转缘。若复观行缘识亦观转缘。与前不异故不重观。或复有说。避无穷过故不重观。谓先观老死即观此生名色六处触受。先观生即观此生识。后观名色六处触受即观前第二生老死。后观识即观前第二生生。若复观无明行应观前第三生。若尔亦应观第四生。如是展转便为无穷。故不重观无明及行。尊者世友作如是说。何故齐识心便转还。以识乐住识住中故。谓识不欲舍于识住。识住者即名色。故观识已还观名色。复作是说。识与名色互为缘故。复作是说。此二展转为因果故。大德说曰。何故齐识心便转还。以度识支无所缘故。犹如尺蠖行至草端。上无所缘即便退下观心亦尔。唯应至识。余非其境故便退还。胁尊者言。何故齐识心便转还。缘转还故。谓前已说识缘名色。今复更说名色缘识。前为因者今转为果。境转还故心亦转还。尊者妙音作如是说。何故齐识心便转还。识是生死众苦本故。谓我菩萨厌生死苦。逾城出家推寻世间老病死苦。谁为根本。谓结生心。复推此心由谁而引。谓业。复推此业由谁而发。谓烦恼。复推烦恼依谁而起。谓事。复推此事谁为根本。谓结生心。便作是念。此结生心恒为生死众苦根本。深可厌患。齐此应还修真对治。尊者设摩达多说曰。何故齐识心便转还。以未来生可比知故。谓先观见有缘生时。知现在生是众苦本。后复观见名色缘识。知过去生是众苦本。便作是念。现在过去生死众苦。既生为本。未来亦然。故不复须更观余境。是故齐识心便转还。由诸有支皆有三世。尊者望满所说义成。如说。无明行位现在前时。二支现在乃至广说。如契经说。佛告苾刍。我于尔时作如是念。谁不有故老死不有。谁灭故老死灭。作是念已便起现观。生不有故老死不有。生灭故老死灭。如是乃至复作是念。谁不有故行不有。谁灭故行灭。作是念已便起现观。无明不有故行不有。无明灭故行灭。行灭故识灭。乃至广说。问何缘菩萨流转分中但观十支。还灭分中具观十二支耶。答菩萨憎恶流转故但观十支爱乐还灭故具观十二支。复次流转分中多诸过患。牵心劣故但观十支。还灭分中多诸功德。牵心胜故具观十二支诸契经中。或说缘起如灯。或说缘起如火聚。或说缘起如城。问世尊何故说缘起法如灯如火聚如城耶。答随所现见即以为喻。谓所化生现见灯者。即以灯喻显缘起法。若所化生现见火聚。即以火聚。显缘起法。若所化生现见城者。即以城喻显缘起法。复次若所化生闻说灯喻解缘起者。佛说如灯。若所化生闻说火聚解缘起者。说如火聚。若所化生闻说如城解缘起者。佛说如城。复次若所化生有下品爱取者。佛则为说缘起如灯。若所化生有中品爱取者。佛则为说缘起如火聚。若所化生有上品爱取者。佛则为说缘起如城。如三品爱取。三根三乐应知亦尔如世尊说。无明缘行取缘有。乃至广说。问何故作此论。答为欲分别契经义故。谓契经说。无明缘行取缘有。虽作是说而不广辩。经是此论所依根本。彼未辩者今应分别。复次为令疑者得决定故。谓行与有体俱是业。或有生疑其体无别。为显差别故作斯论。云何无明缘行。云何取缘有。答无明缘行者。此显示业先余生中造作增长。得今有异熟。及已受异熟。取缘有者。此显示业现在生中造作增长。得当有异熟此显示业者。此佛世尊显了开示已造今造一切不善善有漏业。先余生中者。显示此业在先世余众同分中已尽已灭已离已变。造作增长者。显示此业发起圆满从烦恼生能得果故。得今有异熟者。显示此业感得此生诸果异熟。及已受异熟者。显示此业已受前生诸异熟果所有前生造作增长。善不善业彼异熟果。若今熟。若已熟者。当知皆在行支分中。现在生中者。显示此业唯在此生众同分中。造作增长非余生中。得当有异熟者。显示此业得未来生诸果异熟。所有今生造作增长。善不善业彼异熟果。于此生中果未熟者。当知皆在有支分中。问何故过去生所造业果已熟者名行。现在生所造业于此生中果未熟者名有耶。答过去生所造业果。已熟者。已衰朽。已受用。已与果。已办事。无势力。不能更引后有异熟。然已造作已迁变故。说名为行。现在生所造业。于此生中果未熟者。与彼相违说名为有。有作是说。过去生所造业果已熟者。是故业故说名为行。现在生所造业于此生中果未熟者。是新业故说名为有。有余师说。过去生所造业果已熟者。已与果故说名为行。现在生所造业于此生中果未熟者。未与果故说名为有

问造作增长有何差别。有说。此二无有差别。所显业体无差别故。有说。此二亦有差别。谓名则差别。名造作。名增长故。复次义亦有差别。谓有由一善恶行生善恶趣。有由三善恶行生善恶趣。由一者。加行时唯造作。成满时具二种。由三者。作一二唯造作。若作三具二种。复次有由一无间业堕地狱。有由五无间业堕地狱。由一者。加行时唯造作。成满时具二种。由五者。作四来唯造作。若作五具二种。十善不善业道亦尔。复次有由多业感一生果。如诸菩萨。由三十二百福业故感最后身。造三十一百福业来唯造作。造三十二百福业满具二种。复次故思造业具二种。非故思者唯造作。复次先思造业具二种。率尔造者唯造作。复次有加行业具二种。无加行者唯造作。复次三时定业具二种。时不定者唯造作。复次处定受业具二种。处不定者唯造作。复次定受果业具二种。不定受者唯造作。复次不善业恶趣受者具二种。人天受者唯造作。善业人天受者具二种。恶趣受者唯造作。复次不善业。以不善业为眷属者具二种。以善业为眷属者唯造作善业。以善业为眷属者具二种。以不善业为眷属者唯造作。复次不善业。在耶见愚因果身中者具二种。在正见不愚因果身中者唯造作。善业与上相违。复次不善业。在破戒破见身中者具二种。在破戒不破见身中者唯造作。善业。在具戒具见身中者具二种。在不具戒具见身中者唯造作。复次不善业。在坏加行坏意乐身中者具二种。在坏加行不坏意乐身中者唯造作。善业。在具加行具意乐身中者具二种。在具意乐不具加行身中者唯造作。复次若业作已不舍不吐不依对治者具二种。若业作已能舍能吐依对治者唯造作。复次若业三时恒觉悟者具二种。若不尔者唯造作。复次若业作已无变悔者具二种若业作已有变悔者唯造作。复次若业作已恒忆念者具二种。若业作已不恒忆念唯造作。复次若业作事究竟具二种。若不究竟唯造作。复次若业数作具二种。若不数作唯造作。复次若业作已欢喜赞叹回向果者具二种。若不尔者唯造作。复次明了心作具二种。不明了者唯造作。诸如是等是谓差别

说一切有部发智大毗婆沙论卷第二十四阿毗达磨大毗婆沙论卷第二十五

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中补特伽罗纳息第三之三

无明缘行取缘有。有何差别。答无明缘行者。广说如前。此业缘。世尊说一烦恼。谓无明取缘有者。广说如前。此业缘。世尊说一切烦恼。谓诸取。是谓差别。问何故复作此论。答前虽说所发业自性差别。谓前业在过去生。后业在现在生。前业已与果。后业未与果。前业是故。后业是新。而未说能发缘自性差别。今欲说之故作此论。问何故过去业缘但说无明。现在业缘说一切烦恼耶。答造过去业时。于多种事不现见故。不可知故。但说无明为缘。谓于界趣生洲分位依处加行等起相续所缘。皆不可知。界者三界。不知过去于何界造此业。趣者五趣。不知过去于何趣造此业。生者四生。不知过去于何生造此业。洲者四洲。不知过去于何洲造此业。分位者。羯剌蓝等十种分位。不知过去于何分位造此业。依处者。十善不善业道依处。不知过去于何依处造此业。加行者。有情数非有情数所起加行。不知过去由何加行造此业。等起者。贪嗔痴等。不知过去由何等起造此业。相续者。男女等。不知过去依何相续造此业。所缘者。过去未来现在。或色声香味触法。不知过去心缘何等造此业。虽不现见亦不可知。而发业位皆有无明故。总说彼无明为缘。造现在业时于多种事。皆现见故皆可知故。具说一切烦恼为缘。复次过去业。已衰朽。已受用。已与果。是故业。无势用。不明了故。但说无明为缘。现在业。未衰朽。未受用。未与果。是新业。有势用。极明了故。说一切烦恼为缘。复次过去业微细难觉。若自若他俱不现见。不知何等烦恼所发。然烦恼起必有无明。是故但说无明为缘。现在业粗显易觉若自若他俱能现见。知是彼彼烦恼所发。故说一切烦恼为缘。复次过去业性不猛利。其相暗昧顺无明故但说无明为缘。现在业性猛利。其相明显顺诸取故。具说一切烦恼为缘。问阿罗汉所造业。为名无明缘行。为名取缘有耶。答不名无明缘行。亦不名取缘有。彼无无明亦无取故。然彼业已与果者。当知摄在行支分中。未与果者。当知摄在有支分中。是彼类故。然非十二有支所摄

颇有行缘无明不缘明耶。乃至广说。问何故此中因明无明而作论耶。答是作论者意欲尔故。乃至广说。复次此二俱是根本法故。谓杂染品法无明为根本。清净品法明为根本。复次此二俱是上首法故。如说。无明为上首。无明为前相。生无量种恶不善法。及起此类无惭无愧。明为上首。明为前相。生无量种清净善法。及起此类增上惭愧。复次明与无明近相治故。谓无明是明近对治。明是无明近对治。复次明与无明互相违故。谓无明违明明违无明。复次明与无明互不相摄。而所缘境互相摄故。谓俱缘四圣谛俱缘有漏无漏。俱缘有为无为故。然诸行名义有宽狭。如说无明缘行。阿毗达磨诸论师言。此中意说分位缘起。故此行声说五取蕴。尊者妙音说。此行声唯说诸业。如说。造作有损害行。彼行声说不善业。如说。造作无损害行。彼行声说善业。如说。造作诸有为行。彼行声唯说思。如说。色心心所法。心不相应行。无为。彼行声说不相应行蕴。如说。色受想行识蕴。彼行声总说相应不相应行蕴。如说色受想行识取蕴。彼行声唯说有漏相应不相应行蕴。如说。身语意行。彼身行声说入出息。语行声说寻伺。意行声说想思。故彼行声说一蕴全。二蕴少分。如说。有罪福不动行。彼行声说有漏善不善业。如说。于诸行中有五过患。有怖有畏有苦触。无我我所。诸有智者不见此行。能离诸行。有说。彼行声说不善法。以说彼行有怖有畏有苦触故。有说。彼行声说五取蕴。以说彼行无我我所。诸有智者不见此行能离诸行故。如说。诸行无常有生灭法。有说。彼行声说一切有为法。第三句说由生灭故。有说。彼行声但说五取蕴。第四句说彼寂为乐以寂乐名唯显择灭非无漏法有择灭故。如说。有罪行无罪行。彼行声说善不善业。如说。三妙行三恶行。彼行声说善不善业。及贪嗔邪见。无贪无嗔正见。如说。一切行无常。一切法无我。涅槃寂静。彼行声说一切有为法。此中行声亦说一切有为法。以明无明俱为缘故

颇有行缘无明不缘明耶。答无何以故无。如是行唯以无明为缘非明故。颇有行缘明不缘无明耶。答无。何以故无。如是行唯以明为缘非无明故。颇有行缘无明亦缘明耶。答有。何以故。诸行种类有十一种。欲界有四。谓善。不善。有覆无记。无覆无记。色界有三。谓善。有覆无记。无覆无记。无色界有三。如色界说。及无漏行为十一种。此中欲界善行。明与无明俱非其因。但作三缘。谓等无间。所缘。增上。不善行。以无明为四因。谓相应。俱有。同类。遍行。亦作四缘。明非其因但作二缘。谓所缘增上。欲界有覆无记行。以无明为四因如前说。亦作四缘明非其因。但作一缘谓增上。欲界无覆无记行。除无明异熟。无明非其因。但作三缘。谓除因缘。明非其因。但作一缘谓增上缘。无明异熟以无明为一因。谓异熟因。但作三缘谓除所缘。无明异熟非意地故。明非其因。但作一缘谓增上缘。色界善行。明与无明俱非其因。但作三缘。谓除因缘。色界有覆无记行。以无明为四因。谓相应俱有同类遍行。亦作四缘。明非其因。但作二缘。谓所缘增上。色界无覆无记行。无明非其因。但作三缘。谓除因缘。明非其因。但作一缘谓增上缘。如说。色界三行。无色界三行说亦尔。无漏行除初明及彼俱得无明非其因。但作二缘谓所缘增上。以明为三因。谓相应俱有同类。亦作四缘。初明无明非其因。但作二缘谓所缘增上。明亦非其因。但作一缘谓增上缘。初明俱得明无明俱非其因。但作一缘谓增上缘。是谓此处略毗婆沙。故一切行皆得以明无明为缘理善成立。以增上缘无不遍故

颇有行不缘无明亦不缘明耶。答无。所以者何。无一有情从久远来。不于圣道谤言非道。先谤道已。彼于后时造作增长感大地业。或于后时造作增长感小王业。或于后时造作增长感大王业。或于后时造作增长转轮王业由此因。由此缘由彼圣道展转感得大地所有城邑聚落人非人畜。谷稼药草树木丛林。增长滋茂。如是前心四缘于后心但为一增上缘。此中正说无漏圣道谤道邪见。于诸有漏善业及果皆能作缘。显一切行无有不缘明无明者。以增上缘展转相望无不有故。感大地业者。谓能感得大地山林河海园苑药草等物。于彼自在统领受用。感小王业者。谓能感据堡坞王位。感大王业者。谓能感据川原王位。转轮王业者。谓能感据一主地等力轮等位。如屈厦拏没鲁茶至那天子等。复次感小王业者。谓能感据川原王位。感大王业者。谓能感据一主地位。如屈厦拏没鲁茶等。转轮王业者。谓能感据一洲等位。复次感小王业者。谓能感据一主地位。感大王业者。谓能感据一洲王位。转轮王业者。谓能感据二洲等位。复次感小王业者。谓能感据一洲王位。感大王业者。谓能感据二三洲位。转轮王业者。谓能感据四洲王位。有作是说。感小王业者。谓能感据转轮圣王所使王位。感大王业者。谓能感得转轮王太子位。转轮王业者。谓能感得转轮王位。有余师说。感小王业者。谓能感得轮王太子未灌顶位。感大王业者。谓能感得轮王太子已灌顶位。转轮王业者。谓能感得转轮王位。由此因者。谓由此所造善业。由此缘者。谓由此谤道邪见。由彼圣道者。谓由彼所谤圣道。由此因缘及彼圣道。展转感得大地所有有情无情内外异熟及增上果。其事云何。如诸外道厌世增减。复厌世间怨憎会苦爱别离苦。在家迫迮犹如牢狱。而便出家。既出家已。为解脱故。受持种种非理苦行。执为清净能证解脱。如如依止苦行邪道。如是如是圣道转远。远圣道故不证解脱。便作是念。虽有解脱而无圣道。若当有者我何不得。我修如是难行苦行。经久不得故知无道。既谤道已舍所受持。作是思惟。修福业者。尚于生死不得如意自在快乐。况不修福。既思惟已。种种方便求诸财宝。设大施会因发愿言。愿我此福。能感大地内外物等。得作小王。或作大王或作轮王。统摄自在随其所愿皆得果遂。又如内道厌患世间寿命财位或增或减。又厌世间怨憎会苦爱别离苦。在家迫迮犹如牢狱。流转生死受诸剧苦。为解脱故而便出家。既出家已。少欲喜足精勤苦行。初夜后夜曾不睡眠。依止山岩受小大七。结跏趺坐端身静虑。始从日没至日出时。专注思惟所受定相。炽然精进经历多时。由二因缘不得圣道。一善根未熟。二起邪加行。善根未熟者。谓依佛法极速三生。方得解脱。第一生中种解脱分。第二生中修令成熟。第三生中既成熟已。引起圣道能证解脱。彼先未种解脱分善。故此生中善根未熟。起邪加行者。谓彼受持颠倒对治。以是事故不得圣道。便作是念。虽有解脱而无圣道。若当有者我何不得。我修如是精进苦行。经久不得故知无道。既谤道已舍所受持。作是思惟。修福业者。尚于生死不得如意自在快乐。况不修福。既思惟已。种种方便求诸财宝。设大施会供侍病者敬养有德自作教他。见作随喜。修诸福业炽然无倦。因斯发愿。愿我此福能感大地内外物等。得作小王。或作大王或作轮王。统摄自在随其所愿皆得果遂。既居王位以法治国。令内外物皆悉滋茂。若无圣道谤道邪见无由得生。故彼圣道为此邪见近增上缘。若无邪见施俱善心无由得起。故染污法为不染污近增上缘。若无施福不得王位。若无王位诸内外物无由滋长。故有情数为诸外物近增上缘。如是前心四缘者。谓邪见俱心具有四缘。彼相应俱有法等是彼因缘。疑等是彼等无间缘。圣道是彼所缘缘。除彼自体。余一切法皆是彼增上缘。于后心但为一增上缘者。谓前心四缘与后施俱心但为一增上缘。问后施俱心亦有四缘。因缘者。谓彼相应俱有法等。等无间缘者。谓次彼前心心所法。所缘缘者。谓所舍物及受施者。增上缘者。谓除彼自体。余一切法。如是后心四缘于前心亦为一增上缘。此中何故不说。答亦应说而不说者。应知此是有余之说。有作是说。以前类后其义可知。故不复说。有余师说。前心于后为缘义顺。非后于前。是故不说。问后心四缘皆入前心四缘中摄。彼增上缘。除自摄余一切法故。何缘乃说前心四缘与后心作一增上缘。答此中应说。前心四缘亦与后心具作四缘。而但说作一增上者。应知此说近增上缘。谓前邪见近增上缘不入后心。前三缘摄后心所有。近增上缘不入前心。前三缘摄如余处说。眼识四缘。谓彼相应俱有诸法是彼因缘。次彼前灭心心所法是彼等无间缘。色是彼所缘缘。眼是彼增上缘。如彼唯说近增上缘。此亦应尔。故无有失。有作是说。前邪见心增上缘内。理实具有后心四缘。然增上缘其义宽遍一切处有。是故偏说。问若尔后心亦是前心增上缘摄。既说前心四缘于后为增上缘。是则自体应与自体为增上缘。便违宗义。答此中应说前心四缘于后但作一增上缘。除其自性。而不说者先已说故。谓前品中已说诸识。除其自性。余一切法为能作因故不复说。若于余论余蕴余日所说语言尚可为证。况于此论此蕴此日次前品说而不为证。有说。此中说近增上故无有失

复次若依因缘说者。此中依言显所约义。谓约因缘而作论者得有三句。前约四缘而作论故但有俱句。颇有行缘无明不缘明耶。答有。谓无明异熟及染污行。此中无明异熟以无明为一因。谓异熟因。明非其因。染污行以无明为四因。谓相应俱有同类遍行。明非其因。颇有行缘明不缘无明耶。答有。谓除初明。诸余无漏行。谓余无漏行以明为三因。谓相应俱有同类因。无明非其因颇有行缘无明亦缘明耶。答无。何以故。明与无明相去远故。必无一行以二为因。如有颂言

  虚空大地相去远　　海彼此岸亦复远
  日出没处斯亦远　　正法邪法远中远

颇有行不缘无明亦不缘明耶。答有。谓除无明异熟。诸余无覆无记行。及初明善有漏行。问此中所除无明异熟何者是耶。答谓欲界三十四随眠。及彼相应俱有生等所感异熟。如是名为无明异熟。有作是说。欲界三十四不善随眠得所感异熟。亦名无明异熟。得与所得同一果故。有余师说。不善身语业所感异熟。亦名无明异熟。能起所起同一果故。评曰。二俱非理能得所得能起所起。展转相望非俱有因故。不同一果故。随眠得及身语业所感异熟。非无明异熟。是故初说于理为善。诸余无覆无记行者。谓一切善法异熟一切不善身语业及彼生等异熟。一切不善得及彼生等异熟。一切长养色及彼诸得生等。一切等流法。及彼诸得生等。一切威仪路工巧处通果心相应俱有法。及所起身语业诸得生等。如是诸行明与无明俱非其因。然非无因。谓或有四因。或有三因。或有二因。如理应说。初明者谓现行苦法智忍。无明非其因无漏性故。明亦非其因。若俱若前。俱无明故。然非无因彼有相应俱有因故。问初明俱得亦明无明俱非其因。然非无因。彼俱生等能与彼为俱有因故。此第四句何故不说。前第二句何故不除。答此亦应说。前亦应除。而不尔者是有余说。有作是说。此已摄在第二句中。是苦法忍俱有法故。彼不应作是说。得与所得非俱有因。前已说故前说为善。依如是义有问答言。颇有一刹那顷有二十四得。与苦法智忍俱生。是苦法智忍种类。而与苦法智忍互无因义耶。答有。谓依第四静虑入正性离生者。苦法智忍现在前时。有六地各四行相苦法智忍得俱时现前。彼与苦法智忍互无因义。善有漏行者。谓一切善有漏五蕴明与无明俱非其因。然非无因。谓或有三因或有二因如理应说。由此故说若依因缘因明无明行有三句

问何故名无明。无明是何义。答不达不解不了是无明义。问若尔除无明诸余法。亦不达不解不了。何故不名无明。答若不达不解不了以愚痴为自相者是无明。余法不尔故非无明。问何故名明。明是何义。答能达能解能了是明义。问若尔有漏慧亦能达能解能了何故不名明。答若达解了能于四谛真实通达说名为明。诸有漏慧虽达解了而于四谛不能真实通达故不名明。如暖等四顺决择分虽能猛利推求四谛。而未真实通达四谛不名为明。复次若达解了能于四谛究竟通达说名为明。诸有漏慧虽达解了而于四谛不能究竟通达故不名明。复次若达解了能于四谛决定通达说名为明。诸有漏慧虽达解了而于四谛不能决定通达故不名明。复次若达解了能于四谛见已非复不见。知已非复不知。现观已非复为无知犹豫邪智所伏。说名为明。诸有漏慧虽达解了而于四谛不能如是。故不名明。复次若达解了断所断法。令其究竟无力增长说名为明。诸有漏慧虽达解了而无此力。故不名明。复次若达解了破坏诸有说名为明。诸有漏慧虽达解了而增长有故不名明。复次若达解了能断续有续老死法。能令生死究竟断灭说名为明。诸有漏慧虽达解了无如是力故不名明。复次若达解了。趣苦灭行。及趣诸有世间生死老死灭行说名为明。诸有漏慧虽达解了。而趣苦集行。及趣诸有世间生死老死集行故不名明。复次若达解了非身见事。非随眠事。非颠倒事。非贪嗔痴慢。安足处无垢秽浊。不堕诸有苦集谛摄故说为明。诸有漏慧虽达解了与上相违故不名明。复次若达解了无无明者说名为明。诸有漏慧虽达解了有无明故不名为明。复次能疗病咒说名为明。谓世间人鬼魅所著明咒能疗。如是圣道能疗众生诸烦恼病故说为明。诸有漏慧不能究竟疗烦恼病故不名明。复次诸有漏慧随顺二品。以于二品俱作三缘故不名明。亦非无明如人于他怨家亲友俱随顺者。彼人于他非亲非怨此亦如是。复次有漏慧品能谤明故不名为明。有漏善慧虽顺于明而能引生谤道邪见如叛臣故不名为明。复次诸无漏慧于四圣谛照了明净。如昼分眼见诸色像故说为明。诸有漏慧于四圣谛见不明净。如夜分眼见诸色像故不名明

问除明为因法及非明法余法。几界几处几蕴摄。答一界一处一蕴摄。此中除明为因法者。谓除初明诸余无漏慧。及非明法者。谓一切有漏法及除无漏慧。诸余无漏法。余法者。谓初明彼一界一处一蕴摄者。谓法界法处行蕴摄。问除心为因法及非心法余法。几界几处几蕴摄。答二界一处一蕴摄。此中除心为因法者。谓除现行苦法智忍相应心诸余无漏心。及非心法者。谓十一处。余法者谓现行苦法智忍相应心。彼二界一处一蕴摄者。谓意界意识界意处识蕴摄。问若法是明彼法是明因耶。答应作四句。有法是明非明因。谓未来明。有法是明因非明。谓过去现在除无漏慧诸余无漏行。及未来明相应俱有法。有法是明亦明因。谓过去现在诸无漏慧。有法非明非明因。若说彼类。谓未来无漏得。及彼生等。若不说彼类。谓除前相。问若法是明彼法明为因耶。答应作四句。有法是明非明为因。谓初明。有法明为因非明。谓明相应俱有法及除初无漏得并彼生等。诸余无漏得并彼生等。有法是明亦明为因。谓除初明。诸余无漏慧。有法非明非明为因。若说彼类谓初无漏得及彼生等。若不说彼类谓除前相。复次有随信行道及随法行道。此中随信行道与随信行道为因。亦与随法行道为因。随法行道唯与随法行道为因。非随信行道。以彼劣故有作是说。随信行道亦唯与随信行道为因非随法行道。以见道中随信行者必不转为随法行故。评曰彼不应作是说。同一相续有可得义。复是胜道如何非因。是故前说于理为善。复次有信解道及见至道。此中信解道与信解道为因。亦与见至道为因。见至道唯与见至道为因。非信解道以彼劣故。复次有时解脱道及不时解脱道。此中时解脱道。与时解脱道为因。亦与不时解脱道为因。不时解脱道唯与不时解脱道为因。非时解脱道以彼劣故。复次有见道修道无学道。此中见道与见道为因。亦与修道无学道为因。修道与修道为因。亦与无学道为因。非见道以彼劣故。无学道唯与无学道为因。非见修道以彼劣故。复次有声闻道独觉道佛道。此中声闻道唯与声闻道为因。非余二道以极远故。独觉道唯与独觉道为因。非声闻道以彼劣故。及极远故。亦非佛道以极远故。佛道唯与佛道为因。非余二道以彼劣故。及极远故。复次圣道亦依男身亦依女身。此中依女身圣道与依女身圣道为因。亦与依男身圣道为因。依男身圣道唯与依男身圣道为因。非依女身圣道以彼劣故。有作是说。彼二圣道展转为因随其利钝。彼说非理。男女二身胜劣定故。依彼圣道胜劣亦定有余师说。彼二圣道展转非因依类别故。彼说非理。先于女身入圣道已后转为男。所起圣道应无因故。由是此中前说为善。复次有说一道有说多道。说一道者。不言见道即是修道及无学道。见修无学三道异故。但说圣道依男女身。此二身中圣道是一。说多道者。言二身中圣道各别依类别故。说多道者复有二种。一作是说。依女身圣道于女身中。亦得亦在身亦成就亦现在前。依男身圣道于女身中。得而不在身成就不现在前。依男身圣道于男身中。亦得亦在身亦成就亦现在前。依女身圣道于男身中。不得不在身不成就不现在前。以依男身得圣道。后必无更受女身义故。又彼所依定鄙劣故。二作是说。依女身圣道于女身中。亦得亦在身亦成就亦现在前。依男身圣道于女身中。不得不在身不成就不现在前。依类别故。于男身中说二圣道应知亦尔。彼说非理。先依女身得圣道已后转为男应更得道。是故次前所说为善。如是见道衣九处身。谓人三洲除北俱卢及六欲天。此九皆能入见道故。说一道者。言九依身见道是一依类同故。谓彼所依男女同类。说多道者。言九依身见道各别依处异故。说多道者。复有二种。一作是说。依赡部洲身见道于赡部洲身中。亦得亦在身亦成就亦现在前。依余八处身见道于赡部洲身中。得而不在身成就不现在前。二作是说。依赡部洲身见道于赡部洲身中。亦得。亦在身亦成就亦现在前。依余八处身见道于赡部洲身中。不得不在身不成就不现在前。彼说非理。依赡部洲身得预流果已后生余处应更得果。然无此义。是故次前所说为善。于余八身说二见道应知亦尔。如是修道依三界身说一道者。言三界身修道是一。说多道者言三界身修道各别。说多道者复有二种。一作是说依欲界身修道于欲界身中。亦得亦在身亦成就亦现在前。依上二界身修道于欲界身中。得而不在身成就不现在前。二作是说。依欲界身修道于欲界身中。亦得亦在身亦成就亦现在前依色无色界身修道于欲界身中。不得不在身不成就不现在前。彼说非理。依欲界身得不还果后生上界应更得果。然无此义。是故次前所说为善。于上界身说二修道应知亦尔。二乘无学道亦准此应知。如是无上正等菩提依赡部洲百年位身。乃至依此八万岁身。说一道者言依百年位身无上菩提即是乃至依八万岁身无上菩提。说多道者。言依百年位身无上菩提乃至依八万岁身无上菩提其体各别。说多道者复有二种。一作是说。依百年位身无上菩提于百年位身中。亦得亦在身亦成就亦现在前。依余位身无上菩提于百年位身中。得而不在身成就不现在前。二作是说。依百年位身无上菩提于百年位身中。亦得亦在身亦成就亦现在前依余位身无上菩提于百年位身中。不得不在身不成就不现在前。问若尔何故施设论说诸佛功德一切平等。答由三事故。一修行等。谓一切佛皆三大劫阿僧企耶修四波罗蜜多圆满得无上菩提故。二法身等。谓一切佛皆成十力四无畏等无量无边胜功德故。三利益等。谓一一佛皆度无量无边有情令解脱故复次根等。谓一切佛皆住上上根故。复次戒等。谓一切佛皆得上上戒故。复次道等。谓一切佛皆成上上道故。评曰。此中次前所说为善依同类故

说一切有部发智大毗婆沙论卷第二十五阿毗达磨大毗婆沙论卷第二十六

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中补特伽罗纳息第三之四

入息出息当言依身转耶。依心转耶。乃至广说。问何故作此论。答为令疑者得决定故。谓契经说。佛告长者。此入出息是身法身为本系属身依身而转。施设论说。何缘死者入出息不转耶。谓入出息由心力转。死者无心但有身故。此入出息一说依身一说依心。或有生疑。如是二说俱不了义。或俱了义。欲显此二真实义趣故作斯论。入息出息当言依身转耶。依心转耶。答应言亦依身转亦依心转如其所应。云何名为如其所应。有作是说。于下中上如其所应。谓入出息小时下品壮时中品老时上品。如是说者。由四事故名如所应。谓入出息由四事转。一有息所依身。二风道通。三毛孔开。四入出息地粗心现前。必具此四入出息转。由此故说如所应言。为显此义复作是说若入出息但依身转不依心转。则在无想定灭尽定位入出息亦应转。彼有入出息所依身。风道亦通毛孔亦开。唯无入出息地粗心现前以无心故虽有三事而阙一事故息不转。若入出息但依心转不依身转。则无色界有情入出息亦应转。彼界四事一切皆无故息不转。若入出息但依身心转不如所应。则在卵[穀-禾+卵]及母胎中。羯刺蓝頞部昙闭尸键南诸根未满未熟。并在第四静虑入出息亦应转。问何故羯剌蓝位息不转耶。答彼稀薄故若息转者彼应流动。问何故頞部昙闭尸键南诸根未满未熟位息不转耶。答彼身尔时风道未通毛孔未开。若息转者身应散坏。然在卵[穀-禾+卵]及母胎中。从羯剌蓝乃至诸根未满未熟。尔时未有息所依身风道未通毛孔未开。唯有息地粗心现前。虽有一事而阙三事故息不转。问何故在第四静虑息不转耶。答彼心细故。谓入出息依粗心转第四静虑以上诸地心极微细故息不转。复次内门转故谓息必依外门心转。第四静虑以上诸地心内门转故息不转。复次内事转故。谓息必依外事心转。第四静虑以上诸地心内事转故息不转。复次极寂静故。谓息必依躁动心转。如人涉路躁则动尘心若躁动起入出息。第四静虑以上诸地心极寂静故息不转。尊者世友作如是说。入第四静虑便得转依。谓所依身。有第四静虑微妙大种令诸毛孔一切密合无窍隙故非息所依。由此尔时息不复转。大德说曰。入第四静虑心便不动。心不动故身亦不动。身不动故息不复转。入彼定时一切动法皆息灭故尊者妙音作如是说。入第四静虑一切粗重皆息灭故息不复转。谓欲界中有粗欲贪。初静虑地有寻有伺。第二静虑有喜。第三静虑有乐。由此发生身心粗重。由粗重故入出息转。第四静虑一切皆无故息不转。如是若在下地入第四静虑。唯有息所依身及风道通然毛孔不开亦无息地粗心现前。虽有二事而阙二事故息不转。问何故但说在第四静虑息不复转。不说生第四静虑耶。答是作论者意欲尔故。乃至广说复次亦应说生第四静虑息不复转。而不说者应知此是有余之说。复次已说入彼定当知亦说生彼。如契经说。先在此间入彼静虑后方生彼。问第四静虑亦有风界以四大种不相离故。何缘生彼无息转耶。答第四静虑虽有风界而不名为入息出息。以于彼身不入出故。有说生彼虽有风界而无前说四种事故不名为息。以入出息亦依身转亦依心转及如所应。是故下从无间地狱上至遍净。其中有情诸根满熟入息出息依身心转。此中诸根满熟言显前四事具足。不说眼等根满熟义。谓前四事能发息故说之为根。具故名满。熟谓作用即前四事具足有用。是故说为诸根满熟。有说诸根满熟言者。简处胎卵根未满熟。显风道通毛孔开义。身心二事次后自说应知此中有入息有出息。有入出息地无入出息地。入息者。谓息风入身。出息者谓息风出身。有入出息地者。谓欲界及下三静虑。无入出息地者。谓第四静虑及四无色。生有入出息地。无入出息地心现在前息便不转。生无入出息地。有入出息地心现在前息亦不转。生有入出息地及有入出息心现在前。若不如所应息亦不转。要生有入出息地及有入出息地心现在前。如其所应息方得转

问入出息。何地系随身系耶随心系耶。有作是说。随身地系。诸有欲令入出息随身地系者。彼说生欲界者若欲界心现在前。彼欲界身欲界入出息随欲界心转。即此心所观。即彼若初静虑心现在前。彼欲界身欲界入出息。随初静虑心转。即此心所观问若尔施设论说当云何通。如说欲界入出息离欲界染时最后无间道灭。答欲界入出息。有随欲界心转。有随初静虑心转。随欲界心转者尔时灭。随初静虑心转者尔时现在前。复次彼依择灭说故无相违失。即彼若第二第三静虑心现在前。彼欲界身欲界入出息。随第二第三静虑心转。即此心所观。生初静虑者。若初静虑心现在前。彼初静虑身初静虑入出息随初静虑心转。即此心所观。即彼若欲界心现在前。彼初静虑身初静虑入出息。随欲界心转。非此心所观。即彼若第二第三静虑心现在前。彼初静虑身初静虑入出息。随第二第三静虑心转即此心所观。生第二静虑者。若第二静虑心现在前。彼第二静虑身第二静虑入出息。随第二静虑心转。即此心所观。即彼若欲界初静虑心现在前。彼第二静虑身第二静虑入出息。随欲界初静虑心转非此心所观。即彼若第三静虑心现在前。彼第二静虑身第二静虑入出息。随第三静虑心转。即此心所观生第三静虑者。若第三静虑心现在前。彼第三静虑身第三静虑入出息。随第三静虑心转即此心所观。即彼若欲界初二静虑心现在前。彼第三静虑身第三静虑入出息。随欲界初二静虑心转。非此心所观。诸有欲令入出息随身地系者。彼说欲界入出息四地心所观。初静虑入出息三地心所观。第二静虑入出息二地心所观。第三静虑入出息唯第三静虑心所观。问若入出息随身地系。施设论说当云何通。如说何缘死者入出息不转耶谓入出息由心力转死者无心但有身故。答显入出息随心而转必不离心故作是说不言此息随心地系。有余师说。随心地系诸有欲令入出息随心地系者。彼说生欲界者。若欲界心现在前。彼欲界身欲界入出息随欲界心转。即此心所观。即彼若初第二第三静虑心现在前。彼欲界身初第二第三静虑入出息随初第二第三静虑心转。即此心所观生初静虑者。若初静虑心现在前。彼初静虑身初静虑入出息。随初静虑心转。即此心所观。若欲界心现在前。彼初静虑身欲界入出息随欲界心转。即此心所观。若第二第三静虑心现在前。彼初静虑身第二第三静虑入出息。随第二第三静虑心转。即此心所观。生第二静虑者。若第二静虑心现在前。彼第二静虑身第二静虑入出息。随第二静虑心转。即此心所观即彼若欲界初静虑心现在前。彼第二静虑身欲界初静虑入出息。随欲界初静虑心转。即此心所观。即彼若第三静虑心现在前。彼第二静虑身第三静虑入出息随第三静虑心转。即此心所观。生第三静虑者。若第三静虑心现在前。彼第三静虑身第三静虑入出息。随第三静虑心转。即此心所观。即彼若欲界初二静虑心现在前彼第三静虑身欲界初二静虑入出息。随欲界初二静虑心转。即此心所观。诸有欲令入出息随心地系者。彼说欲界入出息。唯欲界心所观。乃至第三静虑入出息唯第三静虑心所观。问若入出息随心地系。契经所说当云何通。如说佛告长者。此入出息是身法身为本系属身依身而转。答显入出息由身力转必不离身故作是说。不言此息随身地系。评曰。此入出息随身地系是身分故。前说为善问入出息风为先入耶。为先出耶。答应说先入。谓此息风先入口鼻。流至咽喉复从咽喉流至心胸。复从心胸流至脐轮。复从脐轮渐渐流散。遍诸支节。有说。先出。谓脐轮中有息风起流散上下。开诸毛孔方出至外。评曰。彼不应作是说。息风不能开毛孔故。应作是说。有业生风开诸毛孔。毛孔开已乃有息风于中入出。问于胎卵中至何分位入出息转。答至具色根六处满位息风方转。谓将生时息风先入。息风入已名为已生将欲死时息风后出。不复更入名为已死。由此可观生死分齐。有余师说。临欲生时息风先出。息风出已名为已生。将欲死时息风后入不复更出名为已死。如说。云何使我常活令我入息恒得出耶。诸有欲入第四静虑息风后出不复更入名已入定。将出定时息风先入息风入已名已出定。有余师说。诸有欲入第四静虑息风后入不复更出名已入定。将出定时息风先出息风出已名已出定。评曰。此中前说为善。问此入出息为是有情数为非有情数耶。答是有情数。问此入出息为有执受为无执受耶。答是无执受。身中虽有有执受风而入出息是无执受。问此入出息为是长养。为是异熟。为是等流。答唯是等流。身中虽有异熟生风及长养风。然入出息唯是等流如契经说。佛告阿难。若如射箭筈筈相续调入出息令不乱者。应知彼名殊胜饮食。问何故世尊说入出息名饮食耶。答能损益故。谓无上妙饮食益身。如有方便调入出息。亦无粗恶饮食损身。如无方便调入出息。是故世尊说为饮食。问如射箭筈筈相续者是何义耶。答如以后箭射于前箭后触前筈是此中义。有说此中但显前后无间断义。不说后箭触前箭义。又不定说如以后箭射前箭义如契经说。有持来有持去有持来持去念有修持来持去念。此中持来者。谓入息。持去者谓出息如施设论说。吸风入内名持来。引风出外名持去。如鍜金师囊。囊开合风随入出。此亦如是。有作是说。出息名持来。入息名持去有余师说。暖息名持来。冷息名持去。复有说者。上息名持来。下息名持去。评曰。此中初说为善。能缘彼念名持来持去念。即于此念及此相应俱有诸法。若修若习若多所作。名修持来持去念。问此持息念自性是何。答慧为自性。然此聚中念力增故说名为念。如四念住及宿住念本性生念慧为自性。然彼聚中念力增故说名为念。如除色想慧为自性。然彼聚中想力增故说名为想。此亦如是。若并眷属四蕴五蕴为其自性。此持息念。界者谓欲色界非无色界。地者五地谓欲界静虑中间及下三静虑近分。诸有欲令下三根本静虑地亦有舍根者。彼说此念通八地。谓前五及下三静虑。所依者。唯依欲界。非色无色界。有余师说。依欲色界非无色界。然初起时必依欲界。行相者。非圣行相。所缘者。缘息风。念住者。是身念住加行。非根本念住。若依泛尔四念住说是身念住缘色法故。问何故契经说。持息念通四念住。答此能引起四念住故作如是说。问不净观亦能引起四念住。何故不说四念住耶。答亦有经说。此不净观通四念住。如说若观青淤脓烂虫食等事名身念住。又说。若观此中有受能引净贪亦令止息名受念住。又说。若观无损害意怜愍一切遍诸方域名心念住。又说。若观贪嗔痴断离染起明得众苦尽名法念住。问虽此一经说不净观通四念住。而无量经说持息念通四念住。非不净观有何意耶。答以持息念依处串习牢固可恃。假使失念烦恼现行速可依之伏诸烦恼引四念住。如人怖贼速走归城处谓大种相决定故。若不净观非处串习性不牢固。或时失念烦恼现行不能依之速伏烦恼引四念住。言非处者。谓诸造色相不定故。由此多经说持息念通四念住非不净观。复次以持息念增益法想是空观本。由此速能引四念住。是故偏说。若不净观增有情想。如说此骨为女为男障碍空观。不能速疾引四念住是故不说。复次以持息念所缘怜近无种种相。无定次第不依有情任运而转。由此速能引四念住是故偏说。若不净观与此相违是故不说。复次以持息念唯内道起不共外道。由此速能引四念住是故偏说。若不净观外道亦起。不能速疾引四念住是故不说。此持息念。智者一世俗智。三摩地者非三摩地。俱根者一舍根。相应世者。通三世。缘世者过去缘过去。现在缘现在未来。若生法缘未来。若不生法缘三世。善不善无记者唯善。缘善不善无记者唯缘无记。系不系者欲色界系。缘系不系者缘欲色界系。学无学非学非无学者唯非学非无学。缘学无学非学非无学者唯缘非学非无学。见所断修所断不断者唯修所断。缘见所断修所断不断者唯缘修所断。缘名缘义者唯缘义。缘自相续他相续非相续者唯缘自相续。复次此持息念由六因故应知其相。一数二随三止四观五转六净。数有五种。一满数二减数三增数四乱数五净数。满数者。谓从一数至十。减数者。谓于二等数为一等。增数者谓于一等数为二等。乱数者。谓数过十。有余师说。于入谓出于出谓入名为乱数。复有说者。数无次第故名乱数。净数者。于五入息数为五入。于五出息数为五出。问为先数入息为先数出息耶。答先数入息。后数出息。以生时息入死时息出故。又如是观身心安隐非颠倒故。又如是观显于生死先入后出非颠倒故。随者系心随息从外入内。谓从口鼻流至咽喉。复从咽喉流至心胸。复从心胸流至脐轮。如是展转乃至足指心皆随逐心复随息从内出外。半麻一麻。半麦一麦。半指节一指节。半指一指。半搩手一搩手。半肘一肘。半寻一寻。乃至广说。随根势力。息去近远心皆随逐。止者。谓观息风初住口鼻。次住咽喉。次住心胸次住脐轮。展转乃至后住足指。随息所止心住观之。有说。止者。住心观息遍住身中如珠中缕。观者。谓此息风若至口鼻能审观察。若至咽喉亦审观察。如是展转乃至足指亦审观察。观息风已。复作是念。此风聚中有四大种。此四大种生诸造色。此所造色是心心所所依止处。如是行者。观息为先展转遍能观五取蕴。转者。转此入出息观起身念住。展转乃至起法念住。净者从暖乃至无学。有说。四种顺决择分亦是转摄。净谓始从苦法智忍乃至无学。有说。从四念住位乃至金刚喻定皆是转摄。有烦恼故未名为净。尽智起后方名为净。复次此中数作二事。一能数入出息。二能舍耽嗜。依寻随作二事。一能随入出息。二能舍出离。依寻止作二事。一能止住息。二能住等持。观作二事。一能观入出息。二能取心心所法相无所遗漏。转作二事。一能转息观。二能入谛观。有说。转作二事。一能舍异生性。二能得圣性。有说。转作二事。一能舍烦恼。二能净智见。净作二事。一能观圣谛。二能入圣道。有说。净作二事。一能舍烦恼。二能净智见。有说。净作二事。一能证有余依涅槃界。二能证无余依涅槃界。有余师说。净作二事。一能证现法乐住。二能证二涅槃界。问此六息念。几是奢摩他品。几是毗钵舍那品耶。有作是说。前三是奢摩他品。后三是毗钵舍那品。复有说者。前三是毗钵舍那品。后三是奢摩他品。如是说者。此不决定。或有一切皆是奢摩他品。或有一切皆是毗钵舍那品

如薄伽梵于契经中为所化生说伽他曰

  善修息念满　　渐习随佛教
  彼能明照世　　如日出重云

问此颂中。说息念满者谁名为满。谁不满耶。有作是说。佛名为满。独觉声闻俱名不满。有余师说。佛及独觉俱名为满声闻不满。或有说者。声闻乘中到彼岸者亦名为满。诸余声闻名为不满。复有说者。三乘无学皆名为满。学名不满。或复有说。圣者名满。异生不满。如是说者。诸有具上所说六因。说名为满。若不具者名为不满

如契经说佛告苾刍。吾欲两月宴坐。汝等不须参问。唯除送食布洒他时。于是世尊入室宴坐问世尊何故久宴坐耶。答去来诸佛过殑伽沙法尔皆应如是宴坐。尊者世友作如是言。欲为诸天说密法故。有说。为断慢缓苾刍放逸心故。有说为观病苾刍故。有说。欲为他界有情说妙法故。有说。为策退杜多行诸苾刍故。有说。哀愍未来所化诸有情故。谓未来世所化有情闻是事已作如是念。如来犹故多时宴坐。我辈宁得不宴坐耶。有说。为遮外道谤故。谓诸外道毁谤佛言。此乔答摩。好处阓闹爱多言论舍离闲居寂静之乐。为止此等种种谤故多时宴坐。有说。任持菩提分法功德树故。如种树已须更修治。菩提分树亦复如是虽已圆满仍须经久宴坐任持。有说。为受妙法乐故。有说。为观所证微妙诸佛法故。有说。任持难行苦行所劳身故。有说。欲现虽久证得无上菩提而深敬重犹如今时初证得故。大德说曰。由二因缘如来经于两月宴坐。一者自受大法乐故。二者哀愍诸有情故。胁尊者言。为他于法生渴仰故。如彼经说。过二月已。尔时世尊。从宴坐起出到迥处敷座而坐现如是相。令诸苾刍来诣佛所。问世尊。尔时现何等相。有作是说令地微动。有余师说。放胜光明。或有说者。出梵音声。复有说者。化作苾刍前后围绕问讯恭侍。时诸苾刍见已知佛从宴坐起深心惭愧。我等何为不早诣佛。便相告命共往佛所。到已顶礼世尊双足问讯起居退坐一面。世尊告曰。若有外道来问汝言。汝等大师二月宴坐入何等定。应答彼言入持息念。问诸外道辈尚不知有持息念名况知自性。世尊何故作是说耶。答为欲引摄诸外道等所化有情入佛法故。谓有外道及信彼法所化有情。闻佛世尊二月宴坐入持息念生希有心。来诣佛所。佛为说法彼信奉行。复次为欲守护新学苾刍令于佛法不背舍故。谓有苾刍初入佛法学持息念心不敬重欲归外道更求异法。因佛此言诸外道辈来诣佛所恭敬受法。是诸苾刍心便不退。问佛宴坐时遍入一切静虑解脱等持等至。何故但说入持息念。答虽入一切静虑解脱等持等至而持息念是彼上首是故偏说。复次静虑解脱等持等至皆是息念前后眷属是故世尊说持息念

如契经说佛告苾刍。我已念入出息了知我已念入出息。我已念短入出息了知我已念短入出息。我已念长入出息了知我已念长入出息。我已觉遍身入出息了知我已觉遍身入出息。我已止身行入出息了知我已止身行入出息。问入出息。为先短后长为先长后短耶。答先短后长。云何知然。如施设论说。菩萨初入定时其息速疾。久入定已息便安住。如人担重经崄难处其息速疾。后至平道息便安住。故入出息先短后长。问此观息风从鼻而入还从鼻出。何故乃说我觉遍身入出息耶。答息念未成观入出息从鼻入出。息念成已观身毛孔犹如藕根息风周遍于中入出。问若尔何故非出定耶。答意乐加行俱未息故。如菩萨时虽作此观而不出定。亦以意乐加行未息故无有过。尊者世友作如是说。如观一切大种造色所合成身。皆是无常苦空无我。如病如痈如箭不净以不舍离。缘息风觉不名出定此亦应尔。止身行者。谓令息风渐渐微细乃至不生。应知此中念入出息者是总。念短入出息等是别。复次念入出息者是欲界持息念。念短息者是初静虑。念长息者是第二静虑。觉遍身者是第三静虑。止身行者是第四静虑

又彼经说。我已觉喜入出息了知我已觉喜入出息。我已觉乐入出息了知我已觉乐入出息。我已觉心行入出息了知我已觉心行入出息。我已止心行入出息了知我已止心行入出息。应知此中觉喜者。观初二静虑地喜。觉乐者观第三静虑地乐。觉心行者观想及思。止心行者谓令心行渐渐微细乃至不生。又彼经说。我已觉心入出息。了知我已觉心入出息。我已令心欢喜入出息。了知我已令心欢喜入出息。我已令心摄持入出息。了知我已令心摄持入出息。我已令心解脱入出息。了知我已令心解脱入出息。应知此中觉心者。谓观识体。令心欢喜等者。佛虽不复令心欢喜摄持解脱。然菩萨时有如是事故复重观又彼经说。我已随观无常断离灭入出息。了知我已随观无常断离灭入出息。尊者世友作如是说。随观无常者谓观息风无常。随观断者观八结断。随观离者观爱结断。随观灭者观结法断。有说。随观无常者观四大种无常。随观断者观无明结断。随观离者观爱结断随观灭者观余结断。有说。随观无常者观色身无常随观断者观过去结断。随观离者观现在结断。随观灭者观未来结断。有说。随观无常者观大种造色等皆是无常。随观断者观苦受断。随观离者观乐受断。随观灭者观不苦不乐受断。大德说曰。随观无常者观五取蕴无常。随观断者观五取蕴空无我。随观离者观五取蕴苦。随观灭者观五取蕴不转寂灭。又彼经说。今我此定犹为粗浅我应更入余深细定。问此中何者是深细定。有说第四静虑。有说无色。有说灭定

又彼经说。时有三天端严殊妙过于夜分来至我所。第一天言此已命过。第二天言此当命过。第三天言此非已死亦非当死。然住胜定寂静如是。问彼是何天宁作异说。答是欲界天根品异故。谓钝根者作如是念。此大沙门无入出息身不动摇无思作业必已命过。若中根者作如是念。此大沙门犹有暖气身不烂坏。虽非已死而当命过。若利根者曾见诸佛及圣弟子入如是定。身心不动后时还出故作是言。此非已死乃至广说。又彼经说佛告苾刍。若有问言。云何圣住。云何天住。云何梵住。云何佛住。云何学住。云何无学住。应正答言。谓持息念。所以者何此持息念能令学者证所未证。能令无学者得现法乐住。此持息念不杂烦恼故名圣住。自性光净故名天住。自性寂静故名梵住诸佛多住故名佛住。学所得故名为学住。无学得故名无学住学者由此得胜现观断除烦恼故名证所未证无学者由此得不动心解脱故名得现法乐住。有说。此持息念。是圣所有能引圣性故名圣住。广说乃至。是无学所有能引无学性故名无学住。学者由此能证阿罗汉果故名证所未证。无学者由此住四种乐故名得现法乐住。四种乐者。一出家乐。二远离乐。三寂静乐。四三菩提乐。问此持息念是非学非无学。何故名为学无学住。答学无学者身中有故

说一切有部发智大毗婆沙论卷第二十六阿毗达磨大毗婆沙论卷第二十七

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中补特伽罗纳息第三之五

如有色有情心相续依身转。乃至广说问何故作此论。答为令疑者得决定故。谓或有疑欲色界有色故心相续依色转。无色界既无有色心相续应无依转欲令此疑得决定故。显无色界心等相续亦有依转故作斯论。如有色有情心相续依身转。无色有情心相续依何转耶。答依命根众同分。及余如是类心不相应行。何者是余不相应行。谓得生老住无常等。问欲色二界心相续转亦依命根众同分等。此中何故但说依身答亦应说依彼转而不说者。是有余说。有作是说。依义多故。谓欲色界心相续转依身义多。非命根等为依义多。谓眼根等无量色法与眼识等为所依故。有余师说以身粗故但说依身。命根等细难示现故。若生欲界眼识现在前此识以眼及无间灭意为依及所依。以眼根所依大种身根及身根所依大种命根众同分。得生老住无常等为依非所依。如眼识耳鼻舌识应知亦尔。若身识现在前。此识以身及无间灭意为依及所依。以身根所依大种命根众同分。得生老住无常等为依非所依。若意识现在前。此识以无间灭意为依及所依。以身根及身根所依大种命根众同分。得生老住无常等为依非所依。如生欲界。生色界亦尔。差别者。彼无鼻舌识若生无色界意识现在前。此识以无间灭意为依及所依。以命根众同分。得生老住无常等为依非所依。有作是说。若生欲界。眼识现在前。此识以眼及无间灭意为依及所依。以身根及色香味触命根众同分。得生老住无常等为依非所依。如眼识耳鼻舌识应知亦尔。若身识现在前。此识以身及无间灭意为依及所依。以色香味触命根众同分。得生老住无常等为依非所依若意识现在前。此识以无间灭意为依及所依。以身根及色香味触命根众同分。得生老住无常等为依非所依。如生欲界。生色界亦尔。差别者。彼无鼻舌识及香味。生无色界如前说。有余师说。若生欲界眼识现在前。此识以眼及无间灭意为依及所依。以俱生四蕴为依非所依。如眼识耳鼻舌身识应知亦尔。若意识现在前。此识以无间灭意为依及所依。以俱生四蕴为依非所依。如生欲界。生色界应知亦尔。差别者。彼无鼻舌识。生无色界意识现在前。此识以无间灭意为依及所依。以俱生三蕴为依非所依。问命根体为是一物为多物耶。设尔何失。若一物者何故断手等而不死。断头腰便死耶。若多物者何故手等被断离身而无有命。答应说命根体是一物。问若尔何故断手足等而不死耶。答命根有二种。一依具足身。二依不具足身。断手足等令离身时依具足身命根灭。依不具足身命根起。命所依身亦有二种。未断手等名具足身。断手等时名不具足。断手等已具足者灭。不具者生。故命与身相依而转。问何故断头及腰便死。断手足等而不死耶。答头腰二处是大死节故断便死。手等不然。复次欲界有情依段食住。喉通段食。腹为食依。故断二处命根便断。复次头是眼等多根依处断之便坏眼等诸根。腹是息风所依止处。断腰腹坏息无所依故。断二处命根便断手等不尔不可为难。有说。命根体是多物手足等中命根各别所依。能依数量等故。问若尔何故断手足等令离身时而无有命。答以手足等系属身故彼若离身命便不起。如手足等未离身时是身根依名有情数离身不尔。命根亦然。故彼离身命便不起。评曰。应说命根体是一物。有一命故名有命者。如有一心名有心者。有一心灭名无心者。一受一想一思亦然。如是有情有一命故名有命者。而此命根唯是异熟不相应行。如心受等一有情身一刹那顷有一无二

云何众同分。谓有情同分犹如命根体是一物遍与一切身分为依。是不相应行蕴所摄。唯无覆无记性唯有漏通三界。问此众同分。为长养为等流。为异熟。答是异熟及等流。非长养。非色法故。异熟者。谓趣同分等。如地狱趣有情展转相似。乃至天趣等有情亦然。等流者。谓界同分等。如欲界有情展转相似。乃至无色界等有情亦然。有说异熟者。谓初生时得。如与父母等展转相似。等流者。谓后时方得。如与沙门婆罗门等展转相似。洲渚方土及族姓等有情同分。如理应知。有余师说。有情同分通善不善无记性摄。谓四向四果有情同分是善性摄。造五无间业有情同分不善性摄。诸余同分无记性摄。评曰。彼不应作是说。法虽有三种而有情同分唯无记摄。由此应知前说为善问若得众同分彼舍众同分耶。答应作顺前句。谓若得众同分彼定舍众同分。有舍众同分而不得众同分。谓阿罗汉般涅槃时。问若死此生彼时定舍众同分得众同分耶。答应作四句。有死此生彼而不舍众同分不得众同分。如地狱死还生地狱。乃至天死还生天等。有舍众同分得众同分。而非死此生彼。谓入正性离生等位。有死此生彼亦舍众同分亦得众同分。谓地狱等死生异趣等。有不死此生彼亦不舍众同分不得众同分。谓除前相。无有爱当言见所断修所断耶。乃至广说。问何故作此论。答为欲分别契经义故。谓契经说。爱有三种。一欲爱。二有爱。三无有爱。契经虽作是说而不广分别。亦不说无有爱是见所断是修所断。契经是此论根本。彼所不说者今应说之。复次为止异执显经义故。谓或有说。契经所言无有爱者。通见修所断。如分别论者。为止彼执显经所说。无有爱者唯修所断。故作斯论。无有爱当言见所断修所断耶。答应言修所断。无有者。众同分无常。缘此爱说名无有爱。是故此爱唯修所断。以众同分修所断故。有作是说。无有爱或见所断或修所断。云何见所断。谓于见所断法无有而贪。云何修所断。谓于修所断法无有而贪。问谁作此说。答分别论者。彼说意言。三界无常说名无有。能缘彼贪名无有爱。无常既通见修所断。能缘彼爱亦通二种。于此义中无有爱但应言修所断。谓于此论随顺契经无倒义中。无有爱但应言修所断。此中有说。若随经义说无有爱唯修所断。若随实义说无有爱通二所断。所以者何。谓契经说。如有一类恐怖苦受所逼切故作如是念。若我死后断坏无有。岂不乐哉。此经中说彼众同分后时无常。名为无有。如是无有唯修所断。故无有爱非见所断。此中论主说随经义。与分别论者竞释经义。故说无有爱唯修所断。若随实义如后当说。三界无常说名无有。三界无常通二所断。故无有爱亦通二种。有作是说。此无有爱若随实义若随经义。俱应说言唯修所断。三界无常虽通二种。而起爱者唯修所断。以无有爱依厌苦生。但爱当来苦器无有。唯修所断。是众苦器。故无有爱唯修所断。断见虽缘五部无有。而无有爱不能通缘。但缘当来众同分断。是故尊者妙音说曰。起无有爱补特伽罗。唯缘执受蕴界处起。为彼逼切缘彼当来断坏起爱。无见所断逼切有情令爱彼断。故无有爱唯修所断。前来略说无有爱唯修所断

此后应理论者与分别论者相对问答难通。广显无有爱唯修所断。汝说无有爱唯修所断。诸预流者未断此爱耶者。是分别论者问。重定前宗。若不定他宗说他过失则不应理。答如是者。是应理论者答。谓顺契经无颠倒义所立决定故言如是。汝何所欲诸预流者为起如是心。若我死后断坏无有岂不安乐耶者。是分别论者将欲设难反定所宗显违正义。答不尔者。是应理论者遮彼所问显义无违。问何故预流者不起此爱耶。答见法性故。谓预流者见诸法性因果相续故不爱断。复次信业果故。谓预流者深信业果前后相续故不爱断。复次了达空故。谓预流者得空解脱门知无我我所。今有后断故不起爱贪后断灭。复次此无有爱断见所长养。要断见后方现在前。诸预流者已断断见故不起此爱。复次诸预流者得无有爱非择灭故必不复起。听我所说若无有爱唯修所断。诸预流者未断此爱。则应说预流者起如是心。若我死后断坏无有岂不安乐。若预流者不起如是心。若我死后断坏无有岂不安乐。则不应说无有爱唯修所断。诸预流者未断此爱。作如是说。俱不应理者。是分别论者前后两关翻覆设难。前关显顺宗违义后关显顺义违宗。二俱不可故总结言作如是说俱不应理。应理论者后通意言。我宗不说诸未断者皆必现前。或有未断而不现前。或有已断可现前故。若未断者皆必现前。是则应无解脱出离。以未断法无边际故。设起何时起之可尽。此后反破分别论者以通前难。因明论中说破他义有三种路。一犹预破。二说过破。三除遣破。佛契经中明破他说亦有三路。一胜彼破。二等彼破。三违宗破。胜彼破者。如长爪梵志白佛言。我一切不忍。佛告彼曰。汝亦不忍此自见耶彼便自伏。等彼破者。如波吒梨外道白佛言。乔答摩知幻不。若不知者非一切智。若知者应是幻惑。佛告彼言。俱茶邑有恶人名蓝婆铸茶破戒行恶汝知之不。彼言我知。佛告彼曰。汝亦应是破戒恶人。彼便自伏。违宗破者。如邬波离长者白佛言。身业罪大非意业。佛告彼曰。弹宅迦林羯凌伽林等谁之所作。岂非仙人恶意所作。彼答言尔。佛言。身业能作此耶。彼言不能。佛告彼曰。汝今岂不违前所言。彼便自伏。于此三中。应理论者依等彼破以通前难。此有三种如后广说。汝等亦说地狱傍生鬼异熟爱唯修所断。诸预流者未断此爱耶者。是应理论者问。审定他宗。若不定他宗说他过失则不应理。答如是者。是分别论者答。所问理定故言如是。汝何所欲诸预流者为起如是心我当作哀罗筏拏龙王善住龙王琰魔鬼王统摄鬼界诸有情耶者。是应理论者将欲设难反定所宗显违正义。答不尔者。是分别论者遮彼所问显义无违。问何故预流者不起此爱耶。答彼趣是愚圣有智故。彼趣是异生。圣非异生故。彼趣恶意乐。圣意乐善故。彼趣多有破戒恶业。圣者成就清净戒故。复次一切圣者得诸趣非择灭故不爱生彼。问圣者于恶趣皆不起爱耶。答虽无生彼爱而有资具爱如天帝释亦爱设支青衣药叉哀罗筏拏善住龙等。诸预流等闻父母等堕恶趣中亦生爱念。今遮生爱故答不尔。听我所说若地狱傍生鬼异熟爱唯修所断诸预流者未断此爱则应说预流者起如是心我当作哀罗筏拏龙王。乃至广说。若预流者不起如是心。我当作哀罗筏拏龙王。乃至广说。则不应说地狱傍生鬼异熟爱唯修所断。诸预流者未断此爱。作如是说。俱不应理者。是应理论者前后两关翻覆设难。前关显顺宗违义。后关显顺义违宗。二俱不可故总结言作如是说俱不应理。应理论者此初意言如恶趣爱圣者未断而不现前。无有爱亦应尔。故彼所难不顺正理。汝等亦说诸缠所缠故害父母命此缠唯修所断诸预流者未断此缠耶者。是应理论者问。余如前说。答如是者是分别论者答。余如前说。汝何所欲诸预流者为起如是缠故害父母命耶者。是应理论者将欲设难反定所宗显违正义。答不尔者。是分别论者遮彼所问显义无违。问何故预流者不起此缠耶。答若有上品恶意乐者能起此缠。诸预流者意乐善故。复次若有上品无惭无愧能起此缠。诸预流者有惭愧故。复次此缠邪见之所长养邪见后起。诸预流者邪见断故不起此缠。复次诸预流者已得此缠非择灭故及得此业不作戒故毕竟不起。听我所说若缠所缠故害父母命此缠唯修所断。诸预流者未断此缠则应说预流者起如是缠故害父母命。若预流者不起如是缠故害父母命则不应说诸缠所缠故害父母命此缠唯修所断。诸预流者未断此缠。作如是说俱不应理者。是应理论者前后两关翻覆设难。余如前说。应理论者此中意言。如此杀缠圣者未断而不现前。无有爱亦应尔故。彼所难不应正理。汝等亦说于修所断法无有而贪。此贪唯修所断。诸预流者未断此贪耶者。是应理论者问。余如前说。答如是者。是分别论者答。余如前说。此中修所断法者。谓有漏善法无有者。谓彼善根断。若于此起贪名无有贪。此善根断。修所断故缘此起贪亦修所断。汝何所欲诸预流者为缘此起爱耶者。是应理论者将欲设难反定所宗显违正义。答不尔者。是分别论者遮彼所问显义无违。问何故预流者不起此爱耶。答圣于善法恒乐成就不欲远离。此善根断不成善法令远离善。是故圣者不缘起爱。复次圣于善法恒乐增进。此善根断能令善法损减衰退是故圣者不缘起爱。复次此善法无有爱是邪见所长养邪见后起。诸预流者已断邪见故无此爱。复次圣者于此得非择灭故必不起。听我所说若于修所断法无有而贪。此贪唯修所断。诸预流者未断此贪则应说预流者缘此起爱。若预流者不缘此起爱。则不应说于修所断法无有而贪。此贪唯修所断。诸预流者未断此贪。作如是说俱不应理者。是应理论者前后两关翻覆设难余如前说。应理论者此后意言。如善法无有爱圣虽未断而不现前。无有爱亦应尔。故彼所难不应正理。彼既应理此亦应然者。是应理论者总举彼三结成己义。谓彼所说初中后三既应正理。我前所说理亦应然不可为难

无有名何法。答三界无常。问何故复作此论。答为令疑者得决定故。谓或有疑造此论者唯解随经义。不解随实义。欲令此疑得决定故。显此论者前来成立随契经义说无有爱唯修所断。今随实义显无有爱通二所断。三界无常通二断故。复次分别论者问应理论者言。汝从前来虽以言辩伏我而于实理犹未审定。今应定说无有是何而言此爱唯修所断。应理论者答分别论者言。我从前来虽以言辩伏汝成随经义。今随实义此无有爱通二所断。以三界无常通二所断故。有作是说。前来说爱今说无有。欲显此二俱修所断。此中所说三界无常。但说三界众同分灭不说一切。评曰。如前所说为善。三界无常言无简故。缘善法断尚有起爱缘见所断诸法无常宁不起爱。以断见者总计五部为我我所当来断灭后随起爱。虽不总缘而缘一一别别起爱。于理何咎。问诸无漏法亦有无常。何故此中唯说三界。答若无常相是爱所缘。此中说之。无漏无常非爱所缘。故此不说。复次若无常相爱所随增。此中说之。无漏无常非爱随增。是故不说。如世尊说。心解脱贪嗔痴。乃至广说。问何故作此论。答为欲分别契经义故。谓契经说心解脱贪嗔痴。契经虽作是说而不广分别。何等心解脱。为有贪嗔痴心解脱。为离贪嗔痴心解脱。契经是此论根本。彼所不分别者。今应说之。复次为止他宗显正义故。谓或有执心性本净。如分别论者。彼说心本性清净客尘烦恼所染污故相不清净。为止彼执显示心性非本清净客尘烦恼所染污故相不清净。若心本性清净客尘烦恼所染污故相不清净者。何不客尘烦恼本性染污与本性清净心相应故其相清净。若客尘烦恼本性染污虽与本性清净心相应而相不清净。亦应心本性清净不由客尘烦恼相不清净。义相似故。又此本性净心为在客尘烦恼先生。为俱时生。若在先生。应心生已住待烦恼。若尔应经二刹那住。有违宗失。若俱时生。云何可说心性本净。汝宗不说有未来心可言本净。为止如是他宗异执及显自宗无颠倒理故作斯论。如世尊说心解脱贪嗔痴。何等心得解脱。有贪嗔痴心耶。离贪嗔痴心耶。答离贪嗔痴心得解脱。问离贪嗔痴心本来解脱。何故复说得解脱耶答虽约烦恼本来解脱而依行世及在相续今得解脱。谓若身中烦恼未断心未行世不在相续。以心不能自在行世在相续故不名解脱。若自身中诸烦恼断。尔时此心自在行世在相续故。名得解脱。有作是说。贪嗔痴相应心得解脱。问谁作是说。答分别论者。彼说染污不染污心其体无异。谓若相应烦恼未断名染污心。若时相应烦恼已断名不染心。如铜器等。未除垢时名有垢器等。若除垢已名无垢器等。心亦如是。彼不应作是说。若作是说理应违拒。所以者何。非此心与贪嗔痴相合相应相杂而贪嗔痴未断心不解脱。贪嗔痴断心便解脱。此中意说心与烦恼若相应者无解脱义。同对治故。若未断时。以未断故不名解脱。若被断已俱不成就不名解脱相应诸法不可令其远离伴性尚不名断。况名解脱。故解脱心必无烦恼。本相应义。为证此义复引契经。世尊亦说苾刍当知。此日月轮五翳所翳。不明不照不广不净。何等为五。一云。二烟。三尘。四雾。五曷逻呼阿素洛手。此中云者。如盛夏时有少云起须臾增长遍覆虚空。障日月轮俱令不现。烟者如林野中焚烧草木率尔烟起遍覆虚空。障日月轮俱令不现。尘者。如亢旱时大风旋击嚣尘卒起遍覆虚空。障日月轮俱令不现雾者。如秋冬时山河雾起。又闻外国雨初晴时。日照川原地气腾涌。雰霏布散遍覆虚空。障日月轮俱令不现。曷逻呼阿素洛手者。谓阿素洛与天斗时。天用日月以为旗帜。由日月威天常胜彼。时曷逻呼阿素洛常心忿日月欲摧灭之。由诸有情业增上力。尽其智术不能摧坏。遂以手障令暂隐没。如契经说。苾刍当知。无大身形端严殊妙如曷逻呼阿素洛者。此说变化。非谓实身。如日月轮非与五翳相合相应相杂。彼翳未离此日月轮不明不照不广不净。彼翳若离此日月轮。明照广净。如是非此心与贪嗔痴相合相应相杂。而贪嗔痴未断心不解脱。贪嗔痴断心便解脱。此中意说。如日月轮非与五翳从本已来相应相杂。后时离彼明照广净。心亦如是。非从无始与贪嗔痴相应相杂。后时离彼名得解脱。是故要离贪嗔痴心后彼断时名得解脱。其理决定。何等心解脱。过去耶未来耶现在耶乃至广说。问何故作此论。答为止他宗显正义故。谓于三世不了别者。拨无过去未来诸法。为遮彼执欲显实有过去未来。或复有执。无正生时及正灭时如譬喻者。彼说时分但有二种。一者已生。二者未生。复有二种。一者已灭。二者未灭。除此更无正生正灭。为遮彼执欲显实有正生灭位。复次前说离贪嗔痴心得解脱。未说何心为在何世于何解脱。今欲说之。故作此论。何等心解脱。过去耶未来耶现在耶。答未来无学心生时解脱一切障言未来者。即遮拨无过去未来实有法执。无学心者。显无学心名得解脱。生时者。显有正生正灭时遮譬喻者执解脱一切障者显于一切障皆得解脱。谓离非想非非想处修所断下下品烦恼时。于三界五部障皆得解脱。集遍知故。尔时总得诸无为故。问尔时未来心一切得解脱。何故但说未来生时。答且举未来生时为门。类现一切皆得解脱。尔时皆于在身行世得自在故复次以生时心是解脱道。此为上首离一切障。由此未来皆得解脱。故偏说之。复次解脱有二种。一行世解脱。二相续解脱。正生时心具二解脱。故偏说之。余未来心虽有相续解脱而无行世解脱。故不说之。问尔时五蕴皆得解脱。何故但说心解脱耶。答举心为门。类显一切未来五蕴皆得解脱。复次就胜说故。谓五蕴中心最为胜。说心解脱即说一切。如说王来。即说臣妾。复次尔时虽有心所法等皆依心故但说其心。以心大故心所名为大地所有。由心所故起随转色不相应行。依心等生故偏说心不说余蕴。复次心是主故。若心清净余蕴亦然。是故偏说。复次修他心通无间道时但缘心故。此中偏说。此如初品已广说之。问学及非学非无学心亦得解脱。何故但说无学心耶。答就胜说故。谓若说胜法。无学法胜非学法等。若说胜有情。无学有情胜非学有情等。是故此中但说无学。复次以无学心解脱多故。有胜德故。无诸过故。此中说之。余心不尔。是故尊者妙音说曰。多故胜故无诸过故。唯无学心说名解脱。复次以无学心具二解脱。谓自性解脱及相续解脱。故偏说之。余心不尔。是故此中应作四句。有心自性解脱非相续解脱。谓学无漏心。有心相续解脱非自性解脱。谓无学有漏心有心自性解脱亦相续解脱。谓无学无漏心。有心非自性解脱亦非相续解脱。谓学有漏心及异生心。复次若心全分解脱。此中说之。学心唯有一分解脱。非学非无学心或全分不解脱。或一分不解脱。故不说之。复次若心唯解脱唯无缚唯有智无无智。此中说之。余心不尔。是故不说。复次若心解脱五部烦恼及五部法。此中说之。余心不尔。是故不说。复次若心解脱五部障碍及五部所缘。此中说之。余心不尔。是故不说。复次若心有正解脱无邪解脱。有正智无邪智无怨敌者。此中说之。余心不尔。复次若心不为八邪所伏。此中说之。余心不尔。学心虽复远离八邪而犹被障。故亦名伏。复次若心毕竟能断后有得一切有非择灭者。此中说之。余心不尔。复次若心解脱究竟圆满。此中说之。余心不尔。复次若心已得解脱王位以解脱绢而系顶者。此中说之。余心不尔。复次若心唯在解脱犹如摩鲁多爱相续中者。此中说之。余心不尔。复次若心究竟剪拔三界犹如须发诸烦恼者。此中说之。复次若心已断依第一有烦恼顶者。此中说之。复次若心相应有轻安乐广大微妙。此中说之。学心虽复有轻安乐。而彼犹有烦恼怨敌未永尽故。不得名为广大微妙。譬如国王怨敌未尽。或虽已尽而诸边国未来朝贡尔时未为受大快乐。学心犹未尽烦恼故。三界善根未总修故。彼轻安乐不得名为广大微妙。复次若心相应有轻安乐已舍重担不为烦恼。意言所伏名牟尼者。此中说之。复次若心舍热恼处得清凉处。舍烦恼依得善根依。舍杂染蕴得清净蕴。舍染有情聚得净有情聚。永寂意言牟尼圆满。此中说之。复次若入胜义福田数者。此中说之。学有烦恼未入胜义福田数中。如伽他说

  贪欲坏众生　　如田有秽草
  施无贪欲者　　获胜果无疑

复次若害彼命得无间罪。此中说之。复次若功德过失不相杂行者。此中说之。复次若断诸着破诸堤塘除诸障者。此中说之。复次若断四食破四魔怨离四识住究竟超度九有情居。绝诸生路尽界趣生老病死者。此中说之。复次此中不应责造论者。以造论者依经作论。经说无学心得解脱非有学等。故偏说之。问尽智时修三界善根亦解脱不。答亦得解脱。永离障故。问阿罗汉果退已还得。尔时何心名得解脱。为过去者未来者耶。答唯未来者名得解脱。非过去者。更不在身及行世故。已解脱故。今虽重得不名解脱

说一切有部发智大毗婆沙论卷第二十七阿毗达磨大毗婆沙论卷第二十八

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中补特伽罗纳息第三之六

其事如何。答如无间道金刚喻定将灭解脱道尽智将生。若无间道金刚喻定正灭。解脱道尽智正生。尔时名未来无学心生时解脱一切障。此中金刚喻定将灭者。谓生相用时。尽智将生者。谓临至生相。尔时犹名未得解脱。未定行世在相续故。金刚喻定正灭者。谓灭相用时。尽智正生者。谓生相正用。尔时乃名今得解脱。定能行世在相续故。若金刚喻定已灭尽智已生。尔时名为已得解脱。此中且举将解脱位显正解脱。问何故名为金刚喻定。答无有烦恼不断不破不穿不碎。譬如金刚无有若铁若牙若贝若珠石等不断不破不穿不碎。是故此定名金刚喻。假使具缚有情身中能起此定。尔时即能顿断三界一切烦恼。云何知然。金刚喻定现在前时。顿证三界见修所断烦恼断故。问此无间道四蕴五蕴为自性何故但说定耶。答定偏增故。如见道五蕴为自性。见偏增故但名见道。如现观边世俗智四蕴五蕴为自性。智偏增故但说名智。如四通行四蕴五蕴为自性。通慧偏增故但名通行。如是此道虽四蕴五蕴为自性而定偏增。是故但名金刚喻定。问何故此道定偏增耶。答非想非非想处下下烦恼难断难破极难越度。须坚固定为所依止。发大精进乃能除遣。譬如有人欲杀香象。先安其足后发武勇成其杀事。是故此道定用偏增。复次非想非非想处下下烦恼最极微细不明不显难可觉知。须依胜定令心澄细方能除断。如善射者欲射毛端。依巧便法令心澄细发箭方中。是故此道定用偏增

问此金刚喻定有几智耶。答有六智。谓四类智及灭道法智。此中或有以苦类智思惟非想非非想处诸行。作非常苦空非我行相。得阿罗汉果。或有以集类智思惟非想非非想处诸行因作因集生缘行相。得阿罗汉果。或有以灭法智思惟欲界诸行灭作灭静妙离行相。得阿罗汉果。或有以道法智思惟欲界诸行道。作道如行出行相。得阿罗汉果。或有以灭类智。或思惟初静虑诸行灭。乃至或思惟非想非非想处诸行灭。作灭静妙离行相。得阿罗汉果。或有以道类智。思惟九地类智品道。作道如行出行相。得阿罗汉果。如是皆名金刚喻定。是谓此处略毗婆沙

问此金刚喻定依何地有几耶。有作是说。依未至定有五十二。谓依未至定。或有以苦类智。思惟非想非非想处诸行。作四行相中随一行相。得阿罗汉果。或有以集类智。思惟非想非非想处诸行因。作四行相中随一行相。得阿罗汉果。或有以灭法智。思惟欲界诸行灭。作四行相中随一行相。得阿罗汉果。或有以道法智。思惟欲界诸行道。作四行相中随一行相得。阿罗汉果。如是四智有十六行相或有以灭类智。或思惟初静虑诸行灭。作四行相中随一行相。得阿罗汉果乃至或思惟非想非非想处诸行灭。作四行相中随一行相。得阿罗汉果。如是八智有三十二行相。足前十六成四十八。或有以道类智。思惟九地类智品道。作四行相中随一行相。得阿罗汉果。如是一智有四行相。足前四十八成五十二金刚喻定。如依未至定乃至依第四静虑亦尔。依空无边处有二十八。谓依空无边处。或有以苦类智。思惟非想非非想处诸行。作四行相中随一行相。得阿罗汉果。或有以集类智。思惟非想非非想处诸行因。作四行相中随一行相。得阿罗汉果。如是二智有八行相。或有以灭类智。或思惟空无边处诸行灭。作四行相中随一行相。得阿罗汉果。乃至或思惟非想非非想处诸行灭。作四行相中随一行相。得阿罗汉果。如是四智有十六行相。足前八成二十四。或有以道类智。思惟九地类智品道。作四行相中随一行相。得阿罗汉果。如是一智有四行相。足前二十四成二十八金刚喻定。依识无边处有二十四金刚喻定。谓除思惟空无边处诸行灭四行相。余如依空无边处说。依无所有处有二十金刚喻定。谓除思惟识无边处诸行灭四行相。余如依识无边处说

有余师说。依未至定有八十金刚喻定。谓依未至定。或有以苦类智。思惟非想非非想处诸行。作四行相中随一行相。得阿罗汉果。或有以集类智。思惟非想非非想处诸行因。作四行相中随一行相。得阿罗汉果。或有以灭法智。思惟欲界诸行灭作四行相中随一行相。得阿罗汉果。或有以道法智思惟欲界诸行道。作四行相中随一行相。得阿罗汉果。如是四智有十六行相。或有以灭类智。或思惟初静虑诸行灭。作四行相中随一行相。得阿罗汉果。乃至或思惟非想非非想处诸行灭。作四行相中随一行相。得阿罗汉果。如是八智有三十二行相。足前十六成四十八。或有以道类智。或思惟初静虑诸行道。作四行相中随一行相。得阿罗汉果。乃至或思惟非想非非想处诸行道。作四行相中随一行相。得阿罗汉果。如是八智有三十二行相。足前四十八成八十金刚喻定。如依未至定。乃至依第四静虑亦尔。依空无边处有四十金刚喻定。谓依空无边处。或有以苦类智。思惟非想非非想处诸行。作四行相中随一行相。得阿罗汉果。或有以集类智。思惟非想非非想处诸行因。作四行相中随一行相。得阿罗汉果。如是二智有八行相。或有以灭类智。或思惟空无边处诸行灭。作四行相中随一行相得阿罗汉果。乃至或思惟非想非非想处诸行灭。作四行相中随一行相。得阿罗汉果。如是四智有十六行相。足前八成二十四。或有以道类智。或思惟空无边处诸行道。作四行相中随一行相。得阿罗汉果。乃至或思惟非想非非想处诸行道。作四行相中随一行相。得阿罗汉果。如是四智有十六行相。足前二十四成四十金刚喻定。依识无边处有三十二金刚喻定。谓除思惟空无边处诸行灭道八行相。余如依空无边处说。依无所有处有二十四金刚喻定。谓除思惟识无边处诸行灭道八行相。余如依识无边处说

尊者妙音作如是说。依未至定有十三金刚喻定。谓见道中有四类智忍。修道中离非想非非想处修所断染有九无间道。是谓十三金刚喻定。如依未至定。乃至依第四静虑亦尔。依空无边处乃至无所有处。皆但有九金刚喻定。谓除四类智忍。余如依未至定说

如是说者。依未至定有百六十四金刚喻定。谓依未至定。或有以苦类智。思惟非想非非想处诸行。作四行相中随一行相。得阿罗汉果。或有以集类智。思惟非想非非想处诸行因。作四行相中随一行相。得阿罗汉果。或有以灭法智。思惟欲界诸行灭。作四行相中随一行相。得阿罗汉果。或有以道法智。思惟欲界诸行道。作四行相中随一行相。得阿罗汉果。如是四智有十六行相。或有以灭类智。或思惟初静虑诸行灭。作四行相中随一行相。得阿罗汉果。乃至或思惟非想非非想处诸行灭。作四行相中随一行相。得阿罗汉果。如是四八成三十二。足前十六成四十八。如是或思惟初二静虑诸行灭。或思惟第二第三静虑诸行灭。或思惟第三第四静虑诸行灭。或思惟第四静虑空无边处诸行灭。或思惟空识无边处诸行灭。或思惟识无边处无所有处诸行灭。或思惟无所有处非想非非想处诸行灭。各作四行相中随一行相。得阿罗汉果。如是四七成二十八。足前四十八成七十六。如是或思惟初三静虑诸行灭。或思惟第二第三第四静虑诸行灭。或思惟第三第四静虑空无边处诸行灭。或思惟第四静虑空识无边处诸行灭。或思惟空识无边处无所有处诸行灭。或思惟识无边处无所有处非想非非想处诸行灭。各作四行相中随一行相。得阿罗汉果。如是四六成二十四。足前七十六成百。如是或思惟四静虑诸行灭。或思惟第二静虑乃至空无边处诸行灭。或思惟第三静虑乃至识无边处诸行灭。或思惟第四静虑乃至无所有处诸行灭。或思惟空无边处。乃至非想非非想处诸行灭。各作四行相中随一行相。得阿罗汉果。如是四五成二十。足前百成百二十。如是或思惟四静虑空无边处诸行灭。或思惟第二静虑乃至识无边处诸行灭。或思惟第三静虑乃至无所有处诸行灭。或思惟第四静虑乃至非想非非想处诸行灭。各作四行中随一行相得阿罗汉果。如是四四成十六。足前百二十成百三十六。如是或思惟初静虑。乃至识无边处诸行灭。或思惟第二静虑乃至无所有处诸行灭。或思惟第三静虑。乃至非想非非想处诸行灭。各作四行相中随一行相得阿罗汉果。如是三四成十二。足前百三十六成百四十八如是或思惟初静虑乃至无所有处诸行灭。或思惟第二静虑。乃至非想非非想处诸行灭。各作四行相中随一行相得阿罗汉果。如是二四成八。足前百四十八成百五十六。如是或思惟初静虑乃至非想非非想处诸行灭。作四行相中随一行相。得阿罗汉果。此四足前百五十六成百六十。或有以道类智思惟九地类智品道。作四行相中随一行相得阿罗汉果。此四足前百六十成百六十四金刚喻定。如依未至定。乃至依第四静虑亦尔。依空无边处有五十二金刚喻定。谓依空无边处。或有以苦类智思惟非想非非想处诸行。作四行相中随一行相得阿罗汉果。或有以集类智思惟非想非非想处诸行因。作四行相中随一行相得阿罗汉果。如是二智有八行相。或有以灭类智或思惟空无边处诸行灭。作四行相中随一行相得阿罗汉果。乃至或思惟非想非非想处诸行灭。作四行相中随一行相得阿罗汉果。如是四四成十六。足前八成二十四。如是或思惟空识无边处诸行灭。或思惟识无边处无所有处诸行灭或思惟无所有处非想非非想处诸行灭。各作四行相中随一行相得阿罗汉果。如是三四成十二。足前二十四成三十六。如是或思惟空识无边处无所有处诸行灭。或思惟识无边处无所有处非想非非想处诸行灭。各作四行相中随一行相得阿罗汉果如是二四成八。足前三十六成四十四。如是或思惟空无边处。乃至非想非非想处诸行灭。作四行相中随一行相得阿罗汉果。此四足前四十四成四十八。或有以道类智思惟九地类智品道。作四行相中随一行相得阿罗汉果。此四足前四十八成五十二金刚喻定。依识无边处有三十六金刚喻定。谓依识无边处。或有以苦类智思惟非想非非想处诸行。作四行相中随一行相得阿罗汉果。或有以集类智思惟非想非非想处诸行因。作四行相中随一行相得阿罗汉果。如是二智有八行相。或有以灭类智或思惟空无边处诸行灭。作四行相中随一行相得阿罗汉果。乃至或思惟非想非非想处诸行灭。作四行相中随一行相。得阿罗汉果。如是三四成十二。足前八成二十。如是或思惟识无边处无所有处诸行灭。或思惟无所有处非想非非想处诸行灭。各作四行相中随一行相得阿罗汉果。如是二四成八。足前二十成二十八。如是或思惟识无边处。乃至非想非非想处诸行灭。作四行相中随一行相得阿罗汉果。此四足前二十八成三十二。或有以道类智思惟九地类智品道。作四行相中随一行相得阿罗汉果。此四足前三十二成三十六金刚喻定。依无所有处有二十四金刚喻定。谓依无所有处。或有以苦类智思惟非想非非想处诸行。作四行相中随一行相得阿罗汉果。或有以集类智。思惟非想非非想处诸行因。作四行相中随一行相得阿罗汉果。如是二智有八行相。或有以灭类智或思惟无所有处诸行灭作四行相中随一行相得阿罗汉果。或思惟非想非非想处诸行灭。作四行相中随一行相得阿罗汉果。或思惟无所有处非想非非想处诸行灭。作四行相中随一行相得阿罗汉果。如是三四成十二。足前八成二十。或有以道类智思惟九地类智品道。作四行相中随一行相得阿罗汉果。此四足前二十成二十四金刚喻定。此中依无色定。不起法智。亦不缘下地苦集及灭。以无色定唯缘自地及上地故。前来所说生欲界者金刚喻定。生上二界。如应当知所起多少。谓生上二界必不起法智。以彼厌下苦集谛故不欲重观。既不观下苦集。亦不观下灭道。以灭道智用苦集智为上首故。若生上地不依下地离余烦恼上地自有胜下定故。除生非想非非想处。彼无自地无漏定故。必须依下无所有处起无漏定离余烦恼。若生上静虑地。必不缘下静虑地苦集及灭。以厌彼苦集故。如法智说。未解脱心。当言解脱。已解脱心。当言解脱耶。答已解脱心。当言解脱。问何故作此论。答前虽说心解脱贪嗔痴。又说未来无学心生时解脱一切障。而未说未解脱心当言解脱已解脱心当言解脱。今欲说之故作此论。问云何此心名已解脱。答本性解脱贪嗔痴故。问若已解脱贪嗔痴者。何故复言今得解脱。答依烦恼故名已解脱。若依行世在相续故名今解脱。今此位中始能行世在相续故。于如是义未通达者作是难言。若已解脱不应言解脱。若解脱不应言已解脱。已解脱心而言解脱不应正理。虽依前义此难已遣。而今更引余事释之。如契经说。大王今者从何所来彼虽已来而说今来。此亦应尔。不应为难。此中论主为显此义。复引余经反诘难者。今应问彼。如世尊说

  若断爱无余　　如莲花处水
  苾刍舍此彼　　如蛇脱故皮

汝许此说是善说耶。彼答如是。汝何所欲为已舍言舍未舍言舍耶。彼答已舍言舍。听我所说。若已舍不应言舍。若舍不应言已舍。已舍而言舍。不应正理。此中论主反诘难者令彼自解。是等彼释如彼所解而释通故。然此颂中前二句显已舍义。已断烦恼处在世间。心无所著如莲花故。后二句显今舍义。不住此彼六根六尘。如蛇脱皮无顾恋故。彼于昔事而说今声。然无有失。此亦应尔。虽已解脱言今解脱而无有过。为证此义复引余经反诘难者。又世尊说

  断慢自善定　　善心一切脱
  一静居不逸　　越死到彼岸

汝许此说是善说耶。彼答如是。汝何所欲为已到言到未到言到耶。彼答已到言到。听我所说。若已到不应言到。若到不应言已到。已到而言到。不应正理。此释难意如前应知。谓此颂中前二句显已到义。后二句显今到义。彼于昔事而说今声。然无有失。此亦应尔。故总结言。彼既应理。此亦应然。即显此中是等彼释。劝彼难者于诸契经应善分别了不了义。复作是言。故于契经应分别义。如世尊说

  兽归林薮　　鸟归虚空
  圣归涅槃　　法归分别

如是四种至所归处方得安乐。是故智者应于契经善分别义。不应如说而便作解。若如说而解者。则令圣教前后相违。亦令自心起颠倒执。如世尊说。苾刍当知。依厌离染。依离染解脱。依解脱涅槃。乃至广说。问何故作此论。答为广分别契经义故。谓契经说。依厌离染。乃至广说。虽作是说而不广辨。云何依厌离染。乃至云何依解脱涅槃。契经是此论所依根本。彼所不说者今应分别。故作斯论如世尊说。苾刍当知。依厌离染。依离染解脱。依解脱涅槃。问一心聚中即具有厌离染解脱。何故但说依厌离染依离染解脱。不说依解脱离染依离染厌耶答生随顺胜故。谓此三法虽复俱生。而厌于离染生随顺胜。离染于厌生随顺劣离染于解脱生随顺胜。解脱于离染生随顺劣。如触与受虽复俱生。而说触缘受。不说受缘触。此亦如是。此中依有二种。一能生。二能得能生者。谓依厌离染。依离染解脱能得者。谓依解脱涅槃。故于此中作顺后句。问若是依者亦是缘耶。答若是缘者彼亦是依。或有是依而非是缘。谓依解脱而得涅槃。复次依有二种。一者相顺。二者相似。相顺者。谓依厌离染。依离染解脱。相似者。谓依解脱涅槃。云何厌。答若于诸行无学厌恶违逆是谓厌。问厌亦通学及非学非无学。此中何故唯说无学耶。答亦应说学及非学非无学。而不说者当知此义有余。复次此中就胜说故。谓若说胜法。则无学法胜。若说胜有情。则无学有情胜故说无学。复次若说究竟应知亦说初中。故不说二。复次无学法是诸善根本。是故偏说谓诸善法皆依无学得生长故。复次若有厌无欣。有离染无染著有解脱无系缚。有智慧无无知者。此中说之。复次若有厌不复厌。有离染不复离染。有解脱不复解脱者。此中说之。复次若于厌等修圆满者。此中说之。尊者妙音作如是说。以无学法多胜无过。是故偏说。大德说曰。若界趣生及老病死一切尽者。此中说之。学等不尔。是故不说。问厌以何为自性。为是慧为是无贪耶。设尔何失。若是慧者。次后所说当云何通。如说

云何依厌离染。答若厌相应无贪无等贪。无嗔无等嗔。无痴无等痴善根。是谓依厌离染。此中无贪无嗔可尔。无痴云何。无痴即慧。岂慧与慧有相应义。而说厌相应无痴善根耶。若是无贪。次后所说当云何通。如说。云何依厌离染。答若厌相应无贪无等贪。乃至广说。此中无嗔无痴可尔。无贪云何。若厌是无贪。云何说无贪与厌相应。自性与自性无相应义故。见蕴所说复云何通。如说。有事能厌非能离。谓苦集忍智不断诸烦恼。有事能厌亦能离。谓苦集忍智断诸烦恼忍智。是慧非无贪性。云何说厌无贪为体。有作是说。厌以慧为自性问若尔。次后所说当云何通。如说。云何依厌离染。答若厌相应无贪无等贪。乃至广说。答此文但应说无贪无嗔。不应说无痴。诵者言便乘作此说。有余师说。厌以无贪为自性。问若尔。次后所说当云何通。如说。云何依厌离染。乃至广说。答此文但应说无嗔无痴不应说无贪。而说无贪者显示依处。谓或有依无贪故心解脱贪。或有依无嗔故心解脱嗔。或有依无痴故心解脱痴。或有依无贪故心解脱二。乃至或有依无痴故心解脱二。或有依无贪故心解脱三。乃至或有依无痴故心解脱三。此中显示依无贪故心解脱三。故说若厌相应无贪无等贪。乃至广说。非谓别有无贪善根与厌相应。问见蕴所说复云何通。答厌非忍智与忍智相应故立忍智名。彼依相杂说能厌性。评曰。有别法名厌非慧非无贪。是心所法与心相应此说在后。复有所余如是类诸心所法与心相应。然见蕴说苦集忍智名能厌者。由彼忍智与厌相应。说名能厌。非厌自性。此中所说是无漏厌。有漏厌者。谓不净观。持息念。念住三义。观七处善。燸顶忍世第一法相应。随其所应。及现观边世俗智相应。随其所应并余有漏静虑。无色无量解脱胜处遍处。如病如痈如箭等。随其所应无量行相相应。此中随粗显示少分。若广显示过四大海。问若事能厌彼事所厌耶。答应作四句。有事能厌非所厌。谓无漏厌。有事所厌非能厌。谓除有漏厌诸余有漏法。有事能厌亦所厌。谓有漏厌。有事非能厌亦非所厌。谓除无漏厌诸余无漏法。缘一切法非我行相。虽亦缘所厌事。而是欣行相。不与厌相应。如前已说。云何依厌离染。答若厌相应无贪无等贪无嗔无等嗔无痴无等痴善根。是谓依厌离染。此中等言显示上品势力周遍故说为等

复次若随所应缘境遍者说名为等。复次贪嗔痴者。缘有情数等。贪等者缘非有情数。是共法故说名为等。有作是说。此中但应说无贪善根。以此善根近治贪染故名离染。无嗔无痴是能诵者乘便而诵。有余师说无嗔无痴虽非正离染。而是助离染。故亦说之。或有说者。染言通说一切烦恼故。离染言通摄一切有为善法。今随强故但说无贪无等贪等。云何依离染解脱。答若离染相应心。已胜解今胜解当胜解。是谓依离染解脱。此中解脱。是大地所有心所法中胜解为自性。然一切法中有二解脱。一者无为。谓择灭。二者有为。谓胜解。此复二种。一者染污。谓邪胜解。二者不染污。谓正胜解。此复二种。一者有漏。谓不净观持息念等相应。二者无漏。谓苦法智忍等相应。此复二种。一者有学。谓四向三果七补特伽罗相续中起。二者无学谓阿罗汉果相续中起。此复二种。一者时心解脱。谓前五种性相续中起。二者不时心解脱。谓不动种性相续中起。无学解脱复有二种。一者心解脱。谓离贪故。二者慧解脱。谓离无明故。问若此解脱胜解为体。施设论说当云何通。如说。云何离贪故心解脱。谓无贪善根对治贪欲。云何离无明故慧解脱。谓无痴善根对治愚痴。胜解非三善根所摄。云何可说心慧解脱是二善根。答彼文应说云何离贪故心解脱。谓无贪善根相应解脱。云何离无明故慧解脱。谓无痴善根相应解脱。而不说者。应知彼文是有余说。复次心慧解脱实非善根。而善根相应故以善根名说。复次此中显示解脱依处。谓心解脱依无贪善根而得生长。以无贪善根对治贪欲心解脱故。慧解脱依无痴善根而得生长。以无痴善根对治愚痴慧解脱故。此于所依说能依体故不相违。云何依解脱涅槃。答若贪永断嗔永断痴永断。一切烦恼永断。是谓依解脱涅槃。问有身见等随一法断皆是涅槃。此中何故说贪永断乃至一切烦恼永断。答虽一一法断皆是涅槃。而此中但说圆满涅槃。故不应责。复次涅槃之名。唯在无学。学位未满。不名涅槃。故作是说。问以何义故名曰涅槃。答烦恼灭故名为涅槃。复次三火息故名为涅槃。复次三相寂故名为涅槃。复次离臭秽故名为涅槃。复次离诸趣故名为涅槃。复次槃名稠林。涅名为出。出蕴稠林故名涅槃。复次槃名为织。涅名为不。以不织故名为涅槃。如有缕者便有所织。无则不然。如是若有业烦恼者便织生死。无学无有业烦恼故不织生死。故名涅槃。复次槃名后有。涅名为无。无后有故名为涅槃。复次槃名系缚。涅名为离。离系缚故名为涅槃。复次槃名一切生死苦难。涅名超度。超度一切生死苦难故名涅槃。问厌与离染解脱涅槃有何差别。答厌恶违逆名厌。无所希求名离染。心无垢秽名解脱。永舍重担名涅槃。复次毁呰烦恼名厌。毁呰恶行名离染。于缘离系名解脱。诸蕴永寂名涅槃。复次诃毁欲界名厌。离色界名离染。脱无色界名解脱。证永寂静名涅槃。复次厌见所断名厌。离修所断名离染。至无学果名解脱。证永寂灭名涅槃。尊者妙音作如是说。厌谓薄地。离染谓离欲地。解脱谓无学地。涅槃谓诸地果。尊者迦多衍尼子随顺经义作是言。根律仪戒律仪无悔欢喜安乐等持是修行地。如实智见是见地。厌是薄地离染是离欲地。解脱是无学地。涅槃是诸地果。是厌离染解脱涅槃四种差别

说一切有部发智大毗婆沙论卷第二十八阿毗达磨大毗婆沙论卷第二十九

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中补特伽罗纳息第三之七

如世尊说。有三界。谓断界离界。灭界乃至广说。问何故作此论答为广分别契经义故。谓契经说。具寿阿难往诣尊者名上座所。问何故阿难往诣彼所。答尊者阿难。是乐法者。是正法将摄受圣教。御圣教船。恒巡四众。教授教诫。数数观察诸苾刍等。勿有懈怠耽着戏论。或于境界颠倒思惟。令彼一生空过颠坠。故往彼所。复次阿难作如是念。彼名上座恒乐寂静居阿练若。勇猛精勤证何妙德。我应往问。若能为我说所证德。我当合掌随喜赞叹。若不尔者。方便殷勤示其加行。令速证得。勿彼多时居阿练若空无所获。故往彼所。如彼经说。具寿阿难到已施设同分言论。非不同分。问何等名为同分言论。答若居阿练若者。问以阿练若法。若持毗奈耶者。问毗奈耶。若诵素怛缆者。问素怛缆若学阿毗达磨者。问阿毗达磨。是名同分言论。与此相违名不同分言论。谓居阿练若者。问以三藏。持毗奈耶者。问阿练若及余二藏。诵素怛缆者。问阿练若及余二藏。学阿毗达磨者。问阿练若及余二藏。或更问余事。皆名不同分言论。尊者阿难所以唯作同分言论。若作不同分言论者。彼不解故。便不能答。既不能答。心便羞耻。以羞耻故斗诤违拒。不欲令彼起如是过。是故唯作同分言论。谓但问彼阿练若法。如彼经说。尔时阿难问名上座。若有苾刍。居阿练若。或居树下。或居静室。或在冢间。应数思惟何等行法。时名上座白阿难言。若有苾刍。居阿练若。或居树下。或居静室。或在冢间。应数思惟二种行法。谓奢摩他毗钵舍那所以者何。若奢摩他熏修心者。依毗钵舍那而得解脱。若毗钵舍那熏修心者。依奢摩他而得解脱。若奢摩他毗钵舍那熏修心者依三种界而得解脱。云何三界。所谓断界离界灭界。问依对法义于一心中有奢摩他毗钵舍那云何建立如是二种行者差别。答由加行故二种差别。谓加行时或多修习奢摩他资粮。或多修习毗钵舍那资粮多修习奢摩他资粮者。谓加行时恒乐独处闲居寂静怖畏愦闹见谊杂过恒居静室入圣道时。名奢摩他行者。多修习毗钵舍那资粮者谓加行时恒乐读诵思惟三藏。于一切法自相共相数数观察入圣道时。名毗钵舍那行者。复次或有系心一缘不分别法相。或有分别法相不系心一缘。若系心一缘不分别法相者入圣道时。名奢摩他行者。若分别法相不系心一缘者入圣道时。名毗钵舍那行者。复次若利根者。名毗钵舍那行者若钝根者。名奢摩他行者。如利根钝根如是。因力缘力。内分力外分力。内正思惟力外闻他音力。应知亦尔。问断离灭界体是无为无因无果。云何乃说若奢摩他毗钵舍那熏修心者依三种界而得解脱。答彼契经于缘涅槃胜解以界声说。谓修行者虽加行时精进勇猛修习止观二种资粮。若于涅槃不起胜解决定趣证。毕竟不能断诸烦恼心得解脱。故缘涅槃胜解名界。依此界故心得解脱。如彼经说。尔时阿难问名上座。何等断故名为断界。何等离故名为离界。何等灭故名为灭界。名上座言。一切行断故名断界。一切行离故名离界。一切行灭故名灭界。尊者阿难闻已合掌随喜赞叹辞退。复诣竹林道场以此事问五百苾刍。彼复皆如名上座答。问彼诸苾刍云何而答。有作是说。从少至老次第而答。如法集时少者先问。有余师说。从老至少次第而答。如行施物自老至少。复有说者。一苾刍答余皆随喜。胁尊者言。先作白已后次行筹。受筹名答。如彼经说。尔时阿难闻已合掌随喜赞叹。辞诣佛所到已顶礼世尊双足。却住一面。以此句义问佛世尊。佛还如彼上座等答。问尊者阿难忍可上座五百苾刍所说义不。设尔何失。若忍可者。何故复以问佛世尊。若不忍可何故合掌随喜赞叹。答阿难忍可彼所说义。问何故复以问佛世尊。答如佛世尊知而故问。尊者阿难亦复如是。所以者何。阿难欲显善说法中同见同欲文义决定。如大师说。徒众亦然。如亲教说。弟子亦然。如轨范说。受学亦然。如是文义微妙决定。依之修学乃至能证阿罗汉果。非如外道所说文义师徒众等展转相违。依之修学空无所证。复次阿难欲以佛妙言印印所说义。故重问佛。若不以佛妙言印之则所说义犹可倾动。当来四众不敬信故。如世文符。若无王印则所行处人不敬受。此亦如是。故重问佛。如彼经说佛问阿难汝知上座五百苾刍有何功德。阿难白佛。彼名上座五百苾刍皆阿罗汉诸漏已尽已舍重担尽诸有结。逮得己利善办圣旨心善解脱。佛告阿难。如汝所说。问何故世尊问彼功德。答为欲开发少欲喜足所覆真实功德宝藏。令诸世间知已敬养得胜果故。如世伏藏虽多珍宝沙土覆之不得显现。若有开发令无量人采取受用得世富乐。此亦如是。故佛问之。复次开觉施主胜思愿故。谓有施主。恒以衣服等四种供具。施彼上座及五百苾刍。而不知彼有胜功德。欲令知已欢喜踊跃起胜思愿。我等得遇如是福田已种善种。定于来世受大快乐。是故世尊问彼功德。复次为止世间诽谤事故。谓彼上座在母胎中经六十年。既出胎已形容衰老无有威德。故初生已立上座名。后虽出家而被嗤笑。少年强盛昼夜精勤尚难得果况此衰老气力羸劣能得果耶。又彼上座所度五百新学苾刍先随天授。众人毁曰。如是老叟贪著名利度五百人。为充自身驱役供侍。不能教诫令从邪法。五百苾刍先受邪化后虽归正得无学果。而有谤言。此愚人辈先贪利养舍佛从邪。虽后还来而无所得。为止如是诸诽谤故问彼功德。令世共知舍诽谤罪勤修敬养。于当来世生天解脱。彼经虽说断等三界。而不广辩三界差别。彼是此论所依根本。彼不说者今欲说之。故作斯论

云何断界。答除爱结余结断名断界。云何离界答爱结断名离界。云何灭界。答诸余顺结法断名灭界。此中先约阿毗达磨。依世俗理说三界别。近对治道有差别故。余结断者。余八结断。顺结法者。谓除九结余有漏法。是名一种三界差别。复有说者。若八结及此相应并生等断名断界。若爱结及此相应并生等断名离界。若诸余顺结法及此相应并生等断名灭界。即有漏善及诸有为无覆无记名顺结法。复有说者。若无明结断名断界。若爱结断名离界。若诸余结断名灭界。复有说者。或有诸法能缚非能染。彼断名断界。或有诸法能缚亦能染。彼断名离界。或有诸法非能缚非能染。而是所缚是所染。彼断名灭界。复有说者。或有诸法是能系非能染。彼断名断界。或有诸法是能系是能染。彼断名离界。或有诸法非能系非能染。而是所系所染。彼断名灭界。有余师说。唯诸随眠有自性断。问契经所说当云何通。如说。一切行断故名断界。一切行离故名离界。一切行灭故名灭界。品类足说复云何通。如说。云何所断法。答一切有漏法。云何遍知法。答一切有漏法。彼作是答。若诸随眠缘八结起。彼断名断界。若诸随眠缘爱结起。彼断名离界。若诸随眠缘余法起。彼断名灭界。评曰。彼不应作是说。诸有漏法先被系缚离系缚时皆得断故。有作是说。唯爱随眠有自性断。问若尔。前说契经及论当云何通彼作是答。若爱随眠缘八结起。彼断名断界。若爱随眠缘爱结起。彼断名离界。若爱随眠缘余法起。彼断名灭界。评曰。彼不应作是说。诸有漏法先被系缚。离系缚时皆得断故。尊者妙音作如是说。烦恼体断名断界。于境离系名离界。弃诸重担名灭界。胁尊者言。无系缚系缚息名断界。无染污染污息名离界。无彼果彼果息名灭界。尊者设摩达多说曰。诸烦恼断名断界。无贪治贪名离界。果相续灭名灭界。尊者左取作是说言。相续断故名断界。于缘离系名离界。离执受故名灭界。复有说者。过去烦恼断故名断界。现在烦恼断故名离界。未来烦恼断故名灭界。如烦恼断蕴断亦尔。复有说者。苦受断故名断界。乐受断故名离界。不苦不乐受断故名灭界。如三受断顺三受法断亦尔。复有说者。若苦苦断名断界。若坏苦断名离界。若行苦断名灭界。复有说者。若欲界断名断界。若色界断名离界。若无色界断名灭界。如是等说皆依世俗随就一门辩三界别皆非胜义。诸断界是离界耶。答如是。设离界是断界耶。答如是。诸断界是灭界耶。答如是。设灭界是断界耶。答如是。诸离界是灭界耶。答如是。设灭界是离界耶。答如是。问何故复作此论。答前约阿毗达磨依世俗理。就近对治辩三界别。今随契经显此三界体无差别。谓有漏法一一断时。皆得一断。此一一断约差别义说为三界。故此三界义虽有别而体无异

如世尊说。有三想。谓断想离想灭想。乃至广说。问何故作此论。答为广分别契经义故。谓契经说有三种想。谓断离灭。契经虽作是说。而不广分别。彼是此论根本。彼所不说者今欲说之。故作此论。云何断想。答除爱结余结断诸想解名断想。云何离想。答爱结断诸想解名离想。云何灭想。答诸余顺结法断诸想解名灭想。此中广释如界应知。问何故此中不说三想如前三界展转相即。答应说而不说者。当知此义有余。复次此中欲显异相异文故作是说。若作异相异文说者易受持故。复次此中欲现二门二略二阶二蹬二光二炬二明二照二文相影。如界相即。想亦应然。如想不相即界亦应然。而为相影故作是说。问十六行相外有无漏慧不。设尔何失。若有者。识身论及智蕴中何故不说。若无者。此文所说当云何通。如说云何断想。答除爱结余结断。诸想解名断想。乃至广说。此断等想与何行相圣慧相应。品类足论复云何通。如说。云何尽智。谓如实知我已知苦已断集已证灭已修道。云何无生智。谓如实知我已知苦不复知。乃至我已修道不复修。如是二智何行相摄。集异门论复云何通。如说。如实了知我已尽欲漏有漏无明漏是尽智。不复当尽是无生智。如是二智何行相摄。此论见蕴复云何通。如说。受乐受时如实知受乐受。是何行相。契经所说复云何通。如说。如实了知我生已尽梵行已立所作已办不受后有。是何行相。有作是说。十六行相外无别无漏慧。故识身论此论智蕴俱不说有。问此中所说当云何通。如说。云何断想。广说乃至此断等想与何行相圣慧相应。答此约所缘建立三想不依行相。由此三想皆作缘灭四行相故。谓缘断故名为断想。不于此断作断行相。余二亦尔。若作是说。则此三想如前三界展转相即。问品类足论复云何通。如说。云何尽智。广说乃至如是二智何行相摄答如实知我已知苦不复知者。缘苦二行相摄。谓苦非常。我已断集不复断者。缘集四行相摄。我已证灭不复证者。缘灭四行相摄。我已修道不复修者。缘道四行相摄。问集异门论复云何通。如说。如实了知我已尽欲漏。广说乃至如是二智何行相摄。答六行相摄。谓苦非常及缘集四。问见蕴所说复云何通。如说。受乐受时如实知受乐受是何行相。答彼于圣道说乐受声即是缘道四行相摄。问契经所说复云何通。如说。如实了知我生已尽。广说乃至是何行相。答如实了知我生已尽者。是缘集四行相。梵行已立者。是缘道四行相所作已办者。是缘灭四行相。不受后有者。是缘苦二行相。谓苦非常。复次由五缘故经作是说不说行相。云何为五。一由意乐故。谓加行时起此意乐。云何当令我生永尽。广说乃至不受后有。二由对治故。谓修如是殊胜对治令生永尽。广说乃至不受后有。三由所作故。谓由如是殊胜所作令生永尽。广说乃至不受后有。四相续故。谓得如是殊胜相续令生永尽。广说乃至不受后有。五由补特伽罗故。谓此补特伽罗易现易施设一切生尽。广说乃至不受后有。由此五缘故作是说。非谓别有如是行相。有余师说。十六行相外有别无漏慧。问若尔。后说诸文善通识身智蕴何故不说。答应说而不说者。当知此义有余。复次若有行相现在和合能办所作有作用者。识身见蕴明了说之。彼未来修毕竟不起。是故不说复次若有行相能入见道得果离染尽诸漏者。识身见蕴明了显示。彼无此用是故不说。谓彼行相无学果后方起现前。受现法乐游戏神通观本所作受用圣财。复次若有行相加行无间解脱胜进四道可得。识身见蕴明了显示。彼诸行相唯远加行远胜进道乃得现起。是故不说。若作是说。十六行相外有无漏慧者。彼说此中依行相别建立三想。谓断行相相应想名断想。离行相相应想名离想。灭行相相应想名灭想。如是三想。依行相别建立三种。不约所缘。谓于一一择灭无为起此三想。如于一的三箭所中其相各异。依此所说断等三想互不相即。应作是说诸断想是离想耶答不尔。广说乃至设灭想是离想耶。答不尔。评曰。应作是说。十六行相外无别无漏慧于理为善。然此中说断等三想。若无漏者。展转相即。若是有漏。容作断等三种行相互不相即。是故此中不决定说

    大毗婆沙论杂蕴第一中爱敬纳息第四之一

云何爱。云何敬。如是等章。及解章义。既领会已。次应广释。问何故作此论。答为广分别契经义故。谓契经说。若有修习惭愧圆满。应知爱敬亦得圆满。契经虽作是说。而不分别云何爱云何敬。契经是此论所依根本。彼所不分别者今应尽分别之。复次为欲诃毁非善士法令弃舍故。为欲赞叹诸善士法令修习故。为欲显示五浊增时广大有情甚难得故。此中非善士法者。谓有一类。爱则妨敬。敬则妨爱。爱妨敬者。如有父母于子宠极。子于父母有爱无敬。师于弟子应知亦然。此等名为爱则妨敬敬妨爱者。如有父母于子严酷子于父母有敬无爱。师于弟子应知亦然。此等名为敬则妨爱。如是俱名非善士法。善士法者。谓有一类爱则加敬敬则加爱。爱敬俱行名善士法。若有此法增上圆满。应知即是广大有情。如是有情甚为难得。世若无佛此类难遇。设令有者是大菩萨。诸大菩萨爱敬必俱。为显此事及前所说三种因缘故作斯论

云何爱。答诸爱等爱喜等喜乐等乐是谓爱。此本论师于异文义得善巧故。以种种文显示此爱而体无别。问爱以何为自性。答爱有二种。一染污谓贪。二不染污谓信问诸贪皆爱耶。答应作顺前句谓贪皆爱。有爱非贪此即是信问诸信皆爱耶。有作是说诸信皆爱。有爱非信谓染污爱。应作是说信有二种。一者于境唯信不求。二者于境亦信亦求。是故此中应作四句有是信非爱。谓信不求有是爱非信。谓染污爱。有亦信亦爱。谓信亦求。有非信非爱。谓除前相。云何敬。答谓有敬有敬性。有自在有自在性。于自在者有畏怖转是谓敬。此本论师于异文义得善巧故。以种种文显示此敬。而体无别。问敬以何为自性答敬以惭为自性

云何爱敬。乃至广说。问何故复作此论。答前虽别说爱敬自性。而未总说于一境转。今欲显示爱敬二种于一境转故作斯论。云何爱敬。答如有一类于佛法僧亲教轨范及余随一有智尊重同梵行者。爱乐心悦恭敬而住。若于是处有爱及敬。是谓爱敬。此中一类者。谓异生或圣者。异生于佛爱乐心悦恭敬住者彼作是念。佛威力故我等解脱灾横王役种种苦事。及得世间诸资生具。圣者于佛爱乐心悦恭敬住者彼作是念。佛威力故我等永舍诸恶趣因。断二十种萨迦耶见。得正决定见四圣谛。于无边际生死轮回诸苦事中。已作分限。复次彼二于佛爱乐心悦恭敬住者。俱作是念。佛威力故我等出家受具足戒得苾刍性。及余利益安乐资粮。是故尊者邬陀夷言。世尊于我有大恩德。谓拔我无量苦。与我无量乐。灭我无量恶。生我无量善。复次彼二于佛俱作是念。世尊开发我等慧眼故应爱敬。是故尊者舍利子言。若佛世尊不出于世。我等一切盲生盲死。复次彼二于佛俱作是念。佛为法王最初开示无上正法。令诸有情无倒了达。杂染清净系缚解脱。流转还灭生死涅槃。余无此能。故应爱敬。复次彼二于佛俱作是念。世尊最初出无明[穀-禾+卵]宣说正法。亦令无量无边有情出无明[穀-禾+卵]。余无此能。故应爱敬。复次彼二于佛俱作是念。无始时来七依胜定隐蔽不现。佛出世间无倒开示令无量众依之趣入大涅槃宫。余无此能。故应爱敬。复次彼二于佛俱作是念。佛威力故能令无量无边有情修诸善法。谓从不净观乃至无生智。余无此力。故应爱敬。复次彼二于佛俱作是念。佛威力故令诸有情种诸善根成熟解脱。余无此力。故应爱敬。复次彼二于佛俱作是念。佛威力故念住正断神足根力觉支道支三十七种菩提分等功德宝藏出现世间。利益安乐无边有情故应爱敬。彼二于法爱乐心悦恭敬住者俱作是念。我依此法解脱一切身心苦恼究竟安乐。彼二于僧爱乐心悦恭敬住者俱作是念。僧威力故我于正法毗奈耶中净信出家。受具足戒得苾刍性。能正受持百一羯磨。无所毁犯安乐而住。由此速证究竟涅槃。彼二俱于亲教轨范及余随一有事尊重同梵行者。爱乐心悦恭敬住者。谓作是念。此诸师友为我伴侣。令我于法勤修正行速得成办。于前所说三宝师友殊胜境中。具起爱敬。余则不定。应作四句。谓或有境起爱非敬。如父母于子师于弟子等。或复有境起敬非爱。如于有德非已师长。或复有境起爱及敬。如有一类子于父母弟子于师等。或复有境不起爱敬。谓除前相。问如是爱敬于何处有。答三界五趣虽皆容有。而此中说殊胜爱敬唯在欲界人趣非余。唯佛法中有此爱敬

云何供养乃至广说。问何故作此论。答为广分别契经义故。谓契经说

  若于佛法僧　　及所受学处
  能供养恭敬　　乃名为智者
  若于不放逸　　及胜三摩地
  能供养恭敬　　不退近涅槃

契经虽作是说。而不广分别。云何供养。云何恭敬。彼是此论所依根本。彼不说者今应说之。复次为欲诃毁非善士法令弃舍故。为欲赞叹诸善士法令修习故。为欲显示五浊增时广大有情甚难得故。此中非善士法者。谓有一类若供养则妨恭敬。若恭敬则妨供养。云何供养则妨恭敬。如在家者或有男女虽具势力能以种种资生珍馔供养父母。而恃此力心生轻慢。如出家者。或有弟子福德多闻。虽于其师能设种种财法供养。而恃此事遂于师所不生恭敬。此等供养则妨恭敬。云何恭敬则妨供养。如有一类惧他威力虽恭敬之而不供养。如是俱名非善士法。善士法者。谓有一类若供养彼则加恭敬。若恭敬彼则加供养。二事俱行。名善士法。若有此法增上圆满。应知即是广大有情。如是有情甚为难得世若无佛。此类难遇。设令有者是大菩萨诸大菩萨此二必俱。为显此事及前所说三种因缘故作斯论

云何供养。答此有二种。一财供养。二法供养。财供养者。问财供养以何为自性。有作是说。为饶益故舍诸财物。即所舍财是此自性。有余师说。能供养者。身语二业是此自性。或有说者。即能发彼心心所法是此自性。复有说者。受者受已诸根大种及余造色皆得增长是此自性。评曰。应作是说。若所舍财。若能舍者身语二业。若能发彼心心所法。若受者受已诸根大种造色增长皆此自性。如是财供养。总用五蕴以为自性。已说自性。所以今当说。问何故名财供养。财供养是何义。答能为缘义。是供养义。此以财为初故名财供养。若为饶益故舍诸财物。受者受已身心增益如是名施亦名供养。若为饶益故舍诸财物。受者受已身心损减。如是名施不名供养。若为损害故舍匪宜物。受者受已或由神通或由咒药或由福力身心增盛。此虽非施而名供养若为损害故舍匪宜物。受者受已身心损减。此不名施亦非供养。问此财供养在何处有。答唯在欲界。非色无色唯在四趣。非捺落迦。问此财供养谁设谁受。有作是说。傍生趣设。唯傍生趣受。乃至天趣设。唯天趣受。有余师说。傍生趣设唯傍生受。鬼趣设二趣受。人趣设三趣受。天趣设四趣受。下不及上上及下故。评曰。应作是说。四趣皆能展转供养问施设论说。天欲食时取空宝器。以衣覆上而置座前。经须臾顷随其福力粗妙饮食自然盈满。既尔如何受他供养。答虽不受他饮食供养。而有受余香花资具。法供养者。问法供养以何为自性。有作是说。以说法者语为自性。有余师说。以语所起名为自性。或有说者。以能发语心心所法为其自性。复有说者。受者闻已生未曾有善巧觉慧以为自性。评曰。应作是说。若说法者语。若能发语心心所法。若受者闻已生未曾有善巧觉慧皆此自性。如是法供养。总用五蕴以为自性。已说自性。所以今当说。问何故名法供养。法供养是何义。答能为缘义是供养义。此以法为初故名法供养。若为饶益故为他说法。他闻法已生未曾有善巧觉慧。如是名施亦名供养。若为饶益故为他说法。他闻法已不生未曾有善巧觉慧。如是名施不名供养。若为损害故说讥刺他法。他闻是已住正忆念欢喜忍受不数其过。生未曾有善巧觉慧。此虽非施而名供养。若为损害故说讥刺他法。他闻是已发恚恨心。不生未曾有善巧觉慧。此不名施亦非供养。问此法供养在何处有。答此法供养在欲色界。非无色界。五趣皆有。地狱有者如慈授子生地狱中。谓是浴室见诸苦具。便说颂言尝闻世间受苦乐非我非他之所作。受诸苦乐皆缘身身若灭无谁复受时彼地狱无量众生闻此颂已脱地狱苦。从彼命终生天受乐。傍生有者。如迦宾折罗鸟自修梵行为他说法。鬼趣有者。如发爱鬼母为诸鬼子说是颂言

  默然汝上胜　　默然汝井宿
  我得见谛时　　亦当令汝见

人趣有者。如今现见。天趣有者。欲界天中如补处慈尊为诸天说法。色界天中如手天子来白佛言。如此世尊四众围绕为说正法闻已奉行。我闻法已还无热天。为彼诸天说法亦尔。问此法供养谁设谁受。有作是说。地狱趣设唯地狱趣受。乃至唯天趣设唯天趣受。有余师说。地狱趣设唯地狱趣受。傍生趣设二趣受。鬼趣设三趣受。人趣设四趣受。天趣设五趣受。评曰。应作是说。五趣皆能展转供养。云何恭敬。答诸有恭敬有恭敬性。有自在有自在性。于自在者有怖畏转。是谓恭敬。此本论师于异文义得善巧故。以种种文显示恭敬。而体无别恭敬亦以惭为自性

说一切有部发智大毗婆沙论卷第二十九阿毗达磨大毗婆沙论卷第三十

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中爱敬纳息第四之二

云何供养恭敬乃至广说。问何故复作此论。答前虽别说供养恭敬自性。而未总说于一境转。今欲显示此二于一境转故作斯论云何供养恭敬。答如有一类于佛法僧亲教轨范及余随一有智尊重同梵行者。施设供养恭敬而住。若于是处有供养及恭敬。是谓供养恭敬。此中一类义如前说。谓异生或圣者。于佛施设供养恭敬而住者。唯施设财供养恭敬而住非法供养。所以者何。佛于诸法已得究竟。不复从他受学法故。无有能为世尊说法令生未曾有善巧觉慧故。于法施设供养恭敬而住者。有本不说敬养法言。以于涅槃无缘义故。前说供养谓能为缘涅槃无缘是故不说。而有本说者虽于涅槃无生长义而有于彼令显了义谓以财法供养涅槃令诸有情恭敬求证由斯展转断障证得。复次法有二种。一世俗谓名身等法。二胜义谓究竟涅槃。虽于胜义法无生长义而于世俗法有生长义。是故于法亦有敬养。问诸施法物谁应受之。答施世俗法物说法师应受。或应以此书写正法施胜义法物。应勤加守护犹如守护窣堵波物。于僧施设供养恭敬而住者通财法二供养。财供养者谓以香华衣食等物供养僧众。或设五年大会等事名财供养僧。法供养者谓以三契声等为众宣说正法。或在众中论议决择。或复处众赞美功德申述所愿令众欢悦。诸如是等名法供养僧。于亲教轨范及余随一有智尊重同梵行者。施设供养恭敬而住者。亦通财法二种供养。财供养者谓以衣钵饮食汤药及余随一沙门资具而供养之。法供养者谓以三藏劝令受持。或为解释令无疑滞。或复劝请令修正行。诸如是等名法供养。于上所说三宝师友殊胜境中随应供养恭敬而住。于余境中不决定有准前应说。问供养恭敬何处具有。答欲界具有非色无色界。于欲界中四趣具有非捺落迦以地狱中无财供养唯有法故。问此财法供养谁设谁受。答佛于一切有情能设财法二供养。彼随所应能受。一切有情于佛随应能设财供养非法供养。无能为佛说法者故。及不能生佛未曾有善巧觉慧故。独觉除佛于一切有情能设财法二供养。彼随所应能受。一切有情于独觉随应能设财供养。非法供养。舍利子除佛独觉。于一切有情能设财法二供养。彼随所应能受。一切有情于舍利子随应能设财供养非法供养。大目干连除佛独觉及舍利子。于一切有情能设财法二供养彼随所应能受。一切有情于大目干连随应能设财供养非法供养。乃至利根者于钝根者随应能设财法二供养。彼随所应能受。钝根者于利根者随应能设财供养非法供养彼随所应能受

问若无以法供养佛者。契经所说当云何通。如说苾刍善哉善哉。汝乃能以和雅清妙明了易解美亮音声。讽诵正法令我欢喜。答世尊欲令闻俱胝耳得无畏故作如是说。非佛于彼受法供养。谓彼亲教迦多衍那遣诣佛所。为居边国寒地苾刍求请五事。一常澡浴。二以皮作衬身敷具。三请恒着周足革屣。四请持律为第五人得受具戒。五请若有苾刍遣使持衣与余苾刍。彼苾刍若不受我等当如何处分此衣闻俱胝耳承亲教敕来诣佛所。世尊威重释梵护世尚不能侧近正观。况彼辄敢申请佛知是事告阿难曰。汝可将彼至我寝室敷设卧具而安置之。阿难如教佛与同止至夜后分。知彼倦息便告之言。汝应为我诵所解法闻俱胝耳以三契声诵所解法。世尊欢喜为欲令彼得无所畏能申所请。是故赞言善哉。善哉乃至广说。有作是说。世尊赞彼过去所修业道清净感得如是美妙音声。令人乐闻故作是说。非为于彼受法供养。有余师说。世尊赞彼能善诵持波罗衍拏见谛经等故作是说。非为于彼受法供养。或有说者。以彼苾刍在丰马国作诸佛事。世尊赞彼更令彼国无量有情敬重受法故作是说。非为于彼受法供养。复有说者。佛赞弟子有多因缘非为受法。或为彼得无畏心故。如今赞叹闻俱胝耳。或为遮彼诽谤事故。如告无灭吾今背痛汝可为诸苾刍宣说近坚固法。唯汝能说如是胜事。或欲令彼言威肃故。如告目连唯汝能为劫比罗城诸释种等说微妙法。或欲显彼功德大故。如佛赞叹舍利子言。汝能说法如师子吼。汝所说者是决定说。问余契经说复云何通。如说佛告阿难陀言善哉善哉。如汝所说精进速证无上菩提。我闻汝言深生欢喜。答佛以庆喜所说应时故说此言非为受法。谓薄伽梵为化有情曾涉远路劳倦背痛诣一树下。四叠七条以为卧具五条覆体枕僧伽胝。如师子王右胁而卧告阿难曰。汝可为诸苾刍说法不应虚度。尔时阿难承佛圣旨为苾刍众说七觉支言。诸仁者念等觉支是我世尊自觉自说依厌离灭回向于舍。如是乃至舍等觉支广说亦尔。世尊闻彼说精进时便起前际忆念智见。我于过去三无数劫由精进力所修加行速得圆满。疾证无上正等菩提。念已发生殊胜欢喜。由斯喜力背痛便愈。寻起整衣结跏趺坐。告阿难曰汝为大众说精进耶。阿难白佛。唯然世尊佛赞彼曰善哉善哉。我由精进速证菩提。汝今说之故我欢喜。赞应时说非受供养。问毗奈耶说复云何通。如说阿难我今增益出离善法极生欢喜。若不受他法供养者如何增长出离善法。答佛以他事为己事故。他善法增便作是说谓有情类多依佛法净信出家。受具足戒诵持三藏居阿练若寂静思惟。入正决定得果离欲乃至漏尽或种生天解脱种子。佛知是事甚大欢喜作如是念。无量有情以我威力世出世间善法增长。彼之所作即是我事深可庆喜故作是说。然佛世尊定不于他受法供养。法身功德极圆满故。生身必待衣食等资故有于他受财供养。云何身力乃至广说。问何故作此论答为止他宗显正义故。谓或有执。身力身劣无别自体。如分别论彼作是说。心有力时说为身力。心无力时说为身劣。故身力劣无别自体。故遮彼执显身力劣有别自体触处所摄。或复有执。身力自体即是精进。身劣自体即是懈怠。如法密部为止彼执显示别有身力身劣非精进等。有执。身力及与身劣无定自体。如譬喻者彼作是说。象力胜马马力胜牛。故知力劣无定自体。为遮彼执显身力劣有定自体触处所摄。以一切法自性定故诸有为法皆有胜劣自体决定。如眼于色见明了者说名为胜见。不明了说名为劣。广说乃至意知诸法亦复如是。于中各有胜劣定性。身力身劣应知亦尔。问若身力劣各有定性。譬喻者难当云何通。答虽象马等相待胜劣名不决定而有定体。谓马对象劣大种多力大种少。马若对牛劣大种少力大种多。如马余类当知亦尔。以力与劣大种各异故相待时。名虽不定而体恒别。为止如是他宗异执及为显示身力身劣实有别体故作斯论

云何身力。答诸身勇猛强健轻捷能有所办是谓身力。此本论师于异文义得善巧故以种种文显示身力而体无异。云何身劣。答诸身不勇不猛不强不健不轻不捷无所能办是谓身劣。此本论师于异文义得善巧故以种种文显示身劣而体无异。身力身劣几处摄几识识。答一处摄谓触处。二识识。谓身识及意识。此中身识唯了彼自相意识了彼自相及共相。此言即遮分别论者执身力劣无别自体。显示此二有别自体若无自体应非触处摄及二识所识。心力有无非触处摄二识识故。如二力士相叉扑时手腕才交互知强弱。此中论主引现事喻欲令愚智俱得解了。由此即遮法密部执身力是精进身劣是懈怠。显身力劣非精进等。若不尔者手腕才交宁知强弱。精进懈怠非以手触即能知故。又如强者执弱者时力之胜劣相知亦尔。此中论主引第二喻重显斯义令易了知。由此即遮譬喻者执身力身劣无定自体。显示此二有定自体。若不尔者不应才执即知胜劣相待假法定非身识所能了故。问身力身劣以何为自性。有作是说。以大种为自性。问何大种增名为身力何大种增名为身劣。有说。大种无偏增者然四大种有强胜者说名身力。有羸弱者说名身劣。有说。地界增故名为身力。水界增故名为身劣。外物亦尔担山木等地界增故其体坚强柳苽瓠等水大增故其体虚弱。有余师说。身力身劣非四大种是所造触。问七所造触中谁增故名身力。谁增故名身劣。有说。重增故名身力。轻增故名身劣外物亦尔。重者体强。轻者体弱。有说。此二是所造触非七所摄。谓七种外别有所造触。名身力身劣。评曰应作是说。即四大种及所造触。俱是身力身劣自性。谓若调和俱名身力。若不调和俱名身劣

如契经说。菩萨身具那罗延力。此力其量云何。有作是说。十凡牛力等一毫牛力。十毫牛力等一青牛力。十青牛力等一凡象力。十凡象力等一香象力。十香象力等一大诺健那力。十大诺健那力等一钵罗塞建提力。十钵罗塞建提力等半那罗延力。二半那罗延力等一那罗延力。菩萨身力与此力等。有余师说。此量极少。应说十凡牛力等一毫牛力。十毫牛力等一青牛力。十青牛力等一凡象力。十凡象力等一野象力。十野象力等一羯拏鲁诃象力。十羯拏鲁诃象力等一阿罗择迦象力。十阿罗择迦象力等一殑耆洛迦象力。十殑耆洛迦象力等一雪山象力。十雪山象力等一香山象力。十香山象力等一青山象力。十青山象力等一黄山象力。十黄山象力等一赤山象力。十赤山象力等一白山象力。十白山象力等一嗢钵罗象力。十嗢钵罗象力等一拘牟陀象力。十拘牟陀象力等一钵特摩象力。十钵特摩象力等一奔茶利迦象力。十奔茶利迦象力等一钵特莫迦象力。十钵特莫迦象力等一大钵特莫迦象力。十大钵特莫迦象力等一大香象力。十大香象力等一大诺健那力。十大诺健那力等一钵罗塞建提力。十钵罗塞建提力等一娑浪伽力。十娑浪伽力等一伐浪伽力。十伐浪伽力等一遮怒罗力。十遮怒罗力等一伐罗遮怒罗力。十伐罗遮怒罗力等半那罗延力。二半那罗延力等一那罗延力。菩萨身力与此力等。或有说者。此量犹少。应说菩萨身中有十八大节一一大节皆有一那罗延力。复有说者。此量犹少。应说菩萨身中有十八大节。一一大节有十八那罗延力。或复有说。此量犹少。应说菩萨身中大小总有三百二十节。其最小节有一那罗延力。其次大节有二那罗延力。渐次大者力倍倍增。有余复说。此量犹少。应说菩萨身力等千蔼罗伐拏龙象王力。此象王力其量云何。谓此象王举身鲜白如拘牟陀白莲花色。七支善住具有六牙。其头红赤如因达罗瞿博迦色。左右边胁各二踰缮那半。身前后分各一踰缮那。周围身量七踰缮那。高下唯一踰缮那半。此是常身变化不定。此有八千龙象眷属。身皆鲜白如拘牟陀具有六牙七支善住。其头红赤如上烟脂。若转轮王出现于世。此诸象中随一来应。三十三天将游戏苑天福力故才举心时。令大象王牙现异色。便作是念天帝释等今须乘我入苑游戏。即便从此赡部洲没至天帝释宫前而现。身上化出三十二头。皆具六牙如本头色。此头并本有三十三。一一牙上化作七池。一一池中作七莲花。一一花上作七宝院。一一院内作七宝台。一一台中作七宝帐。一一帐内作七天女。一一天女作七侍者。一一侍者作七伎女奏诸伎乐。作是化已。时天帝释及诸眷属升彼本头。三十二天及诸眷属升所化作三十二头。余十千城诸天家族升彼背上。其身轻举犹如旋风吹莲华花或飘桦皮。乘空往诣所游戏苑。尔时诸天都不自见有前后者。到已俱下各诣戏林欢娱受乐。时彼龙象亦自化身如天子形游戏受乐。蔼罗伐拏其力如是。有作是言此力犹少。应说菩萨身中有十八大节一一大节皆有如千蔼罗伐拏龙象王力。有余复言此力犹少。应说菩萨身中大小总有三百二十节。其最小节有如千倍蔼罗伐拏龙象王力。渐次大者力倍倍增。大德说曰。此力犹少。应说菩萨意力无边身力亦尔云何知然。谓昔菩萨吉祥人边受吉祥草诣菩提树自敷为座结跏趺坐。作是坚固愿言。若未诸漏永尽及证无上菩提我终不起此座。无上菩提从未来世将入现在。尔时三千大千世界六种震动。菩萨毛发亦不动摇。由此故知菩萨身力犹如意力量无边际。问若尔何故契经中说菩萨身有那罗延力。答此力世间共所钦重故以为喻而实不然。问菩萨何缘集此身力。答欲现所有皆殊胜故。谓诸色力族姓自在眷属财位功德名闻智见威猛皆殊胜故憍傲有情归伏受法。复次欲为无上正等菩提作所依故集此身力。谓佛无上正等菩提要依此身方得安住。假使无上正等菩提置在妙高大山王顶彼便碎坏犹若微尘。力无畏等甚尊重故。由此三千大千世界中赡部洲。有金刚座。上穷地际。下据金轮。菩萨坐之成正等觉。除此无有坚固依处。是故菩萨初成佛时。方欲经行徐足按地。即令大地六种震动便起胜解乃得经行。复次为欲引摄所化有情犹如遣使故集此力。谓无上觉遣此力使摧彼慢已然后度之。故在家时与诸释种种种捔力无不得胜。将般涅槃亦以身力伏诸力士而度脱之。谓佛世尊化缘将尽欲入寂灭往拘尸城波波邑中。五百力士闻已为佛修治道路。当彼路上有一大石长六十肘广三十肘。彼诸力士欲转去之尽其身力不能令动。世尊既至见已问言。汝诸童子欲何所作。彼闻惘然窃作是念。我等势力赡部推先如何世尊呼为童子。作是念已俱白佛言。我为世尊修治道路。共转此石不能令动。颇能哀愍除此石耶。佛言我能。汝等远避。便以足指挑置掌中。上掷虚空下还接取。以口吹散令如微尘。还使如本弃之路侧。力士惊叹得未曾有。敬礼合掌复白佛言。此是如来何等神力。世尊告曰举石置掌复掷虚空复还接取弃之路侧皆我父母生身之力。以口吹散令如微尘是神通力。还合如本是胜解力。力士闻已欢喜踊跃复白佛言。颇有余力能胜世尊如是力不。佛答言有。谓无常力。佛告力士。谓我父母生身之力。若神通力。及胜解力。今日中夜皆为无常力之灭坏。时诸力士闻佛所说皆于世间深生厌离。佛便为说如应法要。令诸力士及余无量在彼天人得法眼净。永离恶趣。第八有等故为引摄所化有情犹如遣使集此身力。问菩萨何时身力圆满。答年二十五。此后乃至年满五十其力无减。过是已后世尊身力渐渐衰退。有说世尊身力无减犹如意力无衰退故。评曰。如来法身虽无衰退。而生身力必有退减。诸异熟果有衰退故。是故尊者邬陀夷言。今见世尊色力衰减诸根变异。谓五色根。问诸余有情有斯力不。答此力不共一切有情唯最后身菩萨得有。如最初说菩萨力量极为减少尚为难得。况第二说第三说等余有情类而得有耶。然此贤劫世界初成时。有诸有情具那罗延力。或有有半那罗延力。或有钵罗塞建提力。或有摩诃诺健那力。此诸力士充满世间。过是已后渐渐减少乃至今时全无彼力。佛在世时有三释种具有钵罗塞建提力。谓阿难陀设摩释子瞿波释女。尔时亦有具足摩诃诺健那力象力马力牛力等人不可称数。若麟角喻独觉亦有那罗延力。若部行喻独觉其力不可定说。以彼多是声闻种姓后遇别缘得无学果。虽乐寂静而有众居如五百仙一处得果。麟角喻者根极胜故乐独出故。当知如佛必无有二并出世间。如舍利子尚无并出。况麟角喻胜彼多倍。诸声闻人其力不定。如部行喻独觉人说。诸转轮王力亦不定。王四洲者有那罗延力。王三洲者有伐浪伽力。王二洲者有钵罗塞建提力。王一洲者有摩诃诺健那力。此四轮宝亦有差别王四洲者有金轮宝。其量正等四俱卢舍。王三洲者有银轮宝其量正等三俱卢舍。王二洲者有铜轮宝其量正等二俱卢舍。王一洲者有铁轮宝其量正等一俱卢舍。如四轮宝有此差别。应知余宝亦有胜劣谓王四洲者余宝最胜乃至王一洲者余宝最劣。问诸有情类身力既别骨节安立有差别不。答亦有差别。谓凡常力者骨节相远。有象马力者骨节相近。有大诺健那力者骨节相接如接板等。有钵罗塞建提力者骨节相钩。有那罗延力者骨节连锁。菩萨骨节展转相交如龙蟠结。是故最胜。已说佛身力。意力今当说。谓佛世尊成就十力四无所畏及与大悲三念住等不可思议无边功德。随用差别立种种名。具于十种说名意力。云何为十。一处非处智力。二业法集智力。三静虑解脱等持等至发起杂染清净智力。四种种界智力。五种种胜解智力。六根胜劣智力。七遍趣行智力。八宿住随念智力。九死生智力。十漏尽智力问如是十力以何为自性。答以智为自性。谓佛意力是智所成。以智为体智所摄故。如契经说。于处非处如实了知乃至广说。已说自性。所以今当说。问何故名力力是何义。答不可屈义是力义。不可伏义。不可摧义。不可害义。不可转义。不可覆义。能遍觉义。能荷担义。坚固义。最胜义。能制他义。是力义。界者宿住随念智力死生智力是色界系。余力有漏者三界系。无漏者是不系。地者宿住随念智力死生智力在四根本静虑。是通性故。近分无色及不定地非通所依故无此二。余力有漏者在十一地。谓欲界四静虑四无色及未至定静虑中间。无漏者在九地。所依者皆依欲界人赡部洲大丈夫身。唯依此身得成佛故。行相者处非处智力遍趣行智力十六行相。或余行相。业法集智力苦集八行相。或余行相。第三第四第五第六智力苦集道十二行相。或余行相宿住随念智力死生智力是余行相。非十六行相。漏尽智力诸有欲令缘漏尽境故。名漏尽智力者彼说灭四行相。或余行相诸有欲令依漏尽身故名漏尽智力者彼说十六行相。或余行相。所缘者处非处智力缘一切法。业法集智力唯缘苦集。第三第四第五第六智力缘三谛除灭谛。遍趣行智力但缘四谛。宿住随念智力缘欲色界前际五蕴。死生智力缘色处。漏尽智力若缘漏尽境故则缘灭谛。若依漏尽身故则缘一切法。念住者种种胜解智力宿住随念智力唯法念住。死生智力唯身念住。漏尽智力若缘漏尽境故则法念住。若依漏尽身故则四念住。余力皆四念住智者处非处智力遍趣行智力通十智。业法集智力唯八智除灭道。第三第四第五第六智力唯九智除灭智。宿住随念智力死生智力唯世俗智。漏尽智力若缘漏尽境故则唯六智。谓法智类智灭智尽智无生智世俗智。若依漏尽身故则通十智。三摩地俱者处非处智力遍趣行智力三三摩地俱或不俱。业法集智力缘苦集空无愿俱或不俱。第三第四第五第六智力缘苦集道空无愿俱或不俱。宿住随念智力死生智力非三摩地俱。漏尽智力若缘漏尽境故则无相俱或不俱。若依漏尽身故则三三摩地俱或不俱。根相应者总说皆与三根相应谓乐喜舍。过去未来现在者此十力皆通三世。缘过去未来现在者处非处智力遍趣行智力。缘三世及离世第二第三第四第五第六智力。缘三世宿住随念智力。过去现在者缘过去。未来者缘三世。死生智力过去者缘过去。现在者缘现在。未来生法缘未来。若不生法缘三世。漏尽智力若缘漏尽境故则缘离世。若依漏尽身故则缘三世及离世。善不善无记者此十力皆是善。缘善不善无记者漏尽智力若缘漏尽境故则但缘善。若依漏尽身故则缘三种。余九力皆缘三种。有余师说。第三智力但缘善无记。彼不应作是说。此力通缘杂染清净有为法故。杂染法中有不善故。系不系者宿住随念智力死生智力唯色界系。余八力有漏者三界系。无漏者是不系。缘系不系者宿住随念智力死生智力缘欲色界系。业法集智力缘三界系。漏尽智力若缘漏尽境故则缘不系。若依漏尽身故则缘三界系及不系。余力皆缘三界系及不系。学无学非学非无学者。宿住随念智力死生智力唯非学非无学。余八力无漏者是无学。有漏者是非学非无学。缘学无学非学非无学者。业法集智力宿住随念智力死生智力唯缘非学非无学。漏尽智力若缘漏尽境故唯缘非学非无学。若依漏尽身故则缘三种。余力皆缘三种见所断修所断不断者。宿住随念智力死生智力唯修所断。余八力有漏者修所断。无漏者是不断。缘见所断修所断不断者。业法集智力宿住随念智力缘见修所断。死生智力缘修所断。漏尽智力若缘漏尽境故则缘不断。若依漏尽身故则缘三种。余力皆缘三种。缘名缘义者。种种胜解智力根胜劣智力死生智力唯缘义。漏尽智力若缘漏尽境故则但缘义。若依漏尽身故则通缘名义。余力皆通缘名义。缘自相续他相续非相续者。处非处智力遍趣行智力缘三种。漏尽智力若缘漏尽境故则缘非相续。若依漏尽身故则缘三种。余力皆缘自他相续。加行得离染得者。此十力皆可言加行得。三无数劫积集殊胜加行得故。皆可言离染得。离有顶染得尽智时得诸力故。问如是十力加行云何。答此加行有二种。一近加行。谓顺决择分等。二远加行。谓初不退菩提心等。问业法集智力死生智力俱可缘业有何差别。答从因入果是业法集智力。从果入因是死生智力。如因果如是细粗不现见。现见远近亦尔。问无表业云何知。答从果入因从粗入细。从现见入不现见。从近入远。如是知。问宿住随念智死生智二乘亦有。何故唯佛建立力耶。答前说不可屈义等是力义。二乘虽有而无此义故不名力如舍利子虽入第四静虑而不知人当所生处及所从来等事。问二乘亦有漏永尽智何故非力。答佛智猛利速断烦恼及彼余习。非二乘故。复次佛智能知自他相续诸漏永尽时分不谬。声闻独觉无如是能。复次不以自知诸漏尽故名漏尽力。以能知他无边世界诸有情类漏尽差别。及为彼说漏尽方便明了不谬名漏尽力。声闻独觉无如是义

说一切有部发智大毗婆沙论卷第三十阿毗达磨大毗婆沙论卷第三十一

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中爱敬纳息第四之三

已说佛十力。当说四无畏。云何为四。一正等觉无畏。如契经说我是诸法正等觉者。若有世间沙门梵志天魔梵等依法立难。或令忆念于如是法非正等觉无有是处设当有者我于是事正见无由故得安隐无怖无畏。自称我处大仙尊位。于大众中正师子吼转大梵轮。一切世间沙门梵志天魔梵等所不能转二漏永尽无畏。如契经说。我于诸漏已得永尽若有世间沙门梵志天魔梵等依法立难。或令忆念有如是漏未得永尽无有是处。设当有者乃至广说。三说障法无畏。如契经说。我为弟子说能障法染必为障。若有世间沙门梵志天魔梵等依法立难。或令忆念有此障法染不为障无有是处。设当有者乃至广说。四说出道无畏。如契经说。我为弟子说能出道修必出苦。若有世间沙门梵志天魔梵等依法立难。或令忆念修如是道不能出苦无有是处。设当有者我于是事正见无由故得安隐无怖无畏。自称我处大仙尊位。于大众中正师子吼转大梵轮。一切世间沙门梵志天魔梵等所不能转问此四无畏以何为自性。答亦以智为自性。所以者何。初无畏即初力。第二无畏即第十力。第三无畏即第二力。第四无畏即第七力故。已说自性。所以今当说。问何故名无畏无畏是何义。答不怯弱义是无畏义。不倾动义。勇猛义。安隐义。清净义。鲜白义。不惊怖义。是无畏义。界者此四无畏。有漏者三界系。无漏者是不系。地者此四无畏有漏者在十一地。无漏者在九地。所依者此四无畏皆依欲界人赡部洲大丈夫身。唯依此身得成佛故。行相者初无畏十六行相。或余行相。第二无畏诸有欲令缘漏尽境故名漏尽无畏者。彼说灭四行相。或余行相。诸有欲令依漏尽身故名漏尽无畏者。彼说十六行相。或余行相。第三无畏苦集八行相。或余行相。第四无畏十六行相。或余行相。所缘者初无畏缘一切法。第二无畏若缘漏尽境故则缘灭谛。若依漏尽身故则缘一切法。第三无畏缘苦集谛。第四无畏但缘四谛。念住者第二无畏若缘漏尽境故则法念住。若依漏尽身故则四念住。余三无畏皆四念住。智者初及第四无畏皆通十智。第二无畏若缘漏尽境故则唯六智。谓法智类智灭智尽智无生智世俗智。若依漏尽身故则通十智。第三无畏唯有八智。谓除灭道。三摩地俱者。初及第四无畏三三摩地俱或不俱。第二无畏若缘漏尽境故则无相俱或不俱。若依漏尽身故则三三摩地俱或不俱。第三无畏缘苦集空无愿俱或不俱。根相应者总说皆与三根相应。谓乐喜舍。过去未来现在者。此四无畏皆通三世。缘过去未来现在者。初及第四无畏缘三世及离世。第二无畏若缘漏尽境故则缘离世。若依漏尽身故则缘三世及离世第三无畏但缘三世。善不善无记者。此四无畏皆是善。缘善不善无记者。第二无畏若缘漏尽境故则但缘善。若依漏尽身故则缘三种。余三无畏皆缘三种系不系者。此四无畏有漏者三界系。无漏者是不系。缘系不系者。初及第四无畏缘三界系及不系第二无畏若缘漏尽境故则缘不系若依漏尽身故则缘三界系及不系。第三无畏但缘三界系。学无学非学非无学者。此四无畏无漏者是无学。有漏者。是非学非无学。缘学无学非学非无学者。初及第四无畏缘三种第二无畏若缘漏尽境故则缘非学非无学。若依漏尽身故则缘三种。第三无畏但缘非学非无学。见所断修所断不断者。此四无畏有漏者修所断。无漏者是不断。缘见所断修所断不断者。初及第四无畏缘三种。第二无畏若缘漏尽境故则缘不断。若依漏尽身故则缘三种。第三无畏缘见修所断。缘名缘义者。第二无畏若缘漏尽境故则但缘义。若依漏尽身故通缘名义。余三无畏皆缘名义缘自相续他相续非相续者。初及第四无畏缘三种。第二无畏若缘漏尽境故则缘非相续。若依漏尽身故则缘三种第三无畏缘自他相续加行得离染得者。此四无畏皆可言加行得。三无数劫积集殊胜加行得故皆可言离染得。离有顶染得尽智时得无畏故。问此四无畏加行云何答此加行有二种一近加行谓顺决择分等。二远加行谓初不退菩提心等。如是所说十力四无所畏。一一力摄四无畏。一一无畏摄十力故则有四十力四十无畏。然前说初无畏即初力。第二无畏即第十力。第三无畏即第二力。第四无畏即第七力者。依相显说理实。世尊成就四十力四十无畏。依根本说但言成就十力四无所畏。问若十力摄四无畏。四无畏摄十力者。力与无畏有何差别。有说此二无有差别互相摄故。有说此二亦有差别且名即差别谓名力名无畏。复次坚强是力。勇决是无畏。复次安住是力。不可倾动是无畏。复次不可屈伏是力。不怯弱是无畏。复次自利是力。利他是无畏。复次自摄受是力。摄受他是无畏。复次非他所胜是力。能胜他是无畏。复次非他所降伏是力。能降伏他是无畏

复次自相智是力。共相智是无畏。复次智是力。辩是无畏。复次因是力。果是无畏。复次自通达是力。能为他说是无畏。复次通达义是力。通达文是无畏。复次法义无碍解是力。词辩无碍解是无畏。复次于法义无碍解究竟明了是力。于词辩无碍解究竟明了是无畏。复次积集是力。受用是无畏。复次如自丰财宝是力。如能分施他是无畏。复次如解医方是力。如能疗病是无畏。复次智慧明了是力。不怯他难是无畏。力与无畏是谓差别。已说无畏。当说大悲。问大悲以何为自性。答以智为自性。有说。大悲别有自性非智所摄。如是说者。大悲是智无别有体知药病等而救疗故已说自性。所以今当说。问何故名大悲。大悲是何义。答拔济有情增上苦难故名大悲。谓从地狱傍生鬼趣大苦难中拔济令出安置人天喜乐等处。复次拔众生出增上淤泥故名大悲。谓有情类没在烦恼大淤泥中授正法手拔之令出安置圣道及道果中。复次授诸有情增上义利故名大悲谓教众生断三恶行修三妙行。种植尊贵富乐种子。感得尊贵大富乐果。形色美妙众所乐见。肤体细软光明清净。或为轮王。或作帝释。或为魔主。或作梵王。展转乃至或生有顶。或复种植三乘种子引得三乘菩提涅槃。如是皆由大悲威力。复次大价所得故名大悲。谓一切时于一切处。舍施一切所爱身财及妻子等。济诸众生匮乏苦难。具足受持清净禁戒宁舍身命终无毁犯。打骂陵辱割截身支乃至断命曾无嗔忿。精进苦行未尝暂息。恒居寂静专修静虑。为胜慧故求法无怠。如是福德智慧资粮大价圆满乃得如是救众苦难清净大悲。非如二乘或施一食持一宿戒乃至思惟一四句颂便得彼果。复次大加行得故名大悲。谓必经三无数大劫修习百千难行苦行方得如是无限大悲。非如声闻极利根者经六十劫修诸加行便得菩提。非如独觉极利根者唯经百劫修诸加行便得菩提。复次依大身起故名大悲。谓此大悲决定依止三十二种大丈夫相所庄严身。八十随好间饰支体。身真金色常光一寻无能见顶。众生遇者无不获益。大悲依止如是胜身。非如二乘所获功德依止矬陋支体不具诸根缺减无威德身亦能现起。复次舍大安乐救大苦难故名大悲。谓佛世尊弃舍殊胜增上炽盛无量无边不共佛法大安乐事。逾越百千俱胝大海轮围山等诸险难处。游历十方救众生苦作安乐事。如是皆由大悲威力。复次为度无量难化有情造作难为大劬劳事故名大悲。谓佛虽居极尊贵位为众生故。或作陶师。或作商人。或作力士。或作猎主。或作俳优。或贩花鬘。或赁船筏。作如是等诸猥杂类。拔济种种所化有情。或将阿难游历五趣。昼夜无间饶益有情。或为指鬘得度脱故延促地界时远时近。令其调伏然后化之。虽复成就增上惭愧而为有情现阴藏相。令彼见已诽谤止息。无量有情闻皆从化。虽复久断轻躁调戏而为有情现广长舌。乃至发际遍覆面轮令诸有情因受佛化。如是等事无量无边一切皆由大悲威力。复次倾动大舍故名大悲。谓佛成就二种大法。一者大舍。二者大悲。若佛安住大舍法时假使十方诸有情类。一时吹击大角大鼓。或现雷震掣电霹雳诸山大地倾覆动摇不能令佛举心视听。若佛现起大悲法时。击大舍山令其振动。亦令无量那罗延力所合成身。如大猛风吹小草叶处处飘转作诸有情利乐胜事。由斯等义故名大悲。如是大悲界者唯是色界。地者唯在第四静虑所依者唯依欲界人赡部洲大丈夫身。唯依此身得大悲故。行相者非十六行相是余行相。所缘者通缘三界诸法有情。念住者唯法念住。智者唯世俗智。三摩地俱者非三摩地俱。根相应者舍根相应。过去未来现在者是三世。缘过去未来现在者缘三世善不善无记者唯是善。缘善不善无记者缘三种。系不系者唯色界系。缘系不系者缘三界系。学无学非学非无学者唯是非学非无学。缘学无学非学非无学者。但缘非学非无学。见所断修所断不断者唯修所断。缘见所断修所断不断者。缘见修所断缘名缘义者通缘名义。缘自相续他相续非相续者。虽通缘自他相续而多缘他相续。加行得离染得者。可言加行得。三无数劫积集殊胜加行得故。可言离染得。离有顶染得尽智时得大悲故。问云何名为大悲加行。答此加行有二种。一近加行谓顺决择分等。二远加行谓初不退菩提心等。问此大悲何力摄。答处非处智力摄。以佛世尊不共功德多分摄在处非处智力中故。问悲与大悲有何差别。答应知略有八种差别。一自性差别。谓悲无嗔善根为自性。大悲无痴善根为自性。二行相差别。谓悲作苦苦行相。大悲作三苦行相。三所缘差别。谓悲唯缘欲界。大悲通缘三界。四依地差别。谓悲通依十地。即四静虑四近分静虑中间及欲界地。大悲唯在第四静虑五所依差别。谓悲通依三乘及异生身。大悲唯依佛身。六证得差别。谓悲离欲界乃至第三静虑染时得。大悲唯离有顶染时得。七救济差别。谓悲唯希望救济。大悲救济事成。八哀愍差别。谓悲哀愍不平等。大悲哀愍平等。是谓悲与大悲差别。已说佛大悲。当说三念住。云何为三。一者佛说法时。若诸弟子恭敬听受如教奉行。如来于彼不生欢喜心不踊跃。但起大舍住念正知随宜教诲。二者佛说法时。若诸弟子不恭敬听受不如教奉行。如来于彼不生嗔恨。心无怅恨不舍保任。但起大舍住念正知随宜教诲。三者佛说法时。一分弟子恭敬听受如教奉行。一分弟子不恭敬听受不如教奉行。如来于彼不生欢喜亦不嗔恨。但起大舍住念正知。如是三种不共念住应知亦摄在处非处智力。广分别义如理应思。问此十八种不共佛法几于说法能为胜支。答除三念住余十五种。皆于说法能为胜支。所以者何。佛由十力能立自论。由四无畏能破他论。由大悲故起说法欲。由此三种说法事成。三种念住无如是力。但说法时于弟子众不生忧喜。发起大舍住念正知名不共法如契经说。如来成就七种妙法。云何为七。一者知法。二者知义。三者知时。四者知量。五者自知。六者知众。七者知补特伽罗胜劣差别问此七妙法谁几智性。答此七皆是世俗智性。有作是说。知法知量知众三种唯世俗智。知义一种诸有欲令唯有涅槃是胜义者六智为性谓法智类智灭智尽智无生智及世俗智。诸有欲令一切法皆是胜义者十智为性。知时自知八智为性。除灭智及他心智。知补特伽罗胜劣差别九智为性除灭智。有余师说。知时亦以九智为性谓除灭智。评曰。如是所说虽亦有理。然契经中说此七种一切皆是世俗智性皆知事法有差别故。问此七妙法何力所摄。答皆处非处智力所摄

如契经说如来成就五圣智三摩地云何为五。一者有内证智生。知此三摩地是圣离染二者有内证智生知此三摩地非愚者所近是智者所赞。三者有内证智生。知此三摩地现乐后乐。四者有内证智生。知此三摩地寂静微妙是止息道令心一趣有所证得。五者有内证智生。知此三摩地正念故入正念故出。问此五圣智三摩地谁几智性。答此五皆是世俗智性。有作是说。皆八智性。谓除灭智及他心智。尊者妙音作如是说。皆六智性。谓除苦集灭他心智。如是说者。如是所说虽亦有理。然契经中说此五种一切皆是世俗智性。皆知定事有差别故。问此五圣智三摩地何力所摄。答皆处非处智力所摄。因释身力傍论已了

云何择灭乃至广说。问何故作此论。答为止他宗显正义故。谓或有执。择灭非择灭无常灭非实有体。如譬喻者为遮彼执显三种灭皆有实体。或复有执。此三种灭皆是无为。如分别论者。为遮彼执显二灭是无为。无常灭是有为。故作斯论。云何择灭。答诸灭是离系。谓诸法灭亦得离系得离系得是名择灭。云何非择灭。答诸灭非离系。谓诸法灭得不离系不得离系得名非择灭。云何无常灭。答诸行散坏破没亡退是谓无常灭。此中散坏破没亡退文字虽有差别而同显无常灭。又诸行散等言。非如散谷豆等令往异处。但显由无常灭无复作用。又散等言不显诸行自性灭坏但显诸行由无常灭无复作用。谓有为法自性恒有由生相故。有作用起由灭相故。无复作用名为散坏破没亡退

非择灭无常灭何差别。答非择灭者。不由择力解脱疫疠灾横愁恼种种魔事行世苦法。非于贪欲调伏断越。无常灭者诸行散坏破没亡退。是谓二灭差别。此中解脱疫疠灾横愁恼种种魔事苦法者。显有漏法非择灭解脱行世法者。显无漏法非择灭非于贪欲调伏断越者。显异择灭问何故此中但说非择灭无常灭差别不说择灭耶。答是作论者意欲尔故乃至广说。复次此中应作是说。择灭非择灭无常灭何差别。答择灭者由择力故有漏法灭。非择灭者不由择力解脱疫疠广说如前。无常灭者诸行散坏破没亡退。复次择灭是解脱是离系相。非择灭是解脱非离系相。无常灭非解脱非离系相。复次择灭于三世有漏法得。非择灭于未来不生有为法得。无常灭于现在一切法转。复次择灭是善。彼得亦善。非择灭是无记。彼得亦无记。无常灭通三种。彼得亦三种。复次择灭是无漏。彼得通有漏无漏。非择灭是无漏。彼得唯有漏。无常灭通二种。彼得亦二种。复次择灭是不系。彼得或色界系。或无色界系或不系。非择灭是不系。彼得唯三界系。无常灭三界系。或不系。彼得亦三界系或不系。复次择灭是非学非无学。彼得或学或无学或非学非无学。非择灭是非学非无学。彼得亦唯非学非无学。无常灭通三种。彼得亦三种复次择灭是不断。彼得或修所断或不断。非择灭是不断。彼得唯修所断。无常灭通三种。彼得亦三种。复次择灭非择灭俱不染污。彼得亦俱不染污。无常灭通染污不染污。彼得亦二种如染污不染污。有罪无罪退不退亦尔。复次择灭无异熟。彼得或有异熟。或无异熟。非择灭无异熟。彼得亦无异熟。无常灭通二种。彼得亦二种。复次择灭是道果。彼得或是道是道果。或非道非道果。非择灭非道非道果。彼得亦非道非道果。无常灭或是道非道果。或是道亦道果。或非道非道果。彼得亦尔。复次择灭灭谛摄。彼得三谛摄除灭谛。非择灭非谛摄。彼得二谛摄谓苦集。无常灭三谛摄除灭谛。彼得亦尔。应作如是广辨差别。而不尔者前已说故。谓择灭是离系。非择灭无常灭非离系。俱非离系须辨差别。有说。二灭俱不用功得。须辨差别。择灭用功得与二有异故不须说

问已知择灭离系为体。应说何故名择灭耶答择者谓慧。灭是彼果。择所得灭故名择灭。复次一向劬劳。一向加行。一向功用简择诸法方得此灭。故名择灭。复次数数决择苦等得灭。故名择灭。谓苦忍苦智决择苦谛。于见苦所断法得灭。集忍集智决择集谛。于见集所断法得灭。灭忍灭智决择灭谛。于见灭所断法得灭。道忍道智决择道谛。于见道所断法得灭。以苦等智数数决择苦圣谛等。于修所断法得灭。故名择灭。问择灭自性为是一物为多物耶。有说。一物。问若尔证见所断法择灭时。亦证修所断法择灭不。若亦证者修后对治应成无用。若不证者云何一物少分证少分不证。有说。二物。一见所断法择灭。二修所断法择灭。问若尔证见苦所断法择灭时。亦证见集灭道所断。法择灭不。若亦证者修后对治应成无用。若不证者云何一物少分证少分不证。有说。五物谓见所断法择灭有四。修所断择灭有一。问若尔证欲界见修所断法择灭时。亦证色无色界见修所断法择灭不。若亦证者修后对治应成无用。若不证者云何一物少分证少分不证有说择灭有十一物。谓见所断法择灭有八。修所断法择灭有三。问若尔证欲界修所断上上品法择灭时。亦证欲界修所断后八品法择灭不。若亦证者修后对治应成无用。若不证者云何一物少分证少分不证。色无色界修所断九品法择灭征问亦尔。有说。择灭有三十五。谓见所断法择灭有八。修所断法择灭三界各九为二十七。足前八为三十五。问若尔证初静虑修所断法择灭时。亦证后三静虑修所断法择灭不。若亦证者修后对治应成无用。若不证者云何一物少分证少分不证。四无色地修所断法征问亦尔。有说。择灭有八十九。谓见所断法择灭有八。修所断法择灭九地各九为八十一。足前八为八十九。问若尔见所断法三界九地各有四部九品差别。云何择灭但有八种。又见修所断法一一地一一部一一品各有多种。云何择灭但有一种。评曰。应作是说随有漏法有尔所体择灭亦尔。随所系事体有尔所离系亦有尔所体故。问已知择灭随所系事有尔所量。诸有情类证择灭时。为共证一为各别证。设尔何失。二俱有过。若共证一。云何涅槃名不共法。又若尔者若一有情得涅槃时。一切有情亦应皆得。若尔则应不由功用自然解脱。若各别证。云何涅槃名不同类。又契经说当云何通。如说。如来解脱与余阿罗汉等解脱无异。答应作是说。诸有情类证择灭时皆共证一。问若尔云何涅槃名不共法。答涅槃体虽实是共。而约得说名不共。以离系得一一有情自相续中各别起故。问若一有情得涅槃时。诸余有情何故不得。答若身中有涅槃得者名得涅槃。无则不尔。故无一时一切有情得涅槃失。有余师说。诸有情类证择灭时各各别证。问若尔云何涅槃名不同类。答遮同类因故作是说。谓诸择灭无同类因名不同类。非诸有情无别择灭展转相似。问苦法智忍无同类因。亦应名为不同类法。何故有为皆名同类。但说涅槃名不同类。答苦法智忍虽无同类因。而能与他作同类因故亦名同类。涅槃不尔。复次诸有为法同蕴界处三门所摄。同堕三世。同有生灭。同下中上。同有先后。同从因生。同能生果。故名同类。涅槃不尔名不同类。复次一切法中唯有涅槃是善是常。余不尔故名不同类。谓所余法有善非常有常非善有二俱非。涅槃独具善常二义。是故独名不同类法。问契经所说复云何通。如说。如来解脱与余阿罗汉等解脱无异。答三乘身中解脱虽异而善常同故说无异。复次此言显示一相续中有三乘道同证解脱。谓望他身所证解脱。虽各有异而一身中有三乘性同证解脱。随依何乘引起圣道。皆能证得此涅槃故。评曰。彼不应作是说。应作是说。诸有情类普于一一有漏法中。皆共证得一择灭体。前说择灭随所系事多少量故。由此前说于理为善问于外物中为亦证得择灭体不。设尔何失。若亦证得择灭体者。既于外法无成就义。云何成就彼择灭耶。又契经说当云何通。如说。尊者舍利子言。我断诸爱得内解脱。若外物中不得择灭。契经所说复云何通。如说一切行断故名断界。一切行离故名离界。一切行灭故名灭界。答应作是说。于外物中亦得择灭。问若尔既于外物无成就义云何于彼得择灭耶。答虽于外物无成就者。而亦于彼有得择灭。如不成就过去未来命等八根。而有于彼证得择灭。外物亦尔何所相违。问契经所说复云何通。如说。尊者舍利子言。我断诸爱得内解脱。答说于内蕴得解脱故。当知于外亦得解脱。复次外物解脱依内得故。亦名为内。谓内身中修道方得。复次外物解脱得是内故亦名为内。谓得彼得是内蕴摄。复次断内烦恼而得彼灭故亦名内。谓外物中所有择灭断内能系烦恼方得。是故经言。得内解脱。有余师说。外物中无择灭可得。唯断能系诸烦恼缚得择灭故。问若尔契经所说当云何通。如说。一切行断故名断界。乃至广说。答彼经应说。诸行断故名为断界。乃至广说。不应言一切而说一切者。当知彼说少分一切。谓一切有二种。一少分一切。二全分一切。彼经但说少分一切。有作是说。诸外物中虽有择灭而不可得。评曰。彼不应作是说。宁说为无不应说有而不可得。既不可得何须如是无用灭为应作是说。亦有亦得。所以者何。诸有漏法无始时来烦恼所系不得解脱。若断烦恼彼离系故便得解脱。如人被缚后解脱时人名解脱。非谓绳等。既于所系证得解脱故外物中亦得解脱。若不尔者与品类足所说相违。如说。云何得作证法。答一切善法。若外物中虽有择灭而不可得。应有善法非得作证便违彼说。故外亦有择灭可得。问择灭自性为即是蕴为但蕴无。若即是蕴。有情本来应得解脱。以皆本来成就蕴故。若但蕴无。如何为无勤修圣道。答应说。择灭非即是蕴。亦非蕴无。但于有漏诸蕴中得别有自性

说一切有部发智大毗婆沙论卷第三十一阿毗达磨大毗婆沙论卷第三十二

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中爱敬纳息第四之四

如是择灭亦名涅槃。亦名不同类。亦名非聚。亦名非显。亦名最胜。亦名通达。亦名阿罗汉。亦名不亲近。亦名不修习。亦名可爱乐。亦名近。亦名妙。亦名出离。问何故择灭亦名涅槃。答槃名为趣涅名为出。永出诸趣故名涅槃。复次槃名为臭涅名为无。永无臭秽诸烦恼业故名涅槃。复次槃名稠林涅名永离。永离一切三火三相诸蕴稠林故名涅槃。复次槃名为织涅名为不。此中永无烦恼业缕。不织生死异熟果绢故名涅槃。余如前说。问何故择灭亦名不同类。答无同类因故。亦非同类因故。余如前说。问何故择灭亦名非聚。答离诸聚故。谓说有为无住相者。彼说有为法必四类共聚。谓自体及三相。若说有为有住相者。彼说有为法必五类共聚。谓自体及四相。复次诸界诸趣诸生诸蕴诸世诸苦皆名为聚。择灭异彼故名非聚。问何故择灭亦名非显。答显谓称赞涅槃功德智者极成。不待称赞故名非显。复次涅槃功德无边际故不可称赞。如说。此八技术无边不可称赞故名非显。复次显名毁呰涅槃功德究竟圆满。如末尼珠周圆光净不可毁呰故名非显。复次涅槃功德究竟安住。如末尼珠体无增减。随所置处即便安住不可毁呰故名非显。复次显谓显说涅槃是圣现量所证不可显说故名非显。复次诸有为法有因有果。可得以因显说其果。亦得以果显说其因。涅槃无为无因无果不可显说故名非显复次显谓显示。涅槃寂静无婆罗门刹帝利等种姓差别可以显示。亦无青黄赤白等相可以显示。故名非显。复次显谓显现。诸有为法或体是色其相显现或虽非色而依色转亦可显现。涅槃不然故名非显。问何故择灭亦名最胜。答以上妙故。如世上妙衣服饮食庄严具等名为最胜。涅槃亦尔。尊者妙音作如是说。择灭涅槃于诸法中是最胜法。于诸义中是最胜义。于诸事中是最胜事。于诸理中是最胜理。于诸果中是最胜果。故名最胜。问何故择灭亦名通达。答通达谓慧涅槃是慧果故亦名通达。如九遍知是智果故亦名遍知。亦如六处是业果故说名故业。复次择灭涅槃是通达果故名通达。如天眼耳是通果故亦名为通。问何故择灭亦名阿罗汉。答应受供养故。谓阿罗汉总目应义无有世间上妙供具择灭涅槃不应受者。复次罗汉名应。阿之言不。择灭涅槃于诸界趣不应流转故名不应。复次罗汉名贼。亦名为怨。阿之言无。涅槃中无烦恼怨贼。是故择灭名阿罗汉。问何故择灭亦名不亲近。答离亲近本故。谓有亲近有为法者以贪其果。如贪荫凉花叶果等亲近于树。涅槃无果可令彼贪名不亲近。问何故说涅槃智者应亲近。答智者。谓佛及佛弟子。彼应解了及起得证故名亲近。非贪其果故亦名不亲近。问何故择灭亦名不修习。答不在相续故。若在相续数数现前渐渐增进。名可修习。涅槃不尔故亦名不修习。问若尔颂说当云何通

  乔答摩树下　　静虑不放逸
  不久履道迹　　涅槃在心中

答以涅槃得依心起故名在心中。非谓涅槃有修习义。问何故择灭亦名可爱乐。答圣所爱乐故。谓诸圣者怖畏众苦。涅槃离苦圣者爱乐。复次圣厌生死。彼无生死故圣爱乐。谓涅槃中永离一切流转事故。复次圣厌破戒。彼无破戒故圣爱乐。谓涅槃中永离一切破戒事故。由涅槃故佛说无漏戒。名圣所爱戒。此戒能证得离破戒灭故。由此亦名时爱解脱待时爱乐得涅槃故问何故择灭亦名为近答得圣道者现证得故如契经说。精进成就十五法者。名履学迹及近涅槃。复次不选相续而证得故。择灭名近。谓刹帝利婆罗门等能修道者皆证涅槃。复次不选处所而证得故择灭名近。谓在城邑或阿练若修习圣道皆得涅槃。复次由胜解故择灭名近。谓诸圣者灭忍灭智现在前时。由胜解力如对目前明了观故。复次如近事故择灭名近。谓随在处皆可证得。如品类足说。云何远法。谓过去未来法。云何近法。谓现在法及诸无为。复次依近得故择灭名近。谓现在世说名为近。依现在世起离系得证得择灭故名为近。复次舍近入故择灭名近。谓现在世说名近法。舍此近法而入涅槃。是故涅槃亦名为近。胁尊者曰。勤修道者直趣涅槃。故名为近。复次圣道所依各有差别。涅槃无定故名为近。能修道者皆证得故。问圣道亦妙。如品类足说。云何妙法。谓学无学法及择灭无为。何故涅槃独名为妙。答以涅槃是妙中妙故复次圣道虽妙而杂无常。涅槃不尔故独名妙。复次圣道虽妙有能对治。厌患善法谓空空等。涅槃不尔故独名妙。问圣道亦是出离之法。如品类足说

云何出离法。谓欲界善戒。及色无色界离生善定。并学无学择灭无为。何故涅槃独名出离。答涅槃是出离非有出离故。圣道是出离亦是有出离。般涅槃时出离彼故。复次涅槃是真出离法故。谓有漏法有二种舍。一断舍。二弃舍。无漏有为虽无断舍而有弃舍。唯有择灭二舍俱无。名真出离。复次涅槃是究竟出离功德故。如契经说。以色出离欲以无色出离色。以圣道出离无色。以涅槃出离一切有为法

问已知非择灭体非离系。应说何故名非择灭耶。答不由择慧得此灭故名非择灭。非择果故。复次此灭不由一向劬劳一向加行一向功用简择诸法得故。名非择灭。复次。此灭不要由数数决择苦等得故。名非择灭。问若尔此灭由何而得。答由缘阙故。如对一方。余方所有色声香味触等境灭。于彼能缘心心所法。由缘阙故毕竟不生。由此不生得非择灭。问于何世诸法得非择灭耶。有作是说。于三世诸法皆得非择灭。是有为故。问若尔于何不得此灭。得与不得复有何异有余师说。但于过去未来诸法得非择灭非于现在。以现在法在身行故。问若尔此灭应一一念得已还舍舍已复得。谓未来法入现在时。彼非择灭得已还舍现在诸法入过去时。彼非择灭舍已复得。然非择灭无如是义。或有说者。唯于未来法得非择灭。非过去现在。所以者何。过去诸法已在身行。现在诸法在身行故。问若尔此灭得已应舍。谓未来法入现在时。彼非择灭得已舍故。然非择灭无如是义。评曰。此非择灭唯于未来不生法得。所以者何。此灭本欲遮有为法令永不生。若法不生此得便起。如与欲法系属有情。现在正行过去已行未来当行皆有生义。故于彼法不得此灭问择灭与非择灭何者为多。有作是说。择灭多。非择灭少。所以者何。择灭通于三世法得。非择灭唯于未来不生法得故。有余师说。非择灭多。择灭少。所以者何。非择灭通于有漏无漏法得。择灭唯于有漏法得。评曰。应作是说。非择灭多择灭少。所以者何非择灭如有为法数量。择灭但如有漏法数量故。若不尔者诸可生法若得不生应不得非择灭。二灭自性多少虽尔而依得者。应作四句。有法于彼得择灭不得非择灭。谓过去现在及未来可生有漏法。有法于彼得非择灭不得择灭。谓未来不生无漏法。有法于彼得择灭亦得非择灭谓未来不生有漏法。有法于彼不得择灭亦不得非择灭谓过去现在及未来可生无漏法

问诸有情类。于非择灭为皆共得不共得耶。答此不决定。于共有法非择灭则共得。于不共法非择灭则各别得。诸异生类若住一趣。于余趣法。刹那刹那得非择灭。以色等境念念灭时。缘彼眼识等毕竟不生故。如住一趣。一界一地一处亦尔

问由何善法诸修行者于诸恶趣得非择灭。答或由布施。或由持戒。或由闻慧。或由思慧或由修慧。诸修行者于诸恶趣得非择灭。由布施者。有虽十二年开门大施而于恶趣不得非择灭。如吠逻摩屈路罗等由彼不能厌生死故。有虽于一施一团食而于恶趣得非择灭。由彼深能厌生死故。由持戒者有虽尽寿持别解脱戒而于恶趣不得非择灭。如前说故。有虽能持一昼夜戒而于恶趣得非择灭。如前说故。由闻慧者。有虽具解了三藏文义而于恶趣不得非择灭。如前说故。有虽解了一四句颂而于恶趣得非择灭。如前说故。由思慧者。有虽具思惟外内书论而于恶趣不得非择灭。如前说故。有虽思惟少分观法而于恶趣得非择灭。如前说故。即不净观持息念等及诸念住。由修慧者。有虽具得八地世俗定而于恶趣不得非择灭。如前说故。即是外道猛喜子等。有虽修习少分观门而于恶趣得非择灭。如前说故。即暖顶忍极钝根者。得下品忍时。于诸恶趣皆得非择灭。大德说曰要无漏慧觉知缘起方于恶趣得非择灭。离圣道不能越诸恶趣故。评曰。彼不应作是说。菩萨九十一劫不堕恶趣。岂由以无漏慧觉知缘起。应作是说。或施或戒乃至下忍。皆于恶趣得非择灭。问三恶趣非择灭为一时得。为别得耶。有作是说。必一时得。问若尔天授如何已得二恶趣非择灭非地狱耶。答彼于地狱唯除一生。余一切生与二恶趣皆顿得非择灭。问既除一生。岂非别得。有余师说。施戒闻等。若于恶趣得非择灭。或别或总。顺决择分得必总得。问天授岂不得顺决择分耶。评曰。应作是说忍位总得。前位不定。已说恶趣得非择灭。当说善趣得非择灭。增上忍时唯除欲界人天七生。色无色界一一处各一生。于余一切生皆得非择灭。预流者趣一来果时。不起定者加行道时。于欲六生得非择灭。若起定者要至第六无间道时。于欲六生得非择灭。一来者趣不还果时。不起定者加行道时。于欲一生得非择灭。若起定者要至第九无间道时。于欲一生得非择灭。尔时得欲界一切生择灭。不退法者离初静虑染时。不起定者加行道时。于初静虑二生得非择灭。若起定者要至第九无间道时。于初静虑二生得非择灭尔时于初静虑一切生皆得择灭。若退法者离初静虑染时。若起定。若不起定。俱至第九无间道时。得初静虑一切生择灭。不得非择灭。可退生故。乃至离无所有处染应知亦尔。不退法者离非想非非想处染时。不起定者加行道时。于非想非非想处一生得非择灭。若起定者要至第九无间道时。于非想非非想处一生得非择灭。尔时于一切生皆得择灭。若退法者离非想非非想处染时。不起定者加行道时。于八地生得非择灭。若起定者要至第九无间道时。于八地生得非择灭。尔时于一切生皆得择灭

已说生处得非择灭。当说烦恼得非择灭。增上忍时。于三界见所断烦恼得非择灭。至见道中随无间道得彼择灭。圣于修道不退法者。离欲染时。不起定者加行道时。于欲界修所断烦恼得非择灭。若起定者随至彼彼无间道时得非择灭。尔时得彼烦恼择灭。若退法者离欲染时。若起定。若不起定。随至彼彼无间道时。得彼烦恼择灭。不得彼非择灭。乃至离非想非非想处染。随所应当说。问诸退法者。何时于修所断烦恼得非择灭。有作是说。信胜解练根得见至时。时解脱练根得不动时。于修所断已断烦恼得非择灭。评曰。应作是说。若得决定不复退。起彼烦恼时。于彼烦恼得非择灭。问若时于彼得非择灭。亦得彼择灭耶。答应作四句

有法先得非择灭后得择灭。谓三界见所断烦恼。及不退法者不起定离三界修所断烦恼等。有法先得择灭后得非择灭。谓退法者离三界修所断烦恼等。有法俱时得非择灭及择灭。谓不退法者若起定离三界修所断烦恼等。若退法者离欲界前八品染。随无间道现在前时。彼品染污眼等五识。及相应法等。于现所缘得非择灭及彼择灭离欲界第九品染无间道时。彼品染污及善无记眼等五识。及相应法等。于现所缘得非择灭及彼择灭。离初静虑前八品染。随无间道现在前时。彼品染污眼等三识及相应法等。于现所缘。得非择灭及彼择灭。离初静虑第九品染无间道时。彼品染污及善无记眼等三识。及相应法等。于现所缘得非择灭及彼择灭。有法或时于二灭俱不得。谓除前相

已说烦恼得非择灭。当说圣道得非择灭。随信行者于随法行道得非择灭。随法行者于随信行信胜解时解脱道得非择灭。信胜解者若决定依信胜解道得无学果。于见至道得非择灭。见至者于信胜解时解脱道得非择灭。时解脱者若决定依时解脱道得究竟者。于不时解脱道得非择灭。不时解脱者于时解脱道得非择灭。声闻种性于声闻道得决定时。于佛独觉道得非择灭。独觉种性于独觉道得决定时。于佛声闻道得非择灭。佛种性于佛道得决定时。于独觉声闻道得非择灭。阿罗汉果有六种性退法种性若依退道至究竟者。于上五道得非择灭。思法种性若依思道至究竟者。于上四道及下一道得非择灭。乃至堪达种性若依堪达道至究竟者。于上一道于下四道得非择灭。不动种性于下五道得非择灭。问若胜进时得非择灭。此灭何故非道果耶。答不为此灭而修道故。谓为涅槃及为离染勤修于道。以修道故于恶趣等得非择灭。若为此灭而修道者。于恶趣等不得此灭。非于生死不深厌患可于恶趣得非择灭。故非择灭不名道果。如品类足论说。云何果法。谓一切有为法及择灭。云何非果法。谓虚空非择灭。问非择灭得是何心果。有作是说。此灭得是引众同分心果。有余师说。此灭得是续生心果。评曰。应作是说。随住何心得非择灭。即说此得是彼心果。问于何法得非择灭耶。答于三界系不系法得。生欲界者于四法得。生色无色应知亦然。非择灭得随生何地即彼地系。唯是无覆无记性摄。唯是等流。随所依力起此得故。问非择灭得于何法中渐渐增长。答若生欲界于欲界系五识身等非择灭得渐渐增长。亦有意识定缘现在。于此等法非择灭得亦渐增长。然难知故不别显示。于色界系三识身等及于无量解脱胜处遍处等法。于无色界遍处法中非择灭得渐渐增长。若生色界于欲界系五识身等。非择灭得渐渐增长。于色界系三识身等。及于无量解脱胜处遍处等法。于无色界遍处法中非择灭得渐渐增长。生无色界于欲界系五识身等。于色界系三识身等。及于无量解脱胜处遍处等法。于无色界遍处法中非择灭得渐渐增长。问圣者生色界。于欲色界何法得非择灭耶。答若欲界没生初静虑。除欲界依上地起变化心品及所起法。于余欲界法。及依欲界起色界法。皆得非择灭。若欲界没生第二静虑除欲界初静虑。依上地起上三静虑果变化心品及所起法。并初静虑依上地起四识身等。于余欲界初静虑法。及依欲界初静虑起色界上地法。皆得非择灭。若初静虑没生第二静虑除初静虑。依上地起上三静虑果变化心品及所起法。并初静虑依上地起四识身等。于余初静虑法及依初静虑起上下地法。皆得非择灭。若欲界没生第三静虑。除欲界初二静虑。依上地起上二静虑果变化心品及所起法。并初静虑依上地起四识身等。于余欲界初二静虑法。及依欲界初二静虑起色界上地法。皆得非择灭。若初静虑没生第三静虑。除初二静虑依上地起上二静虑果。变化心品及所起法。并初静虑依上地起四识身等。于余初二静虑法。及依初二静虑起上下地法。皆得非择灭。若第二静虑没生第三静虑。除第二静虑依上地起上二静虑果变化心品及所起法。于余第二静虑法及依第二静虑起上下地法。皆得非择灭若欲界没生第四静虑。除欲界初三静虑。依第四静虑起第四静虑果变化心品及所起法。并初静虑依第四静虑起四识身等。于余欲界初三静虑法。及依欲界初三静虑起第四静虑法。皆得非择灭。若初静虑没生第四静虑。除初三静虑。依第四静虑起第四静虑果变化心品及所起法。并初静虑依第四静虑起四识身等。于余初三静虑法。及依初三静虑起上下地法。皆得非择灭若第二静虑没生第四静虑。除第二第三静虑依第四静虑起第四静虑果变化心品及所起法。于余第二第三静虑法及依第二第三静虑起上下地法。皆得非择灭。若第三静虑没生第四静虑。除第三静虑。依第四静虑起第四静虑果变化心品及所起法。于余第三静虑法。及依第三静虑起上下地法。皆得非择灭。问圣者生无色界。于欲色无色界何法得非择灭耶。答若欲界没生空无边处。于欲色界法及依欲色界起无色界法。皆得非择灭。若初静虑没生空无边处。于四静虑法及依四静虑起上下界法。皆得非择灭。若第二静虑没生空无边处。于后三静虑法。及依上三静虑起上下地法。皆得非择灭。若第三静虑没生空无边处。于后二静虑法。及依上二静虑起上下地法。皆得非择灭。若第四静虑没生空无边处。于第四静虑法。及依第四静虑起上下地法。皆得非择灭。若欲界没乃至生非想非非想处。于欲色界下三无色法。及依欲色界下三无色起有顶法。皆得非择灭。若初静虑没乃至生非想非非想处。于色界下三无色法。及依色界下三无色起上下地法。皆得非择灭。乃至若无所有处没生非想非非想处。于无所有处法。及依无所有处起有顶法。皆得非择灭。问圣者生无色界已得欲色界法非择灭不。答不得。先已得故。问圣者生无色上地已得下地法非择灭不。答不得。先已得故。问为先般涅槃者得非择灭多。为后般涅槃者得非择灭多耶。答前般涅槃者得非择灭多。后般涅槃者得非择灭少。如饮光佛时般涅槃者得非择灭多。能寂佛时般涅槃者得非择灭少。能寂佛时般涅槃者得非择灭多。慈氏佛时般涅槃者得非择灭少。问何等阿罗汉住最后心时。成就非择灭最多。欲界耶。色界耶。无色界耶。答无色界。阿罗汉住最后心时。成就非择灭最多。一切色法不现行故。尔时虽无先未得。今始得非择灭者。而有无量非择灭得犹现在前名多成就。有余于此作问答言。颇有蕴界处不相续永灭。于彼不得非择灭耶。答有。谓无色界阿罗汉住最后心时。虽有无量蕴界处不相续永灭。而于彼毕竟不得非择灭。评曰。彼不应作是说。所以者何。无有蕴界处不相续永灭于彼不得非择灭者。问无色界阿罗汉住最后心时。于不相续永灭蕴界处。岂非不得非择灭耶。答虽非今得而名成就。先已得故。谓无色界阿罗汉若决定般涅槃时。除未来世正起刹那。于余蕴界处皆得非择灭

如契经说。有二涅槃界。谓有余依涅槃界。及无余依涅槃界。乃至广说。问何故作此论。答为广分别契经义故。谓契经说。有二涅槃界。一有余依涅槃界。二无余依涅槃界。契经虽作是说而不广辨。云何有余依涅槃界。云何无余依涅槃界。彼是此论所依根本。彼所不分别者今皆应分别之。复次前说。云何择灭。谓诸灭是离系。此离系是涅槃。然涅槃有二种。一有余依。二无余依。今欲分别此二差别。复次为止他宗显正义故。谓或有执。有余依涅槃界有自性。无余依涅槃界无自性。为遮彼执显二种涅槃界皆有自性。或复有执。有余依涅槃界是有漏。无余依涅槃界是无漏。为遮彼执显二种涅槃界皆是无漏。或复有执。有余依涅槃界是有为。无余依涅槃界是无为。为遮彼执显二种涅槃界皆是无为。或复有执。有余依涅槃界是善。无余依涅槃界是无记。为遮彼执显二种涅槃界皆是善性。或复有执。有余依涅槃界是道非道果。无余依涅槃界是道果非道。为遮彼执显二种涅槃界皆是道果。或复有执。有余依涅槃界是道果。无余依涅槃界非道果。为遮彼执显二种涅槃界俱是道果。或复有执有余依涅槃界是谛摄。无余依涅槃界非谛摄。为遮彼执显二种涅槃界皆是谛摄。或复有执。有余依涅槃界是无学。无余依涅槃界非学非无学。为遮彼执显二种涅槃界皆非学非无学。由此所说种种因缘故作斯论。云何有余依涅槃界。答若阿罗汉诸漏永尽。寿命犹存。大种造色相续未断。依五根身心相续转。有余依故。诸结永尽得获触证名有余依涅槃界。此中寿命者。谓命根。问何故不说众同分耶。答是作论者意欲尔故。乃至广说。复次应说而不说者。当知此义有余。复次以命根众同分俱是牵引业果。命根一向是异熟故。此中偏说。依此有余色心等转。于中大种是所依故。最初说之。依此大种所造色生。依所造色心心所起。心是主故。此中偏说大种造色者总显色身依五根身心相续者显心心所。亦有生等不相应行。难了知故属前法故。不别显说。如是诸法相续未断所得诸结永尽。名有余依涅槃界。有作是说。大种造色是身五根。是根心相续是觉此身根觉相续未断。诸结永尽名有余依涅槃界。如契经说。身根觉未断名有余依涅槃。有余依故者。依有二种。一烦恼依。二生身依。此阿罗汉虽无烦恼依而有生身依。复次依有二种。一染污依。二不染污依。此阿罗汉虽无染污依而有不染污依故。所得诸结永尽名有余依涅槃界。得获触证。文字虽别同显一义。云何无余依涅槃界。答即阿罗汉诸漏永尽。寿命已灭大种造色相续已断。依五根身心不复转。无余依故。诸结永尽名无余依涅槃界。此中寿命已灭者显命根及众同分已灭。俱是牵引业果故。且举命根。当知亦即说众同分大种造色相续。已断者总显色身相续已断。依五根身心不复转者。显心心所不复相续。不说生等义如前说。有作是说。大种造色者显身。五根身者显根。心相续者显觉。如是色身心心所法。或身根觉相续已断。诸结永尽名无余依涅槃界。谓阿罗汉将般涅槃。身中风起令不调适。不调适故内火羸劣。火羸劣故所食不消。食不消故不起食欲。无食欲故不复饮食。不饮食故大种损减。大损减故造色诸根亦随损减根损减故心心所法无所依止不复相续。心心所法不相续故。命根等断。命等断故名入涅槃。无余依故者无二种依。一无烦恼依。二无生身依复次一无染污依。二无不染污依无余依故诸结永尽。名无余依涅槃界。问此中何故不说得获触证言耶。答依现在得说得等言。现在得断是故不说。复次依补特伽罗故施设得获触证。此中无有补特伽罗唯有法性。是故不说。颇有阿罗汉不住有余依涅槃界。及无余依涅槃界耶。答理虽无有而依此中所说亦有。谓此中说具有三事者名有余依涅槃界。三事皆无者名无余依涅槃界。生无色界阿罗汉。无色身故非住有余依涅槃界。有心转故非住无余依涅槃界。生有色界阿罗汉入灭尽定。已无心转故非住有余依涅槃界。有色身故非住无余依涅槃界。生欲界不具根阿罗汉。不具五根故非住有余依涅槃界。有色身故非住无余依涅槃界。有说。此文应作是说。云何有余依涅槃界。答若阿罗汉寿命犹存诸结永尽得获触证。云何无余依涅槃界。答即阿罗汉寿命已灭诸结永尽。若作是说则生三界阿罗汉。若有色身。若无色身。若有心转。若无心转。若具五根。若不具五根。但有寿命皆名住有余依涅槃界。寿命灭已皆名住无余依涅槃界。应作是说。而不尔者是本论师为欲饶益诸弟子众令易解故作如是说。问异生有学所得离系。彼是何等涅槃界摄。答彼非二种涅槃界摄。谓诸异生所得离系。但应名断名离名灭名谛。不名遍知。不名沙门果。不名有余依涅槃界。不名无余依涅槃界。若诸有学所得离系。名断名离名灭名谛。有位名遍知。有位不名遍知。有位名沙门果。有位不名沙门果。不名有余依涅槃界。不名无余依涅槃界。若诸无学所得离系。名断名离名灭名谛名遍知。名沙门果。有时名有余依涅槃界。有时名无余依涅槃界

说一切有部发智大毗婆沙论卷第三十二此卷宋本第七幅已下有三处文。文断义绝。一者第七幅初三行有余师说但(之一便云)答此不决定(等)。二者第八幅十四五行或忍或戒乃至不(之下便云)于过去未来诸法得非择灭(等)。三者第十幅初四行不共得耶(之下便云)忍皆于恶趣得非择灭(等)。今捡国丹二本则宋本错将不共得耶。(之下)答此不决定(乃至)或忍或戒乃至下(等)凡三十六行文进而写之于余师说但(之下)却将说但(之下)于过去未来诸法得非择灭(乃至)不共得耶(等)凡三十五行文退而写之于或戒乃至下(之下)。忍(字之上)又错下字为不字又错重写其忍字致使如是三处文断。今依二本进退而正之。又国本中第九幅十七行乃至下忍(之下)于过去未来得非择灭(乃至)为皆共得不共得耶(等)。凡十二行者亦错重写耳故今不取阿毗达磨大毗婆沙论卷第三十三

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中爱敬纳息第四之五

涅槃当言学耶无学耶非学非无学耶。乃至广说。问何故作此论。答前虽说有二种涅槃界。而未说涅槃为是学为无学为非学非无学。今欲说之。复次为止他宗显正义故。谓或有执涅槃有学有无学有非学非无学。如犊子部。为遮彼执显涅槃唯是非学非无学故作斯论。涅槃当言学耶无学耶非学非无学耶。答涅槃应言非学非无学。学无学义不相应故。谓为异果明了进修故名为学。进修满足更无异果可为进修。是学种类而非即彼故名无学。涅槃于此二义俱无故名非学非无学。有作是说。涅槃有学有无学有非学非无学。如犊子部。彼作是说。涅槃自性有三种相。一学二无学三非学非无学。云何学。谓学得诸结断得获触证。云何无学。谓无学得诸结断得获触证。云何非学非无学。谓有漏得诸结断得获触证彼说有过。如何涅槃三得得故便有三相。一法不应有三种体相即体故。为止彼说故作是言。于此义中涅槃但应言非学非无学。谓于此论无倒义中但应说言涅槃唯是非学非无学性。相常住无变易故。此中论主齐此应止。若作余说唐捐其功。有说。此中应作余说。问答决择理更显故。谓应理论者。辨分别论者。所说有过。显自无失。分别论者所说有二。一说涅槃先是非学非无学后转成学。先是学后转成无学。先是无学复转成学。二说涅槃有三种。谓学者常是学。无学者常是无学。非学非无学者常是非学非无学。若对前说释此文者。而汝说涅槃有学有无学有非学非无学耶者。是应理论者问。重定前宗。若不定他宗说他过失则不应理。答如是者是分别论者答。我说涅槃转变不定可有三种故言如是。汝何所欲诸先以世俗道永断欲贪嗔恚。得非学非无学离系得。彼于四谛未得现观。修习现观得现观已证不还果转成学耶者。是应理论者问。彼修行者先是异生今转成学。或离系得转起学耶。答如是者。是分别论者答。述前所问于理无违故言如是。又汝何所欲诸先以世俗道永断欲贪嗔恚。得非学非无学离系得。后证不还果时即彼离系应转成学者。是应理论者诘。彼所宗恐彼非理印述。寻复以理难言。若彼今时转成学者。先应是学体常住故。未证不还果未有学得。已名为学不应正理。汝何所欲阿罗汉向学诸结断证阿罗汉果。彼转成无学耶者。是应理论者问。彼修行者先是学今转成无学。或离系得转起无学耶。答如是者是分别论者答。述前所问。于理无违故言如是。又汝何所欲阿罗汉向学诸结断证阿罗汉果时。即彼结断应转成无学者。是应理论者诘。彼所宗恐彼非理印述。寻复以理难言。若彼今时成无学者先应是无学体常住故。未证阿罗汉果无无学得。已名无学不应正理。汝何所欲诸阿罗汉无学结断。退阿罗汉果时彼转成学耶者。是应理论者问。彼修行者先是无学。今转成学或离系得转起学耶。答如是者。是分别论者答。述前所问。于理无违故言如是。又汝何所欲诸阿罗汉无学结断。退阿罗汉果时。即彼结断应转成学者。是应理论者诘彼所宗恐彼非理印述。寻复以理难言。若彼今时转成学者。先应是学体常住故。未退阿罗汉果无有学得。已名为学不应正理。若对后说释此文者。而汝说涅槃有学有无学有非学非无学耶者。是应理论者问重定前宗。若不定他宗说他过失则不应理。答如是者是分别论者答。我说涅槃体类差别定有三种故言如是。汝何所欲诸先以世俗道永断欲贪嗔恚。得非学非无学离系得。彼于四谛未得现观修习现观得现观已转成学耶者。是应理论者问。彼修行者先是异生今转成学。或离系得转起学耶。答如是者。是分别论者答。述前所问。于理无违故言如是。又汝何所欲诸先以世俗道永断欲贪嗔恚。得非学非无学离系得。后证不还果时。即彼离系应转成学者。是应理论者难。汝说涅槃随学得成学。今既有学得应转成学。若彼今时转成学者先应是学体常住故者。是分别论者反诘通难我说涅槃学者常是学故。未证不还果未有学得。已名为学不应正理者。是应理论者通彼所诘。重成前难。谓先未证不还果时未有学得。得顺五下分结断。彼结断可不名学。今既有学得得彼结断。何故不名学。若有学得不名学者。不应言涅槃随学得说学。汝何所欲阿罗汉向学诸结断证阿罗汉果。彼转成无学耶者。是应理论者问。彼修行者先是学今转成无学。或离系得转起无学耶。答如是者是分别论者答。述前所问。于理无违故言如是。又汝何所欲阿罗汉向学诸结断证阿罗汉果时。即彼结断应转成无学者。是应理论者难。汝说涅槃随无学得成无学。今既有无学得应转成无学。若彼今时成无学者先应是无学体常住故者。是分别论者反诘通难。我说涅槃无学者常是无学故。未证阿罗汉果无无学得。已名无学不应正理者。是应理论者通彼所诘重成前难。谓先未证无学果时无无学得。得一切结断。彼结断可不名无学。今既有无学得得彼结断。何故不名无学。若有无学得不名无学者。不应言涅槃。随无学得说无学。汝何所欲诸阿罗汉无学结断。退阿罗汉果时彼转成学耶者。是应理论者问。彼修行者先是无学今转成学。或离系得转起学耶。答如是者是分别论者答。述前所问。于理无违故言如是。又汝何所欲诸阿罗汉无学结断。退阿罗汉果时。即彼结断应转成学者。是应理论者难。汝说涅槃随学得成学。今既有学得应转成学。若彼今时转成学者。先应是学体常住故者。是分别论者反诘通难。我说涅槃学者常是学故未退阿罗汉果无有学得。已名为学不应正理者。是应理论者通彼所诘重成前难。谓先未退无学果时未有学得。得见所断及修所断一分结断。彼结断可不名学。今既有学得得彼结断。何故不名学。若有学得不名学者不应言涅槃随学得说学。复次。有别诵言。汝说涅槃唯是非学非无学耶。余如前诵。若依此诵应作是说。此中具有问答难通。谓分别论者问。应理论者答。分别论者难。应理论者通。汝说涅槃唯是非学非无学耶者。是分别论者问。重定前宗。若不定他宗说他过失则不应理答。如是者是应理论者答。我说涅槃唯是非学非无学称理顺经故曰如是。汝何所欲诸先以世俗道永断欲贪嗔恚。得非学非无学离系得。彼于四谛未得现观修习现观得现观。已证不还果。转成学耶者是分别论者问。义如前释。答如是者是应理论者答。义如前释。又汝何所欲诸先以世俗道永断欲贪嗔恚。得非学非无学离系得。后证不还果时。即彼离系应转成学者。是分别论者难。如有为法与得相似。既有学得得彼离系。即彼离系应转成学。若彼今时转成学者。先应是学体常住故者。是应理论者通。诸有为法转变不定。及有作用可随得说。涅槃常住无有作用不随得变。若今时是学先亦应是学恐彼非理印述。寻复以理难言。未证不还果未有学得。已名为学不应正理。此中二文。前遮涅槃转变者说后遮涅槃决定者说。俱显涅槃体常住故。唯是非学非无学性不应名学。汝何所欲阿罗汉向。学诸结断证阿罗汉果。彼转成无学耶者。是分别论者问。义如前释。答如是者是应理论者答。义如前释。又汝何所欲阿罗汉向学诸结断证阿罗汉果时。即彼结断应转成无学者。是分别论者难。如有为法与得相似。既有无学得得彼结断。即彼结断应转成无学。若彼今时成无学者。先应是无学体常住故者。是应理论者通。诸有为法转变不定。及有作用可随得说。涅槃常住无有作用不随得变。若今时是无学。先亦应是无学。恐彼非理印述。寻复以理难言。未证阿罗汉果无无学得。已名无学不应正理。此中二文。前遮涅槃转变者说。后遮涅槃决定者说。俱显涅槃体常住故。唯是非学非无学性。不应名无学。汝何所欲诸阿罗汉无学结断。退阿罗汉果时彼转成学耶者。是分别论者问。义如前释。答如是者是应理论者答义如前释。又汝何所欲诸阿罗汉无学结断退阿罗汉果时。即彼结断应转成学者。是分别论者难。如有为法与得相似既有学得。得彼结断即彼结断。应转成学。若彼今时转成学者。先应是学体常住故者。是应理论者通。诸有为法转变不定。及有作用可随得说。涅槃常住无有作用不随得变。若今时是学先亦应是学。恐彼非理印述。寻复以理难言。未退阿罗汉果无有学得。已名为学不应正理。此中二文。前遮涅槃转变者说。后遮涅槃决定者说。俱显涅槃体常住故。唯是非学非无学性不应名学

复次涅槃不应先是非学非无学。乃至广说。问何故复作此论。答欲令前所说义得明了故。谓前来虽广分别而义意未甚明了。今欲略说他宗有过自宗无失。故作斯论。复次涅槃不应先是非学非无学。后转成学。先是学后转成无学。先是无学复转成学者。遮说涅槃转变不定有三种者意。若尔涅槃随得变易。应无常故不应正理。又涅槃不应有学有无学有非学非无学者。遮说涅槃体类差别有三种者意

若尔涅槃随位差别。有杂乱故不应正理。谓异生位具三得一。至有学位具三得二。至无学位亦具三种。若具得三应有学得。若唯得二应非具足。得涅槃者。若无学位以无学得总得三种。有学等位应亦如是。则不应言学得诸结断名学。无学得诸结断名无学。有漏得诸结断名非学非无学。若言诸位虽各具三。而随得故各但名一。是则涅槃随得转变。应如前说有无常过。是故此说亦不应理。若如是者。应成三分诸法不决定故应有杂乱。是则不应施设诸法性相决定者。总以正理破前二说。谓分别论者。一说涅槃随位不定。一说涅槃三种性定是则涅槃体有常有无常。故成二分。复次。彼后所说。亦随能得有转变义。转变非一故名为二。若不随得而转变者。如何可说涅槃有三。若一涅槃随得转变。则一切法皆应不定。若不决定应有杂乱。若有杂乱不应施设常无常等性相决定。佛亦不说涅槃有学有无学性者。总引圣教破前二说。谓契经中。曾不说涅槃有学有无学故。彼所说决定非理。虽无处说涅槃唯非学非无学。而与学无学义不相应故。定是非学非无学性。以涅槃恒是非学非无学。诸法决定无有杂乱。恒住自性不舍自性涅槃。常住无有变易。是故涅槃但应言非学非无学者。既说他宗有过失已。显自所宗无诸过失。以涅槃唯一种故。诸法性相决定无有杂乱。涅槃常住无有变易。其理善成。此中得义。如后定蕴得纳息中当广分别

如契经说。彼成就无学戒蕴定蕴慧蕴解脱蕴解脱智见蕴。乃至广说。问何故作此论。答为广分别契经义故。如契经说。彼成就无学戒蕴。乃至广说。契经虽作是说而不广分别。云何无学戒蕴乃至解脱智见蕴。彼是此论所依根本。彼所不分别者。今悉应分别之。复次前说道果而未说道。今欲说之。复次前说无为阿罗汉果。未说有为阿罗汉果。今欲说之。复次前说涅槃。未说菩提今欲说之。故作斯论。问亦有成就学蕴或非学非无学蕴。契经何故不说。答应说而不说者。当知此义有余。复次是佛世尊为诸弟子简略之说。复次是佛世尊就胜而说。谓诸法中无学法胜。诸有情中无学有情胜。是故偏说。复次是佛世尊称誉长子。故作是说。谓佛或时称誉长子。或时称誉中子。或时称誉幼子。或时称誉长子者。如伽他说

  阿罗汉最乐　　以永断渴爱
  亦永断诸慢　　坏裂无明网

或时称誉中子者。如佛称誉七善士趣。或时称誉幼子者。如池喻经赞预流果。今称誉长子。故唯说无学。复次。若有戒蕴非恶戒所坏。定蕴非散乱所扰。慧蕴非恶慧所覆。解脱蕴非烦恼所乱。解脱智见蕴非无明所蔽者。此中说之。学及非学非无学蕴。无如是义是故不说。云何无学戒蕴。答无学身律仪语律仪。命清净。谓契经说。无学支中正业即此中身律仪。正语即此中语律仪。正命即此中命清净。经说。此三总名戒蕴。问离身语业无别正命。云何此中建立三种。答以黑白二法相对建立故。谓前七不善业道中。嗔痴所起身业名邪业。嗔痴所起语业名邪语。贪所起身语业名邪命。邪活命故。远离此三名正业正语正命。有说。若为活命故作戏乐事。起不善身语业名邪命。若为余事故起不善身语业名邪业邪语。远离此三名正命等。有说。若为活命故作医咒事。起不善身语业名邪命。若为余事起不善身语业名邪业邪语。远离此三名正命等。有说。若由四种爱。故起不善身语业名邪命。若由余事起不善身语业名邪业邪语。远离此三名正命等。有说。若由谄诳等五。起不善身语业名邪命。若由余事。起不善身语业名邪业邪语。远离此三名正命等。有说。遮罪身语业名邪命。性罪身语业名邪业邪语。远离此三名正命等。有说。加行后起不善身语业名邪命。根本业道不善身语业名邪业邪语。远离此三名正命等。问云何此蕴名曰尸罗。答尸罗者是清凉义。远离破戒热恼事故。复次尸罗者是。习学义。于三学中此在初故。如说。持戒故无悔。乃至广说。无学相续中无漏身语业名无学戒蕴。云何无学定蕴。答无学三三摩地。谓空无愿无相。问定体唯一。谓心所法中三摩地。云何建立三种差别。答以近对治三种障故谓空三摩地近对治有身见。无愿三摩地近对治戒禁取。无相三摩地近对治疑。复次行相别故。谓空三摩地三行相俱即空非我。无愿三摩地十行相俱即苦非常集道各四。无相三摩地四行相俱即缘灭四。复次以三事故。一以对治故。二以意乐故。三以所缘故。以对治故建立空三摩地。谓非我行相对治我见。空行相对治我所见。如我见我所见已见已所见。五我见十五我所见亦尔。复次非我行相对治我爱。空行相对治我所爱。如我爱我所爱。我慢我所慢亦尔。以意乐故建立无愿三摩地。谓诸贤圣由意乐故。不愿有及圣道。所以者何。以诸贤圣由意乐故。不愿流转及蕴世苦圣道。依流转及蕴世苦故。亦不愿缘道行相。虽非不愿。而意乐故立无愿名。问圣者何故修圣道耶。答为涅槃故。谓除圣道。更无异法能得涅槃。故修习之非本意乐。以所缘故建立无相三摩地。谓灭谛中无有十相。故名无相五尘男女三有为相。说名十相。复次以灭谛中无上中下及蕴世相故名无相。灭四行相此为所缘。故名无相。云何无学慧蕴。答无学正见智此诵为善。有异诵言无学八智。谓四法类彼诵太总。尽无生智亦此摄故。有别诵言。无学作意相应极简择法最极简择。广说乃至毗钵舍那复有诵言。无学智见明觉现观彼亦大总。尽无生智亦此摄故。云何无学解脱蕴。答无学作意相应心。已胜解。今胜解。当胜解。谓尽无生无学正见相应胜解此蕴所摄故。非无为解脱。谓一切法中二法名解脱。一者择灭即无为解脱。二者胜解即有为解脱。于境自在立解脱名。非谓离系。云何无学解脱智见蕴答尽智。无生智。问何故此二智名解脱智见蕴。答解脱身中独有此故。最能审决解脱事故。无学慧蕴与解脱智见蕴。有何差别。答无学苦集智是无学慧蕴。缘系缚法故。无学灭道智是无学解脱智见蕴。缘解脱法故。复次无学苦集灭智是无学慧蕴。此缘有漏无为解脱。不缘缘解脱无漏智故。无学道智是无学解脱智见蕴。此缘无漏有为解脱。亦缘缘解脱无漏智故。复次无学苦集道智是无学慧蕴。不缘离系法故。无学灭智是无学解脱智见蕴。缘离系法故。是谓差别者。是谓世俗粗相差别。若说胜义真实差别。应如前说。谓无学正见智是无学慧蕴。尽智无生智是无学解脱智见蕴。复次。对治邪慧是无学慧蕴。对治无知是无学解脱智见蕴。复次若慧猛利推求寻觅。加行不息。是无学慧蕴。若慧不猛不利不推不求不寻不觅加行止息。是无学解脱智见蕴。如是五蕴界者非三界系。地者戒蕴在六地。谓四静虑未至中间。余四蕴在九地谓前六地下三无色。问如是五蕴有上中下品差别不。答一相续中无此差别。异相续有。谓佛上品。独觉中品。声闻下品。复次利根者上品。中根者中品。钝根者下品。有为功德虽有无量。此五最胜故立为蕴

如世尊说。苾刍当知。唯一究竟无别究竟。乃至广说。问何故作此论。答为欲分别契经义故。如契经说。唯一究竟无别究竟。虽作是说而不分别。为是勤勇究竟。为是事成究竟经是此论所依根本。彼不说者今欲说之故作此论。问究竟有二。如何言一。胁尊者言。此二究竟一一唯一故说一言。谓唯有一勤勇究竟。无别有余勤勇究竟。及唯有一事成究竟。无别有余事成究竟。如世尊说。唯有一谛无别第二。彼亦一一唯有一种故说一言。谓唯有一苦谛。无别第二苦谛。乃至唯有一道谛。无别第二道谛。此亦如是。故说一言。有作是说。为遮外道邪道邪解脱故说一言。谓诸外道妄执种种露形自饿卧灰服气随日而转。或唯服水啖果食粪。着粪扫衣卧木砾石。投岩赴火行牛等行。以为真道。佛为遮彼作如是言。彼是邪道愚人所习。真道唯一无别第二真道。即是勤勇究竟。又诸外道妄执种种无身无边意净聚世窣堵波等为真解脱。佛为遮彼作如是言。彼是生处非真解脱。真解脱唯一。谓事成究竟。有余师说。唯有一勤勇究竟能断生死因。唯有一事成究竟能舍生死苦。故说一言非无二种。或有说者。究竟唯一。谓事成究竟。为证此故修勤勇究竟。故说究竟唯一无二。复有说者。外道各于自所宗处起究竟想。佛为遮彼作如是言。恶说法中无真究竟。愚人所习不能永离贪嗔痴故。善说法中有真究竟。智人所习能永出离贪嗔痴故。或复有说。非佛欲显真究竟故说唯一言。但为显示外道过失。谓诸外道互兴诤论。起断见者。执断为究竟。拨常见为非。起常见者。执常为究竟。拨断见为非。为显彼失佛作是言。若断究竟常见应非。若常究竟断见应非。究竟唯一无第二故。所执断常俱非究竟。此中何法名究竟耶。答世尊或时于道说究竟声。或时于断说究竟声。出世因果俱究竟故于道说究竟声者。如世尊说

  一类聪慢者　　不能知究竟
  彼不证道故　　不调伏而死

一类者。谓外道彼实愚痴。自谓聪慧。而生憍慢名聪慢者。究竟者谓勤勇究竟。彼于此究竟不如实知见。名不能知。八支圣道说名为道。彼于此道不能证故。不调伏而死。谓有烦恼生有烦恼而死。不得真实调伏道故。于断说究竟声者。如世尊说

  已到究竟者　　无怖无疑悔
  永拔有箭故　　彼住后边身
  此是最究竟　　无上寂静迹
  清净不死迹　　诸相皆尽故

究竟者。谓事成究竟。已能至彼名已到者。无怖者。谓善通达缘起法故。善修习空解脱门故。不畏恶趣及生死苦。无疑者。谓非如外道住恶律仪及邪智见发起种种犹豫言说疑自所证。无悔者。谓已断遍知戒禁取故及已生起究竟智故无有变悔。有箭者。谓二种有箭。一者爱箭。二者见箭。善修圣道得断遍知弃舍变吐永不复转故名永拔。最后自体名后边身。永断因缘不复更受当来生死。是故说彼住后边身。此是最究竟者。谓事成究竟。对勤勇究竟。超过彼故名最无上寂静迹者。三火息故说名寂静智。立处故说名为迹。迹中胜故说名无上。清净不死迹者。迹如前说。离诸烦恼随烦恼故。说名清净。常住无变故名不死诸相皆尽故者。谓涅槃中烦恼业苦众相寂灭。又契经说有一梵志。名数目连。来诣佛所请问佛曰。乔答摩尊。教授教诫诸苾刍等。彼受教已。皆能证得最极究竟涅槃界不。世尊告曰。此事不定一类能证。一类不能。此亦于断说究竟声。涅槃即是断究竟故。复次有勤勇。有勤勇究竟。有事成。有事成究竟。云何勤勇。云何勤勇究竟。云何事成。云何事成究竟。答异生道是勤勇。非勤勇究竟。彼所得断是事成。非事成究竟。圣者道是勤勇是勤勇究竟。彼所得断是事成是事成究竟。复次。有漏道是勤勇非勤勇究竟。彼所得断是事成。非事成究竟。无漏道是勤勇是勤勇究竟。彼所得断是事成是事成究竟。复次向道是勤勇。非勤勇究竟。彼所得断是事成。非事成究竟。果道是勤勇是勤勇究竟。彼所得断是事成是事成究竟。复次学道是勤勇非勤勇究竟。彼所得断是事成。非事成究竟。无学道是勤勇是勤勇究竟。彼所得断是事成是事成究竟。如契经说。佛告苾刍。有诸外道。虽同施设断知诸取。而彼不能具足施设。谓彼但施设断知欲取见取戒取非我语取。此有何义。问何故作此论。答为广分别契经义故。谓契经说佛告苾刍。有诸外道。乃至广说。契经虽作是说。而不广辨其义。彼是此论所依根本。彼所不说者今悉应说之故作斯论。此中问意有三种别。一问外道实不了知断诸取义。世尊何故说同施设断知诸取。二问外道实不能说断知诸取。世尊何故说彼施设断知三取。三问外道亦能少分断我语取。宁不施设但说断三。于此三中先答中问。谓诸外道实不能说断知诸取。世尊何故说彼施设断知三取。有作是说。此是世尊率尔说法。彼不应作是说。所以者何。世尊说法非全无因。或少因故。谓彼所说是谤世尊。故应遮止诃谏违逆。所以者何。世尊永离无义言故。所说称量必饶益故。依田依器雨法雨故。有大因缘乃说法故。由此世尊所有言说。皆使有情获大利乐。故彼所说是谤世尊。复有说者。此言显彼少分断者。彼不应作是说。所以者何。异生亦有能断少分我语取故。谓彼所说不顺正理。故应遮止诃谏违逆。所以者何。如有异生离欲染位全断欲取。从离欲界乃至无所有处染位。能少分断见取戒取。如是离初静虑乃至无所有处染位。亦能少分断我语取。若少分断便施设者。亦应施设断我语取。故彼所说不顺正理。然佛世尊。为天人等无量大众广说法要。无倒开示令随类解。有诸外道。窃闻佛说蕴界处盖念住乃至觉支等名。或有具足。或不具足。是诸外道若有得闻欲取名者。便作是言。我亦施设断知欲取。若有得闻见取名者。便作是言。我亦施设断知见取。若有得闻戒取名者。便作是言。我亦施设断知戒取。此是论主依胜义答。于理无违不谤佛故。谓薄伽梵未出世时。诸外道等多获名利。佛既出世蔽诸外道。如日出已萤光隐没。名利徒众渐渐减少。便集一处而共议言。乔答摩氏未出世时。世间名利皆属我等。既出世已顿归彼人。然乔答摩无有实德胜于我等。但善经论。形貌端严我等不及。虽彼形貌难可夺之。而其经论易可窃取。我等若得还招名利。复共议言。苏尸摩等聪慧强记若遣往诣乔答摩所。求作门人。彼必为其广说经论。闻已还来为我等说。议已共诣苏尸摩所。慰喻劝之。彼便受教。往诣佛所方便窃法。佛以十力四无所畏。于大众中广说法要。时彼外道邻侧经行。为窃法故其心虚怯。于具足说不能具受。或能具受而不解义。然佛世尊所说法要。或有具足或不具足。于所为事无不具足。如契经说。若诸有情能于内身。住循身观如爪上土。若诸有情不于内身住循身观。如大地土。此经所说。于所为事虽名具足。而于所说名不具足。如契经说。四种念住。此经所说二皆具足。如契经说。六界五盖七觉支等。于所为事虽名具足。而于所说名不具足。如契经说。十八界十盖十四觉支等。此经所说二皆具足。如是佛说。或有具足或不具足。而彼外道不能具受。或虽具受而不解义。随所受持便妄施设。为证此义复引契经。如多苾刍集在一处。有诸外道来作是言。如乔答摩。为诸弟子宣说法要。谓作是说。汝等苾刍应断五盖如是五盖能染污心。令慧力劣损害觉分障碍涅槃。于四念住应善住心。于七觉支应勤修习。我等亦能为诸弟子说此法要。则乔答摩所说法要。与我何别。而今汝等独归彼耶。然彼外道尚不能识五盖名相。况能了达住四念住修七觉支。然窃佛语故作是说。施设断取应知亦然。谓彼外道。与盖俱生与盖俱死。尚不识盖。况知能治念住觉支。为显斯理复引别证。又如外道摩健地迦。不了自身众病所集。刹那不住苦空非我。来诣佛所鼓腹而言。吾今此身既无诸病。应知即是究竟涅槃。彼尚不知无病名相。况能了达究竟涅槃。然窃佛语故作是说。施设断取应知亦然。谓彼外道身无楚痛执为无病。得好饮食执为涅槃。彼尚不知四大调适名为无病。况能了达心调适故名为涅槃。复次彼尚不知无漏圣道名为无病。况能了达究竟道果名为涅槃。但窃佛语妄作是说。施设断取应知亦然。答中问已。次答后问。何缘外道但有施设断知三取非我语取。此问外道亦能少分。断我语取宁不施设答彼于长夜执有真实我及有情命者生者能养育者补特伽罗。彼既执有真实我等。宁肯施设断我语取。谓诸外道执我为宗。若彼施设断我语取。便舍自宗归依他见。故不施设断我语取。复次彼诸外道执有我故怖畏无我如临深坑。故不施设断我语取。复次彼诸外道作如是念。有我故活。若无我者。无命者故便为不活。故不施设断我语取。复次彼诸外道作如是念。我若施设断我语取。同梵行者尚轻贱我舍我而去。何况余人怖畏轻贱。故不施设断我语取答后问已。次答初问说同施设断知诸取。斯有何义此问意言。彼诸外道实不了知断诸取义。世尊何故说同施设断知诸取。答是佛世尊随彼言说。谓彼外道自言了知。世尊述彼非自意说。为证此义故复引经。如世尊说。彼诸外道施设实有。有情断坏然依胜义。无实有情但随彼言。而作是说。此亦如是。故无有过。非述他言。便同彼故

说一切有部发智大毗婆沙论卷第三十三阿毗达磨大毗婆沙论卷第三十四

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中爱敬纳息第四之六

如契经说。有二遍知。谓智遍知及断遍知。乃至广说。问何故作此论。答为广分别契经义故。谓契经说有二遍知。谓智遍知及断遍知。契经虽作是说。而不广辨其义。彼是此论所依根本。彼所不说者此皆应说之。复次前说断知诸取。而未分别断知取义。今欲分别故作斯论。云何智遍知。答诸智见明觉现观。是谓智遍知。此中诸名同显一义。以本论主于诸字义得善巧故作种种说。谓对治无知故名智。对治恶见故名见对治无明故名明。对治邪觉故名觉。对治邪现观故名现观。问此中为说何等智等名智遍知。有作是说。唯说无漏说现观故。所以者何。非世俗智可名现观。复有说者。通说有漏无漏智等名智遍知。所以者何。遍知诸法。契经多说世俗智故。问岂世俗智亦名现观。答明了观察是现观义。世俗智中。有能明了观察法者亦名现观。非唯无漏得现观名。故城喻经作如是说。我未证得三菩提时。如实现观生缘老死。非未证得三菩提时已有观缘起。真实无漏智可名现观。由此故知有世俗智亦名现观。问何等世俗智亦名智遍知。答除胜解作意相应世俗智。余闻思修观自共相。诸世俗智极明了者亦得名现观。亦名智遍知。闻所成慧者。如观十八界自共相等。思所成慧者。如持息念四念住等。修所成慧者。如暖顶忍世第一法等。此及无漏慧俱名智遍知。云何断遍知。答诸贪永断。嗔痴永断。一切烦恼永断。是谓断遍知。问于所缘境能遍知故立遍知。名断无所缘及遍知用何故名遍知。答断是智果故亦名遍知

如阿罗汉。是解果故亦说名解。天眼天耳是通果故亦说名通。内六处等是业果故说名故业。此中亦尔。断是智果亦名遍知。问修所断断是智果故。可说为遍知。见所断断既是忍果。云何名遍知。尊者僧伽茷苏说曰。此是慧果故名遍知。谓遍知有二种。一慧为性。二智为性。彼不应作是说。契经但说有二遍知。一智遍知。二断遍知。智遍知者智为自性。断遍知者断为自性。断是智果故名遍知。未曾有处说慧遍知。遍知是智作用名故。胁尊者曰。应说此断名舍遍知。弃舍生死得此断故。尊者妙音作如是说。应说此断名理遍知。见最胜法最胜义理。得此究竟最胜断故。此二所说皆不了义。俱不释断名遍知故。尊者佛护作如是说。断虽于境无遍知用。而约相说亦名遍知。如过去未来眼。虽不见色而约相说亦得名眼。耳乃至意诸心所等。应知亦然。此亦如是。断是智相故名遍知。彼说非理。所以者何。此断恒无遍知用故。有余师说。忍所断断是世俗智果故亦名遍知。彼说非理。欲界乃至无所有处。是事可尔。有顶地中见所断断。如何可说世俗智果。世俗智于彼无永断用故。又异生位用世俗道断下八地见所断时未名遍知。至见道位立遍知时无世俗智。如何说为世俗智果。复有说者。见所断断是无漏智。士用果故亦名遍知。谓无漏智为断欲界第六无间道证一来果时。通得三界见所断断。欲界六品修所断断为一来果。用无漏智为断。欲界第九无间道证不还果时。通得三界见所断断。及得欲界修所断断。为不还果。金刚喻定现在前时通得三界见修所断断。为阿罗汉果。是故彼断亦名遍知。彼亦不应作如是说。见道六遍知应非遍知故。应作是说。忍是智眷属。是智种族故亦名为智。断是彼果故名遍知。如乔答摩种中生者名乔答摩。此亦应尔。问一身见断亦名遍知。何缘乃说诸贪永断。乃至一切烦恼永断名断遍知。答虽一结断亦名遍知。然此中说圆满遍知。一切结尽方名圆满断遍知故

复次世尊。或时于智说遍知声。或时于断说遍知声。于智说遍知声者。如伽他说

  儒童贤寂静　　能益诸世间
  有智能遍知　　贪爱生众苦
  有智言应作　　不作不应言
  智者应遍知　　有言无作者

多求王因缘是此颂根本。谓昔有王名曰多求。禀性凶暴贪求无厌。劫夺国人所有财宝。于是臣佐议共退之。以其次弟绍继王位。时多求王至国边邑。编草作屦以自存活。如是多时。弟王忽忆。问诸臣曰。大兄何在。诸臣答言。闻在边邑作屦自活。王闻忧恼作是思惟。兄既如是。我今何用居王位耶。即时召来封以一邑。人多附彼食便不供。如是更封二邑三邑乃至半国。犹故无厌。遂复兴兵杀弟自立。时天帝释知已念言。今此恶王不识恩义。我今应往诳而恼之。遂自化作婆罗门像。戴帽披苫执瓶持杖。至彼王所作吉祥言。赞叹咒愿在一面立。王言。梵志。从何所来。婆罗门言。从大海外。王言。海外有何事耶答言。我见有一国土。安隐丰乐多诸人众。奇珍异宝充满其国。王言。我力可得彼不。婆罗门言。往必可得。王复问言。谁相导引。答言。我能。王言。几日当可进途。婆罗门言。却后七日。言已便去。时多求王招集兵众。办诸资具至第七日。严驾将行。觅婆罗门竟不能得。王遂忧恼作是念言。彼若来者当得大利。坐失彼故所期不获遂入忧室烦冤而坐。举国无人解其愁毒。时释迦菩萨生彼国中大婆罗门村。少因缘故来至王都。闻如是事心生悲愍。谓诸臣曰。吾能解王心中愁结。诸臣欢喜引至王前。以吉祥言赞叹咒愿在一面立。为王宣说义品伽他

  趣求诸欲人　　常起于悕望
  所欲若称遂　　心便大欢喜
  趣求诸欲人　　常起于悕望
  所欲若不遂　　恼坏如箭中

如是次第为王尽说彼义品中呵欲颂已。即时菩萨自离欲染。王闻遂解心中忧毒。即为菩萨而说初颂。儒童贤寂静。乃至广说。此颂义显无劳分别。菩萨为王说第二颂。有智言应作。乃至广说。此颂前半呵责帝释。谓有智者说许他言必定应作。若不欲作便不应言。后半责王。谓有智者应当遍知若有发言而不作者欲相扰恼。然无实事。王何专直信彼虚言。谁当有能海外来者。谁复能往海彼岸耶。愿王勿求分外之事。于断说遍知声者。如契经说。佛告苾刍。当为汝说所遍知法遍知自性能遍知者。所遍知法。谓五取蕴。遍知自性。谓贪永断。嗔痴永断。一切烦恼永断。能遍知者。谓阿罗汉诸漏永尽。不执如来死后有等不应记法。此中所遍知法谓五取蕴者。问依何遍知而作是说。为智遍知。为断遍知。设尔何失。若依智遍知说。则应说一切法为所遍知。何故但说五取蕴。是若依断遍知说亦不应理。以五取蕴通二遍知。所遍知故不应但说依断遍知。有作是说。此中但依智遍知说。问若尔则应说一切法为所遍知。何故但说五取蕴是。答如四谛中。但说苦谛为应遍知。彼释所以即是此因。有余师说。此中但依断遍知说。问此五取蕴通二遍知。所遍知故不应但说依断遍知而作是说。答如四谛中。但说灭谛是应作证。释彼所以即是此因。此中复有一不共因。谓断遍知唯于取蕴可得。非余遍知自性。谓贪永断嗔痴永断一切烦恼永断者。问余契经说。一切行断离灭名断离灭界。一切行者。即是一切有漏之法。何故此中但说一切烦恼永断名断遍知。答彼经了义是无余说。此不了义是有余说。谓世尊说。烦恼为先诸有漏法皆永断故。复次以诸烦恼难断难破难可超越故偏说之。复次以诸烦恼多诸过患。迷失正理障碍涅槃及诸圣道。是故偏说。复次以诸烦恼是自性断断已不成就。余有漏法非自性断断已犹成就。是故偏说烦恼永断。复次以诸烦恼正与圣道展转相违。余有漏善无覆无记即不如是是故偏说。如灯与闇展转相违。非器油炷。然灯生时正能破闇。亦令器热油尽炷燋。如是圣道与诸烦恼互相违故。圣道现前正断烦恼。亦令所余有漏法断。彼与烦恼同对治故能遍知者谓阿罗汉。乃至广说。问有学亦是能遍知者。何故但说阿罗汉耶。答就胜说故。谓无学法于诸法中。最为殊胜。无学补特伽罗于诸补特伽罗中最为殊胜。是故偏说。复次学虽遍知未能遍断。无学遍知亦能遍断。是故偏说。复次此中但说断遍知者。无学于此圆满究竟。有学不尔。是故偏说。复次以遍断故名断遍知。有学不尔。是故不说。复次前说一切烦恼永断名断遍知。今说成就此遍知者唯阿罗汉。诸归依佛者何所归依乃至广说。问何故作此论。答为于非所归依处起归依想者。显示真实归依处令舍彼归此。如契经说

  众人怖所逼　　多归依诸山
  园苑及丛林　　孤树制多等
  此归依非胜　　此归依非尊
  不因此归依　　能解脱众苦
  诸有归依佛　　及归依法僧
  于四圣谛中　　恒以慧观察
  知苦知苦集　　知永超众苦
  知八支圣道　　趣安隐涅槃
  此归依最胜　　此归依最尊
  必因此归依　　能解脱众苦

复次。为于归依有愚惑者。令得正解无犹豫故。谓或有谓。归依佛者。归依如来头项腹背。及手足等所合成身。今显此身父母生长是有漏法非所归依。所归依者谓佛无学成菩提法即是法身。或复有谓。归依法者归依三谛。或善不善无记等法。或为苾刍所制学处。谓此应作不应作等。今显此法。有为有漏非所归依。所归依者。谓唯灭谛爱尽涅槃。或复有谓。归依僧者。归依四姓出家之僧。今显此僧威仪形相。皆是有漏非所归依。所归依者。谓成僧伽学无学法。由此因缘故作斯论。诸归依佛者。何所归依。答若法实有现有想等想施设言说。名为佛陀归依彼所有无学成菩提法名归依佛。此中若法实有者。显实有佛体以法为自性。此言为遮。或有谓。佛但名但想但假施设无有实体。现有者。显佛体如现实有非曾有。等想者显缘佛想等。想者显此想一切共起。施设者谓依想施设名。言说者谓依名言说转。问若彼无学成菩提法是真佛者。契经所说当云何通。如说。长者何名为佛。谓有释子剃除须发披服袈裟正信出家。具一切智是名为佛。答以所依身显能依法。故作是说于理无违。问若尔恶心出佛身血。何故彼得无间罪耶。答坏所依身。令能依法亦随坏故。得无间罪。复次彼缘无学成菩提法。起恶心故得无间罪。谓彼憎恶无学法故损害佛身得无间罪。非但起心欲出身血。诸归依法者何所归依。答若法实有现有想等想施设言说。名为达磨归依。如是爱尽离灭涅槃。名归依法。此中若法实有者。显实有涅槃。此言为遮有作是说。唯众苦灭说名涅槃非实有体。欲显涅槃实有自体故作是说。现有者。显涅槃如现实有非假说有。余如前释。有本但言。归依爱尽离灭涅槃名归依法。不说实有现有等言。斯有何义。谓涅槃体寂灭离相。想名言说所不及故。无有于中执为非有。此不应理。邪见拨无寂灭涅槃现可得故。此但应说。诵者遗忘。诸归依僧者何所归依。答若法实有现有想等想施设言说。名为僧伽归依。彼所有学无学成僧伽法。名归依僧。此中若法实有者。显实有僧体以法为自性。此言为遮或有谓。僧但名但想但假施设无有实体。现有者。显僧体如现实有非曾有等。余如前释。问何者所归依。何者能归依。归依是何义。答所归依者。谓灭谛全道谛少分。谓除菩萨二无漏道。及除独觉三无漏道。所余道谛是所归依。能归依者。有说。是名等。有说。是语业。有说。亦身业。有说。是信。应作是说。是身语业及能起彼心心所法。并诸随行如是善五蕴是能归依体。归依义者。谓救护义。是归依义问若救护义是归依义。天授亦曾归依三宝。云何复堕无间地狱。答诸有归依佛法僧宝。不破学处。不犯律仪。不越法则。便能救护。彼破学处。毁犯律仪。违越法则。虽归依三宝而不为救护。譬如有人怖畏怨敌。依投国王请为救护。王谓之曰汝若常能不违我法不越我界。我能为汝常作救护。若违我法越我界者。我则不能。众生亦尔。怖畏恶趣及生死苦。归佛法僧若不毁戒。勤修道者便为救护。余则不尔复次随归依心上中下品。还蒙三宝尔所救护是故天授唯除地狱人趣一生。于余恶趣善趣生死得非择灭。岂非三宝救护彼耶。故救护义是归依义。问归依佛者为归依一佛。为一切佛耶。设尔何失。若归依一佛者。如何不是少分归依。若归依一切佛者。如何但言我归依佛。不言一切。契经所说复云何通。如说。我是胜观如来弟子。我是顶髻如来弟子。乃至我是能寂如来弟子。答应作是说。归依佛者。归依一切过殑伽沙数量诸佛。问若尔何故但言我归依佛。不言一切。答佛言总摄一切如来。种类同故以一言说问契经所说复云何通。如说。我是胜观弟子。乃至广说。答。随依彼佛出家见谛。即说我为彼佛弟子。此说依止不说归依。问归依法者。为归依自相续诸蕴灭。为归依他相续诸蕴灭。为归依无情数诸蕴灭耶。设尔何失。若但归依自相续诸蕴灭者。如何不是少分归依。若亦归依他相续等诸蕴灭者。如何但言我归依法。不言一切。又如何说救护义是归依义。他相续等诸蕴灭。于我无救护义故。答应作是说。归依自他相续及无情数一切蕴灭。问若尔何故但言我归依法。不言一切。答法言总摄一切法灭。种类同故以一言说。问他相续等诸蕴灭于我无救护义。何为归依。答彼虽于我无救护义。而彼于他有救护义。救护相等。故亦归依此依得说

若依自性随有漏法有尔所故。自他所得灭无有异。我于一切有漏蕴中得离系故。一切灭于我皆有救护义。问归依僧者。为归依一佛弟子。为归依一切佛弟子耶。设尔何失。若但归依一佛弟子者。如何不是少分归依。若归依一切佛弟子者。如何但言我归依僧。不言一切。又契经说当云何通。佛告贾客。当来世有僧。汝亦当归依。答应说归依一切佛弟子。问若尔何故但言我归依僧。不言一切。答僧言总摄诸佛弟子。种类同故以一言说。问契经所说。复云何通。佛告贾客。乃至广说。答过去现在虽亦有余如来弟子而非现见。当来僧现见是故偏说。解憍陈那等世现见故。复次为显僧宝极难得故。谓佛虽出世间而僧犹未有故。复次未来世僧非现见。故佛偏说有令贾客等生渴仰故。复次现在过去虽有余僧。而佛欲显未来世中自有弟子。故作是说。复次经说亦言。即显亦有余佛弟子令彼归依。恐彼谓无未来僧宝故佛为说令亦归依。问何趣何处有此归依。答归依有二种。一与律仪俱。二不与律仪俱。与律仪俱者。唯在人趣三洲非余。不与律仪俱者通余趣处。问若不受归依而受律仪。彼得律仪不。有说不得。以受律仪者必依三归。以三归为门得律仪故。有说亦得。谓若不知三归律仪受之先后。或复忘误。不受三归者受得律仪。而授者得罪。若有憍慢不受三归但受律仪。彼必不得。问为要自起语表受归依者乃得归依。为他语表受归依者亦得归依。有作是说。要自语表受归依者乃得归依。问若尔契经所说当云何通。谓薄伽梵临涅槃时。阿难白佛。拘尸城中有诸力士及其眷属。皆共归依佛法僧宝。有作是说。佛神力故临涅槃时。寄他语表受三归者亦得归依。余时不得。要须自受。有余师说。尊者阿难先入拘尸城。为诸力士等受三归已。后方白佛。欲显世尊临般涅槃犹有无量受化弟子。故作是说。非由今时。阿师白佛。方得归依。复有说者。由他语表受三归者亦得归依。如迦尸迦女及余哑者等。寄他语表得归依故

问有在母胎。或婴孩位。母等为受三归律仪。彼为得不。答彼无心故。虽俱不得然应为受。令彼后时顺修善故。谓彼长大若毁三宝。或造恶业。他便责言。汝在胎中或婴孩位。先既已受三归律仪。如何今时。轻毁三宝造诸恶业。彼闻惭愧。敬重三宝离诸恶业。复更受持。有此益故先应为受复次为令天神拥护彼。故母等为受三归律仪。谓为受已信敬三宝。诸天善神必拥护彼。不令横死不遭病难。问彼前生中修何善业。今在母腹或婴孩位。他便为受三归律仪。答彼前生中。恒乐赞叹三归净戒。亦劝无量百千有情。归依三宝及受净戒。或复施他受持三归律仪资具。令身获得如是善利。如契经说。归依佛者。不堕恶趣生天人中。受诸快乐。问现见世间归依佛者。亦堕恶趣或受众苦。何故世尊作如是说。答若增上心不顾身命。归依佛者得此善利。不说一切故不相违。有余师说。此依已得证净者说。不说一切。问佛依法生。法胜于佛。何故先说归依佛耶。答佛为教主。若佛不说法不显现。故先归佛。复次如有病者。先访良医。次求妙药。后觅看者。佛如良医。法如妙药。僧如善巧看服药人。故三归依如是次第

    杂蕴第一中无惭愧纳息第五之一

云何无惭。云何无愧。如是等章及解章义既领会已。次应广释。问何故作此论。答为广分别契经义故。谓契经说。无惭无愧。虽作是说而不广办。云何无惭云何无愧。经是此论所依根本。彼所不分别者今应广分别之。复次为令疑者得决定故。谓此二法展转相似。世间有情。见无惭者言是无愧。见无愧者言是无惭。勿谓此二其体是一。今欲显示性相差别。令彼疑者得决定解。复次如是二法唯是不善。亦是施设不善胜因。如说。何缠相应心品一向是不善。谓无惭无愧。今显其相令速厌断。复次如是二法破坏世间。如世尊说。有二黑法能破坏世间。谓无惭无愧。今显其相令速厌断

复次如是二法能令众生种种差别。如契经说。世间若无无惭无愧。无猪犬等种种差别。今显其相令速厌断故作斯论。云何无惭。答诸无惭。无所惭无异惭。无羞无所羞无异羞。无敬无敬性。无自在无自在性。于自在者无怖畏转是谓无惭。此本论主于异名义得善巧故作种种说。文虽差别而体无异。问此中所说差别名言。为显自性。为显行相为显所缘。有作是说。此显无惭自性。问若尔无惭行相云何。答如诸不善心心所法行相。此行相亦尔。所以者何。彼相应故。问无惭所缘云何。答四圣谛。有余师说。此显无惭行相。此行相对余应作四句。有无惭非无惭行相转。谓无惭作余行相转。有无惭行相转非无惭。谓无惭相应法。作无惭行相转。有无惭亦无惭行相转。谓无惭作无惭行相转。有非无惭亦非无惭行相转。谓若取此种类应说无惭相应法作余行相转。若不尔者应说除前相。如说转有四句。已转当转应知亦尔。如无惭行相有三四句诸余行相应知亦尔。问若尔无惭自性云何。答自体自相即彼自性。如说诸法自性即是诸法自相。同类性是共相。问无惭所缘云何。答四圣谛。复有说者。此显无惭所缘。谓诸无惭无所惭无异惭无羞无所羞无异羞者。说缘苦集谛。无敬无敬性无自在无自在性于自在者无怖畏转者。说缘灭道谛自性行相皆如前说。云何无愧。答诸无愧无所愧无异愧无耻无所耻无异耻。于诸罪中不怖不畏不见怖畏是谓无愧。此本论主于异名义得善巧故作种种说。文虽差别而体无异。问此中所说差别名言为显自性。为显行相。为显所缘。有作是说。此显无愧自性问若尔无愧行相云何。答如诸不善心心所法行相。此行相亦尔。所以者何。彼相应故。问无愧所缘云何。答四圣谛。有余师说。此显无愧行相。此行相对余应作四句。有无愧非无愧行相转。谓无愧作余行相转。有无愧行相转非无愧。谓无愧相应法作无愧行相转。有无愧亦无愧行相转。谓无愧作无愧行相转。有非无愧亦非无愧行相转。谓若取此种类。应说无愧相应法作余行相转。若不尔者应说除前相。如说转有四句。已转当转应知亦尔。如无愧行相有三四句。诸余行相应知亦尔。问若尔无愧自性云何。答自体自相即彼自性。如说诸法自性即是诸法自相同类性是共相。问无愧所缘云何。答四圣谛。复有说者。此显无愧所缘。谓诸无愧无所愧无异愧无耻无所耻。无异耻者说缘灭道谛。于诸罪中不怖不畏不见怖畏者说缘苦集谛。自性行相皆如前说。无惭无愧有何差别。答于自在者无怖畏转是无惭。于诸罪中不见怖畏是无愧。如是差别。问何故复作此论。答阿毗达磨说。此二法展转相应其相相似。今欲分别无惭无愧性相差别故作此论。谓于自在者无怖畏转是无惭。于诸罪中不见怖畏是无愧。复次不恭敬是无惭。不怖畏是无愧。复次不厌贱烦恼是无惭。不厌贱恶行是无愧。复次作恶不自顾是无惭。作恶不顾他是无愧。复次作恶不自羞是无惭。作恶不耻他是无愧。复次作恶不羞耻是无惭。作恶而傲逸是无愧。复次独一造罪而不羞耻是无惭。对他造罪而不羞耻是无愧。复次若对少人造罪而不羞耻是无惭。若对众人造罪而不羞耻是无愧。复次若对恶趣有情造罪而不羞耻是无惭。若对善趣有情造罪而不羞耻是无愧。复次若对愚者造罪而不羞耻是无惭。若对智者造罪而不羞耻是无愧。复次若对卑者造罪而不羞耻是无惭。若对尊者造罪而不羞耻是无愧。复次若对在家者造罪而不羞耻是无惭。若对出家者造罪而不羞耻是无愧。复次若对非亲教轨范造罪而不羞耻是无惭。若对亲教轨范造罪而不羞耻是无愧。复次若作恶时不羞天者是无惭。若作恶时不耻人者是无愧。复次于诸恶因不能诃毁是无惭。于诸恶果不能厌怖是无愧。复次贪等流是无惭。痴等流是无愧。是谓无惭无愧差别。如是二法唯欲界系。唯是不善。一切不善心心所法皆遍相应唯除自性。问无惭无愧既唯不善过患深重。何故不立随眠性中。答此二无有随眠相故。谓微细烦恼是随眠相。此二粗动故非随眠。复次猛利烦恼是随眠相。此非猛利故非随眠。复次若不数起起已长时相续烦恼是随眠相。此二数起起已不长时相续故非随眠。复次厚重烦恼是随眠相。此二轻薄故非随眠。复次习气坚固难灭烦恼是随眠相。如刚炭火所在之处热势难息此亦如是。此二习气嚣虚易灭故非随眠。如草叶火所在之处热势易息此亦如是。复次根本烦恼是随眠相。此二既是随烦恼摄故非随眠。是贪无明等流果故

说一切有部发智大毗婆沙论卷第三十四阿毗达磨大毗婆沙论卷第三十五

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中无惭 愧 纳息第五之二

云何惭云何愧乃至广说。问何故作此论。答为广分别契经义故。谓契经说有惭有愧。虽作是说而不广辨。云何为惭云何为愧。经是此论所依根本彼所不分别者今应广分别之。复次欲令疑者得决定故。谓此二法展转相似。世间有情见有惭者言是有愧。见有愧者言是有惭。勿谓此二其体是一。今欲显示性相差别令彼疑者得决定解。复次前虽已说无惭无愧而未说彼近对治法。今欲说彼近对治法所谓惭愧。复次如是二法唯是善性亦是施设善法胜因。如说何法相应心品一向是善。谓惭与愧欲显其相令勤修习。复次如是二法守护世间。如世尊说有二白法能护世间。谓惭与愧。若无此二是则应无善趣解脱。欲显其相令勤修习。复次如是二法能令有情种种差别。所谓父母兄弟姊妹男女眷属尊卑长幼。若无此二如牛羊等。便无尊卑长幼差别。欲显其相令勤修习故作斯论

云何惭。答诸有惭有所惭有异惭。有羞有所羞有异羞。有敬有敬性。有自在有自在性。于自在者有怖畏转。是谓惭。此本论主于异名义得善巧故作种种说。文虽差别而体无异。问此中所说差别名言。为显自性。为显行相。为显所缘。有作是说。此显惭自性。问若尔惭行相云何。答如一切善心心所法行相此行相亦尔。所以者何。彼相应故。问惭所缘云何。答一切法。有余师说。此显惭行相。此行相对余应作四句。有惭非惭行相转。谓惭作余行相转。有惭行相转非惭谓惭相应法作惭行相转。有惭亦惭行相转。谓惭作惭行相转。有非惭亦非惭行相转。谓若取此种类应说惭相应法作余行相转若不尔者应说除前相。如说转有四句。已转当转应知亦尔。如惭行相有三四句诸余行相应知亦尔。问若尔惭自性云何。答自体自相即彼自性。如说诸法自性即是诸法自相。同类性是共相。问惭所缘云何。答一切法。复有说者。此显惭所缘。谓诸有惭。有所惭有异惭有羞有所羞。有异羞者说缘苦集谛。有敬有敬性有自在有自在性。于自在者有怖畏转者说缘灭道谛。自性行相皆如前说

云何愧答诸有愧。有所愧有异愧。有耻有所耻有异耻。于诸罪中有怖有畏深见怖畏是谓愧。此本论主于异名义得善巧故作种种说。文虽差别而体无异。问此中所说差别名言为显自性。为显行相。为显所缘。有作是说。此显愧自性。问若尔愧行相云何。答如一切善心心所法行相此行相亦尔。所以者何。彼相应故。问愧所缘云何。答一切法。有余师说。此显愧行相。此行相对余应作四句。有愧非愧行相转。谓愧作余行相转。有愧行相转非愧。谓愧相应法作愧行相转。有愧亦愧行相转。谓愧作愧行相转。有非愧亦非愧行相转。谓若取此种类应说愧相应法作余行相转。若不尔者应说除前相。如说转有四句。已转当转应知亦尔。如愧行相有三四句。诸余行相应知亦尔。问若尔愧自性云何。答自体自相即彼自性如说诸法自性即是诸法自相。同类性是共相。问愧所缘云何。答一切法。复有说者。此显愧所缘。谓诸有愧有所愧有异愧有耻有所耻有异耻者。说缘灭道谛。于诸罪中有怖有畏深见怖畏者说缘苦集谛。自性行相皆如前说。惭愧何差别。答于自在者有怖畏转是惭。于诸罪中深见怖畏是愧。如是差别。问何故复作此论。答阿毗达磨说此二法展转相应其相相似。今欲分别惭愧二种性相差别故作此论。谓于自在者有怖畏转是惭。于诸罪中深见怖畏是愧。复次有所恭敬是惭。有所怖畏是愧。如是次第与前所说无惭无愧差别相违应随广说。如是二法俱三界系及不系。唯是善遍与一切善心相应。问若尔施设论说当云何通。如说七力几有漏几无漏。答二。唯有漏。谓惭愧。五通有漏无漏。谓信等答彼论应说七力皆通有漏无漏。而不尔者有别意趣。谓彼说力加行根本。加行位中惭愧增故说唯有漏。根本位中信等增故说通二种。若不尔者圣道应不与惭愧相应。则圣者不应惭愧增上是故惭愧定通无漏。或有无惭似惭而转。谓作恶时有羞如嫁娶等。或复有惭似无惭转。谓作善时无羞如行施等。或有无惭似无惭转。谓作恶时无羞如屠猎等。或复有惭似惭而转。谓作善时有羞如悔过等。或有无愧似愧而转。谓作恶时有耻如嫁娶等。或复有愧似无愧转。谓作善时无耻如行施等。或有无愧似无愧转。谓作恶时无耻如屠猎等。或复有愧似愧而转。谓作善时有耻如悔过等

云何增上不善根。云何微俱行不善根乃至广说。问何故作此论。答为广分别契经义故。如契经说彼犹有微俱行不善根未断。从此有余不善法生由是当退。契经虽作是说而不广辨其义。亦不说云何增上不善根。云何微俱行不善根。经是此论所依根本彼所不分别者今应广分别之故作斯论。问何故此中不说中品不善根耶。答是作论者意欲尔故乃至广说。复次应说而不说者当知此义有余。复次已说初后即已显中。如初后上下趣入已出加行究竟应知亦尔。复次若粗现易了易可施设易显易说者此中说之。中品不尔是故不说。谓利根者如指鬘等。钝根者如蛇奴等。粗现易了易可施设易显易说中根不尔。复次中品摄在上下品中故不别说。谓说上品时中在下品劣于上故。说下品时中在上品胜于下故。复次上下品少世所希奇是以故说。中品极多非希奇故略而不说。云何增上不善根。答诸不善根能断善根及离欲染时最初所舍。问诸不善根能断善根者。为即是离欲染时最初所舍。为有异耶。设尔何失。若即是者如何言及。若有异者能断善根诸不善根何时当断。有说即是问若尔者如何言及。答义有异故。谓增上不善根极猛利故能断善根。极粗重故离欲染时最初而舍。复次此不善根由二义故说名增上。一能断灭诸善根故。二离欲染时最初所舍故。有说有异。问若尔者能断善根诸不善根何时当断。答离欲染时最初当断。问如何有异。答多少有异。谓能断善根者少。最初所舍者多。非离欲时最初所断一切皆能断善根故。问唯有邪见能断善根。何缘乃说不善根耶。答虽根本时由邪见断而加行位由不善根。显加行时势用胜故说不善根能断善根。谓染净法皆加行时势用增上非究竟时。如说菩萨见老病死逼恼世间深心厌离。最初发起阿耨多罗三藐三菩提心。由此心故经三大劫阿僧企耶。修集种种难行苦行而无退转。此甚为难非尽智时。修未来世三界所系增上善根故加行时势用为胜。有作是说。邪见所以能断善根当知皆是不善根力。谓不善根摧伏善根令渐羸劣无势力已。然后邪见乃能断之故作是说。复有说者。此说邪见相应痴不善根能断善根不说前位贪等。虽实邪见能断善根尔时痴增故作是说如念住等。有余师说。此中但说痴不善根转。随转时俱增上故。谓贪嗔转时增上非随转时。邪见随转时增上非于转时。唯痴一切时增上是故偏说。即由如是所说因缘不立邪见为不善根。云何微俱行不善根。答诸不善根离欲染时最后所舍。由舍彼故名离欲染。谓欲界下下品贪嗔痴名微俱行不善根。故舍彼时名离欲染微细难断故最后离

问邪见断善根时为作一品断为作九品断耶。设尔何失。若作一品断者何故前说诸不善根能断善根。诸言所表非唯一故。次后所说复云何通。如说云何微俱行善根。答断善根时最后所舍。若作九品断者。云何前说诸不善根能断善根。离欲染时最初所舍名增上不善根耶。如何一品所断邪见能作九品断善根耶。如何一品邪见所断而名九品所断善耶。有作是说作一品断。问若尔何故前说诸不善根能断善根。答前文但应说不善根能断善根。不应说诸。而说诸者。欲显断善邪见相应痴不善根。未来种类有多刹那故作是说。复次正断善时虽无多品而加行位品类有多。所说诸言通显加行伏断正断俱名断故。问次后所说复云何通。如说云何微俱行善根。答断善根时最后所舍。答依现行断故作是说。谓下下品邪见现前令上上品善根不行。如是乃至若上中品邪见现前。令下中品善根不行。若上上品邪见现前。令下下品善根不行。及令九品皆不成就。故前八品善根先得不现行。后得不成就。第九品善根得不现行时即得不成就以渐次得不现行故。后作是说断善根时最后所舍名微俱行善根。以一时得不成就故。前作是说离欲染时最初所舍名能断善增上不善根。是故前后二说善通。应作是说。作九品断。问若尔云何前说诸不善根能断善根。离欲染时最初所舍名增上不善根乃至广说。答有多种九品。谓有现行九品。有异熟九品。有对治九品。有断善根九品。现行九品者。谓有时下下品现行。乃至有时上上品现行。有即说此为因九品。谓加行得者下下品为九品因。乃至上中品为二品因。上上品但为上上品因。劣为胜因。非胜劣因。非所尚故。非加行得者九品皆得展转为因。异熟九品者。谓上上品业受上上品异熟。乃至下下品业受下下品异熟。如施设论说。若作杀生罪上上者生无间地狱。上中者生大热地狱。乃至下下者生傍生鬼趣。乃至广说。对治九品者。谓下下品明断上上品无明。乃至上上品明断下下品无明。断善根九品者。谓下下品邪见断上上品善根。乃至上上品邪见断下下品善根。若依断善九品说者。彼邪见则有九品。若依对治九品说者。彼邪见则唯一品以对治九品故。前说离欲染时最初所舍。以断善九品故后说断善根时最后所舍。是故前后二说善通。复次断法有二种。一如见所断是故能断九品邪见。离欲染时一品顿断。二如修所断是故所断九品善根断善根时九品渐断。问断善根者是何义耶。答非如世间斧等断木。邪见与善不相触故。然相续中邪见现在前时。令诸善根成就得灭不成就得生说名为断。若相续中无善根得尔时名为善根已断。问此善根断自性是何。有作是说。以不信为自性。谓信故善根续。不信故善根断。有余师说。以邪见为自性。谓由邪见善根断故。或有说者。以断善时诸烦恼缠为自性。谓由彼力善根断故。复有说者。以一切法为自性。谓断善根时一切法皆随顺故。譬喻者言。无实自性。谓彼相续先有善根。今时断灭有何自性。所引现喻如顶中说。评曰应作是说。诸善根断以不成就为自性。是无覆无记心不相应行蕴所摄。此即说在复有所余如是类法不相应中。问何界趣处能断善根。答在欲界。非色无色界。人趣非余趣。三洲除北洲。尊者瞿沙伐摩说曰。唯赡部洲能断善根。以此洲人于善恶业所作猛利非余洲故。问若尔根蕴所说当云何通。如说赡部洲人极多成就十九根。极少成就八根。如赡部洲。东胜身洲西牛货洲亦尔。答彼文应说东西洲人极多成就十九根极少成就十三根。而不作是说者应知是诵者错谬。评曰彼不应作是说。一切所诵皆无异故。三洲所作皆猛利故应知前说于理为善。问何等补特伽罗能断善根。答唯见行者能断善根。非爱行者。以见行者意乐坚固于善恶业所作猛利。爱行轻动于染净品俱不猛故。于见行中男子女人俱能断善。尊者瞿沙伐摩说曰。唯男子能断善根以志性强故。如施设论说。男子造业胜非女人。男子练根胜非女人。男子意乐胜非女人。故知女人不能断善。问若尔根蕴所说复云何通。如说若成就女根定成就八根男根亦尔。答彼文应说若成就女根定成就十三根。若成就男根定成就八根。而不作是说者应知是诵者错谬。评曰彼不应作是说一切所诵皆无异故。男女所作皆猛利故。如栴酌迦婆罗门女恶心谤佛过诸丈夫。然施设论。说男胜者依多分说非谓一切。由此应知前说为善。问所搋半择迦无形二形能断善不。答不能。所以者何。前说意乐坚固所作猛利者能断善根。彼扇搋等意乐轻动所作劣故。复次见行者能断善根彼是爱行故。复次多嗔者能断善根彼多贪故。问断何等善根。唯欲界耶通三界耶。设尔何失。若唯断欲界者。识身论说当云何通。如说若害蚁卵无少悔心应说是人断三界善。若通断三界者彼上界善。先不成就今云何断。答应说唯断欲界善根。问若尔识身论说当云何通。答彼文应说若害蚁卵无少悔心。应说彼断三界中善。而不作是说者欲令三数满故。谓先成就欲界善根。上界善根已不成就。今时复断欲界善根则三界善根皆不成就。由断善位三数乃满故说彼人断三界善。有说通断三界善根。问彼上界善根先不成就今云何断。答于不成就中更不成就以转远故说名为断。复次上界善根依欲界善生长滋茂。若欲界善断彼则干枯故说断彼。复次欲界善根与上界善为门为加行为足依处。若欲界善断彼无门等亦说为断。复次若当欲界善根不断彼上界善容有生长积集之义。今欲界善断故彼善无容生长积集故说为断。由此尊者妙音说曰。若不断欲界善根则色无色善根可得生长。由此断故彼更不生亦说为断。问何故但说杀害蚁卵心无有悔不说余耶。答彼全无过无所用故。谓诸蚁卵于人无过亦无所用而故杀害尚无悔心。况复有过有所用者。故知彼类已断善根是以偏说。问为断加行善根。为断生得善根。答应说唯断生得善根。所以者何。加行善根先已舍故。有作是说。亦断加行善根。问彼先已不成就如何名今断。答于不成就中更不成就。以转远故说名为断。如是等有多义如三界中广说。此中复有一不共义谓加行善根以生得善为因缘为根本。为等起。故此断时亦说断彼。问为但有漏缘邪见能断善根。为亦无漏缘耶。有作是说。唯有漏缘邪见能断善根。所以者何。具二种缚势力强故。评曰应作是说。无漏缘邪见亦能断善根。彼虽无所缘缚。而因力长养亦增盛故。问为但有为缘邪见能断善根。为亦无为缘耶。有作是说。唯有为缘邪见能断善根。义如前说。评曰应作是说无为缘邪见亦能断善根。义如前说问为但同分界地缘邪见能断善根。为亦不同分界地缘耶。有作是说。唯同分界地缘邪见能断善根。义如前说。评曰应作是说不同分界地缘邪见亦能断善根。义如前说。问同分界地缘中。为谤因邪见能断善根。为谤果耶。有作是说唯谤因邪见能断善根。如说若害蚁卵无少悔心。应说是人断三界善。有余师说。唯谤果邪见能断善根。如说。若决定执无善无恶业果异熟。应说是人断三界善。评曰应说谤因谤果邪见俱能断善。谤因邪见如无间道。谤果邪见如解脱道。谤因者与善根成就得俱灭。谤果者与善根不成就得俱生。是故此二俱能断善。问断九品善根时。为不起断为数起耶。有作是说。不起断如见道。有余师说。数起断如修道评曰应说不定。或有不起而能相续断九品尽。或有唯断一品便起。或二或三乃至或八。然后方起复断后品。问住律仪者断善根时。为先舍律仪然后断善。为断时舍耶。有作是说。先舍律仪然后断善。谓彼身中先起一类邪见舍律仪。后起一类邪见断诸善根。如猛风吹树先摧枝叶然后拔根。彼亦如是。评曰应说不定。所以者何。随彼彼类心起彼彼律仪。彼心舍时彼律仪随舍

问续善根时为九品顿续。为一一品渐续耶。有作是说。一一品渐续。有余师说。若应从地狱中。死当生地狱者能续三品。若应从地狱中死当生傍生鬼趣者能续六品。若应从地狱中死当生人天趣者能续九品评曰应作是说。九品顿续。渐次现前。如病差者一时病除后渐生力。然彼应从地狱中死当生地狱者。三品善根得亦在身成就亦现前。六品善根得而不在身成就不现前。当生傍生鬼趣者。六品善根得亦在身成就亦现前。三品善根得而不在身成就不现前。当生人天趣者。九品善根得。亦在身成就亦现前。问善根为断者多为续者多耶。答随尔所断还尔所续。谓断欲界欲界续。断生得生得续。断九品九品续。问断善根已于现法中还能续不。答且依施设论说彼于现法中不能续善。决定于地狱中生时或死时方能续善如彼论说。若害蚁卵无少悔心应说是人断三界善。彼于现法不能续善根。定于地狱中生时或死时方能续善。问谁于地狱生时能续善根。谁于地狱死时能续善根耶。答若于地狱中有中未受断善根邪见异熟果者。彼于地狱生时能续。若于地狱中有中即受彼邪见异熟果者。乃至地狱死时彼果尽故能续善根。所以者何。如邪见与善根相妨彼果亦尔。复次若由因力断善根者地狱死时方续。若由缘力断善根者地狱生时能续。复次若由自力断善根者。死时方续。若由他力断善根者生时能续复次若由自性力断者死时方续。若由资粮力断者生时能续。复次若见戒俱坏而断者死时方续若见坏戒不坏而断者生时能续。复次若意乐加行俱坏而断者死时方续。若意乐坏加行不坏而断者生时能续。复次若常见为加行而断者死时方续若断见为加行而断者生时能续。尊者妙音说曰。彼断善者或有地狱生时。见不善业异熟果相现在前。便作是念。我先自作如是恶业今当受此不如意果。起此信时名为续善。或有生地狱已即受苦异熟果作如是念。我先自作如是恶业今还自受如是苦果。起此信时名为续善。复次若依理说断善根者于现法中亦有能续。谓彼若遇多闻善友具戒辩才言词威肃。能为说法引发其心。告言汝于因果正理应生信解勿起邪谤。如于我所以淳净心恭敬供养。于余尊重同梵行边亦应如是。由此令汝长夜获安。彼闻其言欢喜领受。当知即是已续善根。是故善根有现法续。有转身续。问谁现法续。谁转身续耶。答若断善根不造无间业者现法能续。若断善根亦造无间业者转身乃续。复次若由缘力断善根者现法能续。若由因力断善根者转身乃续。复次若由他力断者现法能续。若由自力断者转身乃续。复次若由资粮力断者现法能续。若由自性力断者转身乃续。复次若见坏戒不坏而断者现法能续。若见戒俱坏而断者转身乃续。复次若意乐坏加行不坏而断者现法能续。若意乐加行俱坏而断者转身乃续。问若现法中亦能续者。前施设论当云何通。答彼说现法不能续者。即是所说有断善根亦造无间。或由因力断善根等。问若现法中续善根者。彼命终已生地狱耶。答彼不决定。生于地狱唯有转身续善根者定生地狱。问住何等心能续善根。答或住疑心。或住正见。谓于因果。有时生疑此或应有。或生正见此决定有。尔时善根得还续起。善得起故名续善根。问谁住疑心续。谁住正见续耶。有作是说。转身续者住疑心续。现法续者住正见续。评曰应作是说。此不决定。问善根若续便能起耶。有作是说。现法续者能起现前。转身续者但是成就。评曰应作是说。此不决定。问若现法中续善根者。彼现身能入正性离生不。有说。不能。以彼邪见坏相续故。善根羸劣尚不能生顺决择分。何况能入正性离生。有说。彼虽现不能入正性离生而能引起顺决择分。评曰应作是说。彼能引起顺决择分。亦复能入正性离生。乃至能得阿罗汉果。如嗢羯吒婆罗门等断善根已。尊者舍利子为其说法令续善根渐得见谛乃至究竟。如毗奈耶中广说。问杀断善人与害蚁卵何者罪重。答且依施设论说。若住等缠其罪正等所受异熟无差别故。若缠不等罪随有异。有作是说。害蚁卵重非断善人。所以者何。蚁卵成就诸善根故。复有说者。杀断善人得罪为重。所以者何。人是善趣害之重故。评曰应作是说。若依罚罪杀断善人得罪为重得边罪故。若依业道害蚁卵重以彼成就诸善法故。问诸断善根者彼皆是邪性定聚耶。有作是说诸断善根者彼皆是邪性定聚。或有是邪性定聚而非断善根。如未生怨王等。彼造无间业不断善根故。评曰应作是说。此有四句有断善根非邪性定聚。如布刺拏等六师是也。彼断善根不造无间业故。有是邪性定聚非断善根。如未生怨王等。有断善根亦邪性定聚。如提婆达多等。彼断善根亦造无间业故。有不断善根亦非邪性定聚。谓除前相。问于何处受断善邪见异熟果耶。答于无间地狱受彼异熟果。如阿罗汉所趣最上到于涅槃。断善根者所趣最下到无间狱。复次如有顶定思有漏善中胜故受有顶异熟果。如是断善邪见恶中胜故。于无间狱受异熟果。问于何处受无间业果。答若断善者。诸无间业。及余破僧。定于无间地狱中受。若不断善者。余四无间业。或于无间地狱。或余地狱中受异熟果。问断善邪见于众同分为但能满亦能引耶。答亦能牵引。亦能圆满。有作是说。但能圆满不能牵引。所以者何。业能牵引众同分果彼非业故。如是说者。前说者好。邪见相应有思业故。邪见与彼同一果故

说一切有部发智大毗婆沙论卷第三十五阿毗达磨大毗婆沙论卷第三十六

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中无惭愧纳息第五之三

云何欲界增上善根。云何微俱行善根。乃至广说。问何故作此论。答为广分别契经义故。谓契经说彼犹有微俱行善根未断。从此有余善法当起由是清净。契经虽作是说而不广分别其义。亦不说云何欲界增上善根。云何微俱行善根。经是此论所依根本。彼所不分别者。今应广分别之故作斯论。问何故此中不说中品善根耶。答是作论者意欲尔故。乃至广说。复次应说而不说者。当知此义有余。复次已说初后即已显中。如初后上下趣入已出加行究竟。应知亦尔。复次若粗现易了易可施设。易显易说者此中说之。中品不尔是故不说。复次中品摄在上下品中故不别说。复次上下品少世所希奇是以故说。中品极多非希奇故略而不说。问何故此中但说欲界善根不说色无色界耶。答是作论者意欲尔故。乃至广说。复次应说而不说者当知此义有余。复次色无色界善根。以欲界善根为门为加行为趣入路。若说此应知亦已说彼故不别说。复次此中但说近对治故。谓次前说二不善根彼近对治。即是欲界二种善根是故偏说。复次欲界增微善根易现易了易施设故此中说之。色无色界增上善根虽易现易了易可施设而微者不尔是故不说。上二界无断善义故微善根相难可施设。云何欲界增上善根。答菩萨入正性离生时所得欲界现观边世俗智。及如来得尽智时所得欲界无贪无嗔无痴善根。如是善根于欲界系诸善根中最为胜故说名增上。云何微俱行善根。答断善根时最后所舍。由舍彼故名断善根。如是善根是欲界系生得善中下下品摄名微俱行。问此中何故以尽智时所得善根对现观边世俗智辨差别耶。有作是说。此中不以尽智时所得善根对现观边世俗智而辨差别。然以现观边世俗智对现观边世俗智而辨差别。谓现观边世俗智声闻者劣。独觉者中。菩萨者胜故。又以尽智时所得善根对尽智时所得善根而辨差别。谓尽智时所得善根声闻者劣。独觉者中。如来者胜故。有余师说。此中亦以尽智时所得善根对现观边世俗智而辨差别。谓菩萨现观边世俗智是劣。尽智时所得善根是胜。声闻独觉亦尔。复次菩萨现观边世俗智。胜于独觉尽智时所得善根。独觉现观边世俗智。胜于声闻尽智时所得善根故。或有说者。此中不欲辨二差别但明此二平等无异。谓此皆由越有顶得现观边世俗智。越见所断有顶得故。尽智时所得善根。越修所断有顶得故。问二乘亦尔何故不说。答彼不能越见修所断有顶习气非增上故。复有说者。此中不欲说二差别及二平等。但说菩萨欲界现观边世俗智。及如来尽智时所得欲界善根。是欲界增上善根胜二乘所得故。问若尔声闻独觉岂无增上善根。答彼复展转望余下类说名增上非望上乘

问现观边世俗智入正性离生已方得何故言入时得耶。答理应言入已方得而说入时得者。此已入名入时于近说远声。如说大王今者从何所来。此亦已来而说今来。如说受乐受时如实知受乐受等。此亦已受名受时。如说断苦断乐入第四静虑。此亦于苦已断名断。如说思惟何法入慈等至。此亦已入名入。如说阿罗汉心解脱欲漏有漏无明漏。此于欲漏亦已解脱名解脱。此中亦尔。已入名入时。复有说者。正应说菩萨入正性离生时得现观边世俗智。以诸谛初智皆名正性离生诸忍名入故。谓苦集灭类忍入苦集灭类智时名得现观边世俗智。如金刚喻定现在前时名得尽智时此亦如是。问何故此智名现观边。答现观苦边集边灭边。得此智故名现观边。有说。此是诸瑜伽师观圣谛时傍修得故名现观边尊者妙音说曰。此智近现观故名现观边。如近村物名曰村边。问此现观边所修世俗善法四蕴五蕴为自性。何故但说世俗智耶。答以智增故说名为智。犹如见道五蕴为自性见增故名见。金刚喻定四蕴五蕴为自性。定增故名定。四种通行四蕴五蕴为自性。通增故名通。此亦如是。问苦现观边欲界世俗智与色界世俗智何者为胜。答色界者胜以界胜故集灭现观边亦尔。问集现观边欲界世俗智苦现观边色界世俗智何者为胜。答欲界者所依胜故胜。色界者界胜故胜。以灭问苦集亦尔。问苦现观边欲界世俗智集现观边色界世俗智何者为胜。答色界者二事胜故胜。一界胜二所依胜。以苦问灭以集问灭亦尔。问苦现观边欲界世俗智集现观边欲界世俗智何者为胜。答集现观边胜。以所依胜故以苦问灭。以集问灭亦尔。如欲界色界亦尔。问何故现观边世俗智法智时不修。答法智于彼非田非器乃至广说。复次此智现观边修故名现观边世俗智。若法智时亦修者应名现观中世俗智非现观边。复次先说此智越有顶见所断故得。非法智时能越有顶见所断故不修此智。复次于一一谛所作已办加行息时能修此智。住法智时多有所作加行未息。谓法智时虽知欲界苦而未知色无色界苦。虽断欲界集而未断色无色界集。虽证欲界灭而未证色无色灭。故法智时不修此智。复次于一一谛现观究竟及断见此所断尽时能修此智。住法智时无如是事是故不修。问何故道类智时不修此智。答道类智于此非田非器。乃至广说。复次此智是见道眷属系属见道道类智是修道故不修此智。复次此智是向道眷属系属向道。道类智是果道故不修此智。复次此智是随信行随法行相续中修道类智时。名信胜解见至相续是故不修此智。复次此智名现观边于三谛有边声转故修此智。如说萨迦耶苦边。萨迦耶集边。萨迦耶灭边。而不说萨迦耶道边故道类智时不修此智。问因论生论。何故于三谛有边声转非于道谛。答以其有能知一切苦。断一切集证一切灭。而无有能修一切道。佛亦于道得修习修俱不尽故无边声转。复次若谛有漏无漏道俱能有所作者有边声转。道谛唯无漏道能有所作故无边声转。如有漏无漏道。世间出世间道。有味无味道。耽嗜依出离依道。当知亦尔。复次苦谛是有是有果于彼有边声转。谓苦集谛是有是有果。灭谛虽非有而是有果。道谛非有非有果故无边声转。以于道谛不说边故。道类智时不修此智。复次从不可知本际以来世俗道。于三谛曾有所作谓我是道。今道类智现在前时。见真道故彼便惭耻是故不修。如村邑中若未立主。有自贵者自称为主。后立主时彼自贵者。惭羞舍去此亦如是。复次现观边世俗智是有是有果。苦集谛是有是有果。灭谛虽非是有而是有果故见彼时修世俗智。道谛非有非有果故。见彼时不修此智。复次苦集谛有无边过患。灭谛有无边胜利故。见彼时修世俗智。道谛无无边过患亦无无边胜利故。见彼时不修此智。复次无始时来世俗智于三谛已有功能。谓知断灭而不究竟。以于有顶无功能故。今于三谛得现观时以究竟故。彼便欢喜如与欲法起得现前。是以故修。无始时来于道圣谛未有功能。谓未修习故见道时不修此智。复次于苦集灭得现观时未见真道故。世俗智犹自谓道是以故修。于道圣谛得现观时见真道故此世俗智自知非道故不复修。此中应说乌孔雀喻。复次见三谛时犹未永断谤道邪见。及未永断非道谓道戒禁取故。诸世俗智犹自称道是以故修。见道谛已彼皆永断故不复修此世俗智。问得道类智时如舍见道此现观边世俗智为亦舍不。答不舍。所以者何。有漏无漏道舍法异故。谓无漏道三缘故舍。一退故。二得果故。三练根故。有漏道四缘故舍。一退故。二越界地故。三断善根故。四舍众同分故。道类智时于舍有漏四缘皆无故。于尔时不舍此智。复次道类智与见道。现行成就俱相违故尔时便舍。与现观边世俗智虽现行相违而成就不相违故尔时不舍。问何故修道中此智不现前耶。答此现观边世俗智是见道眷属系属见道故于修道必不现前。复次此智是向道眷属系属向道。修道带果故不现前。复次此智依随信随法行相续。修道中无此相续故不现前。复次此智与修道虽成就不相违而现行相违是故不起。复次此智与见道所缘行相等极相似。故于修道位必不现前。此现观边世俗智界者唯欲色界。问何故此智非无色界耶。答以无色界于此智非田非器。乃至广说。复次若界有见道彼界则有此智。无色界中无见道故此智亦无。问因论生论何故无色界中无见道耶。答无色界于见道非田非器。乃至广说。复次若界有缘一切法非我行相彼界则有见道。无色界中无缘一切法非我行相故无见道。复次若界有行谛善根彼界则有见道。无色界中无行谛善根故无见道。复次若界有顺决择分彼界则有见道无色。界中无顺决择分故无见道复次若界。有忍有智彼界则有见道。无色界中有智无忍故无见道。复次若界有法智类智彼界则有见道。无色界中虽有类智而无法智故无见道。复次若界止观平等。或观偏增。彼界则有见道。无色界中止增非观故无见道。复次若界有遍缘智彼界则有见道。无色界中无遍缘智故无见道。无见道故彼所修世俗智亦无复次此智设在无色界有不可修故便为无用是故彼无谓修此智必依见道。见道唯能修自下地不能修上故彼设有亦不可修。又无色界无见道因中随其所应即是无此智因。地者此智七地中有。谓欲界未至静虑中间及四静虑。若依未至定入正性离生。彼修一地见道二地现观边世俗智。若依初静虑入正性离生。彼修二地见道三地现观边世俗智。若依静虑中间入正性离生。彼修三地见道四地现观边世俗智。若依第二静虑入正性离生。彼修四地见道五地现观边世俗智。若依第三静虑入正性离生。彼修五地见道六地现观边世俗智。若依第四静虑入正性离生。彼修六地见道七地现观边世俗智。所依者。此智依欲界身。非色无色界。问此智为依异生身。为依圣者身耶设尔何失。若依异生身者。何故不名异生法耶。若依圣者身者。何故圣者不现前耶。有说此智不依异生身。亦不依圣者身都无所依。评曰彼不应作是说。云何名善根而无所依耶应作是说。依圣者身以依随信随法行身而修得故。问若尔何故不现在前。答此智与见道现行相违故。过见道位无容起故。设见道位中见道须臾不现前者此智便起。以见道无刹那断义。是故此智无容现前。问若不现前云何可说此依随信随法行身。答彼身有二种。一是见道所依。二是现观边世俗智所依。见道于见道所依身得亦在身成就亦现前。现观边世俗智于彼身得而不在身成就不现前。现观边世俗智于现观边世俗智所依身得亦在身成就亦现前。见道于彼身得而不在身成就不现前。设见道位此世俗智所依身现在前者。则此智成就亦现在前见道唯于未来成就。然见道位必起见道所依身故见道成就亦现在前。此智唯于未来成就。若见道位不起见道所依身者。则无见道见圣谛义便非圣者。是故必起见道所依。由此彼身得非择灭。是故此智毕竟不起。行相者。此智总有十二行相。谓苦现观边所修者作苦四行相。集现观边所修者作集四行相。灭现观边所修者作灭四行相。所缘者。此智缘三界三谛。苦现观边所修者缘三界苦谛。集现观边所修者缘三界集谛。灭现观边所修者缘三界灭谛。问此为总缘为别缘耶。答别缘。谓欲界者随所应缘欲界三谛。色界随所应缘色无色界三谛。有说。总缘谓欲界者。随所应缘三界三谛。色界者亦尔。如是说者前说者好。如无漏智法分类分各别缘故。念住者。此智苦集现观边所修者通四念住。灭现观边所修者唯法念住。智者此智唯世俗智。定者此智不与定俱。根相应者。此智总与三根相应谓乐喜舍根。过去未来现在者。此智唯未来苦集现观边所修者缘三世。灭现观边所修者缘离世。善不善无记者。此智唯善。苦集现观边所修欲界者缘三种色界者缘善无记。灭现观边所修者唯缘善。三界系不系者。此智欲色界系。苦集现观边所修欲界者缘欲界系。色界者缘色无色界系。灭现观边所修缘不系。学无学非学非无学者。此智是非学非无学。缘非学非无学。见所断修所断不断者。此智唯修所断。苦集现观边所修者缘见修所断。灭现观边所修者缘不断。缘名缘义者。此智苦集现观边所修者通缘名义。灭现观边所修者唯缘义。缘自相续他相续非相续者。此智苦集现观边所修者缘自他相续。灭现观边所修者缘非相续。加行得离染得生得者。此智唯加行得。闻思修所成者。此智欲界者是思所成。非闻所成此胜故。非修所成不定故。色界者是修所成非闻所成此胜故。非思所成彼无思慧故。彼若思时便入定故在意地。在五识者此智在意地非五识。以五识中无加行善故。问此智为有异熟为无异熟。答有异熟善有漏故。问此智于何处受异熟果。答欲界者于欲界。色界者于色界。初静虑者于初静虑。乃至第四静虑者于第四静虑。问声闻者可尔彼容有色界相续故。佛及独觉者云何可尔。非佛独觉可有色界相续受此异熟故。答彼种性补特伽罗亦曾有色界蕴界处相续。于彼展转受此异熟。问若尔云何圣者相续中所成就因得异生相续中果耶。答以如是义许为因果亦无有过。如业蕴说。若具见修所断结二种缚者可往恶趣。诸预流者唯有修所断结缚阙见所断结缚故不往恶趣。由此恶趣有二种因。一见所断结。二修所断结。诸预流者所成就修所断结既是恶趣因。岂非圣者相续中所成就因得异生相续中果耶。故此所说亦无有过。此说不生因果可有是事若可生者无如是事。复有说者。佛及独觉亦有如声闻色界蕴界处相续于彼展转受此智异熟果。评曰彼俱不应作如是说。应作是说。现观边世俗智是有漏有记故说有异熟。而无曾受及当受义。故不应责受异熟身。问颇有二圣者同生一地于现观边世俗智一成就一不成就耶。答有。谓一依初静虑入正性离生。一依第二静虑入正性离生。彼命终俱生第二静虑。依初静虑者不成就此智以越地舍故。依第二静虑者成就。此智生自地不舍故。颇有二阿罗汉同在一地。于现观边世俗智一成就一不成就耶。答有。谓彼先时一依初静虑入正性离生。一依第二静虑入正性离生。彼命终俱生第二静虑。住中有中得阿罗汉果。依初静虑者不成就。此智以越地舍故。依第二静虑者成就。此智生自地不舍故问声闻独觉及与如来得尽智时皆修三界九地善根。此中何故但说如来所得欲界善根非余。答虽实皆得然于此中欲说欲界增上善根故不说二乘及余地所得。问诸阿罗汉得尽智时皆修三界九地善根不。答此不决定。若生欲界得尽智时能修未来三界九地。生初静虑得尽智时能修未来二界八地。生上不修下有漏故。乃至若生非想非非想处得尽智时能修未来一界一地。此中善根胜故偏说。而实具修四蕴五蕴。问如是所修为加行得为离染得为生得耶。答是离染得亦加行得。离有顶染时得故。声闻独觉亦以加行现在前故。但非生得彼非胜故。问此所修者为闻所成。为思所成。为修所成。答三种皆有。谓欲界者闻思所成。色界者闻修所成。无色界者唯修所成。问何故现观边世俗智非闻所成。尽智时所修善根有闻所成耶。答彼是见道眷属一向猛利是速疾道之所修故非闻所成。此是尽智眷属尽智息求是容豫道故能通修诸加行善。问如是善根为在意地。为在五识。答唯在意地。以五识中无加行善。虽有生得善而非此所修。故唯意地。问若此善根唯意地者施设论说当云何通。如说阿罗汉得尽智已六恒住法为有为无。若有者云何有。若无者云何无。设有者几过去成就。几未来成就。几现在成就。答有谓阿罗汉眼见色已。不喜不忧心恒住舍具念正知。广说乃至意知法已。不喜不忧心恒住舍具念正知。彼阿罗汉得尽智已若最初起善眼识现在前。彼成就过去一未来六现在一。此灭已不舍。若起善耳识现在前。彼成就过去二未来六现在一。此灭已不舍乃至若起善意识现住前。彼成就过去未来六现在一。复有说言。若最初起善眼识现在前彼过去无。但成就未来六现在一。此灭已不舍。若起善耳识现在前彼成就过去一未来六现在一。此灭已不舍。乃至若起善意识现在前。彼成就过去五未来六现在一。此灭已不舍。若复起善意识或余识现在前。彼成就过去未来六现在一。如是所说云何通耶答此说漏尽清净身中所起灭者。不说无始生死以来所起灭者。然此所说非尽智时所修善根无相违过。复有说者。六恒住法亦唯意地以说眼见色已乃至意知法已不喜不忧心恒住舍具念正知故。问若尔何故复说善眼识等现在前时成就现在一耶。答当知此是恒住加行非恒住体故不相违。问六恒住法以何为自性。答以念慧为自性云何知然。如契经说诸阿罗汉心善解脱具六恒住。云何为六。谓眼见色已乃至意知法已不喜不忧心恒住舍具念正知。若兼取相应俱有则四蕴五蕴为自性。已说自性。所以今当说。问何故名恒住恒住是何义。答诸阿罗汉恒于此住未尝舍离故名恒住。问一切阿罗汉皆有此六恒住法耶。有作是说。非一切阿罗汉皆有此六。谓不时解脱已得边际第四静虑及愿智者乃有此六。评曰。应作是说。一切阿罗汉皆有此六。云何知然。此六恒住皆以漏尽清净身中念慧为体。诸阿罗汉无不成就此念慧故。问此六恒住在何界地。有说此六在欲色界唯二地有。谓欲界初静虑以意地者。亦与善眼识等相入出故不在上地。复有说者。在五地有。谓欲界四静虑五地意识皆与眼等识相入出故。评曰。应作是说。通在三界十一地有。谓欲界未至静虑中间四静虑四无色意识念慧遍诸地故。问此六恒住为有上中下差别不。答有。谓如来者上。独觉者中。声闻者下。复次不动法种性者上。退法种性者下。余四种性者中。问若声闻独觉亦成就六恒住法何故说三种念住是佛不共法耶。答佛恒为众宣说法要是御众生故偏说之。声闻独觉无此事故不言其有。复次声闻独觉虽有少分非究竟故而不建立。复次声闻独觉虽断贪恚而有余习故。若徒众有违顺时便生相似贪恚忧喜故不建立有三念住。复次六恒住法与三念住建立有异。谓三念住依众建立。六恒住法依境建立。于境不起忧喜则易。于众则难故。声闻等有六恒住。无三念住。问何故得尽智时顿修未来三界善根非余时耶。答尔时三界烦恼永尽更无所作。唯须世俗入出定心受用诸定故此时修三界善根。复次是时永舍昔所未舍诸烦恼聚。及最初得昔所未得诸功德聚故。能顿修三界善根。复次是时心得自在王位首系解脱吉祥白练。三界善根皆来朝贡。如登王位首系练时一切国土皆来朝贡。复次是时能破昔所未破烦恼怨敌。三界善根皆来迎贺。如人能破敌国怨已归国之时。一切国人皆来迎贺。复次是时能伏昔所未伏烦恼力士三界善根皆共庆赞。如大众中有能降伏所未曾伏大力士者众咸庆赞。复次是时解脱究竟满故。能傍修习三界善根。谓从见道渐次乃至金刚喻定解脱未满但能少分随所应修。得尽智时解脱满故能傍修习三界善根。如人引水溉灌田时一畦满已复入一畦乃至诸畦。悉皆满已其水滂溢遍流余处。复次是时能缚烦恼尽故三界善根皆得解脱势用增盛是故顿修。谓无始来三界善法恒为烦恼之所系缚不得自在无有势用。是故不能具足修习若修行者离欲染时少得解脱余缚犹多。乃至若离有顶八品烦恼缚时虽多解脱尚有少缚。若离有顶第九品时三界善根诸缚皆断得自在故一切顿修。犹如绢等九等缚时若断一二乃至断八其束不散。断第九时其束乃散此亦如是。复次无始时来三界善法皆共厌患有顶烦恼虽多方便而未能断。今得断尽是以顿修。复次金刚喻定势力增猛一切烦恼皆能永灭。所引尽智亦能总得一切解脱。是故此位能总修习三界善根。时解脱阿罗汉得尽智时能修二智三十行相。谓尽智十四行相除空非我。无学正见智十六行相。若四静虑未至中间一一具修法智类智各三十行相。若三无色唯修类智三十行相。不时解脱阿罗汉得尽智时能修三智四十四行相。谓尽智无生智各十四行相。无学正见智十六行相。若四静虑未至中间一一。具修法智类智各四十四行相。若三无色唯修类智四十四行相。是谓修习无漏善根

说一切有部发智大毗婆沙论卷第三十六阿毗达磨大毗婆沙论卷第三十七

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中无惭愧纳息第五之四

诸心过去彼心变坏耶。乃至广说。问何故作此论。答为止他宗显正义故。谓或有执。过去未来非实有体现在是无为。彼于三世愚惑不了起如是执为遮彼执欲显实有过去未来现在是有为法。复次有诸外道执有为法行于世时物性相隐。有诸外道执有为法行于世时物性相变。有诸外道执有为法行于世时物性相往。为遮彼执显有为法前灭后生故作斯论。诸法变坏。略有二种。一世变坏。二理变坏。世变坏者。谓过去世现在变坏名过去故。理变坏者。谓染污法。诸染污法皆违理故。过去染污心具二变坏。不染污心唯世变坏。未来现在染污心唯理变坏。不染污心不名变坏。是谓此处略毗婆沙。诸心过去彼心变坏耶。答诸心过去彼心皆变坏。谓染污心具二变坏故名变坏心。不染污心唯世变坏故名变坏心。有心变坏彼心非过去。谓未来现在贪恚相应心。彼心但由理变坏故名变坏心。为证此义复引契经如世尊说汝等苾刍。设被怨贼锯解汝身或诸支节。汝等于彼心勿变坏。亦当护口勿出恶言。若心变坏及出恶言于自所求深为障碍。此证嗔心名为变坏。怨谓怨对贼谓劫盗。问何故但说锯解身支。答欲显能为多苦因故。谓刀槊等伤害身时有入时苦出时不苦有出时苦入时不苦。若以锯解入出皆苦。于此极苦尚不应嗔。况于轻苦而当嗔恨。自所求者善趣涅槃。又世尊说。汝等苾刍于妙欲境不应发起变坏之心。此证贪心名为变坏。妙欲境者谓五妙欲。变坏心者谓淫欲心。问若现在至过去说过去法名世变坏者。未来至现在何故现在法不名世变坏耶。答若变坏已不复变坏名世变坏。现在变坏复当变坏。是故不说为世变坏。复次若世具有世变及作用坏者名世变坏。现在虽有世变而无作用坏。以现在法有作用故不名世变坏。复次世间共许已谢灭法名世变坏不说现在。是故现在非世变坏。问一切烦恼无不违理皆应名理变坏。何故但说贪嗔二心名变坏耶。答是作论者意欲尔故乃至广说有说此中亦应说余烦恼相应心名为变坏。而不说者当知此义有余。有说不应责问作论者意。以作论者依经造论。经中但说贪嗔相应名为变坏。非余烦恼是故不说。问置作论者世尊何故但说贪嗔相应之心名为变坏不说余耶。答佛观所化应闻贪嗔相应之心名为变坏而得悟解办所作事。故说此二非余烦恼。复次佛观此二变坏所依及所缘境是故偏说。贪变坏所依者。若贪现前身便柔软轻举怡悦。变坏所缘者。若所爱境现在前时。心心所法于彼耽染时所依空如无情物。于粗秽境见为净妙。嗔变坏所依者。若嗔现前身便粗强沉重惨瘁。变坏所缘者。若所憎境现在前时。心心所法于彼憎恶。不欲面对况能视之。于美妙中谓为鄙陋。复次佛观此二变坏色形是故偏说。贪变坏色者。若贪现前令所依身变成黄色。变坏形者。若增上贪数数现起。男形隐没女形出现。嗔变坏色者。若嗔现前令所依身变成异色。变坏形者。若增上嗔数数现起。人形相灭蛇形相生。曾闻有一离系外道。虽依佛出家而不舍本见闻。佛弟子说彼法中种种过失。生重嗔恚由嗔恚故变作毒蛇。复次佛观此二变坏分位及众同分是故偏说。贪变坏分位者。由贪力故说诸男女幼少中年老年差别。变坏众同分者如世尊说。有欲界天名为戏忘。彼耽戏乐身极疲劳心便忘念。由忘念故而便殒殁。嗔变坏分位者。由嗔力故亦说男女幼少中年老年差别。变坏众同分者如世尊说。有欲界天名为意愤。彼愤恚故角眼相视由此相视愤恚更增。如是多时而便殒殁。复次佛观此二变坏自他身及众具。过余烦恼是故偏说。复次佛观此二能生种种违顺过失。过余烦恼是故偏说。复次佛观此二是斗诤本过余烦恼是故偏说。复次世间种种深重过失。多由爱憎是故偏说。复次此二随眠遍在六识。皆自力起是故偏说。复次此二随眠是诸欢戚烦恼根本。又能生长依诸身心种种过患及众苦恼是故偏说。诸心染着彼心变坏耶乃至广说。问何故复作此论。答前说于妙欲境。不应起贪。于解身支不应起嗔。勿谓唯欲界修所断贪嗔名为变坏。欲显三界贪及五部贪嗔皆名变坏故作斯论。诸心染着彼心变坏耶。答诸心染着彼心皆变坏。谓过去者由世及理二变坏故名变坏心。未来现在者但由理变坏故名变坏心。有心变坏彼心非染着。谓过去贪不相应心。若染污者由二变坏故名变坏心。不染污者但由世变坏故名变坏心。及未来现在嗔相应心。此心但由理变坏故名变坏心。为证此义复引契经。如世尊说汝等苾刍设被怨贼。广说乃至于自所求深为障碍。此中略故但说染着理。亦应说有憎恶心。诸心憎恶彼心变坏耶。答诸心憎恶彼心皆变坏。谓过去者由二变坏故名变坏心。未来现在者但由理变坏故名变坏心。有心变坏彼心非憎恶。谓过去嗔不相应心。若染污者由二变坏故名变坏心。不染污者但由世变坏故名变坏心。及未来现在贪相应心。此心但由理变坏故名变坏心。为证此义亦应引经。如世尊说汝等苾刍于妙欲境不应发起变坏之心。虽诸染污心皆名变坏而由如前说故但说二种云何掉举乃至广说。问何故作此论。答欲令疑者得决定故。谓世尊说掉举恶作合立一盖。或有生疑离掉举无恶作离恶作无掉举。欲令此疑得决定故。显离掉举有恶作离恶作有掉举故作斯论。云何掉举。答诸心不寂静不止息轻躁掉举。心躁动性是谓掉举。此中论主于异名义得善巧故作种种说。文虽差别而体无异。云何恶作。答诸心燋灼懊变恶作心追悔性是谓恶作。如是诸名义如前说。诸心有掉举彼心恶作相应耶。答应作四句。此二互有宽狭义故。有心有掉举非恶作相应。谓无恶作心有躁动性。即色无色界五部染污心。欲界见所断四部心及修所断染污五识。恶作不相应染污意识。有心有恶作非掉举相应。谓无染污心有追悔性。即苾刍等护学处者多有此心。如应收举床几等物而不收举。及应闭门而不闭等。依福非福亦有此心。此中恶作总有四句。一有恶作是善于不善处起。二有恶作是不善于善处起。三有恶作是善于善处起。四有恶作是不善于不善处起。第一句者。谓如有一作恶事已心生追悔。我所作者非为好作何因作此不善事耶。如护学处诸苾刍等有所违越便生悔恨。第二句者。谓如有一作善事已心生追悔。我所作者非为好作何因作此无用事耶。如胜家长者施独觉食已心生追悔。我宁以此食与奴婢作使何乃施彼髡头沙门。第三句者。谓如有一作少善已心生追悔。我所作者非为善作何不多作此善事耶。如尊者无灭言。我若知彼有此威德应更多施何大少耶。第四句者。谓如有一作少恶已心生追悔。我所作者非为好作何不多作如是事耶。如屠脍等作少恶已悔不多作。此四句中第一第三名有恶作非掉举相应心。有心有掉举亦恶作相应。谓染污心有追悔性。即前四句中第二第四句是此所说。问此中何故不说有躁动心有追悔性。而但言染污心有追悔性耶。答但是染污心必有躁动不说自成。若说有躁动心者。则疑染污心中有无躁动者故但说染污心即由此故前第二句说无染污心有追悔性。无躁动义亦不说自成。若说无躁动心有追悔性者则疑无染污心。或有躁动故。前但说无染污心。有心无棹举亦非恶作相应谓除前相。此中所名以相声说。若法已立名已称说者作前三句。未立名未称说者作第四句。故言除前相。此复云何。谓识蕴中作此四句。初句取无恶作有掉举心。第二句取无掉举有恶作心。第三句取有掉举有恶作心。除此所余无掉举无恶作心作第四句云何惛沈乃至广说。问何故作此论。答为令疑者得决定故。如世尊说。惛沉睡眠合立一盖或有生疑离惛沈无睡眠。离睡眠无惛沈。欲令此疑得决定故。显离惛沈有睡眠离睡眠有惛沈故作斯论。云何惛沈。答诸身重性。心重性。身不调柔。心不调柔。身[夢-夕+登]瞢。心[夢-夕+登]瞢身愦闷。心愦闷。心惛重性。是谓惛沈。此中论主于异名义得善巧故作种种说。文虽差别而体无异。身重性者显五识相应惛沈。心重性者显意识相应惛沈。由此余句应知亦尔。心惛重性者显此皆是心所法性。云何睡眠。答诸心睡眠惛微而转心昧略性。是谓睡眠心。睡眠者显此但与意识相应。惛微转者显异觉时及无心定。心昧略性者显此自性是心所法。谓略即简五识相应。昧简诸定及分别意。诸心有惛沈彼心睡眠相应耶。答应作四句。此二互有宽狭义故。有心有惛沈非睡眠相应。谓无睡眠心有惛沈性。即色无色界一切染污心。及欲界觉时诸染污心。有心有睡眠非惛沈相应。谓无染污心有睡眠性。即欲界善无覆无记睡眠相应意识。有心有惛沈亦睡眠相应。谓染污心有睡眠性。即欲界染污睡眠相应意识。此中问答如前掉举恶作中说。有心无惛沈亦非睡眠相应。谓除前相。此中所名以相声说。若法已立名已称说者作前三句。未立名未称说者作第四句。故言除前相。此复云何。谓识蕴中作此四句。初取有惛沈无睡眠心。第二句取有睡眠无惛沉心。第三句取有惛沈有睡眠心。除此所余无惛沈无睡眠心作第四句

睡眠当言善耶乃至广说。问何故作此论。答前说睡眠心昧略为性。未说为是善为不善为无记。今欲说之故作斯论。睡眠当言善耶不善耶无记耶。答睡眠应言或善或不善或无记。谓睡眠时心心所法有三种故。云何善。谓善心睡眠惛微而转心昧略性。由彼觉时于诸善事好行串习故睡梦中亦复随转。如在本有于诸善事好行串习彼于死有或中有中亦复随转。此亦如是。问此睡梦中所起善法为加行善为生得耶。答唯生得善以惛微故。有余师说。亦加行善以于文义亦简择故。云何不善。谓不善心睡眠惛微而转心昧略性。由彼觉时于不善事好行串习故睡梦中亦复随转。如在本有于不善事好行串习彼于死有或中有中亦复随转。此亦如是。问此睡梦中所起不善为见所断修所断耶。答通二所断。云何无记。谓无记心睡眠惛微而转心昧略性。由彼觉时于无记事好行串习故睡梦中亦复随转。如在本有于无记事好行串习彼于死有或中有中亦复随转。此亦如是。问此睡梦中所起无记。为是有覆为无覆耶。答二种俱有。有覆无记者。谓欲界身边二见相应睡眠。无覆无记者。谓威仪路工巧处异熟生非通果。威仪路者。如睡梦中自谓行等。工巧处者。如睡梦中自谓画等。异熟生者。如睡梦中除前所说余无记转。有余师说。唯异熟生。是睡眠中无覆无记以心惛昧不发身语故无威仪及工巧性

梦中当言福增长耶乃至广说。问何故作此论。答前说睡眠通善不善无记。未说梦中有福增长等。今欲说之故作斯论。梦中当言。福增长耶。非福增长耶。非福非非福增长耶。答梦中应言。或福增长。或非福增长。或非福非非福增长。有处说得名为增长。有处说生名为增长。何处说得名为增长。如定蕴说。何故异生退时见修所断结增长。世尊弟子退时唯修所断结增长。彼处说得名为增长。何处说生名为增长。如施设论说。异生欲贪随眠起时必起五法。一欲贪随眠。二欲贪随眠增长生。三无明随眠。四无明随眠增长生。五掉举。彼处说生名为增长。此中说能取爱非爱果等思名为增长。以此能取如应果故。福增长者。如有梦中布施作福受持斋戒。或余随一福相续转。其事云何。彼随觉时善胜解力。梦中还似彼善事转。故如觉时能取爱果说为增长。谓若觉时好行布施。或以饮食或以衣服卧具医药房舍等事。给施于他。由斯串习胜解力故梦中还似此所作转。若于觉时好作福业。或勤修理佛法僧事道路桥梁园林花果池沼福舍。或乐瞻病供侍有德。或营五年大会等福。由斯串习胜解力故梦中还似此所作转若于觉时受持八斋及诸禁戒。谓苾刍等七众律仪。由斯串习胜解力故梦中还似此所作转。若于觉时好乐诵读听问说授思惟简择三藏文义。由斯串习胜解力故梦中还似此所作转。若于觉时修不净观。或持息念四念住等诸观行问。由斯串习胜解力故。梦中还似此所修转。由如是等胜解力故梦中福业亦得增长。非福增长者。如有梦中害生命不与取欲邪行故妄语饮诸酒。或余随一非福相续转。其事云何。彼随觉时恶胜解力梦中还似彼恶事转故。如觉时取非爱果说为增长。谓若觉时好害他命如屠羊等。或不与取如劫贼等。或欲邪行如奸非者。或故妄语如伪证等。或饮诸酒如耽酒人。或作其余挝打骂詈才构彼此俳优歌咏饮啖血肉贪着五欲。增恶三宝憍慢邪见嫉妒等事。由斯串习胜解力故梦中还似彼所作转。故于梦中诸非福业亦得增长。非福非非福增长者。如有梦中非福非非福相续转其事云何。彼随觉时非善非恶胜解力故梦中还似彼事而转。故如觉时能取非爱非非爱果说为增长。谓若觉时作威仪路或工巧处。或作田种担负等事。由斯串习胜解力故梦中还似彼所作转。故于梦中非福非非福业亦得增长。问若于梦中福增长者何故佛说愚人眠时无果异熟。答如人觉时能作种种田种等事眠则不能。如是觉时能修种种殊胜善业。谓能读诵听闻说授简择文义。修不净观持息念等别总念住顺决择分。入正决定得预流果乃至能得阿罗汉果。或复能修人天胜业。眠时于此皆不能成故说眠时无果异熟。是故尊者世友说曰。眠时所作福业果少故说无果非谓全无。问若于梦中非福增长何故佛说宁当睡眠勿起恶觉。答如人觉时数起种种增上恶觉眠时则无故作是说。非谓梦中一切非福皆不增长。问梦中善不善业能引众同分不。答不能。以明了业能引众同分彼昧劣故。有说亦能。谓彼能引蛴螬蚯蚓等闇劣众同分非余胜者。评曰如是说者。不应作是说。如前说者好。眠时但能造圆满业非牵引业。随他力转性昧劣故。然得欲界五蕴异熟。梦名何法乃至广说。问何故作此论。答前虽说梦作用而未说梦自性今欲说之。复次为破他宗显正义故。谓或有执。梦非实有。如譬喻者彼作是说。梦中自见饮食饱满诸根充悦。觉已饥渴身力虚羸。梦中自见眷属围绕奏五乐音欢娱受乐觉已皆无独处愁瘁。梦中自见四兵围绕东西驰走觉已安然。由此应知梦非实有。为遮彼执显实有梦。若梦非实便违契经。如契经说我为菩萨时于一夜中作五大梦。又契经说胜军大王于一夜中作十大梦。毗奈耶说。讫栗鸡王于一夜中作十四梦。又契经说难地迦母来白佛言。我夫犯戒既命终已于夜梦中现。昔时身来谓我曰。汝是我妇可为昔事。世尊我时都无异想曾无一念随顺彼心。世尊告曰善哉善哉。汝是不还果人岂复染斯欲事。又契经说汝等当断如梦之法。此法是何。谓五取蕴。又伽他说

  如梦所会人　　觉已便不见
  死已于所爱　　不见亦复然

若梦非实便与此等所说相违。由是因缘故作斯论。梦名何法。答诸睡眠时心心所法于所缘转。彼觉已随忆能为他说我已梦见如是如是事是谓梦。问若梦所见觉已不忆设忆不能为他说者为是梦不。答彼亦是梦但不圆满。若圆满者是此所说。问梦以何为自性。答即以梦时心心所法而为自性。有作是说意为自性由意势力诸心所转取梦境故。有余师说。念为自性由念势力觉已随忆为他说故。或有说者。五取蕴为自性梦时诸蕴展转相资成梦事故。复有说者。以一切法为梦自性皆是梦心所缘事故。评曰。如是诸说虽各有义而最初说于理为善。以此中说诸睡眠时心心所法于所缘转。此显睡时若心心所法于所缘境明了转者说名为梦不说余故。问梦在意地非五识身如何梦中能见色等。有作是说。是诸鬼神先示其人吉不吉相虽在意地而缘色等。尊者妙音作如是说。梦中法尔能见当来吉不吉相。通达梦事制造梦书。诸仙人等作如是说。大德说曰。梦中虽无眼等五识能见色等而由意地。眠势衰微梦见色等。如难地迦母所见梦事。尊者世友作如是说。由五因缘见所梦事。如彼颂言

  由疑虑串习　　分别曾更念
  亦非人所引　　五缘梦应知

寿吠陀书作如是说。七因缘故梦见色等。如彼颂言

  由曾见闻受　　希求亦分别
  当有及诸病　　七缘梦应知

应说五缘见所梦事。一由他引。谓若诸天诸仙神鬼咒术药草亲胜所念及诸圣贤所引故梦。二由曾更。谓先见闻觉知是事。或曾串习种种事业今便梦见。三由当有。谓若将有吉不吉事法尔梦中先见其相。四由分别谓若思惟希求疑虑即便梦见。五由诸病。谓若诸大不调适时便随所增梦见彼类。问何界趣处有此梦耶。答欲界有梦。非色无色彼无睡故。于欲界中。有作是说。四趣有梦唯除地狱。彼由苦逼无睡眠故。应说地狱亦容有梦。如施设论说。等活地狱中虽热所逼骨肉燋烂有时冷风所吹。或因狱卒唱活彼即还活骨肉复生。苦受暂停便生少乐。由此故知亦容有睡因斯有梦。问何等补特伽罗有梦。答异生圣者皆得有梦。圣者中从预流果乃至阿罗汉独觉亦皆有梦。唯除世尊。所以者何。梦似颠倒佛于一切颠倒习气皆已断尽故无有梦。如于觉时心心所法无颠倒转睡时亦尔。问佛亦有睡眠耶。答有。云何知然。契经说故。如契经说。诸离系子来至佛所作是问言。乔答摩尊有睡眠不。世尊告曰。祠火当知我极热时为解食闷亦暂睡眠。彼复白佛。世有一类沙门梵志作如是言。有睡眠者即是愚痴。乔答摩尊将无是事。世尊告曰。若有诸漏杂染后有生老病死苦果。未断未遍知而睡眠者可名愚痴。佛于诸漏杂染后有生老病死苦果。已断已遍知故。虽有睡眠不名愚痴。然诸睡眠略有二种。一染污。二不染污。诸染污者佛及独觉阿罗汉等已断遍知。不染污者为调身故乃至诸佛亦现在前况余不起。故知诸佛亦有睡眠。是故睡眠通五趣有。中有亦有。在胎卵中诸根身分已满足者亦有睡眠。问梦所见事为是曾更为非曾更。设尔何失。若曾更者。云何梦见有角人耶。岂曾有时见人有角。契经所说复云何通。如说菩萨于一夜中作五大梦。一者梦见身卧大地头枕妙高山王。右手搅西大海。左手搅东大海。两足搅南大海。二者梦见有吉祥草名曰坚固。从脐中出渐高渐大遍覆虚空。三者梦见有诸虫鸟身白头黑。缘菩萨足极至膝轮还复退落。四者梦见有四色鸟从四方来至菩萨边皆成一色。五者梦见粪秽山上经行往来而不被污。菩萨何处曾更此事而梦见耶。若所梦事非曾更者。云何菩萨非颠倒耶。有作是说。梦所见事皆是曾更。问若尔云何梦见有角人耶。岂曾有时见人有角。答彼于觉时异处见人。异处见角。梦中惛乱见在一处故无有失。复次于大海中有兽似人头上有角彼曾见之。今还梦见以大海中遍有一切有情形类故名大海。问菩萨五梦复云何通。菩萨岂曾更如是事。答曾更有二。一者曾见。二者曾闻。菩萨昔时虽未曾见而曾闻故今梦见之。问菩萨何时闻如是事。答曾于过去诸佛法中修习梵行。彼佛亦曾梦见斯事为其宣说从彼得闻故今梦见。有作是说。劫初时人亦有梦见如是事者。从彼传说菩萨得闻。由此今时复还梦见。复有说者。梦所见事非必曾更。问若尔云何菩萨非颠倒耶。答此是无上正等菩提之先兆故非颠倒摄。问诸占梦书谁之所造。答仙人所造。彼由宿住随念智力忆念本事而造此书。问彼智不能观未来境。观未来境乃是愿智。彼无愿智。云何能造占未来事诸梦书耶。答彼由比知未来梦事。谓见过去如是梦者有如是果。现在亦然。由此比知未来如是梦者亦当有如是果。故彼能造诸占梦书。有说。诸仙亦有获得妙愿智者。能造此书为诸有情避危难故。问梦境宿住随念智境何者为多。答梦境多。非第四静虑宿住随念智境。所以者何。第四静虑宿住随念智唯能忆念三无数劫。梦则能知无数无数大劫之事故。有问言颇有不入静虑不起通慧而能得知无数无数大劫事不。答有。谓梦问如世尊说汝等当断如梦之法。此法是何。谓五取蕴。何故取蕴说如梦耶。答刹那性故。不久住故。诳有情故。灭坏法故。虚为性故。难厌足故。说之如梦

说一切有部发智大毗婆沙论卷第三十七阿毗达磨大毗婆沙论卷第三十八

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中无惭 愧 纳息第五之 余

如契经说有五盖。为五盖摄诸盖。为诸盖摄五盖乃至广说。问何故作此论。答欲令疑者得决定故。如契经说有五盖。一贪欲盖。二嗔恚盖。三惛沉睡眠盖。四掉举恶作盖。五疑盖。或有生疑盖唯有五无明非盖。欲令此疑得决定故。显五盖外别有第六。谓无明盖。由此因缘故作此论。为五盖摄诸盖。为诸盖摄五盖。合诸盖摄五盖。非五盖摄诸盖不摄何等。谓无明盖诸盖多故能摄五盖五盖少故不摄诸盖。如大器能覆小器。小器不能覆大器。无明随眠虽亦是盖。重故不说在五盖中。世尊别立为第六盖。谓前五盖势力皆等。无明偏重是故别说。为证此义复引契经。如世尊说

  无明盖所覆　　爱结所系缚
  愚智俱感得　　如是有识身

问无明是盖亦是结。爱是结亦是盖。何故此中说无明唯是盖。说爱唯是结耶。答无明亦应说是结爱。亦应说是盖。而不说者应知此是有余之说。复次欲现种种文种种说故。若以种种文种种说者。义则易解易可受持余便烦乱。复次欲现二门乃至广说。如无明说盖。爱亦应尔。如爱说结无明亦应尔。为现二门乃至广说。是故无明但说为盖。爱但名结。复次无明盖义多结义少故但说为盖。爱结义多盖义少故但说为结。复次无明盖义重结义轻故但说为盖。爱结义重盖义轻故但说为结。复次覆义是盖义。诸烦恼中。更无第二烦恼能覆有情慧眼如无明者故说为盖。系义是结义。诸烦恼中。更无第二烦恼系缚有情久处生死如贪爱者故说为结。诸有情类为无明盖所盲爱结所缚故。不能弃舍生死趣向涅槃。譬如有人遭二怨贼。一缚其手足。二以土坌眼。是人被缚眼无所见。不能逃避至安隐处。有情亦尔。无明所覆贪爱所结。不能舍离生死趣向涅槃。此中应说二怨贼喻。昔有二贼。一名伊利一名舍奢。恒共游止。若遇财主一缚手足一坌其目取财而去。其人被缚目无所见。即于是处困苦至死。有情亦然。无明贪爱所覆系故沉沦生死。是故尊者妙音说曰。诸有情类无明所盲贪爱所缚。久处生死增长恶法。是故无明偏说为盖。爱偏名结其义善立。然无明盖势用偏重一胜前五故佛不说在五盖中。五盖势力皆齐等故。诸盖彼覆耶乃至广说。问何故复作此论。答先依契经理趣但于五盖外别立第六无明为盖。今欲依对法理趣说一切烦恼无非是盖。以覆障义是盖义故。一切烦恼皆能覆障圣道及圣道加行善根。是故皆名为盖。由此因缘复作斯论。诸盖彼覆耶。答应作四句。此中盖者依性相说。贪欲等五。若过去若未来若现在无不皆是所立五中盖性相故。皆名为盖。此中覆者依作用说。一切烦恼在现在时有覆作用故名为覆。过去未来无覆作用故不名覆。由此二种互有宽狭故作四句。有盖非覆。谓过去未来五盖。此有盖性相故名为盖。而无覆作用故不名覆。以过去者作用已息。未来者未有作用故。问过去盖覆过去相续。未来盖覆未来相续。现在盖覆现在相续。何故今说过去未来是盖非覆。答若依诸法自性说者覆通三世。以诸法自性通三世故。若依补特伽罗说者覆唯现在。以补特伽罗唯现在故。谓唯于现在蕴界处法立补特伽罗非于过未。彼堕法数非有情故。今唯依彼补特伽罗建立覆义故唯现在。又先已说覆依作用立故不应为难。有覆非盖。谓除五盖诸余烦恼现在前。此复云何。谓色无色界一切烦恼。欲界见慢无明及五盖所不摄诸缠现在前。是谓覆非盖。问何故唯说现在烦恼是覆非余。答若说现在当知亦说过去未来性相同故。然现在世有覆作用显故偏说。复次现在烦恼于自相续覆障圣道及圣道加行善根。过未不尔故说现在。复次现在烦恼于自相续发起诸业。过未不尔故说现在。复次现在烦恼于自相续取果与果。过未不尔故说现在。复次现在烦恼于自相续能为同类因遍行因异熟因取等流果异熟果。过未不尔故说现在。复次现在烦恼于自相续能为染污现可呵责令没淤泥堕非理处。过未不尔故说现在。复次现在烦恼于自相续作热恼事作损害事。过未不尔故说现在。复次现在烦恼于自相续作自性愚及所缘愚。过未不尔故说现在复次现在烦恼于自相续愚于三世及离世法。过未不尔故说现在。复次现在烦恼障碍所依所缘行相令不解脱。过未不尔故说现在。由如是等种种因缘。唯说现在烦恼名覆。有盖亦覆。谓五盖随一现在前。谓贪欲盖现在前时。觉位有三盖现在前。谓贪欲惛沉掉举。睡位有四盖现在前。谓前三并睡眠。如贪欲盖。嗔恚恶作疑盖亦尔。若惛沈盖现在前时。觉位定有二盖现在谓。谓惛沉掉举。睡位定有三盖现在前。谓前二并睡眠。如惛沈盖掉举盖亦尔。若睡眠盖现在前时。定有三盖现在前。谓睡眠惛沉掉举。如是五盖现在前时。亦名为盖有盖性相故。亦名为覆有覆作用故。有非盖非覆。谓除前相

此中所名以相声说。若法已立名已称说者作前三句。未立名未称说者作第四句。故言除前相。此复云何。谓行蕴中作四句。过去未来五盖为初句除五盖。诸余现在烦恼为第二句现在五盖为第三句。余相应不相应行蕴及四蕴。全并三无为为第四句。诸欲界系无明随眠彼一切不善耶。乃至广说。问何故作此论。答前显无明亦是盖性。未显不善今欲显之。复次为止他宗显正义故。谓或有执一切烦恼皆是不善。如譬喻者彼作是说。一切烦恼不巧便慧所摄持故皆是不善。为遮彼执显诸烦恼有是不善有是无记。问一切烦恼不巧便慧所摄持故应皆不善。如何亦说有无记耶。答感不爱果故名不善。非不巧便所摄持故。若不尔者。无覆无记应有不善彼性中亦有不巧便者故。或复有执欲界烦恼皆是不善。色无色界一切烦恼皆是无记。为遮彼执显欲界身见边见及彼相应无明亦是无记。由是因缘故作斯论。诸欲界系无明随眠彼一切不善耶。答诸不善无明随眠皆欲界系。有欲界系无明随眠非不善。谓欲界系有身见边执见相应无明。问何故欲界身见边见及彼相应俱有等法非不善。耶。答若法体是无惭无愧。或彼相应。或彼俱有。或彼所生者是不善。身见等法与彼相违故非不善。所余广释如后结蕴不善纳息。诸色无色界系无明随眠彼一切无记耶。乃至广说。问何故复作此论。答前显无明有是不善性。未显亦无记今欲显之复作斯论。诸色无色界系无明随眠彼一切无记耶。答诸色无色界系无明随眠皆是无记。有无记无明随眠非色无色界系。谓欲界系有身见边执见相应无明问何故色无色界系烦恼。及彼相应俱有等法非不善耶。答若法体是无惭无愧。或彼相应。或彼俱有。或彼所生者。是不善。上二界系烦恼等法与彼相违故非不善。所余广释如后结蕴不善纳息。诸见苦集所断无明随眠彼皆是遍行耶。乃至广说。问何故作此论。答前说无明是不善或无记。而未说彼是遍行非遍行。今欲说之故作斯论。诸见苦集所断无明随眠彼皆是遍行耶。答诸是遍行无明随眠皆见苦集所断。有见苦集所断无明随眠非遍行。谓见苦集所断非遍行随眠相应无明。即见苦集所断贪嗔慢随眠相应无明。诸见灭道所断无明随眠彼皆非遍行耶。答诸见灭道所断无明随眠皆非遍行。有非遍行无明随眠非见灭道所断。谓见苦集所断非遍行随眠相应无明。即见苦集所断贪嗔慢随眠相应无明。此中遍行非遍行义。余处广说故不显示

云何不共无明随眠乃至广说。问何故作此论。答前说无明亦是盖性是不善或无记。是遍行非遍行。未说无明是不共非不共。今欲说之。复次前说烦恼相应无明。未说烦恼不相应无明。今欲说之故作斯论。云何不共无明随眠答诸无明于苦不了于集灭道不了。此中不了者显不欲忍义。谓由无明迷覆心故。于四圣谛不欲不忍故名不了。非但不明。如贫贱人恶食在腹虽遇好食不欲食之。异生亦尔。无明覆心闻四圣谛不欲不忍。问若尔云何不名邪见。答无行相转说名邪见。此唯不欲非无行相故非邪见。复次谤毁实物名为邪见。此唯不忍故非邪见。问此中所说不了名言为显自性。为显行相。为显所缘。有作是说。此显无明自性。问如是无明行相云何。答无知黑闇愚痴是此无明行相。问如是无明所缘云何。答即四圣谛。有余师说。此显无明行相。谓此无明唯于四圣谛不了行相转。问若尔品类足论所说当云何通。如说云何不共无明随眠随增。谓无知黑闇愚痴。答应知彼论是有余说。彼说无明行相不尽。谓此更有不了行相。有说不了即是无知黑闇愚痴无相违过。问如是无明自性云何。答自体自相即此自性。如说诸法自性即是诸法自相。同类性是共相。问如是无明所缘云何。答即四圣谛。复有说者。此显无明所缘。谓于苦不了者说缘苦谛。于集灭道不了者说缘集灭道谛。自性行相皆如前说。评曰。应作是说。如是无明于四圣谛。一向愚钝一向闇昧。一向不明了。一向不决择。以为自性。已说自性所以今当说。问如是无明何故名不共。不共是何义。答如是无明自力而起非余随眠相应起故名为不共。非如贪等相应无明他力而起。有作是说如是无明非余随眠相杂而起故名不共。有余师说。如是无明与余随眠不同意乐故名不共。或有说者。如是无明与余随眠所作各别故名不共。复有说者。如是无明迷四圣谛不与随眠相应而起故名不共。或复有说。如是无明不与随眠相应。唯是异生所起故名不共。有余复说。如是无明于起烦恼最为上首故名不共。问不共无明为但见所断。为通五部耶。设尔何失。若唯见所断识身论说当云何通。如说彼是修所断不共无明相应心。若通五部。此本论文何故不说而但言于苦不了于集灭道不了耶。答应作是说。如是无明唯见所断。问若尔识身论说当云何通。答彼文应作是说。彼是修所断随眠不相应无明相应心。不应说言彼是修所断不共无明相应心。问说不共无明相应心。说随眠不相应无明相应心。义有何异。答修所断无明容有随眠不相应者。而不名不共。所以者何。他力起故。谓若无明自力而起。非余随眠相应起者名为不共。修所断无明虽有不与随眠相应起者。而非自力所起。是忿恨等力所起故不名不共。有作是说。不共无明五部皆有。问若尔此本论文何故不说。答此中但说见道所断不共无明。以此无明迷四圣谛不与随眠相应起故。修所断者虽非随眠相应而起而不迷谛是故不说。复次此中但说唯异生起不共无明。修所断者圣者亦起是故不说。复次此中但说通缘有漏无漏有为无为不共无明。修所断者但缘有漏有为是故不说。复次此中但说自力而起不共无明。修所断者他力所起是故不说。问此修所断不共无明何心中有。答若欲界者。十小烦恼地法等俱心中可得。初静虑者。谄诳憍俱心中可得。第二静虑以上地者。唯憍相应心中可得。问此中所说不共无明何位现起。答若诸异生由胜解力发起正见。或起邪见。心劳惓时数数间起。迷四圣谛不共无明。谓缘四谛不欲不忍不了行相。问一切心中皆有般若何缘今说不共无明于谛不了。答慧为无明所覆蔽故不明不净。于四圣谛亦不能了。复次此中但说不共无明于谛不了。不说般若故不应责。问颇有随眠不与随眠相应耶。答有。即前所说不共无明及修所断忿等俱起无明随眠。问颇有随眠不名有随眠耶。答有。即前所说不共无明及修所断忿等俱起无明随眠缘彼随眠已断尽者。问颇有随眠于诸随眠不随增耶。答有。即前所说不共无明缘无漏者。问颇有随眠非诸随眠所随增耶。答有。谓诸随眠已离系者。问如有随眠不与随眠相应而起。颇有随眠不与诸缠相应起耶。答无。一切随眠皆与惛沉掉举俱故。问如有随眠不与随眠相应而起。颇亦有缠而不与缠相应起耶。答无。诸染污心皆与惛沉掉举俱故问如有随眠不与随眠相应而起颇亦有缠不与随眠相应起耶。答无诸缠必与无明随眠相应起故

云何不共掉举缠。答无不共掉举缠。问何故作此论。答为令疑者得决定故。谓无明与掉举俱通三界五部六识。不善无记遍与一切染污心俱。或有生疑如无明有不共掉举亦尔。欲令此疑得决定故。显掉举缠无不共者故作斯论。谓掉举缠必与无明随眠俱故。亦与惛沈缠相应故不名不共。问惛沉掉举皆与一切染污心俱。何故此中但说掉举非惛沈耶。答是作论者意欲尔故。乃至广说。复次亦应说惛沈而不说者应知是有余说。复次惛沉掉举恒相应故。此中说一则已说余。复次以掉举缠随顺放逸多诸过失坚固猛利。惛沈不尔是故偏说。由此契经于顺上分五结门中唯立掉举。品类足论唯说掉举在十烦恼大地法中施设论中唯说掉举在五法内。如说异生欲贪随眠起时必起五法。一欲贪随眠。二欲贪随眠增长生。三无明随眠。四无明随眠增长生。五掉举。如是等处皆由掉举多过失故偏说非余此中亦尔。复次以掉举缠数行猛利绕乱四支五支静虑是故偏说。惛沈愚钝随顺等持似定而转。惛沈现前便速入定过失轻故此中不说。复次以掉举缠败坏善品令于定境不能专注。惛沈不尔是故偏说。复次以掉举缠绕乱心品于诸善法不欲勤修。设欲勤修速还懈废。惛沈不尔是故偏说。复次以彼惛沈似无明转。前已广说。无明随眠则已说彼是故不说。复次以掉举缠猛利坚固多诸过失。或有谓彼同于随眠亦有不共。是故偏说无不共者

    杂蕴第一中相纳息第六之一

色法生住老无常当言色耶非色耶。如是等章及解章义既领会已。次应广释。问何故作此论答为广分别契经义故。如契经说。佛告苾刍。法有二种。一者有为。二者无为。有为之起亦可了知。尽及住异亦可了知。无为无起而可了知。无尽住异而可了知诸师于此契经义趣。不如实知起种种执。谓或有执。诸有为相非实有体。如譬喻者彼作是说诸有为相是不相应行蕴所摄。不相应行蕴无有实体。故诸有为相非实有体。为遮彼执显有为相实有自体。或复有执。诸有为相皆是无为。如分别论者彼作是说。若有为相体是有为性羸劣故。则应不能生法住法异法灭法。以有为相体是无为性强盛故。便能生法乃至灭法。或复有执。三相是有为。灭相是无为。如法密部彼作是说。若无常相体是有为性羸劣故。不能灭法。以是无为性强盛故便能灭法。为遮彼执显有为相皆是有为。或复有执。相与所相一切相似。如相似相续沙门。彼作是说。色法生住老无常体还是色。乃至识法生老住无常体还是识。为遮彼执显有为相。唯不相应行蕴所摄。或复有执。色等五蕴。出胎时名生。相续时名住。衰变时名异。命终时名灭。如经部师为遮彼执显彼唯是众同分相非有为相。有为相者诸有为法一一刹那皆具四相。复次为令疑者得决定故。如定蕴说。过去法得或过去或未来或现在。未来现在法得亦尔。或有生疑。如得与法有同世者有异世者。相与所相亦应如是。为令彼疑得决定故。显相与法无异世者。所以者何。得与所得不同一果。不定俱行非俱有因故。或异世。相与所相是同一果决定俱行。为俱有因故必同世。为遮前说种种异宗。及为除疑故作斯论

色法生住老无常当言色耶非色耶。答应言非色。此中色法谓十色处及法处少分。彼有为相但是非色唯法处摄。此即所相能相异类非色法。生住老无常当言非色耶色耶。答应言非色。此中非色法。谓意处及法处少分。彼有为相如前说。此即所相能相同类有见法。生住老无常当言有见耶无见耶答应言无见。此中有见法谓色处彼有为相但是无见唯法处摄。此即所相能相异类。无见法生住老无常。当言无见耶有见耶。答应言无见此中无见法。谓十一处除色处。彼有为相如前说。此即所相能相同类。有对法生住老无常当言有对耶无对耶。答应言无对。此中有对法谓十色处。彼有为相但是无对。唯法处摄。此即所相能相异类无对法生住老无常当言无对耶有对耶。答应言无对。此中无对法谓意处法处彼有为相如前说。此即所相能相同类。有漏法生住老无常。当言有漏耶无漏耶。答应言有漏。此中有漏法谓十色处及二处少分。彼有为相但是有漏唯法处摄。此后诸门所相能相皆是同类。无漏法生住老无常。当言无漏耶有漏耶。答应言无漏此中无漏法。谓意处法处少分。彼有为相但是无漏唯法处摄。有为法生住老无常当言有为耶无为耶。答应言有为。此中有为法谓十一处及法处少分。彼有为相但是有为唯法处摄。无为法生住老无常当言无为耶有为耶。答应言无为法无生住老无常。此中无为法谓法处少分是无为故无有为相。此前所说五种二门所相能相有同有异此后所说五种三门所相能相一切皆同。如应当知摄处多少。及随所应遮前异执谓说所相能相世同即遮经部异时四相。说色等相非色等摄即遮相似相续沙门。说色等相还色等摄。说生等相皆是有为。即遮法密分别论者说生等相是无为法。十门分别生等诸相一切皆遮譬喻者说生等诸相体非实有。非实有法如瓶衣等不应如是广分别故

云何老乃至广说。问何故作此论答前已依贤圣道理显有为相。今欲依世俗道理显有为相前已依贤圣言说显有为相今欲依世俗言说显有为相。前已依胜义谛显有为相。今欲依世俗谛显有为相。复次前已显细有为相。今欲显粗有为相前已显觉慧现见有为相。今欲显色根现见有为相。前已显刹那有为相。今欲显相续有为相。前已显连缚有为相。今欲显分位有为相。故作斯论。问此中何故不问生耶。答是作论者意欲尔故。乃至广说。复次亦应问而不问者应知此中是有余说。复次若令诸法损灭散坏此中说之。生令诸法增长炽盛是故不说。复次若令诸法衰退离散此中说之。生令诸法增盛和合是故不说。云何老。答诸行向背熟变相是谓老。契经中说发希发白皮缓皮皱色衰力损身曲背偻喘息短急气势萎羸行步迟微扶杖进止体多黡黑。犹如彩画诸根昧熟支分变坏举身战掉动转呻吟诸行朽败是名为老。阿毗达磨或说蕴熟。或如此中所说老相。诸行向者。趣向死门诸行背者。弃背少壮。诸行熟者。诸根昧熟诸行变者。身力衰变。尊者世友作如是说诸行损败故名为老。如故衣等。诸行朽坏故名为老。如破车等。诸行羸弱故名为老。如朽舍等。诸行衰萃故名为老。如萎花等。诸行慢缓故名为老。如乐器等。大德说曰。已生诸行损盛引衰故名为老。云何死答彼彼有情从彼彼有情众同分移转坏没舍寿暖命根灭弃诸蕴身殒丧是谓死。契经说死与此相同。文句虽多而义无别同显死故。云何无常。答诸行散坏破没亡退是谓无常。此中文句虽有多种义亦无别。皆共显了无常义故。问云何无常散坏诸行。答非如散坏谷豆等物。但令诸行无复作用故名散坏。谓一刹那作所作已。第二刹那不复能作死无常何差别。答诸死是无常。有无常非死谓除死余行灭。问何故复作此论。答世说无常与死无异。欲显差别故作斯论谓死唯内。唯有情数。唯有根心。无常通内外有情无情数有根无根有心无心。是谓差别。问云何死亦无常。云何无常非死耶。答最后命根灭名死亦无常。余时命根灭名无常非死。复次最后诸蕴灭名死亦无常。余时诸蕴灭名无常非死。复次内诸蕴灭名死亦无常。外诸蕴灭名无常非死。如内外有情数无情数。有根无根。有心无心。应知亦尔业力强耶无常力强耶。答业力强非无常力。此中圣道以业声说。无常者谓灭相。佛于圣道或说为受或说为想或说为思或说为意或说为灯或说为信精进念定慧。或说为船筏山石水花。或说为慈悲喜舍。如是一一别释如经。此中圣道说名为业。故业力强非无常力。有作是说。无常力强非业力。所以者何。此业亦无常故。如人能杀千人敌者是人名为胜千人敌。此亦如是。故无常力强非业力。于此义中业力强非无常力。所以者何。业能灭三世行。无常唯灭现在行故。谓圣道力灭三世行断彼诸行得择灭故。无常唯能灭现在行令彼不复有作用故。复次圣道业力能灭可生不可生行令得择灭。亦令诸行在未来世毕竟不生得非择灭。无常唯能灭可生行非不生者故业力强。有作是说。此中业者能引五趣众同分业。无常者谓灭相故。业力强非无常力。有说无常力强非业力。所以者何。此业亦无常故。于此义中业力强非无常力。所以者何。业力能引五趣众同分。无常唯能灭现在行故。有余师说。此中业者谓能和合。无常力者谓能别离故。业力强非无常力。有说无常力强非业力。所以者何。此业亦无常故。于此义中业力强非无常力。所以者何。和合事难别离易故。如作器难坏器则易。此亦如是故业力强。复有说者。此中业力谓一切种身语意业。无常力者谓无常相故。业力强非无常力。有说无常力强非业力。所以者何。此业亦无常故。于此义中业力强非无常力。所以者何。业力能感一切果法。无常唯能灭起法故

说一切有部发智大毗婆沙论卷第三十八阿毗达磨大毗婆沙论卷第三十九

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中相纳息第六之二

如世尊说有三有为之有为相。有为之起亦可了知。尽及住异亦可了知。一刹那中云何起。答生云何尽。答无常。云何住异。答老。问何故作此论。答为欲分别契经义故。谓契经说有三有为之有为相。乃至广说。虽作是说而不显示云何起尽云何住异经是此论所依根本。彼不说者今应说之。复次为止他宗显正义故。谓或有执三有为相非一刹那。如譬喻者彼作是说。若一刹那有三相者。则应一法一时亦生亦老亦灭。然无此理互相违故。应说诸法初起名生。后尽名灭。中熟名老。为遮彼执显一刹那具有三相。问若如是者。则应一法一时亦生亦老亦灭答作用时异故不相违。谓法生时生有作用。灭时老灭方有作用。体虽同时用有先后。一法生灭作用究竟名一刹那故无有失。或生灭位非一刹那。然一刹那具有三体故。说三相同一刹那。由此因缘故作斯论问诸行自性有转变不。设尔何失。若有转变云何诸法不舍自相。若无转变云何此中说有住异。答应说诸行自性无有转变。问若尔何故此中说有住异。答此中住异是老别名。非谓转变。如生名起无常名尽老名住异应知亦然。复次有因缘故说无转变。有因缘故说有转变。有因缘故无转变者。谓一切法各住自体。自我自物自性自相无有转变。有因缘故有转变者。谓有为法得势时生。失势时灭。得力时生。失力时灭。得士用时生。失士用时灭。得增上时生。失增上时灭。得功能时生。失功能时灭。炽盛时生。萎歇时灭。增进时生。衰退时灭。兴举时生。堕落时灭。猛利时生迟钝时灭。滋茂时生。枯瘁时灭。和合时生。离散时灭。故有转变。复次转变有二种。一者自体转变。二者作用转变。若依自体转变说者。应言诸行无有转变。以彼自体无改易故。若依作用转变说者。应言诸行亦有转变。谓法未来未有作用。若至现在便有作用。若入过去作用已息。故有转变。复次转变有二种。一者自体转变。二者功能转变。若依自体转变说者。应言诸行无有转变。以彼自体无改易故若依功能转变说者。应言诸行亦有转变。谓未来世有生等功能现在世有灭等功能。过去世有与果功能。故有转变复次转变有二种。一者物转变。二者世转变。若依物转变说者。应言诸行无有转变以物恒时无改易故。若依世转变说者。应言诸行亦有转变。谓有未来现在过去世改易故。既有转变说有异相无违理失问诸有为相于有为法。为是自相为共相耶。设尔何失。若是自相云何一法而有四相。若是共相云何一切有为法各各别有四相耶。有作是说。此是自相。问若尔云何一法有四相耶。答一法四相亦无有失。如一色法有多种相。所谓如病如痈如箭。乃至广说百四十相。然此自相非如四大种坚湿暖动相。但一一法各各别有生住异灭故名自相。复次自相有二种。一者主自相。二者客自相。此有为相是有为法客自相非主自相。故一法有四相亦无有失。复次自相有二种。一者本性自相。二者他合自相。此有为相是有为法。他合自相。非本性自相故一法有四相亦无有失。有余师说。此是共相。问若尔云何一切有为法各各别有四相耶。答以相似故名为共相。如一法上有生等四。余法亦然非如一缕贯在众花故名共相。复有说者。此非自相亦非共相。诸有为法生住异灭名义同故体各别故。然此生等是法标印。若有此者知是有为。如大士相于彼大士。不名自相亦非共相但是标印。若有此者知是大士。生等亦然评曰。应作是说。此是共相。然共相有二种。一者自体共相。谓一一有为法自体各有生等四义。二者和合共相。谓一一有为法各与生等四相和合。此四但是和合共相问生相复有余生相不。设尔何失。若有者此复有余。此复有余如是展转应成无穷。若无者谁生此生而生他耶。答应作是说。生复有生。问若尔生相应成无穷。有作是说。许此无穷亦无有失。三世宽博岂无住处。由是因缘生死难断难破难越众苦生长连锁无穷。又同一刹那故无无穷失。有余师说。诸行生时三法俱起。一者法二者生三者生生。此中生能生二法。谓法及生生。生生唯生一法。谓生。由此道理无无穷失。问何故生能生二法。生生唯生生耶。答法性尔故不应为难。如诸女人有生二子有生一子。岂应为难评曰。应作是说。诸行生时九法俱起。一者法。二者生。三者生生。四者住。五者住住。六者异。七者异异。八者灭。九者灭灭。此中生能生八法。谓法及三相四随相。生生唯生一法。谓生由此道理无无穷失。问何故生能生八法。生生唯生生耶。答法性尔故不应为难。如鸡犬等有生八子有生一子。岂应为难。如生与生生。住与住住。异与异异。灭与灭灭。应知亦尔。问诸行起时除其自性余有为法皆有作用能生此法。何故唯说生能生此法耶。答诸行起时生正能生。余但佐助故但说生能生此法。如女产时虽有诸女而为佐助母正生故独名产者。尊者世友作如是说。要有生故此法得生故但说生能生此法。此义有余亦待余缘此法生故。复作是说。若无生者此法不生故但说生能生此法。此亦有余。若无余缘法不生故。大德说曰。生相胜故说生能生。谓法起时虽有余缘而生最胜。如伎书画染衣等时虽有余缘而说胜者。如但说生能生此法故名生相。住异灭相应知亦然

问诸有为法有住相不。设尔何失。若有者有为相中何故不说。如世尊说有三有为之有为相不说有四。又契经说复云何通。如说苾刍诸行。不住若无者此前所说当云何通。如说色法生住老无常当言色耶。非色耶。乃至广说。品类足说复云何通。如说云何生谓诸行起。云何住。谓诸行生已不坏。云何老谓诸行熟。云何无常谓诸行生已坏。答应作是说。有为法有住相。问若尔有为相中何故不说。答契经应说有四有为之有为相。而不说者应知彼是有余之说。复次诸有为法实有住相。似无为故佛不说在有为相中。复次若法能令诸行损减。世尊说在有为相中。住相能令诸行增益故不说在有为相中。问生亦能令诸行增益。何故说在有为相中。答生最能令诸行损减非老无常。所以者何。若生不引令入现在。老何所衰。无常宁灭。由生引行令入现在故。老能衰。无常能灭。故生最能损减诸行。譬如有人隐在稠林。有三怨敌欲为损害。一从稠林牵之令出。一损其力。一断彼命。若一不从稠林牵出。二何损害。三相于行应知亦然。复次若法能令诸行和合及令散坏世尊说在有为相中。生相能令诸行和合。异灭能令诸行散坏。住相不尔故不说在有为相中。复次若法能令诸行历世。世尊说在有为相中。生相令行从未来世入现在世。异灭令行从现在世入过去世。住相不尔。故不说在有为相中。复次标别有为名有为相。住相堕在无为部中。故佛不说名有为相。有说彼经亦说住相。如彼经说。尽及住异亦可了知。住即住相。问何故但说有三有为之有为相。答住异合立故但说三。世尊欲令厌有为法欣求寂灭故于彼经住异合说

如示室利与黑耳俱。令诸有情住异俱舍。问契经所说复云何通。如说苾刍诸行不住。答不久住故说不住言。非谓全无刹那住相。尊者世友作是释言。契经但遮刹那后住说不住言。非谓诸行无刹那住。若全无住。世尊不应建立施设世及刹那。复作是释。刹那住相微细难知难可施设故说不住。谓刹那量是佛所知非诸声闻独觉等境。如乘神通屈伸臂顷从此处没至色究竟于其中间非不相续可有从此往至彼义亦非一法移转至彼。又无从此越至彼义。是故决定刹那刹那生灭相续。从此至彼于其中间诸刹那量最极微细唯佛能知。由此故言诸行不住。大德释曰。诸行生已虽少时住而老无常速即损灭故言不住。有作是说。有为法无住相。问此前所说当云何通。如说色法生住老无常。乃至广说。答此前应说色法生老无常。乃至广说。不应言住而言住者。应知此住是老别名。如生名起无常名尽老名为住应知亦尔。故三相中老名住异。问品类足说复云何通。如说云何住谓诸行生已不坏。答彼论所说我不能通。评曰。既不能通应信有住。由住相力诸行生已能取自果能取所缘。由异灭力一刹那后无复作用。若无住相诸行应无因果相续。心心所法应无所缘。故必有住。问言异相者。为灭坏故名为异相。为转变故名异相耶。设尔何失。若灭坏故名异相者。应有为相但有三种。异即灭故。若转变故名异相者。应同转变外道所宗。答应作是说。非灭坏故及转变故名为异相。然令诸行作用损败。作用朽故作用羸弱。作用衰瘁。作用慢缓。故名异相。有作是说。令转变故名为异相问若尔应同转变外道所立宗义。答彼执诸行相续转时前位不灭转变为后。如薪成灰乳为酪等。今说诸行相续转时前灭后生而有转变。谓有为法生时势盛。灭时势衰。生时力强。灭时力劣。生时名新。灭时名故。生时滋茂。灭时枯瘁。生时和合灭时离散生时兴举灭时堕落。生时猛利。灭时迟钝。生时得作用。灭时失作用。生时得增上灭时失增上。生时得功能。灭时失功能。生时炽盛。灭时萎歇。生时增进灭时退减生时得士用。灭时失士用。生时未熟。灭时已熟故名转变非同外道问诸有为相与所相法。为同为异设尔何失。若同者云何四不为一。一不为四。又取一时应作四解。若异者云何不以余相为相。有作是说。相所相同。问若尔云何四不为一。一不为四。又取一时应作四解。答相虽有四而体是一。于一自体有多相故。于一所缘作四种解理亦无违。如于一物起无常等多行相故。有余师说。相所相异。问若尔云何不以余相为相。答无如是失能相所相从无始来互相属故。复次能相所相从无始来恒和合故。不相离故。常相随故。相杂住故。尊者世友作如是说。相所相异。然诸能相依所相起。如烟依火。是故不以余相为相。复次能相既是所相过患。虽不相离而相不同如病既是人之过患虽不相离而相各别。若病与人相不异者。其病若愈人亦应无。大德说曰。佛说生等是有为之相故知相属而相不同。如舍等属人而相有异问若一切刹那皆有老相何不一切时首生白发答此难非理老相白发不相即故。白发是色有见有对。老相非色无见无对。二体既异如何难言有老相时即有白发。复次老与少壮或有相违或不相违。若相违者首生白发。不相违者不生白发。复次若增益大种多损减大种少者不生白发。若损减大种多增益大种少者首生白发。复次气势强者不生白发。气势弱者首生白发。复次白发不由老相故起。但众同分将欲尽时有此异熟可厌相起。如酒油等将欲尽时法尔于中有滓秽起。问何界趣处有白发耶。答在欲界有非色无色。地狱趣无。傍生鬼有。人三洲有。除北俱卢。彼无如是可厌相故。乘纯净业而生彼故。由杂秽业白发生故。问如是白发何等人有。答异生圣者皆有白发。诸圣者中从预流果乃至独觉皆有白发唯除世尊。佛无此等可厌相故。以白发等是滓秽故。诸佛皆无发希发白皮缓皮皱音声破坏解支节苦。亦无心乱渐舍诸根般涅槃时诸根顿灭问佛田何业得此果耶。答先菩萨时三无数劫修集种种难行苦行所起善业。后后刹那转增转盛。信慧坚猛诸所施为。无萎歇故。由此善业为相似因。今受如斯相似胜果。故无发白面皱等事问若一切刹那皆有无常相者。何不一切时皆有尸骸相现。答若有根身灭有根身生者无尸骸相现。若有根身灭无根身生者有尸骸相现。复次若有心身灭有心身生者无尸骸相现。若有心身灭无心身生者有尸骸相现。复次若有情数身灭有情数身生者无尸骸相现。若有情数身灭无情数身生者有尸骸相现。复次若有执受身灭有执受身生者无尸骸相现若有执受身灭无执受身生者有尸骸相现。复次由诸有情业增上力命终后有尸骸相现。谓诸有情须受用彼皮肉筋骨发毛爪齿蹄角等故。由诸有情业增上力活时未有尸骸相现。谓一昼夜总有六十四亿九万九千九百八十刹那五蕴生灭。若一一刹那皆有尸骸相现者则一有情尸骸大地无容受处。既不埋殡深为可恶诸有情类逃避无方故。由有情业增上力活时未有尸骸相现。问化生有情于命终后何故无有尸骸相现。答以彼受生及命终时诸根身分顿得舍故。如人水中暂出暂没。不可知彼没何所至出何所从。故化生死后无尸骸相现复次化生有情其身轻妙。犹如火焰云雾电光灭则无余故无尸现。复次大种多者无有尸骸。彼造色多故无尸骸。复次非根多者死有尸骸。彼根法多故无尸骸。复次发毛爪等可舍法多者死有尸骸。化生有情可舍法少故无尸骸。复次览精血等以成身者死有尸骸。化生不尔故无尸骸

问诸有为法生时。为体是生法故生。为与生相合故生耶。设尔何失。若体是生法故生者。生相则应无用。若与生相合故生者。则无为法生相合故亦应可生。答应作是说。体是生法故生。问若尔生相则应无用。答虽体是生法若无生相合者则不可生。故彼生时由生相合生相是彼生胜因故如可破法破因能破及可断法断因能断。故可生法生相能生。有作是说。与生相合故生问若尔无为与生相合亦应可生。答无为无有生相合义故不可生。如虚空等。无破因合故不可破。无断因合故不可断。无生相合故不可生应知亦尔。生相与彼未尝合故。有为住异二种问答应知亦尔。问诸有为法灭时。为体是无常法故灭为与无常相合故灭耶设尔何失。若体是无常法故灭者则无常相应成无用。若与无常相合故灭者。则无为法无常合故亦应可灭答应作是说体是无常法故灭。问若尔无常相则应无用。答虽体是无常法。若无无常相合者则不可灭。故彼灭时由无常合。无常是彼灭胜因故。如可生法生因能生此亦如是。有作是说。与无常相合故灭。问若尔无为与无常合应亦可灭。答无为无有无常合义故不可灭。如虚空等无生相合故不可生。此亦如是无常与彼未尝合故。有余师说。有为体是生住异灭若无四相则不可知。犹如闇中有瓶衣等。若无灯照则不可知。此亦如是。故有为相是彼了因。评曰。应知此中初说为善问如有为法有有为相。无为亦有无为相耶。设尔何失。若有者云何无为名非聚法。若无者品类足说当云何通。如说云何不生不住不灭法。谓一切无为法。答应作是说诸无为法无无为相问若尔品类足说当云何通。答翻对有为故作是说。谓有为法有生住灭。无为异彼说不生等。非谓别有不生等相如契经说。佛告苾刍。汝等有生有老有死有没有出。所以者何。汝等诸行犹如幻事阳焰等故。问此中所说生出死没有何差别。有作是说无有差别。生即是出死即是没。一切皆是刹那性故。尊者世友作如是说。入母胎时名生出母胎时名出。诸蕴熟时名没。舍诸蕴时名死。胁尊者曰。中有诸蕴得时名出。舍时名没。生分诸蕴得时名生。舍时名死。尊者妙音作如是说。胎卵湿生诸蕴起时名生诸根渐生故坏时名死有余尸骸故。化生诸蕴起时名出诸根顿出故。坏时名没无余尸骸故。大德说曰。于诸趣中初受生时名生。命根尽时名死。中间诸蕴刹那生时名出。刹那灭时名没。尊者觉天作如是说。有色有情生时名生。死时名死。无色有情生时名出。死时名没。是谓生出死没差别

    杂蕴第一中无义纳息第七之一

如世尊说

  修诸余苦行　　当知无义俱
  彼不获利安　　如陆挥船掉

如是等章及解章义既领会已。次应广释。问何故作此论。答为欲分别契经义故。虽一切论皆为释经。然此纳息释多经义。谓契经说世尊住在邬卢频螺池边泥烂缮那河侧菩提树下。成佛未久为诸声闻略说法要。告诸苾刍我已解脱无义苦行得解脱彼甚为善哉。自正愿力速证无上佛菩提故。时诸苾刍闻佛所说欢喜踊跃恭敬尊重。摄心属耳听受法要尔时恶魔作如是念。今彼沙门乔答摩种。菩提树下为众说法。其诸声闻恭敬听受。我今应往为作留难。便自化作摩纳婆身。来至佛前说伽他曰

  仁今舍苦行　　古仙真净道
  更修余秽道　　必不获清净

此中义者。谓彼恶魔于诸天身作真净想。于昔外道所修苦行。起能证得真净道想故。白佛言。仁今何故舍旧诸仙能得真净苦行妙道。修余鄙秽逸乐道耶。此必不能获得清净宜时速舍。故佛为彼说此颂言修诸余苦行。乃至广说。此颂意言。非我于彼外道苦行不能修故而弃舍之。但审观察如是苦行。毕竟不能断诸烦恼得真义利。故我舍之更修真实处中妙行。由斯已证无上菩提能拔众生生死剧苦。此颂义者。外道所修种种苦行。在正法外故说诸余。有说。应言下贱苦行。谓诸苦行略有二种。一者上胜。谓八圣道及彼眷属。二者下贱。谓诸外道所修苦行。杂我执故立下贱名复次彼诸外道所修苦行。为求世间生死苦果。以果劣故立下贱名。有说应言不死苦行。言不死者是天别名。即呼天魔名为不死。魔崇如是外道苦行故。此名为不死苦行。复次诸外道等希求天中诸妙欲乐。修此苦行故说名为不死苦行。次言当知无义俱者。修彼苦行当知能引此世他世诸衰损事名无义俱。复言彼不获利安者。重释前义。利谓利益。安谓安乐彼诸苦行不能永断诸烦恼故。不能引生殊胜善故。不获究竟利益安乐。如在陆地挥船掉者。唐设劬劳终无所遂。外道苦行当知亦尔。虽勤修习不获利安。时彼天魔复请佛曰。若此苦行不获利安。佛修何道得真清净。世尊告曰

  我修戒定慧　　处中真净道
  得究竟净果　　及无上菩提

契经虽作是说而不分别其义。经是此论所依根本。彼所不分别者今应尽分别之故作斯论。何故世尊作如是说。修余苦行无义俱耶。答彼行趣死近死至死非如是苦行能超越死故。谓诸有情为欲超越老死海故修彼苦行。然彼苦行从见趣起倍令沉没老死海故。佛说修彼与无义俱。生老死三遍在诸有。老死正是有情所厌死起厌强故此偏说。尊者妙音作如是说。一切流转皆名无义。一切还灭皆名有义。如是苦行从见趣起违背还灭。随顺流转。故说修彼与无义俱。大德说曰。三恶趣苦皆名无义。善趣解脱皆名有义。如是苦行邪方便起。违善趣等。顺恶趣苦故。说修彼与无义俱。尊者世友作如是说。如是苦行能令众生堕在生死。恒受诸界诸趣诸生诸处众苦。故说修彼与无义俱。又世尊说结加趺坐端身正愿住对面念。乃至广说。问何故作此论。答为欲分别契经义故。如契经说有诸苾刍。居阿练若。或在树下。或在静室结加趺坐。端身正愿住对面念。乃至广说。契经虽作是说。而不分别其义。经是此论所依根本。彼不说者今欲说之故作斯论。问诸威仪中皆得修善。何故但说结加趺坐。答此是贤圣常威仪故。谓过去未来过殑伽沙数量诸佛及佛弟子皆住此威仪而入定故。复次如是威仪顺善品故。谓若行住身速疲劳。若倚卧时便增惛睡。唯结加坐无斯过失。故能修习殊胜善品。复次如是威仪违恶法故。谓余威仪顺淫欲等诸不善法。唯结加坐能违彼故。复次如是威仪引人天等入正法故。谓余威仪不能引导人天龙鬼阿素洛等令入佛法。如结加坐威仪者故。复次如是威仪生人天等敬信心故。谓余威仪不能发起人天龙鬼阿素洛等敬信之心。如结加坐威仪者故。设此威仪生恶寻伺为生他善尚应住之。况自顺生殊胜善品。复次唯依此威仪证得无上佛菩提故。谓依余威仪亦能证得二乘菩提。不能证得佛菩提故。复次住此威仪怖魔军故。谓佛昔于菩提树下结加趺坐破二魔军。谓自在天及诸烦恼故。令魔众见此威仪即便惊恐多分退散。复次此是不共外道法故。谓余威仪外道亦有。唯结加坐外道无故。复次结加趺坐顺修定故。谓诸散善住余威仪皆能修习。若修定善唯结加坐最为随顺。由如是等种种因缘。是故但说结如趺坐。问结加趺坐义何谓耶。答是相周圆而安坐义。声论者曰。以两足趺加致两髀。如龙盘结端坐思惟。是故名为结加趺坐。胁尊者言。重垒两足左右交盘正观境界名结加坐。唯此威仪顺修定故。大德说曰。此是贤圣吉祥坐故名结加坐。问端身者是何义。答是身正直而安坐义。问正愿者是何义。答是顺善品而注心义。问住对面念是何义耶。答面谓定境。对谓现瞩。此念令心现瞩定境。无倒明了名对面念。复次面谓烦恼。对谓对治。此念对治能为生死上首烦恼名对面念。复次面谓自面。对谓对瞩此念令心对瞩自面。而观余境名对面念。问何故系念在自面耶。答无始时来男为女色。女为男色。多分依面故观自面伏诸烦恼。复次有情贪心多依面上眉眼唇齿耳鼻等生非余身支故。观自面伏除贪欲。复次面有七孔不净常流。生厌离心过余身分。故观自面而修厌舍。复次自面见希不多起爱故彼系念在面非余。若不照时自不见故。复次修观行者多乐观察十二处相。面上恒有九处差别。是故观之。有亦说为住背面念对背二义俱理无违。所以者何。由此念力弃背杂染。对向清净故。弃背生死。对向涅槃故。弃背流转。对向还灭故。弃背五欲。对向定境故。弃背萨迦耶见。对向空解脱门故。弃背我执。对向无我故。弃背邪法。对向正法故。由是对背俱理无违。安住此念者。名住对面念

说一切有部发智大毗婆沙论卷第三十九阿毗达磨大毗婆沙论卷第四十

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中无义纳息第七之二

云何名住对面念耶。答修观行者。系念眉间。或观青瘀或观膖胀。或观脓烂。或观破坏。或观异赤。或观被食。或观分离。或观白骨。或观骨锁。此等名为住对面念。问何缘系念在眉间耶。答修观行者。先依此处生贤圣乐后渐遍身。是故彼于眉间系念。如受欲者男女根处先生欲乐后渐遍身。此亦如是。亦有本说。系念明闇明者谓眼。即说系念在鼻按中。复有本说。系念发际。或有本说。系念鼻端。有本说。住无贪俱念。此即说。住奢摩地俱念。或有说。住与明俱念此即说住毗钵舍那俱念。修观行者如是系念在眉间等。观察死尸青瘀等相即不净观。此中名为住对面念问何故此中但说不净观名对面念。非持息念界差别观耶。答此中亦应说持息念界差别观名对面念。而不说者是有余说。复次应知此中且说初观。谓不净观是众观初。应知说初即显中后。复次应知此中就多分说。谓修观者多分依止不净观门趣入圣道。非持息念界差别观。是故偏说。尊者妙音作如是说。一切如理作意所引念皆名对面念。非唯不净观。然尊者迦多衍尼子随顺契经。且说不净观名对面念。谓契经说。有诸苾刍。居阿练若或在树下。或在静室。结加趺坐端身正愿住对面念。为断贪欲离贪欲故心多安住。如为断贪欲如是为断嗔恚惛沉睡眠掉举恶作疑应知亦尔。于五盖中贪欲最重。又最在初。是故遍说。彼近对治。谓不净观。贪欲若断。余随断故。不别说彼近对治法名对面念

问修观行者系念眉间。尔时当言住在何位。答超作意位。然瑜伽师修不净观总有三位。一初习业位。二已熟修位。三超作意位。修此观者复有三种。一者乐略。二者乐广。三乐广略。此中唯乐略者。谓彼行者先往冢间观察死尸青瘀等相。善取相已退坐一处重观彼相。若心散乱不明了者。复往冢间如前观察善取其相。如是乃至若得明了心不散乱速还住处。洗足就座结加趺坐。调适身心令离诸盖。忆念观察先所取相。以胜解力移属自身。始从青瘀乃至骨琐。于骨琐中。先观足骨。次观踝骨。次观胫骨。次观膝骨。次观髀骨。次观臗骨。次观腰骨。次观脊骨。次观胁骨。次观髆骨。次观臂骨。次观肘骨。次观腕骨。次观手骨。次观肩骨。次观项骨。次观颔骨。次观齿骨。后观髑髅。彼胜解力观察如是不净相已。系念眉间湛然而住。复转此念入身念住。展转乃至入法念住。是名乐略修观行者不净观成。唯乐广者。谓彼行者。先往冢间观察死尸青瘀等相如前广说。展转乃至系念眉间以止息已。复转此念。先观髑髅。次观齿骨。展转乃至后观足骨。彼胜解力观自骨已。复观外骨在自骨边。渐遍一床一房一寺一园一邑一田一川一国。展转乃至大海边际。周遍大地。心眼及处骨琐充满。复渐略之。乃至唯观自身骨琐。于中渐复略去足骨。展转乃至后观髑髅。彼胜解力观察如是不净相已。系念眉间堪然而住。复转此念入身念住。展转乃至入法念住。是名乐广修观行者不净观成。乐广略者。谓彼行者先往冢间观察死尸青瘀等相如前广说展转乃至大海边际。周遍大地。心眼及处骨琐充满。复渐略之。展转乃至后观髑髅。系念眉间少止息已。数复广略如前观察至纯熟已。系念眉间湛然而住。复转此念入身念住。展转乃至入法念住。是名乐广略修观行者不净观成。问何缘修此不净观时。数数广略缘不净境。答欲显观心得自在故。谓于境界得自在者。乃能数数广略观之。若不自在便无斯力。复次彼瑜伽师作如是念。我从无始生死已来烦恼乱心不净谓净。今于不净如实观察。欲令纯熟数广略观。复次欲显善根势力大故。义言我取少不净相便能渐广充满大地。复渐略之唯观少分。岂不于境势力大耶。复次彼瑜伽师自显力大。故数于境广略观察。谓无始来为欲贪力所执持故。于不净境不能自在广略观之。今伏欲贪得自在故。能数广略观不净境。是故此中应作四句。有不净观所缘少非自在少。谓彼但于自身数观不净。有不净观自在少非所缘少。谓彼暂于周遍大地起不净想不能数观。有不净观所缘少亦自在少。谓彼暂于自身起不净想。不能数观。有不净观非所缘少亦非自在少。谓彼能于周遍大地数观不净。复有四句。有不净观所缘无量非自在无量。谓即前第二句。有不净观自在无量非所缘无量。谓即前第一句。有不净观所缘无量亦自在无量。谓即前第四句。有不净观非所缘无量亦非自在无量。谓即前第三句。问修此三种不净观时。齐何名为初习业位。齐何名为已熟修位。齐何名为超作意位。答唯乐略者。从往冢间观察死尸青瘀等相广说乃至以胜解力移属自身。始从青瘀乃至骨琐。一切皆名初习业位。从于骨琐先观足骨。广说乃至后观髑髅。复于此中除半观半。复除一分。唯观一分。一切皆名已熟修位。以胜解力观察如是不净相已。系念眉间湛然而住。复转此念入身念住。展转乃至入法念住。一切皆名超作意位。唯乐广者。从往冢间观察死尸青瘀等相广说乃至复渐略之。乃至唯观自身骨琐。一切皆名初习业位。从复于中略去足骨。展转乃至后观髑髅。复于此中除半观半。复除一分唯观一分。一切皆名已熟修位。以胜解力观察如是不净相已。系念眉间湛然而住。乃至广说。一切皆名起作意位。乐广略者。从往冢间观察死尸青瘀等相广说乃至数复广略。如前观察。于中最后复渐略之。乃至唯观自身骨琐。一切皆名初习业位。从复于中略去足骨。展转乃至后观髑髅。复于此中除半观半。复除一分唯观一分。一切皆名已熟修位。至纯熟已系念眉间湛然而住。乃至广说。一切皆名超作意位。有作是说唯乐略者。从往冢间观察死尸青瘀等相广说乃至以胜解力移属自身。始从青瘀乃至骨琐。如是皆名初习业位。从于骨琐先观足骨。广说乃至后观髑髅。如是皆名已熟修位。以胜解力观察如是不净相已。系念眉间湛然而住。乃至广说。如是皆名超作意位。唯乐广者。从往冢间观察死尸青瘀等相广说乃至系念眉间少时止息。如是皆名初习业位。少止息已。复转此念先观髑髅。广说乃至后观髑髅。如是皆名已熟修位。以胜解力观察如是不净相已。系念眉间湛然而住。乃至广说。如是皆名超作意位。乐广略者。从往冢间观察死尸青瘀等相广说乃至系念眉间少时止息。如是皆名初习业位少止息已数复广略。如前观察。乃至纯熟。如是皆名已熟修位。至熟修已系念眉间堪然而住。乃至广说。如是皆名超作意位。有余师说。前说三种修此观者。从往冢间广说乃至系念眉间湛然而住。皆通初习业及已熟修位。有差别者。初习业位于其中间心有散乱。已熟修位于其中间心无散乱。若转此念复观髑髅。或左或右或后或前。起不净想入身念住。展转乃至入法念住。齐此名为超作意位。复有说者。乐略等三从往冢间广说乃至系念眉间湛然而住。皆通三位。有差别者。初习业位心有散乱亦不明了。已熟修位虽不散乱而未明了。超作意位心不散乱亦得明了。复次初习业位是下品故。观行迟钝多有留难。已熟修位是中品故。观行少利犹有留难。超作意位是上品故。观行迅速全无留难。是谓差别

问不净观以何为自性。答以无贪善根为自性。修定者说。以慧为自性。所以者何。经为量故。如契经说。眼见色已随观不净。如理思惟乃至广说。观是慧故。有余师说。以厌为自性。所以者何。厌所缘故。评曰。此不净观。无贪善根以为自性。非慧非厌。所以者何。对治贪故。问前契经说当云何通。答与慧相应故说为观。而此体是无贪善根。是缘色贪近对治故。若并眷属四蕴五蕴为其自性。此不净观。界者唯欲色界。以无色界无缘色法不净观故。地者十地。谓在欲界静虑中间及四静虑四近分故。所依者唯依欲界身。以色无色界身不起此观故。行相者非十六行相所缘者唯缘欲界色处为境。问此不净观为缘欲界一切色处。为少分耶。答此缘欲界一切色处。问若尔。经说当云何通。如契经说。尊者无灭在一林中宴坐树下。过初夜分有四天女。皆名悦意。端严殊妙。来至尊者无灭座前。合掌恭敬顶礼双足。退住一面。白尊者言。我四天女。能于四处变化自在。一者随欲化作种种上妙色身诸相爱者。我等皆能欢娱承事。二者随欲化作种种上妙衣服。三者随欲化作种种妙庄严具。四者随欲化作种种上妙花香饮食珍玩诸欲乐具。尊者颇能相纳受不。时彼尊者作是思惟。此四故来见相娆恼。我当于彼起不净观。既思惟已入初静虑不能起之。展转遂入第四静虑亦不能起。便作是念。此四天女有种种色。故我不能观为不净。彼若纯作一种色者。我必能观。遂告彼曰。诸姊。颇能皆为我现青色身不。时诸天女现青色身。尊者不能观为不净。令现黄赤犹故不能。复起念言。若作白色顺骸骨想。彼若更能为现白色。我定于彼能观不净。即告之言姊更为我变身为白。即为变之。亦复不能观为不净。以诸天女形色鲜洁如妙光明难起厌故。问尊者无灭何故令天转作青黄赤白四色。答欲观诸色变坏相故。复次色相移转易起厌故。复次青色随顺青瘀想故。黄色随顺脓[月*闌]想故。赤色随顺异赤想故。白色随顺骇骨想故。复次青黄赤白是众色本。又无诤论故令转变。历试自心能起厌不。尊者无灭知彼色妙。不能观之起不净想。遂便闭目默然而坐。彼知尊者都无染心。惭愧礼足忽尔不现。如二力士相叉扑时知力既齐解手而退。天女无灭应知亦然。既尔云何说不净观能缘欲界一切色耶。答无灭不能普于欲界一切色处起不净想。余有能者故不相违。如佛独觉舍利子等利根声闻皆能观故。问有缘佛色身起不净观不。有作是说。无有能者。佛色微妙最极鲜洁如净光明不可厌故。有余师说。佛能自缘起不净观。余无能者。或有说者。不净观有二种。一色缘起。二色过患。色缘起者。能缘佛身。色过患者。不能缘佛。复有说者。不净观有二种。一共相境。二自相境。共相境者能缘佛身。自相境者不能缘佛。此不净观念住者。身念住俱。有说。此非根本念住。但可是身念住加行。智者。世俗智俱。三摩地者。非三摩地俱。根相应者。总说但与三根相应。谓乐喜舍。过去未来现在者。是三世。过去缘过去。现在缘现在。未来生法缘未来。若不生法缘三世。善不善无记者。是善缘三种。系不系者。是欲色界系缘欲界系学无学非学非无学者。是非学非无学缘非学非无学。见所断修所断不断者。是修所断。缘修所断缘名缘义者。唯缘义。缘自相续他相续非相续者。缘自他相续。加行得离染得生得者。有加行得有离染得。非生得。离染得者。谓离染时而修得故。加行得者。谓作加行现在前故。佛无加行。独觉下加行。声闻或中加行。或上加行。异生上加行现在前。曾得未曾得者。通曾得未曾得。圣者菩萨后有异生通曾得未曾得。余异生唯曾得。闻思修所成者。通三种。在意地五识身者。唯在意地。问若尔。经说当云何通如契经说。眼见色已随观不净如理思惟。乃至广说。答五识为门引生意识起不净观。故作是说然不净观唯在意识。如意近行唯在意地亦由五识所引发故。契经亦说眼见色已。广说乃至意知法已。起喜忧舍六意近行。此亦如是。问此不净观亦缘声香味触法不。答此唯缘色不缘余五。问若尔。经说当云何通。如契经说。眼见色已。广说乃至意知法已。随观不净如理思惟。答由六识门引不净观。故作是说。然不净观缘色非余。复次依通对治。故作是说。谓不净观虽但缘色。而能对治缘六境贪。如为色贪所覆蔽者。修不净观而伏除彼。为声等贪所覆蔽者。亦修此观而伏除之。故作是说。复次先于色处起不净观。厌患诸色。后于依色声等五境亦能厌患。厌患声等虽是余观非不净观而不净观所引生故名不净观。复次先缘色处修不净观得纯熟已。后于余境亦欲厌患。若能者善。若不能者还缘色处起不净观。如欲战时先安营垒然后出战。若胜者善。若不胜者还投营垒。此亦如是故作是说。然不净观缘色非余。复次先于色处起不净观。后于声等起余厌观。彼与此观厌行相同。故亦说彼名不净观。复次不净观有二种一者根本。二者等流。若根本者。唯缘色处。若等流者。通缘声等乃至有漏心心所法。阿毗达磨唯说根本不净观故说缘色处。契经通说根本等流不净观故。说见色已广说乃至意知法已。随观不净如理思惟。问谁能起此不净观耶。答圣者异生俱能现起。圣通一切学无学位。问何处起此不净观耶。答唯人三洲能初现起。天中无有青瘀等相故六欲天唯能后起。有说。初后皆唯人趣。六欲天中无青瘀等不净相故都不现起。问观房等中骨等充满。此不净观为何所缘。有作是说。彼缘自身骨等为境有余师说。缘曾冢间所见骨等。或有说者。缘房等中诸空界色评曰。应作是说。此是假想胜解作意相应无贪。随所乐缘皆无有失。问此观一切非骨琐等。为骨琐等宁非颠倒。答此是善故。如理作意所引生故。无贪善根为自性故。引生圣道胜加行故。伏烦恼故。感爱果故。虽不如实而非颠倒。有作是说。此不净观亦名颠倒。于非不净观不净故。问若尔。何故非不善耶。答由二缘故名为不善。一所缘倒。二自性倒。此不净观虽所缘倒非自性倒故非不善。复次由二缘故名为不善。一所缘倒。二意乐倒。此不净观虽所缘倒非意乐倒故非不善复次契经中说。有五现见等至。云何为五。谓有苾刍如实观察自身。从足至顶种种不净充满。谓发毛爪齿尘垢皮肉骨髓筋脉。肝肺脾肾大小肠胃胆生熟藏澹热心肚。屎尿涕唾汗泪脓血脂膏脑膜。譬如有人观见仓内麻米豆等种种杂物充满其中。此亦如是。是名第一现见等至。复有苾刍如实观察自身。从足至顶种种不净充满。谓发毛等如前广说。复观除去皮肉血等。唯观骸骨识于中行。是名第二现见等至。复有苾刍如实观察自身。从足至顶种种不净充满。谓发毛等如前广说。复观除去皮肉血等。唯观骸骨识于中行。亦住今世。亦住后世。是名第三现见等至。复有苾刍如实观察自身。从足至顶种种不净充满。谓发毛等如前广说。复观除去皮肉血等。唯观骸骨识于中行。不住今世。但住后世。是名第四现见等至。复有苾刍如实观察自身。从足至顶种种不净充满。谓发毛等如前广说。复观除去皮肉血等。唯观骸骨识于中行。不住今世。不住后世。是名第五现见等至。问如是五种现见等至以何为自性。有作是说。以慧为自性。说如实观察故。有余师说。以三摩地为自性。说等至故。评曰。应作是说。以无贪为自性。观察不净对治贪故。而说观察及等至者。此从彼生及生彼故。又与定慧共相应故。已说自性。所以今当说。问何故名为现见等至。答现见谓眼。由眼见色引生此故立现见名。依等至生能生等至。或复此与等至。相应故名等至。问五中后四亦观于识。如何可说现见谓眼。答由眼现见诸不净物。展转引生如是五种现见等至。五中后四亦能缘识于理无违。问谁有此五现见等至。答第一第二异生圣者皆得有。第三是预流者及一来者所有。第四是不还者所有。第五是阿罗汉所有。如契经说。舍利子言。世尊所起现见等至。无余通达所知境故。说为无上。诸余沙门婆罗门等不能及故问何故世尊所得如是五不净观名无上耶。答能伏一切所缘境故说为无上。有作是说如实观故说为无上。谓观发是发观毛是毛。乃至广说。评曰彼不应作是说。若作是说。便显世尊观多境不净观。唯观少境实发毛等但摄欲界少分色故。应作是说。前说为善。能伏一切故名无上。声闻独觉不能总伏一切色处皆为不净。无灭不能观天女色为不净故。除佛无能观佛身色为不净故又世尊说。大目干连底沙梵天不说第六无相住者耶。乃至广说。问何故作此论。答为广分别契经义故。谓契经说。世尊一时在室罗筏住誓多林给孤独园。过初夜分有三梵天。光明照曜来诣佛所。到已顶礼世尊双足却住一面。时一梵天前白佛曰。大仙当知。娑计多国多苾刍尼今夜命过作是语已退住一面。第二梵天复前白佛。大仙当知。彼多尼众有有余依而灭度者。作是语已退住一面。第三梵天又前白佛。大仙当知。彼多尼众有无余依般涅槃者。作是语已退住一面。时三梵天合掌恭敬绕佛三匝礼双足已忽然不现。至明清旦世尊来诣苾刍众中敷座而坐。告苾刍众曰。昨过初夜分有三梵天光明照曜来诣我所。广说乃至忽然不现。尔时具寿大目干连在彼众中作如是念。何等梵天有此智见。知住有余无余依者。作是念已入三摩地。如壮士夫屈伸臂顷。誓多林没至于梵世。去底沙梵不远而出。从三摩地起整理衣服诣底沙梵所。作是问言。何等梵天有此智见。知住有余无余依者。问大目干连有胜智见。过底沙梵多俱胝倍。何故往问底沙梵耶。答大目干连知而故问。如佛有时知而故问。问有余梵天胜底沙梵者。何故但问底沙梵耶。答此梵本是大目干连共住弟子相委故问复次彼底沙梵住不还果。余梵众天有未知者。欲显彼德令余梵天恭敬尊重。是故偏问。时底沙梵答尊者言。即梵众天有此智见。知住有余无余依者。大目干连复问彼曰。诸梵众天皆有如是胜智见不。底沙答曰。非彼皆有此胜智见。若梵众天于天长寿妙色名誉不生喜足。下如实知胜出离者无此智见。若梵众天于天长寿妙色名誉能生喜足。亦如实知胜出离者有此智见。尊者复问。彼天如何知住有余无余依者。底沙答曰。若有苾刍得阿罗汉是俱解脱。彼梵众天作如是念。今此大德是俱解脱。乃至有身人天皆见。身坏命终都无见者。若有苾刍得阿罗汉非俱解脱是慧解脱。彼梵众天作如是念。今此大德是慧解脱。乃至有身人天皆见。身坏命终都无见者。若有苾刍非阿罗汉。非俱解脱。非慧解脱。然是身证。彼梵众天作如是念。今此大德是身证者。当修胜根亲近善友。若得随顺房舍资具。必当漏尽证得无漏心慧解脱。于现法中能自通达证具足住。又自了知。我生已尽。梵行已立。所作已办。不受后有。若有苾刍虽非身证而是见至。彼梵众天作如是念。今此大德是见至者。当修胜根亲近善友。广说乃至不受后有。若有苾刍虽非见至。是信胜解。彼梵众天作如是念。今此大德是信胜解当修胜根。广说乃至不受后有。底沙梵天说是语已默然而住。问底沙何故不说随信随法行耶。答若补特伽罗是彼境界者。彼便说之。随信随法行非底沙境界是故不说所以者何。若他心智知见道者。决定先起无漏法智。生上界者。无漏法智必不现前。故随信法行非底沙境界。复次若补特伽罗在梵天处有种类者彼便说之。随信随法行在梵天处无其种类。故彼不说。尔时尊者大目干连闻底沙梵说法语已。欢喜踊跃示现教导赞励庆喜。殷勤取别入三摩地。如壮士夫屈伸臂顷。从梵天没至誓多林苾刍众中欻然出现。从三摩地起前诣佛所。顶礼双足退坐一面。具以上事而白世尊。佛便问曰。大目干连底沙梵天不说第六无相住者耶。目连答曰。如是世尊。作是语已即从座起顶礼佛足合掌恭敬而白佛言。今正是时。唯愿为众宣说第六无相住者。令苾刍众闻已受持。佛告目连。谛听谛听。极善作意。当为汝说。若有苾刍。于一切相不复思惟证无相心三摩地具足住。是名第六无相住者。契经虽作是说。而不分别其义。彼是此论所依根本。彼不说者今欲说之。复次有于彼经不了其义。便执缘灭谛入正性离生。见道名为无相住故。唯灭谛中无诸相故。为遮彼执欲显见道非但缘灭。故作斯论云何名第六无相住者耶。答随信行随法行。名为第六无相住者。问云何得知随信法行名为第六无相住者。答一切圣者总有七种。底沙梵天已说五种。未说随信随法行者。故知此二合为第六无相住者。所以者何。此二无相不可安立。不可施设。在此在彼。若苦法智忍。若苦法智。广说乃至若道类智忍。以此无相不可安立。不可施设。在此在彼。故名第六无相住者。问何故此二合立一耶。答即此文说此二俱无相。不可安立。不可施设故。复次此二俱不起不相似心故。此二俱有十五心故。此二心品现行等故。此二俱是速疾道故。此二意乐俱不起故。此二俱是微细道故。此二俱是不可安立施设法故。此二俱是难觉道故。此二俱是不现见故。问此二于一切皆不现见耶。答不尔。于声闻独觉虽不现见。于佛世尊是现见故。复次此二。地等道等品等离染等故。合立为一。问前五既非无相住摄。何故说此名为第六无相住耶。答无相住者。是圣者中第六圣者。故名第六无相住者。非无相住总有六种。此名第六。如余处说害第五虎非前四亦名虎。然所害法总有五种。第五名虎。此中亦然。又如余处说第六增上王。非前五亦名王。然增上法总有六种。增上王是第六。此亦如是。无相住者是第六。非六皆名无相住。然无相声说多种义。谓或说空。或说无相。或说不动心解脱。或说非想非非想处。广释所以如智蕴说。此中无相正说见道义如前释。又极迅速难了知故。谓声闻他心智极设加行但知二心。谓苦法智忍及苦法智相应心。若欲知第三乃知第十六。若独觉他心智极设加行但知四心。谓初二心及灭类智忍灭类智相应心。有说。独觉但知三心。谓初二心及集类智相应心。唯佛他心智能次第遍知。是故见道名为无相

说一切有部发智大毗婆沙论卷第四十阿毗达磨大毗婆沙论卷第四十一

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中无义纳息第七之三

如契经说。佛转法轮憍陈那等苾刍见法。地神药叉举声遍告。世尊今在婆罗痆斯仙人鹿苑。三转法轮具十二相。乃至广说。问何故作此论。答为欲分别契经义故。谓契经说。佛转法轮。地神药叉举声遍告。契经虽作是说。而不分别其义。不说地神为自有智见。为因他故知举声遍告。经是此论所依根本。彼不说者今应说之。复次欲令疑者得决定故。经说。地神举声遍告。佛在鹿苑三转法轮。或有生疑。地神自有现量智见知如是事。欲令此疑得决定故。显彼但有比量知见生处得智。于转法轮非现境故。由是因缘故作斯论。为彼地神有正智见知佛转法轮苾刍见法不。答无。此事甚深非彼境故。彼云何知。答由五缘故。一者信世尊故。谓佛起世俗心我转法轮苾刍见法。由是彼知。谓佛若起无漏心或未曾得世俗心。一切有情无能知者。若起曾得世俗心时。诸有情类有能知者。谓佛起此世俗心时。若欲令钝根者亦知。则蛇奴等亦能了知。若欲令利根者亦不知。则舍利子等入边际第四静虑。起妙愿智亦不能知若欲令恶趣亦知。则猿猴等亦能了知。若欲令善趣亦不知。则诸人天无能知者。今佛欲令地神知故。起曾得世俗心我转法轮苾刍见法。地神知已举声遍告。问佛何故起此世俗心。答三无数劫修集种种难行苦行。为益有情。今转法轮苾刍见法。即昔加行今初得果。深生欢喜故起此心。复次昔发弘誓。为饶益他今始得果。故起此心。复次昔发大愿。为拔济他今始得果。故起此心。复次所期胜义。利乐有情今创果遂。故起此心。二者或佛告他我转法轮苾刍见法。故彼得闻。谓若于心得善巧者佛起心已即能了知。若但于言得善巧者。佛告他已方能了知。问世尊何故告他令知。答世尊欲显善说法中所言诚谛一见一乐。众皆同许故告他知。复次三无数劫修多苦行。为益有情今初得果。深生欢喜故告他知。复次世尊自显于九十六诸道法中最尊最胜无能及者。故告他知。复次欲显佛法实能出离有大神变。故告他知。复次佛欲显示憍陈那等真实功德。亦示世间良福田。故告他令知。复次欲令天人于佛圣教深敬信故。告他令知。复次世尊自显远离法悭。于希有法无师拳故告他令知复次佛欲显己有大士法非余道故告他令知。复次世尊自显有聪明相非余道故告他令知。如契经说。诸聪明者有三种相。一善思所思。二善作所作。三善说所说。三者或从大德天仙所闻。谓佛转法轮五苾刍见法。问何等名曰大德天仙。有作是说。是净居天。有余师说是欲界天已见谛者。复有说者。有长寿天曾见过去诸佛世尊转法轮相。今见世尊有如是相。欢喜踊跃告他令知。地神既闻举声遍告。四者或彼尊者憍陈那等起世俗心。佛转法轮我等见法。由是彼知。问何故尊者起世俗心。答已害二十种萨迦耶见故。已断一切恶趣因故。无边生死今有边故。无际苦海今有际故。已见圣谛故。入正定聚故。深生欢喜。故起此心。复次昔所发起弘誓大愿及诸苦行今果遂故。深生欢喜。故起此心。五者或彼告他地神得闻。问何故尊者告他令知。答尊者欲显善说法中所言诚谛一见一乐。众皆同许故告他知。复次欲显世尊三无数劫修多苦行。今初得果故告他知。复次欲显佛法于九十六诸道法中最尊最胜。故告他知。复次欲显佛法实能出离有大神变。故告他知。复次欲令天人于佛圣教深敬信故告他令知。复次为欲引发无量有情乐法心。故告他令知。复次欲令无量懈怠有情勤精进。故告他令知。复次欲显如来舍极苦行有大果故。告他令知。复次欲显自身归依佛法不唐捐故。告他令知。转法轮义如后定蕴不还纳息当广显示。又契经说。有诸苾刍得阿罗汉诸漏已尽。三十三天数数云集善法堂中。称说某处有某尊者。或彼弟子。剃除须发被服袈裟。正信出家勤修圣道。诸漏已尽证得无漏心慧解脱。于现法中能自通达。证具足住。又自了知。我生已尽。梵行已立。所作已办。不受后有。乃至广说。问何故作此论。答为欲分别契经义故。谓圆生树契经中说。有诸苾刍得阿罗汉诸漏已尽。三十三天乃至广说。契经虽作是说。而不分别其义。不说三十三天为自有智见为因他故知集善法堂称说其事。经是此论所依根本。彼不说者今应说之。复次欲令疑者得决定故。谓有生疑。彼天自有现量智见知如是事。欲令此疑得决定故。显彼但有比量智见生处得智于漏尽德非现境故。由是因缘故作斯论。为彼诸天有正智见知诸苾刍得阿罗汉诸漏尽不。答无。此事甚深非彼境故。彼云何知。答由五缘故。一者信世尊故。谓佛起世俗心是诸苾刍得阿罗汉诸漏已尽。由是彼知。谓佛若起无漏心或未曾得世俗心。一切有情无能知者。若起曾得世俗心时。诸有情类有能知者。谓佛起此世俗心时。如前广说。乃至今佛欲令彼天知故。起曾得世俗心是诸苾刍得阿罗汉诸漏已尽。彼天知已集善法堂称说其事。问佛何故起此世俗心。答以彼真实适佛意故。谓若苾刍永断后有。乃为真实适可佛意。是诸苾刍诸漏已尽永断后有。皆能真实适佛意故。起世俗心令诸天知云集称说。二者或佛告他。是诸苾刍得阿罗汉诸漏已尽。故彼得闻。谓若于心得善巧者。佛起心已即能了知。若但于言得善巧者。佛告他已方能了知。问世尊何故告他令知。答世尊欲显善说法中所言诚谛一见一乐。众皆同许故告他知。复次世尊自显于九十六诸道法中最尊最胜无能及者故告他知。复次欲显佛法实能出离有大神变故告他知。复次佛欲显示彼诸苾刍真实功德。亦示世间良福田故告他令知。复次欲令天人于佛圣教深敬信故告他令知。复次佛欲勉励余修行者勇进心故告他令知。三者或从大德天仙所闻。谓彼苾刍诸漏已尽。问何等名曰大德天仙。答天中证得阿罗汉者。问彼一切阿罗汉。皆知是事而告他耶。答不尔。根等胜者能知。非余四者。或彼尊者起世俗心我已漏尽得阿罗汉。由是彼知。问何故尊者起世俗心。答以彼尊者无始时来烦恼炽盛身心热恼今得清凉。无始时来生死相续今得永断。既舍郁蒸而得清凉。舍有爱味得无爱味。舍耽嗜得出离。舍染污得清净。深生欢喜故起此心。五者或彼告他诸天得闻。问何故尊者告他令知。答尊者欲显善说法中所言诚谛一见一乐。众皆同许故告他知。余随所应如佛告他及憍陈那告他中说。复次欲令先来供给尊者衣服饮食敷具医药。诸施主等闻生欢喜。功德更增。故告他知。复次欲令先来不敬信者。生敬信故告他令知。复次欲显出家勤修苦行有胜果故告他令知。问诸余天神亦有称说漏尽者不。答应说亦有。问何故唯说三十三天。答以彼诸天数数云集论善恶事故偏说之。谓彼诸天于白黑月。每常八日若十四日若十五日。集善法堂称量世间善恶多少。复次三十三天常共伺察造善恶者。见造善者便拥护之。见造恶者即共嫌毁。是故偏说。复次三十三天见人造善欢喜赞叹故偏说之。复次三十三天有圆生树喻阿罗汉故偏说之。问三十三天亦共称说有学者不。答亦共称说。诸有学者若诸有情。孝养父母彼尚称说。况有学者。问若尔。何故契经说彼但共称说阿罗汉耶。答依胜说故。谓无学法补特伽罗俱胜有学。是故偏说。复次以圆生树与漏尽者多分相似。可以为喻。是故偏说。复次以漏尽者极可乐故。离众过故。极清净故。无罪咎故。极难得故。无可嫌故。应供养故。偏称说之。复次以阿罗汉解脱圆满功德具足。永尽一切生老病死故偏称说。复次若阿罗汉出现世间。天人充满恶趣减少。如有德王出现于世。是故偏说。复次若阿罗汉出现世间。诸天众增。非天众减。如月满时大海盈满。是故偏说。复次若阿罗汉出现世间。则诸天军胜。阿素洛。如战时见善勇天子。是故偏说。复次若阿罗汉出现世间。后生天子寿色名誉胜前生者。如贫贱人以饭汁施胜余施主。是故偏说。复次若阿罗汉出现世间。以少物施便获大果。如迦叶波尊者无灭施一粗食。人天多返受胜妙果。是故偏说。复次若阿罗汉出现世间能令见者生少净心生天受乐。如狗虾蟆气嘘执恶。是故偏说。复次若阿罗汉出现世间。生死牢狱多得解脱。如王生子大赦天下。是故偏说。复次若阿罗汉出现世间。善恶趣道明了显现。如日出时照烛安险。是故偏说。复次若阿罗汉出现世间。能令诸天不失天位。如天帝释衰相蠲除。是故偏说。复次若阿罗汉出现世间。令天宫中天仙充满。如为善友之所摄持功德充满。是故偏说。复次若阿罗汉出现世间。能令诸天厌五欲乐。如天帝释琰摩轮王。妙欲现前能生厌舍。是故偏说。复次若阿罗汉出现世间。能令世间听闻正法。菩提分宝悉皆丰饶。如海宝船随所至处。是故偏说。复次若阿罗汉出现世间。一切有情悉皆受乐。如降甘雨稼穑丰稔。是故偏说。由如是等种种因缘。是故诸天唯说无学。问三十三天为称说一切阿罗汉。为少分耶。有作是说。称说一切。以彼诸天好赞他德。诸阿罗汉所作已办甚为希有。故皆称说。复有说者。不称说一切。所以者何。有阿罗汉若百若千。依山谷中而入寂灭。诸共住者尚不了知。况余天人远共称说。问称说何等阿罗汉耶。答如此经中所称说者。谓阿罗汉造作增长名誉业者。彼称说之。若不造作名誉业者。设复造作而不增长。彼不称说。复次若有豪贵而出家者。彼称说之。如释王等。复次若有巨富大功德者。彼称说之。如无灭等。复次若有大智利他无惓者。彼称说之。如舍利子等。复次若能护持佛法众所共归依者。彼称说之。如饮光等。复次若有生时震动天地现光明者。彼称说之。复次若有出家精勤苦行。能作难作护持佛法。利天人者彼称说之。余阿罗汉彼不称说。问增上慢者。诸天知不。有作是说。有知不知。谓依殊胜功德起增上慢者。诸天不知若依下劣功德起增上慢者。诸天则知。复次若依微妙功德起增上慢者。诸天不知。若依粗浅功德起增上慢者。诸天则知。复次若依上界功德起增上慢者诸天不知。若依欲界功德起增上慢者。诸天则知。有余师说。增上慢者。诸天不知。如天帝释世无佛时若见外道独处闲居。便往其所观察礼敬谓是如来。帝释尚然。况余天众。问诸犯戒者。诸天知不。答有知不知。谓犯粗重戒。诸天则知。若犯微细戒。诸天不知

如契经说。摩揭陀国诸辅佐臣。或是化法调伏。或是法随法行。乃至广说。问何故作此论。答为欲分别契经义故。谓胜威经作如是说。一时佛在那地迦邑郡氏迦林。时摩揭陀国有八万四千诸辅佐臣。一时命过。有说。疾疫故彼命终。有说。彼为未生怨杀。谓未生怨杀父王已。亦杀辅佐八万四千。彼诸眷属诣阿难所作如是言。彼彼国邑有信佛者。身坏命终如来皆记生彼彼处。摩揭陀国先王侍臣八万四千亦皆信佛。今已命过。未蒙世尊记所生处。唯愿为请。阿难许之。于日初分往如来所。顶礼双足却住一面。恭敬合掌现亲爱相方便请言。彼彼国邑有信佛者。身坏命终佛记生处。摩揭陀国影坚王臣八万四千亦皆信佛。今已命终如来不记。彼诸眷属心生愁恼。若佛不记彼生处者。恐彼眷属起嫌恨心。唯愿世尊哀愍为记。又佛在此摩揭陀国。成等正觉。其地有恩。又影坚王。深信三宝供养恭敬未尝暂阙。是故世尊必应为记。佛愍彼故默然许之。即持衣钵入那地迦。如法乞食。食讫还至郡氏迦林。收衣钵洗足已入所止房。敷座而坐。安身定意系念思惟。观摩揭陀诸臣生处。问佛于诸法才举心时。无碍智见自然而转何故入房专精思察。答欲显业果极深邃故。最微细故。难觉知故。难显了故。难现见故。由是一切三藏教中毗奈耶藏最为甚深。多明业果差别相故。诸契经中说业果处最为甚深。十二支中行有二种最为甚深。佛十力中自业智力最为甚深。此八蕴中第四业蕴最为甚深。四难思中有情业果最为甚深。故佛入房专精思察。复次佛欲显示摩揭陀臣身心因果。障碍对治命终受生。一一皆有种种差别。是故入房专精思察。复次应受化者犹未集故。谓佛说法非为一人。如大龙王雨必普润。为待无量应化有情。故且入房思惟系念。复次胜威天子犹未至故。谓影坚王被子杀已生多闻室。名曰胜威。彼闻如来说其辅佐生处差别。必来听受。为待彼故且复入房。复次欲令阿难敬重法故。谓若为彼轻尔说法。即彼于法不深敬重。欲令渴仰闻必受持如理思惟广为他说。故且入室系念思惟。复次为断愚人憍慢心故。谓无智者实无所知。怀聪明慢。若他请问不观浅深率尔便答。佛欲断彼憍慢心故。自显智见于一切法任运而转。若得他问尚审思惟安详而答。况无智者问便酬对。复次佛欲自显善士法故。谓诸善士有三种相。即善思所思等。故不问已轻易而答。复次佛欲自显智者相故。谓诸智者审思方说。故佛得问系念思惟。有作是说。佛欲入房游戏静虑。阿难请问故未酬答。尔时世尊于日后分从定而起出诣众中。敷如常座安详而坐。尊者阿难前至佛所。顶礼双足合掌恭敬而白佛言。如来今者。面目清净进止从容。诸根寂静必游静虑受现法乐。先所请者。唯愿说之。佛告阿难。如是如是如汝所说。谛听谛听善思念之。当为汝说。摩揭陀国八万四千诸辅佐臣已命终者。或是化法调伏。或是法随法行。皆断三结。得预流果。不复退堕。定趣菩提极七返有。七返人天往来流转作苦边际。一类生在四大王众天。如是乃至一类生在他化自在天众同分中。乃至广说。问辅佐臣者义何谓耶。答彼恒护持佛法僧宝令无损减。故名辅佐。复次以彼皆是频毗娑罗内供奉者。故名辅佐。复次彼皆翼助频毗娑罗摄养国人。故名辅佐。复次彼是先世曾所立名。谓昔有王。七宝具足王四洲渚。将领辅佐八万四千。乘空游戏。时轮宝等忽止不行。王遂惊怖谓诸臣曰。将非失位。或命尽耶。菩提树神仰白王曰。此下不远有菩提树。诸佛依之成等正觉。不应在上乘空而行。王闻疾下顶礼悔谢。与诸辅佐恭敬右绕。设供养已从余道去时。转轮王者今影坚王是八万四千辅佐臣者今未生怨所诛者。是故知辅佐是先世名。契经虽作是说而不分别其义。经是此论所依根本。彼不说者今应说之。故作斯论云何彼名化法调伏。云何彼名法随法行。答若在天中而见法者名化法调伏。若在人中而见法者名法随法行。复次若不受持戒而见法者名化法调伏。若受持戒而见法者名法随法行。复次若在人中种诸善根亦令成熟。后生天中得解脱者名化法调伏。若在人中种诸善根亦令成熟。即于人中得解脱者名法随法行。复次若在人中修顺决择分善根。后生天中得通达者名化法调伏。若在人中修顺决择分善根。即于人中得通达者名法随法行。复次若在人中修加行道。后生天中入正性离生者名化法调伏。若在人中修加行道。即于人中入正性离生者名法随法行。复次若在人中修行谛善根。后生天中得谛现观者名化法调伏。若在人中修行谛善根。即于人中得谛现观者名法随法行。复次若在人中修治善根。后生天中见清净者名化法调伏。若在人中修治善根。即于人中见清净者名法随法行。复次若在人中受假名戒。后生天中得圣所爱戒者名化法调伏。若在人中受假名戒。即于人中得圣所爱戒者名法随法行。复次若在人中得别解脱静虑律仪。后生天中得无漏律仪者名化法调伏。若在人中得别解脱静虑律仪。即于人中得无漏律仪者名法随法行。复次若在人中受作意戒。后生天中得法尔戒者名化法调伏。若在人中受作意戒。即于人中得法尔戒者名法随法行。复次若在人中得增上戒增上心学。后生天中得增上慧学者名化法调伏。若在人中得增上戒增上心学。即于人中得增上慧学者名法随法行。复次若在人中修预流支。后生天中得预流果者名化法调伏。若在人中修预流支。即于人中得预流果者名法随法行。复次若在人中得世俗信。后生天中得证净者名化法调伏。若在人中得世俗信。即于人中得证净者名法随法行。复次若在人中修三十七菩提分法。后生天中得具足者名化法调伏。若在人中修三十七菩提分法。即于人中得具足者名法随法行。问何故天中得见法者名化法调伏。即于人中得见法者名法随法行耶。答若于天中得见法者修加行少。若于人中得见法者修加行多故。谓在人中得见法者。先勤恭敬供养师友。诵素呾览学毗奈耶。听受决择阿毗达磨。于一切法自相共相思惟观察。得纯熟已往诣山林居闲静处。初夜后夜除去睡眠渐复受持小大七法。始从日没至日出时。结跏趺坐顶安静镇。行鞠法杖精进炽然。系念思惟方入圣道。彼由如是多加行法。是故名为法随法行。若于天中得见法者。由昔人中闻思修故今时任运圣道现前。彼受化生见法调伏故立化法调伏别名

云何多欲乃至广说。问何故作此论。答为欲分别契经义故。谓契经说有多欲有不喜足。契经虽作是说而不分别其义。经是此论所依根本。彼不说者今应说之。故作斯论。云何多欲。答诸欲已欲当欲是谓多欲。此本论师于异名义得善巧故。以种种名显示多欲。文虽有异而体无别云何不喜足。答诸不喜不等喜不遍喜不已喜不当喜。是谓不喜足。此本论师于异名义得善巧故。以种种名显示不喜足。文虽有异而体无别。多欲不喜足何差别乃至广说。问何故复作此论。答欲令疑者得决定故。谓此二法展转相似见多欲者世人共言是不喜足。见不喜足者世人共言是多欲。或有生疑此二是一。为令彼疑得决定故。显此二种其义各别故作斯论。多欲不喜足何差别。答于未得可爱色声香味触。衣服饮食床座医药。及余资具。诸希求寻索思慕方便是谓多欲。此中于未得可爱色声香味触者。依在家者说。彼于未得可爱色等四方追求。谓务农者追求田园牛羊等畜衣宅谷等诸资生具。若富贵者追求胜位国土城邑象马珍玩诸欲乐具。于未得衣服饮食床座医药及余资具者依出家者说。彼于未得衣钵房舍资具及弟子等种种追求。诸希求等名虽有异而体无别。皆为显示多欲义故。于已得可爱色声香味触衣服饮食床座医药及余资具。诸复希复欲复乐复求是谓不喜足。此中于已得可爱色声香味触者依在家者说。彼于已得可爱色等不生喜足。复更希求。谓务农者于田园等得一希二。乃至广说。若富贵者于胜位等得一希二。乃至广说。于已得衣服饮食床座医药及余资具者。依出家者说。彼于已得衣等不生喜足。复更希求。谓于衣钵房舍资具及弟子等得一希二。乃至广说。诸复希等名虽有异而体无别。皆为显示不喜足故。如是差别者。显多欲故。希求寻索思慕方便。即多欲是希求等因。若心无爱者无希求等故。及显不喜足故。复希复欲复乐复求即不喜足。是复希等因。若心无贪者无复希等故。此即显示多欲不喜足。虽俱以贪不善根为自性。而依未得已得境起故有差别。有作是说。不喜足是因多欲是果。此中因果互相显示。或有说者。希欲是多欲追求是不喜足。复有说者。难满是多欲多希求故。难养是不喜足喜选择故。有余师说。多欲唯在意地缘未来故。不喜足通六识身缘现在故。评曰。应作是说。此二俱是欲界一切贪不善根俱通六识。谓彼一切令于已得色等境界不喜足义名不喜足。令于未得色等境界多希求义名为多欲。是故此二皆通欲界。六识俱起贪不善根。云何少欲乃至广说。问何故作此论。答为欲分别契经义故。谓契经说有少欲有知足。契经虽作是说而不分别其义。经是此论所依根本彼不说者今应说之。复次前说多欲及不喜足。今欲说彼近对治法故作斯论。云何少欲。答诸不欲。不已欲。不当欲。是谓少欲。此本论师于异名义得善巧故。以种种名显示少欲。文虽有异而体无别。云何喜足。答诸喜等喜遍喜已喜当喜是谓喜足。此本论师于异名义得善巧故。以种种名显示喜足。文虽有异而体无别。少欲喜足何差别乃至广说。问何故复作此论。答欲令疑者得决定故。谓此二法展转相似。见少欲者世人共言是喜足。见喜足者世人共言是少欲。或有生疑此二是一。为令彼疑得决定故。显此二种其义各别故作斯论。少欲喜足何差别。答于未得可爱色声香味触衣服饮食床座医药及余资具。诸不希不求不寻不索不思慕不方便。是谓少欲。此中于未得可爱色声香味触者。依在家者说。彼于未得可爱色等不生希求。谓务农者于田园等不生希求。若富贵者于胜位等不生希求。于未得衣服饮食床座医药及余资具者。依出家者说彼于未得衣钵房舍资具及弟子等不生希求。诸不希等名虽有异而体无别。皆为显示少欲义故。问何故此中问少欲而答不欲耶。答未得可爱色等资具。总有二种。谓如法不如法。于如法者有欲。于不如法者不生欲故。复次于应受者有欲。于不应受者不生欲故。复次于能止苦者有欲。于增烦恼者不生欲故。复次于梵行求有欲。于欲求有求邪梵行求不生欲故。复次于饶益他事有欲。于损害他事不生欲故。应知此中不生欲者。谓不善欲。有欲者。谓善欲。于已得可爱色声香味触衣服饮食床座医药及余资具。诸不复希。不复欲。不复乐。不复求。是谓喜足。此中于已得可爱色声香味触者依在家者说。彼于已得可爱色等生喜足故不复希求。谓务农者于田园等随得充济便生喜足。不复希求。若富贵者于胜位等随所已得便生喜足。不复希求。于已得衣服饮食床座医药及余资具者依出家者说。彼于已得衣等生喜足故。不复希求。谓于衣钵房舍资具及弟子等随所已得。便生喜足不复希求。不复希等名虽有异而体无别。皆为显示喜足义故如是差别者显少欲故。不希不求乃至广说。即少欲是不希不求等因若心有爱者有希求等故。及显喜足故不复希等即喜足。是不复希等因若心有贪者有复希等故。此即显示少欲喜足。虽俱以无贪善根为自性。而依未得已得境起故有差别。有作是说。喜足是因少欲是果。此中因果互相显示。或有说者。不希欲是少欲。不追求是喜足。复有说者。易满是少欲少希求故。易养是喜足不选择故。有余师说。少欲唯在意地缘未来故。喜足通六识身缘现在故。评曰。应作是说。此二俱是三界系及不系。无贪善根俱通六识。谓彼一切令于已得色等境界生喜足义名为喜足。令于未得色等境界少希求义名为少欲。是故此二皆通三界系及不系。六识俱起无贪善根

应知此中有少欲者而名多欲。如但须一两药即得充济而希二两等。有多欲者而名少欲。如须百千资生众具方得充济。但欲尔所不复多希。有少求者而名不喜足。如得少物已得充济。而复少求有多求者而名喜足。如得少物全未充济。更须百千供身方足。但求尔所不复多求

说一切有部发智大毗婆沙论卷第四十一阿毗达磨大毗婆沙论卷第四十二

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中无义纳息第七之四

云何难满乃至广说。问何故作此论。答为欲分别契经义故。谓契经说有难满有难养。契经虽作此说而不分别其义。经是此论所依根本。彼不说者今应说之。故作斯论。云何难满。答诸重食重啖多食多啖大食大啖。非少能济是谓难满。诸重食等名虽有异而体无别。皆为显示难满义故。云何难养。答诸饕极饕餮极餮。耽极耽嗜极嗜。好咀嚼。好尝啜。选择而食。选择而啖。非趣能济是谓难养。饕极饕等名虽有异而体无别。皆为显示难养义故。难满难养有何差别。答即前所说是谓差别。问何故复作此论。答欲令疑者得决定故。谓此二法展转相似。见难满者世人共言此是难养。见难养者世人共言此是难满。或有生疑此二是一。为令彼疑得决定故。显此二种其义各别故作斯论。谓即前说重食啖等非少能济是难满饕极饕等。非趣能济是难养。复次多欲是难满希多食故。不喜足是难养。选择而食故。此中文略但依食说。应知衣等亦有二义。有本无此差别问答。问何故此中不问差别。答应问而不问者当知此义有余。复次答不异前故不复问。非如多欲不喜足。答异前故

云何易满乃至广说。问何故作此论。答为欲分别契经义故。谓契经说有易满有易养。契经虽作是说而不分别其义。经是此论所依根本。彼不说者今应说之。复次前说难满难养今欲说彼近对治法故作斯论。云何易满。答诸不重食。不重啖。不多食。不多啖。不大食。不大啖。少便能济是谓易满。不重食等名虽有异而体无别。皆为显示易满义故。云何易养。答诸不饕不极饕。不餮不极餮。不耽不极耽。不嗜不极嗜。不好咀嚼。不好尝啜。不选择而食。不选择而啖。趣得便济是谓易养。诸不饕等名虽有异而体无别。皆为显示易养义故。易满易养有何差别。答即前所说是谓差别。问何故复作此论。答欲令疑者得决定故。谓此二法展转相似。见易满者世人共言此是易养。见易养者世人共言此是易满。或有生疑此二是一。为令彼疑得决定故。显此二种其义各别故作斯论。谓即前说不重食等少便能济是易满。诸不饕等趣得便济是易养。复次少欲是易满。不希食故喜足。是易养。不选择而食故。此中文略但依食说。应知衣等亦有二义。有本无此差别问答。问何故此中不问差别。答应问而不问者应知此义有余。复次答不异前故不复问。非如少欲喜足答异前故应知此中有少食者而名难满。如食一团即得充济而食二团等。有多食者而名易满。如食一斛方得充济。但食尔所更不多食。昔有牝象名曰磨荼。从外方载佛驮都来入迦湿弥罗国。乘斯福力命终生此得丈夫身。出家修道成阿罗汉。宿习力故日食一斛乃得充济。将般涅槃集曾供觐苾刍尼曰。当为汝等说我胜法。尼众诮言。尊既易满。诚有胜法。阿罗汉曰。汝勿相轻吾实易满。苾刍尼言。日食一斛如何易满。阿罗汉曰。汝等不知我此生前曾为牝象载佛驮都来入此国。由斯善业今得为人出家修道成阿罗汉。余习力故日应食饭一斛五斗。恒自节量。但食一斛如斯易满非我而谁。时苾刍尼顶礼悔谢。又胜军王福德力故日能食饭饮甘蔗浆各两大斛。此浆及饭因一茎蔗一枝稻生。然自节量各食一斛。此等多食而名易满。有选择食名为难养。如食粗食足得充济而饕餮故选择食之。有选择食而名易养。如食粗食不得支身。选择食之方可充济。而于美食心不耽嗜。或有贪多而食少。如乌鸱等。或有食多而贪少。如象马等。或有贪食俱多。如猫犬等。或有贪食俱少。如龟蟹等。难满难养俱是欲界。通于六识。贪不善根。易满易养俱是三界系及不系。通于六识。无贪善根。如契经说。有四圣种皆以喜足为其自性。此四广如定蕴不还纳息中说

    杂蕴第一中思纳息第八之一

云何思。云何虑。如是等章及解章义既领会已。次应广释。问何故作此论。答为止他宗显正义故。谓或有执思虑是心。如譬喻者彼说思虑是心差别。无别有体。为遮彼执显思与虑是心所法别有自体。或复有执。思之与虑声虽有异而体无别。如声论者彼说思虑音韵虽别而无异体。为遮彼执。显此二种自体亦别故作斯论。云何思。答谓思等思增思思性思类心行意业是谓思。此本论师于异名义得善巧故。以种种名显示思体。文虽有异而体无别。问此中思者说何等思。有作是说。此说牵引众同分思。有余师说。此说圆满众同分思。评曰。应作是说。此中总说一切意业。若能牵引众同分者。若能圆满众同分者。若有漏者。若无漏者。若在意地。若在五识。皆说名思。一切皆有造作相故。云何虑答诸虑等虑增虑称量筹度观察是谓虑。此本论师于异名义得善巧故。以种种名显示虑体。文虽有异而体无别。问此中虑者说何等虑。有作是说。此说通达四圣谛虑。谓见道等如实观察四圣谛故。有余师说。此中正说修所成虑。谓燸顶忍世第一法。或有说者。此中正说思所成虑。谓不净观持息念等。乃至念住。复有说者。此中正说闻所成虑。谓分别诸法自相共相。安立诸法自相共相。除物体愚及所缘愚。于诸法中不增不减。或复有说。此中正说生所得虑。谓于三藏十二分教。受持转读究竟流布。评曰。应作是说。此中总说一切般若。若生所得。若闻所成。若思所成。若修所成。若通达谛。若有漏者。若无漏者。若在意地若在五识。皆说名虑。一切皆有观察相故思虑何差别。问何故复作此论。答欲令疑者得决定故。谓此二法展转相似。见多思者世人共言。此人多虑。见多虑者世人共言。此人多思。或有生疑此二是一。为令彼疑得决定故。显此二种其体各别故作斯论。思虑何差别。答思者业。虑者慧。是谓差别。复次思是造作相。虑是观察相。复次能分别爱非爱果令无杂乱是思相。能分别诸法自相共相令无疑惑是虑相。问一切不善善有漏法皆能感爱非爱异熟果。何故但说思能分别爱非爱果非余法耶。答思最胜故作如是说。谓思能感爱非爱果势力最胜。是故偏说。如偈书染虽有余缘以人胜故人得其名此亦如是。问分别诸法自相共相余心心所亦有此能。何故说此是慧非余。答慧最胜故作如是说。谓慧分别诸法自相共相最胜。是故偏说。引喻如前问何等慧能分别诸法自相。何等慧能分别诸法共相耶。答分别一物相者。是分别自相。分别多物相者。是分别共相。复次分别一一蕴等者。是分别自相。分别二蕴三蕴等者。是分别共相。复次闻思所成慧多分别自相。修所成慧多分别共相。复次十六行相所不摄慧多分别自相。十六行相所摄慧唯分别共相。复次行谛时慧多分别自相。现观时慧唯分别共相。复次别观诸谛慧名分别自相。总观诸谛慧名分别共相。问此二种慧如何应知。答如种种物近帝青宝。自相不现皆同彼色。分别共相慧应知亦尔。如种种物远帝青宝。青黄等色各别显现。分别自相慧应知亦尔。复次如日出时光明遍照众闇顿遣。分别共相慧应知亦尔。如日出已渐照众物。墙壁窍隙山岩幽薮。皆悉显现。分别自相慧应知亦尔。复次如人持灯初入闇室顿破诸闇。分别共相慧应知亦尔。如灯入已渐照瓶衣器箧诸物。分别自相慧应知亦尔。复次如镜远照别相不显。分别共相慧应知亦尔如镜近照别相明了。分别自相慧应知亦尔。复次如人远观山林等物。分别共相慧应知亦尔。如人近观山林等物。分别自相慧应知亦尔。问此中所说闻思修所成慧其相云何。有作是说。若于三藏十二分教。受持转读究竟流布名。闻所成慧。依此发生思所成慧。依此发生修所成慧。此断烦恼证得涅槃。如依金矿生金依金生金刚。此能摧坏山石等物。评曰。应作是说。若于三藏十二分教。受持转读究竟流布。是生得慧。依此发生闻所成慧。依此发生思所成慧。依此发生修所成慧。此断烦恼证得涅槃。如依种生芽。依芽生茎。依茎转生枝叶花果。复次依闻生者名闻所成慧。依思生者名思所成慧。依修生者名修所成慧。复次闻所引者名闻所成慧。思所引者名思所成慧。修所引者名修所成慧。复次缘力起者。名闻所成慧。因力起者。名思所成慧。俱力起者。名修所成慧。复次他力起者。名闻所成慧。自力起者。名思所成慧。俱力起者。名修所成慧。复次资粮力起者。名闻所成慧。自性力起者。名思所成慧。俱力起者。名修所成慧。复次外力起者。名闻所成慧。内力起者。名思所成慧。俱力起者。名修所成慧。复次教力起者。名闻所成慧。义力起者。名思所成慧。定力起者。名修所成慧问如是三慧有何差别。答闻所成慧。于一切时依名了义。彼作是念。素怛缆。毗奈耶。阿毗达磨所说有何义耶。亲教轨范同梵行者所说有何义耶。诸余论等所说有何义耶。随其所念皆能解了。思所成慧。有时依名了义。有时不依名而了义。修所成慧。于一切时不依名而了义。如有三人入池洗浴。一未学浮。二学未善。三学已善。未学浮者。于一切时攀岸草等然后洗浴。闻所成慧应知亦尔。学未善者或攀不攀而能洗浴。思所成慧应知亦尔。学已善者于一切时无所攀附自在洗浴。修所成慧应知亦尔。复次闻所成慧为三慧因。思所成慧唯思慧因。非闻慧因彼是劣故。非修慧因彼异界故。修所成慧唯修慧因非闻慧因。彼是劣故非思慧因。彼亦劣故。及异界故。复次闻所成慧唯闻慧果非余二果彼是胜故。思所成慧是二慧果非修慧果。彼是胜故。及异界故。修所成慧是二慧果非思慧果。彼异界故。复次闻所成慧现在前时唯修闻慧思所成慧现在前时唯修思慧。修所成慧现在前时能修三慧。问何故二慧现在前时唯修自类。修所成慧能修三种。答闻思二慧不依定生。势力下劣现在前时唯修自类。即习修故说名为修。不修未来自类他类。修所成慧依定而生。势力增胜现在前时能修自类及修他类。修自类者。现在习修未来得修。修他类者唯未来修复次闻思所成慧初刹那现在前时唯成就现在。第二刹那已后现在前时成就过去现在。后不起时唯成就过去。修所成慧未曾得者。初刹那现在前时成就未来。现在第二刹那以后成就三世。后不起时唯成就过去未来。有余师说。闻思二慧串习胜者现在前时。亦修未来自类善法。彼说成就非如前说

如是三慧。界者。欲界有二。谓闻所成慧。思所成慧。色界有二。谓闻所成慧。修所成慧。无色界唯有修所成慧。问何故欲界无修所成慧耶。答欲界是不定界。非修地。非离染地若欲修时堕思中故。问何故色无色界无思所成慧耶。答色无色界是定界。是修地。是离染地。若欲思时堕修中故。问何故无色界无闻所成慧耶。答彼无耳根听闻法故。闻所成慧要因耳根听闻法已展转能引现在前故。有作是说。欲界具有三慧。色无色界如前说。欲界修所成慧者。如现观边世俗智空空无愿无愿无相无相三摩地俱。及尽智时所修欲界善根相应。然极少故诸处不说。有余师说。欲色二界皆具三慧。无色界唯有修所成慧。或有说者。欲色二界皆具三慧。无色界有二种。谓思修所成慧。复有说者。三界皆具有三慧。评曰。应知此中初说为善。地者。闻所成慧在五地。谓欲界四静虑。有说。在六地。谓前五及静虑中间。有说。在七地。谓前六及未至地。思所成慧唯在一地谓欲界。修所成慧有漏者在十七地。谓四静虑四近分静虑中间四无色四近分。无漏者在九地。谓四静虑未至中间下三无色。所依者。闻所成慧依欲色界身。思所成慧依欲界身。修所成慧依三界身。行相者。有作是说。闻思所成慧非十六行相有漏故。修所成慧十六行相。或余行相。评曰。应作是说。三慧皆通十六行相及余行相。以十六行相通有漏无漏故。问若三慧皆通十六行相及余行相者。如是三慧有何差别。答如前已说种种差别。然闻思所成慧自力故无未来修。他力故有未来修。修所成慧自力故有未来修。是谓差别。所缘者三慧皆缘一切法。念住者。三慧皆通四念住。智者闻思所成慧。唯世俗智。修所成慧通十智。根相应者。闻修所成慧三根相应。谓乐喜舍。思所成慧二根相应。谓喜及舍。三摩地俱者闻思所成慧。非三摩地俱有漏故。修所成慧三三摩地俱及不俱。过去未来现在者。此三慧皆堕三世。缘三世及离世。善不善无记者。此三慧皆是善。缘三种系不系者。闻所成慧欲色界系。思所成慧唯欲界系。修所成慧色无色界系及不系。三慧皆缘三界系及不系。学无学非学非无学者。闻思所成慧唯非学非无学。修所成慧通三种。三慧皆缘三种。见所断修所断不断者。闻思所成慧唯修所断。修所成慧通修所断及不断。三慧皆缘三种。缘名缘义者。此三慧皆缘名义。缘自相续他相续非相续者。此三慧皆缘三种。在意地在五识身者。唯在意地。以五识中无加行善故。加行得离染得生得者。此三慧皆通加行得离染得。非生得。闻思所成慧离染得者。离有顶染时得故。有说。三慧虽加行得而亦可言生得。从上地没生下地时亦有得故。有余师说。闻所成慧。在欲界者唯加行得。在色界者可言是加行得。可言是生得。可言是加行得者。谓在欲界加行修习闻所成慧。观察诸法自相共相。极纯熟者从欲界没生色界时乃可得故。可言是生得者。虽在欲界加行修习闻所成慧。观察诸法自相共相。若未生彼犹未能得。要生色界方得彼故。思所成慧唯加行得。修所成慧通三得。加行离染生时得故。问如是三慧声闻独觉如来具几。答如来虽具三慧。然是修所成慧所显。所以者何。自然觉悟具力无畏及大悲等修功德故。独觉虽具三慧。而是思所成慧所显。所以者何。彼虽自然觉悟。而无力无畏等诸修功德。由多思虑而入道故。声闻虽具三慧。而是闻所成慧所显。所以者何。彼闻法音而入道故。复次如是三慧皆可名为闻所成慧。如说。多闻能知法等。皆可名为思所成慧。如此中说虑即是慧虑。似思故亦名为思。皆可名修所成慧如说。云何应修法。谓善有为法。又契经说。有三种慧。一言说究竟慧。即是此中闻所成慧。二思虑究竟慧。即是此中思所成慧。三出离究竟慧。即是此中修所成慧。一切加行善心心所皆入如是三慧品摄。云何寻乃至广说。问何故作此论。答为止他宗显正义故。谓或有执。寻伺即心。如譬喻者为遮彼执显寻与伺是心所法。或复有执。寻伺是假。为遮彼执显此二种是实有法。故作斯论。云何寻。答诸心寻求辨了显示推度构画分别性分别类是谓寻。诸心寻求等名虽有异而体无差别。皆为显了寻自性故。云何伺。答诸心伺察随行随转随流随属是谓伺。诸心伺察等名虽有异而体无差别。皆为显了伺自性故。寻伺何差别。答心粗性名寻。心细性名伺。是谓差别。问何故复作此论。答欲令疑者得决定故。谓此二法展转相似。见多寻者世人共言。此是多伺。见多伺者世人共言。此是多寻。或有生疑此二体一。欲令彼疑得决定故。显此二种自体各别故作斯论。问此中所说心粗细性显何义耶。有作是说。此则显心粗性细性若作是说。寻伺应以心为自性。亦不相应一物粗细不俱有故。有余师说。此显心粗时有寻性。心细时有伺性。若作是说。应显寻伺非一心俱。心粗细时刹那别故。评曰。应作是说。此中显示即一心中粗性名寻。细性名伺若作是说。显一心中有寻有伺。寻令心粗伺令心细。问云何一心粗细二法互不相违。答所作异故。寻性猛利。伺性迟钝。共助一心故。虽粗细而不相违。问寻伺粗细其相如何。答如针鸟翮和束捔。身生受利钝。寻伺亦尔。又如酢水等分相和置于口中。生识利钝。寻伺亦尔。又如盐糗等分相和置于口中。生识利钝。寻伺亦尔。施设论说。如叩钟铃铜铁器等。其声发运。前粗后细。寻伺亦尔。法蕴论说。如天震雷人吹贝等。初大后微。寻伺亦尔。又作是说。如鸟飞空鼓翼翔翥。前粗后细寻伺亦尔。彼说皆显寻伺不俱作用增时有前后故。有作是说。如以熟酥置冷水上。日光照触由水日故非释非凝。如是一心有寻有伺。二力任持非粗非细。是故寻伺互得相应。寻令心粗伺令心细此中略有三种分别。一自性分别。谓寻伺。二随念分别。谓意识相应念。三推度分别。谓意地不定。慧欲界五识身唯有一种自性分别。虽亦有念而非随念分别。不能忆念故。虽亦有慧而非推度分别不能推度故。欲界意地具三分别初静虑三识身唯有一种自性分别。虽有念慧非二分别。义如前说。初静虑意地。若不定者具三分别。若在定者有二分别。谓自性及随念。虽亦有慧而非推度分别。若推度时便出定故。第二第三第四静虑心。若不定者有二分别。谓随念及推度。除自性彼无寻伺故。若在定者唯有一种随念分别。无色界心。若不定者有二分别。除自性。若在定者唯有一种随念分别。诸无漏心随地不定有。但有分别者。谓除推度有。唯有一分别者。谓随念。无具三者无不定故。云何掉举乃至广说。问何故作此论。答为止他宗显正义故。谓或有执。掉举心乱无有别体。为遮彼执欲显此二其体各别故作斯论。云何掉举。答诸心不寂静。不止息躁动掉举。心躁动性是谓掉举。不寂静等名虽有异而体无差别。皆为显了掉举自性故。云何心乱。答诸心散乱流荡不住非一境性。是谓心乱。心散乱等名虽有异而体无差别。皆为显了心乱自性故。掉举心乱有何差别。答不寂静相名掉举。非一境相名心乱。是谓差别。问何故复作此论。答为令疑者得决定故。谓此二法展转相似。见掉举者世人共言。此是心乱。见心乱者世人共言。此是掉举。或有生疑此二是一。欲令此疑得决定故。显此二种其体各别故作斯论。不寂静相者。谓令心躁动障碍五支四支定故。非一境相者。谓令心流荡于外色声香味触故。问掉举心乱其相如何。答如人坐床一挽令起掉举亦尔。发动心故。一策令行心乱亦尔。令心于境数移转故。又如令水从泉眼出。掉举亦尔。令心躁动故。令水出已流满诸池。心乱亦尔。令心流散故。问心乱以何为自性。答以染污三摩地为自性。有作是说。有别心所名为心乱。非三摩地。评曰。应作是说。前说为善。即三摩地烦恼相应。令心于境数数移转名心乱故掉举心乱虽恒相应然约用增。应作四句。有心名有掉举非有心乱。谓于一境三摩地极躁动时。有心名有心乱非有掉举。谓于多境三摩地不极躁动时。有心名有掉举亦有心乱。谓于多境三摩地极躁动时。有心不名有掉举亦非有心乱。谓于一境三摩地不极躁动时。大德说曰。若心名有心乱亦名有掉举。有心名有掉举非有心乱。谓于一境三摩地极躁动时。如行一路驰走不息

复次此中因说心所。应说大地等法。谓大地法有十种。一受。二想。三思。四触。五欲。六作意。七胜解。八念。九三摩地。十慧。大烦恼地法亦有十种。一不信。二懈怠。三放逸。四掉举。五无明。六忘念。七不正知。八心乱。九非理作意。十邪胜解。此二种大地法。名虽二十体唯十五。谓大地法中受想思触欲。名五体亦五。大烦恼地法中不信懈怠放逸掉举无明。亦名五体亦五。所余十法名虽有十体唯有五。谓大烦恼地法中忘念即大地法中念。不正知即彼慧。心乱即彼三摩地。非理作意即彼作意。邪胜解即彼胜解。然大地法通染污不染污。大烦恼地法唯染污。念等五法顺善品胜。多建立在诸善品中。或有生疑唯不染污故。复说在烦恼地中。有说。此五顺染亦胜。是故重说。惛沈顺定余不遍染。故不立在此地法中。然于此中应作四句。有是大地法非大烦恼地法。谓受想思触欲。有是大烦恼地法非大地法。谓不信懈怠放逸掉举无明。有是大地法亦大烦恼地法。谓忘念不正知心乱非理作意邪胜解。有非大地法亦非大烦恼地法。谓除前相。诸有欲令心乱非三摩地者。彼说此二种大地法。名有二十体有十六。所作四句与前有异。谓第一句有六法。即前五种及三摩地。第二句亦有六法。谓前五及心乱。第三句有四法。谓前五中除心乱。第四句如前说。评曰。此中前说为善。小烦恼地法有十种。一忿。二恨。三覆。四恼。五谄。六诳。七憍。八悭。九嫉。十害。大善地法有十种。一信。二精进。三惭。四愧。五无贪。六无嗔。七轻安。八舍。九不放逸。十不害。大不善地法有五种。一无明。二惛沈。三掉举。四无惭。五无愧。大有覆无记地法有三种。一无明。二惛沈。三掉举。大无覆无记地法有十种。即前大地受等十法。问大地法等有何义耶。答若法一切心中可得名大地法。谓若染污不染污。若有漏无漏。若善不善无记。若三界系不系。若学无学非学非无学。若见所断修所断不断。若在意地。若五识身。一切心中皆可得故名大地法。若法一切染污心中可得。名大烦恼地法。谓若不善。若无记。若欲界系。若色界系。若无色界系。若见所断。若修所断。若在意地。若五识身。烦恼起时皆可得故。名大烦恼地法。应知此中不信等五。唯与一切染污心俱故。立大烦恼地法。忘念等五如前已说。若法少分染污心中可得名小烦恼地法。谓忿等七。唯不善谄诳憍。或不善。或无记。又忿等七。唯欲界系。谄诳欲界初静虑系。憍三界系。又此十种唯修所断。唯在意地。若一起时必无第二互相违故。名小烦恼地法。若法唯在一切善心中可得名大善地法。谓若有漏。若无漏。若生得善。若加行善。若三界系。若不系。若学若无学。若非学非无学。若在意地。若五识身。一切善心皆可得故。名大善地法。若法一切不善心中可得。名大不善地法。谓若见苦所断。若见集所断。若见灭所断。若见道所断。若修所断。若在意地。若五识身。一切不善心中皆可得故。名大不善地法。应知此中无惭无愧。唯在一切不善心中可得故。名大不善地法。惛沉掉举烦恼缠摄。通与一切不善心相应。又障止观势用强故。复建立在不善地中。无明一种随眠所摄。遍与一切不善心相应故。复立在不善地中。所余随眠及随烦恼无如是义。若法一切有覆无记心中可得名大有覆无记地法。谓若欲界萨迦耶见边执见相应心。若色无色界一切烦恼相应心。若在意地。若五识身。一切有覆无记心中皆可得故。名大有覆无记地法。应知此中无别心所。唯是有覆无记性摄。唯有无明惛沉掉举是烦恼缠。障止观胜。或是随眠遍在一切有覆无记心中可得故。立有覆无记地中。若法一切无覆无记心中可得。名大无覆无记地法。谓若欲界系。若色界系。若无色界系。若在意地。若五识身。若异熟生。若威仪路。若工巧处。若通果心。皆可得故。名大无覆无记地法。应知此中无别心所。唯是无覆无记性摄。即受等十遍在一切无覆无记心中可得故。立无覆无记地中

说一切有部发智大毗婆沙论卷第四十二阿毗达磨大毗婆沙论卷第四十三

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中思纳息第八之二

应知此中有二种三摩地。一染污。二不染污。染污者。名三摩地。亦名散乱。不染污者。名三摩地。不名散乱。故三摩地有十二句。一有三摩地。一所缘是散乱。二有三摩地。一所缘非散乱。三有三摩地。一行相是散乱。四有三摩地。一行相非散乱。五有三摩地。一所缘一行相是散乱。六有三摩地。一所缘一行相非散乱。七有三摩地。多所缘是散乱。八有三摩地。多所缘非散乱。九有三摩地多行相是散乱。十有三摩地。多行相非散乱。十一有三摩地。多所缘多行相是散乱。十二有三摩地。多所缘多行相非散乱。有三摩地一所缘是散乱者。如有一类。随于一物思惟不净。修未纯熟。复即于此或观青瘀。或观膖胀。或观脓烂。或观破坏。或观异赤。或观被食。或观分离。或观白骨。或观骨锁。其心散乱流荡不住。不专一境。由此因缘前定退失。后定不进。有三摩地一所缘非散乱者。如有一类。随于一物思惟不净。修已纯熟。复即于此或观青瘀广说乃至或观骨锁。心不散乱。不流不荡。安住守一。由此因缘前定不失能进后定有三摩地一行相是散乱者。如有一类。思惟非常。修未纯熟。复即由此。或观增减。或观暂时。或观转变。或观磨灭。其心散乱流荡不住。不专一境。由此因缘前定退失后定不进。有三摩地一行相非散乱者。如有一类思惟非常。修已纯熟。复即由此或观增减。广说乃至或观磨灭。心不散乱不流不荡安住守一。由此因缘前定不失能进后定有三摩地一所缘一行相是散乱者。如有一类。思惟色非常。修未纯熟。复即于此由此或观增减。广说乃至或观磨灭。其心散乱流荡不住。不专一境。由此因缘前定退失后定不进

有三摩地一所缘一行相非散乱者。如有一类。思惟色非常。修已纯熟。复即于此由此或观增减。广说乃至或观磨灭。心不散乱。不流不荡安住守一。由此因缘前定不失能进后定

有三摩地多所缘是散乱者。如有一类。于身住循身观。修未纯熟。复于受住循受观。于心住循心观。于法住循法观。其心散乱流荡不住。不专一境。由此因缘前定退失后定不进有三摩地多所缘非散乱者。如有一类。于身住循身观。修已纯熟。复于受住循受观。乃至于法住循法观。心不散乱。不流不荡安住守一。由此因缘前定不失能进后定

有三摩地多行相是散乱者。如有一类。思惟非常。修未纯熟。复或观苦。或观空。或观非我。其心散乱流荡不住。不专一境。由此因缘前定退失后定不进

有三摩地多行相非散乱者。如有一类。思惟非常。修已纯熟。复或观苦。或观空或观非我。心不散乱。不流不荡安住守一。由此因缘前定不失能进后定

有三摩地多所缘多行相是散乱者。如有一类。思惟身是非常。修未纯熟复观受是苦。心是空。法是非我。其心散乱流荡不住。不专一境。由此因缘前定退失后定不进

有三摩地多所缘多行相非散乱者。如有一类。思惟身是非常。修已纯熟。复观受是苦。心是空。法是非我。心不散乱。不流不荡安住守一。由此因缘前定不失能进后定

云何无明乃至广说。问何故作此论。答为令疑者得决定故。谓契经说不达不解不了知故。名为无明。不正知亦以不了知为相。或有生疑无明即是不正知性。是则二种体无差别。欲令彼疑得决定故。显此二种其体各别故作斯论。云何无明。答三界无智。此说应理。谓三界系无智具摄诸无明故。若作是说不知三界名无明者。则应不摄缘灭道谛二种无明。彼不缘三界故。云何不正知。答非理所引慧。问此中何故问少答多。谓不正知唯染污慧。非理所引慧。通染及不染云何知然。如业蕴说。诸意恶行皆是非理所引意业。有是非理所引意业非意恶行。谓一切有覆无记意业。及一分无覆无记意业。故知非理所引慧名通染不染。答此中非理所引慧者。应知唯摄诸染污慧。所以者何。非理所引略有二种。一者世俗。二者胜义。今说胜义非理所引。故知唯摄诸染污慧。唯染污法名为胜义非理所引。无覆无记但由世俗得彼名故此后应理论者与分别论者。相对问答难通显不正知。虽是非理所引慧摄。然有正知而妄语义。汝说不正知是非理所引慧耶者。是分别论者问。重定前宗。若不定他宗说他过失则不应理答如是者是应理论者答。谓前所立理无颠倒故言如是。汝何所欲诸有正知而妄语者。彼皆失念不正知故而妄语耶者。亦是分别论者问。举有妄语复审所宗。答如是者亦是应理论者答。谓彼所说称可所宗故言如是。又何所欲无有正知而妄语耶者。是分别论者将欲设难反定所宗显违正理。答不尔者是应理论者。遮彼所问显理无违。谓虽不正知是非理所引慧。然有正知而妄语义非无此义故言不尔。应听我说。若言不正知是非理所引慧。诸有正知而妄语。彼皆失念不正知故而妄语者则应说无有正知而妄语。若不说无有正知而妄语者。则不应言不正知是非理所引慧。诸有正知而妄语。彼皆失念不正知故而妄语。作如是说俱不应理者。是分别论者前后两关翻覆设难。前关显顺宗违理。后关显顺理违宗。二俱不可故总结言作如是说俱不应理。彼难意言。若不正知即是非理所引慧者。诸虚诳语皆是非理所引慧。发此语即从不正知起。应说无有正知妄语。若说非无正知妄语。则不应说此语皆从不正知起故。前违理后复违宗。进退推征二俱有难。应理论者后通意言。诸虚诳语虽许皆从不正知起。而可说为正知妄语。所以者何。虚诳语者正知彼事而妄说故。谓彼正知所见等事而颠倒说。是故说为正知妄语。复次虚诳语者正知自想而妄说故。谓彼正知见等自想而颠倒说。是故说为正知妄语。复次虚诳语者正知自见而妄说故。谓彼正知见等自见而颠倒说。是故说为正知妄语。复次虚诳语者应正知说而妄说故。谓彼对他王臣等众应正知说而颠倒说。是故说为正知妄语。故虚诳语虽许皆从不正知起而可说为正知妄语。若此语从不正知起则但名不正知妄语非正知妄语者。此语亦从十大地法等起。亦应名受等妄语非正知妄语。应理论者此后反破分别论者以通前难。三种破中是等彼破。三种破义如前已说。然于受等大地等法。略去初后但举中间无明。诘彼以通前难应诘彼言。诸无明皆不正知相应耶者是应理论者问。审定他宗若不定他宗说他过失则不应理。答如是者是分别论者答。所问理定故言如是。汝何所欲诸有正知而妄语者皆无明趣无明所缠。失念不正知故而妄语耶者亦是应理论者问。举有妄语重审彼宗。答如是者亦是分别论者答。谓此所说称可彼宗故言如是。又何所欲无有正知而妄语耶者是应理论者将欲设难反定彼宗显违正理。答不尔者。是分别论者遮此所问显理无违。谓诸无明虽皆不正知相应。然有正知而妄语义非无此义故言不尔。应听我说若言一切无明皆不正知相应。诸有正知而妄语。皆无明趣无明所缠失念不正知故而妄语者。则应说无有正知而妄语。若不说无有正知而妄语者则不应言一切无明皆不正知相应。诸有正知而妄语皆无明趣无明所缠失念不正知故而妄语。作如是说亦俱不应理者。是相应论者前后两关翻覆设难。前关显顺宗违理。后关显顺理违宗。二俱不可故总结言。作如是说亦俱不应理。此难意言。若诸无明皆不正。知相应者。诸虚诳语皆是失念。不正知发此语即从无明而起。应说无有正知妄语。若说非无正知妄语则不应说此语皆从无明而起。故前违理后复违宗。进退推征二俱有难分别论者理应通言。诸虚诳语虽许皆从无明而起。然可说为正知妄语。不说彼为无明妄语。应理论者应告彼言。我宗亦尔诸虚诳语虽许皆从不正知起而可说为正知妄语非不正知。故彼非难云何憍。乃至广说。问何故作此论。答为欲分别契经义故。谓契经说。心憍心慢契经虽作是说而不分别其义。经是此论所依根本。彼不说者今应说之故作斯论。云何憍。答诸憍醉极醉闷极闷心傲逸心自取是谓憍。此中憍等名虽有异而体无别。皆为显了憍自性故。云何慢。答诸慢已慢当慢心举恃心自取是谓慢。此中慢等名虽有异而体无别。皆为显了慢自性故。憍慢何差别。问何故复作此论。答欲令疑者得决定故。谓此二法展转相似。见多憍者世人共言此是多慢。见多慢者。世人共言此是多憍。为令彼疑得决定故显憍与慢自性各别故作斯论。憍慢何差别。答若不方他染着自法心傲逸本名憍。若方于他自举恃相名慢。是谓差别。此中憍者。谓不方他但自染着种姓色力财位智等心傲逸相。此中慢者。谓方于他种姓色力财位智等自举恃相。问憍以何为自性。有作是说。意为自性。末陀末那声相近故。有余师说。爱为自性。此中说染着自法故。复有说者。慢为自性。末陀磨那声相近故。然依他转但名为慢。不依他转说名为慢。亦名为憍。评曰。应作是说。有别心所爱所引起说名为憍。唯在意地。唯修所断。此憍与慢多种差别。谓慢是烦恼。憍非烦恼。慢是结缚随眠随烦恼缠。憍非结缚随眠及缠但随烦恼慢通见修所断。憍唯修所断。慢非大地等法摄。憍是小烦恼地法摄。然慢与憍俱三界系。问慢方他起。欲色二界修所断慢。可方他起外门转故。无色界慢见所断慢不方他起内门转故。云何名慢。答且无色界修所断慢。虽不方他而住慢相故亦名慢。复次先在下界方他起慢由数习力后生无色彼慢现行。有作是说。虽生无色慢不现行而在下界亦起彼慢。谓二证得无色定者展转问答所得定相因斯起慢。谓我所得胜于彼定。我能速入彼则不能。我能久住彼则不尔。见所断慢虽不方他。而住慢相故亦名慢复次修所断慢方他而起由数习力引见所断慢亦现行。有作是说。见所断慢亦方他起。如我见者集在一处展转问答我我见相因斯起慢。谓己我见胜他我见。评曰。应作是说。非一切慢要方他起。无始时来数习力故。依自相续慢亦现行。如契经言。尊者无灭往诣尊者舍利子所。作如是言。我有天眼清净过人观千世界不多用力。舍利子言。此是汝慢。此慢但依自相续起。然说诸慢方他起者从多分说。多分方他而起慢故若起增上慢我见苦是苦。乃至广说。问何故作此论。答为止他宗显正义故。谓或有执。慢无所缘。或复有执。慢缘他地。或复有执。慢缘无漏。或复有执。慢缘无为。或复有执。慢缘他部。为遮如是种种僻执。显一切慢皆有所缘。不缘他地。不缘无漏。不缘无为。不缘他部。故作斯论。若起增上慢我见苦是苦。或见集是集此何所缘。答如有一类亲近善士。听闻正法如理作意。由此因缘得谛顺忍。苦现观边者。于苦忍乐显了是苦。集现观边者。于集忍乐显了是集。彼由此忍作意持故。或由中间不作意故见疑不行。设行不觉。便作是念。我于苦见是苦。或于集见是集。由此起慢已慢当慢心举恃心自取名增上慢。此即缘苦或即缘集。此中如有一类者。谓修顺决择分者。亲近善士者。谓亲近善友。善友谓佛及佛弟子。令修善法得利乐故。听闻正法者。毁此流转赞叹还灭。引胜行教名为正法。彼能属耳无倒听闻。如理作意者。谓厌恶流转。欣乐还灭。正思所闻趣修胜行。由此因缘者。谓由前三为加行故。得谛顺忍者。谓顺决择分善根中忍。此忍随顺四圣谛理。或顺圣道故。名谛顺。苦现观边者。于苦忍乐显了是苦者。谓缘苦谛顺忍。集现观边者。于集忍乐显了是集者。谓缘集谛顺忍。忍乐显了是忍异名。皆为显示观察法忍。现观者谓见道。此忍近彼故名为边。此则总显法随法行。此中具显四预流支。谓亲近善士乃至法随法行预流向果此为先故。彼由此忍作意持故者。彼瑜伽师由忍观谛于境作意善根持故。能令见疑暂不现行。或由中间不作意故者。已出前定未入后定说为中间。非理作意名不作意。或此显无如理作意。此则显后设行不觉见疑不行者。由忍作意善根持故。此中见者。谓有身见及戒禁取。疑者谓疑。有说见者。谓有身边见戒禁取。唯除邪见。得忍不拨四圣谛故。西方师言。唯戒禁取此中名见。以得忍者不执我故。评曰。应作是说。彼亦执我。是故此中初说为善。虽暂执我不执断常故。虽暂计净不执为胜故。然诸烦恼由五因缘。虽未永断而不现行。一由奢摩他力。二由毗钵舍那力。三由善师友力。四由好居处力。五由性薄烦恼力。此中略故但举前二忍。谓毗钵舍那作意。谓奢摩他。由二善根所任持故见疑不行。设行不觉者烦恼细故。觉慧劣故。便作是念乃至广说者。彼有漏忍观苦集谛。便谓已得无漏真见。未得谓得名增上慢。因见苦起者。缘所缘苦。因见集起者缘所缘集。彼有漏忍虽能总别观苦集谛。而增上慢但能别缘。谓见苦所断者。但缘自地见苦所断法。乃至修所断者。但缘自地修所断法。问此增上慢亦应能缘苦集忍品心心所法。何故但说缘苦集耶。答亦应说彼而不说者。应知此中是有余说。复次缘忍品者唯修所断。缘苦集者通五部慢。此中但说能遍缘者故不说缘忍增上慢。复次有漏忍品亦苦集摄。是故此中说缘苦集。缘苦集言遮计此慢无所缘执。亦遮此慢能缘他地及他部执。有余师说。缘苦集者缘苦集忍非缘苦集。彼说非理。后依灭道增上慢中不说即缘灭或道。故即缘苦集不违理故

若起增上慢我见灭是灭或见道是道此何所缘。答如有一类亲近善士。听闻正法如理作意。由此因缘得谛顺忍。灭现观边者。于灭忍乐显了是灭道。现观边者于道忍乐显了是道。彼由此忍作意持故。或由中间不作意故见疑不行。设行不觉便作是念。我于灭见是灭或于道见是道。由此起慢已慢当慢心举恃心自取名增上慢。此即缘彼心心所法。此中诸句义如前说。此即缘彼心心所法者。彼有漏忍观灭道谛便谓已得无漏真见。未得谓得名增上慢。因见灭起者。缘能缘灭有漏忍品心心所法。因见道起者。缘能缘道有漏忍品心心所法。彼有漏忍虽缘灭道而增上慢但缘忍品心心所法。灭道寂静非慢境故。缘心等言。遮计此慢无所缘执。亦遮此慢能缘无为及无漏执。问此增上慢为欲界系色界系耶。设尔何失。若欲界系欲界无顺决择分忍此何所缘。若色界系未离欲染补特伽罗应无此慢。有作是说。此慢是色界系。问若尔未离欲染补特伽罗应无此慢。答此中略说离欲染者。有说。未离欲染者亦起未至地增上慢。彼不应作是说。未离下地染者必不起上地烦恼故。复有说者。此慢亦是欲界系。问若尔欲界无顺决择分忍此何所缘。答欲界虽无顺决择分。而亦有彼相似善根。此增上慢缘彼而起。欲界具有一切功德相似法故。若起增上慢我生已尽乃至广说。问何故复作此论。答前文唯说异生所起增上慢。今欲通说异生圣者所起增上慢。如异生圣者应知未见谛已见谛。未现观已现观。不定聚正定聚。无圣道有圣道亦尔。复次前文唯说未得果者增上慢。今欲通说未得果已得果者增上慢。复次前文唯说依见道生增上慢。今欲通说依见修无学道生增上慢。复次前文唯说依学道生增上慢。今欲通说依学无学道生增上慢。复次前文唯说欲色界增上慢。今欲通说三界增上慢故作斯论。若起增上慢我生已尽此何所缘。答如有一类作是念言。此是道此是行。我依此道此行。已遍知苦。已永断集已证灭。已修道。我生已尽。由此起慢已慢当慢心举恃心自取名增上慢。此即缘生。此中此是道此是行者。随于何处作道行想已遍知苦乃至已修道者。随于何处作苦集灭道想。我生已尽者。随于何蕴作生想。此即缘生者。缘所尽生即有漏蕴。问此增上慢亦应能缘慢者。所执有漏道行何故但说缘所尽生。答亦应说彼而不说者。应知此中是有余说。复次缘道行者唯修所断缘所尽生通五部慢。此中但说能遍缘者。复次有漏道行亦是生摄故说缘生。有余师说。所执道行说名为生能生慢故。此慢但缘能尽生道。彼说非理后依梵行已立等慢不说缘生故。此慢缘所尽生不违理故

若起增上慢我梵行已立此何所缘。答如有一类作是念言。此是道此是行。我依此道此行。已遍知苦已永断集。已证灭。已修道。我梵行已立。由此起慢已慢当慢心举恃心自取名增上慢。此即缘彼心心所法。此中诸句义如前说。我梵行已立者。随于何处作梵行想。诸阿罗汉于学道名已立于无学道名今立此即缘彼心心所法者。此增上慢缘彼所执有漏道行。无漏梵行非彼境故。若起增上慢我所作已办此何所缘。答如有一类作是念言。此是道此是行。我依此道此行。已遍知苦。已永断集。已证灭。已修道。我已断随眠。已害烦恼。已吐结。已尽漏。所作已办。由此起慢已慢当慢心举恃心自取名增上慢。此即缘彼心心所法。此中诸句义如前说。已断随眠广说乃至已尽漏者此本论师于异名义。得善巧故作种种说。文虽有异而体无别。皆为显示烦恼灭故。断害吐尽于随眠等。交互建立义并无违。即烦名恼灭为所作。证之满足故名已办。此即缘彼心心所法者。此增上慢缘彼所执有漏道行。诸烦恼灭非彼境故若起增上慢我不受后有。乃至广说。问何故复作此论。答前说依时解脱所起增上慢。今欲说依不时解脱所起增上慢。复次前说依尽智所起增上慢。今欲说依无生智所起增上慢故作斯论。若起增上慢我不受后有此何所缘。答如有一类作是念言。此是道此是行。我依此道此行。已遍知苦。已永断集。已证灭。已修道。我生已尽。梵行已立。所作已办。不受后有。由此起慢已慢当慢心举恃心自取名增上慢。此即缘有此中诸句义如前说。复说我生已尽等者。显无生智依尽智起。如前尽智依道行起故说道行。不受后有者。得无生智不复退堕受后有故。此即缘有者。此增上慢即缘所不受有。此中问答如前应知。以有与生义相似故。有本说缘心心所法显不受后有即是灭道故。问我生已尽何故不然。答彼亦应尔但绮互说

问谁起几种增上慢耶。有说异生起五种增上慢。谓于胜品有漏善根及预流等四沙门果。预流起四除第一。一来起三除前二。不还起二除前三。诸阿罗汉无增上慢。问预流等云何于自果起慢。答于胜根性起增上慢。有说异生起九种增上慢。谓于胜品有漏善根。及于无漏四向四果。预流果起七除前二。一来向起六除前三。一来果起五除前四。不还向起四除前五。不还果起三除前六。阿罗汉向起二除前七。阿罗汉果无增上慢。预流向无起增上慢义。评曰。圣者亦于胜有漏善起增上慢。故六圣者如前所起各复增一。问异生云何于阿罗汉起增上慢。答异生有二种。一爱行者。二见行者。若爱行者修不净观。伏爱品烦恼令不现行。彼性不起见品烦恼。便自谓得阿罗汉果。若见行者修持息念。伏见品烦恼令不现行。彼性不起爱品烦恼便自谓得阿罗汉果。问此增上慢。为但依有处起。为亦依无处耶。答通依二处起。谓异生于有漏善起增上慢依有处起。于无漏善起增上慢依无处起预流果于预流果及有漏善。起增上慢依有处起。于预流向乃至阿罗汉果。起增上慢依无处起。广说乃至阿罗汉向于阿罗汉向及有漏善。起增上慢依有处起。于阿罗汉果起增上慢依无处起。问未得色无色界根本定者亦能起彼增上慢耶。有说不起。以彼烦恼系属彼地根本定故。应说不定全未得者必不能起未离下染上地烦恼不现前故。若已证得而未起者容起彼慢。彼近分地亦有慢等诸烦恼故

云何自谓卑而起慢乃至广说。问何故作此论。答欲令疑者得决定故。谓有生疑自高陵物可名为慢。自卑尊他应不名慢。为令彼疑得决定故显有卑慢自卑尊他故作斯论。云何自谓卑而起慢耶。答如有一类见他胜己种姓族类财位伎艺及田宅等作是念言。彼少胜我我少劣彼。然劣于他多百千倍。由此起慢已慢当慢心举恃心自取。是名自谓卑而起慢此中种谓刹帝利婆罗门等。姓谓迦叶波乔答摩等。族谓父族母族。类谓白黑等。财谓金银等。位谓王侯等。伎谓巧术等。艺谓书数等。田谓稼穑生处。宅谓人等居处。等谓等余聪辩等事。于如是事见他胜己多而谓少故成卑慢。若称量者则不名慢

复次慢有七种。一慢。二过慢。三慢过慢。四我慢。五增上慢。六卑慢。七邪慢。慢者于劣谓己胜或于等谓己等。由此起慢已慢当慢心举恃心自取。过慢者于等谓己胜。或于胜谓己等。由此起慢广说如前。慢过慢者于胜谓己胜。由此起慢广说如前。我慢者于五取蕴谓我我所由此起慢广说如前。增上慢者于胜功德未得谓得。未获谓获。未触谓触。未证谓证。由此起慢广说如前。卑慢者于他多胜谓己少劣。由此起慢广说如前。邪慢者实自无德谓己有德。由此起慢广说如前。问增上慢邪慢俱依未得处起云何差别。答增上慢通于有无处起。邪慢唯于无处起。复次增上慢通于已得未得处起。邪慢唯于未得处起。复次增上慢于等功德或胜功德处起。邪慢都无功德处起复次增上慢于似功德或实功德处起。邪慢都无功德处起。复次增上慢内外道俱起。邪慢唯外道起。复次增上慢异生圣者俱起。邪慢唯异生起。是谓差别。问如是七慢几见所断。几修所断。有作是说。一唯见所断。谓我慢。一唯修所断谓卑慢。余五通见修所断。有余师说。二唯见所断谓我慢邪慢。一唯修所断谓卑慢。余四通见修所断。评曰。应作是说。七慢皆通见修所断。问我慢邪慢云何通修所断。答有身见及邪见于五部法执我我所及拨为无此后。或缘见苦所断法起我慢及邪慢。或乃至缘修所断法起我慢及邪慢。故此二慢通修所断。问云何卑慢见所断耶。答如我见者。互相问答我见相已。有便知他我见胜已。而于多胜谓己少劣遂起卑慢。此等卑慢是见所断问如是七慢几何界系。有作是说。欲界具七。上二界唯有六除卑慢。彼无校量种姓等故。评曰。色无色界亦具七慢。问彼无校量种姓等义宁有卑慢。答彼虽无有校量种等而有比度定等功德。复次先在欲界方他而起。由数习力后生上界引起彼慢。有作是说。虽生上界卑慢不起。而在欲界起彼卑慢。如二证得上界定者。展转问答所得定相。因斯校量有起卑慢。评曰。应作是说。非卑慢等要比度他胜劣而起。无始时来数习力故。虽生上界亦有现行。是故三界皆具七慢

说一切有部发智大毗婆沙论卷第四十三阿毗达磨大毗婆沙论卷第四十四

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中思纳息第八之三

如契经说。若起欲寻恚寻害寻。或自害。或害他。或俱害。乃至广说。问何故作此论。答为广分别契经义故。谓契经说佛告苾刍。我未证得三菩提时。或起欲寻恚寻害寻。或起出离寻。无恚寻无害寻。虽起欲寻恚寻害寻而不放逸。便作是念。若起欲寻恚寻害寻。或自害。或害他。或俱害。契经虽作是说而不分别其义。经是此论所依根本。彼不说者今应说之故作斯论。云何欲寻自害。答如有一类起贪缠故。身劳心劳。身烧心烧。身热心热。身焦心焦。复由此缘当受长夜非爱非乐非喜非悦诸异熟果如是自害。此中身劳等。显欲寻等流果贪嗔痴等能驱役故。令身心劳如炽火故。能烧身心令热令燋。当受长夜等。显欲寻异熟果。当受恶趣非爱果故。云何欲寻害他。答如有一类起贪缠故观视他妻。彼夫见已心生嗔忿结恨愁恼。如是害他。问观他妻者亦招苦果应名俱害。何故说此唯是害他。答观视过轻其夫未能现加辱害是故不说。云何欲寻俱害。答如有一类。起贪缠故污夺他妻。彼夫觉已遂于其妻及于其人打缚断命。或夺财宝如是俱害。问彼夫害他亦招苦果应名三害何以称俱。答彼人现世不遭罪罚反被称誉是故不说。复次夫亦是他故名俱害。云何恚寻自害。答如有一类起嗔缠。故身劳心劳。身烧心烧。身热心热。身焦心焦。复由此缘当受长夜非爱非乐非喜非悦诸异熟果。如是自害。此中二果如前应知。云何恚寻害他。答如有一类起嗔缠故。断害他命如是害他。问断他命者亦招苦果应名俱害。何故说此唯是害他。答断贼命等。现无责罚更被称誉是故不说。云何恚寻俱害。答如有一类。起嗔缠故断害他命。亦复被他断害其命。如是俱害。问杀能害者亦招苦果应名三害何以称俱。答诛害他者世共称誉现无罪苦是故不说。复次彼亦是他故名俱害。云何害寻自害。答如有一类起害缠故。身劳心劳。身烧心烧。身热心热。身焦心焦。复由此缘当受长夜非爱非乐非喜非悦诸异熟果。如是自害。此中二果如前应知。云何害寻害他。答如有一类起害缠故打缚于他。如是害他。问打缚他者亦招苦果应名俱害。何故说此唯是害他。答打缚恶人世同称赞现不招苦是故不说。云何害寻俱害。答如有一类起害缠故打缚于他。亦复被他之所打缚如是俱害。此中问答如前应知问此三恶寻以何为自性。答欲寻以欲界五部六识身俱贪相应寻为自性。恚寻亦以五部六识身俱嗔相应寻为自性。害寻有说。即嗔一分相应寻为自性。害即嗔故。问若尔恚寻害寻有何差别。答嗔有二种。一欲断众生命。二欲打缚众生。前名为恚后名为害。复次嗔有二种。一于应嗔处起。二于不应嗔处起。前名为恚后名为害。彼二相应寻名恚寻害寻故有差别。有说害寻无明一分相应寻为自性。害即无明故。如施设论说。何缘故痴增。谓于害界害想害寻。若习若修若多所作彼相应寻名为害寻。评曰。应作是说。有别心所说名为害。非嗔。非无明。非随眠。自性是嗔所引。是嗔等流随。嗔后起。名烦恼垢。唯修所断意识相应。此相应寻是害寻自性。此三不善故名恶寻。复次有三善寻一出离寻。二无恚寻。三无害寻。问此三善寻以何为自性。答皆以一切善心相应寻为自性。谓三恶寻一一别起自性各异。非与一切不善心俱。此三善寻无别自性皆与一切善心相应。问若尔此三有何差别。答自性无别而义有异。是三恶寻近对治故。谓诸善寻违欲寻故名出离寻。违恚寻故名无恚寻。违害寻故名无害寻。如契经说我未证得三菩提时。虽起欲寻恚寻害寻而不放逸。问菩萨尔时若不放逸如何犹起此三恶寻。尊者世友作如是说。菩萨虽起此三恶寻而勤修善名不放逸。复次虽起恶寻而速能觉知是不善名不放逸。复次虽起即能厌弃吐舍名不放逸。复次暂起便能修彼对治名不放逸。复次起已即能断因缺依了知境过名不放逸。复次三因缘故烦恼现前。一由因力。二境界力。三加行力。菩萨起此三不善寻。但由因力能伏余二名不放逸。大德说曰。菩萨虽起速能伏除。如一渧水堕热铁上名不放逸。胁尊者曰。起已速舍如救头然名不放逸

问菩萨何处起三恶寻。胁尊者曰。由因力故随处而起不劳定责。如盲颠蹶愚者昏迷。随至皆然何定处所。有作是说。菩萨弃舍转轮王位。踰城出家求无上觉。寻访师友至王舍城。于日初分入城乞食。百千众生围绕瞻仰。礼拜赞叹心无厌足。菩萨于彼初起欲寻。众围绕故妨废乞食饥火所恼复起恚寻。嗔心渐歇害寻复起。须臾觉察生重惭愧。有余师说。菩萨弃舍劫比罗城。依空闲林求无上觉。父王遂遣释种五人随逐侍卫。于中有执乐行得净。初见菩萨修苦行时即便舍去中复有执苦行得净。后见菩萨舍苦行时亦复辞去。时有难陀难陀跋罗二梵志女。因献乳糜见无侍者遂住供给。女手柔软摩触菩萨。菩萨于彼便起欲寻。即生念言。先吾左右不弃我者。岂有女人得近于我。遂于左右复起恚寻。嗔心稍歇害寻复起。便自觉悟生大惭愧。或有说者。菩萨未出家时。父王净饭为娉五百玉女以为妃娣。娱乐菩萨不令出家。菩萨舍之而出家已。诸王遣使索女还国。净饭王曰。我子出家心甚忧恼。见其妃娣时用慰怀今者未能放其还国。诸王闻已各生忿恚。共发兵戈来相征罚。父王忧怖遣告菩萨吾今坐汝致此怨仇。有说天神来告菩萨。菩萨闻已于父王所先发欲寻。于五百王恚寻。次起于其军众复起害寻。少时觉察深生惭愧。复有说者。菩萨出家修苦行时。忆昔所受五欲乐事起于欲寻。后闻天寿乱己宫室复起恚寻。于彼媒媾复起害寻。须臾觉悟生大惭愧。或复有说。菩萨六年修苦行时。恶魔随逐欲作留难。或时示现可爱色像。菩萨于彼发起欲寻。或时示现可畏色像。菩萨于彼发起恚寻。或时示现侮弄色像。菩萨于彼发起害寻。少时追悔深起惭愧。尊者妙音作如是说。菩萨先以欲界闻思所生二慧伏诸烦恼。爱此慧故发起欲寻。须臾觉悟此是烦恼增恶此故发起恚寻。渐复歇薄发起害寻。于后觉知深生惭愧。大德说曰。菩萨昔居菩提树下。初夜魔女来相媚乱。尔时菩萨暂起欲寻。中夜魔军总来逼恼菩萨。于彼暂起恚寻。渐复歇薄复起害寻。须臾觉察即入慈定令魔兵众摧败堕落如契经说。菩萨起此三恶寻已。便自了知此能自害害他俱害。问云何菩萨所起欲寻恚寻害寻能为三害。答虽无害用而依相说。恶寻必有三害相故。复次恶寻起时自利事远故名自害。利他事远故名害他。俱利事远故名俱害复次恶寻起时自利事坏故名自害。利他事坏故名害他。俱利事坏故名俱害。复次恶寻起时自利心息故名自害。利他心息故名害他。俱利心息故名俱害。复次恶寻起时于自相续取果与果故名自害。令诸施主虽施四事而无大果故名害他。即总此二名为俱害。复次恶寻起时于自相续生自性愚。及所缘愚故名自害。令他施主施无大果故名害他。即总此二名为俱害。复次恶寻起时染自相续故名自害。染他相续故名害他。即总此二名为俱害。复次恶寻起时令自相续离贤圣乐故名自害。亦令他离故名害他。即总此二名为俱害。尊者世友说曰。恶寻起时令自相续离系果远故名自害。令所化者离系果远故名害他。即总此二名为俱害。尊者妙音说曰。恶寻起时令自相续胜功德远故名自害。令所化者胜功德远故名害他。即总此二名为俱害。大德说曰。恶寻起时令一切智一切种智不能速证故名自害。令所化者不疾得益故名害他。即总此二名为俱害。胁尊者曰。恶寻起时身心热恼故名自害。失所化益故名害他。即总此二名为俱害。尊者觉天说曰。恶寻起时身心不适故名自害。天神诃责故名害他。即总此二名为俱害

如契经说。佛告苾刍。我初成佛多起二寻。谓安隐寻及远离寻。问此二寻以何为自性。答安隐寻以出离寻为自性。远离寻以无恚害寻为自性。有说翻此。复次安隐寻对治欲寻。远离寻对治恚害寻。有说翻此。复次安隐寻无贪善根相应。远离寻无嗔痴善根相应。有说翻此。复次安隐寻对治贪相应寻。远离寻对治嗔痴相应寻。有说翻此。复次安隐寻慈悲相应。远离寻喜舍相应。有说翻此。复次安隐寻苦集智相应。远离寻灭道智相应。有说翻此。复次安隐寻空及苦集无愿三摩地俱。远离寻无相及道无愿三摩地俱。有说翻此。尊者妙音说曰。见流转过失相应寻名安隐寻。见还灭功德相应寻名远离寻。尊者觉天说曰。见还灭功德相应寻名安隐寻。见流转过失相应寻名远离寻。大德说曰。无边利益意相应寻名安隐寻。无边安乐意相应寻名远离寻。胁尊者曰。无边安乐意相应寻名安隐寻。无边利益意相应寻名远离寻。尊者世友说曰。无边怜愍意乐所起名安隐寻。无边调善意乐所起名远离寻。问何故初成佛已多分起此二寻。答由此二寻是阿耨多罗三藐三菩提前行者及净道故。复次为对治昔在家时受欲乐故。初成佛已多起远离寻。为对治修苦行时无利苦故。初成佛已起安隐寻。复次初成佛已庆自德故多起安隐寻。欲度他故多起远离寻智多耶境多耶。乃至广说。问何故作此论。答为止他宗显正义故。谓或有执。有缘无智如譬喻者。彼作是说。若缘幻事健达缚城及旋火轮鹿爱等智皆缘无境。为遮彼执显一切智皆缘有境。或复有执。有智不缘境有境非智缘。为遮彼执显一切智皆能缘境。显一切境皆智所缘。复次为显外道有颠倒故境智相违。及显内道无颠倒故境智相顺。复次有说。智多非境以一境上有多智故。今欲显示境多非智由此因缘故作斯论。智多耶境多耶。答境多非智。所以者何。智亦境故。谓智唯摄一界一处一蕴少分。境摄十八界十二处五蕴。有作是说。智多非境。所以者何。如非想非非想处下下品一刹那受。为欲界十智知。谓九不同分界遍行随眠相应品智。及善世俗智知。为欲界十智知。乃至无所有处亦尔。为非想非非想处十六智知。谓十一遍行随眠相应品智。及修所断贪慢无明相应智无覆无记善世俗智。如是总有九十六智并无漏智九十七智知彼一受。余受余法如理应知。是故当知智多非境。彼说非理。所以者何。彼智相应俱有等法及智自性皆是境故设智非境其境尚多况智亦境而境非多。问若智亦境智境何别。答能知是智所知是境。复次智唯非色无见无对有为相应有所依有所缘有行相。境通色非色有见无见。有对无对有为无为。相应不相应有所依无所依有所缘无所缘。有行相无行相。复次智唯三世三谛所摄。境通三世非世四谛所摄。此等名为境与智别

智多耶识多耶。乃至广说。问何故作此论。答为止他宗显正义故。谓或有执。识智二法展转相应忍即智故。为遮彼执显一切智与识相应。非一切识与智相应。诸无漏忍非智性故。或复有执。智唯无漏识唯有漏。互不相应。为遮彼执显识与智俱通二种。有相应义。有余师执。智即是识分位差别故。智与识无相应义。为遮彼执显识与智体用各别。有相应义。由此因缘故作斯论。智多耶识多耶。答识多非智。所以者何。诸智皆识相应。非诸识皆智相应。忍相应识非智相应故。问诸无漏忍何故非智。答于所见境未重观故。谓无始来于四圣谛未以无漏真实慧见。今虽创见而未重观故。不名智。要同类慧于境重观方成智故。无一有情于一切法。无始时来非有漏慧数数观之。故有漏慧皆智所摄。复次忍于圣谛推度忍可。未究竟故非智所摄。复次忍与所断疑得俱故非智所摄。设不与俱而是彼类。有漏无间道非真对治故。虽疑得俱而亦是智。由无漏忍非智所摄故说识多。复次识摄七界一处一蕴。智唯一界一处一蕴少分所摄是故智少

有漏行多耶无漏行多耶。乃至广说。问何故作此论。答为止他宗显正理故。谓或有执佛生身是无漏。如大众部彼作是说。经言如来生在世间长在世间。若行若住不为世法之所染污。由此故知如来生身亦是无漏。为遮彼执显佛生身定是有漏。若佛生身是无漏者。则于佛身无比女人不应起爱。指鬘不应起嗔傲士不应起慢。坞卢频螺不应起痴。既缘起爱及嗔慢痴故佛生身定非无漏。问若尔彼部所引契经当云何释。答彼依法身故作是说。经言如来生在世间长在世间者依生身说。若行若住不为世法之所染污者依法身说。故不相违复次依不随顺故说不染。谓世八法随顺世间。诸有情类亦随顺彼故说染污。世间八法随顺如来。佛不顺之故说不染。复次如来生身虽是有漏而超八法故说不染。问利等八法如来亦有何故言超。利谓哀愍勇长者故一日受彼三亿具衣。衰谓入彼大娑罗村乞食不得空钵而返毁谓战遮婆罗门女及孙陀利谤佛声遍十六大国。誉谓如来生时声彻他化自在。成佛声至色究竟天。转法轮时声至梵世。称谓跋罗堕阇梵志以五百颂现前赞佛。论力外道坞波离等诸大论师。以百千颂瞻仰赞佛。具寿阿难合掌赞佛诸希有法。尊者舍利子恭敬赞佛诸无上法。如是一切。讥谓跋罗堕阇梵志先五百颂现前骂佛。苦谓如来有时背痛。砾石毒刺伤足指等。乐谓如来有轻安乐。及生死中最胜受乐。如何世尊超世八法。答如来虽遇利等四法而不生于高欢喜爱。如来虽遇衰等四法而不生于下戚忧恚。由此名超故称不染。非谓无漏立不染名。如妙高山住金轮上。八方猛风不能倾动诸佛亦尔。住净尸罗。世间八法不能倾动。是故为遮他宗异执显示正理故作斯论。有漏行多耶无漏行多耶。答有漏行多非无漏行。所以者何。有漏行摄十处二处少分。无漏行唯摄二处少分故。有作是说。无漏行多非有漏行。所以者何。如欲界系下下品摄。一刹那色定为四种无漏慧缘。一苦法智忍。二苦法智。三集法智忍。四集法智。余色余法如理应知。复有此余诸无漏法故无漏行决定为多。有余师说。有漏行多。所以者何。如一无漏行为四有漏缘。一邪见。二疑。三无明。四善世俗智。余无漏行如理应知。复有此余诸有漏法。故有漏行决定为多。评曰应作是说。有漏无漏行虽俱无边。而此本论师且约处摄说有漏多非无漏行

复次此本论师虽不问答有为无为诸法多少。而义应有问有为法多耶无为法多耶。答有为法多非无为法。所以者何。有为法摄十一处一处少分。无为法唯摄一处少分故。评曰应作是说。无为法多非有为法。所以者何。随有漏法有尔所体择灭无为数量亦尔。随无漏道有尔所体。非择灭无为数量亦尔。复有此余随有漏法体量多少。诸非择灭及虚空无为故。无为法多非有为法。然准前门且依处说故说无为其数是少云何行圆满乃至广说。问何故作此论。答为欲分别契经义故。谓契经说。佛弟子众。尸罗圆满。等持圆满。般若圆满。行圆满。护圆满。契经虽作是说。而不分别其义不说云何行护圆满。经是此论所依根本。彼不说者今欲说之故作斯论。云何行圆满。答无学身律仪语律仪命清净。问学及非学非无学亦有律仪。何故此中唯说无学。答依胜说故。谓若法若补特伽罗。俱无学胜是故偏说。复次若有律仪非不律仪所损坏者此中说之。学等不尔。无学身业名身律仪。无学语业名语律仪。无学身语业总名命清净。即是正业正语正命。契经说戒。或名尸罗。或名为行。或名为足。或名为箧。言尸罗者是清凉义。谓恶能令身心热恼。戒能安适故曰清凉。又恶能招恶趣热恼。戒招善趣故曰清凉。又尸罗者是安眠义。谓持戒者得安隐眠常得善梦故曰尸罗。又尸罗者是数习义常习善法故曰尸罗。又尸罗者是得定义谓持戒者心易得定故曰尸罗。又尸罗者是隧蹬义。如伽他说

  佛法池清凉　　尸罗为隧蹬
  圣浴不濡身　　逮彼岸功德

又尸罗者是严具义。有庄严具于幼为好非壮老年。有庄严具于壮为好非幼老年。有庄严具于老为好非幼壮年。尸罗严身三时常好。如伽他说

  尸罗严身具　　幼壮老咸宜
  住信慧为珍　　福无能盗者

又尸罗者是明镜义。如镜明净像现其中。住净尸罗无我像现。又尸罗者是阶陛义。如尊者无灭言。我蹈尸罗阶升无上慧殿。又尸罗者是增上义。佛于三千大千世界有威势者皆尸罗力。昔此迦湿弥罗国中有一毒龙。名无怯惧。禀性暴恶多为损害。去彼不远有毗诃罗数为彼龙之所娆恼。寺有五百大阿罗汉。共议入定欲逐彼龙尽其神力而不能遣有阿罗汉从外而来。诸旧住僧为说上事。时外来者至龙住处。弹指语言。贤面远去。龙闻其声即便远去。诸阿罗汉怪而问言。汝遣此龙是何定力。彼答众曰。我不入定亦不起通。但护尸罗故有此力。我护轻罪如防重禁故使恶龙惊怖而去。由此尸罗是增上义。又尸罗者是头首义。如有头首。即能见色闻声嗅香尝味觉触知法。有尸罗者。即能见四圣谛色。闻未曾有名身等声。嗅三十七觉分花香。尝出家远离三菩提寂静味。觉静虑解脱等持等至触。知蕴处界自相共相法。是故尸罗是头首义。契经说。戒名为行者以诸世间说戒名行故。诸世间见持戒者言彼有行。见破戒者言彼无行。又净持戒是众行本能至涅槃故名为行。契经说戒名为足者。能往善趣至涅槃故。如有足者能避险恶至安隐处。有净戒者能越恶趣生天人中。或超生死到涅槃岸故名为足。契经说。戒名为箧者。任持一切功德法故。谓持戒者任持功德不令退散。如箧持宝。尊者妙音作如是说。戒名不坏。所以者何。如足不坏则能自在往安隐处。具净戒者亦复如是能至涅槃。此中无学身语净戒名行圆满行中极故。云何护圆满。答无学根律仪。应知此中根是所护。由念慧力护眼等根不令于境起诸过患。如钩制象不令奔逸。是故无学正念正知名护圆满。如伽他说

  世间诸瀑流　　正念能防护
  若令毕竟断　　其功唯正知

问根律仪根不律仪。各以何为自性。答根律仪以正念正知为自性。根不律仪以失念不正知为自性。云何知然。经为量故。如契经说。天告苾刍。汝今不应自开疮漏。苾刍答曰。我当覆之。天复语言。疮漏非小以何能覆。苾刍答曰。我当覆以正念正知。天曰善哉。此为真覆。故知此二是根律仪覆护律仪。义相似故根不律仪翻前而立故是失念及不正知。问若正念正知是根律仪者。契经所说当云何通。如说念慧圆满故根律仪圆满。岂说自性圆满故自性圆满耶。答念慧有二种。一因性。二果性。因性者名念慧。果性者名根律仪。复次念慧有二种。一生得善。二加行善。生得善者名念慧。加行善者名根律仪。复次念慧有二种。一不定善。二定善。不定善者名念慧。定善者名根律仪。复次念慧有二种。一世间善。二出世间善。世间善者名念慧。出世间善者。名根律仪。复次念慧有二种。一学。二无学。学者名念慧。无学者名根律仪。复次念慧有二种。一钝根种性。二利根种性钝根种性名念慧。利根种性名根律仪故与契经不相违害。有作是说。根律仪以不放逸为自性。根不律仪以放逸为自性。有余师说。根律仪以六恒住法为自性。根不律仪以此所对治诸烦恼业为自性。或有说者。根律仪以于六根已断已遍知法不成就性。及彼对治道成就性为自性。根不律仪以于六根未断未遍知法成就性。及彼对治道不成就性为自性。复有说者。根律仪以于六根已断已遍知时。所有妙行善根生长广大为自性。根不律仪以于六根未断未遍知时。所有恶行不善根生长广大为自性。有作是言。根律仪以一切善法为自性。根不律仪以一切染污法为自性。复有说言。根律仪以一切善法及顺善无覆无记法为自性。根不律仪以一切染污法及顺染无覆无记法为自性。昔此迦湿弥罗国中有毗诃罗名吉祥胤。二阿罗汉曾住其中。俱证三明。具八解脱。得无碍解。是说法师是亲兄弟。父名难提婆罗门种。俱作是说。根律仪根不律仪。皆以无覆无记不相应行蕴中律仪不律仪为自性。问若此俱是无覆无记心不相应行蕴摄者。此二自性有何差别。答随顺染污者名不律仪。随顺清净者名律仪。是谓差别。评曰。此诸说中初说为善。经说念慧能护根故

复次即此念慧有位亦得断律仪名。随位差别建立多种。且说有漏断律仪者。谓欲界见修所断法。以未至地能离欲界有漏。九无间道中念慧二法为断律仪。若初静虑见修所断法。以第二静虑近分地能离初静虑。九无间道中念慧二法为断律仪。乃至无所有处见修所断法。以非想非非想处近分地能离无所有处。九无间道中念慧二法为断律仪。若说无漏断律仪者。谓欲界见修所断法。以未至地能离欲界。无漏诸无间道中念慧二法为断律仪。若初静虑见修所断法。以依未至静虑中间及初静虑能离初静虑三地。无漏诸无间道中念慧二法为断律仪。第二静虑见修所断法。以前三地及第二静虑能离第二静虑。四地无漏诸无间道中念慧二法为断律仪。第三静虑见修所断法以前四地及第三静虑能离第三静虑五地。无漏诸无间道中念慧二法为断律仪。第四静虑见修所断法。及无色界见所断法。以前五地及第四静虑能离第四静虑等。六地无漏诸无间道中念慧二法为断律仪。空无边处修所断法。以前六地及空无边处能离空无边处。七地无漏九无间道中念慧二法为断律仪。识无边处修所断法。以前七地及识无边处能离识无边处八地无漏九无间道中念慧二法为断律仪。无所有处及非想非非想处修所断法。以前八地及无所有处能离二地九地。无漏九无间道中念慧二法为断律仪

说一切有部发智大毗婆沙论卷第四十四阿毗达磨大毗婆沙论卷第四十五

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    杂蕴第一中思纳息第八之四

云何异生性。乃至广说。问何故作此论。答为止他宗显正义故。谓或有执欲界见苦所断十随眠是异生性。如犊子部。彼说异生性是欲界系。是染污性是见所断。是相应行蕴摄。为遮彼执显异生性是三界系。是修所断。是不染污。是不相应行蕴所摄。或复有执。异生性无实体。如譬喻者为遮彼执显异生性自体实有。为遮此等诸部异执。显示正理故作斯论。此本论中说异生性。品类足论说异生法。如说。云何异生法。谓地狱傍生鬼界比俱卢洲无想天。彼业彼生是谓异生法。问何故此本论中。说异生性非异生法。品类足论。说异生法非异生性耶。答是作论者意欲尔故。复次此彼皆是有余说故。复次此彼二论各说一种互相显故。复次异生性胜。非异生法。此本论中且就胜说。此论已说异生性。故品类足论不重说之。此论未说异生法故。品类足论说异生法。此显彼论在此后造。有作是说。彼论已说异生法故此不重说。彼论未说异生性。故此论说之。此显彼论在此先造。问何故名异生性。尊者世友作如是说。能令有情起异类见异类烦恼造异类业。受异类果异类生故。名异生性。复次能令有情堕异界故。往异趣故。受异生故。名异生性。复次能令有情信异师故。作异相故。受异法故。行异行故。求异果故。名异生性。大德说曰。能令有情依止异类界趣生有。发起种种颠倒烦恼。造作增长感后有业。轮转生死无分限故。名异生性。阿毗达磨诸论师言。异生分故异生体故名异生性。尊者妙音作如是说。异生类故名异生性。胁尊者言。异生依故障圣性故。名异生性。问何故名异生法。答诸异生者有此法故。名异生法。譬如世间王法臣法。问诸异生法。圣者亦有。何故但立异生法名。答诸异生法圣者多无。设有少者不名圣法。以圣者于彼得而不在身成就不现前故。唯异生于彼得而亦在身成就亦现前故名异生法。复次异生成就彼法。能令彼法取果与果故。名异生法。圣者虽成就彼法。而不尔故不名圣法。复次异生成就彼法。能令彼法往异趣异界异处异生受异果故。名异生法。圣者虽成就彼法。而不尔故不名圣法。复次异生性是有漏。彼法亦有漏故名异生法。圣性是无漏彼法非无漏故不名圣法。复次异生为彼所覆蔽故。所缠缚故。所诳惑故。名异生法。圣不尔故不名圣法。复次诸异生类随顺彼法生长彼法故。名异生法。圣不尔故不名圣法。问异生性异生法。何差别。答异生性唯非色。异生法通色非色。异生性唯无见。异生法通有见无见。异生性唯无对。异生法通有对无对。异生性唯不相应。异生法通相应不相应。异生性唯无所依无所缘无行相异生法皆通二种。异生性唯不染污。无罪无异熟。异生法皆通二种。复次异生性唯无记。异生法通善不善无记。异生性通三界系。异生法唯欲色界系。异生性唯修所断。异生法通见修所断。复次异生性是因。异生法是果。如因果能作所作亦尔。复次异生性法界法处行蕴所摄。异生法十八界十二处五蕴所摄。复次异生性苦法智忍时舍。异生法余时舍。如是等门是谓差别。如世尊说。随信随法行超异生地。未得预流果定不命终。问何故名异生地。答一切圣者皆名同生。此异于彼故名异生。容受异生名异生地。问若尔。圣者异异生故应名异生。答一切圣者同会真理。同见同欲故名同生。异生不尔。可厌贱故立异生名。不应为难。尊者世友作如是说。容起异见异类烦恼。容造异业。容堕异界。往异趣等。而受生故。名异生地。复次容信异师。广说乃至求异果故。名异生地。大德说曰。异于正法及毗奈耶。而受生故。名为异生。是诸异生生长依处名异生地云何异生性。答若于圣法圣暖圣见圣忍圣欲圣慧。诸非得已非得当非得。是谓异生性。问为不得苦法智忍是异生性。为不得一切圣法是异生性耶。设尔何失。若不得苦法智忍是异生性者。道类智已生舍苦法智忍。尔时苦法智忍非得。应是异生性。是则住修道无学道者。亦应名异生。若不得一切圣法是异生性者。则应一切有情皆名异生。无圣者成就一切圣法故。谓乃至佛亦不成就二乘圣法。及自乘学法。亦应名异生。有作是说。不得苦法智忍是异生性。问若尔道类智已生舍苦法智忍。尔时苦法智忍非得。应是异生性。是则住修道无学道者亦应名异生。答苦法智忍生时。害彼非得。令于自相续永不复生故。住修道无学道者。于苦法智忍虽不成就。而不名不得。亦不名得。如眼根生时害彼非得。令于自相续永不复生。眼根灭已虽不成就。而不名不得。亦不名得此亦如是。故无前过。复次道类智已生。苦法智忍虽不成就。而成就彼等流果故。不名异生。复有说者。不得一切圣法是异生性。问若尔。则应一切有情皆名异生。无圣者成就一切圣法故。答虽无圣者具足成就一切圣法。而非异生。以彼非得杂圣得故。谓若身中圣法非得不杂得者。是异生性。圣者身中圣法非得杂圣得故非异生性。彼得非得恒俱生故。复次彼非得有二种。一共。二不共。不共者是异生性。共者非异生性。圣者身中圣法非得。一向是共故无前失。复次彼非得有二种。一未被害二已被害。未被害者是异生性。已被害者非异生性。圣者身中圣法非得。皆已被害故无前失。复次一切圣法非得有二。一依异生相续现起。二依圣者相续现起。前是异生性。后非异生性。故无圣者名异生失。问圣法圣暖圣见圣忍圣欲圣慧有何差别。有作是说。此中六句皆共显示苦法智忍。初一是总。后五是别。初一是略。后五是广。初一是不分别。后五是分别。谓苦法智忍令蕴种子皆悉萎悴故名圣暖。推求谛理故名圣见。忍可谛理故名圣忍。爱乐谛理故名圣欲。决择谛理故名圣慧。复次苦法智忍令有种子皆悉萎悴故名圣暖。推求行转故名圣见。忍可行转故名圣忍。爱乐解脱故名圣欲。觉了谛理故名圣慧。有说。六地苦法智忍。即是此中六句所显。有说。六姓苦法智忍。即是此中六句所显。复有说者。此中六句皆共显示一切圣法。谓诸圣法义有总别。初一是总。后五是别。五中二释如前应知。有说。六姓一切圣法。即是此中六句所显。有说。三乘学无学法。即是此中六句所显。有余师说。此中显示真实相似二种圣法。相似圣法。即暖等四顺决择分。圣法者。谓真实圣法即无漏道。圣暖者谓暖法。圣见者谓顶法。圣忍者谓下中忍法。圣欲者谓增上忍法圣慧者谓世第一法。若未修得暖法等四。当知彼是全分异生。若得暖等亦名圣者。如世尊说。若有成就暖等善根。我说彼名相似圣者。然异生性唯是真实圣法非得非不得余故彼不应言暖等。谓暖等此异生性当言善耶不善耶无记耶。答应言无记。谓无覆无记非得性故。一切非得皆是无覆无记性摄。问异熟生等四无记中此何所摄。答非四所摄。但是等流无覆无记。问此何故非有覆无记。答非离染时舍此性故。何故异生性非善耶。答善法或由加行故得。或由余缘故得。无设加行求作异生。又断善时善法皆舍。得诸善法不成就性。若异生性是善性者。断善根者。应非异生。非直语言其义便立。故复问答显非善等。此中有说。善法或由加行故得者。显由加行所起诸善。或由余缘故得者。显彼所修未来诸善。复次善法或由加行故得者。显加行得善。或由余缘故得者。显离染得善。复次善法或由加行故得者。显加行得善中顺胜进分顺决择分。或由余缘故得者。显加行得善中顺退分顺住分。问若尔。此中何故不说生得善耶。答应说而不说者。当知此义有余。复次此中但说难得胜善。诸生得善易得下劣故不说之。复次诸异生性皆是生得。若此中说生得善者。便不异彼。故不说之。复有说者。善法或由加行。故得者。显加行得善。或由余缘故得者。显生得善。复次善法或由加行故得者。显胜进时所得诸善。或由余缘故得者。显退等时所得诸善。此中应作四句分别。或有善法由加行故得非由余缘。如暖顶忍世第一法。见道现观边世俗智。道类智不动心解脱。无诤愿智边际定等。或有善法由余缘故得非由加行。如生得善。或有善法由加行故得亦由余缘。如四沙门果。静虑无色无量解脱胜处遍处等。或有善法非由加行故得。亦非由余缘者无也。无设加行求作异生者。显异生性非加行得善。谓必无有先非异生。后求证得彼下贱故。无始时来是异生故。又断善时善法皆舍等者。显异生性非生得善。谓断善时正断生得非加行故。若断善根非异生者。甚违正理。彼极恶故。勿有如斯所说过失。故异生性决定非善。何故异生性非不善耶。答离欲染时不善皆舍。得不善法不成就性。若异生性是不善者。诸异生离欲染应非异生。若非异生彼后不应还生欲界。圣离欲染必不更受欲界生故。又若尔者。色无色界应无异生。便有大失。故异生性定非不善。故彼唯是无覆无记。此异生性当言欲界系耶。色界系耶。无色界系耶。答应言或欲界系。或色界系。或无色界系。非直语言其义便立。故应问答重显斯义。何故异生性非唯欲界系耶。答欲界没生无色界时欲界法皆舍。得欲界法不成就性。若异生性唯欲界系者。诸异生欲界没生无色界。应非异生。若非异生。则应生彼无退堕者。圣者生上必无退受下地生故。虽欲界没生色界者。亦舍欲界法。而非全舍。彼犹成欲界变化心等故。由此但说生无色界。何故异生性非唯色界系耶。答色界没生无色界时色界法皆舍。得色界法不成就性。若异生性唯色界系者诸异生色界没生无色界应非异生。若非异生猛喜子等不应生下。圣不尔故。虽色界没生欲界者。亦舍色界法。而非全舍。彼犹成色界烦恼等法故。由此但说生无色界。何故异生性非唯无色界系耶。答入正性离生。先现观欲界苦。后合现观色无色界苦圣道起。先办欲界事。后合办色无色界事。是故异生性非唯无色界系。法应如是。若成就此地异生性。必先现观此地苦谛。又圣道起先为对治异生性故作如是说。问若尔。异生性应唯欲界系。答唯欲界系有前过失。故此应言通三界系。此异生性当言见所断耶。修所断耶。答应言修所断。非直语言其义便立。故应问答重显斯义。何故异生性非见所断耶。答见所断法皆染污异生性不染污故。诸染污法随部随品渐渐断之得不成就。诸异生性苦法智忍一时顿舍。随地第九无间道力一时顿断故非染污。又世第一法正灭。苦法智忍正生。尔时舍三界异生性。得彼不成就性。非于尔时见所断法而有舍故。若异生性是见所断。应此位中未舍彼性。则具缚者住苦法智忍时。应成就异生性。见所断法具成就故。住此位者应名为圣亦名异生。便成杂乱。故异生性非见所断。问尔时唯应舍欲界异生性。上二界异生性先不成就故。如何乃说舍三界耶。答应说尔时舍三界中随一异生性。得彼不成就性。而言舍三界异生性者。为满三数故作是说。谓上二界异生性先不成就。今复舍欲界异生性。三数便满故作是说。有说。上二界异生性虽先不成就。今复不成就。故亦说舍。云何先不成就今复不成就耶。谓转远故。有说。欲界异生性能资能引上二界异生性与彼为门为加行故。若舍欲界异生性时亦说舍彼。有说。成就欲界异生性时。色无色界诸异生性。容当现起与彼为依安足处故。若舍欲界异生性时。断彼生路故亦说舍。有说。尔时三界诸异生性得非择灭故作是说。尔时顿得三界九地诸异生性非择灭故以是义故有问言。颇有法一时舍九时断耶。答有。谓异生性一时舍者谓苦法智忍生时。九时断者。谓离欲界乃至非想非非想处染。各于第九无间道时。颇有于异生性已得择灭未得非择灭耶。答应作四句。或有于异生性。已得择灭未得非择灭。谓诸异生已离欲界乃至无所有处染。或有于异生性已得非择灭未得择灭。谓诸圣者未离欲界染。或有于异生性已得择灭及非择灭。谓诸圣者已离欲界乃至非想非非想处染。或有于异生性未得择灭及非择灭。谓诸异生未离欲界染。颇有异生性未断而不成就耶。答应作四句。或有异生性未断而不成就。谓诸异生生欲界未离初静虑染。彼上八地异生性未断而不成就。已离初静虑染。未离第二静虑染。彼上七地异生性未断而不成就。乃至已离无所有处染。彼上一地异生性未断而不成就。若生初静虑。未离第二静虑染。彼上七地异生性未断而不成就。已离第二静虑染。未离第三静虑染。彼上六地异生性未断而不成就。乃至已离无所有处染。彼上一地异生性未断而不成就。乃至若生无所有处。彼上一地异生性未断而不成就。若诸圣者未离欲界染。彼九地异生性未断而不成就。已离欲界染。未离初静虑染。彼上八地异生性未断而不成就。乃至已离无所有处染。未离非想非非想处染。彼上一地异生性未断而不成就。或有异生性成就而非未断。谓诸异生生欲界已离欲界染。彼欲界异生性成就而非未断。乃至生无所有处已离无所有处染。彼无所有处异生性成就而非未断。或有异生性未断亦成就。谓诸异生未离欲界染。彼欲界异生性未断亦成就。乃至生无所有处未离无所有处染。彼无所有处异生性未断亦成就。若生非想非非想处。彼非想非非想处异生性未断亦成就。或有异生性非未断亦非成就。谓诸异生生欲界已离初静虑染。未离第二静虑染。彼初静虑异生性非未断亦非成就。乃至已离无所有处染。彼初静虑乃至无所有处异生性非未断亦非成就。若生初静虑。未离第二静虑染。彼欲界异生性非未断亦非成就。已离第二静虑染。未离第三静虑染。彼欲界第二静虑异生性非未断亦非成就。乃至已离无所有处染。彼欲界第二静虑乃至无所有处异生性非未断亦非成就。乃至若生非想非非想处。彼欲界乃至无所有处异生性非未断亦非成就。若诸圣者已离欲界染。未离初静虑染。彼欲界异生性非未断亦非成就。已离初静虑染。未离第二静虑染。彼欲界初静虑异生性非未断亦非成就。乃至已离非想非非想处染。彼三界九地异生性非未断亦非成就。颇有异生性已断而成就耶。答应作四句。谓前第二句作此初句。前初句作此第二句。前第四句作此第三句。前第三句作此第四句准前所说应知其相。异生性名何法。答三界不染污心不相应行。问何故复作此论。答欲令疑者得决定故。谓前说不得圣法名异生性。或有生疑。不得圣法非实有体。如未得财。欲令此疑得决定故。显异生性是实有法行蕴所摄。故作斯论。有作是说。前虽已显异生性相而未辨体。今欲说之故作斯论。有余师说。前虽已显异生性体。未辨其相。今欲说之故作斯论。或有说者。前显异生性对治。今欲说异生性体故作斯论。言三界者遮异生性唯欲界系。不染污者。遮异生性是染污法及见所断。心不相应者。遮异生性是心所法。行者遮异生性非实有法。假法理非行蕴摄故。此即遮异执显异生性体。尊者妙音说。异生性即众同分。如牛羊等诸众同分。即说名为牛羊等性。如是异生众同分体名异生性。有余师言。别有一法是不染污。心不相应行蕴所摄。如命根等名异生性。为遮彼执前说异生性名不得圣法。不得即是不成就性。问何缘不许即异生众同分。及有别法名异生性。而许圣法不成就性名异生性耶。答异生众同分。非亲违圣法故。别有一法不可知故。非如圣法不成就性。亲违圣法。有相可知名异生性。理善成立诸法邪见相应。彼法邪思惟相应耶。乃至广说。问何故异生性后说邪支耶。答此二展转相扶持故。谓异生性扶持邪支。此邪支复能扶持异生性。复次行者厌异生性及八邪支。而修圣道故。异生性后复分别邪支。诸法邪见相应。彼法邪思惟相应耶。答应作四句。此中邪见一切地有。非一切染污心。有身见等聚中无故。邪思惟一切染污心有。非一切地。静虑中间以上无故。由此相望作大四句。有法邪见相应非邪思惟。谓邪见相应邪思惟。及余邪思惟不相应邪见相应法。此中邪见相应邪思惟者。谓欲界未至定初静虑邪见俱寻。彼唯与邪见相应非邪思惟。自性与自性由三因缘不相应故。一无二思惟俱时起故。二前后思惟不和合故。三诸法自性不自观故。谓待他生不待自性。及余邪思惟不相应邪见相应法者。谓静虑中间乃至有顶邪见相应法。即九大地法。九大烦恼地法。惛沈伺心。有法邪思惟相应非邪见。谓邪思惟相应邪见。及余邪见不相应邪思惟相应法。此中邪思惟相应邪见者。谓欲界未至定初静虑邪见。彼唯与邪思惟相应非邪见。自性与自性由前所说三种因缘不相应故。及余邪见不相应邪思惟相应法者。谓欲界未至定初静虑除邪见聚。取余染污聚中邪思惟相应法。即有身见边执见戒禁取见取疑贪嗔慢不共无明。相应聚中邪思惟相应法。谓十大地法等如理应知。有法邪见相应亦邪思惟。谓除邪见相应邪思惟。及除邪思惟相应邪见。诸余邪见邪思惟相应法。谓欲界未至定初静虑邪见聚中邪见邪思惟相应法。即九大地法。九大烦恼地法。无惭无愧惛沉睡眠伺心。有法非邪见相应亦非邪思惟。谓邪见不相应邪思惟。邪思惟不相应邪见。及诸余心心所法色无为心不相应行。此中邪见不相应邪思惟者。谓欲界未至定初静虑除邪见聚。取余染污聚中邪思惟。彼俱不相应彼聚无邪见故。自性与自性不相应故。邪思惟不相应邪见者。谓静虑中间乃至有顶邪见。彼俱不相应。自性与自性不相应故。彼地无思惟故。及诸余心心所法者。谓静虑中间乃至有顶。除邪见聚。取余染污心心所法并一切善无覆无记。色无为心不相应行者。谓一切色无为心不相应行。如是诸法俱不相应。彼聚无邪见故。彼地无思惟故。不染污故。非相应法故

诸法邪见相应。彼法邪精进相应耶。答应作四句。此中邪见一切地有。非一切染污心邪精进一切地及一切染污心俱有。由此相望作中四句。有法邪见相应非邪精进。谓邪见相应邪精进。此中邪见相应邪精进者。谓邪见聚中懈怠但与邪见相应非邪精进。自性与自性不相应故。有法邪精进相应非邪见。谓邪见及余邪见不相应。邪精进相应法。此中邪见者。谓诸邪见皆与邪精进相应非邪见。彼聚定有邪精进故。自性与自性不相应故。及余邪见不相应邪精进相应法者。谓一切地。除邪见聚。取余染污聚中邪精进相应法。有法邪见相应亦邪精进。谓除邪见相应邪精进。诸余邪见相应法。此中除邪见相应邪精进者。以邪精进体数极多。此中但除与邪见相应者。余无滥故非此所除。诸余邪见相应法者。谓邪见聚中除邪精进及邪见体。取余心心所法彼俱相应。即九大地法。八大烦恼地法。无惭无愧惛沉睡眠寻伺及心。有法非邪见相应亦非邪精进。谓邪见不相应邪精进及诸余心心所法。色无为心不相应行。此中邪见不相应邪精进者。谓有身见等相应邪精进。彼俱不相应。以彼聚中无邪见故。自性与自性不相应故。及诸余心心所法者。谓一切善无覆无记心心所法非有染污。色无为心不相应行者。谓一切色无为心不相应行。如是诸法俱不相应不染污故。非相应法故。如以邪见对邪精进。以邪见对邪念邪定亦尔。此中应作二中四句邪念邪定如邪精进。遍一切地一切染污心皆得有故。如以邪见对邪精进邪念邪定。以邪思惟对邪精进邪念邪定亦尔。此中应作三中四句。以邪思惟不遍一切地。如邪见不遍一切染污心故。诸法邪精进相应。彼法邪念相应耶。答应作四句。此中二法俱遍一切地。一切染污心有。由此相望作小四句。有法邪精进相应非邪念。谓邪念。此中邪念必与邪精进相应非邪念恒俱有故。自性与自性不相应故。有法邪念相应非邪精进。谓邪精进。此中邪精进必与邪念相应。非邪精进恒俱有故。自性与自性不相应故。有法邪精进相应亦邪念。谓邪精进邪念相应法。此中除邪精进及邪念体。取余染污心心所法。即九大地法。八大烦恼地。法十小烦恼地法。无惭无愧。贪嗔慢疑惛沉睡眠恶作怖寻伺及心。如是诸法是染污者。二俱相应恒俱有故。有法非邪精进相应亦非邪念。谓诸余心心所法色无为心不相应行。此中诸余心心所法者。谓一切善无覆无记心心所法。非有染污。余如前说。如以邪精进对邪念。以邪精进对邪定亦尔。如以邪精进对邪念邪定。以邪念对邪定亦尔。此中应作二小四句。皆遍一切地。一切染污心有故。此中不说邪语等三。非相应法故

问此八邪支。几欲界系。几色界系。几无色界系耶。答邪见邪精进邪念邪定通三界系。邪思惟邪语邪业邪命唯欲色界系。色界中唯初静虑。上地无故。有说。色界亦无邪命。彼不为活命起身语业故。评曰。此中前说为善。彼贪所起身语二业名邪命故。问此八邪支。几见所断几修所断耶。答一见所断。谓邪见。三修所断。谓邪语邪业邪命。余四通见修所断。问此杂蕴中何故先说清净法。后说杂染法耶。答为欲显示世第一法士用果故。谓世第一法能引见道。永断邪见。是彼士用果。清净即是世第一法等。杂染即是邪见等八支

说一切有部发智大毗婆沙论卷第四十五阿毗达磨大毗婆沙论卷第四十六

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中不善纳息第一之一

三结乃至九十八随眠。如是章及解章义既领会已。次应广释此三结等。皆是契经所说唯除五结及九十八随眠。此中应除如是二论。所以者何。一切阿毗达磨皆为解释契经。此二论既非契经所说。是故应除。由此尊者妙音作如是说。一切阿毗达磨皆为释经。因如是如是经。作如是如是论。非经说者皆应除之。有说。不应除此二论。所以者何。彼二亦是契经说故。谓于增一阿笈摩。五法中说五结。九十八法中说九十八随眠。时经久远而俱亡失。此本论师以愿智力忆念观察。于此重叙而解释之。有说。此二虽非经说而不应除。问五结既非契经所说。何故不除。答诸论皆随作者意乐。不违法相。欲造便造。谓于此中说遍行结非遍行结遍行非遍行结。说遍行结者如三结。说非遍行结者如五结。说遍行非遍行结者如九结。由此五结虽非经说而不应除。问九十八随眠既非经说何故不除。答阿毗达磨皆为释经七种随眠。是经所说。今作论者广以行相界部差别而分别之。是故此论亦不应除。问何故于此先立章耶。答为欲显示诸门义故。若不立章门。义无由得显。如彩画者不能彩画虚空。复次欲令此论久住世故。谓此论中虽善立蕴纳息章门。而百千众中乃有一人能具诵持况不善立。谁当有能诵持如是杂乱文句无诵持者便速隐没。复次若不立章则空。无所问。必有所依而发问故。问何故论者依经立章。答诸所造论皆为释经。故诸经中所有种种不相似义。今此解释立为杂蕴。乃至见义立为见蕴。然一一蕴具一切义。复次为显契经义无量故。非如外典文多义少或全无义。如逻摩衍拏书有一万二千颂。唯明二事。一明逻伐拏劫私多去。二明逻摩将私多逻。佛经不尔。若文若义无量无边。无量者义难测故。无边者文难知故。譬如大海无量无边。无量者深。无边者广。复次欲显契经堪问难故。非如外典不堪问难。若问难时转增无义。如狝猴子不耐打触。若打触时便失粪秽。佛经不尔。堪任问难。若问难时生净戒色善根妙触。如婆罗痆斯所出叠衣堪耐打触。若打触时发鲜净色及胜妙触。复次欲显契经发则妙故。谓有三事覆则妙。发则不妙。一愚人二女人三外道书论。复有三事发则妙。覆则不妙。一智人二日月三佛法经论。复次欲显契经堪思择故。非如外典不堪思择。若思择时能使有情慧眼损减。如人观日损减眼根。佛法不尔。堪任思择。若思择时慧眼增益。如人观月增长眼根。问何故于此先立章后作问耶。答如造舍法故。如欲造舍先立基址后方结构。如是尊者欲造法舍。如基址法故先立章。如结构法故后作门。复次如种树法故。如欲种树先治其地然后种殖。如是尊者欲种法树。如治地法故先立章。如种殖法故后作门。复次如结鬘法故。如欲结鬘先经其缕然后结花。如是尊者欲结法鬘。如经缕法故先立章。如结花法故后作门。复次如彩画法故。如欲彩画必先作模后填众彩。如是尊者欲画法像。如作摸法故先立章。如填彩法故后作门。复次如刻镂法故。如欲刻镂必先作朴后刻支体。如是尊者欲镂法像。如作朴法故先立章。如刻支体法故后作门。复次如观行法故如瑜伽师先立大种及所造色。后以极微刹那分析。尊者亦尔。如立大种及所造色故先立章。如以极微刹那分析故后作门。复次如佛说法故。如佛说法先摽后释。谓先摽言六界六触处十八意近行及四依处说名有情。后复释言。如是名六界。乃至如是名四依处。尊者亦尔。如先摽法故先立章。如后释法故后作门。复次欲现二种善巧法故。谓先立章。现于义善巧。后作门。现于文善巧。如义善巧文善巧。当知义力文力义无碍解。法无碍解。义无碍解究竟。法无碍解究竟亦尔。复次显己智见无错乱故。谓若智见有错乱者。其所造论亦复错乱。不能立蕴纳息章门。若彼智见无错乱者。其所造论亦不错乱。能善立蕴纳息章门。尊者显己智见无谬故先立章然后作门。问何故立章先依三结。后乃至依九十八随眠耶。答是作论者意欲尔故。谓作论者随己意欲而作此论。不违法相故不应责。胁尊者曰。一切生疑谓若先说三不善根。或乃至先说九十八随眠者。亦皆有疑。何缘立章先依于彼。故但所说不违法相。若先若后俱无有失。复有说者。阿毗达磨应以相求。不应责其先后次第。或有说者。此中亦可随少因缘释其次第。然阿毗达磨义理深广。若复释此便为繁乱。难可受持故不复释。有作是说。此中欲显渐增法故。谓先说三。次四次五。乃至最后说九十八。复次显烦恼树渐增长故。先说三结。乃至后说九十八随眠。有余师说。欲显断彼渐次证得沙门果故。谓三结断。证得初果。是以先说三不善根。欲漏倍断得第二果。即彼尽断得第三果。是故次说。余二漏断得第四果。是故后说。瀑流扼取身系盖等无别断证。皆重显示三漏故说。是故此中先说三结。乃至后说九十八随眠。有三结。谓有身见结戒禁取结疑结。问此三结以何为自性。答以二十一事为自性。谓有身见结三界见苦所断有三事。戒禁取结三界见苦道所断有六事。疑结三界见苦集灭道所断有十二事。此二十一事是三结自性。我物相分自体本性。已说自性。所以今当说。问何故名结。结是何义。答系缚义是结义。合苦义是结义杂毒义是结义。此中系缚义是结义者。谓结即是系。云何知然。如契经说。尊者执大藏。往尊者舍利子所。问言大德。为眼结色色结眼耶。乃至意法为问亦尔。舍利子言。眼不结色。色不结眼。此中欲贪说名能结。乃至意法亦复如是。如黑白牛同一靷系。若有问言。为黑系白。白系黑耶。应正答言。黑不系白。白不系黑。此中有靷说名能系。由此故知结即是系。合苦义是结义者谓欲界结令欲界有情与欲界苦合非乐。色界结令色界有情与色界苦合非乐。无色界结令无色界有情与无色界苦合非乐。杂毒义是结义者。谓胜妙生及有漏定。如无量解脱胜处遍处等。以杂烦恼故圣者厌离如杂毒食。虽复美妙。智者远之。如世尊说。三结永断证预流果。得不堕法定趣菩提。极七反有七生天上七生人中。流转往来作苦边际。问如阿毗达磨说八十八随眠永断证预流果。池喻经说。无量苦断证预流果。何故此说三结永断证预流果耶。答应作是说。此是世尊为所化生有余略说。复次世尊观察所化有情意乐随眠为说法要。意乐者谓善根。随眠者谓烦恼。观察如是意乐随眠。略说法要断彼烦恼。所说称量不少不多。少说不能断彼烦恼。多说于彼则为唐捐。譬如良医观察病者病及病因。授以方药。所授称量不少不多。少则不能除其病苦。多则于彼亦为唐捐。复次所说法要有略有广。略者谓说三结永断证预流果。广者谓说八十八随眠永断。及说无量苦断证预流果。如略说广说诸不分别说分别说总说别说无异说有异说不遍说遍说顿说渐说。当知亦尔。复次为利根者说三结永断证预流果。为钝根者说八十八随眠永断及说无量苦断证预流果。如为利根钝根者说。诸为因力缘力内力外力自思惟力他说法力。开智者说智者说当知亦尔。复次为诱怯弱所化有情。显示易行。如牵手故谓怯弱者怖多所行。为诱进之于多说少。此中应说佛栗氏子于多闻少便奉行喻。谓有苾刍名佛栗氏子。如来在世于佛法出家。是时已制过二百五十学处。于半月夜说别解脱戒经时。闻说自爱诸善男子乐学戒者应如是学。便生怯弱。谁能于此众多学处具足奉行。便诣佛所顶礼双足白言世尊。我今不能守护如是众多学处。请退还家修本俗业。世尊哀愍软言诃摈。复劝谕曰。善哉善哉。佛栗氏子。汝能修学三学处不。谓增上戒学增上心学增上慧学。彼闻数少。欢喜踊跃。即白佛言。我能修学彼学。如是三种学时。便为已学一切学处。如是世尊若说八十八随眠永断。或说无量苦断证预流果者。则所化有情心生怯弱。谁能拔此八十八种大烦恼树。谁能越此八十八种大烦恼河。谁能竭此八十八种大烦恼海。谁能碎此八十八种大烦恼山。谁能修八十八种烦恼对治。由世尊说三结永断证预流果。彼闻数少欢喜踊跃。便勤修学三结对治。断三结时诸见所断皆得永断。同对治故。复次世尊于此说胜事故。谓见所断诸烦恼中三结最胜。是故尊者妙音说曰。于见所断诸烦恼中三结最胜。余皆属此。如因见生贪嗔慢等。复次世尊于此说上首故。谓此三结是见所断烦恼上首。如勇健将常在军前。由此势力诸见所断烦恼生长难可制伏。复次世尊于此说胜功德胜怨敌故。胜功德者谓预流果。胜怨敌者谓此三结。复次佛于此说三三摩地近障法故。谓有身见是空近障。戒禁取是无愿近障。疑是无相近障。复次如是三结近见道者数现行故。如杂蕴说。忍作意持见疑不行设行不觉。烦恼微细觉慧劣故。见谓有身见及戒禁取。疑即是疑。复次由此三结难断难破难可越度。是故偏说。复次由此三结过患增盛坚固众多。是故偏说。谓有身见结是六十二见趣根本。诸见趣是余烦恼根本。余烦恼是业根本。诸业是异熟果根本。依异熟果一切善不善无记法皆得生长。戒禁取结能起种种无义苦行。疑结能使有情疑前际疑后际疑前后际。于内犹豫此为何物。云何此物。谁现有谁当有。如是有情生从何来死往何所。复次如是三结已断已遍知。乃至阿罗汉犹相似转。谓有身见结苦类智忍时已断已遍知。诸阿罗汉犹相似转。谓作是说。我钵我衣我同住我弟子我房舍我资具。于无我中而说有我戒禁取结道类智忍时已断已遍知。诸阿罗汉犹相似转。如洗手足住阿练若。但畜三衣常行乞食。乃至具足受持十二杜多功德。谓得清净。曾闻尊者路摩尚只迦。虽是阿罗汉每日洗浴谓得清净。此类极多。疑结道类智忍时已断已遍知。诸阿罗汉犹相似转。谓阿罗汉远见竖物便生犹豫。杌耶人耶。为男为女。若见二路亦怀疑惑。此是正道非正道耶。见二衣钵亦怀犹豫。是我所有他所有耶。如是一切。复次诸瑜伽师以三结断为其上首。总证一切见所断结诸择灭故。复次诸瑜伽师以三结断为其上首。总觉一切见所断结诸择灭故。复次如是三结是顺下分通三界故。贪欲嗔恚虽是顺下分。而不通三界。边执见邪见见取慢无明等虽通三界。非顺下分故不说断。复次七随眠中诸预流果已永断者。此中说故。谓预流果七随眠中已永断二。谓见及疑。见有二种。谓缘自地他地差别。于中各说一上首者。复次于九结中诸预流果已永断者。此中说故。谓预流果于九结中已断三结。谓见取疑。是故尊者妙音说曰。此经应言永断三结证预流果。谓见取疑。复次十随眠中诸预流果已永断者。此中说故。十随眠者。谓五见。疑贪恚慢痴。预流于此十随眠中已永断六。谓五见疑。此中唯说永断三结不说六者。但说转故。谓此六中有身见是转边执见是随转。戒禁取是转。见取是随转。疑是转。邪见是随转。已说转当知亦说随转。是故但说永断三结。复次此经略现门梯蹬故。谓见所断诸烦恼中。有唯一部有通二部有通四部。若说有身见。当知总说唯一部者。若说戒禁取。当知总说通二部者。虽更无别通二部随眠。而戒禁取则名通二部。或复说彼相应俱有。若说疑。当知总说通四部者。复次见所断结。有是自界遍行。有是他界遍行。若说有身见。当知总说自界遍行。若说戒禁取疑当知总说他界遍行。问何故自界遍行但说一结。他界遍行说二结耶。答他界遍行通有漏缘无漏缘故。若说戒禁取。当知总说有漏缘结。若说疑。当知总说无漏缘结。如自界遍行他界遍行。诸自地遍行他地遍行。当知亦尔。复次见所断结。有是有漏缘。有是无漏缘。若说有身见及戒禁取。当知总说有漏缘结。若说疑当知总说无漏缘结。问何故说二有漏缘结。无漏缘结但说一耶。答有漏缘结有是自界自地缘。有是他界他地缘。若说有身见。当知总说自界自地缘者。若说戒禁取。当知总说他界他地缘者。如有漏缘无漏缘。诸有诤缘无诤缘。世间缘出世间缘。有爱味缘无爱味缘。耽嗜依缘出离依缘。堕界缘不堕界缘。顺结缘不顺结缘。顺取缘不顺取缘。顺缠缘不顺缠缘。当知亦尔。复次见所断结。有有为缘。有无为缘。若说有身见及戒禁取。当知总说有为缘结。若说疑。当知总说无为缘结。有为缘结说二所以如前应知。如有为缘无为缘诸常缘无常缘恒缘非恒缘有变易缘无变易缘当知亦尔。复次见所断结有是见性有非见性。若说有身见及戒禁取。当知总说是见性结。若说疑当知总说非见性结。是见性结说二所以如前应知。如见性非见性诸视性非视性推求性非推求性乐寻觅性非乐寻觅性乐回转性不乐回转性坚执性不坚执性数取境性不数取境性当知亦尔。复次见所断结有是不善有是无记。若说戒禁取疑。当知总说诸不善结。若说有身见当知总说诸无记结。诸不善结说二所以如前应知。如不善无记有异熟无异熟。感二果感一果。无惭无愧相应。无惭无愧不相应。当知亦尔。复次见所断结有欢行相转。有戚行相转。若说有身见及戒禁取当知总说欢行相转者。若说疑当知总说戚行相转者。欢行相转说二所以如前应知。复次如是三结障三净蕴。是故偏说谓有身见障净戒蕴。有说。障净定蕴戒禁取障净定蕴。有说。障净戒蕴疑障净慧蕴。如障三净蕴诸障三学三修三清净当知亦尔。复次如是三结障八支圣道。是故偏说。谓有身见障正语正业正命。有说。障正念正定。戒禁取障正念正定。有说。障正语正业正命。疑障正见正思惟正精进。复次欲令疑者得决定故。说预流果永断三结。谓世间疑。已得圣者。犹执有我。犹执吉凶。犹怀疑惑。故世尊说永断此三。证预流果。以预流果初圣果故

问为初得道故名预流。为初得果故名预流。设尔何失。两俱有过。若初得道故名预流。则第八圣应名预流。第八圣者谓随信行及随法行。从胜数之。是第八故。彼最初得无漏道故。若初得果故名预流。则倍离欲染及全离欲染者。入正性离生至道类智位应名预流。尔时证得四圣果中最初果故。有作是说。以初得道故名预流。问第八圣者应名预流。答若初得道具缘道智乃名预流。第八圣者虽初得道。而未具得缘道智故不名预流。复次若初得道是道类智修道果道所摄道者。乃名预流。第八不尔。复次若初得道具三缘者。乃名预流。一舍已得道。二得未得道。三得结断一味得。舍已得道者。谓舍见道。得未得道者。谓得修道。得结断一味得者。谓得三界见所断结一味断得。第八不尔。复次若初得道具五缘者。乃名预流。一舍已得道。二得未得道三得结断一味得。四顿得八智。五一时修十六行相。第八不尔。复次若初得道已断一切见所断结。无事烦恼忍所断惑见邪性者乃名预流。第八不尔。复次若初得道有相有施设可共谈论者。乃名预流。第八不尔。复次若初得道容死生者乃名预流。第八不尔。有余师说。以初得果故名预流。问倍离欲染及全离欲染者。入正性离生至道类智位应名预流。答若初得果。是渐次非超越。乃名预流。余则不尔。复次若初得果证初解脱。是初得度。住初果者。乃名预流。余则不尔。复次若初得果。先未以世俗道倍离欲染及全离欲染而得果者。乃名预流。余则不尔。复次若初得果。先未以世俗道证欲界法六品断。或九品断而得果者。乃名预流。余则不尔。复次若初得果。是四果中最初果者。乃名预流。余则不尔。复次若初得果。是四向四果中最初果者。乃名预流。余则不尔。复次若初得果。是四双八只补特伽罗中最初果者。乃名预流。余则不尔。复次若初得果地道俱定者。乃名预流。谓一来果地虽定而道不定。有漏无漏道俱能得故。不还果地道俱不定。依六地有漏无漏道皆能得故。阿罗汉果道虽定而地不定。依九地皆能得故。预流果地道俱定。唯依未至定无漏道得故。复有说者。不以初得道故名预流。亦不以初得果故名预流。然以成就预流果故名预流。补特伽罗名依法立。如酥油瓶药水等故。问以何义故。名预流耶。答流谓圣道。预者谓入。彼入圣道故名预流。问一来不还及阿罗汉亦入圣道。应名预流。答若依此义亦不遮彼。然预流果初故受名。余依别德更立异称

问一来不还阿罗汉亦得不堕法。何故唯说预流果得不堕法耶。答亦应说余而不说者。应知此经是有余说。复次诸果各有胜义显义。谓预流果不堕法胜不堕法显。故说不堕。不堕恶趣故。一来果一来法胜一来法显。故说一来。唯一往来故。不还果不还法胜不还法显。故说不还。不还欲界故。阿罗汉果无生法胜无生法显。故说无生。不受后有故。是故预流独说不堕。问异生亦有得不堕法。何故于此不说异生。答应说而不说者。当知此义有余。复次彼不定故。谓诸异生于不堕法有得不得。诸预流者定得不堕。故偏说之

定者谓住正性定聚。诸预流者定般涅槃故说为定。缘已变故。犹如坏器。三层阁上投之于地。未至地顷。虽曰未破。必当破故亦名为破

趣菩提者尽无生智名曰菩提。彼于菩提愿乐忍可。敬重爱欲随顺趣向。临至名趣

极七返有者。谓唯受七有。问应言十四有。或二十八有。若此唯依本有说者。应言十四有。天上人中各七有故。若依本有中有说者。则二十八有。天人各有十四有故。谓七本有及七中有。何故但说极七有耶。答如七叶树不过七故说极七有。谓天与人本有中有各有七故。如余经说。佛转法轮四谛三转十二行相。非唯三转十二行相。应说十二转四十八行相。谓于四谛各有三转十二行相。然一一谛各有三转十二行相。不过三转十二行相故说此言。余经亦说。有七处善及三义观。速于圣法毗奈耶中。能尽诸漏。不应但说有七处善。彼应说有三十五处善或无量处善。不过七故作如是说。谓于五蕴或于余法。一一各有七处善故。此亦如是。又余经说。苾刍我今当说二法。二谓眼色乃至意法。彼不应言二。应说有十二。不过二故说二法言。此亦如是。问何预流唯经七有流转往来不增不减。胁尊者曰。若增若减亦俱生疑。唯受七有不违法相故不应责。复次彼异熟因但有尔所感异熟果势力在故。复次彼业力故能受七有。圣道力故不至第八。如为七步毒蛇所螫。大种力故能行七步。毒势力故不至第八。复次若受八有。彼第八生应无圣道。圣道法尔不依欲界第八身故。彼第八生若无圣道。应见谛已还不见谛。得圣果已还不得果。入现观已还不现观。成圣者已还作异生。勿有斯过。故唯七有。复次若受八有便越三世。过殑伽沙应正等觉法毗奈耶则于如来非内眷属。如过七族不名为亲。复次增上忍时已除欲界人天七生。色无色界处别一生。于诸余生得非择灭。若法已得非择灭者必不现前故唯七有。复次彼于欲界上下七处有受生义。七处谓人及六欲天。于中往来人天相间故受七有。复次欲界九品烦恼势力有差别故彼受七有。复次彼于七有修七觉支得圆满故。唯受七有。复次彼于七有修七依定七种圣道得圆满故。唯受七有。复次彼于七有修七随眠能对治道得圆满故唯受七有不增不减

七生天上七生人中者。此依圆满预流而说故。人天有等受七生。然有预流人天生别。谓或天七人六。或人七天六。或天六人五。或人六天五或天五人四。或人五天四。或天四人三。或人四天三。或天三人二。或人三天二。或天二人一。或人二天一。此中且说极多生者故说预流人天各七。问圆满预流何处满七。为在天上为在人中受第七有般涅槃耶。此中有说。若依此生得预流果即说此生入七有数。彼作是说。若人中得果则天上满七而般涅槃。若天上得果则人中满七而般涅槃。有作是说。若依此生得预流果不说此生入七有数。彼作是说。若人中得果还人中满七而般涅槃。若天上得果还天上满七而般涅槃。应知此中初说非理。以得果生中有全是异生摄故。是则预流唯应说受二十七有。而施设论说。预流者二十八有流转往来作苦边际故。不应说初得果生入七有数。问受七有者前六生中起圣道不。有说不起。若当起者应般涅槃。有说亦起。业力持故不般涅槃。问若满七有无佛出世彼在家得阿罗汉耶。有说不得。彼要出家受余法服得阿罗汉。有说彼在家得阿罗汉已。后必出家受余法服。如是说者。彼法尔成佛弟子相乃得极果。如五百仙人在伊师迦山中修道。本是声闻出无佛世。猕猴为现佛弟子相。彼皆学之证独觉果无学不受外道相故

流转往来者天上寿尽来生人中。人中寿尽往生天上。如富贵者林苑游观。流谓中有转谓本有。作苦边际者是证苦边际义。问此苦边际为在苦中为在苦外。若在苦中应非边际。若在苦外世间现喻当云何通。如世金筹初中后际无不是金。苦之边际亦应是苦。有作是说。苦边际者谓在苦中。即阿罗汉最后诸蕴体。虽是苦非后苦因不生后苦后苦不续名苦边际。有余师说。苦边际者谓在苦外即是涅槃。永出苦故名苦边际。世间现喻不必须通非三藏摄不须释故。世法圣法理各别故

说一切有部发智大毗婆沙论卷第四十六阿毗达磨大毗婆沙论卷第四十七

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中不善纳息第一之二

有三不善根。谓贪不善根。嗔不善根。痴不善根。问此三不善根以何为自性。答以十五事为自性。谓贪嗔不善根各欲界五部为十事。痴不善根欲界四部及见苦所断一分为五事。谓欲界系见集灭道修所断痴全是不善立不善根。见苦所断痴有十种。即五见疑贪嗔慢俱不共无明以为第十。于中八种是不善故立不善根。身边二见相应无明是无记故非不善根。问根是因义身边二见相应无明既是一切不善法因。何故不立不善根耶答若法体是不善能为一切不善法因者立不善根。身边二见相应无明虽是一切不善法因。而体是无记故非不善根。由此三不善根以十五事为自性。已说自性所以今当说。问何故名不善根。不善根是何义。答于诸不善法。能生能养能增能益能摄能持能滋长义。是不善根义。尊者世友作如是说。于诸不善法。为因为种子为转为随转为等起为摄益义是不善根义。大德说曰。于诸不善法。为本为能植为转为随转能摄益义是不善根义。问若不善因义是不善根义。前生不善五蕴与后生未生不善五蕴为因。前生十不善业道与后生未生十不善业道为因。前生不善三十四随眠与后生未生不善三十四随眠为因。如是等不善法皆应立不善根。何故但说三不善根。尊者世友作如是说。此是世尊观所化者宜闻法故有余略说。胁尊者言。佛知诸法性相势用余不能知。若法应立不善根。者则便立之故不应责。尊者妙音作如是说。大师知此贪嗔痴三于诸不善为因势用偏重偏近故立为根。复次不善法中。此三最胜名义胜故偏立为根。复次不善法中。此三难断难破难越故偏立根。复次不善法中。此三过重过多过盛故偏立根。复次此三近障三种善根。是三善根增上怨敌。是故偏立为不善根。复次离欲染时此三极作留难障碍如守狱卒。是故偏立为不善根。复次诸不善法此为上首。犹如猛将在军前行由此势力诸余不善皆得生长故偏立根。复次诸不善法。此三为因为根为导为集为缘为等起为能作为主为本故立为根。因者如种故根者坚牢故导者能引故集者能生故缘者能助故等起者能发生故能作者能长养故主者能摄受故本者能为依故。复次以此三法具五义故立不善根余法不尔。谓此三法通五部遍六识。是随眠性能发粗恶身语业。断善根时为强加行。通五部者。谓通见苦乃至修所断。此简五见及疑。遍六识者谓眼识乃至意识相应。此简慢是随眠性者。谓贪不善根是欲贪随眠性。嗔不善根是嗔恚随眠性痴不善根是无明随眠性。此简诸缠烦恼垢等。能发粗恶身语业者。如契经说。贪嗔痴生一切粗恶身语意业。断善根时为强加行者。如施设论说。诸断善根云何而断。以何行相断。谓如有一是极猛利贪嗔痴类乃至广说。此二俱释不善根义。问增上邪见能断善根。何故不立不善根耶。答断善加行及正断时此三皆胜故立为根。邪见唯于断善时胜非加行位故不立根。谓诸内外染净事业。加行时难。究竟时易。如诸菩萨见老病死逼恼世间。为救济故初发无上正等觉心。由此心故三无数劫。修习百千难行苦行无有留碍常不退转。初菩提心甚为难得。非后尽智无生智时。所修未来三界善法。是故邪见非不善根。复次断善根时此三为转亦为随转故立为根。邪见非转亦非随转故不立根。有作是说。断善根时贪嗔但为转。痴亦为随转故立为根。邪见但为随转非转究竟时易故不立根。复次邪见所以能断善根。应知皆由贪嗔痴力。是故但立贪等为根。谓不善根摧伏善法。令无势力羸劣衰损。然后邪见能断善根。复次先说具五义者立不善根。邪见不尔。谓唯四部意识相应虽是随眠性。而不能发粗恶身语业见所断心于身语业。非近因等起刹那等起故。非断善时为强加行。是故邪见非不善根。由前五义总简诸余不善五蕴。谓不善色蕴五义皆无。不善受想识蕴。及非随眠缠垢相应行蕴虽通五部遍六识能发粗恶身语业。而阙余二义。不善不相应行蕴虽通五部而阙后四义。诸随眠中五见及疑。虽是随眠性而阙余四义。慢虽通五部是随眠性能发粗恶身语业。而阙余二义。十缠中惛沉掉举无惭无愧。虽通五部遍六识能发粗恶身语业。而阙余二义。睡眠虽通五部而阙余四义。忿覆恶作嫉悭。虽亦能发粗恶身语业。而阙余四义。谄诳憍害恨恼。是烦恼等流故名烦恼垢。虽亦能发粗恶身语业。而阙余四义。故皆不立为不善根。复次贪嗔痴三。是业增上根本集故立不善根。如契经说。迦逻摩。当知贪嗔痴三是业根本集。应知此经依增上说。余非增上故不立根。复次贪嗔痴三尽故业尽故立为根。如契经说。贪嗔痴尽故诸业亦随尽。此经亦依增上义说。复次贪嗔痴三展转相引。展转相助故立为根。如契经说。贪能起嗔嗔能起贪无明助二。应知亦从贪嗔而起。复次此于三受多随增故立不善根。余法不尔。如说于乐受贪随增。于苦受嗔随增。于不苦不乐受痴随增。问于一一受一切随增。何故此中作如是说。答从多分故作如是说。谓于乐受贪多随增。于苦受嗔多随增。于不苦不乐受痴多随增。复次贪依乐受而起。以乐受为根本。造多恶行引多苦果。嗔依苦受而起。以苦受为根本。造多恶行引多苦果。痴依不苦不乐受而起。以不苦不乐为根本。造多恶行引多苦果。故作是说。复次此三佛说是违顺故立不善根。余法不尔。谓契经说。诸有情类由违顺力多兴斗诤。如诸天众与阿素洛由违顺力数起斗诤。亦如逻摩逻伐拏等为私多等起诸斗诤。因斯杀害无量有情。当知皆是由违顺力。违者谓嗔贪名为顺。问此中何故不说痴耶。答痴即在此二分中摄。已说违顺则已说痴。若诸有情不愚痴者。为天妙境尚不造恶。况为人间及恶趣境。而兴斗诤造诸恶业。因斯流转受苦无穷。复次略现烦恼梯蹬门故。说不善根唯有三种。谓诸烦恼三品所摄贪品嗔品痴品为三。如契经说。佛告梵志。若诸有情为二十一烦恼染心。虽自执有真实净法得毕竟净。而堕恶趣受下贱身。大德法救于彼经中。摄诸烦恼皆入三品。谓贪嗔痴三品差别说一则说彼品一切。如说贪品嗔品痴品。如是亲品怨品中品。有恩品有怨品无二品。适意品不适意品非二品应知亦尔。复次由三不善根起十恶业道堕十恶处是故偏说。云何三不善根起十恶业道。如契经说。杀生有三种。谓贪嗔痴生乃至邪见应知亦尔。施设论亦说三不善根是十恶业道生长因本。云何由彼堕十恶处。如契经说。杀生业道若习若修若多所作。能令众生当堕地狱傍生鬼界。广说乃至邪见亦尔。施设论亦说杀生业道。若习若修若多所作。最上品者堕无间地狱。次微劣者堕大炎热地狱。次微劣者堕炎热地狱。次微劣者堕大号叫地狱。次微劣者堕号叫地狱。次微劣者堕众合地狱。次微劣者堕黑绳地狱。次微劣者堕等活地狱。次微劣者堕傍生趣。最微劣者堕饿鬼界。广说乃至邪见亦尔。复次若世尊说为内垢者立不善根。余法不尔。如契经说。内垢有三。谓贪嗔痴。如说内垢内怨内嫌内贼亦尔。复次若世尊说有增减者立不善根。余法不尔。如契经说。云何贪增嗔增痴增。云何贪减嗔减痴减。于余烦恼不说增减。是故不立为不善根。复次若说增上退因缘者立不善根。余法不尔。如说苾刍苾刍尼等。若自观见贪嗔痴增。应自了知退诸善法。复次若佛说为烦恼障者立不善根。余法不尔。如说云何名烦恼障。谓有一类贪嗔痴三。数数现行增上猛利。复次若世尊说彼为尘者立不善根。余法不尔。如契经说。尘有三种谓贪嗔痴。如说为尘根栽垢秽热恼毒箭火刺刀毒痈病亦尔。是故立三不善根

问三不善根云何现起。答若心起贪嗔则不起。若心起嗔贪则不起。此二心起决定有痴。所以者何。贪嗔行相更互相违痴不尔故。贪行相欢。嗔行相戚。无明行相俱不相违。复次贪现起时令身增益摄持身故。嗔现起时令身损减毁坏身故。痴于此二俱不相违。复次贪起令身柔软调适。欣乐所缘。若爱前境昼夜观之无厌足故。嗔起令身粗涩刚强。憎背所缘。若憎前境乃至不欲举眼看故。痴于二事俱不相违

三不善根皆通五部亦遍六识。所以者何若不善根唯见所断。则修所断不善应无根而生。若不善根唯修所断则见所断不善应无根而生。故不善根定通五部。若不善根唯在意地。则五识中不善应无根而生。若不善根唯在五识。则意地不善应无根而生。故不善根定遍六识。若贪俱起诸不善心由二根故说名有根。谓贪及彼相应无明。若嗔俱起诸不善心由二根故说名有根。谓嗔及彼相应无明。余惑俱起诸不善心由一根故说名有根。谓唯无明

问多处说根。谓有处说有身见为根。或有处说世尊为根。或有处说欲为根。或有处说不放逸为根。或有处说自性为根。此诸根名义何差别。答说有身见为根者依诸见趣。谓执我我所故六十二见趣生长。说世尊为根者依所说法。谓唯佛能说杂染清净系缚解脱流转还灭等诸妙法门。说欲为根者依集善法。谓要有欲能集诸善。说不放逸为根者依守善法。谓不放逸故能守护诸善。诸放逸者虽有善法而复退坏。说自性为根者依不舍自体。谓一切法以自性为根不失自体。问若尔无为法亦应名有根。答若依此义诸无为法说名有根亦无有过。有说。有处说自性为根者依同类因。谓同类因与后生未生自性类法为同类因故。问苦法智忍及俱起法应名无根。答此虽无同类因而为他同类因。诸无为法则不如是。有作是说。苦法智忍及俱起法虽无同类因。而有相应俱有因故不名无根法。评曰应作是说。此中自体说名自性。无处说因为自性故

有三漏。谓欲漏有漏无明漏问此三漏以何为自性。答以百八事为自性。谓欲漏以欲界四十一事为自性。则贪五嗔五慢五见十二疑四缠十。有漏以色无色界五十二事为自性。即贪十慢十见二十四疑八。无明漏以三界十五事为自性。即欲色无色界各五部无明由此三漏以百八事为自性。品类足说。云何欲漏谓欲界除无明诸余结缚随眠随烦恼缠是名欲漏。云何有漏谓色无色界除无明诸余结缚随眠随烦恼缠是名有漏。云何无明漏谓三界无知是名无明漏。彼言应理若作是说缘三界无知是名无明漏。则应不摄无漏缘无明。问身语恶行为是随烦恼。非随烦恼耶。设尔何失。若是随烦恼此中何故不说。若非随烦恼。识身足论当云何通。如彼说身语恶行是不善非结非缚非随眠是随烦恼非缠应弃应舍应断应遍知能生后苦异熟。有作是说。身语恶行是随烦恼。问若尔此中何故不说。答应说而不说者当知此义有余。复次若法是随烦恼亦是缠者此中说之。身语恶行虽是随烦恼而非缠故此中不说。复有说者。身语恶行非随烦恼。问识身足论当云何通。答识身足论应作是说。身语恶行是不善非结非缚非随眠非随烦恼非缠。乃至广说。而彼论说是随眠烦恼者以身语恶行为随烦恼所扰恼故亦名随烦恼。问若尔彼亦为结所系乃至为缠所缠亦应名结乃至名缠。答理亦应然而不说者应知彼是有余之说。复次彼论为现异闻异说。由异说故义则易解。复次彼论为现二门二略二阶二蹬二炬二明二文二影。由斯门等二义俱通。如彼自性非结等故名非结等。亦非随烦恼自性故应名非随烦恼。如彼为随烦恼所扰恼故名随烦恼。亦为结所系乃至缠所缠故应名为结乃至名缠。彼但为现二门等故。各彰一说二义俱通是故三漏以百八事为其自性。已说自性所以今当说问何故名漏。漏是何义。答留住义淹贮义流派义禁持义魅惑义醉乱义是漏义。留住义是漏义者。谁令有情留住欲界色无色界。所谓诸漏。淹贮义是漏义者。如湿器中淹贮种子便能生芽。如是有情烦恼器中淹贮业种能生后有。流派义是漏义者如泉出水乳房出乳。如是有情从六处门诸漏流派。禁持义是漏义者。如人为他所禁持故不能随意游适四方。如是有情为诸烦恼所禁持故循环诸界诸趣诸生。不得自在趣涅槃界。[魅-未+勿]惑义是漏义者。如人为鬼之所[魅-未+勿]惑。不应说而说不应作而作不应思而思。如是有情为诸烦恼所[魅-未+勿]惑故起身语意三种恶行。醉乱义是漏义者。如人多饮根茎枝叶花果等酒即便醉乱。不了应作不应作事无惭无愧颠倒放逸。如是有情饮烦恼酒不了应作不应作事无惭无愧颠倒放逸。声论者说阿萨腊缚者。萨腊缚是流义。阿是分齐义。如言天雨阿波吒梨。或施财食阿旃荼罗阿言显此乃至彼义。如是烦恼流转有情乃至有顶故名为漏

问若留住义是漏义者。诸业亦有留住功能。如契经说。二因二缘留诸有情久住生死。谓烦恼业。由烦恼业为种子故生死难断难破难灭。有人八岁或十岁时断烦恼尽得阿罗汉。但由业力仍住生死。或九十岁有至百年。何故唯说烦恼为漏不说业耶。答应说而不说者当知此义有余。复次业不定故谓或有业留诸有情久住生死。或复有业令诸有情对治生死烦恼。不尔故独名漏复次业以烦恼为根本故。谓定无有不断烦恼而舍诸业。是故唯说烦恼为漏复次业由烦恼势力引故但说烦恼是漏非业。有烦恼尽而寿住者亦由烦恼余势力故。如以泥团掷壁虽干而不堕者应知此是湿时余力。复次烦恼尽故而般涅槃非由业尽故业非漏。诸阿罗汉业积如山后蕴不续般涅槃故。问何故欲界诸烦恼等除无明立欲漏。色无色界诸烦恼除无明立有漏。三界无明立无明漏耶。答先作是说留住义是漏义。欲界有情所以住欲界者由彼期心于欲。喜乐于欲钦羡于欲希望于欲思求于欲寻访于欲耽湎于欲。是故欲界烦恼等除无明立欲漏。色无色界有情所以住色无色界者。由彼期心于有。喜乐于有钦羡于有希望于有思求于有寻访于有耽湎于有。是故色无色界烦恼除无明立有漏。三界有情所以期心欲有。乃至耽湎欲有而住三界者皆由无知之力。是故三界无明立无明漏。复次欲界有情虽亦求有而多求欲。是故欲界烦恼等除无明立欲漏。色无色界有情全不求欲但求于有。有作是说。虽亦求欲而多求有。是故色无色界烦恼除无明立有漏。三界有情所以多求欲及有者由无知力。是故三界无明立无明漏。复次若界有成有坏是界所生烦恼等除无明立欲漏。若界有成无坏是界所生烦恼除无明立有漏。三静虑地虽亦有成有坏而第四静虑及无色界有成无坏故从多说。若界有成有坏及界有成无坏。有情住者由无知力。是故三界无明立无明漏。有余但释立有漏因。谓住于此有求彼有。若住于彼无求此有。故彼烦恼除无明立有漏。譬喻论师但立二漏。谓无明漏及有爱漏。二际缘起之根本故。谓无明是前际缘起根本。有爱是后际缘起根本。问彼云何释经三漏耶。答彼说有爱有二种。谓有不善有无记。有有异熟有无异熟。有感二果有感一果。有无惭无愧相应。有无惭无愧不相应诸不善有异熟感二果。无惭无愧相应者立欲漏。由此爱故欲界余烦恼等除无明亦名欲漏。诸无记无异熟感一果。无惭无愧不相应者立有漏。由此爱故色无色界余烦恼除无明亦名有漏。问何故由爱余烦恼等除无明名欲漏及有漏耶。答以爱难断难破难越过重过多过盛。能令界别地别部别。由爱势力生诸烦恼。乃至广说爱之过患。是故由爱余烦恼等得二漏名。问何故三界无明别立无明漏耶。胁尊者曰。佛知诸法性相势用无有错谬。若法堪任独立漏者便独立漏。若不堪任独立漏者便共立漏故不应责。复次前已说漏是留住义。无余烦恼留诸有情久住生死如无明者。故独立漏。尊者妙音作如是说。佛知无明留诸有情久住生死。势力速疾尤重亲近过余烦恼。故独立漏。复次因无明故于所知境有爱恚痴故独立漏。复次由无明故令诸有情不知前际不知后际不知前后际。不知内不知外不知内外。不知业不知果不知业果。不知善行不知恶行。不知因不知从因生法。不知佛法僧宝。不知苦集灭道不知善不善法。不知有罪无罪。不知应修不应修。不知胜劣不知黑白。于总别缘起缘生诸法及六触处。无实智见有黑闇痴。是故独立无明为漏。复次无明难离有大过患故独立漏。贪虽难离而无大过患。嗔虽有大过患而非难离。慢等俱无故共立漏。复次经说无明为诸恶首故独立漏。如说无明为上首为前相故。生无量种恶不善法。复于其中无惭无愧。复次无明自体尤重作业尤重故独立漏。自体尤重者。谓与一切烦恼相应亦有不共。作业尤重者。谓共一切烦恼作业亦独作业。余烦恼等则不如是。复次经说。无明为恶趣本故独立漏。如说

  诸此世他世　　颠坠恶趣者
  皆无明为本　　亦贪欲为因

复次经说。无明名为浪耆故独立漏。如契经说。苾刍当知真实浪耆即无明是。谓有毒虫名为浪耆自身既盲生子亦盲彼若螫他亦令他盲。无明亦尔。自既盲暗令相应法亦成盲暗。若在有情相续中起亦令盲暗。复次无明在三界缘一界生愚。谓无色界四蕴在九地缘一地生愚。谓非想非非想处四蕴有九品缘一品生愚。谓非想非非想处下下品四蕴故独立漏。问余他界地遍行随眠应如无明各独立漏。答无明偏多故独立漏。谓有九种他界地缘遍行无明。即邪见等七种相应及二不共。邪见见取疑但有二。戒取唯一故不应难。复次无明是诸烦恼上首周普遍行故独立漏。上首者。谓无明覆故于四圣谛不乐不忍昏迷不了。如饥饿人先遇粗食饱餐啖已。于后虽得种种肴馔而不甘乐。如是有情无明粗食久蕴心中。后时虽遇四谛美食而不甘乐。由不乐故便生犹豫。谓此是苦为非苦耶。乃至是道为非道耶。如是无明引生犹豫一切犹豫能引决定。若遇正说得正决定。便知有苦乃至有道。若遇邪说得邪决定便谓无苦乃至无道。如是犹豫引生邪见。彼作是念。若无四谛决定有我及有我所。如是邪见引生身见。复作是念。此我我所为断为常。若见所执相似相续便谓为常即是常见。若见所执变坏不续便谓为断即是断见。如是身见引生边见。彼于三见随计一种能得清净解脱出离即是戒取。如是边见引生戒取。复作是念。如是三见既得清净解脱出离便为最胜即是见取。如是戒取引生见取。彼爱自见憎恚他见。于自他见称量起慢。如是无明于引随眠最为上首。由随眠故引起十缠。谓忿嫉缠是嗔等流。覆缠有说是贪等流。有余师说。是痴等流应作是说。是二等流。或贪名利覆藏自罪。或由无知覆藏罪故。惛沉睡眠及无愧缠是痴等流。掉举与悭及无惭缠是贪等流。恶作缠是疑等流。随眠亦引六烦恼垢。谓害恨垢是嗔等流。恼垢是见取等流。诳憍垢是贪等流。谄垢是五见等流。如是无明复为上首引生缠垢。周普者从无间狱乃至有顶皆可得故。又异生位见位修位皆成就故。又于诸法自相共相皆迷起故。遍行者非以无明一刹那起。能缘五部为五部因五部随增说名遍行。但由无明遍一切处同类起故说名遍行。谓与遍行随眠俱起即名遍行。与不遍行随眠俱起名不遍行。自界他界自地他地有漏无漏缘有为无为缘亦如是说。与诸烦恼俱起和合。如团中腻如麻中油故名遍行。由此无明具上三义故独立漏。如契经说。彼由非理作意起故。欲漏有漏无明漏。未生者便生已生者倍复增广。问有尔所烦恼生。还尔所烦恼灭。一刹那后必不住故。云何而说三漏生已倍增广耶。答依下中上渐增说故。谓下品生已为中品缘。中品生已为上品缘。故作是说。复次依等无间缘说倍复增广。谓下品烦恼生已。与中品为等无间缘。中品烦恼生已。与上品为等无间缘。故作是说。复次依同类遍行因说倍复增广。谓下品烦恼生已与中品为二因。中品烦恼生已与上品为二因。故作是说。复次依取果与果说倍复增广。谓下品烦恼生已能取能与中品果。中品烦恼生已能取能与上品果。故作是说。尊者世友作如是说。非烦恼多说倍增广。依彼生已不复还堕未生位中。故作是说。复次依彼生已不复还堕未来世中。故作是说。复次依数数生故作是说。谓一烦恼生已复起非理作意。不依对治便生第二。复生第三乃至百千故作是说。复次依渐猛利故作是说。谓下烦恼生已复起非理作意。不依对治便生中品复生上品展转增盛。故作是说。复次依随境转故作是说。谓随缘一色等境界烦恼生已。由彼复起非理作意不依对治更缘声等生诸烦恼。故作是说。大德说曰。依一有中缠多行故说倍增广。谓具缚者从无间狱乃至有顶烦恼皆等自地烦恼无增减故。然有现行不现行者。若起非理作意不依对治便数现行。若起如理作意依对治者便不现行。故作是说

如契经说。漏有七种为害热恼。谓或有漏是见所断乃至广说。问胜义漏有三种。谓欲漏有漏无明漏。何故于此说七漏耶。答此中漏具亦说漏声。如诸经中于彼彼具亦说彼彼如前广说。胁尊者曰。佛说法已有异所化来至会中。如来怜愍以别文句复说七漏令彼得解。复次佛说三漏利根已解。为钝根者复说七漏。如利钝根因力缘力内力外力内思惟力外闻法力。开智说智应知亦尔尊者望满作如是说。佛此中说二胜义漏。谓见所断及修所断见所断漏以自名说。修所断漏依对治说。彼对治有二种。谓伏对治及断对治。于中前五依伏对治。最后一种依断对治。故说七漏

如契经说。正知见彼得阿罗汉果时从欲有无明漏心得解脱。问离欲界染时从欲漏心得解脱。离有顶染时从有漏无明漏心得解脱。佛何故说正知见彼得阿罗汉果时从欲等三漏心得解脱。答此中于已解脱亦说今解脱声。此即于近以远声说。如说今者从何所来。又如余处已断说断已入说入已受说受。此亦如是。复次依欲有漏双究竟灭故作是说。复次依证三漏一味断得故作是说。复次依集漏断故作是说。复次依灭作证故作是说。如说得阿罗汉果时九十八随眠灭作证。复次依得无学治彼法智故作是说。复次依得无学离彼系性故作是说。复次依相续断故作是说。谓无始来数断欲漏二漏续起今断二漏无复相续。复次依断彼缘故作是说。谓无始来二漏与彼作三种缘。今断二漏彼缘永断。复次依厌对治故作是说。谓彼证得第四果时总厌三漏我无始来为彼诳惑心不解脱。今得解脱深生厌离。问尔时五蕴皆得解脱。何故但说心解脱耶。答心于五蕴最胜故说。谓若说胜亦已说余如王得脱眷属亦尔。复次以心为首总说五蕴皆得解脱。复次以依心故名心所法。以心大故名大地法故但说心。复次修他心智无间道时但缘心故作如是说。心诸胜事如余广说

说一切有部发智大毗婆沙论卷第四十七阿毗达磨大毗婆沙论卷第四十八

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中不善纳息第一之三

有四瀑流。谓欲瀑流有瀑流见瀑流无明瀑流。问此四瀑流以何为自性。答以百八事为自性。谓欲瀑流以欲界二十九事为自性。即贪五嗔五慢五疑四缠十。有瀑流以色无色界二十八事为自性。即贪十慢十疑八。见瀑流以三界三十六事为自性。即欲色无色界各十二见。无明瀑流以三界十五事为自性。即欲色无色界各五部无明。由此四瀑流以百八事为自性。已说自性所以今当说。问何故名瀑流瀑流是何义。答漂激义腾注义坠溺义是瀑流义。漂激义是瀑流义者。谓诸烦恼等漂激有情令于诸界诸趣诸生生死流转。腾注义是瀑流义者。谓诸烦恼等腾注有情令于诸界诸趣诸生生死流转。坠溺义是瀑流义者。谓诸烦恼等坠溺有情令于诸界诸趣诸生生死流转。问若坠溺等义是瀑流义者。顺上分结应非瀑流。彼令有情趣上生故。答顺上分义异瀑流义。谓依界地立顺上分结。彼令有情趣上界地故。依解脱道立为瀑流。虽生有顶而令有情沉没生死。不至解脱及圣道故。尊者妙音亦作是说。虽久生上而为瀑流之所漂溺退善品故。尊者左受作如是说。此中增上数行烦恼如瀑流故说名瀑流。问何故别立见为瀑流。轭取而不别立为见漏耶。胁尊者言。佛知诸法性相势用。若法堪任别建立者则别立之。若不尔者便总建立。复次诸见轻躁行相猛利于留住义不随顺故。与余迟钝烦恼合立为欲有漏。与漂激等义相随顺是故别立瀑流。轭取如一车等驾以二牛性俱躁急车等必坏。若彼二牛一迟一疾互相制御便无所损。故不别立见为见漏。复次见性躁动顺离染法不顺留住。是故与余迟钝烦恼合立为漏。于漂激等其义相顺故别立为瀑流轭取。问若见躁动顺离染法不应立为瀑流轭取以瀑流等顺沉溺故。答为呵外道着诸见故别立诸见为瀑流等。谓诸外道随起见趣邪推求境。便于生死转复沉溺无有出期。譬如老象陷溺淤泥随动其身转复沉溺。分别论者说有四漏。谓欲漏有漏见漏无明漏。于彼论宗不须问答

有四轭。谓欲轭有轭见轭无明轭。此轭自性如瀑流说而义有异。谓漂溺义是瀑流义。和合义是轭义。谓诸有情为四瀑流所漂溺已。复为四轭和命系碍便能荷担生死重苦如牵捶牛置之辕轭勒以鞦鞅能挽重载。故一切处说瀑流已即便说轭义相邻故。有四取。谓欲取见取戒禁取我语取问此四取以何为自性。答以百八事为自性。谓欲取以欲界三十四事为自性。即贪五嗔五慢五无明五疑四缠十。见取以三界三十事为自性。即欲色无色界见各有十。戒禁取以三界六事为自性。即欲色无色界戒禁取各二。我语取以色无色界三十八事为自性。即贪十慢十无明十疑八。由此四取以百八事为自性。已说自性所以今当说问何故名取。答以三事故说名为取。一执持故。二收采故。三选择故。又以二事故名为取。一能炽然业。二行相猛利。能炽然业者。取令五趣有情业火恒炽然故。行相猛利者。诸取行相极勇捷故。问取是何义。答薪义是取义。如缘薪故火得炽然。有情亦尔。烦恼为缘业得炽盛。复次缠裹义是取义。如蚕作茧自缠自裹。乃至于中而自取死。有情亦尔起诸烦恼自缠自裹而于其中伤失慧命。展转乃至堕诸恶趣。复次伤害义是取义。如利毒刺数刺其身身便损坏。有情亦尔。烦恼毒刺数刺法身法身便坏。问何故无明别立漏。瀑流轭而不别立取耶。胁尊者言。佛知诸法性相势用。若于此中堪别立者则别立之。若不尔者便总揵立故不应责。复次前说以三事故名取。谓执持收采选择。无明虽有前二而无第三故不别立取。以无明愚暗不能选择法故。复次前说以二事故名取。谓能炽然业及行相猛利。无明虽能炽然业而非行相猛利故不别立取以无明迟钝不能决了法故问何故五见中四见合立为见取。一见别立为戒禁取耶。胁尊者言。佛知诸法性相势用。若于见中堪别立者则别立之。若不尔者便总建立故不应责。复次前说以二事故名取。谓能炽然业及行相猛利。五趣有情由戒禁取炽然诸业等余四见故别立取。尊者妙音作如是说。五趣有情由戒禁取炽然诸业势用速疾尤重亲近。过余四见故别立取。复次以戒禁取违逆圣道远离解脱故别立取。违逆圣道者。由戒禁取舍真圣道。妄计种种非理苦行能得清净。如断饮食卧灰卧杵面随日转服气服水。或唯啖果。或但食菜。或着弊衣或全露体。执如是等能得清净。远离解脱者。如如修行苦行邪道如是如是远离解脱。复次以戒禁取欺诳内外二道故别立取。欺诳内道者。如执洗净受持十二杜多功德能证清净。欺诳外道者。如执种种即前所说非理苦行能得清净。尊者妙音亦作是说。此戒禁取现见生苦如炎炽火。欺诳二道如惑婴儿故别立取。问何故名我语取。为以行相。为以所缘。若以行相萨迦耶见应名我语取我行相转故。若以所缘诸法无我如何可说我语取耶。答不以行相不以所缘名我语取。有前失故然欲界烦恼除见立欲取。色无色界烦恼除见立我语取。问何故尔耶。答欲界烦恼依淫欲转依境界转依众具转依他身转故立欲取。色无色界烦恼与彼相违依内起故立我语取。复次欲界烦恼感内身时。须淫欲须境界须众具须第二故立欲取。色无色界烦恼感内身时。与彼相违故立我语取。复次欲界烦恼感内身时。唯依非定多因外门外事故立欲取。色无色界烦恼感自身时。唯依于定多因内门内事故立我语取。复次欲界烦恼不能感得广大身形长久寿量故立欲取。色无色界烦恼能感得广大身形。如色究竟天身长万六千踰缮那。亦能感得长久寿量。如非想非非想处寿八万大劫。故彼烦恼立我语取。问何故欲漏瀑流轭取亦摄诸缠有漏等中全不摄彼。有作是说。有漏乃至我语取中亦摄诸缠。品类足说。云何有漏谓色无色界除无明诸余结缚随眠随烦恼缠。是名有漏。有瀑流轭及我语取亦应摄缠。应作是说。上界缠少不自在故不说为有漏。乃至我语取欲界虽多而见所断不具足故不自在故但总说十缠不别说五部。问诸烦恼垢何故不说为漏等耶。有作是说。彼亦说在欲漏等中。品类足说。云何欲漏。谓欲界除无明诸余结缚随眠随烦恼缠。是名欲漏乃至广说。随烦恼者即烦恼垢。应作是说。烦恼垢粗不坚住故不说漏等。不信懈怠放逸亦由过轻微故不说漏等。如契经说。如是四取无明为因无明为集是无明类从无明生。问余经皆说爱为取缘此经何故作如是说。答依近因故说爱为取缘。依远因故说无明为取因等。如近因远因在此在彼现前不现前此众同分余众同分应知亦尔。复次依同类因故说爱为取缘。依同类遍行因故说无明为取因等。复次为破外道虚妄僻执故说无明为取因等。谓诸外道虽舍居家。无取无积勤修苦行。而由无智着诸见趣。堕险恶道无有出期。故说无明为取因等。问爱即摄在欲取等中何故乃说爱为取缘。答即贪随眠初起名爱。后增名取故不相违。复次即贪随眠下品名爱。中上名取故不相违

有四身系。谓贪欲身系嗔恚身系戒禁取身系。此实执身系。问此四身系以何为自性。答以二十八事为自性。谓贪欲嗔恚身系各欲界五部为十事。戒禁取身系三界各二部为六事。此实执身系三界各四部为十二事。由此四身系以二十八事为自性。已说自性所以今当说。问何故名身系。身系是何义。答缚身义结生义是身系义。缚身义是身系义者。谓此四种于生死中缚有情身等缚遍缚。如集异门说。贪欲身系未断未遍知故。于彼彼身彼彼形彼彼所得。自体为因为缘为缚为等缚为遍缚为结相续。如结鬘师或彼弟子。取种种花集置一处。以缕结作种种花鬘。缕与花鬘为因为缘为缚为等缚为遍缚为结相续。余三身系广说亦尔。结生义是身系义者。如契经说。三事合故得入母胎。一者父母俱有染心。二者其母无病值时。三者健达缚正现在前。尔时健达缚爱恚二心展转现在前方得结生故。结生义是身系义。问若缚身等义是身系义者。余烦恼等亦有此义何故不立为身系耶。有作是说。此是世尊观所化者有余略说。胁尊者言。佛知诸法性相势用。若法堪任立身系者则便立之。若不尔者则不建立故不应责。尊者妙音作如是说。佛知此四缚有情身等缚遍缚势用速疾尤重亲近过余烦恼。是故偏立。复次此四身系缚二部身过余烦恼。是故偏立。谓初二身系缚在家者身过余烦恼。后二身系缚出家者身过余烦恼。如在家出家有室宅无室宅。有摄受无摄受。有积聚无积聚。有眷属无眷属。无远离有远离应知亦尔。复次此四身系缚三界身过余烦恼。是故偏立。谓初二身系缚欲界身过余烦恼。后二身系缚色无色界身过余烦恼。复次此四身系起二诤根过余烦恼。是故偏立。谓初二身系起爱诤根。后二身系起见诤根。如契经说。执瓶持杖梵志诣大迦多衍那所作是问言。何因何缘刹帝利与刹帝利诤。婆罗门与婆罗门诤吠舍与吠舍诤。戍达罗与戍达罗诤。尊者答言。彼由贪嗔爱诤根故互兴斗诤。梵志复言。何因何缘诸出家者无有室宅摄受积聚面相斗诤。尊者答言。彼由戒禁取及此实执见诤根故互兴斗诤。如二诤根。二边二箭二戏诤二我执应知亦尔。复有说者。此中现门现略现入故但说四。谓诸烦恼或唯见所断。或通见修所断。若说后二身系。当知总说唯见所断者。若说初二身系。当知总说通见修所断者。复次诸烦恼或是遍行或非遍行。若说后二身系。当知总说是遍行者。若说初二身系。当知总说非遍行者。复次诸烦恼或是见性或非见性。若说后二身系。当知总说是见性者。若说初二身系。当知总说非见性者。复次诸烦恼或唯异生现行。或通异生圣者现行。若说后二身系。当知总说唯异生现行者。若说初二身系。当知总说通异生圣者现行者。复次诸烦恼或欢行相转。或戚行相转。若说嗔恚身系。当知总说戚行相转者。若说余三身系。当知总说欢行相转者。复次诸烦恼或唯欲界系。或通三界系。若说初二身系。当知总说唯欲界系者。若说后二身系当知总说通三界系者。故为现门现略现入。契经但说四种身系

有五盖。谓贪欲盖嗔恚盖惛沉睡眠盖掉举恶作盖疑盖。问此五盖以何为自性。答以欲界三十事为自性。谓贪欲嗔恚各欲界五部为十事。惛沉掉举各三界五部通不善无记。唯不善者立盖为十事。睡眠唯欲界五部通善不善无记。唯不善者立盖为五事。恶作唯欲界修所断通善不善。唯不善者立盖为一事。疑通三界四部通不善无记唯不善者立盖为四事。由此五盖以欲界三十事为自性。问盖有何相。尊者世友作如是说自性即相。相即自性。以一切法自性与相不相离故。复次耽求诸欲是贪欲相。憎恚有情是嗔恚相。身心沉没是惛沈相。身心躁动是掉举相。令心昧略是睡眠相。令心变悔是恶作相。令心行相犹豫不决是疑相。已说盖自性及相。所以今当说。问何故名盖。盖是何义。答障义覆义破义坏义堕义卧义是盖义。此中障义是盖义者。谓障圣道及障圣道加行善根故名为盖。覆义乃至卧义是盖义者。如契经说。有五大树种子虽小。而枝体大覆余小树。令枝体等破坏堕卧不生花果。云何为五。一名建折那。二名劫臂怛罗。三名阿湿缚健陀。四名邬昙跋罗。五名诺瞿陀。如是有情欲界心树。为此五盖之所覆故。破坏堕卧不能生长七觉支花四沙门果故。覆等义是盖义。问若障圣道及障圣道加行善根是盖义者。余烦恼等亦有此义。世尊何故不说盖耶。有作是说。此是世尊为所化者有余略说。胁尊者言。佛知诸法性相势用有盖相者便立为盖。无盖相者则不立之故不应责。尊者妙音作如是说。佛知此五能障圣道及障圣道加行善根。势用捷速尤重亲近过所余法故偏立盖。复次如是五盖因时果时俱能为障故偏立盖。因时为障者。此五随一现在前时。心尚不能起有漏善无记。何况圣道。果时为障者。由此五盖堕诸恶趣。便总障碍一切功德

复次如是五盖欲界有情多数现起行相微细。余烦恼等则不如是。故偏立盖。谓慢见等欲界有情起者甚少。如地狱等岂能起慢我所受苦胜他苦耶傍生趣中如虾蟆等。愚痴闇劣岂能发起诸恶见趣。是故尊者妙音说曰。诸余烦恼虽障圣道。而此五种数数现行行相微细是故偏立。复次此五障定及障定果。胜余烦恼故偏立盖。复次此五能障三界离染九遍知道四沙门果。胜余烦恼故偏立盖复次贪欲令远离诸欲法。嗔恚令远离诸恶法。惛沉睡眠令远毗钵舍那。掉举恶作令远奢摩他。彼由远此离诸欲恶法及毗钵舍那奢摩他故。便为疑箭恼坏其心。为有诸恶不善业果。为非有邪。因斯造作种种恶业。是故偏立此五为盖。复次贪欲嗔恚破坏戒蕴。惛沉睡眠破坏慧蕴。掉举恶作破坏定蕴。彼由破坏此三蕴故。便为疑箭恼坏其心。为有诸恶不善业果为非有邪。因斯造作种种恶业。是故偏立此五为盖。复次贪欲嗔恚障碍戒蕴。惛沉睡眠障碍慧蕴。掉举恶作障碍定蕴。彼由障碍此三蕴故。便为疑箭恼坏其心。为有诸恶不善业果。为非有邪。因斯造作种种恶业。是故偏立此五为盖如说破坏障碍三蕴。破坏障碍三学三修三净亦尔。复有说者。此中现门现略现入。是故但立此五为盖。谓烦恼等或唯一部。或通四部。或通五部。若说恶作当知总说唯一部者。若说疑盖当知总说通四部者。若说余盖当知总说通五部者。复次诸烦恼等或唯见所断。或唯修所断或通见修所断。若说疑盖当知总说唯见所断者。若说恶作当知总说唯修所断者。若说余盖当知总说通见修所断者。复次诸烦恼等或是随眠或非随眠。若说贪欲嗔恚疑盖。当知总说是随眠者。若说惛沉睡眠掉举恶作。当知总说非随眠者。复次诸烦恼等或是遍行。或非遍行或通二种。若说疑盖当知总说是遍行者。若说贪欲嗔恚恶作。当知总说非遍行者。若说惛沉掉举睡眠。当知总说通二种者。复次诸烦恼等或唯异生现行。或通异生圣者现行。若说疑恶作盖。当知总说唯异生现行者。若说余盖当知总说通异生圣者现行者。复次诸烦恼等或欢行相转。或戚行相转或通二种。若说贪欲当知总说欢行相转者。若说嗔恚恶作疑盖。当知总说戚行相转者。若说惛沉睡眠掉举。当知总说通二种者。故为现门现略现入。契经但立此五为盖。问盖名有五体有几耶。答体有七种。谓贪欲盖名体俱一。嗔恚疑盖应知亦尔。惛沉睡眠盖名一体二。掉举恶作盖应知亦尔。如名对体。名施设对体施设。名异相对体异相。名异性对体异性。名分别对体分别。名觉慧对体觉慧。应知亦尔。问何故贪欲嗔恚疑一一别立盖。惛沉睡眠掉举恶作二二合立盖耶。胁尊者言。佛知诸法性相势用。若法堪任别立盖者则别立之。若不尔者便共立盖故不应责。复次若是随眠亦缠性者各别立盖。若是缠性非随眠者二共立盖复次若是圆满烦恼性者各别立盖。若非圆满烦恼性者二共立盖。结缚随眠随烦恼缠五义具足者名圆满烦恼。复次以三事故名共立盖。谓一食故。一对治故。等荷担故。此中一食一对治者。谓贪欲盖以净妙相为食。不净观为对治。由此一食一对治故别立一盖。嗔恚盖以可憎相为食。慈观为对治。由此一食一对治故别立一盖。疑盖以三世相为食。缘起观为对治。由此一食一对治故别立一盖。惛沉睡眠盖以五法为食。一瞢愦。二不乐。三频欠。四食不平性。五心羸劣性。以毗钵舍那为对治。由此同食同对治故共立一盖。掉举恶作盖以四法为食。一亲里寻。二国土寻。三不死寻。四念昔乐事。以奢摩他为对治。由此同食同对治故共立一盖。等荷担者。贪欲嗔恚疑一一能荷一盖重担故别立盖。惛沉睡眠二二能荷一盖重担故共立盖。如城邑中一人能办一所作者则令别办。若二能办一所作者则令共办。又如椽梁强者用一弱者用二此亦如是。问何缘五盖次第如是。答如是次第于文于说俱随顺故。复次如是次第授者受者俱随顺故。复次五盖如是次第生故。世尊如是次第而说。是故尊者世友说曰。得可爱境便生贪欲。失可爱境次生嗔恚。失此境已心便羸弱。次生惛沈。由惛沈故心便愦闷。次生睡眠。从彼觉已次生掉举。既掉举已次生恶作。从恶作后复引生疑。由此五盖次第如是。问佛说五盖差别有十。云何分五为十盖耶。答以三事故分五为十。一内外故。二自体故。三善恶故。内外者。谓有贪欲盖缘内而起。有贪欲盖缘外而起故成二盖。有嗔恚盖是嗔自体。有嗔恚盖是嗔因缘故成二盖。自体者。谓有惛沈盖。有睡眠盖。有掉举盖。有恶作盖。二分成四。善恶者。谓疑于善恶分成二盖故。由三事分五为十。此十一一能障通慧菩提涅槃故名为盖。问七随眠中慢无明见。世尊何故不立盖耶。答慢非盖者能隐覆心故名为盖。慢能策心令心高举故不立盖。无明所以不立盖者等荷担故说名为盖。无明隐覆行相转故。荷担偏重不顺等义故不立。在此盖类中见非盖者能灭慧故说名为盖。见即是慧不可自性还灭自性故慧非盖。问因论生论盖能总灭有为善法。何故但说盖灭慧耶。答以慧胜故但说灭慧。即总说灭有为善法胜尚能灭。况余劣者。如人能伏千人敌者。诸余劣者岂不能伏。问色无色界诸烦恼等何故非盖。答彼无盖相故不立盖。复次盖能障碍三界离染四沙门果九遍知道。色无色界诸烦恼等无如是能故不立盖。复次盖能障碍定及定果。色无色界诸烦恼等无如是能故不立盖。复次盖能障碍三道三根三种律仪三种菩提三慧三蕴三学三修三净。色无色界诸烦恼等。无如是能故不立盖。三道者。谓见道修道无学道。三根者。谓未知当知根已知根具知根。三种律仪者。谓别解脱律仪。静虑律仪。无漏律仪。三种菩提者。谓声闻菩提。独觉菩提。无上菩提。三慧者。谓闻所成慧。思所成慧。修所成慧。三蕴者。谓戒蕴定蕴慧蕴。三学三修三净亦尔。复次盖唯不善。色无色界诸烦恼等皆是无记。故不立盖。问因论生论。何故唯立不善为盖非无记耶。答障善法聚故名为盖。由此盖者唯是不善。如契经说善法聚者。谓四念住近障此者。谓恶法聚。恶法聚者。即是五盖。尊者妙音亦作是说。虽诸烦恼障圣道故皆应名盖。而为有情深厌离故唯说不善。问无惭无愧既唯不善遍与一切不善心俱何故非盖。有作是说。此是世尊为受化者有余略说。胁尊者言。佛知诸法性相势用。若法堪任立为盖者则便立之。若不尔者不立为盖故不应责。尊者世友作如是说。无惭无愧虽与一切不善心俱唯是不善。而造恶时无羞无耻于所造恶多诸巧便。于障覆义不显了故不立为盖。尊者妙音亦作是说。无惭无愧虽于所作不善业中势用增上。而于障覆义不显了故不立盖。尊者佛陀提婆说曰。无惭无愧虽障戒蕴。而彼势用不及贪嗔。虽障定蕴而彼势用不及掉举及以恶作。虽障慧蕴而彼势用不及惛沈及以睡眠故不立盖。问嫉悭二结何故非盖。答亦应名盖而不说者。当知此是有余之说。有作是说。此是世尊为受化者简略而说。胁尊者言。佛知诸法性相势用。堪立盖者则便立之。若不尔者不立为盖故不应责。尊者世友作如是言。嫉悭二种恼乱二趣。及与出家在家二众故立为结。然于障覆义不增强故不立盖。尊者妙音亦作是说。嫉悭二结盖义不显故不立盖。尊者觉天作如是说。嫉悭二结障戒定慧势用不及贪欲盖等故不立盖。问忿覆二缠何故非盖。答亦应名盖而不说者。当知此是有余之说。有作是说。此是如来为所度生简略之说。胁尊者言。佛知诸法性相势用堪立盖者则便立之。不堪立者便不立盖故不应责。尊者世友作如是说。忿覆二缠于障覆心义不显了故不立盖。尊者妙音亦作是说。忿覆二缠于障覆义非增上故不立为盖。尊者觉天作如是说。忿覆二缠障戒蕴等势用。不及贪欲盖等故不立盖。西方诸师作如是说。忿覆二种无别体故不别立盖。问六烦恼垢何故非盖。答亦应名盖而不说者。当知此是有余之说。有作是说。此是如来为所度生简略之说。胁尊者言。佛知诸法性相势用堪立盖者则便立之。不堪立者便不立盖故不应责。尊者世友作如是言。六烦恼垢行相粗动不顺盖义故不立盖。尊者妙音亦作是说。六烦恼垢不顺盖相故不立盖。微细数行是盖相故。尊者觉天作如是说。六烦恼垢障戒定慧势用。不及贪欲盖等故不立盖。如契经说。无明盖所覆爱结所系缚愚智。俱感得如是有识身。问无明能覆亦能缚爱结能缚亦能覆。何故但说无明所覆爱结缚耶。答俱应说二而不说者。应知彼是有余之说。复次欲令所说义易解故。以种种语种种文说。复次彼经欲现二门二略二阶二蹬二明二炬二文二影。如说。无明所覆爱结亦应尔。如说。爱结所缚无明亦应尔。欲现二门乃至二影互相显照故作是说。复次先作是说。覆是盖义无余烦恼覆障慧眼如无明者。是故但说无明所覆。缚是结义无余烦恼系缚有情流转生死如爱结者。是故但言爱结所缚。诸有情类无明所盲爱结所缚不能趣入究竟涅槃。此中应说二狂贼喻。昔有二贼恒在崄路。若捉得人一坌其眼。一缚手足。彼人既盲复被系缚不能逃避有情亦尔。无明所盲。爱结所缚。不能趣入究竟涅槃。流转生死恒受苦恼。尊者妙音亦作是说。无明所盲。爱结所缚。便容造作恶不善业。复次依增上义故作是说。谓无明覆用增上。爱结缚用增上。复次依多分义故作是说。谓无明多分能覆爱结多分能缚

说一切有部发智大毗婆沙论卷第四十八阿毗达磨大毗婆沙论卷第四十九

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中不善纳息第一之四

有五结。谓贪结嗔结慢结嫉结悭结。问此五结以何为自性答以三十七事为自性。谓贪结慢结各三界五部为三十事嗔结欲界五部为五事。嫉结悭结各欲界修所断为二事。由此五结以三十七事为自性。已说自性所以今当说。问何故名结。结是何义。答系缚义合苦义杂毒义是结义。此广如上三结中说。问何故但立此为结耶。答亦应说余而不说者。当知此是有余之说。有作是说。此是世尊为所化者简略而说胁尊者言。佛知诸法性相势用。堪立结者则建立之。不堪立者便不建立故不应责。尊者世友作如是说。此中但说迷色等事自相烦恼系心为结。贪嗔慢三唯是迷事自相烦恼故立为结。五见及疑唯是迷理共相烦恼。无明虽复通迷理事。而多迷理故不立结。嫉悭二缠亦但迷事恼乱。二部及二趣故过患多故亦立为结。余缠及垢无如是事故不立结尊者妙音亦作是说。此五于事结心过重故立为结。尊者觉天作如是说。此五于事数数现行恼乱自他过患尤重故立为结。余烦恼等无如是事故不立结。有五顺下分结。谓贪欲顺下分结。嗔恚顺下分结有身见顺不分结。戒禁取顺下分结。疑顺下分结。问此五顺下分结以何为自性。答以三十一事为自性。谓贪欲嗔恚顺下分结。各欲界五部为十事。有身见顺下分结三界见苦所断为三事。戒禁取顺下分结三界各见苦道所断为六事。疑顺下分结三界各四部为十二事。由此五顺下分结以三十一事为自性。已说自性所以今当说。问何故名顺下分结。顺下分结是何义耶。答如是五结下界现行下界所断结。下界生取。下界等流异熟果故。名顺下分结。下界者。谓欲界。问若尔一切烦恼皆是下界现行。身在欲界一切烦恼皆容起故。六十四随眠是下界所断欲界三十六。非想非非想处二十八。唯在欲界方能断故三十六随眠结下界生。欲界三十六随眠一一现在前皆令欲界生相续故三十四随眠能取下界等流异熟果。欲界三十四随眠是不善能为异熟因故。二随眠唯能取下界等流果。欲界有身见边执见。是无记故不能取异熟果。如是一切烦恼皆应名顺下分结。世尊何故唯说此五名顺下分结非余烦恼耶。答亦应说余而不说者。当知此是有余之说。有作是说。此是世尊为所化者简略而说。胁尊者言。佛知诸法性相势用。若法堪立顺下分结则建立之。若不堪者便不建立故不应责。尊者妙音作如是说。佛知此五下界现行。下界所断结下界生取。下界果。势用捷速尤重亲近过余烦恼。故偏立为顺下分结。复次下有二种。谓界下有情下界下者。谓欲界。有情下者。谓异生。由初二结过患重故不越欲界。由后三结过患重故不越异生。故唯立此五为顺下分结。复次下有二种。谓地下有情下。地下。谓欲界。有情下。谓异生。由初二结过患重故不出下地。由后三结过患重故不出下有情故。但说此五名顺下分结。复次此五于彼欲界有情。犹如狱卒及防逻者。故偏立为顺下分结。谓初二结犹如狱卒。后之三结如防逻者。如有罪人禁在牢狱。有二狱卒恒守御之不令辄出。复有三人常为防逻。彼人设以亲友财力伤害狱卒走出远去。三防逻者还执将来闭置牢狱。此中牢狱即喻欲界。罪人即喻愚夫异生。二狱卒者喻初二结。三防逻人喻后三结。若有异生以不净观伤害贪欲。复以慈观伤害嗔恚离欲。乃至无所有处。生初静虑乃至有顶。彼有身见戒禁取疑还执将来置在欲界。尊者妙音亦作是说。二结未断未遍知故不出欲界。三结未断未遍知故。还生欲界故。偏说此五名顺下分结。尊者左受亦作是说。二所缚故不越欲界。三未断故还堕欲界。故偏立此五为顺下分结。复次此中现门现略现入故。偏说此五名顺下分结。谓诸烦恼或唯一部或通二部。或通四部或通五部。若说有身见。当知总说唯一部者。若说戒禁取。当知总说通二部者若说疑。当知总说通四部者。若说贪欲嗔恚。当知总说通五部者。如是唯见所断。通见修所断。是遍行非遍行。唯异生现行。通异生圣者现行。欢行相转戚行相转。应知亦尔。复次通见修所断诸烦恼中。唯有贪嗔独立遍六识。唯见所断诸烦恼中。唯身见等三为转为上首故。偏立此五为顺下分结。复次若问何故初二结立顺下分。应如不善根中广答。若问何故后三结立顺下分应如三结中广答。由此二问答总遮余烦恼问何故随烦恼非顺下分结。答彼亦应是顺下分结而不说者。当知有余有作是说。此是世尊为所化者简略之说复有说者。若令下界及下有情生相续者立顺下分。诸随烦恼不能结生故不立为顺下分结

如契经说。汝等应受持我前所显五顺下分结。尔时会中摩洛迦子即从座起偏袒一肩右膝着地。向薄伽梵曲躬合掌白言。世尊。我已受持世尊所说五顺下分。世尊告曰。云何受持。彼言。贪欲即是欲贪随眠缠心是顺下分。世尊已显我已受持。乃至疑结广说亦尔。佛言。痴人外道异学闻汝所说当诃诘汝。如病婴儿仰卧床上。彼尚不了色等欲尘况能现起贪欲缠心。然彼犹有欲贪随眠。乃至疑结广说亦尔。问如佛所说五顺下分彼具受持宁被诃责。答诃所取义非所取名。诃所解义非所解名。遮所说义不遮其名。谓彼具寿说起烦恼名顺下分非不起者。佛说烦恼若未断时名顺下分不必现起。复次彼说烦恼要现行时名顺下分。佛说成就亦得名为顺下分结。复次彼说烦恼要现在时名顺下分。佛说三世皆得名为顺下分结。复次彼说烦恼要缠心时名顺下分佛说若缠若随眠位皆得名为顺下分结。如说贪欲缠及随眠不正善断时名顺下分结。乃至疑结广说亦尔。有五顺上分结。谓色贪顺上分结无色贪顺上分结。掉举顺上分结。慢顺上分结。无明顺上分结。问此五顺上分结以何为自性。答以八事为自性谓色贪即色界修所断爱为一事。无色贪即无色界修所断爱为一事。掉举慢无明即色无色界各修所断掉举慢无明为六事。由此五顺上分结以八事为自性。已说自性所以今当说。问何故名顺上分结。顺上分结是何义答令趣上义。令向上义。令上生相续义。是顺上分结义。问若趣上等义是顺上分结义者。顺上分结应非瀑流。坠溺等是瀑流义故。答瀑流义异顺上分义。谓依界地立顺上分。彼令有情趣上生故。依解脱道立为瀑流。虽生有顶而令有情沉没生死不至解脱及圣道故。问何故色界无色界贪各别立为顺上分结。余三二界合立一耶。答余三亦应依界别立。而不尔者当知有余。复次欲令所说义易解故以种种语种种文说。复次世尊欲现二门二略二阶二蹬二明二炬二文二影。如爱依界别立二结。掉举慢无明亦应各立二。如掉举等二界合立爱亦应尔。如是便应顺上分结。或八或四为现二门乃至二影互相显照故作是说。复次爱令界别地别部别爱能增长一切烦恼。爱有爱处所说多过故依界别立为二结。掉举等三无如是事故。上二界合立为一。问何故唯修所断立为顺上分结。答令趣上生名顺上分。见所断结亦令堕下故不立为顺上分结。复次上人所行名顺上分。上人是圣非诸异生。见所断结唯异生起故不立为顺上分结。于圣者中唯不还者所起诸结立顺上分。问因论生论何故预流及一来者所起诸结非顺上分。答顺上分者。谓趣上生预流一来所起诸结亦令生下故不立为顺上分结。复次若越度界亦得果者彼所起结立顺上分。预流一来虽复得果非越度界故。彼所起非顺上分。复次若越度界亦断不善烦恼尽者。所起诸结立顺上分。顺流一来二事俱阙故。所起结非顺上分。复次若越度界顺下分结亦断尽者。彼所起结名顺上分。预流一来二事俱阙故。所起结非顺上分。复次顺上分结与顺下分所依各异。若身中起顺上分结彼必不起顺下分结。若身中起顺下分结彼必不起顺上分结。预流一来身中容起顺下分结故。必不起顺上分结。复次若不复起似异生业。彼所起结立顺上分。预流一来犹复现起似异生业故所起结非顺上分。云何彼起似异生业。谓乐着杂彩涂饰香花受畜金银珍玩宝物驱役作使犹行捶罚。亦与男女同处一床摩触尸骸。生细滑想。又无惭耻行非梵行。此等名为似异生业。复次若有不复生于血滴。增羯吒私。入于母胎生熟二藏中间住者彼所起结名顺上分。预流一来容有此事故。所起结非顺上分。如彼契经说。质怛罗居士告诸亲友。汝等当知。我定不复生于血滴增羯吒私。入于母胎生熟二藏中间止住。我已永断五顺下分不复还退受欲界生。尊者妙音亦作是说。解脱贪欲嗔恚结者。我说解脱入母胎事。问顺上分中。掉举自性为是结不。设尔何失。若是结者。品类足说当云何通。如说云何结法。谓九结。云何非结法。谓除九结诸余法。若非结者此经所说当云何通。如说。云何五顺上分结。谓色贪无色贪掉举慢无明。答应言是结。问品类足说当云何通。答外国诸师所诵异此。谓彼诵言云何结法。谓九结及顺上分结中掉举。云何非结法。谓除九结及顺上分结中掉举诸余法。问迦湿弥罗国诸师何故不如彼诵。答此亦应如彼诵而不诵者有别意趣。以彼掉举是结非结不决定故。谓掉举性少分是结。即上二界者。少分非结即欲界者。或有是结即圣所起者。或有非结即异生起者。有位是结即已离欲染圣者所起。有位非结即未离欲染圣者所起。问何故掉举上二界者是结。欲界者非结耶。答以欲界非定界。非修地。非离染地。无胜定慧。能觉掉举为扰乱事故不立结。色无色界是定界。是修地。是离染地。有胜定慧。能觉掉举为扰乱事故立为结。如近村邑虽发大声亦不为患。阿练若处虽发小声亦以为患。复次欲界多有非法烦恼。如忿恨等覆障掉举令不明了故不立结。色无色界无多如此非法烦恼覆障掉举。彼明了故立之为结。如近村邑恶行苾刍虽多不觉。阿练若处恶行苾刍虽少易觉。问惛沉掉举俱通三界。俱遍六识。俱通五部。并与一切染污心俱。何缘掉举立顺上分。非惛沈耶。答以彼掉举为过猛利过重过多故佛立为顺上分结。亦由此故立十烦恼大地法中。又由此故外国所诵品类足说云何结法。谓九结及顺上分结中掉举。又由此故杂蕴已说云何不共无明随眠云何不共掉举缠。又由此故施设论说异生欲贪随眠起时有五法起。一欲贪随眠。二欲贪随眠。随生有诵欲贪随眠增益。三无明随眠。四无明随眠。随生有诵无明随眠增益。五掉举。惛沈不尔故不立为顺上分结。复次以掉举缠行相明利所作捷速。扰乱五支四支定慧故。佛立为顺上分结惛沈行相闇昧迟钝与定相似能随顺定故惛沈者能速发定故不立为顺上分结。复次惛沈既是无明等流。无明复是顺上分结。覆障惛沈令不明了。是故惛沈非顺上分。问上界亦有谄诳憍三。何不立为顺上分结。答诸烦恼垢粗动易息系缚用劣。故不立在诸结聚中即由此义。胁尊者言。佛知诸法性相势用。堪立结者便立为结。若不尔者则不立之故不应责。尊者妙音亦作是说谄诳憍等粗动易息。不顺结义故不立结。一切随眠缠中少分可立为结

有五见。谓有身见边执见邪见见取戒禁取。问此五见以何为自性。答以三十六事为自性谓有身见边执见各三界见苦所断为六事。邪见见取各三界四部为二十四事戒禁取三界各见苦道所断为六事。由此五见以三十六事为自性。已说自性所以今当说。问何故名见。见是何义答以四事故名见。一彻视故。二推度故。三坚执故。四深入所缘故。彻视故者。谓能彻视故名为见。问此见既邪又是颠倒云何名视。答虽邪颠倒而性是慧能见所缘故亦名视。如人见境若明若昧俱名视故。推度故者。谓能推度故名为见。问一刹那顷如何推度。答性猛利故亦能推度。坚执故者。谓能坚执故名为见。此见于境僻执坚牢非圣慧刀无由令舍。佛佛弟子执圣慧刀截彼见芽方令舍故。如有海兽名室首魔罗。彼所啮物非刀不能解。谓彼若啮诸草木等要截其芽方令舍故。如有颂言

  愚人所受持　　鳣鱼所衔物
  室首魔罗啮　　非刀不能解

深入所缘故者。谓性猛利深入所缘。如针堕泥故名为见。复次以二事故名见。一观视故。二决度故。复次以三事故名见。一有见相故。二成所作故。三于境无碍故。复次以三事故名见。一意乐故。二执着故。三推究故。复次以三事故名见。一意乐故。二加行故。三无知故。意乐故者。谓意乐坏者。加行故者。谓加行坏者。无知故者。谓俱坏者。复次意乐故者。谓邪修定者。加行故者。谓邪推求者。无知故者。谓邪闻法者

已释诸见总义。一一别义今当释。问何故名有身见。答此见于有身转故名有身见。问余见亦有于有身转。彼应名有身见。答此见于自身转非他身。于有身转非无身故名有身见。余见于自身转或于他身转。于有身转。或于无身转故不名有身见。于自身转者。谓自界地缘。于他身转者。谓他界地缘。于有身转者。谓有漏缘或有为缘。于无身转者。谓无漏缘或无为缘。问边执见亦于自身转非他身。于有身转非无身。彼应名有身见答义虽俱有而初得名。后所立名更随余义。谓彼别执断常二边故。随此义名边执见。复次此见于有身转执我我所故名有身见。余见虽亦有于有身转。而不执我我所故。不名有身见。复次此见于有身转作我我所行相故。名有身见。余见虽亦有于有身转而不作我我所行相故。不名有身见。复次此见于有身转计我作我受故。名有身见。余见虽亦有于有身转而不计我作我受故。不名有身见。复次此见于有身转顺施戒修故名有身见。余见虽亦有于有身转。而不顺施戒修故。不名有身见。复次此见于有身转不违业果故。名有身见。余见虽亦有于有身转。而违业果故不名有身见。尊者世友作如是说。此见但于自身转故名有身见。即五取蕴名为自身。问何缘取蕴名自身耶。答自因缘力之所作故。自业烦恼所得果故。对边执见问答如前。问何故名边执见。答此见执二边故名边执见。谓于断常二边转故。如契经说。迦多衍那若以正慧如实知见世间集者。则于世间不执为无执为无者。即是断见。谓彼若见后身生时便作是念。如是有情死此生彼必定非断。若以正慧如实知见世间灭者。不执为有执为有者。即是常见。谓彼若见诸蕴界处别别相续便作是念。如是有情有生有灭必定非常复次此见所执极边鄙故名边执见。谓诸外道执有实我已为愚猥。况复执我为断为常而非边鄙。复次此见所执极边远故名边执见。谓诸外道执有实我。于无我理已为边远。况复执我为断为常而非边远。复次此执二边行相转故名边执见。谓执断常二行相转。如契经说。苾刍当知。我不与世间诤。而世间与我诤。问此经所说其义云何。尊者世友作如是说。世尊定说有因果故。谓佛若遇常见外道彼说诸法有果无因。以无因。故自性常有。世尊告曰。汝言有果我亦说有。汝言无因是愚痴论。世尊若遇断见外道彼说诸法有因无果。以无果故当来断灭。世尊告曰。汝言有因我亦说有。汝言无果是愚痴论。佛于二论各许一边离断离常而说中道。故作是说。我不与世间诤。而世间与我诤。复次世尊是如法论者。诸外道等是非法论者。如法论者法尔无诤。非法论者法尔有诤。复次佛于世俗随顺世间彼于胜义不随顺佛。复次世尊善断二诤根故。二诤根者。谓爱及见。佛已永断故说无诤。世间未断故说有诤。大德说曰。世尊是如理论者。诸外道等是非理论者。如理论者法尔无诤。非理论者法尔有诤如马涉险步有低昂。若游平路行无差逸。复次佛是见义见法见善见调柔者故说无诤。世间不尔故说有诤。问何故名邪见。答邪推度故说名邪见。问若尔五见皆邪推度。何独说此为邪见耶。答依别行相立此名故。别行相者。谓无行相。若不依此而立名者。则应五种皆名邪见。五见皆是邪推度故。然无行相过患尤重故。唯依此立邪见名复次若邪推度亦坏事者说名邪见。所余四见虽邪推度而不坏事故别立名。复次若邪推度谤因果者说名邪见。所余四见虽邪推度不谤因果故别立名。复次若邪推度与施戒修极相违者说名邪见。余见不尔故别立名。复次若邪推度亦谤过去未来现在正等菩提三宝归者说名邪见。余见不尔故别立名。复次若邪推度坏二恩者说名邪见。余见不尔故别立名二恩者。谓法恩生恩。坏法恩者。谓无施与。无爱乐。无祠祀无妙行。无恶行。无妙恶行业果异熟。无此世。无他世。坏生恩者。谓无父无母。无化生有情世间。无有真阿罗汉正至正行。乃至广说。复次若邪推度起二怨者说名邪见。余见不尔故别立名。起二怨者。一起法怨。二起生怨。起法怨者。谓言无施与乃至广说。起生怨者。谓言无父母乃至广说。复次若邪推度坏现量者说名邪见。余见不尔故别立名。如人陷坠炽火坑中。为诳世间言我受乐。邪见有情亦复如是。居种种苦蕴界处中邪见缠心言我无苦。如是说者。名坏现量。复次若邪推度名暴恶者说名邪见。如契经说苾刍当知。诸邪见者随彼见力所有身业语业思求愿行。及彼种类一切能招不可爱不可喜不可乐不可意果。所以者何。彼邪见是暴恶见故。所余四见虽邪推度而非暴恶故别立名。问何故名见取。答此取诸见故名见取。问此通取五取蕴。何故但名见取耶。答此因诸见通取五蕴故但名见取。复次以何相故立见取名。谓若取见或取余蕴执最胜者立见取名。复次此应名见等取。略去等言但名见取。复次此多取见故名见取。问何故名戒禁取。答此取诸戒禁故名戒禁取。问此通取五取蕴。何故但名戒禁取耶。答此因戒禁通取五蕴故。但名戒禁取。复次以行相故名戒禁取。谓取戒禁或取余蕴执能净者名戒禁取。复次此见应名戒禁等取。略去等言故。但名戒禁取。复次此多取戒禁故。名戒禁取。问何故二见俱名为取。答由此二见取行相转故俱名取。谓有身见执我我所边执见执断常。邪见执无。取此诸见以为最胜故名见取。取诸戒禁能得净故名戒禁取。复次前之三见推度所缘势用猛利故名为见。后之二见执受能缘势用猛利故名为取

有六爱身。谓眼触所生爱身。耳鼻舌身意触所生爱身。如是爱身应说一种。如九结中三界诸爱总立爱结。或应说二。如七随眠中欲界爱立欲贪随眠。色无色界爱立有贪随眠。或应说三。如契经说。苾刍当知。三爱河者。即三界爱。或应说四。如契经说。有诸苾刍苾刍尼等。因衣服因饮食因卧具因有无有爱生时生住时住着时着。或应说五。谓见苦集灭道及修所断爱。或应说九。谓上上品乃至下下品爱。或应说十八。如十八爱行。或应说三十六。如三十六爱行。或应说百八。如百八爱行。若以在身刹那分别有无量爱。问世尊何故广一爱等。略无量爱等说六爱身耶。答约所依故。谓从一爱至无量爱。无不皆依六根六门六阶六蹬六迹六路六众而出六识相应故但说六。问嗔恚无明亦依六根广说乃至六识相应。世尊何故说六爱身不说六嗔恚六无明身耶。答应说而不说者。当知此义有余。复次已说爱身当知则亦说嗔恚无明身所依等故。复次爱通三界独行遍六识故说为身。嗔恚虽亦独行遍六识。而不通三界无明虽亦通三界。而非独行遍六识故不说为身。复次爱通三界独行遍六识。异生圣者俱得现行故说为身。嗔恚虽亦独行遍六识。异生圣者俱得现行。而不通三界。无明虽亦通三界。异生圣者俱得现行而非独行遍六识故不说为身。复次爱能分别诸界诸地诸部亦能生长一切烦恼故立为身。嗔恚无明无如是事故不说为身。问何故名身。答多爱积集故名为身。谓非一刹那眼触所生爱名眼触所生爱身。要多刹那眼触所生爱乃名眼触所生爱身乃至意触所生爱身亦尔。如独一象不名象军。要多象集乃名象军。马军步军应知亦尔。是故多爱方名爱身问有身见等亦多积集应名为身。何独说爱。答有身见等亦应名身。而不说者是有余说。复次有身见等唯在意地不在五识故不名身。问无惭无愧惛沉掉举亦通六识何不名身。答亦应名身而不说者。当知此是有余之说。复次前说通三界独行遍六识者说之为身。惛沉掉举虽通三界而非独行遍六识故不得名身。无惭无愧二义俱阙故不名身。复次随眠微细势用增强可名为身。缠垢粗动势用羸劣故不名身。复次前说爱能分别诸界诸地诸部故说为身。有身见等无如是义尚不名身。何况缠垢

说一切有部发智大毗婆沙论卷第四十九阿毗达磨大毗婆沙论卷第五十

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中不善纳息第一之五

有七随眼。谓欲贪随眠嗔恚随眠有贪随眠慢随眠无明随眠见随眠疑随眠。问此七随眠以何为自性。答以九十八事为自性。谓欲贪嗔恚随眠各欲界五部为十事。有贪随眠色无色界各五部为十事。慢无明随眠各三界五部为三十事。见随眠三界各十二为三十六事。疑随眠三界各四部为十二事。由此七随眠以九十八事为自性。已说自性所以今当说。问何故名随眠。随眠是何义答微细义随增义随缚义是随眠义。微细义是随眠义者。欲贪等七行相微细。如七极微成一细色。随增义是随眠义者。欲贪等七普于一切微细有漏皆悉随增。乃至一极微。或一刹那顷欲贪等七皆随增故。随缚义是随眠义者。如空行影水行随故。空行谓鸟。水行谓鱼。鸟以翅力欲度大海。水中有鱼善取其相而作是念。无有飞鸟能过大海。唯除勇迅妙翅鸟王。即逐其影鸟乏堕水鱼便吞之。如是随眠于一切位恒现起得非理作意。若现前时即受等流或异熟果复次微细义是随眠义者。依自性说随增义是随眠义者。依作用说。随缚义是随眠义者。依彼得说。复次微细义是随眠义者。依自性说。随增义是随眠义者。依相续说。随缚义是随眠义者。依习气坚牢说。复次微细义是随眠义者。依过去随眠说。随增义是随眠义者。依现在随眠说。随缚义是随眠义者。依未来随眠说。复次微细义是随眠义者。依行相说。随增义是随眠义者。依所缘缚说。随缚义是随眠义者。依相应缚说。复次微细义随增义是随眠义者。依相应随眠说。随缚义是随眠义者。依不相应随眠说。问随眠皆与心等相应。如何言依不相应说。答此中于得立随眠名得随眠故。说名随眠。外国诸师作如是说。由四种义故名随眠。谓微细义随入义随增义随缚义。是随眠义。微细义是随眠义者。谓欲贪等自性行相俱极微细。随入义是随眠义者。谓欲贪等随入相续无不周遍。如油在麻腻在团中无不周遍。随增义是随眠义者。谓欲贪等于相续中展转随增。如孩乳母。随缚义是随眠义者。如空行影水行随逐。复次微细义是随眠义者。依自性说。随入义是随眠义者。依相应说。随增义是随眠义者。依行相说。随缚义是随眠义者。依彼得说应以三事知诸随眠。一以自性故。二以果故。三以补特伽罗故。以自性故者。欲贪随眠如食兴蕖嗔恚随眠如食辛辣。有爱随眠如乳母衣。慢随眠如憍傲人。无明随眠如盲瞽者。见随眠如失道者。疑随眠如临岐路。以果故者。欲贪随眠若习若修若多所作。当生鸽雀鸳鸯等中。嗔恚随眠若习若修若多所作当生蜂蝎毒蛇等中。有贪随眠若习若修若多所作当生色无色界。慢随眠若习若修若多所作当生卑贱种族。无明随眠若习若修若多所作当生愚盲种族。见随眠若习若修若多所作当生外道种族。疑随眠若习若修若多所作当生边鄙种族。以补特伽罗故者。欲贪随眠如难陀等。嗔恚随眠如气嘘指鬘等。有贪随眠如遏玺多阿逻荼嗢达洛迦等。慢随眠如傲士等。无明随眠如邬卢频螺婆迦叶波等。见随眠如善星等。疑随眠如摩洛迦子等。问嫉悭何故不立随眠。答彼二无有随眠相故。复次随眠微细彼二粗动。复次随眠轻微彼二尤重。复次随眠猛利彼二数行。复次随眠是根本烦恼彼二是烦恼等流。谓嫉是嗔恚等流。悭是欲贪等流。复次随眠习气坚固如于此地烧担山木火灭虽久其地犹热。彼二习气不坚固。如于此地烧草桦皮。火才灭已其地便冷。复次随眠难伏。彼二易伏。是故彼二不立随眠。余缠及垢准二应说

有九结。谓爱结恚结慢结无明结见结取结疑结嫉结悭结。问此九结以何为自性。答以百事为自性。谓爱慢无明结。各三界五部为四十五事。恚结唯欲界五部为五事。见结有十八事。谓有身见边执见各三界见苦所断为六事。邪见三界各四部为十二事。取结有十八事。谓见取三界各四部为十二事。戒禁取三界各见苦道所断为六事。疑结三界各四部为十二事。嫉悭结各欲界修所断为二事。由此九结以百事为自性。已说自性所以今当说。问何故名结。结是何义。答系缚义合苦义杂毒义是结义。所余广释如三结处已释。诸结总义一一自性今当广说。云何爱结。谓三界贪。然三界贪于九结中总立爱结。七随眠中立二随眠。谓欲界贪名欲贪随眠。色无色界贪名有贪随眠。于余经中立为三爱。谓欲爱色爱无色爱。问此三何别。答世尊所化根有三品。为利根者说一爱结。为中根者说二随眠。为钝根者说三界爱。复次世尊所化修有三种。为初习业者说一爱结。为已熟修者说二随眠。为超作意者说三界爱。复次世尊所化乐有三种。为乐略者说一爱结。为乐广者说三界爱。为乐略广者说二随眠。复次合苦义是结义。以三界贪俱令有情苦合非乐故立一爱结。随增义是随眠义。以欲界贪外门随增。色无色贪内门随增故立二随眠。染境义是爱义。以所染着欲色无色境有差别故。立三界爱。云何恚结。谓于有情欲为损害。问若于非情欲为损害亦应是恚。何故不说。答从多说故。谓此恚结多于有情欲为损害。少于非情。是故不说。复次从重说故。谓于有情欲为损害其罪甚重。非于非情。是故不说复次从本说故。谓此恚结要于有情欲为损害。然后方于非情亦起。是故不说。复次依想说故。谓于非情若起恚结。亦于彼处起有情想。是故但说于有情起。云何慢结。谓七种慢。一慢二过慢三慢过慢四我慢五增上慢六卑慢七邪慢。慢谓于劣谓己胜。于等谓己等。令心高举。过慢谓于等谓己胜于胜谓己等令心高举。慢过慢谓于胜谓己胜令心高举。我慢谓于五取蕴谓我我所令心高举。增上慢谓未得胜德谓己已得令心高举。卑慢谓于他多胜谓己少劣令心高举。邪慢谓实全无德谓己有德。如是七慢总名慢结。云何无明结。谓三界无知此说为善。若作是说缘三界无知。即应不摄无漏缘无明。云何见结。谓三见即有身见边执见邪见。总名见结。云何取结。谓二取即见取戒禁取。总名取结

问何故五见中三见立见结。二见立取结耶。答于合苦时由名等故。谓前三见同是女名。后之二见同是男名。以见是女声。取是男声故。复次于合苦时由事等故。谓见结取结各摄十八事。复次摄随眠亦等故。谓见结取结于九十八随眠中各摄十八。复次前三见是推度非执受故。合立见结。后二见是推度亦执受故。合立取结。复次前三见等推度境故。合立见结。后二见等推度见故。合立取结。云何疑结。谓于谛犹豫。问何故说此于谛犹豫。答欲令疑者得决定故。谓如有人远见竖物便生犹豫杌耶人耶。设彼是人为男为女。或见二道便生犹豫。是所往路为复非耶。见二衣钵亦生犹豫是我所有他所有耶。或疑此等是实疑结欲令彼疑得决定故。今显此疑但是欲界无覆无记邪智为体非真疑结。真疑结者。谓于苦等四谛犹豫。云何嫉结。谓心妒忌。云何悭结。谓心吝护。问何故说此二相别耶。答欲令疑者得决定故。谓世间人于嫉谓悭于悭谓嫉。于嫉谓悭者。如有见他所得好事。心生妒忌便谓为悭。然实妒忌是嫉非悭。于悭谓嫉者。如有见他吝护妻等便谓为嫉。然实吝护是悭非嫉。为令彼疑得决定故说嫉与悭二相差别。问何故于十缠中。唯立悭嫉为结。答唯此二缠有结相故。余无结相故不立结。复次以后显初故。但说二。谓十缠中嫉悭居后说后为结则已显初。复次以嫉与悭独立离二故立为结。余缠不尔。独立者。谓自力现行。离二者。谓一向不善。忿覆二缠虽能独立亦复离二。而似随眠为随眠相之所映夺。其相不显故不立结。由此义故。外国诸师说此二种即随眠性。惛沉掉举不能独立他力起故亦不离二。或是不善或无记故。睡眠恶作虽亦独立而不离二。睡眠通善不善无记。恶作通善不善性故。无惭无愧虽是离二而非独立。唯嫉与悭独立离二异随眠相故。立为结。复次以嫉与悭最为鄙贱深可厌毁故。立为结。复次以嫉与悭性甚猥弊违背正理故。立为结。谓他荣胜于自无损。何缘于他横生妒忌。虽复积聚百千珍财终不能持一钱往至后世。何缘固情吝护而不施他。复次由二法故。令诸有情于生死中多受毁辱。一无威德。二极贫穷。无威德者由多嫉妒。极贫穷者由多悭吝。若无威德极贫穷者。父母兄弟妻子僮仆尚轻蔑之。况非亲者。故十缠中立二为结。复次嫉悭于彼欲界有情犹如狱卒及防捍者。如有罪人絷在囹圄二卒禁守不令得出。复有清洁庄严园林二人防捍不令得入。囹圄者喻恶趣。园林者喻人天。狱卒防捍喻嫉与悭。欲界有情所以絷在恶趣囹圄不能得出。复不得入人天园者。以嫉与悭二结障故。如契经言。时天帝释往诣佛所。作如是问。由何结故。人天及龙阿素洛等屡兴战斗。世尊告曰。由嫉与悭。问诸有情类或具九结。或有六结。或有三结。或全无结。具九结者。谓具缚异生。有六结者。谓已离欲染异生及未离欲染圣者。有三结者谓已离欲染圣者。全无结者。谓阿罗汉无成二结及一结者。佛何故说由嫉与悭人天龙等屡兴战斗。答彼经但说诸富贵者数现行结不说成就。谓天帝释二天中尊由嫉与悭。与非天众数战斗故。但说二结。复次佛为呵责天帝释故。于彼契经说此二结。谓诸天中有苏陀味胜阿素洛。阿素洛宫有端正女胜彼诸天。天自悭味嫉他美女。非天悭女嫉他美味。天为美女往非天处。非天为味复往天宫。是故诸天与阿素洛由嫉悭结数兴战斗。尔时天帝与阿素洛适斗战已。心犹恐怖来诣佛所。作如是问。由何结故人天及龙阿素洛等屡兴战斗。彼意问言由何结故天与非天数兴战斗。故佛告曰。由嫉与悭。佛意告言。汝等天众及阿素洛由嫉悭结数兴战斗。故嫉与悭是汝等患亦是重担伤害汝等应速舍离。问六烦恼垢何故非结。答相粗动故。若相微细系缚坚牢可立为结。垢相粗动系义不坚故不立结

有九十八随眠。谓欲界系三十六随眠。色无色界系各三十一随眠。此即以九十八事为自性。随眠名义如前已释。问何故说此九十八随眠耶。答是作论者意欲尔故。谓本论师随欲作论不违法相故不应责。复次为止著文沙门意故。谓有沙门执著文字离经所说终不敢言。彼作是说谁有智慧过于佛者。佛唯说有七种随眠如何强增为九十八。为遮彼意广七随眠为九十八。谓依行相界部别故。七随眠中欲贪随眠部别故为五。嗔恚随眠亦尔。有贪随眠界别故为二。部别故为五。界部别故为十。慢随眠界别故为三。部别故为五。界部别故为十五。无明随眠亦尔。见随眠界别故为三。行相别故为五。部别故为十二。行相界部别故为三十六。疑随眠界别故为三。部别故为四。界部别故为十二。是故七随眠依行相界部别故为九十八随眠。广略虽异而体无差别

三结乃至九十八随眠几不善几无记。问何故作此论。答为止他宗显正义故谓或有说。一切烦恼皆是不善。由不巧便所摄持故。如譬喻者。为遮彼意显诸烦恼。有是不善有是无记。若诸烦恼由不巧便所摄持故是不善者。此不巧便应非不善非不巧便所摄持故。不巧便者即是无知。所摄持者是相应义。自体不与自体相应故不巧便应非不善。复有欲令欲界烦恼皆是不善。色无色界一切烦恼皆是无记。为遮彼意显示欲界有身见边执见及彼相应无明亦是无记。复有说者。欲现门义故作斯论。谓前已说何故于此先立章耶。为欲显示诸门义故。若不立章门义无由得显。如彩画者不能彩画虚空。既立章已应显门义。答三结中一无记谓有身见。问何故有身见是无记耶。答若法是无惭无愧自性与无惭无愧相应。是无惭无愧等起等流果者是不善。有身见非无惭无愧自性不与无惭无愧相应。非无惭无愧等起等流果。故是无记。复次此有身见非一向坏意乐。故非不善。无惭无愧不相应故非一向坏意乐。复次此见不违施戒修故。谓执我者作如是说。由布施故我当富乐。由持戒故我当生天由修定故我当解脱。故是无记。复次此有身见唯迷自体。不逼恼他故是无记。谓执我者眼见色时言我见色色是我所。广说乃至意了法时言我了法法是我所。虽于自体有此倒执。而不恼他故是无记。复次此有身见无异熟果故是无记。尊者世友作如是说。此有身见不能发起粗身语业。故是无记。问不善烦恼亦有不能起粗身语业者。应是无记。答贪嗔痴慢若增盛时必能发起粗身语业。此有身见设增盛时亦不能起粗身语业。故是无记复次此有身见不令有情堕诸恶趣。故是无记。问不善烦恼亦有不令堕恶趣者。应是无记。答不善烦恼若增盛时必令有情堕诸恶趣。此有身见设增盛时亦终不令堕诸恶趣。故是无记复次此见不能感非爱果。故是无记。问此见既令后有相续。后有即是非爱果摄。如何不能感非爱果。如契经说。苾刍当知。我终不赞起后有者。所以者何。若起后有一刹那者则为增苦。苦者即是非爱果摄。答此中所说非爱果者是苦苦类。契经所说非爱果者通三苦类。此有身见令有相续。非苦苦类故不相违。复次此有身见虽起后有。为苦苦本说为增苦。而不与彼为异熟因。故是无记。大德说曰。此有身见是颠倒执是不安隐是愚痴类。故是不善。若有身见非不善者。更有何法可名不善。如世尊说。乃至愚痴皆是不善。彼说不应理非异熟因故。若有身见皆不善者色无色界应有苦苦。然世尊说乃至愚痴皆不善者。非巧便故说为不善。不言能感不爱果故二应分别。谓戒禁取疑结或不善或无记。问应分别者义何谓耶。答应分析故名应分别。谓后二结。一分是不善一分是无记。故应分别。分别论者作如是言。所问二结应分别记非一向等。由此故言二应分别。谓彼二结欲界是不善。色无色界是无记。问何故色无色界烦恼是无记耶。答若法是无惭无愧自性与无惭无愧相应。是无惭无愧等起等流果者是不善。色无色界烦恼不尔。故是无记。复次色无色界烦恼非一向坏意乐。故非不善。无惭无愧不相应故非一向坏意乐。复次色无色界烦恼无异熟果。故是无记。问因论生论。何故色无色界烦恼无异熟果耶。答四支五支定所伏故。如毒蛇等咒术所伏不能为害。此亦如是。复次上界无彼异熟器故。若彼烦恼有异熟者应是苦受。苦受必是欲界所系。不应上界烦恼异熟是欲界系。故彼烦恼定无异熟。复次彼邪见等非极颠倒。于分相似处所起故。不恼他故但是无记。谓彼邪见谤言无苦。然上二界有相似乐。上界见取执彼诸蕴以为第一。然彼亦有相似第一。彼戒禁取执彼诸蕴以为能净。然彼亦有相似能净。谓色界道能净欲界。无色界道能净色界。故彼烦恼定非不善。尊者世友作如是说。上界烦恼不能发起粗身语业。故是无记。问不善烦恼亦有不能起粗身语业者应是无记。答不善烦恼若增盛时必能发起粗身语业。上界烦恼设增盛时亦不能起粗身语业。故是无记。复次上界烦恼不令有情堕诸恶趣。故是无记。问不善烦恼亦有不令堕恶趣者应是无记。答不善烦恼若增盛时必令有情堕诸恶趣。上界烦恼设增盛时亦终不令堕诸恶趣。故是无记。复次彼惑不能感非爱果。故是无记。问彼惑既令后有相续。后有即是非爱果摄。如何不能感非爱果。如契经说。苾刍当知。我终不赞起后有者。所以者何。若起后有一刹那者则为增苦。苦者即是非爱果摄。答此中所说非爱果者是苦苦类。契经所说非爱果者通三苦类。上界烦恼令有相续。非苦苦类故不相违。大德说曰。上界烦恼若是无记更有何法可名不善。如世尊说。若诸烦恼能发起业皆是不善。彼说非理。若彼烦恼是不善者。色无色界应有苦苦。然世尊说若诸烦恼能发起业皆不善者。依恶业说故不相违。三不善根唯不善。以彼自性是不善。复与一切不善法为因。为本为道路为由序为能作为生为缘为有为集为等起故。三漏中一无记谓有漏。由上所说诸因缘故。色无色界一切烦恼皆是无记。二应分别。谓欲漏或不善或无记。无惭无愧及彼相应是不善。无惭无愧者显彼自性唯是不善。及彼相应者。显欲漏中三十四事及三少分亦是不善。三少分者。谓彼相应惛沉睡眠掉举少分。余是无记。谓欲漏中有身见边执见及三少分皆是无记。三少分者。谓有身见边执见相应惛沉睡眠掉举少分。如是五法无惭无愧不相应故皆非不善。问无惭不与无惭相应。无愧不与无愧相应。岂是无记。答无惭虽不与无惭相应。而与无愧相应。无愧虽不与无愧相应。而与无惭相应。俱不相应者方是无记故。无明漏或不善或无记。无惭无愧相应是不善。谓欲界见集灭道及修所断无明唯是不善。见苦所断三见疑慢贪嗔相应及不共无明亦是不善。余是无记。谓欲界二见相应及色无色界一切无明。无惭无愧不相应故皆是无记。问何故十缠中唯说与无惭无愧相应耶。答是作论者意欲尔故。谓作论者随欲造论不违法相故不应责。复次此二唯是不善遍与一切不善心相应。是故偏说。忿覆嫉悭虽唯是不善。而不遍与一切不善心相应。惛沉掉举虽遍与一切不善心相应。而非唯是不善。睡眠恶作二义俱无。是故不说随眠与垢准此应知。无惭无愧二义俱有与不善义多少量等。如函盖相称故偏说相应。四瀑流中一无记。谓有瀑流义如前说。三应分别。谓欲瀑流或不善或无记无惭无愧及彼相应是不善。无惭无愧者显彼自性唯是不善。及彼相应者显欲瀑流中二十四事及三少分。亦是不善。三少分者。谓彼相应惛沉睡眠掉举少分。余是无记。谓欲瀑流中与有身见边执见相应惛沉睡眠掉举少分无惭无愧不相应故皆是无记。见瀑流或不善或无记。欲界三见是不善。谓邪见见取戒禁取无惭无愧相应故。欲界二见色无色界五见是无记。无惭无愧不相应故。无明瀑流或不善或无记。无惭无愧相应是不善。谓欲界见集灭道及修所断无明唯是不善。见苦所断三见疑慢贪嗔相应及不共无明亦是不善。余是无记。谓欲界二见相应及色无色界一切无明。无惭无愧不相应故皆是无记。如四瀑流四轭亦尔。瀑流与轭名体等故。四取中一无记谓我语取。义如前说。三应分别。谓欲取或不善或无记。无惭无愧及彼相应是不善。无惭无愧者显彼自性唯是不善。及彼相应者显欲取中二十八事及四少分亦是不善。四少分者谓彼相应惛沉睡眠掉举无明少分。余是无记。谓欲取中与有身见边执见相应惛沉睡眠掉举无明少分。无惭无愧不相应故皆是无记。见取或不善或无记。欲界二见是不善谓邪见见取。欲界二见色无色界四见是无记。欲界二见者谓有身见边执见。色无色界四见者。谓五见中除戒禁取。戒禁取或不善或无记。欲界是不善。无惭无愧相应故。色无色界是无记。无惭无愧不相应故。四身系中二不善。谓贪欲嗔恚。二应分别。谓戒禁取此实执身系欲界是不善。无惭无愧相应故。色无色界是无记。无惭无愧不相应故。五盖唯不善。皆与无惭无愧相应故。五结中三不善。谓嗔嫉悭结。二应分别。谓贪慢结或不善或无记。欲界是不善。无惭无愧相应故。色无色界是无记。无惭无愧不相应故。五顺下分结中。二不善。谓贪欲嗔恚一无记谓有身见。二应分别。谓戒禁取疑结或不善或无记。欲界是不善。色无色界是无记。五顺上分结唯无记。无惭无愧不相应故。五见中二无记。谓有身见边执见。三应分别。谓邪见见取戒禁取。或不善或无记。欲界是不善。色无色界是无记。六爱身中二不善。谓鼻舌触所生爱身。四应分别。谓眼耳身触所生爱身。或不善或无记。欲界是不善。梵世是无记。意触所生爱身或不善或无记欲界是不善。色无色界是无记。七随眠中二不善。谓欲贪嗔恚随眠。一无记谓有贪随眠。四应分别。谓慢疑随眠。或不善或无记。欲界是不善。色无色界是无记。无明随眠或不善或无记。无惭无愧相应是不善。谓欲界见集灭道及修所断无明。见苦所断有身见边执见不相应无明。余是无记。谓欲界有身见边执见相应无明及色无色界一切无明。见随眠或不善或无记。欲界三见是不善。谓邪见见取戒禁取。欲界二见色无色界五见是无记。九结中三不善谓恚嫉悭结。六应分别谓爱慢取疑结或不善或无记欲界是不善。色无色界是无记。无明结或不善或无记。无惭无愧相应是不善。余是无记。义如前说。见结或不善或无记。欲界一见是不善谓邪见。欲界二见谓有身见边执见。色无色界三见是无记。九十八随眠中三十三不善。六十四无记。一应分别。谓欲界见苦所断无明随眠或不善或无记。无惭无愧相应是不善。谓有身见边执见不相应无明。余是无记。谓有身见边执见相应无明

说一切有部发智大毗婆沙论卷第五十阿毗达磨大毗婆沙论卷第五十一

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中不善纳息第一之六

问何故名善不善无记答若法巧便所持。能招爱果。性安隐故名善。巧便所持者显道谛。能招爱果者。显苦集谛少分即有漏善。性安隐者显灭谛。若法非巧便所持。能招不爱果。性不安隐故名不善。此总显苦集谛少分即诸恶法。若法与彼二种相违。故名无记。复次若法能招可爱果乐受果。故名善。若法能招不爱果苦受果。故名不善。若法与彼二种相违。故名无记。复次若法能引可爱有芽及解脱芽故名善。若法能引非爱有芽故名不善。若法与彼二种相违故名无记。复次若法能令生善趣故名善。若法能令生恶趣故名不善。若法与彼二种相违故名无记。复次若法堕还灭品。性轻升故名善。若法堕流转品。性沉重故名不善。若法与彼二种相违故名无记。雾尊者言。由四事故名善。一自性故。二相应故。三等起故。四胜义故。自性故者。谓自性善。有说。是惭愧。有说。是三善根。相应故者。谓相应善即彼相应心心所法。等起故者。谓等起善即彼所起身语二业不相应行。胜义故者。谓胜义善即是涅槃安隐故名善。分别论者亦作是说。自性善谓智。相应善谓识。等起善谓身语业。胜义善谓涅槃。由四事故名不善。一自性故。二相应故。三等起故。四胜义故。自性故者。谓自性不善。有说。是无惭无愧。有说。是三不善根。相应故者。谓相应不善即彼相应心心所法。等起故者。谓等起不善即彼所起身语二业不相应行。胜义故者。谓胜义不善即是生死不安隐故名不善。分别论者亦作是说。自性不善谓痴。相应不善谓识。等起不善谓身语业。胜义不善谓生死。胁尊者言。若法是如理作意。自性与如理作意相应。从如理作意等起。是如理作意等流离系果故名善。若法是非理作意。自性与非理作意相应。从非理作意等起。是非理作意等流果故名不善。若法与彼二种相违故名无记。复次若法是惭愧。自性与惭愧相应。从惭愧等起。是惭愧等流离系果故名善。若法是无惭无愧。自性与无惭无愧相应。从无惭无愧等起。是无惭无愧等流果故名不善。若法与彼二种相违故名无记。复次若法是三善根。自性与三善根相应。从三善根等起。是三善根等流离系果故名善。若法是三不善根。自性与三不善根相应。从三不善根等起。是三不善根等流果故名不善。若法与彼二种相违故名无记。复次若法是信等五根。自性与信等五根相应。从信等五根等起。是信等五根等流离系果故名善若法是五盖。自性与五盖相应。从五盖等起。是五盖等流果故名不善。若法与彼二种相违故名无记。集异门说。何故名善。答由此能引可爱可喜可乐悦意如意果。故名善。此显等流果。复次由此能招可爱可喜可乐悦意如意异熟故名善。此显异熟果。何故名不善。答由此能引不可爱不可喜不可乐不悦意不如意果。故名不善。此显等流果。复次由此能招不可爱不可喜不可乐不悦意不如意异熟。故名不善。此显异熟果。若法与彼二种相违。故名无记。问世尊定记苦真是苦集真是集灭真是灭道真是道。一切法者谓十二处。如是诸法世尊显说施设开示。如何可立为无记耶。答非为不说故名无记。然诸善法佛记为善。诸不善法记为不善。若法不可记善不善。说为无记。复次佛记善法有可爱果。记不善法有非爱果。若法无彼二果可记。说为无记。复次由二事故善法可记。一由自性。二由异熟。不善亦尔。无记虽有自性可记。而无异熟故名无记。或有不说故名无记。如诸经中应舍置记。四种记论杂蕴已说

三结乃至九十八随眠几有异熟。几无异熟。问何故作此论。答为止他宗显己义故。谓或有执。离思无异熟因。离受无异熟果。如譬喻者为止彼意。显异熟因及异熟果俱通五蕴。或复有执。诸异熟因果。若熟已因体便无。如饮光部。彼作是说。诸异熟因果未熟位其体犹有。果若熟已其体便无。如外种子。芽未生位其体犹有。牙若生已其体便无。为遮彼意显异熟因果已熟位其体犹有。或复有执。善不善业无异熟果。如诸外道。为破彼义显善恶业有异熟果。为止此等种种异执显己所宗故作斯论。复次勿为止他显示己义。但为开发诸法实性令生正解故作斯论。答诸不善有异熟。诸无记无异熟。此广分别应准前门。问有异熟者义何谓耶。为与自异熟法俱名有异熟。为与他异熟法俱名有异熟。设尔何失。若与自异熟法俱名有异熟则因果应并。伽他所说复云何通。如说

  作恶不即受　　非如乳成酪
  犹灰覆火上　　愚蹈久方烧

有萨阇草。磨置乳中即便成酪。业果不尔。如灰覆火。愚夫轻蹈。初虽不觉后便被烧。作恶亦尔。因时虽乐至果熟时有恶趣苦。若与他异熟法俱名有异熟。则应圣道亦有异熟。与他异熟俱时起故。答自异熟俱名有异熟。问若尔。因果应并。伽他所说复云何通。答俱有二种。一者有俱。二者并俱。有俱者。如有因有果有所缘有异熟。有因有果者。如因谢已百俱胝劫果乃现前。相去虽远。而后名有因前名有果。有所缘者。如人住此观日月轮发生眼识。此彼相去虽四十千踰缮那量。而此眼识名有所缘。有异熟者。如造业已百俱胝劫异熟方起。相去虽远。而前业因名有异熟。并俱者。如有寻有伺有喜有警觉。有寻者谓寻相应法。有伺者谓伺相应法。有喜者谓喜根相应法。有警觉者谓作意相应法。应知此中有异熟者。依有俱说。不依并俱。复次俱有二种。一者有俱。二者合俱有俱者。如有因有果有所缘有异熟。合俱者。如有寻有伺有喜有警觉应知此中有异熟者。依有俱说不依合俱。复次俱有三种。一者近俱。二者远俱。三者近远俱。近俱者。如有寻有伺有喜有警觉。远俱者。如有因有果有所缘有异熟。近远俱者。如有漏有随眠有缘有事。有漏者谓漏相应法。及漏所缘法。有随眠亦尔。有缘者谓与彼缘近远诸法。有事亦尔。事谓因事或所系事。应知此中有异熟者。依远俱说不依余二。问何故名异熟。答异类而熟故名异熟。熟有二种。一同类。二异类。同类熟者谓等流果。即善生善。不善生不善。无记生无记。异类熟者谓异熟果。即善不善法招无记果。余问答义如杂蕴说

三结乃至九十八随眠。几见所断几修所断。问何故作此论。答为止他宗显己义故。谓譬喻者作如是说。异生不能断诸烦恼。大德说曰。异生无有断随眠义。但能伏缠。若作是说于理无损。问彼何故作此执。答依契经故。谓契经说。若以圣慧见法断者。是名真断非诸异生。已有圣慧故未能断。问若尔。经说复云何通。如说。苾刍彼猛喜子。已断欲染。已断色染。已断空无边处识无边处无所有处染。生非想非非想处。又说外仙已离欲染。彼作是答。所引契经不断说断不离说离如余契经不断说断不离说离。何等契经不断说断。如说

  愚执我我所　　死时皆永断
  智者既知此　　不执我我所

何等契经不离说离。如说。有村邑中童男童女。戏弄灰土以造舍宅。于此舍宅未离染时修营拥卫。若时离染毁坏舍去。如此二经不断说断不离说离。所引契经义亦应尔。然诸异生于诸烦恼。实未永断但能暂伏。谓离染时以世俗道攀初静虑离欲界染。渐次乃至攀非想非非想处。离无所有处染。非想非非想处无上可攀故不能离。犹如蚇蠖缘草木时攀上舍下。若至极处无上可攀即便退下。如人上树应知亦然。如野干等践暴麻芦。但损苗茎不除根栽。异生离染应知亦然。唯能暂伏不能永断。为遮彼意显诸异生以世俗道亦能断结。或复有执。必无圣者以世俗道断烦恼义。彼作是说。圣者何缘舍无漏道而用世俗。为遮彼意显有圣者以世俗道断烦恼义。或复有执。一切烦恼皆悉顿断。无渐断义。彼作是说。金刚喻定现在前时烦恼顿断。即由彼定断一切惑。是故说名金刚喻定。犹如金刚能破铁石牙骨贝玉末尼等故。彼虽许有四沙门果。然断烦恼要金刚定。问前之三果未能断惑。何用立为。彼作是答。前之三果伏诸烦恼。引金刚定令现在前。方能永断故非无用。譬如农夫左手握草右执利镰一时刈断。为遮彼意显诸烦恼有二对治。谓见及修二道差别。一一现前皆能永断。或复有执。于四圣谛得现观时顿而非渐。为断彼执显于四谛得现观时渐而非顿。见所断惑如修所断。不应一时断一切故。若于四谛得现观时顿非渐者。便违圣教。如契经说。给孤独长者来诣佛所白佛言。世尊。于四圣谛得现观时。为顿为渐。世尊告曰。如四桄梯渐登非顿。或复有执。一切烦恼无有见修所断差别。为遮彼意显诸烦恼定有见修所断差别。为止此等种种异执显己所宗故作斯论。复次勿为止他显示己义。俱为开发诸法实性令生正解故作斯论。答三结中有身见结见为前行有二句。或见所断。或见修所断。问前行是何义。答先立义先答义是前行义。先立义是前行义者。先立见所断句。后立不定句。先答义是前行义者。先以见所断句答。后以不定句答。云何见所断。若有身见非想非非想处系。随信随法行现观边苦忍断。是见所断。谓有身见从欲界乃至非想非非想处可得。世俗道起能断欲界乃至无所有处有身见。于非想非非想处有身见。此世俗道无能断力。便住不进。后若见道现在前时方能断彼。此中有身见者。定彼自性。非想非非想处系者。定彼地。随信随法行者。定彼能断补特伽罗。现观边苦忍者。定彼对治道。断者。定彼道所作。若有身见有不杂对治决定对治不共对治。圣者断非异生。圣道断非世俗。见道断非修道。忍断非智者是此所说。余若异生断修所断。世尊弟子断见所断。何者是余。谓从欲界乃至无所有处有身见。彼若异生断以修道断。圣者断以见道断。异生断以世俗道断。圣者断以无漏道断。异生断以智断。圣者断以忍断。异生断以九品断九品。圣者断以一品断九品。异生断数起断。圣者断不起断。异生断不观谛断。圣者断观谛断。如有身见结。五顺下分结中有身见结。五见中有身见边执见亦尔。自性同故俱通九地唯一部故。戒禁取疑结见为前行有二句。或见所断或见修所断。前行义如上说。云何见所断。若戒禁取疑非想非非想处系。随信随法行现观边诸忍断。是见所断。谓戒禁取疑从欲界乃至非想非非想处可得。世俗道起能断欲界乃至无所有处戒禁取疑。于非想非非想处戒禁取疑。此世俗道无能断力便住不进。后若见道现在前时方能断彼。此中戒禁取疑者。定彼自性。非想非非想处系者。定彼地。随信随法行者。定彼能断补特伽罗。现观边诸忍者。定彼对治道。断者定彼道所作。若戒禁取疑有不杂对治决定对治。不共对治。圣者断非异生。圣道断非世俗。见道断非修道。忍断非智者是此所说。余若异生断修所断。世尊弟子断见所断。何者是余。谓从欲界乃至无所有处戒禁取疑。彼若异生断以修道断。圣者断以见道断。异生断以世俗道断。圣者断以无漏道断。异生断以智断。圣者断以忍断。异生断以九品断九品。圣者断以一品断九品。异生断数起断。圣者断不起断。异生断不观谛断。圣者断观谛断。如戒禁取疑结。四暴流轭中见暴流轭四取中见取戒禁取。四身系中戒禁取此实执取身系。五顺下分结中戒禁取疑结。五见中邪见见取戒禁取。七随眠中见疑随眠。九结中见取疑结亦尔。自性同故俱通九地唯四部故。贪不善根修为前行有二句。或修所断或见修所断。问前行是何义。答先立义先答义是前行义。先立义是前行义者。先立修所断句。后立不定句。先答义是前行义者。先以修所断句答。后以不定句答。云何修所断。若贪不善根学见迹诸智断。是修所断。谓贪不善根五部可得。即见苦乃至修所断。见道起能断见苦乃至见道所断贪不善根。于修所断贪不善根。此见道无能断力。便住不进。后胜修道现在前时方能断彼。此中贪不善根者定彼自性。学见迹者定彼能断补特伽罗。诸智者定彼对治道。断者定彼道所作。若贪不善根有不杂对治决定对治不共对治。圣者断非异生。修道断非见道。智断非忍者是此所说。余若异生断修所断。世尊弟子断见所断。何者是余。谓前四部贪不善根即见苦乃至见道所断。彼若异生断以修道断。圣者断以见道断。异生断以世俗道断。圣者断以无漏道断。异生断以智断。圣者断以忍断。异生断以九品断九品。圣者断以一品断九品。异生断数起断。圣者断不起断。异生断不观谛断。圣者断观谛断。问此中所说若贪不善根学见迹诸智断是修所断者。显圣者身中修所断贪不善根。余若异生断修所断。世尊弟子断见所断者。显异生圣者身中见所断贪不善根。余有异生身中修所断贪不善根。此中何故不说。答应说而不说者。当知此义有余。复次彼已说在前所说中。所以者何。以部差别建立烦恼。不以在身诸烦恼。部有五无六。圣者见道现在前时断见所断。后若修道现在前时断修所断。异生修道现在前时总断五部。以诸异生不能分别五部差别唯能总断。说异生断修所断言。即已说彼故不别说。复次说学见迹诸智断言。即已显彼故不别说。异生身中修所断者。即学见迹智所断故。如贪不善根。嗔痴不善根。三漏中欲漏。四暴流轭中欲暴流轭。四取中欲取。四身系中贪欲嗔恚身系。五盖中除恶作疑余盖五结中嗔结。五顺下分结中贪欲嗔恚结。七随眠中欲贪嗔恚随眠。九结中恚结亦尔。自性同故俱唯欲界通五部故。有漏无明漏见为前行有三句。或见所断。或修所断。或见修所断问前行是何义答先立义先答义是前行义。先立义是前行义者。先立见所断句。次立修所断句。后立不定句。先答义是前行义者。先以见所断句答。次以修所断句答。后以不定句答。云何见所断。若有漏无明漏非想非非想处系随信随法行现观边诸忍断。是见所断。谓有漏从初静虑乃至非想非非想处可得。无明漏从欲界乃至非想非非想处可得。世俗道起能断初静虑乃至无所有处有漏欲界乃至无所有处无明漏。于非想非非想处有漏无明漏。此世俗道无能断力。便住不进。后若见道现在前时方能断彼见所断者。此中有漏无明漏者定彼自性。非想非非想处系者。定彼地。随信随法行者定彼能断补特伽罗。现观边诸忍者定彼对治道。断者定彼道所作。若有漏无明漏有不杂对治决定对治不共对治。圣者断非异生。圣道断非世俗。见道断非修道。忍断非智者是此所说。云何修所断。若有漏无明漏学见迹诸智断。是修所断。谓彼有漏无明漏有五部。见道现在前时断前四部。于修所断有漏无明漏。此见道无能断力便住不进。后胜修道现在前时方能断彼。此中有漏无明漏者定彼自性。学见迹者定彼能断补特伽罗。诸智者定彼能断对治道。断者定彼道所作。若有漏无明漏有不杂对治决定对治不共对治。圣者断非异生。修道断非见道。智断非忍者是此所说。余若异生断修所断。世尊弟子断见所断。何者是余。谓从初静虑乃至无所有处有漏。从欲界乃至无所有处无明漏。异生身中五部。圣者身中四部。彼若异生断以修道断。圣者断以见道断。异生断以世俗道断。圣者断以无漏道断。异生断以智断。圣者断以忍断。异生断以九品断九品圣者断以一品断九品。异生断数起断。圣者断不起断。异生断不观谛断。圣者断观谛断。如有漏无明漏。四暴流轭中有无明暴流轭。四取中我语取。五结中贪慢结。六爱身中意触所生爱身。七随眠中有贪慢无明随眠。九结中。爱慢无明结亦尔。自性同故俱通八九地。及通五部故。前行有三种。一不共前行。二毕竟前行。三最初前行。不共前行者如三结等。毕竟前行者如三不善根等。最初前行者如有漏无明漏等。若诸烦恼通三界系唯见所断。彼见为前行有二句。如三结等。若诸烦恼唯欲界系通于五部。彼修为前行有二句。如三不善根等。若诸烦恼通三界系亦通五部。彼见为前行有三句。如有漏无明漏等。是谓此处略毗婆沙

恶作盖修所断。异生圣者俱以九品智断彼故。如恶作盖五结中嫉悭结。五顺上分结。六爱身中前五爱身。九结中嫉悭结亦尔。同是九品智所断故。疑盖若异生断修所断。世尊弟子断见所断。此唯欲界前四部故。九十八随眠中二十八见所断。谓有顶前四部。十修所断。谓三界修所断部。余若异生断修所断。世尊弟子断见所断。谓下八地前四部。问若二十八见所断。十修所断。余不定者。品类足论何故说九十八随眠中八十八见所断十修所断耶。答此文是了义。彼文是不了义。此文无别意趣。彼文有别意趣。此文无别因缘。彼文有别因缘此文依胜义谛说。彼文依世俗谛说。复次彼论依渐次者具缚者非超越者说。此论依非渐次者不具缚者超越者说。复次彼论唯依圣者离染非异生圣道作用非世俗说。此论通依圣者异生离染圣道世俗道作用说。复次此论是决定说。彼论依异门说。谓先离欲乃至无所有处染入正性离生者。彼见道中亦证下八地见所断法无漏离系得。故作是说。八十八见所断十修所断。尊者妙音亦作是说。此论所说依决定理。品类足论说八十八见所断者。依证无漏解脱得说。或依渐次得果者说

问何故名见所断。何故名修所断耶。见不离修修不离见。如何建立二所断名。答虽见道中亦有如实修可得。修道中亦有如实见可得。而见者是慧修者是不放逸。如实者是增广义。或猛利义。见道中慧多不放逸少。修道中不放逸多慧少。故彼所断名有差别。复次如实者是平等义。或相似义。虽见道中有尔所慧。亦有尔所不放逸。修道中有尔所不放逸。亦有尔所慧。而见道中慧用增胜。不放逸用劣弱。修道中不放逸用增胜。慧用劣弱。故彼所断名有差别。尊者世友作如是说。虽观四谛断诸烦恼。不可分别此见所断此修所断。而由见力断弃吐者。名见所断。如已得道。若习若修若多所作。分齐品类渐令微薄乃至究竟。皆断尽者名修所断。有作是说。见所断者亦名修所断。见道中亦有如实修故。修所断者亦名见所断。修道中亦有如实见故。于此义中若由见力断弃吐者。名见所断。如已得道。若习若修若多所作。分齐品类渐令微薄乃至究竟。皆断尽者名修所断。问此说何义。答此说见道是猛利道。暂现在前一时能断九品烦恼。修道是不猛利道。数数修习久时方断九品烦恼。如利钝二刀同截一物。利者顿断钝者渐断暂见断者名见所断。数修断者名修所断。复次若以见增上道断者名见所断。若以修增上道断者名修所断。复次若以见慧二相道断者名见所断。若以见智慧三相道断者名修所断。复次若以眼明觉慧四相道断者名见所断。若以眼明觉智慧五相道断者名修所断。复次若以诸忍断者名见所断。若以诸智断者名修所断。复次若九品以一品断者名见所断。若九品以九品断者名修所断。复次若以未知当知根断者名见所断。若以已知根断者名修所断。复次若如析石而断者名见所断若如绝藕丝而断者名修所断。复次若违勇决者名见所断。若违加行者名修所断。复次未见谛而观谛断者名见所断。若已见谛重观谛断者名修所断。复次若以一因道而断者名见所断。若以二因道而断者名修所断复次如大力士擐甲胄而断者名见所断如尪疾人御驴车而断者名修所断。复次若断彼时唯修自所观谛诸行相者名见所断。若断彼时亦修他所观谛诸行相者名修所断复次若以向道未成就果而断者名见所断。若以向道已成就果而断者名修所断。复次若以无分齐品类道断者名见所断。若以有分齐品类道断者名修所断。复次若以随信随法行道断者名见所断。若以信胜解见至身证道断者名修所断。复次若以初顿起道而断者名见所断。若以后数起道而断名修所断。复次若彼离系四沙门果摄者名见所断。若彼离系或三或二或一沙门果摄者名修所断。复次若所断法缘无事者名见所断。若所断法缘有事者名修所断。复次若彼断已永不退者名见所断。若彼断已或退或不退者名修所断。复次若解脱已不复缚者名见所断。若解脱已或复缚或不复缚者名修所断。复次若离系已不复系者名见所断。若离系已或复系或不复系者名修所断。复次若断彼时忍为无间道智为解脱道者名见所断。若断彼时智为无间道智为解脱道者名修所断。复次若断彼时智为加行道忍为无间道智为解脱道者名见所断。若断彼时智为加行。无间解脱道者名修所断。复次若法先得非择灭后得择灭者名见所断。若法或先得非择灭后得择灭。或先得择灭后得非择灭。或一时得二灭者名修所断。复次若断彼时修缘一谛道者名见所断。若断彼时修缘四谛道者名修所断。复次若断彼时修四行相道者名见所断。若断彼时修十六行相道者名修所断。复次若断彼时唯修相似道者名见所断。若断彼时修相似不相似道者名修所断。复次若断彼时修二或一三摩地者名见所断。若断彼时修三三摩地者名修所断。复次若断彼时不起断者名见所断。若断彼时或起断或不起断者名修所断

说一切有部发智大毗婆沙论卷第五十一阿毗达磨大毗婆沙论卷第五十二

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中不善纳息第一之七

三结乃至九十八随眠。几见苦所断乃至几修所断。问何故作此论。答前门虽已止顿断沙门意。而未遮顿现观者意。亦未显渐现观义。今欲遮显顿渐现观。有作是说。前门虽已遮顿现观者意。亦已显渐现观义。而不粗显明了现见。今令粗显明了现见。或有说者。今欲显示五部烦恼及五对治。五部烦恼者。谓见苦所断乃至修所断。五部对治者。谓苦忍苦智是见苦所断对治。乃至道忍道智是见道所断对治。苦集灭道及世俗智是修所断对治。由此因缘故作斯论。答三结中有身见结见苦所断。问何故有身见唯见苦所断。答此见唯于苦处转故。观察苦时此见便断。复次此见唯于果处转故。观察果时此见便断。复次有身见结是倒自性。一切颠倒皆见苦断。颠倒断时此见亦断。同对治故。复次此烦恼粗初无间道苦法类忍现在前时即便永断。若烦恼细后无间道金刚喻定现在前时方能断尽。如衣有垢不坚著者。才洗便净。若坚著者以淳灰等。用功浣之然后得净。亦如瓦器腻不深入。水荡便净。腻深入者或以汤煮。或以火烧然后得净。尊者妙音亦作是说。此见粗故初无间道现在前时即便永断。衣器二喻亦如前说。复次非此见根深入境地。不深入故其性羸劣。初无间道苦法类忍现在前时即便永断。若烦恼根深入境地。后无间道金刚喻定现在前时方能断尽。譬如树根不深入地。小风吹之即便摧倒。根深入者大风吹之乃可摧倒。尊者世友作如是说。此有身见缘五蕴起。如实观见五取蕴时此见便断。复次此有身见从常乐净我想而生。四想断时此见便断。大德说曰。此有身见缘有身生名有身见。若观有身无我我所此见便断。故有身见结唯见苦所断。如有身见结。五顺下分结中有身见结五见中有身见边执见亦尔。自性同故。俱迷苦故。戒禁取结有二种。或见苦所断。或见道所断。问何故戒禁取非见集灭所断耶。答外道唯于苦道起此戒禁取故。谓诸外道亦能谓集如垢秽处。亦能谓灭如洗浴处。彼谓集是垢秽处故不生悕求。彼谓灭是洗浴处故妄生悕求。妄悕求故发起种种无利苦行。如如发起无利苦行。如是如是烦恼垢增染污身心去涅槃远。如人为除身体垢故秽水澡浴。如如澡浴如是如是更增垢秽。故戒禁取唯通二部。复次此戒禁取唯于苦道二处转故。苦处转者见苦所断。道处转者见道所断。复次此戒禁取唯于秽净二处转故。秽处转者见苦所断。净处转者见道所断。复次此戒禁取唯有二种。谓内外道所起差别。内道起者见苦所断。外道起者见道所断。复次此戒禁取唯有二种。谓非因计因及非道计道。非因计因者见苦所断。非道计道者见道所断。如戒禁取结。四取中戒禁取。四身系中戒禁取身系。五顺下分结中戒禁取结。五见中戒禁取亦尔。自性同故。疑结有四种。或见苦所断乃至或见道所断。问何故无有修所断疑。答未见事时心有犹豫。见彼事已犹豫即除故无有疑是修所断。如疑结四瀑流轭中见瀑流轭。四取中见取。四身系中此实执身系。五盖中疑盖。五顺下分结中疑结。五见中邪见见取。七随眠中见疑随眠。九结中见取疑结亦尔。体类同故。三不善根有五种或见苦所断。乃至或修所断。五部皆有贪嗔痴故。如三不善根。三漏四瀑流轭中除见余瀑流轭。四取中欲取我语取。四身系中贪欲嗔恚身系。五盖中除恶作疑余盖。五结中贪嗔慢结。五顺下分结中贪欲嗔恚结。六爱身中意触所生爱身。七随眠中除见疑余随眠。九结中爱恚慢无明结亦尔。体类同故。虽总说此皆通五部。而别分别有一有二有四有五。欲漏等中有身见边执见恶作嫉悭忿覆唯一部。戒禁取唯二部。邪见见取疑唯四部。贪嗔慢等通五部故。恶作盖修所断智所断故。如恶作盖五结中嫉悭结。五顺上分结。六爱身中前五爱身。九结中嫉悭结亦尔。同依事转品类等故。九十八随眠中。二十八见苦所断。苦处转故。十九见集所断。集处转故。十九见灭所断。灭处转故。二十二见道所断。道处转故。十修所断。依事转故。问此中何者名见苦所断。乃至何者名修所断耶。答若对治决定对治所缘决定者。名见苦乃至见道所断。若对治不决定对治所缘不决定者。名修所断。复次若处所决定对治所缘决定者。名见苦乃至见道所断。若处所不决定对治所缘不决定者。名修所断。复次若苦忍苦智为对治者。名见苦所断。乃至若道忍道智为对治者。名见道所断。若苦集灭道及世俗智为对治者。名修所断。复次若苦法类忍断者。名见苦所断。乃至若道法类忍断者。名见道所断。若四法类智及世俗智断者。名修所断。复次若观苦谛断者。名见苦所断。乃至若观道谛断者名见道所断。若或观苦谛。乃至或观道谛或观余事断者。名修所断。复次若违苦谛观者。名见苦所断。乃至若违道谛观者名见道所断。若违四谛观。及违余事观者。名修所断

三结乃至九十八随眠。几见几非见。问何故作此论。答为止他宗显正义故。谓或有执。一切烦恼皆是见性。所以者何。行相猛利说名为见。一切烦恼各于自业行相猛利。如有身见执我我所行相猛利。边执见执断执常行相猛利。邪见执无行相猛利。见取执最胜行相猛利。戒禁取执能净行相猛利。疑犹豫行相猛利。贪染着行相猛利嗔憎恶行相猛利。慢高举行相猛利。无明不了行相猛利。故诸烦恼皆是见性。或复有执。一切烦恼皆非见性。所以者何。了达诸法说名为见。一切烦恼于自所缘皆不了达故非见性。为止彼意显诸烦恼有是见性有非见性故作斯论。答三结中二见一非见。二见者谓有身见戒禁取。一非见者谓疑。余广说如本论。广释见义如前已说。谓五见处

三结乃至九十八随眠。几有寻有伺。几无寻唯伺。几无寻无伺。问何故作此论。答为止他宗显正理故。谓或有执。从欲界乃至有顶皆有寻伺。如譬喻者。彼何故作此执。依契经故。谓契经说。心粗性名寻。心细性名伺。然粗细性从欲界乃至有顶皆可得。故知三界皆有寻伺。大德说曰。对法诸师所说非理。所以者何。心粗细性三界皆有。契经说此即是寻伺。而言寻伺唯二地有。谓欲界及梵世。故对法者所说非理。亦名恶说恶受持者。不名善说善受持者。阿毗达磨诸论师言。我等所说及所受持是善非恶。所以者何。施设粗细有多种故。谓有处说。缠是粗随眠是细。此中寻伺非粗非细。此二非缠非随眠故。或有处说。色蕴是粗四蕴是细。此中寻伺是细非粗行蕴摄故。或有处说。欲界是粗初静虑是细。此中寻伺俱通粗细二地皆有寻及伺故。或有处说。初静虑是粗第二静虑是细。此中寻伺是粗非细。初静虑上无寻伺故。如是等处施设粗细有多品类不应定执。粗性名寻细性名伺。亦不应执寻伺二种三界皆有。然契经说。寻伺是心粗细性者。依下二地能扰动心粗细性说。第二静虑乃至有顶心离扰动故无寻伺。又彼既说二定以上有寻有伺。云何建立有寻伺等三地有异。彼作是说。欲界初静虑一切善染无覆无记及静虑中间。乃至有顶染污心等名有寻有伺地。静虑中间善及无覆无记心等名无寻唯伺地。第二静虑乃至有顶善及无覆无记心等名无寻无伺地。若尔经说当云何通。如契经说。寻伺寂静无寻无伺定生喜乐入第二静虑具足住。彼作是说。此经依善无覆无记。不依染说寻伺寂静。彼说非理。所以者何。有何因缘入第二定唯善无记寻伺寂静非染污耶。宁说染污寻伺寂静非善无记。所以者何。诸染污法离染时舍。善无记法越界地时方舍尽故。然譬喻者是无知果黑闇果不勤加行果。故说寻伺三界皆有而寻与伺。下二地有上七地无。是为正说。为止如是他宗所说显示正理故作斯论。答三结三种。谓或有寻有伺。或无寻唯伺。或无寻无伺。云何有寻有伺。谓在欲界及初静虑。云何无寻唯伺。谓在静虑中间。云何无寻无伺。谓在上三静虑及四无色。余广说如本论。问此中何者名有寻有伺。何者名无寻唯伺。何者名无寻无伺耶。答若与寻伺俱寻伺相应。是寻伺等起寻伺所转者名有寻有伺。若不与寻俱唯与伺俱。不与寻相应唯与伺相应。非寻等起唯伺等起。寻已寂静唯伺所转者名无寻唯伺。若非寻伺俱。非寻伺相应。非寻伺等起。非寻伺所转者。名无寻无伺。复次若有种种寻求种种伺察者名有寻有伺若无种种寻求有种种伺察者名无寻唯伺。若无种种寻求。亦无种种伺察者名无寻无伺。复次若有数数寻求数数伺察者名有寻有伺。若无数数寻求有数数伺察者名无寻唯伺。若无数数寻求亦无数数伺察者名无寻无伺

三结乃至九十八随眠。几乐根相应。几苦喜忧舍根相应。问何故作此论。答为止他宗显正理故。谓或有执。诸法生时渐次非顿。如譬喻者。大德说曰。诸法生时次第而生无并起义。如经狭路有多商侣一一而过。尚无二人一时过义。况得有多。诸有为法亦复如是。一一从自生相而生。别和合生理不俱起。阿毗达磨诸论师言。有因缘故说有为法别和合生。一一从自生相生故。有因缘故说有为法一和合生。不相离者一时生故。谓依生相说有为法别和合生。若依刹那说有为法一和合生。不相离者必俱起故。或复有执。力无力义。是名相应不相应义。谓若此法由彼力生。即说此法与彼相应。若法不由彼力生者。虽俱时起无相应义。如由彼心力此心生故。得说此心与彼心相应。又由心力心所生故。得说心所与心相应。又由心所力心所生故。得说心所与心所相应。不由心所力心得生故。不可说心与心所相应。为遮彼意显示心与心所相应。心所亦与心所相应。心所。又得与心相应。唯心与心无相应义。一身二心不俱起故。或复有执。诸法各与自性相应。不与他性。彼作是说相爱重义是相应义。无法与法极相爱重。如自性者。是故唯与自性相应。为遮彼意显示唯与他性相应。相应名义异体相望而建立故。如心心所展转相望。同一所依一所缘等互不相舍名相应故。或复有执。诸法与自性无相应义亦非不相应。无相应义者诸法不待自性而生故。非不相应者极相爱重是相应义故。为遮彼意显示诸法不乱相应故作斯论。问何故但问与受相应。答是作论者意欲尔故。谓作论者随欲造论不违法相故不应责。复次以受与受行相各别不违成就而违现行是故偏问。不违成就者。一身容成就五受根故。违现行者。必无二受俱时现行故。复次以受随根转变而起。于一受体建立五根余法不尔故偏问受。复次受居十二缘起轮中。犹如车毂是故偏问。复次以一切法皆归趣受是故偏问。复次除受更问何根相应。若问命等八根相应便为非理不相应故。若问信等五三无漏相应。亦为非理唯是善故。若问余染及想思等心所相应。亦为非理。无根相故。或有即是烦恼性故。若问念定及慧相应。亦为非理。烦恼相应无根相故。或有即是烦恼性故。若问意根亦不应理依心建立相应法故。又心相应无差别故。受有根相非烦恼体能生烦恼故问相应。答三结中有身见戒禁取结三根相应。除苦忧根。问此何故除苦根。答苦根在五识。此二结在意地故不相应。问此何故除忧根。答忧戚行相转。此二结欢行相转故不相应。总说此二三根相应。别分别者若在欲界初二静虑喜舍相应。若在第三静虑乐舍相应。若在第四静虑及无色界唯舍相应。是故总说三根相应。疑结四根相应除苦根。问此何故除苦根。答苦根在五识疑在意地故不相应。总说疑结四根相应。别分别者若在欲界忧舍相应。若在初二静虑喜舍相应。若在第三静虑乐舍相应。若在第四静虑及无色界唯舍相应。是故总说四根相应。问何故疑结若在欲界不与喜根相应。若在初二静虑则与喜根相应耶。答欢戚行相不相应故。谓欲界疑戚行相转。喜根欢行相转。行相既别无相应义。初二静虑疑与喜根俱欢行相转故得相应。以等义是相应义故。复次欲界喜粗疑细故不相应。问何故欲界喜粗。答欲界有情不应起而起故。于欲界事亦不应起而起故。云何欲界有情不应起而起谓欲界有情本性是苦复加余苦应生厌离而更踊跃岂不是粗。云何于欲界事不应起而起。谓若见他颠蹶迷谬应生慈愍而更欢笑岂不是粗欲界疑结沉思故细。粗细既别无相应义。初二静虑疑喜俱细故得相应。复次欲界疑结敦重喜根轻躁故不相应。初静虑二俱敦重故得相应。复次欲界疑结于内门转。欲界喜根于外门转故不相应。初二静虑俱内门转故得相应。复次欲界疑结如主喜根如客故不相应。初二静虑二皆如主故得相应。复次欲界疑结虽不与喜受相应而与忧受相应。初二静虑疑结若不与喜受。相应便为无受。喜是彼地自性受故。若疑心聚全无受者便违相依及相应法勿有斯过。是故疑结初二静虑喜根相应。三不善根中贪不善根三根相应除苦忧根。以苦忧根戚行相转。贪不善根欢行相转故不相应。嗔不善根三根相应除乐喜根。以乐喜根欢行相转嗔不善根戚行相转故不相应。痴不善根及欲漏无明漏五根相应。以彼皆通六识身欢戚行相转故。有漏三根相应除苦忧根。以色无色界无忧苦根故。彼无忧苦因根蕴当广说。除邪见余广说如本论。邪见四根相应除苦根。以苦根在五识邪见在意地故不相应。总说邪见四根相应别分别者若在欲界三根相应除乐苦根。若在初二静虑喜舍根相应。若在第三静虑乐舍根相应。若在第四静虑及无色界。唯舍根相应。问欲界邪见何者喜根相应何者忧根相应耶。答或有本来不好施与不好爱乐不好祠祀。彼后若遇邪见外道。闻说无施与无爱乐无祠祀无妙行无恶行无妙恶行业果异熟闻已欢喜作是念言。我从本来不好施与乃至祠祀甚为好事。以彼无果无异熟故。如是邪见喜根相应。或有本来好行施与好行爱乐好行祠祀。彼后若遇邪见外道。闻说无施与无爱乐无祠祀无妙行无恶行无妙恶行业果异熟。闻已忧戚作是念言。我从本来好行施与乃至祠祀极为唐捐。以彼无果无异熟故。如是邪见忧根相应广释相应义。六因中已说

三结乃至九十八随眠。几欲界系几色界系几无色界系。问何故作此论。答为止他宗显正理故。谓或有执。欲界所有烦恼及随烦恼名数色无色界亦有。为止彼意显示欲界是不定地多诸烦恼及随烦恼。色无色界是定地故少诸烦恼及随烦恼。如嗔随眠及恶作等。彼界无故。或复有执。有漏瀑流轭我语取欲界亦有缘内而生诸烦恼等得彼名故为止彼意显有漏等不通欲界上二界惑定所摄藏多缘内起得彼名故。或复有执。嫉悭二缠梵世亦有。如分别论者。问彼何故作此执。答依契经故。谓契经说。大梵天王告诸梵众。我等不须往诣沙门乔答摩所礼敬听法。即住此处当令汝等度生老死证永寂灭。彼说梵王为嫉悭结缠绕心故作如是语。为遮彼意显嫉悭结唯欲界有。或复有执。梵世有覆缠。问彼何故作此执。答依契经故。谓契经说。大梵天王不了尊者马胜所问恐梵众知。方便引出软言愧谢。彼说梵王由覆缠故引出众外方申不了。为遮彼意显示覆缠唯欲界有。然大梵王为慢谄诳覆蔽心故便作是语。由此因缘故作斯论

答三结三种或欲界系。或色界系或无色界系。余广说如本论。问何故名欲界系色界系无色界系耶。答系在欲故名欲界系。系在色故名色界系。系在无色故名无色界系。如牛马等系在于柱或在于栓名柱等系。复次为欲界足所系缚故名欲界系。为色界足所系缚故名色界系。为无色界足所系缚故名无色界系。足谓烦恼如伽他言佛所行无边无足。谁将去

如人有足则得自在游涉八方无足不尔。如是有情有烦恼足则能游涉诸界趣生。无烦恼足则不如是。诸佛永断烦恼足故。于界趣生无复流转。然由定慧所行无边。复次欲界窟宅所摄藏故。欲界我执所执着故名欲界系。色界窟宅所摄藏故。色界我执所执着故名色界系。无色界窟宅所摄藏故。无色界我执所执着故名无色界系。窟宅谓爱。我执谓见。复次为欲界爱所滋润。我我所见所执着故名欲界系。为色界爱所滋润。我我所见所执着故名色界系为无色界爱所滋润。我我所见所执着故名无色界系。复次欲界乐欲所坚着故名欲界系。色界乐欲所坚着故名色界系。无色界乐欲所坚着故名无色界系。乐者谓爱欲者谓见。复次为欲界生死所系缚故名欲界系。为色界生死所系缚故名色界系。为无色界生死所系缚故名无色界系。复次为欲界垢所污故毒所害故秽所染故名欲界系为色界垢所污故。毒所害故秽所染故名色界系。为无色界垢所污故毒所害故秽所染故名无色界系。一切烦恼皆名为秽非唯是嗔故通三界。复次为欲界烦恼所系缚故名欲界系。为色界烦恼所系缚故名色界系。为无色界烦恼所系缚故名无色界系

诸结堕欲界彼结在欲界耶。乃至广说。此中堕者堕有六种。一界堕。二趣堕三补特伽罗堕。四处堕。五有漏堕。六自体堕。界堕者。如此中说诸结堕欲界彼结在欲界等。此中意说。若是此界法即名堕此界。若欲界法名堕欲界。若色界法名堕色界。若无色界法名堕无色界。趣堕者。如说法者行法施时发是愿言。以此法施令堕诸趣有情速出生老病死。补特伽罗堕者。如毗奈耶说。有三补特伽罗堕僧数中令僧和合。处堕者。如品类足说。云何色蕴谓十色处及堕法处色。有漏堕者。如品类足说。云何堕法谓有漏法。自体堕者。如大种蕴说。有执受是何义。答此增语所显堕自体法。于六堕中此中唯依界堕作论。此中在者在有四种。一自体在。二器在。三现行在。四处在。自体在者。谓一切法各住自体自我自物自相自分自本性中。器在者。如枣等在盆中天授等在舍中。现行在者。若法于此现行可得。处在者。若法于此处可得。此中总依四在作论。或具不具如应当知。诸结堕欲界彼结在欲界耶。答应作四句有结堕欲界彼结非在欲界。谓缠所缠色界没起欲界中有。色界没生欲界者唯是异生。彼欲界中有在色界起法应如是。死有灭处中有现前。如种灭处萌芽现前。彼从死有至中有时。欲界三十六随眠随一现前令生相续。及恶魔住梵世缠所缠故诃拒如来。缠所缠者。有说忿缠。彼忿缠心诃拒佛故。有说覆缠。彼覆缠心诃拒佛故。有说嫉缠。彼嫉缠心诃拒佛故。有说悭缠。彼悭缠心诃拒佛故。评曰。应作是说。于九缠中随一现前而诃拒佛。除眠不能发语业故。问何故名魔。答断慧命故。或常放逸而自害故。问何故名恶。答怀恶意乐成就恶法及恶慧故。尊者妙音作如是说。勃恶者死生彼处故说名为恶。问魔住梵世何所为耶。答诃拒佛故。问彼有何力能住梵世。答梵所引故如契经说。一时薄伽梵在室罗筏住誓多林给孤独园。尔时有一梵天住在梵世。起恶见趣。此处是常恒不变易纯永出离。更无有常恒不变易。纯永出离过此处者。尔时世尊知彼心已。譬如壮士屈伸臂顷。从此处没至梵世出去彼梵天不远而住。时彼梵天遥见佛已即命佛曰。善来大仙。此处是常恒不变易。纯永出离。更无有常恒不变易。纯永出离过此处者。仁能厌舍灾患欲界。而来至此甚为善哉。宜于此间安乐常住。世尊告曰。此处非常恒不变易。纯永出离。而汝谓常恒不变易。纯永出离。由重无明蔽汝心故。汝应省察过去诸梵堕欲界者如花果落。云何妄计此为常等。如是梵天再三自赞。佛亦再三诃彼所说。尔时彼梵睹佛威光难为抗敌。又住寂静离欲地中。不乐言论便作是念。谁能与佛为敌论耶。念已便忆。魔与如来恒为怨对必能抗敌。即以神力引置梵世化作欲地而安处之。尔时彼梵复白佛言。此处是常乃至广说。世尊告曰。此处非常广说如上。魔便白佛大仙。应随梵天所说勿复违拒当奉行之。若违拒者譬如有人吉祥天神来过其舍。以刀杖等驱逐令出。亦如有人从高转堕放舍手足便坠深坑。又如有人从树端落放舍手足堕必至地故。应奉顺梵天所说。复白佛言。仁岂不见我等梵众围绕梵天。敬顺其言不敢违逆。佛时告曰。汝非梵王亦非梵众。乃是恶魔。无有耻愧。横来相扰。尔时恶魔知佛觉已。心怀愧恼不能自退。梵以神力令彼还宫。因彼契经而作此论。是谓有结堕欲界彼结非在欲界。堕欲界者。是界堕非余堕。非在欲界者色界可得故。此有三在除自体在不在自界现在前故

说一切有部发智大毗婆沙论卷第五十二阿毗达磨大毗婆沙论卷第五十三

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中不善纳息第一之八

有结在欲界彼结非堕欲界。谓缠所缠欲界没起色界中有。欲界没生色界者。通异生及圣者。彼色界中有在欲界起法应如是。死有灭处中有现前。如种灭处萌芽现前。彼从死有至中有时。若异生色界三十一随眠随一现前令生相续。若圣者色界修所断三随眠随一现前令生相续。及住欲界色无色界结现在前。谓住欲界不死不生而色无色界结现在前。彼通异生及圣者。若异生色无色界六十二随眠随一现前。谓爱见疑慢上静虑者。若圣者色无色界修所断六随眠随一现前。谓爱慢上静虑者。彼定后烦恼现在前。烦恼后定现在前。是谓有结在欲界非堕欲界。在欲界者有三在除自体在。不在自界现在前故。非堕欲界者。堕色无色界故。是界堕非余堕。有结堕欲界彼结亦在欲界。谓缠所缠欲界没起欲界中有生有。欲界没生欲界者。通异生及圣者。异生于五趣生无碍。圣者于二趣生无碍。谓人天。从死有至中有时。若异生欲界三十六随眠随一现前令生相续。若圣者欲界修所断四随眠随一现前令生相续。从中有至生有亦尔。及住欲界欲界结现在前谓住欲界不死不生而欲界结现在前。彼通异生及圣者。若异生欲界三十六随眠随一现前。若圣者欲界修所断四随眠随一现前。是谓有结堕欲界亦在欲界。堕欲界者是界堕非余堕。亦在欲界者具四在以在自界现在前故。有结非堕欲界彼结亦非在欲界。谓缠所缠色界没起色界中有生有。色界没生色界者。通异生及圣者。若异生生上亦生下。一一处有多生。若圣者生上不生下。一一处唯一生。从死有至中有时。若异生色界三十一随眠随一现前令生相续。若圣者色界修所断三随眠随一现前令生相续。从中有至生有亦尔。色界没生无色界。彼亦通异生及圣者。从死有至生有时。若异生无色界三十一随眠随一现前令生相续。若圣者无色界修所断三随眠随一现前令生相续。无色界没生无色界。彼亦通异生及圣者。若异生生上亦生下。一一处有多生。若圣者生上不生下。一一处唯一生。从死有至生有时。若异生无色界三十一随眠随一现前令生相续。若圣者无色界修所断三随眠随一现前令生相续。无色界没生色界。彼唯异生。从死有至中有时。色界三十一随眠随一现前令生相续。及住色界色无色界结现在前。谓住色界不死不生而色无色界结现在前。彼通异生及圣者若异生色无色界六十二随眠随一现前。谓爱见疑慢上静虑者。若圣者色无色界修所断六随眠随一现前。谓爱慢上静虑者。彼定后烦恼现在前。烦恼后定现在前住无色界无色界结现在前。谓住无色界不死不生而无色界结现在前。彼通异生及圣者。若异生无色界三十一随眠随一现前。若圣者无色界修所断三随眠随一现前。是谓有结非堕欲界亦非在欲界。非堕欲界者。堕色无色界故。是界堕非余堕非在欲界者。在色无色界现在前故。容具四在。亦在自界现在前故。诸结堕色界彼结在色界耶。答应作四句。如文广说。然与欲界四句相翻。谓前初句作此第二句。前第二句作此初句。前第三句作此第四句。前第四句作此第三句。虽粗翻前而细有异故。复广说。谓前初句有二种。一色界没起欲界中有。二魔住梵世诃拒如来。今第二句有三种。即前二及住色界无色界结现在前。前第二句有三种。一欲界没起色界中有。二住欲界色界结现在前。三住欲界无色界结现在前。今初句但有前二。前第三句有二种。一欲界没起欲界中有生有。二住欲界欲界结现在前。今第四句有七种。谓即前二及别有五。一欲界没生无色界。二无色界没生无色界。三无色界没生欲界。四住欲界无色界结现在前。五住无色界无色界结现在前。前第四句有七种。一色界没起色界中有生有。二色界没生无色界。三无色界没生无色界。四无色界没生色界。五住色界色界结现在前。六住色界无色界结现在前。七住无色界无色界结现在前。今第三句但有二种。谓前第一及前第五既有此异故。复广说。堕在多少准前应知。诸结堕无色界彼结在无色界耶。答诸结在无色界彼结堕无色界。以无色界现在前者。定非欲色二界结故。有结堕无色界彼结非在无色界。谓住欲色界无色界结现在前。谓住下二界不死不生。无色界结现在前。彼通异生及圣者。若异生无色界三十一随眠随一现前谓爱见疑慢。上静虑者。若圣者无色界修所断三随眠随一现前。谓爱慢。上静虑者。彼定后烦恼现在前。烦恼后定现在前。是谓有结堕无色界彼结非在无色界。堕无色界者。是界堕非余堕。非在无色界者。在欲色界现在前故。此有三在除自体在。不在自界现在前故。诸结非堕欲界彼结非在欲界耶。答应作四句翻上应知。谓前欲界初句作此第二句。前第二句作此初句。前第三句作此第四句。前第四句作此第三句。诸结非堕色界彼结非在色界耶。答应作四句翻上应知。谓前色界初句作此第二句。前第二句作此初句。前第三句作此第四句。前第四句作此第三句。诸结非堕无色界彼结非在无色界耶。答如是以无色界现在前结决定非堕欲色界故。有结非在无色界彼结非不堕无色界。谓住欲色界无色界结现在前。谓住下二界不死不生无色界结现在前。彼通异生及圣者。若异生无色界三十一随眠随一现前。谓爱见疑慢。上静虑者。若圣者无色界修所断三随眠随一现在前。爱慢。上静虑者。彼定后烦恼现在前。烦恼后定现在前。是谓有结非在无色界彼结非不堕无色界。非在无色界者。在欲色界现在前故。此有三在除自体在。不在自界现在前故。非不堕无色界者。是界堕非余堕。此结堕无色界故。问何故于此立非句耶。答是作论者意欲尔故。谓本论师随欲造论不违法相故不应责。复次欲显言论得自在故。谓于言论得自在者能立非句。若于言论不自在者。尚不能依是句作论况立非句。复次欲令弟子生觉意故。谓依非句而作论者。则诸弟子能生觉意。谓诸法性此亦可尔彼亦可尔不相违背。复次或有非句与是句别。如后补特伽罗品中。是句有四三二。非句有五六四。今则不尔故立非句

具见世尊弟子。乃至广说。问何故作此论。答为止他宗显己义故。谓有执色九品渐次分分而断。如外国师彼作是说。如诸染污心心所法九品渐断色亦应尔。为遮彼意显诸染污心心所法九品渐断。色有漏善无覆无记心心所法。要由第九无间道力一时顿断。问何故染污心心所法九品渐断。色有漏善无覆无记心心所法。要由第九无间道力一时断耶。答明与无明互相违故。谓下下明起断上上无明。乃至上上明起断下下无明。色有漏善无覆无记与明无明俱不相违。然与明无明为依安足处。如灯与闇更互相违。器及油炷不违于二然能为依及安足处。复次染心心所是自性断与道相违。堕何品道现在前时便断彼品。令失成就得不成就。色有漏善无覆无记非自性断不正违道。诸染污色加行道时已失成就。诸有漏善无覆无记多分断已犹有成就随地第九无间道时正断染污心心所法。令色等上所缘缚尽故亦说名断。色等法如灯明起正能破闇。兼能热器烧炷尽油复次勿为止他显己宗义。但为显示诸法正理开悟学者故作斯论。问为简何事说具见言。世尊弟子复简何事。答说具见言为简随信随法行者。世尊弟子为简异生。问何故随信随法行者不名具见。答若相续中已具见四谛。已断四邪见者得名具见。随信随法行者未已具见四谛当具见故。未已断四邪见。当已断故不名具见。复次若相续中已断四种无知愚闇已起四种无漏智者得名具见。随信随法行者未已断四种无知愚闇。当已断故。未已起四种无漏智。当已起故不名具见。复次若相续中已破四种犹豫疑网。已起四种决定圣智者得名具见。随信随法行者未已破四种犹豫疑网。当已破故未已起四种决定圣智。当已起故不名具见。复次若相续中无如霜雹及余灾害烦恼恶行颠倒见者得名具见。随信随法行者。犹有此事不名具见。如诸稼穑有灾害者不名为具。此亦如是。复次若已降伏四谛洲者得名具见。随信随法行者。未已降伏四谛洲故不名具见。问何故异生不名世尊弟子。答若闻佛说三宝四谛。决定信受者名世尊弟子。异生闻说三宝四谛。或信不信故不名世尊弟子。复次若唯事佛不事余天者名世尊弟子。异生事佛或事余天故不名世尊弟子。复次若于三宝得证净者名世尊弟子。异生不尔故不名世尊弟子。复次若于佛法心不移动如门阃者名世尊弟子。异生于佛法其心轻动如柳絮叠花故不名世尊弟子。复次若闻正法已。不为邪闻所坏者名世尊弟子。异生闻正法已。或为邪闻所坏故不名世尊弟子。问此中说何等名具见世尊弟子耶。答此中说预流一来不还阿罗汉名具见世尊弟子。诸色未断彼色系耶。乃至广说。此中诸色若时名断即时离系。若时离系即时名断。先断后离系先离系后断无是事故。染污心心所法。或先断后离系。或断时即离系。彼有九品。谓上上乃至下下。前八品先断后离系。下下品断时即离系。谓上上品断已犹为后八品为所缘系。乃至前八品断已犹为下下品为所缘系。同地九品展转相缘为系事故。若断第九品时九品皆得离系于前八品所缘系尽。彼相应系先已尽故名得离系。于第九品二系俱尽故得离系。是谓此处略毗婆沙具见。世尊弟子诸色未断彼色系耶。答如是。设色系彼色未断耶。答如是。前已说诸色若时名断即时离系。若时离系即时名断。先断后离系。先离系后断无是事故。以一切色最后无间道所断故。尔时即名得离系故。预流一来五地诸色未断而系。不还未离初静虑染四地诸色未断而系。已离初静虑染未离第二静虑染。三地诸色未断而系。已离第二静虑染未离第三静虑染。二地诸色未断而系。已离第三静虑染。未离第四静虑染。一地诸色未断而系。具见世尊弟子诸受想行识未断。彼受想行识系耶。答如是。谓预流一来有三界修所断受想行识未断而系。不还未离初静虑染。有八地修所断受想行识未断而系。已离初静虑染未离第二静虑染。有七地修所断受想行识未断而系。乃至已离无所有处染。有一地修所断受想行识未断而系

有受想行识系彼受想行识非未断。谓家家或一来或一间。欲界修所断上中品结已断遍知。彼相应受想行识下品结系。此中家家已断欲界前三品或四品结。亦已断彼相应受想行识。彼相应受想行识犹为欲界后六品或五品结为所缘系。一来已断欲界前六品结。亦已断彼相应受想行识。彼相应受想行识犹为欲界后三品结为所缘系。一间已断欲界前七品或八品结。亦已断彼相应受想行识。彼相应受想行识犹为欲界后二品或一品结为所缘系。是谓系非未断具见世尊弟子。诸色已断。彼色离系耶。答如是。设色离系彼色已断耶。答如是。前已说诸色若时名断即时离系。若时离系即时名断。先断后离系。先离系后断无是事故。以一切色最后无间道所断故。尔时即名得离系故。谓不还者已离色染。五地诸色已断离系已离第三静虑染。未离第四静虑染四地诸色已断离系。已离第二静虑染未离第三静虑染。三地诸色已断离系。已离初静虑染未离第二静虑染。二地诸色已断离系。未离初静虑染。一地诸色已断离系。具见世尊弟子。诸受想行识已断。彼受想行识离系耶。答诸受想行识离系。彼受想行识已断。谓阿罗汉三界见修所断受想行识已断离系。不还已离无所有处染。三界见所断及八地修所断受想行识已断离系。已离识无边处染未离无所有处染。三界见所断及七地修所断受想行识已断离系。乃至未离初静虑染。三界见所断及一地修所断受想行识已断离系。预流一来三界见所断受想行识已断离系有受想行识已断非离系。谓家家或一来或一间。欲界修所断上中品结已断遍知。彼相应受想行识下品结系。此中家家已断欲界前三品或四品结。亦已断彼相应受想行识。彼相应受想行识犹为欲界后六品或五品结为所缘系。一来已断欲界前六品结。亦已断彼相应受想行识。彼相应受想行识犹为欲界后三品结为所缘系。一间已断欲界前七品或八品结。亦已断彼相应受想行识。彼相应受想行识犹为欲界后二品或一品结为所缘系。是谓已断非离系

问诸预流者若断欲界上上品结。亦即断彼相应受等。彼相应受等犹为八品结为所缘系。若断欲界上中品结。亦即断彼相应受等。彼相应受等。犹为七品结为所缘系。此中何故不说预流。但说家家一来一间为系非未断及断非离系。答应说而不说者。当知此义有余。复次诸预流者坏相不定。是故不说。谓具缚者无如是义。不具缚者有如是义。家家等三皆有此义。其相不坏决定故说。复次诸预流者。若断欲界一二品结。无死生义故不说之。如断五品。谓瑜伽师得初果已为断欲界修所断结起大加行。必无未断一大品结有死生故。如断五品。必无未断第六品结有死生义。家家等三有死生故此中偏说。问色无色界八地受等亦有已断非离系义。及有犹系非未断义。如断一品八品犹系。乃至断八品第九品犹系。此中何故但说欲界不说色界无色界耶。答应说而不说者。当知此义有余。复次此中且显初入加行。已说欲界即亦说彼。复次渐断欲界修所断结建立多种补特伽罗。谓断三四说名家家。若断第六说名一来。若断七八说名一间。渐断上界修所断结。无如是义是故不说。问欲界修所断下品结分断如一间者。亦有已断非离系义。及有犹系非未断义。此中何故但说欲界修所断结上中品断。又彼相应受想行识。亦有上中品结系义。如断上上八品犹系。若断上中七品犹系。若断三四六五犹系。何故但说下品结系。答亦应说彼而不说者。应知此是有余略说。欲令智者思力增故

此中家家是预流差别。一间是一来差别。家家有二种。谓生二家三家别故。生二家者谓断欲界前四品结。余有欲界二有种子。生三家者谓断欲界前三品结。余有欲界三有种子。问何故无有断五品结名家家耶。答若断第五必断第六成一来故。第六品结性羸劣故不能独障证一来果。如一缕丝不能制象。一间者。谓断欲界前七品或八品结。余有欲界一有种子。问彼或犹有二品结在。何故说彼为一间耶。答不以一品烦恼在故名为一间。但以彼有一有种子名一间故。有余师说无断八品名一间者。所以者何若断第八必断第九成不还故。第九品结性羸劣故不能独障证不还果。如一缕丝不能制象。如无断五名为家家。如实义者。有断八品名为一间。无断五品名家家者。所以者何。断五品已若断第六证一来果。犹生欲界自地所有引众同分定应熟业有与果义不极为障。第六品结性羸劣故不能独障证一来果故无断五名家家者。断八品已若断第九证不还果。决定无有生欲界义自地所有引众同分。定应熟业无与果义。极为障碍。第九品结虽性羸弱而能助彼障不还果故有断八名一间者。由此故说有情三位定应熟业极作障碍。一者从顶将入忍位。二者将证不还果位。三者将得阿罗汉位。谓从顶位将入忍时。恶趣所有引众同分定应熟业极作障碍义言。汝若得入忍位决定不受三恶趣生。我于谁身当受异熟。由此于彼极作障碍。圣者将离欲界染时。欲界所有引众同分定应熟业极作障碍义言。汝若证不还果决定不复受欲界生。我于谁身当受异熟。由此于彼极作障碍。圣者将离有顶染时二界所有引众同分。定应熟业极作障碍义言。汝若成阿罗汉决定不复受后有生。我于谁身当受异熟。由此于彼极作障碍。故无断五名为家家。有断第八名一间者。家家有二谓天家家及人家家。天家家者。谓于天上或受二生或受三生。或一天处或二天处或三天处受二三生。或一天家或二天家或三天家受二三生。人家家者。谓于人中或受二生或受三生。或一洲处或二洲处或三洲处受二三生。或一人家或二人家或三人家受二三生。一间有二。谓天一间及人一间。天一间者谓于天上唯受一生。或四大王众天。或三十三天。或夜摩天。或睹史多天。或乐变化天。或他化自在天。受此一生。人一间者。谓于人中唯受一生。或赡部洲。或东胜身洲或西牛货洲。受此一生。由三缘故建立家家。一由业故。二由根故。三由结故。由业故者。谓先造作增长欲界二有或三有业。由根故者。谓彼已得对治欲界三品或四品结无漏诸根。由结故者谓彼已断欲界三品或四品结。于此三缘随一不具不名家家。由三缘故建立一间。一由业故。二由根故。三由结故。由业故者。谓先造作增长欲界一有业。由根故者。谓彼已得对治欲界七品或八品结。无漏诸根。由结故者。谓彼已断欲界七品或八品结。于此三缘随一不具不名一间

问圣者为造欲界引众同分业不。有说不造所以者何。以欲界多诸过患多诸灾横。是故圣者不造欲界引众同分业。但造欲界满众同分业。问若尔契经所说当云何通。如契经说。佛赞慈氏成佛事时。会中有学未离欲者。闻已发愿。使我见彼胜妙事已乃般涅槃。答彼丰资缘未触重苦暂发此愿。若触重苦。即便厌离一切有生。作是念言。设有是事能如怖鸟速飞于空。我亦今时速趣灭度。故彼不造能引欲界众同分业。彼作是说。家家二有或三有业。异生位造非于圣位。三四品结或异生位或圣位断。一间一有业唯异生位造。七八品结或异生位或圣位断有说圣者亦造欲界引众同分业。彼业所引众同分果。势力炽盛殊胜微妙。清净鲜白。无诸过患。无诸灾横。随顺善品。彼作是说。家家二有或三有业异生位造或于圣位三四品结或异生位或圣位断。一间一有业或异生位或圣位造。七八品结或异生位或圣位断

问若在欲界经生圣者。为复得生上二界不设尔何失。二俱有过。若得生者。增壹经说当云何通。如说有五种补特伽罗。此间下种此间究竟。一极七返有。二家家。三一来。四一间。五现法般涅槃。此间下种者。谓在欲界入正性离生。此间究竟者谓在欲界得诸漏尽。有五补特伽罗。此间下种彼间究竟。一中般涅槃。二生般涅槃。三有行般涅槃。四无行般涅槃。五上流般涅槃。此间下种者。谓在欲界入正性离生。彼间究竟者。谓在色无色界得诸漏尽。若不生者。帝问经颂当云何通。如彼颂说

  三于此知法　　二于彼胜进
  既得胜进已　　俱升梵辅天

彼第二说。复云何通。如说。大德我行如理若有教诲。我当奉行即于此间作苦边际。若无教诲曾闻殊妙色究竟天。我后命终当生于彼。答若在欲界经生圣者不复得生色无色界。问若尔帝问经颂当云何通。答彼二虽升梵世而非死生谓有释女名瞿比迦。有三苾刍。常入其舍以妙音声为彼说法。彼闻法已心生净信。厌患女身愿为男子。命终生在三十三天。为帝释儿端严殊妙。天为立字称瞿博迦。时三苾刍自爱声故。命终生在健达缚中。健达缚者。是天乐神昼夜常为诸天作乐。时瞿博迦见已便识告言。我昔闻汝法音厌患女身。愿为男子命终生此三十三天。为帝释儿端严殊妙。汝等曾修无上梵行。宁生卑贱健达缚中。时三乐神闻彼语已。二极羞愧得离欲染以神通力升梵辅天。一犹住此是故彼二虽升梵世而非死生。有说彼二虽有死生而不违理。谓昔人中但曾修得顺决择分。命终生在健达缚中。由瞿博迦讥诮彼故二极羞愧。得入见道离欲界染。证不还果命终生在梵辅天中。故有死生亦不违理。问彼第二说。复云何通。如说。大德我行如理。广说如前。答帝释不解阿毗达磨。不知欲界经生圣者不得上生故作是说。问彼对佛前作违理语。世尊何故不诃制之。答佛知彼言。虽复违理而不障道故不诃制。后入法性自当解了恐彼羞耻故不诃之。有说欲界经生圣者。亦有得生色无色界。问若尔增壹经说当云何通。如说有五补特伽罗。乃至广说。答圣者有二种。一有杂乱有移转。二无杂乱无移转。有杂乱有移转者。应知如帝问经说。无杂乱无移转者。应知如增壹经说。由斯理趣二说善通。评曰。若在欲界经生圣者定不复生色无色界。所以者何。若在欲界经生圣者必无三事。一者不退。二者不转根。三者不生色无色界。圣道久住彼相续中极坚牢故。恐上二界有长时苦同欲界故

说一切有部发智大毗婆沙论卷第五十三阿毗达磨大毗婆沙论卷第五十四

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中不善纳息第一之九

有五补特伽罗。谓随信行随法行信胜解见至身证。乃至广说。问何故尊者此结蕴中依五补特伽罗作论。后智定蕴中依七补特伽罗作论。谓于此五加慧解脱及俱解脱答是作论者意欲尔故。乃至广说。复次此结蕴中依有结者而作论故不说后二。智定蕴中依有智定者而作论故。有结无结者俱应说之。复次此结蕴中依有烦恼者而作论故不说后二。智定蕴中依有智定者而作论故。有烦恼无烦恼者俱应说之。复次此结蕴中以补特伽罗为章。以烦恼为门故不说后二。智定蕴中以补特伽罗为章。以智定为门故亦说后二。是故此彼依五依七补特伽罗而造于论。云何随信行补特伽罗。谓有一类。本来禀性多信多爱多恩多乐多随顺多胜解。不好思量观察简择。由彼禀性多信等故。有时遇佛或佛弟子为说法要教授教诫。广为开阐无常苦空无我等义。彼作是念。所为我说无常苦空无我等义甚为善哉。欲令我修如是观行。我应无倒精勤修学彼勤修学无常苦空无我等观。既淳熟已渐次引起世第一法。次复引生苦法智忍。从此见道十五刹那一切皆名随信行者。此随信行补特伽罗。或是预流向。或是一来向。或是不还向。谓若具缚或乃至断五品结已入正性离生。彼于见道十五心顷名预流向。若断六品或乃至断八品结已入正性离生。彼于见道十五心顷名一来向。若离欲染或乃至离无所有处染已入正性离生。彼于见道十五心顷名不还向。云何随法行补特伽罗。谓有一类。本来禀性多思多量多观察多简择。不好信爱思乐随顺及与胜解。由彼禀性多思等故。有时遇佛或佛弟子为说法要教授教诫。广为开阐无常苦空无我等义。彼作是念。所为我说无常苦空无我等义。我应观察。为实为虚审观察已知无颠倒。复作是念。甚为善哉。欲令我修如是观行。我应无倒精勤修学。所余广说如随信行。云何信胜解补特伽罗。谓随信行得道类智舍随信行得信胜解问彼于尔时何所舍得。答舍名得名舍道得道。舍名者舍随信行名。得名者得信胜解名。舍道者舍见道。得道者得修道。此信胜解补特伽罗。或是预流果。或是一来向。或是一来果。或是不还向。或是不还果。或是阿罗汉向。谓住预流果未胜进来名预流果。若从此胜进名一来向。若住一来果未胜进来名一来果。若从此胜进名不还向。若住不还果未胜进来名不还果。若从此胜进名阿罗汉向。云何见至补特伽罗。谓随法行得道类智。舍随法行。得见至。问彼于尔时何所舍得。答舍名得名舍道得道。舍名者舍随法行名。得名者得见至名。舍道者舍见道。得道者得修道。此见至补特伽罗。或是预流果。乃至或是阿罗汉向。如信胜解应说其相。云何身证补特伽罗。谓信胜解或见至以身具证八解脱未以慧尽诸漏。彼舍信胜解或见至得身证。问彼于尔时何所舍得。外国诸师作如是说。舍名得名舍道得道。舍名者舍信胜解或见至名。得名者得身证名。舍道者舍信胜解或见至道。得道者得身证道。迦湿弥罗国诸论师言。此舍名得名。非舍道得道。信胜解等得灭定时不舍不得无漏道故。云何慧解脱补特伽罗。谓信胜解或见至但以慧尽诸漏。未以身具证八解脱。彼舍信胜解或见至得慧解脱。问彼于尔时。何所舍得。答舍名得名舍道得道。舍名者舍信胜解或见至名。得名者得慧解脱名。舍道者舍修道。得道者得无学道。云何俱解脱补特伽罗。谓慧解脱或见至或身证。以身具证八解脱亦以慧尽诸漏。彼舍慧解脱或见至或身证得俱解脱。若先得阿罗汉果后得灭定。彼舍慧解脱得俱解脱。但舍名得名。非舍道得道如舍信胜解等得身证说。若先得灭定后得阿罗汉果。彼舍身证得俱解脱。舍名得名舍道得道。舍名者舍身证名。得名者得俱解脱名。舍道者舍修道。得道者得无学道。若诸菩萨证得无上正等菩提彼尽智时舍见至。得俱解脱。舍名得名舍道得道舍名者舍见至名。菩萨修位名见至故。得名者得俱解脱名。诸佛皆是俱解脱故。舍道者舍修道。得道者得无学道。西方师说。菩萨学位先起灭定后得菩提。彼舍身证得俱解脱。迦湿弥罗国诸论师言。三十四念得菩提故。菩萨学位未起灭定故。尽智时定舍见至得俱解脱。必无钝根未得灭定得尽智时成俱解脱故。无舍信胜解得俱解脱者

问何故名俱解脱。答障有二分。一烦恼障。二解脱障。于二分障心解脱故名俱解脱。问若先得阿罗汉果后得灭定者彼于解脱障何等心解脱。有漏耶无漏耶。有说有漏以无漏心得尽智时已解脱故。评曰应作是说。有漏无漏俱得解脱。所以者何。解脱有二种。一者行世解脱。二者在身解脱。彼未得灭定时入出定心不得行世。不行世故不得在身。若得灭定入出定心行世在身故名解脱。是故有漏无漏二心俱得解脱。如俱解脱依义立名。前五立名亦应依义。问何故名随信行。答由彼依信随信行故名随信行。谓依有漏信随无漏信行。依有缚信随解脱信行。依有系信随离系信行。由信为先得入圣道。如是种类补特伽罗从本以来性多信故。若闻他劝汝应务农以自存活彼不思察。我为应作为不应作。我为能作为不能作。为有宜便为无宜便。闻已便作。或闻他劝汝应商贾。或应事王。或应习学书算印等种种伎艺以自存活。亦不思察。广说乃至。闻已便作。或闻他劝汝应出家亦不思察。为应出家不应出家为能出家。不能出家。为能持戒不能持戒为有宜便为无宜便闻他劝已即便出家。既出家已。若闻他劝汝应诵习彼不思察。为应诵习不应诵习。为能诵习不能诵习。为有宜便为无宜便。为素怛缆。为毗柰耶。为阿毗达磨。闻他劝已即便诵习。或闻他劝营理僧事亦不思察。我为应作为不应作。我为能作为不能作。为有宜便为无宜便。闻已便作。或闻他劝住阿练若亦不思察。我为应住为不应住。我为能住为不能住。为有宜便为无宜便。闻已便住。彼渐次修圣道加行展转引起世第一法无间引生苦法智忍。从此见道十五刹那名随信行。问何故名随法行。答由彼依法随法行故名随法行。谓依有漏法随无漏法行。依有缚法随解脱法。行。依有系法随离系法行。由慧为先得入圣道。如是种类补特伽罗从本以来性多慧故。若闻他劝汝应务农以自存活。彼便思察。我为应作为不应作。我为能作为不能作。为有宜便为无宜便。审思察已然后作之。余广如前随信行说。彼渐次修圣道加行展转引起世第一法无间引生苦法智忍。从此见道十五刹那名随法行问随信行者。如有尔所信亦有尔所慧。随法行者。如有尔所慧亦有尔所信。何故一名随信行。一名随法行耶。答或但信他展转修行而入圣道。或自思察展转修行而入圣道。若但信他展转修行入圣道者名随信行。若自思察展转修行入圣道者名随法行。复次或由因力加行力不放逸力皆不广大而入圣道。或由三力皆悉广大而入圣道。若由三力皆不广大入圣道者名随信行。若由三力皆悉广大入圣道者名随法行。复次或由止行而入圣道。或由观行而入圣道。若由止行入圣道者名随信行。若由观行入圣道者名随法行。复次或乐奢摩他。或乐毗钵舍那乐奢摩他者名随信行。乐毗钵舍那名随法行。如乐喜欲亦尔

复次或由止为先而入圣道。或由观为先而入圣道。若由止为先入圣道者名随信行。若由观为先入圣道者名随法行。复次或有奢摩他增或有毗钵舍那增奢摩他增者名随信行。毗钵舍那增者名随法行。复次或由止熏心依观得解脱。或由观熏心依止得解脱。若由止熏心依观得解脱者名随信行若由观熏心依止得解脱者名随法行。复次或有钝根或有利根。若钝根者名随信行。若利根者名随法行复次或有说智或有开智。有说智者名随信行。有开智者名随法行。复次或由缘力而入圣道或由因力而入圣道若由缘力入圣道者名随信行。若由因力入圣道者名随法行。复次或得增上心奢摩他非增上慧毗钵舍那。或得增上慧毗钵舍那非增上心奢摩他。前名随信行。后名随法行。复次如世尊说二因二缘能生正见。一外闻他法音。二内如理作意。若外闻他法音多者名随信行。若内如理作意多者名随法行。复次如契经说。人有四法多有所作。一亲近善士。二听闻正法。三如理作意。四法随法行。若亲近善士听闻正法多者名随信行。若如理作意法随法行多者名随法行。复次或有多住无贪善根。或有多住无痴善根。多住无贪善根者名随信行。多住无痴善根者名随法行。复次或有外信有情。或有内思正法。外信有情者名随信行。内思正法者名随法行。问何故名信胜解。答由彼依信得信胜解故名信胜解。谓依见道所摄信得修道所摄信胜解。依向道所摄信得果道所摄信胜解。复次由彼补特伽罗以信为先心脱三结是故名信胜解。问何故名见至。答由彼依见得至于见故名见至。谓依见道所摄见得至修道所摄见。依向道所摄见得至果道所摄见。复次由彼补特伽罗以见为先心脱三结是故名见至。问信胜解亦应名信至见至亦应名见胜解。何故一名信胜解一名见至耶。答如信胜解名信胜解见至亦应名见胜解。如见至名见至信胜解亦应名信至。而不尔者欲现异相异门说法令诸智者爱乐受持不相杂乱。问何故名身证。答由彼以身证八解脱。未以慧尽诸漏故名身证。问何故名慧解脱。答由彼以慧尽诸漏未以身证八解脱故名慧解脱。俱解脱名如前已释

问如见道中依利钝别建立二种补特伽罗。谓随信行及随法行。修道中亦依利钝别建立二种补特伽罗。谓信胜解及见至。何故无学道中不依利钝别建立二种补特伽罗。而总说一。或慧解脱或俱解脱耶。答欲界乃至无所有处。或有漏道为断对治。或无漏道为断对治。若非想非非想处唯无漏道为断对治故。总立一补特伽罗。复次前位或有贪多行者。或有不者若离非想非非想处染时身等无贪故总立一补特伽罗。复次前位或有痴多行者。或有不者。若离非想非非想处染时身等无痴故总立一补特伽罗。复次前位或有慢多行者或有不者。若离非想非非想处染时身等无慢故总立一补特伽罗。复次以无学位解脱平等故总立一补特伽罗。如契经说。如来解脱与阿罗汉苾刍解脱等无差别。复次以无学位同剪三界烦恼重髻。同截有顶烦恼颈首。同越三界后有关津。同弃三界所有爱欲。故总立一补特伽罗。有作是说。无学位中亦有二种补特伽罗谓时解脱不时解脱。问若尔唯应建立二种补特伽罗。谓钝及利。或应立六补特伽罗。谓见修无学位各有二种。即随信行乃至第六不时解脱。如何立七补特伽罗。答由五缘故建立七种。一由加行故。二由根故三由定故。四由解脱故。五由定及解脱故。由加行故者。谓随信行及随法行。由根故者谓信胜解。及见至。由定故者谓身证。由解脱故者谓慧解脱。由定及解脱故者谓俱解脱

随信行者或应说一。谓七种中名随信行。或应说三谓由根故即下中上。或应说五谓由种性故。即退法乃至堪达。或应说十五。谓由道故。即苦法智忍乃至道类智忍位。或应说七十三。谓由离染故。即欲界具缚离一品乃至九品染为十。离初静虑一品乃至九品染为九。欲界第十。即初静虑具缚者故不别说。后类应知。乃至离无所有处一品乃至九品染为九合七十三。或应说六百五十七。谓由所依故。即三洲六欲天所依各有前说七十三种。若以根种性道离染所依二合三合四合五合其数增长如理应思。若以在身刹那分析应说无量。随信行者此中总说一随信行。如随信行数随法行亦尔。根道离染所依等故。唯种性别以随法行唯是不动种性摄故。信胜解者或应说一。谓七种中名信胜解。或应说三。谓由根故。或应说五谓由种性故。或应说八十一谓由离染故。即欲界具缚离一品乃至九品染为十。离初静虑乃至无所有处各一品乃至九品染为六十三。离非想非非想处一品乃至八品染为八合八十一。有说离染故应说八十二。谓前说八十一加离有顶第九品染无间道时。或应说四百五。谓由所依故即欲界所依有八十一。初静虑所依有七十二。第二静虑所依有六十三。第三静虑所依有五十四。第四静虑所依有四十五。空无边处所依有三十六。识无边处所依有二十七。无所有处所依有十八。非想非非想处所依有九谓彼具缚及离一品乃至八品染为九合四百五。有说此应说四百一十四。谓欲界所依有八十二。初静虑所依有七十三。第二静虑所依有六十四。第三静虑所依有五十五第四静虑所依有四十六。空无边处所依有三十七。识无边处所依有二十八。无所有处所依有十九。非想非非想处所依有十。谓彼具缚及离一品乃至八品染为九。离第九品无间道时为彼第十。此依九地所依分别。若依二十九处所依分别其数多少如理应思。以根种性离染所依二三四合数更增广。若以在身刹那分折应说无量。信胜解者此中总说一信胜解如信胜解见至亦尔。根及离染所依等故。唯种性别以诸见至唯是不动种性摄故。身证者或应说一谓七种中名身证。或应说三。谓由根故或应说六谓由种性故。即退法乃至不动法。或应说九。谓由离染故即非想非非想处具缚及离一品乃至八品染为九。复有说者。此应说十。谓即前九加离第九无间道时为彼第十。或应说二十七。谓由所依故。欲界所依有九。色界所依有九。无色界所依有九。此唯非想非非想处。非三无色。得灭定者不生彼故。有说此应说三十。谓三界各加第九无间道时。此依三界所依分别。若依地处所依分别其数多少如理应思。以根种姓离染所依二三四合数更增广若以在身刹那分折有无量。身证者此中总说为一身证慧解脱者或应说一谓七种中名慧解脱。或应说三。谓由根故。或应说六。谓由种性故。或应说九谓由所依故。即欲界乃至非想非非想处所依此依九地所依分别。若依二十九处所依分别成二十九。若以根种性所依二三合数如理应思。若以在身刹那分折即有无量慧解脱者此中总说一慧解脱。如慧解脱数俱解脱亦尔。有差别者谓彼所依以俱解脱不在下三无色处故

此五补特伽罗于三结乃至九十八随眠。几成就几不成就。此中尊者以补特伽罗为章以诸烦恼为门故作斯问答随信行于三结苦类智未已生皆成就。苦类智已生二成就一不成就。二成就者谓戒禁取疑。彼通三界二四部故。一不成就者谓萨迦耶见。彼唯通三界见苦所断故。于三不善根未离欲染皆成就。已离欲染皆不成就。此三唯是欲界系故。已离欲染者彼异生位先已离故后准应知。于三漏未离欲染皆成就。已离欲染二成就一不成就。二成就者谓有漏无明漏。一不成就者谓欲漏。于四瀑流轭取未离欲染皆成就。已离欲染三成就一不成就。三成就者谓有见无明瀑流轭见戒禁我语取。一不成就者谓欲瀑流轭取。于四身系未离欲染皆成就。已离欲染二成就二不成就。二成就者谓戒禁取此实执身系。二不成就者谓贪欲嗔恚身系。于五盖未离欲染道法智未已生皆成就。道法智已生四成就一不成就。已离欲染皆不成就。五盖唯是欲界系故。四成就者谓前四盖一不成就者谓疑盖。道法智已生彼已断故。于五结未离欲染皆成就。已离欲染二成就三不成就。二成就者谓贪慢结。通三界系故。三不成就者谓嗔嫉悭结。唯欲界系故。于五顺下分结未离欲染苦类智未已生皆成就。苦类智已生。四成就一不成就。四成就者谓初后各二。一不成就者谓有身见。已离欲染苦类智未已生三成就二不成就。三成就者谓后三。二不成就者谓初二。苦类智已生二成就三不成就。二成就者。谓后二。三不成就者。谓初三。于五顺上分结未离色染皆成就。已离色染四成就一不成就。四成就者。谓除色贪。一不成就者。谓色贪。于五见苦类智未已生皆成就。苦类智已生三成就二不成就。三成就者。谓后三。二不成就者。谓初二。于六爱身未离欲染皆成就。已离欲染未离梵世染。四成就二不成就。四成就者。谓初后各二。二不成就者。谓鼻舌触所生爱身。已离梵世染。一成就五不成就。一成就者。谓第六。五不成就者。谓前五。于七随眠未离欲染皆成就。已离欲染五成就二不成就。五成就者。谓有贪等五。二不成就者。谓欲贪嗔恚。于九结未离欲染皆成就。已离欲染六成就三不成就。六成就者。谓爱等六。三不成就者。谓恚嫉悭。于九十八随眠未离欲染。苦法智未已生。皆成就者。谓具缚者苦法智忍时一切随眠无不成就。余广说如本论。问何故不说道类智已生耶。答彼若已生非随信行。是故不说。如随信行随法行亦尔。此二地道离染所依。若定若生无不皆等唯根有异。谓钝根者名随信行。利根者名随法行故。信胜解于三结皆不成就彼唯见所断故。于三不善根未离欲染皆成就已离欲染皆不成就。彼唯欲界系故。未离欲染者。谓预流果一来向一来果不还向。已离欲染者。谓不还果阿罗汉向。彼或异生位已离欲染。或至圣位方离欲染后准应知。于三漏未离欲染皆成就。已离欲染二成就一不成就。二成就者。谓有漏无明漏。一不成就者。谓欲漏于四瀑流轭。未离欲染三成就一不成就。三成就者。谓欲有无明瀑流轭。一不成就者。谓见瀑流轭。已离欲染二成就二不成就。二成就者。谓有无明瀑流轭。二不成就者。谓欲见瀑流轭。于四取未离欲染二成就二不成就。二成就者。谓欲我语取。二不成就者。谓见戒禁取。已离欲染一成就三不成就。一成就者。谓后一。三不成就者。谓前三。于四身系未离欲染二成就二不成就。二成就者。谓前二。二不成就者。谓后二。已离欲染皆不成就。前二唯欲界系。后二唯见所断故。于五盖未离欲染四成就一不成就。四成就者谓前四。一不成就者谓后一。已离欲染皆不成就。前四后一皆欲界系故。于五结未离欲染皆成就。已离欲染二成就三不成就。二成就者。谓贪慢结。三不成就者。谓嗔嫉悭。于五顺下分结。未离欲染二成就三不成就。二成就者。谓前二。三不成就者。谓后三。已离欲染皆不成就。前二欲界系。后三见所断故。于五顺上分结。未离色染皆成就。已离色染四成就一不成就。四成就者。谓除色贪。一不成就者。谓色贪。于五见皆不成就彼唯见所断故。于六爱身未离欲染皆成就。已离欲染未离梵世染四成就二不成就。四成就者。谓初后各二。二不成就者。谓中间二。已离梵世染一成就五不成就。一成就者。谓后一。五不成就者。谓前五。于七随眠。未离欲染五成就二不成就。五成就者。谓欲贪嗔恚有贪慢无明。二不成就者谓见疑。已离欲染三成就四不成就。三成就者。谓有贪慢无明。四不成就者。谓余四。于九结未离欲染六成就三不成就。六成就者。谓爱恚慢无明嫉悭结。三不成就者。谓见取疑结。已离欲染三成就六不成就。三成就者。谓爱慢无明。六不成就者。谓余六。于九十八随眠。未离欲染十成就八十八不成就。十成就者。谓三界修所断。八十八不成就者。谓三界见所断。已离欲染未离色染六成就九十二不成就。六成就者。谓色无色界修所断。九十二不成就者。谓三界见所断。及欲界修所断。已离色染三成就九十五不成就。三成就者。谓无色界修所断。九十五不成就者。谓三界见所断。及欲色界修所断。如信胜解见至亦尔。此二地道离染所依。若定若生无不皆等。唯根有异。谓钝根者名信胜解。利根者名见至故。身证于三结三不善根皆不成就。以三结唯见所断故。三不善根唯欲界系故。身证必已离三界见所断及下八地修所断故。于三漏二成就一不成就。二成就者。谓有无明漏。一不成就者。谓欲漏。于四瀑流轭。二成就二不成就。二成就者。谓有无明。二不成就者。谓欲见。于四取一成就三不成就。一成就者。谓我语取。三不成就者。谓余三取。于四身系及五盖皆不成就。前二身系及五盖唯欲界系故。后二身系唯见所断故。于五结二成就三不成就。二成就者。谓贪慢结。三不成就者。谓嗔嫉悭结。于五顺下分结皆不成就。前二唯欲界系。后三唯见所断故。于五顺上分结。四成就一不成就。一不成就者。谓色贪。四成就者。谓余四。于五见皆不成就于见所断久已离故。于六爱身一成就五不成就。一成就者。谓第六。五不成就者。谓前五。于七随眠三成就四不成就。三成就者。谓有贪慢无明。四不成就者。谓余四。于九结三成就六不成就。三成就者。谓爱慢无明。六不成就者。谓余六。于九十八随眠。三成就九十五不成就。三成就者谓无色界修所断。九十五不成就者。谓三界见所断。及欲色界修所断问颇有圣者成就九十八随眠耶。答有。谓具缚者入正性离生住苦法智忍时。问颇有圣者已断八十八随眠。未断十随眠而未得果耶。答有。谓已离色染入正性离生住灭类智时。彼欲界三十六随眠。色界三十一随眠。无色界见苦集灭所断二十一随眠已断。未断无色界见道所断七及修所断三随眠而未得果住向道故。问颇有已断九十八随眠而未得阿罗汉果耶。答有谓已离无所有处染未离非想非非想处染。彼已断欲界三十六随眠。色界三十一随眠下三无色三十一随眠。而未得阿罗汉果彼或是异生。或是不还者故。评曰彼不应作是说。九十八随眠依界建立不依地故。由此彼问应答言无

说一切有部发智大毗婆沙论卷第五十四阿毗达磨大毗婆沙论卷第五十五

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中不善纳息第一之十

有身见与有身见为几缘。有身见与戒禁取。乃至无色界修所断无明随眠为几缘。乃至无色界修所断无明随眠与无色界修所断无明随眠为几缘。无色界修所断无明随眠与有身见乃至无色界修所断慢随眠为几缘。乃至广说。问何故作此论。客为止他宗显己义故。谓或有执。缘无实性如譬喻者。问彼师何故作此执耶。答彼依契经故作是执。谓契经说无明缘行。彼作是言。无明无异相。行有异相。云何无异相法与有异相法作缘而有实性。大德说曰。诸师随想施设缘名非实有性。为遮彼执显实有缘故作斯论。若执诸缘无实性者。应一切法皆无实性。四缘具摄一切法故。谓因缘摄一切有为法。等无间缘除过去现在阿罗汉最后心心所法。摄余过去现在一切心心所法。所缘缘增上缘总摄一切法复次若诸缘性非实有者。则一切法无甚深义。谓若显示一切法时。若不摄在诸缘观察则为粗浅易可了知。若摄在缘而观察者。则为甚深过四大海。唯佛种智能究竟知

复次若诸缘性非实有者。应不施设三种菩提。谓以上智观察缘性名佛菩提若以中智观察缘性名独觉菩提。若以下智观察缘性名声闻菩提

复次若诸缘性非实有者。觉慧应无三品转义。谓诸觉慧下应常下。中应常中。上应常上。然诸觉慧下可为中。中可为上。故诸缘性定实有体。有功能故。由此尊者妙音说曰。若诸缘性非实有者。师应不能令弟子慧初劣后胜。弟子亦应常为弟子不转成师。然由诸缘性实有故。师令弟子慧得渐增。弟子有时得成师义。故诸缘性决定实有。问若诸缘性是实有者。云何通彼所引契经

答无明自体虽无异相而所作业得有异相。谓无量门无量梯蹬。功能差别与行作缘。譬如一人有五伎艺。彼体虽一而用有五。复次为欲显示诸有为法自性羸劣。不得自在。依怙于他。无自作用。不随己欲故作斯论。自性羸劣者。谓诸有为法从缘生性立自性名。有说。有为有生灭故自性羸劣。有说。有为从缘生故自性羸劣。如契经说。苾刍当知。色是无常。诸因诸缘能生色者亦是无常。既是无常因缘所起色云何常。受想行识亦复如是。由羸劣故诸有为法。或四缘生或三缘生或二缘生。尚无一缘独能生者。何况无缘。故有为法自性羸劣。如羸病者。或四人扶或三人扶。或二人扶方能起住。尚无一人独令起住。何况无人。不得自在者。谓诸有为法无自力用而可得生。依怙于他者。谓诸有为法必依怙他方能起用无自作用者。谓诸有为法不能自起分别作用。谁造于我我为造谁。不随己欲者。谓诸有为法无自欲乐勿令我生勿令我灭而得遂者。复次为欲开示迷缘起者。缘起正理故作斯论。谓或有执。唯有无明缘行乃至生缘老死是缘起法。为令彼迷得开解故。显有为法皆是缘起。众世所言。此中应说。复次勿为止他显己宗义。但欲开示缘起正理令他得解故作斯论

答有身见与有身见为或四三二一缘。问何故此中问有身见与有身见为几缘。答言为或四三二一缘。后智蕴中问法智与法智为几缘答言因等无间所缘增上耶。答是作论者意欲尔故。乃至广说。复次此彼应同而有异者。是作论者以种种说作种种文庄严于义。使不杂乱令易受持

复次为欲显示二门二略二阶二蹬二炬二明二文二影。如此所说彼亦应然。如彼所说此亦应然。故作是说。复次此说是了义彼说不了义。此说无别意彼说有别意。此说无别因彼说有别因。此说是胜义彼说是世俗。复次此所作论依四分别。一分别界。二分别世。三分别刹那。四分别等无间缘。彼所作论依一分别。谓但分别等无间缘。故此所说与彼有异。此中四者云何四。如有身见无间起有身见。即思惟彼前生与后生为四缘。谓一刹那有身见无间。第二刹那有身见现在前。此后所生即缘前起。彼前与后具作四缘。谓因等无间所缘增上缘。因缘者。谓前生有身见与后生有身见为二因。谓同类因及遍行因。等无间缘者。谓后生有身见从前生有身见无间而生。所缘缘者。谓后生有身见缘前生有身见而生。增上缘者。谓前于后或唯无障或不碍生。此中因缘如种子法。等无间缘如开避法。所缘缘如任杖法。增上缘如不障法。后生有身见由前生有身见为四缘摄受故。能行世能取果能作业能知缘。此中三者云何三。如有身见无间起有身见不思惟彼前生与后生为三缘。除所缘谓一刹那有身见无间。第二刹那有身见现在前。此后所生不缘前起。谓或缘色受想行识。或除前有身见缘所余行蕴。彼前与后但作三缘。谓因等无间增上缘。释此三缘如前广说。后生有身见由前生有身见为三缘摄受故。能行世能取果能作业能知缘。或有身见无间起余心后起有身见。即思惟彼前生与后生为三缘除等无间。谓一刹那有身见无间。第二刹那有身见不现在前。或边执见或邪见或见取或戒禁取或疑或贪或嗔或慢或无明或有漏善或无覆无记心现在前。此后还起有身见即缘前生有身见。彼前与后但作三缘谓因所缘增上缘。释此三缘如前广说。后生有身见由前生有身见为三缘摄受故。能行世能取果能作业能知缘。此中二者云何二。如有身见无间起余心后起有身见。不思惟彼前生与后生为二缘。谓因增上。谓一刹那有身见无间。第二刹那有身见不现在前。或边执见乃至或无覆无记心现在前。此后还起有身见不缘前生有身见。谓或缘色受想行识。或除有身见缘所余行蕴彼前与后但作二缘。谓因增上缘。释此二缘如前广说。后生有身见由前生有身见为二缘摄受故。能行世能取果能作业能知缘。此中一者云何一。后生有身见与前生有身见。若作所缘为所缘增上。不作所缘一增上。以后与前无因缘无等无间缘义故。问何故此中问一答二。答论者作论立法非一。或有先遮后答。或有先答后遮。先遮后答者。如此中说。若作所缘为所缘增上者是遮二缘。不作所缘一增上者。是答一缘。先答后遮者如一行纳息说。若前生未断则系者是答系。若前未生设生已断则不系者是遮不系。复有说者。此俱是答。谓后与前若作所缘便为二缘答前二问。不作所缘但为一缘答此一问。前答二中但答一分。所未答者此中答之。后准此释未来有身见与过去现在有身见。若作所缘为所缘增上。不作所缘一增上。未来现在有身见与过去有身见。若作所缘为所缘增上。不作所缘一增上。问现在有身见正有作用可能缘境。过去有身见作用已息如何能缘。而此中说若作所缘为所缘增上。答过去有身见曾在现在时缘彼已灭。今虽过去追谈彼用故作是说。问此中前说后生有身见与前生有身见。若作所缘。为所缘增上。不作所缘一增上者。说过去后生有身见与过去前生有身见为二一缘。何故不说未来有身见与未来有身见为二一缘耶。答应说而不说者。当知此义有余。复次此中但说有前后者。彼无前后故略不说。问未来生位与未生者岂无前后。答世无别故不名前后。问若尔过去前生后生世既无别应非前后。答彼法曾在现在等时有世别义故成前后。未来不尔故略不说。欲界有身见与色无色界有身见为一增上。谓欲界有身见于上二界有身见。或唯无障或不碍生故为一增上缘。非因缘者。谓界地别因果断故。非等无间缘者。谓无下地烦恼无间上地烦恼现在前故。非所缘缘者。谓决定无上地烦恼缘下义故。色无色界有身见与欲界有身见。若作等无间为等无间增上。不作等无间一增上。谓若住色无色界有身见俱生心而命终起欲界有身见俱生心而结生者。彼色无色界有身见与欲界有身见为等无间增上缘非因缘者义如前说。非所缘缘者。谓诸有身见不缘他地故。若不住色无色界有身见俱生心而命终起欲界有身见俱生心而结生者。彼色无色界有身见与欲界有身见但为一增上缘。非等无间缘者。谓彼欲界有身见非色无色界有身见无间生故。非余二缘义如前说。色界有身见与无色界有身见为一增上义如前说。无色界有身见与色界有身见。若作等无间为等无间增上。不作等无间一增上。此中诸义。准前应知。如有身见与有身见。应知有身见与余一切非遍行。余一切非遍行与一切非遍行。一切遍行与一切非遍行亦尔。谓诸随眠类别有十。即五见五非见。五见者。谓有身见边执见邪见见取戒禁取。五非见者。谓疑贪嗔慢无明。此中五名遍行。谓邪见见取戒禁取疑无明。五名非遍行。谓有身见边执见贪嗔慢。此中有身见边执见虽遍缘自地故名遍行。而不缘他地故亦名非遍行。由此摄在非遍行中如有身见与有身见。应知有身见与余一切非遍行亦尔者。如有身见与有身见为缘多少。有身见与余一切边执见贪嗔慢。为缘多少亦尔。余一切非遍行与一切非遍行亦尔者。如有身见与有身见为缘多少。边执见与边执见贪嗔慢有身见。贪与贪嗔慢有身见边执见。嗔与嗔慢有身见边执见贪。慢与慢有身见边执见贪嗔为缘多少亦尔。一切遍行与一切非遍行亦尔者。如有身见与有身见为缘多少。邪见见取戒禁取疑无明。一一与有身见边执见贪嗔慢为缘多少亦尔。有身见与戒禁取为缘。或四三二一缘。此中四者云何四。如有身见无间起戒禁取。即思惟彼前生与后生为四缘。谓有身见刹那无间戒禁取刹那现在前。此后所生即缘前起。彼前与后具作四缘。谓因等无间所缘增上缘。因缘者。谓前生有身见与后生戒禁取为二因。谓同类因及遍行因。等无间缘者。谓后生戒禁取从前生有身见无间而生。所缘缘者。谓后生戒禁取缘前生有身见而生。增上缘者。谓前于后或唯无障或不碍生。此中因缘如种子法。等无间缘如开避法。所缘缘如任杖法。增上缘如不障法。后生戒禁取由前生有身见为四缘摄受故。能行世能取果能作业能知缘。此中三者云何三。如有身见无间起戒禁取。不思惟彼前生与后生为三缘除所缘缘。谓有身见刹那无间戒禁取刹那现在前。此后所生戒禁取不缘前有身见起。谓或缘色受想行识。或除有身见缘所余行蕴。彼前生有身见与后生戒禁取但作三缘。谓因等无间增上缘。释此三缘如前广说。后生戒禁取由前生有身见为三缘摄受故。能行世能取果能作业能知缘。或有身见无间起余心后起戒禁取。即思惟彼前生与后生为三缘除等无间。谓有身见刹那无间戒禁取刹那不现在前。或有身见或边执见或邪见或见取或疑或贪或嗔或慢或无明或有漏善或无覆无记心现在前。此后方起戒禁取即缘前生有身见。彼前生有身见与后生戒禁取但作三缘。谓因所缘增上缘。释此三缘如前广说。后生戒禁取由前生有身见为三缘摄受故。能行世能取果能作业能知缘。此中二者云何二如有身见无间起余心后起戒禁取。不思惟彼前生与后生为二缘。谓因增上。谓有身见刹那无间戒禁取刹那不现在前。或有身见乃至无覆无记心现在前。此后方起戒禁取不缘前生有身见。谓或缘色受想行识。或除有身见缘所余行蕴彼前生有身见与后生戒禁取但作二缘。谓因增上缘。释此二缘如前广说。后生戒禁取由前生有身见为二缘摄受故。能行世能取果能作业能知缘。此中一者云何一。后生有身见与前生戒禁取。若作所缘为所缘增上。不作所缘一增上。以后与前无因缘无等无间缘义故。此中问答如前应知。未来有身见与过去现在戒禁取。若作所缘为所缘增上。不作所缘一增上。未来现在有身见与过去戒禁取。若作所缘为所缘增上。不作所缘一增上。此中问答如前应知。欲界有身见与色无色界戒禁取为一增上。谓欲界有身见于上二界戒禁取。或唯无障或不碍生故为一增上缘。非因缘者。谓界地别因果断故。非等无间缘者。谓无下地烦恼无间上地烦恼现在前故。非所缘缘者。谓决定无上地烦恼缘下义故。色无色界有身见与欲界戒禁取。若作所缘非等无间。为所缘增上。谓若不住色无色界有身见俱生心而命终起欲界戒禁取俱生心而结生。此欲界戒禁取缘色无色界有身见起。彼色无色界有身见与欲界戒禁取。为所缘增上缘。非因缘者义如前说。非等无间缘者。谓彼欲界戒禁取非色无色界有身见无间生故。若作等无间非所缘。为等无间增上。谓若住色无色界有身见俱生心而命终起欲界戒禁取俱生心而结生。此欲界戒禁取不缘色无色界有身见起。彼色无色界有身见与欲界戒禁取为等无间增上缘。非因缘者义如前说。非所缘缘者此不缘彼故。若作等无间及所缘。为等无间所缘增上。谓若住色无色界有身见俱生心而命终起欲界戒禁取俱生心而结生。此欲界戒禁取缘色无色界有身见起。彼色无色界有身见与欲界戒禁取为等无间所缘增上。非因缘者义如前说。不作等无间及所缘。一增上。谓若不住色无色界有身见俱生心而命终起欲界戒禁取俱生心而结生。此欲界戒禁取不缘色无色界有身见起。彼色无色界有身见与欲界戒禁取但为一增上缘。非余三缘义如前说。色界有身见与无色界戒禁取为一增上义如前说。无色界有身见与色界戒禁取。若作所缘非等无间为所缘增上。若作等无间非所缘。为等无间增上。若作等无间及所缘。为等无间所缘增上不作等无间及所缘一增上。此中诸义准前应知。如有身见与戒禁取。应知有身见与余一切遍行。一切遍行与一切遍行。余一切非遍行与一切遍行亦尔。如有身见与戒禁取。应知有身见与余一切遍行亦尔者。如有身见与戒禁取为缘多少。有身见与邪见见取疑无明为缘多少亦尔。一切遍行与一切遍行亦尔者。如有身见与戒禁取为缘多少。邪见与邪见见取戒禁取疑无明。见取与见取戒禁取疑无明邪见。戒禁取与戒禁取疑无明邪见见取。疑与疑无明邪见见取戒禁取。无明与无明邪见见取戒禁取疑为缘多少亦尔。余一切非遍行与一切遍行亦尔者。如有身见与戒禁取为缘多少。边执见贪嗔慢一一与邪见见取戒禁取疑无明为缘多少亦尔

于诸法中。若问摄应依界分别。若问智应依谛分别。若问识应依处分别。若问烦恼应依部分别。如是分别诸法相时。则易示现易可施设。此中问烦恼故应依五部分别。五部者。谓见苦所断见集灭道及修所断。见苦所断烦恼有二种。一遍行。二不遍行。见集所断烦恼亦尔。见灭所断烦恼有二种。一有漏缘。二无漏缘。见道所断烦恼亦尔。修所断烦恼唯有一种。谓不遍行。此中见苦所断遍行烦恼与见苦所断遍行烦恼为四缘。谓因等无间所缘增上。因缘者有四因。谓相应俱有同类遍行。等无间缘者。谓见苦所断遍行烦恼无间见苦所断遍行烦恼现在前。所缘缘者。谓见苦所断遍行烦恼缘见苦所断遍行烦恼而生。增上缘者。谓此与彼唯无障生。见苦所断遍行烦恼与见苦所断不遍行烦恼为四缘。因缘者有二因谓同类遍行。等无间缘者。谓见苦所断遍行烦恼无间。见苦所断不遍行烦恼现在前。所缘缘者。谓见苦所断不遍行烦恼缘见苦所断遍行烦恼而生。增上缘如前说见苦所断遍行烦恼与见集所断遍行烦恼为四缘。因缘者唯一因。谓遍行。等无间缘者。谓见苦所断遍行烦恼无间。见集所断遍行烦恼现在前。所缘缘者。谓见集所断遍行烦恼缘见苦所断遍行烦恼而生。增上缘如前说。见苦所断遍行烦恼与见集所断不遍行烦恼。及见灭道修所断一切烦恼为三缘。除所缘。因缘者。唯一因。谓遍行。等无间缘者。谓见苦所断遍行烦恼无间。彼诸烦恼现在前。增上缘如前说。非所缘缘者。彼诸烦恼不能缘他部非遍行故。见苦所断不遍行烦恼与见苦所断不遍行烦恼为四缘。因缘者有三因。谓相应俱有同类等无间缘者。谓见苦所断不遍行烦恼无间。见苦所断不遍行烦恼现在前。所缘缘者。谓见苦所断不遍行烦恼。缘见苦所断不遍行烦恼而生。增上缘如前说见苦所断不遍行烦恼。与见苦所断遍行烦恼为四缘因缘者。唯一因。谓同类。等无间缘者。谓见苦所断不遍行烦恼无间。见苦所断遍行烦恼现在前。所缘缘者。谓见苦所断遍行烦恼。缘见苦所断不遍行烦恼而生增上缘如前说见苦所断不遍行烦恼。与见集所断遍行烦恼为三缘。除因。等无间缘者。谓见苦所断不遍行烦恼无间。见集所断遍行烦恼现在前。所缘缘者。谓见集所断遍行烦恼。缘见苦所断不遍行烦恼而生。增上缘如前说非因缘者。非遍行法不与他部烦恼为因。见苦所断不遍行烦恼。与见集所断不遍行烦恼。及见灭道修所断一切烦恼为等无间增上缘等无间缘者。谓见苦所断不遍行烦恼无间。彼诸烦恼现在前。增上缘如前说。非余二缘者。不遍行法定非他部染法因故。不遍行惑定不能缘他部法故。如见苦所断二种烦恼与九种烦恼为缘多少。见集所断二种烦恼与九烦恼为缘多少应知亦尔。见灭所断有漏缘烦恼。与见灭所断有漏缘烦恼为四缘。因缘者有三因谓相应俱有同类。等无间缘者。谓见灭所断有漏缘烦恼无间见灭所断有漏缘烦恼现在前。所缘缘者。谓见灭所断有漏缘烦恼缘见灭所断有漏缘烦恼而生。增上缘如前说。见灭所断有漏缘烦恼。与见灭所断无漏缘烦恼为三缘。除所缘。因缘者唯一因。谓同类。等无间缘者。谓见灭所断有漏缘烦恼无间。见灭所断无漏缘烦恼现在前。增上缘如前说非所缘缘者。谓见灭所断无漏缘烦恼唯缘择灭。非烦恼故。见灭所断有漏缘烦恼与见苦集所断遍行烦恼为三缘。除因等无间缘者。谓见灭所断有漏缘烦恼无间。见苦集所断遍行烦恼现在前。所缘缘者。谓见苦集所断遍行烦恼。缘见灭所断有漏缘烦恼而生。增上缘如前说。非因缘者非遍行法于他部染无因义故。见灭所断有漏缘烦恼。与见苦集所断不遍行烦恼。及见道修所断一切烦恼为等无间增上缘。非因非所缘。等无间缘者。谓见灭所断有漏缘烦恼无间。彼诸烦恼现在前。增上缘如前说。非因缘义亦如上说。非所缘缘者。彼诸烦恼非遍行故不缘他部。见灭所断无漏缘烦恼。与见灭所断无漏缘烦恼为三缘。除所缘。因缘者有三因。谓相应俱有同类等无间缘者。谓见灭所断无漏缘烦恼无间。见灭所断无漏缘烦恼现在前。增上缘如前说。非所缘缘者。彼缘择灭非烦恼故。见灭所断无漏缘烦恼。与见灭所断有漏缘烦恼为四缘。因缘者唯一因。谓同类。等无间缘者。谓见灭所断无漏缘烦恼无间。见灭所断有漏缘烦恼现在前。所缘缘者。谓见灭所断有漏缘烦恼。缘见灭所断无漏缘烦恼而生。增上缘如前说。见灭所断无漏缘烦恼。与见苦集所断遍行烦恼为三缘。除因。等无间缘者。见灭所断无漏缘烦恼无间。见苦集所断遍行烦恼现在前。所缘缘者。见苦集所断遍行烦恼。缘见灭所断无漏缘烦恼而生。增上缘如前说。非因缘者。不遍行惑与他部染不为因故。见灭所断无漏缘烦恼。与见苦集所断不遍行烦恼及见道修所断一切烦恼。为等无间增上缘。非因非所缘。等无间缘者。谓见灭所断无漏缘烦恼无间。彼诸烦恼现在前。增上缘如前说。非因缘者。不遍行惑与他部染无因义故。非所缘缘者。彼诸烦恼不遍行故不缘他部。如见灭所断二种烦恼。与九种烦恼为缘多少。见道所断二种烦恼。与九烦恼为缘多少应知亦尔。修所断烦恼与修所断烦恼为四缘。因缘者有三因。谓相应俱有同类。等无间缘者。谓修所断烦恼无间。修所断烦恼现在前。所缘缘者。谓修所断烦恼。缘修所断烦恼而生。增上缘如前说。修所断烦恼。与见苦集所断遍行烦恼为三缘。除因。等无间缘者。谓修所断烦恼无间。见苦集所断遍行烦恼现在前。所缘缘者。谓见苦集所断遍行烦恼。缘修所断烦恼而生。增上缘如前说。非因缘者。非遍行法不为他部染法因故。修所断烦恼。与见苦集所断不遍行烦恼。及见灭道所断一切烦恼。为等无间增上缘。非因非所缘。等无间缘者。谓修所断烦恼无间。彼诸烦恼现在前。增上缘如前说。非因缘者。非遍行法不为他部染法因故。非所缘缘者。不遍行惑皆不能缘他部法故又诸烦恼有十五部。谓三界各有见苦乃至修所断五部。于中一一与十五部为缘多少如理应思。又一一界五部烦恼分为九种。合二十七。于中一一与二十七为缘多少如理应思

说一切有部发智大毗婆沙论卷第五十五阿毗达磨大毗婆沙论卷第五十六

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中一行纳息第二之一

有九结。谓爱结乃至悭结。若于此事有爱结系亦有恚结系耶。如是等章及解章义。既领会已。次应广释。此中事者。事有五种。一自体事。二所缘事。三系事。四因事。五摄受事。自体事者。如见蕴说。若事能通达彼事能遍知耶。设事能遍知彼事能通达耶彼于诸忍诸智自体以事声说即彼复说若事已得彼事成就耶。设事成就彼事已得耶。此中有说。一切法自体以事声说。有作是说。若法有得者以事声说。所缘事者。如品类足说。一切法皆是智所知随其事。云何随其事。谓若法是此智所行境。彼于所缘以事声说。然契经说。当为汝等说四十四智事及七十七智事者。阿毗达磨诸论师言。彼经说自体事。谓诸忍智缘有支者以事声说。尊者妙音作如是说。彼经说所缘事。谓诸忍智所缘有支以事声说。系事者。如此中说。若于此事有爱结系亦有恚结系耶。乃至广说。此中五部法以事声说。谓见苦集灭道修所断法。是五部烦恼所系事故说名系事。因事者。如品类足说。云何有事法。云何无事法。彼意说有因法无因法。又伽他说

  苾刍心寂静　　能永断诸事
  彼生死尽故　　不受于后有

彼颂意说。一切生死皆依于因。有因故有生死。因断故生死尽。由此不复受未来三有生摄受事者。如契经说。应舍田事宅事财事摄受之心。应离田事宅事财事摄受之业。又伽他说

  若于田事财　　牛马等僮仆
  男女亲别欲　　是人名极贪

又在家者作如是言。我摄此事我持此事。诸如是等名摄受事。复有五事。一界事。二处事。三蕴事。四世事。五刹那事。于此十事。此中但依系事作论。不依余九

阿毗达磨诸论师言。所系事是实能系结亦实。补特伽罗是假。犊子部说。所系事是实。能系结亦实。补特伽罗亦是实。譬喻者说能系结是实。所系事是假补特伽罗亦假。问彼何故说所系事是假耶。答彼说有染与无染境不决定故知境非实。谓如有一端正女人种种庄严来入众会。有见起敬有见起贪。有见起嗔。有见起嫉。有见起厌有见起悲。有见生舍。应知此中子见起敬。诸耽欲者见而起贪。诸怨憎者见而起嗔。诸同夫者见而起嫉。诸有修习不净观者见而起厌。诸离欲仙见起悲愍。作如是念。此妙色相不久当为无常所灭。诸阿罗汉见而生舍。由此故知境无实体。彼说非理。所以者何。若境非实。应不作缘生心心所。若尔应无染净品法。补特伽罗定非实有。佛说无我无我所故

诸烦恼有与五识相应。有与意识相应。五识相应者。若在过去系过去事。若在现在系现在事。若在未来生法者系未来事。不生法者系三世事。意识相应者。若在过去若在未来若在现在。皆容系三世事。复次眼识相应烦恼于色处作所缘系。于彼相应意处法处作相应系。耳识相应烦恼于声处作所缘系。于彼相应意处法处作相应系。鼻识相应烦恼于香处作所缘系。于彼相应意处法处作相应系。舌识相应烦恼于味处。作所缘系。于彼相应意处法处作相应系。身识相应烦恼于触处作所缘系。于彼相应意处法处作相应系意识相应烦恼于十二处作所缘系。于彼相应意处法处作相应系。是谓一行略毗婆沙。若于此事有爱结系亦有恚结系耶。答若于此事有恚结系必有爱结系。或有爱结系无恚结系。谓于色无色界法有爱结未断。此中爱结通三界五部。唯有漏缘非遍行。恚结唯欲界通五部。唯有漏缘非遍行。诸具缚者于欲界五部事。若有爱结系亦有恚结系。若有恚结系亦有爱结系。于色无色界五部事。有爱结系无恚结系。不具缚者于欲界五部事。随未断处有爱结系。亦有恚结系。若已断处无爱结系。亦无恚结系。于色无色界五部事。随未断处有爱结系。无恚结系。若已断处无爱结系。亦无恚结系。由爱结长恚结短故。所问应作顺后句答。若于此事有恚结系必有爱结系。谓于欲界五部未断尽事。或有爱结系。无恚结系。谓于色无色界法有爱结未断。此中或有八地未断。乃至或有非想非非想处未断。于此地中或有五部未断。乃至或有修所断未断。于此部中或有九品未断。乃至或有下下品未断。此中总相说未断言。问何故色无色界五部法无恚结系耶。答以上二界无恚结故。问何故上二界无恚结耶。答彼于恚结非田器故。复次诸瑜伽师厌患恚结求上二界。若上二界有恚结者。诸瑜伽师不应求彼勤修加行。若法下地有上地亦有者。是则应无渐次灭法。此若无者亦应无有究竟灭法。是所引故。若复拨无究竟灭法则亦应拨解脱出离。勿有斯过故上二界无有恚结。复次恚结必依粗涩相续。色无色界相续细滑胜奢摩他所滋润故无有恚结。复次若于此界有忧苦根则有恚结。诸有情类依忧苦根于他相续起嗔恚故。色无色界无忧苦根故无恚结。复次若欲界中有无惭无愧则有恚结。有情依止无惭无愧于他相续起嗔恚故。上二界无无惭无愧故无恚结。复次若于是界有嫉与悭则有恚结。诸有情类依止嫉悭于他相续起嗔恚故。色无色界无嫉无悭故无恚结。复次若于是界有女男根则有恚结。诸有情类依女男根于他相续起嗔恚故。色无色界无女男根故无恚结。复次若于此界有段食贪则有恚结。诸有情类依段食贪于他相续起嗔恚故。色无色界无段食贪故无恚结。复次若于此界有淫欲爱则有恚结。诸有情类依淫欲爱于他相续起嗔恚故。色无色界无淫欲爱故无恚结。复次若于此界有五重盖则有恚结。诸有情类依五重盖于他相续起嗔恚故。色无色界无五重盖故无恚结。复次若于是界有五妙欲则有恚结。诸有情类依五妙欲起嗔恚故。色无色界无五妙欲故无恚结。复次若于是界有怨憎相则有恚结。怨憎相者。谓九恼事。色无色界无怨憎相故无恚结。由此尊者妙音说言。有情若遇诸怨憎相便起恚结。诸怨憎相上二界无故无恚结。复次慈是恚结近对治道。色界有慈故无恚结。如处若有吠岚婆风。是处云烟必不得住。色界无故无色亦无。非诸烦恼下地所无上地得有渐次断故。若于此事有爱结系亦有慢结系耶。答如是。设有慢结系复有爱结系耶。答如是。谓爱慢结俱通三界五部。唯有漏缘非遍行长短等故。所问应作如是句答。若具缚者。三界五部事皆为二结系。不具缚者。随已断处无二结系。若未断处有二结系。或有九地乃至或有一地于此地中或有五部乃至或有一部。于此部中或有九品乃至或有一品。故言如是

若于此事有爱结系亦有无明结系耶。答若于此事有爱结系必有无明结系或有无明结系无爱结系。谓苦智已生集智未生。于见苦所断法。有见集所断无明结未断。此中爱结通三界五部。唯有漏缘非遍行。无明结通三界五部。有漏无漏缘遍行非遍行。诸具缚者于三界五部事。若有爱结系亦有无明结系。若有无明结系亦有爱结系。不具缚者于已断处。或有遍行无明结系无爱结系。无明结长。爱结短故。所问应作顺前句答谓于三界五部事中若有爱结系必有无明结系。或有无明结系无爱结系。广说如前。谓苦智已生集智未生。见苦所断爱无明结。于自部事已断尽。故俱不能系。见集所断遍行无明结于见苦所断事。为所缘系。见集所断爱结于见苦所断事。非所缘系非遍行故。非相应系。是他聚故。若于此事有爱结系亦有见结系耶。答应作四句。此中爱结通三界五部。唯有漏缘非遍行。见结通三界唯四部通有漏无漏缘遍行非遍行。诸具缚者于三界五部事。若有爱结系亦有见结系。若有见结系亦有爱结系。不具缚者爱结通五部故长。唯有漏缘非遍行故短。见结唯四部故短。通有漏无漏缘遍行非遍行故长此二互有长短义故。所问应作四句而答。或有爱结系无见结系。谓集智已生灭智未生。于见灭道所断见结不相应法。及于修所断法有爱结未断。此中见灭道所断见结不相应法者。谓彼邪见自性及见取戒禁取疑贪嗔慢不共无明等聚相应不相应法。于此诸法爱未断故。有爱结系。彼于自聚为所缘系及相应系。若于他聚为所缘系。非相应系无见结系。所以者何。遍行见结缘五部者彼已断故。余未断者于此见结不相应法。非所缘系。无漏缘故。非相应系。是他聚故。自性与自性不相应故。彼于修所断法爱未断故有爱结系。或有九地爱结未断。乃至或有一地爱结未断。于此地中或有九品爱结未断。乃至或有一品爱结未断无见结系所以者何遍行见结缘五部者彼已断故。修所断部无见结故。复次灭智已生道智未生。于见道所断见结不相应法。及于修所断法。有爱结未断。此中见道所断见结不相应法如前说。于此诸法及于修所断法。有爱结系无见结系亦如前说。复次具见世尊弟子于修所断法有爱结未断。此中道类智已生具见三界四圣谛故名为具见。彼于修所断法爱未断故。有爱结系或有九地爱结未断乃至或有一地爱结未断。于此地中或有九品爱结未断乃至或有一品爱结未断无见结系。所以者何。一切见结彼已断故。或有见结系无爱结系。谓苦智已生集智未生。于见苦所断法有见集所断见结未断。此中苦智已生集智未生。见苦所断爱结见结二俱已断。见集所断见结未断故。于见苦所断法为所缘系。见集所断爱结虽未断而于见苦所断法。非所缘系非遍行故。非相应系。是他聚故。或有二俱系。谓具缚者于见修所断法有二结系。问何故名具缚者。答由此有情一切支分皆能缚故。一切支分皆被缚故。名为具缚。一切支分皆能缚者。五部烦恼皆能为缚。一切支分皆被缚者。五部诸法皆被系缚。此具缚者于见苦所断法有一部爱结系二部见结系。于见集所断法亦尔。于见灭所断见结相应法。有一部爱结系三部见结系。于见结不相应法有一部爱结系三部见结系。于见道所断法亦尔。于修所断法有一部爱结系二部见结系。复次苦智已生集智未生。于见集灭道修所断法有二结系。此中于见集所断法。有一部爱结系一部见结系。于见灭所断见结相应法。有一部爱结系二部见结系。于见结不相应法。有一部爱结系一部见结系。于见道所断法亦尔。于修所断法有一部爱结系一部见结系。尔时于见苦所断法。虽有见结系而无爱结系。故此不说。复次集智已生灭智未生。于见灭道所断见结相应法有二结系。此中于见灭道所断见结相应法。各有一部爱结系一部见结系。尔时于见灭道所断见结不相应法及修所断法。虽有爱结系而无见结系。故此不说。复次灭智已生道智未生。于见道所断见结相应法有二结系。此中于见道所断见结相应法。有一部爱结系一部见结系。尔时于见道所断见结不相应法及修所断法。虽有爱结系而无见结系。故此不说。或有二俱不系。谓集智已生灭智未生。于见苦集所断法无二结系。灭智已生道智未生。于见苦集灭所断法无二结系。具见世尊弟子于见所断法无二结系。已离欲染于欲界法无二结系。已离色染于欲色界法无二结系。已离无色染于三界法无二结系。此中诸法能系所系俱已断故皆离二结。谓爱见结俱离系故。此复应作颇设问答。颇有见灭道所断见结相应法。有爱结系无见结系。非不见随眠之所随增耶。答有。谓六品结断已入正性离生。集智已生灭智未生。见灭道所断前六品见结相应法有爱结系。后三品爱结缘彼未断故。无见结系遍行见结缘五部者彼已断故。自部前六品无漏缘见结亦已断故。自部后三品无漏缘见结虽未断而于前六品已断见结相应法非所缘系无漏缘故非相应系。是他聚故。而见随眠非不随增。见取戒禁取自部后三品于前六品犹随增故。见随眠通五见。见结唯是前三见故。如对见结。对疑结亦尔。谓如见结通三界唯四部。通有漏无漏缘遍行非遍行。疑结亦尔。是故爱结若对疑结如对见结。若于此事有爱结系亦有取结系耶。答应作四句。此中爱结通三界五部唯有漏缘非遍行。取结通三界唯四部有漏缘。通遍行非遍行。诸具缚者于三界五部事。若有爱结系亦有取结系。若有取结系。亦有爱结系不具缚者爱结通五部故长。唯非遍行故短取结通遍行非遍行故长。唯四部故短。此二互有长短义故所问应作四句而答。或有爱结系无取结系。谓集智已生灭智未生。于修所断法有爱结未断。灭智已生道智未生。于修所断法有爱结未断。具见世尊弟子于修所断法有爱结未断。此中或有九地爱结未断。乃至或有一地爱结未断。于此地中或有九品爱结未断乃至或有一品爱结未断。由未断故有爱结系无取结系。所以者何。遍行取结缘五部者彼已断故。非遍行取结未断。已断于修所断法非能系故。修所断部无取结故。或有取结系无爱结系。谓苦智已生集智未生。于见苦所断法有见集所断取结未断。此中苦智已生集智未生。见苦所断爱结取结二俱已断。见集所断取结未断故。于见苦所断法为所缘系。见集所断爱结虽未断而于见苦所断法。非所缘系非遍行故。非相应系是他聚故

或有二俱系。谓具缚者于见修所断法有二结系。此中具缚者于见苦所断法。有一部爱结系二部取结系。于见集所断法亦尔。于见灭所断法。有一部爱结系三部取结系。于见道所断法亦尔。于修所断法。有一部爱结系二部取结系。复次苦智已生集智未生。于见集灭道修所断法有二结系。此中于见集所断法。有一部爱结系一部取结系。于见灭道所断法。各有一部爱结系二部取结系。于修所断法。有一部爱结系一部取结系尔时于见苦所断法。虽有取结系而无爱结系。故此不说。复次集智已生灭智未生。于见灭道所断法有二结系。此中于见灭道所断法。各有一部爱结系一部取结系。尔时于修所断法。虽有爱结系而无取结系。故此不说。复次灭智已生道智未生。于见道所断法有二结系。此中于见道所断法。有一部爱结系一部取结系。尔时于修所断法虽有爱结系而无取结系。故此不说。或有二俱不系。谓集智已生灭智未生。于见苦集所断法无二结系。灭智已生道智未生。于见苦集灭所断法无二结系。具见世尊弟子。于见所断法无二结系。已离欲染于欲界法无二结系。已离色染于欲色界法无二结系。已离无色染于三界法无二结系。此中诸法能系所系俱已断故皆离二结。谓爱取结俱离系故。若于此事有爱结系亦有嫉结系耶。答若于此事有嫉结系必有爱结系。或有爱结系无嫉结系。谓于欲界见所断法及于色无色界法有爱结未断。此中爱结通三界五部。唯有漏缘非遍行。嫉结唯欲界修所断有漏缘非遍行。诸具缚者于欲界修所断事。若有爱结系亦有嫉结系。若有嫉结系亦有爱结系。于欲界见所断四部事及色无色五部事。有爱结系无嫉结系。不具缚者若未离欲染于欲界修所断事具二结系。于三界见所断四部事。随未断处有爱结系无嫉结系。若已断处无二结系。于色无色界修所断事。有爱结系。无嫉结系。已离欲染于欲界五部事无二结系。于色无色界五部事。随未断处有爱结系无嫉结系。若已断处无二结系。由爱结长嫉结短故。所问应作顺后句答。若于此事有嫉结系必有爱结系。谓于欲界修所断未离系事。或有爱结系无嫉结系。谓于欲界见所断法有爱结未断。此中或有四部爱结未断。乃至或有一部爱结未断。于色无色界法有爱结未断。此中或有八地爱结未断。乃至或有一地爱结未断。于此地中或有五部爱结未断。乃至或有一部爱结未断。于此部中或有九品爱结未断。乃至或有一品爱结未断。由未断故有爱结系无嫉结系。所以者何。见所断部无嫉结故。色无色界亦无嫉结。彼无嫉悭如前恚说。如对嫉结。对悭结亦尔。谓嫉与悭俱唯欲界修所断。有漏缘非遍行故。如爱结对后作一行。慢结对后作一行亦尔。谓爱与慢俱通三界五部。唯有漏缘非遍行故若于此事有恚结系亦有慢结系耶。答若于此事有恚结系必有慢结系。或有慢结系无恚结系。谓于色无色界法。有慢结未断。此中恚结唯欲界通五部唯有漏缘非遍行。慢结通三界五部。唯有漏缘非遍行。诸具缚者于欲界五部事。若有恚结系亦有慢结系。若有慢结系。亦有恚结系。于色无色界五部事。有慢结系无恚结系。不具缚者于欲界五部事。随未断处有恚结系亦有慢结系。若已断处无恚结系亦无慢结系于色无色界五部事。随未断处有慢结系无恚结系。若已断处无慢结系亦无恚结系。由恚结短慢结长故。所问应作顺前句答。若于此事有恚结系必有慢结系谓于欲界五部未断尽事。或有慢结系无恚结系。谓于色无色界法。有慢结未断此中或有八地未断。乃至或有一地未断。于此地中或有五部未断。乃至或有一部未断。于此部中或有九品未断。乃至或有一品未断。若于此事有恚结系亦有无明结系耶。答若于此事有恚结系必有无明结系。或有无明结系无恚结系谓未离欲染。苦智已生集智未生。于欲界见苦所断法。有见集所断无明结未断。此中恚结唯欲界通五部唯有漏缘非遍行无明结通三界五部有漏无漏缘遍行非遍行。诸具缚者于欲界五部事。若有恚结系亦有无明结系。若有无明结系亦有恚结系。于色无色界五部事。有无明结系无恚结系。不具缚者于欲界已断处。或有遍行无明结系无恚结系。于色无色界未断处亦尔。由恚结短无明长故。所问应作顺前句答。若于此事有恚结系必有无明结系。谓于欲界五部未断尽事。或有无明结系无恚结系。谓未离欲染苦智已生集智未生。于欲界见苦所断法。有见集所断无明结未断。此中未离欲染者。若已离欲染于欲界法二结俱无故说未离彼。苦智已生集智未生。见苦所断恚与无明二俱已断。见集所断遍行无明犹未断故。于见苦所断法为所缘系。见集所断恚结于见苦所断法非所缘系非遍行故。非相应系是他聚故。复次于色无色界法有无明结未断。此中或有八地无明结未断。乃至或有一地无明结未断。于此地中或有五部无明结未断。乃至或有一部无明结未断。于此部中或有九品无明结未断。乃至或有一品无明结未断。由未断故有无明结系。无恚结系彼无恚结故。若于此事有恚结系亦有见结系耶。答应作四句。此中恚结唯欲界通五部唯有漏缘非遍行。见结通三界唯四部。通有漏无漏缘遍行非遍行。诸具缚者于欲界五部事。若有恚结系亦有见结系。若有见结系亦有恚结系。于色无色界五部事。有见结系无恚结系。不具缚者恚结通五事故长。唯欲界有漏缘非遍行故短。见结通三界有漏无漏缘遍行非遍行故长。唯四部故短。此二互有长短义故。所问应作四句而答。或有恚结系无见结系。谓未离欲染集智已生灭智未生。于欲界见灭道所断见结不相应法。及于欲界修所断法有恚结未断。此中见灭道所断见结不相应法者。谓邪见自性及见取戒禁取疑贪嗔慢不共无明等聚相应不相应法。于此诸法恚未断故有恚结系。彼于自聚为所缘系及相应系。若于他聚为所缘系非相应系无见结系。所以者何。遍行见结缘五部者彼已断故。余未断者于此见结不相应法非所缘系无漏缘故。非相应系是他聚故。自性与自性不相应故。彼于欲界修所断法。恚未断故有恚结系。或有九品恚结未断。乃至或有一品恚结未断无见结系。所以者何。遍行见结缘五部者彼已断故。修所断部无见结故。复次灭智已生道智未生。于欲界见道所断见结不相应法。及于欲界修所断法有恚结未断。此中见道所断见结不相应法如前说。于此诸法及于欲界修所断法。有恚结系无见结系亦如前说复次具见世尊弟子。未离欲染于欲界修所断法有恚结未断。彼于欲界修所断法。恚未断故有恚结系无见结系如前应知。或有见结系无恚结系。谓未离欲染苦智已生集智未生。于欲界见苦所断法。有见集所断见结未断。于色无色界法有见结未断。此中苦智已生集智未生。见苦所断恚结见结二俱已断。见集所断见结未断故。于见苦所断法为所缘系。见集所断恚结虽未断。而于见苦所断法非所缘系非遍行故。非相应系是他聚故。于色无色界法。有见结未断者。或有八地见结未断。乃至或有一地见结未断。于此地中或有四部见结未断。乃至或有一部见结未断。由未断故有见结系无恚结系彼无恚故。或有二俱系。谓具缚者于欲界见修所断法有二结系。此具缚者于欲界见苦所断法。有一部恚结系二部见结系。于欲界见集所断法亦尔。于欲界见灭所断见结相应法。有一部恚结系三部见结系。于彼见结不相应法。有一部恚结系二部见结系。于欲界见道所断法亦尔。于欲界修所断法。有一部恚结系二部见结系复次未离欲染苦智已生集智未生。于欲界见集灭道修所断法有二结系。此中于欲界见集所断法。有一部恚结系一部见结系。于欲界见灭所断见结相应法。有一部恚结系二部见结系。于彼见结不相应法。有一部恚结系一部见结系。于欲界见道所断法亦尔。于欲界修所断法。有一部恚结系一部见结系。尔时于欲界见苦所断法。虽有见结系而无恚结系。故此不说。复次集智已生灭智未生。于欲界见灭道所断见结相应法有二结系。此中未离欲染于欲界见灭道所断见结相应法。各有一部恚结系一部见结系。尔时于欲界见灭道所断见结不相应法及修所断法。虽有恚结系而无见结系故此不说。复次灭智已生道智未生。于欲界见道所断见结相应法有二结系。此中未离欲染于欲界见道所断见结相应法。有一部恚结系一部见结系尔时于欲界见道所断见结不相应法及修所断法。虽有恚结系而无见结系。故此不说

说一切有部发智大毗婆沙论卷第五十六阿毗达磨大毗婆沙论卷第五十七

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中一行纳息第二之二

或有二俱不系。谓集智已生灭智未生。于见苦集所断法。及于色无色界见灭道所断见结不相应法。并于色无色界修所断法无二结系。灭智已生道智未生。于见苦集灭所断法。及于色无色界见道所断见结不相应法。并于色无色界修所断法无二结系。具见世尊弟子。未离欲染于见所断法及于色无色界修所断法无二结系。已离欲染于欲界法无二结系。已离色染于欲色界法无二结系。已离无色染于三界法无二结系。此中诸法能系所系俱已断故皆离二结。谓恚见结俱离系故。问欲界有恚。彼于恚结得离系时可说不系。色无色界本无恚结。如何言彼恚结不系。答不系有二种一从系得不系。二本性无系。故名不系。欲界诸法有恚结故。得解脱时说彼从系而得不系。上二界法本无恚结。故说彼为本性不系。以不系言含二种义故此说为二俱不系。如毗奈耶说有二种补特伽罗。名为清净。一者本来不犯禁戒。二者犯已如法悔除。第一本性无染故名清净。第二从染得净故名清净。不系亦尔。故无有失。问色无色界见灭道所断见结不相应法何者是耶。答彼邪见自性及见取戒禁取疑贪慢不共无明等聚相应不相应法。相应法者。谓邪见自性及见取乃至不共无明聚中心心所法。不相应法者。谓邪见乃至不共无明聚中。所有四相及彼诸得聚中能相所相。如对见结。对疑结亦尔。谓如见结通三界唯四部。通有漏无漏缘遍行非遍行。疑结亦尔。是故恚结若对疑结如对见结。若于此事有恚结系亦有取结系耶。答应作四句。此中恚结唯欲界通五部。唯有漏缘非遍行。取结通三界唯四部有漏缘通遍行非遍行。诸具缚者于欲界五部事。若有恚结系亦有取结系。若有取结系亦有恚结系。于色无色界五部事。有取结系无恚结系。不具缚者恚结唯欲界非遍行故短。通五部故长。取结唯四部故短。通三界遍行非遍行故长。此二互有长短义故。所问应作四句而答。或有恚结系无取结系。谓未离欲染。集智已生灭智未生。于欲界修所断法有恚结未断。灭智已生道智未生。于欲界修所断法有恚结未断。具见世尊弟子。未离欲染于欲界修所断法有恚结未断。此中或有九品恚结未断。乃至或有一品恚结未断。由未断故有恚结系无取结系。所以者何。遍行取结缘五部者彼已断故。非遍行取结于修所断法未断已断俱不能系故。修所断部无取结故。或有取结系无恚结系。谓未离欲染。苦智已生集智未生。于欲界见苦所断法。有见集所断取结未断。于色无色界法有取结未断。此中未离欲染。苦智已生集智未生。欲界见苦所断恚结取结二俱已断。欲界见集所断取结未断故。于欲界见苦所断法为所缘系。欲界见集所断恚结虽未断而于欲界见苦所断法。非所缘系非遍行故。非相应系是他聚故。于色无色界法有取结未断者。或有八地取结未断。乃至或有一地取结未断。于此地中或有四部取结未断。乃至或有一部取结未断。由未断故有取结系无恚结系。彼无恚故。或有二俱系。谓具缚者于欲界见修所断法有二结系。此中具缚者于欲界见苦所断法。有一部恚结系二部取结系。于欲界见集所断法亦尔。于欲界见灭所断法。有一部恚结系三部取结系。于欲界见道所断法亦尔。于欲界修所断法有一部恚结系二部取结系。复次未离欲染。苦智已生集智未生。于欲界见集灭道修所断法有二结系。此中于欲界见集所断法。有一部恚结系一部取结系。于欲界见灭道所断法。各有一部恚结系二部取结系。于欲界修所断法。有一部恚结系一部取结系。尔时于欲界见苦所断法。虽有取结系而无恚结系。故此不说

复次集智已生灭智未生。于欲界见灭道所断法有二结系。此中亦未离欲染。于欲界见灭道所断法。各有一部恚结系一部取结系。尔时于欲界修所断法。虽有恚结系而无取结系。故此不说。复次灭智已生道智未生。于欲界见道所断法有二结系。此中亦未离欲染。于见道所断法。有一部恚结系一部取结系。尔时于欲界修所断法。虽有恚结系而无取结系。故此不说。或有二俱不系。谓未离欲染。集智已生灭智未生。于见苦集所断法。及于色无色界修所断法无二结系。灭智已生道智未生。于见苦集灭所断法。及于色无色界修所断法无二结系。具见世尊弟子。未离欲染。于见所断法。及于色无色界修所断法无二结系。已离欲染于欲界法无二结系。已离色染于欲色界法无二结系。已离无色染于三界法无二结系。此中诸法能系所系俱已断故皆离二结。谓恚取结俱离系故。若于此事有恚结系亦有嫉结系耶。答若于此事有嫉结系。必有恚结系。或有恚结系无嫉结系。谓于欲界见所断法有恚结未断。此中恚结唯欲界通五部。唯有漏缘非遍行嫉结唯欲界修所断有漏缘非遍行。诸具缚者于欲界修所断事。若有恚结系亦有嫉结系。若有嫉结系。亦有恚结系于欲界见所断事。有恚结系无嫉系结。不具缚者若未离欲染。于欲界修所断事具二结系。于欲界见所断事随未断处有恚结系无嫉结系。若已断处无二结系。若已离欲染于欲界五部事无二结系。于色无色界五部事。若具缚若不具缚一切时无二结系。由恚结长嫉结短故。所问应作顺后句答。若于此事有嫉结系必有恚结系。谓于欲界修所断未离系事。或有恚结系无嫉结系。谓于欲界见所断法有恚结未断。此中或有四部恚结未断。乃至或有一部恚结未断。由未断故有恚结系无嫉结系。所以者何。见所断部无嫉结故。如对嫉结。对悭结亦尔。谓嫉与悭俱唯欲界修所断有漏缘非遍行故

若于此事有无明结系亦有见结系耶。答若于此事有见结系必有无明结系。或有无明结系无见结系。乃至广说。此中无明结通三界五部有漏无漏缘遍行非遍行。见结通三界唯四部通有漏无漏缘遍行非遍行。诸具缚者于三界五部事。若有无明结系亦有见结系。若有见结系亦有无明结系。不具缚者无明结长见结短故。所问应作顺后句答。若于此事有见结系必有无明结系。谓于三界五部有见结未断事。或有无明结系无见结系。谓集智已生灭智未生。于见灭道所断见结不相应法。及于修所断法有无明结未断。此中见灭道所断见结不相应法者谓彼邪见自性及见取戒禁取疑贪嗔慢不共无明等聚相应不相应法。于此诸法无明结未断故有无明结系。彼于自聚为所缘系及相应系。若于他聚为所缘系非相应系无见结系。所以者何。遍行见结缘五部者彼已断故。余未断者于此见结不相应法。非所缘系无漏缘故。非相应系是他聚故。自性与自性不相应故。彼于修所断法无明结未断故有无明结系或有九地无明结未断。乃至或有一地无明结未断。于此地中或有九品无明结未断。乃至或有一品无明结未断无见结系。所以者何。遍行见结缘五部者。彼已断故。修所断部无见结故。复次灭智已生道智未生。于见道所断见结不相应法。及于修所断法有无明结未断。此中见道所断见结不相应法如前说。于此诸法及于修所断法有无明结系无见结系亦如前说。复次具见世尊弟子。于修所断法有无明结未断。此中或有九地无明结未断。乃至或有一地无明结未断。于此地中或有九品无明结未断。乃至或有一品无明结未断。由未断故有无明结系无见结系。所以者何。一切见结彼已断故。如对见结。对疑亦尔。谓如见结通三界唯四部通有漏无漏缘遍行非遍行。疑结亦尔。是故无明结若对疑结如对见结。若于此事有无明结系亦有取结系耶。答若于此事有取结系。必有无明结系。或有无明结系。无取结系。乃至广说。此中无明结通三界五部有漏无漏缘遍行非遍行。取结通三界唯四部有漏缘通遍行非遍行。诸具缚者于三界五部事。若有无明结系亦有取结系。若有取结系亦有无明结系。不具缚者无明结长取结短故。所问应作顺后句答。若于此事有取结系必有无明结系。谓于三界五部有取结未断事。或有无明结系无取结系。谓集智已生灭智未生。于修所断法有无明结未断。灭智已生道智未生。于修所断法有无明结未断。具见世尊弟子。于修所断法有无明结未断。此中或有九地无明结未断。乃至或有一地无明结未断。于此地中或有九品无明结未断。乃至或有一品无明结未断。由未断故有无明结系无取结系。所以者何。遍行取结缘五部者彼已断故。非遍行取结未断已断于修所断法非能系故。修所断部无取结故。若于此事有无明结系亦有嫉结系耶。答若于此事有嫉结系必有无明结系。或有无明结系无嫉结系。谓于欲界见所断法。及于色无色界法有无明结未断。此中无明结通三界五部有漏无漏缘遍行非遍行。嫉结唯欲界修所断有漏缘非遍行。诸具缚者于欲界修所断事。若有无明结系亦有嫉结系。若有嫉结系亦有无明结系。于欲界见所断四部事。及色无色界五部事。有无明结系无嫉结系。不具缚者若未离欲染。于欲界修所断事具二结系。于三界见所断四部事。随未离系处有无明结系无嫉结系。若已离系处无二结系。于色无色界修所断事。有无明结系无嫉结系。已离欲染于欲界五部事无二结系。于色无色界五部事。随未离系处。有无明结系无嫉结系。若已离系处无二结系。由无明结长嫉结短故。所问应作顺后句答。若于此事有嫉结系必有无明结系。谓于欲界修所断未离系事。或有无明结系。无嫉结系。谓于欲界见所断法有无明结未离此中或有四部无明结未断。乃至或有一部无明结未断。于色无色界法有无明结未断。此中或有八地无明结未断。乃至或有一地无明结未断。于此地中或有五部无明结未断。乃至或有一部无明结未断。于此部中或有九品无明结未断。乃至或有一品无明结未断。由未断故有无明结系无嫉结系。所以者何。见所断部无嫉结故。色无色界亦无嫉故。如对嫉结。对悭结亦尔。谓嫉与悭俱唯欲界修所断有漏缘非遍行故。若于此事有见结系亦有取结系耶。答若于此事有见结系必有取结系。或有取结系无见结系。乃至广说。此中见结通三界唯四部通有漏无漏缘遍行非遍行。取结通三界唯四部有漏缘通遍行非遍行。诸具缚者于三界五部事。若有见结系亦有取结系。若有取结系亦有见结系。不具缚者有于见灭道所断见结不相应法。有取结系无见结系。由见结短取结长故。所问应作顺前句答。若于此事有见结系必有取结系。谓于三界五部未离见结系事。或有取结系无见结系。谓集智已生灭智未生。于见灭道所断见结不相应法有取结未断。灭智已生道智未生。于见道所断见结不相应法有取结未断。此中见灭道所断见结不相应法如前说。于此诸法取结未断故有取结系。彼于自聚为所缘系及相应系。若于他聚为所缘系非相应系无见结系。所以者何。遍行见结缘五部者彼已断故。余未断者于此见结不相应法非所缘系无漏缘故。非相应系是他聚故。自性与自性不相应故。若于此事有见结系亦有疑结系耶。答应作四句。此中见结通三界唯四部通有漏无漏缘遍行非遍行。疑结亦尔。诸具缚者于三界五部事。若有见结系亦有疑结系。若有疑结系亦有见结系。不具缚者见疑二结各于自聚有系故长。各于他聚无系故短。是故所问应作自本四句而答。或有见结系无疑结系。谓集智已生灭智未生。于见灭道所断见结相应法有见结未断。灭智已生道智未生。于见道所断见结相应法有见结未断。此中见灭道所断见结相应法者。谓彼邪见相应心心所法。见结于彼有相应系以未断故。无所缘系无漏缘故。疑结于彼全无系义。所以者何。遍行疑结缘五部者彼已断故。余未断者于见结相应法非所缘系无漏缘故非相应系是他聚故。或有疑结系无见结系谓集智已生灭智未生。于见灭道所断疑结相应法有疑结未断。灭智已生道智未生于见道所断疑结相应法有疑结未断。此中见灭道所断疑结相应法者。谓彼疑相应心心所法。疑结于彼有相应系以未断故。无所缘系无漏缘故。见结于彼全无系义。所以者何。遍行见结缘五部者彼已断故。余未断者于疑结相应法非所缘系无漏缘故非相应系是他聚故。或有二俱系。谓具缚者于见修所断法有二结系。此中具缚者于见苦所断法有二部见结系二部疑结系。于见集所断法亦尔。于见灭所断见结相应法。有三部见结系二部疑结系。于见灭所断疑结相应法。有三部疑结系二部见结系。于见灭所断见疑一结不相应法。有二部见结系二部疑结系。于见道所断法亦尔。于修所断法。有二部见结系二部疑结系。苦智已生集智未生。于见苦集灭道修所断法有二结系。此中苦智已生集智未生。于见苦所断法。有一部见结系一部疑结系。于见集所断法亦尔。于见灭所断见结相应法。有二部见结系一部疑结系。于见灭所断疑结相应法。有二部疑结系一部见结系。于见灭所断见疑二结不相应法。有一部见结系一部疑结系。于见道所断法亦尔。于修所断法。有一部见结系一部疑结系。或有二俱不系。谓集智已生灭智未生。于见苦集所断法。及于见灭道所断见疑二结不相应法。并于修所断法无二结系灭智已生道智未生。于见苦集灭所断法。及于见道所断见疑二结不相应法。并于修所断法无二结系。具见世尊弟子。于见修所断法无二结系。已离欲染于欲界法无二结系。已离色染于欲色界法无二结系。已离无色染于三界法无二结系。此中诸法能系所系俱已断故皆离二结。谓见疑结俱离系故。见灭道所断见疑二结不相应法。虽未离自部系。而见疑二结于彼不系故名无二结系。若于此事有见结系亦有嫉结系耶。答应作四句。此中见结通三界唯四部通有漏无漏缘遍行非遍行。嫉结唯欲界修所断有漏缘非遍行。诸具缚者于欲界修所断事。若有见结系亦有嫉结系。若有嫉结系。亦有见结系。于欲界见所断四部事。及色无色界五部事有见结系无嫉结系。不具缚者若未离欲染。苦智已生集智未生。于三界见所断四部事。及于色无色界修所断事。有见结系无嫉结系。于欲界修所断事具二结系。集智已生灭或道智未生。于欲界修所断事有嫉结系无见结系。于三界见灭或道所断见结相应法。有见结系无嫉结系。于三界见苦集所断法。及见灭道所断见结不相应法无二结系。若已离欲染于欲界五部事无二结系。于色无色界五部事。随未离见结者有见结系无嫉结系。若已离见结者无二结系。此二互有长短义故。所问应作四句而答。或有见结系无嫉结系。谓于欲界见所断法。及于色无色界法有见结未断。此中于欲界见所断法有见结未断者。或有四部见结未断。乃至或有一部见结未断。于色无色界法有见结未断者。或有八地见结未断。乃至或有一地见结未断。于此地中或有四部见结未断。乃至或有一部见结未断。由未断故有见结系无嫉结系。所以者何。见所断部及上二界无嫉结故。或有嫉结系无见结系。谓未离欲染。集智已生灭智未生。于欲界修所断法有嫉结未断。灭智已生道智未生。于欲界修所断法有嫉结未断。具见世尊弟子。未离欲染于欲界修所断法有嫉结未断。此中或有九品嫉结未断。乃至或有一品嫉结未断。由未断故有嫉结系无见结系。所以者何。遍行见结缘五部者彼已断故。余未断者于修所断法不能为系无漏缘故。修所断部无见结故。或有二俱系。谓具缚者于欲界修所断法有二结系。此中具缚者于欲界修所断法。有二部见结系一部嫉结系。复次未离欲染。苦智已生集智未生。于欲界修所断法有二结系。此中未离欲染者或有九品未离。乃至或有一品未离彼苦智已生集智未生。于欲界修所断法。有一部见结系一部嫉结系。或有二俱不系。谓未离欲染。集智已生灭智未生。于见苦集所断法。及于见灭道所断见结不相应法。并于色无色界修所断法无二结系。灭智已生道智未生。于见苦集灭所断法。及于见道所断见结不相应法。并于色无色界修所断法无二结系。具见世尊弟子。未离欲染。于见所断法。及于色无色界修所断法无二结系。已离欲染于欲界法无二结系。已离色染于欲色界法无二结系。已离无色染于三界法无二结系。此中或有已断故不系。或有本无故不系。如对嫉结。对悭结亦尔。谓嫉与悭俱唯欲界修所断有漏缘非遍行故。如见结对后作一行。疑结对后作一行亦尔。谓见与疑俱通三界唯四部通有漏无漏缘遍行非遍行故

若于此事有取结系亦有疑结系耶。答若于此事有疑结系必有取结系。或有取结系无疑结系。乃至广说。此中取结通三界唯四部有漏缘通遍行非遍行。疑结通三界唯四部通有漏无漏缘遍行非遍行。诸具缚者于三界五部事。若有取结系亦有疑结系。若有疑结系亦有取结系。不具缚者有于见灭道所断疑结不相应法。有取结系无疑结系。由取结长疑结短故。所问应作顺后句答。若于此事有疑结系必有取结系。谓于三界五部未离疑结事。或有取结系无疑结系。谓集智已生灭智未生。于见灭道所断疑结不相应法有取结未断。灭智已生道智未生于见道所断疑结不相应法有取结未断。此中见灭道所断疑结不相应法者。谓彼疑自性及见取戒禁取贪嗔慢不共无明等聚相应不相应法。于此诸法取结未断故有取结系。彼于自聚为所缘系及相应系。若于他聚为所缘系非相应系。无疑结系。所以者何。遍行疑结缘五部者彼已断故。余未断者于此疑结不相应法。非所缘系无漏缘故。非相应系是他聚故。自性与自性不相应故。若于此事有取结系亦有嫉结系耶。答应作四句。此中取结通三界唯四部有漏缘通遍行非遍行。嫉结唯欲界修所断有漏缘非遍行。诸具缚者于欲界修所断事。若有取结系亦有嫉结系。若有嫉结系亦有取结系。于欲界见所断四部事及色无色界五部事。有取结系无嫉结系。不具缚者若未离欲染。苦智已生集智未生。于三界见所断四部事。及色无色界修所断事有取结系。无嫉结系。于欲界修所断事具二结系。集智已生灭或道智未生。于欲界修所断事。有嫉结系无取结系。于三界见灭或道所断事。有取结系无嫉结系。于三界见苦集所断事无二结系。若已离欲染。于欲界五部事无二结系。于色无色界五部事随未离取结者。有取结系无嫉结系若已离取结者无二结系。此二互有长短义故。所问应作四句而答。或有取结系无嫉结系。谓于欲界见所断法。及于色无色界法有取结未断。此中于欲界见所断法有取结未断者。或有四部取结未断。乃至或有一部取结未断。于色无色界法有取结未断者。或有八地取结未断。乃至或有一地取结未断。于此地中或有四部取结未断。乃至或有一部取结未断。由未断故有取结系无嫉结系所以者何。见所断部及上二界无嫉结故。或有嫉结系无取结系。谓未离欲染集智已生灭智未生。于欲界修所断法有嫉结未断。灭智已生道智未生于欲界修所断法有嫉结未断。具见世尊弟子。未离欲染。于欲界修所断法有嫉结未断。此中或有九品未断。乃至或有一品未断。由未断故有嫉结系无取结系。所以者何。遍行取结缘五部者彼已断故。余未断者于修所断法不能为系。非所缘故。修所断部无取结故。或有二俱系。谓具缚者于欲界修所断法有二结系。此中具缚者于欲界修所断法。有二部取结系一部嫉结系。复次未离欲染苦智已生集智未生。于欲界修所断法有二结系。此中未离欲染者或有九品未离。乃至或有一品未离。彼苦智已生集智未生。于欲界修所断法。有一部取结系一部嫉结系。或有二俱不系。谓未离欲染。集智已生灭智未生。于见苦集所断法。及于色无色界修所断法无二结系。灭智已生道智未生。于见苦集灭所断法。及于色无色界修所断法无二结系。具见世尊弟子。未离欲染于见所断法。及于色无色界修所断法无二结系。已离欲染于欲界法无二结系。已离色染于欲色界法无二结系。已离无色染于三界法无二结系。此中或有已断故不系。或有本无故不系。如对嫉结对悭结亦尔。谓嫉与悭俱唯欲界修所断有漏缘非遍行故

若于此事有嫉结系亦有悭结系耶答如是。设有悭结系复有嫉结系耶。答如是。谓嫉悭结俱唯欲界修所断故。所问应作如是句答。若未离欲染于欲界修所断法具二结系。于三界见所断法。及色无色界修所断法无二结系已离欲染于三界一切法无二结系。长短相似故言如是。问嫉结依他而转悭结依自而转。何缘互相问俱答如是耶。有作是说。嫉结于他能缘亦现起。于自能缘不现起。悭结于自能缘亦现起。于他能缘不现起。此据能缘故言如是。复有说者。此二俱缘自他而起。问嫉结缘他而起可尔。缘自而起云何。答如有施主为二苾刍作资生具。一则成好一不成好。不成好者见而生嫉。作是念言。彼资生具如我所得岂不快哉。此嫉亦能缘自而起。问悭结缘自而起可尔。缘他而起云何。答如有一类见他施时。便起悭心作如是念。彼人何用施他物为。然所施物自全无分。此悭亦能缘他而起故。答如是于理无违

说一切有部发智大毗婆沙论卷第五十七阿毗达磨大毗婆沙论卷第五十八

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中一行纳息第二之三

若于此事有过去爱结系。亦有未来耶。乃至广说。此中诸结有二种。一迷自相。二迷共相。迷自相者谓爱恚慢嫉悭结。迷共相者谓无明见取疑结。迷自相诸结中。爱结于三界五部事能为系。未来未断定系彼三世一切事。过去不定谓于此事若前生未断则系。若前未生设生已断则不系。现在亦不定。谓于此事若现在前则系。不现在前则不系。慢结亦尔。恚结于欲界五部事能为系。未来未断定系彼三世一切事。过去不定。谓于此事若前生未断则系。若前未生设生已断则不系。现在亦不定。谓于此事若现在前则系。不现在前则不系。嫉结于欲界修所断事能为系。未来未断定系彼三世一切事。过去不定。谓于此事若前生未断则系。若前未生设生已断则不系。现在亦不定。谓于此事若现在前则系。不现在前则不系。悭结亦尔。迷共相诸结。于三界五部事能为系。过去未来未断定系彼三世一切事。现在不定。谓于此事若现在前则系。不现在前则不系。是谓历六小七大七略毗婆沙

若于此事有过去爱结系。亦有未来耶。答如是。所以者何。前说爱结于三界五部事能为系。未来未断定系彼三世一切事故。设有未来复有过去耶。答若前生未断则系。若前未生设生已断则不系。所以者何。前说爱结过去不定。谓于此事若前生未断则系。若前未生设生已断则不系故。问若时过去爱结已断。即时未来爱结亦已断。若时过去爱结未断。即时未来爱结亦未断。今何故说若前生未断则系。若前未生设生已断则不系耶。外国诸师作如是说。若前生未断则系者。说中三品结。若前未生则不系者。说下三品结。设生已断则不系者。说上三品结。迦湿弥罗国诸论师言。若前生未断则系者。说九品结。若前未生则不系者。说后三品结。设生已断则不系者。说前六品结。如过去前六品爱结已断未来亦尔。后三品爱结虽未断而未生故。在未来为系非过去。此中意说。若于此事有未来爱结未断。亦有前生爱结未断。即于此事亦有过去爱结系义。若于此事虽有未来爱结未断。而前于此爱结未生。虽余处生而于此事亦名未生。设生已断即于此事无有过去爱结系义。若于此事有过去爱结系亦有现在耶。答若现在前。所以者何。前说爱结现在亦不定。谓于此事若现在前则系。不现在前则不系故。谓于此事若起爱结现在前。则有现在爱结系义。若于此事或起余结现在前。或起善无覆无记心现在前。或于余处起爱结现在前。或无心时则无现在爱结系义。设有现在复有过去耶。答若前生未断则系。若前未生设生已断则不系。此中义意如前广说。若于此事有未来爱结系亦有现在耶。答若现在前。此中义意亦如前说。设有现在复有未来耶。答如是。此中义意如前已说

若于此事有过去爱结系亦有未来现在耶答未来必系现在。若现在前。此中义意并如前说。设有未来现在复有过去耶。答若前生未断则系。若前未生设生已断则不系。此中义意亦如前说。若于此事有未来爱结系亦有过去现在耶。答此中有四句。或有未来无过去现在。谓于此事爱结未断。而前未生设生已断不现在前。此中爱结未断者显有未来爱结。而前未生设生已断者遮有过去爱结。不现在前者。遮有现在爱结。或有未来及过去无现在。谓于此事有爱结前生未断不现在前。此中有爱结前生未断者。显有过去爱结。不现在前者。遮有现在爱结。既有爱结前生未断。即亦显有未来爱结。是故此中不别说有。或有未来及现在无过去。谓于此事有爱结现在前而前未生设生已断。此中有爱结现在前者显有现在爱结。而前未生设生已断者。遮有过去爱结。既有爱结现在前即亦显彼未来有故不别说未来有义。或有未来及过去现在。谓于此事有爱结前生未断亦现在前。此中有爱结前生未断者显有过去爱结。亦现在前者显有现在爱结。既有过去现在爱结未来亦有不说自成。设有过去现在复有未来耶。答如是。此中义意已如前说。若于此事有现在爱结系亦有过去未来耶。答未来必系过去。若前生未断则系。若前未生设生已断则不系。此中义意并如前说。设有过去未来复有现在耶。答若现在前。此中义意亦如前说。如爱结历六。应知恚慢嫉悭非遍行无明结历六亦尔。迷自相结义相似故虽有广狭而得相类。若于此事有过去见结系亦有未来耶。答如是。设有未来复有过去耶。答如是。若于此事有过去见结系亦有现在耶。答若现在前。设有现在复有过去耶。答如是。若于此事有未来见结系亦有现在耶。答若现在前。设有现在复有未来耶。答如是。若于此事有过去见结系亦有未来现在耶。答未来必系。现在若现在前。设有未来现在复有过去耶。答如是若于此事有未来见结系亦有过去现在耶。答过去必系。现在若现在前。设有过去现在复有未来耶。答如是。若于此事有现在见结系亦有过去未来耶。答如是。设有过去未来复有现在耶。答若现在前。所以者何。先作是说。迷共相诸结于三界五部事能为系。过去未来未断定系彼三世一切事。现在不定。谓于此事若现在前则系。不现在前则不系故。如见结历六。应知取疑遍行无明结历六亦尔。迷共相结义相似故虽有广狭而得相类

若于此事有过去爱结系亦有过去恚结系耶。答若前生未断则系。若前未生设生已断则不系。谓于此事若有前生爱结未断。亦有前生恚结未断。即于此事亦有过去恚结系义。若于此事虽有前生爱结未断而前于此恚结未生虽余处生而于此事亦名未生。设生已断即于此事无有过去恚结系义。设有过去恚结系。复有过去爱结系耶。答若前生未断则系若前未生设生已断则不系。谓于此事若有前生恚结未断。亦有前生爱结未断。即于此事亦有过去爱结系义。若于此事虽有前生恚结未断而前于此爱结未生。虽余处生而于此事亦名未生。设生已断即于此事无有过去爱结系义。若于此事有过去爱结系。亦有未来恚结系耶。答若未断云何未断。谓未离欲染必亦有未来恚结系义。设有未来恚结系。复有过去爱结系耶。答若前生未断则系。若前未生设生已断则不系。谓于此事若有未来恚结未断。亦有前生爱结未断。即于此事亦有过去爱结系义。若于此事虽有未来恚结未断而前于此爱结未生。虽余处生而于此事亦名未生。设生已断即于此事无有过去爱结系义。若于此事有过去爱结系。亦有现在恚结系耶。答若现在前。谓于此事若有前生爱结未断。亦有恚结现在前则有现在恚结系义。若于此事或起余结现在前。或起善无覆无记心现在前。或于余处起恚结现在前。或无心时则无现在恚结系义。设有现在恚结系复有过去爱结系耶。答若前生未断则系。若前未生设生已断则不系。谓于此事若有恚结现在前亦有爱结前生未断。即于此事亦有过去爱结系义。若于此事虽有恚结现在前而前于此爱结未生。虽余处生而于此事亦名未生。设生已断即于此事无有过去爱结系义。若于此事有过去爱结系亦有过去现在恚结系耶。答此中有四句。或有过去爱结系。无过去现在恚结系。谓于此事有爱结前生未断。无恚结前生。设生已断不现在前。此中有爱结前生未断者。显有过去爱结。无恚结前生设生已断者。遮有过去恚结。不现在前者。遮有现在恚结。或有过去爱结系及有过去恚结系无现在。谓于此事有爱结恚结前生未断无恚结现在前。此中有爱结恚结前生未断者。显有过去爱结恚结。无恚结现在前者。遮有现在恚结。或有过去爱结系。及有现在恚结系无过去。谓于此事有爱结前生未断。有恚结现在前而前未生设生已断。此中有爱结前生未断者。显有过去爱结。有恚结现在前者。显有现在恚结。而前未生设生已断者。遮有过去恚结。或有过去爱结系。及有过去现在恚结系。谓于此事有爱结恚结前生未断及有恚结现在前。此中有爱结恚结前生未断者。显有过去爱结恚结。有恚结现在前者。显有现在恚结。设有过去现在恚结系。复有过去爱结系耶。答若前生未断则系。若前未生设生已断则不系。此中义意广如前说。若于此事有过去爱结系。亦有未来现在恚结系耶。答此中有三句。或有过去爱结系无未来现在恚结系。谓于色无色界法有爱结前生未断。此中有爱结前生未断者。显有过去爱结。于色无色界法者。遮有未来现在恚结。彼无恚结如前应知。或有过去爱结系及有未来恚结系无现在。谓于此事有爱结前生未断及有恚结未断不现在前。此中有爱结前生未断者。显有过去爱结。及有恚结未断者。显有未来恚结。未断者必有未来系义故。不现在前者。遮有现在恚结。或有过去爱结系亦有未来现在恚结系。谓于此事有爱结前生未断及有恚结现在前。此中有爱结前生未断者。显有过去爱结。及有恚结现在前者。显有现在恚结。此未来有不说自成。以现在前者未来必有故。设有未来现在恚结系。复有过去爱结系耶。答若前生未断则系。若前未生设生已断则不系。此中义意广如前说

若于此事有过去爱结系。亦有过去未来恚结系耶。答此中有三句。或有过去爱结系。无过去未来恚结系。谓于色无色界法有爱结前生未断。此中有爱结前生未断者显有过去爱结。于色无色界法者。遮有过去未来恚结。或有过去爱结系。及有未来恚结系无过去。谓于此事有爱结前生未断。及有恚结未断。而无恚结前生设生已断。此中有爱结前生未断者。显有过去爱结。有恚结未断者。显有未来恚结。无恚结前生设生已断者。遮有过去恚结。或有过去爱结系。亦有过去未来恚结系。谓于此事有爱结恚结前生未断。此中有爱结前生未断者。显有过去爱结。有恚结前生未断。者显有过去恚结此未来有不说自成。以有过去者未来必有故。设有过去未来恚结系。复有过去爱结系耶。答若前生未断则系。若前未生设生已断则不系。此中义意广如前说。若于此事有过去爱结系。亦有过去未来现在恚结系耶。答此中有五句。或有过去爱结系。无过去未来现在恚结系。谓于色无色界法有爱结前生未断。此中有爱结前生未断者。显有过去爱结。于色无色界法者遮有三世恚结。或有过去爱结系及有未来恚结系。无过去现在。谓于此事有爱结前生未断。及有恚结未断。而前未生设生已断不现在前。此中有爱结前生未断者。显有过去爱结。有恚结未断者。显有未来恚结。而前未生设生已断者。遮有过去恚结。不现在前者遮有现在恚结。或有过去爱结系。及有未来现在恚结系无过去。谓于此事有爱结前生未断。及有恚结现在前。而前未生设生已断。此中有爱结前生未断者。显有过去爱结有恚结现在前者。显有现在恚结。此未来有不说自成。义如前说。而前未生设生已断者。遮有过去恚结。或有过去爱结系及有过去未来恚结系无现在。谓于此事有爱结恚结前生未断而无恚结现在前。此中有爱结前生未断者。显有过去爱结。有恚结前生未断者。显有过去恚结。此未来有不说自成。义如前说。而无恚结现在前者。遮有现在恚结。或有过去爱结系。亦有过去未来现在恚结系。谓于此事有爱结恚结前生未断。及有恚结现在前。此中有爱结前生未断者。显有过去爱结。有恚结前生未断者。显有过去恚结。有恚结现在前者。显有现在恚结。此未来有不说自成。有过去现在者必亦有未来故。设有过去未来现在恚结系。复有过去爱结系耶。答若前生未断则系。若前未生设生已断则不系。此中义意广如前说。如对恚结对嫉结悭结亦尔。俱唯欲界故。以爱对彼作小七句。如对恚结。说差别者。于欲界见所断法。及于色无色界法。有爱结前生未断。无过去未来现在嫉结悭结。此中有爱结前生未断者显二七句。中有过去爱结于欲界见所断法。及于色无色界法无三世嫉悭结者。遮二七句。中有过去未来现在嫉悭结。此于欲界见所断法与前差别。以嫉悭二结唯修所断故。若于此事有过去爱结系亦有过去慢结系耶。答若前生未断则系。若前未生设生已断则不系。谓于此事若有前生爱结未断亦有前生慢结未断。即于此事亦有过去慢结系义。若于此事虽有前生爱结未断而前于此慢结未生。虽余处生而于此事亦名未生。设生已断即于此事无有过去慢结系义。设有过去慢结系。复有过去爱结系耶。答若前生未断则系。若前未生设生已断则不系。谓于此事若有前生慢结未断。亦有前生爱结未断。即于此事亦有过去爱结系义。若于此事虽有前生慢结未断而前于此爱结未生。虽余处生而于此事亦名未生。设生已断即于此事无有过去爱结系义。若于此事有过去爱结系。亦有未来慢结系耶。答如是。所以者何。前说慢结于三界五部事能为系。未来未断定系彼三世一切事故。设有未来慢结系复有过去爱结系耶。答若前生未断则系。若前未生设生已断则不系。谓于此事若有未来慢结未断。亦有前生爱结未断。即于此事亦有过去爱结系义。若于此事虽有未来慢结未断而前于此爱结未生。虽余处生而于此事亦名未生。设生已断即于此事无有过去爱结系义。若于此事有过去爱结系。亦有现在慢结系耶。答若现在前。谓于此事若有前生爱结未断。亦有慢结现在前则有现在慢结系义。若于此事或起余结现在前。或起善无覆无记心现在前。或于余处起慢结现在前。或无心时则无现在慢结系义。设有现在慢结系。复有过去爱结系耶。答若前生未断则系。若前未生设生已断则不系。谓于此事若有慢结现在前。亦有爱结前生未断即于此事亦有过去爱结系义。若于此事虽有慢结现在前而前于此爱结未生。虽余处生而于此事亦名未生。设生已断即于此事无有过去爱结系义。若于此事有过去爱结系。亦有过去现在慢结系耶。答此中有四句。或有过去爱结系无过去现在慢结系。谓于此事有爱结前生未断。无慢结前生设生已断不现在前。此中有爱结前生未断者。显有过去爱结未断。无慢结前生设生已断者。遮有过去慢结。不现在前者遮有现在慢结。或有过去爱结系。及有过去慢结系无现在。谓于此事有爱结慢结前生未断。无慢结现在前。此中有爱结慢结前生未断者。显有过去爱结慢结。无慢结现在前者。遮有现在慢结。或有过去爱结系。及有现在慢结系无过去。谓于此事有爱结前生未断。及有慢结现在前而前未生设生已断。此中有爱结前生未断者。显有过去爱结。有慢结现在前者。显有现在慢结。而前未生设生已断者。遮有过去慢结。或有过去爱结系。及有过去现在慢结系谓于此事有爱结慢结前生未断及有慢结现在前。此中有爱结慢结前生未断者。显有过去爱结慢结。有慢结现在前者显有现在慢结。设有过去现在慢结系。复有过去爱结系耶。答若前生未断则系。若前未生设生已断则不系。此中义意广如前说

若于此事有过去爱结系亦有未来现在慢结系耶。答未来必系现在若现在前。此中未来必系者。未来慢结若未断时定系三界五部一切事故。现在若现在前者义如前说。设有未来现在慢结系。复有过去爱结系耶。答若前生未断则系。若前未生设生已断则不系。此中义意广如前说。若于此事有过去爱结系。亦有过去未来慢结系耶。答未来必系过去。若前生未断则系。若前未生设生已断则不系。此中二义并如前说。设有过去未来慢结系。复有过去爱结系耶。答若前生未断则系。若前未生设生已断则不系。此中义意亦如前说。若于此事有过去爱结系。亦有过去未来现在慢结系耶。答此中有四句。或有过去爱结系及有未来慢结系。无过去现在。谓于此事有爱结前生未断。无慢结前生设生已断不现在前。此中有爱结前生未断者显有过去爱结。无慢结前生设生已断者。遮有过去慢结。不现在前者。遮有现在慢结。此未来有不说自成。彼爱结未断此慢必有故。或有过去爱结系。及有过去未来慢结系无现在。谓于此事有爱结慢结前生未断无慢结现在前。此中有爱结慢结前生未断者。显有过去爱结慢结。无慢结现在前者。遮有现在慢结。此未来有不说自成。义如前说。或有过去爱结系。及有未来现在慢结系无过去。谓于此事有爱结前生未断。及有慢结现在前而无前生设生已断。此中有爱结前生未断者。显有过去爱结。有慢结现在前者。显有现在慢结。而无前生设生已断者。遮有过去慢结。此未来有不说自成。慢结现在前必有未来故。或有过去爱结系。亦有过去未来现在慢结系。谓于此事有爱结慢结前生未断。及有慢结现在前。此中有爱结慢结前生未断者。显有过去爱结慢结。有慢结现在前者。显有现在慢结。此未来有不说自成。义如前说。设有过去未来现在慢结系。复有过去爱结系耶。答若前生未断则系。若前未生设生已断则不系。此中义意广如前说。若于此事有过去爱结系。亦有过去无明结系耶。答如是。所以者何。前说迷共相诸结于三界五部事能为系。过去未断定系彼三世一切事。无明既亦是共相结故答如是。设有过去无明结系复有过去爱结系耶。答若前生未断则系。若前未生设生已断则不系。谓于此事若有前生无明结未断。亦有前生爱结未断。即于此事亦有过去爱结系义。若于此事虽有前生无明结未断。而前于此爱结未生。虽余处生而于此事亦名未生。设生已断即于此事无有过去爱结系义。若于此事有过去爱结系亦有未来无明结系耶。答如是。所以者何。前说共相诸结于三界五部事能为系。未来未断定系彼三世一切事故。设有未来无明结系。复有过去爱结系耶。答若前生未断则系。若前未生设生已断则不系。谓于此事若有未来无明结未断。亦有前生爱结未断。即于此事亦有过去爱结系义。若于此事虽有未来无明结未断而前于此爱结未生。虽余处生而于此事亦名未生。设生已断即于此事无有过去爱结系义。若于此事有过去爱结系。亦有现在无明结系耶。答若现在前。谓于此事若有前生爱结未断。亦有无明结现在前则有现在无明结系义。若于此事或起善无覆无记心现在前。或于余处起无明结现在前或无心时则无现在无明结系义。设有现在无明结系。复有过去爱结系耶。答若前生未断则系。若前未生设生已断则不系。谓于此事若有无明结现在前。亦有爱结前生未断。即于此事亦有过去爱结系义。若于此事虽有无明结现在前。而前于此爱结未生。虽余处生而于此事亦名未生。设生已断即于此事。无有过去爱结系义若于此事有过去爱结系。亦有过去现在无明结系耶。答过去必系现在若现在前。此中义意并如前说。设有过去现在无明结系。复有过去爱结系耶。答若前生未断则系。若前未生设生已断则不系。此中义意广如前说。若于此事有过去爱结系。亦有未来现在无明结系耶。答未来必系现在若现在前。此中义意并如前说。设有未来现在无明结系。复有过去爱结系耶。答若前生未断则系。若前未生设生已断则不系。此中义意广如前说。若于此事。有过去爱结系。亦有过去未来无明结系耶。答如是。所以者何。前说共相诸结于三界五部事能为系。过去未来未断定系彼三世一切事故。设有过去未来无明结系。复有过去爱结系耶。答若前生未断则系。若前未生设生已断则不系。此中义意广如前说。若于此事有过去爱结系。亦有过去未来现在无明结系耶。答过去未来必系。现在若现在前。此中义意皆如前说。设有过去未来现在无明结系。复有过去爱结系耶。答若前生未断则系。若前未生设生已断则不系。此中义意广如前说

说一切有部发智大毗婆沙论卷第五十八阿毗达磨大毗婆沙论卷第五十九

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中一行纳息第二之四

若于此事有过去爱结系。亦有过去见结系耶。答若未断。谓于此事若有前生爱结未断。见结亦未断。即于此事亦有过去见结系义。若于此事虽有前生爱结未断而见结已断。即于此事无有过去见结系义。如道类智已生于修所断法。有爱结前生未断。集类智已生于见灭道所断见结不相应法。有爱结前生未断。由此义故。此中总说若未断言。不说道类智未至已生位。由彼位亦有有爱无见故。迷共相结过去未断必系三世所系事故。非如爱等作不定说。设有过去见结系。复有过去爱结系耶。答若前生未断则系。若前未生设生已断则不系。谓于此事若有前生见结未断。亦有前生爱结未断。即于此事亦有过去爱结系义。若于此事虽有前生见结未断。而前于此爱结未生。虽余处生而于此事亦名未生。设生已断。即于此事无有过去爱结系义。若于此事有过去爱结系。亦有未来见结系耶。答若未断。谓于此事若有前生爱结未断见结亦未断。即于此事亦有未来见结系义。若于此事虽有前生爱结未断。而见结已断。即于此事无有未来见结系义。余如前说。设有未来见结系复有过去爱结系耶。答若前生未断则系。若前未生设生已断则不系。谓于此事。若有未来见结未断。亦有前生爱结未断。即于此事亦有过去爱结系义。若于此事虽有未来见结未断。而前于此爱结未生。虽余处生而于此事亦名未生。设生已断。即于此事无有过去爱结系义若于此事有过去爱结系。亦有现在见结系耶。答若现在前。谓于此事若有前生爱结未断。亦有见结现在前则有现在见结系义。若于此事。或起余结现在前。或起善无覆无记心现在前。或于余处起见结现在前。或无心时则无现在见结系义。设有现在见结系。复有过去爱结系耶。答若前生未断则系。若前未生设生已断则不系。谓于此事若有见结现在前。亦有爱结前生未断。即于此事亦有过去爱结系义。若于此事虽有见结现在前。而前于此爱结未生。虽余处生而于此事亦名未生。设生已断。即于此事无有过去爱结系义。若于此事有过去爱结系亦有过去现在见结系耶。答此中有三句。或有过去爱结系。无过去现在见结系。谓于此事有爱结前生未断而见结已断。此中有爱结前生未断者。显有过去爱结。而见结已断者遮有过去现在见结。谓集类智已生。于见灭道所断见结不相应法。有前生爱结未断。道类智已生。于修所断法。有前生爱结未断。或有过去爱结系及有过去见结系。无现在。谓于此事有爱结前生未断。及有见结未断而不现在前。此中有爱结前生未断者。显有过去爱结。有见结未断者。显有过去见结。彼未断位于所系事必有过去见结系故。而不现在前者。遮有现在见结。或有过去爱结系。亦有过去现在见结系。谓于此事有爱结前生未断。亦有见结现在前。此中有爱结前生未断者。显有过去爱结。亦有见结现在前者。显有现在见结。此过去有不说自成。见结现在前过去必有故。设有过去现在见结系。复有过去爱结系耶。答若前生未断则系。若前未生设生已断则不系。此中义意广如前说。若于此事有过去爱结系。亦有未来现在见结系耶。答此中有三句。或有过去爱结系。无未来现在见结系。谓于此事有爱结前生未断。而见结已断。此中有爱结前生未断者。显有过去爱结。而见结已断者。遮有未来现在见结。余如前说。或有过去爱结系。及有未来见结系无现在。谓于此事有爱结前生未断。及有见结未断而不现在前。此中有爱结前生未断者。显有过去爱结有见结未断者。显有未来见结。彼未断位于所系事必有未来见结系故。而不现在前者。遮有现在见结。或有过去爱结系亦有未来现在见结系。谓于此事有爱结前生未断。及有见结现在前。此中有爱结前生未断者。显有过去爱结。有见结现在前者。显有现在见结。此未来有不说自成。见结现在前未来必有故。设有未来现在见结系。复有过去爱结系耶。答若前生未断则系。若前未生设生已断则不系。此中义意广如前说。若于此事有过去爱结系。亦有过去未来见结系耶。答若未断。此中义意如前应知。设有过去未来见结系。复有过去爱结系耶。答若前生未断则系。若前未生设生已断则不系。此中义意广如前说。若于此事有过去爱结系。亦有过去未来现在见结系耶。答此中有三句。或有过去爱结系。无过去未来现在见结系。谓于此事有爱结前生未断。而见结已断。此中有爱结前生未断者。显有过去爱结而见结已断者。遮有过去未来现在见结。谓集类智已生。见灭道所断见结不相应法。有爱结前生未断。道类智已生。修所断法有爱结前生未断。或有过去爱结系。及有过去未来见结系无现在。谓于此事有爱结前生未断。及有见结未断而不现在前。此中有爱结前生未断者。显有过去爱结。有见结未断者。显有过去未来见结。而不现在前者遮有现在见结。或有过去爱结系。亦有过去未来现在见结系。谓于此事有爱结前生未断。亦有见结现在前。此中有爱结前生未断者。显有过去爱结。亦有见结现在前者。显有现在见结。此过去未来有不说自成。见结现在前必有过去未来故。设有过去未来现在见结系。复有过去爱结系耶。答若前生未断则系。若前未生设生已断则不系。此中义意广如前说。如对见结对取结疑结亦尔。俱唯三界见所断故。以爱对彼作小七句。如对见说。于中亦有少分差别。谓取结唯有道类智已生。于修所断法有爱结前生未断者。有过去爱。无三世取。非如见结集类智已生于见灭道所断见结不相应法。有爱结前生未断者。亦有过去爱无三世见。差别义少故此不说。如爱结对后作小七。乃至嫉结对悭结随其所应作小七亦尔。此中随其所应者。唯慢与爱俱通三界五部。唯有漏缘非遍行故。对后作小七句。皆如爱说。无明通三界五部。有漏无漏缘遍行非遍行见疑通三界唯四部通有漏无漏缘遍行非遍行。二取通三界唯四部。有漏缘通遍行非遍行。恚唯欲界通五部。唯有漏缘非遍行。嫉悭唯欲界修所断有漏缘非遍行。如是诸结宽狭有异。对后七句有不同者。是故须说随所应言

如小七大七亦尔差别者。以二对一乃至以八对一。谓以过去爱结恚结。先对过去慢结。次对未来。次对现在。次对过去现在。次对未来现在。次对过去未来。后对过去未来现在。慢结作七句如以过去爱结恚结。对慢结作七句。对无明结见结取结疑结嫉结悭结各作七句亦尔。次除爱结。以过去恚结慢结先对过去无明结。次对未来。次对现在。次对过去现在。次对未来现在。次对过去未来。后对过去未来现在无明结作七句。如以过去恚结慢结。对无明结作七句。对见结取结疑结嫉结悭结各作七句亦尔。次除恚结。以过去慢结无明结。先对过去见结。次对未来。次对现在。次对过去现在。次对未来现在。次对过去未来。后对过去未来现在见结作七句。如以过去慢结无明结对见结作七句。对取结疑结嫉结悭结各作七句亦尔。次除慢结。以过去无明结见结。先对过去取结。次对未来。次对现在。次对过去现在次对未来现在。次对过去未来。后对过去未来现在取结作七句。如以过去无明结见结。对取结作七句对疑结嫉结悭结各作七句亦尔。次除无明结。以过去见结取结。先对过去疑结。次对未来。次对现在。次对过去现在。次对未来现在。次对过去未来。后对过去未来现在疑结作七句。如以过去见结取结对疑结作七句。对嫉结悭结各作七句亦尔。次除见结。以过去取结疑结。先对过去嫉结。次对未来。次对现在。次对过去现在。次对未来现在。次对过去未来。后对过去未来现在嫉结作七句。如以过去取结疑结对嫉结作七句。对悭结作七句亦尔。复除取结。以过去疑结嫉结。先对过去悭结。次对未来。次对现在。次对过去现在次对未来现在。次对过去未来。后对过去未来现在悭结作七句。如以二结对一结。以三以四以五以六以七以八结对一结亦尔

如过去爱等为首有七。乃至过去未来现在爱等为首亦各有七。如是应知有七七句。此中有说以过去爱等。先对过去恚等。次对未来。次对现在。次对过去现在。次对未来现在。次对过去未来。后对过去未来现在恚等为初七句。以过去爱等。先对未来恚等。次对现在。次对过去现在。次对未来现在。次对过去未来。次对过去未来现在。后对过去恚等为第二七句。以过去爱等。先对现在恚等。次对过去现在。次对未来现在。次对过去未来。次对过去未来现在。次对过去。后对未来恚等为第三七句。以过去爱等。先对过去现在恚等。次对未来现在。次对过去未来。次对过去未来现在。次对过去。次对未来。后对现在恚等。为第四七句以过去爱等。先对未来现在恚等。次对过去未来。次对过去未来现在。次对过去。次对未来。次对现在后对过去现在恚等。为第五七句。以过去爱等。先对过去未来恚等。次对过去未来现在。次对过去。次对未来。次对现在。次对过去现在。后对未来现在恚等。为第六七句。以过去爱等。先对过去未来现在恚等。次对过去。次对未来。次对现在。次对过去现在。次对未来现在。后对过去未来恚等。为第七七句。是谓小七。以过去爱恚等。先对过去慢等。次对未来。次对现在。次对过去现在。次对未来现在。次对过去未来。后对过去未来现在慢等为初七句。以过去爱恚等。先对未来慢等。次对现在。次对过去现在。次对未来现在。次对过去未来。次对过去未来现在。后对过去慢等。为第二七句。以过去爱恚等。先对现在慢等。次对过去现在。次对未来现在。次对过去未来。次对过去未来现在。次对过去。后对未来慢等为第三七句。以过去爱恚等。先对过去现在慢等。次对未来现在。次对过去未来。次对过去未来现在。次对过去。次对未来。后对现在慢等。为第四七句。以过去爱恚等。先对未来现在慢等。次对过去未来。次对过去未来现在。次对过去。次对未来。次对现在。后对过去现在慢等。为第五七句。以过去爱恚等。先对过去未来慢等。次对过去未来现在。次对过去。次对未来。次对现在。次对过去现在。后对未来现在慢等。为第六七句。以过去爱恚等。先对过去未来现在慢等。次对过去。次对未来。次对现在。次对过去现在。次对未来现在。后对过去未来慢等。为第七七句是谓大七。如是所说唐捐其功。于文无益于义无益。以重说故。又非唯七七句应作是说。以过去爱等。先对过去恚等。次对未来。次对现在。次对过去现在。次对未来现在。次对过去未来。后对过去未来现在恚等。为初七句。以未来爱等。先对未来恚等。次对现在。次对过去现在。次对未来现在。次对过去未来。次对过去未来现在。后对过去恚等。为第二七句。以现在爱等。先对现在恚等。次对过去现在。次对未来现在。次对过去未来。次对过去未来现在。次对过去。后对未来恚等。为第三七句。以过去现在爱等。先对过去现在恚等。次对未来现在。次对过去未来。次对过去未来现在。次对过去。次对未来。后对现在。为第四七句。以未来现在爱等。先对未来现在恚等。次对过去未来次对过去未来现在。次对过去。次对未来。次对现在。后对过去现在恚等。为第五七句。以过去未来爱等。先对过去未来恚等。次对过去未来现在。次对过去。次对未来。次对现在。次对过去现在。后对未来现在恚等。为第六七句。以过去未来现在爱等。先对过去未来现在恚等。次对过去。次对未来。次对现在。次对过去现在。次对未来现在。后对过去未来恚等。为第七七句。是谓小七。以过去爱恚等。先对过去慢等。次对未来。次对现在。次对过去现在。次对未来现在。次对过去未来。后对过去未来现在慢等。为初七句。以未来爱恚等。先对未来慢等。次对现在。次对过去现在。次对未来现在。次对过去未来。次对过去未来现在。后对过去慢等。为第二七句。以现在爱恚等。先对现在慢等。次对过去现在。次对未来现在。次对过去未来。次对过去未来现在。次对过去。后对未来慢等。为第三七句。以过去现在爱恚等。先对过去现在慢等。次对未来现在。次对过去未来。次对过去未来现在。次对过去。次对未来。后对现在慢等。为第四七句。以未来现在爱恚等。先对未来现在慢等。次对过去未来。次对过去未来现在。次对过去。次对未来。次对现在。后对过去现在慢等。为第五七句。以过去未来爱恚等。先对过去未来慢等。次对过去未来现在。次对过去。次对未来。次对现在。次对过去现在。后对未来现在慢等。为第六七句。以过去未来现在爱恚等。先对过去未来现在慢等。次对过去。次对未来。次对现在。次对过去现在。次对未来现在。后对过去未来慢等。为第七七句。若作是说功不唐捐。于文有益于义有益。不重说故。又唯有七七句

问一行历六小七大七。有何差别。答名即差别。谓名一行。名历六。名小七。名大七故。复次依一行法作问答故名一行。依六句法作问答故名历六。依七句法作问答以一对一故名小七。依七句法作问答以二对一。乃至以八对一故名大七。复次以不相似法对不相似法作问答。不以世定故名一行。以相似法对相似法作问答。以世定故名历六。以不相似法对不相似法作问答。以世定以一对一故名小七。以不相似法对不相似法作问答。以世定以二对一。乃至以八对一故名大七。一行历六小七大七。是谓差别

三结乃至九十八随眠。于九十八随眠中。一一摄几随眠。答一切应分别。问何故作此论。答为止他宗显正义故。谓或有说。诸法摄他性非自性摄。如分别论者。彼依假名契经。及依世俗言论故作是说。依假名契经者。如契经说。诸台帐等所有中心为台帐等。众材所依能任持彼令不散坠。故说中心能摄于彼。然彼中心与众材异而说能摄。故知诸法皆摄他性非自性摄。余经亦说于五根中慧根最胜。慧根能摄诸余四根。然彼慧根与四根异而说能摄。故知诸法皆摄他性非自性摄。又余经说。世尊告彼手长者言。汝以何法摄自徒众。徒众云何受汝所摄。手长者言。世尊为我说四摄事。一者布施。二者爱语。三者利行。四者同事。我以此四摄自徒众。徒众由此受我所摄。然手长者与徒众异而说摄众。故知诸法皆摄他性非自性摄。余经复说。正见正思惟正精进慧蕴摄。正念正定定蕴摄。然正思惟正精进与慧蕴异。正念与定蕴异。而说彼摄。故知诸法皆摄他性非自性摄。依世俗言论者。谓世间说户枢摄扇缕摄衣服附摄薪等。在家者说。我能摄田诸畜财宝僮仆家属出家者说。我摄徒众资具衣钵。如是能摄与所摄异。故知诸法皆摄他性。为止彼意显一切法皆摄自性是胜义摄。若摄他性是胜义者。则一法自性应是一切法。一法生时一切法应生。一法灭时一切法应灭。复有别失。应见苦所断即见集灭道修所断摄。断见苦所断时见集所断等烦恼亦应断。若尔修后诸对治道应成无用。勿有此过故一切法唯摄自性是胜义摄。问若一切法唯摄自性是胜义摄非他性者。分别论者所引契经世俗言论当云何通。答所引契经是不了义。依假名说有别意趣。谓契经说。诸台帐等所有中心为台帐等。众材所依能任持彼。令不散坠。故说中心能摄彼者于任持义假立摄声。此任持彼不散坠故。假立摄名。非胜义摄。又契经说。于五根中慧根最胜。慧根能摄余四根者。于方便义假立摄声。慧为方便令余四根亦速运转能办大事。假立摄名。非胜义摄。又契经说。以四摄事摄徒众者。于能引彼令不离散假立摄声。由四摄事方便诱引假立摄名。非胜义摄。又契经说。正思惟正精进亦慧蕴摄。正念亦定蕴摄者。于随顺义假立摄声。以正思惟正精进随顺慧蕴。正念随顺定蕴故。假立摄名。非胜义摄又彼所引世俗言论。户枢摄扇缕摄衣服附摄薪等。依任持义假说摄名。非胜义摄。在家者说能摄田等。出家者说摄徒众等。依饶益义假说摄名。非胜义摄。摄他性者待时待因而立摄名。非究竟摄。待时者。谓有时能摄。有时不摄。待因者。谓有因能摄。有因不摄。故非究竟。如有颂曰

  有因故起爱　　有因故起憎
  世间无无因　　而起爱憎者

摄自性者。不待时因而有摄义。是究竟摄。不待时者。诸法无时不摄自性。以彼一切时不舍自体故。不待因者诸法无因而摄自性。以不待因缘而有自体故。若欲观察一切法者。应先观彼自性摄义。问观察诸法自性摄时。有何胜利得何功德。答除去我想及一合想。修习法想别想易满。谓诸有情若有我想一合想者。贪嗔痴等烦恼增盛。由增盛故不能解脱生老病死愁叹忧苦诸灾患事。若除我想及一合想。便观色法如面糗聚不久离散。观无色法前后不俱不久磨灭。总观一切有为之法。犹如沙抟风飘散坏。由此便得空解脱门相似种子。观有为法空非我故。便于生死深不愿乐。由此复得无愿解脱门相似种子。彼于生死不愿乐故。便于涅槃深心愿乐。由此复得无相解脱门相似种子。彼于如是三三摩地。依下生中依中生上依上发慧。离三界染得三菩提证永寂灭。观察诸法自性摄时。便获如是胜利功德。由此因缘故作斯论。此中一切应分别者。谓三结乃至九十八随眠。一一所摄随眠各异。是故一切皆应分别

谓三结中有身见结摄三者。谓此结于九十八随眠中摄三随眠。即三界见苦所断有身见随眠。此约总种类说摄三随眠。若别分别欲界者摄欲界有身见。色界者摄色界有身见。无色界者摄无色界有身见。此一一界有三世别。过去者摄过去有身见。未来者摄未来有身见。现在者摄现在有身见。此复一一有多刹那。各自相摄后准应知。戒禁取结摄六者。谓此结于九十八随眠中摄六随眠。即三界见苦道所断戒禁取随眠。疑结摄十二者。谓此结于九十八随眠中摄十二随眠。即三界见苦集灭道所断疑随眠。三不善根中贪嗔不善根各摄五者。谓摄欲界五部贪嗔。痴不善根摄四一少分者。谓摄欲界后四部及见苦所断不善无明。三漏中欲漏摄三十一者。谓摄欲界三十六随眠中除五无明余三十一。有漏摄五十二者。谓摄色无色界六十二随眠中除十无明余五十二。无明漏摄十五者。谓摄三界各五部无明。四瀑流中欲瀑流摄十九者。谓摄欲界五部贪嗔慢及四部疑。有瀑流摄二十八者。谓摄色无色界各五部贪慢及各四部疑。见瀑流摄三十六者。谓摄三界各十二见。即有身见边执见各一戒禁取二邪见见取各四为十二。无明瀑流摄十五者。谓摄三界各五部无明。如四瀑流四轭亦尔者。名义虽别而体同故。四取中欲取摄二十四者。谓摄欲界五部贪嗔慢无明及四部疑。见取摄三十者。谓摄三界各十见。即前所说十二见中除二戒禁取余十见。戒禁取摄六者。谓摄三界各二戒禁取。我语取摄三十八者。谓摄色无色界各五部贪慢无明及各四部疑。四身系中贪欲嗔恚身系各摄五者。谓摄欲界五部贪嗔。戒禁取身系摄六者。谓摄三界各二戒禁取。此实执身系摄十二者。谓摄三界各四见取。五盖中贪欲嗔恚盖各摄五者。谓摄欲界五部贪嗔。疑盖摄四者。谓摄欲界四部疑。余盖无所摄者。惛沉睡眠掉举恶作是缠性故。不摄随眠五结中贪慢结各摄十五者。谓摄三界各五部贪慢。嗔结摄五者。谓摄欲界五部嗔。嫉悭结无所摄者。此二结非随眠性故。五顺下分结中贪欲嗔恚结各摄五者。谓摄欲界五部贪嗔。有身见结摄三者。谓摄三界各一有身见。戒禁取结摄六者。谓摄三界各二戒禁取。疑结摄十二者。谓摄三界各四部疑。五顺上分结中色贪结摄一少分者。谓摄色界修所断少分贪。无色贪结摄一少分者。谓摄无色界修所断少分贪。掉举结无所摄者。非随眠性故。慢结摄二少分者。谓摄色无色界各修所断少分慢。无明结摄二少分者。谓摄色无色界各修所断少分无明五见中有身见边执见各摄三者。谓摄三界各一有身见边执见。邪见见取各摄十二者。谓摄三界各四邪见见取。戒禁取摄六者。谓摄三界各二戒禁取。六爱身中眼耳身触所生爱身各摄二少分者。谓各摄欲色界修所断各少分贪。鼻舌触所生爱身各摄一少分者。谓各摄欲界修所断少分贪。意触所生爱身摄十三二少分者。谓摄三界各前四部。及无色界修所断贪并欲色界修所断各少分贪。七随眠中欲贪嗔恚随眠各摄五者。谓摄欲界五部贪嗔。有贪随眠摄十者。谓摄色无色界各五部贪慢。无明随眠各摄十五者。谓摄三界各五部慢无明。见随眠摄三十六者。谓摄三界各十二见。疑随眠摄十二者。谓摄三界各四部疑。九结中爱慢无明结各摄十五者。谓摄三界各五部贪慢无明。恚结摄五者。谓摄欲界五部嗔见。取结各摄十八者。谓见结摄三界各一有身见边执见四邪见。取结摄三界各二戒禁取四见取。疑结摄十二者。谓摄三界各四部疑。嫉悭结无所摄者。非随眠性故。九十八随眠中欲界有身见摄欲界有身见。乃至无色界修所断无明。摄无色界修所断无明者。各各自摄彼自性故。问云何诸法各摄自性。答自性于自性是有是实是可得故说名为摄。自性于自性非异非外非离非别恒不空故说名为摄。自性于自性非不已有非不今有非不当有故名为摄。自性于自性非增非减故名为摄。诸法自性摄自性时。非如以手取食指捻衣等。然彼各各执持自体令不散坏故名为摄。于执持义立以摄名。故胜义摄唯摄自性

说一切有部发智大毗婆沙论卷第五十九阿毗达磨大毗婆沙论卷第六十

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中一行纳息第二之五

三结乃至九十八随眠。为前摄后后摄前耶。问何故作此论。答为重遮遣分别论者执他性摄。及重开显应理论者说自性摄令转分明故作斯论。答三结三不善根互不相摄者。谓自性各别。故三结三漏三结二漏少分互相摄余不相摄者。谓三结与欲漏有漏中有身见戒禁取疑互相摄。自性同故。与无明漏及二漏少分互不相摄。自性异故。后准应知。三结四瀑流三结三瀑流少分互相摄。余不相摄者。谓三结与欲有见瀑流中有身见戒禁取疑互相摄。与无明瀑流及三瀑流少分互不相摄。如对四瀑流对四轭亦尔。自性同故。三结四取三结一取三少分互相摄余不相摄者。谓三结与戒禁取及余三取中有身见疑互相摄。与余三取少分互不相摄。三结四身系一结一身系互相摄。余不相摄者。谓戒禁取结与戒禁取身系互相摄。与余三身系互不相摄。三结五盖一结少分一盖互相摄。余不相摄者。谓疑结中不善者与疑盖互相摄。与余四盖互不相摄。三结五结互不相摄者。自性异故。三结五顺下分结三结三顺下分结互相摄。余不相摄者。谓三结与五顺下分结中有身见戒禁取疑结互相摄。与余二结互不相摄。三结五顺上分结互不相摄者。自性异故。三结五见二结二见互相摄。余不相摄者。谓前三结与五见中有身见戒禁取互相摄。与余三见互不相摄。三结六爱身互不相摄者。自性异故。三结七随眠三结一随眠一少分互相摄余不相摄者。谓三结与疑随眠及见随眠中有身见戒禁取互相摄。与余五随眠及见随眠中余三见互不相摄。三结九结三结一结二少分互相摄。余不相摄者。谓三结与九结中疑结及见结中有身见取结中戒禁取互相摄。与余六结及见结中余二见取结中见取互不相摄。三结九十八随眠三结二十一随眠互相摄。余不相摄者。谓三结与九十八随眠中三有身见六戒禁取十二疑随眠互相摄。与余七十七随眠互不相摄。如是乃至九结九十八随眠。七结九十八随眠互相摄。余不相摄者。谓九结中前七结与九十八随眠互相摄。后二结与随眠互不相摄。此二俱非随眠性故。此中举初三结举后九结与后广辨相摄。三不善根乃至七随眠与后相摄略不说者。相易了故。三结乃至九十八随眠。几令欲有相续几令色有相续。几令无色有相续。答一切应分别。问何故作此论。答为止他宗显己义故。谓或有执不染污心亦令有相续如分别论者。问彼何故作此执。答彼依契经故作此执。谓契经说。菩萨正知入母胎。正知住母胎。正知出母胎。既有正知。入母胎者。正知即在不染污心故。不染污心亦令有相续。为遮彼意显唯染污心能令有相续故作斯论。问云何通彼所引契经。答依无倒想说正知言。谓诸有情多起倒想而入母胎。男入胎时于母起爱于父起恚。女入胎时于父起爱于母起恚。谓彼与己有顺违故。后有菩萨入母胎时心无颠倒。于父父想。于母母想。虽俱亲爱而无异心。有亲爱故心有染污。无倒想故名为正知。故彼契经不违我义。复次所以作此论者。谓或有执。唯爱与恚令有相续如譬喻者。问彼何故作此执。答依契经故。谓契经说三事合故得入母胎。一者父母交爱和合。二者母身是时调适。三健达缚正现在前。时健达缚二心互起。谓爱恚俱。由此故知唯爱与恚令有相续。为遮彼意显一切烦恼皆令有相续故作斯论。问云何通彼所引契经答契经说。彼中有位心正结生时非唯爱恚。故我所说不违彼经。复次所以作此论者。谓或有执恶趣唯用恚心结生。善趣唯用爱心结生为遮彼意显欲界一切处三十六随眠一一现前令生相续。色界一切处三十一随眠一一现前令生相续。无色界一切处三十一随眠一一现前令生相续故作斯论。复次勿为止他显示己义。然为显示诸法正理开悟有情故作斯论。然诸有声说多种义。此中有者说众同分及随众同分有情数五蕴。如说诸在欲界死生者。皆受欲有邪等。彼亦说众同分及随众同分有情数五蕴。如说诸缠所缠受地狱有等。彼亦说众同分及随众同分有情数五蕴。如说受欲有时最初得几业所生根等。彼亦说众同分及随众同分有情数五蕴。如说四有谓本有死有中有生有。彼亦说众同分及随众同分有情数五蕴。如说诸舍欲有受欲有。彼一切欲界法灭。欲界法现在前邪等。彼亦说众同分及随众同分有情数五蕴。如说云何有法。谓一切有漏法。彼说一切有漏法名有。如说颇勒惧那当知识食能令后有生起。彼说结生心及眷属名有。如说阿罗陀当知若业能令后有相续。是名有者。彼说能引后有思名有。如说取缘有。阿毗达磨诸论师言。彼说时分五蕴名有。尊者妙音作如是说。彼说能引后有诸业名有。如说七有。一地狱有。二傍生有。三鬼界有。四天有。五人有。六业有。七中有。彼说五趣及彼因彼方便名有。谓地狱有等即是五趣。业有是彼因。中有是彼方便。如说云何欲有。谓诸业欲界系取为缘。能趣后生。乃至广说。彼说业及异熟名有。不说取缘。问若尔。门论所说当云何通。如说欲有欲界一切随眠随增。色有色界一切随眠随增。无色有无色界一切随眠随增。欲有可尔。所以者何。欲界五部业皆能感异熟。彼容欲界一切随眠所随增故。色无色有云何可尔。所以者何。彼界唯有修所断业感异熟故。答彼门论中。应说欲有欲界一切随眠随增。色有色界遍行及修所断随眠随增。无色有无色界遍行及修所断随眠随增。而不尔者。有别意趣。谓五部结有心是有眷属。故亦假说为有。故说一切随眠随增。有说。彼论有章有门。章中但说业及异熟名有不说取缘。门中具说彼业异熟及说取缘。故说一切随眠随增。评曰。彼不应作是说。所以者何。彼论师先立章义后以门通。如何门中与章说异。是故前说于理为善

问何故名有。答有增有减故名为有。问若尔。圣道亦有增减应亦名有。答若有增减亦能长养摄益任持有者说名为有。圣道虽有增减。而损减违害破坏诸有。故不名有。复次若有增减亦令诸有生老病死不断绝者说名为有。圣道虽有增减。而令诸有生老病死皆断不续故不名有。复次若有增减亦是趣苦集行。趣有世间生老病死集行者说名为有。圣道虽有增减。而是趣苦灭行趣有世间生老病死灭行故不名有。复次若有增减亦是萨迦耶见事。颠倒事爱事随眠事。贪嗔痴安足处。有垢有毒有过有刺有浊堕有堕苦集谛者说名为有。圣道虽有增减。而与此一切相违故不名有。复有说者。此可怖畏故名为有。问若尔。涅槃亦可怖畏。应亦名有。如契经说。苾刍当知。无闻异生。以愚痴故怖畏涅槃。谓于是处我不有。我所亦不有。我当不有。我所亦当不有。答若有怖畏是正见者起说名为有涅槃。虽有怖畏而是邪见者起故不名有。复次若有怖畏通异生及圣者起说名为有涅槃。虽有怖畏。而是异生非圣者起故不名有。有作是说。是苦法器故名为有。问有亦是乐法器。如契经说。大名当知。色若一向是苦非乐。非乐所随无少乐喜所随逐者应无有情为求乐故染着于色。大名当知。以色非一向苦亦是乐亦是乐所随是少乐喜所随逐故。有诸有情为求乐故染着于色。又契经说。决定建立三受无杂。一乐。二苦。三非苦乐。又契经说。道依道具涅槃依道以道乐故证乐涅槃。是故诸有非唯苦器。宁以苦器释有名耶。答生死法中虽有少乐而苦多故。立苦器名。是故诸有唯名苦器。如毒瓶中置一渧蜜。不由此故名为蜜瓶。但名毒瓶。以毒多故。有亦如是。多苦所依。但名苦器

然诸相续略有五种。一中有相续。二生有相续。三时分相续。四法性相续。五刹那相续。中有相续者。谓死有蕴灭中有蕴生。此中有蕴续死有蕴。是故名为中有相续。生有相续者。谓中有蕴灭或死有蕴灭生有蕴生。此生有蕴续中有蕴。或续死有蕴。是故名为生有相续。时分相续者。谓羯刺蓝乃至盛年时分蕴灭。頞部昙乃至老年时分蕴生。此頞部昙乃至老年时分蕴续羯刺蓝乃至盛年时分蕴。是故名为时分相续。法性相续者。谓善法无间不善法或无记法生。此不善法或无记法续前善法不善法。或无记法无间。广说亦尔。是故名为法性相续。刹那相续者。谓前前刹那无间后后刹那生。此后后刹那续前前刹那。是故名为刹那相续。此五相续亦得摄在二相续中。前三不离法性刹那二相续故。法性亦得入刹那中。一切皆是刹那性故。此五相续界者。欲界具五。色界唯四。除时分。无色界唯三。除中有及时分。趣者地狱唯四。除时分。余四趣皆具五。生者四生皆具五种相续。此中但依中生二有相续作论

谓三结令三有相续者。此依总种类说。然此三结通三界系。欲界系者令欲有相续。色界系者令色有相续。无色界系者令无色有相续。生有中有最初刹那随一现前而结生故。余随本论如理应知。问随眠能令诸有相续。非缠非垢不坚牢故。意地烦恼令有相续非五识身。正结生时定有意识无五识故。何缘本论说五盖嫉悭结鼻舌触所生爱身。令欲有相续。眼耳身触所生爱身令欲色有相续。掉举顺上分结令色无色有相续耶。答本论应说贪欲嗔恚疑盖令欲有相续。贪慢无明顺上分结令色无色有相续。意触所生爱身令三有相续。余二盖嫉悭结掉举顺上分结前五触所生爱身不令有相续。而不作是说者。应知此文有别意趣。谓未解脱余二盖等命终还生欲有等故。说彼能续欲有等言。然结生时非由彼力

复次由三缘故说诸烦恼令有相续。一未断故。二能感有异熟果故。三结生时能润有故。诸在意地不善随眠三缘具有。无记随眠不能感有。但有二缘。诸在五识不善随眠不能润有。但有二缘。无记随眠唯有未断无余二缘。不善缠垢但有二缘无能润有。无记缠垢唯有一缘。谓未断故。惛沈盖等由未断故。或感有故。说能续有非能润有。于理无违

三结乃至九十八随眠依何定灭。问何故作此论答欲显诸佛出现世时有胜事故。施设论说。绕赡部洲有转轮王路广一喻缮那。无轮王时海水所覆无能见者。若转轮王出现于世。大海水减一踰缮那。此轮王路尔乃出现。金沙遍布众宝庄严。栴檀香水以洒其上。转轮圣王巡幸洲渚与四种军俱游此路。如是诸佛未出世时。根本地依无能见者。诸有断结皆依边地。若具十力转法轮王出现于世。根本地依尔乃出现。菩提分法金沙遍布。种种功德众宝庄严。四澄净水以洒其上。佛与无量无边眷属。俱游此路趣涅槃城。由是因缘故作斯论。复次为遮分别论者有诸烦恼不依定灭。彼作是说。若有圣者生在非想非非想处。彼无圣道现在前义。寿量尽时烦恼亦尽成阿罗汉。名为齐顶。为遮彼执显无烦恼不依定灭故作斯论。此中定者显对治道。谓对治道或说为定。或说为道。或名对治。或名作意。或说为行。言虽有异其义无别。此中灭者显示永断。谓此永断或说为灭。或说为尽。或名离染。或名离系。或名解脱。言虽有异其义无别。昔此法内有二论师。一名侍毗罗。二名瞿沙伐摩。尊者侍毗罗作如是说。此中说永断无余断毕竟断无片影断。如是永断是圣者非异生。是圣道能非世俗道。所以者何。因七依经造此论故。彼经唯说七根本地。谓四静虑下三无色。非根本地有世俗道能断烦恼。故知唯圣者用无漏道断。尊者瞿沙伐摩作如是说。此中说永断无余断毕竟断无片影断。如是永断是圣者亦异生。是圣道能亦世俗道。问岂不此论因七依经如何异生依根本地起世俗道有永断义。答由此因缘说阿毗达磨照了契经等犹如明灯。契经等中所未说者此中说之。所未现者此中现之。彼有余说此无余说。是故圣者及诸异生依七根本及八边地起圣世俗道俱能永断结。如是二说俱得善通。此本论文容二义故

答三结或依四或依未至灭者。四谓四静虑地。未至谓未至地及静虑中间。此二俱名未至地故。问此地何故名未至耶。答未入根本能现在前断诸烦恼故名未至。问契经唯说根本为依非未至地。此中何故说三结或依四或依未至灭。答此中应说或依四或未至灭。不应言依未至灭。而言依未至灭者。有别意趣。谓后依言重说根本。此中意言三结或依四灭者。或四根本依灭或依未至灭者。或未至四根本依而灭。如有问他。汝为入城作此事。为未入城作此事。此中一城前后再说。依言亦尔。于理无违。复次依言有通有别。别者唯说诸根本地如七依经。通者通说根本边地。如此中说。故此依言亦不违理。然此三结依欲界乃至非想非非想处可得。欲界者唯依未至灭。初静虑者或依初静虑或依未至灭。第二静虑者或依二静虑或依未至灭。第三静虑者或依三静虑或依未至灭。第四静虑及四无色者。或依四静虑或依未至灭。所以者何。三结永断无余断毕竟断无片影断。必以见道。然诸见道唯依六地。谓四静虑及未至定静虑中间。若依未至定入正性离生。如是三结依未至灭。乃至若依第四静虑入正性离生。如是三结依第四静虑灭。虽唯有第四静虑及四无色地三结。或依四或依未至灭。而依总种类说。余亦无失。虽依八地边起世俗道亦分断三结。而非永断。故此不说。然此三结永断唯在道类忍时。若别说者有身见永断唯在苦类忍。故言依四依未至灭。三不善根及欲漏依未生灭者。离欲染时彼永断故。若异生若圣者若有漏道若无漏道俱依未至。离欲染故。有漏无明漏或依七或依未至灭者。七谓四静虑及下三无色即七。依定未至谓未至定及静虑中间。此二俱名未至地故。此中有漏从初静虑乃至非想非非想处可得。无明漏从欲界乃至非想非非想处可得。此二俱离非想非非想处染时方得永断。彼非想非非想处染依九地道而得永离。故言或依七或依未至灭。然无明漏欲界者唯依未至灭。有漏无明漏初静虑者依初静虑或依未至灭。第二静虑者。依二静虑或依未至灭。乃至识无边处者依四静虑下二无色或依未至灭。无所有处非想非非想者。依四静虑下三无色或依未至灭。依总种类亦得说。余或依七或依未至灭。此中但说二永断处故。唯圣者无漏道断。即是最后金刚喻定。余随所应如本论说。异生圣者世俗圣道永断差别如理应知

诸结过去。彼结已系耶。乃至广说。问何故作此论答为止他宗显正理故。谓或有说。过去未来非实有体。或复有说烦恼断已毕竟不退为遮彼说显示过去未来实有。及显烦恼断已有退。故作斯论。应知此中先名已系后名当系现名今系。又于此中有作是说。结用名系。有作是说。结得名系。然结于得有三种类。一如牛王引得前行。二如犊子随得后行。三如形质与影得俱。如牛王者先结后得。如犊子者先得后结。如形质者结与得俱。诸结过去彼结已系耶。答诸结过去彼结已系谓结在过去彼得亦过去。曾为系故说名已系。有结已系彼结非过去。谓结未来现在已系。即诸结在未来现在。彼得在过去曾为系故。此结如犊子随得后行故诸结未来彼结当系耶。答应作四句。义不定故。有结未来彼结非当系。谓结未来已断已遍知已灭已吐定不当退。此中已断者谓已得断遍知。已遍知者。谓已得智遍知。已灭者谓已得择灭。已吐者谓已断系得。已证离系得。有作是说。已断已遍知已灭已吐同显舍义。定不当退者谓不退法阿罗汉。未来三界见修所断结定不当退。退法阿罗汉未来三界见所断结定不当退。不退法不还。若已离无所有处染。未来三界见所断结及下八地修所断结定不当退。乃至若未离初静虑染。未来三界见所断结。及欲界修所断结定不当退。退法不还及预流一来。未来三界见所断结定不当退。不退法异生。若已离无所有处染如菩萨等未来下八地见修所断结定不当退。乃至若已离欲界染未离初静虑染。未来一地见修所断结定不当退是谓有结未来彼结非当系。有结当系彼结非未来谓结过去已断已遍知已灭已吐定当退。此中诸句义如前释。定当退者谓退法阿罗汉过去三界修所断结有定当退。退法不还若已离无所有处染。过去下八地修所断结有定当退。乃至若未离初静虑染。过去一地修所断结有定当退。退法异生若已离无所有染。过去下八地见修所断结有定当退。乃至若已离欲界染未离初静虑染。过去一地见修所断结有定当退。是谓有结当系彼结非未来。有结未来彼结亦当系。谓结未来已断已遍知已灭已吐定当退。此中已断等如初句释。定当退者如第二句释。然前说过去今说未来。有结非未来彼结亦非当系。谓结过去已断已遍知已灭已吐。定不当系及现在结。此中诸句如初句释。然前说未来今说过去及现在结者。谓现在结亦非未来是现在故。亦非当系是今系故。诸结现在彼结今系耶。答诸结现在彼结今系。谓现在诸结定有现在得。如形质影必俱有故。有结今系彼结非现在谓结过去未来今系即过去未来结有现在得。过去结者。如牛王引得前行。未来结者如犊子随得后行。彼得现在故名今系诸用此道断欲界结。退此道时还得彼结系不。乃至广说。问何故作此论。答为止他宗显正理故。谓或有执。定无退起诸烦恼义。如分别论者。彼引世间现喻为证。谓作是说。如瓶破已唯有余瓦不复作瓶。诸阿罗汉亦应如是。金刚喻定破烦恼已不应复起诸烦恼退。如烧木已唯有余灰不还为木。诸阿罗汉亦应如是。无漏智火烧烦恼已不应复起诸烦恼退。彼引此等世间现喻。证无退起诸烦恼义。为遮彼执显有退起诸烦恼义。若无退者便违契经。如契经说。阿罗汉有二种。一退法。二不退法。又契经说。由五因缘令时解脱阿罗汉退隐没忘失

云何为五。一多营事业。二乐诸戏论。三好和斗诤。四喜涉长途。五身恒多病。又契经说。有阿罗汉名瞿底迦。是时解脱六反退已。于第七时恐复退失以刀自害而般涅槃。故知定有起烦恼退。问若有退义分别论者所引现喻当云何通。答不必须通。所以者何。彼非素怛缆。非毗捺耶。非阿毗达磨。但是世间粗浅现喻。世间法异贤圣法异。不应引世间法难贤圣法。若必须通当说喻过喻。既有过为证不成。如瓶破已必有余瓦。得阿罗汉已有余烦恼不。若有烦恼者应非阿罗汉。若无烦恼者即义与喻别不应为证。如烧木已定有余灰。得阿罗汉已有余烦恼不。若有烦恼者应非阿罗汉。若无烦恼者即义与喻别不应为证。然世间木无被烧义。但木极微与火极微为因已灭。此火极微与灰极微为因已灭。应作是说。木是火因火是灰因。而世间想谓火烧木令木成灰。木既灭已犹有余灰。非全无物故喻与法义不相似。又阿罗汉断诸烦恼非令全无过去未来烦恼性相犹实有故。若相续中违烦恼道未现在前。尔时名为烦恼未断。若相续中违烦恼道已现在前。断诸系得证离系得。不成就烦恼名烦恼已断。应作是说。修习圣道是希有事。今阿罗汉虽断烦恼而不令无。是故尊者妙音说曰。烦恼不在自身中行说名为断非令全无。如说天授舍宅中无非谓天授余处亦无。烦恼断时应知亦尔。过去有故。若遇退缘为因引生未来烦恼故必有起烦恼退义。问分别论者云何释通应理论者所引契经。答彼说退时退道非果。以沙门果是无为故。问既许有退。退道退果有何差别。而说无退。又彼许退无学道时。为得学道为全不得。若得学道果亦应退非无学果成学道故。若全不得便有大过。退无学道不得学道。若尔应住异生位故。若非异生及学无学。应离凡圣有别有情许即便非世尊弟子故。应许有起烦恼退。分别论者又说随眠是缠种子。随眠自性心不相应。诸缠自性与心相应。缠从随眠生。缠现前故退诸阿罗汉。已断随眠缠既不生彼如何退。故说无退是应正理。彼如是说是无知果。是黑闇果。是无明果。是不勤方便果。然实有起烦恼义。为止彼宗及显退法相应正理故作斯论

问退以何法为自性耶。有作是说。若起如是烦恼诸缠现前故退。即以此法为退自性。若作是说退以不善有覆无记为其自性。有余师说。若退堕时随顺退者是退自性。若作是说以一切法为退自性。由退堕时诸法皆有随顺退义。譬喻尊者作如是言。退无自性唯假施设。所以者何。身中先有诸善功德。今遇退缘退失此法有何自性。如人有财为贼所夺。有人问曰。汝今失财以何为体。财主答曰。我本有财今为贼夺但无财物知有何体。如人有衣为他夺去露形而住。有人问曰。汝今无衣以何为体。衣主答曰。我先有衣今被夺去知有何体。如人衣破有人问曰。汝今衣破用何为性。衣破者曰。我衣先完今衣破已知有何性。如是身中先有胜德今唯退失有何自性。评曰。退自性者是不成就无覆无记。即是非得心不相应行蕴所摄。即在复有所余如是类法心不相应中摄。应知退与顺退法异。退以不成就非得为自性。无覆无记心不相应行蕴所摄。顺退法以一切不善有覆无记为其自性。如僧破与破僧罪异。僧破以不和合为自性。无覆无记心不相应行蕴所摄。破僧罪以虚诳语为自性。僧成就破破僧人成就罪。如是退与顺退法异故。退自性决定实有是不相应行蕴所摄。即是非得其理极成

说一切有部发智大毗婆沙论卷第六十阿毗达磨大毗婆沙论卷第六十一

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中一行纳息第二之六

问为烦恼现在前故退。为退已烦恼现在前。设尔何失。二俱有过。所以者何。若烦恼现在前故退者。品类足说当云何通。如说三缘故起欲贪随眠。一欲贪随眠未断未遍知。二顺欲贪缠法现在前。三于彼有非理作意。广说乃至。起疑随眠应知亦尔。契经所说复云何通。如说由五因缘令时解脱阿罗汉退。谓多营事业。乃至身恒多病。定蕴所说复云何通。如说由非学非无学心退起学法得。云何彼是阿罗汉而起烦恼现在前。又何等心无间起烦恼现在前。若退已烦恼现在前者。施设论说当云何通。如说若时心远心刚强起无色界三缠现在前。谓贪慢无明。而多起慢。彼三缠内随一现前。应说彼退无色贪尽。住色贪尽中。识身论说复云何通。如说一类补特伽罗无色染污心现在前故。舍无学善根学善根相续。退无学心住学心。品类足说复云何通如说云何顺退法。谓不善及有覆无记。住何等心后烦恼现在前。答应作是说。烦恼现在前故退。问此已善通后诸违难。前诸违难当云何通。答皆非违难。所以者何。品类足说三缘故起诸随眠者。依未断尽烦恼者说。谓起烦恼现在前者。或有已断尽自地烦恼。或有未断尽自地烦恼。彼依未断尽自地烦恼而起烦恼现在前者说。又起烦恼现在前者。或退或不退。彼依不退而起烦恼现在前者说。又起烦恼现在前者。或染污心无间。或不染污心无间。彼依染污心无间而起烦恼现在前者说。又起烦恼现在前者。有具因缘有不具因缘。彼依具因缘而起烦恼现在前者说。谓诸有情三因缘故起诸烦恼名具因缘。一由因力。二由境界力。三由加行力。欲贪随眠未断未遍知者说因力。顺欲贪缠法现在前者说境界力。于彼有非理作意者说加行力。复次为遮外道所说意趣故作是说。由三缘故起诸随眠。谓外道说专由境界起诸烦恼。若有境界烦恼便生。若境界坏烦恼不起。为遮彼意。说诸缠起亦因未断自类随眠。亦由彼有非理作意。契经中说。由五种因缘令时解脱阿罗汉退者。彼于退具说退因缘。如余经说。彼具名彼定蕴所说。由非学非无学心退起学法得者。彼说根退不说果退。复次烦恼相应心亦名非学非无学故。说果退亦不违理。云何彼是阿罗汉而起烦恼现在前者。先是阿罗汉后起烦恼现在前。若起烦恼现在前便非阿罗汉。如先异生后入圣道。入圣道已便非异生。如先学者后起无学法。起无学法已便非学者。此亦如是于理何违。何等心无间起烦恼现在前者。若毕竟离非想非非想处染。起彼地缠现在前故。退者即彼地善心无间起烦恼现在前。若未毕竟离非想非非想处染。起彼地缠现在前故。退者即彼地或善心或染污心无间起烦恼现在前。乃至初静虑应知亦尔。若毕竟离欲界染起欲界缠故。退者即欲界或善心或无覆无记心无间起烦恼现在前。若未毕竟离欲界染起欲界缠故。退者即欲界或善心或染污心或无覆无记心无间起烦恼现在前。此中若未得根本善静虑无色定现在前者。彼不能起色无色界缠现在前故退。但能起欲界缠现在前故退。若得根本善静虑现在前非无色定者。彼不能起无色界缠现在前故退。但能起欲色界缠现在前故退。若得根本善静虑无色定现在前者。彼能起三界缠现在前故退。有余师说。退已烦恼现在前。问此已善通前诸违难。后诸违难当云何通。答皆非违难。所以者何。施设识身二论所说。依觉知位不说退时。谓先虽退而未觉知。烦恼现在前乃觉知故。如有先诵四阿笈摩。余务所缠遂便忘失。乃至未诵犹不觉知。后若诵时方知忘失。彼虽先忘而今始觉。此亦如是先退后知。依知时说故不违理。品类足说。不善及有覆无记名顺退法者。依损善品转远善品故作是说。如如烦恼现在前时。如是如是损远善品故说顺退。非谓烦恼现在前时方退。善法先已退故。住何等心后烦恼现在前者。住欲界无覆无记心后烦恼现在前。谓威仪路及工巧处非异熟生性羸劣故。问岂不羸劣弥顺于退。答若于净品其性虽劣而于染品力强胜者住彼便退。退已烦恼即现在前。异熟生心于净染品性俱劣故住彼心时非进非退。有说欲界三无记心随住一种皆有退义。此心无间烦恼现前。然此欲界无覆无记心。有与三界缠相违者。住此心时必不退起三界烦恼。有与欲色界缠相违不与无色界缠相违者。住此心时虽不退起欲色界烦恼。而容退起无色界烦恼。有与欲界缠相违不与色无色界缠相违者。住此心时虽不退起欲界烦恼。而容退起色无色界烦恼。有与三界缠皆不相违者。住此心时皆容退起三界烦恼。评曰。此二说中前说为善。要起烦恼现在前时乃成退失胜功德故此说退位。若退性者不必要起烦恼现前不退无学位有退性者故。问退时为住意地为住五识身耶。答应作是说。住意地退非五识身。问若尔云何通坞陀衍那事。昔有王号坞陀衍那。将诸宫室诣水迹山除去男子纯与女人奏五妓乐。纵意嬉戏乐音清妙香气馚馥。命诸女人露形而舞。时有五百离欲仙人乘神境通经此上过。有见妙色有闻妙声有嗅妙香皆退神通。堕此山上如折翼鸟不复能飞。王见问曰汝等是谁。诸仙答曰。我是仙人。王复问言。汝得非想非非想处根本定不。仙人答言。我等未得。王乃至问汝等为得初静虑不。仙乃至答我等曾得而今已退。时王嗔忿作如是言。不离欲人如何观我宫人婇女。极非所宜。便拔利剑断截五百仙人手足。彼诸仙人有住眼识退者有住耳识退者有住鼻识退者。如何言住意地退耶。猛喜子事复云何通。昔有仙人名猛喜子。食时常受胜军王请。每至食时乘神通力如雁王飞至王宫上。王自承接抱置金床烧香散花恭敬礼拜以妙饮食而供养之。仙人食讫除器澡漱咒愿王已飞空而去。王于后时以国事故欲诣余处作是念言。我行去后谁当如我承事仙人。脱不如法仙人性躁。或咒咀我令失王位。或断我命或害国人。便问少女。我行去后汝能如我事仙人耶。女答言能。王遂殷勤约敕少女。令如常法供养仙人。然后乃行营理国事。仙人后日临至食时飞空而来至王宫所。王女承抱置金床上。仙人离染力微劣故触细软触退失神通。如常受供食讫澡漱及咒愿已欲乘空去而不能飞。入王苑中欲修旧道。闻象马等种种喧声虽极作意而不能得。时彼仙人知室罗筏城中士女恒作是念。若大仙人履地行者我等当得接足供养。彼仙尔时便起矫慧。语王女曰汝告城中。今日仙人履地而出。诸所欲作皆应作之。于是王女即便依教。诸人闻已除去城中瓦砾粪秽扫洒清净。严列幢幡烧香散花作诸音乐庄饰严丽犹如天城。是时仙人步行而出去城不远入林树间。欲修旧道闻诸鸟声其心惊乱而不能得。便舍此去诣于河边。复闻水中龙鱼腾跃。心既喧扰而不能修。遂即登山作如是念。我退善品都由有情。设我曾修戒禁苦行当感有翅猫狸之形。水陆空行无脱我者。发恶愿已毒心稍息。须臾复能离八地染后生非想非非想处。有顶寂止甘露门田。八万劫中受闲静乐。业寿尽已还生此间苦法林中。作猫狸兽身及两翅各广五十踰缮那量。以此大身害有情类空行水陆无得免者。从此命终堕无间狱。受诸剧苦难有出期。如是仙人住身识退。如何言住意地退耶。复云何通天帝释事。谓释迦佛未出世时有一仙人名为洲胤。天帝数往咨受法义。后于一时天帝乘辇欲往仙所。阿素落女设芝夫人窃作是念。今天帝释将无舍我欲往其余诸美人所。便先升辇自隐其形令天帝释不知同往。临至仙所回顾见之。因即告言汝何来。此仙人不欲见诸女人。宜速还宫不应住此。设芝推托不欲还宫。天帝既忿以华茎击夫人。遂以谄媚音谢。仙人闻之便生欲爱退胜定故螺髻便堕。此即仙人住耳识退。如何言住意地退耶。答应知此等住意地退。由眼等识引令起故作如是说于理无违。尊者僧伽筏苏说曰。住五识退于理何违。五识取境时亦生烦恼故。谓对治力极羸劣者眼见色等亦容退故。评曰应作是说。住意地退非五识身。对违顺境要有分别起烦恼故。由此故说若住意地有六胜事不共五识。一退二离染三死四生五断善根六续善根

退有三种。一已得退。二未得退。三受用退。已得退者谓先已得诸胜功德遇缘而退。未得退者如伽他说

  我观天世间　　退于圣慧眼
  由耽著名色　　不见四真谛

此颂意说。一切有情若勤方便皆应获得诸圣慧眼。但由耽著名与色故不能精勤修正方便。于四真谛未得现观。于圣慧眼有未得退。又如颂言

  愚夫众所敬　　是则为衰损
  于顶而退堕　　断灭诸善根

此颂佛依天授而说。谓彼已起暖善根不久当起顶善根。中间贪着胜名利故于顶善根有未得退。从此展转断灭善根。诸如是等名未得退。受用退者。谓于已得诸胜功德不现在前。如佛于已得诸佛功德不现在前。独觉于已得独觉功德不现在前。声闻于已得声闻功德不现在前。余亦应尔。问如是三退佛独觉声闻各有几种。答佛有一种。谓受用退已得诸功德有不现前故。无未得退。住诸有情最胜根故。无已得退诸佛皆是不退法故。独觉有二种。谓未得退及受用退。未得退者未得诸佛最胜根故。受用退者有已得功德不现在前故。无已得退独觉皆是不退法故。声闻乘中不时解脱有二种谓未得退及受用退。未得退者未得诸佛独觉根故。受用退者有已得功德不现在前故。无已得退不时解脱非退法故。时解脱具三种。已得退者。已得功德有可退故。未得退者。未得三乘不退根故。受用退者。有已得功德不现在前故。有作是说。佛全无退。无已得退者诸佛皆是不退法故。无未得退者住诸有情最胜根故。无受用退者佛于过去三无数劫。修集百千难行苦行皆为利乐一切有情。得成佛已昼夜六时观有情界无可化者而不饶益。是故诸佛无受用退。虽有功德不现在前非本所期故不名退。独觉唯有一受用退。有已得功德不现在前故。无未得退者于独觉乘根性已定更不求佛胜根性故。无已得退者独觉皆是不退法故。声闻乘中不时解脱亦唯有受用退。有已得功德不现在前故。无未得退者。于声闻乘根性已定更不求佛独觉乘故。无已得退者。不时解脱不退法故。时解脱有二种。一已得退。已得功德有可退故。二受用退有已得功德不现在前故。无未得退者于时解脱根性已定。不求三乘胜根性故。评曰。此二说中初说为善。诸佛定有受用退故。独觉声闻于胜根性有钦羡故。时解脱者有可转作不时解脱如何说彼无未得退。问云何知佛有受用退。答契经说故。如契经说。佛告阿难。如来所得四增上心现法乐住。我说于彼展转有退。如与弟子共集会时。若不动心解脱身作证具足住。我说于彼都无有退。由此知佛有受用退。问此经为说有已得退。为当说有受用退耶。设尔何失。二俱有过。所以者何。若此经说已得退者。四增上心现法乐住亦不应退。诸佛皆是不退法故。若此经说受用退者不动心解脱亦应有退。非一切时现在前故。答此中说佛有受用退。问此已善通前所设难。后所设难当云何通。谓不动心解脱亦应有退。非一切时现在前故。答不动心解脱以成就为胜。若得彼法更无所作故。虽不现前而不说为退。四增上心现法乐住以现行为胜。不现前者便说为退。有作是说。此契经中说。未至定名不动心解脱。说根本静虑名增上心现法乐住。世尊多起未至定现在前。非根本静虑。谓食前食后将说法时。及说法竟并说法已入静室时。佛虽于诸定能速疾入。而于最近者数入非余。故佛数数入未至定。如勇健者虽于诸处能速往来。而于近处数数游从非于远处。故作是说。有余师说。此契经中说利益他事名不动心解脱。说自利益事名增上心现法乐住。世尊多起利益他事现在前。非自利益事故作是说。或有说者。此契经中说慈悲名不动心解脱。说喜舍名增上心现法乐住。世尊多起慈悲现在前。少起喜舍故作是说。复有说者。此契经中说大悲名不动心解脱。说大舍名增上心现法乐住。世尊多起大悲现在前。少起大舍故作是说。尊者妙音作如是说。此契经中。说一切结永断遍知名不动心解脱。说一切种有为功德名增上心现法乐住。佛于一切无为功德恒成就故说为不退。佛于一切有为功德有不起者故说有退。有为功德以起现前为胜事故。尊者觉天作如是说。此契经中说能得得名不动心解脱。说所得得名增上心现法乐住。佛于一切所得功德有不现前故说有退。诸能得得恒现在前故说不退。问若佛亦有受用退者此受用退何者最多为佛为独觉为声闻耶。答此受用退佛最为多。非独觉声闻彼功德少故。谓佛一刹那顷功德不现在前有受用退。多于二乘尽众同分于诸功德有受用退。所以者何。如来功德无量无数微妙炽盛最胜清净。过诸世界极微尘量一一功德皆应现前。若不现前有受用退故受用退佛最为多。如转轮王统四洲渚。若一日夜舍自国土有受用退。多余小王尽众同分舍自国土有受用退。前来且说三乘无学于三种退有具不具。学位异生随其所应当准此说。如定蕴说。以何等故上三果有退非预流果耶。且彼文说见所断烦恼。于无事起故断已不退。云何说彼于无事起。谓无处转故云何无处转。谓于我转故于胜义谛我毕竟无故彼烦恼断已不退。修所断烦恼于有事起故断已有退。云何说彼于有事起。谓有处转故。云何有处转。谓于少分净相转故。云何名为少分净相。谓于发爪唇齿面目手足指等形显色中有少净相。于中亦有诸不净相观不净相由如理作意。先离烦恼观彼净相。由非理作意起烦恼退。无有少法有我我所可令观彼退无我观。如契经说。一切法无我无有情无命者无养育者无补特伽罗。于此身内空无士夫无能作者无遣作者无能受者无遣受者。纯空行聚。是故一切见所断结圣慧断已皆永不退。是故无退预流果者。复次永断三界见所断结立预流果。无退三界见所断结永断者故。复次永断非想非非想处见所断结立预流果。无退非想非非想处见所断结永断者故。问云何无退彼永断者。答以彼非想非非想处见所断结。难断难破难可越度。是故断已不可还续。复次以忍对治无事烦恼立预流果。必无退忍起无事结故彼不退。复次由见道力得预流果定无退失见道者故。问因论生论。何故定无退见道者。答以见道是极速疾道不起期心道。无容退失如是道故。复次诸瑜伽师入见道已。名堕法河堕大法流堕法彼浪堕法洄澓。尚无暇能起有漏善无覆无记心。况有能起染污心退。如人堕在山谷瀑流随浪漂溺。尚不能据此彼两岸何况能出。复次见道能治三界所有见所断结。无退三界见所断结对治道故。复次见道能治所有非想非非想处见所断结。无退非想非非想处见所断结对治道故。复次见道能治忍所对治无事烦恼。无有退彼对治道故。复次见道创见四圣谛理决了明白。无于此理重迷谬者故必不退。问如至无学位有退住修道。宁无至修位退住见道者。答修道位中有起烦恼现在前义见。道位中无起烦恼现在前义。是故彼此不可为例。复次修道位中容有退者故至无学位有退住修道。见道位中无有退者故至修道位无退住见道。问退阿罗汉果住预流果时。名退不还一来果不。答亦名退彼。所以者何。住彼下故如人从彼第三层舍堕至于地。彼人亦说堕初二层此亦如是。问本不成就中间二果今何言退。答已不成就复不成就故亦名退。问如何说彼已不成就复不成就答彼先已远今更远故。复次先断尔所烦恼尽故建立二果。今还退起尔所烦恼故说彼退。复次先断二果所对治得今还退起故说彼退。复次先用如是无间解脱。断诸烦恼得二果者。今还退起所断烦恼令彼二道远而更远故说彼退。复次不还一来果是阿罗汉因故退果时因亦名退。问预流果亦是阿罗汉因。退阿罗汉时预流应退。答此预流果是下圣位。退上果时极住此果。若复退失预流果者。应本得果今还不得。见道位中无住义故。应本见谛今还不见。应本现观今非现观。应本圣者今成异生。欲令无有如是等过故无退失预流果义。复次以预流果是见道证先说见道必无退义。是故无退预流果者。此说位退不说根性。预流果转根亦有退者故退根本沙门果。若未还得无命终义。若退彼向虽未还得容可命终。所以者何。根本果位易见易施设。谓此是预流果乃至此是阿罗汉果。是故退已若未还得必不命终。向位难见难施设。故从彼退已虽未还得有命终义。复次根本果位诸瑜伽师于果发起增上庆悦。如务农者于六月中修治稼穑后收子实积置场中生大庆悦。此亦如是。故退果时生大忧恼。若未还得终不舍命。向中不尔故退彼时虽未还得有命终义。复次根本果位具三因缘。一舍曾得道。二得未曾得道。三证结断一味得。故退果时若未还得必不命终。向即不尔故退彼位虽未还得容可命终。复次根本果位具五因缘。一舍曾得道。二得未曾得道。三证结断一味得。四顿得八智。五一时修十六行相。故退果时若未还得无命终理。向中不尔故退彼时虽未还得有命终义。复次根本果位是瑜伽师最胜安隐稣息之处。故退果时若未还得无命终义。向即不尔故退彼时虽未还得有命终理。复次根本果位所有结断是所作及所作究竟。所有圣道是功用及功用究竟。故退果时若未还得无命终理。向中结断是所作非所作究竟。所有圣道是功用非功用究竟。故退向时虽未还得有命终义。复次根本果位容诸行者广修圣道故退果时若未还得无命终理。向中不容广修圣道故退向已虽未还得有命终义。复次根本果位诸瑜伽师能善了知功德过失。功德者谓道及道果。过失者谓生死因果。故退果时若未还得无命终理。向中不尔故退彼时虽未还得有命终义。复次根本果位诸瑜伽师方能善取四圣谛相。向中不尔事未成故。如人道行于四方相未能善取若坐一处方能善取。果向亦然故退果时若未还得无命终理。若退向时虽未还得有命终义。复次根本果位若退失时有证知者故未还得必不命终。退失向时无证知者故未还得有命终义。如村邑中若被劫夺有证知者速可还得。两村邑间若被劫夺无证知者难可还得。复次根本果位诸瑜伽师先广加行安足坚固。由此退时若未还得终不舍命。向中不尔故退彼时若未还得有命终理。预流果先广加行者。谓彼先求解脱果故。精勤修习惠施净戒。不净观持息念念住。闻所成慧。思所成慧。修所成慧。及暖顶忍世第一法。并见道中十五心顷。即此总名安足坚固。有作是说。从初乃至世第一法名广加行。见道十五心名安足坚固。一来果先广加行者。谓即前说及离欲染诸加行道六无间道五解脱道即此名为安足坚固。有作是说。预流果名安足坚固。不还果先广加行者。谓即前说及离欲染诸加行道三无间道二解脱道。即此名为安足坚固。有作是说。一来果名安足坚固。阿罗汉果先广加行者。谓即前说及离初静虑乃至无所有处染。一一地各有诸加行道九无间道九解脱道。并离非想非非想处染诸加行道九无间道八解脱道。即此总名安足坚固。有作是说。不还果名安足坚固。复次根本果位诸瑜伽师。断绝止息一切生分故。退果时若未还得无命终义。向中不尔故退彼时虽未还得有命终理。谓预流果除欲界七生。及色无色界一一处一生。余一切生得非择灭。一来果除欲界二生。及色无色界一一处一生。余一切生得非择灭。不还果除色无色界一一处一生。余一切生得非择灭。阿罗汉果于一切生得非择灭不复生故。复次根本果位诸瑜伽师总集三界见修所断烦恼断得。故退果时若未还得终不舍命。向中不尔故退彼时虽未还得有命终义。谓预流果位总集三界见所断烦恼断得。一来果位总集三界见所断。及欲界修断六品烦恼断得不还果位总集三界见所断。及欲界修所断九品烦恼断得。阿罗汉果位总集三界见修所断一切烦恼断得。复次根本果位是瑜伽师本所求处。故退果已若未还得必不命终。向位不尔故退彼时若未还得有命终义

若离欲界染或离初静虑染。或复乃至离无所有处染。此后得入正性离生。后若退者决定不起下地缠退但容得起上地缠退所以者何。下地烦恼有漏无漏二对治道所残害故无有势力起彼而退。复次断彼缠后有见道生镇压其上故不能起下地缠退。譬如有人从山堕落堕后复有颓山压上。尚不能动况能起行。复次断彼缠后有忍智生无有退忍智者故。不能起下地缠退。复次断彼缠后起法类智无有全退法类智者。故不能起下地缠退。复次断彼缠后起增上忍世第一法无退增上忍世第一法者。故不能起下地缠退。复次异生离欲界染乃至离无所有处染时。地地见修所断烦恼总为一束作九品断。后入见道得圣果已。设起下地烦恼退者。为但得彼修所断结。为亦得彼见所断结。若但得彼修所断结。如何二结同一道断。退彼道时但唯得一。若亦得彼见所断结。如何得圣果成见所断结。是故异生随离何地何品染已后。若得入正性离生得圣果已。必无还起先时所断烦恼退义

问如当得阿罗汉果住金刚喻定时。犹成就非想非非想处下下品结。若退阿罗汉果还起非想非非想处下下品结时。为亦得成就金刚喻定不。答不得成就金刚喻定。所以者何。金刚喻定用大功力加行作意修习而得。彼下下品结不由功力加行作意修习而得。是故退时但得彼结不得此定。复次金刚喻定胜进时得。彼下下品结退堕时得。是故退时但得彼结不得此定。复次金刚喻定现在前时。违彼结现行不违彼成就。是故金刚喻定现在前时。犹成就彼结。非想非非想处下下品结现在前时。违金刚喻定现行亦违成就。是故退起彼品结时必不成就金刚喻定。复次金刚喻定是无间道。无住无间道而退者。亦有无退已住无间道者。有住解脱道而退者。亦有退已住解脱道者。有作是说。亦有住胜进道而退者。及有退已住胜进道者。是故住金刚喻定时成就有顶下下品结。退起有顶下下品结时。必不还得金刚喻定

说一切有部发智大毗婆沙论卷第六十一阿毗达磨大毗婆沙论卷第六十二

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中一行纳息第二之七

问何处有退。答欲界有退非余界。人趣有退非余趣。问欲界天中何故无退。答无退具故。问岂不彼天有五妙欲胜于人趣宁说为无。答诸契经中说五退具天中非有故说为无。复次六欲天中初入圣道得圣果者皆是利根诸利根者皆不退故。问钝根人中入圣道已后生天上为有退不。答彼亦不退。所以者何。经生圣者决定不退。亦不转根。亦不得生色无色界。圣道于彼相续中住既经多时极坚牢故。问三恶趣中何故不退。答彼无离染入圣道义。既无胜德。于何说退。问色无色界既有胜德何故无退。答彼无退具功德坚牢。是故不退问何等人可退。何等人不可退耶。答有人信他随他意欲而入圣道。有人自信随自意欲而入圣道。初人可退。后人不可退。复次有不思量观察得失而入圣道。有极思量观察得失而入圣道。初人可退。后人不可退。复次有人因力加行力不放逸力皆不广大。有人三力悉皆广大。初人可退后人不可退。复次有信为先而入圣道。有慧为先而入圣道。初人可退。后人不可退。复次有奢摩他为先而入圣道。有毗钵舍那为先而入圣道。初人可退。后人不可退。复次有行止行。有行观行。初人可退。后人不可退。复次有多爱乐希求于止。有多爱乐希求于观。初人可退。后人不可退。复次有止增上。有观增上。初人可退。后人不可退。复次有止熏心依观得解脱。有观熏心依止得解脱。初人可退后人不可退。复次有得内心止不得增上慧法观有得增上慧法观不得内心止。初人可退。后人不可退。复次有乐习定不乐多闻。有乐多闻不乐习定。初人可退。后人不可退。复次有乐自利不乐利他。有乐利他不乐自利。初人可退。后人不可退。复次有随信行种性。有随法行种性。初人可退。后人不可退。复次有钝根者。有利根者。初人可退。后人不可退。复次有缘力入道。有因力入道。初人可退。后人不可退。复次有外友力入道。有内友力入道。初人可退。后人不可退。复次有从他闻法力入道。有内正思惟力入道。初人可退后人不可退。复次有无贪增上。有无痴增上。初人可退。后人不可退。复次契经中说。人有四法能多所作。一亲近善士。二听闻正法。三如理作意。四法随法行。初二法增上者可退。后二法增上者不可退。复次有心善解脱慧不善解脱。有慧善解脱心不善解脱。初人可退。后人不可退。有作是说。有心善解脱慧不善解脱。有慧善解脱心不善解脱。此二人可退。有心善解脱慧善解脱。此人不可退。问诸已退者住经几时。答住经少时。乃至未觉彼寻觉已速修胜进复次彼起烦恼现前退时深生惭愧速即令断。如明眼人昼日平地忽自颠蹶。速起四顾勿有他人见我者不。如是行者起烦恼时深生惭愧。勿有诸佛或佛弟子或余善人知我者不。故速令断还复本位。复次彼起烦恼现前退时烧身心故速令还灭。如软体者迸火触身不能堪耐速即除灭。复次彼起烦恼现前退时嫌臭秽故速便除断。如乐净人有少粪秽堕彼身上速即除洗。复次彼起烦恼现前退时身心重故速便弃舍。如羸弱者忽得重担力所不逮速即弃之。有作是说。退者不定。不自在故起诸烦恼或速能断还复本位。或经久时方得本果。谓以欲界闻思慧力引起修慧圣道现前。转信胜解成见至根。然后复趣阿罗汉果。故彼退已迟速不定。问若退不还阿罗汉果。已为复作彼不应作事耶。答不复能作。所以者何。退上果者所作事业与先未得上果圣人事业异故

阿罗汉有六种。一退法。二思法。三护法。四安住法。五堪达法。六不动法。此中退法者谓彼应退思法者谓彼思已持刀自害。护法者谓彼殷重守护解脱。安住法者谓彼不退亦不升进。堪达法者谓彼堪能达至不动。不动法者谓彼本得不动种性。或由练根而得不动。问退法阿罗汉必退耶。乃至堪达法阿罗汉必练根至不动耶。有作是说。阿罗汉中退法必退。思法必思持刀自害。护法必能守护解脱。安住法必能不退亦不升进。堪达法必能练根至不动。以是事故。彼名退法。乃至名堪达法。若作是说。依六作用建立六种阿罗汉名。彼说欲界具有六种。色无色界唯有二种。谓安住及不动法。如是说者。退法阿罗汉不必退。乃至堪达法阿罗汉不必练根至不动法。问若尔何故彼名退法。乃至彼名堪达法耶。答阿罗汉中退法者不必退若退从此种性非余乃至堪达法者不必练根至不动法。若能练根至不动者。决定从此种性非余。若作是说。依六种性建立六种阿罗汉名。此说三界皆具六种。六种种性遍三界故。问云何建立如是六种阿罗汉耶。答依根建立。问根有九品。谓下下下中下上。中下中中中上。上下上中上上。云何依根建立六种不立九耶。有作是说。此六种中退法成就二品根。谓下下下中。思法成就一种根。谓下上。护法成就一种根。谓中下。安住法成就一种根。谓中中。堪达法成就一种根。谓中上。不动法阿罗汉成就一种根。谓上下。独觉成就一种根。谓上中。佛成就一种根。谓上上。评曰。彼不应作是说。无一成就二品根故。利根尚无具二品根者。况钝根者有具二品根。应作是说。阿罗汉中退法成就下下品根。思法成就下中品根。护法成就下上品根。安住法成就中下品根。堪达法成就中中品根。从时解脱练根至不动法。成就中上品根本种性。不动法成就上下品根。独觉成就上中品根。如来成就上上品根

有说。六种阿罗汉中。退法作一事。谓退。思法作二事。谓退及思。护法作三事。谓退思护。安住法作四事。谓退思护及安住。堪达法作五事。谓退思护安住及练根至不动。如是说者。退法作三事。一退住学根。二练根至思。三即住彼般涅槃。思法作四事。一退住学根。二退住退法根。三练根至护。四即住彼般涅槃。护法作五事。一退住学根。二退住退法根。三退住思法根。四练根至安住。五即住彼般涅槃。安住法作六事。一退住学根。二退住退法根。三退住思法根。四退住护法根。五练根至堪达。六即住彼般涅槃。堪达法作七事。一退住学根。二退住退法根。三退住思法根。四退住护法根。五退住安住法根。六练根至不动法。七即住彼般涅槃。问思法阿罗汉退住学根时得何学根。为得退法种性学根。为得思法种性学根。答彼得退法种性学根。非思法种性学根。所以者何。彼先于学位未得思法学根故。今若退得思法学根。是进非退不应正理。契经中说。有阿罗汉名乔底迦。是时爱心解脱彼六反退失阿罗汉果已。第七反还得阿罗汉果时。恐复退失以刀自害。问彼为是退法为是思法耶。设尔何失。二俱有过。所以者何。若是退法何缘自害。若是思法何故退耶。答应作是说。彼是退法。问若尔何故以刀自害。答彼厌退故以刀自害。若先不退而自害者乃是思法。有作是说。彼从退法练根至思。仍恐退故以刀自害。故不违理。若本性思至无学位决定无有退住学义

诸用此道断欲界结。退此道时还得彼结系不。答还得彼结系。诸用此道断色无色界结。退此道时还得彼结系不。答还得彼结系。此中有说。结用名系。谓先离染时断诸结系用。退时还得彼结系用。有作是说。结得名系。谓离染时断诸结得。今退道时还得结得。结用结得互相资助。但有一时。必有第二。为缚不舍名为结用不必现在。得结属已是结得用。此唯现在过去未来无得用故。问若道能断结住此道不退。若住此道退此道不断结。谓无间道能断诸结。无住此道而有退者。住解脱道容有退者。无用此道断诸结义。今何故说诸用此道断三界诸结。退此道时还得彼结系。答此不违理。所以者何。无间道是解脱道因。解脱道是无间道果。退此果时亦说因退。复次诸无间道是烦恼得对治。退起烦恼得时亦说退彼。复次为断烦恼故立无间道。退起烦恼时亦说退彼。复次断名有二。一通二别。别唯无间道。通通解脱道。今依通义故不相违。尊者僧伽筏苏说曰。住无间道及解脱道俱有退义。如预流者已断前五品烦恼起上上品缠。退时名退前五品无间解脱道。评曰。彼不应作是说。所以者何。必无有住无间道退。亦无退已住无间道。是故前说于理为善。谓退果时名退。因等

有九遍知。谓欲界见苦集所断结尽第一遍知。色无色界见苦集所断结尽第二遍知。欲界见灭所断结尽第三遍知。色无色界见灭所断结尽第四遍知。欲界见道所断结尽第五遍知。色无色界见道所断结尽第六遍知。五顺下分结尽第七遍知。色爱结尽第八遍知。一切结尽第九遍知。问何故作此论。答为止他宗显正理故。谓或有说。无断遍知诸无为法无自性故。为止彼宗显无为法实有自性故。断遍知决定实有。或复有说。此断遍知非唯有九。一切择灭皆得名为断遍知故。为遮彼说显断遍知唯有九种。后当显说立九因缘。有说。断遍知唯有一种。以一切择灭体唯一故。为遮彼意显断遍知体非唯一故作斯论

问断是无为不能缘虑。无决了用。何名遍知。答此虽不能缘虑决了。而是智果故名遍知。如阿罗汉是解果故亦名为解。如六触处是业果故亦名旧业。如天眼耳是通果故亦名为通。此断亦尔。是智果故亦名遍知问修所断断是智果故可名遍知。见所断断乃是忍果何名遍知。答彼断亦是世俗智果。谓世俗道离欲界乃至无所有处染。彼八地中见所断断是世俗智果故亦名遍知。问若世俗道有作用处。见所断断是智果故可名遍知。此于非想非非想处无断作用。彼见所断断云何名遍知。尊者僧伽筏苏说曰。彼是慧果故名遍知。断有二种。一是智果。二是慧果。此中慧果说名遍知。评曰。彼不应作是说。所以者何。契经但说有二遍知。一智遍知。二断遍知。佛曾不说有慧遍知。又慧非智应名遍慧。何名遍知知。是智故应作是说。忍所得断金刚喻定现在前时。复能证故亦名智果。谓金刚喻定是胜义。沙门彼所证灭名沙门果。由此定证得阿罗汉果时总证得三界见修所断断。是故此断亦名遍知。复次忍是智眷属故亦名智。此忍所得灭亦名遍知。复次此断既由智种族得故名遍知。如瞿答摩种族所出名乔答摩。复次此断既有遍知相故亦名遍知。由此亦为智所证故。如过去未来眼虽不见色而不舍眼相故亦名为眼。尊者妙音作如是说。此断应立理遍知名。谓遍了知胜义谛理究竟谛理而证得故。胁尊者言。此断应立舍遍知名。谓遍了知生死过失。永舍生死而证得故。如是二说虽不违理而经但说断遍知名。故三说中初说为善

然断自性亦名为断。亦名为离。亦名为灭。亦名为谛。亦名遍知。亦名沙门果。亦名有余依涅槃界。亦名无余依涅槃界。如是八种于诸位中有具不具。谓苦法智忍灭苦法智生时。彼所得断。名断名离名灭名谛。未名遍知。未名沙门果。未名有余依涅槃界。未名无余依涅槃界。苦类智忍灭苦类智生时。彼所得断。名断名离名灭名谛。未名遍知。未名沙门果。未名有余依涅槃界。未名无余依涅槃界。集法智忍灭集法智生时。彼所得断。名断名离名灭名谛名遍知。谓欲界见苦集所断结尽遍知。未名沙门果。未名有余依涅槃界。未名无余依涅槃界。集类智忍灭集类智生时。彼所得断。名断名离名灭名谛名遍知。谓色无色见苦集所断结尽遍知。未名沙门果。未名有余依涅槃界。未名无余依涅槃界。灭法智忍灭灭法智生时。彼所得断。名断名离名灭名谛名遍知。谓欲界见灭所断结尽遍知。未名沙门果。未名有余依涅槃界。未名无余依涅槃界。灭类智忍灭灭类智生时。彼所得断。名断名离名灭名谛名遍知。谓色无色界见灭所断结尽遍知。未名沙门果。未名有余依涅槃界。未名无余依涅槃界。道法智忍灭道法智生时。彼所得断。名断名离名灭名谛名遍知。谓欲界见道所断结尽遍知。未名沙门果。未名有余依涅槃界。未名无余依涅槃界。道类智忍灭道类智生时。彼所得断。名断名离名灭名谛名遍知。谓色无色界见道所断结尽遍知。名沙门果。谓预流果。未名有余依涅槃界。未名无余依涅槃界。尔时此断及三界见苦集灭所断结断。并欲界见道所断结断。总证一味离系得。彼断尔时名断名离名灭名谛名遍知。即前所得名沙门果。谓预流果。未名有余依涅槃界。未名无余依涅槃界。预流求证一来果。断欲界一品乃至五品结时。彼所得断名断名离名灭名谛。未名遍知。未名沙门果。未名有余依涅槃界。未名无余依涅槃界。断第六品结无间道灭。解脱道生时。彼所得断。名断名离名灭名谛。未名遍知。名沙门果。谓一来果。未名有余依涅槃界。未名无余依涅槃界。尔时此断及三界见所断结断。并欲界修所断前五品结断。总证一味离系得。彼断尔时名断名离名灭名谛。未名遍知。即前所得名沙门果。谓一来果。未名有余依涅槃界。未名无余依涅槃界。一来求证不还果。断第七第八品结时。彼所得断名断名离名灭名谛。未名遍知。未名沙门果。未名有余依涅槃界。未名无余依涅槃界。断第九品结无间道灭。解脱道生时。彼所得断。名断名离名灭名谛名遍知。谓五顺下分结尽遍知。名沙门果。谓不还果。未名有余依涅槃界。未名无余依涅槃界。尔时此断及三界见所断结断。并欲界修所断前八品结断。总证一味离系得。彼断尔时名断名离名灭名谛名遍知。谓五顺下分结尽遍知名沙门果。谓不还果。未名有余依涅槃界。未名无余依涅槃界。离初静虑乃至第三静虑各九品结。及离第四静虑前八品结时。彼所得断。名断名离名灭名谛。未名遍知。未名沙门果。未名有余依涅槃界。未名无余依涅槃界。离第四静虑第九品结无间道灭。解脱道生时。彼所断名断名离名灭名谛名遍知。谓色爱尽遍知。未名沙门果。未名有余依涅槃界。未名无余依涅槃界

问此色爱尽遍知云何建立。为色界一切修所断结尽。为第四静虑一切修所断结尽。为第四静虑修所断下下品结尽耶。有作是说。唯第四静虑修所断下下品结尽。有余师说。唯第四静虑一切修所断结尽。评曰。应作是说。色界一切修所断结尽。皆是色爱尽遍知。然断下下品结时得遍知名离空无边处。乃至无所有处各九品结。及离非想非非相处前八品结时。彼所得断。名断名离名灭名谛。未名遍知。未名沙门果。未名有余依涅槃界。未名无余依涅槃界。离彼第九品结金刚喻定灭。初尽智生时。彼所得断。名断名离名灭名谛名遍知。谓一切结尽遍知名沙门果。谓阿罗汉果。名有余依涅槃界。未名无余依涅槃界。尔时此断及三界见所断结断。及下八地修所断结断。并非想非非想处前八品修所断结断。总证一味离系得。彼断尔时名断名离名灭名谛名遍知。谓一切结尽遍知名沙门果。谓阿罗汉果。名有余依涅槃界。未名无余依涅槃界。若阿罗汉蕴界处灭。后更不续。入无余依涅槃界已。尔时彼断名断名离名灭名谛名遍知。即前所得名沙门果。谓阿罗汉果。不名有余依涅槃界。而名无余依涅槃界。问一切择灭皆名为断。断是智果故皆应名遍知。何故此名唯在九位。余位不得遍知名耶。答唯九位中。或四缘具或五缘具得遍知名。余位不然故唯立九。谓前六位唯见道果。具四缘故得遍知名。一灭双因。二离俱系。三得无漏离系得。四缺有顶诸遍行。后之三位是修道果。具五缘故得遍知名。即前四缘及永度界。谓苦法智忍灭苦法智生时。未灭双因。虽灭见苦所断因。未灭见集所断因故。未离俱系。虽离见苦所断系。未离见集所断系故。唯得无漏离系得未缺有顶诸遍行。虽有一缘阙三缘故。彼所得断未名遍知。苦类智忍灭苦类智生时。未灭双因。虽灭见苦所断因。未灭见集所断因故。未离俱系。虽离见苦所断系。未离见集所断系故。然得无漏离系得。及缺有顶诸遍行。虽有二缘阙二缘故。彼所得断未名遍知。集法智忍灭集法智生时名灭双因。先灭见苦所断因。今灭见集所断因故。亦离俱系。先离见苦所断系。今离见集所断系故。既得无漏离系得。及缺有顶诸遍行。具四缘故。彼所得及前断名第一遍知。集类智忍灭集类智生时名灭双因。先灭见苦所断因。今灭见集所断因故亦离俱系。先离见苦所断系。今离见集所断系故。既得无漏离系得。及缺有顶诸遍行。具四缘故。彼所得及前断名第二遍知。灭法智忍灭灭法智生时名灭双因。先灭见苦集所断因。今灭见灭所断因故。亦离俱系。先离见苦集所断系。今离见灭所断系故。既得无漏离系得。及缺有顶诸遍行。具四缘故。彼所得断名第三遍知。灭类智忍灭灭类智生时名灭双因。先灭见苦集所断因。今灭见灭所断因故。亦离俱系。先离见苦集所断系。今离见灭所断系故。既得无漏离系得。及缺有顶诸遍行具四缘故。彼所得断名第四遍知。道法智忍灭道法智生时名灭双因。先灭见苦集所断因。今灭见道所断因故。亦离俱系。先离见苦集所断系。今离见道所断系故。既得无漏离系得。及缺有顶诸遍行。具四缘故。彼所得断名第五遍知。道类智忍灭道类智生时名灭双因。先灭见苦集所断因。今灭见道所断因故。亦离俱系。先离见苦集所断系。今离见道所断系故。既得无漏离系得。及缺有顶诸遍行。具四缘故。彼所得断名第六遍知。如是六种唯见道果。具四缘立离欲界修所断一品乃至八品染时未灭双因。虽灭一品乃至八品因。未灭八品乃至一品因故。亦未离俱系。虽离一品乃至八品系。未离八品乃至一品系故。虽得无漏离系得及缺有顶诸遍行。而未永度界。虽有二缘阙三缘故。彼所得断未名遍知。离彼第九品染无间道灭解脱道生时名灭双因。先灭八品因今灭第九品因故。亦离俱系。先离八品系。今离第九品系故。既得无漏离系得及缺有顶诸遍行。并永度欲界具五缘故。彼所得及前断名第七遍知。谓五顺下分结为尽遍知。离四静虑修所断各一品乃至八品染时未灭双因虽灭一品乃至八品因。未灭八品乃至一品因故。未离俱系。虽离一品乃至八品系未离八品乃至一品系故。虽得无漏离系得及缺有顶诸遍行。而未永度界。虽有二缘阙三缘故。彼所得断未名遍知。离前三静虑修所断各第九品染。无间道灭解脱道生时名灭双因。先灭八品因。今灭第九品因故。亦离俱系。先离八品系。今离第九品系故。虽得无漏离系得。及缺有顶诸遍行而未永度界。虽有四缘阙一缘故。彼所得断未名遍知离第四静虑修所断第九品染。无间道灭解脱道生时名灭双因。先灭八品因。今灭第九品因故。亦离俱系。先离八品系。今离第九品系故。既得无漏离系得。及缺有顶诸遍行并永度色界。具五缘故。彼所得及前断名第八遍知。谓色爱尽遍知。离四无色修所断各一品乃至八品染时未灭双因。虽灭一品乃至八品因。未灭八品乃至一品因故。亦未离俱系。虽离一品乃至八品系。未离八品乃至一品系故。虽得无漏离系得。及缺有顶诸遍行而未永度界。虽有二缘阙三缘故。彼所得断未名遍知。离前三无色修所断各第九品染。无间道灭解脱道生时名灭双因。先灭八品因。今灭第九品因故。亦离俱系。先离八品系。今离第九品系故。虽得无漏离系得。及缺有顶诸遍行。而未永度界。虽有四缘阙一缘故。彼所得断未名遍知。离非想非非想处修所断第九品染。金刚喻定灭初尽智生时名灭双因。先灭八品因。今灭第九品因故。亦离俱系。先离八品系今离第九品系故。既得无漏离系得。及缺有顶诸遍行并永度无色界。具五缘故。彼所得及前断名第九遍知。谓一切结尽遍知。此后三种是修道果具五缘立。问四沙门果是稣息处。于诸断皆证一味离系得。何故不还阿罗汉果总集诸断立一遍知。预流一来不说总集诸断立一遍知。答虽得四果位皆总集断。而后二果时具二义故。总集诸断立一遍知。二义者何。一者得果二者越界。得预流果一来果时虽是得果而非越界。离第四静虑第九品染时。虽是越界而非得果。得不还果时二义无阙。一者得果。谓得不还果。二者越界。谓越欲界。得阿罗汉果时亦具二义。一者得果。谓得阿罗汉果。二者越界。谓越无色界。言总集者是合一义。于无色界分离染故得预流果。全离染故得阿罗汉果。于欲界分离染故得一来果。全离染故得不还果。于色界分离全离染俱不得果。唯于二处二义无阙。谓得果时亦即越界故。阿罗汉及不还果总集诸断立一遍知。复次要具二义处方总集遍知。一者于三界中随越一界。二者于顺下顺上分结中随尽一种。得预流果一来果时二义皆阙。离第四静虑第九品染时。虽越色界而阙一义。得不还果时二义无阙。一越欲界。二顺下分结尽。得阿罗汉果时亦具二义。一越无色界。二顺上分结尽故。后二果位方总集遍知。复次要具二义处方总集遍知。一者于三界中随越一界。二者于不善无记烦恼中随尽一种。得预流果一来果时二义皆阙。离第四静虑第九品染时。虽越色界而阙一义。得不还果时二义无阙。一越欲界。二不善烦恼尽。得阿罗汉果时亦具二义。一越无色界。二无记烦恼尽故。后二果位方总集遍知。复次要具二义处方总集遍知。一者于三界中随越一界。二者于有异熟无异熟烦恼中随尽一种。得预流果一来果时二义皆阙。离第四静虑第九品染时。虽越色界而阙一义。得不还果时二义无阙。一越欲界。二有异熟烦恼尽。得阿罗汉果时亦具二义。一越无色界。二无异熟烦恼尽故。后二果位方总集遍知。复次要具二义处方总集遍知。一者于三界中随越一界。二者于感二果一果烦恼中随尽一种。得预流果一来果时二义皆阙。离第四静虑第九品染时。虽越色界而阙一义。得不还果时二义无阙。一越欲界。二感等流异熟二果烦恼尽。得阿罗汉果时亦具二义。一越无色界二唯感等流一果烦恼尽故。后二果位方总集遍知。复次要具二义处方总集遍知。一者于三界中随越一界。二者于无惭无愧相应不相应烦恼中随尽一种。得预流果一来果时二义皆阙。离第四静虑第九品染时。虽越色界而阙一义。得不还果时二义无阙。一越欲界。二无惭无愧相应烦恼尽。得阿罗汉果时亦具二义。一越无色界。二无惭无愧不相应烦恼尽故。后二果位方总集遍知。复次要具二义处方总集遍知。一者于三界中随越一界。二者于五趣四生中随尽一种。得预流果一来果时二义皆阙。离第四静虑第九品染时。虽越色界而阙一义。得不还果时二义无阙。一越欲界。二尽人趣胎生。得阿罗汉果时亦具二义。一越无色界。二尽天趣化生故。后二果位方总集遍知

说一切有部发智大毗婆沙论卷第六十二阿毗达磨大毗婆沙论卷第六十三

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中一行纳息第二之八

如是九遍知谁舍几谁得几。答有诸有情无舍无得。谓诸异生。问此中问答不依异生。但依圣者为有。圣者于九遍知无舍得不。答有。谓住本性有胜进时亦无舍得。谓苦法智忍灭苦法智生时。及苦类智忍灭苦类智生时。皆于九遍知无舍无得。集法智忍灭集法智生时无舍得一。集类智忍灭集类智生时无舍得一。灭法智忍灭灭法智生时无舍得一。灭类智忍灭灭类智生时无舍得一。道法智忍灭道法智生时无舍得一。道类智忍灭道类智生时。若未离欲染入正性离生者亦无舍得一。若已离欲染入正性离生者舍五得一。谓舍前五。得五顺下分结尽遍知。此中有说。六地见道舍得皆尔。有说。后五三法智位不得遍知。圣者离欲界一品乃至八品染时。无舍无得。离第九品染无间道灭解脱道生时舍六得一。谓舍前六得五顺下分结尽遍知。离初静虑一品染。乃至离第四静虑八品染时。无舍无得。离第四静虑第九品染。无间道灭解脱道生时无舍得一谓色爱尽遍知。离空无边处一品染。乃至离非想非非想处八品染时。无舍无得。离非想非非想处第九品染。金刚喻定灭初尽智生时舍二得一。谓舍五顺下分结尽及色爱尽遍知。得一切结尽遍知。此说胜进时遍知舍得。退时亦有舍得此义。谓阿罗汉起无色界缠退时。舍一得二。谓舍第九得第八第七。即彼起色界缠退时舍一得一。谓舍第九得第七。即彼起欲界缠退时。舍一得六。谓舍第九得前六。已离色界染不还者。起色界缠退时。舍一无得。谓舍色爱尽遍知。即彼起欲界缠退时。舍二得六。谓舍第八第七。得前六。未离色界染不还者。起欲界缠退时。舍一得六。谓舍五顺下分结尽。得前六。未离欲界染圣者。起欲界缠退时。于九遍知无舍无得

如是九遍知问几是静虑果。答九是静虑及眷属果。问几是无色果。答二是无色及眷属果。谓色爱尽及一切结尽。问几是根本静虑果。答五。谓第二第四第六及后二。有说。第二第四及后三为五。尊者妙音说。此有八。谓除第七。问几是静虑眷属果。答九。谓未至定非余。静虑中间如根本静虑说。问几是根本无色果。答一。谓第九。问几是无色眷属果。答一。谓第八是空无边处近分非余。问几是见道果。答六。谓前六。有说七。谓前七。问几是修道果。答三。谓后三。问几是忍果。答应说如见道果。问几是智果。答应说如修道果。问几是法智果。答三。谓后三。问几是类智果。答二。谓后二。问几是法智品果。答六谓第一第三第五及后三。问几是类智品果。答五。谓第二第四第六及后二。有说六。谓第二第四第六及后三。问几是世俗道果。答二。谓第七第八。问几是无漏道果。答九。无漏道力得一切故

问若已离色染入正性离生者。彼何时得色爱尽遍知。尊者僧伽筏苏说曰。道类智时得。由彼尔时名为住果亦住向故。评曰。彼不应作是说。非住果时名住向故。谓得果时未起一念向道现前。如何名向。有余师说。彼后若离空无边处染。尔时乃得色爱尽遍知。谓彼尔时修未来无漏诸静虑地彼断对治故。彼亦不应作如是说。尔时但修未来无漏诸静虑地无色对治非色对治故。复有说者。彼后当得阿罗汉果。金刚喻定现在前时。乃得此色爱尽遍知。谓彼尔时总于三界见修所断烦恼等断。同证一味离系得故。彼亦不应作如是说。尔时诸断总集为一。名一切结尽遍知。如何说得色爱尽遍知。应作是说。彼定从果起胜进道现在前时。方乃得此色爱尽遍知。若不许彼决定从果起胜果道现在前者。诸已离第三静虑染。依下地入正性离生道类智时。得第三果。既不起胜果道现在前。彼若命终生第四静虑或无色界。应不成就无漏乐根。若尔便违十门纳息。如说。谁成就乐根。答若生遍净。若生遍净下。若圣者生遍净上。勿有此失故。必应许诸得果已彼定从果起胜果道。尔时方名得色爱尽遍知。由此理趣若先已离欲界三四品染。入正性离生道类智时得预流果。若经生者定是家家。若先已离欲界七八品染。入正性离生道类智时得一来果。若经生者定是一间。若不许彼得圣果已决定从果起胜果道。彼若经生云何成就三四七八品无漏对治根

为九遍知摄一切遍知。为一切遍知摄九遍知。答一切摄九。非九摄一切。此中九者如前说。一切者此及余断。一切体宽故能摄九。此九体狭故不能摄一切。如大器能覆小器。非小器能覆大器。不摄何等。谓苦智已生集智未生。三界见苦所断结尽非九所摄。即苦法智忍灭苦法智生时。所得欲界见苦所断一切法断。及苦类智忍灭苦类智生时。所得色无色界见苦所断一切法断。如是诸断非九所摄。立见道果初二遍知。缘未具故。具见世尊弟子未离欲染。欲界修所断结尽非九所摄。谓诸圣者离欲界一品乃至八品修所断染。所得诸断非九所摄。立修道果第一遍知。缘未具故。已离欲染未离色染。色界修所断结尽非九所摄。谓诸圣者离初静虑一品修所断染。乃至离第四静虑八品修所断染。所得诸断非九所摄。立修道果第二遍知缘未具故。已离色染未离无色染。无色界修所断结尽非九所摄。谓诸圣者离空无边处一品修所断染。乃至离非想非非想处八品修所断染。所得诸断非九所摄。立修道果第三遍知缘未具故

问诸异生者离欲界一品见修所断染。乃至离无所有处九品见修所断染。所得诸断亦非九所摄。此中何故不说。答应说而不说者。当知此义有余。复次此中但依圣者作论。不依异生。以九遍知唯在圣者身中立故

问诸已离欲界乃至无所有处染。入正性离生。彼先所得诸断。今至圣位随其所应。乃至未得见修道果断遍知名。彼断亦非此九所摄。此中何故不说彼耶。答应说而不说者。当知此义有余。复次此中略显初入门故。相粗者说不说细者。复次此中但说具缚异生入圣道者。彼非具缚而入圣道。是故不说

有八补特伽罗。一预流向。二预流果。三一来向。四一来果。五不还向。六不还果。七阿罗汉向。八阿罗汉果。问如是八种补特伽罗。名既有八实体有几。阿毗达磨诸论师言。此名有八实体唯五。谓预流向阿罗汉果。名有二种实体亦二。预流果一来向。名虽有二实体唯一。一来果不还向。名虽有二实体唯一。不还果阿罗汉向。名虽有二实体唯一。带果行向有情一故。尊者妙音作如是说。八补特伽罗名体俱有八。彼作是说。诸预流者乃至未起胜彼果道。成就预流果故名预流者。若起胜彼果道便舍预流果故。名一来向非预流者。诸一来者乃至未起胜彼果道。成就一来果故名一来者。若起胜彼果道便舍一来果故。名不还向非一来者。诸不还者乃至未起胜彼果道。成就不还果故名不还者。若起胜彼果道便舍不还果故。名阿罗汉向非不还者。以依根立补特伽罗故。不可言一有二种故。彼所造生智论言。问一来向成就预流果不。答不成就。问不还向成就一来果不。答不成就。问阿罗汉向成就不还果不。答不成就。评曰。应作是说。诸有渐次得四果者。彼名虽八实体唯五。如名体。名施设体施设。名异相体异相。名异性体异性。名建立体建立。名差别体差别。名分别体分别。名觉体觉。应知亦尔。问若八实体唯有五者。云何建立此八种名。答依道现行故立八种。谓预流者乃至未起胜彼果道。彼预流果得而亦在身成就亦现在前。于一来向未得。未在身未成就未现在前。名预流果非一来向。若起胜彼果道现在前。彼一来向得而亦在身成就亦现在前。于预流果得而不在身成就不现在前。名一来向非预流果。诸一来者乃至未起胜彼果道。彼一来果得而亦在身成就亦现在前。于不还向未得。未在身未成就未现在前。名一来果非不还向。若起胜彼果道现在前。彼不还向得而亦在身成就亦现在前。于一来果得而不在身成就不现在前。名不还向非一来果。诸不还者乃至未起胜彼果道。彼不还果得而亦在身成就亦现在前。于阿罗汉向未得。未在身未成就未现在前。名不还果非阿罗汉向。若起胜彼果道现在前。彼阿罗汉向得而亦在身成就亦现在前。于不还果得而不在身成就不现在前。名阿罗汉向非不还果。故体虽五而名有八。若并超越得四果者。即名有八体有七种。谓见道中有一来向无预流果。有不还向无一来果。唯决定无阿罗汉向无不还果。故体有七此八补特伽罗于九遍知几成就。几不成就。乃至广说。此中以补特伽罗为章以遍知为门。已说八种补特伽罗。今说此八于九遍知有不成就有成就者。此成就者有少有多。谓预流向或不成就或成就一二三四五。不成就者。谓苦法智忍乃至集法智忍位。此五心顷于见修道九种遍知皆未成就。四缘五缘俱未具故。成就一者。谓集法智集类智忍位。此二心顷俱成就欲界见苦集所断法断一遍知故。成就二者。谓集类智灭法智忍位。此二心顷成就三界见苦集所断法断二遍知故。成就三者。谓灭法智灭类智忍位。此二心顷成就三界见苦集所断法断。及欲界见灭所断法断三遍知故。成就四者。谓灭类智道法智忍位。此二心顷成就三界见苦集灭所断法断四遍知故。成就五者。谓道法智道类智忍位。此二心顷成就三界见苦集灭所断法断。及欲界见道所断法断。五遍知故。预流果成就六。谓道类智乃至未起胜彼果道。成就三界见所断法断六遍知故。一来向若倍离欲染入正性离生者如预流向。谓或不成就即见道初五心顷。或成就一二三四五即见道后十心顷。如其次第二二刹那。若从预流果趣一来果者。及一来果成就六。谓从起胜预流果道。乃至离欲染第六无间道。皆名趣一来果者。从道类智或离欲染第六解脱道。乃至未起胜彼果道。名一来果俱成就六。即三界见所断法断六遍知。不还向若已离欲染入正性离生者如预流向。谓或不成就即见道初五心顷。或成就一二三四五即见道后十心顷。如其次第二二刹那。此中有说。若已离欲染依六地。入正性离生者皆如预流向说。有作是说。若已离欲染依未至定入正性离生者如预流向说。若依上五地入正性离生者非如预流向。谓从苦法智忍乃至集类智忍未成就遍知。从集类智乃至灭类智忍成就一。谓色无色界见苦集所断法断遍知。从灭类智乃至道类智忍成就二。谓色无色界见苦集灭所断法断遍知。以上五地道非欲界法断对治故。于集灭道三法智时。不得欲界见所断法断三遍知。若从一来果趣不还果者成就六。谓从起胜一来果道。乃至离欲染第九无间道。皆名趣不还果者。彼成就六。谓三界见所断法断六遍知。不还果成就一。谓五顺下分结尽。从道类智或离欲染第九解脱道。乃至未起胜彼果道名不还果。彼成就一五顺下分结尽遍知。总三界见所断断。及欲界修所断断为自性故。阿罗汉向或成就一或成就二。谓未离色染者成就一。已离色染者成就二。谓从起胜不还果道。乃至金刚喻定皆名阿罗汉向。彼若未离色界染尽成就一。谓五顺下分结尽遍知。若已离色界染者成就二。谓次前一及色爱尽遍知。阿罗汉果成就一。谓一切结尽遍知。总集三界一切法断为自性故。独觉大觉如阿罗汉。俱唯成就第九遍知。问独觉学位为成就几。答部行喻者如声闻说。麟角喻者如菩萨说。问菩萨圣位成就几耶。答且见道中。有作是说。如预流向初五心顷。全未成就后十心顷如其次第。二二刹那成就一二三四五种。复有说者。初七心顷全未成就。从集类智乃至灭类智忍成就一。谓色无色界见苦集所断法断遍知。从灭类智乃至道类智忍成就二。谓色无色界见苦集灭所断法断遍知。第四静虑非欲界法断对治故。于集灭道三法智时。不得欲界见所断法断三遍知。从初道类智乃至金刚喻定皆成就一。谓五顺下分结尽遍知。问菩萨何时得色爱尽遍知。尊者僧伽筏苏说曰。初道类智位即得此遍知。评曰。彼不应作是说。无一念顷得果向故。有作是说。离非想非非想处染初无间道时得此遍知。彼亦不应作如是说尔时但修无色对治道。非色对治故。复有说者。金刚喻定现在前时得此遍知。彼亦不应作如是说。尔时总于三界一切见修所断法断。得一味离系得名得一切结尽遍知。如何今时得色爱尽。应作是说。菩萨圣位决定不得色无色界见道所断法断遍知。及色爱尽遍知总集遍知故。无容修彼断对治故

    结蕴第二中有情纳息第三之一

三界各有二部结谓见修所断。如是等章及解章义既领会已。次应广释。问何故作此论。答欲显三界各二部结令诸有情受种种苦。谓此诸结于生死中与诸有情。作大系缚作大无义作大崄伏。由有此故令诸有情于三界中受诸苦恼轮回生死。数入母胎生熟藏间。住冥闇处种种不净之所逼切。生已不知此结过患。复还染习受苦无穷。欲令有情于此诸结知见觉。已勤修对治断此诸结得永涅槃。不复轮回受生死苦。如不觉知怨家系缚无义崄伏则不能避。若觉知者便能避之。故应思惟筹量观察诃毁诸结种种善语乃至经生亦不忘失。如慈爱子初生之时便作是说。三界各有见修所断二部诸结。有情由此所系缚故。数入母胎受诸苦恼。轮回生死难有出期。问尊者何故于初生时作如是语。答以彼尊者在母胎中众苦逼切便作是念。何缘有情数入母胎受如是苦。作是念已。由宿爱乐多闻愿力即能了知。皆由三界各二部结未永断故。由是初生便能诃毁二部诸结种种过患。由此因缘故作斯论

问此中部言欲显何义。答欲显众义。如苾刍部名苾刍众。婆罗门部名婆罗门众。余亦如是。部众群聚名异义同。问此中顿言欲显何义。答显一时义。云何知然。契经说故。如契经说憍萨罗主胜军大王。来诣佛所。到已顶礼世尊双足。退坐一面。以敬爱语慰问世尊。佛亦随宜而慰喻彼。既问喻已复白佛言。我昔闻佛曾说此语。去来今世无有沙门婆罗门等。于一切法具实智见。若言有者必无是处。乔答摩尊忆此语不。佛言。不忆。复白佛言。世或有人。恶受文义异受异说。乔答摩尊必不应尔。唯愿审忆为我说之。佛言。大王。我忆往昔曾作是语。去来今世无有沙门婆罗门等。于一切法顿得智见。若言有者必无是处。决定经于三无数劫修习百千难行苦行。积渐具六波罗蜜多。然后乃能于一切法具实智见。故知顿者欲显一时

于欲界见修所断二部结颇有顿得系耶。答有。谓已离欲染异生。从离欲染退时及色无色界没生欲界时。谓诸异生已离欲染。若起欲界下下缠退。顿得欲界见修所断下下品结。若起欲界下中缠退。顿得欲界见修所断下下下中二品结乃至若起欲界上上缠退。顿得欲界见修所断九品诸结。先顿断故今还顿得。又上二界没生欲界时。九品缠中随起何品令生相续皆顿得。欲界见修所断九品诸结故有顿得此系。颇有顿离系耶。答有。谓异生离欲染时。此说异生离欲染位。总束欲界见修所断诸烦恼结以为九品。如刈草法品品顿断。谓以下下品无间道。顿断欲界见修所断上上品结。乃至以上上品无间道。顿断欲界见修所断下下品结。故有顿离此系。颇有渐得系耶答无。谓决定无先得欲界见所断结。后得欲界修所断结。亦决定无先得欲界修所断结。后得欲界见所断结。故无渐得此系颇有渐离系耶。答有。谓世尊弟子先离彼见所断结。后离彼修所断结。谓诸圣者先以见道断欲界见所断结。后以修道断欲界修所断结。故有渐离此系

于色界见修所断二部结颇有顿得系耶。答有。谓已离色染异生从离色染退时。及无色界没生欲色界时。谓诸异生已离色染。若起色界下下缠退。顿得色界见修所断下下品结。若起色界下中缠退。顿得色界见修所断下下下中二品结。乃至若起色界上上缠退。顿得色界见修所断九品诸结。此说自地。若起彼下地九品缠中一一退时。皆顿得上地见修所断九品诸结。若起欲界九品结中一一退时。亦皆顿得色界见修所断九品诸结。有作是说。此中应言。已离色染异生起欲界及梵世缠退时。顿得色界见修所断二部诸结。评曰。彼不应作是说。所以者何。此中总说顿得界系不说地故。若起第四静虑缠退。乃至若起欲界缠退。皆顿得色界见修所断结。其义无异先顿断故今还顿得。又无色界没生欲色界时。九品缠中随起何品令生相续。皆顿得色界见修所断九品诸结。有作是说。此中应言。无色界没生欲界及梵世时。顿得色界见修所断二部诸结。评曰。彼不应作是说。所以者何此中总说顿得界系不说地故。若生第四静虑乃至若生欲界。皆顿得色界见修所断诸结其义无异。故有顿得此系颇有顿离系耶。答有。谓异生离色染时此说异生离色染位。总束色界一一静虑见修所断诸烦恼结各为九品。如刈草法品品顿断。谓下下品无间道顿断色界一一静虑见修所断上上品结。乃至以上上品无间道顿断色界一一静虑见修所断下下品结。故有顿离此系。颇有渐得系耶。答无。谓决定无先得色界见所断结。后得色界修所断结。亦决定无先得色界修所断结。后得色界见所断结。故无渐得此系。颇有渐离系耶。答有。谓世尊弟子先离彼见所断结。后离彼修所断结。谓诸圣者先以见道断色界见所断结。后以修道断色界修所断结。故有渐离此系

于无色界见修所断二部结。颇有顿得系耶。答无。谓无异生全离无色染。后起自下缠退顿得无色界见修所断结义。亦无异生三界上没生三界时。顿得无色界见修所断结义。故无顿得此系。颇有顿离系耶。答无。谓无异生于无色界全离染义故决定无顿离无色界见修所断结。此约界说不约地故。虽约地说有顿离义。而非此中意所显示。故无顿离此系。前无顿得准此应知。颇有渐得系耶。答无。谓决定无先得无色界见所断结。后得无色界修所断结。亦决定无先得无色界修所断结。后得无色界见所断结。故无渐得此系。颇有渐离系耶。答有。谓世尊弟子先离彼见所断结后离彼修所断结。谓诸圣者。先以见道断无色界见所断结。后以修道断无色界修所断结。故有渐离此系

问异生圣者随离何地九品染时。几无间道几解脱道而得离耶。有作是说。异生但以三无间道三解脱道离九品染。谓以下品无间解脱道离上三品染。以中品无间解脱道离中三品染。以上品无间解脱道离下三品染。圣者亦尔。有余师说。异生但以一品无间解脱道顿离九品染。圣者以九品无间解脱道渐离九品染。所以者何。异生道钝于所知断。不能分折作九品异。故一品道而顿断之。圣者道利于所知断。能善分折作九品异。故九品道而渐断之。评曰。彼不应作是说。若作是说欲显异生劣于圣者。翻显圣者劣于异生。若诸异生以一品道离九品染。圣者以九品道离九品染。岂非圣者劣于异生。如多服毒饮少药时便能总吐谁不称善。应作是说。异生圣者无不皆以九无间道九解脱道离九品染。问若尔。异生圣者有何差别。答异生以九无间道九解脱道。总束见修所断诸结以为九品。如刈草法品别顿断。圣者以一无间道一解脱道。顿断九品见所断结。以九无间道九解脱道渐断九品修所断结。是谓异生圣者差别

问异生圣者随离何地九品染时。以几加行以几入定而得离耶。有作是说。以三加行以三入定离九品染。谓以初加行以初入定离上三品。以第二加行以第二入定离中三品。以第三加行以第三入定离下三品。评曰。应作是说。此事不定。或有以一加行以一入定离九品染。或有乃至以九加行以九入定离九品染

问异生圣者随离何地九品染时。为止息为不止息耶。有作是说。异生不止息。圣者或止息或不止息。复有说者。圣者不止息。异生或止息或不止息。评曰。应作是说。此事不定。谓异生圣者俱或止息或不止息离九品染。有余师说。离欲界染不止息。离色无色界染或止息或不止息。或有说者离色无色界染不止息。离欲界染或止息或不止息。评曰。应作是说。此事不定。离三界染皆或止息或不止息而离九品。问异生圣者起缠退时起何品缠得何品结。有作是说。异生于下三品中随起一缠退时得下三品结。于中三品中随起一缠退时得下中六品结。于上三品中随起一缠退时得九品结。圣者起下下品缠退时得下下品结起下中品缠退时。得下下下中二品结。乃至起上上品缠退时得九品结。复有说者。异生于九品中随起一品缠退时皆得九品结。圣者退时义如前说。所以者何。异生但以世俗定力任持相续。诸世俗定力羸劣故净不坚牢染法易得。圣者亦以无漏定力任持相续。诸无漏定力强胜故净法坚牢染法难得故。评曰。彼不应作是说。所以者何。异生圣者俱未曾见不服毒药而致死者。应作是说。异生若起下下品缠退时得下下品结。若起下中品缠退时。得下下下中二品结。乃至若起上上品缠退时得九品结。圣者亦尔。问若尔。异生圣者有何差别。答异生若起下下品缠退时。顿得见修所断下下品结。若起下中品缠退时。顿得见修所断下下下中二品结。乃至若起上上品缠退时。顿得见修所断九品结。圣者若起下下品缠退时。唯得修所断下下品结。若起下中品缠退时。唯得修所断下下下中二品结。乃至若起上上品缠退时。唯得修所断九品结。见所断结无退得义。是谓异生圣者差别。有余师说。若起欲界下三品中随一缠退时。得欲界下三品结。若起欲界中三品中随一缠退时。得欲界下中六品结。若起欲界上三品中随一缠退时。得欲界九品结若起色无色界下下品缠退时。得彼下下品结。若起色无色界下中品缠退时。得彼下下下中二品缠乃至若起色无色界上上品缠退时。得彼九品结。或有说者。若起欲界九品中随一缠退时。皆得欲界九品结。若起色无色界缠退时。义如前说。所以者何。欲界无定染法易得。色无色界有定染法难得故。评曰。彼不应作是说。断烦恼时皆由定故。应作是说。三界九地诸烦恼中。若起下下品缠退时。皆唯得下下品结若起下中品缠退时。皆得下下下中二品结。乃至若起上上品缠退时。皆得九品结

说一切有部发智大毗婆沙论卷第六十三阿毗达磨大毗婆沙论卷第六十四

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中有情纳息第三之二

生欲界圣者有三事命终。一全离染而命终。二全退而命终。三分离染而命终。异生但有二事命终。一全离染而命终。二全退而命终。无分离染而命终者。生色界圣者有二事命终。一全离染而命终。二分离染而命终。无有退者。色无色界无退义故。异生但有一事命终。谓全离染彼无退故。无分离染而命终故。生无色界圣者异生应知亦尔。问何故圣者有分离染而命终。异生不尔答以诸圣者有无漏定。任持相续令极坚固。异生但有世俗诸定。任持相续非极坚固。复次圣者成就胜奢摩他毗钵舍那异生不尔。复次圣者成就无漏道力随意所为。异生不尔。是故圣者有分离染而命终义。异生即无。有作是说。以诸圣者具三种力。一圣道力。二烦恼力。三定业力。定业力故有全离染而命终义烦恼力故有全退已而命终义。圣道力故有分离染而命终义异生但有二种力。谓烦恼力。定业力。无圣道力。定业力故有全离染而命终义。烦恼力故有全退已而命终义。无圣道力故无分离染而命终义。有余师说。圣者有三力。一道力。二烦恼力。三定业力。由道力故有全离染而命终。由烦恼力故有全退已而命终。由定业力。故有分离染而命终。若全离染得此地生非择灭故。决定受业便不与果。由此定业为留难故。有分离染而命终者。如家家等。异生但有二力。谓道力烦恼力。无定业力。由道力故有全离染而命终。由烦恼力故有全退已而命终。无定业力故无分离染而命终。设全离染而有还生此地义故。决定受业不为留难。或有说者。分离染位有别立圣补特伽罗。谓离欲界三四品染别立家家。离六品染别立一来。离七八品别立一间。是故圣者有分离染而命终义。异生定无分离染位如圣别立补特伽罗。是故彼无分离染已而命终义。复有说者。圣者于定有自在力故离染时有离少分而命终者。异生于定无自在力。故离染时无离少分而命终者。尊者僧伽筏苏说曰。异生亦有分离染位而命终者。然命终已结生心时先所断结必还成就。评曰。彼不应作是说。彼命终心势力劣故。先所断结已得成就。是故前说于理为善

问以世俗道离诸染时。无间解脱有几行相。答诸无间道有三行相。一粗行相。二苦行相。三障行相。诸解脱道有三行相。一静行相。二妙行相。三离行相。问无间道中何行相后。起解脱道何行相耶。有作是说。从粗行。相无间道后。起静行相为解脱道。从苦行相无间道后。起妙行相为解脱道。从障行相无间道后。起离行相为解脱道。有余师说。从粗行相无间道后。起妙行相为解脱道。从苦行相无间道后。起静行相为解脱道。从障行相无间道后。起离行相为解脱道。粗妙苦静障离对故。评曰。此事不定。从粗行相无间道后。容起静等三种行相为解脱道。从苦行相无间道。后容起妙等三种行相为解脱道。从障行相无间道后。容起离等三种行相为解脱道。以此六种有漏行相随离染者所乐起故

问以世俗道离诸染时无间解脱各缘何地。答离欲染时。九无间道唯缘欲界。九解脱道缘初静虑。问若尔。善通根蕴所说。如说。颇有思惟色界法。而能遍知欲界耶。答有。彼意说断遍知。云何二道所缘行相而不杂乱。若此二道所缘行相有杂乱者。于离染事如何不为障碍留难。答如是二道所缘行相虽有杂乱。于离染事然不能为障碍留难。所以者何。彼于离染诸迳路中已善修习加行成故。如见道中。缘欲界忍智后缘有顶忍智现在前。缘有顶忍智后缘欲界忍智现在前。虽有所缘行相杂乱。于现观事。然不能为障阂留难。所以者何。彼于现观诸迳路中已善修习加行成故。此亦如是。故无有失。有作是说。离欲染时九无间道八解脱道皆缘欲界。最后解脱缘初静虑。如以灭道智离非想非非想处染时。九无间道八解脱道皆缘灭道。最后解脱道缘非想非非想处有漏四蕴此亦如是。有余师说。离欲染时或无止息或有止息。无止息者。九无间道八解脱道皆缘欲界。最后解脱道缘初静虑。有止息者。或离一品即便止息。或离二品而便止息。如是乃至或离八品方乃止息。若离一品即止息者。彼无间道缘欲界。解脱道缘初静虑。若离二品便止息者。彼二无间道。一解脱道缘欲界。第二解脱道缘初静虑。如是乃至若离八品方止息者。彼八无间道七解脱道皆缘欲界。第八解脱道缘初静虑。或有说者。离欲染时九无间道九解脱道皆缘欲界。如以苦集智离欲染时。九无间道九解脱道皆缘欲界。此亦如是。问若尔。虽无无间解脱所缘行相杂乱过失。根蕴所说当云何通。如说。颇有思惟色界法而能遍知欲界耶。答有。彼意说断遍知。答根蕴依近加行而说。谓修行者将离欲染。先起如是分别思惟。欲界苦粗障初静虑静妙离。问若尔。根蕴后说复云何通。如说颇有思惟无色界法而能遍知欲界耶。答无。彼意说断遍知。岂修行者将离欲染。不先起此分别思惟。欲界苦粗障无色界静妙离部。答虽起如是分别思惟。而远非近。非于思惟无色界后即能引生离欲染道。思惟色界是近加行即能引生离欲染道。故彼二说非互相违。复有说者。离欲染时九无间道九解脱道皆缘初静虑。问若尔。善通根蕴所说。如说。颇有思惟色界法而能遍知欲界耶。答有。彼意说断遍知。又无二道所缘行相杂乱过失。云何缘他地能离余地染。答此亦无失。如灭道智离诸染时。虽缘灭道而断苦集。此亦如是。评曰。如是诸说虽各能生弟子觉慧。而最初说于理为善。谓九无间道皆缘欲界。九解脱道皆缘初静虑。所以者何。以世俗道离欲染时。厌下欣上方能离故。如离欲染离上七地染。应知亦尔

问世俗无间解脱道中一一能修几种行相。答诸异生者离欲染时。九无间道中修三行相。谓苦粗障八解脱道中修六行相。谓苦粗障及静妙离。最后解脱道中即修此六行相。亦修未来初静虑地无边行相。如是乃至离无所有处染。随其所应当知亦尔。若诸圣者离欲染时。九无间道中修十九行相。谓粗等三及有漏无漏十六圣行相。八解脱道中修二十二行相。谓粗等三静等三。及有漏无漏十六圣行相。最后解脱道中即修此二十二行相。亦修未来初静虑地无边行相。即诸圣者离初静虑染时。九无间道中修十九行相。谓粗等三及唯无漏十六圣行相。八解脱道中修二十二行相。谓粗等三静等三。及唯无漏十六圣行相。最后解脱道中即修此二十二行相。亦修未来第二静虑地无边行相如是。乃至离无所有处染。随其所应当知亦尔

问何故初静虑近分通修有漏无漏十六圣行相。上地近分唯修无漏耶。答初静虑近分有圣行相。故能通修有漏无漏十六圣行相。上地近分无圣行相。故唯能修无漏行相。有作是说。诸异生者离欲染时。九无间道中修九行相。谓粗等三及慈悲喜舍。不净观持息念。八解脱道中修十二行相。谓即前九及静等三。最后解脱道中即修此十二行相。亦修未来初静虑地无边行相。若诸圣者离欲染时。九无间道中修二十五行相。谓粗等三慈悲喜舍。不净观持息念。及有漏无漏十六圣行相。八解脱道中修二十八行相。谓即前二十五及静等三。最后解脱道中即修此二十八行相。亦修未来初静虑地无边行相。上地近分修义如前

问何故初静虑近分能修如是种种行相。上地近分不能修耶。答初静虑近分有种种善根。故能修此种种行相。上地近分诸善根少。故不能修种种行相。复次欲界烦恼有种种相还修种种善根。对治上地烦恼无种种相故。彼不修种种对治

问现在俱行负重有用。世俗无间及解脱道行相所缘。已如前说。未来修者为何所缘。答离欲染时。九无间道中所修未来粗等三行相唯缘欲界。八解脱道中。所修未来粗等三行相。缘欲界及初静虑。静等三行相。唯缘初静虑。最后解脱道中。所修未来粗等三行相通缘三界。静等三行相缘初静虑。乃至非想非非想处。离初静虑染时。九无间道中。所修未来粗等三行相唯缘初静虑。八解脱道中。所修未来粗等三行相缘初二静虑。静等三行相唯缘第二静虑。最后解脱道中。所修未来粗等三行相通缘三界。静等三行相缘第二静虑。乃至非想非非想处。离第二静虑染时。九无间道中。所修未来粗等三行相。唯缘第二静虑。八解脱道中所修。未来粗等三行相缘第二第三静虑。静等三行相唯缘第三静虑。最后解脱道中。所修未来粗等三行相通缘三界。静等三行相缘第三静虑乃至非想非非想处。离第三静虑染时。九无间道中。所修未来粗等三行相唯缘第三静虑。八解脱道中。所修未来粗等三行相缘第三第四静虑。静等三行相唯。缘第四静虑。最后解脱道中。所修未来粗等三行相通缘三界。静等三行相缘第四静虑乃至非想非非想处。离第四静虑染时。九无间道中所修未来粗等三行相唯缘第四静虑。八解脱道中。所修未来粗等三行相缘第四静虑及空无边处。静等三行相唯缘空无边处。最后解脱道中。所修未来粗等三行相。及静等三行相。缘空无边处乃至非想非非想处。问若离第四静虑染。八解脱道中所修未来粗等三行相。能缘第四静虑及空无边处者。识身论说当云何通。如说颇有无色界善心能了别色无色界法耶。答无。彼遮刹那不遮相续。谓一刹那顷无色界善心。能了别色无色法者无有是处。若离彼染八解脱道中所修未来粗等三行相。或缘色界第四静虑。或缘无色界空无边处斯有是处故遮刹那不遮相续。此与彼说俱为善通。离空无边处染时。九无间道中。所修未来粗等三行相。唯缘空无边处。八解脱道中所修未来粗等三行相。缘空无边处及识无边处。静等三行相唯缘识无边处。最后解脱道中所修未来粗等三行相及静等三行相。缘识无边处乃至非想非非想处。离识无边处染时。九无间道中所修未来粗等三行相唯缘识无边处。八解脱道中所修未来粗等三行相。缘识无边处及无所有处。静等三行相唯缘无所有处。最后解脱道中。所修未来粗等三行相及静等三行相。缘无所有处及非想非非想处。离无所有处染时。九无间道中所修未来粗等三行相唯缘无所有处。八解脱道中所修未来粗等三行相。缘无所有处及非想非非想处。静等三行相唯缘非想非非想处。最后解脱道中所修未来粗等三行相。及静等三行相。唯缘非想非非想处。问何故最后解脱道中所修未来静虑所摄粗等行相通缘三界。无色所摄粗等行相唯缘无色界耶。答静虑地中有遍缘智。能缘自地下地上地。无色地中无遍缘智。唯缘自上不缘下地。复次静虑地中功德粗显易。知易了。非无色地。复次静虑地中多诸功德多诸胜利。无色不尔。复次静虑地中善有种种异相异性。无色不尔。复次静虑地中有异相根异相受异相心心所法。无色不尔。是故尔时所修未来静虑所摄粗等行相通。缘三界。无色所摄粗等行相唯缘无色界

欲界见所断结尽何果摄。乃至广说。问何故作此论。答先说三界二部诸结顿渐得舍。未说彼断是何果摄。今欲说之故作斯论。欲界见所断结尽何果摄。答四沙门果或无处。四沙门果摄者。谓彼结尽证预流果时即预流果摄。证一来果时即一来果摄。证不还果时即不还果摄。证阿罗汉果时即阿罗汉果摄。或无处者谓诸异生已离欲染彼结尽非果摄。已离欲染入正性离生者。见道十五心顷彼结尽非果摄。次第者道现观二心顷彼结尽非果摄。欲界修所断结尽何果摄。答不还阿罗汉果。或无处不还果摄者。谓彼结尽证不还果时即不还果摄。阿罗汉果摄者。谓彼结尽证阿罗汉果时即阿罗汉果摄。或无处者谓诸异生已离欲染彼结尽非果摄。已离欲染入正性离生者。见道十五心顷彼结尽非果摄。无次第者非果摄义。所以者何。离欲染第九无间道灭时方断彼尽。第九解脱道生时证不还果。彼结尽即不还果摄故。色界见所断结尽。何果摄。答四沙门果或无处。四沙门果摄者。谓彼结尽证预流果时即预流果摄。乃至证阿罗汉果时即阿罗汉果摄。或无处者谓诸异生已离色染彼结尽非果摄。已离色染入正性离生者。见道十五心顷彼结尽非果摄。无次第者非果摄义。所以者何道类智忍灭时方断彼尽道类智生时随其所应证前三果。彼结尽即前三果摄故。色界修所断结尽何果摄。答阿罗汉果。或无处。阿罗汉果摄者谓彼结尽证阿罗汉果时即阿罗汉果摄。或无处者谓诸异生已离色染彼结尽非果摄。已离色染入正性离生者。见道十五心顷及道类智等。诸有学位彼结尽非果摄。次第者从离第四静虑染第九解脱道。乃至金刚喻定现在前时彼结尽非果摄。无色界见所断结尽何果摄。答四沙门果。谓彼结尽证预流果时即预流果摄。乃至证阿罗汉果时即阿罗汉果摄。无异生者非果摄义。所以者何。无有异生能离非想非非想处见所断结故。亦无次第者非果摄义。所以者何。道类智忍灭时方断彼尽。道类智生时随其所应证前三果。彼结尽即前三果摄故。无色界修所断结尽何果摄。答阿罗汉果。谓彼结尽证阿罗汉果时即阿罗汉果摄。无异生者非果摄义。所以者何。无有异生能离非想非非想处修所断结故。亦无次第者非果摄义。所以者何。金刚喻定现在前时方断彼尽。初尽智生时证阿罗汉果。彼结尽即阿罗汉果摄故。有五部结。谓见苦所断结。乃至修所断结。问何故作此论。答先虽说三界二部结尽诸果所摄。而未说五部结尽诸果所摄。今欲说之故作斯论。见苦所断结尽何果摄。答四沙门果或无处。四沙门果摄者。谓彼结尽证预流果时即预流果摄。乃至证阿罗汉果时即阿罗汉果摄。或无处者无有异生。非果摄义。所以者何。无异生者能离非想非非想处见苦所断结故。次第者苦现观一心顷。集灭现观各四心顷。道现观三心顷。彼结尽非果摄。见集所断结尽何果摄。答四沙门果或无处四沙门果摄者。如前说。或无处者无有异生非果摄义。所以者何。无异生者能离非想非非想处见集所断结故。次第者集现观一心顷灭现观四心顷。道现观三心顷。彼结尽非果摄。见灭所断结尽何果摄。答四沙门果或无处。四沙门果摄者。如前说。或无处者无有异生非果摄义。所以者何。无异生者能离非想非非想处见灭所断结故。次第者灭现观一心顷。道现观三心顷。彼结尽非果摄。见道所断结尽何果摄。答四沙门果。谓彼结尽证预流果时即预流果摄。乃至证阿罗汉果时即阿罗汉果摄。无有异生非果摄义。所以者何。无异生者能离非想非非想处见道所断结故。亦无次第者非果摄义。所以者何。道类智忍灭时方断彼尽。道类智生时随其所应证前三果。彼结尽即前三果摄故。修所断结尽何果摄。答阿罗汉果。谓彼结尽证阿罗汉果时即阿罗汉果摄。无有异生非果摄义。所以者何。无异生者能离非想非非想处修所断结故。亦无次第者非果摄义。所以者何。金刚喻定现在前时方断彼尽。初尽智生时证阿罗汉果彼结尽即阿罗汉果摄故

有九部结。谓苦法智所断结。乃至修所断结。问何故作此论。答先虽说五部结尽诸果所摄。而未说九部结尽诸果所摄。今欲说之故作斯论。即前五部诸结依对治差别说为九部。谓法类智品各别所对治结分为八部。杂所对治总为一部故有九部。苦法智所断结尽何果摄。答四沙门果。或无处四沙门果摄者。谓彼结尽证预流果时即预流果摄。乃至证阿罗汉果时即阿罗汉果摄。或无处者谓诸异生已离欲染彼结尽非果摄。已离欲染入正性离生者。见道十五心顷彼结尽非果摄。次第者苦现观三心顷。集灭现观各四心顷。道现观三心顷。彼结尽非果摄。苦类智乃至道法智所断结尽何果摄。答四沙门果或无处。四沙门果摄者。如前说。或无处者若苦类智所断结尽。无有异生非果摄义。所以者何。无异生者能离非想非非想处见苦所缘结故。次第者苦现观一心顷集灭现观各四心顷。道现观三心顷。彼结尽非果摄。若集法智所断结尽。谓诸异生已离欲染彼结尽非果摄。已离欲染入正性离生者。见道十五心顷彼结尽非果摄。次第者集现观三心顷。灭现观四心顷。道现观三心顷。彼结尽非果摄。若集类智所断结尽。无有异生非果摄义。所以者何。无异生者能离非想非非想处见集所断结故。次第者集现观一心顷。灭现观四心顷。道现观三心顷。彼结尽非果摄。若灭法智所断结尽。谓诸异生已离欲染彼结尽非果摄。已离欲染入正性离生者。见道十五心顷彼结尽非果摄。次第者灭道现观各三心顷彼结尽非果摄。若灭类智所断结尽无有异生非果摄义。所以者何。无异生者能离非想非非想处见灭所断结故。次第者灭现观一心顷。道现观三心顷。彼结尽非果摄。若道法智所断结尽。谓诸异生已离欲染彼结尽非果摄。已离欲染入正性离生者。见道十五心顷彼结尽非果摄。次第者道现观二心顷彼结尽非果摄故说无处。道类智所断结尽何果摄。答四沙门果。谓彼结尽证预流果时即预流果摄。乃至证阿罗汉果即阿罗汉果摄。无有异生非果摄义。所以者何。无异生者能离非想非非想处见道所断结故。亦无次第者非果摄义。所以者何。道类智忍灭时方断彼尽。道类智生时随其所应证前三果。彼结尽即前三果摄故。修所断结尽何果摄。答阿罗汉果。谓彼结尽证阿罗汉果时即阿罗汉果摄。无有异生非果摄义。所以者何。无异生者能离非想非非想处修所断结故。亦无次第者非果摄义。所以者何。金刚喻定现在前时方断彼尽。初尽智生时证阿罗汉果。彼结尽即阿罗汉果摄故

问为无间道能断诸结。为解脱道能断诸结。设尔何失。二俱有过。所以者何。若无间道能断诸结。此文所说当云何通。如说苦法智所断结。乃至道类智所断结。若解脱道能断诸结。智蕴所说当云何通。如说诸结见苦所断彼结非苦智断是苦忍断。乃至诸结见道所断彼结非道智断是道忍断。答应作是说。唯无间道能断诸结。问若尔善通智蕴所说。此文所说当云何通。答此文应作是说。有九部结。谓苦法智忍所断。乃至道类智忍所断。而不作是说者有别意趣。谓忍属智是智助伴。诸忍所断名智所断。如臣所作名王所作。复次无间道正能断结。解脱道持令不生。谓无间道虽正断结。若无解脱道持令不生者。彼结还起便为过患。显解脱道于断有用故。此文说法类智断。复次无间解脱同一所作。于断结事俱有势力。如二力士同害一怨。一扑置地一令不起。不尔还起能为过患。又如二人同逐一贼。一驱令出一牢闭门。不尔还入能为过患。又如二士同捉一蛇。一内瓶中一牢盖口。不尔还出能为过患。无间解脱断结亦然。显解脱道于断有用故。此文说法类智断。复次欲显解脱道于无间道所断结中有多作用。此多作用如根蕴说。故此文说法类智断。复次诸无间道正断结。得诸解脱道与彼诸结断得俱生。既得彼断有断彼用。故此文说法类智断。复次断有二种。一别二通。别唯无间通解脱。此依通说故不违理。复次此中诸忍以智名说能引智故因立果名。如饥渴名因彼因触。故能断结唯无间道

有十五部结。谓三界各有五。即见苦所断结。乃至修所断结。问何故作此论。答先虽说九部结尽诸果所摄。而未说十五部结尽诸果所摄。今欲说之故作斯论。谓约界部二门。分别诸结差别有十五种。欲界见苦集灭道所断结尽何果摄。答四沙门果。或无处。四沙门果摄者。谓彼结尽证预流果时即预流果摄。乃至证阿罗汉果时即阿罗汉果摄。或无处者若欲界见苦所断结尽。谓诸异生已离欲染彼结尽非果摄。已离欲染入正性离生者。见道十五心顷彼结尽非果摄。次第者苦现观三心顷。集灭现观各四心顷。道现观三心顷。彼结尽非果摄。若欲界见集所断结尽。谓诸异生已离欲染彼结尽非果摄。已离欲染入正性离生者。见道十五心顷。彼结尽非果摄。次第者集现观三心顷。灭现观四心顷。道现观三心顷。彼结尽非果摄。若欲界见所断结尽。谓诸异生已离欲染彼结尽非果摄。已离欲染入正性离生者。见道十五心顷彼结尽非果摄。次第者灭道现观各三心顷。彼结尽非果摄。若欲界见道所断结尽。谓诸异生已离欲染彼结尽非果摄。已离欲染入正性离生者。见道十五心顷彼结尽非果摄。次第者道现观二心顷。彼结尽非果摄。欲界修所断结尽何果摄。答不还阿罗汉果或无处。不还果摄者。谓彼结尽证不还果时即不还果摄。阿罗汉果摄者。谓彼结尽证阿罗汉果时即阿罗汉果摄。或无处者。谓诸异生已离欲染彼结尽非果摄。已离欲染入正性离生者。见道十五心顷彼结尽非果摄。无次第者非果摄义。所以者何。离欲染第九无间道灭时方断彼尽。第九解脱道生时证不还果即不还果摄故。色界见苦集灭道所断结尽何果摄。答四沙门果。或无处。四沙门果者。如前说。或无处者若色界见苦所断结尽。谓诸异生已离色染彼结尽非果摄。已离色染入正性离生者。见道十五心顷彼结尽非果摄。次第者苦现观一心顷。集灭现观各四心顷。道现观三心顷。彼结尽非果摄。若色界见集所断结尽。谓诸异生已离色染彼结尽非果摄。已离色染入正性离生者。见道十五心顷彼结尽非果摄。次第者集现观一心顷。灭现观四心顷。道现观三心顷。彼结尽非果摄。若色界见灭所断结尽。谓诸异生已离色染彼结尽非果摄。已离色染入正性离生者。见道十五心顷彼结尽非果摄。次第者灭现观一心顷。道现观三心顷。彼结尽非果摄。若色界见道所断结尽。谓诸异生已离色染彼结尽非果摄。已离色染入正性离生者。见道十五心顷彼结尽非果摄。无次第者非果摄义。所以者何。道类智忍灭时方断彼尽。道类智生时随其所应证前三果彼结尽即前三果摄故。色界修所断结尽何果摄。答阿罗汉果或无处。阿罗汉果摄者。谓彼结尽证阿罗汉果时即阿罗汉果摄。或无处者。谓诸异生已离色染彼结尽非果摄。已离色染入正性离生者。见道十五心顷及道类智等诸有学位彼结尽非果摄。次第者从离第四静虑染第九解脱道。乃至金刚喻定现在前时彼结尽非果摄。无色界见苦集灭所断结尽何果摄。答四沙门果或无处。四沙门果者。如前说。或无处者若无色界见苦所断结尽。无有异生非果摄义。所以者何。无异生者能离非想非非想处见修所断结故。次第者苦现观一心顷。集灭现观各四心顷。道现观三心顷。彼结尽非果摄。若无色界见集所断结尽。无有异生非果摄义。义如前说。次第者集现观一心顷。灭现观四心顷。道现观三心顷。彼结尽非果摄。若无色界见灭所断结尽无有异生非果摄义。义如前说。次第者灭现观一心顷。道现观三心顷。彼结尽非果摄。若无色界见道所断结尽何果摄。答四沙门果。谓彼结尽证预流果时即预流果摄。乃至证阿罗汉果时即阿罗汉果摄。无有异生非果摄义。义如前说。亦无次第者非果摄义。所以者何。道类智忍灭时方断彼尽。道类智生时随其所应证前三果。彼结尽即前三果摄故。无色界修所断结尽何果摄。答阿罗汉果。谓彼结尽证阿罗汉果时即阿罗汉果摄。无有异生非果摄义。义如前说。亦无次第者非果摄义。所以者何。金刚喻定现在前时方断尽。初尽智生时证阿罗汉果彼结尽即阿罗汉果摄故

说一切有部发智大毗婆沙论卷第六十四阿毗达磨大毗婆沙论卷第六十五

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中有情纳息第三之三

三结乃至九十八随眠一一尽何果摄。问何故作此论。答先虽说十五部结尽诸果所摄。而未说十六章烦恼尽诸果所摄。今欲说之故作斯论。答三结中有身见尽四沙门果摄。或无处。四沙门果摄者。谓彼尽证预流果时即预流果摄。乃至证阿罗汉果时即阿罗汉果摄。或无处者谓无异生非果摄义。所以者何。无异生者能离非想非非想处有身见故。次第者苦现观一心顷。集灭现观各四心顷。道现观三心顷。有身见尽非果摄。如三结中有身见尽。应知五顺下分结中有身见。五见中有身见边执见尽亦尔。自性等故同对治故。戒禁取疑尽四沙门果摄。四果摄义如前应知。此无异生非果摄义。所以者何。无异生者能离非想非非想处戒禁取疑故。亦无次第者非果摄义。所以者何。道类智忍灭时方断彼尽。道类智生时随其所应证前三果。戒禁取疑尽即前三果摄故。如三结中戒禁取疑尽。应知四瀑流轭中见瀑流轭。四取中见取戒禁取。四身系中戒禁取此实执身系。五顺下分结中戒禁取疑。五见中邪见见取戒禁取。七随眠中见疑随眠。九结中见取疑结尽亦尔。自性等故。同对治故。三不善根尽不还阿罗汉果摄。或无处。不还果摄者。谓彼尽证不还果时即不还果摄。阿罗汉果摄者。谓彼尽证阿罗汉果时即阿罗汉果摄。或无处者。谓诸异生已离欲染彼尽非果摄。已离欲染入正性离生者。见道十五心顷彼尽非果摄。无次第者非果摄义。所以者何。离欲染第九无间道灭时方断彼尽。第九解脱道生时证不还果即不还果摄故。如三不善根尽。应知三漏中欲漏。四瀑流轭中欲瀑流轭。四取中欲取。四身系中贪欲嗔恚。五盖中前四盖。五结中嗔嫉悭结。五顺下分结中贪欲嗔恚。六爱身中鼻舌触所生爱身。七随眠中贪欲嗔恚。九结中恚嫉悭结尽亦尔。自性等故。同对治故。有漏无明漏尽阿罗汉果摄。谓彼尽证阿罗汉果时即阿罗汉果摄。无有异生非果摄义。所以者何。无异生者能离非想非非想处有漏无明漏故。亦无次第者非果摄义。所以者何。金刚喻定现在前时方断彼尽。初尽智生时证阿罗汉果彼尽即阿罗汉果摄故。如有漏无明漏尽。应知四瀑流轭中有无明瀑流轭。四取中我语取。五结中贪慢结。五顺上分结中除色贪余四。六爱身中意触所生爱身。七随眠中有贪无明慢。九结中爱慢无明结尽亦尔。自性等故。同对治故。疑盖尽四沙门果摄。或无处。四沙门果摄者如前说。或无处者。谓诸异生已离欲染疑盖尽非果摄。已离欲染入正性离生者。见道十五心顷疑盖尽非果摄。次第者道现观二心顷疑盖尽非果摄。色贪顺上分结尽阿罗汉果摄或无处。阿罗汉果摄者。谓彼尽证阿罗汉果时即阿罗汉果摄。或无处者。谓诸异生已离色染彼尽非果摄。已离色染入正性离生者。见道十五心顷及道类智等诸有学位彼尽非果摄。次第者从离第四静虑染第九解脱道。乃至金刚喻定现在前时彼尽非果摄。如色贪顺上分结尽。应知眼耳身触所生爱身尽亦尔。自性等故。同对治故。然有差别。此中应言或无处者。谓诸异生已离梵世染彼尽非果摄。已离梵世染入正性离生者。见道十五心顷及道类智等诸有学位彼尽非果摄。次第者从离初静虑染第九解脱道。乃至金刚喻定现在前时彼尽非果摄。九十八随眠中欲界见苦集灭道所断随眠尽四沙门果摄或无处。此如十五部结中欲界前四部尽说。欲界修所断随眠尽不还阿罗汉果摄或无处。此如十五部结中。欲界第五部尽说。色界见苦集灭道所断随眠尽四沙门果摄或无处。此如十五部结中色界前四部尽说。色界修所断随眠尽阿罗汉果摄或无处。此如十五部结中色界第五部尽说。无色界见苦集灭所断随眠尽四沙门果摄或无处。此如十五部结中无色界前三部尽说。无色界见道所断随眠尽四沙门果摄。此如十五部结中无色界第四部尽说。无色界修所断随眠尽阿罗汉果摄。此如十五部结中无色界第五部尽说。预流向中诸结尽何果摄。答无处。所以者何。预流果前无沙门果摄彼尽故。预流果中诸结尽何果摄。答预流果。谓此果中总摄三界见所断诸结尽。一来向中诸结尽何果摄。答预流果或无处。预流果摄者。谓此果中总摄三界见所断诸结尽。或无处者。谓倍离欲染入正性离生者。见道十五心顷诸结尽非果摄。次第者欲界前五品修所断诸结尽非果摄。所以者何。是胜果道所证得故。如胜果道非果所摄。所得结尽理亦应尔。一来果中诸结尽何果摄。答一来果。谓此果中总摄三界见所断诸结尽。及摄欲界修所断前六品诸结尽。不还向中诸结尽何果摄。答一来果或无处。一来果摄者。谓此果中。总摄三界见所断诸结尽。及摄欲界修所断前六品诸结尽。或无处者。谓已离欲乃至无所有处染入正性离生者。见道十五心顷诸结尽非果摄。次第者。欲界修所断第七第八品诸结尽非果摄。不还果中诸结尽何果摄。答不还果。谓此果中总摄三界见所断诸结尽。及摄欲界修所断诸结尽。阿罗汉向中诸结尽何果摄。答不还果或无处。不还果摄者。谓此果中总摄三界见所断诸结尽。及摄欲界修所断诸结尽。或无处者。谓离初静虑一品。乃至非想非非想处八品染诸结尽非果摄。所以者何。是胜果道所证得故。如胜果道非果所摄。所得结尽理亦应尔阿罗汉果中诸结尽何果摄。答阿罗汉果。谓此果中总摄三界见修所断诸结尽。问此中为说诸向果中所成就诸结尽。为说诸向果中新所证得诸结尽。设尔何失。二俱有过。所以者何。若说诸向果中所成就诸结尽者。前三果中诸结尽不应唯说自果摄。如已离欲前五品染入正性离生者。至道类智时证预流果。彼欲界修所断五品结尽。非此果摄。何故不说或无处耶。又已离欲前八品染入正性离生者。至道类智时证一来果。彼欲界修所断第七八品结尽非此果摄何故不说或无处耶。又已离欲乃至无所有处染入正性离生者。至道类智时证不还果。彼上二界七地修所断结尽非此果摄何故不说或无处耶。若说诸向果中新所证得诸结尽者。后三向中诸结尽不应亦说前果摄。向中新所证结尽定非前果所摄故。答此中总说诸向果中所成就诸结尽。问若尔善通后三向难。前三果难当云何通。答此说具缚入见道者故。前三果所成就结尽唯说自果摄。有作是说。此中果位说新所证所求满故。向位未满所求事故总说成就故。向果位二说善通

具见世尊弟子未离欲染。欲界修所断诸结尽何果摄。答一来果或无处。一来果摄者。谓欲界修所断前六品诸结尽。或无处者。谓欲界修所断第七第八品诸结尽。已离欲染未离色染。色界修所断诸结尽何果摄。答无处。谓离初静虑一品乃至第四静虑八品染。彼修所断诸结尽非果摄。已离色染未离无色染。无色修所断诸结尽何果摄。答无处。谓离空无边处一品乃至非想非非想处八品染。彼修所断诸结尽非果摄

此中说有四沙门果。谓预流果一来果不还果阿罗汉果。问何故说此四沙门果。答为止他宗显己义故。谓或有说。四沙门果唯是无为如分别论者。问彼何故作是说。答依契经故。如契经说。佛告苾刍。吾当为汝说沙门性及沙门沙门果。云何沙门性。谓八支圣道。云何沙门谓成就此法者。云何沙门果。谓预流果乃至阿罗汉果。云何预流果谓永断三结。云何一来果谓永断三结薄贪嗔痴。云何不还果谓永断五顺下分结。云何阿罗汉果。谓永断贪嗔痴及一切烦恼。依此经故说沙门果唯是无为。为遮彼意显沙门果亦有为亦无为。若沙门果唯无为者便违契经。如契经说。有行四向有住四果。此中住者住有为果非无为果。以无为果不可住故。彼作是说。无为果中亦可说住故。施设论作如是说。彼住于断不求胜进。为得未得。为获未获。为触未触。为证未证。彼论非证。所以者何。彼论意说。住于道故。谓住断者非如乘象马住象马上。但于证断道不进不退说名为住。有余契经。唯说有为是沙门果。如说五根增上猛利迅速圆满。名俱解脱阿罗汉果。次减劣者名慧解脱阿罗汉果。次减劣者名不还果。次减劣者名一来果。最减劣者名预流果。此中。唯说信等五根胜劣差别名沙门果故。知沙门果。非但是无为。问若沙门果亦是有为。云何通彼所引契经。答四沙门果实通有为无为。而彼契经且说是无为者。所以者何。唯说果故。若法是沙门果非沙门性者彼经说之道。是沙门果亦是沙门性故彼不说。复次若法是婆罗门果非婆罗门性者彼经说之道。是婆罗门果亦是婆罗门性故彼不说。复次若法是梵行果非梵行性者彼经说之道。是梵行果亦是梵行性故彼不说。复次若法是果非有果者彼经说之道。是果亦是有果故彼不说。复次若法是离非有离者彼经说之道。是离亦是有离故彼不说。复次若法是所求非所厌者彼经说之道。是所求亦是所厌故彼不说。为止如是他宗所说欲显自宗故说四果。复次勿为止他显示己义。但为开发法相正理令他了知故说四果。问四沙门果自性是何。答品类足论作如是说。预流果有二种。谓有为及无为。云何有为预流果。谓证预流果者于诸学法已正当得。已得者谓过去。正得者谓现在。当得者谓未来。云何无为预流果。谓证预流果者。于诸结断已正当得。已得者谓过去。正得者谓现在。当得者谓未来。问道是有为堕在三世可说于彼已正当得。断是无为不堕三世云何说于彼已正当得耶。答品类足论应作是说。于诸结断得获触证不应说言已正当得。作是说者有别意趣。欲显彼断得及相续得者。谓彼断得在过去名已得。在现在名正得。在未来名当得。相续者谓证断相续。在过去名已得。在现在名正得。在未来名当得。又彼论说一来果有二种。谓有为及无为。云何有为一来果。谓证一来果者。于诸学法已正当得。余如前说。云何无为一来果。谓证一来果者。于诸结断已正当得余如前说。不还果有二种。谓有为及无为。云何有为不还果。谓证不还果者。于诸学法已正当得余如前说。云何无为不还果。谓证不还果者。于诸结断已正当得。余如前说。阿罗汉果有二种。谓有为及无为。云何有为阿罗汉果。谓证阿罗汉果者。于诸无学法已正当得。余如前说。云何无为阿罗汉果。谓证阿罗汉果者。于诸结断已正当得。余如前说。施设论中亦作是说。预流果有二种。谓有为及无为。云何有为预流果。谓此果得及此得得。此果得者。谓有为无为预流果得。此得得者。谓此果得之得由此果得故成就预流果。由此得得故成就此果得。若诸学根学力学戒学善根八学法。及此种类诸学法。是名有为预流果。云何无为预流果。谓三结永断。及此种类诸结法永断。八十八随眠永断。及此种类随眠法永断。是名无为预流果。一来果有二种。谓有为及无为。云何有为一来果。谓此果得及此得得。余如前说。若诸学根学力学戒学善根八学法。及此种类诸学法。是名有为一来果。云何无为一来果。谓三结永断。及此种类诸结法永断。八十八随眠永断。及此种类随眠法永断贪嗔痴倍断。及此种类烦恼法倍断。是名无为一来果。不还果有二种。谓有为及无为。云何有为不还果。谓此果得及此得得。余如前说。若诸学根学力学戒学善根八学法。及此种类诸学法。是名有为不还果。云何无为不还果。谓五顺下分结永断。及此种类诸结法永断。九十二随眠永断。及此种类随眠法永断。是名无为不还果。阿罗汉果有二种。谓有为及无为。云何有为阿罗汉果。谓此果得及此得得。余如前说。若诸无学根无学力无学戒无学善根十无学法。及此种类诸无学法。是名有为阿罗汉果。云何无为阿罗汉果。谓贪嗔痴永断。及一切烦恼永断。越一切趣断一切路。灭三种火渡四瀑流。摧诸傲慢离诸渴爱。破阿赖耶。无上究竟无上寂静无上安乐。及诸爱尽离灭涅槃。是名无为阿罗汉果。是谓四沙门果自性我物相分本性。已说自性。所以今当说。问何故名沙门果。沙门果是何义。答所有圣道是沙门性。有为无为及诸择灭。是此果故名沙门果。问若尔。此果不应唯四。谓见道中八忍品是沙门性。八智品是有为沙门果。八部法断是无为沙门果。离欲界染时九无间道是沙门性。九解脱道是有为沙门果。九品法断是无为沙门果。如是乃至离非想非非想处染时应知亦尔。如是便有八十九有为沙门果。八十九无为沙门果。若依此说。此沙门果有二百六十七。谓八十九在过去。八十九在现在。八十九在未来。品类足论作如是说。云何果法。谓一切有为法及择灭。随诸圣道尔所刹那。即有尔所有为沙门果。随有漏法有尔所量。择灭无为亦有尔所。随有尔所择灭无为。即有尔所无为沙门果。若以刹那在身分别。便有无量沙门果体。何故唯说四沙门果。有作是说。此是世尊为受化者所宜闻故有余略说。胁尊者曰。唯佛世尊能具正智诸法性相势用分齐。余不能知。若此堪立沙门果者即便立之。若不堪者便不建立。故不应难。尊者世友作如是说。此是世尊为开智者简要而说。故不应难。复次此四果位易见易施设。谓此是预流果乃至此是阿罗汉果。所余诸位难见难施设。故佛但说四沙门果。复次此四果位。诸瑜伽师于果发起增上庆悦。余位不尔。如务农者于六月中修治稼穑。后收子实积置场中生大庆悦。此亦如是。故佛唯说四沙门果。复次此四果位具三因缘。一舍曾得道。二得未曾得道。三证结断一味得。余位不尔。故佛唯说四沙门果。复次此四果位具五因缘。一舍曾得道。二得未曾得道。三证结断一味得。四顿得八智。五一时修十六行相。余位不尔。故佛唯说四沙门果。复次此四果位。是瑜伽师最胜安隐稣息之处。余位不尔故佛唯说四沙门果。复次此四果位所有圣道是功用。是功用究竟所有结断是所作。是所作究竟。余位圣道是功用非功用究竟。余位结断是所作非所作究竟。故佛唯说四沙门果。复次此四果位容修行者广修圣道。余位不尔。故佛唯说四沙门果。复次此四果位。诸瑜伽师能善了知功德过失。功德者谓道及道果。过失者谓生死因果。余位不尔。故佛唯说四沙门果。复次此四果位。诸瑜伽师方能善取四圣谛相。余位不尔。如人道。行于四方相未能善取。若坐一处方能善取。此亦如是。故佛唯说四沙门果。复次此四果位。若退失时有证知者。余位不尔。如村邑中若被劫夺有证知者非两中间。故佛唯说四沙门果。复次此四果位。诸瑜伽师先广加行安足坚固。余位不尔。预流果先广加行者。谓彼先求解脱果故。精勤修习惠施净戒。不净观持息念念住闻思修慧。及暖顶忍世第一法。并见道中十五心顷。即此总名安足坚固。有说。从初乃至世第一法名广加行。见道十五心名安足坚固。一来果先广加行者。谓即前说及离欲染诸加行道。六无间道五解脱道即此名为安足坚固。有说。预流果名安足坚固。不还果先广加行者。谓即前说及离欲染诸加行道。三无间道二解脱道。即此名为安足坚固。有说。一来果名安足坚固。阿罗汉果先广加行者。谓即前说及离初静虑一品染诸加行道。乃至金刚喻定。即此总名安足坚固。有说。不还果名安足坚固。故佛唯说四沙门果。复次此四果位。诸瑜伽师断绝止息一切生分。余位不尔。谓预流果除欲界七生及色无色界一一处一生。余一切生得非择灭。一来果除欲界二生及色无色界一一处一生。余一切生得非择灭。不还果除色无色界一一处一生。余一切生得非择灭。阿罗汉果于一切生。得非择灭。故佛唯说四沙门果。复次此四果位。诸瑜伽师总集三界见修所断烦恼断得。余位不尔。谓预流果位总集三界见所断烦恼断得。一来果位总集三界见所断。及欲界修所断前六品烦恼断得。不还果位总集三界见所断。及欲界修所断九品烦恼断得。阿罗汉果位总集三界见修所断一切烦恼断得。故佛唯说四沙门果。复次此四果位。是瑜伽师本所求处。余位不尔故佛唯说四沙门果。复次此四果位。诸瑜伽师说有退者若未还得必不命终。余位不尔。故佛唯说四沙门果。复次此四果位对治五趣得非择灭。余位不尔。谓预流果对治地狱傍生鬼趣得非择灭。一来果对治人趣一分得非择灭。不还果对治人趣全分得非择灭。阿罗汉果对治天趣得非择灭。故佛唯说四沙门果。复次此四果位对治四生得非择灭。余位不尔。谓预流果对治卵生湿生得非择灭。一来果对治胎生一分得非择灭。不还果对治胎生全分得非择灭。阿罗汉果对治化生得非择灭。故佛唯说四沙门果。复次此四果位对治二边。余位不尔。言二边者。谓欲界及有顶对治欲界边故得一来不还果。对治有顶边故得预流阿罗汉果。故佛唯说四沙门果。复次此四果位对治二有根本。余位不尔二有根本者。谓欲界及有顶。对治欲界有根本故得一来不还果。对治有顶有根本故得预流阿罗汉果。故佛唯说四沙门果。复次此四果位能永对治二种恶思。及彼异熟所依诸蕴。余位不尔。二种恶思者。谓断善根思及起无间业思。预流果能永对治断善根思。一来果能永对治起无间业思。不还果能永对治彼异熟果。阿罗汉果能永对治彼所依诸蕴。故佛唯说四沙门果。复次此四果位对治三法。余位不尔。谓预流果对治三结。一来果对治三不善根及欲漏一分。不还果对治三不善根及欲漏全分。阿罗汉果对治有漏无明漏。故佛唯说四沙门果。复次此四果位对治四法。余位不尔。谓预流果对治见瀑流轭见取戒禁取及后二身系。一来果对治欲瀑流轭取及初二身系一分。不还对治欲瀑流轭取及前二身系全分。阿罗汉果对治有无明瀑流轭及我语取。故佛唯说四沙门果。复次此四果位对治五法。余位不尔。谓预流果对治疑盖后三顺下分结及五见。一来果对治前四盖嗔嫉悭结。及前二顺下分结一分。不还果对治前四盖嗔嫉悭结。及前二顺下分结全分。阿罗汉果对治贪慢结。及五顺上分结。故佛唯说四沙门果。复次此四果位对治六爱身。余位不尔。谓预流果对治见所断意触所生爱身。一来果对治鼻舌触所生爱身一分。不还果对治鼻舌触所生爱身全分。阿罗汉果对治眼耳身触所生爱身。及修所断意触所生爱身。故佛唯说四沙门果。复次此四果位对治七随眠。余位不尔。谓预流果对治见疑随眠。一来果对治欲贪嗔恚随眠一分。不还果对治欲贪嗔恚随眠全分。阿罗汉果对治有贪慢无明随眠。故佛唯说四沙门果。复次此四果位对治九结。余位不尔。谓预流果对治见取疑结。一来果对治恚嫉悭结一分。不还果对治恚嫉悭结全分。阿罗汉果对治爱慢无明结。故佛唯说四沙门果。复次此四果位对治九十八随眠。余位不尔。谓预流果对治三界见所断随眠。一来果对治欲界修所断随眠一分。不还果对治欲界修所断随眠全分。阿罗汉果对治色无色界修所断随眠。故佛唯说四沙门果。复次此四果位各出一种重烦恼际。余位不尔。谓预流果出见所断重烦恼际。一来果出能等起五无间业重烦恼际。谓欲界前六品烦恼能等起五无间业。后三品不尔。势力劣故。不还果出诸不善重烦恼际。阿罗汉果出诸无记重烦恼际。故佛唯说四沙门果

问何故离欲界染立二沙门果。谓一来不还果。离色无色界染立一沙门果。谓阿罗汉果耶。胁尊者曰。唯佛世尊能具正知诸法性相势用分齐余不能知。若离此染堪立二果便即立二。若离此染堪立一果便即立一。故不应难。复次四沙门果无不皆因离三界染而得建立。谓离三界见所断染立预流果。若离三界见所断染。及离欲界修所断前六品染立一来果。若离三界见所断染。及离欲界修所断染立不还果。若离三界见修所断染立阿罗汉果。复次以欲界是不定界非修地非离染地。故离彼染立二沙门果。色无色界是定界是修地是离染地。故离彼染唯立一沙门果。复次以欲界难断难破难可越度。故离彼染立二沙门果。色无色界易断易破易可越度。故离彼染唯立一沙门果。复次以欲界过患增盛过患坚固过患众多故。离彼染立二沙门果。色无色界与此相违。故离彼染唯立一沙门果。复次以欲界烦恼犹如瀑流难可越度。故离彼染立二沙门果。如人渡河其水深广涛波漂急数数止息乃能渡之。如契经说。邑主当知。言瀑流者喻五妙欲。色无色界与此相违。故离彼染唯立一沙门果。复次以欲界是崄难界。烦恼增重作业增重。犹如重担难可越度。故离彼染立二沙门果。色无色界非崄难界。烦恼作业设有增重而易越度。故离彼染唯立一沙门果。如人担重登崄难山数数止息乃能越度。若至平地虽复担重而易远涉。此亦如是。复次以欲界是杂秽界。犹如淤泥杂诸粪秽难可出离。故离彼染立二沙门果。色无色界与此相违。故离彼染唯立一沙门果。如粪聚上造立宫室。虽复妙好人不乐住。色无色界亦复如是。为居欲界杂秽法上。虽复妙好贤圣不乐。是故尊者僧伽筏苏作如是说。此欲界中多诸过失。谓丧父母兄弟姊妹妻子眷属亡失财位。或被割截耳鼻手足及诸身分。或复遭于四百四病。由如是等种种因缘受诸剧苦。如是欲界多诸过失。若离彼染。总立一切四沙门果犹少况二。复次以欲界有男身女身难可越度。故离彼染立二沙门果。色无色界唯有男身易可越度。故离彼染唯立一沙门果。复次以欲界有男根女根难可越度。故离彼染立二沙门果。色无色界无男女根易可越度。故离彼染唯立一沙门果。复次以欲界有不善无记二种烦恼难可越度。故离彼染立二沙门果。色无色界唯有一种无记烦恼易可越度。故离彼染唯立一沙门果如不善无记二种烦恼。如是有异熟无异熟生二果生一果。无惭无愧相应不相应烦恼应知亦尔。复次以欲界有苦根忧根无惭无愧嫉悭段食。及淫欲爱五盖五欲诸恶趣等种种过患难可出离。故离彼染立二沙门果。色无色界与此相违故离彼染唯立一沙门果。复次欲界具有十八界十二处等多有漏法难可出离。故离彼染立二沙门果。色无色界有漏法少。故离彼染唯立一沙门果。问何故离见所断染立初一沙门果。离修所断染立后三沙门果耶。答见所断染易可远离。故离彼时立初一沙门果。修所断染难可远离。故离彼时立后三沙门果

说一切有部发智大毗婆沙论卷第六十五阿毗达磨大毗婆沙论卷第六十六

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中有情纳息第三之四

问前说圣道是沙门性有为无漏。及诸择灭是此果故名沙门果。无漏道力所证得者可立此名。世俗道力所证得者如一来不还果。云何名沙门果。答如无漏道离欲界染若倍若全立果分齐。如是圣者以世俗道离欲界染。若倍若全亦立一来及不还果。故二亦得沙门果名。尊者僧伽筏苏说曰。以世俗道离欲染时亦修未来。诸无漏道所得二果是彼果故。亦得建立沙门果名。彼不应作是说。所以者何。未来圣道未有作用。如何于彼此得果名。有余师说。以世俗道离欲染时无漏道得恒相续转。所得二果是彼果故。亦得建立沙门果名。彼不应作是说。所以者何。得无断结证断作用。如何于彼此得果名。复有说者。以世俗道得二果者。金刚喻定现在前时。总证三界见修所断一味断得。前所得断是此果故名沙门果。此定是真沙门性故。彼亦不应作如是说。所以者何。得二果时未得此定。若得此定失彼果名。如何彼二名沙门果。应作是说。从多立名多是圣道所得果故。谓世俗道得二果时。三界一切见所断断。皆是圣道力所得故名沙门果。虽有欲界六品九品修所断断非圣道得。然从多分亦得建立沙门果名一无漏得总所得故

问如是所说四沙门果几是假名。几是实义。答二是假名。谓一来不还果。二是实义。谓预流阿罗汉果。问何故一来不还果名假名果。预流阿罗汉果名实义果耶。答诸世俗道是假名道。中间二果少彼所得。以多从少名假名果。诸无漏道是实义道。初后二果全彼所得。故初后果名实义果。复次中间二果有漏无漏二道共得名假名果。假名即是共所得义。如共有者名假名物。初后二果唯是无漏道力所得名实义果。实义即是独所得义。如独有者名实义物。复次中间二果世俗圣道假设名言而证得故。名假名果。谓彼二道在未来时假作义言。既同一事誓一所作一应随喜。初后二果唯圣道得。非由二道假设名言而证得故。名实义果。有余师说。假名果者。谓初二果唯声闻乘所证得故。实义果者。谓后二果一切声闻独觉大觉皆证得故。多是实义少是假名。评曰。彼不应作是说。少多非表假实义故。此中前说于理为善。所以者何。沙门果者。是沙门性力所引得。唯无漏道是沙门性。成就彼者名真沙门。故彼所得二果名实义沙门果。诸世俗道非沙门性。成就彼者名假沙门。故彼所得二果名假名沙门果。问道是有为有下中上随因力生可名为果。断是无为无下中上非因所生云何名果。答断虽不生而是所得加行证故亦名为果。谓瑜伽师住高山顶或居静室。节量饮食减省睡眠及资身具。受持小七大七日法顶安定镇行鞠法杖。从今日没至明日出。发起殊胜勇猛精进。展转引生无漏圣道。由斯证得四沙门果。时示导者赞慰彼言。善哉善哉。汝能精进修正加行今得此果如务农者于六月中修治畦垄耘[禾*(而/而)]稼穑后收子实积置场中。旧务农者赞慰彼曰。善哉善哉。汝于六月多设劬劳今得此果。故道与断俱得果名。如是所说四沙门果。问几是静虑果。答四是静虑及眷属果。问几是无色果。答一。谓阿罗汉果。问几是根本静虑果。答二。谓不还果阿罗汉果。问几是静虑近分果。答四谓初静虑近分非余静虑。中间如根本说。问几是根本无色果。答一。谓阿罗汉果。问几是无色近分果。答无。问几是见道果。答三。谓除阿罗汉果。问几是修道果。答三。谓除预流果。问几是忍果。答三。谓除阿罗汉果。问几是智果。答三谓除预流果。问几是法智果。答三。谓除预流果。问几是类智果。答一。谓阿罗汉果问几是法智品果。答三。谓除预流果。问几是类智品果。答四。问几是世俗道果。答二。谓一来果及不还果。问几是无漏道果。答四

如契经说。摩揭陀主吠提呬子未生怨王。来诣佛所到已顶礼世尊双足退坐一面而白佛言。为有现见沙门果不。佛言亦有。王问云何。世尊告曰。我今问王。应随意答。若王给侍或诸僮仆不自在者。有时见王升高台殿设五伎乐与诸眷属欢娱嬉戏。彼既见已作是念言。我亦是人如何不尔。然王宿世多修福业。故于今生受斯胜报。我于今者应修胜业亦当如王众所钦羡。作是念已便舍家法。剃除须发被服袈裟。受持三归及清净戒。于十业道能断能修。王余使人于外见已。寻还启白具陈上事。请王追取如本驱策。王闻其言如所请不。王言不也。若有此人我应往见礼敬供养。如彼本时供事于我。我于今者而供事之尽其形寿。施与衣服饮食医药房舍卧具。及诸资缘令无匮乏。佛告王曰。如此之事岂非现见沙门果耶。王白佛言。诚如圣教。问诸沙门果实唯有四。何故此经复说第五。答真沙门果实唯有四。此说现见沙门果者。但是出家近士用果。问出家既非真沙门性。如何说有沙门果耶。答出家虽非真沙门性。而世假立沙门性名。故诸世间见出家者。便谓我见如是沙门。是故出家近士用果。亦得假立沙门果名。此现见名表非实义。师子吼经复作是说。唯我法内有四沙门。谓初沙门乃至第四。外道法内无真沙门及婆罗门。唯有空号。于如是事处大众中正师子吼都无所畏。应知此中初沙门者谓诸预流。第二沙门者谓诸一来。第三沙门者谓诸不还。第四沙门者谓诸阿罗汉。胁尊者曰。应知此中佛随胜者于先而说初沙门者谓诸阿罗汉。第二沙门者谓诸不还。第三沙门者谓诸一来。第四沙门者谓诸预流善贤经中复作是说。若此处有八支圣道当知是处有四沙门。谓初沙门乃至第四。此中有说。趣四果向名四沙门。初沙门者谓预流向。第二沙门者谓一来向。第三沙门者谓不还向。第四沙门者谓阿罗汉向。胁尊者曰。此契经中说四种向及说四果。若此处有八支圣道者即说四向。当知是处有四沙门者即说四果。准陀经中亦作是说。沙门有四无有第五。四沙门者。一胜道沙门。二示道沙门。三命道沙门。四污道沙门。应知此中胜道沙门者。谓佛世尊自能觉故。一切独觉应知亦然。示道沙门者。谓尊者舍利子。无等[雨/隻]故。大法将故。常能随佛转法轮故。一切无学声闻应知亦尔。命道沙门者。谓尊者阿难陀。虽居学位而同无学多闻闻持具净戒禁。一切有学应知亦然。污道沙门者。谓莫暍落迦苾刍喜盗他财物等是。问如上所引三种经中所说沙门有何差别。有作是说。师子吼经说沙门者谓住四果。善贤经中说沙门者谓行四向准陀经中说沙门者谓住四果及行诸向。有余师说。师子吼经说沙门者谓住四果。善贤经中说沙门者谓行四向及住四果。准陀经中说沙门者谓具足摄一切沙门。或有说者。师子吼经及善贤经说沙门者谓住四果准陀经中说沙门者。谓住果向一切沙门。复有说者。师子吼经及善贤经说沙门者谓学无学。准陀经中说沙门者。谓学无学及非学非无学。有作是言。师子吼经及善贤经说沙门者谓诸圣者。准陀经中说沙门者谓诸圣者及诸异生。复有说言。师子吼经及善贤经说沙门者谓持戒者。准陀经中说沙门者谓持戒者及犯戒者。或复有说。此三经中所说沙门义无差别。问前二经说有四沙门。污道沙门岂四所摄。答亦四所摄。谓预流向。然预流向有近有远。近谓见道。远谓此前顺决择分顺解脱分乃至正信而出家者。如契经说。有四种预流支。谓亲近善士。听闻正法。如理作意。法随法行支因。向名义无差别。问善贤经说。若此处有八支圣道当知是处有四沙门。污道沙门岂此所摄。答亦此所摄。以圣道支有实有假。实谓无漏正见等八。假谓有漏正见等八。污道沙门亦得成就有漏正见。故彼亦是初沙门摄。复有说者。前二经说四种沙门即是第三。契经所说胜道等四非预流等。故此三经所说无异。问初经所说当云何通。唯我法内有四沙门。佛于众中正师子吼。世尊岂说唯我法内。有毁犯戒而师子吼。答说亦无失。所以者何。污道沙门虽复破戒而不破见。虽破加行不破意乐。设有问言。汝犯戒恶为善为不善。彼言不善。为应作为不应作。彼言不应作。为有异熟为无异熟。彼言有异熟。为得可爱果为得不可爱果。彼言得不可爱果。为恶趣受为善趣受。彼言恶趣受。为自身受。为他身受。彼言自身受。为是师过为是教过为是自过。彼言非师过。亦非教过是我之过。彼有如是有漏正见。信有因果。不愚因果。如是正见。九十六种外道所无。故佛众中正师子吼。依彼而说亦无有过如契经说。佛告苾刍。我实知见有三种人。于诸有情多有所作其恩难报。假使尽形以诸上妙衣服饮食卧具医药。及余资缘而供养之。亦不能报。云何为三。一者有人为他说法。令舍家法趣于非家。剃除须发被服袈裟。以正信心受持净戒。二者有人为他说法。令知集法皆是灭法。远尘离垢于诸法中生净法眼。三者有人为他说法。令尽诸漏证得无漏心慧解脱。于现法中自能通达生已尽等具足而住。问劝他令受近事律仪。是人亦名多有所作其恩难报。此契经中何故不说。答应说而不说者。当知此义有余。复次出家律仪是因是果故经偏说。谓此是近事律仪果。苾刍律仪因故。复次劝出家者。即是劝人入于圣法故经偏说。谓入圣法略有二种。一者世俗。二者胜义。世俗者。谓舍离家法趣于非家。剃除须发被服袈裟。以正信心受持净戒。胜义者。谓从世第一法入苦法智忍。复次劝出家者即是劝人脱庸贱事故经偏说。谓在家者多为种种庸贱恶事之所逼切。诸出家人解脱此故。复次劝出家者。即是劝人解脱众苦故经偏说。谓出家者解脱现身诸苦恼事。由此展转解脱一切生老病死忧悲苦恼生死法故。复次劝出家者。即是劝人受现法乐。由此展转复得毕竟自在安乐故经偏说。复次劝出家者。即是劝人现佛出世故经偏说。现佛出世略有二种。一者世俗。二者胜义。世俗者。谓舍离家法趣于非家。剃除须发被服袈裟。以正信心受持净戒。胜义者。谓于四圣谛得真净觉。初出家时。已现世俗佛出于世。既出家已展转修行。复现胜义佛出于世。复次劝出家者。即是劝人学诸佛身故经偏说。谓诸佛身略有二种。一者生身。二者法身。若舍家法趣于非家。剃除须发被服袈裟。以正信心受持净戒。当知即是学佛生身。若能展转修习正行。于四圣谛起真净觉。当知即是学佛法身。复次劝出家者。即是劝人学诸佛行故经偏说。然诸佛行略有二种。一者世俗。二者胜义。世俗者。谓舍离家法趣于非家。剃除须发被服袈裟。以正信心受持净戒。胜义者。谓于四圣谛能正了知。初出家时已能随学世俗佛行。既出家已精进修行。复能随学胜义佛行。复次劝出家者。即是劝人入佛法海故经偏说。谓若有人弃舍家法净信出家。即名初入诸佛法海。若尽诸漏证般涅槃。名究竟入诸佛法海。复次劝出家者。即是劝人决定趣入真解脱路故经偏说。如契经说。诸出家者。于四圣谛定得如实智见现观。复次劝出家者。即是劝人决定当得三种律仪谓。别解脱律仪。静虑律仪。无漏律仪。故经偏说。复次劝出家者。即是劝人决定当得三种善蕴。谓戒蕴定蕴慧蕴。故经偏说。如三善蕴如是三学三修三净应知亦尔。复次劝出家者。即是劝人决定当得三种正道谓见道修道无学道故经偏说。如三正道三地亦尔。复次劝出家者。即是劝人决定当得三无漏根。谓未知当知根已知根具知根故经偏说。复次劝出家者。即是劝人如应当得三种菩提。谓声闻菩提独觉菩提无上菩提。故经偏说。复次劝出家者。即是劝人决定当得三种牟尼。谓身牟尼语牟尼意牟尼故经偏说。如三寂静三清净亦尔。复次劝出家者。即是劝人身心远离故经偏说。谓出家时身便少事。身少事故心亦少事。由斯远离烦恼恶业。复次劝出家者即是劝人身心离垢故经偏说。谓出家时身便清净。身清净故心亦清净。身心净故烦恼业垢速得除灭。复次劝出家者。即是劝人身心妙好故经偏说。谓出家时身便妙好。身妙好故心亦妙好。复次劝出家者。即是劝人身心端严故经偏说。谓出家时身便端严。身端严故心亦端严复次劝出家者。即是劝人决定当得究竟寂静即是涅槃故经偏说。复次劝出家者。即是劝人得不共法故经偏说。谓出家时威仪服饰所作事业。不与一切在家者共。复次劝出家者。即是劝人弃烦恼业故经偏说。谓出家时剃除须发被服袈裟受持净戒。烦恼恶业皆渐舍离。出家形饰非彼器故。如香洁人臭秽不住。复次劝出家者。即是劝人作无尽业得无尽财。作无罪业得无罪财。作无害业得无害财。作不共外道业得不共外道财。作不共异生业。得不共异生财。故经偏说。复次劝出家者。即是劝人一向修学螺画之行。谓尽寿修清白梵行。诸在家者不能如是。故经偏说。问螺画之行其义云何。尊者世友作是说。昔此洲内有二仙人。一名饷佉。二名履企。具足第一轨则梵行。诸在家者皆不能及。劝人出家即劝同彼。有作是说。如螺贝上雕画文像坚固难坏。风吹日曝及余外缘卒难毁灭。出家人行亦复如是。在家不能修如是行。虽暂受持而寻毁坏。有余师说。如螺贝上雕画文像清洁明了无诸垢秽。出家人行亦复如是。在家不能修如是行。虽极受持而犹杂秽。现见在家得不还果。虽离欲染而处居家。受畜生数非生数物。所作事业未甚清净。况有在家得初二果与异生类无有差别。出家之人虽破禁戒。犹胜在俗受持戒者。故经偏说。劝人出家其恩难报。复次劝出家者。即是劝人修尊贵业。所得果报胜琰魔王轮王帝释。故经偏说。劝人出家其恩难报。劝人受持近事戒等。无如是事故经不说。问何故此经唯说令得初后二果其恩难报。不说令得中间二果。答应说而不说者。当知此义有余。复次此中具摄四沙门果。所以者何。远尘离垢于诸法中生净法眼者说前三果。谓诸具缚及离欲界五品染已。入正性离生生净法眼得预流果。若离欲界六七品染已。入正性离生生净法眼得一来果。若离欲界乃至无所有处染已。入正性离生生净法眼得不还果。令尽诸漏及得无漏。心慧解脱者即是令得阿罗汉果。故此经中具摄四果。复次此经说得初后二果即具说得四沙门果。现始终故。始谓预流果。终者即是阿罗汉果。如现始终如是初入已度加行究竟应知亦尔。复次此经说得初后二果即已说得中间二果谓得预流果者决定无间得一来果。得阿罗汉果者决定次前得不还果故。复次初后二果定由无漏道力所得故偏说之。中间二果或是世俗道力所得故此不说。如有漏无漏道力所得。系缚解脱道力所得应知亦尔。复次初后二果俱超非想非非想处而得故偏说之。谓预流果超非想非非想处见所断得。阿罗汉果超非想非非想处修所断得。复次此经略现初入门故。由此但说初后二果。谓诸沙门果有因见道得。有因修道得。若说预流果应知总说见道得者。若说阿罗汉果应知总说修道得者。如见道修道得如是。见地修地未知当知根已知根得应知亦尔。复次诸沙门果有因见所断烦恼尽故立。有因修所断烦恼尽故立。若说预流果应知总说因见所断烦恼尽故立者。若说阿罗汉果应知总说因修所断烦恼尽故立者。如因见修所断烦恼尽故立。如是因无事有事烦恼尽故。忍所对治智所对治烦恼尽故立。应知亦尔。复次诸沙门果。有因对治见戏论故立。有因对治爱戏论故立。若说预流果应知总说因对治见戏论故立者。若说阿罗汉果应知总说因对治爱戏论故立者。如因对治二种戏论故立。如是因对治二边二箭二诤根故立应知亦尔。复次诸沙门果。或因顿断烦恼故得。或因渐断烦恼故得。若说预流果。应知总说因顿断烦恼故得者。谓及超越得一来不还果者。若说阿罗汉果。应知总说因渐断烦恼故得者。谓及次第得一来不还果者。由如是等种种因缘。此经但说令他证得初后二果其恩难报

诸预流者所成就学法。此法预流果摄耶。乃至广说。问何故作此论。答先唯说无为沙门果。今欲说有为无为沙门果故作斯论。此中所问先略后广。谓先问所成就学无学法。次问所成就无漏法。后问所成就一切法。诸预流者所成就学法。此法预流果摄耶。答或摄或不摄。义不定故。云何摄。答有为预流果已得不失。已得者。谓信胜解已得信胜解预流果摄种性诸根。见至已得见至预流果摄种性诸根。不失者。谓信胜解不转根作见至故。不失信胜解预流果。摄种性诸根或不退失。云何不摄。答诸预流者所得胜进无漏根等有为法。谓离欲界修所断前六品染。诸加行道六无间道五解脱道诸胜进道。如是学法预流者虽成就而非预流果所摄。以胜果道非果摄故。设法预流果摄此是学法耶。答或学或非学非无学。义不定故。云何学。答有为预流果。谓道类智等及彼眷属。云何非学非无学。答无为预流果。谓三界见所断法断。诸一来者所成就学法。此法一来果摄耶。答或摄或不摄。义不定故。云何摄。答有为一来果已得不失。已得者。谓信胜解已得信胜解一来果摄种性诸根。见至已得见至一来果摄种性诸根。不失者。谓信胜解不转根作见至故。不失信胜解一来果摄种性诸根。或不退失。云何不摄。答诸一来者所得胜进无漏根等有为法。谓离欲界修所断后三品染。诸加行道三无间道二解脱道。诸胜进道如是学法。一来者虽成就。而非一来果所摄。以胜果道非果摄故。设法一来果摄此是学法耶。答或学或非学非无学。义不定故。云何学。答有为一来果。谓道类智等。或离欲染第六解脱道等及彼眷属。云何非学非无学。答无为一来果。谓三界见所断法断。及欲界前六品修所断法断。诸不还者所成就学法。此法不还果摄耶。答或摄或不摄义不定故。云何摄。答有为不还果已得不失。已得者。谓信胜解已得信胜解不还果摄种性诸根。见至已得见至不还果摄种性诸根。不失者。谓信胜解不转根作见至故。不失信胜解不还果摄种性诸根。或不退失。云何不摄。答诸不还者所得胜进无漏根等有为法。谓离初静虑乃至非想非非想处染。诸加行道无间道。及有学解脱道胜进道。如是学法。不还者虽成就。而非不还果所摄。以胜果道非果摄故。设法不还果摄此是学法耶。答或学或非学非无学。义不定故。云何学。答有为不还果。谓道类智等或离欲染第九解脱道等及彼眷属云何非学非无学。答无为不还果。谓三界见所断法断。及欲界修所断法断。诸阿罗汉所成就无学法。此法阿罗汉果摄耶。答如是。谓阿罗汉所成就一切加行无间解脱胜进道皆是阿罗汉果摄。以彼无有胜果道故。无有胜果可趣求故。设法阿罗汉果摄。此是无学法耶。答或无学或非学非无学。义不定故。云何无学。答有为阿罗汉果。谓尽智无生智无学正见及彼眷属。云何非学非无学。答无为阿罗汉果。谓三界一切见修所断法断。诸预流者所成就无漏法。此法预流果摄耶。答或摄或不摄。义不定故。云何摄。答有为无为预流果已得不失。有为预流果者。谓道类智等及彼眷属。无为预流果者。谓三界见所断法断。已得者。谓信胜解已得信胜解预流果摄种。性诸根。见至已得见至预流果摄种。性诸根。及已得三界见所断法断。不失者谓信胜解不转根作见至故。不失信胜解预流果摄种。性诸根。或不退失。云何不摄。答诸预流者所得胜进无漏根等有为法。及彼所证诸结尽。并预流者所成就非择灭。诸预流者所得胜进无漏根等。有为法者。谓离欲界修所断前六品染。诸加行道六无间道五解脱道诸胜进道。如是无漏法。预流者虽成就。而非预流果所摄。以胜果道非果摄故。及彼所证诸结尽者。谓欲界前五品修所断法断。是胜果道所证断故。如胜果道。非此果摄。并预流者所成就非择灭者。谓预流者于三界及无漏法得非择灭。彼虽成就此非择灭。而此非择灭非预流果摄。所以者何。非择灭是无记。预流果是善故。设法预流果摄。此是无漏法耶。答如是。谓有为及无为预流果俱是无漏故。诸一来者所成就无漏法。此法一来果摄耶。答或摄或不摄。义不定故。云何摄。答有为无为一来果已得不失。有为一来果者。谓道类智等。或离欲染第六解脱道等及彼眷属。无为一来果者。谓三界见所断法断。及欲界前六品修所断法断。已得者。谓信胜解已得信胜解一来果摄种。性诸根。见至已得见至一来果摄种。性诸根。及已得三界见所断法断。并欲界前六品修所断法断。不失者。谓信胜解不转根作见至故。不失信胜解一来果摄种。性诸根。或不退失此及欲界前六品修所断法断。云何不摄。答诸一来者所得胜进无漏根等有为法。及彼所证诸结尽。并一来者所成就非择灭。诸一来者所得胜进无漏根等有为法者。谓离欲界修所断后三品染。诸加行道三无间道二解脱道诸胜进道。如是无漏法。一来者虽成就。而非一来果所摄。以胜果道非果摄故。及彼所证诸结尽者。谓欲界第七第八品修所断法断。是胜果道所证断故。如胜果道非此果摄。并一来者所成就非择灭者。谓一来者于三界及无漏法得非择灭。彼虽成就此非择灭。而此非择灭非一来果摄。所以者何。非择灭是无记。一来果是善故。设法一来果摄。此是无漏法耶。答如是。谓有为无为一来果。俱是无漏故

说一切有部发智大毗婆沙论卷第六十六阿毗达磨大毗婆沙论卷第六十七

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中有情纳息第三之五

诸不还者所成就无漏法。此法不还果摄耶。答或摄或不摄。义不定故。云何摄。答有为无为不还果已得不失。有为不还果者。谓道类智等。或离欲染第九解脱道等及彼眷属。无为不还果者。谓三界见所断法断。及欲界修所断法断。已得者。谓信胜解已得信胜解不还果摄种性诸根。见至已得见至不还果摄种性诸根。及已得三界见所断法断。并欲界修所断法断。不失者。谓信胜解不转根作见至故。不失信胜解不还果摄种性诸根。或不退失此及欲界修所断。法断。云何不摄。答诸不还者所得胜进无漏根等有为法。及彼所证诸结尽。并不还者所成就非择灭。诸不还者所得胜进无漏根等有为法者。谓离初静虑乃至非想非非想处染。诸加行道无间道。及有学解脱道胜进道。如是无漏法。不还者虽成就。而非不还果所摄。以胜果道非果摄故。及彼所证诸结尽者。谓初静虑乃至无所有处。各九品修所断法断。及非想非非想处前八品修所断法断。是胜果道所证断故。如胜果道非此果摄。并不还者所成就非择灭者。谓不还者于三界及无漏法得非择灭。彼虽成就此非择灭。而此非择灭非不还果摄。所以者何。非择灭是无记。不还果是善故。设法不还果摄。此是无漏法耶。答如是。谓有为无为不还果。俱是无漏故。诸阿罗汉所成就无漏法。此法阿罗汉果摄耶。答或摄或不摄。义不定故。云何摄。答有为无为阿罗汉果已得不失。有为阿罗汉果者。谓尽智无生智无学正见及彼眷属。无为阿罗汉果者。谓三界见修所断法断。已得者。谓时解脱已得时解脱阿罗汉果摄种性诸根。不时解脱已得不时解脱阿罗汉果摄种性诸根。及已得三界见修所断法断。不失者。谓时解脱不转根作不时解脱故。不失时解脱阿罗汉果摄种性诸根。或不退失此及三界修所断法断。云何不摄。答阿罗汉所成就非择灭。谓阿罗汉于三界及无漏法得非择灭。彼虽成就此非择灭。而此非择灭非阿罗汉果摄。所以者何。非择灭是无记。阿罗汉果是善故。设法阿罗汉果摄。此是无漏法耶。答如是。谓有为无为阿罗汉果俱是无漏故

诸法预流者成就。此法预流果摄耶。答应作四句。此成就果摄互有宽狭故。有法预流者成就非预流果摄。谓预流者所得胜进无漏根等有为法。及彼所证诸结尽。并预流者所成就非择灭有漏法。此中有四法。前三如前说。彼所成就有漏法者总有三种。谓善染污无覆无记。善复有二。谓加行善及生得善。染污谓三界修所断染法。无覆无记谓威仪路工巧处异熟生。如是诸法预流者成就非预流果摄。果唯无漏。此有漏故。有法预流果摄非预流者成就。谓预流果未得已失。未得者。谓信胜解未得见至预流果摄种性诸根。及见至不得信胜解预流果摄种性诸根。已失者。谓信胜解转根作见至故。失信胜解预流果摄种性诸根。或有退失。有法预流者成就亦预流果摄。谓预流果已得不失。应知此中义如前说。有法非预流者成就亦非预流果摄。谓除前相。此中相声即名所表。谓若法已称已说名所表者作前三句。此中除之若法未称未说名所表者作第四句。此复云何。谓善染污无覆无记。善有二种。谓有漏及无漏。有漏善者。谓预流者所不成就加行离染生得善。无漏善者。谓预流者所不成就下位上位一切圣道。及所未得上位择灭。染污者。谓三界见所断染法。及预流者已断欲界修所断染法。无覆无记者。谓预流者所不成就威仪路工巧处异熟生。及一切变化心等。如是诸法是第四句。诸法一来者成就此法一来果摄耶。答应作四句。此成就果摄互有宽狭故。有法一来者成就非一来果摄。谓一来者所得胜进无漏根等有为法。及彼所证诸结尽。并一来者所成就非择灭有漏法。此中有四法。前三如前说。彼所成就有漏法者总有三种。谓善染污无覆无记。善复有二。谓加行善及生得善。染污谓欲界后三品修所断染法。及色无色界修所断染法。无覆无记谓威仪路工巧处异熟生。如是诸法。一来者成就。非一来果摄。果唯无漏。此有漏故。有法一来果摄非一来者成就。谓一来果未得已失。未得者。谓信胜解未得见至一来果摄种性诸根。及见至不得信胜解一来果摄种性诸根。已失者。谓信胜解转根作见至故。失信胜解一来果摄种性诸根。或有退失。有法一来者成就亦一来果摄。谓一来果已得不失。应知此中义如前说。有法非一来者成就亦非一来果摄。谓除前相。此中相声即名所表。谓若法已称已说名所表者作前三句。此中除之。若法未称未说名所表者作第四句。此复云何。谓善染污无覆无记。善有二种。谓有漏及无漏。有漏善者。谓一来者所不成就加行离染生得善。无漏善者。谓一来者所不成就下位上位一切圣道。及所未得上位择灭。染污者。谓三界见所断染法。及一来者已断欲界修所断染法。无覆无记者。谓一来者所不成就威仪路工巧处异熟生。及一切变化心等。如是诸法是第四句。诸法不还者成就。此法不还果摄耶。答应作四句。此成就果摄互有宽狭故。有法不还者成就非不还果摄。谓不还者所得胜进无漏根等有为法。及彼所证诸结尽。并不还者所成就非择灭有漏法。此中有四法。前三如前说。彼所成就有漏法者总有三种。谓善染污无覆无记。善复有三。谓加行离染生得善。染污。谓色无色界修所断染法。无覆无记。谓威仪路工巧处异熟生及变化心等。如是诸法。不还者成就。非不还果摄。果唯无漏。此有漏故。有法不还果摄。非不还者成就。谓不还果未得已失。未得者。谓信胜解未得见至不还果摄种性诸根。及见至不得信胜解不还果摄种性诸根。已失者。谓信胜解转根作见至故。失信胜解不还果摄种性诸根。或有退失。有法不还者成就亦不还果摄。谓不还果已得不失。应知此中义如前说。有法非不还者成就亦非不还果摄。谓除前相。此中相声即名所表。谓若法已称已说名所表者作前三句。此中除之。若法未称未说名所表者作第四句。此复云何。谓善染污无覆无记。善有二种。谓有漏及无漏。有漏善者。谓不还果所不成就加行离染生得善。无漏善者。谓不还者所不成就下位上位一切圣道。及所未得上位择灭。染污者。谓三界见所断染法。及欲界修所断染法。无覆无记者。谓不还者所不成就威仪路工巧处异熟生及变化心等。如是诸法是第四句。诸法阿罗汉成就。此法阿罗汉果摄耶。答应作四句。此成就果摄互有宽狭故。有法阿罗汉成就非阿罗汉果摄。谓阿罗汉所成就非择灭有漏法。彼所成就非择灭者。如前广说。彼所成就有漏法者总有二种。谓善及无覆无记。善有三种。谓加行离染生得善。无覆无记。谓威仪路工巧处异熟生及变化心等。如是诸法。阿罗汉成就。非阿罗汉果摄。果唯无漏。此有漏故。有法阿罗汉果摄非阿罗汉成就。谓阿罗汉果未得已失。未得者。谓时解脱未得不时解脱阿罗汉果摄种性诸根。及不时解脱不得时解脱阿罗汉果摄种性诸根。已失者。谓时解脱转根作不时解脱故。失时解脱阿罗汉果摄种性诸根。或有退失。有法阿罗汉成就亦阿罗汉果摄。谓阿罗汉果已得不失。应知此中义如前说。有法非阿罗汉成就亦非阿罗汉果摄。谓除前相。此中相声即名所表。谓若法已称已说名所表者作前三句。此中除之。若法未称未说名所表者作第四句。此复云何。谓善染污无覆无记。善有二种。谓有漏及无漏。有漏善者。谓阿罗汉所不成就加行离染生得善。无漏善者。谓诸学法。染污者。谓三界见修所断染法。无覆无记者。谓阿罗汉所不成就威仪路工巧处异熟生及变化心等。如是诸法是第四句

问信胜解为转根作见至不。设尔何失。二俱有过。所以者何。若信胜解转根作见至者。后根蕴中何故不说。如彼说若舍无漏根。得无漏根彼皆从果至果耶。答若从果至果。彼皆舍无漏根得无漏根。有舍无漏根得无漏根非从果至果谓现观边道类智现在前时。及时解脱阿罗汉练根作不动时。此本论师有何劳倦而不说。信胜解练根作见至时。若信胜解不转根作见至者。此中所说当云何通。如此说。有法预流果摄非预流者成就。谓预流果未得已失。若信胜解不转根作见至者。如何预流果有得已而失耶。后智蕴说复云何通。如彼说。预流者于三三摩地未来皆成就过去。若已灭不失即成就现在。若现在前即成就。若信胜解不转根作见至者。如何预流者有三摩地已灭而失。为简彼故说有已灭而不失耶。识身论说复云何通。如彼说有过去无学心是已了非今了非当了。谓时解脱阿罗汉退阿罗汉果作信胜解。彼练根作见至已还得阿罗汉果。彼时解脱道所摄无学心。是已成就非今成就非当成就。彼于成就施设了声。是已了者是已成就非今了者非今成就。非当了者非当成就。若信胜解不转根作见至者。如何彼说时解脱阿罗汉退阿罗汉果作信胜解。练根作见至已还得阿罗汉果耶。答应作是说。有信胜解转根作见至

问若尔。善通后所设难。后根蕴中何故不说。答后根蕴中应作是说。有舍无漏根得无漏根非从果至果谓现观边道类智现在前时。信胜解练根作见至时。退法等练根作思法等时。及时解脱练根作不动时。而不作是说者。有别意趣。谓彼举始举终。影显中故说。现观边道类智现在前时者。即是举始说时解脱练根作不动时者。即是举终。由举始终。影显中间。有信胜解练根作见至时。若学位中无练根义至无学位亦应如是。如学位中无救护无势力。无学位中亦应尔。故亦显有退法等转根作思法等。如举始终如是。举初入已度加行究竟应知亦尔。尊者僧伽筏苏说曰。信胜解练根作见至。即摄在根蕴所说中。即是从果至果摄故。谓预流者修习练根加行道已趣一来果。若得一来果即名转根。得果与转根时。无差别。若一来者修习练根加行道已趣不还果。若得不还果即名转根。得果与转根时无差别。问何故无有得预流果阿罗汉果即名练根。彼作是答。出过欲界是无始来数数旧法。无一有情于欲界染未曾离故。由此得有求转根者倍离全离欲界染故。得二果时亦即转根。出过有顶。非无始来数数旧法。无一有情于有顶染曾已离故。由此无有求转根者分离全离有顶染故。得二果时亦即转根。问如汝所说学位练根进得二果。即是从果至果摄故不别说者。无学位中有六种性转退法作思法。乃至转安住作堪达时。后根蕴中何故不说。但说时解脱练根作不动耶。彼作是答。此亦摄在根蕴说中。所以者何。转退法作思法时不舍退法根而得思法根。乃至转安住作堪达时不舍前四根而得堪达根。若转堪达作不动时顿舍前五根得不动根故。彼但说时解脱练根作不动时。舍无漏根得无漏根非从果至果。不说转退法等作思法等。评曰。彼不应作是说。所以者何。尚无有一成就二根。况有成就五品根者。又不还者修习练根加行道已虽不能得阿罗汉果。何故不能转作见至。诸异生辈虽不得果而有转根。何缘圣者离得果时无转根义。离染转根加行各别。如何离染得二果时亦即转根。故后根蕴举始举终影显中故。不说信胜解练根作见至。亦不说退法等练根作思法等。有余师说。无信胜解转根作见至

问若尔善通根蕴所说。此中所说当云何通。如此说有预流果未得已失。若信胜解不转根作见至者。如何预流果有得已而失耶。彼于此中有作是说。不成就过去未来得。有作是说。有成就过去未来得。若作是说。不成就过去未来得者。彼说预流果得在未来名未得。在过去名已失。在现在名成就。若作是说。有成就过去未来得者。彼说预流果有三种。谓下中上。若初住下预流果时于中上预流果名未得。于下品预流果名成就。不应说已失无所已失故。若初住中预流果时于上预流果名未得。于下预流果名已失。于中预流果名成就。若初住上预流果时于中下预流果名已失。于上预流果名成就。不应说未得无所未得故。问若初住中预流果者于下未得。若初住上预流果者于中下俱未得。如何说已失耶。彼作是答。超过彼故说名已失。谓彼先时有可得义今至胜位已超过彼更不可得故名已失。由斯理趣虽信胜解无有转根作见至者。而得说预流果有未得已失义。后智蕴说复云何通。如彼说预流者于三三摩地未来皆成就过去。若已灭不失即成就现在。若现在前即成就。若信胜解不转根作见至者。如何预流者有三三摩地已灭而失。为简彼故说有已灭而不失耶。彼作是答。后智蕴中应作是说。预流者于三三摩地未来皆成就过去已灭即成就。不应说不失而说不失者是诵者错谬。识身论说复云何通。如彼说时解脱阿罗汉退阿罗汉果作信胜解。练根作见至已还得阿罗汉果彼作是答。我不能通识身论文极明了故。评曰既不能通识身论说。又前损减智蕴论文。虽通此文亦不应理。故应信受有信胜解能转根作见至。若有学位不能转根。无学位中亦应不转如有学位。无救护无势力。无学位中亦应尔。故尊者佛护作如是说。信胜解转根作见至有六事不共。一者在欲界不在色无色界。二者依静虑不依无色定。三者用无漏道不用世俗道。四者用法智不用类智。五者是已退非未退。六者住果非住胜果道。问彼何故在欲界非在色无色界耶。彼作是答。由说法力方能转根。唯欲界中有说者故。问彼何故依静虑不依无色定耶。彼作是答。学位练根要依得果地。无依无色定得学果者。故学转根不依无色。问彼何故用无漏道不用世俗道耶。彼作是答。要猛利道方能转根。世俗道钝故彼不用。问彼何故唯用法智不用类智。彼作是答。要生欲界方能转根。欲界唯得法智自在。故彼不用类智转根。问彼何故是已退者。非未退者。彼作是答。厌患退者方求练根。要曾退已而有厌患。故未退者无转根义。问彼何故住果非住胜果道。彼作是答。若住胜果道而练根者。应练根时舍多道得少道。彼应名退不名为进。故唯住果有转根义。以练根时唯得果故

阿毗达磨诸论师言。学转根时于彼六事。三事应理三事不可。谓彼所说学位转根在欲界非在色无色界者此事应理。唯欲界有转根义故。又彼所说彼依静虑不依无色定者此亦应理。唯依静虑得学果故。又彼所说彼用无漏道不用世俗道者此亦应理。学位练根如见道故。然彼所言彼用法智不用类智者此事不可。所以者何。义不定故。谓生欲界或有于法智得自在非类智。或有于类智得自在非法智故。又彼所言是已退者非未退者。此亦不可。所以者何。义不定故。谓或已退或复未退然怖畏退或求胜根而练根故。又彼所言彼住果非住胜果道者此亦不可。所以者何。义不定故。谓学练根或住果位或住胜果道求利根故或畏退故。问若住胜果道而转根者舍多道得少道岂非退耶。答彼求利根不求多道故无有失。如多铜铁贸少金银岂名失利

问于欲界内何处转根。为但人中为亦天上。答唯在人中受教胜故。又畏退故。问人四洲内何处转根。尊者窭沙筏摩说曰。唯赡部洲有转根义。赡部洲人根猛利故。评曰应作是说。人三洲内皆得转根。除北俱卢无胜德故。问为依男身有转根义为亦依女。有作是说。唯依男身有转根义。男身功德胜女人故。评曰应作是说。诸转根者亦依男身亦依女身。以依女身亦能发起胜功德故。问随依何地先得学果后即依彼而转根耶。有说即依彼学者转根。亦有依余地然胜非劣。谓初二果依未至定得果转根不依余地。若不还果依彼地得即依彼地而后转根。或依余地然胜非劣。诸不还者极少成就三地果。极多成就六地果。谓次第者离欲界染第九解脱道时。彼成就三地不还果。即未至定初静虑及静虑中间。若已离欲染即依此三地入正性离生者。彼道类智时亦即成就此三地不还果。若依第二静虑入正性离生者。彼道类智时成就四地不还果。谓前三地及第二静虑。若依第三静虑入正性离生者。彼道类智时成就五地不还果。谓前四地及第三静虑。若依第四静虑入正性离生者。彼道类智时成就六地不还果。谓前五地及第四静虑。依初三地得不还果已。即依此三地而转根者。彼舍三地不还果。得三地不还果。即彼若依第二静虑而转根者。彼舍三地不还果得四地不还果。即彼若依第三静虑而转根者。彼舍三地不还果。得五地不还果。即彼若依第四静虑而转根者。彼舍三地不还果。得六地不还果。若依第二静虑得不还果已即依第二静虑而转根者。彼舍四地不还果得四地不还果。即彼若依第三静虑而转根者。彼舍四地不还果。得五地不还果。即彼若依第四静虑而转根者。彼舍四地不还果。得六地不还果。若依第三静虑得不还果已。即依第三静虑而转根者。彼舍五地不还果。得五地不还果。即彼若依第四静虑而转根者。彼舍五地不还果。得六地不还果。若依第四静虑得不还果已。即依第四静虑而转根者。彼舍六地不还果。得六地不还果。无依上地得不还果后依下地而转根者。所以者何。勿舍多道得少道故。应名损减不名增益。或有说者。有依上地得不还果后依下地而转根者。彼作是说。依第四静虑得不还果已若依第三静虑而转根者。彼舍六地不还果。得五地不还果。即彼若依第二静虑而转根者。彼舍六地不还果。得四地不还果。即彼若依初静虑等三地而转根者。彼舍六地不还果。得三地不还果。依第三静虑得不还果已。若依第二静虑而转根者。彼舍五地不还果。得四地不还果。即彼若依初静虑等三地而转根者。彼舍五地不还果。得三地不还果。依第二静虑得不还果已。若依初静虑等三地而转根者。彼舍四地不还果。得三地不还果。此中但说与前异者。依自上地而转根者舍得多少如前应知。问若依上地得不还果后依下地而转根者。既舍多道得少道故。应名损减岂是增益。答彼求利根不求多道舍多得少亦无有过。如多贱货贸少贵珍。乃名增益不名损减。依果说已若依道说诸不还者。未离初静虑染若依初静虑等三地而转根者。彼舍三地圣道。得三地圣道。已离初静虑染未离第二静虑染。若依初静虑等三地而转根者。彼舍四地圣道。得三地圣道。已离第二静虑染未离第三静虑染。若依初静虑等三地而转根者。彼舍五地圣道得三地圣道。已离第三静虑染未离第四静虑染。若依初静虑等三地而转根者。彼舍六地圣道得三地圣道。已离第四静虑染未离空无边处染。若依初静虑等三地而转根者。彼舍七地圣道。得三地圣道。已离空无边处染未离识无边处染。若依初静虑等三地而转根者。彼舍八地圣道得三地圣道。已离识无边处染。若依初静虑等三地而转根者。彼舍九地圣道。得三地圣道。未离第二静虑染。若依第二静虑而转根者。彼舍四地圣道得四地圣道。已离第二静虑染未离第三静虑染。若依第二静虑而转根者彼舍五地圣道得四地圣道。乃至已离识无边处染。若依第二静虑而转根者。彼舍九地圣道得四地圣道。未离第三静虑染。若依第三静虑而转根者。彼舍五地圣道得五地圣道。已离第三静虑染未离第四静虑染。若依第三静虑而转根者。彼舍六地圣道得五地圣道。乃至已离识无边处染。若依第三静虑而转根者。彼舍九地圣道得五地圣道。未离第四静虑染。若依第四静虑而转根者。彼舍六地圣道得六地圣道。已离第四静虑染未离空无边处染。若依第四静虑而转根者。彼舍七地圣道得六地圣道。乃至已离识无边处染。若依第四静虑而转根者。彼舍九地圣道得六地圣道。已离初静虑等染。若依第二静虑等而转根者。舍得多少如理应思。无依无色而转根者。学果不依无色定故。应作是说。若于上地已得自在而依下地学转根等。亦得上地无漏果道。然转根时不得无色彼定无有不还果故。此中应作颇设问答。颇有圣者舍九地圣道得六地圣道而名为进不名退耶。答有谓已离识无边处染。信胜解依第四静虑而转根时。颇有圣者已离无所有处染而但成就一地圣道耶。答有。谓已离无所有处染。依未至定入正性离生。彼见道中十五心顷。颇有不还者已离无所有处染。唯成就三地无漏果道耶。答有。谓已离无所有处染。信胜解于上地不得自在。依未至定或初静虑或静虑中间转根作见至时。颇有身证者不成就无漏无色定耶。答有。谓身证信胜解转根作见至时

说一切有部发智大毗婆沙论卷第六十七阿毗达磨大毗婆沙论卷第六十八

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中有情纳息第三之六

问已离无所有处染信胜解转根作见至时。既舍三无色无漏对治道于三地断为亦舍不。设尔何失。二俱有过。所以者何。若舍彼断云何不成就彼三地烦恼。若不舍者云何舍彼道而不舍断耶。答应作是说。不舍彼断。问既舍彼道如何不舍三地断耶。答下三无色地有二对治道。一者世俗。二者无漏。学转根时虽舍彼无漏而不舍世俗。由世俗得持彼断故。学转根时不失彼断。问若世俗道有作用处学转根时可不舍断。若世俗道无作用处学转根时宁不舍断。如离非想非非想处一品乃至八品染。已信胜解转根作见至时。彼非想非非想处修所断法断为舍为不舍。若舍彼断云何不成就彼地烦恼。若不舍者云何舍彼对治而不舍断。有作是说。必无分离非想非非想处染而转根者。彼若转根或全离染或复全退。复有说者。亦有分离非想非非想处染而转根者。虽舍彼道而不舍断。评曰应作是说。彼虽舍道亦舍彼断而不成就彼地烦恼。如诸异生已离无所有处染命终生非想非非想处。彼于欲界乃至识无边处若道若断。虽皆舍之而不成就彼地烦恼。此亦如是故不应难。问下地烦恼不依上身可舍道断。而不成就下地烦恼。上地烦恼亦依下身学转根时既舍道断。云何不成就已所断烦恼。答分离非想非非想处一品乃至八品染已。而转根者离彼染后起如见道无间解脱持彼相续不令复退。如异生位已离无所有处染入正性离生。得不还果已必不退起先所断结。此亦如是故不应难

问信胜解转根作见至时。用几加行道几无间道几解脱道而转根耶。有作是说。彼用一加行道九无间道九解脱道而转根。评曰彼不应作是说。学无漏根非久修习易可转故。应作是说。彼但用一加行道一无间道一解脱道而转根如见道故。问时解脱阿罗汉转根作不动时。用几加行道几无间道几解脱道而转根耶。有作是说。彼用一加行道一无间道一解脱道而转根。评曰彼不应作是说。以无学根是久修习难可舍故。又舍重果更得重果多用功故。如人坏舍复造舍时。多用功力非如创造。应作是说。彼用一加行道九无间道九解脱道而转根如修道故

问信胜解转根作见至时。加行道等为有漏为无漏耶。答彼加行道或有漏或无漏。未来所修通有漏及无漏。彼无间道一向无漏。未来所修亦唯无漏彼解脱道一向无漏。未来所修有作是说。亦唯无漏。复有说者。尔时通修有漏无漏。问时解脱阿罗汉转根作不动时。加行道等为有漏为无漏耶。答彼加行道或有漏或无漏。未来所修通有漏及无漏。九无间道八解脱道一向无漏。未来所修亦唯无漏。第九解脱道一向无漏。未来所修通有漏及无漏。彼于尔时随其所应兼修三界诸善根故

问信胜解转根作见至时。加行道等为是曾得为未曾得耶。答彼加行道或是曾得或未曾得。无间解脱道俱唯未曾得。问时解脱阿罗汉转根作不动时。加行道等为是曾得为未曾得耶。答彼加行道或是曾得或未曾得。九无间道九解脱道唯未曾得

信胜解转根作见至时。加行无间道是信胜解道摄。解脱道是见至道摄。时解脱阿罗汉转根作不动时。加行道九无间道八解脱道是时解脱道摄。第九解脱道是不时解脱道摄。信胜解转根作见至时。若住果而转根者。彼加行无间解脱道皆是果道摄。若住胜果道而转根者。彼加行无间道是胜果道摄。解脱道是果道摄。时解脱阿罗汉转根作不动时。彼加行无间解脱道皆是果道摄。彼无胜果道故。信胜解转根作见至时。若住果而转根者。彼舍果道得果道。若住胜果道而转根者。彼舍果道及胜果道唯得果道。时解脱阿罗汉转根作不动时。唯舍果道得果道。无学位无胜果道故。阿罗汉有六种。谓退法思法护法安住法堪达法不动法。退法阿罗汉转根作思法时。彼舍退法根得思法根。思法阿罗汉转根作护法时。彼舍思法根得护法根。护法阿罗汉转根作安住法时。彼舍护法根得安住法根。安住法阿罗汉转根作堪达法时。彼舍安住法根得堪达法根。堪达法阿罗汉转根作不动法时。彼舍堪达法根得不动法根。如是五位一一皆用一加行道九无间道九解脱道而得转根。彼加行道九无间道八解脱道起时有得无舍。第九解脱道起时有得有舍。谓舍退法等根得思法等根。前四位加行无间解脱道。及第五位加行无间八解脱道。皆是时解脱道摄。第九解脱道是不时解脱道摄。如无学道有六种性。修道亦有此六种性。谓学退法种性乃至学不动法种性。问信胜解转根作见至时。若住退法种性者。为转退法种性根即得不动法种性根。为转退法种性根但得思法种性根。渐次胜进最后方得不动法种性根。乃至若住安住法种性者。为转安住法种性根即得不动法种性根。为转安住法种性根但得堪达法种性根。复转堪达法种性根方得不动法种性根耶。有作是说。若住退法种性者。转退法种性根即得不动法种性根。不由渐次胜进方得。乃至若住安住法种性者。转安住法种性根即得不动法种性根。不由渐次胜进方得。所以者何。学位转根异无学位。谓无学位难舍难得要多功用渐次乃成。学位不尔故顿转得。评曰彼不应作是说。舍得难易但由无间解脱多少。不由渐顿而有差别。应作是说。若住退法种性者。转退法种性根但得思法种性根。渐次胜进方至不动。乃至若住安住法种性者。转安住法种性根但得堪达法种性根。复转堪达法种性根方得不动法种性根如是五位一一皆用一加行道一无间道一解脱道而得转根。彼加行无间道起时有得无舍。解脱道起时有得有舍。谓舍退法等种性根得思法等种性根。前四位加行无间解脱道。及第五位加行无间道皆是信胜解道摄。第五位解脱道是见至道摄。如修道位有六种性。见道位亦有此六种性。谓学退法种性乃至学不动法种性。然见道位无转根者。所以者何。见道速疾不起意乐一起相续要至修道方有更起余加行故。如见道位有六种性。相应行地亦有此六种性。谓相应行退法种性。乃至相应行不动法种性。此地中有六种性者。谓暖顶忍世第一法。此是圣道近加行故。缘谛行相似圣道故。依身及定同见道故。前位不尔故不立六种性。此相应行地亦有转根义。谓转退法暖种性根起思法暖种性根。转思法暖种性根起护法暖种性根转护法暖种性根起安住法暖种性根。转安住法暖种性根起堪达法暖种性根。转堪达法暖种性根起不动法暖种性根。转声闻暖种性根起独觉暖种性根。转声闻独觉暖种性根起佛暖种性根。如说暖位顶位亦尔。忍位有异。谓转退法忍种性根起思法忍种性根。渐次乃至转堪达法忍种性根起不动法忍种性根。转声闻忍种性根。起独觉忍种性根。无转声闻独觉忍种性根起佛忍种性根义。所以者何。忍违恶趣诸得忍性者于诸恶趣得非择灭。菩萨有时乘大愿力生诸恶趣饶益有情故。二乘忍位无趣佛乘理。有余师说。声闻暖顶位有转趣独觉及佛义。独觉暖顶位无转趣佛义。所以者何。如佛无师自然觉悟独觉亦尔。如佛期心一结跏坐引发一切善功德聚。从不净观乃至发起尽无生智中间相续不起异心独觉亦尔。评曰彼不应作是说。麟角喻独觉暖顶位中可无趣佛义。部行喻者暖顶位中转趣佛乘不违理故。由此前说于理为善。问相应行地诸转根者。为有无间解脱道不。有说亦有。谓转退法等种性起思法等种性时。一一别有一加行道九无间道九解脱道。以久修习有漏种性难舍得故。如无学位转无漏根。有余师说。一一但有一加行道一无间道一解脱道修习暖等。非久远故易舍易得。如有学位转无漏根。复有说者。相应地中诸转根者。但起加行数数修习厌劣欣胜。乃至转得胜位种性。无无间道及解脱道。以得胜时不舍劣故非如圣位。诸转根者无成就二品无漏种性故。得胜品时必舍劣品故。须无间及解脱道。评曰相应地中诸转根者。虽不舍劣得胜品根而得胜时劣品种性不现行故亦名为舍。故转退法种性等起思法种性等时。用多加行引一无间一解脱道而得转根亦不违理。修习暖等非久远故有漏加行难成办故。若转趣余乘无无间解脱时经久远乃成办故。世第一法位虽有六种性然不转根一刹那故。前预流果位亦有六种性。既有转根亦有退者。故有于彼作问答言。颇有退预流果而不成就见所断结耶。答有。谓退胜种性时。诸在欲界死生者皆受欲有耶。乃至广说。问何故作此论。为止他宗显正理故。谓或有说三界死生皆无中有。为止彼宗显欲色界定有中有无色界无。或复有说。无色界中亦有色故亦有中有如欲色界。为止彼宗显无色界无诸色故亦无中有。或复有执。欲色界中业猛利者即无中有。业迟钝者即有中有。为止彼宗显欲色界皆有中有故作斯论。所说有声显多种义。一行纳息已广说之。此中有声显属众同分有情数五蕴。诸在欲界死生者皆受欲有耶。答应作四句。在欲界死生与受欲有互有宽狭故。有在欲界死生非受欲有。谓欲界没起色界中有。此通异生及诸圣者。色界中有在欲界起。所以者何。法应如是。若于是处死有蕴灭。即于此处中有蕴生。如种灭处即有芽生法应尔故。此中在欲界死者。谓欲界死有在欲界灭故。在欲界生者。谓色界中有在欲界起故。非受欲有者。谓受色有即受色界中有诸蕴。有受欲有非在欲界死生。谓色界殁起欲界中有。此唯异生。欲界中有在色界起。所以者何。法应如是。广说如前。此中受欲有者。谓受欲界中有诸蕴。非在欲界死者。谓色界死有在色界灭故。非在欲界生者。谓欲界中有在色界起故。有在欲界死生亦受欲有。谓欲界殁起欲界中有生有。此通异生及诸圣者。异生于五趣皆得受生。圣者唯于人天有受生义。此中若从死有趣中有时在欲界死者。谓欲界死有在欲界灭故。在欲界生者。谓欲界中有在欲界起故。受欲有者。谓受欲界中有诸蕴。若从中有趣生有时。在欲界死者。谓欲界中有在欲界灭故。在欲界生者。谓欲界生有在欲界起故。受欲有者。谓受欲界生有诸蕴。有非在欲界死生亦非受欲有。谓色界殁生色无色界。无色界殁生无色色界。色界殁生色界者。谓生中有及生生有。此通异生及诸圣者。此中若从死有趣中有时非在欲界死者。谓色界死有在色界灭故。非在欲界生者。谓色界中有在色界起故。非受欲有者。谓受色有即受色界中有诸蕴。若从中有趣生有时非在欲界死者。谓色界中有在色界灭故。非在欲界生者。谓色界生有在色界起故。非受欲有者。谓受色有即受色界生有诸蕴。色界殁生无色界者。谓生生有以无色界无中有故。此通异生及诸圣者。此中非在欲界死者。谓色界死有在色界灭故。非在欲界生者。谓无色界生有在无色界起故。非受欲有者。谓受无色有即受无色界生有诸蕴。无色界殁生无色界者。谓生生有。此通异生及诸圣者。此中非在欲界死者。谓无色界死有在无色界灭故。非在欲界生者。谓无色界生有在无色界起故。非受欲有者。谓受无色有即受无色界生有诸蕴。无色界殁生色界者。谓生中有此唯异生。此中非在欲界死者。谓无色界死有在无色界灭故。非在欲界生者。谓色界中有在色界起故非受欲有者。谓受色有即受色界中有诸蕴。诸在色界死生者皆受色有耶。答应作四句。在色界死生与受色有互有宽狭故。有在色界死生非受色有。谓色界殁起欲界中有此唯异生。欲界中有在色界起。此中在色界死者。谓色界死有在色界灭故。在色界生者。谓欲界中有在色界起故。非受色有者。谓受欲有即受欲界中有诸蕴。有受色有非在色界死生。谓欲界殁起色界中有。此通异生及诸圣者。色界中有在欲界起。此中受色有者。谓受色界中有诸蕴。非在色界死者。谓欲界死有在欲界灭故。非在色界生者。谓色界中有在欲界起故。有在色界死生亦受色有。谓色界殁起色界中有生有。此通异生及诸圣者。异生生上亦生下一一处容受多生。圣者生上不生下一一处唯受一生。此中若从死有趣中有时在色界死者。谓色界死有在色界灭故。在色界生者谓色界中有在色界起故。受色有者谓受色界中有诸蕴。若从中有趣生有时在色界死者。谓色界中有在色界灭故。在色界生者。谓色界生有在色界起故。受色有者。谓受色界生有诸蕴。有非在色界死生亦非受色有。谓欲界殁生欲界无色界。无色界殁生无色界欲界。欲界殁生欲界者。谓生中有及生有。此通异生及诸圣者。此中若从死有趣中有时。非在色界死者。谓欲界死者有在欲界灭故。非在色界生者。谓欲界中有在欲界起故。非受色有者。谓受欲有即受欲界中有诸蕴。若从中有趣生有时非在色界死者。谓欲界中有在欲界灭故。非在色界生者。谓欲界生有在欲界起故。非受色有者。谓受欲有即受欲界生有诸蕴。欲界殁生无色界者。谓生生有。此通异生及诸圣者。此中非在色界死者。谓欲界死有在欲界灭故。非在色界生者。谓无色界生有在无色界起故。非受色有者。谓受无色有即受无色界生有诸蕴。无色界殁生无色界者。谓生生有。此通异生及诸圣者。此中非在色界死者。谓无色界死有在无色界灭故。非在色界生者谓无色界生有在无色界起故。非受色有者。谓受无色有即受无色界生有诸蕴。无色界殁生欲界者。谓生中有此唯异生。此中非在色界死者。谓无色界死有在无色界灭故。非在色界生者。谓欲界中有在欲界起故。非受色有者谓受欲有即受欲界中有诸蕴。诸在无色界死生者皆受无色有耶。答诸在无色界死生者皆受无色有。谓无色界无诸色故。无下中有在彼起义。故不可说在彼死生不受彼有。此通异生及诸圣者。异生生上亦生下一一处容受多生。圣者生上不生下一一处唯受一生有。受无色有非在无色界死而在无色界生。谓欲色界殁生无色界唯生生有。此通异生及诸圣者。此中受无色有者谓受无色界生有诸蕴。非在无色界死者。谓欲色界死有在欲色界灭故。而在无色界生者。谓无色界生有在无色界起故

诸在欲界死生者有几耶。答四。谓欲色界异生圣者。此中欲界异生圣者通中有生有。色界异生圣者唯中有。生有不在欲界起故。欲界殁生无色界者。无色界生有不在欲界死处。是故此唯有四。不得说六。无色界生不依色处。故不可言在欲界起。诸在色界死生者有几耶。答三。谓欲界异生色界异生圣者。此中欲界异生唯中有。色界异生圣者通中有生有。色界殁生无色界者。无色界生有不依色故不可说彼在色界起。故此唯三。不得说五。诸在无色界死生者有几耶。答二。谓无色界异生圣者中有必依色处起故。无色界殁生欲色界者中有不在无色界起。故此唯二不得说四。诸非在欲界死生者皆非受欲有耶。答应作四句乃至广说。谓前欲界四句中初句作此第二句。第二句作此初句。第三句作此第四句。第四句作此第三句。此中诸义如前应知。诸非在色界死生者皆非受色有耶。答应作四句乃至广说。谓前色界四句中初句作此第二句。第二句作此初句。第三句作此第四句。第四句作此第三句。此中诸义如前应知。诸非在无色界死生者皆非受无色有耶。答诸非在无色界死生者皆非受无色有。谓受无色有者必在无色界生故。有非受无色有非不在无色界死而非在无色界生。谓无色界殁生欲色界。此唯异生。无色界殁生欲色界中有诸蕴。此中非受无色有者。谓受欲色有故。非不在无色界死者。谓在无色界死故。而非在无色界生者。谓在欲色界生故

诸非在欲界死生者有几耶。答五。谓欲界异生色无色界异生圣者。问此应有八云何说五。谓色界殁生色界异生圣者。色界殁生无色界异生圣者。色界殁生欲界异生。无色界殁生无色界异生圣者。无色界殁生色界异生。如是有八宁说五耶。答种类同故但说有五。谓色界殁生色界异生。及无色界殁生色界异生。此二虽别而色界异生种类同故合说为一。色界殁生无色界异生。及无色界殁生无色界异生。此二虽别而无色界异生种类同故合说为一。色界殁生无色界圣者。及无色界殁生无色界圣者。此二虽别而无色界圣者种类同故合说为一。余有欲界异生色界圣者各为一故足前为五诸非在色界死生者有几耶。答六。谓三界异生圣者。问此应有九云何说六。谓欲界殁生欲界异生圣者。欲界殁生色界异生圣者。欲界殁生无色界异生圣者。无色界殁生无色界异生圣者。无色界殁生欲界异生。如是有九宁说六耶。答种类同故但说有六。谓欲界殁生欲界异生。及无色界殁生欲界异生。此二虽别而欲界异生种类同故合说为一。欲界殁生无色界异生。及无色界殁生无色界异生。此二虽别而无色界异生种类同故合说为一。欲界殁生无色界圣者。及无色界殁生无色界圣者。此二虽别而无色界圣者种类同故合说为一。余有欲界圣者色界异生及圣者各为一故足前为六。诸非在无色界死生者有几耶。答四。谓欲色界异生圣者。问此应有七云何说四。谓欲界殁生欲界异生圣者。欲界殁生色界异生圣者。色界殁生色界异生圣者。色界殁生欲界异生。如是有七宁说四耶。答种类同故但说有四。谓欲界殁生欲界异生及色界殁生欲界异生。此二虽别而欲界异生种类同故合说为一。欲界殁生色界异生。及色界殁生色界异生。此二虽别而色界异生种类同故合说为一。欲界殁生色界圣者。及色界殁生色界圣者。此二虽别而色界圣者种类同故合说为一。余有欲界圣者足前为四。颇有欲界死不生欲界耶乃至广说。此中所说与前异者。谓遮生有故说不生。设起中有亦说不生。颇有欲界死不生欲界耶。答有。谓起欲色界中有生无色界或般涅槃。起欲色界中有者。谓欲界殁起欲色界中有。虽在欲界起非生有故说不生欲界。生无色界者。谓欲界殁生无色界生有。彼不在欲界故说不生欲界。般涅槃者。谓欲界殁诸漏尽者便般涅槃。永不生故说不生欲界。余文广释准前应知。问无色界殁生欲色界者。彼二中有何处现在前。有作是说。在第四静虑。评曰彼不应作是说。所以者何。若无色界有方处者可作是说。然无色界无有方处。何缘远至第四静虑。有余师说。若从彼殁生无色界即在彼方处中有现在前。彼亦不应作如是说。所以者何若作是说从无色界殁生无色界者云何可尔。应作是说。若欲色界殁生无色界。及无色殁生无色界者。彼无色界殁生欲色界时。彼二中有即当生处而现在前

诸欲界死不生欲界者有几耶。答六。谓三界异生圣者乃至广说。问何故不说般涅槃者。答应说而不说者当知此义有余。复次此中说死更受生者。般涅槃者死已不生故此不说。复次此纳息内依诸有情补特伽罗而兴问答。般涅槃者舍有情数堕于法数不可施设补特伽罗故此不说。后准应知

颇有欲界死不生三界耶。答有。谓起欲色界中有或般涅槃乃至广说。此中亦遮生有作论故。起中有及般涅槃者皆名不生。诸欲界死不生三界者有几耶。答四。谓欲色界异生圣者。即欲界殁生欲色界中有中者。诸色界死不生三界者有几耶。答三。谓欲界异生色界异生圣者。即色界殁生欲色界中有中者。诸无色界死不生三界者有几耶。答二谓欲色界异生。即无色界殁生欲色界中有中者。圣者不生下界地故唯说异生

颇有未离欲染命终不生欲界耶乃至广说。问何故作此论。答为止他宗显正理故。谓或有说唯伏烦恼亦得上生。如譬喻者为遮彼意。显伏烦恼不得上生。要断下地诸烦恼尽方得上生故作斯论。分别论者拨无中有于此等问极生迷惑。谓未离此地染命终不生此及下地。若信中有于此等问不生迷惑遮生有故。问如何得知未离下染不得生上。答下地烦恼障碍上地诸功德故。未得上地根本功德不生彼故。若执唯伏下地烦恼即得上生。诸以欲界闻思慧力伏烦恼者彼应不生三界九地。闻思慧力能伏三界九地烦恼令不起故。非修慧力伏诸烦恼令不现行。胜闻思慧以闻思慧分别诸法伏诸烦恼胜修慧故

诸未离欲染命终不生欲界者有几耶。答二。谓欲界异生圣者未离欲染不上生故。但有欲界住中有中异生圣者。诸未离色染命终不生欲色界者有几耶。答四。谓欲色界异生圣者。问此应有七云何说四。谓欲界没生欲界异生圣者。欲界殁生色界异生圣者。色界殁生色界异生圣者。色界殁生欲界异生。如是有七宁说四耶。答种类同故但说有四。谓欲界殁生欲界异生。及色界殁生欲界异生。此二虽别而欲界异生种类同故合说为一。欲界殁生色界异生。及色界殁生色界异生。此二虽别而色界异生种类同故合说为一。欲界殁生色界圣者及色界殁生色界圣者。此二虽别而色界圣者种类同故合说为一。余有欲界圣者足前为四。诸未离无色染命终不生三界者有几耶。答四。谓欲色界异生圣者。问此应有九云何说四。谓欲界没生欲界异生圣者。欲界没生色界异生圣者。色界殁生色界异生圣者。色界殁生欲界异生。无色界殁生色界异生无色界殁生欲界异生。如是有九宁说四耶。答种类同故但说有四。谓欲界殁生欲界异生。及色无色殁生欲界异生。此三虽别而欲界异生种类同故合说为一。欲界殁生色界异生。及色无色殁生色界异生。此三虽别而色界异生种类同故。合说为一。欲界殁生色界圣者。及色界殁生色界圣者。此二虽别而色界圣者种类同故合说为一。余有欲界圣者足前为四。前来生言皆说中有依遮生有而作论故

说一切有部发智大毗婆沙论卷第六十八阿毗达磨大毗婆沙论卷第六十九

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中有情纳息第三之七

此中欲界异生圣者几随眠随增几结系耶。答异生九十八随眠随增九结系。圣者十随眠随增六结系。此中者谓前来所说诸有情中一切有情总唯有六。谓三界各有异生及圣者。欲界异生具九十八随眠随增具九结系。欲界圣者唯有修所断十随眠随增。见所断者皆已断故。六结系者除见取疑此三圣者亦已断故。色界异生圣者几随眠随增几结系耶。答异生六十二随眠随增六结系。圣者六随眠随增三结系。异生六十二随眠随增者。谓色无色界各三十一。欲界三十六彼已断故。六结系者除恚嫉悭定界无故。圣者六随眠随增者。谓色无色界修所断各三。彼已断欲界修所断四故。三结系者。谓爱慢无明。余已断故。无色界异生圣者几随眠随增几结系耶。答异生三十一随眠随增六结系。圣者三随眠随增三结系。异生三十一随眠随增者。谓无色界三十一种。余已断故。六结系者。除恚嫉悭彼界无故。圣者三随眠随增者。谓无色界修所断三。余已断故。三结系者。谓爱慢无明。余已断故。问欲界有情非上二界随眠随增。此何故说欲界异生具九十八随眠随增。欲界圣者修所断十随眠随增。色界有情非无色界随眠随增。此何故说色界异生有六十二随眠随增。色界圣者修所断六随眠随增。答依不解脱彼得说故。谓欲界异生虽非色无色界随眠随增。而未解脱彼随眠得故说随增。欲界圣者虽非色无色界修所断随眠随增。而未解脱彼随眠得故说随增。由此色界异生圣者说无色界随眠随增亦不违理。复次此依彼得现行说故。谓欲界异生虽非色无色界随眠随增。而有彼得现在转故亦说随增。欲界圣者虽非色无色界修所断随眠随增。而有彼得现在转故亦说随增。由此色界异生圣者说无色界随眠随增亦不违理。复次此依彼得已得未得正得说故亦不违理。已得者说彼过去得。未得者说彼未来得。正得者说彼现在得。谓欲色界异生圣者虽非上界随眠随增。而有三世彼随眠得流转未断故说随增。复次依容现起故作是说。谓欲界异生圣者虽非色无色界随眠随增。而容现起彼随眠故亦说随增。谓离欲染已彼容现起故。由此色界异生圣者说无色界随眠随增应知亦尔。虽彼退已亦容现起下界随眠。而已断故有能毕竟不复退故不说下界随眠随增。复次显彼等流曾现起故作如是说亦不违理。谓欲界有情从不可知本际已来。无不曾起色无色界诸随眠者故说随增。色界有情从不可知本际已来。无不曾起无色界诸随眠者故说随增。问色无色界有情从不可知本际已来。无不曾起欲色二界诸随眠者。何故不说亦为下界随眠随增。答虽亦曾起而已断故不说随增。问亦有圣者具九十八随眠。谓具缚者住苦法智忍时。此中何故说欲界圣者但有十种随眠随增耶。答虽亦有此而时少故但说有十随眠随增。谓初刹那具九十八。此刹那后即已断十倏忽便至第十六心。时间既促故。但说有修所断十随眠随增。复次入见道者有七十三。前九有情初刹那顷。虽具成就九十八种而不现行。以见道位善有漏心尚不得起况起染污无覆无记。此中唯依现行烦恼建立有情分位差别。故说圣者极多唯十随眠随增。唯此十种容现起故。余处亦依现行烦恼建立有情分位差别。如契经说。有一梵志来诣佛所问言。世尊当为天耶。佛言不也。复问当为龙阿素洛健达缚揭路荼紧奈落莫呼洛伽药叉逻刹娑非人人耶。佛言不也。所以者何。梵志当知。若有诸漏未断未遍知以现行故。当生天趣可当为天。广说乃至当生人趣可当为人。我于诸漏已断已遍知。如断树根截多罗头。由此诸漏永不现行。于诸后有得不生法故。我决定不当为天。广说乃至不当为人。有处亦依现行异熟建立有情分位差别。如契经中有伽他曰

  佛是真人　　自调常定　　恒游梵路
  心乐寂静

若受此界异熟相续即名此界受生有情。谓受欲界异熟相续即名欲界受生有情。若受色界异熟相续即名色界受生有情。若受无色界异熟相续即名无色界受生有情。佛既受人异熟相续。证真实法故名真人。此论亦依现行异熟建立有情界地差别。如十门中说。谁成就眼根。谓生色界若生欲界已得未失。谁不成就眼根。谓生无色界。若生欲界未得已失。此依三界异熟相续。若现在前名生此界余法不定故不依说问何故尊者此纳息中数依中有而作论耶。答为止他宗显正理故。谓或有执。三界受生皆无中有如分别论者。或复有说。欲色界生定有中有如应理论者。问分别论者依何量。故执无中有。答依至教量。谓契经说。若有一类造作增长五无间业。无间必定生地狱中。既言无间必生地狱故知中有决定为无。又伽他说

  再生汝今过盛位　　至衰将近琰魔王
  欲往前路无资粮　　求住中间无所止

既说中间无所止处。故知中有决定为无。又说过难证无中有。谓如影光中无间隙死有生有应知亦然。问应理论者依何量故说有中有。答依至教量。如契经说。入母胎者要由三事俱现在前。一者母身是时调适。二者父母交爱和合。三健达缚正现在前。除中有身何健达缚。前蕴已坏何现在前。故健达缚即是中有。又经说有中般涅槃。中有若无。此依何立。余经复说。此身已坏余身未生意成有情依止于爱而施设取。世尊既说此身已坏余身未生意成有情依爱立取。故知中有决定非无。若无中有意成有情名何所表。又说过难证有中有。谓从此洲殁生北俱卢等。若无中有此身既灭彼身未生中间应断。是则彼身本无而有。此身亦则本有而无。法亦应尔。本无而有有已还无。勿有斯过故有中有。问应理论者云何释通分别论者所引至教而说中有是有非无。答彼所引经是不了义是假施设有别意趣。所以者何。且彼经说若有一类造作增长五无间业。无间必定生地狱者。彼经意遮余趣余业不遮中有。遮余趣者。谓无间业定招地狱不招余趣。有此业者命终定生捺落迦中非余趣故。遮余业者。谓无间业顺次生受非顺现法受。非顺后次受。由此业力命终定堕捺落迦中受异熟故。此是彼经所说意趣。若如经文而取义者。彼经既说造作增长五无间业。无间必定生地狱中。岂造四三二一余业不生地狱而但说五。又说无间生地狱中。岂造业已第二刹那即堕地狱。然造业已有经百年方堕地狱。是故不应如文取义便执中有决定为无。所引伽他亦同此释。谓遮余趣及遮余业说无中间不遮中有。问应理论者云何释通分别论者所说过难。而说中有定有非无。答彼所设难不必须通。所以者何非三藏故世俗法异贤圣法异。不应引世俗法而诘难贤圣法。若必须通应说喻过喻。既有过为证不成谓如影光非有情数。无根无心死有生有岂同彼耶。又如影光俱时而起。死有生有岂俱生耶。又此影光无间隙喻乃证中有是有非无。谓如影光无间无隙。如是死有趣中有时无间无隙。复从中有趣生有时亦无间隙。是故中有定有非无。问分别论者云何释通应理论者所引至教。而执中有决定为无。答彼所引经是不了义。是假施设。有别意趣。所以者何。且初经说入母胎者要由三事广说乃至。三健达缚正现在前。健达缚言经不应说彼无鼓等诸乐器故应说蕴行彼蕴行故。应理论者便诘彼言纵说蕴行或健达缚俱证中有是有非无。异此蕴行言何所表。分别论者复作责言。汝说四生皆有中有胎卵可有三事入胎。湿化二生云何可尔。故所引经非应正理。应理论者箴喻彼言。三事入胎随应而说。谁令三事要遍四生。非设此言便遮中有。分别论者通第二经。言有中天住彼入灭。由此经说中般涅槃。又舍欲界已未至色界而入灭者名中般涅槃。或受色界众同分已未经多时而入灭者名中般涅槃。或生色界寿量未尽而入灭者名中般涅槃。是故此名非证中有。应理论者便诘彼言。此中天名佛何处说。经但说有二十八天。谓四大王众天乃至非想非非想处天。不说有中天。汝依何而说。又经说有生般涅槃。汝亦应许有天名生住彼入灭。又契经说有行般涅槃乃至上流。汝亦应许有天名有行乃至上流。既无别天名为生等如何别立有天名中。又汝所说舍欲界已未至色界而入灭者名中般涅槃亦不应理。所以者何。既舍欲界未至色界。若无中有依何身住而般涅槃。故汝所言空无实义。又汝所说或受色界众同分已未经多时而入灭者名中般涅槃此亦非理。所以者何。生般涅槃依此立故。又无色界亦应说有中般涅槃。生彼未久有尽余结而入灭故。若尔无色亦应说有七善士趣便违契经。以契经说七善士趣唯色界故。又汝所说或生色界寿量未尽而入灭者名中般涅槃此亦非理。所以者何。一切有情多分中夭唯除人趣北俱卢洲。及住睹史多天一生所系菩萨。诸余中夭而入灭者皆应名为中般涅槃。是则此名非唯色界故彼所说皆不应理。分别论者通第三经言。意成有情即是无色界。谓有出家犊子梵志。已离欲染得天眼通。彼有同学已离色染先此命终生无色界。犊子梵志以天眼通。欲色界中遍观不见。便作是念彼断灭耶为决自疑来至佛所。以所疑事而白佛言。乔答摩尊。愿为解脱。此身已坏余身未生。意成有情依止何法而施设取。世尊告曰。梵志当知。此身已坏余身未生。意成有情依止于爱而施设取。佛意告言。汝之同学从此命终。生无色界依爱立取非谓断灭。应理论者便诘彼言。经说意成表多种义。成表中有。或表化身。或表劫初人。或表上二界。何缘知此表无色天不表中有。分别论者作如是说。宁知此言唯表中有不表无色。应理论者作如是言。即以此经知表中有。谓此经说此身已坏余身未生。意成有情依爱立取。此身已坏余身未生。意成有情岂离中有。非无色界可名未生故。彼通经定不应理。问分别论者云何释通应理论者所设过难而执中有决定为无。答诸从死有至生有时要得生有方舍死有。如折路迦缘草木等。先安前足方移后足。是故死生中无断过。应理论者便诘彼言。若作是说则有大过。谓人中死生地狱者应先得地狱诸蕴。后方舍人中诸蕴。若尔趣坏所依身坏。有一身内二心俱生。趣坏者。谓彼于尔时是地狱趣亦人趣摄。身坏者。谓彼于尔时是地狱身亦人身摄。有一身内二心俱生者。谓死有生有二心俱生。一有情身二心并起心既有二身应非一。故彼所说非为释难。问此二论师于一中有一说为有一执为无。如是二说。何者为胜。答应理论者所说为胜。所引至教及设过难彼不通故。然分别论者是无知果。黑闇果。无明果。不勤加行果。由此决定拨无中有。然此中有是实有物与实有物性相相应。如是为止他宗所说及显自宗所说正理故作斯论。复次勿为止他显己宗说。然为显示诸法正理开悟学者故作斯论

问一切中有为是趣摄非趣摄耶。设尔何失。二俱有过。所以者何。若是趣摄施设论说当云何通。如彼论说。为五趣摄四生为四生摄五趣。答四生摄五趣非五趣摄四生。不摄何等不摄中有。法蕴论说复云何通。如彼论说。云何眼界。答四大种所造清净色是眼。及眼根眼处眼界地狱傍生鬼天人眼。修所成眼及中有眼。品类足论复云何通。如彼论说。云何眼根。谓四大种所造净色。能视能见眼界眼处眼根所摄。地狱傍生鬼天人眼。或复所余中有等眼。若非趣摄。尊者达罗达多所说当云何通。如说。中有趣向彼趣即彼趣摄。如稻谷芽虽非稻谷能引彼故亦名稻谷。有作是说。诸趣中有即诸趣摄问若尔善通尊者达罗达多所说。施设论说当云何通。答施设论文应作是说。四生五趣展转相摄随其种类。而不尔者应知彼文诵者错谬。问法蕴论说复云何通。答法蕴论文应作是说。地狱傍生鬼天人眼修所成眼。不应复说及中有眼。而复说者有别意趣。谓中有眼虽即趣摄以微细故复别显之。如贼军将虽贼军摄以罪重故。诃诸贼已复别诃之。又如女人虽欲具摄以过重故。毁欲具已复别毁之。中有亦尔。虽即趣摄以微细故。复别显之。由此已通品类足说。有说。中有非趣所摄。问若尔善通施设论等。尊者达罗达多所说当云何通。答彼不须通非三藏故。文颂所说或然不然。达罗达多是文颂者言多过实故不须通。若必须通应求彼意。谓诸中有似所趣形故。说摄在所向诸趣。地狱中有形如地狱。乃至人中有形即如人。而实中有非趣所摄。评曰。此二说中后说为善。所以者何。趣谓所趣。即所至处。中有趣彼非所至处。犹如道路故非趣摄。复次趣非扰乱中有扰乱。是故中有非趣所摄。复次趣多安住中有不住。如风阳焰故非趣摄。复次诸趣是果中有是因。因不即果故非趣摄。如因非果作非所作取非所取向非所向应知亦尔。复次诸趣相粗中有相细细不即粗故非趣摄。如细非粗不现见非现见。不明了非明了应知亦尔。复次中有在彼二趣中间故非趣摄。如田邑土世界中间非田等摄。复次趣是根本善恶业招。彼加行业招于中有。因既有异故。不相摄

问何界地处有中有耶。有作是说。业猛利者即无中有。业迟钝者即有中有。由此地狱及诸天中皆无中有。业猛利故。人傍生鬼或有中有或无中有。业不定故。复有说者。化生有情即无中有业猛利故。三生有情或有中有或无中有业不定故。有余师说若用顺定受业而招生者即无中有。若用顺不定受业而招生者即有中有。应作是说。欲色界生定有中有。连续处别死有生有令不断故。无色界生定无中有。问何故无色界定无中有耶。答非田器故。谓色法是中有田器。无色界生无诸色故。定无中有。复次连续处别死有生有令不断故而起中有。无色界生无方处别。可须连续而起中有故无色界定无中有。复次若界地处受二种业异熟果者便有中有。二种业者。一顺中有受业。二顺生有受业。复有二种。一顺起受业。二顺生受业。复有二种。一顺起异熟业。二顺生异熟业。复有二种。一顺细果业。二顺粗果业。无色界中唯受一种业异熟果故无中有。一种业者。谓顺生有受业乃至顺粗果业。复次若界地处受加行根本二种业异熟果者便有中有。无色界中唯受根本业异熟果故无中有。复次若界地处受二种业异熟果者便有中有。二种业者。一有色业。二无色业。复有二种。一相应业。二不相应业。复有二种。一有所依业。二无所依业。复有二种。一有所缘业。二无所缘业。复有二种。一有行相业。二无行相业。复有二种。一有警觉业。二无警觉业。无色界中唯受一种业异熟果故无中有。一种业者。谓无色业乃至有警觉业。复次若界地处受能趣所趣业异熟果者便有中有。无色界中唯受所趣业异熟果故无中有。如能趣所趣能续所续应知亦尔。复次若界地处受身语意三种业异熟果者。便有中有。无色界中唯受一种意业异熟果故无中有。复次若界地处受善五蕴异熟果者便有中有。无色界中唯受善无色四蕴异熟果故无中有。复次若界地处受十善业道异熟果者便有中有。无色界中唯受后三善业道异熟果故无中有。复次若界地处受黑黑或白白或黑白黑白业异熟果者便有中有。无色界中不受此三业异熟果故无中有。复次若界地处有鲜白因及鲜白果者便有中有。无色界中虽有鲜白因。而无鲜白果故无中有。复次若界地处有去有来便有中有。无色界中无去无来故无中有。问若此处死还生此处如闻有死生自尸中既无去来。何须中有。连续二有令不断耶。答有情死已或生恶趣。或生人中。或生天上。或般涅槃。生恶趣者识在脚灭。生人中者识在脐灭。生天上者识在头灭。般涅槃者识在心灭。诸有死已生自尸中为虫等者。彼未死时多爱自面故彼死已生自面上。既从彼脚来生自面。若无中有谁能连续。无此处死还生此处。舍身受身必移转故。设有是事无色亦无故无色界定无中有。问无色界殁生欲色界者。既随当生处中有现前。彼无往来何用中有。答彼先已造感中有业虽无往来亦受中有业力所引必应起故

问中有可转不可转耶。譬喻者说。中有可转。以一切业皆可转故。彼说所造五无间业尚可移转。况中有业。若无间业不可转者。应无有能出过有顶。有顶善业最为胜故。既许有能过有顶者。故无间业亦可移转。阿毗达磨诸论师言。中有于界于趣于处皆不可转。感中有业极猛利故。问若中有于界不可转者。无闻苾刍事当云何通。有族姓子于佛法中适出家已不学多闻。即便居在阿练若处坚持禁戒心乐寂静。乘宿因力修世俗定。若起世俗初静虑时便谓得预流果。乃至若起世俗第四静虑时便谓得阿罗汉果。彼一生中起增上慢。未得谓得。未获谓获。未解谓解。未证谓证。不求胜进。彼命终时第四静虑中有现前。便作是念。一切结缚我已永断应般涅槃更无生处。何缘有此中有现前。遂起邪见拨无解脱。若有解脱我应得之。由谤涅槃邪见力故。第四静虑中有便灭。无间地狱中有现前。命终后生无间地狱。是则中有于界可转。宁说于界不可转耶。答住本有时有此移转非中有位故不相违。谓彼将死由业势力第四静虑生相现前。彼既见已便作是念。一切结缚我已永断应般涅槃更无生处。何缘有此生相现前。遂起邪见拨无解脱。若有解脱我应得之。由谤涅槃邪见力故。第四静虑生相便灭。无间地狱生相现前。命终后生无间地狱。住本有位有此移转。非中有位故不违理。问若中有于趣不可转者。善恶行者事当云何通。室罗筏国昔有二人。一恒修善。一常作恶。修善行者于一身中恒修善行未尝作恶。作恶行者于一身中常作恶行未尝修善。修善行者临命终时顺后次受恶业力故。欻有地狱中有现前。便作是念。我一身中恒修善行未尝作恶。应生天趣。何缘有此中有现前。遂起念言。我定应有顺后次受恶业。今熟故此地狱中有现前。即自忆念。一身已来所修善业深生欢喜。由胜善思现在前故。地狱中有即便隐殁。天趣中有欻尔现前。从此命终生于天上。作恶行者临命终时。顺后次受善业力故。欻有天趣中有现前。便作是念。我一身中常作恶行未尝修善。应生地狱。何缘有此中有现前。遂起邪见拨无善恶及异熟果。若有善恶异熟果者我不应然。由谤因果邪见力故。天趣中有寻即隐殁地狱中有欻尔现前。从此命终生于地狱。是则中有于趣可转。宁说中有不可转耶。答彼本有时有此移转。非中有位故不相违。谓诸有情临命终位。有爱非爱生相现前。如契经说。修善行者临命终时。见妙堂阁园林池沼伎乐香花。处处陈列宝饰舆等似欲相迎。作恶行者临命终时。见崄沟壑猛火烟焰。刀山剑树毒刺稠林。狐狼野干猫狸冢墓。秽恶众具似欲相迎。修善行者临命终位。顺后次受恶业力故。有地狱趣生相现前。彼既见已便作是念。我一身中恒修善行未尝作恶。应生天趣。何缘有此生相现前遂起念言。我定应有顺后次受恶业今熟。故此地狱生相现前。即自忆念一身已来所修善业。深生欢喜。由胜善思现在前故。地狱生相即便隐殁。天趣生相欻尔现前。从此命终生于天上。作恶行者。临命终时。顺后次受善业力故。欻有天趣生相现前。彼既见已便作是念。我一身中常作恶行。未尝修善。应生地狱。何缘有此生相现前。遂起邪见拨无善恶及异熟果。若有善恶异熟果者我不应然。由谤因果邪见力故。天趣生相便即隐殁。地狱生相欻尔现前。从此命终生于地狱。彼本有位有此移转非中有位故不违理。问若中有于处不可转者。彼影坚王事当云何通。摩揭陀国昔有大王名曰影坚。恒乐修集睹史多天胜妙善业。命终乘彼中有之身往彼天处。至妙高山胁多闻王宫边。正遇为王造诸饮食。其色鲜洁香气美妙。见已起爱作是念言。愿且生此受斯饮食。然后乃趣睹史多天。作是念时彼天中有寻即隐殁。多闻天子中有现前。因此便生多闻天处。是则中有于处可转。宁说中有不可转耶。答彼本有时有此移转非中有位故不相违。谓影坚王为假名子未生怨王闭在囹圄。断诸饮食削足下皮。饥渴所逼受诸苦恼。尔时佛在鹫峰山中。怜愍彼故身放慈光从窗牖入照触王身。令王少时身心安隐。便作是念。世尊大慈。宁不垂愍救我苦厄。尔时世尊知王心念。便告尊者大目揵连。汝可速诣影坚王所。如我辞曰。大王当知。我于大王所应作者皆已作讫。谓已永拔诸恶趣苦。人中少时定受恶业。佛尚不免。况王小圣而得免耶。宜自安心勿甚忧恼。尔时尊者大目揵连承佛语已。即入胜定。起神境通鹫峰山没于王宫出。如处泉池出没自在。欻然踊现影坚王前。告彼王曰。大王当知。如来大慈所言无二。深见因果能善记别故。遣我来慰问于汝。令告汝曰。大王当知。我于大王所应作者皆已作讫。谓已永拔诸恶趣苦。人中少时定受恶业。佛尚不免。况王小圣而得免耶。宜自安心勿甚忧恼。尔时尊者大目揵连因复为王说种种法。时王饥渴所逼恼故。于所说义不能领解。白目连曰。诸天食中何天段食最为美妙。宜为我说我愿欲闻。时大目揵连次第赞说六欲天中美妙饮食。王初闻说四天王处多闻王宫美妙饮食。便即舍命生彼天宫。与多闻王而作太子。王为立号名最胜尊。寻从彼天来诣佛所。到已顶礼世尊双足。欢喜踊跃数自称名。我最胜尊愿佛垂念。彼住本有临命终时。睹史多天生相先现。爱多闻室美妙食时。睹史多天生相便殁。多闻天子生相现前。从此命终受彼中有。乘斯中有而生彼天。既本有时有此移转。非中有位故不相违

说一切有部发智大毗婆沙论卷第六十九阿毗达磨大毗婆沙论卷第七十

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中有情纳息第三之八

问住中有位为经几时。答经于少时速求生故。谓住中有。于六处门遍求生缘。速往和合。问若受中有即遇生缘此彼和合可速往彼。与彼缘会于中结生。若遇生缘不和合者。如何彼住不经多时。如有父在迦湿弥罗国。母在至那。或有母在迦湿弥罗国。父在至那。如是生缘难可和合。如何中有速往结生。答应知有情作父母业有定不定故。于父母有可转义不可转义。若于父母俱可转者。即往余父母和合处结生。若于父可转于母不可转者。即彼女人性虽贞洁受持五戒具足威仪。而必与余男子和合。令中有者速往结生。若于母可转于父不可转者。即彼男子性虽贤良受持五戒威仪具足。而必与余女人和合。令中有者速往结生。若于父母俱不可转者。即彼有情未命终位。由业力故令其父母。虽有住缘而不顾恋。必起相趣和合之心。彼相趣时于所经处。毒不能害刃不能伤。火不能烧水不能溺。及余种种夭横因缘。皆不能碍必得和合。令彼有情既命终已。适受中有即往结生。问若诸有情欲常增者可随中有速往结生。若有欲心不常增者。如何中有随往结生。如马春时欲心增盛余时不尔。牛于夏时欲心增盛余时不尔。狗于秋时欲心增盛余时不尔。熊于冬时欲心增盛余时不尔。如何有情适受中有令彼和合而往结生。答由彼有情住中有位业增上力令其父母非时欲心亦得增盛。相趣和合彼得结生。有余师说。相似类中亦得结生故无有失。谓马春时欲心增盛余时不尔。驴一切时欲心增盛。应生马中者以非时故转生驴中。牛于夏时欲心增盛余时不尔。野牛恒时欲心增盛。应生牛中者以非时故转生野牛中。狗于秋时欲心增盛余时不尔。野干恒时欲心增盛。应生狗中者以非时故转生野干中。熊于冬时欲心增盛余时不尔。罴一切时欲心增盛。应生熊中者以非时故转生罴中。虽彼形相与余相似而众同分如本不转。以诸中有不可转故。如是中有住经少时。必往结生速求生故。尊者设摩达多说曰。中有极多住七七日。四十九日定结生故。尊者世友作如是说。中有极多住经七日。彼身羸劣不久住故。问若七日内生缘和合彼可结生。若尔所时生缘未合彼岂断坏。答彼不断坏。谓彼中有乃至生缘未和合位。数死数生无断坏故。大德说曰。此无定限。谓彼生缘速和合者。此中有身即少时住。若彼生缘多时未合。此中有身即多时住。乃至缘合方得结生。故中有身住无定限。问中有形量大小云何。答欲界中有如五六岁小儿形量。色界中有如本有时形量圆满。问若欲界中有如五六岁小儿形量。云何于父母起颠倒想生爱恚耶。答形量虽小而诸根猛利。如本有时能作诸事业。如壁等上画老人形。其量虽小而有老相。问菩萨中有其量云何。答如住本有盛年时量。三十二相庄严其身。八十随好而为间饰。身真金色圆光一寻。由此菩萨住中有时。照百俱胝四大洲等。如百千日一时俱照。梵音深妙令人乐闻。如美音鸟其声清亮。智见无碍离诸杂染问菩萨中有若如是者法善现颂当云何通。如说

  白象相端严　　具六牙四足
  正知入母腹　　寝如仙隐林

答此不须通非三藏故。文颂所说或然不然。诸文颂者言多过实。若必须通应求彼意随现梦相故作是说。谓彼国中梦见此相以为吉瑞。故菩萨母梦见此事欲令占相。诸婆罗门闻已咸言。此相甚吉。故法善现作如是说。亦不违理。菩萨已于九十一劫不堕恶趣。况最后身受此中有而入母胎。是故智者不应依彼所说文颂。而言菩萨所受中有如白象形

问中有诸根为具不具。答一切中有皆具诸根。初受异熟必圆妙故。有作是说。中有诸根亦有不具。随本有位所不具根彼亦不具。如印印物像现如印。如是中有趣本有故。如本有时有根不具。此中初说于理为善。谓中有位于六处门遍求生处根必无缺。此说眼等非女男根。色界中有无彼根故。欲界中有彼亦不定。当受卵胎二类生者。住中有位有女男根。至卵胎中方有不具。若不尔者应无当受卵胎生义

问一切中有形状云何。答中有形状如当本有。谓彼当生地狱趣者。所有形状即如地狱。乃至当生天趣中者。所有形状即如彼天。中有本有一业引故。有作是说。若此命终受中有者。中有形状即如此身。如印印物像现如印。彼说非理。所以者何。无色界殁受欲色界中有身者何所似耶。岂有诸天所受中有形如地狱。宁有地狱所受中有形如诸天。又色界殁生欲界者。所受中有应非女男。欲界命终生色界者。所受中有应是女男。是故此中初说应理。问若中有形状如当本有。一狗等腹中容有五趣中有顿起。既有地狱中有现前。如何不能焚烧母腹。地狱本有多为猛火所焚烧故。答彼居本有亦不恒烧。如暂游增或余地狱施设论说。有时等活捺落迦中。冷风暂起有声唱言等活等活。尔时有情寻复等活。本有尚然。况在中有。设许恒烧如不可见亦不可触。以中有身极微细故。火亦应尔。诸趣中有虽居一腹非互触烧业所遮故。母腹亦尔故不被烧。问若在小处有情命终生色界者。如何容受色界中有大形状耶。答中有色身微细无碍。宁恐处小而不容受。虽中有形如当本有。而事业等不必皆同问诸趣中有行相云何。答地狱中有头下足上而趣地狱。故伽他言

  颠坠于地狱　　足上头归下
  由毁谤诸仙　　乐寂修苦行

诸天中有足下头上。如人以箭仰射虚空。上升而行往于天趣。余趣中有皆悉傍行。如鸟飞空往所生处。又如壁上画作飞仙举身傍行求当生处。问中有行相皆如是耶。答应作是说。不必皆尔且依人中命终者说。若地狱死还生地狱不必头下足上而行。若天中死还生天趣不必足下头上而行。若地狱死生于人趣应首上升。若天中死生于人趣应头归下。鬼及傍生二趣中有随所往处如应当知。有余师说。中有行相一切皆尔。所以者何。表所造业有差别故。谓地狱业极秽下故。初受中有头必归下。后随所往行相不定。生诸天业极胜上故初受。中有首必上升。后随所往行相不定。余三种业非极上下。故彼中有初皆傍行后随所往行相不定。复有说者。一切中有初受所造业异熟故。皆表所造业有差别。地狱中有是极下业所得果故。随行动时足上头下。诸天中有是最上业所得果故。随行动时足下头上。余三中有是处中业所得果故。随行动时首之与足等无上下。虽彼所往上下不定而行动时头足必尔

问中有生时为有衣不。答色界中有一切有衣。以色界中惭愧增故。惭愧即是法身衣服。如彼法身具胜衣服生身亦尔。故彼中有常与衣俱。欲界中有多分无衣。以欲界中多无惭愧。唯除菩萨及白净苾刍尼所受中有恒有上妙衣服。有余师说。菩萨中有亦无有衣。唯有白净苾刍尼等。所受中有常与衣俱。问何缘菩萨中有无衣而白净等中有有衣。答由白净尼曾以衣服施四方僧故。彼中有常有衣服。问若尔菩萨于过去生以妙衣服施四方僧。白净尼等所施衣服碎为微尘犹未为比。如何菩萨中有无衣。而彼中有常有衣服。答由彼愿力异菩萨故。谓白净尼以衣奉施四方僧已。便发愿言。愿我生生常着衣服。乃至中有亦不露形。由彼愿力所引发故。所生之处常丰衣服彼最后身所受中有常有衣服。入母胎位乃至出时衣不离体。如如彼身渐次增长如是如是衣随渐大。后于佛法正信出家。先所著衣变为法服。受具戒已转成五衣。于佛法中勤修正行不久便证阿罗汉果。乃至最后般涅槃时即以此衣缠身火葬。菩萨过去三无数劫所修种种殊胜善行。皆为回向无上菩提利益安乐诸有情故。由斯行愿于最后身居诸有情最尊胜位。众生遇者无不蒙益。是故菩萨所受中有虽具相好而无有衣愿力有殊不应为难。诸有发愿如白净尼。所受中有亦有衣服。应知此中前说应理。菩萨功德惭愧增上。诸余有情色界中有所不及故。在中有位必不露形

问在中有位资段食不。答色界中有不资段食。欲界中有必资段食。问欲界中有段食云何。有作是说。欲界中有至有食处便食彼食。至有水处便饮彼水。由彼饮食以自存济。此说非理。所以者何。中有极多难周济故。谓契经说。如从袋等泻粳米等置仓镬中数极稠密。五趣有情所受中有散在处处数量过彼。若彼受用诸饮食者一切世间所有饮食。唯供狗犬一类中有尚不周济况余中有而可充足。又中有身既极轻妙受粗重食身应散坏。应作是说。中有食香非食粗质故无前过。谓有福者歆飨清净华果食等轻妙香气以自存活。若无福者歆飨粪秽臭烂食等轻细香气以自存活。又彼所食香气极少中有虽多而得周济

如是中有有多种名。或名中有。或名揵达缚。或名求有。或名意成。问何故中有或名中有。答居死有后在生有前。二有中间有自体起。欲色有摄故名中有。问余有亦在二有中间有自体起。三有所摄宁非中有。答若有居在二有中间。轻细难见难明难了立中有名。余有虽在二有中间。粗重易见易明易了不名中有。复次若有居在二有中间是界是生非趣所摄名为中有。余有虽在二有中间界生趣摄故非中有。复次若有居在二有中间。已舍前趣未至后趣说为中有。余有虽在二有中间而未舍前趣。或已至后趣故非中有。问何故中有名健达缚。答以彼食香而存济故。此名唯属欲界中有。问何故中有名求有耶。答于六处门求生有故。如住中有求后有心相续猛利。住余不尔。故独中有立求有名。问何故中有复名意成。答从意生故。谓诸有情或从意生。或从业生。或从异熟生。或从淫欲生从意生者。谓劫初人及诸中有。色无色界并变化身。从业生者。谓诸地狱。如契经说。地狱有情业所系缚不能免离。由业而生不由意乐。从异熟生者。谓诸飞鸟及鬼神等。由彼异熟势轻健故能飞行空。或壁障无碍。从淫欲生者。谓六欲天及诸人等。诸中有身从意生故。乘意行故名为意成

世尊经中作如是说。三事和合得入母胎。父母俱有染心和合。母身调适无病。是时及健达缚正现在前。此健达缚尔时二心展转现前入母胎藏。此中三事和合者。谓父及母并健达缚三事和合。父母俱有染心和合者。谓父及母俱起淫贪而共合会。母身调适无病。是时者。谓母起贪身心悦豫名身调适。持律者说。由母起贪身心浑浊。如春夏水浑浊而流。不能自持名身浑浊。母腹清净无风热痰互增逼切故名无病。由此九月或十月中任持胎子令不损坏。言是时者。谓诸母邑有秽恶事。月月恒有血水流出。此若过多由稀湿故不得成胎。此若太少由干稠故亦不成胎。若此血水不少不多不干不湿。方得成胎名为是时。是中有者入胎时故。谓母血水于最后时余有二滴。父精最后余有一滴展转和合方得成胎。及健达缚正现在前者。谓即中有此处现在前。非于余处非前非后。此健达缚尔时二心展转现前入母胎藏者。谓健达缚将入胎时于父于母爱恚二心展转现起方得入胎。若男中有将入胎时于母起爱于父起恚。作如是念。若彼丈夫离此处者我当与此女人交会。作是念已颠倒想生。见彼丈夫远离此处。寻自见与女人和合。父母交会精血出时。便谓父精是自所有。见已生喜而便迷闷。以迷闷故中有粗重。既粗重已便入母胎。自见己身在母右胁向脊蹲坐。尔时中有诸蕴便灭生有蕴生名结生已。若女中有将入胎时。于父起爱于母起恚。作如是念。若彼女人离此处者我当与此丈夫交会。作是念已颠倒想生。见彼女人远离此处。寻自见与丈夫和合。父母交会精血出时。便谓母血是自所有。见已生喜而便迷闷。以迷闷故中有粗重。既粗重已便入母胎。自见己身在母左胁向腹蹲坐。尔时中有诸蕴便灭生有蕴生名结生已。诸有情类多起如是颠倒想已而入母胎。唯除菩萨将入胎时。于父父想于母母想。虽能正知而于其母起亲附爱。乘斯爱力便入母胎。余随所应义如前说

问中有何处入于母胎。有作是说。中有无碍随所乐处而便入胎。问若中有身无能障碍如何依住此母胎中。答业力所拘故依此住。有情业力不可思议。无障碍物令有障碍。是故于此不应为难。应作是说。中有入胎必从生门是所爱故。由此理趣诸双生者后生为长。所以者何。先入胎者必后出故。问菩萨中有何处入胎。答从右胁入正知入胎于母母想无淫爱故。复有说者。从生门入诸卵胎生法应尔故。问轮王独觉先中有位何处入胎。答从右胁入正知入胎于母母想无淫爱故。复有说者。从生门入诸卵胎生法应尔故。有余师说。菩萨福慧极增上故将入胎时无颠倒想不起淫爱。轮王独觉虽有福慧非极增上。将入胎时虽无倒想亦起淫爱故。入胎位必从生门施设论说。若彼父母福业增上。子福业劣不得入胎。若彼父母福业劣薄。子福业胜不得入胎。要父母子三福业等方得入胎。问若富贵丈夫与贫贱女合。或富贵女人与贫贱男合。如何中有亦得入胎。答富贵男子与贫贱女人合时。必于自身起下劣想。于彼女人生尊胜想。富贵女人与贫贱男子合时。必于自身生下劣想。于彼男子起尊胜想。贫贱男子与富贵女人合时。必于自身生尊胜想。于彼女人起下劣想。贫贱女人与富贵男子合时。必于自身起尊胜想。于彼男子生下劣想。子于父母将入胎位应知亦然。故入胎时皆有等义

问中有微细一切墙壁山崖树等皆不能碍。此彼中有为相碍耶。有作是说。此彼中有亦不相碍。以极微细相触身时不觉知故。复有说者。此彼中有亦互相碍。以相遇时此彼展转有语言故。问若尔宁说中有无碍。答于余无碍非谓中有。问此彼中有皆相碍耶。答自类相碍非于余类。谓地狱中有但碍地狱中有。乃至天中有但碍天中有。有作是说。劣碍于胜以粗重故。胜不碍劣以细轻故。谓地狱中有碍五中有。傍生中有碍四中有。鬼界中有碍三中有。人中有碍二中有。天中有唯碍天中有

问神境通力与中有位诸有所行何者为疾。有作是言。中有行疾。所以者何。经说业力胜神通故。如是说者。神境通力行势迅速非诸中有。问若尔何故经说业力胜神境通。答依无障碍故作是说。不依行势。谓佛神通能碍一切有情神通。独觉神通除佛能碍诸余神通。舍利子神通除佛独觉能碍一切有情神通。大目干连神通除佛独觉及舍利子能碍一切有情神通。诸利根者神通能碍一切钝根者神通。无佛独觉一切声闻。及余有情咒术药物。能碍中有令不往趣应受生处。然必往彼随类结生。由此契经说诸业力胜神通力若依行势而作论者。应说神通胜于中有

问中有为能互相见不。答能互相见。问谁能见谁。有作是说。地狱中有唯见地狱中有。乃至天中有唯见天中有。有余师说。地狱中有唯见地狱中有。傍生中有见二中有。鬼界中有见三中有。人中有见四中有。天中有见五中有。复有说者。地狱中有见五中有。乃至天中有亦见五中有

问诸本有眼见中有不。有作是说。地狱傍生鬼人趣眼不见中有。唯天趣眼能见中有。问诸天趣眼谁能见谁。有作是说。四大王众天眼除自上处中有见下中有。乃至他化自在天眼除自上处中有见下中有。初静虑天眼除自上处中有见下中有。乃至第四静虑天眼除自上处中有见下中有。复有说者。欲界天眼不见中有。色界天眼能见中有。唯能见下不见自上。若作是说。无生得眼能见第四静虑中有。应作是说。住本有者诸生得眼皆无能见中有身者。唯极清净修得天眼能见中有。问云何知然。答契经说故。谓契经说。若男若女具净尸罗修诸善法。彼命终已得意成身。如白衣光或如明夜。极净天眼乃能见之。若男若女毁犯净戒作诸恶法。彼命终已得意成身。如黑羺光或如闇夜。极净天眼乃能见之。由此故知住本有者。诸生得眼皆无能见中有身者

毗奈耶说。度使魔罗伽诛药叉提婆达多毗卢宅迦。皆即此身陷入无间大地狱中受诸剧苦。问此等为受中有身不。答受中有身。然以迅速难可觉知故作是说。初一刹那死有蕴灭中有蕴生。后一刹那中有蕴灭生有蕴生。由此迅速难可觉知。有作是说。彼于佛等起重恶行。临命终时身极厚重。故此大地不能持彼。如油沃沙即便陷入。既入地已方乃命终。受中有身后生地狱。是故说彼皆即此身陷入无间大地狱中。依初陷时而作是说。有余师说。彼业猛利未及命终。无间地狱火焰上踊缠缚彼身牵入地狱。彼于中路方乃命终受中有身。后至地狱舍中有身方得生彼。依初去时而作是说。亦不违理

如契经说。尔时天帝即于佛前说伽他曰

  大仙应当知　　我即于此座
  还得天寿命　　唯愿尊忆持

问天帝尔时有死生不。设尔何失。二俱有过。所以者何。若有死生应受中有。如何时众恒见彼身。若无死生如何彼说还得天寿。答应作是说。彼无死生。问若尔善通前所设难。伽他所说当云何通。答依脱恶趣故作是说。谓佛为彼略说法要。彼见真谛得预流果。于诸恶趣毕竟解脱。随意所乐人天受生。故于佛前欢喜踊跃作诸爱语说此伽他。如人因他解脱牢狱。随意所乐欢娱游适。还至他所作如是言。我赖汝恩还得寿命。天帝亦尔。故不相违。复次彼依解脱见道所断诸烦恼病故作是说。谓佛为彼略说法要。令断一切见道所断诸烦恼病。安住第一无病圣道及道果中。故于佛前欢喜踊跃说此伽他。如人遇医重病得愈。随意受用诸饮食等。还至医所作如是言。我赖汝恩还得身命。天帝亦尔。故不相违。复次彼依获得四神足寿。故于佛前说如是颂。如契经说。苾刍当知。何等为寿。谓四神足。世尊为彼略说法要。令不起座得四神足。故于佛前欢喜踊跃。作诸爱语说此伽他。复次彼依获得慧命根故作如是说。如契经说。诸命根中慧命最胜。谓佛为彼略说法要。令得慧命故于佛前欢喜踊跃。作诸爱语说此伽他。问岂天帝释先无慧根。今闻法已方乃获得。答先虽有慧而是有漏。今得无漏故作是说。复次彼依解脱五种衰相故作是说。谓诸天中将命终位先有二种五衰相现。一小二大。云何名为小五衰相。一者诸天往来转动从严身具出五乐声。善奏乐人所不能及。将命终位此声不起。有说。复出不如意声。二者诸天身光赫弈昼夜恒照身无有影。将命终时身光微昧。有说。全灭身影便现。三者诸天肤体细滑入香池浴才出水时。水不着身如莲花叶。将命终位水便着身。四者诸天种种境界悉皆殊妙漂脱诸根。如旋火轮不得暂住。将命终位专著一境经于多时不能舍离。五者诸天身力强盛眼尝不瞬。将命终时身力虚劣眼便数瞬。云何名为大五衰相。一者衣服先净今秽。二者花冠先盛今萎。三者两腋忽然流汗。四者身体欻生臭气。五者不乐安住本座。前五衰相现已犹可转。后五衰相现已不可转。时天帝释已有五种小衰相现。不久当有大衰相现。心生忧怖作是念言。谁能救我如是衰厄我当归谁得免斯难。作是念已便自了知。除佛世尊无能救护。寻诣佛所求哀请救。佛为说法便得见谛。令彼衰相一时皆灭故于佛前欢喜踊跃。作诸爱语。说此伽他。诸有欲令顺现受业引众同分。彼作是说。天帝即于听法座上。更新引得命等八根。诸有欲令顺现受业不能引得众同分者。彼作是说。天帝即于听法座上除五衰相身位如本。由此理趣故无死生。有余师说。时天帝释亦有死生。问若尔善通伽他所说前所设难当云何通。谓有死生必受中有。如何时众恒见彼身。答一切天中本有中有皆是化生。诸化生者死无遗质中有迅速。故众不知天帝释身而有间断

问施设论说。天初生时如五岁等小儿形量。天怀膝上欻尔化生。彼天便谓是我男女。此新生天亦言。彼天是我父母。其量既小。如何时众皆见如本。答初生虽小生已寻大。时间迅速众不觉知。复有说者。众虽觉知而作是念。此天帝释神力自在。于世尊前自现神变。或大或小不谓死生。有余师说。非一切天于初生时身量皆小如帝释等。大威德天于初生时及中有位皆如本有盛年时量。故虽死生而众不觉。如是说者。彼无死生。故二说中初说为善。经死生者身心变故施设论说。劫初时人有忽腹行身形既变共号为蛇。复有欻然生第三牙。身形既变共号为象。问如是转变有死生不。设尔何失。二俱有过。所以者何。若有死生应受中有。如何众人不见间断。若无死生如何人趣即作傍生。答应作是说。彼无死生。问若尔善通前所设难。如何人趣即作傍生。答非即人趣转作傍生。但彼身形前后有异。于中有说。彼恒是人然宿业因兴衰不定。初福业胜故作人形。后时食恶谄曲增故。人形相灭变作傍生。如或有人被他咒术。变似驴等而实是人。复有说者彼是傍生。然彼适从极光净殁。乘宿恶业受傍生趣。前福余势初时似人。后时食恶谄曲增故。人形相灭复傍生形。如虾蟆身前后转变。前名科斗显黑形圆。后名虾蟆形方显杂。然彼前后俱是傍生。劫初变人应知亦尔。有余师说。彼有死生。问若尔善通后所设难。前所设难当云何通。谓有死生必受中有。如何众人不见间断。答劫初时人本有中有皆是化生。诸化生者死无遗质。中有迅速时人不知。彼所受身而有间断。如是说者。彼无死生故。二说中初说为善。经死生者多忘本事。既忆本事故非死生

说一切有部发智大毗婆沙论卷第七十阿毗达磨大毗婆沙论卷第七十一

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中十门纳息第四之一

二十二根。乃至九十八随眠。如是四十二章及解章义既领会已。应广分别。二十二根者。谓眼根耳根鼻根舌根身根女根男根命根意根乐根苦根喜根忧根舍根信根精进根念根定根慧根未知当知根已知根具知根。此广分别。如后根蕴根纳息中十八界者。谓眼界色界眼识界耳界声界耳识界鼻界香界鼻识界舌界味界舌识界身界触界身识界意界法界意识界。此界契经亦名略说亦名广说。名略说者。对大记经如大譬喻大涅槃等。名广说者。对处契经彼处契经。亦名略说亦名广说。名略说者对界契经名广说者。对蕴契经。彼蕴契经亦名略说亦名广说。名略说者对处契经。名广说者。对诸所有受皆是苦等经。彼诸所有受皆是苦等经。但名略说不名广说。有作是说。此界契经等亦名略说亦名广说。即依自说不对余经。谓界经中广说色心。略说心所故。彼处契经亦名略说亦名广说。即依自说不对余经。谓处经中广说色略说心心所故。彼蕴契经亦名略说亦名广说。即依自说不对余经。谓蕴经中广说心所。略说色心故。彼诸所有受皆是苦契经但名略说不名广说。复有说者。此界契经名为广说亦摄一切法。彼大譬喻大涅槃等经虽名广说而不摄一切法。彼处契经虽摄一切法而非广说。是处中说故。彼蕴契经不名广说。是略说故。亦不摄一切法。但摄有为非无为故。彼诸所有受皆是苦等经不名广说。是极略说故。于中亦有摄一切法者如说诸法空无我等。有余师说。更无略说契经。如世尊说施有二种。一者法施。二者财施经等。更无广说契经如大譬喻大涅槃经等。如是诸说虽各有义。然佛世尊于所知境。先作广说后作略说。谓于所知境先广说十八界。后即于此略说为十二处。复即于此除无为法略说为五蕴。是名世尊广略说法。即依如是广略说法。佛告尊者舍利子言。我于法宝能广略说。而能解者甚为难得。复依如是广略说法。尊者舍利子白佛言。世尊唯愿如来广略说法此定当有解法宝者。于如是事应作譬喻。如海龙王久处大海。增长威势上升虚空。兴布大云遍覆空界。掣电晃曜震大雷音。普告世间我当注雨。一切药草卉木丛林。闻如是声皆大惊慑咸作是念。此大龙王处大海中久增威势。今若注雨未有息期。我等皆当定为漂没。尔时大地闻如是声心不惊疑面无异色。虚怀仰请海龙王言。唯愿恣情降注大雨。过百千岁我悉能受。世尊亦尔。曾于过去释迦牟尼帝幢宝髻然灯胜观。乃至最后迦叶波佛所。增长福德智慧资粮。升有余依涅槃空界。兴大悲云遍覆世间。发胜慧电普照一切。虚空非我无畏雷音。遍告所化舍利子等。我于法宝能广略说。而能解者甚为难得。时诸所化除舍利子。闻佛此言皆生怯惧。咸作是念。佛得如是。昔所未得名句文身。为我等说恐不能解。唯舍利子六十劫中。增长智见猛利圆满犹如大地。闻佛此言心不惊疑。面无异色能无所畏。而请佛言。唯愿如来广略说法。此定当有解法宝者。问亦应有法非诸声闻独觉境界。彼舍利子何缘无畏作如是请。答彼唯请佛声闻所知非佛所知。声闻境界非佛境界。声闻所行非佛所行。声闻根所及非佛根所及故不违理。复次知佛开许故作是请。谓舍利子作如是念。世尊慈悲诸所说法。必应称量定有饶益。要于田器而雨法雨。所雨法雨终不唐捐。诸所发言必依法器。若非法器终不发言。世尊既知我有尔所堪受法器。作如是言。故知世尊开许我请。是故尊者请佛无畏

问佛为何等所化有情。说蕴处界广略三法。答佛随所化所愚而说。谓愚于界者为说十八界。若愚于处者为说十二处。若愚于蕴者为说五蕴。复次世尊所化略有三种。一初习业。二已串修。三超作意初习业者为说十八界。已串修者为说十二处。超作意者为说五蕴。复次世尊所化有三种根。谓钝中利为钝根者说十八界。为中根者说十二处。为利根者说五蕴。复次世尊所化有三种智。一者开智。二者说智。三者引智。为开智者说五蕴。为说智者说十二处。为引智者说十八界。复次世尊所化有三种乐。谓广中略。为乐广者说十八界。为乐中者说十二处。为乐略者说五蕴。复次世尊所化有三憍逸。一恃姓憍逸。二恃财憍逸。三恃命憍逸。恃姓憍逸者为说十八界。谓族姓义是界义。种类贵贱无差别故。恃财憍逸者为说十二处。谓生门义是处义。随有所生寻散尽故。恃命憍逸者为说五蕴。谓积聚义是蕴义。有为积聚寻散灭故。复次世尊所化有三种愚。一者愚色心。二者愚于色。三者愚心所。愚色心者为说十八界。于此界中广说色心略说心所故。愚于色者为说十二处。于此处中广说色略说心心所故。愚心所者为说五蕴。于此蕴中广说心所略说色心故。复次为计我者说十八界。谓一身中有多界别无一我故为愚所依及所缘者说十二处。谓分别识有六所依六所缘故。为我慢者说五蕴。谓身唯有生灭五蕴不应恃怙起我慢故。佛为此等所化有情说蕴处界广略三法

问此十八界名有十八。实体有几。答此界实体或有十七或有十二。若说六识便失意界。离六识身无别意界。故十八界名有十八实体十七。若说意界便失六识。离此意界无别六识。故十八界名有十八实体十二。如名与体。名施设体施设。名异相体异相。名异性体异性。名差别体差别。名建立体建立。名觉体觉。应知亦尔。问若十八界名有十八。体或十七或十二者云何建立十八界耶。答以三事故建立十八。一以所依。二以能依。三以境界。以所依故立六内界。谓眼界乃至意界。以能依故立六识界。谓眼识界乃至意识界。以境界故立六外界。谓色界乃至法界。问若以所依能依境界各有六故。立十八界有差别者。诸阿罗汉最后念心应非意界。依彼不能生后识故。答彼亦是意界依彼不能生后识者非彼为障。但余缘障故后识不起。设后起者亦作所依。如有余缘不生芽等。岂沃壤地非芽等依。此十八界过去未来现在皆具。问过去可有此十八界。以六识身无间已灭名意界故。未来现在如何亦有十八界耶。答此十八界依相而立。三世各有十八界相。若未来现在识无意界相者。过去识亦应无以相无转故

问等无间缘未来未有。现在过去亦应不立。此既得立。意界应然。答等无间缘依用而立。未来未有等无间法故不可立等无间缘。设立于谁有此缘用。此十八界依相而立。未来虽无识所依用。而已有识可立所依。故此与彼不可为例。诸阿罗汉最后念心。虽非等无间缘而是意界准此应知。余契经中世尊自说恶叉聚喻。说此喻已告诸苾刍。有情身中有多界性。彼亦摄在此十八界。所依能依境界摄故。又佛于彼多界经中说界差别有六十二。彼亦摄在此十八界。即所依等三事摄故。问何故世尊为众说彼六十二界。答为对外道身见为本。有六十二见趣别故。又世尊告天帝释言。憍尸迦当知。世有种种界。随各所想。而各执着。随各执着而各说之。各言此实余皆愚妄。彼亦摄在此十八界。即所依等三事摄故。有作是说。彼经诸见以界声说。皆唯摄在此法界中。尊者左受作如是说。以四事故立十八界。一自性故。二所作故。三能作故。四蕴差别故。以自性故建立色界乃至法界。以所作故建立眼识界乃至意识界。以能作故建立眼界乃至意界。以蕴差别故建立十八界。谓色蕴差别建立十界一界少分。识蕴差别建立七心界。三蕴摄在一法界中。如是名为诸界自性。我物自体相分本性已说界自性所以今当说。问何故名界。界是何义。答种族义是界义。段义分义片义异相义不相似义分齐义是界义。种种因义是界义。声论者说驰流故名界。任持故名界。长养故名界。应知此中种族义是界义者。如一山中有多种族。谓金银铜铁白镴铅锡丹青等石。白墡土等异类种族。如是于一相续身中。有十八界异类种族。段义是界义者。如有次第安布段物得种种名。谓次第安布材木等段。名为宫殿台观舍等。次第安布余甘子等段名阿摩洛迦。次第安布竹篾等段名盖扇等。次第安布骨肉等段名男女等。如是次第安布眼等。十八界段名为有情摩纳婆等。分义是界义者。谓男身中有十八分。女等亦尔。即十八界。片义是界义者。谓男身中有十八片。女等亦尔。即十八界。异相义是界义者。谓眼界相异乃至意识界相异。不相似义是界义者。谓眼界不似余界。乃至意识界不似余界。分齐义是界义者。谓眼界分齐异余十七界。乃至意识界分齐异余十七界。种种因义是界义者。谓因此故有眼界非即因此乃至有意识界。乃至因此故有意识界非即因此乃至有眼界。声论者说。驰流故名界者。谓此诸界驰流三界五趣四生轮转生死。任持故名界者。谓此诸界任持自性。长养故名界者。谓此诸界长养他性。是故种族义是界义。乃至长养故名为界

已总说界立名所因。今当一一别说其相。问眼界云何。答诸眼于色已正当见。及彼同分是名眼界。已见色者。谓过去眼。正见色者。谓现在眼。当见色者。谓未来眼。及彼同分者。此国诸师说有四种。一者过去彼同分眼。谓眼界不见色已灭。二者现在彼同分眼。谓眼界不见色正灭。三者未来彼同分眼。为眼界不见色当灭。四者未来毕竟不生眼界。外国诸师说有五种三如前说。未来毕竟不生眼界分为二种。一有识属眼界。二无识属眼界。旧外国师同此国说。旧此国师同外国说。诸见色眼于自有情名同分眼。于余有情亦名同分。诸不见色眼于自有情名彼同分眼。于余有情亦名彼同分。有作是说。诸见色眼于自有情名同分眼。于余有情名彼同分。诸不见色眼于自有情名彼同分眼。于余有情亦名彼同分。复有说者。诸见色眼于自有情名同分眼。于余有情非同分亦非彼同分。诸不见色眼于自有情名彼同分眼。于余有情非同分亦非彼同分。彼不应作是说。云何有眼而非同分非彼同分。应作是说。于三说中初说应理。问岂用他眼能见色耶。答谁说能用他眼见色。问若无能用他眼见色。如何有情自见色眼于余有情亦名同分。答以有用眼根恒定故。眼界用者。谓能见色。如眼于色有用已灭说为同分。于自于他此同分名恒无改转。虽无能用他眼见色。而有用眼恒名同分。正灭当灭应知亦尔。问同分眼能见色。彼同分眼不能见色。云何见色眼是不见色眼之同分。不见色眼是彼见色眼之同分耶。答彼此二眼互为因故。谓见色眼与不见色眼为因。不见色眼亦与见色眼为因。复次彼此二眼互相生故。谓见色眼能生不见色眼。不见色眼复能生见色眼。复次彼此二眼互相引故。谓见色眼能引不见色眼。不见色眼复能引见色眼。复次彼此二眼互相转故。谓见色眼能转不见色眼。不见色眼复能转见色眼。复次彼此二眼互相续故。谓见色眼能续不见色眼。不见色眼复能续见色眼。复次见色眼与不见色眼。俱一界摄。俱一处摄。俱一根摄。同一见性故。见色眼是不见色眼之同分。不见色眼复是彼见色眼之同分。如眼界耳鼻舌身界亦尔。同分彼同分品类差别皆相似故

问色界云何。答诸色为眼已正当见及彼同分是名色界。已所见者。谓过去色。正所见者。谓现在色。当所见者。谓未来色。及彼同分者。谓有四种彼同分色。一者过去彼同分色。谓色界不为眼所见已灭。二者现在彼同分色。谓色界不为眼所见正灭。三者未来彼同分色。谓色界不为眼所见当灭。四者未来毕竟不生色界。或有色界于一有情是同分。于二三四乃至百千诸有情等亦是同分。谓此色界是一有情眼所见。亦是二三四乃至百千诸有情等眼所见故。如百千人同观初月。然此色界于诸缘彼生眼识者名同分。于不缘彼生眼识者名彼同分。又如众中有一伎女。形容端正众具庄严。诸有缘之起眼识者彼色界名同分。诸有不缘起眼识者即彼色界名彼同分。又如法师升座说法。言辞清辩形貌端严。诸有缘之起眼识者彼色界名同分。诸有不缘起眼识者即彼色界名彼同分。或有色界于一有情名彼同分。于二三四乃至百千诸有情等亦名彼同分。谓彼色界在隐映处。无量有情不能见故。或有色界一切有情眼所不见。即彼色界于一切时名彼同分。如妙高山中心之色。及大地中大海下色。一切有情无有见者。问彼色岂非天眼境界。答彼色虽是天眼境界。而无用故此不观之。复次非一切时天眼现起。故有彼色天眼不见。问彼色岂非佛眼境界。答彼色虽是佛眼境界。而无用故佛不观之。复次非一切时有佛出世。如今无佛既无佛眼故。有彼色非佛眼见

问何故见色眼于自有情名同分。于余有情亦名同分。而所见色于见者名同分。于不见者名彼同分耶。答容一色界多有情见。无一眼界二有情用故。谓有色界一有情见。容二三四乃至百千有情亦见是共见故。诸有见者此色界于彼名同分诸不见者此色界于彼名彼同分。无一眼界二有情用。况多有情是不共故。诸用此眼能见色者此眼于彼名同分。诸余有情眼若见色若不见色。此眼于彼亦名有作用。眼既是不共。于一切时相恒定故。如色界声香味触界亦尔。同分彼同分品类差别皆相似故。然于此义或有欲令唯嗅尝觉各自身中诸香味触。彼作是说。香味触界依世俗理如色界说。谓诸世间作如是语。汝所嗅香我等亦嗅。汝所尝味我等亦尝。汝所觉触我等亦觉。依胜义理香味触界如眼界说。谓一有情所嗅香界余不能嗅。若一有情所尝味界余不能尝。若一有情所觉触界余不能觉。问若一触界二有情身各在一边共所逼触。岂非胜义如色界说。答如是触界有多极微和集一处。二身逼触各得一边无共得者。故胜义理如眼界说。香味触界准此应知。复有欲令亦嗅尝觉他及非情诸香味触。彼作是说。香味触界若已受用及受用时。依世俗理如色界说。谓诸世间说共得故。依胜义理如眼界说。一所受用余不得故。若未受用香味触界。依胜义理亦有共得如色界说义。谓在未来当至现在。有多人等共得义故。若依前义应作是说。香味触界依世俗理如色界说。依胜义理如眼界说。若依后义应作是说。香味触界若已受用及受用时。依世俗理如色界说。依胜义理如眼界说。若未受用依胜义理。亦可得言如色界说。是故诸论皆作是说。如色界声香味触界亦尔。以香味触可共得故

问眼识界云何。答眼及色为缘所生眼识是名眼识界。问眼识生时除自性余一切法皆作缘。何故但眼色为缘。答此中且说增胜缘故。谓若法是眼识所依所缘者。此中说之眼。是眼识所依色是眼识所缘。是故偏说。余法不尔。复次若法是眼识近增上缘者此中说之眼。及色与眼识作近增上缘。胜眼识上生住异灭。是故偏说。复次若法是眼识不共胜缘者此中说之眼。及色与眼识作不共胜缘。胜眼识生住异灭。是故偏说。问眼识亦以色为缘生。何故名眼识不名色识耶。答亦有经说此名色识。如说。色界为缘生色识。乃至法界为缘生法识。问但有一经作如是说。余一切经皆说眼识。如何不说名色识耶。答眼是内故但名眼识。色是外故不名色识。复次眼是所依故但名眼识。色是所缘故不名色识。复次眼是根故但名眼识。色是根义故不名色识。复次眼是有境故但名眼识。色是境故不名色识。复次眼是不共故但名眼识。色是共故不名色识。复次诸立名者皆就所依显所立名有差别故。眼是识所依根故但名眼识。乃至意是意识所依根故但名意识。如声唯就所依立名。显所立名有差别故。如依鼓起但名鼓声。若依贝起但名贝声。依箜篌等应知亦尔。问眼等六识皆依意生。何缘前五不名意识。答若法是识不杂不共不乱所依识名依。彼眼是眼识不杂不共不乱所依故名眼识。广说乃至身是身识不杂不共不乱所依故名身识。意是五识杂共乱依。是故前五不名意识。问若尔。意识亦应不说名意识耶。答意识更无不杂不共不乱所依如前五识。是故但说名为意识。以是因缘应作四句。有法是眼识所依非等无间缘。谓俱生眼。有法是眼识等无间缘非所依。谓无间已灭诸心所法。有法是眼识所依亦是等无间缘。谓无间已灭意界。有法非眼识所依亦非等无间缘。谓除前相。乃至身识四句亦尔。若法是意识所依亦是等无间缘。有法是意识等无间缘而非所依。谓无间已灭诸心所法。尊者世友亦作是说。眼识亦以色为缘生。何缘眼识不名色识。答眼是眼识所依。色不尔故。复次眼是眼识胜缘。色不尔故。复次眼唯堕自相续。色不定故。复次眼唯在近。色不定故。复次眼唯在内。色不定故。复次眼是不共。色不尔故。复次眼唯有执受。色不定故。复次眼有损益。识随损益。色不尔故。问色若有损益识亦随损益。若无色者眼识不生亦应名色识。何缘但说名眼识耶。答此不应例。所以者何。有眼根者。虽一色坏更缘余色眼识可生。若无眼根。虽有多色恒现在转眼识不生。是故眼识损益随根不随于色。复次眼有下中上识随下中上。色不尔故。复次眼是不共。色不定故。有缘一界色生二界眼识。无依一界眼生二界眼识故。有缘一趣色生五趣眼识。无依一趣眼生二趣眼识。况有多故。有缘一生色生四生眼识。无依一生眼生二生眼识。况有多故。复次眼是眼识胜增上缘。色不尔故。大德说曰。若眼有留难识亦有留难。若眼无留难识亦无留难。故名眼识不名色识。问若色有留难眼识亦有留难。无所缘色眼识不生故。答色有众多。眼唯有一。不应为例。谓若有眼虽一色坏而缘第二眼识得生。若第二坏缘第三色眼识得生余坏缘余生识亦尔。若一身中眼根坏者。设有无量那庾多色正现在前。缘彼眼识皆不得生。是故眼识不名色识。乃至身识应知亦尔。问有契经言。眼所识色此有何意。诸色但是眼识所识。眼根不能了别色故。答彼于所依显能依事。故不违理。谓佛世尊或于所依显能依事。或于能依显所依事。于所依显能依事者。如彼经言眼所识色。于能依显所依事者。如有处说。眼识所受眼识所了说名所见。复次彼经应言眼识所识色。诵者错谬故彼但言眼所识色。复次彼经应言眼识所识色。略去中间故但说眼所识色。如说牛车择灭等故。复次彼契经中依胜具说。故不违理。如伎染书依胜具说。此亦如是。如作伎乐时。虽有乐具及诸子女并余助伴。而伎乐主偏得其名。是胜具故。又如染衣等时。非无水器染师助伴。而彼染色偏得其名。是胜具故。又如书时。非无水墨盛贮墨器及人叶等。而笔胜故偏得其名。此亦如是。虽识色时有多识具谓空明等。而眼胜故偏得其名。故彼经说眼所识色。复次眼是识色所依止故。彼契经言眼所识色。如言道路是商侣等所应行处。然彼道路但是脚足所应行处。彼商侣等是彼脚足所依止故偏得其名。此亦如是。如眼识界。耳鼻舌身识界亦尔。缘生立名释通经义皆相似故。问意界云何。答诸意于法已正当了。及彼同分是名意界。已了法者谓过去意界。正了法者谓现在意界。当了法者谓未来意界。及彼同分者谓未来毕竟不生意界。无有过去现在意界是彼同分。心心所法必托所缘方能起故。由此未来当生意界亦必是同分。问意界若缘十七界起是同分不。答亦是同分。如眼界等有见等用必是同分。意界亦尔。有了用者即名同分

问法界云何。答诸法为意已正当了是名法界。已为意了者。谓诸法界已为过去意界所了。正为意了者。谓诸法界正为现在意界所了。当为意了者。谓诸法界当为未来意界所了。问法界为有彼同分不。答无。所以者何。以无有法非去来今无量意识所了别故。有意识起一刹那中。唯除自性相应俱有。了别所余一切法故。问余十七界亦是意识所了别境。应皆是同分。便无彼同分。如何说有彼同分耶。答余十七界不依意识立为同分及彼同分。但依各别根境相对。谓眼对色色对眼。乃至身对触触对身。问若尔。意界及意识界唯应对法界立同分彼同分。是则缘余十七界者应非同分。答理应如是。然以意界及意识界能通了别一切法故。依自作用立为同分。如眼等根有见等用。必不立为彼同分故。有余师说。法界总摄一切法尽。以十七界亦名法故无斯过失。彼不应作是说法名虽通而法界别故。由此前说于理为善。此中应作颇设问答。颇有俱有法有是同分。有是彼同分耶。答有。谓彼同分十七界上生住异灭。法界摄故恒名同分。颇有相应俱有法。有是同分有是彼同分耶。答有。谓未来不生意界意识界等是彼同分。彼相应心所法及彼随转色。不相应行法界摄故恒名同分

说一切有部发智大毗婆沙论卷第七十一阿毗达磨大毗婆沙论卷第七十二

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中十门纳息第四之二

问意识界云何。答意及法为缘所生意识是名意识界。此中问答分别如眼识界应知。问何缘六识界不说彼同分。答应说而不说者。当知此义有余。复次六识界是生所显。依生建立彼同分心。是不生故唯说同分。复次六识界是用所显。依用建立彼同分心。无作用故唯说同分。复次六识界皆是意界摄。已说意界有彼同分。应知即已说六识界。故不复说。问若尔。不应立六识界。此六即是意界摄故。答虽即意界而为建立。根境识三各有六故复别说有六识差别问诸契经中说心意识。如是三种差别云何。或有说者。无有差别。心即是意意即是识。此三声别义无异故。如火。名火亦名焰顶。亦名炽然。亦名生明。亦名受祀。亦名能熟。亦名黑路。亦名钻息。亦名烟幢。亦名金相。如是一火有十种名。声虽有异而体无别。如天帝释亦名铄羯罗。亦名补烂达罗。亦名莫伽梵。亦名婆飒缚。亦名憍尸迦。亦名设芝夫。亦名印达罗。亦名千眼。亦名三十三天尊。如是一主有十种名。声虽有异而体无别。如对法中说受名受。亦名等受。亦名别受。亦名觉受。亦名受趣。如是一受有五种名。声虽有异而体无别。故契经说心意识三。声虽有异而无差别。复有说者。心意识三亦有差别。谓名即差别。名心名意名识异故。复次世亦差别。谓过去名意。未来名心。现在名识故。复次施设亦有差别。谓界中施设心。处中施设意。蕴中施设识故。复次义亦有差别。谓心是种族义。意是生门义。识是积聚义。复次业亦有差别。谓远行是心业。如有颂曰

  能远行独行　　无身寐于窟
  调伏此心者　　解脱大怖畏

前行是意业。如有颂曰

  诸法意前行　　意尊意所引
  意染净言作　　苦乐如影随

续生是识业。如契经说。入母胎时识若无者。羯刺蓝等不得成就。故知续生是识业用。复次彩画是心业。如契经说。苾刍当知。诸傍生趣由心彩画。有种种色。归趣是意业。如契经说。苾刍当知。如是五根各别所行各别境界。意根总领受彼所行境界。意归趣彼作诸事业。了别是识业。如契经说。苾刍当知。识能了别种种境事。复次滋长是心业。思量是意业。分别是识业。胁尊者言。滋长分割是心业。思量思惟是意业。分别解了是识业。应知此中滋长者是有漏心。分割者是无漏心。思量者是有漏意。思惟者是无漏意。分别者是有漏识。解了者是无漏识。心意识三是谓差别

问眼色眼识界。为必同系。为亦有异系耶。答如是三种或有同系或有异系。云何同系。谓生欲界以欲界眼见欲界色时。彼欲界眼欲界色生欲界眼识。即彼以初静虑眼见初静虑色时。彼初静虑眼初静虑色生初静虑眼识。若生初静虑以初静虑眼见初静虑色时。彼初静虑眼初静虑色生初静虑眼识。是名同系云何异系。谓生欲界以初静虑眼见欲界色时。彼初静虑眼欲界色生初静虑眼识。即彼以第二静虑眼见欲界色时。彼第二静虑眼欲界色生初静虑眼识。见初静虑色时。彼第二静虑眼初静虑色生初静虑眼识。见第二静虑色时。彼第二静虑眼第二静虑色生初静虑眼识。即彼以第三静虑眼见欲界色时。彼第三静虑眼欲界色生初静虑眼识。见初静虑色时。彼第三静虑眼初静虑色生。初静虑眼识。见第二静虑色时。彼第三静虑眼第二静虑色生初静虑眼识。见第三静虑色时。彼第三静虑眼第三静虑色生初静虑眼识。即彼以第四静虑眼见欲界色时。彼第四静虑眼欲界色生初静虑眼识。见初静虑色时。彼第四静虑眼初静虑色生初静虑眼识。见第二静虑色时。彼第四静虑眼第二静虑色生初静虑眼识。见第三静虑色时。彼第四静虑眼第三静虑色生初静虑眼识。见第四静虑色时。彼第四静虑眼。第四静虑色。生初静虑眼识。若生初静虑。以初静虑眼见欲界色时。彼初静虑眼。欲界色生初静虑眼识。所余广说如生欲界。若生第二第三第四静虑。广说随相应知。颇有异系眼异系色。生异系眼识耶答有。谓以第二静虑眼见欲界色时。彼第二静虑眼欲界色生初静虑眼识。以第三静虑眼见欲界色时。彼第三静虑眼欲界色生初静虑眼识。见第二静虑色时。彼第三静虑眼第二静虑色生初静虑眼识。以第四静虑眼见欲界色时。彼第四静虑眼欲界色生初静虑眼识。见第二静虑色时。彼第四静虑眼第二静虑色生初静虑眼识。见第三静虑色时。彼第四静虑眼第三静虑色生初静虑眼识。如是三种各异地系。是谓眼色识同系异系义。问身眼色眼识界为必同系。为亦有异系耶。答如是四种或有同系或有异系。云何同系。谓生欲界以欲界眼见欲界色时。彼欲界身欲界眼欲界色生欲界眼识。若生初静虑以初静虑眼见初静虑色时。彼初静虑身初静虑眼初静虑色生初静虑眼识。是谓同系。云何异系。谓生欲界以初静虑眼见欲界色时。彼欲界身初静虑眼欲界色生初静虑眼识。见初静虑色时。彼欲界身初静虑眼初静虑色生初静虑眼识。即彼以第二静虑眼见欲界色时。彼欲界身第二静虑眼欲界色生。初静虑眼识。见初静虑色时。彼欲界身第二静虑眼识静虑色生初静虑眼识。见第二静虑色时。彼欲界身第二静虑眼第二静虑色生初静虑眼识。即彼以第三静虑眼见欲界色时。彼欲界身第三静虑眼欲界色生初静虑眼识。见初静虑色时。彼欲界身第三静虑眼初静虑色生初静虑眼识。见第二静虑色时。彼欲界身第三静虑眼第二静虑色生初静虑眼识。见第三静虑色时。彼欲界身第三静虑眼第三静虑色生初静虑眼识。即彼以第四静虑眼见欲界色时。彼欲界身第四静虑眼欲界色生初静虑眼识。见初静虑色时。彼欲界身第四静虑眼初静虑色生初静虑眼识。见第二静虑色时。彼欲界身第四静虑眼第二静虑色生初静虑眼识。见第三静虑色时彼欲界身第四静虑眼第三静虑色生初静虑眼识。见第四静虑色时。彼欲界身第四静虑眼第四静虑色生初静虑眼识。若生初静虑。以初静虑眼见欲界色时。彼初静虑身初静虑眼欲界色生初静虑眼识。即彼以第二静虑眼见欲界色时。彼初静虑身第二静虑眼欲界色生初静虑眼识。见初静虑色时。彼初静虑身第二静虑眼初静虑色生初静虑眼识。见第二静虑色时。彼初静虑身第二静虑眼第二静虑色生初静虑眼识。即彼以第三静虑眼见欲界色时。彼初静虑身第三静虑眼欲界色生初静虑眼识。见初静虑色时。彼欲界身第三静虑眼初静虑色生初静虑眼识。见第二静虑色时。彼初静虑身第三静虑眼第二静虑色生初静虑眼识。见第三静虑色时。彼初静虑身第三静虑眼第三静虑色生初静虑眼识。即彼以第四静虑眼见欲界色时。彼初静虑身第四静虑眼欲界色生初静虑眼识。见初静虑色时。彼初静虑身第四静虑眼初静虑色生初静虑眼识。见第二静虑色时。彼初静虑身第四静虑眼第二静虑色生初静虑眼识。见第三静虑色时。彼初静虑身第四静虑眼第三静虑色生初静虑眼识。见第四静虑色时。彼初静虑身第四静虑眼第四静虑色生初静虑眼识。如生初静虑。生第二第三第四静虑。广说随相应知。有差别者。若生第二静虑应一切时说第二静虑身。若生第三静虑应一切时说第三静虑身。若生第四静虑应一切时说第四静虑身

颇有异系身异系眼异系色生异系眼识耶。答有。谓生欲界以第三静虑眼见第二静虑色时。彼欲界身第三静虑眼第二静虑色生初静虑眼识。即彼以第四静虑眼见第二静虑色时。彼欲界身第四静虑眼第二静虑色生初静虑眼识。见第三静虑色时。彼欲界身第四静虑眼第三静虑色生初静虑眼识。若生第二静虑。以第三静虑眼见欲界色时。彼第二静虑身第三静虑眼欲界色生初静虑眼识。即彼以第四静虑眼见欲界色时。彼第二静虑身第四静虑眼欲界色生初静虑眼识。见第三静虑色时。彼第二静虑身第四静虑眼第三静虑色生初静虑眼识。若生第三静虑以第四静虑眼见欲界色时。彼第三静虑身第四静虑眼欲界色生初静虑眼识。见第二静虑色时。彼第三静虑身第四静虑眼第二静虑色生初静虑眼识。如是四种各异地系。是谓身眼色识同系异系义。如说眼界色界眼识界及与身同系异系。如是耳界声界耳识界及与身同系异系广说随相应知

问鼻香鼻识界。为必同系。为亦有异系耶。答如是三种唯有同系。谓欲界鼻欲界香生欲界鼻识。虽有余系鼻而无香鼻识。故此不说

问身鼻香鼻识界为必同系。为亦有异系耶。答如是四种唯有同系。谓欲界身欲界鼻欲界香生欲界鼻识。虽有余系身及鼻界而无香鼻识故此不说。如鼻界香界鼻识界及与身唯同系。如是舌界味界舌识界及与身唯有同系。广说随相应知

问身触身识界为必同系。为亦有异系耶。答如是三种。或有同系或有异系。云何同系。谓生欲界彼欲界身欲界触生欲界身识。若生初静虑彼初静虑身初静虑触生初静虑身识。是谓同系。云何异系。谓生第二静虑彼第二静虑身第二静虑触生初静虑身识。若生第三静虑彼第三静虑身第三静虑触生初静虑身识。若生第四静虑彼第四静虑身第四静虑触生初静虑身识。是谓异系身触必无异地系义。以根境合方生识故。根境粗细必相似故。此中无四相对同异身界无别所依身故

问意法意识界。为必同系。为亦有异系耶。答如是三种。或有同系或有异系。云何同系。谓欲界意欲界法生欲界意识。乃至非想非非想处意。非想非非想处法。生非想非非想处意识。是谓同系。云何异系。有作是说。欲界善心无间唯有未至定现在前。未至定无间欲界善心现在前。或有说者。欲界善心无间有未至定或初静虑现在前。彼二无间欲界善心现在前。复有说者。欲界善心无间有未至定或初静虑或静虑中间现在前。彼三无间欲界善心现在前。尊者妙音作如是说。欲界善心无间有未至定或初静虑或静虑中间或第二静虑现在前。彼四无间欲界善心现在前。如超定时初静虑等无间超第二静虑等而第三静虑等现在前故。评曰。彼不应作是说。定不定心相生异故。应作是说。欲界善心无间有未至定或初静虑现在前。彼二无间欲界善心现在前。彼无间势力唯能至此故。谓欲界善心无间或未至定或初静虑现在前时。彼欲界意初静虑地意识法。或三界系或不系。彼二无间欲界善心现在前时。彼初静虑地意欲界意识法。或三界系或不系。初静虑无间顺次入第二静虑时。彼初静虑意第二静虑意识法。或三界系或不系。第二静虑无间逆次入初静虑时。彼第二静虑意初静虑意识法。或三界系或不系。第二静虑无间顺次入第三静虑时。彼第二静虑意第三静虑意识法。或三界系或不系。第三静虑无间逆次入第二静虑时。彼第三静虑意第二静虑意识法。或三界系或不系。第三静虑无间顺次入第四静虑时。彼第三静虑意第四静虑意识法。或三界系或不系。第四静虑无间逆次入第三静虑时。彼第四静虑意第三静虑意识法。或三界系或不系。第四静虑无间顺次入空无边处时。彼第四静虑意空无边处意识法。或无色界系或不系。空无边处无间逆次入第四静虑时。彼空无边处意第四静虑意识法。或三界系或不系。空无边处无间顺次入识无边处时。彼空无边处意识无边处意识法。或识无边处系或无所有处系。或非想非非想处系。或不系。识无边处无间逆次入空无边处时。彼识无边处意空无边处意识法。或无色界系或不系。识无边处无间顺次入无所有处时。彼识无边处意无所有处意识法。或无所有处系。或非想非非想处系。或不系。无所有处无间逆次入识无边处时。彼无所有处意识无边处意识法。或识无边处系或无所有处系。或非想非非想处系。或不系。无所有处无间顺次入非想非非想处时。彼无所有处意非想非非想处意识法。或非想非非想处系。或不系。非想非非想处无间逆次入无所有处时。彼非想非非想处意无所有处意识法或无所有处系。或非想非非想处系。或不系。初静虑无间顺超入第三静虑时。彼初静虑意第三静虑意识法。或三界系或不系。第三静虑无间逆超入初静虑时。彼第三静虑意初静虑意识法。或三界系。或不系。乃至识无边处无间顺超入非想非非想处时。彼识无边处意非想非非想处意识法。或非想非非想处系。或不系。非想非非想处无间逆超入识无边处时。彼非想非非想处意识无边处意识法。或识无边处系。或无所有处系。或非想非非想处系。或不系。余地随相皆应广说

如是。已说顺逆入定。次复应说入定定果。此中定果者。十四变化心。谓欲界初静虑各有四。第二静虑有三。第三静虑有二第四静虑有一。且欲界有四变化心者。谓初静虑果乃至第四静虑果。此四变化心无间净四静虑现在前。净四静虑无间此四变化心现在前。欲界初静虑果变化心无间。净初静虑现在前时。彼欲界意初静虑意识法。或三界系或不系。净初静虑无间。欲界初静虑果变化心现在前时。彼初静虑意欲界意识法。即所变化或四处或二处。如是乃至欲界第四静虑果变化心无间。净第四静虑现在前时。彼欲界意第四静虑意识法。或三界系或不系净第四静虑无间。欲界第四静虑果变化心现在前时。彼第四静虑意欲界意识法。即所变化或四处或二处。余十静虑果变化心对净静虑广说随相应知

如是已说入定定果。次复应说命终受生。谓欲界殁生初静虑时。彼欲界意初静虑意识法。或上八地系。或不系。初静虑殁生欲界时。彼初静虑意欲界意识法。或三界系。或不系。欲界殁乃至生非想非非想处时。彼欲界意非想非非想处意识法。或非想非非想处系或不系。非想非非想处殁乃至生欲界时。彼非想非非想处意欲界意识法。或三界系。或不系。乃至无所有处殁生非想非非想处时。彼无所有处意非想非非想处意识法。或非想非非想处系。或不系。非想非非想处殁生无所有处时。彼非想非非想处意无所有处意识法。或无所有处系或非想非非想处系。或不系。是谓异系。此中无四相对同异。以意界等通在九地。不必依止色身起故

问此六识身几有分别。几无分别。答前五识身唯无分别。第六识身或有分别。或无分别。且在定者皆无分别。不在定者容有分别。计度分别遍与不定意识俱故。此中且说眼识后起分别意识

问以欲界眼见欲界色。及以色界眼见欲色界色时。于彼色起几种眼识。此后于彼复起几种分别意识。答已断善根者眼见色时。于彼色起二种眼识。谓染污无覆无记。此后于彼复起三种分别意识。谓善染污无覆无记。不断善根者若诸异生未离欲界染。眼见色时于彼色起三种眼识。谓善染污无覆无记。此后于彼复起欲界三种分别意识。谓善染污无覆无记。即彼若生欲界已离欲界染。未离初静虑染。以欲界眼见诸色时。于彼色起二种眼识。谓除染污。此后于彼复起分别意识。若退法者。欲界三种。初静虑二种。不退法者。欲界初静虑各二种。谓除染污。即彼以初静虑眼见欲界色时。于彼色起无覆无记眼识。此后于彼复起分别意识。初静虑二种除染污。欲界若退法者三种。不退法者二种。见初静虑色时。于彼色起无覆无记眼识。此后于彼复起分别意识。初静虑三种。欲界若退法者二种。除无记。不退法者唯善。即彼已离初静虑染。未离第二静虑染。以初静虑眼见欲界色时。于彼色起无覆无记眼识此后于彼复起分别意识。若退法者。欲界三种初静虑二种。不退法者欲界二种。初静虑唯善。见初静虑色时。于彼色起无覆无记眼识。此后于彼复起分别意识。若退法者。欲界二种。初静虑三种。不退法者。欲界初静虑各唯善。即彼以第二静虑眼见欲界色时。于彼色起无覆无记眼识。此后于彼复起分别意识。若退法者。欲界三种。前二静虑各二种。不退法者。欲界第二静虑各二种。初静虑唯善。见初静虑色时。于彼色起无覆无记眼识。此后于彼复起分别意识。若退法者。欲界第二静虑各二种。初静虑三种。不退法者欲界初静虑各唯善。第二静虑二种。见第二静虑色时。于彼色起无覆无记眼识。此后于彼复起分别意识。若退法者欲界初静虑各二种第二静虑三种。不退法者。欲界初静虑各唯善。第二静虑三种。即彼已离第二静虑染。未离第三静虑染。以初静虑眼见欲界色时。于彼色起无覆无记眼识。此后于彼复起分别意识。若退法者。欲界三种。前三静虑各二种。不退法者。欲界及第三静虑各二种。前二静虑各唯善。见初静虑色时。于彼色起无覆无记眼识。此后于彼复起分别意识。若退法者。欲界第二第三静虑各二种。初静虑三种。不退法者。欲界及前二静虑各唯善。第三静虑二种。即彼以第二静虑眼见欲界色时。于彼色起无覆无记眼识。此后于彼复起分别意识。若退法者欲界三种。前二静虑各二种不退法者欲界二种。前二静虑各唯善。见初静虑色时。于彼色起无覆无记眼识。此后于彼复起分别意识。若退法者欲界第二静虑各二种。初静虑三种。不退法者欲界及前二静虑各唯善。见第二静虑色时。于彼色起无覆无记眼识。此后于彼复起分别意识。若退法者欲界初静虑各二种。第二静虑三种。不退法者欲界及前二静虑各唯善。即彼以第三静虑眼见欲界色时。于彼色起无覆无记眼识。此后于彼复起分别意识。若退法者欲界三种前三静虑各二种。不退法者欲界第三静虑各二种。前二静虑各唯善。见初静虑色时。于彼色起无覆无记眼识。此后于彼复起分别意识。若退法者欲界第二第三静虑各二种。初静虑三种不退法者欲界及前二静虑各唯善。第三静虑二种。见第二静虑色时。于彼色起无覆无记眼识。此后于彼复起分别意识。若退法者欲界及初第三静虑各二种。第二静虑三种。不退法者欲界及前二静虑各唯善。第三静虑二种。见第三静虑色时。于彼色起无覆无记眼识。此后于彼复起分别意识。若退法者欲界及前二静虑各二种。第三静虑三种。不退法者欲界及前二静虑各唯善。第三静虑三种即彼已离第三静虑染。未离第四静虑染以初静虑眼见欲界色时。于彼色起无覆无记眼识。此后于彼复起分别意识。若退法者欲界三种。四静虑各二种。不退法者欲界及第四静虑各二种。前三静虑各唯善。见初静虑色时。于彼色起无覆无记眼识。此后于彼复起分别意识。若退法者欲界及后三静虑各二种。初静虑三种。不退法者欲界及前三静虑各唯善。第四静虑二种。即彼以第二静虑眼见欲界色时。于彼色起无覆无记眼识。此后于彼复起分别意识。若退法者欲界三种。四静虑各二种。不退法者欲界第四静虑各二种。前三静虑唯善见初静虑色时。于彼色起无覆无记眼识。此后于彼复起分别意识。若退法者欲界及后三静虑各二种。初静虑三种。不退法者欲界及前三静虑各唯善。第四静虑二种。见第二静虑色时。于彼色起无覆无记眼识。此后于彼复起分别意识。若退法者欲界及初第三第四静虑各二种。第二静虑三种。不退法者欲界及前三静虑各唯善。第四静虑二种。即彼以第三静虑眼见欲界色时。于彼色起无覆无记眼识。此后于彼复起分别意识。若退法者欲界三种。四静虑各二种。不退法者欲界第四静虑各二种。前三静虑唯善。见初静虑色时。于彼色起无覆无记眼识。此后于彼复起分别意识。若退法者欲界及后三静虑各二种初静虑三种。不退法者欲界及前三静虑各唯善。第四静虑二种。见第二静虑色时。于彼色起无覆无记眼识。此后于彼复起分别意识。若退法者。欲界及初第三第四静虑各二种。第二静虑三种。不退法者欲界及前三静虑各唯善。第四静虑二种。见第三静虑色时。于彼色起无覆无记眼识。此后于彼复起分别意识。若退法者欲界及初第二第四静虑各二种。第三静虑三种。不退法者。欲界及前三静虑各唯善。第四静虑二种

说一切有部发智大毗婆沙论卷第七十二阿毗达磨大毗婆沙论卷第七十三

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中十门纳息第四之三

即彼以第四静虑眼见欲界色时。于彼色起无覆无记眼识。此后于彼复起分别意识。若退法者欲界三种。四静虑各二种。不退法者欲界第四静虑各二种。前三静虑各唯善。见初静虑色时。于彼色起无覆无记眼识。此后于彼复起分别意识。若退法者欲界及后三静虑各二种。初静虑三种。不退法者欲界及前三静虑各唯善。第四静虑二种见第二静虑色时。于彼色起无覆无记眼识。此后于彼复起分别意识。若退法者欲界及初第三第四静虑各二种。第二静虑三种。不退法者欲界及前三静虑各唯善。第四静虑二种见第三静虑色时。于彼色起无覆无记眼识。此后于彼复起分别意识。若退法者欲界及初第二第四静虑各二种。第三静虑三种。不退法者欲界及前三静虑各唯善。第四静虑二种。见第四静虑色时。于彼色起无覆无记眼识。此后于彼复起分别意识。若退法者欲界及前三静虑各二种。第四静虑三种。不退法者欲界及前三静虑各唯善。第四静虑三种。即彼若已离第四静虑染。以四静虑眼见五地色。于彼色起无覆无记眼识。及五地分别意识多少。随相应知此中已离初静虑染等以欲界眼见诸色时。于彼色起眼识分别。准前易了故不复说。若诸异生生初静虑。未离初静虑染。见欲界色时。于彼色起二种眼识。除染污。此后于彼复起分别意识。欲界三种。初静虑二种见初静虑色时。于彼色起三种眼识。此后于彼复起分别意识。欲界二种。初静虑三种。即彼已离初静虑染。未离第二静虑染。以初静虑眼见欲界色时。于彼色起眼识分别。广说如前。见初静虑色时。于彼色起二种眼识所起分别如前应知。即彼以第二静虑眼见欲界色时。于彼色起无覆无记眼识。此后于彼复起分别意识。欲界三种前二静虑二种。见初静虑色时。于彼色起无覆无记眼识。此后于彼复起分别意识。欲界及第二静虑各二种。初静虑三种。见第二静虑色时。于彼色起无覆无记眼识。此后于彼复起分别意识。欲界及初静虑各二种。第二静虑三种。即彼已离第二静虑染。未离第三静虑染。以三地眼见四地色。或已离第三静虑染。未离第四静虑染。或已离第四静虑染。以四地眼见五地色。于彼色起眼识分别。准前应知。如说异生生初静虑。如是即彼生第二第三第四静虑。一一广说随相应知

已说异生。若诸圣者未离欲界染。见欲界色时。于彼色起三种眼识此后于彼复起欲界三种分别。即彼若生欲界已离欲界染。未离初静虑染。以欲界眼见诸色时。于彼色起二种眼识。此后于彼复起分别意识。若退法者欲界三种。初静虑二种。不退法者欲界初静虑各二种。即彼以初静虑眼见欲界色时。于彼色起无覆无记眼识。此后于彼复起分别意识。初静虑二种。欲界若退法者三种。不退法者二种见初静虑色时。于彼色起无覆无记眼识。此后于彼复起分别意识。初静虑三种。欲界唯善。即彼已离初静虑染。未离第二静虑染。以初静虑眼见欲界色时。于彼色起无覆无记眼识。此后于彼复起分别意识。若退法者欲界三种。初静虑二种。不退法者欲界二种。初静虑唯善。见初静虑色时。于彼色起无覆无记眼识。此后于彼复起分别意识。欲界唯善初静虑。若退法者三种。不退法者唯善。即彼以第二静虑眼见欲界色时。于彼色起无覆无记眼识。此后于彼复起分别意识。若退法者欲界三种。前二静虑各二种。不退法者欲界第二静虑各二种。初静虑唯善。见初静虑色时。于彼色起无覆无记眼识。此后于彼。复起分别意识。欲界唯善。第二静虑二种。初静虑若退法者三种。不退法者唯善。见第二静虑色时。于彼色起无覆无记眼识。此后于彼复起分别意识。欲界初静虑各唯善。第二静虑三种。即彼已离第二静虑染。未离第三静虑染以三地眼见四地色。或已离第三静虑染。未离第四静虑染。或已离第四静虑染。以四地眼见五地色。于彼色起眼识分别。随相应知。此中已离初静虑染等。以欲界眼见诸色时。于彼色起眼识分别。准前易了故不复说

已说圣者生欲界。即彼若生初静虑。未离初静虑染。见欲界色时。于彼色起二种眼识。此后于彼复起初静虑二种分别。见初静虑色时。于彼色起三种眼识。此后于彼复起初静虑三种分别。即彼已离初静虑染。未离第二静虑染。以初静虑眼见欲界色时。于彼色起眼识分别。准前应知。见初静虑色时。于彼色起二种眼识。此后于彼复起前二静虑二种分别。即彼以第二静虑眼见欲界初静虑色时。于彼色起无覆无记眼识。此后于彼复起前二静虑各二种分别。见第二静虑色时。于彼色起无覆无记眼识。此后于彼复起分别意识。初静虑唯善。第二静虑三种即彼已离第二静虑染。未离第三静虑染。以初静虑眼见欲界初静虑色时。于彼色起眼识分别准前应知。即彼以第二静虑眼见欲界初静虑色时。于彼色起无覆无记眼识。此后于彼复起分别意识。初及第三静虑各二种。第二静虑唯善。见第二静虑色时。于彼色起无覆无记眼识。此后于彼复起分别意识。前二静虑各唯善。第三静虑二种。即彼以第三静虑眼见欲界初静虑色时。于彼色起无覆无记眼识。此后于彼复起分别意识。初及第三静虑各二种。第二静虑唯善。见第二静虑色时。于彼色起无覆无记眼识。此后于彼复起分别意识。前二静虑各唯善。第三静虑二种。见第三静虑色时。于彼色起无覆无记眼识。此后于彼复起分别意识。前二静虑各唯善。第三静虑三种。即彼已离第三静虑染。未离第四静虑染。或已离第四静虑染。以四地眼见五地色时。于彼色起眼识分别。随相应知。如说圣者生初静虑。如是即彼生第二第三第四静虑。一一广说随相应知

此中眼识依自地眼。缘下地色容有二种。谓除染污。缘自地色容有三种。若依上地眼唯无覆无记。善染污眼识唯生自地容现在前。由此必定系属生故。善分别意识能缘一切自上下地。染污分别意识唯能缘自上地。无覆无记分别意识唯能缘自下地。善及染污分别意识生自下地容现在前。非生上地。无覆无记分别意识唯生自地容现在前。由此必定系属生故。眼识后起分别意识非唯一生。设经多生缘所见色亦得起故。问何缘生在后三静虑。而得现起初静虑眼识耶。譬喻者说。谁说生在后三静虑而能现起初静虑地眼等诸识。然后三静虑自有眼等识依自地根了自下境。若不尔者。云何生上作巧方便。引初静虑眼等诸识令现在前。评曰。彼不应作是说。应作是说。后三静虑无眼等识。所以者何。无寻伺故。眼等五识恒与寻伺相应起故。问何缘生在后三静虑。不引欲界眼等诸识令现在前。而但引起初静虑识。有作是说。欲界劣故生在胜地。不欲引彼眼等诸识令现在前。有余师说。彼界别故。谓欲界系眼等诸识与上地根不同界系。初静虑识与上地根虽不同地。而界同故亦依彼起。或有说者。欲界眼等识非修果非通果故。依上地根不得现起。初静虑眼等识是修果是通果故。依上地根亦得现起。复有说者。欲界眼等识非定界非修地。非离染地故。依上地根不得现起。初静虑眼等识是定界是修地是离染地故。依上地根亦得现起。由如是等种种因缘。生后三静虑得起初静虑眼等诸识不起欲界。如说眼识依诸地根了诸地色。引意识中三种分别数有多少。耳等诸识准此应知

问诸成就眼界亦成就色界耶。答若成就眼界亦成就色界。有成就色界不成就眼界。谓生欲界若未得眼。或得已失。未得眼者。谓羯剌蓝等位及生盲者。得已失者。谓得眼已或腐烂。或被挑或虫食。或余缘坏。问诸成就眼界亦成就眼识界耶。答应作四句。有成就眼界不成就眼识界。谓生第二第三第四静虑。眼识界不现在前。有成就眼识界不成就眼界。谓生欲界若未得眼或得已失。有成就眼界亦成就眼识界。谓生欲界已得眼而不失。或生初静虑。或生第二第三第四静虑眼识界现在前。有不成就眼界。亦不成就眼识界。谓生无色界。问诸成就色界亦成就眼识界耶。答若成就眼识界。亦成就色界。有成就色界不成就眼识界。谓生第二第三第四静虑。眼识界不现在前

问若不成就眼界亦不成就色界耶。答若不成就色界。亦不成就眼界。有不成就眼界非不成就色界。谓生欲界若未得眼或得已失。问诸不成就眼界。亦不成就眼识界耶。答应作四句。有不成就眼界非不成就眼识界。谓生欲界若未得眼。或得已失。有不成就眼识界非不成就眼界。谓生第二第三第四静虑眼识界不现在前。有不成就眼界。亦不成就眼识界。谓生无色界。有非不成就眼界亦非不成就眼识界。谓生欲界已得眼而不失。或生初静虑。或生第二第三第四静虑眼识界现在前。问诸不成就色界。亦不成就眼识界耶。答若不成就色界。亦不成就眼识界。有不成就眼识界非不成就色界。谓生第二第三第四静虑眼识界不现在前

问诸眼界不成就。得成就亦色界耶。答若色界不成就。得成就眼界亦尔。有眼界不成就得成就非色界。谓生欲界渐得眼界。问诸眼界不成就得成就亦眼识界耶。答应作四句。有眼界不成就得成就非眼识界。谓无色界殁生第二第三第四静虑。或生欲界渐得眼界。有眼识界不成就。得成就非眼界。谓生第二第三第四静虑眼识界现在前。或从彼殁生欲界及初静虑。有眼界不成就。得成就亦眼识界。谓无色界殁生欲界及初静虑。有眼界非不成就得成就亦非眼识界。谓除前相。问诸色界不成就得成就亦眼识界耶。答应作四句。有色界不成就。得成就非眼识界。谓无色界殁生第二第三第四静虑。有眼识界不成就得成就非色界。谓生第二第三第四静虑眼识界现在前。或从彼殁生欲界及初静虑。有色界不成就。得成就亦眼识界。谓无色界殁生欲界及初静虑。有色界非不成就。得成就亦非眼识界。谓除前相

问诸眼界成就。得不成就亦色界耶。答应作四句。有眼界成就。得不成就非色界。谓生欲界已得眼而失。有色界成就。得不成就非眼界。谓欲界无眼者殁生无色界。有眼界成就得不成就亦色界。谓欲界有眼者殁生无色界。或色界殁生无色界。有眼界非成就得不成就亦非色界。谓除前相。问诸眼界成就得不成就亦眼识界耶。答应作四句。有眼界成就得不成就非眼识界。谓生欲界已得眼而失。或第二第三第四静虑殁生无色界。有眼识界成就得不成就非眼界。谓欲界无眼者殁生无色界。或欲界初静虑殁生第二第三第四静虑或即住彼眼识界已现在前而断。有眼界成就得不成就亦眼识界。谓欲界有眼者殁生无色界。或初静虑殁生无色界。有眼界非成就得不成就亦非眼识界。谓除前相。问诸色界成就得不成就亦眼识界耶。答应作四句。有色界成就得不成就非眼识界。谓第二第三第四静虑殁生无色界。有眼识界成就得不成就非色界。谓欲界初静虑殁。生第二第三第四静虑。或即住彼眼识界已现在前而断。有色界成就得不成就亦眼识界。谓欲界初静虑殁生无色界。有色界非成就得不成就亦非眼识界。谓除前相

如眼界色界眼识界展转相对有十二论如是耳界声界耳识界展转相对。乃至意界法界意识界展转相对。亦各应有十二论。如是则说同分对同分。若不同分对不同分。应作是说。眼界色界眼识界有五种三论。耳界声界耳识界有四种三论。鼻界香界鼻识界有三种三论。舌界味界舌识界有二种三论。身界触界身识界有一种三论。如是一一随相应知

十二处者。谓眼处色处耳处声处鼻处香处舌处味处身处触处意处法处。问何故作此论。答为广分别契经义故。谓契经说。有生闻婆罗门。来诣佛所。到已顶礼世尊双足。合掌恭敬慰问佛已退坐一面。而白佛言。乔答摩尊。常为众说一切。云何一切。齐何施设此一切言。佛告生闻婆罗门曰。我说一切即十二处。所谓眼处乃至法处。如来齐此施设一切。若有沙门婆罗门等作如是说。我能舍佛所说一切。别更施设有一切言。彼但有语而无实义。若还问之便不能了。后自思审转生迷闷。所以者何。非彼境故。契经虽作是说而不分别其义。经是此论所依根本。彼不说者今欲说之。故作斯论。问若作是说。言一切者谓十八界。或作是说。言一切者谓五蕴及无为。或作是说。言一切者谓四谛及虚空非择灭。或作是说。言一切者谓名与色。如是等说岂但有语而无实义答此中遮义不遮于文。但遮义施设。不遮文施设。佛意说言。一切法性皆摄入此十二处中。若有说言。我能施设别更有法。不摄在此十二处中。彼但有语而无实义。非佛意说十二处外无名色等差别法门。然佛所说十二处教最上胜妙非余法门。问何故此教最上胜妙。答此是处中说摄一切法故。十八界教虽摄一切法。而是广说难可受持。五蕴教非唯略说难可解了。而亦不能摄一切法。以蕴不摄三无为故。唯佛所说十二处教摄诸法尽。非广非略。是故说为最上胜妙。故作是言。若欲观察诸法性相。当依如是十二处教。若依如是十二处教观察诸法所有性相。便生十二尔焰智光。复现十二实义影像。如人莹拭十二明镜悬在诸方。若入其中便现十二自身影像。一一有情身中有十二处可得问若一身中有十二处。云何建立十二处耶。答以彼自性作用别故。谓十二处虽在一身。而十二种自性作用有差别故非互相杂。如一室内有十二人伎艺各别。虽同一室而有十二自性作用。复次以二事故立十二处。一以所依。即眼等六。二以所缘。即色等六。复次以三事故立十二处。一以自性。二以所依。三以所缘。自性故者。谓立眼处乃至法处。所依故者。谓立眼处乃至意处。所缘故者。谓立色处乃至法处。如是名为诸处自性我物自体相分本性

已说处自性。所以今当说。问何故名处。处是何义。答生门义是处义生路义藏义仓义经义杀处义田义池义流义海义白义净义是处义应知。此中生门义是处义。者如城邑中出生诸物。由此长养诸有情身。如是所依及所缘内出生种种心心所法。由此长养染净相续。生路义是处义者。如道路中通生诸物。由此长养诸有情身。如是所依及所缘内通生种种心心所法。由此长养染净相续。藏义是处义者。如库藏中有金银等宝物积集。如是所依及所缘内有心心所诸法积集。仓义是处义者。如篅仓中有稻麦等诸谷积集。如是所依及所缘内有心心所诸法积集。经义是处义者。如织经上编布诸纬。如是所依及所缘上。遍布种种心心所法。杀处义是处义者。如战场中断百千头令堕于地。如是所依及所缘内有无量种心心所法。为无常灭之所灭坏。田义是处义者。如在田中有无量种苗稼生长。如是所依及所缘内生长种种心心所法。池义是处义者。如有问言

  水从何池出　　何处道不通
  何处摄世间　　苦乐等皆尽

世尊告曰

  眼耳鼻舌身　　意及诸余处
  此摄名及色　　能令无有余
  水从此池出　　此处道不通
  此处摄世间　　苦乐等皆尽

流义是处义者。如有问言

  诸处将流泄　　以何能制防
  若从彼已流　　谁复能偃塞

世尊告曰

  诸处将流泄　　正念能制防
  若从彼已流　　净慧能偃塞

海义是处义者。如世尊说。苾刍当知诸有情类以眼为海。现前诸色是彼涛波。于色涛波自制抑者能度眼海。得免洄澓逻刹裟等种种崄难。乃至意法广说亦尔。白义是处义者。谓眼等处粗显明了。净义是处义者。谓眼等处贞实澄洁。是谓生门乃至净义。外论说此名勃路拏。如摩健地迦出家外道说。乔答摩说诸勃路拏。皆来入我咒术章句。勃路拏声含二种义。一根本义。二能作义。以十二处与心心所为根本故及能作动心心所故。已总说处立名所因。今当一一别说其相。问眼处云何。答诸眼于色已正当见及彼同分是名眼处。已见色等言如界中已释。乃至意处应知亦尔。问色处云何。答诸色为眼已正当见及彼同分是名色处。已所见等言如界中已释。乃至法处应知亦尔。问若十色处法处少分皆体是色。何故唯一名色处耶。答唯此一处色相粗显易见易了。故名色处余处不尔。故立别名。复次唯此一处是二眼境。谓肉天眼故名色处。余处不尔故立别名。复次唯此一处是三眼境。谓肉天圣慧眼故名色处。余处不尔故立别名复次唯此一处是二眼境。眼识所缘故名色处。是故尊者妙音说曰。若二眼境眼识所缘立色处名。余处不尔。复次若有粗细长短此彼方处可了立色处名。余处不尔故非色处。复次若形相大及可积聚易了知者立色处名。余处不尔故非色处。复次若可种植增长易了立色处名。余处不尔故非色处种植增长通内外分。外分种植谓下种时。增谓萌芽时。长谓茎叶花果时。内分种植谓羯刺蓝位。增谓頞部昙位。长谓闭尸键南钵罗奢佉等位复次若可施设为方隅性立色处名。余处不尔故非色处。唯于色处施设一切方隅自性。非余处故。复次若可施设踰缮那性立色处名。余处不尔故非色处。唯于色处施设一切踰缮那性。非余处故。复次若能覆盖诸余色法。如巾帽者立色处名。余处不尔故非色处。唯有色处能总覆盖诸余色法。非余处故。复次若处具有形色显色立色处名。余处不尔故非色处。复次若处具有二十种色或二十一立色处名。余处不尔故非色处

问何故名触处。为是可触故名触处。为体是触故名触处。为触所缘故名触处。设尔何失。三皆有过。所以者何。若是可触故名触处。极微展转既不相触。如何触处是可触耶。若体是触故名触处。大种造色非触自性。如何触处体是触耶。若触所缘故名触处。此亦是余心心所境。如何但说触所缘耶。答应作是说此是可触故名触处。问极微展转既不相触。如何触处是可触耶。答依世俗说不依胜义。谓世共说眼所受境名可见。耳所受境名可闻。鼻所受境名可嗅。舌所受境名可尝。身所受境名可触。意所受境名可知。是故可触故名触处。复次缘生身识故名触处。如契经说。身触为缘生于身识。此是胜义了别境心故。此所缘名为触处。复次此名触处亦名养处。由此长养诸余色法令增盛故。如能增喜名为喜处。此能长养故名养处。尊者世友作如是说。极微展转互相触不。答互不相触。若相触者即应住至第二刹那。大德说曰。一切极微实不相触。但由无间假立触名。有作是说。极微展转实不相触亦非无间。但和合住彼此相近假立触名

问十二处体无非是法。何故唯一立法处名。答虽十二处体皆是法。而但于一立法处名亦无有失。有譬喻故。如十八界。体虽皆法。而但于一立法界名。又如十智虽皆缘法。而但于一立法智名。又如七觉支。虽皆能择法。而但于一立择法觉支名。又如六随念。虽皆缘法。而但于一立法随念名。又如四念住。虽皆缘法。而但于一立法念住名。又如四证净虽皆缘法。而但于一立法证净名。又如四无碍解虽皆缘法。而但于一立法无碍解名。又如三宝三归虽体皆法。而但于一立法宝法归名。此亦如是虽十二处体皆是法。而但于一立法处名亦无有失。复次法处有一名。余处有二名。一名者谓共名。以十二处皆是法故。二名者谓共不共名。共名如前。不共名者谓眼处等。欲令易了显不共名。法处更无不共名故但显共名。故名法处。复次生有为法生相。唯在此处摄故独名法处。复次四有为相是一切法印封幖帜。简别有为异无为故。彼相唯在此处摄故独名法处。复次名句文身诠表显示诸法性相令易解了彼三唯在此处摄故独名法处。复次如诸窗牖通风行故名风行处。法处亦尔。通生诸法故名法处。诸烦恼业及定慧等。能生一切有为法故。及能通证无为法故。复次达一切法皆空非我空解脱门。在此处摄故名法处

问能执诸法为我我所。萨迦耶见亦此处摄。如何此处不名我处。答萨迦耶见是虚妄执。不称诸法实相而解。是故此处不立我名。空解脱门证法实相是故此处依彼名法。复次择灭涅槃是常是善不变不易。生老病死所不能坏是胜义法。彼法唯在此处摄故独名法处。复次分别诸法自相共相。安立诸法自相共相。破自性愚及所缘愚于一切法不增不减如实解慧。唯此处摄故名法处。余处不尔故别立名。复次此摄多法故名法处。摄多法者。谓于此处有色非色法。相应不相应法。有所依无所依法。有所缘无所缘法。有行相无行相法。有警觉无警觉法。有为法无为法。余处不尔故别立名。复次此处对意故名法处。谓眼等处唯对色等。唯有意处对一切法故。对意者别得通名。由如是等种种因缘十二处中一名法处

别说诸处一一相已。今应复说诸处次第。问何故世尊先说内处后说外处。答以依六识所依所缘次第说故。问何故世尊于六内处先说眼处。乃至后说意处。于六外处先说色处。乃至后说法处。答随顺文词诠表相故。复次随顺说者受者持者次第法故。复次随顺粗细次第法故。谓六内处眼处最粗。是故前说。乃至意处最细。是故后说六外处中色处最粗。是故前说。乃至法处最细是故后说。复次依定不定次第说故。六内处中前五定取现在境故前说。意处取境不决定故后说。谓以三世及无为法。或总或别为所取故。前五处中前四定取所造色故前说。身处取境不决定故后说。谓以能造及所造色。或总或别为所取故。前四处中于所取境远速明者前说。此相违者后说。依内六处前后次第说。外六处次第亦尔。复次依处上下次第说故。谓一身中眼处最上。耳处次下鼻处次下舌处次下身多在下。意无方处故最后说。依六内处前后次第说。六外处应知亦尔。复次依诸有情展转相遇礼仪次第故作是说。谓相遇时。先互相见。次与言论。次奉香花。次设饮食。次授细妙卧具等事。由此最后互相得意故。十二处次第如是

说一切有部发智大毗婆沙论卷第七十三阿毗达磨大毗婆沙论卷第七十四

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中十门纳息第四之四

问云何建立内处外处。为依于法为依于我。设尔何失。二俱有过。所以者何。若依于法法无作用。于无作用一切法中。云何建立内处外处。若依于我我实性无。如何依我立内外处。答唯依法立然非一切。谓六识身是染净法所依止处。若与六识作所依者名为内处。作所缘者名为外处。故依法立内外处名。复次若法是根立为内处。若法是根义立为外处。复次若法是有境立为内处。若法是境立为外处。有说。依我立内外处。我即是心。我执依故。于此心上假立我名。如契经说

  由善调伏我　　智者得生天
  应善调伏心　　心调能引乐

既善调心即善调我。故知心上假立我名。此我所依立为内处。我所缘者立为外处。然内外名非圆成实。谓于我是内者于他名外。于我是外者于他名内故。而且依一立内外非名非不决定

如契经说。汝等苾刍。于内六处应如实知。问于外六处亦应如实知。何故世尊唯劝知内处。答世尊欲令诸弟子辈多于内门修静虑故。如契经说。汝等苾刍。应观内根不应缘外。复次世尊欲令诸弟子辈内修静虑无所增益。如契经说。汝等苾刍。应内修定勿妄增益常乐我净。汝等苾刍应内修定如实观察。诸行无常苦空非我因集生缘。由此八种圣慧行相。于一切时应观诸有。复次世尊欲令诸弟子辈于内修习不共静虑。如世尊说。汝等苾刍。应内修定不应修习诸共静虑。谓粗苦障静妙离观。汝等苾刍应内修定。谓应修习不共静虑观察诸有。如病如痈如箭恼害。无常有苦是空非我。由此八种胜寻思杖。能遍摧伏一切有生。复次此契经中。唯勤观察内六处者以内是外所依止故亦劝观彼。所以者何。以有我故便有我所。有我见故有我所见。有五我见故有十五我所见。有我执故有我所执。有我痴故有我所痴。有我爱故有我所爱。为养内我求外资具。复次世尊欲令诸弟子等先于内法修念住故。谓修行者先缘内法修习念住。既成满已方缘于外。由如是等种种因缘。是故世尊唯劝知内

如契经说有六内处。契经复说有六触处。问此二六处有何差别。或有说者。此二无别。所以者何。六内处即六触处。六触处即六内处。声虽有异而义无别。复有说者。亦有差别。谓名即差别名内六处名六触处故。复次诸同分者名六触处。彼同分者名六内处。复次诸可生法名六触处。不可生法名六内处。复次有业用者名六触处。无业用者名六内处。若作是说。诸现在者名六触处。过去未来者名六内处。复次诸已生者名六触处。未已生者名六内处。若作是说。过去现在名六触处。未来名六内处。复次心心所法正依住者名六触处。心心所法不正依住。唯空转者名六内处。复次眼等六处作触所依义名六触处。作余心心所法所依义名六内处。胁尊者言。眼等六处自性名内六处。若有所作名六触处。如苾刍钵。若说自性但名为钵。苾刍用时名苾刍钵。尊者望满作如是言。眼等六处自体名内六处。若与触作所依名六触处。如铁酥钵。若说自体但名铁钵。若盛酥时名铁酥钵。问眼等六处亦为受等之所依止。何故但名触处不名受等处耶。答亦应说受等处而不作是说者。当知此义有余。复次契经举胜兼显劣者。谓于一切心心所中。触最为胜。若说触处当知兼显名受等处。复次心心所法以触为命。触所住持触所引发。由触力故能现在前。故名触处。谓心心所于境流散。由触摄持令得和合。又若无触诸心心所应如死尸不能触对自所缘境。皆由触力有触境用。如有命根身能觉触。是故眼等但名触处。如契经说。六内处名此岸六外处名彼岸。问六内外处与此彼岸。有何相似而作是说。答与心心所作所依缘。有近有远似此彼岸故作是说。如河两岸。近者名此远者名彼。如是六处与心心所。作所依者近故如此岸。作所缘者远故如彼岸。复次是心心所初入已渡如此彼岸故作是说。如诸有情。初入河处名为此岸。已渡河处名为彼岸。如是与心心所法作所依者。如初入故名此岸。作所缘者如已度故名彼岸。故内外处名此彼岸。复次契经中说。寂灭涅槃名为彼岸。涅槃唯是外处所摄既名彼岸。故内六处得此岸名。如契经说。萨迦耶是此岸。萨迦耶灭是彼岸。萨迦耶者即是生死。于生死中六内处胜故。六内处得此岸名。既六内处名为此岸故。六外处得彼岸名。问此中何法如河。而说六内外处如此彼岸耶。答心心所法如河故。内外处如此彼岸。如有瀑河漂此彼岸。情非情物同趣大海。心心所法亦复如是。漂内外处所摄有情。同趣生老病死大海。问于此河中谁为船筏。答八支圣道如有船筏。百千众生之所依止。从河此岸渡至彼岸随意游适。如是无量无边有情依止圣道。从生死此岸至涅槃彼岸。自在游赏故。八圣道犹如船筏

如契经说。有八胜处有十遍处。问彼八与十既亦名处。何故但有十二处耶。答彼八与十皆摄在此十二处中。谓彼自性俱有相应即此意处法处摄故

如契经说。有四无色处。谓空无边处识无边处无所有处非想非非想处。问何故世尊于四无色以处声说。答为破外道解脱执故。谓诸外道执四无色为四涅槃。一执空无边处名无身涅槃。二执识无边处名无边意涅槃。三执无所有处名净聚涅槃。四执非想非非想处名世间窣堵波涅槃。为破如是外道涅槃执故。说四无色名为生处非真解脱。真解脱者乃名涅槃

如契经说。复有二处。一无想有情处。二非想非非想处。问何故世尊说此二处。答为破外道解脱想故。谓诸外道于此二处起解脱想。为破彼想佛说此二名为生处非真解脱。复次为破外道不还想故。谓诸外道于此二处起不还想。为破彼想佛说此二名退还处。谓彼处没退还诸界诸趣诸生。流转生死无息期故。复次为破外道不散想故。谓诸外道执此二处是真解脱不复散坏。为破彼执佛说此二是散坏处。谓从彼殁散向诸界诸趣诸生。流转生死无息期故。若从无想有情天殁决定散堕欲界受生。若从非想非非想殁。非圣散堕下地受生。复次观此二处寿量长远。诸外道等执为解脱。唯诸异生所受生处寿量长远。无有过于无想天者。谓彼寿量五百大劫。一切有情所受生处。寿量长远无过非想非非想处。谓彼寿量八万大劫。为遣外道此解脱执佛说此二名为生处非真解脱。复次佛于余处以二名说。一名有情居。二名为识住。于此二处亦二名说。一名有情居。二名为处。故于此二以处声说。谓受生处。复次佛说诸识住定是有情居。有有情居而非识住。谓此二处显非无此故说处名。即是有情所居处义

如契经说。尊者舍利子往诣佛所作如是言。大德世尊。施设诸处为无有上。谓十二处。摄一切法。此是世尊无余智见过此更无所知见法。若有沙门婆罗门等。觉所知法过世尊者无余是处。问尊者舍利子如何能知此十二处摄一切法。而赞佛言施设诸处为无有上。答由教故知。谓舍利子得四证净于佛所说决定信受。曾闻世尊说十二处摄一切法。由此故知。问尊者舍利子于十二处唯有教智无证智耶。答亦有证智。谓舍利子于十二处亦能一一无倒证知。问佛舍利子于十二处。俱能一一无倒证知。佛舍利子有何差别。答佛能于此十二处法。一一证知自相共相。尊者舍利子于此十二处法。唯能一一证知共相。于彼自相未能一一如实证知。谓有无量诸处差别。皆摄入此十二处中。而舍利子须他显示乃能知故。复次尊者舍利子于十二处一一证知由他教引。佛于十二处一一证知皆能自觉不由他教

复次佛于十二处。具一切智一切种智。尊者舍利子于十二处唯有一切智。无一切种智。复次佛于十二处不依六识而能证知唯有尔所。尊者舍利子于十二处。要依六识方能证知唯有尔所。谓舍利子作是念言。一切识身唯有六种识身定有所依所缘。此所依缘定有十二。故十二处不增不减

复次尊者舍利子虽于十二处一一证知。而要先思惟佛所说法。谓佛先说十二处名。后随此名一一分别。世尊分别十一处已。时舍利子作是念言。前十一处所不摄法必应摄在最后法处。故作是说大德世尊。施设诸处为无有上。谓十二处摄一切法。世尊证知十二处相。不由思惟他所说教故。舍利子虽能证知十二处相。而与佛智极有差别。是故号佛为无上尊

五蕴者谓色蕴受蕴想蕴行蕴识蕴。问何故作此论。答为广分别契经义故。谓契经中说。有五蕴色乃至识。虽作是说而不广释。经是此论所依根本。彼不说者今欲说之故作斯论

问色蕴云何。答如契经说。诸所有色皆是四大种及四大种所造。余经复说。云何色蕴。诸所有色若过去若未来若现在。若内若外若粗若细。若劣若胜若远若近。如是一切略为一聚说名色蕴。乃至识蕴广说亦尔。阿毗达磨作是说言。云何色蕴。谓十色处及法处所摄色是名色蕴。问此三处说义有何异。答各为遮止他宗所说。问如契经说。诸所有色。皆是四大种及四大种所造。此为遮止何宗所说。答此为遮止觉天等说。谓佛观察未来世中。有觉天等当作是说。四大种外无别所造。为遮彼意故作是说。诸所有色皆是四大种及四大种所造。显离大种有所造色。问余经复说。诸所有色若过去若未来若现在。乃至广说。此为遮止何宗所说。答此为遮止外道所说。谓佛在世有出家外道名为杖髻。拨无过去未来。为遮彼意故世尊说诸所有色若过去若未来若现在。乃至广说。显有过去未来色等。问阿毗达磨作如是言。云何色蕴谓十色处及法处所摄色。此为遮止何宗所说。答此为遮止譬喻者说。谓譬喻者拨无法处所摄诸色故。此尊者法救亦言。诸所有色皆五识身所依所缘。如何是色非五识身所依所缘。为遮彼意故作是说。云何色蕴。谓十色处及法处所摄色。问若法处所摄诸色是实有者。尊者法救所说当云何通。答不必须通非三藏故。若必须通当正彼说。诸所有色皆五识所依。及六识所缘法处所摄色。虽非五识所依所缘。而是意识所缘色摄。复次法处所摄色依四大种而得生。故从所依说在身识所缘中。故彼尊者说亦无失

问受蕴云何。答六受身。谓眼触所生受。乃至意触所生受。契经及阿毗达磨皆作是说。问想蕴云何。答六想身谓眼触所生想。乃至意触所生想。契经及阿毗达磨皆作是说。问行蕴云何。答契经说此是六思身。谓眼触所生思。乃至意触所生思。阿毗达磨说此行蕴。略有二种。谓相应行不相应行。乃至广说。问世尊何故于相应不相应行蕴中。偏说思为行蕴非余行耶。答思于施设行蕴法中最为上首。思能导引摄养诸行故佛偏说。如爱施设集谛法中最为上首。爱能导引摄养诸集故佛偏说。复次造作有为故名为行。思是造性余法不尔。故佛偏说思为行蕴

问识蕴云何。答六识身。谓眼识乃至意识。契经及阿毗达磨皆作是说。如是名为诸蕴自性我物自体相分本性

已说自性。所以今当说。问何故名蕴蕴是何义。答聚义是蕴义。合义是蕴义。积义是蕴义。略义是蕴义。若世施设即蕴施设。若多增语即蕴增语。聚义是蕴义者。谓诸所有色。若过去若未来若现在。广说乃至若远若近。如是一切总为一聚立为色蕴。乃至识蕴聚义亦尔。合义是蕴义者。谓诸所有色。若过去若未来若现在。广说乃至若远若近。如是一切总为一合立为色蕴。乃至识蕴合义亦尔。积义是蕴义者。如种种物总为一积名杂物蕴。如是诸色总为一积立为色蕴。乃至识蕴积义亦尔。略义是蕴义者。谓诸所有色。若过去若未来若现在。广说乃至若远若近。如是一切总略一处立为色蕴。乃至识蕴略义亦尔。问过去未来现在诸色可略聚耶。答虽不可略聚其体。而可得略聚其名。乃至识蕴应知亦尔。问若尔无为亦应立蕴。诸无为名可略聚故。答诸有为法有作用故有略聚义。虽体有时不可略聚者。而略聚其名立色等蕴。诸无为法无作用故无略聚义。虽可略聚其名。而不可立为蕴。若世施设即蕴施设者。谓色蕴可施设有三世。乃至识蕴亦可施设有三世故。若多增语即蕴增语者。如多财名财蕴。多谷名谷蕴。多军名军蕴。虽多人众不相叠肩。而同一事故名为军。如是俱胝那庾多等诸极微色。虽相去远以相同故合立色蕴。乃至识蕴无量刹那虽相去远。而相同故合立识蕴。问若多增语是蕴增语者。为有一极微名色蕴不。有作是说。非一极微可立色蕴。若立色蕴要多极微。复有说者。一一极微有蕴相故。亦可各别立为色蕴。若一极微无色蕴相。众多聚集亦应非蕴阿毗达磨诸论师言。若观假蕴应作是说。一极微是一界一处一蕴少分。若不观假蕴应作是说。一极微是一界一处一蕴。如人于谷聚上取一粒谷。他人问言汝何所取。彼人若观谷聚应作是答。我于谷聚取一粒谷。若不观谷聚应作是答。我今聚谷。乃至识蕴一一刹那问答亦尔

如是已释诸蕴总名。今应分别诸蕴次第。问何故世尊先说色蕴。乃至最后说识蕴耶。答随顺文辞诠表相故

复次随顺说者受者持者次第法故。复次随顺粗细次第法故。谓五蕴内色蕴最粗故佛先说。于四蕴内受蕴最粗故。次色说。问受等四蕴无有方处无形质故。如何可说有粗有细耶。答虽无方处亦无形质。而依行相立粗细名。如世有言。我手足痛。我头腹痛。我支节痛。痛即是受。以受如色可施设故。于无色蕴说受最粗。于三蕴内想最为粗。女男等想易了知故次受后说。于二蕴内行蕴相粗。贪嗔痴等相易了故次想后说。识蕴最细总取境相难了知故最在后说

复次从无始来男女于色更相爱乐故先说色。更相爱色由贪受味故次说受。此贪受味由颠倒想故次说想。此颠倒想由烦恼生故次说行。一切烦恼依识而生染污诸识故后说识。复次二种色观于入佛法为甘露门。谓不净观及持息念。故先说色。既观色已能见受过故次说受见受过已想不颠倒故次说想。想无倒已烦恼不生故次说行。无烦恼故识便清净故后说识。复次色蕴如器。为无色蕴所依所缘。是故先说。受如饮食是正所贪故次说受。想如助味由颠倒想贪着诸受故次说想。行如厨人诸烦恼业能有造作故次说行。识如食者能了别境故后说识。复次依界地故说五先后。谓欲界中有诸妙欲色相显了故先说色。诸静虑中有喜乐等受相显了故次说受。前三无色取空等相想显了故次说想。有顶地中思最为胜行相显了故次说行。色等四种即四识住。识是能依故最后说问五蕴有为皆应名行。何缘于一独立行名。答如十八界虽皆是法。而但于一立法界名。广说乃至三宝三归虽皆是法而但立一法宝法归。如是五蕴虽皆是行。而但于一立行蕴名亦无有过。复次行蕴有一名。余蕴有二名。一名者。谓共名。谓五种蕴皆是行故。二名者谓共不共名。共名如前。不共名者。谓余四蕴欲令易了显不共名。行蕴更无不共名故。但显共名故名行蕴。复次生一切行生相唯在此蕴摄故独名行蕴。复次四有为相是一切行印封幖帜。简别有为异无为故。彼相唯在此蕴摄故独名行蕴。复次名句文身诠表显示诸行性相作用差别令易解了。彼三唯在此蕴摄故独名行蕴。复次觉一切行皆空非我空解脱门。此蕴摄故独名行蕴。问能执诸行为我我所。萨迦耶见亦此蕴摄。如何此蕴不名我蕴。答萨迦耶见是虚妄执。不称诸行实相而解。是故此蕴不立我名。空解脱门觉行实相。是故此蕴依彼名行。复次分别诸行自相共相。安立诸行自相共相。破自性愚及所缘愚。于一切行不增不减。如实解慧唯此蕴摄故名行蕴。余蕴不尔故别立名。复次此摄多行故名行蕴摄。多行者谓此蕴中有相应不相应行。有所依无所依。有所缘无所缘行。有行相无行相行。有警觉无警觉行。余蕴不尔故立别名。复次行谓造作。有为法中能造作者思最为胜。思但摄在此行蕴中。故此行蕴独名为行

问大地法等诸心所中。何故别立受想为蕴。余心所法不别立耶。胁尊者言。唯佛通达诸法性相作用差别。若法堪任独立蕴者便独立蕴。若不堪任独立蕴者便共立蕴故不应责

复次。世尊欲以异相异文庄严于义。故作是说。谓佛若以异相异文庄严于义则受化者欣乐受持不生厌倦。复次世尊欲现二门二略二阶二蹬二炬二明二光二影故作是说。谓如受想各别立蕴。余心所法亦应别立。如余心所合立行蕴。受想亦应合立为蕴。如是则应蕴有无量。或但有三以现二门乃至二影故。蕴有五不减不增。复次世尊欲显二门法要。是故别立受想为蕴。谓诸心所有是根性有非根性。若说受别立蕴当知已说是根心所。若说想别立蕴当知已说非根心所。如根性非根性。明性非明性。现见性非现见性。喜观性非喜观性。妙性非妙性。胜性非胜性。有势力性无势力性。增上性非增上性应知亦尔。复次受想二法二界所显故别立蕴。谓受蕴色界所显。喜乐等受色界增故。想蕴无色界所显空识等想无色界增故。复次由二法故。诸瑜伽师于二界劳倦故别立蕴。谓受力故诸瑜伽师于色界劳倦。想力故诸瑜伽师于无色界劳倦。复次诸有情类。耽着乐受执颠倒想。生死轮回受诸剧苦。欲令了知此二过患故别立蕴。复次受想二法为因发起二诤根本。胜余法故别立为蕴。谓受能发起爱诤根本。想能发起见诤根本。如能发起二诤根本。如是能发起二杂染二边二箭二戏论二我所应知亦尔。复次受想二法别立识住故独立蕴。余心所法总立识住故共立蕴。复次诸瑜伽师厌恶受想。入灭尽定故别立蕴如施设论说。云何加行得灭尽定。以何方便起灭尽定。谓初修业者。于一切行不作功用。亦不思惟但作是念。谁未生故受想得生。谁已生故受想便灭。作是念已能如实知。灭定未生故受想得生。若灭定生受想便灭。知已厌离受想二法。乃至不生得灭尽定。由如是等种种因缘。别立受想各为一蕴

问无为何故不立蕴耶。答无蕴相故不立为蕴。谓蕴是聚积相。无为无此相故不立为蕴。复次无为是蕴究竟灭处故不立蕴。如瓶衣等究竟灭处非瓶衣等。复次诸有为法生灭相应。有因有缘得有为相可立为蕴。诸无为法生灭不相应。无因无缘不得有为相故不立蕴。复次诸有为法属因属缘因缘和合可立为蕴。诸无为法与此相违故不立蕴。复次诸有为法为生所起。为老所衰。为无常所灭。可立为蕴。诸无为法与此相违故不立蕴。复次诸有为法流行于世。取果与果有诸作用。能了所缘可立为蕴。诸无为法与此相违故不立蕴。复次诸有为法堕在三世。与苦相应有前后际。有下中上可立为蕴。诸无为法与此相违故不立蕴。复次诸无为法无五蕴相。不可立在此五蕴中。亦不可立为第六蕴。无聚积等诸蕴相故。复次蕴是作相。诸无为法无有作相故不立蕴。复次蕴从他生。诸无为法不从他生故不立蕴。由如是等种种因缘无为非蕴

如契经说。有五种功德蕴。谓戒蕴定蕴慧蕴解脱蕴解脱知见蕴。问蕴应有十。如何说五。答彼戒等蕴皆摄在此色等五中故蕴唯五。如契经说。尊者阿难告诸苾刍作如是语。我亲从佛边受八万法蕴。从诸苾刍所传受得二千。问世尊既说众多法蕴。如何但说有色等五。答彼多法蕴皆摄在此色等五中故蕴唯五。问彼诸法蕴是何蕴摄。有作是说。一切法蕴语为自性。彼说摄在此色蕴中。有余师说。一切法蕴名为自性。彼说摄在此行蕴中。是故世尊唯说五蕴

问一一法蕴其量云何。有作是说有法蕴论六千颂成。一一法蕴各如彼量。复有说者。如世尊说。蕴处界食缘起谛宝。念住正断。神足根力。觉支道支。如是等类一一法门各一法蕴。不可定说有尔所颂。尊者妙音作如是说。一一法蕴有五十万五千五百五十颂文。有余师说。一一法蕴有十五万五千五百五十颂文。有余复言。一一法蕴唯有一万五千五百五十颂文。评曰彼皆不应作如是说。应作是说。受化有情有八万行。为对治彼八万行故。世尊为说八万法蕴。彼诸有情依佛所说八万法蕴入佛法中。作所应作各得究竟

说一切有部发智大毗婆沙论卷第七十四阿毗达磨大毗婆沙论卷第七十五

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中十门纳息第四之五

五取蕴者。谓色取蕴受取蕴想取蕴行取蕴识取蕴。问何故作此论。答为欲分别契经义故。谓契经说。有五取蕴。谓色取蕴乃至识取蕴。契经虽作是说而不广辩其义。经是此论所依根本。彼不说者今应分别故作斯论。问色取蕴云何。答若色有漏有取。彼色在过去未来现在。或起欲或起贪或起嗔或起痴或起怖。或复随起一心所随烦恼是名色取蕴。此中起欲起贪者谓起爱结。起嗔者谓起恚结。起痴者谓起无明结。起怖者有作是说。此中不应说或起怖。所以者何。怖即烦恼。若说烦恼即已说怖。问若尔此怖以何烦恼为自性。有作是说。以有身见为自性。所以者何。执有我者多怖畏故。若说有身见即已说怖。有余师说。以爱为自性。所以者何。若有爱者多怖畏故。复有说者。以无智为自性。所以者何。诸无智者多怖畏故。若说无明即已说怖。评曰应作是说。此所起中应别说怖。所以者何。有别心所与心相应。是怖自性此即摄在。复有所余如是类法与心相应心所法内非诸烦恼。问此怖自性于何处有。答在欲界有非上二界。问若怖自性色界中无。云何释通契经所说。如契经说。苾刍当知。有极光净先生。诸天见后生者睹劫火焰心生恐怖。而慰喻言。大仙勿怖大仙勿怖。我数曾见此劫火焰。烧空梵宫即于彼灭。伽他所说。复云何通。如说

  闻说长寿天　　有妙色名誉
  深心怀厌怖　　如鹿对师子

答经颂于厌以怖声说。问若尔厌怖有何差别。答名即差别。谓彼名厌此名为怖。尊者世友作如是说。怖唯欲界厌通三界。复作是说。怖在烦恼品厌在善根品。复作是说。怖通染污无覆无记厌唯是善。大德说曰。于衰损事深心疑虑欲得远离说名为怖。已得远离深心憎恶说名为厌。如是名为厌怖差别。问异生圣者谁有怖耶。有作是说。异生有怖圣者无怖。所以者何。圣者已离五怖畏故。五怖畏者。一不活畏。二恶名畏。三怯众畏。四命终畏。五恶趣畏。评曰应作是说。异生圣者二皆有怖。问圣者已离五种怖畏如何有怖。答圣者虽无五种大怖而有所余暂时小怖。问何等圣者有余小怖。为有学位无学位耶。有作是说。唯有学位有余小怖。以怖唯是烦恼品故。评曰应作是说。学无学位皆容有怖。学谓预流一来不还者。无学谓阿罗汉独觉除佛世尊。佛无恐怖毛竖等事。于一切法如实通达得无畏故。或复随起一心所随烦恼者。谓缘色生诸余遍行及修所断余烦恼等问受取蕴云何。答若受有漏有取。彼受在过去未来现在。或起欲或起贪或起嗔或起痴或起怖。或复随起一心所随烦恼。是名受取蕴。此中广释如前。应知有差别者。谓随起一随烦恼中。缘此受生诸余遍行及见所断余非遍行

如受取蕴如是想行及识取蕴广说。应知是名取蕴自性我物自体相分本性

已说自性。所以今当说。问何故名取蕴。取蕴是何义。答此从取生复能生取故名取蕴。复次此从取转复能转取故名取蕴。复次此由取引复能引取故名取蕴。复次此由取长养复能长养取故名取蕴。复次此由取增广复能增广取故名取蕴。复次此由取流派复能流派取故名取蕴。复次此蕴属取故名取蕴。如臣属王故名王臣。诸有漏行都无有我。设有问言。汝属于谁。应正答言。我属于取。复次诸取于此应生时生。应住时住。应执时执。故名取蕴。复次诸取于此增长广大故名取蕴。复次诸取于此长养摄受故名取蕴。复次诸取于此染着难舍。犹如尘垢染着衣服故名取蕴。复次诸取于此深生乐着。如鱼鳖等乐着河池故名取蕴。复次此是诸取巢穴舍宅故名取蕴。谓依此故贪嗔痴慢见疑缠垢。皆得生长。应知此中依同分取立取蕴名。谓依欲界取名欲界取蕴。依色界取名色界取蕴。依无色界取名无色界取蕴。如依三界同分取立取蕴名。依九地取应知亦尔。此于界地无杂乱故。若于相续容有杂乱。谓依自取他蕴名取蕴亦依他取自蕴名取蕴。若于相续无杂乱者。一切外物应非取蕴。以外物中无诸取故。然诸外物依有情取立取蕴名互生长故

问蕴与取蕴有何差别。答名即差别彼名为蕴此名取蕴。复次蕴通有漏无漏。取蕴唯有漏。复次蕴摄三谛取蕴摄二谛。复次蕴摄十七界一界少分。取蕴摄十五界三界少分。复次蕴摄十一处一处少分。取蕴摄十处二处少分。复次蕴摄五蕴取蕴摄五蕴各少分。复次于蕴中有流转者受诃责。有还灭者受赞叹。于取蕴中有流转者受诃责。无还灭者受赞叹。蕴与取蕴是谓差别六界者。谓地界水界火界风界空界识界。问何故作此论。答是作论者意欲尔故。谓本论师随自意欲而作此论不违法相故不应责。复次不应诘问此本论师。所以者何。世尊施设十八界已。复于此中略出少分施设六界。故此六界十八界中摄五界全四界少分。五界全者。谓前五识界。四界少分者。谓色触意及意识界。此中空界摄色界少分。地水火风界摄触界少分。识界摄意界意识界少分。以此二界通有漏无漏。识界唯摄有漏分故。由此六界十八界中摄五界全四界少分。问置本论师。世尊何故十八界中略出少分施设六界。答观受化者所宜差别。谓有所化于所知境但愚少分。或有所化于所知境愚于一切。愚少分者为说六界。愚一切者为说十八界。复次世尊所化有利根者。有钝根者。为利根者说六界。为钝根者说十八界。复次世尊所化有开智者有说智者。为开智者说六界。为说智者。说十八界。复次世尊所化有乐略者有乐广者。为乐略者说六界。为乐广者说十八界。复次于十八界为略现门故说六界谓十八界中有是色有非色。若说前五界。当知已说诸是色界。若说识界。当知已说诸非色界。复次十八界中有有见有无见。若说空界。当知已说诸有见者若说余五界。当知已说诸无见者。复次十八界中有有对有无对。若说前五界。当知已说诸有对者。若说识界。当知已说诸无对者。复次十八界中有相应有不相应。若说识界。当知已说诸相应者。若说余五界。当知已说不相应者。如相应不相应。如是有所依无所依。有所缘无所缘。有行相无行相。有警觉无警觉。应知亦尔。复次由此六界能生能养能长有情色无色身故复施设。能生者。谓识界。能养者谓地水火风界。能长者谓空界。复次由此六界能引能持能增有情色无色身故复施设。能引者谓识界。能持者谓地水火风界。能增者谓空界。复次由此六界是根本有情事。是遍行有情事。是无始有情事。是无分别有分别有情事故复施设。根本有情事者。谓欲色界受生有情。从结生心乃至死有。无此六界无势用时。遍行有情事者。谓欲色界一切有情从结生心乃至死有。无此六界不增上时。无始有情事者。谓不可知本际已来诸有情类。从结生心乃至死有。无此六界不作用时无分别有分别有情事者。谓有有情未可分别是男是女。如羯刺蓝頞部昙闭尸揵南位。如是六界亦有势用。或有有情已可分别是男是女钵罗奢佉等位。如是六界亦有势用。尊者妙音作如是说。由此六界得入母胎势用增上故复施设。由如是等种种因缘故。佛世尊于十八界略出少分。施设如是六界差别

问地界云何。答坚性。虽此地界总是坚性。而此坚性差别无边。谓内外分坚性各异。内分中坚性者。谓发毛爪齿尘垢皮肉。筋骨脉心脾肾肝肺胃肚肠粪。生藏熟藏手足支节。如是等中所有坚性。此诸坚性有胜有劣。谓足坚性胜手坚性。若诸有情少时手行手皮血肉即便坏尽。若以足行尽众同分足皮血肉都无损坏。由此故知内分坚性有胜有劣。外分中坚性者。谓地山砾石塼瓦草木。螺蚌[韅-革+虫]蛤铜铁金银白镴铅锡末尼真珠珊瑚琥珀珂贝璧玉。帝青大青末罗羯多。杵藏石藏飒颇胝迦。及红颇黎吠琉璃等所有坚性。此内外分种种坚性。以相同故略为一聚总名地界

问水界云何。答湿性。虽此水界总是湿性。而此湿性差别无边。谓内外分湿性各异。内分中湿性者。谓泪污涕唾肪膏髓恼涎胆痰癊脓血尿等所有湿性。外分中湿性者。谓江河池沼泉井沟渠四大海等所有湿性。此内外分种种湿性。以相同故略为一聚总名水界

问火界云何。答暖性。虽此火界总是暖性。而此暖性差别无边。谓内外分暖性各异。内分中暖性者。谓身中热等热遍热。由此所饮所食所啖。皆易消热令身安隐。此若增时便成热病。外分中暖性者。谓炬灯烛陶窖炉等火聚炎焰。烧诸城。村山林旷野。及诸药草日轮未尼天龙宫殿所出火焰。并地狱等诸火暖性。应作是说。内火暖性热于外火。所以者何。若以饮食置釜镬中。下然炽火经一日夜。犹不能令形色变易。如在腹中经须臾顷。此内外分种种暖性以相同故。略为一聚总名火界

问风界云何。答轻等动性。虽此风界总是动性。而此动性差别无边。谓内外分动性各异。内分中动性者。谓有上行风有下行风。有住胁风有住腹风。有住背风有如针风。有如刀风。有荜茇罗风有婆呾瑟耻罗风。有婆呾寠拉摩风。有入息风有出息风。有随身分支节行风所有动性。外分中动性者。谓有四方风。或有尘风。或无尘风。或毗湿缚风。或吠岚婆风。或小风。或大风。或风轮风等所有动性。此内外分种种动性以相同故。略为一聚总名风界

问空界云何。答如契经说。有眼穴空。有耳穴空。有鼻穴空。有面门空。有咽喉空。有心中空有心边空。有通饮食处空。有贮饮食处空。有弃饮食处空。有诸支节毛孔等空。是名空界。阿毗达磨作如是说。云何空界。谓邻碍色。碍谓积聚即墙壁等有色。近此名邻碍色。如墙壁间空。丛林间空。树叶间空。窗牖间空。往来处空。指间等空。是名空界。有作是说此文应言云何空界谓邻难除色。然色有二种。一者易除谓有情数。二者难除谓无情数。此空界色多近非情墙壁树等。而施设故名邻难除色。旧对法者及此国师。俱说空界处处皆有。谓骨肉筋脉皮血身分。昼夜明闇形显等处皆有此色。问缘空界色眼识生不。有说缘此眼识不生。谓空界色虽眼识境而此眼识毕竟不生。复有说者。缘空界色眼识亦生。问若尔何故见不明了。答此空界色昼为明所覆。夜为闇所覆。故眼虽见而不明了

问虚空空界有何差别。答虚空非色空界是色。虚空无见空界有见。虚空无对空界有对。虚空无漏空界有漏。虚空无为空界有为。问若此虚空是无为者。契经所说当云何通。如契经说。世尊以手摩扪虚空告苾刍众。岂佛以手摩扪无为而告弟子。答彼于空界说虚空声。非谓虚空手可摩扪。余经亦说。佛告苾刍。若有画师或彼弟子持诸彩色来作是言。我能彩画虚空。作种种文像有是事不。苾刍白佛无有是事。彼亦于空界说虚空声又伽他说

  兽归林薮　　鸟归虚空　　圣归涅槃
  法归分别

彼亦于空界。说虚空声。复有颂言

  虚空无鸟迹　　外道无沙门
  愚夫乐戏论　　如来则无有

彼亦于空界说虚空声。有余经说。鸟步虚空迹难可现亦不可寻。彼亦于空界说虚空声。有处问虚空而答以空界。如品类足作如是言。云何虚空谓有虚空无障无碍色于中行周遍增长。问何故问虚空而答以空界。答虚空微细难可显说。空界相粗易可开示。以粗显细故作是说

问以何缘故知有虚空。尊者世友作如是说。以佛说故知有虚空。谓契经中。佛处处说虚空虚空。故知实有。问为但信教知有虚空。为此虚空亦现量得。答亦现量得。若无虚空一切有物应无容处。既有容受诸有物处知有虚空。复作是说。以有往来聚集处故知有虚空。若无彼因彼亦不有。言彼因者即是虚空。虚空是彼容受因故。复作是说。容有碍物知有虚空。若无虚空彼无容处。复作是说若无虚空应一切处皆有障碍。既现见有无障碍处故。知虚空决定实有。无障碍相是虚空故。大德说曰。虚空不可知非所知事故。所知事者色非色性虚空与彼俱不相应。所知事者谓此彼性虚空与彼俱不相应。此虚空名。但是世间分别假立。评曰应作是说。实有虚空非彼不知即谓非有由前教理实有虚空

问若尔虚空有何作用。答虚空无为无有作用。然此能与种种空界作近增上缘。彼种种空界能与种种大种作近增上缘。彼种种大种能与有对造色等作近增上缘。彼有对造色能与心心所法作近增上缘。若无虚空。如是展转因果次第皆不成立。勿有此失。是故虚空体相实有不应拨无

问识界云何。答五识身及有漏意识。问何故无漏识不立识界耶。答与识界相不相应故。若法能长养诸有。摄益诸有。任持诸有者。立六界中。无漏意识。能损减诸有。散坏诸有。破灭诸有。是故不立在六界中。复次若法能令诸有相续生老病死流转不绝者立六界中。无漏意识与此相违。是故不立在六界中。复次若法是趣苦集行亦是趣有世间生老病死集行者立六界中。无漏意识与此相违。是故不立在六界中。复次若法是有身见事。颠倒事爱事。随眠事与贪嗔痴为安足处。有垢有毒有秽有刺。有过有浊堕在诸有苦集谛摄者立六界中。无漏意识与此相违。是故不立在六界中。尊者世友作是问言。此六界中何故不摄无漏意识。即自答言。如是六界从诸漏生。无漏意识不从漏生。复作是说。如是六界能生诸漏。无漏意识不生诸漏。复作是说。如是六界是我执缘。无漏意识非我执缘。复作是说。如是六界是有情依。无漏意识非有情依。复作是说。如是六界是异熟依。无漏意识非异熟依。复作是说如是六界是入胎缘。无漏意识非入胎缘。复作是说。如是六界无始来有。无漏意识非无始有。大德说曰。如是六界是自体分。无漏意识非。自体分。胁尊者言。如是六界是生死依。无漏意识非生死依。由如是等种种因缘无漏意识不立识界

问蕴取蕴界有何差别。答名即差别。谓名为蕴名为取蕴名为界故。复次于有为法施设蕴于有漏法施设取蕴。于有情数法施设界。复次蕴有流转还灭作用。取蕴唯有流转作用。界有结生入胎作用如是名为蕴取蕴界三种差别

有二法。谓有色无色法。问何故作此论。答为欲遮遣补特伽罗。及为显示智殊胜故。为欲遮遣补特伽罗者。谓显唯有有色无色法毕竟无实补特伽罗故。及为显示智殊胜者。谓有聪慧殊胜智者。由此二法通达一切。此二遍摄一切法故。由此二缘故作斯论。问有色法云何。答谓十处一处少分。十处者。谓眼耳鼻舌身色声香味触处。一处少分者。谓法处少分。问无色法云何。答谓一处一处少分。一处者谓意处。一处少分者。谓法处少分。问此中何等名有色法无色法耶。答若法有色名体是色者名有色法。若法有非色名体非色者名无色法。或有法虽有色名而体非色。如契经说寂静解脱超有色法。至无色法。应知此中有色法者即有色定。又契经说。身证色定具足而住。又如有言。我今正受如是色受。又如佛说。我以如是色经典句付属汝等应正受持。如是等处虽有色名而体非色。若有色名体是色者名有色法。或色体有色用。或色用有色体。或体与相互相有故立有色名。复次若法体是四大种。或是四大种所造者名有色法。若法体非四大种。或非四大种所造者名无色法。复次若法大种为因及体是所造色者名有色法。若法非大种为因及体非所造色者名无色法。复次若法可种植可增长者名有色法。若法不可种植及不可增长者名无色法。尊者世友作如是说。有色相者名有色法。何等名有色相。谓有渐次积集相者名有色相。复作是说。若有渐次散坏相者名有色相。复作是说。若有形质可取相者名有色相。复作是说。若有方所可取相者名有色相。复作是说。若有大小所取相者名有色相。复作是说。若有障碍可取相者名有色相。复作是说。若有怨害可取相者名有色相。复作是说。若有损害可取相者名有色相。复作是说。若增益可取相者名有色相。复次若有三种色相可得名有色相。谓或有色有见有对。或复有色无见有对。或复有色无见无对。复作是说。若有牵来引去相者名有色相。复作是说。有变碍相名有色相。问若有变碍相名有色相者。过去未来极微无表既无变碍应无色相。若无色相体应非色。答彼亦是色得色相故。谓过去色虽今无变碍而曾有变碍。未来色虽今无变碍而当有变碍极微一一虽无变碍而多积集即有变碍。无表自体虽无变碍而彼所依有变碍故亦名变碍。所依者何谓四大种。所依有变碍故无表亦可说有变碍。如树动时影亦随动。复作是说。若有容受障碍相者名有色相。复作是说。若有大种为因相者名有色相。复作是说。无一切色同一色相。所以者何。眼处色相异乃至法处所摄色相异。大德说曰。若有能坏有对色相是有色相。与前所说色相相违名无色相。若法有此无色相。者名无色法

问堕法处色。何不摄在十色处中。答若色可以刹那极微而分析者立十色处。堕法处色虽有刹那可分析义。而无极微可分析义故不摄在十色处中。复次若色可作五识所依及所缘者立十色处。堕法处色不与五识作所依缘故不摄在十色处中。复次若色有障碍可立十色处。堕法处色既无障碍故不摄在十色处中

问为欲界色多色界色多耶。答若依处说欲界色多色界色少。所以者何。以欲界色摄二处全九处少分。色界色唯摄九处少分。若依体说色界色多欲界色少。所以者何。以色界身处俱广大故。谓色界身形量广大过于欲界。色界处所亦复如是。施设论说。如从此处至梵众天。从梵众天至梵辅天。其量亦尔。广说乃至。如从此处至善见天。从善见天。至色究竟其量亦尔。故色界色多于欲界

复有二法。谓有见无见法。问何故作此论。答为欲遮遣补特伽罗。及为显示智殊胜故。为欲遮遣补特伽罗者。谓显唯有见无见法毕竟无实补特伽罗故。及为显示智殊胜者。谓有聪慧殊胜智者。由此二法通达一切。此二遍摄一切法故。复次为止他宗显正理故。谓或有执一切法皆是有见。如尊者妙音彼作是说。一切法皆是有见慧眼境故。为止彼意显一切法。或是有见或是无见。由此三缘故作斯论。问有见法云何答。一处谓色处。问无见法云何。答十一处。谓余十一处。问有见无见是何义耶。尊者世友作如是说。能现所现及可示现在此在彼是有见义。与此相违是无见义。大德说曰。是眼所照。是眼所行。是眼境界是有见义。与此相违是无见义。胁尊者言。若有影像明了可见是有见义。与此相违是无见义。问何故有色十一处中唯一色处说名有见。答唯一色处粗显易了。广说如前。十一色内唯一色处立色处名。此有见法有二十种。谓长短方圆正不正高下。青黄赤白影光明暗云烟尘雾。复有说者。此有二十一。谓前二十种加空一显色。问此二十色内。几有显无形几有显有形。答二十色内八有显无形。谓青黄赤白影光明暗。余十二色有显有形。有说此中应作四句。或有色有显无形。谓青黄赤白影光明暗。此八种色有显可知无形可知故。或有色有形无显。谓身表色此有形可知无显可知故。或有色有显有形。谓长短方圆正不正高下云烟尘雾。此十二种有显有形而可知故。或有色无显无形。谓除前相。即空界色。问水镜等中所有影像为是实有非实有耶。譬喻者说此非实有。所以者何。面不入镜镜不在面。如何镜上有面像生。阿毗达磨诸论师言。此是实有是眼所见眼识所缘色处摄故。问面不入镜镜不在面。云何实有。答生色因缘有多种理非一种理故彼非难。如缘月光月爱珠器。得有水生非不实有。彼所生水有水用故。如缘日光及日爱珠牛粪末等。而有火生非不实有。彼所生火有火用故。如缘钻燧及人功力。而有火生非不实有。彼所生火有火用故。如是缘水镜等及人面等有影像生非不实有。所生影像能为所缘生觉念故。问世间所闻诸谷响等。为是实有非实有耶。譬喻者说。此非实有。所以者何。一切音声刹那性故。于此处生即此处灭。刹那顷生自然即灭。如何能至谷等生响。阿毗达磨诸论师言。此是实有。是耳所闻耳识所缘声处摄故。问声刹那生即此处灭。如何能至谷等生响。答生声因缘非一种理有多种理故彼非难。如缘唇齿舌齶喉等相击出声。彼所出声非不实有。生耳识故。如是缘声及缘谷等而有响生非不实有。能为所缘生觉念故

说一切有部发智大毗婆沙论卷第七十五阿毗达磨大毗婆沙论卷第七十六

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中十门纳息第四之六

复有二法。谓有对无对法。问何故作此论。答为欲遮遣补特伽罗。及为显示智殊胜故。为欲遮遣补特伽罗者。谓显唯有有对无对法。毕竟无实补特伽罗。及为显示智殊胜者。谓有聪慧殊胜智者。由此二法通达一切。此二遍摄一切法故。复次为止他宗显正理故。谓或有执。若与对俱说名有对不与对俱说名无对。若作是说。五识身等名为有对。所依所缘俱对碍故。或复有执。若与嗔俱说名有对。不与嗔俱说名无对。若作是说。嗔相应品心心所法说名有对。为止彼意显有碍色说名有对。此所余法说名无对。由此三缘故作斯论。问有对法云何。答十处。谓五内色处。及五外色处。问无对法云何。答二处。谓意处及法处。问有对无对是何义耶。答诸极微积聚是有对义。非极微积聚是无对义。复次诸可分析是有对义。不可分析是无对义。复次诸可积集是有对义。不可积集是无对义。复次诸有障碍是有对义。若无障碍是无对义。复次诸有形质是有对义。若无形质是无对义。复次若能容受。及能障碍是有对义。若不能容受及不能障碍是无对义。胁尊者言。若可分析则可积集。若可积集则有障碍。若有障碍则有形质。若有形质则能容受及能障碍。若能容受及能障碍是有对义。与上相违是无对义。尊者世友作如是说。有细分相有障碍相是有对相。无细分相无障碍相是无对相。大德说曰。若能容受及能障碍相是有对相。若不能容受及不能障碍是无对相。尊者妙音作如是说。若可施设极微积聚性。显色长短性。随生音响性者。是有对相。与此相违是无对相。此中极微积聚性者。说八处显色。长短性者说色处。随生音响性者说声处。尊者世友作如是说。极微杂合积集住相是有对相。与此相违是无对相。尊者觉天作如是说。能据处所展转相碍是有对相。与此相违是无对相

应知有对总有三种。一障碍有对。二境界有对。三所缘有对。障碍有对者。如以手击手以手击石以石击石以石击手以杵击钟。此等展转更相障碍。如是名为障碍有对。境界有对者。如眼根等诸有境法各于自境界有所拘碍。如是名为境界有对。所缘有对者。如心心所有所缘法。各于自所缘有所拘碍。如是名为所缘有对。如是三种。有对法中。此中但说障碍有对。问障碍有对十色处中。几处展转有相碍义。有作是说。唯有触处有相碍义。余十一处无相碍义非所触故。或有说者。唯有五处有相碍义。谓内处中唯有身处。若外处中色香味触。彼作是说。若以手击手即以五击五。若以手击石即以五击四若以石击石即以四击四。若以石击手即以四击五。若以杵击钟亦以四击四。复有说者。唯有九处有相碍义。十色处中唯除声处。若不尔者。有以手等击眼处等时应不生苦。评曰。应作是说。十种色处皆有碍义。若声处无碍者。此应无积聚义。又不应名障碍有对。施设论说。眼定对色色定对眼。广说乃至意定对法法定对意。彼师但依境界有对。而造彼论故作是说。或有眼于水有碍于陆无碍如鱼等眼。或有眼于陆有碍于水无碍如人等眼。或有眼于水于陆二俱有碍。如水逻刹娑捕鱼人等眼。或有眼于水于陆二俱无碍。谓除前相即被翳眼。或有眼于夜有碍于昼无碍如鸺鹠等眼。或有眼于昼有碍于夜无碍如人等眼。或有眼于昼于夜二俱有碍如马鹿猫狸等眼。或有眼于昼于夜二俱无碍。谓除前相即被翳眼。此中有碍者谓境界有对

复有二法谓有漏无漏法。问何故作此论。答为欲遮遣补特伽罗。及为显示智殊胜故。为欲遮遣补特伽罗者。谓显唯有有漏无漏法。毕竟无实补特伽罗。及为显示智殊胜者。谓有聪慧殊胜智者。由此二法通达一切。此二遍摄一切法故。复次为止他宗显正理故。谓或有执。佛身无漏如大众部。问彼何故作此执。答依契经故。如契经说。苾刍当知。如来生在世间长在世间出世间住。不为世法之所染污。彼作是说。既言如来出世间住不为世法之所染污。由此故知佛身无漏。为止彼意显佛生身唯是有漏。若佛生身是无漏者便违契经。如契经说。无明所覆爱结所缚。愚夫智者感有识身。世尊亦是智者所摄身定应是无明爱果。是故佛身定应有漏。又若佛身是无漏者。无比女人不应于佛生身起爱。指鬘于佛不应生嗔诸憍傲者不应生慢。坞卢频螺迦叶波等不应生痴。于佛生身既有发起贪嗔痴慢。故知佛身定非无漏。问若佛生身是有漏者。云何通彼所引契经。答彼说法身故不成证。谓彼经说。如来生在世间长在世间者。说佛生身。出世间住不为世法所染污者说佛法身。复次依佛不随世法转义说彼契经故无有失。谓世八法随世间转。世间亦随世八法转。虽世八法随世间转。而佛不随世八法转。复次依佛解脱世八法义。说彼契经。故无有失。问佛亦曾遇此世八法。如何说佛解脱此耶。谓一日中勇猛长者曾奉施佛三百千衣。诸如是等名佛遇利。佛入娑罗婆罗门邑乞食不得空钵而还。诸如是等名佛遇衰。佛于生时名誉上至他化自在。得菩提时名誉上至色究竟天。转法轮时名誉上至大梵王宫。诸如是等名佛遇誉。佛为战遮婆罗门女孙陀利女恶心毁谤。恶名流布十六大国。诸如是等名佛遇毁。佛为跋罗堕阇梵志以五百颂现前讥骂诸如是等名佛遇讥。即此梵志须臾回此五百颂言现前赞佛。如是论力及坞波离以妙伽他现前赞佛。尊者舍利子以众多颂现前赞佛无上功德。尊者阿难陀以众多颂现前赞佛希有妙法。诸如是等名佛遇称。佛有轻安及胜受乐。一切有情所不能及名佛遇乐。佛有头痛背痛腹痛。及有伤足出血等事名佛遇苦。既有此事如何解脱。答虽遇此事而不生染。故说世尊于此解脱。谓佛虽遇利等四法。而心不生高欢喜爱。又佛虽遇衰等四法。而心不生下戚忧恚。如妙高山据金轮上。八方猛风不能倾动。世尊亦尔住戒金轮。此世八法所不能动。是故名为于此解脱。解脱此故说为不染。非谓生身亦是无漏。然佛生身从漏生故说为有漏。能生他漏故名有漏。是故为止他宗所说及显己宗无颠倒理。并前二缘故作斯论。问有漏法云何。答十处二处少分。谓意处法处少分。问无漏法云何。答二处少分。谓即意处法处少分。问有漏无漏其义云何。答若法能长养诸有。摄益诸有。任持诸有。是有漏义。与此相违是无漏义。复次若法能令诸有相续生老病死流转不绝是有漏义。与此相违是无漏义。复次若法是趣苦集行。及是趣诸有世间生老病死行是有漏义与此相违是无漏义。复次若法是有身见事。苦集谛摄是有漏义。与此相违是无漏义。复次若法能令诸漏增长是有漏义。若法能令诸漏损减是无漏义。尊者世友作如是说。有漏相者从漏生相是有漏相。能生漏相是有漏相。无漏相者与此相违。大德说曰。若离此事诸漏不有。应知此事是有漏相。若离此事诸漏得有。应知此事是无漏相。尊者觉天作如是说。若法是漏生长依处是有漏相。与此相违是无漏相

复有二法。谓有为无为法。问何故作此论。答为欲遮遣补特伽罗。及为显示智殊胜故。为欲遮遣补特伽罗者。谓显唯有有为无为法。毕竟无实补特伽罗故。及为显示智殊胜者。谓有聪慧智殊胜者。由此二法通达一切。此二遍摄一切法故。复次为止他宗显正理故。谓或有执。有对法是有为。无对法是无为。或复有执。有漏法是有为。无漏法是无为。为止彼意显无对法及无漏法俱通有为无为由此三缘故作斯论。问有为法云何。答十一处一处少分。谓法处少分。问无为法云何。答一处少分。谓法处少分。问有为无为是何等义。答若法有生有灭有因有果得有为相。是有为义。若法无生无灭无因无果。得无为相。是无为义。复次若法依属因缘和合作用是有为义。若法不依属因缘和合作用是无为义。复次若法为生所起。为老所衰。为无常所灭。是有为义。与此相违是无为义。复次若法流转于世。能取果。有作用分别所缘。是有为义。与此相违是无为义。复次若法堕世堕蕴与苦相续。前后变易有下中上是有为义。与此相违是无为义。尊者世友作如是说。何等有为相。谓堕世相堕蕴相是有为相。何等无为相。谓不堕世相不堕蕴相是无为相。大德说曰。若法由有情加行。而有聚散是有为相。若法由有情加行。而无聚散是无为相。尊者觉天作如是说。若法由因缘作是有为相。若法不由因缘作是无为相。尊者妙音作如是说。若法与有为相合是有为相。若法不与有为相合是无为相

复有三法。谓过去未来现在法。问何故作此论。答为止他宗显正理故。谓或有执。世与行异。如譬喻者分别论师。彼作是说。世体是常行体无常。行行世时如器中果。从此器出转入彼器。亦如多人从此舍出转入彼舍。诸行亦尔。从未来世入现在世。从现在世入过去世。为止彼意显世与行体无差别。谓世即行行即是世。故大种蕴作如是说。世名何法。谓此增语所显诸行。复有愚于三世自性。谓拨无过去未来。执现在是无为法。为止彼意显过去未来体相实有。及显现在是有为法。所以者何。若过去未来非实有者。应无成就及不成就。如第二头第三手第六蕴第十三处第十九界。无有成就及不成就。过去未来法亦应尔。既有成就及不成就。故知实有过去未来。又应诘彼拨无过去未来体者。若有异熟因在现在世时。彼所得果当言在何世。过去耶未来耶现在耶。若言在过去应说有过去。若言在未来应说有未来。若言在现在应说异熟因果同时。如是便违伽他所说

  作恶不即受　　非如乳成酪
  犹灰覆火上　　愚蹈久方烧

若言彼果不在三世彼应无果。以异熟果非无为故。若无果者因亦应无。如第二头第三手等。若有异熟果在现在世时。彼所酬因当言在何世。过去耶未来耶现在耶。若言在过去应说有过去。若言在未来应说有未来。若言在现在应说异熟因果同时。如是便违前所引颂。若言彼因不在三世。彼应无因。以异熟因非无为故。若无因者果亦应无。如第二头第三手等。复次若过去未来非实有者。应无出家受具戒义。如有颂言

  若执无过去　　应无过去佛
  若无过去佛　　无出家受具

复次若过去未来非实有者。应出家众皆有正知而虚诳语。如有颂言

  若执无过去　　而言岁少多
  彼应日日增　　正知虚诳语

复次若过去未来非实有者。彼现在世应亦是无。观过去未来施设现在故。若无三世便无有为。若无有为亦无无为。观有为法立无为故。若无有为无为应无一切法。若无一切法应无解脱出离涅槃。如是便成大邪见者。勿有斯过故知实有过去未来。又现在世非无为法。因缘生故有作用故。无为不尔。如是为遮他宗所说及显正理故作斯论

问过去法云何。答五蕴十二处十八界各一分。问未来法云何。答五蕴十二处十八界各一分。问现在法云何。答五蕴十二处十八界各一分。问如是三世以何为自性。答以一切有为法为自性。如说自性。我物自体相分本性应知亦尔。已说自性。所以今当说。问何故名世。世是何义。答行义是世义。问诸行无来无去。云何行义是世义。所以者何。诸行若来不应有去来相合故。诸行若去不应有来去相合故。复次诸行若来则来处应空缺。诸行若去则去处应盈碍。是故尊者世友说言。诸行无来亦无有去。刹那性故住义亦无。诸行既无来去等相。如何立有三世差别。答以作用故立三世别。即依此理说有行义。谓有为法未有作用名未来。正有作用名现在。作用已灭名过去。复次色未变碍名未来。正有变碍名现在。变碍已灭名过去。受未领纳名未来。正能领纳名现在。领纳已灭名过去。想未取相名未来。正能取相名现在。取相已灭名过去。行未造作名未来。正有造作名现在。造作已灭名过去。识未了别名未来。正能了别名现在。了别已灭名过去。复次眼未见色名未来。正能见色名现在。见色已灭名过去。广说乃至意未了法名未来。正能了法名现在。了法已灭名过去。问现在眼等若彼同分无见等用应非现在。答彼虽无有见等作用。而决定有取果作用。是未来法同类因故诸有为法在现在时皆能为因取等流果。此取果用遍现在法无杂乱故。依之建立过去未来现在差别。复次诸有为法三有为相。未已作用名未来。一已作用二正作用名现在。三已作用名过去。复次诸有为法未有四缘作用名未来。正有四缘作用名现在。四缘作用已灭名过去。复次诸有为法未有六因作用名未来。正有六因作用名现在。六因作用已灭名过去。复次诸有为法未取未与士用果名未来。正取正与士用果名现在。取与士用果已灭名过去。复次诸有为法未取未与等流果名未来。正取或与等流果名现在。取或与等流果已灭名过去。复次不善善有漏法。未取未与异熟果名未来。正取未与异熟果名现在。取异熟果已灭名过去。复次诸有为法。未酬相应俱有因名未来。正酬相应俱有因名现在。酬相应俱有因已灭名过去。复次诸有为法。未已酬同类遍行因名未来。已酬未灭名现在。已酬已灭名过去。复次异熟无记法。未已酬异熟因名未来。已酬未灭名现在。已酬已灭名过去。复次诸有为法未已起灭名未来。已起未已灭名现在。已起已灭名过去。复次诸有为法。未已起坏名未来。已起未已坏名现在。已起已坏名过去。复次诸有为法。未已起离名未来。已起未已离名现在。已起已离名过去。如起对灭坏离。生对灭坏离亦尔。然契经中未来亦说已生等者。依彼种类故作是说。如说有法已生已有已作。有为。有所作缘已生。有尽法有费法有离法有灭法有坏法。欲令不坏无有是处。此中已生者。唯说生所生法。已有者。显有自性。已作者。显有过患。有为者。显有造作。有所作者。显业有果。缘已生者。显因缘合。有尽费离灭坏法者。显定当有欲令不坏。无有是处者。显不自在。复次诸有为法在二世前名过去。在二世后名未来。在二世中名现在。复次诸有为法。为三世因名过去。为二世因名现在。为一世因名未来。复次诸有为法。是三世果名未来。是二世果名现在。是一世果名过去。复次诸有为法。观过去现在故施设未来。不观未来故施设未来。无第四世故观未来现在。故施设过去。不观过去故施设过去。无第四世故。观过去未来。故施设现在。不观现在故施设现在。无第四世故。如是名为三世差别。依此建立诸行行义。由此行义世义得成

问诸有为法未来生时。为已生而生。为未已生而生。设尔何失。二俱有过。所以者何。若已生而生者。云何诸行非转还耶。若未已生而生者。云何诸行非本无而有耶。答应作是说。有因缘故已生而生。谓一切法已有自性本来各住自体相故。已有体故说名已生。非从因缘已生自体。因缘和合起故名生。有因缘故未已生而生。谓未来法名未已生。有从因缘正得生故。问诸有为法未来生时。为已有故而生。为未已有故而生。设尔何失。二俱有过。所以者何。若已有故而生者。自体已有复何用生。若未已有故而生者。应一切法本无今有。说一切有应不得成。答应作是说已有而生。问若尔。善通后所设难。前所设难当云何通。答体虽已有而无作用。今遇因缘而生作用。问作用与体为一为异。答不可定说为一为异。如有漏法一一体上有无常等众多义相。不可定说为一为异。此亦如是。故不应责。问为此法生即此法灭。为余法生余法灭耶。设尔何失。二俱有过。所以者何。若此法生即此法灭者。应未来生即未来灭。若余法生余法灭者。应色等生余受等灭。答应作是说。有因缘故说此法生即此法灭。谓色蕴生即色蕴灭。乃至识蕴生即识蕴灭。有因缘故说余法生余法灭。谓未来世生现在世灭。问诸有为法未来生时。为世体生为世中生。设尔何失。二俱有过。所以者何。若世体生者。一法生时应未来世一切法生。此既生已应无未来。此复已灭应无现在。便坏三世一切有义若世中生者。云何诸行非异世耶。答应作是说。有因缘故说世体生。以一刹那行生时即是未来世生故。有因缘故说世中生。未来世行有多刹那。于中唯一刹那生故。问诸有为法未来生时为自性生。为他性生。设尔何失。二俱有过。所以者何。若自性生者。云何非本无自性今有自性。本无实物今有实物。若他性生者。云何不舍自性成无性相。答应作是说。非自性生。亦非他性生。然于自性有如是法生已而灭

问若法是色性。彼法是过去性耶。答应作四句。有法是色性非过去性。谓未来现在色性。有法是过去性非色性。谓过去四蕴性。有法是色性亦过去性。谓过去色性。有法非色性亦非过去性。谓未来现在四蕴性及无为性。如以色性对过去性有四句。以色性对未来现在性亦各有四句。如色蕴对三世有三四句。受想行识蕴对三世亦尔。如是便有十五四句。问若法是色性。彼法是方处性耶。答若法是方处性彼定是色性。有法是色性非方处性。谓过去未来色。及现在极微无表色性。问若法是受性。彼法非方处性耶。答若法是受性彼定非方处性。有法非方处性而非是受性。谓想行识蕴。及极微无表色无为性。如受蕴想乃至识蕴应知亦尔

问若法是色。彼法有变碍耶。答若法有变碍彼定是色。有法是色而无变碍。谓过去未来色。及现在极微无表色。问若法是受。彼法能领纳耶。答若法能领纳彼定是受。有法是受非能领纳。谓过去未来受。问若法是想。彼法能取像耶。答若法能取相彼定是想。有法是想非能取相。谓过去未来想。问若法是行。彼法能造作耶。答若法能造作彼定是行。有法是行非能造作。谓过去未来行。问若法是识彼法能了别耶。答若法能了别彼定是识。有法是识非能了别。谓过去未来识。问未来诸法有出无入。过去诸法有入无出。如何未来不施设减。如何过去不施设增。尊者世友作如是说。为已计数而言未来不施设减。复言过去不施设增耶。既未计数如何可言不可施设未来有减过去有增。然过去未来法无边量故。不可施设有增有减。如大海水无量无边。取百千瓶不知其减。投百千瓶不知其增。复作是说。未来诸法未已起未已灭故不施设减。过去诸法已起已灭故不施设增。复作是说。未来诸法未已起已坏故不施设减。过去诸法已起已坏故不施设增。复作是说。未来诸法未已起已离故不施设减。过去诸法已起已离故不施设增。如起对灭坏离。以生对灭坏离广说亦尔。大德说曰。若有碍物流行世者。可言施设有减有增。然有为法缘合故生生已即灭。如何施设过去有增未来有减。胁尊者曰。过去未来法无作用。如何施设有增有减

问过去未来为有积聚。如现在世墙壁等物。为无积聚各离散耶。设尔何失。二俱有过。所以者何。若有积聚如现在世墙壁等者。云何施主造所舍物功不唐捐。云何去来非有方所。云何壁等不皆是常。云何去来非可现见。若无积聚各离散者。云何可说有过去事。如契经说。过去有王名大善见。都香茅城居善法殿。如是等事无量无边。云何可说有未来事。如契经说。未来有佛号慈氏尊。尔时有王名曰蠰佉。所都大城名鸡睹末。如是等事无量无边。云何宿住随念智观过去事。死生智观未来事。妙愿智观过去未来事。未来诸法来集现在时。如何聚物非本无今有。现在诸法散往过去时。如何聚物非有已还无。有作是说。过去未来亦有积聚。如现在世墙壁等物。问若尔。善通后所设难前所设难当云何通。且诸施主造所舍物。所设功力宁不唐捐。答为现见故。谓未造时物虽已有而未现见。施主造已方可现见。故不唐捐。云何去来非有方所。答许有方所复有何过。云何壁等不皆是常。答刹那无常与彼合故。云何去来非可现见。答彼非现在五识境故非可现见。要与现在五识为境方可现见评曰。过去未来非有积聚如现在物但各离散。问若尔善通前所设难。后所设难当云何通。且云何说有过去事。答如曾现在说亦无失。云何可说有未来事。答如当现在说亦无失。云何宿住随念智等观察过去未来事耶。答如曾所更如当所受。而观过去未来世事。此有何过而不能通复有说者。如呼诸字次第相续引生名句显所说义。虽彼诸字不可积集。而能引生名句显义。如是过去未来世法虽无积聚。而能生智。随其所应知所知境复有说者。以现在事类观去来。犹如农夫以现稼穑类知前后。未来诸法来集现在时。如何聚物非本无今有。现在诸法散往过去时。如何聚物非有已还无。答三世诸法因性果性。随其所应次第安立。体实恒有无增无减。但依作用说有说无。诸积聚事。依实有物。假施设有。时有时无。如是此宗许有无义有何过难。而不能通分位。有无是所许故

说一切有部发智大毗婆沙论卷第七十六阿毗达磨大毗婆沙论卷第七十七

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中十门纳息第四之七

说一切有部有四大论师。各别建立二世有异。谓尊者法救说类有异。尊者妙音说相有异。尊者世友说位有异。尊者觉天说待有异。说类异者。彼谓诸法于世转时。由类有异非体有异。如破金器等作余物时形虽有异而显色无异。又如乳等变成酪等时舍味势等非舍显色。如是诸法从未来世至现在世时。虽舍未来类得现在类。而彼法体无得无舍。复从现在世至过去世时。虽舍现在类得过去类。而彼法体亦无得无舍。说相异者。彼谓诸法于世转时。由相有异非体有异。一一世法有三世相。一相正合二相非离。如人正染一女色时。于余女色不名离染。如是诸法住过去世时。正与过去相合。于余二世相不名为离。住未来世时。正与未来相合。于余二世相不名为离。住现在世时。正与现在相合。于余二世相不名为离。说位异者。彼谓诸法于世转时。由位有异非体有异。如运一筹。置一位名一。置十位名十。置百位名百。虽历位有异而筹体无异。如是诸法经三世位。虽得三名而体无别。此师所立世无杂乱。以依作用立三世别。谓有为法未有作用名未来世。正有作用名现在世。作用已灭名过去世。说待异者。彼谓诸法于世转时前后相待立名有异。如一女人待母名女待女名母体虽无别由待有异得女母名。如是诸法待后名过去。待前名未来。俱待名现在。彼师所立世有杂乱。所以者何。前后相待一一世中有三世故。谓过去世前后刹那名过去未来。中间名现在未来。三世类亦应然。现在世法虽一刹那待后待前及俱待故应成三世。岂应正理。说相异者。所立三世亦有杂乱。一一世法彼皆许有三世相故。说类异者。离法自性说何为类故亦非理。诸有为法从未来世至现在时前类应灭。从现在世至过去时后类应生。过去有生未来有灭岂应正理。故唯第三立世为善。诸行容有作用时故

复有三法。谓善不善无记法。问善法云何。答善五蕴及择灭。问不善法云何。答不善五蕴。问无记法云何。答无记五蕴及虚空非择灭。余义广说如前不善纳息

复有三法。谓欲界色界无色界系法。问欲界系法云何。答欲界系五蕴。问色界系法云何。答色界系五蕴。问无色界系法云何。答无色界系四蕴。余义广说亦如前不善纳息。复有三法。谓学无学非学非无学法。问学法云何。答学五蕴。问无学法云何。答无学五蕴。问非学非无学法云何。答有漏五蕴及三无为。问学等三法其义云何。答以无贪嗔痴道学断贪嗔痴是学义。以无贪嗔痴道不学断贪嗔痴。已学断故是无学义。与二相违是非学非无学义。复次以无爱道。学断爱非爱事是学义。以无爱道学断爱者。遮无学道。非爱事者。遮世俗道。以无爱道不学断爱已学断故。亦非爱事是无学义。以无爱道不学断爱者。遮学道。非爱事者。遮世俗道。与二相违是非学非无学义。复次学断烦恼学谛现观是学义。不学断烦恼已学断故。亦不学谛现观已学谛现观故是无学义。与二相违是非学非无学义。复次学断二求谓欲求有求。学满一求。谓梵行求。是学义。不学断二求已学断故。不学满一求。已学满故是无学义。与二相违是非学非无学义。复次若相续中有烦恼得。亦有无漏道得。而学断烦恼是学义。若相续中无烦恼得。而有无漏道得。不学断烦恼已学断故是无学义。与二相违是非学非无学义。复次若相续中未离贪爱。有无漏道得而学断贪爱是学义。若相续中已离贪爱而有无漏道得。不学断贪爱已学断故是无学义。与二相违是非学非无学义。复次见修道摄是学义。无学道摄是无学义与二相违是非学非无学义。复次见修地摄是学义。无学地摄是无学义。与二相违是非学非无学义。复次未知当知已知根摄是学义。具知根摄是无学义。与二相违是非学非无学义。复次随信行随法行信胜解见至身证。五圣者身中诸无漏道是学义。慧解脱俱解脱。二圣者身中诸无漏道是无学义。与二相违是非学非无学义。复次四向及前三果。七圣者身中诸无漏道是学义。第四果一圣者身中诸无漏道是无学义。与二相违是非学非无学义。复次十八学圣者身中诸无漏道是学义。九无学圣者身中诸无漏道是无学义。与二相违是非学非无学义。问住学果者乃至未起胜果道时。诸无漏道云何名学。答学阿世耶犹未息故。彼无漏道亦得名学

复有三法。谓见所断修所断无断法。问见所断法云何。答随信随法行现观边忍所断。此复云何。谓见所断八十八随眠及彼相应心心所法。彼所等起不相应行。是名见所断法。问修所断法云何。答学见迹修所断。此复云何。谓修所断十随眠。及彼相应彼所等起身语二业。彼所等起不相应行。并不染污诸有漏法。是名修所断法。问无断法云何。答无漏五蕴。及三无为。余义广说如前不善纳息。四谛者。谓苦谛集谛灭谛道谛。问何故作此论。答为广分别契经义故。谓契经说有四圣谛。虽作是说而不广辩。经是此论所依根本。彼未说者今欲说之。故作斯论。问如是四谛自性云何。阿毗达磨诸论师言。五取蕴是苦谛。有漏因是集谛。彼择灭是灭谛学无学法是道谛。譬喻者说。诸名色是苦谛。业烦恼是集谛。业烦恼尽是灭谛。奢摩他毗钵舍那是道谛。分别论者作如是说。若有八苦相是苦是苦谛。余有漏法是苦非苦谛。招后有爱是集是集谛。余爱及余有漏因是集非集谛。招后有爱尽是灭是灭谛。余爱尽及余有漏因尽是灭非灭谛。学八支圣道是道是道谛。余学法及一切无学法是道非道谛。若作是说。诸阿罗汉但成就苦灭二谛。不成就集道二谛。所以者何。招后有爱诸阿罗汉已断尽故。学八支圣道得阿罗汉果时皆已舍故。尊者妙音作如是说。若堕自相续五蕴。若堕他相续五蕴。若有情数及无情数诸蕴。如是一切皆是苦是苦谛。修观行者起现观时。唯观堕自相续五蕴为苦。不观堕他相续五蕴。及无情数诸蕴为苦。所以者何。逼切行相是苦现观。堕他相续及无情数蕴于自相续非逼切故。彼生智论作如是说。自相续蕴极自逼切。非他相续及无情数蕴。非离自身他及非情能相逼切。无自身者他及非情何所逼切。故现观时唯观堕自相续五蕴为苦非余。若堕自相续五蕴因。若堕他相续五蕴因。若有情数及无情数诸蕴因。如是一切皆是集是集谛。修观行者起现观时。唯观堕自相续五蕴因为集不观堕他相续五蕴因。及无情数诸蕴因为集。若堕自相续五蕴尽。若堕他相续五蕴尽。若有情数及无情数诸蕴尽。如是一切皆是灭是灭谛。修观行者起现观时。唯观堕自相续五蕴尽为灭。不观堕他相续五蕴尽。及无情数诸蕴尽为灭。若堕自相续五蕴对治。若堕他相续五蕴对治。若有情数及无情数诸蕴对治。如是一切皆是道是道谛。修观行者起现观时。唯观堕自相续五蕴对治为道。不观堕他相续及无情数诸蕴对治为道。如是说者。若堕自相续五蕴。若堕他相续五蕴。若有情数及无情数诸蕴。如是一切皆是苦是苦谛。修观行者起现观时。皆观为苦。问逼切行相是苦现观。堕他相续及无情数蕴。于自相续既非逼切。修观行者起现观时何故亦观为苦。答设彼于自不能逼切亦观为苦。所以者何。无始时来于一切苦皆起无智。为对治彼皆应起智。无始时来于一切苦皆起犹豫。为对治彼皆应起决定。无始时来于一切苦皆起诽谤。为对治彼皆应起信。故应遍观一切为苦。况彼于自亦能逼切。所以者何。若有为他所打触者。亦生大苦。岂非逼切。若有空中木石瓦等堕自身上。亦生大苦。岂非逼切。既有逼切自相续义。故现观时亦观为苦。若堕自相续五蕴因。若堕他相续五蕴因。若有情数及无情数诸蕴因。如是一切皆是集是集谛。修观行者起现观时皆观为集。若堕自相续五蕴尽。若堕他相续五蕴尽。若有情数及无情数诸蕴尽。如是一切皆是灭是灭谛。修观行者起现观时皆观为灭。若堕自相续五蕴对治。若堕他相续五蕴对治。若有情数及无情数诸蕴对治。如是一切皆是道是道谛。修观行者起现观时皆观为道。如是名为四谛自性我物自体相分本性

已说谛自性。所以今当说。问何故名谛。谛是何义。答实义是谛义。真义如义不颠倒义无虚诳义是谛义。问若实义是谛义。乃至无虚诳义是谛义者。虚空非择灭亦有实义乃至无虚诳义。何故世尊不立为谛。答若法是苦是苦因。是苦尽是苦对治者。世尊立为谛。虚空非择灭非苦非苦因非苦尽非苦对治。是故世尊不立为谛。复次若法是蕴是蕴因是蕴尽是蕴对治者立为谛。虚空非择灭非蕴非蕴因非蕴尽非蕴对治故不立为谛。复次若法是疾病是疾病因是疾病尽是疾病对治者立为谛。虚空非择灭非疾病非疾病因非疾病尽非疾病对治故不立为谛。复次若法是痈箭恼害过患。是痈箭恼害过患因。是痈箭恼害过患尽。是痈箭恼害过患对治者立为谛。虚空非择灭于彼皆非故不立为谛。复次若法是重担。是能荷重担是重担尽。是重担对治者立为谛。虚空非择灭于彼皆非故不立为谛。复次若法是此岸是彼岸是河是船筏者立为谛。虚空非择灭于彼皆非故不立为谛。复次若法是苦是苦因。是道是道果者立为谛。虚空非择灭非苦非苦因。非道非道果故不立为谛。复次若法有因性果性者立为谛。虚空非择灭无因性果性故不立为谛。复次虚空非择灭无漏故非苦集谛。无记故非灭谛。无为故非道谛。复次虚空非择灭不堕世故非三谛。无记故非灭谛。复次虚空非择灭非蕴自性故非三谛。无记故非灭谛。复次虚空非择灭不随苦故非三谛。无记故非灭谛。复次若法是邪见及无漏慧所缘者立为谛。虚空非择灭非邪见及无漏慧所缘故不立为谛。复次若法是无明及明所缘者立为谛。虚空非择灭非无明及明所缘。故不立为谛。复次若法是杂染事及清净事者立为谛。虚空非择灭非杂染事及清净事。故不立为谛。复次若法是可欣事及可厌事者立为谛。虚空非择灭非可欣事及可厌事。故不立为谛。复次若法是欣作意事及厌作意事者立为谛。虚空非择灭非欣作意事及厌作意事。故不立为谛

问若不颠倒义是谛义者。四种颠倒应非谛摄。所以者何。颠倒转故。答以余缘故立为颠倒。以余缘故是谛所摄。谓三缘故立为颠倒。一决度故。二增益故。三一向倒故。是有是实实相相应故是谛摄。复次彼于无常计常苦计为乐不净计净无我计我故立为倒。以有因性果性故是谛摄。问若无虚诳义是谛义者。诸虚诳语应非谛摄。所以者何。虚诳转故。答以余缘故立虚诳语。谓违自想诳惑他故。以余缘故是谛所摄。谓是有是实实相相应。复次以余缘故立虚诳语。谓不见言见见言不见。不闻言闻闻言不闻。不觉言觉觉言不觉。不知言知知言不知。以余缘故是谛所摄。谓有因性果性是故实义是谛义。乃至无虚诳义是谛义问此四圣谛云何建立为依。实事为依。因果为依。现观而建立耶。设尔何失。三皆有过。所以者何。若依实事而建立者。谛应有三。谓苦集谛。无别体故应合为一。灭为第二道为第三。故有三谛。若依因果而建立者。谛应有五。谓有漏法因果别故既立为二。诸无漏道亦有因果应分为二。灭为第五故有五谛。若依现观而建立者。谛应有八。谓瑜伽师入现观位。先别观欲界苦。后合观色无色界苦。先别观欲界诸行因。后合观色无色界诸行因。先别观欲界诸行灭。后合观色无色界诸行灭。先别观欲界诸行对治。后合观色无色界诸行对治。故有八谛。答应作是说。此四圣谛依因果立。问若尔。应有五谛非四。答圣道因果合立一故谛四非五。谓无漏道因性果性皆是能趣苦有世间生老病死究竟灭行故合立一。问若尔。有漏因性果性皆是能趣苦有世间生老病死流转集行。亦应合一。谛应唯三。答虽尔行相有别有总。是故建立圣谛唯四。谓于有漏果性有四行相。一苦二非常三空四非我。于有漏因性有四行相。一因二集三生四缘。于无漏道因性果性。总唯有四行相。一道二如三行四出。有作是说。以三缘故建立四谛。一实事故。二因果故。三谤信故。实事故者。谓此四谛实事有二。一者有漏。二者无漏。因果故者。谓有漏事有因果性。果性立苦谛。因性立集谛。无漏事中有二种类一有因性有果性二有果性无因性。有因性有果性。者立道谛。有果性无因性者立灭谛。问何故有漏事因性果性各立一谛。无漏道因性果性合立一谛耶。答缘彼谤信有别总故。谓于有漏因性果性各别起谤。一于果性谤实非苦。二于因性谤实非集。又于有漏因性果性各别生信。一于果性信实是苦。二于因性信实是集。于无漏道因性果性。总起一谤谓谤非道。总生一信谓信是道。是故三缘建立四谛。复有说者。依现观故建立四谛。问若尔。圣谛应八非四。答谛行相同故四非八。谓欲界苦及色无色界苦。虽别现观而同是苦谛。及同苦等行相所观故合立一。欲界诸行因及色无色界诸行因。虽别现观而同是集谛。及同因等行相所观故合立一。欲界诸行灭及色无色界诸行灭。虽别现观而同是灭谛。又同灭等行相所观故合立一。欲界诸行对治。及色无色界诸行对治。虽别现观而同是道谛。又同道等行相所观故合立一。故依现观建立四谛不增不减

问苦集灭道各有何相。胁尊者曰。逼迫是苦相。生长是集相。寂静是灭相。出离是道相。尊者世友作如是说。流转是苦相。能转是集相。止息是灭相。还灭是道相。复作是说。生依流转是苦相。能转生依是集相。生依止息是灭相。能灭生依是道相。大德说曰。于实有事建立谛名。谓五取蕴。如从炉出极热铁团。三苦所随顺苦流转没在苦海杂苦而住。如苦合成犹如铁团。与火合故火势随逐极热如火。此五取蕴亦复如是。与苦合故如苦合成。故与苦合是苦谛相。如是苦蕴从烦恼生。由业转变诸趣流转。无始相续故能生转是集谛相。此烦恼业究竟离故。于诸趣生不复流转。故不流转是灭谛相。修净戒定正观生灭。能断有因能证有尽。故能断证是道谛相

问若谛有四。何故世尊说有一谛。如伽他说

  一谛无有二　　众生于此疑
  别说种种谛　　我说无沙门

此颂意言唯有一谛。外道犹豫别说有多。佛说彼法中无沙门道果。沙门道果依一谛故。胁尊者曰。言一谛者。谓四圣谛各唯有一。唯一苦谛无第二苦。唯一集谛无第二集。唯一灭谛无第二灭。唯一道谛无第二道。故说一谛。不违说四。复次言一谛者。谓一灭谛为欲遮遣余解脱故。谓诸外道说四解脱。一无身解脱。即空无边处。二无边意解脱。即识无边处。三净聚解脱。即无所有处。四世窣堵波解脱。即非想非非想处。佛作是说。彼非真实解脱出离。是无色有真解脱者。唯一灭谛究竟涅槃。复次言一谛者。谓一道谛。为欲遮遣余道谛故。谓诸外道说多道谛。如执自饿为道。或执卧灰为道。或执随日转为道。或执饮风饮水食果食菜为道。或执露形为道。或执卧刺棘等为道。或执不卧为道。或执着弊故衣为道。或执服诸药物断食为道。佛作是说。彼非真道。是邪僻道是虚伪道是矫诈道。如是诸道。非诸善士所应习行。是诸恶人所应游履。真净道者。谓一道谛。即正见等八支圣道。复次言一谛者。谓一灭谛。永舍一切生死苦故。又一谛者。谓一道谛。能断一切生死因故。余契经中说有二谛。一世俗谛。二胜义谛。问世俗胜义二谛云何。有作是说。于四谛中前二谛是世俗谛。男女行住及瓶衣等。世间现见诸世俗事。皆入苦集二谛中故。后二谛是胜义谛。诸出世间真实功德。皆入灭道二谛中故。复有说者。于四谛中前三谛是世俗谛。苦集谛中有世俗事。义如前说。佛说灭谛如城如宫或如彼岸。诸如是等世俗施设灭谛中有。是故灭谛亦名世俗。唯一道谛是胜义谛。世俗施设此中无故。或有说者。四谛皆是世俗谛摄。前三谛中有世俗事。义如前说。道谛亦有诸世俗事。佛以沙门婆罗门名说道谛故。唯一切法空非我理是胜义谛。空非我中诸世俗事绝施设故。评曰。应作是说。四谛皆有世俗胜义苦集中有世俗谛者。义如前说。苦谛中有胜义谛者。谓苦非常空非我理。集谛中有胜义谛者。谓因集生缘理。灭谛中有世俗谛者。佛说灭谛如园如林如彼岸等。灭谛中有胜义谛者。谓灭静妙离理。道谛中有世俗谛者。谓佛说道如船筏如石山如梯蹬如台观如花如水。道谛中有胜义谛者。谓道如行出理。由说四谛皆有世俗胜义谛故。世俗胜义俱摄十八界十二处五蕴。虚空非择灭亦二谛摄故

问世俗中世俗性。为胜义故有为胜义故无。设尔何失。二俱有过。所以者何。若世俗中世俗性胜义故有者。应唯有一谛。谓胜义谛。若世俗中世俗性胜义故无者。亦应唯有一谛。谓胜义谛。答应作是说。世俗中世俗性胜义故有。若世俗中世俗性胜义故无。佛说二谛言应非实。佛说二谛言既是实。故世俗中世俗性胜义故有。问若尔。唯应有一谛。谓胜义谛。答实唯有一谛。谓胜义谛。问若尔。何故立有二谛。答依差别缘立有二谛不依实事。若依实事唯有一谛。谓胜义谛。依差别缘建立二种。若依此缘立世俗谛。不依此缘立胜义谛。若依此缘立胜义谛。不依此缘立世俗谛。譬如一受有四缘性。若依此缘立因缘性。不依此缘乃至立增上缘性。若依此缘乃至立增上缘性。不依此缘乃至立因缘性。又如一受有六因性。若依此缘立相应因性。不依此缘乃至立能作因性。若依此缘乃至立能作因性不依此缘乃至立相应因性。二谛亦尔。依别缘立不依实事。问世俗胜义亦可施设各是一物不相杂耶。答亦可施设。其事云何。尊者世友作如是说。能显名是世俗。所显法是胜义。复作是说。随顺世间所说名是世俗。随顺贤圣所说名是胜义。大德说曰。宣说有情瓶衣等事。不虚妄心所起言说是世俗谛。宣说缘性缘起等理。不虚妄心所起言说是胜义谛。尊者达罗达多说曰。名自性是世俗。此是苦集谛少分。义自性是胜义。此是苦集谛少分。及余二谛二无为

如契经说。出家梵志总有三种婆罗门谛。云何为三。谓有出家梵志作如是说。一切有情皆不应害。如是所说是谛非虚。是名第一婆罗门谛。复有出家梵志。作如是说。我非彼所有。彼非我所有。如是所说是谛非虚。是名第二婆罗门谛。复有出家梵志作如是说。诸有集法皆有灭法。如是所说是谛非虚。是名第三婆罗门谛。问此中何者是婆罗门何者是谛。答此中意说出家外道名婆罗门。彼所说中。前三是谛。余皆虚妄一切有情皆不应害者。谓诸有情皆不应杀。我非彼所有。彼非我所有者。谓我不属彼。彼不属我。诸有集法皆有灭法者。谓诸有生皆归于灭。复有说者。此中意说住佛法者名婆罗门。即前所说三种名谛。为对外道佛说此经。谓有外道自谓我是真婆罗门。而为祠祀杀诸牛羊。及多聚集杂类众生而断其命。佛对彼故作如是说。损害他者非真婆罗门。真婆罗门者。于诸有情皆不应害。复有外道自谓我是真婆罗门。而为生天受诸欲乐勤修梵行。佛对彼故作如是说。为天欲乐修梵行者非真婆罗门。真婆罗门者于诸所有志无系属。而修行梵行。复有外道自谓我是真婆罗门。而执断常乖于中道。佛对彼故作如是说。执断常者非真婆罗门。真婆罗门者。知有集法皆有灭法。集故非断灭故非常。非断非常契于中道。复次此经意说三解脱门所有加行。一切有情皆不应害者。说空解脱门加行。我非彼所有。彼非我所有者。说无愿解脱门加行。诸有集法皆有灭法者。说无相解脱门加行。有作是说。此经意说三解脱门如其次第。或有说者。此经意说三三摩地。谓空无愿无相三种如其次第。复有说者。此经意说戒蕴定蕴慧蕴三种如其次第。如说三蕴如是。三学三修三净应知亦尔

如契经说。佛告苾刍观四方者。谓观四谛。问世尊何故于四圣谛以方声说。答观所化者宜闻说故。谓有所化闻以方声。说四圣谛即易悟入。故佛于谛说四方声。如余契经。佛为所化于八解脱说八方声。所化闻之即易悟入。此经亦尔。故于四谛说四方声。问四谛四方有何相似。而于四谛说四方声。答四谛四方四数等故。问佛于何谛说何方声。答佛于苦谛说东方声。于彼集谛说西方声。以现观时先观苦谛次观集故。有作是说。东方如集西方如苦。先因后果次第说故。佛于道谛说南方声。道谛南方俱应供故。佛于灭谛说北方声。灭谛北方俱最胜故

如契经说。于四圣谛应知慧根。问此为依摄为依所缘。若依摄者。四谛慧根互不相摄。如何于四谛说应知慧根。若依所缘即一切法皆是所缘何独四谛。答应作是说。此不依摄不依所缘而作是说。然于建立四圣谛时。慧用最胜。故作是说。于四圣谛应知慧根。如于建立四证净时。信用最胜故作是说。于四证净应知信根。如于建立四正胜时。精进用最胜故作是说。于四正胜应知精进根。如于建立四念住时。念用最胜故作是说。于四念住应知念根。如于建立四神足时。定用最胜故作是说。于四神足应知定根。此中亦尔。有作是说。此依所缘。问慧根既能缘一切法。何独四谛作是说耶。答若法有漏无漏慧缘。此中偏说。虚空非择灭唯有漏慧缘故此不说

说一切有部发智大毗婆沙论卷第七十七阿毗达磨大毗婆沙论卷第七十八

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中十门纳息第四之八

如契经说。尊者舍利子作如是言。诸善法生皆四圣谛摄趣四圣谛。问三谛有为说生可尔。灭谛无为既无生义。如何可说诸善法生摄在四谛。答此经意说诸善法生无不摄在四圣谛中。不言四谛一一皆摄所生善法。于理何违。复次生有二种。一有自性故名为生。二从缘起故名为生。有自性故名为生者。生言显体非灭坏义。从缘起故名为生者。生言欲显从缘起义。诸善法中具二生者三谛所摄。唯有自性故名生者灭谛所摄。故经所说亦不违理。复次生有二种。一作用生。二彼得生。诸善法中具二生者三谛所摄。唯彼得生者灭谛所摄。择灭虽不生而得生故。胁尊者曰。此契经中说诸忍智名所生善。此诸忍智随应摄在四圣谛中不言遍摄。言趣谛者是缘谛义。谓苦忍苦智道谛摄缘苦谛。集忍集智道谛摄缘集谛。灭忍灭智道谛摄缘灭谛。道忍道智道谛摄缘道谛

如契经说。佛告苾刍。一切如来应正等觉说拔济法。谓四圣谛。宣说开示四圣谛法。拔济有情出生死故。问何故说此拔济法耶。答欲显要由自勤修道有拔济义不由他修。云何知然契经说故。如契经说。有婆罗门名道德迦。来诣佛所到已顶礼世尊双足合掌恭敬而说颂言

  稽首此人间　　勇猛真梵志
  净眼普观照　　愿能除我疑

问今此颂中欲显何义。答彼婆罗门禀性懒惰谓他修道能除自惑。故对佛说爱语伽他。欲显世尊是天梵志乘勇猛愿来生人间。为济有情已修圣道。唯愿哀愍除我疑惑。世尊于是为说颂言

  我于脱汝疑　　必无自在力
  要汝见胜法　　方能越瀑流

今此颂中。世尊欲显无他修道断自惑义。若有此义我坐树下修圣道时。一切有情烦恼应断。我于一切具大慈悲。而诸有情惑未顿断。故无他道断自惑义。如他服药自病不除。要自服药其病方愈。由此故知要自修道有拔济义不由他修。是故世尊说拔济法。此拔济法即四圣谛。欲令有情依此修道。见四圣谛断自疑惑。问言拔济者是何义耶。答从崄难处引诸有情置平坦处故名拔济。崄难处者。谓异生性如深坑谷及山岩等诸可畏处。平坦处者。谓诸圣性如大王路。由佛宣说四圣谛法。从异生性极崄难处。引诸有情置诸圣性极平坦处。谓令入道及得道果故名拔济。复次从平等处引入正性故名拔济。平等处者谓世第一法。正性者谓苦法智忍。由佛宣说四圣谛法。引诸有情从世第一法入苦法智忍故名拔济。复次从大苦处引诸有情置大乐处故名拔济。大苦处者谓生死。大乐处者谓涅槃。由佛宣说四圣谛法引诸有情令出生死得大涅槃故名拔济。问何故四谛名拔济法非界处蕴。答观四圣谛入道得果离染尽漏。观界处蕴不如是故。复次观四圣谛令所化者近入圣道近证法身。观界处蕴是远加行。谓修行者远加行中初习业位观十八界。已串修位观十二处。超作意位观于五蕴。燸顶忍等近加行中。方观四谛能入圣道证果法身。故唯四谛名拔济法

问言圣谛者是何义耶。为是善故名为圣谛。为无漏故名为圣谛。为圣者成就故名圣谛耶。设尔何失。三皆有过。所以者何。若是善故名圣谛者。四中后二可名圣谛唯是善故。前二既通三种如何亦名圣谛。若无漏故名圣谛者。四中后二可名圣谛是无漏故。前二既有漏如何名圣谛。若圣者成就故名圣谛者。非圣者亦成就如何独名圣谛。如说谁成就苦集谛。谓一切有情。谁成就灭谛。谓不具缚者。答应作是说。圣者成就故名圣谛。问若尔善通前二种难第三难云何通。答圣具成四故名圣谛。异生不尔。问亦有圣者不具成四如具缚者。见道初心灭谛尔时犹未成故。答时分少故非如异生。谓具缚者见道初心虽未成四。此后必具成就四种。异生怛时不具成四。是故苦等独名圣谛。复次圣者品中有具成四故名圣谛。异生品中无成四者故非彼谛。复次若圣法印印相续者得圣者名彼所有谛故名圣谛。复次若已得圣所爱戒名为圣者彼所有谛故名圣谛。复次若已得圣慧名为圣者。彼所有谛故名圣谛。复次若已得圣奢摩他毗钵舍那名为圣者彼所有谛故名圣谛。复次若已得圣财名为圣者。彼所有谛故名圣谛。复次若已入圣胎名为圣者。彼所有谛故名圣谛。复次若已得圣觉支道支名为圣者。彼所有谛故名圣谛。尊者僧伽筏苏说曰。佛在世时异生圣者共兴诤论。诸异生说诸行是常乐净有我诸圣者说诸行无常苦空非我。诸异生说我言是谛。圣者复说我言是谛。为灭诤故。共诣佛所请佛决之。佛作是言。圣言是谛余言非谛。所以者何。圣于苦等现知见觉所言是谛异生不尔。是故四谛唯属圣者非诸异生故名圣谛。尊者世友作如是说。如是四谛唯诸圣者圣慧通达故名圣谛

问苦圣谛云何。答如契经说。生苦老苦病苦死苦非爱会苦爱别离苦求不得苦。略说一切五取蕴苦是名苦圣谛。应知此中与生相合故名生苦。与住异相合故名老苦。与逼恼相合故名病苦。与灭相合故名死苦。与非爱会相合故名非爱会苦。与爱别离相合故名爱别离苦。与不自在不随所欲相合故名求不得苦。如是诸苦皆是有漏取蕴所摄。故名略说一切五取蕴苦。复次生是一切苦安足处苦之良田故名生苦。老能衰变可爱盛年故名老苦。病能损坏可爱安适故名病苦。死能断灭可爱寿命故名死苦。不可爱境与身合时引生众苦故名非爱会苦。诸可爱境远离身时引生众苦故名爱别离苦。求如意事不果遂时引生众苦故名求不得苦。如是诸苦皆是有漏取蕴所摄。故名略说一切五取蕴苦。问五取蕴苦其量广大何故名略。答苦虽广大而略说之故名为略。谓五取蕴苦患极多不可广说欲令所化总生厌离故略说之。譬如有人多诸过恶不可广说。有问彼过但可总答是极恶人言虽是略而过甚广。此亦如是故名略说五取蕴苦

问于诸蕴中为有乐不。设尔何失。二俱有过。所以者何。若诸蕴中亦有乐者。何故名苦谛而不名乐谛。若诸蕴中全无乐者。契经所说当云何通。如契经说。大名当知。色若一向有苦无乐。非乐所随不生喜乐。远离乐者有情不应为乐于色起贪起着。以诸色中有苦有乐。亦乐所随亦生喜乐。不离乐故有情为乐于诸色中起贪起着。乃至于识广说亦尔。又说三受各定建立不相杂乱。谓乐及苦不苦不乐。又契经说。道依资粮涅槃依道。以道乐故得涅槃乐。道既是乐如何蕴中可说无乐。答应作是说。于诸蕴中。亦有少乐。以诸蕴中苦多乐少少从多故但名苦蕴。如毒瓶中置一渧蜜。少从多故但名毒瓶。诸蕴亦尔。乐少苦多唯名苦谛。有作是说。于诸蕴中全无乐故但名苦谛。问若尔经说当云何通。答相待立名假说有乐。谓受上苦时于中苦起乐想。受中苦时于下苦起乐想。受地狱苦时于傍生苦起乐想。受傍生苦时于鬼界苦起乐想。受鬼界苦时于人苦起乐想。受人苦时于天苦起乐想。受有漏苦时于无漏道亦生乐想。故说有乐。复有说者。若依世间施设于诸蕴中亦说有乐。谓诸世间饥时得食渴时得饮。寒时得暖热时得冷行疲倦时得车马等。皆言得乐。若依贤圣施设于诸蕴中应说无乐。谓诸圣者从无间狱。乃至有顶诸蕴界处。皆等观见如热铁团。评曰。应知此中初说为善。苦多乐少但名苦谛

问苦集圣谛云何。答如契经说。诸所有爱及后有爱。喜俱行爱彼彼喜爱。是名苦集圣谛。问诸有漏法能为因义皆是集谛。何故世尊但说集谛是爱非余。答爱于施设集圣谛中。势用增强非余有漏。故偏说爱是集非余。然有漏法皆是集谛。如施设行蕴中思最胜故说思非余。而实相应不相应行皆是行蕴。是故偏说爱为集谛。复次爱是三世众苦因本。道路由绪能作生缘。集起胜故偏说集谛。复次爱能数数招集苦果胜故偏说。如有颂言

  如树根未拔　　斫斫还复生
  未断爱随眠　　数数感众苦

复次爱于有情能烧能润是故偏说。因时能润果时能烧。如热油渧堕在身时能烧能润。爱于有情亦复如是。复次以爱能起如起尸鬼能招生业。是故偏说。如有水处有起尸鬼能起死尸。有爱身中有招生业能招生死。复次以爱能摄有情无情内外诸事是故偏说。摄有情者。由爱势力摄受妻子奴婢作使。象马牛羊驼驴等事。摄无情者。由爱势力摄受宫殿舍宅珍财及谷麦等。复次爱能长养男身女身是故偏说。谓诸有情由爱势力能正供养父母师长。及能养育妻子作使朋友眷属乃至禽兽由爱势力。从一谷中残害生类持至余谷养育其子。复次以爱势力欲得未来生趣自体由欲得故便起希望。由希望故即便求觅。由求觅故得生趣体故偏说爱。复次爱能滋润诸有生死令不萎枯是故偏说。如水能润树木药草令不萎枯。复次爱能润识生后有芽谓由爱力得入母胎滋润精血令住胎藏是故偏说。复次若有所依所缘行相。能起爱者即此所依所缘行相起余烦恼。犹如鱼王所游止处小鱼皆随。此亦如是由此说爱名烦恼王是故偏说。复次若相续中有贪爱者。诸余烦恼皆集其中。如润湿衣尘垢易着。是故偏说爱为集谛。复次若相续中有贪爱水。诸余烦恼皆悉乐住。如有水处鱼虾蟆等皆悉乐住是故偏说。复次爱如炽火能烧一切。又如碱水饮无足时是故偏说。如炽火中投诸物类。悉皆烧尽无充足时。又如渴人饮以碱水。随饮随渴无厌足时。如是身中未离爱者贪着境界无满足时。复次爱能和合别异有情令不别异是故偏说。如水和合别异砂等令不相离。复次爱令有情善法生涩无所堪能。爱润有情令有住着不能出离是故偏说。谓诸有情由爱势力所修善法生涩无能。又润有情令于生死所在执着不能超升。如蝇蜂等至酥油蜜。湿皮等上胶粘翅足不能飞空。复次爱于有情因位果位。所作有异是故偏说。谓所起爱于诸有情因时随顺如善亲友。果时违害如恶怨家。如诸商人入海采宝。至一洲渚遇逻刹斯。先现善颜作诸爱语。以礼供事请以为夫。后知委信方便诱引。禁铁城中饮食血肉。渐至都尽唯有余骨。爱逻刹斯亦复如是。先令有情嬉戏造恶。后令堕恶趣受种种剧苦。复次爱是起因是故偏说。如契经说。业为生因爱为起因生死流转。复次爱难断离是故偏说。如人忽遇二逻刹斯。一作母形难可免离。二作怨形易可免离。如是有情未离欲染。有二烦恼数数现行。一者贪欲难可断离。二者嗔恚易可断离。复次爱数现行微细难觉是故偏说。如善旋师所用利器。所有断尽微细难知。复次爱于有支渐立三种是故偏说。谓初起时说名为爱。次增广位说名为取。死后得果说名无明。复次有十染法爱为上首是故偏说。如契经说。佛告阿难。缘爱故求。缘求故得。缘得故集。缘集故贪。缘贪故着。缘着故悭。缘悭故摄受。缘摄受故守护。缘守护故执持刀杖。斗诤欺诳谄诈轻侮。生无量种恶不善法。复次爱于染污八等至中势力增强是故偏说。如说味相应初静虑。为在定时味。为出定已味。应言出定已味。非在定时味。乃至味相应非想非非想处广说亦尔。复次佛说贪爱缚诸异生如绳系鸟是故偏说。复次佛说贪爱如网如藤笼缚难免是故偏说。复次佛说贪爱深广难渡犹如大海是故偏说。复次佛说贪爱长远如河难可寻偃是故偏说。如契经说言长河者喻三种爱。谓欲爱色爱无色爱。复次以佛说贪爱难断难破难可越度是故偏说。复次佛说贪爱多诸过患炽盛坚牢是故偏说。复次佛说贪爱能令界别地别部别及能生长一切烦恼是故偏说。由如是等种种因缘。有漏法中。唯爱一种世尊偏说为集圣谛。而集圣谛非唯爱摄

问苦灭圣谛云何。答如契经说。即诸所有爱及后有爱喜俱行爱彼彼喜爱。无余断弃吐尽离灭静没。是名苦灭圣谛。问既说诸爱无余断等名灭圣谛。即集亦灭如何但说苦灭圣谛。答此亦应说集灭圣谛。而不说者是有余说。复次已说苦灭当知即说集谛亦灭。以苦与集是一物故。复次若说苦灭应知已说集谛亦灭。要灭其因果乃灭故。复次为所化者欣乐灭故但说苦灭。谓所化者于苦厌心胜于厌集。无始时来为苦逼故。今闻佛说苦灭圣谛便生欢喜言。此弊恶众苦灭尽甚为快哉。由此喜心速求证灭。由如是等种种因缘世尊但说苦灭圣谛。而不说为集灭圣谛。问趣苦灭道圣谛云何。答如契经说八支圣道。谓正见乃至正定。是名趣苦灭道圣谛。问此亦应说趣集灭道。如何但说趣苦灭道。答此亦应说趣集灭道。而不说者是有余说。复次已说趣苦灭道当知即说趣集灭道。以苦与集非别物故。复次若说趣苦灭道应知已说趣集灭道。要灭因已果方灭故。复次为所化者欣乐灭道故作是说。谓所化者厌苦情深闻说此道能趣苦灭极生欢喜。由此速能修道加行。是故但说趣苦灭道。复次欲显圣道唯能遮苦令永不生故作是说。谓设问道。汝为有力令因非因果非果不。道答不能。然诸因缘能生苦者。我能对治令不生苦。是故但说趣苦灭道。复次为欲遮遣于道诽谤。是故但说趣苦灭道。谓有幼年七八岁等证无学果。乃至百岁寿命方尽。于其中间受种种苦。如受四百四病等苦。世人见之便诽谤道。言此圣道不能尽苦。是故世尊作如是说。圣道能灭后有众苦。由如是等种种因缘。世尊但说趣苦灭道。而不说为趣集灭道

问何故世尊先说苦谛。乃至最后说道谛耶。答随顺文辞故作是说。谓作是说文辞随顺。复次若作是说随顺说者。受者持者非余次第。复次依现观时故作是说。谓次第法略有三种。一生起次第。二易说次第。三现观次第。生起次第者。谓四念住四静虑四无色等。诸瑜伽师先起身念住。是故先说。乃至后起法念住。是故后说。静虑无色广说亦尔。易说次第者。谓四正胜四神足五根五力七等觉支八道支等。虽四正胜俱时而有而易说故。先说断恶后说修善。于断恶中先说断已生恶。后说遮未生恶。于修善中先说起未生善。后说增已生善。若作是说。言辞轻便四神足等广说亦尔。现观次第者。谓四圣谛。诸瑜伽师于现观位。先现观苦故佛先说。次现观集故佛次说。次现观灭故佛次说。后现观道故佛后说

问因论生论。何故行者入现观时。先现观苦乃至最后现观道耶。答依粗细故。谓四谛中苦谛最粗故先现观。渐次乃至道谛最细故后现观。如学射时先射粗物。渐次乃至能射毛端。复次以迷苦愚能持迷集愚。乃至迷灭愚能持迷道愚。若未除迷苦愚终不能除迷集愚。乃至若未除迷灭愚终不能除迷道愚。故先现观苦乃至最后现观道。复次以迷苦愚能引迷集愚。乃至迷灭愚能引迷道愚。若未遮迷苦愚。必不能遮迷集愚。乃至若未遮迷灭愚必不能遮迷道愚。故先现观苦乃至最后现观道。复次以苦谛观能引集谛观。乃至灭谛观能引道谛观。若未起苦谛观必不能起集谛观。乃至若未起灭谛观必不能起道谛观。故先现观苦乃至最后现观道。复次以苦谛观是集谛观因本道路由绪能作生缘集起。乃至灭谛观是道谛观。因本道路由绪能作生缘集起。若未起苦谛观必不能起集谛观。乃至若未起灭谛观必不能起道谛观故。先现观苦乃至最后现观道。复次苦谛观是集谛观加行所依门安足处。乃至灭谛观是道谛观加行所依门安足处。若未起苦谛观必不能起集谛观。乃至若未起灭谛观必不能起道谛观故。先现观苦乃至最后现观道。胁尊者言。修观行者知五取蕴如病如痈如箭等已。次求其因知是集谛。次求无处知是灭谛。后求对治知是道谛。如软弱人身遭病等。为苦所逼便起念言。我此病等因何而生。知因风热痰癊等起。复作是念。何当得愈知除灭时。复作是念。由何当愈知服药等。由此因缘故先现观苦。乃至最后现观道。复次修观行者知五取蕴多诸过患。次求其因次求其灭后求对治。如人有子专行劫盗。作如是念。我子因谁而作此恶知因恶友。复作是念。子所行恶何时当止知调善时复作是念。谁令调善知由善友。由此因缘故先现观苦。乃至最后现观道

问先因后果随顺次第。何故行者先现观苦后现观集。答知苦断集次第顺故。问知苦断集顺何次第。答此顺世间伐树次第。谓伐树者先断枝等然后拔根。伐生死树次第亦尔。先知苦者如断枝等。后断集者如拔树根。问先道后灭随顺次第。何故行者先现观灭后现观道。答证灭修道次第顺故。问证灭修道顺何次第。答此顺所趣能趣次第。若先说修道后说证灭者。不知此道为是谁道。若先说证灭后说修道者。即知此道是趣灭道。如人问他当示我道。他反诘言汝问何道。其人报言问某城道。他遂答言此是彼道。先说证灭后说修道。应知亦尔举灭示道顺次第故。复次诸瑜伽师。先以缘三谛道断迷三谛愚。后以缘道谛道断迷道谛愚。故先现观灭后乃现观道。譬如有人先观他面知其好丑。后欲自知面好丑故取镜照之。由此因缘先现观灭后现观道。问现观谛时为观自相为观共相。设尔何失。二俱有过。所以者何。若观自相诸法自相差别无边。应无观谛得究竟者。且地自相无边差别。观未穷尽而便命终。况更能观诸余自相。若观共相如何四谛不顿现观复于何时以如实智观谛自相。于谛自相。若不能观云何名为现观谛者。答应作是说观于共相。问如何四谛不顿现观。答现观谛时虽观共相而不现观一切共相。谓但现观少分共相然自共相差别无边。且地大种亦名自相亦名共相。名自相者对三大种。名共相者一切地界皆坚相故。大种造色合成色蕴。如是色蕴亦名自相亦名共相。名自相者对余四蕴。名共相者诸色皆有变碍相故。即五取蕴合成苦谛。如是苦谛亦名自相亦名共相。名自相者对余三谛。名共相者诸蕴皆有逼迫相故。思惟如是共逼迫相。即是思惟苦及非常空非我相。亦即名为苦谛现观。如是现观若对诸谛名自相观。若对诸蕴名共相观。由对诸蕴名共相观。故现观时名观共相。由对诸谛名自相观。故于四谛不顿现观。复次一谛非四。四谛非一。故于四谛不顿现观。复次一行相非四。四行相非一。故于四谛不顿现观。复次有漏无漏相各差别。故于四谛不顿现观。复次有为无为相各差别。故于四谛不顿现观。复次果因所证能证各别。故于四谛不顿现观。复次以四圣谛或相有异或性相异。故无一时顿现观义。复次能觉所觉根与相义。行相所缘境与有境相各有别。故于四谛不顿现观。复次于一一谛尚不顿观。况有一时顿观四谛。谓现观位先别观欲界苦。后合观色无色界苦。先别观欲界集。后合观色无色界集。先别观欲界灭。后合观色无色界灭。先别观欲界道。后合观色无色界道。故无顿观四圣谛义

问因论生论。何故行者先别观欲界苦。后合观色无色界苦耶。答依粗细相而起现观。欲界苦粗故先现观。色无色界苦细故后现观。问若尔色界苦粗应先现观。无色界苦细应后现观。如何一时观二界苦。答俱定地摄故合现观。谓欲界苦非定地摄故先别观。色无色界苦俱定地摄故后合观。复次欲界苦与身俱现执受故先别观。色无色苦不与身俱非现执受故后合观。复次欲界苦现痛逼迫。如荷重担故先别观色无色界苦非现痛逼迫如荷重担故后合观。复次欲界苦现恼行者如现怨敌故先别观。色无色界苦非现恼行者如现怨敌故后合观。复次欲界苦近故先别观。色无色界苦远故后合观。如近远如是邻逼。非邻逼和合非和合此身众同分。余身众同分。应知亦尔。复次欲界苦现见故先别观。色无色界苦不现见故后合观。问入现观位于色无色界苦若不现见云何名现观耶。答现见有二种。一执受现见。二离染现见。入现观位于欲界苦具二现见故名现观。于色无色界苦唯有离染现见故名现观。如商贾者有两担财。一自身担二使他担。自身担者具二现见。一知重现见。二知财现见。使他担者唯一现见。谓知财现见。复次欲界苦有善不善无记三种故先别观。色无色界苦唯有善无记二种故后合观。复次行者成就欲界异生性故先别观欲界苦。不成就色无色界异生性故。后合观色无色界苦。谓法应尔。若成就此界异生性者。即先观此界苦。复次于欲界苦先起诽谤故先别现观而生于信。于色无色界苦后起诽谤故后合现观而生于信。由如是等种种因缘。先别观欲界苦。后合观色无色界苦。三谛现观准此应知

问若以共相现观谛者。复于何时以如实智观谛自相。于谛自相若不能观。云何名为现观谛者。答非如实智于诸自相以自相观名谛现观。而如实智于诸自相。以共相观名谛现观。复次于谛自相共相无知。现观谛时一切顿断虽观共相。而亦得名如实现观诸谛自相。复次苦非常等名谛自相。此于诸蕴即名共相。故于诸谛观苦等时。即名现观自相共相。蕴等自相差别无边。观之不能断诸烦恼。故现观位不各别观。问入现观时既总观蕴。如何于谛不总观耶。答入现观时观四谛理。断迷四谛别相烦恼。无一烦恼总迷四谛。故于四谛不总现观。于诸蕴中有总迷惑。故于诸蕴得总现观。又蕴自相非诸谛理。无始已了故不复观四谛自相无始未了。故今于彼各别现观

说一切有部发智大毗婆沙论卷第七十八阿毗达磨大毗婆沙论卷第七十九

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中十门纳息第四之九

如契经说苦圣谛应以慧遍知。阿毗达磨说。智所遍知谓一切法。问若一切法是所遍知如阿毗达磨说。何故契经唯说以慧应遍知苦。答契经唯依出世间慧。说苦圣谛是应遍知。阿毗达磨总依世间出世间慧。说一切法是所遍知。如世间出世间有漏无漏缚解系不系应知亦尔。复次契经唯依近遍知慧说苦圣谛是应遍知。阿毗达磨依近远慧说一切法是所遍知。如近远邻逼非邻逼和合非和合应知亦尔。复次契经唯依观共相慧说苦圣谛是应遍知阿毗达磨总依观自相共相慧说一切法是所遍知。如自相共相慧。自相共相觉自相共相作意应知亦尔。复次契经唯依不共慧说苦圣谛是应遍知。阿毗达磨总依共不共慧说一切法是所遍知。复次契经依现观时说苦圣谛是应遍知。阿毗达磨依行谛时说一切法是所遍知。复次契经依施设觉说苦圣谛是应遍知。阿毗达磨依胜义觉说一切法是所遍知。问施设觉者义何谓耶。答依果粗显易见。方便说遍知苦。依生死因不续。方便说永断集。依具二德不在身。方便说应证灭。依能永断诸烦恼道。方便说应修道。如是名为施设觉义。非尽理故立施设名。胁尊者言。世尊唯说应遍知苦。或谓唯苦是应遍知。故对法中说一切法是所遍知。世尊唯说集应永断。或谓唯集是应永断故。对法中说有漏法皆应永断。世尊唯说灭应作证。或谓唯灭是应作证。故对法中依得作证说诸善法皆应作证。世尊唯说道应修习。或谓唯道是应修习。故对法中总说一切善有为法皆应修习。此则显示经义不了。阿毗达磨是了义说。复次为令永断生死道路故佛唯说应遍知苦。谓有身见是六十二见趣根本。见趣是余烦恼根本。诸余烦恼是业根本。诸业复是异熟根本。依止异熟生长一切善不善无记法。由此轮转生死无穷。遍知苦时断有身见。身见断故生死路绝。故佛唯说应遍知苦。复次为令永断五我见十五我所见。故佛唯说应遍知苦。复次为令永断有身见边执见。及为证得空无愿三摩地。故佛唯说应遍知苦。复次从无始来诸有情类于五取蕴。起我有情命者生者及养育者数取趣想。谁能断此诸恶倒想。令得法想谓苦遍知。故佛唯说应遍知苦。复次从无始来于苦非常空非我蕴起常乐我净想。谁能断此诸颠倒想。令得无颠倒想谓苦遍知。故佛唯说应遍知苦。复次从无始来诸有情类。虽为诸蕴损恼逼切如荷重担。而于诸蕴希求贪着。如诸婴儿。虽为乳母打骂逼切。而归附之。欲令有情断蕴贪着。故佛唯说应遍知苦。复次从无始来诸有情类。由诸烦恼恶行颠倒。令心心所于境邪曲。谁令正直谓苦遍知。故佛唯说应遍知苦。复次诸瑜伽师若遍知苦便能安住无倒想心。设彼现观苦圣谛已。于余圣谛不复现观。有人问言此五取蕴为苦为乐。答言唯苦如热铁团。复问取蕴为常非常。答言非常一刹那后决定不住。复问取蕴为净不净。答言不净如粪秽聚。复问取蕴有我无我。答言无我作者受者皆不可得唯空行聚。此无颠倒由苦遍知。故佛唯说应遍知苦。复次取蕴如病性不调适。取蕴如痈性能逼恼。取蕴如箭性能损害。取蕴如刀性能伤切。取蕴如毒性能杀害。取蕴如火性能焚烧。取蕴如怨性不饶益。取蕴如边城恒为种种业烦恼贼之所侵扰。能知此者谓苦遍知。故佛唯说应遍知苦。复次诸瑜伽师。若遍知苦名遇真佛出现世间。名入胜义如理正法。名真出家。名真受用正法财宝得无障碍。故佛唯说应遍知苦。复次诸瑜伽师。若遍知苦名舍曾缘得未曾缘。名舍共得不共。名舍世间得出世间。故佛唯说应遍知苦。复次诸瑜伽师。若遍知苦开未曾开圣道门。故能舍未曾舍异生性。能得未曾得圣性。故佛唯说应遍知苦。复次诸瑜伽师。若遍知苦舍名得名舍界得界舍性得性舍名得名者。谓舍异生名得圣者名舍界得界者。谓舍异生界分。得圣者界分。舍性得性者。谓舍异生种性。得圣者种性故佛唯说应遍知苦。复次诸瑜伽师。若遍知苦得心不得心因。得苦不得苦因。得明不得明因。故佛唯说应遍知苦。复次诸瑜伽师。若遍知苦舍五同分得八同分。五同分者谓五无间业同分。八同分者谓四向四果同分。故佛唯说应遍知苦。复次诸瑜伽师。若遍知苦则舍如柳絮异生性。住如帝幢佛法性。故佛唯说应遍知苦。复次诸瑜伽师。若遍知苦名为最初得法证净。故佛唯说应遍知苦。复次诸瑜伽师。若遍知苦名最初得无有是处。如契经说无有是处。见圣谛者故断他命越所学处乃至广说。故佛唯说应遍知苦。复次诸瑜伽师。若遍知苦名为最初入大法海。登大法山。摧大怨敌。升大法座。故佛唯说应遍知苦。复次苦应遍知非皆永断。集应永断不应唯遍知。灭应作证不应唯遍知。道应修习不应唯遍知。故佛唯说应遍知苦。复次于四圣谛皆应遍知。苦在最初故唯说苦

如契经说。苦集圣谛应以慧永断。阿毗达磨说。应永断者谓有漏法。若说唯爱是集谛者。应问彼言诸有漏法皆应永断如对法说。何故世尊唯说爱应永断非余一切有漏法耶。彼应如前爱为集。答若说一切有漏法因是集谛者。应问苦谛亦应永断何故唯说集应永断。答佛为舍苦故作是说汝等若欲舍众苦者应永断集。集永断故苦则不生名真舍苦。复次佛为舍果故作是说。汝等若欲舍苦果者应永断因。因永断故苦果不生名真舍果。复次为止苦流故作是说。如止流者当堰水源。欲止苦流应永断集。复次永断集故。便害俱因离俱系。得无漏离系得。灭有顶遍行因。故佛唯说集应永断。复次若断因者果即随断。若灭因者果即随灭。若弃因者果即随弃。若吐因者果即随吐。故佛唯说集应永断。复次世尊欲令诸有情类舍蕴重担故作是说。谓如有人荷负重担经崄难处。而复蹎蹶为担逼切欲脱无由。有人语言欲脱此担当断担索乃可脱之。如是有情荷蕴重担经历生死诸崄难处。为蕴重担之所逼切故。佛告言汝等若欲脱蕴重担当永断集。集既断已蕴担便脱。复次为对外道故作是说。谓诸外道苦果所逼。虽厌苦果而不断因。如愚痴狗舍人逐块。故佛告彼汝等厌苦当永断集。集因断已苦果不生便得解脱。复次集引三界下中上果。若永断集苦果不生。是故世尊告有情类。汝等厌苦当永断集。复次集能生长三种苦果。若永断集彼不生长。是故世尊告有情类。若厌三苦当永断集。复次集能生长四种苦生。若永断集彼不生长。是故世尊告有情类。若厌四苦当永断集。复次集能生长五种苦趣。若永断集彼不生长。是故世尊告有情类。若厌五苦当永断集。复次苦但应舍不应断之。故佛唯说集应永断。由如是等种种因缘世尊唯说集应永断

如契经说苦灭圣谛应以慧作证阿毗达磨说得作证者谓诸善法。问若诸善法皆应作证如对法说。何故世尊唯作是说灭应作证。答灭是解脱离系为相。故佛唯说灭应作证。复次灭无处所亦无所依。故佛唯说灭应作证。复次灭虽是因而无有果。灭虽是果而无有因。故佛唯说灭应作证。复次灭虽是因而无有因。灭虽是果而无有果。故佛唯说灭应作证。复次灭是能作非有能作。是缘非有缘。是离非有离。故佛唯说灭应作证。复次灭令蕴无而不变法。故佛唯说灭应作证。复次灭能息三堕四遮五故佛唯说灭应作证。复次灭是一味广大道果。能净四姓及诸名言名无上法。故佛唯说灭应作证复次灭唯无漏得通二种灭唯非学非无学得通三种。灭一谛摄得三谛摄。灭唯不系得通三种。灭唯不断得通二种。故佛唯说灭应作证。复次灭是善亦是常。是善亦离世。是善亦离蕴。是善无三品。是善无前后。故佛唯说灭应作证。复次灭是沙门果非沙门。是婆罗门果非婆罗门。是梵行果非梵行。是道果非道。故佛唯说灭应作证。复次为证灭故证有为善。故佛唯说灭应作证。由如是等种种因缘。故佛唯说灭应作证

如契经说趣苦灭道圣谛应以慧修习。阿毗达磨说应修习法者谓有为善法。问诸有为善皆应修习如对法说。何故世尊唯作是说应修圣道。答圣道应修不应永断。非如余善应断应修。故佛唯说应修圣道。复次圣道唯有得修习修。非如余善具四种修。所谓得习对治除遣。故佛唯说应修圣道。复次圣道具善无漏二圣。非如余善唯有善圣。故佛唯说应修圣道。复次圣道应修不断缘彼贪等烦恼。非如余善亦修亦断缘彼烦恼。故佛唯说应修圣道。复次圣道应修是出非没。非如余善虽是应修亦出亦没。谓出欲界没初静虑。乃至出无所有处没非想非非想处。故佛唯说应修圣道。问得圣道者离欲染已生初静虑。乃至离无所有处染已生非想非非想处。如何圣道是出非没。答虽有是事而诸圣道不招异熟。非如余善能招异熟。故诸圣道唯名为出。复次修习圣道能损诸有。能害诸有。能破诸有修习余善长养诸有。摄益诸有。任持诸有。故佛唯说应修圣道复次修习圣道断有流转生老病死令不相续。修习余善续有流转生老病死不令间断。故佛唯说应修圣道。复次修习圣道是趣苦有世间生老病死灭行。修习余善是趣苦有世间生老病死集行。故佛唯说应修圣道。复次修习圣道非有身见事乃至不堕苦集谛摄。修习余善是有身见事。乃至堕在苦集谛摄。故佛唯说应修圣道。复次修习圣道非界趣生生老病死流转之因。修习余善是界趣生生老病死流转之因。故佛唯说应修圣道。复次修习圣道令界趣生生老病死流转都尽。修习余善令界趣生生老病死流转无尽。故佛唯说应修圣道。复次圣道唯是可爱可爱果。可喜可喜果。可意可意果。可欣可欣果。可乐可乐果。余善不尔。故佛唯说应修圣道。复次圣道是沙门是沙门果。是婆罗门是婆罗门果。是梵行是梵行果。是道是道果。故佛唯说应修圣道。复次修习圣道定趣涅槃。修习余善所趣不定。故佛唯说应修圣道。由如是等种种因缘。故佛唯说应修圣道

有十六行相缘四圣谛起。谓缘苦谛有四行相。一苦二非常三空四非我。缘集谛有四行相。一因二集三生四缘。缘灭谛有四行相。一灭二静三妙四离。缘道谛有四行相。一道二如三行四出。问十六行相名有十六实体有几。有作是说。名有十六实体有七。谓缘苦谛四种行相名有四种实体亦四。缘余三谛各四行相名虽有四实体唯一。问何故缘苦有四行相名有四种实体亦四。缘余三谛而不尔耶。答缘苦行相是四颠倒近对治故。如四颠倒名体各四。缘余三谛所起行相非四颠倒近对治。故名虽有四实体唯一。评曰应作是说。十六行相名与实体俱有十六。如名与体。名施设体施设。名异相体异相。名异性体异性。名差别体差别。名建立体建立。名觉了体觉了。应知亦尔。问言行相者自性是何。答自性是慧。应知此中慧是行相。亦是能行亦是所行。与慧相应心心所法虽非行相而是能行亦是所行。与慧俱有不相应行。及余有法虽非行相亦非能行而是所行。有作是说。言行相者总以一切心心所法为其自性。若作是说。诸心心所皆是行相。亦是能行亦是所行。余一切法虽非行相亦非能行而是所行。复有说者。所言行相以一切法为其自性。若作是说。诸相应法亦是行相。亦是能行亦是所行。不相应法虽是行相亦是所行而非能行。评曰应作是说。言行相者自性是慧如初所说。如是名为行相自性。我物自体相分本性

已说自性所以今当说。问何故名行相。行相是何义。答于诸境相简择而转是行相义。问何故名苦广说乃至何故名出。答伤痛逼迫如荷重担。违逆圣心故名为苦。由二缘故说名非常。一由所作。二由属缘。由所作者。诸有为法一刹那顷能有所作。第二刹那不复能作。由属缘者诸有为法系属众缘。方有所作违我所见故名为空。违于我见故名非我。如种子法故名为因。能等出现故名为集。令有续起故名为生。能有成办故名为缘。譬如埿团轮绳水等众缘和合成办瓶等。取蕴永尽故名为灭。有为相息故名为静。是善是常故名为妙。最极安隐故名为离。是离自体非有离故。违害邪道故名为道。违害非理故名为如。趣涅槃宫故名为行。能永超度故名为出。是能出性非没性故。复次粗重所逼故名为苦。性不究竟故名非常。内离士夫作者受者遣作受者故名为空。性不自在故名非我。引发诸有故名为因。令有等现故名为集。能有滋产故名为生。有所造作故名为缘。性不相续尽诸相续故名为灭。三火永寂故名为静。脱诸灾横故名为妙。出众过患故名为离。是出要路故名为道。能契正理故名为如。能正趣向故名为行。永超生死故名为出

问有四行相观生死果。何故此果但名苦谛不名非常空非我谛。答亦应说为非常等谛。而不说者是有余说。复次既说为苦谛当知已说为非常空及非我谛以相同故。复次苦相不共唯有漏法是苦非余故名苦谛。非常等三是余共相。谓非常相三谛皆有。空非我相遍一切法。故此不名非常等谛。复次苦违诸有。有情闻之能舍生死故名苦谛。美妙饮食持与小儿。若语是苦彼便远弃。语非常等彼无舍心。是故不名非常等谛。复次生死有苦愚智同信。外道闻之亦不诽谤。闻非常等有不生信。故名苦谛非非常等。复次能知所知易分别故。但名苦谛非非常等。谓佛世尊说有苦智故此所知但名苦谛。如智所知。觉所觉。根根义。行相所缘。有境及境。应知亦尔。复次此苦谛名旧所传说是旧文句。过去诸佛过殑伽沙皆以苦名表示此谛。今佛亦尔故不应责。复次此谛四相苦相最初。是故世尊但名苦谛。问有四行相观生死因。何故此因但名集谛不名因等三种谛耶。答亦应说为因生缘谛而不说者是有余说。复次既说为集谛当知已说因生缘谛以相同故。复次能知所知易分别故但名集谛非因生缘。谓佛世尊说有集智故此所知但名集谛。如智所知觉所觉等应知亦尔。复次此集谛名旧所传说是旧文句。过去诸佛过殑伽沙皆以集名表示此谛。今佛亦尔故不应责。复次集相但于有漏法有。招集生死非无漏故。因生缘相无漏亦有。圣道亦名因生缘故。集不共故立以谛名。是故世尊但名集谛。问有四行相观于涅槃。何故涅槃唯名灭谛不名静等三种谛耶。答亦应说为静妙离谛。而不说者是有余说。复次既说为灭谛当知已说静妙离谛以相同故。复次能知所知易分别故但名灭谛非静妙离。谓佛世尊说有灭智故此所知但名灭谛。如智所知觉所觉等应知亦尔。复次灭名不共故立谛名。灭名唯显究竟灭故。静名滥定妙离滥道故不名为静妙离谛。复次此灭谛名旧所传说是旧文句。过去诸佛过殑伽沙皆以灭名表示此谛。今佛亦尔故不应责。复次此谛四相灭相最初是故世尊但名灭谛。问有四行相观于圣道。何故圣道但名道谛不名如等三种谛耶。答亦应说为如行出谛。而不说者是有余说。复次既说为道谛当知已说如行出谛以相同故。复次能知所知易分别故。但名道谛非如行出。谓佛世尊说有道智。故此所知但名道谛。如智所知觉所觉等应知亦尔。复次道名唯显趣涅槃路故立谛名。如滥正理。行通有漏。出通涅槃。故此不名如行出谛。复次此道谛名旧所传说是旧文句。过去诸佛过殑伽沙皆以道名表示此谛。今佛亦尔故不应责。复次此谛四相道相最初是故世尊但名道谛

毗奈耶说。世尊有时为四天王先以圣语说四圣谛四天王中二能领解二不领解。世尊怜愍饶益彼故。以南印度边国俗语说四圣谛。谓瑿泥迷泥蹋部达[甲*葉]部。二天王中一能领解一不领解。世尊怜愍饶益彼故。复以一种篾戾车语说四圣谛。谓摩奢睹奢僧摄摩萨缚怛罗毗刺迟。时四天王皆得领解。问佛以圣语说四圣谛能令所化皆得解不。设尔何失。二俱有过。所以者何。若言能者后二天王闻圣语说何故不解。若不能者伽他所说当云何通。如有颂言

  佛以一音演说法　　众生随类各得解
  皆谓世尊同其语　　独为我说种种义

一音者谓梵音。若至那人来在会坐。谓佛为说至那音义。如是砾迦叶筏那达刺陀末[甲*葉]婆佉沙睹货罗博喝罗等人来在会坐。各各谓佛独为我说自国音义。闻已随类各得领解。又贪行者来在会坐。闻佛为说不净观义。若嗔行者来在会坐。闻佛为说慈悲观义。若痴行者来在会坐。闻佛为说缘起观义。憍慢行等类此应知。此伽他中既作是说。如何可说佛以圣语。说四圣谛不令一切所化有情皆得领解。有作是说。佛以圣语说四圣谛能令一切所化有情皆得领解。问若尔何故后二天王闻圣语说而不能解。答彼四天王意乐有异。为满彼意故佛异说。谓二天王作如是念。若佛为我以圣语说四圣谛者我能受行。第三天王作如是念。若佛为我以南印度边国俗语说四谛者我能受行弟四天王作如是念。若佛为我随以一种篾戾车语说四谛者我能受行。是故世尊随彼意说。复次世尊欲显于诸言音皆能善解故作是说。谓有生疑佛唯能作圣语说法。于余言音未必自在。为决彼疑佛以种种言音说法。显于诸方言音自在。所说法要闻皆受行。复次有所化者依佛不变形言而得受化。有所化者依佛转变形言而得受化。依佛不变形言得受化者。若变形言而为说法彼不能解。如说佛在摩揭陀国为度池坚步行十二踰缮那故七万众生皆得见谛。彼皆依佛不变形言而得受化。若变形言为说法者。彼诸众生应不见谛。依佛转变形言得受化者。若不变形言而为说法彼不能解。是故世尊作三种语。为四天王说四圣谛。复有说者。佛以一音说四圣谛。不令一切所化有情皆能领解。世尊虽有自在神力。而于境界不能改越。如不能令耳见诸色眼闻声等。问若尔前颂当云何通。答不必须通非三藏故。诸赞佛颂言多过实。如分别论者。赞说世尊心常在定。善安住念及正知故。又赞说佛恒不睡眠离诸盖故。如彼赞佛实不及言前颂亦然故不须释。复次如来言音遍诸声境随所欲语皆能作之。谓佛若作至那国语胜在至那中华生者。乃至若作博喝罗语胜在彼国中都生者。以佛言音遍诸声境故。彼伽他作如是说。复次佛语轻利速疾回转。虽种种语而谓一时。谓佛若作至那语已无间复作砾迦国语。乃至复作博喝罗语。以速转故皆谓一时。如旋火轮非轮轮想。前颂依此故亦无违。复次如来言音虽有多种。而同有益故说一音

如契经说佛告苾刍。此苦圣谛我昔未闻。于此法中如理作意。由此便生眼智明觉。此苦圣谛慧应遍知我昔未闻乃至广说。此苦圣谛慧已遍知我昔未闻乃至广说。集灭道谛广说亦尔。此苦圣谛我昔未闻等。显未知当知根。此苦圣谛慧应遍知等。显已知根。此苦圣谛慧已遍知等。显具知根。集灭道谛各显三根应知亦尔。大德法救作如是说。我思此经举身毛竖。以佛所说必不违义定有次第。今此契经越次第说具知根。后复说未知当知根故。非佛独觉及诸声闻。得有如是观行次第。具知根后如何复起初无漏根。若舍此经必不应理。佛初说故以五苾刍而为上首。八万诸天闻此所说皆证法故。若欲不舍复违次第故思此经举身毛竖。然后大德虽作是言而不舍经。但回文句彼作是说。此经应言此苦圣谛。我昔未闻乃至广说。集灭道谛广说亦尔。此苦圣谛慧应遍知。此集圣谛慧应永断。此灭圣谛慧应作证。此道圣谛慧应修习。昔未闻等广说如前。此苦圣谛慧已遍知。此集圣谛慧已永断。此灭圣谛慧已作证。此道圣谛慧已修习。昔未闻等广说如前。若作是说不失次第。随顺现观非如经说。阿毗达磨诸论师言。不应辄回此经文句。过去无量诸大论师。利根多闻过于大德。尚不敢回此经文句。况今大德而可辄回。但应寻求此经意趣。谓说法者依二次第。一依随顺说法次第如此经说。二依随顺现观次第如大德说。胁尊者言。此经不说三无漏根。但说菩萨菩提树下欲界闻思所成慧力修行四谛。问世尊既说我由此观证得无上正等菩提。岂有闻思证菩提义。答菩萨由此闻思慧力。伏除一切四圣谛愚。由此定当证无上觉。故说由此证得菩提。如人先时湿皮覆面。后得除去以[縠-士+十]覆之。其障轻微可言无障。故此非说三无漏根

如契经说佛告苾刍。我于四圣谛三转十二行相。生眼智明觉。问此应有十二转四十八行相。何故但说三转十二行相耶。答虽观一一谛皆有三转十二行相。而不过三转十二行相故作是说。如预流者极七反有。及七处善并二法等。此中眼者。谓法智忍。智者。谓诸法智。明者。谓诸类智忍。觉者。谓诸类智。复次眼是观见义。智是决断义。明是照了义。觉是警察义

问此四圣谛若自性断者亦所缘断耶。答应作四句。有自性断非所缘断。谓缘无漏苦集及无所缘诸有漏法。有所缘断非自性断。谓缘有漏圣道。有自性断亦所缘断。谓缘有漏苦集。有非自性断亦非所缘断。谓缘无漏圣道。及无所缘圣道灭谛

说一切有部发智大毗婆沙论卷第七十九阿毗达磨大毗婆沙论卷第八十

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中十门纳息第四之十

四静虑者。谓初静虑。第二静虑。第三静虑。第四静虑。问何故作此论。答欲令疑者得决定故。谓品类足说。云何初静虑。谓初静虑摄善五蕴。乃至云何第四静虑。谓第四静虑摄善五蕴。彼唯说善静虑。或有生疑。静虑唯善非染。亦非无覆无记。为决彼疑显四静虑。通善及染无覆无记故作斯论。问此四静虑自性云何。答各以自地五蕴为自性。是名静虑自性我物自体相分本性

已说自性。所以今当说。问何故名静虑。为能断结故名静虑。为能正观故名静虑。若能断结故名静虑。则无色定亦能断结应名静虑。若能正观故名静虑。则欲界三摩地亦能正观。应名静虑。有作是说。以能断结故名静虑。问诸无色定亦能断结应名静虑。答若定能断不善无记二种结者名为静虑。诸无色定唯断无记非不善故不名静虑。问若作是说。唯未至定可名静虑。上地不断不善结故。答上地虽无彼断对治。而有不善厌坏对治。以能厌坏亦名能断。问若作是说。上地灭道法智品。及彼一切类智品应非静虑。皆非欲界断及厌坏二对治故。答彼于欲界虽无全界全地对治。而彼界地容有不善厌坏对治。由此势力余亦得名。复次四静虑中有能对治不善结者。无色全无。故静虑名不通无色。尊者妙音作如是说。色界六地于欲界结皆有断对治及厌坏对治。然未至定已断彼结。余地对治无彼可断。虽无彼可断而有对治用。如日三分皆能破暗。初分已破余无可破。又如六人共一怨家。一人已杀余无可杀。又如六灯皆能破暗。持一入室其暗已除。余五入时无暗可破。如是六地于欲界结。皆有断能非唯未至。若不尔者依上五地入见道时。应不证得欲见所断诸结离系。既能证得。故知六地于欲界结有断对治。复次若定能断见修所断二结尽者名为静虑。诸无色定唯能断修所断结尽故非静虑。复次若能断结五蕴俱生能为所依起多功德。能具摄受四支五支。能发六通具四通行。三种变现三明三根三道三地四沙门果九遍知道。见修二道法类二智。及忍智者名为静虑。诸无色定虽能断结。而不具上所说功德故非静虑。复有说者。以能正观故名静虑。问若尔欲界有三摩地。亦能正观应名静虑。答若能正观亦能断结名为静虑。欲界三摩地虽有能正观。而不能断结。故不名静虑。复次若能正观坚固难坏相续久住。于所缘境长时注意而不舍者名为静虑。欲界三摩地无如是德故非静虑。复次若三摩地具有定名定用。能正观者名为静虑。欲界三摩地虽有定名而无定用。如泥椽梁有名无用故非静虑。复次若三摩地非散乱风之所摇动如密室灯。能正观者名为静虑。欲界三摩地多散乱风之摇动。如四衢灯故非静虑。如是说者。要具二义方名静虑。谓能断结及能正观。欲界三摩地虽能正观而不能断结。诸无色定虽能断结。而不能正观故非静虑。复次若能遍观遍断结者名为静虑。欲界三摩地虽能遍观而不能遍断结。诸无色定二义俱无故非静虑。复次若能静息一切烦恼。及能思虑一切所缘名为静虑。欲界三摩地虽能思虑一切所缘。不能静息一切烦恼。诸无色定两义都无故非静虑。复次诸无色定有静无虑。欲界三摩地有虑无静。色定俱有故名静虑。静谓等引。虑谓遍观。故名静虑

四静虑支总有十八。谓初静虑有五支。一寻二伺三喜四乐五心一境性。第二静虑有四支。一内等净二喜三乐四心一境性。第三静虑有五支。一行舍二正念三正慧四受乐五心一境性。第四静虑有四支。一不苦不乐受二行舍清净三念清净四心一境性。问四静虑支名有十八实体有几。答唯有十一。谓初静虑支名与实体俱有五种。第二静虑支虽有四。而三如前增内等净。第三静虑支虽有五。而第五如前但增前四。第四静虑支虽有四。而后三如前但增第一。故静虑支名有十八实体十一。复有说者。实体唯十。谓三静虑乐合为一。评曰。彼不应作是说。初二静虑是轻安乐。第三静虑别是受乐。初二静虑乐行蕴摄。第三静虑乐受蕴摄。故前所说于理为善。如名实体名施设体施设。名异相体异相。名异性体异性。名差别体差别。名建立体建立。名觉体觉。应知亦尔。问此中何者是静虑。何者是静虑支。答心一境性是静虑。以三摩地为自性故。此及所余是静虑支。问若三摩地是静虑者。初第三静虑应各唯四支。第二第四静虑应各唯三支。则静虑支应唯十四。云何乃说十八支耶。答三摩地是静虑亦是静虑支。余是静虑支非静虑故有十八。如择法是觉亦是觉支。余是觉支非觉。正见是道亦是道支。余是道支非道。离非时食是斋亦是斋支。余是斋支非斋。此亦如是。加是名为静虑支。自性我物自体相分本性

已说自性。所以今当说。问何故名静虑支。静虑支是何义。答寂静思虑故名静虑。随顺此静虑故名静虑支。以随顺义。负重担义。成大事义。坚胜义。分别义。是支义故。随顺义者。若法随顺此地静虑。名此地静虑支。负重担义者。若法能引此地静虑。名此地静虑支。成大事义者。若法能办此地静虑。名此地静虑支。坚胜义者。若法助成此地静虑。令其坚胜名此地静虑支。分别义者。如军车等诸分别异故名军车等支。如是静虑诸分别异名静虑支。如是已释静虑支名。次应分别杂无杂相。问若是初静虑支。亦是第二静虑支耶。答应作四句。有是初支非第二支。谓寻伺。有是第二支非初支。谓内等净。有是初支亦是第二支。谓喜乐心一境性。有非初支亦非第二支。谓除前相问若是初静虑支亦是第三静虑支耶。答应作四句。有是初支非第三支。谓寻伺喜乐。有是第三支非初支。谓舍念慧乐。有是初支亦是第三支谓心一境性。有非初支亦非第三支。谓除前相。问若是初静虑支亦是第四静虑支耶。答应作四句。有是初支非第四支。谓寻伺喜乐。有是第四支非初支。谓不苦不乐舍念。有是初支亦是第四支。谓心一境性。有非初支亦非第四支。谓除前相。问若是第二静虑支。亦是第三静虑支耶。答应作四句。有是第二支非第三支。谓内等净喜乐。有是第三支非第二支。谓舍念慧乐。有是第二支亦是第三支。谓心一境性。有非第二支亦非第三支。谓除前相。问若是第二静虑支。亦是第四静虑支耶。答应作四句。有是第二支非第四支。谓内等净喜乐。有是第四支非第二支。谓不苦不乐舍念。有是第二支亦是第四支。谓心一境性。有非第二支亦非第四支。谓除前相。问若是第三静虑支。亦是第四静虑支耶。答应作四句。有是第三支非第四支。谓慧乐。有是第四支非第三支。谓不苦不乐。有是第三支亦是第四支。谓舍念心一境性。有非第三支亦非第四支。谓除前相。问轻安行舍一切地有。何故初二静虑立轻安为支非行舍。第三第四静虑立行舍为支非轻安耶。答先说随顺是支义故。谓轻安唯随顺初二静虑故立为支。行舍唯随顺第三第四静虑故立为支。复次互相覆故。谓初二静虑轻安用胜。能覆行舍故立为支。第三第四静虑行舍用胜。能覆轻安故立为支问何故此二能互相覆。答此二行相更相违故。谓轻安相轻举。行舍相沉静。俱时而有更互相违。如人一时亦行亦住。亦睡亦觉一向相违。而善心中对治各异故得俱起。谓轻安能对治惛沈。行舍能对治掉举。复次为对治欲界五识身。及所引身粗重故。初静虑立轻安为支。为对治初静虑三识身。及所引身粗重故。第二静虑立轻安为支。第二第三静虑无粗识身。及所引身粗重可对治故。第三第四静虑不立轻安为支。彼既不立轻安为支。故立行舍为支。复次初二静虑有染污喜扰动身心。故世尊说应习轻安不应住舍。是故初二静虑唯立轻安为支。第三第四静虑无染污喜扰动身心故世尊说。但应住舍勿习轻安。是故第三第四静虑唯立行舍为支。复次初二静虑轻安有因。谓诸善喜。如契经说。心有喜故身则轻安。是故初二静虑唯立轻安为支。第三第四静虑轻安无因。谓无善喜唯应住舍。故彼但立行舍为支。复次第三静虑弃舍极喜。第四静虑弃舍极乐。故此唯立行舍为支。初二静虑既不立行舍为支。故立轻安为支无相违故。问内等净即是信诸地皆有。何故唯在第二静虑立为支耶。答前说随顺是支义故。谓信唯顺第二静虑。是故唯此立信为支。复次初静虑中。寻伺如火。身识如泥。令心相续。热恼浊乱信不明净。如热泥中面像不现。第二静虑无寻伺火及识身泥。心相续中信相明净。如清冷水面像得现。故于此立内等净支。第三静虑有极悦受。第四静虑有胜舍受覆心相续信相不显故彼及初皆不建立内等净支。复次第二静虑诸瑜伽师。于离染中初生信胜。故唯此立内等净支。谓瑜伽师离欲界染起初静虑现在前时。作是思惟。我虽已离不定界染。诸定地染为可离耶。彼后复离初静虑染第二静虑现在前时。于界地染俱可离中。初生大信如欲界染我既能离。色无色染亦必可离。如初静虑染既可离。乃至非想非非想处染定可离。彼初静虑现在前时未生定信。后二静虑现在前时。虽有定信而非初故信相不显。故皆不立内等净支。复次起增上信必依大喜因。喜信者信必坚固。第二静虑有极胜喜故唯此立内等净支。问慧遍诸地何故唯于第三静虑立为支耶。答前说随顺是支义故。谓慧唯顺第三静虑。故但于彼立正慧支。复次第三静虑有适悦受。诸适悦中此最为胜。耽着此故诸瑜伽师。不欲欣求上地胜法。此受即是自地留难。对治此故立正慧支是故世尊作如是说。应以正慧觉了此乐。勿固贪着不求上地。上下地中无有自地极乐留难如此地者。故彼不立正慧为支。复次初静虑中。有粗寻伺覆障正慧。第二静虑。有极喜跃覆障正慧。第四静虑。有胜舍受覆障正慧。以胜舍受是无明分正慧是明。明无明分互相违害。故皆不立正慧为支。第三静虑无有如彼覆正慧法故立为支。问念遍诸地何故唯在后二静虑立念为支。答前说随顺是支义故。谓念唯顺后二静虑。故但于彼立念为支。复次后二静虑。俱有地地增上留难。对治彼故立念为支。余地不尔。谓第二静虑有极胜喜轻躁漂溺。如逻刹斯诸瑜伽师。由此衰退不能坚固。离自地染为对治彼。第三静虑立念为支。是故世尊作如是说。应住正念勿为下地喜所漂溺退失自地。第三静虑有极胜乐。生死乐中此为最上留碍行者如诈亲怨。诸瑜伽师由此衰退不能坚固离自地染。为对治彼第四静虑立念为支。是故世尊作如是说。应住正念勿为下地乐所留碍退失自地。复次初静虑中有粗寻伺犹如暴风覆障正念。第二静虑有极喜跃。如水涛波覆障正念。故俱不立正念为支。后二静虑无此过失。是故俱立正念为支。问若是静虑支亦是菩提分耶。答应作四句有是静虑支非菩提分。谓伺乐受舍受有是菩提分非静虑支。谓精进正语正业正命。有是静虑支亦是菩提分。谓余菩提分法。有非静虑支亦非菩提分。谓除前相。问何故伺乐受舍受不立菩提分耶。答被覆损故。谓伺被正思惟之所覆损。乐受被轻安乐之所覆损。舍受被行舍之所覆损。故不立为菩提分法。问若尔何故立静虑支。答菩提分中为策正见。立正思惟为菩提分。伺行相细策正见中为寻覆损立静虑支。为遮下地恶不善法不相覆损。菩提分中轻安乐受同一刹那有相覆损。静虑支中地别建立无覆损义。菩提分中行舍受舍。同一刹那有相覆损。静虑支中对治利益。支用各别不相覆损。问何故精进非静虑支。答诸静虑支顺自地胜。精进于顺他地为胜。谓初静虑精进顺第二静虑为胜。乃至无所有处精进。顺非想非非想处为胜。故彼不立为静虑支。复次精进损害三摩地因。三摩地因即是胜乐。如契经说。乐故心定。勤精进者身心多苦。修三摩地身心多乐。是故精进非静虑支。问何故正语正业正命非静虑支。答静虑支者。谓与静虑相应住境。必有所依所缘行相。及有警觉乃名相应。正语业命无如是义。是故不立为静虑支。由此四相及诸得等。不相应法皆不应立为静虑支。非助等持住一境故。问何故惭愧无贪无嗔。不放逸不害等非静虑支耶。答非极随顺诸静虑故。此诸善法多于欲界。散地恶法为近对治。势力增强非于定地。是故不立为静虑支。问心想思等何故不立为静虑支。答非极随顺诸静虑故。心顺流转定顺还灭。故心不立为静虑支。复次心胜如王。诸心所法皆如臣佐。定是心所故心不立为静虑支。如诸国王不事臣佐。想思触欲皆顺流转。作用偏胜定顺还灭。故彼不立为静虑支。作意唯在欲界散地。对境用胜非诸定地。故亦不立为静虑支。胜解唯于无学位胜。静虑遍于一切位胜。故彼不立为静虑支。复次此中应以诸静虑支。对四念住四正断四神足五根五力七等觉支八圣道支展转相摄。复应以初静虑支乃至第四静虑支。对菩提分法展转相摄。复应以初静虑支乃至第四静虑支。对四念住乃至八圣道支展转相摄。应随其相一一广说

问静虑近分及无色定为立支不。若立支者此何不说。若不立者施设论说当云何通。如说。颇有空无边处定。于空无边处定根胜道胜定胜而支等耶。答有。谓从空无边处定起无间。复入空无边处定。有作是说。静虑近分及无色定亦建立支。问若尔善通施设论说。今于此中何故不说。答理亦应说而不说者。应知此中是有余说。谓初静虑近分如根本亦有五支。然除喜受增舍受。第二静虑近分如根本亦有四支。亦除喜受增舍受。第三静虑近分如根本亦有五支。然除乐受增舍受。第四静虑近分。及无色定。如根本第四静虑皆亦有四支。评曰。应作是说。静虑近分及无色定皆不立支。功德少故苦道摄故。问若尔善通此中所说。施设论说当云何通。答依因长养故说为胜。言支等者。谓觉道支

问何故初及第三静虑俱立五支。第二第四静虑俱立四支耶。答前说随顺是支义故。谓四静虑各有尔所。能随顺法不增不减。复次欲界诸恶难断难破难可越度。故初静虑建立五支为牢强对治。第二静虑重地极喜。难断难破难可越度。第三静虑建立五支为牢强对治。初及第三静虑俱无如是难断难破难越度法。是故第二第四静虑唯立四支。以彼俱不假牢强对治故。复次为对治欲界增上五欲境贪故。初静虑立五支。为对治第二静虑五部重地喜爱故。第三静虑亦立五支。初及第三静虑。俱无如是所对治故。第二第四静虑俱唯立四支。复次为欲随顺超定法故。谓从五支定超入五支定。复从四支定超入四支定。以支等者易可超入。问若从第三静虑超入空无边处。复从第四静虑超入识无边处。彼俱无支云何随顺。答诸外内事初作时难。后成办时不假随顺。且外事者如遮诺迦与臣怀月。十二年中学造金法。初成一粒如穬麦量。便师子吼。我等今者能造金山。言内事者。如瑜伽师修神境通。初学离地如半苣蕂。次复离地如一苣蕂。如是渐渐半麦一麦。半指一指半搩一搩。半肘一肘半寻一寻。彼后成时随心欲往色究竟天自在能往。超定亦尔初时难故假支齐等。后时易故设不立支亦能超入。故初第三各立五支。第二第四各立四支。如契经说。苾刍当知。有四天道能令有情未净者净净者转明。问何故世尊作如是说。答欲令有情于生天道。深生厌怖欣求安住胜义天道。生天者。谓三十三天。彼有四苑庄严殊妙。一名众车。二名粗恶。三名欢喜。四名杂林。如是四苑有四衢道。天诸婇女游集其中。诸胜美人于中游止。种种音乐恒时击奏。安置种种肴膳饮食。宝树行列枝条荫映。花叶茂盛香气氛氲。果实繁多光净甘美。随欲变鸟雅韵和鸣。诸天于中受诸欲乐。游戏既毕相与入苑。于此正法毗奈耶中。择灭涅槃如彼天苑。四妙静虑如四衢道。通明婇女游集其中。解脱无碍美人游止。三藏音乐恒时击奏。安置净喜肴膳饮食。菩提分法宝树行列。无量解脱胜处遍处。枝条荫映觉支道支。花叶茂盛诸妙净戒。香气氛氲诸沙门果。光净甘美学与无学。随欲变鸟雅韵和鸣。众圣于中受胜定乐。游戏既毕俱入涅槃云何名为四种天道。谓离欲恶不善法有寻有伺。离生喜乐初静虑具足住。是名第一天道离欲恶不善法者。问得初静虑时总离欲界一切法。何故但说离欲恶不善法耶。答恶不善法以为上首。总离欲界故作是说。复次恶不善法违害圣道自性应断。彼若断已不复成就。是故偏说。诸有漏善无覆无记。不违圣道非自性断。彼若断已犹可成就。是故不说。然有漏善无覆无记。断恶不善时亦随说断。同一对治故一时断故。如灯违暗非炷油器。而破暗时亦能烧炷尽油热器。复次恶不善法难断难破难可越度。是故偏说。复次恶不善法多诸过患炽盛坚牢。是故偏说。复次恶不善法离欲染时。极为障碍留难系缚。如暴狱卒故偏说之。复次诸瑜伽师专为断彼恶不善法修初静虑。是故偏说。复次诸瑜伽师憎恶彼故总舍欲界。故偏说离恶不善法。复次恶不善法上地所无故偏说离。由如是等种种因缘唯说离欲恶不善法。问此中何者是欲。何者是恶不善法耶。答事具欲是欲。烦恼欲是恶不善法。复次欲。谓五欲。恶不善法。谓五盖。复次欲。谓欲爱。恶不善法。谓欲界诸余烦恼。复次欲。谓欲寻。恶不善法。谓恚害寻。复次欲。谓欲界。恶不善法。谓恚害界。复次欲。谓欲想。恶不善法。谓恚害想。复次欲。谓欲爱。恶不善法。谓即欲爱。此即说离种种欲爱。有寻有伺者与寻俱法名有寻。与伺俱法名有伺。离生者。问上地中离胜妙清净过初静虑。何故唯说此名离生。答此中举初以显后故。作如是说。世尊有处举后显初。如说。云何非自他害。谓在非想非非想处。如举初后始入已度加行究竟应知亦尔。复次初得离生发希奇想。后时不尔故作是说。复次以初静虑唯从离生。后诸静虑亦从定生。从离生故名为离生。如水生者说名水生。陆地生者说名陆生。复次初静虑离二无漏定为眷属故。独名离生。谓未至定静虑中间。复次初静虑离是后离门。所依加行因本道路。及安足处独得离名。复次初静虑离牵引任持。长养后离独得离名。复次初静虑离是后诸离生缘集起独得离名。复次上地诸离决定依止初静虑离得及前起故。初静虑独得离名。复次诸瑜伽师离欲界染起初静虑现在前时。欢喜踊跃胜于后时故。独名离。如饥渴人初得饮食。虽复粗恶而生欢喜。胜于后时得美饮食。复次三种行者依初静虑得入离生。得果练根及尽诸漏故独名离。三种行者。谓具缚者。分离欲者。全离欲者。复次为令疑者得决定故。独立离名。如欲界中有寻有伺。有诸识身尊卑眷属。初静虑中亦有此事。或有生疑如欲界无离。初静虑亦尔。为决此疑说初静虑有离非欲。复次欲界无离近对治彼。故初静虑独立离名。复次唯初静虑能离三界一切烦恼独立离名。复次唯初静虑有四沙门果道。九遍知果道。具三十七菩提分法故独名离。复次唯初静虑能离所有。苦根忧根男根女根无惭无愧食爱淫爱。五盖五欲悭贪嫉恚。五蕴十二处及十八界等故独名离。由如是等种种因缘。唯初静虑独名离生。喜乐者。喜谓喜根乐谓轻安乐。复次喜受蕴摄。乐行蕴摄。初静虑具足住者。谓得获成就初静虑善五蕴。得获成就名具足住

复次寻伺灭内等净心一趣。无寻无伺定生喜乐。第二静虑具足住。是名第二天道寻伺灭者。问得第二静虑时。总灭初静虑一切法。何故但说寻伺灭耶。答以寻伺为上首。总灭初静虑故作是说。复次寻伺难断难破难可越度。是故偏说。复次寻伺多诸过患。炽盛坚牢。是故偏说。复次寻伺离初静虑染时。极为障碍留难系缚。如暴狱卒故偏说之。复次诸瑜伽师专为断寻伺。修第二静虑。是故偏说。复次诸瑜伽师憎恶寻伺故。总舍初静虑故偏说之。复次寻伺上地所无。是故偏说。由如是等种种因缘但说寻伺灭内等净者。内谓心等。净谓信。由信平等令内心净故名内等净。尊者世友作如是说。寻伺躁动扰乱定心。信能除彼令心等净。如波浪息水则澄清。是故说信名内等净。复作是说。染喜腾跃浑浊定心。信能除彼令心等净。如离泥浊水则澄清。是故说信名内等净。大德法救作如是说。行者将入第二静虑。心于定境信向乐住。不流驰散久住一境。得第二定斯有是处。此由信力。是故说信名内等净。心一趣者。谓一门转非如欲界心六门转。初静虑中心四门转。第二静虑心一门转故名一趣。即是心行一境界义。无寻无伺者。谓寻伺已灭定生者。问初静虑亦有定。何故唯说第二静虑名定生耶。答第二静虑等持增盛胜妙清净。过初静虑。是故偏说复次第二静虑定所引发定所长养。初静虑后现在前故。名为定生。非如初静虑。非定所引发。非定所长养。欲界心后现在前故。不名定生。复次初静虑心有定不定。有内门转有外门转。有缘内事有缘外事。第二静虑心多在定。多唯内门转。唯缘内事故名定生。复次第二静虑灭语言本。语言本者。谓寻与伺。如契经说。要寻伺已能发语言。非不寻伺。第二静虑寻伺已灭无语言本故说定生。复次第二静虑名圣默然。故名定生。如契经说。佛告目连。汝等勿轻第二静虑。此是圣者默然法故。由如是等种种因缘定生。唯在第二静虑。喜乐者。喜谓喜根。乐谓轻安乐。复次喜受蕴摄。乐行蕴摄。第二静虑具足住者。得获成就第二静虑善五蕴得获成就名具足住

说一切有部发智大毗婆沙论卷第八十阿毗达磨大毗婆沙论卷第八十一

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中十门纳息第四之十一

复次离喜住舍。正念正慧身受乐。圣应说舍第三静虑具足住。是名第三天道离喜者。问得第三静虑时。总离第二静虑诸有漏法。何故但说离喜耶。答以喜为上首。总离第二静虑诸有漏法故偏说喜。复次以喜难断难破难可越度故偏说之。复次以喜多诸过患。炽盛坚牢。是故偏说。复次以喜离第二静虑染时。极为障碍系缚留难。如暴狱卒故偏说之。复次诸瑜伽师专为对治喜故。修第三静虑。是故偏说。复次诸瑜伽师憎厌喜故总舍第二静虑故偏说之。复次喜上地无余法容有故偏说喜。由如是等种种因缘。唯说离喜。住舍。正念正慧者。舍谓行舍。正念谓胜善念。正慧谓胜善慧。身受乐者。身谓意身。有作是说。意有乐时亦令大种所造色身有适悦乐。此即意识相应乐受名身受乐。圣应说舍者。圣谓诸佛及圣弟子。应为他说。应自住舍。问圣于诸地皆应说舍。何故唯说第三静虑。答第三静虑具自他地二种留难故偏说之。他地留难者。谓第二静虑喜。漂没轻躁如逻刹斯。能令瑜伽师于第二静虑离染衰退。故说应舍。勿为此喜之所留难。自地留难者。谓第三静虑乐。生死乐中此乐最胜。诸瑜伽师染着此乐。不求上地胜妙功德。故说道者为初习业诸瑜伽师。说此乐受是留难处不应染着。复次佛及弟子应为他说第三静虑自地他地。留难过失劝他令舍。是故名为圣应说舍。谓为他说第三静虑。有胜乐受。能令众生染着迷闷。不求上地胜妙功德。汝等应住正念正知。勿为此乐之所留难。亦为他说第二静虑。有胜喜受。能令众生漂溺轻躁退失第二静虑离染。汝等应住正念及舍。勿为此喜之所留难。如旧商主为新商人。说诸国邑所有过患。谓如是国如是邑中。多诸淫女博戏矫诈酒肆贼难应远防之。勿令汝等丧失财货。第三静虑具足住者。谓得获成就第三静虑善五蕴。得获成就名具足住

复次断乐断苦先喜忧没。不苦不乐舍念清净。第四静虑具足住。是名第四天道断乐者。问得第四静虑时。总离第三静虑诸有漏法。何故但说断乐耶。答以乐为上首。总离第三静虑诸有漏法故偏说乐。复次以乐难断难破难可越度故偏说之。复次以乐多诸过患炽盛坚牢。是故偏说。复次以乐离第三静虑染时。极为障碍系缚留难。如暴狱卒故偏说之。复次诸瑜伽师专为对治乐故修第四静虑。是故偏说。复次诸瑜伽师憎厌乐故。总离第三静虑故偏说之。复次乐上地无余法容有故偏说乐。由如是等种种因缘唯说断乐。断苦者。问离欲染时修观行者已断苦根。何故今离第三静虑染时乃说断苦。答此于已断说名为断谓于远事而说近声。如已来者亦说今来。如说。大王从何处来。如已解脱说解脱声。如说。由此知见心解脱欲漏有漏无明漏。离欲染时心已解脱欲漏。离非想非非想处染时。心解脱有漏无明漏。如于已入而说入声。如说。菩萨入正性离生。得现观边世俗智。如于已受而说受声。如说。受乐受时如实知受乐受无有自知现在受者。故知已受而说受声。此中亦尔已断说断。谓于远事而说近声。复次依双法尽俱说断声言双法者。谓苦与乐。离欲染时虽苦已尽而乐未尽。今离第三静虑染已。苦乐俱尽俱说断声。复次断乐者。谓断第三静虑乐根。断苦者。谓断彼相应心心所法。复次断乐者。谓断第三静虑乐根。断苦者。谓断第三静虑入出息。诸贤圣者于入出息生于苦想过诸异生于无间狱所起苦想。复次断乐者。谓断第三静虑乐根。断苦者。谓即断彼乐根。如说。无常故苦。先喜忧没者。离欲染时忧根已没。离第二静虑染时喜根已复没。是故说今先喜忧没。不苦不乐者。谓不苦不乐受。舍清净者。谓行舍。念清净者。谓善念。问下地亦有无漏舍念。何故但说第四静虑舍念清净。答第四静虑舍念。俱离八扰乱事故名清净。苦乐忧喜入息出息寻伺名为八扰乱事。此中皆无独名清净。复次第四静虑无内外灾故名清净。下三静虑有内外灾不名清净。谓初静虑内有寻伺火故外为火灾所烧。第二静虑内有极喜水故外为水灾烂。第三静虑内有出入息风故外为风灾飘。第四静虑无此三灾故说清净。复次第四静虑所依身器三灾不及。念无忘失舍无諠杂。非如下地故说清净。复次第四静虑离诸烦恼及随烦恼。故说舍念清净非余。谓有舍念离诸烦恼非随烦恼。谓下三静虑无漏舍念或有舍念离随烦恼非诸烦恼。谓第四静虑有漏舍念。或有舍念离诸烦恼及随烦恼。谓第四静虑无漏舍念。或有舍念非离烦恼及随烦恼。谓下三静虑有漏舍念及欲界一切舍念。应知此中随烦恼者。即上所说八扰乱事

复次第四静虑所依色身澄洁明净。譬如灯光舍念依彼故亦清净。复次第四静虑是圆满依诸依中胜。是究竟地诸地中尊。故彼舍念亦名清净。复次第四静虑定名不动定之势力遍所依身。故彼舍念亦名清净。复次第四静虑是七依定齐下上俱有三无漏定故。由此舍念亦名清净。复次第四静虑有二事广。一处所广。二善根广。故彼舍念亦名清净。复次第四静虑过殑伽沙菩萨依之入正性离生。证得无上正等菩提。故彼舍念亦名清净。复次第四静虑三瑜伽师依之得入正性离生得果尽漏。谓佛独觉及诸声闻。故彼舍念亦名清净。复次第四静虑大种造色。显色形色皆极胜妙故。彼舍念亦名清净。复次依第四静虑宿住随念智。能缘欲界及四静虑诸宿住事故。彼舍念亦名清净。由如是等种种因缘。第四静虑所有舍念独名清净。第四静虑具足住者。谓得获成就第四静虑善五蕴。得获成就名具足住

如契经说。有四种增上心所现法乐住。问何故名为增上心所。答此中心所即三摩地。无三摩地具大势力。有大功用能成大事。能如根本四静虑者。故此独名增上心所。复次四静虑中有无量种增上心所殊胜功德。如无量解脱胜处遍处无碍解。无诤愿智边际定等。是故独名增上心所。复次依四静虑诸瑜伽师。以无量门受心所乐。谓前所说诸功德门。及空空等三三摩地是故独名增上心所

复次此四静虑乐通行摄。是故独名增上心所。问四静虑中亦有能引后乐功德。何故但说现法乐住。答亦应说为后法乐住。而不说者应知此经是有余说。复次若说此为现法乐住。应知已说后法乐住。以后法乐用现法乐为因得故

如契经说。先于此间修彼等至后方生彼。复次后法乐住依止系属现法乐住。现法乐住不依止系属后法乐住。是故但说现法乐住即已说彼。复次现法乐住与后法乐住为加行门。若已说此即已说彼。复次现法乐住是因后法乐住是果。若已说因即已说果。如因果如是。能作所作。能生所生。能成所成。能续所续。能引所引。能转所转。能相所相。应知亦尔。复次现法乐近后法乐远。若已说近即已说远。如近远如是。邻逼非邻逼。和合非和合。此身众同分。余身众同分。应知亦尔。复次现法乐住若愚若智。内道外道正观邪观。皆共信有故偏说之。后法乐住有不信者如诸外道是故不说。复次诸愚夫类多贪现乐不求后乐。于现乐中贪少欲乐。不求广大离欲妙乐。世尊欲令舍小欲乐。得四静虑广大妙乐。作如是说。汝等若求广大乐者。当舍欲乐修四静虑。是故但说现法乐住。复次以四静虑现在前时。必受现乐故偏说之。后乐不定或退生下或进生上。或般涅盘是故不说。由如是等种种因缘。世尊但说四种静虑名现法乐。近分无色虽亦有乐义。而苦通行摄故不说之

如契经说如是四种增上心所现法乐住。诸修定者数数入出。应正了知寂静解脱超过诸色。四无色定诸修定者数数入出应正宣示。问何故世尊于四静虑劝应了知。于四无色劝应宣示。答静虑粗显明了易见。诸修定者从彼出已复乐欲入故。佛告言。若欲复入应正了知入出定相勿有谬失。无色微细相隐难见。诸修定者从彼出已不乐复入故。佛告言。若不乐复入应正宣示他。入出定相勿令忘失。复次四静虑中多有种种异相功德。诸修定者从彼出已复乐欲入故。佛告言。若乐复入应正了知入出定相勿有谬失。无色定中无有多种异相功德。诸修定者从彼出已不乐复入故。佛告言。若不乐复入应正宣示他。入出定相勿令忘失。复次四静虑中根受心所有多异相。诸修定者从彼出已复乐欲入故。佛告言。若乐复入应正了知入出定相勿有谬失。无色定中根受心所无多异相。诸修定者从彼出已不乐复入故。佛告言。若不乐复入应正宣示他。入出定相勿令忘失。复次四静虑中有无量种功德胜利。诸修定者从彼出已复乐欲入故。佛告言。若乐复入应正了知入出定相勿有谬失。无色定中无无量种功德胜利。诸修定者从彼出已不乐复入故。佛告言。若不乐复入应正宣示他。入出定相勿令忘失。复次四静虑中有遍照智缘自上下。诸修定者从彼出已。复乐欲入故。佛告言。若乐复入应正了知入出定相勿有谬失。无色定中无遍照智能缘自上不缘下地。诸修定者从彼出已不乐复入故。佛告言。若不乐复入应正宣示他。入出定相勿令忘失。由如是等种种因缘。佛于静虑劝应了知。于四无色劝应宣示

如契经说。四种静虑有四胜利。四无色定有一胜利。问何故静虑胜利有四。无色定中胜利唯一。答即由前说种种因缘。静虑无色胜利有异。此中复有二不共答。谓静虑中有三种定。一有寻有伺。二无寻唯伺。三无寻无伺无色定中唯有一种无寻无伺。复次四静虑中有三种受。谓喜乐舍。无色定中唯有舍受。故四静虑胜利有四。无色定中胜利唯一。问静虑胜利有何差别。答名即差别。谓名静虑名胜利故。复次静虑三种。谓善染污无覆无记。胜利唯善。复次静虑二种谓有漏无漏。胜利唯无漏。复次静虑或色界系。或不系。胜利唯不系。复次静虑或学或无学。或非学非无学。胜利唯学无学复次静虑或见所断。或修所断。或非所断。胜利唯非所断。复次静虑通染不染。胜利唯不染。复次静虑通有异熟无异熟。胜利唯无异熟。复次静虑三谛摄。除灭谛。胜利唯道谛摄。是谓静虑胜利差别

如契经说。初静虑忧根灭。第二静虑苦根灭问离欲染时断忧及苦。契经何故作是说耶。答依过对治故作是说。谓离欲染位虽断苦根。而未名为过苦对治。于初静虑得离染时。过苦对治故说苦灭。苦对治者。谓初静虑。复次依过族姓及苦所依故作是说。谓离欲染位虽断苦根。而未过苦所依族姓。于初静虑得离染时。过苦所依及苦族姓故说苦灭所依族姓。谓诸识身。问离欲染位虽断忧根。而未过彼对治所依及彼族姓。不应说忧初静虑灭。答忧根对治所依族姓皆在意识。既与忧根同在意识。故正断时即说彼灭。苦根所依及苦族姓。不与对治同在一识。故过对治所依族姓方说苦灭。有作是说。第二静虑苦根灭者。谓寻伺灭以诸贤圣于寻伺中发生苦想。过诸异生厌地狱苦。能生苦想故名苦根有契经中说四静虑犹如床座。问世尊何故说四静虑如床座耶。答是高胜性摄受性故。高胜性者。对欲界说。以四静虑出欲界故。摄受性者。对善法说。静虑摄受多善法故。复次诸贤圣者。于无始来生死长途极生疲厌故。于静虑暂时憩息。如倦长途暂居床座。故于静虑说床座声

有契经说。四种静虑譬如凉风。问世尊何故说四静虑如凉风耶。答此能止业烦恼热故。谓初静虑能止欲界种种不善业烦恼热第二静虑能止初静虑寻伺相应业烦恼热。第三静虑能止第二静虑极喜相应业烦恼热。第四静虑能止第三静虑极乐相应业烦恼热。故说静虑譬如凉风

有契经中说。四静虑如妙饮食。问世尊何故说四静虑如饮食耶。答有能任持法身义故。如村邑中诸妙饮食。皆送王城长养尊胜。如是种种胜妙善根。皆集静虑长养法身。故说静虑如妙饮食

有契经中佛为梵志。说第四静虑名究竟迹。问世尊何故为婆罗门舍前三静虑。说第四静虑名究竟迹。答有婆罗门闻佛具有一切智见。复闻诸佛无不皆依第四静虑证得无上正等菩提。一切施设第四静虑为究竟迹。彼作是念若佛施设第四静虑是究竟迹。决定具有一切智见。作是念已来问世尊。佛知彼意故但为说第四静虑是究竟迹。彼闻决定信佛具有一切智见。佛又告彼婆罗门言。第四静虑是如来迹。是佛所行佛所习近。如野龙象夏日中时。从稠林出见地方所。其地沃润花果茂盛。流泉浴池其水清美。杂花映发甚可爱乐。见已欢喜以牙掘地而安其足。世尊亦尔。第四静虑行舍现前掘尔焰地而安智足。应知此中如来迹者。说第四静虑究竟奢摩他。佛所行者。说第四静虑究竟毗钵舍那。佛所习近者。总说第四静虑究竟止观

有契经中说。四静虑皆是乐住。问世尊何故说四静虑是乐住耶。答根本静虑易现在前。故名乐住非如近分。及无色定难现在前。所以者何。诸有情类为欲界业烦恼系缚。引未至定令现在前极为艰难。如被反缚甚难自解。有情亦尔。既为欲界业烦恼缚为解自缚。引未至定极为艰难。修不净观或持息念。经于十年或十二年。有能引起未至定者。有不能引故极艰难。若离欲染起初静虑不由功用故易现前。从初静虑复欲引起静虑中间。多用功力。异心所灭异心所生。粗心所灭细心所生。寻俱者灭。伺俱者生。故定中间亦难现起。譬如有人以木破木多用功力然后乃破。以初静虑自地心所有灭有生亦复如是。后三静虑近分难起。根本易起如初应知。问已离下染起无色定。亦不艰难宁非乐住。答虽离下染以无色定极微细故起亦艰难。起静虑时易于彼故。又无色界既无诸色非皆信有。故修行者欲起彼定亦甚艰难。如爪长者来白具寿阿难陀言。我等在家长夜贪着色等五境。闻无色界极生惊恐如临深坑。云何有情而都无色故难信有以难信故起极艰难。复次依四静虑易可离染。非近分等故名乐住。譬如二人俱往一处。一从陆路一则乘船。虽俱到彼而乘船者不为艰难非陆路者。如是有情有依静虑而离染者。有依近分或依无色而离染者。虽俱离染而依静虑不为艰难非近分等。故唯静虑得乐住名。复次唯静虑中具二种乐故名乐住。一乐受乐二轻安乐。前三静虑皆具二乐。第四静虑虽无受乐。而轻安乐势用广大胜前二乐。近分无色虽有轻安。而不广大故不名乐。复次乐有二种。一者主乐。二者客乐。主乐者。谓依静虑起静虑。客乐者。谓依静虑起无色住。住静虑地具起二乐故名乐住。住无色地不具二乐故非乐住。近分非胜故不得名。复次四静虑中无恼害乐势用广大。非近分等故名乐住

如契经说。若于是处无诸恼害说名为乐。复次根本静虑现在前时。长养大种遍身中生令身充悦故名乐住。近分定等现在前时。长养大种唯心边生。非极充悦故非乐住。有作是说。近分定等现在前时。长养大种虽遍身生。而长养用不及静虑现在前时长养大种故非乐住。譬如二人同一池浴。一身入水。一用手浇。虽俱洗浴而入水者润益为胜非手浇者。复次四静虑中止观力等故名乐住。近分定中观强止劣。无色定中止强观劣俱非乐住。复次四静虑中精进与止平等而转故名乐住。虽一切地精进力强。而静虑中为止所制故平等转。余地不尔故非乐住。复次四静虑中增上舍断离染可得故名乐住。谓离染时有二种断。一增上舍断。二有功用断。依近分无色离诸染时。名有功用断极艰难故。依根本静虑离诸染时。名增上舍断任运转故。譬如二人俱诣一方。一乘良马。一乘恶马。乘良马者甚不艰难至所诣处。乘恶马者甚为艰难方得至彼。复次四静虑中无功用道离染可得故名乐住。近分无色有功用道。而得离染故非乐住。如多人众俱渡大河。有依草束。有依浮瓠。有依棑筏。有依船舫。依船舫者任运安乐得至彼岸。依余物者怖畏艰难而到彼岸。有情亦尔度烦恼河。有依静虑。有依余地。虽俱从生死此岸度至涅槃彼岸。而依静虑者安乐易到故名乐住非依近分无色者。由如是等种种因缘。唯四静虑名为乐住。如名乐住如是亦名触住。俱住

四无量者。一慈二悲三喜四舍。问何故静虑无间说无量耶。答静虑引起四无量故。复次静虑无量更相引故。复次以四无量是静虑中胜功德故。问此四无量自性是何。答慈悲俱以无嗔善根。为自性对治嗔故。若兼取相应随转。则四蕴五蕴为自性。欲界者四蕴。色界者五蕴。问若慈悲俱以无嗔善根。为自性对治嗔者。慈对治何等嗔。悲对治何等嗔耶。答慈对治断命嗔。悲对治捶打嗔。复次慈对治应嗔处嗔。悲对治不应嗔处嗔。有作是说。慈无量以无嗔善根。为自性对治嗔故。悲无量以不害为自性对治害故。喜以喜根为自性。若兼取相应随转。则欲界者四蕴为自性。色界者五蕴为自性。问若喜无量以喜根为自性者。品类足说当云何通。如说。云何喜无量。谓喜及喜相应受想行识。若彼所起身语二业者。彼所起心不相应行皆名为喜。岂有喜受与受相应。答彼文应说。谓喜及喜相应想行识。不应言受而言受者是诵者谬。复次彼论总说五蕴为喜无量自性。虽喜受与受不相应。而余心心所法与受相应。故作是说亦不违理。有余师说。此喜无量欣为自性。欣体非受别有心所与心相应。有说。欣在喜根相应聚中可得。有作是说。喜根后生欣由喜力所引起故。若作是说此喜无量与受相应亦不违理。舍以无贪善根为自性对治贪故。若兼取相应随转。则欲界者四蕴为自性。色界者五蕴为自性。如是名为无量自性。问此四无量其相云何。答自性即是相。相即是自性。自性与相不相离故。尊者世友作如是说。授与饶益是慈相。除去衰损是悲相。庆慰得舍是喜相。忘怀平等是舍相。

已说无量自性及相。所以今当说。问何故名无量。无量是何义。答普缘有情对治无量戏论烦恼故名无量。问戏论有二种。一爱戏论。二见戏论。何无量。对治何戏论耶答无量不能断诸烦恼。但能制伏。或令转远。有时四种皆对治爱。有时四种皆对治见。若依四种近对治说。应言慈悲近对治见戏论。以见行者多嗔恚故。喜舍近对治爱戏论。以爱行者多亲附故。有作是说。慈悲近对治爱戏论。喜舍近对治见戏论。复次普缘有情对治无量放逸烦恼故名无量。谓四无量能近对治欲界放逸诸烦恼故。复次如是四种是诸贤圣。广游戏处故名无量。如富贵人有无量种广游戏处。谓诸园苑宫殿台阁游猎等处。复次如是四种能缘无量有情为境。生无量福引无量果故名无量

此四无量界者在欲色界。地者慈悲舍三在七地。谓欲界四静虑。及未至定静虑中间。有说。在十地。谓四静虑四近分。静虑中间及欲界。喜无量在三地。谓欲界初二静虑有余师说。初二静虑无悲无量。所以者何。初二静虑有胜喜受欢行相转。悲无量戚行相转。初二静虑若有悲者。则一心中有欢有戚便违正理。问若尔初二静虑如何有无漏厌。答无漏厌与真实作意相应不违于喜。如如于境觉真实相。如是如是深生喜慰如如于境深生喜慰。如是如是复欣彼觉。如人求宝而掘于地。如如掘地如是如是得诸宝物。如如得宝如是如是复欣掘地。悲无量与胜解作意相应故违于喜。评曰。应作是说。初二静虑有悲无量。云何知然。有至教故。如定蕴说。初二静虑摄初二静虑四无量等故知有悲。此四无量所依者。唯依欲界身而得现起。行相者。慈有与乐行相。悲有拔苦行相。喜有喜慰行相。舍有舍置行相。所缘者。唯缘欲界。唯缘聚集。唯缘和合。唯缘有情。谓缘欲界五蕴二蕴有情为境。若诸有情住自地心者则缘彼五蕴。若诸有情住他地心。或无心者则缘彼二蕴。有作是说。初静虑无量缘欲界有情。第二静虑无量。缘欲界及初静虑有情。第三静虑无量。缘欲界及初二静虑有情。第四静虑无量缘欲界及下三静虑有情。复有说者。初静虑无量。缘欲界及初静虑有情。第二静虑无量。缘欲界及初二静虑有情。第三静虑无量。缘欲界及下三静虑有情。第四静虑无量。缘欲界及四静虑有情。有余师说。慈无量缘欲界及下三静虑。所以者何。慈无量与乐行相转。唯四地中有乐受故。悲无量唯缘欲界。所以者何。悲无量拔苦行相转。唯欲界中有苦受故。喜无量缘欲界及初二静虑。所以者何。喜无量喜慰行相转。唯三地中有喜受故。舍无量缘欲界四静虑。所以者何。舍无量舍置行相转。一切地中有舍受故。评曰。此诸说中初说为善。谓四但缘欲界为境。念住者。此四唯与法念住俱。智者此四唯与世俗智俱。三摩地者。此四不与三摩地俱。唯有漏故。根相应者。慈悲舍三与喜乐舍三根相应。喜全不与受根相应。若兼说彼相应随转。则喜亦与喜根相应。过去未来现在者。此四无量皆通三世。过去缘过去。现在缘现在。未来可生法缘未来不可生法。缘三世善不善无记者。此四无量唯是善缘三种。欲界色界无色界系者。此四无量欲色界系唯缘欲界系。学无学非学非无学者。此四无量唯非学非无学唯缘非学非无学。见所断修所断非所断者。此四无量唯修所断。缘见修所断。缘名缘义者。此四无量通缘二种。缘自相续缘他相续者。此四无量唯缘他相续加行得离染得者。此四无量皆通二种。应知此中离染得者。谓初静虑无量离欲界染故得。第二静虑无量。离初静虑染故得。第三静虑无量。离第二静虑染故得。第四静虑无量。离第三静虑染故得。或离自地上地染时。修得无量加行得者。谓四无量多由加行而现在前。佛不由加行而现在前。独觉由下加行而现在前。声闻由中上加行而现在前。异生不定种姓多故。曾得未曾得者此。四无量皆通二种。一切圣者及住后有异生皆通二种。诸余异生唯是曾得。有作是说。一切圣者及住内法异生皆通二种。外法异生唯是曾得

说一切有部发智大毗婆沙论卷第八十一阿毗达磨大毗婆沙论卷第八十二

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中十门纳息第四之十二

问此四无量加行云何。答缘七有情而起加行。七有情者。谓分欲界一切有情为怨亲。中三品差别。怨亲二品。复各分三谓下中上。中品有情总为一种无差别故。于此七品有情境中。若欲修慈先缘亲品。于亲品中先缘上品。上品亲者。谓自父母轨范亲教。或余随一可尊重处。智慧多闻同梵行者。于此上品亲有情境作是思惟。云何当令此有情类得如是乐。然心刚强难可调伏。从无始来串习成故。于极有恩诸有情所恶阿世耶任运生长。善阿世耶虽作意起而不能住。复应勇励思其重恩制心令住。如以芥子投于锥锋。虽有着时而难可住。久习不已加行乃成。由善巧力投之方住。如是行者于上品。亲要勤修习与乐意乐。经于多时乃得坚住。于上品亲与乐意乐得坚住已。次于中亲复修如是与乐意乐。此既成已次于下亲复修如是与乐意乐。此既成已次于中品。次于下怨。次于中怨。后于上怨。各修如是与乐意乐。渐次修习至成满时。普于欲界一切有情。与乐意乐平等相续。如于上亲。上怨亦尔。齐此名为修慈究竟。修悲修喜次第亦然。拔苦庆慰意乐有别。云何当令此有情类。离如是苦是悲意乐。此有情类得乐离苦。岂不快哉是喜意乐。欲修舍时先缘中品。谓于彼起舍置意乐。中品有情最易舍故。缘亲发爱。缘怨发嗔。故缘处中。初修于舍。舍中品已。次舍下怨。次舍中怨。次舍上怨。次舍下亲。次舍中亲。次舍上亲。先舍其怨。后舍亲者嗔心易舍非爱心故。渐次修习至成满时。普于欲界一切有情。舍置意乐平等相续。无异分别犹如持秤。缘有情类如总观林。齐此名为修舍究竟。问何等有情能修无量。答有情种性略有二种。一于有情乐求过失。二于有情乐求功德。若于有情乐求失者。于四无量多不能修。所以者何。阿罗汉等欲求其失亦可得故。彼于先时亦有瑕隙。故令我等今轻毁之。谁能于彼作饶益事。若于有情乐求德者。于四无量多分能修。所以者何。断善根者欲求其德亦可得故。彼于先时多修善业。故今感得尊贵家生形貌端严众所乐见。言词威肃闻皆敬受。智慧多闻人皆推仰。我应于彼作饶益事

问此四无量次第云何。为如说而生为别有次第。有作是说。如说而生。谓瑜伽师先于欲界诸有情类欲与饶益。与饶益者即是慈相。故佛说慈以为第一。次于欲界诸有情类欲除衰损。除衰损者即是悲相。故佛说悲以为第二。彼诸有情既得饶益复离衰损。次应于彼而生庆慰。庆慰彼者即是喜相。故佛说喜以为第三。既于有情生庆慰已。次应于彼平等舍置。等舍置者即是舍相。故佛说舍以为第四。故四无量如说而生。复有说者。此四无量先悲次慈次喜后舍。谓瑜伽师先于欲界诸有情类欲除衰损。次复于彼欲与饶益。次复于彼深生庆慰。最后于彼平等舍置。尊者僧伽筏苏说曰。悲喜二种互相制御。若先起悲次必生喜。悲令心下须喜策故。若先生喜次必起悲。喜令心举须悲制故。评曰。应作是说。非四无量如说而生。所以者何。修观行者随乐生故。有观行者先起于慈。次悲次喜后起于舍。广说乃至有观行者先起于舍。次喜次悲后起于慈。或有不定有观行者得慈非余。广说乃至有观行者得舍非余。或有不定非四无量有顺次入。或逆次入。或顺超入。或逆超入。如通解脱胜处遍处问若未起初静虑无量。能起第二静虑无量不。乃至若未起第三静虑无量。能起第四静虑无量不。有说。不能初静虑无量与第二静虑无量。为加行门依梯蹬故。乃至第三静虑无量与第四静虑无量为加行门依梯蹬故。有说。亦能谓观行者。若依此地得自在力即依此地先起无量。未起下地无漏圣道。尚起上地无漏圣道。况四无量而不能起。问为下地无量后起上地无量速疾。为上地无量后起下地无量速疾耶。答上地无量后起下地无量速疾。非下地无量后起上地无量速疾。如学梵书后学佉卢瑟吒书速疾。非学佉卢瑟吒书后学梵书速疾。问初静虑无量无间。即能起第二静虑无量不。乃至第三静虑无量无间。即能起第四静虑无量不。依逆次第为问亦尔。有说不能必修自地加行引发方现前故。有说。亦能已熟修者起一加行。或无加行能历诸地。或上或下起无量故。问慈无量等无间即能起悲无量等不。答如定蕴说。思惟何等入慈等至。谓乐有情乃至思惟何等入舍等至。谓舍有情。有作是说。彼说无量俱生行相。复有说者。彼说无量等无间缘。若作是说彼说无量俱生行相。慈无量等无间能生悲无量等。若作是说彼说无量等无间缘。慈无量等无间不能生悲无量等四种加行。各有差别自加行后现在前故。应知作意略有三种。一自相作意。二共相作意。三胜解作意。自相作意者。如有思惟地为坚相。水为湿相。火为暖相。风为动相。如是一切。共相作意者。如十六圣行相俱生作意等。胜解作意者。如不净观持息念解脱胜处遍处等俱生作意。问此四无量于三种中。为与何等作意俱生。答唯与胜解作意俱生假想起故

问且慈无量欲与他乐。缘何等乐与有情耶。有作是说。彼缘第三静虑中乐欲与有情。生死乐中此最胜故若作是说。诸有未得第三静虑。彼应不能起慈无量。或有说者。彼余生中曾受第三静虑中乐。今复依止第三静虑起宿住随念智。缘曾受乐欲与有情。若作是说。诸有未得第三静虑宿住智者。彼应不能起慈无量。复有说者。彼缘无间所受诸乐欲与有情。谓饮食乐或车乘乐。或衣服乐或卧具乐。或余种种近所受乐。缘此诸乐欲与有情。尊者世友作如是说。彼缘有情所受乐相。欲令有情恒受此乐。若作是说慈应不能普缘有情。所以者何。非诸有情皆有乐故。复作是说。彼缘有情起乐根相。欲令有情恒受此乐。若作是说。慈应不能普缘有情。所以者何。非诸有情于一切位。恒起乐根现在前故。复作是说。彼缘有情所受饮食车乘衣服。及卧具等种种乐相。欲令有情恒受此乐。若作是说。慈应不能普缘有情。所以者何。非诸有情皆得如是诸乐具故。大德说曰。先加行时缘曾所见诸有情乐。以怜愍心起胜解想。欲令一切欲界有情。平等皆得如是乐具。由此因缘皆受胜乐。此中意说。诸瑜伽师居近村城阿练若处。于日初分着衣持钵。入近村城如法乞食。于所经处见诸有情纯受胜乐。谓乘象马辇舆等行。众宝严身僮仆侍卫音乐赞咏。陈列香花受极快乐。如诸天子见诸有情唯受剧苦。谓无衣服头发蓬乱身体臭秽。手足皴裂执破瓦盂巡行乞丐。饥穷苦逼如诸饿鬼。见是事已速还住处。收衣洗足结跏趺坐。柔软身心令其调适。离诸障盖有所堪能。忆想先时所见苦乐。于有情类等起怜愍。欲令皆受所见胜乐。问所缘有情非皆得乐。如何慈观非颠倒耶。答利益意乐所等起故。安乐意乐所等起故。调善意乐所等起故怜愍意乐所等起故。如理作意所等起故。善根相应故。惭愧相应故。自性是善故。伏诸烦恼故。远离烦恼故。不名颠倒。复有说者。设名颠倒亦无有失。问若名颠倒应成不善。答颠倒有二种。一自性。二所缘。具二颠倒乃名不善。慈无量观虽有所缘颠倒。而非自性颠倒故非不善。尊者世友作如是说。慈无量观虽不能令所缘有情皆得胜乐。而亦缘彼诸有情类乐具为境故非颠倒。复作是说。缘诸有情乐根为境故非颠倒。复作是说。修此加行能伏嗔缠故非颠倒。大德说曰。如是慈观能违嗔心故非颠倒。问此慈无量为缘一有情欲与其乐。为缘多有情欲与其乐。答此慈无量初修习时。缘多有情欲与其乐。总缘有情修慈心故。后成满已缘一缘多。欲与其乐随意自在。如慈无量问答分别悲亦应尔

如契经说。慈俱行心无怨无对无恼无害广大无量善修习故。与乐胜解遍缘一方二方三方四方上下。若竖若横缘此世间。遍一切分遍一切处。一切有情慈俱行心。与乐胜解遍具足住。乃至广说。问此慈无量缘诸有情。何故经说缘一方等。答此经应言。缘东方等诸有情类。而言遍缘一方等者。于有情类以方声说。如举其器示器中物。此经复说。缘此世间遍一切分遍一切处。一切有情慈俱行心。与乐胜解遍具足住者。问此慈无量缘诸有情。为以方域边际而观。为以有情边际而观。设尔何失。二俱有过。所以者何。若以方域边际观者。何故经说缘此世间遍一切分。遍一切处一切有情。若以有情边际观者。何故非别得有情海边际。有作是说。此以方域边际而观。问若尔。善通后所设难。前所设难当云何通。答应知此说。少分一切。谓一切言略有二种。一少分一切。二一切一切。此经但说少分一切。故不违理。复有说者。此以有情边际而观。问若尔。善通前所设难。后所设难当云何通。答虽无别得有情边际。而有总得有情边际。如四生摄一切有情。无一有情非四生摄。或有说者。佛以有情边际而观。余以方域边际而观。有余师说。佛及独觉俱以有情边际而观。声闻异生但以方域边际而观。评曰。应作是说。此不决定以四无量皆是假想。皆与胜解作意相应。或有一切皆以有情边际而观。或有一切皆以方域边际而观

如世尊说。苾刍当知。我七岁中修慈心故。七成坏劫不来生此。世界坏时生极光净。世界成已生空梵宫。作大梵王威德自在。于千世界我为独尊。复于后时来生欲界。三十六反作天帝释。于无量世作转轮王。具四种兵成就七宝。以法御世亦号法王。此经所言七岁中者。佛意正说经七雨时。谓昔胜时有一菩萨名大威勇。于中印度作大国王。以大威恩统摄一切。然彼国土时多暑热。去城不远有一大林。其地高凉花果茂盛。草木青翠泉池清冷。时彼国人于雨四月。多舍城邑来此避暑。各随所乐作诸事业。时菩萨王以国事务及诸城邑委任大臣。亦往此林居高静处。离欲界染修四无量。雨四月中无时懈废。既度雨际节气渐凉。林中诸人各还城邑作诸事业。尔时菩萨亦从林出。还诣王都设大法祀。广修施福以诸饮食。衣服香花象马辇舆。房舍僮仆灯明卧具。及医药等奉施沙门。并婆罗门贫病孤独。远行羁客诸乞求者。既修施已受持净戒。如是往还经于六反。至第七反过雨际时。有说。寿终生极光净。有作是说。坏劫时至菩萨命终。生极光净。故知七岁谓七雨时。问菩萨所修四无量定是色界系。可由此故生极光净及生梵天。云何复作帝释轮王。岂色界业招欲界果。答菩萨尔时起三无量。一欲界系。由此得作帝释轮王。二初静虑系。由此得作大梵天王。三第二静虑系。由此得生极光净天。复次欲界虽无根本无量。而有无量入出定心。此招轮王帝释异熟。根本无量感极光净或大梵王。复次欲界虽无究竟无量。而有加行。由此得作帝释轮王。究竟无量能招梵王或极光净。复次欲界具有一切善根相似种子。乃至亦有相似灭定由有无量相似善根。得作轮王或天帝释。由有无量真实善根。得生梵天或极光净。复次菩萨林中修无量故。生极光净或作梵王。由还王都设大施会作转轮王。由受持戒作天帝释。复次此经中说三福业事。谓施戒修。如彼经说。苾刍当知。我念过去造三种业得三种果。由彼我今具大威德。所谓布施调伏寂静。布施即是施福业事。调伏即是戒福业事。寂静即是修福业事。施福业事能感轮王。戒福业事感天帝释。修福业事感大梵王。或极光净。如契经说。有三种福业事。一施性福业事。谓以诸饮食衣服香花。广说乃至及医药等。奉施沙门婆罗门等。二戒性福业事。谓离断生命离不与取。离欲邪行。离虚诳语。离饮酒等。三修性福业事。谓慈俱行心。无怨无对无恼无害。广说如前。悲喜舍俱行心广说亦尔。问色无色界有多善根。何故唯说此四无量。为修性福业事耶。答世间唯于饶益他事起福业想。色无色界诸善根中。无欲饶益他如四无量者。是故偏说此为修福业事。复次世于福果起于福想。诸善根中无有能感广饶益果如无量者。是故偏说。复次此四无量及所得果。坚牢难坏故独名福。如伽他说

  福非火所烧　　风亦不能碎
  福非水所烂　　能净持世间
  福能与王贼　　勇猛相抗拒
  不为人非人　　之所能侵夺
  福终无损失　　如坚固伏藏
  以决定能招　　此世他世乐

问非福亦非火所烧等。此中何故唯说福耶。答非福虽非火所烧等。而非福果为火等坏。四无量福及所得果。于去来今非火等坏

如契经说。佛告苾刍。妙眼弟子于诸学处。若有一切及一切种善圆满者。身坏命终生于梵世。于诸学处若有一切及一切种不善圆满者。身坏命终或生他化自在天。或生乐变化天。或生睹史多天。或生夜摩天。或生三十三天。或生四大王众天。或生大刹帝利家。或生大婆罗门家。或生大长者家。或生随一大富贵家。生如是等诸尊胜家。丰饶财宝仓库盈溢。具大宗叶多诸眷属僮仆作使象马辇舆。恒受快乐。问若尔。妙眼应胜世尊。所以者何。妙眼弟子于诸学处。善圆满者得生梵世。不善圆满者生六欲天。及生人中受富贵快乐。世尊弟子于诸学处。善圆满者生天解脱。不善圆满者堕诸恶趣受诸剧苦。理岂尔耶。答不应以佛格量妙眼。所以者何。佛弟子中最卑小者。谓预流果尚胜妙眼。况余尊者。又即世尊昔菩萨位。作梵志师名为妙眼。不应以彼格量世尊。问岂菩萨时胜已成佛。答非彼胜佛但有别意。谓彼妙眼乐修梵住。彼诸弟子求生梵世。故为开示修梵住法。彼弟子中乐修梵住。若已圆满起梵住者。身坏命终生于梵世。彼弟子中乐修梵住。若未圆满起梵住者。身坏命终随福多少。生六欲天。及生人趣诸尊胜家受大快乐。又彼胜时人皆纯善不修无量加行善根。亦得生天人中受乐。况修无量加行善根而不生天人中受乐。佛为弟子证得涅槃。制别解脱律仪学处。若有弟子不犯律仪不破学处。不越轨则不踰界分。彼得生天及证解脱若有弟子犯律仪破学处。越轨则踰界分。彼命终已堕诸恶趣。妙眼弟子于四梵住诸学处中修满未满。世尊弟子于别解脱律仪学处。有持有犯。故彼与佛不应格量。又彼经说。尔时妙眼作如是念。吾今不应与诸弟子同生一处。应修上慈生极光净。作是念已。便速修起第二静虑胜慈无量。于此命终生极光净。问妙眼菩萨既近佛地。决定应离财法二悭。何缘自修第二静虑胜慈无量生彼上天。但为弟子说初静虑四梵住法令生梵世。答彼观弟子根器所宜。故但为彼说初静虑。复次彼诸弟子是婆罗门。长夜期心希求梵世。故但为说生梵世因。复次世无佛时无有能起后三静虑诸无量者。唯除邻近佛地菩萨。问上地无量明净胜妙过于下地。何故彼说第二静虑名上慈耶。答观初静虑说彼为上。复次胜彼弟子所修无量。故名上慈。复次妙眼所修是未曾得过曾得者故名上慈。复次世无佛时无有能起后三静虑诸无量者。唯有妙眼能起第二静虑无量。故名为上。是故尊者妙音说曰。异生无能起上三地诸无量者。由佛说力世尊弟子亦能起之。问何故无量名梵住耶。答梵世在初具可得故。谓未至定虽在最初。而非具有彼无喜故。第二静虑虽复具有而非最初。上地俱阙。唯初静虑梵天所居。最初具有故名梵住。复次对治非梵故名梵住。非梵即是欲界烦恼。初静虑中慈悲喜舍。近对治彼故名梵住。复次对治非梵行故名梵住。非梵行者谓淫欲事。初静虑中慈悲喜舍近对治彼。故名梵住。复次修梵行者身中可得。故名梵住。复次梵谓世尊慈悲喜舍。佛所施设故名梵住。复次梵谓梵音慈悲喜舍梵音所说。故名梵住。复次修此四种得生梵天。为大梵王故名梵住。复次以四无量于梵福中最胜最尊。故名梵住。问梵住无量有何差别。有作是说。无有差别。谓四梵住即四无量。复有说者。亦有差别。谓名即差别。此名梵住。彼名无量故。复次对治非梵名为梵住。对治戏论名为无量。复次对治非梵行名为梵住。对治戏论行名为无量。复次修梵行者身可得名为梵住。离戏论者身中可得名为无量。复次对治不信名为梵住。对治放逸名为无量。复次在梵世者名为梵住。在上地者名为无量。复次在未至定及梵世者名为梵住。在上地者名为无量。复次在未至定及梵世者名为梵住。亦名无量。在上地者唯名为无量。复次曾所得者名为梵住。未曾得者名为无量。复次内道所得名为梵住。亦名无量。外道所得唯名梵住。复次共所得者名为梵住。不共得者名为无量。是故尊者妙音说曰。梵住是共。异生与圣者共竞此法故。无量是不共。圣者与异生不共竞此法故。梵住无量是谓差别

佛说有四补特伽罗能生梵福。云何为四。谓有一类补特伽罗。于未曾立窣堵波处。为佛舍利起窣堵波。是名第一补特伽罗能生梵福。复有一类补特伽罗。于未曾立僧伽蓝处。为佛弟子起僧伽蓝。是名第二补特伽罗能生梵福。复有一类补特伽罗。佛弟子众既破坏已还令和合。是名第三补特伽罗能生梵福。复有一类补特伽罗。修四梵住。是名第四补特伽罗能生梵福。譬喻者说。如是契经非皆佛说。此中前三亦非一切皆生梵福。彼所得果不相似故。谓若有人在佛生处。得菩提处。转法轮处。般涅槃处。起大制多众宝严饰。复有余人。更于诸处。聚砂石等作小制多。彼二生福岂得相似。又若有人。为佛弟子造僧伽蓝高广严饰。如誓多林竹林大林闇林寺等。复有余人。为佛弟子随宜造立小僧伽蓝。彼二生福岂得相似。又若有人。令彼天授所破僧众还得和合。复有余人。能善和息憍饷弥等僧斗诤事。彼二生福岂得相似。故知彼经非皆佛说。亦非一切皆生梵福。四梵住经是佛所说。此四梵住皆是梵福。阿毗达磨诸论师言。如是契经皆佛所说。此中四种皆生梵福。问彼所得果岂相似耶。答所为等故皆生梵福。谓未曾立窣堵波处。为佛世尊真实大梵起窣堵波。若大若小皆生梵福。于未曾立僧伽蓝处。为佛弟子修梵行者起僧伽蓝。若大若小皆生梵福。佛弟子众若大若小既破坏已。不得同修清净梵行。若令和合还得同修清净梵行。故和合者皆生梵福。所为既等。故前三中。事虽有异而福无别。复次饶益等故皆生梵福。如修无量为欲饶益无量有情。如是未立窣堵波处。为佛舍利起窣堵波。亦为饶益无量有情。谓于是处无量百千。诸有情类以诸香花宝幢幡盖及伎乐等。诸供养具而供养之。由此起善身语意业。或种豪族多饶财宝。形貌端严众所爱敬。具大威德胜善种子。或种轮王及天帝释并魔王等诸善种子。或种声闻独觉及佛菩提种子。如是饶益无量有情。如修无量为欲饶益无量有情。如是未立僧伽蓝处。为佛弟子起僧伽蓝。亦为饶益无量有情。谓于是处无量百千诸有情类。以诸饮食卧具医药种种资具奉施供养。或经一日或经七日半月一月。或经五年。或常相续。由此起善身语意业。佛弟子众由此因缘。受持读诵思惟解说三藏文义。起不净观或持息念别总念住。或暖顶忍世第一法。入正决定得果漏尽。由此因缘令施主等或种豪族。广说乃至。或种声闻独觉及佛菩提种子。如是饶益无量有情。如修无量为欲饶益无量有情。如是和合佛弟子众。亦为饶益无量有情。谓僧破已。应入见道得果尽漏。受持读诵思惟解说三藏文义。住阿练若修不净观持息念等。所有善品皆不得成。应种三乘菩提种者亦不能种。由此三千大千世界法轮不转。乃至净居诸天亦有异心现起。佛弟子众还和合时。应入见道得果尽漏。乃至应种三乘种者。皆能成办。由此三千大千世界法轮复转。乃至净居诸天皆无异心现起。如是饶益无量有情。饶益等故皆生梵福。尊者世友作如是说。若未曾立窣堵波处。为佛舍利起窣堵波。由四因缘能生梵福。一以广大思愿舍多财故。二令无量有情种善根故。三诸所营造善究竟故。四安置如来身界藏故。若未曾立僧伽蓝处。为佛弟子起僧伽蓝。由四因缘能生梵福。一以广大思愿舍多财故。二令无量有情种善根故。三诸所营造善究竟故。四无所依止佛弟子众。令得依止修善业故。若僧破已还令和合。由四因缘能生梵福。一舍离四种语恶行故。二摄受四种语妙行故。三破坏非法故。四建立正法故。若有修习四无量者。由四因缘能生梵福。一离违顺故。二断诸盖故。三得梵果故。四系属梵故。由此四种皆生梵福

问此四梵福其量云何。有作是说。若业能招转轮王果。齐此名为一梵福量。有余师说。若业能招天帝释果。齐此名为一梵福量。或有说者。若业能招他化自在天王胜果。齐此名为一梵福量。复有说者。若业能招梵天王果。齐此名为一梵福量。或复有说。世界成时一切有情。能感世界增上果业。齐此名为一梵福量。有余复说。除近佛地菩萨善业。诸余有情能招财富增上果业。齐此名为一梵福量。复有余说。大梵天王最初请佛。转正法轮所得梵福。齐此名为一梵福量。问梵王何时得此梵福。有作是说。彼初发心欲往请佛。当于尔时即得梵福。彼师不应作如是说。若作是说。应未作业而便得福。复有说者。正请佛时得此梵福。彼亦不应作如是说。正请佛时心是欲界无覆无记。无还无记无异熟果岂名梵福。应作是说。大梵天王既请佛已还归梵宫。世尊于后转正法轮。五苾刍众八万诸天皆得见谛。诸神传唱声至梵宫。梵王闻已欢喜踊跃。作是念言。由我请佛转正法轮。饶益无边诸有情类。我所应作念已作讫。梵王尔时乃得梵福。评曰。如是诸说。一梵福量皆是赞美此梵福言。未为称实而实梵福无量无边。是广大思所引发故

说一切有部发智大毗婆沙论卷第八十二阿毗达磨大毗婆沙论卷第八十三

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中十门纳息第四之十三

如契经说。住慈定者。刀毒水火皆不能害。必无灾横而致命终。问何故尔耶。尊者世友作如是说。以慈三摩地是不害法故。复作是说。慈三摩地威势大故。复作是说。慈三摩地为饶益他。诸天善神皆拥卫故。复作是说。修静虑者静虑境界。具神通者神通境界。所有威德不思议故。复作是说。住慈定者起胜分心。非胜分心有死生故。大德说曰。若住慈定。色界大种遍身分生。令所依身坚密如石。故不可害。问悲喜舍定为可害不。若可害者。何故慈定与悲喜舍俱无量摄。而独慈定不可害耶。若不可害者经何故不说。答应作是说。悲喜舍定亦不可害。问若尔。此经何故不说。答应说而不说者。当知此义有余。复次既说慈定。应知亦说悲喜舍定种类同故。复次慈定在初。若说慈定应知已说悲喜舍定。复次住悲等定虽不可害。而出定时身有微苦。慈定不尔是故偏说。复次住悲等定虽不可害而皮有损。慈定不尔是故偏说。复次悲等根本虽不可害。而加行时则可伤害。慈则不尔是故偏说。曾闻有人虽得欲界慈定加行。而犯王法时法司者执送见王。白言。此人犯应死罪。时王乘象欲出城游。见已遣人捡王法律。知其所犯王应手害。王遂大嗔以矛[矛*贊]彼。其人见已便起慈心。令所[矛*贊]矛还趣王所。去王不远而投于地。王见惊怖问罪人言。汝有何术能为此事。其人答言我无异术。见王嗔故遂起慈心。令恶心者不能为害。王因忏谢遂释放之。由此故知修慈加行亦不可害。悲等不尔如契经说。修慈断嗔。修悲断害。修喜断不乐。修舍断贪嗔。问既说慈舍俱对治嗔。所对治嗔有何差别。答慈对治断命嗔。舍对治捶打嗔。复次慈对治是处嗔。舍对治非处嗔。问无量为能断烦恼不。若能断者。定蕴所说当云何通。如说慈悲喜舍皆不能断诸结。若不能断者。此经云何通。答应作是说。无量不能断诸烦恼。问若尔。善通定蕴所说。此经所说当云何通。答断有二种。一暂时断。二毕竟断。依暂时断此经说能断。依毕竟断定蕴说不断。如是经论二说善通。如暂断毕竟断。如是有片断无片断。有影断无影断。有余断无余断。有随缚断无随缚断。有分断无分断。制伏断拔根断。伏诸缠断。害随眠断。应知亦尔

问若四无量不断烦恼。余经所说复云何通。如说苾刍。修慈心定。若不胜进住不还果。广说乃至修舍心定。应知亦尔。答彼经说圣道名慈等心定。如诸经中佛于圣道。或说为想。或说为受。或说为思。或说为意。或说为灯。或说为信精进念定慧。或说为船筏。或说为山石。或说为水华。一一引经如余处说。彼经亦尔。于无漏道说慈等声。亦不违理。复次为求慈等四种梵住离欲染者。或见异生或是圣者。若是异生先离欲染得慈等定。于后得入正性离生证不还果。若彼先时于欲界染未得全离。后时得入正性离生。证预流果或一来果。彼后证得不还果者是慈等力。若是圣者离欲染时。得慈等定及不还果。依此故说修慈等定得不还果。亦不违理

如契经说。修不净观能断欲贪。修舍无量亦断欲贪。此二何别。答修不净观对治淫欲贪。修舍无量对治境界贪。复次修不净观对治显色贪。修舍无量对治形色贪。复次修不净观对治细触贪。修舍无量对治容仪贪。复次修不净观对治形貌贪。修舍无量对治有情贪。是谓差别

如契经说。与慈俱修念等觉支。依止离。依止无欲。依止灭。回向于舍。悲喜舍三说亦如是。问无量有漏。觉支无漏。云何有漏与无漏俱。尊者世友作如是说。由四无量调伏其心。令心质直有所堪能。从此无间引起觉支。觉支无间引起无量。无量觉支相杂而起。故说为俱而实不并

问四无量中何者最胜。有作是说。慈最为胜。所以者何。不可害故。有余师说。悲最为胜。所以者何。佛以大悲说正法故。或有说者。喜最为胜。所以者何。断不乐故。复有说者。舍最为胜。所以者何。断贪嗔故。大德说曰。由二因缘舍最为胜。一由所作。谓若修舍能断贪嗔。二由寂静。谓于有情无分别转。故舍最胜

问世尊何故但说大悲。不说大慈大喜大舍。答皆应说大。以佛身中一切功德皆是大故。为欲饶益无量有情心所起故。为欲拔济无量有情心所起故。为欲哀愍无量有情心所起故。于诸有情善心平等相续转故。然于此中不应为问。所以者何。若悲自性。即是大悲可为此问。然悲大悲自性各别。故不应问。而诸经中亦有处说大慈大喜及大舍言

问悲与大悲有何差别。答名即差别。谓名为悲。名大悲故。复次悲以无嗔善根为自性。大悲以无痴善根为自性。复次悲对治嗔不善根。大悲对治痴不善根。复次悲在四静虑。大悲唯在第四静虑。复次悲是无量摄。大悲非无量摄。复次悲在异生圣者身中成就。大悲唯在圣者身中成就。复次悲在声闻独觉及佛身中成就。大悲唯在佛身成就。复次悲但能悲而不能救。大悲能悲亦复能救。如有二人住大河岸。见有一人为水所溺一唯扼手悲嗟而已不能救之悲亦如是。第二悲念投身入水而救济之。大悲亦尔。尊者世友作如是说。悲但缘欲界苦所苦有情。大悲缘三界苦所苦有情。复作是说。悲但缘粗苦所苦有情。大悲缘粗细苦所苦有情。复作是说。悲但缘苦苦所苦有情。大悲缘三苦所苦有情。复作是说。悲但缘身苦所苦有情。大悲缘身心苦所苦有情。复作是说。悲但缘现法苦所苦有情。大悲缘现法及后法苦所苦有情。复作是说悲但缘近苦所苦有情。大悲缘近远苦所苦有情。复作是说。悲但缘现在苦所苦有情。大悲缘三世苦所苦有情。大德说曰。大悲是佛第四静虑不共住法。能远随行能细随行能遍随行。普于一切怨亲中品。诸有情类平等而转。悲与异生声闻独觉皆等成就。定不能缘色无色界。悲与大悲是谓差别

问以何义故名为大悲。答拔济大苦诸有情类。故名大悲。大苦者谓地狱傍生鬼界中苦。复次拔济沉溺三毒淤泥诸有情类。安置圣道及圣道果。故名大悲。复次以大利益大安乐事摄有情类。故名大悲。谓令有情修身语意三种妙行感大尊贵多饶财宝。形貌端严众所爱敬。轮王帝释魔王等果。及种三乘菩提种子。如是等事皆由大悲。复次大价所得故名大悲。非如独觉声闻菩提。于一斋日以一抟食。施与一人发胜思愿。便名树彼菩提种子。由斯展转得彼菩提。大悲要由经多时分。于一切处以一切种上妙乐具施诸有情。乃至身命都无吝惜。发胜思愿方名树彼大悲种子。由斯展转乃得大悲。复次大加行得故名大悲。非如声闻菩提唯六十劫修加行得。独觉菩提唯经百劫修加行得。如来大悲三无数劫。修习百千难行苦行然后乃得。故名大悲。复次依大身住故名大悲。非如独觉声闻菩提依下劣身亦得现起。大悲要依具三十二大丈夫相所庄严身。八十随好间饰支体身真金色圆光一寻观无厌足。依如是身方得现起。故名大悲。复次舍大法乐故名大悲。谓佛弃舍最上胜妙圆满清净不共法乐。数数踰越无量百千俱胝轮围山等。为他说法不辞劳倦。故名大悲。复次由此势力能令大士作难作事。故名大悲。谓佛世尊为众生故舍尊贵位。或作陶师。或作力士。或作乐人。或作猎师。或作淫女。或作乞人。或引难陀遍游五趣。或现近远而化指鬘。虽具惭愧。为化女人现阴藏相。虽离掉举。为化众生现广长舌。作如是等极难作事。故名大悲。复次由此势力动大舍山令不安住。故名大悲。佛有二种不共住法。一者大舍。二者大悲。若佛大舍现在前时。假使一切世界有情皆被烧然如干薪聚。虽佛前住而不视之。若起大悲。乃至见一众生受苦。那罗延身虽极坚固难可摇动。而犹猛风吹芭蕉叶。由此等义故名大悲。毗柰耶说。佛以普慈慈荫有情而为说法。问诸有情类由佛普慈慈荫之时为得乐不。若得乐者。何故地狱傍生鬼界。及余苦厄诸有情类。由佛慈荫而不离苦。若不得乐伽他所说当云何通。如说

  鬼神以恶意　　欲来趣向人
  虽未触害身　　而已生苦怖

恶意向人即令苦怖。佛心慈荫宁不得乐。有作是说。佛以普慈慈荫有情亦令得乐。问若尔。善通伽他所说。前所设难当云何通。答佛观有情业可转者。普慈缘彼即令得乐。若观彼业不可转者。佛不缘彼而起普慈。复有说者。佛虽以普慈慈荫有情。而诸有情不即得乐。问若尔。善通前所设难。伽他所说当云何通。答佛以普慈慈荫他故。现种种事乃令得乐。鬼神亦应现可畏事。方令苦怖非唯慈心。世尊所现种种事者。或现神通。或现爱事。或现妙药。或现妙触。或现乐影。如是所现其类极多。现神通者。曾闻佛住王舍大城鹙鹭池边竹林精舍。时有居士请佛及僧。欲往其家设大施会。佛日初分着衣持钵与苾刍众入王舍城。未生怨王恶友天授所教化故。纵极狂醉护财大象欲害如来。尔时如来申举右手。于五指端化五师子。象见惊怖反顾避之。佛于其后化作大坑。其坑深广各百千肘。象见转怖便顾左右。佛于左右。化作高墙俱欲颓压。象见惶惧。仰视虚空。佛于空中化作大石。周匝猛焰将欲堕落。象见惊惶周慞遍顾。佛又处处化作猛火。唯佛足边清凉安静。象既见已醉心醒悟。佛知调伏灭五师子。象前以鼻摩世尊足。佛以百福庄严相手。摩彼象顶。便以象语而为说法。诸行无常诸法无我涅槃寂静。汝应于我起敬信心。不久必得脱傍生趣。象闻法已起敬信心。厌离象身不复饮食。命终生在三十三天念荷佛恩。来诣佛所。佛为说法见四圣谛。礼敬佛已还自天宫。时世皆言护财大象。佛慈荫故狂醒生天。此中慈荫谓现神通。佛于余处复现神通。曾闻佛欲般涅槃时。游力士邑至播波村住彼村边。尺蠖林内力士闻已共集议言。我等皆应同诣佛所。若不往者。当罚五百古大金钱。充邑家用。时有力士名曰卢遮。豪望多财心不信佛。窃作是念。我不惜钱。但不能违亲友制约。遂与邑人同诣佛所。顶礼佛足却住一面。尔时阿难谓卢遮曰。汝来见佛甚为善哉。无上福田不久当往娑罗林间入大寂灭。卢遮性直白阿难言。我来见佛非自心愿。但不能违亲友制约。阿难以手牵卢遮臂。前诣佛所而白佛言。卢遮力士不信三宝。唯愿世尊为说法要。佛作是念。此爱行人贪着五欲。若为说法卒未能解。佛愍彼故为现神通。化作一坑尸粪充满臭烟熢[火*孛]猛火洞然。其中出声。卢遮力士。若不信佛听受法者。彼命终已定生此中。卢遮见闻身心战惧。便归投佛。佛为说法。心生信已即受三归。时世皆言。卢遮力士佛慈荫故令信三宝。此中慈荫谓现神通。现爱事者。曾闻佛住弥絺罗邑大自在天庵罗林内。有梵志妇名婆斯搋。丧失六子心遂狂乱。追念子故露形驰走。遇来入此庵罗林中。遥见世尊多百千众。前后围绕而为说法。狂者见佛法尔便醒。彼既羞惭曲躬而坐。尔时佛告尊者阿难。汝可取衣与梵志妇。吾欲为彼说正法要。阿难受教取衣与之。彼着衣已礼佛而坐。佛作是念此婆斯搋心没忧海。假使今者过殑伽沙佛为说法。亦不能解。佛愍彼故为现神通。化作六子在其前住。彼见欢喜忧恼便息。佛为说法见四圣谛。时世皆言。此婆斯搋。佛慈荫故狂醒见谛。此中慈荫谓现爱事。佛于余处复现爱事。曾闻佛往室罗筏国住誓多林给孤独园。有一梵志。稻田成熟垂当收刈令一子守。忽遇灾雹田坏子亡。梵志发狂露形驰走。遇来入此誓多林中。遥见世尊多百千众前后围绕而为说法。狂者见佛法尔便醒。前礼佛足退坐一面。佛作是念。此婆罗门心没忧海。假使今者过殑伽沙佛为说法。亦不能解。佛愍彼故为现神通。化作稻田及所爱子。彼见欢喜忧恼便息。佛为说法见四圣谛。时世皆言。此婆罗门。佛慈荫故狂醒见谛。此中慈荫谓现爱事。现妙药者。曾闻世尊游迦尸邑。展转来至婆罗痆斯。住施鹿林仙人堕处。有一居士名曰大军。彼居士妇亦名大军。夫妇二人俱信三宝。恒以资具恣佛及僧。有一苾刍服吐下药。吐下过量因致风虚。医人处方须服肉汁。时看病者往居士家。具以上事告居士妇。彼居士妇遣使持钱向市买肉。时彼国王名为梵授。生子欢喜普敕城中一日断杀。使者遍城求肉不得。时居士妇知已念言。我恣佛僧诸资身具。彼病苾刍药须肉汁。今既不获或因致死。复念。世尊昔菩萨位。为救他命数舍身肉。今我亦应学菩萨行。即入静室手执利刀。自割髀肉持与使者。令办肉汁施病苾刍。病者得已不作忆念。因即服之所患便愈。时居士妇苦痛所逼。呻吟在室不任自安。居士外来问其所在。家人因以先事具白居士。入室见妇呻吟遂发嗔忿。沙门释子极无惭愧。如何受施不知时宜。施虽无厌受应知量。寻往佛所欲白世尊。正值如来为众说法。瞻仰尊颜嗔心便止窃作是念。未应白佛。先当请佛及苾刍僧。因至家中乃可具白。遂前礼佛退坐一面。佛说法竟。即从坐起请佛及僧。明当受供。佛知请意默然许之。居士还家夜办供具。晨朝敷座遣使白佛。营供已讫惟圣知时。尔时世尊以日初分。着衣持钵将苾刍僧。往居士家。敷座而坐。知而故问。家母在何。居士答言。在室病苦。佛告居士汝可语之。大悲世尊今令唤汝。佛非唯解内缘起法。亦善能知外缘起事。即以神力引香山中疗刀疮药。封涂其疮令止苦痛。平复如本。居士入室告其妻言。大悲世尊令我唤汝。妻曰。佛力不可思议。才闻世尊令仁唤我。疮苦痛止乎复如本。夫妻喜跃倍加敬信。共诣佛所顶礼双足。佛为说法俱见圣谛。时世皆言。大军夫妻。佛慈荫故疮愈见谛。此中慈荫谓现妙药。佛于余处复现妙药。昔胜军王断贼手足弃城堑中。世尊尔时着衣持钵为乞食故将欲入城。彼贼见佛举声大唤。唯愿世尊垂哀救苦。佛非唯解内缘起法。亦善能知外缘起事。即以神力引香山中疗刀疮药。封涂其疮令止苦痛。因为说法。贼闻法已见四圣谛。时世皆言。乃至恶贼。佛慈荫故苦止见谛。此中慈荫谓现妙药。现妙触者。曾闻佛住鹫峰山南。提婆达多居鹫峰北。昼夜头痛不能寝食。阿难愍彼具白世尊。佛申右手如象王鼻穿鹫峰山。摩天授顶现细妙触。发诚谛言。我于天授慈心怜愍。与罗怙罗等无异者。当令天授头痛即止。天授头痛应声便止。遂顾念言。谁手见触。既知佛手。而作是言。善达医方可用自活。时人皆曰。乃至天授佛慈荫故头痛得除。此中慈荫谓现妙触。佛于余处复现妙触。曾闻世尊巡行房舍。至一房内见一苾刍。病卧粪中不能起动。彼见佛已悲号白佛。世尊。我今无归无救。世尊告曰。汝本出家。岂不归依三界慈父。彼言。如是。佛复告言。汝何乃言无归无救。汝曾瞻养病苾刍耶。答言。不曾。佛言。故宜他不看汝。世尊便自扶病苾刍。脱彼身衣安置一处。复以竹片刮去彼身所著粪秽。以白土泥涂摩支体。天帝注水而沐浴之。复以牛粪涂其房中。更敷新草扶令安坐。浣所污衣曝干令着。佛分半食而与食之。以福庄严细妙触手。摩其顶上。令彼病苦应时即愈。因为说法成阿罗汉。时世皆言。乃至病者佛慈荫故病除得果。此中慈荫谓现妙触。现乐影者。曾闻世尊与舍利子一处经行。时有一鸟为鹰所逐。怖急便趣舍利子影。怖犹不止举身战栗。复越佛影身心坦然。时舍利子合掌白佛。如何此鸟至我影中犹有恐惧。才至佛影。心无惊怖身不战栗。世尊告言。汝六十劫修不害意。我于三大无数劫中修不害意。汝有害习。我已永断故令如是。时世皆言。乃至小鸟佛慈荫故令怖畏除。此中慈荫谓现乐影。佛于余处复现乐影。曾闻愚暴毗卢宅迦。坏如天宫劫比罗国。诛戮释种劫夺珍财。将五百释女还室罗筏国。共升台观而自矜夸释种豪慢我已诛讫。释女语言。释种为戒所防制故令汝诛杀。毗卢宅迦闻已大忿。此诸释女犹怀傲慢。皆截手足弃城堑中。释女尔时苦痛所逼。各专念佛请垂哀愍。佛知彼念。大悲所牵屈申臂顷寻至其所。念天帝释令持衣覆。自放身光照诸释女。时诸释女蒙光影覆。苦痛皆除身心安隐。因为说法皆见圣谛。命终生妙三十三天。世人皆言。佛慈荫故乃至释女皆获利乐。此中慈荫谓现乐影。由如是等种种因缘。故非慈荫即令得乐

如契经说。修慈究竟极至遍净天。修悲究竟极至空无边处修喜究竟极至识无边处。修舍究竟极至无所有处。问修慈究竟极至遍净。是事可尔。得彼果故系属彼故。修三无量究竟极至下三无色。云何可尔。岂有色界善招无色果耶。答有作是说。此说甚深。弥勒下生当解此义。复有说者。尊者寂授能解此义。此本论师当造论时。逢彼在定不获请问。有余师说。佛观所化宜于无色说无量声。乃能悟解。故作是说。如于解脱说八方声。或有说者。此中佛于第三静虑。下三无色对治觉支。说为慈等。故不违理。有余复言。与彼相似故作是说。谓慈无量乐行相转。乐受极至第三静虑。悲无量苦行相转。有色便有断手足等种种苦事。空无边处诃责诸色似悲行相。喜无量欢行相转。识无边处于识欢悦似喜行相。舍无量舍行相转。无所有处多所弃舍似舍行相。故依相似说无量声。复次至彼乐住故作是说。谓乐修慈者。离欲界染。起初净虑心不乐住。更求胜进离初静虑染起第二静虑亦复如是。离第二静虑染起第三静虑时心便乐住。乐修悲者。离欲界乃至第三静虑染。起第四静虑心不乐住。更求胜进离第四静虑染起空无边处时心便乐住。乐修喜者。离欲界乃至第四静虑染。起空无边处心不乐住。更求胜进离空无边处染。起识无边处时心便乐住。乐修舍者。离欲界乃至空无边处染。起识无边处心不乐住。更求胜进离识无边处染。起无所有处时心便乐住。故依乐住说无量声。复次依相随顺故作是说。谓慈所起欲界等流顺第三静虑。第三静虑所起欲界等流顺慈。广说乃至舍所起欲界等流顺无所有处。无所有处所起欲界等流顺舍。故依相顺说无量声。复次为对外道于无色界起解脱想。故于无色说无量声。显无色界皆如无量非真解脱。是故尊者妙音说曰。诸外道辈愚无色界执为解脱。故佛于彼说无量声。显似无量非真解脱

四无色者谓空无边处。识无边处。无所有处。非想非非想处。问何故作此论。答为止他宗显正义故。谓或有说。无色界有色。如分别论者。或复有说。无色界无色。如应理论者。问分别论者依何教理说无色界亦有色耶。答依契经故。谓契经说。名色缘识识缘名色。无色界既有识亦应有名色。余经复说。寿暖识三恒和合不相离。不可施设离别殊异。无色界中既有寿识亦应有暖。余经复说。离色受想行。不应说识有去来住有死有生。无色界中既得有识。亦应具足有四识住。复有过难。若无色界全无色者。欲色界死生无色界。或二万劫。或四万劫。或六万劫。或八万劫。诸色断已后死还生欲色界时色云何起。若色断已还得起者。般涅槃已诸行既断。亦应后时还起诸行。勿有此失。故无色界决定有色。问应理论者依何教理说无色界全无色耶。答依契经故。谓契经说。色界出离欲。无色界出离色。寂灭涅槃出离有为。既说无色界出离色。故无色界定无诸色。余经复说入静虑时观一切色受想行识如病如痈。乃至广说。入无色定时。观一切受想行识。如病如痈。乃至广说。由此故知无色界中定无诸色。余经复说。无色诸定寂静解脱超过诸色。由此故知无色界中定无诸色。余经复说超诸色想灭有对想。不思惟种种想入无边空。空无边处具足住故。无色界定无诸色复有过难。若无色界犹有色者。应无渐次灭法。若无渐次灭法。应无究竟灭法。若无究竟灭法应无解脱出离涅槃勿有此过故。无色界决定无色。问此二说中何者为善。答应理论师所说为善。问应理论者云何释通分别论者所引契经。答彼所引经是不了义。是假施设有别意趣。所以者何。如来说法。或依欲界。或依色界。或依无色界。或依欲色界。或依色无色界。或依三界。或依离三界。依欲界者如说三界三寻三想。谓欲恚害。依色界者。如说四静虑。依无色界者如说四无色。依欲色界者。如彼所引经依色无色界者。如说修定意所成等。依三界者。如说三界及三有等。依离三界者。如说涅槃及圣道等。且彼所引等一契经名色与识互为缘者。依欲色界说。若无色界唯名与识更互为缘。若即如文而取义者。即彼经说六处缘触。岂无色界具有六处。又彼所引第二契经。寿暖识三不相离者。亦依欲色界说。若无色界唯寿与识互不相离。若即如文。而取义者。即彼经说寿暖识三不可施设离别殊异。岂此三种蕴界处门。不可施设离别殊异。又彼所引第三契经。离色受想行不应说识。有去来等者亦依欲色界说。若无色界应说离受想行。不应说识有去来等。若即如文而取义者如余经说。一切有情皆依食住。岂上二界亦资段食。问云何通彼所说过难。答此不须通非三藏故。若必须通应示义趣。谓于三界死生往来。或色续色。或色续无色。或无色续无色。或无色续色故。不应说诸色断已。复云何起无断义故。问若离色已复还生色。般涅槃已应还起行。答离有二种。一暂时离。二究竟离。暂时离者。复可还生。究竟离者。必不复起故不应难。问分别论者云何释通应理论者所引契经。彼作是说。此所引经是不了义。是假施设有别意趣。所以者何。谓彼经说无色界出离色者。出离粗色非无细色。如说色界出离诸欲。而色界中犹许有色。说无色界出离诸色。无色界中应许有色。彼不应作是说。不说色界出离色故可犹有色。说无色界出离色故应定无色又如色界说出离欲细欲亦无。说无色界出离色故亦无细色。又无色界无粗受等。亦应说为无受等界。又色界色细于欲界应说色界亦名无色。下三无色粗于有顶应说下三名有色界。故彼所说定不应理。彼于余经及说过难皆不能通。是故应知。分别论者。是无知果。黑闇果。无明果。不勒加行果。说无色界犹有细色。然无色界诸色皆无。为止如是他宗所说显示己宗所有正义。非但止他显己所说。亦为显示诸法正理。令他解了故作斯论

说一切有部发智大毗婆沙论卷第八十三阿毗达磨大毗婆沙论卷第八十四

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中十门纳息第四之十四

云何空无边处。品类足说。空无边处总有二种。谓定及生。若生彼处无覆无记受想行识。如是总名空无边处。乃至非想非非想处说亦如是。此中定者谓无色定。生者即说无色界生。若生彼处无覆无记受想行识。此言说彼四蕴异熟。契经中说。超诸色想灭有对想。不思惟种种想入无边空。空无边处。具足住。是名空无边处。此中超诸色想者。谓超眼识相应想。问离初静虑染时。已超此想。何故今说超诸色想耶。答过所依故。过有二种。一过自性。二过所依。离初静虑染时。过彼自性说名为超。离第四静虑染时过彼所依说名超彼。复次过现行故。过有二种。一者断过。二者不现行过离初静虑染时。断诸色想说名为超。离第四静虑染时。彼不现行说名超彼。复次过住处故。过有二种。一过欲贪。二过住处。离初静虑染时。过彼欲贪说名为超。离第四静虑染时。过彼住处说名超彼。复次若生第四静虑。眼识引彼色贪现前故。离第四静虑染时。亦说超诸色想。不复引起缘色贪故。灭有对想者。谓灭耳鼻舌身识相应想。问离欲界染时。已灭鼻舌识相应想。离初静虑染时。已离耳身识相应想。何故今说灭有对想耶。答前诸答中随其所应亦通此问。有余师说嗔相应想名有对想。问离欲界染时。已灭一切嗔相应想。何故今说灭有对想耶。答过依处故。谓诸依处能起嗔想。今离第四静虑染时。皆超过彼故名为灭。问何故不名灭诸色想超有对想。答亦应互说欲现异文令生爱乐。复次欲现二门。乃至广说。不思惟种种想者。谓不现起第四静虑意识相应诸杂乱想。问种种想者义何谓耶。答此想缘种种处差别相故。谓染污者缘十处差别相。不染污者缘十二处差别相。是故此想名种种想。问何故说不思惟种种想耶。答以种种想离第四静虑染时。极作留难系缚障碍如暴狱卒。故世尊说。离第四静虑染时。不应思惟起种种想。如是便能速离此染入无边空。空无边处者。问此何故名空无边处。为以自性。为以所缘。设尔何失。二俱有过。所以者何。若以自性。空无边处以四蕴为自性不应名空。若以所缘空无边处缘四圣谛及虚空非择灭。云何但名空无边处。答应作是说。此不以自性亦不以所缘。但以加行故名空无边处。如施设论说以何加行修空无边处定。由何加行入空无边处定。谓初业者先应思惟墙上树上崖上舍上等诸虚空相。取此相已假想胜解。观察照了无边空相。以先思惟无边空相。而修加行。展转引起初无色定故。说此名空无边处。复次法尔初远离色地名空无边处。复次法尔初解脱色地名空无边处。谓瑜伽师先攀上色地离下色地染。若离第四静虑染时。攀空无边处四蕴而离第四静虑染。先缘上地作虚空想。后方引起离下染道。如人上树先攀上枝而舍下枝。若至树端更无上枝而可攀故但起空想。复次依等流故说此定名空无边处。谓瑜伽师从此定出必起相似空想现前。曾闻苾刍出此定已。便举两手扪摸虚空。有见问言。汝何所觅。苾刍答曰。我觅自身。彼言。汝身即在床上。如何余处更觅自身。故从此出起虚空想。此想即是前定等流。具足住者。谓得获成就空无边处善四蕴。于得获成就说具足住声。是故名为空无边处

云何识无边处。如契经说。超一切空无边处入无边识。识无边处。具足住。是名识无边处。问此何故名识无边处。为以自性。为以所缘。设尔何失。二俱有过。所以者何。若以自性识无边处以四蕴为自性。不应但名识无边处。若以所缘识无边处缘四圣谛及虚空非择灭亦不应但名识无边处。答应作是说。此不以自性。亦不以所缘。但以加行名识无边处。如施设论说。以何加行修识无边处定。由何加行入识无边处定谓初业者。先应思惟清净眼等六种识相。取此相已假想胜解。观察照了无边识相。以先思惟无边识相而修加行。展转引起第二无色定故。说此名识无边处。复次依等流故说此定名识无边处。谓瑜伽师从此定出必起相似识相现前。谓于识相欢悦而住。具足住者。谓得获成就识无边处善四蕴。于得获成就说具足住声。是故名为识无边处

云何无所有处。如契经说。超一切识无边处。入无所有无所有处具足住。是名无所有处。问此何故名无所有处。答此中无我无我所故。问一切地中无我我所。何独此名无所有处。答无有余地能令我执及我所执。羸劣穿薄势力减少如此地者。故此独名无所有处。复次此地无有真实常恒不变易法。损伏常见胜诸余地。故此独名无所有处。复次此地无有所趣所归屋舍室宅能为救护。摧伏憍慢懈怠放逸胜诸余地。故此独名无所有处。复次此地中无无边行相初舍彼相。故此独名无所有处。尊者世友作如是说。于此定中无能所摄行相转故。如说非我有处有时有所属物。亦无处时物属我者。故此独名无所有处。具足住者。谓得获成就无所有处善四蕴。于得获成就说具足住声。是故说名无所有处。问佛何故说无所有处独名舍耶。答舍谓圣道能尽舍故。有圣道地此最为后故于此地独立舍名。尊者世友作如是说。此地近舍假想胜解无边行相。粗观解故独立舍名。大德说曰。此地弃舍作意功用无边行相心心所法。无功用住故独名舍

云何非想非非想处。如契经说。超一切无所有处。入非想非非想处具足住。是名非想非非想处。问此何故名非想非非想处。答此地中无明了想相。亦无无想相故名非想非非想处。无明了想相者。非如七地有想定故。亦无无想相者。非如无想及灭定故。由此地想闇钝羸劣。不明了不决定故名非想非非想处。具足住者。谓得获成就非想非非想处善四蕴。于得获成就说具足住声。是故名为非想非非想处

问欲界非想非非想处。何缘无有无漏道耶答非由器故。谓彼二地非无漏道所依。由器故无漏道二地中无。复次断有根故。谓彼二地是有根本。诸无漏道断有根本。故无漏道二地中无。复次断二边故。谓彼二地是下上边。诸无漏道能断二边住于中道故彼地无。复次欲界无定亦非修地非离染地。有顶闇钝不决似疑。诸无漏道必依定界修离染地明利决定故二地无。复次欲界地中掉举增上。有顶地中寂止增上。非无漏道所依止处

问何故世尊于无色定皆说超言。静虑不尔。答佛于静虑亦说超言。如世尊告坞陀夷言。苾刍离欲恶不善法有寻有伺。离生喜乐入初静虑具足而住。我说是火亦是所断亦是应超。乃至第四静虑亦尔。问唯一经说静虑应超。余经皆说无色是超。此有何意。答静虑中有种种异相不相似法。故不说超。无色不尔。故独说超。复次静虑中有异相诸根异相诸受及有异相心心所法。故不说超。无色不尔。故独说超。复次静虑中有多种功德多种胜利。故不说。超无色不尔。故独说超。复次静虑粗显明了现见。故不说超。无色细隐不明了不现见。故独说超。复次静虑遍缘自上下地。故不说超。无色唯能缘自上地。故独说超。复次以诸静虑与上下地虽不死生而有往来。谓神通力从下往上从上来下。故不说超无色地中无如是义。故独说超。复次以诸静虑与上下地中有交杂。下地中有上地现前。上地中有下地现前。既有交杂。故不说超。无色地中无如是义。故独说超。复次生上静虑起下地法。如诸识身变化心等。故不说超。生上无色必不起下诸有漏法。故独说超。复次生上静虑有下地法得常随转。如变化心等。故不说超。生上无色必无下地诸有漏法得随转义。故独说超。由如是等种种因缘。佛于无色说有超言。静虑不尔

如契经说。空无边处二万劫寿。识无边处四万劫寿。无所有处六万劫寿。非想非非想处八万劫寿。问何故无色寿量有倍增者。有增半者。有增少分者耶。答如异熟因有尔所力。还受尔所异熟果故。复次空识无边处有无边行相亦有余行相。谓空无边处无边行相招万劫寿。余行相亦招万劫寿。识无边处无边行相招二万劫寿。余行相亦招二万劫寿。此上更无无边行相。唯有余行相。故彼寿量不倍增下。然无所有处别有摧伏我我所等。胜善观行异于余地。由彼善招二万劫寿。故余行相所招寿量亦倍倍增。复次空识无边处有奢摩他毗钵舍那。谓空无边处奢摩他招万劫寿。毗钵舍那亦招万劫寿。识无边处奢摩他招二万劫寿。毗钵舍那亦招二万劫寿。此上无胜毗钵舍那。唯有奢摩他。故彼寿量不倍增下。余如前说。复次四无色地皆无多种功德法故。一一等有二万劫寿。上三无色离下地染。有少多故倍倍增寿。谓识无边处已离下一无色地染招二万劫寿并本二万为四万劫。无所有处已离下二无色地染。招四万劫寿并本二万为六万劫。非想非非想处已离下三无色地染。招六万劫寿并本二万为八万劫

八解脱者。一有色观诸色解脱。二内无色想观外色解脱。三净解脱身作证具足住。四超诸色想灭有对想。不思惟种种想入无边空。空无边处具足住解脱。五超一切空无边处入无边识。识无边处具足住解脱。六超一切识无边处。入无所有无所有处具足住解脱。七超一切无所有处。入非想非非想处。具足住解脱。八超一切非想非非想处。入想受灭身作证具足住解脱。问此八解脱自性是何。答初三解脱以无贪善根为自性。皆对治贪。故若兼取相应随转。则欲界者以四蕴为自性。色界者以五蕴为自性。四无色处解脱皆以四蕴为自性。想受灭解脱。以不相应行蕴为自性。如是名为解脱自性。我物自体相分本性。已说自性。所以今当说问何故名解脱。解脱是何义。答弃背义是解脱义。问若弃背故名解脱者。何等解脱弃背何心。答初二解脱弃背色贪心。第三解脱弃背不净观心。四无色处解脱各自弃背次下地心。想受灭解脱弃背一切有所缘心。故弃背义是解脱义。尊者世友作如是说。心于烦恼解脱清净。故名解脱。大德说曰。由胜解力而得解脱。故名解脱。胁尊者言。有所背舍故名解脱

此八解脱。界者初三解脱是色界。前三无色处解脱。有漏者是无色界。无漏者是不系。后二解脱是无色界。地者初二解脱在初二静虑及未至定静虑中间。余地亦有相似善根。而不立为初二解脱。所以者何。欲界散乱弃背力劣。故不建立初二解脱。弃背欲界及初静虑识身所引缘色贪心。故初二静虑立初二不净解脱。第二第三静虑无识身所引缘色贪心故。第三第四静虑不立初二不净解脱第三解脱在第四静虑。下地亦有相似善根。而不立为第三解脱。所以者何。立净解脱为欲弃背不净观心。若在下地为不净观力所摧伏。不广不明故不建立。第三静虑虽无初二不净解脱。而为胜乐所迷乱故。不广不明故不建立。第四解脱在空无边处

问于此地中何法是解脱。何法非解脱。答离第四静虑染诸加行道。九无间道八解脱道。及生得善等非解脱。余有为善是解脱。第五解脱在识无边处

问于此地中何法是解脱。何法非解脱。答离空无边处染诸加行道。九无间道八解脱道。及生得善等非解脱。余有为善是解脱。第六解脱在无所有处。问于此地中何法是解脱。何法非解脱。答离识无边处染诸加行道。九无间道八解脱道。及生得善等非解脱。余有为善是解脱。第七解脱在非想非非想处。问于此地中何法是解脱。何法非解脱。答离无所有处染诸加行道。九无间道八解脱道。及生得善等非解脱。余有为善是解脱。想受灭解脱在非想非非想处。所依者。初三解脱依欲界身起。想受灭解脱依欲色界身起。余四解脱依三界身起。行相者。初二解脱作不净行相。第三解脱作净行相。四无色处解脱作十六行相。或余行相。想受灭解脱不作行相。所缘者。初三解脱缘欲界色处。第四解脱缘四无色。及彼因彼灭一切类智品。若四无色及类智品。非择灭并虚空。若谓一物。若谓多物一切皆缘。第五解脱缘后三无色。及彼因彼灭一切类智品。若后三无色及类智品。非择灭并虚空。若谓一物。若谓多物。一切皆缘。第六解脱缘后二无色。及彼因彼灭一切类智品。若后二无色及类智品。非择灭并虚空。若谓一物。若谓多物。一切皆缘。第七解脱缘非想非非想处。及彼因彼灭一切类智品。若非想非非想处及类智品。非择灭并虚空。若谓一物。若谓多物。一切皆缘想受灭解脱无所缘。有作是说。空无边处解脱亦缘第四静虑非择灭。余所缘如前说。乃至非想非非想处解脱。亦缘无所有处非择灭。余所缘如前说。念住者。初三解脱身念住俱。四无色处解脱四念住俱。想受灭解脱若依自性相杂念住。应言非念住俱。若依所缘念住应言是法念住。智者初三解脱世俗智俱。前三无色处解脱六智俱。谓苦集灭道智类智世俗智。非想非非想解脱世俗智俱。想受灭解脱不与智俱。三摩地者。初三及后二解脱非三摩地俱。前三无色处解脱三三摩地俱。或非三摩地俱。根相应者。初二解脱喜舍根相应想受灭解脱非根相应。余五解脱皆舍根相应。三世者。皆通三世缘。三世者。初三解脱过去缘过去。现在缘现在。未来若生法缘未来。若不生法缘三世。四无色处解脱。缘三世及离世。想受灭解脱无所缘。善不善无记者。皆唯是善。缘善不善无记者。初三解脱缘三种。四无色处解脱唯缘善无记。想受灭解脱无所缘。三界系及不系者。初三解脱唯色界系。后二解脱唯无色界系。前三无色处解脱。有漏者。无色界系。无漏者。是不系。缘三界系及不系者。初三解脱唯缘欲界系。四无色处解脱缘无色界系及不系。想受灭解脱无所缘。学无学非学非无学者。初三及后二解脱。唯非学非无学。前三无色处解脱通三种缘。学无学非学非无学者。初三解脱唯缘非学非无学。四无色处解脱缘三种。想受灭解脱无所缘。见所断修所断非所断者。初三及后二解脱唯修所断。前三无色处解脱。有漏者。修所断。无漏者。非所断。缘见所断修所断非所断者。初三解脱唯缘修所断。四无色处解脱缘三种。想受灭解脱无所缘。缘名缘义者。初三解脱唯缘义。四无色处解脱。若谓无色界。亦有名者彼说通缘名义。若谓无色界。无名者彼说唯缘义想受灭解脱。无所缘缘自相续他相续非相续者。初解脱缘自他相续。第二第三解脱。有说。唯他相续。有说通缘自他相续。四无色处解脱缘三种。想受灭解脱无所缘。加行得离染得者。想受灭解脱唯加行得。余七解脱亦加行得。亦离染得。离染得者。初静虑地解脱离欲界染时得。乃至非想非非想处解脱。离无所有处染时得。彼后由加行现在前。加行得者由加行故得。亦由加行故现在前。声闻或由中加行。或由上加行。独觉由下加行。佛不由加行得及现前。曾得未曾得者。想受灭解脱唯未曾得。余七解脱通曾得未曾得。谓诸圣者及内法异生皆通曾得及未曾得。外法异生唯是曾得如是已说解脱总相。一一别相今应广说。有色观诸色是初解脱。有色者。谓有内各别色想未离未舍未除。观诸色者。谓为离舍除内各别色想。由胜解作意观外诸色。若青瘀若脓烂若膖胀若骨锁。是初解脱者。初谓名数次第在初。或入此定次第在初解脱。谓入此定时所有善色受想行识总名解脱。内无色想观外色是第二解脱。内无色想者。谓内各别色想已离已舍已除。观外色者。谓不为离舍除内各别色想。而由胜解作意观外诸色。若青瘀等广说如前。第二及解脱亦如前说。问为观外色时有内无色想。为观外色时无内无色想耶。设尔何失二俱有过。所以者何。若观外色时有内无色想者。云何一心不作二解。若作二解应有二。体一心二体与理相违。若观外色时无内无色想者。此中所说当云何通谓内无色想观外色是第二解脱。答应作是说。若观外色时无内无色想。问若尔。善通前所设难此中所说当云何通。答依观行者期心说故。谓观行者先作期心。我若于内无色想时应观外色。世尊依彼故作是说。内无色想观外色。复次依观行者先起分别修行说故。谓观行者先作如是分别修行。我若于内无色想时应观外色。故作是说。复次此中文句依义准说。谓若内无色想时义准必应观外诸色。若观外色时义准必应内无色想。复次此中文句兼加行善根说。内无色想者说加行善根。观外色者说究竟善根。复次内无色想者约所依说观外色者约所缘说。净解脱身作证具足住是第三解脱。问此净解脱为即有色观诸色。为即内无色想观外色耶。若即有色观诸色者。此与初解脱有何差别。若即内无色想观外色者。此与第二解脱有何差别。答应作是说。此净解脱即内无色想观外色。问若尔。此与第二解脱有何差别。答名即差别。谓彼名第二。此名第三。复次地亦有差别。谓彼在初二静虑。此在第四静虑。复次相续亦有差别。谓第二解脱通依内外道相续。净解脱唯依内道相续。复次第二解脱作不净行相。净解脱作净行相。复次第二解脱对治色贪。净解脱对治不净观。复次第二解脱少加行少功用得。净解脱多加行多功用得。复次第二解脱自性明净所缘不明净。自性胜妙所缘非胜妙。净解脱自性所缘。俱明净俱胜妙。是谓第二第三差别。问修观行者何故修此净解脱耶。答欲试善根满未满故。谓观行者作是念言。虽观不净相不起烦恼。而未知善根为成满不。若观净相烦恼不生。乃知善根已得成满故观净相修净解脱。复次修观行者观不净相心沈戚故善品不增。为令善品更增进故。复观净相修净解脱。如游冢间数观尸秽。心沈戚故善品不增。为令善品更增进故。观妙园林流泉池沼。或游城邑观诸妙事令心欣悦能修胜善。此亦应然故观净相。复次修观行者久观不净。心便乐着善品不增。为令善品得增进故。舍不净观修净解脱。复次修观行者欲显自心坚牢不退。谓缘净境烦恼不生况缘余境。故观净相修净解脱。复次修观行者显自善根有大势力。谓缘净境烦恼不生况缘余境。故观净相修净解脱。复次显净解脱非诸有情皆能修起。唯妙胜解乐净天殁。来生人中乃能修起。故修行者修净解脱。曾闻苾刍于日后分来诣佛所求好房舍佛敕阿难与好房舍。阿难受敕而授与之。彼苾刍言宜净扫洒。悬缯幡盖烧香散花。敷软床褥安置好枕。我乃受之不尔不用。阿难于是具以白佛。佛言随索皆应与之。尔时阿难具办授与。苾刍受已于夜初分起净解脱。因是次第起余解脱。诸漏永尽成阿罗汉复修加行引起神通。于晨朝时乘通而去。阿难于后往诣彼房不见苾刍。但见床座寻往白佛。佛告阿难汝勿轻彼。彼于昨夜起净解脱及余解脱成阿罗汉引起神通晨朝已去。然彼苾刍从妙胜解。乐净天殁来生人中。彼若不得净妙房舍便不能修第三解脱。乃至不得极果神通。由是故知此净解脱非诸有情皆能修起。唯乐净者乃能起之。第三与解脱亦如前说。四无色解脱如四无色说想受灭解脱如后根蕴当广分别。数及解脱准前应知问何故静虑少分善根立为解脱。无色地一切皆立解脱耶。答静虑粗显明了见见。故少善根立为解脱。无色细隐不明了不现见故根本地皆立解脱。复次静虑中有种种异相不相似法。故少善根立为解脱。无色不尔是故总立。复次静虑中有异相根受心心所法。故少善根立为解脱。无色不尔是故总立。复次静虑有多功德胜利。故少善根立为解脱。无色不尔是故总立。复次静虑遍缘自上下地。故少善根立为解脱。无色唯缘自上非下是故总立。复次静虑解脱唯是有漏故别建立。无色解脱亦通无漏是故总立。问因论生。论何故静虑解脱唯有漏。无色解脱通有漏无漏耶。答前说五门亦通。答此此中复有一不共。答谓静虑中所有解脱唯与胜解作意相应诸无色中所有解脱多与真实作意相应故不相似

问何故世尊于八解脱以方声说。答观所化故如于四谛说四方声。问解脱与方有何相似。答解脱与方俱有八故。问方乃有十如何相似。答如调象法唯依八方。非上下方是故相似。复次如人平面唯视八方。如是正心修八解脱。复次如依八方能调龙象。解脱亦尔。依八加行而现在前除解脱障。尊者妙音作如是说。方与解脱三同三异。言三同者。一如调象者要趣于方乃能调象。世尊亦尔。要趣解脱能调所化。二如调象者。于一时间唯趣一方而调一象。世尊亦尔。一时唯依一种解脱调一所化。三如调象者。令所调象趣一方时去余方远。世尊亦尔。令所化生起一解脱现在前时余解脱远不现行故。言三异者。一如调象者。要趣于方乃能调象。世尊不尔。端坐一处亦令所化能起解脱。二如调象者。于一时间唯趣一方而调一象。世尊不尔。于一时间令多所化起多解脱。三如调象者。令所调象趣一方时去余方远。世尊不尔。令所化生起一解脱现在前时余解脱近由成就故。复次佛欲自显是胜调御。故于解脱说以方声。曾闻憍萨罗主胜军大王。敕捕象人捕大野象。令调象者依调象法善调御之。象既调已王与象师共乘游猎。时所乘象见雌象群。欲心炽盛即便奔逐。象师尽术制不能回。王与象师俱被伤损。遇因攀树命济还宫。王责象师付法刑罚。时调象者白大王言。彼象实调愿王许验。时象贪息便速还宫。象师见之将诣王所。遂于象顶置热铁丸徐语之言。此是最后调伏汝法。应忍受之。若不忍受必以先来调汝苦事次第调汝。象闻便忍不动如山。时热铁丸烧然象顶。如烧桦皮王见嗟怪令去铁丸。告象师曰此象既调先何故尔。象师跪白。我能调身不能调心。王言颇有能调心者。象师曰有谓佛世尊。能调众生身心诸病。王闻欢喜寻与象师。乘所调象往诣佛所。见佛世尊多百千众围绕说法。前礼佛足退坐一面。佛即为王说甚深法。非诸独觉声闻所知。因告苾刍如调象者。正调象时于八方内但趣一方而调于象。调马牛等亦复如是。无上调御调所化时顿依八方而调所化言八方者喻八解脱。故显世尊是胜调御。于八解脱说以方声

说一切有部发智大毗婆沙论卷第八十四阿毗达磨大毗婆沙论卷第八十五

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中十门纳息第四之十五

如契经说。有一苾刍来诣佛所。顶礼佛足退坐一面。而白佛言。世尊。说有明界净界。空无边处界。识无边处界。无所有处界。非想非非想处界。灭界。如是七界缘何施设。世尊告曰。缘闇故施设明界。缘不净故施设净界。缘色趣故施设空无边处界。缘边际故施设识无边处界。缘所有故施设无所有处界。缘有身故施设非想非非想处界。缘有身灭故施设灭界。问此中苾刍依何事问。世尊复以何事而答。答此中苾刍依八解脱覆相而问。佛亦以此覆相而答。明界者。谓初二解脱。净界者。谓第三解脱。四无色处界者。谓四无色解脱。灭界者。谓想受灭解脱。问何故苾刍依八解脱覆相而问答。以彼苾刍少欲喜足覆藏己善。不欲令他知自有德故作此问。问何故世尊以八解脱覆相而答。答欲令苾刍意乐满故。谓彼苾刍作如是念。若佛为我覆相而答。八解脱者岂不善哉。由此世尊覆相而答。此中缘闇故施设明界者。闇谓欲界缘色处贪。初二解脱是彼对治故缘彼立。缘不净故施设净界者。不净谓初二解脱第三解脱。是彼对治故缘彼立。缘色趣故施设空无边处界者。色趣谓第四静虑第四解脱。是彼对治故缘彼立。缘边际故施设识无边处界者。边际谓空无边处。彼住色边际故。第五解脱是彼对治故缘彼立。缘所有故施设无所有处界者。所有谓识无边处彼有无边行相转故。第六解脱是彼对治故缘彼立。缘有身故施设非想非非想处界者。有身谓无所有处。此犹有生死身非全无所有故。第七解脱是彼对治故缘彼立。缘有身灭故施设灭界者。有身灭谓非想非非想处。以彼能灭无所有处有身法故。第八解脱是彼对治故缘彼立。有作是说。此中苾刍依略广离三界染覆相而问。世尊亦以此覆相而答。明界者。略显离欲界染加行道。此缘闇施设者。闇谓欲界缘五欲贪。色界加行是彼对治故缘彼立。净界者略显离欲界染。空无边处界者。略显离色界染。识无边无所有非想非非想处界者。广显离无色界染。灭界者略显离无色界染。此中有说。明界者略显离欲界染。唯未至定断欲闇故。净界者广显离色界染。以四静虑等皆名净故。空无边处界者。略显离色界染。后三无色处界者。广显离无色界染灭界者。略显离无色界染。欲界唯有一地染故。略显对治色无色界各有四地染故。广略显彼对治。譬喻者说。此中苾刍依八等至覆相而问。佛亦以此覆相而答。然此经文诵者增减。谓增减界而减广界。明界者。谓初二静虑此缘闇施设者。闇谓外缘诸盖。初二静虑是彼对治故缘彼立。净界者。谓第三静虑。广界者。谓第四静虑。四无色处界即四无色处

即此经说。时彼苾刍闻佛所说欢喜敬受。复白佛言。世尊。明界乃至灭界由何定得。佛告苾刍。如是诸界由自行余定得。苾刍闻已欢喜敬受礼佛而去。此中有说。彼问得界。复有说者。彼问得断

若问得界彼问意言。如是诸界由何定得彼体。佛答意言。明界乃至非想非非想处界。由自行定得。自行定者谓自近分。由自近分离下地染得自地解脱。谓由初静虑近分离欲界染得初二解脱。由第四静虑近分离第三静虑染得净解脱。由空无边处近分离第四静虑染得空无边处解脱。乃至由非想非非想处近分。离无所有处染得非想非非想处解脱。唯有灭界由余定得。余定者谓有所依定。即是非想非非想处。彼是诸有根本定故。或有说。此名有胜定。于诸有中此最胜故。或说此名想受灭定。是想受灭入出定故。由此定得第八解脱。若问得断彼问意言。如是诸界由何定得彼断。佛答意言。明界乃至无所有处界。由自行余定得。自行定者。谓自近分即有漏定。余定者谓诸无漏定。欲界乃至无所有处。皆由此二定离染得彼断。非想非非想。处界但由余定得。唯无漏定能离非想非非想处染得彼断。故灭界但由余得。余谓有身灭即是涅槃。般涅槃时舍灭尽定说名为断。由余涅槃而得彼断故说彼由余得

八胜处者。一内有色想观外色少。二内有色想观外色多。三内无色想观外色少。四内无色想观外色多。内无色想观外诸色青黄赤白。复为四种。如是八种名八胜处。问此八胜处自性是何。答无贪善根以为自性对治贪故。若兼取相应随转。则欲界者以四蕴为自性。色界者以五蕴为自性。如是名为胜处自性。我物自体相分本性。已说自性所以今当说。问何故名胜处。胜处是何义。答胜所缘境故名胜处。复次胜诸烦恼故名胜处。虽观行者非一切能胜所缘境。而于所缘不起烦恼亦名为胜。如契经说。于此处胜故名胜处。此八胜处界者皆是色界。地者前四胜处在初二静虑及未至定静虑中间。后四胜处在第四静虑。所依者皆依欲界身起。行相者一切皆非分明行相。所缘者皆缘欲界一切色处。问若尔经说当云何通。尊者无灭在室罗筏住一精舍。尔时有四悦意天女。来至尊者座前而立。白言。我等于四色处转变自在。随所爱色皆能化作。以相娱乐随心所玩。衣服严具皆能现之。愿垂纳受以充供侍。尊者无灭作是念言。我应缘彼起不净观。作是念已入初静虑。缘彼不能起不净想。乃至后入第四静虑缘亦不能起不净想。复作是念。此天女身有种种色惑乱人意。若彼纯作一种色者。我能于彼起不净观。念已语言姊等前说于四色处转变自在。愿能为我皆现青色。天女奉教即为现青。缘亦不能起不净想。复作是念。彼于四色转变自在。若作余色或能缘之起不净观。念已语言愿现黄色。天女即为皆现黄色。缘亦不能起不净想。复语天女皆现赤色。缘亦不能起不净想。复作是念。于诸色中白色最能顺不净观。我当令彼皆现白色。念已语言愿现白色。天女复为皆现白色。缘亦不能起不净想。尊者无灭作是念言。天色殊妙不可胜伏。于是闭目默然而坐。天知尊者都无染心。相顾既惭忽然不现。时尊者定不胜彼境。境亦不能胜尊者定。如二力士展转力齐不能相胜。此亦如是。此经所说当云何通。答尊者无灭于天色境虽不能胜。舍利子等利根胜定皆能胜之。问缘佛身色颇有能起不净观不。有说。不能。以佛身色光明赫曜清净无垢。无有能缘起不净想。有作是说。一切异生声闻独觉。皆不能缘诸佛身色起不净想。唯佛世尊于佛身色容有能缘起不净想。或有说者。不净观有二种。一观色过患。二观色缘起。观色过患者。不能缘佛起不净想。观色缘起者亦能缘佛起不净想。复有说者。不净观有二种。一于自相转。二于共相转。于自相转者。不能缘佛起不净想。于共相转者。亦能缘佛起不净想。问诸不净观为在意地为在五识。答在意地非五识。问若尔经说当云何通。如说眼见色已随观不净如理思惟。广说乃至身觉触已随观不净如理思惟。答由五识身方便引起诸不净观故作是说。如意近行实唯意地。五识引起此亦应尔。问诸不净观唯缘色处。但应说言眼见色已。随观不净如理思惟。何故亦言耳闻声已。广说乃至身觉触已如理思惟。答如不净观能伏色贪亦能伏余四境贪故。作如是说亦不违理。有作是说。眼见色已广说乃至身觉触已。一一皆能引起缘色不净观故作如是说。或有说者。非不净观缘声等起。别有殊胜不净行相。能缘声等不净相生。复有说者。诸瑜伽师。先缘色处修不净观。得成熟已后缘声等。起厌患想胜伏彼境。能伏者善。若不能伏复缘色处起不净观。如习斗战而活命者从木册出。与他斗战得胜者善。若不得胜还入木册。此亦如是故不相违。有余师说。此契经中不说缘色起不净观。但说于色等起厌患想。观此成满已乃至能厌心心所法。故彼经说意知法已。随观不净如理思惟。故不净言显厌患想非不净观。故八胜处唯以欲界一切色处为所缘境。念住者此八唯与身念住俱。智者一切唯与世俗智俱。三摩地者。一切不与三摩地俱。根相应者总说但与喜舍相应。三世者皆通三世。缘三世者。此八胜处过去缘过去。现在缘现在。未来若生法缘未来。若不生法缘三世。善不善无记者。皆唯是善缘善不善无记者皆缘三种。三界系及不系者皆唯色界系。缘三界系及不系者。皆唯缘欲界系。学无学非学非无学者。皆唯非学非无学。缘学无学非学非无学者。皆唯缘非学非无学。见所断修所断非所断者。皆唯修所断。缘见所断修所断非所断者。皆唯缘修所断。缘名缘义者。皆唯缘义。缘自相续他相续非相续者。初二缘自他相续。后六有说。唯缘他相续。有说。通缘自他相续。加行得离染得者。皆通二种。离染得者。在初静虑者离欲界染时得。在第二静虑者离初静虑染时得。在第四静虑者离第三静虑染时得。彼后由加行现在前加行得者由加行故得。亦由加行故现在前。声闻或由中加行。或由上加行。独觉由下加行。佛不由加行得及现前。曾得未曾得者。皆通曾得未曾得。谓诸圣者及内法异生皆通二种。外法异生唯是曾得如是已说胜处总相。一一别相今应广说。内有色想观外色少。若好若恶于彼诸色胜知胜见是初胜处。此中内有色想者。谓有内各别色想未离未舍未除。观外色者谓为离舍除各别内色想。由胜解作意观外诸色。少者谓二种少。一所缘少。二自在少。若好者。谓不弊坏青黄赤白色。若恶者。谓弊坏青黄赤白色。于彼诸色胜知胜见者。谓为调伏欲贪故。断坏欲贪故。超越欲贪故。于彼诸色起胜知见胜伏彼色。谓摄受彼及调伏彼。犹如大家及大家子摄受调伏自诸仆使。是故名为胜知胜见。是初胜处者。初谓名数次第在初。或入彼定次第在初胜处者。谓入彼定时所有善色。受想行识总名胜处。如初胜处应知第二胜处亦尔。有差别者。谓此第二观外色多。多有二种一所缘多。二自在多。余如前说。内无色想观外色少。若好若恶于彼诸色胜知胜见。是第三胜处。此中内无色想者。谓内各别色想已离已舍已除。观外色者。谓不为离舍除内各别色相。而由胜解作意观外诸色。余如前说。如第三胜处应知第四胜处亦尔。有差别者。谓第四胜处观外色多。内无色想。观外色青青显青现青光无量。无量净妙可喜可乐不可违逆。如坞莫迦花。或婆罗痆斯染青衣色。于彼诸色胜知胜见有如是想。是第五胜处。此中内无色想外观色义如前说。青者谓诸青色。若大若小总说为青。青显者。谓彼青色眼所照了眼所行境故名青显。青现者。谓彼青色如为眼识所了别已。引生意识亦分别之故名青现。青光者。谓彼青色光明照曜故名青光。无量者。谓彼青色广无边际故名无量。无量净妙者。谓如青色广无边际。彼净妙相亦无边际。是故名为无量净妙。可喜者。谓彼青色可欣可悦令意悦豫故名可喜。可乐者。谓彼青色可爱可玩。若缘于此不复希余故名可乐。不可违逆者谓彼青色令心堪忍随顺趣向。是故名为不可违逆。如坞莫迦花或婆罗痆斯染青衣色者。谓彼极青故引为喻。于彼诸色胜知胜见。义如前说。有如是想者。谓于彼青色有如前说。青想现前是第五胜处。义亦如前。如说青胜处说黄赤白胜处应知亦尔。有差别者黄胜处应说如羯尼迦罗花。赤胜处应说如槃度时缚迦花。白胜处应说如坞杀私星婆罗痆斯。黄赤白衣随类应说。问四显色中何者最胜。尊者世友作如是说白色最胜世共说此是吉祥故。如四方中东方最胜。是吉祥故白色亦尔。大德说曰。缘白色时令心明净。以不随顺惛沉睡眠。能任持身故最为胜

十遍处者。谓青黄赤白地水火风空无边处识无边处遍处。问此十遍处自性是何。答前八遍处以无贪善根为自性对治贪故。若兼取相应随转。即欲界者以四蕴为自性。色界者以五蕴为自性。后二遍处俱以四蕴为自性。如是名为遍处自性。我物自体相分本性。已说自性所以今当说。问何故名遍处。遍处是何义。答由二缘故名为遍处。一由无间。二由广大。由无间者。谓纯青等胜解作意不相间杂故名无间。由广大者。谓缘青等胜解作意。境相无边故名广大。大德说曰。所缘宽广无有间隙故名遍处

此十遍处界者。前八遍处是色界。后二遍处是无色界。地者前八遍处在第四静虑。第九遍处在空无边处。第十遍处在识无边处。所以者何。以净解脱在第四静虑。由此能入后四胜处。此后四胜处复能入前八遍处。此中解脱唯于所缘总取净相。未能分别青黄赤白。后四胜处虽能分别青黄赤白。而未能作无边行相。前四遍处非唯分别青黄赤白。而亦能作无边行相。谓观青等一一无边。复思青等为何所依。知依大种故。次观地等一一无边。复思此所觉色由何广大知由虚空故。次起空无边处复思此能觉谁为所依。知依广识故。次复起识无边处。此所依识无别所依。故更不立上为遍处。所依者前八遍处唯依欲界身起。后二遍处通依三界身起。行相者。此十皆作无边行相。所缘者。前八遍处唯缘欲界色处。后二遍处各缘自地四蕴。念住者。前八遍处身念住俱。后二遍处法念住俱。智者一切皆与世俗智俱三摩地者一切不与三摩地俱。根相应者。一切唯与舍根相应。三世者。皆通三世。缘三世者。前八遍处过去缘过去。现在缘现在未来若生法缘未来。若不生法缘三世。后二遍处俱缘三世。善不善无记者。皆唯善缘善不善无记者。前八遍处缘三种。后二遍处缘善无记。三界系及不系者。前八遍处唯色界系。后二遍处唯无色界系。缘三界系及不系者。前八遍处唯缘欲界系。后二遍处唯缘无色界系。学无学非学非无学者。皆唯非学非无学。缘学无学非学非无学者。皆唯缘非学非无学。见所断修所断非所断者。皆唯修所断。缘见所断修所断非所断者。前八遍处唯缘修所断。后二遍处缘见修所断。缘名缘义者。皆缘义。缘自相续他相续非相续者。前八遍处。有说。唯缘他相续。有说通缘自他相续。后二遍处俱缘自他相续。加行得离染得者。皆通加行得及离染得。离染得者。前八遍处离第三静虑染时得。第九遍处离第四静虑染时得。第十遍处离空无边处染时得。彼后由加行现在前。加行得者由加行故得。亦由加行故现在前。声闻或由中加行。或由上加行。独觉由下加行。佛不由加行得及现前。曾得未曾得者。皆通曾得未曾得。谓诸圣者及内法异生通曾得未曾得。外法异生唯是曾得

问此十遍处加行云何。答前四遍处以眼识为加行。至成满时缘青黄赤白四色处为境。中四遍处以身识为加行。至成满时缘地水火风四触处为境。有作是说。前七遍处以眼识为加行。中一遍处以身识为加行。所以者何。地水火遍处。以形显色为所缘故。风遍处以动性触为所缘故。复有说者。前八遍处皆以眼识为加行。所以者何。风遍处亦以色为所缘故。如世间说。东风南风西风北风。有尘风无尘风。毗隰缚风。吠岚婆风。风轮风等。故风遍处亦缘色处。空无边处以空为加行。识无边处以识为加行

如是已说遍处总相。一一别相今应略说。于一切青若上若下若傍。无二无量。起一青想是初遍处。一切青者。谓诸青色若小若大总名为青。上者谓上方。下者谓下方。傍者谓四方四维无二者。谓纯青相无余间杂。无量者。谓无边际。起一青想者。谓由胜解作意于一切处起一青想。是初遍处者。初谓名数次第在初。或入此定次第在初遍处。谓入此定时所有善色受想行识总名遍处。如青遍处广说。乃至识无边处遍处亦尔。有差别者。后二遍处不应说色。唯应说受想行识蕴。问前八遍处可有上下。彼所缘境有方处故。后二遍处缘空缘识。所缘既无方处上下。云何可说有上下耶。答后二遍处所缘虽无上下方所。而所依定有三品。故可说上下。上谓依上品定。下谓依下品定。复言傍者依中品定。复次修观行者。身所居处有上下故可言上下傍。谓处等其事云何下者住人中。中者住四大王众天。上者住三十三天。如是乃至他化自在展转相望为下中上。上者名上。下者名下。中者名傍

问何故第三静虑无解脱胜处遍处耶。答非田器故乃至广说。复次对治欲界初静虑中。识身所引缘色贪故。初二静虑立缘不净解脱胜处。第二第三静虑无识身所引缘色贪故。第三第四静虑。不立缘色不净解脱胜处。前三静虑有寻伺喜乐。及入出息扰乱事故无净解脱。后四胜处前八遍处缘净妙境能伏烦恼其事甚难。是故必依无扰乱地乃得成就。复次第三静虑去欲界远。于静虑中又非最胜。故无解脱胜处遍处复次第三静虑如第三无色。无多功德故无解脱等。谓空识无边处有无边行相功德。非想非非想处有灭定功德。无所有处无无边行相。又无灭定。是故此地功德减少第三静虑如彼亦无解脱胜处遍处功德。复次第三静虑有生死中最胜受乐。能令行者耽着迷乱故无解脱胜处遍处。问若尔应无无量通等诸余功德。答言功德少不说全无。若此地中无无量等应此静虑空无功德。复次无量总缘通慧游戏此地。得有解脱胜处遍处功德。别缘色等伏诸烦恼以难成故此地中无

如契经说。得地遍处定者。作如是念。地即是我我即是地。地之与我无二无别。得余遍处定者。随自所缘广说亦尔。问得遍处定者。必已离第三静虑染。彼所起我见必是第四静虑。若第四静虑我见。必唯缘第四静虑地等前八遍处。但缘欲界色处为境。如何可说与彼我见同缘地等。有作是说。此中于未得彼定者说得彼定者声。如非沙门说名沙门。非婆罗门说名婆罗门。谓以欲界闻思所成初学修习地等遍处。犹未能断欲界烦恼。未得根本地等遍处。故缘地等容起我见。或有说者。仍旧名说亦不相违。如有国王。虽失王位。仍旧名说亦呼为王。如是先得地遍处等。今虽退失仍名得者。彼起欲界我见。缘欲界地等计我于理无违。复有说者。依速入出遍处我见。作如是说亦不相违。谓彼先得地遍处等。后速退起欲界我见。缘执欲界地等为我。速复还得第四静虑地遍处等彼缘欲界地等为境。如提婆达多先得静虑。以神境通力变作小儿。着金缕俗衣作五花顶。在未生怨太子膝上婉转而戏。仍令太子知是尊者提婆达多。时未生怨怜爱抱弄。呜而复以唾置口中。提婆达多贪利养故遂咽其唾。故佛诃曰。汝是死尸食人唾者。彼咽唾时便退静虑。速复还得令所变身在太子膝如故而戏。遍处我见应知亦尔。有余师说。此中有身见执第四静虑地等为我。前八遍处亦缘第四静虑地等。问岂不前八遍处缘欲界色耶。答亦缘欲界色亦缘第四静虑色。问色界诸天纯一白色。云何缘彼作青等耶。答色界有情纯一白色。彼非情数亦有青等。评曰。彼不应作是说。若有身见与八遍处相应俱有。可设难言如何相应俱有法。或缘第四静虑或缘欲界。然有身见前八遍处非相应非俱有不应为难。而一有情名计我者亦名得定者。以有身见故名计我者。以遍处故名得定者。有身见执第四静虑地等为我。前八遍处缘欲界色非俱时故善通此经。此有身见与八遍处所依身同所缘境异

如契经说。有地等定有地等遍处。问此地等定与地等遍处有何差别。答地等定在欲界四静虑地等遍处唯在第四静虑。复次加行时名地等定。成满时名地等遍处。复次因时名地等定。果时名地等遍处。复次若作少分解时名地等定。若作周遍解时名地等遍处。是谓差别

问解脱胜处遍处有何差别。答名即差别谓此名解脱此名胜处此名遍处。复次下品善根名解脱。中品善根名胜处。上品善根名遍处。复次小善根名解脱。大善根名胜处。无量善根名遍处。复次唯因名解脱。唯果名遍处。通因果名胜处。复次能有弃背名解脱。能胜伏境名胜处。能广所缘名遍处。复次唯作胜解名解脱。能伏烦恼名胜处。于所缘境无二无量名遍处。复次若得解脱未必已得胜处遍处。若得胜处必已得解脱。未必已得遍处。若得遍处必已得解脱及胜处。所以者何。从解脱入胜处。从胜处入遍处。故是谓解脱胜处遍处差别

此中八智三三摩地。三重三摩地。如后智蕴当广分别。三结乃至九十八随眠。如此蕴初已广分别

说一切有部发智大毗婆沙论卷第八十五阿毗达磨大毗婆沙论卷第八十六

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中十门纳息第四之十六

眼根。乃至无色界修所断无明随眠。于九十八随眠中。一一有几随眠随增耶。问何故作此论。答为依前章显门义故。谓依前说四十二章显随眠等十种门义。复次为止他宗显正理故。谓或有执。无学身中眼根等法亦是无漏。为遮彼执显眼根等唯是有漏是诸随眠所随增故。或复有执。烦恼颠倒无实所缘。为遮彼执显诸烦恼有实所缘。或复有执。无有所缘相应缚义。若于所缘有缚义者。缘无漏法应有缚义。若于相应有缚义者。彼得断已亦应有缚。为遮彼执显有所缘相应缚义。所缘缚者。唯于有漏随眠缘彼必随增故。虽缘无漏而不随增故无缚义。相应缚者。要彼相应烦恼未断。烦恼断已虽有相应而无缚义。复次为遮有缚而于自身起增上慢谓已解脱。谓彼暂时伏诸烦恼。而称自身已得解脱。欲令彼知于自眼等犹有贪等随眠随增。复次为广分别契经义故。谓契经中说眼根等有诸贪等随眠随增虽有此言不广分别。今欲分别故作斯论

应知此中有五部法。即为五部随眠随增。五部法者。谓见苦所断法乃至修所断法。五部随眠应知亦尔。此中见苦所断法为见苦所断一切随眠。及见集所断遍行随眠之所随增。见集所断法为见集所断一切随眠。及见苦所断遍行随眠之所随增。见灭所断法为见灭所断一切随眠。及遍行随眠之所随增。见道所断法为见道所断一切随眠。及遍行随眠之所随增。修所断法为修所断一切随眠。及遍行随眠之所随增。复次有十种法。复为九种随眠随增。十种法者。谓见苦集灭道所断各有二种法。一相应。二不相应。修所断亦有二种法。一染污。二不染污。九种随眠者。谓见苦集所断随眠各有二种。一遍行。二不遍行。见灭道所断随眠各有二种。一有漏缘。二无漏缘。及修所断随眠。总为九种。此中见苦所断相应法。为见苦所断一切随眠及见集所断遍行随眠之所随增。自部者。随其所应有所缘相应缚。他部者。唯有所缘缚。见苦所断不相应法。为见苦所断一切随眠。及见集所断遍行随眠之所随增。皆唯有所缘缚。见集所断相应法为见集所断一切随眠。及见苦所断遍行随眠之所随增。自部者。随其所应有所缘相应缚。他部者。唯有所缘缚。见集所断不相应法。为见集所断一切随眠。及见苦所断遍行随眠之所随增皆唯有所缘缚。见灭所断相应法。为见灭所断一切随眠。及遍行随眠之所随增。自部有漏缘者。随其所应有所缘相应缚。无漏缘者。唯有相应缚。他部者。唯有所缘缚。见灭所断不相应法。为见灭所断有漏缘随眠。及遍行随眠之所随增。皆唯有所缘缚。见道所断相应法。为见道所断一切随眠。及遍行随眠之所随增。自部有漏缘者。随其所应有所缘相应缚。无漏缘者。唯有相应缚。他部者。唯有所缘缚。见道所断不相应法。为见道所断有漏缘随眠。及遍行随眠之所随增。皆唯有所缘缚。修所断染污法。为修所断一切随眠。及遍行随眠之所随增。自部者随其所应有所缘相应缚。他部者唯有所缘缚。修所断不染污法。为修所断一切随眠。及遍行随眠之所随增。皆唯有所缘缚。应知此中见苦所断遍行随眠。于见苦所断遍行随眠相应法。随其所应为所缘相应缚。于余自地自部他部诸有漏法。但为所缘缚。见苦所断不遍行随眠。于见苦所断不遍行随眠相应法。随其所应为所缘相应缚。于余自地自部他部诸有漏法。但为所缘缚。见集所断遍行随眠。于见集所断遍行随眠相应法。随其所应为所缘相应缚。于余自地自部他部诸有漏法但为所缘缚。见集所断不遍行随眠。于见集所断不遍行随眠相应法。随其所应为所缘相应缚。于余自地自部诸有漏法。但为所缘缚。见灭所断有漏缘随眠。于见灭所断有漏缘随眠相应法。随其所应为所缘相应缚。于余自地自部诸有漏法。但为所缘缚。见灭所断无漏缘随眠。于见灭所断无漏缘随眠相应法。随其所应但为相应缚。见道所断有漏缘随眠。于见道所断有漏缘随眠相应法。随其所应有所缘相应缚。于余自地自部诸有漏法。但为所缘缚见道所断无漏缘随眠。于见道所断无漏缘随眠相应法。但为相应缚。修所断随眠。于修所断随眠相应法。随其所应为所缘相应缚。于余自地自部诸有漏法。但为所缘缚

复次有四十一种法。复为三十六种随眠随增。四十一种法者。谓见苦所断有十一法。即十随眠。相应法。并不相应。法为十一。见集所断有八法。即七随眠相应法。并不相应法为八。见灭所断亦尔。见道所断有九法。即八随眠相应法。并不相应法为九。修所断有五法。即四随眠相应法。并不相应法为五。三十六种随眠者。谓见苦所断有十。见集灭所断各七。见道所断有八。修所断有四。唯依部说不依界故。此中有身见相应法。为有身见及彼相应无明随眠之所随增。随其所应为所缘相应缚。此即总说若别说者。若于彼为所缘缚。即于彼非相应缚。若于彼为相应缚。即于彼非所缘缚。余应准此。此复为余见苦所断一切随眠。及见集所断遍行随眠之所随增。但为所缘缚。如有身见相应法。边执见。及见苦所断邪见。乃至慢相应法随应亦尔。见苦所断不共无明相应法。为见苦所断不共无明随眠之所随增。随其所应为所缘相应缚。此复为余见苦所断一切随眠。及见集所断遍行随眠之所随增。但为所缘缚。见苦所断不相应法。为见苦所断一切随眠。及见集所断遍行随眠之所随增。但为所缘缚。如见苦所断十一法。见集所断八法随应亦尔。见灭所断邪见相应法。为见灭所断邪见。及彼相应无明随眠之所随增。但为相应缚。此复为余见灭所断有漏缘随眠。及遍行随眠之所随增。但为所缘缚。如见灭所断邪见相应法。见灭所断疑相应法随应亦尔。见灭所断见取相应法。为见灭所断见取。及彼相应无明随眠之所随增。随其所应为所缘相应缚。此复为余见灭所断有漏缘随眠。及遍行随眠之所随增但为所缘缚。如见灭所断见取相应法。见灭所断贪嗔慢相应法随应亦尔。见灭所断不共无明相应法。为见灭所断不共无明随眠之所。随增但为相应缚。此复为余见灭所断有漏缘随眠。及遍行随眠之所随增。但为所缘缚。见灭所断不相应法。为见灭所断有漏缘随眠。及遍行随眠之所随增。但为所缘缚。如见灭所断八法。见道所断九法。随应亦尔。修所断贪相应法。为修所断贪及彼相应无明随眠之所随增。随其所应为所缘相应缚。此复为余修所断随眠。及遍行随眠之所随增。但为所缘缚。如修所断贪相应法。修所断嗔慢相应法。随应亦尔。修所断不共无明相应法。为修所断不共无明随眠之所随增。随其所应为所缘相应缚。此复为余修所断随眠。及遍行随眠之所随增。但为所缘缚。修所断不相应法。为修所断一切随眠。及遍行随眠之所随增。但为所缘缚。若说摄法应依十八界。若说诸识应依十二处。若说诸智应依四圣谛。若说诸随眠应依五部。今说随眠故。依五部分别随眠随增差别

眼根欲色界遍行。及修所断随眠随增者。眼根通欲色界唯修所断故。有尔所随眠随增。然此眼根通在五地。谓欲界四静虑。此五各为自地遍行。及修所断随眠随增。耳鼻舌身根亦尔者。亦通欲色界五地。唯修所断如眼根故。女根欲界遍行。及修所断随眠随增者。女根唯欲界修所断故。有尔所随眠随增。男苦根亦尔者。亦唯欲界修所断如女根故。命根三界遍行。及修所断随眠随增者。命根通三界唯修所断故。有尔所随眠随增然此命根通在九地。谓欲界四静虑四无色。此九各为自地遍行。及修所断随眠随增。信等五根亦尔者。信等五根通有漏无漏。有漏者亦通三界九地。唯修所断如命根故。无漏者非随眠随增。意根一切随眠随增者。意根通有漏无漏。有漏者通三界五部故。有尔所随眠随增。然此意根在九地。谓欲界四静虑四无色。此九各为自地一切随眠随增。无漏者非随眠随增。舍根亦尔者。亦通有漏无漏。有漏者亦通三界九地五部如意根故。乐根色界一切欲界遍行。及修所断随眠随增者。乐根通欲色界唯三地有。谓欲界初及第三静虑。欲界者在五识。初静虑者在三识。此二俱唯修所断故。一一各为自地遍行。及修所断随眠随增。第三静虑者在意识通有漏无漏。有漏者通五部及通一切随眠相应故。自地一切随眠随增。无漏者非随眠随增。喜根色界一切欲界。除无漏缘疑及彼相应无明。余一切随眠随增者。喜根通欲色界唯三地有。谓欲界初二静虑。欲界者通五部。不与嗔疑随眠相应。由喜根欢行相转。嗔疑戚行相转。欢戚相违不相应故。欲界喜根除见灭道所断疑及彼相应无明。为余一切欲界随眠随增。见灭道所断疑及彼相应无明。于喜根非所缘缚缘无漏故。非相应縳不相应故。余疑及嗔虽不相应。而于喜根有缘缚义。故说喜根欲界除无漏缘疑。及彼相应无明。余一切随眠随增。初二静虑喜根俱通有漏无漏。有漏者俱通五部及通一切随眠相应。定地疑亦与喜乐相应故。各自地一切随眠随增故。说喜根色界一切随眠随增。无漏者非随眠随增忧根欲界一切随眠随增者。忧根唯欲界通五部。及一分随眠相应故。有尔所随眠随增。三无漏根无随眠随增者。一切无漏法非诸随眠随增事故。所以者何。若法是有身见事。是颠倒事。是随眠事。是贪嗔痴所安足处。有垢有秽有浊者。为诸随眠之所随增。无漏法不尔。故非随眠之所随增。复次若处有爱是处即为随眠随增。如湿腻处尘秽易着。无漏法不尔。故非随眠之所随增。复次若法有身见执为我我所。是处即为随眠随增。无漏法不尔。复次若法是随眠所缘事。及随增事者。即为随眠之所随增。无漏法虽是随眠所缘事而非随增事故。非随眠之所随增。复次若法是随眠所缘处。亦是随增处者。即为随眠之所随增。无漏法虽是随眠所缘处。而非随增处故非随眠之所随增。胁尊者曰。无漏滑净非诸随眠能安其足。是故不为随眠随增。如吠琉璃极滑净者。蚊虻蝇等不能安足。大德说曰。无漏焰热非诸随眠能安其足。是故不为随眠随增。如焰热地不可安足。尊者妙音作如是说。无漏威猛随眠缘彼而不随增。如栴茶罗子观威猛王面心极战怯。尊者世友作如是说。缘有漏法起随眠时随眠渐增。如人观月眼根增长。故有漏法随眠随增。缘无漏法起随眠时随眠渐减。如人观日眼根损减。故无漏法不为随眠之所随增

眼耳鼻舌身色声触眼耳身识界。欲色界遍行及修所断随眠随增者。此十一界通欲色界。唯修所断故有尔所随眠随增此依界说。然地有异。谓眼等八通在五地故。为五地遍行及修所断随眠随增。眼耳身识唯在二地。谓欲界初静虑故唯二地遍行。及修所断随眠随增。眼耳鼻舌身色声触处色蕴色取蕴。前五界有色有见有对法亦尔者。如是诸法亦通欲色界五地。唯修所断如眼界等故。香味鼻舌识界欲界遍行。及修所断随眠随增者。如是四界唯欲界修所断故。有尔所随眠随增。香味处亦尔者。亦唯欲界修所断如香界等故。意法意识界一切随眠随增者。如是三界皆通有漏无漏。有漏者通三界九地五部。及通一切随眠相应故。为一切随眠随增。无漏者非随眠随增。意法处后四蕴后四取蕴识界。无色无见无对。有漏有为法过去未来现在。非学非无学法亦尔者。此诸法中有唯有漏。有通有漏无漏。诸有漏者皆通三界九地五部。及通一切随眠相应故。为一切随眠随增。无漏者非随眠随增。无漏无为法无随眠随增。学无学无断法亦尔者。皆无漏故义如前说。善及修所断法三界遍行及修所断随眠随增者。此中善法通有漏无漏。修所断法唯有漏。诸有漏者皆通三界九地。唯修所断故。有尔所随眠随增。无漏者非随眠随增。不善及欲界系法。欲界一切随眠随增者。如是二法唯欲界通五部故。有尔所随眠随增。无记法色无色界一切欲界二部。及见集所断遍行随眠随增者。无记法。谓色无色界诸染污法。及无覆无记法。欲界有身见边执见品诸染污法。及无覆无记法。并虚空非择灭。若色无色界无记法。通二界八地五部故。为色无色界一切随眠随增。若欲界无记法染污者。唯见苦所断故。为欲界见苦所断一切。及见集所断遍行随眠随增。不染污者唯修所断故。为欲界修所断一切。及遍行随眠随增。虚空非择灭非随眠随增。色界系法色界一切随眠随增者。此唯色界通四地五部故。有尔所随眠随增。无色界系法。无色界一切随眠随增者。此唯无色界通四地五部故。有尔所随眠随增。见所断法见所断一切随眠随增者。此通三界九地及前四部故。有尔所随眠随增。修所断随眠。不能缘见所断法故。非修所断随眠随增

苦集谛一切随眠随增者。苦集二谛总摄三界九地五部诸有漏法故。为一切随眠随增。灭道谛无随眠随增。法类苦集灭道智三三摩地亦尔者。皆无漏故一切不为随眠随增。三三摩地唯无漏者。此中唯说三解脱门所摄定故。四静虑色界一切随眠随增者。此四静虑通有漏无漏。有漏者唯色界通五部通染污不染污。若定若生皆是此四静虑所摄。是故总为色界一切随眠随增。无漏者非随眠随增。四无量色界遍行。及修所断随眠随增者。此中唯说成满无量唯在色界。然喜无量唯在初二静虑。余三无量通在四静虑皆唯修所断。是故总说色界遍行及修所断随眠随增。前三解脱八胜处。前八遍处他心智亦尔者。此中亦说成满解脱胜处遍处故。唯色界修所断摄。依地差别如前应知。他心智通有漏无漏。有漏者唯在色界通四静虑唯修所断故。此及前三种有漏如无量说。四无色无色界一切随眠随增者。四无色中前三通有漏无漏。第四唯有漏。诸有漏者唯无色界通五部通染污不染污。若定若生皆是此四无色所摄。是故总为无色界一切随眠随增。无漏者非随眠随增。后五解脱后二遍处。无色界遍行及修所断随眠随增者。此中有漏者随地差别。皆唯无色界唯修所断故。有尔所随眠随增。无漏者非随眠随增。世俗智除无漏缘见。余一切随眠随增者。此世俗智通三界九地五部。染污不染污一切有漏慧故。有尔所随眠随增。除无漏缘见者。谓除见灭道所断邪见。彼于世俗智非所缘缚。缘无漏故非相应缚。自性与自性不相应故。邪见即是世俗智故。然诸随眠于世俗智所缘相应二缚。差别应作四句。或有随眠于世俗智。为所缘缚非相应缚。谓有漏缘见。或有随眠于世俗智。为相应缚非所缘缚。谓除无漏缘见。诸余无漏缘随眠。或有随眠于世俗智。为所缘缚亦相应缚。谓除有漏缘见。诸余有漏缘随眠。此即总说。若别说者。若于彼为所缘缚。即于彼非相应缚。若于彼为相应缚。即于彼非所缘缚。或有随眠于世俗智。非所缘缚亦非相应缚。谓无漏缘见于此义中。雾尊者说四句有异。或有随眠于世俗智。为所缘缚非相应缚。谓自地缘世俗智见随眠未断。或有随眠为世俗智。为相应缚非所缘缚。谓除自地他界缘。或他地缘。或自界他界缘。或自地余法缘。或无漏缘见随眠。诸余自地他界缘。或他地缘或自界他界缘。或自地余法缘。或无漏缘随眠未断。或有随眠于世俗智。为所缘缚亦相应缚。谓除自地缘世俗智见随眠。诸余自地缘世俗智随眠未断。此即总说。若别说者。若于彼为所缘缚。即于彼非相应缚若于彼为相应缚。即于彼非所缘缚。或有随眠于世俗智。非所缘缚亦非相应缚。谓一切他地随眠。及自地随眠已断。设未断者。而是他界缘。或他地缘或自界他界缘。或自地余法缘。或无漏缘见随眠。三重三摩地三界遍行。及修所断随眠随增者。重三摩地通三界九地。唯修所断故。有尔所随眠随增

有身见结。见苦所断一切。及见集所断遍行随眠随增者。谓三结中有身见结。通三界九地唯见苦所断故。有尔所随眠随增。有身见顺下分结。有身见边执见亦尔者。谓五顺下分结中。有身见及五见中有身见边执见。亦通三界九地唯见苦所断。如三结中有身见故。戒禁取结见苦所断一切。及见集所断遍行。见道所断有漏缘随眠随增者。谓三结中戒禁取结。通三界九地唯见苦道所断。唯有漏缘故有尔所随眠随增。见道所断无漏缘随眠于戒禁取。非所缘缚缘无漏故。非相应缚不相应故。戒禁取及戒禁取身系。顺下分结戒禁取亦尔者。谓四取中戒禁取。四身系中戒禁取。五顺下分结中戒禁取。五见中戒禁取。亦通三界九地唯见苦道所断。唯有漏缘如三结中戒禁取故。疑结见所断有漏缘。及疑相应无漏缘无明随眠随增者。谓三结中疑结通三界九地。前四部通有漏无漏缘故。有尔所随眠随增。见所断有漏缘者。谓见苦集所断一切及见灭道所断有漏缘随眠。见灭道所断无漏缘随眠。于疑结。非所缘缚缘无漏故。非相应缚或异聚故。或自性与自性不相应故。疑顺下分结疑随眠疑。结亦尔者。谓五顺下分结中疑结。七随眠中疑随眠。九结中疑结。亦通三界九地。前四部有漏无漏缘。如三结中疑结故。贪嗔不善根欲界有漏缘随眠随增者。谓三不善根中贪嗔。唯欲界通五部。唯有漏缘故有尔所随眠随增。无漏缘随眠于贪嗔。非所缘缚缘无漏故。非相应缚异聚故。余准应知。前二身系前二盖嗔结前二顺下分结前二随眠。恚结亦尔者。谓四身系中贪嗔。五盖中贪嗔。五结中嗔结。五顺下分结中贪嗔。七随眠中欲贪嗔恚。九结中恚结。亦唯欲界通五部唯有漏缘。如贪嗔不善根故。痴不善根欲界除无漏缘无明。余一切随眠随增者。谓三不善根中。痴唯欲界通五部有漏无漏缘故。有尔所随眠随增。除无漏缘无明者。见灭道所断无漏缘相应不共无明。于痴不善根。非所缘缚缘无漏故。非相应缚自性与自性不相应故。欲漏欲界一切随眠随增者。谓三漏中欲漏唯欲界通五部。有漏无漏缘故。有尔所随眠随增。欲暴流轭取惛沉睡眠掉举盖亦尔者。谓四暴流中欲暴流。四轭中欲轭。四取中欲取。五盖中惛沉睡眠掉举盖。亦唯欲界通五部。有漏无漏缘如欲漏故。有漏色无色界一切随眠随增者。谓三漏中有漏通色无色界八地五部。有漏无漏缘故。有尔所随眠随增。有暴流轭我语取亦尔者。谓四暴流中有暴流。四轭中有轭。四取中我语取。亦通色无色界八地五部。有漏无漏缘如有漏故。无明漏除无漏缘无明。余一切随眠随增者。谓三漏中无明漏通三界九地五部。有漏无漏缘故。有尔所随眠随增。除无漏缘无明者。彼于无明漏。非所缘缚缘无漏故。非相应缚自性与自性不相应故。无明暴流轭无明随眠无明结亦尔者。谓四暴流中无明暴流。四轭中无明轭。七随眠中无明随眠。九结中无明结。亦通三界九地五部。有漏无漏缘如无明漏故。见暴流轭。见所断有漏缘。及见相应无漏缘。无明随眠随增者谓四暴流中见暴流。四轭中见轭通三界九地前四部。有漏无漏缘故。有尔所随眠随增。除无漏缘邪见疑。及彼疑相应无明。并无漏缘不共无明。以彼于见暴流轭。非所缘缚缘无漏故。非相应缚自性与自性不相应故。或他聚故。见取邪见见随眠见结亦尔者。谓四取中见取。五见中邪见。七随眠中见随眠。九结中见结。亦通三界九地前四部。有漏无漏缘。如见暴流轭故。此实执身系。见所断有漏缘随眠随增者。谓四身系中此实执身系。通三界九地前四部。唯有漏缘故。有尔所随眠随增。见取取结亦尔者。谓五见中见取。九结中取结。亦通三界九地前四部。唯有漏缘。如此实执身系故。恶作盖欲界遍行及修所断随眠随增者。谓五盖中恶作盖唯欲界修所断故。有尔所随眠随增。嫉悭结鼻舌触所生爱身嫉悭结亦尔者。谓五结中嫉悭结。六爱身中鼻舌触所生爱身。九结中嫉悭结。亦唯欲界修所断如恶作盖故。疑盖欲界见所断有漏缘。及疑相应无漏缘无明随眠随增者。谓五盖中疑盖。唯欲界通前四部。有漏无漏缘故。有尔所随眠随增。除欲界无漏缘疑邪见。及彼邪见相应无明。并无漏缘不共无明。以彼于疑盖。非所缘缚缘无漏故。非相应缚自性与自性不相应故。或他聚故。贪慢结三界有漏缘随眠随增者。谓五结中贪慢结。通三界九地五部。唯有漏缘故。有尔所随眠随增。意触所生爱身慢随眠。爱慢结亦尔者。谓六爱身中意触所生爱身。七随眠中慢随眠。九结中爱慢结。亦通三界九地五部。唯有漏缘。如五结中贪慢结故。色贪色界遍行。及修所断随眠随增者。谓五顺上分结中色贪。唯色界四地修所断。不还者身中现行故。有尔所随眠随增。异生位中色界遍行已于彼贪有所缘缚故。无色贪无色界遍行。及修所断随眠随增者。谓五顺上分结中无色贪。唯无色界四地修所断。不还者身中现行故。有尔所随眠随增。余如前说。后三顺上分结色无色界遍行。及修所断随眠随增者。谓五顺上分结中掉举慢无明。通色无色界八地唯修所断。不还者身中现行故。有尔所随眠随增。余如前说。眼耳身触所生爱身。欲色界遍行。及修所断随眠随增者。谓六爱身中眼耳身触所生爱身。通欲界初静虑唯修所断故。有尔所随眠随增。有贪随眠色无色界。有漏缘随眠随增者。谓七随眠中有贪随眠。通色无色界八地五部。唯有漏缘故。有尔所随眠随增

欲界见苦所断随眠。欲界见苦所断一切。及见集所断遍行随眠随增者。谓九十八随眠中欲界见苦所断十随眠。一一皆为欲界见苦所断一切随眠。及见集所断遍行随眠随增。欲界见集所断随眠。欲界见集所断一切。及见苦所断遍行随眠随增者。谓九十八随眠中欲界见集所断七随眠。一一皆为欲界见集所断一切随眠。及见苦所断遍行随眠随增。欲界见灭所断随眠。欲界见灭所断除无漏缘不共无明。余一切及遍行随眠随增者。谓九十八随眠中欲界见灭所断七随眠。一一皆为尔所随眠随增。欲界见道所断随眠。欲界见道所断除无漏缘不共无明。余一切及遍行随眠随增者。谓九十八随眠中欲界见道所断八随眠。一一皆为尔所随眠随增。见灭道所断中。俱说除无漏缘不共无明者。彼于随眠。非所缘缚缘无漏故。非相应缚不与随眠相应故。欲界修所断随眠。欲界修所断一切。及遍行随眠随增者。谓九十八随眠中。欲界修所断四随眠。一一皆为尔所随眠随增。色无色界五部随眠广说亦尔等者。谓九十八随眠中。色界五部三十一。无色界五部三十一。一一皆为自界自部。及遍行随眠随增。广如欲界说以相同故

说一切有部发智大毗婆沙论卷第八十六阿毗达磨大毗婆沙论卷第八十七

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中十门纳息第四之十七

此中随眠于诸随眠。为所缘缚及相应缚。宽狭不等应作四句。或有随眠。于诸随眠为所缘缚非相应缚。谓有漏缘不共无明。或有随眠。于诸随眠为相应缚非所缘缚谓除无漏缘不共无明。诸余无漏缘随眠。或有随眠。于诸随眠为所缘缚亦相应缚。谓除有漏缘不共无明。诸余有漏缘随眠。此即总说。若别说者若于彼为所缘缚即于彼非相应缚。若于彼为相应缚即于彼非所缘缚。或有随眠。于诸随眠非所缘缚亦非相应缚。谓无漏缘不共无明。于此义中。雾尊者说。四句有异。或有随眠。于诸随眠为所缘缚非相应缚。谓自地不共无明缘彼未断。或有随眠。于诸随眠为相应缚非所缘缚。谓除自地他界缘。或他地缘。或自界他界缘。或自地余法缘。或无漏缘不共无明诸余自地他界缘。或他地缘。或自界他界缘。或自地余法缘。或无漏缘随眠未断。或有随眠。于诸随眠为所缘缚亦相应缚。谓除自地缘彼不共无明。诸余自地缘彼随眠未断。此即总说。若别说者。若于彼为所缘缚即于彼非相应缚。若于彼为相应缚。即于彼非所缘缚。或有随眠。于诸随眠非所缘缚亦非相应缚。谓诸随眠已断。设未断者。若他地随眠。若自地他界缘。或他地缘。或自界他界缘。或自地余法缘。或无漏缘不共无明

问若诸随眠有寻有伺。彼于有寻有伺法为所缘缚耶。答应作四句。有诸随眠。有寻有伺而于有寻有伺法非所缘缚。谓诸随眠有寻有伺而已断。设未断而他界缘。或他地缘。或自界他界缘。或自地余法缘。或无漏缘。有诸随眠。于有寻有伺法为所缘缚而非有寻有伺。谓诸随眠无寻唯伺。是有漏缘缘彼未断。有诸随眠。有寻有伺亦于有寻有伺法为所缘缚。谓诸随眠有寻有伺。是自地有漏缘缘彼未断。有诸随眠非有寻有伺。亦于有寻有伺法非所缘缚。谓诸随眠无寻唯伺而已断。设未断而他界缘。或他地缘。或自界他界缘。或自地余法缘。或无漏缘及诸随眠无寻无伺

问若诸随眠无寻唯伺。彼于无寻唯伺法为所缘缚耶。答应作四句。有诸随眠无寻唯伺。而于无寻唯伺法非所缘缚。谓诸随眠无寻唯伺而已断。设未断而他界缘。或他地缘。或自界他界缘。或自地余法缘。或无漏缘。有诸随眠于无寻唯伺法为所缘缚。而非无寻唯伺。谓诸随眠有寻有伺。是自地有漏缘缘彼未断。有诸随眠无寻唯伺。亦于无寻唯伺法为所缘缚。谓诸随眠无寻唯伺。是有漏缘缘彼未断。有诸随眠非无寻唯伺。亦于无寻唯伺法非所缘缚。谓诸随眠有寻有伺而已断。设未断而他界缘。或他地缘。或自界他界缘。或自地余法缘。或无漏缘。若诸随眠有寻有伺而是他地。及诸随眠无寻无伺

问若诸随眠无寻无伺。彼于无寻无伺法为所缘缚耶。答应作四句。有诸随眠无寻无伺。而于无寻无伺法非所缘缚。谓诸随眠无寻无伺而已断。设未断而他界缘。或他地缘。或自界他界缘。或无漏缘。有诸随眠于无寻无伺法为所缘缚。而非无寻无伺。谓诸随眠有寻有伺。或无寻唯伺是自地有漏缘缘彼未断。有诸随眠无寻无伺。亦于无寻无伺法为所缘缚。谓诸随眠无寻无伺。是自地有漏缘缘彼未断。有诸随眠非无寻无伺。亦于无寻无伺法非所缘缚。谓诸随眠有寻有伺。或无寻唯伺而已断。设未断而他界缘。或他地缘。或自界他界缘。或自地余法缘。或无漏缘

问若诸随眠有寻有伺。彼于有寻有伺法为相应缚耶。答若诸随眠于有寻有伺法为相应缚彼必有寻有伺。或有随眠有寻有伺。而于有寻有伺法非相应缚。谓诸随眠有寻有伺而已断。问若诸随眠无寻唯伺。彼于无寻唯伺法为相应缚耶。答应作四句。有诸随眠无寻唯伺。而于无寻唯伺法非相应缚。谓诸随眠无寻唯伺而已断。有诸随眠于无寻唯伺法为相应缚。而非无寻唯伺。谓诸随眠有寻有伺。于无寻唯伺法为相应缚。有诸随眠无寻唯伺。亦于无寻唯伺法为相应缚。谓诸随眠无寻唯伺而未断。有诸随眠非无寻唯伺。亦于无寻唯伺法非相应缚。谓诸随眠有寻有伺而已断。及诸随眠无寻无伺。问若诸随眠无寻无伺。彼于无寻无伺法为相应缚耶。答应作四句。有诸随眠无寻无伺。而于无寻无伺法非相应缚。谓诸随眠无寻无伺而已断。有诸随眠于无寻无伺法。为相应缚而非无寻无伺。谓诸随眠无寻唯伺。于无寻唯伺法为相应缚。有诸随眠无寻无伺。亦于无寻无伺法为相应缚。谓诸随眠无寻无伺而未断。有诸随眠非无寻无伺。亦于无寻无伺法非相应缚。谓诸随眠无寻唯伺而已断。及诸随眠有寻有伺

颇有法是有漏是心所。无寻唯伺未断未遍知。而非无寻唯伺随眠随增耶。答有。谓欲界寻。颇有法是有漏是心所。无寻唯伺未断未遍知。而为有寻有伺随眠随增耶。答有。谓欲界初静虑寻。颇有法是有漏是心所无寻无伺。而非无寻无伺随眠随增耶。答有。谓静虑中间伺。颇有聚。一时生。一时住。一时灭。一所依。一所缘。同行相。生时俱生。灭时俱灭。而随眠于彼有是相应缚有非相应缚耶。答有。谓不共无明聚。无明于彼有是相应缚。谓于无明相应法有非相应缚。谓于无明自性

眼根乃至无色界修所断无明随眠。缘识及缘缘识于九十八随眠中。一一有几随眠随增耶。问何故作此论。答为止他宗显正义故。谓譬喻者作如是说。眼等六识身所缘境各别。彼说意识别有所缘。不缘眼等五识所缘。又说六识唯缘外境。不缘内根亦不缘识。为遮彼意显前五识各别所缘。唯缘外境不缘根识。意识所缘与五识境。有同有异亦缘内根亦缘诸识。复次为欲显示诸法正理令他了知故作斯论

应知此中所缘诸法有十六种。谓三界各五部。及无漏法能缘诸识。亦有如是十六种异。问此中何法几识所缘。答欲界见苦所断法五识所缘。一欲界见苦所断一切随眠相应识。二欲界见集所断遍行随眠相应识。三欲界修所断善及无覆无记识。四色界修所断善及无覆无记识。五法智品无漏识。欲界见集所断法。五识所缘亦尔。有差别者。谓见集所断一切随眠相应识。见苦所断遍行随眠相应识。欲界见灭所断法六识所缘。一欲界见苦所断遍行随眠相应识。二欲界见集所断遍行随眠相应识。三欲界见灭所断有漏缘随眠相应识。四欲界修所断善及无覆无记识。五色界修所断善及无覆无记识。六法智品无漏识。欲界见道所断法六识所缘亦尔。有差别者。谓见道所断有漏缘随眠相应识。欲界修所断法五识所缘。一欲界见苦所断遍行随眠相应识。二欲界见集所断遍行随眠相应识。三欲界修所断善。及染污无覆无记识。四色界修所断善及无覆无记识。五法智品无漏识。色界见苦所断法八识所缘。一欲界见苦所断他界缘遍行随眠相应识。二欲界见集所断他界缘遍行随眠相应识。三欲界修所断善识。四色界见苦所断一切随眠相应识。五色界见集所断遍行随眠相应识。六色界修所断善及无覆无记识。七无色界修所断善识。八类智品无漏识。色界见集所断法八识所缘亦尔。有差别者。谓色界见集所断一切随眠相应识。见苦所断遍行随眠相应识。色界见灭所断法九识所缘。一欲界见苦所断他界缘遍行随眠相应识。二欲界见集所断他界缘遍行随眠相应识。三欲界修所断善识。四色界见苦所断遍行随眠相应识。五色界见集所断遍行随眠相应识。六色界见灭所断有漏缘随眠相应识。七色界修所断善及无覆无记识。八无色界修所断善识。九类智品无漏识。色界见道所断法九识所缘亦尔。有差别者。谓色界见道所断有漏缘随眠相应识。色界修所断法八识所缘。一欲界见苦所断他界缘遍行随眠相应识。二欲界见集所断他界缘遍行随眠相应识。三欲界修所断善识。四色界见苦所断遍行随眠相应识。五色界见集所断遍行随眠相应识。六色界修所断善及染污无覆无记识。七无色界修所断善识。八类智品无漏识。无色界见苦所断法十识所缘。一欲界见苦所断他界缘遍行随眠相应识。二欲界见集所断他界缘遍行随眠相应识。三欲界修所断善识。四色界见苦所断他界缘遍行随眠相应识。五色界见集所断他界缘遍行随眠相应识。六色界修所断善识。七无色界见苦所断一切随眠相应识。八无色界见集所断遍行随眠相应识。九无色界修所断善及无覆无记识。十类智品无漏识。无色界见集所断法十识所缘亦尔。有差别者。谓无色界见集所断一切随眠相应识。见苦所断遍行随眠相应识。无色界见灭所断法十一识所缘。一欲界见苦所断他界缘遍行随眠相应识。二欲界见集所断他界缘遍行随眠相应识。三欲界修所断善识。四色界见苦所断他界缘遍行随眠相应识。五色界见集所断他界缘遍行随眠相应识。六色界修所断善识。七无色界见苦所断遍行随眠相应识。八无色界见集所断遍行随眠相应识。九无色界见灭所断有漏缘随眠相应识。十无色界修所断善及无覆无记识。十一类智品无漏识。无色界见道所断法十一识所缘亦尔。有差别者。谓无色界见道所断有漏缘随眠相应识。无色界修所断法十识所缘。一欲界见苦所断他界缘遍行随眠相应识。二欲界见集所断他界缘遍行随眠相应识。三欲界修所断善识。四色界见苦所断他界缘遍行随眠相应识。五色界见集所断他界缘遍行随眠相应识。六色界修所断善识。七无色界见苦所断遍行随眠相应识。八无色界见集所断遍行随眠相应识。九无色界修所断善。及染污无覆无记识。十类智品无漏识无漏法十识所缘。一欲界见灭所断无漏缘随眠相应识。二欲界见道所断无漏缘随眠相应识。三欲界修所断善识。四色界见灭所断无漏缘随眠相应识。五色界见道所断无漏缘随眠相应识。六色界修所断善识。七无色界见灭所断无漏缘随眠相应识。八无色界见道所断无漏缘随眠相应识。九无色界修所断善识。十法类智品无漏识。问此十六识一一有几随眠随增。答欲界见苦所断识。欲界见苦所断一切。及见集所断遍行随眠随增。欲界见集所断识。欲界见集所断一切。及见苦所断遍行随眠随增。欲界见灭所断识。欲界见灭所断一切。及遍行随眠随增。欲界见道所断识。欲界见道所断一切。及遍行随眠随增。欲界修所断识。欲界修所断一切。及遍行随眠随增。色无色界各五部识亦尔。有差别者。谓各应说自界无漏识。非随眠随增义如前说

复次此中所缘法有三十二种。谓前十六法各有二种。前四部二种者。一相应。二不相应。修所断二种者。一染污。二不染污。无漏法二种者。一有为。二无为。有为无漏。谓法类智品。无为无漏。谓三无为。能缘识亦有三十二种。谓前十六识各有二种。见苦集所断二者。一遍行随眠相应识。二不遍行随眠相应识。见灭所断二者。一有为缘随眠相应识。二无为缘随眠相应识。见道所断二者。一有漏缘随眠相应识。二无漏缘随眠相应识。修所断二者。一染污识。二不染污识。无漏有二者。一法智品无漏识。二类智品无漏识。此中一一法有尔所识所缘。一一识有尔所随眠随增。各随所应准前应说

复次此中所缘法有百二十。谓三界五部染污法有九十八。即九十八随眠品。此中若彼自性。若彼相应。若彼等起。皆名彼品。三界修所断不染污法有十七。谓欲界七。色界六。无色界四。欲界七者。谓善有二。一生得善法。二加行善法。无记有五。一异熟生法。二威仪路法。三工巧处法。四通果无记法。五自性无记法。色界六者。谓善有二。如欲界说。无记有四。除工巧处。余如欲界说。无色界四者。谓善有二。如欲界说。无记有二。一异熟生。二自性无记。无漏法有五。谓法智品类智品。及三无为。能缘识有百一十四。谓三界五部染污识有九十八。即九十八随眠相应识。三界修所断不染污识有十四。谓欲界有六。一生得善识。二加行善识。三异熟生识。四威仪路识。五工巧处识。六通果无记识。色界有五。除工巧处识。余如欲界说。无色界有三。一生得善识。二加行善识。三异熟生识。无漏识有二。一法智品无漏识。二类智品无漏识。此中一一法有尔所识所缘。一一识有尔所随眠随增。各随所应准前应说。问生得善识能缘何法。答欲色界者。能缘三界及无漏一切法。无色界者。能缘自上地有漏无漏一切法及虚空。问加行善识能缘何法答欲色界者。能缘三界及无漏一切法。无色界者。能缘自上地有漏无漏一切法及虚空。并次下地有漏法。问异熟生无记识能缘何法。答欲界不善果者。唯缘欲界修所断法。善果者。唯缘欲界五部法。色界者。缘自下地一切有漏法。有说唯缘自地五部法。无色界者。唯缘自地五部法。问威仪路识能缘何法。答欲界者。唯缘欲界五部法。色界者。唯缘欲色界五部法。问工巧处识能缘何法。答唯缘欲界五部法。问通果无记识能缘何法。答欲界者。唯缘欲界修所断法。色界者。唯缘欲色界修所断法

问虚空非择灭何识所缘。答三界修所断善识所缘

眼根缘识欲色界三部。无色界遍行。及修所断缘缘识。三界四部者眼根通欲色界五地唯修所断。十六识内八识所缘。一欲界见苦所断遍行随眠相应识。此识欲界见苦所断一切。及见集所断遍行随眠随增。二欲界见集所断遍行随眠相应识。此识欲界见集所断一切。及见苦所断遍行随眠随增。三欲界修所断善及染污无覆无记识。此识欲界修所断一切。及遍行随眠随增。四色界见苦所断遍行随眠相应识。此识色界见苦所断一切。及见集所断遍行随眠随增。五色界见集所断遍行随眠相应识。此识色界见集所断一切。及见苦所断遍行随眠随增。六色界修所断善及染污无覆无记识。此识色界修所断一切。及遍行随眠随增。七无色界修所断善识。即空无边处近分善心。此识无色界修所断一切。及遍行随眠随增。八无漏识。谓苦集法类智品。此识非随眠随增。故说眼根缘识欲色界三部。无色界遍行及修所断随眠随增。眼根缘识。十六识内十三识所缘。一欲界见苦所断一切随眠相应识。是眼根缘缘识。缘缘眼根。欲界见苦所断遍行随眠相应识等。故此识欲界见苦所断一切。及见集所断遍行随眠随增。二欲界见集所断一切随眠相应识。是眼根缘缘识。缘缘眼根。欲界见集所断遍行随眠相应识等。故此识欲界见集所断一切。及见苦所断遍行随眠随增。三欲界见道所断无漏缘随眠相应识。是眼根缘缘识。缘缘眼根。苦集法智品相应识。故此识欲界见道所断一切。及遍行随眠随增。四欲界修所断善及染污无覆无记识。是眼根缘缘识。缘缘眼根。欲界修所断识等。故此识欲界修所断一切。及遍行随眠随增。五色界见苦所断一切随眠相应识。是眼根缘缘识。缘缘眼根。色界见苦所断遍行随眠相应识等。故此识色界见苦所断一切。及见集所断遍行随眠随增。六色界见集所断一切随眠相应识。是眼根缘缘识。缘缘眼根。色界见集所断遍行随眠相应识等。故此识色界见集所断一切。及见苦所断遍行随眠随增。七色界见道所断无漏缘随眠相应识。是眼根缘缘识。缘缘眼根。苦集类智品相应识。故此识色界见道所断一切。及遍行随眠随增。八色界修所断善及染污无覆无记识。是眼根缘缘识。缘缘眼根。色界修所断识等。故此识色界修所断一切。及遍行随眠随增。九无色界见苦所断遍行随眠相应识。是眼根缘缘识。缘缘眼根。无色界修所断善识。故此识无色界见苦所断一切。及见集所断遍行随眠随增。十无色界见集所断遍行随眠相应识。是眼根缘缘识。缘缘眼根。无色界修所断善识。故此识无色界见集所断一切。及见苦所断遍行随眠随增。十一无色界见道所断无漏缘随眠相应识。是眼根缘缘识。缘缘眼根。苦集类智品相应识故。此识无色界见道所断一切。及遍行随眠随增。十二无色界修所断善。及染污无覆无记识。是眼根缘缘识。缘缘眼根。无色界修所断善识等。故此识无色界修所断一切。及遍行随眠随增。十三苦集道智品无漏识。是眼根缘缘识。缘缘眼根。有漏无漏识。故此识非随眠随增。故说眼根缘缘识。三界四部随眠随增。耳鼻舌身根亦尔者。谓耳等根亦通欲色界五地。唯修所断如眼根故。女根缘识欲界三部。色界遍行。及修所断缘缘识。欲界四部。色界三部。无色界遍行。及修所断者。女根唯欲界修所断十六识内五识所缘。一欲界见苦所断遍行随眠相应识。此识欲界见苦所断一切。及见集所断遍行随眠随增。二欲界见集所断遍行随眠相应识。此识欲界见集所断一切。及见苦所断遍行随眠随增。三欲界修所断善。及染污无覆无记识。此识欲界修所断一切。及遍行随眠随增。四色界修所断善。及无覆无记识。此识色界修所断一切。及遍行随眠随增。五无漏识。谓苦集法智品此识非随眠随增。故说女根缘识。欲界三部色界遍行。及修所断随眠随增。女根缘缘识。十六识内九识所缘。一欲界见苦所断一切随眠相应识是女根缘缘识。缘缘女根。欲界见苦所断遍行随眠相应识等。故此识欲界见苦所断一切。及见集所断遍行随眠随增。二欲界见集所断一切随眠相应识。是女根缘缘识。缘缘女根。欲界见集所断遍行随眠相应识等。故此识欲界见集所断一切。及见苦所断遍行随眠随增。三欲界见道所断无漏缘随眠相应识。是女根缘缘识缘缘女根。苦集法智品相应识。故此识欲界见道所断一切。及遍行随眠随增。四欲界修所断善。及染污无覆无记识。是女根缘缘识。缘缘女根。欲界修所断识等。故此识欲界修所断一切。及遍行随眠随增。五色界见苦所断遍行随眠相应识。是女根缘缘识。缘缘女根。色界修所断善。及无覆无记识。故此识色界见苦所断一切。及见集所断遍行随眠随增。六色界见集所断遍行随眠相应识。是女根缘缘识。缘缘女根。色界修所断善。及无覆无记识。故此识色界见集所断一切。及见苦所断遍行随眠随增。七色界修所断善。及染污无覆无记识。是女根缘缘识缘缘女根。色界修所断善。及无覆无记识等。故此识色界修所断一切。及遍行随眠随增。八无色界修所断善识。是女根缘缘识。缘缘女根。色界修所断善及无覆无记识。故此识无色界修所断一切。及遍行随眠随增。九苦集道智品无漏识。是女根缘缘识。缘缘女根。有漏无漏识。故此识非随眠随增。故说女根缘缘识。欲界四部。色界三部。无色界遍行。及修所断随眠随增。男苦根亦尔者。谓男苦根亦唯欲界修所断。如女根故

命根缘识三界三部缘缘识。三界四部者。命根通三界九地唯修所断。十六识内十识所缘。一欲界见苦所断遍行随眠相应识。此识欲界见苦所断一切。及见集所断遍行随眠随增。二欲界见集所断遍行随眠相应识。此识欲界见集所断一切。及见苦所断遍行随眠随增。三欲界修所断善及染污无覆无记识。此识欲界修所断一切。及遍行随眠随增。如欲界三部识。色无色界各三部识亦尔。合为九识。十无漏识。谓苦集法类智品。此识非随眠随增故。说命根缘识三界三部随眠随增。命根缘识。十六识内十三识所缘。一欲界见苦所断一切随眠相应识是命根缘缘识。缘缘命根。欲界见苦所断遍行随眠相应识等。故此识欲界见苦所断一切。及见集所断遍行随眠随增。二欲界见集所断一切随眠相应识。是命根缘缘识。缘缘命根。见集所断遍行随眠相应识等。故此识欲界见集所断一切。及见苦所断遍行随眠随增。三欲界见道所断无漏缘随眠相应识。是命根缘缘识。缘缘命根。苦集法智品相应识。故此识欲界见道所断一切。及遍行随眠随增。四欲界修所断善。及染污无覆无记识。是命根缘缘识。缘缘命根。欲界修所断识等。故此识欲界修所断一切。及遍行随眠随增。如欲界四部识。色无色界各四部识亦尔。有差别者。谓见道所断无漏缘随眠相应识。缘缘命根。苦集类智品相应识。后准应知。合为十二识。十三苦集道智品无漏识。是命根缘缘识。缘缘命根有漏无漏识。故此识非随眠随增。故说命根缘缘识。三界四部随眠随增

说一切有部发智大毗婆沙论卷第八十七阿毗达磨大毗婆沙论卷第八十八

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中十门纳息第四之十八

意根缘识缘缘识有为缘者。意根通三界九地五部有漏及无漏法类智品故。十六识所缘。一欲界见苦所断一切随眠相应识。此识欲界见苦所断一切。及见集所断遍行随眠随增。二欲界见集所断一切随眠相应识。此识欲界见集所断一切。及见苦所断遍行随眠随增。三欲界见灭所断有为缘随眠相应识。此识欲界见灭所断有为缘。及遍行随眠随增。四欲界见道所断一切随眠相应识。此识欲界见道所断一切。及遍行随眠随增。五欲界修所断善及染污无覆无记识。此识欲界修所断一切。及遍行随眠随增。如欲界五部有为缘识。色无色界各五部有为缘识亦尔。合为十五识。十六无漏识。谓苦集道法类忍智品。此识非随眠随增。故说意根缘识有为缘随眠随增。意根缘缘识亦十六识所缘。此意根缘缘识随眠随增。亦如意根缘识说。故说意根缘缘识有为缘随眠随增舍根亦尔者。舍根亦通三界九地五部有漏及无漏法类智品如意根故

乐根缘识欲界四部。色界有为缘无色界二部。及遍行缘缘识欲无色界四部。色界有为缘者。乐根通欲界初及第三静虑。欲界者。五识身相应。初静虑者。三识身相应。此二唯有漏修所断。第三静虑者。意识相应通有漏无漏。有漏者通五部。无漏者通法类智品。故此乐根十六识内十二识所缘。一欲界见苦所断遍行随眠相应识。此识欲界见苦所断一切。及见集所断遍行随眠随增。二欲界见集所断遍行随眠相应识。此识欲界见集所断一切。及见苦所断遍行随眠随增。三欲界见道所断无漏缘随眠相应识。此识欲界见道所断一切。及遍行随眠随增。四欲界修所断善。及染污无覆无记识。此识欲界修所断一切。及遍行随眠随增。五色界见苦所断一切随眠根应识。此识色界见苦所断一切。及见集所断遍行随眠随增。六色界见集所断一切随眠相应识。此识色界见集所断一切。及见苦所断遍行随眠随增。七色界见灭所断有为缘随眠相应识。此识色界见灭所断有为缘及遍行随眠随增。八色界见道所断一切随眠相应识。此识色界见道所断一切。及遍行随眠随增。九色界修所断善及染污无覆无记识。此识色界修所断一切。及遍行随眠随增。十无色界见道所断无漏缘随眠相应识此识无色界见道所断一切。及遍行随眠随增十一无色界修所断善识。此识无色界修所断一切。及遍行随眠随增。十二无漏识。谓苦集道法类智品。此识非随眠随增故。说乐根缘识。欲界四部色界有为缘无色界二部。及遍行随眠随增。乐根缘识十六识内十四识所缘。一欲界见苦所断一切随眠相应识。是乐根缘缘识。缘缘乐根。欲界见苦所断遍行随眠相应识等。故此识欲界见苦所断一切。及见集所断遍行随眠随增。二欲界见集所断一切随眠相应识。是乐根缘缘识缘缘乐根。见集所断遍行随眠相应识等。故此识欲界见集所断一切。及见苦所断遍行随眠随增。三欲界见道所断一切随眠相应识。是乐根缘缘识。缘缘乐根。欲界见道所断无漏缘随眠相应识。及苦集道法智品相应识。故此识欲界见道所断一切。及遍行随眠随增四欲界修所断善。及染污无覆无记识。是乐根缘缘识。缘缘乐根。欲界修所断识等。故此识欲界修所断一切。及遍行随眠随增。五无色界见苦所断遍行随眠相应识。是乐根缘缘识。缘缘乐根。无色界见道所断无漏缘随眠相应识等。故此识无色界见苦所断一切。及见集所断遍行随眠随增。六无色界见集所断遍行随眠相应识。是乐根缘缘识。缘缘乐根。无色界见道所断无漏缘随眠相应识等。故此识无色界见集所断一切。及见苦所断遍行随眠随增。七无色界见道所断一切随眠相应识。是乐根缘缘识。缘缘乐根。无色界见道所断无漏缘相应识。及道类智品无漏识。故此识无色界见道所断一切。及遍行随眠随增八无色界修所断善。及染污无覆无记识。是乐根缘缘识。缘缘乐根。无色界修所断善识等。故此识无色界修所断一切。及遍行随眠随增。及色界五部有为缘识。是乐根缘缘识。缘缘乐根。随其所应有漏无漏识。故此识随其所应色界有为缘随眠随增。此五并前八合为十三识。十四苦集道智品无漏识。是乐根缘缘识。缘缘乐根有漏无漏识。故此识非随眠随增。故说乐根缘缘识。欲无色界四部。色界有为缘随眠随增。喜根缘识欲色界有为缘。无色界二部及遍行。缘缘识欲色界有为缘。无色界四部者。喜根通欲界及初二静虑。唯意识相应。欲界者。唯有漏通五部。初二静虑者。通有漏无漏。有漏者通五部。无漏者通法类忍智品故。此喜根十六识内十三识所缘。一欲界见苦所断一切随眠相应识。此识欲界见苦所断一切。及见集所断遍行随眠随增。二欲界见集所断一切随眠相应识。此识欲界见集所断一切。及见苦所断遍行随眠随增。三欲界见灭所断有为缘随眠相应识。此识欲界见灭所断有为缘。及遍行随眠随增。四欲界见道所断一切随眠相应识。此识欲界见道所断一切。及遍行随眠随增。五欲界修所断善。及染污无覆无记识。此识欲界修所断一切。及遍行随眠随增。如欲界五部有为缘识色界五部有为缘识亦尔。合为十识。十一无色界见道所断无漏缘随眠相应识。此识无色界见道所断一切。及遍行随眠随增。十二无色界修所断善识。此识无色界修所断一切。及遍行随眠随增。十三无漏识谓苦集道法类智品。此识非随眠随增故说喜根缘识。欲色界有为缘无色界二部。及遍行随眠随增。喜根缘识十六识内十五识所缘。一欲界见苦所断一切随眠相应识。是喜根缘缘识。缘缘喜根。自部他部随其所应有漏识故。此识欲界见苦所断一切。及见集所断遍行随眠随增。二见集所断一切随眠相应识。是喜根缘缘识。缘缘喜根。自部他部随其所应有漏识故。此识欲界见集所断一切。及见苦所断遍行随眠随增。三欲界见灭所断有为缘随眠相应识。是喜根缘缘识。缘缘喜根。自部有为缘随眠相应识。故此识欲界见灭所断有为缘。及遍行随眠随增。四欲界见道所断一切随眠相应识。是喜根缘缘识。缘缘喜根。自部一切随眠相应识。及苦集道法智品相应识。故此识欲界见道所断一切及遍行随眠随增。五欲界修所断善。及染污无覆无记识。是喜根缘缘识。缘缘喜根。欲界修所断识等。故此识欲界修所断一切。及遍行随眠随增。如欲界五部有为缘识。色界五部有为缘识亦尔。合为十识。十一无色界见苦所断遍行随眠相应识。是喜根缘缘识。缘缘喜根。无色界见道所断无漏缘随眠相应识等。故此识无色界见苦所断一切。及见集所断遍行随眠随增。十二无色界见集所断遍行随眠相应识。是喜根缘缘识缘缘喜根。无色界见道所断无漏缘随眠相应识等故此识无色界见集所断一切。及见苦所断遍行随眠随增。十三无色界见道所断一切随眠相应识。是喜根缘缘识。缘缘喜根。无色界见道所断无漏缘随眠相应识。及苦集道类智品相应识。故此识无色界见道所断一切。及遍行随眠随增。十四无色界修所断善及染污无覆无记识。是喜根缘缘识。缘缘喜根。无色界修所断善识等。故此识无色界修所断一切。及遍行随眠随增十五苦集道智品无漏识。是喜根缘缘识。缘缘喜根。有漏无漏识故。此识非随眠随增。故说喜根缘缘识。欲色界有为缘无色界四部随眠随增

忧根缘识。欲界有漏缘。色界遍行及修所断缘缘识。欲界有为缘色界三部。无色界遍行及修所断者。忧根唯欲界有漏意识相应通五部。十六识内七识所缘。一欲界见苦所断一切随眠相应识。此识欲界见苦所断一切。及见集所断遍行随眠随增。二欲界见集所断一切随眠相应识。此识欲界见集所断一切。及见苦所断遍行随眠随增。三欲界见灭所断有为缘随眠相应识。此识欲界见灭所断有为缘。及遍行随眠随增。四欲界见道所断有漏缘随眠相应识。此识欲界见道所断有漏缘及遍行随眠随增。五欲界修所断善。及染污无覆无记识。此识欲界修所断一切。及遍行随眠随增。六色界修所断善。及无覆无记识。此识色界修所断一切。及遍行随眠随增。七无漏识。谓苦集法智品。此识非随眠随增故。说忧根缘识欲界有漏缘色界遍行。及修所断随眠随增。忧根缘识十六识内十识所缘。一欲界见苦所断一切随眠相应识。是忧根缘缘识缘缘忧根自部他部随其所应有漏识。故此识欲界见苦所断一切。及见集所断遍行随眠随增二欲界见集所断一切随眠相应识。是忧根缘缘识。缘缘忧根自部他部。随其所应有漏识。故此识欲界见集所断一切。及见苦所断遍行随眠随增。三欲界见灭所断有为缘随眠相应识。是忧根缘缘识。缘缘忧根自部有为缘随眠相应识。故此识欲界见灭所断有为缘。及遍行随眠随增。四欲界见道所断有漏缘随眠相应识。是忧根缘缘识。缘缘忧根自部有漏缘随眠相应识故。此识欲界见道所断有漏缘。及遍行随眠随增。五欲界修所断善。及染污无覆无记识。是忧根缘缘识。缘缘忧根欲界修所断识等。故此识欲界修所断一切。及遍行随眠随增。六色界见苦所断遍行随眠相应识。是忧根缘缘识。缘缘忧根色界修所断善。及无覆无记识。故此识色界见苦所断一切。及遍行随眠随增。七色界见集所断遍行随眠相应识。是忧根缘缘识。缘缘忧根。色界修所断善。及无覆无记识。故此识色界见集所断一切。及见苦所断遍行随眠随增。八色界修所断善。及染污无覆无记识。是忧根缘缘识。缘缘忧根。色界修所断善。及无覆无记识等。故此识色界修所断一切。及遍行随眠随增。九无色界修所断善识。是忧根缘缘识。缘缘忧根。色界修所断善。及无覆无记识。故此识无色界修所断一切。及遍行随眠随增。十苦集道智品无漏识。是忧根缘缘识。缘缘忧根。有漏无漏识。故此识非随眠随增。故说忧根缘缘识。欲界有为缘。色界三部。无色界遍行。及修所断随眠随增信等五根缘识。缘缘识三界四部者。信等五根通有漏无漏。有漏者通三界九地唯修所断。无漏者通九地法类智品。故此信等五根。十六识内十三识所缘。一欲界见苦所断遍行随眠相应识。此识欲界见苦所断一切。及见集所断遍行随眠随增。二欲界见集所断遍行随眠相应识。此识欲界见集所断一切。及见苦所断遍行随眠随增。三欲界见道所断无漏缘随眠相应识。此识欲界见道所断一切。及遍行随眠随增。四欲界修所断善。及染污无覆无记识此识欲界修所断一切。及遍行随眠随增。如欲界四部识。色无色界各四部识亦尔。合为十二识。十三无漏识。谓苦集道法类智品。此识非随眠随增。故说信等五根缘识。三界四部随眠随增。信等五根缘识十六识内亦十三识所缘。一欲界见苦所断一切随眠相应识。是信等五根缘缘识。缘缘信等五根自部他部。随其所应有漏识故。此识欲界见苦所断一切。及见集所断遍行随眠随增二欲界见集所断一切随眠相应识。是信等五根缘缘识。缘缘信等五根自部他部。随其所应有漏识故。此识欲界见集所断一切。及见苦所断遍行随眠随增。三欲界见道所断一切随眠相应识。是信等五根缘缘识。缘缘信等五根自部无漏缘随眠相应识。及苦集道法智品相应识。故此识欲界见道所断一切。及遍行随眠随增。四欲界修所断善。及染污无覆无记识。是信等五根缘缘识。缘缘信等五根欲界修所断识等。故此识欲界修所断一切。及遍行随眠随增。如欲果四部识。色无色界各四部识亦尔。合为十二识。十三苦集道智品无漏识。是信等五根缘缘识。缘缘信等五根有漏无漏识。故此识非随眠随增。故说信等五根缘缘识。三界四部随眠随增

三无漏根缘识三界二部。及遍行缘缘识。三界四部者。三无漏根通苦集灭道法类智品。十六识内七识所缘。一欲界见道所断无漏缘随眠相应识。此识欲界见道所断一切。及遍行随眠随增。二欲界修所断善识。此识欲界修所断一切。及遍行随眠随增。如欲界二部识。色无色界各二部识亦尔。合为六识。七无漏识。谓道法类智品。此识非随眠随增。故说三无漏根缘识。三界二部及遍行随眠随增。三无漏根缘识。十六识内十三识所缘。一欲界见苦所断遍行随眠相应识。是三无漏根缘缘识。缘缘三无漏根欲界见道所断无漏缘随眠相应识等。故此识欲界见苦所断一切。及见集所断遍行随眠随增。二欲界见集所断遍行随眠相应识。是三无漏根缘缘识。缘缘三无漏根欲界见道所断。无漏缘随眠相应识等。故此识欲界见集所断一切。及见苦所断遍行随眠随增。三欲界见道所断一切随眠相应识。是三无漏根缘缘识。缘缘三无漏根欲界见道所断无漏缘随眠相应识。及道法智品相应识。故此识欲界见道所断一切。及遍行随眠随增。四欲界修所断善。及染污无覆无记识。是三无漏根缘缘识。缘缘三无漏根欲界修所断善识等。故此识欲界修所断一切。及遍行随眠随增。如欲界四部识。色无色界各四部识亦尔。合为十二识。十三苦集道智品无漏识。是三无漏根缘缘识。缘缘三无漏根有漏无漏识。故此识非随眠随增。故说三无漏根缘缘识。三界四部随眠随增。眼耳鼻舌身色声触界缘识。欲色界三部。无色界遍行。及修所断缘缘识。三界四部眼耳鼻舌身色声触处色取蕴。前五界有见有对法亦尔者。如是诸法皆通欲色界五地。唯修所断故。如眼根等应知其相。香味鼻舌识界缘识欲界三部。色界遍行。及修所断缘缘识。欲界四部。色界三部。无色界遍行。及修所断。香味处亦尔者。如是诸法皆唯欲界修所断故。如女根等应知其相。眼耳身识界。缘识欲色界三部。缘缘识欲色界四部。无色界二部。及遍行者。如是诸法通欲界及初静虑。唯修所断。十六识内七识所缘。一欲界见苦所断遍行随眠相应识。二欲界见集所断遍行随眠相应识。三欲界修所断善。及染污无覆无记识。如欲界三部识。色界三部识亦尔。合为六识。七无漏识。谓苦集法类智品故眼耳身识界缘识。欲色界三部随眠随增。如是缘识。十六识内十一识所缘。一欲界见苦所断一切随眠。相应识二欲界见集。所断一切随眠相应识。三欲界见道所断无漏缘随眠相应识。四欲界修所断善。及染污无覆无记识。如欲界四部识。色界四部识亦尔。合为八识。九无色界见道所断无漏缘随眠相应识。十无色界修所断善识。十一苦集道法类智品无漏识故。眼耳身识界缘缘识。欲色界四部。无色界二部。及遍行随眠随增。意界意识界缘识缘缘识有为。缘意处后四蕴有为法过去未来现在法亦尔者。如是诸法皆通三界九地。五部有漏及无漏法类智品。如意根等应知其相。法界缘识三界一切。缘缘识有为缘法处。无色无见无对善法亦尔者。此诸法中。除善余法皆通三界九地。五部有漏及无漏法类智品并三无为故。十六识所缘。此诸缘识亦十六识所缘。唯除无为。缘识善法通有漏无漏。有漏者。通三界九地。唯修所断。无漏者。通法类智品并择灭故。此善法亦十六识所缘。然见苦集所断中。唯取遍行随眠相应识。见灭道所断中。唯取无漏缘随眠相应识。此善法缘识亦十六识所缘。唯除无为缘识。故此诸法缘识三界一切随眠随增。缘缘识有为缘随眠随增。色蕴缘识欲色界四部。无色界二部。及遍行缘缘识。三界四部有色法亦尔者。色蕴及有色法俱通有漏无漏。有漏者。通欲色界五地。唯修所断。无漏者。通六地法类智品故。十六识内十一识所缘。一欲界见苦所断遍行随眠相应识。二欲界见集所断遍行随眠相应识。三欲界见道所断无漏缘随眠相应识。四欲界修所断善。及染污无覆无记识。如欲界四部识。色界四部识亦尔。合为八识。九无色界见道所断无漏缘随眠相应识。十无色界修所断善识。十一无漏识。谓苦集道法类智品。故色蕴等缘识欲色界四部。无色界二部。及遍行随眠随增。此色蕴等缘识十六识内十三识所缘。谓三界各四部识。除见灭所断识。然无色界见苦集所断中。唯取遍行随眠相应识。合为十二识。十三苦集道智品无漏识。故色蕴等缘缘识三界四部随眠随增。后四取蕴。缘识有漏缘缘缘识有为缘识界有漏法。见所断法亦尔者。此诸法中除见所断。余法皆通三界九地五部。唯有漏见所断法。通三界九地。前四部唯有漏故。皆十六识所缘。然除见灭道所断无漏缘识。此诸缘识亦十六识所缘。然除见灭所断无为缘识。故此诸法缘识有漏缘随眠随增缘缘识有为缘随眠随增无漏法缘识。三界三部及遍行缘缘识。有为缘无断法亦尔者。无漏及无断法谓灭道谛及虚空非择灭故。十六识内十识所缘。一欲界见灭所断无为缘随眠相应识。二欲界见道所断无漏缘随眠相应识。三欲界修所断善识。如欲界三部识。色无色界各三部识亦尔。合为九识。十无漏识。谓灭道法类智品。故此二法缘识三界三部。及遍行随眠随增。此二法缘识十六识所缘。于中唯除无为缘识。故此二法缘缘识。有为缘随眠随增。无为法缘识三界二部。及遍行缘缘识有为缘者三无为法。十六识内七识所缘。一欲界见灭所断无为缘随眠相应识。二欲界修所断善识。如欲界二部识。色无色界各二部识亦尔。合为六识。七无漏识。谓灭法类智品故。无为法缘识三界二部。及遍行随眠随增。无为法缘识十六识所缘。于中唯除无为缘识。故无为法缘缘识有为缘随眠随增。不善法缘识欲界有漏缘。色界遍行。及修所断缘缘识。欲界有为缘色界三部。无色界遍行。及修所断。欲界系法亦尔者。不善等法唯欲界通五部故。如前忧根应知其相。无记法缘识欲界三部。色无色界有漏缘缘缘识欲界四部。色无色界有为缘者。无记法通三界。欲界者。修所断。及见苦所断中有身边执见品。色无色界者。通五部并二无为故。无记法十六识内十四识所缘。一欲界见苦一切随眠相应识。二欲界见集所断遍行随眠相应识。三欲界修所断善。及染污无覆无记识。及色无色界各五部识。于中唯除无漏缘识。合为十三识。十四无漏识。谓苦集法类智品。故无记法缘识。欲界三部。色无色界有漏缘随眠随增。无记法缘识。十六识内十五识所缘。除欲界见灭所断识。色无色界各五部识中除无为缘识。故无记法缘缘识欲界四部。色无色界有为缘随眠随增。色界系法缘识。欲界三部。色界有漏缘。无色界遍行。及修所断缘缘识。欲界三部色界有为缘。无色界四部者。色界系法通五部故。十六识内十识所缘。一欲界见苦所断他界缘遍行随眠相应识。二欲界见集所断他界缘遍行随眠相应识。三欲界修所断善识。及色界五部有漏缘识。合为八识。九无色界修所断善识。十无漏识。谓苦集类智品。故色界系法缘识。欲界三部。色界有漏缘。无色界遍行。及修所断随眠随增。色界系法缘识。十六识内十三识所缘。一欲界见苦所断一切随眠相应识。二欲界见集所断一切随眠相应识。三欲界修所断善。及染污无覆无记识。及色界五部有为缘识。合为八识。九无色界见苦所断遍行随眠相应识。十无色界见集所断遍行随眠相应识。十一无色界见道所断无漏缘随眠相应识。十二无色界修所断善。及染污无覆无记识。十三苦集道智品无漏识。故色界系法缘缘识。欲界三部。色界有为缘。无色界四部随眠随增。无色界系法缘识。欲色界三部。无色界有漏缘缘缘识。欲界三部。色界四部。无色界有为缘者。无色界系法通五部故。十六识内十二识所缘。一欲界见苦所断他界缘遍行随眠相应识。二欲界见集所断他界缘遍行随眠相应识。三欲界修所断善识。如欲界三部识。色界三部识亦尔。合为六识。及无色界五部有漏缘识。合为十一识。十二无漏识。谓苦集类智品故无色界系法缘识。欲色界三部无色界有漏缘随眠随增无色界系法缘识。十六识内十三识所缘。谓欲界见苦集修所断三部识。色界四部识。除见灭所断识。于见道所断识中。唯取无漏缘随眠相应识。无色界五部有为缘识。合为十二识。十三苦集道智品无漏识。故无色界系法缘缘识。欲界三部。色界四部。无色界有为缘随眠随增。学无学法缘识。三界二部。及遍行缘缘识。三界四部者。学无学法唯无漏通四谛法类智品故。如三无漏根应知其相非学非无学法缘识。三界四部。及见道所断有漏缘。缘缘识有为缘者。此法通三界五部。唯有漏故。十六识所缘。唯除见道所断无漏缘识。故非学非无学法缘识。三界四部。及见道所断有漏缘随眠随增。此法缘识亦十六识所缘。然除无为缘识。故此法缘缘识有为缘随眠随增。修所断法缘识三界三部。缘缘识三界四部者。修所断法通三界九地故。如命根应知其相

说一切有部发智大毗婆沙论卷第八十八阿毗达磨大毗婆沙论卷第八十九

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中十门纳息第四之十九

苦集谛缘识。有漏缘缘缘识有为缘。世俗智亦尔者。苦集谛等皆通三界九地。五部唯有漏故。如后四取蕴等应知其相。灭谛缘识三界二部。及遍行缘缘识有为缘者。如无为法应知其相。道谛缘识三界二部。及遍行缘缘识三界四部苦集灭道智。及三三摩地亦尔者。如三无漏根应知其相。四静虑缘识。欲界四部。色界有为缘。无色界二部及遍行缘缘识欲无色界四部。色界有为缘者。四静虑通有漏无漏。有漏者。唯色界通五部。无漏者。通四谛法类智品故。四静虑十六识内十二识所缘。一欲界见苦所断他界缘遍行随眠相应识。二欲界见集所断他界缘遍行随眠相应识。三欲界见道所断无漏缘随眠相应识。四欲界修所断善识。此及色界五部有为缘识合为九识。十无色界见道所断无漏缘随眠相应识。十一无色界修所断善识。十二无漏识。谓苦集类智品道法类智品故。四静虑缘识欲界四部色界有为缘。无色界二部。及遍行随眠随增。四静虑缘识十六识内十四识所缘。除欲无色界各见灭所断识。及除色界无为缘识。无漏识中取苦集道智品故。四静虑缘缘识。欲无色界四部。色界有为缘随眠随增。慈悲舍无量缘识。欲色界三部。无色界遍行。及修所断缘缘识。欲界三部。色无色界四部。净解脱。后四胜处。前八遍处亦尔者。三无量通色界四地。净解脱等唯第四静虑皆唯有漏修所断故。十六识内八识所缘。一欲界见苦所断他界缘遍行随眠相应识。二欲界见集所断他界缘遍行随眠相应识。三欲界修所断善识。四色界见苦所断遍行随眠相应识。五色界见集所断遍行随眠相应识。六色界修所断善。及染污无覆无记识。七无色界修所断善识。八无漏识。谓苦集类智品故。三无量等缘识。欲色界三部。无色界遍行。及修所断随眠随增。三无量等缘识。十六识内十二识所缘。谓欲界见苦集修所断识。及色无色界各四部识。除见灭所断识。于见道所断中。唯取无漏缘随眠相应识。无色界见苦集所断中。唯取遍行随眠相应识。合为十一识。十二苦集道智品无漏识故。三无量等缘缘识欲界三部。色无色界四部随眠随增。喜无量缘识。欲色界三部缘缘识。欲界三部。色界四部。无色界二部。及遍行。初二解脱。前四胜处亦尔者。喜无量等唯初二静虑有漏修所断故。十六识内七识所缘。一欲界见苦所断他界缘遍行随眠相应识。二欲界见集所断他界缘遍行随眠相应识。三欲界修所断善识。四色界见苦所断遍行随眠相应识。五色界见集所断遍行随眠相应识。六色界修所断善。及染污无覆无记识。七无漏识。谓苦集类智品故。喜无量等缘识欲色界三部随眠随增。喜无量等缘识。十六识内十识所缘。谓欲界见苦集修所断识。及色界四部识。除见灭所断识。于见道所断中。唯取无漏缘随眠相应识。合为七识。八无色界见道所断无漏缘随眠相应识。九无色界修所断善识。十苦集道智品无漏识故。喜无量等缘缘识。欲界三部。色界四部。无色界二部。及遍行随眠随增。前三无色缘识。缘缘识。欲界三部。色界四部。无色界有为缘者。前三无色通有漏无漏。有漏者。唯无色界通五部。无漏者。通四谛类智品故。十六识内。十三识所缘。一欲界见苦所断他界缘遍行随眠相应识。二欲界见集所断他界缘遍行随眠相应识。三欲界修所断善识。如欲界三部识。色界三部识亦尔。及色界见道所断无漏缘随眠相应识。并无色界五部有为缘识。合为十二识。十三无漏识。谓苦集道类智品。前三无色缘识。亦十六识内十三识所缘。谓欲界见苦集修所断识。及色界四部识。除见灭所断识。并无色界五部有为缘识。合为十二识。十三苦集道智品无漏识故。前三无色缘识及缘缘识。俱欲界三部。色界四部。无色界有为缘随眠随增。非想非非想处缘识。欲色界三部。无色界有漏缘缘缘识。欲界三部。色界四部。无色界有为缘者。非想非非想处唯有漏通五部故十六识内十二识所缘。一欲界见苦所断他界缘遍行随眠相应识。二欲界见集所断他界缘遍行随眠相应识。三欲界修所断善识。如欲界三部识。色界三部识亦尔。及无色界五部有漏缘识。合为十一识。十二无漏识谓苦集类智品故。非想非非想处缘识。欲色界三部无色界有漏缘随眠随增。非想非非想处缘识。十六识内十三识所缘。谓欲界见苦集修所断识。及色界四部识。除见灭所断识。于见道所断中。唯取无漏缘随眠相应识。并无色界五部有为缘识。合为十二识。十三苦集道智品无漏识故。非想非非想处缘缘识。欲界三部。色界四部。无色界有为缘随眠随增。空识无边处。无所有处。解脱缘识。缘缘识。欲界三部。色无色界四部者。此三解脱通有漏无漏。有漏者。唯无色界修所断加行善摄。无漏者。唯类智品故。十六识内十二识所缘。一欲界见苦所断他界缘遍行随眠相应识。二欲界见集所断他界缘遍行随眠相应识。三欲界修所断善识。如欲界三部识。色界三部识亦尔。及色界见道所断无漏缘随眠相应识。合为七识。八无色界见苦所断遍行随眠相应识。九无色界见集所断遍行随眠相应识。十无色界见道所断无漏缘随眠相应识。十一无色界修所断善。及染污无覆无记识。十二无漏识谓苦集道类智品。此三解脱缘识。亦十二识所缘。谓欲界见苦集修所断识。色无色界各四部识。除见灭所断识。合为十一识。十二苦集道智品无漏识故。此三解脱缘识。缘缘识。俱欲界三部。色无色界四部。随眠随增。后二解脱。及后二遍处缘识。三界三部。缘缘识欲界三部。色无色界四部者。此四法唯无色界修所断加行善摄故。十六识内十识所缘。一欲界见苦所断他界缘遍行随眠相应识。二欲界见集所断他界缘遍行随眠相应识。三欲界修所断善识。如欲界三部识。色界三部识亦尔。合为六识。七无色界见苦所断遍行随眠相应识。八无色界见集所断遍行随眠相应识。九无色界修所断善。及染污无覆无记识十无漏识。谓苦集类智品故。此四法缘识。三界三部随眠随增。此四法缘识。十六识内十二识所缘。谓三界各见苦集修所断识。及色无色界各见道所断无漏缘随眠相应识。并苦集道智品无漏识故。此四法缘缘识。欲界三部。色无色界四部。随眠随增。法智缘识。欲界二部及遍行。色界遍行及修所断缘缘识。欲界四部。色界三部。无色界遍行及修所断者。法智在六地故。十六识内四识所缘。一欲界见道所断无漏缘随眠相应识。二欲界修所断善识。三色界修所断善识。四无漏识。谓道法智品故。法智缘识。欲界二部及遍行。色界遍行及修所断随眠随增。法智缘识。十六识内九识所缘。一欲界见苦所断遍行随眠相应识。二欲界见集所断遍行随眠相应识。三欲界见道所断一切随眠相应识。四欲界修所断善。及染污无覆无记识。五色界见苦所断遍行随眠相应识。六色界见集所断遍行随眠相应识。七色界修所断善。及染污无覆无记识。八无色界修所断善识。九苦集道智品无漏识故。法智缘缘识。欲界四部。色界三部。无色界遍行。及修所断随眠随增。类智缘识。色无色界二部及遍行。欲界遍行及修所断。缘缘识。欲界三部。色无色界四部者。类智在九地故。十六识内六识所缘。谓色无色界各见道所断无漏缘随眠相应识。及三界修所断善识。合为五识。六无漏识。谓道类智品故。类智缘识。色无色界二部及遍行。欲界遍行及修所断随眠随增。此类智缘识十六识内十二识所缘。谓三界各见苦集所断遍行随眠相应识。及修所断善。及染污无覆无记识。并色无色界各见道所断一切随眠相应识。合为十一识。十二苦集道智品无漏识故。类智缘缘识。欲界三部。色无色界四部。随眠随增。问何界何地见道所断邪见。缘何品何地圣道耶。有作是说。彼邪见但缘断对治圣道。若作是说。欲界邪见但缘未至定所摄圣道。初静虑邪见。但缘三地所摄圣道。第二静虑邪见但缘四地所摄圣道。第三静虑邪见但缘五地所摄圣道。第四静虑。及无色界邪见。皆但缘六地所摄圣道。复有说者。彼邪见亦缘厌坏对治圣道。若作是说欲色界邪见皆缘六地所摄圣道。空无边处邪见。缘七地所摄圣道。识无边处邪见缘八地所摄圣道。无所有处及非想非非想处邪见。俱缘九地所摄圣道。评曰。应作是说。欲界见道所断邪见。缘六地一切法智品圣道。色无色界见道所断邪见。皆缘九地一切类智品圣道。以种类同故。他心智缘识。欲色界四部。无色界二部及遍行。缘缘识。三界四部者。他心智通有漏无漏。有漏者。通色界四地。唯修所断加行善摄。无漏者。通四静虑地。道法类智品故。他心智十六识内十一识所缘。一欲界见苦所断他界缘遍行随眠相应识。二欲界见集所断他界缘遍行随眠相应识。三欲界见道所断无漏缘随眠相应识。四欲界修所断善识。五色界见苦所断遍行随眠相应识。六色界见集所断遍行随眠相应识。七色界见道所断无漏缘随眠相应识。八色界修所断善。及染污无覆无记识。九无色界见道所断无漏缘随眠相应识。十无色界修所断善识。十一无漏识。谓苦集类智品。及道法类智品故。他心智缘识。欲色界四部。无色界二部。及遍行随眠随增。他心智缘识十六识内十三识所缘。谓三界各四部识。除见灭所断。无色界见苦集所断识中。唯取遍行随眠相应识。合为十二识。十三苦集道智品无漏识故。他心智缘缘识。三界四部随眠随增。三重三摩地缘识三界三部。缘缘识三界四部者。三重三摩地通三界九地。唯修所断加行善摄故。十六识内十识所缘。一欲界见苦所断遍行随眠相应识。二欲界见集所断遍行随眠相应识。三欲界修所断善。及染污无覆无记识。如欲界三部识。色无色界各三部识亦尔。合为九识。十无漏识。谓苦集法类智品故。三重三摩地缘识。三界三部随眠随增。三重三摩地缘识。十六识内十三识所缘。谓三界各四部识除见灭所断。合为十二识。十三苦集道智品无漏识故。三重三摩地缘缘识。三界四部随眠随增有身见结缘识三界三部者。谓此结缘识。三界各见苦集修所断三部随眠随增。缘缘识三界四部者。谓此结缘缘识三界各四部随眠随增。除见灭所断有身见。顺下分结有身见边执见亦尔者。谓五顺下分结中有身见。五见中有身见边执见缘识缘缘识随眠随增。亦如三结中有身见结说。戒禁取结缘识三界三部。及见道所断有漏缘者。谓此结缘识。三界各见苦集修所断三部。及见道所断有漏缘随眠随增。缘缘识三界四部者。谓此结缘缘识三界各四部随眠随增。除见灭所断。戒禁取。及戒禁取身系。戒禁取顺下分结。戒禁取亦尔者。谓四取中戒禁取。四身系中戒禁取。五顺下分结中戒禁取。五见中戒禁取。缘缘识。缘缘识随眠随增。亦如三结中戒禁取结说。疑结缘识有漏缘者。谓此结缘识三界各五部有漏缘随眠随增。缘缘识有为缘者。谓此结缘缘识三界各五部有为缘随眠随增。无明漏暴流轭见取。此实执身系。贪慢结疑。顺下分结。邪见见取。意触所生爱身。慢无明见疑随眠。爱慢无明见取疑结亦尔者。谓三漏中无明。四暴流轭中无明。四取中见取。四身系中此实执。五结中贪慢。五顺下分结中疑。五见中邪见见取。六爱身中意触所生爱。七随眠中慢无明见疑。九结中爱慢无明见。及取疑。缘识缘缘识随眠随增。亦如三结中疑结说。三不善根及欲漏缘识。欲界有漏缘色界遍行。及修所断者。谓此四法缘识。欲界五部有漏缘。色界遍行。及修所断随眠随增。缘缘识欲界有为缘。色界三部。无色界遍行。及修所断者。谓此四法缘缘识。欲界五部有为缘。色界见苦集修所断三部。无色界遍行。及修所断随眠随增。欲暴流轭取前二身系。除恶作余盖嗔结。前二顺下分结。欲贪嗔恚随眠恚结亦尔者。谓四暴流轭取中欲。四身系中前二。五盖中除恶作余。五结中嗔。五顺下分结中前二。七随眠中欲贪嗔恚。九结中恚结。缘识随眠随增。亦如三不善根。及欲漏说。有漏缘识。欲界三部。色无色界有漏缘者。谓有漏缘识欲界见苦集修所断三部。色无色界各五部有漏缘随眠随增。缘缘识欲界三部。色无色有为缘者。谓有漏缘缘识。欲界见苦集修所断三部。色无色界各五部有为缘随眠随增。有暴流轭我语取。有贪随眠亦尔者。谓四暴流轭中有。四取中我语。七随眠中有贪。缘识缘缘识随眠随增。亦如三漏中有漏说恶作盖缘识。欲界三部。色界遍行。及修所断者。谓此盖缘识。欲界见苦集修所断三部。色界遍行。及修所断随眠随增。缘缘识欲界四部。色界三部。无色界遍行。及修所断者。谓此盖缘缘识。欲界四部。除见灭所断。色界见苦集修所断三部。无色界遍行。及修所断随眠随增。嫉悭结鼻舌触所生爱身。嫉悭结亦尔者。谓五结中嫉悭。六爱身中鼻舌触所生爱。九结中嫉悭。缘识缘缘识随眠随增。亦如恶作盖说。色贪顺上分结缘识欲色界三部。无色界遍行。及修所断者。谓此结缘识。欲色界见苦集修所断三部。无色界遍行。及修所断随眠随增。缘缘识欲界三部。色无色界四部者。谓此结缘缘识。欲界见苦集修所断三部。色无色界各四部随眠随增除见灭所断。后四顺上分结。缘识三界三部者。谓此结缘识三界各见苦集修所断三部随眠随增。缘缘识欲界三部。色无色四部者。谓此结缘缘识。欲界见苦集修所断三部。色无色界各四部。除见灭所断。随眠随增。眼耳身触所生爱身缘识。欲色界三部者。谓此爱身缘识。欲色界各见苦集修所断三部随眠随增。缘缘识欲色界四部。无色界遍行。及修所断者。谓此爱身缘缘识。欲色界各四部。除见灭所断。无色界遍行。及修所断随眠随增。欲界见苦集。及修所断随眠缘识。欲界三部。色界遍行。及修所断者。谓此随眠缘识。欲界见苦集修所断三部。色界遍行。及修所断随眠随增。缘缘识欲界四部。色界三部。无色界遍行。及修所断者。谓此随眠缘缘识。欲界四部。除见灭所断。色界见苦集修所断三部。无色界遍行。及修所断随眠随增。欲界见灭所断随眠缘识。欲界三部。及见灭所断有漏缘。色界遍行。及修所断者。谓此随眠缘识。欲界见苦集修所断三部。及见灭所断有漏缘。色界遍行。及修所断随眠随增。缘缘识欲界有为缘。色界三部。无色界遍行。及修所断者。谓此随眠缘缘识。欲界五部有为缘。色界见苦集修所断三部。无色界遍行。及修所断随眠随增。欲界见道所断随眠缘识。欲界三部。及见道所断有漏缘。色界遍行。及修所断者。谓此随眠缘识。欲界见苦集修所断三部。及见道所断有漏缘。色界遍行。及修所断随眠随增。缘缘识。欲界四部。色界三部。无色界遍行。及修所断者。谓此随眠缘缘识。欲界四部除见灭所断。色界见苦集修所断三部。无色界遍行。及修所断随眠随增色界见苦集。及修所断随眠缘识。欲色界三部无色界遍行。及修所断者。谓此随眠欲色界各见苦集修所断三部。无色界遍行。及修所断随眠随增。缘缘识。欲界三部。色无色界四部者。谓此随眠缘缘识。欲界见苦集修所断三部。色无色界各四部。除见灭所断。随眠随增色界见灭所断随眠缘识。欲色界三部。及色界见灭所断有漏缘。无色界遍行。及修所断者。谓此随眠缘识欲色界各见苦集修所断三部。及色界见灭所断有漏缘。无色界遍行。及修所断随眠随增。缘缘识。欲界三部。色界有为缘。无色界四部者。谓此随眠缘缘识。欲界见苦集修所断三部。色界五部有为缘。无色界四部。除见灭所断随眠随增。色界见道所断随眠缘识。欲色界三部。及色界见道所断有漏缘。无色界遍行。及修所断者。谓此随眠缘识。欲色界各见苦集修所断三部。及色界见道所断有漏缘。无色界遍行。及修所断随眠随增。缘缘识。欲界三部。色无色界四部者。谓此随眠缘缘识。欲界见苦集修所断三部。色无色各四部。除见灭所断随眠随增。无色界见苦集。及修所断随眠缘识。三界三部者。谓此随眠缘识。三界各见苦集修所断三部随眠随增。缘缘识。欲界三部。色无色界四部者。谓此随眠缘缘识。欲界见苦集修所断三部。色无色界各四部。除见灭所断随眠随增。无色界见灭所断随眠缘识。三界三部。及无色界见灭所断有漏缘者。谓此随眠缘识。三界各见苦集修所断三部。及无色界见灭所断有漏缘随眠随增。缘缘识。欲界三部。色界四部。无色界有为缘者。谓此随眠缘缘识。欲界见苦集修所断三部。色界四部。除见灭所断。无色界五部。有为缘随眠随增。无色界见道所断随眠缘识。三界三部。及无色界见道所断有漏缘者。谓此随眠缘识。三界各见苦集修所断三部。及无色界见道所断有漏缘随眠随增。缘缘识。欲界三部。色无色界四部者。谓此随眠缘缘识。欲界见苦集修所断三部。色无色界各四部。除见灭所断随眠随增

问何故此中但说缘识及缘缘识。不说缘缘缘识等耶。答为遮展转无穷过故。谓若更说第三缘识。复应更说第四缘识。如是展转即为无穷。复次如等无间缘但应思惟至第二转。不应思惟第三转等。所缘缘亦应尔。复次诸法缘识。与缘缘识随眠随增。多分有异。故定应说。第三转等随眠随增。多分无异故不复说。复次阿毗达磨略示方隅。令开智者展转悟入。故不复说第三转等

意根乃至无色界修所断无明随眠。于三界十五部心中。一一等无间生几心耶。问何故作此论。答为止他宗显正理故。谓或有说心与心为等无间缘非心所。心所与心所为等无间缘非心。如譬喻者。为遮彼意显心心所展转能作等无间缘。非唯相似故作斯论。此中欲显等无间缘。是故唯问心心所法。问此中何故但问生有漏心。不问生无漏心耶。答此是结蕴。唯有漏心。能增长结。故偏说之。问分别诸结但依五部。今何故问十五心耶。答今此蕴中非唯蕴结。亦显结事。此通三界故。问三界十五部心。心心所中心最为胜。故此独问不问心所。此中生者说正生时。等无间缘作用时故

说一切心总有十六。即前十五及无漏心。问此十六心展转相望各从几生。复各生几。答欲界前四部心。各从十五心生。除无漏心。唯能生欲界五部心。非下地染污心能生上地心故。亦非染污心能生无漏心故。欲界修所断心从十六心生。复能生十六心。色界前四部心从十一心生除欲界前四部心及无漏心。唯能生欲色界十心。色界修所断心从十二心生。除欲界前四部心。复能生十六心。无色界前四部心从七心生。谓自界五部心。及欲色各修所断心。复能生十五心。除无漏心。无色界修所断心从八心生。谓自界五部心欲色界各修所断心。及无漏心。复能生十六心。无漏心从四心生。复能生四心。谓三界各修所断心及无漏心。非无漏心与染污心相入出故。此中总据一切有情。或一切时容有而说。非但说一补特伽罗。于一刹那有如是事

意根等无间生十五心者。十六心中除无漏心。非所说故。此则总说。有差别者。若未离欲界染欲界意根等无间容生六心。谓欲界五及色界修所断心。即未至定加行善心。若已离欲界染未离色界染。欲界意根等无间容生十心。谓欲界五如退等时。及色界五如续生等时。若已离色界染欲界意根等无间容生十一心。谓欲界五如退等时。色界一如入定时。无色界五如续生时。若未离色界染色界意根等无间容生十一心。谓欲界五如续生或退等时。色界五无色界修所断心。即空无边处近分加行善心等如入定时。若已离色界染色界意根等无间容生十一心。谓欲界修所断心即通果心等。色界五如退等时。无色界五如续生等时。无色界意根等无间容生十五心。谓欲界五如续生时。色界五如续生退等时。及无色界五。舍及信等五根亦尔者。生十五心如意根故。乐根等无间生十一心者。谓欲色界各五。及无色界修所断心。即第三静虑乐根等无间。超入空无边处有漏定故乐等四受及五识身必不命终故。等无间不生无色前四部心。苦根等无间生五心者。谓欲界五忧根亦尔者。亦生五心如苦根故。非从忧苦能入定心。彼与定心极相违故。喜根等无间生十心者。谓欲色界各五部心。欲界喜根生欲界五。色界喜根生色界五。非欲界喜根等无间。生色界染污喜俱心亦非色界喜根等无间生欲界染污喜俱心。喜根唯能引自地烦恼故。此中有说。色界喜根等无间生欲界善无记心。欲界喜根等无间。不生色界善无记心。要欲界舍根等无间能生色界心等故未知当知根等无间不生心者。不生三界十五心故。即由此义经说见道名无相者。无间不生有漏心故。已知俱知根等无间生三心者。谓三界修所断善心。此中得预流一来果已或以欲界心出。或以未至定心出。得不还果已若依未至定者。亦以此二心出。若依余五地者。皆以自地出。得阿罗汉果已若依未至定者。或以欲界心出。或以未至定心出。若依无所有处者或以无所有处心出。或以非想非非想处心出。若依余地者。皆以自地心出

眼耳身识界生十心者。谓欲色界各五部。唯生自界鼻舌识界。生五心者谓欲界五部。无漏法生三心者。谓三界修所断。过去法生二心者。谓色无色界修所断。即出灭定无想异熟。无想定心至生用时。过去能入心心所法。尔时方有等无间缘取与果用。问出无想异熟心为通色界五部。为但修所断耶。设尔何失。二俱有过。所以者何。若通色界五部。此中何故不说。谓此中应说过去生六心。何故但言过去生二。若但修所断根蕴所说当云何通。如说。彼想起已彼诸有情从彼处殁。彼想应言或善或无记。于彼想色界有漏缘随眠随增。答应作是说出无想异熟心通色界五部。问若尔。此中何故不说。答应说而不说者。当知此义有余。复次此中但说出无想灭定心加行功用力所引故。出无想异熟心非加行功用力所引起。故此不说。复次此中但说唯是善心出。无想异熟心或善或染或无记。故此不说。有作是说。出无想异熟心唯修所断。问根蕴所说当云何通。答彼文应作是说。于彼想色界遍行随眠随增。然遮无漏缘故说有漏缘随眠随增。评曰。此二说中前说为善。问何故彼想非无漏缘随眠随增。答彼执无想为涅槃。执无想定为圣道。是故尔时不起邪见拨无灭道。从此以后容起邪见。未来法不生心者非等无间缘故。四无量生六心者。谓色界五部及欲界修所断。缘欲界故。缘有情故。不能引起无色界心前二解脱。前四胜处。应知亦尔。缘欲界故。第四第五解脱生六心者。谓无色界五部。及色界修所断。他心智生六心者。谓色界五部及欲界修所断。五通等无间不能引起无色界心。第三解脱。后四胜处。前八遍处。生五心者。谓色界五部皆事别观。不能引起无色界心。后二遍处生五心者。谓无色界五部是假想观。不能引起色界定心。第八解脱不生心者。虽是心等无间而非心等无间缘故。法智生二心者。谓欲色界修所断心。缘欲界四谛故。不能引起无色界心。色贪顺上分结生二心者。谓欲色界修所断心下地染心不生上故。后四顺上分结生三心者。谓三界修所断心。由此五结不还身中方现行故。余文易了。故不分别

说一切有部发智大毗婆沙论卷第八十九阿毗达磨大毗婆沙论卷第九十

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中十门纳息第四之二十

眼根乃至无色界修所断无明随眠。一一所增随眠当言有寻有伺无寻唯伺无寻无伺耶。问何故作此论。答为止他宗显正理故。谓或有说。寻伺是心粗细相故乃至有顶。诸染污心皆有寻伺。是故寻伺三界皆有。如譬喻者。为遮彼执显唯欲界及初静虑。未至定中有寻有伺。静虑中间无寻唯伺。第二静虑乃至有顶无寻无伺。由此因缘故作斯论。眼根所增随眠具三者。谓缘眼根所增随眠。通欲界四静虑五地遍行及修所断。如是随眠若在欲界及初静虑有寻有伺。若在静虑中间无寻唯伺。若在第二第三第四静虑无寻无伺故说具三。后说具三者皆准此应知。然无寻无伺地。或多或少。女根所增随眠。有寻有伺者。彼所增随眠唯在欲界故。眼耳身识界所增随眠。或有寻有伺或无寻唯伺者。眼等五识虽有寻有伺。而在初静虑者。亦为静虑中间随眠作所缘缚故。彼所增随眠亦通无寻唯伺。初静虑所增随眠。或有寻有伺或无寻唯伺者。初静虑言总显未至根本静虑中间三地诸法故说有二。设唯显根本亦必有二。静虑中间初静虑等所有随眠缘三地故。余文易了故不分别

眼根乃至无色界修所断无明随眠一一所增随眠。当言乐根苦根喜根忧根舍根相应耶。问何故作此论。答为止他宗显正理故。谓或有执。乐苦二受随所依身。从欲界乃至第四静虑皆有。喜忧二受随所依心。从欲界乃至非想非非想处皆有。为遮彼意欲显乐受唯在欲界初及第三静虑。苦忧二受唯在欲界。喜受唯在欲界初二静虑。唯有舍受遍在诸地。或复有执。心心所法次第而起互不相应。如譬喻者。为遮彼意显心心所俱时而生有相应义。由此因缘故作斯论。眼根所增随眠四根相应除苦根者。眼根所增随眠通欲色界五地遍行及修所断。若在欲界喜忧舍根相应。若在初二静虑喜舍根相应。若在第三静虑乐舍根相应。若在第四静虑唯舍根相应。是故总说四根相应。苦根唯与五识相应。五识中无缘眼根等诸随眠故彼定不与苦根相应。女根所增随眠三根相应除乐苦根者。女根所增随眠唯在欲界。欲界乐苦俱在五识故。彼不与乐苦相应。意根所增随眠五根相应者。意根通与五受相应故相应缚五根相应。若所缘缚有四除苦。三重三摩地所增随眠。四根相应除苦根者。苦根唯缘色等五境非定等故。三三摩地唯无漏故。不增随眠非此所说余文易了不复分别。恐诸智者生厌惓故

眼根乃至无色界修所断无明随眠。谁成就。谁不成就。问何故作此论。答为止他宗显正理故。谓或有执。无实成就不成就性唯假建立。欲显成就不成就性是实有物。若不尔者。便违契经。如契经说。应知如是补特伽罗成就善法及不善法。又契经说。我成就十力四无所畏等。若无成就不成就性。异生圣者有学无学断善根者不断善者。决定建立皆不得成。决定因缘不可得故。然成就者不成就者是世俗有。若成就性不成就性是胜义有。如死生者是世俗有。诸死生法是胜义有。入出定者是世俗有。所入出定是胜义有。作者受者是世俗有。业异熟果是胜义有。如是成就不成就性是胜义有。施设成就不成就者是世俗有。谓若身中有成就性名成就者。若彼身中有不成就性名不成就者。如树等是假色等。四尘是实。如是补特伽罗是假。色等五蕴是实。于此假者身相续中。依得非得说有成就不成就法。由此因缘故作斯论

眼根色界及欲界已得不失。成就者。色界诸天皆具根故。决定成就眼等五根。此具根言依显者说。女男根不显无亦名具根。又容有者彼皆成就故说具根。非一切有勿忧苦等彼亦有故。及欲界已得者。谓钵罗奢佉位以彼不失者。谓不烂坏不堕落不虫食不被害。无色界及欲界未得已失不成就者。无色界无色故不成就眼等根。及欲界未得者。谓羯刺蓝頞部昙闭尸键南位。已失者。谓烂坏堕落虫食被害耳鼻舌根亦尔者。如眼根说身根欲色界成就者。有色界生必有身根故。无色界不成就者彼无色故。女男根欲界已得不失成就者。如眼根说。色无色界及欲界。未得已失不成就者。色无色界无女男根无淫爱故。厌舍此根生彼界故。色无色界无段食故。必因段食有此根故。因无惭愧有此根故。又女男根彼无用故。问若尔。鼻舌彼亦应无。彼无嗅香尝味事故。答鼻舌二根于彼有用。谓庄严身及起言说。女男二根令身丑陋。有惭愧者必隐覆之。尊者妙音作如是说。上二界无招彼业故。问色无色界既无男根应非丈夫。答色无色界有丈夫用故名丈夫。丈夫用者。谓能离欲能成善事故名丈夫。如契经说。四向四果皆名丈夫。非诸女人皆无向果。如契经说。此大生主。虽是女人而入圣道。得果尽漏亦名丈夫。于此义中应作四句。或有丈夫不成就男根。谓生色无色界等。或有成就男根而不名丈夫。如扇搋半择迦等。或有丈夫亦成就男根。谓具男根离欲染等。或有非丈夫亦不成就男根。谓除前相。胎卵湿生渐命终者。渐舍眼等六种色根。于身根中亦有渐舍。谓手足等。若舍一切身根极微即便命终。若地狱中解诸支节。乃至糜烂亦有身根。有说。尔时亦有眼等。若全无者。后应不生。异熟断已后不续故。有作是说。诸地狱中眼等六根断已更续。业所引故。趣法尔故。如人等中支节断坏不可还续。地狱等中支节断已寻复续生。诸趣法尔不可相例。故彼眼等断已还生。身根必无全分断者。若全分断无更续义。是诸色根所依止故。彼有少分身根极微。依此后时还生支节。诸支节内所有身根断已还生如眼根等。有余师说。诸地狱中虽解身支为百千分。而诸分内皆有身根。诸分中间有连续故。如碎杜仲及藕根茎。亦如破苽蔕不相离。若相离者身根即无。非一有情有二身故。而世现见断诸虫身。为多分已犹行动者。风势所转非有身根。命意舍根一切有情皆成就者。皆通三界九地诸位恒成就故。乐根遍净以下及圣者生上成就。异生生上不成就者乐根唯在欲界初及第三静虑。通有漏无漏。欲界初静虑者唯有漏。第三静虑者通二种。诸有漏者生上舍下故不成就。诸无漏者生上地时不舍下地。无漏唯有得果转根退时舍故。问若生第二静虑未离第二静虑染。彼成就何地乐根。答彼成就第三静虑染污乐根。若彼已离第二静虑染。复得第三静虑无染乐根。是故若生遍净以下皆成就乐根。此遍净言总显自地举后显前。余皆准此。问颇有圣者生在第四静虑以上不成就乐根耶。有说亦有。谓已离第三静虑染。依第二静虑及下三地入正性离生。得不还果已不起后向。命终往生第四静虑以上诸地。彼不成就乐根。评曰。彼不应作是说。若已离上地染依下地入正性离生者。彼得果已必起胜果道。修上地无漏得上地灭然后命终。如已离欲界三四品。或七八品染。入正性离生。彼得果已必起胜果道。修胜品无漏得胜品灭然后命终。问若已离第三静虑染。依第二静虑及下三地。信胜解练根作见至。彼不起后向命终往生第四静虑以上诸地。彼成就何乐根。答彼于上地若得自在当练根时。亦能修上无漏乐根。设于上地不得自在。彼得果已亦必起胜果道修上无漏然后命终是故圣者生遍净上。决定成就无漏乐根。成就喜根准此应说。苦根欲界成就。色无色界不成就者。欲界有情乃至佛亦成就苦根。违境逼时不由分别而生苦故。色无色界无苦根者。由胜定力所滋润故。无违境故。无有不善业烦恼故。又色无色是胜界故。谓劣界中胜身亦有苦受。如欲界声闻及独觉大觉。若胜界中劣身亦无苦受。如色无色界异生。如有灾秋时嘉苗。亦遭虫食等事。无灾秋时秽草亦无虫食等事。忧根未离欲染成就。已离欲染不成就者。忧根必由分别而起。未离欲者分别生忧。已离欲者起分别时不生忧戚。是故忧根是善性者若离欲染亦不成就。欲界烦恼所引发故。三无漏根已得不失。成就未得。已失不成就者。谓未知当知根已入见道名已得。道类智未现在前名不失。苦法智忍未现在前名未得。道类智现前以后名已失。已知根已起道类智或退阿罗汉果名已得。尽智未现在前名不失。道类智未现在前或未退阿罗汉果名未得。尽智现前以后名已失。具知根尽智现在前名已得。不退阿罗汉果名不失。尽智未现在前名未得。退阿罗汉果名已失。身色声触界。欲色界成就。无色界不成就者。问身色触界可尔。声界云何恒时成就。有作是说。大种合离必生声界。有情若在欲色界中。大种恒有故常发声。评曰彼不应作是说。若四大种必恒生声。此所生声何大种造。若即此造应名有对色一四大种生。若说余造余四大种复必生声。如是展转有无穷过。应作是说。生欲色界有情身中。多四大种在一身内。有相击者便发生声。不相击者即无声起。虽一身中必有声界。非诸身分皆遍发声。尊者觉天作如是说。非欲色界恒成就声。此本论文依多分说。眼耳身识界。梵世以下及生上三静虑。现在前成就。不现在前。及无色界不成就者。谓生欲界及初静虑。随其所应成就。染污或善三识诸无记中。有惯习者亦恒成就。如胜威仪工巧通果。若生第二静虑以上。唯无记者时有现前即便成就。若不现前则不成就。以五识身性羸劣故。他地现起势不坚强。若意识中变化心等。设生他地势亦坚强故不现前亦得成就。无漏无为如意界等恒成就者。谓非择灭一切有情无不成就非择灭故。后无断法准此应知。三重三摩地如道谛等。已得成就未得不成就者。得已必无退舍事故。将般涅槃方修得故。般涅槃已非有情数。故不可说不成就言。余文易了故不分别

眼根乃至无色界。修所断无明随眠一一得遍知时。于九十八随眠中。几随眠得遍知。于九结中几结尽。问何故作此论。答为止他宗显正理故。谓或有执。色法亦有见所断者。为遮彼意显诸色法非见所断。或复有执。异生不能断见所断随眠。有余复执。异生不能断诸随眠唯能制伏。为遮彼意显诸异生能断欲界乃至无所有处见修所断随眠。唯除有顶。故作斯论。然诸遍知略有二种。一智遍知。二断遍知。此中但依断遍知而作论。断是择灭虽非遍知是遍知果故名遍知。如六触处说名故业果立因名。遍知亦尔又此中说得遍知者。谓断彼尽随断何法。究竟尽时名得遍知。非要唯依九遍知说。眼根得遍知时色爱尽者。谓眼根在五地。即欲界四静虑欲爱尽时。欲界眼根得遍知。乃至第四静虑爱尽时第四静虑眼根得遍知。今依究竟得遍知说。故色爱尽名得遍知。余皆准此。异生三十一随眠得遍知者。异生尔时断色界见修所断三十一随眠尽。故无结尽者。谓九结中尔时无一究竟尽故。虽诸随眠亦名为结。而此中说差别法门。谓说随眠依九十八。说结依九。余例应知。圣者三随眠得遍知者。圣者尔时唯色界修所断三随眠得遍知故。无结尽者。谓九结中无一结尽。女男根得遍知时欲爱尽者。谓女男根唯在欲界故。欲爱尽名得遍知。异生三十六随眠得遍知者。异生尔时断欲界见修所断三十六随眠尽故。三结尽者。谓九结中尔时恚嫉悭结究竟尽故。圣者四随眠得遍知者。圣者尔时唯欲界修所断四随眠得遍知故。三结尽者如异生说。然恚结中唯修所断命根得遍知时。无色爱尽者。谓命根在九地欲爱尽时。欲界命根得遍知。乃至非想非非想处爱尽时。非想非非想处命根得遍知。今依究竟得遍知说。故无色爱尽名得遍知。三随眠得遍知者。尔时断无色界修所断三随眠尽故。三结尽者。谓九结中爱慢无明三结尽故。乐根得遍知时。遍净爱尽即乐根得遍知者。尔时不得九十八随眠中一随眠究竟尽。故作是说。余例应知。然得遍知有十七位。谓四法忍智四类忍智时。唯得见所断诸法遍知。欲界乃至无所有处。八地爱尽时通得见修所断诸法遍知。非想非非想处一地爱尽时。唯得修所断诸法遍知。诸法于此十七位中名得遍知。随相应说恐文繁广不别显示

眼根乃至无色界修所断无明随眠。一一灭作证时。于九十八随眠中。几随眠灭作证。于九结中几结尽。问何故作此论。答为止他宗显正理故。谓或有执。金刚喻定现在前时。顿断一切三界见修所断烦恼。此前诸位唯能伏缠于诸随眠皆未能断。如顿断沙门。彼说顿觉得无学果。如梦觉时顿舍惛睡。为遮彼意显断随眠。分位差别有八十九。此诸位中皆证灭故。或复有执。唯无间道断随眠得。唯解脱道能证彼灭。如西方沙门彼作是说。非无间道不断烦恼。非解脱道不证彼灭。为遮彼意显无间道能断烦恼。隔烦恼得令不续故。亦能证灭引离系得令正起故。诸解脱道唯名证灭。与离系得俱现前故。又为显示灭作证理令智者知故作斯论。于法作证略有二种。一智作证。二得作证。智作证者。谓一切法智。能证知。得作证者。谓诸善法通果无记得能证获。此中唯依得作证说。于中但依灭作证说。灭谓择灭。于诸位中起得证灭名灭作证。此灭作证随位差别有八十九。谓四法忍智四类忍智时。及九地各九无间解脱道时四法类忍智时唯证见所断法灭。非想非非想处前八无间解脱道时。唯证修所断法灭。余七十三时通证见修所断法灭。又灭作证总有五位。谓各自品对治道时。及证得四沙门果时。并练根时。应说有六而练根时必得果故即四果摄故说五时。三界见修所断烦恼于此五位。灭作证时有具不具。或有烦恼唯有一时。谓非想非非想处第九品修所断。即证得阿罗汉果时。或有烦恼唯有二时。谓非想非非想处前八品修所断。及下七地各九品修所断。即各自品对治道时。及证得阿罗汉果时。欲界第九品修所断亦二时。谓证得后二果时。或有烦恼唯有三时。谓欲界第七八品修所断即各自品对治道时。及证得后二沙门果时。欲界第六品修所断亦三时。谓证得后三沙门果时。或有烦恼唯有四时。谓色无色界见道所断。即证得四沙门果时。欲界前五品修所断亦四时。谓各自品对治道时。及证得后三沙门果时。或有烦恼具有五时。谓三界见苦集灭所断。及欲界见道所断。即各自品对治道时。及证得四沙门果时。此依圣者灭作证说。若依异生八地见修所断烦恼。皆唯自品对治道时名灭作证。余有漏法灭作证时准前烦恼应知。分位历眼根等四十二章辩灭作证如本论说

问前遍知门与此灭作证门有何差别。答前遍知门显眼根等究竟尽时得断差别。灭作证门显眼根等究竟尽时。及后诸位证灭差别。谓后诸位复数证得眼根等灭一味得故。西方诸师作如是说。前遍知门显无间道断烦恼得。灭作证门显解脱道证离系得。此国诸师作如是说。前遍知门唯显无间道断烦恼得。灭作证门通显无间解脱道证离系得。复次前遍知门唯显初位得断遍知。灭作证门通显初后于灭作证。是谓遍知与灭作证二门差别

此十门中通前所说四十二章有五位别。谓前所说四十二章总有三类。谓二十二根。乃至见修所断。无断法名境界类。四圣谛乃至三重三摩地名功德类。三结乃至九十八随眠名过失类。境界类中二十二根。最初多故别作一位。过失类中九十八随眠。最后多故别作一位。余三类法各作一位故合有五。于五位中有相似者各略相类。不相似者各广分别。智者于此应善了知

此中尊者略以十门。通前所说四十二章。于中差别复有多种。谓眼根乃至无色界修所断无明随眠灭。缘识及缘缘识。于九十八随眠中。一一有几随眠随增。眼根乃至无色界修所断无明随眠断道缘识。及缘缘识一一有几随眠随增。眼根乃至无色界修所断无明随眠。缘识及缘缘识所增随眠。几无所缘缚非相应缚。几为相应缚非所缘缚。几为所缘缚亦相应缚。几非所缘缚亦非相应缚。眼根乃至无色界修所断无明随眠灭。缘识及缘缘识所增随眠。几为所缘缚非相应缚。几为相应缚非所缘缚。几为所缘缚亦相应缚。几非所缘缚亦非相应缚。眼根乃至无色界修所断无明随眠断道。缘识及缘缘识所增随眠。几为所缘缚非相应缚。几为相应缚非所缘缚。几为所缘缚亦为相应缚。几非所缘缚亦非相应缚。眼根乃至无色界修所断无明随眠。缘识及缘缘识。于三界十五部心中。一一等无间生几心。眼根乃至无色界修所断无明随眠。缘识及缘缘识所增随眠。一一等无间生几心。眼根乃至无色界修所断无明随眠灭。缘识及缘缘识一一等无间生几心。眼根乃至无色界修所断无明随眠灭。缘识及缘缘识所增随眠。一一等无间生几心。眼根乃至无色界修所断无明随眠断道。缘识及缘缘识。一一等无间生几心。眼根乃至无色界修所断无明随眠断道。缘识及缘缘识所增随眠。一一等无间生几心。眼根乃至无色界修所断无明随眠。缘识及缘缘识。当言有寻有伺。无寻唯伺。无寻无伺耶。眼根乃至无色界修所断无明随眠。缘识及缘缘识所增随眠。当言有寻有伺。无寻唯伺。无寻无伺耶。眼根乃至无色界修所断无明随眠灭。缘识及缘缘识。当言有寻有伺。无寻唯伺。无寻无伺耶。眼根乃至无色界修所断无明随眠灭。缘识及缘缘识所增随眠。当言有寻有伺。无寻唯伺。无寻无伺耶。眼根乃至无色界修所断无明随眠断道。缘识及缘缘识。当言有寻有伺。无寻唯伺。无寻无伺耶。眼根乃至无色界修所断无明随眠断道。缘识及缘缘识所增随眠当言有寻有伺。无寻唯伺。无寻无伺耶。眼根乃至无色界修所断无明随眠。缘识及缘缘识当言乐苦喜忧舍根相应耶。眼根乃至无色界修所断无明随眠。缘识及缘缘识所增随眠。当言乐乃至舍根相应耶。眼根乃至无色界修所断无明随眠灭。缘识及缘缘识。当言乐乃至舍根相应耶。眼根乃至无色界修所断无明随眠灭。缘识及缘缘识所增随眠。当言乐乃至舍根相应耶。眼根乃至无色界修所断无明随眠断道。缘识及缘缘识。当言乐乃至舍根相应耶。眼根乃至无色界修所断无明随眠断道。缘识及缘缘识所增随眠。当言乐乃至舍根相应耶。眼根乃至无色界修所断无明随眠。缘识及缘缘识。谁成就谁不成就。眼根乃至无色界修所断无明随眠。缘识及缘缘识所增随眠。谁成就谁不成就。眼根乃至无色界修所断无明随眠灭。缘识及缘缘识。谁成就谁不成就。眼根乃至无色界修所断无明随眠灭。缘识及缘缘识所增随眠。谁成就谁不成就眼根乃至无色界修所断无明随眠断道。缘识及缘缘识。谁成就谁不成就。眼根乃至无色界修所断无明随眠断道。缘识及缘缘识所增随眠。谁成就谁不成就。眼根乃至无色界修所断无明随眠。缘识及缘缘识。得遍知时。于九十八随眠中。几随眠得遍知。于九结中几结尽。眼根乃至无色界修所断无明随眠。缘识及缘缘识所增随眠得遍知时。几随眠得遍知。几结尽。眼根乃至无色界修所断无明随眠灭。缘识及缘缘识。得遍知时。几随眠得遍知。几结尽。眼根乃至无色界修所断无明随眠灭。缘识及缘缘识所增随眠。得遍知时。几随眠得遍知。几结尽。眼根乃至无色界修所断无明随眠断道。缘识及缘缘识得遍知时。几随眠得遍知。几结尽。眼根乃至无色界修所断无明随眠断道。缘识及缘缘识所增随眠。得遍知时。几随眠得遍知。几结尽。眼根乃至无色界修所断无明随眠。缘识及缘缘识。灭作证时。于九十八随眠中。几随眠灭作证。于九结中几结尽。眼根乃至无色界修所断无明随眠。缘识及缘缘识所增随眠。灭作证时。几随眠灭作证。几结尽。眼根乃至无色界修所断无明随眠灭。缘识及缘缘识所增随眠。灭作证时。几随眠灭作证。几结尽。眼根乃至无色界修所断无明随眠灭。缘识及缘缘识所增随眠。灭作证时。几随眠灭作证。几结尽。眼根乃至无色界修所断无明随眠断道。缘识及缘缘识。灭作证时。几随眠灭作证。几结尽。眼根乃至无色界修所断无明随眠断道。缘识及缘缘识所增随眠。灭作证时。几随眠灭作证。几结尽。眼根乃至无色界修所断无明随眠。各九结中几结所系。三缚中几缚所缚。十随眠中几随眠随增。六垢中几垢所染。十缠中几缠所缠。眼根乃至无色界修所断无明随眠。缘识及缘缘识。几结所系。乃至几缠所缠。眼根乃至无色界修所断无明随眠灭。缘识及缘缘识几结所系。乃至几缠所缠。眼根乃至无色界修所断无明随眠断道。缘识及缘缘识几结所系。乃至几缠所缠成就。眼根乃至无色界修所断无明随眠者。几结所系。乃至几缠所缠成就。眼根乃至无色界修所断无明随眠。缘识及缘缘识者。几结所系。乃至几缠所缠成就。眼根乃至无色界修所断无明随眠灭者。几结所系。乃至几缠所缠成就。眼根乃至无色界修所断无明随眠灭。缘识及缘缘识者。几结所系。乃至几缠所缠成就。眼根乃至无色界修所断无明随眠断道者。几结所系。乃至几缠所缠成就。眼根乃至无色界修所断无明随眠断道。缘识及缘缘识者。几结所系。乃至几缠所缠不成就。眼根乃至无色界修所断无明随眠者。几结所系。乃至几缠所缠不成就。眼根乃至无色界修所断无明随眠。缘识及缘缘识者。几结所系。乃至几缠所缠不成就。眼根乃至无色界修所断无明随眠灭者。几结所系。乃至几缠所缠不成就。眼根乃至无色界修所断无明随眠灭。缘识及缘缘识者。几结所系。乃至几缠所缠不成就。眼根乃至无色界修所断无明随眠断道者。几结所系。乃至几缠所缠不成就。眼根乃至无色界修所断无明随眠断道。缘识及缘缘识者。几结所系。乃至几缠所缠。如是种类有无量门。通前所说四十二章。诸有智者应随决择

说一切有部发智大毗婆沙论卷第九十阿毗达磨大毗婆沙论卷第九十一

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中十门纳息第四之二十一

眼根乃至无色界。修所断无明随眠灭。缘识及缘缘识。于九十八随眠中。一一有几随眠随增。答眼根灭缘识。欲色界二部。及遍行随眠随增。缘缘识。欲色界有为缘。无色界二部。及遍行随眠随增。耳鼻舌身乐喜根灭缘识。及缘缘识亦尔。女根灭缘识。欲界二部。及遍行。色界遍行。及修所断随眠随增。缘缘识。欲界有为缘。色界三部。无色界遍行。及修所断随眠随增。男苦忧根灭缘识。及缘缘识亦尔。命根灭缘识。三界二部。及遍行随眠随增。缘缘识。三界有为缘随眠随增。意舍信等五根灭缘识。及缘缘识亦尔。通余章义准此应知

眼根乃至无色界修所断无明随眠断道。缘识及缘缘识。一一有几随眠随增。答眼根断道。缘识及缘缘识。三界四部随眠随增。耳鼻舌身命意舍信等五根断道。缘识及缘缘识亦尔。女根断道缘识。欲界四部。色界三部随眠随增。缘缘识欲色界四部。无色界二部。及遍行随眠随增。男苦忧根断道。缘识及缘缘识亦尔。乐根断道。缘识欲色界四部。无色界二部。及遍行随眠随增。缘缘识。三界四部随眠随增喜根断道。缘识及缘缘识亦尔。通余章义准此应知

眼根乃至无色界修所断无明随眠。缘识及缘缘识所增随眠。几为所缘缚非相应缚。几为相应缚非所缘缚。几为所缘缚亦相应缚。几非所缘缚亦非相应缚。答眼根缘识所增随眠。有为所缘缚非相应缚。谓欲色界见苦集所断不遍行。无色界遍行。及修所断随眠。有为相应缚非所缘缚。谓缘眼根欲色界他界地缘。遍行随眠。有为所缘缚亦相应缚。谓欲色界遍行。及修所断随眠。眼根缘识所增随眠。非所缘缚亦非相应缚者无也。若非此所增随眠。而于此非所缘缚亦非相应缚者。谓三界二部。及无色界见苦集所断不遍行随眠。眼根缘缘识所增随眠。有为所缘缚非相应缚。谓三界见道所断有漏缘。及无色界见苦集所断。不遍行随眠。有为相应缚非所缘缚。谓三界见道所断无漏缘。及欲色界他界地缘遍行随眠。有为所缘缚亦相应缚。谓欲色界三部。无色界遍行。及修所断随眠。眼根缘缘识所增随眠。非所缘缚亦非相应缚者无也。若非此所增随眠。而于此非所缘缚。亦非相应缚者。谓三界见灭所断一切随眠耳鼻舌身根缘识。及缘缘识所增随眠亦尔。女根缘识所增随眠。有为所缘缚非相应缚。谓欲界见苦集所断不遍行。色界遍行。及修所断随眠。有为相应缚非所缘缚者无也。有为所缘缚亦相应缚。谓欲界遍行。及修所断随眠。女根缘识所增随眠。非所缘缚亦非相应缚者无也。若非此所增随眠。而于此非所缘缚。亦非相应缚者。谓欲色界二部。色界见苦集所断不遍行。及无色界一切随眠。女根缘缘识所增随眠。有为所缘缚非相应缚。谓欲界见道所断有漏缘。色界见苦集所断不遍行。无色界遍行。及修所断随眠。有为相应缚非所缘缚。谓欲界见道所断无漏缘。及欲色界他界地缘遍行随眠。有为所缘缚亦相应缚。谓欲界三部色界遍行。及修所断随眠。女根缘缘识所增随眠。非所缘缚亦非相应缚者无也。若非此所增随眠。而于此非所缘缚。亦非相应缚者。谓欲界见灭所断。一切色无色界二部。及无色界见苦集所断不遍行随眠。男苦根缘识。及缘缘识所增随眠亦尔。命根缘识所增随眠。有为所缘缚非相应缚。谓三界见苦集所断不遍行随眠。有为相应缚非所缘缚。谓缘命根三界他界地缘遍行随眠。有为所缘缚亦相应缚。谓三界遍行及修所断随眠。命根缘识所增随眠。非所缘缚。亦非相应缚者无也。若非此所增随眠。而于此非所缘缚。亦非相应缚者。谓三界三部随眠。命根缘缘识所增随眠。有为所缘缚非相应缚。谓三界见道所断有漏缘随眠。有为相应缚非所缘缚。谓三界见道所断无漏缘。及三界他界地缘遍行随眠。有为所缘缚亦相应缚。谓三界三部随眠。命根缘缘识所增随眠。非所缘缚亦非相应缚者无也。若非此所增随眠。而于此非所缘缚。亦非相应缚者。谓三界见灭所断一切随眠。意根缘识。及缘缘识所增随眠。有为所缘缚非相应缚者无也。有为相应缚非所缘缚。谓三界见道所断无漏缘。及缘意根三界他界地缘遍行随眠。有为所缘缚亦相应缚。谓三界有漏缘随眠。意根缘识所增随眠。非所缘缚亦非相应缚者无也。若非此所增随眠。而于此非所缘缚。亦非相应缚者。谓三界无为缘随眠。舍根缘识及缘缘识所增随眠亦尔。乐根缘识所增随眠。有为所缘缚。非相应缚。谓欲无色界见道所断有漏缘。欲界见苦集所断不遍行。无色界遍行。及修所断随眠。有为相应缚非所缘缚。谓三界见道所断无漏缘。及缘乐根欲色界他界地缘遍行随眠。有为所缘缚亦相应缚。谓欲界遍行修所断。及色界有漏缘随眠。乐根所增随眠。非所缘缚。亦非相应缚者无也。若非此所增随眠。而于此非所缘缚。亦非相应缚者。谓欲无色界。见灭所断一切色界见灭所断无为缘。无色界见苦集所断不遍行随眠。乐根缘缘识所增随眠。有为所缘缚非相应缚。谓无色界见苦集所断不遍行随眠。有为相应缚非所缘缚。谓三界见道所断无漏缘。及三界他界地缘遍行随眠。有为所缘缚亦相应缚。谓欲界三部见道所断有漏缘。色界一切有漏缘。无色界遍行。修所断见道所断。有漏缘随眠。乐根缘缘识所增随眠。非所缘缚亦非相应缚者无也。若非此所增随眠。而于此非所缘缚。亦非相应缚者。谓欲无色界见灭所断一切及色界见灭所断无为缘随眠。喜根缘识所增随眠。有为所缘缚非相应缚。谓无色界遍行。修所断及见道所断。有漏缘随眠。有为相应缚非所缘缚。谓三界见道所断无漏缘。及缘喜根欲色界他界地缘遍行随眠。有为所缘缚。亦相应缚。谓欲色界一切有漏缘随眠。喜根缘识所增随眠。非所缘缚。亦非相应缚者无也。若非此所增随眠。而于此非所缘缚。亦非相应缚者。谓欲色界见灭所断无为缘。无色界见灭所断一切及见苦集所断不遍行随眠。喜根缘缘识所增随眠。有为所缘缚非相应缚。谓无色界见苦集所断不遍行随眠。有为相应缚非所缘缚。谓三界见道所断无漏缘。及三界他界地缘遍行随眠。有为所缘缚亦相应缚。谓欲色界一切有漏缘。无色界遍行。修所断见道所断有漏缘随眠。喜根缘缘识所增随眠。非所缘缚。亦非相应缚者无也。若非此所增随眠。而于此非所缘缚。亦非相应缚者。谓欲色界见灭所断无为缘。及无色界见灭所断一切随眠。忧根缘识所增随眠。有为所缘缚非相应缚。谓色界遍行。及修所断随眠。有为相应缚非所缘缚者无也。有为所缘缚亦相应缚。谓欲界一切有漏缘随眠。忧根缘识所增随眠。非所缘缚亦非相应缚者无也。若非此所增随眠。而于此非所缘缚。亦非相应缚者。谓欲界一切无漏缘。色界二部。及苦集所断不遍行。及无色界一切随眠。忧根缘缘识所增随眠。有为所缘缚非相应缚。谓色界见苦集所断不遍行。无色界遍行。及修所断随眠。有为相应缚非所缘缚。谓欲界见道所断无漏缘。欲色界他界地缘遍行随眠。有为所缘缚亦相应缚。谓欲界一切有漏缘。色界遍行。及修所断随眠。忧根缘缘识所增随眠。非所缘缚。亦非相应缚者无也。若非此所增随眠。而于此非所缘缚。亦非相应缚者。谓欲界见灭所断无为缘。色无色界二部。及无色界见苦集所断不遍行随眠。信等五根缘识所增随眠。有为所缘缚非相应缚。谓三界见苦集所断不遍行。及见道所断有漏缘随眠。有为相应缚非所缘缚。谓三界见道所断无漏缘。及缘信等五根。三界他界地缘遍行随眠。有为所缘缚亦相应缚。谓三界遍行。及修所断随眠。信等五根缘识所增随眠。非所缘缚。亦非相应缚者无也。若非此所增随眠。而于此非所缘缚。亦非相应缚者。谓三界见灭所断一切随眠。信等五根缘缘识所增随眠。有为所缘缚非相应缚者无也有为相应缚非所缘缚。谓三界见道所断无漏缘。及他界地缘遍行随眠。有为所缘缚亦相应缚。谓三界三部。及见道所断有漏缘随眠。信等五根缘缘识所增随眠。非所缘缚亦非相应缚者无也。若非此所增随眠。非所缘缚。亦非相应缚者。谓三界见灭所断一切随眠。三无漏根缘识所增随眠。有为所缘缚。非相应缚。谓三界遍行修所断。及见道所断有漏缘随眠。有为相应缚非所缘缚。谓三界见道所断无漏缘随眠。有为所缘缚亦相应缚者无也。三无漏根缘识所增随眠。非所缘缚。亦非相应缚者无也。若非此所增随眠。而于此非所缘缚。亦非相应缚者。谓三界见灭所断一切。及见苦集所断不遍行随眠。三无漏根缘缘识所增随眠。有为所缘缚非相应缚。谓三界见苦集所断不遍行随眠。有为相应缚非所缘缚。谓三界见道所断无漏缘。及他界地缘遍行随眠。有为所缘缚亦相应缚。谓三界遍行修所断。及见道所断有漏缘随眠。三无漏根缘缘识所增随眠。非所缘缚。亦非相应缚者无也。若非此所增随眠。而于此非所缘缚。亦非相应缚者。谓三界见灭所断一切随眠。通余章义准此应知眼根乃至无色界修所断无明随眠灭。缘识及缘缘识所增随眠。几为所缘缚。非相应缚。几为相应缚。非所缘缚。几为所缘缚。亦相应缚。几非所缘缚。亦非相应缚。答眼根灭缘识所增随眠。有为所缘缚非相应缚。谓欲色界遍行。修所断及见灭所断有为缘随眠。有为相应缚非所缘缚。谓欲色界见灭所断无为缘随眠。有为所缘缚亦相应缚者无也。眼根灭缘识所增随眠。非所缘缚亦非相应缚者无也。若非此所增随眠而于此非所缘缚。亦非相应缚者。谓欲色界见道所断一切。见苦集所断不遍行。及无色界一切随眠。缘缘识所增随眠。有为所缘缚非相应缚。谓三界见道所断有漏缘。欲色界见苦集所断不遍行。及无色界遍行。修所断随眠。有为相应缚非所缘缚。谓三界见道所断无漏缘。及欲色界他界地缘遍行随眠。有为所缘缚亦相应缚。谓欲色界遍行。修所断及见灭所断有为缘随眠。眼根灭缘缘识所增随眠。非所缘缚亦非相应缚者无也。若非此所增随眠。而于此非所缘缚。亦非相应缚者。谓欲色界见灭所断无为缘。无色界见灭所断一切。及见苦集所断不遍行随眠。耳鼻舌身乐喜根灭缘识。及缘缘识所增随眠亦尔。女根灭缘识所增随眠。有为所缘缚非相应缚。谓欲色界遍行。修所断及欲界见灭所断有为缘随眠。有为相应缚非所缘缚。谓欲界见灭所断无为缘随眠有为所缘缚亦相应缚者无也。女根灭缘识所增随眠。非所缘缚亦非相应缚者无也。若非此所增随眠。而于此非所缘缚。亦非相应缚者。谓欲界见道所断一切。见苦集所断不遍行。色界二部见苦集所断不遍行。及无色界一切随眠。缘缘识所增随眠。有为所缘缚非相应缚。谓欲界见道所断有漏缘。欲色界见苦集所断不遍行。无色界遍行及修所断随眠。有为相应缚非所缘缚。谓欲界见道所断无漏缘。及欲色界他界地缘遍行随眠。有为所缘缚亦相应缚。谓欲色界遍行修所断及欲界见灭所断有为缘随眠。女根灭缘缘识所增随眠。非所缘缚亦非相应缚者无也。若非此所增随眠。而于此非所缘缚。亦非相应缚者。谓欲界见灭所断无为缘。色无色界二部。及无色界见苦集所断不遍行随眠。男苦忧根灭缘识及缘缘识所增随眠亦尔。命根灭缘识所增随眠。有为所缘缚非相应缚。谓三界遍行修所断。及见灭所断有为缘随眠。有为相应缚非所缘缚。谓三界见灭所断无为缘随眠。有为所缘缚亦相应缚者无也。命根灭缘识所增随眠。非所缘缚亦非相应缚者无也。若非此所增随眠。而于此非所缘缚。亦非相应缚者。谓三界见道所断一切。及见苦集所断不遍行随眠。缘缘识所增随眠。有为所缘缚非相应缚。谓三界见道所断有漏缘及见苦集所断不遍行随眠。有为相应缚非所缘缚。谓三界见道所断无漏缘。及他界地缘遍行随眠。有为所缘缚亦相应缚。谓三界遍行修所断及见灭所断有为缘随眠。命根灭缘缘识所增随眠。非所缘缚亦非相应缚者无也。若非此所增随眠。而于此非所缘缚。亦非相应缚者谓三界见灭所断无为缘随眠。意舍信等五根灭。缘识及缘缘识所增随眠亦尔。通余章义准此应知

眼根乃至无色界修所断无明随眠断道。缘识及缘缘识所增随眠。几为所缘缚。非相应缚。几为相应缚。非所缘缚。几为所缘缚。亦相应缚。几非所缘缚。亦非相应缚。答眼根断道缘识所增随眠。有为所缘缚非相应缚。谓三界见道所断有漏缘。见苦集所断不遍行随眠。有为相应缚非所缘缚。谓三界见道所断无漏缘。及欲色界他界地缘遍行随眠。有为所缘缚亦相应缚。谓三界遍行。及修所断随眠眼根断道缘识所增随眠。非所缘缚亦非相应缚者无也。若非此所增随眠。而于此非所缘缚。亦非相应缚者。谓三界见灭所断一切随眠。缘缘识所增随眠。有为所缘缚非相应缚者无也。有为相应缚非所缘缚。谓三界见道所断无漏缘。及他界地缘遍行随眠。有为所缘缚亦相应缚。谓三界三部。及见道所断有漏缘随眠。眼根断道缘缘识所增随眠。非所缘缚亦非相应缚者无也。若非此所增随眠。而于此非所缘缚。亦非相应缚者。谓三界见灭所断一切随眠。耳鼻舌身根断道。缘识及缘缘识所增随眠亦尔。女根断道缘识所增随眠。有为所缘缚非相应缚。谓欲界见道所断有漏缘。及欲色界见苦集所断不遍行随眠。有为相应缚非所缘缚。谓欲界见道所断无漏缘。及欲色界他界地缘遍行随眠。有为所缘缚亦相应缚。谓欲色界遍行。及修所断随眠。女根断道缘识所增随眠。非所缘缚亦相应缚者无也。若非此所增随眠。而于此非所缘缚。亦非相应缚者。谓欲色界见灭所断一切。色界见道所断一切。及无色界一切随眠。缘缘识所增随眠。有为所缘缚非相应缚。谓色无色界见道所断有漏缘。无色界遍行及修所断随眠有为相应缚非所缘缚。谓三界见道所断无漏缘。及欲色界他界地缘遍行随眠。有为所缘缚亦相应缚。谓欲色界三部。及欲界见道所断有漏缘随眠。女根断道缘缘识所增随眠非所缘缚。亦非相应缚者无也。若非此所增随眠。而于此非所缘缚。亦非相应缚者。谓三界见灭所断一切。及无色界见苦集所断不遍行随眠。男苦忧根断道缘识及缘缘识所增随眠亦尔。命根断道缘识所增随眠。有为所缘缚非相应缚。谓三界见道所断有漏缘。及见苦集所断不遍行随眠。有为相应缚非所缘缚。谓三界见道所断无漏缘。及他界地缘遍行随眠。有为所缘缚亦相应缚。谓三界遍行。及修所断随眠。命根断道缘识所增随眠。非所缘缚亦非相应缚者无也。若非此所增随眠。而于此非所缘缚。亦非相应缚者。谓三界见灭所断一切随眠缘缘识所增随眠。有为所缘缚非相应缚者无也。有为相应缚非所缘缚。谓三界见道所断无漏缘。及他界地缘遍行随眠有为所缘缚亦相应缚者。谓三界三部。及见道所断有漏缘随眠。命根断道缘缘识所增随眠。非所缘缚。亦非相应缚者无也。若非此所增随眠。而于此非所缘缚。亦非相应缚者。谓三界见灭所断一切随眠。意舍信等五根断道缘识及缘缘识所增随眠亦尔。乐根断道缘识所增随眠。有为所缘缚非相应缚。谓三界见道所断有漏缘。欲色界见苦集所断不遍行。无色界遍行。及修所断随眠。有为相应缚非所缘缚。谓三界见道所断无漏缘。及欲色界他界地缘遍行随眠。有为所缘缚亦相应缚。谓欲色界遍行。及修所断随眠。乐根断道缘识所增随眠。非所缘缚。亦非相应缚者无也。若非此所增随眠。而于此非所缘缚。亦非相应缚者。谓三界见灭所断一切。及无色界见苦集所断不遍行随眠。缘缘识所增随眠有为所缘缚非相应缚。谓无色界见苦集所断不遍行随眠。有为相应缚非所缘缚。谓三界见道所断无漏缘。及他界地缘遍行随眠。有为所缘缚亦相应缚。谓欲色界三部。无色界遍行修所断。及三界见道所断有漏缘随眠。乐根断道缘缘识所增随眠。非所缘缚亦非相应缚者无也。若非此所增随眠。而于此非所缘缚。亦非相应缚者。谓三界见灭所断一切随眠。喜根断道缘识及缘缘识所增随眠亦尔。通余章义准此应知

眼根乃至无色界修所断无明随眠。缘识及缘缘识。于三界十五部心中。一一等无间生几心。答眼根缘识及缘缘识。一一等无间生十五心。耳乃至三无漏根缘识及缘缘识亦尔。通余章义准此应知

眼根乃至无色界修所断无明随眠。缘识及缘缘识所增随眠。一一等无间生几心。答眼根缘识及缘缘识所增随眠。一一等无间生十五心。耳鼻舌身命意乐喜舍信等五三无漏根缘识及缘缘识所增随眠亦尔。女根缘识所增随眠。等无间生十心。缘缘识所增随眠等无间生十五心。男苦忧根缘识及缘缘识所增随眠亦尔。通余章义准此应知。眼根乃至无色界修所断无明随眠灭。缘识及缘缘识。一一等无间生几心。答眼根灭缘识及缘缘识。一一等无间生十五心。耳乃至信等五根灭缘识及缘缘识亦尔。通余章义准此应知。眼根乃至无色界修所断无明随眠灭。缘识及缘缘识所增随眠一一等无间生几心。答眼根灭缘识所增随眠等无间生十心。缘缘识所增随眠等无间生十五心。耳乃至信等五根灭。缘识及缘缘识所增随眠亦尔。通余章义准此应知。眼根乃至无色界修所断无明随眠断道。缘识及缘缘识。一一等无间生几心。答眼根断道缘识及缘缘识。一一等无间生十五心。耳乃至信等五根断道缘识及缘缘识亦尔。通余章义准此应知。眼根乃至无色界。修所断无明随眠断道。缘识及缘缘识所增随眠。一一等无间生几心。答眼根断道缘识及缘缘识所增随眠。一一等无间生十五心。耳鼻舌身命意乐喜舍信等五根断道。缘识及缘缘识所增随眠亦尔。女根断道缘识所增随眠等无间生十心。缘缘识所增随眠等无间生十五心。男苦忧根断道缘识及缘缘识所增随眠亦尔。通余章义准此应知

眼根乃至无色界。修所断无明随眠。缘识及缘缘识。当言有寻有伺。无寻唯伺。无寻无伺耶。答眼根缘识及缘缘识。各具三。耳乃至三无漏根缘识及缘缘识亦尔。通余章义准此应知。眼根乃至无色界修所断无明随眠。缘识及缘缘识。所增随眠。当言有寻有伺。无寻唯伺。无寻无伺耶。答眼根缘识及缘缘识所增随眠。各具三。耳乃至三无漏根缘识及缘缘识所增随眠亦尔。通余章义准此应知。眼根乃至无色界。修所断无明随眠灭。缘识及缘缘识。当言有寻有伺。无寻唯伺。无寻无伺耶。答眼根灭缘识及缘缘识。各具三。耳乃至信等五根灭缘识及缘缘识亦尔。通余章义准此应知。眼根乃至无色界。修所断无明随眠灭。缘识及缘缘识所增随眠当言有寻有伺。无寻唯伺。无寻无伺耶。答眼根灭缘识及缘缘识。所增随眠各具三。耳乃至信等五根灭缘识。及缘缘识所增随眠亦尔。通余章义准此应知。眼根乃至无色界。修所断无明随眠断道。缘识及缘缘识。当言有寻有伺。无寻唯伺。无寻无伺耶。答眼根断道缘识及缘缘识。各具三。耳乃至信等五根断道缘识及缘缘识亦尔。通余章义准此应知。眼根乃至无色界。修所断无明随眠断道。缘识及缘缘识所增随眠。当言有寻有伺。无寻唯伺。无寻无伺耶。答眼根断道缘识及缘缘识所增随眠各具三。耳乃至信等五根断道缘识及缘缘识所增随眠亦尔。通余章义准此应知

眼根乃至无色界。修所断无明随眠缘识及缘缘识。当言乐苦喜忧舍根相应耶。答眼根缘识及缘缘识四根相应。除苦根。耳乃至三无漏根缘识及缘缘识亦尔。通余章义准此应知。眼根乃至无色界。修所断无明随眠缘识及缘缘识所增随眠。当言乐乃至舍根相应耶。答眼根缘识及缘缘识所增随眠。四根相应。除苦根。耳乃至三无漏根。缘识及缘缘识所增随眠亦尔。通余章义准此应知。眼根乃至无色界。修所断无明随眠灭缘识及缘缘识。当言乐乃至舍根相应耶。答眼根灭缘识及缘缘识。四根相应。除苦根。耳乃至信等五根灭缘识及缘缘识亦尔。通余章义准此应知。眼根乃至无色界。修所断无明随眠灭缘识及缘缘识所增随眠。当言乐乃至舍根相应耶。答眼根灭缘识及缘缘识所增随眠。四根相应。除苦根。耳乃至信等五根灭缘识及缘缘识所增随眠亦尔。通余章义准此应知。眼根乃至无色界。修所断无明随眠断道缘识及缘缘识当言乐乃至舍根相应耶。答眼根断道缘识及缘缘识。四根相应。除苦根。耳乃至信等五根断道缘识及缘缘识亦尔。通余章义准此应知

眼根乃至无色界。修所断无明随眠断道。缘识及缘缘识所增随眠。当言乐乃至舍根相应耶。答眼根断道缘识及缘缘识所增随眠四根相应。除苦根。耳乃至信等五根断道缘识及缘缘识所增随眠亦尔。通余章义准此应知

眼根乃至无色界。修所断无明随眠缘识及缘缘识。谁成就谁不成就。答眼根缘识。空无边处以下。及圣者生上成就异生生上不成就。缘缘识一切有情皆成就。耳鼻舌身根缘识及缘缘识亦尔。女根缘识欲色界。及圣者生无色界成就。异生生无色界不成就。缘缘识空无边处以下。及圣者生上成就。异生生上不成就。男苦忧根缘识及缘缘识亦尔。命根缘识及缘缘识。一切有情皆成就。意乐喜舍信等五三无漏根。缘识及缘缘识亦尔。通余章义准此应知。眼根乃至无色界。修所断无明随眠。缘识及缘缘识所增随眠。谁成就谁不成就。答眼根缘识所增随眠。未离空无边处染成就已离空无边处染不成就。缘缘识所增随眠。未离无色界染成就。已离无色界染不成就。耳鼻舌身根缘识及缘缘识所增随眠亦尔。女根缘识所增随眠。未离色界染成就。已离色界染不成就。缘缘识所增随眠未离空无边处染成就。已离空无边处染不成就。男苦忧根缘识及缘缘识所增随眠亦尔。命根缘识及缘缘识所增随眠。未离无色界染成就。已离无色界染不成就。意乐喜舍信等五三无漏根缘识及缘缘识所增随眠亦尔。通余章义准此应知。眼根乃至无色界。修所断无明随眠灭。缘识及缘缘识。谁成就谁不成就。答眼根灭缘识欲色界。及圣者生无色界成就异生生无色界不成就。缘缘识一切有情皆成就。耳鼻舌身乐喜根灭。缘识及缘缘识亦尔。女根灭缘识欲色界及圣者生无色界成就。异生生无色界不成就。缘缘识空无边处以下。及圣者生上成就。异生生上不成就。男苦忧根灭缘识及缘缘识亦尔。命根灭缘识及缘缘识。一切有情皆成就。意舍信等五根灭缘识及缘缘识亦尔。通余章义准此应知。眼根乃至无色界。修所断无明随眠灭。缘识及缘缘识所增随眠。谁成就谁不成就。答眼根灭缘识所增随眠。未离色界染成就。已离色界染不成就。缘缘识所增随眠。未离无色界染成就。已离无色界染不成就。耳鼻舌身乐喜根灭缘识及缘缘识所增随眠亦尔。女根灭缘识所增随眠。未离色界染成就。已离色界染不成就。缘缘识所增随眠。未离空无边处染成就。已离空无边处染不成就。男苦忧根灭缘识及缘缘识所增随眠亦尔。命根灭缘识及缘缘识所增随眠。未离无色界染成就。已离无色界染不成就。意舍信等五根灭缘识及缘缘识所增随眠亦尔。通余章义准此应知

说一切有部发智大毗婆沙论卷第九十一阿毗达磨大毗婆沙论卷第九十二

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    结蕴第二中十门纳息第四之二十二

眼根乃至无色界。修所断无明随眠断道。缘识及缘缘识。谁成就谁不成就。答眼根断道。缘识及缘缘识。一切有情皆成就。耳鼻舌身命意乐喜舍信等五根断道。缘识及缘缘识亦尔。女根断道缘识欲色界。及圣者生无色界成就。异生生无色界不成就。此缘缘识一切有情皆成就。男苦忧根断道。缘识及缘缘识亦尔。通余章义准此应知。眼根乃至无色界修所断无明随眠断道。缘识及缘缘识所增随眠。谁成就谁不成就。答眼根断道。缘识及缘缘识。所增随眠。未离无色界染成就。已离无色界染不成就。耳鼻舌身命意乐喜舍信等五根断道。缘识及缘缘识所增随眠亦尔。女根断道缘识所增随眠。未离色界染成就。已离色界染不成就。此缘缘识所增随眠。未离空无边处染成就。已离空无边处染不成就。男苦忧根断道。缘识及缘缘识。所增随眠亦尔。通余章义准此应知。眼根乃至无色界。修所断无明随眠缘识及缘缘识。得遍知时于九十八随眠中。几随眠得遍知。于九结中几结尽。答眼根缘识得遍知时。空无边处爱尽。即眼根缘识得遍知无结尽。此缘缘识得遍知时。无色爱尽。三随眠得遍知。三结尽。耳鼻舌身根缘识及缘缘识得遍知时亦尔。女根缘识得遍知时色爱尽。异生三十一随眠。得遍知无结尽。圣者三随眠得遍知无结尽。此缘缘识得遍知时。空无边处爱尽。即女根缘缘识得遍知无结尽。男苦忧根缘识及缘缘识得遍知时亦尔。命根缘识及缘缘识。得遍知时无色爱尽。三随眠得遍知三结尽意乐喜舍信等五三无漏根。缘识及缘缘识。得遍知时亦尔。通余章义准此应知

眼根乃至无色界修所断无明随眠。缘识及缘缘识所增随眠得遍知时。几随眠得遍知。几结尽。答眼根缘识所增随眠得遍知时。空无边处爱尽。即眼根缘识所增随眠得遍知。无结尽。此缘缘识所增随眠。得遍知时无色爱尽。三随眠得遍知。三结尽。耳鼻舌身根。缘识及缘缘识所增随眠得遍知时亦尔。女根缘识所增随眠。得遍知时色爱尽。异生三十一随眠得遍知无结尽。圣者三随眠得遍知无结尽。此缘缘识所增随眠。得遍知时。空无边处爱尽。即女根缘缘识所增随眠。得遍知无结尽。男苦忧根缘识及缘缘识。所增随眠得遍知时亦尔。命根缘识及缘缘识所增随眠得遍知时无色爱尽。三随眠得遍知三结尽。意乐喜舍信等五三无漏根。缘识及缘缘识所增随眠得遍知时亦尔。通余章义准此应知

眼根乃至无色界。修所断无明随眠灭。缘识及缘缘识。得遍知时几随眠得遍知。几结尽答眼根灭缘识得遍知时色爱尽。异生三十一随眠得遍知无结尽。圣者三随眠得遍知无结尽。此缘缘识得遍知时无色爱尽。二随眠得遍知三结尽。耳鼻舌身乐喜根灭。缘识及缘缘识。得遍知时亦尔。女根灭缘识得遍知时色爱尽。异生三十一随眠得遍知无结尽。圣者三随眠得遍知无结尽。此缘缘识得遍知时。空无边处爱尽。即女根灭缘缘识得遍知无结尽。男苦忧根灭。缘识及缘缘识得遍知时亦尔。命根灭缘识及缘缘识得遍知时。无色爱尽。三随眠得遍知三结尽。意舍信等五根灭。缘识及缘缘识。得遍知时亦尔。通余章义准此应知。眼根乃至无色界。修所断无明随眠灭。缘识及缘缘识所增随眠得遍知时。几随眠得遍知。几结尽。答眼根灭缘识所增随眠。得遍知时色爱尽。异生三十一随眠。得遍知无结尽。圣者三随眠得遍知无结尽。此缘缘识所增随眠。得遍知时无色爱尽。三随眠得遍知。三结尽。耳鼻舌身乐喜根灭。缘识及缘缘识所增随眠得遍知时亦尔。女根灭缘识所增随眠。得遍知时色爱尽。异生三十一随眠。得遍知无结尽。圣者三随眠得遍知无结尽。此缘缘识所增随眠。得遍知时空无边处爱尽。即女根灭缘缘识所增随眠。得遍知无结尽。男苦忧根灭。缘识及缘缘识所增随眠得遍知时亦尔。命根灭缘识及缘缘识所增随眠。得遍知时无色爱尽。三随眠得遍知。三结尽。意舍信等五根灭。缘识及缘缘识所增随眠得遍知时亦尔。通余章义准此应知

眼根乃至无色界。修所断无明随眠断道。缘识及缘缘识得遍知时。几随眠得遍知几结尽。答眼根断道。缘识及缘缘识。得遍知时无色爱尽。三随眠得遍知三结尽。耳鼻舌身命意乐喜舍信等五根断道。缘识及缘缘识。得遍知时亦尔。女根断道缘识。得遍知时色爱尽。异生三十一随眠。得遍知无结尽。圣者三随眠得遍知无结尽。此缘缘识得遍知时无色爱尽。三随眠得遍知三结尽。男苦忧根断道。缘识及缘缘识。得遍知时亦尔。通余章义准此应知

眼根乃至无色界。修所断无明随眠断道。缘识及缘缘识所增随眠得遍知时。几随眠得遍知。几结尽。答眼根断道。缘识及缘缘识所增随眠得遍知时。无色爱尽。三随眠得遍知。三结尽。耳鼻舌身命意乐喜舍信等五根断道。缘识及缘缘识所增随眠得遍知时亦尔。女根断道。缘识所增随眠。得遍知时色爱尽。异生三十一随眠得遍知无结尽。圣者三随眠得遍知无结尽。此缘缘识所增随眠得遍知时。无色爱尽。三随眠得遍知。三结尽。男苦忧根断道。缘识及缘缘识所增随眠得遍知时亦尔。通余章义准此应知

眼根乃至无色界。修所断无明随眠。缘识及缘缘识。灭作证时于九十八随眠中。几随眠灭作证。于九结中几结尽。答眼根缘识灭作证时。空无边处爱尽。即眼根缘识灭作证。无结尽。至阿罗汉九十八随眠灭作证。九结尽。此缘缘识灭作证时得阿罗汉果。九十八随眠灭作证。九结尽。耳鼻舌身根。缘识及缘缘识灭作证时亦尔。女根缘识灭作证时色爱尽。异生三十一随眠灭作证。无结尽。圣者三随眠灭作证。无结尽。至阿罗汉九十八随眠灭作证。九结尽。此缘缘识灭作证时。空无边处爱尽即女根缘缘识灭作证。无结尽。至阿罗汉九十八随眠灭作证。九结尽。男苦忧根缘识及缘缘识灭作证时亦尔。命根缘识及缘缘识。灭作证时得阿罗汉果。九十八随眠灭作证九结尽。意乐喜舍信等五三无漏根。缘识及缘缘识灭作证时亦尔。通余章义准此应知

眼根乃至无色界。修所断无明随眠。缘识及缘缘识所增随眠灭作证时。几随眠灭作证。几结尽。答眼根缘识所增随眠灭作证时。空无边处爱尽。即眼根缘识所增随眠灭作证。无结尽。至阿罗汉九十八随眠灭作证。九结尽。此缘缘识所增随眠灭作证时。得阿罗汉果。九十八随眠灭作证。九结尽。耳鼻舌身根缘识及缘缘识所增随眠灭作证时亦尔。女根缘识所增随眠灭作证时色爱尽。异生三十一随眠灭作证。无结尽。圣者三随眠灭作证无结尽。至阿罗汉九十八随眠灭作证。九结尽。此缘缘识所增随眠灭作证时。空无边处爱尽。即女根缘缘识所增随眠灭作证。无结尽。至阿罗汉九十八随眠灭作证。九结尽。男苦忧根缘识及缘缘识所增随眠灭作证时亦尔。命根缘识及缘缘识所增随眠灭作证时得阿罗汉果。九十八随眠灭作证。九结尽。意乐喜舍信等五三无漏根。缘识及缘缘识所增随眠灭作证时亦尔。通余章义准此应知

眼根乃至无色界。修所断无明随眠灭。缘识及缘缘识。灭作证时。几随眠灭作证几结尽。答眼根灭缘识灭作证时色爱尽。异生三十一随眠灭作证无结尽。圣者三随眠灭作证无结尽。至阿罗汉九十八随眠灭作证。九结尽。此缘缘识灭作证时得阿罗汉果。九十八随眠灭作证九结尽。耳鼻舌身乐喜根灭。缘识及缘缘识灭作证时亦尔。女根灭缘识灭作证时色爱尽。异生三十一随眠灭作证无结尽。圣者三随眠灭作证无结尽。至阿罗汉九十八随眠灭作证九结尽。此缘缘识灭作证时空无边处爱尽。即女根灭缘缘识灭作证无结尽。至阿罗汉九十八随眠灭作证九结尽。男苦忧根灭。缘识及缘缘识灭作证时亦尔。命根灭缘识及缘缘识。灭作证时得阿罗汉果。九十八随眠灭作证九结尽。意舍信等五根灭。缘识及缘缘识灭作证时亦尔。通余章义准此应知

眼根乃至无色界。修所断无明随眠灭。缘识及缘缘识所增随眠灭作证时。几随眠灭作证。几结尽。答眼根灭缘识所增随眠。灭作证时色爱尽。异生三十一随眠灭作证。无结尽。圣者三随眠灭作证。无结尽。至阿罗汉九十八随眠灭作证九结尽。此缘缘识所增随眠。灭作证时得阿罗汉果。九十八随眠灭作证。九结尽。耳鼻舌身乐喜根灭缘识及缘缘识所增随眠灭作证时亦尔。女根灭缘识所增随眠。灭作证时色爱尽异生三十一随眠。灭作证无结尽。圣者三随眠灭作证。无结尽。至阿罗汉九十八随眠灭作证九结尽。此缘缘识所增随眠灭作证时。空无边处爱尽。即女根灭缘缘识所增随眠。灭作证。无结尽。至阿罗汉九十八随眠灭作证九结尽。男苦忧根灭。缘识及缘缘识所增随眠灭作证时亦尔。命根灭缘识及缘缘识。所增随眠灭作证时得阿罗汉果。九十八随眠灭作证九结尽。意舍信等五根灭缘识及缘缘识所增随眠灭作证时亦尔。通余章义准此应知。眼根乃至无色界。修所断无明随眠断道。缘识及缘缘识灭作证时几随眠灭作证几结尽。答眼根断道缘识及缘缘识。灭作证时得阿罗汉果。九十八随眠灭作证九结尽。耳鼻舌身命意乐喜舍信等五根断道。缘识及缘缘识灭作证时亦尔。女根断道。缘识灭作证时色爱尽。异生三十一随眠灭作证无结尽。圣者三随眠灭作证。无结尽。至阿罗汉九十八随眠灭作证九结尽。此缘缘识灭作证时得阿罗汉果。九十八随眠灭作证九结尽。男苦忧根断道。缘识及缘缘识灭作证时亦尔。通余章义准此应知

眼根乃至无色界。修所断无明随眠断道。缘识及缘缘识所增随眠灭作证时。几随眠灭作证。几结尽。答眼根断道。缘识及缘缘识。所增随眠灭作证时得阿罗汉果。九十八随眠灭作证。九结尽。耳鼻舌身命意乐喜舍信等五根断道。缘识及缘缘识所增随眠灭作证时亦尔。女根断道缘识所增随眠。灭作证时色爱尽。异生三十一随眠灭作证。无结尽。圣者三随眠灭作证。无结尽。至阿罗汉九十八随眠灭作证。九结尽。此缘缘识所增随眠。灭作证时得阿罗汉果。九十八随眠灭作证。九结尽。男苦忧根断道。缘识及缘缘识所增随眠灭作证时亦尔。通余章义准此应知

眼根乃至无色界。修所断无明随眠。各九结中几结所系。三缚中几缚所缚。十随眠中几随眠随增。六垢中几垢所染。十缠中几缠所缠。答眼根九结所系。三缚所缚。十随眠随增。六垢所染。十缠所缠。耳乃至信等五根亦尔。通余章义准此应知

眼根乃至无色界。修所断无明随眠。缘识及缘缘识。几结所系。乃至几缠所缠。答眼根缘识及缘缘识。九结所系。三缚所缚。十随眠随增六垢所染。十缠所缠。耳乃至信等五根。缘识及缘缘识亦尔。通余章义准此应知

眼根乃至无色界。修所断无明随眠灭。缘识及缘缘识。几结所系。乃至几缠所缠。答眼根灭缘识及缘缘识。九结所系。三缚所缚。十随眠随增。六垢所染。十缠所缠。耳乃至信等五根灭缘识及缘缘识亦尔。通余章义准此应知

眼根乃至无色界。修所断无明随眠断道。缘识及缘缘识。几结所系。乃至几缠所缠。答眼根断道缘识及缘缘识。九结所系。三缚所缚。十随眠随增。六垢所染。十缠所缠。耳乃至信等五根断道。缘识及缘缘识亦尔。通余章义准此应知

成就眼根乃至无色界。修所断无明随眠者。几结所系。乃至几缠所缠。答成就眼根者。若异生未离欲染九结所系。三缚所缚。十随眠随增。六垢所染。十缠所缠。已离欲染未离初静虑染。六结所系。二缚所缚。九随眠随增。三垢所染。二缚所缚。已离初静虑染。六结所系。二缚所缚。九随眠随增。一垢所染。二缠所缠。若圣者未离欲染入正性离生。苦类智未已生。九结所系。三缚所缚。十随眠随增六垢所染。十缠所缠。苦类智已生道类智未已生。九结所系。三缚所缚。八随眠随增。六垢所染。十缠所缠。道类智已生未离欲染。六结所系。三缚所缚。四随眠随增。六垢所染。十缠所缠。已离欲染未离初静虑染入正性离生。苦类智未已生。六结所系。二缚所缚。九随眠随增。三垢所染。二缠所缠。苦类智已生道类智未已生。六结所系。二缚所缚。七随眠随增。三垢所染。二缠所缠。道类智已生未离初静虑染。三结所系。二缚所缚。三随眠随增。三垢所染。二缠所缠。已离初静虑染入正性离生苦类智未已生。六结所系。二缚所缚。九随眠随增。一垢所染。二缠所缠。苦类智已生道类智未已生。六结所系。二缚所缚。七随眠随增。一垢所染。二缠所缠。道类智已生未离无色染。三结所系。二缚所缚。三随眠随增。一垢所染。二缠所缠。已离无色染无结系。乃至无缠缠。成就耳鼻舌身女男命意。乐苦喜舍信等五根者亦尔。成就忧根者若异生。九结所系。三缚所缚。十随眠随增。六垢所染。十缠所缠。若圣者苦类智未已生。九结所系。三缚所缚。十随眠随增。六垢所染。十缠所缠。苦类智已生道类智未已生。九结所系。三缚所缚。八随眠随增。六垢所染。十缠所缠。道类智已生。六结所系。三缚所缚。四随眠随增。六垢所染。十缠所缠。成就未知当知根者。未离欲染。入正性离生苦类智未已生。九结所系。三缚所缚。十随眠随增。六垢所染。十缠所缠。苦类智已生。九结所系。三缚所缚。八随眠随增。六垢所染。十缠所缠。已离欲染未离初静虑染。入正性离生苦类智未已生。六结所系。二缚所缚。九随眠随增。三垢所染。二缠所缠。苦类智已生。六结所系。二缚所缚。七随眠随增。三垢所染。二缠所缠。已离初静虑染入正性离生苦类智未已生。六结所系。二缚所缚。九随眠随增。一垢所染。二缠所缠。苦类智已生。六结所系。二缚所缚。七随眠随增。一垢所染。二缠所缠。成就已知根者若未离欲染。六结所系。三缚所缚。四随眠随增。六垢所染。十缠所缠。若已离欲染未离初静虑染。三结所系。二缚所缚。三随眠随增。三垢所染。二缠所缠。若已离初静虑染。三结所系。二缚所缚。三随眠随增。一垢所染。二缠所缠。成就具知根者无结系。乃至无缠缠。通余章义准此应知

成就眼根乃至无色界修所断无明随眠。缘识及缘缘识者几结所系。乃至几缠所缠。答成就眼乃至具知根。缘识及缘缘识者。诸结所系乃至诸缠所缠。如前成就眼根者说。通余章义准此应知

成就眼根乃至无色界修所断无明随眠灭者。几结所系乃至几缠所缠。答成就眼根灭者。若异生未离初静虑染六结所系。二缚所缚。九随眠随增。三垢所染。二缠所缠。已离初静虑染。六结所系。二缚所缚。九随眠随增。一垢所染。二缠所缠。若圣者未离初静虑染入正性离生苦类智未已生。六结所系。二缚所缚。九随眠随增。三垢所染。二缠所缠。苦类智已生道类智未已生。六结所系。二缚所缚。七随眠随增。三垢所染。二缠所缠。道类智已生未离初静虑染。三结所系。二缚所缚。三随眠随增。三垢所染。二缠所缠。已离初静虑染入正性离生苦类智未已生。六结所系。二缚所缚。九随眠随增。一垢所染。二缠所缠。苦类智已生道类智未已生。六结所系。二缚所缚。七随眠随增。一垢所染。二缠所缠。道类智已生未离无色染。三结所系。二缚所缚。三随眠随增。一垢所染。二缠所缠。已离无色染无结系。乃至无缠缠。成就耳鼻舌身女男命信等五根灭者亦尔。成就意根灭者。若异生未离欲染。九结所系。三缚所缚。十随眠随增。六垢所染。十缠所缠。已离欲染未离初静虑染。六结所系。二缚所缚。九随眠随增。三垢所染。二缠所缠。已离初静虑染。六结所系。二缚所缚。九随眠随增。一垢所染。二缠所缠。若圣者未离欲染入正性离生苦类智未已生。九结所系。三缚所缚。十随眠随增。六垢所染。十缠所缠。苦类智已生道类智未已生。九结所系。三缚所缚。八随眠随增。六垢所染。十缠所缠。道类智已生未离欲染。六结所系。三缚所缚。四随眠随增。六垢所染。十缠所缠。已离欲染未离初静虑染。入正性离生苦类智未已生。六结所系。二缚所缚。九随眠随增。三垢所染。二缠所缠。苦类智已生道类智未已生。六结所系。二缚所缚。七随眠随增。三垢所染。二缠所缠。道类智已生未离初静虑染。三结所系。二缚所缚。三随眠随增。三垢所染。二缠所缠。已离初静虑染入正性离生苦类智未已生。六结所系。二缚所缚。九随眠随增。一垢所染。二缠所缠。苦类智已生道类智未已生。六结所系。二缚所缚。七随眠随增。一垢所染。二缠所缠。道类智已生未离无色染。三结所系。二缚所缚。三随眠随增。一垢所染。二缠所缠。已离无色染无结系。乃至无缠缠。成就乐苦喜忧舍根灭者亦尔。通余章义准此应知

成就眼根乃至无色界。修所断无明随眠灭。缘识及缘缘识者。几结所系。乃至几缠所缠。答成就眼根乃至信等五根灭。缘识及缘缘识者诸结所系。乃至诸缠所缠。如前成就意根灭者说。通余章义准此应知

成就眼根乃至无色界。修所断无明随眠断道者。几结所系。乃至几缠所缠。答成就眼根乃至信等五根断道者。诸结所系乃至诸缠所缠。亦如前成就意根灭者说。成就眼根乃至无色界。修所断无明随眠断道。缘识及缘缘识者。诸结所系乃至诸缠所缠。如前成就意根灭。缘识及缘缘识者说。通余章义准此应知

不成就眼根乃至无色界。修所断无明随眠者。几结所系乃至几缠所缠。答不成就眼耳鼻舌女男根者诸结所系。乃至诸缠所缠。如前成就眼根者说。不成就身根者若异生。六结所系。二缚所缚。九随眠随增。一垢所染。二缠所缠。若圣者未离无色染。三结所系。二缚所缚。三随眠随增。一垢所染。二缠所缠。已离无色染无结系。乃至无缠缠。不成就乐喜根者。六结所系。二缚所缚。九随眠随增。一垢所染。二缠所缠。不成就苦根者。若异生未离初静虑染。六结所系。二缚所缚。九随眠随增。三垢所染。二缠所缠。已离初静虑染。六结所系。二缚所缚。九随眠随增。一垢所染。二缠所缠。若圣者未离初静虑染。三结所系。二缚所缚。三随眠随增。三垢所染。二缠所缠。已离初静虑染未离无色染。三结所系。二缚所缚。三随眠随增。一垢所染。二缠所缠。已离无色染无结系。乃至无缠缠。不成就忧根者。诸结所系乃至诸缠所缠。如前成就眼根灭者说。不成就信等五根者。九结所系。三缚所缚。十随眠随增。六垢所染。十缠所缠。不成就未知当知根者。若异生诸结所系。乃至诸缠所缠。如前成就眼根异生说。若圣者未离欲染。六结所系。三缚所缚。四随眠随增。六垢所染。十缠所缠。已离欲染未离初静虑染。三结所系。二缚所缚。三随眠随增。三垢所染。二缠所缠。已离初静虑染未离无色染。三结所系。二缚所缚。三随眠随增。一垢所染。二缠所缠。已离无色染无结系。乃至无缠缠。不成就已知根者。若异生。诸结所系乃至诸缠所缠。如前不成就未知当知根异生说。若圣者。在见道未离欲染苦类智未已生。九结所系。三缚所缚。十随眠随增。六垢所染。十缠所缠。苦类智已生。九结所系。三缚所缚。八随眠随增。六垢所染。十缠所缠。已离欲染未离初静虑染苦类智未已生。六结所系。二缚所缚。九随眠随增。三垢所染。二缠所缠。苦类智已生六结所系。二缚所缚。七随眠随增。三垢所染。二缠所缠。已离初静虑染苦类智未已生。六结所系。二缚所缚。九随眠随增。一垢所染。二缠所缠。苦类智已生。六结所系。二缚所缚。七随眠随增。一垢所染。二缠所缠。在无学道无结系。乃至无缠缠。不成就具知根者。若异生诸结所系。乃至诸缠。所缠。如前不成就已知根异生说。若圣者在见道诸结所系。乃至诸缠所缠。如前不成就已知根者在见道说。在修道诸结所系。乃至诸缠所缠。如前不成就未知当知根者在修道说。通余章义准此应知

不成就眼根乃至无色界。修所断无明随眠。缘识及缘缘识者。几结所系。乃至几缠所缠。答不成就眼根缘识者。六结所系。二缚所缚。九随眠随增。一垢所染。二缠所缠。不成就耳鼻舌身女男苦忧根。缘识者。及不成就女男苦忧根。缘缘识者亦尔。通余章义准此应知

不成就眼根乃至无色界。修所断无明随眠灭者。几结所系。乃至几缠所缠。答不成就眼根灭者。若异生在欲界。九结所系。三缚所缚。十随眠随增。六垢所染。十缠所缠。在识无边处以上。六结所系。二缚所缚。九随眠随增。一垢所染。二缠所缠。若圣者在见修道诸结所系乃至诸缠所缠。如前未离欲染在见修道圣者说。不成就耳鼻舌身女男乐苦根灭者亦尔。有差别者。不成就女男苦根灭者。应言在第二静虑以上。不成就乐根灭者。应言在第三静虑具缚。及在空无边处以上。不成就喜根灭者。若异生在欲界具缚。九结所系。三缚所缚。十随眠随增。六垢所染。十缠所缠。在第四静虑以上。六结所系。二缚所缚。九随眠随增。一垢所染。二缠所缠。若圣者具缚入正性离生初刹那顷。九结所系。三缚所缚。十随眠随增。六垢所染。十缠所缠。不成就忧根灭者亦尔。有差别者。应言在第二静虑以上。不成就命及信等五根灭者。诸结所系乃至诸缠所缠。若异生如前未离欲染诸异生说。若圣者在见修道。如前未离欲染在见修道诸圣者说。不成就意舍根灭者。若异生具缚。若圣者具缚。入正性离生初刹那顷。俱九结所系。三缚所缚。十随眠随增。六垢所染。十缠所缠。通余章义准此应知

不成就眼根乃至无色界。修所断无明随眠灭。缘识及缘缘识者。几结所系。乃至几缠所缠。答不成就眼根灭缘识者。六结所系。二缚所缚。九随眠随增。一垢所染。二缠所缠。不成就耳鼻舌身乐喜根灭缘识者。及不成就女男苦忧根灭缘识。及缘缘识者亦尔。通余章义准此应知

不成就眼根。乃至无色界。修所断无明随眠断道者。几结所系。乃至几缠所缠。答不成就眼根断道者。若异生在欲界。九结所系。三缚所缚。十随眠随增。六垢所染。十缠所缠。在识无边处以上。六结所系。二缚所缚。九随眠随增。一垢所染。二缠所缠。若圣者在见修道诸结所系。乃至诸缠所缠。如未离欲染在见修道诸圣者说。不成就耳鼻舌身女男乐苦根断道者亦尔。有差别者。不成就女男苦根断道者。应言在第二静虑以上不成就乐根断道者。应言在第三静虑未起加行道。及在空无边处以上不成就喜根断道者。若异生在欲界。九结所系。三缚所缚。十随眠随增。六垢所染。十缠所缠。在第四静虑以上。六结所系。二缚所缚。九随眠随增。一垢所染。二缠所缠。若圣者在见修道诸结所系。乃至诸缠所缠。如未离欲染在见修道诸圣者说。不成就忧根断道者亦尔。有差别者。应言在第二静虑以上。不成就命信等五根断道者。若异生若圣者。诸结所系乃至诸缠所缠。如前在欲界不成就眼根断道。异生圣者说。不成就意舍根断道者。若异生若圣者。诸结所系乃至诸缠所缠。如前在欲界不成就喜根断道异生圣者说。通余章义准此应知

不成就眼根乃至无色界。修所断无明随眠断道。缘识及缘缘识者。几结所系。乃至几缠所缠。答不成就女根断道缘识者。六结所系。二缚所缚。九随眠随增。一垢所染。二缠所缠。不成就男苦忧根断道缘识者亦尔。通余章义准此应知。决择余门准前应说

说一切有部发智大毗婆沙论卷第九十二阿毗达磨大毗婆沙论卷第九十三

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    智蕴第三中学支纳息第一之一

如世尊说。学行迹成就学八支。彼成就。过去几。未来几现在几。如是等章及解章义既领会已。次应广释。问何故作此论。答为欲解释契经义故。如契经说。学行迹成就学八支。漏尽阿罗汉成就十无学支。契经虽作是说。而不说彼成就。过去几。未来几。现在几。契经是此论所依根本。彼未说者今应说之。复次为止他宗显正理故。谓或有执。过去未来无实自性。现在虽有而是无为。为遮彼意显示实有过去未来可成就故。若彼非有应不成就。如第二头。第六蕴等既可成就故如实有。又为显示现在世法定是有为有生灭故。或复有执。无实成就不成就性。如譬喻者。彼说有情不离诸法说名成就。离诸法时名不成就。俱假施设。如五指合假说为拳。离即非拳此亦如是。问彼何故作是执。答彼依契经故作是执。谓契经说。有转轮王成就七宝。若成就性是实有者。成就轮宝神珠宝故。应法性坏。所以者何。亦是有情亦非情故。成就象宝及马宝故。复应趣坏。所以者何。亦是傍生亦是人故。成就女宝故复应身坏。所以者何。亦是男身亦女身故。成就主兵主藏臣故复应业坏。所以者何。君臣杂故。勿有此失故成就性定非实有。为遮彼意显成就性定是实有。若不尔者便违契经。如说。学行迹成就学八支。漏尽阿罗汉成就十无学支。圣者现起有漏心时。应不成就过去未来诸无漏法。云何成就八支十支。复违余经。如说。如是补特伽罗。成就善法及不善法。若彼善法现在前时。应不成就不善法。若不善法现在前时。应不成就善法。若无记法现在前时。应不成就善不善法。云何说成就善不善法耶。复违余经。如说。成就七善法者彼现法中多住喜乐如理勤修必能尽漏七善法者知法知义乃至广说。七中若一现在前时应不成就余六善法。若起余法现在前时。应不成就七。云何成就七善法耶。复违余经。如说。如来成就十力。若起一力现在前时。应不成就九。若起余法现在前时。应不成就十。云何如来成就十力。复有余失。谓诸异生不染污心现在前住。应成无学。不成就三界一切烦恼故。诸无学者起有漏心现在前位。应成异生。不成就一切学无学法故。勿有此失。故成就性决定实有。问若成就性是实有者。前譬喻者所引契经当云何通。答轮王于彼有自在力随意受用如成就故。立成就名。若全拨无实成就性。如何于彼立成就名。复有余师许有成就拨不成就。彼作是说。诸成就性有作用故可是实有。不成就性既无作用。云何实有。为遮彼执显不成就亦是实有。若不成就非实有者。亦应非有实成就性相待立。故如影与光明暗昼夜寒热等事相待而立阙一不成。此亦如是。复次不成就性与成就性近互相违故。俱实有如贪无贪嗔无嗔痴无痴等近互相违故俱实有。复次若不成就非实有性应不施设烦恼断法。所以者何。非圣道生断诸烦恼。如刀断物。如石磨香。然诸圣道现在前时。令诸烦恼成就得灭。亦令彼烦恼不成就得生。尔时说为断诸烦恼。有余复执道是无为。如分别论者。彼作是说。唯一无上正等菩提常住不灭随彼彼佛出现世间。能证者虽异而所证无别。如一龙象妙饰庄严。虽有多人次第乘御。而彼龙象前后是一。问彼何故作此执。答彼依契经。如契经说。佛告苾刍。我证旧道故知圣道定是无为。为遮彼执欲显圣道堕三世故。定是有为非无为法。堕三世故。又执圣道体是无为。便违契经。如契经说。有一近事名毗舍佉。来诣法授苾刍尼所。问言。圣道为是有为。为是无为。苾刍尼言。圣道有为堕三世故。问若圣道是有为分别论者所引契经当云何通。答由五事相似故说名旧道。一地相似。诸佛皆依第四静虑得菩提故。二加行相似。诸佛皆经三无数劫修习六种波罗蜜多得圆满故。三所缘相似。诸佛皆缘四圣谛理证菩提故。四行相相似。诸佛皆以苦非常等十六行相修圣道故。五所作相似。诸佛皆以无漏道力断自身中一切烦恼。亦令无量无边有情得涅槃乐故。若不依此释旧道名而执无为。是旧义者。即彼经说旧城旧都岂旧城都是无为法。又若经说。证旧圣道即执圣道是无为法。契经亦说。蛇退旧皮岂蛇旧皮是无为法。如伽他说

  若断爱无余　　如莲花处水
  苾刍舍此彼　　如蛇脱旧皮

如旧城等皆是有为旧圣道言理亦应尔。为止此等他宗所说及为显示诸法正理故作斯论

如世尊说。学行迹成就学八支。此中云何学八支。谓学正见乃至正定成就者。问谁成就为法成就。为补特伽罗成就耶。设尔何失。二俱有过。所以者何。若法成就者。一切法既无作用。于无作用一切法中何法能成就何法所成就。若补特伽罗成就者。谛义胜义。补特伽罗都不可得。既无真实补特伽罗。云何说彼能成就法。答应作是说。非法成就亦非补特伽罗成就。然有真实成就性及不成就性。而无真实成就者及不成就者。如有真实杂染清净系缚解脱流转还灭因果死生诸业异熟道及道果。而无真实杂染清净者乃至修道证道果者。有作是说。法成就。问若尔法无作用云何成就。答诸法虽无作用而有功能。问若尔眼处应成就十一处。十一处亦应成就眼处。答依此理说亦无有过。皆有功能互相引故。评曰。应作是说。能成就者非法。亦非补特伽罗。无真实作用故。补特伽罗非实有故。然有四蕴五蕴生时。与如是类诸得俱转说名成就。与如是类非得俱转名不成就。问若尔经说当云何通。如说。如是补特伽罗成就善法。及不善法答此是世尊于诸蕴中依世俗说。不言实有补特伽罗成就诸法。问此中何者是成就义。尊者世友作如是说。不断义是成就义。问若尔具缚补特伽罗。于一切法皆名不断。应皆成就。答非皆成就有未得故。复作是说。已得义是成就义。问若尔无学已得学法应成就彼。答非成就彼已舍彼故。复作是说。不弃舍义是成就义。问若尔学位不弃舍无学法应成就彼。答非成就彼未得彼故。复作是说。已得未舍义是成就义。此言应理。若法已得而未舍时必成就故。大德说曰。世俗有情不离诸法假说成就。胜义中无成就性故。问何故名学为学所学为得学法。设尔何失。二俱有过。所以者何。若学所学故名学者。定蕴所说当云何通。如说。有学非学所学。谓有学者安住自性。若得学法故名学者。契经所说当云何通。如说。佛告尸缚迦言。学所学故说名为学。答应作是说。学所学故说名为学。问若尔定蕴所说当云何通。答彼说世俗共称学者。谓于所学学不学时。世共称彼以为学者。故本论师说彼为学而实非学。复次彼于所学希望不止。依彼期心故说为学。有作是说。得学法故说名为学。问若尔契经所说当云何通。答契经依彼不息期心。不舍加行故作是说。谓有学者。虽或起善心。或起不善心。或起无记心。而恒不舍趣涅槃心。及彼加行故一切时名学所学。然亦有时不学所学。如人在路暂憩息时。有人问言。欲何所趣。其人答曰。欲趣某方。以不舍趣心虽住亦言趣。是学者行迹故名学行迹。问无学行迹明净胜妙过于有学。何缘但说学行迹耶。答亦应说有无学行迹而不说者。是有余说。复次既已说始则已说终故。已说学迹则亦说无学。复次欲显各别有殊胜事。谓有学位行迹殊胜。无学位中解脱殊胜。如王与臣各有胜事。谓王尊贵威伏殊胜。臣于事业勇战殊胜。复次有学行迹能断烦恼。胜烦恼怨无学不尔。复次有学行迹为断烦恼。勤修加行。无学不尔。复次数数行义是行迹义。有学数行。无学不尔。是故不说无学行迹。彼成就过去几未来几现在几。答若依有寻有伺定初学见现在前。过去无。未来现在八。此中有寻有伺定者。谓未至定及初静虑。依者。有说。俱生是依。复有说者等无间缘是此依义。评曰。应作是说。即彼二地总说为依。初有四种。一入正性离生初。谓依彼地初入正性离生故。二得果初。谓依彼地初得学果故。三转根初。谓依彼地信胜解初练根作见至故。四离染初。谓世俗道离诸染已。初依彼地起无漏道现在前故。此中总依四初作论。而历诸位有具不具。随其所应当审思择。学见现在前者。问学者亦有非学非无学见现在前。彼亦是学见。是诸学者所起见故。何故此中不说学者学见现在前耶。答应作是说。而不说者。当知此中是有余说。复次此中学见即说学见。非学者见故不应责。过去无者。谓如前说。诸初刹那现在前时全无过去。未有一念已生灭故。设已生灭得果转根。或退舍故。未来八者。谓即初时具修未来学八支故。现在八者。尔时八支现在前故。彼灭已不失。若复依有寻有伺定学见现在前。过去未来现在八。此中彼者。谓彼八支。灭已者。谓无常。灭已不失者。谓由三因缘失无漏道。一得果故。二转根故。三退舍故。无此三缘故言不失。若复依等者。谓彼第二刹那以去。复依有寻有伺定学见现在前。问何故复起此地学见。答念报恩故。谓依此地破烦恼怨。念报彼恩故复重起。如因铠仗伏怨敌已。复数修治爱重藏护。复次由四缘故复重起彼。一为现法乐住。二为游戏功德。三为观本所作。四为受用圣财。过去八者。谓从第二刹那以后成就过去初刹那时已起灭者。未来现在各有八者如前。应知彼灭已不失。若依无寻无伺定学见现在前。过去未来八现在七。此中无寻无伺定者。谓第二第三第四静虑。问何故不说静虑中间。答应说而不说者。当知此义有余。复次静虑中间与后三地支无增减。是故不说。过去未来各有八者如前应知。现在七者。除正思惟。彼无寻故。彼灭已不失。若依无色定学见现在前。过去未来八。现在四。此中无色定者。谓前三无色定。问何故不说第四无色定耶。答彼地无圣道故。后当说起世俗心故。过去未来各有八者如前应知。现在四者。除正思惟正语业命。彼地无故彼灭已不失若入灭定或世俗心现在前。过去未来八现在无。此中入灭定者。谓正住灭受想定。世俗心者。谓出灭定有漏定心。或复起余有漏定心。过去未来各有八者。谓前最初所起有寻有伺定八支。及未来修者。现在无者在灭定时无圣道故。世俗心时不起无漏八道支故

若依无寻无伺定初学见现在前。过去无。未来八。现在七。此中依义如前应知。无寻无伺定即后三静虑。初者具四如前广说。释学见义亦如前说。过去无者。初刹那时未有一念已生灭故。设已生灭三缘舍故。未来八者。谓即初时具修未来学八支故。现在七者。彼地无有正思惟故。彼灭已不失。若复依无寻无伺定学见现在前。过去现在七。未来八。此中彼灭已不失等如前释。过去七者。谓从第二刹那以后成就过去。初刹那时已起灭七。彼灭已不失。若依无色定。学见现在前。过去七。未来八。现在四。此中过去七者。谓初刹那已起灭者。余如前释。彼灭已不失。若入灭定或世俗心现在前。过去七。未来八。现在无。此中一切如前。应知彼灭已不失。若依有寻有伺定。学见现在前。过去七。未来现在八。此中过去七者。谓前最初所起无寻无伺定七支。未来八者。即最初位未来所修。从入灭定世俗心后说。起有寻有伺定者。后当分别

若依无色定初学见现在前。过去无。未来八。现在四。此中无色定者。谓前三。无色定初者。唯依离染作论。以世俗道离诸染已初起无漏。三无色定现在前故。无依无色入见道义故。无第一入正性离生。初无依无色得学果义。亦无依无色学位练根义。故无得果及转根初。余如前释。问有漏无色定必依无漏静虑为加行起。无漏无色定亦应必依无漏静虑为加行起。何故此中说依无色定初学见现在前。过去不成就八支耶。答无漏道支有属静虑有属无色。属静虑者虽过去成就。而属无色者过去不成就。故说过去无有八支。有作是说。有依世俗道得不还果已。不起无漏道。复以世俗道离四静虑染。或复离三无色染已。初起无漏无色定时。彼过去无八支圣道。故作是说。过去全无彼灭已不失。若复依无色定学见现在前过去现在四。未来八。此中过去四者。谓前所起初念四支。未来八者。谓前所修未来八支。余如前释。彼灭已不失若入灭定。或世俗心现在前。过去四。未来八。现在无。此中一切如前。应知彼灭已不失。若依有寻有伺定学见现在前。过去四。未来现在八。此中过去四者。谓无色定初起四支。未来八者。即彼时修未来八支。问无色定无间必无能起有寻有伺定。何故此中作如是说。答当知此中是说次第。非定次第依说随顺说。不依定随顺说彼灭已不失。若依无寻无伺定学见现在前。过去四。未来八。现在七。此中过去四者。谓先依无色定最初所起四支。未来八者。即彼所修未来八支。问次前所起有寻有伺定八支。入过去皆应不失。如何但说过去四耶。答此中所说过去未来皆显最初起及修者。不显后位所起所修故无有失。现在随时现在前故随起而说。问今于此中说何学者。答若诸学者于一切定次第遍入。如有次第蹬上阶梯是此所说。谓有学者先入有寻有伺定。次入无寻无伺定。次入无色定。次入灭定。后起世俗心。如是学者是此所说。若有学者先入有寻有伺定。次入无寻无伺定。次入无色定。次入灭定。后起无漏心。此等学者非此所说。如杂蕴说。若有一类补特伽罗。具十二支缘起法者是此所说。若不具者非此所说。如契经说。先见女人形貌端严众所乐见。次见衰老。次见疾病。次见命终。次见死后诸位变坏。如是女人是经所说。若不尔者非经所说。此中学者应知亦然。评曰。应作是说。此中总说一切学者。随诸学者。于诸位中所起学支皆摄尽故。应知行迹差别有四。一苦迟通行。二苦速通行。三乐迟通行。四乐速通行。然诸行迹应说一种。谓趣苦灭行。趣有世间生老病死灭行。或应说二。谓趣名灭行。及趣色灭行。或应说三。谓趣三界灭行。或应说五。谓趣五蕴灭行。或应说十二。谓趣十二支缘起灭行。或应说无量。谓在相续刹那差别无边际故。问世尊何故广一二三。略十二等。建立如是四通行耶。答以三事故。一以地故。二以根故。三以补特伽罗故。此则总说。若别说者。但以二事。谓地故根故或地故补特伽罗故。地故根故者。谓未至定。静虑中间。三无色定。诸钝根者所有圣道名苦迟通行。即此诸地诸利根者。所有圣道名苦速通行四根本静虑诸钝根者。所有圣道名乐迟通行。即此诸地诸利根者。所有圣道名乐速通行。地故补特伽罗故者。谓未至定。静虑中间。三无色定。随信行信胜解时解脱者。所有圣道名苦迟通行。即此诸地随法行见至不时解脱者。所有圣道名苦速通行。四根本静虑随信行信胜解时解脱者。所有圣道名乐迟通行。即此诸地随法行见至不时解脱者所有圣道名乐速通行

问此四通行自性是何。答五蕴四蕴以为自性。谓在静虑及近分者五蕴为自性。在无色者四蕴为自性。如是名为通行自性。我物自体相分本性。已说自性所以今当说。问何故名通行。通行是何义。答通谓通达行谓行迹。能正通达趣向涅槃。是通行义。苦迟通行者。问圣道非苦受自性。亦非苦受相应。何故名苦。答近分无色难成办故。所起圣道说名为苦。根本静虑易成办故所起圣道说名为乐。此广分别如前结蕴四静虑中。问何故圣道说名为迟。答由钝根者所起圣道。不能速趣究竟涅槃故说名迟。诸利根者所起圣道疾趣涅槃故说名速。问有信胜解疾至涅槃胜于见至。如信胜解精勤修行速证涅槃。见至懈怠不能速证。如有颂言

  不放逸放逸　　多觉寤睡眠
  如乘利钝马　　勤行者先至

如有二人俱趣一方。一乘利马。一乘钝马。乘利马者不勤行故不能速至。乘钝马者以勤行故便能速至。如是见至与信胜解俱趣涅槃。若信胜解精勤修行速证涅槃。见至懈怠不能速证。如何乃说钝根圣道不能速趣说名为迟。答此中意说等勤行者。若等勤行见至速证。非信胜解故说为迟。问此四种行五蕴四蕴以为自性。何故名通。通唯显慧非余蕴故。答以慧增故但说名通。如见道中虽具五蕴。以慧增故但立见名。如现观边诸世俗智。虽以四蕴五蕴为性。而慧增故但立智名。金刚喻定虽以四蕴五蕴为性。等持增故但立定名。通行亦尔。故不应责

如契经说。云何苦迟通行。谓诸苾刍于五取蕴诃毁厌恶。问苦迟通行缘四谛境。何故世尊但说缘苦。答亦应说此缘余三谛。而不说者是有余说。复次苦谛在初既说缘苦。应知亦说缘余三谛。复次彼契经中但显加行未显根本。谓加行时缘五取蕴起厌行相。至根本时缘四圣谛。集异门论作如是说。云何苦迟通行。谓静虑所不摄钝信等五根。云何苦速通行。谓静虑所不摄利信等五根。云何乐迟通行。谓静虑所摄钝信等五根。云何乐速通行。谓静虑所摄利信等五根。问此四通行五蕴四蕴以为自性。何故彼论唯说利钝信等五根。答依胜说故。谓于五蕴四蕴行中五根最胜。复次信等五根于所作事方便善巧。能速成办胜于余蕴故偏说之。问诸有情类有中根不。若有者彼论何故不说。若无者契经当云何通。如契经说。有诸有情在世间生在世间。长有利根者。有中根者。有钝根者。乃至广说。有作是说。无有中根。所以者何。见道有二。一随信行道。二随法行道。修道亦有二。一信胜解道。二见至道。无学道亦有二。一时解脱道。二不时解脱道。无第三道故。无中根。问若尔契经。当云何通。答受佛化者有先见谛。有中见谛。有后见谛。先见谛者说名利根。中见谛者说名中根。后见谛者说名钝根。复次受佛化者有近见谛。有远见谛。有不近不远见谛。近见谛者说名利根。如阿若多憍陈那等。远见谛者说名钝根。如善贤等。不近不远见谛者。说名中根。如护国等。复有说者。亦有中根。问若尔彼论何故不说答应说而不说者。当知此义有余。复次中根即在利钝中摄。所以者何。说钝根时中根名利胜钝根故。说利根时中根名钝劣利根故。由此尊者世友说曰。中根应言在利根摄。胜钝根故。此复可言在钝根摄。劣利根故。大德说曰。中根可言利钝根摄。而不可言上下根摄。所以者何。利钝根者各三品故。云何知然。大觉独觉舍利子等。皆随法行种性中摄。此三种根岂得相似利根性中。既有三品故知。钝根性亦得有三品。利钝二道各三品。故契经中说有三品根。以第三道不可得故。阿毗达磨说无中根。如是善通经论二说

集异门论复作是说。苦迟通行若习若修若多所作。能满苦速通行。乐迟通行若习若修若多所作。能满乐速通行。问说何所满为满于根为满离染。若满于根。苦迟通行。若习若修若多所作。理应能满二速通行乐迟通行。若习若修若多所作。亦应能满二速通行。若满离染。迟应满迟。速应满速。何故彼论作是说耶。答应作是说彼说满根且说相似非不相似。苦与苦相似非乐。乐与乐相似非苦故

问。谁成就几通行。答或有成就一。谓未离欲染者。或有成就二。谓已离欲染者。尊者僧伽筏苏说曰。有具成就四通行者。谓依根本静虑练根者住无间道时。未舍二迟通行。而得二速通行。评曰。彼不应作是说。若作是说。便应坏根补特伽罗。坏根者尔时应是钝根亦是利根。坏补特伽罗者。尔时应亦是信胜解等亦是见至等。勿有此失。是故前说于理为善。有成就一二。无成就三四。无一成就利钝根故。问谁用几通行作所作事耶。答有但用一。或有用二。或有用三。有具用四。而不一时。有用一者。谓或唯用苦迟通行。作所作事。如钝根者依未至定。静虑中间。三无色定。随其所应入正性离生。得果离染修余功德而般涅槃。或复唯用苦速通行作所作事。如利根者依未至定静虑中间三无色定。随其所应入正性离生。得果离染修余功德。而般涅槃。或复唯用乐迟通行作所作事。如钝根者离欲染已。依四根本静虑随其所应。入正性离生得果离染。修余功德而般涅槃。或复唯用乐速通行作所作事。如利根者离欲染已。依四根本静虑随其所应。入正性离生得果离染。修余功德而般涅槃。有用二者。谓或有用苦迟通行。及乐迟通行作所作事。如钝根者依未至定等。及依初静虑等。随其所应入正性离生。得果离染修余功德而般涅槃。或复有用苦迟通行。及苦速通行作所作事。如钝根者唯依未至定等。随其所应入正性离生得果练根离染。修余功德而般涅槃。或复有用乐迟通行。及苦速通行作所作事。如钝根者依初静虑等。及依未至定等。随其所应入正性离生得果练根离染。修余功德而般涅槃。或复有用乐迟通行乐速通行作所作事。如钝根者唯依初静虑等。随其所应入正性离生得果练根离染。修余功德而般涅槃。或复有用苦速通行。及乐速通行作所作事。如利根者依未至定等。及依初静虑等。随其所应入正性离生得果离染。修余功德。而般涅槃。有用三者。谓或有用苦迟通行。及乐迟苦速通行作所作事。如钝根者依未至定等。及依初静虑等。随其所应入正性离生得果练根离染。修余功德而般涅槃。或复有用苦迟通行。及苦速乐速通行作所作事。如钝根者依未至定等及初静虑等。随其所应入正性离生得果练根离染。修余功德而般涅槃。或复有用苦迟通行。及乐迟乐速通行。如钝根者依未至定等。及依初静虑等。随其所应入正性离生得果练根离染。修余功德而般涅槃。或复有用乐迟通行。及苦速乐速通行作所作事。如钝根者依初静虑等及依未至定等。随其所应入正性离生得果练根离染。修余功德而般涅槃。有用四者。谓钝根者依未至定等。及依初静虑等。随其所应入正性离生得果练根离染。修余功德而般涅槃

说一切有部发智大毗婆沙论卷第九十三阿毗达磨大毗婆沙论卷第九十四

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    智蕴第三中学支纳息第一之二

问谁于如是四种通行得几舍几。答诸异生位无得无舍。此四通行唯无漏故。世第一法现在前时。得一或二未有所舍。问此中不依异生作论唯依圣者。答亦有圣者于四通行无得无舍。谓自性住进退位中有得舍义。且进位中若未离欲染入正性离生。住苦法智忍乃至道法智时皆无舍得一。道类智忍时舍一得一。若已离欲染依未至定入正性离生。住苦法智忍乃至道法智时亦皆无舍得一。道类智忍时舍一得二。若依上地入正性离生。住苦法智忍乃至道法智时皆无舍得二。道类智忍时舍二得二。若预流者趣一来果。诸加行道五无间道五解脱道时。皆无舍得一。第六无间道时舍一得一。若一来者趣不还果。诸加行道二无间道二解脱道时无舍得一。第九无间道时舍一得二。若不还者趣阿罗汉果。离初静虑。乃至无所有处染。诸加行无间解脱道时皆无舍得二。离非想非非想处染。诸加行道八无间道八解脱道时。亦皆无舍得二。第九无间道时舍二得二。是说离染位。若未离欲染信胜解。练根作见至。诸加行道时无舍得一。无间道时舍一得一。若已离欲染信胜解。练根作见至。诸加行道时无舍得二。无间道时舍二得二。若时解脱阿罗汉练根作不动。诸加行道八无间道八解脱道时皆无舍得二。第九无间道时舍二得二。是说转根位。若未离欲染圣者。起诸相似无量解脱胜处遍处。及不净观持息念念住等。诸功德时皆无舍得一。若已离欲染圣者。起无量解脱胜处遍处。不净观持息念诸念住。无碍解无诤愿智边际定。三三摩地三重三摩地杂修静虑引发五通。诸加行道五无间道三解脱道等时。皆无舍得二。若入灭定想微细心时亦无舍得二。微微心时无舍无得。诸如是等是说修功德位。若退位中阿罗汉。及已离欲染有学。退胜根住劣根时皆舍二得二。未离欲染有学。退胜根住劣根时。皆舍一得一。是说退根位。若阿罗汉。起色无色界缠退时舍二得二。起欲界缠退时舍二得一。若不还者。已离色等染起色界等缠退时舍二无得。即不还者。起欲界缠退时舍二得一。若一来者。退胜果道。时舍一无得。退一来果时舍一得一。若预流者。退胜果道时舍一无得。是说退离染位。退余功德义准应知。如施设论说。有四种补特伽罗。谓有补特伽罗现法中迟身坏后速。或有补特伽罗现法中速身坏后迟。或有补特伽罗现法中迟身坏后亦迟或有补特伽罗现法中速身坏后亦速。问后二可尔。前二云何。圣者转生决定不退亦不转根。欲界经生。决定不入色无色界。如何可说现迟后速。复如何说现速后迟。岂有见至经生。退为信胜解者。答彼论不说转根及退。但说精进及懈怠者。若现身懈怠后身精进者。名现法中迟身坏后速。若现身精进后身懈怠者。名现法中速身坏后迟。若现身懈怠后身亦懈怠者。名现法中迟身坏后亦迟。若现身精进后身亦精进者。名现法中速身坏后亦速。如是名为彼论说意

如契经说。有四种行。一不堪忍行。二堪忍行。三调伏行。四寂静行。云何不堪忍行。谓不堪忍寒热饥渴。蚊虻风曝蛇蝎恶触。恶人侵恼非理语言。身中所生种种苦痛。于此等事不能堪忍。是名不堪忍行。云何堪忍行。谓能堪忍如前所说寒热等事。是名堪忍行。云何调伏行。谓根律仪。是名调伏行。云何寂静行。谓无漏道。是名寂静行。问为四通行摄彼四行。为彼四行摄四通行耶。答彼四行摄四通行。非四通行摄彼四行。不摄何等。谓彼前三

如契经说。有四种断。一苦迟通断。二苦速通断。三乐迟通断。四乐速通断。此中苦迟通断苦故迟故。说名为劣苦速通断。但以苦故说名为劣。乐迟通断但以迟故说名为劣。乐速通断不能正显广大饶益天人众者不广大故亦名为劣。世尊通断能正显示广大饶益天人众故独名为妙。问为四通行摄四通断。为四通断摄四通行耶。答展转相摄各随其事。谓苦迟通断即苦迟通行。乃至乐速通断即乐速通行。故随其事展转相摄。复有说者。四通断唯无学。四通行通学无学。若作是说。四通行摄四通断。非四通断摄四通行。不摄何等。谓有学四通行。问圣道是妙不应名劣。如品类足说。云何劣法。谓不善有覆无记法。何故契经说四种断有名为劣。答劣有二种。一染污劣。二减少劣。四种通断虽非染污劣。而有减少劣。有作是说。苦迟通断。是未至定静虑中间三无色定。时解脱圣道摄。苦速通断。即是彼地诸声闻乘。不时解脱圣道摄。乐迟通断。是四根本静虑。时解脱圣道摄。乐速通断中不能正显广大饶益天人众者即是四根本静虑。诸声闻乘不时解脱圣道摄。乐速通断中。能正显示广大饶益天人众者是佛乘圣道摄。问独觉圣道是何品摄。有作是说。声闻品摄。复有说者。佛品中摄。所以者何。如佛无师自能觉故。有余师说。前三通断如前应知乐速通断中不能正显广大饶益天人众者是独觉圣道摄乐速通断中能正显示广大饶益天人众者是世尊圣道摄。问根本静虑声闻不时解脱圣道是何品摄。有作是说。独觉品摄。复有说者。佛品所摄。所以者何。彼无漏根依佛得故。有作是言。前三通断是外异生。乐速通断中。不能正显广大饶益天人众者是独觉圣道摄。乐速通断中能正显示广大饶益天人众者是世尊圣道摄。问声闻圣道是何品摄。有作是说。独觉品摄。复有说者。佛品所摄。所以者何。彼无漏根依佛得故。或有说者。前三通断是诸外道。乐速通断中不能正显广大饶益天人众者是声闻圣道摄。乐速通断中。能正显示广大饶益天人众者是世尊圣道摄。问独觉圣道是何品摄。有作是说。声闻品摄。复有说者。佛品所摄。所以者何。如佛无师自能觉故。评曰。如是诸说。虽各自生弟子觉意。而实义者四种通断即四通行。二四通摄三乘圣道。然第四中不能正显广大饶益天人众者。声闻独觉二圣道摄。能正显示广大饶益天人众者。佛圣道摄。此通二断非唯第四。彼契经中不说此唯是乐速通断故。在佛身者皆是妙故。问四通行中世尊依何通行。入正性离生得果离染尽漏。独觉依何通行。声闻依何通行耶。答世尊依乐速通行。入正性离生得果离染尽漏。云何知然。经为量故。如契经说。鬘母一时来诣佛所。作如是问。世尊依何通行。证得阿耨多罗三藐三菩提耶。佛告鬘母。一切如来应正等觉。皆依乐速通行证得无上正等菩提。尔时鬘母便设二难。世尊往因六年苦行。乃证无上正等菩提。云何言依乐速通行。佛言。愚人我不因彼六年苦行证大菩提。弃舍彼已受食乳糜。然后依止乐速通行。证得无上正等菩提。由此故知。世尊依止乐速通行入见道等。以依第四静虑入正性离生。乃至得菩提故。独出独觉如佛世尊。众出独觉所依不定如诸声闻。声闻乘中尊者舍利子。依苦速通行入正性离生得果离染。依乐速通行尽漏。所以者何。彼依未至定入正性离生得果离染。依第四静虑尽漏故。尊者大目连依苦速通行。入正性离生得果离染及尽漏。所以者何。彼依未至定入正性离生得果离染。依无色定尽漏故。问何故舍利子与大目连。俱依未至定入正性离生得果离染。而舍利子依第四静虑得阿罗汉果。大目连依无色定得阿罗汉果耶。答此二尊者。俱是到究竟声闻故。决定渐次得四沙门果。是故俱依未至定入正性离生。而尊者舍利子。是毗钵舍那行故。依第四静虑得阿罗汉果尊者大目连。是奢摩他行故。依无色定得阿罗汉果。问一切到究竟声闻。为皆决定渐次得四沙门果不。答皆决定渐次得四沙门果。所以者何。一切到究竟声闻。皆是随佛转法轮者。若不渐次得四沙门果。云何于彼入住出心能善解说。问能善解说四沙门果入住出心。无如佛者佛岂渐次得四沙门果耶。答于此义中不应难佛。以佛往昔为菩萨时。已能善说四沙门果胜。舍利子住无学位。故不应以声闻难佛。诸声闻人非自证处。不能为他自在说故。有作是说。一切到究竟声闻。非皆决定渐次得四沙门果。所以者何。若彼在异生位先已离欲染。岂遇佛说法要退已后方趣预流果耶。问若尔云何能善解说四沙门果。答此不应难。如阿难陀是钝根者虽住学位。而能善说四沙门果。能令无量百千有情成阿罗汉。况利根者超越趣证住无学地而不能说。评曰。应作是说一切到究竟声闻。皆决定渐次得四沙门果。不以能说故但以法尔。故谓过殑伽沙数如来应正等觉。所有到究竟声闻弟子。皆渐次证得四沙门果。是故法尔不应为难

如世尊说。漏尽阿罗汉成就十无学支。此中云何十无学支。谓无学正见乃至正定。及无学正解脱正智。问学位为有正解脱正智不。若有者此中何故不说。若无者契经所说当云何通。如契经说。尊者舍利子慰喻给孤独长者言。勿怖勿怖无闻异生。成就不信恶戒少闻悭吝恶慧。邪见邪思惟邪胜解邪解脱邪智故。怖堕地狱傍生鬼界。汝已永断不信恶戒。乃至邪解脱邪智。成就信戒闻舍慧。正见正思惟正胜解正解脱正智故不应怖。答应作是说。学位亦有正解脱正智。问若尔此中何故不说。答有有二种。一者有体。二者有支

学位虽有正解脱正智体。而不立为正解脱正智支。问何故无学位立正解脱正智为支。学位不立。答依胜立故。谓诸法中。无学法胜非学法。补特伽罗中。无学补特伽罗胜。非学补特伽罗。是故学位虽有此二不立为支。复次唯无学位。正解脱正智势用多故。自性胜故。离过患故。建立为支。复次唯无学位正解脱正智。已断一切有根本故建立为支。复次唯无学心具二解脱。一者自性。二者相续。故彼相应胜解与智建立为支。二解脱心是非差别。应作四句。或有心自性解脱。非相续解脱。谓有学无漏心。或有心相续解脱。非自性解脱。谓无学有漏心。或有心自性解脱。亦相续解脱。谓无学无漏心。或有心非自性解脱。亦非相续解脱。谓有学有漏心。及一切异生心。复次有学正解脱正智。为邪解脱邪智所覆损故。不立为支。问有学正见正思惟等。亦为邪见邪思惟等之所覆损。何故立支。答有学正见正思惟等亲断邪见邪思惟等。一切烦恼害烦恼怨犹如铠仗。故立为支。问有学正解脱正智。岂不能害诸烦恼耶。答解脱非正害诸烦恼。害烦恼已得解脱故。正智虽能害修所断一切烦恼。而不能害见所断者故不立支。复次唯无学位正解脱正智。无相违法故立为支。相违法者。谓邪解脱邪智。复次唯无学心全分解脱故心相应。胜解与智建立为支。非如学心少分解脱。谓见所断一切烦恼少分不解脱。谓修所断一切烦恼。复次唯无学心一切解脱。一切离系故心相应。胜解与智建立为支。一切解脱者。谓于五部烦恼。一切离系者。谓于五部所缘。复次唯无学心解脱一切障。远离一切障故心相应。胜解与智建立为支。解脱一切障者。谓于五部障。远离一切障者。谓于五部所缘。复次唯无学位断如藤爱离诸系缚。故彼二法建立为支。复次唯无学位断依有顶烦恼重髻故彼二法建立为支。复次唯无学位。已剪三界烦恼须发故。彼二法建立为支。复次唯无学位解脱圆满。故彼二法建立为支。复次唯无学位轻安乐胜非烦恼热所损害故。唯无学位受轻安乐广大殊胜所作事业已成办故。如王已害一切怨敌。所受快乐广大殊胜。唯无学位。已灭一切烦恼。意言牟尼满故。唯无学位弃舍染污蕴担。得纯净蕴担故。唯无学位弃舍热恼界处。得清凉界处故。唯无学位弃舍不善根所依。得善根所依故。唯无学位弃舍烦恼自体。得清净自体故。唯无学位是诸世间功德田故。如世尊说

  若有贪等者　　如有秽草田
  故离贪等田　　施者获大果

唯无学位损害便获无间罪故。唯无学位破一切着。断一切缚离一切障故。唯无学位遍知四食。及四识住。超越九种有情居故。唯无学位功德现行无杂秽故。谓唯有妙行无诸恶行。唯有善根无不善根。由如是等种种因缘。唯无学位正解脱正智建立为支。问若有学位。有邪解脱。及邪智者。契经所说当云何通。如说。长者勿怖勿怖。汝已永断不信恶戒。乃至邪解脱邪智耶。答邪解脱邪智有二种。一者能令有情堕三恶趣。即见所断彼已永断。二者不令有情堕三恶趣。即修所断彼犹成就

如契经说。佛告阿难。舍利子是聪慧苾刍。能为给孤独长者。善分别四预流支十种义。问云何分别四预流支十种义。胁尊者曰。于一一预流支。皆以十义分别故。谓以十义分别亲近善士。乃至以十义分别法随法行。尊者望满作如是说。以信分别亲近善士。以闻分别听闻正法。以正见分别如理作意。以余分别法随法行。尊者妙音作如是说。以信戒分别亲近善士。以闻分别听闻正法。以正见分别如理作意。以余分别法随法行。阿毗达磨诸论师言。以信戒分别亲近善士。以闻及慧分别听闻正法。以正见分别如理作意。以余分别法随法行。尊者世友作如是说。以信戒舍分别亲近善士。以闻及慧分别听闻正法。以正见分别如理作意。以余分别法随法行。大德说曰。尊者舍利子。为给孤独长者。善分别四预流支。及四证净。四预流支者即是分别四预流支。十种义者即是分别四证净。谓以三事分别四证净。一自性故。二等起故。三等流故。自性故者。谓信与戒。等起故者。谓闻舍慧正见正思惟。由闻慧故等起于信。由正思惟等起于戒。由舍正见信戒增长等流故者。谓正胜解正解脱及正智。问正胜解正解脱有何差别。答因名正胜解。果名正解脱。复次加行时名正胜解。究竟时名正解脱。问闻慧正见正智有何差别。答闻谓闻所成慧。思谓思所成慧。正见正智。谓修所成慧。因名正见。果名正智。尊者左受作如是说。以十种义分别四预流支。及彼等流果。谓以信戒舍分别亲近善士。以闻分别听闻正法。以正思惟正胜解。分别如理作意。以慧正见分别法随法行。以正解脱正智。分别彼等流果。雾尊者曰。此中以十义为五事。分别四证净。一自性故。谓信戒。二相似故。谓舍正胜解。三加行故。谓闻及慧。四随顺故。谓正见正思惟。五果故。谓正解脱正智。尊者觉天作如是说。此中以十义分别四预流支。谓以信戒舍分别亲近善士。以闻及慧分别听闻正法。以正思惟分别如理作意。以余分别法随法行

问何故名阿罗汉。答应受世间胜供养故。名阿罗汉。谓世无有清净命缘非阿罗汉所应受者。复次阿罗者。谓一切烦恼。汉名能害。用利慧刀害烦恼贼。令无余故名阿罗汉。复次罗汉名生。阿是无义。以无生故名阿罗汉。彼于诸界诸趣诸生生死法中不复生故。复次汉名一切恶不善法。言阿罗者。是远离义。远离诸恶不善法故。名阿罗汉。此中恶者谓不善业。不善者谓一切烦恼。障善法故说为不善。是违善义。如有颂言

  远离恶不善　　安住胜义中
  应受世上供　　故名阿罗汉

漏尽者谓诸漏永尽。问顺诸漏法亦得永尽。何故但说彼漏尽耶。答彼以漏尽而为上首。应知亦说顺漏法尽。复次诸漏难断难破难越。非顺漏法故偏说之。复次诸漏过失多胜坚牢。非顺漏法故偏说之。复次诸漏自性断断已不成就。与圣道相违故偏说尽。诸圣道起正与一切烦恼相违。非有漏善无覆无记。然诸圣道断烦恼时亦兼断彼。如明灯起与闇相违非油炷器。然破闇时亦令油尽炷燋器热。问何故但说漏尽不说暴流轭等。答三漏在前摄烦恼尽。是故偏说。暴流轭等虽有摄烦恼尽而不在前。三结三不善根。虽在前而摄烦恼不尽。故阿罗汉但说漏尽。非暴流等

彼成就过去几未来几现在几。答若依有寻有伺定。初无学智现在前。过去无未来十现在九。此中有寻有伺定者。谓未至定及初静虑依者。有说。俱生是依。复有说者。等无间缘是此依义。评曰。应作是说。即彼二地总说为依。初有四种如前广说。此中但依二初作论。一得果初。谓依彼地初得阿罗汉果。二转根初。谓依彼地时解脱初练根作不动。无学智现在前者谓尽智。问无学者亦有非学非无学智见现在前。彼亦是无学智见。是诸无学者所起智见故。何故此中不说无学者无学智见现在前耶。答应作是说。而不说者当知。此中是有余说。复次此中无学智见即说无学智见。非无学者智见故不应责。过去无者。谓如前说二初刹那现在前时全无。过去未有一念已生灭故。设已生灭得果转根。或退舍故。未来十者。谓即初时具修未来。无学十支故。现在九者。尔时九支现在前故。谓除正见。此刹那中。无容起故彼灭已不失。若复依有寻有伺定。无学智现在前。过去现在九。未来十。此中彼者。谓彼九支。灭已者谓无常灭已。不失者。谓无三因缘失彼圣道。如前说。若复依等者。谓彼第二刹那已去。复依有寻有伺定尽无生智随一现在前。问何故复起此地智耶。答念报恩故。由四缘故。如前广说。过去九者。谓从第二刹那以去。成就过去初刹那时已起灭者。余如前说。彼灭已不失。若依无寻无伺定无学智现在前。过去九。未来十。现在八。此中无寻无伺定者。谓后三静虑。不说静虑中间义如前说。现在八者除正思惟。彼无寻故。余如前说。彼灭已不失。若依无色定无学智现在前。过去九。未来十。现在五。此中无色定者。谓前三无色定。不说第四。义如前说。现在五者。除正思惟正语业命。彼地无故。余如前说。彼灭已不失。若入灭定或世俗心现在前。过去九。未来十。现在无。此中入灭定者。谓住灭受想定。世俗心者。谓出灭定有漏定心。或复起余有漏定心。过去九者。谓前最初所起有寻有伺定九支。未来十者。即彼初时所修十支。现在无者尔时圣道不现前故。彼灭已不失。若依有寻有伺定。初无学见现在前。过去现在九。未来十。此中初无学见者。谓无学正见。过去九者。谓初所起有寻有伺定无学智俱生聚九支。现在九者。谓除正智。以见与智不俱起故。未来十者。是先初智及今初见所修十支。余如前说。彼灭已不失。若复依有寻有伺定。无学若智若见现在前。过去未来十。现在九。此中若智者。尽无生智随一。若见者无学正见。过去十者。谓前初智初见俱生聚十支。未来十者即彼所修。现在九者。智时除见见时除智余九支。余如前说。彼灭已不失。若依无寻无伺定。若智若见现在前。过去未来十。现在八。此中现在八者。除正思惟智见随一余八支。余如前说。彼灭已不失。若依无色定。无学若智若见现在前。过去未来十。现在五。此中现在五者。除正思惟正语业命智见随一余五支。余如前说。彼灭已不失。若入灭定或世俗心现在前。过去未来十。现在无。此中过去未来十者。是前初智初见时所起所修十支。余如前说

若依无寻无伺定。初无学智现在前。过去无。未来十。现在八。此中初无学智现在前者。谓尽智。过去无者。初刹那时未有一念已生灭故。设已生灭三缘舍故。未来十者。谓即初时具修未来无学十支。现在八者除正思惟及正见。余如前说。彼灭已不失。若复依无寻无伺定。无学智现在前。过去现在八。未来十。此中无学智现在前者。谓尽无生智随一。余如前说。彼灭已不失。若依无色定。无学智现在前。过去八。未来十。现在五。此中过去八者。谓前无寻无伺定初无学智俱生聚八支。余如前说。彼灭已不失。若入灭定或世俗心现在前过去八。未来十。现在无。此中过去八者。谓初智俱生聚八支余如前说。彼灭已不失。若依有寻有伺定。无学智现在前。过去八。未来十。现在九。此中现在九者。谓除正见。余如前说。彼灭已不失。若依无寻无伺定。初无学见现在前。过去现在八。未来十。此中初无学见现在前者。谓无学正见。过去八者。谓初智俱生聚八支。未来十者。谓前初智及今初见所修十支。余如前说。彼灭已不失。若复依无寻无伺定。展转乃至若依有寻有伺定。无学若智若见现在前等。皆随所应准前应说

若依无色定。初无学智现在前。过去无。未来十。现在五。此中初无学智现在前者。谓尽智。过去无者。初刹那时未有一念已生灭故。设已生灭三缘舍故。未来十者。谓即初时具修未来无学十支。现在五者。除正思惟正语业命及正见。余如前说。彼灭已不失。若复依无色定。无学智现在前。过去现在五。未来十。此中无学智现在前者。谓尽无生智随一。未来十者。谓初智时所修十支。余如前说。彼灭已不失。若入灭定或世俗心现在前。过去五。未来十。现在无。此中过去五者。谓初智俱生聚五支。余如前说。彼灭已不失。若依有寻有伺定。乃至若依无寻无伺定。无学智现在前等。皆随所应准前应说。若依无色定。初无学见现在前。过去现在五。未来十。此中初无学见现在前者。谓无学正见。过去五者。谓前初智俱生聚五支。未来十者。谓前初智及今初见所修未来十支。彼灭已不失。若复依无色定。无学若智若见现在前。过去六。未来十。现在五。此中过去六者。谓前初智俱生聚五支。及前初见俱生聚五支合为六。余如前说。彼灭已不失。若入灭定或世俗心现在前。展转乃至若依无寻无伺定。无学若智若见现在前等。皆随所应准前应说

此中一切过去未来皆说最初起及修者。不说后位所起所修。现在随起现前者说。所说无学亦通一切。非唯次第遍入定者。问何故得学果时。见为无间道。见为解脱道。得无学果时。见为无间道智为解脱道耶。答无学果位所应作业一切已办。加行止息不复寻求。故不名见。学果不尔故得见名。问何故无学位初说智后说见学位初后皆说见耶。答无学位初必起尽智。故初说智。后若更起胜功德时。亦有推度故后说见。学位先起苦法智忍。唯见非智故初说见。后无漏智所作未办。推度不息亦得见名。故后说见

说一切有部发智大毗婆沙论卷第九十四阿毗达磨大毗婆沙论卷第九十五

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    智蕴第三中学支纳息第一之三

云何为见。乃至广说。问何故作此论。答为止他宗显正理故。谓或有说。诸有为法皆是见性。所以者何。行相猛利说名为见。诸有为法皆有作用行相猛利。故有为法皆是见性。为遮彼意显唯眼根及决度慧是见非余。或复有说。现观边忍亦是智性。如譬喻者。彼作是说。无漏智眼初堕境时说名为忍。后安住境说名为智。如涉路者于平坦处。初念止息后便安住。大德亦说。下智名忍上智名智。为遮彼意显无漏忍是见非智。有余复说。尽无生智亦是见性。为遮彼意显彼息求。不复推度是智非见。复次此智蕴中。应具分别见智慧三自性差别故作斯论

云何为见。答眼根五见。世俗正见。学无学见。问何故眼根说名为见。答由四事故。一贤圣说故。二世俗说故。三契经说故。四世现见故。贤圣世俗说故者。谓诸贤圣及诸世俗俱作是言。我眼见彼往来行住坐卧等事。又若见人颠蹶迷谬。俱作是说。汝既眼见何故尔耶。契经说故者。谓契经说眼见色已。不应取相及取随好。复作是说。眼见色已应观不净如理思惟。复作是说。眼见色已好不应爱恶不应憎。复作是说。眼见色已起喜忧舍三意近行。复作是说。眼见色已不应欢戚。唯应住舍正念正知。世现见故者。谓世现见。眼明净者所见无谬。不明净者所见有谬。又世现见有眼根者能见诸色。无眼根者不能见色。又世现见眼所对方能见彼色。所不对方便不能见。又世现见多不能见被障诸色眼有障故。尊者世友作如是说。何故眼根说名为见。谓世现见有净眼者言我见净。有不净眼者言我见不净。大德说曰。何故眼根说名为见。谓契经说。眼根所得眼识所了说名所见。世俗亦然。是故眼根说名为见。五见者。谓有身见。边执见。邪见。见取。戒禁取。问何故此五说名为见。答以四事故。一观视故。谓能观视所应取境。问此五邪僻颠倒观视如何名见。答此虽邪僻颠倒观视。而是慧性故名为见。如人眼根。虽不明了而能观视。故亦名见。二决度故。谓能决度所应取境。问既一刹那如何决度。答性猛利故立决度名。三坚执故。谓于自境坚固僻执。非圣道剑不能令舍。佛及弟子以圣道剑。断彼见牙后方舍故。如有海兽名室首摩罗。凡所衔物坚执不舍。要以利剑断截其牙。然后乃舍。五见亦然。四深入故。谓于所缘锐利深入如针堕泥。复次以二事故此五名见。一照瞩故。二推求故。复次以三事故此五名见。一见相相应故。二能成见事故。三于缘无碍故。复次以三事故此五名见。一意乐故。二执着故。三寻求故。复次以三事故说名为见。一意乐故。二加行故。三无知故。意乐故者。谓得定者见。加行故者。谓寻思者见。无知故者。谓随闻者见

复次意乐故者。谓意乐坏者见。加行故者。谓加行坏者见。无知故者。谓俱坏者见。是故此五亦说名见。世俗正见者。谓善意识相应慧。是见性故说名为见。学见者。谓学无漏慧。无学见者。谓无学正见。此二亦俱是见性故名为见。应知此中五见于境如霠夜见色。世俗正见于境如晴夜见色。学见于境如霠昼见色。无学见于境如晴昼见色

云何为智。答五识相应慧除无漏忍。余意识相应慧。此中五识相应慧有三种。一善。二染污。三无覆无记。善者谓唯生得善。染污者。谓唯修所断贪嗔痴相应。无覆无记者。谓异熟生。亦有少分威仪路工巧处及通果心俱生。余意识相应慧亦有三种。一善二染污三无覆无记。善有二种。一有漏。二无漏。有漏善有三种。一加行得。二离染得。三生得。加行得者谓闻所成慧。思所成慧。修所成慧。闻所成慧者。谓于文义如理决择。思所成慧者。谓不净观持息念。及念住等。修所成慧者。谓暖顶忍世第一法。现观边世俗智。无量解脱胜处遍处等。离染得者。谓静虑无量无色解脱胜处遍处等。生得者。谓生彼地法尔所得善。无漏有二种。一学二无学。学谓学八智。无学谓尽智无生智。无学正见智。染污者。谓见修所断烦恼随烦恼相应。无覆无记者。谓异熟生威仪路工巧处通果心俱生

云何为慧。答六识相应慧。此有三种。谓善染污无覆无记。广如前说。有差别者。无漏八忍亦是慧摄。择法通故。一切心俱皆得有慧。已说见智慧三种自性。复应分别此三杂不杂相。诸见是智耶。答应作四句。见与智自性互有广狭故。有见非智。谓眼根及无漏忍。问何故眼根不名为智。答眼根是色。智非色故。复次眼根不相应。无所依。无所缘。无行相。无警觉。智不尔故。问何故无漏忍非智耶。答以无漏忍于所观谛。虽忍而未决。虽观而未审。虽寻求而未究竟。虽伺察而未了知。虽现观而未重审。唯作功用加行不息。故不名智。复次决定义是智义。忍与所断疑得俱生。于所见境未极决定。故不名智。尊者世友作如是说。忍于圣谛虽正堪忍。而未审知故不名智。大德说曰。见事究竟乃立智名。非初忍时见事究竟。故无漏忍虽不名智而实是智。雾尊者曰。重观名智。从无始来于四圣谛。未有一念圣慧曾观。忍起创观故未名智。五识俱慧虽于所缘不能重观。而色等境从无始来。已起无量有漏慧观。依种类说既名重观。故亦名智。余有漏智不重缘者。准此应知。不应为难

有智非见。谓五识身相应慧尽无生智。除五见及世俗正见。余意识相应有漏慧。问何故五识身相应慧非见耶。答行相猛利深入所缘说名为见。五识身相应慧行相不猛利。不能深入所缘。故不名见。复次见能分别。彼慧不能分别故。见能缘自相共相。彼慧唯能缘自相故。见能缘三世及无为。彼慧唯能缘现在故。见能数数取境。彼慧唯能一刹那取境故。见于所缘筹量观察。彼慧不尔。由如是等种种因缘。五识身相应慧不名为见。问尽智无生智何故非见耶。答此二智行相不猛利故。不深入所缘故。复次见作功用加行不息。二智不尔。如安住鸟故不名见。复次寻求伺察说名为见。二智不尔。故不名见。由此尊者妙音说曰。尽无生智所作已办。更无胜事而可追求。故不名见。有作是说。诸无漏慧总有二种。一能对治恶见。二能对治无知。能对治恶见者名见。尽无生智唯能对治无知。故不名见。复有说者。诸无漏慧总有三种。一唯能对治恶见。二唯能对治无知。三能对治恶见无知。唯能对治恶见者。是见非智。谓现观边无漏忍。唯能对治无知者。是智非见。谓尽智无生智。能俱对治者。是智亦是见。谓余无漏慧。尊者世友作如是说。推度名见。尽无生智所作究竟。不复推度故不名见。复作是说寻求名见。尽无生智所作已办。不复寻求故不名见。复作是说。若尽无生智是见性者。诸阿罗汉唯应成就九无学支。除正智支。然世尊说。诸阿罗汉成就十无学支故。尽无生智非见。问如世俗正见学见无学见。虽亦是智而名为见。若尽无生智虽亦是见。而名为智。斯有何失。答如初修习加行观时。世俗正见虽具智见性。而立正见支非正智支。已入学位诸学八智。虽具智见性。而立正见支非正智支。已至无学位无学正见。虽具智见性而立正见支非正智支。若尽智无生智亦具智见性者。亦应立正见支非正智支。是则诸阿罗汉。唯应成就九无学支。如是便违世尊所说。诸阿罗汉成就十支。大德说曰。尽无生智定是见性决度性故。问若尔。阿罗汉应唯成就九支。答二支唯无学地有。谓正解脱正智。八支通学无学地有。谓余八支。尽无生智虽亦是见。而所作事已得究竟。异前学位。故别立支不应为难。评曰。应作是说。尽无生智是智非见。所作已办。于四圣谛不复推求加行息故。除五见及世俗正见。余意识相应有漏慧者。此有二种。一染污。二无覆无记。染污者。谓贪嗔慢疑。及不共无明相应慧。无覆无记者。谓异熟生威仪路工巧处通果心俱生慧。问何故意地贪等相应慧非见耶。答彼慧行相不猛利故。不能深入所缘境故。复次彼二烦恼所覆损故。二烦恼者。谓贪嗔慢疑随一。及彼相应无明。问若尔。不共无明相应慧应是见。唯一烦恼相应起故。答彼无明有二种。一见所断不共无明。覆障尤重过二烦恼。二修所断不共无明。与自力起缠垢相应。彼独立故。能覆损慧如贪嗔等故。彼相应慧如贪等相应亦不名见。问何故无覆无记慧非见耶。答彼慧行相不猛利故。不能深入所缘境故。复次彼慧势力极羸劣故不名为见。要有势力于境坚强方名见故。问诸异熟生威仪路慧势力羸劣于理可尔。工巧处慧及通果心相应之慧。势力强盛宁非见耶。答工巧处慧虽有势力最强盛者。如毗湿缚羯磨天等彼所造作如愿智生。而为邪命所覆损故不名为见。谓工巧事皆欲活命为因起故。虽工巧处心心所法现在前时是不染污。而为邪命力所引生故。说彼由邪命覆损即是为贪所覆损义。设不为贪所覆损者。势力浮浅行相劣钝。于所缘境不能深入。故不名见。复次二巧处慧如疑而转。于所缘境不能决定。所以者何。虽极巧者作工巧事。若为他人之所弹斥便犹豫故。诸通果慧于所缘境亦不猛利。不能深入所缘境故。但由前定势力所引任运转故。于所缘境不推求故不名为见。复次诸通果慧由先串习。所变化事为因引生。如习工巧故不名见。复次异熟生等四无记慧皆势力劣。如不成善不成染污。故不成见。有见亦智。谓五见世俗正见。除无漏忍及尽无生智。余无漏慧即学八智。及无学正见此无漏慧。及前五见世俗正见。皆具见智二种相故第三句摄

有非见非智谓除前相。相谓所名。若法是前三句所表皆名为相。除此余法为第四句。是第四句所表之法。此复是何。谓色蕴中除眼余色。于行蕴中除慧余行。及三蕴全并无为法为第四句

诸见是慧耶。答应作四句。见与慧自性互有广狭故。有见非慧谓眼根能观视故。色自性故。有慧非见。谓五识身相应慧尽无生智。除五见及世俗正见。余意识相应有漏慧。择法性故。非推度故。广说如前有见亦慧。谓除尽无生智余无漏慧。及五见世俗正见。即无漏忍学八智及无学正见等。能推度故。择法性故。具二种相。有非见非慧。谓除前相。相谓所名。如前广说。诸智是慧耶。答诸智皆是慧。能审决者皆择法故。有慧非智。谓无漏忍创观谛境未审决故

见摄智智摄见耶。乃至广说。此中有二种四句。一种二句准前问定应知其相

诸成就见彼智耶乃至广说。此中见智慧三。若成就一必有余二。是故皆作如是句答。问谁成就见智慧耶。答一切有情。此即总说然有多少。谓断善根者。成就三界见所断见智慧。成就三界修所断染污智慧。成就欲界无覆无记智慧。不断善根未得色界善心者。成就三界见所断见智慧。成就三界修所断染污智慧。成就欲界善见智慧。成就欲界无覆无记智慧。已得色界善心未离欲染者。成就三界见所断见智慧。成就三界修所断染污智慧。成就欲色界善见智慧。成就欲界无覆无记智慧。已离欲染未得无色界善心者。若生欲界成就色无色界见所断见智慧。成就色无色界修所断染污智慧。成就欲色界善见智慧。成就欲色界无覆无记智慧。若生色界不成就欲界善见智慧。成就余如生欲界说。已得无色界善心。未离色染者。若生欲界成就色无色界见所断见智慧。成就色无色界修所断染污智慧。成就三界善见智慧。成就欲色界无覆无记智慧。若生色界不成就欲界善见智慧。成就余如生欲界说。已离色染生欲界者。成就无色界见所断见智慧。成就无色界修所断染污智慧。成就三界善见智慧。成就欲色界无覆无记智慧。若生色界不成就欲界善见智慧。成就余如生欲界说若生无色界不成就欲色界善见智慧。及不成就欲色界无覆无记智慧。若异熟生心现在前。则成就无色界无覆无记智慧。若异熟生心不现在前。则亦不成就无色界无覆无记智慧。成就余如生欲界说。异生如是

若圣者。随信随法行苦智未已生。未离欲染者。成就三界见所断见智慧。成就三界修所断染污智慧。成就欲色界善见智慧。成就欲界无覆无记智慧。成就无漏见慧。即彼已离欲染未离色染者。成就色无色界见所断见智慧。成就色无色界修所断染污智慧。未得无色界善心者。成就欲色界善见智慧。已得无色界善心者。成就三界善见智慧。成就欲色界无覆无记智慧。成就无漏见慧。即彼已离色染者。成就无色界见所断见智慧。成就无色界修所断染污智慧。成就三界善见智慧。成就欲色界无覆无记智慧。成就无漏见慧。苦智已生集智未已生未离欲染者。成就三界见集灭道见智慧。成就三界修所断染污智慧。成就欲色界善见智慧。成就欲界无覆无记智慧。成就无漏见智慧。即彼已离欲染未离色染者。成就色无色界见集灭道所断见智慧。成就色无色界修所断染污智慧。未得无色界善心者。成就欲色界善见智慧。已得无色界善心者。成就三界善见智慧。成就欲色界无覆无记智慧。成就无漏见智慧。即彼已离色染者。成就无色界见集灭道所断见智慧。成就无色界修所断染污智慧。成就三界善见智慧。成就欲色界无覆无记智慧。成就无漏见智慧。集智已生灭智未已生未离欲染者。成就三界见灭道所断见智慧。成就三界修所断染污智慧。成就欲色界善见智慧。成就欲界无覆无记智慧。成就无漏见智慧。即彼已离欲染

未离色染。成就色无色界见灭道所断见智慧。成就色无色界修所断染污智慧。未得无色界善心者。成就欲色界善见智慧。已得无色界善心者。成就三界善见智慧。成就欲色界无覆无记智慧。成就无漏见智慧。灭智已生道智未已生未离欲染者。成就三界见道所断见智慧。成就三界修所断染污智慧。成就欲色界善见智慧。成就欲界无覆无记智慧。成就无漏见智慧。即彼已离欲染未离色染者。成就色无色界见道所断见智慧成就色无色界修所断染污智慧。未得无色界善心者。成就欲色界善见智慧。已得无色界善心者。成就三界善见智慧。成就欲色界无覆无记智慧。成就无漏见智慧。即彼已离色染。成就无色界见道所断见智慧。成就无色修所断染污智慧。成就三界善见智慧。成就欲色界无覆无记智慧。成就无漏见智慧

信胜解见至未离欲染者。成就三界修所断染污智慧。成就欲色界善见智慧。成就欲界无覆无记智慧。成就无漏见智慧。即彼已离欲染。未得无色界善心者若生欲界。成就色无色界修所断染污智慧。成就欲色界善见智慧。成就欲色界无覆无记智慧。成就无漏见智慧。若生色界不成就欲界善见智慧。成就余如生欲界说。即彼已得无色界善心。未离色染者若生欲界。成就色无色界修所断染污智慧。成就三界善见智慧。成就欲色界无覆无记智慧。成就无漏见智慧若生色界不成就欲界善见智慧。成就余如生欲界说。即彼已离色染。若生欲界。成就无色界修所断染污智慧。成就三界善见智慧。成就欲色界无覆无记智慧。成就无漏见智慧。若生色界不成就欲界善见智慧。成就余如生欲界说。若生无色界不成就欲色界善见智慧及不成就欲色界无覆无记智慧。若异熟生心现在前。则成就无色界无覆无记智慧。若异熟生心不现在前。则亦不成就无色界无覆无记智慧。成就余如生欲界说。阿罗汉若生欲界。成就三界善见智慧。成就欲色界无覆无记智慧。成就无漏见智慧。若生色界成就色无色界善见智慧。成就欲色界无覆无记智慧。成就无漏见智慧。若生无色界异熟生心不现在前。成就无色界善见智慧。成就无漏见智慧。若异熟生心现在前。亦成就无色界无覆无记智慧

诸见已断已遍知彼智耶。答如是设智已断已遍知彼见耶。答如是。诸见已断已遍知彼慧耶。答如是设。慧已断已遍知彼见耶。答如是。诸智已断已遍知彼慧耶。答如是。设慧已断已遍知彼智耶。答如是。所以者何。见智慧三断遍知位皆相似故。问谁于见智慧已断已遍知。答诸阿罗汉此说究竟断遍知者。有学异生多少不定。谓阿罗汉三界。见智慧皆已断已遍知。诸不还者。若已离无所有处染。三界见所断见智慧。及八地修所断见智慧已断已遍知。乃至若未离初静虑染。三界见所断见智慧。及欲界修所断见智慧。已断已遍知。诸一来预流者。三界见所断见智慧已断已遍知。随信随法行若灭智已生道智未已生。三界见苦集灭所断见智慧。已断已遍知。若集智已生灭智未已生。三界见苦集所断见智慧。已断已遍知。若苦智已生集智未已生。三界见苦所断见智慧。已断已遍知。圣者如是。若诸异生已离无所有处染。八地见修所断见智慧。已断已遍知。乃至已离欲界染未离初静虑染。一地见修所断见智慧。已断已遍知。是名见智慧三。问定摄成就断五门分别

诸正见是择法觉支耶。乃至广说。问何故作此论。答前论是此所依根本。谓前作是说。云何为见。云何为智。云何为慧。虽作是说而未分别正见正智。与择法觉支互有广狭。今欲分别故作斯论。然今于此阿毗达磨发智论中有决定相。若觉支后分别道支则道支唯无漏。以七觉支唯无漏故。若觉支前分别道支。则道支通有漏无漏。此中觉支前分别道支故。应知道支通有漏无漏。是谓此处略毗婆沙。诸有智者应随分别

诸正见是择法觉支耶。答应作四句。正见与择法觉支互有广狭故。有正见非择法觉支谓世俗正见以诸觉支助如实觉唯无漏故。有择法觉支非正见。谓尽无生智非见性故。有正见亦择法觉支。谓除尽无生智余无漏慧即现观边八忍。及学八智无学正见。如是三种具二相故。有非正见亦非择法觉支。谓除前相。相谓所名如前广说。此复是何。谓行蕴中除意识相应善慧。诸余行蕴及四蕴全并无为法作第四句。诸正智是择法觉支耶。答应作四句。正智与择法觉支亦互有广狭故。有正智非择法觉支谓世俗正智彼无觉支相故。有择法觉支非正智。谓无漏忍彼无智相故。有正智亦择法觉支。谓除无漏忍余无漏慧。即学八智及尽无生智无学正见具二相故。有非正智亦非择法觉支。谓除前相。相谓所名如前广说。此复是何。谓行蕴中除六识相应善慧。诸余行蕴。及四蕴全并无为法作第四句。问何故此中唯说正见正智与择法觉支互有广狭。不说余道支与余觉支互有广狭耶。答是作论者意欲尔故。乃至广说。复次此中亦应说诸是正勤。亦是精进觉支耶。答诸是精进觉支亦是正勤有是正勤非精进觉支。谓世俗正精进乃至诸是正定亦是定觉支耶。答诸是定觉支亦是正定。有是正定非定觉支。谓世俗正定。应作是说而不说者。应知此中是有余说。复次此中所说现始现终略去中间。故作是说。始谓正见终谓正智。如现始终初入已度。方便究竟应知亦尔。复次若法相对满四句者此中说之。若法相对唯有顺后句者此中不说。复次此智蕴中若法是见智慧自性者。则分别之是智类故。精进念定非智类故此中不说。七觉支八道支一一现在前时几觉支几道支现在前耶。问何故作此论。答为止他宗显正理故。谓或有说。诸心所法次第而生。非一时生。如譬喻者。大德亦说。诸心所法次第而生。非一时生。如多商侣过一狭路。要一一过非二非多。诸心所法亦复如是。一一各别生相所生。必无一时和合生义。问彼依何量作如是说。答依至教量。谓契经说。若于尔时心沈恐沈。修三觉支名非时修。谓轻安定舍。修三觉支名是时修。谓择法精进喜。若于尔时心掉恐掉。修三觉支名非时修。谓择法精进喜。修三觉支名是时修。谓轻安定舍。彼作是说。觉支既有时非时修。故知心所次第而生。非一时起。又余经说。舍利子言。我于七觉支定能随意自在住。谓我欲于此觉支定日初分住。即便能住。若我欲于此觉支定日中分住。即便能住。若我欲于此觉支定日后分住。即便能住。彼作是说。既舍利子于七觉支随所欲住。故知心所次第而生。非一时起其理决定。为遮彼意显诸心所有一时生故作斯论。问若诸心所有一时生。云何通彼所引契经。答前契经说。时非时修三觉支者。乃证心所非要次第一一而生。说三觉支一时修故。证诸心所有俱时生。问若诸觉支随所依地。或六或七一时而生。何故经说时非时修各唯三种。答依止观品觉支势用有增减故作如是说。谓三觉支是奢摩他品。三觉支是毗钵舍那品。若奢摩他品觉支增时令心沉下。尔时应修观品觉支策心令举。而修止品故说非时。若毗钵舍那品觉支增时令心浮举。尔时应修止品觉支抑心令下。而修观品故说非时。虽诸觉支一时而起。而用有增减故唯说三。复次入圣道时依止观品。有差别故作如是说。谓若依奢摩他品觉支入圣道者。应修止品觉支抑心令下。而修观品故说非时。若依毗钵舍那品觉支入圣道者。应修观品觉支策心令举。而修止品故说非时。有余师说。与上相违。谓若依奢摩他品觉支入圣道者。心多沉下。应修观品觉支策心令举。而修止品故说非时。若依毗钵舍那品觉支入圣道者。心多浮举。应修止品觉支抑心令下。而修观品故说非时。虽诸觉支体俱时起。而彼作用有增减时。故经所说不违俱起。但违次第一一而生

说一切有部发智大毗婆沙论卷第九十五阿毗达磨大毗婆沙论卷第九十六

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    智蕴第三中学支纳息第一之四

彼后所引舍利子经亦不定遮一时生义。谓舍利子。善知入出觉支定心。于觉支定。随心所欲能自在住。此依时分说住觉支随意自在。不说别起一一觉支。故不成证。复次彼经依住三地觉支。故作是说亦不违理。谓于日初分欲住有寻有伺地觉支。即便能住。于日中分欲住无寻唯伺地觉支。即便能住。于日后分欲住无寻无伺地觉支。即便能住。故作是说不违俱起。复次彼经依住三根相应觉支而说亦不违理。谓于日初分欲住乐根相应觉支。即便能住。于日中分欲住喜根相应觉支。即便能住。于日后分欲住舍根相应觉支。即便能住。故作是说不违俱起。复次彼经依住三三摩地俱生觉支而说亦不违理。谓于日初分欲住空三摩地俱生觉支。即便能住。于日中分欲住无愿三摩地俱生觉支。即便能住。于日后分欲住无相三摩地俱生觉支。即便能住。故作是说不违俱起。复次彼经依住三智俱生觉支而说亦不违理。谓于日初分欲住尽智俱生觉支。即便能住。于日中分欲住无生智俱生觉支。即便能住。于日后分欲住无学正见智俱生觉支。即便能住。故作是说不违俱起。复次彼经依住九地觉支而说亦不违理。谓于日初分欲住未至定等三地觉支。即便能住。于日中分欲住后三静虑地觉支。即便能住。于日后分欲住前三无色地觉支。即便能住。故作是说不违俱起。或复有执。静虑近分有喜无戒。或复有执。静虑中间以上诸地有正思惟。或复有执。无色地中亦得有戒。为遮此等种种异执及显正理故作斯论

若依未至定念觉支现在前时。学六觉支八道支现在前。无学六觉支九道支现在前。此中六觉支者除喜觉支。九道支者正见正智随除一种。余皆具有。此说即遮静虑近分有喜无戒。亦有诵言。若依有寻有伺未至定。念觉支现在前者。虽于义无益而为除疑故作是说。如余处说。依未至言通静虑中间。及上地近分。皆未至彼根本定故立未至名。今为简去静虑中间及上近分。故说若依有寻有伺未至定言。此显唯依初静虑前未至定念觉支现在前。若依初静虑念觉支现在前时。学七觉支八道支现在前。无学七觉支九道支现在前。此中九道支者如前说。余皆具有。若依静虑中间念觉支现在前时。学六觉支七道支现在前。无学六觉支八道支现在前。依第三第四静虑亦尔。此中六觉支者除喜觉支。学七道支者除正思惟。无学八道支者除正思惟及正见正智随一。此说便止上地亦有正思惟执。若依第二静虑念觉支现在前时。学七觉支七道支现在前。无学七觉支八道支现在前。彼地有喜无正思惟。余如前说。若依无色定念觉支现在前时。学六觉支四道支现在前。无学六觉支五道支现在前。此中六觉支者除喜觉支。学四道支者。除正思惟及正语业命。无学五道支者。即除前四及正见正智随一。此说便止无色定中亦有戒执择法精进轻安定舍觉支。正见正勤正念正定道支亦尔。皆通一切地如念觉支故此即总说。有差别者。若正见道支现在前时定除正智

若依初静虑喜觉支现在前时。学七觉支八道支现在前。无学七觉支九道支现在前。此中九道支者正见正智随除一种。余皆具有。若依第二静虑喜觉支现在前时。学七觉支七道支现在前。无学七觉支八道支现在前。此中学七道支者除正思惟。无学八道支者。除正思惟及正见正智随一。问何故近分地无喜觉支耶。答非田器故。复次诸近分地已离下染未离下染俱得现前。未甚希奇故不生喜。如人被缚及解脱时所得胜事。心于此事不以为奇。故不生喜。复次若近分地亦有喜者。与根本地应无差别。复次若近分地亦有喜者。应耽着此喜不求根本地。若尔便应障离下染。如人中路有所耽着。于所趣方不能速至。故诸近分无喜觉支。若依未至定正思惟现在前时。学六觉支八道支现在前。无学六觉支九道支现在前。此中六觉支者。除喜觉支。九道支者。正见正智随除一种。余皆具有。若依初静虑正思惟现在前时。学七觉支八道支现在前。无学七觉支九道支现在前。此中无学九道支者如前应知。问何故上地无正思惟。答非田器故。复次为对治寻希求上地。若上地中亦有寻者。应不希求起胜加行。复次若下地法上地皆有。是则应无渐次灭法。若无渐灭法应无究竟灭法。若无究竟灭法。应无解脱出离涅槃。勿有此失。是故上地无正思惟。复次正思惟粗上地微细。复次正思惟者。是寻求相。上无寻求故彼非有。复次若地中有身语表业。及五识中随有一种。可于此地有正思惟。上地中无身语表业。及五识身故彼非有。若依未至定正语现在前时学六觉支八道支现在前。无学六觉支九道支现在前。此中六觉支者。除喜觉支。余如前说。若依初静虑正语现在前时。学七觉支八道支现在前。无学七觉支九道支现在前。此中无学九道支者如前应知。若依静虑中间正语现在前时。学六觉支七道支现在前。无学六觉支八道支现在前。依第三第四静虑亦尔。此中六觉支者除喜觉支。学七道支者除正思惟。无学八道支者。除正思惟及正见正智随一。若依第二静虑正语现在前时。学七觉支七道支现在前。无学七觉支八道支现在前。此中学七道支无学八道支俱如前说。正业正命亦尔者。俱唯六地有故。问何故无色无正语等三种戒耶。答非田器故。复次戒是色一分。无色无色故彼无戒。复次戒是大种所造。无色无大种故亦无戒。问既无无漏大种。亦应无无漏戒耶。答戒由大种而得成。色不由大种而成。无漏但由心力成无漏故。复次厌患诸色入无色定。戒是色故彼地中无。复次若无色定犹有色者。则应无有渐次灭法。乃至广说。故彼无戒。复次对治恶戒故有善戒。无色界定不能对治诸恶戒法。故无善戒。所以者何。诸恶戒法唯欲界有。无色于欲具四远故不能对治。云何四远。一所依远。二所缘远。三行相远。四对治远。故无色定无正语等三种戒支

有三十七菩提分法。谓四念住四正胜四神足五根五力七觉支八道支。世尊虽说菩提分法而不说有三十七种。但说七觉支名菩提分法。云何知然。经为量故。谓契经说有一苾刍来诣佛所顶礼双足。却住一面而白佛言。如世尊说。七觉支者何谓七觉支。世尊告曰。即七种菩提分法名七觉支。问菩提分法有三十七。何故世尊唯说七觉支名菩提分法。答佛随苾刍所问而答。苾刍唯问七觉支故。佛唯说七菩提分法。若彼苾刍问四念住乃至若问八道支者。佛亦应随彼所问一一而答。复次彼契经中唯说无漏菩提分法。唯七觉支一向无漏。故偏说之。余通有漏故彼不说。有作是说。余契经中亦具说有三十七种菩提分法。时既久远彼经灭没。云何知然。如彼尊者达罗达多作如是说。世尊有时说一道支。有时说二。乃至有时说三十七。即三十七菩提分法。如斧柯喻。契经中说于三十七修道法中若唯取决定者。则应说七种修道法。谓七觉支唯无漏故。若唯取不决定者。则应说余六位修道法。谓四念住乃至八道支。通有漏无漏故。若通取决定不决定者。则应说三十七种修道法。谓前六位及七觉支。故三十七菩提分法。亦是世尊契经所说。问菩提分法名有三十七。实体有几耶。答此实体。有十一或十二。若以一切摄入觉支即七觉支。名既有七实体亦七信正思惟各唯一种正语业命。有说为二。正命即是正语业故。有说为三。正语业外有正命故。若说为二即唯十一。若说为三则有十二。所以者何。谓四念住慧根慧力正见。摄入择法觉支。四正胜精进根精进力正勤。摄入精进觉支。四神足定根定力正定。摄入定觉支。念根念力正念。摄入念觉支。信根信力合为信故。若以一切摄入道支即八道支。名虽有八实体不定。若说正念即正语业。实体唯七。若说正命非正语业。实体有八。复有信喜轻安舍四。故亦十一。或有十二。所以者何。谓四念住慧根慧力择法觉支。摄入正见。四正胜精进根精进力精进觉支。摄入正勤。四神足定根定力定觉支。摄入正定。念根念力念觉支。摄入正念。信根信力合为一信故。有作是说。正语业命戒自性故应合为一。若作是说。菩提分法名有三十七。实体唯十。如名实体如是。名施设。体施设。名异相。体异相。名异性。体异性。名差别。体差别。名分别体分别。名觉。体觉。应知亦尔。如是名为菩提分。法自性。我物相分本性。已说自性。所以今当说。问何故名为菩提分法。菩提分法是何义耶。答尽无生智说名菩提。已究竟觉四圣谛故。若法随顺此究竟觉势用增上。此中说为菩提分法。已释总名。一一所以今应别说。问何故名念住乃至道支耶。答由念势力折除自体故名念住自体即是有漏五蕴。要由念住折除彼故。于正持策身语意中此最为胜。故名正胜或名正断。于正修习断修法时。能断懈怠故名正断。能为神妙功德所依故。名神足。势用增上故名为根难可摧制故名为力。助如实觉故名觉支。助正求趣故名道支。问言觉支者是何义耶。为能觉悟故名觉支。为觉之支故名觉支。若能觉悟故名觉支。则应一是六非若觉之支故名觉支。则应六是一非。有作是说。此能觉悟故名觉支。问若尔。则应一是六非。答六是觉分能随顺觉。从胜而说亦名觉支。复有说者。是觉之支故名觉支。问若尔则应六是一非。答择法是觉亦是觉支。余六是觉支而非觉。如正见是道亦是道支。余七是道支而非道。心一境性是静虑亦是静虑支。余是静虑支而非静虑。离非时食是斋亦是斋支。余是斋支而非斋。此亦如是。问言道支者是何义耶为能求趣故名道支。为道之支故名道支。若能求趣故名道支。则应一是七非。若道之支故名道支。则应七是一非。有作是说。此能求趣故名道支。问若尔。则应一是七非答七是道分能随顺道从胜而说亦名道支。复有说者。是道之支故名道支。问若尔。则应七是一非。答正见是道亦是道支。余七是道支而非道。如择法是觉亦是觉支。余六是觉支而非觉。余如前说。已说菩提分法。所以次第今当说。问何故先说四念住乃至后说八道支耶。答随顺文词巧妙次第法故。复次随顺说者受者轻便次第法故。复次四念住从初业地乃至尽无生智。势用常胜是故先说。四正胜从暖乃至尽无生智。势用常胜是故次说。四神足从顶乃至尽无生智。势用常胜是故次说。五根从忍乃至尽无生智。势用常胜是故次说。五力从世第一法乃至尽无生智。势用常胜是故次说。八道支见道中胜七觉支修道中胜。问何故八道支见道中胜。七觉支修道中胜耶。答求趣义是道支义。见道速疾不越期心。顺求趣义故见道中八道支胜。觉悟义是觉支义。修道九品数数觉悟。顺觉悟义故修道中七觉支胜。问若尔。何故先说七觉支。后说八道支耶。答随顺文词巧妙次第法故。复次随顺说者受者轻便次第法故。复次随顺增数次第法故。谓先说四次说五次说七后说八故。复次显清净法渐增长故。谓先修四次修五次修七后修八故。有余师说。诸修行者。先由念住于身等境。自相共相如实了知。除自相愚及所缘愚导起诸善。如有目者引导盲徒。是故最初说四念住。由念住力了知境已。于断修事能发正勤。故于第二说四正胜。由正胜力令相续中。过失损减功德增盛。于殊胜定能正修习。故于第三说四神足。由神足力令信等五与出世法为增上缘。故于第四说于五根根义既成能招恶趣。烦恼恶业不能屈伏。故于第五说于五力。力义既成能如实觉四圣谛境无有犹豫。故于第六说七觉支既如实觉四圣谛已。厌舍生死欣趣涅槃。故于第七说八道支。评曰。应知此中前说为胜。以修道位邻近菩提。顺觉义胜故说觉支。又修道位九地九品数数能觉觉支胜故。如是已总说菩提分法七位次第。今当别说觉支道支二位次第。问何故七觉支中先说念觉支。乃至后说舍觉支耶。答随顺文词巧妙次第法故。复次随顺说者受者轻便次第法故。尊者妙音作如是说。已见谛者。忆念先时所现观事而为上首。修习觉支令渐圆满。如契经说。彼于此法系念思惟令不迷谬。起念觉支修令圆满。念圆满已于法简择筹量观察起择法觉支修令圆满。择法满已发勤精进心不退屈。起精进觉支修令圆满。精进满已发生胜喜心不染着。起喜觉支修令圆满。喜圆满已身心猗适离惛沈故。起轻安觉支修令圆满。轻安满已身心悦乐得三摩地。起定觉支修令圆满。定圆满已远离贪忧心便住舍。起舍觉支修令圆满。故七觉支如是次第。问何故八道支中先说正见支。乃至后说正定支耶。答随顺文词巧妙次第法故。复次随顺说者受者轻便次第法故。尊者妙音作如是说。求见谛者于现观事正见为先修习道支令渐圆满。如契经说。由正见故起正思惟。由正思惟故得正语。由正语故复得正业。由正业故复得正命。由正命故发起正勤。由正勤故便起正念。由正念故能起正定。故八道支如是次第

已说次第。所依地今当说。问何地有几菩提分法。答未至定中有三十六。除喜觉支。初静虑中具三十七。静虑中间及第三第四静虑各唯有三十五。除喜觉支及正思惟。第二静虑有三十六。除正思惟。前三无色有三十二。除喜觉支及正思惟正语业命。欲界有顶各有二十二。除觉支。道支唯无漏故。若觉支前说道支者。欲界有顶亦有道支通有漏故

已说依地。现在前今当说。问何地有几菩提分法俱时现前。答未至定中有三十六菩提分法。唯三十三俱时现前。除三念住。所以者何。以四念住所缘各别。尚无有二俱时现前。况有三四。初静虑中具三十七。唯三十四俱时现前。除三念住。静虑中间及第三第四静虑各三十五。唯三十二俱时现前除三念住。第二静虑有三十六。唯三十三俱时现前。除三念住。前三无色有三十二。唯二十九俱时现前。除三念住。欲界有顶有二十二。唯有十九俱时现前。除三念住余随义说非要别体

已说现在前。杂不杂相今当说。问此三十七菩提分法中。诸是觉支者亦是道支耶。答应作四句。有是觉支非道支。谓喜轻安舍。有是道支非觉支。谓正思惟正语业命。有是觉支亦是道支。谓除信诸余菩提分法。有非觉支亦非道支。谓信。问何故立喜为觉支耶。答顺觉悟义是觉支义。喜顺彼胜故立觉支。问云何喜顺彼胜。答以修道中九地九品数修胜觉。如如于谛能如实觉。如是如是发生胜喜。如如生喜。如是如是。复乐于谛起如实觉。如人掘地得诸珍宝。如如掘地如是如是得宝生喜。如如得宝生喜。如是如是复乐掘地。此亦如是。问何故不立喜为道支。答顺求趣义是道支义。喜非顺彼胜故不立道支。问云何喜非顺彼胜。答如如于谛发生胜喜。如是如是乐住不去。故于求趣喜非随顺。如人在路有所乐着。于所趣方不能速至。此亦如是。问何故轻安舍俱立为觉支。答顺觉悟义是觉支义。轻安与舍顺彼胜故俱立觉支。问云何轻安舍俱顺彼胜耶。答由轻安力息诸事务住平等舍。便能于谛起如实觉故顺彼胜。问何故轻安舍不立为道支。答顺求趣义是道支义。轻安与舍非顺彼胜故不立为道支。问云何此二非顺彼胜。答轻安息求。舍不乐趣。与求趣义一向相违。如去与住睡眠与觉一向相违。此亦如是。问正思惟何故立为道支非觉支耶。答顺求趣义是道支义。彼策正见求出生死速趣涅槃。如杖捶牛速有所至故立道支。求趣不息是正思惟觉支。安静义不相顺。诸安静者能如实觉是故不立彼为觉支。问何故正语业命立为道支非觉支耶。答顺求趣义是道支义。正语业命如毂能成见道轮故。顺求趣义立为道支。顺觉悟义是觉支义。觉悟非色是相应。有所依。有所缘。有行相。有警觉。正语业命与彼相违故不立为觉支。问何故信不立觉支道支耶。答初发趣时信用增上。已入圣位修觉道支。时分不同故俱不立。复次诸清净法于清净品。相有圆满者有不圆满者。圆满者。谓具有根力觉道支相。与此相违名不圆满。不圆满中有觉支相。无道支相者立为觉支非道支。如喜轻安舍。有道支相无觉支相者。立为道支非觉支。如正思惟正语业命。相圆满者立觉道支。如念定慧等。不圆满中无觉道支相者俱不立如信。问何不立心为菩提分法。答心无菩提分法相故。复次心于杂染清净品中势用均等。菩提分法于清净品。势用偏增是故不立。复次菩提分法多缘共相。心多缘自相是故不立。复次菩提分法对治烦恼。一切烦恼皆是心所。故能对治亦非是心。复次菩提分法辅佐菩提。心王不应辅佐于觉。如王无有辅佐臣义。复次心令生死轮转无穷。菩提分法能断生死。义不相应是故不立。复次菩提分法能调伏心。不可所调即能调摄。诸有欲令定即心者。说心亦是菩提分法。彼违理故非此所论。问大地法中何故但立念定慧受为菩提分。答念定慧三顺清净品势用增上。菩提分法亦复如是。故摄此三。受于杂染清净品中势用俱胜。故亦立为菩提分法。有余师说。受于杂染势用虽胜而于净品作饶益事。如旃荼罗姓虽鄙劣而与豪族作饶益事。故亦立为菩提分法。想思触欲于杂染品势用偏增。故不立为菩提分法。于假想观胜解偏增。菩提分法顺真实观。是故胜解非彼所摄。有余师说。菩提分法学位偏增。至无学位胜解方胜。故不立为菩提分法。作意于境令心发觉易脱不定。菩提分法令心住境。义不相应故亦不立。有余师说。初取境时作意力胜。至境相续彼力渐微。菩提分法要取境已多时方有。义不相应故亦不立。问何故三受皆通无漏。唯立喜为菩提分法。答乐舍二受无彼相故。复次菩提分法行相猛利。乐舍迟钝故俱不立。复次无漏乐受为轻安乐所覆损故。舍为行舍所覆损故相不明了。故不立为菩提分法

问何故寻伺俱通无漏。唯立寻为菩提分法。答伺无彼相是故不立。复次菩提分法行相猛利。伺用微劣是故不立。复次伺用为寻所覆损故。于策正见寻用偏增。故伺不立菩提分法。问大善地法中何故但立信精进轻安舍四种为菩提分法耶。答由此四种顺菩提胜故。偏立为菩提分法。谓趣菩提信为上首。将起众行信为初基。故立信为菩提分法。精进遍策趣菩提行。令速趣向三乘菩提。故亦立为菩提分法。轻安调适对治惛沈助观品胜。行舍平等对治掉举助止品胜。菩提分中止观为主。故俱立为菩提分法。惭愧等六散善品中势用虽胜。而于定善势用微劣。故不立为菩提分法。以菩提分定善摄故。有余师说。大善法中若所治强自性胜者立为觉分。余则不尔所治强者。谓与一切染心相应。自性胜者。谓众行本策发众行助止观胜。信精进轻安舍皆具二义。惭愧等六无具二者。谓惭等五二义并无。不放逸一种唯阙自性胜。故不立为菩提分法。问何故欣厌亦体是善。而不立为菩提分法。答欣厌二法不能遍缘。一心品中无容俱起。助觉非胜是故不立。问何故一切色等法中唯无表色。有立觉分非余法耶。答正语业命随顺圣道。势用偏增故立觉分。余法不尔是故不立。问何故圣种不立觉分。答若于在家及出家众。二事胜者立为觉分。一期心胜。二受行胜。彼四圣种于出家众有二事胜。于在家者唯一事胜。谓有期心无受行义。如天帝释坐宝花座。有十二那庾多诸天美女恒自围绕。常有六万音乐。而为娱乐。于四圣种虽有期心无受行义。影坚王等诸大国王。给孤独等诸大长者亦复如是。故四圣种不立觉分。有作是说。前三圣种无贪善根以为自性。第四圣种即是精进。乐断乐修精进摄故。若作是说。第四圣种亦是觉分。分别论者立四十一菩提分法。谓四圣种足三十七。不应理故非此所论品类足说。云何念觉支。谓圣弟子。于苦集灭道。思惟苦集灭道起能助菩提念。乃至广说。是未知当知根。或诸学者见生死过患涅槃胜利。起能助菩提念。乃至广说。是已知根。或阿罗汉。观心解脱起能助菩提念。乃至广说。是具知根。是名念觉支乃至舍觉支。广说亦尔。云何正见。谓圣弟子于苦集灭道思惟苦集灭道。起择法。乃至广说是未知当知根。或诸学者见生死过患涅槃胜利。起择法乃至广说。是已知根。或阿罗汉。观心解脱起择法。乃至广说。是具知根是名正见。乃至正定广说亦尔。问何故觉支。中说起能助菩提念等言。道支中不说起能助菩提择法等言答应说而不说者。当知此义有余。复次欲现异说异文。由异说异文故。说者受者俱生欣乐。复次欲现二门二略二阶二蹬二炬二明二光二影故作是说。复次先作是说。尽无生智名曰菩提。修道位中觉支义显。近菩提故说助菩提。见道位中道支义显。去菩提远是故不说。如契经说。不净观俱修念觉支。依止厌依止离依止灭回向于舍。乃至舍觉支广说亦尔。问不净观是有漏。七觉支是无漏。云何有漏法与无漏法俱。尊者世友作如是说。以不净观摄伏其心。令极调柔有堪能已无间能起觉支现前。从此复能起不净观。依如是义故说俱言

如契经说。诸圣弟子。若以一心属耳听法。能断五盖修七觉支速令圆满。问要在意识修所成慧能断烦恼非在五识。生得闻思能断烦恼。如何乃说若以一心属耳听法能断五盖。答依展转因故作是说。谓善耳识无间引生善意识。此善意识无间引生闻所成慧。此闻所成慧无间引生思所成慧。此思所成慧无间引生修所成慧。此修所成慧修习纯熟。能断五盖故不违理。问断五盖时未能圆满修七觉支。何故契经作如是说。能断五盖修七觉支速令圆满。答离欲染时名能断五盖。离色染时名修七觉支离无色染时名速令圆满故无有失。有作是说。离欲染时名能断五盖。离无色染时名修七觉支速令圆满。此说初后略去中间故无有失。复有说者。无间道时名能断五盖。解脱道时名修七觉支速令圆满。相邻近故说名为速

说一切有部发智大毗婆沙论卷第九十六阿毗达磨大毗婆沙论卷第九十七

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    智蕴第三中学支纳息第一之五

诸法念觉支相应。彼法择法觉支相应耶。乃至广说。问何故作此论。答为止他宗显正理故。谓或有执。无实相应诸心心所不俱起故。为遮彼意欲显相应是实有物故作斯论。答应作四句。此中念及择法觉支。俱遍一切地一切无漏心故。应作小四句。有法念相应非择法。谓择法觉支者。谓念俱生择法觉支自性。彼与念相应非择法觉支。由三缘故自性不与自性相应。一无二体俱时起故。二前与后。不和合故。三一切法不观自体。必以他体为缘生故。有法择法相应非念。谓念觉支者。谓择法俱生念觉支自性。彼与择法相应非念觉支。自性不与自性相应义如前说。有法念相应亦择法。谓二相应法者。谓念择法觉支俱生。除二自性余相应法。即八大地法。十大善地法。随地位亦有寻伺等及心。有法非念相应亦非择法。谓余心心所法色无为心不相应行者。谓除无漏心心所法。诸余有漏心心所法。及一切色无为心不相应行作第四句。如对择法觉支。对精进轻安定舍觉支。正勤正定亦尔者。如念觉支对择法觉支作小四句对精进觉支乃至正定应知亦尔。诸法念觉支相应彼法喜觉支相应耶。答应作四句。此中念觉支遍一切地一切无漏心。喜觉支遍一切无漏心。非一切地故。应作中四句。有法念相应非喜。谓喜觉支及喜不相应。念觉支相应法者。谓念俱生喜觉支自性。彼与念相应非喜觉支。自性不与自性相应义如前说。及喜不相应念觉支相应法。即未至定静虑中间。后二静虑前三无色。念觉支相应法。彼与念相应非喜觉支。彼诸地中皆无喜故。有法喜相应非念。谓喜觉支相应念者。谓喜俱生念觉支自性。彼与喜相应非念觉支。自性不与自性相应义如前说。有法念相应亦喜。谓二相应法者。谓念喜觉支俱生。除二自性余相应法。即八大地法。十大善地法。随地位亦有寻伺等及心有法非念相应亦非喜。谓喜不相应念觉支。及余心心所法色无为心不相应行者。谓未至定静虑中间。后二静虑前三无色念觉支自性。彼非念觉支相应。自性与自性不相应故。亦非喜觉支相应。彼诸地中皆无喜故。除无漏心心所法。诸余有漏心心所法。及一切色无为心不相应行作第四句。如对喜觉支。对正见正思惟亦尔者。如念觉支对喜觉支作中四句。对正见正思惟应知亦尔。诸法念觉支相应。彼法正念相应耶。答如是。设法正念相应彼法念觉支相应耶。答如是者谓念觉支即是正念故。应作如是句

诸法择法觉支相应。彼法精进觉支相应耶。答应作四句。此中择法精进觉支俱遍一切地一切无漏心故。应作小四句。有法择法相应非精进。谓精进觉支者。谓择法俱生精进觉支自性。彼与择法相应非精进觉支。自性与自性不相应故。有法精进相应非择法。谓择法觉支者。谓精进俱生择法觉支自性。彼与精进相应非择法觉支。自性与自性不相应故。有法择法相应亦精进。谓二相应法者。谓择法精进觉支俱生。除二自性余相应法即九大地法。九大善地法。随地位亦有寻伺等及心。有法非择法相应亦非精进谓余心心所法色无为心不相应行者。谓除无漏心心所法。诸余有漏心心所法。及一切色无为心不相应行作第四句。如对精进觉支对轻安定舍觉支正勤正念正定亦尔者。如择法觉支对精进觉支作小四句。对轻安定舍觉支。正勤正念正定应知亦尔。诸法择法觉支相应彼法喜觉支相应耶。答应作四句。此中择法觉支遍一切地一切无漏心。喜觉支遍一切无漏心非一切地。故应作中四句。有法择法相应非喜。谓喜觉支及喜不相应。择法觉支相应法者。谓择法俱生喜觉支自性。彼与择法相应非喜觉支。自性与自性不相应故。及喜不相应择法觉支相应法。即未至定静虑中间。后二静虑。前三无色择法觉支相应法。彼与择法相应非喜觉支彼诸地中皆无喜故。有法喜相应非择法。谓喜觉支相应择法者。谓喜俱生择法觉支自性。彼与喜相应非择法觉支。自性与自性不相应故。有法择法相应亦喜。谓二相应法者。谓择法喜觉支俱生。除二自性余相应法即八大地法。十大善地法。随地位亦有寻伺等及心。有非择法相应亦非喜。谓喜不相应择法觉支。及余心心所法。色无为心不相应行者。谓未至定静虑中间。后二静虑前三无色择法觉支自性。彼非择法觉支相应。自性与自性不相应故。亦非喜觉支相应。彼诸地中皆无喜故。除无漏心心所法诸余有漏心心所法。及一切色无为心不相应行作第四句。如对喜觉支。对正思惟亦尔者。如择法觉支对喜觉支作中四句。对正思惟应知亦尔。诸法择法觉支相应彼法正见相应耶。答诸法正见相应亦择法相应。有法择法相应非正见相应。谓正见所不摄择法觉支相应法者。谓尽无生智相应法。彼与择法觉支相应非正见。尽无生智非见性故。由择法宽正见狭故作顺后句。诸法精进觉支相应彼法喜觉支相应耶。答应作四句。此中精进觉支遍一切地一切无漏心。喜觉支遍一切无漏心。非一切地故。应作中四句。广释四句准前应知。如对喜觉支对正见正思惟亦尔者。如精进觉支对喜觉支作中四句。对正见正思惟应知亦尔。诸法精进觉支相应。彼法轻安觉支相应耶。答应作四句。此中精进与轻安觉支。俱遍一切地一切无漏心故。应作小四句广释四句准前应知。如对轻安觉支对定舍觉支正念正定亦尔者。如精进觉支对轻安觉支作小四句。对定舍觉支正念正定应知亦尔。诸法精进觉支相应。彼法正勤相应耶。答如是。设法正勤相应。彼法精进觉支相应耶。答如是者。谓精进觉支即是正勤故。应作如是句。诸法喜觉支相应。彼法轻安觉支相应耶。答应作四句。此中喜觉支遍一切无漏心非一切地。轻安觉支遍一切无漏心亦遍一切地故。应作中四句。广释四句准前应知。如对轻安觉支。对定舍觉支正勤正念正定亦尔者。如喜觉支对轻安觉支作中四句。对定舍觉支正勤正念正定应知亦尔。诸法喜觉支相应。彼法正见相应耶。答应作四句。此中喜觉支遍一切无漏心非一切地。正见遍一切地非一切无漏心故。应作大四句。有法喜相应非正见。谓喜觉支相应正见。及正见不相应。喜觉支相应法者。谓喜觉支俱生正见自性彼与喜觉支相应非正见。自性与自性不相应故。及正见不相应。喜觉支相应法。即初二静虑尽无生智俱生喜觉支相应法。彼与喜觉支相应。非正见是他聚故。有法正见相应非喜。谓正见相应喜觉支。及喜觉支不相应。正见相应法者。谓正见相应喜觉支自性。彼与正见相应非喜觉支。自性与自性不相应故。及喜觉支不相应。正见相应法即未至定静虑中间。后二静虑前三无色正见相应法。彼与正见相应非喜觉支。彼诸地中皆无喜故。有法喜相应亦正见。谓二相应法者。谓喜觉支正见俱生除二自性余相应法。即八大地法。十大善地法。随地位亦有寻伺等及心。有法非喜相应亦非正见。谓喜觉支不相应正见。正见不相应喜觉支。及余心心所法。色无为心不相应行者。谓喜觉支不相应正见。即未至定静虑中间。后二静虑前三无色。正见自性彼非喜觉支相应。彼诸地中皆无喜故。亦非正见相应。自性与自性不相应故。正见不相应喜觉支。即初二静虑尽无生智俱生喜觉支自性。彼非正见相应是他聚故。亦非喜觉支相应。自性与自性不相应故。及余心心所法。即未至定静虑中间。后二静虑前三无色。尽无生智俱生聚心心所法。及一切有漏心心所法。并一切色无为心不相应行作第四句。如对正见对正思惟亦尔者。如喜觉支对正见作大四句。对正思惟应知亦尔

诸法轻安觉支相应。彼法定觉支相应耶。答应作四句。此中轻安定觉支俱遍一切地一切无漏心故。应作小四句。广释四句准前应知。如对定觉支对舍觉支正勤正念正念亦尔者。如轻安觉支对定觉支作小四句。对舍觉支乃至正定。应知亦尔。诸法轻安觉支相应彼法正见相应耶。答应作四句。此中轻安觉支遍一切地一切无漏心。正见遍一切地非一切无漏心故。应作中四句。广释四句准前应知。如对正见对正思惟亦尔者。如轻安觉支对正见作中四句对正思惟应知亦尔

诸法定觉支相应。彼法舍觉支相应耶。答应作四句。此中定舍觉支。俱遍一切地一切无漏心故。应作小四句。广释四句准前应知。如对舍觉支对正勤正念亦尔者。如定觉支对舍觉支作小四句。对正勤正念应知亦尔。诸法定觉支相应。彼法正见相应耶。答应作四句。此中定觉支遍一切地一切无漏心。正见遍一切地非一切无漏心故。应作中四句。广释四句准前应知。如对正见对正思惟亦尔者。如定觉支对正见作中四句对正思惟应知亦尔。诸法定觉支相应。彼法正定相应耶。答如是。设法正定相应。彼法定觉支相应耶。答如是者。谓定觉支即是正定故应作如是句

诸法舍觉支相应。彼法正见相应耶。乃至广说。此中舍觉支对正见正思惟作中四句。对正勤正念正定作小四句。正见对正思惟作大四句。对正勤正念正定作中四句。正思惟对正勤正念正定作中四句。正勤对正念正定作小四句。正念对正定作小四句。如是一切准前应知

云何世俗正见。乃至广说。问何故作此论。答为欲分别诸契经中深隐义故。如契经说。若成就增上世俗正见者。设经百千生终不堕恶趣

如是等经虽说种种世俗正见而不广释。经是此论所依根本。彼未释者今应分别。复次前虽总说见智慧三。而未别说云何世俗正见。云何世俗正智。前论是此所依根本。彼未说者今应说之。复次为止他宗显正理故。谓或有说。意识相应善有漏慧非皆是见。如譬喻者彼作是说。五识所引能发表业。及命终时意地善慧皆非见性。所以者何。见有分别五识所引意地善慧。如五识身不能分别故非见性。见内门起能发表业。意地善慧依外门转故非见性。见用强猛命终善慧。势用微劣故非见性。问彼云何通契经所说。如契经说。彼命终时善心心所法。与正见俱行彼作是答。世尊说彼将命终时。相续善心正见俱起。非正死位有正见行。为遮彼执显意识俱。一切善慧皆见性摄。由如是等种种因缘故作斯论

云何世俗正见。答意识相应有漏善慧。此有三种。一加行得。二离染得。三生得。加行得者。谓闻所成慧。思所成慧。修所成慧。此中差别有不净观持息念等。及诸念住。并暖顶忍世第一法等俱生慧。离染得者。谓静虑无量无色解脱。胜处遍处等俱生慧。生得者。谓生彼地所得善慧。诸如是等世俗正见。差别无边如四大海水渧无量。今于此中略说粗显世俗正见。云何世俗正智。答五识相应善慧。及意识相应有漏善慧。五识相应善慧者。谓眼识相应善慧。乃至身识相应善慧。眼识相应善慧者。谓观父母诸佛独觉菩萨声闻亲教轨范。及余尊重同梵行等。所起眼识相应善慧。耳识相应善慧者。谓听父母亲教轨范。及余尊重同梵行等所有善语。及听诸佛圣弟子等三藏法教。所起耳识相应善慧。鼻舌身识相应善慧者。谓受用段食时所起三识相应善慧。此非一切皆能起之。要观行者观察段食。而受用时方能发起。意识相应有漏善慧广如前说

已说世俗正见正智自性。杂不杂相今当说。诸世俗正见。是世俗正智耶。答诸世俗正见亦是世俗正智。有世俗正智非世俗正见。谓五识相应善慧。此中世俗正见必于所缘重审决故。五识俱慧不名为见如前已说。世俗正见摄世俗正智。世俗正智摄世俗正见耶。答世俗正智摄世俗正见。非世俗正见摄世俗正智。不摄何等。谓五识相应善慧。此中正智体宽正见狭故。如大摄小非小摄大

诸成就世俗正见。彼世俗正智耶。答如是。设成就世俗正智。彼世俗正见耶。答如是。问谁成就世俗正见正智耶。答不断善根者。此则总说。若别说者有多有少。谓或有唯成就欲界世俗正见正智。或有唯成就色界。或有唯成就无色界。或有成就欲色界。或有成就色无色界。或有成就三界世俗正见正智。如说三界九地亦尔。或少或多如理应说。诸世俗正见已断已遍知。彼世俗正智耶。答如是。设世俗正智已断已遍知。彼世俗正见耶。答如是。问谁于世俗正见正智。已断已遍知耶。答诸阿罗汉。此则总说。若别说者有多有少。谓已离无所有处染异生圣者。八地世俗正见正智已断已遍知。乃至已离欲染未离初静虑染异生圣者。一地世俗正见正智已断已遍知。此世俗正见正智是有漏故。具问定摄成就断五门分别

问何故名世俗。为可变坏故名世俗。为贪依处故名世俗。若可变坏故名世俗者。圣道亦可变坏应名世俗。若贪依处故名世俗者。亦是嗔痴依处何独说贪。答应作是说。是可变坏故名世俗。问若尔圣道亦可变坏应名世俗。答若可变坏能续诸有增长有者名为世俗。圣道虽可变坏而不能续诸有。乃令诸有损减故非世俗。复次若可变坏能令生死流转无穷。生老病死恒相续者名为世俗。圣道虽可变坏而不令生死流转无穷。乃断生老病死令不相续故非世俗。复次若可变坏是趣苦集行。亦是趣有世间生老病死集行者名为世俗。圣道虽可变坏而非趣苦集行。亦非趣有世间生老病死集行故非世俗。复次若可变坏是有身见处。是颠倒处。爱处。随眠处。是贪恚痴安立足处。有垢有毒有过有刺有浊有染。随有世间随苦集谛者名为世俗。圣道虽可变坏而与彼相违故非世俗。复有说者。是贪依处故名世俗。问若尔亦是嗔痴依处何独说贪。答彼虽亦是嗔痴依处。而贪初胜是故偏说。然契经中说可变坏故名世俗。如契经言。具寿丰赡来诣佛所。顶礼双足而白佛言。世尊。所说世俗世俗义何谓耶。佛告丰赡。是可变坏故名世俗。具寿丰赡。复白佛言。何谓可变坏。佛告丰赡。眼处可变坏。色处可变坏。乃至意处可变坏。法处可变坏。由可变坏故名世俗。问何故世尊说十二处是可变坏故名世俗非余法耶。答观受化者。宜闻诸处是世俗言。而得悟解故偏说处。如余经中说取蕴等名为世俗此经亦然。复次十二处教是处中说。而摄法尽故偏说之。问诸变坏者皆世俗耶。答应作四句。有是世俗而非变坏。谓过去未来苦集二谛。有是变坏而非世俗。谓现在道谛。有是世俗亦是变坏。谓现在苦集二谛。有非世俗亦非变坏。谓过去未来道谛。及一切无为。问变与坏有何差别。答变者显示细无常法。坏者显示粗无常法。复次变者显示刹那无常。坏者显示众同分无常。复次变者显示内分无常。坏者显示外分无常。复次变者显示有情数无常。坏者显示非情数无常。如说舍坏仓库等坏。云何无漏见乃至广说。问何故作此论。答前虽总说见智慧三。而未别说云何无漏见云何无漏智。前论是此所依根本。彼未说者今应说之。复次前虽已说世俗见智。今欲显彼近对治法故作斯论。云何无漏见。答除尽无生智余无漏慧。此复是何。谓现观边八无漏忍。及学八智无学正见。云何无漏智。答除无漏忍余无漏慧。此复是何。谓学无学八智。已说无漏见智自性。今当显示杂不杂相。诸无漏见是无漏智耶。答应作四句。有无漏见非无漏智。谓无漏忍。此有见相无智相故。有无漏智非无漏见。谓尽无生智。此有智相无见相故。有无漏见亦无漏智。谓除无漏忍尽无生智。余无漏慧此复是何。谓学八智无学正见。此有见相及智相故。有非无漏见亦非无漏智。谓除前相。相谓所名广如前说。此复是何。谓行蕴中除无漏慧。诸余行蕴及四蕴全。并无为法。作第四句。无漏见智相摄四句准定应知。诸成就无漏见彼无漏智耶。答诸成就无漏智亦无漏见。有成就无漏见非无漏智。谓苦法智忍现在前时。尔时未修无漏智故。此本论师善知诸法性相差别。若应说者乃至一念亦别说之。不应说者乃至量过四大海水而亦不说。所说广略要观有用。问何故此中但说问定摄成就四不说断耶。答有垢者断。无漏无垢故不说断。如衣器等要有垢者。须浣涤之非无垢者。是故无漏不应说断。问若无漏法不应断者。契经所说。当云何通。如说苾刍。汝等若解我之所说筏喻法门。法尚应断。何况非法。此法应知即无漏道。答断有二种。一断爱断。二弃舍断圣道虽无断爱断而有弃舍断。般涅槃时弃舍此故。谓诸苾刍先依圣道得尽诸漏念报恩故。数复修起圣道现前。后为世间四百四病众苦逼切故

佛告曰。汝等苾刍。已依圣道作所应作。当应弃舍入无余依涅槃。如人依筏得渡河已。念报其恩而犹荷戴。他人告曰汝先依此已得渡河。今可弃舍自在而去苾刍亦尔

问此中云何是法非法。答内道言教是法。外道言教是非法。内道言教显空非我随顺涅槃。能令永断生老病死尚应断之。何况外道所有言教。背空非我违逆涅槃。能令世间生老病死增长相续而不应断。复有说者。若善受持名句文身者是法。不善受持名句文身者是非法。善受持者尚应断之。况不善者而不应断。尊者妙音作如是说。若善受持阿笈摩者是法。不善受持阿笈摩者是非法。善受持者尚应断之。况不善者而不应断。胁尊者曰。如理作意是法。不如理作意是非法。如理作意者尚应断之。况不如理者而不应断。复次惭愧是法。无惭无愧是非法。三善根是法。三不善根是非法。四念住是法。四颠倒是非法。五根是法。五盖是非法。六随念是法。六爱身是非法。七觉支是法。七随眠是非法。八道支是法。八邪支是非法。九次第定是法。九结是非法。十善业道是法。十不善业道是非法。此等清净法尚应断之。况彼等杂染法而不应断

    智蕴第三中五种纳息第二之一

云何邪见如是等章及解章义。既领会已次应广释。问何故作此论。答为欲分别契经义故。如契经说。苾刍。当知诸邪见者。如其所见起身语业。思求愿行皆是彼类。如是诸法一切能招不可爱乐。不可欣喜。不随所欲。不如意果。所以者何。由此邪见是勃恶见故。契经虽有是说。而不分别其义。经是此论所依根本。彼未说者今应说之。复次前虽总说见智慧三。而未别说。云何邪见云何邪智。前论是此所依根本。彼未说者今应说之故作斯论。云何邪见。答若不安立则五见皆名邪见。谓若不安立萨迦耶等。五见名及行相差别。即彼五见皆名邪见。皆于所缘邪推度故。若安立即唯无施与无爱乐。无祠祀。无妙行。无恶行。无妙恶行业。果异熟等见名邪见。谓若安立萨迦耶等五见名及行相差别。则唯作无行相转者。独名邪见邪中极故。如说嗅酥及恶旃茶罗等。云何邪智。答六识相应染污慧。此中五识相应染污慧者。谓贪嗔相应慧。意识相应染污慧者。谓五见及贪嗔慢疑不共无明。并余缠垢相应慧。如是一切皆名邪智。已说邪见邪智自性。杂不杂相今当说。诸邪见是邪智耶。答诸邪见是邪智。谓邪推求者必邪审决故。有邪智非邪见。谓五识相应染污慧。即贪嗔相应慧。及除五见余意识相应染污慧。即贪嗔慢疑及不共无明并余缠垢相应慧。邪见摄邪智邪智摄邪见耶。答邪智摄邪见。非邪见摄邪智不摄何等。谓五识相应染污慧及除五见余意识相应染污慧。有审决相无推度相故。诸成就邪见彼邪智耶。答诸成就邪见亦邪智。邪智多故见亦智故。即道类智未已生位。有成就邪智非邪见。谓学见迹即道类智已生。诸有学位名学见迹。已具见四圣谛迹故。此则总说。若别说者有多有少。谓或成就九地邪智。乃至或有成就一地邪智。一一地中或有成就九品邪智。乃至或有成就一品邪智。诸邪见已断已遍知彼邪智耶。答诸邪智已断已遍知亦邪见。谓阿罗汉有邪见已断已遍知非邪智。谓学见迹此则总说。若别说者有多有少。谓或有九地邪智非已断已遍知。乃至或有一地邪智非已断已遍知。一一地中或有九品邪智非已断已遍知。乃至或有一品邪智非已断已遍知。染污邪智九品断故。云何正见乃至广说。问何故作此论。答为欲分别契经义故。如契经说。诸正见者如其所见。起身语业思求愿行皆是彼类。如是一切能招可爱可乐可欣可喜随所欲如意果。所以者何。由此正见是贤善见故。契经虽有是说而不分别其义。经是此论所依根本。彼未说者今应说之。复次前虽总说见智慧三。而未别说云何正见云何正智。前论是此所依根本。彼未说者今应说之。复次前虽已说邪见邪智。今欲说彼近对治法故作斯论。云何正见。答尽无生智所不摄意识相应善慧。此有二种。一有漏。二无漏。有漏者。即世俗正见如前广说。无漏者。谓无漏忍及学八智无学正见。云何正智。答五识相应善慧。及无漏忍所不摄意识相应善慧。此有二种。一有漏即世俗正见。二无漏即学无学八智

已说正见正智自性。杂不杂相今当说。诸正见是正智耶。答应作四句。有正见非正智。谓无漏忍此有见相无智相故有正智非正见。谓五识相应善慧。及尽无生智。此有智相无见相故。有正见亦正智。谓无漏忍。尽无生智所不摄意识相应善慧。此有二种。一有漏即世俗正见。二无漏即学八智无学正见。此二皆具见智相故。有非正见亦非正智。谓除前相相即所名。广如前说。谓行蕴中除诸善慧。诸余行蕴及四蕴全。并无为法作第四句。此摄四句准定应知。诸成就正见彼正智耶。答如是。设成就正智彼正见耶。答如是。问谁成就正见正智耶。答不断善根者此则总说。若别说有多有少。谓或有唯成就欲界二。或有唯成就色界二。或有唯成就无色界二。或有唯成就色界无漏二。或有唯成就无色界无漏二。或有唯成就欲色界二。或有唯成就色无色界二。或有成就欲色无色界三。或有成就欲色界无漏二。或有成就色无色界无漏二。或有成就三界无漏二。诸正见已断已遍知彼正智耶。答如是。设正智已断已遍知彼正见耶。答如是。问谁于正见正智已断已遍知耶。答阿罗汉此则总说。若别说者有多有少。谓已离无所有处染有学异生。八地正见正智已断已遍知。乃至已离欲染未离初静虑染有学异生。一切正见正智已断已遍知。依究竟说唯阿罗汉

说一切有部发智大毗婆沙论卷第九十七阿毗达磨大毗婆沙论卷第九十八

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    智蕴第三中五种纳息第二之二

如契经说。云何邪见。谓无施与无爱乐无祠祀。乃至广说。云何正见。谓有施与有爱乐有祠祀。乃至广说。问施与爱乐祠祀有何差别。有作是说。无有差别施与爱乐祠祀三声。同显一义无差别故。如有颂言

  若施僧福田　　名善施爱祀
  世间解所赞　　彼当获大果

复有说者。亦有差别。谓名即差别。此名施与。此名爱乐。此名祠祀。三名别故。有说此三义亦差别。外论者言。无施与者谓无施三类福。无爱乐者。谓无施别婆罗门福。无祠祀者。谓无施众婆罗门福。复次无施与者。谓无施三类福。无爱乐者。谓无施非大祠中婆罗门福。无祠祀者。谓无施大祠中婆罗门福。复次无施与者。谓无施三类福。无爱乐者。谓无施不住天祠婆罗门福。无祠祀者。谓无施住天祠婆罗门福。复次无施与者。谓无施三类福。无爱乐者。谓无施非祀火婆罗门福。无祠祀者。谓无施祀火婆罗门福。复次无施与者。谓无施三类福。无爱乐者。谓无施在家婆罗门福。无祠祀者。谓无施出家婆罗门福。复次无施与者。谓无施三类福。无爱乐者。谓无施不修定婆罗门福。无祠祀者。谓无施修定婆罗门福。复次无施与者。谓无施三类福。无爱乐者。谓无施不修苦行婆罗门福。无祠祀者。谓无施修苦行婆罗门福。复次无施与者。谓无施三类福。无爱乐者。谓无施非善习诵吠陀。及吠陀支论婆罗门福。无祠祀者。谓无施善习诵吠陀。及吠陀支论婆罗门福。复次无施与者。谓无施三类福。无爱乐者。谓无施不具解行婆罗门福。无祠祀者。谓无施具解行婆罗门福。复次无施与者。谓无施三类等福。无爱乐者。谓无施婆罗门福。无祠祀者。谓无祠天福。内论者言。无施与者。谓无过去福。无爱乐者。谓无未来福。无祠祀者。谓无现在福

复次无施与者。谓无身业福。无爱乐者。谓无语业福。无祠祀者。谓无意业福。复次无施与者。谓无施性福。无爱乐者。谓无戒性福。无祠祀者。谓无修性福。复次无施与者。谓无施悲田福。无爱乐者。谓无施恩田福。无祠祀者。谓无施福田福。复次无施与者。谓无将施时欣乐福。无爱乐者。谓无正施时心净福。无祠祀者。谓无施已欢喜无悔福。复次无施与者。谓无能施净信。无爱乐者。谓无所舍财法。无祠祀者。谓无所施受者。复次无施与者。谓无所舍财法。无爱乐者。谓无所施受者。无祠祀者。谓无能施福业。复次无施与者。谓无将施时福。无爱乐者。谓无正施时福无祠祀者。谓无受用时福。复次无施与者。谓无布施时福。无爱乐者。谓无受用时福。无祠祀者。谓无后随念福。复次无施与者。谓无作意舍福。无爱乐者。谓无身语舍福。无祠祀者。谓无彼受用福。复次无施与者。谓无能施福。无爱乐者。谓无施所得果。无祠祀者。谓无所施田。复次无施与者。谓无施恶趣福。无爱乐者。谓无施人趣福。无祠祀者。谓无施天趣福。复次无施与者。谓无施异生福。无爱乐者。谓无施有学圣者福。无祠祀者。谓无施无学圣者福。此等名为三种差别

诸左慧皆是结耶。乃至广说。问何故作此论。答为止他宗显正理故。谓或有说。诸染污慧非结自性。彼作是说。云何是慧而有缚义。为遣彼执显染污慧见为性者是结所摄。故作斯论。诸左慧皆是结耶。答应作四句。左慧与结互广狭故。有左慧非结。谓除二结余染污慧。除二结者。谓除见结取结。余染污慧者。谓贪嗔慢疑不共无明。及余缠垢相应慧。此有左慧相无结相故。有结非左慧。谓七结即爱等七。此有结相无左慧相故。有左慧亦结。谓二结即见结取结具二相故。有非左慧亦非结。谓除前相。相谓所名如前广说。此复是何。谓行蕴中除染污慧。及余七结。诸余行蕴及四蕴全。并无为法作第四句

问何故名左。左是何义。答意乐左故堕左品故。说名为左。即是偏僻用非便义。复次彼于解脱正理善品。皆违越故说名为左。复次不吉祥故说名为左。如有于佛贤圣制多及天灵庙。不右绕者以不吉祥故名为左。复次用非巧便故名为左。如世见有诸用左人。咸谓此人非巧便者。复次所行不正故名为左。如说外道是左道人。所说所行皆不正故。问若染污慧名左慧者。何故说佛身有左光。答立左名因义各别故。谓染污慧违越解脱正理善品故立左名。佛有常光附身而起。以恒安住故立左名。不同余光起灭不定。以佛身有常光一寻。乃至微尘及细虫等。光威所铄皆不近身。复有说者。佛有三光映夺余光皆令成左。是故说佛身有左光。佛三光者。一佛身光作真金色。此光照触诸金山时令彼威光隐没不现。二佛齿光极鲜白色。此光照触雪山王时令彼威光隐没不现。三佛智光清净遍照。此光照触外道邪论皆令摧伏隐没不现。如是三光令余退没。皆成左性故名为左。有作是说。佛身金光照齿所发鲜白光时。显佛面门威严增盛。如秋丽日光照雪山。令彼山王威严转盛

问诸佛皆有如是左光。遍身一寻恒发照不。答诸佛皆有如是左光。遍身一寻恒时发照。问若尔然灯佛本事云何通如契经说。然灯如来应正等觉。身光赫奕照灯光城。周匝围绕踰缮那量。经十二年昼夜无别观华开合以知昼夜。既尔云何诸佛皆有常光一寻。答彼经不说。然灯如来遍身所发常光一寻。但说彼佛为化有情。现大神变发化光照。于十二年施作佛事。有作是说。非诸佛身皆有如是常光一寻。以佛身光非相好摄。或大或小起灭不定。评曰应作是说。诸佛皆有如是左光遍身一寻恒时发照。虽非相好摄而法尔恒有。诸佛身常有胜妙威光故

云何学见。乃至广说。问何故作此论。答前虽总说见智慧三。而未别说云何学见云何学智云何学慧。前论是此所依根本。彼未说者今应说之。故作斯论。云何学见。答学慧。谓无漏忍及学八智。从苦法智忍。乃至金刚喻定诸无漏慧皆名学见。云何学智。答学八智。谓四法智及四类智。云何学慧。谓学见学智总名学慧见智俱有择法相故。已说学见智慧自性。杂不杂相今当说。诸学见是学智耶。答诸学智亦学见。学智必有推度相故。有学见非学智。谓无漏忍此忍未有审决相故。诸学见是学慧耶。答如是。设学慧是学见耶。答如是。学位见与慧遍无漏心故。诸学智是学慧耶。答诸学智亦学慧。有学慧非学智。谓无漏忍义如前说。此三摄义准定应知。诸成就学见彼学智耶。答诸成就学智亦学见智即见故。有成就学见非学智。谓苦法智忍现在前时。尔时未有无漏智故。诸成就学见彼学慧耶。答如是。设成就学慧彼学见耶。答如是。学位见慧必俱成故。诸成就学智彼学慧耶。答诸成就学智亦学慧。有成就学慧非学智。谓苦法智忍现在前时。忍有慧相无智相故

云何无学见。乃至广说。问何故作此论。答前虽总说见智慧三。而未别说云何无学见云何无学智云何无学慧。前论是此所依根本。彼未说者今应说之。故作斯论。云何无学见。答尽无生智所不摄无学慧谓无学正见。云何无学智。答无学八智。谓四法智及四类智。云何无学慧。答无学见无学智总名无学慧见智。定有择法相故。已说此三自性杂不杂相今当说。诸无学见是无学智耶。答诸无学见亦无学智。无学位中能推度者必审决故。有无学智非无学见。谓尽无生智此智息求不推度故。诸无学见是无学慧耶。答诸无学见亦无学慧。有无学慧非无学见。谓尽无生智。此智唯有择法审决二种相故。诸无学智是无学慧耶。答如是。设无学慧是无学智耶。答如是。无学智慧俱遍无学无漏心故。此三摄义准定应知。诸阿罗汉无不成就此三种者。是故此三展转相问皆答如是。学无学三不说断者俱无断故

云何非学非无学见。乃至广说。问何故作此论。答前虽总说见智慧三。而未别说。云何非学非无学见。云何非学非无学智云何非学非无学慧。前论是此所依根本。彼未说者今应说之。故作斯论。云何非学非无学见。答眼根五见世俗正见。此三见相。广如前说。谓观视等。云何非学非无学智。答五识相应慧。及意识相应有漏慧俱通三种。谓善染污无覆无记。广如前说。云何非学非无学慧。答五识相应慧。及意识相应有漏慧。有漏智慧俱遍一切有漏心品。皆有审决择法相故。已说此三自性杂不杂相今当说。诸非学非无学见。是非学非无学智耶。答应作四句。此见与智互广狭故。此中初句谓眼根者。唯能观视非审决故。第二句谓五识相应慧等者。有审决相。无推度相故。第三句谓五见世俗正见者。皆有推度审决相故。第四句谓除前相者。相谓所名。如前广说。此复是何。谓色蕴中除眼根诸余色蕴。行蕴中除有漏慧诸余行蕴。及三蕴全。并无为法作第四句。非学非无学见慧相对作四句亦尔。非学非无学智慧相对自性等故。皆答如是。此三摄义准定应知。成就与断广说准前初纳息说应知其相。若成就一定有余二。随一已断已得遍知余二亦尔。故更相问。皆答如是

如大梵天作如是说。我是梵是大梵得自在。乃至广说。问何故作此论。答诸恶见趣于生死中令诸有情起大染着引大无义。与生死苦作大依处。谓有此者定于三界。往返轮回受诸苦恼。数数趣入秽闇母胎。住生藏下熟藏之上。为诸不净恒所逼切。出产门时受诸剧苦。生堕草等如利刀割。此等苦事无量无边。皆由不知见趣过患。欲令知已厌恶断灭故作斯论。如大梵天作如是说。我是梵是大梵得自在。我于世间能造化能出生是彼父。此于五见何见摄。见何谛断此见耶。此中以二事推求诸见趣。一以自性。二以对治。以自性者。谓此诸见趣以何为自性。以对治者。谓此诸见趣以何为对治。杂蕴见蕴生智论中。皆亦以二事推求诸见趣。谓以自性及以对治。如生智论作如是说。沙门乔答摩是幻化者诳惑世间。佛由此道已超幻诳。彼谤此道是邪见摄。是彼自性见道所断。是彼对治道智生时能断。如是不实推求不实分别颠倒恶见令永灭故。又彼论说。世尊何故悭阿罗汉。佛由此道已超悭吝。彼谤此道是邪见摄。是彼自性见道所断。是彼对治道智生时。能断如是不实推求。乃至广说。梵网经中。亦以二事推求见趣。一以自性。二以等起。梵问经中但以一事推求见趣。谓以等起。如是诸处合以三事推求见趣。一以自性。二以等起。三以对治。胁尊者曰。不应推求诸恶见趣。所以者何。谁有智者劳烦诘问无明者暗盲者堕坑。评曰。应以三事推求见趣。所以者何。若以三事推求见趣。虽是异生具烦恼缚。而同圣者诸恶见趣永不现行。此中应说实法师因缘。如杂蕴中已广说其事

答我是梵是大梵得自在者。取劣法为胜见取摄见苦所断。此中梵王实非真梵。非真大梵。非于一切皆得自在。而谓自身实是真梵是真大梵。普于一切皆得自在。彼于下劣法而计为最胜。故见取摄是彼自性。所以者何。法中最胜唯有涅槃。有情中胜唯有圣者佛。心得自在于法亦自在。声闻独觉虽于诸法未得自在。而于自心已得自在。梵王于此二种自在俱未能得。而彼自谓已得自在。于劣计胜故见取摄。苦智生时能断如是不实推求不实分别。颠倒恶见令永灭故。名见苦断是彼对治。由此见取于苦处生。故见苦时此见永灭。如日才出轻霜即除。如草端露风摇便堕。我于世间能造化能出生。是彼父者非因计因。戒禁取摄见苦所断。此中意说。诸有情类各自业感内身外物。而彼梵王。谓自能化出生。为父非因计因。戒禁取摄是彼自性。见苦所断是彼对治如前应知。如梵众天作如是说。此是梵是大梵得自在。此于世间能造化能出生。是我等父。此于五见何见摄。见何谛断此见耶。答此是梵是大梵得自在者取劣法为胜见取摄见苦所断。此中梵众。执大梵王是梵是大梵普得自在。于劣计胜见取所摄。是彼自性见苦所断是彼对治。广说如前。此于世间能造化能出生。是我等父者。非因计因戒禁取摄见苦所断。此中梵众。执大梵王普于世间是造化者。是出生者与彼为父。非因计因戒禁取摄是彼自性。见苦所断是彼对治。广说如前

问此中是梵是大梵得自在有何差别。答是梵者。谓执梵王五取蕴果。是真清净寂静安乐。是大梵者。谓执梵王五取蕴果。于诸真净寂乐中尊。得自在者。谓执梵王五取蕴果。有最胜用统摄一切皆得自在。如是皆名取劣为胜。谓执秽苦为真净乐。及有净乐最胜用故。真乐净者谓灭道谛。灭道二谛俱是真胜。一切法中涅槃最胜。是善是常超余法故。有为法中圣道最胜。能永超越生死法故。一切随眠不随增故。如有颂言

  灭于诸法胜　　道于有为胜
  一切有情中　　如来为最胜

问于梵世中梵王最胜。观彼为胜应是正见。如何说彼是恶见耶。答若谓唯于梵世中胜容非恶见。然彼谓于一切最胜故恶见摄。彼于诸佛独觉声闻及上诸天皆为劣故。又彼妄执五取蕴果同真灭道故恶见摄。问此中于世间能造化能出生是彼父等。有何差别。答于世间者。谓于有情世间及器世间。能造化者。谓能造作器世间。及能化作有情世间能出生者。谓能出生非情数物重显造义。是彼父等者。谓是一切有情之父重显化义。此执皆是非因计因。谓执梵王五取蕴果。能造化作一切世间。然诸世间有情数者。各从自业烦恼而生。非情数者。一切有情业增上力共所引起。彼于劣果执为胜因。既非因计因故戒禁取摄。此及前见取俱迷果处。苦谛生故皆见苦所断。又我常执力所引故。如彼皆成见苦所断

已说如是恶见自性。及彼对治等起。云何梵网经中说彼等起。如彼经说前劫坏时。诸有情类多从此殁生极光净众同分中。此劫成时空中先有梵天宫起。时极光净有一有情。寿业福尽从彼天殁来生梵宫。独一长时俨然而住。后便起爱思念同侣。云何当令诸余有情生我同分为我等侣。问彼由何缘起斯爱念。胁尊者曰。不应诘问无明者愚盲者颠蹶。有作是说。往彼处者。尔时法尔起此爱念。谓法尔力是彼生缘。复有说者。无始时来诸有情类乐相习近。由串习力引彼爱生故彼爱念由因力起。或有说者。彼未除灭摄众爱故。谓先于此为众导师后生彼天犹有余习由此势力引起彼爱。有余师说。极光净天来至梵世。作初静虑种种化身。与大梵王共相娱乐。彼后息化还自天宫。于是梵王追慕同侣。起斯爱念有作是言。梵王自起初静虑化作梵众身而自娱乐。后既疲惓便息神通化众没已。作如是念。谁能常起诸化众身。云何当令余有情类生我同分为我徒侣。有余复言。梵王先起自地天眼傍见余界。大梵天王梵辅梵众恭敬围绕见已念言彼之形色容貌威光非胜于我。彼有徒众而我独无。云何当令余有情类来生我所为我徒众。彼经复说。梵王当起此思念时。极光净天余有情类。诸有寿尽业尽福尽。皆从彼殁来生梵世。梵王见已作是念言。此诸有情是我化作。问梵王何故起此念耶。答由彼梵王先起思愿。彼有情类应念而生。故彼梵王起如是念。有作是说。梵王化作诸梵众已。入中间定既入定已。化众便没时极光净有情命终来生梵世。后大梵王从定起已既见梵众作是念言。前所化众应已隐没。今诸有情现在前者。或应是我化力引生。或可是先思愿所作。由斯大梵作是念言。此诸有情是我化作。彼经复说。梵众生已作是念言。我等曾见如是有情长寿久住。问彼住何处曾见梵王答即住梵世曾见梵王。然不忆知何处曾见。如于集会曾见一人。后经久时复遇相见。虽醒曾相见而不忆处所。有作是说。彼住中有曾见梵王。若尔云何曾见大梵长寿久住。以中有身速求生处不久住故。复有说者。彼从极光净来至梵宫为娱乐。梵王尔时曾见。问彼既已失第二静虑。云何能忆上宿住事。答彼诸梵众离自地染。复依第二静虑起宿住随念智通。能忆上地曾所见事。问若尔何故缘大梵王起斯恶见。答从离染退故缘梵王复起恶见。问岂不色界无退义耶。答劫初成时彼亦有退。有余师说。彼以本性念生智忆上曾见事。问岂不色界无有本性念生智耶。答劫初成时色界亦得有本性念生智。或有说者。梵王先入中间静虑住经多时。彼诸梵众从上地殁。生梵世中见大梵王长寿久住威光赫奕。不敢亲附后出定已。命诸梵众共相慰问。时诸梵众互相谓言。我等曾见如是有情长寿久住。彼经复说。时诸梵众作是念言。我等皆是梵王化作。从彼而生是我等父。问何缘彼起如是念耶。答彼闻梵王数作是说。我能造化我能出生。是汝等父闻已深信。复曾见梵王长寿久住。既深生信重故起是念。如有国王实无技用。然对臣众而自矜夸。我于昔时有大威勇。亲率士众摧伏勍敌。臣众既闻无不信受。咸言我等幸遇大王。亲友国人皆获安乐。复有说者。彼闻梵王数如前说。为审决故便起宿住随念智通。观察自他先蕴相续渐次乃至初结生心。而不能观前命终位。下通不能观上境故。彼由通力知大梵王先生久住。后起思念我等便生由此定知。我等皆是梵王化作。从彼而生是我等父。故由通力彼起是念

问劫初成时几有情类。问时发起如前所说颠倒想见。有作是说。小千界中有一大梵十独梵千梵众。中千界中有千大梵十千独梵千千梵众。大千界中有千千大梵俱胝独梵百俱胝梵众。复有说者。小千界中有一大梵千独梵十千梵众。中千界中有千大梵十千独梵俱胝梵众。大千界中有十千大梵俱胝独梵百俱胝梵众。有依杂说。大千界中有俱胝大梵百俱胝独梵百千俱胝梵众。评曰。应作是说。大千界中有俱胝大梵百俱胝独梵十俱胝那庾多梵众。劫初成时同时发起如前所说。颠倒想见

问大梵天王住在何处。梵辅梵众住何处耶。西方诸师。作如是说。初静虑地处别有三。一梵众天处。二梵辅天处。三大梵天处。此处即是静虑中间。迦湿弥罗诸论师说。初静虑地唯有二处。即梵辅天中有高胜静处。如近聚落有胜园林是大梵王常所居处。此处即是静虑中间。问大梵天等身量云何。答大梵王身量一踰缮那半。梵辅天身量一踰缮那。梵众天身量半踰缮那。问大梵天等寿量云何。答大梵王寿量一劫半。梵辅天寿量一劫。梵众天寿量半劫。应知此处四十中劫合为一劫。问大梵天王经几时量独一而住。经几时量与众共住。经几时量复与众别。有作是说。经五中劫独一而住。经五中劫与众共住。经五中劫复与众别。复有说者。经十中劫独一而住。经十中劫与众共住。经十中劫复与众别。评曰。应作是说。经于半劫独一而住。经于半劫与众共住。经于半劫复与众别。二十中劫是半劫量。梵辅梵众依未至地心命终结生。大梵依静虑中间心命终结生所以者何。命终结生心唯舍受相应。舍受唯在初静虑近分地有。非根本地故。诸起此见我一切忍此于五见何见摄。乃至广说。问何故作此论。答为欲分别契经义故。谓契经说。长爪梵志。来诣佛所而白佛言。乔答摩。当知我一切不忍。乃至广说。契经虽作是说。而不说此于五见何见摄。见何谛断此见。经是此论所依根本。彼未说者今应说之。故作斯论。问何故名为长爪梵志。答由彼梵志身爪俱长。而且说为长爪梵志。问彼复何缘留此长爪。答彼贪习业无容剪故。有作是说。彼恒山居爪发虽长无人剪剃。复有说者。彼在家时乐习弦管。后虽出家犹爱长爪故不剪之。有余师说。彼在外道法中出家。外道法中有留爪者。故说彼为长爪梵志。此中以二事推求见趣。一以自性。二以对治。如文应知。问此恶见趣等起云何。答尊者舍利子。及大目干连。投佛出家是此等起。谓长爪梵志。是舍利子舅。曾教尊者外道书论。闻舍利子与大目连归佛出家。深心忧悔作如是念。智境无穷设解深远终有回义。彼乔答摩多闻智慧虽定应胜舍利子等。而必应有胜。乔答摩定复有余能胜彼者。如是展转智境无穷。故我不应不设方便。作是念已来诣佛所而白佛言。乔答摩。当知我一切不忍。世尊告曰。汝为忍此所起见不。时彼梵志作是思惟。若答言。忍便违所立。若言不忍便无所宗。若无所宗则非论道。思已愧耻默然而住。复次长爪梵志是断见者。彼观一切后当必断。故佛告言。汝所起见亦当断不。复次长爪梵志是犹豫者。彼观一切皆可犹豫。故佛告言。汝于自见亦犹豫不。然彼梵志有占相智。自知所立必当堕负故。彼梵志默然而住。世尊告曰。无量有情同汝所见汝亦同彼。谓诸世间依三种见。一有一类。起如是见。立如是论。我一切忍。二有一类。起如是见。立如是论。我一切不忍。三有一类。起如是见。立如是论。我一分忍一分不忍。此中若言一切我皆忍者。彼依此见生爱贪着。若言一切我皆不忍者。彼依此见不生爱贪着。若言我一分忍一分不忍者。彼依此见一分生爱贪着。一分不生爱贪着。问一切见趣无不皆能生爱贪着。世尊何故说依彼见有不生者。答应知彼经有别意趣。谓常见者执有后世。于能引发后有业思生爱贪着。若断见者执无后世。于能引发后有业思不爱贪着。是彼契经所说意趣。然诸见趣无不皆能生爱贪着。谓断见者信有现在入胎为初命终为后。拨无他世。于此见中生爱贪着。与常见者保执无异

说一切有部发智大毗婆沙论卷第九十八阿毗达磨大毗婆沙论卷第九十九

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    智蕴第三中五种纳息第二之三

如契经说。佛告梵志。若有沙门婆罗门等。舍恶见趣而不取者。当知此类少中复少。问此类云何少中复少。答世间有情性愚钝者如大地土。性聪慧者如爪上土。性聪慧中。邪见者多正见者少。喻如前说。是故名为少中复少。问如见蕴说断常见者展转相违。云何此中说有一类起如是见。我一分忍一分不忍而不相违。答此中说。一补特伽罗。若执色蕴为常。彼执四蕴为断。若执四蕴为常。彼执色蕴为断。故此二见非互相违。见蕴说二补特伽罗。一执色常。一执色断乃至执识亦有二种。故彼二见展转相违。彼经复说。世尊说此见趣法时。长爪梵志远尘离垢。于诸法中生净法眼。时舍利子受具足戒已经半月。随观此法得阿罗汉。问时舍利子随观何法。尊者世友作如是说。尊者舍利子。即随观世尊为彼梵志说见趣法。成阿罗汉。复有说者。尊者舍利子。即随观梵志得预流果道所观法。成阿罗汉。有作是说。尊者舍利子。即随观梵志得预流果能证学法。成阿罗汉。大德说曰。彼舍利子。随观缘起有十二支差别性法。成阿罗汉。是名舍利子所随观法

诸起此见。有阿罗汉。天魔所娆漏失不净。乃至广说。问何故作此论。答为欲分别佛涅槃后。假名苾刍所起恶见。令有智者知而制之。故作斯论。诸起此见。有阿罗汉。天魔所娆漏失不净。此于五见何见摄。见何谛断此见耶。答非因计因戒禁取摄。见苦所断。此中非因计因者。谓彼不净从烦恼生。而说天魔所娆故出。故戒禁取以为自性。见苦所断显彼对治。苦智生时能断如是不实推求不实分别。颠倒恶见令永灭故名见苦断。广说如前。诸起此见。有阿罗汉。于自解脱犹有无知。此于五见何见摄。见何谛断此见耶。答谤阿罗汉无漏智见。邪见摄。见道所断。此中谤阿罗汉无漏智见者。谓阿罗汉于自解脱。由无漏智见已离无知。而说犹有无知。则拨无彼无漏智见。是故邪见以为自性。见道所断显彼对治。道智生时能断如是不实推求。乃至广说如前应知。诸起此见。有阿罗汉。于自解脱犹有疑惑。此于五见何见摄。见何谛断此见耶。答谤阿罗汉越渡疑惑。邪见摄。见道所断。此中谤阿罗汉越渡疑惑者。谓阿罗汉于自解脱。由无漏道已断疑惑。而说犹有疑惑。则拨无彼道。是故邪见以为自性。见道所断显彼对治。道智生时能断如是不实推求。乃至广说如前应知。诸起此见。有阿罗汉。但由他度。此于五见何见摄。见何谛。断此见耶。答谤阿罗汉无障无背。现量慧眼身证自在。邪见摄见道所断。此中谤阿罗汉无障无背现量慧眼身证自在者。谓阿罗汉实自证得无障无背现量慧眼身证自在。非但由他而得度脱。然说但由他故得度。则谤圣道。是故邪见以为自性。见道所断显彼对治。道智生时能断如是不实推求。乃至广说如前应知。诸起此见。道及道支苦言所召。此于五见何见摄。见何谛断此见耶。答非因计因戒禁取摄见苦所断此中非因计因者。谓诸圣道要修方得。而说苦言能召令起。故戒禁取以为自性。见苦所断显彼对治。苦智生时能断如是不实推求。乃至广说如前应知。此于苦果计为道因。故见苦时永断此见

已说五种恶见自性及彼对治。等起云何。谓大天因缘是此等起。昔末土罗国有一商主。少娉妻室生一男儿。颜容端正与字大天。未久之间商主持宝远适他国。展转贸易经久不还。其子长大染秽于母。后闻父还心既怖惧。与母设计遂杀其父。彼既造一无间业已。事渐彰露。便将其母展转逃隐波吒梨城。彼后遇逢本国所供养阿罗汉苾刍。复恐事彰。遂设方计杀彼苾刍。既造第二无间业已。心转忧戚。后复见母与余交通。便愤恚言。我为此故造二重罪。移流他国跉跰不安。今复舍我更好他人。如是倡秽谁堪容忍。于是方便复杀其母。彼造第三无间业已。由彼不断善根力故。深生忧悔寝处不安。自惟重罪何缘当灭。彼后传闻沙门释子有灭罪法。遂往鸡园僧伽蓝所。于其门外见一苾刍徐步经行。诵伽他曰

  若人造重罪　　修善以灭除
  彼能照世间　　如月出云翳

时彼闻已欢喜勇跃。知归佛教定能灭罪。因即往诣一苾刍所。殷勤固请求度出家。时彼苾刍既见固请。不审捡问遂度出家。还字大天教授教诫。大天聪慧。出家未久。便能诵持三藏文义。言词清巧善能化导。波吒梨城无不归仰。王闻召请数入内宫。恭敬供养而请说法。彼后既出在僧伽蓝。不正思惟梦失不净。然彼先称是阿罗汉。而令弟子浣所污衣。弟子白言。阿罗汉者诸漏已尽。师今何容犹有斯事。大天告言。天魔所娆汝不应怪。然所漏失略有二种。一者烦恼。二者不净。烦恼漏失阿罗汉无。犹未能免不净漏失。所以者何。诸阿罗汉烦恼虽尽。岂无便利涕唾等事。然诸天魔常于佛法而生憎嫉。见修善者便往坏之。纵阿罗汉亦为其娆故我漏失。是彼所为。汝今不应有所疑怪。是名第一恶见等起。又彼大天欲令弟子欢喜亲附。矫设方便次第记别四沙门果。时彼弟子稽首白言。阿罗汉等应有证智。如何我等都不自知。彼遂告言。诸阿罗汉亦有无知。汝今不应于己不信。谓诸无知略有二种。一者染污。阿罗汉已无。二者不染污。阿罗汉犹有。由此汝辈不能自知。是名第二恶见等起。时诸弟子复白彼言。曾闻圣者已度疑惑。如何我等于谛实中犹怀疑惑。彼复告言。诸阿罗汉亦有疑惑。疑有二种。一者随眠性疑。阿罗汉已断。二者处非处疑。阿罗汉未断。独觉于此而犹成就。况汝声闻于诸谛实能无疑惑而自轻耶。是名第三恶见等起。后彼弟子披读诸经。说阿罗汉有圣慧眼。于自解脱能自证知。因白师言。我等若是阿罗汉者应自证知。如何但由师之令入都无现智能自证知。彼即答言。有阿罗汉但由他入不能自知。如舍利子智慧第一。大目干连神通第一。佛若未记彼不自知。况由他入而能自了。故汝于此不应穷诘。是名第四恶见等起。然彼大天虽造众恶。而不断灭诸善根故。后于中夜自惟罪重。当于何处受诸剧苦。忧惶所逼数唱苦哉。近住弟子闻之惊怪。晨朝参问。起居安不。大天答言。吾甚安乐。弟子寻白。若尔昨夜何唱苦哉。彼遂告言。我呼圣道汝不应怪。谓诸圣道若不至诚。称苦召命终不现起。故我昨夜数唱苦哉。是名第五恶见等起。大天于后集先所说。五恶见事。而作颂言

  余所诱无知　　犹豫他令入
  道因声故起　　是名真佛教

于后渐次鸡园寺中。上座苾刍多皆灭殁。十五日夜布洒他时。次当大天升座说戒。彼便自诵所造伽他。尔时众中。有学无学多闻持戒修静虑者。闻彼所说无不惊诃。咄哉愚人宁作是说。此于三藏曾所未闻。咸即对之翻彼颂曰

  余所诱无知　　犹豫他令入
  道因声故起　　汝言非佛教

于是竟夜斗诤纷然。乃至终朝朋党转盛。城中士庶乃至大臣。相次来和皆不能息。王闻自出诣僧伽蓝。于是两朋各执己诵。时王闻已亦自生疑。寻白大天。孰非谁是我等今者当寄何朋。大天白王。戒经中说若欲灭诤依多人语。王遂令僧两朋别住。贤圣朋内耆年虽多而僧数少。大天朋内耆年虽少而众数多。王遂从多依大天众。诃伏余众。事毕还宫。尔时鸡园诤犹未息后随异见遂分二部。一上座部。二大众部。时诸贤圣知众乖违。便舍鸡园欲往他处。诸臣闻已遂速白王。王闻既嗔便敕臣曰。宜皆引至殑伽河边。载以破船中流坠溺。即验斯辈是圣是凡。臣奉王言便将验试。时诸贤圣各起神通。犹如雁王陵虚而往。复以神力摄取船中同舍鸡园未得通者。现诸神变作种种形相。次乘空西北而去。王闻见已深生愧悔。闷绝躃地水洒乃苏。速即遣人寻其所趣。使还知在迦湿弥罗。复固请还僧皆辞命。王遂总舍迦湿弥罗国。造僧伽蓝安置贤圣众。随先所变作种种形。即以摽题僧伽蓝号。谓鸡园等数有五百。复遣使人多赍珍宝营办什物而供养之。由是尔来此国多有诸贤圣众任持佛法。相传制造于今犹盛。波吒梨王既失彼众。相率供养住鸡园僧。于后大天因游城邑有占相者。遇尔见之窃记彼言。今此释子却后七日定当命终。弟子闻之忧惶启告。彼便报曰。吾已久知。还至鸡园遣诸弟子。分散遍告波吒梨城。王及诸臣长者居士。却后七日吾当涅槃。王等闻之无不伤叹。至第七日彼遂命终。王及诸臣城中士庶悲哀恋慕。各办香薪。并诸酥油花香等物。积置一处而焚葬之。持火来烧随至随灭。种种方计竟不能然。有占相师。谓众人曰。彼不消此殊胜葬具。宜以狗粪而洒秽之。便用其言火遂炎发。须臾焚荡俄成灰烬。暴风卒至飘散无遗。故彼是前恶见等起。诸有智者应知避之

    智蕴第三中他心智纳息第三之一

云何他心智。云何宿住随念智。如是等章及解章义。既领会已。次应广释。问何故尊者依前二智而作论耶。答是彼尊者意欲尔故。谓本论师随欲造论不违法相。故不应责。如此尊者于根蕴中。依法类二智而作论。于定蕴中依尽无生二智而作论。复于根蕴中依苦集灭道四智而作论。于结蕴定蕴及此蕴后依八智而作论。于修智等处依十智而作论。如是尊者于此蕴初依他心宿住二智而作论。如善巧陶师先熟调泥团置轮上。随自意乐造器等物。尊者亦尔。闻思修慧观察法相。断自性愚及所缘愚。随欲造论。故不应责。复次以前二智俱通加行及离染得。俱是修所成。俱是通自性。俱是四支五支静虑果。故偏依之而作此论。复次以前二智俱以智见为自性。俱于所缘分齐而取。谓他心智唯缘现在。宿住随念智但缘过去。故偏依之而作此论。有作是说。以此二智俱通有漏无漏二品。故偏依之而作此论。评曰。彼不应作是说。宿住随念智唯是有漏故

云何他心智。答若智修所成。是修果。依止修。已得不失。能知他相续现在欲色界心心所法。或无漏心心所法。是谓他心智。此中若智修所成者。谓修所成慧为自性故。是修果者。谓是四支五支静虑果故。依止修者。谓依数习而成就故。已得不失者。已证得不舍故。问何故不说未得已失。答应说而不说者。当知此义有余。复次若由此智说名成就他心通者。此中说之。未得已失诸他心智无如是义。是故不说。能知他相续现在欲色界心心所法或无漏心心所法者。谓能如实知他有情身中现在世欲色界。或无漏心心所法。此说他心智所缘境相。有别诵言。若智现起如实知他有情有所寻求。有所伺察。有所摄受。众缘所起意及意所有。是谓他心智。此中若智现起者。说现行他心智。如实知者。简别占相智等。他有情者。简别知自心心所法。有所寻求者。谓欲界初静虑心心所法。有所伺察者。谓静虑中间心心所法。有所摄受者。谓后三静虑心心所法。复有说者。有所寻求显欲界初静虑。有所伺察。显从欲界乃至静虑中间。有所摄受。显从欲界乃至第四静虑。此中显示能寻求等。故色等法非此智境。众缘所起者。如能知智由四缘生。所知亦由四缘生故。意及意所有者。意即是心。诸心所法名意所有。如是皆说他心智境。此他心智或应说一。谓他心智通及示导。或应说二。谓有漏无漏。有缚解脱。有系不系。或应说三。谓下中上品。或应说四。谓四静虑果。或应说六。谓有漏无漏各有三品。或应说八。谓四静虑果各有有漏无漏。或应说九。谓下下品乃至上上品。或应说十二。谓四静虑果各有三品。或应说十八。谓有漏无漏各有九品。或应说二十四。谓四静虑果各有有漏无漏。此复各有三品。或应说三十六。谓四静虑果各有九品。或应说七十二。谓四静虑果各有有漏无漏。此复各有九品。若以在身刹那分别应说无量无边。此中总说一他心智。问此他心智以何为自性。答以慧为自性。是谓他心智自性我物自体相分本性。已说自性。所以今当说

问何故名他心智。他心智是何义耶。答知他心故名他心智。问此亦知他诸心所法。何故但名他心智耶。答诸瑜伽师意乐加行。欲知他心非他心所。是故但立他心智名。以心为先亦知心所。譬如有人意乐加行但欲见王。若见王时亦见臣等。复次诸法立名依多缘故。谓或依自性。或依对治。或依加行。或依相应。或依所依。或依所缘。或依行相。或依所缘及行相等。依自性立名者。谓五蕴四谛世俗智等。依对治立名者。谓法智类智对治欲界上二界故。依加行立名者。谓空识无边处无所有处。五现见定他心智等。依相应立名者如品类足说。云何顺乐受等法。谓乐受等相应。如是一切依所依立名者。谓眼识等。依所缘立名者。谓四念住无相定等。依行相立名者。谓苦集智。此二行相无杂所缘杂故。依所缘及行相立名者。谓灭道智。此二所缘行相俱无杂故。诸如是等立名因缘乃有无量。今他心智但依加行立名非余。复次相应品中心最胜故。依知胜法立此智名。如说王来非无臣等。复次以依心故名心所法。心是大地。故诸心所法名大地。所有故但说心。复次修他心通无间道位。唯缘心故但说知心

此他心智界者。有漏他心智是色界。无漏他心智是不系。问何故无色界无他心智耶。答非田器故。乃至广说。复次修他心智依色起故。地者唯在四根本静虑非近分。无色彼地不能发五通故。问静虑中间心心所法何地智能知耶。有作是说。初静虑上品智能知。复有说者。第二静虑下品智能知。评曰。应作是说初静虑三品智皆能知。所以者何。一地摄故。所依者唯依欲色界身起。行相者。无漏他心智。作缘道谛四行相转。有漏他心智。作不明了行相转。所缘者。初静虑他心智缘欲界初静虑地心心所法。第二静虑他心智缘欲界初二静虑地心心所法。第三静虑他心智缘欲界前三静虑地心心所法。第四静虑他心智缘欲界四静虑地心心所法。无他心智能知无色心心所法。彼地胜故。如初静虑等他心智。不知第二静虑等心心所法。问生欲色界起无色地心心所法。是他心智所缘境不。答非所缘境。如不知果因亦尔故。念住者。是三念住除身念住。智者是四智。谓法类道世俗智。即总说彼为他心智。三摩地俱者。无漏他心智道无愿俱。有漏他心智非三摩地俱。根相应者。总说此与三根相应。谓乐喜舍。三世者。是三世缘。三世者。过去缘过去。现在缘现在。未来若生法缘未来。若不生法缘三世。善不善无记者。唯是善。缘善不善无记者缘三种。系不系者。有漏他心智唯色界系。无漏他心智唯不系。缘系不系者。缘欲色界系及不系。学无学非学非无学者。通三种。缘学无学非学非无学者。缘三种。见修所断不断者。有漏他心智唯修所断。无漏他心智是不断。缘见修所断及不断者。缘三种。缘名缘义者。唯缘义。缘自他相续非相续者。唯缘他相续。加行离染得者。通加行离染得。离染得者。谓初静虑者离欲界染时得。乃至第四静虑者离第三静虑染时得。或离自地上地染时亦容修得。加行得者。谓修胜进加行时得。及起加行令现在前。谓诸声闻以中上品加行。独觉唯以下品加行。佛不以加行能现在前。曾得未曾得者。一切圣者及内法异生。皆通曾得未曾得。外法异生唯是曾得

问修他心智加行云何。答施设论说。初修业者于世俗定。已得自在数起现前。令转明利先审观察自身心相。若时身。有如是相现。尔时便起如是相心。若时自起如是相心。尔时身有如是相现。自审观察身心相已。次审观察他身心相。若时身有如是相现。尔时便起如是相心。若时他起如是相心。尔时身有如是相现。审观察他身心相已。次纯观彼心心所法。作是思惟。我应观彼心心所法。何所寻求。何所伺察。何所摄受。既思惟已纯观彼心相续前后行相差别。观彼心相若得纯熟。齐是名为修他心智加行成满。集异门论作如是说。修他心智加行云何。谓审观察缘五取蕴。为苦非常空非我智行相差别。渐次能引无漏智生。善知他心名他心智。问无漏他心智能缘四谛智。何故但说缘苦智耶。答亦应说缘余三谛智。而不说者当知有余。复次此中但说初入加行。但缘苦智不说缘余。后相续时亦缘余智。问前施设论后集异门所说加行有何差别。答前说有漏他心智加行。后说无漏他心智加行。复次前说他心智加行。非胜妙明净。后说他心智加行。胜妙明净。然他心智虽加行时亦缘色起。而成满时不复缘色。所以者何。先观粗法为入细故。又他心智虽加行时亦缘自相续。而成满时唯缘他相续。所以者何。缘自不名他心智故。又他心智但缘他心。不缘他心所缘行相。若缘他心所缘行相。应缘自心非他心智。自心是彼所缘及能缘行相故。问若眼不见色为能知他心不。答能知。耳闻声故。问若不见色闻声为能知他心不。答能知。鼻臭香故。问若不见色闻声臭香。为能知他心不。答能知。舌尝味故。问若不见色闻声臭香尝味。为能知他心不。答能知。身觉触故。问若不见色闻声臭香尝味觉触。为能知他心不。有作是说。彼不能知。所以者何。他心智起因缘色故。评曰。应作是说。初引发时则不能知。已成满者虽不缘色而亦能知。曾得有漏心心所法有十五种。是他心智所应取境。谓欲界及四静虑。各有下中上三品心心所法。曾得有漏他心智有十二种。谓四静虑各有下中上三品他心智。此中初静虑曾得有漏他心智下品者。能知欲界三品及初静虑下品。曾得有漏心心所法中品者。能知欲界三品及初静虑下中二品曾得有漏心心所法。上品者。能知欲界及初静虑各三品曾得有漏心心所法。如是展转乃至第四静虑曾得有漏上品他心智。能知欲界及四静虑各三品曾得有漏心心所法。如曾得有漏十二种他心智知十五种曾得有漏心心所法。未曾得有漏十二种他心智知十五种未曾得有漏心心所法亦尔。无漏心心所法有十二种。是他心智所应取境。无漏他心智亦有十二种。谓四静虑各有三品。此中第二静虑无漏他心智下品者。能知初静虑及第二静虑。各唯下品无漏心心所法。中品者。能知初静虑及第二静虑各下中二品无漏心心所法。上品者。能知初静虑及第二静虑各三品无漏心心所法。如是展转乃至第四静虑上品无漏他心智。能知四静虑各三品无漏心心所法。问何故上地下中品有漏他心智俱能知下地三品有漏心心所法。上地下中品无漏他心智。不知下地中上品无漏心心所法耶。答有漏无漏心心所法建立各异。谓有漏心心所法依相续建立。有一身相续中成就三品有漏心心所法。无漏心心所法依根品建立。无一身相续中成就二品无漏心心所法。况有成就三者。建立既别故知有异

有十四种通果心心所法。皆是他心智所应取境。谓欲界初静虑各有四静虑果。第二静虑有后三静虑果。第三静虑有后二静虑果。第四静虑唯有第四静虑果。问初静虑他心智。于欲界四静虑通果心心所法。能知几种。有作是说。能知四种。所以者何。一切皆是欲界摄故。复有说者。唯能知初静虑果不知余三。所以者何。如不知因果亦尔故

诸他心智。于地度。根度。补特伽罗度。心心所法皆不能知。于地度心心所法不能知者。谓初静虑他心智。不能知第二静虑以上心心所法。乃至第三静虑他心智。不能知第四静虑以上心心所法。于根度心心所法不能知者。谓钝根者他心智。不能知利根者心心所法。于补特伽罗度心心所法不能知者。谓有学他心智。不能知无学心心所法。问一切无学他心智。皆能知一切有学心心所法耶。答不也。谓时解脱他心智。不能知见至心心所法。见至他心智。亦不能知时解脱心心所法。所以者何。时解脱他心智。于见至心心所法根度故不知见至他心智。于时解脱心心所法补特伽罗度故不知。问有学上地他心智。无学下地他心智。此二为得互相知耶。答不也。所以者何。有学上地他心智。于无学下地他心智。补特伽罗度故不知。无学下地他心智。于有学上地他心智地度故不知。问声闻上地他心智。如来下地他心智。此二为得互相知耶。答不也。所以者何。声闻上地他心智。于如来下地他心智根度故不知。如来下地他心智。于声闻上地他心智地度故不知。独觉望余乘准前义应说

如来无漏心心所法。及未曾得有漏心心所法。俱非他心智现所取境。曾得有漏心心所法。佛欲令他知者即知。谓佛若欲令钝根者知我心。非利根者则蛇奴等亦知佛心。舍利子等皆不能知。若欲令傍生趣等知我心。非人天趣则傍生趣等亦知佛心。人及天趣皆不能知。云何知然。契经说故。谓契经说。一时佛住广严城猕猴池侧重阁精舍。时诸苾刍以世尊钵及彼自钵皆置露处。有一猕猴下娑罗树来趣钵所。时苾刍众恐彼损钵竞驱逐之。佛言汝等不应驱逐。彼有别意须臾当知。时彼猕猴取世尊钵。徐还上树成满流蜜。安庠而下持奉世尊。以有虫故世尊不受。佛起曾得有漏心品令彼去虫。猕猴即知退住一处。择去虫已来奉世尊。未作净故佛复不受。佛起曾得有漏心品。令彼以水遍洒作净。猕猴即知退住一处。以水作净还奉世尊。于是世尊哀愍为受。猕猴欢喜踊跃无量。舞[跳-兆+(焰-火)]却行堕坑而死。乘斯福业得生人中。长大出家勤修梵行。不久便获阿罗汉果。世共号为献蜜上座。尊者论力由彼因缘。以妙伽他而赞佛曰

  无上天人调御士　　能令恶趣亦知心
  若住甚深微妙定　　乃至人天不能了

佛他心智能知三道。独觉他心智能知二道。声闻他心智能知一道。问佛得缘佛他心智不。有说不得。所以者何。无二如来俱出世故。复有说得。此说能缘不说现起。问独觉得缘独觉他心智不。答麟角喻者唯佛应知。众出独觉决定得缘独觉他心智。此说能缘亦说现起。声闻亦定得缘声闻他心智。此亦说能缘亦说现起。异生定得缘异生他心智。如众出独觉及诸声闻说。有作是说。麟角喻独觉亦定得缘麟角喻独觉他心智。亦说能缘亦说现起。余世界中有麟角喻独觉出世无理遮故。唯佛无漏心心所法。及未曾得有漏心心所法。定无他心智能缘现起者。无色界一切心心所法。定非他心智所缘。非其境故

说一切有部发智大毗婆沙论卷第九十九阿毗达磨大毗婆沙论卷第一百

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    智蕴第三中他心智纳息第三之二

诸有情类。有流转者有还灭者。流转者谓更受生。还灭者谓趣涅槃。若诸有情生欲色界。及诸异生生无色界。修他心智者。于彼心心所法。由二事故得他心智。一者能缘。二者现起。若诸有情已般涅槃。及诸圣者生无色界。修他心智者。于彼心心所法由一事故得他心智。谓但能缘不能现起。问若诸圣者生无色界。能修下地他心智不。有说不修。以彼毕竟无起义故。评曰。应作是说。虽必不起而彼得修。生上能修下无漏故。如法智品不违理故。异生生彼无修此义

或有心心所法是佛他心智境非独觉声闻。或有心心所法是佛独觉他心智境非诸声闻。或有心心所法是佛独觉声闻他心智境。如契经说。苾刍当知。大雪山中有如是处猕猴与人俱不能行。有如是处。猕猴能行人不能行。有如是处猕猴与人二俱能行。此契经中大雪山者。显所知法。如是处者。显在见道十五刹那。猕猴显独觉。人显声闻。能行不能行显诸他心智。然他心智能知同类心心所法非不同类。谓有漏者知有漏。无漏者知无漏。曾得者知曾得。未曾得者知未曾得。法智品者知法智品。类智品者知类智品。声闻他心智于见道唯能知二刹那心。独觉他心智于见道唯能知三刹那心。佛他心智于见道次第能知十五刹那心。所以者何。佛他心智。不由加行而现在前。独觉他心智。由下加行而得现前。声闻他心智。由中加行或上加行方现前故。谓修观者将入见道。声闻欲知彼见道心。先修法智品他心智加行。彼修观者既入见道。此他心智加行已满。便能知彼二刹那心。谓苦法智忍。及苦法智俱心。彼修观者入类智品。声闻复修类智品他心智加行。经十三刹那加行方满。乃能知彼第十六心。谓本欲知第三心。今乃知彼第十六心。是故声闻他心智唯知见道初二心。若修观者将入见道。独觉欲知彼见道心。先修法智品他心智加行。彼修观者既入见道。此他心智加行已满。便能知彼二刹那心。谓苦法智忍及苦法智俱心。彼修观者入类智品。独觉复修类智品他心智加行。经五刹那加行方满。乃知彼第八心。谓本欲知彼第三心。今乃知彼集类智俱心。有说。知彼第十五心。经十二刹那加行满故。有说。独觉能知四心。谓知初二及第八第十四心。有余师说。能知初二及第十一第十二心。即灭类智忍及灭类智俱心。佛他心智不由加行故。具知彼见道十五刹那心

佛智于三道皆能知自相共相。独觉智于独觉声闻道。能知自相共相。于佛道能知共相非自相。声闻智于声闻道能知自相共相。于佛独觉道能知共相非自相。问声闻入现观时。于佛独觉道能现观不设尔何失。若能现观。云何声闻他心智不能知佛及独觉心。若不能现观。云何亦得缘彼证净。又应现观时不遍观道谛。答应作是说。声闻入现观时。于佛独觉道亦能现观。问若尔云何声闻他心智不能知佛及独觉心。答入现观时知彼共相非自相故。能现观他心智唯知自相故。彼他心智。不知佛及独觉心

问一有情相续中所有他心智。能知一切有情随其所应心心所法。此智于彼为知总物类。为知别刹那。设尔何失。若知总物类非别刹那者。于别刹那云何能知。若知别刹那者。云何此智所依非多。谓我他心智聚。有二十一法缘一有情一刹那受。如一刹那受。一切刹那受亦尔。如受刹那无量无边。诸余一切心心所法刹那亦尔。如一有情心心所法刹那无量无边。诸余一切有情心心所法刹那亦尔。如是我心心所法则为多。余一切有情由智多故所依亦多。有作是说。知总物类非别刹那。问若尔于别刹那云何能知。答无有是处。然为分别。假使能知物类智尽。于余刹那不复欲知。设复欲知亦不能知。智若未尽欲知即知。又物类智于诸刹那不欲别知。设欲别知亦不能知。诸欲知者唯于物类。复有说者。知别刹那。问若尔云何此智所依非多。答无如是失。此彼等故。如我他心智聚二十一法。有无量无边刹那。于余一切有情一切心心所法。一一刹那别别能缘。如是诸余一切有情他心智聚。亦各有无量无边刹那。于余一切有情一切心心所法。一一刹那别别能缘。故智所依无偏多失。评曰。应知此中后说为善。心心所法所缘定故

问诸他心智。为能通缘三世。为但缘现在耶。答诸他心智但缘现在。问若尔论说当云何通。如说过去未来法九智知。除灭智。答应作是说。过去未来法八智知。除灭智。他心智现在法九智知。除灭智。而不作是说者。应知有别意趣。谓彼种类九智所知。若在过去即是过去他心智所知。亦是未来不生法。他心智所知。若在未来唯是未来他心智所知。若在现在即是现在他心智所知。亦是未来不生法他心智所知。依此意说过去未来法是九智所知。不说过去未来法是现在他心智所知。复有欲令他心智现在前时能知他相续三刹那心。谓现在前者。次前灭者次后生者。论依此说亦不相违。评曰。彼不应作是说。以他心智唯知现在他心心所。非余法故。问诸他心智为缘一物。为缘俱生心心所聚。设尔何过。若缘一物。契经所说当云何通。如契经说。于有贪心如实知此是有贪心。乃至广说。若于一时知贪及心岂非缘聚。余经所说复云何通。如世尊说。我一作意遍知苾刍僧诸心之所念。若缘聚者。云何他心智有三念住别。答应作是说。一刹那顷他心智起但缘一物。问若尔契经所说当云何通。如说。于有贪心如实知此是有贪心耶。答有贪心者。谓贪相应心。然知贪时不即知心。若知心时不复知贪。如观有垢衣。若观垢时则不观衣。若观衣时不复观垢。此亦如是。故不相违。问若尔余经所说复云何通。如世尊说。我一作意遍知苾刍僧诸心之所念耶。答彼经不说他心智但说比智。谓佛先以一他心智观一苾刍心所念已。后以比智总观苾刍僧诸心之所念。知彼皆住寂静正行。有作是说。此非他心智。亦非比智。乃是愿智。总知苾刍诸心所念。复有说者。此非他心智。亦非比智及愿智。然世尊尽智现在前时得。欲界如是种类未曾得无覆无记心心所法。不入静虑亦不起通。一作意时由此则能遍知苾刍僧诸心之所念。有说。此是欲界善心尽智时得。谓胜思慧。有余师说。诸他心智能缘俱生心心所聚。问若尔云何他心智有三念住别。答初引发时有三念住。后成满时总缘俱起心心所法。作杂缘法念住。评曰。一切他心智。一刹那顷但缘一法。唯缘实物。唯观自相。唯观现在时。唯观他相续。唯观心心所。不在见道。非空无相三摩地俱。亦非尽智无生智摄。无间道中不修不起是容豫道种类摄故

云何宿住随念智。答若智修所成是修果依止修已得不失。能现忆知诸宿住事。种种相状及所言说。是谓宿住随念智。此中若智修所成者。谓修所成慧为自性故。是修果者。谓是四支五支静虑果故。依止修者。谓依数习而成就故。已得不失者。已证得不舍故。问何故不说未得已失。答应说而不说者。当知此义有余。复次若由此智说名成就宿住通者。此中说之。未得已失。诸宿住智无如是义。是故不说。能现忆知诸宿住事者。谓此智能明了忆知过去生中。欲色界自他相续等事。种种相状及所言说者。谓生本死有名种种相状。可显示彼相状别故。中有名所言说。中有微细但可言说。不可示其相状别故。有作是说。中有名种种相状。似本有故。生本死有名所言说。可说彼为刹帝利等种姓别故。又本有时能起种种言论事故。复有说者。种种相状者。略显前生事。及所言说者广显前生事。有余师说。种种相状者。显过去世所诠表事。及所言说者显过去世能诠表事。如契经说。佛告阿难。若有相状及有言说可施设。有色身名身。若无相状及无言说可施设。有增语触有对触不。阿难白佛。不也。世尊此中内六处名相状。外六处名言说。有作是说。外六处名相状。内六处名言说。所以者何。依内六处可说六识及触言故。谓说名眼识眼触乃至意识意触。又契经说。由如是相状入初静虑具足住。此中相者谓加行相。状者谓所缘状。如论所说。除前相者相谓所名。如伽他说

  若成就八智　　十六行相者
  如赡部真金　　无能说其过

此中相声说无漏慧。应知此中诸宿住事。种种相状及所言说。皆显宿住随念智境。即欲色界过去生中。自他所更有漏五蕴

此宿住随念智。或应说一。谓宿住随念智通明力。或应说二。谓曾得未曾得。或应说三。谓下中上三品。或应说四。谓四静虑果。或应说六。谓曾得未曾得各有三品。或应说八。谓四静虑果各有曾得未曾得。或应说九。谓下下品乃至上上品。或应说十二。谓四静虑果各有三品。或应说十八。谓曾得未曾得各有九品。或应说二十四。谓四静虑果各有曾得未曾得。此复各有三品。或应说三十六。谓四静虑果各有九品。或应说七十二。谓四静虑果各有曾得未曾得此复各有九品。若以在身刹那分别应说无量无边。此中总说一宿住随念智。问此宿住随念智以何为自性。答以慧为自性。是谓宿住随念智自性。我物自体相分本性

已说自性。所以今当说。问何故名宿住随念智。宿住随念智是何义耶。答诸过去生有漏五蕴名为宿住。随念势力而能知彼。故名宿住随念智。谓此聚中虽有多法。而念力增故说随念。如四念住虽慧为体。而念力增故名念住。如持息念虽慧为体。而念力增名持息念。如本性念生智。虽慧为体。而念力增名本性念生智。如伏除色想虽慧为体。而想力增名伏除色想。此亦如是虽体是慧。而念力增名宿住随念智

此宿住随念智。界者是色界。问何故无色界无宿住随念智耶。答非田器故。乃至广说。复次宿住随念智依色引发。无色界无色故无此智。地者唯在四根本静虑。非近分无色。彼地不能发五通故。问静虑中间诸宿住事。依何地智能随念知。有作是说。初静虑上品随念智能知。复有说者。第二静虑下品随念智能知。评曰。应作是说。初静虑三品随念智皆能知。所以者何。一地摄故。所依者唯依欲色界身起。行相者作不明了行相。非十六行相摄故。所缘者初静虑宿住随念智。缘欲界初静虑前际有漏五蕴。乃至第四静虑宿住随念智。缘欲界四静虑前际有漏五蕴。此智不能缘无色界诸宿住事。彼地胜故。如初静虑宿住随念智。不知第二静虑以上诸宿住事。乃至第三静虑宿住随念智。不知第四静虑以上诸宿住事。是故第四静虑宿住随念智。不知无色界诸宿住事。问曾生欲色界所起无色界诸宿住事。是此智所缘不。答非此智所缘。如不知果。因亦尔故。问若宿住随念智。不能知无色界宿住事者。契经所说当云何通。如契经说。世尊于过去诸宿住事。若有色若无色。若有想若无想。种种相状及所言说皆能忆知。有作是说。若有色者。谓欲色界生本死有色相粗故。若无色者。谓中有位色微细故。评曰。彼不应作是说。所以者何。若作是说。声闻亦知与佛何异。而舍利子以此赞佛无上德耶。应作是说。若有色者。谓欲色界。若无色者。谓无色界。然佛不以宿住随念智忆知无色界诸宿住事。但以比智知无色界诸宿住事。问若尔外道及诸声闻亦有比智与佛何异。而舍利子以此赞佛无上德耶。答应知比智略有三种。一外道。二声闻。三佛。外道欲观诸宿住事。若观欲色界或二万劫不见。或四万劫不见。或六万劫不见。或八万劫不见。便谓断灭。声闻欲观诸宿住事。若观欲色界二万劫不见。便谓彼生空无边处。而彼或生上地寿量不尽而死。若观欲色界四万劫不见。便谓彼生识无边处。而彼或再生空无边处。或生上地寿量不尽而死。若观欲色界六万劫不见。便谓彼生无所有处。而彼或三生空无边处。或一生半生识无边处。或生非想非非想处寿量不尽而死。若观欲色界八万劫不见。便谓彼生非想非非想处。而彼或四生空无边处。或再生识无边处。或一生一分生无所有处。世尊欲观诸宿住事。若观欲色界命终时心。或结生时心。即如实知。如是有情当生空无边处。或从彼殁。如是有情当生识无边处。或从彼殁。如是有情当生无所有处。或从彼殁。如是有情当生非想非非想处。或从彼殁。于此四处或寿量尽而死。或寿量不尽而死。皆如实知。是故外道比智谓彼断灭。声闻比智或如其事或不如其事。佛比智明净胜妙皆如实知。内法异生及诸独觉。比智无色诸宿住事。如诸声闻应知其相。问第四静虑所起宿住随念智。为一刹那总缘五地诸宿住事。为地地别缘。设尔何失。若总缘五地。云何粗细一时能知。若地地别缘。何故说此能缘五地。答应作是说。地地别缘。问若尔何故说此能缘五地。答但说此智能缘五地。不说一时斯有何失。下三静虑准此应知。有作是说。若初引起地地别缘。若至成满时能总缘五地。念住者唯是杂缘法念住。尊者妙音作如是说。通四念住。如契经说。我念过去受乐受苦。既念知乐苦即是受念处。评曰。应作是说。念过去世诸乐苦具名受乐苦。非但缘受故彼非证。然宿住随念智。总观前生分位差别。唯是杂缘法念住摄。智者唯是世俗智。尊者妙音作如是说。此通六智。谓八智中除他心智及灭智。除他心智者。彼缘现在。此缘过去故。除灭智者彼缘无为。此缘有为故。评曰。应作是说。此唯世俗智缘前际事故。三摩地俱者。非三摩地俱。唯有漏故。根相应者。三根相应。谓乐喜舍。三世者是三世。缘三世者。过去现在者缘过去。未来者缘三种。善不善无记者。唯是善。缘善不善无记者。缘三种。系不系者。唯色界系。缘系不系者。唯缘欲色界系。学无学非学非无学者。唯非学非无学。缘学无学非学非无学者。唯缘非学非无学。见修所断不断者。唯修所断。缘见修所断不断者。缘见修所断。缘名缘义者。通缘名义。缘自他相续非相续者。缘自他相续。加行离染得者。通加行离染得。离染得者。谓初静虑者。离欲界染时得。乃至第四静虑者。离第三静虑染时得。或离自地上地染时亦容修得。加行得者。谓修胜进加行时得。及起加行令现在前。谓诸声闻以中上品加行。独觉唯以下品加行。佛不以加行能现在前。此所得者。唯修所成。在定有故。曾得本曾得者。一切圣者及内法异生。皆通曾得未曾得。外法异生唯是曾得。有作是说。住最后有异生及诸圣者。通曾得未曾得。诸余异生唯是曾得

问修宿住随念智加行云何。答施设论说。初修业者。于世俗定已得自在。数起现前令转明利。先审忆念次前灭心随念知已。次审忆念久已灭心随念知已。展转乃至加行成满。此中有说。渐审忆念至入母胎。前一刹那心名加行成满。若作是说非善成满。所以者何。入母胎前一刹那心是中有位。中有即是此生所摄。以众同分无差别故。犹忆此生岂善成满。应作是说。渐审忆念至此中有。前一刹那心名加行成满。彼是前生命终心故。能随念知名善成满。问修此加行渐忆念时。为以刹那。为以分位。答此以分位。不以刹那。若以刹那渐次忆念半生未尽即便命终。岂能修至加行成满。谓先忆念此生老位。次复忆念此生中年位。次复忆念此生少年位。次复忆念此生童子位。次复忆念此生婴孩位。次复忆念此生钵罗奢佉位。次复忆念此生键南位。次复忆念此生闭尸位。次复忆念此生頞部昙位。次复忆念此生羯刺蓝位。次复忆念入母胎位。次复忆念住中有位。次复忆念初受中有位。最后忆念前生命终位。尔时此智加行成满。问修此加行时为依自相续。为依他相续耶。有作是说。依自相续。若尔自前生欲色界者可尔。若前生无色界者云何可尔。复有说者。依他相续。若尔他前生欲色界者可尔。若前生无色界者云何可尔。评曰。应作是说。修此加行时。亦依自相续。亦依他相续。依自相续修加行者。若自前生欲色界者。即依自相续加行成满。若自前生无色界者。转依他相续加行成满。依他相续修加行者。若他前生欲色界者。即依他相续加行成满。若他前生无色界者。转依自相续加行成满。问修此加行时。为依欲界。为依色界耶。答此有四种。或有依欲界初修加行。后依色界加行成满。谓与暴恶难共住者。同住一处作是思惟。此必前生从欲界死。渐审忆念此乃前生从色界死。或有依色界初修加行。后依欲界加行成满。谓与调善易共住者。同住一处作是思惟。此必前生从色界死。渐审忆念此乃前生从欲界死。或有依欲界初修加行。还依欲界加行成满。谓与暴恶难共住者。同住一处作是思惟。此必前生从欲界死。渐审忆念此果前生从欲界死。或有依色界初修加行。还依色界加行成满。谓与调善易共住者。同住一处作是思惟。此必前生从色界死。渐审忆念此果前生从色界死。如依界修加行差别。依趣等亦尔

问此宿住随念智为但忆知曾所更事。为亦忆知未曾更事。答此但忆知曾所更事。问若尔此智应不忆知五净居事。无始时来未生彼故。答曾所更事略有二种。一者曾见。二者曾闻。虽未曾见五净居事。而曾闻故亦能忆知。余欲色界极远极胜。诸难知事准此应知

问此宿住随念智。为一入定唯知一生。为一入定知多生耶。答初引发时若一入定唯知一生。后成熟时若一入定知百千生。世尊一入定若初若后皆能知百千生。问此宿住随念智。为能舍近百千生事。而知远百千生事耶。答初引发时不能。后成熟时则能。世尊若初若后俱能

问此宿住随念智。渐次忆知前际无量宿住事已。欲退出时为依前入渐次退出。为顿出耶。有作是说。必依前入渐次退出。评曰。应作是说。随所意乐。若渐若顿皆能退出。问以宿住智忆知前际宿住事已。无间即能起死生智。观察后际死生事耶。答佛能非余。诸佛功德不作加行能现前故。独觉声闻诸外道等。要作加行方能起故

问此宿住随念智。一刹那顷能知几生。答能知一生。云何知然。有圣教故。如毗奈耶说。尊者净妙告诸苾刍言。我一起心忆知过去五百生事。时诸苾刍皆共诃摈言。汝自称得过人法不应共住。必无但起一刹那心知多生故。尔时佛告诸苾刍言。汝等不应诃摈净妙。随实想说不犯重故。谓此净妙曾生无想有情天中。五百劫寿今忆彼事。谓五百生随实想说故不犯重。由此证知一刹那顷但知一生。问此宿住随念智。一刹那顷能知几趣耶。有作是说。此智一刹那顷但知一趣。谓或知地狱趣。乃至或知天趣。复有说者。此智一刹那顷能知二趣。谓或知地狱傍生趣。或知鬼界傍生趣。或知人傍生趣。或知天傍生趣。评曰。应作是说。此智一刹那顷。随其所应能知多趣。谓若忆念转轮王事。一刹那顷即知人鬼傍生三趣。若知轮王诸臣眷属。名知人趣。若知能转轮及受祀鬼等。名知鬼趣。若知象马等。名知傍生趣。若能忆念曼驮多王。与天帝释共集会事。能知四趣。唯除地狱知余三趣。广说如前。知天趣者。谓知帝释及彼眷属。假使五趣一处集会一刹那顷皆能忆知。是故此智一刹那顷。随其所应能知多趣

如契经说。常见论者忆知宿住事。有三种差别。一有常见论者能忆知二万劫事。二有常见论者能忆知四万劫事。三有常见论者能忆知八万劫事。复有别诵。第三忆知六万劫事。问何等常见论者能忆知二万劫事。乃至何等常见论者能忆知八万劫事耶。答常见论者根有三品。若下根者能忆知二万劫。若中根者能忆知四万劫。若上根者能忆知八万劫。复次常见论者能忆知三劫坏事。若能忆知火劫坏事者。彼能忆知二万劫。若能忆知水劫坏事者。彼能忆知四万劫。若能忆知风劫坏事者。彼能忆知八万劫。复次常见论者。能忆知三根坏事。若能忆知喜根坏事者。彼能忆知二万劫。若能忆知乐根坏事者。彼能忆知四万劫。若能忆知舍根坏事者。彼能忆知八万劫。复次常见论者有三乘种性差别。若有声闻种性者。彼能忆知二万劫。若有独觉种性者。彼能忆知四万劫。若有佛种性者。彼能忆知八万劫。是谓三种别忆知缘。问已说二智自性。杂不杂相今当说。诸他心智皆现知他心心所法耶。答应作四句。此中他心智通三世。现知他心心所法者唯现在。然通他心智。及非他心智。故有四句。有他心智非现知他心心所法。谓过去未来他心智。此有他心智相。而无现知他心等用。谓过去者作用已灭故。未来者未有作用故。有现知他心心所法。非他心智。谓如有一或睹相。或闻语或得如是生处得智。能现知他心心所法。睹相现知他心心所法者。人趣中有如邬波难陀释子。至一近事家。见其门边有一驳犊。便告近事。若得卧具如汝门边驳犊皮者岂不美哉。时彼近事作是念言。今此释子定应欲得我驳犊皮持作卧具。便害驳犊以皮施与释子。受之还本所止。犊母悲唤寻后而行。故知人中有睹相智。闻语现知他心心所法者。人趣中有如邬波难陀释子。见一居士着新好衣入誓多林。便告彼曰。若得三衣敷具似汝所著衣者岂不美哉。时彼居士作是念言。今此释子定应欲得我所著衣作衣卧具。便脱施与。故知人中有闻语智。有作是说。所引二种皆闻语摄或俱睹相。此本论文。应作是说。或睹相或占卜。能现知他心心所法。或睹相者。如前所说。及余见闻身语业相知他心者。或占卜者。如诸外道种种占卜知他心者。生处得智现知他心心所法者。谓地狱等。有其事云何。且地狱中亦有生处得智能知他心等。然无别现事可说。问彼于何时知他心等。答初生地狱未受苦时。若受苦已尚不能知自心所念。况能知他心心所法。问彼住何心知他心等。善耶。染污耶。无覆无记耶。答三种皆能知。问为住意识。为住五识知他心等。答唯住意识。问为住威仪路心。为住工巧处心。为住异熟生心知他心等。答唯住威仪路心。所以者何。彼无现起工巧处心故。彼异熟生心唯五识有故

说一切有部发智大毗婆沙论卷第一百阿毗达磨大毗婆沙论卷第一百一

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    智蕴第三中他心智纳息第三之三

傍生趣亦有生处得智能知他心等。云何知然。昔有女人置儿一处作余事业。时有一狼持其儿去。傍人为逐语彼狼言。汝今何缘将他儿去。狼遂报曰。其母过去五百生中常害我子。我亦过去五百生中常害彼子。怨怨相报于今未息。彼若能舍我亦舍之。傍人便告彼儿母曰。汝若惜子当舍怨心。女人报言我已舍矣。狼观女意都不舍怨。但恐害儿妄言已舍。遂害其子舍之而去。问傍生何时知他心等。答初中后位皆悉能知。问彼住何心知他心等。善耶。染污耶。无覆无记耶。答三种皆能知。问为住意识。为住五识。知他心等。答唯住意识。问为住威仪路心。为住工巧处心。为住异熟生心知他心等。答三种皆能知。彼亦现起工巧处心故。彼异熟生心意识亦有故。非如地狱决定不受善异熟果。鬼趣亦有生处得智知他心等。云何知然。昔有女人。为鬼所魅羸瘦将死。咒师问鬼汝今何为恼此女人。鬼便报言。此女过去五百生中常害我命。我亦过去五百生中常害彼命。怨怨相报于今未息。彼若能舍我亦舍之。咒师因报彼女人曰。汝若惜命当舍怨心。女人报言我已舍矣。鬼观女意都不舍怨。恐命不全妄言已舍。遂断其命舍之而去。问鬼趣何时知他心等。答初中后位皆悉能知。问彼住何心知他心等。善耶。染污耶。无覆无记耶。答三种皆能知。问为住意识。为住五识知他心等。答唯住意识。问为住威仪路心。为住工巧处心。为住异熟生心知他心等。答三种皆能知。如傍生趣说

天趣亦有生处得智知他心等。然微细故不别说之。余如傍生鬼趣广说。人趣中无生处得智知他心等。所以者何。非田器故。有胜睹相。闻语智等所覆损故。有他心通及愿智等所映蔽故。问谁生处得智知几趣心耶。有作是说。各唯自知。复有说者。地狱唯知地狱。傍生知二。鬼趣知三。天趣知五。施设论说哀罗筏拏善住龙王知天心者。是比相智知非生处得智。评曰。应作是说。于四趣中生处得智。各知五趣。于理无违。问人趣亦有本性念生智类。应能知他心等。何故不说。答应说而不说者。当知此义有余。复次少故不说。谓人趣中得此智者极少有故而不说之。有作是说。本性念生智类。不能现知他心心所法故此不说有他心智亦现知他心心所法。谓若智修所成。是修果依止。修已得不失。能现知他现在欲色界心心所法。或无漏心心所法。此是现在他心智通广如前释。有非他心智亦非现知他心心所法。谓除前相。相谓所名乃至广说。谓行蕴中总除三世他心智通。及除现在睹相闻语生处得智。能现知他心心所者。诸余行蕴及四蕴全并无为法作第四句

诸宿住随念智皆现忆知诸宿住事耶。答应作四句。此中宿住随念智通三世。现忆知诸宿住事者唯现在。然通宿住随念智。及非宿住随念智。故有四句。有宿住随念智。非现忆知诸宿住事。谓过去未来宿住随念智。此有宿住随念智相。而无现忆知诸宿住事用。诸过去者作用已灭故。未来者未有作用故。有现忆知诸宿住事。非宿住随念智。谓如有一得本性念生智。或得如是生处得智。能现忆知诸宿住事。本性念生智现忆知宿住事者唯人趣有。余四趣中无此智故。生处得智能现忆知诸宿住事者。谓地狱等有。其事云何。且地狱中如契经说。地狱有情互相谓言奇哉自误。我等过去曾闻沙门婆罗门说诸欲过患。能引未来可怖畏事汝等应断。我等虽闻而不信用。今因彼欲受斯剧苦。问彼于何时忆宿住事。答初生地狱未受苦时。若受苦已次前灭事尚不能忆。况久灭事而能忆知。问彼住何心忆宿住事。答住善染污无覆无记皆能忆知。于六识中唯住意识。于三无记中唯住威仪路。问彼生处得智能忆知几生答能忆知一生。谓从彼殁来生此者。有说。乃至知五百生。傍生趣有生处得智。能现忆知宿住事者。如契经说。有螺音狗。昔为梵志。名刀提那忆宿住事子令升座食饭示宝。皆随其言。问于何时忆宿住事。答初中后位皆能忆知。问彼住何心忆宿住事。答住善染污无覆无记皆能忆知于六识中唯住意识。三无记中通住三种。问彼生处得智能忆知几生。有作是说。唯忆一生。谓从彼殁来生此者。评曰。应作是说能忆多生。如狼忆知五百生事。鬼趣亦有生处得智。能现忆知宿住事者。如伽他说

  我昔集珍财　　以法或非法
  他今受富乐　　我独受贫苦

问彼于何时忆宿住事。答初中后位皆能忆知。问彼住何心忆宿住事。答住善染污无覆无记皆能忆知。于六识中唯住意识。三无记中通住三种。问彼生处得智能忆知几生。有作是说。唯忆一生。谓从彼殁来生此者评曰。应作是说。能忆多生。如鬼忆知五百生事。天趣亦有生处得智。能现忆知宿住事者。如伽他说

  我施誓多林　　蒙大法王住
  贤圣僧受用　　故我心欢喜

问彼于何时忆宿住事。答初中后位皆能忆知。问彼住何心忆宿住事。答住善染污无覆无记皆能忆知。于六识中唯住意识。三无记中通住三种。问彼生处得智能忆知几生。有作是说。唯忆一生。谓从彼殁来生此者。评曰。应作是说。能忆多生。人趣中无生处得智忆宿住事。非田器故。为本性念生智等所损覆故。为宿住随念通。及愿智等所映蔽故

有宿住随念智亦现忆知诸宿住事。谓若智修所成。是修果依止。修已得不失。能现忆知诸宿住事种种相状及所言说。此是现在宿住随念智通。广如前释。有非宿住随念智亦非现忆知诸宿住事。谓除前相。相谓所名乃至广说。谓行蕴中总除三世宿住随念智通。及除现在本性念生智。生处得智。能现忆知宿住事者。诸余行蕴及四蕴全并无为法作第四句

诸宿住随念智。皆知他过去蕴处界心相续耶。答应作四句。此中初句是缘自相续宿住随念智。第二句是缘他相续愿智。及宿住随念智加行。第三句是缘他相续宿住随念智。第四句是缘自相续愿智。及宿住智加行。是谓此处略毗婆沙。有宿住随念智。非知他过去蕴处界心相续。谓若智修所成。是修果依止。修已得不失。知自前生过去蕴处界心相续。此即缘自相续宿住随念智。缘过去生自宿住事故。有知他过去蕴处界心相续。非宿住随念智。谓若智修所成。是修果依止。修已得不失。知他此生过去蕴处界心相续。此即缘他相续愿智。及宿住智加行。缘现在生他过去事故。有宿住随念智亦知他过去蕴处界心相续。谓智修所成。是修果依止。修已得不失。知他前生过去蕴处界心相续。此即缘他相续宿住随念智。缘过去生他宿住事故。有非宿住随念智。亦非知他过去蕴处界心相续。若智修所成。是修果依止。修已得不失。知自此生过去蕴处界心相续。此即缘自相续愿智。及宿住随念智加行。缘自此生过去事故。此中愿智唯缘此生。过去诸有漏法。宿住随念智唯缘前生过去诸有漏法。宿住随念智加行。亦唯缘此生过去诸有漏法。然诸愿智通缘三世。此中唯取缘此生过去有漏法者。问前所说本性念生智。以何为自性。答以慧为自性。是谓本性念生智自性我物自体相分本性。已说自性。所以今当说。问何故名本性念生智。本性念生智是何义耶。答生谓前生诸有漏法。智谓此生能知彼智。念谓此智俱生胜念。言本性者简别修得。即本性智由胜念力知过去生诸有漏法故。名本性念生智。复次住本性心由胜念力发起此智。知过去生诸有漏法。故名本性念生智。本性心者。谓善染污无覆无记。不由修得故名本性。复次本性者。谓诸法自性即过去生诸有漏法自性。智由念力知本性生。故名本性念生智。复次本性者。谓前际法性即过去生有漏法性。智由念力知本性生故名本性念生智。问此智俱生法有多种何故但说念耶。答念力增故。如四念住持息念宿住随念智。虽慧为体。而念力增故名念住等。如伏除色想虽体是慧。而想力增故名伏除色想。此亦如是。虽体是慧。而念力增故名本性念生智。问此本性念生智在何界有。答唯欲界有。问此本性念生智在何趣有。答唯人趣有。所以者何。唯欲界人趣中能造殊胜业引得此智。又人趣中智慧猛利胜余趣故。问此本性念生智。由何业力而引起耶。有作是说。若诸有情喜作爱语令他欢喜。由彼业力能引此智。复有说者。若诸有情喜传好事令他心悦身得安乐。由彼业力能引此智。有余师说。若诸有情见他惶怖。方便慰喻为作归依令得无畏。由彼业力能引此智。或有说者。若诸有情见他愁恼以法开喻令得无忧。由彼业力能引此智。有余复说。若诸有情见崄隘处修令宽博。使往来者无有艰难。由彼业力在母腹中无迫迮苦故得此智。或有余说。若诸有情施他种种美妙饮食。由彼业力能引此智。评曰。应作是说。若诸有情。不造恼害他业。恒作饶益他事。由斯业故在母腹中。不为风热痰癊病等之所逼切。后出胎时无迫迮苦。是故能忆诸宿住事。故有是说。若诸有情住在母腹及出胎时。不受众病迫迮苦者。皆应能忆过去生事但由母病及迫迮苦皆悉忘之。问此本性念生智。初中后时何者为胜。答此不决定。谓或有初生时胜。如世跋罗等初生之时。便作是说。今此家中颇有财物。令我随意行布施耶。或有中年时胜如尊者护国等。或有老年时胜。如庵婆瑟搋等。广说如契经问此本性念生智能忆几生事耶。有作是说。唯能忆一生事。谓从彼殁来生此者。或有说者。此能忆二生。或乃至七生事如王舍城内有一屠儿。名曰伽吒。是未生怨王少小知友。曾白太子。汝登王位与我何愿。太子语言当恣汝请。后未生怨害父自立。伽吒于是从王乞愿。王便告曰随汝意求。伽吒白言。愿王许我王舍城中独行屠杀。王遂告曰。汝今云何求此恶愿。岂不怖畏当来苦耶。屠儿白王。诸善恶业皆无有果何所怖畏。王遂告曰汝云何知。伽吒白王。我忆过去六生。于此王舍城中常行屠杀。最后生在三十三天多受快乐。从彼天殁来生此间。少小与王得为知友。故知善恶其果定无。王闻生疑便往白佛。佛告王曰。此事不虚。然彼屠儿曾以一食施与独觉发邪愿言。使我常于王舍城内独行屠杀后得生天。由胜业因果遂其愿。彼先胜业与果今尽。却后七日定当命终生号叫地狱。次第受先屠业苦果。是故此智极知七生。复有说者。此极能忆五百生事。谓有苾刍自忆过去五百生中堕饿鬼趣。念彼所受饥渴苦时。遍身流汗深心怖恼。息诸事业精进炽然。后经多时得预流果。彼作是念。我从先来。赖诸苾刍济惠资具。令我所怖已得永灭。今应追觅诸资身具以酬先恩。作是念已处处求觅诸资身具。时诸苾刍见而谓曰。汝先少事今何故多。彼遂为他具说本事。复有苾刍自忆过去五百生中堕地狱趣。念彼所受地狱苦时。诸毛孔中遍皆流血。身及衣服非常臭秽。每日诣水澡浴浣衣。众人谓之计水为净。彼息事业精进炽然经于多时证阿罗汉。于后不数澡浴浣衣。众人怪问。彼亦为他具说本事。由此故知此智忆念极五百生。有余师说。此智能知过去坏劫及成劫事。谓佛往昔为菩萨时。为化有情发大誓愿。有时曾作旃茶罗王名曰三钩。善通一切书论咒术。尔时阿难作彼王子名师子耳。颜貌端正世所绝伦。时舍利子作婆罗门名曰池坚。善通明论及诸眷属。彼有一女名为贞洁。容貌端严众所乐见。时王往诣婆罗门所为子求婚。池坚大忿白彼王言。汝诸姓中最为卑贱。我是梵志诸姓中尊。何缘来此故相轻辱。时王遂告婆罗门言。族姓尊卑亦无常定。汝何见忽而自矜高。汝颇曾闻诸梵书字是谁所造。池坚报曰。我闻古昔有婆罗门名瞿频陀。是彼所造。王曰。彼时瞿频陀者即我身是。汝又颇闻佉卢瑟吒书字是谁所造。婆罗门曰我闻古昔有大仙人名佉卢瑟吒。是彼所造。王曰。彼时大仙人者即我身是。王又问言。汝颇曾闻诸吠陀论及彼眷属世俗书等是谁造耶。婆罗门言如是如是部党书论。即是彼彼诸婆罗门仙人等造王又报言。彼皆是我昔时名字汝颇知耶。如何汝今自矜见蔑。池坚于是一一推征如王所言是实非谬。深心敬慕遂许王婚。由此故知此智能忆极过去世劫成坏事

如契经说。佛告邑主。我自忆念过去九十一劫以来。于净戒田施饮食等尝无废阙。又亦不忆为饮食等于戒毁伤。问世尊为以宿住随念智忆知此事。为以本性念生智忆知此事。设尔何失。若以宿住随念智忆知此事。何故但忆九十一劫而不多耶。若以本性念生智忆知此事。何故前说有说此智唯忆一生。有说忆二乃至极七生。有说忆五百生。有说忆劫成坏。而不说能忆九。十一劫耶。答应作是说世尊以宿住随念智忆知此事。问若尔。何故但忆九十一劫而不忆多。答实能忆多且说尔许。问若尔。何故不说忆多。胁尊者曰。一切生疑若说忆多若说忆少皆生疑问。故随事说于理无违不应责问。复次从彼建立七佛世尊是故偏说。复次从彼以来修相好业故偏说之。复次从彼以来业道清净不堕恶趣。恒受男身常忆宿住是故偏说。复有说者。世尊以本性念生智忆知此事。问若尔。何故前说有说唯忆一生。乃至有说忆劫成坏。而不说能忆九十一劫耶。答前说余人能忆多少而不说佛。若说佛者亦能忆多

问本性念生智为能忆知中有事不。有作是说。不能忆知。所以者何。以中有事极微细故非此智境。评曰。应作是说本性念生智亦能忆知中有中事。所以者何。若不忆知此智知境应成间杂。谓少分能知。少分不知故。问菩萨前生既有本性念生智。于最后生为亦有不。设尔何失。若有者。云何缘力非胜因力耶若无者。云何菩萨非转衰退。答应作是说。菩萨最后身亦有本性念生智。问若尔。云何缘力非胜因力耶。答非无缘力者。名有内因力。及以利根故名有内因力。谓此菩萨于诸有情根性最胜名有因力。又谁说菩萨无缘力耶。有净居天现老病死。觉发菩萨厌生死心岂非缘力。又鹿释女为菩萨说赞涅槃颂。觉发菩萨欣涅槃心。亦是缘力。如说

  不久汝当得　　安乐以为母
  无忧以为父　　寂灭以为妻

菩萨见闻如是事已。既增厌欣踰城出家。又过去生有无量佛。为菩萨说菩提资粮。诸如是等皆名缘力。有作是说。菩萨最后身无本性念生智。问若尔。云何非转衰退。答虽无此智。而有殊胜宿住随念智。及愿智等。故非衰退。评曰。应知此中前说应理。从九十一劫恒有此智故

云何时爱心解脱乃至广说。问何故作此论。答为欲分别契经义故。谓契经说。佛告阿难。苾刍不应乐与众聚耽诸戏论。若乐众聚耽戏论者。能证时爱心解脱。及不动心解脱。无有是处。若诸苾刍不乐众聚不耽戏论。能证二解脱。斯有是处。契经虽作是说。而不广释其义。不说此二解脱自性。及得因缘。根蕴虽说得二因缘。不显自性。今欲显之。复次为止他宗显正理故。谓或有说。时爱心解脱是有学有所作。不动心解脱是无学无所作。为遮彼意显二解脱俱是无学更无所作。或复有说。时爱心解脱是有漏。不动心解脱是无漏。为遮彼意显二解脱俱是无漏。复有欲令时爱心解脱是有为不动心解脱是无为。为遮彼意显二解脱俱是有为。由此等缘故作斯论云何时爱心解脱。答时解脱阿罗汉尽智。或无学正见相应心胜解。已胜解当胜解。云何不动心解脱。答不动法阿罗汉尽智无生智。或无学正见相应心胜解。已胜解当胜解。此中尽无生智无学正见相应心者。简别有学及有漏。心胜解者谓现在。已胜解者谓过去。当胜解者谓未来。此即简异无为解脱。显二解脱唯以无学无漏心相应胜解为自性。然一切法中唯有二法是解脱自性。谓无为法中择灭是解脱自性。有为法中大地法所摄胜解是解脱自性。此胜解有二种。一染污。谓贪等相应名邪胜解。二不染污。谓无贪等相应名正胜解。此正胜解复有二种。一有漏。谓不净观持息念。无量解脱胜处遍处等相应胜解。二无漏。谓学无学胜解学胜解者。谓四向三果所摄胜解。即苦法智忍乃至金刚喻定相应胜解。无学胜解者。谓阿罗汉果所摄胜解。即尽无生智无学正见相应胜解。无学胜解复有二种。一时爱心解脱。即五种阿罗汉果所摄胜解亦名时解脱。二不动心解脱。谓不动法阿罗汉果所摄胜解亦名不时解脱。此二解脱各有二种。一名心解脱。离贪爱故。二名慧解脱。离无明故。问若无学胜解离贪爱故名心解脱。离无明故名慧解脱者。集异门说当云何通。如说云何心解脱。谓无贪善根对治贪爱云何慧解脱。谓无痴善根对治无明耶。答集异门论应作是说。云何心解脱。谓无贪善根相应胜解。云何慧解脱。谓无痴善根相应胜解。应作是说而不说者有别意趣。谓依善根显示胜解。若依无贪故心解脱贪爱。此相应胜解名心解脱。若依无痴故慧解脱无明。此相应胜解名慧解脱。是故此中二心解脱。俱以无学胜解为自性。是名解脱自性我物自体相分本性。已说自性。所以今当说。问何故名时解脱。时解脱是何义耶。答由彼解脱待时得故。时虽有多略有六种。一得好衣时。二得好食时。三得好卧具时。四得好处所时。五得好说法时。六得好补特伽罗时。待得好衣时者。谓彼要得细软鲜净胜妙衣服时乃得解脱。若不尔者则不得解脱。待得好食时者。谓彼要得美妙饮食酥蜜等时乃得解脱。若不尔者则不得解脱。待得好卧具时者谓彼要得厚软卧具床褥等时乃得解脱。若不尔者则不得解脱。待得好处所者。谓彼要得寂静处所胜妙房舍时乃得解脱。若不尔者则不得解脱。待得好说法时者。谓彼要得如理应机教诫教授时乃得解脱。若不尔者则不得解脱。待得好补特伽罗时者谓彼要得具胜德行禀性柔和易共住者。与同住时乃得解脱。若不尔者则不得解脱。问何故名不时解脱。不时解脱是何义耶。答由彼解脱不待时得故。时即如前所说六种。不待得好衣时者。谓彼虽得恶粪扫衣时。而能速得解脱。胜时解脱者。得价直百千两金衣时。不待得好食时者。谓彼虽得粗恶饮食时。而能速得解脱。胜时解脱者。得百味饮食时。不待得好卧具时者。谓彼虽得边鄙卧具石床等时。而能速得解脱。胜时解脱者。得上妙卧具时。不待得好处所时者。谓彼虽得愦闹处所恶房舍时。而能速得解脱。胜时解脱者。得静妙处所时厌彼谊杂速入定故。不待得好说法时者。谓彼虽得违理失机教诫教授时。而能速得解脱。胜时解脱者。得如理应机教诫教授时。厌彼所说速入定故。不待得好补特伽罗时者。谓彼虽得不具德行为性。佷戾难共住者与同住时。而能速得解脱。胜时解脱者。得具德行等与同住时。厌彼猥恶速入定故。复次依狭小道而得解脱故名时解脱。狭小道者。谓若极速第一生中种善根。第二生中令成熟。第三生中得解脱。余不决定。依广大道而得解脱名不时解脱。广大道者。谓若极迟声闻乘。经六十劫而得解脱。如舍利子独觉乘。经百劫而得解脱。如麟角喻佛乘。经三无数劫而得解脱。复次依羸劣道而得解脱故名时解脱。羸劣道者。谓于解脱善品加行。不能恒常殷重修故。若于日初分修。于中后分则不能修。若于夜初分修。于中后分则不能修。虽暂能修而不殷重依强胜道而得解脱。故名不时解脱。强胜道者与上相违。复次依止增道而得解脱故名时解脱。依观增道而得解脱故名不时解脱。复次依可引夺道而得解脱故名时解脱。可引夺道者。谓所修道可为适意不适意。饶益不饶益。乐苦资具之所引夺。依不可引夺道。而得解脱。故名不时解脱。不可引夺道者与上相违。复次依五种种姓道。而得解脱。故名时解脱。五种种姓道者。谓退法种姓道。乃至堪达法种姓道。依一种种姓道而得解脱故名不时解脱。一种种姓道者。谓不动法种姓道。此则说五种种姓阿罗汉名时解脱。不动法种姓阿罗汉名不时解脱。问因论生论。何故前五阿罗汉总立为一时解脱。第六阿罗汉别立为一不时解脱耶。答有别缘故。时解脱多。不时解脱少。谓依种姓。施设前五种姓。名时解脱阿罗汉。第六种姓名不时解脱故。有别缘故。时解脱少。不时解脱多。谓依乘施设唯声闻乘有时解脱阿罗汉。三乘皆有不时解脱阿罗汉故。有别缘故二解脱等。谓二解脱俱离烦恼。俱是清净无学身中圣道摄故。复次时解脱劣故施设五种。不时解脱胜故建立一种。如今世间国王大臣长者居士。诸富贵者其数极少。诸贫贱类其数甚多。又如世间佛及独觉到究竟声闻其数极少。诸余声闻其数甚多。又如世间聪慧者少愚蒙者多。又如世间为善者少作恶者多。又如世间正见者少邪见者多。又如世间端正者少丑陋者多。又如世间调柔者少刚强者多。如是前五阿罗汉劣故合名时解脱。第六阿罗汉胜故别名不时解脱。复次前五阿罗汉世间易得。故合立一名时解脱。第六阿罗汉世间难得。故别立一名不时解脱。如今世人往至那国执师子国还者极少。往近聚落还者甚多。此亦如是。复次前五阿罗汉不多用功力。不多设加行。不多作意而得。故合立一名时解脱。第六阿罗汉与上相违。故别立一名不时解脱。复次前五阿罗汉有增有减。故合立一名时解脱。第六阿罗汉无增无减。故别立一名不时解脱。此中增者谓进。减者谓退

说一切有部发智大毗婆沙论卷第一百一阿毗达磨大毗婆沙论卷第一百二

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    智蕴第三中他心智纳息第三 之四

何缘时心解脱名爱耶。答时解脱阿罗汉。恒于此法。殷勤守护宝爱执藏。勿我遇缘退失此法。如一目人自及亲友殷勤守护宝爱执藏勿遇寒热尘翳等缘。令此一目更当失坏。彼亦如是故名为爱。谓钝根者于自功德为性宝爱过利根者。如诸女人于自男女。禀性慈爱过诸丈夫。复次时解脱阿罗汉于自解脱未得自在。多用功力乃能现前。既得现前欢喜宝重故名为爱。不时解脱阿罗汉。于自解脱已得自在。少用功力即能现前虽得现前而不极重故不名爱。复次时解脱阿罗汉功德容退。彼畏退故数起现前故名为爱。不时解脱阿罗汉功德无退。不畏退故不数现前故不名爱。复次时解脱阿罗汉。由信增道证故名为爱不时解脱阿罗汉。由慧增道证故不名爱。复次时解脱阿罗汉。性多调善人多爱乐故名为爱。不时解脱阿罗汉。性多刚强人不爱乐故不名爱。如今世人。性不利者多分软善人好亲附。性不钝者多分刚猛人不亲附。复次时解脱阿罗汉。无厌背圣道善根故名为爱。不时解脱阿罗汉。有厌背圣道善根故不名爱。厌背圣道善根者。谓空空无愿无愿无相无相三摩地相应善根。此本论文虽不问答。而义有故今应说之。问何缘不时解脱名不动耶。答以体殊胜故名不动。如今世间殊胜饮食衣服严具说名不动。不为劣物格量转故。复次贪等烦恼令诸有情身心轻躁。令诸善根生[革*卬]离散故名为动。不时解脱阿罗汉不为如是烦恼所动故名不动。复次贪等烦恼。能令有情于诸分位胜劣不定故名为动。不时解脱阿罗汉不为如是烦恼所动故名不动如勇健人无敌能动名不动者。复次不时解脱阿罗汉。于诸功德定不退失故名不动。如善射人射必中的名不动者。如契经说。佛告舍利子。若有苾刍苾刍尼等。成就不动心解脱末尼宝者。能断不善法。能修习善法问何故不动心解脱。说名末尼宝耶。答以不动心解脱。坚牢故。胜妙故。无过故明彻故。无垢故。清净故。难得故。可爱乐故。名末尼宝。复次以不动心解脱。能破无明闇故名末尼宝。如以光明末尼置闇室中。能破彼闇作显照事。如是以不动心解脱末尼宝。置相续中能破无明闇作显照事。复次以不动心解脱能除烦恼尘垢故。名末尼宝。如清水末尼置浊水中水便澄净。如是以不动心解脱末尼宝置相续中。能除一切烦恼尘垢。复次以不动心解脱善安住故名末尼宝。如方等末尼随所置处即善安住。如是以不动心解脱末尼宝。置相续中。即善安住定无退失。复次以不动心解脱能除贫乏圣财故名末尼宝。如无价末尼置室宅内能引财宝除诸贫匮。如是以不动心解脱末尼宝置相续中。能引圣财除乏功德。复次以不动心解脱能饶益诸有情故名末尼宝。如如意珠置高幢上。随意所乐雨诸宝物充济百千贫匮有情。如是世尊以不动心解脱末尼宝。置不放逸无量幢上。随诸有情所乐差别雨。正法宝。能令无量无边有情离生死苦善根满足。由如是等种种因缘。说不动心解脱。名末尼宝。问若不动心解脱有如是胜事。何故世尊说不动心解脱名无减无增法耶。答依修行者平等说故。谓若东方有无量刹帝利子。南方有无量婆罗门子。西方有无量吠舍子。北方有无量戌达罗子。皆来归我剃除须发被服袈裟正信舍家趣于非家。于不动心解脱身作证具足住。或不尔者。此不动心解脱亦无减无增故。复次依圣教功德无边说故。谓圣教中有无边功德。非唯有不动心解脱。假使此不动心解脱去亦不减来亦不增故复次依佛功德无边说故。谓佛身中有无边功德。非唯有不动心解脱假使不动心解脱去亦不减来亦不增故。复次为除众疑故作是说。谓大目连。于布洒他夜。摈瞻波苾刍。令出众外。时有苾刍心生疑念。勿苾刍僧令致减少。故世尊说。假使殊胜功德丛林众中。摈出不动心解脱者。我苾刍僧亦无有减。彼若来者众亦不增。况彼苾刍破戒犯禁。坏诸威仪远离白法。岂令清众有减有增。复次以不动心解脱不可退故说名无减。不胜进故说名无增。故不动心解脱虽有胜事。而佛说为无减无增

诸时爱心解脱皆尽智相应耶。乃至广说。问何故作此论。答欲令疑者得决定故。谓有闻说时解脱阿罗汉唯修尽智无学正见。便疑不时解脱阿罗汉亦唯修二。复有闻说不时解脱阿罗汉修尽无生智无学正见。便疑时解脱阿罗汉亦修三种。欲除彼疑显时解脱唯修二种不时解脱具修三种。复次前虽说二解脱自性。而未说彼杂不杂相。今欲说之故作斯论。此中时爱心解脱对尽智相应有四句。不动心解脱对无生智相应。作顺后句皆如本文应知

问何等阿罗汉唯修尽智无学正见二无漏慧。何等阿罗汉。具修尽无生智无学正见三无漏慧耶。答有阿罗汉心善解脱非慧善解脱。有阿罗汉心慧俱善解脱。前唯修二。后具修三。复次有阿罗汉因力加行力不放逸力皆狭小。有阿罗汉因力加行力不放逸力皆广大。前唯修二。后具修三。复次有阿罗汉是奢摩他行。有阿罗汉是毗钵舍那行。前唯修二。后具修三。如二行二乐二欲二爱亦尔。复次有阿罗汉修止为先而入圣道。有阿罗汉修观为先而入圣道。前唯修二。后具修三。复次有阿罗汉以止修心依观得解脱有阿罗汉以观修心依止得解脱。前唯修二。后具修三。复次有阿罗汉得内心奢摩他。不得增上慧法观。有阿罗汉得内心奢摩他。亦得增上慧法观。前唯修二。后具修三。复次如契经说。二因二缘能生正见。一外闻他音。二内正作意。若外闻他音增上者唯修二。若内正作意增上者具修三。复次如契经说。有四法者多有所作。一亲近善士。二听闻正法。三如理作意。四法随法行。前二增者唯修二。后二增者具修三。复次钝根者唯修二。利根者具修三。如钝根利根缘力因力。外分力内分力。说智闻智。应知亦尔复次若无贪善根增者唯修二。若无痴善根增者具修三。复次若以灭道智尽三界结者唯修二。若以苦集智尽三界结者具修三。复次若以无相道无愿三摩地尽三界结者唯修二若以空苦集无愿三摩地尽三界结者具修三。此中时爱心解脱阿罗汉。金刚喻定唯一刹那。尽智流注长时相续。从尽智出。或起无学正见。或起世俗心不动心解脱阿罗汉。金刚喻定及尽智唯一刹那。无生智流注长时相续。从无生智出。或起无学正见或起世俗心。一切阿罗汉皆修无学正见圆满。而非一切皆现在前

问尽智无生智有何差别答且名即差别。谓此名尽智此名无生智。复次因是尽智。果是无生智。复次已作是尽智。因长养是无生智。复次未得而得。或已得而得是尽智。唯未得而得。是无生智。复次或解脱道或胜进道摄是尽智。唯胜进道摄是无生智。复次依之建立五阿罗汉是尽智。依之建立一阿罗汉是无生智。复次通利钝根者得是尽智。唯利根者得是无生智。是谓差别。问最初尽智是何智耶。有作是说。是苦类智。所以者何。诸瑜伽师观生死果而入圣道。观生死果圣道满故。如以毒箭射诸禽兽。其毒最初从疮门入。渐次遍身作毒事已。死时还从疮门而出。圣道亦尔。复有说者。是集类智所以者何。诸瑜伽师观生死果而入圣道观生死因圣道满故。一切生死皆果因摄。先遍知果。后遍知因。则生死道断不复相续名为苦边。评曰。应作是说。最初尽智亦是苦类智亦是集类智。若起苦类智尔时不起集类智。若起集类智尔时不起苦类智如契经说。诸阿罗汉如实自知。我生已尽。梵行已立。所作已办。不受后有。此中我生已尽者。然诸生名显多种义。谓或有生名显入母胎。或有生名显出母胎。或有生名显分位五蕴。或有生名显不相应行蕴少分或有生名显非想非非想处四蕴或有生名显入母胎者。如说云何生。谓彼彼有情。于彼彼众同分中生等。生入起出现。或有生名显出母胎者。如说菩萨初生即行七步。或有生名显分位五蕴者。如说有缘生。或有生名。显不相应行蕴少分者。如说云何生。谓诸蕴起。或有生名显非想非非想四蕴者。如此中说我生已尽。问此尽何生。过去耶未来耶现在耶若尽过去生。过去生已灭何复尽。若尽未来生。未来生未至何所尽。若尽现在生。现在生不住何须尽。答应作是说。尽三世生所以者何。此中生名既显非想非非想处四蕴。诸瑜伽师总观非想非非想处。三世四蕴离彼染故。令生因果皆不得成。大德说曰。我生已尽言。如世尊说牟尼观生尽。彼亦如此应别征问。而应答言尽未来生。以修行者受持戒禁勤修梵行。皆为遮止未来世生令不起故。譬如有人有三厄难。一者已受。二者正受。三者当受。诸已受者彼已受故不复遮止。诸正受者彼正受故不可遮止。诸当受者应以财货。或亲友力。或余方便。而遮止之。行者亦尔。诸过去生已灭故不须遮止。诸现在生正受故不可遮止。诸未来生修正加行而遮止之令永不生。故说为尽。梵行已立者。谓无漏行已立。问为学梵行已立。为无学梵行已立耶。答学梵行已立。非无学梵行。所以者何。无学梵行今始立故。所作已办者。一切烦恼皆已断故。一切所作已究竟故。一切道路已遮塞故。复次诸界趣生生老病死皆毕竟尽。故名所作已办。不受后有者。显无生智。问非一切阿罗汉皆得无生智。何故诸契经初。皆说阿罗汉不受后有耶。有作是说。佛于经中随有者说。而结集者通冠经初复有说者。结集法者皆得愿智无碍解等殊胜功德。观察世尊说诸经时。阿罗汉众若有无生智者。即亦说彼不受后有若无无生智者。即不说彼不受后有。后诵持者不善简别。故通诵在一切经初。尊者妙音作如是说。诸阿罗汉皆无后有故通说为不受后有。不说无生智为不受后有。故不相违。胁尊者曰。若诸烦恼未断未遍知者。皆不说为我生已尽。梵行已立所作已办。不受后有。若诸烦恼已断已遍知者。皆总说为我生已尽。乃至不受后有

问我生已尽乃至不受后有。一一当言是何智耶有作是说。我生已尽是尽智。梵行已立所作已办不受后有是无生智。或有说者。我生已尽梵行已立是尽智。所作已办不受后有是无生智。复有说者。我生已尽梵行已立所作已办是尽智。不受后有是无生智。问不时解脱阿罗汉。初起尽智唯一刹那无间。必起无生智。尚无二刹那尽智无间起无生智义。况有三刹那尽智后方起无生智者。如何今说我生已尽梵行已立所作已办是尽智。不受后有是无生智耶。答于一刹那尽智自性。义说为三非三刹那故不违理。胁尊者曰。此中四句不说尽智无生智。亦不说无学正见。但总赞说诸阿罗汉一切生尽梵行已立所作已办不受后有。如是四种无别自性。有说。此中我生已尽是尽智。梵行已立是道智。所作已办是灭智。不受后有是无生智。有说。此中我生已尽是集智。梵行已立是道智。所作已办是灭智。不受后有是苦智。有说。此中我生已尽是遍知集。梵行已立是遍知道。所作已办是遍知灭。不受后有是遍知苦。有说。此中我生已尽是观集。梵行已立是观道。所作已办是观灭。不受后有是观苦。有说。此中我生已尽是证集。梵行已立是证道。所作已办是证灭。不受后有是证苦。有说。此中我生已尽是断集梵行已立是修道所作已办是证灭。不受后有是知苦。有说。此中我生已尽是舍因。梵行已立是得道。所作已办是证果。不受后有是知事。有说。此中我生已尽是集无愿。梵行已立是道无愿。所作已办是灭无相。不受后有是苦无愿及空

问何故名尽智。为缘尽故名为尽智。为烦恼尽身中起故名尽智耶。设尔何失。若缘尽故名尽智者。尽智唯应缘灭圣谛。不应说此缘四圣谛。若烦恼尽身中起故名尽智者。则无生智无学正见亦应名尽智。彼亦烦恼尽身中起故。答应作是说。唯烦恼尽身中起故名为尽智。问若尔。无生智及无学正见亦应名尽智。答若烦恼尽身中初起及遍有者乃名尽智。无学正见虽皆遍有而非初起。无生智非遍有。时解脱者不成就故。亦非初起。必尽智后方现前故。有作是说。此缘尽故名为尽智。问此缘四谛岂独缘尽。答以尽胜故独摽智名。谓四谛中灭谛最胜。涅槃性故是善常故。依之建立能缘智名故名尽智

问有无漏慧离十六种圣行相不。设尔何失。若有者。识身论中何故不说。若无者品类足论当云何通。如说云何尽智谓我已知苦。已断集。已证灭。已修道。彼十六中何行相摄。复说云何无生智。谓我已知苦不复知。乃至我已修道不复修。彼十六中何行相摄。集异门论复云何通。如说我已尽欲漏有漏无明漏是尽智。彼不复当起是无生智。彼十六中何行相摄。此论见蕴复云何通。如说受乐受时如实知受乐受。此十六中何行相摄。契经所说复云何通。如说我生已尽。乃至不受后有。彼十六中何行相摄。答应作是说。离十六行相无别无漏慧。问若尔。善通识身足论。品类足论当云何通。答我已知苦不复知者。是苦四行相。已断集不复断者。是集四行相。我已证灭不复证者。是灭四行相。我已修道不复修者。是道四行相。问集异门论复云何通。答知三漏尽及不复起是六行相。谓苦非常及缘集四。问此论见蕴复云何通。答彼意不说知受乐受。但说知道即道等四行相。问契经所说当云何通。答由五种缘故作是说。一加行故。二对治故。三作事故。四相续故。五补特伽罗故。加行故者。谓瑜伽师先加行时作如是念。我当尽一切生。乃至我当不受后有。对治故者。谓瑜伽师修如是对治。令一切生尽。乃至令不受后有。作事故者。谓瑜伽师作如是事。谓尽一切生乃至不受后有。相续故者。谓瑜伽师得如是相续令一切生尽。乃至不受后有。补特伽罗故者。谓如是补特伽罗易见易施设。谓一切生尽乃至不受后有。由此五缘经作是说。我生已尽乃至不受后有。非无漏观中有如是行相。要二智后起此分别。有作是说。亦有无漏慧离十六行相。问若尔。善通品类足等。识身论中何故不说。答若诸行相现在有用能作胜事。彼论说之。若不尔者彼论不说。复次若诸行相能入圣道。得果离染尽诸漏者彼论说之。若不尔者彼论不说。复次若诸行相。加行无间解脱胜进四道皆有。彼论说之。余无漏慧行相。唯在远加行道及远胜进道可得故。彼论不说。评曰。应作是说。无无漏慧离十六圣行相

云何学明乃至广说。问何故作此论。答为欲分别契经义故。如契经说。佛告居士。如汝先以学智学见学明观四圣谛。今此耶舍童子亦以无学智无学见无学明观四圣谛。故此童子决定不复乐住居家。畜诸资产受五欲乐。契经虽作是说。而不分别其义。经是此论所依根本。彼未说者今应说之。复次世间妄执种种咒论以为真明。谓支明事明兽明禽明瞿腊毗明刹尼迦明健驮梨明星明乌明孔雀明象钩明咒龙蛇明火明水明迷乱明等。及诸外论。世间于此起真明想。为遮彼意欲显别有胜义真明故作斯论。云何学明。答学慧。谓学位无漏慧。云何学智。答学八智。谓学位四法智四类智。云何无学明。答无学慧。谓无学位诸无漏慧。云何无学智。答无学八智。谓无学位四法智四类智。问何故名明。答通达解了故名为明。问若尔。诸善有漏慧亦通达解了应亦名明。答若能通达解了亦于四圣谛决择现观者乃名为明。诸善有漏慧虽能通达解了而于四圣谛不能决择现观故不名明。如顺决择分所摄慧。虽极猛利。而于四圣谛。未能决择现观。未能毕竟真实决择现观谛故。复次若能通达解了不为无知犹豫。邪见之所杂乱断见疑已不复令起。不增诸有生老病死。非身见事。非堕苦集。不增无明。永离烦恼魑魅魍魉者乃名为明。诸善有漏慧虽能通达解了。而无余德故不名明。复次诸善有漏慧。俱涉二品。故不名明。谓与明无明俱作三缘故。如人与己怨亲交涉非定名亲。复次诸善有漏慧与谤明者俱。是苦集世间品摄故不名明。问若善有漏慧不名明者。契经所说当云何通。如说有三明。一宿住随念智证明。二死生智证明。三漏尽智证明。后一可尔前二云何。答前二亦有少分明相故假名明。谓违烦恼故。不杂烦恼故。顺胜义明故。引无漏明故。是故尊者妙音说曰。于三明中唯漏尽智是胜义明。余二能引胜义明故假立明名。复次宿住随念智证明。通达解了前际法故。死生智证明。通达解了后际法故。漏尽智证明。通达解了涅槃性故。皆说为明。复次初明知前际流转法故。第二明知后际流转法故。第三明知还灭法故。皆说为明。复次初明除前际无知故。第二明除后际无知故。第三明除涅槃无知故。皆说为明。复次初明除蕴愚故。第二明除有情愚故。第三明除法愚故。皆说为明。复次初明知诸有情前际。由如是业死彼生此因果相续。第二明知诸有情后际。由如是业死此生彼因果相续。第三明知诸有情由如是道能尽诸漏隔断因果。唯此一种是胜义明。前之二种是世俗明。复次如是三明皆能随顺厌舍生死。皆能引发殊胜功德。皆能趣向毕竟涅槃。故名为明。而实明者唯无漏慧。问何故六通中三立为明。三不立为明耶。答神境智证通如工巧处转。天耳智证通唯能取声。他心智证通唯取自相无胜用故不立为明。后之三通皆有胜用故立为明。胜用者。谓皆能随顺厌舍生死。皆能引发殊胜功德。皆能趣向毕竟涅槃。问云何后三通皆有此胜用。答第四宿住随念智证通。见前际事深生厌离。第五死生智证通。见后际事深生厌离。第六漏尽智证通。既厌离已欣乐涅槃。由此皆能随顺厌舍生死。乃至皆能趣向毕竟涅槃。复次第四通见前际自衰损事深生厌离。第五通见后际他衰损事深生厌离。第六通既厌离已欣乐涅槃。由此皆有前三胜用。复次第四通见前际种种相续诸蕴界处深生厌离。第五通见后际种种散坏诸蕴界处深生厌离。第六通既厌离已欣乐涅槃。由此皆有前三胜用。复次第四通能除常见。第五通能除断见。第六通既离二边安住中道。由此皆有前三胜用。复次第四通能引空解脱门。第五通能引无愿解脱门。第六通能引无相解脱门。由此皆有前三胜用。由如是等种种因缘。后之三通皆有胜用。故六通内偏立为明。集异门论作如是说。有三种无学明。一无学宿住随念智证明。谓知诸有情行有相续无学智。二无学死生智证明。谓知诸有情自业胜劣无学智。三无学漏尽智证明。谓知漏尽无学智。问漏尽智证明。是无学法故可说为无学智。前二明是非学非无学法。如何可说为无学智耶。答彼论应作是说。有三种无学明。又应说为无学者智。而不作是说者。应知无学身中起故。前二亦名无学。略去中间如牛车等。如施设论说。有二种三摩地。一圣二非圣。圣复有三一善有漏。二无漏。三无覆无记。此中善有漏定以善故名圣。非以无漏故名圣。若无漏定以善故及无漏故名圣。无覆无记定虽非善故无漏故名圣。而以圣者身中起故亦名为圣。此亦如是无学者身中起故亦名无学。及无学智。问前二种明学者亦有。何故唯立在无学位。答在无学位明义胜故。谓若说法胜则无学法胜非学。若说补特伽罗胜。则无学补特伽罗胜非学。复次无学者明胜不杂无明故。学者明劣杂无明故。不立为明。有四种殊胜功德。一通二明三力四示导。如来身中漏尽智具四种义。谓漏尽智证通。漏尽智证明。漏尽智力。教诫示导。独觉无学声闻。漏尽智有三种义。谓除力义余三如前。如来身中宿住随念智及死生智有三种义。谓除示导有通明力。独觉无学声闻即前二智有二种义。谓是通明非力示导。学者及异生身中。即前二智唯有通义无余三种。有作是说。时解脱阿罗汉身中漏尽智唯有二义。谓通示导。非力非明。余二智唯有一义。谓通非余。神境智他心智一切身中皆唯有二义。谓通示导。天耳智一切身中唯有一义谓通非余。问何故如来身中有智立为力。声闻独觉身中诸智皆不立为力耶。答不可屈伏无障碍义是力义。声闻独觉身中诸智。犹为无知屈伏。及有障碍故不名力。曾闻佛与尊者舍利子一处经行。有一有情来诣彼所。佛告舍利子。汝可观此有情过去曾于何处为汝亲友。时舍利子。以初静虑乃至以第四静虑。宿住随念智观之。皆不能见。便从定起而白佛言。我之定力观不能见。佛告舍利子。如是有情。曾于过去尔所劫前为汝亲友。彼时既远非诸声闻独觉境界故汝不知。佛又一时与舍利子一处经行。时有一人遇缘而死。佛告舍利子。汝应观彼当生何处。时舍利子。以初静虑。乃至以第四静虑天眼观之。皆不能见。便从定起而白佛言。我之天眼观不能见。佛告舍利子。此人命终生某世界。彼处既远非诸声闻独觉境界故汝不知。问三乘漏尽既无差别。何故漏尽智二乘非力耶。答佛漏尽智胜妙猛利。非诸声闻独觉所及。虽俱尽漏而有迟速。如有二人各伐一树。一人勇健加用利斧。一人力劣又用钝斧。虽俱伐树而有迟速。故佛漏尽智立力非二乘。又二乘智虽能尽漏。有余习故不名为力。又漏尽智立为力者。不依能尽自身漏故。但依能令他身漏尽。谓佛善达如是有情。应依苦迟通行当得漏尽。乃至如是有情。应依乐速通行当得漏尽。由此方便为说正法。皆令漏尽故立力名。二乘不尔故不名力

说一切有部发智大毗婆沙论卷第一百二阿毗达磨大毗婆沙论卷第一百三

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    智蕴第三中他心智纳息第三之五

问六通中。几是明非示导。几是示导非明。几是明亦是示导。几非明亦非示导耶。答二通是明非示导。谓宿住随念智证通。及死生智证通。二通是示导非明。谓神境智证通。及他心智证通。一通是明亦是示导。谓漏尽智证通。一通非明亦非示导。谓天耳智证通。问何故六通三是示导三非示导耶。答现希有事令他信伏。引入正法故名示导。三有此义余三不然。谓若自说我能远闻。我能远见。我能远忆诸宿住事。他皆生疑为虚为实。不即信伏。故非示导。曾闻有一居士信外道法。屈请离系亲子及彼徒众。来赴其家供以饮食。离系亲子适入其家即便微笑。居士怪问。师离掉举何为笑耶。彼遂答言。吾有妙德汝在家者岂尽知耶。于是居士殷勤问之。彼便告曰奈末陀河侧有二猕猴。共斗不已俱堕彼河为水漂溺。吾为是事愍而笑之。居士赞言。甚为希有。大师天眼清净乃尔。食时既至居士念言。我当因食验彼虚实。便以饭覆臛先授与师。以臛沃饭与彼弟子。时彼弟子受已即食师独不食。居士问言。大师何缘而独不食。彼言无臛如何食之。居士调言。奇哉天眼。乃能远见不能近观。外道师徒时深愧耻。故天眼等三非示导。自说远闻及能远忆。亦不令他即信伏故。既不信伏如何可引令入正法。是故此三皆非示导。若为示现神境智通。变一为多变多为一。乃至梵世神力自在。令多有情深心信伏引入正法故名示导。若为示现他心智通。记说彼心思念差别如所记说。皆实非虚令多有情。深心信伏引入正法故名示导。若为示现漏尽智通。随其所宜教诫教授。速令见谛远尘离垢。于诸法中生净法眼。展转乃至诸漏永尽。令多有情深心信伏。引入正法故名示导问应为何等补特伽罗现神变事。答若于佛法决定信者。及不信者不应为现。若不定者应为现之引入正法。除此更无余方便故。云何知然。如契经说。一时佛在那茶建他城侧。周匝庵罗林中。有居士子名鸡筏多。来诣佛所顶礼双足却住一面而白佛言。今此城中安隐丰乐。多诸人众深心信敬佛法僧宝。唯愿世尊留一弟子恒在此处。对诸沙门婆罗门等。时现神变示过人法。令此城中信佛法者倍增坚信。令暂往来诸不信者信受佛法。时佛告彼居士子言。我曾不令诸弟子众。对诸沙门婆罗门等。现诸神变示过人法。然我常令诸弟子众。覆藏自善发露己恶。时居士子复白佛言。若佛弟子对诸沙门婆罗门等。现神变事示过人法。有何过患而佛不许。若佛弟子覆藏自善发露己恶。有何功德而佛许之。尔时世尊告居士子。我今问汝随汝意答。若我弟子对诸沙门婆罗门等。现神变事变一为多变多为一。乃至梵世神力自在。信佛法者见此事已。向不信者说如是言。奇哉世尊诸圣弟子。能现如是甚希有事。时不信者语信者言。此何希有。世有明咒名健驮梨。善受持者亦能示现如是幻惑。谁有智者现斯鄙事。佛告居士子。于汝意云何。有不信者作如是言讥信者不。居士子曰。实有斯事。世尊复告居士子言。若我弟子记说他心思念差别。如所记说皆实非虚。信佛法者知此事已。向不信者说如是言。奇哉世尊诸圣弟子。乃有如是甚希有事。时不信者语信者言此何希有。世有明咒名刹尼迦。善受持者亦能造作如是幻惑。谁有智者作斯鄙事佛告居士子。于汝意云何。有不信者作如是言讥信者不。居士子曰。实有斯事。尔时世尊告居士子。若我弟子对诸沙门婆罗门等。现神变事示过人法。有是过患故我不许。若我弟子覆藏自善发露己恶。顺贤圣法世所称誉。有斯功德故我许之。由此故知决定信者及不信者。不应为现诸神变事。若不定者应为现之。方便引令入佛正法

此契经中佛为居士子说三种示导。一神变示导。二记心示导。三教诫示导。问何故名示导。答示谓示现。导谓导引。现希有事引入正法故名示导。如守门者立示导名。谓守门者示现内事导引外人。示现外事导引内人。示现内事导引外人者。谓彼侯王若不澡浴寝食观宝即便引现。示现外事导引内人者。谓彼伺外贡献珍奇殊方信物引内人受。如是示现佛正法中微妙功德。方便导引所化有情。令其趣入故名示导此契经中复说。菩萨初中后夜各起通明。起通明已明星出时。证得无上正等菩提。问何缘菩萨初中后夜各起通明。答过殑伽沙后身菩萨。将证大觉法应尔故。复次初中后夜各起通明。欲令自身成法器故。复次欲现神变了达事故。通能现神变。明能了达事。故起通明。复次欲现安足远作事故。通现安足。明远作事。故起通明。复次如无间道解脱道故。通如无间道。明如解脱道。故起通明。复次如见道修道故。通如见道。明如修道。故起通明。复次欲显善有漏无覆无记。有漏无漏及无漏法现前有用。故起通明。善有漏法者。谓神境智证通。及宿住随念智证通明。无覆无记法者。谓天眼智证及天耳智证二通。有漏无漏法者。谓他心智证通。无漏法者。谓漏尽智证通明。复次为欲次第降伏魔怨。初中后夜各起通明。曾闻菩萨知修苦行非真道已。遂受难陀难陀跋罗姊妹所奉具十六德香蜜乳糜。食已身心安隐有力。从吉祥人边受吉祥草。诣菩提树下手自敷设。如婆苏吉龙王盘身结加趺坐。坐已便发坚固誓言。我若于此不尽诸漏证得无上正等菩提誓当不起。尔时大地大海诸山六种震动。如海轻船逐浪高下。乃至他化自在天宫皆悉震动。犹如猛风吹芭蕉叶。魔王惊慑观动所因。遂见菩萨坐菩提树。端身不动誓取菩提。速出自宫往菩萨所。谓菩萨曰。刹帝利子可起此座。今浊恶时众生刚强。定不能证无上菩提。且应现受转轮王位。我以七宝当相奉献。菩萨告曰。汝今所言如诱童子。日月辰星可令坠落。山林大地可升虚空。欲令我今不取大觉起此座者定无是处。尔时魔王告菩萨曰。汝若不用我软美语。须臾令汝见大怖事。作是语已雨花还宫遍告六天。汝等速办弓弩刀剑斗轮罥索矛槊戟等诸斗战具。我有大怨在菩提树。当与汝等速往伐之。菩萨尔时作如是念。与凡夫斗尚不可轻。况他化天大自在主。念已速修离欲染道。离欲界染起初静虑神境智通。化作种种对敌胜具。魔军若作鸟形来者。我应化作猫狸形敌。魔军若作猫狸形者。我应化作狗狼形敌。魔军若作狗狼形者。我应化作豺豹形敌。魔军若作豺豹形者。我应化作虎形敌之。魔军若作虎形来者。我应化作师子敌之。魔军若作师子形者。我应化作龙麟敌之。魔军若作龙麟来者。我应化作猛火敌之。魔军若作猛火来者。我应化作暴雨敌之。魔军若作暴雨来者。我应化作大盖敌之。如是敌类有无量种。复化坚固吠琉璃台。身虽处中而能远见座前地下。化作能发雷吼大种。作是化已复自念言。勿我前生障他修善。遂起宿住随念智明。自见前生曾不障碍诸修善者。乃以种种诸修善具而资助之。又自思惟。勿我善业劣彼魔善。思已便见魔王前生。唯曾设一无遮施会。于彼会中有一独觉。由斯善业今得生天。自见前生设无遮会。百千万亿其数难知。于诸会中佛独觉等百千万亿数亦难知。复自思惟。我布施福尚不与彼而共格量。况戒定等无量善业彼皆绝分。作是念已。端身正意俨然而坐。于后魔王将三十六俱胝魔军。各现种种可畏形相。执持战具色类无边。遍三十六踰缮那量。俱时奔趣菩提树下。尔时菩萨告魔王言。汝昔但设一大施会神用尚然。我于往昔设无遮会。百千万亿其数难知。况余功德汝皆绝分。何缘来此欲相恼耶。时恶魔王谓菩萨曰。我之功德以汝为证。汝之功德谁复证耶。菩萨遂伸相好严手击座前地。时彼地下雷吼六种震大音声。魔军既闻惊骇退散。知己非敌各自还宫。菩萨所成业生眼耳但极闻见一踰缮那魔军既远。欲闻其声有何评论。遂起天耳既闻声已。欲观彼色为何所作。复起天眼既见色已。欲知其心当何思念。起他心通知帝释天众心生庆喜。魔王眷属心生嫉恼。菩萨于是复审思惟。魔党何缘起斯恶事。知起恶事皆缘五欲。耽着五欲皆由烦恼。既厌烦恼遂尽诸漏。证得无上正等菩提。故欲次第降伏魔怨。初中后夜各起通明

谛现观时于何最初而得证净。佛耶法耶僧耶。问何故作此论。答为止他宗显正理故。谓或有说。于四圣谛一时现观如分别论者。问彼何故作是说。答彼依契经。如世尊说。若于苦谛无有疑惑。于集灭道谛亦无有疑惑。既于四谛顿无疑惑。故知现观定顿非渐。为遮彼意显现观时。于四圣谛定渐非顿。若不尔者便违契经。如契经说。给孤独长者来诣佛所。顶礼佛足白佛言。世尊。诸瑜伽师。于四圣谛为顿现观为渐现观。佛告居士。诸瑜伽师。于四圣谛定渐现观。如渐登上四桄梯法。问若于四谛渐现观者。云何释通分别论者所引契经。答彼所引经应作是说。若于道谛无有疑惑。于苦集灭谛亦无有疑惑。而不作是说者应知有别意趣。谓彼经说已得果者。若于苦谛无有疑惑。于余三谛亦无疑惑。迷四谛疑皆已断故。尊者世友作如是说。彼经意说。疑不现行。谓瑜伽师。若于苦谛已入现观无有疑惑。于余三谛所有疑惑得虽未断而永不行。于彼已得非择灭故。大德说曰。若初得入正性离生。于诸谛宝皆名现信。问彼大德亦说于四圣谛得现观时渐而非顿。今何故作是说。答彼说若住苦法忍时。若于四谛不皆得信必无住义。如持泥器至重阁上投之于地。未至地顷器虽未破必当破故亦得破名。此亦如是。是故为止他宗所说及显正理故作斯论

此中佛者。谓佛身中诸无学法。缘彼无漏信名佛证净。此中法者。谓独觉身中三无漏根等学无学法。菩萨身中二无漏根等诸学法。及苦集灭三谛缘彼无漏信名法证净。此中僧者。谓声闻身中学无学法。缘彼无漏信名僧证净。诸无漏戒名戒证净。自性净故依证起故亦名证净

若苦集灭现观时于法最初得证净。道现观时于佛法僧最初得证净。此中苦现观时于法最初得证净者。谓即于苦法得无漏信。胁尊者言。尔时于苦信有过患。亦于苦灭信有胜利。谓此苦灭极为净妙。如是下贱鄙秽苦灭甚为快哉。集现观时于法最初得证净者。谓即于集法得无漏信。胁尊者言。尔时于集信有过患。亦于集灭信有胜利。谓此集灭极为净妙。如是下贱鄙秽集灭甚为快哉。灭现观时于法最初得证净者。谓即于灭法得无漏信。信灭胜利极为净妙。谓有漏法毕竟寂灭甚为快哉。问于三圣谛得现观时。一一皆得二种证净。谓信与戒何故此中唯说得信。答应说得二而不说者。应知此中是有余说。复次此中非但问谁得几证净。而问谁得几缘何宝证净。戒无所缘虽得不说。有作是说。于法最初得证净者。不说唯得缘法证净。但说于法而得证净。信戒俱因法宝得故。皆得名法证净。道现观时于佛法僧最初得证净者。外国诸师作如是说。道现观时。三刹那顷即现在信及随转戒。应知具有四证净义。谓即此信缘佛身中无学法故名佛证净此信复缘独觉身中学无学法。菩萨身中诸学法故名法证净。此信复缘声闻身中无漏法故名僧证净。此随转戒名戒证净。评曰彼不应作是说。时现在信总缘三乘无漏法故。唯是杂缘法证净摄。然即此信现在前时。亦修未来多刹那信。于此无量刹那信中。若有唯缘佛无学法名佛证净。若有唯缘独觉菩萨无漏法者。是不杂缘法证净摄。若有唯缘声闻身中学无学法名僧证净。若有杂缘佛及独觉菩萨身中无漏法者。若有杂缘佛及声闻无漏法者。若有杂缘独觉菩萨声闻身中无漏法者。若有杂缘佛及独觉菩萨声闻无漏法者。皆是杂缘法证净摄。现在未来信随转戒是戒证净。如见道位道现观时三刹那顷。道类智时应知亦尔。有差别者。三刹那时。唯修缘道诸信及戒。道类智时。修缘四谛诸信及戒

问灭道二谛是清净事是可信处。现观此时可得证净。苦集二谛是杂染事非可信处。是诸烦恼颠倒恶行所依止故。现观彼时如何亦得证净。答由二缘故而得证净。一由可信。二由可求。于灭道谛具由二缘而得证净。于苦集谛但由一缘而得证净。谓是可信而非可求。如人掘凿有宝等处。彼于是处有信有求。若人掘凿无宝等处。彼于是处有信无求。是处虽无宝水等物。然有所为而掘凿之。此亦如是故无有失。尊者妙音作如是说。诸瑜伽师。先见苦集有过患故。后于灭道见有胜利。谓此灭道极为净妙。永息能除如是秽恶苦集谛故。由此行者于苦集谛虽无所求亦得证净。胁尊者曰。诸瑜伽师。为苦集谛之所逼恼。故于灭道见有胜利。譬如有人风雨所逼。便见室盖是可归依。故于苦集虽无所求亦得证净

诸瑜伽师。皆于灭谛由二缘故而得证净。一由可信。二由可求。非于道谛皆由二缘而得证净。谓随信行者于随信行。随法行道俱由二缘而得证净。随法行者于随法行道。具由二缘而得证净。于随信行道但由一缘而得证净。谓是可信非所求故。信胜解者。于信胜解及见至道。俱由二缘而得证净。若见至者。于见至道具由二缘而得证净。于信胜解道但由一缘而得证净。谓是可信非所求故。时解脱者。于时解脱及不时解脱道。俱由二缘而得证净。不时解脱者。于不时解脱道。具由二缘而得证净。于时解脱道。但由一缘而得证净。谓是可信非所求故。声闻乘者。于三乘道皆由二缘而得证净。独觉乘者。于自上乘道俱由二缘而得证净于声闻乘道。但由一缘而得证净。谓是可信非所求故。诸佛乘者。于佛乘道具由二缘而得证净。于二乘道但由一缘而得证净。谓是可信非所求故

问若缘舍利子身中无学法起无漏信。为是法证净。为是僧证净耶。设尔何失。若是法证净者彼缘声闻无学法起如何名法证净。若是僧证净者。云何独一补特伽罗而得名众。答应作是说。是僧证净。问彼既独一如何名僧。答彼舍利子声闻乘中最尊胜故。虽是独一补特伽罗而僧证净。依法建立非数取趣。缘声闻乘无学法起无漏信故。非无漏信缘假有情

若依未至定未曾得佛证净现在前时。现在修二证净。未来修四证净。曾得佛证净现在前时。现在修二证净。未来无。乃至依第四静虑应知亦尔。若依无色定未曾得佛证净现在前时。现在修一证净。未来修四证净。曾得佛证净现在前时。现在修一证净。未来无。如佛证净。应知余三证净亦尔。有差别者。无色定中无戒证净

问云何建立四证净耶。为以自体。为以所缘。若以自体唯应有二。谓信及戒。若以所缘唯应有三。谓佛法僧证净。戒无所缘故。答应作是说。亦以自体。亦以所缘。而建立四证净。谓以自体建立戒证净。戒无所缘故以所缘建立余三证净。信缘三宝故如以自体以所缘建立。以自体以三宝以自体以随念建立应知亦尔。是名证净自性我物自体相分本性。已说自性所以今当说。问何故名证净。证净是何义。答净谓信戒离垢秽故。于四圣谛别别观察。别别筹量。别别觉证。而得此净故名证净。胁尊者曰。此应名不坏。净言不坏者。不为不信及诸恶戒所破坏故。净谓清净信是心之清净相故。戒是大种清净相故。尊者世友作如是说。此应名不断净。谓得此已无有沙门婆罗门等力能引夺令断坏故。如契经说。是名见为根信证智相应。世间沙门婆罗门等不能引夺令其断坏。大德说曰。若于佛法不能观察筹量觉证。所得信戒易可动转如水上船。若于佛法能审观察筹量觉证。所得信戒不可动转犹如帝幢故。此正应名不动净。尊者妙音作如是说。如是四种应名见净见四圣谛。得此净故或应名慧净圣慧俱转故

问何故世尊先说佛证净。乃至后说戒证净耶。答若作是说。随顺文词次第法故。复次随顺说者受者持者次第法故复次佛是能说故应先。信法是所说故应次。信僧是所为故应次。信戒是僧所住故最后说。复次佛如良医故应先。信法如无病故应次。信僧如看病者故应次。信戒如妙药故最后说。复次佛如商主能示道路故应先。信法如宝渚是正所趣故应次。信僧如商侣能为助伴故应次。信戒如资粮能正任持故最后说。复次佛如船师故应先。信法如彼岸故应次。信僧如同载故应次。信戒如船筏故最后说。由此等缘此四证净如是次第。如契经说。圣所爱戒不破不穿不杂不秽。圣所受用非凡所取。智者所赞能善究竟能善引发。问何故名为圣所爱戒。答是诸功德所依处故。谓诸圣者爱乐功德故爱此戒。如人爱宝亦爱宝器。如是圣者爱乐清净菩提分法功德宝故。亦爱如是所依戒器复次圣者憎恶诸破戒恶戒。能对治破戒恶故圣者爱之。复次圣者憎恶诸崄恶趣戒。能超越崄恶趣故圣者爱之。复次圣者憎恶生死流转戒能超越生死流转故圣者爱之。复次圣者爱涅槃。戒能趣涅槃故圣者爱之。如契经说。戒能展转趣向涅槃。圣者爱乐。问不破不穿不杂不秽。如是四句有何差别。有说无别。如是四种。声虽有异义无别故。如集异门论说。于此诸戒恒作恒转。劝作劝转。亦名不破。亦名不穿。亦名不杂。亦名不秽。故知此四声异义同。有说此四亦有差别。谓名即差别。此名不破此名不穿此名不杂此名不秽。复次于初犯聚不违越故名不破。于第二犯聚不违越故名不穿。于第三第四犯聚不违越故名不杂。于第五犯聚不违越故名不秽。复次不违越故名不破。不依贪故名不穿。不依嗔故名不杂。不依痴故名不秽。复次不违越故名不破。依无贪故名不穿。依无嗔故名不杂。依无痴故名不秽。复次不违越故名不破。依奢摩他故名不穿。依毗钵舍那故名不杂。能断烦恼故名不秽。复次不违越故名不破。不为恶寻所损坏故名不穿。自体坚住故名不杂。极清净故名不秽。复次自性坚强故名不破。远离非所行故名不穿。非犯戒恶所间杂故名不杂。不舍善意乐故名不秽。此中复说。圣所受用者。是诸功德所依止故。非凡所取者。非诸异生执此净戒为真道故。智者所赞者。佛及弟子所称誉故。能善究竟者。俱时圆满故。能善引发者。能招爱果故

如契经说。有大龙象以信为手。以舍为牙。以慧为头。以念为颈。于其两肩担集善法。问何故世尊说信为手。答取善法故。如象有手能取有情无情数物。如是圣者有信手故。能取种种微妙善法。是故世尊说信为手

如契经说。苾刍当知。天中时时有四声起。云何为四。谓若此间有圣弟子成就多住佛证净者。尔时成就佛证净。天欢喜踊跃高声唱言。我先成就佛证净故而来生此。今圣弟子成就多住佛证净故。亦当生我众同分中。与我为伴甚为快哉。成就多住余三证净广说亦尔。问此圣弟子及彼诸天。皆具成就四种证净。何故说有成就多住身证净者。乃至说有成就多住戒证净者。答依修加行入法时说。谓或有行者求佛证净。勤修加行而入圣道。乃至或有行者。求戒证净勤修加行。而入圣道故作是说。复次依多爱乐作意而说。谓或有行者多分爱乐缘佛作意。乃至或有行者多分爱乐。缘戒作意故作是说

如契经说。佛告苾刍。若有信乐汝所说者。汝当哀愍方便为说四种证净。劝令安住以自调伏。所以者何。诸四大种可令变异。成就如是四证净者终无变异。问世尊何故说此契经。答示说法师说法仪故。谓有说者。不知受者是器非器。轻尔为说令彼受者。或生轻慢或生怯怖空无所得。故世尊说。若有信乐汝所说者。汝当哀愍方便为说。勿得轻尔。复次示报恩者真报恩故。如余经说。苾刍当知。若有孝子一肩担父。一肩担母。经于百年处处游历。犹非真实报父母恩。若有孝子能劝父母。于佛法僧因果等法。未信者信信者增长。无净戒者劝受持戒。有悭贪者劝行惠施。无胜慧者劝修胜慧。令善安住以自调伏。乃名真实报父母恩。故此经中教为说法。问诸佛法中有无量种功德法宝。皆应为他方便宣说。何故于此独令为说四证净耶。答应知此中证净为首。总令为说诸功德宝。胁尊者曰。此中世尊。以证净声说诸圣道。谓诸圣道或是相应。或是俱有。若说信应知总说相应圣道。若说戒应知总说俱有圣道。复次此中略显初入法门。谓佛法中诸功德宝。或是色法或非色法。若说戒应知总说是色法宝。若说信应知总说非色法。宝。如色非色如是相应不相应有所依无所依。有所缘无所缘。有行相无行相。有警觉无警觉。是根非根等应知亦尔。复次此四证净有不坏相及清净相故偏说之。复次依四证净所引等流。设施殊胜四沙门果故偏说之。复次此四证净能止恶趣及贫穷怖故偏说之。以戒能止恶趣怖。信能止贫穷怖故。虽无漏信戒不招异熟果。而无漏信戒必与有漏信戒互相引发故。能遮止二种怖畏。复次为欲方便导引可化外道有情入佛法故。谓诸苾刍或有亲属。先为外道以亲爱故来相慰问。时诸苾刍不护彼意。赞叹佛法毁訾外道。令彼嗔恨转远佛法。故世尊说汝等苾刍。无力无畏大悲等德。不知有情根欲性行。不应轻尔为他说法。若有信乐汝所说者。汝当哀愍方便为说四种证净。劝令安住以自调伏。所以者何。诸四大种可令变异。成就如是四证净者终无变异。问一切法性皆无变异。何故唯说四大种耶。答欲以四法显四法故。复次诸瑜伽师。先观大种无变异相。后观诸法性不变异。心便欢悦故偏说之。复次以四大种能持一切情非情法故偏说之。复次以四大种能持一切生死流转故偏说之。复次以四大种能持五蕴令不断绝故偏说之。复次诸外道说大种有五其性常住。为对彼故佛说唯四而是无常。假使大种汝执为常可令变异。得证净者终无变异

如契经说。未生怨王能成就无根信。问诸有为法。无不有根。何故说彼信无根耶。答此信无有见道根故。如契经说。是名见为根信证智相应。谓未生怨所成就信不依见道故名无根。然彼信心坚固难坏。如依见道。复次未生怨王所成就信不可改易。如无漏信而无有根。诸无漏信依无漏根。以无漏智无漏善根为根本故。复次此信无有同类因故说名无根。谓无始来未得如是坚强信故。譬如有树依他茎生自既无根名无根树。复次未生怨王所成就信。自性坚固不由亲近佛及弟子。乃能发生故名无根。由此信力若乘象马若在高楼。遥见世尊即便投下顶礼双足。由坚信力或佛威神无所伤损。复次未生怨王所成就信未免恶趣故名无根。彼后命终暂堕地狱受少苦已方生天故

说一切有部发智大毗婆沙论卷第一百三阿毗达磨大毗婆沙论卷第一百四

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    智蕴第三中他心智纳息第三之六

诸预流者。于四颠倒几已断。几未断耶。答一切已断。问何故作此论。答为止他宗显正理故。谓或说有十二颠倒。八唯见所断。四通修所断。如分别论者。问彼依何量作如是说。答依契经故。谓契经说。于无常起常想颠倒心颠倒见颠倒。于苦起乐。于无我起我。于不净起净想颠倒心颠倒见颠倒。由此故知一切颠倒有十二种。于中八种唯见所断。谓常我中各取三种乐。净中各唯取见颠倒。四种通修所断。谓乐净中各取想心二颠倒。此中见所断者。苦类智忍现在前时方毕竟断。修所断者。金刚喻定现在前时方毕竟断。为止彼意显诸颠倒唯有四种唯见所断故作斯论。谓此问言诸预流者于四颠倒几已断几未断。即止颠倒有十二种。此复答言一切已断即止颠倒通修所断无修所断法预流已断故。又若颠倒有十二种通修所断便违契经。如契经说。佛告苾刍。若四颠倒所颠倒者。当知彼是愚夫异生。此经既说有四颠倒。应知颠倒非十二种。既说颠倒所颠倒者。当知彼是愚夫异生。应知颠倒非修所断。问若诸颠倒唯有四种。分别论者所引契经当云何通。答想心二种实非颠倒。亲近颠倒故。颠倒相应故。亦名颠倒。问若尔受等诸心所法亦应名颠倒。彼与心想义相似故。答世间但于心想二种说颠倒名。非受思等是故但说心想颠倒。佛随世俗而说法故

问此四颠倒自性是何。答见为自性。问若尔五见中几见为自性。答此以见苦所断二见半为自性。谓有身见见取全。及边执见中常见。二见半非颠倒自性。谓邪见戒禁取全。及边执见中断见。有作是说。此四颠倒于五见中三见各一分以为自性。谓有身见中我见是我颠倒自性非我所见。边执见中常见是常颠倒自性非断见。见取中见苦所断执乐净见是乐净颠倒自性非余见取。问何故唯此是颠倒耶。答以三事故建立颠倒一推度性故。二妄增益故。三一向倒故。邪见断见虽是推度性及一向倒。而非妄增益坏事转故。戒禁取虽是推度性及妄增益。而非一向倒。亦于少分实处转故。谓有色界道能净欲界有。无色界道能净色界有。上地道能净下地。与无漏道断染证灭义相似故。如是名为颠倒自性我物自体相分本性

已说自性所以今当说。问何故名颠倒。颠倒是何义。答于粗谛理颠倒而转故名颠倒。由此四颠倒唯见苦所断。问何故四颠倒唯见苦所断。答由此唯于苦处转故。见苦谛时此便永断。复次由此唯于果处转故。若见果时此便永断。复次此四颠倒有是有身见。有依有身见有身见断时。余亦随断对治同故。由此四颠倒唯见苦所断。复次苦谛粗显于中迷谬过失极重。贤圣所诃故立颠倒。三谛微隐于中迷谬过非极重。不甚被诃不立颠倒。如人昼日平地颠蹶。世共诃笑非夜崄处。复次诸瑜伽师现观苦已心无颠倒。故见苦时颠倒皆断。设见苦已未见余三。便出观者若有问言。此五取蕴为常无常。彼便定答皆是无常。一刹那后必不住故。复若问言此五取蕴为乐为苦。彼便定答一切是苦如热铁丸。复若问言此五取蕴为净不净。彼便定答皆是不净如粪秽聚。复若问言此五取蕴有我无我。彼便定答皆无有我。定无作者。无遣作者。亦无受者。无遣受者。唯空行聚。故四颠倒唯见苦所断。苦类智时一切已断故

问若尔亦有随信随法行者。已断此四颠倒。此中何故不说。而但说言诸预流者一切已断耶。答应说而不说者当知此义有余。复次随信随法行者有差别相有已断尽。谓苦类智已生。有未断尽。谓苦类智未生。是故不说。诸预流者无差别相。皆已断故此中说之。复次欲令疑者得决定故偏说预流。谓预流者。犹畜妻子处妙卧具。摩执女人着妙衣服。涂饰香花驱役僮仆。捶打缚录诸有情类。同诸异生有见生疑未断颠倒。是故说彼已断颠倒。一来准此故不别说。诸随信行随法行者。有漏善心尚不现起。况起染污无覆无记。于彼无疑是故不说

问预流一来。于五欲境起染爱时。为起乐净想。为起苦不净想耶。设尔何失。若起乐净想者如何非颠倒。若起苦不净想者。如何于境起染爱耶答应作是说。起乐净想。问若尔何故非颠倒耶。答先作是说。由三事故建立颠倒。预流一来于境所起乐及净想。虽是妄增益。而非推度性。非见性故。亦非一向颠倒。有少实事故。复次于谛理所起乐净想者是颠倒摄预流一来皆已断尽。于境事所起乐净想者非颠倒摄。预流一来犹未断尽容有现前。有作是说。预流一来于五欲境起染爱时。于彼唯起苦不净想。问若尔何故起染爱耶。答彼虽于境知苦不净。而无始来串习烦恼。烧然身心热痛所逼。不觉于境而起染爱。如有乐净婆罗门子。其指有时遇触不净。诣锻师所求火净之。锻师语言。幸有灰等洗以清水足可使净。何能忍苦求火锻之。婆罗门言。灰水等洗不能令净。要当为我以火净之。于是锻师以热铁钳而钳其指。时婆罗门热苦所逼。不觉振手内指口中。彼虽审知指为不净。苦逼不觉内置口中。预流一来染爱亦尔。复次彼虽于境知苦不净。而无始来串习烦恼。烧然身心热痛所逼。为止息故于境染爱。如软弱者身患痈疮苦痛难忍。医语之言。汝可当以湿狗粪涂苦痛可息。其人闻已速取涂之。彼虽审知狗粪不净。为止苦故而取涂之。预流一来染爱亦尔。故彼虽起苦不净想。而于五欲起染爱事。诸预流者。于空无愿无相三三摩地。成就过去几未来几现在几。问何故作此论。答为止他宗显正理故。谓或有说。过去未来无实自性。或复有说。无实成就不成就性为遮彼意欲显实有过去未来成就性等故作斯论。答未来一切。过去若已灭不失。现在若现在前。此中未来一切者具成就三。过去若已灭不失者。随一二三已灭非练根故。失则成就过去尔所。现在若现在前者。若随一现在前则成就现在一。且道类智初刹那时不成就过去。无一刹那已生灭故。已生灭者得果舍故。成就未来三具得修故。成就现在一。谓道无愿此灭已不失。若空现在前彼成就过去一。谓无愿。未来三现在一。谓空此灭已不失。若无相现在前彼成就过去二。谓空无愿未来三现在一。谓无相。此灭已不失。若三三摩地随一现在前。彼成就过去未来三现在一。谓现在前者

有三三摩地。谓空无愿无相。然三摩地。或应说一。谓心所中大地法内名三摩地。又五根中名定根。五力中名定力。七觉支中名定觉支。八道支中名正定。或应说二。谓有漏无漏三摩地。或系缚解脱。或系不系三摩地。或应说三谓此所说。或应说四谓三界系及不系。或应说五谓三界系及学无学。广说乃至。若以相续刹那分别。则有无量三摩地。问若尔世尊何故增一减无量等。建立三种三摩地耶。答由三缘故唯建立三。一对治故。二期心故。三所缘故。对治故者。谓空三摩地是有身见近对治故。问空三摩地有空非我二行相。有身见有我我所二行相。此中以何等行相。对治何等行相耶。答以非我行相对治我行相。以空行相对治我所行相。复次以非我行相对治五我见行相。以空行相对治十五我所见行相。如对治我见我所见行相。如是对治己见己所见行相。是我属我行相。是己属己行相。应知亦尔。复次以非我行相对治我爱。以空行相对治我所爱。如对治我爱我所爱。如是对治己爱己所爱。我痴我所痴己痴己所痴等应知亦尔。复次以非我行相对治执蕴是我行相。以空行相对治执蕴中有我行相。如对治执蕴是我执蕴中有我行相。如是对治执处是我。执处中有我执界。是我执界中有我。若总若别行相应知亦尔。期心故者。谓无愿三摩地诸修行者期心。不愿三有法故。问彼于圣道亦不愿耶。答虽于圣道非全不愿。而彼期心不愿三有圣道。依有故亦不愿。又彼期心不愿五蕴圣道。是蕴故亦不愿。又彼期心不愿三世圣道。堕世故亦不愿。又彼期心不愿众苦圣道。与苦展转相续故亦不愿。问若尔何故修圣道耶。答为趣涅槃故修圣道。谓修行者作是思惟。究竟涅槃由何趣证。思已定知必由圣道。故虽不愿而要修之。如越瀑流要凭船筏。所缘故者。谓无相三摩地此定所缘离十相故。谓离色声香味触及女男三有为相。复次蕴名为相。此定所缘离诸蕴相故名无相。复次世名为相。前后名相上中下等名相。此定所缘离世等相故名无相。有作是说。三三摩地皆由对治差别建立。谓空三摩地。近对治有身见。无愿三摩地。近对治戒禁取。无相三摩地。近对治疑。由此为先对治一切。复有说者。三三摩地皆依行相差别建立。谓空三摩地。有空非我二行相。无愿三摩地。有苦非常。及集道各四行相。无相三摩地。有灭四行相。故三摩地唯建立三。施设论中初作是说。空三摩地是空。非无愿无相。无愿三摩地是无愿非空无相。无相三摩地是无相非空无愿。所以者何。由此三种行相别故。即彼论中次作是说。空三摩地是空亦无愿非无相。无愿三摩地是无愿亦空非无相。无相三摩地唯是无相非空无愿。问何故空无愿展转相。亦而无相独立耶。答依初得时有同异故。谓若依空三摩地入正性离生。苦现观四心顷亦修无愿。若依无愿三摩地入正性离生。苦现观四心顷亦修空故。空无愿展转相亦初得无相修自非余。复次依初对治有同异故。谓空无愿初对治时。俱能对治见苦所断烦恼等故。无相初对治时。独能对治见灭所断烦恼等故。即彼论中复作是说。空三摩地是空亦无愿无相。无愿三摩地是无愿亦空无相。无相三摩地是无相亦空无愿。问此三何故一一具三。答一一自体有三义故。谓此一一非常非恒非不变易。非我我所故皆名空。不愿生长贪嗔痴等及后有故皆名无愿。离色声香味触女男七种相。故皆名无相。是名三三摩地自性我物自体相分本性。已说自性所以今当说。问何故名三摩地。三摩地是何义耶。答由三缘故名三摩地。一平等故。二摄持故。三相似相续故。平等故者。谓无始来烦恼恶行邪见颠倒。令心心所偏曲而转。由此定力令心心所于境正直平等而转。故名三摩地。摄持故者。谓无始来心心所法于境驰散。由此定力方便摄持令住一境。故名三摩地。相似相续故者。谓无始来心心所法善染无记异类相续。由此定力前后一类唯善相续。故名三摩地。复次由三缘故名三摩地。谓住一境故。相续住故。正审虑故。复次由三缘故名三摩地。谓能持身令平等故。摄诸善法。令不散故。能令善心平等转故。复次由三缘。故名三摩地。谓于所缘恒不舍故。任持种种胜善法故。令奢摩他毗钵舍那住一所缘平等转故。尊者世友作如是说。何故名三摩地。摄持多种善心心所。令于一境平等相续故名等持。复作是说。能持平等故名等持。如能持婴儿故名持。婴儿者能持水故名持水者。能持枰故名持枰者。此亦如是。能持种种胜平等法故名等持。大德说曰。即此等持亦名等至。此复多种。谓善法等至。不善法等至。无记法等至。九次第等至。两两交会亦名等至。于此义中。唯说能持善心心所。令其相续平等而转故名等持。不善无记等非此所说

三三摩地界者。若有漏是三界。若无漏是不系地者。若有漏在十一地。若无漏在九地。所依者依三界相续。行相者空三摩地有二行相。无愿三摩地有十行相。无相三摩地有四行相。问诸空三摩地皆作空行相转耶。答应作四句。有空三摩地非作空行相转。谓空三摩地作非我行相转。有作空行相转非空三摩地。谓空行相转空三摩地相应诸法。有空三摩地亦作空行相转。谓空行相转空三摩地。有非空三摩地亦非作空行相转。谓若唯说此种类者。即非我行相转空三摩地相应诸法。若不唯说此种类者即除前相。如转作四句。已转当转应知亦尔。如空行相作三四句。非我行相应知亦尔。如是空三摩地有六四句。无愿三摩地有三十四句。无相三摩地有十二四句。如是三三摩地合有四十八四句。所缘者。空三摩地若有漏缘一切法。若无漏唯缘苦谛。无愿三摩地缘三谛除灭谛。无相三摩地唯缘灭谛。念住者。空无愿三摩地各四念住俱。无相三摩地唯法念住俱。智者空三摩地四智俱。谓法类苦世俗智。无愿三摩地七智俱。除灭智。无相三摩地四智俱。谓法类灭世俗智。三摩地者即三摩地。根相应者。三根相应。谓乐喜舍。三世者。是三世。缘三世者。空三摩地若有漏缘三世及离世。若无漏及无愿三摩地缘三世。无相三摩地缘离世。善不善无记者。皆是善。缘善不善无记者。空无愿三摩地缘三种。无相三摩地唯缘善。三界系不系者。若有漏是三界系。若无漏是不系。缘三界系不系者。空三摩地若有漏缘三界系及不系。若无漏唯缘三界系。无愿三摩地缘三界系及不系。无相三摩地唯缘不系。学无学非学非无学者。皆通三种。缘学无学非学非无学者。空三摩地若有漏缘三种。若无漏唯缘非学非无学。无愿三摩地缘三种。无相三摩地唯缘非学非无学。见修所断不断者。若有漏皆修所断。若无漏皆不断。缘见修所断不断者。空三摩地若有漏缘三种。若无漏唯缘见修所断。无愿三摩地缘三种无相三摩地唯缘不断。缘名缘义者。空无愿三摩地通缘名义。无相三摩地唯缘义。缘自相续他相续非相续者。空三摩地若有漏缘三种。若无漏及无愿三摩地唯缘自他相续。无相三摩地唯缘非相续。加行得离染得者。皆通二种。曾得未曾得者。皆通二种

此三三摩地亦名三解脱门。问三摩地与解脱门有何差别。答三摩地通有漏无漏。解脱门唯无漏。问何故解脱门唯无漏耶。答有漏有缚为解脱门不应理故。问依何义立解脱门耶。为依入正性离生。为依尽漏。设尔何失。若依入正性离生立解脱门者。则应唯苦法智忍相应定名解脱门。若依尽漏立解脱门者。则应唯金刚喻定名解脱门。答应作是说。俱依二义立解脱门。然解脱门总摄一切无漏定。谓一切圣道皆名正性离生。得一切圣道时皆名为入。断诸漏时皆名尽漏。四道俱定皆有尽义。如世第一法无间。苦法智忍现在前时。得空三摩地名入正性离生。苦现观无间。集现观现在前时。得无愿三摩地。亦名入正性离生。集现观无间。灭现观现在前时。得无相三摩地。亦名入正性离生。余位无间起无漏定时应知亦尔。见道位中别起无漏三三摩地别尽诸漏。修道位中总起无漏三三摩地总尽诸漏。无学位中总起无漏三三摩地。总遮诸漏。亦名尽漏。是故三解脱门总摄诸无漏定。问何故名解脱门。答涅槃名解脱。依此三三摩地。能趣证解脱故名解脱门。复次如排楯故名解脱门。如斗战时先以排楯防捍怨敌。后以利剑断怨家头。令堕战场随意所趣。如是行者。与烦恼怨敌。共斗战时。先以三解脱门排楯。防捍烦恼怨敌。后以无漏慧剑断烦恼成就性头。令堕不成就性地。如本所愿趣向涅槃。如契经说。定是正道。不定是邪道。定心得解脱非不定心。是故无漏三三摩地是解脱门非有漏定。施设论说空有多种。谓内空。外空。内外空。有为空。无为空。无边际空。本性空。无所行空。胜义空。空空。如是十种空如余处分别。问何缘诸处多分别空。答以空行相。是二十种萨迦耶见近对治故。彼二十种萨迦耶见能为一切烦恼根本。流注生死不趣涅槃过患增上故。多说彼近对治法。如契经说。若圣弟子。三等持鬘具足成就。能断一切恶不善法。修习善法速得圆满。问何故等持说名为鬘。答性端严故。可爱乐故。如少壮者首冠花鬘形貌端严众所爱乐。如是圣者冠等持鬘。功德端严天人敬爱。又如人首若冠花鬘。不为猛风飘乱其发。如是圣者冠等持鬘。诸胜功德掉不能乱。又如人首冠以花鬘。随所经行多获胜利。如是圣者冠等持鬘。于诸位中多获功德。诸位谓入正性离生。得果离染永尽诸漏。又如以缕结花作鬘。能令众花久不散坏。如是胜定持诸功德。虽经久时而不失坏。是故说此名等持鬘。又如以缕贯结众花。世间于中共生鬘想。如是圣者以三等持摄诸功德。诸天人众于此共生等持鬘想。又如以缕贯结众花系在一处。世间于中起系鬘想。如是以定摄诸善心系在一境。诸天人众咸谓圣者系等持鬘。是故等持以鬘为喻。如契经说。空三摩地是上座住处。问何故佛说空三摩地是上座住处耶。答上座多住此空定故。谓三界中佛是第一功德上座多住空定。独觉是第二功德上座亦多住空定。尊者舍利子是第三功德上座亦多住空定。目干连等诸大声闻亦名上座。彼亦多住空三摩地故。说此空定是上座住处。复次空三摩地是诸内道不共住处。一切内道皆是上座。一切外道皆是婴儿。谓内道法中年八岁者亦名上座。成就功德上座法故。外道法中年八十者亦名婴儿。成就过失婴儿法故。问外道岂有无愿无相。而但说空是不共法。答外道法中虽无真实无愿无相。而有相似。谓粗行相等相似无愿。静行相等相似无相。九十六种外道法中。尚无相似空定况有真实。故唯说空定是内道不共法。复次空三摩地能引上座功德法故名上座住处。上座功德法者。谓道及道果。空三摩地能引彼力殊胜非余。是有身见近对治故。复次空三摩地能令身心安住不动。故名上座住处。谓诸有情乃至未得空三摩地。身心轻躁犹如风尘。若得此定身心不动安静如山。是故尊者妙音说曰。若知诸法是空非我身。及觉慧皆不动摇。身心安静故名上座。故说空是上座住处。复次诸瑜伽师。若住空定其心安住。不为世间适意不适意。可爱非可爱。饶益非饶益。乐具苦具之所倾动。是故说为上座住处。夫上座者心安住故。云何知然。如契经说。尊者舍利子。生母命终同住弟子还俗。有苞齿苾刍。常于尊者心有怨恨。闻此事已。速告尊者舍利子言。汝母命过弟子还俗汝意云何。舍利子言。我母命过生死法尔。弟子还俗凡愚何怪。苞齿苾刍窃作是念言。虽自慰心必燋惶时。舍利子多住空故。虽闻是事而心不动。于日初分着衣持钵。入室罗筏城次第乞食。饭食既讫还誓多林收衣钵洗足已。以尼师檀置左肩上。出所住处往诣闇林。坐一树下入于天住作是思惟。世间颇有可爱妙色变坏之时。令我忧悲生苦恼不。自审观察都无是事。于日后分还誓多林。尔时阿难见舍利子便问尊者从何所来。舍利子言从闇林来。阿难复问尊者住彼入何等定。答言我入有寻伺定。复问住彼何所寻思。时舍利子具以上答。阿难遂问舍利子言。尊者常说若佛世尊不出世者。我等便为无目而死。佛是世间可爱妙色若当变坏。尊者岂能不生忧悲苦恼事不。舍利子言若有是事亦何忧恼。但作是念。世尊灭度一何疾哉。世间眼灭谁能将导。阿难叹曰。善哉善哉。尊者。善修空三摩地。我我所执及我慢等已断遍知。如断草根多罗树顶。令彼于后永不复生。世尊妙色虽当变坏有为法然何所忧恼。由此故知住空定者其心安住。不为世间违顺倾动。是故说为上座住处。无愿无相势力不然。故不说为上座住处如契经说尊者舍利子于憍萨罗国住一林中时有活命出家外道。亦住彼林邻近尊者去林不远。诸村邑中有时广设四月节会。时彼外道巡诸村邑。饱食猪肉恣情饮酒。窃持残者还至林中。见舍利子坐一树下。酒所昏故起轻蔑心。我今与彼虽俱出家。我独富乐而彼贫苦。寻趣尊者作是颂言

  我已饱酒肉　　复窃持余来
  地上草木山　　皆视如金聚

时舍利子闻已念言。此死外道都无惭愧。乃能无赖说此伽他。我今亦应对彼说颂。作是念已即说颂言

  我常饱无相　　恒住空定门
  地上草木山　　皆视如唾聚

今此颂中尊者舍利子作师子吼。说三解脱门。谓于初句说无相解脱门。于第二句说空解脱门。于后二句说无愿解脱门。问时彼外道身命尚存。何缘轻言此死外道。答应知死言目鄙恶事。复次彼无慧命故说为死

此中无相三摩地者。谓无相声说多种义。或于空三摩地说无相声。如是或于见道。或于不动心解脱。或于非想非非想处。或即于无相三摩地说无相声。于空三摩地说无相声者。如契经说。有一苾刍得无相心定。然根钝故不知此定有何果报有何胜利。彼作是念。尊者阿难佛及弟子。常所称叹我应往问。复作是念。尊者阿难善知声相。若得我问必还问我。汝已得此所问定耶。若答言得。便为自显所得胜法违少欲行。若言不得。是虚诳语。若作余言。便是恼乱上座苾刍违越轨范。复作是念。我应随逐尊者阿难。若为他说此定事者我亦得闻。遂逐六年竟不闻说。彼怀疑久俯仰问言。若有获得无相心定不沈不举。摄持诸行如水堤塘。解脱故住住故解脱。佛说此定有何果报。有何胜利。阿难闻已便反问言。汝得此定耶。彼作是念。我昔所虑今果得之。便默然而住。阿难告言。佛说此定得解果报得解胜利。解谓智生修道尽漏。汝亦不久当得此事。此中不沈者已断我见故。不举者已断我所见故。又不沈者已断五我见故。不举者已断十五我所见故。如我我所见己己所见我我所爱己己所。爱我我所痴己己所痴应知亦尔。又不沈者。得涅槃故。不举者。舍生死故。摄持诸行者。多起加行多用功力。极善作意得此定故。如水堤塘者。如水从泉出流漫池中。堤塘堰之不令流散。如是此定随一境转。遍满此境便住不散。解脱故住者。是自性解脱住故。解脱者。是相续解脱此定观无我我所相故名无相而实是空。以彼苾刍专修此定。能初证入正性离生。于最后时尽诸漏故。法印经说若观色声香味触相。而舍诸相名无相定。彼观境界相而舍有情相。谓以空定观色等法。舍有情想。于中都无女男等故。由此尊者妙音说曰。诸有情想依境界相故。观境相舍有情想女男相无名无相定。而实是空三摩地摄

说一切有部发智大毗婆沙论卷第一百四阿毗达磨大毗婆沙论卷第一百五

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    智蕴第三中他心智纳息第 三 之七

于见道说无相声者。如说。目连不说第六无相住者。云何第六无相住者。谓随信行随法行者不可施设。在此在彼不可施设。在苦法智忍乃至在道类智忍故。问何故见道说名无相。答见道速疾不越期心。不可施设此彼相故。于不动心解脱说无相声者。如说。大德瞿达多当知贪欲嗔恚愚痴是相有不动心解脱是最胜无相。问何故不动心解脱名无相耶。答一切烦恼皆名为相。彼心不为烦恼扰乱。烦恼于心不得自在。心于烦恼得自在故。说名无相。于非想非非想处说无相声者。如说。我多起加行多用功力。得无相心定。不应于中欣乐染着。此说不起有顶味定唯起净定。问何故非想非非想处名无相耶。答彼无明了想。相亦无无想相。但有昧钝不明了想微细现行。如疑而转故名无相。即于无相三摩地说无相声者。如此中说三三摩地。谓空无愿无相三摩地所缘境中无十相故

如契经说。一时佛住室罗筏城东鹿母精舍。尊者阿难来诣佛所。顶礼双足而白佛言。我忆一时佛住释种迷主卢园。亲从世尊闻如是义。由我多住空三摩地乃至广说。我于是义善受持不。世尊告曰。汝善受持如说无异。问若善受持不应生犹豫。既生犹豫云何善受持。答虽生犹豫而不邪分别。不全忘故亦名善受持。问尊者阿难闻持第一如来所说八万法蕴。以正念器皆能受持。宁于一句而生疑惑。答闻此法时心忧恼故。诛诸释种是此因缘。谓毗卢宅迦愚痴甚故。破劫比罗城。诛诸释种已至第二日尊者阿难将一苾刍。入彼城内此城昔日如妙天宫。当于尔时其犹丘冢。所有楼观却敌埤堄。诸窗牖等皆悉毁坏。如宝树行无不摧折。清泉池沿泥血所浑。凫雁鸳鸯孔雀鹦鹉命命鸟等。皆为烟焰所逼恼故飞散虚空。诸小女男失父母故。随逐阿难悲啼号哭。各陈丧失父母诸亲。阿难复至母猪池侧。见诸释种昨为痴王埋以半身铁磨磨杀。证圣死者七万七千。尊者阿难见是事。已极生忧恼。于后世尊诸根闲寂觉慧安住不动如山。心意宴然犹持石钵摄念安静。若持油器诸根调顺如宝马王正视安庠。来入城内观有为法变坏无常。尔时阿难观世尊面威光转盛颜貌熙怡。见已念言。世尊与我生地眷属毁丧无异。世尊安静不动如山。而我身心极生苦恼。佛知其念。告阿难言。由我多住空三摩地。汝起城邑想处。我起阿练若想。汝起亲属想处。我起中庸人想。汝起有情想处。我起圆满法想故。我安静不动如山。佛知阿难及苾刍众心。于是处不能修善。遂渐行至室罗筏城。暂时住在鹿母精舍

尔时阿难忧苦稍止。来诣佛所而白佛言。我忆一时乃至广说。由此尊者闻是法时。心忧恼故而生疑惑。问佛言。我多住空三摩地者。多住何空。有说。多住无所行空。于四威仪顺此空故。谓若有一。余三便空。是故此空佛所多住。评曰。应作是说。住本性空。观法本性空无我故。虽见变坏而不忧恼。时诸苾刍闻世尊说由我多住空三摩地。便疑此是佛不共定。佛知其意。告阿难言。若有苾刍亦欲多住此空定者。当除城邑想及有情想。起阿练若想。若能如是与我无异。问世尊何故劝诸苾刍先除二想。答由此二想令诸苾刍生忧恼故。世尊于是复告阿难。若余苾刍亦欲多住此空定者。当除有情想及阿练若想起于地想。若能如是与我无异。如是有余苾刍应除阿练若想及地想。起空无边处想。乃至有余苾刍应除识无边处想。及无所有处想。起非想非非想处想若能如是与我无异。若复能除无所有处想。及非想非非想处想。乃能究竟多住空想。问何故世尊于一切位。渐减前一想。渐增后一想。不总劝除前诸想耶。答过去诸佛过殑伽沙。皆作如是次第说故。复次欲令所说文不乱故。若总劝除前诸想者其文便乱。诸佛说法文必无乱故。渐减前一想。渐增后一想。复次欲令所说文不重故。若总劝除前诸想者其文便重。诸佛说法文必不重故作是说。复次欲令所说文要略故。若总劝除前诸想者文便繁广。诸佛说法文必要略故作是说复次欲显论道法应尔故。谓古昔论师凡兴论道。若取后一必舍前一。世尊既是无上论师。故依论道作如是说。问此中城邑想。乃至非想非非想处想各显何事。答城邑想者。显缘劫比显城想。有情想者。显缘释种想。阿练若想者。显缘诺瞿陀园想。及缘苾刍修善处想。地想者显分散色想。所以者何。若有诸色则有断截手足耳鼻身分等苦。空无边处想者。即显空无边处想乃至非想非非想处想者。即显非想非非想处想。复次城邑想者。显十五我所见。有情想者。显五我见。阿练若想者。显能缘空处想。地想者。显所缘空处四无色想显彼对治。复次城邑想者。显欲界器世间有情想者。显欲界有情世间。阿练若想者。显前二静虑。地想者显后二静虑。四无色想显彼对治。复次城邑想者。总显欲界。所以者何。欲界秽杂如城邑故。如伽他说

  若能伏城邑　　刺骂缚害等
  苦乐不能动　　如山名苾刍

有情想者。显初静虑。所以者何。初静虑地犹有王臣尊卑差别有情众故。阿练若想者。显第二第三静虑。所以者何。离寻伺喜名圣默然故。地想者。显第四静虑。所以者何。彼地中有地遍处故。四无色想显彼对治。即彼经说。佛告阿难。如是趣入无上空定。能速尽诸漏证得无漏无加行解脱。问云何名为有加行解脱无加行解脱耶。答时解脱名有加行解脱。不时解脱名无加行解脱。复次前五种性阿罗汉相续中。名有加行解脱。不动种性阿罗汉相续中。名无加行解脱。复次若依未至定静虑中间下三无色地者。名有加行解脱。若依根本四静虑者。名无加行解脱。是名二种解脱差别

有三重三摩地。谓空空三摩地。无愿无愿三摩地。无相无相三摩地。施设论说。云何空空三摩地。谓有苾刍。思惟有漏有取诸行皆悉是空。观此有漏有取诸行空无常。恒不变易法我及我所。如是观时无间。复起心心所法。思惟前空观亦复是空。观此空观亦空无常。恒不变易法我及我所。如人积聚众多柴木以火焚之。手执长竿周旋敛拨。欲令都尽既知将尽。所执长竿亦投火中。烧令同尽。云何无愿无愿三摩地。谓有苾刍思惟有漏有取诸行皆悉无常。观此有漏有取诸行非常非恒是变易法。如是观时无间复起心心所法。思惟前无常观亦复是无常。观此无常观亦非常非恒是变易法。喻如前说。云何无相无相三摩地。谓有苾刍思惟择灭皆是寂静。观此弃舍诸依爱尽离灭涅槃。如是观时无间复起心心所法。思惟寂静观非择灭亦是寂静。观此非择灭亦无生等諠杂法故。喻如前说。应知彼论所说义者。谓先起空定观五取蕴为空。后起空空定观前空观亦为空。谓观空者亦是空故。先起无愿定观五取蕴为无常。后起无愿无愿定。观前无愿观亦是无常。谓观无常者亦是无常故。先起无相定观择灭为寂静。后起无相无相定。观无相观亦是寂静。谓观寂静者非择灭亦是寂静。三有为相皆寂静故。如旃茶罗积集柴木烧死尸时。手执长竿敛拨令尽。后亦烧竿。此亦如是。问何时得此重三摩地。有作是说。见道中得。如得现观边世俗智时亦得此故。或有说者。修道中得。如圣者离染得变化心时亦得此故。复有说者。尽智时得。如尽智时修得三界有漏善根亦得此故。评曰。应作是说若应得此三摩地者。彼离非想非非想处染时。乃得如是重三摩地。非皆能得。诸有得者后起加行方现在前。佛无加行。独觉有中加行。声闻有中上加行

问此重三摩地几智后现在前耶。答四智后现在前。谓法智类智苦智灭智。此则总说。若别说者。欲界重三摩地三智后现在前。诸法苦灭智。色无色界重三摩地三智后现在前。谓类苦灭智。欲界重三摩地未至定所摄圣道后现在前非想非非想处重三摩地无所有处所摄。圣道后现在前。余地重三摩地皆自地所摄。圣道后现在前

此三重三摩地。界者。通三界。地者。在十一地。谓未至定。静虑中间。四根本静虑。四根本无色。及欲界。所依者。唯依欲界身。行相者。空三摩地有二行相。空空三摩地唯有空行相。所以者何。唯空行相圣道后现在前故。问何故此定唯空行相圣道后现在前耶。答以空行相与有相违。能令有情速舍生死。此重空定厌背圣道。尚能舍圣道。况不舍生死。故唯空行相圣道后现在前。问何故此定不作非我行相耶。答若见诸法非我不见为空者。虽厌生死而非增胜。若见为空则于生死厌力增胜。如人在道独行。遇逢一伴虽知非属于己而不大愁。后若别时便极愁恼故。空行相于厌生死胜于非我。由是此定不作非我行相。无愿三摩地有十行相。无愿无愿三摩地。唯有无常行相。所以者何。唯无常行相圣道后现在前故。问何故此定唯无常行相圣道后现在前耶。答以无常行相与有相违。能令有情速舍生死。此重无愿定厌背圣道。尚能舍圣道。况不舍生死。故唯无常行相圣道后现在前。问何故此定不作苦行相耶。答圣道非苦故。问何故此定不作缘集四行相耶。答圣道不能招三有故。问何故此定不作缘道四行相耶。答此定若作缘道行相。应欣圣道不应厌背。无相三摩地有四行相。无相无相三摩地唯有静行相。所以者何。唯静行相圣道后现在前故。问何故此定不作灭行相耶。答灭有二种。一非择灭。二无常灭。若作灭行相则不知缘何灭。问若尔亦应非静行相。谓静亦有二种一非择灭。二择灭。若作静行相则亦不知缘何静耶。答有处说二灭。无处说二静故不应例。复次灭义滥多。静义滥少。谓灭有三静唯二故。若复不作静行相者。此更作何行相。问何故此定不作妙行相耶。答以非择灭非妙法故。所以者何。品类足说。云何妙法。谓善无漏法。非择灭无记故非妙法。问何故此定不作离行相耶。答以非择灭非离法故。所以者何。品类足说。云何离法。谓欲界善戒。色无色界出离所生。诸善等至。学法无学法。及择灭此定所缘。非择灭无彼所说离法相故。此重三摩地所缘者。空空及无愿无愿三摩地。有说。别缘最后刹那圣道。有说。别缘最后刹那圣道俱生三摩地。有说。总缘相续圣道。有说。总缘相续圣道俱生三摩地。无相无相三摩地缘非择灭。念住者。皆唯法念住俱。智者。皆唯世俗智俱。三摩地者。即是有漏三摩地。非无漏三摩地。根相应者。三根相应。谓乐喜舍三。世者是三世。缘三世者。空空及无愿无愿三摩地。若在过去现在缘过去。若在未来。诸有欲令别缘最后刹那圣道。或彼俱生三摩地者。彼说正起者缘现在。余未来者缘三世。诸有欲令总缘相续圣道。或彼俱生三摩地者。彼说正起者。缘过去现在余未来者缘三世。有余师说。重空无愿三摩地总缘一切圣道。彼说三世皆缘三世。无相无相三摩地唯缘离世。善不善无记者皆是善。缘善不善无记者。前二唯缘善。后一唯缘无记。三界系不系者。皆通三界系。缘三界系不系者。皆缘不系。学无学非学非无学者。皆是非学非无学。缘学无学非学非无学者。前二缘无学。后一缘非学非无学。见修所断不断者。皆是修所断。缘见修所断不断者。皆缘不断。缘名缘义者。皆缘义。缘自他相续非相续者。前二缘自相续。后一缘非相续。加行得离染得者。皆通二得。曾得未曾得者。皆唯未曾得。问此三重三摩地何处谁起。答欲界起非色无色界。人趣起非余趣。三洲起非北洲。三洲中女男俱能起。非扇搋等。尊者瞿沙筏摩说曰。唯赡部洲能起非余洲。唯男身能起非女身。所以者何。此定唯依强胜身故。唯赡部洲男身强胜。评曰。应知此中前说应理。三洲女男俱强胜故。如赡部洲男于心定俱得自在。东西二洲及此洲女亦于心定俱得自在故皆强胜。问何等补特伽罗能起此三摩地。答圣者能起非异生。无学能起非有学。不时解脱能起非时解脱。所以者何。若于定得自在及无烦恼身。方能起此三摩地故。一切异生及信胜解二事俱无。见至虽于定得自在而身中犹有烦恼。时解脱虽身中无烦恼。而于定不得自在故。皆不能起此定。唯有不时解脱。具二事故能起此定

问何时是此三摩地耶。为初刹那为总相续。若初刹那是此定者。后相续者名何定耶。若总相续是此定者。识身论说当云何通。如说。颇有法是世间。有漏有取取蕴所摄。依内起因择生唯善性欲界系。定从无漏无间而生缘无漏法。唯是圣者不共之法非共异生。答有。谓欲界系空空无愿无愿无相无相三摩地。有作是说。唯初刹那是此定摄。问若尔后相续者名何定耶。答彼是此定相似善根非此定摄。复有说者。总诸相续皆是此定。问若尔识身论说当云何通。答彼论总说此定种类。谓此定前后虽多刹那。而皆是此定一种类摄。此从无漏无间而生故不违彼。若别说者初刹那定次无漏生缘无漏法。后相续者虽非无漏无间而生而缘无漏

问此重三摩地何时现在前。有作是说。临涅槃时方起此定。谓阿罗汉临般涅槃复起圣道。次圣道后此定现前。出此定已便般涅槃。不复起此定亦不起圣道。评曰。应作是说。得此定者随欲现前时无决定。问圣道无间此定现前。此定无间起圣道不。答此定无间不起圣道。所以者何。厌圣道故。有作是说。此定无间亦起圣道。问此定无间若起圣道。云何说此厌圣道耶。答此定虽能厌背圣道而不如圣道能厌背此定。圣道虽能厌背此定而圣道后此定现前。此定虽能厌背圣道。此后圣道宁不现前。评曰。应作是说。圣道无间此定现前。此定无间不起圣道。以无用故。由此应知前说应理

问此定不能断诸烦恼。亦不能引殊胜功德。何缘圣者有数起耶。答以四因缘有数起者。一住现法乐故。二游戏功德故。三观本所作故。四受用圣财故。复次此三摩地势用微密定自在者。乃能现前故数起之。游戏胜观诸道过去皆已修已息耶。乃至广说。修有四种。一得修。二习修。三对治修。四除遣修。得修习修。谓一切善有为法。对治修除遣修。谓一切有漏法。西方诸师说修有六。谓前四种。更加二修。一防护修。二分别修。防护修者。谓防护诸根。如契经说。于此六根善调伏。善覆藏。善守护。善摄。善修。能招后乐。分别修者。谓分别色身。如契经说。此身中有发毛爪齿。乃至广说。此国诸师说后二种。即是对治除遣修摄。故一切修唯有四种。此中依前二修作论。然四种修历法分别应作四句。有法是前二修非后二修。谓无漏有为法。有法是后二修非前二修。谓染污及无覆无记有为法。有法是前二修亦是后二修。谓善有漏法。有法非前二修亦非后二修。谓无为法。问修是何义。答熏发义是修义。习学义是修义。令明净义是修义。有为善法现在者习修所显。未来者得修所显。现在者习故得。故名修未来者。唯得故名修现在者。受用故名修未来者。引发故名修现在者。在身故名修未来者。起得故名修现在者。现前故名修未来者。成就故名修现在者。正作所作事。故名修未来者。如遥与欲故名修诸道过去。皆已修已息耶。答诸道过去皆已修已息。已修者谓过去善。已有得习二修故。已息者谓过去法所作已息故。有道已修已息非过去。谓道未来已修已息如不净观。乃至尽智现在前时。能修未来无量刹那善有为法。此所修法。第二刹那已后皆名已修已有得修故。亦名已息所作已办。故而非过去现在未来。故诸道未来皆未已修已息耶。答应作四句。义不定故。有道未来非未已修已息。谓道未来已修已息。此如次前所说者是。有道未已修已息非未来。谓未曾得道初现在前。谓未曾得不净观乃至。尽智正现在前。此未已修。正有得修及习修故。亦未已息正作所作事故。而非未来在现在故。有道未来亦未已修已息。谓道未来未已修已息。谓不净观乃至尽智现在前时。能修未来无量刹那善有为法。此所修法初刹那顷。名未已修。今正得修故。亦名未已息正作所作事故。此所修道犹在未来。有道非未来亦非未已修已息。谓道过去及曾得道今现在前。道过去者。已修已息如前已说。及曾得道今现在前者。先有得修故名已修所作已办故名已息。即是曾得不净观等现在前时。问此道现在今习修故正作事故。应名未已修已息。云何说非未已修已息耶。答虽依习修应唯说过去道是此句摄。而依得修故亦说现在曾得道为此句。诸道现在皆正修耶。答诸道现在皆正修。谓若现在未曾得道。由得习二修故名正修。若现在曾得道但由习修故名正修。有道正修非现在。谓未曾得道初现在前所修未来彼种类道。然种类有四种。一修种类。二律仪种类。三界种类四相似种类。修种类者。如此中说未曾得道初现在前。所修未来彼种类道。此中有说。有漏道以有漏道为种类。无漏道以无漏道为种类。评曰。应作是说。有漏道以有漏无漏道为种类。无漏道以无漏有漏道为种类。所以者何。一一现前俱修未来二种道故。由彼势力未来修者皆可说为彼种类故。律仪种类者。如业蕴说。若成就过去戒。亦成就未来现在此种类戒耶。此中律仪以律仪为种类。别解脱律仪以别解脱律仪为种类。静虑律仪以静虑律仪为种类。无漏律仪以无漏律仪为种类。律仪加行以律仪加行为种类。律仪后起以律仪后起为种类。于中表以表为种类。无表以无表为种类。界种类者如根蕴说。若成就此种类。眼根亦成就。此种类身根耶。此中若是此界法还以此界法为种类。谓欲界法以欲界法为种类。色界法以色界法为种类。无色界法以无色界法为种类。相似种类者。如毗柰耶说。尊者物犊子。左手放光。右手分卧具等。与相似种类苾刍。谓令持素怛缆者与持素怛缆者。同在一处。持毗柰耶者。与持毗柰耶者。同在一处。持阿毗达磨者。与持阿毗达磨者。同在一处。居阿练若者。与居阿练若者。同在一处。令诸苾刍种类同者。共在一处谈论静默。互相随顺修诸善法无忧恼故。契经亦说。诸有情类诸界各别种类同者。更相爱乐。恶者乐恶。善者乐善。于四种类中此中但依修种类而作论。谓不净观乃至尽智现在前时。能修未来无量刹那善有为法。此所修法初刹那顷。是正得修而非现在在未来故。此中现在对正修。问若唯依得修说应作四句。谓或有现在非正修。如曾得道今现在前。或有正修非现在。如修未来初刹那顷。或有现在亦正修。如未曾得道现在前。或有非现在亦非正修。如道过去及未来。已修已息。此中通依。得习修说故。以现在对正修。问唯作顺前句答。以现在道必有习修名正修故

问若退上果住下果时。所得下果名得修耶。答名得非修。问彼还进得所退果时。所得上果名得修不。答若过去者名得非修。若未来者名为得修。问何故过去者名得非修。未来者名得修耶。答若现在道与彼为因者。可说彼为得修。现在道与过去无因义故过去道名得非修。问诸退上果住下果时。所得未来下无漏果。既有现在无漏得。因何不名修。答若现在因由胜进故得未来者彼可名修。退住下果时现在无漏得。虽是彼因而非胜进故不名修。不由现在得修彼未来。故但由退故彼得现前。

    智蕴第三中修智纳息第四之一

有八智。谓法智乃至道智。如是等章及解章义既领会已。次应广释。问何故尊者依此八智而作论耶。答诸作论者随欲造论不应诘责。故本论师随自意欲不违法相而造此论。余处亦依八智作论。如前结蕴后定蕴等。有处唯依一刹那智而作论。如杂蕴智纳息中说。颇有一智知一切法耶。答无有处。唯依二智作论。如次前纳息及根蕴定蕴。有处唯依四智作论。如后根蕴。有处具依十智作论。谓本论师于所知境具足了达自相共相随欲造论。或略或广不违法相。故不应责。复次不应诘责作论者意。谓此八智是佛所说。此本论师依经造论。经说八智不可增减。尊者不能减一说七增一说九。所以者何。诸佛所说无增减故。又佛所说无量无边。以义无量文无边故。如大海水无量无边。以深无量广无边故。假使尊者舍利子等诸大论师。数过百千那庾多等同时出世为释佛经二句义故。制造百千俱胝等论。觉慧穷尽犹不能了如是二句义之边际。况本论师于佛所说八智义中能有增减。问佛于经中或说二智。或说四智。或说八智或说十智。何缘尊者此中但依八智作论。答以此八智是处中说。摄诸智尽故依造论。谓二智等皆是略说摄智不尽。十智契经虽摄智尽而是广说。唯此八智摄诸智尽是处中处故偏依之。复次如是八智学无学者。及有染无染者身中。俱有故偏依之。尽无生智唯无学者。及唯无染者身中可得。是故不依。复次如是八智通智见性故偏依之。尽无生智不通见性。是故不依。复次如是八智数数修起故偏依之。尽无生智不数修起。是故不依。由如是等种种因缘此中但依八智作论

说一切有部发智大毗婆沙论卷第一百五阿毗达磨大毗婆沙论卷第一百六

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    智蕴第三中修智纳息第四之二

或有一智摄一切智。谓法智非如法智以智体是法故。或有二智摄一切智。谓有漏智无漏智。或有三智摄一切智。谓法智类智世俗智。或有四智摄一切智。谓前三智加他心智。或有五智摄一切智。谓世俗智及苦集灭道智。或有六智摄一切智。谓前五智加他心智。或有七智摄一切智。谓八智中除他心智。或有八智摄一切智。谓此中说法智类智他心智世俗智苦智集智灭智道智。问若此八智摄一切智。复有八智。谓法住智。涅槃智。死生智。漏尽智。宿住随念智。妙愿智。尽智。无生智。如是八智何智摄耶。答随其所应皆摄在此。谓法住智是知因智。故知三界下中上果法所住因故。彼智即此四智所摄。谓法类世俗集智。涅槃智是知灭智彼智即此四智所摄。谓法类世俗灭智。死生智即此世俗智所摄。尊者妙音说。死生智四智所摄。谓法类世俗苦智。评曰。应知此中前说应理。漏尽智诸有欲令缘漏尽法故名漏尽智者。四智所摄。谓法类世俗灭智。诸有欲令漏尽身得故名漏尽智者。八智所摄。宿住随念智世俗智所摄。尊者妙音说。宿住随念智六智所摄。即八智中除他心智。缘过去法故。及除灭智。缘有为法故。评曰。应知此中前说应理。妙愿智世俗智所摄。尊者妙音说。妙愿智八智所摄。谓十智中除尽无生智。是见性故。评曰。应知此中前说应理。尽智无生智俱六智所摄。除他心智非见性故。及除世俗智是无漏故。由此八智摄一切智

尊者僧伽筏苏说曰。应说一智。谓决定智以决定义是智义故。此决定智。有二差别。一者有漏。二者无漏。若有漏者。由自性故名世俗智。若无漏者。由对治差别故。复立二种。谓对治欲界者名法智。对治色无色界者名类智。即前三智若能知他心心所法名他心智。又无漏智由行相别复立四智。若于苦谛作四行相转者名苦智。乃至若于道谛作四行相转者名道智。问若决定智唯有一种或二或三。云何此中立有八智。答以五事故立有八智。一对治故立法类智。二自性故立世俗智。三加行故立他心智。四行相故立苦集智。五行相所缘故立灭道智。尊者左受作如是说。对治四种愚故立有八智。四种愚者。一界愚。二心愚。三法愚。四谛愚。对治界愚故立法类智。对治心愚故立他心智。对治法愚故立世俗智。对治谛愚故立苦业灭道智。是名八智自性我物自体相分本性已说智自性所以今当说。问何故名智。智是何义。答决定义是智义。问若尔疑相应慧应不名智。于所缘境不决定故。答彼亦是智一刹那顷于所缘境亦决定故。然此聚中疑势用胜。令心于境多刹那中犹豫不决。说名疑聚。如三摩地一刹那中于境恒住。有时若与掉举相应。令多刹那于境转易说名为乱。又如有情若多贪者说名贪行。若多嗔者说名嗔行。若多痴者说名痴行。一一非不有余烦恼。此亦如是故无有失。譬喻者说。若心有智则无无知。若心有疑则无决定。若心有粗则无有细。然对法者所说法相如闹丛林。谓一心中。有智有无知。有非智非无知。有疑有决定。有非疑非决定。有粗有细。有非粗非细。阿毗达磨诸论师言。许法俱生斯有何失。谓诸心所展转力生一心相应相用各别智。谓般若无知谓无明非智非无知。谓余心所法。疑谓犹豫。决定谓智。非疑非决定。谓余心所法。粗谓寻。细谓伺。非粗非细。谓余心所法。如诸色法异类俱生。心所亦尔。故无有失。有作是说。于所缘境重决择义是智义。诸有漏慧于所缘境无始时来数数决择故皆名智。诸无漏慧重决择者皆名为智。唯无漏忍于四圣谛。未重决择故不名智。复有说者。由二义故说名为智。谓证知义。及了知义。证知义者。谓证知苦乃至证知道故名智。了知义者。谓了知自相续了知他相续故名智

已总说诸智所以一一所以今当说。问何故名法智。答智体是法故名法智。问若尔余智亦体是法。何故不名法智耶。答虽一切智体皆是法。而但于一立法智名如十八界。十二处。七觉支。六随念。四念住。四证净。四无碍解。三宝。三归。皆体是法而但于一建立法名。此亦如是故不应责。复次法智但有一名。谓共名。余智有二名。谓共不共名。为简别故说不共名。复次初觉知法故名法智。后觉知法故名类智。复次若初得法证净相应智故名法智。此后所得故名类智。复次于现见法。得现量智故名法智。此后所得故名类智。复次欲界多有非法烦恼。谓忿恨覆恼嫉悭等相应烦恼。若智是彼近对治者名法智。色无色界无有如是非法烦恼。对治彼者法智后生故名类智复次若智六地所摄。能缘一地说名法智。若智九地所摄。能缘八地说名类智。此依有漏地说。复次若智六地所摄。能缘六地说名法智。若智九地所摄。能缘九地说名类智。此依无漏地说。复次若智对治十八界十二处五蕴者名法智。若智对治十四界十处五蕴者名类智。复次若智对治善不善无记五蕴者名法智。若智对治善无记五蕴者名类智。复次若智对治福非福不动行者名法智。若智对治福及不动行者名类智。复次若智对治段食淫欲爱者名法智若智对治诸定爱者名类智。问何故名他心智。答知他心故名他心智。问此亦知他诸心所法。何故但名他心智耶。答以期心故谓修观者先起意乐。欲知他心由此意乐。后知心时亦知心所。如人意乐本欲见王。后见王时亦见臣等。复次诸法得名由多缘故。谓或由自性得名。如谛如蕴如世俗智。或由对治得名。如法类智。或由加行得名如他心智等。或由相应得名。如说。乐受等相应法。名顺乐受等法。或由所依得名。如眼识等。或由行相得名。如苦集智。或由所缘得名。如念住等。或由行相所缘得名。如灭道智故由加行名他心智。复次以心胜故虽亦知心所。但名他心智。如王来等。复次以心是大地故。心所名大地法。复次证他心通无间道时但缘心故。复次说心远行独行等故。复次说心是前行等故。复次说心是增上王故。复次说心是城主故。复次说心是依趣故。复次说心能起善恶戒故。复次说心能引善恶趣故。复次心是内处遍诸界地有所缘故。复次心是所依非心所故。复次若心行处心所随故。复次若心调伏不调伏时。诸心所法亦如是故。复次若心流散不流散时。诸心所法亦如是故。由此等缘。此他心智虽亦知心所。而名他心智问何故名世俗智。答知世俗故名世俗智。问亦知胜义。何故但名世俗智耶。答虽亦少分知蕴界处四圣谛等诸胜义法。而多分知男女往来瓶衣车乘舍林山等。世俗法故名世俗智。复次此世俗智实无智相。而诸世俗共立智名。如非王种但诸人众。假想施设共立王名。复次此世俗智一切有情展转共许无有诤论。如僧上坐如悦众人众所许故名为世俗。复次此世俗智遍诸有情。缘一切境故名世俗。复次此世俗智愚痴所依。系属愚痴是愚痴者安立足处故名世俗。声论者说此世俗智为诸无知之所覆蔽。如器中物器所覆蔽故名世俗。复次此世俗智为对治道之所变坏。为愚痴者之所欣尚故名世俗。问何故名苦智。乃至道智耶。答缘苦圣谛四行相转故名苦智。乃至缘道圣谛四行相转故名道智。问诸世俗智亦能缘。四谛各四行相转岂名四智耶。答若唯缘苦谛唯四行相转者名苦智。乃至若唯缘道谛唯四行相转者名道智。诸世俗智于四圣谛或一一别缘。或二二合缘。或三三合缘。或四总缘。或缘余法。或复总缘所起行相。亦不决定故不名苦智乃至道智。以杂乱故。复次若别缘四谛各四行相转。不与苦集同一缚者名四谛智。诸世俗智虽亦有别缘四谛各四行相转。而与苦集同一缚。故不名四谛智。问此与灭道不同一缚。何故不立灭道智耶。答初不立故后亦不立。复次若别缘四谛各四行相转。能对治烦恼者名四谛智。诸世俗智。虽亦有别缘四谛各四行相转。而不能对治烦恼故不名四谛智。复次若别缘四谛各四行相转。于四圣谛证见明了。不为见疑无明所惑。不增烦恼不招三有。定趣涅槃者名四谛智。诸世俗智。无如是义故不名四谛智。复次若别缘四谛各四行相转。是圣性者名四谛智。诸世俗智。非圣性摄故不名四谛智

如是八智。界者他心智若有漏是色界。若无漏是不系。世俗智通三界。余六智是不系。地者法智在六地。类智在九地。他心智在四地。世俗智在十八地。谓八等至八近分静虑中间及欲界。余四智。法智摄者在六地。类智摄者在九地。所依者。法智唯依欲界起。他心智唯依欲色界起。类智世俗智俱依三界起。余智法智摄者。唯依欲界起。类智摄者。通依三界起。行相者法智类智俱作十六行相。他心智无漏者。作道四行相。有漏者作不明了行相。世俗智作十六行相。亦作余行相。苦集灭道智各作四行相。问诸苦智皆作苦行相转耶。答应作四句。或有苦智非作苦行相转。谓苦智作非常空非我行相转。或有作苦行相转非苦智。谓作苦行相转苦智相应法。或有苦智亦作苦行相转。谓作苦行相转苦智。有非苦智亦非作苦行相转。若唯取此种类者。谓作非常空非我行相转苦智相应法。若不唯取此种类者谓除前相。如转有四句已转当转应知亦尔。如苦智对苦行相有三四句。对非常空非我行相应知亦尔。如苦智有十二句。集灭道智应知亦尔。如是总有四十八四句。所缘者。法智类智俱缘四谛。他心智缘他心心所法。世俗智缘一切法。苦智缘苦谛。集智缘集谛。灭智缘灭谛。道智缘道谛。念住者。他心智是三念住除身念住。灭智是法念住。余智通四念住。智者。此八智即是八智。三摩地者。法智类智三三摩地俱。他心智无漏者道无愿三摩地俱。有漏者非三摩地俱。世俗智非三摩地俱。苦智空无愿三摩地俱。集智集无愿三摩地俱。灭智无相三摩地俱。道智道无愿三摩地俱。根相应者。世俗智五根相应。余智三根相应。谓乐喜舍。三世者。此八智皆通三世。缘三世者。法智类智世俗智皆缘三世及离世。他心智过去缘过去。现在缘现在。未来生法缘未来不生法。缘三世。灭智缘离世。余智缘三世。善不善无记者。世俗智通三种。余智唯是善。缘善不善无记者。类智缘善无记。灭道智唯缘善。余智缘三种。三界系不系者。他心智若有漏色界系。若无漏是不系。世俗智通三界系。余智是不系。缘三界系不系者法智缘欲界系及不系。类智缘色无色界系及不系。他心智缘欲色界系及不系。世俗智缘三界系及不系。苦集智缘三界系。灭道智缘不系。学无学非学非无学者。他心智通三种。世俗智唯非学非无学。余智是学无学。缘学无学非学非无学者。法类世俗他心智皆缘三种。苦集灭智唯缘非学非无学。道智缘学无学。见修所断不断者。他心智若有漏修所断。若无漏是不断。世俗智是见修所断。余智是不断。缘见修所断不断者。法类世俗他心智缘三种。苦集智缘见修所断。灭道缘不断。缘名缘义者。法类世俗苦集智。通缘名义。余智唯缘义。缘自他相续非相续者。法类世俗智缘三种。他心智缘他相续苦集道智缘自他相续。灭智缘非相续。加行得离染得生得者。世俗智通三种。余智通加行离染得。曾得未曾得者。他心世俗智通曾得未曾得。余智唯未曾得

复次法智有四种。一于法初知故名法智。二于法现知故名法智。三于法实知故名法智。四于法出离知名法智。比类智亦有四种。一以因比类知果。二以果比类知因。三以身语业比类知心。四以所说法比类知佛。他心智亦有四种。谓从四缘生亦能为四缘。此智所智亦尔。世俗智亦有四种。一知名世俗。二知缚世俗。三知假立世俗。四知执着世俗。苦智亦有四种一知生苦。二知流转苦。三知热恼苦。四知和合苦。集智亦有四种。一知业。二知烦恼。三知爱。四知事。灭智亦有四种一知三结永断。二知薄贪嗔痴。三知五顺下分结尽。四知一切结尽。道智亦有四种。一知从第八补特伽罗一切学位诸有所作。二知降伏怨敌。三观本所作。四观近尽漏。尽智亦有四种。一见所不摄。二远离空定。三非他心智。四加行迟缓。无生智亦有四种。一因故。二果故。三相续故。四补特伽罗。此中所说四法智等。泛释经中诸智差别。非皆即是法智等摄。复次应说十智总为一智。谓法智皆以法为体故。应说十智总为一智。谓类智皆是圣种类故应说十智总为一智。谓决定智。以决定义是智义故。应说十智总为一智。谓所知智知所知故重审决故。应说十智总为一智。谓道智道谛摄故。应说十智总为一智。谓愿智能满所愿故。应说十智总为一智。谓尽智烦恼尽者身中得故。应说十智总为一智。谓无生智不退堕故。云何法智。答于欲界诸行诸行因诸行灭诸行能断道所有无漏智。此中诸行者。谓苦谛。诸行因者。谓集谛。诸行灭者。谓灭谛。诸行能断道者。谓道谛。能知欲界如是四谛。诸无漏智总名法智。又于法智及法智地所有无漏智是谓法智者。问何故复说此耶。答前虽说能断欲界诸行无间道。而未说加行解脱胜进道。今欲说之。此中法智者。谓三道法智。法智地者。谓三道法智相应俱有等法。复次能断道者。谓无间道法智。法智者。谓余三道法智。法智地者。谓四道法智相应俱有等法。及四法忍品。复次能断道者。谓能断欲界烦恼四道无漏法。法智者。谓余时所起所修法智。法智地者。谓彼相应俱有等法。次后类智准此应知。他心智等如文广说。应知其相。法智乃至道智于八智中一一摄几。问何故作此论。答为止他宗显正理故。谓或有执诸法摄者。谓摄他性不摄自性。如分别论者。为遮彼执欲显诸法皆摄自性不摄他性故。作斯论。此中理趣如结蕴中已广分别。答法智摄法智五智少分。谓他心智苦集灭道智者。此中总说法智摄法智。然法智在六地。未至定者摄未至定者。乃至第四静虑者摄第四静虑者。又法智有四种。谓四谛智苦智摄苦智乃至道智摄道智。又法智在三世。过去摄过去。未来摄未来。现在摄现在。过去未来各多刹那一一自摄。即此法智摄他心智少分者。谓他心智有有漏。有无漏。此唯摄无漏。彼无漏复有法智品。有类智品。此唯摄法智品。故说摄彼少分即此法智摄苦集灭道智少分者。谓彼四智。各有法智品。有类智品。此唯摄法智品。故说摄彼少分。类智摄类智五智少分。谓他心智苦集灭道智者。此中总说类智摄类智。然类智在九地。未至定者摄未至定者。乃至无所有处者摄无所有处者。余广说如法智。他心智摄他心智四智少分。谓法类世俗道智者此中总说。他心智摄他心智。然他心智在四根本静虑初静虑者摄初静虑者。乃至第四静虑者摄第四静虑者。又他心智有有漏有无漏。有漏摄有漏。无漏摄无漏此有漏者。有曾得有未曾得。曾得摄曾得。未曾得摄未曾得。此无漏者有法智品有类智品。法智品摄法智品。类智品摄类智品。又此他心智通三世。过去摄过去。未来摄未来。现在摄现在。过去未来各多刹那一一自摄。即此他心智摄法智少分者。谓法智在六地。此唯摄彼在四根本静虑者。又法智有四种。谓四谛智。此唯摄彼道智。又彼道智。有别缘者。有总缘者。有缘现在者。有缘过去未来者。有缘自相续者。有缘他相续者。有缘心心所法者。有缘余蕴者。此唯摄彼别缘现在他相续心心所法故说摄彼少分。如说。此摄法智少分。说此摄类智少分亦尔。有差别者。应说类智在九地。此唯摄彼在根本四静虑者。又此他心智摄世俗智少分者。谓世俗智在十八地。此唯摄彼在根本四静虑者。又世俗智有善染污无覆无记。此唯摄彼善者。又彼善者有别缘者。有总缘者广说如前。此唯摄彼别缘现在他相续心心所法者。故说摄彼少分。又此他心智摄道智少分者。谓道智在九地。此唯摄彼在根本四静虑者。又彼道智有别缘者。有总缘者。广说如前。此唯摄彼别缘现在他相续心心所法者故说摄彼少分。世俗智摄世俗智他心智少分者。此中总说世俗智摄世俗智。然世俗智在十八地。欲界者摄欲界者。乃至非想非非想处者。摄非想非非想处者。又世俗智有善染污无覆无记。善者摄善者。染污者摄染污者。无覆无记者摄无覆无记者。又世俗智通三世。过去摄过去。未来摄未来。现在摄现在。过去未来各多刹那一一自摄。又世俗智摄他心智少分者。谓他心智。有有漏。有无漏。此唯摄彼有漏者故。说摄彼少分。苦智摄苦智二智少分。谓法类智者。此中总说苦智摄苦智。然苦智在九地。未至定者摄未至定者。乃至无所有处者摄无所有处者。余如前说。又此苦智摄法智少分者。谓法智有苦集灭道智。此唯摄彼苦智故说摄彼少分。如说。此摄法智少分。说此摄类智少分亦尔。如苦智摄一智二智少分。集智灭智应知亦尔。道智摄道智三智少分。谓法类他心智者。此中总说道智摄道智。然道智在九地。未至定者摄未至定者。乃至无所有处者。摄无所有处者。余如前说。又此道智摄法类智少分者。如前苦智摄法类智少分说。又此道智摄他心智少分者。谓他心智有有漏有无漏。此唯摄彼无漏者。故说摄彼少分。此中摄者。谓摄自性。自性于自性实有可得。不离不脱常住不空。恒为障碍故说为摄

若成就法智乃至广说。问何故作此论。答为止他宗显正理故。谓或有执。无实成就不成就性。如譬喻者。为遮彼执显成就性不成就性决定实有。故作斯论。若成就法智于此八智。几成就几不成就。答或三四五六七八谓苦法智苦类智忍时。无他心智成就三。有他心智成就四。此中三者。谓法智苦智世俗智。四者。谓前三加他心智。若未离欲染入正性离生者。尔时成就三。若已离欲染入正性离生者。尔时成就四。后诸所说准此应知。苦法智时。法智苦智成就现在未来。即一智体以对治故名法智。以行相故名苦智。世俗他心智成就过去未来。苦类智忍时。增见增慧增道。非智非名。尔时法智苦智世俗智或他心智。皆唯成就过去未来。以现在无故。后诸所说准此应知。苦类智集法智忍时。无他心智成就四。有他心智成就五。此中四者。谓法类苦世俗智。五者。谓前四加他心智。苦类智时增见增慧增道增智增名。谓类智名此苦智。名苦法智时已得故。集法智忍时增见慧道。非智非名。集法智乃至灭法智忍时。无他心智成就五。有他心智成就六。此中五者。谓法类苦集世俗智。六者。谓前五加他心智。集法智时增见慧道及智名。谓集智名此法智。名苦法智时已得故。集类智忍集类智灭法智忍时。增见慧道非智非名。所以者何。集类智时所得集智名。不异集法智时所得集智名故。尔时所得类智名。不异苦类智时所得类智名故。灭法智乃至道法智忍时。无他心智成就六。有他心智成就七。此中六者。谓法类苦集灭世俗智。七者。谓前六加他心智。灭法智时增见慧道及智名。谓灭智名灭类智忍。灭类智道法智忍时增见慧道。非智非名。所以者何。灭类智时所得灭智名。不异灭法智时所得灭智名故。尔时所得类智名。不异苦类智时所得类智名故。道法智乃至道类智时。无他心智成就七。有他心智成就八。此中七者。谓八智中除他心智。八者。谓前七加他心智。道法智时增见慧道及智名。谓道智名道类智忍。道类智时增见慧道。非智非名。所以者何。道类智时所得道智名。不异道法智时所得道智名故。尔时所得类智名。不异苦类智时所得类智名故。若成就类智乃至若成就道智。于此八智成就少多。如文广说应知其相。增见慧道及增智名。如法智中应知其相。然成就法智及苦智。以苦法智时为初成就。类智以苦类智时为初成就。他心智以离欲染第九解脱道。及无色界没生色界中有结生心为初成就。世俗智无初一切有情本成就故。成就集智以集法智时为初成就。灭智以灭法智时为初成就。道智以法智时为初。法类苦集灭道智。从初得后。乃至未般涅槃恒时成就。世俗智从不可知本际。乃至未般涅槃恒时成就。他心智已离欲染未生无色界未般涅槃恒时成就。是谓此处略毗婆沙

若修法智亦类智耶。乃至广说。问何故作此论。答为止他宗显正理故。谓或有说。善染无记法皆有修义。为遮彼执显唯善有为法得有修义。云何知然。如契经说。善有为法应修非余。所以者何。若法智者为爱果故。精勤修习令渐增长。说名为修。唯善有为法能得爱果。谓得世间可爱异熟增上果故。亦得出世离系果故。诸有智者精勤修习。从下至中从中至上令速获得所求爱果。染无记法及善无为无如是用故不名修。或有拨无未来修义。谓过去未来俱无实体故。为遮彼执显定实有过去未来。现在能修未来善法。谓现在世胜善为因。引起未来诸善法得。由得彼法故说彼为所修。若无能修未来善者。则应无有得果等义。谓得果等时现在唯有一智未来修八智。现在唯有一行相未来修十六行相。现在唯有一刹那未来修无量刹那。现在或唯有有漏心心所法。未来修有漏无漏心心所法。或有现在唯有无漏心心所法。未来修无漏有漏心心所法。如是等事皆应不成。复次诸佛证得大菩提时。现在唯有尽智功德。若无未来修善义者。则应诸佛无一切智。勿有此等大过失故。必应许修未来善法。为遮此等种种异执。及显正理故作斯论。修有四种如前广说。此中唯依二修作论。谓得修习修

说一切有部发智大毗婆沙论卷第一百六阿毗达磨大毗婆沙论卷第一百七

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    智蕴第三中修智纳息第四之三

异生离欲染时。诸加行道九无间道八解脱道中。现在唯修世俗智。未来亦唯修世俗智。第九解脱道中。现在唯修世俗智。未来修世俗他心智。离初静虑染时。若依初静虑作加行。彼加行道中现在唯修世俗智。未来修世俗他心智。若依第二静虑近分作加行。彼加行道九无间道八解脱道中。现在唯修世俗智。未来亦唯修世俗智。第九解脱道中现在唯修世俗智。未来修世俗他心智。离第二第三静虑染时应知亦尔。离第四静虑染时。若依第四静虑作加行。彼加行道中。现在唯修世俗智。未来修世俗他心智。若依空无边处近分作加行。彼加行道九无间道九解脱道中。现在唯修世俗智。未来亦唯修世俗智。离空无边处染时。诸加行道九无间道九解脱道中。现在唯修世俗智。未来亦唯修世俗智。离识无边处无所有处染时应知亦尔

未离欲染异生。起四无量。初二解脱。前四胜处。不净观。持息念。念住。暖顶忍世第一法时。现在唯修世俗智。未来亦唯修世俗智。已离欲染异生。起四无量。初三解脱。八胜处。前八遍处。不净观。持息念。念住时。现在唯修世俗智。未来修世俗他心智。起暖顶忍世第一法时。现在唯修世俗智。未来亦唯修世俗智。起无色四解脱。二遍处。及念住时。现在唯修世俗智。未来亦唯修世俗智。引发五通时。诸加行道二解脱道中。现在唯修世俗智。未来修世俗他心智。一解脱道中。现在修世俗他心智。未来亦修世俗他心智。五无间道中。现在唯修世俗智。未来亦唯修世俗智。二解脱道中。不修智无记故圣者见道中。若如是功德现在修未来。即修如是功德。如诸忍现在前时。现在修如是忍。未来亦修如是忍。诸智现在前时。现在修如是智。未来亦修如是智。除三心顷。未来亦修世俗智。谓苦集灭类智时。亦修未来现观边世俗智。问何故见道中唯修同分。修道中能修同分不同分耶。答以见道处所定对治定故唯修同分。修道处所不定对治不定。故能修同分不同分。复次以见道所缘定对治定故唯修同分。修道所缘不定对治不定。故能修同分不同分。复次见道中初得圣种性于四圣谛初修圣行相故唯修同分。修道中已得圣种性。于四圣谛已修圣行相。故能修同分不同分。复次见道中初得见谛。初得现观故唯修同分。修道中已得见谛已得现观。故能修同分不同分。道类智时无他心智者。现在修道类二智。未来修六智。除世俗他心智。有他心智者。现在修道类二智。未来修七智。除世俗智。圣者以世俗道离欲染时。若无漏作加行。彼加行道中。四法四类智随二现在修。未来修七智。除他心智。若世俗作加行。彼加行道九无间道八解脱道中。现在唯修世俗智。未来修七智。除他心智。第九解脱道中。现在唯修世俗智。未来修八智。离初静虑染时。若无漏作加行。彼加行道中。四法四类智随二现在修。未来修八智。若世俗作加行。彼加行道九解脱道中。现在唯修世俗智。未来修八智。九无间道中现在唯修世俗智。未来修七智。除他心智。乃至离无所有处染。时。应知亦尔。以无漏道离欲染时。若世俗作加行。彼加行道中。现在唯修世俗智。未来修七智。除他心智。若无漏作加行。彼加行道中。四法四类智随二现在修。未来修。七智。除他心智。九无间八解脱道中。四法智随二现在修。未来修七智。除他心智。第九解脱道中四法智随二现在修。未来修八智。离初静虑染时。若以世俗作加行。彼加行道中现在唯修世俗智。未来修八智。若无漏作加行。彼加行道中。四法四类智随二现在修。未来修八智。九无间道中。二法四类智随二现在修。未来修七智。除他心智。九解脱道中。二法四类智随二现在修。未来修八智。乃至离无所有处染应知亦尔。离非想非非想处染时。若世俗作加行。彼加行道中。现在唯修世俗智。未来修八智。若无漏作加行。彼加行道中四法四类智随二现在修。未来修八智。九无间道中二法四类智随二现在修。未来修六智。除世俗他心智。八解脱道中。二法四类智随二现在修。未来修七智。除世俗智。第九解脱道中。二类智随二现在修。未来修八智及修三界无量善根未离欲染信胜解。练根作见至时。若世俗作加行。彼加行道中。现在唯修世俗智。未来修七智。除他心智。若无漏作加行。彼加行道中。四法四类智随二现在修。未来修七智。除他心智。无间道中。四法四类智随二现在修。未来修六智。除世俗他心智。解脱道中四法四类智随二现在修。未来有说修六智。除世俗他心智。有说修七智。除他心智。已离欲染信胜解。练根作见至时。若世俗作加行。彼加行道中。现在唯修世俗智。未来修八智。若无漏作加行。彼加行道中。四法四类智随二现在修。未来修八智。无间道中四法四类智随二现在修。未来修六智。除世俗他心智。解脱道中四法四类智随二现在修。未来有说修七智。除世俗智。有说修八智。时解脱阿罗汉练根作不动时。若世俗作加行。彼加行道中。现在唯修世俗智。未来修八智。若无漏作加行。彼加行道中。四法四类智随二现在修。未来修八智。九无间道中二法四类智随二现在修。未来修六智。除世俗他心智。八解脱道中二法四类智随二现在修。未来修七智。除世俗智。第九解脱道中二类智随二现在修。未来修八智。及修三界无量善根。未离欲染圣者。起四无量。初二解脱。前四胜处。不净观。持息念。及世俗念住时。现在唯修世俗智。未来修七智。除他心智。杂修静虑时。初刹那顷四法四类智随二现在修。未来修七智。除他心智。第二刹那顷现在唯修世俗智。未来修七智。除他心智。第三刹那顷四法四类智随二现在修。未来修八智。引发五通时。五无间道中。现在唯修世俗智。未来修七智。除他心智。诸加行道二解脱道中。现在唯修世俗智。未来修八智。一解脱道中未来修八智。现在唯修世俗他心智。有说。亦修道法道类随二。他心智二解脱道不修智无记故。已离欲染圣者。起四无量世俗解脱胜处遍处不净观持息念世俗念住世俗无碍解无诤愿智边际定空空无愿无愿无相无相三摩地入灭定想微细心时。现在唯修世俗智。未来修八智。起无漏他心智时。现在修道法道类随二他心智。未来修八智。依静虑地。起无漏念住无漏义无碍解时。四法四类智随二现在修。未来修八智。起无漏辩无碍解时。道法道类智随二现在修。未来修八智。依无色定起无漏念住无漏义无碍解无漏解脱时。四类智随二现在修。未来修八智。依无色定起无漏辩无碍解时。现在修道类二智。未来修八智。起入灭尽定微微心时。现在唯修世俗智。未来亦唯修世俗智。是谓此处略毗婆沙

若修法智亦类智耶。答应作四句。义不定故有修法智非类智。谓入现观苦集灭道法智时。学见迹阿罗汉。已得法智现在前时。此中入现观苦集灭道法智时者。谓见道中四法智时。唯修法智不修类智。所以者何。以见道中若如是功德现在修未来。即修如是功德法智现在前时。唯修未来法智品。类智现在前时。唯修未来类智品故学见迹阿罗汉。已得法智现在前时者。学谓预流一来不还补特伽罗。迹谓四圣谛。以无漏慧已具见四谛迹故名学见迹。阿罗汉者谓慧解脱或俱解脱。此学无学已得法智现在前时唯修法智。是习修故不修类智。所以者何。以曾得法现在前时。势力羸劣尚不能及第二刹那。况能修余未来远者。有修类智非法智。谓入现观苦集灭类智时。学见迹阿罗汉。已得类智现在前时此中入现观苦集灭类智时者。谓见道中三类智时。唯修类智不修法智。义如前说。学见迹阿罗汉。已得类智现在前时者。谓学无学曾得类智现在前时。唯修类智不修法智。义如前说。有俱修。谓入现观道类智时。学见迹阿罗汉。未得无漏智现在前时。未得世俗智现在前。能俱修时。此中入现观道类智时者。谓见道后道类智时。能修法智。亦修类智。由此位中舍曾得道。得未曾得道。证结断一味得。顿得八智。俱时修十六行相故。学见迹阿罗汉。未得无漏智现在前时者。谓有学位以无漏道离欲染。若无漏作加行。彼加行道九无间道九解脱道时。乃至离无所有处染时。亦尔。离非想非非想处染若无漏作加行。彼加行道九无间道八解脱道时。信胜解练根作见至。若无漏作加行。彼加行道无间道解脱道时。杂修静虑初后心时。起无漏他心智无漏念住无漏解脱时。如是等学位未得无漏智现在前时。能修法智。亦修类智。若无学位离非想非非想处染第九解脱道时。时解脱练根作不动。若无漏作加行。彼加行道九无间道九解脱道时杂修静虑初后心时。起无漏他心智无漏念住无漏无碍解无漏解脱时。如是等无学位未得无漏智现在前时。能修法智。亦修类智。未得世俗智现在前能俱修时者。谓学位以世俗道离欲染。若世俗作加行。彼加行道九无间道九解脱道时。乃至离无所有处染时亦尔。离非想非非想处染。若世俗作加行。彼加行道时。信胜解练根作见至。若世俗作加行。彼加行道时。杂修静虑中间心时。引发五通诸加行道五无间道三解脱道时。起四无量世俗解脱胜处遍处不净观持息念世俗念住入灭定想微细心时。若无学位时解脱练根作不动。若世俗作加行。彼加行道时。杂修静虑中间心时。引发五通诸加行道五无间道三解脱道时。起四无量世俗解脱胜处遍处世俗念住世俗无碍解无诤愿智边际定空空无愿无愿无相无相三摩地入灭定想微细心时。如是等学无学位。未得世俗智现在前时。能修未来法智类智。有俱不修。谓学见迹阿罗汉。已得世俗智现在前时。未得世俗智现在前俱不修时。一切异生染污心无记心无想定灭定无想天无漏忍时。此中学见迹阿罗汉已得世俗智现在前时者。谓有学无学位已得世俗智现在前时。势力羸劣尚不能修未来自类有漏功德。况能修异类法智类智品。未得世俗智现在前俱不修时者。谓即有学无学位未曾得闻思所成慧。及入灭定微微心现在前时。皆不能修法智类智。一切异生者。谓异生位诸有心时皆不能修法智类智。此非异生所修法故。染污心者。谓诸圣者诸染污心现在前时。皆不能修法智类智。以染污心是顺退分其性沉重懈怠相应。自尚非修。况能修他无漏功德。要顺胜分其性轻妙精进相应心方能修善故。无记心者。谓诸圣者诸无记心现在前时。皆不能修法智类智。以无记心卑下羸劣如腐种子。自尚非修。况能修他无漏功德。要坚胜心能修功德。无想定灭定者。谓住无想定及住灭定时。俱不能修法智类智。要有心位方有所修。无心位中不能修故。无想天者。有说。生彼于一切时不起善心。故不能修法智类智。有说。生彼虽起善心。而不能修加行善法。以彼唯起生得善故。尚不能修加行有漏。况法类智彼岂能修。无漏忍时者。谓见道中八无漏忍时不能修智。尔时唯修自类功德。非他类故

问何故已得善法现在前时。不能修余未来诸善功德。答作用劣故。已受用故。已作事故。已与果故。复次已修已息无势用故。复次起已得法现在前时。前已得修今复习修。二修历世但有损减更无增益。岂能更修未曾得善。如人食用先所集财。但有损减更无增益。岂名更集未曾集财。复次若多用功所起善法。能修未来诸余善法。起已得善现在前时不多用功故。不能修未来善法。复次若已得善现在前时。能修未来诸善法。者。世尊将欲入涅槃时。次第入诸静虑等至。亦应能修未来功德。世尊现起初尽智时。已具得修一切功德。今若更修前应未得。若尔前位功德未满。初成佛时应非究竟。证得无上正等菩提。勿有此失故。已得善现在前时。定不能修未来善法。余修智义如文广说。准前方隅应知其相

法智乃至道智。于八智中一一缘几智耶。问何故作此论。答为止他宗显正理故。谓或有说。诸所缘缘非实有体。为遮彼执显所缘缘实有自体故作斯论。答法智缘七智。除类智。类智缘七智。除法智。所以者何法智缘下类智缘上。故不相缘。如有二人同住一处一人观地。一人观空。如是二人不相见面。他心智世俗智俱缘八智者。此二总能缘心心所法故。苦智集智俱缘二智。谓他心世俗智者。此二唯能缘有漏心品故。灭智不缘智者缘无为故。道智缘七智除世俗智者。缘道谛故。有余于此别作问言。法智乃至道智。于八智中一一几智缘耶。即自答言。法智四智缘。除类苦集灭智。类智四智缘。除法苦集灭智。他心智七智缘。除灭智。世俗智六智缘。除灭道智。苦集灭道智五智缘。除苦集灭智。法智乃至道智自他相望为几缘耶。问何故作此论。答为止他宗显正理故。谓或有执缘无实体。为遮彼意欲显四缘实有自体故作斯论。答法智与法智为四缘。乃至广说。问何故此中与前结蕴不善纳息所说有异。谓此中说法智与法智为四缘。不善纳息说有身见与有身见或为四三二一缘耶。答如此中说彼亦应尔。如彼所说此亦应尔。但为显示异相异文令受持者生欣乐故。复次欲现二门二略二影二梯二蹬二门二炬令知所说更相显故。复次彼说是了义。此说非了义。彼说无别意。此说有别意。彼说无别缘。此说有别缘。彼说依胜义。此说依世俗。复次彼依四种差别而说。谓界差别。世差别。刹那差别。等无间缘差别。此唯依一种差别而说。谓等无间缘差别。法智与法智为四缘者。谓因等无间所缘增上。此中因者如种子法。等无间者如开避法。所缘者如柱杖法。增上者如不障法。法智与法智为因缘者。谓为一因即相似因。为等无间缘者。谓法智无间法智现在前。为所缘缘者。谓法智缘法智而生。为增上缘者。谓法智不障碍法智生。与类智为三缘除所缘者。谓法智与类智为三缘。除所缘。为因缘者。谓法智与类智为一因。即同类因。为等无间缘者。谓法智无间类智现在前。为增上缘者。谓法智不障碍类智生。除所缘者。谓法智与类智互不相缘。与他心智为四缘等者。谓法智与自相续他心智。为因等无间。非所缘。与他相续他心智为所缘。非因等无间。余如前说。与世俗智为三缘除因者。谓因缘如种子法。无漏与有漏非种子法故。法智与世俗智非因缘。但为三缘。与苦集灭智为三缘除所缘者。谓苦集智缘有漏。法智无漏故非彼所缘。灭智缘无为法。法智有为故非彼所缘。与道智为四缘如前说。类智与类智为四缘等。准前法智应知其相。他心智与他心智为四缘等者。此中因缘。谓一同类因。余如前说。与世俗智为四缘者。此中因缘。谓同类异熟二因。余如前说。与苦集智为四缘等者。谓无漏他心智。与苦集智为一同类因者。定非所缘彼缘有漏故。若有漏他心智。与苦集智为所缘者。定非因缘。有漏不与无漏为因缘故。与灭智为三缘除所缘者。彼缘无为故。与道法类智为四缘者。义如前说。世俗智与世俗智。为四缘者。此中因缘。谓同类遍行异熟三因。余如前说。与苦集智为三缘除因者。有漏不与无漏法为因缘故。与灭道智为二缘谓等无间增上者。彼缘无漏故。余如前说。与法类智为三缘除因者。有漏与无漏非如种子故。与他心智为四缘等者。谓世俗智与自相续有漏他心智。为同类因等无间缘。与自相续无漏他心智为等无间缘。俱非所缘。与他相续有漏他心智为所缘。非因等无间。苦智与苦智及集灭智为三缘除所缘等者。如文广说。其中所以准前应知诸结欲界系彼结法智断耶。乃至广说。问何故作此论。答欲令疑者得决定故。谓法智能断色无色界结。类智不能断欲界结。或有生疑。如法智能断色无色界结。类智为亦能断欲界结耶。如类智不能断欲界结。法智为亦不能断色无色界结耶。欲令此疑得决定故。显法智定能断色无色界结。类智定不能断欲界结。故作斯论。问何故法智能断色无色界结。类智不能断欲界结耶。答法智先断欲界结故。亦能断色无色界结。类智不先断色无色界结。故不能断欲界结。复次类智未断色无色界结故。法智断之。法智已断欲界结故类智不断。复次若类智能断欲界结者。云何断耶。为先断色无色界结。后断欲界结。为先断欲界结。后断色无色界结耶。若先断色无色界结。后断欲界结者。欲界结粗先已断故。复何所断。若先断欲界结后断色无色界结者。类智则应受他诃责。自界诸结犹未能离。如何欲断他界结耶。如王未降自国怨敌欲伏他国为他所诃。复次一切类智定以法智为因故。法智能助彼断色无色界结。非一切法智定以类智为因。故类智不能助法智断欲界结。复次道类智后类智多分不现在前。设现在前势用羸劣。要毕竟离欲界结已。胜用类智方容现前故彼不能断欲界结。复次法智要离欲界结已。用方猛利。由猛利故能断上结。类智要离有顶结已。用方猛利。彼猛利时。下结已断复何所断。复次法智极猛利。断不善结尚不用功。况无记结而不能断。如极利刀尚能断铁。况草木等。类智不极猛利。断无记结尚多用功。况不善结而当能断。如以钝刀断草木等。尚多用功。况能断铁。复次法智具能断十八界十二处五蕴。如有壮士力敌千夫。能断上结。类智唯能断十四界十处五蕴。力用劣故不断下结。复次欲界邪见能缘三界苦集先断。彼已复欲断彼所缘。是故法智能断上二界结。色无色界邪见。不能缘欲界苦集。是故类智不能断欲界结。复次欲界他界缘遍行诸结。能缘色无色界苦集先断。彼已复欲断彼所缘。是故法智能断上二界结。上界他界缘遍行诸结。不缘欲界苦集。是故类智不能断欲界结。如有国王先杀怨贼。后亦坏彼游戏之处。复次欲界诸蕴逼切有情过于重担。既断彼已数复赞彼对治及灭。尔时复能断上诸蕴。是故法智能断上界结。类智不能断欲界结。然法智能断色无色界结者。是灭道法智非苦集法智。所以者何。法应尔故。谓修行者为欲界蕴现所逼切过于重担。既舍彼已报彼对治。及灭恶故。数复观察。数观察时即自然能断色无色界结。复次欲界是不定界非修地非离染地。色无色界是定界是修地是离染地非厌。不定界法能断定界结故。复次欲界是粗。色无色界是细。非厌粗界法能断细界结故。复次欲界是下劣。色无色界是胜妙非厌。下劣界法能断胜妙界结故。复次欲界是下。色界是中。无色界是上非厌。下界法能断中上界结。复次若苦集法智能断色无色界结者。便为于异处修厌离于异处得解脱。如断手系手得解脱。若断足系足得解脱。非断手系足得解脱。非断足系手得解脱。是故法智能断色无色界结者。是灭道法智非苦集法智。然灭道法智能断色无色界结者。唯生欲界非生色无色界所以者何。入出法智方便心唯欲界系生。上二界者已舍此心必不起故。复次法智随转戒。唯是欲界大种所造生。上二界者舍此大种必不起故。复次生上二界者必于法智所作已办。加行已息不复现前。如阿罗汉于三界结断对治道。所作已办不复现前。问若尔。何故诸阿罗汉起无漏智耶。答欲观所舍诸蕴过患。及观所得灭道胜利故。彼复起诸无漏智。复次彼由四缘起无漏智。一为住现法乐故。二为游戏功德故。三为观本所作故。四为受用圣财故。尊者妙音作如是说。世尊弟子生无色界。不起静虑及静虑中所发功德。生色界者亦能起之。彼说何义。彼说若生无色界者。不起法智断上界结。生色界者若未离色无色界染亦能起灭道法智断色无色界结。评曰。彼不应作是说。所以者何。若有此义应不决定。谓生色界于法智少分能起。少分不能起。少分能起者。谓灭道法智少分。不能起者。谓苦集法智。或有能起。或有不能起。或有能起者。谓未离彼染。或有不能起者。谓已离彼染。或时能起或时不能起。或时能起者。谓起离染道时。或时不能起者。谓引善根时。是故前说于理为善。诸结欲界系彼结法智断耶。答应作四句。义不定故。有结欲界系非法智断。谓欲界结。或忍断。或余智断或不断。此中或忍断者。谓四法智忍断。或余智断者。谓世俗智断。或不断者。谓已断故。或未起彼断加行故。有结法智断非欲界系。谓色无色界结法智断。即色无色界修所断结灭道法智断。有结欲界系亦法智断。谓欲界结法智断。即欲界修所断结四法智断。有结非欲界系亦非法智断。谓色无色界结。或忍断。或余智断。或不断。此中或忍断者。谓四类智忍断。或余智断者。谓类智或世俗智断。或不断者。谓已断故。或未起彼断加行故。诸结色无色界系。彼结类智断耶。答诸结类智断。彼结色无色界系。谓色无色界修所断结四类智断。有结色无色界系非类智断。谓色无色界结。或忍断。或余智断。或不断。此中或忍断者。谓四类智忍断。或余智断者。谓法智。或世俗智断。或不断者。谓已断故。或未起彼断加行故。诸结见苦所断。彼结苦智断耶。答诸结见苦所断。彼结非苦智断。或忍断。或余智断或不断。此中或忍断者。谓苦类智忍断。或余智断者。谓世俗智断。或不断者。谓已断故。或未起彼断加行故。必无苦智能断彼结。无漏智唯能断修所断故。设结苦智断。彼结见苦所断耶。答诸结苦智断。彼结非见苦所断是修所断无漏智。不能断见所断故。见集灭道所断结。对集灭道智断准上应知。唯无间道能断诸结。由此中说苦智等不能断见所断结故

说一切有部发智大毗婆沙论卷第一百七阿毗达磨大毗婆沙论卷第一百八

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    智蕴第三中修智纳息第四之四

诸结法智断彼结灭法智作证耶。乃至广说。问何故作此论。答为止他宗显正理故。谓或有执。无间道断诸结得。解脱道证彼灭得。如外国诸论师。为遮彼意显无间道能断诸结得亦证彼灭得。若无间道唯断结得。解脱道方能证彼灭得者便违此说。诸结法智断。彼结灭法智作证等。若以灭道法智究竟离非想非非想处染者。彼以法智为无间道。类智为解脱道。如何可说诸结法智断。彼结灭即法智作证耶。是故应知。无间道能断诸结得。亦证彼灭得。理不可违。由此因缘故作斯论。诸结法智断。彼结灭法智作证耶。答诸结法智断。彼结灭法智作证。谓随法智为无间道。断尔所结。此无间道即能证彼尔所灭故。有结灭法智作证彼结非法智断。谓或忍断。或余智断。彼结灭法智作证。如预流者。以世俗道断欲界一品乃至五品结已。复以法智为无间道。断第六品得一来果。尔时无间道法智。证先忍所断三界见所断结灭。及证先世俗智所断。欲界前五品修所断结灭。一来者以世俗道断欲界第七第八品结已。复以法智为无间道。断第九品得不还果。尔时无间道法智。证先忍所断三界见所断结灭。及证先世俗智所断。欲界前八品修所断结灭。不还者以世俗道或类智。离初静虑乃至无所有处染。以类智断非想非非想处八品结已。复以法智为无间道。断第九品得无学果。尔时无间道法智。证先忍所断三界见所断结灭。及证先世俗智所断欲界修所断结。灭类智世俗智所断七地修所断结灭。类智所断非想非非想处前八品修所断结灭。如是诸结灭法智作证。彼结非法智断。诸结类智断。彼结灭类智作证耶。答诸结类智断。彼结灭类智作证。谓随类智为无间道。断尔所结。此无间道即能证彼尔所灭故。有结灭类智作证。彼结非类智断谓或忍断或余智断。彼结灭类智作证如诸圣者以法智或世俗道离欲界乃至无所有处染。以法智断非想非非想处八品结已。复以类智断第九品得无学果。尔时无间道类智。证先忍所断三界见所断结灭。及证先法智世俗智所断八地修所断结灭。法智所断非想非非想处。前八品修所断结灭。如是诸结灭类智作证。彼结非类智断。诸结苦智断彼结灭苦智作证耶。答诸结苦智断彼结灭苦智作证。谓随苦智为无间道。断尔所结。此无间道即能证彼尔所灭故。有结灭苦智作证彼结非苦智断。谓或忍断。或余智断。彼结灭苦智作证。如预流者。以世俗道或集灭道智。断欲界一品乃至五品结已。复以苦智为无间道断第六品。尔时无间道苦智。证先忍所断三界见所断结灭。及证先世俗集灭道智所断欲界前五品修所断结灭。一来者以世俗道及集灭道智断欲界第七第八品结已。复以苦智为无间道。断第九品得不还果。尔时无间道苦智。证先忍所断三界见所断结灭。及证先世俗集灭道智所断。欲界前八品修所断结灭。不还者以世俗道或集灭道智。离初静虑乃至无所有处染。以集灭道智。断非想非非想处八品结已。复以苦智为无间道。断第九品得无学果。尔时无间道。苦智证先忍所断三界见所断结灭。及证先世俗集灭道智所断。八地修所断结灭。集灭道所断非想非非想处。前八品修所断结灭。如是诸结灭。苦智作证。彼结非苦智断。如说苦智说集灭道智。应知亦尔。问前门此门有何差别。答诸有欲令无间道断诸结得。解脱道证彼灭得者。彼说前门显无间道作用。此门显解脱道作用。诸有欲令无间道能断诸结得。亦证彼灭得者。彼说前门显无间道能断诸结得及证彼灭得。此门唯显无间道证诸结灭得。如断结得证彼灭得。舍过失修功德。舍无义得有义。舍下劣得胜妙。离爱染苦。证寂静乐。应知亦尔。复次前门显断有为。此门显证无为。复次前门显顿断。此门显数断。复次前门显断时即证。此门显先断后证。是谓前门此门差别眼根乃至无色界修所断无明随眠。于十智中几智知耶。乃至广说。问何故作此论。答为止他宗显正理故。谓或有执。有诸觉慧无所缘境。如取幻事健达缚城。镜像水月影光鹿爱旋火轮等。种种觉慧皆无实境。为遮彼执显诸觉慧皆实有境。或复有执。有能知智不知所知。有所知境非智所知。为遮彼执显无能知智不知所知。及无所知境非智所知。由此因缘故作斯论。若问摄应依十八界审思而答。若问识应依十二处审思而答。若问随眠应依五部审思而答。若问智应依四圣谛审思而答。如是诸法易可显示。易可施设。此中问智故应依四圣谛审思而答。然一切法略有五种。谓四谛所摄及所不摄。此中三界苦集。及道谛所摄法各有二种。谓相应及不相应。灭谛所摄法。及谛所不摄法各唯一种。谓不相应。欲界苦集谛所摄。相应法七智知。除类灭道智。不相应法六智知。除类他心灭道智。色界苦集谛所摄。相应法七智知。除法灭道智。不相应法六智知。除法他心灭道智。无色界苦集谛所摄。相应不相应法俱六智知。除法他心灭道智。灭谛所摄法六智知。除他心苦集道智。道谛所摄相应法七智知。除苦集灭智。不相应法六智知。除他心苦集灭智。谛所不摄法一智知。谓世俗智。是谓此处略毗婆沙。此中眼根七智知等。准前所说应知其相。问何故名智。答能知所知故名为智。问何故名所知。答是智所知故名所知。尊者妙音作如是说。能量故名智。所量故名所知。能称所称能度所度应知亦尔。胁尊者言能知故名智。若法是智所行所缘所取境事。说名所知。智与所知相对建立。故无有智不知所知。亦无所知非智所知。无智无所知。无所知无智如说无常想。若习若修。若多所作。能除一切欲贪。色贪。无色贪。掉举。我慢。无明。乃至广说。问何故作此论。答为广分别契经义故。谓契经说。无常想若习若修若多所作。广说如前。契经虽有是说而不分别其义。经是此论所依根本。彼未说者今应说之。故作斯论。问世尊何故说此契经。答有诸有情。心多懈怠不勤精进舍诸善轭。为劝策彼故说此经。复次为劝学者舍后有爱故说此经。谓世尊说弥勒当来成佛时事。有诸学者作是念言。愿我当见彼成佛事乃般涅槃。故佛告言。汝等今者。有诸资具少时适意故爱后有。若乏资缘为苦所逼便于诸有都不爱乐。尔时应修此无常想。永尽诸漏而般涅槃。是故不应贪爱后有。故为学者说此契经

然无常想。若习若修若多所作。能除一切欲贪者。此想应言法智相应。谓苦法智。此想应言有寻有伺。谓未至定寻伺俱生。此想应言舍根相应。谓未至定舍根俱生。此想应言与无愿俱。谓苦无愿相应。此想应言缘欲界系。谓缘欲界五蕴。能除一切色贪者。此想应言类智相应。谓苦类智。此想应言。或有寻有伺。谓未至定及初静虑寻伺俱生。或无寻唯伺。谓静虑中间唯伺俱生。或无寻无伺。谓在后三静虑。此想应言。或乐根相应。谓在第三静虑。或喜根相应。谓在初二静虑。或舍根相应。谓在未至定静虑中间第四静虑。此想应言与无愿俱。谓苦无愿相应。此想应言缘色界系。谓缘色界五蕴。能除一切无色贪者。此想应言类智相应。谓苦类智。或有寻有伺。或无寻唯伺。或无寻无伺。乐喜舍根相应与无愿俱。缘无色界系。如前能除色贪想说有差别者。此想或无寻无伺。谓在后三静虑。及前三无色。或舍根相应。谓在未至定静虑中间第四静虑及前三无色。缘无色界系。谓缘无色界四蕴。能除一切掉举我慢无明者。此想应言法类智相应。谓苦法类智。此想应言。或有寻有伺。或无寻唯伺。或无寻无伺。乐喜舍根相应与无愿俱。皆如前能除无色贪想说。此想应言。或缘欲界系。谓缘欲界五蕴。或缘色界系。谓缘色界五蕴。或缘无色界系。谓缘无色界四蕴

问一切圣道皆能断结。何故唯说无常想耶。答此中想声显诸圣道。谓佛或时以受声想声思声意声灯声信精进念定慧声船筏声山石声水声花声慈悲喜舍声。显诸圣道。广说如前。此中亦尔故不应难。问无常想唯能对治二部烦恼。谓见苦及修所断。何故此中说能除一切三界贪等。答此中但应说能除三界贪等。不应说一切。而说一切者。一切有二种。谓少分一切。及一切一切。此中但说少分一切。谓见苦及修所断一切非余。复次佛为圣者说此契经。彼已永断见所断结。劝彼修习此无常想。令断一切三界修所断结故无有过。问无常想能对治七随眠。何故此中唯说能断贪慢无明。答由此三种通三界遍五部。是故偏说。五见及疑虽通三界而不遍五部。嗔虽遍五部而不通三界。故不说之。复次由此三种通三界异生圣者。俱可现行。是故偏说。五见及疑虽通三界。而诸圣者必不现行。嗔虽异生圣者俱可现行。而不通三界。是故不说。问何故贪分三界差别而掉举等不然。答彼亦应分三界差别。而不分者应知有余。复次欲现异说异文庄严于义。令受持者生欣乐故。复次欲现二门二略。乃至广说。复次贪爱是重难断难破。多诸过患。是故偏分。复次以贪爱故诸界诸地诸部差别。是故偏分。问修无常想能除七慢。何故此说唯除我慢。答此中且说近对治故。谓无常想是我慢近对治。如契经说。若诸苾刍。修无常想者能引无我想。若住无常无我想者。能断我慢速尽诸漏。问何故一切随烦恼中唯说掉举。答随烦恼中过患增者唯有掉举。谓通三界是缠性摄。惛沈虽具如是二义。而在上界顺等至故。过患不增。是故此中偏说掉举。如说七处善三义观。能于此法毗奈耶中速尽诸漏。云何为七。谓如实知色色集色灭趣色灭行色味色患色出。如实知受想行识七亦尔。此智当言法智乃至道智耶。乃至广说。问何故作此论。答为广分别契经义故。谓契经说。苾刍当知。有七处善及三义观。广说如前。契经虽作是说而不分别其义。经是此论所依根本。彼未说者今应说之。故作斯论。问世尊何故说此契经。答有诸学者已入见道。住修道中为修所断烦恼所恼。世尊欲令修彼对治。告言。汝等已得圣道。何不依之断余烦恼。如勇健人为怨所恼。他人告曰汝既勇健。宁不害怨而为彼恼。复次有诸学者已得初果。于后胜果不作加行。设作加行不如实知。世尊欲令起胜加行告言。汝等若能不舍先得预流诸加行者。不久必获究竟漏尽。佛为彼故说此契经

如实知色是四智。谓法类世俗苦智者。此中法智知欲界色果。类智知色界色果。世俗智知一切色果。苦智知有漏色果非常苦空非我。此虽有四而立一善。皆同观察一色果故。如实知色集是四智。谓法类世俗集智者。此中法智知欲界色因。类智知色界色因。世俗智知一切色因。集智知有漏色因集生缘。此虽有四而立一善。皆同观察一色因故。如实知色灭是四智。谓法类世俗灭智者。此中法智知欲界色灭。类智知色界色灭。世俗智知一切色灭。灭智知有漏色灭静妙离。此虽有四而立一善。皆同观察一色灭故。如实知趣色灭行是四智。谓法类世俗道智者。此中法智知欲界色对治道。类智知色界色对治道。世俗智知一切色对治道。道智知有漏色对治道如行出。此虽有四而立一善。皆同观察一色道故。如实知色味是四智。谓法类世俗集智者。此中四智皆知色味如前应知。此虽有四而立一善。皆同观察一色集故。如实知色患是四智。谓法类世俗苦智者。此中四智皆知色患如前应知。此虽有四而立一善。皆同观察一色苦故。如实知色出是四智。谓法类世俗灭智者。此中四智皆知色出如前应知。此虽有四而立一善。皆同观察一色灭故。如实知受想行识七亦尔者。如观色说。问若尔。应说三十五处善。或无量处善何故说七。答观一一蕴各各有七。不过七数故说有七。如余经说。诸预流者极七反有。彼若别说二趣二有应二十八。谓人趣有七天趣有七。人中有七天中有七。然不过七故说七名。又如余经说有二法。谓眼色乃至意法。又如余经说三转法轮有十二行相。彼不过二及十二故说二十二。此亦如是。胁尊者言。此经应说如实知色乃至识。如实知色集乃至识集。如实知色灭乃至识灭。如实知趣色灭行乃至趣识灭行。如实知色味乃至识味。如实知色患乃至识患。如实知色出乃至识出。若作是说唯有七处善。非三十五或无量种。复次若略说有七处善。若广说有三十五或无量种。契经略说故唯有七。如略广总别。不分别分别顿说渐说应知亦尔。复次为利根者说七处善。为钝根者说三十五或无量种。如利根钝根。因力缘力内分力外分力。内思惟力外闻法力。开智说智应知亦尔。复次依近观察说七处善。依远观察说三十五或无量种。如近远邻逼非邻逼现前非现前。此众同分余众同分应知亦尔。复次依无漏观说七处善。依有漏观说三十五或无量种。如有漏无漏。世出世缚解。系不系应知亦尔。复次依现观时说七处善。依观察时说三十五或无量种。复次依总相观故说七处善。依别相观故说三十五或无量种。如总相别相观。自相共相观。自相共相觉。自相共相作意应知亦尔

问此中为说自相作意。为说共相作意耶。设尔何失。若说自相作意者。此中所说当云何通。如说七处善三义观。能于此法毗奈耶中。速尽诸漏非自相作意可能尽漏。若说共相作意者。此中所说复云何通。如说如实知色乃至如实知识。答应作是说。此中正说自相作意。问若尔云何能速尽漏。答此自相作意能引共相作意。彼共相作意能速尽漏。依展转因故作是说。复有说者。此中正说共相作意。问若尔云何此契经说。如实知色乃至如实知识耶。答此契经中应作是说。如实知蕴蕴集蕴灭趣蕴灭行蕴味蕴患蕴出。而别说者。应知说时异。现观时异。如佛为四天王先以圣语说四圣谛。二解二不解等如前已说。故知说时异现观时异。谓说时别说。现观时总现观故。问七处善三义观有何差别。答名即差别。谓名七处善。名三义观故。有作是说。七处善是无漏。三义观是有漏。问若尔此说当云何通。如实知色是四智。谓法类世俗苦智等。答此世俗智虽亦容有而不现行。复次此七处善是圣行相。说为无漏实通有漏。对三义观非圣行相。唯是有漏故名无漏。问为能以七处善入三义观耶。答不能以七处善是无漏行相。三义观是有漏行相故。复有说者。七处善通有漏无漏。三义观唯有漏。问为能以七处善入三义观耶。答能。然多用功力。多起作意。多作加行。谓如实知色乃至识。如实知色患乃至识患而入蕴观。如实知色集乃至识集。如实知色味乃至识味而入处观。如实知色灭乃至识灭。如实知色出乃至识出而入界观。虽能如是以七处善入三义观。而多用功力。多起作意。多作加行。问三义观在前七处善在后。世尊何故先说七处善。后说三义观耶。答虽三义观在前七处善在后。而先说七处善后说三义观者。于说于文皆随顺故。复次如是次第说者受者皆随顺故。复次若作是说。于文于义皆圆满故。若先说三义观。后说七处善者。则于义虽圆满而于文不圆满。尊者妙音作如是说。应前说者则前说之。应后说者则后说之二俱无过。以三义观位别有二。一在见道前。二在修道前。见道前者此中不说。修道前者此中说之。如见道修道。见地修地未知当知根已知根应知亦尔。胁尊者言。此中说四地。谓修行地见地修地无学地。如说七处善三义观者说修行地。如实知色色集色灭趣色灭行乃至识亦尔者说见地。如实知色味色患色出乃至识亦尔者说修地。速尽诸漏者说无学地。问何故见道中说四处善。修道中但说三处善耶。答以见道处所决定对治决定非修道故。复次以见道所缘决定对治决定非修道故。复次以见道初得见谛初得现观。修道已得见谛已得现观故。复次以见道初得圣种性初得圣行相。修道已得圣种性已得圣行相故。问何故于此七处善中。再说前三谛。一说道谛耶。答此中道谛数分别故。谓如实知色乃至识。此如实知皆是道谛。如实知色集乃至识集。色灭乃至识灭趣。色灭行乃至趣识灭行。色味乃至识味。色患乃至识患。色出乃至识出。此如实知亦皆是道谛。既于道谛数分别故不再说之。复次有已生苦有未生苦。有已生苦因有未生苦因。有已生苦灭有未生苦灭。如是诸法唯有道谛能知断证。故说三谛则已说道。复次有近苦有远苦。有近苦因有远苦因。有近苦灭有远苦灭。如是诸法唯有道谛能知断证。故说三谛则已说道。复次三谛有边是故再说。道谛无边故唯一说。问因论生论。何故三谛说有边而道谛说无边耶。答苦可尽知。集可尽断。灭可尽证。道不可尽修故。余义广说。如现观边世俗智处。复次前四处善说见道位。见道必具观察四谛故具说四。后三处善说修道位。修道位中所修圣道即是道谛。未必具观四圣谛故但说三种。复次一切贤圣皆厌苦集欣乐涅槃。圣道不尔。是故世尊再说三谛一说道谛。问何故见道中先说苦谛后说集谛。而修道中先说集谛后说苦谛耶。答见道中依现观次第。修道中依因果次第故作是说。复次见道中依见次第。修道中依说次第故作是说。以见次第先果后因。说次第先因后果故。复次佛依修道为爱行者。说断爱法作如是言。汝等先应观察诸蕴味。观察味已见味过患。见过患已能速出离。复次修道位中已于生死有分齐故不多厌苦。但为烦恼扰浊心故多厌烦恼。诸烦恼中爱数行故多分厌爱。故修道中先观爱味。次观爱患。后观爱出。复次爱于现在最能引心驰流诸境。爱于未来最能润有令不断绝。故诸圣者厌爱心增。修道位中先观爱味。次观爱患。后观爱出。问何故世尊令所化者数数观察所知境界。答无始时来迷所知境失于正道。沉沦生死受种种苦。世尊欲令悟所知境趣于正道。超出生死离种种苦。故令数观所知境界。此中要者。谓七处善及三义观。问先集后味有何差别。答名即差别。谓名色等集。名色等味故。复次集通六识味唯意地。复次集通染污不染污。味唯染污。复次集通三界味唯欲界。复次集通业烦恼味唯烦恼。复次集通诸烦恼。味唯是爱是谓差别。问诸蕴集为是一为有异耶。设尔何失。若是一者契经所说当云何通。如说喜集故有色集触集故有三蕴集。名色集故有识集。若有异者。施设论说复云何通。如说此爱若过去若未来若现在。皆是苦因。苦根本苦道路。苦由绪。苦能作。苦生苦缘。苦有苦集。及苦等起。答应作是说。有别缘故诸蕴集是一。有别缘故诸蕴集有异。谓依远因故诸蕴集是一。依近因故诸蕴集有异。如依远近在彼在此不现前现前。余身众同分此身众同分应知亦尔。复次契经中说三种集异一烦恼。集二苦。集三业。集谓喜集故有色集者说烦恼集。触集故有三蕴集者说苦集。名色集故有识集者说业集。此经中说业名色故。如说烦恼苦业集烦恼。苦业有烦恼。苦业生烦恼。苦业路应知亦尔。复次契经中说三时有异。一积集时。二受用时。三守护时。谓喜集故有色集者说积集时。触集故有三蕴集者说受用时。名色集故有识集者说守护时。复次此中别说三时有异。一将和合时。二正和合时。三不别离时。谓喜集故有色集者说将和合时。触集故有三蕴集者说正和合时。名色集故有识集者说不别离时。复次此契经中说三有异。一中有。二本有。三生有。谓喜集故有色集者说中有。触集故有三蕴集者说本有。名色集故有识集者说生有。复次喜集故有色集者说名缘色。触集故有三蕴集者说名缘名。名色集故有识集者说名色缘名。复次以爱希求未来诸有身分自体故。世尊说喜集故有色集。触能长养心心所法。任持牵引令现在前。故世尊说触集故有三蕴集。识依名色增长广大。故世尊说名色集故有识集。问先苦后患有何差别。答名即差别。谓名色等苦。名色等患故。复次苦通三受。患唯苦受。复次苦通染污不染污患唯染污。复次苦通三界患唯欲界。复次苦通烦恼业苦患唯烦恼。复次苦通诸烦恼。患唯在爱。是谓差别。色乃至识灭。色乃至识出。何差别耶。答若由此爱诸色集起。彼断名色灭。若诸余爱缘色增广。彼断名色出乃至广说。问何故此中问色等灭而答爱等灭耶。答因断故果随断。因灭故果随灭。因息故果随息。舍因故亦舍果。吐因故果亦吐。若断道路诸有不续。色等永灭便至苦边故。问色等灭而答爱等灭。问何故此中已生爱等断名灭。未生爱等断名出耶。答已生烦恼业已有所作。已障圣道。已取果。已与果。已为同类遍行异熟因。已取等流异熟果。于自相续已作染污。已作系缚。已作苦事。但可断灭。不可出离故说为灭。未生烦恼业与上相违。可出离故说之为出。如三苦事。一者已受。二者正受。三者当受。已正受者不可出离。当应受者或以自力。或以他力。或财物力而可出离。问何故此中三说爱。再说余烦恼业耶。答以爱难断难破。难可越度多诸过患。甚可诃责故三说之。如诸贼女人与余恶法。总诃厌已复别诃厌。复次由爱力故界别地别部别。一切烦恼因爱而生。因爱增长故三说之。问何故诸处以种种问。数数分别灭谛非余。答以此灭谛一切法中最胜最妙。四圣谛中亦最胜妙故多分别。问何故此中但问答分别灭出差别非集味苦患耶。答亦应说彼二种差别。而不说者是有余说。复次此中以后显示于前。谓问答分别灭出差别。应知前二亦应说之。复次灭谛最胜故偏分别苦集非胜故不说之

说一切有部发智大毗婆沙论卷第一百八阿毗达磨大毗婆沙论卷第一百九

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    智蕴第三中七圣纳息第五之一

随信行乃至俱解脱。于八智几成就。几不成就。如是等章及解章义。既领会已次应广释。问何故作此论。答为止他宗显正理故。谓或有执。无实成就不成就性。为遮彼执显成就性不成就性体俱实有故作斯论。问何故此中及后定蕴俱依七种补特伽罗而作论。前于结蕴不善纳息。唯依五种补特伽罗而作论耶。答是作论者意欲尔故。乃至广说。复次前结蕴中依有结者而作论故。不说后二补特伽罗。此及定蕴依有智定补特伽罗。而作论故亦说后二。复次前结蕴中以补特伽罗为章。以烦恼为门故不说后二。此及定蕴以补特伽罗为章。以智定为门故亦说后二。以慧解脱及俱解脱虽无烦恼。而有智定故具说七补特伽罗。广辩七种补特伽罗如前结蕴不善纳息答随信行于八智。或成就一二三四五六七八义不定故。谓苦法智忍时无他心智一。有他心智二者。若未离欲染入正性离生。不成就他心智故名无他心智。彼成就一世俗智。若已离欲染入正性离生。成就他心智故名有他心智。彼成就世俗他心二智。苦法智苦类智忍时。无他心智三有他心智四者。此二心顷若不成就他心智但成就三。谓法智苦智世俗智。若成就他心智则成就四。谓前三加他心智。后位增智准前应知。随法行亦尔者。如随信行或成就一乃至八故。以此二圣地等道等所依身等离染亦等。唯根有异。谓随信行是钝根摄。若随法行是利根摄。信胜解于八智或成就七八。谓无他心智七。有他心智八者。谓未离欲染不成就他心智故唯成就七。若已离欲染亦成就他心智故具成就八。见至亦尔者如信胜解。或成就七。或具八故。以此二圣地。等道等所依身等离染亦等。唯根有异准前应知。身证慧解脱俱解脱。于此八智皆成就者。以此三圣皆已离欲染具成就八智故

随信行乃至俱解脱。于八智成就过去几未来几现在几。问何故作此论。答为止他宗显正理故。谓或有执过去未来俱非实有。为遮彼执显彼实有。复次前虽总说成就八智。未依三世分别多少。今欲说之故作斯论。答随信行于八智。苦法智忍时无他心智过去未来一。现在无有他心智过去未来二。现在无者无他心智有他心智义如前说。一谓世俗智。二谓世俗他心智。忍非智故现在都无。苦法智时。无他心智过去一者。谓世俗智未来三者。谓法智苦智世俗智。现在二者谓法智苦智。有他心智过去二未来四。现在二者过去未来加他心智现在不加。以他心智见道决定无容现前亦不修故。后位增智准前应知。随法行亦尔者。此二地等广说如前。信胜解于八智。无他心智未来七。有他心智未来八。过去若已灭不失。现在若现在前者。过去若已灭非得果练根及退故失则成就。若未已灭设已灭三缘故。失则不成就。此说无漏智。或他心智非世俗智。以世俗智过去未来定成就故现在或一或二或三。若无心时都不成就。见至亦尔者准前应知。身证等三如文具说。已灭不失谓若已灭非练根等及退故失则成就

随信行乃至俱解脱。法智乃至道智现在前时。几智现在前耶。问何故作此论。答为止他宗显正理故。谓或有执。诸智虽可一一现前不得有二。为遮彼执显智现前或一或二或复三种。有余复执。入现观时总观四谛。四智顿起为遮彼执显现观时。各别观谛无二谛智俱时起义况得起多。或复有执。多识俱生多智并起。为遮彼执显一有情一刹那中唯起一识。智体亦尔故作斯论。答随信行法智现在前时。二智现在前。谓法苦智二。广说乃至道智现在前时二智现在前。谓道法智。二者谓见道位七智现在前时。一一刹那智体虽一而义说二。谓对治故或名法智或名类智。行相故或名苦智乃至或名道智。随法行亦尔者。此二地等广说如前。信胜解法智现在前时。或二三智现在前。谓法苦智二广说乃至道智现在前时。或二三智现在前。谓道法智非他心智二。是他心智三。道类智非他心智二。是他心智三者。谓修道位诸智现在前时。一一刹那智体虽一。而义说二或义说三。谓无漏智现在前时。若苦集灭智及他心智所不摄道智但义说二。谓对治故或名法智。或名类智。行相故或名苦智。乃至或名道智。若他心智所摄道智则义说三。谓对治故或名法智或名类智。行相故名道智。加行故名他心智。有漏智现在前时。若非他心智则唯一智。谓世俗智。若是他心智则义说二。谓自性故名世俗智。加行故名他心智。见至身证亦尔者。谓位等故诸智现前义相似故。慧解脱法智现在前时。或二三智现在前。谓法苦智。非尽无生智二。是尽或无生智三。广说乃至道智现在前时。或二三智现在前。谓道法智。非尽无生他心智二。是尽或无生或他心智三。道类智非尽无生他心智二。是尽或无生或他心智三者。谓无学位诸智现在前时。一一刹那智体虽一而义说二。或义说三。谓无漏智现在前时若尽无生智所不摄苦集灭智。及尽无生他心智所不摄道智但义说二。谓对治故或名法智。或名类智。行相故或名苦智。乃至或名道智。若尽或无生智所摄苦集灭智。及尽或无生。或他心智所摄道智则义说三。谓对治故或名法智。或名类智。行相故或名苦智。乃至或名道智。事办故或名尽智。因圆故或名无生智。加行故或名他心智。有漏智现在前时。若非他心智则唯一智。谓世俗智若是他心智则义说二。谓自性故名世俗智。加行故名他心智。问何故尽智无生智他心智体不相杂耶。答尽无生智非见自性。他心智是见自性故不相杂。尽智无生智所起行相互有异故亦不相杂。谓苦我已知等是尽智所起行相。不复当知等是无生智所起行相。俱解脱亦尔者。谓位等故。随信行乃至俱解脱于三三摩地几成就几不成就问何故作此论。答为止他宗显正理故。谓或有执。三三摩地体唯是一义说三种。为遮彼执显此三种自性各异故作斯论。答随信行于三三摩地。灭法智忍未已生成就二。已生成就三者。谓灭法智忍未现在前但成就空无愿二。苦法智忍时二双修故。灭法智忍已生。乃至道类智忍现在前时皆成就三。复成就无相故。随法行亦尔者。此二地等广说如前。信胜解乃至俱解脱于三三摩地皆成就者已具得故

随信行乃至俱解脱。于三三摩地。成就过去几未来几现在几。答随信行于三三摩地。若依空入正性离生苦法智忍时。过去无。未来二现在一。广说乃至灭法智。乃至道类智忍时过去二。未来三。现在一者。谓若依空入正性离生。见苦初心顷过去无。见苦四心顷现在一。谓空见苦后三心顷。及见集初心顷过去一。谓空见集后三心顷。见灭初心顷过去二。谓空无愿见苦见集各四心顷未来二。谓空无愿见灭四心顷现在一。谓无相见集四心顷见道三心顷现在一。谓无愿见灭后三心顷。见道三心顷皆过去具三。见灭四心顷见道三心顷皆未来亦具三。若依无愿入正性离生应知亦尔。有差别者。谓过去定无。空唯有一或二见苦见集各四心顷见道三心顷皆现在一。谓无愿。问何等补特伽罗依空入正性离生。何等补特伽罗依无愿入正性离生耶。答若见行者依空入正性离生。若爱行者依无愿入正性离生。唯除菩萨。虽是爱行而依空入正性离生。又见行者复有二种。着我见者依非我行相入正性离生。着我所见者依空行相入正性离生。诸爱行者亦有二种。我慢增者依非常行相入正性离生。懈怠增者依苦行相入正性离生。复次若利根者多依空入正性离生。若钝根者多依无愿入正性离生。如利根钝根乃至开智说智应知亦尔。若依无愿入正性离生者。彼或依无愿无相离三界染尽众同分空不现前。随法行亦尔者。此二地等广说如前。信胜解乃至俱解脱。于三三摩地皆未来三。过去若已灭不失。现在若现在前者。此皆准前应知其相。随信行乃至俱解脱空无愿无相三摩地现在前时。几智现在前耶。答随信行空三摩地现在前时。或二或无。广说乃至俱解脱亦尔者。谓见道中忍时无智。智时有二智。修道中苦集灭智时有二智。道智时或二或三智。无学道中苦集灭智。无学正见摄者一一有二智。非无学正见摄者。一一有三智。道智若非无学正见摄者有三智。若是无学正见摄他心智者亦有三智。即此若非他心智者唯有二智。问何故尽无生智不与空三摩地相应耶。答行相异故。谓空行相非尽无生智。若尽无生智行相非空。复次空三摩地与见相应。尽无生智非见性故。复次空三摩地自性是胜义。所起行相亦是胜义。尽无生智自性虽是胜义。而所起行相非胜义。谓此智后作是念言。我生已尽等有我行相是世俗摄非胜义故

随信行乃至俱解脱。三无漏根七觉支八道支随应现在前时。几智现在前耶。答随信行未知当知根现在前时。或二或无。广说乃至俱解脱亦尔者。谓见道中八忍时全无智。七智时各有二智。修道中苦集灭智时各有二智。道智时或有二智或有三智。无学道中苦集灭道智。皆或有二智或有三智准前应知。问此中数说慧解脱者起他心智。此起必依根本静虑。若慧解脱亦能现起根本静虑。岂不违害苏尸摩经。彼经中说。慧解脱者不能现起根本静虑。答慧解脱有二种。一是少分。二是全分。少分慧解脱于四静虑能起一二三。全分慧解脱于四静虑皆不能起。此论中说少分慧解脱。故能起他心智。苏尸摩经说全分慧解脱。彼于四静虑皆不能起。如是二说俱为善通。由此少分慧解脱者。乃至能起有顶等至但不得灭定。若得灭定名俱解脱。诸法法智相应。彼法类智相应耶。乃至广说。问何故作此论。答为止他宗显正理故。谓或有执。心心所法。一一而生无相应义。为遮彼执显心心所必俱时生有相应义。或复有执。心心所法前后相应。有余复执。自性与自性相应。为遮彼执显相应者必俱时生。别有自体故作斯论。此中诸法由三缘故。互相交涉对显相应。谓或有法由相摄故。互相交涉如智与智。或复有法由相应故互相交涉如智与三摩地。或复有法由相摄相应故互相交涉如智与根觉支道支。是谓此处略毗婆沙。诸法法智相应。彼法类智相应耶。答不尔。设法类智相应。彼法法智相应耶。答不尔。所以者何。非一心故。所缘异故。对世俗智亦尔。所以者何。非一心故。有漏无漏聚各异故。诸法法智相应。彼法他心智相应耶。答应作四句。义不定故。有法法智相应非他心智。谓他心智所不摄法智相应法。此法是何。谓苦集灭法智。及他心智所不摄道法智相应法。有法他心智相应非法智。谓法智所不摄他心智相应法。此法是何。谓类智世俗智所摄他心智相应法。有法法智相应亦他心智。谓法智所摄他心智相应法。此法是何。谓此相应九大地法。十大善地法。寻伺及心。有法非法智相应。亦非他心智。谓法智他心智。及法智他心智不摄不相应诸余心心所法。色无为心不相应行。此中法智他心智者。自性与自性不相应故。及法智他心智不摄不相应。诸余心心所法者不摄。除彼自性不相应。除彼相应。取诸余心心所法。此法是何。谓苦集灭类智他心智所不摄。道类智相应聚。无漏忍相应聚。他心智不相应一切有漏心心所法。色无为心不相应者。谓一切色无为心不相应行。皆非法智相应亦非他心智无所缘故。对苦集灭道智及正见亦尔者。如法智对他心智作四句。此对苦集灭道智及八道支中正见亦尔

诸法法智相应彼法空三摩地相应耶。答应作四句。此中法智与三三摩地相应。空三摩地与二智二忍相应。二智者。谓苦法智苦类智。二忍者。谓苦法智忍苦类智忍。是故此中作大四句。有法法智相应非空。谓法智相应空。及空不相应法智相应法。此中法智相应空者。谓法智俱生空三摩地。此与法智相应非空。自性与自性不相应故。及空不相应法智相应法者。谓无愿无相俱生法智相应法。有法空相应非法智。谓空相应法智。及法智不相应。空相应法。此中空相应法智者。谓空俱生法智。此与空相应非法智。自性与自性不相应故。及法智不相应空相应法者。谓苦类智及苦忍俱生空三摩地相应法。有法法智相应亦空。谓二相应法。此中二相应法者。谓法智空俱生聚中。除二自性。诸余心心所法。此法是何。谓二相应八大地法。十大善地法。寻伺及心。有法非法智相应亦非空。谓法智不相应空。空不相应法智。及法智空不摄。不相应。诸余心心所法色无为心不相应行。此中法智不相应空者。谓苦类智及苦忍俱生空三摩地。此非法智相应是他聚故。亦非空相应。自性与自性不相应故。空不相应法智者。谓无愿无相俱生法智。此非空相应是他聚故。亦非法智相应。自性与自性不相应。及法智空不摄不相应。诸余心心所法者不摄。除二自性不相应。除二相应。取诸余心心所法。此法是何。谓法智不相应无愿无相相应聚。及一切有漏心心所法。色无为心不相应行者。谓一切色无为心不相应行。皆非法智相应。亦非空无所缘故。对无愿无相喜觉支正思惟亦尔者。如法智对空作大四句。此对无愿无相喜觉支正思惟亦尔

诸法法智相应。彼法未知当知根相应耶。答应作四句义不定故。有法法智相应非未知当知根。谓未知当知根所不摄法智相应法。此法是何。谓已知根具知根所摄法智相应法。此与法智相应非未知当知根。是他聚故。有法未知当知根相应非法智。谓未知当知根所摄法智。及法智不摄不相应未知当知根相应法。此中未知当知根所摄法智者。谓未知当知根俱生聚中法智。此与未知当知根相应非法智。自性与自性不相应故。及法智不摄不相应未知当知根相应法者。谓诸类智及无漏忍俱生聚中。未知当知根相应法。此与未知当知根相应非法智。是他聚故。有法法智相应亦未知当知根。谓未知当知根所摄法智相应法。此法是何。谓余八根及彼相应。余非根心所法。有法非法智相应亦非未知当知根。谓未知当知根所不摄法智。及法智未知当知根不摄不相应。诸余心心所法。色无为心不相应行。此中未知当知根所不摄法智者。谓已知根具知根俱生聚中法智。此非法智相应。自性与自性不相应故。亦非未知当知根相应。是他聚故。及法智未知当知根不摄不相应。诸余心心所法者。谓法智不摄不相应。已知根具知根俱生聚中心心所法。及一切有漏心心所法。皆非法智相应。亦非未知当知根。是他聚故。色无为心不相应行者。谓一切色无为心不相应行皆俱不相应。无所缘故。对已知具知根亦尔者。如法智对未知当知根有四句。此对已知根具知根亦尔

诸法法智相应彼法念觉支相应耶。答应作四句义不定故。有法法智相应非念谓法智相应念觉支。此与法智相应非念。自性与自性不相应故。有法念觉支相应非法智。谓法智及法智不相应念觉支相应法。此中法智者。谓念觉支俱生法智。此与念觉支相应非法智。自性与自性不相应故。及法智不相应。念觉支相应法者。谓无漏忍及类智俱生聚中念觉支相应法。此与念觉支相应非法智。是他聚故。有法法智相应亦念。谓二相应法即法智俱生聚中除法智及念。诸余心心所法与二相应。此复是何。谓二相应八大地法。十大善地法。寻伺及心。有法非法智相应亦非念。谓法智不相应念觉支。及余心心所法。色无为心不相应行。此中法智不相应念觉支者。谓无漏忍类智俱生聚中念觉支。此非法智相应是他聚故。亦非念相应。自性与自性不相应故。及余心心所法者。此非无漏心心所法。但是有漏心心所法。色无为心不相应行者。谓一切色无为心不相应行。皆俱不相应无所缘故。对精进轻安定舍觉支正精进正念正定亦尔者。如法智对念觉支有四句。此对精进觉支乃至正定亦尔。诸法法智相应。彼法择法觉支相应耶。答诸法法智相应。亦择法觉支法智。皆是择法觉支摄故。有法择法觉支相应非法智。谓法智所不摄择法觉支相应法。此法是何。谓无漏忍类智俱生聚中择法觉支相应法。此与择法觉支相应非法智。是他聚故。如法智对后。类智对后亦尔者。如法智对类智。乃至正定类智对他心智乃至正定亦尔。诸法他心智相应。彼法世俗智相应耶。答应作四句义不定故。有法他心智相应非世俗智。谓世俗智所不摄他心智相应法。此法是何。谓无漏他心智相应法。有法世俗智相应非他心智。谓他心智所不摄世俗智相应法。此法是何。谓他心智所不摄。诸善染污无覆无记世俗智相应法。有法他心智相应亦世俗智。谓他心智所摄世俗智相应法。此法是何。谓此相应。九大地法。十大善地法寻伺及心。有法非他心智相应。亦非世俗智。谓他心世俗智及他心世俗智不摄不相应。诸余心心所法。色无为心不相应行。此中他心世俗智者。自性与自性不相应故。及他心世俗智不摄不相应。诸余心心所法者。谓无漏忍苦集灭智。及他心智所不摄道智俱生聚心心所法。俱不相应是他聚故。色无为心不相应行者。谓一切色无为心不相应行俱不相应无所缘故。对道智择法觉支正见亦尔者。如他心智对世俗智有四句。此对道智择法觉支正见亦尔。诸法他心智相应。彼法苦智相应耶。答不尔。设法苦智相应彼法他心智相应耶。答不尔。对集灭智空无相三摩地未知当知根亦尔者。非一心故。或行相异故。或所缘异故。诸法他心智相应。彼法无愿三摩地相应耶。答应作四句义不定故。有法他心智相应非无愿。谓他心智相应无愿及无愿不相应他心智相应法。此中他心智相应无愿者。谓他心智俱生无愿。此与他心智相应非无愿。自性与自性不相应故。及无愿不相应他心智相应法者。谓有漏他心智相应法。此与他心智相应非无愿是他聚故。有法无愿相应非他心智。谓无愿相应他心智。及他心智不相应无愿相应法。此中无愿相应他心智者。谓无愿俱生他心智。此与无愿相应非他心智。自性与自性不相应故。及他心智不相应无愿相应法者。谓苦集无愿。及他心智不相应。道无愿相应法。此无愿相应非他心智是他聚故。有法他心智相应亦无愿。谓二相应法。即无漏他心智俱生聚中。除他心智及无愿三摩地。诸余心心所法。此法是何。谓八大地法。十大善地法寻伺及心。有法非他心智相应。亦非无愿。谓他心智不相应无愿。无愿不相应他心智。及诸余心心所法。色无为心不相应行。此中他心智不相应无愿者。谓苦集无愿及他心智不相应道无愿。此非他心智相应是他聚故。亦非无愿相应。自性与自性不相应故。无愿不相应他心智者。谓有漏他心智此非无愿相应是他聚故。亦非他心智相应。自性与自性不相应故。及诸余心心所法者。谓空无相俱生聚中。心心所法及他心智不摄不相应有漏心心所法。此俱不相应是他聚故。色无为心不相应行者。谓一切色无为。心不相应行。此俱不相应无所缘故。对念精进喜轻安定舍觉支正思惟正精进正念正定亦尔者。如他心智对无愿有四句。此对六觉支四道支亦尔

诸法他心智相应。彼法已知根相应耶。答应作四句义不定故。有法他心智相应。非已知根。谓已知根所不摄他心智相应法。此法是何。谓具知根所摄他心智相应。及有漏他心智相应心心所法。此法他心智相应非已知根是他聚故。有法已知根相应。非他心智。谓已知根所摄他心智。及他心智不摄不相应已知根相应法。此中已知根所摄他心智者。谓修道中无漏他心智。此与已知根相应非他心智。自性与自性不相应故。及他心智不摄不相应已知根相应法者。谓修道中苦集灭智俱生聚。及他心智所不摄道智。俱生聚中心心所法。此与已知根相应非他心智是他聚故。有法他心智相应亦已知根。谓已知根所摄他心智相应法。此法是何。谓修道中无漏他心智相应法。即此相应八无漏根。及彼相应余非根心所法。有法非他心智相应。亦非已知根。谓已知根所不摄他心智。及他心智已知根不摄不相应。诸余心心所法。色无为心不相应行。此中已知根所不摄他心智者。谓具知根所摄他心智。及有漏他心智。此非他心智相应。自性与自性不相应故。亦非已知根相应是他聚故。及他心智已知根不摄不相应。诸余心心所法者。谓未知当知根俱生聚心心所法。他心智不摄不相应。具知根俱生聚心心所法。他心智不摄不相应。有漏心心所法。此俱不相应是他聚故。色无为心不相应行者。谓一切色无为。心不相应行俱不相应无所缘故。对具知根亦尔者。如他心智对已知根有四句。此对具知根亦尔。诸法世俗智相应彼法苦智乃至正定相应耶。答不尔。设法苦智乃至正定相应。彼法世俗智相应耶。答不尔。所以者何。非一心故。苦智乃至正定皆无漏故

诸法苦智相应。彼法集智相应耶。答不尔。设法集智相应。彼法苦智相应耶。答不尔。对灭道智无相三摩地亦尔。所以者何。非一心故。行相异故。或所缘异故。诸法苦智相应。彼法空三摩地相应耶。答应作四句义不定故。有法苦智相应非空。谓苦智相应空。及空不相应苦智相应法。此中苦智相应空者。谓苦智相应空三摩地。此与苦智相应非空。自性与自性不相应故。及空不相应苦智相应法者。谓无愿俱生苦智相应法。此与苦智相应非空是他聚故。有法空三摩地相应非苦智。谓空相应苦智。及苦智不相应空相应法。此中空相应苦智者。谓空三摩地俱生苦智。此与空相应非苦智。自性与自性不相应故。及苦智不相应空相应法者。谓苦忍俱生空相应法。此与空相应非苦智是他聚故。有法苦智相应亦空。谓二相应法。此法是何。谓苦智相应空。俱生聚中除苦智及空。诸余心心所法。即八大地法。十大善地法寻伺及心。有法非苦智相应。亦非空。谓苦智不相应空。乃至广说。此中苦智不相应空者。谓苦忍俱生空。此非苦智相应是他聚故。亦非空相应。自性与自性不相应故。空不相应苦智者。谓无愿俱生苦智。此非苦智相应。自性与自性不相应故。亦非空相应是他聚故。及诸余心心所法者。谓苦智不相应无愿俱生聚心心所法。无相俱生聚心心所法。一切有漏心心所法。此俱不相应是他聚故。色无为心不相应行者。谓一切色无为心不相应行。此俱不相应无所缘故。对无愿亦尔者。如苦智对空有四句。此对无愿亦尔。对三无漏根七觉支八道支如法智说。者如法智对三无漏根等。此苦智对三无漏根等。广说亦尔

说一切有部发智大毗婆沙论卷第一百九阿毗达磨大毗婆沙论卷第一百一十

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    智蕴第三中七圣纳息第五之二

诸法集智相应。彼法灭智相应耶。答不尔。设法灭智相应。彼法集智相应耶。答不尔。对道智空无相三摩地亦尔。所以者何。非一心故。行相异故。或所缘异故。诸法集智相应。彼法无愿三摩地相应耶。答应作四句义不定故。有法集智相应非无愿。谓集智相应无愿。即集智俱生无愿三摩地。此与集智相应非无愿。自性与自性不相应故。有法无愿相应非集智。谓集智及集智不相应无愿相应法。此中集智者。谓无愿俱生集智。此与无愿相应非集智。自性与自性不相应故。及集智不相应无愿相应法者。谓苦忍苦智集忍集智道忍道智俱生聚中无愿相应法。此与无愿相应非集智是他聚故。有法集智相应亦无愿。谓二相应法此法是何。谓集智俱生聚中除集智及无愿。诸余心心所法。即八大地法。十大善地法寻伺及心。有法非集智相应亦非无愿。谓集智不相应无愿。乃至广说。此中集智不相应无愿者。谓苦忍苦智集忍道忍道智俱生聚中无愿。此非集智相应是他聚故。亦非无愿相应。自性与自性不相应故。及诸余心心所法者。谓空无相俱生聚中心心所法。及一切有漏心心所法。此俱不相应是他聚故。色无为心不相应行者。谓一切色。无为心不相应行。此俱不相应无所缘故。对三无漏根七觉支八道支如法智说者。谓如法智对三无漏根等。此集智对三无漏根等。广说亦尔

诸法灭智相应。彼法道智相应耶。答不尔。设法道智相应。彼法灭智相应耶。答不尔。对空无愿三摩地亦尔。所以者何。非一心故。行相异故。所缘异故。诸法灭智相应。彼法无相三摩地相应耶。答应作四句义不定故。有法灭智相应非无相。谓灭智相应无相。即灭智俱生无相三摩地。此与灭智相应非无相。自性与自性不相应故。有法无相相应非灭智。谓灭智及灭智不相应无相相应法。此中灭智者。谓无相俱生灭智。此与无相相应非灭智。自性与自性不相应故。及灭智不相应无相相应法者。谓灭忍俱生无相相应法。此与无相相应非灭智是他聚故。有法灭智相应亦无相。谓二相应法。此法是何。谓灭智俱生聚中。除灭智及无相。诸余心心所法。即八大地法。十大善地法寻伺及心。有法非灭智相应。亦非无相。谓灭智不相应无相。乃至广说。此中灭智不相应无相者。谓灭忍俱生无相。此非灭智相应是他聚故。亦非无相相应。自性与自性不相应故。及诸余心心所法者。谓空无愿俱生聚中心心所法。及一切有漏心心所法。此俱不相应是他聚故。色无为心不相应行者。谓一切色。无为心不相应行。此俱不相应。无所缘故。对三无漏根七觉支八道支如法智说者。谓如法智对三无漏根等。此灭智对三无漏根等。广说亦尔

诸法道智相应。彼法空三摩地相应耶。答不尔。设法空三摩地相应。彼法道智相应耶。答不尔。对无相三摩地亦尔。所以者何。非一心故。行相异故。所缘异故。诸法道智相应。彼法无愿三摩地相应耶。答应作四句义不定故。有法道智相应非无愿。谓道智相应无愿。即道智俱生无愿。此与道智相应非无愿。自性与自性不相应故。有法无愿相应非道智。谓道智及道智不相应无愿相应法。此中道智者。谓无愿俱生道智。此与无愿相应非道智。自性与自性不相应故。及道智不相应无愿相应法者。谓苦忍苦智集忍集智道忍俱生聚中无愿相应法。此与无愿相应非道智是他聚故。有法道智相应亦无愿。谓二相应法。此法是何。谓道智俱生聚中除道智及无愿。诸余心心所法。即八大地法。十大善地法寻伺及心。有法非道智相应亦非无愿。谓道智不相应无愿。乃至广说。此中道智不相应无愿者。谓苦忍苦智集忍集智道忍俱生聚中无愿。此非道智相应是他聚故。亦非无愿相应。自性与自性不相应故。及诸余心心所法者。谓空无相俱生聚中心心所法。及一切有漏心心所法。此俱不相应是他聚故。色无为心不相应行者。谓一切色无为心不相应行。此俱不相应无所缘故。对三无漏根七觉支八道支如法智说者。谓如法智对三无漏根等。此道智对三无漏根等。广说亦尔

诸法空三摩地相应。彼法无愿三摩地相应耶。答不尔。设法无愿三摩地相应。彼法空三摩地相应耶。答不尔。对无相亦尔。所以者何。非一心故。行相异故。或所缘异故。诸法空三摩地相应。彼法未知当知根相应耶。答应作四句义不定故。有法空相应非未知当知根。谓未知当知根所不摄空相应法。此法是何。谓已知根具知根俱生空相应法。此与空相应非未知当知根是他聚故。有法未知当知根相应非空。谓未知当知根所摄空。及空不摄不相应。未知当知根相应法。此中未知当知根所摄空者。谓未知当知根俱生聚中空。此与未知当知根相应非空。自性与自性不相应故。及空不摄不相应。未知当知根相应法者。谓无愿无相俱生聚中未知当知根相应法。此与未知当知根相应非空是他聚故。有法空相应亦未知当知根。谓未知当知根所摄空相应法。此法是何。谓此聚中八根及彼相应诸非根心所法。有法非空相应亦非未知当知根。谓未知当知根所不摄空。乃至广说。此中未知当知根所不摄空者。谓已知根具知根俱生聚中空。此非空相应。自性与自性不相应故。亦非未知当知根相应是他聚故。及空未知当知根不摄不相应。诸余心心所法者。谓已知根具知根所摄。无愿无相俱生聚中心心所法。及一切有漏心心所法。此俱不相应是他聚故。色无为心不相应行者。谓一切色无为心不相应行。此俱不相应无所缘故。对已知具知根亦尔者。如空三摩地对未知当知根有四句。此对已知具知根亦尔。诸法空三摩地相应。彼法念觉支相应耶。答应作四句义不定故。有法空相应非念。谓空相应念。即空三摩地俱生念觉支。此与空相应非念。自性与自性不相应故。有法念相应非空。谓空及空不相应念相应法。此中空者。谓念觉支俱生空三摩地。此与念相应非空。自性与自性不相应故。及空不相应念相应法者。谓无愿无相俱生念觉支相应法。此与念相应非空是他聚故。有法空相应亦念。谓二相应法。即空俱生聚中除空及念。诸余心心所法。此法是何。谓八大地法。十大善地法寻伺及心。有法非空相应亦非念。谓空不相应念。乃至广说。此中空不相应念者。谓无愿无相俱生念觉支。此非空相应是他聚故。亦非念相应。自性与自性不相应故。及诸余心心所法者。谓一切有漏心心所法。此俱不相应是他聚故。色无为心不相应行者。谓一切色无为心不相应行。此俱不相应无所缘故。对择法精进轻安舍觉支正见正精进正念亦尔者。谓如空三摩地对念觉支有四句。此对择法等亦尔。诸法空三摩地相应。彼法喜觉支相应耶。答应作四句义不定故。有法空相应非喜。谓空相应喜及喜不相应空相应法。此中空相应喜者。谓空俱生聚中喜觉支。此与空相应非喜。自性与自性不相应故。及喜不相应空相应法者。谓未至定静虑中间。后二静虑前三无色地中。空三摩地相应法。此与空相应非喜是他地故。有法喜相应非空。谓喜相应空及空不相应喜相应法。此中喜相应空者。谓喜觉支俱生聚中空三摩地。此与喜相应非空。自性与自性不相应故。及空不相应喜相应法者。谓无愿无相俱生聚中喜相应法。此与喜相应非空是他聚故。有法空相应亦喜。谓二相应法。即初二静虑空俱生聚中。除空及喜。诸余心心所法。此法是何。谓八大地法。十大善地法寻伺及心。有法非空相应亦非喜。谓空不相应喜。乃至广说。此中空不相应喜者。谓无愿无相俱生聚中喜。此非空相应是他聚故。亦非喜相应。自性与自性不相应故。喜不相应空者。谓未至定静虑中间。后二静虑前三无色地中空三摩地。此非空相应。自性与自性不相应故。亦非喜相应是他地故。及诸余心心所法者。谓未至定静虑中间。后二静虑前三无色地中。无愿无相俱生聚中心心所法。及一切有漏心心所法。此俱不相应是他聚故。色无为心不相应行者。谓一切色无为心不相应行。此俱不相应无所缘故。对正思惟亦尔者。如空三摩地对喜觉支作四句。此对正思惟亦尔。诸法空三摩地相应。彼法定觉支相应耶。答诸法空相应彼法亦定相应。一切空三摩地皆是定觉支摄故。有法定相应非空。谓空所不摄定相应法。此法是何。谓无愿无相俱生聚中定觉支相应法。此与定觉支相应非空是他聚故。对正定亦尔者。如空三摩地对定觉支作顺前句。此对正定亦尔。如空对后无愿无相。对后亦尔者。如空三摩地对后无愿无相。对后广说亦尔。有差别者。如空对喜觉支正思惟无愿无相。对喜觉支正见正思惟亦尔

诸法未知当知根相应。彼法已知根相应耶。答不尔。设法已知根相应。彼法未知当知根相应耶。答不尔。对具知根亦尔。所以者何。非一心故位各别故。诸法未知当知根相应。彼法念觉支相应耶。答应作四句义不定故。有法未知当知根相应非念。谓未知当知根所摄念。即未知当知根俱生聚中念。此与未知当知根相应非念觉支。自性与自性不相应故。有法念觉支相应非未知当知根。谓未知当知根所不摄念相应法。此法是何。谓已知根具知根俱生聚中念相应法。此与念相应非未知当知根是他聚故。有法未知当知根相应亦念。谓未知当知根所摄念相应法。此法是何。谓余八根及彼相应。诸非根心所法。有法非未知当知根相应亦非念。谓未知当知根所不摄念。乃至广说。此中未知当知根所不摄念者。谓已知根具知根俱生聚中念。此非未知当知根相应。是他聚故。亦非念相应。自性与自性不相应故。及余心心所法者。谓一切有漏心心所法。此俱不相应。是他聚故。色无为心不相应行者。谓一切色无为心不相应行。此俱不相应。无所缘故。对择法精进定觉支正见正精进正念正定亦尔者。谓如未知当知根对念觉支有四句。此对择法觉支等亦尔。诸法未知当知根相应。彼法喜觉支相应耶。答应作四句。义不定故。有法未知当知根相应非喜。谓未知当知根所摄喜。及喜不摄不相应未知当知根相应法。此中未知当知根所摄喜者。谓未知当知根俱生聚中喜。此与未知当知根相应。非喜。自性与自性不相应故。及喜不摄不相应未知当知根相应法者。谓未至定静虑中间。第三第四静虑地中未知当知根相应法。此与未知当知根相应非喜。是他地故。有法喜觉支相应。非未知当知根。谓未知当知根所不摄喜相应法。此法是何。谓已知根具知根俱生聚中喜相应法。此与喜相应非未知当知根。是他聚故。有法未知当知根相应亦喜。谓未知当知根所摄喜相应法。此法是何。谓余八根及彼相应诸非根心所法。有法非未知当知根相应亦非喜。谓未知当知根所不摄喜。乃至广说。此中未知当知根所不摄喜者。谓已知根具知根俱生聚中喜。此非未知当知根相应。是他聚故。亦非喜相应。自性与自性不相应故。及喜未知当知根不摄不相应诸余心心所法者。谓未至定静虑中间。后二静虑前三无色地中。已知根具知根俱生聚中心心所法。及一切有漏心心所法。此俱不相应。是他聚故。色无为心不相应行者。谓一切色无为心不相应行。此俱不相应。无所缘故。诸法未知当知根相应。彼法轻安觉支相应耶。答应作四句。义不定故。有法未知当知根相应非轻安。谓未知当知根相应轻安。此与未知当知根相应非轻安。自性与自性不相应故。有法轻安相应非未知当知根。谓未知当知根不相应轻安相应法。此法是何。谓已知根具知根俱生聚中。轻安相应法此与轻安相应。非未知当知根。是他聚故。有法未知当知根相应亦轻安。谓未知当知根相应轻安相应法。此法是何。谓十大地法。九大善地法。寻伺及心。有法非未知当知根相应亦非轻安。谓未知当知根不相应轻安即已知根具知根俱生聚中轻安。此非未知当知根相应。是他聚故。亦非轻安相应。自性与自性不相应故。及余心心所法者。谓一切有漏心心所法。此俱不相应。是他聚故。色无为心不相应行者。谓一切色无为心不相应行。此俱不相应。无所缘故。对舍觉支亦尔者。谓如未知当知根对轻安觉支有四句。此对舍觉支亦尔。诸法未知当知根相应。彼法正思惟相应耶。答应作四句。义不定故。有法未知当知根相应非正思惟。谓未知当知根相应正思惟。及正思惟不相应未知当知根相应法。此中未知当知根相应正思惟者。谓未知当知根俱生聚中正思惟。此与未知当知根相应非正思惟。自性与自性不相应故。及正思惟不相应。未知当知根相应法者。谓静虑中间后三静虑地中未知当知根相应法。此与未知当知根相应非正思惟。是他聚故。有法正思惟相应非未知当知根。谓未知当知根不相应正思惟相应法。此法是何。谓已知根具知根俱生聚中正思惟相应法。此法与正思惟相应。非未知当知根。是他聚故。有法未知当知根相应亦正思惟。谓未知当知根相应正思惟相应法。此法是何。谓十大地法。十大善地法。寻伺及心。有法非未知当知根相应亦非正思惟。谓未知当知根不相应正思惟。乃至广说。此中未知当知根不相应正思惟者。谓已知根具知根俱生聚中正思惟。此非未知当知根相应。是他聚故。亦非正思惟相应。自性与自性不相应故。及诸余心心所法者。谓静虑中间后三静虑前三无色地中已知根具知根俱生聚中心心所法。及一切有漏心心所法。此俱不相应。是他聚故。色无为心不相应行者。谓一切色无为心不相应行。此俱不相应。无所缘故。如未知当知根对后已知具知根对后亦尔。有差别者。具知根对正见应作四句。与前有异。有法具知根相应非正见。谓具知根所摄正见。及正见不摄不相应具知根相应法。此中具知根所摄正见。谓具知根俱生正见。此与具知根相应非正见。自性与自性不相应故。及正见不摄不相应具知根相应法者。谓尽智无生智俱生聚中具知根相应法。此与具知根相应非正见。是他聚故。有法正见相应非具知根。谓具知根所不摄正见相应法。此法是何。谓未知当知根已知根俱生聚中正见相应法。此与正见相应非具知根。是他聚故。有法具知根相应亦正见。谓具知根所摄正见相应法。此法是何。谓余八根及彼相应诸非根心所法。有法非具知根相应亦非正见。谓具知根所不摄正见。乃至广说。此中具知根所不摄正见者。谓未知当知根已知根俱生聚中正见。此非具知根相应。是他聚故。亦非正见相应。自性与自性不相应故。及诸余心心所法者。谓一切有漏心心所法。此俱不相应。是他聚故。色无为心不相应行者。谓一切色无为心不相应行。此俱不相应。无所缘故。念觉支乃至正念对后广说。如觉支纳息者。如此蕴初纳息已广说。如说。苾刍吾当为汝说四十四智事。汝应谛听极善作意。乃至广说。问何故作此论。答为广分别契经义故。如契经说。佛告苾刍。吾当为汝说四十四智事。汝应谛听。乃至广说。契经虽作是说而不分别其义。经是此论所依根本。彼未说者今应说之。故作斯论。问世尊何故说此契经。答世尊昔者由此加行为门为路。证得无上正等菩提。今复说此示诸弟子。汝等若能不舍如是加行门路。不久当得诸漏永尽。譬如长者由是方便。集得珍财而受富乐。复亦以此方便教诸子孙告言。汝等若能不舍如是方便。必获珍财亦受富乐。世尊亦尔。云何四十四智事。谓知老死智。知老死集智。知老死灭智。知趣老死灭行智。如是知生有取爱受触六处名色识行智。知行集智。知行灭智。知趣行灭行智。是名四十四智事。问此中何故不说知无明智等耶。答应说而不说者。当知此义有余。复次若法有支所摄。以有支为因。是有支果者。此中说之。无明虽亦有支所摄而不以有支为因。亦非有支果故此不说。复次若依此法具起四智。此中说之。依无明但起三智。不起缘有支集智故此不说。此中知老死智等四十四智事当言法智乃至道智耶。答应言知老死智是四智。谓法类世俗苦智乃至广说。此中知老死智是四智。谓法智者知欲界老死。类智者知色无色界老死。世俗智苦智者。俱知三界老死。如知苦有四智知集灭道应知亦尔。如依老死起十六智事。乃至依行应知亦尔。如是合有一百七十六智事。若以相续刹那分别则有无量无边智事。此中世尊依十一支四谛差别各起四智故。但说有四十四智事

此四十四智事。几有漏几无漏。答一切皆通有漏无漏。几缘有漏几缘无漏。答二十二缘有漏。二十二缘无漏。几有为。几无为。答一切是有为。几缘有为。几缘无为。答三十三缘有为。十一缘无为。几过去几未来几现在。答一切皆通三世。几缘过去。几缘未来。几缘现在。答三十三缘三世。十一缘非世。若如杂蕴分位三世。应言三缘过去。谓知行智。知行集智。知识集智三缘未来。谓知老死智。知老死集智。知生智。十六缘现在。谓知生集智。知有智。知有集智。知取智知取集智。知爱智。知爱集智知受智。知受集智。知触智。知触集智。知六处智。知六处集智。知名色智。知名色集智。知识智。十一缘三世。十一缘非世。问如是智事既不能入正性离生。得果离染及尽诸漏。何缘圣者修令现前。答由四缘故。一为住现法乐故。二为游戏功德故。三为观本所作故。四为受圣财故。如说。苾刍吾当为汝说七十七智事。汝应谛听极善作意。乃至广说。问何故作此论。答为广分别契经义故。广说如前。问世尊何故说此契经。答世尊昔者。由此加行为门为路。广说如前。云何七十七智事。谓知生缘老死智。知彼非不生缘老死智。知过去生缘老死智。知彼非不生缘老死智。知未来生缘老死智。知彼非不生缘老死智。及法住智。遍知此是无常有为。思所作。从缘生。尽法减法离法灭法。如依生缘老死起七智。乃至依无明缘行亦尔。故有七十七智事。问此中何故不说知无明所从缘智耶。答应说而不说者。当知此义有余。复次若法有支所摄。以有支为因是有支果者。此中说之。无明虽亦有支所摄。而不以有支为因。亦非有支果。故此不说。复次若依此法起缘有支七智者。此中说之。依无明所从缘不起缘有支七智。故此不说

此中知生缘老死智等。七十七智事。当言法智乃至道智耶。答应言知生缘老死等。前六智皆是四智。谓法类世俗集智。第七法住智。是一世俗智。如知生缘老死七智。乃至知无明缘行七智亦尔。此中法智者。知欲界生缘老死等。类智者。知色无色界生缘老死等。世俗智集智者。俱知三界生缘老死等。问已说生缘老死等。何故复说非不生缘老死等耶。答论有二种。一立自宗。二遮他宗。立自宗者。如善说法者立善说法宗。恶说法者立恶说法宗。应理论者立应理论宗。分别论者立分别论宗。遮他宗者。如善说法者遮恶说法宗。恶说法者遮善说法宗。应理论者遮分别论宗。分别论者遮应理论宗。若但说生缘老死等者。或有生疑为兴言论。作如是说。理未必尔。为决彼疑显此理定。是故复说非不生缘老死等。此中知生缘老死。是法类世俗集四智。知非不生缘老死亦是四智。各有八智。知过去未来生缘老死。亦各有八智。合有二十四智。第七法住智唯是一世俗智故。足前有二十五智。如知生缘老死。乃至知无明缘行亦尔。如是合有二百七十五智。若以相续刹那分别。则有无量无边智事。此中世尊依十一支。三世差别各起七智。故但说有七十七智事。问何故不说知现在耶。有作是说。七中前二即知现在。复有说者。七中前二通知三世。过去未来难了知故。复别说知。现在不尔。故不别说。此七十七智事。几有漏。几无漏。答十一法住智唯有漏。唯是世俗智性摄故。余六十六智通有漏无漏。四智摄故。有作是说。一切皆通有漏无漏。几缘有漏。几缘无漏。答一切皆缘有漏。几有为。几无为。答一切皆有为。必无智体。是无为故。几缘有为。几缘无为。答一切皆缘有为。几过去。几未来。几现在。答一切皆通三世。几缘过去。几缘未来。几缘现在。答诸有欲令七中前二唯缘现在者。彼说二十二缘过去。二十二缘未来。二十二缘现在。十一缘三世。诸有欲令七中前二通缘三世者。彼说二十二缘过去。二十二缘未来。三十三缘三世。此智不能入正性离生等。由四缘故。修令现前义如前说

问何故第七名法住智。答法者是果。住者是因。知果法所住因故。名法住智。谓知三界下中上果所住之因名法住智。此智唯知因之别相。非圣行相。故唯世俗智摄。有作是说此通四智。谓法类世俗集智。问若尔。何故说是一世俗智。答实通无漏。此中且说是有漏者。此多分知因别相故。复有说者。前六智是知因智故名为法住。缘彼起智名法住智。此智知道非知集因亦四智摄。谓法类世俗道智。问若尔。何故作如是说。遍知此是无常有为。思所作。从缘生。尽法减法离法灭法。无漏岂得名离法耶。答此中但应作如是说。遍知此是无常有为。乃至灭法。不应说离法。而说离法者。欲显圣者亦厌无漏不生欣乐故说离法。有余复说。前知因智是四智性。今知彼智名法住智。故此法住智。知彼世俗智亦名知离法。评曰。应知此中初说为善

如世尊说。苏尸摩当知。先有法住智。后有涅槃智。问此中何者是法住智。何者是涅槃智耶。有作是说。知集智是法住智。知灭智是涅槃智。有余复说。知苦集智是法住智。知灭道智是涅槃智。或有说者。知苦集道智是法住智。知灭智是涅槃智。问若尔。何故说先有法住智。后有涅槃智耶。答虽有法住智在涅槃智后。而有法住智在涅槃智前。故作是说。复有说者。知流转智是法住智。知还灭智是涅槃智。复次知缘起智是法住智。知缘起灭智是涅槃智。复次知生死智是法住智。知生死灭智是涅槃智。有余师说。近分地智是法住智。根本地智是涅槃智。云何知然。经为量故。如契经说。有诸外道共集议言。佛未出时我等多获名誉利养由佛出世名利顿绝。如日既出爝火潜辉。设何方便名利如本。然憍答摩有二事胜。谓善经论。形貌端严。虽形貌难移而经论易窃。我等众内有苏尸摩。念慧坚强堪窃彼法。若得彼法名利如本。既共议已告苏尸摩。彼由二缘遂受众请。一爱亲友二善根熟。便出王舍城诣竹林精舍。谓苾刍曰。我欲出家。时诸苾刍将往白佛。佛知根性。遣诸苾刍。度令出家与受具戒彼后未久诵三藏文。亦少解义。窃作是念。欲利亲友今正是时。遂从竹林出欲还王舍城。然佛有遍照护法天眼。恒观世间谁能窃者。时有五百应真苾刍。苏尸摩前自赞己德。我生已尽。梵行已立。所作已办。不受后有。苏尸摩曰。仁等所证依何定耶。为初静虑为乃至无所有处耶。诸苾刍言。我等所证皆不依彼。苏尸摩言。若不依彼如何得证。诸苾刍曰。我等皆是慧解脱者。时苏尸摩闻已忙然不识所谓。便作是念。脱我亲友问此义者。我当云何。还诣佛所问如是义。世尊告曰。苏尸摩当知。先有法住智。后有涅槃智。苏尸摩曰。我今不知何者法住智。何者涅槃智。佛言。随汝知与不知然法应尔。时苏尸摩不果先愿。然彼五百应真苾刍依未至定得漏尽已后。方能起根本等至。由此故知近分地智是法住智。根本地智是涅槃智

说一切有部发智大毗婆沙论卷第一百一十阿毗达磨大毗婆沙论卷第一百一十一

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    智蕴第三中七圣纳息第五之三

若成就法智。彼类智耶。答若得。此中得者。已得名得。谓苦类智现前以后。后诸得言皆准此释。设成就类智彼法智耶。答如是。谓苦法智现前以后。法智苦智恒成就故。若成就法智彼他心智耶。答若得不失。此中得者。谓已离欲染。不失者。谓不退起欲界烦恼。设成就他心智彼法智耶。答若得谓苦法智现前以后。若成就法智彼世俗智耶。答如是。一切有情无不成就世俗智故。设成就世俗智彼法智耶。答若得。谓苦法智现前以后。余智一行如文广说。然法智类智及四谛智。若得以后恒时成就他心智。有漏者已离欲染。若不退起欲界烦恼。及不生无色界恒时成就。无漏者已离欲染。若不退起欲界烦恼恒时成就。世俗智一切有情恒时成就。是谓此处略毗婆沙

若成就过去法智。彼未来耶。答如是。此成就过去者。必成就未来故。此在何位。谓已入正性离生。苦现观后二心顷。集灭现观各四心顷。道现观三心顷。得四沙门果。及学无学练根已。若法智已灭不失。设成就未来。彼过去耶。答若已灭不失则成就。谓前所说诸位。若未灭设灭已失则不成就。此在何位。谓已入正性离生。苦现观一心顷。谓苦法智时得四沙门果。及学无学练根已。法智未灭设灭已失。谓得果练根或退故失。若成就过去法智。彼现在耶。答若现在前。谓若不起类智诸忍。或世俗智非无心位。尔时法智定现在前。此在何位。谓已入正性离生。集灭道现观各一心顷。谓三法智时得四沙门果。及学无学练根已。若法智已灭不失及现在前。设成就现在。彼过去耶。答已灭不失则成就。此如次前所说诸位。若未灭设灭已失则不成就。此在何位。谓已入正性离生苦现观一心顷。谓苦法智时得四沙门果。及学无学练根已。若法智未已灭设灭已失。而法智现在前。若成就未来法智彼现在耶。答若现在前。此在何位。谓已入正性离生。苦集灭道现观各一心顷。谓四法智时得四沙门果。及学无学练根已。若法智现在前。设成就现在彼未来耶。答如是。若成就现在法智者必成就未来故。若成就过去法智彼未来现在耶。答未来定成就。现在若现在前。此如前成就过去现在说。设成就未来现在彼过去耶。答若已灭不失则成就。若未灭设灭已失则不成就。此如前说。设成就现在彼过去耶。设若成就未来法智彼过去现在耶。答有未来。非过去现在。谓彼已得。未灭设灭已失不现在前。此中已得者显有未来。未灭设灭已失者。显无过去。不现在前者。显无现在。此在何位。谓得四沙门果。及学无学练根已。若法智未已起灭。先已起灭者已失。及不现在前。有未来及过去非现在。谓彼已灭不失不现在前。此中已灭不失者。显有过去。不现在前者显无现在。但有过去必有未来。此在何位。谓已入正性离生。苦现观后二心顷。集灭现观各三心顷。除法智时。道现观二忍心顷。得四沙门果。及学无学练根已。若法智已灭不失不现在前。有未来及现在非过去。谓彼现在前未灭设灭已失。此中现在前者。显有现在未灭。设灭已失者。显无过去。但有现在必有未来。此在何位。谓已入正性离生。苦现观一心顷。谓苦法智时得四沙门果。及学无学练根已。若法智未灭先灭已失而现在前。有未来及过去现在。谓彼已灭不失亦现在前。此中已灭不失者。显有过去。亦现在前者。显有现在。若有过去现在必有未来。此如前成就过去现在说。设成就过去现在彼未来耶。答如是。但成就过去现在。必成就未来故。若成就现在法智。彼过去未来耶。答未来定成就。过去若已灭不失则成就。如前成就三世位说。若未灭设灭已失则不成就。如前成就未来现在非过去说。设成就过去未来。彼现在耶。若现在前如前成就三世位说。如法智历六。类苦集灭道智亦尔者。如法智依三世有六句问答。类苦集灭道智亦尔。有差别者。各说自名随应而说

若成就过去他心智。彼未来耶。答如是。但成就过去必成就未来故。此在何位谓生欲界已离欲染。若生色界若学者。在欲色界已起无漏他心智不失。生无色界未得无学果。设成就未来彼过去耶。答若已灭不失则成就。此如次前所说诸位。若未灭设灭已失则不成就。此在何位。谓学者在欲色界。未起无漏他心智。设起已失。生无色界设起不失。生无色界得无学果。若成就过去他心智。彼现在耶。答若现在前。谓若不起余智诸忍。非无心位。尔时此智定现在前。此在何位。谓诸圣者。或诸异生。生欲色界此他心智现在前时。设成就现在。彼过去耶。答如是。此如次前所说诸位。若他心智现在前时。必成就过去有漏他心智。无漏者则不定。若成就未来他心智。彼现在耶。答若现在前。此如前成就过去现在说。设成就现在。彼未来耶。答如是。但成就现在必有未来故。若成就过去他心智。彼未来现在耶。答未来定成就。现在若现在前。此在何位。谓他心智现在前时。即欲色界异生圣者。设成就未来现在。彼过去耶。答如是。此如次前所说诸位。若成就未来他心智。彼过去现在耶。答有未来。非过去现在。谓彼已得不失。未灭设灭已失不现在前。此中已得不失者。显有未来。未灭设灭已失者。显无过去。不现在前者。显无现在。此在何位。谓若学者在欲色界。未起无漏他心智。设起已失。生无色界设起不失。生无色界得无学果。有未来及过去。非现在。谓彼已灭不失不现在前。此在何位。谓生欲界已离欲染。他心智不现在前。若生色界他心智不现在前。若学者在欲色界。已起无漏他心智不失。生无色界未得无学果有未来及过去现在。谓彼现在前。即生欲色界异生圣者。他心智现在前时。设成就过去现在。彼未来耶。答如是。此如次前所说诸位。若成就现在他心智。彼过去未来耶。答如是。亦如次前所说诸位。设成就过去未来。彼现在耶。答若现在前。此亦如前所说诸位

若成就过去世俗智。彼未来耶。答如是设成就未来彼过去耶。答如是。一切有情无不成就过去未来世俗智故。若成就过去世俗智。彼现在耶。答若现在前谓若不起诸无漏慧非无心位。此世俗智定现在前设成就现在彼过去耶。答如是。此等准前应知其相

若成就过去法智。彼过去类智耶。答若已灭不失则成就。此在何位谓已入正性离生。集灭现观各四心顷。道现观三心顷。得四沙门果。及学无学练根已。起法类智已灭不失。若未灭设灭已失则不成就。此在何位。谓已入正性离生。苦现观后二心顷。得一来不还果。及学者练根已。若法智已灭不失。类智未灭设灭已失。设成就过去类智。彼过去法智耶。答若已灭不失则成就。此如前成就过去法智及类智位说。若未灭设灭已失则不成就。此在何位。谓得四沙门果。及学无学练根已。类智已灭不失。法智未灭设灭已失。若成就过去法智。彼未来类智耶。答若得。谓苦类智已生。此在何位。谓已入正性离生。苦现观后一心顷。集灭现观各四心顷。道现观三心顷。得四沙门果。及学无学练根已。若法智已灭不失。设成就未来类智。彼过去法智耶。答若已灭不失则成就。此如次前所说诸位。若未灭设灭已失则不成就。此在何位。谓得四沙门果。及学无学练根已。法智未灭设灭已失。若成就过去法智。彼现在类智耶。答若现在前。谓若不起余智诸忍。非无心位。此定现前。此在何位。谓已入正性离生。苦集灭现观各一心顷。谓类智时。得四沙门果。及学无学练根已。若法智已灭不失。类智现在前时。设成就现在类智。彼过去法智耶。答若已灭不失则成就。此如次前所说诸位。若未灭设灭已失则不成就。此在何位。谓得四沙门果。及学无学练根已。法智未灭设灭已失。而类智现在前。若成就过去法智彼过去现在类智耶。答有过去法智。非过去现在类智。谓法智已灭不失。类智未灭设灭已失不现在前。此在何位。谓已入正性离生。苦现观一心顷。谓类智忍时。得一来不还果。及学练根已。若法智已灭不失。类智未灭先灭已失不现在前。有过去法智及过去类智非现在。谓法类智已灭不失。类智不现在前此在何位。谓已入正性离生。集灭道现观各三心顷。除类智时。得四沙门果。及学无学练根已。法智类智已灭不失。而类智不现在前。有过去法智及现在类智非过去。谓法智已灭不失。类智现在前未灭设灭已失。此在何位。谓已入正性离生苦现观一心顷。谓苦类智时。得一来不还果。及学练根已。若法智已灭不失。类智未灭先灭已失而现在前。有过去法智。及过去现在类智。谓法类智已灭不失。类智现在前。此在何位。谓已入正性离生。集灭现观各一心顷。谓类智时得四沙门果。及学无学练根已。法类智已灭不失。而类智现在前。设成就过去现在类智。彼过去法智耶。答若已灭不失则成就。此如次前所说诸位。若未灭设灭已失则不成就。此在何位。谓得四沙门果。及学无学练根已。若类智已灭不失。法智未灭设灭已失而类智现在前。若成就过去法智。彼未来现在类智耶。答有过去法智非未来现在类智。谓法智已灭未得类智。此在何位。谓已入正性离生。苦现观一心顷。谓苦类智忍时。有过去法智及未来类智非现在。谓法智已灭不失。已得类智不现在前。此在何位。谓已入正性离生。集灭道现观各前三心顷。得四沙门果。及学无学练根已。若法智已灭不失。类智不现在前。有过去法智。及未来现在类智。谓法智已灭不失。类智现在前。此在何位。谓已入正性离生。苦集灭现观各后一心顷。得四沙门果。及学无学练根已。若法智已灭不失。类智现在前。设成就未来现在类智。彼过去法智耶。答若已灭不失则成就。此如次前所说诸位。若未灭设灭已失则不成就。此在何位。谓得四沙门果。及学无学练根已。法智未灭设灭已失。而类智现在前。若成就过去法智。彼过去未来类智耶。答有过去法智非过去未来类智。谓法智已灭未得类智。此在何位谓已入正性离生。苦现观一心顷。谓苦类智忍时。有过去法智及未来类智非过去。谓法智已灭不失。已得类智未灭。设灭已失。此在何位。谓已入正性离生。苦现观后一心顷。得一来不还果。及学练根已。若法智已灭不失。类智未灭设灭已失。有过去法智及过去未来类智。谓法类智已灭不失。此在何位。谓已入正性离生。集灭现观各四心顷。道现观三心顷。得四沙门果。及学无学练根已。法智类智已灭不失。设成就过去未来类智。彼过去法智耶。答若已灭不失则成就。此如次前所说诸位。若未灭设灭已失则不成就此在何位。谓得四沙门果。及学无学练根已。类智已灭不失。法智未灭设灭已失。若成就过去法智。彼过去未来现在类智耶。答有过去法智。非过去未来现在类智。谓法智已灭未得类智。此在何位。谓已入正性离生。苦现观一心顷。谓苦类智忍时。有过去法智。及未来类智。非过去现在。谓法智已灭不失已得类智。未灭设灭已失不现在前。此在何位。谓得一来不还果。及学练根已若法智已灭不失。类智未灭设灭已失不现在前。有过去法智。及未来现在类智非过去。谓法智已灭不失。类智现在前。未灭设灭已失。此在何位。谓已入正性离生。苦现观后一心顷。得一来不还果。及学练根已。若法智已灭不失。类智未灭设灭已失而现在前。有过去法智。及过去未来类智非现在。谓法类智已灭不失。类智不现在前。此在何位。谓已入正性离生。集灭道现观各前三心顷。得四沙门果。及学无学练根已。法智类智已灭不失。类智不现在前。有过去法智及过去未来现在类智。谓法类智已灭不失。类智现在前此在何位。谓已入正性离生。集灭现观各后一心顷。得四沙门果。及学无学练根已。法智类智已灭不失。而类智现在前。设成就过去未来现在类智。彼过去法智耶。答若已灭不失则成就。此如次前所说诸位。若未灭设灭已失则不成就。此在何位。谓得四沙门果。及学无学练根已。若类智已灭不失亦现在前。法智未灭设灭已失。如对类智作小七。对集灭道智亦尔者。如法智对类智作小七。对集灭道智作小七亦尔。有差别者。各说自名随应而说。若成就过去法智。彼过去他心智耶。答若已灭不失则成就。此在何位。谓已离欲染入正性离生。苦现观后二心顷。集灭现观各四心顷。道现观三心顷。得后二沙门果及已离欲染学无学练根已法智已灭不失。若学者法智无漏他心智已灭不失。生无色界未得无学果。若未灭设灭已失则不成就。此在何位。谓未离欲染入正性离生。苦现观后二心顷。集灭现观各四心顷。道现观三心顷。得初二沙门果。及未离欲染学练根已。若法智已灭不失。若学者法智已灭不失。无漏他心智未灭设灭已失。生无色界未得无学果。设成就过去他心智。彼过去法智耶。答若已灭不失则成就。此如前俱成就说。若未灭设灭已失则不成就。此在何位。谓诸异生。生欲界已离欲染。及生色界。若已离欲染入正性离生。苦现观初二心顷。得后二沙门果。及已离欲染。学无学练根已。法智未灭设灭已失。若学者无漏他心智已灭不失。法智未灭设灭已失。生无色界未得无学果。若成就过去法智。彼未来他心智耶。答若已得不失。此中已得者。谓已离欲染。不失者。谓不退起欲染。此在何位。谓已离欲染入正性离生。苦现观后二心顷。集灭现观各四心顷。道现观三心顷。得后二沙门果。及已离欲染学无学练根已。法智已灭不失。若学者在欲界。法智已灭不失。生色无色界未得无学果。设成就未来他心智。彼过去法智耶。答若已灭不失则成就。此如次前所说诸位。若未灭设灭已失则不成就。此在何位。谓诸异生已得他心智不失。若已离欲染入正性离生。苦现观初二顷。得后二沙门果。及已离欲染学无学练根已。法智未灭设灭已失。若学者在欲界法智未灭设灭已失。生色无色界设灭已不失。生彼得无学果。若成就过去法智。彼现在他心智耶。答若现在前。此在何位。谓得后二沙门果。及已离欲染学无学练根已。法智已灭不失。他心智现在前。设成就现在他心智。彼过去法智耶。答若已灭不失则成就。此如次前所说诸位。若未灭设灭已失则不成就此在何位。谓诸异生起他心智现在前时。若得后二沙门果。及已离欲染有学无学练根已。法智未灭设灭已失。而他心智现在前时。若成就过去法智。彼过去现在他心智耶。答有过去法智非过去现在他心智。谓法智已灭不失。他心智未灭设灭已失不现在前此在何位。谓未离欲染入正性离生。苦现观后二心顷。集灭现观各四心顷。道现观三心顷。得初二沙门果。及未离欲染学练根已。法智已灭不失。若学者法智已灭不失。无漏他心智未灭设灭已失。生无色界未得无学果。有过去法智及过去他心智非现在。谓法智他心智已灭不失。他心智不现在前。此在何位。谓已离欲染入正性离生。苦现观后二心顷。集灭现观各四心顷。道现观三心顷。得后二沙门果。及已离欲染学无学练根已。法智已灭不失。他心智不现在前。若学者无漏他心智已灭不失。生无色界未得无学果。有过去法智及过去现在他心智。谓法智已灭不失。他心智现在前。此在何位。谓得后二沙门果及已离欲染学无学练根已。法智已灭不失他心智现在前设成就过去现在他心智。彼过去法智耶。答已灭不失则成就。此如次前所说诸位。若未灭设灭已失则不成就。此在何位。谓诸异生起他心智现在前时。若得后二沙门果。及已离欲染学无学练根已。法智未灭设灭已失而他心智现在前时。若成就过去法智。彼未来现在他心智耶。答有过去法智。非未来现在他心智。谓法智已灭不失。未得他心智。设得已失。此在何位。谓未离欲染苦现观后二心顷集灭现观各四心顷。道现观三心顷。得初二沙门果及未离欲染学练根已。法智已灭不失。有过去法智及未来他心智非现在。谓法智已灭不失。他心智已得不失不现在前。此在何位。谓已离欲染入正性离生。苦现观后二心顷。集灭现观各四心顷。道现观三心顷。得后二沙门果。及已离欲染学无学练根已。法智已灭不失他心智不现在前有过去法智及未来现在他心智。谓法智已灭不失。他心智现在前。此如前成就过去法智现在他心智说。设成就未来现在他心智。彼过去法智耶。答若已灭不失则成就。此如次前所说诸位。若未灭设灭已失则不成就此如前成就现在他心智。不成就过去法智说。若成就过去法智。彼过去未来他心智耶。答有过去法智。非过去未来他心智谓法智已灭不失。未得他心智。设得已失。此如前有过去法智非未来现在他心智说。有过去法智及未来他心智非过去。谓法智已灭不失。他心智已得不失。未灭设灭已失。此在何位。谓学者法智已灭不失。无漏他心智未灭设灭已失生无色界未得无学果。有过去法智及过去未来他心智。谓法智他心智已灭不失。此如前成就过去法智他心智说。设成就过去未来他心智。彼过去法智耶。答若已灭不失则成就若未灭设灭已失则不成就。此如前。设成就过去他心智。彼过去法智耶。说若成就过去法智。彼过去未来现在他心智耶。答有过去法智。非过去未来现在他心智。谓法智已灭不失。未得他心智设得已失。此如前有过去法智非未来现在他心智说。有过去法智及未来他心智非过去现在。谓法智已灭不失。他心智已得不失。未灭设灭已失不现在前。此如前有过去法智及未来他心智非过去说。有过去法智及过去未来他心智非现在。谓法智他心智已灭不失。他心智不现在前。此如前有过去法智及过去他心智非现在说。有过去法智及过去未来现在他心智。谓法智已灭不失。他心智现在前。此如前有过去法智及过去现在他心智说。设成就过去未来现在他心智。彼过去法智耶。答若已灭不失则成就。若未灭设灭已失则不成就。此如前。设成就过去现在他心智。彼过去法智耶。说若成就过去法智。彼过去世俗智耶。答如是。以过去未来世俗智一切有情皆成就故。此在何位。谓已入正性离生。苦现观后二心顷。集灭现观各四心顷。道现观三心顷。得四沙门果。及学无学练根已。若法智已灭不失。设成就过去世俗智。彼过去法智耶。答若已灭不失则成就。此如次前所说诸位。若未灭设灭已失则不成就。此在何位。谓一切异生。若已入正性离生。苦现观初二心顷。得四沙门果。及学无学练根已。法智未灭设灭已失。若成就过去法智彼未来世俗智耶。答如是。此如前。若成就过去法智。彼过去世俗智耶。说设成就未来世俗智彼过去法智耶。答若已灭不失则成就。若未灭设灭已失则不成就。此如前。设成就过去世俗智。彼过去法智耶。说若成就过去法智。彼现在世俗智耶。答若现在前。谓若不起诸无漏慧非无心位此定现前。此在何位。谓得四沙门果。及学无学练根已。若法智已灭不失起世俗智现在前时。设成就现在世俗智。彼过去法智耶。答若已灭不失则成就。此如次前所说诸位。若未灭设灭已失则不成就此在何位。谓一切异生。若得四沙门果。及学无学练根已。法智未灭设灭已失。起世俗智现在前时。余文准前应知其相。若成就过去法智。彼过去苦智耶。答若已灭不失则成就。此在何位谓已入正性离生。苦现观后二心顷。集灭现观各四心顷。道现观三心顷。得四沙门果。及学无学练根已。若法智苦智已灭不失。若未灭设灭已失则不成就。此在何位。谓得四沙门果。及学无学练根已。若非苦法智已灭不失。苦智未灭设灭已失。设成就过去苦智。彼过去法智耶答若已灭不失则成就。此如前成就过去法智苦智说。若未灭设灭已失则不成就。此在何位。谓得四沙门果。及学无学练根已。若苦类智已灭不失。法智未灭设灭已失。若成就过去法智。彼未来苦智耶。答如是。若成就过去法智者。必成就未来苦智故。此在何位。谓已入正性离生。苦现观后二心顷。集灭现观各四心顷道现观三心顷。得四沙门果。及学无学练根已。若法智已灭不失。设成就未来苦智。彼过去法智耶。答若已灭不失则成就。此如次前所说诸位。若未灭设灭已失则不成就。此在何位。谓已入正性离生。苦现观一心顷。谓苦法智时。得四沙门果。及学无学练根已。法智未灭设灭已失。若成就过去法智。彼现在苦智耶。答若现在前。谓若不起余智诸忍。非无心位此定现前。此在何位。谓已入正性离生。苦现观一心顷。谓苦类智时得四沙门果。及学无学练根已。若法智已灭不失。而苦智现在前。设成就现在苦智。彼过去法智耶。答若已灭不失则成就。此如次前所说诸位。若未灭设灭已失则不成就。此在何位。谓已入正性离生。苦现观一心顷。谓苦法智时得四沙门果。及学无学练根已。法智未灭设灭已失。而苦智现在前时。余文准前应知其相。如法智对后作小七。乃至灭智对道智。随其所应作小七亦尔者。谓如法智对后类智等作小七。如是类智对后他心智等。乃至灭智对后道智应知亦尔。如小七大七亦尔者。谓如八智以前对后作小七。如是八智以前对后作大七应知亦尔。差别者。以二或多对一。或以一对二或多者。谓前小七中定以一对一。今大七中。或以二或多对一或以一对二或多。是谓小七大七差别。如过去为首有七。未来乃至过去未来现在为首亦各有七。如应当知者。谓如过去法智等为首问三世类智等。有小大七差别。如是未来法智等为首。问三世类智等乃至过去未来现在法智等为首。问三世类智等。亦各有小大七差别。皆如所应当知其相。此中一行历六小七大七差别等义。如前结蕴广说应知

说一切有部发智大毗婆沙论卷第一百一十一阿毗达磨大毗婆沙论卷第一百一十二

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    业蕴第四中恶行纳息第一之一

三恶行三不善根。为前摄后后摄前耶。如是等章及解章义。既领会已。次应广释。问何故作此论。答为欲分别契经义故。如契经说。有三恶行三不善根。契经虽作是说而不广辩。亦未说三恶行摄三不善根。三不善根摄三恶行。契经是此论根本。彼未说者今应说之。故作斯论

三恶行者。谓身恶行。语恶行。意恶行。云何身等恶行。如世尊说。何者身恶行。谓断生命。不与取。欲邪行。何者语恶行。谓虚诳语。离间语。粗恶语。杂秽语。何者意恶行。谓贪欲嗔恚邪见。应知此中世尊唯说根本业道所摄恶行。不说业道加行后起所摄恶行。此发智论通说所有不善身业。若是业道所摄。若非业道所摄。如是一切名身恶行。通说所有不善语业。若是业道所摄。若非业道所摄。如是一切名语恶行。通说所有不善意业。若是业道所摄。若非业道所摄。如是一切名意恶行

如此论中摄诸恶行。集异门论亦作是说。故彼论言。何者身恶行。谓断生命。不与取。欲邪行。如是所说随顺契经。又言复次断生命。不与取。非梵行。如是复摄前所不摄。于自妻室所起欲行。又言。有余不善身业。如是复摄所有业道加行后起又言。有余诸有非理所引身业。问何者非理所引身业。前所未摄今更摄耶。答前说自性。今说等起。此谁所等起。谓非理作意。复有说者。此是一切有覆无记。及一分无覆无记身业。一切有覆无记身业者。谓初静虑地谄爱等所起。一分无覆无记身业者。谓应如是去来。如是行住。如是坐卧。如是裁割。如是缝缀。而不如是去来行住乃至缝缀。此等身业作不应作。不应理故摄在非理所引品中。由此名身恶行。若作是说。身恶行则通不善无记欲界色界。然恶行唯不善唯欲界。是故前说者好。又彼论言。何者语恶行。谓虚诳语。离间语。粗恶语。杂秽语。如是所说随顺契经。又言。有余不善语业。如是复摄所有业道加行后起。又言。有余诸有非理所引语业。问何者非理所引语业。前所未摄今更摄耶。答前说自性。今说等起。此谁所等起。谓非理作意。复有说者。此是一切有覆无记。及一分无覆无记语业。一切有覆无记语业者。谓初静虑地谄爱等所起。一分无覆无记语业者。谓应说一言二言多言男言女言非男女言去来今言。而不如是说一乃至去来今言。此等语业说不应说。不应理故摄在非理所引品中。由此名语恶行。若作是说。语恶行则通不善无记欲界色界。然恶行唯不善唯欲界。是故前说者好。又彼论言。何者意恶行。谓贪欲嗔恚邪见。如是所说随顺契经。又言。有余不善意业。如是复摄诸不善思。又言。有余诸有非理所引意业。问何等非理所引意业。前所未摄今更摄耶。答前说自性。今说等起。此谁所等起谓非理作意。复有说者。此是一切有覆无记。及一分无覆无记意业。名非理所引意业。一切有覆无记非理所引意业者。谓欲界萨迦耶见边执见相应意业。及色无色界一切烦恼相应意业。一分无覆无记非理所引意业者。谓诸意业起如前说。无覆无记非理所引身业语业。若作是说。意恶行则通不善及以无记。又通三界。然恶行唯不善唯欲界。是故前说者好

如发智论。集异门论摄身恶行及语恶行。施设论中所说亦尔。唯除意恶行别有所摄故彼论言。问为身三恶行摄一切身恶行为一切身恶行。摄身三恶行耶。答一切摄三。非三摄一切。不摄者何。谓非断命。以手杖等捶击有情。及非邪行。于所应行作不净行。起饮酒等诸放逸业。由不正知失念。受用诸饮食等。及不能避诸犯戒者。诸如是等所起身业非三所摄。问诸犯戒者无量。云何能避。虽复舍此还近彼故。答所在皆有。欲离实难。能不随染。是为真避。故有说言。身虽在远而随彼习。即名亲近。身虽在近不随彼习。即名远离。问为语四恶行摄一切语恶行。为一切语恶行摄语四恶行耶。答一切摄四。非四摄一切。不摄者何。谓如有一。独处空闲作如是说。无有惠施。无有亲爱。无有祠祀。如是等语恶行。世间有情不生领解。非四所摄。问为意三恶行摄一切意恶行。为一切意恶行摄意三恶行耶答一切摄三。非三摄一切。不摄者何。谓贪欲嗔恚邪见。俱生受想行识非三所摄彼论中意恶行摄四蕴自性。如是施设五蕴自性为诸恶行

问此发智论。集异门论。与佛契经。及施设论摄诸恶行。何故不同。答依二种门说诸恶行。一依世俗。二依胜义。谓佛契经及施设论。依世俗门说诸恶行。此发智论集异门论。依胜义门说诸恶行。如依世俗胜义分别。如是依不了义了义。有别意趣无别意趣。有别因缘无别因缘。世俗谛现观胜义谛现观等。应知亦尔。复有说者。由三缘故所摄不同。谓自性故。相杂故。世讥嫌故。此发智论集异门论。说其自性。施设论中说其相杂。若法虽非恶行自性。而与恶行相和杂故。亦得其名。于契经中说世讥嫌。以诸世间于根本业道多生讥嫌。非于业道加行后起。由此缘故摄诸恶行经论不同。如是名为恶行自性

已说自性。所以今当说。问何故名恶行。恶行有何义。答可厌毁故名恶。游履依处故名行。可厌毁故名恶者。如有说言。恶妻子。恶衣食。恶人恶处恶往来等。游履依处故名恶行者。谓断生命粗恶语及嗔恚。行有情处。不与取欲邪行及贪欲。行资具处。虚诳语离间语杂秽语。行于名处。邪见。行名色处。复有说者。感苦受果故名恶。动转捷利故名行。问沉溺诸恶云何捷利。答彼恶行者有如是巧便。虽行恶行。而令世间不知其恶。故名捷利。复有说者。习近恶人故能招恶趣。故名恶行。复有说者。有三因缘故名恶行。谓恶思所思故。恶说所说故。恶作所作故。恶思所思。谓意恶行。恶说所说。谓语恶行。恶作所作。谓身恶行。复有说者。有三因缘故名恶行。谓恶作义故。可厌毁故。决定能感非爱果故。恶作义者。行身语意诸恶行故名为恶行。可厌毁者。谓行恶行毁犯尸罗。常为诸天大师有智同梵行者共所厌毁。决定能感非爱果者。谓诸所有身语意恶行。无处无容能感可爱果。有处有容感非爱果。集异门论亦作是说。有何因缘名为恶行。谓彼能感非爱乐非适悦不可意果。此显等流果。复言能感非爱乐非适悦不可意异熟。此显异熟果

三不善根者。谓贪嗔痴。问此三以何为自性。答贪不善根有五。即欲界系五部所断爱。嗔不善根有五。则五部所断恚。痴不善根有五。即欲界系见集灭道及修所断全。并见苦所断一分。然见苦所断无明有十。此中除有身见边执见相应。取余无明故言一分。此十五法唯是不善。遍生不善法名不善根。应知。此三皆与六识身相应。是名三不善根自性。已说自性。所以今当说。问何故名不善根。不善根有何义。答能生不善义。是不善根义。能养不善义。能增不善义。能长不善义。能益不善义。能持不善义。能令不善法广流布义。是不善根义。尊者世友作如是说。诸不善因义是不善根义。诸不善种义。等起不善义。能为转因引不善义。为随转因生不善义摄益一切不善法义。是不善根义。大德说曰。依止此物遍能生长诸不善法。能为转因。为随转因。摄益不善。故名不善根

问若不善因义。是不善根义者。是即前生不善五蕴。与后一切已生未生不善五蕴为因。前生十不善业道。与后一切已生未生十不善业道为因。前生不善。三十四随眠俱生品。与后一切已生未生不善。三十四随眠俱生品如应为因。如是一切不善法。皆应名不善根。如是三种有何殊胜不共因缘。世尊独立为不善根。答此是世尊有余之说。大师观彼所化有情心行愿乐。简略而说。胁尊者曰。唯佛世尊究竟了达诸法性相亦知势用。非余所知。若法有不善根相即便立之。无者不立。尊者妙音亦作是说。大师知此三不善根。有如是势用。如是强盛。如是亲近。能与一切不善为因。除此不善根。余不善法无如是事。复有说者。如是三种。能生一切不善诸法。难断难灭难超难度。是故独立为不善根。复有说者。如是三种。多诸过患。谓生一切现法后法众多忧苦。是故独立为不善根。复有说者。如是三种。于出欲界极为障碍。如壮狱卒守于狱门。是故独立为不善根。复有说者。如是三种于不善中最为殊胜。最为上首。前行前导。如最胜军将导一切。此不善根增上力故。能令一切不善增广。是故独立为不善根。复有说者。如是三种。与三善根为近对治怨敌障碍。是故独立为不善根。复有说者。如是三种。能与一切不善。为因为根为眼为集为缘。发起一切不善诸法。障碍一切诸功德法。不善法中最为殊胜。是故独立为不善根。复有说者。如是三种。遍摄一切不善诸法。谓诸不善。或是贪品。或是嗔品。或是痴品。是故独立为不善根。又此三种具足五义。谓通五部。遍在六识。是随眠性。能起粗恶身业语业。作断善根牢强加行。是故独立为不善根。通五部者遮五见疑。遍六识者遮其诸慢。随眠性者遮缠垢等。能起粗恶身业语业。作断善根牢强加行者。示现根义。又此五义遮一切法成立根义。谓不染污法有遍六识。无余四义。染污色蕴全无五义。染污受蕴想蕴及除烦恼缠垢。所余相应染污行蕴。虽通五部亦遍六识。而非随眠性。虽能起粗恶身语二业。而非断善牢强加行。所有染污不相应行蕴虽通五部。无余四义。染污识蕴中。眼等五识全无五义。意识虽通五部。亦能起粗恶身业语业。而无余三义。十烦恼中五见及疑。有随眠性无余四义。慢通五部。是随眠性。能起粗恶身业语业。无余二义。于十缠中。惛沉掉举无惭无愧虽通五部亦遍六识。而非随眠性。虽起粗恶身业语业。而非断善牢强加行。睡眠一种虽通五部无余四义。所余五缠。虽起粗恶身语二业无余四义。六烦恼垢。虽亦有时能起粗恶身语二业。无余四义。唯贪嗔痴。具足五义非所余法。是故独立为不善根。又此三种。多于三受随逐随增。是故独立为不善根。又此三种。欲界有情多分现起。能发十种不善业道生十恶处。是故独立为不善根

如是三种通五部。与六识俱起诸不善品为根。此中贪相应品。由二根故说名有根。谓贪及彼相应无明。嗔相应品亦二根故说名有根。谓嗔及彼相应无明。除此所余不善心品由一根故说名有根。所谓无明

问世尊处处。说根不同。谓或说有身见边执见为根。或说世尊为根。或说乐欲为根。或说不放逸为根。或说自性为根。如是等有何义。答有身见边执见。由能发起六十二见故说为根。世尊能说杂染清净。系缚解脱。生死涅槃。起正教法故说为根。乐欲能引一切善法。故说为根。诸不放逸。摄护一切所修善法。令不散失故说为根。自性能持自体不失故说为根。如是无为。能持自体故说为根。亦无有过。复有说者。为同类因持等流果。或是同类因性所持。是故有为自性名根。复有说者。相应俱有因力任持。是故有为自性名根。名能显了诸法自性。故亦说彼为自性根。此贪嗔痴能生能长诸不善法。故说为根。三不善根如结蕴广说

已说三恶行三不善根自性。今当显示杂无杂相。三恶行三不善根为前摄后。后摄前耶。答应作四句。有恶行非不善根。谓身语恶行邪见。不善思。由此唯有恶行相。无不善根相故。有不善根非恶行。谓痴不善根。由此唯有不善根相。无恶行相故。有恶行亦不善根。谓贪欲嗔恚不善根。由此具有二种相故。有非恶行。非不善根。谓除前相。相谓所名。除前三句名所显义。所余诸法为第四句。谓色蕴中。除不善色取余色蕴。于行蕴中除三不善根。不善邪见。及不善思。取余相应不相应行蕴。及三蕴全。并无为法。如是一切作第四句。是故说言谓除前相。复次于眼识贪俱生不善品中。或有恶行非不善根。应作四句。有恶行非不善根。谓不善思。有不善根非恶行。谓痴不善根。有恶行亦不善根。谓贪不善根。有非恶行非不善根。谓除前相。如于眼识作四句。乃至于意识亦尔。如于贪俱生不善品作六四句。于嗔俱生品亦尔。于邪见俱生不善品中。唯意地故作一四句。有恶行非不善根。谓邪见及不善思。有不善根非恶行。谓痴不善根。有恶行亦不善根者无也。有非恶行非不善根。谓除前相。于不共无明俱生不善品中。亦以唯意地故作一四句。有恶行非不善根。谓不善思。有不善根非恶行。谓痴不善根。有恶行亦不善根者无也。有非恶行非不善根。谓除前相

三妙行。三善根。为前摄后。后摄前耶。乃至广说。问何故作此论。答为欲分别契经义故。如契经说。有三妙行三善根。契经虽作是说。而未广辩。广说如前。三妙行者。谓身妙行。语妙行。意妙行。云何身等妙行。如世尊说。何者身妙行。谓离断生命。离不与取。离欲邪行。何者语妙行。谓离虚诳语。离离间语。离粗恶语。离杂秽语。何者意妙行。谓无贪无嗔正见。应知此中世尊唯说根本业道所摄妙行。不说业道加行后起所摄妙行

此发智论通说所有善身业。若是业道所摄。若非业道所摄。如是一切名身妙行。通说所有善语业。若是业道所摄。若非业道所摄。如是一切名语妙行。通说所有善意业等。若是业道所摄。若非业道所摄。如是一切名意妙行。如此论中摄诸妙行。集异门论亦作是说。故彼论言。何者身妙行。谓离断生命。离不与取。离欲邪行。如是所说随顺契经。又言。复次离断生命。离不与取。离非梵行。如是复摄前所不摄。于自妻室离起欲行。又言。有余善身业。如是复摄所有业道加行后起。又言。有余诸有如理所引身业。问何等如理所引身业。前所未摄今更摄耶。答前说自性。今说等起。此谁所等起。谓如理作意。复有说者。此是一分无覆无记身业。谓应如是去来。如是行住。如是坐卧。如是裁割。如是缝缀。而皆如是。如应去来。乃至缝缀。此等身业作所应作。应正理故。摄在如理所引品中。由此名身妙行。若作是说。身妙行则通善及无记。然妙行唯善。是故前说者好。又彼论言。何者语妙行。谓离虚诳语。离离间语。离粗恶语。离杂秽语。如是所说随顺契经。又言。有余善语业如是复摄所有业道加行后起。又言。有余诸有如理所引语业。问何等如理所引语业。前所未摄今更摄耶。答前说自性。今说等起。此谁所等起。谓如理作意。复有说者。此是一分无覆无记语业。谓应说一言二言多言男言女言非男女言去来今言。而皆如是说一乃至去来今言。此等语业说所应说。应正理故。摄在如理所引品中。由此名语妙行。若作是说。语妙行则通善及无记。然妙行唯善。是故前说者好。又彼论言。何者意妙行。谓无贪无嗔正见。如是所说随顺契经。又言。有余善意业。如是复摄所有善思。又言。有余诸有如理所引意业。问何等如理所引意业。前所未摄今更摄耶。答前说自性。今说等起。此谁所等起。谓如理作意。复有说者。此是一分无覆无记意业。名如理所引意业。谓诸意业起如前说。无覆无记如理所引身业语业。若作是说。意妙行则通善及无记。然妙行唯善是故前说者好

如发智论集异门论。摄身语妙行。施设论中所说亦尔。唯除意妙行。别有所摄故。彼论言

问为身三妙行摄一切身妙行。为一切身妙行摄身三妙行耶。答一切摄三。非三摄一切。不摄者何。谓离前说以手杖等捶击有情。及所应行诸不净行。并饮酒等诸放逸业。而能安住正知正念。受用食等。复能正避诸犯戒者。诸如是等所起身业非三所摄。所余问答如前应知。问为语四妙行摄一切语妙行。为一切语妙行摄语四妙行耶。答一切摄四。非四摄一切。不摄者何。谓如有一独处空闲。作如是说。有惠施。有亲爱。有祠祀。如是等语妙行。于世有情不生领解。非四所摄。问为意三妙行摄一切意妙行。为一切意妙行摄意三妙行耶。答一切摄三。非三摄一切。不摄者何。谓无贪无嗔正见俱生受想行识非三所摄。彼论中意妙行摄四蕴自性。如是施设五蕴自性为诸妙行

问此发智论。集异门论。与契经施设论。摄诸妙行何故不同。答依二种门说诸妙行。一依世俗。二依胜义。谓契经施设论。依世俗门说诸妙行。此发智论集异门论。依胜义门说诸妙行。如依世俗胜义分别。如是依不了义了义等。广说如前。复有说者。由三缘故所摄不同。谓自性故。相杂故。世所欣赞故。此发智论集异门论说其自性。施设论中说其相杂。若法虽非妙行自性。而与妙行相杂故亦得其名。于契经中说世欣赞。以一切世间于根本业道多起欣赞。非于业道加行后起。由此缘故。摄诸妙行经论不同。如是名为妙行自性。已说自性。所以今当说。问何故名妙行。妙行有何义。答可欣赞故名妙。游履所依处故名行可欣赞故名妙者。如有说言。妙妻子。妙衣食。妙人。妙处。妙往来等。游履所依处故名行者。谓即于前三种恶行所依之处。与彼相违起三妙行。复有说者。感乐受果故名为妙。动转捷利故名为行。问于妙行中云何捷利。答行妙行者有如是巧便。虽不希求世间名誉。而为劝他修妙行故。所修妙行皆令他知。故名捷利。复有说者。习近善人能招善趣。故名妙行。复有说者。有三因缘故名妙行。谓善思所思故。善说所说故。善作所作故。善思所思。谓意妙行。善说所说。谓语妙行。善作所作。谓身妙行。复有说者。有三因缘故名妙行。谓善作义故。可欣赞故。决定能感可爱果故。善作义者。行身语意诸善行故名为妙行。可欣赞者。谓行善行守护尸罗。常为诸天大师有智同梵行者共所欣赞。决定能感可爱果者。谓所有身语意妙行。无处无容能感非爱诸果异熟。有处有容能感可爱诸果异熟。集异门论亦作是说。有何因缘名为妙行。谓彼能感可爱可乐适意悦意甚可喜果。此显等流果。复言。能感可爱可乐适意悦意可喜异熟。此显异熟果

三善根者。谓无贪无嗔无痴善根。云何无贪善根。谓心所法与心相应。是贪对治。是名无贪善根性。云何无嗔善根。谓心所法与心相应。是嗔对治。是名无嗔善根性。云何无痴善根。谓心所法与心相应。是痴对治。是名无痴善根性。此三善根。于一心中具足可得。三不善根。非于一心具足可得。又三善根。具足防卫一切善心。通六识身有漏无漏。三不善根。不能具足防卫一切诸不善心。又三善根。遍与善心相应。三不善根。不遍与不善心相应。又三善根。能遍发起一切善心。三不善根不能遍起一切不善心。如是随转不随转等。皆应广说。是名三善根自性

已说自性。所以今当说。问何故名善根。善根有何义。答能生善义是善根义。能养善义。能增善义。能长善义。能益善义。能持善义。能令善法广流布义。是善根义。尊者世友作如是说。善法因义。是善根义。善法种义。等起善义。能为转因。引诸善义。为随转因生诸善义。摄益一切诸善法义。是善根义。大德说曰。依止此物遍能生长一切善法。能为转因。为随转因。摄益诸善。故名善根

问若善法因义是善根义者。前生善五蕴。与后一切已生未生善五蕴为因。前生十善业道。与后一切已生未生十善业道为因。前生三十七菩提分法。与后一切已生未生三十七菩提分法为因。如此则一切善法皆应名善根。如是三种有何殊胜不共因缘立为善根。答此是世尊有余之说。大师观彼所化有情心行愿乐。简略而说。胁尊者曰。唯佛世尊究竟了达诸法性相亦知势用。非余能知。若法有善根相者即便立之。无者不立。尊者妙音亦作是说。大师知此三种善根。如是势用。如是强盛。如是亲近。能与一切善法为因。其余善法无如是事。复有说者。此三善根。于诸善法最为殊胜。以殊胜故立为善根。复有说者。此三善根于诸善法。最为上首前行前导。如最胜军将导一切。如是善根增上力故。能令一切善法增广故。立为善根。复有说者。此三善根。能与一切善法为因为根为眼为集。发起一切善法。障碍一切不善诸法。于善法中最为殊胜。故立为根。复有说者。以三善根能遍发起十善业道。生十善处故立为根。由如是等诸因缘故。于善法聚唯此三种立为善根。已说三妙行三善根自性。今当显示杂无杂相。三妙行三善根。为前摄后后摄前耶。答应作四句。有妙行非善根。谓身语妙行及善思。由此唯有妙行相。无善根相故。有善根非妙行。谓正见所不摄无痴善根。由此唯有善根相。无妙行相故。有妙行亦善根。谓无贪无嗔正见。由此具有二种相故。有非妙行非善根。谓除前相。相谓所名。除前三句名所显义。所余诸法为第四句。谓色蕴中。除诸善色取余色蕴。于行蕴中除三善根及诸善思取余相应不相应行蕴。及三蕴全。并无为法。如是一切作第四句。故言谓除前相。复次于眼识俱生善法品中。或有妙行非善根。应作四句。有妙行非善根。谓善思。有善根非妙行。谓无痴善根。有妙行亦善根。谓无贪无嗔。有非妙行非善根。谓除前相。如于眼识俱生善品。如是乃至于身识俱生善品亦尔。于正见俱生品中。或有妙行非善根。应作四句。有妙行非善根。谓善思。有善根非妙行者。无也。有妙行亦善根。谓无贪无嗔正见。有非妙行非善根。谓除前相。尽智无生智俱生品中。或有妙行非善根。应作四句。有妙行非善根谓善思。有善根非妙行。谓无痴善根。有妙行亦善根。谓无贪无嗔。有非妙行非善根。谓除前相

说一切有部发智大毗婆沙论卷第一百一十二阿毗达磨大毗婆沙论卷第一百一十三

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    业蕴第四中恶行纳息第一之二

三恶行。十不善业道。为三摄十。十摄三耶。乃至广说。问何故作此论。答为欲分别契经义故。如契经说。有三恶行十不善业道。契经虽作是说而不广辩。广说如前。复有说者。前已分别三种恶行。而未分别十不善业道。今欲分别故作斯论

此中三恶行名略事广。十不善业道名广事略。故三恶行摄十不善业道。非十不善业道摄三恶行。以诸恶行摄业道已而更有余。譬如大器覆于小器而更有余。是故三摄十非十摄三。不摄者何。谓除业道所摄。余身语意恶行。何者是余身语恶行。谓身语业道加行后起。及施设论所说诸业。并一切遮罪所摄业。何者是余意恶行。谓不善思今当显示十不善业道。根本加行后起三种差别。彼断生命三种者。谓若屠羊者。彼先诣羊所。若买若牵若缚若打。乃至命未断。尔时所有不善身语业。是断生命加行。若以杀心正断他命。尔时所有不善身表。及此刹那无表。是断生命根本。从是以后即于是处。所有剥皮断截支肉。或卖或食。所起不善身语表无表业。是断生命后起。不与取三种者。谓初起盗心往彼彼处。图谋伺察攻墙断结取他财宝。乃至举物未离本处。尔时所有不善身语业。是不与取加行。若以盗心正取他物举离本处。尔时所有不善身表。及此刹那无表。是不与取根本。从是以后或物主觉乃至相系相害。则以杀生加行为偷盗后起。若主不觉分张受用。尔时所起不善身语表无表业。是不与取后起。欲邪行三种者。谓以欲火所烧逼故。若信若书若饮食财宝以表爱相。彼或摩或触乃至未和合前。所有不善身语业。是欲邪行加行。若于尔时彼此和合所起不善身表。及此刹那无表是欲邪行根本。此中有说。才和合时即成业道。有说。畅热恼时方成业道。从是以后即依此事所有不善身语表无表业。是欲邪行后起。虚诳语三种者。谓以财利名誉等故。对一有情。或大众会。矫为明证覆想而说。乃至未发所摄受虚诳语言。尔时所有不善身语业。是虚诳语加行。若正发所摄受虚诳语言。尔时所有不善语表。及此刹那无表。是虚诳语根本。从是以后即依此事所起不善身语表无表业。是虚诳语后起。离间语三种者。谓以财利名誉等故。种种方便于他亲友破坏离间。乃至未发正破坏言。尔时所有不善身语业。是离间语加行。若以坏意正发坏言尔时所有不善语表及此刹那无表。是离间语根本。从是以后即依此事所起不善身语表无表业。是离间语后起。此中有说。若离间语令他沮坏方成业道。若尔者。破坏圣人应非业道。然离间语坏圣者重。如是说者。但起坏心作离间语。若坏不坏皆成业道。粗恶语三种者。谓彼本性多嗔恚故。将出语时先现愤发。身掉色变怒目叱吒。住彼人所乃至未发正毁辱言。尔时所有不善身语业。是粗恶语加行。若至其所发毁辱言。尔时所有不善语表。及此刹那无表。是粗恶语根本。从是以后即依此事所起不善身语表无表业。是粗恶语后起。此中有说。令彼嗔恼方成业道。若尔者。骂离欲者应非业道。然粗恶语骂离欲者重。如是说者。但怀愤恚发粗恶言。若恼不恼悉成业道。杂秽语三种者。谓以财利恭敬名誉及戏乐故。乐作种种非义非时不应法语。或俳优者。欲作愚者欢笑语时。指顾跳跃作诸言笑。乃至未发彼根本语。尔时所有不善身语业。是杂秽语加行。若正发起诸无义说杂戏语时所有不善语表。及此刹那无表。是杂秽语根本。从是以后即依此事所起不善身语表无表业。是杂秽语后起。其余贪欲嗔恚邪见意三业道起即根本。非有加行后起差别。有说。亦有加行后起。谓不善思此中根本七不善业道诸有表业。及此刹那诸无表业。各具五义。一恶行。二犯戒。三不律仪。四业。五业道。从是已后诸无表业。各唯有四义。谓除业道。唯于思究竟时名业道故

问由几不善业道俱生思究竟转。答于身业自性三不善业道中。或时由一思究竟转。谓身三业一一而起。或时由二思究竟转。谓如有一盗他羊等。有是希望即于盗时亦断其命。或自行欲邪行。遣使作杀盗随一。以欲邪行唯自所究竟故。若有如是种类法生。一刹那顷。由二不善业道俱生思究竟转。或时由三思究竟转。谓如有一先遣二使杀生偷盗。自行欲邪行。若有如是种种法生。一刹那顷三皆究竟尔时三不善业道俱生思究竟转。犹如群贼相期一处劫掠他时。于刹那顷有牵彼车。有断彼命。有淫彼妇。当知尔时彼诸盗者。有由三不善业道俱生思究竟转。于语业自性四不善业道中。或时由一思究竟转。谓语四业一一而起。有说。一者唯杂秽语。或时由二思究竟转。谓作虚诳语非时故有杂秽语。或作离间语非时故有杂秽语。或作粗恶语非时故有杂秽语。或时由三思究竟转。谓作虚诳语离间语非时故有杂秽语。或作虚诳语粗恶语非时故有杂秽语。或作离间语粗恶语非时故有杂秽语。或时由四思究竟转。谓作虚诳语离间语粗恶语非时故有杂秽语。若总论之。或时由五思究竟转。或乃至由八思究竟转。谓遣六使作六业道自行欲邪行。若有如是种类法生。一刹那顷七皆究竟。及意三业道随一现前。如是八种业道俱生思究竟转。当知意三各别现起思究竟转。无俱生义。无二心故。无遣他故。由此不说或九或十俱生之义

问于何界中有几不善业道可得。答唯于欲界一切具足可得。或不律仪所摄。或非律仪非不律仪所摄。色无色界一切都不可得

问于何趣中有几不善业道可得。答捺落迦趣有后五非律仪非不律仪所摄。无断生命者。由彼无能断他命故。如说于彼乃至所有恶不善业。未尽灭吐定不命终。无不与取者。由彼无有受财分故。无欲邪行者。由彼无有摄受妻室故。无虚诳语及离间语者。无摄受虚诳语事故。常无和合故。有粗恶语者。苦受所逼故。有杂秽语者。非时说故。贪欲嗔恚邪见具有。未离欲故。傍生鬼趣皆具十种。非律仪非不律仪所摄。人趣三洲具十不善业道。或不律仪所摄或非律仪非不律仪所摄。北拘卢洲有后四非律仪非不律仪所摄。无断生命者。定寿千岁无中夭故。及性淳善定升进故。无不与取者。彼无摄受自他分故。无欲邪行者。无摄受妻室故。彼若欲作非梵行时。与彼女人共诣树下。若所应者树枝低覆令彼和合。若不覆者并愧而离。无虚诳语者。无有摄受虚诳语事故。无离间语者。由彼有情恒和好故。无粗恶语者。由彼常说软美言故。有杂秽语者。由彼非时歌咏戏笑故。贪欲嗔恚邪见具有未离欲故。欲界天中具十不善业道。非律仪非不律仪所摄。问彼天为有断命事不。答彼虽不自相害而害余趣。复有说者。亦自相害故如是说。诸天手足随断随生。斩首中截即便殒没。有不与取。乃至杂秽语者。由彼亦有劫盗他物。侵他所受。作矫妄言。说破坏语。愤恚骂辱非时歌咏等故。贪欲嗔恚邪见具有。未离欲故问若盗命过苾刍财物。于谁处得根本业道耶。答若已作羯磨者。于羯磨众处得。若未作羯磨者。普于一切善说法众处得

问若得伏藏物作盗想而自用者。彼于谁处得根本业道。答于王处得。大地所有皆属王故。复有说者。于其田宅所属处得。所以者何。彼于此中被税利故。如是说者。于王处得。大地所有王为主故。其田宅主唯输地利非伏藏利。问若取两国中间伏藏作盗想者。复于谁处得根本业道。答若转轮王出现世时轮王处得。若无轮王都无处得

问若盗如来窣堵波物。于谁处得根本业道。有说。亦于国王处得。有说。于施主处得。有说。于守护人处得。有说。于能护彼天龙药叉非人处得。如是说者。于佛处得。所以者何。如世尊言。阿难当知。若我住世有于我所恭敬供养。及涅槃后乃至千岁。于我驮都如芥子许恭敬供养。我说若住平等之心。感异熟果平等平等。由此言故。世尊灭度虽经千岁。一切世间恭敬供养佛皆摄受

问若于受学禁戒女人所行不净行。谓苾刍尼邬波斯迦勤修梵行。及炽然修外道苦行。毁犯彼者。于谁处得根本业道。或有说者。于彼各别所师处得。复有说者。于彼同梵行处得。如是说者。于王处得。彼是国王所防护故。问于寄客女人行不净行。彼于谁处得根本业道。或有说者。于所寄主人处得。如是说者。于王处得。彼是国王所防护故

问于自货女行不净行。于谁处得根本业道。答若与其价都无处得。若不与价于王处得

问于未嫁女行不净行。于谁处得根本业道。答若已许他于夫处得。若未许他于其父母诸亲处得

问若有女人为其父母兄弟姊妹亲族等护。有罚有碍是他妻妾他所摄受。乃至或有赠一花鬘。若于彼所行不净行。于谁处得根本业道。答于能摄护。乃至赠一花鬘处得。如施设论说。赡部洲人形交成淫。东毗提诃。西瞿陀尼。北拘卢洲。四大王众天。三十三天亦尔。夜摩天相抱成淫。睹史多天执手成淫。乐变化天欢笑成淫。他化自在天相顾眄成淫

问地居所起淫事加行。即是空居根本业道。空居业道有加行不。答皆有加行。谓夜摩天即以执手。欢笑。顾眄。为加行睹史多天即以欢笑。顾眄。为加行。乐变化天即以顾眄为加行。问唯相顾眄成业道处有加行不。答于彼亦有。先对一方为眄他女。回顾余方未睹加行。见成根本。先坐一宫为顾他女起趣余宫。未睹加行。见成根本。问何缘地居形交成淫。空居不尔。答此烦恼粗。彼烦恼细。此烦恼重。彼烦恼轻。此烦恼勤。彼烦恼利。又彼诸天境界炽盛。境界明净。境界胜妙。由如是境界所牵引故。才触对时即令醉闷。是故于彼欲火易息。复有说者。以上诸天近离欲道。是故于彼欲火渐微。如是说者。一切淫事必二形交欲火方息

问若尔。施设论说当云何通。答彼说时量迟速差别。谓夜摩天如相抱时量欲火便息。乃至他化自在天。如顾眄时量欲火便息。施设论中但依时量故作是说

三妙行十善业道。为三摄十十摄三耶。乃至广说。问何故作此论。答为欲分别契经义故。如契经说。有三妙行十善业道。契经虽作是说。而未广辩。广说如前。复有说者。前已分别三种妙行。而未分别十善业道。今欲分别故作斯论

此中三妙行名略事广。十善业道名广事略。故三妙行摄十善业道。非十善业道摄三妙行。说喻如前。不摄者何。谓除业道所摄身语意妙行。所余身语意妙行。此中何等身语妙行非业道摄。谓身语业道加行后起。及施设论所说诸业。并离遮罪所摄诸业。何等意妙行非业道摄。谓善思。今应显示十善业道。根本加行后起三种差别。谓离十不善业道根本。即十善业道根本。离不善业道加行后起。即善业道加行后起。此复云何。犹如勤策受具戒时。先整衣服入受戒场。顶礼僧足求亲教师。受持衣钵往问遮处。来至众中。重问遮难。白一羯磨乃至第三羯磨未竟。是名善业道加行。若至第三羯磨究竟。尔时表业及此刹那无表。是名善业道根本。从是以后为说四依四重等事。是名善业道后起

此中根本七善业道。若表及此刹那无表。各具七义。一尸罗。二妙行。三律仪。四别解脱。五别解脱律仪。六业。七业道。从此已后诸无表业各唯有五义。谓除别解脱及业道。已得究竟解脱诸恶非最初故。亦唯于思究竟时名业道故。问由几善业道俱生思究竟转。答于受八戒及五戒时。若住五识善心。由六善业道俱生思究竟转。若住意识善心。由七善业道俱生思究竟转。若住染污心。或无记心。由四善业道俱生思究竟转。受十戒时亦尔。受具戒时若住五识善心。由九善业道俱生思究竟转。若住意识善心。由十或九善业道俱生思究竟转。若住染污心。或无记心。或无心时。由七善业道俱生思究竟转。受非律仪非不律仪时。身语七善业道。随所要期多少不定。意三善业道。或有。或无。或多。或少。生欲界者若起欲界五识善心。由二善业道俱生思究竟转。若起欲界意识善心。由三善业道俱生思究竟转。若起色界善心。及彼地无漏正见俱生心。由十善业道俱生思究竟转。若起彼地尽智无生智俱生心。由九善业道俱生思究竟转。若起无色界善心。及彼地无漏正见俱生心。由三善业道俱生思究竟转。若起彼地尽智无生智俱生心。由二善业道俱生思究竟转。生初静虑者。若起三识善心。由二善业道俱生思究竟转。若起自地意识不定善心。由三善业道俱生思究竟转。若起自地意识有漏定心。及自地无漏正见俱生心。由十善业道俱生思究竟转。若起自地尽智无生智俱生心。由九善业道俱生思究竟转。若起第二第三第四静虑善心。及彼地无漏正见俱生心。由十善业道俱生思究竟转。若起彼地尽智无生智俱生心。由九善业道俱生思究竟转。若起无色界善心。及彼地无漏正见俱生心。由三善业道俱生思究竟转。若起彼地尽智无生智俱生心。由二善业道俱生思究竟转。如生初静虑。如是生第二静虑。乃至生无色界皆应广说。差别者。除三识身。生无色界亦除前七业道

问于何界何趣。有几善业道可得。答欲界具十。或律仪。或非律仪非不律仪所摄。色界亦具十。皆律仪所摄。无色界中成就有十。现前唯三。于诸趣中。那落迦有后三。傍生。鬼趣。具十。皆非律仪非不律仪所摄。人趣三洲。及欲界天皆具有十。或律仪。或非律仪非不律仪所摄。北拘卢洲唯有后三。皆非律仪非不律仪所摄。色无色天如前已说

三业十业道为三摄十。十摄三耶。乃至广说。问何故作此论。答为欲分别契经义故。如契经说。有三业十业道。契经虽作是说。而未广辩。广说如前。复有说者。欲显业趣最甚深最微细难见难觉故。所以者何。一切如来所说经中。无有甚深如业经者。十二转中无有甚深如业转者。佛十力中无有甚深如业力者。于八蕴中无有甚深如业蕴者。四不思议中无有甚深如业不思议者。由是缘故世尊一时极善安住殷勤作意。摄心思惟入闲静处。默然宴坐审谛观察。摩揭陀国诸辅佐臣。为在何趣。为受何生。为往何处。由此作意方能了知。彼诸臣等。在如是趣。受如是生。往如是处。问诸佛法尔才举心时。于一切法殊胜智见无障碍转。为何义故极善安住殷勤作意。广说乃至默然而坐。或有说者。为显业趣最甚深故。最微细故。最难见故。最难觉故。复有说者。为审观察摩揭陀国诸辅佐臣。种种因性。种种果性。种种相续性。种种对治性。及命终心。续生心等。由此观察如应悉知。复次世尊为欲委知彼诸臣等生处差别。故极作意复有说者。为待当来所化生故。有所化生应闻说法作饶益事。于此众中犹未集会。复有说者。为待辰那栗连婆故。彼是先世频毗婆罗。于此众中犹未集会。复有说者。欲令阿难生尊重意。殷勤恭敬无倒受持思量观察。复有说者。为欲除断诸邪慢人憍傲心故。谓有于法少分知已。便生憍慢而不修学。为除彼意显佛世尊不由加行。于一切法殊胜智见无障碍转。尚于一切问记事中殷勤观察。况于汝小智而当不学生憍慢耶。复有说者。欲显成就正士法故。诸有正士法尔皆应善思所思。善说所说。善作所作。复有说者。世尊一时入闲静处默然宴坐。尊者阿难请问斯事。世尊未答便入寂定。从定起已乃为记别。由是因缘故作斯论。复有说者。由三因缘所以作论。一为分别契经义故。二为遮止他所说故。三为显了世间现见所行事故。为分别契经义者。谓契经说业有二种。一思业二思所起业。彼所说业今欲广释。是名分别契经义。为遮止他所说者。如胜论外道说五种业。谓取舍屈申行为第五业。数论外道说九种业。谓取舍屈申举下开闭行为第九业。或有外道说十二处皆是业性。彼作是言。眼作何业。谓见色。色作何业。谓眼所行。广说乃至。意作何业。谓能知法。法作何业。谓意所行。欲止如是邪宗所立。显示无倒诸业自性。又譬喻者说。身语意业皆是一思。为遮彼意显除思体。别有身语二业自性。又分别说部建立贪欲嗔恚邪见是业自性。彼何故作是说。依契经故。如契经说。故思所造身三种业。已作已集是恶不善。能生众苦感苦异熟。故思所造语四种业。意三种业。已作已集是恶不善。能生众苦感苦异熟。意三业者。谓贪恚邪见。由此经故说贪等三是业自性。为遮彼意显贪欲等非业自性。故作斯论。问若贪欲等非业性者。分别说部所引经云何通。答是业资粮故说名业。如薄伽梵处处经中说彼资粮名为彼法。如前广说乐资粮等名为乐等。此中亦尔。于业资粮说名为业。尊者法救作如是说。此中世尊唯摄其业。就所依处显示业性。故作是说。谓若依此阶梯殊胜思究竟转。则于此处宣说业名。如是一切名为遮止他所说故。为显了世间现见所行事者。谓诸世间于其业果立业名想。如见彩画锦绣等物。说言如是奇巧作业。此实非业但是业果。是名显了世间现见所行事故。由此三缘故作斯论

三业者。谓身业语业意业。问此三业云何建立。为自性故。为所依故。为等起故。若自性者应唯一业。所谓语业。语即业故。若所依者。应一切业皆名身业。以三种业皆依身故。若等起者。应一切业皆名意业。以三皆是意等起故。答具由三缘建立三业。一自性故建立语业。二所依故建立身业。三等起故建立意业。复有说者。由三缘故建立三业。一依自处故。二依他处故。三依相应处故。依自处故建立语业。依他处故建立身业。依相应处故建立意业。如是名为三业自性

已说自性。所以今当说。问何故名业。业有何义。答由三义故说名为业。一作用故。二持法式故三分别果故。作用故者。谓即作用说名为业。持法式者。谓能任持七众法式。分别果者。谓能分别爱非爱果

问若尔者。彼俱有相应法亦能分别爱非爱果悉名业耶。答此中唯说胜者名业。此三种业于诸俱有相应法中最为胜故。譬如世间于种种胜处得种种名。此亦如是。如世间说乐师作乐。此中非无乐具乐器及乐人等。但于其中乐师最胜故得其名。又如书者非无种种纸墨笔等。及勤方便和合成字。然随最胜人得其名。染者锻者喻亦如是。今此亦然。虽有种种自性俱有。及相应法一切皆能感异熟果。然于其中能分别果业为最胜。是故偏说。复有说者。由三义故说名为业。一有作用故。二有行动故。三有造作故。有作用者。即是语业。如是评论我当如是如是所作。有行动者。即是身业虽实无动如往余方。有造作者。即是意业造作前二。由此义故说名为业。十业道者。谓身三业道。语四业道。意三业道

问十善业道十不善业道岂不合说有二十耶。何故此中但说有十。答不过十故。谓依恶行所依止处。发起十种不善业道。即依此处由远离故。即能发起十善业道。复有说者。略说十种广说二十。如略广如是。无差别差别。总别。遍不遍。无异有异。俱时次第应知亦尔。复有说者。随利根者故说有十。随钝根者故说二十。如利根钝根如是。因力缘力内力外力。内如理作意所任持力。外他言音多修习力。略开智力广辩智力。应知亦尔。是名十业道自性

已说自性。所以今当说。问何故名业道。业道有何义。答思名为业。思所游履究竟而转名为业道。问若思名业。思所游履究竟而转名业道者。余善不善一切无记。无不皆为思所游履究竟而转。一切皆应说名业道。有何殊胜不共因缘。唯说此十以为业道。答此是世尊有余之说。大师观彼所化有情心行愿乐简略而说。胁尊者曰唯佛世尊究竟了达诸法性相。亦知势用。非余所知。若法有业道相者。即便立之。无者不立。尊者妙音亦作是说。大师知此十种业道。有如是势用。如是强盛。如是亲近。能与业思作所行路令究竟转。除此业道余一切法无如是事。复有说者。由二因缘建立业道。一世所诃毁。二世所称叹。即是十种不善业道及善业道。问若世所诃毁名业道者。是则恶心出佛身血。一切世间皆共诃毁。何故不说以为业道。答若世所诃毁。如来出世及不出世。一切时有者立为业道。出佛身血有佛世有。无佛世无。故不立业道。于称叹中远离出血所有问答应知亦尔。复有说者。由三因缘建立业道。一由依处。二由施设。三由分别爱非爱果。复有说者。若由此故令内外物。有时衰损。有时增盛。建立业道。当知此中所居为外。寿等为内。云何由此外物衰损。谓断生命业道增时。一切外物皆少光泽不久坚住。若不与取业道增时。一切外物有灾有患。多遭霜雹尘秽等障。若欲邪行业道增时。一切外物多有怨竞。若虚诳语业道增时。一切外物多诸臭秽。若离间语业道增时。一切外物多不平正。丘陵坑坎崄阻悬隔。若粗恶语业道增时。一切外物粗弊鄙恶毒刺沙砾。设有金银等宝少而无光不调难用。若杂秽语业道增时。一切外物时候乖变。速疾磨灭多不成实。若贪欲业道增时。一切外物多分损减微细鲜少。若嗔恚业道增时。一切外物多分枯悴果实苦涩。若邪见业道增时。一切外物多分零落。乏少花果或全无果。是名由此令外物减云何复知由此业道故。令寿量等内物减耶。谓若十不善业道具增长时。此赡部洲有四衰损出现于世。谓寿量衰损。有情衰损。资具衰损。善品衰损。寿量衰损者。谓劫初时。此赡部洲人寿无量岁。至劫末时人寿十岁。有情衰损者。谓劫初时。此赡部洲广博严净。多诸淳善福德有情。城邑次比人民充满。至劫末时唯余万人。资具衰损者。谓劫初时。此赡部洲安隐丰乐。种种地味帝竹稻米。为上妙食。至劫末时人民饥馑唯稊稗等为上妙食。善品衰损者。谓劫初时。此赡部洲十善业道增上圆满。于劫减时十恶业道增上圆满。云何由此令诸外物有时增耶。谓若离断生命业道增时。一切外物悉多光泽长时坚住。离不与取业道增时。一切外物不为灾患。霜雹等障之所侵损。离欲邪行业道增时。一切外物无诸怨竞。离虚诳语业道增时。一切外物皆多香洁。离离间语业道增时。一切外物严好易求。地平如掌广博严净。离粗恶语业道增时。一切外物微妙丰饶。无有崄涩毒刺沙砾。金银等宝调柔光净多所堪任。离杂秽语业道增时。一切外物时无乖变坚固成实。无贪业道增时。外物充足圆满增盛。无嗔业道增时。外物光泽果实甘美。正见业道增时。外物丰饶花果繁实。是名由此令外物增。云何复知由此业故。令寿量等内物增耶。谓若十善业道具增长时。此赡部洲有四增盛出现于世。谓寿量增盛。有情增盛。资具增盛。善品增盛。寿量增盛者。谓劫末时。此赡部洲人寿十岁。至劫增时寿八万岁。有情增盛者。谓劫末时。此赡部洲唯余万人。至劫增时广博严净。多诸淳善福德有情。城邑次比人民充满。资具增盛者。谓劫末时。此赡部洲。人民饥馑。以稊稗等为上妙食。至劫增时安隐丰乐。种种地味帝竹稻米。为上妙食。善品增盛者。谓劫末时。世间十恶业道增盛。至劫增时。世间十善业道增盛。复有说者。由三果故立十业道。一异熟果。二等流果。三增上果。谓断生命。若习若修若多修习。生那落迦傍生鬼趣。是异熟果。从彼处没来生人中。多病短命。是等流果。彼增上故所感外物皆少光泽。不久坚住。是增上果。诸不与取。若习若修若多修习。生那落迦傍生鬼趣。是异熟果。从彼处没来生人中。财宝匮乏是等流果。彼增上故所感外物有灾有患。多遭霜雹尘秽等障。是增上果。诸欲邪行。若习若修若多修习。生那落迦傍生鬼趣。是异熟果。从彼处没来生人中。妻不贞良。是等流果。彼增上故所感外物多有怨竞。是增上果。诸虚诳语。若习若修若多修习。生那落迦傍生鬼趣。是异熟果。从彼处没来生人中多遭诽谤。是等流果。彼增上故所感外物多诸臭秽。是增上果。诸离间语。若习若修若多修习。生那落迦傍生鬼趣。是异熟果。从彼处没来生人中。亲友乖离是等流果。彼增上故所感外物多不平正。丘陵坑坎崄阻悬隔。是增上果。诸粗恶语。若习若修若多修习。生那落迦傍生鬼趣。是异熟果。从彼处没来生人中。恒闻种种不如意声。是等流果。彼增上故所感外物粗弊鄙恶毒刺沙砾。虽有金等少而无光不调难用。是增上果。诸杂秽语。若习若修若多修习生那落迦傍生鬼趣。是异熟果。从彼处没来生人中。言不威肃。是等流果。彼增上故所感外物时候乖变。速疾磨灭多不成实。是增上果。诸有贪欲。若习若修若多修习。生那落迦傍生鬼趣。是异熟果。从彼处没来生人中。贪欲猛利。是等流果。彼增上故所感外物多分损减微细鲜少。是增上果。诸有嗔恚。若习若修若多修习。生那落迦傍生鬼趣。是异熟果。从彼处没来生人中。嗔恚猛利。是等流果。彼增上故所感外物多分枯悴果实苦涩。是增上果。诸有邪见。若习若修若多修习。生那落迦傍生鬼趣。是异熟果。从彼处没来生人中。愚痴猛利。是等流果。彼增上故所感外物多分零落乏少花果或全无果。是增上果。离断生命。若习若修若多修习。生人天趣。是异熟果。从彼处没来生此间无病长寿。是等流果。彼增上故所感外物皆多光泽长时坚住。是增上果。由此道理其余白品九善业道。与上相违皆应广说。故由三果立十业道

问何故不说思为业道。答思即是业。思所行故名为业道。当知业道非即是思。是故不说。如王所行说名王路。而王路非王。此亦如是。思所行故说名业道。而业道非思。王座等喻亦复如是。复有说者。若法与思譬如三事和合而生。有作用转立为业道。思不与思譬如三事和合而生。有作用转故非业道。复有说者。若法与思俱时而生。有作用转立为业道。思不与思俱时而生。有作用转不立业道。复有说者。若法与思同在现在。与思为路立为业道。思不与思同在现在。与思为路不立业道。问若遣他断生命。乃至作杂秽语。彼使或经多日。乃作时遣他者思灭已久。云何得名与思同在现在为路。令思究竟立业道耶。答就可得义建立业道。谓若余法可得与思同时为路故立业道。非一刹那二思可得现在为路。是故不立思为业道。问思亦与思同在现在。谓他相续思。何故不说。答依自相续建立业道不依他立

已说三业十业道自性。今当显示杂无杂相。三业十业道。为三摄十。十摄三耶。答应作四句。有业非业道。谓业道所不摄身语业及意业全。有业道非业。谓后三业道。有业亦业道。谓前七业道。有非业非业道。谓除前相。相谓所名。如前广说。谓色蕴中除业取余色蕴。行蕴中除不善贪嗔邪见及无贪无嗔正见并一切思。取余相应不相应行蕴。及三蕴全并无为法。如是一切作第四句故言谓除前相。问十业道中何故前七建立业及业道。后三唯业道非业耶。答如施设论说。诸断生命是业是作用。与能发起断生命思。为因为道为迹为路。广说乃至诸杂秽语是业是作用。与能发起杂秽语思。为因为道为迹为路。所有不善贪恚邪见。非业非作用。唯与即彼俱生品思。为因为道为迹为路。离断生命是业是作用。与能发起离断生命思。为因为道为迹为路。广说乃至离杂秽语是业是作用。与能发起离杂秽语思。为因为道为迹为路。所有无贪无嗔正见。非业非作用。唯与即彼俱生品思。为因为道为迹为路。由此证知彼义应尔

说一切有部发智大毗婆沙论卷第一百一十三阿毗达磨大毗婆沙论卷第一百一十四

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    业蕴第四中恶行纳息第一之三

三业。谓身语意业。四业。谓黑黑异熟业。白白异熟业。黑白黑白异熟业。非黑非白无异熟业。能尽诸业。为三摄四。四摄三耶。问何故作此论。答为欲分别契经义故。如契经说三业四业。契经虽作是说。而未广辩。亦未曾说为三摄四。为四摄三。乃至广说。复有说者。前虽分别三业。而未分别四业。今欲分别故作斯论。此中云何黑黑异熟业。谓不善业能感崄恶趣异熟。问异熟不应名黑所以者何。如品类足说。云何黑法。谓不善法及有覆无记法。云何白法。谓善法及无覆无记法。诸异熟果无覆无记。何故名黑。答此中但应说云何黑业。谓不善业能感崄恶趣。不应更说黑异熟言。应如是说而不尔者。有何意趣。谓如是说已成立黑是因非果。如说。贼儿此所出言骂父非子。此中亦尔。复有说者。此中依止不可意黑故作是说。黑有二种。一染污黑。二不可意黑。此中业由二黑故说名为黑。异熟但由不可意黑故亦名黑。问黑业亦感人天中异熟。何故但说感恶趣异熟耶。答亦应说而不说者。当知此义有余。复有说者。彼不决定。谓人天中若处有黑业异熟。此处必有白业异熟。无处唯有黑业异熟。无白业异熟者。诸恶趣中若处有白业异熟。此处必有黑业异熟。有处唯有黑业异熟。无白业异熟者。由恶趣中有决定黑异熟处。是故偏说。集异门论复作是说。云何黑黑异熟业。谓不善业感那落迦趣。问诸不善业亦感傍生鬼趣异熟。何故唯说感那落迦不说余耶。答应说而不说者。当知此义有余。复有说者。彼不决定。谓傍生鬼趣亦受不善业异熟。亦受善业异熟。那落迦趣决定唯受不善业异熟。是故偏说。复有说者。世尊经中以重恶业怖诸有情。为顺彼经是故但说感那落迦诸不善业名黑黑异熟业。为显此义应引彼经。有二外道。一名布剌拏憍雉迦。受持牛戒。二名頞制罗迻尔迦。受持狗戒。此二外道于一时间同集会坐。作如是言。世间所有难行禁戒。我等二人修学已满。谁能如实记别我等所感异熟。闻释迦种生一太子颜貌端正。以三十二大丈夫相八十随好庄严其身。观无厌足。身真金色。常光一寻言音清亮和雅悦意。过妙音鸟羯罗频迦。智见无碍辩才无滞。厌舍家法出趣非家勤修苦行。复还厌离修处中行。证得无上正等菩提。具一切智如实证见诸法性相。断一切疑网。施一切决定。究达一切问论原底。我等二人今应往问。若得记别我等禁戒所感异熟。则当依学岂不快哉。于是二人来至佛所。种种爱语。相慰问已。退坐一面。时布剌拏。先为他问。而白佛言。此迻尔迦受持狗戒修学已满。当何所趣当何所生。世尊告曰。汝布剌拏止不须问勿因此事。汝等皆当不忍不信心怀耻恨。如是至三。彼犹殷勤请问不止。佛以慈愍告言。谛听吾当为汝如实记别。受持狗戒若无缺犯当生狗中。若有缺犯当堕地狱。时布剌拏闻佛语已。心怀忧怖悲泣哽咽不能自胜。世尊告曰。吾先岂不数告汝言。止不须问勿因此事。汝等皆当不忍不信心怀耻恨。今果如是。时布剌拏便自抑止而白佛言。不以世尊记迻尔迦。当生狗趣故我悲泣。然我长夜受持牛戒修学已满。恐亦当尔所以忧怖。唯愿大慈为我宣说受持牛戒。当何所趣当何所生。世尊告曰。受持牛戒若无缺犯当生牛中。若有缺犯当堕地狱。如是等事如经广说。问云何受持狗戒牛戒名无缺犯。答若持狗戒一如狗法名无缺犯。若持牛戒一如牛法名无缺犯。若不尔者名有缺犯。是故世尊以重恶业怖诸有情。故说能感那落迦趣诸不善业。为顺彼经故集异门作如是说。感那落迦诸不善业名黑黑异熟业。复有说者。见道所断诸不善业名黑黑异熟业。自种类中无白杂故。如是说者。一切不善业皆名黑黑异熟业。由欲界中不善强盛。不为善法之所陵杂。以不善法能伏能断自地善故。善业羸劣而为不善之所陵杂。以欲界善不能断不善故

云何白白异熟业。谓色界系善业。问无色界系善业亦感白异熟。何故唯说色界系善业名白白异熟业。不说无色界系善业耶。答应说而不说者。当知此义有余。复有说者。若说色界系善业名白白异熟业。当知已说无色界系善业亦是彼业。同是定地修地法故。若说此当知亦说彼。复有说者。若诸善业能感二种异熟果。谓中有生有此善业名白白异熟业。无色界业唯感生有。不感中有。是故不说。如中有生有如是。起受生受。起异熟生异熟。起果生果。细果粗果。应知亦尔。复有说者。若业能感二种异熟。谓色非色此诸善业名白白异熟业。无色界业唯感非色。不感于色。是故不说。复有说者。若具二业能感异熟。谓色非色。此中善业名白白异熟业。无色界唯有非色业。无有色业。是故不说。如色非色如是。相应不相应。有所依无所依。有行相无行相。有所缘无所缘。有作意无作意。二种业应知亦尔。复有说者。若具三业能感异熟。谓身语意。此净善业名白白异熟业。无色界中唯有意业能感异熟。是故不说。复有说者。若具以五蕴能感异熟。此净善业名白白异熟业。无色界中唯有四蕴能感异熟。是故不说。复有说者。若有具足十善业道能感异熟。此净善业名白白异熟业。无色界中唯有三善业道。能感异熟。是故不说。复有说者。若此界中有二鲜净。有二明白。一因。二果。此界善业名白白异熟业。无色界中有一鲜净明白。谓因。是故不说。由如是等种种因缘。唯色界系善业名白白异熟业。非无色界系善业。云何黑白黑白异熟业。谓欲界系善业。能感人天趣异熟业。问无有一业亦黑亦白。何故名黑白黑白异熟业耶。答为欲显示一依止中。一相续中。受二种业所感异熟。一黑。二白。是故说名黑白黑白异熟业。问诸恶趣中亦受黑白二业异熟。何故唯说能感人天趣异熟业。名黑白黑白异熟业。不说能感恶趣异熟业耶。答应说而不说者。当知此义

有余复有说者。若说能感人天善业名黑白黑白异熟业。当知已说能感恶趣善业亦是彼业。以杂杂相无差别故。若说此当知已说彼。复有说者。彼不决定。是故不说。谓在欲界人天趣中。无有一处而不杂受黑白业异熟者。诸恶趣中虽有杂受黑白业异熟处。而更有处一向纯受黑业异熟。谓一分傍生鬼。及一切地狱。由恶趣中有不决定。是故不说。复有说者。欲界系修所断善不善业。名黑白黑白异熟业。一种类中二业杂故。复有说者。若善不善业。能感欲界人天傍生鬼趣异熟。名黑白黑白异熟业。于一趣中杂受二业异熟故。如是说者。欲界一切善业。名黑白黑白异熟业。以彼善业体虽是白。而为不善黑所陵杂。以不善能断自地善故。不善不尔。不为自地善所陵杂。自地善不能断自地不善故。由此欲界善业名第三业。云何非黑非白无异熟业能尽诸业。谓能永断诸业学思。问诸无漏业是胜义白何故乃名非黑非白。答集异门论施设论。皆说此业不同。不善染污黑。及感不可意异熟黑故说非黑。又亦不同善有漏白。及感可意异熟白故说非白。复有说者。此依果白故说非白。白有二种。一因白。二果白。善有漏业具二白故名白。诸无漏业。唯有因白而无果白。故不名白。复有说者。依异熟白故名非白。白有二种。一自体白。二异熟白。善有漏业具二白故名白。无漏业唯有自体白无异熟白故不名白。复有说者。此无漏业能断世间所爱异熟。非世所爱无有白相。故不名白。以是义故名非黑白。此无漏业非如前三感异熟果。是故说名无异熟业。此无漏业令前三业毕竟灭尽等尽遍尽。永断永害弃舍变吐离欲寂灭。是故说名能尽诸业。如是则说十七学思。谓见道中四法智忍相应学思。离欲界染八无间道相应学思。此十二思能尽黑黑异熟业。离欲界染第九无间道相应学思。能尽黑黑异熟业。及黑白黑白异熟业。离初静虑染第九无间道相应学思。乃至离第四静虑染第九无间道相应学思。能尽白白异熟业。如是十七无漏思。说名能断诸业学思。复有说者。一切无间道无漏思。皆名能断诸业学思。以一切无间道皆能断诸业故。复有说者。一切学思皆名能断诸业学思。以诸学思皆能对治有漏业故。如是说者。谓初说唯十七无漏思。正能对治前三业故。问诸无漏慧相应俱有。皆能正断前三种业。何故唯说无漏学思。答思能发动诸法令断是故偏说。复有说者。虽皆能断此中辨业故唯说思。问若尔。亦应说随转身语业。何故唯说思耶。答由此学思与无漏慧相应而转。同一所缘同一行相。同一所依。相助有力能断诸业。非身语业得有是事。是故不说

已说三业四业自性。今当显示杂无杂相。三业四业为三摄四四摄三耶。答三摄四。非四摄三。不摄者何。谓除能断诸业学思。余无漏业无色界系善业一切无记业。此中除能断诸业学思余无漏业者诸说十七无漏思为第四业者。彼说除十七思。余无漏加行无间解脱胜进道相应思。及学随转业。并一切无学业。是名余无漏业。诸说一切无间道相应学思为第四业者。彼说除一切无间道。余无漏加行解脱胜进道相应学思。及学随转业。并一切无学业。是名余无漏业。诸说一切学思为第四业者。彼说学随转业。一切无学业。是名余无漏业。如是说者。谓初说除无色界系善业者。谓无色界系一切善业。除无记业者。谓三界系诸无记业。由此道理三业具摄学无学非学非无学业。四业唯摄学非学非无学业。三业具摄欲界色界无色界系业。四业唯摄欲色界系业。三业具摄善不善无记业。四业唯摄善不善业。三业具摄见所断修所断无断业。四业唯摄三种一分。三业具摄有漏无漏业。染污不染污业。有异熟无异熟业。相应不相应业。有随转无随转业。表无表业。四业唯摄诸二业少分。如是等门皆应广说。是故说言三摄四。非四摄三。不摄者何。谓除能断诸业学思。余无漏业。无色界系善业。一切无记业。三业谓身语意业复有三业。谓顺现法受业。顺次生受业。顺后次受业。问何故作此论。答为欲分别契经义故。如契经说。顺现法受等三业。而不广辩。广说如前。复有说者。前虽分别身等三业。而未分别顺现法受等三业。今欲分别故作斯论

云何顺现法受业。谓若业此生造作增长。则于此生受异熟果。是名顺现法受业。问若业此时造作增长。则于此时受异熟果耶。答不尔。所以者何。诸善恶业要待相续。或度相续方受异熟。谓若此业造作增长。或则于此一相续中。或则于此一时分中。或则于此一众同分中受异熟果。如是名为顺现法受业。必无有业此刹那造。则此及次刹那熟义。由异类故。亲引发故。此中所有世所现见顺现法受业者。曾闻。有采樵者。入山遇雪迷失途路。时会日暮雪深寒冻。将死不久即前入一蒙密林中。乃见一罴先在林内。形色青绀眼如双炬。其人惶恐分当失命。此实菩萨现受罴身。见其忧恐寻慰喻言。汝今勿怖。父母于子或有异心。吾今于汝终无恶意。即前捧取将入窟中。温暖其身令稣息已。取诸根果劝随所食。恐冷不消抱持而卧。如是恩养。经于六日至第七日。天晴路现人有归心。罴既知已复取甘果饱而饯之。送至林外殷勤告别。人跪谢曰。何以报恩。罴言。我今不须余报。但如此日我护汝身。汝于我命亦愿如是。其人敬诺担樵下山。逢二猎师。问言。山中见何虫兽。樵人答言。我亦不见余兽。唯见一罴。猎师求请。能相示不。樵人答曰。若能与我三分之二。吾当示汝。猎师依许相与俱行。竟害罴命分肉为三。樵人两手欲取罴肉。恶业力故双臂俱落。如珠缕断。如截藕根。猎师荒忙惊问所以。樵人耻愧具述委由。是二猎师责樵人曰。他既于汝有此大恩。汝今何忍行斯恶逆。怪哉汝身何不糜烂。于是猎师共持其肉施僧伽蓝。时僧上座得妙愿智。则时入定观是何肉。则知是与一切众生作利乐者大菩萨肉。寻时出定以此事白众。众皆惊叹共取香薪。焚烧其肉收其余骨。起窣堵波礼拜供养。如是恶业。要待相续。或度相续。方受其果

复次昔有屠贩牛人。驱牛涉路人多粮尽饥渴热乏。息而议曰。此等群牛终非己物。宜割取舌以济饥虚。则时以盐涂诸牛口。牛贪碱味出舌舐之。则用利刀一时截取。以火暗炙而共食之。食已相与临水澡漱。俱嚼杨枝揩齿既了。擘以刮舌。恶业力故。诸人舌根犹如烂果一时俱落。如是恶业。要待相续。或度相续。方受其果

复次闻昔有暴恶者。令母执器自构牛乳。构便过量。母止之言。余者可留以乳犊子。其人既闻忽生嗔忿。以手掬乳散其母面。随着母身乳滴多少。恶业力故则令彼人身上还生尔所白癞。如是恶业。要待相续。或度相续。方受其果。是为略引顺现法受三种恶业。昔憍萨罗国有王名胜军。生其一女具十八丑。贫贱者不与。富贵者不求。有长者子财位丧失。王闻遣使召至告言。吾有小女少乏容色。卿若不耻厚俸珍财。其人许之。王闻欢喜。多赐财宝田宅仆使恣其所欲。降嫔以礼密令归第。其人惭耻出则关钥。亲知莫见。有诸密友。责言。何故不示我妻。长者子言。何遽之有。众人怪其推延遂共立约。却后七日各将室家会某园林欢娱宴赏。违者当罚金钱五百。至第七日皆如所约。唯长者子不将妇来。自恃财富任罚多少。其妇独在家中自责自恨。我宿何罪受此恶身。众人皆乐唯我独苦。不如早死。一心念佛便欲自害。佛知时至。则于此没踊出其前。女见如来深生悲喜。发殷净心观佛相好。善业力故。须臾变身犹如天女。倍增踊跃。佛为说法。远尘离垢得预流果。世尊既还彼女独坐。端正无比安隐快乐。时彼朋类既见其人不将妻室便醉以酒。窃其户钥共往其家。遥见其妇端严无比如帝释妃。于是众人深生赞仰。因相谓曰。比不示人诚由于此。则驰园所共谢其夫并庆赞之。其人惭赧谓相讥弄。及还见之深生疑怪。问言。圣女为是幻术。为鬼魅耶。我妇安在。其妻具以上事答之。于是其夫得未曾有归依三宝。如是善业。要待相续。或度相续。方受其果

昔健驮罗国迦腻色迦王。有一黄门恒监内事。暂出城外见有群牛数盈五百来入城内。问驱牛者。此是何牛。答言。此牛将去其种。于是黄门则自思忖。我宿恶业受不男身。今应以财救此牛难。遂偿其价悉令得脱。善业力故。令此黄门则复男身。深生庆悦寻还城内。伫立宫门附使启王。请入奉觐。王令唤入怪问所由。于是黄门具奏上事。王闻惊喜厚赐珍财。转授高官令知外事。如是善业。要待相续。或度相续。方受其果

昔怛叉尸罗国有一女人。至月光王舍千头处礼无忧王所起灵庙。见有狗粪在佛座前。寻作是思。此处清净。如何狗粪秽污其中。以手捧除香泥涂饰。善业力故。令此女人遍体生香如栴檀树。口中常出青莲华香。如是善业。要待相续。或度相续。方受其果。是为略引顺现法受三种善业

云何顺次生受业。谓若业此生造作增长。于第二生受异熟果。是名顺次生受业

云何顺后次受业。谓若业此生造作增长。随第三生。或随第四。或复过此。受异熟果。是名顺后次受业

问诸顺现法受业。定于现法受耶。顺生顺后为问亦尔。譬喻者说。此不决定。以一切业皆可转故。乃至无间业亦可令转。问若尔。云何说名顺现法受业等耶彼作是说。诸顺现法受业不定。于现法中受异熟果。若受者定于现法非余。故名顺现法受业。顺生顺后所说亦尔。彼说一切业皆可转。乃至无间业亦可转。若无间业不可转者。应无有能越第一有。然有能越第一有者。是故无间业亦应可转。阿毗达磨诸论师言。诸顺现法受业。决定于现法中受异熟果。故名顺现法受业。顺生顺后所说亦尔。是故若问何故名顺现法受业。乃至顺后次受业。应以此答

复有余师。说四种业。谓顺现法受业。顺次生受业。顺后次受业。顺不定受业。诸顺现法受业。乃至顺后次受业此业不可转。诸顺不定受业此业可转。唯为转此第四业故。受持禁戒勤修梵行。彼作是思。愿我由是当转此业。复有余师。说五种业。谓顺现法受业。顺次生受业。顺后次受业。各唯一种顺不定受业中复有二种。一异熟决定。二异熟不决定。诸顺现法受业。顺次生受业。顺后次受业。顺不定受业中异熟决定业。皆不可转。顺不定受业中异熟不决定业。此业可转。唯为转此第五业故。受持禁戒勤修梵行。彼作是思愿我由是当转此业。复有余师。说八种业。谓顺现法受业有二种。一异熟决定。二异熟不决定。顺次生受业。顺后次受业。顺不定受业亦各有二。一异熟决定。二异熟不决定。是谓八业。于中诸异熟定业皆不可转。诸异熟不定业皆可转。为转此故受持禁戒勤修梵行。是故此中应作四句。谓或有业时分决定异熟不定。或有业异熟决定时分不定。或有业时分决定异熟亦定。或有业时分不定异熟亦不定。云何业时分决定异熟不定。谓顺现法受业。顺次生受业。顺后次受业中。异熟不定业。云何业异熟决定。时分不定谓顺不定受业中异熟定业。云何业时分决定异熟亦定。谓顺现法受业。顺次生受业。顺后次受业中异熟定业。云何业时分不定异熟亦不定。谓顺不定受业中异熟不定业。如是名为八业四句。问颇有一时一刹那顷能起三种业耶。谓顺现法受业。顺次生受业。顺后次受业。答有。谓先遣二使。断生命。不与取。后自行欲邪行。以此自所究竟非由他故。若有如是种类法生。三业同时皆得究竟。于中初业于现法中受异熟果。第二业于无间生受异熟果。第三业于随第三生以后诸生受异熟果。其余业道自作教他差别亦尔

问此顺现法受业等。几能引众同分果。几能满众同分果。或有说者。二能引众同分果。亦能满众同分果。谓顺次生受业。顺后次受业。二能满众同分果。不能引众同分果。谓顺现法受业。顺不定受业。复有说者。三能引众同分果。亦能满众同分果。谓除顺现法受。一能满众同分果。不能引众同分果。谓顺现法受。复有欲令顺现法受业。亦能引众同分果。若作是说。此四种业。一切皆能引众同分果。及满众同分果。问如是诸业何者最胜。或有说者。顺现法受业最胜。所以者何。近得果故。复有说者。顺后次受业最胜。所以者何。一切菩萨业最为胜。而皆是顺后次受故。问顺现法受业能近得果。于诸业中可说为胜。顺后次受业去果悬远。云何最胜耶。答顺现法受业虽近得果。而果下劣不名最胜。顺后次受业虽去果远。而果殊胜难尽故名最胜。如外种子有近得果而果下劣。有去果远而果最胜。如有秋苗经三半月则便结果。此果最近而最下劣。如稻麦等经于六月其果乃熟。去果次远而次为胜。如佉梨树经五六年或十二年方结其果。此果次胜。如多罗树经于百年方结其果。此果最胜。如外种子去果最近其果最劣。去果次远其果次胜。去果最远其果最胜。种随其果胜劣差别。内业亦尔。顺现法受业。去果最近而果最劣。顺次生受业去果次远而果次胜。顺后次受业。去果最远而果最胜。业随其果胜劣差别。故顺后次受业最胜非余。问于何界中能造几业。有说。欲界能造四种善不善业。色无色界能造三种善业。除顺现法受。所以者何。于欲界中依佛菩萨声闻独觉父母师长诸有德边。发起增上善恶业故。此业速疾受异熟果。色无色界无此胜缘。是故于彼不能起此顺现法受业。问若尔。品类足说当云何通。如彼说言。顺现法受业。顺次生受业。顺后次受业。一切随眠之所随增。答于彼论中应作是说。顺现法受业。欲界一切随眠之所随增。顺次生受业。顺后次受业。欲界一切随眠。色无色界遍行随眠。及修所断随眠之所随增。应作是说。而不说者。有何意趣。当知彼文是总略而说。问若尔。集异门说复云何通。如彼说言。顺现法受业。顺次生受业。顺后次受业。欲界一切随眠。色无色界遍行随眠。及修所断随眠之所随增。答彼文应作是说。顺现法受业。欲界一切随眠之所随增。顺次生受业。顺后次受业。欲界一切随眠。色无色界遍行随眠。及修所断随眠之所随增。应作是说。而不说者有何意趣。当知彼中言势所引。故作是说。如是说者。色无色界亦能引起顺现法受业。问前说欲界依佛菩萨等胜缘能起顺现法受业。上二界无此胜缘。云何能起。答彼处但以因力任持。亦能引起顺现法受业。欲界亦有但由因力起此业者。谓或有人开门大施供养贤圣。而不能引顺现法受业。或复有人以一抟食施一傍生。而能引起顺现法受业。如是等故知不必皆依胜缘而起此业。然其要由因力任持方能引起。是故往昔阿毗达磨迦湿弥罗诸大论师咸作是说。若殷净心持一把草施他牛食。当知能引顺现法受业

问于何趣中能造几业。答那落迦中能造四种不善业三种善业。除顺现法受。傍生饿鬼。及三洲人。欲界天中。能造四种善不善业。北拘卢洲能造四种善业三种不善业。除顺次生受。色无色界天中。能造多少如前已说。问于何生中能造几业。答于四生中皆能造四种善不善业

问谁于何地能造几业。答若诸异生生在欲界未离欲界染。能造欲界四种善不善业。若已离欲界染未离初静虑染。若退法者。彼能造欲界四种业。能造初静虑三种业。除顺现法受。有说。彼能造初静虑二种业。谓顺后次受及不定受。若不退法者。彼能造欲界三种善业。除顺次生受。能造初静虑三种业。除顺现法受。若已离初静虑染。未离第二静虑染。若退法者。彼能造欲界四种业。能造初二静虑三种业。除顺现法受。有说。彼能造第二静虑二种业谓顺后次受。及不定受。若不退法者。彼能造欲界三种善业。除顺次生受。能造初静虑二种业。谓顺后次受。及不定受能造第二静虑三种业。除顺现法受。广说乃至。若已离无所有处染。若退法者。彼能造欲界四种业。能造四静虑四无色三种业。除顺现法受。有说。彼能造非想非非想处二种业。谓顺后次受。及不定受。若不退法者。彼能造欲界三种善业。除顺次生受。能造四静虑三无色二种业。谓顺后次受及不定受。能造非想非非想处三种业。除顺现法受。如是已说异生生在欲界。若诸异生生初静虑未离初静虑染。彼能造初静虑四种业。若已离初静虑染未离第二静虑染。彼能造初静虑三种业。除顺次生受。能造第二静虑三种业。除顺现法受。广说乃至。若已离无所有处染。彼能造初静虑三种业。除顺次生受。能造三静虑三无色二种业。谓顺后次受及不定受。能造非想非非想处三种业。除顺现法受。如说生初静虑。如是乃至生非想非非想处亦应广说。如是已说诸地异生。若诸圣者生在欲界未离欲界染。彼能造欲界四种善不善业。已离欲界染未离初静虑染。彼能造欲界二种业。谓顺现法受。及不定受能造初静虑三种业。除顺现法受。已离初静虑染。未离第二静虑染。若退法者。彼能造欲界二种业。谓顺现法受及不定受。能造初二静虑三种业。除顺现法受。有说。彼能造第二静虑二种业。谓顺后次受及不定受。若不退法者。彼能造欲界二种善业。谓顺现法受及不定受。能造初静虑一种业。谓不定受。能造第二静虑三种业。除顺现法受。乃至若已离无所有处染。未离非想非非想处染。若退法者。彼能造欲界二种业。谓顺现法受及不定受。能造四静虑三种业。除现法受。能造四无色三种业。除顺现法受。此则总说。若别说者。四无色中。若造顺次生受业。则不造顺后次受业。若造顺后次受业。则不造顺次生受业。有说。彼能造非想非非想处二种业。谓顺后次受及不定受。若不退法者。彼能造欲界二种善业。谓顺现法受及不定受。能造四静虑三无色一种业。谓不定受。能造非想非非想处二种业。谓顺次生受及不定受。若已离非想非非想处染。彼能造欲界二种业。谓顺现法受及不定受。能造四静虑四无色一种业。谓不定受。如是已说圣者生在欲界。若诸圣者生初静虑。未离初静虑染。彼能造初静虑三种业。除顺后次受。若已离初静虑染。未离第二静虑染。彼能造初静虑二种业。谓顺现法受及不定受。能造第二静虑三种业。除顺现法受。若已离第二静虑染。未离第三静虑染。彼能造初静虑二种业。谓顺现法受及不定受。能造第二静虑一种业。谓不定受。能造第三静虑三种业。除顺现法受。广说乃至。若已离无所有处染。未离非想非非想处染。彼能造初静虑二种业。谓顺现法受及不定受。能造三静虑三无色一种业。谓不定受。能造非想非非想处二种业。谓顺次生受及不定受。若已离非想非非想处染。彼能造初静虑二种业。谓顺现法受及不定受。能造三静虑四无色一种业。谓不定受。如说圣者生初静虑。如是生第二第三第四静虑广说亦尔。除未离自地染。彼能造自地四种业与前差别。若诸圣者生空无边处。未离空无边处染。彼能造空无边处二种业。谓顺现法受及不定受。若已离空无边处染。未离识无边处染。彼能造空无边处二种业。谓顺现法受及不定受。能造识无边处二种业。谓顺次生受及不定受。若已离识无边处染。未离无所有处染。彼能造空无边处二种业。谓顺现法受及不定受。能造识无边处一种业。谓不定受。能造无所有处二种业。谓顺次生受及不定受。若已离无所有处染。未离非想非非想处染。彼能造空无边处二种业。谓顺现法受及不定受。能造识无边处无所有处一种业。谓不定受。能造非想非非想处二种业。谓顺次生受及不定受。若已离非想非非想处染。彼能造空无边处二种业。谓顺现法受及不定受。能造三无色一种业。谓不定受。如说圣者生空无边处。如是乃至生非想非非想处广说亦尔。住欲界中有位。能造二十二种业。谓中有位异熟定业及不定业。如是羯剌蓝。遏部昙。闭尸。键南。钵罗奢佉。初生。婴孩。童子。少壮。衰老位。各有异熟定及不定业。是名二十二业。住羯罗蓝位。能造二十种业。谓除中有业二。如是乃至住衰老位能造二业。谓则老位定及不定业。问若中有位所造诸业。至本有位受异熟者。此业当言是顺现法受。顺次生受耶。答此是顺现法受业。非顺次生受。所以者何。中有本有总众同分无差别故

已说前后三业自性。今当显示杂无杂相。为前摄后。后摄前耶。答前摄后。非后摄前。不摄者何。谓不定业。无记业。无漏业。此中前三通摄定不定业。后三唯摄定业。前三通摄善不善无记业。后三唯摄善不善业。前三通摄有漏无漏业。后三唯摄有漏业。如是广说有无量门前后差别。今简略说。故言前摄后非后摄前。不摄者何。谓不定业。无记业无漏业

说一切有部发智大毗婆沙论卷第一百一十四阿毗达磨大毗婆沙论卷第一百一十五

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    业蕴第四中恶行纳息第一之四

三业。谓身语意业。复有三业。谓顺乐受业。顺苦受业。顺不苦不乐受业。问何故作此论。答为欲分别契经义故。如契经说。顺乐受等业。契经虽作是说。而不广辩。广说如前。复有说者。前虽分别身等三业。而未分别顺乐受等三业。今欲分别故作斯论。所说受名总有五种。一自性受。二现前受。三所缘受。四相应受。五异熟受。自性受者。如说三受。谓乐受。苦受。不苦不乐受。现前受者。如大因缘法门经说。阿难当知。受乐受时余二受便灭。应知如是所受乐受。是无常苦灭坏之法。离我我所如是苦受。不苦不乐受应知亦尔。所缘受者。如识身论说。眼色为缘生于眼识。三和合故触。触为缘故受。当知此受能领受色非数取趣。色是眼触所生受缘非数取趣。如是乃至意法广说亦尔。相应受者。如说有乐受法。有苦受法。有不苦不乐受法。云何乐受法。谓乐受相应法。云何苦受法。谓苦受相应法。云何不苦不乐受法。谓不苦不乐受相应法。异熟受者。如此中说。顺乐受业。顺苦受业。顺不苦不乐受业。于此五受中依异熟受而作此论。云何顺乐受业。谓欲界系善业。乃至第三静虑地善业。云何顺苦受业。谓不善业。云何顺不苦不乐受业。谓广果系善业。及无色界系善业。问顺乐受业决定能感乐受异熟果耶。余二受业为问亦尔。若决定者。此后所说当云何通。如后论言。颇有业不感身心受异熟。而感异熟耶。答有。谓诸业感色心不相应行异熟。若不定者。何故说名顺乐受业。顺苦受业。顺不苦不乐受业。有说定感。谓顺乐受业。决定能感乐受异熟。由此故名顺乐受业。乃至顺不苦不乐受业。决定能感不苦不乐受异熟。由此故名顺不苦不乐受业。问若尔。后所说云何通。如说。颇有业不感身心受异熟。而感异熟耶。乃至广说。答彼业定感彼受异熟。及感色心不相应行。然所感受不常现前。所感色等则恒相续。于所感受不现前时。说彼受业唯感色心不相应行。是故无过。如此则二文善通。复有说者。顺乐受业不定。能感顺乐受异熟。乃至顺不苦不乐受业不定。能感不苦不乐受异熟。问若尔。何故此业名顺乐受等耶。答顺乐受业。虽不定感乐受异熟。然感乐受异熟者唯此业非余。故说此为顺乐受业。余二受业所说亦尔。复有说者。顺乐受业。虽不定感乐受异熟。然如乐受能与喜乐作所依止。令喜乐生相续而转作安足处。余异熟果亦能如是。故名顺乐受业。顺苦受业。虽不定感苦受异熟。然如苦受能与忧苦作所依止。令忧苦生相续而转作安足处。余异熟果亦能如是。故名顺苦受业。顺不苦不乐受业。虽不定感不苦不乐受异熟。然如不苦不乐受。不能与喜乐忧苦作所依止。不能令喜乐忧苦生。相续而转作安足处。余异熟果亦复如是。故名顺不苦不乐受业。复有说者。如乐受能长养所依。余异熟亦尔。故名顺乐受业。如苦受能损害所依。余异熟亦尔。故名顺苦受业。如不苦不乐受。非能长养亦非损害所依。余异熟亦尔。故名顺不苦不乐受业。问欲界乃至第三静虑。有不苦不乐受异熟不。若有者。此中所说云何通。如说。云何顺不苦不乐受业。谓广果系善业。及无色界系善业。若无者。静虑中间所有善业。当言能感何受异熟。或有说者。下地无有不苦不乐受异熟。所以者何。下地法粗。此受微细。下地不寂静。此受寂静。复有说者。下地有情所起善业。皆为求乐受故起。无有希求不苦不乐受者。是故下地所有善业。不感此受异熟。问彼亦无有求苦受者。何故下地感此异熟。答欲界有情为求乐故多造苦因。故虽不求而感彼异熟。舍受寂静无有求乐受而造舍受业者。是故无彼异熟。问静虑中间所有善业。当言能感何受异熟。答感初静虑喜根异熟。复有说者。感初静虑乐受异熟。问若尔。后文云何通。如说。颇有业感心受异熟。非身耶。答有。谓善无寻业。答彼文应作是说。谓善无寻无伺业。而不作是说者有何意耶。应知此中言势减少。或有说者。静虑中间所有善业。虽不感受异熟果。而能感色心不相应行。问若尔。何故此后论言。善无寻业感心受耶。答但言能感心受非身。不言唯感心受异熟。非感色心不相应行。复有说者。下地亦有不苦不乐受异熟。问此中所说当云何通。如说。云何顺不苦不乐受业。谓广果系善业。及无色界系善业。答此中但显顺不苦不乐受业异熟最后边际。谓第四静虑是有色地边。无色界是三界边。复有说者。此中但显此受异熟不共田器。谁是此受异熟不共田器。谓第四静虑。及无色界。复有说者。下地虽有此受异熟。然为余受所覆。相不明了不久相续。从广果上更无余受。唯有此受明了相续。是故偏说。诸说下地无不苦不乐受异熟者。彼说欲界下三静虑阿罗汉等。住威仪心入涅槃。广果阿罗汉。住威仪心异熟心入涅槃。无色界阿罗汉。住异熟心入涅槃。诸说下地亦有不苦不乐受异熟者。彼说欲界四静虑阿罗汉等。住威仪心异熟心入涅槃。无色界阿罗汉。住异熟心入涅槃

已说前后三业自性。今当显示杂无杂相。为前摄后。后摄前耶。答前摄后。非后摄前。不摄者何。谓无记业无漏业。此中前三业通有记无记。后三业唯有记。前三业通有漏无漏业。后三业唯有漏。是故言前摄后非后摄前。不摄者何。谓无记业及无漏业。三业谓身语意业。复有三业。谓过去未来现在业。复有三业谓善不善无记业。复有三业。谓学无学非学非无学业。复有三业。谓见所断修所断无断业。为前摄后。后摄前耶。答随其事展转相摄。所以者何。以身语意业自性。或过去或未来或现在。或善或不善或无记。或学或无学或非学非无学。或见所断或修所断或无断。故言随其事展转相摄

三业谓身语意业。复有三业。谓欲色无色界系业。为前摄后。后摄前耶。答前摄后。非后摄前。不摄者何。谓无漏业。此中前三业通有漏无漏。后三业唯有漏。是故言前摄后非后摄前。不摄者何。谓无漏业

四业如前说。三业谓顺现法受等业。为四摄三。三摄四耶。答应作四句。有四非三。谓能断诸业学思。欲界系善不善不定业。色界系善不定业。有三非四。谓无色界系善决定业。有四亦三。谓欲界系善不善决定业。及色界系善决定业。有非四非三。谓除能断诸业学思。余无漏业。无色界系善不定业。及无记业。四业如前说。三业谓顺乐受等业。为四摄三。三摄四耶。答应作四句。有四非三。谓能断诸业学思。有三非四。谓无色界系善业。有四亦三。谓欲界系善不善业。色界系善业。有非四非三。谓除能断诸业学思。余无漏业。及无记业

四业如前说。三业谓过去等业。复有三业。谓善等业。复有三业。谓学等业。复有三业。谓见所断等业。为四摄三。三摄四耶。答三摄四。非四摄三。不摄者何。谓除能断诸业学思。余无漏业。无色界系善业。及无记业

四业如前说。三业谓欲界系等业。为四摄三。三摄四耶。答应作四句。有四非三。谓能断诸业学思。有三非四。谓无色界系善业。一切无记业。有四亦三。谓欲界系善不善业。色界系善业。有非四非三。谓除能断诸业学思。余无漏业。三业谓顺现法受等业。复有三业。谓顺乐受等业。为前摄后。后摄前耶。答后摄前。非前摄后。不摄者何。谓不定业。此中前三唯摄定业。后三通摄定不定业。是故言后摄前非前摄后。不摄者何。谓不定业

三业谓顺现法受等业。复有三业。谓过去等业。复有三业。谓善等业。复有三业。谓学等业。复有三业。谓见所断等业。为前摄后。后摄前耶。答后摄前。非前摄后。不摄者何。谓不定业。无记业。无漏业。此中前三业。唯摄定唯有记唯有漏业。后诸三业。通摄定不定。有记无记。有漏无漏业。是故言后摄前非前摄后不。摄者何。谓不定业。无记业无漏业

三业谓顺现法受等业。复有三业。谓欲界系等业为前摄后。后摄前耶。答后摄前。非前摄后。不摄者何。谓不定业。无记业。此中前三业唯摄定唯有记业。后三通摄定不定。有记无记业。是故言后摄前。非前摄后。不摄者何。谓不定业。无记业

三业谓顺乐受等业。复有三业。谓过去等业。复有三业。谓善等业。复有三业。谓学等业。复有三业。谓见所断等业。为前摄后。后摄前耶。答后摄前。非前摄后。不摄者何。谓无记业。无漏业。此中前三业。唯有记唯有漏。后诸三业。通有记无记。有漏无漏。是故言后摄前。非前摄后。不摄者何。谓无记业。无漏业。问何故无记及无漏业不感乐受等异熟耶。答诸无记业自性羸劣势不坚住。故无异熟。诸无漏业离诸烦恼。非三界系。故无异熟。所以者何。若所起业自性坚强。烦恼所系者能感异熟。譬如外种若体坚实。有水所润粪土所覆。乃能生芽。若不坚实。虽有水润粪土所覆不能生芽。若虽坚实无水所润粪土所覆亦不生芽。内业亦尔。若体坚强爱水所润余烦恼覆能感异熟。诸无记业虽爱水润余烦恼覆。而性劣不坚不感异熟。诸无漏业虽体坚强。无爱水润余烦恼覆不感异熟。诸不善业有漏善业具足二义能感异熟。是故无记及无漏业。非前所摄

三业谓顺乐受等业。复有三业。谓欲界系等业。为前摄后。后摄前耶。答后摄前非前摄后。不摄者何。谓无记业。此中前三业唯有记。后三通有记无记。是故言后摄前非前摄后。不摄者何。谓无记业

三业谓诸过去等业。复有三业。谓善等业。复有三业。谓学等业。复有三业。谓见所断等业。为前摄后。后摄前耶。答随其事展转相摄。义异体不异故。三业谓过去等业。复有三业谓欲界系等业。为前摄后后摄前耶。答前摄后。非后摄前。不摄者何。谓无漏业。此中前三业通有漏无漏。后三唯有漏。是故言前摄后非后摄前。不摄者何。谓无漏业

三业谓善等业。复有三业。谓欲界系等业。为前摄后。后摄前耶。答前摄后非后摄前。不摄者何。谓无漏业。此中前三业通有漏无漏。后三业唯有漏。是故言前摄后非后摄前。不摄者何。谓无漏业。三业谓善等业。复有三业。谓学等业。复有三业。谓见所断等业。为前摄后。后摄前耶。答随其事展转相摄。义异体不异故。三业谓欲界系等业。复有三业。谓学等业。复有三业。谓见所断等业。为前摄后。后摄前耶。答后摄前非前摄后。不摄者何。谓无漏业。此中前三业唯有漏。后三业通有漏无漏。是故言后摄前非前摄后。不摄者何。谓无漏业。三业谓学等业。复有三业。谓见所断等业。为前摄后。后摄前耶。答随其事展转相摄如前释。颇有业感身受非心耶。答有。谓不善业。谓以不善业唯感苦根异熟故。问何故不善业不感心受耶。答彼类心受。所谓忧根而忧根非异熟故不感心受。问何故忧根非异熟耶。答忧根作意生故。分别强故。离欲舍故。异熟不尔

颇有业感心受非身耶。答有。谓善无寻业。此中诸有欲令下地无不苦不乐受异熟果者。此善无寻业所感心受异熟。谓第二静虑喜根。第三静虑乐根。第四静虑。及无色界舍根。有说。亦感初静虑喜根同一地故。而不感三识相应。乐根以此业微细故。诸有欲令下地亦有不苦不乐受异熟果者。此善无寻业所感心受异熟。谓第二静虑喜根舍根。第三静虑乐根舍根。第四静虑。及无色界舍根。有说。亦感静虑中间舍根。有说。亦感初静虑喜根乐根粗故非此业感

颇有业感身心受耶。答有。谓善有寻业。诸有欲令下地无不苦不乐受异熟果者。此善有寻业。若在欲界感五识身相应。乐根身受异熟。及感意识相应。喜根心受异熟。若在初静虑感三识身相应。乐根身受异熟。及感意识相应。喜根心受异熟。诸有欲令下地亦有不苦不乐受异熟果者。此善有寻业。若在欲界感五识身相应。乐根舍根身受异熟。及感意识相应。喜根舍根心受异熟。若在初静虑感三识身相应。乐根舍根身受异熟。及感意识相应。喜根舍根心受异熟。问何故喜根是异熟果非忧根耶。答喜受行相有粗有细。不必恒时作意而起。不必恒时是强分别。微细定中亦得有故。又此喜根非离欲舍。与异熟法不相违故有是异熟。忧根不尔故非异熟。问何故舍根唯善业感非不善耶。答舍根行相微细寂静。智者所乐故善业感。诸不善业性是粗动。故不能感舍受异熟。颇有业不感身心受而感异熟耶。答有。谓诸业感色心不相应行异熟。色异熟者。谓九处除声处。心不相应行异熟者。谓命根众同分得生住老无常。有说。及无想事

问此中何者名身受。何者名心受。答若受在五识身名身受。在意地名心受。复有说者。诸受中无分别者名身受。有分别者名心受。复有说者。若受缘自相境名身受。缘自相共相境名心受。复有说者。若受缘现在境名身受。缘三世及无为境名心受。复有说者。若受缘实有境名身受。缘实有假有境名心受。复有说者。若受于境一往取者名身受。数数取者名心受。复有说者。若受于境暂缘即了者名身受。推寻乃了者名心受。复有说者。诸受中若依色缘色名身受。若依非色缘色非色名心受。如色非色如是有对无对。积聚非积聚。和合非和合说亦尔。尊者世友说曰。佛说二受。谓身受心受。何者名身受。何者名心受。此中无有身受。诸所有受皆是心受。何以故。心相应故。然所有受若依五根转名身受。恒以身为增上缘故。若依意根转名心受。恒以心为增上缘故。有作是说。无有身受。诸所有受皆是心受。何以故。心相应故。然所有受若依三根转。取和合境名身受。恒作想故。若依三根转取不和合境名心受。非恒作想故。大德说曰。受有二种。一者身受。二者心受。若是身受。亦是心受。有是心受而非身受。谓所有受不取外事而起分别。但依内事执取其相而起分别。谓缘一切补特伽罗。有缘法处所摄色。心不相应行无为法等名心受。大德欲令如是心受。无实境界唯分别转

如说三障。谓烦恼障业障异熟障。问何故作此论。答为欲分别契经义故。如契经说。若诸有情成就六法。虽闻如来所证所说法毗奈耶。而不堪任远尘离垢。于诸法中生净法眼。何等为六。一烦恼障。二业障。三异熟障。四不信。五不乐。六恶慧。虽说成就如是六法。而未广辩亦未曾说。云何名烦恼障。云何业障。云何异熟障。彼契经是此论缘起根本。彼所未说者今应说之故作斯论。复有说者。前虽分别诸业。而未分别彼业等障。今欲分别故作斯论

如是三障。总以炽然猛利烦恼五无间业那落迦等种种异熟。为其自性。已说自性所以今当说。问何故名障。答如是三种。能碍圣道及圣道加行善根。是故名障。云何烦恼障。谓如有一本性具足炽然贪嗔痴烦恼。由如此故。难生厌离。难可教诲。难可开悟。难得免离。难得解脱。此中本性具足炽然猛利贪烦恼者。如难陀等。具足炽然猛利嗔烦恼者。如指鬘等。具足炽然猛利痴烦恼者。如迦叶波等。问若尔者如说难生厌离。难可教诲。难可开悟。难得免离。难得解脱。此言善通。由彼精勤方便教化皆见谛故。如说能碍圣道及圣道加行善根。此云何通。答彼虽能碍圣道及圣道加行善根。然由佛力巧化方便彼得见谛。于舍利子等诸大声闻非所化境。复有说者。具足炽然猛利贪烦恼者。如黄门等。具足炽然猛利嗔烦恼者。如气嘘等。具足炽然猛利痴烦恼者。如六师等。问若尔如说能碍圣道及圣道加行善根。此言善通。由彼毕竟不见谛故。如说难生厌离难教诲等。此云何通。由彼毕竟不得见谛不名难故。答应作是说。不生厌离不可教诲等。而不作是说者有何意趣。谓即不生厌离名难生厌离。乃至即不得解脱。名难得解脱

问云何建立此烦恼障。为依成就。为依现行。答此依现行。不依成就。若依成就者则一切有情无有差别。等具成就诸烦恼故。由依现行而建立故烦恼差别。则成四句。或有烦恼炽然非猛利。或有烦恼猛利非炽然。或有烦恼亦炽然亦猛利。或有烦恼非炽然亦非猛利。烦恼炽然非猛利者。谓下品烦恼数行者是。猛利非炽然者。谓上品烦恼不数行者是。炽然亦猛利者。谓上品烦恼数行者是。非炽然非猛利者。谓下品烦恼不数行者是。此中炽然非猛利烦恼。亦是烦恼障。由此烦恼虽是下品以数行故。依下生中。依中生上。渐次乃至能断善根。彼猛利非炽然烦恼。亦非烦恼障。由此烦恼虽是上品。不数行故渐可损减。乃至能入正性离生究竟断灭。彼炽然亦猛利烦恼。是烦恼障一切为重。彼非炽然非猛利烦恼。非烦恼障一切为轻。如是善根亦有四句。或有善根炽然非猛利。或有善根猛利非炽然。或有善根炽然亦猛利。或有善根非炽然非猛利。炽然非猛利者。谓下品善根数行者是。猛利非炽然者。谓上品善根不数行者是。炽然亦猛利者。谓上品善根数行者是。非炽然非猛利者。谓下品善根不数行者是。此中炽然非猛利善根。不为烦恼障所障。由此虽是下品善根以数行故。依下生中。依中生上。渐次增长能速趣证一切结断。彼猛利非炽然善根。则为烦恼障所障。由此虽是上品善根不数行故。或容烦恼数数现行。渐次增长能断善根。彼炽然亦猛利善根一切为胜。彼不炽然不猛利善根一切为劣

云何业障。谓五无间业。何等为五。一害母。二害父。三害阿罗汉。四破僧。五恶心出佛身血。问如前所说能碍圣道及圣道加行善根。故名为障。除五无间业。复有其余妙行恶行。所谓决定第八有业。及上嗔恚缠害招多蚁等。由此为障不能于现法中趣入圣道。何故不说为业障耶。答亦应说此以为业障。而不说者当知此义有余。此中三障皆有余说。复有说者。五无间业定能为障是故偏说。余妙行恶行。或能为障。或不为障。是故不说。复有说者。五无间业具五因缘。易见易知是故偏说。何等为五。一自性故。二趣故。三生故。四果故。五补特伽罗故。自性故者。谓此五种性是决定极重恶业。趣故者。此五决定于地狱受不于余趣。生故者。此五决定顺次生受。非顺现法受。非顺后次受。非顺不定受果故者。谓此五种定感世间极不爱果。补特伽罗故者。谓能造此五补特伽罗易见易知。谓此能害母。此能害父。乃至此能出佛身血。除此五种所余一切妙行恶行。皆无如是五种因缘。易见易知是故不说

问诸无间加行能满彼果业。此于彼果为定不定。若言定者此中何故不说。又尊者指鬘室利鞠多云何能转。若不定者。害生命纳息所说云何通。如说颇有未害生杀生未灭。此业异熟定生地狱耶。答有如作无间业加行时命终。或有说者。此业于彼果定。问害生命纳息则为善通。而此中何故不说。答此中应说五无间业及彼加行。而不说者有何意耶。答此已说在五无间中。五无间业用此为加行故。若说果当知已说加行。问尊者指鬘云何能转。答彼犹未作无间加行。是故彼说我今且未杀母且当饭食。问岂非欲害一切智耶。答尔时彼于非一切智起害加行。非于一切智。由是因缘世尊化作凡流苾刍。入踏婆林勿彼尊者。于一切智起杀加行不可救疗。若诸有情于一切智起杀加行。如殑伽沙数如来应正等觉。亦不能救令脱地狱。故知彼于非一切智起杀加行。非于一切智。问室利鞠多云何能转。答彼亦不作无间加行。是故彼虽密设火阱及杂毒食。而心念言。如来若是一切智者自当避之。若非一切智者便当殄灭。勿令幻惑食啖世间故。彼非于一切智所起杀加行是以可转。复有说者。此业于彼果不定。问此中不说则为善通。尊者指鬘室利鞠多业亦可转。害生命纳息当云何通。答诸无间加行能满彼果业。此于彼果有定有不定。害生命纳息说。彼定者。尊者指鬘室利鞠多所可转易。是不定者。如是二说俱为善通。云何异熟障。谓诸有情处。那落迦。傍生。鬼界。北拘卢洲。无想天处。问余洲亦有异熟为障。如扇搋迦半择迦无形二形等。此中何故不说。答此中应说而不说者当知此是有余之说。是以前说此中三障皆有余说。复有说者。此中但说决定为障。彼非决定。由彼有情所有异熟。或有为障或不为障是以不说

问如是三障于一相续可成就几。答或但成一。谓于三种随一一成就或成就二。谓烦恼障业障。或烦恼障异熟障。无有成就业障异熟障非烦恼障者。由此亦无成就三者

问如是三障何者最重。或有说者。异熟障重。所以者何。因时可转。果时不可转故。复有说者。业障最重所以者何。业障能引异熟障故如是说者。烦恼障重。以烦恼障能引业障。业障复能引异熟障。如是皆以烦恼为本是故最重

三恶行中何者最大罪。谓破僧虚诳语。此业能取无间地狱一劫寿量异熟苦果。余业不定故。问此说破僧虚诳语为最大罪。余处复说。意业为最大罪。余处复说。邪见为最大罪。此三大罪有何差别。或有说者。罪有三种。一业。二烦恼。三恶行。业中意业为大罪。烦恼中邪见为大罪。恶行中破僧虚诳语为大罪。复有说者。恼乱大众故意业为大罪。灭一切善根故邪见为大罪。能感大苦异熟果故。破僧虚诳语为大罪。复有说者。三业中意业为大罪。五见中邪见为大罪。五无间业中破僧虚诳语为大罪。复有说者。见所断业道中邪见为大罪。修所断业道中。破僧虚诳语为大罪。见修所断业中意业为大罪。复有说者。依思业故说意业为大罪。依思所造业故。说破僧虚诳语为大罪。依非业故说邪见为大罪。复有说者。依能起业故说意业为大罪。依所起业故说破僧虚诳语为大罪。依非业故说邪见为大罪。复有说者。依能转业故说意业为大罪。依所转业故。说破僧虚诳语为大罪。依非业故说邪见为大罪。是名三种大罪差别

问彼破僧时。亦有身业往来加行思惟及余语业。何故但说虚诳语能破僧耶。答若破僧时加行究竟。一切时有者此中说之。于诸业中唯虚诳语加行究竟。一切时有能令僧坏是故偏说。余业不尔是故不说

问如说能取无间地狱果。何故名无间地狱耶。答此假立名假立想。不必如名悉有其义。又此地狱亦名无间。亦名热铁猛焰炽然攒射支体。亦名常于六触处门受诸苦恼。亦名自受业所招苦。复有说者。以于此中无间无隙可令乐受暂现在前故名无间。问余地狱中。为有歌舞及饮食等喜乐事耶。答余地狱中虽无异熟喜乐。而有等流喜乐。如施设论说。等活地狱有时有分凉风暂吹。或闻如是音声唱言。等活等活。时彼有情忽然还活。支节血肉平复如本。暂生喜乐。无间地狱无如是事故名无间。复有说者。生彼有情其数甚多。无间无隙故名无间。此说不然。所以者何。上品恶行生彼地狱。世间有情不皆能起上品恶行。如要修习上品妙行方生有顶。世间有情不皆能起上品妙行。是故生有顶者少。生无间者亦尔。故彼非说。问若尔云何名无间。答依异熟果说名无间。以诸有情造大恶业生彼地狱。得广大身一一身形悉皆广大。遍彼多处中无间隙故名无间

说一切有部发智大毗婆沙论卷第一百一十五阿毗达磨大毗婆沙论卷第一百一十六

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    业蕴第四中恶行纳息第一之五

问此业能取一劫寿果为是何劫。或有说者。是成劫。复有说者。是坏劫。复有说者。是大劫。如是说者此是中劫。由彼亦有不尽中劫而得脱故。如毗奈耶说。提婆达多。当于人寿四万岁时来生人中。必定当证独觉菩提。舍利子等所不能及。问如是伽他当云何通

  诸有破僧人　　破坏和合僧
  生无间地狱　　寿量经劫住

尊者世友作如是说。减一劫住亦名一劫。如世间人于减一日。住持所作亦名直日。此亦如是

问此破僧罪亦能取地狱五蕴异熟。何故但言取一劫寿。或有说者。以寿为先。世尊总说取五蕴果。复有说者。此中世尊说最胜法。谓五蕴中寿命最胜是故偏说。复有说者。寿命能持一切五蕴。令不散坏是故偏说。复有说者。寿从初生尽众同分无有间断。令众同分亦无间断。余法不尔是故不说。复有说者。由寿量故表知世间。或增或减。或进或退。或兴或衰。是故偏说问何故破僧得劫住罪。非起恶心出佛身血耶。答若起恶心出佛身血坏佛生身。若破坏僧坏佛法身。一切如来应正等觉。敬重法身不重生身。复有说者。若起恶心出佛身血但毁尊重。若破坏僧即名毁坏尊重所重。若起恶心出佛身血但伤大师。若破坏僧即名伤损大师所师。如大师。如是法王归依依趣亦尔。有说。彼起杀心出佛身血。但是加行罪。以佛法尔不可害故。破僧不尔是根本罪。如加行根本。如是加行究竟亦尔。复有说者。若起恶心出佛身血。不多发起广大加行。但由率尔卒暴而伤。破僧不尔。要由发起广大加行。或经一月乃至四月。方便诱诳诸新学苾刍令彼顺已。然后能破是以罪重。复有说者。若起恶心出佛身血不恼乱大众。虽伤佛身不能令佛生恼乱心。亦不諠扰。以作此事世间众生。或有闻者或不闻故。若破坏僧极大諠扰恼乱大众。以破僧时应得入正性离生者。不得入正性离生。应得果证者不得果证。应离欲者不得离欲。应尽漏者不得尽漏。不得诵持思惟三藏。不得静处思惟诸法。修习静虑无色等至。不得种殖三乘种子。三千大千世界法轮不转。展转声至净居诸天。令其觉慧不得安静明了现行。若所破僧还和合时。应入正性离生者。即入正性离生。应得果证者即得果证。应离欲者得离欲。应尽漏者得尽漏。便有诵持思惟三藏。在空闲处思惟诸法。修习静虑无色等至。亦能种殖三乘种子。三千大千世界法轮复转。展转声至净居诸天。令其觉慧复得安静明了现行。由是因缘。若起恶心出佛身血。不能生起经劫住罪。若破坏僧便能生起经劫住罪

问僧破以何为自性。答以不和合无覆无记不相应行为自性。是不相应行蕴所摄。即余处说复有所余如是种类不相应行。是故僧破异破僧罪异。僧破是不和合性无覆无记。是不相应行蕴所摄。破僧罪是虚诳语。不善语业色蕴所摄如退体异退法亦异。退体是不成就性无覆无记。不相应行蕴所摄。退法是不善。有覆无记五蕴所摄。此亦如是僧破异破僧罪异。由此僧破僧所成就。破僧罪破僧人成就

问何处破僧。答在欲界人趣。若破羯磨僧通在三洲。若破法轮僧唯赡部洲。所以者何。若处有大师可得及道可得。即于是处有破法轮。余洲无有大师及道。是故亦无破法轮者。譬如世间若处有王是处有伪王起。若处有力士是处有捔力者起。此亦如是。若于是处有大师。是处有邪师起。若处有道是处有邪道起。法尔邪正同处相违问破羯磨僧破法轮僧有何差别。答破羯磨者。谓一界内有二部僧各各别住。作布洒陀羯磨说戒。破法轮者。谓立异师异道。如提婆达多。言我是大师。非沙门乔答磨。五法是道。非乔答磨所说八支圣道。所以者何。若能修习是五法者。速证涅槃非八支道。云何五法。一者尽寿着粪扫衣。二者尽寿常乞食食。三者尽寿唯一坐食。四者尽寿常居迥露。五者尽寿不食一切鱼肉血味盐酥乳等。是谓破羯磨僧破法轮僧差别问于破僧时极少几人成破僧事。答破羯磨僧极少八人。四人已上方名为僧三人不尔。于一界内有二部僧各各别住。作布洒陀羯磨说戒。乃得名为羯磨坏故。破法轮僧极少九人。以一界内有二部僧各各别住。于无惭愧部中。定别有一众所尊重能教诲者。当知则是提婆达多。于正众中极少四人。于邪众中极少五人。如是极少下至九人则法轮僧坏。问齐何当言法轮僧坏。答施设论说。提婆达多自为第五皆共受筹。齐此当言法轮僧坏。复有说者。作表白已。复有说者。离所闻处。复有说者。离所见处。复有说者离见闻处。如是说者。若由意乐誓受余师。谓彼愚痴诸苾刍众。由定意乐发如是心作如是语。提婆达多是我大师非佛世尊。齐此当言法轮僧坏。问何等种类补特伽罗破法轮僧。答补特伽罗有二种。一者爱行。二者见行。诸见行者破法轮僧非爱行者。以见行者所有意乐坚固猛利。于杂染清净品所作决定无有退转。诸爱行者无如是事故不能破。又唯男子破法轮僧。非诸女人亦非扇搋半择迦等。所以者何。破法轮时法尔自安立为大师。而诸女人非增上器。于大师非分故不能破。然能广作破僧方便。犹如粗喜苾刍尼等。诸扇搋半择迦无形二形皆是爱行。诸爱行者所有意乐不坚不猛。于染净品皆不决定。是故彼类不能破僧

问于何时分破法轮僧。答于六时中不能破僧余时则能。谓非初时亦非后时。非于二疱未出现时。非未和合共结界时。非未建立第一双时。非于大师涅槃后时。非初后者。由此二时诸苾刍众。于圣教中和合一味不可破坏。非于二疱未出时者。谓圣教中未生戒见二种疱时。非未和合共结界时者。要一界内有二部僧。别住异忍方名破僧故。非未建立第一双者。谓未建立第一双时定无能破法轮僧者。诸佛法尔皆有第一双贤圣弟子。若有破坏法轮僧已不经日夜。此第一双还令和合。非于大师涅槃后者。若于大师般涅槃后。作如是言我是大师非如来者。咸共责言。大师在世汝何不言我是大师。今涅槃后乃作是语。是故决定于此六时法轮不坏。于所余时法轮可坏

问住何等心僧破。或有说者。住于眼识。复有说者。住于耳识。复有说者。住于意识。如是说者。六识身中随住一识皆容僧破。问住何等受僧破。或有说者。住于乐根。复有说者。住于苦根。复有说者。住于喜根。复有说者。住于忧根。复有说者。住于舍根。如是说者。于五受中随住一受皆容僧破

问僧破是何心果。或有说者。是出家心果。所以者何。在家无有僧破坏故。复有说者。受具心果。所以者何。勤策无有僧破坏故。复有说者。若取邻近受具心果。若取悬远出家心果。如是说者。若住此心僧破坏者即此心果。问何等种类补特伽罗可破坏耶。答唯是异生非诸圣者。所以者何。世尊记说无处无容一切圣者可破坏故。问诸有已得顺决择分为可破不。或有说者。除此所余是可破坏。复有说者。此亦可破。所以者何。世尊唯记无处无容一切圣者是可破坏不记余故

问如提婆达多能破坏僧。何故说言世尊眷属不可破坏。尊者世友说曰。此中说四向四果名世尊眷属。是真弟子。是真实僧。不可破坏。复次佛眷属有二。一是异生。二是圣者。提婆达多唯破异生。由此故说彼能破僧。一切圣者皆不可破。由此故说世尊眷属不可破坏。大德说曰。佛眷属有二。一内二外。内谓圣者无动无坏。外谓异生可动可坏。此中异生可动坏故。提婆达多能破坏僧。圣无动坏故说世尊眷属不坏

问破僧时佛在众不。答佛时住彼界内而不在众。云何知耶。曾闻提婆达多欲破僧时。佛以慈愍故呵制之言。提婆达多汝勿破僧。勿起极重恶不善业。勿趣非爱大苦果处。佛虽如是殷勤呵制。而彼都无止息之心。尔时世尊起正智见审观前际。勿我昔时破他眷属。即自观见昔我无量无数劫前。曾破坏他仙人眷属。彼业异熟今现在前。观见是已知此僧众定当破坏。便入静室默然宴坐。提婆达多便破坏僧。故知世尊在于界内而不在众

问为一切佛皆有如是破僧事耶。有说。不尔。所以者何。若有如是破坏他业。造作增长便有破僧。若无是业则无破僧唯世尊释迦牟尼。曾有此业造作增长。故今僧破余佛不尔。有说。余佛亦有破僧。曾闻迦叶波佛时。有苾刍名曰花上是誉上子。造五无间断灭善根

问提婆达多为先破僧后断善根。先断善根后破僧耶。或有说者。彼先破僧后断善根。所以者何。要具尸罗多闻端正。贵族威肃言词善巧。乃能破僧。若断善根便失净戒。非增上故不能破僧。尊者世友亦作是说。提婆达多先破坏僧后断善根。若先断善根后破僧者。于破僧时应不能生一劫住罪。所以者何。非断善根补特伽罗。于非法中起非法想。于破僧中起有罪想。若于非法起于法想。于破僧中起无罪想。而破僧者终不能生一劫住罪。要于非法起非法想。于破僧中起有罪想。如是破僧方能生起一劫住罪。由此道理诸破坏僧一切皆生劫住罪耶。设有能生劫住罪者。一切皆能破僧耶。应作四句或有破僧非能生起一劫住罪。谓于非法起于法想。及于破僧起非罪想。而破坏僧。或有能生一劫住罪而非破僧。谓断善根。或有破僧亦能生起一劫住罪。谓于非法起非法想。于破僧中起有罪想。而破坏僧。或有不能破坏于僧。亦不能生一劫住罪。谓除前想。大德说曰。彼起破僧加行时。亦起断善加行。起断善加行时。亦起破僧加行。是故彼破僧时则断善。断善时则破僧。彼由俱时造二罪故。成就极重恶不善业。而无一念悔愧之心

问诸造无间业彼断善耶。设断善彼造无间业耶。答应作四句。或有造无间业非断善。如未生怨王等。或有断善非造无间业。如六师等。或有造无间业亦断善。如提婆达多始褰持等。或有不造无间业亦不断善。谓除前想。三妙行中何者最大果。谓第一有等至中思。此业能取非想非非想处八万劫寿果。当知此中依异熟果为问故作此答。若依五果。或唯依离系果为问应作是答。谓金刚喻定相应思。此思能证一切结尽断遍知果。由此中意问异熟果故作是答

问为一思能感八万劫寿。为多思耶。若一思者。云何少业能感多果。若多思者。云何不名一众同分果分分别感。或有说者。一思能感。问云何少业能感多果。答先以一思总感后以多思成满。譬如画者先以一色作模。后填众彩。此亦如是。复有说者。多思能感。问云何不名一众同分果分分别感。答于彼定中。缘一境界一类行相。有众多思相续而起。或有能感十千劫寿。或有能感二十千劫。或有能感三十千劫。或有能感四十千劫等寿。如是多思分分别感。然依一种定前加行起一类定。缘一境界一类行相。多思相续现前而感故名一身。如是说者。一思总感。多思成满

问此思为是近分地摄。为根本地摄耶。或有说者。是近分地。复有说者。是根本地。如是说者此则不定。或近分地。或根本地。所以者何。以一切思同一地故。问八万劫者是何劫耶。或有说者。此是中劫。复有说者。此是成劫。复有说者。此是坏劫。如是说者此是大劫

问此业能取四蕴异熟。何故唯说取寿果耶。或有说者。以寿为先。世尊总说取四蕴果。复有说者。此中世尊说最胜法。谓四蕴中寿为最胜是故偏说。有说。唯寿能持四蕴令不散坏是故偏说。有说。寿于一期无断。令众同分亦无间断。余法不尔是故偏说。复有说者。由寿量故表知世间。或增或减。或进或退。或兴或衰。由此因缘故偏说寿

如说恶行妙行感爱非爱最大果。如是善不善根并十业道亦应广说。谓三不善根中。何者最大罪。谓能起破僧虚诳语。此不善根能取无间地狱一劫寿果。十不善业道中。何者最大罪。谓破僧虚诳语。此业能取无间地狱一劫寿果。三善根中。何者最大果。谓能起第一有等至中思。此善根能取非想非非想处八万劫寿果。十善业道中。何者最大果。谓与第一有等至中思俱者。此业道能感非想非非想处八万劫寿果。应知此中以略说故。但说恶行妙行最大果非余

    业蕴第四中邪语纳息第二之一

诸邪语彼邪命耶。设邪命彼邪语耶。如是等章及解章义既领会已。次应广释。问何故作此论。答为止他宗显己义。故。谓譬喻者说离语及业。别有正命邪命体性。彼何故作是说。由契经故。如契经说八支圣道。彼作是说。佛说八支者。各有体性不相杂乱。由此便说正命邪命。离语业外有体可得。为遮彼意显正命等皆即语业故作斯论。如于不善语业道中。若贪所起名为邪语。亦名邪命。为命起故。嗔痴所起但名邪语。不名邪命。不为命而起故。于不善身业道中。若贪所起名为邪业。亦名邪命。嗔痴所起但名邪业。不名邪命。所以如前。于善语业道中。无贪所起名为正语。亦名正命。邪命对治故。无嗔痴所起名为正语。不名正命。所以如前。于善身业道中。无贪所起名为正业。亦名正命。无嗔痴所起名为正业。不名正命。所以如前。由此即显正命邪命。皆摄语业而为体性。是谓此处略毗婆沙。诸邪语彼邪命耶。设邪命彼邪语耶。答应作四句。有邪语非邪命。谓除趣邪命语四恶行。诸余语恶行。即嗔痴所起语业。是语业性故非为命起故。有邪命非邪语。谓起邪命身三恶行。即贪所起身业为命起故。非语业性故。后语句中应准此释。有邪语亦邪命。谓起邪命语四恶行。有非邪语非邪命。谓除趣邪命身三恶行。诸余身恶行。诸邪业彼邪命耶。设邪命彼邪业耶。答应作四句。有邪业非邪命。谓除趣邪命身三恶行。诸余身恶行即嗔痴所起身业。是身业性故。非为命起故。有邪命非邪业。谓趣邪命语四恶行。即贪所起语业为命起故。非身业性故。后二句准此释。有邪业亦邪命。谓趣邪命身三恶行。有非邪业非邪命。谓除趣邪命语四恶行。诸余语恶行。此中诸贪所起皆以趣向邪命故名邪命。诸正语彼正命耶。设正命彼正语耶。答应作四句。有正语非正命。谓除趣正命语四妙行。诸余语妙行。即无嗔无痴所起语业。是语业性故。非邪命对治故。有正命非正语。谓趣正命身三妙行。即无贪所起身业。是邪命对治故。非语业性故。后二句准此释有正语亦正命。谓趣正命语四妙行。有非正语非正命。谓除趣正命身三妙行。诸余身妙行。诸正业彼正命耶。设正命彼正业耶。答应作四句。有正业非正命。谓除趣正命身三妙行。诸余身妙行。即无嗔无痴所起身业。是身业性故。非邪命对治故。有正命非正业。谓趣正命语四妙行。即无贪所起语业。邪命对治故。非身业性故。后二句准此释。有正业亦正命。谓趣正命身三妙行。有非正业非正命。谓除趣正命语四妙行。诸余语妙行。此中诸无贪所起。皆以趣向正命故名正命。已略显示杂无杂相。今当广说彼差别相。谓若有为利活命因缘起诸恶行。此名邪语邪业。亦名邪命。是语业性故。为命所起故。若有为余种种因缘。起诸恶行名邪语邪业。不名邪命。是语业性故。非为命起故。余门准此释。复次若有随其种种傍生明咒。邪活命缘。起诸恶行名邪语业。亦名邪命。若有为余种种因缘。起诸恶行名邪语业。不名邪命。复次若以四爱因缘。起诸恶行名邪语业。亦名邪命。若以余缘起诸恶行名邪语业。不名邪命。复次若有矫诈现相以利求利五邪命缘。起诸恶行。名邪语业。亦名邪命。若为余缘起诸恶行名邪语业。不名邪命。复次若起恶行加行。名邪语业。亦名邪命。若起恶行根本业道名邪语业。不名邪命。所以者何。加行难除非根本故。复次若起种种遮罪。名邪语业。亦名邪命。若起性罪。名邪语业。不名邪命。所以者何。遮罪难防非性罪故。由如是等六门七门所说道理。决定无能离语业外别立邪命。问若尔何故说邪语等三种。及于经中说八支圣道。正语业外别说正命耶。答佛以邪命诳惑于人。微细难觉故与语业俱时示现复别示现。如贼军将同众诛戮复别枭首。复有说者。以诸邪命难可净除。故与语业俱时呵责。复别呵责犹如女人与诸事欲及烦恼欲。俱时说过复别呵责。云何邪命难可净除。谓有二法难除难舍。即在家者邪见。及出家者邪命。诸在家人虽极聪慧受持五戒。若苦所逼则以种种香花饮食祠祷天神。诸出家人虽极聪慧受持具戒。资身命缘系属他故。见施主时便整威仪现亲善相。是故别说邪命正命。契经及施设论皆作是说。断生命乃至邪见皆有三种。一从贪生。二从嗔生。三从痴生。云何断生命从贪生。谓如有一以贪皮肉筋骨等故。害他有情。或为所爱悦意。亲友曾当于己作饶益者。而行杀事。或他以财及诸饶益求己行杀。如国王等以诸财位。招募骁勇令讨未伏。如是等杀名从贪生。云何从嗔生。谓如有一于他有情。有损恼心。怨嫌之心。恶意乐心。而断彼命。或复害彼亲属朋友以绝怨路。如是等杀名从嗔生。云何从痴生如有一类起如是见。立如是论。驼马牛羊鸡猪鹿等。皆为祠祀人所食用。是以杀之无罪。复有一类起如是见。立如是论。虎豹豺狼蜈蚣蛇等伤害于人。为人除患杀亦无罪。又此西方有蔑戾车名曰目迦起如是见。立如是论。父母衰老。及遭痼疾。若能杀者得福无罪。所以者何。夫衰老者诸根朽败不能饮食。若死更得新胜诸根。饮新暖乳。若遭痼疾多受苦恼。死便解脱故杀无罪。如是等杀名从痴生。以迷业果起邪谤故

云何不与取从贪生。谓如有一欲他财物不与而取。或为所爱悦意。亲友曾当于己作饶益者。而行盗窃。或他以财及诸饶益求己行盗。如募将士掠他财宝。如是等盗名从贪生。云何从嗔生。谓如有一于诸有情。有损恼怨嫌恶意乐心。而盗彼物令其困恼。或复盗彼亲友财物以憎彼故。如是等盗名从嗔生。云何从痴生。如有一类诸婆罗门。起如是见。立如是论。大地所有本是梵王神力化作。施诸婆罗门。今婆罗门势力羸弱。刹帝利等侵夺受用。故婆罗门取受用时是取己物皆无盗罪。然彼取时作他物想。如是等盗名从痴生。迷于业果起邪谤故

云何欲邪行从贪生。谓此多分以耽染心。或以财利诸饶益事。于彼彼所行欲邪行。是名从贪生。云何从嗔生。谓如有一于他有情。有损恼怨嫌恶意乐心。欲令污辱受诸衰损。便于彼所行欲邪行。是名从嗔生。云何从痴生。谓婆罗门起如是见。立如是论。诸婆罗门应畜四妇。刹帝利三。吠舍应二。戍达罗一。婆罗门等数若未满。淫他妻室亦无有罪。然彼淫时起属他想。又此西方有蔑戾车名曰目迦。起如是见。立如是论。母女姊妹及儿妻等。于彼行欲悉无有罪。所以者何。一切母邑。皆如熟果已办饮食道路桥船阶梯臼等。法尔有情共所受用。是故于彼行欲无罪。此等邪行名从痴生。所以如前

云何虚诳语从贪生。谓如有一为名利故。于他有情覆想而说。若为己若为他。如国王等招募辩士。令行游说为诱未伏。彼人尔时以财位故。或依内诳外。或依外诳内。或依二诳二。此等虚诳语名从贪生。云何从嗔生。谓如于他有损恼心。怨嫌恶意乐心。欲陷彼故行虚诳语。或复于彼所爱亲友。作虚诳语以憎彼故。此等虚诳语名从嗔生。云何从痴生。谓如有一起如是见。立如是论。诸为自他身难命难。而妄语者不得妄语罪。如猎师问鹿所在。及贼军问王军所在。虽实见实知恐害彼故。虽不实答而无有罪。当知彼类非不有罪。彼谓都无便数数作。此等虚诳语名从痴生。所以如前

云何离间语从贪生。谓如有一为名利故。于彼有情或彼亲友作离间语。若为己若为他。如国王等招募辩士。令行离间规令他伏。彼人尔时以财位故。或依内离外。或依外离内。或依二离二。又婆罗门有二施主。一施衣。二施食。婆罗门念言。若二施主共和好者。我于二所各得一事。若彼乖违则一一处皆得二事。由是因缘行离间语。是名从贪生。云何从嗔生。如有于他有损恼心怨嫌恶意乐心。而离间彼或彼亲友坏彼故。是名从嗔生。云何从痴生。如有一类婆罗门等。起如是见。立如是论。诸不律仪家。若和好者为恶滋多。若乖离者作恶便少。是故若有于彼类中。作离间语终无有罪。是名从痴生。所以如前。云何粗恶语从贪生。如以名利于他有情骂詈毁辱。若为己若为他。如国王等委酷法人令主辞狱。及令军佐制造书檄。由此等缘作粗恶语。是名从贪生。云何从嗔生。谓如于他有损恼心怨嫌恶意乐心。便骂辱彼或彼亲友若为己若为他。是名从嗔生。云何从痴生。谓如丈髻外道名事火。天性甚卒暴多粗恶语。彼诸弟子以为善妙皆习粗语。是名从痴生。所以如前

云何杂秽语从贪生。谓如有一为己及他名利等故作杂秽语。如俳优者为财利故。于大集处种种词咏戏调杂说。又诸男女以爱染心作杂秽语。复有制造世俗文章。受持讽诵是名从贪生。云何从嗔生。谓如于他有损恼心。怨嫌恶意乐心。轻调彼故作杂秽语。或轻调彼所爱亲友以憎彼故。是名从嗔生。云何从痴生。如有一类婆罗门。起如是见。立如是论。诸有[木*巳]火。或祀余神。或诵吠陀诸咒术等。一切皆得清净解脱。是名从痴生。所以如前。云何贪从贪生。谓贪缠无间贪缠现前。是名贪从贪生。云何从嗔生。谓嗔缠无间贪缠现前。是名贪从嗔生。云何从痴生。谓痴缠无间贪缠现前。是名贪从痴生。云何嗔从贪生。谓贪缠无间嗔缠现前。是名嗔从贪生。云何从嗔生。谓嗔缠无间嗔缠现前。是名嗔从嗔生。云何从痴生。谓痴缠无间嗔缠现前。是名嗔从痴生

云何邪见从贪生。谓贪缠无间邪见缠现前。是名邪见从贪生。云何从嗔生。谓嗔缠无间邪见缠现前。是名邪见从嗔生。云何从痴生。谓痴缠无间邪见缠现前。是名邪见从痴生。问已知十不善业道。一切皆从贪嗔痴起。于中一一几为加行。几为究竟。而能起耶。或有说者。断生命粗恶语及嗔恚三。为加行由嗔究竟。不与取欲邪行。及贪欲三。为加行由贪究竟。余语业道三。为加行由三究竟。邪见一种三。为加行由痴究竟。复有说者。欲邪行不定。谓若欲令要出不净方成业道者。则三为加行由贪究竟。若有欲令才入秽门便成业道者。则三为加行由三究竟。所余业道一切皆以三。为加行由三究竟

说一切有部发智大毗婆沙论卷第一百一十六阿毗达磨大毗婆沙论卷第一百一十七

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    业蕴第四中邪语纳息第二之二

有律仪。有不律仪。有住律仪者。有住不律仪者。云何律仪。谓有七种。即离断生命。乃至离秽杂语。云何不律仪。谓亦有七种。即断生命乃至杂秽语。云何住律仪者。谓有七众。一苾刍。二苾刍尼。三正学。四勤策男。五勤策女。六近事男。七近事女。云何住不律仪者谓有十二种不律仪家。一屠羊。二屠鸡。三屠猪。四捕鸟。五捕鱼。六游猎。七作贼。八魁脍。九缚龙。十守狱。十一煮狗。十二婆具履迦。此中屠羊者。为活命故怀杀害心。若买若卖养饲断命。如是一切皆名屠羊。屠鸡屠猪亦复如是。捕鸟者。为活命故采捕众鸟。捕鱼等亦如是。缚龙者。为活命故习咒龙蛇。或言缚象。煮狗者。谓栴茶罗等诸秽恶人。婆具履迦者。谓有傍生名婆具罗。即是蟒类。恒于旷野吞食商侣。有人专能杀之。取商侣价以自活命。由此故名婆具履迦。有说。罝弶名婆具罗。有人为活命故恒设罝弶。取诸众生故名婆具履迦。有说。猎主名婆具履迦。如有颂言

  鹿出婆具履迦苦　　终不还投婆具罗
  智者弃凡俗出家　　终不还归苦迫迮

尊者妙音作如是说。若受上命讯问狱囚。肆情暴虐加诸苦楚。或非理断事。或毒心赋税。如是一切皆名住不律仪者

问如是诸律仪要受方得。此不律仪亦如是耶。或有说者。亦由受得。谓手执杀具誓从今日乃至命终。常作此业以自活命。尔时便得此不律仪。复有说者。虽执杀具自立誓言。然彼不得此不律仪。由二缘得。一由作业。二由受事。由作业者。谓生不律仪家最初作彼杀生等业。尔时便得此不律仪。由受事者。谓生余家为活命故怀杀害心。往屠羊等不律仪所。作是誓言我从今者乃至命终。常作汝等所作事业以自活命。尔时便得此不律仪。复有说者。此亦最初作彼业时。方乃获得此不律仪。彼说不律仪唯一缘得

若有以下品心起有表业受诸律仪。尽众同分彼诸律仪下品随转。虽于后时励力发起身语意摄恶行妙行。然彼律仪常下品转更不增长。若有以中品心起有表业受诸律仪。尽众同分彼诸律仪中品随转。虽于后时励力发起身语意摄恶行妙行。然彼律仪常中品转不增不减。若有以上品心起有表业受诸律仪。尽众同分彼诸律仪上品随转。虽于后时励力发起身语意摄恶行妙行。然彼律仪常上品转更不损减。故如是。问颇有新学苾刍成就上品律仪。而阿罗汉成就下品律仪耶。答有。谓有新学苾刍以上品心。起有表业受诸律仪。有阿罗汉以下品心。起有表业受诸律仪。如是新学苾刍成就上品律仪。而阿罗汉成就下品律仪

若有最初以下品缠断众生命。于此众生得下品断生命所摄。及不律仪所摄表无表业。于余一切有情身上。唯得下品不律仪所摄无表业。若彼后时随以下中上品缠断众生命。于此众生唯得下中上品。断生命所摄表无表业。更不得不律仪所摄表无表业。先已得故如是最初以中品缠以上品缠。广说亦尔。断生命等。随别渐得不律仪业普顿得故。问如屠羊者不欲杀余众生。何故此人普于一切有情所得不律仪耶。答虽于羊处起不律仪。然诸有情一切皆有羊蕴界处。又彼恶心境界宽遍。故于一切得不律仪。无有是处为分别故。设诸有情皆作羊像。来住前者于彼一切。皆起恶心皆欲杀害。是故于一切有情所得不律仪

住不律仪者。有于一切有情得不律仪。非由一切支。非由一切因。有于一切有情得不律仪。由一切支。非由一切因。有于一切有情得不律仪。由一切因。非由一切支。有于一切有情得不律仪。由一切支。由一切因。若由一切支。由一切因。得不律仪非于一切有情者。此类无有一切有情者。即是一切有情之类。一切支者。谓断生命乃至说杂秽语。一切因者。谓下中上缠。或贪嗔痴。有于一切有情得不律仪。非由一切支。非由一切因者谓以下缠断众生命。或中或上非余亦不起余支。有于一切有情得不律仪。由一切支非由一切因者。谓以下缠断众生命。乃至说杂秽语。或中或上非余。有于一切有情得不律仪。由一切因非由一切支者。谓以下中上缠断众生命不起余支。有于一切有情得不律仪。由一切支由一切因者。谓以下中上缠断众生命。乃至说杂秽语。住律仪者。有于一切有情得律仪。非由一切支。非由一切因。有于一切有情得律仪。由一切支。非由一切因。有于一切有情得律仪。由一切支。由一切因。若于一切有情得律仪。由一切因非由一切支者。此类无有。若由一切支由一切因得律仪。非于一切有情者。此亦无有一切有情者。即是一切有情之类。一切支者。谓离断生命乃至离杂秽语。一切因者。谓下中上品心。或无贪无嗔无痴。有于一切有情得律仪。非一切支非一切因者。谓以下心受近事勤策戒。或中或上或二非余。有于一切有情得律仪。亦一切支非一切因者。谓以下心受近事乃至苾刍戒。或中或上或二非余。有于一切有情得律仪。亦一切支亦一切因者。谓以下中上心。如次受近事勤策苾刍戒。问若以下中上心。如次受近住近事勤策戒时。即名于一切有情得律仪。亦一切因非一切支。何以言无。答此中但依尽寿律仪作论不依昼夜。所以者何。彼名为斋。于律仪中非决定故

问如受律仪于下品后复得中品。于中品后复得上品。诸不律仪亦如是耶。或有说者。如得律仪不律仪亦尔。所以者何。诸善律仪作大功用。作大加行尚数数得。况不律仪。如是说者。律仪渐得非不律仪。所以者何。律仪难得以难得故渐受渐得。不律仪易得以易得故顿受顿得

问如善律仪有支不具。诸不律仪亦如是耶。答健驮罗国诸论师言。不律仪业有支不具。若诸有情生在种种不律仪家。生便喑哑尽众同分不能言说。彼但可得身三业性不律仪业。不得语四。迦湿弥罗国诸大论师咸作是说。诸不律仪无支不具。如善律仪渐次受者有支不具。诸不律仪则不如是。无渐受故易可得故。问住不律仪者受八戒斋时。舍不律仪得律仪。至明旦时舍律仪还得不律仪耶。答健驮罗国诸论师言。住不律仪者受八戒斋时。舍不律仪得律仪。至明旦时舍律仪还得不律仪。得律仪故不律仪断。舍律仪故不律仪续。迦湿弥罗国诸大论师咸作是说。住不律仪者受八戒斋时。舍不律仪得律仪。至明旦时舍律仪不得不律仪。得律仪故舍不律仪。分齐极故又舍律仪。是故尔时名非律仪非不律仪。若彼有情尽众同分。不复作者不得不律仪。若复作者还得不律仪。尽寿律仪由四缘舍。一舍所学。二二形生。三断善根。四舍众同分。诸持律者说。法灭没时为第五缘。谓法灭没时。一切所学。出家受具。结界羯磨。悉皆息灭。是故尔时律仪亦舍。如是说者。当于尔时先得律仪不舍。已出家者犹名出家。已受具者犹名受具。未出家者无复出家。未受具者无复受具。依此故言一切息灭

诸不律仪由四缘舍。一受别解脱律仪。二得静虑律仪。三二形生。四舍众同分。问如善律仪舍所学。舍此不律仪亦如是耶。答或有说者。若能决定舍诸杀具。尔时舍不律仪。如是说者。虽复决定舍诸杀具。若不受戒得善律仪。终不得名舍不律仪

三恶行。三曲秽浊。乃至广说。问何故作此论。答为欲分别契经义故。如契经说。有三恶行。三曲秽浊。契经虽作是说。而不广辩广说如前。复有说者。前纳息中已分别三恶行。而未分别三曲秽浊。今欲分别故作斯论

三曲秽浊。谓身曲身秽身浊。语曲语秽语浊。意曲意秽意浊。三曲云何。谓谄所起身语意业。所以者何。谄名为曲。由曲相法所起三业说名为曲。是彼果故。问复何因缘谄名为曲。答直相违故。如有颂言

  诸盘回屈曲　　不平直不正
  崄坑涧稠林　　是皆喻其谄

复有说者。以诸有情谄所损污。难出生死难入涅槃。犹如曲木难出稠林难入聚落。此亦如是故名为曲。复有说者。以诸有情谄所损污。诸所作事将现在前。复还弃背将欲出言复还内止。其性崄恶难得意趣。难可共交故名为曲。复有说者。以诸有情谄所损污。诸聪慧者皆应远离。如乐净人逃避冢间死尸臭秽。正直所厌故名为曲。复有说者。以诸有情谄所损污。诸佛于彼亦舍大悲。如谄病人良医所弃。障碍正化故名为曲。问谄在何处。答在欲界初静虑非上地。问何故上地无谄。答上地于谄。非田非器非地非依。以非田器非地依。故于彼不有。复有说者。为除其谄往趣上地。若于上地复有谄者。不应加行求趣上地。若下地法上地亦有者。不应施设渐次灭法。若不施设渐次灭法。则应无有究竟灭法。若无究竟灭法。便无解脱。若无解脱亦无生死则一切法无。欲令无如是过是故上地无谄。复有说者。若于是处安立王臣。安立众生尊卑差别。则有其谄。非于上地得有斯事故无有谄。诸有王臣众主尊卑差别。必怀谄曲更相接事故。复有说者。若于是处有诸识身。有寻有伺。及有自性身语表业则有其谄。如是诸法上地皆无故无有谄。三秽云何。谓嗔所起身语意业。所以者何。嗔名为秽。由秽相法所起三业。说名为秽是彼果故。问诸烦恼皆是其秽如有颂言

  世间诸秽草　　能秽污良田
  如是诸贪秽　　秽污诸含识
  世间诸秽草　　能秽污良田
  如是诸秽秽　　秽污诸含识

慢爱无明。余烦恼颂说亦如是。何故此中唯嗔名秽。答虽诸烦恼皆名为秽。然唯嗔恚有二秽名故独名秽。如上颂言如是诸秽秽秽污诸含识。复有说者。由此嗔恚秽自相续。秽他相续。胜余烦恼故说名秽。云何秽自相续。谓若嗔恚现在前时。举身粗强恼悴颦蹙战掉不安。如鬼所著人不喜见。云何秽他相续。谓若嗔恚恼乱他时令他尘垢。或受鞭捶乃至丧命。问嗔在何处。答在欲界。非上二界。问何故上二界无嗔耶。答非田非器乃至广说。复有说者。为除嗔故求趣上界广说如前。复有说者。若于是处有悭嫉结则有嗔恚。所以者何。以诸有情依悭嫉结。于他相续起嗔恚故。上界不尔故无嗔恚。复次若处有无惭无愧。则有嗔恚上界不尔。复次若处有苦忧根。则有嗔恚上界不尔。复次若处有男女根。则有嗔恚上界不尔。复次若处有段食爱及淫欲爱。则有嗔恚上界不尔。释皆如前。是故上界无有嗔恚。复有说者。若于是处有怨害因则有嗔恚。怨害因者名九恼事。色无色界无怨害因故无有嗔。是故尊者妙音说言。怨害因缘则令嗔转。或有说者。若所依身干燥粗强则有嗔恚。上界依身润泽柔濡故无嗔恚。复有说者。色无色界有嗔对治。谓等引慈故无有嗔。如于是处若有吠蓝婆风。是处云场终不得住上界亦尔。有嗔对治等引中慈。吠蓝婆风故嗔云场于彼不住

三浊云何。谓贪所起身语意业。所以者何。贪名为浊。由浊相法所起三业说名为浊。是彼果故。问何因缘故贪名为浊。答能染浊故。世间染色说名为浊。如世间说根浊茎浊枝浊叶浊花浊果浊。此皆能染故名为浊。复次浊者是鄙下义。世间并谓多贪欲者名为鄙浊。复次浊者是不清净义。由贪蔽心习近染法舍净法故。问贪在何处。答在欲界乃至非想非非想处。已说自性今当显示杂无杂相。为三恶行摄三曲秽浊。三曲秽浊摄三恶行耶。答应作四句。有恶行非曲秽浊。谓除欲界谄嗔贪所起身语意恶行。诸余身语意恶行。有曲秽浊非恶行。谓初静虑谄贪所起身语意业。及余色无色界贪所起意业。有恶行亦曲秽浊。谓欲界谄嗔贪所起身语意恶行。有非恶行非曲秽浊。谓除前相。相谓所名如前说。谓于色蕴中除不善色。及谄贪所起有覆无记色。取余色蕴。于行蕴中除不善思。贪嗔邪见及谄贪所起有覆无记思。取余相应不相应行蕴。及三蕴全并无为法。如是一切作第四句故言谓除前相

此中有二种等起。谓因等起。及刹那等起。因等起名能转心。刹那等起名随转心。问五识亦能作二等起发身语业不。或有说者。五识不能发身语业。所以者何。唯有意识于身语业。作转随转令彼业现前。五识不能作转。亦不能作随转。不能令彼业现前。问若尔如说自见身表业。自闻语表业。三识识。此云何通。答不见身表但见余相。不闻语表但闻余音。即由此义名见名闻。三识识者。缘他身业非自身业。复有说者。五识亦能发身语业。以意识作能转亦作随转。五识虽不作能转。而作随转发彼业故。若作是说。即为善通自见身表自闻语表。所以者何。若以意识作能转及随转。亦以眼识作随转者便见身表。若以意识作能转及随转。亦以耳识作随转者便闻语表。三识识者。亦缘自业亦缘他业。尊者僧伽伐苏说曰。五识亦能发身语业。作因等起及刹那等起。所以者何。如有士夫先不作意。欻被他打即还打彼。非于尔时得起我当打彼思念。当知即是住身识打。是故五识亦能发起身语二业。作因等起及刹那等起。如是说者。五识不能作因等起发身语业。所以者何意识于身语业作能转及随转。五识唯作随转不作能转故

此中若善心作能转。即善心作随转。若染污心作能转。即染污心作随转。若威仪路心作能转。即威仪路心作随转。若工巧处心作能转。即工巧处心作随转。发身语业。问若威仪路心作能转。即彼心作随转者。如有行时遇见佛像等起善眼识。或见淫女等起染眼识。如是岂非善染随转起彼业耶。尊者世友作如是说。此由觉慧速疾回转起增上慢。谓于行位起此眼识。而实行时则善心染心不现在前。若善心染心现在前时即止不行。此善心染心。但如伴者不名等起。复有说者。威仪路心发起业时。善染心等相助发起。是故威仪路心转时。其随转心容有三种。谓善染无记。问若工巧处心作能转。即彼心作随转者。如画师画作佛时起善眼识。画女人时起染眼识。如是岂非善染随转发彼业耶。尊者世友作如是说。觉慧速疾起增上慢。谓于画时起此眼识。而实画时善心染心不现在前。若善心染心现在前时便止不画。此善心染心。但如伴者不名等起。复有说者。工巧处心发起业时。善心染心相助发起。是故工巧处心为能转时。其随转心容有三种。谓善染无记。问异熟生心何故不能作二等起发身语业耶。答强盛心发身语业。异熟生心其性羸劣故不能发。复有说者。若身语业异熟生心。为二等起而发起者。此身语业当言是何。为威仪路。为工巧处。为异熟生。若威仪路。或工巧处。异熟生心云何能发。若异熟生此身语业应是异熟。然身语业定非异熟。加行起故。亦不可说为善染污。执异熟生心所起故。由此异熟生心。不能发身语业。复次若见所断心作能转。修所断心作随转。或修所断心作能转。即修所断心作随转。发身语业斯有是处。若见所断心作能转。即见所断心作随转。或修所断心作能转。见所断心作随转发身语业无有是处。何以故。以见所断心不能作刹那等起发身语业故。今于此中。因论生论。问何故住见所断心。不能作刹那等起发身语业耶。答要粗散心。能作刹那等起发身语业。此心微细故不能发。复次外门转心。能作刹那等起发身语业。此心内门转故不能发。复有说者。若见所断心。能作刹那等起发身语业者。此业当言是何。为见所断。为修所断。为俱所断。若见所断者。此身语业应非修所断法为方便依。谓修所断四大所造。若修所断者。不应以见所断心。为刹那等起。若俱所断者。随所起一业应成二分。如是则一法有二自性。但不尔故见所断心非刹那等起。问若见所断心不能作刹那等起。发身语业者。契经所说当云何通。如契经说。诸邪见人所有身语意业。若思若求若所造作。一切皆得不可爱不可乐非悦意果。所以者何。此见暴恶所谓邪见。答依因等起作如是说。非依刹那等起是故无过。复次若此众同分心作能转。即此众同分心作随转。或余众同分心作能转。即余众同分心作随转。发身语业斯有是处。若此众同分心作能转。余众同分心作随转。发身语业无有是处。复有说者。亦有是处。谓如有人发愿当作五年大会中间命终。乘此愿力生富贵家自忆宿命。如昔所愿一切皆作。如是则名此众同分心作能转。余众同分心作随转发身语业

三妙行三清净。谓身语意清净。乃至广说。问何故作此论。答为欲分别契经义故。如契经说有三妙行三清净。虽作是说而不广辩。广说如前。复有说者。前纳息中已分别三妙行未分别三清净今欲分别故作斯论

为三妙行摄三清净。三清净摄三妙行耶。答随其事展转相摄。所以者何。诸身妙行即身清净。诸语妙行即语清净。诸意妙行即意清净。问无漏妙行永离垢离秽离浊可名清净。有漏妙行既是有垢有秽有浊。云何名清净。答有漏妙行以分清净故名清净。所以者何。有漏妙行亦能离乃至无所有处诸烦恼垢。故得名清净。复有说者。有漏妙行能引发。随顺第一义清净故亦名清净

三妙行三寂默。谓身语意寂默。乃至广说。问何故作此论。答为欲分别契经义故。如契经说。有三妙行三寂默。虽作是说而不广辩。广说如前。复有说者。前纳息中已分别三妙行。未分别三寂默。今欲分别故作斯论

三妙行三寂默。为三妙行摄三寂默。三寂默摄三妙行耶。答应作四句。有妙行非寂默。谓除无学身语妙行。诸余身语妙行。及一切意妙行。有寂默非妙行。谓无学心。有妙行亦寂默。谓无学身语妙行。有非妙行非寂默。谓除前相。相谓所名如前广说。谓于色蕴中除善色。行蕴中除无贪无嗔。正见及诸善思。识蕴中除无学心。取余色行识蕴及二蕴全并无为法。如是一切作第四句。故言谓除前相

三清净三寂默。为三清净摄三寂默。三寂默摄三清净耶。答应作四句。有清净非寂默。谓除无学身语清净。诸余身语清净。及一切意清净。此复云何。谓学非学非无学身语清净。及三种意清净。以意寂默唯无学心故。有寂默非清净。谓无学心非业性故。有清净亦寂默。谓无学身语清净。有非清净非寂默。谓除前相。相谓所名如前广说

问何故于五蕴中。唯色识二蕴建立寂默非余蕴耶。答应具建立而不立者。当知此义有余。复有说者。此中显示最初最后故作是说。初谓色蕴后谓识蕴。如说初后如是入出趣向已度。方便究竟当知亦尔。复有说者。此中显示最粗最细。于五蕴中。色蕴最粗。识蕴最细。复有说者。真实寂默唯无学心。此无学心由谁比度。谓身语业。故唯无学心身语业。建立寂默。问何故寂默唯在无学。答唯无学身中寂默可得。学及非学非无学身中皆不可得。因论生论何故唯无学身中寂默可得。非余耶。答由此寂默是最胜法。非劣身中有胜法可得。所以者何。若说胜法则无学法。胜非学法等。若说胜补特伽罗则无学补特伽罗。胜非有学等。复有说者。无学身中烦恼意言究竟息灭。寂默圆满故立寂默。余身不尔故不建立

问妙行清净寂默有何差别。或有说者。名即差别。谓名妙行。名清净。名寂默。复有说者义亦差别。谓善巧作义是妙行义。体洁白义是清净义。离痴乱义是寂默义。复有说者。能感爱果故名妙行。不杂烦恼故名清净。究竟静息故名寂默。是谓妙行清净寂默三种差别。诸身恶行。彼尽非理所引身业耶。设非理所引身业。彼尽身恶行耶。乃至广说。问何故作此论。答为欲分别契经义故。如契经说。有非理所引身语意业。契经虽作是说而不广辩。广说如前。复有说者。前纳息中虽已分别三种恶行。而未分别非理所引身语意业。今欲分别故作斯论。诸身恶行。彼尽非理所引身业耶。设非理所引身业。彼尽身恶行耶。答诸身恶行彼尽非理所引身业。何以故。以诸恶行皆违理故。非理作意所等起故。有非理所引身业。非身恶行。谓有覆无记身业。及无覆无记。非理所引身业有覆无记身业者。谓初静虑地谄爱等烦恼所起身业。无覆无记非理所引身业者。谓应如是去来。而不如是去来等。广说如前。诸语恶行。彼尽非理所引语业耶。设非理所引语业。彼尽语恶行耶。答诸语恶行。彼尽非理所引语业。何以故。以诸恶行皆违理故。非理作意所等起故。有非理所引语业。非语恶行。谓有覆无记语业。及无覆无记非理所引语业。有覆无记语业者。谓初静虑地谄爱等所起语业。无覆无记非理所引语业者。谓应作一言而不作等。广说如前

诸意恶行。彼尽非理所引意业耶。设非理所引意业。彼尽意恶行耶。答应作四句。有意恶行非非理所引意业。谓贪欲嗔恚邪见三种意恶行。有非理所引意业非意恶行。谓有覆无记意业。及无覆无记非理所引意业。有覆无记意业者。谓欲界系萨迦耶见。边执见相应思。及色无色界一切烦恼相应思。无覆无记非理所引意业者。谓思能起。如前所说。无覆无记非理所引身语二业。有意恶行亦非理所引意业。谓不善意业。有非意恶行亦非非理所引意业。谓除前相。相谓所名如前广说。谓于行蕴中作四句。于中除贪嗔邪见。及染污思。并无覆无记非理所引思。取余相应不相应行蕴。及四蕴全并无为法。如是一切作第四句。故言谓除前相

诸身妙行。彼尽如理所引身业耶。设如理所引身业。彼尽身妙行耶答诸身妙行。彼尽如理所引身业。何以故。一切妙行不违理故。如理作意所等起故。有如理所引身业非身妙行。谓无覆无记如理所引身业。此复云何。谓应如是去来。而能如是去来等。广说如前

诸语妙行彼尽如理所引语业耶。设如理所引语业。彼尽语妙行耶。答诸语妙行。彼尽如理所引语业。何以故一切妙行不违理故。如理作意所等起故。有如理所引语业。非语妙行。谓无覆无记如理所引语业。此复云何。谓应作一言而作一言等。广说如前。诸意妙行。彼尽如理所引意业耶。设如理所引意业。彼尽意妙行耶。答应作四句。有意妙行。非如理所引意业。谓无贪无嗔正见三种意妙行。有如理所引意业。非意妙行。谓一分无覆无记如理所引意业。即思谓能起。如前所说。无覆无记如理所引身语二业。有意妙行。亦如理所引意业。谓善意业。有非意妙行。亦非如理所引意业。谓除前相。相谓所名如前广说。谓于行蕴中作四句。于中除无贪无嗔正见及善思。并无覆无记。如理所引思。取余相应不相应行蕴。及四蕴全并无为法。如是一切作第四句。故言谓除前相

说一切有部发智大毗婆沙论卷第一百一十七阿毗达磨大毗婆沙论卷第一百一十八

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    业蕴第四中邪语纳息第二之三

诸法由业得。彼法当言是善不善无记耶。乃至广说。问何故作此论。答为止他宗显己义故。谓犊子部。分别论者。欲令音声是异熟果。问彼由何量作如是说。答由圣言故。如施设论说。何缘菩萨感得梵音大士夫相。菩萨昔余生中。离粗恶语此业究竟得梵音声。由此说故彼便计声是异熟果。为遮此意显一切声非异熟果故作斯论。诸法由业得。彼法当言是善不善无记耶。答依异熟果诸法由业得彼法是无记。问何故作是说。答或有诸法虽由业得而非无记。如诸律仪不律仪等。为简彼法故作是说。依异熟果诸法由业得彼法是无记此中犊子部分别论者。问应理论者言。定作是说依异熟果诸法由业得彼法是无记耶。此是审定他宗之言。若不审定他所立宗。便难他者则无有能与他作过。亦是征难他所不说故审定言。汝今忍可定作是说。依异熟果诸法由业得。彼法是无记耶。应理论者答言如是。彼复问言为何所欲。如来善心说语。妙音美音和雅音悦意音。此语是善耶。应理论者答言如是。彼便难言。听我说汝负处失处违自言处。若作是说。依异熟果诸法由业得彼法是无记。则不应言如来善心说诸妙音美音和雅音悦意音此语是善。作是说者不应道理。若作是说如来善心说诸妙音美音和雅音悦意音。此语是善则不应言依异熟果诸法由业得彼法是无记。而作是说不应道理。应理论者释彼难言。应作是说。菩萨昔余生中。造作增长感异熟果大宗叶业。由是因缘展转出生如来咽喉微妙大种。从此能生妙语音声而声非异熟

问若一切声非异熟果。施设论说当云何通。答依展转因作如是说。然一切声非异熟果。问何故诸声非异熟果。或有说者。声属第三传。谓最初业生诸大种。大种生声。声属第三故非异熟果。复有说者。声属第五传。谓初业生异熟大种。异熟大种生长养大种。长养大种生等流大种。从此等流大种生声。声属第五故非异熟果。复有说者。声随欲转非异熟法可随欲转。复有说者。声复生声非从异熟复生异熟。有说。声是现在加行所发。异熟果是先业所起。复有说者。离初静虑染时语表便断。若是异熟者应离三界染时方断。复有说者。声有三种。谓善不善无记。异熟果唯无记。有说。若声是异熟者生可爱趣。应一切时出如意声。生非可爱趣。应一切时出不如意声。现见有时与此相违。是故声非异熟。复有说者。声有间断异熟色无间断。是故声非异熟。然诸菩萨由二因缘。发愿求佛大士夫相微妙梵音。一由曾见。二由曾闻。由曾见者。谓彼菩萨。曾见诸佛处大集会。为诸有情以梵音声。宣说正法摧伏异论。微妙深远具丈夫相。由曾闻者。谓彼菩萨。具闻如来以梵音声。宣说正法乃至具丈夫相。尔时菩萨见闻欢喜深心爱乐。则便誓受顺彼正因。我诸禁戒梵行精进。皆当回向愿于未来。得住如是大士行类。由此意乐复以种种上妙香花供具音乐。供养诸佛独觉声闻制多形像。承事供养父母师长同梵行者。修如是等殊胜福时。一一回求此梵声相。又勤净除二种业道。谓粗恶语。及杂秽语。由勤净除粗恶语故。得大士相微妙梵音。由此梵音摧伏一切外道他论。由勤净除杂秽语故。感得言词威肃清亮。由此言词映夺一切世俗异论。譬如有人见他处在华妙堂阁。陈列五乐欢娱自恣。闻他拊奏五乐音声。作是思惟。我于何时当得如是处妙堂阁。陈列五乐欢娱自适。既思惟已勤加功力。积集财宝如其所愿皆能办之。菩萨亦尔由见及闻。发愿求佛梵音声相诸业。过去乃至广说。问何故作此论。答诸有不顾去来愚三世者。欲令过去未来是无。唯说现在无为是有。为遮彼执显过去未来是实有法故作斯论。复次所以作此论者。为欲遮止外道所说故。彼说言一切诸法后为前因。犹如泉水后逼于前令涌令注。如是后水为前水因。诸法亦尔由后念法所推逼故。令从未来起入现在。复从现在灭入过去。是故未来为现在因。现为过因。为遮彼执明一切法。前为后因非后前因。若说后法为前因者。便违内外诸法缘起。违内法缘起者。谓应行缘无明。乃至老死缘生。因于子息而有父母。眼识为缘生于眼色。乃至意识为缘生于意法。从頞部昙生羯逻蓝。乃至从老生于中年。违外法缘起者。谓应芽为种因。乃至果为花因如是等若尔则有大过。谓未作应得。应先受善恶异熟。后造善恶业。先堕无间狱。后造五逆罪。先受轮王位。后造轮王业。先证阿耨多罗三藐三菩提。然后修菩萨行。若未作而得。亦应已作而失。如此则无系缚出离。勿有此过。是故诸法前为后因。非后前因。由是因缘故作斯论。诸业过去彼果过去耶。答彼果或过去。或未来。或现在果。谓异熟果由已灭等差别故。成三种诸业未来彼果未来耶。答如是。以非果先因在后故。诸业现在彼果现在耶。答彼果或现在。或未来。所释如前。此中有说。依刹那现在作论。依此所说诸业过去。彼果随在何世。而彼业皆有四种。谓顺现法受。乃至顺不定受。诸业未来诸业现在。随所有果彼业亦四。而不应言诸业现在彼果现在。非此刹那造业。即此刹那受异熟果故。或有说者。此中依分位现在而作论。依此所说诸业过去彼果过去。未来现在。诸业未来诸业现在彼果未来。皆如前说。诸业现在彼果现在者。彼业有二。谓顺现法受。顺不定受。复有说者。此中依一众同分现在作论。依此所说诸业过去。彼果或过去者如前说。或未来者彼业有二。谓顺后次受。及顺不定受。或现在者彼业有三。除顺现法受。诸业未来亦如前说。诸业现在彼果或现在者。彼业有二。谓顺现法受。及顺不定受。或未来者彼业有三。除顺现法受。问颇有顺现法受业。因在过去果在未来耶。答有。谓依刹那分位现在。不依一众同分现在而说。复有说者。亦依一众同分现在而说。谓如有人。造作增长顺现法受业已。未获与果率尔命终。尔时即名因在过去果在未来。颇有顺现法受业。因在过去果在现在。或因在现在果在未来耶。若依一众同分现在为问。应答言无。尊者妙音说有。谓如前说。颇有如身业感异熟果。语业意业不尔耶。乃至广说。今于此中方便显示三业所感爱非爱果。后见蕴中方便显示分位差别。此中所问先答黑品。后答白品。是名此处略毗婆沙。颇有如身业感异熟果。语业意业不尔耶。答有。如身不护语护。彼于尔时有善心或无记心。谓于今时起不善身表业。由此发起无表业随转。及于今时或先时起善语表业。由此发起无表业随转。即于尔时善心现起或无记心。此中身业感非爱异熟。语业感爱异熟。意业若善心起感爱异熟。若无记心起。不感爱非爱异熟。又如身护语不护。彼于尔时有不善心或无记心。谓于今时起善身表业。由此发起无表业随转。及于今时或由先时起不善语表业。由此发起无表业随转。即于尔时不善心现起或无记心。此中身业感爱异熟。语业感非爱异熟。意业若不善心起。感非爱异熟。若无记心起。不感爱非爱异熟。是名如身业感异熟果。语业意业不尔

颇有如语业感异熟果。身业意业不尔耶。答有。如身护语不护。彼于尔时有善心或无记心。谓于今时或由先时起善身表业。由此发起无表业随转。及于今时起不善语表业。由此发起无表业随转。即于尔时善心现起或无记心。此中身业感爱异熟。语业感非爱异熟。意业若善心起。感爱异熟。若无记心起。不感爱非爱异熟。如身不护语护。彼于尔时起不善心或无记心。谓于今时或由先时起不善身表业。由此发起无表业随转。及于今时起善语表业。由此发起无表业随转。即于尔时起不善心或无记心。此中身业感非爱异熟。语业感爱异熟。意业若不善心起。感非爱异熟。若无记心起。不感爱非爱异熟。是名如语业感异熟果。身业意业不尔

诸有欲令有缺减律仪不律仪者。依彼意趣此诸句中。身护语不护。语护身不护。皆得依三种说。谓若住律仪。若住不律仪。若住非律仪非不律仪。诸有欲令无缺减律仪不律仪者。依彼意趣。此等唯依住非律仪非不律仪者说非余

颇有如意业感异熟果身业语业不尔耶。答有。如身护语护。彼于尔时有不善心此相违说亦尔。此相违等如前准释此中若意业感非爱异熟身语业便感爱异熟。若意业感爱异熟。身语业便感非爱异熟。是名如意业感异熟果。身业语业不尔

颇有如身业语业感异熟果意业不尔耶。答有。如身不护语不护。彼于尔时有善心或无记心。此相违说亦尔。如前准释。此中若身语业感非爱异熟。意业便感爱异熟。或都不感。若身语业感爱异熟。意业便感非爱异熟。或都不感。是名如身业语业感异熟果。意业不尔

诸有欲令有缺减律仪不律仪者。及有欲令无缺减律仪不律仪者。依彼意趣此诸句中。身护语护。身不护语不护。皆得依三种说。谓若住律仪若住不律仪。若住非律仪非不律仪。颇有如身业意业感异熟果语业不尔耶。答有。如身不护语护。彼于尔时有不善心此相违说亦尔。如前准释

颇有如语业意业感异熟果身业不尔耶。答有。如身护语不护。彼于尔时有不善心此相违说亦尔。如前准释。颇有如身业语业感异熟果。意业亦尔耶。答有。如身不护语不护。彼于尔时有不善心此相违说亦尔。如前准释。此中或三业皆感非爱异熟。或三业皆感爱异熟。是名如身业语业感异熟果。意业亦尔

颇有非身业语业意业感异熟果。而感异熟果耶。答有。谓心不相应行感异熟果。色心心所法心不相应行此复云何。谓无想定灭尽定。得及彼生老住无常

问无想定感何异熟。或有说者。无想定感无想及色异熟。命根众同分。是彼有心静虑。异熟所余诸蕴是俱异熟。复有说者。无想定感无想及色异熟。命根是彼有心静虑。异熟所余诸蕴是俱异熟。复有说者。无想定感无想异熟。所余诸蕴是俱异熟。问若尔命根便非是业所感异熟。品类足说当云何通。如说一法是业异熟非业。所谓命根。答一切命根是异熟果。诸异熟果多由业感故作是说。然此不无非业感者。复有说者。若有心时亦感无心诸蕴异熟。若无心时亦感有心诸蕴异熟。问若尔应有心因感无心果。应无心因感有心果。答此亦无过。如有色因感无色果。或无色因感有色果。业果差别不违正理此亦如是。评曰应作是说。无想异熟唯无想定感。一切命根及众同分。眼等色根皆业所感。余蕴俱感。问灭尽定感何异熟。答感非想非非想处四蕴异熟。问得感何异熟。答感色心心所法心不相应行。问得能感众同分不。或有说者。不感。所以者何。众同分者是业所感。此得非业故不能感。诸说得不能感众同分者。彼说诸得感色异熟者。能感四处。谓色香味触。亦感心心所法异熟者。谓乐受苦受不苦不乐受。及相应法。感心不相应行异熟者。谓得生住老无常。尊者僧伽伐苏说曰。得亦能感众同分果。谓众多得积集能感一众同分。所得依身愚钝羸劣。不明不利。犹如蚯蚓蚖蛇象等。彼众同分是得所感。诸说得亦能感众同分者。彼说此得感色异熟者。谓九处除声处。感心心所法异熟者。谓乐受苦受不苦不乐受。及相应法。感心不相应行异熟者。谓命根众同分得生住老无常。彼不应作是说。所以者何。得得相望不同一果。假使积集数过俱胝复何所益。若同一果可有是事。是故如前所说者好。尊者妙音作如是说。得不能感众同分果。余业感得众同分时。于其眼处乃至意处。得亦能感相状异熟。即彼诸法生住老无常此中亦摄依附彼法。不自在故。颇有顺现法受等三业。非前非后受异熟果耶。答有。乃至广说。此中非前者。遮过去。非后者遮未来。受异熟果者。谓三业同于一刹那顷受异熟果。依此立问。是以答言有。谓顺现法受业色者。此业能感四处异熟。谓色香味触。顺次生受业心心所法者。此业能感乐受苦受不苦不乐受。及彼相应异熟。顺后次受业心不相应行者。此业能感四类异熟。谓命根众同分得生住老无常。又顺现法受业心不相应行者。此业能感二类异熟。谓得生住老无常。顺次生受业色者。此业能感九处异熟。除声处。顺后次受业心心所法者。此业能感乐受苦受不苦不乐受。及彼相应异熟。又顺现法受业心心所法者。此业能感乐受苦受不苦不乐受。及彼相应异熟。顺次生受业心不相应行者。此业能感四类异熟。谓命根众同分得生住老无常。顺后次受业色者。此业能感九处异熟。谓除声处。颇有顺乐受等三业。非前非后。受异熟果耶。答有。谓顺乐受业色者。此业能感人天九处异熟。谓除声处。能感恶趣四处异熟。谓色香味触。顺苦受业心心所法者。此业能感苦受。及彼相应异熟。顺不苦不乐受业心不相应行者。此业能感人天四类异熟。谓命根众同分得生住老无常。能感恶趣二类异熟。谓得生住老无常。又顺乐受业心不相应行者。此业能感人天四类异熟。谓命根众同分得生住老无常。能感恶趣二类异熟。谓得生住老无常。顺苦受业色者。此业能感恶趣九处异熟。谓除声处。能感人天四处异熟。谓色香味触。顺不苦不乐受业心心所法者。此业能感不苦不乐受。及彼相应异熟。又顺乐受业心心所法者。此业能感乐受及彼相应异熟。顺苦受业心不相应行者。此业能感恶趣四类异熟。谓命根众同分得生住老无常。能感人天二类异熟。谓得生住老无常。顺不苦不乐受业色者。此业能感人天九处异熟。谓除声处。能感恶趣四处异熟。谓色香味触

颇有三界业。非前非后受异熟果耶。答有。乃至广说。此中道理应答言无。以异熟果界地断故。而言有者。有何理耶。有说。此中以问非理。是故随彼作非理答。何故须作非理问耶。欲试验他故为此问。曾闻迦湿弥罗国有一论师。至北印度闇林僧伽蓝。知众事者差为僧使。故不受言我是论师应免斯事。其知事者往白众首阿罗汉言。迦湿弥罗国有一苾刍。至此僧伽蓝次当僧使彼不受言我是论师应免斯事。阿罗汉言汝应往问。颇有三界业。非前非后受异熟果耶。知僧事者便往问之。彼得此问答言无有。知僧事者还往众首阿罗汉所白言。已问彼答言无。阿罗汉言。定是论师应免僧事。故今于此还述彼问。欲有试验故亦复作非理而答。复有说者。依增上果为此问答亦不违理。以三界业容有一时受此果故谓欲界系业色者。此业亦感欲界系九处异熟。谓除声处。色界系业心心所法者。谓婆罗门长者居士诸净信者。闻有苾刍证得静虑。便施种种衣服饮食诸资身具。彼受施已发生乐受及相应法。无色界系业心不相应行者谓婆罗门长者居士诸净信者。闻有苾刍得无色定。便施种种衣服饮食诸资身具。彼受施已命根不断。又欲界系业心不相应行者。此业亦感欲界四类异熟。谓命根众同分得生住老无常。色界系业色者。谓婆罗门长者居士诸净信者。闻有苾刍证得静虑。便施种种衣服饮食诸资身具。彼受施已长养诸根增益大种。无色界系业心心所法者。谓婆罗门长者居士诸净信者。闻有苾刍证无色定。便施种种衣服饮食诸资身具。彼受施已发生乐受及相应法。又欲界系业心心所法者。此业亦感乐受苦受不苦不乐受。及彼相应法。色界系业心不相应行者。谓婆罗门长者居士诸净信者。闻有苾刍证得静虑。便施种种衣服饮食诸资身具。彼受施已命根不断。无色界系业色者。谓婆罗门长者居士诸净信者。闻有苾刍证无色定。便施种种衣服饮食诸资身具。彼受施已长养诸根增益大种。由此道理今于此中。依增上果作此问答亦不违理。以增上果一切界地无隔断故。颇有善不善业。非前非后受异熟果耶。答有。乃至广说。谓善业色者。此业能感人天九处异熟。谓除声处。能感恶趣四处异熟。谓色香味触。不善业心心所法者。此业能感苦受及彼相应异熟。心不相应行者。此业能感恶趣四类异熟。谓命根众同分得生住老无常。能感人天二类异熟。谓得生住老无常。又善业心心所法者。此业能感乐受不苦不乐受。及彼相应异熟。心不相应行者。此业能感人天四类异熟。谓命根众同分得生住老无常。能感恶趣二类异熟。谓得生住老无常。不善业色者。此业能感恶趣九处异熟。谓除声处。能感人天四处异熟。谓色香味触。颇有见修所断业。非前非后受异熟果耶。答有。乃至广说。谓见所断业色者。此业能感恶趣九处异熟。谓除声处。能感人天四处异熟。谓色香味触。修所断业。心心所法。心不相应行者。此业有二种。谓善不善。善业心心所法者。此业能感乐受不苦不乐受。及彼相应异熟。心不相应行者。此业能感人天四类异熟。谓命根众同分得生住老无常。能感恶趣二类异熟。谓得生住老无常。不善业心心所法者。此业能感苦受及彼相应异熟。心不相应行者。此业能感恶趣四类异熟。谓命根众同分得生住老无常。能感人天二类异熟。谓得生住老无常。又见所断业心心所法者。此业能感苦受及彼相应异熟。心不相应行者。此业能感恶趣四类异熟。谓命根众同分得生住老无常。能感人天二类异熟。谓得生住老无常。修所断业色者。此业有二种。谓善不善。善业色者。此业能感人天九处异熟。谓除声处。能感恶趣四处异熟。谓色香味触。不善业色者。此业能感恶趣九处异熟。谓除声处。能感人天四处异熟。谓色香味触。异熟因果如杂蕴智纳息中已广说

    业蕴第四中害生纳息第三之一

颇有已害生杀生未灭耶。如是等章及解章义既领会已。次应广释。此中有非杀生以杀生声说。有非加行以加行声说。谓杀生加行亦名杀生。杀生后起亦名加行。是谓此处略毗婆沙。颇有已害生杀生未灭耶。答有。如已断他命彼加行未息。谓如有人为害他命。以刀杖等加害。加行未息而彼命已断。遣使咒药广说亦尔。颇有未害生杀生已灭耶。答有。如未断他命。彼加行已息。谓如有人为害他命。以刀杖等加害。其命未断彼谓已断。不复加害。遣使咒药广说亦尔。颇有已害生杀生已灭耶。答有。如已断他命彼加行已息。谓如有人为害他命。以刀杖等加害。即命断时加行亦息。遣使咒药广说亦尔。颇有未害生杀生未灭耶。答有。如未断他命。彼加行未息。谓如有人为害他命。以刀杖等加害。其命未断彼加行亦未息。遣使咒药广说亦尔

颇有未害生杀生未灭。此业异熟定生地狱耶。答有。如作无间业加行时命终。其事云何。谓如有人欲害其母适起加行。或为官司所获。或母有力反害其子。或母福德天神为杀子堕地狱而母犹存。或起加行致母必死。而便中悔自害其命亦生地狱。如害母如是造余无间应知亦尔。问唯法无众生云何而有杀罪。尊者世友说曰。如虽无众生。而有众生想。如是虽无众生。而有杀罪。复次此蕴界处。能起我想。有情想。命者。生者。养者。补特伽罗想。是故若断坏彼得杀生罪。复次蕴界处。能起我想常乐净想。是以若断坏之。彼得杀生罪。大德说言。此蕴界处。是有执受起三时觉。谓我当杀正杀已杀。是故若断坏彼得杀生罪。然众生是世俗有杀生罪。是胜义有此杀生罪。由二缘得。一起加行。二果究竟。若起加行果不究竟。或果究竟不起加行。皆不得杀罪。若起加行果亦究竟方得杀罪。问颇有亦起加行果亦究竟。而不得杀罪耶。答有。如能杀所杀俱时舍命。或能杀者前死。问杀何蕴名杀生。过去耶。未来耶。现在耶。过去已灭。未来未至。现在不住。悉无杀义云何名杀生耶。答杀未来蕴。非过去现在。问未来未至云何可杀。答彼住现在遮未来世诸蕴和合说名为杀。由遮他蕴和合生缘故得杀罪。有说杀现在未来蕴但非过去。问未来可尔现在不住设彼不杀亦自然灭。云何杀耶。答断彼势用说名为杀。所以者何。先现在蕴虽不住而灭。然不能令后蕴不续。今现在蕴不住而灭。则能令其后蕴不续故。于现蕴亦得杀罪。问诸蕴中何蕴可杀。于彼得杀罪。有说色蕴。所以者何。唯色可为刀杖等所触故。有说五蕴

问四蕴无触云何可杀。答彼依色转色蕴坏时。彼便不转故亦名杀。如瓶破时乳等亦失。又彼都于五蕴起恶心。而杀故于彼得杀罪。问为杀无记。于彼得罪为三种耶。有说。无记。所以者何。唯无覆无记。可为刀杖等所触故。有说三种。问善染污法无触云何可杀。答善染污法依无记转。无记坏时彼便不转故亦名杀。余广说如前。问如以一加行俱时杀母及余女人。彼于母得杀生及无间无表罪。于余女人唯得杀生无表罪。而此表业为但得一为得二耶。有作是说。但得一表。所以者何。以一加行俱时而杀无差别故。尊者妙音说曰。彼得二表。所以者何。此身表业极微所成。害母及余极微各异。如无表得二表亦应尔。问如以一加行杀多众生。随尔所众生得尔所无表罪。而此表业为但得一为得多耶。有说得一。所以者何。以一加行俱时而杀无差别故。尊者妙音说曰。彼得多表。广说如前

问杀寿应尽者得杀罪不。答若此刹那寿应尽。即尔时加害者不得杀罪。若由加害乃至令彼一刹那寿住不生。法皆得杀罪。咒多刹那。问杀断末摩者。得杀罪不。答若此刹那正应舍命。即尔时加害者不得杀罪。若由加害乃至令彼一刹那命住不生。法皆得杀罪。况多刹那

问若有害他令定当死。便自害命得杀罪不。答不得。所以者何。以彼果未究竟。便自失命无后众同分。可成就彼罪故。问若战斗时互相加害。俱时死者各得杀罪不。答不得。所以者何。以二皆悉果未究竟。便俱失命无后众同分。可成就彼罪故。问若为王等逼令行杀。得杀罪不。有说不得。所以者何。他力所制非彼意乐故。如是说者。亦得杀罪。除自要心宁舍己命终不害他。如是则无罪。问若依先王所制法。令刑罚有过得杀罪不。答得王及法司。若遣他杀得杀生无表罪。彼所遣人。及若自杀俱得杀生表无表罪。若众多有情谋害一命。彼起加行亲断命者。得杀生摄表无表罪。余同谋及作声援者。但得杀生无表。若彼多人等设加行断彼一命。当知皆得表无表罪。颇有非身作。而得杀生罪耶。答有。谓语遣杀。颇有不发语而得虚诳语罪耶。答有。谓身表。颇有非身作不发语而得二罪耶。答有。谓仙人意愤。及布洒他时默然表净

说一切有部发智大毗婆沙论卷第一百一十八阿毗达磨大毗婆沙论卷第一百一十九

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    业蕴第四中害生纳息第三之二

颇有业不善顺苦受异熟未熟乃至广说。问何故作此论。答为止他义显己义故。谓或有说。无有中有。或复有说。虽有中有而生恶趣者无。或复有说。生恶趣者虽有中有而生地狱者无。或复有说。生地狱者虽有中有而先造无间业者无。或复有说。先造无间业者

虽有中有而中有中不受无间异熟。或复有说。虽住中有亦受无间异熟。而但受四蕴不受色蕴。欲遮此等种种僻执显有中有。于有色界一切生处无不皆有。于中亦受色蕴异熟。由是因缘故作斯论

颇有业不善顺苦受异熟未熟。非不初受异熟果。而起染污心耶。答有。如造作增长无间业。已此业最初地狱中有异熟果生。问造作增长何差别。有说。无差别。有说。名则差别。此名造作。此名增长。有说义亦有差别。谓或有由一恶行堕诸恶趣。或有由三。若由一恶行堕恶趣者。彼加行时但名造作不名增长。若至究竟名为造作亦名增长。若具由三堕恶趣者。造一二时但名造作不名增长。若具造三名为造作亦名增长。如三恶行三妙行亦尔。差别者生善趣。复次或有由一无间堕于地狱。或具由五。若由一者彼加行位。但名造作不名增长。若至究竟名为造作亦名增长。若具由五造一至四。但名造作不名增长。若具造五名为造作亦名增长。复次或有由一不善业道堕诸恶趣。或具由十。若由一者彼加行位。但名造作不名增长。若至究竟名为造作亦名增长。若具由十造一至九。但名造作不名增长。若具造十名为造作亦名增长。如十不善业道。十善业道亦尔。差别者生善趣。复次或有由多妙行感一众同分。如诸菩萨最后众同分。由三十二百福所感。若造一百福至三十一百福。但名造作不名增长。若时具造三十二百福。名为造作亦名增长。复次或有业故思所造。或有业非故思造。若故思所造名为造作亦名增长。若非故思所造。但名造作不名增长。审思而造。率尔而造。说亦尔。复次或有业顺三时受。或有业顺不定受。顺三时受名为造作亦名增长。顺不定受但名造作不名增长。顺决定受。顺不定受。说亦尔

复次或有业顺别定受。或有业顺不别定受。顺别定受者。名为造作亦名增长。顺不别定受者但名造作不名增长。复次或有业时分定异熟亦定。或有异熟定。时分不定。二俱定者名为造作亦名增长。唯一定者但名造作不名增长。复次有不善业顺恶趣受。有不善业顺善趣受。前名造作亦名增长。后名造作不名增长。善业与此相违。说亦尔。复次有不善业。不善为助伴有不善业。善业为助伴。前名造作亦名增长。后名造作不名增长。善业与此相违。说亦尔。复次有不善业无作见邪见。迷因果相续中生。有不善业有作见正见。不迷因果相续中生。前名造作亦名增长。后名造作不名增长。善业与此相违。说亦尔。复次有不善业坏戒坏见。有不善业坏戒不坏见。前名造作亦名增长。后名造作不名增长。善业与此相违。说亦尔。复次有不善业加行坏意乐坏。有不善业加行坏意乐不坏。前名造作亦名增长。后名造作不名增长。善业与此相违。说亦尔。复次有业作已不舍不变不吐不依对治。有业作已舍变吐依对治。前名造作亦名增长。后名造作不名增长。如是有业三时觉察。三时不觉察。作已无悔。作已有悔作已随念。作已不随念。数数忆念。不数数忆念。说亦尔。复次若业能取果与果。名为造作亦名增长。若业取果不能与果。但名造作不名增长。尊者世友说曰。若所作业意乐回向意乐显示。为同类者称赞显说。是名造作亦名增长。若所作业与此相违。但名造作非名增长。有作是说。若所作业一切种圆满。一切种究竟。如造制多严饰周毕。此名造作亦名增长。若所作业与此相违。但名造作不名增长。大德说言。若所业众缘和合必。定感果名为造作亦名名增长。若所作业与此相违。但名造作不名增长。如是等有无量门。是名造作增长差别

无间业有五种。一害母。二害父。三害阿罗汉。四破和合僧。五起恶心出佛身血。问此五无间业以何为自性。答以身语业为自性。前三后一身业为自性。第四一种语业为自性。是故此五三界三处一蕴所摄。三界者色声法界。三处者色声法处。一蕴者色蕴。是名无间业自性。已说自性。所以今当说。问何故名无间。答由二缘故说名无间。一遮现后。二遮余趣。遮现后者。此五但是顺次生受。非顺现法受及顺后次受。故名无间。遮余趣者。谓此决定于地狱受。非杂余趣。故名无间。由二因缘建立无间。一背恩养。二坏德田。背恩养者。谓害母害父。坏德田者。谓余三种。由二因缘得无间罪。一起加行二果究竟。虽起加行果不究竟。彼不得无间罪。虽果究竟不起加行。亦不得无间罪。虽起加行果不究竟者谓如有人欲害其母。母觉知已藏谷[卄/積]中。有余女人在母寝处。其人既至谓是己母以刀害之。害已方更往谷[卄/積]中揩拭刀刃刀触母身因兹丧命。起加行时果未究竟。果究竟时已无加行。由此不成无间之罪。有果究竟不起加行者。谓如有人扶持父母经崄路过。恐其贼来。推逼令进。父母颠仆因即丧命。果虽究竟非加行起。是故要起加行及果究竟方成无间。问颇有起加行及果究竟。而不得无间罪耶。答有。谓与所杀俱时命终。无后众同分可成就彼罪故。有兄遣弟自往害母弟依兄教俱得无间。若弟遣他及共他害。唯弟得无间。有兄遣弟令他害母。弟依兄教俱得无间。若弟自害及共他害唯弟得无间。有兄遣弟共他害母。弟依兄教俱得无间。弟若自害及但令他。唯弟得无间。有兄遣弟母来当害。弟依兄教俱得无间。若母去方害唯弟得无间。如兄遣弟。兄遣于妹弟遣于兄遣姊亦尔。如遣害来遣害去住坐卧亦尔。如害母害父亦尔。害阿罗汉。出佛身血。遣使差别类此应知。若非人杀非人父母不得无间罪。非人杀人人杀非人应知亦尔。唯有人类杀人父母方得无间。问若扇搋半择迦无形二形杀害父母得无间不答不得。所以者何。彼身法尔志力微劣不能作律仪。不律仪器故。尊者世友作如是说。扇搋迦等杀害父母不得无间。所以者何。彼于父母无爱敬心。可先现前今灭坏故。复次彼于父母无胜惭愧。可先现前今灭坏故。大德说言。扇搋迦等烦恼增故定恶趣摄。恶趣摄故无无间罪。问诸傍生类杀害父母得无间不。答不得。所以者何。彼身法尔志力微劣。不能作律仪不律仪器故。尊者世友说曰。诸傍生类杀害父母不得无间。所以者何。彼于父母无爱敬心。可先现前今灭坏故。复次彼于父母无胜惭愧。可先现前今灭坏故。大德说言。诸傍生类杀害父母。于无间罪有得不得。谓聪慧者得。非聪慧者不得。曾闻有聪慧龙马。人贪其种令与母合。马后觉知断势而死。问如以一加行俱时杀母及余女人。彼所有无表已如前说。彼有表业于谁边得耶。答于母边得。所以者何。以于彼中无间罪为胜故。尊者妙音说曰。诸有表业。极微所成。害母及余极微各异故。有表罪于二人边得。问如有女人羯剌蓝堕。有余女人收置身中。后所生子以谁为母杀害何者得无间罪。答前为生母。后为养母。唯害生母得无间罪。以羯剌蓝依前生故。诸所作事应咨养母。于非母作母想害。及于母作非母想害。俱不得无间罪。要于母作母想害。方得无间罪。于父及余应知亦尔。颇有女人非母。非阿罗汉。害之得无间罪耶。答有。谓害转根为女父。颇有男子非父。非阿罗汉。害之得无间罪耶。答有。谓害转根为男母。问若母是阿罗汉。或父是阿罗汉。彼害一一时为但得一无间罪。为得二耶。若言但得一者。彼背恩养。及坏德田。云何得一。经说复云何通。如佛告始骞持言。汝今已得二无间罪。谓害父及阿罗汉。若言得二者。彼害一命云何而得二罪。答应言得一。彼背恩养及坏德田。俱于一身转故。契经应说。汝由二缘得无间罪。谓害父及阿罗汉。而言得二罪者。欲以二罪诃责彼故。有余师言。罪体虽一所感苦倍。是以说二

问如害阿罗汉得无间罪。害诸有学亦得是罪耶。答不得。所以者何。前说无间由二缘得。一背恩养。二坏德田。害诸有学非坏德田。以彼有功德亦有过失。有妙行亦有恶行。有善根亦有不善根故。问退失阿罗汉果者。害之得无间耶。答不得。还是有学故。如前说。问此于最后命将断时。必住无学。云何不得无间耶。答于无学身无恶心故。谓彼但于学者身中起杀意及加行。非于无学。由无无间因故不得无间罪

毗奈耶说。娑罗林中有众多苾刍。为群贼所杀劫夺衣物。有近住官皆悉捉获。送至王所王敕依法。其中有一贼逃至胜林求欲出家。时苾刍众不审捡察。度令出家为受具戒。时典刑者将余群贼。至于冢间欲屠割之。苾刍闻已为知世间可厌事故。皆共往观。向出家者亦在其中。见诸罪人支节分解各各异处。彼薪出家者。即时惶恐。闷绝擗地久而乃稣。众问其故。答言。死者是我朋侣。我昨与其同为此事。若不出家亦遭斯苦。苾刍闻已互相谓言。今此恶人如何处置。便往白佛。佛言。此人杀苾刍众。得无间罪不合出家。若已出家众应驱摈勿与同止。所以者何。造无间者于我正法毗奈耶中。不能生长诸善法故。问彼不了知是阿罗汉。何故得无间罪。答不以知故得罪。以坏德田。故得罪彼于苾刍众中。起无简择等杀意乐。由此极恶之心害及阿罗汉。是故得无间罪

问若先造余无间。后乃破僧。彼生地狱先受何果。若先受余无间果者。破僧应成顺后次受。若先受破僧果者。余无间应成顺后次受。答若先造余无间业。彼后不能破僧。若先破僧。后便能造余无间业。彼后所造皆由破僧增上力故。同招无间地狱果。余顺次生受恶行。随无间业准此应知。又先破僧。后造余无间业。彼后所造皆由破僧增上力故。同招无间。乃至极受一劫寿果更无增寿。余顺次生受恶行。随无间业寿量长短亦准此知。问若因破僧生无间地狱。寿命未尽世界便坏者。彼中夭不。若中夭者彼极重业所引寿量云何中断。若不夭者云何不与世界坏而作留难。如契经说。若处乃至一有情在灾便不坏。答若寿量定彼无中夭。问若尔云何不于世界坏而作留难。答彼由业力引置余世界地狱中受。如王都内欲有恩赦。先移重囚置于边狱。然后放赦。彼亦如是。有说。此世界将欲坏时。若诸有情造无间业者。彼命终法尔更不生此间。而必生于余世界地狱中受此业果。有说。世界将欲坏时。定无有情造极恶业

问颇有具造五无间耶。有说无。所以者何。此业极重无器能胜而容受故。有余师说。有具造五。如迦叶波佛时。有苾刍名花上。是誉上子彼具造五无间业。及断善根。问由一无间。与乃至由五。堕于地狱有何差别。答由一无间堕地狱者。其身狭小苦具不多。苦受现前非极猛利。若乃至由五无间堕地狱者。其身广大苦具增多。苦受现前极为猛利

问五无间业何者最重。答破和合僧坏法身故。次出佛身血。次害阿罗汉。次害母。后害父。母之恩养于父为重。德田势力于恩田为胜故。问世尊所有诸无学法说名为佛。此不可害。云何恶心出血得无间罪耶。尊者世友说曰。以于能成大菩提法。起恶意乐欲毁坏故。虽害生身而于彼得无间罪。复次成诸佛无学法依生身转。若坏所依当知亦坏能依。如瓶破乳则失。是以得无间罪。问如起恶心出佛身血。得无间罪。颇有起恶心不至出血。亦得此无间罪耶。答有。是故应作四句。有起恶心出佛身血不得无间罪。谓起欲打心而出血。有起恶心不至出血。而得无间罪。谓起欲杀心乃至令血移处。有起恶心出佛身血。亦得无间罪。谓起欲杀心而出血。有起恶心不至出血。不得无间罪。谓起欲打心乃至令血移处。问佛身为有疮穴等不。答无。所以者何。一切如来相好圆满。身毛皮等殊妙齐平。是故无有疮穴等事。问此何业果。答如来昔于三无数劫修菩萨行时。若见有情身分缺坏。便起深悲方便救济要令圆满。若见佛像菩萨像圣僧像。灵龛制多僧伽蓝等雕落破坏。方便修治。要令如本。由此业故。今得如是相好庄严无疮穴等

颇有故思害生命后不受远离。而于一切有情得防护耶。答有。如起杀加行中间证见法性。此显不因受诸学处。但由入正性离生时。得不作律仪。名为防护。其事云何。掣迦契经是此论根本。昔有释种名掣迦。先是世尊祖父。僮仆因事逃叛住雪山所。产育男女各数十人。姻亲强盛舍宅严好。虽仓库盈溢而以畋猎为事。曾于一时。少壮丈夫皆出游猎。时薄伽梵欲往天宫为报母恩安居说法。先以佛眼遍观世间。勿有众生佛应亲度。由不见佛失获益时。寻见掣迦及诸眷属。善根已熟见谛时至。尔时世尊为度彼故。从住处没现彼门前。老父遥见则知是佛。欢喜迎逆恭敬作礼。白言。圣子。今是何日降至我家。善逝法王。今是何日得垂顾念。即命扫洒敷饰净座。烧香散花请佛世尊。入家就座。时彼老父。率诸女人稽首佛足。合掌恭敬取家所有。干湿净肉调和香味以奉世尊。尔时世尊告言。止止。诸佛如来不食血肉。时彼老父及诸女人。承命惭耻却坐一面。有说。佛于是日虚中而过。有说。取北洲食以济中时。佛应彼机为说法要。合家大小同证离生。得预流果生净法眼。深心欢喜瞻仰世尊。佛顾余机重为说法。时诸少年收捕禽鹿。恣行杀害更设机阱担肉而归。至诸妇人常所迎处。忽于是日特怪不来。咸作是思。勿有他故。登高觇望遥见家中。有非常人威光赫奕。如铸金台父及女人。前后围绕便生忿恚。共相谓言。此等不迎必由彼制。恚怒既深不遑释担。持刀直进规欲害佛。父叱之言。汝等止止。此是圣子善逝法王。来度我等宜各庆幸勿起恶心。诸子既闻咸生悔愧。弃刀释担稽首求哀。恭敬合掌却坐一面。佛应彼机为说法要。诸子闻已亦证离生得预流果。生净法眼。深心欢喜瞻仰世尊。时林野中无量虫鹿。冲诸机阱死伤非一。由圣道力令诸子等杀生业道无表不生。问杀何等生于加行位可入圣道。有作是说。杀傍生等但非杀人。有作是说。亦通杀人唯除已起无间加行。故作是说。如起杀加行中间证见法性若于一切有情得防护。彼于一切有情受远离耶。答应作四句。有于一切有情得防护。非受远离。如不受学处而证见法性。此显不受别解脱律仪。名不受学处。有于一切有情受远离。非得防护。如受学处而犯远离。此显虽受别解脱律仪。而由不如理作意。及贪等烦恼故。于所防护不能远离。有于一切有情得防护亦受远离。如受学处不犯远离。此显已受别解脱律仪。复能如理作意思择。乃至为命亦不故犯。如闻昔有乞食苾刍。次第巡里到珠师舍。正逢彼匠为王穿珠见苾刍来欢喜持钵。入家取食。苾刍衣赤日照光生。遥映宝珠亦同赤色有鹅在侧。谓肉便吞。苾刍见之遮护不及。珠师持钵盛满食来授与苾刍交谢而去。其人于后觉少一珠。窃谓苾刍盗而持去。寻则奔逐擒获将还。责言。沙门汝既释子。何无廉耻盗我王珠。苾刍答言。我无此事。其人窃念。若不苦治珠不可得。便加考楚触处血流。彼吞珠鹅复来唼血。其人恚愤以杖击之鹅因致死。苾刍便请看鹅死活。彼寻叱言。且理出珠何预鹅事。苾刍固请彼乃为看报言已死。苾刍告曰。鹅吞汝珠。其人不信。犹疑假托。苾刍谓曰。我实见吞。彼遂持刀以剖鹅腹。乃于腹内得所失珠。彼生惭耻悲喜交集。礼谢苾刍白言。尊者。何不早示使我盲愚。苦楚尊身造斯恶业。长夜受苦无有出期。苾刍告言。我受禁戒。宁舍身命不伤蚁卵。若先示汝必定害鹅。不护众生岂名持戒。如此等类名于有情亦得防护亦受远离。有非于一切有情得防护亦非受远离。谓除前相相谓所名。如前广说。谓除成就三律仪人二律仪天趣。余人天及余趣全。作第四句故言除前相。有四种律仪名为防护。一别解脱律仪。二静虑律仪。三无漏律仪。四断律仪。别解脱律仪者。谓欲界尸罗。静虑律仪者。谓色界尸罗。无漏律仪者。谓无漏尸罗。断律仪者。谓于静虑无漏二律仪中各取少分。离欲界染九无间道中。世俗随转戒二律仪摄。谓静虑律仪。及断律仪。无漏随转戒亦二律仪摄。谓无漏律仪。及断律仪。问何故唯此名断律仪。答能与破戒及起破戒烦恼。作断对治故。谓前八无间道中。二随转戒。唯与起破戒烦恼作断对治。第九无间道中。二随转戒通与破戒及起破戒烦恼。作断对治。是故静虑无漏律仪对断律仪作四句。静虑律仪对断律仪。作四句者。有是静虑律仪。非断律仪。谓除离欲界染九无间道中。世俗随转戒。诸余世俗随转戒。有是断律仪。非静虑律仪。谓离欲界染九无间道中。无漏随转戒。有是静虑律仪。亦是断律仪。谓离欲界染九无间道中世俗随转戒。有非静虑律仪。亦非断律仪。谓除离欲界染九无间道中。无漏随转戒。诸余无漏随转戒。无漏律仪对断律仪作四句者。有是无漏律仪。非断律仪。谓除离欲界染九无间道中无漏随转戒。诸余无漏随转戒。有是断律仪。非无漏律仪。谓离欲界染九无间道中世俗随转戒。有是无漏律仪。亦是断律仪。谓离欲界染九无间道中。无漏随转戒。有非无漏律仪。亦非断律仪。谓除离欲界染九无间道中。世俗随转戒。诸余世俗随转戒

问此四律仪。谁成就几。答或有但成就一。谓除断律仪。余三律仪一一成就。而无但成就断律仪者。或有成就二。谓或别解脱。静虑二。或静虑。无漏二。或静虑断二。而无成就无漏断二者。或有成就三。谓或别解脱静虑无漏三。或别解脱。静虑断三。或静虑无漏断三。无有成就别解脱无漏断三者。或有具成就四。此中但成就别解脱律仪者。谓异生生欲界受学处。未得色界善心。但成就静虑律仪者。谓异生生欲界不受学处。得色界善心而犹具缚。及生第二第三第四静虑。但成就无漏律仪者。谓圣者生无色界。或成就别解脱静虑二者。谓异生生欲界受学处。得色界善心而犹具缚。或成就静虑无漏二者。谓圣者生欲界不受学处。未离欲界染。及生第二第三第四静虑。或成就静虑断二者。谓异生生欲界不受学处。而离欲界一品乃至九品染。及生初静虑。或成就别解脱静虑无漏三者。谓圣者生欲界受学处。未离欲界染。或成就别解脱静虑断三者。谓异生生欲界受学处。离欲界一品。乃至九品染。或成就静虑无漏断三者。谓圣者生欲界不受学处。离欲界一品。乃至九品染。及生初静虑。或具成就四者。谓圣者生欲界受学处。离欲界一品。乃至九品染

问此四律仪几随心转。几不随心转。答三随心转。一不随心转。谓别解脱律仪。问何故别解脱律仪不随心转。答别解脱律仪粗而重。随心转律仪细而轻故。有说。别解脱律仪为恶戒所损伏。随心转律仪不为恶戒所损伏故。有说。别解脱律仪为恶意乐。及害意乐所损伏。随心转律仪不为彼所损伏故。有说。别解脱律仪势用蹇钝行。不及心随心转律仪势用捷利行及心故。有说。别解脱律仪依表。随心转律仪依无表故。有说。别解脱律仪是表果。随心转律仪是无表果故。有说。别解脱律仪依表是表果。随心转律仪依心是心果故。有说。别解脱律仪。依部众人和合受得。随心转律仪但依法得故。有说。别解脱律仪依他得。随心转律仪依自得故。有说。别解脱律仪。不与心一生一住一灭。随心转律仪。与心一生一住一灭故。有说。别解脱律仪。不与心一果一等流一异熟。随心转律仪。与心一果一等流一异熟故。有说。别解脱律仪。不与心俱生。随心转律仪。与心俱生故。有说。随心转法理应如是。心若善彼亦善。不善无记亦尔。别解脱律仪唯是善。若随心转者。善心起时彼可随转。不善无记心起时彼应断故。有说。随心转法理应如是。若心欲界彼亦欲界。色无色界不系亦尔。别解脱律仪唯是欲界。若随心转者欲界心起时彼可随转。色无色界不系心起时彼应断故。有说。随心转法理应如是。若心学彼亦学无学。非学非无学亦尔。别解脱律仪。唯非学非无学。若随心转者。非学非无学心起时彼可随转。学无学起时彼应断故。有说。随心转法理应如是。若心见所断。彼亦见所断。修所断不断亦尔。别解脱律仪。唯修所断。若随心转者。修所断心起时彼可随转。见所断心。非所断心起时彼应断故。有说。若别解脱律仪随心转者。应未来修。未来成就。然别解脱律仪无未来修。及未来成就故。有说。若此别解脱律仪随心转者。应不施设住戒长幼故。有说。若此律仪随心转者。应不施设戒品决定故。有说。若此别解脱律仪随心转者。应非四缘五缘而舍。言四缘者。一舍学处。二二形生。三善根断。四舍众同分。言五缘者。谓上四缘。及夜尽故。有说。若此别解脱律仪随心转者。应从上界生欲界时得。若尔便应无住律仪不律仪等三种差别故。有说。若别解脱律仪随心转者。有心时可有。无心时应断故。勿有此等诸过失故。别解脱律仪不随心转。问住别解脱律仪者。犯律仪时舍律仪不。外国诸师作如是说。彼舍律仪得非律仪。非不律仪。若时发露无覆藏心。如法悔除便舍非律仪。非不律仪。还得律仪。若作是说。便为善通。发露悔过还住律仪。作法悔除亦非无用。有余师说。彼犯律仪时舍律仪。得非律仪非不律仪。若时发露无覆藏心。如法悔除便舍非律仪非不律仪。而不得律仪。问如说发露悔过还住律仪。当云何通。如法悔除岂非无用。答住善意乐名住律仪。尔时舍恶意乐。发善意乐故非无用。然实此位不得律仪。复有说者。彼犯律仪时。现在律仪断。得非律仪非不律仪。而成就过去律仪。若时发露无覆藏心等如第二说。或有说者。彼犯律仪时初刹那断。次后复续。迦湿弥罗国诸论师言。彼犯律仪时不舍律仪。而得非律仪非不律仪。是故尔时名住非律仪非不律仪。亦名住律仪者。若时发露无覆藏心。如法悔除便舍非律仪非不律仪。但名住律仪者。如有富者负他债时名负债者。亦名富者。后还债已但名富者。若如是说便为善通。发露悔过还住律仪。作法悔除亦非无用。问善戒云何能治恶戒。答由誓受心为助伴故。无始数习诸恶尸罗暂受善戒则能除舍。犹如室中久时积闇。明灯才至则便除遣。又如于淡久习碱想。才尝盐味彼想则除。善戒治恶亦复如是。道治烦恼应知亦然

说一切有部发智大毗婆沙论卷第一百一十九阿毗达磨大毗婆沙论卷第一百二十

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    业蕴第四中害生纳息第三之三

问别解脱律仪。为但从所能有情处得。为亦从非所能处得耶。若但从所能处得者。则此律仪应有增减。谓从非所能处。生所能处时律仪应增。即从所能处生。非所能处时律仪应减。又此律仪应少分处受。而世尊说无少分受。又应成立离系所宗。谓彼外道为诱他故作如是言。善来男子。有众生去此过百踰缮那。若起善心弃舍刀杖誓不害彼。于彼便得不杀律仪。若言亦从非所能处得者。法救论所说当云何通。如彼说。尸罗从所能处得。慈从所能非所能处得。答应作是说。律仪从所能非所能处得。问前三种难此为善通。法救论云何通耶。答当知彼尊者以密意说。佛亦以密意说诸契经。况彼尊者无密意言。密意者何。谓彼尊者说现在世蕴界处名为所能。过去未来名非所能。别解脱戒名曰尸罗。静虑无漏二戒名慈。彼说别解脱戒。唯于现在有情数蕴界处得。不于过未。以过去未来堕法数故。静虑无漏二种律仪。通于三世蕴界处得。故彼所说理亦无违。是故别解脱律仪。与静虑无漏二种律仪有差别相。谓别解脱律仪唯于现在有情处得。静虑无漏二种律仪通于三世境界处得。别解脱律仪。通于业道根本加行后起处得。静虑无漏二种律仪。唯于业道根本处得。由此差别应作四句。有蕴界处于彼得别解脱律仪。非静虑无漏。谓现在业道加行后起。有蕴界处于彼得静虑无漏律仪。非别解脱。谓过去未来根本业道。有蕴界处于彼得别解脱律仪。亦静虑无漏。谓现在世根本业道。有蕴界处不从彼得别解脱律仪。亦非静虑无漏。谓过去未来业道加行后起。问若别解脱律仪。唯于现在有情处得。非于去来蕴界处者。则诸如来应正等觉律仪不等。所以者何。过去诸佛出现世时。无量有情为律仪境。彼有情类已入涅槃。释迦牟尼于彼境上不得律仪。今释迦佛出现世时。无量有情为律仪境。彼有情类已入涅槃。慈氏如来于彼境上不得律仪。境有宽狭律仪亦尔。岂非诸佛律仪不等。答应作是说。律仪境界虽有多少。而律仪体前后无异。俱从一切有情境处总发得故。有作是说。三世如来律仪不等亦无有失。问若尔施设论说当云何通。如彼说一切如来应正等觉皆悉平等。答由三事等故名平等。一修行等。谓诸如来皆于过去三无数劫。勤修四种波罗蜜多。究竟圆满得菩提故。二利益等。谓诸如来等于无量应化有情。作利乐事皆究竟故。三法身等。谓诸如来皆得十力四无所畏。三念住大悲十八不共法等胜功德故。由此三义故言平等。非律仪体无多少异。又由根等故说等言。以一切如来皆住上品根故。又由戒等。一切如来皆得上品戒故。有余师说。一切如来应正等觉所有律仪。皆于一切有情处得故说等言。非体无异。谓过去佛律仪所从诸有情境。设今犹在释迦牟尼。从彼境上亦得律仪。然无此理。释迦如来应正等觉律仪所从诸有情境。设当在者慈氏如来。从彼境上亦得律仪。然无此理。故说等言亦无有失。然诸律仪应说有一。如说。戒蕴戒修戒学。或应说二。谓表无表。或应说三。谓下中上。或从无贪无嗔无痴所生差别。或应说四。谓身语业各有表无表。或应说六。谓表无表各有下中上。或三根所生。或应说七。谓离断生命乃至离杂秽语。或应说九。谓从下下乃至上上。或应说十二。谓身语表无表各有三品或三根生。或应说十四。谓离断生命乃至离杂秽语。各有表无表。或应说十八。谓表无表各有九品。或应说二十一。谓离断生命乃至离杂秽语皆有三品或三根生。或应说四十二。谓离断生命乃至离杂秽语。各有表无表皆从三品或三根生。若以相续刹那分别。则有无量律仪。今总说七种。谓离断生命乃至离杂秽语。此中有说。彼七支戒一一于一切有情处得而所得是一。彼说于一有情所犯一支戒时。于一切有情处此一支戒断。余六犹转。此即善通世尊所说。若犯学处。非苾刍。非沙门。非释种子。有说。此七支戒。一一于一切有情处得而所得各异。如有情数量所得戒亦尔。彼说于一有情所。犯一支戒时。即此一有情处一支戒断余六犹转。余有情处七支皆转。问若尔云何通世尊所说。若犯学处非苾刍等。答依胜义苾刍言非苾刍。以不能趣彼故。有余师说。别解脱律仪。随因差别成二十一。此中有说。二十一种。一一于一切有情处得。而所得不异。彼说由贪烦恼。于一有情所犯一支戒时。于一切有情处无贪所生一支戒断。余二十种如先犹转。此则善通世尊所说。若犯学处非苾刍等。有说。此二十一种一一于一切有情处得。而所得各异。如有情数量所得戒亦尔。彼说由贪烦恼于一有情所犯一支戒时。即此一有情处无贪所生一支戒断。余二十种如先犹转。余有情处二十一种具足皆转。问若尔云何通世尊所说。若犯学处非苾刍等。答依胜义苾刍言非苾刍。如前说。依如是理故作是说。宁作出家犯诸学处。不为五戒邬波索迦。所以者何。彼若毁犯五种学处身中便空。诸出家者设犯五处而更有余众多犹转。迦湿弥罗国诸论师言。虽犯律仪而律仪不断。如法悔除还名持戒。无有顿受别舍得故。未悔除位具得二名。若已悔除但名持戒

问于外物中得律仪不。若有得者。所得律仪应有增减。谓生草枯时酒味坏时应减。即彼生时熟时应增。如是等事其类寔繁。是故律仪应有增减。若无得者即此律仪境应少分处受。而世尊说。如是律仪无少分受。又断生草等悔除应无用。有作是说。虽有得者而不名律仪。但是顺律仪法。问此顺律仪法为是律仪摄。为非律仪摄。若是律仪摄说为律仪。或说顺律仪竟有何异。若非律仪摄。此有何相而言顺律仪非律仪摄。如是说者。于外法中亦得律仪。问若尔律仪应有增减。答无增减。以总得故。谓此律仪总于一切生草等上得一无表。而世间无有无生草等时。总于一切蒲桃等酒。则不坏时得一无表。世间无有无诸酒时。是故律仪无有增减。余亦如是。问别解脱律仪由何等心得。答由普于一切有情。起善意乐。无损害心得。若起此心于某处受某处。不受不得律仪。由此律仪遍于一切所应受处。得防护故。是故说。若此律仪有方域者大地所不受。由此律仪于有情处得。有情界多地界少故

若成就身彼成就身业耶。答应作四句。有成就身非身业。谓处卵[穀-禾+卵]。若诸异生住胎脏中。若生欲界住非律仪非不律仪都无身表。设有而失彼住卵[穀-禾+卵]及胎脏中者。虽成就身未能发表。先所发表死时已失。此表依前众同分故。问何故此位未能发表。答以身微劣未能与表为所依故。有余师言。粗心能发身语表业。彼心细故。又外门心能发表业。尔时彼心内门转故。又外事心能发表业。彼心缘内事起故不能发表。有说。此位中迫迮不得自在。尚不能动。况起表业。如为怨贼缚置笼中挂龙牙上。尚不能动。况有所趣。问若尔何故亦说胎中有转动耶。答风力所转非心所为。表业必由心力所起。若生欲界住非律仪非不律仪无身表者。谓眠醉闷舍诸加行不求起表。设有而失者。谓三缘故虽起表而失。一意乐息故。二舍加行故。三限势过故。有成就身业非身。谓诸圣者生无色界。此中学成就学随转身业。无学成就无学随转身业。生无色故不成就身。有成就身亦身业。谓诸圣者住胎脏中。若生欲界住律仪。若住不律仪。若住非律仪非不律仪。现有身表。或先有不失。若生色界此中圣者。住胎脏中时亦未能起表。但成就静虑无漏无表。若生欲界住律仪者。谓于三种律仪。或一或二或具而住。即别解脱静虑无漏。住不律仪者。谓屠羊等。住非律仪非不律仪现有身表者。谓不眠不醉不闷不舍加行求起表业。或先有不失者。谓三缘故。先所起表不失。一意乐不息故。二不舍加行故。三限势未过故。此说由殷重信或猛利缠。起表无表乃至未舍。若生色界者彼决定成就身无表业。或亦成就身表。有非成就身亦非身业。谓诸异生生无色界。彼无色故不成就身。异生故不成就身业。有漏者度界地已舍故。无漏者未得故。问何故有漏色业度界地舍非无漏耶。答有漏色业被缚有系。无漏色业解脱离系故。有说。有漏色业堕界堕地。无漏堕地而不堕界故。有说。有漏色业同类大种造。能造所造俱有漏故。无漏色业异类大种造。大种有漏业无漏故。由此因缘度界地时。有漏业舍。无漏不舍

问得忍异生命终时。舍忍法不。若舍者何故不堕恶趣。又若舍者何故异生命终时舍。圣者不舍。若不舍者。何故此文及大种蕴皆不说耶。答应言舍。问若尔彼何故不堕恶趣。答由此善根势力大故。自有善根势力微劣。虽复成就不障恶趣。况不成就。如生得善或有善根势力强盛。虽不成就而障恶趣。况复成就如此忍法。是故虽舍不堕恶趣。复有说者。由此善根身中生故。令招恶趣诸业烦恼远离。于身毕竟不起。因尚不起。况堕恶趣。如人秋时服于下药。药虽不住彼人身中。而彼身中病亦不生。此亦如是。复有说者。由此善根势力威猛熏习身故。令招恶趣诸业烦恼。于此身中永不复起。因不起故不堕恶趣。如师子王所居窟穴。王虽不在余气尚存。诸小禽兽无能入者。此亦如是。复次此善根身中如主。势力强盛。不善如客势力衰微。复次此善根意乐增上。乐断恶法乐修善法。复次此善根身中生已一切恶趣得非择灭。非择灭法无有生者。是以不堕。复次由此善根身中生故。令彼行者堕大法流。由如此义不堕恶趣。复有说者。由此善根邻近圣道。依圣道力不堕恶趣。如怖怨贼依附于王。依王力故令诸怨贼不敢正视。况能为害。此亦如是。近圣道故令招恶趣诸业烦恼尚不现行。况堕恶趣。复有说者。由此善根守护圣者所住身器。义言此身圣道当住。能招恶趣诸业烦恼应永远离。如有胜处王应居止所。司守掌余无能住。此亦如是。复有说者。由此善根身中生。故令彼行者定处人天不居恶趣。如富贵者定居胜处不居卑陋。此亦如是。有说。此善根加行正胜。令招恶趣诸业烦恼势力衰微。不复能招恶趣异熟。是故虽舍不堕恶趣。有说。由此善根增上力故。令彼行者见恶行过失妙行功德。由此恶业必不复生。况堕恶趣。有说。由此善根增上力故。令彼行者住善意乐。见生死过涅槃胜德。不造恶业不堕恶趣。有说。由此善根增上力故。令彼行者其心调柔随顺涅槃信根深固。由此虽舍不堕恶趣。尊者妙音说曰。由此善根增上力故。令彼行者意乐殊胜。于般涅槃心常随顺趣向临入。欲乐忍可希求敬爱。由此因缘不造恶业。是故虽舍不堕恶趣。问何故异生命终时舍所得忍法。圣者不舍。答异生无有无漏对治。以自持御故此善根命终时舍。圣有无漏对治。以自持御。是故不舍。有说异生定力羸劣势不坚牢。以有漏故。如无胶水杂诸彩色随所画物。不得久住。是以故舍。圣者无漏定力坚强。持此善根命终不舍。所说譬喻翻上应知。有说。异生无胜止观故命终舍。圣者相违命终不舍。有余师说。异生命终亦不舍忍。问若尔此文及大种蕴何故不说。答应说而不说者。当知此义有余。有说。已说在第三句中。谓诸圣者住胎脏中成身及业。圣有二种。一世俗。二胜义。得此善根名世俗圣。若入圣道名胜义圣。发心出家尚名圣者。况得忍法。有余师说。此不决定异生命终有舍不舍。若于忍法恒时加行殷重。加行修习坚牢。彼命终时不舍忍法。若不尔者命终时舍。如所听习。若极淳熟经久不忘不尔便忘。如慈授子于初生时便能唱言。结有二部乃至广说。如是说者。异生命终定舍忍法。善根劣故异生依此地起此类善根。命终还生此地。舍同分故尚决定舍。况色界法经欲界生而当不舍

契经中说。生有四种。谓卵生。胎生。湿生。化生。云何卵生。谓诸有情由卵[穀-禾+卵]生。当住卵[穀-禾+卵]。已住今住卵[穀-禾+卵]。盛裹破坏卵[穀-禾+卵]生等生起现起出已出。谓鹅雁孔雀。鹦鹉舍利迦。俱枳罗命命鸟等。及一类龙。一类妙翅。一类人趣。复有所余由卵[穀-禾+卵]生。广说如上。是名卵生。云何胎生。谓诸有情由胎膜生。当住胎膜。已住今住胎膜。盛裹破坏胎膜生等。生起现起出已出。谓象马牛羊驼驴鹿等。及一类龙。一类妙翅。一类鬼。一类人趣。复有所余由胎膜生。广说如上。是名胎生。云何湿生。谓诸有情由湿气生。或依草木诸叶窟聚。或依腐肉食粪秽等。或依陂池河海展转相润相逼相依生等。生起现起出已出。谓蚊蚋蠛蠓。百足蚰蜒蚑行蜂等。及一类龙。一类妙翅。一类人趣。复有所余由湿气生。广说如上。是名湿生。云何化生。谓诸有情生无所托诸根无缺支体圆具依处顿生顿起顿出。谓诸地狱天趣。一切中有。及一类龙。一类妙翅。一类鬼。一类人趣。复有所余诸有情类生无所托。广说如上。是名化生。问欲界天中诸妙色鸟。为卵生为化生耶。若卵生者。彼命终已应有尸骸。是则诸天应见秽色。然诸天众于六处门常对妙境。如契经说。彼眼所见一切可爱适意平等。乃至意所知亦尔。若是化生。前化生中何故不说。答彼皆卵生。问若尔彼命终已应有尸骸。云何诸天见秽色耶。答彼命终未久有暴风飘举其尸远弃他处。有余师说。彼皆化生。问前化生中何故不说。答应说而不说者。当知此义有余。有说彼已摄在前所说一类妙翅鸟中。是以无过。问如是四生以何为自性。答四蕴五蕴以为自性。谓欲色界五蕴。无色界四蕴。此中有说。唯异熟蕴以为自性。有说亦通长养。是名四生自性。已说自性。所以今当说。问何故名生。答诸有情类和合而起故名为生。问三界五趣皆和合起。亦名为生。何独此四。答此四唯令有情数起。亦遍摄有情数。界趣不尔。以界虽遍有情数。而非但有情数起通非情故。趣虽但有情起。而非遍有情数。不摄中有故。由此但四说名为生。问生是何义。答有情现义是生义。有情起义有情出义。是生义

问于何界趣。有几生可得。答于欲界中四生可得。色无色界唯有化生。彼受生时无所托故。于五趣中天及地狱。唯有化生。有说。鬼趣亦唯化生。有说。鬼趣亦有胎生。如饿鬼女白目连曰

  我夜生五子　　随生皆自食
  昼生五亦然　　虽尽而无饱

傍生人趣皆具四生。人卵生者。昔于此洲有商人。入海得一雌鹤。形色伟丽奇而悦之。遂生二卵。于后卵开出二童子端正聪慧。年长出家。皆得阿罗汉果。小者名邬波世罗。大者名世罗。又如毗舍佉母生三十二卵。般遮罗王妃生五百卵等。人胎生者如今世人。湿生者。如曼驮多遮卢。邬波遮卢。鸽鬘庵罗卫等。人化生者。如劫初人。四生有情皆受生已。容得圣法。得圣法已。必更不受卵湿二生。问何故尔耶。答卵湿二生性多愚昧。圣者聪慧故不受彼生。有说。湿卵二生法尔与圣性相违故。圣者不受。有余师说。彼二生类多恶意乐多害意乐。圣者不尔。意乐唯善。有说。彼二生类多行恶戒沉溺苦海。圣者已得圣所爱戒坚固浮囊能越度彼。有说。卵湿二生是傍生类。圣者已得彼非择灭。有说。卵湿二生多相迫迮。圣者不尔。多宽太业。由如此义圣者不受彼二生类。有余师说。圣乐独处厌怖重生。而湿生者类多繁杂。诸卵生者类经再生。谓出母胎及出卵[穀-禾+卵]。故世间说梵志沙门。鸟名再生。象名再饮。是以圣者不受彼生。有余师说。卵湿二生多无依怙。圣者成就胜依怙法故不受彼生。由此有如是说。若庵罗卫有胜依怙则不应为摩健地迦之所陵辱。尊者妙音说曰。父所生趣子还生中。此说意言。如近佛地诸大菩萨。是众圣之父。彼定不受卵湿二生。得果圣子亦复如是。由此所说诸因缘故。圣必不受卵湿二生

问如是四生何者最广。有作是说。卵生最广如闻。外国诸山谷中。随所在处卵皆充满。象等践蹋都不觉知。有余师言。胎生最广。如闻。外国有一虾蟆生七畦子。一鱼游历七陂池中生子充满。有余师说。湿生最广。所以者何。若于雨际设有聚集腐肉粪等。下自金轮上至梵世。而彼一切悉可为虫。如是诸虫皆湿生摄。如是说者。化生最广。摄二趣全三趣少分。及一切中有皆化生故。又二界全一界少分皆化生故。于欲界中三生加行亦化生故。问如是四生何者最胜。答化生最胜。问若尔何故最后身菩萨不受化生。答二出世时不和合故。谓劫初时人受化生。尔时佛不出世。至劫减时佛出于世。尔时人无化生。复有说者。化生轻飘不堪与佛力无畏等。功德山王作依止故。复有说者。一切化生其身微弱。不能荷负阿耨多罗三藐三菩提之重担故。复有说者。若受化生。便无亲族眷属等事。而彼皆是妙业之果。菩萨长夜勤修妙业极圆满故不受化生。复有说者。菩萨长夜精进炽然造作增长感父母业。菩萨父母亦于长夜。修习感圣子业。若受化生则二所修俱空无果。是以不受。有说。欲显菩萨一切尊胜。所谓智见族姓位等。以是义故不受化生。有说。为断众生族姓慢故。依胜族姓不受化生。有说。欲摄引乐在家者令入法故不受化生。若受化生彼当说言。佛无亲属故毁家法岂比我等。若菩萨生刹帝利家宗亲强盛。而能厌舍如弃涕唾开甘露门成等正觉。则彼皆生希有之想。所说敬受。有说。菩萨欲为法幢作内外护故不受化生。诸佛皆有内护外护。内谓菩提分法。外谓亲属。若无外护当为外道恶党所坏故。佛世尊度诸释种以护正法。由此乃至六群苾刍亦言。若有外道来恼佛者。佛若不制我等亦能以力伏彼。有说。欲止外道谤故不受化生。谓佛亲从睹史多宫殁。身光赫奕照大千世界。入于母胎十月满已从母胎出。即行七步自称独尊。出家苦行诣菩提树成等正觉。尚被谤言过百劫后大幻当出无父无母食啖世间。若受化生便增诽谤。是故菩萨不受化生。有说。为欲饶益当来诸有情故不受化生。所以者何若受胎生便有遗身。般涅槃后虽越千载。无量有情乃至若能于遗身界。如芥子许起殷净心。恭敬供养获无边福。生天受乐得般涅槃。若受化生便无是事。所以者何。化生命终如灯光灭无遗余故。此中因论生论。问何故化生命终无遗余耶。答由彼生时诸根顿起。所以殁时亦复顿灭。如人戏水乍出乍没。复有说者。化身轻妙如云如电。亦如风焰灭已无余莫知方所。复次化生造色增。余三生大种增。由造色增故灭则顿灭。复次化生根法增。余三生非根法增。由根法增故灭则顿灭。谓化生者所受身形发爪等物无根法少。问若化生死无遗余者。何故经说化生妙翅鸟取化生龙为食耶。答以不知故取之为食。然不充饥。有说。彼龙未死之顷暂得充饥。死已还饥。饥复取食无违经过。复有说者。诸化生龙其身精妙。如酥油等才吞入腹便成食事。或有说者。化生妙翅鸟多诸巧便得化生龙。以足按颈从尾吞之。命未绝来能作食事。死则不尔。有余师说。彼妙翅鸟食化生龙时。涎液先流烂脑随下。与龙俱咽食事便成。非化生龙独成食事

问余经所说复云何通。如说。大地狱中。有黑驳狗肥壮暴恶。扑诸有情卧铁地上。掴裂其腹啖食肠肚。答由彼肠肚未离身来。暂得充饥故说为食。有说。由彼受罪有情恶业力故。但令受苦非作食事

若成就身彼成就语业耶。答应作四句。有成就身非语业。有成就语业非身。有成就身亦语业。有非成就身亦非语业。此皆如前身对身业中说。差别者此说语表。以身业语业系地有无必无别故。若成就身彼成就意业耶。答诸成就身。彼定成就意业。有成就意业非身。谓生无色界。若成就身彼成就身业语业耶。答有成就身非身业语业。谓处卵[穀-禾+卵]若诸异生住胎藏中。若生欲界住非律仪非不律仪。无身语表设有而失。有成就身及身业。非语业。谓生欲界住非律仪非不律仪。现有身表。或先有不失无语表设有而失。有成就身及语业。非身业。谓生欲界住非律仪非不律仪现有语表。或先有不失无身表设有而失。有成就身及身业语业。谓诸圣者住胎藏中。若生欲界住律仪。若住不律仪。若住非律仪非不律仪。现有身语表。或先有不失。若生色界设成就身业语业。彼成就身耶。答或成就。或不成就。云何成就。谓如前说。云何不成就。谓诸圣者生无色界。若成就身彼成就身业意业耶。答有成就身及意业。非身业。谓处卵[穀-禾+卵]。若诸异生住胎藏中。若生欲界住非律仪非不律仪无身表。设有而失。有成就身及身业意业。谓诸圣者住胎藏中。若生欲界住律仪。若住不律仪。若住非律仪非不律仪。现有身表。或先有不失。若生色界设成就身业意业。彼成就身耶。答或成就。或不成就。云何成就。谓如前说。云何不成就。谓诸圣者生无色界。若成就身。彼成就语业意业耶。答有成就身及意业。非语业。有成就身及语业意业。此皆如前身对身业意业中说。差别者。此说语表。设成就语业意业。彼成就身耶。答或成就。或不成就。亦如彼说。若成就身。彼成就身业语业意业耶。答有成就身及意业。非身业语业。有成就身及身业意业。非语业。有成就身及语业意业。非身业。有成就身。及身业语业意业。此皆如前身对身业语业中说。以意业一切时皆成就故。设成就身业语业意业。彼成就身耶。答或成就。或不成就。亦如彼说

若成就身业。彼成就语业耶。答应作四句。有成就身业非语业。谓生欲界住非律仪非不律仪现有身表。或先有不失。无语表。设有而失。有成就语业非身业。谓生欲界住非律仪非不律仪。现有语表。或先有不失。无身表。设有而失。有成就身业亦语业。谓诸圣者住胎藏中。若生欲界住律仪。若住不律仪。若住非律仪非不律仪。现有身语表。或先有不失。若生色界。若诸圣者生无色界。有非成就身业。亦非语业。谓处卵[穀-禾+卵]。若诸异生住胎藏中。若生欲界住非律仪非不律仪。无身语表。设有而失。若诸异生生无色界。若成就身业彼成就意业耶。答诸成就身业。彼成就意业。有成就意业非身业。谓处卵[穀-禾+卵]。若诸异生住胎藏中。若生欲界住非律仪非不律仪。无身表。设有而失。若诸异生生无色界。若成就身业。彼成就语业意业耶。答有成就身业及意业。非语业。谓生欲界住非律仪非不律仪。现有身表。或先有不失。无语表。设有而失。有成就身业及语业意业。谓诸圣者住胎藏中。若生欲界住律仪。若住不律仪。若住非律仪非不律仪。现有身语表。或先有不失。若生色界。若诸圣者生无色界。设成就语业意业。彼成就身业耶。答或成就。或不成就。云何成就。谓如前说。云何不成就。谓生欲界住非律仪非不律仪。现有语表。或先有不失。无身表。设有而失

若成就语业。彼成就意业耶。答诸成就语业。彼成就意业。有成就意业。非语业。此如前身业对意业说。差别者。此说语表。此上所说总略义者。所谓彼身若生无色界定不成就。生欲色界则定成就彼身业语业。若在卵[穀-禾+卵]异生。处胎藏中及诸异生生无色界定不成就。一切圣者。色界异生。及欲界异生。住善恶戒者皆定成就。余或成就。或不成就。意业一切皆定成就

说一切有部发智大毗婆沙论卷第一百二十阿毗达磨大毗婆沙论卷第一百二十一

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    业蕴第四中害生纳息第三之四

若业未离染。彼业异熟未离染耶。乃至广说。问何故作此论。答为止他宗显己义故。谓犊子部说五部业。所得异熟亦通五部。欲止彼意显业虽通五部而彼异熟唯修所断故作斯论。若业未离染。彼业异熟未离染耶。答诸业未离染。彼业异熟定未离染。或有业异熟未离染。彼业已离染。谓预流者见所断业已离染。彼业异熟未离染。应知此中或有业先离染。后异熟方离染。或有业与彼异熟俱时离染。必无异熟先得离染。后时彼业方得离染。谓四法忍时。令四部所摄诸不善业先得离染。非彼异熟。又离欲界染前八无间道时。令前八品修所断诸不善业先得离染。非彼异熟。彼诸异熟要至第九无间道时方得离染。是名业先离染。后彼异熟方得离染。若离欲界染第九无间道时。令第九品诸不善业。一切不善身业语业。欲界善业。及彼诸异熟俱时离染。离初静虑染第九无间道时。令初静虑业及彼异熟俱时离染。如是乃至离非想非非想处染。第九无间道时。令非想非非想处业。及彼异熟俱时离染。如是名为业与异熟俱时离染。以非色不善业。五部所摄亦九品道断。诸不善色业。有漏善业。一切异熟。唯修所断。唯上上品道断故。是名此处略毗婆沙。然此中依二业作论。谓见所断修所断故作是说。若依五业作论者。则不应言谓预流者见所断业。乃至广说。应作是说。谓未离欲染者。苦智已生集智未生。见苦所断业已离染。彼业异熟未离染。集智已生灭智未生。见苦集所断业已离染。彼业异熟未离染。灭智已生道智未生。见苦集灭所断业已离染。彼业异熟未离染。道智已生未离欲界染者。见苦集灭道所断业已离染。彼业异熟未离染。离欲界染一品。乃至八品时。彼八品业已离染。彼业异熟未离染。离欲界染第九无间道时。彼第九品业。一切不善身语业。欲界善业。及彼诸异熟俱时离染。离初静虑乃至非想非非想处染。第九无间道时。诸地善业及彼异熟俱时离染。而不作是说者。由依二业而作论故

若业已离染。彼业异熟已离染耶。答诸业异熟已离染。彼业定已离染。或有业已离染。彼业异熟未离染。谓预流者见所断业已离染。彼业异熟未离染。此中分别广如前说。若业有果。彼业皆有异熟耶。乃至广说。问何故作此论。答为止邪宗显正义故。谓有外道执一切善恶业无果异熟。为止彼意显一切业无不有果。诸有漏善及不善业皆有异熟故作斯论。然契经中说。果有五种。一等流果。二异熟果。三离系果。四士用果。五增上果。等流果者。谓善生善。不善生不善。无记生无记。异熟果者。谓诸不善有漏善法所招异熟因。是善恶果唯无记。异类而熟故立异熟名。离系果者。谓无间道断诸烦恼。此无间道。以烦恼等断为离系果。及士用果。以解脱道为等流果。及士用果。以后等胜自类诸道为等流果。若无间道。以能于先来诸烦恼断集得作证。此无间道以彼烦恼断。但为士用果。此则总说。若别说者。苦法智忍。以彼欲界见苦所断十随眠等断。为离系果。及士用果。以苦法智品为等流果。及士用果。以后等胜诸无漏道为等流果。如是乃至道类智忍。以色无色界。见道所断十四随眠等断为离系果。及士用果。以道类智品为等流果。及士用果。以后等胜诸无漏道为等流果。以三界见苦集灭所断。及欲界见道所断诸随眠等断集得作证。此道类忍。以彼诸断为士用果。诸预流者。于一来果求作证时。初五无间道。以彼五品随眠等断。为离系果及士用果。以五解脱道。为等流果及士用果。以后等胜自类诸道为等流果。第六无间道以第六品随眠等断。为离系果及士用果。以第六解脱道为等流果及士用果。以后等胜自类诸道为等流果。以三界见所断及欲界修所断。前五品随眠等断集得作证。此第六无间道。以彼诸断为士用果。诸一来者。于不还果求作证时。无间道起能断欲界修所断四随眠。若断第七及第八品。此无间道。以彼二品随眠等断。为离系果及士用果。以二解脱道为等流果及士用果。以后等胜自类诸道。为等流果。若断第九品一无间道。以第九品随眠等断。为离系果及士用果。以第九解脱道。为等流果及士用果。以后等胜自类诸道。为等流果。以三界见所断及欲界修所断前八品随眠等断集。得作证。此第九无间道。以彼诸断为士用果。诸不还者。于无学果求作证时。无间道起能断色无色界修所断六随眠。若断初静虑染一品。乃至九品。此九无间道。以彼九品随眠等断。为离系果及士用果。以九解脱道为等流果及士用果。以后等胜自类诸道为等流果。如是乃至离非想非非想处染。前八无间道。以彼八品随眠等断。为离系果及士用果。以八解脱道为等流果及士用果。以后等胜诸无漏道。为等流果。金刚喻定以第九品随眠等断。为离系果及士用果。以初尽智品为等流果及士用果。以后等胜诸无漏道。为等流果。以三界见所断及下八地修所断。并非想非非想处修所断。前八品随眠等断集。得作证。此金刚喻定以彼诸断为士用果。若诸异生离欲界乃至无所有处。见修所断染诸无间道。以彼诸断诸解脱道。及后等胜自类诸道。为果。多少如理应思。士用果者。若法由彼士用故成此法。说为彼士用果。增上果者。若法由彼增上所起。当知此法是彼增上及增上果。是余增上非增上果。谓后生诸法是前法增上。及增上果。前生诸法。是后法增上非增上果。未来诸法。是过现法增上。及增上果。过现诸法。是未来法增上非增上果。未来现在法。是过去法增上。及增上果。过去诸法。是未来现在法增上。非增上果。问士用果增上果何差别。答诸所作事。于能作者是士用果及增上果。于能受者唯增上果。如稼穑等所作诸事于农夫等是士用果。及增上果。于受用者唯增上果。士用力起名士用果。增上力起名增上果。增上力宽不障碍故。士用力狭能引证故。是名二果差别。西方诸师说果有九种。谓于前五更加四种。一安立果。二加行果。三和合果。四修习果。安立果者。谓依风轮安立水轮。复依水轮安立金轮。复依金轮安立大地。复依大地安立一切情非情数。此中后后是前前果。余安立果类此应知。加行果者。谓不净观。或持息念。为加行。故渐次引起尽无生智。余加行果类此应知。和合果者。谓眼色和合生眼识。乃至意法和合生意识。余和合果类此应知。修习果者。谓由色界道起欲界化。及欲界语。此化及语。是修习果。余修习果亦尔。迦湿弥罗国诸论师言。此中后四即前五摄。彼即士用增上果故

应知世俗对治道业。具由五果说名有果。彼加行解脱胜进道业。及余不善善有漏业。由四果故说名有果。除离系果。若诸无漏对治道业。亦由四果说名有果。除异熟果彼加行解脱胜进道业。及无记业。由三果故说名有果。除离系果及异熟果。是名此处略毗婆沙

若业有果彼业皆有异熟耶。答诸业有异熟。彼业皆有果。应知此业。或由五果。或由四果。说名有果。或有业有果。彼业无异熟。谓无记业。无漏业。应知此业或由四果。或由三果。说名有果。然无异熟不坚实故。无爱润故

若业无果彼业皆无异熟耶。答无有业无果。谓一切业或由五果。或由四果。或由三果。说有果故。或有业无异熟。谓无记业。无漏业。如前说。问若一切业皆有果者。佛所说颂当云何通。如说

  如花虽可爱　　有色而无香
  如是有妙语　　无果无所作

答依说法者佛说此颂。谓说法时彼听法者。不能信受如教奉行。名为无果。或说法者虽复善说。而不能行故言无果。或先有所言许施他物。后不能惠故言无果。问余经所说复云何通。如说

  有命乐惛眠　　空无果无义
  无味无胜利　　都无有出生

答有觉寤时能逮胜德。乐睡眠故虚越此时。世尊依彼说如是颂。问若乐睡眠空无果者。余经所说复云何通。如说。宁可睡眠勿余寻伺。答有觉寤时起恶寻伺。斗诤恼乱无量有情。佛为诫彼故作是说。由此义故经有别意。非谓诸业都无有果

若业不善彼业皆颠倒耶。答应作四句。有业不善彼业非颠倒。谓如有一见有因果。起如是见。立如是论。有业有业果异熟而行身语意恶行。问何因缘故彼行恶行。答三因缘故。一由时故。二由处故。三由补特伽罗故。由时故者。谓五浊增时诸有情类。威德损减喜造诸恶。在彼时故亦行恶行。由处故者。谓生达絮蔑戾车中诸有情类。其性愚鄙多造恶业。生彼处故亦行恶行。由补特伽罗故者。谓有一类得恶行众同分。其性犷暴多造恶业。如屠羊等诸不律仪。亲近彼故亦行恶行。应知此业由自性故说名不善。是身语意恶行摄故。由所依故名非颠倒。是有作见不愚因果。正见身中所等起故。如宝器中盛诸粪秽。有业颠倒彼业非不善。谓如有一见无因果。起如是见。立如是论。无业无业果异熟。而行身语意妙行。问何因缘故彼行妙行。答三因缘故。一由时故。二由处故。三由补特伽罗故。由时故者。谓五浊不增时。诸有情类具大威德。好修诸善在彼时故。虽不乐为亦行妙行。由处故者。谓生中国诸有情类。其性聪敏志意调柔。多修善业生彼处故。虽不乐为亦行妙行。由补特伽罗故者。谓有一类得妙行众同分。其性和雅多修善业。如住律仪亲近彼故。虽不乐为亦行妙行。应知此业由所依故说名颠倒。是无作见愚于因果。邪见身中所等起故。由自性故名非不善。是身语意妙行摄故。如秽器中盛诸珍宝。有业亦不善亦颠倒。谓如有一见无因果。起如是见。立如是论无业无业果异熟。复行身语意恶行。问何因缘故彼行恶行。答三因缘故如前说。应知此业由自性故说名不善。以身语意恶行摄故。由所依故复名颠倒。是无作见愚于因果。邪见身中等所起故。如秽器中盛诸粪秽。有业非不善非颠倒。谓如有一见有因果。起如是见。立如是论。有业有业果异熟。复行身语意妙行。问何因缘故彼行妙行。答三因缘故如前说。应知此业由自性故名非不善。以身语意妙行摄故。由所依故名非颠倒。是有作见不愚因果。正见身中等所起故。如宝器中盛诸珍宝

若业是善彼业不颠倒耶。答应作四句。谓前第二句作此第一句。前第一句作此第二句。前第四句作此第三句。前第三句作此第四句。广如前说。复次于此有异解释。若业不善彼业皆颠倒耶。答应作四句。有业不善彼业非颠倒。谓如有一于见有不见想。他问言汝见不。彼或自为。或为他。或为名利。便覆此想此忍此见此欲。答言。我见。应知此业由想力故名为不善。以覆想说故。由所说事名非颠倒。于见言见故。有业颠倒彼业非不善。谓如有一于见有不见想。他问言。汝见不。彼不自为。不为他。不为名利。不覆此想此忍此见此欲。答言。不见。应知此业由所说事名为颠倒。以于见言不见故。由想力故名非不善。以不覆想而说故。有业亦不善亦颠倒。谓如有一于见有见想。他问言。汝见不。彼或自为。或为他。或为名利。便覆此想此忍此见此欲。答言。不见应知此业由想力故名为不善。以覆想而说故由所说事复名颠倒。以于所见言不见故。有业非不善非颠倒。谓如有一于见有见想。他问言。汝见不彼不自为。不为他。不为名利。不覆此想此忍此见此欲。答言。我见。应知此业由想力故名非不善。以不覆想而说故。由所说事名非颠倒以于所见说言见故。如于所见作四句。如是于所闻觉知亦各作四句。如于所见闻觉知各作四句。如是于所不见闻觉知亦各作四句。如以不善对颠倒作八四句。如是以善对不颠倒应知亦尔。是则合成十六四句。及前二四句成十八四句。复总以不善九小四句。及善九小四句。各为一大四句。是故总别有二十四句

此中眼识所受名见。耳识所受名闻。三识所受名觉。意识所受名知。说四境故见闻觉知。是根非识然举识者显眼等根必由识助方能取境。以同分根能有作用非彼同分故。问何故眼等三识所受各立一种。而鼻舌身三识所受。合立一种名为觉耶。尊者世友说曰。三识所缘皆唯无记。境无记故根立觉名。又以三根唯取至境。与境合故立以觉名。大德说言。唯此三根境界钝昧犹如死尸。故发识时说名为觉。有余师言。眼耳二识依自界缘自他界。意识依自他界。缘自他界故彼所受各立一种。鼻等三识唯依自界唯缘自界。故彼所受合立一种。如自界他界同分不同分说亦尔。有余师言。眼耳二识依同分。缘同分不同分。意识依同分不同分。缘同分不同分。故彼所受各立一种。鼻等三种唯依同分。唯缘同分。故彼所受合立一种。此说界同分。有说。眼耳二识依无记缘三种。意识依三种缘三种。故彼所受各立一种。鼻等三识唯依无记唯缘无记。故彼所受合立一种。有说。眼耳二识依近缘近远。意识依近远缘近远。故彼所受各立一种。鼻等三识依近缘近。故彼所受合立一种。此三根境无间而住。方能发识故。名为近。有说。眼耳二识或所依大所缘小。或所缘大所依小。或所依所缘等。眼识所依大所缘小者。如见毛端等。所缘大所依小者如见山等。所依所缘等者。如见蒲桃果等。如是耳识如量应知。意识所依虽不可说其量大小。而所缘境或小或大。故彼所受各立一种。鼻等三识所依所缘大小量等故。彼所受合立一种。随所依根极微多少。与尔所境极微合时。方能发生鼻等识故。有说。眼等三识缘业非业。故彼所受各立一种。鼻等三识唯缘非业。故彼所受合立一种。有说。眼等三识。缘持戒犯戒及缘余法。故彼所受各立一种。鼻等三识唯缘余法。故彼所受合立一种。有余师言。眼等三识。通缘律仪不律仪及余法。故彼所受各立一种。鼻等三识唯缘余法。故彼所受合立一种。有说。眼等三识通缘表及余法。故彼所受各立一种。鼻等三识唯缘余法。故彼所受合立一种。有说。眼等三识通缘染不染法。故彼所受各立一种。鼻等三识唯缘不染。故彼所受合立一种。有说。眼等三识。通缘妙行恶行及缘余法。故彼所受各立一种。鼻等三识唯缘余法。故彼所受合立一种。由此所说见闻觉知。随识依缘有别有总。若成就不善业。彼成就色无色界系业耶。答诸成就不善业。彼定成就色无色界系业。谓生欲界若断善根。彼定成就不善业。及色无色界系一业。谓染污业。不断善根未得色界善心者亦尔。若已得色界善心。未离欲界染。彼成就不善业。及色界系二业。谓善染污。无色界系一业。谓染污。有成就色无色界系业非不善业。谓生欲界已离欲界染。若生色界。谓生欲界已离欲界染。若未得无色界善心。彼成就色界系三业。谓善染污无覆无记。无色界系一业。谓染污。若已得无色界善心。未离色界染。彼成就色界系三业。谓善染污无覆无记。无色界系二业。谓善染污。若已离色界染。未离无色界染。彼成就色界系二业。谓善无覆无记。无色界系二业。谓善染污。若已离无色界染。彼成就色界系二业。谓善无覆无记。无色界系一业。谓善。若生色界者。谓若未得无色界善心。彼成就色界系三业。谓善染污无覆无记。无色界系一业。谓染污。若已得无色界善心。未离色界染。彼成就色界系三业。谓善染污无覆无记。无色界系二业。谓善染污。若已离色界染。未离无色界染。彼成就色界系二业。谓善无覆无记。无色界系二业。谓善染污。若已离无色界染。彼成就色界系二业。谓善无覆无记。无色界系一业。谓善。若成就欲界系善业。彼成就色无色界系业耶。答诸成就欲界系善业。彼定成就色无色界系业。有成就色无色界系业。非欲界系善业。谓断善根补特伽罗。若生色界。谓若成就欲界善业。未得色界善心。彼成就色无色界系一业。若已得色界善心。未离欲界染。彼成就色界系二业。无色界系一业。若已离欲界染。未得无色界善心。彼成就色界系三业。无色界系一业。若已得无色界善心。未离色界染。彼成就色界系三业。无色界系二业。若已离色界染。未离无色界染。彼成就色界系二业。及成就无色界系二业。若已离无色界染。彼成就色界系二业。及成就无色界系一业。若断善根。彼成就色无色界系一业。若生色界未得无色界善心。彼成就色界系三业。无色界系一业。若已得无色界善心。未离色界染。彼成就色界系三业。无色界系二业。若已离色界染。未离无色界染。彼成就色界系二业。无色界系二业。若已离无色界染。彼成就色界系二业。无色界系一业。前断善根。此生色界俱不成就。欲界系善业已断善根故。已舍彼善故。若成就欲界系善业。彼成就色无色界系善业耶。答应作四句。有成就欲界系善业。非色无色界系善业。谓生欲界不断善根。未得色界善心。有成就色无色界系善业。非欲界系善业。谓生色界得无色界善心。有成就欲界系善业。亦色无色界系善业。谓生欲界得无色界善心。有非成就欲界系善业。亦非色无色界系善业。谓断善根补特伽罗。若成就欲界系业。彼成就色界系业耶。答如是。设成就色界系业。彼成就欲界系业耶。答如是。谓生欲界若断善根。彼成就欲界系二业。色界系一业。若不断善。而未得色界善心。彼成就欲界系三业。色界系一业。若已得色界善心。未离欲界染。彼成就欲界系三业。色界系二业。若已离欲界染。未离色界染。彼成就欲界系二业。色界系三业若已离色界染。彼成就欲界系二业。色界系二业。若生色界未离色界染。彼成就欲界系一业。色界系三业。若已离色界染。彼成就欲界系一业。色界系二业

若成就欲界系业。彼成就无色界系业耶。答诸成就欲界系业。彼成就无色界系业。谓生欲界若断善根。彼成就欲界系二业。无色界系一业。若不断善根。未离欲界染。彼成就欲界系三业。无色界系一业。若已离欲界染。未得无色界善心。彼成就欲界系二业。无色界系一业。若已得无色界善心。未离无色界染。彼成就欲界系二业。无色界系二业。若已离无色界染。彼成就欲界系二业。无色界系一业。若生色界未得无色界善心。彼成就欲界系一业。无色界系一业。若已得无色界善心。未离无色界染。彼成就欲界系一业。无色界系二业。若已离无色界染。彼成就欲界系一业。无色界系一业。有成就无色界系业。非欲界系业。谓生无色界补特伽罗。谓生彼界。若未离彼界染。起异熟生心。彼成就无色界系三业。若不起异熟生心。彼成就无色界系二业。若已离无色界染。起异熟生心。彼成就无色界系二业。若不起异熟生心。彼成就无色界系一业。俱不成就欲界系业。已舍彼故。若成就欲界系业。彼成就不系业耶。答应作四句。有成就欲界系业。非不系业。谓诸异生生欲色界。有成就不系业。非欲界系业。谓诸圣者生无色界。有成就欲界系业。亦不系业。谓诸圣者生欲色界。有非成就欲界系业。亦非不系业。谓诸异生生无色界

若成就色界系业。彼成就无色界系业耶。答诸成就色界系业。彼定成就无色界系业。谓生欲界若未得色界善心。彼成就色界系一业。无色界系一业。若已得色界善心。未离欲界染。彼成就色界系二业。无色界系一业。若已离欲界染。未得无色界善心。彼成就色界系三业。无色界系一业。若已得无色界善心。未离色界染。彼成就色界系三业。无色界系二业。若已离色界染。未离无色界染。彼成就色界系二业。无色界系二业。若已离无色界染。彼成就色界系二业。无色界系一业。若生色界未得无色界善心。彼成就色界系三业。无色界系一业。若已得无色界善心。未离色界染。彼成就色界系三业。无色界系二业。若已离色界染。未离无色界染。彼成就色界系二业。无色界系二业。若已离无色界染。彼成就色界系二业。无色界系一业。有成就无色界系业。非色界系业。谓诸有情生无色界。谓生彼界若未离无色界染。起异熟生心。彼成就无色界系三业。若不起异熟生心。彼成就无色界系二业。若已离无色界染。起异熟生心。彼成就无色界系二业。若不起异熟生心。彼成就无色界系一业

若成就色界系业。彼成就不系业耶。答应作四句。有成就色界系业。非不系业。谓诸异生生欲色界。有成就不系业。非色界系业。谓诸圣者。生无色界。有成就色界系业。亦不系业。谓诸圣者。生欲色界。有非成就色界系业。亦非不系业。谓诸异生生无色界

若成就无色界系业。彼成就不系业耶。答诸成就不系业。彼定成就无色界系业。谓诸圣者生欲色界。若未得无色界善心。彼成就不系学业。无色界系一业。若已得无色界善心。未离无色界染。彼成就不系学业。无色界系二业。若已离无色界染。彼成就不系无学业。无色界系一业。若诸圣者生无色界。未离无色界染。起异熟生心。彼成就不系学业。无色界系三业。若不起异熟生心。彼成就不系学业。无色界系二业。若已离无色界染。起异熟生心。彼成就不系无学业。无色界系二业。若不起异熟生心。彼成就不系无学业。无色界系一业。有成就无色界系业。非不系业。谓诸异生若生欲色界。未得无色界善心。彼成就无色界系一业。若已得无色界善心。彼成就无色界系二业。若诸异生生无色界。若起异熟生心。彼成就无色界系三业。若不起异熟生心。彼成就无色界系二业。若成就欲界色界无色界系不系业。彼命终生何处。答或欲界。或色界。或无色界。或无生处。谓诸圣者若生欲界。未离欲界染。彼成就欲界系三业。色界系二业。无色界系一业。不系学业。彼命终生欲界。若已离欲界染。未得无色界善心。彼成就欲界系二业。色界系三业。无色界系一业。不系学业。彼命终生色界。若已得无色界善心。未离色界染。彼成就欲界系二业。色界系三业。无色界系二业。不系学业。彼命终亦生色界。若已离色界染。未离无色界染。彼成就欲界系二业。色界系二业。无色界系二业。不系学业。彼命终生无色界。若已离无色界染。彼成就欲界系二业。色界系二业。无色界系一业。不系无学业。彼命终无生处若诸圣者生色界。未得无色界善心。彼成就欲界系一业。色界系三业。无色界系一业。不系学业。彼命终生色界。若已得无色界善心。未离色界染彼成就欲界系一业。色界系三业。无色界系二业。不系学业。彼命终亦生色界。若已离色界染。未离无色界染。彼成就欲界系一业。色界系二业。无色界系一业。不系学业。彼命终生无色界。若已离无色界染。彼成就欲界系一业。色界系一业。无色界系一业。不系无学业。彼命终无生处。由此故说成就四业者彼命终。或生欲界。或生色界。或生无色界。或无生处

说一切有部发智大毗婆沙论卷第一百二十一阿毗达磨大毗婆沙论卷第一百二十二

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    业蕴第四中表无表纳息第四之一

若成就身表。彼成就此无表耶。如是等章。及解章义。既领会已。次应广释。问何故作此论。答为止他宗显己义故。谓譬喻者。说表无表业无实体性所以者何。若表业是实可得依之令无表有。然表业无实。云何能发无表令有。且表业尚无无表云何有而言有者。是对法诸师矫妄言耳。如人遇见美女为染近故。语言。汝可解去人服。吾衣汝天衣。女闻欢喜如言为解。彼人即前种种摩触。恣心意已语言。天衣已为汝着。女言。我今体露如是。宁死不露天衣何在。彼答之言。天服微妙唯我见之非汝能见。如是愚人本无天衣。况为他着。诸对法者所说亦尔。本无表业。况有依表所起无表。故对法者妄兴此论。又表无表若是色者。青黄赤白为是何耶。复云何成善不善性。若因摇动成善恶性。花剑等动何故不尔。为止如是譬喻者意。显自所宗。表无表业皆是实有。故作斯论。若诸表业无实体者。则与契经相违。如契经言。愚夫希欲说名为爱。爱所发表说名为业。又契经言。在夜寻伺犹如起烟。旦动身语犹如发焰。若无表业无实体者。则亦与契经相违。如契经说。色有三摄一切色。有色有见有对。有色无见有对。有色无见无对。若无无表色者。则应无有三种建立。无第三故。又若拨无表无表色。吠题呬字。未生怨王。应当不触害父无间。谓发表位父命犹存。父命终时表业已谢。由先表力得后无表故。未生怨触无间业。又彼杖髻出家外道。亦应不触害应无间。谓发表位目连命犹存。目连涅槃时表业已谢由先表力得后无表故。彼外道触无间业。又若拨无表无表业。应无建立三品有异。谓住律仪品。住不律仪品。住非律仪非不律仪品。然彼所言此表无表体。若是色青黄赤白为是何耶。此责不然非显色外无别色故。当知身表是形非显。语表是声亦非显色二种。无表法处色摄故不可责以同青等。然诸色处总有四种。一有色处唯显可了非形。二有色处唯形可了非显。三有色处显形俱可了。四有色处显形俱不可了。显可了非形者。谓青黄赤白影光明闇。形可了非显者。谓身表色。显形俱可了者。谓所余若显若形俱可了色显形俱不可了者。谓空界色。又如所说。若身摇动成善恶性。花剑等动何不尔者。此亦不然。有根法异。无根法异。身是有情数摄。由心运动能表有善恶心心所法。花剑等不尔故。表无表决定实有。然表无表依身而起有依一分。如弹指举足等。一分动转作善恶业有依具分。如礼佛逐怨等。举身运动作善恶业。此中随所依身。极微数量表业亦尔。如表数量无表亦尔。问随彼彼业若有表即有无表耶。若有无表即有表耶。或有说者。七根本业道决定具有表与无表。加行后起表业定有无表不定。唯猛利缠。及殷重信。所作发无表非余。有说。七根本业道无表定有表则不定。若自作者有表若遣他作唯得无表。加行后起如前说。评曰。应作是说。除欲邪行余根本业道。无表定有表则不定。若自作即时究竟者彼有表业。若遣他作或究竟时。表已息者则唯有无表。若欲邪行表亦定有加行位决定有表。无表不定如前说。后起位定有无表。表则不定若作则有。不作则无。当知此说散心所作。若随支分定散差别。有表无表如理应思

彼非律仪非不律仪所摄。妙行恶行由三因缘无表不断。一由意乐不息。二由加行不舍。三由限势未过。由意乐不息加行不舍者。如于佛像窣堵波等。起淳净心恭敬供养。所发无表从初刹那乃至意乐未息。或加行未舍已来相续不断。若意乐息及加行舍无表便断。限势未过者。谓淳净心及猛利缠所作善恶。随彼势力无表不断。如猛利缠杀捃多蚁。所发无表尽形相续。淳净心所作亦尔。谓如有人起殷重信。修营供具奉施众僧。烧香散花种种供养。或于佛说如是日月五年会等。请诸众僧种种供养。起淳净心发身语业。乃至意乐未息。或加行未舍无表不断。若意乐息及舍加行无表便断。余处中行广说亦尔。复有处中妙行恶行。尽众同分无表不断。妙行者。如有立愿。若不供养诸佛形像窣堵波等终不先食。彼于日日随力所能。下至一花一香供养。尽众同分无表不断。或有立愿。若不施他资具命缘。终不先食。彼于日日随力所能。下至施他一抟之食半搩手衣。尽众同分无表不断。或有立愿。若于三宝不先供养。终不先食。彼于日日随力所能。下至施僧一器之食。或复涂扫一足之地。尽众同分无表不断。或有立愿每年某日施诸贫乏。或供养僧。即取少物以供彼用。留所余财以为储拟。尽众同分无表不断。如是等是名妙行。恶行者。如有立愿。我当日日于彼怨所作诸衰损。若不作者终不先食。即于日日下至一打或一恶言诃骂毁辱。尽众同分无表不断。如是等是名恶行

或有造作诸佛形像窣堵波等诸供养具。书写三藏所摄正法。造圣僧像建僧伽蓝。给施衣药诸资身具。安立福舍种殖树林。造井桥船阶道处等。此诸表业所发无表。具由三缘相续不断。一由意乐。二由所依。三由事物。由意乐者。谓缘彼事深生欢喜意乐不息。由所依者。谓所依身同分相续命未终位。由事物者。谓所修建佛像等事未都坏灭。如是三缘随阙一种。由前所发无表便断。是名妙行。恶行者。谓造罟网刀箭等事。应准前说。是谓所说表无表业略毗婆沙

若成就身表。彼成就此无表耶。答应作四句。有成就身表非此无表。谓生欲界住非律仪非不律仪。现有身表不得此无表。或先有身表不失不得此无表。现有身表者。谓不眠不醉不闷不舍加行求起身表。不得此无表者。谓非殷重信。非猛利缠。虽发身表不得此无表。或先有身表不失者。谓三缘故不舍表业。一意乐不息故。二不舍加行故。三限势未过故。不得此无表者。义如前说。有成就身无表非此表。谓诸圣者住胎藏中。若生欲界住律仪不得别解脱律仪无身表。设有而失。若生色界无身表。设有而失。若诸圣者生无色界。此中圣者住胎藏时不能起表。前生表业已失。但成就静虑无漏无表。住律仪者。谓住静虑无漏律仪。无身表者。谓或眠或醉或闷。舍诸加行不求起表。故设有而失者。谓由三缘舍身表业。一意乐息故。二舍加行故。三限势过故。若生色界无身表者。谓舍加行不求起表故。设有而失者如前说。若诸圣者生无色界者。学成就学无表。无学成就无学无表。有成就身表亦此无表。谓生欲界住律仪。不得别解脱律仪。现有身表亦得此无表。或先有此表不失。亦得此无表。若住别解脱律仪。若住不律仪。若住非律仪非不律仪。现有身表亦得此无表。或先有身表不失亦得此无表。若生色界现有身表。或先有身表不失。此中现有身表亦得此无表等者。谓以殷重信。或猛利缠。发表亦得无表。若住别解脱律仪若住不律仪。彼定成就身表无表。若生色界现有身表者。谓不舍加行求起表业。余如前说。有非成就身表。亦非此无表。谓处卵[穀-禾+卵]。若诸异生住胎藏中。若生欲界住非律仪非不律仪。无身表设有而失。若诸异生生无色界。诸异生类住胎卵中。已失前生表无表业现不能起。如前应知。生无色界已舍有漏未得无漏。彼地无色故余如前说。若成就善身表。彼成就此无表耶。答应作四句。有成就善身表。非此无表。谓生欲界住不律仪。及住非律仪非不律仪。现有善身表。不得此无表。或先有此表不失。不得此无表现有善身表者。谓不眠等故。不得此无表者。谓非殷重信所起故。或先有此表不失者。谓前说三缘故。不得此无表者。谓彼亦非殷重信所起故。问住不律仪者。有何善身表。答彼亦于父母师长佛独觉诸佛弟子等。供养恭敬起善表故。有成就善身无表非此表。谓诸圣者住胎藏中。若生欲界住律仪不得别解脱律仪。无善身表。设有而失。若生色界无善身表。设有而失。若诸圣者生无色界。此中住律仪者。谓住静虑无漏律仪。不得别解脱律仪者。谓住此律仪定成就善身无表故。余如前说。有成就善身表亦此无表。谓生欲界住律仪。不得别解脱律仪。现有善身表亦得此无表。或先有此表不失亦得此无表。若住别解脱律仪。若住不律仪。及住非律仪非不律仪。现有善身表亦得此无表。或先有此表不失。亦得此无表。若生色界现有善身表。或先有此表不失。此中一切义如前说。有非成就善身表。亦非此无表。谓处卵[穀-禾+卵]。若诸异生住胎藏中。若生欲界住不律仪。及住非律仪非不律仪。无善身表。设有而失。若诸异生生无色界

若成就不善身表。彼成就此无表耶。答诸成就不善身无表。彼定成就此表。有成就不善身表。非此无表。谓生欲界住律仪。及住非律仪非不律仪。现有不善身表。不得此无表。或先有此表不失。不得此无表。现有不善身表者。谓不眠等故。不得此无表者。谓非猛利缠所起故。先有此表不失者。谓前说三缘。余如前说。问住何等律仪有不善身表。答住三律仪皆容得有。问住静虑无漏律仪者。有何等不善身表。答有。于有情起捶打等不善身表。问亦应有成就不善身无表非身表。谓遣他杀等。是则此中应作四句。何故作顺后句耶。有作是说。应作四句。有成就不善身表。非此无表。谓生欲界住律仪。及住非律仪非不律仪。现有不善身表。不得此无表。或先有此表不失。不得此无表。有成就不善身无表。非此表。谓生欲界住律仪。及住非律仪非不律仪。遣他杀等。有成就不善身表。及此无表。谓生欲界住不律仪。若住律仪。及住非律仪非不律仪。现有不善身表。亦得此无表。或先有此表不失。亦得此无表。有非成就不善身表。亦非此无表。谓处卵[穀-禾+卵]。若诸异生住胎藏中。若生欲界住律仪。及住非律仪非不律仪。无不善身表。设有而失。不得此无表。若生色无色界应作是说。而不说者。应知此文但依同类表无表说。不依异类。谓从身表发身无表。是名同类。若由语表发身无表。是名异类。应作是说。无有唯成就不善身无表者。故此但应作顺后句。所以者何。若能发语遣他杀等。由此发得身无表者。必亦成就不善身表。以必能动身手等故。若不尔者前说成就善身无表非此表中。亦应作是说。若住不律仪。及住非律仪非不律仪。以善语言遣他施等。由此发得善身无表。前于善中既无此说。故知发言遣他施等。由此发得身无表者。必亦能动身手等故。由此成就善身表业。是故二处皆无此说。若成就有覆无记身表。彼成就此无表耶。答无成就有覆无记身无表。有成就此表。谓生色界现有有覆无记身表。问何故欲界无有覆无记身表耶。答欲界烦恼能为等起。发身语者皆是不善。唯萨迦耶见。及边执见。彼相应无明。虽是有覆无记。而皆是见所断。非见所断心能发身语业。以内门起极微细故。问若生欲界已离欲界染。起初静虑烦恼现前。何故不发有覆无记身语表业。答生欲界中唯能起彼等至烦恼非生烦恼。诸烦恼中发身语业唯生烦恼。有余师说。法性应尔。若起此地烦恼现前。还能转动此地异熟相续。发起此地表业。诸染污业必以自地异熟相续为所依止。非生欲界容有色界异熟相续。是故唯生色界初静虑中。得起此有覆无记身语表业

若成就无覆无记身表。彼成就此无表耶。答无成就无覆无记身无表有成就此表。谓生欲色界现有无覆无记身表。于中差别如理应知

若成就过去身表。彼成就此无表耶。答应作四句。有成就过去身表。非此无表。谓生欲界住非律仪非不律仪。先有身表不失。不得此无表。先有身表不失者。谓三缘故如前所说。不得此无表者。谓非殷重信。及猛利缠所等起故。有成就过去身无表非此表。谓诸圣者住胎藏中。若生欲界住律仪。不得别解脱律仪。先无身表设有而失。若生色界先无身表。设有而失。若诸学者生无色界无身表等。准前应知。问若诸学者以世俗道得不还果。曾不现起无漏律仪便生无色。彼云何成就过去身无表业。若不成就。何故此文作如是说。若诸学者生无色界耶。有作是说。亦有学者生无色界。不成就过去身无表业。然此文中但依成就者说。是以无过。有余师说。得圣果已必起胜果圣道现前故。诸学者生无色界必定成就过去身无表业。有成就过去身表亦此无表。谓生欲界住律仪。不得别解脱律仪。先有身表不失亦得此无表。若住别解脱律仪。若住不律仪。若住非律仪非不律仪。先有身表不失亦得此无表。若生色界先有身表不失。此中若住别解脱律仪。若住不律仪者有说。此文唯说第二刹那以后。初刹那顷。未有过去表无表故。有作是说。即初刹那亦成就过去表无表业。前加行业彼成就故。有非成就过去身表。亦非此无表。谓处卵[穀-禾+卵]。若诸异生住胎藏中。若生欲界住非律仪非不律仪。先无身表设有而失。若阿罗汉及诸异生生无色界

若成就过去善身表。彼成就此无表耶。答应作四句。有成就过去善身表非此无表。谓生欲界住不律仪。及住非律仪非不律仪。先有善身表不失。不得此无表。有成就过去善身无表非此表。谓诸圣者住胎藏中。若生欲界住律仪。不得别解脱律仪。先无善身表设有而失。若生色界先无善身表设有而失。若诸学者生无色界。有成就过去善身表亦此无表。谓生欲界住律仪不得别解脱律仪。先有善身表不失。亦得此无表。若住别解脱律仪。若住不律仪。及住非律仪非不律仪。先有善身表不失。亦得此无表。若生色界先有善身表不失。若住别解脱律仪者。此中二说如前应知。问生色界者。云何成就过去善身表。答如佛一时往至梵世。梵众诸天礼拜旋绕。乃至彼加行未舍以来。成就过去善身表业。有非成就过去善身表亦非此无表。谓处卵[穀-禾+卵]。若诸异生住胎藏中。若生欲界住不律仪。及住非律仪非不律仪。先无善身表设有而失。若阿罗汉及诸异生。生无色界

若成就过去不善身表。彼成就此无表耶。答诸成就过去不善身无表。彼成就此表。有成就过去不善身表非此无表。谓生欲界住律仪。及住非律仪非不律仪。先有不善身表不失。不得此无表。此中二说如前应知

若成就过去有覆无记身表。彼成就此无表耶。答无成就过去有覆无记身表及此无表。若成就过去无覆无记身表彼成就此无表耶。答无成就过去无覆无记身表及此无表

若成就未来身表。彼成就此无表耶。答无成就未来身表。有成就此无表。谓诸圣者住胎藏中。生欲界已得色界善心。若生色界若诸圣者生无色界。问何故无有成就未来身语表业。答无有预造未来表业非已生故。若成就未来身语表业。应未造业而有受用。何故成就未来无表。彼与心俱随心修故

若成就未来善身表。彼成就此无表耶。答无成就未来善身表。有成就此无表。谓诸圣者住胎藏中。若生欲界已得色界善心。若生色界。若诸圣者生无色界

若成就未来不善身表。彼成就此无表耶。答无成就未来不善身表及此无表

若成就未来有覆无记身表。彼成就此无表耶。答无成就未来有覆无记身表及此无表

若成就未来无覆无记身表。彼成就此无表耶。答无成就未来无覆无记身表及此无表。问何故无有成就去来有覆无覆无记表业。答彼成就得势力唯尔。但能成就同刹那业。无力能成已灭未至。彼业过去得亦过去。彼业未来得亦未来。彼业现在得亦现在。有说。彼业习气不坚牢故。无成就去来世者。如善恶业习气坚牢。则能成就去来二世。无记不尔

若成就现在身表。彼成就此无表耶。答应作四句。有成就现在身表。非此无表。谓生欲界住律仪。不得别解脱律仪。现有身表不得此无表。设先有身表不失。而不得此无表。若住非律仪非不律仪现有身表不得此无表。设先有身表不失。而不得此无表。若生色界现有身表。此中生欲界住律仪者。谓住静虑无漏律仪。现有身表者。即显尔时心不在定及不眠等。不得此无表者。显过现表非殷重信非猛利缠。所等起故。不发无表故。现在无有成就现在身无表非此表。谓生欲界住律仪。不得别解脱律仪。正在定设不在定。现无身表。先有身表不失得此无表。若住别解脱律仪及住不律仪现无身表。若住非律仪非不律仪现无身表。先有身表不失得此无表。若生色界正在定。此中正在定者。显有无表亦遮有表。得此无表者。显有过去身表。所发身无表业现在随转。若住别解脱律仪。及住不律仪。现无身表者。有作是说。此说第二刹那以后。彼初刹那必有表故。有作是说。彼初刹那亦是所说有。现无身表。受不律仪故。及在定中得具戒故。有成就现在身表亦此无表。谓生欲界住律仪。不得别解脱律仪。现有身表亦得此无表。或先有身表不失。得此无表。若住别解脱律仪。及住不律仪。现有身表。若住非律仪非不律仪。现有身表亦得此无表。或先有身表不失。得此无表。此中若住别解脱律仪。及住不律仪。现有身表者。有作是说。唯取初刹那以后。诸刹那无身表故。有说。亦取诸余刹那。后位身表亦容起故。有非成就现在身表亦非此无表。谓处卵[穀-禾+卵]及住胎藏中。若生欲界住律仪。不得别解脱律仪。不在定现无身表。设先有身表不失而不得此无表。若住非律仪非不律仪现无身表。设先有身表不失。而不得此无表。若生色界不在定现无身表。若生无色界。此中不在定者。显不成就现在无表。余如前说。若成就现在善身表。彼成就此无表耶。答应作四句。有成就现在善身表非此无表。谓生欲界住律仪。不得别解脱律仪。现有善身表。不得此无表。设先有善身表不失。而不得此无表。若住不律仪。及住非律仪非不律仪。现有善身表。不得此无表。设先有善身表不失。而不得此无表。若生色界现有善身表。此中若生色界现有善身表者。必不成就现在无表。以必不在定故。余如前说。有成就现在善身无表非此表。谓生欲界住律仪。不得别解脱律仪。正在定设不在定现无善身表。先有善身表不失而得此无表。若住别解脱律仪现无善身表。若住不律仪。及住非律仪非不律仪。现无善身表。先有善身表不失而得此无表。若生色界正在定。若住别解脱律仪。现无善身表者。有作是说。此说第二刹那以后。有作是说。通初刹那如前说故

有成就现在善身表亦此无表。谓生欲界住律仪。不得别解脱律仪。现有善身表亦得此无表。先有善身表不失。得此无表。若住别解脱律仪。现有善身表。若住不律仪。及住非律仪非不律仪。现有善身表。亦得此无表。先有善身表不失得此无表。有非成就现在善身表。亦非此无表。谓处卵[穀-禾+卵]。及住胎藏中。若生欲界住律仪。不得别解脱律仪不在定。现无善身表。设先有善身表不失。而不得此无表。若住不律仪。及住非律仪非不律仪。现无善身表。设先有善身表不失。而不得此无表。若生色界不在定。现无善身表。若生无色界。若成就现在不善身表。彼成就此无表耶。答应作四句。有成就现在不善身表非此无表。谓生欲界住律仪。及住非律仪非不律仪。现有不善身表。不得此无表。设先有不善身表不失而不得此无表。住律仪者。谓住三种律仪。不得此无表者。非猛利缠所等起故。余皆如前说。有成就现在不善身无表非此表。谓生欲界住不律仪。现无不善身表。若住律仪。及住非律仪非不律仪。现无不善身表。先有不善身表不失。得此无表。住不律仪现无不善身表者。有作是说。除初刹那。有说通初。有但由语发身不律仪故

有成就现在不善身表亦此无表。谓生欲界住律仪。及住非律仪非不律仪。现有不善身表。亦得此无表。先有不善身表不失得此无表。若住不律仪。现有不善身表。皆如前说。有非成就现在不善身表。亦非此无表。谓处卵[穀-禾+卵]。若住胎藏中。若生欲界住律仪。及住非律仪非不律仪。现无不善身表。设先有不善身表不失而不得此无表。若生色无色界皆如前说

若成就现在有覆无记身表。彼成就此无表耶。答无成就现在有覆无记身无表。有成就此表。谓生色界现有有覆无记身表若成就现在无覆无记身表。彼成就此无表耶。答无成就现在无覆无记身无表。有成就此表。谓生欲色界现有无覆无记身表。如前广说。身表无表。如是语表无表。广说亦尔。但说语声与前有异此中所说决定义者。欲界必无随心转无表。色界必无依表发无表。问何故尔耶。答法应尔故。复有说者。欲界中有依表发无表。是故必无随心转无表。色界中有随心转无表。是故必无依表发无表。复有说者。欲界表业能发无表。是故必无随心转无表。色界表业不发无表。是故得有随心无表。复有说者。欲界生得能发业心殷重猛利故。所发表能发无表。色界生得能发业心非殷重猛利故。所发表不能发无表。复有说者。若生欲界无定心故。不定心胜故。所发表能发无表。若生色界有定心故。不定心劣故。所发表不能发无表。以如是等诸因缘故。色界必无依表无表。欲界定无随心无表

问随语响声是语业不。答彼非语业但名语声由语起故。问箫笛等声是语业不。答彼非语业但名语声。由风气等所起故。问诸禽兽声是语业不。有作是说。彼非语业但名语声。闻彼不能解了义故。有余师说。彼是语业人虽不了彼所说义。而彼同类互相领解。又如解禽兽语者。闻彼音声知所说故。问诸化语是语业不。有作是说。彼是语业由心发故。有余师说。彼非语业但名语声。以所化身无执受故若业欲界系彼业果欲界系耶。乃至广说。应知此中依四果作论除增上果。以增上果不决定故极宽漫故。谓生一一界各有三界果及四界业。一一各以四界诸法为增上果。若业欲界系。彼业果欲界系耶。答诸业欲界系彼业果亦尔。谓三果或二果。有业果欲界系非彼业。谓由色界道作欲界化发欲界语。此化及语是色界道士用果。若业色界系彼业果色界系耶。答诸业果色界系彼业亦尔。谓三果或二果有业色界系非彼业果。谓由色界道作欲界化发欲界语。此化及语是色界道士用果。及由色界道证诸结断。即诸静虑近分世俗道。彼诸断是此道。离系果士用果。约地分别准前应知。若业无色界系。彼业果无色界系耶。答诸业果无色界系彼业亦尔。谓三果或二果有业无色界系非彼业果。谓由无色界道证诸结断。即诸无色近分道。彼诸断是此道离系果士用果。约地分别准前应知。若业不系彼业果不系耶。答诸业不系彼业果亦尔。谓三果或二果有业果不系非彼业。谓由色无色界道证诸结断。即诸近分世俗道彼诸断。是此道离系果士用果。约地分别准前应知。若业非欲界系。彼业果非欲界系耶。答诸业果非欲界系彼业亦尔。有业非欲界系非彼业果。谓由色界道作欲界化发欲界语。此化及语是色界道士用果。若业非色界系彼业果非色界系耶。答诸业非色界系彼业果亦尔。有业果非色界系非彼业。谓由色界道作欲界化发欲界语。此化及语是色界道士用果。及由色界道证诸结断。彼诸断是此道离系果士用果。约地分别准前应知。若业非无色界系。彼业果非无色界系耶。答诸业非无色界系彼业果亦尔。有业果非无色界系非彼业。谓由无色界道证诸结断。彼诸断是此道离系士用果。约地分别准前应知。若业非不系彼业果非不系耶。答诸业果非不系彼业亦尔。有业非不系非彼业果。谓由色无色界道证诸结断。彼诸断是此道离系士用果。约地分别准前应知问诸所化事由谁化作。为由道耶。为由化心耶。若由道者何故化心说名能化。若由化心者此中所说当云何通。如说由色界道作欲界化发欲界语。有作是说。诸所化事由道化作。问若尔何故化心说名能化。答应名所化心不应名能化。然由道力作化事已。化心与所化俱时起故。名能化心实非能化。有余师说。诸所化事由化心作。问若尔此说当云何通。如说由色界道作欲界化发欲界语。答依展转因故作是说。如子孙法。谓神境通道无间而灭。化心与所化俱时而起。化心即是此道近士用果。所化事复是化心近士用果。所化事。谓四处或二处。如是说者。诸所化事由道化作亦由化心谓神境通道无间而灭。化心与所化俱时而起。虽俱时起而能化心唯是道果。诸所化事是前道果及化心果

问离所化身发化语不。有说。不发问若尔此说当云何通。如说由色界道作欲界化发欲界语。答所化身有二种。一者有语。二者无语。由色界道作欲界化者显无语化身发欲界语者。显有语化身。有说。离化身亦发化语。如在空界不见化身但闻化语。而此中所说由色界道作欲界化者。总显有语无语化身。发欲界语者总显依身离身化语。如是说者。离所化身不发化语。语者必由粗四大种相击起故

说一切有部发智大毗婆沙论卷第一百二十二阿毗达磨大毗婆沙论卷第一百二十三

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    业蕴第四中表无表纳息第四之二

颇有业有漏有漏果耶。乃至广说。应知此中依三果作论。除士用果及增上果。以士用果多杂乱故。多法为因得一法故。以增上果不决定故。极宽漫故如前已说。迦湿弥罗国诸论师言。此中依一因多果作论。若依此说颇有业有漏有漏果耶。答有。谓等流异熟果。颇有业有漏无漏果耶。答有。谓离系果。颇有业有漏有漏无漏果耶。答有。谓等流异熟离系果。颇有业无漏无漏果耶。答有。谓等流离系果。颇有业无漏有漏果耶。答无。颇有业无漏有漏无漏果耶。答无。颇有业有漏无漏有漏无漏果耶。答无。所以者何。此中依一因多果而作论。故无如是因体是有漏亦是无漏。如无此因。亦无此果。故答言无。颇有业有漏无漏有漏果耶。答无。颇有业有漏无漏无漏果耶。答无。西方诸师作如是说。此中依多因一果而作论。若依此说颇有业有漏有漏果耶。答有。谓等流异熟果。颇有业有漏无漏果耶。答有。谓离系果。颇有业有漏有漏无漏果耶。答无。所以者何。此中依多因一果而作论。故无如是果体是有漏亦是无漏。如无此果。亦无此因。故答言无。颇有业无漏无漏果耶。答有。谓等流离系果。颇有业无漏有漏果耶。答无。颇有业无漏有漏无漏果耶。答无。颇有业有漏无漏有漏无漏果耶。答无。颇有业有漏无漏有漏果耶。答无。颇有业有漏无漏无漏果耶。答有。谓离系果评曰。应知此中前说为善。以本论文多同前故。依一体业为问答故。无一业体通染净故

颇有业学学果耶。答有。谓等流果。颇有业学无学果耶。答有。谓等流果。颇有业学非学非无学果耶。答有。谓离系果。颇有业无学果耶。答有。谓等流果。颇有业无学无学学果耶。答无。颇有业无学非学非无学果耶。答无。问时解脱阿罗汉练根作不动。第九无间道顿证三界见修所断一切结断。彼诸结断是此道果应答言有。何故言无。答虽是此道士用果。而非离系果。前已说此中除士用增上果。故答言无。颇有业非学非无学非学非无学果耶。答有。谓等流异熟离系果。颇有业非学非无学学果耶。答无。问世第一法无间引生苦法智忍。此忍应是世第一法所引生果应答言有。何故言无。答彼虽是士用果。而非三果所摄。前已说此中依三果作论。故答言无。颇有业非学非无学无学果耶。答无。如世尊说。不修身不修戒。不修心。不修慧。乃至广说。修有四种。谓得修习修对治修除遣修。如智蕴等广说。此中依二修作论。谓对治修除遣修。若于身戒心慧对治道。未生名不修身。乃至不修慧。此依对治修说。又缘身戒心慧所有烦恼。未断未遍知名不修身。乃至不修慧。此依除遣修说。若于身戒心慧对治道已生。名为修身。乃至修慧。此依对治修说。又缘身戒心慧所有烦恼。已断已遍知。名为修身。乃至修慧。此依除遣修说。是谓此处略毗婆沙

云何不修身。答若于身未离贪欲润喜渴。又无间道能尽色贪。彼于此道未修未安。若于身未离贪者。谓未离爱未离欲者。谓于爱欲未断未遍知。未离润者。谓于爱润未断未遍知。未离喜者。谓于爱喜未断未遍知。未离渴者。谓于爱渴未断未遍知。又无间道能尽色贪者。谓无间道能尽色界爱。彼于此道未修未安者。谓未修习及未安息。修谓习修安谓得修。又起名修灭名安。又已生名修已灭名安。应知此中若于身未离贪欲润喜渴。名不修身者。依除遣修说。又无间道能尽色贪。彼于此道未修未安名不修身者。依对治修说。有余师说。若于身未离贪欲润喜渴。名不修身者。谓于缘身爱未断未遍知。又无间道能尽色贪。彼于此道未修未安。名不修身者。谓于缘身诸余烦恼。未断未遍知。有作是说。若于身未离贪等者。显未断系得。又无间道能尽色贪等者。显未证离系得。如未断系得。未证离系得。如是未损减过失。未修习功德。未弃下劣。未证胜妙。未舍无义。未得有义。未除有爱热恼。未受无爱快乐。应知亦尔。或有说者。若于身未离贪等者。显无间道未起作用。又无间道能尽色贪等者。显解脱道未起作用。复有说者。若于身未离贪等者。显未离欲界。乃至第三静虑染。又无间道能尽色贪等者。显未离第四静虑染。此等差别如理应知。云何不修戒。答若于戒未离贪。广说如身。云何不修心。答若于心未离贪欲润喜渴。又无间道能尽无色贪。彼于此道未修未安。若于心未离贪等如前说。又无间道能尽无色贪者。谓无间道能尽无色界爱。未修未安如前说应知。此中若于心未离贪欲润喜渴名不修心者。依除遣修说。又无间道能尽无色贪。彼于此道未修未安名不修心者。依对治修说。有余师说。若于心未离贪等者。谓于缘心爱未断未遍知。又无间道能尽无色贪等者。谓于缘心诸余烦恼未断未遍知。余广说如前。复有说者。若于心未离贪等者。显未离欲界乃至无所有处染。又无间道能尽无色贪等者。显未离非想非非想处染。此等差别如理应知。云何不修慧。答若于慧未离贪广说如心已说。不修身等自性杂无杂相今当说。若不修身彼不修戒耶。答如是。设不修戒彼不修身耶。答如是。以身与戒俱于离第四静虑染时方断尽故。若不修身彼不修心耶。答诸不修身彼不修心。有不修心非不修身。谓已离色染。未离无色染。若不修身彼不修慧耶。答诸不修身彼不修慧。有不修慧非不修身如前说。若不修戒彼不修心耶。答诸不修戒彼不修心。有不修心非不修戒。如前说。若不修戒彼不修慧耶。答诸不修戒彼不修慧。有不修慧非不修戒如前说。此中诸如前说者。俱谓已离色染未离无色染。以对治处同故。若不修心彼不修慧耶。答如是。设不修慧彼不修心耶。答如是。以心与慧俱于离非想非非想处染时方断尽故

如世尊说。修身修戒修心修慧。云何修身。答若于身已离贪欲润喜渴。又无间道能尽色贪。彼于此道已修已安。云何修戒。答若于戒已离贪。广说如身。云何修心。答若于心已离贪欲润喜渴。又无间道能尽无色贪。彼于此道已修已安。云何修慧。答若于慧已离贪。广说如心。略毗婆沙及释诸句翻前黑品如理应思

已分别修身等自性。杂无杂相今当说。若修身彼修戒耶。答如是。设修戒彼修身耶。答如是。以身与戒俱。于离第四静虑染。时方断尽故。若修身彼修心耶。答诸修心彼修身。有修身非修心。谓已离色染未离无色染。若修身彼修慧耶。答诸修慧彼修身。有修身非修慧。如前说。若修戒彼修心耶。答诸修心彼修戒。有修戒非修心。如前说。若修戒彼修慧耶。答诸修慧彼修戒。有修戒非修慧。如前说。此中诸句如前说者。俱谓已离色染未离无色染。以对治处同故。若修心彼修慧耶。答如是。设修慧彼修心耶。答如是。以心与慧俱于离非想非非想处染时。方断尽故

已随本论文句差别。释不修身戒心慧等。当复随义释此差别。有作是说。不修身者。谓于不净。净想颠倒未断未遍知。不修戒者。谓于苦乐想颠倒。未断未遍知。不修心者。谓于无常常想颠倒。未断未遍知。不修慧者。谓于无我我想颠倒。未断未遍知。有余师说。不修身者。谓于段食。未断未遍知。不修戒者。谓于触食。未断未遍知。不修心者。谓于识食。未断未遍知。不修慧者。谓于意思食。未断未遍知。或有说者。不修身者。谓于色蕴。未断未遍知。不修戒者。谓于受蕴。未断未遍知。不修心者。谓于识蕴。未断未遍知。不修慧者。谓于想蕴行蕴未断未遍知。复有说者。不修身者。谓于色随识住。未断未遍知。不修戒者。谓于受随识住。未断未遍知。不修心者。谓于能住识。未断未遍知。不修慧者。谓于想随识住行随识住。未断未遍知。有作是言。不修身者。谓未修身念住。不修戒者。谓未修受念住。不修心者。谓未修心念住。不修慧者。谓未修法念住。有余师言。不修身者。谓未修身修。不修戒者。谓未修戒修。不修心者。谓未修心修。不修慧者。谓未修慧修。有余复说。不修身者。谓身于觉支未能随顺。不修戒者。谓戒于觉支未能随顺。不修心者。谓心于觉支未能随顺。不修慧者。谓慧于觉支。未能随顺。或复有说。不修身者。谓身未能为戒所依。不修戒者。谓戒未能为奢摩他所依。不修心者。谓奢摩他未能为毗钵舍那所依。不修慧者。谓毗钵舍那未能害诸烦恼。如不修身等。如是诸说差别。如是修身等翻此应知

若成就过去戒。彼成就未来现在此类戒耶。乃至广说。类有四种。一修类二律仪类三界类四相似类。修类者。如前智蕴说。谓未曾得道现在前时。能修未来自类诸道。此中有说。诸有漏道有漏为类。诸无漏道无漏为类。复有说者。诸有漏道通以有漏无漏为类。诸无漏道通以无漏有漏为类。若有漏道现在前时。通修有漏及无漏道此由有漏道力修故俱名彼类。若无漏道现在前时。通修无漏及有漏道。此由无漏道力修故俱名彼类。律仪类者。如此业蕴说。谓有成就过去戒。非未来现在此类戒等。此中律仪律仪为类。谓别解脱律仪别解脱律仪为类。静虑律仪静虑律仪为类。无漏律仪无漏律仪为类。律仪加行律仪加行为类。律仪根本律仪根本为类。律仪后起律仪后起为类表戒表戒为类。无表戒无表戒为类。界类者如后根蕴说。谓有成就此类眼根。非此类身根等。此中若法于此界有。即说此为彼类。谓欲界法欲界为类。色界法色界为类。无色界法无色界为类。相似类者如毗奈耶说。谓物特子左手放光右手分僧卧具。与同类者。诸持经者持经者共。诸持律者持律者共。诸说法者说法者共。诸闲居者闲居者共。分配同类。非异类者。欲令展转相随顺故。善法增进恶法损减。如说有情诸界各别。有同类者更相随顺恶胜解者恶胜解俱。善胜解者善胜解俱。更相随顺作所应作。今于此四类中。依律仪类而作论

若成就过去戒。彼成就未来现在此类戒耶。答有成就过去戒。非未来现在此类戒。谓表戒已灭不失。此类戒不现前。有及未来非现在。谓静虑无漏戒已灭不失。此类戒不现前。有及现在非未来。谓表戒已灭不失。此类戒现前。有及未来现在。谓静虑无漏戒已灭不失。此类戒现前。成就过去戒。非未来现在此类戒。谓表戒已灭不失。此类戒不现前者。此说表戒。表戒为类。如先已受近事戒。勤策表戒不现前。或先已受勤策戒。苾刍表戒不现前。近事女等说亦尔。若说无表戒即以无表戒为类。诸有欲令若犯戒时现在戒类断。过去不失者。彼说此中更应作是说。及无表戒已灭不失。此类戒不现前。如已受近事戒而毁犯。或已受勤策戒苾刍戒而毁犯。近事女等说亦尔。诸有欲令若犯戒时现在戒不断。过去亦不失者。彼说此中更无余说。无有唯成过去无表戒。而非现在此类无表故。及未来非现在。谓静虑无漏戒已灭不失。此类戒不现前者。此说静虑无漏律仪已起已灭。虽成就而不现前。及现在非未来。谓表戒已灭不失。此类戒现前此说表戒表戒为类。如先已受近事戒。勤策表戒现在前。或先已受勤策戒苾刍表戒现在前。此中复应作如是说。及无表戒已灭不失。此说无表戒无表戒为类。诸说犯戒时现在戒断。过去不舍者。彼说受近事等戒已。乃至第二刹那无犯。彼成就现在无表。亦成就过去。诸说犯戒时现在戒不断。过去亦不舍者。彼说近事等受戒已。至第二刹那即犯者亦成就现在何况无犯。近事女等说亦尔。及未来现在。谓静虑无漏戒已灭不失。此类戒现前者。此说静虑无漏律仪。已起已灭亦成就亦现前

若成就未来戒。彼成就过去现在此类戒耶。答有成就未来戒非过去现在此类戒。谓阿罗汉生无色界。有及过去非现在。谓静虑无漏戒已灭不失。此类戒不现前。有及现在非过去。谓无漏戒初现前。有及过去现在。谓静虑无漏戒已灭不失。此类戒现前。有成就未来戒。非过去现在此类戒。谓阿罗汉生无色界及过去非现在。谓静虑无漏戒已灭不失。此类戒不现前者。此说静虑无漏律仪已起已灭。虽成就不现前。及现在非过去。谓无漏戒初现前者。此说苦法智忍。及得果转根初刹那现前位。及过去现在。谓静虑无漏戒已灭不失。此类戒现前者皆如前说

若成就现在戒。彼成就过去未来此类戒耶。答有。成就现在戒非过去未来此类戒。谓表戒初现前。有及过去非未来。谓表戒已灭不失。此类戒现前。有及未来非过去。谓无漏戒初现前。有及过去未来。谓静虑无漏戒已灭不失。此类戒现前。成就现在戒。非过去未来此类戒。谓表戒初现前者。此说别解脱律仪初受得位。问此位亦成就过去加行戒。云何说非过去耶。答此中依根本律仪类而作论。彼但是律仪加行。而非根本律仪是故不说。及过去非未来。谓表戒已灭不失此类戒现前此说表戒表戒为类。如先已受近事戒勤策表戒现在前。或先已受勤策戒苾刍表戒现在前。近事女等说亦尔。若说无表戒无表戒为类。二说差别如前应知。及未来非过去。谓无漏戒初现前者。此说苦法智忍。及得果转根初刹那现前位。及过去未来者。谓静虑无漏戒已灭不失。此类戒现前者。此说静虑无漏律仪。已起已灭亦成就亦现前

此中三种律仪。谓别解脱律仪。静虑律仪。无漏律仪。唯依别解脱律仪。安立七众差别不依余二。七众者。一苾刍二苾刍尼三式叉摩那四室罗摩拏洛迦五室罗摩拏理迦六邬波索迦七邬波斯迦。问何故唯依别解脱律仪。安立七众差别不依余耶。答以别解脱律仪渐次而得渐次安立故。谓若能离四性罪一遮罪。名邬波索迦。若复能离四性罪多遮罪。名室罗摩拏洛迦。若有能离一切性罪一切遮罪。名苾刍苾刍尼等。准此应知。静虑无漏七支律仪。顿得顿起顿安立。若依静虑无漏律仪安立七众。是则七众安立差别应顿非渐。有作是说。别解脱律仪。从初表业发得已后。于一切时现在成就。若眠若醉若狂若闷。若思不思。若染污心。若无记心。若无心等。一切位中。现在相续随转不断故。可依之立七众别。静虑无漏律仪若正在定现在成就。现在随转出则不然。故不依之立七众别。若依静虑无漏律仪立七众别者。则七众安立应不决定。入出定时无期限故。有余师说。别解脱律仪七众差别。俱唯欲界可得安立。静虑无漏律仪通上界得。若当依此立七众者。则七众安立应通上界。有余复说。别解脱律仪七众差别。俱唯人趣可得安立。静虑无漏律仪亦通天趣。若当依此立七众者。则七众安立应通天趣。复有说者。别解脱律仪七众差别。但由有佛出世可得安立。静虑无漏律仪。若佛出世若不出世俱可安立。若当依此立七众者。是则七众安立差别。亦应通在无佛出世。有余师说。何故不依静虑律仪以立七众。唯依别解脱者。以别解脱律仪七众差别。但内道有外道则无。静虑律仪通内外道有。若当依此立七众者。则七众安立应通外道。复何故不依无漏律仪以立七众。但依别解脱者。以别解脱律仪七众差别俱通凡圣。无漏律仪唯圣非凡。若当依此立七众者。则七众安立应唯在圣。由此所说诸因缘故。唯依别解脱律仪安立七众不依余二

如世尊说。邬波索迦有五学处。谓离杀生。离不与取。离欲邪行。离虚诳语。离饮诸酒。问何故名邬波索迦。答亲近修事诸善法故。谓彼身心狎习善法。故名邬波索迦。问若尔者。诸不断善皆名邬波索迦耶。以彼身心亦修善故。答不尔。此依律仪所摄妙行善法。以立名故。问若尔者。诸住律仪皆名邬波索迦耶。以彼皆修律仪善故。答此以在初故得名。余律仪更以余缘建立。复次此是律仪初入加行为能近事。余律仪与此相违故彼非难。有余师说。亲近承事诸善士故。谓彼恒时亲承善士故名邬波索迦。有作是说。亲近修事精进行故。谓彼恒时爱乐修习。速舍生死。速证涅槃。精进之行。故名邬波索迦。复有说者。亲近承事诸佛法故。谓彼至诚受持守护诸佛法律。不惜身命故名邬波索迦。问何故此五名为学处。答是近事者所应学故。有说此应名为学迹。若有游此便升无上智慧殿故。如尊者阿奴律陀告诸苾刍。我依戒住戒戒为梯橙。已能升陟无上慧殿。汝等应学勿生放逸。有说此应名为学害。由学此五害恶戒故。有说此应名为学路。此为径路一切律仪。妙行善法皆得转故。有说此应名为学禁。如诸外道所受禁法。种种差别以为幖帜。如是圣众以此五种所学禁法为初幖帜。有说此应名为学本。诸所应学此为本故。有说此五应名学基。于涅槃城为基趾故

问何故于非梵行中。唯依离犯他妻建立学处。而不依离犯自妻耶。答旧对法诸师。及迦湿弥罗国诸论师说。离欲邪行是近事者所受律仪。家族本地离非梵行则不如是。故此唯立离犯他妻。胁尊者曰。法王法主知此律仪。有法能为障碍遮止。有法不为障碍遮止。谓欲邪行于此律仪最极能为障碍遮止。如守门者禁门不开。余非梵行则不如是。故此唯立离犯他妻。有作是说。犯欲邪行性罪所摄世所讥嫌。余非梵行虽性罪摄。非世讥嫌故此不制。有作是说。于他妻等远离则易非于自妻。谓处居家妻子围绕。昼夜习近恩爱缠心。不能受持远离习近。内真不净外假庄严。如画粪车自妻骸骨。离欲邪行易防护者。谓求他妻难遂心故。有余师说。若犯他妻即是根本恶业道摄。非于自妻是故不说。有余师言。于自妻室生喜足者。亦得名为纯一圆满清白梵行故此不立。有说此是诸佛方便令他入法。谓佛先观若作如是立近事戒者。彼于恶行能离几许即如实知。彼所离者如四海水。余未离者如草端露。彼既能见犯他是罪能远离之。不久亦见犯自有罪亦当远离故。此唯立离犯他妻。复有说者。此是诸佛善权方便。若佛为其制自妻者。则诸国王宰官长者。不能弃舍自妻室故。便白佛言。我不能受如来禁戒。复求请除离自妻室我等由斯得有继嗣。故佛唯立离犯他妻。有余师言。若诸圣者经生不犯立近事戒于自妻不尔。所以者何。犯自妻有三。谓从贪嗔痴生。经生圣者虽不犯从痴所生。痴见品摄故圣者已断。而犯贪嗔所生是故不立

问邬波索迦。若更受持远离非梵行等五种学处。彼为别得异先所受诸律仪不。答更不别得。然名最胜邬波索迦。以别受持远离禁故。如苾刍等若更受持十二杜多功德。更不别得异先所受苾刍等戒。然名最胜大苾刍等。以别受持远离行故。彼亦如是。问何故语四善业道中。离虚诳语。独立学处而非余耶。答旧对法诸师。及迦湿弥罗国诸论师说。离虚诳语是近事者所受律仪家族本地。离离间等则不如是。故此唯立离虚诳语。胁尊者曰。法王法主知此律仪。有法能为障碍遮止。有法不为障碍遮止。谓虚诳语于此律仪最极能为障碍遮止。如守门者禁门不开。离间语等则不如是。有作是说。虚诳语性罪所摄讥嫌最重。离间语等虽性罪摄讥嫌少轻。故不立为近事学处。有作是说。离虚诳语易可防护非离余三。谓处居家御僮仆等。难可远离离间等三。及身业中捶挞等事。复有说者。作虚诳语业道最重。余三少轻故不立为近事学处。有余师说。唯虚诳语能破坏僧。故立学处余三不尔。有余复说。若诸圣者经生不犯立近事戒。圣者经生必定远离虚诳语业。非余语业。所以者何。余语有三。谓从贪嗔痴生。经生圣者。虽不犯从痴所生痴见品摄故。圣者已断而犯贪嗔所生是故不立。问世尊何故于遮罪中。唯离饮酒立为学处。答旧对法诸师。及迦湿弥罗国诸论师说。唯离饮酒是近事者。所受律仪家族本地。离余遮罪则不如是。故此唯立离饮诸酒。胁尊者曰。法王法主知此律仪有法能为障碍遮止。有法不为障碍遮止。谓饮诸酒于此律仪。最极能为障碍遮止。如守门者禁门不开。离余遮罪则不如是。故此唯立离饮诸酒。有作是说。离饮诸酒易可防护非余遮罪。谓酪清浆沙糖水等足能止渴何用酒为。有余师言。离饮酒戒能总防护诸余律仪。如堑垣城能总防护。复有说者。若不防护离饮酒戒。则总毁犯诸余律仪余则不尔。曾闻有一邬波索迦。禀性仁贤受持五戒专精不犯。后于一时家属大小当为宾客。彼独不往留食供之时至取食。碱味多故须臾增渴。见一器中有酒如水。为渴所逼遂取饮之。尔时便犯离饮酒戒。时有邻鸡来入其舍。盗心捕杀烹煮而啖。于此复犯离杀盗戒。邻女寻鸡来入其室。复以威力强逼交通。缘此更犯离邪行戒。邻家愤怒将至官司。时断事者讯问所以。彼皆拒讳。因斯又犯离虚诳语。如是五戒皆因酒犯。故遮罪中独制饮酒。有余师说。酒令失念增无惭愧。其过深重故偏制立。如律中说。制地国中有一毒龙。性极暴恶为稼穑害。其所居池水陆空飞无敢近者。时有尊者名曰善来。以巧方便令其调伏。因此名称流布八方。于是信心竞兴供养。渐次游化至室罗筏。值彼城中请僧设会。有近事女家不丰饶。独请善来奉上饮食。食多盐味须臾增渴。为渴所逼现相求饮。时近事女作是思惟。尊者所食极为肥腻。若饮冷水或当致疾。遂设方便授以清酒。彼不审察便取饮之。赞慰收衣趣胜林寺。将至醉闷湎眩便倒。衣钵锡杖狼藉在地。露体而卧无所觉知。佛将阿难经行遇见。知而故问此卧者谁。何为此间醉酒而卧。阿难白佛此是善来。佛告阿难可集僧众。僧众集已佛在众中。敷如常座结加趺坐。尔时世尊告苾刍众。汝等闻见苾刍善来曾以巧便伏毒龙不。诸苾刍众随已见闻。各白佛言。我曾闻见。佛言。汝等于意云何。善来今能伏虾蟆不。苾刍皆曰。不也世尊。尔时如来种种方便呵毁酒过告诸苾刍。汝等若称佛为师者。自今已往下至茅端所沾酒渧亦不得饮。故遮罪中独制饮酒。有作是说。饮酒能令智慧衰退。如说长者智慧衰退。是第六失故遮罪中独制饮酒。有余师说。圣者经生必不饮酒。虽婴孩位养母以指。强渧口中不自在故而无有失。才有识别设遇强缘。为护身命亦终不饮。故遮罪。中独立酒戒

说一切有部发智大毗婆沙论卷第一百二十三阿毗达磨大毗婆沙论卷第一百二十四

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    业蕴第四中表无表纳息第四之三

问颇有唯受三归成近事不。为有律仪缺减成近事不。若言有者。契经所说文句差别岂非无义。如说我某甲归佛法僧。愿尊忆持。我是近事我从今日乃至命终。护生归净。亦应说有律仪缺减勤策苾刍等。若无者。即前契经文句差别宁非无义。何故安立一分少分多分满分近事耶。健驮罗国诸论师言。唯受三归及律仪缺减悉成近事。问若唯受三归成近事者。契经文句宁非无义。经说近事受律仪时。于戒师前作如是说。我某甲归佛法僧。愿尊忆持我是近事。我从今者乃至命终。于其中间护生归净。答彼由此表但得三归。名为近事而未得律仪。后说学处方得律仪。然彼文句非为无义。由后自誓令前三归得坚牢故。若不护生归非净故。问若缺减律仪成近事者。便为善顺一分等言。所以者何。若受一名一分。受二名少分。受三受四名多分。具受五名满分故。云何不有律仪缺减勤策苾刍等耶。答佛观所化机宜不同。授与律仪亦不一种。如诸近事不乐舍家为摄引故。佛随其意于五学处多少受得。故彼律仪有缺减受。苾刍勤策意乐舍家。为安立故制具律仪。具受乃得故彼律仪无缺减受。以是世尊内眷属故。迦湿弥罗国诸论师言。无有唯受三归及缺减律仪名为近事。问若尔契经宁非无义。如说我某甲归佛法僧。乃至广说。答彼由此表既得三归。亦得律仪故成近事。问此唯自誓离于杀生。云何由此具得五种。答由此自誓离杀为依。五种律仪亦俱时得。五学处中彼为胜故。以受戒者为不损生。于损生中杀为上首。故以离杀为五所依。又护生言非唯离杀。谓不损恼一切有情。彼自誓言我从今者乃至命尽。于诸有情不害其命。不盗其物。不侵其妻。不行虚诳。为护前四。亦不饮酒。故护生言非唯离杀。然有别诵言舍生者。此言意说舍杀生等。略去杀等但说舍生。又舍生言显于生类。舍损恼事即五律仪。皆为遮防损生事故。由此自誓方得律仪。故彼契经非为无义。问若唯自誓便得律仪。何故复说五种学处。答虽由自誓已得律仪。而未了知彼差别相。欲令知故说五学处。故彼所说皆非无义。问若尔何故说有一分等邬波索迦耶。答此说持位非说受位。谓于五中持一不持四名一分。持二不持三名少分。持三持四名多分。具持五名满分。尊者僧伽筏苏分同前二师说。彼说无有唯受三归便成近事。然有缺减五种律仪亦成近事。谓彼将受近事戒时。先与戒师共详审议。如是学处我能受持。如是学处我不能受。既详议已归佛法僧。自誓要期得尔所戒随先详议能受少多。今得律仪其数亦尔。由此故说近事律仪名详议戒。非勤策等戒得有此名。如是说者。无但三归即成近事。亦无缺减近事律仪。成近事者如无缺减。勤策等律仪名勤策等彼亦如是

问诸有但受近事律仪。不受三归得律仪不。有说不得。以受三归与此律仪。为门为依为加行故。有说不定谓若不知先受三归后方受戒。信戒师故便受律仪。彼得律仪戒师得罪若彼解了先受三归。后受律仪是正仪式。但憍慢故不受三归。作如是言且应受戒。何用归信佛法僧。为彼慢缠心虽受不得。问若先不受近事律仪。便受勤策律仪。得勤策律仪不。有说不得。以近事律仪与此律仪为门为依为加行故。有说不定。若不了知先受近事律仪。后方受勤策律仪。信戒师故受此律仪。彼得律仪戒师得罪。若彼解了先受近事律仪。后受勤策律仪是正仪式。但憍慢故不欲受学近事律仪。作如是言何用受此近事劣戒。彼慢缠心虽受不得。如说不受近事律仪。而受勤策律仪。如是不受勤策律仪。而受苾刍律仪。广说亦尔。问诸近事受勤策律仪。及勤策受苾刍律仪。彼为舍前律仪得后律仪不。若舍前得后者。何故施设论说前后律仪彼俱成就。又若舍者。后舍勤策为近事时。及舍苾刍为勤策时。更来受戒。云何得彼近事勤策二律仪耶。若不舍者。彼既成就二种律仪。或复三种。何故得名唯依后戒。又亲教师彼既有二。何故佛说后是前非。答受后律仪不舍前戒。谓近事受勤策律仪不舍近事五。更得勤策十。尔时成就十五律仪。若勤策受苾刍律仪。不舍前十五更得苾刍过二百五十。尔时成就过二百六十五律仪。有余师说。若近事受勤策律仪。不舍近事五更得勤策五。尔时成就十种律仪。若勤策受苾刍律仪。不舍前十更得苾刍过二百四十。尔时成就过二百五十律仪。问彼既成就二种律仪或复三种。何故得名唯依后戒。答就胜立名不应为难。如得胜位舍本劣名。问彼亲教师既有二种。何故佛说后是前非。答以胜律仪依后师得。不依前故。如不依彼律仪得名。彼师亦尔。复有说者。舍前律仪。问若尔何故施设论说前后律仪彼俱成就。答彼论意说。由前律仪资后令胜。前戒势力今时犹转故说成就。而先律仪实不成就。问后舍苾刍为勤策时。及舍勤策为近事时。复云何得彼二戒耶。答即由语表自誓我今还为勤策或近事故。得二律仪非成旧戒。如是说者不舍前戒而得后戒彼后所受非前所受相违法故。又前后戒因。缘各别。不应相合成十数等

问若童子时受近事戒。至少年位。方娉妻室。彼于此妻先得戒不。若先得者今应犯戒。若先不得则此律仪应从少分有情处得。答应言先得。问若尔今应犯戒。答得由别分非总相续。先所受得离欲邪行。非非梵行今如何犯。习近自妻非邪行故。谓一相续别分有多。所遮所行别故无犯问若童子位得不作律仪。至少年时方娉妻室。彼于此妻先得律仪不。若先得者今应犯律仪。然不作律仪得必无犯。若先不得则此律仪。应从少分有情处得。答应言先得广说如前。问近事律仪依何处有。答依欲界有非色无色界。依人趣有非余趣。依三洲有除北洲。问若此律仪唯依人趣。契经所说当云何通。如契经说。时天帝释来诣佛所。作如是言。愿佛忆持。我是近事我从今者乃至命终。于其中间护生归净。答彼自显示是信等流。非受律仪不应为难

如契经说。近住律仪具足八支。何等为八。谓离害生命。离不与取。离非梵行。离虚诳语离饮诸酒。诸放逸处离歌舞倡伎。离涂饰香鬘离高广床离非时食。问此有九支何以言八。答二合为一故说八支。谓离涂饰香鬘与离歌舞倡伎。同于庄严处转故合立一支。问云何名近住。云何近住支。答离非时食名为近住。离害生等名近住支。问此近住支应唯有七。答离非时食名为近住。亦近住支故不唯七。如正见名道亦道支。余名道支非道。择法名觉亦觉支。余名觉支非觉。三摩地名静虑亦静虑支。余名静虑支非静虑。如是离非时食名近住亦近住支。余名近住支非近住。故说近住具足八支。尊者妙音众世说曰。应言近住或全无支。或一二三乃至或七。非要具八方名近住。如是说者。非全无支乃至或七。得名近住。名近住者要具八支

问近住律仪云何而得。答从他教得。谓随师教自发诚言恭敬受得。问受律仪者或先自发言。或与师俱说得律仪不答不得要随师语。如师语而说方受得故。问近住律仪从谁应受。答从七众受皆得非余。所以者何。若无尽寿戒者。则不堪任为戒师故。问着何服饰受此律仪答常所受用衣服严具着之。皆得受此律仪。若为暂时庄严身者。必须弃舍方受此戒。床座等具准此应知。问齐何时受。答齐一昼夜不增不减。谓清旦时从师受得。至明清旦律仪便舍。问若有顿受半月一月。或复多时得律仪不。答应言不得。所以者何。一昼夜时分限定故光闇往来易了知故。一斋食时非时定故非一昼夜。近住律仪可使顿经二昼夜受。况多昼夜可顿受得。如近事等尽寿律仪不可顿受。二众同分。况多同分可顿受得昼夜律仪。理亦应尔。律仪分齐唯有二故。问受昼非夜。受夜非昼。得此戒不。有说不得。所以者何。佛说此为昼夜戒故。问若尔者。尊者迦多衍那所说因缘当云何通。如说时彼尊者告屠儿言。汝等皆应离此恶业。勿于来世受大苦果。屠儿答言。我以此业而自存活如何能离。尊者告言。汝等所作屠羊等业何时分造。屠儿答言。唯于昼分。尊者告曰。汝等可于夜分受持近住八戒。诸屠儿辈欢喜奉行。命终皆生旷野鬼趣。每于昼日有黑驳狗欻然而现啖食其肉。唯余骸骨俄顷肉生平复如旧。还被食啖受诸苦恼如地狱趣。每至夜分五欲自娱。游戏受乐犹如天趣。尊者复诣诸欲邪行淫女等处告言。汝等应离此业。勿于来世受大苦果。彼人答言。我等久习如是事业非卒能离。尊者告言。汝等所作邪秽事业在何时分。彼人答言。唯于夜分。尊者告曰。汝等可于昼分受持近住八戒。诸邪行者欢喜奉行。命终皆生旷野鬼趣。每于夜分有百足虫欻尔而生唼食其肉。唯余骸骨俄顷肉生平复如旧。还被唼食受诸苦恼如地狱趣。每至昼分五欲自娱。游戏受乐犹如天趣。如是所说当云何通。答彼妙行摄非是律仪。受妙行果。非律仪果。是以无过。有余师言。是彼尊者神力化作非是真实。令俱胝耳厌世间故。化为彼事故不须通有说亦得。谓有要期。月八日等恒受斋戒有缘碍故得如是受。评曰。前说为善昼夜戒故。问若至午后受此戒者亦得戒不。答应言不得。除先要期。月八日等恒受斋戒。彼有余缘午前不忆。食已方忆深生悔愧。即请戒师如法受者亦得此戒

问扇搋半择迦无形二形。受近住律仪得律仪不。答应言不得。所以者何。彼所依身志性羸劣非律仪器。亦不能为不律仪器。如碱卤田嘉苗秽草俱不生长。然应授彼近住律仪。令生妙行当受胜果。或扇搋等国王委任。令知要务苦楚多人。若受律仪毒心暂息。饶益多人故亦应为受。然实不得近住律仪

如是所说近住律仪。或有根本业道净而近分不净。如自在者受此律仪。有彼厨人欲害生命拟充所食。彼便告曰。我今受戒不得杀生。留待明朝杀充所食。复有捕获怨敌将来请欲加害。彼便告曰。我今受律仪不得杀害。留待明旦依法刑戮。如是名为根本业道净而近分不净。世尊说彼所受律仪。虽是胜业而不获大果。或有根本业道净近分亦净。而恶寻思之所损害。谓欲寻思恚寻思害寻思。世尊说彼所受律仪。虽是胜业而不获大果。或有根本业道净近分亦净非恶寻思之所损害。而不摄受正念。谓佛随念法。随念僧。随念戒。随念舍。随念天。随念世尊。说彼所受律仪。虽是胜业而不获大果。或有根本业道净近分亦净。非恶寻思之所损害。摄受正念而不回向解脱。谓求生天欲乐等故受持禁戒。世尊说彼所受律仪。虽是胜业而不获大果。若有根本业道净近分亦净。非恶寻思之所损害。摄受正念回向解脱。世尊说彼所受律仪。是殊胜业能获大果。世尊依后所受律仪。告毗舍佉鹿子母曰。若有成就此八近住律仪。十六大国所有珍宝。欲比其价十六分中不能及一。如是百分千分皆千分。数分算分。乃至邬波尼杀昙分亦不及一。十六大国者。谓泱伽国。摩揭陀国。迦尸国。憍萨罗国。佛栗氏国。末罗国。奔哒罗国。苏噏摩国。頞湿缚迦国。頞饭底国。叶筏那国。剑跋阇国。俱卢国。般遮罗国。筏蹉国。戍洛西那国。此十六国丰诸珍宝故偏说之。诸珍宝者。谓末尼真珠。吠琉璃宝。螺贝璧玉珊瑚金银。摸婆洛揭拉婆宝。頞湿摩揭婆宝。赤珠右旋宝等。又佛依后所说律仪。诃天帝释所说赞颂。如天帝释闻佛所说近住律仪功德殊胜。便以伽他而赞叹曰

  六斋神变月　　受持八戒斋
  彼功德殊胜　　则为与我等

尔时世尊。告苾刍众。此天帝释所说伽他违于道理。若阿罗汉可作是说。所以者何。此天帝释贪嗔痴等。未能永离。未得解脱。生老病死愁忧悲苦缠缚身心。如何可言受持此戒所获功德与我等耶。诸阿罗汉诸漏已尽。所作已办。舍诸重担自利已满尽诸有结。心善解脱不受后有。彼可说言受持此戒所获功德。则与我等。天帝功德唯感天帝。受持八戒证三菩提。故不应言但与其等

问谁应受此近住律仪。有作是说。唯圣者非异生。唯是近事非非近事。唯有为暂时舍尽寿。然有为尽寿舍尽寿。为尽寿舍暂时。谁有为暂时受尽寿。然有为尽寿受暂时。如是说者。亦圣者亦异生。亦近事亦非近事。然薄伽梵。为毗舍佉鹿子母说。及天帝释所说伽他唯依圣者

问近住律仪依何处有。答唯依欲界有非色无色界。依人趣有非余趣。依三洲有除北洲。问若此律仪唯依人趣。契经所说当云何通。如契经说。有海居龙从大海出于六斋日受八戒斋。放舍身心寂然而住。徐发吟韵作如是言。今于世间无所恼害答彼得妙行不得律仪。自庆暂时离诸恶行。彼自忆念昔在人中。受八戒斋不能清净。有毁犯故堕龙趣中。作是思惟我本人趣。若能清净持八戒斋。今应生天受诸快乐。何期毁犯堕斯恶趣。厌恶行故数从海出受八戒斋吟韵自庆。然实彼龙唯得妙行不得律仪。问何故此律仪名为近住。答近阿罗汉住故名近住。以受此律仪随学彼故。有说。此近尽寿戒住故名近住。有说。此戒近时而住故名近住。如是律仪。或名长养。长养薄少善根有情令其善根渐增多故。有说长养在家善根令近出家善根住故。问如是所说八支律仪。几是尸罗支。几是不放逸支几是远离支。答五是尸罗支。谓离害生命。乃至离饮酒。一是不放逸支。谓离非时食。余二是远离支。又前四是尸罗支。离性罪故。第五是不放逸支。虽受尸罗。若饮诸酒心便放逸不能护故。后三是远离支。以能随顺厌离心故。厌离能证律仪果故。由此近住具有八支。而于五增三。于十减一。合二为一故。开一为二故。

    业蕴第四中自业纳息第五之一

云何自业。自业是何义。如是等章。及解章义既领会已。次应广释。问何故作此论。答为欲分别契经义故。如契经说。佛告摩纳婆。世间有情皆由自业。皆是业分。皆从业生业为所依。业能分判诸有情类。彼彼处所高下胜劣。契经虽作是说。而未广辩自业之义。契经是此论所依根本。彼不说者今应说之。故作斯论。尊者世友说曰。世间有情皆由自业者。谓自作业还自受异熟。皆是业分者。谓如所作业受如是异熟。皆从业生者。谓业为生因取异熟果。生于彼彼所应生处。业为所依者。谓业为依因受彼彼有具。业能分判诸有情类。彼彼处所高下胜劣者。谓如前说。彼彼生处由业分判高下胜劣

云何自业。答若业已得今有异熟。及业异熟已生正受。若业已得今有异熟者。此句显示顺中有受业。及业异熟已生正受者。此句显示顺生有受业。如顺中有受。顺生有受。应知顺起受异熟。顺生受异熟。顺起受果。顺生受果。顺细果。顺粗果业亦尔。问为由因故名自业。为由果故名自业耶。若由因故名自业者。后句所说当云何通。后句说言及业异熟已生正受。若由果故名自业者。前句所说当云何通。谓业已得今有异熟。有作是说。但由因故名为自业。由前句故。有作是说。但由果故名为自业由后句故。如是说者。但由因故名为自业。问若尔何故复说及业异熟已生正受。答于住果位。彼因方得自业之名。是故尊者妙音说曰。若爱非爱果已起现前。彼业尔时名为自业。非未造业及造业时。有能现前受异熟果。要业灭已果方起故

自业是何义。答是得自果。自等流自异熟义。此中有说。自果者士用果。自等流者等流果。自异熟者异熟果。有说。诸句皆显异熟果。此中说感异熟业名自业故。有处等流以异熟声说。如说何等名受异熟。答言爱是。有处异熟以等流声说。如此中说。复次此业所招异熟于自相续现。熟非余故名自业问为此造业即此受果。为异造业异受果耶。答有缘故说此造此受。有缘故说异造异受。有缘故说无造无受。有缘故说此造此受者。谓蕴处界展转相续刹那虽异可说一故。有缘故说异造异受者。谓人趣造业余趣受果。余趣造业亦尔。有缘故说无造无受者。谓一切法无我。无有情无命者。无养育者。无补特伽罗。空无内士夫。离作者受者。唯有生灭诸行聚故。于自相续。养随养。育随育。护随护。转随转。益随益。故名自业。问善业异熟可于自相续能为养等。不善业异熟于自相续但为损害。如那落迦十三猛焰缠烧其身。彼宁有。养等耶。答养等有二种。一令增长。二令不断。善业异熟于自相续由二事故说名养等。恶业异熟于自相续但令不断说名养等。非令增长故无有过

若业是自业此业当言过去耶。未来耶。现在耶。答此业当言过去。问何故此业不当言未来。答非先受果后造因故。问何故此业不当言现在。答异熟因果不俱时故若业是自业此业成就耶。答应作四句。有业是自业此业不成就。谓业已得今有异熟。及业异熟已生正受。此业已失如无间业已现在前。已牵异熟果正现前。此业已失由舍所依众同分故。若律仪业已现在前已牵异熟。此有四种。谓顺现法受。顺次生受。顺后次受。顺不定受。果正现前此业已失。由四缘故。或五缘故。谓舍所学二形生。断善根舍众同分。或明相出若不律仪业已现在前。已牵异熟。此有四种。谓顺现法受等如前说。果正现前此业已失。由四缘故。谓受律仪得静虑。二形生舍众同分。若非律仪非不律仪。诸余身语妙行恶行已现在前。已牵异熟。此有四种。谓顺现法受等如前说。果正现前此业已失。由三缘故。谓意乐息。舍加行限势过。若欲界系善不善思已现在前。已牵异熟。此有四种。谓顺现法受等如前说。果正现前此业已失。谓若善者由断善根。或由舍众同分等故。若不善者。由离染故。若恶作忧根俱生。善思已现在前已牵异熟。此有四种。谓顺现法受等如前说。果正现前此业已失。由断善根故。或已离染故。若初静虑顺退分。顺胜进分。顺决择分等业。已现在前。已牵异熟。此有四种。谓顺现法受等如前说。果正现前此业已失。由已离染故。或易界地等故。如是乃至非想非。非想处。顺退分等业广说应知。有业成就此业非自业。谓业非已得今有异熟。及业异熟非已生正受。此业不失。如无间业已现在前。已牵异熟果未现前此业不失。由未舍所依众同分故。若律仪业。若不律仪业。若非律仪非不律仪。诸余身语妙行恶行。若欲界系善不善思。若恶作忧根俱生善思。已现在前已牵异熟。皆有四种。谓顺现法受等如前说。果未现前此业不失。由无前所说诸失缘故。若初静虑顺退分。顺住分。顺胜进分。顺决择分等业。已现在前已牵异熟。此有四种。谓顺现法受等如前说。果未现前此业不失。由未全离染不易界地等故。如是乃至非想非非想处。顺退分等业广说应知。有业是自业此业亦成就。谓业已得今有异熟。及业异熟已生正受。此业不失。如律仪业。若不律仪业。若非律仪非不律仪。诸余身语妙行恶行已现在前。已牵异熟。此有二种。谓顺现法受。顺不定受。果正现前。此业不失。由无前所说诸失缘故。若欲界系善不善思。若恶作忧根俱生善思。已现在前已牵异熟。此有四种。谓顺现法受等如前说。果正现前此业不失。由无前所说诸失缘故。若诸静虑。无色顺退分。顺住分。顺胜进分。顺决择分等业。已现在前已牵异熟此有四种。谓顺现法受等如前说。果正现前此业不失。由无前所说诸失缘故。有业非自业此业亦不成就。谓业非已得今有异熟及业异熟。非已生正受此业已失。如无间业余众同分中。已消已受。已作所作。已与果已。无能异熟已熟。若律仪业若不律仪业。若非律仪非不律仪。诸余身语妙行恶行。若欲界系善不善思。若恶作忧根俱生善思。若诸静虑。无色顺退分。顺住分。顺胜进分。顺决择分等业。余众同分中。已消已受。已作所作。已与果已。无能异熟已熟。此业已失。由有前说诸失缘故。非亦有四句。翻是应知。谓前第二句作此第一句前第一句作此第二句。前第四句作此第三句。前第三句作此第四句。广说如前

说一切有部发智大毗婆沙论卷第一百二十四阿毗达磨大毗婆沙论卷第一百二十五

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    业蕴第四中 自 业纳息第五之二

若业是自业。此业定当受异熟耶。答应作四句。有业是自业。此业定当不受异熟。谓业已得今有异熟。及业异熟已生正受。此业异熟已至最后位。此最后言义有多种。谓有最后千劫。有最后百劫。有最后劫。有最后千岁。有最后百岁。有最后岁。有最后月。有最后昼夜。有最后刹那。云何最后千劫。谓如一业能引非想非非想处八十千劫寿量。彼住最后千劫时。此业是自业。此业定当不受异熟。已至最后异熟位故。云何最后百劫。谓如一业能引无烦天处十百劫寿量。彼住最后百劫时。此业是自业此业定当不受异熟。已至最后异熟位故。云何最后劫。谓如一业能引遍净天处六十四劫寿量。彼住最后劫时。此业是自业。此业定当不受异熟。已至最后异熟位故。云何最后千岁。谓如一业能引他化自在天处十六千岁寿量。彼住最后千岁时。此业是自业。此业定当不受异熟。已至最后异熟位故。云何最后百岁。谓如一业能引北俱卢洲十百岁寿量。彼住最后百岁时。此业是自业。此业定当不受异熟。已至最后异熟位故。云何最后岁。谓如一业能引南赡部洲百岁寿量。彼住最后岁时。此业是自业。此业定当不受异熟。已至最后异熟位故。云何最后月。谓如一业能引十二月寿量。彼住最后月时。此业是自业。此业定当不受异熟。已至最后异熟位故。云何最后昼夜。谓如一业能引三十昼夜寿量。彼住最后昼夜时。此业是自业。此业定当不受异熟。已至最后异熟位故。云何最后刹那。谓如一业能引百刹那寿量。彼住最后刹那时。此业是自业。此业定当不受异熟。已至最后异熟位故。有业定当受异熟。此业非自业。谓业非已得今有异熟。及业异熟非已生正受。此业异熟未熟。如无间业已现在前。已牵异熟果未现前若律仪业。若不律仪业。若非律仪非不律仪。诸余身语妙行恶行。若欲界系善不善思。若恶作忧根俱生善思。若诸静虑。无色顺退分。顺住分。顺胜进分。顺决择分等业。已现在前。已牵异熟。此有三种。谓顺现法受。顺次生受。顺后次受。果未现前。有业是自业。此业定当受异熟。谓业已得今有异熟。及业异熟已生正受。此业异熟未至最后位。此最后言义有多种。谓有最后千劫。乃至最后刹那。最后千劫者。谓如一业能引非想非非想处八十千劫寿量。彼住最初千劫时。此业是自业。此业定当受异熟。谓定当受七十九千劫异熟。乃至彼住第七十九千劫时。此业是自业。此业定当受异熟。谓定当受千劫异熟。最后百劫者。谓如一业能引无烦天处十百劫寿量。彼住最初百劫时。此业是自业。此业定当受异熟。谓定当受九百劫异熟。乃至彼住第九百劫时。此业是自业。此业定当受异熟。谓定当受百劫异熟。最后劫者。谓有一业能引遍净天处六十四劫寿量。彼住最初劫时。此业是自业。此业定当受异熟。谓定当受六十三劫异熟。乃至彼住第六十三劫时。此业是自业。此业定当受异熟。谓定当受一劫异熟。如是最后千岁。乃至最后刹那。随其所应。广说亦尔。如是诸业果正现前故名为自业。未至最后异熟位故。名定当受异熟。有业非自业。此业定当不受异熟。谓业非已得今有异熟。及业异熟非已生正受。此业异熟已熟。谓诸无间业余众同分中。已消已受。已作所作。已与果已。无能异熟已熟。如律仪业。若不律仪业。广说乃至。若诸静虑。无色顺退分。顺住分。顺胜进分。顺决择分等业。已消已受。已作所作。已与果已。无能异熟已熟。非亦有四句。翻是应知。谓前第二句作此第一句。前第一句作此第二句。前第四句作此第三句。前第三句作此第四句。广说如前。若业成就此业定当受异熟耶。答应作四句。有业成就此业定当不受异熟。谓业过去不善善有漏异熟已熟。此业不失。若业未来不善善有漏已得而定不生。若业无记无漏成就。此中谓业过去不善善有漏异熟已熟。此业不失者。如律仪业。若不律仪业。若非律仪非不律仪。诸余身语妙行恶行。已现在前已牵异熟。此有二种。谓顺现法受。顺不定受。果已现前此业不失。无前所说诸失缘故。若欲界系善不善思。若恶作忧根俱生善思。已现在前已牵异熟。此有四种。谓顺现法受等如前说。果已现前此业不失。无前所说诸失缘故。若诸静虑。无色顺退分。乃至顺决择分等业。已现在前已牵异熟。此有四种。谓顺现法受等如前说。果已现前此业不失。无前所说诸失缘故。若业未来不善善有漏已得而定不生者。谓欲界系善不善思。未来已得而定不生定不生故。此业定当不受异熟。若恶作忧根俱生善思。若诸静虑。无色顺退分。乃至顺决择分等业。未来已得而定不生定不生故。此业定当不受异熟。若业无记无漏成就者。谓无记无漏业。虽成就而性不贞实。及无爱润故。此业定当不受异熟。有业定当受异熟。此业不成就。谓业过去不善善有漏异熟未熟。此业已失。若业未来不善善有漏不得而定当生。此中谓业过去不善善有漏异熟未熟。此业已失者。如律仪业。已现在前已牵异熟。此有三种。谓顺现法受。顺次生受。顺后次受。果未现前此业已失。由前所说诸失缘故。若不律仪业。若非律仪非不律仪。诸余身语妙行恶行。若欲界系善不善思。若恶作忧根俱生善思。若诸静虑。无色顺退分。乃至顺决择分等业。已现在前已牵异熟。此有三种。谓顺现法受等如前说。果未现前此业已失。由前所说诸失缘故。若业未来不善善有漏不得而定当生者。谓诸无间业未来未得。而定当生。定当生故定当受异熟。若律仪业。若不律仪业。若非律仪非不律仪。诸余身语妙行恶行。若欲界系善不善思。若恶作忧根俱生善思。若诸静虑。无色顺退分。乃至顺决择分等业。未来未得而定当生。定当生故定当受异熟。此有三种。谓顺现法受等如前说。有业成就此业。定当受异熟。谓业过去不善善有漏异熟未熟此业不失。若业未来不善善有漏已得亦定当生。若业现在不善善有漏。此中谓业过去不善善有漏异熟未熟此业不失者。谓诸无间业已现在前已牵异熟。果未现前。若律仪业。若不律仪业。若非律仪非不律仪。诸余身语妙行恶行。若欲界系善不善思。若恶作忧根俱生善思。若诸静虑。无色顺退分。乃至顺决择分等业。已现在前已牵异熟。此有三种。谓顺现法受等如前说。果未现前此业不失。由无前所说诸失缘故。若业未来不善善有漏已得亦定当生者。谓欲界系善不善思。未来已得亦定当生。定当生故定当受异熟。此有三种。谓顺现法受等如前说。若恶作忧根俱生善思。若诸静虑。无色顺退分乃至顺决择分等业。未来已得亦定当生。定当生故定当受异熟。此有三种。谓顺现法受等如前说。若业现在不善善有漏者。谓诸无间业正现在前。若律仪业。若不律仪业。若非律仪。非不律仪。诸余身语妙行恶行。若欲界系善不善思。若恶作忧根俱生善思。若诸静虑。无色顺退分。乃至顺决择分等业。正现在前。此有三种。谓顺现法受等如前说。有业不成就此业定当不受异熟。谓业过去不善善有漏异熟已熟此业已失。若业未来不善善有漏不得亦定不生。若业无记无漏不成就。此中谓业过去不善善有漏异熟已熟此业已失者。谓诸无间业余众同分中。已消已受。广说如前。若律仪业。若不律仪业。若非律仪非不律仪。诸余身语妙行恶行。若欲界系善不善思。若恶作忧根俱生善思。若诸静虑。无色顺退分。乃至顺决择分等业。已在过去已消已受。广说如前。此业已失。由有前说诸失缘故。若业未来不善善有漏不得亦定不生者。谓诸无间业未来未得定当不生。定不生故定当不受异熟。若律仪业。广说乃至。若诸静虑。无色顺退分。乃至顺决择分等业。未来未得定当不生。定不生故定当不受异熟。若业无记无漏不成就者。谓由不贞实及无爱润故。或先未得。或得已失故非。亦有四句。翻是应知。谓前第二句作此第一句。前第一句作此第二句。前第四句作此第三句。前第三句作此第四句。广说如前若预流者。有不善业能顺苦受。乃至广说。问何故作此论。答欲令疑者得决定故。如说二因令堕恶趣。谓见所断修所断业。诸预流者。虽已永断见所断业。而未能断修所断业。或有生疑。诸预流者应堕恶趣。或复生疑。彼应已断修所断业。欲令彼疑得决定故。显预流者。虽未永断修所断业。而彼决定不堕恶趣。故作斯论。若预流者。有不善业能顺苦受。异熟未熟彼既成就。应堕恶趣何道障故而不堕耶。答由二部结缚诸有情令堕恶趣。谓见所断修所断结。诸预流者。虽未永断修所断结而已永断见所断结。阙一资粮不堕恶趣。如车具二轮有所运载。鸟有二翼能飞虚空阙一不然。此亦如是。故预流者不堕恶趣。随本论文所释如是。然有说者。愚堕恶趣智则不然。一切预流是智者故。凡堕恶趣圣则不然一切预流是圣者故。有恶意乐害意乐者堕恶趣。有善意乐无害意乐者不然一切预流有善意乐无害意乐故。犯戒者堕恶趣。持戒者不然一切预流是持戒者。由彼已得圣所爱戒坚牢船故。复有说者。一切预流于诸恶趣得非择灭。诸法若得非择灭者。彼法毕竟不现在前。是故预流不堕恶趣。有余师说。若有不见恶行过失妙行功德。彼堕恶趣一切预流如实知见善恶得失。由失念故。虽暂起恶业而不堕恶趣。有作是说。萨迦耶见未断未遍知。造恶业者容堕恶趣。一切预流萨迦耶见已断已遍知。虽暂起恶业。而不堕恶趣。如世尊说。若有身见已断已遍知。具五功德。一者障三恶趣。二者遮五无间业。三者解脱种种诸恶见趣。四者无际生死已作分齐。五者临命终时心神明了。有说。预流智腹净故。虽有恶业不堕恶趣。如有二人食不应食。一内火劣所食不消便致大苦。一内火盛所食易消不增大苦。如是异生及预流者。虽俱受境作不善业而诸异生智腹不净。无圣道火故便堕恶趣受诸剧苦。诸预流者智腹净故。于人天中但受微苦。有说。预流从无量殑伽沙等。如来应正等觉圣种中生故。虽有恶业不堕恶趣。如有二人俱犯王法。一是凡庶便致重刑。一是王子但遭诃责。如是异生及预流者俱作恶业而诸异生非圣种故所造恶业招恶趣苦。一切预流是圣种故。恶业但招人天轻苦。有说。预流见境过故。虽有恶业不堕恶趣。如有二鱼俱贪钩饵。一无善巧为食吞钩丧失身命。一有善巧以尾击饵接取食之不失身命如是异生及预流者。虽俱受境作不善业。而诸异生无圣智故于所受用不见过失。深生耽着便招重苦。诸预流者有圣智故。于所受用见诸过失。不深耽着但受轻苦。有说。预流具止观故虽有恶业不堕恶趣。如瞿陀与乌俱于水上共食死尸。有人以箭射之。瞿陀无翼便没水中。乌有翼故即时飞去。如是异生及预流者。虽俱受境作不善业。为无常箭所中射时。异生无止观翼故。即便沉没恶趣水中。预流有止观翼故。便升天人涅槃空界。有说。预流及一来者。心调柔故。顺涅槃故。信种坚故。信根深故。虽有恶业不堕恶趣。譬如大海义敕众流。汝今便可漂拔诸树同集我所。众流对曰。余悉能漂唯除杨柳。海问其故。众流复言。柳具二德不可漂至。一盘根深固。二柔软随流。设鼓波涛不能漂拔。如是恶趣义敕惑流汝今可漂。诸受欲者同集我所。惑流对曰。余悉能漂。唯除二果。恶趣问其故。惑流复言。彼具二德不可漂至。一信根深固二心行调柔。鼓业波涛不能漂拔。故预流者不堕恶趣

如世尊说。我圣弟子应自审记。已尽地狱傍生饿鬼崄恶趣坑。乃至广说。问何故作此论。答欲令疑者得决定故。如世尊说。若有苾刍苾刍尼等。能随观察见自身中。有四证净现在前者。应自审记。已尽地狱傍生饿鬼崄恶趣坑。又世尊说。若有多闻诸圣弟子。能随观察见自身中。有四证净现在前者。彼圣弟子应自审记已尽地狱傍生饿鬼崄恶趣坑。有于此疑诸预流者。于自已尽地狱傍生饿鬼等事。有现量智能正知耶。为令彼知诸预流者。于前说事但由比量非现量知故作此论。诸预流者。为有现智能自审知。已尽地狱傍生饿鬼崄恶趣坑。而自记耶。答不能。若尔彼云何知。答信佛语故。谓世尊说。若有苾刍苾刍尼等。如前广说。又世尊说。若有多闻诸圣弟子。广说乃至。已尽地狱傍生饿鬼崄恶趣坑。问此中地狱傍生饿鬼已摄恶趣。何故复说崄恶趣坑。答前广后略。前别后总。前开后合。无重说过。有作是说。地狱言显地狱。傍生言显傍生。饿鬼言显饿鬼。崄恶趣坑言。显扇搋半择迦无形二形。以彼是人中崄恶趣坑故。复有说者。地狱等言显地狱等。崄恶趣坑言显造无间业者。以彼于无间生必堕地狱故。有余师说。地狱等言显地狱等。崄恶趣坑言显断善根者。以彼若不续必堕地狱故。有余师说。地狱等言显地狱等。崄恶趣坑言显不律仪者。以彼当堕诸恶趣故。或有说者。地狱等言显恶趣果。险恶趣坑言显往彼因。如世尊说汝等苾刍若见有行三恶行者。当知已见地狱傍生饿鬼恶趣。有余复说。地狱等言显三恶趣。崄言重显地狱。以地狱中无善异熟不安隐故。恶趣言显饿鬼。以彼资具恒时匮乏所趣皆恶故。坑言显傍生。以彼劫成时生劫坏时殁难可出故。有余师言。险言总显三恶趣。以三恶趣极危险故。恶趣言亦总显三恶趣。以彼所趣皆秽恶故。坑言亦总显三恶趣。以彼身心皆极下劣。居鄙秽法如粪坑故。问地狱等处有无量种苦具。现在如何。可言已尽地狱傍生鬼等。答一切圣者不生彼故。更不受彼蕴界处故说名已尽。非全令彼苦具亦无。方名已尽。问亦有异生不堕恶趣。何故但说圣者已尽。答异生不定。或有不堕。亦有堕者。以不定故不说已尽。一切圣者决定不堕是故偏说。问诸预流者于人天趣亦少分尽。何故但说尽地狱等。答诸预流者于人天趣有生不生。于地狱等决定不生是故偏说。又预流者已得四智。谓苦集灭道智。未得尽智无生智故。问何故复作此论。答欲令疑者得决定故。谓有生疑。诸预流者于已尽中但比知故。于四圣谛亦应比知。复有生疑。诸预流者已断见所断烦恼及果故。亦应已得尽无生智。为除彼疑显预流者已得四智。未得尽智及无生智。得四智故于四谛中现智证知。未得尽智无生智故。比知已尽故作斯论。问何故预流未得尽智及无生智。答尽一切生。断一切惑。办一切事。方起尽智及无生智。非预流者尽一切生。断一切惑。办一切事。是故未得尽无生智。有余师说。永尽一切界趣生处生老病死。方可证得尽无生智。非预流者永尽一切界趣生处生老病死。是故未得尽无生智

如世尊说。由学谋害那伽谛观却后七日憍萨罗家必当殄灭。云何学谋害。乃至广说。问何故作此论。答为欲分别契经义故。如契经说。苾刍当知。以害湿器坏尸罗威。由学谋害那伽谛观却后七日憍萨罗家必当殄灭。云何名为害湿器耶。谓憍萨罗主。毗卢择迦。放纵痴狂害诸释种。此诸释种是彼母亲。自小已来数同器食。世间说此为湿器。亲彼背此亲而行杀害害湿器亲故。说害湿器言。有说。应言以害湿面谓诸释种雨泪求哀。不矜湿面而行杀戮。有说。应言以害湿眼。谓诸释种悲泪盈目不生慈哀反害其命。以此业故必当殄灭。云何名曰坏尸罗威。谓坏世俗无漏戒故。学谋害者。学谓预流及一来果。彼行谋害由谋害故令彼王种不久当灭。云何名曰那伽谛观。此那伽言目阿罗汉。诸阿罗汉审谛观彼。或薄伽梵名大那伽。谓佛世尊当审谛观察。却后七日憍萨罗家必当殄灭。学谋害故。毗卢择迦却后七日种族皆尽。西方诸师作如是说。由学谋害憍萨罗家第七日中必当殄灭。今欲分别彼契经中所说义故而作斯论

云何学谋害。答如有学者。未离欲染。他加害时便作念言。当令衰坏母失爱子。问何缘学者被他害耶。答由三缘故。谓非时非处非道行故。非时行者。谓夜分中游于聚落村亭。关逻为巡候者之所捉获缚录推问种种加害。非处行者。谓入酒家淫家王家博戏家等。为监察者之所捉获。鞭挞考讯种种苦切。非道行者。谓营农月辄入园田践他苗稼。为守护者之所捉获。加诸苦楚以苦逼故。便作念言。当令衰坏母失爱子。衰坏者谓死灭。母子乖离故名母失爱子。问学者已得不作律仪。何故乃作如是谋害。答彼由苦逼便于自身起如是念。宁当令我衰坏失爱。勿令我为斯苦所逼。不于他身是以无过。有说。于他亦起斯念。然但欲诃责不欲加害。所以者何。若彼了知由此谋害。下至能杀一蚁卵者。设救自命亦不起此心。故此所念但为诃责。问此学谋害为但作念。为亦发言。有说。但念而不发言。有说。发言亦无有过。为诃责故非加害故。所以者何。若彼了知由此语业。下至能害一蚁卵者。设救自命尚不起心况起语业。问若城邑等父母所居。学者于中起谋害不。有说。不起。有说。亦起。但为诃责。广说如前。又如学者已离欲染。他加害时从离欲退作是念言。当令衰坏母失爱子。问彼为退已发此心言。为未退时起此谋害。若彼退已发此心言。便无威力所作谋害云何速成。若未退时起此谋害。既无欲恶。如何起此谋害心言。答应作是言。彼必退已。问既无威力如何速成。答未离欲时威力微劣。起多心念谋害方成。离欲退时胜道余势。资彼心愿谋害速成。有作是说。彼未退位天龙神鬼敬德归诚。彼遇苦缘退行谋害。天等助力令事速成。问不还退时既行谋害。阿罗汉退亦谋害耶。答无学退时不行谋害。由果殊胜虽暂退时行相作业不同学退。问无学退已谋害尚无。况未退时得有谋害。若尔经说当云何通如说羯洛迦孙驮佛诃叱度使魔罗。应时彼魔陷入地狱。答但为诃责不欲加害。然彼业尽自堕地狱曾闻彼佛将一侍者。名曰至远。入娑罗村次第乞食。时魔度使化作少年。掷石遥打侍者。头破血流被面。随佛后行。时佛右旋如象王。顾见如是事。诃叱魔言。汝何非分造斯恶业。魔时业尽便堕地狱。故但诃责非欲加害

问诸学谋害为但自为亦为他耶。答有亦为他。如昔于此迦湿弥罗国有王都名婫逻吒。去城不远有僧伽蓝。名曰石崖。中有苾刍是阿罗汉。僧伽蓝侧自染袈裟。城中人有失一犊子。寻访至此。遥问苾刍见犊子不。答言不见。彼渐前行。苾刍业力令彼人见。衣似牛皮染汁如血。煮札似肉器如牛头。见已惊怒叱言大贼。如何苾刍盗我犊子而复屠杀。遂加楚挞缚送王所。王付法司禁闭牢狱。以彼业力令诸门人。虽历多时而无忆者。恶业尽已彼诸门人皆生忆念。我师何在寻访乃知禁在牢狱。便共白王我师无辜枉禁多岁。愿王照察放我等师。王敕法司速宜放出。彼阿罗汉在禁多时。衣坏发长无沙门像。法司巡察不见苾刍。寻还白王无此囚类。门人重启师定在中。囚絷多年失沙门相。愿于禁所令宣告言。谁是沙门王恩放出。王如其语寻令宣告。彼阿罗汉恶业既尽。才闻唤声如睡梦觉。以神通力上升虚空。犹如雁王翔空而住。王见是已投身闷绝。冷水洒面良久乃稣。自伤无知枉禁圣者。当堕恶趣无有出期。遂与群臣仰空礼谢。唯愿圣者哀恕我愆。时阿罗汉俯而告曰。吾于汝等曾不生嗔。王曰。若然请垂摄受。尊者慈愍下降王宫。王及群臣欢喜赞礼。为剃须发奉上新衣。并彼门人广设供养。香花翼从送往伽蓝。彼门徒中多诸圣者。时阿罗汉勖众而言。以我宿殃横遭拘絷。勿以恶意。观彼王都。时有勤策得预流果。其身在远不闻此言。后随苾刍入王都邑。见师禁处窃起害心。此非法城抂禁亲教。绵历岁序备受艰辛。哀哉苦毒诚为难忍。时有非人敬信三宝。知勤策念于此夜中。雨土满城一切堙灭。又即此国昔有王都。名曰善坚去城不远。有僧伽蓝名战主迦。中有苾刍是阿罗汉。入深静虑不掩户扇。城中有人妻叛投寺。见僧入定藏窜床下。其夫寻后入寺问僧。僧不审察。答言不见。夫遂遍求床下捉得夫乃嗔骂云。贼苾刍。如何沙门辄藏我妇纵情。楚挞缚送王所。王付法司广如前说。与前别者。有晚出家证预流果。而行谋害非人纵火。烧灭王都故知亦有为他谋害

问诸学谋害其体是何。答嗔相应思是谋害体。内法名谋害。外法名意愤。外仙意愤令村无村。令城无城。令国无国。由斯彼触害生命罪。问何故俱令村等殄灭。外仙得罪内则不尔答外无圣道。内有圣道外阙止观。内具止观。外为加害内为诃责。外亦起加行。内但发心言。是故外仙得罪非内。问诸学谋害必果遂耶。答此不决定。若诸有情造作增长。大威势业异熟现前便不果遂。如昔有一婆罗门王名补沙友憎嫉佛法。焚烧经典。坏窣堵波破僧伽蓝害苾刍众。于迦湿弥罗国一边境中。破五百僧伽蓝况于余处。恶魔方便使鸠叛荼药叉鬼神冥助威势。令所往处无能拒者。渐灭佛法至菩提树。菩提树神名为谛语。作如是念。今此恶王甚大愚暴。将欲毁坏殑伽沙等诸佛世尊。破恶魔军成妙觉处。即自化现殊胜女身。伫立其前。彼王见已寻生贪染。护法善神遂得其便。杀王及军并恶神众无得免者。时佛法中有多学者。虽作谋害无一得成。由彼国王福力大故。又如昔者达刺陀王。入迦湿弥罗国。毁灭佛法。杀苾刍众坏窣堵波。破僧伽蓝焚烧经典。尔时彼国有多贤圣。虽起谋害亦无成者。由彼恶王福力大故。由此故说。若诸有情造作增长大威势业。异熟现前便不果遂

说一切有部发智大毗婆沙论卷第一百二十五阿毗达磨大毗婆沙论卷第一百二十六

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    业蕴第四中自业纳息第五之三

云何苾刍留多寿行。乃至广说。问何故作此论。答为欲分别契经义故。如契经说。时薄伽梵留多命行。舍多寿行。又欲分别毗奈耶义故。如毗奈耶说。大生主为首。五百苾刍尼留多命行舍多寿行。经毗奈耶虽有是说。而未分别留舍因缘。彼经及毗奈耶是此论根本。彼未说者今应说之。故作斯论。又诸造论皆为分别诸所有法自相共相。今此亦然。不应为问

云何苾刍留多寿行。答谓阿罗汉成就神通得心自在。若于僧众若别人所。以衣以钵。或以随一沙门命缘众具布施施已发愿即入边际第四静虑。从定起已心念口言。诸我能感富异熟业。愿此转招寿异熟果。时彼能招富异熟业。则转能招寿异熟果。问彼有何缘留多寿行。答留多寿行。略有二缘。谓为饶益他及住持佛法。为饶益他者。谓教弟子修诸观行。彼审观察齐我寿住。此诸门人逮胜法不。设我寿尽为更有余。能善开示道非道不若见无能便留寿行。为住持佛法者。谓营佛像僧房等事。彼审观察齐我寿住。此所营事得成办不。设我寿尽为更有余善巧方便能成办不。若见无能便留寿行。又彼观见当有国王大臣长者等欲毁灭佛法。便审观察齐我寿住当有方便令不毁灭不。设我寿尽为更有余善巧方便能住持不。若见无能便留寿行为留寿行。以衣钵等施僧别人。依契经说。谓世尊说。若有施主能施他物名施五事。由此还当得五事果。一寿二色三力四乐五辩。彼审观察为施僧众。当获大果为施别人。若见施僧当获大果便施与僧。若施别人当获大果便施别人。是故于僧或别人所以衣以钵。或以随一沙门命缘众具布施。施已发愿即入边际第四静虑。从定起已心念口言。诸我能感富异熟业。愿此转招寿异熟果。时彼能招富异熟业则转能招寿异熟果

问理无富异熟果可成寿异熟果。何故乃说富异熟业。则转能招寿异熟果。答无转果体。有转业力。谓由布施边际定力。转富异熟业招寿异熟果。虽俱可转而彼今时不顾富果。祈寿果故。有余师说。有业先感寿异熟果。然有灾障由今布施边际定力。彼灾障灭寿异熟起。虽俱可转而彼今时不顾富果。祈寿果故。有作是说。有业先招寿异熟果。然不决定由今布施边际定力。令招寿业决定与果。复有欲令由施定故引取宿世残寿异熟。谓阿罗汉有余生中残寿异熟。由今布施边际定力引令现前定力不思议令久断还续

问所留寿行正由谁引。为由施力为定力耶。若由施力不应入定。若由定力不应行施。有说由施。有说由定。如是说者。俱由二种。虽多行施若不入定彼终不能引寿果故。虽数入定若不行施彼终不能引寿果故。然施力能引定力令决定。由此故言俱由二种。云何苾刍舍多寿行。答谓阿罗汉成就神通得心自在。如前布施。施已发愿即入边际第四静虑。从定起已心念口言。诸我能感寿异熟业。愿此转招富异熟果。时彼能招寿异熟业。则转能招富异熟果。问彼有何缘舍多寿行。答自利利他俱究竟故。已得尽智故名自利究竟。于利他事。若有堪能此事成已便归圆寂。若无堪能亦名究竟。有作是说。彼厌自身犹如毒器。故愿弃舍。如有颂言

  梵行妙成立　　圣道已善修
  寿尽时欢喜　　犹如舍毒器

为舍寿行以衣钵等施僧别人。依契经说。谓世尊说诸福业事略有三种。一施性福业事。二戒性福业事。三修性福业事。于施性事。若习若修。若多所作。感大富果。乃至广说。彼审观察为施僧众当获大果为施别人。若见施僧当获大果便施与僧。若施别人当获大果便施别人。故于僧众或别人所。以衣以钵。或以随一沙门命缘众具布施。施已发愿即入边际第四静虑。从定起已心念口言。诸我能感寿异熟业。愿此转招富异熟果。时彼能招寿异熟业。则转能招富异熟果。问理无寿异熟果可成富异熟果。何故乃说寿异熟业。则转能招富异熟果。答无转果体。有转业力。谓由布施边际定力。转寿异熟业招富异熟果。虽俱可转而彼今时不顾寿果。祈富果故。有余师说。有业先感富异熟果。然有灾障。由今布施边际定力彼灾障灭富异熟起。虽俱可转而彼今时不顾寿果。祈富果故。有作是说。有业先招富异熟果。然不决定。由今布施边际定力。令招富业决定与果。复有说者。有业先招富异熟果粗而非妙。由今布施边际定力。令感粗业转招妙果。谓彼先引长时粗果。今由施定祈愿力故。令彼转招今时妙果。复有欲令由施定故引取宿世残富异熟。谓阿罗汉有余生中残富异熟。由今布施边际定力引令现前。定力不思议令久断还续

问此富异熟正由谁引。为由施力为定力耶。若由施力不应入定。若由定力不应行施。有说由施。有说由定。如是说者俱由二种。虽多行施若不入定彼终不能引富果故。虽数入定若不行施。彼终不能引富果故。然施力能引定力令决定。由此故言俱由二种。问若诸有情寿果富果不决定者可有留舍。若俱决定如何留舍。答但作分限无留舍事。譬如良医所记分限无能过者。此亦应然。尊者妙音作如是说。彼阿罗汉由起边际。第四定力。引色界大种令身中现前。而彼大种有顺寿行有违寿行。由此因缘或留或舍。有作是说。彼阿罗汉由此自在三摩地力。转去曾有宿业所生诸根大种住时势分。引取未曾定力所起诸根大种住时势分。彼说不然。命根别有非根大种为自性故

经说世尊留多命行。舍多寿行其义云何。有作是说。诸佛世尊舍第三分寿。有作是说。诸佛世尊舍第五分寿。若说诸佛舍第三分寿者。彼说世尊释迦牟尼寿量应住百二十岁。舍后四十但受八十。问佛出世时此洲人寿不过百岁。何故世尊释迦牟尼寿百二十。答如佛色力种姓富贵徒众智见胜余有情。寿量亦应过众人故若说诸佛舍第五分寿者。彼说世尊释迦牟尼所感寿量应住百岁。舍后二十但受八十。问诸佛色力种姓富贵徒众智见胜余有情。何故寿量与众人等。答生在尔所寿量时故。由此经言舍寿行者。谓舍四十或二十岁留命行者。谓留三月。问何故世尊留舍尔所命行寿行不增减耶。答诸佛事业善究竟故。齐尔所时诸佛事业得善究竟故不增减。有说。法尔诸佛世尊唯舍唯留尔所寿命。有说。欲显诸佛世尊不贪寿命能早弃舍。诸余有情贪寿命故不能弃舍。勤求圆寂勿有生疑。佛亦如是。故舍寿行。显异有情化事未终复留三月。有说。欲显诸佛世尊善住圣种故舍寿行。谓如世尊于有有具深生喜足于寿亦然。有说。世尊避衰老位故舍寿行。所化有情事未究竟复留三月。如邬陀夷一时为佛按摩支体见异常相。而白佛言。今者世尊。支体舒缓诸根变异。容貌改常。今位尚然。况过八十。故避衰老舍多寿行。有说。欲显得定自在故。佛世尊留舍寿命。如世尊说。我善修行四神足故欲住一劫或一劫余。如意能住。有说。欲显诸佛世尊能伏众魔留舍寿命。谓证无上妙菩提时已伏二魔。谓天烦恼。今将证入涅槃界时又伏二魔。谓蕴及死。伏蕴魔故舍多寿行。伏死魔故留多命行。问命行寿行有何差别。有说无别。如品类足说。云何命根。谓三界寿。有说。此二亦有差别。谓名即差别。名为命行名寿行故。有说。由此故活名命行。由此故死名寿行有说。所留名命行。所舍名寿行。有说。可生法名命行。不可生法名寿行。有说。暂时住名命行。一期住名寿行。有说同分名命行。彼同分名寿行。有说。修果名命行。业果名寿行。有说。无漏业果名命行。有漏业果名寿行。有说。明果名命行。无明果名寿行。有说。新业果名命行。故业果名寿行。有说。与果业果名命行。不与果业果名寿行。有说。近业果名命行。远业果名寿行。尊者妙音作如是说。顺现受业果名命行。顺次生受。顺后次受。顺不定受业果名寿行。命行寿行是谓差别问多行言有何义。答多言显示所留所舍非一刹那。行言显示所留所舍是无常法。问何处留舍命行寿行。答在欲界非余界。在人趣非余趣。在三洲非北洲。问谁能留舍命行寿行。答是圣者非异生。是无学非有学。是不时解脱非时解脱。亦男亦女

云何心狂乱。乃至广说。问何故作此论。答为释契经毗奈耶故。如契经说。婆私瑟搋婆罗门女丧六子故。心发狂乱露形驰走。见世尊已还得本心。毗奈耶说。室利筏蹉心狂乱故。行无量种非沙门法不顺法行。毗奈耶中又作是说。苦受所逼若心狂乱。及初业位皆无有犯。契经毗奈耶虽作是说。而不广辩。今为广辩故作斯论

云何心狂乱。答谓由四缘势力所逼令心狂乱。一由非人现恶色像。遇已惊恐令心狂乱。谓有非人变作象马驼牛羊等可畏色相。来现其前心便狂乱。问彼曾不见象马等耶。何故今时见便惊恐。答彼虽曾见而今非时非处非道忽然见故。言非时者。谓于夜分见象马等便作是念。何故今时有象马等来至我所。定是非人来相逼害。由此惊恐心便狂乱。言非处者。谓于堂阁房阁等处见象马等便作是念。何缘此处有象马等。定是非人来相逼害。由此惊恐心便狂乱。言非道者。谓于冢间非象马等尝所行路。见象马等便作是念。何缘于此有象马等。定是非人来相逼害。由此惊恐心便狂乱。二由非人忿打支节。苦受所逼令心狂乱。谓于大众游止处所。以轻慢心弃诸便秽。或于诸佛独觉声闻精舍等中。行不净行善神忿恚打触支节。人有支节如芥子许。若打触时心便狂乱。三由大种乖违令心狂乱。谓有多食胡桃麻子苣藤等时。发热风等大种乖反心便狂乱。四由先业异熟令心狂乱。谓有先时欢喜踊跃。传惊怖事令他忧恼。或作坑阱陷坠众生。或纵猛火焚烧山泽。或以强力逼他饮酒。或以倒想解释契经。如是等业令心狂乱。然此狂乱非异熟果。但从恶业异熟所生。以恶业不招意地异熟故。有说。狂乱由五种缘。前四如前。愁忧第五。谓因丧失所爱子等。愁毒缠心遂发狂乱

问此心狂乱于何处有。答于欲界有。非色无色界。然地狱无。心常乱故。心狂乱者。谓时非恒鬼及傍生有心狂乱。人天亦有。除北俱卢。彼无罪业增上果故。问此心狂乱谁有谁无。答圣者异生俱容得有。圣通众圣唯除诸佛。佛无心乱无坏音声。无断末磨。无渐舍命。异生心乱具由五缘。圣者但由大种乖适。圣无惊恐。超五畏故。无非人打。无秽事故。亦无先世恶业异熟。以决定业必先受已方入圣故。不决定业。由圣道力已转灭故。亦无愁忧。证法性故。有说。圣者乱由二缘。谓大种乖违。及非人所打。问圣者已得不作律仪。定无秽事非人何忿。答信佛法者敬重众圣终不恼触。有不信者憎嫉众圣。伺便恼触。故圣亦为非人所打

问住何等心得有狂乱。答住有漏非无漏。住意识非五识。问若尔。何缘见二月等。答此等皆是意识分别非五识中有斯乱解。问为未狂心说有狂乱。为已狂心说有狂乱。答非未狂心说有狂乱。亦非已狂心说有狂乱。然有狂乱心。无狂乱心。住未来世。若遇狂乱缘则无狂心灭。有狂心起。若遇不狂乱缘。则有狂心灭。无狂心起

问若心狂乱亦散乱耶。答应作四句。有心狂乱非散乱。谓狂者无染心。有心散乱非狂乱。谓不狂者有染心。有心狂乱亦散乱。谓狂者有染心。有心非狂乱亦非散乱。谓不狂者无染心现前

何缠相应法皆是不善耶。答谓无惭无愧。问缠有十种。何故唯说无惭无愧。答是作论者意欲尔故。乃至广说。有说。此二唯是不善。亦与一切不善心俱。忿覆悭嫉虽但不善而非一切不善心俱。惛沉掉举虽与一切不善心俱。非唯不善。以通不善无记性故。睡眠恶作非唯不善。亦非一切不善心俱。睡眠通三性。恶作通二性故。觉无悔恶心。此二不行故。诸不善心中皆有无惭无愧。诸无惭无愧皆不善心俱互不相离。是故偏说。此中亦应问何善相应法皆是善耶。答谓惭愧。以惭愧与善心更互相随不相离故。而不说者。非独此二唯善性摄。遍善心故

佛教云何。乃至广说问何故作此论。答为止于非佛教起佛教想故。如今有言。我说佛教。我闻佛教。彼于非佛教中起佛教想。为欲遮止如是想故。及为显示佛所说者是真佛教。余所说者非真佛教。故作斯论。问今时何故有作是言。我说佛教。我闻佛教。答彼依根本故作是说。谓今所说染净缚解生死涅槃因果等法。根本皆是佛所说故。有说。彼依相似而说。谓佛先依如是次第名句文身为他演说。今亦复依如是次第名句文身而宣说故有说。彼依随顺而说。谓佛先依如是随顺名句文身为他演说。今亦复依如是随顺名句文身而宣说故。有说。彼依办事处同故作是说。谓如佛边亲闻法要。入圣得果离染尽漏。闻今所说亦办斯事

佛教云何。答谓佛语言唱词评论语音语路语业语表。是谓佛教。问何故佛教唯是语。表非无表耶。答生他正解故名佛教。他正解生但由表业非无表故。有说。佛教耳识所取非无表业可耳识取故非佛教。有说。佛教二识所取诸无表业唯一识取。故非佛教。有说。世尊三无数劫精勤苦行求佛语表。今得成满。非无表故。谓佛世尊昔于无量正等觉所精勤苦行求无上智。为他说法。依蕴界处求蕴界处。展转相续今得成佛。为诸有情演说法要。令舍生死得般涅槃。此事皆由佛语表业。是故佛教唯佛语表

问如是佛教以何为体。为是语业。为是名等。若是语业。次后所说当云何通。如说佛教名何法。答谓名身句身文身。次第行列。次第安布。次第连合。伽他所说复云何通。如说欲为颂因文即是字。颂依名转。造者为依。若是名等此文所说当云何通。如说佛教云何。谓佛语言乃至语表。是谓佛教。答应作是说。语业为体。问若尔。次后所说当云何通。如说佛教名何法。答谓名身句身乃至广说。答后文为显佛教作用。不欲开示佛教自体。谓次第行列安布连合。名句文身是佛教用。问伽他所说复云何通。答有于名转。有于义转。此中且说于名转者。有说。佛教名等为体。问若尔。此文所说当云何通。如说佛教云何。谓佛语言。乃至广说。答依展转因故作是说。如世子孙展转生法。谓语起名。名能显义。如是说者语业为体。佛意所说他所闻故

佛教当言善耶。无记耶。乃至广说。问何故复作此论。答前虽显示佛教自体。而未显示佛教等起。今欲显示故作斯论。佛教当言善耶。无记耶。答或善。或无记。云何善。谓佛善心所教语言乃至语表。云何无记。谓佛无记心所发语言乃至语表。问于佛教中何者善。何者无记。答阿毗达磨。素怛缆藏。多分是善。毗奈耶藏多分无记。如世尊说。门应关闭。衣钵应置竹架龙牙。如是等言皆无记故。有说。佛教若为所化说应知是善。若为余事说是则无记。如世尊告阿难陀言。汝往观天为雨不雨。园中何故高声大声。如是等言皆无记故。有说。佛教若用功说应知是善。若任运说是则无记。有说。佛教力无畏等所摄受者应知是善。力无畏等不摄受者是则无记

声闻独觉善心发语。善无记心俱得究竟。无记心发语无记善心俱得究竟。佛善心发语善心究竟。无记心发语无记善心俱得究竟。定无善心发语无记心究竟。诸佛说法有增无减故。佛所作业定无萎退故

佛教名何法。乃至广说。问何故复作此论。答前虽显示佛教自体。而未显示佛教作用。今为显示故作斯论

佛教名何法。答谓名身句身文身。次第行列。次第安布。次第连合。此则总显。佛教作用。契经。应颂。记说。伽他。自说。因缘。譬喻。本事。本生。方广。希法。论议。名何法。答谓名身句身文身。次第行列。次第安布。次第连合。是名佛教作用差别。契经云何。谓诸经中散说文句。如说诸行无常。诸法无我。涅槃寂静等。问契经有何义。答此略说有二义。一结集义。二刊定义。结集义者。谓佛语言能摄持义。如花鬘缕。如结鬘者以缕结花冠众生首久无遗散。如是佛教结集义门。冠有情心久无忘失。刊定义者。谓佛语言能裁断义。如匠绳墨。如工巧者绳墨众材。易了正邪去曲留直。如是佛教刊定义门。易了是非去恶留善。应颂云何。谓诸经中依前散说契经文句后结为颂。而讽诵之。即结集文结集品等。如世尊告苾刍众言。我说知见能尽诸漏。若无知见能尽漏者。无有是处。世尊散说。此文句已复结为颂。而讽诵言

  有知见尽漏　　无知见不然
  达蕴生灭时　　心解脱烦恼

记说云何。谓诸经中诸弟子问如来记说。或如来问弟子记说。或弟子问弟子记说。化诸天等问记亦然。若诸经中四种问记。若记所证所生处等。伽他云何。谓诸经中结句讽颂彼彼所说即驎颂等如伽他言

  习近亲爱与怨憎　　便生贪欲及嗔恚
  故诸智者俱远避　　独处经行如驎角

自说云何。谓诸经中因忧喜事世尊自说。因喜事者。如佛一时见野象王。便自颂曰

  象王居旷野　　放畅心无忧
  智士处闲林　　逍遥志恬寂

因忧事者。如佛一时见老夫妻。便自颂曰

  少不修梵行　　丧失圣财宝
  今如二老鹤　　共守一枯池

因缘云何。谓诸经中遇诸因缘而有所说。如义品等种种因缘。如毗奈耶作如是说。由善财子等最初犯罪。是故世尊集苾刍僧制立学处

譬喻云何。谓诸经中所说种种众多譬喻。如长譬喻大譬喻等。如大涅槃持律者说本事云何。谓诸经中宣说前际所见闻事。如说过去有大王都。名有香茅。王名善见。过去有佛。名毗钵尸。为诸弟子说如是法。过去有佛。名为式企毗湿缚浮羯洛迦孙驮羯诺迦牟尼迦叶波。为诸弟子说如是法。如是等。本生云何。谓诸经中宣说过去所经生事。如熊鹿等诸本生经。如佛因提婆达多说五百本生事等

方广云何。谓诸经中广说种种甚深法义。如五三经梵网幻网五蕴六处大因缘等。胁尊者言。此中般若说名方广。事用大故希法云何。谓诸经中说三宝等甚希有事。有余师说。诸弟子等赞叹世尊希有功德。如舍利子赞叹世尊无上功德。尊者庆喜赞叹世尊甚希有法。论议云何。谓诸经中决判默说大说等教。又如佛一时略说经已。便入静室宴默多时。诸大声闻共集一处。各以种种异文句义。解释佛说

书名何法。乃至广说。问何故作此论。答欲令疑者得决定故谓此论中广辩胜义自性差别勿有生疑。作此论者唯善胜义不闲世俗。为显论者胜义世俗俱善了达故作斯论

书名何法。答谓如理转变身业及此所依诸巧便智。此中书者非所造字。但是所有能造字法。此能成字故说为书。如理转变身业者。显所起果即是色蕴所依。巧便智者。显能起因即是四蕴。如是五蕴为书自性

数名何法。答如理转变意业。及此所依诸巧便智。此中数者。非谓所数稻麻等物百千等数。但是所有能数之法。此能数法故说为数。佛弟子中尊者庆喜善解数法余所不过。曾于一时为乞食故。执持衣钵趣广严城。时城门前有一外道。遥见庆喜窃作念言。承此沙门解数第一。吾今当试为实尔耶。时城门边有一大树。枝叶繁茂名诺瞿陀。外道趋前指树而问。汝今知此叶数几何。尊者仰顾寻答之曰。今此树叶若干百千。言已入城。于后外道作是思惟。何理验知彼言虚实。便取少叶而藏匿之。庆喜出城外道重问。仁向所数为定几何。庆喜报言。吾前已说。外道复曰。请重陈之。尊者看树寻复答曰。先有尔所今少若干。外道欣然谢而叹曰。知数第一信唯其人。又如波罗衍拏。才见佛颔便言此决定有妙齿四十。如斯解数其类寔多。如理转变意业者。显所起果。所依巧便智者。显能起因如是四蕴为数自性

算名何法。答谓如理转变语业。及此所依诸巧便智。此中算者。非谓所算一十百千万亿等法。但是所有能算之法。此能算法故说为算。如理转变语业者。显所起果即是色蕴。所依巧便智者。显能起因即是四蕴。如是五蕴为算自性

印名何法。答谓如理转变身业。及此所依诸巧便智。此中印者非所造印。但是所有能造印法。此能成印故说为印如理转变身业者。显所起果即是色蕴。所依巧便智者。显能起因即是四蕴。如是五蕴为印自性诗名何法。答谓如理转变语业。及此所依诸巧便智。此中诗者非所述咏。但是所有能成咏法。此能成咏故说为诗。如理转变语业者。显所起果即是色蕴。所依巧便智者。显能起因即是四蕴。如是五蕴为诗自性。问于诸文颂何者是诗。何者非诗。有作是说。佛语非诗。余语是诗。有余师说。内教非诗。外教是诗。如是说者。文义相称能引义利不名为诗。诗谓翻此世间文颂

世间种种工巧业处名何法。乃至广说。问何故作此论。答欲以略文摄多义故。谓若随诸工巧业处而广说者生多言论。欲以略言类摄彼故而作斯论。世间种种工巧业处名何法。答谓慧为先造作彼。彼工巧业处。及此所依诸巧便智。此中不辩所造作事。但为显示能造作法。造作彼彼工巧业处者。显所起果身语意业随其所应。所依巧便智者。显能起因。如是或以五蕴。或以四蕴为其自性

处处说威仪路。及起威仪路。威仪路者。谓色香味触四处为体。起威仪路者。谓能起彼意法二处为体。眼鼻舌身四识是威仪路加行。非起威仪路。意识是威仪加行。亦是起威仪路。又眼等四识能缘。威仪路。不能缘起威仪路。意识能缘威仪路。亦能缘起威仪路。有余由此所引意识。具能缘十二处。处处说工巧处。及起工巧处。工巧处者。谓色声香味触五处为体。起工巧处者。谓能起彼意法二处为体。眼等五识是工巧处加行。非起工巧处。意识是工巧处加行。亦起工巧处。又眼等五识能缘工巧处。不能缘起工巧处意识能缘工巧处。亦能缘起工巧处。有余由此所引意识。具能缘十二处

若成就学戒。彼成就非学非无学戒耶。答应作四句。有成就学戒非非学非无学戒。谓学者生无色界。彼世俗戒越界地舍故。有成就非学非无学戒非学戒。谓阿罗汉及诸异生。生欲色界。诸阿罗汉在欲色界。定成就非学非无学戒。定不成就学戒。已舍故。若诸异生在欲色界。或成就非学非无学戒。一切异生定不成就学戒。未得故。有成就学戒亦非学非无学戒。谓学者生欲色界。一切学者在欲色界。定成就非学非无学戒及学戒。未舍故。有非成就学戒亦非非学非无学戒。谓阿罗汉及诸异生。生无色界。生彼阿罗汉定不成就学戒。已舍故。生彼异生定不成就学戒。未得故。彼二世俗戒俱不成就。越界地舍故

若成就无学戒。彼成就非学非无学戒耶。答应作四句。有成就无学戒非非学非无学戒。谓阿罗汉生无色界。彼世俗戒越界地舍故。有成就非学非无学戒非无学戒。谓诸学者。及诸异生生欲色界。学者在欲色界。定成就世俗戒。异生在欲色界。或成就世俗戒。彼俱不成就无学戒。俱未得故。有成就无学戒亦非学非无学戒。谓阿罗汉生欲色界。有非成就无学戒亦非非学非无学戒。谓诸学者及诸异生。生无色界。彼无学戒。俱未得故。彼世俗戒俱已舍故

问诸是戒彼业耶。答诸是戒彼即业。有是业非戒。谓意业等。问若处有戒。彼有业耶。答若处有戒彼有业。或处有业无戒。谓无色界等。问若成就戒。彼成就业耶。答若成就戒。彼成就业。有成就业非戒。谓异生生无色界等。问若有戒。彼有业耶。答若有戒彼有业。或有业无戒。谓诸异生生无色界等

说一切有部发智大毗婆沙论卷第一百二十六阿毗达磨大毗婆沙论卷第一百二十七

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    大种蕴第五中大造纳息第一之一

大种所造处。几有见。几无见。如是等章及解章义。既领会已。应广分别。问何故作此论。答为欲分别契经义故。如契经说。诸所有色皆是四大种。及四大种所造。虽作是说而未广辩。大种所造处。几有见。几无见。乃至广说。经是此论所依根本。彼未说者今应说之。故作斯论。有说。为止余师所说。谓此部内有二论师。一者觉天。二者法救。觉天所说色唯大种。心所即心。彼作是说。造色即是大种差别。心所即是心之差别。彼何故作是说。依契经故。如契经说。眼肉团中。若内各别坚性坚类。近有执受名内地界。乃至各别动性动类。近有执受名内风界。彼依此经故说造色即是大种。又契经说云何等持。谓善心一境性。由此故说心所即心问彼复云何立界处蕴耶。答彼作是说诸四大种。有是能见。有是所见。乃至有是能触。有是所触。诸能见者立为眼界。诸所见者立为色界。乃至诸能触者立为身界。诸所触者立为触界。心中有依眼根。乃至有依意根。依眼根者立眼识界。乃至依意根者立意识界。即六识身无间已灭立为意界。即心差别有名为受。有名为想。有名为思。并三无为立为法界。如界处亦尔。蕴者。诸四大种立为色蕴。诸心差别有名为受。有名为想。有名为思有名为识。立为四蕴。问彼云何通契经所说。诸所有色皆是四大种。及四大种所造。答彼作是说。非所造声离四大种别有所因即于大种立所造声。云何知然。如契经说。苾刍当知。触由二缘。所谓眼色乃至意法。有六触处是先所为是先所造。我说即是故业。应知无闻异生由此所触受乐受苦。由此所造或此随一。非离前六触处别有第七触处而可于中立所造声。即于前六说为所造。前经亦然。非离大种别有所造。即于大种立所造声。于我非难阿毗达磨诸论师言。彼所引经别有密意。不可引证前所引经。彼经前说六触处者。谓密意说未明了位。后言由此所造或此随一者。谓密意说已明了位。如未明了位已明了位。如是无分别位有分别位。未可显位已可显位。未可说位已可说位。应知亦尔。又六触处者说中有位。由此所造等者说本有位。尊者妙音说曰。彼经前说六触处者。谓密意说根无缺位。后说由此所造等者谓密意说根有缺位。胁尊者言。有六触处者密意说欲界。由此所造者。密意说色界。或此随一者。密意说无色界。经义如是。云何可证前经所说所造色言。又所造言若无异者。余经所说。复云何通如契经说。尊者圆满告尊者庆喜言具寿当知。所有我执谁之所造。是色所造。是受想行识所造我执即是萨迦耶见。若所造言无别义者。岂可身见即是色等。然离色等别有我执。故知经说所造色者非即大种。问若离大种别有造色。如何会释彼所引经。于眼肉团中有地界等。答彼经说眼根所依大种不说眼体。又彼经说世所共知肉团名眼。非说眼根。世于肉团眼想转故。尊者妙音亦作是说。世于大种立眼根名。以是眼根所依止故。有余师说。彼所引经于义无妨。彼经但说眼肉团中有地等界。不言地等即是眼根。于义何妨。尊者法救说。离大种别有造色。说心所法非即是心。然说色中二非实有。谓所造触及法处色。立蕴处界如对法宗。彼亦不然。诸所造触如余造色应别有故。若无法处所摄色者无表戒等不应有故。欲止如是二师所说故作斯论。有说。为止外道所说。谓外道说大种有五。即前四及虚空。今但说四明虚空非大种。问何故虚空不立大种。尊者世友作是释言。以虚空无大种相故。谓有增有减是大种相。无增无减是虚空相。有损有益。是大种相。无损无益是虚空相有兴有衰是大种相。无兴无衰是虚空相。是故虚空不立大种。尊者妙音作如是释。虚空大种其相各异。谓有情身中所有大种。多是先业异熟所生。虚空体无异熟生义。由此虚空不立大种。大德说曰。虚空虽大而体非种。不能生故。余有为法虽能为种而体非大。相不遍故。由此虚空不立大种。为止如是外道所执及显自宗故作斯论。有余师说。非但为止他执显自宗故而作此论。但于法相相应义中应显所明故作斯论。问何故此中先辨大造。答彼作论者意欲尔故。谓本论师随自意欲不违法相先辨大造。有说。有情观此二种为入佛法真甘露门。一不净观。二持息念。不净观观造色。持息念观大种。有说。若观大种造色渐次能证佛独觉声闻三种菩提。谓若以上智观察彼者。起上品身念住。从此次起上品受念住。次心。次法。次起杂缘。次暖顶忍世第一法。次起见道。乃至起无学道。皆以上品。尔时名为上品善士。证得无上正等菩提。若以中智观察彼者。起中品身念住。广说乃至起无学道皆以中品。尔时名为中品善士。证得中品独觉菩提。若以下智观察彼者。起下品身念住。广说乃至起无学道。皆以下品。尔时名为下品善士。证得下品声闻菩提。有说。若观大种造色。便能降伏一切憍逸。谓诸有情以色族姓财宝自在眷属等故生诸憍逸。若未观察大种等时。随一现前势力强盛。若观察已便能降伏。所以者何如轮王身所有大造。狗等所有大造亦然。由观此故便舍憍逸。以如是等所说因缘。故此蕴中先辨大造

契经中说诸所有色。皆是四大种及四大种所造。诸所有言。总有二种。一有余义。二无余义有余义者。如世间说诸所有食我尽欲啖。此但欲啖随得少分。无余义者。如世间说诸所有法我尽欲知。此总欲知一切法相。此中所说诸所有言。总显一切色法皆尽。谓所有色。总有二种。一四大种。二所造色。除此更无第三色体。问何故大种唯四。胁尊者曰。此不应责。所以者何。若增若减俱亦生疑。不以疑故便违法相。但随圣教唯说四种。有余师言。若减四者功用便阙。若过四者则亦无用。如方床座唯有四足。问何故名大种。答大而是种。故名大种。如言大地。如言大王。义别体同。应持业释。问云何大义。云何种义。答能减能增能损能益体有起尽。是为种义体相形量遍诸方域成大事业。是为大义。问此四云何成大事业。答与大积聚造色为依。令坏令成是大事业。由此唯四不减不增。谓减不能成大事业增于事业复为无用。问余法何缘不名大种。答余无如是大种相故。谓无为法大而非种。其余有为种而非大故。唯此四得名大种

问造是何义。为是因义是缘义耶。设尔何失。俱见其过。若是因义。此四大种于所造色五因皆无。如何可言能造诸色。若是缘义诸所造色各除自体。余一切法无不皆是此增上缘。如何但言大种所造。答应作是说造是因义。问此于造色五因皆无。如何因义。答虽同类等五因皆无。而别有余五种因义。谓生因依因立因持因养因。由此能造。有余师言。造是缘义。问诸所造色各除自体余法皆是此增上缘。如何但言大种所造。答增上缘义。有亲有疏。有近有远。有合不合。有在此生。有在余生。诸亲近合在此生者说名为因。疏远不合在余生者说名为缘。由此义故说诸大种与所造色为因增上。亦不违理

问地水火风何相何业。答坚是地相。持是地业。湿是水相。摄是水业。暖是火相。熟是火业。动是风相。长是风业。问地是坚相亦是色相。广说乃至。风是动相亦是色相。如何一法有二相耶。答有亦无失。由此理趣于一法中。可得施设有多相故。如一有漏法。即有如病如痈等。广说乃至。百四十句诸过患相而无有失。此亦如是。有余师言。相有二种。一自相。二共相。坚湿暖动相是自相。色相是共相。如是二相互不相违。于一法立亦无有过

问此四大种于一切时不相离耶。答如是。云何知然。如入胎经说。佛告庆喜。初羯逻蓝。若有地界无水界者。便应干散。今不散者水所摄故。若有水界无地界者。便应流治。今不流者地所持故。若有地水无火界者。便应臭烂。今不烂者火所熟故若有三界。无风界者应不增长。今增长者风所动故。问余经所说当云何通。地界扰乱。或令至死或令有情受次死苦。乃至风界亦复如是。答此说大种随一增时能为扰乱。非谓四种有时相离

问此四大种品类有几。答品类有四。谓异熟生长养。等流。变化。有余师说。品类有三。谓异熟生。长养。等流。其变化者长养所摄。复有说者。品类有二。谓异熟生。及长养。变化大种入长养中。等流摄入异熟长养。评曰。于前三说中说为善。有四大种非二摄故

问一四大种为但造一造色极微。为能造多。若但造一。如何不成因四果一。因多果少理不应然。若能造多。则一四大种所造色有多极微。云何展转非俱有因。对法者说。有对造色展转相望无俱有因。许则便违对法宗义。答应作是说。一四大种但能造一造色极微。问如何不成因四果一。因多果少理不应然。答果少因多理亦无失。世现见有如是类故。因四果一于理无违。有说造多。问若尔者一四大种所造色有多极微。云何展转非俱有因。答非一果故非俱有因。以俱有因法必同一果故。此不成因同犹豫故。评曰如前说者好

问大种造色云何而住。为大种在下造色在上。为大种在上造色在下。为大种造色相杂而住。大种在外造色处中耶设尔何失。一切有过。若大种在下造色在上。则诸造色近大种者。可以大种为能造因。所造色中有隔远者。如何可以大种为因。若大种在上造色在下。则应造色为大种因。不应大种为造色因。若大种造色相杂而住。大种在外造色处中者。应断截时见诸孔隙犹如断藕。有说在下为因所依法应尔故。问若尔于逼近色可说能造。于隔远者云何造耶。答不说一树所有大种。都在其下造诸造色。但说一树分分皆有大种在下造色在上。有作是说相杂而住。大种在外造色处中。问若尔应断截时见诸孔隙犹如断藕。答虽有孔隙而不可见。以诸大种非有见故所见孔隙是造色故。问诸内外事其相各别。内事别者。谓诸众生若百若千集会一处威仪形相各各不同。外事别者。谓果石等。或青或黄或赤或白。香味等相各各不同。如是相别。为由业异。为由大种异。为由造色异。答俱由三种。依异熟因故说由业异。依生因依因。立因。持因养因故说由大种异。依同类因故。说由造色异。问外事差别由何业异。答若诸有情行诸妙行。感得外事形相平直。色香味触皆悉美妙。若诸有情行诸恶行。感得外事形相险曲。色香味触皆悉粗弊。问诸果石等其相各别。青黄赤白形貌等异。或有相似由何威力。答由三威力然大种强。谓诸大种不平等者。便有种种显形等异。若平等者则便相似

问诸有情类口所发声。当言何处大种所造。有说。喉边大种所造。有说。心边大种所造。有说。脐边大种所造。评曰。总说此声一切身支大种所造。若别说者。轻小语声应言喉边大种所造。叱吒哮吼号叫等声。应言遍身大种所造。现见此等举身掉动故

问颇有色非四大种。亦非四大种所造耶。答有。谓一二三大种。此虽是色而非四大种。唯一二三故。亦非四大种所造以诸大种非所造故。问何故大种非所造耶。答能造所造性各别故。因果异故。能成所成性各别故。如能成所成。如是能引所引。能生所生。能作所作。能和合所和合。能转所转。能相所相。当知亦尔。有说。大种若是所造。为三造一。为四造一。若三造一。体用阙少云何能造。若四造一。应地界等造地界等。则有自性观自性过。然一切法他性为缘。能有所作不顾自体。由此大种不名所造

诸四大种有十一种。谓眼处所依。乃至身处所依。色处所依乃至法处所依。诸所造色亦有十一种。谓眼处乃至身处。色处乃至法处。问眼处所依大种。能造几所造色。乃至法处所依大种。能造几所造色。答应作是说。眼处所依大种唯造眼处。乃至法处所依大种唯造法处。有作是说。眼处所依大种能造三种。谓眼处身处触处。耳鼻舌处所依大种亦尔。身处所依大种能造二种。谓身处触处。色声香味法处。所依大种亦尔。触处所依大种唯造触处。复有欲令一切大种皆能造色声触。欲界大种皆造香味。彼说眼处所依大种能造七种。谓眼处。身处。色声香味触处。耳鼻舌处所依大种亦尔。身处所依大种能造六种。谓身处色声香味触处法处所依大种亦尔。色处所依大种能造五种。谓色处声香味触处。声香味触处所依大种亦尔。有余师说。眼处所依大种能造十一种。乃至法处所依大种亦尔。评曰。此诸说中初说为善。谓眼处所依大种唯造眼处。乃至法处所依大种唯造法处

问云何异相大种能造同相造色。答观别义故说亦无失。谓观别义故。说异相大种造同相造色。观别义故。说同相大种造异相造色。观别义故。说异相大种造异相造色。观别义故。说同相大种造同相造色。观别义故。说异相大种造同相造色者。谓坚湿暖动相大种。造触相造色。有说。此造见相造色等。观别义故说同相大种造异相造色者。谓触相大种。造十一种造色。观别义故。说异相大种造异相造色者。谓坚湿暖动相大种。造十一种造色。观别义故。说同相大种造同相造色者。谓触相大种造触相造色。有说。此造见相造色等

问大种造色相别云何。尊者世友作如是说。因是大种果是造色。能生是大种。所生是造色。所依是大种。能依是造色。能相是大种所相是造色。和合是大种。和合所生是造色。能建立是大种。所建立是造色。大德说曰。坚湿暖动相是大种。若色大种为因。而无大种相是造色。有余师说。大种如天帝。造色如天众。大种如自在。造色如眷属。大种如王。造色如臣。大种如日月轮。造色如日光月明。大种如树身。造色如枝等。大种如墙。造色如影。大种如灯焰。造色如灯明。大种如藕。造色如花。大种如镜。造色如像。是故尊者时毗罗言

  根生从大种　　如灯焰生明
  如藕生莲花　　如镜生众像

阿毗达磨诸论师言。大种无见。造色有见无见。大种有对。造色有对无对。大种有漏。造色有漏无漏。大种无记。造色善不善无记。大种欲色界系。造色欲色界系及不系。大种非学非无学。造色学无学非学非无学。大种修断。造色修断不断。大种苦集谛摄造色苦集道谛摄。大种无异熟。造色有异熟无异熟。大种不染造色染不染大种非业。造色业非业。诸如是等大种造色。二相差别有无量门触处实事有十一种。谓四大种。及七种造触七种造。触者。谓滑涩轻重冷饥渴。滑谓细软。涩谓粗强。轻谓不可称。重谓可称。冷谓此所逼便起暖求。饥谓此所逼便起食欲。渴谓此所逼便起饮欲。问何大种增故滑。乃至渴耶。有作是说。不由大种偏增故滑。乃至渴。但由大种性类差别。有生滑果。乃至有生渴果。有余师言。水火增故滑。地风增故涩。火风增故轻。地水增故。重故施设论作是问言。何缘活时身轻调顺。死便身重不调顺耶。答言活时火风未灭故身轻调顺。死后身中火风已灭故。重不调顺。水风增故冷。风增故饥。谓风增故击动食消引饥触生便发食欲。火增故渴。谓火增故煎迫饮消。引渴触生便发饮欲

问十一触中极多缘。几发生身识。有作是说。一一别缘发生身识。以十一种相用增故。有余师言。极多缘五发生身识。谓四大种滑等随一。复有说者。总缘十一亦生身识。问岂不五识唯取自相境耶。答自相有二种。一事自相。二处自相。依事自相说缘十一种触生于身识。依处自相说五识身取自相境。是故无过。如是说者。缘十一事亦生身识。如缘色处二十种事。亦生眼识此亦应尔。故五识身通缘总别。而无五识取共相过。多事自相一识能缘。然不明了问缘五色根所依大种发身识不。有说。不发。如五色根不可触故不发身识。所依大种理亦应然。问若尔何故说为身识所识。答依法性说身识所识。未来世中身识境故。然无现在发身识义。有说。除身根所依大种皆能发身识。以身根所依极邻近故不能发身识。然他身识所缘境故。亦得名为身识所识。问十一种触几在欲界。几在色界。答二唯在欲界。谓饥与渴。九通欲色界。问若色界中有重触者。以何义故。施设论说。北俱卢洲衣重一两。四大王众天衣重半两。三十三天衣重一铢。夜摩天中衣重半铢。睹史多天衣重一铢中四分之一。乐变化天衣重一铢中八分之一。他化自在天衣重一铢中十六分之一。此上天衣皆不可称耶。有说。色界衣虽不可称而余物可称。有说。彼界一衣虽不可称多衣积集即可称。如细缕轻毛积集便重。问若色界中有冷触者。彼施设论何故复说。如人欲天所有冷暖。可了知者上界俱无耶。答冷有二种。一能为益。二能为损彼无能损。有能为益。又即彼说所有冷暖上界俱无。岂以此言即说彼界亦无暖触。若尔则彼大种应唯有三非阙功用。而能造色故。色界中冷暖俱有。问饥渴二触为是长养。为是等流。为是异熟。健陀罗国西方师言。通长养等流。非异熟生。以饮食能断故。阿毗达磨者不许异熟色断已复续。有说。饥渴亦通异熟生。性以饮食暂断非永断故。断有二种。谓永断暂时断。永断不可续非暂时断。如地狱中暂截身分。异熟生色断已续生。迦湿弥罗国诸论师言。饱时彼亦不断饮食障故不可觉知。饮食消已还可觉知。问若是异熟者。为善业果。恶业果耶。答是二种果。是故富者饥渴是善业果。贫者饥渴是恶业果问饥渴何处大种所造。有说。腹边大种所造。入胎经说。在母腹中。有时脐边彼有情类。有业异熟微风初起。即彼处大种能造饥渴。有余师说。遍身分中大种能造于饥渴。时遍身扰恼故

说一切有部发智大毗婆沙论卷第一百二十七阿毗达磨大毗婆沙论卷第一百二十八

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    大种蕴第五中大造纳息第一之二

大种所造处。几有见。几无见。问何故不问几有色几无色。答彼作论者意欲尔故。随彼意欲而造论。但不违法性便不应责有说。所造无无色故。不得问言几有色。几无色问亦无无为。后不应问几有为几无为。答亦不应问。而后问者当知彼是有余之说。有说。欲以种种文种种说。庄严于义令易解故。复次欲以二门二阶二略二明二炬二影二光互相显示。如无所造是无色故不问。如是无所造是无为故亦不应问。如无所造是无为而得问。如是虽无所造是无色亦应问。如是二门互相影示。令知前后问答理通。有余师言。此中分别所造诸色几有见等。既举所造诸色为章。宁复可问几有色等。以诸色言即显有色。色体皆有变碍义故。有彼色义故名有色。非如有衣及有子等

大种所造处几有见。答一谓色处。问何故色处名为有见。答眼根名见有见用故。所见色处有能见眼故名有见。如有主等或复见者。是能显示色处相粗。可相显示在此在彼相状差别。所显示色有能显示故名有见。如有名等。或复见者是诸影像。唯有色处可有影像故名有见。余则不尔。几无见。答八二少分。八者谓眼耳鼻舌身声香味处。二少分者。谓触处法处。虽诸触处皆无见摄。而非一切是所造色。若所造色亦无见者。是此所问余非所问故说少分。法处亦尔。大种所造处几有对。答九一少分。九者谓五内处及外四处。一少分者谓触处。虽诸触处皆有对摄。而非一切是所造色。若所造色亦有对者。是此所问余非所问故说少分。几无对。答一少分谓法处。虽诸法处皆无对摄。而非一切是所造色。若所造色亦无对者。是此所问余非所问故说少分。然有对有三种一障碍有对。谓十色处。二境界有对谓五色根及心心所。三所缘有对。谓心心所。此中说障碍有对非余

大种所造处几有漏。答九二少分。九者如前说。二少分者。谓触处法处。虽诸触处皆有漏摄。而非一切是所造色。若所造色亦有漏者。是此所问余非所问故说少分。非诸法处。皆有漏摄。亦非一切是所造色。若所造色亦有漏者。是此所问余非所问故说少分。几无漏。答一少分谓法处。非诸法处皆无漏摄。亦非一切是所造色。若所造色亦无漏者。是此所问余非所问故说少分

大种所造处几有为。答九二少分。九者如前说。二少分者。谓触处法处。虽诸触处皆有为摄。而非一切是所造色。若所造色亦有为者。是此所问余非所问故说少分。非诸法处皆有为摄。亦非一切是所造色。若所造色亦有为者。是此所问余非所问故说少分。几无为。答无。彼皆有为故

大种所造处几过去。答十一少分。谓除意处。虽诸眼处皆所造摄。而非一切皆在过去。有在未来现在世故。若是所造亦过去者。是此所问余非所问故说少分。耳鼻舌身色声香味处亦尔。非诸触处皆所造摄。亦非一切皆在过去。若是所造亦过去者。是此所问余非所问故说少分。法处亦尔。如说过去。未来现在说亦如是。有数等故

大种所造处几善。答三少分。谓色声法处虽诸色处皆所造摄。而非一切皆是善性。若是所造亦善性者。是此所问余非所问故说少分。声处亦尔。非诸法处皆所造摄。亦非一切皆是善性。若是所造亦善性者。是此所问余非所问故说少分。几不善。答三少分如前说。几无记。答七三少分。七者谓五内处及香味处。三少分者。谓色声触处。虽诸色处皆所造摄。而非一切皆是无记。若是所造亦无记者。是此所问余非所问故说少分。声处亦尔。虽诸触处皆无记摄。而非一切皆是所造。若是无记亦所造者。是此所问余非所问故说少分

大种所造处几欲界系。答二九少分。二者谓香味处。九少分者。谓五内处。及色声触法处。虽诸眼处皆所造摄。而非一切皆欲界系。若是所造亦欲界系者。是此所问余非所问故说少分。耳鼻舌身色声处亦尔。非诸触处皆所造摄。亦非一切皆欲界系。若是所造亦欲界系者。是此所问余非所问故说少分。法处亦尔。几色界系。答九少分如前说。几无色界系。答无。彼无色故

大种所造处几学。答一少分。谓法处。非诸法处皆学所摄。亦非一切皆是所造。若是所造亦学摄者。是此所问余非所问故说少分。几无学。答一少分如前说。几非学非无学。答九二少分。九者谓内五处。及外四处。二少分者。谓触处法处。虽诸触处皆非学非无学摄。而非一切皆是所造。若是非学非无学亦所造者。是此所问余非所问故说少分。非诸法处皆非学非无学摄。亦非一切皆是所造。若是非学非无学。亦所造者。是此所问余非所问故说少分

大种所造处几见所断。答无。必无诸色见所断故。几修所断。答九二少分。九者如前说。二少分者。谓触处法处。虽诸触处皆修所断摄。而非一切皆是所造。若修所断亦所造者。是此所问余非所问故说少分。非诸法处皆修所断摄。亦非一切皆是所造。若修所断亦所造者。是此所问余非所问故说少分。几不断。答一少分。谓法处。非诸法处皆不断摄。亦非一切皆是所造。若是所造亦不断者。是此所问余非所问故说少分

若成就大种彼所造色耶。答诸成就大种。彼成就所造色。有成就所造色非大种。谓诸圣者生无色界。谁成就大种及所造色。谓欲色界一切有情。此则总说。若别说者。或有有情。成多大种及多造色。或有有情。成少大种及少造色。成多大种及多造色者。如大海中有诸有情所得身形。或百二百三百四百五六七百踰缮那量。如曷逻呼阿素洛王所得身形其量广大。如色究竟所得身形。一万六千踰缮那量。成少大种及少造色者。犹如蚊蠛水中虫等。乃至极细非人眼境。问何故圣者生无色界。唯成就造色非大种耶。答彼界无色。又不成就他界大种。以有漏法越地舍故。造色不尔通无漏故异地成就。无有圣者不成就无漏戒。是故圣生彼界唯成就造色。于中学成就学随转色。无学成就无学随转色

若不成就大种。彼所造色耶。答诸不成就所造色。彼不成就大种。有不成就大种非所造色。谓诸圣者生无色界。谁不成就所造色及大种。谓生无色界一切异生。彼界无有一切色故。又不成就下界色故有漏诸色生上失故。无漏诸色彼未得故。问顺前句中何所不摄。而复顺立顺后句耶。答顺前句中唯摄欲色界一切有情。及摄无色界一切圣者。未摄无色界一切异生。为欲摄彼故复立顺后句

若成就大种彼善色耶。答应作四句。有成就大种非善色。谓处卵[穀-禾+卵]。若诸异生住胎藏中。若生欲界住不律仪。及非律仪非不律仪。无善身语表。设有而失。彼处卵[穀-禾+卵]。住胎异生前生所有表无表色。由失所依众同分故一切已舍。今于此位未能起表。又无入定理故。不成就一切善色。问何故此位未能起表。答以所依身极羸弱故。要身强盛能起表业。又此位心极微劣故。心粗胜者能发表业。又此位心内门转故。心外门转能起表业。又此位中胎卵迫迮尚不能动。况能起表。然有时胎动转者。此由风力非心所为。表业必由心力所起。问何缘此位无入定理耶。答此位身心俱羸劣故。又无入定加行缘故。得忍异生命终舍忍。如前业蕴已广决择。四生广说亦如业蕴。若生欲界住不律仪及非律仪非不律仪无善身语表者。谓睡眠醉闷。及舍加行不求起表。设有而失者。谓由三缘故失。一意乐息。二舍加行。三限势过。此亦如业蕴广说。有成就善色非大种。谓诸圣者生无色界。是圣者故成就善色生无色故。不成就大种。彼诸圣者通学无学。学成学善色。无学成无学善色。有成就大种亦善色。谓诸圣者住胎藏中。若生欲界住律仪。若住不律仪。及非律仪非不律仪。现有善身语表。或先有不失。若生色界住胎圣者。定成有漏无漏无表道力强故。若生欲界住律仪者。谓随所应住三律仪。住不律仪及非律仪非不律仪。现有善身语表者。谓不睡眠。不醉。不闷。不舍加行。求起表业。或先有不失者。谓三缘故如前说。若生色界者彼定成就静虑律仪故。有善色有非成就大种及善色。谓诸异生生无色界。生无色故不成大种。有漏善色越界舍故。无漏善色彼未得故若成就大种彼不善色耶。答诸成就不善色。彼定成就大种。有成就大种。非不善色。谓处卵[穀-禾+卵]及住胎藏。若生欲界住律仪。及非律仪非不律仪。无不善身语表。设有而失。若生色界。谓若成就不善色者定在欲界。无在欲界不成大种必有身故。由此得为顺后句。答释余文句准上应知

若成就大种彼有覆无记色耶。答诸成就有覆无记色彼定成就大种。有成就大种非有覆无记色。谓生欲界若生色界。现无有覆无记身语表。谓若成就有覆无记色者定在色界。无有在色界不成大种必有身故。由此得为顺后句。答无有生欲界起有覆无记表。善染表业依自他身故。若成就大种彼无覆无记色耶。答如是。设成就无覆无记色。彼大种耶。答如是。以成就大种者必成就身根等故。若成就身根等者必成就大种故。生欲色界一切有情。皆成就大种及无覆无记色故。生无色界二俱无故。若成就大种彼善不善色耶。答有成就大种非善不善色。谓处卵[穀-禾+卵]。若诸异生住胎藏中。若生欲界住非律仪非不律仪。无善不善身语表。设有而失。有成就大种亦善色非不善色。谓诸圣者住胎藏中。若生欲界住律仪。无不善身语表。设有而失。若住非律仪非不律仪。现有善身语表。或先有不失。无不善身语表。设有而失。若生色界有成就大种。亦不善色非善色。谓生欲界住不律仪。无善身语表。设有而失。若住非律仪非不律仪。现有不善身语表。或先有不失。无善身语表。设有而失。有成就大种亦善不善色。谓生欲界住律仪。现有不善身语表或先有不失。若住不律仪。现有善身语表。或先有不失。若住非律仪非不律仪。现有善不善身语表。或先有不失。设成就善不善色彼大种耶。答如是。谓成就善不善色者必在欲界。在欲界者定成就大种故。若成就大种彼善有覆无记色耶。答有成就大种非善有覆无记色。谓处卵[穀-禾+卵]。若诸异生住胎藏中。若生欲界住不律仪及非律仪非不律仪。无善身语表。设有而失。有成就大种亦善色非有覆无记色。谓诸圣者住胎藏中。若生欲界住律仪。若住不律仪及非律仪非不律仪。现有善身语表。或先有不失。若生色界现无有覆无记身语表。有成就大种亦善有覆无记色。谓生色界现有有覆无记身语表。设成就善有覆无记色彼大种耶。答如是。谓成就善有覆无记色者必在色界。在色界者定成就大种故

若成就大种彼善无覆无记色耶。答有成就大种亦无覆无记色非善色。谓处卵[穀-禾+卵]。若诸异生住胎藏中。若生欲界住不律仪。及非律仪非不律仪。无善身语表。设有而失。有成就大种亦善无覆无记色。谓诸圣者住胎藏中。若生欲界住律仪。若住不律仪。及非律仪非不律仪。现有善身语表。或先有不失。若生色界。设成就善无覆无记色。彼大种耶。答如是。谓成就善无覆无记色者。必在欲色界。在欲色界者。定成就大种故

若成就大种彼不善有覆无记色耶。答无。谓成就不善色者必在欲界。成就有覆无记色者必在色界。无一有情俱生二界故

若成就大种彼不善无覆无记色耶。答有成就大种。亦无覆无记色。非不善色。谓处卵[穀-禾+卵]。及住胎中。若生欲界住律仪。及非律仪非不律仪。无不善身语表。设有而失。若生色界有成就大种。亦不善无覆无记色。谓生欲界住不律仪。若住律仪。及非律仪非不律仪。现有不善身语表。或先有不失设成就不善无覆无记色彼大种耶。答如是。谓成就不善无覆无记色者。必在欲界。在欲界者定成就大种故。若成就大种彼有覆无记无覆无记色耶。答有成就大种。亦无覆无记色。非有覆无记色。谓生欲界。若生色界。现无有覆无记身语表。有成就大种。亦有覆无记无覆无记色。谓生色界现有有覆无记身语表。设成就有覆无记无覆无记色彼大种耶。答如是。谓成就此二无记色者。必在色界。在色界者定成就大种故若成就大种彼善不善有覆无记色耶。答无。谓成就善不善色者必在欲界。成就善有覆无记色者。必在色界。无一有情俱生二界故

若成就大种。彼善不善无覆无记色耶。答有成就大种。亦无覆无记色。非善不善色。谓处卵[穀-禾+卵]。若诸异生住胎藏中。若生欲界住非律仪非不律仪。无善不善身语表。设有而失。有成就大种亦善无覆无记色。非不善色。谓诸圣者住胎藏中。若生欲界住律仪。无不善身语表。设有而失。若住非律仪非不律仪。现有善身语表。或先有不失。无不善身语表。设有而失。若生色界有成就大种。亦不善无覆无记色非善色。谓生欲界住不律仪。无善身语表。设有而失。若住非律仪非不律仪。现有不善身语表。或先有不失。无善身语表。设有而失。有成就大种亦善不善无覆无记色。谓生欲界住律仪。现有不善身语表。或先有不失。若住不律仪。现有善身语表。或先有不失。若住非律仪非不律仪。现有善不善身语表。或先有不失。设成就善不善无覆无记色。彼大种耶。答如是。谓成就此三色者。必在欲界。在欲界者定成就大种故

若成就大种彼善有覆无记无覆无记色耶。答有成就大种亦无覆无记色。非善有覆无记色。谓处卵[穀-禾+卵]。若诸异生住胎藏中。若生欲界住不律仪。及非律仪非不律仪。无善身语表。设有而失。有成就大种亦善无覆无记色。非有覆无记色。谓诸圣者住胎藏中。若生欲界住律仪。若住不律仪及非律仪非不律仪。现有善身语表。或先有不失。若生色界现无有覆无记身语表。有成就大种亦善有覆无记无覆无记色。谓生色界现有有覆无记身语表。设成就善有覆无记无覆无记色。彼大种耶。答如是。谓成就此三色者。必在色界。在色界者定成就大种故

若成就大种。彼不善有覆无记无覆无记色耶。答无。谓成就不善无覆无记色者。必在欲界。成就有覆无记无覆无记色者。必在色界。无一有情俱生二界故

若成就大种。彼善不善有覆无记无覆无记色耶。答无。谓成就善不善无覆无记色者。必在欲界。成就善有覆无记无覆无记色者。必在色界。无一有情俱生二界故若成就善色彼不善色耶。答应作四句。有成就善色非不善色。谓诸圣者住胎藏中。若生欲界住律仪。无不善身语表设有而失。若住非律仪非不律仪。现有善身语表。或先有不失。无不善身语表。设有而失。若生色界若诸圣者。生无色界。有成就不善色非善色。谓生欲界住不律仪。无善身语表。设有而失。若住非律仪非不律仪。现有不善身语表。或先有不失。无善身语表。设有而失。有成就善色亦不善色。谓生欲界住律仪。现有不善身语表。或先有不失。若住不律仪。现有善身语表。或先有不失。若住非律仪非不律仪。现有善不善身语表。或先有不失。有非成就善色。及不善色。谓处卵[穀-禾+卵]。若诸异生住胎藏中。若生欲界住非律仪非不律仪。无善不善身语表。设有而失。若诸异生生无色界

若成就善色。彼有覆无记色耶。答诸成就有覆无记色。彼定成就善色。或成就善色。非有覆无记色。谓诸圣者住胎藏中。若生欲界住律仪。若住不律仪及非律仪非不律仪。现有善身语表。或先有不失。若生色界现无有覆无记身语表。若诸圣者生无色界。若成就善色彼无覆无记色耶。答应作四句。有成就善色。非无覆无记色。谓诸圣者生无色界。有成就无覆无记色非善色。谓处卵[穀-禾+卵]。若诸异生住胎藏中。若生欲界住不律仪及非律仪非不律仪。无善身语表。设有而失。有成就善色。亦无覆无记色。谓诸圣者住胎藏中。若生欲界住律仪。若住不律仪及非律仪非不律仪。现有善身语表。或先有不失。若生色界有非成就善色。及无覆无记色。谓诸异生生无色界

若成就善色。彼不善有覆无记色耶。答无。谓成就不善色者。必在欲界。成就有覆无记色者。必在色界。无一有情俱生二界故若成就善色。彼不善无覆无记色耶。答有成就善色。非不善无覆无记色。谓诸圣者生无色界。有成就善色亦无覆无记色。非不善色。谓诸圣者住胎藏中。若生欲界住律仪。无不善身语表。设有而失。若住非律仪非不律仪。现有善身语表。或先有不失。无不善身语表。设有而失。若生色界。有成就善色亦不善无覆无记色。谓生欲界住律仪。现有不善身语表。或先有不失。若住不律仪。现有善身语表。或先有不失。若住非律仪非不律仪。现有善不善身语表。或先有不失。设成就不善无覆无记色彼善色耶。答或成就。或不成就。云何成就。即如上说。云何不成就。谓生欲界住不律仪。无善身语表。设有而失。若住非律仪非不律仪。现有不善身语表。或先有不失。无善身语表。设有而失

若成就善色彼有覆无记无覆无记色耶。答有成就善色。非有覆无记无覆无记色。谓诸圣者生无色界。有成就善色亦无覆无记色。非有覆无记色。谓诸圣者住胎藏中。若生欲界住律仪。若住不律仪及非律仪非不律仪。现有善身语表。或先有不失。若生色界现无有覆无记身语表。有成就善色亦有覆无记无覆无记色。谓生色界现有有覆无记身语表。设成就有覆无记无覆无记色。彼善色耶。答如是。谓成就有覆无记无覆无记色者。必在色界。在色界者定成就善色故。若成就善色。彼不善有覆无记无覆无记色耶。答无。谓成就不善无覆无记色者。必在欲界。成就有覆无记无覆无记色者。必在色界。无一有情俱生二界故若成就不善色。彼有覆无记色耶。答无。谓成就不善色者。必在欲界。成就有覆无记色者。必在色界。无一有情俱生二界故若成就不善色。彼无覆无记色耶。答诸成就不善色。彼定成就无覆无记色。有成就无覆无记色。非不善色。谓处卵[穀-禾+卵]。及住胎中。若生欲界住律仪及非律仪非不律仪。无不善身语表。设有而失。若生色界若成就不善色。彼有覆无记无覆无记色耶。答无。如上说

若成就有覆无记色。彼无覆无记色耶。答诸成就有覆无记色。彼定成就无覆无记色。有成就无覆无记色。非有覆无记色。谓生欲界。若生色界。现无有覆无记身语表。如上所说总略义者。谓四大种生欲色界必定成就。生无色界定不成就。无覆无记色亦尔。善色生色界定成就。生欲无色界。或成就或不成就。不善色生色无色界定不成就。生欲界或成就或不成就。有覆无记色。生欲无色界定不成就。生色界或成就或不成就

说一切有部发智大毗婆沙论卷第一百二十八阿毗达磨大毗婆沙论卷第一百二十九

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    大种蕴第五中大造纳息第一之三

诸四大种依何定灭。乃至广说。问何故作此论。答欲显诸佛出现世间有大功德故。如施设论说。赡部洲边绕大海际。有转轮王路广一踰缮那。诸转轮王若不出世水所覆没无能游履。若出世时海水周减一踰缮那。此路乃现平饰清净底布金砂。栴檀香水自然洒润。轮王每欲巡此洲时。导从四军而游此路。如是诸佛未出世时。无有能依诸根本地断烦恼者。若佛十力大法轮王出世间时。根本地现平等清净。布觉分砂洒戒定水。佛与无数那庾多眷属。依之趣入无畏涅槃宫。问此中云何显佛出世有大功德。答佛不出世此问尚无况有能答。如佛昔在室罗筏城住誓多林。时有苾刍名曰马胜。是阿罗汉。独于静室作是思惟。诸四大种何处永灭。为欲知故入胜等持。即以定心于誓多林没。欻然出在四大王众天。从定而起问彼天众。诸四大种何处永灭。天众答曰。我等不知是四大种何处永灭。然我所事四大天王。智慧威德并皆殊胜。彼或能了可往问之。尊者即时诣四王所。作如上问皆曰不知。复共仰推三十三天众。三十三天众复。推帝释。帝释仰推夜摩天众。夜摩天众推苏夜摩天子。苏夜摩天子推睹史多天众。睹史多天众推珊睹史多天子。珊睹史多天子。推乐变化天众。乐变化天众推妙变化天子。妙变化天子推他化自在天众。他化自在天众推妙自在天子。妙自在天子推梵天众。如是尊者遍问欲天竟。不能知大种灭处。欲往梵世入胜等持。复以定心自在宫没。梵众天出。从定而起作如上问。梵众咸曰。我等不知有大梵王。是梵大梵作者化者。为一切父自在生育。具大威德无与等者。无有不见不了不识。彼定能知仁应往问。尊者即问大梵所在。梵众答曰。我亦不知大梵天王定所在处。仁欲见者随处谛求。即有光明于中而现。尊者马胜遂发诚心。愿大梵王于此众现。应时大梵即放光明。便自化身为童子像。首分五顶形貌端严。在梵众中随光而现。尊者前进问曰。大仙诸四大种何处永灭。梵王不达作矫乱言。苾刍当知我是大梵。是自在者作者。化者。生者养者为一切父。此是谄诳所发语业。尊者告曰。我不问仁梵非梵等。但问大种何处永灭。尔时大梵知此苾刍非矫乱言卒能酬遣。便执两手引出众外。此是谄诳所发身业。出众外已谢尊者言。我实不知大种灭处。然诸梵众咸谓我是自在作者无不知见。若我众中云不知者。是诸梵众便见轻蔑。尊者自失近舍如来。远劳见问致无所获。今可速还诣佛请问。如佛所说应正受持。马胜既闻梵王推佛。欢喜辞退复入等持。即以定心于梵世没。欻然还出誓多林中。从定而起整理衣服。往世尊前恭敬作礼。问四大种何处永灭。尔时世尊为说不见边际鸟喻云。汝亦然乃至梵宫遍请所问。不得边际还至此中。犹如彼鸟不得边际。然汝所问不合问仪。随此而答亦乖答理。汝欲问者。当如是问

  四大与短长　　细粗净不净
  于何处永弃　　名色灭无余

此问随顺应如是答

  识不见无边　　周遍广大性
  更无余广大　　能映夺此者
  四大与短长　　细粗净不净
  于是处永弃　　名色灭无余

有说。此中佛说圣道。世尊于此说识声故。有说。此中佛说涅槃。以说无边识不见故。若无佛出世说正法者则虽梵王亦多愚惑。若佛出世宣说正法则八岁勤策亦能解了。设有来问长老知耶。诸四大种何处永灭。彼若诵持大种蕴者。即言依四定或依未至灭。世若无佛此等便无故。佛出世有大功德

诸四大种及所造色依何定灭。答依四定或依未至灭定。或名道或名行迹。或名对治。或名作意。义无差别。灭或名断。或名离染。或名为尽。或名离系。义亦无别。昔于此部有二论师。一名时毗罗。二名瞿沙伐摩。尊者时毗罗作如是说。此中但说永断无余断。无随缚断。无少分断。无影像断。说圣者断非异生断。说圣道作用。非世俗道作用。所以者何。依七依经以立斯论。彼经但说根本地故。无有异生。或诸圣者依根本地起世俗道能离染故。尊者瞿沙伐摩作如是说。此中但说永断无余断。无随缚断。无少分断。无影像断。此说应理。余则不然。所以者何。此中通说诸圣者断。及异生断。圣道作用。及世俗道作用故。问依七依经以立此论。彼经唯说诸根本地。无有异生。或诸圣者依根本地起世俗道。能离诸染云何说通。答由此故言阿毗达磨是诸经镜灯焰光明。诸契经中未宣说者此中宣说。未示现者此中示现。经说有余。此中无余。经说有异意。此中无异意。阿毗达磨中言多尽理。由此经论二说善通

大种造色依四定灭者。谓依四静虑依未至灭者。谓依初静虑近分。及静虑中间空无边处近分。此中静虑无色近分。静虑中间皆名未至。并未能入胜根本地。而能现前断烦恼故。问契经唯说根本名。依何故此中说依未至。有作是说。此中应言依四定或未至灭。不应言依未至。而言依者有何意耶。此文再说根本地故。依四定者说四依定。依未至者谓举诸依。显诸未至。非即说此未至为依。如说入城未入城耶。虽再说城言无别城事。彼亦如是。有余师说。此中依言总说诸定。非但根本。皆能与道作所依故。然七依定就胜而说大种造色五地所系。谓欲界四静虑。是故离第四静虑染时。乃究竟断。然离彼染或依初静虑近分。或依四静虑。或依静虑中间。或依空无边处近分。若依空无边处近分。离彼染时通。圣者及异生。唯世俗道非圣道。若依余地离彼染时。唯圣者非异生。唯圣道非世俗道。此中说究竟所灭大种造色。谓第四静虑所系故。言依四定或依未至灭。若欲界所系大种造色。但应言依未至灭。依初静虑近分灭故。初静虑所系大种造色。应言依初定或依未至灭。依初静虑静虑中间。及前二静虑近分灭故。第二静虑所系大种造色。应言依二定。或依未至灭。依前二静虑静虑中间。初及第三静虑近分灭故。第三静虑所系大种造色。应言依三定或依未至灭。依前三静虑静虑中间。初及第四静虑近分灭故。应知此中诸依前三静虑。及静虑中间灭者。唯圣者非异生。唯圣道非世俗道。诸依初静虑近分灭者。通圣者及异生。通圣道及世俗道。诸依余三静虑近分灭者。通圣者及异生。唯世俗道非圣道。上七近分无圣道故

寻伺有对触依何定灭。答依初定。或依未至灭。依初定灭者。谓依初静虑。依未至灭者。谓依前二静虑近分。及静虑中间。寻伺有对触二地所系。谓欲界初静虑。是故离初静虑染时。乃究竟断。然离彼染或依初静虑。或依静虑中间。或依前二静虑近分。若依第二静虑近分。离彼染时通圣者及异生。唯世俗道非圣道。若依余地离彼染时。唯圣者非异生。唯圣道非世俗道。此中说究竟所灭。寻伺有对触。谓初静虑所系故。言依初定或依未至灭。若欲界所系寻伺有对触。但应言依未至灭。依初静虑近分灭故。此通圣者及异生。通圣道及世俗道乐根依何定灭。答依三定或依未至灭。依三定灭者。谓依前三静虑。依未至灭者。谓依初静虑近分。及静虑中间。第四静虑近分。乐根三地所系。谓欲界初静虑第三静虑。是故离第三静虑染时。乃究竟断。然离彼染或依前三静虑。或依静虑中间。或依初及第四静虑近分。若依第四静虑近分。离彼染时。通圣者及异生。唯世俗道非圣道。若依余地离彼染时。唯圣者非异生。唯圣道非世俗道。此中说究竟所灭乐根。谓第三静虑所系故。言依三定。或依未至灭。若欲界所系乐根。但应言依未至灭。依初静虑近分灭故。初静虑所系乐根。应言依初定。或依未至灭。依初静虑静虑中间。及前二静虑近分灭故。此中诸依初静虑。及静虑中间灭者。唯圣者非异生。唯圣道非世俗道。诸依初静虑近分灭者。通圣者及异生。通圣道及世俗道。依第二静虑近分灭者。通圣者及异生。唯世俗道非圣道

喜根依何定灭。答依二定或依未至灭。依二定灭者。谓依前二静虑。依未至灭者。谓依初静虑近分。及静虑中间。第三静虑近分。喜根三地所系。谓欲界前二静虑。是故离第二静虑染时。乃究竟断。然离彼染。或依前二静虑。或依静虑中间。或依初及第三静虑近分。若依第三静虑近分。离彼染时。通圣者及异生。唯世俗道非圣道。若依余地离彼染时。唯圣者非异生。唯圣道非世俗道此中说究竟所灭喜根。谓第二静虑所系故。言依二定。或依未至灭。若欲界所系喜根。但应言依未至灭。依初静虑近分灭故。初静虑所系喜根。应言依初定。或依未至灭。依初静虑静虑中间。及前二静虑近分灭故。此中诸依初静虑。静虑中间灭者。唯圣者非异生。唯圣道非世俗道。依初静虑近分灭者。通圣者及异生。通圣道及世俗道。依第二静虑近分灭者。通圣者及异生。唯世俗道非圣道。苦根忧根段食依何定灭。答依未至灭。谓初静虑近分以苦根等唯欲界系。是故离彼染时。即究竟断。然离彼染时。唯依初静虑近分。此通圣者及异生。通圣道及世俗道

舍根触思识食。依何定灭。答依七定。或依未至灭。依七定灭者。谓依四静虑。及前三无色。依未至灭者。谓依初静虑近分。及静虑中间。此舍根等九地所系。谓从欲界乃至非想非非想处。是故离非想非非想处染时。乃究竟断。然离彼染。或依初静虑近分。或依静虑中间。或依四静虑。或依前三无色。此唯圣者非异生。唯圣道非世俗道。此中说究竟所灭舍根三食。谓非想非非想处所系故。言依七定。或依未至灭。若欲界所系舍根三食。但应言依未至灭。依初静虑近分灭故。初静虑所系舍根三食。应言依初定。或依未至灭。依初静虑静虑中间。及前二静虑近分灭故。第二静虑所系舍根三食。应言依二定。或依未至灭。依前二静虑静虑中间。初及第三静虑近分灭故。第三静虑所系舍根三食。应言依三定。或依未至灭。依前三静虑静虑中间。初及第四静虑近分灭故。第四静虑所系舍根三食。应言依四定。或依未至灭。依四静虑静虑中间。初静虑近分。空无边处近分灭故。空无边处舍根三食。应言依五定。或依未至灭。依四静虑。空无边处。静虑中间。初静虑近分。识无边处近分灭故。识无边处舍根三食。应言依六定。或依未至灭。依四静虑。前二无色静虑中间。初静虑近分。无所有处近分灭故。无所有处舍根三食。应言依七定。或依未至灭。依四静虑。前三无色。静虑中间。初静虑近分。非想非非想处近分灭故。此中诸依七定。静虑中间灭者。唯圣者非异生。唯圣道非世俗道。诸依初静虑近分灭者。通圣者及异生。通圣道及世俗道。诸依上七地近分灭者。通圣者及异生唯世俗道非圣道诸四大种及所造色。已断已遍知当言住何果。答阿罗汉果。或无所住。住阿罗汉果者。谓彼补特伽罗大种造色。已断遍知住无学果。或无所住者。谓彼补特伽罗大种造色。已断遍知犹未住果。即诸异生已离色界染。及先离彼染。入正性离生。住见道中十五心顷。若渐次者离第四静虑染。最后解脱道离空无边处染。诸加行道九无间道九解脱道。乃至离无所有处染应知亦尔。离非想非非想处染。诸加行道九无间道八解脱道。住此诸位补特伽罗大种造色。已断遍知。于四沙门果而犹未住。问先离色界染入正性离生道类智时。大种造色已断遍知。此补特伽罗住不还果。此中何故不说。答应说而不说者当知此义有余。有说。此中依渐次说。谓说具缚入正性离生者。非超越者是故不说。寻伺有对触已断已遍知。当言住何果。答阿罗汉果。或无所住。住阿罗汉果者。谓彼补特伽罗寻伺有对触已断遍知。住无学果。或无所住者。谓彼补特伽罗寻伺有对触已断遍知。犹未住果。即诸异生已离初静虑染。或先离彼染。入正性离生住见道中十五心顷。若渐次者。离初静虑染最后解脱道。离第二静虑染。诸加行道九无间道九解脱道。乃至离无所有处染。应知亦尔。离非想非非想处染。诸加行道九无间道八解脱道。住此诸位补特伽罗寻伺有对触已断遍知。于四沙门果而犹未住。问先离初静虑染。入正性离生道类智时。寻伺有对触已断遍知。此补特伽罗住不还果。此中何故不说。答应说而不说者当知此义有余。有说。此中依渐次说。广说如前。乐根已断已遍知当言住何果。答住阿罗汉果。或无所住。住阿罗汉果者。谓彼补特伽罗乐根已断遍知。住无学果。或无所住者。谓彼补特伽罗乐根已断遍知。犹未住果。即诸异生已离第三静虑染。或先离彼染。入正性离生。住见道中十五心顷。若渐次者。离第三静虑染。最后解脱道离第四静虑染。诸加行道九无间道九解脱道。乃至离无所有处染。应知亦尔。离非想非非想处染。诸加行道九无间道八解脱道。住此诸位补特伽罗。乐根已断遍知。于四沙门果。而犹未住。问先离第三静虑染。入正性离生道类智时。尔时乐根已断遍知。此补特伽罗住不还果。此中何故不说。答应说而不说者当知此义有余。有说。此中依渐次说广说如前

喜根已断已遍知。当言住何果。答阿罗汉果。或无所住。住阿罗汉果者。谓彼补特伽罗喜根已断遍知。住无学果。无所住者。谓彼补特伽罗。喜根已断遍知。犹未住果。即诸异生已离第二静虑染。或先离彼染。入正性离生。住见道中十五心顷。若渐次者。离第二静虑染。最后解脱道。离第三静虑染。诸加行道九无间道九解脱道。乃至离无所有处染。应知亦尔。离非想非非想处染。诸加行道九无间道八解脱道。住此诸位补特伽罗喜根已断遍知。于四沙门果而犹未住。问先离第二静虑染。入正性离生道类智时。尔时喜根已断遍知。此补特伽罗住不还果。此中何故不说。答应说而不说者当知此义有余。有说。此中依渐次说。广说如前苦根忧根段食。已断已遍知。当言住何果。答不还果。或阿罗汉果。或无所住。住不还果者。谓彼补特伽罗苦根等三已断遍知。住学第三果。住阿罗汉果者。谓彼补特伽罗苦根等三已断遍知。住无学果。无所住者。谓彼补特伽罗苦根等三已断遍知。犹未住果。即诸异生已离欲界染。或先离彼染。入正性离生。住见道中十五心顷。住此诸位补特伽罗。苦根等三已断遍知。于四沙门果而犹未住。此中不说渐次诸位名无所住。以离欲界染最后无间道生。尔时苦根等三究竟断尽。最后解脱道时。此补特伽罗必住不还果故

舍根触思识食已断已遍知。当言住何果。答阿罗汉果。此中不说。或无所住。所以者何。离非想非非想处染。最后无间道生尔时舍根三食究竟断尽。最后解脱道时。此补特伽罗必住阿罗汉果。故余师于此作别意释。谓此意问四大种等已断已遍知。当言何果摄。由此不说四大种等已断遍知。住不还果先离色染。后入正性离生道类智时虽得不还果。而彼离系非不还果摄。以不还果但摄见所断。及欲界修所断断。为断果故。评曰初说为善。所以者何。此中但问补特伽罗四大种等已断遍知。得住何果不问果摄故

契经中说食有四种。一段食。二触食。三意思食。四识食。云何段食。谓由粗细分段为缘。长养诸根。增益大种。云何触意思识食。谓有漏触意思识为缘。长养诸根。增益大种。此中长养诸根者。显长养诸法。增益大种者。显异熟诸法。问诸根亦可增益有异熟故。大种亦可长养有长养故。何故此中唯作是说。答诸根大种俱应作二种说。而不说者当知此义有余。复次欲以种种文种种说。庄严于义令易解故。复次欲现二门二阶二略二明二炬二影二光。互相显示如根说。长养大种亦应尔。如大种说增益根亦应尔。由二门等互相影故。则所说理通文要义显

问如所说长养增益。为于长益法长益。为于不长益法长益耶。若于长益法长益者。彼长益法复何长益。若于不长益法长益者。不长益法云何长益。答非于长益法长益。亦非于不长益法长益。然长益不长益法先住未来。若遇长益缘。则不长益法灭。长益法生。若遇不长益缘则长益法灭。不长益法生。虽无转作而义俱立

问颇有有漏触思识为缘。长养诸根。增益大种。而非食耶。答有。谓异界触思识能长养增益诸根大种。问颇有同界触思识为缘。长养诸根。增益大种。而非食耶。答有。谓异地触思识能长养增益诸根大种。问颇有同地触思识为缘。长养诸根。增益大种。而非食耶。答有。谓无漏触思识。能长养增益诸根大种。问何故无漏不立食耶。答诸无漏法无食相故。又法现前增益诸有。摄受诸有。住持诸有。可说为食。无漏诸法。损减违害破坏诸有故不说食。又法现前连续诸有。连续老死能令生死轮转无穷。可说为食。无漏诸法断息诸有。断息老死。能令生死不复轮转故不说食。又法现前随顺苦集。随顺老死。能令生死诸有。世间流转不息可说为食。无漏诸法随顺苦集灭。随顺老死灭能令生死诸有世间不复流转故不说食。又法现前是身见事。是颠倒事。是贪爱事。是随眠事。是贪嗔痴安立足处。有垢有毒。有秽有浊。有刺有怨。诸有所摄。堕苦集谛。可说为食。无漏诸法非身见事。非颠倒事。非贪爱事。非随眠事。非贪嗔痴安立足处。无垢无毒。无秽无浊。无刺无怨。非诸有所摄。不堕苦集谛故不说食。又无漏法不能究竟长养诸有。虽暂长养非究竟故不说为食。尊者妙音亦作是说。非无漏法长养诸有。虽暂长养而非究竟。终违有故不说为食。夫说为食终能长养

问食体是何。答是十六事。于中十三事是段食体。即十一触及香味处。触思识三是余食体。蕴界处摄者。是十一界五处三蕴少分所摄。十一界者。谓七心界。及香味触法界。五处者。谓香味触处。意处。法处。三蕴者。谓色行识蕴。是谓四食自体。我物性相

已说自体。所以今当说。何故名食。食是何义。答牵有义是食义。续有义。持有义。生有义。养有义。增有义。是食义。此四于有能牵。乃至能增故名为食。问若牵有。乃至增有是食义者。诸有漏法皆应名食。何故但说四耶。胁尊者言。唯佛世尊究竟了达诸法性相。亦知势用非余能知。若法有食相作用可立食者。即便立之。无者不立。尊者世友作如是言。此是世尊有余之说。略说影说有观待说。佛观化宜而说法故。尊者妙音说曰。佛知此四牵有续有持有生有养有增有体相势用。强盛邻近故立为食。余法不尔故不说食。有余师言。如是四法极能长养诸界趣生老死世间。令其流转故立为食。余则不尔。或有说者。食有二相。一牵引当有令现在前。二任持今有令相续住。有余师说。食有三种。一者业食。二者生食。三者长养食。业食谓思。生食谓识。长养食者。谓段与触

说一切有部发智大毗婆沙论卷第一百二十九阿毗达磨大毗婆沙论卷第一百三十

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    大种蕴第五中大造纳息第一之四

问如是四食。几牵当有令现在前。几持今有令相续住。有作是说。一牵当有令现在前。谓意思食。三持今有令相续住。谓余三食。或有说者。二牵当有。谓意思识。二持今有谓余二食。有余师说。三牵当有。谓触思识。一持今有。所谓段食。如是说者。四食尽牵当有令现在前。尽持今有令相续住

问诸食于有。几未生令生几生已长养。有作是说。诸食于有。一未生令生。谓意思食。三生已长养。谓余三食。复有说者。二未生令生。谓意思识。二生已长养。谓余二食。有余师说。三未生令生。谓触思识。一生已长养。所谓段食。如是说者四食于有。皆未生令生生已长养。问何食于何法食事偏增。答段食养色根大种胜故。于色根大种食事偏增。触食养心心所胜故。于心心所食事偏增。思食养后有胜故。于诸后有食事偏增。识食养名色胜故。于诸名色食事偏增问如说牵有义是食义等。此言为是因义。是缘义耶。设尔何失。二俱有过若是因义者。外香味触于内诸处五因皆无。云何为食。若是缘义者除内自性。余法皆是此增上缘。何故但说四种为食。有说。是因义。问若尔外香味触于内诸处五因皆无。云何为食。答外香味触为觉发因。令内香等得成食事。内香味触于内诸处。有因义故说之为食。谓眼唯以触处为食。耳鼻舌身色声亦尔。香用香处触处为食。味以味处触处为食。触处唯以触处为食。心心所法三食为食。此中因义如理应思。有说。是缘义。问若尔除内自性。余法皆是此增上缘。何故但说四种为食。答于内诸处增上缘法。有亲有疏。有近有远。有合不合。有在此生。有在余生。诸亲近合。在此生者。说之为食。疏远不合在余生者不说为食。故食唯四。此四皆于内十二处能为食事。然有增微如前所说

问何故色处不立为食。有作是说。无食相故。有说。色处取时粗重若于取时细轻者名食。要微细转滋养身故。有说。色处不至而取。食唯至取。非身不合成食事故。有说。色处至变坏位食事方成。谓水所浸烂。火所熟变。风所动摇。然后方成食。所作事非色未变。得名为食。故色非食香等不尔。有余师说。若色是食。眼见色时应除饥渴。若然施主所费则为唐捐。有余复言。若色是食。诸出家者眼见色时应犯远离非时食法。或有说者。若色是食则色界天应受段食取诸色故。当知后三所说乖理。香触亦有如斯过故。应知前四所说者好。问若色非食经云何通。如世尊言。长者汝所施食。色香味具甚为妙好。答色虽非食。为欲发起施主思故佛作是说。谓佛赞美所施食时。施主便发殊胜思愿。快哉如来赞受我食。我当必获殊胜福利。问若赞色具色非食者。亦赞香等俱应非食。彼既是食此亦应然。答佛于此中不欲简别是食非食。但欲发起施主思愿说此契经。若此赞说即是食者触非所赞便应非食

问段食是何义。答分段而食故名段食。问若尔所饮吮等非段食耶。答从多分说是故无过。复有说者。饮吮等时亦作分段。有余师言。从初而说。谓劫初时人受用地味。皆作分段而吞啖之因名段食

问佛说段食。有粗有细云何应知粗细差别。答集异门说。段食粗细互相观待而可了知。谓水族中小为大食。传相观待粗细得成。如底民耆罗耆罗所食是粗。底民耆罗所食为细。底民耆罗所食是粗。底民所食为细。底民所食是粗。大鱼龟鳖及末羯罗失兽摩罗等所食为细。大鱼鳖等所食是粗。余水行虫所食为细。诸陆族中象马驼等所食是粗。羊鹿猪等所食为细。羊鹿猪等所食是粗。兔猫狸等所食为细。兔猫狸等所食是粗。余陆行虫所食为细。空行族中诸妙翅鸟所食是粗。鹅雁孔雀鹦鹉舍利命命鸟等所食为细。鹅雁孔雀等所食是粗。余空行类所食为细。有作是说。若诸有情以草木等而为食者所食是粗。以饼饭等而为食者所食是细。有余师说。以饼饭等而为食者所食是粗。以酥油等而为食者所食是细。有余复说。面门吞啖诸食是粗。脐毛孔入诸食为细。谓胎藏中诸有情类食从脐入。唯诸菩萨食从一切毛孔而入。有作是言。若食啖已有等流者此食是粗。无等流者此食为细。如苏陀味香为食等

问触思识食有粗细不。若有者何故契经唯说段食有粗细。若无者何故段食有粗细非余耶。答触思识食亦有粗细。界地相待故。谓欲界是粗色界为细。色界是粗。无色界为细。初静虑是粗。第二静虑为细。乃至无所有处是粗。非想非非想处为细。问若尔何故契经不说。答应说而不说者当知此义有余。有说。契经举初显后。已说段食有粗细当知余食亦有粗细有说。段食由四因缘。有多少故粗细可知。余食不尔。一追求故。二积集故。三受用故。四等流故。追求故者。谓诸有情追求段食。有多有少。所求多者是粗所求少者为细。积集故者。谓诸有情积集段食有多有少所集多者是粗所集少者是细。受用故者。谓诸有情受用段食有多有少。所受多者是粗所受少者是细。等流故者。谓诸有情段食等流有多有少。等流多者所食是粗等流少者所食是细。有说。段食观待诸处可说粗细余食不尔。谓香味触观待色声可说为细。观待意法可说为粗触思识三意法处摄。此于诸处唯细非粗无异观待不说粗细

问于何界有几食。答欲界具四段食偏增。色界有三。触食偏增。无色亦三。下三无色思食偏增。非想非非想处识食偏增。有说。非想非非想处亦思食增。一思能感八十千劫寿量果故。问于何趣有几食。答地狱具四。识食偏增。问地狱之中有何段食。答饮镕铜汁。吞热铁丸。以为段食。问夫为食者有所滋益。此物入身烧唇舌齶咽喉胸腹。从下出已焰赫转增举身燋然。云何名食。答虽为烧恼而有食相。初入身时暂除饥渴故。傍生具四。随一偏增。种类处所有差别故。鬼趣具四。思食偏增。曾闻一时尊者满愿为乞食故。将入布色羯逻伐底城。于城门前忽然见一老饿鬼女。问言汝今何为住此鬼女反问尊见我耶。尊答如是。鬼女便曰。我夫入城希此城中有长者等痈肿溃烂。当因挤搦收取脓血还共食之。为是我今于此住待。复问汝夫入来久近。鬼女答曰。饥渴所迷不忆我夫入城久近。然唯记此城边大河。七移城南七移城北。于今未还。尊者愍伤悒然舍去。如是鬼女饥渴多时。希望所持身相续住。故知鬼趣思食偏增。人及欲天皆具四食。然彼种类段食偏增。色无色天如界中说

问于何生有几食。答卵生具四。触食偏增。有说思食增。云何知然。如集异门说。海中有兽时出海滨。于沙潬中产生诸卵。以沙埋覆还入海中。彼在卵[穀-禾+卵]。忆念母故身不烂坏。谓忆念母先孚暖时所有触故。若忘其母身便烂坏。有余师说。若母忆念卵中子者卵则不坏。母若忘之彼卵便坏。此不应理。所以者何。勿以他食能持自命。是故前说于理为善。胎生具四。段食偏增。湿生具四。触食偏增。化生具四。随一偏增。种类处所有差别故

所说食声有二差别。一世俗。二胜义。世俗者如世间言。有残食瓶无残食瓶。又如世间说城邑食。所谓此食出吉祥城此食出呾叉翅罗城。此食出奢羯罗城。此食出寂静宫。如是等又如赞者说诸食名。谓剌雉多食。牟地多食。佛所赞食。四方食等。又如经说。顺食逆食。言顺食者。如世尊言。苾刍当知一切有食。谓天暴雨其滴洪澍诸山。溪谷最先盈满。溪谷满已小沟涧满。小沟涧满已。大沟涧满。大沟涧满已。小江河满。小江河满已。大江河满。大江河满已。大海盈满。言逆食者。如世尊言。苾刍当知一切有食。大海有食。谓大江河。大江河有食。谓小江河小江河有食。谓大沟涧。大沟涧有食。谓小沟涧。小沟涧有食。所谓溪谷。溪谷有食。谓天暴雨。胜义食者。谓此四食真实资益诸有情故

问诸段皆食耶。答应作四句。有段非食。谓以段为缘。不能长益诸根大种。有食非段谓。以触思识为缘。而能长益诸根大种。有段亦食。谓以段为缘。而能长益诸根大种。有非段非食。谓以触思识为缘。不能长益诸根大种。如段食有四句。如是识思触食各有四句。皆应广说。如是差别成十六句。问不能长益诸根大种便非食耶。答如是。所以者何。前说长益是食相故。问今现见有食已痛逼。乃至或令舍于身担。云何长益是食相耶。答虽所饮食有损有益。但今说食谓益非损。益有二时。一初食时。二消化时。或有消化时损。初食时益。如食美毒此亦名食或有初食时损。消化时益。如服苦药此亦名食。由此二种随于一时作食事故。皆得名食。故说长益名为食相。有说彼类食已初虽不安。后变吐时还能为益。故先所说食自相成。经说苾刍如是四食。能令部多有情安住。及能摄益求有有情。问此经所说部多求有二种有情云何差别。答住本有名部多。住中有名求有。于六处门求当有故。有说圣名部多。异生名求有。彼类多求当来有故。有说。无学名部多。学名求有。彼容希求当来有故。问部多有情亦可摄益。求有有情亦可安住。如何但说能令部多有情安住。及能摄益求有有情。答此契经文俱应作二种说。而不说者当知此义有余。有说。此中欲以种种文种种说庄严于义令易解故。有说。此中欲现二门二略。乃至广说。有说。本有安住最经多时。圣与无学求暂安住。于此义显说安住言。余不如是不说安住

经说苾刍如是四食。是众病本。是痈疮本。是毒箭本。是老死因。是老死缘。问食亦能为安乐根本。如世尊说。道依资粮涅槃依道。由道乐故得乐涅槃。道之资粮食为上首。何故说是病等本耶。答为止有情食段欲故。彼由贪食起诸恶行招感剧苦。是故世尊作如是说。设诸段食唯现乐因。智者尚应不生耽嗜。以起恶业招当苦故。况为现身众病本等。是故智者不应染着。佛为此故说是契经

经说苾刍应观段食如旷野子肉。应观触食如新剥皮牛。应观思食如火坑炎炭。应观识食如三百利鉾。问云何苾刍应观段食如旷野子肉。答譬如夫妻唯有一子。面貌端正怜爱情深。值国饥荒欲诣他土。行至旷野遂绝糇粮。前路尚遥不食数日。皆困将死。其夫窃念。路远粮绝命在须臾。我等三人理不俱济。岂得相守俱丧。此中今若一人充食。则死一存二犹胜俱亡。若以我供虑妻志渜悲恨自绝不能出难。若以妻供恐儿失母亦不存活。便为两失。然所爱子我等所生。夫妻若存子容可得。宜舍子命度兹旷野。作是念已悲不自胜。妻便怪之前问其故。夫乃具以所念告之。妻闻哽咽闷绝擗地。良久乃稣号哭呼天称冤酷毒夫乃徐喻久而许之。于是夫妻抱子呜唼。失声悲叫何期苦哉。涕咽多时乃尽子命。破析为脯充路资粮。每欲食时夫妻相哭。称言子子雨泪而食。食已嗟惋自责自咎。然彼夫妻自初筹议。乃至食已随路行时。曾无欢情唯念爱子。如是行者住空闲处。终不放逸正思惟妻。生一可爱妙善法子。心常念之初无舍离。厌生死境趣涅槃方。于长时修资缘匮乏。为持圣道所依苦身。舍所专修入城乞食。与不放逸正思惟俱。自舍空闲乃至食已。曾无染着欢乐之心。唯念所舍专修之法。苾刍如是于段食中。应观如前旷野子肉。若于段食已断遍知者。于五欲爱亦断遍知。同一制伏一对治故。若五欲爱已断遍知。则无一结未断遍知。能系缚彼还生欲界。此依离欲爱得不还果。顺下分结尽密意而说。问云何苾刍应观触食如新剥皮牛。答假如其牛有过于主。欲令苦故生剥去皮。其牛尔时以无皮故。随所住止若地若空。所有诸虫竞来唼食。为去虫故揩触蕃篱草木壁等转增苦痛。彼牛尔时宁有少乐。触与未触皆受大苦。如是诸有宁有少乐。生与未生无不皆苦。苾刍如是应观触食。犹如所说新剥皮牛。若于触食已断遍知者。便于三受亦断遍知。诸受以触为缘生故。如经言触缘受。若于三受已断遍知。则所作已办故应思择求断触食。此依越有顶得阿罗汉果。一切结尽密意而说

云何苾刍应观思食如火坑焰炭。答如近城邑有大火坑。无焰无烟焰炭盈满。有不愚稚非騃智人见已念言。此大火坑焰炭盈满。我若堕者必死无疑。作是念已便起思愿。求欲远之即便舍去。诸有痴幼顽无智人见已念言。此坑之中红赫可爱。便即投趣受苦命终。如彼智者见大火坑怖而远避。如是诸圣于后有思深生厌舍。如无智者投大火坑受苦丧命。如是异生起后有思。受无边苦失于慧命。苾刍如是应观思食。如上所说焰炭火坑。若于思食已断遍知者。便于三爱亦断遍知。以彼三爱是起因故。如契经说。业为因故生。爱为因故起。若于三爱已断遍知。则所作已办故应思择求断思食。此亦依越有顶得阿罗汉果一切结尽密意而说

问云何苾刍应观识食如三百利鉾。答假如有人于日初分被百鉾[矛*(替-曰+貝)]。日中分时亦百鉾[矛*(替-曰+貝)]。于日后分亦百鉾[矛*(替-曰+貝)]。如是日日受三百鉾。乃至尽寿。其人尔时举体皆疮。无少完全如芥子许。如是行者于日日中。恒为三百异境所引。如利鉾心于所专修。而为侵害乃至尽寿。令所修习多诸疮疣。苾刍如是应观识食。如上所说三百利鉾。若于识食已断遍知者。则于名色亦断遍知。以识是彼名色缘故。如契经说识缘名色。若于名色已断遍知。则所作已办故应思择求断识食。此依越有顶得阿罗汉果一切结尽密意而说

问余食亦如三百鉾不。若亦如三百鉾者。何故但说观识食耶。若不如三百鉾者。何故唯识食如三百鉾非余食耶。答余食亦应如三百鉾。如以此观识食。亦应以此观余三食。而契经但说观识食者。当知此是有余之说。有说。此经示最后边。显前所说诸食亦尔。有余师言。心性刚强最难调伏。佛为呵责以三百鉾而为譬喻。余食自以余门说喻。有说此经随显胜说。是故无过。前三喻中理有通者皆以此释。如契经说。此吠罗摩婆罗门。以如是诸妙饮食。布施摩诃娑罗婆罗门众。有以饮食布施赡部林中异生。此获施福果大于彼。问此契经中为说何等。名为赡部林中异生。有作是说。赡部洲中诸有腹者皆此所说。有说。诸有外仙已离欲染是此所说。有言此是近佛菩萨。理不应然。诸有布施近佛菩萨所获施福。胜施俱胝阿罗汉众。如是说者。此说已得顺决择分善根异生。其德胜彼婆罗门故。此经复言。若以饮食布施赡部林中异生。有以饮食施一预流。此获施福果大于彼。由此已断诸恶见故。三结尽故。离见所断恶趣因故。作有边际故。得预流果故。此经复言。若以饮食施百预流。有以饮食施一一来。此获施福果大于彼。离修所断恶趣因故。薄贪嗔痴故。得一来果故。此经复言。若以饮食施百一来。有以饮食施一不还。此获施福果大于彼。由此已断顺下分结故。越欲界生故。得不还果故。此经复言。若以饮食施百不还。有以饮食施一阿罗汉。此获施福果大于彼。由此已断一切结故。越有顶生故。得阿罗汉果故。此经复言。若以饮食施百阿罗汉。有以饮食施一独觉。此获施福果大于彼。自能觉故。此经复言。若以饮食施百独觉。有以饮食施一如来。此获施福果大于彼。自能遍觉故。亦能觉他故。此经复言。若以饮食奉施如来。有造僧伽蓝施四方僧众。此获施福果大于彼。以僧伽蓝无障碍故。问施佛功德胜于施僧。此中施福皆先举劣后举其胜。何故此中先佛后僧。答即以是故先佛后僧。所以者何。若声闻僧便不摄佛。若四方僧则亦摄佛。是福田僧苾刍僧故。若唯施佛但佛应受。僧众不受故福为劣。若施僧众。僧众与佛俱应纳受故福为胜。无障碍故。获福无限故。虽所举先佛后僧。而犹得名先劣后胜

问所得果胜亦由胜思。何故世尊唯赞田胜。答世尊所化有二差别。一信慧具足。二有信无慧。于信慧具佛不赞田。彼自能知田非田故。于信无慧佛则赞田。彼不能知田非田故。然彼施果。或有欲令思胜故胜。或有欲令田胜故胜。而实果胜俱由二种。由此得成四句差别。谓有由田不由思胜。或有由思不由田胜。或有俱由二种故胜。或由二种俱劣故劣。问佛施舍利子。舍利子施佛。此二施福何者为多。答诸有欲令果由思胜者。彼说佛施福多。以佛施思于现前位。舍利子等尚不能知。何况能及。诸有欲令果由田胜者。彼说舍利子施福多。以佛福田三界中最胜故

问预流果向为可施不。若可施者。前经何故不说。若不可施余经所说复云何通。如说

  四向与四果　　是真福田僧
  具戒慧等持　　施者获大果

有说可施。谓衣服等非诸饮食。问若可施者。前经何故不说。答前所引经说施饮食。非衣服等是故不说。有说。此向亦可施食。但有摄取而无受用。谓毗呵罗中有入见道者。余人为受所施食分。或将食时有入见道。施主以食置其膝上。或复安置曼荼罗中。问前所引经何故不说。答彼经唯说能受用者。此据摄取故不相违。有余师言。此向不可施是故前经不说。问若尔者所引经颂当云何通。答彼颂欲显补特伽罗由道差别成福田义。谓显成就无漏道者施获大果名真福田。不说尔时能受他施。前问可施不可施者。意问能受不能受故

说一切有部发智大毗婆沙论卷第一百三十阿毗达磨大毗婆沙论卷第一百三十一

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    大种蕴第五中大造纳息第一之五

如契经说。邬揭罗长者白佛言。世尊。我于一时自手执杓施僧饮食时。有天神空中语我。长者当知。此阿罗汉果。此阿罗汉向此不还果。此不还向。此一来果。此一来向。此预流果。此预流向。此持此犯。我于尔时虽闻彼语。自省无有不平等心。于僧众中等心而施。问彼天神者为是谁耶。复何因缘来语长者。答有作是说。是魔众天欲为长者善品留难。有说。是鬼以虚诳言惑乱长者。有余师说。彼是长者常所祭天故来空中。示导长者福田差别。有余复言。彼是长者过去亲属生在天中。以诚实言汲引长者。问若是长者过去亲属于预流向云何能知。见道迅速非其境故。答预流向有二种。一者世俗。二者胜义。得顺决择分名为世俗。已入见道名为胜义。住世俗向是彼天境。若胜义向舍利子等。尚不尽知况彼天等。彼天所示但是世俗。能受长者所施食故。亦有余经说胜义向。如世尊告婆拖梨言。若有苾刍是俱解脱。我设告彼汝来以身于此泞渠为我作彴。婆拖梨听于意云何。彼闻我命为拒逆不。将登蹑时为退避不正践蹈时为转侧不。婆拖梨曰不也。世尊复告婆拖梨。置俱解脱。若有苾刍是慧解脱。我设告彼乃至广说。复置慧解脱说于身证。复置身证说于见至。复置见至说信胜解置信胜解说随法行。置随法行说随信行。佛问彼答一一如前。有说。此经亦说世俗预流果向。以见道中不能听受佛语义故。评曰此中说胜义向于理为善。以说随信随法行故。问住见道时无能听受。佛说义者无异心故。如何世尊以言告彼。答世尊依彼志乐而说。无如是事为分别故。假在见道有异分心。能受如来此言义者。必舍见道作所敕事。佛意呵责婆拖梨言。住见道中尚从我命。况汝远离一切功德。而于我所生违逆心。是故此中说胜义向问长者何故虽闻天语。犹于僧中平等心施。有说。僧众皆是长者一揵椎声所召集故。彼作是念。此皆是我一揵椎声之所召集。无宜于此不等心施。有说。僧众受此饮食皆除饥渴无差别故。彼作是念。我施饮食为除饥渴。如阿罗汉受我施已饥渴得除。具缚异生受我饮食亦复如是。无宜于此不等心施。有说。长者施僧饮食本意但欲饶益他故。彼作是念。我施饮食为饶益他不欲自利。如阿罗汉受我饮食所得饶益。毁戒亦然。是故我今应等心施有说。长者避爱恚故彼作是念。若施不等僧或于我起爱恚心。由此当招不如意果。我即于彼便作怨仇。何得名为真净施主。有说。长者随佛教故彼作是念。如来常说若有于一补特伽罗偏心敬养有五过失。若有一失尚不应为何况于五。有说。长者不望报故。彼作是念。施果异熟唯欲界受。我若命终当生色界。施果于我便为无益。设当有益尚不希求况复无益。故我但应平等心施。有说。长者敬出家故彼作是念。我离欲染得不还果。犹于居家眷属珍财不能弃舍。诸出家者虽有具缚。而于居家眷属财产能弃能舍能不积集。受佛禁戒尽寿修行。纯一圆满清净梵行。设有失念毁犯戒者。深生惭耻常希清净。若在居家不能如是。故我于此应等心施。有说。长者重仪相。故彼作是念。诸出家人剃发染衣。仪相同佛持戒破戒。俱令世间瞻睹生福。为作福田故我于中应等心施。有说。长者荷佛恩故彼作是念。我依佛法获得忍智。金刚杵剑摧破二十身见山峰。断截无边恶趣根本。作有边际定趣涅槃。于四谛中慧眼清净。尽下分结出欲淤泥。故我不应于佛弟子。心不平等而行惠施。有说。长者显自所得觉慧坚牢不可转故。彼作是念。我慧坚牢岂随天言轻有转变。故于僧众施心平等。显己如是故来白佛

如契经中佛告庆喜。施食有二果无差别。一者菩萨受彼食已。证得无上正等菩提。二者如来受彼食已。入于无余大涅槃界。问初受食者有贪嗔痴。后受食者贪嗔痴尽。何缘施果无差别耶。答由思及田有偏胜故。佛依偏胜说果无差。谓初难陀难陀跋罗姊妹二人。闻说菩萨受十六转甘味乳糜。必当得成无上等觉。欢喜踊跃发殊胜思。持上乳糜奉施菩萨。菩萨食已即于是夜。降伏魔军成等正觉。女闻倍喜更起胜思。彼所施田虽非殊胜。由思胜故能招胜果。准陀于佛将涅槃时。见佛身形少如衰变。又闻不久必入涅槃。恋慕不堪其心扰乱。殊胜思愿不能现前。然由胜田能招胜果。佛依此故说无差别。有作是说。欲遮准陀变悔心故。如彼经说。佛告阿难。若彼准陀工巧之子。或他所引或自寻思。于施食中而生变悔。于难得事便为不得。难得事者所谓诸佛将涅槃时最后供养。彼若生变悔者。汝便应以六处而劝喻之。谓施食因缘能招长寿。色力乐誉富贵臣僚。我从世尊亲闻是事。施食有二果无差别。一者菩萨受彼食已。证得无上正等菩提。二者如来受彼食已。入于无余大涅槃界。复应告彼准陀。当知于施食中。若生变悔汝于如是难得事中便为不得。如失菩萨将成佛。时奉施乳糜。所生胜福慎莫变悔。由此故言二果无别。有说。二时俱能资益离染身故。谓食于消化时能作食事。佛于后夜成正觉时。彼食消化如成正觉。涅槃亦尔。故说二施果无差别。有说。初受食已证得佛法。后受食已受用佛法。得修习修说亦如是。有说。初受食已便入一切静虑解脱等持等至。后受食已亦入一切静虑解脱等持等至。有说。初受食已渡烦恼河。后受食已渡生死河。有说。初受食已涸烦恼海。后受食已涸生死海。如是拔烦恼树。拔生死树。破烦恼山。破生死山。越烦恼依。越生死依。说亦如是。有说。初受食已弃舍集谛。后受食已弃舍苦谛。有说。初受食已证入道谛。后受食已证入灭谛。有说。初受食已舍集入道。后受食已舍苦入灭。有说。初受食已超越诸漏。后受食已超顺漏法。有说。初受食已超四暴流。后受食已超顺流法。如流顺流说超差别如是。扼顺扼取。顺取身系顺身系。诸盖顺诸盖说超亦尔。有说。初受食已摧破二魔。谓烦恼魔。自在天魔。后受食已亦破二魔谓蕴魔死魔。有说。初受食已入有余大涅槃界。后受食已入无余大涅槃界。佛依如是种种因缘。说二种施果无。差别

    大种蕴第五中缘纳息第二之一

大种与大种为几缘。如是等章。及解章义。既领会已。当广分别。问何故作此论。答欲止譬喻者所说故。彼说缘性非实有法。问彼何故作是说。答依契经故。如契经说。无明缘行。行相有异无明一相。如何一相无明为缘生异相行。而缘是实。尊者亦说。缘是诸师假立名号。体非实有。亦为遮止如是所说显示诸缘体是实有。若诸缘性非实有者。则一切法皆非实有。以因缘摄一切有为法。等无间缘摄过去现在。除阿罗汉最后心聚。余心心所法。所缘缘增上缘摄一切法故。又若缘性非实有者。应不施设诸法甚深。谓不依因缘观察则诸法性粗浅易知。若以因缘而观察者。则甚深义过四大海。唯佛能知非余所测。又若缘性非实有者。应不施设有三菩提。谓以上智观因缘故得佛菩提。以中智观得独觉菩提。以下智观得声闻菩提。又因缘性非实有者。应不施设有三品慧。谓下品慧应常下品。中应恒中。上应恒上。无实缘力令增减故。若尔便无师徒教习。又师徒性应无改转。尊者妙音亦作是说。若缘非实师不应令弟子觉慧转。下作中。转中作上。无修习缘令增长故。师徒教诲应不得成。师应常师弟子亦尔。由如是等所说理故。知缘自性决定实有。问若缘实有当云何通譬喻论师所引经义。答无明虽一作用有多。多用为缘生异相行。以有为法随托众缘。有无量门作用别故。譬如一士而有五能。而不相违彼亦如是。有说。为显诸有为法自性羸劣。不能自起必藉他缘。无实作用无有自在故作斯论。此中自性谓法自体。或云此显所生诸法自性羸劣。以羸劣故有藉四缘。或三或二方得生起。尚无有法藉一缘生况无所藉。如羸病者。必假若四若三若二。所倚任缘而得起转。尚无假一况全不假。或云此显能生因缘自性羸劣。以羸劣故或四或三或二相资方能生法。如羸劣者。或四或三或二相假能办一事。如契经说。色是无常色之因缘亦无常性。无常所起色云何常。由诸有为性羸劣故不能自起。谓彼无力可能自生。由不自生故藉他起。要假缘力方得生故。由藉他缘故无作用。谓法无欲作是念言。我应作谁谁令我作。无作用故则无自在。谓我勿起我勿灭中。诸有为法不自在故。有说。为遣诸缘起愚故作斯论。缘起愚者。谓彼闻说无明缘行。乃至生缘老死。便谓唯此是缘起法今欲决定显示从缘所生。内外诸法皆是缘起。由此等缘故作斯论

大种与大种为几缘。答。因。增上。因者二因。谓俱有。同类。俱生互相望为俱有因。前生与后生为同类因。增上者谓不碍生。及唯无障。此依种类总相而说。然四大种有十一种。谓眼处所依。乃至法处所依。眼处所依与眼处所依为因。增上与余所依但一增上。乃至法处所依与法处所依为因。增上与余所依但一增上。眼处所依大种复有二种。谓左与右左与左所依为因。增上与右所依但一增上。右与右所依为因。增上与左所依但一增。上左眼所依大种复有二种。谓所长养及异熟生。长养与长养为因。增上与异熟生但一增上。异熟与异熟为因。增上与所长养但一增上。异熟大种复有二种。谓善业异熟及不善业异熟。善业异熟与善业异熟为因。增上与不善业异熟但一增上。不善业说亦尔。善业异熟大种复有二种。谓天及人。天与天为因。增上与人但一增上。人说亦尔。天大种复有二种。谓欲界及色界。欲界与欲界为因。增上与色界但一增上。色界说亦尔。色界大种复有四种。谓初静虑乃至第四静虑。初静虑与初静虑为因。增上与余静虑但一增上。乃至第四静虑说亦尔。不善业异熟大种复有三种。谓地狱傍生饿鬼。地狱与地狱为因。增上与余二但一增上。傍生饿鬼说亦尔。如说异熟。长养亦尔。如说左右亦尔。如说眼处所依大种。乃至法处所依大种亦尔。此中异者。谓五外处有自他身。情非情等差别应思。问同趣同地处所差别。展转相望为有因不。答有说。无因。此不应理。应有大种是刹那故。谓五净居所有大种。无始生死曾未起故。诸所造色十一种等准前大种广说应知。大种与所造色为几缘。答因。增上。因者五因。谓生因。依因。立因。持因。养因。增上者谓不碍生。及唯无障。有说。大种与所造触为同类因。此不应理。大种所造触非同类故。所造色与所造色为几缘。答因。增上。因者三因。谓俱有。同类。异熟。增上者谓不碍生。及唯无障。此总相说。差别说者准前大种如理应思。所造色与大种为几缘。答因。增上。因者一因。谓异熟因。增上者。谓不碍生。及唯无障。有说。造触与诸大种为同类因。此不应理。造触大种非同类故

大种与心心所法为几缘。答所缘。增上。所缘者。谓与身识彼相应法。及与意识彼相应法为所缘。身识及相应法。取自相。意识及相应法。取自相共相。增上者如前说。心心所法与心心所法为几缘。答因。等无间。所缘。增上。因者五因。谓相应。俱有。同类。遍行。异熟。等无间者。谓心心所法等无间。心心所法现在前。所缘者。谓心心所法。与心心所法为所缘。增上者如前说。心心所法与大种为几缘。答因。增上。因者。一因。谓异熟因。增上者如前说。大种与眼处为几缘。答因。增上。因者五因。谓生等五。增上者如前说。眼处与眼处为几缘。答因增上。因者一因。谓同类因。增上者如前说。眼处与大种为几缘。答一增上。增上义如前说。如眼处。耳鼻舌身香味处亦尔。大种与色处为几缘。答因。增上。因者五因。谓生等五。增上者如前说。色处与色处为几缘。答因。增上。因者二因。谓同类。异熟。增上者如前说。色处与大种为几缘。答因。增上。因者一因。谓异熟因。增上者如前说。如色处。声触处亦尔。总说虽然而义有异。谓大种与声处为因。增上。因者。五因。谓生等五。增上者如前说。声处与声处为因。增上。因者一因。谓同类因。增上者如前说。声处与大种为因。增上。因者一因。谓异熟因。增上者如前说。大种与触处为因。增上。因者七因。谓生等五。及俱有。同类增上者如前说。触处与触处为因。增上。因者七因。谓生等五。及俱有。同类。增上者如前说。触处与大种为因。增上。因者二因。谓俱有。同类。增上者如前说。大种与意处为几缘。答所缘。增上。所缘者谓与身识意识为所缘。身识取自相。意识取自相共相。身识取时若一若多广如前说。意处与意处为几缘。答因。等无间。所缘。增上。因者三因。谓同类。遍行。异熟。等无间者。谓意处等无间。意处现在前。所缘者。谓意处与意处为所缘。增上者如前说。此依种类总相而说。然意处有六种。谓眼识。乃至意识。此中眼识与眼识为因。等无间。增上。非所缘。因者二因。谓同类。异熟。等无间者谓眼识等无间。眼识现在前。增上者如前说。非所缘者以眼识唯缘色。眼识非色故。如眼识与眼识。眼识与耳鼻舌身识亦尔。眼识与意识为因等无间。所缘。增上。因者。二因。谓同类。异熟等无间者。谓眼识等无间。意识现在前。所缘者。谓眼识与意识为所缘。增上者如前说。如眼识对六识。耳鼻舌身识对六亦尔意识与意识为因。等无间。所缘。增上。因者三因。谓同类。遍行。异熟。等无间者。谓意识等无间。意识现在前。所缘者。谓意识与意识为所缘。增上者如前说。意识与眼识为因。等无间增上。非所缘。因者三因。即同类。遍行。异熟。等无间者。谓意识等无间眼识现在前增上者如前说。非所缘者。以眼识唯缘色。意识非色故。如意识对眼识。意识对余识亦尔。问眼等五识展转无间现在前不。答诸瑜伽师说。眼等五识展转无间不现在前。皆从意识无间生故。阿毗达磨诸论师言。眼等五识展转皆得无间而起。若不尔者违根蕴说。如彼说。苦根与苦根为因。等无间。增上。非所缘。意处与大种为几缘。答因。增上。因者一因。谓异熟因。增上者如前说。大种与法处为几缘。答因。所缘。增上。因者七因。谓生等五。及俱有。同类。所缘者。谓与身识相应法。及意识相应法。为所缘。增上者如前说。法处与法处为几缘。答因。等无间。所缘。增上。因者五因。即相应等五。等无间者。谓法处等无间。法处现在前。所缘者。谓法处与法处为所缘。增上者如前说。法处与大种为几缘。答因。增上。因者三因。谓俱有。同类。异熟。增上者如前说

大种与眼根为几缘。答因。增上。因者五因。谓生等五。增上者如前说。眼根与大种为几缘。答一增上。增上义如前说。如眼根。耳鼻舌身男女根亦尔。大种与命根为几缘。答一增上。增上义如前说。命根与大种为几缘。答一增上。增上义如前说。大种与意根为几缘。答所缘。增上。所缘增上义皆如前说。意根与大种为几缘。答因增上。因者一因。谓异熟因。增上者如前说。如意根。乐苦喜忧舍信精进念定慧根亦尔。大种与未知当知根为几缘。答所缘。增上。所缘者。谓诸大种与苦忍苦智。集忍集智。及相应根为所缘。增上者如前说。未知当知根与大种为几缘。答一增上。增上义如前说。如未知当知根。已知根具知根亦尔。问大种对处问答有三。何故对根问答唯二。答彼造论者意欲尔故。谓所造论随彼意欲而造论。但令不违法相。不应责其所以。有说。此是有余之说。有说。此中现种种文种种说。庄严于义令易解故。有说。此中现二门二略乃至广说。有说。诸根即处所摄。若说处当知已说根。是以不问。有说。此中广略渐次。谓初四问次三后二。由前广说后可准知。为去繁文渐略而说。问色法于色法有同类因耶。答西方诸师。譬喻尊者说。色于色无同类因。对法诸师说。色于色有同类因。如前杂蕴同类因中已广分别

何故四大种一生一住一灭而不相应。心心所法一生一住一灭说名相应。答如四大种或减或增。心心所法则不如是。此中生者。谓生所生。住者谓住所住。及异所异。灭者谓灭所灭。问诸有为法各有生住灭。何故乃言一生一住一灭。答有因缘故说各有生住灭。谓各别有诸相相故非一相。有因缘故说一生一住一灭。谓皆不离一刹那时等。于一时生住灭故。问四大种体有增减不。设尔何失二俱有过。若有增减宁不相离。所以者何。若坚物中地极微多。水火风少。地微随与水等量杂余则相离。乃至动物说亦如是。若无增减水石等物。不应得成坚软等异。答应言大种体有增减。问若尔云何名不相离。答虽有增减而不相离。以展转相资同作所作故。如坚物中虽地微多水火风少。然离水等地微不能作所作事。乃至动物说亦如是。如多村邑共营一事。虽有人数多少不同。而互相须不可相离。问心心所体亦有增减。如何乃言则不如是。谓心所法于三界。三性。有漏。无漏。诸心聚中有多有少。答由事等故不名增减。若一心中有二想一受等可名增减。然一心中一想一受等故异大种。有说。大种体无增减。问石等云何坚软等异。答大种势力有增微故。如坚物中四大极微。体数虽等而其势力地极微增。乃至动物说亦如是。如一两盐和一两糗置于舌上。盐生识猛糗生识微。此亦如是。水酢均和生舌识喻。针锋鸟翮生身识喻。广说亦尔。问心心所法亦用有增微。如指鬘利根。蛇奴根钝。如何言不如是耶。答如四大种势力粗显。增微易了是以说之。心心所法则不如是。由此大种不说相应。又心心所法皆有所缘。四大种无所缘。非无所缘法可说相应。所以者何。心心所法。有所依。有行相。有发悟故。必有所缘。有所缘故恒相应不相离。四大种与此相违。故无所缘无所缘故。虽不相离而不相应。不相离有二种。一大种不相离共造一色故。二心心所法不相离共缘一境故。五蕴虽复同在一身。无此二事非不相离。是故大种不说相应

问云何得知此四大种恒不相离。答自相作业一切聚中皆可得故。谓坚聚中地界自相现可得故有义极成。于此聚中若无水界。金银锡等应不可销。又水若无彼应分散。若无火界石等相击火不应生。又火若无无能成熟彼应腐败。若无风界应无动摇。又若无风应无增长。于湿聚中水界自相现可得故有义极成。于此聚中若无地界至严寒位应不成冰。又地若无船等应没。若无火界应无暖时。又火若无彼应腐败。若无风界应不动摇。又风若无应无增长。于暖聚中火界自相现可得故有义极成。于此聚中若无地界灯烛等焰应不可回。又地若无不应持物。若无水界应不生流。又水若无焰不应聚。若无风界应不动摇。又若无风应无增长。于动聚中风界自相现可得故有义极成。于此聚中若无地界触墙等障应不折回。又地若无应不持物。若无水界应无冷风。又水若无彼应分散。若无火界应无暖风。又火若无彼应腐败。问此四大种其相各异展转相违。云何一时不相离起。尊者世友作如是说言。异相相违因缘各别。非诸相异皆必相违。诸不相违而相异者。容俱时起互不相离。如四大种及香味触青黄色等。诸有异相而互相违。必无一时不相离起。如薪与火。雹与稼穑。逻呼月轮。药病明闇

说一切有部发智大毗婆沙论卷第一百三十一阿毗达磨大毗婆沙论卷第一百三十二

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    大种蕴第五中缘纳息第二之二

问若坚不坚物转相作者。诸法云何不舍自相。云何相作。如水性软至冬凝结。斧斫犹难金等性坚。若置炎炉便销如水。如是等岂非诸法舍自相耶。答非诸坚物转作不坚。亦非不坚转成坚物。然坚不坚法住未来世。若遇坚缘。则不坚法灭坚法续生。遇不坚缘则坚法灭不坚续生。余亦如是。故无诸法舍自相过

问大种等聚中有间隙不。设尔何失。二俱有过。若有间隙宁不相离。间隙若无何不成一。答有说。此有间隙空界于中相杂住故。问若尔。云何名不相离。答空界于中能自隐匿。令于诸物见不相离。如丛中女自蔽其身。有说。此无间隙展转相逼无间住故。问若尔。云何不成一耶。答虽无间隙而不成一。如蕴处界三世等中。间隙虽无而不成一。彼亦如是。又大种等自体作用。各各异故不可成一

问诸极微互相触不。设尔何失。二俱有过。若相触者宁不成一。或成有分。若不相触击时应散或应无声。答应作是说。极微互不相触。若触则应或遍或分。遍触则有成一体过。分触则有成有分失。然诸极微更无细分。问聚色相击宁不散耶。答风界摄持故令不散。问岂不风界能飘散耶。答有能飘散。如坏劫时。有能摄持。如成劫时。问若不触者。即相击时云何发声。答即由此因故使声发。若相触者。如何发声。谓诸极微体相触者。手等相和体应相糅。中无间隙如何发声。尊者世友作如是说。若诸极微互相触者。彼应得住至后刹那。大德说言。实不相触。但于合集无间生中。随世俗谛假名相触。问诸是触物。为是触为因故生。为非触为因故生。诸非触物。为非触为因故生。为是触为因故生。答有时是触为因生于非触。谓和合物正离散时。有时非触为因生于是触。谓离散物正和合时。有时是触为因生于是触。谓和合物复和合时。有时非触为因生于非触。谓向游尘同类相续

问极微当言可见不可见耶。答尊者妙音作如是说。极微当言可见。慧眼境故。阿毗达磨诸论师言。极微当言不可见非肉天眼所能见故。此中不依慧眼作问。以于诸法无差别故。颇有过去大种造过去色耶。乃至广说。问何故作此论。答欲止他义显己义故。谓有余部拨无去来说现在世是无为法。欲止彼意显有去来。亦明现在是有为法。广如前说。复有外道。依世现喻执有为法后为前因。彼作是言。现见泉水前为后逼令其涌流。如是诸法由未来法逼令现在。复由现法逼令过去。故有为法后为前因。今欲止彼外道所说。显有为法前能生后非后前因。不尔便违内外缘起。谓世父母应从子生。眼色应从眼识而起。应无明等从行等生。种等应从芽等而起。先受苦乐报后造善恶业。先得菩提然后修行。既未作而得应已作而失。若尔便无得解脱理。又欲遮说大种造色必同世者。显有异世。由此因缘故作斯论。诸有对所造色。及随心转无表色。随在何世即彼世大种造。谓过去造过去现在造现在。未来造未来。若表所起诸无表色。复有三类造时不等。谓初刹那如有对等。各为同世大种所造。第二刹那若在过现。俱为过去大种所造。若在未来通为现未大种所造。后诸刹那过现如前。若在未来通为三世大种所造。所以者何。诸有依表发起律仪及不律仪非二无表。初刹那顷表无表色。与此及余能造大种现在俱灭。灭至第二刹那以后表及大种俱在过去。诸无表色有在过去。有在未来。有在现在。是谓此处略毗婆沙颇有过去大种造过去色耶。答有。谓过去一切有对所造色。随心转无表。表所起无表。唯为过去大种所造。颇有过去大种造未来色耶。答有。谓有未来表所起无表。唯为过去大种所造。颇有过去大种造现在色耶。答有。谓有现在表所起无表。唯为过去大种所造。颇有未来大种造未来色耶。答有。谓未来一切有对所造色。随心转无表。及有未来表所起无表。唯为未来大种所造。颇有未来大种造过去现在色耶。答无。谓无果先因后理故。颇有现在大种造现在色耶。答有。谓现在一切有对所造色。随心转无表。及有现在表所起无表。唯为现在大种所造。颇有现在大种造过去色耶。答无。谓无果先因后理故。颇有现在大种造未来色耶。答有。谓有未来表所起无表。唯为现在大种所造。诸随心转无表。是等流。无执受有情数摄。彼能造大种是长养。无执受有情数摄。诸表所起无表。是等流。无执受有情数摄。彼能造大种是等流。有执受有情数摄。诸随心转无表。有二种。一静虑律仪所摄。二无漏律仪所摄。此各有七。谓离害生命。乃至离杂秽语。静虑律仪所摄七种。共一四大种所造。无漏律仪七种亦尔。诸表所起无表有三种。一律仪所摄。二不律仪所摄。三非律仪非不律仪所摄。律仪所摄复有七种。谓离害生命。乃至离杂秽语。如是七种各一四大种所造。离害生命复有二种。谓表无表。此二各一四大种所造。有余师说。此表无表共一四大种所造。故彼问言颇有一四大种造二处色耶。答有。谓色处法处。及声处法处。尊者妙音亦作是说。阿毗达磨诸论师言。彼说非理。不可一四大种造粗细二果。是故如前所说者好。如离害生命。表与无表各一四大种所造。如是乃至离杂秽语亦尔。不律仪所摄亦有七种。谓害生命乃至杂秽语。非二所摄有二七种。谓害生命离害生命。乃至杂秽语离杂秽语。此诸七种各一四大种所造。如是诸七各复有二。谓表无表。此亦各一四大种造。余师说等如前应知。若成就过去大种。彼过去所造色耶。乃至广说。问何故作此论。答欲止拨无去来二世。及说成就不成就体非实有者。意显去来世。及成就等是实有法。故作此论。若成就过去大种。彼过去所造色耶。答无成就过去大种。有成就过去所造色。谓诸圣者住胎藏中。若生欲界住律仪。若住不律仪。若住非律仪非不律仪。先有身语表不失。若生色界。若诸学者生无色界。问亦有学者。生无色界不成就过去所造色。谓彼先在欲色界时。未起未灭诸无漏道。命终生无色界。都不成就过去所造色。如何乃说。若诸学者。生无色界成就过去所造色耶。答依成就者作如是说。谓有学者先欲色界。已起已灭诸无漏道。彼成就过去所造色故。有说。彼在欲色界时。必已起灭诸无漏道。如胜进道必起现前。无有住果而命终故

若成就过去大种。彼未来大种耶。答无成就过去未来大种。问何故无成就过去未来大种耶。答由彼大种但有尔所成就势力刹那现前则有成就。已灭未现无成就者。谓诸大种与成就得必同一世。今时彼得不现在前故不成就。有说。大种习气不坚。故无成就去来世者。以是羸劣无记性故。谓善恶等习气坚牢。故有成就去来世者。劣无记法则不如是。如暂执持极香花物。虽加洗拭习气犹随。非如执持余木石等。手才放舍此气便无。有说。若成就去来世大种者。则一趣成就五趣大种。如是一身即五趣身。是则趣坏所依亦坏。欲令无如是过。是故大种不成就去来。问如生一趣。成就五趣诸业烦恼。而非趣坏。此亦应然。答以异熟果故说诸趣差别。不以业烦恼故。然诸大种或有是异熟果者。则有趣坏及所依坏过失。故彼非难

若成就过去大种。彼未来所造色耶。答无成就过去大种。有成就未来所造色。谓诸圣者住胎藏中。若生欲界得色界善心。若生色界。若诸圣者生无色界。以彼定成就未来所造色故若成就过去大种。彼现在大种耶。答无成就过去大种。有成就现在大种。谓生欲色界。无有生欲色界不成就大种故。若成就过去大种。彼现在所造色耶。答无成就过去大种。有成就现在所造色。谓生欲色界。无有生欲色界不成就所造色故若成就过去所造色。彼未来大种耶。答无成就未来大种。有成就过去所造色。谓诸圣者住胎藏中。若生欲界住律仪。若住不律仪。若住非律仪非不律仪。先有身语表不失。若生色界若诸学者。生无色界。能成就过去所造色。彼未来所造色耶。答应作四句。有成就过去所造色。非未来所造色。谓生欲界住律仪。不得色界善心。若住不律仪。若住非律仪非不律仪。先有身语表不失。有成就未来所造色。非过去所造色。谓阿罗汉生无色界。有成就过去所造色。亦未来所造色。谓诸圣者住胎藏中。若生欲界得色界善心。若生色界。若诸学者生无色界。有非成就过去所造色。亦非未来所造色。谓处卵[穀-禾+卵]。若诸异生住胎藏中。若生欲界。住非律仪非不律仪。先无身语表。设有而失。若诸异生生无色界

若成就过去所造色。彼现在大种耶。答应作四句。有成就过去所造色。非现在大种。谓诸学者生无色界。有成就现在大种。非过去所造色。谓处卵[穀-禾+卵]。若诸异生住胎藏中。若生欲界住非律仪非不律仪。先无身语表。设有而失。有成就过去所造色。亦现在大种。谓诸圣者住胎藏中。若生欲界住律仪。若住不律仪。若住非律仪非不律仪。先有身语表不失。若生色界有非成就过去所造色。亦非现在大种。谓阿罗汉若诸异生生无色界。若成就过去所造色。彼现在所造色耶。答应作四句。有成就过去所造色。非现在所造色。谓诸学者生无色界。有成就现在所造色。非过去所造色。谓处卵[穀-禾+卵]。若诸异生住胎藏中。若生欲界住非律仪非不律仪。先无身语表。设有而失。有成就过去所造色。亦现在所造色。谓诸圣者住胎藏中。若生欲界住律仪。若住不律仪。若住非律仪非不律仪。先有身语表不失。若生色界有非成就过去所造色。亦非现在所造色。谓阿罗汉。若诸异生。生无色界。过去已舍故。现在无色身故

若成就未来大种。彼未来所造色耶。答无成就未来大种。有成就未来所造色。谓诸圣者住胎藏中。若生欲界得色界善心。若生色界若诸圣者生无色界。若成就未来大种。彼现在大种耶。答无成就未来大种。有成就现在大种。谓生欲色界。无有生欲色界不成就大种故。若成就未来大种。彼现在所造色耶。答无成就未来大种。有成就现在所造色。谓生欲色界。无有生欲色界不成就现在所造色故。若成就未来所造色。彼现在大种耶。答应作四句有成就未来所造色非现在大种。谓诸圣者生无色界。有成就现在大种。非未来所造色。谓处卵[穀-禾+卵]。若诸异生住胎藏中。若生欲界不得色界善心。有成就未来所造色。亦现在大种。谓诸圣者住胎藏中。若生欲界得色界善心。若生色界有非成就未来所造色。亦非现生大种。谓诸异生生无色界。若成就未来所造色。彼现在所造色耶。答应作四句。有成就未来所造色。非现在所造色。谓诸圣者生无色界。有成就现在所造色。非未来所造色。谓处卵[穀-禾+卵]。若诸异生住胎藏中。若生欲界不得色界善心。有成就未来所造色。亦现在所造色。谓诸圣者住胎藏中。若生欲界得色界善心。若生色界。有非成就未来所造色。亦非现在所造色。谓诸异生生无色界若成就现在大种。彼现在所造色耶。答如是。设成就现在所造色。彼现在大种耶。答如是。以非现在大种无果故。亦非现在所造色无因故

过去大种与过去大种为几缘。答因。增上。因者二因。谓俱有。同类。俱生互相望为俱有因。前生与后生为同类因。增上者。谓不碍生。及唯无障。过去大种与过去所造色为几缘。答因。增上。因者五因。谓生因。依因。立因。持因。养因。增上者。如前说。过去所造色与过去所造色为几缘。答因。增上。因者三因。谓俱有同类。异熟。增上者如前说。过去所造色与过去大种为几缘。答因。增上。因者一因。谓异熟因。增上者如前说

过去大种与未来大种为几缘。答因。增上。因者一因。谓同类因。增上者如前说。未来大种与未来大种为几缘。答因。增上。因者一因。谓俱有因。增上者如前说。未来大种与过去大种为几缘。答一增上。增上义如前说。过去大种与未来所造色为几缘。答因。增上。因者五因。谓生等五。增上者如前说。未来所造色与未来所造色为几缘。答因。增上。因者二因。谓俱有因。异熟因。增上者如前说。未来所造色与过去大种为几缘。答一增上。增上义如前说

过去大种与现在大种为几缘。答因。增上。因者一因。谓同类因。增上者如前说。现在大种与现在大种为几缘。答因。增上。因者。有说。此中依刹那现在为论故唯一因。谓俱有因。有说。此中通依刹那分位。一生现在为论故。有二因。谓俱有同类。增上者如前说。现在大种与过去大种为几缘。答一增上。增上义如前说。过去大种与现在所造色为几缘。答因。增上。因者五因。生等五。增上者如前说现在所造色与现在所造色为几缘。答因。增上。因者。有说。此中依刹那现在为论故唯一因。谓俱有因。有说。此中通依刹那分位。一生现在为论故。有三因。谓俱有。同类。异熟。增上者如前说。现在所造色与过去大种为几缘。答一增上增上义如前说

过去所造色与未来大种为几缘。答因。增上。因者一因。谓异熟因。增上者如前说未来大种与过去所造色为几缘。答一增上。增上义如前说。过去所造色与未来所造色为几缘。答因。增上。因者二因。谓同类。异熟。增上者如前说。未来所造色与过去所造色为几缘。答一增上。增上义如前说

过去所造色与现在大种为几缘。答因。增上。因者一因。谓异熟因。增上者如前说。现在大种与过去所造色为几缘。答一增上。增上义如前说。过去所造色与现在所造色为几缘。答因。增上。因者二因。谓同类。异熟。增上者如前说。现在所造色与过去所造色为几缘。答一增上。增上义如前说

未来大种与未来所造色为几缘。答因。增上。因者五因即生等五。增上者如前说。未来所造色与未来大种为几缘。答因。增上。因者一因。谓异熟因。增上者如前说

未来大种与现在大种为几缘。答一增上。增上义如前说。现在大种与未来大种为几缘。答因。增上。因者一因。谓同类因。增上者如前说。未来大种与现在所造色为几缘。答一增上增上义如前说。现在所造色与未来大种为几缘。答因。增上。因者一因。谓异熟因。增上者如前说

未来所造色与现在大种为几缘。答一增上。增上义如前说。现在大种与未来所造色为几缘。答因。增上。因者五因。谓生等五。增上者如前说。未来所造色与现在所造色为几缘。答一增上。增上义如前说。现在所造色与未来所造色为几缘。答因。增上。因者二因。谓同类。异熟。增上者如前说现在大种与现在所造色为几缘。答因。增上。因者五因。谓生等五。增上者如前说。现在所造。色与现在大种为几缘。答因。增上。因者一因。谓异熟因。增上者如前说。诸说此中依刹那分位。一生现在。为论者。则符此答。诸说此中但依刹那现在。为论者。则应答言。但一增上。便与本论答不相应若成就欲界系大种。彼欲界系所造色耶。答如是。设成就欲界系所造色。彼欲界系大种耶。答如是。以无成就欲界系大种而非果故。亦无成就欲界系所造色而非因故。若成就欲界系大种。彼色界系大种耶。答应作四句。有成就欲界系大种。非色界系大种。谓生欲界。色界大种不现在前。有成就色界系大种。非欲界系大种。谓生色界。不作欲界化。不发欲界语。有成就欲界系大种。亦色界系大种。谓生欲界。色界大种现在前。若生色界。作欲界化。发欲界语。有非成就欲界系大种。亦非色界系大种。谓生无色界。若成就欲界系大种。彼色界系所造色耶。答应作四句。有成就欲界系大种。非色界系所造色。谓生欲界。不得色界善心。有成就色界系所造色。非欲界系大种。谓生色界。不作欲界化。不发欲界语。有成就欲界系大种。亦色界系所造色。谓生欲界。得色界善心。若生色界作欲界化。发欲界语。有非成就欲界系大种。亦非色界系所造色。谓生无色界

若成就欲界系所造色彼色界系大种耶。答应作四句。有成就欲界系所造色。非色界系大种。谓生欲界。色界大种不现在前。有成就色界系大种。非欲界系所造色。谓生色界不作欲界化。不发欲界语。有成就欲界系所造色。亦色界系大种。谓生欲界。色界大种现在前。若生色界。作欲界化。发欲界语。有非成就欲界所造色。亦非色界大种。谓生无色界

若成就欲界系所造色。彼色界系所造色耶。答应作四句。有成就欲界系所造色。非色界系所造色。谓生欲界不得色界善心。有成就色界系所造色。非欲界系所造色。谓生色界不作欲界化。不发欲界语。有成就欲界系所造色。亦色界系所造色。谓生欲界得色界善心若生色界作欲界化。发欲界语。有非成就欲界系所造色。亦非色界系所造色。谓生无色界

若成就色界系大种。彼色界系所造色耶。答诸成就色界系大种。彼定成就色界系所造色。有成就色界系所造色。非色界系大种。谓生欲界。得色界善心。色界大种不现在前。问生欲界者。住色界何等心。令彼大种现在前。为一向住善。为三种耶。设尔何失。俱见其过。若一向住善心者。施设论说当云何通。如说住此无闻异生由起色贪缠所缠故。五蕴色有于现法中以取为缘趣当来有。若住三种心者。善心可尔。有随转色为彼果故。染及无记为有何果令彼现前。有作是说唯住善心。问施设论说当云何通。答彼说身中所增长色。问若尔。彼说复云何通。如说住此无闻异生。由起无色贪缠所缠故四蕴无色。有于现法中以取为缘趣当来有。彼身亦有所增长色。何故不说。有作是说。应说而不说者。当知此义有余。有说。起彼界缠时无增长色。是以不说。复有说者。住三种心。问善心可尔。有随转果故。余二有何果令彼现前。答彼生欲界者。起色界善心时。由随转色故。令彼现前。起染污心时。由有彼地空界色。在此身中相杂住故。令彼现前。起无记心时。由有彼地化色。令彼现前故住三种心皆能起彼地大种

说一切有部发智大毗婆沙论卷第一百三十二阿毗达磨大毗婆沙论卷第一百三十三

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    大种蕴第五中缘纳息第二之三

欲界系大种与欲界系大种为几缘。答因。增上。因者二因。谓俱有。同类。俱生互相望为俱有因。前生与后生为同类因。增上者。谓不碍生。及唯无障。欲界系大种与欲界系所造色。为几缘。答因。增上。因者五因。谓生因。依因。立因。持因。养因。增上者如前说。欲界系所造色与欲界系所造色为几缘。答因。增上。因者二因。谓同类。异熟。增上者如前说。欲界系所造色与欲界系大种为几缘。答因。增上。因者一因。谓异熟。增上者如前说

欲界系大种与色界系大种为几缘。答一增上。增上义如前说。色界系大种与色界系大种为几缘答因。增上。因者二因。谓俱有。同类。增上者如前说。色界系大种与欲界系大种为几缘。答一增上。增上义如前说

欲界系大种与色界系所造色为几缘。答一增上。增上义如前说。色界系所造色与色界系所造色为几缘。答因。增上。因者三因。谓俱有。同类。异熟。增上者如前说。色界系所造色与欲界系大种。为几缘。答一增上。增上义如前说

欲界系所造色与色界系大种为几缘。答一增上。增上义如前说。色界系大种与欲界系所造色为几缘。答一增上。增上义如前说。欲界系所造色与色界系所造色为几缘。答一增上。增上义如前说。色界系所造色与欲界系所造色为几缘。答一增上。增上义如前说。色界系大种与色界系所造色为几缘。答因。增上。因者五因。谓生等五。增上者如前说。色界系所造色与色界系大种为几缘。答因。增上。因者一因。谓异熟因。增上者如前说。诸色欲界系。彼色一切欲界系大种所造耶。答应作四句。有色欲界系。非欲界系大种所造。谓欲界系大种。以诸大种非所造故。有色欲界系大种所造。非欲界系。谓色不系欲界系大种所造。此复云何。谓一切法智品随转色。及依欲界身现前类智品随转色有色欲界系。欲界系大种所造。谓色欲界系。欲界系大种所造。此复云何。谓欲界系有对所造色。及表所起无表。有色非欲界系。非欲界系大种所造。谓色界系大种。若色色界系。色界系大种所造。若色不系。色界系大种所造

诸色色界系彼色一切色界系大种所造耶。答应作四句。有色色界系。非色界系大种所造。谓色界系大种。所以如前有色色界系大种所造。非色界系。谓色不系。色界系大种所造。此复云何。谓依色界身现前类智品随转色。有色色界系。色界系大种所造。谓色色界系。色界系大种所造。此复云何。谓色界系有对所造色。及有漏随心转无表。有色非色界系。非色界系大种所造。谓欲界系大种。若色欲界系。欲界系大种所造。若色不系。欲界系大种所造

诸色过去。彼色一切过去大种所造耶。答应作四句。有色过去非过去大种所造。谓过去大种。所以如前。有色过去大种所造。非过去。谓色未来现在过去大种所造。此复云何。谓未来现在表所起无表。过去大种所造。以依过去表故。有色过去过去大种所造。谓色过去。过去大种所造。此复云何。谓过去一切有对所造色。随心转无表。表所起无表。有色非过去非过去大种所造。谓未来现在大种。若色未来现在。现在大种所造。若色未来。未来大种所造

诸色未来。彼色一切未来大种所造耶。答诸色未来大种所造。彼色一切未来。此复云何。谓未来一切有对所造色。随心转无表。若表所起无表。未来大种所造。以依未来表故。有色未来非未来大种所造。谓未来大种。若色未来。过去现在大种所造。此复云何。谓未来表所起无表。过去现在大种所造。以依过去现在表故

诸色现在。彼色一切现在大种所造耶。答应作四句。有色现在非现在大种所造。谓现在大种若色现在。过去大种所造。此复云何。谓现在表所起无表。过去大种所造。所以如前。问此无表色。亦有现在所依大种。何故不说耶。答彼是转依。非造依故。此无表色有二种依。一是转依。谓现在大种。由彼力转故。二是造依。谓过去大种。由彼力造故。此中但说造依。不说转依。是故不说。能造五因皆过去故。有色现在。大种所造非现在。谓色未来。现在大种所造。此复云何。谓未来表所起无表。现在大种所造。所以如前。有色现在。现在大种所造。谓色现在。现在大种所造。此复云何。谓现在一切有对所造色。随心转无表。若现在表所起无表。现在大种所造。以依现在表故。有色非现在。非现在大种所造。谓过去未来大种。若色过去。未来过去大种所造。若色未来。未来大种所造地云何。乃至广说问何故作此论。答欲令疑者得决定故。谓此论中多说胜义。或有生疑。彼作论者唯善胜义。不善世俗。为令彼疑得决定故。显地界等与地等别。故作斯论

地云何。答显形色此是世俗想施设地谓诸世间于显形色。依共假想施设地名。如世间说青黄地等。长短地等。地界云何。答坚性触。此是胜义能造地体

水云何。答显形色此是世俗想施设水。谓诸世间于显形色。依共假想施设水名。如世间说青黄等水。长短等水。云何水界。答湿性触。此是胜义能造水体

火云何。答显形色此是世俗想施设火。谓诸世间于显形色。依共假想施设火名。如世间说青黄等火。长短等火。又如梵志观火。颂云

  赤焰多疾疫　　黄兵缘饥馑
  彩丰青退减　　白黑主兴灭

火界云何。答暖性触。此是胜义能造火体。风云何。答即风界。风界云何。答动性触。问何故不说世俗风耶。答世间于风无假想故。有余师说。世间于风亦起假想少故不说。如世间说此有尘风。此无尘风。毗湿缚风。吠岚婆风。小风大风。尘轮风等

地水火风几处所摄。乃至广说。问何故作此论。答欲令疑者得决定故。谓闻所说世俗地等。便谓无体。非处所摄。非识所识。或谓假实同一处摄。同一识识。为除彼疑显假地等亦实有体但假立名。于五处中随一处摄。于五识中随一识识。又显假实不同处摄。不同识识。由此等缘故作斯论

地水火风几处所摄。几识所识。答地水火一处所摄。谓色处眼所见故。二识所识。谓眼识意识。眼识取自相。意识取自相共相。风一处所摄。谓触处身所得故。二识所识谓身识意识。取自共相如前应知。有说。此亦通色处摄。及眼识识少故不说

地水火风界几处所摄几识所识。答一处所摄谓触处身所得故。二识所识。谓身识意识。取自共相如前应知。问几处和合说为能牵。几处和合说为所牵。答若有情数于有情数。则九处能牵。九处所牵。若有情数于非有情数则九处能牵。四处所牵。若非有情数于非有情数。则四处能牵。四处所牵。若非有情数于有情数。则四处能牵。九处所牵。如说牵持运等亦尔。问几处和合说为能量。几处和合说为所量。答四处能量。四处所量。五根微妙非量法故。问几处和合说为能称。几处和合说为所称。有作是说。四处能称四处所称。有余师说。四处能称重是所称。问几处和合说为能烧。几处和合说为所烧。有作是说。四处能烧。四处所烧。有余师说。暖是能烧。四是所烧。问几处和合说为能断。几处和合说为所断。有作是说。四处能断。四处所断。有余师说。坚性是能断。四处是所断。问几处和合说为能洗。几处和合说为所洗。有作是说。四处能洗。四处所洗。有余师说。四处能洗。色处所洗。如说洗已鲜白。或如金色。复有说者。四处能洗。触是所洗。如说杯盛澡屑往某池边。揩洗其身令去尘垢。或有说者。四处是能洗。十二处是所洗。由洗浴故。内十二处皆悉明净离诸垢浊

问此四大种几能为灾。答三。除地问何故地不能为灾。答非其田。非其器。乃至广说。有说。猛利方能为灾。地性迟钝不能为灾。有说。若能损坏内事。彼于外事亦能为灾。谓断末摩名坏内事。此唯三大。故地非灾。有说。为坏地故立灾。三大于地能烧浸击故说为灾。地则不尔。有说。若地亦为灾者。应从风轮。乃至第四静虑皆令坚固。合为一抟此乃成劫非谓能坏。有说。若地能为灾者。便应坏及第四静虑。然无诸灾坏及彼者。此中因论生论。何故彼地灾不及之。有说。即由地非灾故。有说。彼地若为灾及是则应无最上灾顶。谓上三静虑如次能为三灾之顶。若第四静虑灾所坏者。便更无处为上灾顶。以诸无色无方处故。有说欲避净居诸天。由彼更无上生义故。若彼处所灾所及者。则净居天无有尽寿而涅槃者。若尔云何知彼寿量。若言亦有尽寿涅槃。是则彼地灾无由起。如说若处乃至尚余一蚁卵在灾便不坏。有说若处有内灾者便有外灾。第四静虑无内灾故外灾不及。谓初静虑内有如火寻伺故。外有火灾。第二静虑内有如水喜悦故外有水灾。第三静虑内有入出息风故外有风灾。第四静虑更无内灾。是故外灾皆不能及

问火灾起时火从何出。有作是说。世界成时有七日轮俱时而起。持双山后隐伏而住。然后彼处一日轮升。绕苏迷卢而为照耀。至劫将末火灾起时。余六日轮渐次而出。由彼势力世界便坏。有说。世界将欲坏时。即一日轮分为七日。由彼势力世界便坏。有说即一日轮至劫将末。成七倍热焚烧世界。有说。七日先藏地下。后渐出现作用如前。如是说者。诸有情类业增上力。令世界成。至劫末时。业力尽故。随于近处有灾火生。乃至梵宫皆被焚燎

问水灾起时水从何出。有作是说。第三静虑边雨热灰水。由此乃至极光净天皆被浸荡。有说。从下水轮涌出。由彼势力世界便坏。如是说者。诸有情类业增上力令世界成。至劫末时业力尽故。随于近处有灾水生。由彼因缘世界便坏

问风灾起时风从何出。有作是说。第四静虑边有畔喋婆大风。卒起百俱胝界。妙高山王金轮围等皆被倾拔。令互相击上下翻腾。如糗面抟空中散灭。有余师说。从下风轮有猛风起。吹散世界。如是说者诸有情类业增上力。令世界成。至劫末时业力尽故。随于近处有灾风生。至遍净天皆被散坏

问三灾起时一切外物。为皆转变顺彼灾耶。有作是言。物皆变顺。谓此世界火灾起时。一切外物皆悉轻燥。犹如干草叠絮桦皮。火才触时即烧即尽。若水灾起一切外物。皆将融液如沙糖等。水才触时随即消坏。若风灾起一切外物。皆将离散如沙糗抟。风才触时即便散坏。若尔诸法应舍自相。如是说者。三灾起时坚湿等物亦无转变。但由有情业增上力。令三灾起能坏难坏

如是三灾与所坏事。必是同分界地所摄。谓欲界灾能坏欲界。初静虑灾坏初静虑。乃至第三静虑亦尔。问若尔。经说当云何通。如说大地妙高山等皆悉洞然。风吹绝焰展转乃至上烧梵宫。极光净天有生未久。于劫成坏不善了知。见已惊恐便作是念。勿彼火焰烧尽梵宫当复烧此。答当知彼经依相续说。谓色界火续欲界生。彼烧梵宫。非欲界火水风相续准此应知

问此三灾起先后云何。答火水风三如次先后。然非三种邻次而生。谓七火灾先次第起。然后方有一水灾生。如是经于七七火劫。及七水劫。复七火灾。从彼无间一风灾起。故风水劫皆次火生。火劫从三以数起故。由此善释遍净天寿六十四劫。如是所说是大劫量。一一各有八十中劫。成住坏空各二十故。且初火劫将烧坏时。赡部洲人寿八万岁。安隐丰乐人众甚多。国邑村城鸡飞相及。人多修习十善业道。从此以后捺落迦中有情命终不复生彼。尔时已度二十住劫。二十坏劫此为最初。地狱有情从此渐减乃至最后无一为余。名为地狱有情界坏。次坏傍生。次坏饿鬼。一一坏相如地狱说。次赡部洲诸有情坏。问傍生鬼趣先人坏者。人中所须乳酪等味。耕驭等事如何得有。有说。由人业增上力。有非情物似傍生现。出乳等味作诸事业。问人身今有八万户虫。作任持缘令身相续。彼时既阙身云何存。答尔时人身法尔得住。如诸菩萨转轮王身。虽无诸虫而法尔住。如是说者。诸大海中是诸傍生本所住处。若彼无有一傍生时。即名傍生有情界坏。若傍生类人等杂居。人等坏时彼方随坏。鬼有情坏类此应知。然赡部洲人趣将坏。尔时法尔有一有情。无师自思入初静虑。从彼定起唱如是言。此初静虑甚乐甚静。展转宣告遍赡部洲。闻者摄心皆入初定。从此舍寿上生梵天。赡部洲中有情渐减。乃至无一有情为余。名赡部洲。有情界坏。次坏毗提诃洲。次坏。瞿陀尼洲。一一坏相如赡部说。北拘卢洲如三恶趣。无得静虑生梵世者。然彼寿尽必生欲天。乃至彼处有情界尽。名北拘卢有情界坏。人趣坏已四大王众天。法尔有一得初静虑。从彼定起宣告如前。乃至彼处有情界尽。名彼天中有情界坏。次坏三十三天。次坏夜摩天。次坏睹史多天。次坏乐变化天。次坏他化自在天。一一坏相如初天说。欲界有情次第坏已。时初静虑有一有情。法尔能入第二静虑。从彼定起唱如是言。第二静虑甚乐甚静。如是展转声遍梵宫。闻者摄心入第二定。命终皆往生彼天中。初静虑天有情渐减。乃至无一有情为余。名为梵天有情界坏。如是欲界及诸梵宫。久远空虚无有情类。赡部洲等大地诸山。经历多时天不降雨。一切草木皆悉干燋。更不复生乃至都尽。久时复有第二日轮出现世间。炎赫倍热由此枯涸坑涧泉池。乃至令其都无津润。久时复有第三日轮出现世间。炎赫倍热。由此枯竭一切江河。乃至令其都无津润。久时复有第四日轮出现世间。炎赫倍热。由此枯涸无热恼池。即四大河所从出者。谓殑伽信度缚刍私多。乃至令其都无津润。久时复有第五日轮出现世间。炎赫倍热。由此渐次枯涸大海。乃至令其都无津润。久时复有第六日轮出现世间。炎赫倍热。由此大地妙高山等。皆悉焦熬发烟熢[火*孛]。久时复有第七日轮出现世间。炎赫极热。由此大地妙高山王等。一时焰发中表烔燃。乃至梵宫悉皆焚荡。上从梵世下至风轮。周遍烧燃无余灰烬。如酥油等烧燃尽时。无有遗余。此亦如是。尔时欲界初静虑中。皆悉空虚。都无所有。二十坏劫此时已度。二十空劫从此为初。问几劫坏有情。几劫坏器。有说。十劫坏有情。十劫坏器。有说。十五劫坏有情。五劫坏器。如是说者。十九劫坏有情。一劫坏器。别业难转。非共业故如是世界坏经久时。于下空中有微风起。二十空劫此时已度。二十成劫从此为初。所起微风渐广渐厚。时经久远盘结成轮。厚十六亿踰缮那量。广则无数。其体坚密。假设有一大诺健那。以金刚轮奋威悬击。金刚有碎风轮无损。次有云起雨风轮上。滴如车轴积水成轮。如是水轮于未凝结位。深十一亿二万踰缮那。有说。广量与风轮等有言。狭小分百俱胝。百俱胝轮。其量皆等。谓径十二亿三千四百半围量三倍。谓三十六亿一万三百五十踰缮那。此不傍流。由有情业力。有余师说。由风力所抟。次于水轮。有别风起。抟击此水上结成金。此即金轮厚三亿二万。水轮遂减唯深八洛叉。有说。金轮广如水量。有师复说。少广水轮。次有云起雨金轮上。滴如车轴经于久时。积水浩然深过八万。猛风攒击宝等变生。复有异风析令区别谓分宝土成诸山洲。分水甘碱为内外海。初四妙宝成苏迷卢。挺出海中处金轮上。谓四面如次北东南西金银吠琉璃颇胝迦宝。随宝威德色现于空。故赡部洲空似吠琉璃色。此山出水八万踰缮那。水中亦然。端严可爱。次以金宝成七金山。绕苏迷卢住金轮上。在水中量同苏迷卢。出水相望各半半减。次以土等成四大洲。下据金轮绕金山外。最后以铁成轮围山。在四洲外如墙围绕。出水半减第七金山。在水量同苏迷卢等。诸山广量皆与出水量同。七金山间有七内海。八功德水盈满其中。七金山外有碱外海。此八大海各深八万。前七广量如所绕山。第八有说。广三亿二万二千踰缮那。有说。更增千二百八十七踰缮那半。苏迷卢山有四层级。初层傍出一万六千。次上三层各半半减。四层相去量各十千。有说。初层下齐水量。次二去下量各十千。其第四层去下二万。四层四面如妙高山。四宝所成庄严殊妙。四层如次。坚手持鬘。恒憍。四王天众居止持双山等七金山上。亦有四王所部村邑。七山四级日月等天。皆是四大王众天摄故。欲天中此天最广。从第四层级复有四万踰缮那。至苏迷卢顶。是三十三天住处。山顶四面各二十千。若据周围数成八万。有余师说。面各八十千。与下际四边其量正等。山顶四角各有一峰。其高广量各有五百。有药叉神名金刚手。于中止住守护诸天。于山顶中有城名善见。面二千半周万踰缮那。金城量高踰缮那半。其地平坦真金所成。俱用百一杂宝严饰。地触柔软如妒罗绵。蹑时齐膝随足高下。有微风起吹去萎华。引新妙华弥散其地。是天帝释所都大城。城有千门严饰壮丽。门有五百青衣药叉。勇健端严踰缮那量。各严铠仗防守城门。于其城中有殊胜殿。种种妙宝具足庄严。蔽余天宫故号殊胜。面二百五十。周千踰缮那。其城四隅有四台观。以金银等四宝所成。种种庄严甚可爱乐。城外四面四苑庄严。是彼诸天共游戏处。一众车苑。谓此苑中随天福力种种车现。二粗恶苑。天欲战时随其所须甲仗等现。三杂林苑。诸天入中所玩皆同俱生胜喜。四喜林苑。极妙欲尘殊类皆集历观无厌。如是四苑形皆正方。一一周千踰缮那量。中央各有一如意池。面各五十踰缮那量。八功德水盈满其中。随欲妙花宝舟好鸟。一一奇丽种种庄严。四苑四边有四妙地。中间去苑各二十踰缮那。地一一边量皆二百。是诸天众胜游戏所。诸天于彼捔胜欢娱。城外东北有圆生树。是三十三天受欲乐处。盘根深广五踰缮那。耸干上升枝条傍布。高广量等百踰缮那。舒叶开花妙香芬馥。顺风熏满百踰缮那。若逆风时犹遍五十。城外西南角有大善法堂。三十三天常于半月八日十四日十五日。集此堂中详辨人天。及制伏阿素洛等。如法不如法事如是等类余处广说

说一切有部发智大毗婆沙论卷第一百三十三阿毗达磨大毗婆沙论卷第一百三十四

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    大种蕴第五中缘纳 息 第二之四

已说成立风水金轮诸海山洲地居器已。次辨成立空居诸天大梵天等所居宫地。然彼宫殿。有说。依空。有说。空中密云弥布如地。为彼宫殿所依。外器世间。至色究竟。上无色故不可施设。问从夜摩天至色究竟。所依云地其量如何。有说。从夜摩至他化自在云地。皆等妙高顶量色界云地下狭上广。谓初二三四静虑地。如次等彼四洲。小千中千大千。诸世界量。有余师说。夜摩天宫云地倍于妙高山顶。乃至他化自在天宫云地。望前展转相倍。初二三定如次。等于小千中千大千界量。第四静虑其量无边。由此若依第四静虑。起有身见极难除断。以执无边地为我故。问第四静虑地。若无边灾所不及宁非常住。答刹那无常故无此失。有说。第四静虑地中。宫殿所依俱无常定。谓彼宫池随彼诸天生时死时俱起没故。此说非理。所以者何。应无有情共器业故。由此如前所说者好。诸器世间既成立已。最初有一极光净天。由寿业福随一尽故。从彼殁已生大梵宫。后诸有情亦从彼殁有生梵辅。有生梵众。有生他化自在天宫。渐渐下生。乃至人趣北洲为始。次瞿陀尼。次毗提诃。后生赡部。次生鬼趣。次生傍生。后生地狱。由法尔力。若处后空彼必先住。若处先空彼必后住。若大地狱一有情生。尔时已度二十成劫。二十住劫此为最初。问几劫器世间成。几劫有情渐住。有说。十劫器世间成。十劫有情渐住。有说。五劫器世间成。十五劫有情渐住。如是说者。一劫器世间成。十九劫有情渐住

问齐几世界俱坏俱成。有说。齐百俱胝四大洲界。有说。无数世界俱坏俱成。云何知然。经为量故。如契经说。佛告苾刍我眼清净过于人眼。见东方等无数世界。或有正坏。或坏已空。或有正成。或成已住。如天大雨。滴如车轴。无间无缺此亦如是。问何故一切世界不俱坏俱成。答以诸有情业不等故。谓有情类。于此处所共业增长世界便成。共业若尽世界便坏。又有情类。于彼处所净业若增此界便坏净业若减此界便成。问若诸有情。于劫将坏余半劫。在破和合僧。堕无间狱有中夭不。若有中夭。彼业云何感一劫寿。若不中夭。彼于劫坏宁不稽留。如契经言。若处乃至一蚁卵在灾便不坏。况彼在耶。有作是说。彼无中夭。若尔。彼于劫坏宁不稽留。劫欲坏时业增上力。飘置余界大地狱中。譬如王都有嘉喜事。先移极罪置边狱中。后于王都方降恩赦。有余师说。劫欲坏时法尔有情其心调善。于余重罪尚能不为。况有破坏和合僧者。复有说者劫欲坏时。若造破僧无间业者。命终便堕他界狱中。法尔不生将坏处故。如说。火劫世间坏时有情上生。灾起时分水劫风劫广说亦然。但水风灾坏相有异。谓水能浸烂。风能飘击。所坏势力远近不同。复如火劫。世间成时先后时分水风亦尔

如彼大劫有大三灾。如是中劫小三灾现。一刀兵。二疾疫。三饥馑。初刀兵劫将欲起时。赡部洲人极寿十岁。为非法贪染污相续。不平等爱映蔽其心。邪法萦缠嗔毒增上。相见便起猛利害心。如今猎师见野禽兽随手所执皆成刀杖。各逞凶狂互相残害。七日七夜死亡略尽。赡部洲内才余万人。各起慈心渐增寿量。尔时名为度刀兵劫次疾疫劫将欲起时。赡部洲人极寿十岁。由具如前诸过失故。非人吐毒疾疫流行。遇辄命终难可救疗。都不闻有医药之名。时经七月七日七夜。疾疫流行死亡略尽。赡部洲内才余万人。各起慈心渐增寿量。尔时名为度疾疫劫。后饥馑劫将欲起时。赡部洲人极寿十岁。亦具如前诸过失故。天龙忿责不降甘雨。由是世间久遭饥馑。由饥馑故便有聚集。白骨运筹三种言异。由二因故名有聚集。一人聚集谓彼时人。由极饥羸聚集而死。二种聚集。谓彼时人为益后人。辍其所食置于小箧。拟为种子故饥馑时名有聚集言。有白骨亦由二因。一彼时人身形枯燥。命终未久白骨便现。二彼时人饥馑所逼。聚集白骨煎汁饮之。有运筹言。亦二因故。一由粮少传筹食之。谓一家中从长至幼随筹至日得少粗食。二谓以筹挑故场蕴得少谷粒多用水煎。分共饮之以济余命。如是饥馑经七年七月七日七夜。饥馑所逼死亡略尽。赡部洲内才余万人。各起慈心渐增寿量。尔时名为度饥馑劫。此三灾横虽复难除。然有圣言说彼对治。谓若有能一日一夜持不杀戒。于未来生决定不逢刀兵灾起。若能以一诃梨怛鸡。起殷净心奉施僧众于当来世决定不逢疾疫灾起。若有能以一抟之食起殷净心奉施僧众。于当来世决定不逢饥馑灾起。问如是三灾余洲有不。答无根本灾。而有相似。谓嗔增盛身力羸劣数加饥渴。此说二洲。北拘卢洲亦无相似。以无罪业而生彼故。又彼无有嗔增盛故

    大种蕴第五中具见纳息第三之一

已具见谛。世尊弟子未离欲染所成就。色界系身语业色。何大种所造。如是等章。及解章义既领会已。当广分别。问何故作此论。答欲令疑者得决定故。谓契经说。佛告苾刍。若此身中离生喜乐。滋润遍滋。润适悦遍适悦。于此身中无有少分。离生喜乐而不遍满。此契经中说根本地。勿谓唯此根本地中有能离法非近分地。断此疑故。显近分中亦有相似能离善法。有余师说。欲止分别论者。说预流一来亦得根本静虑。彼何故作是说。依契经故。如说。慧阙无静虑。静虑阙无慧。是二具足者去涅槃不远。预流一来。无不有慧故。彼亦有根本静虑。为遮彼执显初二果未得静虑。问若尔彼所引颂当云何通。尊者世友作如是说。彼说正思择名静虑。若不尔者外道亦得根本静虑。岂便许彼亦有慧耶。分别论者作是说言。许彼有慧复有何过。彼说不然。所以者何。具是二者便于涅槃已为不远。非诸外道去涅槃近。以彼无有解脱法故。有说。为止譬喻者意。彼说诸近分地唯有善法。今明近分具有三种。谓善染无记。若近分地唯有善者。世尊弟子未离欲贪。依未至定起世俗道。彼随转律仪何地大种造。譬喻尊者作如是言。是初静虑大种所造。岂不汝等说。预流一来未得静虑。彼作是说。我遮善静虑非染无记。彼说非理。未离欲贪。尚不能起初善静虑。况能起彼无覆无记。是故为止他宗及显正理故作斯论

问已说已具见谛。何故复言世尊弟子。答已具见谛者。欲差别随信随法行故。世尊弟子者。欲差别诸异生故。此是谁耶。答此是预流。及一来果非余。以说未离欲染故。问随信法行何故不名已具见谛。有作是说。已见四谛及已害邪见者。名已具见谛。随信随法行。非已见四谛。今正见故。非已害邪见。今正害故。由此不名已具见谛。有余师说。若相续中。已除一切见倒恶行恶趣烦恼。方得名为已具见谛。随信随法行。今正能除不名已除犹成就故。由此不名已具见谛。如良田中无有一切尘雹灾横。名具足田致诸稼穑。复有说者。若相续中已除四疑生四决定。尔时名已具见。随信随法行。今除四疑。生四决定。不名已具。有说。若身中已除四闇。已起四明。已除四无智。已起四智。名已具见。随信随法行则不如是。不名已具。有说。已伏四谛洲渚。已除其中烦恼怨敌。乃名已具。随信随法行。今伏今除不名已具。问何故异生不名世尊弟子。答若唯顺佛语不受余教。名世尊弟子。异生或顺佛语。或顺邪言故。不名世尊弟子。有说。诸有正闻非邪闻所伏。乃名世尊弟子。异生不尔。有说若成就四种证净。名世尊弟子。异生无四证净故不名世尊弟子。有说。若唯称佛以为大师。名世尊弟子。异生或称外道邪魔以为师故。不名世尊弟子。有说。若唯归敬三宝以为福田。名世尊弟子。诸异生类。或以邪神诸外道等以为福田。不名世尊弟子。有说。若信唯佛是一切智。唯佛所说法能渡生死。唯苾刍僧是梵行者。名世尊弟子。诸异生类与此相违。是故不名世尊弟子。有说。于佛圣教其心坚牢。如天帝幢。名世尊弟子。诸异生类于佛教中心不坚牢。犹如叠絮随风上下转动无恒。故不名为世尊弟子

已具见谛世尊弟子。未离欲染所成就。色界系身语业色。何大种所造。答色界系。此依种类总相而说。若别说者。应言未至地大种所造。此则遮说预流一来亦得静虑者。意说。未离欲染故。无有未离欲染而能得静虑者。又亦遮说未至地中无无记者。意说。色界大种造故。无有未得静虑地而能起彼大种者。问何故此中但问随世俗道身语业非无漏耶。答彼造论者意欲尔故。随彼意欲而作斯论。但令不违法相不应责其所以。有说。应具足问而不问者。当知此义有余有说。无漏身语业决定不离。随世俗道身语业。若问世俗。当知已问无漏。有说。无漏律仪以世俗戒为加行。为门。为依。为安足处。若问彼加行则已问彼。有说。无漏戒依世俗戒得故。问世俗则问无漏。有说。随世俗道身语律仪。必与能造同其种类。今但问同类随地差别。无漏异类是以不问。有说。此随世俗道色有异诤论。谓有说。是未至地大种所造。有说。是初静虑大种所造。是以问之。无漏定是欲界大种所造。是以不问。由此等缘。唯问世俗身语业。不问无漏。生欲界入有漏四静虑。身语业色。何大种所造。答色界系。此依种类总相而说。若别说者。随初静虑世俗道色。即初静虑系大种所造。乃至随第四静虑世俗道色。即第四静虑系大种所造

生欲界入无漏四静虑身语业色。何大种所造。答欲界系。依欲界身现在前故。问何故有漏所依大种。必与所造同一地系。无漏所依随何身起。即彼系耶。答有漏律仪有缚有系故。为同地大种所造。无漏律仪离缚离系。然依身起故。随何地身中现前。即彼大种所造。有说。有漏律仪堕界堕地故。自界地大种所造。无漏律仪虽堕于地而不堕界。然依身起故。随所依大种所造有说。有漏律仪为同类大种所造故地必同无漏律仪为异类大种所造故。随身别。以必依身现在前故

生色界入有漏四静虑身语业色何大种所造。答色界系。此依种类总相而说。若别说者。随初静虑世俗道色。即初静虑系大种所造。乃至随第四静虑世俗道色。即第四静虑系大种所造

生色界入无漏四静虑。身语业色何大种所造。答色界系此亦依总相说。若别说者。若生初静虑入无漏四静虑。彼身语业皆初静虑大种所造。若生第二静虑。入无漏三静虑。彼身语业皆第二静虑大种所造。若生第三静虑。入无漏二静虑。彼身语业皆第三静虑大种所造。若生第四静虑。入无漏第四静虑。彼身语业第四静虑大种所造。此中应知生下地上地定现前。生上地下地定不现前。问何故尔耶。答下地定劣。上地定胜。于胜生欣尚故起。于劣生厌背故不起。有说。下趣于上。上不趣下。如臣朝王。王不朝臣。有说。生下地者于上地法。更有所作故起现前。生上地者。于下地法更无所作。是故不起。如阿罗汉不起三界断对治道。以无用故。有说。加行善法由功用起。生上地者下地法无用。作于无用法更起功力令现在前。非如无记

问大种随地有五类别几无间灭几无间现前。答生欲界者。若欲界心无间有漏初静虑现在前。彼一类大种灭。谓欲界二类大种无间现前谓欲界初静虑。若有漏初静虑无间。有漏初静虑现在前。彼二类大种灭。二类大种无间现前。谓欲界初静虑。若有漏初静虑无间。无漏初静虑现在前。彼二类大种灭。谓欲界初静虑一类大种无间现前。谓欲界若无漏初静虑无间无漏初静虑现在前彼一类大种灭。一类大种无间现前。谓欲界若无漏初静虑无间。有漏初静虑现在前。彼一类大种灭。谓欲界二类大种无间现前。谓欲界初静虑。若有漏初静虑无间。欲界心现在前。彼二类大种灭。谓欲界初静虑。一类大种无间现前。谓欲界。若欲界善心无间。无漏初静虑现在前。若无漏初静虑无间。欲界善心现在前。俱一类大种灭。一类大种无间现前谓欲界如入出初静虑。乃至入出第四静虑。随其所应皆应广说。如生欲界乃至生第四静虑。随其所应亦应广说

问若生欲界。色界大种现在前时。何处现前。有说。眉间。有说。鼻端。有说。心边。有说。脐边。有说。足指。有作是说。随先加行安心处所是处现前。有余师说。欲界大种粗。色界大种细。细入粗隙。如油入沙。然根本静虑现在前时。色界大种遍身内起。若近分定现在前时。色界大种唯心边起。有说。近分定现在前时。色界大种亦遍身起。然长养身不如根本。如有二人俱诣池浴。一在池侧掬水浴身。一入池中没身而洗。二人用水虽俱遍身。然长养身入池者胜。问欲界身中先有间隙。色界大种来入中耶。答不尔。未来欲界身自有二种。一唯欲界大种。二色界大种杂。若时遇入色界定缘彼唯欲界者便灭。色界杂者便生。故不可言先有间隙后来住中

世尊弟子。生无色界所成就无漏身语业色。何大种所造。答或欲界系。或色界系。问此中何故复作斯论。答欲令疑者得决定故。谓无色界无有诸色。或有生疑。世尊弟子生无色界。所成就无漏色非大种所造。为除此疑故说。或欲界系。或色界系大种所造。问彼所成就色。定欲色界大种所造。何故言或。答应决定说。而言或者。欲显界无杂乱。无漏对治有杂乱。由界无杂乱故。欲界大种所造异。色界大种所造异。无有一色二界大种所造。是故说或。此即总说。然无漏色随起依地。能造大种有五类别。谓欲界四静虑系大种所造。世尊弟子生无色界。若阿罗汉唯成就未来五地大种。所造无漏色。非现在不起故。非过去已舍故。若不还者亦成就未来五地大种。所造无漏色非现在不起故。过去不定。依五地身起有多少。或全无故。由此应说。或有学者生无色界成就未来五地依戒。过去全无。谓先依欲界四静虑身。于第三果及第四向。诸无漏道未起未灭。从彼命终生无色界。或有学者生无色界。成就未来五过去一。谓先欲界四静虑时随依一身。于第三果或第四向。诸无漏道已起已灭。从彼命终生无色界。或有学者生无色界。成就未来五。过去二。谓先欲界四静虑时。随依二身于第三果或第四向。诸无漏道已起已灭。从彼命终生无色界。或有学者生无色界。成就未来五。过去三。谓先欲界四静虑时。随依三身于第三果或第四向。诸无漏道已起已灭。从彼命终生无色界。或有学者生无色界。成就未来五。过去四。谓先欲界四静虑时随依四身于第三果。或第四向。诸无漏道已起已灭。从彼命终生无色界。或有学者生无色界。成就未来五。过去五。谓具依欲界四静虑身。于第三果或第四向。诸无漏道已起已灭。从彼命终生无色界。有作是说。无有学者生无色界不成就过去色。以彼先在欲色界时。于第三果或第四向。必已起灭方命终故。是故本论说言。若诸学者。生无色界成就过去未来所造色。若于彼得阿罗汉果成就未来所造色。非过去所造色。若谓不尔本论应说。学者生无色界。有不成就过去所造色。尊者僧伽伐苏说曰。或有学者生无色界。都不成就过去未来五地身中无漏业色。谓先依欲界四静虑身。于第三果及第四向。诸无漏道未起未灭。从彼命终生无色界。或有学者。生无色界成就过去未来各一。谓先欲界四静虑时。随依一身于第三果或第四向。诸无漏道已起已灭。从彼命终生无色界。如是成二成三成四成五。准前广说如理应思。若生彼界得阿罗汉果别得未来五地依戒。此说非理。无得果时唯得无为非有为故。又与本论所说相违。如说。圣者生无色界。成就未来所造色。非过去大种。若如彼意本论应说。圣者生无色界有不成就未来所造色。故前所说于理为善

无色界殁生欲界。最初所得诸根大种。何大种为因。乃至广说。问何故复作斯论。答欲令疑者得决定故。谓无色界都无诸色。或有生如是疑。欲色界殁生无色界。彼色或经八万六万四万二万劫断。从彼命终生欲色界。最初所得诸根大种无因而生。为除彼疑。显彼诸色非无因生故作斯论。无色界殁生欲界。最初所得诸根大种何大种为因。答欲界系。此依种类总相而说。若别说者。应作是说。无色界没来生欲界。最初所得诸根大种。若生地狱还以地狱大种为因。乃至若生天趣。还以天趣大种为因。若眼根及彼大种还以眼根所依大种为因。余根及境类此应知。眼中左眼及彼大种还以左眼所依大种为因。左中异熟还以异熟为因。长养还以长养为因。如左右亦尔。余根及境广说亦尔。然续生心俱起大种展转为俱有因。于眼等为生等因。无始生死久灭大种。与今大种为同类因。问何故此中不问。眼等与初所得根大为因。有说。此是要略之言。故不问耳。有余师说。大种通与根大为因。是以问之。眼等不与大种为因。是以不问。有说。大种久灭及今并有因义。眼等但有久灭为因。是故不说。无色界殁生色界。最初所得诸根大种何。大种为因。答色界系。此亦依种类总说。若别说者应作是说。无色界殁来生色界。最初所得诸根大种。若生初静虑。还以初静虑大种为因。乃至若生第四静虑。还以第四静虑大种为因。若眼根及彼大种。还以眼根所依大种为因。眼中左右异熟长养广说如前。余根及境广说亦尔。然续生心俱起大种展转为俱有因。如是等广说如前

色界殁生欲界。最初所得诸根大种何大种为因。答欲界系。此亦总说。若差别说如前。应知余义亦如前广说

说一切有部发智大毗婆沙论卷第一百三十四阿毗达磨大毗婆沙论卷第一百三十五

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    大种蕴第五中具见纳息第三之二

生欲界作色界化。乃至广说。问何故作此论。答欲止他义显己义故。如譬喻者作如是说。诸所化物皆非实有。若实有者云何名化。大德亦言。化非实有。是修所现。如尸起作鬼咒所为。为止如是所说意趣显诸化事皆是实有。由此等缘故作斯论

生欲界作色界化发色界语。彼身语色何大种所造。答色界系。生色界作欲界化。发欲界语。彼身语色何大种所造。答欲界系。以有漏所造色皆同分界地大种所造故。然所化身差别有八。谓生欲界作欲界化有二种。一似自身。二似他身。作色界化亦有此二。及生色界作色界化有二种。一似自身。二似他身。作欲界化亦有此二。是谓八。此中但依二种作论。谓生欲界作色界化。及生色界作欲界化似他身者。问何故此中但依二身作论。答彼作论者意欲尔故。随彼意欲而造论。但令不违法相。不应责其所以。有说。唯此二身微细难见难了。是故偏说。有说。唯此二身最难现前。藉多加行方能起故。有说。此于世间难可信受。谓谁能作他界他身。有说。此二最为希有。谓能化作异界异身。是故偏说。诸变化心总有二种。一欲界系二色界系。或为五。谓欲界四静虑系。或为十二。则十二种能化者心。谓得初静虑果者。乃至得第四静虑果者。各有三种。何等为三。一异生。二有学。三无学。复有说三。一外法异生。二内法异生。三圣者。复有说三。谓三位得。一离染时得。谓离下染得静虑时二得果时得。谓得无学果时。三练根时得。谓转根作见至不动时。或分十四。谓欲界系有四。则四静虑果。初静虑系亦有四。如欲界说。第二静虑系有三。则上三静虑果。第三静虑系有二。则上二静虑果。第四静虑系有一。则第四静虑果。以下地心羸劣故。不能于上地化。或分十五。谓五地系诸变化心。各有上中下品。有说。得五地变化心者各有三类。谓异生等如前说。或复分为四十二种。谓前十四各有上中下品。有说。得十四种变化心者各有三类。谓异生等如前说

诸作欲界化。彼身还似欲界有情。诸作色界化。彼身还似色界有情。问所作化身几处所摄。答若生欲界作欲界化。自身他身皆四处摄。谓色香味触。作色界化。自身他身皆二处摄。谓色触。若生色界作色界化。自身他身皆二处摄。作欲界化。自身他身皆四处摄。如前说。有说。若作他身则四处摄。若作自身唯二处摄。勿彼成就香味处故。如是说者。虽化香味无成就失。如人衣服严具花香。虽复在身而不成就

问若生欲界作欲界化初静虑果。作色界化初静虑果。如是二种谁劣谁胜。答此二运转等无差别。然色界者界胜故胜。问若生欲界作欲界化第二静虑果。作色界化初静虑果。如是二种谁劣谁胜。答欲界者运转胜。以彼从欲界。乃至第二静虑能往还故。色界者界胜以色界法胜欲界故。问若生欲界作欲界化初静虑果。作色界化第二静虑果。如是二种谁劣谁胜。答色界者二事胜。一界胜。二运转胜。如说。生欲界作欲色界化。初第二静虑果。相对辨胜劣。如是生欲界作欲色界化。初第三静虑果。初第四静虑果。第二第三静虑果。第二第四静虑果。第三第四静虑果。相对辨胜劣。准前问答如理应思。如生欲界。如是生初静虑。生第二静虑。生第三静虑。随其所应当思广说问如生初静虑者。有能发起身语表心故。令所化身作往来等种种所用。上诸静虑无如是心。化主生彼所化。云何有往来等用。答如生初静虑。以发起表心。令化身转作往来等用。如是生上诸静虑。亦以初静虑发起表心。令所化身起往来等用。如眼识等。有余师说。诸所化。身无往来等种种作用。但默然住由化主力。令彼似有往来等事。如帝网戏非有现有。问化事起时。为必有依托方得现耶。为复不尔。有说。化事必有依托。谓必依于木石块等。化主方能作所化事。有余师说。若初起通者所起化事要有所假。若通慧满者。无所依假能起化事。问为一心一化。为一心多化。若一心一化。经颂所说当云何通。如说

  一化主语时　　诸所化皆语
  一化主若默　　诸化皆默然

若一心多化。施设论说复云何通。如说。神境智证通云何加行。以何方便起神境智证通。答彼初业者习世俗定令极自在。极自在已起令现前。由现前故于神境通便能引发。从彼乃能随起一化。起一化事尚尔许心。况复多耶有作是说。一心一化。问所引经颂当云何通。答先以多心祈多化语。后以一心令语俱发。前多心是转。后一心随转。有余师说。一心多化。问彼施设论当云何通。答若初起通者一心一化。若通慧满者一心多化。问于一心中所起化事。为必同类亦异类耶。有说。必同类化。谓作象时不作马等。有说。亦异类化。谓初起通者。一心但能作一类物。若通慧满者。一心能作象等四军

问已知修所成化事。为亦有生得化耶。有说无。以生得势用劣故。但能转变令似异本。有说。亦有。然唯能作自身非余。问若尔云何通经所说。如契经说。有三魔女各各化作多百女身。所谓童女产未产女。中女老女。其数各百。又自化身种种严饰。为惑媚故诣菩萨所。谓菩萨曰。可起沙门。我等今来愿相适事。菩萨不受。寻令彼身作衰老形羞惭而退。答即依魔女异熟身上。化作前说多百女身。如拘执毛不离拘执。如是说者。生所得心自身他身俱能化作。云何知然。曾闻尊者邬波鞠多。端身静虑魔为娆弄。便以花鬘冠尊者顶。尊者出定惊怪念言。此谁所作寻则知此是魔所为。为调彼故则以神力化作三尸。系魔王颈。所谓死蛇死狗死人。于是魔王极怀惭耻。种种方便欲去不能。所系三尸缠绕其颈。转急转臭魔既无聊倍增惶恐。为脱尸故。便陷入地更出腾空。又没大海水中。复入苏迷卢腹尽力摆突终不能去。魔既困弊自度力穷。渐历六天求欲免脱既不能得。往梵宫边请大梵言。唯愿哀愍。解我颈上仙人所辱。梵王告曰。吾不能去。可还归依本系汝者。魔闻此已下赡部洲。五体归诚礼尊者足。白言。大德。唯愿慈悲。赦我前愆去尊所报。尔时尊者邬波鞠多徐告魔言。吾知时矣。魔重稽首谢过求哀。请示何时为除所辱。尊者告曰。汝能从今乃至如来圣教未灭更不恼乱诸苾刍不。魔曰。唯然。当如教敕。请更诲示。唯尊所为。尊者复言。向为佛法然有私愿。今欲请为。魔曰。唯命。尊者告曰。佛涅槃后经于百岁我身乃生。如来法身吾今已见。所未见者。谓佛生身。仁今颇能为我现不。魔曰。此事甚易我能为之。愿尊见时勿便致敬。令我获罪。尊者曰尔。则时为魔解去三尸。魔王欢喜谢尊者已。便入林中即自化身作如来像。三十二相八十种好。威光赫奕过千日轮。复更化作诸苾刍众。右舍利子左大目连。尊者阿难持钵随后。又与阿若多憍陈那等千二百五十人俱。如半月形从林而出。时尊者邬波鞠多见已欢喜得未曾有。以淳净意如断根树。莫能自持。不觉投身礼魔双足。魔王悚惧寻灭化身。由此故知生所得慧。亦能化作自身他身

问则彼尊者邬波鞠多。于化事中所得自在过俱胝倍胜彼魔王。尊者何缘不自化作。而苦求请魔王作耶。答于修所成尊者自在。于生得化不及魔王。欲试魔王生得化力。是故请彼化作佛身。有说。修所得化尊者自得不生希有。生所得化尊者不得生希有心。欲寄魔王观生得化。是故求彼令作佛身。有说。尊者深心敬佛。若自化作恐敬心不胜。是以令魔作之。有说。尊者少欲若自化作。恐天人等谓已是佛极加敬养。般涅槃后诸天世人供养悲哀同佛灭度。是以但请魔作。问修得生得二种变化云何差别。答所化无别。但修得者净速圆妙。非生所得。有说。生得心化唯依自界身。修得心化通依自他界身

问有留化事不若有者。佛何故般涅槃时不留化身。令于灭后住持说法饶益有情。若无者。何故尊者大迦叶波已般涅槃留身久住。曾闻尊者大迦叶波。入王舍城最后乞食。食已未久登鸡足山。山有三峰如仰鸡足。尊者入中结跏趺坐。作诚言曰。愿我此身并纳钵杖久住不坏。乃至经于五十七俱胝六十百千岁。慈氏如来应正等觉。出现世时施作佛事。发此愿已寻般涅槃。时彼三峰便合成一。掩蔽尊者俨然而住。及慈氏佛出现世时。将无量人天至此山上。告诸众曰。汝等欲见释迦牟尼佛杜多功德弟子众中第一大弟子迦叶波不。举众咸曰。我等欲见。慈氏如来则以右手抚鸡足山顶。应时峰坼还为三分。时迦叶波将纳钵杖。从中而出上升虚空。无量天人睹斯神变。叹未曾有其心调柔。慈氏世尊如应说法皆得见谛。若无留化如此之事云何有耶。有说。有留化事。问若尔世尊何故不留化身至涅槃后住持说法。答所应作者已究竟故。佛谓所应度皆已度讫。所未度者圣弟子度之。有说。无留化事。问若尔迦叶波事云何得有。答诸信敬天神所任持故。有说。迦叶波尔时未般涅槃。慈氏佛时方取灭度。此不应理。宁可说无不说彼默然多时虚住。如是说者。有留化事。是故大迦叶波已入涅槃。问经说。一时作双示导。谓身下出火身上出水。身下出水身上出火。此为一心为二心作。若一心作。云何一心有相违二果。若二心作。云何一时有二心俱起。有说。一心所作。问云何一心有相违二果。答先以二心别祈水火。后住一心令其俱发。前二心是转。后一心随转。有说。二心所作。问云何一时有二心俱起。答由胜定力水火二心速疾回转。似俱时发。如物[打-丁+費]子。左手放光右手随言分僧卧具。若时发表无容放光。若时放光无容发表。由胜定力光表二心速疾回转。似俱时发。水火二心应知亦尔施设论说。佛于一时化作化佛。身真金色相好庄严。世尊语时化身亦语。化身语时世尊亦语。弟子一时作化弟子。剃除须发着僧伽胝。弟子语时所化便默。所化语时弟子便默。所以者何。佛于心定俱得自在。入出速疾不舍所缘。发自语已便发化语。发化语已复发自语。以极速故似俱时发。弟子心定非极自在。入出迟缓数舍所缘。发自语已发于化语。化语起时自语已灭。发化语。已复发自语。自语起时化语已灭。非极速故觉知前后。问诸大声闻亦能如是。世尊于此有何不共。答佛以一心能发二语。谓自及化。自语已化则语。化语已自则语。极迅速故非俱谓俱。声闻一心亦发二语。谓自及化。自语灭已化乃语。化语灭已自乃语。非极迅速故非俱觉非俱。又佛世尊于诸智境皆得自在。非诸声闻。故佛此中亦有不共

彼复翻说佛于一时化作化佛。身真金色相好庄严。世尊语时所化便默。所化语时世尊便默。弟子一时作化弟子。剃除须发着僧伽胝。弟子语时所化亦语。所化语时弟子亦语。问诸大声闻亦能如是。世尊于此有何不共。答佛于心定俱得自在。入出速疾不舍所缘。能以一心发于二语。谓自及化。于中欲令语者便语。不令语者便默。声闻心定非极自在。入出迟缓数舍所缘。虽能一心发于二语。谓自及化。然于其中欲令一语第二亦语。欲令一默第二亦默。不能令其一默一语。又佛世尊于诸智境皆得自在非诸声闻。故佛此中亦有不共

契经中说。佛告阿难。我之神力能以意所成身倏尔至于梵世。阿难白佛。何其劣哉。此事声闻亦能。世尊何足自叹。谓所化作名意所成身。声闻亦能以此至于梵世。佛若尔者有何不共。世尊颇能离神通力。以粗大种父母生身。于倏忽间至梵世不。世尊告曰。此我亦能。阿难复言。此事实难。愿说譬喻令我信解。佛言。谛听。如世间铁。或饼或团置炎炉中。渐轻渐软渐调渐净。随意所为。如是如来身随心转。系心于身作轻软等想。身随心力成轻软等事。由能系心相续势力。令所系身运转随意。此中有说。佛尽智时得欲界无覆无记。未曾得心心所法。由此势力不入静虑不起神通。才发心时则能举身至色究竟。何况梵世。有作是说。世尊尔时起缘风心令身转举。有余师说。起缘空心能令佛身所往无碍。有言。佛意则说此身名意所成。由随意力成轻软等运转事故。离定通力能运此身。至梵世故与声闻别。有言。佛说意所成身则所化身不假定通能至梵世。与声闻别。有言。佛说由意势通令所化身速至梵世。此捷疾力二乘等无。故佛依此自显殊胜

问颇有变化心一刹那顷断而不得。得而不断俱不俱耶。答有。谓离欲染最后无间道时。于变化心有此四句。断而不得者。谓欲界系上三静虑果。得而不断者。谓初静虑系初静虑果。亦断亦得者。谓欲界系初静虑果。不断不得者。谓初静虑系上三静虑果。第二静虑系上三静虑果。第三静虑系上二静虑果。第四静虑系第四静虑果。如离欲界染最后无间道作四句。如是离初静虑染最后无间道。乃至离第三静虑染最后无间道。随其所应各有四句

化当言有大种无大种耶。答当言有大种。无有现色离大种故。化当言有所造色。无所造色耶。答当言有所造色。化有二种。一修得。二生得。修得化若欲界系四处摄。若色界系二处摄。生得化若欲界系九处摄。若色界系七处摄。由如是法成化身故。化当言有心。无心耶。答当言无心。然化有二种。一修得此无心。二生得此有心。此中说修得化非心依故。又有二种。一作他身此无心。二作自身此有心。此中说他身化非心依故。若变化他有情身者。如自身说。化当言谁心所转耶。答当言化主。由化主心令有表故。然修得化由化主心转。若生得化由自心转。此中说修得化。又作他身由化主心转。若作自身由自心转。此中说他身化

问诸化皆灭耶。答修得化灭。生得化有灭不灭。谓天龙药叉等自身化时。有异色等起。此于后时异色等灭。而自身在。又作他身者灭。作自身者有灭不灭。若变化他有情身者如自身说。问诸化所食谁腹中消。答此若化主所须。所宜食者即化主腹中消。若非化主所须所宜食者。如草木等聚置一处。若化他有情令饮食者。随化主意有消不消

问化身由何出烟焰等。答由化主力。谓诸化主欲于是处起烟起焰。起烟焰峰。起烟焰舍。则于是处烟焰等起。问由何化身有烧者有不烧者。复以何故有烧身不烧衣。烧衣不烧身。俱不俱耶。答由化主力。谓诸化者随意所欲。或烧不烧

如契经说。尊者达腊婆末罗子。以神通力上升虚空火界焚身无余灰烬。问彼尊者火焚身时。为涅槃前。为涅槃后答诸说有留化者。彼说涅槃后火起焚身。谓彼获得心定自在将取灭度。神力升空于虚空中。化作床座及种种薪。便以愿力入火界定。才发火已则般涅槃。由此焚身令无灰烬。诸说无留化者。彼说命未尽火起焚身。谓彼获得心定自在。将欲灭度神力升空入火等持。令身渐死随无根处火起焚之。乃至最后唯有心命依处。如极细毛端许。乃入涅槃火亦随灭。余毛端量所不烧者由细难知。谓无灰烬

中有。当言有大种无大种耶。乃至广说。问何故次化明中有。答是作论者意欲尔故。乃至广说。有说。化与中有俱是微细难可了知。有余师说。此二俱是意所成身。有说。此二多诸诽谤。谓譬喻者说。化非实。分别论者拨无中有。前明化是实有。今明中有非无。以是故次化明中有

中有当言有大种无大种耶。答当言有大种无有现色离大种故。中有当言有所造色。无所造色耶。答当言有所造色。欲界九处摄。色界七处摄。由如是法成彼身故。中有当言有心无心耶。答当言有心。中有当言谁心所转耶。答当言自心。由自心力起表业故。中有义如结蕴广说

世名何法。答此增语所显行。问何故作此论答为止他宗显自宗故。谓譬喻者。分别论师。执世与行其体各别。行体无常。世体是常。诸无常行。行常世时如诸器中果等转易。又如人等历入诸舍。为遮彼执显三世体则是诸行。行无常故世亦无常。由是等缘故作斯论。三世义亦如结蕴广说

劫名何法。答此增语所显半月月时年。问何故作此论。答为释经故。如契经说。有一苾刍来诣佛所。顶礼双足却住一面。白世尊言。佛恒说劫。此为何量。佛言。苾刍。劫量长远非百千等岁数可知。苾刍复言。有譬喻不。世尊言有。今为汝说。如近城邑有全段石山。纵广高量各踰缮那。迦尸细缕百年一拂。山已磨灭此劫未终。苾刍当知。汝等长夜经此劫数无量百千。在于地狱傍生鬼趣。及人天中。受诸剧苦生死轮转未有尽期。何得安然不求解脱。彼经则是此论所依经。虽说劫未分别劫体是何今欲分别故作斯论。问何故但说半月月时年为劫。不说刹那腊缚牟呼栗多昼夜以为劫耶。答应说而不说者。当知此义有余。有说。此中举粗摄细。谓刹那等细。半月月等粗。若说粗当知已说细。由积细时为粗时故。有说。此中举近摄远。谓劫近为半月等所成。半月等复为刹那等成故。说近时亦已说远

劫体是何。有说。是色处。云何知然。如施设论说。劫初时人身光恒照。以贪味故光灭闇生。于是东方有日轮起。光明辉朗同于昔照。见已喜曰。天光来来。以天光来故名为昼。须臾未几日轮西没。闇起如先。见已叹言。天光没没。以天光没故名为夜。由此证知劫体是色。劫体皆积昼夜成故。如是说者。昼夜等位无不皆是五蕴生灭。以此成劫劫体亦然。然劫既通三界时分。故用五蕴四蕴为性

已说自性。所以今当说。何故名劫。劫是何义。答分别时分故名为劫。谓分别。刹那腊缚牟呼。栗多时分以成昼夜。分别昼夜时分以成半月。月时年分别半月等时分以成于劫。以劫是分别时分中极故得总名。声论者言。分别位故说名为劫。所以者何。劫是分别有为行中究竟位故

劫有三种。一中间劫。二成坏劫。三大劫。中间劫复有三种。一减劫。二增劫。三增减劫。减者从人寿无量。岁减至十岁。增者从人寿十岁增至八万岁。增减者从人寿十岁增至八万岁。复从八万岁减至十岁。此中一减一增十八增减。有二十中间劫经二十中劫世间成。二十中劫成已住。此合名成劫。经二十中劫世间坏。二十中劫坏已空。此合名坏劫。总八十中劫合名大劫。成已住中二十中劫初一唯减。后一唯增。中间十八亦增亦减。问此三谁最久。有说。减劫最久。增劫为中。增减最促。谓身有光时所经时久非身光灭。乃至于今食地味时所经时久非地味灭。乃至于今食地饼时所经时久非地饼尽。乃至于今食林藤时所经时久非从彼尽。乃至于今食自然稻时。所经时久非从彼尽。乃至于今。故此减劫时最为久。如是说者。初减后增中间十八。此二十劫其量皆等。唯于减时佛出于世。于唯增时轮王出世。于增减时独觉出世

问施设论说。人中四洲由日月轮以辨昼夜。欲天昼夜云何得知。答因相故知。谓彼天上若时钵特摩花合。殟钵罗花开。众鸟希鸣。凉风疾起。少欣游戏。多乐睡眠。当知尔时说名为夜。若时殟钵罗花合。钵特摩花开。众鸟和鸣。微风徐起。多欣游戏。少欲睡眠。当知尔时说名为昼

说一切有部发智大毗婆沙论卷第一百三十五阿毗达磨大毗婆沙论卷第一百三十六

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    大种蕴第五中具见纳息第三之三

心起住灭分名何法。答此增语所显。刹那腊缚牟呼栗多。问此应半月等前说。所以者何。由刹那等积成昼夜。昼夜积成半月月等半月月等积成劫故。何故前说粗后说细耶。答彼作论者意欲尔故。乃至广说。有作是说。阿毗达磨应以相求不以先后。但不违法相随说无失。有余师说。此作论中先说粗后说细令诸学者渐次入故。此中起分。谓生住分。谓老。灭分。谓无常。有为法有三分齐。谓时色名。时之极少。谓一刹那。色之极少。谓一极微。名之极少。谓依一字。积此以为渐多分齐名分齐。如杂蕴说

问彼刹那量云何可知。有作是言。施设论说。如中年女缉绩毳时。抖擞细毛不长不短。齐此说为怛刹那量。彼不欲说毳缕短长。但说毳毛从指间出。随所出量是怛刹那。问前问刹那。何缘乃引施设论。说怛刹那量。答此中举粗以显于细。以细难知不可显故。谓百二十刹那成一怛刹那。六十怛刹那成一腊缚。此有七千二百刹那。三十腊缚成一牟呼栗多。此有二百一十六千刹那。三十牟呼栗多成一昼夜。此有少二十不满六十五百千刹那。此五蕴身一昼一夜。经于尔所生灭无常。有说。此粗非刹那量。如我义者。如壮士弹指顷经六十四刹那。有说。不然。如我义者。如二壮夫掣断众多迦尸细缕。随尔所缕断经尔所刹那。有说。不然。如我义者。如二壮夫执挽众多迦尸细缕。有一壮士以至那国百练刚刀捷疾而断。随尔所缕断经尔所刹那。有说。犹粗非刹那量。实刹那量。世尊不说。云何知然。如契经说。有一苾刍来诣佛所。顶礼双足却住一面。白世尊言。寿行云何。速疾生灭。佛言。我能宣说汝不能知。苾刍言。颇有譬喻能显示不。佛言。有今为汝说。譬如四善射夫各执弓箭。相背攒立欲射四方。有一捷夫来语之曰。汝等今可一时放箭。我能遍接俱令不堕。于意云何。此捷疾不。苾刍白佛。甚疾。世尊。佛言。彼人捷疾不及地行药叉。地行捷疾不及空行药叉。空行捷疾不及四大王众天。彼天捷疾不及日月轮。二轮捷疾不及坚行天子。此是导引日月轮车者。此等诸天展转捷疾寿行生灭捷疾于彼。刹那流转无有暂停。由此故知世尊不说实刹那量。问何故世尊不为他说实刹那量。答无有有情堪能知故。问岂舍利子亦不知耶。答彼虽能知而于彼无用是故不说。佛不空说法故

一岁有十二月。昼夜增减略为二时。由减及增各六月故。然昼与夜增减相违。虽各二时而无四位。昼夜增减各一腊缚。月则各一牟呼栗多。三十牟呼栗多成一昼夜。于中昼夜多少四类不同。增位极长不过十八。减位极短唯有十二。昼夜停位各有十五。谓羯栗底迦月白半第八日。昼夜各十五牟呼栗多。从此以后昼减夜增各一腊缚。至末伽始罗月白半第八日。夜有十六牟呼栗多。昼十四至报沙月白半第八日。夜有十七昼十三。至磨伽月白半第八日。夜有十八昼十二。从此以后夜减昼增各一腊缚。至颇勒窭那月白半第八日。夜有十七昼十三。至制怛罗月白半第八日。夜有十六昼十四。至吠舍佉月白半第八日。昼夜各十五。从此以后夜减昼增各一腊缚。至誓瑟搋月白半第八日。夜有十四昼十六。至阿沙茶月白半第八日。夜有十三昼十七。至室罗筏拏月白半第八日。夜有十二昼十八。从此以后昼减夜增各一腊缚。至婆达罗钵陀月白半第八日。夜有十三昼十七。至阿湿缚庾阇月白半第八日。夜有十四昼十六。如是复至羯栗底迦月白半第八日。昼夜停等。是名略说时之分齐

问彼极微量复云何知。答应知极微是最细色不可断截破坏贯穿不可取舍乘履抟掣。非长非短。非方非圆。非正不正。非高非下。无有细分不可分析。不可睹见。不可听闻。不可嗅尝。不可摩触故说极微。是最细色。此七极微成一微尘。是眼眼识所取色中最微细者。此唯三种眼见。一天眼。二转轮王眼。三住后有菩萨眼。七微尘成一铜尘。有说。此七成一水尘。七铜尘成一水尘。有说。此七成一铜尘。七水尘成一兔毫尘。有说。七铜尘成一兔毫尘。七兔毫尘成一羊毛尘。七羊毛尘成一牛毛尘。七牛毛尘成一向游尘。七向游尘成一虮。七虮成一虱。七虱成一穬麦。七穬麦成指一节。二十四指节成一肘。四肘为一弓。去村五百弓。名阿练若处。从此已去名边远处。则五百弓成摩揭陀国一俱卢舍。成北方半俱卢舍。所以者何。摩揭陀国其地平正去村虽近而不闻声。北方高下远犹声及。是故北方俱卢舍大。八俱卢舍成一踰缮那。赡部洲人身长三肘半。或有过者。毗提诃人身长八肘。瞿陀尼人身长十六肘。俱卢洲人身长三十二肘。四大王众天身长俱卢舍四分之一。三十三天身长半俱卢舍。天帝释身长一俱卢舍。夜摩天身长。俱卢舍四分之三。睹史多天身长俱卢舍。乐变化天身长俱卢舍。及俱卢舍四分之一。他化自在天身长俱卢舍半。梵众天身长半踰缮那。梵辅天身长一踰缮那。大梵天身长一踰缮那半。少光天身长二踰缮那。无量光天身长四踰缮那。极光净天身长八踰缮那。少净天身长十六踰缮那。无量净天身长三十二踰缮那。遍净天身长六十四踰缮那。无云天身长百二十五踰缮那。福生天身长二百五十踰缮那。广果天身长五百踰缮那。无想天身亦尔。无烦天身长千踰缮那。无热天身长二千踰缮那。善现天身长四千踰缮那。善见天身长八千踰缮那。阿迦腻瑟搋天身长十六千踰缮那。如是名为色之分齐。颇有法四缘生耶。乃至广说。问何故作此论。答为止说缘无实者意显诸缘性皆是实有故作斯论。从缘生法有三种。一色。二心心所法。三心不相应行。色复有三。谓善染污无覆无记。心心所法心不相应行亦尔。此中善色。及异熟所不摄。无覆无记色生时一缘一少分。于此有作用。一缘者增上。一少分者因缘。则同类因。则此灭时一缘一少分。于此有作用。一缘者增上。一少分者因缘。则俱有因。染污色生时。一缘一少分。于此有作用。一缘者增上。一少分者因缘。则同类因遍行因。则此灭时一缘一少分。于此有作用。一缘者增上。一少分者因缘。则俱有因。异熟色生时一缘一少分。于此有作用。一缘者增上。一少分者因缘。则同类因异熟因。则此灭时一缘一少分。于此有作用。一缘者增上一少分者因缘。则俱有因。善心心所法及异熟所不摄。无覆无记心心所法生时。二缘一少分。于此有作用。二缘者增上等无间。一少分者。因缘。则同类因。则此灭时二缘一少分。于此有作用。二缘者增上所缘。一少分者因缘。则俱有因相应因。染污心心所法生时。二缘一少分。于此有作用。二缘者。增上等无间。一少分者。因缘。则同类因遍行因。则此灭时二缘一少分。于此有作用。二缘者增上所缘。一少分者。因缘则俱有因相应因。异熟心心所法生时。二缘一少分。于此有作用。二缘者。增上等无间。一少分者。因缘则同类因异熟因。则此灭时二缘一少分。于此有作用。二缘者。增上所缘。一少分者因缘。则俱有因相应因。善心不相应行中无想等至。灭尽等至生时。二缘一少分。于此有作用。二缘者。增上等无间。一少分者因缘。则同类因。则此灭时一缘一少分。于此有作用。一缘者增上。一少分者因缘。则俱有因。余善及异熟所不摄。无覆无记心不相应行生时。一缘一少分。于此有作用。一缘者增上。一少分者因缘。则同类因。则此灭时一缘一少分。于此有作用。一缘者增上。一少分者因缘。则俱有因。染污心不相应行生时。一缘一少分。于此有作用。一缘者增上。一少分者因缘。则同类因遍行因。则此灭时一缘一少分。于此有作用。一缘者增上。一少分者因缘则俱有因。异熟心不相应行生时。一缘一少分。于此有作用。一缘者增上。一少分者因缘。则同类因异熟因。则此灭时一缘一少分。于此有作用。一缘者增上。一少分者因缘。则俱有因。是谓此处略毗婆沙颇有法四缘生耶。答有。谓一切心心所法。问此法生时但由二缘半。于此有作用。云何乃说四缘生耶。答生位灭位合说四缘。起未已灭总名生故。问生时灭时各二缘半。若合说者应有五缘。何故说四。答依种类说不过四故。谓一缘唯于生时作用。一缘唯于灭时作用。二缘通于二时作用故合说四。颇有法三缘生耶。答有。谓无想等至灭尽等至。问此法生时但由二缘半。于此有作用。云何乃说三缘生耶。答生位灭位合说三缘。起未已灭总名生故。问此于生时有二缘半。灭时有一缘半。若合说者应有四缘。何故说三。答依种类说不过三故。谓一缘唯于生时作用。二缘通于二时作用故合说三。颇有法二缘生耶。答有。谓除无想灭尽等至。诸余心不相应行。及一切色。问此法生时但由一缘半。于此有作用。云何乃说二缘生耶。答生位灭位合说二缘。起未已灭总名生故。问此于生时有一缘半。灭时有一缘半。应有三缘。何故说二。答依种类说不过二故。谓二缘俱于生时灭时有作用故。颇有法一缘生耶。答无。所以者何。诸有为法性羸劣故。不自依故。依止他故。无作用故。不自在故。彼有为法最极少者。谓一刹那。一极微。法生位灭位除其自体。余一切法为增上缘。于灭位中生等为彼俱有因故。说为因缘。由此定无一缘生者

此中因缘摄一切有为法。等无间缘摄过去现在。除阿罗汉最后心聚。余心心所法。所缘缘增上缘。摄一切法。又因缘摄五蕴。等无间缘。摄无色四蕴少分。所缘缘增上缘。摄五蕴及非蕴。又因缘摄三世。等无间缘摄二世少分。所缘缘增上缘。摄三世及非世。问如是四缘谁胜谁劣。有说。因缘胜余劣。以因增长有生灭故。有说。等无间缘胜余劣。以能开辟圣道门故。有说。所缘缘胜余劣。诸心心所所依仗故。有说。增上缘胜余劣。诸法生灭皆不障故。如是说者。皆胜皆劣功能差别故。问谛与忍智为所缘缘。于与三乘谁为亲胜答无偏亲胜如豆聚等。但由忍智上中下故。施设所缘有三差别。如三力士射坚洛叉。摩诃诺健那中而不破。钵罗塞建提。破而不度。那罗延箭。破已直度更穿余物。非彼洛叉有坚软异。但由射者势力不同。故说洛叉亦有差别

问何缘阙故便般涅槃。有说。因缘流转生死由因缘力。因缘断故生死则断。有说。等无间缘。以阿罗汉后心不续便涅槃故。有说。所缘缘。以诸尔焰不起此后心心所法便涅槃故。有说。增上缘。以阿罗汉最后心后无不障碍便断绝故。如是说者。四缘阙故而般涅槃。以涅槃时四缘摄法。于彼相续皆无作用。便般涅槃

云何因相应法。乃至广说。问何故作此论。答欲止愚于相应法者执相应法体非实有。显相应法体是实有。故作斯论。于此义中有作是说。此中但依一因作论。谓相应因。由此中说相应言故。依彼意趣释此文者。云何因相应法。答一切心心所法。此是相应因自体法。与相应因自体法相应故名因相应。云何因不相应法。答色无为心不相应行。问色等既非相应因。自体如何乃说因不相应。答色等虽非相应因自体。而与相应因自体不相应故说为因不相应。斯有何失。云何因相应因不相应法。答则心心所法少分因相应。少分因不相应。少分因相应者。谓自于他。少分因不相应者。谓自于自。云何非因相应。非因不相应法。答则心心所法少分非因相应。少分非因不相应。少分非因相应者。谓自于自。少分非因不相应者。谓自于他。有说。此中依二因作论谓相应因俱有因。由此二因恒与彼法不相离故。有说。此中依三因作论。谓相应因俱有因同类因。由此三因通三性故。有说。此中依四因作论。除同类因遍行因。由此四因通三世故。有说。此中依五因作论。除能作因。以通无为非亲胜故。有说。此中依六因作论。由此所说因言总故。然相应法或有具作六因自体。或有但作五因自体。或有但作四因自体。何等具作六因自体。谓不善遍行心心所法。何等但作五因自体。谓不善非遍行心心所法。若有覆无记遍行心心所法。若善有漏心心所法。何等但作四因自体。谓有覆无记非遍行心心所法。若无覆无记心心所法。若无漏心心所法。依彼意趣释此文者。云何因相应法。答一切心心所法。谓六因自体法。与六因自体法相应。五因自体法。与五因自体法相应。四因自体法。与四因自体法相应故。名因相应。后三问答准前应知

云何缘有缘法。乃至广说。问何故作此论。答欲止愚于所缘缘性执所缘缘非实有法者意显所缘缘体是实有故作斯论。云何缘有缘法。答若意识并相应法。缘心心所法。由有所缘法。为此所缘故。说此为缘有缘法。如明眼者见明眼人。彼明眼人复有所见。缘有缘法应知亦尔。云何缘无缘法。答五识身并相应法。若意识并相应法。缘色无为心不相应行。由无所缘法为此所缘故。说此为缘无缘法。如明眼者见生盲人。彼生盲人更无所见。缘无缘法应知亦尔。云何缘有缘缘无缘法。答若意识并相应法。缘心心所法。及色无为心不相应行。由有所缘无所缘法。为此所缘故。说此为缘有缘缘无缘法。如明眼者见明眼人及生盲人。彼明眼人复有所见。彼生盲人更无所见。缘有缘缘无缘法应知亦尔。有余。谓此第三句义。则合初二更无异体。此不应理。与本论相违故。如本论说。缘有缘法是有为。缘随眠随增。缘无缘法是一切随眠随增。缘有缘缘无缘法是有为缘随眠随增。非缘有缘非缘无缘法。是有漏缘随眠随增。然有意识并相应法。一刹那顷总缘有缘及无缘法。是故如前所说者好。云何非缘有缘非缘无缘法。答色无为心不相应行。由此法不缘有所缘无所缘法故说此为非缘有缘非缘无缘法。如生盲人都无所见。此亦如是

如世尊说。内无色想观外色。乃至广说。问何故作此论。答为欲分别契经义故。如契经说。内无色想观外色。虽作是说而不分别。云何内无色想观外色。乃至广说。今欲分别。故作斯论。云何内无色想观外色耶。答谓有苾刍起如是胜解。今我此身将死。已死将上舆。已上舆将往冢间。已往冢间将置地。已置地将为种种虫食。已为种种虫食。彼于最后不见内身。唯见外虫。是名内无色想观外色。谓彼由先多胜解。力不见身相。但见违逆损害内身外诸虫相。复有苾刍起如是胜解。今我此身将死。已死将上舆。已上舆将往冢间。已往冢间将置薪[卄/積]。已置薪[卄/積]将为火焚。已为火焚彼于最后不见内身。唯见外火。是名内无色想观外色。谓彼由先多胜解力。不见身相。但见违逆损害内身外诸火相。复有苾刍起如是胜解。今我此身。甚为虚伪。如雪或雪抟。如沙糖或沙糖抟。如生熟酥或生熟酥抟。将为火炙。已为火炙将融销。已融销。彼于最后不见内身唯见外火。是名内无色想观外色。谓彼由先多胜解力。不见身相。但见违逆损害内身外诸火相。此中如雪或雪抟者。谓北方诸瑜伽师。如沙糖或沙糖抟者。谓南方诸瑜伽师。如生熟酥或生熟酥抟者。谓一切处诸瑜伽师。问若时作内无色想则时观外色耶。为尔时但观外色。不作内无色想耶。设尔何过。若时作内无色想。则时观外色者。云何一觉不作二解差别解耶。如是一觉便成多体。若尔时但观外色。不作内无色想者。此文所说内无色想观外色复云何通答应说。尔时但观外色。不作内无色想。问若尔此文所说内无色想观外色当云何通。答依瑜伽师意乐而说。谓观行者有如是意乐。我当内无色想观外色随彼而说。然于尔时唯观外色。有说。依彼先时分别行相故作是说。谓瑜伽师先起如是分别行相。我当如是如是作内无色想观外色观。及修观时唯观外色。有说。此文依修加行成满时说。谓内无色想者。说此善根加行时。观外色者。说此善根成满时。非于一时有二种解。有说。此文依义至说。谓若内无色想义至观外色。若观外色义至内无色想。非于一觉有二种解。有说。内无色想者。说所依观外色者。说所缘。非于所缘俱起二解。有余师说。若时作内无色想。则时亦观外色。问若尔云何一觉不作二解差别解耶。答虽作二解而不相违故无有失。此不应理。有无二相互相违故。是故如前所说者好

如世尊说。有除色想。乃至广说。问何故复作此论。答彼作论者意欲尔故。乃至广说。有说。为欲分别契经义故。谓契经中说除色想。而不广辩。今欲辩之故作斯论。云何除色想耶。答谓有苾刍起如是胜解。今我此身将死。已死将上舆。已上舆将往冢间。已往冢间将置地。已置地将为种种虫食。已为种种虫食。此种种虫将散。已散。彼于最后不见自身。亦不见虫。是名除色想。谓彼由先多胜解力不见身相。亦复不见违害内身外诸虫相。复有苾刍起如是胜解。今我此身将死。已死将上舆。已上舆将往冢间。已往冢间将置薪[卄/積]。已置薪[卄/積]将为火焚。已为火焚此焚尸火将灭。已灭。彼于最后不见自身。亦不见火。是名除色想。谓彼由先多胜解力不见身相。亦复不见违害内身外诸火相。复有苾刍起如是胜解。今我此身甚为虚伪。如雪或雪抟。如沙糖或沙糖抟。如生熟酥或生熟酥抟。将为火炙。已为火炙将融销。已融销。此能销火将灭。已灭。彼于最后不见自身。亦不见火。是名除色想。谓彼由先多胜解力不见身相。亦复不见违害内身外诸火相。如雪抟等三种譬喻。随方差别如前应知

问彼瑜伽师何处曾见如是诸相。而今观耶。答由彼曾与同梵行者作瞻病人。曾见苾刍大种乖适。断诸饮食呻吟苦痛。虽加医药转复增剧。乃至渐困暴汗交流。喘息奔急须臾命尽。为缚床舆安置其尸。同学悲酸送至葬所。若所至处薪难得者。便置坑中悒然舍去。后日重往见彼尸骸。已为狐狼鸱枭雕鹫乌鹊饿狗之所啖食。须臾远观骨肉都尽。倏忽四散其处寂然。若处柴薪易可得者。便积薪木安置其尸。以火焚之俄顷皆尽。须臾火灭寂无所有。彼瑜伽师善取如是种种相已。疾还所住洗足敷座。结跏趺坐调直身心。令无热恼远离诸盖。有所堪能忆念先时。所取诸相以胜解力想见己身。次第有前所见众相。若不曾作瞻养病人。彼于一时见雪抟等渐次为火之所销融。乃至后时都无所见。取是相已。以胜解力想见己身。次第有前所见众相。由此缘故诸瑜伽师。于其自身起斯胜解。问如是观察分位不同。于诸观门何等所摄。答是除色想及此加行。并此加行。加行所摄。谓不见身不见虫火此最后位除色想摄。若不见身而见虫火。是除色想加行所摄。若犹见身亦见虫火。是此加行。加行所摄。有作是说。是除色想及第二初解脱所摄。谓不见身不见虫火。是除色想。若不见身而见虫火。是第二解脱。若犹见身亦见虫火。是初解脱。有余师说。显三善根。谓不见身不见虫火。此显上品。若不见身而见虫火。此显中品。若犹见身亦见虫火。此显下品

说一切有部发智大毗婆沙论卷第一百三十六阿毗达磨大毗婆沙论卷第一百三十七

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    大种蕴第五中具见纳息第三之四

问此除色想。自体云何。答慧为自体。若尔何故以想为名。由此聚中想用增故。如持息念身等念住。本性生念。宿住随念。皆慧为体。以念为名。念用增故。彼亦如是已说自体。应释其名。此以何故名除色想。由此能遣诸积集色令不现前。名除色想。界者色界。地者第四静虑。所依者依欲界身。行相者不明了行相。所缘者缘欲界。问此缘欲界何法。答有说。即缘[卄/積]坑等处。有说。即缘彼处空界。如是说者。即缘所除所有诸色。于中有说。唯缘所除自身诸色念住者身念住。智者世俗智。等持者非等持俱。根者舍根相应世者通三世。过去缘过去。现在缘现在。未来可生者。缘未来。不生者缘三世。善不善无记者。是善缘三种。有说。唯缘无记。三界系不系者。是色界系。缘欲界系。学无学非学非无学者。是非学非无学。缘非学非无学。见所断修所断不断者。是修所断。缘修所断。缘自身他身非身者。有说。唯缘自身。有说。缘自他身。有说。通缘三种。缘名缘义者。唯缘义。加行得离染得者。是加行得。非离染得。已离第四静虑染者。若不加行求此想时。终不能起令现前故有说。佛离染得。离有顶染时得故。余加行得。有说。余亦离染得。而加行现前。佛不加行独觉下加行。声闻或中或上。起处者在欲界。非色无色界。在人三洲非北洲。问此谁所起。答有说唯圣者非异生。有说。异生亦起。异生有二种。一内法异生。二外法异生。内法者能起非外法。以外法异生。长夜执我怖畏无我。不乐遣除内所依色故。已说此想自性等门复应显示有杂无杂。问诸无除色想皆未离色染耶。答诸未离色染皆无除色想。有无除色想非未离色染。谓已离色染而未入彼定。问诸有除色想皆已离色染耶。答诸有除色想皆已离色染。有已离色染非有除色想。谓已离色染而未入彼定。所以者何。前说彼定唯加行得。非离染得故。虽已离第四静虑染。若不加行求此定时。终不能起令现前故。有说。此定虽离染得。而独觉等要起加行方令现前。此依现前有无作论故作是说

问除色想言有多处说。谓此处说杂蕴。亦言入无色定除去色想。波罗衍拏亦作是说

  诸有除色想　　能除一切身
  于内外法中　　无有不见者

众义品中亦作是说

  于想有想非即离　　亦非无想非除想
  如是平等除色想　　无有染着彼因缘

如是诸说义有何异。答此说能遣诸积集色令不现前。名除色想。波罗衍拏众义品说。断色界爱名除色想。杂蕴中说。不缘下地流转诸色名除色想。有说。此除色想在第四静虑。波罗衍拏众义品说。除色想者在七地。谓未至中间四静虑空无边处近分。杂蕴所说除色想者。亦在七地。谓四无色上三近分。有说。此除色想是身念住。波罗衍拏众义品说。除色想者是法念住。杂蕴所说除色想者。通四念住。有说此除色想是不共。余三是共。有说。杂蕴所说是共。余三不共。是名诸说异义

四识住七识住。为四摄七。七摄四耶。乃至广说。问何故作此论。答为欲分别契经义故。谓契经说。四识住七识住九有情居。而不广分别。亦不明摄。今欲广解。并显相摄故。作斯论。四识住者。如契经说。一色随识住。二受随识住。三想随识住。四行随识住。色随识住者。谓色有漏随顺于取有情数摄。行随识住亦尔。受随识住者。谓受有漏随顺于取想。随识住亦尔。有余师说。色随识住者。谓色有漏随顺于取。有情数非有情数摄。行随识住亦尔。受想随识住如前说。问有情数蕴。说为识住。此事可尔。非有情数蕴云何名识住。答有多种识住。谓相应识住。俱有识住。所依识住。所缘识住。所行识住。非有情数蕴。是识所缘故名识住。已说自性。应说因缘。何因缘故说名识住。答识于此中住。等住近住故名识住。如马等所住名马等住。有说。此中喜所润识增长广大故名识住。有说。此中爱所润识摄受不离故名识住。有说。此中诸有漏识随顺取识生起执着。安住增长故名识住

问何故无漏法不立识住。答诸无漏法无识住相故。复次若法能增益有。能摄受有。能住持有。立为识住。诸无漏法能损减有。能违害有。能破坏有。故非识住。复次若法乃至是身见事。乃至堕苦集谛立为识住。诸无漏法乃至非身见事。乃至不堕苦集谛。故非识住。有说。若法喜所润识于中增长广大立为识住。诸无漏法与此相违故非识住。有说。若法爱所润识于中摄受不离立为识住。诸无漏法则不如是。故非识住。有说。若法诸有漏识随顺取识于中生起执着。安住增长立为识住。诸无漏法与此相违故非识住

问何故识非识住。答为识故立识住。如为王故立王座。如王座王床王路亦尔。如王非路路非王。是王所行故名王路。如是识非住住非识。是识所止故名识住。是故识非识住。有说。若法识所乘御。如象马船人所乘御。彼法立识住非识。乘御于识故识非识住。复次若法与识俱生俱住俱灭。于识有用立为识住。识于识不尔。有说。识住法尔与识俱在现在。是识所住。非识与识得有此事。问自识他识俱在现在。何不展转立识住耶。答自识于自识非识住故。于他识亦非无异相故。复次于自识亲尚非识住。况于疏远。有说。若法与识三和合生。互有作用立为识住。非识与识三和合生互有作用。故非识住

由自分识于中住故。自分诸蕴得识住名。谓欲界蕴。欲界识所住。色界蕴色界识所住。无色界蕴。无色界识所住。初静虑蕴。初静虑识所住。乃至非想非非想处蕴。非想非非想识所住。问生欲界起色无色界无漏心现在前。现在二蕴是识住不。答应言是识住。问无同分识于中止住。云何名识住。答得识住相故。谓同分识余缘故不生。非此不能生故亦名识住。如泉池侧。置象马鱼师子等口以为注道。水不行时非此为障。水若行者为作所依。虽水不行亦名注道。彼亦如是。七识住者。如契经说。有色有情身异想异。如人一分天是第一识住有色者。谓彼有情有色可了。有色身。有色界处蕴。有色施设。故名有色。有情者。谓谛义胜义。有情不可得非实有体。然于界处蕴中。假想施设说为有情。奈落。意生。儒童。养者。补特伽罗。命者。生者。故名有情。身异者。谓彼有情有种种身。种种显形状貌差别故名身异。想异者。谓彼有情。有乐想。苦想。不苦乐想。故名想异。如人一分天者。人则一切人。一分天。谓欲界天。是第一识住者。第一则次第中最初数。识住谓彼所系色受想行识。释识住义已如前说。有色有情身异想一。如梵众天。谓彼初起是第二识住。有色等如前说。想一者。谓彼有情染想无异。如梵众天者。此显梵世诸天。谓彼初起者。谓彼初生同起染想。后便想异。是第二识住者。第二准前识住。如前说。有色有情身一想异。如极光净天。是第三识住。有色等如前说。身一者。谓彼有情有一类身。一类显形状貌无别。想异者。谓彼有情有乐想不苦不乐想。由彼诸天厌根本地喜根已。起近分地舍根现前。厌近分地舍根已。起根本地喜根现前。如富贵人。厌欲乐已欣住法乐厌法乐已欣住欲乐。如极光净天者。此显第二静虑诸天。有色有情身一想一。如遍净天。是第四识住。有色等如前说。想一者。谓彼有情有无覆无记无差别想。如遍净天者。此显第三静虑诸天。无色有情一切色想皆超越故。诸有对想皆隐没故。于别异想不作意故。入无边空。空无边处具足住。如随空无边处天。是第五识住。无色有情一切空无边处皆超越故。入无边识。识无边处具足住。如随识无边处天。是第六识住。无色有情一切识无边处皆超越故。入无少所有无所有处具足住。如随无所有处天。是第七识住。此中诸无色者。谓彼有情无色可了。无有色身。无色界处蕴。无色施设故名无色。有情等如前说。一切空无边处皆超越等如余处说。识住者。谓彼所系受想行识。问何故初静虑有异身非上地。答以初静虑立王臣众有差别故。谓大梵王与诸梵辅及诸梵众数数集会。于中种种显形状貌。衣服语言各有差别。上地不尔。有说。初静虑受上中下无别异。业异熟故身有异。上地不尔。有说。初静虑受有寻伺。业异熟故身有异。上地不尔。有说。初静虑受表无表。业异熟故身有异。上地不尔。有说。初静虑受四识身相应。业异熟故身有异。上地不尔。有说。初静虑受三受相应。业异熟故身有异。上地不尔。由如是等种种因缘。初静虑身异上地身一。又初静虑。由染污想说为想一。第二静虑。由善想说为想异。第三静虑。由无覆无记异熟想说为想一。问何故恶趣。第四静虑。非想非非想处。皆不立识住耶。答有作是说。彼亦应立在识住中。而不立者。是有余说。尊者世友作如是说。此是世尊要略而说。然恶趣等摄在此中。谓诸恶趣当知摄在初识住中。第四静虑摄次三中。非想非非想处摄后三中。所以者何。以界同故。有说。若处有二种识多分可得。立为识住。一爱所摄受识。二见所摄受识。恶趣及非想非非想处。爱所摄受识多分不可得。第四静虑。见所摄受识多分不可得。故非识住。有说。若处有三种识多分可得。立为识住。一见所断识。二修所断识。三不断识。恶趣。非想非非想处。不断识俱不可得。第四静虑。见所断识多分不可得。故非识住。问岂不第四静虑异生。皆有见所断识可得耶。答虽有而于彼地非多分可得。五净居天全无有故。问人欲界天。不断识亦不可得。应非识住。答可得有二。一自性可得。二所依可得。人欲界天。不断识虽非自性可得。而所依可得故立识住。问岂不非想非非想处。不断识亦所依可得耶。生彼有得阿罗汉故。答虽有而非多分。以生彼中暂起圣道。取无学果已。乃至涅槃不现前故。有说。若处有六种识多分可得立为识住。谓见苦所断识。乃至修所断识。及不断识。恶趣。非想非非想处。不断识俱不可得。第四静虑。前四所断识。多分不可得故非识住。问答分别如前应知。有说。若处识所乐住立为识住。诸恶趣中苦所逼故识不乐住。第四静虑乐。迁动故识不安住。谓诸异生或乐入无色。或乐入无想。或乐令识灭。若诸圣者或乐入无色。或乐入净居。或乐入无余。非想非非想处。极寂静故心微劣故识不乐住。有说。若处无坏识法。而可得者立为识住。诸恶趣中有极苦受。第四静虑。有无想定。无想异熟非想非非想处。有灭尽定。能坏识法故非识住。有说。若处由二事故。发起殊胜异分诸识。令现在前立为识住。一由定故。二由生故。恶趣。非想非非想处。二事俱无。第四静虑。虽有定故而无生故。有言。恶趣二事俱无第四静虑虽有定故而无生故。非想非非想处虽有生故而无定故。由如是等种种因缘。恶趣等非识住

问何故四识住中识非识住。七识住中识是识住。答由别因故立四识住。由别因故立七识住。谓若有法识所乘御。与识俱行亲近和合。立四识住。识望于识无如是事故。不立在四识住中。若法与识为因为果。展转相资立七识住。识望于识有如是事。是故立在七识住中

九有情居者。如契经说。有色有情身异想异。如人一分天。是第一有情居。有色有情身异想一。如梵众天。是第二有情居。有色有情身一想异。如极光净天。是第三有情居。有色有情身一想一。如遍净天。是第四有情居。有色等如前说。有情居者。谓彼所系色受想行识。又是有情所居。所住。所止。生处。故名有情居。有色有情。无想无别想。如无想有情天。是第五有情居。有色等如前说。无想者。彼处长时想等灭故。则由此义名无想有情天。无色有情一切色想皆超越。故诸有对想皆隐没故。于别异想不作意故。入无边空空无边处具足住。如随空无边处天。是第六有情居。无色有情。一切空无边处皆超越故。入无边识。识无边处具足住。如随识无边处天。是第七有情居。无色有情一切识无边处皆超越故。入无少所有。无所有处具足住。如随无所有处天。是第八有情居。无色有情一切无所有处皆超越故。入非想非非想处具足住。如随非想非非想处天。是第九有情居。无色等如前说。一切无所有处皆超越等如余处说

问何缘恶趣及无想所不摄。广果天等非有情居。答有作是说。彼亦应立为有情居。而不立者。是有余说。尊者世友作如是说。此是世尊要略而说。然恶趣等摄在此中。谓诸恶趣当知摄在初有情居。无想所不摄。广果天等当知摄在第五有情居。所以者何。以地同故。有说。若处余乐来居。已居其中。不乐迁动。是处可立为有情居。诸恶趣中二俱不然。但由业力令往令住。若随意欲刹那不住故不建立。第四静虑除无想天。余虽乐来而好迁动。如边城邑人不乐居。谓彼异生或乐无色。或乐无想。若诸圣者或乐净居。或趣涅槃。如国边城恒为盗贼邻敌侵故。贵族生财乐转余处。虽留少分以充镇守。有诸商人来求资货。镇人谓曰。此处多灾无以相瞻。商旅咸曰。此非城邑。如是无想所不摄天。惑业所驱恒乐迁动。故不说彼为有情居

已分别三种自性。今当说杂无杂相。问四识住七识住。为四摄七。七摄四耶。答应作四句。有四非七。谓地狱傍生鬼界。广果色受想行。及非想非非想处。受想行。有七非四。谓人。欲界天。梵众。极光净。遍净。空无边处。识无边处。无所有处心。有亦四亦七。谓人。欲界天。梵众。极光净。遍净色受想行。及空无边处。识无边处。无所有处受想行。有非四非七。谓地狱傍生鬼界。广果。非想非非想处心。此中所以如前广说。问四识住九有情居。为四摄九。九摄四耶。答应作四句。有四非九。谓地狱傍生鬼界。无想天所不摄广果。色受想行。有九非四。谓人。欲界天梵众。极光净。遍净。无想天。四无色心。有亦四亦九。谓人。欲界天。梵众。极光净。遍净。无想天。色受想行。及四无色。受想行。有非四非九。谓地狱傍生鬼界。无想天所不摄广果心。此中所以亦如前说。问七识住九有情居。为七摄九。九摄七耶。答九摄七。非七摄九。何所不摄。答二处。谓无想天处。及非想非非想处。此中所以亦如前说

问世尊何故。于无想天。及有顶天多说为处。答有诸外道。执此二处以为解脱。佛为遮彼说为生处。有说。外道执此二处为最寂静。佛说为处。明是喧动而非寂静。是界趣生流转处故。有说。外道执此二处。是真解脱永无退还。故佛说彼是退还处。非真解脱。谓从非想非非想处没。多生下地。无想天没必生欲界。有说。彼二天寿量长远。外道多执为真涅槃。谓无想天于唯异生。生处寿量最远。非想非非想天于一切生处寿量最远。故佛说彼是无常处。有作是说。九有情居。世尊皆以二名宣说。于其七种作二名说。谓名识住及有情居。于余二种亦二名说。谓名为处及有情居。有余师说。佛以识住与有情居展转相摄。余不尽者唯有二处。不应异释。空无边等亦名处故。有说。生处精勤果中此居后边故。说名处。谓唯异生生处精勤果。中无想天为后边。一切生处精勤果中。有顶天为后边

    大种蕴第五中执受纳息第四之一

有执受大种。与有执受大种。为几缘。如是等章。及解章义既领会已。应广分别。问何故作此论。答彼作论者意欲尔故。随彼意欲而作论。但不违法相便不应责。复次欲止说因缘法。及去来世非实有者。意显诸因缘去来实有故作斯论。此中有执受大种者。谓现在刹那有情数摄。心心所法所执受大种。无执受大种者。谓过去未来及现在一分有情数摄。并三世一切非情数摄所有大种。是谓此处略毗婆沙

有执受大种。与有执受大种为几缘。答因。增上。因者一因。谓俱有因。增上者谓不碍生。及唯无障。然有差别。谓一果者。异类相望为因。增上。非一果者。但一增上。有执受大种。与无执受大种。为几缘。答因。增上。因者一因。谓同类因。增上者如前说。然有差别。谓有执受大种。与未来有情数大种。为因。增上。与余无执受大种。但一增上。无执受大种。与无执受大种。为几缘。答因。增上。因者二因谓俱有。同类。增上者如前说。然有差别。谓过去有情数大种。与过去有情数大种。为因。增上。因者。二因。谓俱有。同类。增上者如前说。与未来有情数大种。及现在有情数无执受大种为因。增上。因者一因。谓同类因。增上者如前说。与余无执受大种但一增上。过去非有情数大种。与过去非有情数大种。为因。增上。因者二因。谓俱有。同类。增上者如前说。与未来现在非有情数大种。为因。增上。因者一因。谓同类因。增上者如前说。与过去未来有情数大种。及现在有情数无执受大种。但一增上。未来有情数大种。与未来有情数大种。为因。增上。因者一因。谓俱有因。增上者如前说。与余无执受大种。但一增上。未来非有情数大种。与未来非有情数大种。为因。增上。因者一因。谓俱有因。增上者如前说。与余无执受大种但一增上。现在有情数无执受大种。与现在有情数无执受大种。为因。增上。因者一因。谓俱有因。增上者如前说。与未来有情数大种。为因。增上。因者一因。谓同类因。增上者如前说。与余无执受大种。但一增上。现在非有情数大种。与现在非有情数大种。为因。增上。因者一因。谓俱有因。增上者如前说。与未来非有情数大种。为因。增上。因者一因。谓同类因。增上者如前说。与余无执受大种。但一增上。无执受大种。与有执受大种。为几缘。答因增上。因者一因。谓同类因。增上者如前说。然有差别。谓过去有情数大种。与有执受大种。为因。增上。因者一因。谓同类因。增上者如前说。余无执受大种。与有执受大种。但一增上。已说大种当说所造。所造亦二。谓有执受及无执受。现在刹那有情数摄。心心所法所执受者。是有执受。过去未来及现在一分有情数摄三世一切非情数摄。是无执受。是谓此处略毗婆沙。有执受所造色。与有执受所造色。为几缘。答一增上。增上义如前说。无因者。有对所造色展转相望非俱有因故。有执受所造色。与无执受所造色。为几缘。答因。增上。因者二因。谓同类。异熟。增上者如前说。然有差别。谓有执受所造色。与未来有情数所造色。为因。增上。与余无执受所造色。但一增上。无执受所造色。与无执受所造色。为几缘。答因。增上。因者三因。谓俱有。同类。异熟因。增上者如前说。然有差别。谓过去有情数所造色。与过去有情数所造色。为因。增上。因者三因。谓俱有。同类。异熟因。增上者如前说。与未来有情数所造色。为因。增上。因者二因。谓同类。异熟。增上者如前说。与现在有情数无执受所造色。为因增上。因者一因。谓同类

增上者如前说。与余无执受所造色。但一增上过去非有情数所造色。与过去未来现在非有情数所造色。为因。增上。因者一因。谓同类因。增上者如前说。与余无执受所造色。但一增上。未来有情数所造色。与未来有情数所造色。为因。增上。因者二因。谓俱有。异熟。增上者如前说。与余无执受所造色。但一增上。未来非有情数所造色。与一切无执受所造色。但一增上。现在有情数无执受所造色。与现在有情数无执受所造色。为因。增上。因者一因。谓俱有因。增上者如前说。与未来有情数所造色。为因。增上。因者二因。谓同类。异熟。增上者如前说。与余无执受所造色。但一增上。现在非有情数所造色。与未来非有情数所造色。为因。增上。因者一因。谓同类因。增上者如前说。与余无执受所造色。但一增上。无执受所造色。与有执受所造色。为几缘。答因。增上。因者二因。谓同类。异熟。增上者如前说。然有差别。谓过去有情数所造色。与有执受所造色。为因。增上。因者二因。谓同类。异熟。增上者如前说。余无执受所造色。与有执受所造色。但一增上

说一切有部发智大毗婆沙论卷第一百三十七阿毗达磨大毗婆沙论卷第一百三十八

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    大种蕴第五中执受纳息第四之二

因相应法。与因相应法。为几缘。答因。等无间。所缘。增上。因者。五因。谓相应。俱有。同类。遍行。异熟。等无间者。谓因相应法等无间。因相应法现在前。所缘者。谓因相应法。与因相应法。为所缘。增上者。谓不碍生。及唯无障。因相应法。与因不相应法为几缘。答因等无间增上。因者四因。谓俱有。同类。遍行。异熟。等无间者。谓因相应法等无间。因不相应法现在前。即无想等至。灭尽等至。是心心所等无间法故。增上者如前说。非所缘者。因不相应法无所缘故。因不相应法。与因不相应法。为几缘。答因。增上。因者四因。谓俱有同类。遍行。异熟。增上者如前说。因不相应法。与因相应法。为几缘。答因。所缘。增上。因者。四因。谓俱有。同类。遍行。异熟。所缘者。谓因不相应法。与因相应法。为所缘。增上者如前说。非等无间者。因不相应法非等无间缘故

有所缘法。与有所缘法。为几缘。答因等无间所缘增上。因者五因。谓相应。俱有。同类。遍行。异熟。等无间者。谓有所缘法等无间。有所缘法现在前。所缘者。谓有所缘法。与有所缘法。为所缘。增上者如前说。有所缘法。与无所缘法。为几缘。答因等无间增上。因者四因。谓俱有。同类。遍行。异熟。等无间者。谓有所缘法等无间。无所缘法现在前。即无想等至。灭尽等至。是心心所等无间法故。增上者如前说。非所缘者。无所缘法无所缘故。无所缘法。与无所缘法。为几缘。答因。增上。因者四因。谓俱有。同类。遍行。异熟。增上者如前说。无所缘法。与有所缘法。为几缘。答因所缘增上。因者四因。谓俱有。同类。遍行。异熟。所缘者。谓无所缘。与有所缘法。为所缘。增上者如前说。非等无间者。无所缘法非等无间缘故有色法。与有色法。为几缘。答因增上。因者三因。谓俱有。同类。异熟。增上者如前说。有色法。与无色法。为几缘。答因所缘增上。因者三因。谓俱有。同类。异熟。所缘者。谓有色法。与无色法。为所缘。增上者如前说。非等无间者。以有色法非等无间缘故。无色法。与无色法。为几缘。答因等无间所缘增上。因者五因。谓相应等五。等无间者。谓无色法等无间。无色法现在前。所缘者。谓无色法。与无色法为所缘。增上者如前说。无色法。与有色法。为几缘。答因。增上。因者四因。谓俱有同类。遍行。异熟。增上者如前说。有见无见有对无对说亦如是。差别者。有见法。与有见法。为二因。谓同类。异熟。余皆如前说。有漏法。与有漏法。为几缘。答因等无间所缘增上。因者五因。谓相应等五。等无间者。谓有漏法等无间。有漏法现在前。所缘者。谓有漏法。与有漏法。为所缘。增上者如前说。有漏法与无漏法。为几缘。答等无间所缘增上。等无间者。谓有漏法等无间。无漏法现在前。所缘者。谓有漏法。与无漏法为所缘。即苦集忍智品心心所法。增上者如前说。非因者。以因如种子。非有漏法。与无漏法为种子故。无漏法。与无漏法为几缘。答因等无间所缘增上。因者三因。谓相应。俱有。同类。等无间者。谓无漏法等无间。无漏法现在前。所缘者。谓无漏法。与无漏法。为所缘。即灭道忍智品心心所法。增上者如前说。无漏法。与有漏法。为几缘。答等无间。所缘。增上。等无间者谓无漏法等无间。有漏法现在前。所缘者。谓无漏法。与有漏法。为所缘。增上者如前说。非因者。以因如种子。非无漏法。与有漏法为种子故。有为法。与有为法。为几缘。答因等无间所缘增上。因者五因。谓相应等五。等无间者。谓有为法等无间。有为法现在前。所缘者。谓有为法。与有为法。为所缘。增上者如前说。有为法。与无为法。为几缘。答无。无为法。与无为法。为几缘。答无。无为法。与有为法。为几缘。答所缘。增上。所缘者。谓无为法。与有为法。为所缘。增上者如前说。问何故有为法。有因有缘。无为法。无因无缘耶。答诸有为法性羸劣故。藉诸因缘。无为法强盛不藉因缘。如劣者依他。强者不依。此亦如是。有说。诸有为法有作用故假诸因缘。无为法无作用故不假因缘。如刈者须镰。掘者须锸。无所作者则无所须。此亦如是。有说诸有为法行世取果作用。了境故须因缘。无为法无如是事故不须因缘。如远行者则须资粮。不行不须。此亦如是。有说。有为如王亦如眷属故有因缘无为如王不如眷属故无因缘。如王王眷属。富贵者富贵者眷属。帝释帝释眷属。当知亦尔

问诸有为法有时不生谁作留难。为有为法。无为法耶。答诸有为法为作留难。非无为法。以无为法恒与有为作能作因。及增上缘。于生不生俱无障故。如泉池侧师子口等。水不流时自有余缘非此为障。问诸无为法。与有为法作增上缘及所缘缘。于能缘不能缘作增上缘。有胜劣不。答增上缘义等无差别。若缘不缘皆无障故。所缘缘义则有差别。于能缘者作所缘缘。于不能缘。则便不作诸缠所缠续地狱有。乃至广说。所说有声义有多种。如结蕴广说。此中说续众同分。有情数五蕴名有。然相续有五。一中有相续。二生有相续。三分位相续。四法相续。五刹那相续。中有相续者。谓死有蕴灭。中有蕴起。中有续死有名中有相续。生有相续者。谓中有蕴灭生有蕴起。生有续中有名生有相续。分位相续者。谓羯逻蓝位蕴灭頞部昙位蕴起。乃至中年位蕴灭老年位蕴起。皆以后位续前位名分位相续。法相续者。谓善法等无间。染或无记法现在前。染法等无间。善或无记法现在前。无记法等无间。善或染法现在前。皆以后法续前法名法相续。刹那相续者。初刹那蕴等无间。第二刹那蕴现在前。后刹那续前刹那名刹那相续。此五皆入二相续中。谓法相续刹那相续。皆不离法及刹那故。界分别者。欲界具五。色界有四除分位。无色界有三又除中有。趣分别者。地狱有四除分位。余趣具五。生分别者。一切具五。于此五相续中。依二相续而作论。谓中有生有

诸缠所缠续地狱有。最初所得诸根大种。彼诸根大种。与彼心心所法为几缘。答一增上。即彼心心所法。与彼诸根大种为几缘答一增上。诸缠所缠续傍生有鬼有人有天有。最初所得诸根大种。彼诸根大种。与彼心心所法为几缘。答一增上。即彼心心所法。与彼诸根大种为几缘。答一增上。问若彼心心所法。不缘彼诸根大种而结生者。可说彼诸根大种。与彼心心所法。但一增上。若彼心心所法。缘彼诸根大种。而缘生者。彼诸根大种。与彼心心所法便为二缘。谓所缘增上。何故定答但一增上。答亦应说二而不说者当知此义有余。有说此中说决定者。谓增上缘则定。所缘缘不定。是以不说。有说此中说互有者。谓根大种与心心所展转为增上缘。是以则说非心心所与根大种为所缘缘。是故不说。有说此中说相资者。谓彼根大与心心所更互相资增上义胜。所缘不尔。随缘何法皆得起故。是以不说

生欲界入有漏初静虑。乃至非想非非想处。长养诸根增益大种。彼诸根大种与彼心心所法为几缘。答一增上。即彼心心所法与彼诸根大种为几缘。答一增上。问彼心心所法。若缘余法而入定者可如所说。若即缘彼诸根大种而入定者则有二缘。何故乃说但一增上。答应说而不说者当知此义有余。有说。此中说决定者。所缘不定是故不说。有说。此中说互有者。所缘不尔是故不说。有说。此中说相资者。谓心心所与彼根大更互相资增上义胜。所缘不尔随缘何法。皆得生起是故不说。问入诸静虑长益根大与入无色差别云何。答静虑长益多而非妙。如缚喝国食无色长益妙而非多。如中印度食

生欲界入无漏初静虑。乃至无所有处。长养诸根增益大种。彼诸根大种与彼心心所法为几缘。答一增上。即彼心心所法与彼诸根大种为几缘。答一增上。此中不说所缘缘义。及静虑无色长益差别。如前应知。问入有漏静虑。无色长益根大。与入无漏差别云何。答有漏长益多而非妙。无漏长益妙而非多二喻如前

生色界入有漏初静虑。乃至非想非非想处。长养诸根。增益大种。彼诸根大种与彼心心所法为几缘。答一增上。即彼心心所法与彼诸根大种为几缘。答一增上。生色界入无漏初静虑。乃至无所有处。长养诸根。增益大种。彼诸根大种与彼心心所法为几缘。答一增上。即彼心心所法与彼诸根大种为几缘。答一增上。此中不说所缘。及静虑无色。有漏无漏长益差别皆如前说有执受是何义。答此增语所显堕自体法。无执受是何义。答此增语所显非堕自体法。然多处说有执受言。谓此中说有执受是何义。谓堕自体法契经复说

  有执受苦蕴　　便引生众苦
  谓生苦老苦　　病苦及死苦

有经复说。无闻异生长夜修治有执受我余经复说。况于此身暂停住中有执受。品类足说。九处少分名有执受。识身论说。有执受蕴是慈所缘。问如是诸说义有何异。答此中说内身所摄五蕴名有执受。初契经说续众同分。有情数五蕴名有执受。次契经说无始时来身见事五蕴。名有执受。后契经说。内身所摄色蕴。名有执受。品类足说一刹那。九处少分名有执受。识身论说一刹那。五蕴少分名有执受。有说品类足。识身论说一刹那有情数。九处少分名有执受。有说。二论说一刹那有根所摄。九处少分名有执受。有说。二论说一刹那异熟所摄。九处少分名有执受。是名差别。问慈何故但缘色。答初修时缘色。成时缘五蕴。西方师说。有执受有四种。一身有执受。二相续有执受。三众同分有执受。四世俗施设有执受。身有执受者。谓初经所说有执受。苦蕴相续有执受者。如说我有根身相续执受。众同分有执受者。如说我有根身众同分执受。世俗施设有执受者。如说我执受如是重担。如是事业。此中说内身五蕴名有执受。此所不摄法是无执受问如前所说。有执受无执受其相云何。答有说。若与血肉筋骨相杂住者名有执受。与此相违名无执受。有说。于彼斫刺破裂时。生苦痛舍担名有执受。与此相违名无执受。尊者妙音作如是说。若法已生未灭有情数。是有对非所闻名有执受。已生者简未来。未灭者遮过去。有情数者遮非有情数。是有对者遮意处法处。非所闻者遮声处。与此相违名无执受。尊者左取作如是言。若法有方分。有情数系属身。是有对可牵可斥名有执受。有方分者遮过去未来。有情数者。遮非有情数。系属身者。遮身所出。谓发毛等。是有对者。遮意处法处。可牵可斥者。遮声处。与此相违名无执受

问十二处中。几有执受。几无执受。答若生欲界九处少分。是有执受。三处全。九处少分。是无执受。三处谓声处意处法处。若生色界七处少分。是有执受。三处全。七处少分。是无执受。三处如前说

问于此身中。三十六种诸不净物。几有执受。几无执受。答发毛爪齿根有执受。余无执受。皮胆脑血生有执受。朽无执受。骨肉筋脉心肺脾肾肝肠胃膜脂髓脑胲生熟二藏皆有执受。膏脓淡饮洟唾泪汗屎尿尘垢皆无执受顺取是何义。答此增语所显。有漏法非顺取是何义。答此增语所显无漏法。问何故有漏法名顺取。答有说。此法从取生。能生取故名顺取。有说。此法从取转。能转取故名顺取。有说。此法取所引能引取故名顺取。有说。此法取所长养。能长养取故名顺取。有说。此法取所增广。增广于取故名顺取。此增广言显滋蔓义。有说。此法系属于取。故名顺取。如属王者名为顺王。由内无我。若有问言。汝属于谁。答言属取。有说。诸取于此法中。将生已生。将执已执。将住已住。故名顺取。有说。诸取于此法中。将长养已长养故名顺取。有说。诸取于此法中。将增广已增广。故名顺取。有说。诸取于此坚着。如湿腻物尘垢随着。故名顺取。有说。诸取于此乐住。如鱼虾蟆乐处水中。故名顺取有说。此法为取舍宅安立足处。故名顺取。谓依此法。一切爱慢见疑嗔痴。诸缠垢等皆生长故。诸有漏法由同分取。得顺取名非异分取。谓欲界法由欲界取。色界法由色界取。无色界法由无色界取。初静虑地法。由初静虑地取。乃至非想非非想地法。由非想非非想地取。以有漏法界地无杂故。若依相续则有杂义。谓由自身取他身法得顺取名。由他身取自身法得顺取名。若不尔外法应非顺取。外无取故

顺结是何义。答此增语所显。有漏法非顺结是何义。答此增语所显无漏法。广释顺结非顺结义如前顺取。非顺取说

见处是何义。答此增语所显。有漏法非见处。是何义。答此增语所显无漏法。然见处声说有多处谓此中说。见处是何谓有漏法俱。迦捺陀契经复说。诸所有见诸所有见处。诸所有见缠。诸所有见等起。诸所有见损害。世尊一切悉知悉见。此中见者谓五见。见处者谓见所缘。见缠者谓见现行。见等起者谓见因。见损害者谓见灭。世尊一切悉知悉见者谓见对治。有作是说。见见处见缠谓苦谛。见等起谓集谛。见损害谓灭谛。世尊一切悉知悉见谓道谛。阿罗揭陀喻经。复说有六见处。谓诸所有色。若过去若未来若现在广说。乃至苾刍。应以正慧观彼一切非我我所。勿起我慢。诸所有受。乃至广说。诸所有想。乃至广说。诸有见闻觉知若得若求。意随寻伺。乃至广说。诸有此见。有我有有情有世间。常恒凝住无变易法正如是住。乃至广说。诸有此见。我应不有。我应非有。我当不有。我当非有。苾刍应以正慧观彼一切非我我所。勿起我慢。苾刍应于如是见处取处等。随观察无我我所。若能如是则于世间无所执受。乃至广说。此中诸所有色受想者。即色受想蕴。诸有此见有我有情。乃至广说。诸有此见我应不有。乃至广说者。谓行蕴诸有见闻觉知等。谓识蕴。问见闻觉知其义已具。若得若求意随寻伺。更何所显。答前广今略。前别今总。前开今合。前渐今顿。是谓所显防诸漏经复作是说。于六见处不正思惟。则于内身随起一执。谛故住故我有我谛故。住故我无我。我见我。我见无我无我见我。或此有我。有有情。有命者。有生者。有养者。有补特伽罗。有意生。有摩纳婆。或无曾当现。于彼彼处已作未作诸善恶业受异熟果。问如是四处说见处声有何差别。答有说。此中所说见处显一切有漏法。初经所说见处。总显五见。第二经所说见处。显见及离见法。第三经所说见处。显有身见边执见。有说。此及初二经所说见处。总显五取蕴。第三经所说见处。但显行蕴少分。有说。此及初二经。通显相应不相应法。第三经。唯显相应法。如相应不相应。有所依无所依。有行相无行相。有所缘无所缘。有警觉无警觉亦尔。有说此及初二经。通显有色无色法。第三经。唯显无色法。如有色无色。有见无见。有对无对亦尔。有说。此及初二经通显染不染法。第三经。唯显染法。如染不染。有罪无罪。有覆无覆。黑白。缠非缠。亦尔。有说。此及初二经。通显见修所断法。第三经。唯显见所断法。如见所断。修所断。无事有事。忍对治。智对治亦尔。有说。此及初二经。通显善不善无记法。第三经。唯显无记法。有说。此及初二经。通显有异熟无异熟法。第三经。唯显无异熟法

问诸有漏法。由何见故说名见处。答有说。由有身见边执见故说为见处。此二但缘自地境故。有说。由四见故谓除邪见。由此四种有漏缘故。如是说者。由五见故得见处名。问若尔灭道应名见处邪见境故。答见处有二。一所缘处。二随眠处。具此二义乃名见处。灭道虽是邪见所缘处。非随眠处故不名见处。有说。见处有二。一所缘处。二相应处。具此二义。立见处名。灭道虽是见所缘处。非相应处。由此不得名为见处若法是内彼法内处摄耶。乃至广说。问何故作此论。答彼作论者意欲尔故。随彼意欲而作论。但不违法相便不应责。有作是说。为止他宗显己义故。谓有异宗说内外法皆非实有。今遮彼意。明内外法皆是实有故作斯论。然内外法差别有三。一相续内外。谓在自身名为内。在他身及非有情数名为外。二处内外。谓心心所所依名内。所缘名外。三情非情内外。谓有情数法名内。非有情数法名外。此中但依相续。为论

若法是内。彼法内处摄耶。答应作四句。有法是内。非内处摄。如说于内受内法住。修法观。彼法是内者在自身故。非内处摄者。非心心所所依故。应知此中亦摄自身色等五境。有法内处摄非是内。如说于外身外心住。修心观。彼法内处摄者。是心心所所依故。非内者非在自身故。应知此中亦摄他身眼耳鼻舌。有法是内。亦内处摄。如说于内身内心住。修心观彼法是内者。在自身故。亦内处摄者。心心所所依故。应知此中亦摄自身眼耳鼻舌。有法非是内非内处摄。如说于外受外法住。修法观彼法非内者。非在自身故。非内处摄者。非心心所所依故。应知此中亦摄他身等色等五境若法是外彼法外处摄耶。答应作四句。有法是外非外处摄。如说于外身外心住。修心观彼法是外者。在他身故。非外处摄者。非唯心心所所缘故。应知此中亦摄他身眼耳鼻舌。有法外处摄非外。如说于内受内法住。修法观。彼法外处摄者。唯心心所所缘故。非外者。非在他身。及非有情数故。应知此中亦摄他身色等五境。有法是外亦外处摄。如说于外受外法住。修法观。彼法是外者。在他身及非有情数故。亦外处摄者。唯心心所所缘故。应知此中亦摄他身等色等五境。有法非外非外处摄。如说于内身内心住。修心观。彼法非外者。非在他身。及非有情数故。非外处摄者。非唯心心所所缘故。应知此中亦摄自身眼耳鼻舌

说一切有部发智大毗婆沙论卷第一百三十八阿毗达磨大毗婆沙论卷第一百三十九

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    大种蕴第五中执受纳息第四之三

有二受。谓身受心受。乃至广说。问何故作此论。答欲止他宗显己义故。谓或有说。受即是心分位差别。复有说言。唯有苦受无别乐舍。为遮彼意。显受非心有三差别故作斯论。问此中何故不问一受。答彼作论者意欲尔故。乃至广说。有说。此中显受差别展转相摄。非显受体故不问一。有二受谓身受心受。有三受。谓乐受苦受不苦不乐受。为二摄三三摄二耶。答互相摄随其事。谓身受摄三少分即此摄身受。心受亦尔是故说随其事。二受如前说。有四受谓三界系受。及不系受为二摄四四摄二耶。答互相摄随其事。谓身受摄二少分即此摄身受。二少分者。欲界系受。色界系受。心受摄二全二少分即此摄心受。二全者。无色界系受不系受。二少分者。欲界系受。色界系受。是故说随其事。二受如前说。有五受。谓乐根苦根喜根忧根舍根。为二摄五五摄二耶。答互相摄随其事。谓身受摄一全二少分即此摄身受。一全者苦根。二少分者乐根舍根。心受摄二全二少分。即此摄心受。二全者喜根忧根。二少分者。乐根舍根是故说随其事。二受如前说。有六受。谓眼触所生受。耳鼻舌身意触所生受。为二摄六六摄二耶。答互相摄随其事。谓身受摄五全即此摄身受。五全者。眼触所生受。乃至身触所生受。心受摄一全即此摄心受。一全者。谓意触所生受是故说随其事。二受如前说。有十八受。谓六喜意近行。六忧意近行。六舍意近行。为二摄十八十八摄二耶。答二摄十八非十八摄二。何所不摄。谓有漏乐根苦根。五识相应舍根。及无漏受。问何故有漏乐根非意近行耶。答欲界初静虑乐根唯在五识。及三识意近行唯在意识。故有漏乐根非意近行。问第三静虑有漏乐根。唯在意识何故不说。答初非分故后亦不立。有说。彼非全故。谓无全地有漏乐根。在意识者是故不立。有说。彼乐受虽与意识相应。而非捷利。意近行必捷利分别转故。又所对苦非近行故此亦不立。问何故苦根非意近行。答苦根唯五识相应。意近行者意识相应。有说。苦根不能分别。能分别者立意近行。有说。苦根取自相境。意近行者取自共相。复次苦根唯缘现在。意近行者通缘三世。复次苦根一往取境。意近行者数往而取。复次苦根不能思度。能思度者立意近行。问何缘五识相应舍根非意近行。答如苦根说。问何故无漏受非意近行。答以无漏受无意近行相故。又受若能增益诸有。摄受诸有。任持诸有。立意近行。无漏受损减违害破坏诸有故。不立意近行。又受乃至是身见事。乃至堕苦集谛立意近行。无漏受乃至非身见事。乃至不堕苦集谛。故不立意近行。二受如前说。有三十六受。谓六耽嗜依喜。六出离依喜。六耽嗜依忧。六出离依忧。六耽嗜依舍。六出离依舍。为二摄三十六三十六摄二耶。答二摄三十六非三十六摄二何所不摄。谓如前说。即有漏乐根苦根五识相应。舍根及无漏受。问答分别如前应知。二受如前说。有百八受。谓依三世各三十六。为二摄百八百八摄二耶。答二摄百八非百八摄二。何所不摄。谓如前说。即有漏乐根。乃至无漏受问答如前。三受四受。为三摄四四摄三耶。答互相摄随其事。谓乐受摄三少分即此摄乐受。三少分者。欲界系。色界系。不系受。苦受摄一少分即此摄苦受。一少分者。欲界系受。不苦不乐受。摄一全。三少分。即此摄不苦不乐受。一全者。无色界系受。三少分者。欲界系。色界系。不系受。是故说随其事。三受五受。为三摄五五摄三耶。答互相摄随其事。谓乐受摄二全。即此摄乐受。二全者。乐根喜根。苦受摄二全即此摄苦受。二全者。苦根忧根。不苦不乐受摄一全。即此摄不苦不乐受。一全者。舍根。是故说随其事。三受六受。为三摄六六摄三耶。答互相摄随其事。谓乐受摄六少分。即此摄乐受。苦受摄六少分即此摄苦受。不苦不乐受摄六少分。即此摄不苦不乐受。诸六少分者。眼触所生受。乃至意触所生受。是故说随其事。三受十八受。为三摄十八十八摄三耶。答三摄十八非十八摄三。何所不摄。谓有漏乐根苦根五识相应。舍根及无漏受。三受。三十六受。三受。百八受说亦尔。皆于三受不摄有漏乐根。乃至无漏受故。问答如上。四受五受。为四摄五五摄四耶。答互相摄随其事。谓欲界系受。摄二全三少分。即此摄欲界系受。二全者。苦根忧根。三少分者。乐根喜根舍根。色界系受摄三少分。即此摄色界系受。三少分者。乐根喜根舍根。无色界系受摄一少分。即此摄无色界系受。一少分者。舍根。不系受摄三少分。即此摄不系受。三少分者乐根喜根舍根。是故说随其事。四受六受。为四摄六六摄四耶。答互相摄随其事。谓欲界系受。摄二全四少分。即此摄欲界系受。二全者。鼻触所生受。舌触所生受。四少分者。眼触所生受。耳身意触所生受。色界系受摄四少分。即此摄色界系受。四少分者。眼触所生受。耳身意触所生受。无色界系受。摄一少分。即此摄无色界系受。不系受摄一少分。即此摄不系受。一少分者。意触所生受。是故说随其事。四受十八受。为四摄十八十八摄四耶。答四摄十八非十八摄四。何所不摄。谓有漏乐根苦根五识相应舍根。及无漏受。四受。三十六受。四受百八受。说亦尔。问答如上

五受六受。为五摄六六摄五耶。答互相摄随其事。谓乐根舍根摄六少分。即此摄乐根舍根。六少分者。眼触所生受。乃至意触所生受。苦根摄五少分。即此摄苦根。五少分者。眼触所生受。乃至身触所生受。忧根喜根摄一少分。即此摄忧根喜根一少分者。意触所生受。是故说随其事。五受十八受。五受。三十六受。五受。百八受。皆如前四受十八受等。说是故说随其所应。六受。十八受。六受。三十六受。六受百八受。当知亦尔。十八受。三十六受。为十八摄三十六三十六摄十八耶。答互相摄随其事。谓六喜意近行摄十二全。即此摄六喜意近行。十二全者。六耽嗜依喜。六出离依喜。六忧意近行摄十二全。即此摄六忧意近行。十二全者。六耽嗜依忧。六出离依忧。六舍意近行摄十二全。即此摄六舍意近行。十二全者。六耽嗜依舍。六出离依舍。是故说随其事。十八受。百八受。为十八摄百八百八摄十八耶。答互相摄随其事。谓六喜意近行。摄三十六全。即此摄六喜意近行。三十六全者。六耽嗜依喜。六出离依喜。此各三世。六忧意近行。摄三十六全。即此摄六忧意近行。三十六全者。六耽嗜依忧。六出离依忧。此各三世。六舍意近行摄三十六全。即此摄六舍意近行。三十六全者。六耽嗜依舍。六出离依舍。此各三世。是故说随其事。三十六受。百八受。为三十六摄百八百八摄三十六耶。答互相摄随其事。谓三十六各摄三全。即此摄三十六。三全者。即三十六各三世别。是故说随其事

问十八意近行云何建立。为以相应。为以自性。为以所缘。设尔何过。若以相应则唯有一。谓意识相应近行。若以自性则唯有三。谓喜近行。忧近行。舍近行。若以所缘则唯有六。谓色近行乃至法近行。何故说十八耶。答总以三缘故立十八。谓一意识相应近行。有喜忧舍三种自性。各缘色等六种境起故有十八。已说自性当说所以。何因缘故。名意近行。答此十八受意为近缘。行于境界。名意近行。又此为近缘令意于境数数行故名意近行。又依意故近境而行。名意近行。于境捷利乐数分别故名为行。如捷利女。数于其夫。起分别行。或取喜相。或取忧相。或取舍相。如是捷利受数于六境。起分别行。或行顺喜相。或行顺忧相。或行顺舍相。由此因缘名意近行。问此十八意近行。为但意地。亦五识耶。答唯在意地非五识。问若尔何故经说眼见色已。于顺喜色起喜近行。于顺忧色起忧近行。于顺舍色起舍近行。广说乃至意知法已。于顺喜法起喜近行。于顺忧法起忧近行。于顺舍法起舍近行耶。答由五识身所引起故。为迳路故作如是说。然意近行唯在意地。如不净观亦唯意地。然契经言眼见色已。随观不净具足安住。亦由眼识所引起故。为迳路故作如是说。又契经说。眼见色已乃至广说。故知意近行不在五识。问亦说意知法已。岂亦不在意识耶。答就胜说故无过。谓初喜等虽亦近行。然非明利。后重于境捷利分别。乃名近行。由此故言意知法已。又五识中无近行义如前已说问前际后际所有分别亦是意近行耶。契经何故不说。答是意近行但随明了故且说现在。由斯类显去来亦是。问诸有非见色已而分别色。乃至非触触已而分别触。此所生喜等是意近行耶。答是意近行。然契经中依明了义。说见色已。乃至广说。问诸有眼见色已。起声等分别。乃至意知法已。起色等分别。此所生喜等是意近行耶。答是意近行。然契经中依明了义。说见色已乃至广说。若作是说则觉所觉。根根义。行相所缘皆得明了。若不尔者便不分明

问此十八意近行。几杂缘。几不杂缘。答十五不杂缘。谓色意近行三。乃至触意近行三。余杂缘不杂缘。谓法意近行三缘内六处。及外法处。若总若别名不杂缘。若缘此七或总或别。及外五中或一或二。或乃至五名为杂缘。于外五中。若合缘二。或乃至五亦名杂缘。法意近行法名通故。以合缘故非前十五

问颇有色等决定顺喜。乃至决定顺舍耶。答依所缘故。无依相续故。有。谓有色等。或时可意。或时不可意。或于彼可意。于此不可意。于余非可意非不可意。有说。色等于亲品顺喜。于怨品顺忧。于中品顺舍

问此十八意近行。几续生几命终。答六。谓六舍意近行。所以者何。诸喜忧意近行胜作意转。命终续生无胜作意。问羯逻蓝等位中。各有几意近行。答皆容有十八。问几意近行能离染耶。答一谓杂缘。舍法意近行。能为无间道故。若解脱道通有杂缘。喜法意近行。加行胜进亦通所余

问此十八意近行。何界地有几。答欲界具一切。色界中初二静应。各有十二除六忧。第三第四静虑。各有六。复除六喜。无色界中空无边处近分。若许有别缘下者。则有四舍意近行。谓色声触法。若唯许总缘下者。则唯有一法舍意近行。如是说者。应说有四。四无色根本。及上三近分。各唯有一法舍意近行

问几意近行缘何界法。答欲界系十八中。六唯缘欲界系。谓缘香味喜忧舍近行。九通缘欲色界系。谓缘色声触喜忧舍近行。三通缘三界系及不系。谓缘法喜忧舍近行。初二静虑各十二中。四唯缘欲界系。谓缘香味喜舍近行。六通缘欲色界系。谓缘色声触喜舍近行。二通缘三界系及不系。谓缘法喜舍近行。第三第四静虑各有六中。二唯缘欲界系。谓缘香味舍近行。三通缘欲色界系。谓缘色声触舍近行。一通缘三界系及不系。谓缘法舍近行。空无边处近分。若许有四意近行者。三唯缘色界系。谓缘色声触舍意近行。一通缘色无色界系及不系。谓缘法舍意近行。若许唯有一意近行。谓法舍意近行者彼一通缘色无色界系及不系。四无色根本。及上三近分。所有各一法舍意近行。皆通缘无色界系及不系。问此诸意近行。谁成就几。答生欲界。若未得色界善心。彼成就欲界一切。初二静虑各八。第三第四静虑各四。无色界一。若得色界善心。未离欲界染。彼成就欲界一切。初静虑十。第二静虑八。第三第四静虑各四。无色界一。若已离欲界染。未得第二静虑善心。彼成就欲界初静虑各十二。第二静虑八。第三第四静虑各四。无色界一。若得第二静虑善心。未离初静虑染。彼成就欲界初静虑各十二。第二静虑十。第三第四静虑各四。无色界一。若已离初静虑染。未得第三静虑善心。彼成就欲界初二静虑各十二。第三第四静虑各四。无色界一。若得第三静虑善心。未得第四静虑善心。彼成就欲界初二静虑各十二。第三静虑六。第四静虑四。无色界一。若得第四静虑善心。未得空无边处善心。彼成就欲界初二静虑各十二。第三第四静虑各六。无色界一。若得空无边处善心。诸说彼地近分有四意近行者。彼成就欲界初二静虑各十二。第三第四静虑各六。空无边处四。上三无色各一。诸说彼地近分唯有一意近行者。彼成就四无色各一。余如前说。若生初静虑。若未得第二静虑善心。彼成就初静虑十二。第二静虑八。第三第四静虑各四。无色界一。成就欲界一。谓法舍意近行。即通果心俱。总缘色等为境起故。有说。彼成就三。谓色声法舍意近行。即通果心俱。此心若缘所起身表。即有缘色舍意近行。此心若缘所起语表。即有缘声舍意近行。此心若缘所变化事以总缘故。即有缘法舍意近行。有说。彼成就六。谓六舍意近行。即通果心俱。此心容有总别缘故。若得第二静虑善心。未离初静虑染。彼成就第二静虑十。余如前说。若已离初静虑染。未得第三静虑善心。彼成就第二静虑十二。余如前说。若得第三静虑善心。未得第四静虑善心。彼成就第三静虑六。余如前说。若得第四静虑善心。未得空无边处善心。彼成就第四静虑六。余如前说。若得空无边处善心。有说。彼成就空无边处四。上三无色各一。有说。彼成就四。无色各一。余如前说。生第二静虑。若未得第三静虑善心。彼成就第二静虑十二。第三第四静虑各四。无色界一。欲界如前说。成就初静虑一。谓法舍意近行。以总缘故。有说。成就三。谓色声法舍意近行。若缘所起身表。即有缘色舍意近行。若缘所起语表。即有缘声舍意近行。若缘所变化事。以总缘故。即有缘法舍意近行。有说。彼成就四。谓色声触法舍意近行。以生第二静虑。起初静虑三识身时。容有彼眷属。别缘色声触。初静虑地无覆无记意识现在前故。或通果心总别缘故。若得第三静虑善心。未得第四静虑善心。彼成就第三静虑六。余如前说。若得第四静虑善心。未得空无边处善心。彼成就第四静虑六。余如前说。若得空无边处善心。有说。彼成就空无边处四。上三无色各一。有说。彼成就四。无色各一。余如前说。生第三静虑。若未得第四静虑善心。彼成就第三静虑六。第四静虑四。无色界一。欲界初静虑如前说。成就第二静虑一。谓法舍意近行。即通果心俱。总缘色等为境起故。有说。彼成就三。谓色触法舍近行。即通果心俱。此心容有总别缘故。若得第四静虑善心等如前说。生第四静虑。成就多少应准前说。生无色界不成就下。成就自上亦应准前广说

问此诸意近行云何得。答离欲界染前八无间解脱道时。各得初静虑近分六。第九无间道时。得初静虑及彼眷属十二。得欲界一。谓法舍近行。有说。得三。谓色声法舍近行。有说。得六。谓六舍近行。离初静虑染。前八无间解脱道时。各得第二静虑近分六。第九无间道时得第三静虑及彼近分十二。欲界如前说。得初静虑一。谓法舍近行。有说。得三。谓色声法舍近行。有说。得四。谓色声触法舍近行。离第二静虑染。前八无间解脱道时。各得第三静虑近分六。第九无间道时。得第三静虑及彼近分六。欲界初静虑如前说。得第二静虑一。谓法舍近行。有说。得三。谓色触法舍近行。离第三静虑染。前八无间解脱道时。各得第四静虑近分六。第九无间道时得第四静虑及彼近分六。欲界初二静虑如前说。得第三静虑一。有说。得三。如第二静虑说。离第四静虑染。一切无间解脱道时各得空无边处四。有说。得一。离空无边处染。乃至离无所有处染。一切无间解脱道时皆唯得一。证阿罗汉果时得欲界初二静虑各十二。第三第四静虑各六。空无边处四。有说一。上三无色各一。已说离染得。受生得者。谓从上地没生下地时。得自地一切。及下地随所应如说得舍。及断亦应准前广说

此十八意近行。由耽嗜出离依有差别故。世尊说为三十六师句。此中顺染受名耽嗜依。顺善受名出离依。问何故不说无覆无记。答彼亦说在此二中故。谓无覆无记。受有顺染品。有顺善品。顺染品者耽嗜依摄。顺善品者出离依摄。问何故说此名师句耶。答此差别句能表大师。是师幖帜故名师句。由此诸句。唯佛大师能知能说无滞碍故。如契经言。若时众会恭敬信受如来不喜。若不敬受如来不忧。正念正知住清净舍。有说。此是外道师句。彼于此中有迷执故。有说。此应名为师迹。是诸邪师所游履故。有说。此应名为怨路。爱名为怨。依此而转。或诸烦恼皆名为怨。彼依此转故名怨路。有说此应名为刀道。游涉此者有伤害故。如说梵志第三意刀。若挥举时发恶招苦

问此三十六何界地有几。答欲界具一切。色界中初二静虑各有二十。第三第四静虑各有十。无色界中空无边处近分。若许有别缘则有五。若说唯总缘则但有二。如是说者。应说有五。四无色根本及上三近分各唯有二。问此三十六。何界地几缘何界地。答欲界三十六中。十二唯缘欲界系。十八通缘欲色界系。六通缘三界系及不系。初二静虑各二十中。四唯缘欲界系。六唯缘色界系。六通缘欲色界系。二通缘色无色界系及不系。二通缘三界系及不系。第三第四静虑各十中。二唯缘欲界系。三唯缘色界系。三通缘欲色界系。一通缘色无色界系。及不系。一通缘三界系及不系。空无边处近分。若说有五者。三唯缘色界系。一通缘无色界系及不系。一通缘色无色界系及不系。若说有二者。一通缘无色界系及不系。一通缘色无色界系及不系。四无色根本。及上三近分。各有二中二俱通缘无色界系及不系

问此三十六。谁成就几。答生欲界若断善根。彼成就欲界十八。初二静虑各八。后二静虑各四。四无色各一。若不断善根。未得色界善心。彼成就欲界三十六。上地如前说。若得初静虑善心。未离欲界染。彼成就欲界三十六。初静虑十四。上地如前说。若已离欲界染。未得第二静虑善心。彼成就欲界十二。初静虑二十。上地如前说。若得第二静虑善心。未离初静虑染。彼成就欲界十二。初静虑二十。第二静虑十四。上地如前说。若已离初静虑染。未得第三静虑善心。彼成就欲界初静虑各十二。第二静虑二十。上地如前说。若得第三静虑善心。未离第二静虑染。彼成就欲界初静虑各十二。第二静虑二十。第三静虑十。上地如前说。若已离第二静虑染。未得第四静虑善心。彼成就欲界初二静虑各十二。第三静虑十。上地如前说。若得第四静虑善心。未离第三静虑染。彼成就欲界初二静虑各十二。后二静虑各十四。无色各一。若已离第三静虑染。未得空无边处善心。彼成就欲界初二静虑各十二。第三静虑六。第四静虑十四。无色各一。若得空无边处善心。未离第四静虑染。彼成就空无边处五。有说二。上三无色各一。下地如前说。若已离第四静虑染。未得识无边处善心。彼成就第四静虑六。空无边处五。有说二。上三无色各一。下地如前说。若得识无边处善心。未离空无边处染。彼成就识无边处二。上二无色各一。下地如前说。若已离空无边处染。未得无所有处善心。彼成就空无边处四。有说一。识无边处二。上二无色各一。下地如前说。若得无所有处善心。未离识无边处染。彼成就无所有处二。有顶一。下地如前说。若已离识无边处染。未得有顶善心。彼成就识无边处一。无所有处二。有顶一。下地如前说。若得有顶善心。未离无所有处染。彼成就有顶二。下地如前说。若已离无所有处染。未离有顶染。彼成就无所有处一。有顶二。下地如前说。若已离有顶染。彼成就有顶一。下地如前说。生初静虑。若未得第二静虑善心。彼成就初静虑二十。第二静虑八。后二静虑各四。四无色各一。成就欲界一。谓法出离依舍。有说成就三。谓色声法出离依舍。有说成就六。谓六出离依舍。若得第二静虑善心。未离初静虑染。彼成就第二静虑十四。余如前说。若已离初静虑染。未得第三静虑善心。彼成就初静虑十二。第二静虑二十。余如前说。如是乃至离有顶染。广说如前。如生初静虑如是生第二静虑等准前广说。如理应知。得舍断三亦准前说。如契经说。以六出离依喜。为仗为依为建立故。于六耽嗜依喜。能弃能舍及能变吐。如是便断。以六出离依忧。为仗为依为建立故于六耽嗜依忧。能弃能舍及能变吐。如是便断。以六出离依舍。为仗为依为建立故。于六耽嗜依舍。能弃能舍及能变吐。如是便断。当知此说暂断名断。复言以六出离依喜。为仗为依为建立故。于六出离忧。能弃能舍及能变吐。如是便断。当知此说离欲界染。复言以六出离依舍。为仗为依为建立故。于六出离依喜。能弃能舍及能变吐。如是便断。当知此说离第二静虑染。复言以一种性所依舍。为仗为依为建立故。于种种性所依舍。能弃能舍及能变吐。如是便断。当知此说离第四静虑染。复言以非彼性类。为仗为依为建立故。于一种性所依舍。能弃能舍及能变吐。如是便断。当知此说离非想非非想处染。非彼性类者。谓无漏道要由此道。能离非想非非想处染故

说一切有部发智大毗婆沙论卷第一百三十九阿毗达磨大毗婆沙论卷第一百四十

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    大种蕴第五中执受纳息第四之四

以无间道证预流果。修彼道时四念住。几现在修。几未来修。乃至广说。问何故作此论。答欲止他宗显己义故。谓或有说。无未来修。勿有未作而已得故。为遮彼执显有未来修。彼虽未起已起彼类故。或复有说二心俱行。以见闻等俱时有故。为遮彼执显无二心俱行。刹那迅转非俱似俱故。或复有说。四正断等非一时有用因异故。为遮彼执显此同时得有四种体无别故。或复有说。信等唯无漏。经说异生无信等根故。为遮彼执明信等通有漏。契经但说无漏根故。或复有说。根力体异。由彼胜劣位差别故。为遮彼执显位虽殊而根力用一体有故。或复有说。觉支通有漏。说不净俱修念觉支故。为遮彼执显觉支唯无漏。经说有俱非同时俱故。或复有说。近分地有喜。经说依喜断出离忧故。为遮彼执明近分无喜。经说已断当断名断故。或复有说。正语业命不俱时有。一刹那中无二身语故。为遮彼执。显三戒俱三根所起。一时可得故。或复有说。预流一来亦得静虑。为遮彼执显俱不得未离欲故。或复有说。忍即是智。为遮彼执显忍非智。以于谛境未审决故。或复有说。异生不断惑未见谛故。为遮彼执明异生亦断惑见粗等故。或复有说。圣者不以世俗道断惑。为遮彼执。显圣自在随用何道故。或复有说。上地亦有正思惟支。为遮彼执显上地无彼支以无寻故。或复有执。无色亦有无漏戒支。为遮彼执。显彼无戒以无色故。或复有说。三三摩地义别体同。为遮彼执。明体亦异行相别故。为止此等种种异宗显正所明。故作斯论

以无间道证预流果。修彼道时四念住几现在修。几未来修。四正断。四神足。五根。五力。七觉支。八道支。四静虑。四无量。四无色。八解脱。八胜处。十遍处。八智三等持。几现在修。几未来修。答念住现在一。未来四。正断神足现在未来四。根力现在未来五。觉支现在未来六。道支现在未来八。无静虑。无无量。无无色。无解脱。无胜处。无遍处。无智等持。现在未来一。念住现在一。未来四者。此则遮二心俱行。及无未来修执。若有二心俱时行者。则应现在修四念住。然四念住必不俱行。一心相应无四慧故。不可此四一体建立行相所缘俱有异故。非一相续多心并起。勿由彼成多有情故。若未来世无修义者。则所修善无增广义。起多加行则为唐捐。设功用多所获少故。又初成佛时应未具足一切功德。勿有此等过失故。有未来修。未来世宽故具修四。现修势用能引当来种类法。得令现前故。现在一者。谓杂缘法念住。见道谛故。正断神足现在未来四者。此则遮说正断神足非俱时有一。正勤体有四。所作如灯。一时有四作用。一三摩地由四因生故。从所因立四名称。未来修者。亦体一义分故。现在未来各言修四根力。现在未来五者。此则遮根力体异。及说五种次第生执。虽根力位异而自体无别。即一信等有生破二用立根力名互不相违。相资俱起故。此五种非次第生。觉支现在未来六者。此则遮说近分有喜。此处未得上根本地。未离下怖。不生喜故。经说依喜断出离忧者。依加行道说。非无间道故不相违。此依未至无喜故六。道支现在未来八者。此则止正语业命不俱者意。无贪嗔痴所发无表。各有七种俱时起故。无静虑者。此则止预流一来亦得静虑者意。此未离欲入见道故。已离欲者非二向故。无无量者。此遮无量亦通无漏。及见道中修无量执。此缘有情故。非无漏见道迅速。又初得故不能兼修。又复未得根本地故。不修无量。无无色者。此遮无色有见道执。无色中无遍缘智故必无见道。又此未得无色定故。无解脱无胜处无遍处者。此遮前三解脱等。亦通无漏者执。十六行相所不摄故不名无漏。又尔时未得根本地故。彼皆不修无智者。此则遮说忍即是智。忍于谛境未如实审决故不名智。又于此位自分修故。不修未来诸智。是故言无等持。现在未来一者。此则遮说三三摩地义别体同。以三等持行相异故。体亦有别。一者。谓无愿等持道类忍时。唯修此故。虽八忍皆无间道。依证果位说道类忍非余

以无间道证一来果。修彼道时四念住。乃至三等持。几现在修。几未来修。答若倍离欲染。入正性离生修彼道时。念住现在一。未来四。正断神足。现在未来四。根力现在未来五。觉支现在未来六。道支现在未来八。无静虑。无无量。无无色。无解脱。无胜处。无遍处。无智等持。现在未来一。若倍离欲染入正性离生者。此则遮说异生不断惑。然异生类能以粗等六种行相。离欲界染乃至无所有处染。若先已离六品欲染。名倍离欲。倍后三故。所余文句皆如前释

若从预流果以世俗道证一来果。修彼道时。念住现在一。未来四。正断神足现在未来四。根力现在未来五。觉支现在无。未来六。道支现在无。未来八。无静虑。无无量。无无色。无解脱。无胜处。无遍处智。现在一。未来七。等持现在无。未来三。以世俗道。证一来果者。此则遮说圣者不以世俗道断惑。圣于二道。俱成就故。随欲现前。即以彼断。念住现在。一者。谓杂缘法念住。有漏离染无间道。必总缘故。根力现在未来五者。此则遮说信等唯无漏。说观信等为集等故。佛观三根。方说法故。有漏亦有根力用故。觉支现在无者。此则遮说觉支通有漏有漏不能如实觉故。说不净观俱修念觉支者。依展转因有俱而说。未来六者。圣者起有漏道时。亦兼修无漏故。道支现在无者。虽道支通有漏。然觉支后说故亦唯无漏。阿毗达磨有如此相。无无量等者。未至定中无彼根本地诸善法故。智现在一者。谓世俗智未来七者。除他心智。以无间道相违故。又未得故。此中但依八智作论。除尽无生。以位局故。等持现在无者。三等持虽通有漏。然此中说无漏者。以无漏是解脱门故。此文说第六无间道。以彼能证一来果故。余如前说。若从预流果以无漏道证一来果修彼道时。念住现在一。未来四。正断神足现在未来四。根力现在未来五。觉支现在未来六。道支现在未来八。无静虑。无无量。无无色。无解脱。无胜处。无遍处智。现在二。未来七。等持现在一。未来三。念住现在一者。谓法念住。或杂不杂以四法智随起一故。智现在二者。谓苦智法智二。或乃至道智法智二。等持现在一者。谓三中随一。余如前说

以无间道证不还果修彼道时。四念住乃至三等持。几现在修。几未来修。答若已离欲染。依未至定入正性离生修。彼道时。念住现在一。未来四。正断神足现在未来四。根力现在未来五。觉支现在未来六。道支现在未来八。无静虑。无无量。无无色。无解脱。无胜处。无遍处。无智等持。现在未来一。无静虑者。见道依下不修上故。余如前说

若依初静虑入正性离生。修彼道时。念住现在一。未来四。正断神足现在未来四。根力现在未来五。觉支现在未来七。道支现在未来八。静虑现在未来一。无无量。无无色。无解脱。无胜处。无遍处。无智等持。现在未来一。释此文句准前应知

若依静虑中间。入正性离生修彼道时。念住现在一。未来四。正断神足现在未来四。根力现在未来五。觉支现在六。未来七。道支现在七。未来八静虑现在无。未来一。无无量。无无色。无解脱。无胜处。无遍处。无智等持。现在未来一。觉支现在六者。静虑中间无喜根故。依上修下故。未来七。道支现在七者。此遮上地有寻者执此上心细故无有寻。余如前说。若依第二静虑。入正性离生修彼道时。念住现在一。未来四。正断神足现在未来四。根力现在未来五。觉支现在未来七。道支现在七。未来八。静虑现在一。未来二。无无量。无无色。无解脱。无胜处。无遍处。无智等持。现在未来一。释此文句准前应知

若依第三静虑。入正性离生修彼道时。念住现在一。未来四。正断神足现在未来四。根力现在未来五。觉支现在六。未来七。道支现在七。未来八。静虑现在一。未来三。无无量。无无色。无解脱。无胜处。无遍处。无智等持。现在未来一。释此如前

若依第四静虑入正性离生修彼道时。念住现在一。未来四。正断神足现在未来四。根力现在未来五。觉支现在六。未来七。道支现在七。未来八。静虑现在一。未来四。无无量。无无色。无解脱。无胜处。无遍处。无智等持。现在未来一。此随所应如前释

若从一来果以世俗道证不还果。修彼道时念住现在一。未来四。正断神足现在未来四。根力现在未来五。觉支现在无。未来六。道支现在无。未来八。无静虑。无无量。无无色。无解脱。无胜处。无遍处智。现在一。未来七。等持现在无。未来三。释此文句如前应知。若从一来果以无漏道证不还果修彼道时。念住现在一。未来四。正断神足现在未来四。根力现在未来五。觉支现在未来六。道支现在未来八。无静虑。无无量。无无色。无解脱。无胜处。无遍处智。现在二。未来七。等持现在一。未来三。皆如前释。以无间道证神境智通。修彼道时。四念住乃至三等持。几现在修。几未来修。答若诸异生。依初静虑修彼道时。念住现在一。未来四。正断神足现在未来四。根力现在未来五。无觉支。无道支。静虑。现在未来一。无量现在无。未来四。无无色。解脱。现在无。未来二。胜处现在无。未来四。无遍处智。现在未来一。无等持。此中念住现在一者。谓身念住。神境智通。但缘色故。彼无间道亦但缘色。问如金刚喻定缘有顶四蕴。或三界灭道漏尽通。缘有顶四蕴。如是则所缘。或异。此中何故神境智通与无间道。必同缘色。答金刚喻定与最初尽无生智。俱是观谛断烦恼道。但求离染非于所缘。有所转作故。所缘或异。神境通等皆是随事作意。俱欲于境变现了知故。所缘必同。无量现在无。未来四者。根本地中有漏功德由同地故。随应皆修解脱。现在无。未来二者。谓初二解脱彼在初二静虑系故。胜处现在无。未来四者。谓初四胜处。亦彼系故。智现在未来一。谓世俗智。问何故无他心智。答无间道中不修彼故。是容睱道之所修故。余随所应如前说

若诸圣者依初静虑修彼道时。念住现在一。未来四。正断神足现在未来四。根力现在未来五。觉支现在无。未来七。道支现在无。未来八。静虑现在未来一。无量现在无。未来四。无无色解脱。现在无。未来二。胜处现在无。未来四。无遍处智。现在一。未来七。等持现在无。未来三。静虑现在未来一者。问圣者已离第三静虑染得第四静虑。依初静虑修神境通。无间道中应言静虑未来修四。无漏通依上下修故何故但说未来一耶。答有说。应言未来修四而不说者当知有余。有说。此中依渐次者说。谓从具缚入正性离生。乃至得不还果已。依初静虑修神境通无间道中。未来修一。不修上者以未得故。有说。假使离第三静虑染。依初静虑修神境通。亦但修一不修上地故。问岂不依初静虑断上地染。及无学者。修练根时亦修上地所有功德耶。宁说依下不能修上。答断上地惑能修上者。以彼地道所治同故。法断彼惑能治必修。无学练根如得彼果。是故此皆依下修上。诸通不尔故不修上。如见道中唯修自下。此例非理。见道是初得种性未自在故。唯自分修。修道是已得种性。于彼自在宁不兼修。然五通是胜功德。修加行时必极作意。若诸静虑已得自在何理为障而不兼修。由此应知前说者好。无无色等准此应知。余如前说

若诸异生依第二静虑修彼道时。念住现在一。未来四。正断神足现在未来四。根力现在未来五。无觉支。无道支。静虑。现在。未来一无量。现在无。未来四。无无色。解脱。现在无。未来二。胜处现在无。未来四。无遍处智。现在未来一。无等持。静虑。现在未来一者。彼已得下地。而不修者。有漏功德唯自地修堕界地故。余如前说

若诸圣者。依第二静虑修彼道时。念住现在一。未来四。正断神足现在未来四。根力现在未来五。觉支现在无。未来七。道支现在无。未来八。静虑现在一。未来二。无量现在无。未来四。无无色。解脱。现在无。未来二。胜处现在无。未来四。无遍处智。现在一。未来七。等持现在无。未来三。静虑未来二者。谓初二静虑初唯无漏。余如前说

若诸异生依第三静虑修彼道时。念住现在一。未来四。正断神足现在未来四。根力现在未来五。无觉支。无道支。静虑。现在未来一。无量现在无。未来三。无无色。无解脱。无胜处。无遍处智。现在未来一。无等持。无量未来三者。除喜无量。无解脱等者。第三静虑乐所迷故。无解脱等。厌行功德净解脱等。虽作欣行相。由地有灾横故亦不得。有余如前说

若诸圣者。依第三静虑修彼道时。念住现在一。未来四。正断神足现在未来四。根力现在未来五。觉支现在无。未来七。道支现在无。未来八。静虑现在一。未来三。无量现在无。未来三。无无色。无解脱。无胜处。无遍处智。现在一。未来七。等持现在无。未来三。广释如前。若诸异生。依第四静虑修彼道时。念住现在一。未来四。正断神足现在未来四。根力现在未来五。无觉支。无道支。静虑。现在未来一。无量现在无。未来三。无无色解脱。现在无。未来一。胜处现在无。未来四。遍处现在无。未来八。智现在未来一。无等持。解脱。未来一者。谓净解脱身作证具足住。胜处未来四者。谓后四胜处。遍处。未来八者。谓前八遍处。由此地中离八灾横故。有此等清净功德。余如前说。若诸圣者。依第四静虑修彼道时。念住现在一。未来四。正断神足现在未来四。根力现在未来五。觉支现在无未来七。道支现在无。未来八。静虑现在一。未来四。无量现在无。未来三。无无色。解脱。现在无。未来一。胜处现在无。未来四。遍处现在无。未来八。智现在一。未来七。等持现在无。未来三。广释如前

以无间道。证天耳智通。他心智通。宿住随念智通。死生智通。修彼道时。四念住乃至三等持。几现在修。几未来修。答如神境智通。应随相说。由此五种皆依四静虑。异生圣者俱能起故。然修天耳死生智通。无间道时。现在念住如神境智通说。以俱缘色作身念住故。修他心智通。无间道时。现在唯起心念住。修宿住随念智通无间道时。现在唯起法念住。余随所应皆如前说

以无间道。证漏尽智通修彼道时。四念住。乃至三等持。几现在修。几未来修。答若依未至定。证阿罗汉果修彼道时。念住现在一。未来四。正断神足现在未来四。根力现在未来五。觉支现在六。未来七。道支现在未来八。静虑现在无。未来四。无无量。无色。现在无。未来三。解脱现在无。未来三。无胜处。无遍处智。现在二。未来六。等持现在一。未来三。念住现在一者。谓法念住。或杂不杂。四类智。二法智。随一现前故。静虑未来四者。断有顶惑。通修上下能治道故。无无量等者。尔时不修有漏法故。有漏不能治有顶故。无色。解脱。未来三者。谓前三无色。及即彼三解脱通无漏故。智现在二者。谓灭智法智二。或道智法智二。或苦智类智二。乃至或道智类智二。未来六者。除世俗智。及他心智。彼有漏故。与无间道相违故。等持现在一者。谓空无相无愿随一现前。金刚喻定与六智相应故。此中但说断有顶惑第九无间道。彼能证得漏尽智通故。余如前说

若依初静虑。证阿罗汉果修彼道时。念住现在一。未来四。正断神足现在未来四。根力现在未来五。觉支现在未来七。道支现在未来八。静虑现在一。未来四。无无量。无色。现在无。未来三。解脱现在无。未来三。无胜处。无遍处智。现在二。未来六。等持现在一。未来三。若依静虑中间。证阿罗汉果修彼道时。念住现在一。未来四。正断神足。现在未来四。根力现在未来五。觉支现在六。未来七。道支现在七。未来八。静虑现在无。未来四。无无量。无色。现在无。未来三。解脱现在无。未来三。无胜处。无遍处智。现在二。未来六。等持现在一。未来三。若依第二静虑。证阿罗汉果修彼道时。念住现在一。未来四。正断神足现在未来四。根力现在未来五。觉支现在未来七。道支现在七。未来八。静虑现在一。未来四。无无量。无色。现在无。未来三。解脱现在无。未来三。无胜处。无遍处智。现在二。未来六。等持现在一。未来三。若依第三第四静虑。证阿罗汉果修彼道时。念住现在一。未来四。正断神足现在未来四。根力现在未来五。觉支。现在六。未来七。道支现在七。未来八。静虑现在一。未来四。无无量。无色。现在无。未来三。解脱现在无。未来三。无胜处。无遍处智。现在二。未来六。等持现在一。未来三。此随所应如前释

若依无色定。证阿罗汉果修彼道时。念住现在一。未来四。正断神足现在未来四。根力现在未来五。觉支现在六。未来七。道支现在四。未来八静虑现在无。未来四。无无量。无色。现在一。未来三。解脱现在一。未来三。无胜处。无遍处智。现在二。未来六。等持现在一。未来三。依无色定者。谓依空无边处。或依识无边处。或依无所有处。由此三地皆有无漏道。能离非想非非想处染故。非想非非想处。定力昧劣非无漏道所依止故。此中不说道支。现在四者。此则遮说无色界有无漏戒。及说上地有正思惟者意。以无所依四大种故。及上地心渐微细故。问如无无漏大种。而有无漏戒。如是虽无彼地大种。而有彼地戒。斯有何失。答无漏戒不堕界地。随所依身大种所造。由此虽无无漏大种。而有所造无漏戒。有漏戒必堕界地。唯为自地大种所造。彼无大种故戒亦无。问若无漏戒随所依身大种所造者生欲色界入无漏无色定时应起彼定俱无漏戒有所依身大种故。答虽无漏戒随所依身大种所造。然随何地要有大种造。有漏戒方随彼类起。无漏戒无色中无有大种造。有漏戒故无漏戒于彼亦无。依彼所有发无漏故。问何故戒体唯色。答遮恶色起故。又是身语业性故。身语二业色为体故。问何故意业非戒。答不能亲遮恶戒故。问何故恶戒非意业。答未离欲者。皆成就不善意业。彼岂悉名犯戒或不律仪耶。是故恶戒非意业。又善意业若是善戒。则应一切不断善者悉名住律仪。彼皆成就善意业故。若许尔者。便一有情名住律仪。亦名住不律仪者。则应无有三种差别。如是则与圣教相违故。善恶戒俱非意业。又世共许防禁身语说名戒故。意业非戒。应知意业是发戒因。不可戒因即名为戒。勿令因果有杂乱失。是故无色道支唯四。未来通修下地无漏故。具有八无色解脱。现在一者。谓前所依三地随一。余如前释

说一切有部发智大毗婆沙论卷第一百四十阿毗达磨大毗婆沙论卷第一百四十一

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    大种蕴第五中执受纳息第四之五

四念住者。一身念住。二受念住。三心念住。四法念住。然此念住总说唯一。谓心所中一慧自性。根中慧根。力中慧力。觉支中择法觉支。道支中正见。或分为二。谓有漏无漏。或分为三。谓下中上。或分为四。谓三界系及不系。或分为五。谓三界系及学无学。乃至若以相续刹那差别分别则有无量。问世尊何故于此义中。开少合多唯说四种。答佛依正慧行相所缘。粗细不同建立四种。问若尔何故契经中说观内外俱十二种别。答不过四故但说四种。如七叶树七生预流。彼亦如是。问此体是慧何故世尊说为念住。答慧由念力得住所缘故名念住。或此慧力令念住境故名念住。此二于境展转相资胜于余法故说念住。广辩念住如余处说

四正断者。一于已生恶不善法为令断故。生欲发勤摄心持心。二于未生恶不善法为不生故。余说如前。三于未生善法为令生故。余说如前。四于已生善法为令安住不忘倍修增广故。余说如前。然此正断或总为一。谓心所中一精进体。根中精进根。力中精进力。觉支中精进觉支道支中正精进。或分为二。谓有漏无漏。或分为三。谓下中上。或分为四。谓三界系及不系。或分为五。谓三界系及学无学。乃至若以相续刹那差别分别则有无量。问世尊何故于此义中开少合多唯说四种。答一精进体于刹那中。作用不同建立四种。谓于已生未生恶法断及不生故。复于未生已生善法生及增广故。如灯一念四用差别。谓烧炷尽油热器破闇彼亦如是。问法蕴等论说。断已生恶不善法。即具四种。谓于已生恶不善法为令断故。生欲发勤摄持心者。彼断已生恶不善位。亦能令彼恶不善法未生不生。复令善法未生得生已生住等。乃至说修已生善法令安住等亦具有四。谓于已生善法为令安住不忘倍修增广故。生欲发勤摄持心者。彼修已生诸善法位。亦能令彼恶不善法已生者断。未生不生。复令善法未生者生。如是便成十六正断。何故于此但说四耶。答依修行者差别意乐。至加行位故作是说。谓彼先时起一意乐。至加行位便具四种。如是依彼四种意乐。至加行位故作是说。然加行时皆唯有四。不过四故但说四种。如由意乐加行故说。如是由趣入加行故说。由依处加行故说。由胜解加行故说应知亦尔。已说自性当说所以。问此四何缘说为正断。答由此四种能正断故。问前二可尔。后二云何。答以初为名故无有失。或此四种皆有断义。谓前二断烦恼障。后二断所知障。修善法时断法知故。暂断永断俱名断故。有处说此名为正胜。无倒策发成胜事故

问恶与不善何差别。答恶谓有覆无记。不善谓诸不善。有作是说。恶谓色无色界。及欲界少分染法。不善谓欲界多分染法。有说。恶谓欲界身边二见品。不善谓欲界诸余烦恼等。问何故恶不善法已生者说令断。未生者说令不生。答已生者于自相续。已有作用故说令断。未生者于自相续。未有作用故说令不生。有说。已生者于自相续。已障圣道故说令断。未生者于自相续。未障圣道故说令不生。有说。已生者于自相续。已取果与果故说令断。未生者于自相续。未取果与果故说令不生。有说。已生者于自相续。已取等流果异熟果故说令断。未生者于自相续。未取等流果异熟果故说令不生。有说。已生者于自相续。已酬同类遍行因故说令断。未生者于自相续。未酬同类遍行因故说令不生。有说。已生者于自相续。已烧已恼故说令断。未生者于自相续未烧未恼故说令不生。有说。已生者于自相续。已作讥呵。已作垢染。已作胶泞。已堕恶意故说令断。未生者于自相续。未作讥呵。未作垢染。未作胶泞。未堕恶意故说令不生。问所修诸善随尔所生即尔所灭。无有生已过一刹那有停住义。如何乃言于已生善法为令安住不忘倍修增广耶。答应知此中说二分善法。谓顺住分。顺胜进分。令安住不忘者说顺住分。令倍修增广者说顺胜进分。俱依相续展转胜进。说安住等。故无有失。有说。此中说三品善法。谓下中上令安住不忘者。说依下品善根转至中品。令倍修增广者。说依中品善根转至上品。虽一刹那生已即灭。而依相续故作是说

此正断欲界有四。色无色界亦尔。问欲界有恶不善法可说有四。云何上界亦说四耶。答彼虽过患不具。而具有彼功德。有说。彼虽无所治而有能治。问未至地可尔上地云何。答有多种对治。谓舍对治。断对治。持对治。远分对治。厌坏对治。上地虽无舍及断对治。而有余对治。问静虑可尔无色云何。答无色虽无坏对治。而有持及远分对治

此正断学无学位各具四种。问学位可尔有恶不善法故。无学云何。答彼虽无过患而有功德。有说。彼虽无所治而有能治。谓多种对治如前说。彼虽无舍及断而有所余问缘涅槃精进何正断摄。有说。初正断摄以断即涅槃故。有说。第二正断摄以涅槃是不生故。有说。第三正断摄。缘涅槃时善法生故。有说。第四正断摄。缘涅槃时善法增故。如是说者。四正断摄。缘涅槃时作四事故。谓缘诸法择灭性时。即令一切恶不善法已生者断。未生不生及令一切世出世善。未生者生已生增广

四神足者。一欲三摩地断行成就神足。二勤三摩地断行成就神足。三心三摩地断行成就神足。四观三摩地断行成就神足。问云何名神云何名足。有作是说。三摩地名神。欲等四名足。由四法所摄受令三摩地转故。问等持俱有相应法多。何故此四独名神足。答此于等持随顺胜故。谓于俱有相应法中。资益等持此四为胜。复有说者。三摩地是神亦足。欲等四唯足非神。如择法是觉亦支。余六唯支非觉。正见是道亦支。余七唯支非道。离非时食是斋亦支。余七唯支非斋。彼亦如是。问若三摩地是神亦足或应立一。或应立五。何故说四耶。答唯三摩地立为神足。从四因生故说为四。谓加行位。或由欲力引发等持令其现起。广说乃至或由观力引令现起。由加行位四法随增。令等持起故得定位。于一等持建立四种。已说自性当说所以。问此四何缘说为神足。答者所思求诸所欲愿。一切如意故名为神。引发于神故名神足。然此神用略有二种。一世俗所欣。二圣者所乐。若分一为多。合多成一。此等名为世俗所欣。若于世间诸可意事不住顺想。于诸世间不可意事不住违想。于诸可意不可意事。安住于舍正念正知。此等名为贤圣所乐。复有三种神用。一运身二胜解三意势。运身神用者。谓举身凌虚犹若飞鸟。亦如壁上所画飞仙。胜解神用者。谓于远作近解由此力故。或住此洲手扪日月。或屈伸臂顷至色究竟天。意势神用者。谓眼识至色顶。或上至色究竟天。或傍越无边世界。问此三神用谁成就几。有说。声闻成一。谓运身。独觉成二除意势。唯佛世尊具成三种。有说。异生成一。谓运身。二乘成二除意势。然声闻运身所显。独觉意解所显。佛具成三意势所显。或复五种神用。一业。二异熟。三变现。四具德。五发心。业神用者。谓中有等。异熟神用者。谓飞禽等。变现神用者。谓依静虑。分一为多。合多为一等。具德神用者。谓四神足。发心神用者。谓天龙等。此中天者谓欲界天。于所说五神用中。此中说具德神用。如契经说苾刍当知。欲三摩地断行成就修于神足。依止离依止无染依止灭。回向于舍勤三摩地心三摩地。观三摩地说亦如是。此中说何名为离等。有作是说。是三摩地彼说。若缘三摩地为境修于神足。由二缘故名依离等。谓意乐故及所缘故。若缘余法为境修于神足。但由一缘名依离等。谓意乐故非所缘故。有余师说。是寂灭涅槃。彼说若缘寂灭涅槃为境修于神足。由二缘故名为离等。谓意乐故及所缘故。若缘余法为境修于神足。但由一缘名依离等。谓意乐故非所缘故。复有说者。是三摩地及寂灭涅槃。彼说若缘此二为境修于神足。由二缘故名为离等。谓意乐故及所缘故。若缘余法为境修于神足。但由一缘名为离等。谓意乐故非所缘故。应知此中依止离者。谓初静虑。依止无染者。谓第二静虑。依止灭者。谓第三静虑。回向于舍者。谓第四静虑

如契经说苾刍当知。何等名寿。谓四神足。问何故神足说名为寿。答由此为依寿不断故。谓在定位寿必无断。有说。依此离寿灾故。谓在定位远离寿灾。有说。依此寿自在故。如契经说。若有苾刍苾刍尼等。于四神足若习若修若多修习。彼若希求住寿一劫或一劫余。随意自在。由此故说神足为寿

如契经说。有一梵志。来诣具寿阿难陀所。种种爱语欢喜问讯。已退坐一面。问阿难曰。何故于沙门乔答摩所勤修梵行。问何故梵志作是问耶。答彼是阿难昔时朋友。委知尊者是爱行人。于五欲中先恒耽着故。来试验为求爱断而修梵行。为求胜欲修梵行耶故作斯问。阿难答言。我为爱断故在佛所勤修梵行。问勤修梵行。断七随眠。何故但言我为爱断。答尊者庆喜。亦知梵志是爱行人耽着诸欲。为汲引故。意云若汝为爱所缠欲求离者。宜舍家法来世尊所。随我勤修清净梵行。故方便答我为爱断。婆罗门曰。沙门乔答摩实有道迹能断爱不。阿难陀曰。实有勿疑。汝若来修定能断爱。梵志请曰。愿为说之令我心开必当依命。尊者告曰。惟我世尊。如实知见说四神足。依之修习速离爱缠。问若有能于四念住等。三十七种菩提分法。随一修习皆能断爱。何故但言修四神足。答此是爱结近对治故。谓有爱者驰散诸缘。等持能为彼近对治。梵志复曰。如仁所言神足无边修何能尽。问梵志何故作是语耶。答梵志意言。此四神足其体遍在学无学位。彼即无边修何能尽修。若不尽何能断爱。阿难告曰。此非无边。梵志复言。请为解说。阿难告言。吾今问汝可随意答。于意云何。汝曾生欲入园游不。梵志曰然。复问入园既游观已生欲还不。梵志曰然。复问二时所生乐欲岂不有异。梵志曰然。尊者告言。如汝生欲二时有异。一欲入园。二欲还出。如是神足学无学位亦各不同。学位所修为欲断爱。无学所修为现法乐。随所修异非谓无边。梵志如何谓修不尽。彼闻欢喜发淳净心。归佛出家修于梵行

五根者。谓信根精进根念根定根慧根。五力亦尔。此五随名即心所中各一为性。已说自性当说所以。问何缘此五名根。名力。答能生善法故名根。能破恶法故名力。有说。不可倾动名根。能摧伏他名力。有说。势用增上义是根。不可屈伏义是力。若以位别下位名根。上位名力。若以实义一一位中皆具二种。此二广辩如余处说

七觉支者。一念觉支。二择法觉支。三精进觉支。四喜觉支。五轻安觉支。六定觉支。七舍觉支。择法即慧。喜即喜根。舍谓行舍。余四如名即心所中各一为性。已说自性当说所以。问何故此七名觉支耶。答觉谓究竟觉。即尽无生智。或如实觉即无漏慧。七为彼分故名为支。择法亦觉亦支。余六是支非觉。此七广辩如余处说

八道支者。谓正见。正思惟。正语。正业。正命。正精进。正念。正定。正见即慧。正思惟即寻。正语业命。即随心转三根所发身语无表。余三如名即心所性。已说自性当说所以。问何故此八名为道支。答所履通达故名为道。八是彼分故说名支。正见亦道亦支。余七是支非道。此亦如余处广说

四静虑者。谓初静虑乃至第四静虑。有说。寻喜乐舍相应静虑如次为四。此有二种。一修得。二生得。修得者。即彼地摄心一境性。若并助伴即五蕴性。生得者。随地所系余五蕴为性。已说自性当说所以。问此四何缘说为静虑。答静谓寂静。虑谓筹虑。此四地中定慧平等故称静虑。余随有阙不得此名。此四广如余处分别

四无量者。谓慈悲喜舍。慈谓与乐作意相应。无嗔善根为性。悲谓除苦作意相应。无嗔善根为性。有说。不害为性。喜谓庆慰作意相应喜根为性。有说。以善心所中欣为自性。舍谓平等作意相应。无贪善根为性。已说自性当说所以。问何故名无量。答由此四种缘无量有情故。生无量善法故。招无量胜果故。广说此四亦如余处。四无色者。谓空无边处。乃至非想非非想处。此亦二种。一修得。二生得。修得者。即彼地摄心一境性。若并助伴即四蕴性。生得者。即彼地系余四蕴为性。已说自性当说所以。问何故此四说名无色。答此四地中超过一切有色法故。违害一切有色法故。色法于此无容生故说名无色。此四亦如余处广说

八解脱者。一内有色观诸色解脱。二内无色想观外色解脱。三净解脱身作证具足住。四空无边处解脱。乃至七非想非非想处解脱。八灭受想解脱身作证具足住。此中前三无贪善根为性。若并助伴即五蕴性。次四即以彼根本地加行善四蕴为性。有说。亦以彼近分地。前八解脱道为性。最后解脱以灭尽等至为性。已说自性当说所以。问何故名解脱。答解脱所有彼能障故。余义如余处广说

八胜处者。一内有色想观外色少。乃至广说。二内有色想观外色多。乃至广说。三内无色想观外色少。乃至广说。四内无色想观外色多。乃至广说。观青黄赤白复为四种。此八皆以无贪善根为性。至并助伴即五蕴性。已说自性当说所以。问何故名胜处。答降伏所缘摧灭贪爱故名胜处。广分别义如余处说

十遍处者。谓各别观青黄赤白。地水火风即为前八。九空无边处。十识无边处。此中前八无贪善根为性。若并助伴即五蕴性。后二遍处即以彼地有漏加行善。彼胜解俱品四蕴为性。已说自性当说所以。问何故名遍处。答所缘广普。胜解无边故名遍处。余义如余处说

八智者。谓法智。类智世俗智他心智苦智集智。灭智道智非尽无生以位局故。此八皆以心所法中慧为自性。已说自性当说所以。问何故名智。答于所缘法审观决定。故名为智。余义如余处广说

三等持者。一空二无愿三无相。此三皆以心所法中三摩地为性。通有漏无漏。此中唯说无漏解脱门故。若空无我二行相俱。无漏等持名空三摩地。若无常苦因集生缘。道如行出十行相俱。无漏等持名无愿三摩地。若灭静妙离四行相俱。无漏等持名无相三摩地。已说自性当说所以。问何故名等持。答平等持心令专一境。有所成办故名等持广说此三如余处辩。四沙门果者。一预流果。二一来果。三不还果。四阿罗汉果。此四各以二法为性。一无为二有为。无为果者。谓预流果以三界见所断。断择灭为性。一来果以三界见所断断及欲界修所断前六品断择灭为性。不还果以三界见所断。及欲界修所断断择灭为性。阿罗汉果以三界见修所断断择灭为性。有为果者。随其所应皆以无漏五蕴为性。已说自性当说所以。问何故名沙门果。答无倒勇励息除染法名曰沙门。是诸沙门所引所证名沙门果。此亦如余处广说

五通者。一神境智通。二天眼智通。三天耳智通。四他心智通。五宿住随念智通。此五皆以慧为自性。已说自性当说所以。问何故名通。答于自所缘无倒了达。妙用无碍故名为通。界者四唯色界系。他心智通色界系及不系。地者。在四静虑根本地。非近分非无色。所以者何。若地有五通所依殊胜三摩地。彼地有五通。近分无色无五通所依殊胜三摩地。是故于彼无此诸通。有说。若地奢摩他毗钵舍那。平等摄受彼地有五通。近分无色随一阙故无有五通。所依者。皆依欲色界。行相者。四种唯不明了行相。他心智通。若有漏亦不明了行相。若无漏作道四行相。所缘者。神境智通缘欲色界。或四处或二处。天眼智通缘欲色界色处。天耳智通缘欲色界声处。他心智通。缘欲色界及不系心心所。宿住智通缘欲色界五蕴。念住者。前三唯身念住。他心智通是三念住除身。宿住智通唯法念住。智者四种唯世俗智。他心智通。若有漏是世俗智。他心智。若无漏是法智类智道智。他心智三摩地俱者。四种非三摩地俱。他心智通若有漏。亦非三摩地俱。若无漏与道无愿三摩地俱。根相应者。依种类说三根相应。谓乐根喜根舍根。世者五种皆堕三世。前四过去缘过去。现在缘现在。未来若生缘未来。不生缘三世。宿住智通。过去现在缘过去。未来缘三世。善等者。天眼天耳通。是无记缘三种。神境智通。是善缘无记。余是善缘三种。欲界系等者。四是色界系。缘欲色界系。他心智通是色界系及不系。缘欲色界系及不系。学等者。四是非学非无学。缘非学非无学。他心智通。是学无学非学非无学。缘学无学非学非无学见所断等者。三是修所断。缘修所断。他心智通是修所断及不断。缘见修所断及不断。宿住智通。是修所断。缘见修所断。缘名缘义者。宿住智通。通缘名义。余四唯缘义。缘自相续等者。他心智通。唯缘他相续。余四通缘自他相续及非相续。加行离染得者。问此五通为加行得。为离染得。若加行得者。智蕴所说云何通。如说若成就现在他心智。亦成就过去未来耶。答如是。若离染得者。此蕴前说云何通。如说以无间道证神境智通时。念住现在修一。未来修四等。非起先得有未来修。有说。唯加行得。问智蕴所说云何通。答彼文应作是说。若成就现在他心智。未来定成就过去。若已灭不失则成就。若未已灭或已灭而失则不成就。而不说者言。势所引总略答故。有说。唯离染得。问此前所说云何通。答说重调练菩提分法非初得修。尔时但令先所得者转明胜故。如是说者。皆通加行及离染得。此蕴但说加行得者。智蕴唯说离染得者。如是便为二说善通。有说。于彼离染得中。有已曾习。有未曾习。智蕴说已曾习。此蕴说未曾习。如是亦为二说善通。离染得者。谓初静虑所引发者。离欲界染时得。乃至第四静虑所引发者。离第三静虑染时得。若诸圣者。及后有异生通得曾习未曾习。余唯得曾习。离染得已加行现前。佛不加行。独觉下加行。声闻或中或上。又随离染解脱道时。所修得者皆离染得。若于余时而修得者皆加行得。何处起者。欲色界皆得起。欲界中唯人天。人中唯三洲。通男女身。异生圣者学与无学皆得现起

问诸通为无间道摄。为解脱道摄。若无间道摄者。经所说云何通。如说分一为多合多为一。乃至广说。非无间道一刹那中有如是事。若解脱道摄者。品类足说当云何通。如说通云何。谓善慧天眼耳通解脱道。是无记慧云何名通。答诸通是解脱道摄。如沙门果解脱道摄非无间道。此亦如是。问品类足说当云何通。答彼所说通与此说异。彼说善慧皆名为通。以说一切法皆是所通达故。此中所说胜慧名通。此通或善或是无记。通与善慧得作四句。有通非善慧。谓天眼耳通。有善慧非通。谓除通余善慧。有俱是。谓余四通。有俱非。谓除前相

问此五通为如说而生为不尔。有作是说。如说而生。谓先起神境智通故佛前说。乃至后起宿住智通故佛后说。谓彼闻色界天而不能往故。先起神境通往。而不能见其色故。次起天眼通见而不能闻其语故。次起天耳通闻而不能知其心故。次起他心通知彼心已未知宿世曾相遇不故。后起宿住通。世尊依此次第而说。如是说者。次第无定。谓或先起神境通。乃至或先起宿住通。或有唯得神境通。如天授等。或有唯得天眼通。如善星等。是故诸通无顺入逆入。亦无超越次第。如诸等至。或如无量解脱胜处遍处

问修起神境天眼通时。俱有光明此有何异。答若修神境所引光明。或化所为。或自性有。若修天眼所引光明。非化所为唯自性有

说一切有部发智大毗婆沙论卷第一百四十一阿毗达磨大毗婆沙论卷第一百四十二

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    根蕴第六中根纳息第一之一

二十二根。眼根耳根鼻根舌根身根女根男根命根意根乐根苦根喜根忧根舍根信根精进根念根定根慧根未知当知根已知根具知根。此二十二根。几学。几无学。几非学非无学。如是等章。及解章义。既领会已应广分别。问何故尊者以二十二根而作论。答是彼尊者所乐欲故。随彼所欲不违法相而作斯论。不应责其所以。有说。不应问。彼尊者以契经说二十二根。彼根契经是此论根本。依彼经造论不可责其因缘。以彼尊者于佛所说二十二根不能少减说二十一。不能少增说二十三。以佛所说无增减故不可增减。如不可增减。不可多少。不可损益。无量无边应知亦尔。以佛所说无量无边。不可于中作量边故。无量者义难测故。无边者文难知故。譬如大海无量无边。无量者深。无边者广。世尊所说应知亦然。虽百千俱胝那庾多数。如舍利子等诸大论师。于佛所说二句文义。造百千论分别解释。尽其觉性不得边际。是故不应责彼尊者。问置彼尊者。世尊何故说此契经。答观所化者应闻此法得饶益故。复次此经有别缘起。谓有梵志名曰生闻。来诣佛所欢喜。问讯。在一面坐而白佛言。施设几根摄诸根尽。佛言。我说二十二根摄诸根尽。若有遮此更说余根。当知彼说有言无义。若还问彼反生愚惑。所以者何。非其境故由梵志问。说此契经。是故不应征佛说意。问置佛说意。梵志何故但问诸根。不问蕴界处等。答随彼所疑而问。不应为责。或彼梵志性善寻思。随有所闻喜便历问。为知根义周遍游历九十六道问诸根量。如离系者施设一根所谓命根遍内外物。故彼立制不饮冷水。不断生草以有命故。问诸外道于外物中。执有何根名有根法。答有于外物执有意根。有于外物执有命根。有于外物执有二根。由意根故名有根法。由命根故名有命法。有于外物执有二根。谓业与意随应当说。又如外道波罗设利。作如是说。眼不见色。耳不闻声。名圣修根。问何故彼名波罗设利。答是所立名不应问立名所以。名随假立不必皆有实义故。有说。此是彼姓。谓婆罗门有姓憍蹉。有姓筏蹉。有姓扇祑略。有姓憍阵那。有姓婆罗堕阇。有姓波罗设利。有说。此是杂种。谓从刹帝利婆罗门生。名波罗设利。如从驴马所生名骡。如是说者。此是彼姓。彼有弟子名嗢怛罗。曾于一时来诣佛所。欢喜问讯在一面坐。佛时告曰。汝师波罗设利。为汝等说修根法耶。嗢怛罗言。我师曾说。佛问云何。彼云。我师作如是说。眼不见色。耳不闻声。名圣修根无所取故。佛即难曰。若尔盲者应名圣修根不见色故。时阿难陀佛边侍立。为佛摇扇。寻亦难言。聋者亦应名圣修根不闻声故。问设有外道。百千俱胝那庾多数。智慧辩才如舍利子。佛皆能伏。何故世尊作初难已。尊者庆喜作第二难。世尊何故而不遮止。答佛观庆喜咽喉有相。知欲设难故便自止。以佛昔在三无数劫。精勤修习菩萨行时。尚不断他所有才辩。乃至弟子亦不遮遏。况今成佛断他辩才。又佛了知若自所说。若庆喜说平等无异。无有增减故不遮止。又显师与弟子俱能摧伏他故。若师弟子俱能伏者。乃名善伏故不遮制。又欲令彼无余言故。谓若世尊作第一难。庆喜不作第二难者。则彼外道还自众中。以余慢心作如是言。虽为彼师所伏而非弟子。彼虽能伏我等而非我师。若佛世尊作第一难。庆喜复作第二难者。则彼永舍憍慢之心。弟子尚能摧伏我等何况彼师。设我师来亦不能对何况我等。又欲满彼梵志意故彼作是念。乔答摩尊诸力士中。为无有上能伏能破一切论者而无屈挠。诸论师中最为尊胜。往昔所有诸大论师。尚无能对何况我等。若彼弟子与我谈论。我当酬对岂不宜哉。佛一切时满所化意。如其所念而汲引之。故不遮止庆喜所难。复次佛以庆喜为证义人。故彼外道众信重庆喜。以彼尊者形貌端严。善知因陀罗声明论故。佛意令彼问所信人。自验师宗应正理不。庆喜时说故佛不止。复次欲显世尊无胜己虑故。谓诸外道虑弟子中有胜己故。遮其言辩佛无是事。设有弟子百千俱胝那庾多数。辩才智慧如舍利子。亦无问难与佛等者况能胜佛。复次欲显己断法悭垢故。谓诸外道不许弟子与他论难。勿彼由斯多获名誉恭敬利养。佛则不尔。假使世间。一切皆得无边名利。佛无一毫终无嫉妒。是故不止庆喜所说。复次欲显弟子亦胜他故。谓诸外道恐己门徒与他论难堕负受辱。世尊弟子无不胜他。若论难时益更光扬如来正法故不遮制。复次为欲显示善说法中文义满足无异见故。谓诸外道恶说法中。文义乖违师徒见异。随有所立所说所解。师与弟子各各相违。佛正法中无此过失。随有所立所说所解。弟子与师皆同一味。由此等缘对彼外道。佛与庆喜各设一难。问外道若许盲聋之人。是圣修根云何成难。答是为大难亦是总说外道过失无能对者谓汝若许盲聋之人。亦得名为圣修根者。汝等何故弃舍居家。昼夜精勤修诸梵行。但应毁坏眼耳二根。自可名为圣修根者。故前所说是为大难。亦是总诃一切外道。又胜论者说有五根。鼻舌眼身耳根为五。又数论者说十一根。谓五觉根五业根意根。五觉根者。所谓眼耳鼻舌身根。五业根者。谓语手足大小便根。意者意根为第十一。或复有说。百二十根。谓眼耳鼻各二为六。舌身意命及五受根。信等五根总为二十六。趣各二十为百二十。彼说阿素洛为第六趣。有说。根是主义。彼外道说有百二十主。如天主龙主阿素洛主及人主等。要受如是百二十处。胜妙之身方得解脱。生闻梵志闻如是等。说根不同转生疑惑。不知何者是其实说。闻释氏宫生一大子。具三十二大丈夫相八十随好。身真金色圆光一寻。见者欢喜睹无厌足。舍轮王位踰城出家。精勤修习难行苦行。证得无上正等菩提。一切知者一切见者。断一切疑网施一切决定。能尽一切问难源底。闻已即时来诣佛所。在一面坐而白佛言。说根者多沙门说几根摄诸根尽。问何故梵志不以所闻说根差别。请问于佛而直作此问耶。答彼有恶慧恐佛于他所说根中。择善而说故作总问。佛依彼问答言。我说二十二根摄诸根尽。若有遮此更说余根。广说乃至。非其境故。问世尊何故复作是语。若有遮此更说余根。当知彼说有言无义。若还问彼反生迷惑。所以者何。非其境故。答欲令彼知先所闻一根。乃至百二十根皆非实故义言。我是一切知者一切见者。尚不能于二十二根中。减一根说二十一。增一根说二十三。况诸外道僻见无知于诸根中有能增减。说一乃至百二十耶。由此因缘彼来诣佛。但问根义非蕴界等问此二十二根名有二十二。实体有几。答对法者言。名二十二。实体十七。于中男女三无漏根无别体故。问何故男女根无别体耶。答此二即是身根摄故。如说女根云何。谓身根少分。男根云何。谓身根少分。问何故三无漏根亦无别体。答此三即是九根摄故。九谓意根。乐喜舍根。信等五根。此九根有位名未知当知根。有位名已知根。有位名具知根。即见道位。修道位。无学道位。如次应知。又在随信随法行相续中。名未知当知根。在信解见至身证相续中。名已知根。在慧解脱俱解脱相续中。名具知根。九根聚集随位说三故无别体。由此故说二十二根名二十二实体十七。尊者法救作如是说。名二十二。实体十四。谓即前五及命舍定无别实体故。彼说问何故命根无实体。答命根是不相应行蕴所摄。彼说不相应行蕴无实体故。问何故复说舍根无别体。答彼说离苦乐受无别不苦不乐受。所以者何。诸所有受。或乐或苦若非苦乐。云何名受。问若尔经说三受当云何通。答彼作是说。乐受苦受有上。有下有利有钝。有躁有静。诸上利躁者名乐受苦受。诸下钝静者名不苦不乐受。此体不定如疑而转。问何故彼说定根亦无别体。答彼说离心无定体故。如说定云何。谓心一境性。由此诸根名二十二。实体十四。尊者觉天作如是说。名二十二。实体唯一。所谓意根。彼作是说。诸有为法有二自性。一大种。二心。离大种无所造色。离心无心所。诸色皆是大种差别。无色皆是心之差别。由此义故实根唯一。如实义者。应如初说名二十二。实体十七如名体。如是。名施设体施设。名异相体异相。名异性体异性。名别性体别性。名分别体分别。名觉悟体觉悟。应知亦尔。是名诸根自性。我物性相自体已说自性当说所以。问何故名根。根是何义。答增上义是根义。明义是根义。现义是根义。喜观义是根义。端严义是根义。最义是根义。胜义是根义。主义是根义。问若增上义是根义者。诸有为法展转增上。诸无为法于有为增上。则一切法皆应立根。何故世尊立二十二。胁尊者言。佛于诸法了达究竟。善知诸法体相势用余不能知。若法有根相者立根。无者不立不应责问。有说。增上缘有下有上有劣有胜。上胜立根。下劣不立。有说。虽一切法皆有增上缘义。而非皆有增上明现。乃至主义。如二十二根者。如一切有情虽皆互有增上缘义。而有胜者。如鬼界中琰摩王胜。傍生趣中师子王胜。村中主胜。国中王胜。四大洲中转轮王胜。于欲界中自在天胜。千世界中梵王为胜。于三界中佛为最胜。佛于一切有情类中。独称法王无伦匹故。如是诸法虽皆是增上缘。而非一切皆有增上。乃至主义。如二十二根者。故佛唯说此二十二根

问若增上义是根义者。谁于何增上。答眼根于四处增上。一庄严自身。二导养自身。三为识等依。四作不共事。庄严自身者。虽有妙身支分具足。眼根若缺人不喜观。故于严身此为增上。导养自身者。由眼根故见好恶色。舍危就安令身久住。为识等依者。眼识及相应法依此而生。作不共事者。唯眼根见色非余根。耳根于四处增上。一庄严自身。二导养自身。三为识等依。四作不共事。庄严自身者。虽有妙身支分具足。耳根若缺人不喜观。故于严身此为增上。导养自身者。由耳根故闻好恶声。舍危就安令身久住。为识等依者。耳识及相应法依此而生。作不共事者。唯耳根闻声非余根。有余师说。眼根导养生身为胜。耳根导养法身为胜。如说

  譬如明眼人　　能避现崄难
  世有聪明者　　能离当苦恶
  多闻能知法　　多闻能离罪
  多闻舍无义　　多闻得涅槃

复有说者。眼根耳根俱能导养生身法身。导养生身如前说。导养法身者。由眼根故亲近善士。由耳根故听闻正法。由此能引如理作意。法随法行乃至展转证得涅槃。是故经说。梵寿梵志勿坏二根。谓眼与耳。问何故于诸根聚中。但说勿坏二根耶。答由眼耳根佛出世时。为路为门趣入佛法。又由眼耳遇佛便能比知是佛。如说苾刍。汝若不能知佛心者应二处求。一所闻。二所见。由此偏说勿坏二根。鼻舌身根皆于四处增上。一庄严自身。二导养自身。三为识等依。四作不共事。庄严自身者。虽有妙身支分具足。三根随缺人不喜观。导养自身者。由此三根受用段食令身久住。以段食是香味触故。为识等依者。鼻识及相应法依鼻根生。舌识及相应法依舌根生。身识及相应法依身根生。作不共事者。唯鼻能嗅。唯舌能尝。唯身觉触。各非余根。意根于二处增上。一能续后有。二自在随转。能续后有者。如说识若不托母胎名色得成羯逻蓝不。不也世尊。自在随转者。如说

  世间心所引　　亦为心所劳
  心若于彼生　　皆自在随转

有说。意根于染净品增上。如说心杂染故有情杂染。心清净故有情清净。男女二根于二处增上。一有情异。二分别异。有情异者。由此二根令诸有情男女类别分别异者。由此二根形相言音乳房等别。谓劫初时无女男差别。后于是处少造色生。便有男女体类状貌。显形言音衣着饮食受用差别。有说。此二于染净品增上。于染胜者。非于淫欲此无疑故。但由此二若坏若阙。于不律仪。五无间业。不能受作。亦复不能断诸善根。于净胜者。此男女根若坏若阙。便不能起一切律仪。亦复不能离三界染。不能种植三乘种子。命根于二处增上。一令说有根。二令根不断。命根若在可说有根。及令诸根相续住故。有说。命根于四处胜。一续众同分。二持众同分。三护养众同分。四令众同分不断。五受根于杂染品增上。以诸有情由受势力。四方追求游于铁锁。钩索崄路登山越谷。匍匐偃倒。或入大海遇诸畏难。谓波浪洄澓室兽摩罗。黑风旋风伏山滩碛堕恶龙宫。逻刹娑洲金毗罗难盗贼难等。如是种种皆因诸受。问无漏受云何于杂染品增上耶。答初起加行及趣入时。亦于杂染品增上。谓观行者求彼受时。亦须追求衣食等物。由此势力亦生染故。有说受于染净俱胜乐受。于染胜者。如说于乐受贪随增。于净胜者。如说乐故心定。若受于染胜者。如说于苦受嗔随增。于净胜者。如说苦为信依。不苦不乐受于染胜者。如说于不苦不乐受无明随增。于净胜者。如说六出离依舍信等五根。于清净品增上。如说

  信生能归趣　　越放逸流海
  精进能除苦　　慧能得清净

又说我圣弟子具信。伊师迦能舍不善修习善法。又佛告庆喜。精进能得菩提。又说我圣弟子具精进力。舍不善法修习善法。又说念能遍行防护一切。我圣弟子具念防护。舍不善法修习善法。又说定是正道不定是邪道。定心得解脱非不定心。定心能知诸蕴生灭。又说。我圣弟子具三定鬘。能离不善修于善法。又说

  慧为世间上　　能顺趣决择
  能正知诸法　　能尽老死苦

又说。一切法中慧为最上。又说。姊妹。我圣弟子能以慧刀。断诸结缚随眠缠垢。又说。我圣弟子具慧垣墙。能障恶法增长善法。未知当知根。于未见谛而见谛增上。已知根。于已见谛除烦恼过增上。具知根。于已除烦恼过。得现法乐住增上。由此各各于彼彼处有增上义。故说为根

尊者寠沙筏摩作如是说。唯意一种是胜义根。是内是遍有所缘故。是内者。内处摄故。是遍者。从无间狱至有顶故。有所缘者。缘一切法故。余眼等根不具斯义。是故不立为胜义根。谓眼等五虽内处摄。而非是遍非有所缘。命根虽遍而非内处。亦非有缘。苦乐忧喜。虽有所缘非遍非内。舍信等五虽遍有缘而非内处。三无漏根如九根说。问若唯意是胜义根者。余二十一何故名根。答彼与意根作所依。作依。作杂染。作清净。作清净位。故亦名根。谁作所依。谓眼等五根。谁作依。谓命根。谁作杂染。谓五受根。谁作清净。谓信等五根。谁作清净位等三无漏。根。即见位修位无学位。问何故男女复得名根。答生有情故。生欲乐故。制烦恼故。为染依故。生有情者。谓生胎生卵生有情。生欲乐者。谓于是处初生欲乐后乃遍身。如依眉间初生圣乐后乃遍身。于亦如是制烦恼者。谓此志性能于暂时伏诸烦恼。为染依者。谓染污识及相应法此为所依。余处身根发三种识。此唯发染污识非余。发此识时唯作习近意故心与贪俱。尊者僧伽筏苏作如是说。唯命等六是胜义根。所谓眼耳鼻舌身命有情本故。问若命等六是胜义根者。余十六种何故名根。答与命等六。作种子。作杂染。作清净。作清净位。故亦名根。谁作种子。谓意根。谁作杂染。谓五受根。谁作清净。谓信等五根。谁作清净位。谓三无漏根即见位修位无学位。问何故男女亦得名根。答欲界有情欲为种子。欲为苗稼。此依何有。谓男女根。是故此二亦得名根

尊者妙音作如是说。命等八种是胜义根。谓眼耳鼻舌身男女命有情本故。问若命等八是胜义根者。余十四种何故名根。答与命等八作种子。作杂染。作清净。作清净位。故亦名根。广如前说

问身根极微遍身等有。何故此独名女男根。复说为显。尊者世友作如是说。此处能显是男女故。名男女根复说为显。问有二形者亦能显耶。答此不能显不决定故。由此故说非女非男。有说。此处生流转者还灭者故。外道六师补刺拏等名流转者。声闻独觉。及与如来名还灭者。尊者说曰。此处能生诸仙牟尼。诸聪慧者。善调伏者。易共住者。故名男女根。亦说名显

已说诸根聪相所以。今当显示一一别相。问眼根云何。答若已见色。今见色。当见色。及此所余是名眼根。已见色者说过去眼。今见色者说现在眼。当见色者说未来眼。此说同分。及此所余者说彼同分。眼如界中广说。乃至意根说亦如是。问女根云何。答身根少分。男根云何。答身根少分。命根云何。答三界寿。乐根云何。答依顺乐触所生身心乐。平等受受所摄。是谓乐根。苦根云何。答依顺苦触所生身苦。不平等受受所摄是谓苦根。喜根云何。答依顺乐触所生心悦。平等受受所摄。是谓喜根。忧根云何。答依顺苦触所生心戚。不平等受受所摄。是谓忧根。舍根云何。答依顺不苦不乐触所生身心舍。非平等非不平等受受所摄。是谓舍根。信根云何。答于出离远离所生善法。诸信顺印可忍受欲乐心清净性。是谓信根。精进念定慧根如文广说。问未知当知根云何。答未见谛者。未现观者。诸学慧慧根。及所有根。随信随法行。于四圣谛未现观能现观。是谓未知当知根。此中于四圣谛未已见故。名未见谛者。未已现观故名未现观者。诸学慧慧根者。此说慧根及所有根。随信行随法行于四圣谛未现观能现观者。说余八根。总此九根名未知当知根。问此九根中何故慧根再说。别说余根但作一总说耶。答慧名义胜故。谓根聚中慧为最胜。如国中王胜。村中主胜。余根不尔。有说。慧为导首故。如说。苾刍。诸善法生。明为导首。明为前因。由此引生所有惭愧。有说。慧具三现观故。谓慧具三现观。一见现观。二缘现观。三事现观。慧相应法有二现观。谓除见非慧性故。慧具有法有一现观。谓事非余。非慧性故。无所缘故。有说。慧见烦恼令不久住。如穴居众生。人若见时便还入穴。有说。慧照相续则烦恼不侵。如室有灯贼不能盗。有说。慧能照一切法。外日月等唯照一界一处一蕴一世少分。慧能普照十八界。十二处。五蕴。三世。及无为法。有说。无慧者缚。有慧者解。有说。慧入佛法甚欢娱故。谓佛法中以解为胜。是故诸有慧者见妙法宝。于中欢娱如明眼人入于宝渚。若无智慧虽入佛法无所见故常怀忧戚。如生盲人至采宝所更增愁毒。有说。慧根如将。如导。如目。如首。是觉觉支。是道道支。有说。慧能导引余菩提分令不异趣。如明眼者导众盲人令行正路。此亦如是。有说。慧断缠缚犹如利刀。如说。姊妹。我圣弟子。能以慧刀断诸结缚随眠缠垢。有说。慧如台殿。如尊者阿埿律陀言。我依戒住戒。得升无上智慧台殿。有说。慧能安立诸法自相共相。能分别诸法自相共相。破自体愚及所缘愚。于诸法中不增减转。有说。慧是诸佛所爱敬故。佛不爱敬有情色力族姓财富自在。但爱敬慧以慧能证诸功德故。有说。慧能显佛无与等故。谓诸色力族姓财富荣贵自在。不能显佛是最尊胜。唯慧能显。以一切智唯佛有故。余根不尔。以如是等无量因缘。慧根余根作差别说

说一切有部发智大毗婆沙论卷第一百四十二阿毗达磨大毗婆沙论卷第一百四十三

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    根蕴第六中根纳息第一之二

问已知根云何。答已见谛者已现观者。诸学慧慧根。及所有根。信解见至身证。于四圣谛已现观重现观。是谓已知根。此中于四圣谛已见故。名已见谛者。已现观故名已现观者。诸学慧慧根者。此说慧根及所有根。信解见至身证。于四圣谛已现观。重现观者。说余八根。总此九根名已知根。问诸无学者于四圣谛亦重现观。如从退法转至思法。乃至从堪达法转至不动。何故但说学重现观非无学耶。答亦应说无学。而不说者。当知有余。有说。此中举初显后。若说学重现观。当知已说无学亦重现观。如举初显后。举始入显已度。举加行显究竟。当知亦尔。有说。若断未曾断烦恼。得未曾得沙门果者。说重现观。无学尔时非断未曾断烦恼。亦非得未曾得沙门果。是故不说。有说。若断未曾断系得。得未曾得离系得者。说重现观。无学尔时虽得未曾得离系得而不断未曾断系得。是故不说。如断系得。得离系得。除过患修功德。舍下劣证上妙。去无义取有义。尽渴爱苦受无热乐。应知亦尔。有说。舍未曾舍无智。得未曾得智者。说重现观。无学尔时虽得未曾得智。而非舍未曾舍无智。是故不说。应知此依染无智说。由如是等种种因缘。学说重现观非无学

问具知根云何。答漏尽阿罗汉。诸无学慧慧根。及所有根。慧解脱俱解脱能得现法乐住。此中漏尽阿罗汉诸无学慧慧根者。此说慧根及所有根。慧解脱俱解脱能得现法乐住者。说余八根。总此九根名具知根。问学者亦有现法乐住。何故但说无学耶。答亦应说学。而不说者。当知有余。有说。此中举终显始。若说无学得现法乐住。当知已说学亦得现法乐住。如举终显始。举已度显初入。举究竟显加行。当知亦尔。复次此说名义胜者。以法言之。则无学法胜。以补特伽罗言之。则无学补特伽罗胜。有说。此中说得轻安乐非烦恼热所损者。学虽得轻安乐。而犹为烦恼热所损。是故不说。复次此中说受轻安乐自在广大者。学于所作有所作故。虽受轻安乐。而不自在。亦不广大。如王未除一切怨敌。虽受王乐而不自在。亦不广大。彼亦如是。是故不说。有说。此中说已息烦恼意言已满牟尼相者。学则不然。是故不说。有说。此中说有现法乐住。无后世乐住者。学于二世皆有乐住。是故不说。由如是等诸因缘故。无学说乐住非学

问为有三明阿罗汉不。若有者。此中何故不说。若无者。恣举经云何通。如说。尊者舍利子恭敬合掌白佛言世尊。此五百苾刍。几是三明。几是俱解脱。几是慧解脱。此中因论生论。尊者舍利子知是事不。若知者何故问。若不知者。云何得名波罗蜜多声闻。应作是说。彼尊者知。若尔何故问。亦有知而问者。如毗柰耶说。尔时世尊知而故问。由此不应以知故遮其问。有说。尊者欲饶益他故。谓舍利子虽自了知。而知众中有不知者。无无畏故不能问佛。舍利子无是过故。为饶益他所以发问。有说。尊者欲于总中显差别故。谓佛为五百苾刍如应说法。彼闻皆得阿罗汉果。永断后有称可佛心。一切有情真实称可佛心者。谓得阿罗汉果永断后有。尊者舍利子作是念彼诸苾刍。虽皆得阿罗汉果永断后有。而未知彼谁先来勤修加行谁不尔。欲于总中显有差别。故发斯问。有说。世尊先为五百苾刍说法令等住果。尊者舍利子欲显彼道有差别故。是以发问。有说。世尊先为五百苾刍说法。令住平等无为解脱。尊者舍利子。欲显彼有为解脱非无异故。而发斯问。有说。尊者欲显发功德伏藏令世共知故。如世伏藏土所覆故世人不见。若因开发乃得见之生希有想。如是功德宝藏以少欲土覆世无知者。由舍利子所显发故。世人共知生希有想。有说。尊者欲发施主增上思故。有诸施主雨四月中。以衣服等供给僧众。彼或生念。我所施田为良美不。为欲令彼生决定知我等已于良田植福快哉所作功不唐捐。是故尊者发如是问。有说。尊者欲显师徒仪式法应尔故。谓弟子法应问师。师法应教弟子。有说。尊者显己求法无厌离诸懈慢。令他亦然。是以故问。有说。尊者欲断世人少有所知。便生傲足不问他故。彼尊者念言世人智慧。于我所有十六分中不能及一。我犹问他。何况汝等少知少见而不问耶。有说。尊者欲显离法悭垢故。谓法悭者见他问时尚不生喜。何况自问。有说。尊者欲止外道诽谤故。谓诸外道恒谤佛言。沙门乔答摩摄受邬波底沙俱履多故。夜从受法昼为他说。若舍利子于大众前。合掌恭敬而请问者。此谤便止。有说。尊者欲显世尊弟子所有善说皆须佛印印之。故发斯问。如王所司所有符疏。若无王印人不承受。往关津等悉为障碍。若有王印人皆信用所往无碍。如是佛弟子所有善说。若无佛印他不信受。如来灭后所有四众亦不敬受。若为佛印所印可者。闻则奉行。遗法四众亦生敬重。由此等缘彼舍利子而作斯问。若无三明阿罗汉者。彼经所说云何通耶。答应说有三明阿罗汉。问若尔。彼经善通。此中何故不说。答此中应作是说。及所有根慧解脱俱解脱三明。能得现法乐住。而不说者。当知有余。复次已说在先所说中。谓三明阿罗汉。或是慧解脱。或是俱解脱。若说慧解脱。当知已说慧解脱三明。若说俱解脱。当知已说俱解脱三明。故不别说。昔于此义有二论师。一名时毗罗。二名寠沙伐摩。尊者时毗罗偏称赞慧。尊者寠沙伐摩偏称赞灭定。时毗罗作如是说。慧胜非灭定。慧有所缘。灭定无所缘故。寠沙伐摩作如是说。灭定胜非慧灭定唯圣者有。慧通异生有故称赞慧者作如是言。若具三明非八解脱者。是名三明。若具三明亦八解脱者。亦名三明。若具八解脱非三明者。是名俱解脱。若有一明二明。是名慧解脱。所以者何。以慧胜灭定故。称赞灭定者作如是言。若俱八解脱非三明者。是名俱解脱。若具八解脱亦三明者。亦名俱解脱。若具三明非八解脱者。是名三明。若有一明二明。名慧解脱。所以者何。以灭定胜慧故。此二所说俱唐捐其功。于文无益于义无益。然具三明者有得灭定。有不得灭定。若得者名俱解脱三明。若不得者名慧解脱三明

今当重说三无漏根一一立名差别所以。问何故名未知当知根。答未已知而知。未已现观而现观。断无智故名未知当知根。问若如是者。苦法智忍生。于欲界五蕴苦得现观。苦法智生于彼复得现观。则是现观已复现观。何故犹名未知当知根。不名已知根耶。答苦法智忍于欲界五蕴苦名现观。非已现观。苦法智生乃名已现观。然非已现观而现观故。不名已知根。有说。苦法智忍于欲界五蕴苦。虽名现观而不名知。非智性故。苦法智生乃得名知。尔时虽名已现观。而现观而非已知而知。故不名已知根。又此中依智现观而作论。非忍故。亦不名已现观而现观。如何名已知根。有说苦法智后复有未已现观道生。此智为未已现观。觉所倰所覆以下着上。彼增上力故此不自在。由此苦法智不名已知根。余忍智亦尔

问何故名已知根。答已知而知。已现观而现观。断无智故名已知根。问若如是者。道类智忍生。除其自性相应俱有法。于余一切类智品道皆得现观。此后道类智生。于道类智忍自性相应俱有法。乃得现观。尔时于彼忍自性等未已现观而现观。何故名已知根不名未知当知根。答外国师说十六心刹那皆是见道。问今不问彼。但问十五心刹那为见道者。何故尔耶。尊者僧伽筏苏说曰。道类智忍现在前时。能修未来无量刹那道类智忍。彼所修者于现在忍等已得现观。故无有过。此不应理。未来道无作用故。应作是答。从多分说名已现观。谓已现观者无量无边。未已现观者但有少许。已现观而现观者。犹如大地。未已现观而现观者。但如一块。妙高一尘大海一渧。虚空蚊处喻亦如是。故从多分名已知根。问第十六心顷应如七智。何故独说为已知根。非已知而知故。答此亦从多分说。谓初刹那虽与七智相似。后诸刹那皆与彼异。从多分说悉名已知根。一类性故。有说。此后更无未已知。道所倰所覆不以下着上。令不得自在。必当尔故。于知言已知。如去时名已去。彼亦如是

问何故名具知根。答已知而知。已现观而现观。不断无智先已断故。名具知根问若如是者。三乘无学皆是具知。何故世尊独名为佛。答能初觉故。能遍觉故。能别觉故。说名为佛声闻独觉不能初觉。不能遍觉。不能别觉。故不名佛。有说。若于尔焰自觉遍觉。无错谬觉。说名为佛。独觉虽能自觉。无余二种。声闻俱无。故不名佛。有说。若于诸缘能自然觉。一切种觉说名为佛。独觉虽有自然觉。而无一切种觉。声闻俱无。故不名佛。有说。若智于能觉所觉。行相所缘。根根义。有境境。尔焰中。能遍明觉说名为佛。二乘不尔。有说。若有闻而不舍。说名为佛。二乘不尔。有说。若相续中。永伏一切非理习气。说名为佛。二乘不尔。有说。若有于甚深缘起河能尽源底。说名为佛。二乘不尔。故经喻以三兽渡河。谓兔马象。兔于水上但浮而渡马或履地或浮而渡。香象恒时蹈底而渡。声闻独觉及与如来。渡缘起河如次亦尔。有说。若断二种无知。谓染不染。说名为佛。声闻独觉唯能断染。不断不染。故不名佛。有说。若断二种疑惑。谓事随眠。说名为佛。声闻独觉虽断随眠而不断事。故不名佛。有说。若尽智时二障俱断心得解脱谓烦恼障及解脱障。说名为佛。声闻独觉或先脱烦恼障。后解脱障。或先断解脱障。后烦恼障。无俱脱者。故不名佛。有说。若具二圆满者。说名为佛。谓所依能依诸余有情。或所依圆满非能依。如转轮王。或能依圆满非所依。谓声闻独觉。唯佛具二故得佛名。如所依能依器器中处处中明与行。应知亦尔。有说。若三事圆满说名为佛。谓色族辩。二乘不尔。有说。若三事圆满说名为佛。谓立誓果成恣间。二乘不尔。有说。若具三不护三不共念住说名为佛。二乘不尔。有说。若所言无二。辩才无竭。所记无谬。说名为佛。二乘不尔。有说。若具四智说名为佛。谓因智时智相智说智。二乘不尔。有说。若具四智说名为佛。谓无著智。无碍智。无谬智。不退智。二乘不尔。有说。若具种种因觉。种种果觉。种种相续觉。种种对治觉。说名为佛。二乘不尔。有说。若世八法所不能染。功德彼岸无能逮者。一切危厄堪能拔济。说名为佛。二乘不尔。有说。若具十八不共佛法。十力。四无所畏。大悲。三不共念住。说名为佛。二乘不尔。有说。若有深远微细遍行。平等大悲心者。说名为佛。深远者。三无数劫所积集故。微细者。觉三苦故。遍行者。缘三界故。平等者。于怨亲中无异转故。由如是等种种因缘。于三具知唯一名佛

问世尊何故于色蕴中。唯立眼处等为根。非色处等耶。答由色处等无根相故。有说。内处摄者立根。外处摄者不立。有说。若亦作所依者立根。唯作所缘者不立。有境境说亦尔。有说。若唯有情数摄者立根。若不定者不立。有说。若唯是有执受者立根。若非及不定者不立。有说。若唯相续摄者立根。不定者不立。有说。若唯自相续受用者立根。不定者不立。有说。不共者立根。共者不立

问世尊何故于受蕴中。苦受乐受各立二根。不苦不乐受唯立一耶。答不苦不乐受亦应立二。而不立者。当知是有余说。复次欲以种种文种种说庄严于义令易解故。复次欲现二门二略。乃至广说。复次苦乐二受有明利。有不明利。有轻躁。有不轻躁。有安住。有不安住。诸明利轻躁不安住者。立忧喜受。诸不明利不轻躁安住者。立苦乐受。不苦不乐受。唯不明利不轻躁安住。故合立一。复次苦受乐受转有异故。各分为二。谓乐根转异喜根转异。苦根转异。忧根转异。不苦不乐受无异转。故合立为一。复次苦受乐受互相违故。各分为二。谓苦乐相违。忧喜相违。不苦不乐受无此相违。故但说一问何故想蕴不立为根。答非根法多。何独问想。问如色蕴行蕴少分立根。受蕴识蕴皆立为根。唯想不立。所以故问。答以想无根相故。复次根者自力转。想由他转。如佣作人他教即作。不教不作。想于境转。亦复如是。谓受思识领纳造作了别境已。想方取相。复次根者自在不为他覆。想为慧覆。故不说根谓善想为善慧所覆。如于善事善取相者。世间说此名聪慧人。无记想为无记慧所覆。如于世务善取相者。世便说此名巧慧人。染污想为颠倒慧所覆。如说于无常起常想颠倒。乃至于非我起我想颠倒。尊者世友说曰。想何故不立根。答增上义是根义。想增上少故不立根。问想亦有增上。如说一切有为法展转增上。诸无为法于有为增上。答我说少不说无也。又说根者能害烦恼。想不能害烦恼。问想亦能害烦恼。如说苾刍于无常想。若习若修若多修习。能除一切欲贪色无色贪。答此于慧说想名也。大德说曰。根是主义不随于他。想则随他。余心心所分别境已方能取相。故不立根。尊者众世说曰。根者沉实。想用浮虚。故胜解观名为假想。世亦于彼不实解中言是汝想。尊者觉天说曰。根者决定难可摇动。想用随缘转易不定。如影像阳焰。故不立根。问何故烦恼不立为根。答彼无根相。是以不立。有余师说。增上是根。烦恼下劣。问烦恼能令诸有相续。坏诸善品令没生死。令远涅槃难可调伏。云何下劣。答以诸烦恼鄙贱可诃。智者弃之故名下劣。非无势用名为下劣。如旃荼罗补羯娑等。虽有势用亦名下劣。以诸胜人所轻贱故。问若尔。染污受应不立根。答受于染品势用增上故立为根。烦恼不尔。以依诸受生烦恼故。问若尔。想应立根。亦能生烦恼故。答想虽能生烦恼。而不及受胜。由此义故亦不说在缘起支中。有说。受虽随顺染品。而亦与善法交通。烦恼唯于染品随顺。而不顺善。故不立根。犹如狱正所居虽下而与贵胜交往。非如守门狱卒。虽有威猛苦切于人。而极鄙恶可厌贱故。贵胜离之。尊者僧伽伐苏说曰。若法有染无染。身中可得者立根。烦恼唯于有染身中可得。故不立根。若尔忧根及具知根皆不应立。忧根但于有染身中可得。具知根但于无染身中可得故。有说。根是主义。烦恼非主。是心所法故。若尔受等亦应不立。由此因缘前说为善

问何故受善染无记皆立为根。慧念定唯善立根。非染无记。答受于顺杂染品势用增上。善染无记受皆有势力。顺杂染品故并立根。慧念定三顺清净品势用增上。唯善慧念定顺清净品故立为根。染慧念定乃相资助断清净品。无记慧等亦于净品不顺。是故皆不立根。有余师说。受于三品皆有势用。故并立根。慧念定三唯于净品有势用故。唯善立根。所以者何。诸受力故令有情类于诸善染无记事转。由受于净品胜故。说在觉支静虑支中。于染品胜故。说在十二缘起支中。于非二品胜者。谓由受故造作种种无记事业。慧等不尔。由此应知意根亦于三品胜故。善染无记皆立为根。于三胜者。以三品法皆依心故。问何故作意胜解触欲不立为根。答无根相故。谓作意虽能发动于意趣所缘境。非一切时恒有胜用。故不立根。问此于净品岂无胜用。诸修定者初修定时。无不皆由作意力故。答初修定时令心趣境虽暂有力。心住境已便无胜用。故不立根。胜解虽能令心于境印可决定。而于生长无别胜用。故不立根。问岂不胜解于善法中亦有胜用。于戒等五蕴。十无学支中。皆建立故。答于离染位离染相显。立解脱蕴正解脱支。除此更无生长胜用。以无根相不立为根。触虽令心触对于境顺生诸受。然于染净无别胜用。故不立根。问岂不生受即是胜用。答受于染净有胜功能可立为根。触唯生受于染净品无亲胜用。又触唯能随顺染品。非顺净品。故不立根。多顺净品立诸根故。即由此故欲不立根。亦于净品无胜用故。问契经说诸法欲为根本。诸染净品皆从欲生。如何于净无有胜用。答虽染净品无欲不生。契经说为诸法根本。然既生已便无胜用。又多顺爱故不立根。顺下贱法非增上故。问思能令心造作善恶。立为意业。能发身语。能感生死。有增上用。胜于余法。何不立根。答唯顺杂染。非清净品。故不立根。有说。诸业从烦恼生。烦恼鄙贱非增上故。不立为根。业亦应尔。如鄙贱人所生男女。人皆厌弃不与交婚。诸业亦然。故无根义

问何故善心所法中。唯二立根余皆不立。答余并无根相故。谓信能为诸善根本。无有善品离信而成。精进普能策发众善。无有善品离精进成。故此二法增上义胜。可立为根。余则不尔。问惭愧二种自性善摄。说为白法。何不立根。答此能对治遍不善心。一向黑品自性不善。故说名白及自性善。然于生长诸善法中。无别胜能。故无根义。问无贪无恚名为善根。此中何故不立为根。答彼建立根。与此义异。谓彼所治与六识俱。通五所断。是随眠性。能发粗重身语恶业。与断善根作胜加行。具斯五义立不善根。无贪等三能对治彼。及起诸散善业故名善根。此中信等立根。通望生长一切善法。多依随顺出世善品。故无贪等于此非根。问轻安。不害。不放逸舍。何不立根。答无根相故。谓彼所治四随烦恼。三唯遍染心。一为恶寻伴。恼乱菩萨障取菩提。故善法中立彼能治。然于生长清净品法。无胜所作。故不立根。问诸善皆依不放逸起。云何说所作非胜耶。答此但能。除诸放逸法故。令诸善品依信等生。非彼亲能有生长用。问欣厌何故不立根耶。答于散位中此用虽胜。于定善位用不分明。根用必于两位中胜。而于定位明了增强。故彼二法无有根义。问若尔。何故立信为根。答澄净用通一切位故。非唯散位。是故立根。问恶作睡眠。及与寻伺。何故非根。答无根相故。谓前二种唯在散心。后二不通一切界地。又皆无有生善胜能。故皆不说有其根义。问若尔。苦等四受应不立根。答总而言之。受遍诸位。依彼种类皆说为根。又受皆有生长增上。彼四不尔。问道支中立寻静虑。支中立寻伺。岂非生长有增胜耶。答此于定慧有策持力故立为支。非于生长有增上用。是故非根

问何故于诸不相应行唯命立根。答唯命根有根义故。谓彼唯是有情数摄。唯是异熟。能遍任持故立为根。余皆不尔。所以者何。四有为相三义皆无。无想异熟无遍持义。其众同分非唯异熟。由彼亦通等流性故。二无心定。名句文身。得非得等。无后二义。故彼一切皆不立根

问若最胜义是根义者。涅槃于一切法中最胜。何不立根。答彼是诸根尽灭处故。根尽灭处不名为根。如瓶等坏处不名瓶等。有说。若法行世取果与果。有诸作用了知所缘。可立为根。涅槃不尔。有说。若法生灭有因有果有有为相。可立为根。涅槃不尔。有说。根者属因属缘和合而生。涅槃不尔。有说。若法为生所生。为老所老。为灭所灭。可立为根。涅槃不尔。有说。根者堕蕴堕世。众苦所随。涅槃不尔。有说。根者有前后相上中下相。涅槃不尔。有说。最胜是根义者。谓于有为中胜而有作用。涅槃乃于一切法中最胜。而无作用。故不立根。虚空非择灭不立根义。准此应知

说一切有部发智大毗婆沙论卷第一百四十三阿毗达磨大毗婆沙论卷第一百四十四

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    根蕴第 六 中根纳息第一之三

此二十二根。几学。几无学。几非学非无学。答二学。一无学。十非学非无学。九应分别。二学者。谓未知当知根已知根。一无学者。谓具知根。十非学非无学者。谓七色命苦忧根。九应分别者。谓意乐喜舍信等五根。此皆应作三分而答。故名应分别。一作学分。二作无学分。三作非学非无学分。分别论者言。此应作分别记。故名应分别。谓意根或学或无学或非学非无学。云何学。谓学作意相应意根。此复云何。谓从苦法智忍。乃至金刚喻定相应意根。云何无学。谓无学作意相应意根。此复云何。谓尽智。无生智。无学正见相应意根。云何非学非无学。谓有漏作意相应意根。此复云何。谓有三种。何等为三。谓善染污无覆无记。善复有三。谓加行得。离染得。生得。加行得者。复有三种。谓闻所成。思所成。修所成。闻思所成者。谓不净观。持息念。念住等相应。修所成者。谓暖顶忍世第一法。现观边世俗智。静虑无量无色解脱。胜处遍处等相应。离染得者。谓由离染时得。则静虑无量无色解脱。胜处遍处等相应。生得者。谓生时所得。善染污有二种。谓见所断。修所断。无覆无记有四。谓威仪路。工巧处。异熟生。及变化等。通果心如意根。乐根喜根舍根信根精进根念根定根慧根亦尔。然有差别。谓信等五。除染无记余随所应。问何故此中明意根等。唯说作意相应非余。答彼作论者意欲尔故。乃至广说。胁尊者曰。此不应问一切有疑。说余相应亦生疑故。但不违理随说无过。有说。作意顺生心胜故。谓相应法中顺生心者唯作意胜。如不相应中顺生法者唯有生相。是故偏说。有说。作意是警觉相。是牵引相。令意根等取所缘胜。是故偏说。有说。作意能生诸法胜于余法。是故偏说

已分别诸根学等自性。杂无杂相今当说。诸根学彼是学者根耶。答应作四句。有根学彼非学者根。谓学根学者不成就。此复云何。谓随信行不成就随法行诸根。随法行不成就随信行诸根。信胜解不成就见至诸根。见至不成就信胜解诸根。退法姓学不成就五姓学诸根。乃至不动法姓学不成就五姓学诸根。佛乘姓学不成就余二乘姓学诸根。乃至声闻乘姓学不成就余二乘姓学诸根。住苦法智忍位。不成就上学位诸根。乃至住道类智忍位。不成就上学位诸根。住学三果未上进位。不成就下上学位诸根。住上进位如应广说。有是学者根彼根非学。谓非学非无学根。学者成就。此复云何。谓诸学者生欲界。已得眼根不失。及生色界。彼成就眼根。已得者。谓钵罗奢佉位等。不失者。谓不失坏。如眼根。耳鼻舌根亦尔。生欲色界彼成就身根。女成就女根。男成就男根。生遍净及下。成就乐根。生欲界成就苦根。生极光净及下。成就喜根。未离欲染。成就忧根。意命舍根一切成就。生欲界未得无色界善心。彼成就欲色界信等五根。若得无色界善心。成就三界信等五根。生色界未得无色界善心。彼成就色界信等五根。若得无色界善心。成就色无色界信等五根。生无色界彼成就无色界信等五根。有根学彼亦学者根。谓学根学者成就。此复云何。谓随信行成就随信行诸根。随法行成就随法行诸根。信胜解成就信胜解诸根。见至成就见至诸根。退法姓学成就退法姓学诸根。乃至不动法姓学成就不动法姓学诸根。佛乘姓学成就佛乘姓学诸根。乃至声闻乘姓学成就声闻乘姓学诸根。住苦法智忍位成就苦法智忍位诸根。乃至住道类智忍位成就一切见道诸根。住学三果未上进位。各成就所住果所摄诸根。住上进位各成就所得果。及胜果道所摄诸根。有根非学彼亦非学者根。谓无学根及非学非无学根。学者不成就。此复云何。谓诸学者。定不成就无学诸根。及有非学非无学根。学者不成就。谓诸学者生欲界不得眼根。设得。而失。及生无色界彼不成就眼根。不得者。谓未至钵罗奢佉位等。设得而失者。谓已失坏。如眼根。耳鼻舌根亦尔。生无色界彼不成就身根。女不成就男根。男不成就女根。有俱不成。谓生色无色界。及生欲界。或本不得。或已得渐命终等舍。生遍净上不成就乐根。生色无色界不成就苦根。生极光净上不成就喜根。已离欲染不成就忧根。生欲界未得无色界善心。彼不成就无色界信等五根。生色界未得无色界善心。彼不成就欲无色界信等五根。生无色界彼不成就。欲色界信等五根

诸根无学。彼是无学者根耶。答应作四句。有根无学彼非无学者根。谓无学根。无学者不成就。此复云何。谓时解脱。不成就不时解脱诸根。不时解脱。不成就时解脱诸根。退法不成就五种诸根。乃至不动法不成就五种诸根。佛不成就独觉声闻诸根。独觉不成就佛声闻诸根。声闻不成就佛独觉诸根。有是无学者根彼根非无学。谓非学非无学根。无学者成就。此复云何。谓无学者生欲界。已得眼根不失。及生色界彼成就眼根。如眼根。耳鼻舌根亦尔。生欲色界彼成就身根。女成就女根。男成就男根。生遍净及下。成就乐根。生欲界成就苦根。生极光净及下。成就喜根。意命舍根一切成就。生欲界彼成就。三界信等五根。生色界彼成就色无色界信等五根。生无色界彼成就无色界信等五根。有根无学彼亦无学者根。谓无学根。无学者成就。此复云何。谓时解脱成就时解脱诸根。不时解脱成就不时解脱诸根。退法成就退法诸根。乃至不动法成就不动法诸根。佛成就佛诸根。独觉成就独觉诸根。声闻成就声闻诸根。有根非无学彼亦非无学者根。谓学根及非学非无学根。无学者不成就。此复云何。谓无学者定不成就学诸根。及有非学非无学根。无学者不成就。谓无学者生欲界。不得眼根。设得而失。及生无色界彼不成就眼根。如眼根。耳鼻舌根亦尔。生无色界彼不成就身根。女不成就男根。男不成就女根。有俱不成就。谓生色无色界。及生欲界。或本不得。或已得而失。生遍净上彼不成就乐根。生色无色界彼不成就苦根。生极光净上彼不成就喜根。定不成就忧根。生色界彼不成就欲界信等五根。生无色界彼不成就欲色界信等五根

诸根非学非无学。彼是非学非无学者根耶。答诸非学非无学者根。彼根非学非无学。所以者何。以成就学法即名学者。成就无学法即名无学者。若不成就学无学法。名非学非无学者。即是异生。彼所成就根唯是非学非无学故。有根非学非无学彼非非学非无学者根。谓非学非无学根。非学非无学者不成就。此复云何。谓诸异生生欲界未得眼根。设得而失。及生无色界彼不成就眼根。如眼根。耳鼻舌根亦尔。生无色界彼不成就身根。女不成就男根。男不成就女根。有俱不成。谓生色无色界。及生欲界。或本不得。或已得而失。生遍净上不成就乐根。生色无色界不成就苦根。生极光净上不成就喜根。离欲界染不成就忧根。断善根者不成就三界信等五根。生欲界不断善根。若未得色界善心。彼不成就色无色界信等五根。若得色界善心。未得无色界善心。彼不成就无色界信等五根。生色界若未得无色界善心彼不成就欲无色界信等五根。若得无色界善心。彼不成就欲界信等五根。生无色界彼不成就欲色界信等五根

已分别诸根学等。彼学等义今当说。问云何名学无学非学非无学耶。答以无贪道为断贪故。而学此道所摄法名学。以无贪道为断贪故。而不学已学故。此过所摄法名无学。与二相违名非学非无学。复次以无嗔道为断嗔故。而学此道所摄法名学。以无嗔道为断嗔故。而不学已学故。此道所摄法名无学。与二相违名非学非无学。复次以无痴道为断痴故。而学此道所摄法名学。以无痴道为断痴故。而不学已学。故此道所摄法名无学。与二相违。名非学非无学。复次以无爱道为断爱故而学。然非爱事。此道所摄法名学。以无爱道为断爱故而学者。此则遮无学道。然非爱事者。此则遮世俗道。以无爱道为断爱故。而不学已学故。然非爱事。此道所摄法名无学。以无爱道为断爱故。而不学已学故者。此则遮学道。然非爱事者。此则遮世俗道。与二相违名非学非无学。复次若道为断二求满一求故而学。此道所摄法名学。为断二求者。谓欲求有求。满一求者。谓梵行求。若道为断二求满一求故。而不学已学故。此道所摄法名无学。与二相违名非学非无学。复次若道为断烦恼。修谛现观故而学。此道所摄法名学。若道为断烦恼。修谛现观故。而不学已学故。此道所摄法名无学。与二相违名非学非无学。复次若所依中。有烦恼得随缚。有无漏得随逐。彼是学若所依中。无烦恼得随缚。有无漏得随逐。彼是无学。与二相违名非学非无学。复次若所依中。有爱随缚。有无漏得。彼是学。若所依中。无爱随缚。有无漏得。彼是无学。与二相违名非学非无学。复次若法见道修道所摄是学。若法无学道所摄是无学。与二相违是非学非无学。见地修地无学地说亦尔。复次若法未知当知根。已知根所摄是学。若法具知根所摄是无学。与二相违是非学非无学。复次五种补特伽罗相续中。诸无漏法是学。五种补特伽罗者。谓随信行。随法行。信胜解。见至。身证。二种补特伽罗相续中。诸无漏法是无学。二种补特伽罗者。谓慧解脱。俱解脱。与二相违是非学非无学。复次七种补特伽罗相续中。诸无漏法是学。七种补特伽罗者。谓四向前三果。一种补特伽罗相续中。诸无漏法是无学。一种补特伽罗者。谓阿罗汉果。与二相违名非学非无学。复次十八种补特伽罗相续中。诸无漏法是学。九种补特伽罗相续中。诸无漏法是无学。与二相违是非学非无学。此二十二根。几善。几不善。几无记。答八善。八无记六应分别。八善者。谓信等五三无漏根。八无记者。谓七色命根。六应分别者谓意五受。此复云何。谓意根或善。或不善。或无记。云何善。谓善作意相应意根。此有二种。谓有漏无漏。有漏有三。谓加行得。离染得。生得。无漏有二。谓学无学。云何不善。谓不善作意相应意根。此有二种。谓见所断。修所断。即欲界三十四随眠俱生作意相应意根。云何无记。谓无记作意相应意根。此有二种。谓有覆无记。无覆无记。有覆无记者。谓欲界有身见。边执见。及色无色界一切烦恼俱生作意相应意根。无覆无记者。谓威仪路。工巧处。异熟生。通果俱生作意相应意根。如意根。舍根喜根乐根随应亦尔。苦根或善。或不善。或无记。云何善。谓善作意相应苦根。此复云何。谓生得善。云何不善。谓不善作意相应苦根。此复云何。谓修所断。云何无记。谓无记作意相应苦根。此复云何。谓异熟生忧根。或善。或不善。云何善。谓善作意相应忧根。如说。我于何时当于是处得具足住。若于圣处已具足住。于上解脱希求思慕心怀忧戚。云何不善。谓不善作意相应忧根。此复云何。谓见所断。及修所断。问何故无有无记忧根。答无记有二。谓有覆无覆。忧根且非有覆无记。由与欲界有身见边执见不相应故。所以者何。行相异故。彼二见欢行相转。忧根戚行相转。互相违法不相应故。忧根亦非无覆无记。非威仪路工巧处异熟生所摄故。问何故忧根非威仪路所摄。答忧根分别转。威仪路无分别转。若威仪路有忧根者。设有分别。我今应作如是威仪。如佛世尊。或如马胜。即分别时。便应已住如是威仪。然威仪路无此分别。故威仪路无有忧根。问何故忧根非工巧处。答忧根分别转。工巧处无分别转。若工巧处有忧根者。设有分别。我今应作如是工巧。如佛世尊。或如妙业天子。即分别时已应成办如是工巧。然工巧处无此分别。故工巧处无有忧根。问何故忧根非异熟生。答忧根分别转异熟生无分别转。若异熟生有忧根者。设有分别。我今应受如是异熟。如佛世尊。或如转轮圣王。即分别时便应现受如是异熟。然异熟生无此分别故。异熟生无有忧根有说。忧根现加行。转异熟生先业所引。是故忧根非异熟生。有说。忧根随欲而转。以于一切亡失事中。有起忧根。有不起故。异熟生者不随欲受。由业转故。是故忧根非异熟生。有说。忧根若是异熟。则应重业但受少果。谓有因作无间业已便生忧悴。即应名为受彼异熟。岂非果少。有说。忧根离欲时舍。异熟生法离三界染而犹随转。是故忧根非异熟生。由此忧根唯善不善

已分别诸根善等。彼善等义今当说。问云何名善不善无记耶。答若法巧便所摄。能招爱果自性安隐。说名为善。巧便所摄者。显道谛。能招爱果者。显苦集谛少分。自性安隐者。显灭谛。若法不巧便摄。招不爱果性不安隐。说名不善。此则显示苦集谛少分。与二相违说名无记。有说。若法能得爱果及乐受果。说名为善。若法能得不爱果及苦受果。说名不善。与二相违说名无记。有说。若法能生爱有芽及解脱芽。说名为善。若法能生不爱有芽。说名不善。与二相违说名无记。有说。若法能感可爱趣。说名为善。若法能感不可爱趣。说名不善。与二相违说名无记。有说。若法堕还灭品清净品。是轻举性。说名为善。若法堕流转品杂染品。是沉重性说名不善。与二相违说名无记。胁尊者曰。由四缘故说名为善。一自性故。二相应故。三等起故。四胜义故。自性善者。有说。是惭愧。有说。是三善根。相应善者。是彼相应心心所法。等起善者。是彼所起身语业。心不相应行。胜义善者。谓涅槃安隐故名善。分别论者作如是言。自性善者。谓智。相应善者。谓彼相应识。等起善者。谓彼所起身语业。胜义善者。谓涅槃。由四缘故说名不善。一自性故。二相应故。三等起故。四胜义故。自性不善者。有说。是无惭无愧以一向不善遍不善心故。有说。是三不善根以具五义故。相应不善者。谓彼相应心心所法。等起不善者。谓彼所起身语业。心不相应行。胜义不善者。谓生死不安隐。故名不善。分别论者作如是言。自性不善者。谓痴。相应不善者。谓彼相应识。等起不善者。谓彼所起身语业。胜义不善者。谓生死。胁尊者言。若法是如理作意自性。如理作意相应。如理作意等起。如理作意等流果。离系果者。是善。若法是不如理作意自性。不如理作意相应。不如理作意等起。不如理作意等流果者。是不善。与二相违是无记。如如理作意。不如理作意。惭愧无惭无愧。三善根三不善根。信等五根五盖亦尔。集异门说。何故名善。答有可爱果。可乐果。适意果。悦意界。可欣尚果。名善。此说等流果。复次有可爱异熟。可乐异熟。适意异熟。悦意异熟。可欣尚异熟。名善。此说异熟果。与此相违是不善。与二相违是无记。余义如结蕴初纳息广说

此二十二根。几有异熟。乃至广说。问何故作此论。答欲止他宗显己义故。谓譬喻者说。离思无异熟因。离受无异熟果。为遮彼说显异熟因及异熟果俱通五蕴。饮光部说。诸异熟因。异熟未生彼因有体。异熟生已彼因便失。如芽未生种犹有体。芽既生已种体便无。欲止彼意显因恒有。复有外道。执善恶业无果异熟。亦遮彼意显善恶业有果异熟。故作斯论

此二十二根。几有异熟。几无异熟。答一有异熟。十一无异熟。十应分别。一有异熟者。谓忧根。十一无异熟者。谓七色命三无漏根。十应分别者。谓意四受信等五根。此复云何。谓意根。或有异熟。或无异熟。云何有异熟。谓不善善有漏意根。云何无异熟。谓无记无漏意根。如意根。乐根喜根舍根亦尔。苦根或有异熟。或无异熟。云何有异熟。谓善不善苦根。云何无异熟。谓无记苦根。信等五根。或有异熟。或无异熟。云何有异熟。谓有漏信等五根。云何无异熟。谓无漏信等五根已分别诸根有异熟等。彼有异熟等义今当说。问云何名有异熟等。为与自异熟俱故名有异熟。为与他异熟俱故名有异熟耶。若与自异熟俱故名有异熟者。如何因果不并。又违伽他所说。如说。作恶不即熟等若与他异熟俱故名有异熟者。则无漏道应名有异熟。与他异熟俱故。答应说与自异熟俱故名有异熟。问如何因果不并。及违伽他说耶。答有二种俱。一者有俱。二者并俱。有俱者。如有因有果。有所缘有异熟等。并俱者。如有寻有伺。有喜有作意等。此中依有俱而作论。如有俱并俱。有俱不相离俱亦尔。有说。有三种俱。一者远俱。二者近俱。三远近俱。前二如前。远近俱者如有漏有随眠有缘有事等。此中但依远俱作论。问何故名异熟。答异类而熟。故名异熟。熟有二种。一同类。二异类。同类熟者。谓等流果。异类熟者。谓异熟果。余如结蕴广说此二十二根几见所断。乃至广说。问何故作此论。答欲止他宗显己义故。如譬喻者说。无有世俗道能断烦恼。彼大德说。异生无有断随眠者。但能伏缠。亦非世俗道有永断义。由契经言。圣慧见已方能断故。为遮彼说。显世俗道亦能永断。诸异生类亦断随眠。故契经说。嗢达洛迦遏逻摩子。断欲断色。乃至断于无所有处。生于非想非非想处。又说。有外道仙能离欲染。如是等所言圣慧见已方能断者。显能究竟断有顶染。或有说言。诸世俗道虽能永断。但是异生而非圣者。非舍胜道用劣道故。为止彼意。显诸圣者亦以世俗道离八地染。有作是说。顿断非渐。金刚喻定现在前时。一切烦恼一时断故。为遮彼执显必渐断。四沙门果渐次得故。有执。现观唯顿非渐。为遮彼说显渐非顿。又为显示有二部结二部对治。故作斯论

此二十二根。几见所断。几修所断。几不断。答九修所断。三不断。十应分别。九修所断者。谓七色命苦根。三不断者。谓三无漏根。十应分别者。谓意四受信等五根。谓意根或见所断。或修所断。或不断。云何见所断。谓意根随信随法行。现观边忍所断。此复云何。谓见所断八十八随眠相应意根。云何修所断。谓意根学见迹修所断。此复云何。谓修所断十随眠相应意根。及不染污有漏意根。云何不断。谓无漏意根。如意根。舍根亦尔。乐根或见所断。或修所断。或不断。云何见所断。谓乐根随信随法行。现观边忍所断。此复云何。谓见所断二十八随眠相应乐根。即第三静虑见所断。云何修所断。谓乐根学见迹修所断。此复云何。谓修所断五随眠相应乐根。及不染污有漏乐根。五随眠者。谓欲界贪无明。色界贪慢无明

云何不断。谓无漏乐根。喜根或见所断。或修所断。或不断。云何见所断。谓喜根随信随法行。现观边忍所断。此复云何谓见所断五十二随眠相应喜根。五十二随眠者。谓欲界二十四。除嗔疑八。色界二十八。云何修所断。谓喜根学见迹修所断。此复云何。谓修所断六随眠相应喜根。及不染污有漏喜根。六随眠者。谓欲色界贪慢无明。云何不断。谓无漏喜根忧根。或见所断。或修所断。云何见所断。谓忧根随信随法行。现观边忍所断。此复云何。谓见所断十六随眠相应忧根。十六随眠者。谓欲界邪见嗔疑无明名四。云何修所断。谓忧根学见迹修所断。此复云何。谓修所断二随眠相应忧根。及不染污忧根。二随眠者。谓欲界嗔无明。信等五根或修所断。或不断。云何修所断。谓有漏信等五根。云何不断。谓无漏信等五根

已分别诸根见断等。彼见断等义今当说。问云何名见所断修所断耶。如见不离修修不离见。见道中如实修可得。修道中如实见可得。慧名为见。不放逸名修。此中说何名为如实。此中意说。偏多猛利名为如实。谓见道中慧多不放逸少。修道中不放逸多慧少。或复此中意说。平等名为如实。谓见道中随有尔所慧。即有尔所不放逸。修道中随有尔所不放逸。即有尔所慧。尊者世友作如是说。观四圣谛断诸烦恼。云何分别。此是见所断。此是修所断。答由见而断。由见而除。由见变吐。名见所断。有说。见所断亦应言修所断。以见道中如实修可得故。如是说者。由见而断。由见而除。由见变吐名见所断。如所得道。若习若修若多修习。分齐断。限量断。渐令薄究竟断。名修所断。有说。修所断亦应言见所断。以修道中如实见可得故。如是说者。如所得道。若习若修若多修习。分齐断。限量断。渐令薄究竟断。名修所断。问此言有何义。答此说见道。是猛利道暂现在前。九品烦恼一时而断。修道是不猛利道。数习现前九品烦恼九时而断。如利钝刀俱截一物。利者一割便断。钝者数割乃断。有说。若法以见增道断名见所断。若法以修增道断名修所断。有说。若法以二相道断名见所断。二相者。谓见相慧相。若法以三相道断名修所断。三相者。谓见智慧相。有说。若法以四相道断名见所断。四相者。谓眼明觉慧相。若法以五相道断名修所断。五相者。谓眼智明觉慧相。有说。若法由忍断名见所断。若法由智断名修所断。余广说如结蕴初纳息

说一切有部发智大毗婆沙论卷第一百四十四阿毗达磨大毗婆沙论卷第一百四十五

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    根蕴第六中根纳息第一之四

此二十二根几见苦所断乃至广说。问何故复作此论。答前门遮说顿断者意。而犹未遮说顿现观。又亦未显渐次现观。今欲遮显故作斯论。有说。前门亦遮顿现观亦显渐现观。但不明了。今欲令明了故作斯论。有说。所以作论者。欲分别五部烦恼五部对治。故造斯论。五部烦恼者谓见苦所断。乃至修所断。五部对治者。谓苦忍苦智。乃至道忍道智。此二十二根几。见苦所断。几见集所断。几见灭所断。几见道所断。几修所断。几不断。答九修所断。三不断。十应分别。九修所断者。谓七色命苦根。三不断者。谓三无漏根。十应分别者。谓意四受信等五根。谓意根或见苦所断。或见集见灭见道所断。或修所断。或不断。云何见苦所断。谓意根随信随法行苦现观边忍所断。此复云何。谓见苦所断二十八随眠相应意根。云何见集所断。谓意根随信随法行。集现观边忍所断。此复云何。谓见集所断十九随眠相应意根。云何见灭所断。谓意根随信随法行。灭现观边忍所断。此复云何。谓见灭所断十九随眠相应意根。云何见道所断。谓意根随信随所行道。现观边忍所断。此复云何。谓见道所断二十二随眠相应意根。云何修所断。谓意根学见迹修所断。此复云何。谓修所断十随眠相应意根及不染污有漏意根。云何不断。谓无漏意根。如意根。舍根亦尔。乐根或见苦所断。或见集见灭见道所断。或修所断。或不断。云何见苦所断。谓乐根随信随法行。苦现观边忍所断。此复云何。谓见苦所断九随眠相应乐根。云何见集所断。谓乐根随信随法行。集现观边忍所断。此复云何。谓见集所断六随眠相应乐根。云何见灭所断。谓乐根随信随法行。灭现观边忍所断。此复云何。谓见灭所断六随眠相应乐根。云何见道所断。谓乐根随信随法行。道现观边忍所断。此复云何。谓见道所断七随眠相应乐根。云何修所断。谓乐根学见迹修所断。此复云何。谓修所断五随眠相应乐根。及不染污有漏乐根。五随眠者。谓欲界贪无明。色界贪慢无明。云何不断。谓无漏乐根。喜根或见苦所断。或见集见灭见道所断。或修所断。或不断。云何见苦所断。谓喜根随信随法行。苦现观边忍所断。此复云何。谓见苦所断十七随眠相应喜根。十七随眠者。谓欲界除嗔疑。色界一切。云何见集所断。谓喜根随信随法行集现观边忍所断。此复云何。谓见集所断十一随眠相应喜根。云何见灭所断。谓喜根随信随法行。灭现观边忍所断。此复云何。谓见灭所断十一随眠相应喜根。云何见道所断。谓喜根随信随法行。道现观边忍所断。此复云何。谓见道所断十二随眠相应喜根。云何修所断。谓喜根学见迹修所断。此复云何。谓修所断六随眠相应喜根。及不染污有漏喜根。六随眠者。谓欲界除嗔。色界一切。云何不断。谓无漏喜根。忧根或见苦所断。或见集见灭见道所断。或修所断。云何见苦所断。谓忧根随信随法行。苦现观边忍所断。此复云何。谓见苦所断四随眠相应忧根。四随眠者。谓欲界邪见嗔疑无明

云何见集所断。谓忧根随信随法行。集现观边忍所断。此复云何。谓见集所断四随眠相应忧根。云何见灭所断。谓忧根随信随法行灭现观边忍所断。此复云何。谓见灭所断四随眠相应忧根。云何见道所断。谓忧根随信随法行道现观边忍所断。此复云何。谓见道所断四随眠相应忧根。云何修所断。谓忧根学见迹修所断。此复云何。谓修所断二随眠相应忧根及不染污忧根。二随眠者。谓欲界嗔无明。信等五根或修所断。或不断。云何修所断。谓有漏信等五根。云何不断。谓无漏信等五根

已分别诸根见苦所断等。彼见苦所断等义今当说。问云何名见苦所断。乃至修所断耶。答若法对治。决定对治。所缘决定。名见苦所断。乃至见道所断。若法对治不决定。对治所缘不决定。名修所断。有说。若法处所决定对治。所缘决定。名见苦所断乃至见道所断。若法处所不决定对治。所缘不决定。名修所断。有说。若法苦忍苦智为对治。名见苦所断。乃至若法道忍道智为对治名见道所断。若法诸智为对治。名修所断。有说。若法苦忍所断。名见苦所断。乃至若法道忍所断。名见道所断。若法诸智所断。名修所断。有说。若法观苦谛所断。名见苦所断。乃至若法观道谛所断。名见道所断。若法或观苦谛。或观集灭道谛。或不观谛所断。名修所断。有说。若法与见苦谛相违。名见苦所断。乃至若法与见道谛相违。名见道所断。若法与见四谛相违。名修所断

此二十二根。几见。几非见。乃至广说。问何故作此论。答欲止说一切法皆是见性者意。彼作是说。所作猛利说名为见。一切法无不皆于自事猛利故悉名见。为遮彼执。显诸法中唯眼根及慧少分名见非余。故作斯论

此二十二根。几见。几非见。答一见。十七非见。四应分别。一见者。谓眼根。十七非见者。谓六色命意五受信等四根。四应分别者。谓慧三无漏根。慧根或见。或非见。云何见。谓尽智无生智所不摄意识相应慧根。云何非见。谓余慧根即五识相应慧根。及尽智无生智所摄慧根。未知当知根。或见或非见。云何见。谓未知当知根所摄慧根。云何非见。谓未知当知根所摄余根。即余八根。如未知当知根。已知根亦尔。具知根或见或非见。云何见。谓尽智无生智所不摄具知根所摄慧根。云何非见。谓具知根所摄余根。即余八根。及尽智无生智所摄慧根

已分别诸根见等。彼见等义今当说。问何故名见见是何义。答由四缘。故名见。一能观故。二推决故。三坚执故。四深入所缘故。能观故者。谓见自性。问邪见颠倒见。彼何所观。答是故说见自性。谓虽邪颠倒见。而是见慧自性。故说能观。如人随有所见即名能观。非如盲者。推决定者。谓能推求决定。问一刹那顷如何推求。答性猛利故说名推求。坚执故者。谓诸见趣僻执坚牢。非圣道力无由令舍。深入所缘者。谓于境猛入。如针堕埿。有说。由二缘故名见。一照了性故。二推度性故。有说。由三缘故名见。一有见相故。二成见事故。三于境无碍故。有说。由三缘故名见。一意乐故。二执着故。三推决故。有说。由三缘故名见。一意乐故。二加行故三无智故。意乐故者。谓意乐坏者。加行故者。谓加行坏者。无智故者。谓俱坏者。复次意乐故者。谓修定者。加行故者。谓寻思者。无智故者。谓随闻者

此二十二根。几有寻有伺。乃至广说。问何故作此论。答欲止譬喻者所说故。彼说从欲界乃至有顶。皆有寻伺。所以者何。契经说故。如契经说。心粗性是寻。心细性是伺。心粗细性乃至有顶。彼大德说曰。对法诸师说。寻伺是心粗细性。此粗细性相待而立。乃至有顶皆现可得。而说寻伺唯在欲界。及梵世有。此是恶说非为善说。阿毗达磨诸论师言。我等善说非为恶说。以依多门说粗细性非是一种。如说。缠粗随眠细。此中寻伺非粗非细。以俱非缠随眠性故。如说。色蕴粗四蕴细。此中寻伺俱是其细。以俱摄在行蕴中故。如说。欲界粗初静虑细。此中寻伺俱通粗细以二俱通二地摄故。如说。初静虑粗第二静虑细。此中寻伺俱是其粗。以依多门说粗细性。故寻与伺非至有顶。若说寻伺至有顶者。应不说有三地差别。譬喻者言。始从欲界乃至有顶。皆有善染无记三法。一切地染法皆名有寻有伺。唯善无记有三地别。若尔。何故说寻伺灭无寻无伺。定生喜乐入第二静虑。彼言。此依善寻伺说。不说染污。此说不然。何缘乃说灭善寻伺非灭染污。而应先灭染污寻伺。以离染时必断彼故。以越界地方舍于善故。譬喻者真为恶说。欲止彼意显寻与伺唯在二地。故作斯论

此二十二根几有寻有伺。几无寻唯伺。几无寻无伺。答二有寻有伺。八无寻无伺。十二应分别。二有寻有伺者。谓苦忧根。八无寻无伺者。谓七色命根。十二应分别者。谓意。三受。信等五。三无漏根。意根或有寻有伺。或无寻唯伺。或无寻无伺。云何有寻有伺。谓有寻有伺作意相应意根。此复云何。谓欲界初静虑意根。云何无寻唯伺。谓无寻唯伺作意相应意根。此复云何。谓静虑中间意根

云何无寻无伺。谓无寻无伺作意相应意根。此复云何。谓从第二静虑乃至非想非非想处意根

如意根。舍根信等五根三无漏根亦尔。乐根或有寻有伺。或无寻无伺。云何有寻有伺。谓有寻有伺作意相应乐根。此复云何。谓欲界初静虑乐根。云何无寻无伺。谓无寻无伺作意相应乐根。此复云何。谓第三静虑乐根。如乐根。喜根亦尔。然有差别。谓第二静虑喜根名无寻无伺

已分别诸根有寻有伺等。彼有寻有伺等义今当说。问云何名有寻有伺。无寻唯伺。无寻无伺耶。答若法与寻伺俱。寻伺相应。寻伺等起。寻伺俱转。名有寻有伺。若法不与寻俱。唯与伺俱。寻不相应。唯伺相应。非寻等起。唯伺等起。寻已息灭。唯伺俱转。名无寻唯伺。若法不与寻伺俱。非寻伺相应。非寻伺等起。寻伺已息名无寻无伺。有说。若法有寻求。有伺察。名有寻有伺。若法无寻求。有伺察。名无寻唯伺。若法无寻求无伺察。名无寻无伺

此二十二根。几乐根相应。乃至广说。问何故作此论。答欲止他宗显己义故。如譬喻者说心心所次第而生。彼大德言。心心所法一一而起。如经狭路。尚无二并。何况有多。或复有说。若法由彼力起即说与彼相应非余。谓心能生心及心所故。心心所与心相应。心所唯能生于心所故。诸心所亦互相应。心所不能生于心故。不说心与心所相应。或复有执。诸法唯与自体相应。彼作是言。遍和合义是相应义。更无余遍和合。如自体于自体者。故说自体相应非他。有执。诸法自体于自体非相应非不相应。非相应者不自观故。非不相应者遍和合故。为止如是种种异说。显心心所俱时而生展转相应。非于自体唯望他说。故作斯论此二十二根几乐根相应。几苦根相应。几喜根相应。几忧根相应。几舍根相应。答乐根喜根舍根九根少分相应。苦根忧根六根少分相应。乐喜舍根九根少分相应者。谓意信等五根三无漏根。问云何乐喜舍与此九少分相应耶。答意根信等五根通与五受相应。此中但取三受相应故言少分。三无漏根多法为性。今除受体与余相应故言少分。苦根忧根六根少分相应者。谓意信等五根。问云何苦忧与此六少分相应耶。答此六根与五受相应。此中但取忧苦相应故言少分。问何故但问与受相应。不问余心心所耶。答是作论者意欲尔故。随彼意欲而作论。但不违法相。便不应责。有说。一切法皆归趣受是以问之。有说。一受有多根相。谓于一受分为五根余法不尔。故唯问受。有说。诸受成就不相违。现行相违。是以偏问。成就不相违者。谓一有情成就五受。现行相违者。谓一有情一刹那中。不能起二。何况起多。有说。以受是缘起轮毂。是以偏问。有说。除受更欲问何。若问信等五根三无漏根。彼唯是善。非与一切有相应义。若问命等八根。彼唯无记又不相应。问若尔。何故不问意根。答本由意根立相应法。不可还问与意相应。是故此中唯问与受相应之义。五受自性非自相应故。复唯以余法问受。已分别诸根与受相应。彼相应义今当说。问何故名相应。相应是何义。答等义是相应义。问诸心品中。心所法有多有少云何名等。谓欲界多色界少。色界多无色界少。善多不善少。不善多无记少。有覆无记多无覆无记少。云何等义是相应义。答以事等故说名为等。谓一心品中。若有二受。一想等者可说非等。然一心品中如受有一。想等亦尔。故名为等。有说。五种等义是相应义。谓所依等。所缘等。行相等。时等。事等。余广说如结蕴初纳息此二十二根。几欲界系。乃至广说。问何故作此论。答欲止他宗显己义故。谓或有执色界有男女根。彼作是言。有色身处皆有女男二根可得。为止彼意显女男根唯欲界有。故作斯论。复有说言。乐根苦根五地可得。谓欲界四静虑。彼说有身皆有苦乐。为遮彼执。显苦根唯欲界有。乐根唯三地有。故作斯论。或复有说。喜根忧根九地可得。谓从欲界乃至有顶。彼说有心皆有忧喜。三界九地皆有心故。又欲界身不净可厌。尚于合时生喜。离时生忧。况上界中身极净妙犹如灯焰。心无娆浊如清凉池。而于离合得无忧喜。为遮彼执。显忧唯欲界。喜至第二静虑。上地俱无。故作斯论

此二十二根。几欲界系。几色界系。几无色界系。几不系。答四欲界系。三不系。十五应分别。四欲界系者。谓女男苦忧根。三不系者。谓三无漏根。十五应分别者。谓五色命意三受信等五根。眼根或欲界系。或色界系。云何欲界系。谓欲界系大种所造眼根。云何色界系。谓色界系大种所造眼根。如眼根。耳鼻舌身根亦尔。命根或欲界系。或色界系。或无色界系。云何欲界系。谓欲界系寿。云何色界系。谓色界系寿。云何无色界系。谓无色界系寿。意根或欲界系。或色界系。或无色界系。或不系。云何欲界系。谓欲界系作意相应意根。云何色界系。谓色界系作意相应意根。云何无色界系。谓无色界系作意相应意根。云何不系。谓无漏作意相应意根。如意根。舍根信等五根亦尔。乐根或欲界系。或色界系。或不系。云何欲界系。谓欲界系作意相应乐根。云何色界系。谓色界系作意相应乐根。云何不系。谓无漏作意相应乐根。如乐根。喜根亦尔

问何故色界无男女根。答非其田非其器。乃至广说。有说。为欲弃舍男女根故。修诸静虑往色界生。若彼亦有男女根者。则应无有求生彼界。若法下地所有上地亦有者。应不施设有渐次灭法。若无渐次灭法。亦应无毕竟灭法。以渐次灭法能引毕竟灭法故。若无毕竟灭法应无解脱。若无解脱。应无出离。勿有如斯众多过失故。于色界无男女根。有说。女男二根段食所引。如契经说。劫初时人无女男根形相不异。后食地味男女根生。由此便有男女相异。色界离段食故无此二根。有说。男女二根欲界有用。非于色界。是故彼无。问鼻舌二根于彼无用。云何得有。答鼻舌二根于彼有用。令端严故。非女男根有端严义。可惭鄙故。问色界天众为女为男。若尔何失。若是女者应有女根。若是男者应有男根。若非二者便违经说。如说。女身不得作梵王等而不遮男。答应作是说。彼皆是男。问岂不彼类不成就男根耶。答虽无男根而有余丈夫相。又能离染。故说为男。如契经中说。诸果向皆名丈夫。非无女人行向住果。当知亦以能离染故说为丈夫。毗柰耶中亦作是说。佛以两手捧大生主骨。告苾刍众。汝等谛听。一切女人其性轻转。多诸嫉妒谄媚悭贪。唯大生主虽是女人。而离一切女人过失。作丈夫所作。得丈夫所得。我说是辈名为丈夫。色界诸天理亦应尔。能离染故说为丈夫。由此应作四句分别。有是男子不成就男根。谓色无色天大生主等。有成就男根而非男子。谓二形是。有是男子亦成就男根。谓一切丈夫成就男根者。有非男子亦不成就男根。谓除前相。诸是女者必成就女根。有成就女根而非是女。谓二形者。若依所引毗柰耶义。女亦四句应推广说。问何故上界无忧苦根。答非田非器。乃至广说。有说。为欲弃舍忧苦根故。修诸静虑往色界生。若彼亦有忧苦根者。则应无有求生彼界。若法下地所有上地亦有者。应不施设有渐次灭法。广说如前。勿有斯过。故上界无忧苦根。有说。何故忧苦根色界无者。以是欲界不共过失故。诸界地中各有不共功德过失。欲界过失者。谓苦根等。功德者。谓能入见道等。上界功德过失。随地应广说。有说。欲界是过失界。由是过失界故虽殊胜身亦犹有苦。如佛独觉声闻轮王。上界是功德界。由是功德界故。虽下劣身亦无有苦。如遇恶岁虽有美稼不能无灾。若逢善岁虽诸秽草亦无灾及。欲界上界应知亦尔。所以上界亦无忧者。以诸忧根离欲舍故。又是重无知等流果故。生上界者离重无知。是故忧根于彼非有

已分别诸根欲界系等。彼欲界系等义今当说。问云何名欲界系。色界系。无色界系耶。答若法系在欲界名欲界系。系在色界名色界系。系在无色界名无色界系。如牛系在柱等名柱等系。或有说者。若法系属欲界足名欲界系。系属色无色界足名色无色界系。足名烦恼。如说。佛无边所行无足。谁将去如人有足能往四方。若无足者则不能往。如是若有烦恼足者。能往诸界诸趣诸生生死流转。无烦恼足则不能往。或有说者。若法为欲界生死缚所系。名欲界系。为色无色界生死缚所系。名色无色界系。或有说者。若法为欲界阿赖耶所藏。摩摩异多所执。名欲界系。为色无色界阿赖耶所藏。摩摩异多所执。名色无色界系。阿赖耶者谓爱。摩摩异多者谓见。或有说者。若法为欲界爱所润。见执为我我所。名欲界系。为色无色界爱所润。见执为我我所。名色无色界系。或有说者。若法欲界乐欲所合。名欲界系。色无色界乐欲所合。名色无色界系。乐名为爱。欲名为见。或有说者。若法为欲界垢所垢。毒所毒。秽所秽。名欲界系。为色无色界垢所垢。毒所毒。秽所秽。名色无色界系。此中一切烦恼名秽。非但说嗔

说一切有部发智大毗婆沙论卷第一百四十五阿毗达磨大毗婆沙论卷第一百四十六

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    根蕴第六中根纳息第一之五

此二十二根。几因相应。乃至广说。问何故作此论。答欲止说因缘法非实有者意。显因缘法决定实有。亦为遮止愚于相应执相应法非实者意。令知相应是实有故。而作斯论。于此义中。有说。依一因作论。谓相应因。由此中说相应言故。依彼意趣释此文者。此二十二根。几因相应。答十四。谓意五受信等五三无漏根。此是相应因自体。根与相应因自体法相应故。名因相应。几因不相应。答八。谓七色命根。问此八既非相应因体。如何乃说因不相应。答此八虽非相应因体。而与相应因体不相应故。说为因不相应。斯有何失。几因相应因不相应。答即前十四少分因相应。少分因不相应。少分因相应者。谓自性于他性少分因不相应者。谓自性于自性。几非因相应。非因不相应。答即前十四少分。非因相应。少分非因不相应少分非因相应者。谓自性于自性。少分非因不相应者。谓自性于他性。有说。此中依二因作论。谓相应因俱有因。由此二因恒与彼法不相离故。依彼意趣释此文者。此二十二根。几因相应。答十四。此是二因自体。根与二因自体法相应故。名因相应。后三问答如前应知。有说此中依三因作论。谓相应因。俱有因。同类因。由此三因通三性故。有说。此中依四因作论。谓除同类遍行二因。由此四因通三世故。有说。此中依五因作论。谓除能作因。以通无为非亲胜故。有说。此中依六因作论。由此所说因言总故。然相应法或作六因自体。或作五因自体。或作四因自体。如大种蕴广说。依彼意趣释此文者。此二十二根。几因相应。答十四。谓六因自体。根与六因自体法相应。五因自体。根与五因自体法相应。四因自体。根与四因自体法相应故名因相应。后三问答如前应知

此二十二根。几缘有缘。乃至广说。问何故作此论。答欲止说所缘缘非实者意。显所缘缘是实有故。而作斯论。此二十二根。几缘有缘。答十三少分。谓意乐喜忧舍信等五三无漏根少分。有所缘法为此所缘。故说此为缘有缘句。如明眼者见明眼人。彼明眼人复有所见。缘有缘句应知亦尔。几缘无缘。答一十三少分。一者谓苦根。十三少分者。如前说。无所缘法为此所缘。故说此为缘无缘句。如明眼者见生盲人。彼生盲人更无所见。缘无缘句当知亦尔。几缘有缘缘无缘。答即前十三少分。有所缘无所缘法。为此所缘。故说此为缘有缘缘无缘句。如明眼者见明眼人及生盲人。彼明眼人复有所见。彼生盲人更无所见缘有缘缘无缘句。应知亦尔。有余谓。此第三句义。即合初二更无异体。此说不然。与本论相违故。如十门说。缘有缘法是有为缘随眠随增。缘无缘法是一切随眠随增。缘有缘缘无缘法。是有为缘随眠随增。非缘有缘非缘无缘法。是有漏缘随眠随增。然有意识并相应法。一刹那顷总缘有缘及无缘法。是故如前所说为善。几非缘有缘非缘无缘。答八。谓七色命根。由此不缘有所缘无所缘法。故说此为非缘有缘非缘无缘句。如生盲人。都无所见。此句亦尔

此中略示二十二根。缘有缘等四句差别十门所说。十八界等亦应以此四句分别。谓十八界中十色界为第四句。五识界为第二句。意界意识界为前三句。法界具为四句。十二处中十色处为第四句。意处为前三句。法处具为四句。五蕴中色蕴为第四句。受想识蕴为前三句。行蕴具为四句。如蕴取蕴亦尔。六界中五色界为第四句。识界为前三句。有色法。可见法。有对法。无为法。灭谛。为第四句。无色法。无见法。无对法。有漏法。无漏法。有为法。过去未来现在法。善不善无记法。欲色无色界系法。学无学非学非无学法。见修所断不断法。苦集道谛。静虑无色。皆具为四句。四无量中。若取自性。缘住同分心有情。则为第三句。若缘不住同分心有情。则为第二句。若并取相应随转。缘住同分心有情。则为第三第四句。若缘不住同分心有情。则为第二第四句。初三解脱八胜处前八遍处。若取自性为第二句。若并取相应随转。则为第二第四句。灭受想解脱为第四句。余四解脱具为四句。后二遍处为第三第四句。灭智无相等持为第二句。他心智为初句。余六智二等持为前三句。诸门烦恼中。五识相应者为第二句。意识相应者为前三句。是中差别应思。广说诸根此法彼根异生耶。设根异生彼根此法耶。答诸根此法彼根非异生。诸根异生彼根非此法。问何谓此法。何谓异生。答此法谓圣者。异生即异生。诸根此法彼根非异生者。谓诸无漏根唯圣者成就。非诸异生。诸根异生彼根非此法者。谓见所断根。唯异生成就非诸圣者。有说。此法者。谓住苦法智忍。异生者。谓住世第一法。诸根此法彼根非异生者。谓苦法智忍俱生诸根。唯住苦法智忍者现起。非住世第一法者。诸根异生彼根非此法者。谓世第一法俱生诸根。唯住世第一法者现起。非住苦法智忍者。有说。此法者。谓住律仪。异生者。谓住不律仪。诸根住律仪者所起。彼根非住不律仪者所起。诸根住不律仪者所起。彼根非住律仪者所起。有说。此法者。谓不缺根。异生者。谓缺根。如扇搋半择迦无形二形等。诸根不缺根者所起。彼根非缺根者所起。诸根缺根者所起。彼根非不缺根者所起。有说此法者。谓不断善根。异生者。谓断善根。诸信等根不断善者所起。彼根非断善者所起。诸邪见俱生根。断善者所起。非不断善者所起。有说。此法者。谓住正定聚。异生者。谓住邪定聚。诸住正定聚者所起根。彼根非住邪定聚所起。诸住邪定聚者所起根。彼根非住正定聚者所起。有说。此法者。谓住五净居。异生者。谓住五异生处。诸住五净居者所起根。彼根非住五异生处者所起。诸住五异生处者所起根。彼根非住五净居者所起。色蕴摄几根。答七。谓眼等七色根。受蕴摄几根。答五三少分。五者。谓五受根。三少分者。谓三无漏根少分。以三无漏根九法为体。此唯摄三。故言少分。想蕴摄几根。答无想非根故。行蕴摄几根。答六三少分。六者。谓命信等五根。三少分者。谓三无漏根少分。以三无漏根九法为体。此唯摄五故言少分。识蕴摄几根。答一三少分。一者。谓意根。三少分者。谓三无漏根少分。以三无漏根九法为体。此唯摄一故言少分。善根几界几处几蕴摄。答八界二处三蕴。八界者。谓七心界法界。二处者。谓意处法处。三蕴者。谓受蕴行蕴识蕴。唯摄善根有几界几处几蕴。答无。不善根几界几处几蕴摄。答八界二处二蕴。八界者。谓七心界法界。二处者。谓意处法处。二蕴者。谓受蕴识蕴。唯摄不善根有几界几处几蕴。答无。有覆无记根。几界几处几蕴摄。答六界二处二蕴。六界者。谓眼识界耳识界身识界意界意识界法界。二处者。谓意处法处。二蕴者。谓受蕴识蕴。唯摄有覆无记根。有几界几处几蕴。答无。无覆无记根。几界几处几蕴摄。答十三界七处四蕴。十三界者。谓内十二界。及法界。七处者。谓内六处。及法处。四蕴者。谓除想蕴。唯摄无覆无记根。有几界几处几蕴。答五界五处。非蕴。五界者。谓眼等五色根界。五处者。谓眼等五色根处。非蕴者。谓无蕴。唯无覆无记故根法几界几处几蕴摄。答十三界七处四蕴。十三界者。谓内十二界。及法界。七处者。谓内六处。及法处。四蕴者。谓除想蕴。唯摄根法。有几界几处几蕴。答十二界六处二蕴。十二界者。谓内十二界。六处者。谓内六处。二蕴者。谓受蕴识蕴。非根法几界几处几蕴摄。答六界六处三蕴。六界者。谓外六界。六处者。谓外六处。三蕴者。谓色蕴想蕴行蕴。唯摄非根法。有几界几处几蕴。答五界五处一蕴。五界者。谓外五色界。五处者。谓外五色处。一蕴者。谓想蕴。根非根法。几界几处几蕴摄。答十八界十二处五蕴。唯摄根非根法。有几界几处几蕴。答一界一处二蕴。一界者。谓法界。一处者。谓法处。二蕴者。谓色蕴行蕴。颇根为缘生根耶。乃至广说。有说。此中有一标一释一广释。如说。颇根为缘生根耶等。是标。颇眼根为缘生眼根耶等。是释。眼根与眼根为几缘等。是广释。有说。此中有三标三释三广释。如说。颇根为缘生根耶是标。答生。是释。生非根耶等。是广释。颇眼根为缘生眼根耶。是标。答生。是释。生耳根乃至生具知根耶等。是广释。眼根与眼根为几缘。是标。答因增上。是释。乃至与具知根为所缘增上等。是广释。有说。此中有三标三释。如说。颇根为缘生根耶等。是标。答生等。是释颇眼根为缘生眼根耶等。是标。答生等。是释。眼根与眼根为几缘等。是标。答因增上等。是释

颇根为缘生根耶。答生云何生。答如眼为所依。生意三受信等五根。或眼为所缘。生意四受信等五三无漏根。颇根为缘生非根耶。答生。云何生。答如眼为所依。生想思触作意等。或眼为所缘。生想思触作意。及恶作睡眠等。颇根为缘生根非根耶。答生。云何生。答如眼为所依。生意三受信等五根想思触作意等。或眼为所缘。生意四受信等五三无漏根想思触作意等。及恶作睡眠等。颇非根为缘生非根耶。答生。云何生。答如色为所缘。生想思触作意等。及恶作睡眠等。颇非根为缘生根耶。答生。云何生。答如色为所缘。生意五受信等五三无漏根。颇非根为缘。生根非根耶。答生。云何生。答如色为所缘。生意五受信等五三无漏根想思触作意等。及恶作睡眠等。颇根非根为缘。生根非根耶。答生。云何生。答如眼为所依。色为所缘。生意三受信等五根想思触作意等。颇根非根为缘生根耶。答生。云何生。答如眼为所依。色为所缘。生意三受信等五根。颇根非根为缘。生非根耶。答生。云何生。答如眼为所依。色为所缘。生想思触作意等有余于此作第二文。颇根为缘唯生根耶。答不生。由此根亦生非根故。颇根为缘唯生非根耶

答不生。由此根亦生根故。颇根为缘唯生根非根耶。答生。云何生。答如眼为所依。生意三受信等五根想思触作意等。颇非根为缘。唯生非根耶。答不生。由此非根亦生根故。颇非根为缘。唯生根耶。答不生。由此非根亦生非根故。颇非根为缘。唯生根非根耶。答生。云何生。答如色为所缘。生意五受信等五三无漏根想思触作意等。及恶作睡眠等。颇根非根为缘。唯生根非根耶。答生。云何生。答如眼为所依。色为所缘。生意三受信等五根想思触作意等。颇根非根为缘。唯生根耶。答不生。由此根非根亦生非根故。颇根非根为缘。唯生非根耶。答不生。由此根非根亦生根故

有余于此作第三文。颇唯根为缘生根耶。答不生。由此根亦缘非根生故。颇唯根为缘生非根耶。答不生。由此非根亦缘非根生故。颇唯根为缘生根非根耶。答不生。由此根非根亦缘非根生故。颇唯非根为缘生非根耶。答不生。由此非根亦缘根生故。颇唯非根为缘生根耶。答不生。由此根亦缘根生故。颇唯非根为缘生根非根耶。答不生。由此根非根亦缘根生故。颇唯根非根为缘。生根非根耶。答生。广说如上。颇唯根非根为缘生根耶。答生。广说如上。颇唯根非根为缘生非根耶。答生。广说如上

颇眼根为缘生眼根耶。答生。云何生。答谓不碍生。及唯无障。颇眼根为缘生耳根乃至具知根耶。答生。云何生。答如眼为所依。生意三受信等五根。或眼为所缘。生意四受信等五三无漏根。或谤眼根堕诸恶趣。受诸色根命根意根苦根异熟。或信眼根生诸善趣。受诸色根命根意根乐根喜根舍根异熟。是名眼根为缘生耳根乃至具知根。如眼根。耳鼻舌身女男命根亦尔。然有差别。谓女男根。非苦根信等五根所依。命根非一切根所依。颇意根为缘生意根耶。生眼根。乃至具知根耶。答生。云何生。答如意根为所依。生意五受信等五三无漏根。或意根为所缘。生意四受信等五三无漏根。或谤意根堕诸恶趣。受诸色根命根意根苦根异熟。或信意根。生诸善趣。受诸色根命根意根乐根喜根舍根异熟。又意根有善不善。善者于善趣受诸色根命根意根乐根喜根舍根异熟。不善者。于恶趣受诸色根命根意根苦根异熟。如意根。五受根信等五根亦尔。然有差别。谓一切非所依。苦根于自非所缘。信等五根非不善。颇未知当知根为缘。生未知当知根耶。生眼根乃至具知根耶。答生。云何生。答如未知当知根为所依。生未知当知已知意三受信等五根。或未知当知根为所缘。生意四受信等五三无漏根。或谤未知当知根。堕诸恶趣。受诸色根命根意根苦根异熟。或信未知当知根。生诸善趣。受诸色根命根意根乐根喜根舍根异熟。如未知当知根。已知根具知根亦尔。然有差别。谓已知根为所依。生已知根具知根意根三受信等五根。具知根为所依。生具知根意根三受信等五根。问眼根与眼根为几缘。与耳根乃至具知根为几缘。乃至具知根与具知根为几缘。与眼根乃至已知根为几缘。答眼根与眼根。为因增上。因者一因。谓同类因。增上者。谓不碍生及唯无障。后增上义皆同此说。与余色根命根苦根为一增上。与余根为所缘增上。余根者。谓意四受信等五三无漏根。如眼根。耳鼻舌根亦尔。身根与身根女根男根。为因增上。因者一因。谓同类因。与余色根命根苦根。为一增上。与余根为所缘增上。余根者。如前说。女根与女根身根。为因增上。因者一因。谓同类因。与余色根命根苦根。为一增上。与余根为所缘增上。余根者。如前说。如女根。男根亦尔。命根与命根为因增上。因者一因。谓同类因。与七色根苦根。为一增上。与余根为所缘增上。余根者。如前说。意根与意根。为因等无间所缘增上。因者三因。谓同类遍行异熟因。等无间者。谓意根等无间。意根现在前。所缘者。谓意根与意根为所缘。诸等无间。及所缘义。皆准此说。与七色根命根。为因增上。因者一因。谓异熟因。与苦根为因等无间增上。非所缘。因者五因。谓相应俱有同类遍行异熟因。等无间者。谓意根等无间苦根现在前。非所缘者。苦根缘色。意根非色故。与余根为因等无间所缘增上。余根者。谓乐喜舍忧信等五三无漏根。此依具缘等故总说。然因有异。谓与乐喜舍根为五因。即相应等五。与忧根为四因。除异熟因。与信等五根三无漏根为三因。即相应俱有同类因。如意根。乐根喜根舍根信等五根亦尔。当知此依缘数等故总相而说。然以因缘有差别故。恐文隔远。今具分别。谓乐根与乐根。为因等无间所缘增上。因者三因。即同类遍行异熟因。与七色命根。为因增上。因者一因。即异熟因。与意根为因等无间所缘增上。因者五因。即相应等五。与苦根为因等无间增上。非所缘。因者二因。即同类异熟因。非所缘者。苦根缘色。乐根非色故。与喜根为因等无间所缘增上。因者二因。即同类异熟因。与忧根为因等无间所缘增上因者一因。即同类因。与舍根为因等无间所缘增上。因者三因。即同类遍行异熟因。与信等五根三无漏根。为因等无间所缘增上。因者三因。即相应俱有同类因。喜根与喜根。为因等无间所缘增上。因者三因。即同类遍行异熟因。与七色根命根。为因增上。因者一因。即异熟因。与意根。为因等无间所缘增上。因者五因。即相应等五。与乐根。为因等无间所缘增上。因者三因。即同类遍行异熟因。与苦根。为因等无间增上。非所缘。因者三因。即同类遍行异熟因。与忧根。为因等无间所缘增上。因者二因。即同类遍行因。与舍根。为因等无间所缘增上。因者三因。即同类遍行异熟因。与信等五根三无漏根。为因等无间所缘增上。因者三因。即相应俱有同类因。舍根与舍根。为因等无间所缘增上。因者三因。即同类遍行异熟因。与七色根命根。为因增上。因者一因。即异熟因。与意根。为因等无间所缘增上。因者五因。即相应等五。与乐根喜根。为因等无间所缘增上。因者三因。即同类遍行异熟因。与苦根。为因等无间增上。非所缘。因者三因。即同类遍行异熟因。与忧根。为因等无间所缘增上。因者二因。则同类遍行因。与信等五根三无漏根。为因等无间所缘增上。因者三因。即相应俱有同类因信根与信根。为因等无间所缘增上。因者一因。即同类因。与七色根命根。为因增上。因者一因。即异熟因。与意根乐根喜根舍根。为因等无间所缘增上。因者四因。除遍行因。与苦根为因等无间增上。非所缘。因者三因。即相应俱有同类因。与忧根。为因等无间所缘增上。因者三因。即相应俱有同类因。与精进等四根三无漏根为因等无间所缘增上。因者三因。即相应俱有同类因。如信根。精进等四根亦尔。苦根与苦根。为因等无间增上。非所缘。因者二因。即同类异熟因。非所缘者。苦根缘色苦根非色故。与七色根命根。为因增上。因者一因。即异熟因。与三无漏根。为所缘增上。所缘者。谓与苦忍苦智集忍集智品为所缘。与余根为因等无间所缘增上。余根者。谓意乐喜舍忧信等五根。此亦具缘等故总说。然因有异。谓与意根为四因。除遍行因。与乐根喜根舍根为二因。即同类异熟因。与忧根为一因。即同类因。与信等五根为三因。即相应俱有同类因。忧根与忧根。为因等无间所缘增上。因者二因。即同类遍行因。与七色根命根为因增上。因者一因。即异熟因。与苦根为因等无间增上。非所缘。因者三因。即同类遍行异熟因。与三无漏根。为所缘增上。所缘者。谓与苦忍苦智集忍集智品为所缘。与余根为因等无间所缘增上。余根者。谓意乐喜舍信等五根。此亦具缘等故总说。然因有异。谓与意根为五因。即相应等五。与乐喜舍根为三因。即同类遍行异熟因。与信等五根为三因。即相应俱有同类因。未知当知根与未知当知根为因等无间所缘增上。因者三因。即相应俱有同类因。所缘者。谓与道忍道智品为所缘。与具知根为因所缘增上。非等无间。因者一因。即同类因。所缘者。谓与道忍道智品为所缘。非等无间者。未知当知根等无间。具知根不现前故。与七色根命根苦根。为一增上。与忧根为所缘增上。与余根。为因等无间所缘增上。余根者。谓意乐喜舍信等五已知根。此亦具缘等故总说。然因有异。谓与意等九根为三因。即相应俱有同类因。与已知根为一因。即同类因。已知根与已知根。为因等无间所缘增上。因者三因。即相应俱有同类因。与七色根命根苦根。为一增上。与忧根未知当知根为所缘增上。与余根。为因等无间所缘增上。余根者。谓意乐喜舍信等五具知根。此亦具缘等故总说。然因有异谓与意等九根。为三因。即相应俱有同类因。与具知根为一因。即同类因。具知根与具知根。为因等无间所缘增上。因者三因。即相应俱有同类。与七色根命根苦根。为一增上。与忧根未知当知根已知根。为所缘增上。与余根为因等无间所缘增上。余根者。谓意乐喜舍信等五根。因者三因。即相应俱有同类因。等无间者。谓具知根等无间。意等九根现在前。所缘者。谓具知根与意等九根为所缘。增上者。谓不碍生及唯无障

说一切有部发智大毗婆沙论卷第一百四十六阿毗达磨大毗婆沙论卷第一百四十七

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    根蕴第六中有纳息第二之一

欲有相续最初得几业所生根如是等章及解章义。既领会已。当广分别。然有声目多义。如前广说。此中说续众同分有情数五蕴名有。相续有五。亦如前说。此中依二相续作论。谓中有相续生有相续欲有相续最初得几业所生根。答卵生胎生湿生。得二。谓身根命根。问最初羯逻蓝位亦得余色根不。若得者。如何于少时顷便得尔所根耶。又此中何故不说。毗奈耶说复云何通。如说。于母腹中二根初得。谓身与命。若损害彼。乃至广说。若不得者。何故经说天眼观知是男是女。答有言亦得。问如何于少时顷便得尔所根耶。答尔时虽无诸色根相而已具得彼根种子。如清盐水酥蜜沙糖酒等。和合贮在一器。若以草端沾取一渧。于中具有盐等诸味。羯逻蓝位应知亦尔。一切色根种子皆具。问若尔。何故此中不说答应说而不说者。当知此义有余。有说。此中说皆得者。余得不定。是以不说。如生盲等不得眼等。问毗奈耶说复云何通。答彼说能持诸余根者。谓身根能持诸余色根。命根能持余非色根。是故偏说。有说。此位不得余色根问天眼云何观知男女。答羯逻蓝时虽无男女根。而有男女相。由观彼相得知男女。所以者何。非彼已有男女二根可说观故。有余师说。依经故知。经说。若胎是男。依母右胁向背蹲坐。若胎是女。依母左胁向腹蹲坐。得天眼者。观此差别依经而说。或有说者。观中有知。谓天眼观中有后位。若是男子。入于母胎。知此羯逻蓝是男非女。若女入者。复知此位是女非男。如是说者。羯逻蓝位未得余色根。钵罗奢佉位中方乃得故。化生得六或七或八。无形者六。谓眼耳鼻舌身命根。一形者七。谓前六及男女根随一。二形者八谓前六及男女根。问余无色根尔时亦得。谓意五受信等五根。此中何故不说。答此中应说而不说者。当知有余有说。尔时一切得者。此中则说。余无色根。虽有得者而非一切。是故不说。谓上地殁生下地时。虽得彼根。若自地殁还生自地。彼皆不得。是故不说。有说。此中但问初得业所生者。初受生位余无色根。虽有得者而非业生。故此不说。后位所得虽业所生。而非初得。故亦不说。色有相续最初得几业所生根。答六。谓眼耳鼻舌身命根。无色有相续最初得几业所生根。答一。谓命根。颇思惟欲界系法。遍知欲界耶。乃至广说。此中思惟者。是取所缘义。遍知者。是究竟断义。此文显示缘彼彼界法离彼彼界染。或不能离

颇思惟欲界系法。遍知欲界耶。答遍知此通异生及圣者。通无间道及解脱道。若世俗道离欲染时。九无间道缘欲界法离欲界染。若无漏道苦集法智离欲染时。九无间道九解脱道。缘欲界法离欲界染。颇思惟欲界系法。遍知色界耶。答不遍知。颇思惟欲界系法。遍知无色界耶。答不遍知。问何故俱不遍知。答欲界是不定界。非修地非离染地。色无色界是定界。是修地是离染地。非缘不定界非修非离染地法。能离定界修地离染地染。有说。欲界是粗界色无色界是细界。非缘粗界法能离细界染。有说。欲界是下界。色界是中界。无色界是妙界。非缘下界法能离中妙界染。有说。欲界是劣界。色无色界是胜界。非缘劣界法能离胜界染。由此等义故不遍知。颇思惟色界系法。遍知色界耶。答遍知。此通异生及圣者。通无间道及解脱道。若世俗道离色染时。九无间道缘色界法离色界染。若无漏道苦集类智。离色染时。九无间道九解脱道。缘色界法离色界染。颇思惟色界系法。遍知欲界耶。答遍知。此通异生及圣者。唯解脱道非无间道。谓世俗道离欲染时。九解脱道缘色界法离欲界染

颇思惟色界系法。遍知无色界耶。答不遍知。问何故不遍知。答色界是粗界无色界是细界非缘粗界法能离细界染。有说。色界是中界。无色界是妙界。非缘中界法能离妙界染。有说。色界是劣界。无色界是胜界。非缘劣界法能离胜界染。由此等义故不遍知

颇思惟无色界系法。遍知无色界耶。答遍知。此唯圣者非异生。通无间道及解脱道。谓无漏道苦集类智离无色染时。九无间道九解脱道。缘无色界法离无色界染

颇思惟无色界系法。遍知欲界耶。答不遍知。问何故不遍知。答以极远故。非观极远界法能离极远界染

颇思惟无色界系法。遍知色界耶。答遍知。此通异生及圣者。唯解脱道非无间道。谓世俗道离色染时。九解脱道缘无色界法离色界染

几根遍知欲界。答世俗道七。无漏道八。世俗道七者。谓意舍信等五根。无漏道八者。谓前七及已知根

几根遍知色界。答世俗道七。无漏道十。世俗道七者。谓意舍信等五根。无漏道十者。谓前七及喜乐已知根

几根遍知无色界。答十一。谓前十及具知根。已知根为无间道。具知根为解脱道。当知此依最后位说。问离欲界染时最后解脱道。容有根本初静虑现前。彼以舍根为无间道。喜根为解脱道。何故不依最后位说世俗道或八。无漏道或九耶。答此文应作是说。世俗道七或八。无漏道八或九。而不说者。当知有余。有说。此中说决定者。谓离非想非非想处染时。定以具知根为最后解脱道。离欲界染时。非定以喜根为最后解脱道。有于尔时不能即入根本地故。然于尔时多依近分故唯说舍

遍知欲界时。遍知几根。答四。谓女男苦忧根。虽于尔时遍知十九。而依永断无余。无分无片无影无随缚断。故作是说。或此中说。上界不行不可得者。故唯说四。遍知色界时遍知几根。答五。谓眼耳鼻舌身根。虽于尔时遍知十三。而依永断无余。无分无片无影无随缚断。故作是说。或此中说。上界不行不可得者。故唯说五。遍知无色界时遍知几根。答八。谓意命舍信等五根。由此诸根离非想非非想处染时。皆永断故几根得预流果。答九。谓意舍信等五未知当知已。知根。未知当知根为无间道。已知根为解脱道。几根得一来果。答若倍离欲染入正性离生者九。如预流说。若从预流果得一来果者。世俗道七。无漏道八。七者。谓意舍信等五根。八者。谓前七及已知根。几根得不还果。答若已离欲染入正性离生者九。谓意根。乐喜舍根随一。依地别故。信等五未知当知已知根。未知当知根为无间道。已知根为解脱道。若从一来果得不还果者。世俗道七无漏道八。七及八如一来说。此依多分。若入根本或八或九。几根得阿罗汉果。答十一。谓意乐喜舍信等五已知具知根。已知根为无间道。具知根为解脱道。问此说十一为以用故。为以有故。若以用者。无有一时三受并用。如何说十一。若以有者。得不还果亦有三受。何故不说。答此以用故。不以有故。问无有一时三受并用。云何说十一耶。答依一相续作用而说。故无有过。谓容有一补特伽罗。先以乐根得阿罗汉。退已用喜。复退用舍。或初退用舍。后退用喜。如先以乐。如是先喜先舍随应亦尔。证不还果。无如是事。若以此根先得彼果退已还用此根。而得此根者即舍根。以喜乐得无退义故

得预流果遍知几根。答无。尔时未有一根究竟断故。得一来果遍知几根。答无。尔时亦未有根究竟断故。得不还果遍知几根。答若已离欲染入正性离生者无义如前说。若从一来果得不还果者四。谓女男苦忧根。得阿罗汉果遍知几根。答八。谓命意舍信等五根

诸根得预流果。此根得彼果已。当言成就。当言不成就。答解脱道摄者。当言成就。无间道摄者。当言不成就。道类智俱生品诸根。是解脱道摄。此当言成就。已得故。道类智忍俱生品诸根。是无间道摄。此当言不成就。已舍故。诸根得一来果。此根得彼果已。当言成就。当言不成就。答解脱道摄者。当言成就。无间道摄者。当言不成就。道类智或第六解脱道俱生品诸根。是解脱道摄。此当言成就。已得故。道类智忍或第六无间道俱生品诸根。是无间道摄。此当言不成就。已舍故。诸根得不还果。此根得彼果已。当言成就。当言不成就。答解脱道摄者。当言成就。无间道摄者。当言不成就。道类智或第九解脱道俱生品诸根。是解脱道摄。此当言成就。已得故。道类智忍或第九无间道俱生品诸根。是无间道摄。此当言不成就。已舍故。问以无漏道得一来不还果时。可言无间道摄者不成就。若以世俗道得二果时。无间道不舍云何言不成就。答此二果文。应作是说。解脱道摄者。当言成就。无间道摄者。当言或成就或不成就。而不作是说者。当知此中唯依不共胜道而说。有言。此说现前成就。以世俗道得二果已。无间道诸根定不现前故。诸根得阿罗汉果。此根得彼果已。当言成就。当言不成就。答解脱道摄者。当言成就。无间道摄者。当言不成就。最初尽智俱生品诸根。是解脱道摄。此当言成就。已得故。金刚喻定俱生品诸根是无间道摄。此当言不成就。已舍故。诸根得预流果。此根断何界结。答色无色界。或无断。色无色界者。谓道类智忍俱生品诸根。或无者。谓道类智俱生品诸根。以解脱道非断对治故。此根何果摄。答预流果。或无预流果摄者。谓道类智俱生品诸根。或无者。谓道类智忍俱生品诸根。诸根得一来果此根断何界结。答欲界或色无色界或无断。欲界或无者。谓从预流果得一来果时。第六无间道俱生品诸根断欲界结。第六解脱道俱生品诸根不断结。断色无色界或无者。谓倍离欲染入正性离生得一来果时。道类智忍俱生品诸根。断色无色界结。道类智俱生品诸根不断结。此根何果摄。答一来果或无。一来果摄者。谓第六解脱道。及道类智俱生品诸根。或无者谓第六无间道。及道类智忍俱生品诸根。诸根得不还果。此根断何界结。答欲界或色无色界或无断。欲界或无者。谓从一来果得不还果时。第九无间道俱生品诸根断欲界结。第九解脱道俱生品诸根不断结。断色无色界或无者。谓已离欲染入正性离生得不还果时。道类智忍俱生品诸根断色无色界结。道类智俱生品诸根不断结。此根何果摄。答不还果。或无。不还果摄者。谓第九解脱道。及道类智俱生品诸根。或无者。谓第九无间道。及道类智忍俱生品诸根。诸根得阿罗汉果。此根断何界结。答无色界。或无。断无色界者。谓金刚喻定俱生品诸根。或无者。谓初尽智俱生品诸根。此根何果摄。答阿罗汉果。或无。阿罗汉果摄者。谓初尽智俱生品诸根。或无者。谓金刚喻定俱生品诸根

得预流果时所舍诸根。此根断何界结。答欲界或色无色界。或无。得预流果时见道所摄。已得诸根名为所舍。此根或断欲界。谓四法智忍俱生品诸根。或断色无色界。谓四类智忍俱生品诸根。或无。谓七智俱生品诸根此根何果摄。答无。以无预流下果摄此诸根故。得一来果时所舍诸根。此根断何界结。答欲界或色无色界。或无。若倍离欲染入正性离生得一来果时。见道所摄已得诸根名为所舍。此根或断欲界。谓四法智忍俱生品诸根。或断色无色界。谓四类智忍俱生品诸根。或无。谓七智俱生品诸根。若从预流果得一来果时。预流果及此胜果道所摄诸根名为所舍。此根或断欲界。谓六无间道所摄诸根。或无。谓预流果及此胜果道中诸加行道。解脱道胜进道所摄诸根。此根何果摄。答预流果。或无。预流果摄者。谓道类智俱生品所舍诸根。或无者。谓此胜果道。及见道所摄所舍诸根。得不还果时所舍诸根。此根断何界结。答欲界或色无色界。或无。若已离欲染入正性离生得不还果时。见道所摄已得诸根名为所舍。此根或断色无色界谓四类智忍俱生品诸根。或无。谓四法智忍。及七智俱生品诸根。若从一来果得不还果时。一来果及此胜果道所摄诸根名为所舍。此根或断欲界。谓三无间道所摄诸根。或无。谓一来果及此胜果道中诸加行道。解说道胜进道所摄诸根。此根何果摄。答一来果。或无。一来果摄者。谓道类智俱生品。及第六解脱道所摄所舍诸根。或无者。谓此胜果道。及见道所摄所舍诸根

得阿罗汉果时所舍诸根。此根断何界结。答色界或无色界。或无。得阿罗汉果时。不还果及此胜果道所摄诸根名为所舍。此根或断色界。谓离四静虑染各有九无间道所摄诸根。或断无色界。谓离四无色染。各有九无间道所摄诸根。或无。谓不还果及此胜果道中诸加行道。解脱道胜进道所摄诸根

此根何果摄。答不还果。或无。不还果摄者。谓道类智俱生品。及第九解脱道所摄所舍诸根。或无者。谓此胜果道所摄所舍诸根得预流果时所得诸根。此根断何界结。答无。谓得预流果时所得诸根。皆是解脱道类所摄。唯无间道摄能断烦恼故。此根何果摄。答预流果。或无。预流果摄者。谓道类智俱生品所得诸根。或无者。谓尔时所得世俗诸根。问尔时所得诸根皆是无漏预流果摄。复有何世俗根是今所得而言或无。答此文但应说预流果。不应言或无。而说或无者。欲显尔时所得命等八根。是无始时来所未曾得。以是初得圣果依故

得一来果时所得诸根。此根断何界结。答无。义如前说

此根何果摄。答一来果。或无。一来果摄者。谓道类智俱生品。及第六解脱道所摄所得诸根。或无者。谓尔时所得世俗诸根

得不还果时所得诸根。此根断何界结。答无。义如前说

此根何果摄。答不还果。或无。不还果摄者。谓道类智俱生品。及第九解脱道所摄所得诸根。或无者。谓尔时所得世俗诸根。得阿罗汉果时所得诸根。此根断何界结。答无。义如前说。此根何果摄。答阿罗汉果。或无。阿罗汉果摄者。谓初尽智俱生品所得诸根。或无者。谓尔时所得世俗诸根

诸预流者所成就根。此根断何界结。答欲界。或无。断欲界者。谓六无间道所摄诸根。或无者。谓预流果及此胜果道中诸加行道。解脱道胜进道所摄等诸根。此根何果摄。答预流果。或无。预流果摄者。谓道类智俱生品所成就诸根。或无者。谓诸预流者所成就胜果道所摄诸根。及所成就余善有漏染污无覆无记诸根

诸一来者所成就根。此根断何界结。答欲界。或无。断欲界。者。谓三无间道所摄诸根。或无者。谓一来果及此胜果道中诸加行道。解脱道胜进道所摄等诸根

此根何果摄。答一来果。或无。一来果摄者。谓道类智俱生品。及第六解脱道所摄所成就诸根。或无者。谓一来者所成就胜果道所摄诸根。及所成就余善有漏染污无覆无记诸根

诸不还者所成就根。此根断何界结。答色界或无色界。或无。断色界者。谓离四静虑染。各有九无间道所摄诸根。断无色界者。谓离四无色染。各有九无间道所摄诸根。或无者。谓不还果及此胜果道中诸加行道。解脱道胜进道所摄等诸根

此根何果摄。答不还果。或无。不还果摄者。谓道类智忍俱生品。及第九解脱道所摄所成就诸根。或无者。谓不还者所成就胜果道所摄诸根。及所成就余善有漏染污无覆无记诸根

诸阿罗汉所成就根。此根断何界结。答无。以阿罗汉诸结已尽无可断故。此根何果摄。答阿罗汉果。或无。阿罗汉果摄者。谓阿罗汉所成就无漏诸根。或无者。谓阿罗汉所成就善有漏无覆无记诸根

诸预流者断结诸根。此根断何界结。答欲界。谓欲界修所断前六品结。此根何果摄。答无。谓无间道能断诸结。沙门果所摄诸根必是解脱道故。诸一来者断结诸根。此根断何界结。答欲界。谓欲界修所断后三品结。此根何果摄。答无。所以如前

诸不还者断结诸根。此根断何界结。答色界或无色界。色界者。谓四静虑修所断各九品结。无色界者。谓四无色修所断各九品结。此根何果摄。答无。所以如前诸阿罗汉诸结已尽。无断结根故。不问答

诸预流果所摄诸根。此根断何界结。答无。以沙门果所摄诸根是解脱道。唯无间道能断结故。诸一来果不还果阿罗汉果所摄诸根。此根断何界结。答无。所以如前。阿罗汉果又无结可断故

诸苦智是于苦无漏智耶。乃至广说。问何故作此论。答欲令疑者得决定故。谓苦智集智行相无杂。所缘有杂。灭智道智行相无杂。所缘无杂。或有生疑。如苦集智行相无杂所缘有杂。灭道智亦如是耶。如灭道智行相无杂所缘无杂。苦集智亦如是耶。为令此疑得决定故。显苦集智所缘有杂灭道智所缘无杂故作斯论。问何故苦智集智行相无杂。所缘有杂。答离苦无集离集无苦故。谓一一有漏事。果义名苦因义名集。即于一一有漏事中。若智作苦等四行相转名苦智。若智作集等四行相转名集智。故苦集智行相无杂。所缘有杂。灭智道智行相所缘二俱无杂。灭等道等行相异故。有为无为所缘别故

诸苦智是于苦无漏智耶。设于苦无漏智是苦智耶。答诸苦智是于苦无漏智。由无漏智于苦事中。作非常苦空非我四行相转。名苦智故。有于苦无漏智非苦智。谓于苦知集智。由无漏智于苦事中。作因集生缘四行相转。名集智故。前已说离苦无集。故集智所缘亦名为苦

诸集智是于集无漏智耶。设于集无漏智是集智耶。答诸集智是于集无漏智。由无漏智于集事中。作因集生缘四行相转。名集智故。有于集无漏智非集智。谓于集知苦智。由无漏智于集事中。作非常苦空非我四行相转。名苦智故。前已说离集无苦。故苦智所缘亦名为集

诸灭智是于灭无漏智耶。答如是设于灭无漏智是灭智耶。答如是诸道智。是于道无漏智耶。答如是。设于道无漏智是道智耶。答如是。由前已说灭智道智行相所缘俱无杂故。若无漏智缘择灭。作灭静妙离四行相转。名灭智。若无漏智缘圣道。作道如行出四行相转。名道智故

说一切有部发智大毗婆沙论卷第一百四十七阿毗达磨大毗婆沙论卷第一百四十八

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    根蕴第六中有纳息第二之二

诸根无漏缘欲界系。此根法智相应耶。设根无漏法智相应。此根缘欲界系耶。答应作四句。有根无漏缘欲界系。此根非法智相应。谓苦法智忍。及相应根。苦法智集法智忍。及相应根。集法智此中苦法智忍是无漏慧根。此根缘欲界系。非法智相应。以忍与智不相应故。及相应根者。谓苦法智忍相应八无漏根。此根亦缘欲界系。非法智相应。忍相应故。苦法智亦是无漏慧根。此根亦缘欲界系。非法智相应。自体与自体不相应故。谓三缘故自体不与自体相应。一无二自性俱生故。二前后刹那不并故。三一切法不观自性与他为缘故。集法智忍。及相应根。集法智亦如是。有根无漏法智相应。此根不缘欲界系。谓灭道法智相应根。此是灭道法智相应八无漏根。此根不缘欲界系。缘不系法故

有根无漏缘欲界系。此根亦法智相应。谓苦集法智相应根。此是苦集法智相应八无漏根。此根缘欲界系。缘欲界苦集故。有根无漏不缘欲界系。此根亦非法智相应。谓苦类智忍苦类智。及二相应根。集类智忍集类智。及二相应根。灭法智忍及相应根。灭法智灭类智忍灭类智。及二相应根。道法智忍。及相应根。道法智道类智忍道类智。及二相应根。此中苦类智忍苦类智俱是无漏慧根。此根不缘欲界系。缘色无色界系故。亦非法智相应。忍智与智不相应故。及二相应根者。谓苦类智忍苦类智相应八无漏根。此根不缘欲界系。缘色无色界系故。亦非法智相应。与苦类智忍苦类智相应故。集类智忍集类智。及二相应根。亦如是。灭法智忍是无漏慧根。此根不缘欲界系。缘不系法故。亦非法智相应。忍与智不相应故。及相应根者。谓灭法智忍相应八无漏根。此根不缘欲界系。缘不系法故。亦非法智相应。忍相应故。灭法智亦是无漏慧根。此根不缘欲界系。缘不系法故。亦非法智相应。自体与自体不相应故。道法智忍及相应根。道法智亦如是。灭类智忍灭类智俱是无漏慧根。此根不缘欲界系。缘不系法故。亦非法智相应。忍智与智不相应故。及二相应根者。谓灭类智忍灭类智相应八无漏根。此根不缘欲界系。缘不系法故。亦非法智相应。与灭类智忍灭类智相应故。道类智忍道类智。及二相应根亦如是

诸根无漏缘色无色界系。此根类智相应耶。设根无漏类智相应。此根缘色无色界系耶。答应作四句。有根无漏缘色无色界系。此根非类智相应。谓苦类智忍。及相应根。苦类智集类智忍。及相应根。集类智此中苦类智忍是无漏慧根。此根缘色无色界系。非类智相应。忍与智不相应故。及相应根者。谓苦类智忍相应八无漏根。此根亦缘色无色界系。非类智相应。忍相应故。苦类智亦是无漏慧根。此根亦缘色无色界系非类智相应。自体与自体不相应故。集类智忍及相应根。集类智亦如是。有根无漏类智相应。此根不缘色无色界系。谓灭道类智相应根。此是灭道类智相应八无漏根。此根不缘色无色界系。缘不系法故

有根无漏缘色无色界系。此根亦类智相应。谓苦集类智相应根。此是苦集类智相应八无漏根。此根缘色无色界系。缘色无色界苦集故。有根无漏不缘色无色界系。此根亦非类智相应。谓苦法智忍苦法智。及二相应根。集法智忍集法智。及二相应根。灭法智忍灭法智。及二相应根。灭类智忍及相应根。灭类智道法智忍道法智。及二相应根道类智忍及相应根。道类智此中苦法智忍苦法智。俱是无漏慧根。此根不缘色无色界系。缘欲界系故。亦非类智相应。忍智与智不相应故。及二相应根者。谓苦法智忍苦法智相应八无漏根。此根不缘色无色界系。缘欲界系故。亦非类智相应。与忍法智相应故。集法智忍集法智。及二相应根亦如是。灭法智忍灭法智俱是无漏慧根。此根不缘色无色界系。缘不系法故。亦非类智相应。忍智与智不相应故。及二相应根者。谓灭法智忍灭法智相应八无漏根。此根不缘色无色界系。缘不系法故。亦非类智相应。与忍法智相应故。道法智忍道法智。及二相应根亦如是。灭类智忍是无漏慧根。此根不缘色无色界系。缘不系法故。亦非类智相应。忍与智不相应故。及相应根者。谓灭类智忍相应八无漏根。此根不缘色无色界系。缘不系法故。亦非类智相应忍相应故。灭类智亦是无漏慧根。此根不缘色无色界系。缘不系法故。亦非类智相应。自体与自体不相应故。道类智忍及相应根。道类智亦如是

法智当言法智耶。乃至广说。问何故此中但依法类二智作论。答彼作论者意欲尔故。随彼意欲而造论。但不违法性便不应责。彼意欲依二智作论即便作之。谓法智类智如前智蕴。随论者意依二智作论。谓他心智宿住随念智如后定蕴。随论者意亦依二智作论。谓尽智无生智。如此蕴前随论者意依四智作论。谓苦智集智灭智道智。如前结蕴随论者意依八智作论。谓法智类智他心智世俗智苦集灭道智。如所知纳息。随论者意依十智作论。谓前八智。及尽无生智。譬如善巧陶师以湿埿团置于轮上。随意埏埴成种种器。于工巧法而不相违。如是善作论者以闻思慧。行所知境照了除痴。然后随欲造种种论。于诸法性亦不相违。有说。唯法类智互不相摄。亦俱遍缘不相摄境。谓有漏无漏有为无为四圣谛法。有说。以法类智摄一切无漏智尽是彼根本。有说。法类二智作分齐缘。谓法智缘下类智缘上。由此等缘故但依此二智作论

法智当言法智耶。当言类智他心智世俗智苦智集智灭智道智耶。答当言法智或他心智苦智集智灭智道智。当言。法智者。谓知欲界诸行。诸行因。诸行灭。诸行对治道或他心智者。谓知欲界诸行对治道他心心所法。或苦智者。谓知欲界诸行非常相苦相空相非我相。或集智者。谓知欲界诸行因因相集相生相缘相。或灭智者。谓知欲界诸行灭灭相静相妙相离相。或道智者。谓知欲界诸行对治道道相如相行相出相。显自性已当显地。法智当言有寻有伺无寻唯伺无寻无伺耶。答当言三种。谓在未至初静虑名有寻有伺。在静虑中间名无寻唯伺。在上三静虑名无寻无伺。显地已当显相应

法智当言乐根相应喜根相应舍根相应耶。答当言三种谓在第三静虑乐根相应。在初二静虑喜根相应。在未至静虑中间第四静虑。舍根相应。显相应已当显行相法智。当言空无愿无相相应耶。答当言三种。谓二行相空相应。十行相无愿相应。四行相无相相应。显行相已当显所缘。法智当言缘欲界系。缘色界系。缘无色界系。缘不系耶。答当言。缘欲界系或不系。缘欲界系者。谓苦集法智。缘不系者。谓灭道法智

类智当言类智耶。当言法智他心智世俗智苦智集智灭智道智耶。答当言类智或他心智苦智集智灭智道智。当言类智者。谓知色无色界诸行诸行因诸行灭诸行对治道。或他心智者。谓知色无色界诸行无漏对治道他心心所法。或苦智者。谓知色无色界诸行非常等四种相。或集智者。谓知色无色界诸行因因等四种相。或灭智者。谓知色无色界诸行灭灭等四种相。或道智者。谓知色无色界诸行对治道道等四种相。显自性已当显地。类智当言有寻有伺无寻唯伺无寻无伺耶。答当言三种。谓在未至初静虑名有寻有伺。在静虑中间名无寻唯伺。在上三静虑下三无色名无寻无伺。显地已当显相应

类智当言乐根相应喜根相应舍根相应耶。答当言三种谓在第三静虑乐根相应。在初二静虑喜根相应。在未至静虑中间第四静虑下三无色舍根相应。显相应已当显行相。类智当言空无愿无相相应耶。答当言三种。谓二行相空相应。十行相无愿相应。四行相无相相应。已显行相当显所缘

类智当言缘欲界系。缘色界系。缘无色界系。缘不系耶。答当言缘色无色界系或不系。缘色无色界系者。谓苦集类智缘不系者。谓灭道类智

时心解脱。当言学根得无学根得。乃至广说。问何故作此论。答欲解释契经义故。如佛告阿难陀言。苾刍不应乐处愦闹。若乐是者于时爱心解脱。或于不时不动心解脱身作证。能具足住无有是处。若有苾刍不乐愦闹而乐寂静。于时爱心解脱。或不时不动心解脱身作证。能具足住斯有是处彼经虽说二种解脱。而不分别此二自性。亦未曾显由何根得。前智蕴中虽已显示解脱自性。而未显得。今欲显得故作斯论。有说。欲止他所说故。谓或有执。时心解脱有学有所作所作未办故。不动心解脱无学无所作所作已办故。为遮彼执。显二解脱俱是无学所作已办。或复有执。时心解脱是有漏。不动心解脱是无漏。欲止彼意显二解脱俱是无漏。或复有执。时心解脱是有为。不动心解脱是无为。为止彼执显二解脱俱是有为。由此等缘故作斯论。诸法中唯二法是解脱自性。谓有为法中唯有胜解。无为法中唯有择灭彼胜解者。是心所大地法恒与心相应。彼择灭者。是离系是胜义善常住涅槃。胜解有二。谓染不染。染谓邪胜解。即贪等烦恼随烦恼相应。不染谓正胜解。即信等诸善法相应。此正胜解复有二种。谓有漏无漏。有漏者谓不净观持息念无量胜处遍处等相应。无漏复二。谓学无学。学者谓七圣身中无漏胜解。无学者。谓阿罗汉身中无漏胜解。无学胜解复有二种。谓时心解脱。不时心解脱。时心解脱者。谓五种阿罗汉身中无漏胜解。不时心解脱者谓不动法阿罗汉身中无漏胜解。此二亦名心解脱慧解脱。离贪故名心解脱。离无明故名慧解脱。问若此胜解离贪故名心解脱。离无明故名慧解脱者。集异门等所说当云何通。如说云何离贪故心得解脱。答无贪善根对治贪故。云何离无明故慧得解脱。答无痴善根对治痴故。由此说故二解脱体。即是善根非是胜解。答彼文应作是说。云何离贪故心得解脱。答无贪善根相应心胜解印可。即此名为时心解脱。云何离无明故慧得解脱。答无痴善根相应心胜解印可。即此名为不动心解脱。而不作是说者有何意耶。答此就依处以显胜解。谓依无贪故心解脱贪。依无痴故心解脱痴。然心解脱体是胜解

时心解脱当言学根得无学根得学无学根得耶答当言学无学根得。学根得者谓无间道俱生根。无学根得者。谓解脱道俱生根。又学根得者。谓向道俱生根。无学根得者。谓果道俱生根。又学根得者。谓金刚喻定俱生品根。无学根得者。谓尽智俱生品根。又学根得者。谓已知根。无学根得者。谓具知根。又学根得者。谓修道俱生根。无学根得者谓无学道俱生根。修地无学地亦尔。不动心解脱。当言学根得无学根得。学无学根得耶。答若本得不动当言学无学根得。若时解脱阿罗汉得不动。当言无学根得。学无学根得者。广说如前。无学根得者。彼无间解脱道俱无学摄故。一切结尽当言学根得。无学根得。学无学根得耶。答当言学无学根得。广说如前。问此文何故不如不动心解脱说。答此文亦应作如是说。若初证一切结尽。当言学无学根得。若时解脱阿罗汉得不动证一切结尽。当言无学根得。而不作是说者有何意耶。答解脱有二。谓有为无为。二种心解脱是有为。一切结尽是无为。有为解脱有下中上。初所得异后所得异故差别说。无为解脱无下中上。后得同初故无别说

以无间道证预流果。此道当言法智相应。类智他心智世俗智苦智集智灭智道智相应耶。当言有寻有伺无寻唯伺无寻无伺耶。当言乐根喜根舍根相应耶。当言空无愿无相相应耶。当言缘欲界系色界系无色界系不系耶。答以无间道证预流果。此道当言忍相应有寻有伺舍根相应。无愿相应。缘不系忍相应者。道类智忍俱故。有寻有伺者。唯依未至地故。舍根相应者。未至地唯有舍受故。无愿相应者。道无愿俱故。缘不系者类智品为所缘故

以无间道证一来果。此道当言法智相应。类智他心智世俗智苦智集智灭智道智相应耶。当言有寻有伺无寻唯伺无寻无伺耶。当言乐根喜根舍根相应耶。当言空无愿无相相应耶。当言缘欲界系色界系无色界系不系耶。答若倍离欲染入正性离生者。如证预流果说。若从预流果以世俗道证一来果。此道当言世俗智相应。有寻有伺舍根相应。缘欲界系。世俗智相应者。谓粗等三行相随一转故。不与空等相应者。彼唯无漏故。缘欲界系者。欲界五蕴为所缘故。余如前说若从预流果以无漏道证一来果。此道当言法智相应。或苦智。或集智。或灭智。或道智相应。有寻有伺舍根相应。或空或无愿或无相相应。或缘欲界系。或缘不系。法智相应者。谓四法智随一相应。或苦智相应者。即苦法智相应。乃至或道智相应者。即道法智相应。或空相应者。谓二行相相应。或无愿相应者。谓十行相相应。或无相相应者。谓四行相相应。或缘欲界系者谓苦集法智。或缘不系者。谓灭道法智。余如前说

以无间道证不还果。此道当言法智相应。类智他心智世俗智苦智集智灭智道智相应耶。当言有寻有伺无寻唯伺无寻无伺耶。当言乐根喜根舍根相应耶。当言空无愿无相相应耶。当言缘欲界系色界系无色界系不系耶。答若已离欲染入正性离生。此道当言忍相应。或有寻有伺。或无寻唯伺。或无寻无伺。或乐根相应。或喜根相应。或舍根相应。无愿相应。缘不系。或有寻有伺者。谓依未至初静虑。或无寻无伺者。谓依静虑中间。或无寻无伺者。谓依上三静虑或乐根相应者。谓依第三静虑。或喜根相应者。谓依初二静虑。或舍根相应者。谓依未至静虑中间第四静虑。余如前说。若从一来果以世俗道证不还果者。如以世俗道证一来果说。若从一来果以无漏道证不还果者。如以无漏道证一来果说。以无间道证阿罗汉果。此道当言法智相应类智他心智世俗智苦智集智灭智道智相应耶。当言有寻有伺无寻唯伺无寻无伺耶。当言乐根喜根舍根相应耶。当言空无愿无相相应耶。当言缘欲界系色界系无色界系不系耶。答此道当言或法智相应或类智或苦智或集智或灭智或道智相应。或有寻有伺。或无寻唯伺。或无寻无伺。或乐根。或喜根或舍根相应。或空或无愿或无相相应。或缘无色界系。或缘不系。或法智相应者。谓灭道法智随一相应。或类智相应者。谓四类智随一相应。或苦智集智相应者。即苦集类智相应。或灭智道智相应者。即灭道法类智相应。或有寻有伺者。谓依未至初静虑。或无寻唯伺者。谓依静虑中间。或无寻无伺者。谓依上三静虑下三无色。或乐根相应者。谓依第三静虑。或喜根相应者。谓依初二静虑。或舍根相应者。谓依未至静虑中间第四静虑下三无色。或空相应者。谓二行相相应。或无愿相应者。谓十行相相应。或无相相应者。谓四行相相应。或缘无色界系者。谓苦集类智缘有顶苦集故。或缘不系者。谓灭道法类智缘三界灭。及能对治道故

几根永断灭起得预流果。答无根永断。七根灭起。一灭不起一起不灭得预流果。七根灭起者。七谓意舍信等五根。灭谓此七无间道摄。起谓此七解脱道摄。又灭谓向道摄。起谓果道摄。又灭谓道类智忍品摄。起谓道类智品摄。又灭谓未知当知根俱生。起谓已知根俱生。又灭谓见道摄。起谓修道摄。见地修地亦尔。一灭不起者。谓未知当知根。一起不灭者。谓已知根。几根永断灭起得一来果。答若倍离欲染入正性离生者。如证预流果说。若从预流果以世俗道证一来果。无根永断七根灭起得一来果。七根灭起者七如前说。灭谓此七无间道摄。起谓此七解脱道摄。又灭谓向道摄。起谓果道摄

若从预流果以无漏道证一来果。无根永断八根灭起得一来果。八根灭起者。八谓前七加已知根。灭起义如前说

几根永断灭起得不还果。答若已离欲染入正性离生无根永断。七根灭起。一灭不起。一起不灭。得不还果。七根灭起者。七谓意根乐喜舍根随一。信等五根。余如得预流果中说。若从一来果以世俗道证不还果。不入静虑。四根永断七根灭起得不还果四根永断者。谓女男苦忧根。七根灭起者。七谓意舍信等五根。灭起义如从预流得一来说。若入静虑。四根永断。六根灭起。一灭不起。一起不灭。得不还果

四根永断者如前说。六根灭起者。六谓意根信等五根。灭起义如前说。一灭不起者。谓舍根。一起不灭者。谓喜根。若从一来果以无漏道证不还果。不入静虑四根永断八根灭起。得不还果。八根者。谓意舍信等五已知根。余如前说。若入静虑四根永断七根灭起一灭不起。一起不灭。得不还果。七根者。即前谓意信等五。及已知根。余如以世俗道证不还果中说

问离欲界染第九解脱道。谁即入静虑。谁不入耶。答所依力强者入。所依力劣者不入。有说。所依力劣者入。为长养所依故。所依力强者不入。不为长养所依故。有说。欣多者入。厌多者不入。有说。喜乐多者入。忧苦多者不入。有说。以灭道智离欲染者入。以苦集智离欲染者不入。有说。以无相道无愿离欲染者入。以空苦集无愿离欲染者不入。有说。厌欲界法离欲染者入。厌三界法离欲染者不入。有说。为求静虑而离染者入为求解脱而离染者不入。有说。利根者入。钝根者不入。如利根钝根。因力缘力。内分力外分力。内正思惟力外闻正法力。应知亦尔

几根永断灭起得阿罗汉果。答若依未至证阿罗汉果。一根永断七根永断灭起。一灭不起。一起不灭。得阿罗汉果。一根永断者谓命根。七根永断灭起者。七谓意舍信等五根。永断谓有漏摄。灭谓无间道摄起谓解脱道摄。又永断谓世俗摄。灭谓向道摄。起谓果道摄。又永断谓非学非无学摄。灭谓学摄。起谓无学摄。又永断谓有顶摄。灭谓金刚喻定俱生品摄。起谓尽智俱生品摄。又永断谓修所断摄。灭谓已知根摄起谓具知根摄。又永断谓无色界系摄。灭谓修道地摄。起谓无学道地摄。一灭不起者。谓已知根一起不灭者。谓具知根

如依未至。依静虑中间第四静虑三无色定亦尔。若依初静虑证阿罗汉果。二根永断。六根永断灭起。一根灭起。一灭不起。一起不灭。得阿罗汉果二根永断者谓命舍根。六根永断灭起者。六谓意信等五根永断灭起义如前说一根灭起者。一谓喜根。灭起义如前说一灭不起者。谓已知根。一起不灭者。谓具知根。如依初静虑。依第二第三静虑亦尔。然差别者。依第三静虑。应说乐根起灭

说一切有部发智大毗婆沙论卷第一百四十八阿毗达磨大毗婆沙论卷第一百四十九

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    根蕴第六中触纳息第三之一

有十六触谓有对触。增语触。明触。无明触。非明非无明触。爱触。恚触。顺乐受触。顺苦受触。顺不苦不乐受触。眼触。耳触。鼻触。舌触。身触。意触。云何有对触。乃至云何意触。如是等章。及解章义既领会已。当广分别。问何故作此论。答为止他宗显己义故。谓譬喻者说。触非实有。所以者何。契经说故。如契经说。眼及色为缘生眼识。三和合触等。离眼色眼识外实触体不可得。为遮彼意显触体是实有。若触体非实有者。便违经说。如契经说。触为缘受。若无触者但应说六处缘受。或说无缘不应言触缘受。又若触体非实有者。应说缘起唯十一支。契经不应说有十二。又若触体非实有者。但应说有九大地法。然说有十故触实有。问若触实有云何会释彼所引经。答彼经意说三法和合为缘生触非于无体得有生义。此若不生云何缘受。譬如月月爱珠。及器和合为缘生水。非无水生得有水用。又如日日爱珠。粖薪和合为缘生火。非无火生得有火用。如是根境及识和合为缘生触非无触生得有触用。触用谓能为缘生受。是故欲止他说显触实有而作斯论。问何缘根蕴分别触耶。答彼作论者意欲尔故乃至广说。复次此不应问。所以者何。前已说一一蕴中具一切义故。复次一切法触所集起。根由触生故分别触。复次心心所以触为命。触所引触所转触力故现在前此中有根故分别触。复次先安立诸触后辩根相应。根以触为章故应先分别触

问诸圣教中。或说一触如心所中立触心所。十大地法中立触大地法。或说二触谓有漏无漏缚解系不系。或说三触。谓下中上善不善无记。或说四触。谓三界系及不系。或说五触。谓三界系及学无学。或说六触。谓眼触乃至意触。或说七触。谓见苦所断。乃至修所断。并学无学或说八触。谓见苦所断乃至修所断。及见道修道无学道。或说九触谓下下乃至上上。或说十触。谓欲界系。乃至非想非非想处系及不系。若约相续刹那分别则有无量。何故此中于一等广说十六。于无量略说十六耶。答由六因缘不略不广说十六触。谓所缘故。障治故自性故。违顺故相应知所依故。由所缘故立有对触增语触。由障治故立明触无明触。由自性故立非明非无明触。由违顺故立爱触恚触。由相应故立顺乐受触。顺苦受触顺不苦不乐受触由所依故立眼触乃至意触

云何有对触。答五识身相应触。问何故此触名有对答以有对法为所缘故。问增语触亦以有对法为所缘。何故此触独名有对。答此触以初故得名增语触。更以余缘建立。有说。此触但以有对法为所缘。增语触亦缘余法。有说。此触所依所缘皆是有对。增语触所缘虽或有对所依不尔故别立名。云何增语触。答意识身相应触问何故此触名增语。答由此触自性语增故名增语。问云何此触自性语增。答有对触唯欲色界系。此触通三界系及不系。又有对触唯欲界。初静虑地可得。此触一切地可得。又有对触唯有漏。此触通有漏无漏。由此等故自性语增。有说。此触所缘语增故名增语。问云何此触所缘语增。答有对触唯以有色法为所缘。此触通缘有色无色。又有对触但以有对法为所缘。此触通缘有对无对。又有对触但以有漏法为所缘。此触通缘有漏无漏。又有对触但以有为法为所缘此触通缘有为无为。由此等故所缘语增。有说。增语者。谓名此触缘名故名增语。虽亦缘义而非不共故。随不共立名依别立通名。如苦集智等。云何明触。答无漏触即三无漏根相应触。云何无明触。答染污触即一切烦恼随烦恼相应触。云何非明非无明触。答不染有漏触。此中问答各有二遮。谓非明者遮明触。非无明者遮无明触。不染者遮染污触。有漏者遮无漏触。由此遮故此体唯摄一切有漏善无覆无记触。云何爱触。答贪相应触。即三界五部所断六识身俱贪相应触。云何恚触。答嗔相应触。即五所断六识身俱嗔相应触。云何顺乐受触。答乐受相应触。即乐喜根相应触。云何顺苦受触。答苦受相应触。即苦忧根相应触。云何顺不苦不乐受触。答不苦不乐受相应触。即舍根相应触。云何眼触。答眼识身相应触。乃至云何意触。答意识身相应触谓依眼等根生故名眼等触。显自性已当辩相摄。然有一触摄诸触尽。谓心所中一触自性。此中二触摄诸触尽。谓有对触增语触复有三触摄诸触尽。谓明无明。非明非无明触。及顺乐顺苦顺不苦不乐受触。复有六触摄诸触尽。谓眼触乃至意触。问有对触摄几触。乃至意触摄几触耶。答有对触摄六触全七触少分。六全者。谓有对触眼耳鼻舌身触。七少分者。谓无明非明非无明触。爱恚触。顺乐顺苦。顺不苦不乐受触。问云何此摄彼七少分。答彼七通与六识相应。此唯摄五识相应故言少分。增语触摄三触全。七触少分。三全者。谓增语触明触意触。七少分者如前说。问云何此摄彼七少分。答彼七通与六识相应。此唯摄意识相应故言少分。明触摄明触全。四触少分。谓增语触。顺乐顺不苦不乐受触意触。问云何此摄彼四少分。答彼四通有漏无漏。此唯摄无漏故言少分。无明触摄三触全。十一触少分。三全者。谓无明触爱恚触。十一少分者。谓有对增语触。顺乐顺苦顺不苦不乐受触。眼触乃至意触。问云何此摄彼十一少分。答彼十一通染不染。此唯摄染故言少分。非明非无明触。摄非明非无明触全。十一触少分。谓如前说。问云何此摄彼十一少分。答即前十一通染不染。不染有通有漏无漏。此唯摄不染有漏故言少分。爱触摄爱触全。十一触少分。谓有对增语触。无明触。顺乐顺不苦不乐受触。眼触乃至意触。问云何此摄彼十一少分。答彼十一通与贪俱生不俱生。此唯摄俱生故言少分。恚触摄恚触全。十一触少分。谓有对增语触。无明触。顺苦顺不苦不乐受触。眼触乃至意触。问云何此摄彼十一少分。答彼十一通与嗔俱生不俱生。此唯摄俱生故言少分。顺乐受触摄顺乐受触全。十二触少分。谓有对增语触。明无明。非明非无明触爱触。眼触乃至意触。问云何此摄彼十二少分。答彼十二通与乐受俱生不俱生。此唯摄俱生故言少分。顺苦受触摄顺苦受触全。十一触少分。谓有对增语触。无明。非明非无明触。恚触眼触乃至意触。问云何此摄彼十一少分。答彼十一通与苦受俱生不俱生。此唯摄俱生故言少分。顺不苦不乐受触。摄顺不苦不乐受触全。十三触少分。谓有对增语触明无明。非明非无明触。爱恚触。眼触乃至意触。问云何此摄彼十三少分。答彼十三通与舍受俱生不俱生。此唯摄俱生故言少分。眼触摄眼触全。八触少分。谓有对触。无明。非明非无明触。爱恚触。顺乐顺苦。顺不苦不乐受触。问云何此摄彼八少分。答彼八通与眼识相应不相应。此唯摄相应故言少分。如眼触。耳鼻舌身触亦尔。是中差别者。各摄自触全。自识相应八少分。意触摄三触全。七触少分。如增语触说。问何故名摄。摄是何义。答自体于自体。已有当有现有可得故名为摄。有说。自体于自体不异不外不差别不相离。是有不空故名为摄。有说。自体于自体。非不曾有。非不今有。非不当有。故名为摄。诸法不舍自性义是摄义。非如以指捻衣。以手取食。彼可舍故。有说。拘碍义是摄义。诸法拘碍无如自体于自体者。有对触几根相应。乃至意触几根相应耶。答有对触一根全。八根少分相应。一全者。谓苦根。八少分者。谓意乐舍信等五根。问云何此与彼八少分相应。答彼八根通六识俱生品。此唯与五识俱生品相应故言少分。增语触五根全。八根少分相应。五全者。谓喜忧三无漏根。八少分者如前说。问云何此与彼八少分相应。答彼八根通六识俱生品。此唯与意识俱生品相应故言少分。明触。三根全。九根少分相应。三全者。谓三无漏根。九少分者。谓意乐喜舍信等五根。问云何此与彼九少分相应。答彼九根通有漏无漏。此唯与无漏相应故言少分无明触。六根少分相应。谓意五受根。问云何此与彼六少分相应。答彼六根通染不染。此唯与染相应故言少分。非明非无明触。十一根少分相应。谓意五受信等五根。问云何此与彼十一少分相应。答彼十一根中前六通染不染。后五通有漏无漏。此唯与不染有漏相应故言少分。爱触。四根少分相应。谓意乐喜舍根。问云何此与彼四少分相应。答彼四根通贪俱生不俱生。此唯与俱生者相应故言少分恚触。四根少分相应。谓意苦忧舍相。问云何此与彼四少分相应。答彼四根通嗔俱生不俱生。此唯与俱生者相应故言少分。顺乐受触。二根全。九根少分相应。二全者。谓乐喜根。九少分者。谓意信等五三无漏根。问云何此与彼九少分相应。答彼九根中前六通乐受俱生不俱生。此唯与俱生者相应。后三通以九根为性。此唯与六根相应故言少分。顺苦受触。二根全六根少分相应。二全者。谓苦忧根。六少分者。谓意信等五根。问云何。此与彼六少分相应。答彼六根通苦受俱生不俱生。此唯与俱生者相应故言少分。顺不苦不乐受触。一根全。九根少分相应。一全者。谓舍根。九少分者。谓意信等五三无漏根。问云何此与彼九少分相应。答彼九根中前六。通不苦不乐受俱生不俱生。此唯与俱生者相应。后三通以九根为性。此唯与六根相应故言少分。眼触九根少分相应。谓意乐苦舍信等五根。问云何此与彼九少分相应。答彼九根通眼识俱生品不俱生品。此唯与俱生品相应故言少分。如眼触。耳鼻舌身触亦尔。是中差别者。各与自识俱生品根相应。意触。五根全八根少分相应。如增语触说。相应义广说如上

诸根因有对触。此根有对触相应耶。设根有对触相应。此根因有对触耶。答诸根有对触相应。此根因有对触。谓此根以有对触为四因。即相应俱有同类异熟因。有根因有对触。此根非有对触相应。谓根因有对触余触相应。及异熟生无所缘。余触相应者。谓增语触相应。此根。以有对触为二因。即同类异熟因。及异熟生无所缘者。谓命等八根。此根以有对触为一因。即异熟因。诸根因增语触。此根增语触相应耶。设根增语触相应。此根因增语触耶。答诸根增语触相应此根因增语。触谓此根以增语触为五因。即相应俱有同类遍行异熟因。有根因增语触。此根非增语触相应。谓根因增语触余触相应。及异熟生无所缘。余触相应者。谓有对触相应。此根以增语触为三因。即同类遍行异熟因。及异熟生无所缘者。谓命等八根。此根以增语触为一因。即异熟因。诸根因明触此根明触相应耶。答如是。设根明触相应此根因明触耶。答如是。此中因者。谓三因即相应俱有同类因。诸根因无明触。此根无明触相应耶。设根无明触相应。此根因无明触耶。答诸根无明触相应。此根因无明触。谓此根以无明触为四因。即相应俱有同类遍行因。有根因无明触此根非无明触相应。谓根因无明触余触相应。及异熟生无所缘。余触相应者。谓非明非无明触相应。此根以无明触为一因即异熟因。及异熟生无所缘者。谓命等八根。此根以无明触为一因即异熟因。诸根因非明非无明触。此根非明非无明触相应耶。设根非明非无明触相应。此根因非明非无明触耶。答诸根非明非无明触相应。此根因非明非无明触。谓此根以非明非无明触为四因。即相应俱有同类异熟因。有根因非明非无明触。此根非明非无明触相应。谓根因非明非无明触。异熟生无所缘。谓命等八根。以非明非无明触为一因。即异熟因。诸根因爱触此根爱触相应耶。设根爱触相应。此根因爱触耶。答诸根爱触相应此根因爱触。谓此根以爱触为三因。即相应俱有同类因。有根因爱触。此根非爱触相应。谓根因爱触。余触相应及异熟生无所缘。余触相应者。谓余无明触。非明非无明触相应。此根以爱触为二因。即同类异熟因。谓余无明触相应。根以爱触为同类因。非明非无明触相应。根以爱触为异熟因。及异熟生无所缘者。谓命等八根以爱触为一因即异熟因。如说爱触恚触亦尔。差别者。说自名诸根因顺乐受触。此根顺乐受触相应耶。设根顺乐受触相应。此根因顺乐受触耶。答诸根顺乐受触相应。此根因顺乐受触。谓此根以顺乐受触为五因。即相应等五。有根因顺乐受触。此根非顺乐受触相应。谓根因顺乐受触。余触相应。及异熟生无所缘。余触相应者。谓顺苦受触。顺不苦不乐受触相应。此根以顺乐受触为三因。即同类遍行异熟因。及异熟生无所缘者。谓命等八根。以顺乐受触为一因即异熟因。如说顺乐受触。顺苦受触。顺不苦不乐受触亦尔。差别者。说自名诸根。因眼触此根眼触相应耶。设根眼触相应。此根因眼触耶。答诸根眼触相应。此根因眼触。谓此根以眼触为四因。即相应俱有同类异熟因。有根因眼触。此根非眼触相应。谓根因眼触余触相应。及异熟生无所缘。余触相应者。谓耳鼻舌身意触相应。此根以眼触为二因。即同类异熟因。及异熟生无所缘者。谓命等八根。此根以眼触为一因即异熟因。如说眼触。耳鼻舌身触亦尔。差别者。说自名诸根。因意触此根意触相应耶。设根意触相应。此根因意触耶。答诸根意触相应。此根因意触。谓此根以意触为五因。即相应等五。有根因意触。此根非意触相应。谓根因意触。余触相应。及异熟生无所缘。余触相应者。谓眼耳鼻舌身触相应。此根以意触为三因。即同类遍行异熟因。及异熟生无所缘者。谓命等八根。此根以意触为一因即异熟因

诸成就此类眼根。彼成就此类身根耶。乃至广说。类有四种。一修类。二律仪类。三界类。四相似类。此四广说如前业蕴。此中依界类而作论。诸成就此类眼根。彼成就此类身根耶。设成就此类身根。彼成就此类眼根耶。答应作四句。有成就此类眼根非此类身根。谓生欲界不得眼根。设得已失。得色界眼不得眼根者。谓未至钵罗奢佉位等。设得已失者。谓已得眼根。或自然坏。或遇缘坏故失。得色界眼者。谓由善习静虑力故。色界眼根依欲界身得。而不得彼界身根。无成就他界身故。有成就此类身根。非此类眼根。谓生欲界不得眼根。设得已失。不得色界眼彼但成就欲界身根。二界眼根并不成就。有成就此类眼根亦此类身根。谓生欲界眼根已得不失。若生色界已得者。谓已至钵罗奢佉位等。不失者。谓所得眼根非自然坏。及遇缘坏故不失。生色界者色界无有根不具故。有非成就此类眼根。亦非此类身根。谓生无色界。彼地定无诸色根故。如眼根。耳根亦尔。此二俱有异界现前故。诸成就此类鼻根。彼成就此类身根耶。设成就此类身根。彼成就此类鼻根耶。答若成就此类鼻根。彼成就此类身根。有成就此类身根。彼不成就此类鼻根。谓生欲界不得鼻根。设得已失。不得鼻根者。谓未至钵罗奢佉位等。设得已失者。谓已得鼻根。或自然坏。或遇缘坏故。失如鼻根。舌根亦尔。此二俱无异界现前故。问何故生欲界得起色界眼耳根现在前。非鼻舌身根耶。答由眼耳二根。有加行得。离染得。修所成。通所依性四支五支静虑果故。得异界起现在前。鼻舌身根无如是事。故唯自界起现在前。有余师言。生欲界者求起上界天眼耳根。不求余三故不得起。谓观行者作是希求。云何令我见色界色。闻色界声。由此便修根本静虑起天眼耳。彼无香味可欲嗅尝故。不求起色界鼻舌。无生异地觉异地触。设于彼求无理可起。唯取至境故。问天眼以何为自性。答非诸筋骨血肉所成。色界大种所造净色。能无碍视体不可见。眼界眼处眼根所摄是谓天眼。显自性已当释其名。问此何因缘说为天眼。答此眼殊胜故名为天。世于胜法有天言故。如说天衣天庄严具天饮食等。此中皆以殊胜名天。彼亦如是。界者色界系。地者在四静虑地。非近分无色。所以者何。若地有通所依胜定。此地有天眼。非近分无色有通所依胜定。故彼地无天眼。问何故近分无色无通所依胜定耶。答奢摩他毗钵舍那不平等故。非五支四支所成故。非乐道所摄故。问若生欲界修得天眼。现在前时于何处起。答即于生得眼根处起。问若生得眼坏彼何处起。答即于曾有眼根处起。问若彼处所合为一段。不可知者复何处起。答即于应有眼根处起。问诸起天眼现在前者。为有左起右不起耶。右起左不起耶。左劣右中耶。左中右上耶。右劣左中耶。右中左上耶。答不如是起谓起天眼者必二处眼俱起。等劣等中等上。一切天眼无瞎无阙。亦无眩乱及彼同分。问若生欲界化作色究竟万六千踰缮那身。天眼现前观彼色时。人身长三肘半。或四肘尚不遍彼足指。为住何处观彼色耶。为上为下。有说。以神境通住上而见。如营舍人处上观下。如是居上观下众色。有说。住下而见如行像者处下观上。如是居下观上众色。有说。彼时以神境智证通。延广此身令遍所化万六千踰缮那身量而观众色。有说。欲界亦有万六千踰缮那身。应与所化色究竟身俱生。若时化作色究竟身。尔时欲界三肘半或四肘身便灭。彼万六千踰缮那身续起。即依常眼处所而观众色。如是说者。如彼生处异熟身量化身亦尔。如从色界来欲界时。化作化身还如欲界异熟身量。此作彼身当知亦尔。随彼所住观见众色

说一切有部发智大毗婆沙论卷第一百四十九阿毗达磨大毗婆沙论卷第一百五十

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    根蕴第六中触纳息第三之二

问若天眼现在前时。生得眼为断不。若断者云何不异熟生色断已复续。以阿毗达磨者。不欲令异熟生色断已续故。若不断者天眼生得眼二俱见色。云何不错乱耶。答应言不断以异熟色断已不续故。是故尊者妙音作如是问。天眼现在前时生得眼当言断耶。不断耶。答当言不断。即于是处有色界大种与所造天眼俱现在前。问若尔者天眼生得眼二俱见色云何不错乱耶。答天眼起时生得眼住彼同分故无有过。譬如余识现在前时。虽不见色而眼不断此亦如是。问何故不俱见耶。答以一身中无二识俱起。尔时识依天眼不依生得眼故。有说。有色非是生得眼境。为见彼故起天眼现前故。于尔时生得眼虽不断而无用是故不俱见。有说。天眼起时生得眼断。问若尔云何不异熟生色断已可续耶。如是则违阿毗达磨者说。答断有二种。一暂断。二究竟断。暂断者可续非究竟断。是故无过。有说。尔时生得眼灭天眼生。天眼灭生得眼生。彼身中眼根未尝空故不可谓断。有说。彼时生得眼断亦无有过。亦有异熟生色断已续故。云何知然。如契经说。一切施王即时举手自挑两目施婆罗门。由胜思愿令眼平复。又如经说。恶行尔时以朅地罗钩挑善行眼。亦由菩萨胜思愿故还得眼根。施设论说。地狱有山压迮有情令身碎坏。于后未久诸根复生。诸地狱中此类非一。故知异熟生色断已可续。如是说者。起天眼时生得眼不灭。异熟色断亦无续义。问前所引事当云何通。答彼不相违有别义故。即如所说一切施王。尔时但由施心成满。故作是说实未挑眼。其事云何。谓佛昔日为菩萨时。曾作国王名一切施。能满一切来求者意。天上人中此名流布。时天帝释知已念言。彼王如斯惠施无倦。为求无上正等菩提。为希世间名誉天位。若希天位或为我怨。当往验之知其施意。便自化作婆罗门身。戴帽垂鬓金韬络体。手策金杖来诣王前。咒愿王言愿常尊胜。王言梵志来何所求。答言我来正须王眼。王以四宝为眼施之彼不受言。我今须眼何用此为。王闻是已便举两手欲自挑目。帝释知王施心决定便止王言。欲何所求能施难施。为求释梵魔王位耶。为希世间名誉归敬。王言此等皆非所求。唯有离于生老病死应正等觉是我所愿。天帝闻已便复本形赞叹王言。真是菩萨不久定得无上菩提。作是言已忽然不现。故彼尔时实未挑眼。又彼所引善恶行经。善行眼根有余种子。由胜思愿圆满胜前。诸地狱中亦同此释。若无余种则不可生。故异熟色断无续理。由此天眼现在前时生得眼不断

问如生欲界所起天眼。生色界亦起不。有说。不起。以色界中随生得眼所见多少。修得眼亦尔无别作用是故不起。如是说者。亦起现前。问与生得眼同起复何用。答欲游戏通慧故起现前。又中有身非生得眼境故。起天眼观中有差别。问为生欲界所起天眼胜。为生色界所起胜耶。答欲界所起猛利故胜。谓佛独觉到究竟声闻所起天眼作用猛利。非生色界所能现前。色界所起所依故胜。谓彼依身广大胜妙。所起天眼多极微成。非欲界中此眼得起。故二界起各有胜劣

问修得天眼与生得眼有何差别。答名即差别。谓名天眼名生得眼。有说。体亦有异。谓生得眼有同分彼同分。修得天眼唯是同分。又生得眼通所长养及异熟生。修得天眼唯所长养。有说。因亦有异。谓生得眼是业果。修得天眼是修果。问岂不生得眼亦是修果耶。答彼少分是修果。少分是生得智异熟果。天眼唯修果。有说。天眼由加行作意力方得现前。生得眼不尔。有说。果亦有异。谓生得眼与善染无记识为所依。修得天眼唯与无记识为所依。有说。境亦有异。谓生得眼不见中有。修得天眼能见中有。有说。用亦有异。谓修得天眼于生得眼。作用炽盛微妙殊胜。清净明白捷利远细故有差别问一念得起几通果耶。答诸有欲令无留化事。天眼天耳无彼同分者。彼说一念唯起一通果。谓五通随一。诸有欲令有留化事天眼天耳。无彼同分者。彼说一念得起二通果。谓神境通果及余四随一。诸有欲令有留化事。天眼天耳有彼同分。彼说一念得起四通果。谓神境通果天眼天耳及余二随一。谓他心通宿住。随念通。境界各别不俱起故。如是说者。应知第二所说为善。以化事可留。天眼天耳必无彼同分。要于用时乃现前故

问欲界所化色有四种。谓初静虑果。乃至第四静虑果。依初静虑所得天眼。为能具见四种色耶。有说。具见皆是欲界色处摄故。有说。唯见初静虑果非余。以因胜故如因非境果亦应尔。依第二静虑所得天眼。能见初二静虑果色非余。依第三静虑所得天眼。能见前三静虑果色非余。依第四静虑所得天眼。具能见四静虑果色。如是说者。谓初说依初静虑所得天眼。能见欲界初静虑色。乃至依第四静虑所得天眼。能见欲界四静虑色。问依第四静虑所得天眼。能见欲界四静虑色者。为见欲界色眼即见余地色为更起余眼见余地色耶。若见欲界色眼。即见余地色者。如何一眼能见粗细二境。若更起余眼见余地色者。即第四静虑天眼应有五类。各唯见一地色。即不应言此地天眼五地为境。有作是说。即见欲界色眼。能见余地诸色。问如何一眼能见粗细二境。答此亦无过。如看大山即粗细色俱时能见。见粗色者如见千枝大树。见细色者如见中间细草。如是第四静虑一眼能见五地诸色何过。有余师言。见欲界色眼异。乃至见第四静虑色眼异。问若尔第四静虑天眼应有五类。各唯见一地色即不应言此地天眼五地为境。答一地天眼有五类别亦无有过。约地种类。总说一眼见五地境。非不于中所见各异。如定蕴说。依初静虑所引天眼。极能见何系色。答乃至梵世系。依第二静虑所引天眼。极能见何系色。答乃至极光净系。依第三静虑所引天眼。极能见何系色。答乃至遍净系。依第四静虑所引天眼。极能见何系色。答乃至广果系。问傍极见几何。有说。如见上。有说。傍见则宽。如是说者。彼文且说见上分齐不说傍境。然随根势力傍见不定。有远有近如余处说

施设论说。如四大王众天以智以见领解于人。人于四大王众天不能如是。除有修有神通或他威力。乃至他化自在天对人亦尔。谓四大王众天等亦是人眼境。界同一系故。然以极远不能见之。若得神通自能往见。或他力引至彼能观。问若彼天来此能见不。答见。若尔彼中何故不说。答境界少故不说。复次此即摄在他力引中故不别说。又彼论说。如梵众天以智以见领解于人。人于梵众天不能如是除有修有神通或他威力。乃至色究竟天对人亦尔。问彼论所说除有修言是事可尔。云何得说除有神通或他威力。所以者何。虽有神通或他力引得至彼天。若无天眼不能见故。若有天眼虽不至彼亦能见故。答彼但应说除有修言。而复有余言者。有别意趣。谓依他方梵天等说。他方梵天等色亦是此方依初静虑等所引天眼境界。然以极远虽得彼眼不能见之。若自有神通或他力所引至彼乃能以天眼见。除有修言显得天眼。说后二句显至彼因。故彼所说有别意趣彼施设论复作是说初静虑中有三天处。谓梵众梵辅及大梵天。问如是三天互相见不。答彼互相见。问契经所说当云何通。如说梵王有得自体如童子像。非梵众天眼之境界。答是彼眼境而大梵王通力所遮令彼不见。第二静虑有三天处。谓少光无量光极光净。问如是三天互相见不。答彼互相见。第三静虑有三天处。谓少净无量净遍净。问如是三天互相见不。答彼互相见。第四静虑有八天处。谓无云福生广果无烦无热善现善见色究竟。问如是八天互相见不。答彼互相见皆以同一系故

法蕴论说。于眼周围有时有分。色界大种所造天眼。清净现前由此天眼能见前后左右下上诸色差别。见前后左右诸色者。非石壁等所障故。见下诸色者非地水等所障故。见上诸色者。非云雾等所障故。问如是天眼能于一时顿见十方诸色境不。有说。能见以天眼根光明清彻自然遍照。如末尼宝遍发光明。有说。不能一时顿见。问法蕴所说当云何通。答彼说天眼诸方无障。非谓彼能一时顿见。谓人等眼但能睹见面所向色。欲见余方要须回转俯仰方见。天眼不尔面向一方随欲能见不须回转。故说能见上下诸方。非谓十方一时而见

有作是说。意净故见。问意净是信即心所法与心相应此非见体。云何能见。答彼依意根无有扰浊密意而说。谓若意根不余驰散离诸扰浊。能令眼根见色分明故作是说有作是说。胜解故见。问所说胜解是心所法与心相应。此非见体。云何能见。答依瑜伽师意乐安立故作是说。谓瑜伽师起此意乐。令我一念见十方色。然能见色非即胜解。又施设论作如是说。诸有现入青遍处定。从彼定起所见皆青。又由多时住青林中。后出余处所见皆青。依此故言胜解故见。有作是说。即人眼根转为天眼能无障见。此是数论外道所立。彼作是说。所起天眼即是人眼。数习转变明净胜前立以天称。如中印度青林中行。或经旬乃至数习所变举目皆青。修天眼时亦复如是。若尔盲者应不能修此天眼通。便与圣教及现见事皆悉相违。又法无常云何转变。一切天眼皆名无对。石壁等物不能碍故。问一切天眼于所见色为有碍不。若有碍者何故说无对。若无碍者如何住彼色。答于所见色应说有碍。问若尔何故名无对耶。答对有二种。一境界有对。二障碍有对。若依境界有对。天眼名有对。于自境界不能越故。若依障碍有对。天眼名无对。石壁等障不能碍故。此约于境作用而说。若约自体亦是障碍有对所摄极微性故。又诸天眼于境界中。诸瑜伽师随欲自在。于所欲见则有对碍。所不欲见则无对碍

一切天眼光明增上光明所引。问天眼欲见闇中色时云何能见有作是说。此由神通引起光明能见彼色。此不应理不得神通。便应不能修起天眼。如是说者。初引通时若离光明不能见色。若通成满设离光明亦能见色。问神通天眼俱有光明有何差别。答神通光明或自性有或变化有。天眼光明唯自性有。有作是说。天眼光明或自性有或变化有。神通光明唯变化有

诸素怛缆毗奈耶中。皆说菩萨成就异熟生天眼。昼夜能见面各踰缮那。问菩萨所成异熟生眼实非天眼。何故立此名。答菩萨眼根体用殊胜。如世胜事假立天名。问诸余有情亦能远见山日月等。菩萨但见面各踰缮那云何名胜。答如彼所见菩萨亦能面各踰缮那约无障说。谓无障处诸余有情虽能远见。若有障处自掌中物亦不能见菩萨不尔面各踰缮那障无障处悉能彻视。又余有情虽能远见唯粗非细。菩萨不尔。面各踰缮那乃至毛端亦能见故。又余有情虽能远见唯昼非夜。菩萨不尔面各踰缮那昼夜俱见。有说。于余有情所见远近菩萨过彼一踰缮那故作是说。问菩萨成就如是净眼应见女身不净充满。何缘故有染习事耶。胁尊者言。菩萨烦恼未断未遍知。是故犹为无明所迷不应责问。如不应责无明者愚盲者堕坑。有说。菩萨染习彼时不观不净。观不净时不染习彼。有说。菩萨先世曾种胜受用业。于所受用不见不净。所不受用便见不净。如是说者。菩萨成就猛利智慧。善观功德过失差别。诸女人身亦容具有功德过失。菩萨观察彼功德时。胜于一切耽着欲者。若当观察彼过失时。胜于一切不净观者。观彼功德故有染习

问转轮王眼齐何能见。答王四洲者面各能见四俱卢舍。乃至王一洲者面各能见一俱卢舍。问主藏臣眼齐何能见。答四洲王臣见三俱卢舍。乃至一洲王臣见半俱卢舍。如契经说。轮王有时欲试藏臣威力所及。乘船游戏殑伽河中。敕藏臣言吾今须宝藏。臣敬诺请还办之。王不悦曰正尔须办。藏臣惶恐即以两手[打-丁+毛]搅水中。应时捧出种种珍宝持以献王。复白王言须者可取。其不须者还弃水中。问轮王眼根胜主藏者何不自取令臣取耶。答诸尊胜人法应如是。如余尊者虽有自知饮食衣服资具所在。而不自取此亦如是。有余师说。诸转轮王余生积集感侍臣业彼业今熟。诸有所须皆有侍臣令其供办。若王自取业即唐捐。问因论生论。何等名为诸转轮王感侍臣业。答父母师长如法教诲敬顺无违是为此业。若先曾习如是业者。感多侍人所欲皆办。问曾闻殑伽河水有处深一踰缮那。如何藏臣手及其底取诸珍宝。答以轮王业增上力故令宝上升。有说。药叉健达缚等持来授与。有说。恒有十千天神随主藏臣。而为给使彼持授与。问藏臣何故启白王言。余所不须当还弃水。答显王业果不思议故。诸有所须随处可得。不同余类恐身命缘。当有阙乏长时积聚

问声闻独觉及佛天眼能见几世界色。答声闻天眼不作加行见小千界。若作加行见中千界。独觉天眼不作加行见中千界。若作加行见大千界。世尊天眼不作加行见大千界。若作加行能见无量无边世界。如天眼通。天耳通等亦尔

地狱成就几根。乃至广说。问何故此中但说成就极多少位非余位耶。答彼作论者意欲尔故。乃至广说。有说。欲除文杂乱过。谓若具说一切位者。便于文杂乱难可受持故。依多少边际而说。地狱成就几根。傍生乃至诸无色随信行乃至俱解脱成就几根。答地狱极多十九极少八。十九者。谓除三无漏根。即是具七色根不断善者。八者谓身命意及五受根。即失六色根已断善者。傍生极多十九极少十三。十九者。谓除三无漏根。即具七色根者。十三者。谓身命意五受信。等五根。即渐命终先舍六色根者。如说傍生。鬼界亦尔。断善根者极多十三极少八。十三者。谓除一形及信等五三无漏根。八者。谓身命意及五受根。即渐命终及在地狱已失六色根者。邪定聚极多十九极少八。十九者。如地狱极多说。八者如断善极少说。除在地狱失六色根正定聚极多十九极少十一。十九者。谓除一形及二无漏根。即未离欲染不缺根圣者。十一者。谓命意三受信等五一无漏根。即生无色界圣者。不定聚极多十九极少八。十九者。如邪定极多说。八者如断善极少说。及生无色界。异生成就命意舍信等五根。赡部洲极多十九极少八。十九者。谓二形者除三无漏根。及未离欲圣者除一形二无漏根。八者。谓身命意五受根。即断善者渐命终位如赡部洲。毗提诃洲瞿陀尼洲亦尔。俱卢洲极多十八极少十三。十八者。谓除一形三无漏根。十三者。谓身命意五受信等五根。即渐命终位。彼洲无有扇搋半择迦无形二形。断善根邪定正定及离染者。四大王众天极多十九极少十七。十九者。谓除一形二无漏根。即未离欲染圣者。十七者。谓除一形忧根三无漏根。即已离欲染异生。如四大王众天。三十三天。乃至他化自在天亦尔。梵众天极多十六极少十五。十六者。除二形二受二无漏根。即彼圣者。十五者。除二形二受三无漏根。即彼异生。如梵众天。极光净天亦尔。遍净天极多十六极少十四。十六者如前说。十四者。除二形三受三无漏根。即彼异生。广果天极多十六极少十三。十六者如前说。十三者。除二形四受三无漏根。即彼异生中有极多十九极少十三。十九者。谓二形者。除三无漏根。及未离欲染圣者。除一形二无漏根。十三者。谓断善者。除一形信等五三无漏根。及广果异生。除二形四受三无漏根。诸无色极多十一极少八。十一者。命意三受信等五一无漏根。即彼圣者。八者命意舍信等五根。即彼异生。随信行极多十九极少十三十九者。除一形二无漏根。即未离欲染住见道者。十三者。身命意四受信等五一无漏根。即已离欲染渐命终位入见道者。问何故此位能入见道。答是爱行者。一期生中恒厌生死。临命终时苦受所触。厌心转增能入见道。如随信行随法行亦尔。信胜解极多十九极少十一。十九者。除一形二无漏根。即未离欲染信胜解。十一者。命意三受信等五一无漏根。即无色界信胜解。如信胜解见至亦尔。身证极多十八极少十一。十八者。除一形忧根二无漏根。即欲界身证。十一者如信解胜极少说。如身证。慧解脱俱解脱亦尔。然身证成就已知根。二解脱成就具知根

眼根乃至慧根。得遍知时几根得遍知耶。答眼根得遍知时。至离色染五根得遍知。此中遍知是彼爱断遍知果故。得遍知名五根者。眼耳鼻舌身离色染时彼永断故。虽于此位断十三根。唯此五根得究竟断。如眼根。耳鼻舌身根亦尔。女根得遍知时。至离欲染四根得。遍知。谓男女忧苦。虽于此位断十九根。唯此四根得究竟断。如女根。男根苦根忧根亦尔。命根得遍知时。至离无色染八根得遍知。谓命意舍信等五根。如命根。意舍信等五根亦尔。乐根得遍知时。至离遍净染即乐根得遍知。喜根得遍知时。至离极光净染即喜根得遍知

眼根乃至慧根灭作证时。几根灭作证耶。答眼根灭作证时。至离色染五根灭作证。至阿罗汉十九根灭作证。五根者。眼耳鼻舌身。十九者。除三无漏根。如眼。耳鼻舌身根亦尔。女根灭作证时。至离欲染四根灭作证。至阿罗汉十九根灭作证。四者。男女忧苦。十九者。如前说。如女根。男苦忧根亦尔。命根灭作证时。至阿罗汉。十九根灭作证如前说。如命根。意舍信等五根亦尔。乐根灭作证时。至离遍净染即乐根灭作证。至阿罗汉十九根灭作证。如前说。喜根灭作证时。至离极光净染即喜根灭作证。至阿罗汉十九根灭作证。如前说。问此二门何差别。答诸有欲令无间道断系得。解脱道证离系得者。彼说如无间道作用。遍知门亦尔。如解脱道作用。作证门亦尔。诸有欲令无间道断系得。亦证离系得者。彼说如断系得。遍知门亦尔。如证离系得。作证门亦尔。如断系得证离系得除过失修功德。弃下劣证美妙。舍无义得有义。尽爱膏油受无热乐。应知亦尔。有说。如断未断初门亦尔。如证未证后门亦尔。有说。如初作证初门亦尔。如重作证后门亦尔。有说。如断时作证初门亦尔。如断已作证后门亦尔。是谓遍知作证差别

说一切有部发智大毗婆沙论卷第一百五十阿毗达磨大毗婆沙论卷第一百五十一

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    根蕴第六中等心纳息第四之一

一切有情心。当言等起。等住。等灭耶。如是等章。及解章义既领会已。当广分别。问何故作此论。答欲令疑者得决定故。谓诸有情或有身形广大。或有身形狭小。身形广大者。如大海中有诸有情所得自体其量广大。或百踰缮那。或二三四五六七百。或乃至二十一百踰缮那。如曷逻呼阿素洛帝形量广大。长十六千踰缮那。如色究竟天身量身形狭小者如蚊蚁蠛蠓水醋细虫。诸明眼人虽极作意亦不能见。勿有生疑。身广大者心亦广大。身狭小者心亦狭小。欲令此疑得决定故。显有情类大种所造色。虽有多少而心皆等故作斯论。又诸有情或有行动捷速。或有行动迟缓。行动捷速者。如马鹿猫狸等。行动迟缓者。如蛴螬蚯蚓等。勿有生疑。行动速者心生灭速。行动迟者心生灭迟。为令此疑得决定故。显诸有情虽大种所造色动有迟速。而心生灭无不皆等。又诸有情或有威仪轻躁。犹若风颷觉慧漂转如波上日。或有威仪敦重犹如山岳。觉慧沉静如密室灯。勿有生疑。威仪轻躁觉慧漂转者心生灭速。威仪敦重觉慧沉静者心生灭迟。为令此疑得决定故。显诸有情虽威仪有轻重觉慧有浮沉。而心无不等生等灭。问若诸有情心等生灭。何故威仪有轻重觉慧有浮沉耶。答有诸有情于多境界有多心起。有诸有情于一境界有多心起。若诸有情于多境界起多心者。则威仪轻躁觉慧漂转。若诸有情于一境界起多心者。则威仪敦重觉慧沉静。由此等缘故作斯论。一切有情心当言等起等住等灭耶。答如是。问为一切有情心等生等灭。彼一切一刹那生一刹那灭耶。为非一切有情心等生等灭。亦非一切一刹那生一刹那灭耶。设尔何过。若一切有情心等生等灭。彼一切一刹那生一刹那灭者。有心位可尔。无心位云何。谓入无想灭尽定时。余有情心亦生亦灭。彼心灭而不生。出无想灭尽定时。余有情心亦灭亦生。彼心生而不灭。住无想灭尽定时。余有情心亦生亦灭。彼心不生不灭。云何可说心生灭等同一刹那。若非一切有情心等生等灭。亦非一刹那生一刹那灭者。此中所说当云何通。谓一切有情心等起住灭。答应作是说。一切有情心等生等灭。彼一切一刹那生一刹那灭。问有心位可尔。无心位云何。答有心位可尔。无心位亦可尔。谓入无想灭尽定时。如余有情心生彼最初刹那定亦生。如余有情心灭。彼入定心亦灭。出无想灭尽定时。如余有情心生。彼出定心亦生。如余有情心灭。彼最后刹那定亦灭。住无想灭尽定时。如余有情心刹那刹那亦生亦灭。彼中间定刹那刹那亦生亦灭。是故有心无心位俱可尔。有余师说非一切有情心等生等灭。亦非一切一刹那生一刹那灭。谓有有情心灭不生。如入无想灭尽定者。或有有情心生不灭。如出无想灭尽定者。或有有情心不生不灭。如住无想灭尽定者。或有有情心亦生亦灭。如住有心位者。问此中所说当云何通。答此依量等而说。勿有谓心或大或小故说一切有情心等。如是说者。一切有情心等起等灭。彼一切一刹那生一刹那灭。以有为法从缘生已皆则灭故。有贪心离贪心当言等起等住等灭耶。答如是。有嗔离嗔有痴离痴。略散下举。小大掉不掉。不静静。不定定。不修修不解脱解脱心。当言等起等住等灭耶。答如是。问何故作此论。答诸染污心其性沉重。诸善心其性轻举。勿有生疑。染心生灭迟缓。善心生灭迅速。为令此疑得决定故。显二种心生灭时等故作斯论。由二义故心名有贪。一与贪相应。二为贪所系若唯贪相应故名有贪心。则嗔等相应品。及有漏善无覆无记应名离贪心。然彼亦名有贪心。贪所系故。虽由二义心名有贪。此中但依相应义说无杂乱故。亦由二义心名离贪。一贪不相应。二是贪对治。若唯贪不相应名离贪心者。则嗔等相应品亦应名离贪心。然彼不应名离贪心有染污故。虽由二义心名离贪。此中但依贪对治说无杂乱故。有嗔离嗔等皆准此知。是故此中应作是说。有贪心者。谓贪相应。离贪心者。谓贪对治。有嗔心者谓嗔相应。离嗔心者谓嗔对治。有痴心者谓痴相应。离痴心者谓痴对治。略心者谓善心于境摄录故。散心者谓染心于境纵逸故。健驮罗国诸论师言。眠相应心说名为略。以世尊说眠名心略故。如契经说。云何眠梦。谓眠梦位略聚散心。问云何释通见蕴所说。彼说四智如实知略心。谓法智类智道智世俗智一智如实知散心。谓世俗智。答彼说不应通以违他说而作论故。若欲通者当改彼文。略心散心下心等一智如实知。谓世俗智举心等四智如实知如前说。彼说非理。若如是说则染污眠心。应亦略亦散。眠相应故是染污故。欲令无如是过。是故如前所说为善。下心者谓染污心懈怠相应故。举心者谓善心精进相应故。小心者谓染污心。小生所习故。大心者谓善心大生所习故。问无量有情习诸恶行非诸妙行。染心现前非诸善心。云何名染心小生所习。善心大生所习耶。答不以众故立大小名。此中若能修行白法说名为大。余名为小故。三界中唯有一佛而名为大具白法。故余类虽多而名为小。以诸白法不具足故。有说。染心名小。小价得故。谓染污心不由加行不须财宝。但起少许非理作意便相续转如大河流善心名大大价得故。谓诸善心要由加行。及多加行。虽舍百千珍宝有能现前。或不现前。有说。染心名小。少根相应故。谓诸染心或但一根。或二相应无具三者。善心名大。多根相应故。谓诸善心皆与三根相应无有阙者。有说。染心名小。少随转故。谓诸染心唯三蕴随转。善心名大。多随转故。谓诸善心或三蕴或四蕴随转。有说。染心名小。少眷属故。谓诸染心无未来修。善心名大。多眷属故。谓诸善心有未来修。有说。染心名小。少对治故。谓多烦恼相续现前。断少善根后还相续。善心名大。多对治故。如起一念苦法智忍。顿断欲界见苦所断十种随眠令永不起。有说。染心名小。导首劣故。何等名为染心导首。谓诸无明。如说无明。为导首故。便起无量恶不善法。及能引生无惭无愧。犹如商主无眼无足。令诸商人所求不遂。善心名大。导首胜故。何等名为善心导首。谓诸慧明。如说慧明为导首故。便起无量诸妙善法。复能引生殊胜惭愧。犹如商主有眼有足。令诸商人所求果遂。有说染心名小。威力小故。善心名大。威力大故。谓无始来所习恶法。善法才起悉令远离。如经多时习无碱想才食盐时彼想皆舍。又如室中多时积闇灯明才至彼闇便除。又善法断恶永令不生。恶法断善后必相续。由此等缘染心名小善心名大。掉心者。谓染污心掉举相应故。不掉心者。谓善心行舍相应故。不静心者。谓染污心不寂静相应故。一切烦恼皆不寂静性。静心者。谓善心寂静相应故。一切善法皆寂静性。不定心者。谓染污心散乱相应故。定心者。谓善心等持相应故。不修心者。谓于得修习修俱不修心。修心者。谓于得修习修随一或俱修心。不解脱心者。谓于自性解脱相续解脱不解脱心。解脱心者。谓于自性解脱。相续解脱。随一或俱解脱心。寿当言随心转不随心转耶。答不随心转。问何故作此论。答欲止他宗显己义故。谓分别论者说寿随心转。问彼何故作是说。依契经故如契经说。寿暖识三和合非不和合。如是三法不可施设离别殊异。由此证知寿随心转。为止彼说显寿不随心转故作斯论。问何故寿不随心转。答随心转法决定与心一起一住一灭。寿非与心决定一起一住一灭故。有说。随心转法决定与心一果一等流一异熟。寿非与心决定一果一等流一异熟故。有说。随心转法决定与心俱生。寿非决定与心俱生故。有说。随心转法法尔心若善彼亦善。不善无记亦尔。寿唯无记。若随心转者则无记心现在前时寿可转。善不善心现在前时寿应断故。有说。随心转法。法尔心若欲界系彼亦欲界系。色无色界系不系亦尔。寿唯三界系而随生。此界有此界寿非余。若随心转者则生欲界欲界心现在前时寿可转。色界等心现在前时寿应断。乃至生无色界说亦如是。有说。随心转法法尔心若学彼亦学。无学非学非无学亦尔。寿唯非学非无学。若随心转者非学非无学心现在前时寿可转。学心无学心现在前时寿应断。有说。随心转法法尔心若见所断。彼亦见所断。修所断不断亦尔。寿唯修所断。若随心转者则修所断心现在前时寿可转。见断等心现在前时寿应断。有说。随心转法。法尔心有彼有。心无彼无。若寿随心转者。有心时寿可转。无心时寿应断。则住无想灭尽等至。及生无想心不行时。应名为死无命根故。欲令无如是过。是故寿不随心转。问分别论者所引经云何通。如说寿暖识三和合非不和合。乃至广说。尊者世友说曰。此约一所依一相续说。谓此三法于一所依一相续中皆具可得。不说三法必互随转。若如所说作决定者。应不施设蕴界处异。以彼经言如是三法不可施设离别殊异故。然寿是行蕴法界法处摄。暖是色蕴触界触处摄。识是识蕴七心界意处摄。由此不应如文而取。又此三法若定和合。无色界应有暖。非情中应有寿识。无想定等应有识现行。若许便违圣教正理。是故不可随文定取。应知此文依容有义说和合等

寿当言随相续转为一起便住耶。答若欲界有情不住无想灭尽等至。当言随相续转。若住无想灭尽等至。及色无色界有情。当言一起便住。问何故作此论。答欲止他宗显己义故。谓譬喻者不许有非时命终。所以者何。如契经说。寿终不可救。由此故知无非时死。为止彼意显有非时命终故作斯论。问云何名为随相续转。有说。灾横名为相续。谓生欲界不住无想灭尽等至。寿随灾横相续而转。所以者何。若有于寿非恒作。非恒转。非受作。非受转。非时行。非处行。不修梵行食非宜食非量。生者不熟熟者持之。于宜匪宜。不能观察。不服医药。不用医言。不避灾危。作诸凶戏。由此等故寿便中夭。若有于寿恒作恒转受作受转。时行处行修梵行。食所宜食应量。生者令熟熟者弃之。于宜匪宜能审观察服医药用医言。避灾危远凶戏。由此等故寿不中夭。有说。色身名为相续。谓生欲界不住无想灭尽等至。寿随色身相续而转。所以者何。若身平和寿则无夭。若身损坏寿则中夭。有说。他身名为相续。谓生欲界不住无想灭尽等至。寿随他身相续而转。所以者何。若有他身于己寿命不为损害寿便无夭。若为损害寿便中夭。问云何名为一起便住。答随因起已便相续住不随灾横。自身他身违害而转。谓生欲界现住无想灭尽等至。及生上界寿皆不随外缘而转。问欲界不入二无心定。亦有寿量不随缘转。何故不说。答应说而不说者当知此义有余。有说。此中说决定者。谓若住二无心定寿行决定不随缘转。余或随缘是故不说。有说。欲界虽复更有不随缘转。然为显示二定威力故偏说之

如经说有情所得自体有四种。一有所得自体。可为自害不为他害。二有所得自体。可为他害不为自害。三有所得自体。可为自害亦为他害。四有所得自体。不为自害亦不他害。云何有情所得自体可为自害不为他害。谓有欲界戏忘诸天。时好严身耽着嬉戏过时疲极失念而死。复有欲界意愤诸天。有时忿恚角眼相视。久愤不胜从彼殒殁。复有一类或龙妙翅。或鬼及人或复所余。可为自害非他害者。云何有情所得自体可为他害不为自害谓处卵壳或胎藏中。诸根未满诸根未熟。复有一类或龙妙翅。或鬼及人或复所余。可为他害非自害者。云何有情所得自体可为自害亦为他害谓诸禽兽或龙妙翅。或鬼及人或复所余。可为自害亦他害者。云何所得自体不为自害亦不他害。谓生色无色界一切中有。一切地狱。住无想定灭尽定慈定。随信行随法行。最后有菩萨。菩萨母菩萨处胎时。转轮王轮王母轮王处胎时。王仙佛使佛所记者。如殑耆罗殊底穑迦长者子。嗢怛罗长者子。达弭罗长者子。治奢胜织师子。时缚迦鸠摩罗等。佛所记者。住最后有补特伽罗所作未办。北俱卢洲劫初时人。哀罗伐拏龙王善住龙王。琰摩王等。及余一类俱不害者。是名四种所得自体。世尊说有所得自体。不为自害亦不他害。时尊者舍利子。从座而起偏袒一肩。右膝着地合掌恭敬。而白佛言。何等有情所得自体。不为自害亦不他害耶。佛告舍利子。非想非非想处有情。不为自害亦不他害。问因论生论。尊者舍利子于此所问为了知不。若了知者何故复问。若不了知云何得名到究竟声闻。云何世尊不于非田非器而雨法雨。令所说法空无果耶。有说。尊者了知问。若尔何故复问。答亦有知而故问。如毗柰耶说。尔时世尊知而故问为令所说得明了故。又彼尊者虽自了知。为饶益他是以故问。谓于众会有未了知。无无畏故不能问佛。尊者舍利子成就无畏。为益彼故虽知而问。有说。尊者亦不了知问。若尔云何得名到究竟声闻答不说不知说已则知斯有何过。问云何不于非田非器而雨法雨。令所说法空无果耶。答尊者舍利子虽不了知。而于众中有余能知。如慈氏菩萨等故。非无果若无漏慧。虽尔时舍利子胜。若此俗慧则慈氏菩萨胜。故佛一时与慈氏菩萨论世俗谛。舍利子等诸大声闻莫能解了。问下地自体亦有俱非自他所害。何故但说非想非非想处耶。答举后显初故作是说。世尊有处举后显初。如此文等有处举初显后。如说离欲恶不善法。有寻有伺离生喜乐初静虑具足住。如是等。如举后显初举终显始。举出显入举究竟显加行。应知亦尔。有说。下地不定是以不说谓下地有情所得自体。或无灾横如住无想定等。或有灾横如戏忘诸天等。非想非非想处定无灾横是故偏说。有说。四静虑三无色中。亦有如欲界戏忘死等事。非想非非想处都无此事是故偏说。有说。下地有情皆有烦恼势力增上。彼若现前则便夭殁。非想非非想处无此烦恼。是故世尊但说彼地。尊者法救作是释言。此中为自所害者。谓为自地对治道所害。为他所害者。谓为上地边对治道所害。初静虑自体为自所害。谓自地圣道为他所害。谓第二静虑边世俗道。乃至无所有自体为自所害。谓自地圣道为他所害。谓非想非非想处边世俗道。非想非非想处自体非自所害。自地无圣道故。亦非他害。无上地边世俗道故。由此但说非想非非想处。所得自体非俱所害

住无想灭尽等至。寿当言转为住耶。答当言转。问何故作此论。答为令疑者得决定故。谓住无想灭尽等至诸心心所一切不行。尔时心心所法不起不灭。勿谓此位所有寿行。如心心所亦不起灭但凝然住。为除此疑显此位寿念念起灭故作斯论。问云何名转。答刹那刹那起灭相续故名为转。则是迁流非凝住义。如世尊说人寿渐尽如小河水。若诸有情寿起便住。云何知彼寿渐尽耶。答由世尽劫尽故。问何故作此论。答为令疑者得决定故。谓前文说若住无想灭尽等至。及色无色界有情寿。当言一起便住。或谓彼寿一起不灭。为除此疑显彼寿行。离灾横故说一起便住。而实刹那刹那有生有灭。令寿渐尽故作斯论。问五蕴皆渐尽。何独说寿耶。答世尊此中举寿渐尽显五皆有渐尽之义。有说。寿胜佛于此中。举胜显劣故但说寿尽。有说。寿能任持五蕴。若说寿尽当知已说五蕴尽义。有说。寿断众同分亦断。众同分断五蕴亦断。佛随根本。而说故说寿尽。有说。寿量有增有减有盛有衰故佛偏说问诸趣皆有寿渐尽义。何故但说人寿渐尽。答佛于尔时为人说故。有说佛意以人为首。显诸趣中寿皆渐尽。有说。佛是人之同类故。所说法多随顺于人。有说。人寿有极增减盛衰义故。谓劫初时人寿无量。其后渐减至八万岁。后更转减乃至十岁。如是人寿渐尽义明了可知。余趣不尔故佛偏说。问诸大河水亦有渐尽义。何故但说如小河耶。答大河常流不可知其渐尽。不如诸小河水。有时盈溢如夏雨时。有时干枯如至寒际。诸有情类寿河亦然。有时盈溢如结生位。有时都尽如舍命时。是故世尊以小河喻。若诸有情寿起便住者。谓住二无心定。及上界有情。世尽劫尽者。有说。细无常名世尽。粗无常名劫尽。有说。刹那无常名世尽。一期无常名劫尽。有说。有情数物无常名世尽。非有情数物无常名劫尽。有说。内法无常名世尽外法无常名劫尽

入无想定几根灭耶。乃至广说。问何故作此论。答欲止他宗显己义故。谓譬喻者分别论师执。无想定细心不灭。彼作是说。若无想定都无有心。命根便断应名为死。不名在定为止彼意显无想定都无有心。有执。此定虽无有心但离欲染则能现起。以界同故。为遮彼意显无想定离遍净染方能现前。要以第四静虑为等无间缘故。由此尊者世友作如是言。云何无想定谓已离遍净染未离上染。出离想作意为先。心心所法灭是名无想定。由此因缘故作斯论。入无想定几根灭答七。谓意舍信等五根。何系心心所灭。答色界系。此依界类总相而说。然唯第四静虑地系。出无想定几根现前。答七。如前说。何系心心所现前答色界系。此亦依界类总相而说。然唯第四静虑地系。由此所说证无想定决定无心。以入定时但说诸根心心所法灭。而不说起。于出定时但说诸根心心所法起。而不说灭故

说一切有部发智大毗婆沙论卷第一百五十一阿毗达磨大毗婆沙论卷第一百五十二

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    根蕴第六中等心纳息第四之二

问无想定自性云何。答不相应行蕴为性。是彼摄故。界者在色界。地者在根本第四静虑地。问何故下地无此定耶。答非田非器乃至广说。又无想定灭心心所故。得下地不顺心心所灭。问何故第四静虑顺心心所灭。非下地耶。答诸欲入彼定者先起欲界善心。次入初静虑。次入第二静虑。次入第三静虑。后入第四静虑。于第四静虑上中下心。从上入中。从中入下。下品心断入无想定。譬如女人续毛为缕。除去粗者缉绩细者乃至将尽以手绝之。入无想定当知亦尔。从粗入细乃至都灭故。此唯在第四静虑。又下诸地有欢戚受行相粗动难可除灭。第四静虑唯有处中受行相微细易可断灭。故下地中无无想定。问何故无色界无彼定耶。答唯有异生计习此定以为能证无想涅槃。无色界中无有无想异熟可计故。无想定于彼亦无。又诸异生怖畏断灭。彼界无色若更灭心便为断灭。是彼所怖故彼界中无无想定。问此无想定何处能起。有作是说唯欲界起欲界心猛。有说。力故。有余师说。通欲界三静虑起由念曾修加行势力亦能起故。复有说者。第四静虑亦能现起除无想天勿果与因极相逼故。彼殁定当生欲界故。问此无想定谁所起耶。答唯异生起由作出离想故。圣于有法无出离想。问起此定。后有能入见道不。有说。不能由此定是异生定故。若起此定后能入见道。便有圣者成就此定。不应名异生定。有说。起此定后亦能入见道。问若尔云何名异生定。答圣虽成就而不现行。彼依现行名异生定。是故尊者妙音说曰。得此定补特伽罗有能入正性离生者。应言退失此定。于彼极厌不现行故。命终生于第四静虑。于彼处所有容受故。评曰。应知前所说好。问此无想定为加行得。为离染得。答是加行得非离染得。离第三静虑染时不得故。若离染得者圣离第三静虑染时亦应得。然则不应名异生定。问此无想定亦得过去修未来耶。有说。不然。唯有心定可有是事。非于无心有得修义若作是说。定初刹那唯成就现在。定余刹那成就过去现在。出此定已但成就过去。有说。此定有未来修。以加行得法有未来修故。此定必由极作意力加行而得。云何无未来修耶。若作是说。定初刹那成就未来现在。定余刹那成就三世。出此定已成就过去未来。问若如有心有得修者。圣离第三静虑染第九无间道时。如得第四静虑并眷属亦应得此定。是则不应名异生定。答前说此定唯加行得。是故异生圣者离第三静虑染时皆悉不得。唯诸异生离彼染已。以加行力方乃得之。是故无过。如是说者。应如初说。以有心定可未来修。此定无心无未来修义。由此过去亦无得理。如别解脱律仪。此亦如是。问此无想定有退转不。答此无退转。云何知然。曾闻有苾刍得无想定。出此定已诸根寂然。进止威仪语言衣着。受诸饮食皆悉详审。有阿罗汉先得愿智。见已念言此善男子。必获胜法我当观其所证边际。念已入定以愿智力见彼苾刍得无想定。便从定起而语之言。汝之所证极为非善。如何遇佛功德宝藏。舍而谬取外道所学粪坏定耶。汝今宜应疾疾弃舍。苾刍闻已作意舍之。此定随逐不能舍离。乃至休道还家亦不能舍。后命终已生无想天。故知此定不可退转。譬喻者说。此有退转。以一切业皆可转故。乃至无间业若遇胜缘亦有转义。若无间业不可转者。应无有能越第一有。评曰。应知前所说好。问此无想定于众同分为能牵引。为但圆满。答但能圆满不能牵引。以众同分唯业所引此非业故。问此无想定为顺现法受为顺次生受。为顺后次受。为顺不定受耶。答唯顺生法受。非顺现法受等。非顺现法受者。以于余处修此定已生无想天方与果故。非顺后次受者。此定猛利速与果故。非顺不定受者。不可退转故。问此于何处受何异熟果。答于无想天受五蕴异熟果。入灭尽定几根灭。乃至广说。问何故作此论。答为止他宗显己义故。谓譬喻者分别论师执。灭尽定细心不灭。彼说无有有情而无色者。亦无有定而无心者。若定无心命根应断。便名为死非谓在定。为止彼意显灭尽定都无有心。有执。此定虽无有心。但离色染即能现起以界同故。为止彼意显灭尽定要离无所有处染方得现前。非想非非想处心为等无间缘故。由此尊者世友说言。云何灭尽定。谓已离无所有处染。止息想作意为先心心所法灭。是名灭尽定。由此因缘故作斯论。入灭尽定几根灭。答七。谓意舍信等五根。何系心心所灭。答无色界系。此依界类总相而说。然唯非想非非想处系。出灭尽定几根现前。答或七或八。有漏心七。无漏心八。谓若非想非非想处心出者。七根现在前。如前说。若无所有处心出者。八根现在前。谓前七及已知具知根随一。何系心心所现前。答或无色界系。或不系。谓若非想非非想处心出者无色界系。若无所有处心出者不系。由此所说证灭尽定决定无心。以入定时。但说诸根心心所法灭。而不说起。于出定时但说诸根心心所法起而不说灭故

问灭尽定自性云何。答不相应行蕴为性。是彼摄故。界者在无色界。地者在根本非想非非想处地。问何故下地无此定耶。答非田非器乃至广说。又灭尽定灭极细心心所故得。下地不顺极细心心所灭。问何故非想非非想处。顺极细心心所灭。非下地耶。答诸欲入彼定者。先起欲界善心。次入初静虑。次入第二静虑。如是乃至入无所有处。次入非想非非想处。于非想非非想处上中下心。从上入中。从中入下。下品心断。入灭尽定。所说譬喻如前应知。故此唯在非想非非想处。又下诸地皆名有想。行相粗动难可止息。此地名非想非非想。行相微细易可止息故。下地中无灭尽定。有说。二定俱无心故各于一界边立。谓无想定于有色界边立。灭尽定于无色界边立。有说。二定俱无心故各于一地边立。谓无想定依有色地边立。灭尽定依无色地边立。有说。二定俱无心故。各于一聚边立。谓无想定于大种所造色聚边立。灭尽定于心心所法聚边立。有说。一切地皆有二种过。一过贪欲。二过住处。初静虑地过贪欲者。谓自地圣道。过住处者。谓第二静虑。乃至无所有处。过贪欲者。谓自地下地圣道。过住处者。谓非想非非想处。非想非非想处过贪欲者。谓下地圣道。过住处者。谓灭尽等至。若下地有灭尽定者。则下诸地应有三种过。或二种过。非想非非想处。唯有一种过。勿有如斯不平等过故。灭尽定非下地有。有说。此定由二因缘立为解脱。一背舍一切所缘。二边际心断。若下地有灭尽定者。则非背舍一切所缘。于上所缘未弃背故。亦不可说边际心断。中间心断非边际故。有说。此定次第定中为后边故。必从非想非非想处无间而入。由此等缘于下诸地无灭尽定唯有顶有。如世尊说。何等名为灭尽等至。谓超过一切非想非非想处故。想受灭身作证具足住。问灭尽等至即非想非非想处系。何故佛说超过一切非想非非想处耶。答虽即彼系寂静胜故。佛说超彼。譬如村边阿练若处。虽即村界亦以寂静说离于村。又有二种非想非非想处。一有心。二无心。超过一切非想非非想处故者。依有心非想非非想处说想受灭身作证具足住者。依无心非想非非想处说。如有心无心。相应不相应。有所依无所依。有行相无行相。有作意无作意。有所缘无所缘。应知亦尔。又有二种非想非非想处一染污。二不染污。超过一切非想非非想处故者。依染污者说。想受灭身作证具足住者。依不染污者说。如染污不染污。见所断修所断亦尔。又有二种非想非非想处。一曾得二未曾得。超过一切非想非非想处故者。依曾得者说。想受灭身作证具足住者。依未曾得者说。如曾得未曾得。共不共亦尔。又有二种非想非非想处。一离染得。二加行得。超过一切非想非非想处故者。依离染得者说。想受灭身作证具足住者。依加行得者说。又依地次第超过而说超过一切无所有处。入非想非非想处具足住者。依超过下地贪欲说。超过一切非想非非想处故。想受灭身作证具足住者。依超过自地有心住处说。问诸无学者。可言超过一切非想非非想处。彼于有顶具有贪欲及住处二种过故。诸有学者。于彼唯有一种过。如何可言超过一切。答一切有二种。一一切一切。二少分一切。此中学者依少分说故无过。有说。此中但依超过住处而说。谓诸学者。虽于有顶修所断贪欲未能超过一切。而于有顶住处能一切超过。有说。此中依暂时超过说。谓诸学者。暂时超过有心位一切有顶出有心入无心故

问灭尽定中灭一切心心所法。何故但言想受灭。不说心等。答譬喻者说。此定有心唯灭想受。问今不问彼。但问说无心者何故尔耶。答说想受灭显余亦灭。非余相应法离想受起故。有说。此中说最胜者。以诸心品想受最胜。以胜灭故余亦随灭。有说。此中现门现略现趣入故。谓心聚中有是根性有非根性。若说受当知已说是根性者。若说想当知已说非根性者。如根性非根性。有明无明。有现见无现见。应观察不应观察。妙非妙。尊非尊。胜非胜。应知亦尔。有说。想受是诸瑜伽师极所厌患。由受力故令诸有情色界劳弊。由想力故令诸有情无色劳弊。是故世尊说想受灭。有说。想受二界中胜。受于色界中胜。想于无色界中胜。有说。耽乐受故。执倒想故。令诸有情轮回生死。受诸苦恼。有说。想受各别立蕴。及立识住。有说。想受能起爱见二种烦恼。受力故起爱。想力故起见。一切烦恼此二为首。有说。想受是二诤根。由受故耽着诸欲。令在家者起诸斗诤。由想故耽着诸见。令出家者起诸斗诤。如二诤根。二边。二箭。二戏论。二我所。二杂染应知亦尔。有说。行者憎受想故入灭尽定。由如是义故佛唯说灭此二法。如施设论说。云何加行起灭等至。谓初修业者。于一切行不作加行。不欲思惟诸我所有。未生想受当令不生。已生想受当令速灭。若于尔时所有想受未生不生。已生者灭。是名为灭。云何此灭说名等至谓于灭法无障无背自在现见。自身所证故名等至。以是事故世尊说灭唯一刹那。等至相续。问令心平等说名等至。此中无心云何名等至。答等至有二。一令心平等。二令大种平等。无想灭尽定。虽断平等心令不相续。而引平等大种令现在前故名等至

问何故二无心定中。唯灭尽定立为解脱非无想定。胁尊者言。佛于诸法体相作用了达究竟。余不能知。若法有解脱相者。便即立之。无者不立。复次灭尽定唯内法有故立解脱。无想定唯外法有故不立解脱。如内法外法。圣者异生亦尔。复次灭尽定唯背杂染向清净者相续中可得故立解脱。无想定唯背清净向杂染者。相续中可得故不立解脱。如背杂染向杂染。背生死向生死背流转向流转当知亦尔。复次灭尽定唯背我见。向无我见者。相续中可得故立解脱。无想定唯背无我见向我见者。相续中可得故不立解脱。复次灭尽定唯背萨迦耶见向空观者。相续中可得故立解脱。无想定唯背空观。向萨迦耶见者。相续中可得故不立解脱。复次前说灭尽定由二因缘立为解脱。一背一切所缘。二边际心断。无想定二事俱无。是故不立。复次灭尽定。唯障诸界诸趣诸生者。相续中可得故立解脱。无想定。唯不障诸界诸趣诸生者。相续中可得故不立解脱。复次弃背诸有名为解脱。灭尽定。弃背诸界诸趣诸生。生死转流觉。无想定不尔。由此等缘二无心定中。唯灭尽定立为解脱。非无想定

问无想定灭尽定有何差别答名即差别。名无想定。名灭尽定。复次界亦差别。无想定色界系灭尽定无色界系。复次地亦差别。无想定在第四静虑灭尽定在非想非非想处。复次相续亦有差别。无想定在异生相续灭尽定在圣者相续。复次入无想定时作出离想入灭尽定时作止息想。复次入无想定时唯厌于想。入灭尽定时通厌想受。复次入无想定时唯欲灭想。入灭尽定欲灭受想。复次入无想定时灭色界系心心所法。入灭尽定时灭无色界系心心所法。复次入无想定时。灭第四静虑心心所法。入灭尽定时。灭非想非非想处心心所法。复次无想定招色界异熟。灭尽定招无色界异熟。复次无想定招第四静虑异熟。灭尽定招非想非非想处异熟。复次无想定唯顺生受异熟。灭尽定顺生后不定受异熟。故有差别。尊者世友作是问言。无想定灭尽定何差别。答一名无想定。一名灭尽定。故有差别。又界地相续想厌欲乐。所灭异熟皆有差别。广说如上。又异生入无想定感无想处果。圣者入灭尽定感有顶处果。又无想定令诸异生受色界异熟果。灭尽定令诸学者受无色界异熟果。令无学者受无色界等流果。是谓无想定灭尽定差别

问八解脱中世尊何故唯说第三第八解脱。名身作证非余耶。如契经言。净解脱身作证。想受灭解脱身作证。答有余契经于八解脱。世尊皆说名身作证。如大因缘经中。佛于八解脱一一皆说身作证具足住故。问虽少经中于八解脱说身作证。于多经中唯说二种名身作证。何故尔耶。答此二解脱八解脱中。名义最胜。是故偏说。有说。此二解脱俱用加行功力所证故。有说。此二各居一界边谓净解脱居色界边。想受灭解脱居无色界边。有说。此二解脱各居一地边。谓净解脱在第四静虑边。想受灭解脱在非想非非想处边。有说。净解脱于大种所造色聚边际而立。想受灭解脱于心心所法聚边际而立。有说净解脱虽取色净相。而不起烦恼。以殊胜故。世尊安立身作证名想受灭解脱。以无心故。在身非心身力所起非心力起。是故世尊说为身证。有说。于契经中说八解脱身作证者。皆以此二解脱故得名身证。由此等义故。唯二种说身作证具足住者。有多处说具足住声。谓或有处于色蕴少分说具足住。或有于善五蕴说具足住。或有于善四蕴说具足住。或有于不相应行蕴一分说具足住。或有于寂灭涅槃说具足住于色蕴一分说具足住者。如伽他说

  于妙慧圣教　　具足住尸罗
  一切皆贤善　　多功德宝藏

于善五蕴。说具足住者。如说。初静虑乃至第四静虑具足住。于善四蕴说具足住者。如说。空无边处。乃至非想非非想处具足住。于不相应行蕴一分说具足住者。如此八解脱中。说想受灭解脱身作证具足住。于寂灭涅槃说具足住者如说。于涅槃身作证具足住

问灭尽定有几种类。有说。有四。谓具缚者所起。离上三品者所起。离中三品者所起。离下三品者所起。种类各别故。复有说四。谓离六七八九品染者所起。各以为一彼说具缚者。乃至离五品染者。皆未能起此定故。有说。此定有九种。谓离上上品者所起。乃至离下下品者所起。唯具缚者不能起故。有说。此定有十种。谓具缚者所起。乃至离下下品者所起。问若具缚者能起此定。诸异生类何不能起。答缚有二种。一见所断二修所断。于有顶中若缺见所断缚具修所断缚者能起此定。具二缚者则不能起。如是说者。此灭尽定有十一种谓具缚者所起。离上上品者所起。乃至离下下品者所起。时解脱阿罗汉练根得不动者所起。问此十一种体有异耶。有说。不异。问若尔何故说十一。答由位别故非体有异。有说。此十一种其体各异。随位所起种类别故。问若尔具缚者所起。乃至时解脱阿罗汉练根得不动者。所起差别云何。答有具缚时起灭尽定。即彼进断一品染时。复起灭尽定。彼于尔时先所起者得而不在身。成就不现前。今所起者得亦在身。成就亦现前。即彼乃至从时解脱练根得不动。彼于尔时前诸位中所起灭定得而不在身。成就不现前。今不动位所起灭定得亦在身。成就亦现前。由此应知体类各别

问此定有上中下品类别不。若有者。施设论说云何通。如彼说。灭无差别。若无者佛独觉声闻所起无胜劣耶。有说。此定无上中下。问施设论说灭无差别。虽已善通而佛独觉声闻所起无胜劣耶。答体无胜劣。皆以心心所灭为其性故。但由加行说有差别。谓佛起此定不由加行。独觉下加行。声闻或中或上。如是说者。此灭尽定有上中下品类差别。问三乘所起有胜有劣。虽已善通。施设论说灭无差别当云何通。答依能断灭心心所法无差别义说无差别。而灭尽定是有为故。如余有为有上中下。由随根性阶分异故。谓佛所得是上。独觉所得是中。声闻所得是下。声闻乘中有多差别。且有学位具缚所起为下下。乃至断八品所起为上上。无学位中退法种性所起为下下。乃至学得不动种性所起为上下。余本得不动种性所起为上中。波罗蜜多声闻所起为上上。一一种性中根品差别所起。各有上中下品类差别。是故灭定有多品类。问此灭尽定几物为体。有说。此定一物为体。若灭现前即名无心故。问云何一灭刹那现前即名无心。答如一受刹那现前即名有受。一想刹那现前即名有想。一识刹那现前即名有识。如是一灭刹那现前即名无心。斯有何过。有说。此定十一物为体。以十大地法及心灭故。有说。此定二十一物为体。以十大地法十大善地法及心灭故。如是说者。随灭尔所心心所法。即有尔所物现前为此定体。问此灭尽定自体既尔。其相云何。答自体即相。相即自体。以一切法不可离体别说其相。故尊者世友作如是言。此灭尽定解脱为相。故作是说。住此定者心心所法解脱。胜解脱。极胜解脱。离系。胜离系。极胜离系。问此定不能断诸烦恼。如何可说住此定者心心所法解脱等言。答住此定者心心所法暂时解脱。乃至暂时极胜离系。故说此言。非谓此能断诸烦恼

有如是说。若法想微细为因。微微为等无间。不与彼俱。非不成就。是谓解脱问此说何法。有说。此说灭尽定若作是说。此说灭定者。彼说此定想微细为其因。谓一因即同类因。微微亦与作因。谓一因即同类因。亦与作等无间缘。若作是说。此说灭尽定者。彼应说。若法想微细为因。微微为等无间。不应说。不与彼俱。以彼灭定正现前故。应说。非不成就。以住定时彼成就定故。有说此说出定心。若作是说。此说出定心者。彼说此出定心想微细为其因。谓一因即同类因。微微亦与作因。谓一因即同类因。亦与作等无间缘。若作是说。此说出定心者。彼应说。若法想微细为因。微微为等无间。应说。不与彼俱。以住定时彼出定心不现前故。应说。非不成就以住定时彼成就出定心故。由此证知。彼先得出定心。有说。此说入定心。若作是说。此说入定心者。彼说。此入定心想为其因。谓一因即同类因。微细亦与作因。谓一因即同类因。亦与作等无间缘。若作是说。此说入定心者。彼应说。若法想为其因。微细为等无间。应说。不与彼俱。以住定时彼入定心不现前故。应说非不成就以住定时彼成就入定心故

说一切有部发智大毗婆沙论卷第一百五十二阿毗达磨大毗婆沙论卷第一百五十三

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    根蕴第六中等心纳息第四之三

问此中何者是想。何者是微细。何者是微微。有说。空无边处识无边处是想。无所有处是微细。非想非非想处是微微。有说。空无边处识无边处无所有处是想。非想非非想处是微细。若心心所法为等无间缘。入灭尽定是微微。有说。非想非非想处亦是想。亦是微细。亦是微微。所以者何。非想非非想处。有上中下。上者是想。中者是微细。下者是微微。问若俱一地有何差别。有说名则差别。谓此名为想。此名微细。此名微微。有说。品亦差别。谓上者名想。中者是微细。下者是微微。有说。想微细现在前时能修未来圣道。微微现在前时不修。有说。想微细现在前时四念住随一现在修。未来四。微微现在前时。法念住现在修。未来三。除身念住。有说。想微细有曾得。有未曾得。微微唯未曾得

问此中因论生论何故入灭定心。通曾得未曾得。出灭定心唯曾得耶。答入定心多加行用功力。极作意起故。通曾得未曾得。出定心与上相违故唯曾得。有说。入定心能策励增益发起于定故。通曾得未曾得。出定心与此相违故唯曾得。有说。入定心唯有漏故。通曾得未曾得。出定心通有漏无漏故唯曾得。问此中因论生论何故入定心唯有漏。出定心通有漏无漏。答入定心随顺心断故唯有漏。由此心不坚不强。无势力久住。不令余心无间而起。如朽败种故于心断极为随顺。出定心与此相违。故通有漏无漏。有说。入定心以定为寂静非无漏道。以有为寂静故唯有漏。有说。以此定是次第定。从非想非非想地心无间而起。圣道极至无所有处故。入定心唯是有漏

问入灭定心为何所缘。出灭定心为何所缘。答入定心缘定。出心亦尔。问若入定心缘定。出心亦尔者云何不入时则出。出时则入耶。答入定时期心欲入。出定时期心欲出。由期心故无有错乱。又入定心缘未来定。出定心缘过去定。由所缘故亦无错乱。问若入定心缘未来定者。为缘几许未来定耶。有说。但缘初刹那定。有说。通缘应相续起者。评曰应说此入定心。缘未来定。而不可说缘何刹那。不缘何刹那。以未来定有多刹那未有先后。杂乱住故。问若出定心缘过去定。为缘几许过去定耶。答有说。但缘最后刹那定。有说。通缘曾相续起者评曰。应说此出定心缘过去定。而不可说缘何刹那。不缘何刹那。以过去定有多刹那相杂住故

问入灭尽定时。灭何等心心所法。为过去为未来。为现在。若过去者过去已灭。复何所灭。若未来者未来未至。云何可灭。若现在者现在不住。复云何灭。设非定力亦自灭故。答应作是说。灭于未来。问未来未至云何可灭。答住现在世。遮于未来心心所法。令不相续故说为灭。如断城路闭门。竖幢不令人入出。说名除寇。此亦如是。有说。通灭未来现在。问现必不住。复云何灭。设非定力亦自灭故。答先现在世心心所法。令有缘法续起而灭。今现在世心心所法。不令有缘法续起而灭。此由谁力。所谓定灭。问出灭定时。何等心心所法现在前耶。有作是说。先所遮止住未来世心心所法。今现在前。有余师说。余未来世心心所法今现在前。先所遮止住不生法不可复起。评曰。应说起未来世心心所法。而不可说起何等。不起何等。以未来世有多刹那。未有先后杂乱住故。问灭尽定有得过去修未来耶。有说。此定无得过去及修未来。如天眼耳。若作是说。无得过去修未来者。彼说定初刹那唯成就现在定。余刹那成就过去现在。出此定已唯成就过去。有说。此定有得过去及修未来。如他心智宿住智等。若作是说。有得过去未来修者。彼说定初刹那成就未来现在定。余刹那成就三世。出此定已成就过去未来。如是说者。应如初说。若谓此定有得过去修未来者。退此定已后还起时。应说还得先所得者。而实此定退复起时。名得未曾得定。如不犯重而还家者。后更出家名得未曾得戒。彼亦如是。问此灭定何处起。答在欲色界非无色界。若初起唯欲界。若此起已于此定退命终生色界中。由串习力复能现起。余者不能。云何知然。如契经说。尊者舍利子告苾刍众言。若苾刍戒定慧具足者。能数数入出灭受想定。彼于现法及将死时。若不能辨如来圣旨。命终超段食天处。生在意成身天中。于彼复能数数入出灭想受定。斯有是处应如实知。时具寿邬陀夷。在彼会坐。语尊者舍利子言。彼苾刍生意成身天。能数入出灭想受定无有是处第二第三亦如是说。问何故具寿邬陀夷再三违逆尊者舍利子。答彼之所疑非无处所。彼作是念。得此定者必已离无所有处染。命终应生非想非非想处。于彼必无起此定理。又彼不了舍利子意。是故现前再三违逆。问舍利子有何意趣。彼具寿云何不了。答舍利子说生色界者。邬陀夷说生无色界者。舍利子说退者。邬陀夷说不退者。由此不了故三违之。问尊者何故不开悟彼。而致重违逆耶。答尊者念言。谁能开悟如是愚执自是者耶。有说。尊者念欲开悟。由再三违逆故彼意便止。如箭喻经说。有众多增上慢苾刍。于佛前各自赞美。我生已尽。乃至广说。佛时欲为说断慢法。由诸苾刍自赞不止故彼心便息。世尊具足普缘大悲。尚于慢人说法心息。何况尊者舍利子耶。有说。尊者作如是念。此所论事必闻于佛。佛当以此呵邬陀夷及阿难陀。当使此诫经历千载。令无智者不敢违于智人所说。尊者复念。如是苾刍于大众中再三违我竟。无同梵行者随喜我之所说。今应诣佛决判此事。念已则时往至佛所。顶礼双足退坐一面。告苾刍众若苾刍戒定慧具。乃至广说。时邬陀夷亦在彼会。复作如上违逆之言。尊者尔时作如是念。彼故于大师所违反我说。又无同梵行苾刍称赞于我。我于今者唯应默然。时舍利子便默然住。尔时佛告邬陀夷曰。汝以何等为意成身天。岂不欲说非想非非想处耶。彼答如是。世尊告曰。汝是愚人盲无慧眼。云何与上座苾刍论甚深阿毗达磨。佛于尔时现前呵责邬陀夷已。复责具寿阿难陀言。汝见愚人触恼上座。何缘舍置曾不呵止。世尊尔时呵责是已。便入静室宴寂而住。问邬陀夷有过故。世尊呵之。彼阿难陀何过被责。答邬陀夷是阿难陀共住第子。故佛责以不善教诲。复次邬陀夷是阿难陀摄徒众者。故佛诃其不如法告示。复次尊者阿难陀是佛摄徒众者。故佛责曰。汝何不知如法说者。非法说者。复次诸对法者所说甚深。非多人所知。唯除佛及舍利子。阿难亦以多闻力知故。佛责曰。汝知此义何不称赞上座所说以摄受法朋耶。由此等缘故佛呵责。以是义故知灭尽定欲界初起。退生色界复能现前。余不能起

问何故生色界中。能初起静虑无色而非灭定耶。答静虑由三缘故初起。一由因力。二由业力。三由法尔力。由因力者。谓于余生曾近起灭此静虑故。由业力者。谓彼地顺决定受业。已造作增长将与果故。由法尔力者。谓世界坏时下地有情必生上故。无色由二缘故初起。一由因力。二由业力。由因力者。谓余生中曾近起灭此无色故。由业力者。谓彼地顺决定受业。已造作增长将与果故。不由法尔力。第四静虑以上无世界坏故。灭尽定由一缘故初起。谓由说力唯欲界中有佛说故。能起现前不由因力。以余生中未曾起灭此灭定故。不由业力以此定非业性故。不由法尔力。以无色中无世界坏故。问何故生欲色界能起灭定。非无色界耶。答命根依二法转。一色。二心。此定无心断心起故。生欲色界起此定时。心虽断而命根依色转。生无色界色虽断而命根依心转。若生彼起此定者色心俱无。命根无依故应断。是应名死。非谓入定。是故生彼界不起。问退此定已命终生下三无色不。有说。不生。所以者何。退此定已容生二处。一能起此定处。二受此定异熟处。色界虽非受此定异熟处。而是能起此定处。非想非非想处虽非能起此定处。而是受此定异熟处下三无色二事俱无故。退此定无容生彼。有说。亦生。然生彼者不名身证及俱解脱。若作是说则为善通毗木差罗所说。如说。身证于净四无色定。或成就一。或成就四。云何一。谓生非想非非想处。云何四。谓生欲色界。如身证俱解脱亦尔。下三无色。必不成就灭尽定故不得二名。评曰。应知此中初说为善

问住灭尽定得经几时。答欲界有情诸根大种由段食住。若久在定则在定时身虽无损后出定时身便散坏。故住此定但应少时。极久不得过七昼夜。段食尽故。云何知然。曾闻于一僧伽蓝中。有一苾刍得灭尽定。食时将至。着衣持钵诣食堂中。是日打揵稚少晚。彼苾刍以精勤故。便作是念。我何为空过。此时不修于善遂不观后际。则立誓愿入于灭定。乃至打揵稚当出时。彼僧伽蓝有难事起。诸苾刍等散往他处。经于三月难事方解。苾刍还集僧伽蓝中。才打揵稚。彼苾刍从定而出则便命终。复有一苾刍得灭尽定。而常乞食。于日初分着衣持钵方欲诣村。遇天大雨恐坏衣色少时停住。则作是念。我何为空过。此时不修于善遂不观后际。则立誓愿入于灭定。乃至雨止当出。有说。尔时雨经半月。有说。一月其雨方止。彼从定出则便命终。由此故知生于欲界。若久在定则在定时身虽无损后出定时身便散坏。故住此定但应少时极久不得过七昼夜。色界有情诸根大种不由段食之所任持故。住此定或经半劫。或经一劫或复过此。问若有苾刍不立誓愿入灭尽定。云何当出。答法尔应出。如有心定。又彼苾刍或欲饮食。或欲便利。以彼在定虽不为损出则致患故。由此因必应出定。问异生能入灭尽定不。尊者世友说。不能入。契经说。为圣者定故。若异生能入者亦应名异生定有说。异生必欣上地离下地染。如尺蠖虫。非想非非想处无上地可欣故。诸异生不能离彼染。若不离彼见所断染。必无有能入灭尽定。故诸异生不能入此定。有说。异生如如入定则如是如是身心安息。由安息故加行慢缓。是以不能入灭尽定。大德说曰。异生不能入灭尽定。以诸异生如如入定则如是如是我见坚牢。怖边际灭起深坑想。是故不能入灭尽定

问菩萨为入灭尽定不。尊者世友说不能入。契经说。为圣者定故。若菩萨能入者亦应名异生定。有说。菩萨必欣上地离下地染。如尺蠖虫。广说如前。有说。菩萨能入此定。以诸菩萨求一切智。于一切处皆悉寻求。若当不能入此定者何名寻求一切处耶。大德说曰。菩萨不能入灭尽定以诸菩萨虽伏我见不怖边际灭。不起深坑想。而欲广修般罗若故。于灭尽定心不乐入。勿令般若有断有碍故。虽有能而不现入。此说菩萨未入圣位

问已知菩萨前众同分中未曾起灭定。后众同分中为先起灭定。后证无上正等菩提为先证无上正等菩提。后起灭定。若先起灭定者。云何名为不起意乐。云何非起不同分心。云何名三十四心刹那得一切智。若先证无上正等菩提者。云何菩萨名满学者。云何得尽智时名善办所作。云何尽智起已名俱解脱。答外国诸师作如是说一切菩萨先起灭尽定。后证无上正等菩提。问云何名为不起意乐。答彼说一切菩萨先离无所有处染。起如是决定意乐。我当不起于座依第四静虑入正性离生。得不还果起灭尽定。证于无上正等菩提。如所思惟后皆证得。由此故说不起意乐。问云何非起不同分心。答彼说谁言菩萨不起不同分心。然菩萨有不同分心。设有此言亦不违理。不违所立本意乐故。问云何说三十四心刹那得一切智。答彼说此依无漏心说。不论入出灭尽定心。迦湿弥罗国毗婆沙师说。一切菩萨先证无上正等菩提后起灭尽定。问云何菩萨名满学者。答此依根满果满而说。不说定满。斯有何过。问云何得尽智时名善办所作。答解脱障。有说。以下无智为体。有说。于定不自在为体。有说。诸定不得为体。若说以下无智为体者。世尊得尽智时已断一切无智。已生彼对治智由此故名解脱障断。若说于定不自在为体者。彼说世尊得尽智时于一切静虑解脱等持等至。若入若出皆得自在。由此故名解脱障断。若说诸定不得为体者。彼说世尊得尽智时。已得一切静虑解脱等持等至。由此故名解脱障断。是故得说善办所作。问云何尽智起已名俱解脱。答已得彼定入出心故名俱解脱非得定体则由此理名离染得。后时不由加行起故。是以菩萨三十四心刹那证得无上正等菩提。云何名为三十四心刹那。谓菩萨先离无所有处染。后依第四静虑。入正性离生。于见道中有十五心刹那。道类智时为第十六则此名断有顶加行。离非想非非想处染。复有九无间道九解脱道。是名三十四心刹那。菩萨依此证无上觉

如契经说。毗舍佉邬波索迦。诣达磨阵那苾刍尼所。问言。圣者诸苾刍等。念何当言入灭尽定。苾刍尼告毗舍佉言。诸苾刍等入灭定时。终不念言我今入灭定或复当入。然由先时调练心故。心转微细随顺趣入。问将欲入灭定时。先敷绳床次洗足已结跏趺坐端身系念。后便入定。于此中间岂不作念我今入灭定或复当入。答远加行中虽有此念。而从欲界善心无间入初静虑。乃至渐次入灭尽定。于此邻近加行位中。必不念言我今入灭定或复当入复问。圣者诸苾刍等。念何当言出灭尽定。苾刍尼告毗舍佉言。诸苾刍等出灭定时。终不念言我今出灭定或复当出。然彼身命六处为缘。及本要期出灭尽定。或由饥渴便利所恼。在定虽不为损出则作患故。彼法尔出于灭定。又问。圣者诸苾刍等入灭定时。先灭何法。身行耶。语行耶。意行耶。苾刍尼言。诸苾刍等入灭定时。先灭语行。次身行。后意行。问入灭定时灭意行可尔。身语行云何。谓从初静虑入第二静虑时语行已灭。从第三静虑入第四静虑时身行已灭。如何方说入灭定时灭身语行。答入灭定时有远有近。远灭身语行。近灭意行。又从入初静虑。乃至入非想非非想处。皆名入灭定时。为入灭定起。此诸地现在前故。是故无过。复问圣者诸苾刍等出灭定时。先起何法。身行耶。语行耶。意行耶。苾刍尼言。诸苾刍等出灭定时。先起意行。次身行。后语行。问出灭定时起意行可尔。身语行云何。谓从第四静虑入第三静虑时身行方起。从第二静虑入初静虑时语行方起。如何可说出灭定时起身语行。答出灭定时有近有远。近起意行。远起身语行。又从灭定起。乃至入初静虑。皆名出灭定时。复问。圣者诸苾刍等出灭定时。其心何所随顺。何所转近。何所垂入。苾刍尼言。诸苾刍等出灭定时。其心随顺离。转近离。垂入离。问此中说何法名离。有说。灭定名离。若作是说灭定名离者。彼说若世俗心出则二缘故。其心随顺离。转近离。垂入离。谓意乐故及所缘故。若无漏心出。苦集智相应者。则一缘故其心随顺离。转近离。垂入离。谓所缘故。非意乐故。若灭道智相应者。则其心非意乐故。非所缘故。随顺离。转近离。垂入离。有说。涅槃名离。若作是说涅槃名离者。彼说若世俗心出则其心非意乐故。非所缘故。随顺离。转近离。垂入离。若无漏心出苦集。道智相应者则一缘故其心随顺离。转近离。垂入离。谓意乐故。非所缘故。若灭智相应者则二缘故。其心随顺离。转近离垂入离。谓意乐故。及所缘故。有说。灭定涅槃名离。若作是说灭定涅槃名离者。彼说若世俗心出及无漏心出。苦集灭智相应者。总而言之则二缘故。其心随顺离。转近离。垂入离。谓意乐故及所缘故。若道智相应者则一缘故。其心随顺离。转近离。垂入离。谓意乐故非所缘故

又问。圣者诸苾刍等出灭定时。为触几触。苾刍尼告毗舍佉言。触三种触。一不动触。二无所有触。三无相触。问如是三触有何差别。尊者世友作如是说。空无边处识无边处。是不动触。无所有处。是无所有触。非想非非想处。是无相触。有说。空是不动触。无愿是无所有触。无相是无相触。有说。无漏无所有处。缘涅槃者具名三触。谓无漏故名不动触。无所有处摄故名无所有触。缘涅槃故名无相触。大德说曰。诸苾刍等出灭定时。若起非想非非想处心不起余。不同分心当言触无相触。若起无所有处不同分心。当言触无所有触。若起识无边处不同分心。当言触不动触。由此理趣余五有想定应知亦尔。谓空无边处及四静虑。由此次第入灭定不。则由此出由此次第出灭定不。则由此入。如由此次第而睡不。则由此觉。由此次第而觉不。则由此睡彼亦如是

如说。由得依住此灭定故不受当来生老死苦。不起彼集。问灭定不能断诸烦恼。云何得有如是说耶。答应观此中所说意趣。谓诸有学出灭定已作是思惟。此灭定中心心所法。暂灭暂息须臾不行。尚有如是寂静微妙。何况涅槃。有为诸行永灭永息究竟不行。由此为先断余烦恼。灭相续蕴入无余依涅槃界。若诸无学出灭定已作是思惟。广说乃至由此为先灭相续蕴入无余依涅槃界依此密意故作是说。非谓灭定能断烦恼

施设论说。有作愿入灭定。不作愿出。有作愿出灭定。不作愿入。有作愿入灭定亦作愿出。有不作愿入灭定不作愿出。此中作愿入灭定不作愿出者。谓如有一作是愿言。我当入灭定。不作是愿。我当出灭定。四有想定随一现前。彼入灭定从灭定出。四有想定随一现前。作愿出灭定。不作愿入者。谓如有一不作愿言。我当入灭定。而作是愿。我当出灭定。四有想定随一现前。彼入灭定从灭定出。四有想定随一现前。作愿入灭定。亦作愿出者。谓如有一作是愿言。我当入灭定。亦作是愿。我当出灭定。四有想定随一现前。彼入灭定从灭定出。四有想定随一现前。不作愿入灭定。不作愿出者。谓如有一不作愿言。我当入灭定。亦不作愿我当出灭定。四有想定随一现前彼入灭定从灭定出。四有想定随一现前。问作愿入出及唯作愿入者是事可尔。以入定者必当出故。不作愿入出。及唯作愿出者。云何可尔。非不欲入而入定故。答此中一切皆欲入定。皆欲出定。然依入出定心有自在不自在故作是说。谓有于入定心得自在非出定心。彼作愿出定不作愿入。有于出定心得自在非入定心。彼作愿入定不作愿出。有于入出定心俱得自在。彼不作愿入定亦不作愿出。有于入出定心俱不自在。彼作愿入定亦作愿出。问四有想定何者是耶。答四无色定。问何故出灭定时但说起四无色定。答以四无色定于出灭定时。可作逆次出逆超出故。谓若以非想非非想处心出灭定者。彼若则起无所有处心是逆次出。若则起识无边处心是逆超出。若以无所有处心出灭定者彼若则起识无边处心是逆次出。若则起空无边处心是逆超出。是故但说四无色定

说一切有部发智大毗婆沙论卷第一百五十三阿毗达磨大毗婆沙论卷第一百五十四

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    根蕴第六中等心纳息第四之四

契经中说住灭定者。不为火所烧。水所漂。毒所中。刃所害。他所杀。问何故住灭定者有如是胜利。尊者世友作如是说。由此灭定是不害法故。住此者非害所害。有说。此定有大威德。为诸威德天神护之故不可害。有说。得静虑者静虑境界。具神通者神通境界。俱不思议故不可害。有说。此定无心非无心者有生有死故不可害等活契经是此论缘起者。有佛名羯洛俱村驮。有第一双弟子。一名极远。二名等活。尊者等活曾于一城中作多教化众所知识。后于城边多人行处。入灭尽定。时有放牧采樵行人见已咸言。今此尊者端坐灭度诚为异哉。我等宜应焚烧供养。便取种种牛粪干薪。埋积其身焚之舍去。尊者明旦从定而起。振迅衣服。于日初分。持钵入城徐行乞食。时焚烧者见已惊言。我等昨烧其尸。而今复来乞食。城中人众等皆唱言。今此沙门死而还活。由斯故名等活尊者。应知身不烧者由灭定力故。衣不烧者由神通力故。有说。身及衣俱不烧者。皆由灭定力故。是故彼经是此论缘起

传喻中说。若有施从灭定起者。彼必成顺现法受业。问何故施从灭定起者。必成顺现法受业耶。答此不必须通。所以者何。此非素怛缆毗奈耶。阿毗达磨教但是传喻所说。诸传喻说或然不然若必欲通者。应知此施或得现果。或得大果。彼顺世间意所乐故。但说现果。问何故施从灭定起者。或得现果或得大果。答若有施从此定起者。则为施从一切静虑解脱等持等至起者。所以者何。诸欲入出灭尽等至。必先起欲界善心。次入初静虑。如是乃至入非想非非想处。从此无间入灭尽定。从此定出或起非想非非想处。或起无所有处。如是乃至还起初静虑。复入欲界善心。彼由如是功德熏相续故。能令施者或得现果或得大果。有说。从灭定起者。威仪寂静来往语言。衣着饮食皆悉详审。诸清信长者婆罗门等。见已咸生希有之想。以殷净心施诸资具故。得现果或得大果。有说。得此定者名称普闻过于余定。诸清信长者婆罗门等。闻已皆生奇特之想。以殷净心施诸资具故。得现果或得大果。有说。住灭定者诸食皆断。若施从此起者。则为施无食者。食谓住有漏有心定者。虽断段食而食有漏触思识食。住无漏定者虽断真实四食。而有相似触思识食。住灭定者一切皆无。是故施从此起者。则为施于无食者食。由此因缘。或得现果。或得大果。有说。若有施从此定起者。则为施到涅槃还来者食。以此定似涅槃故。谓如入无余依涅槃界者。灭一切有所缘法心心所法。不起不灭。住灭定者。亦灭一切有所缘法。心心所法不起不灭故似涅槃。是故施从此定起者。则为施到涅槃还来者食。由此因缘或得现果。或得大果。复次非但施从灭定起者。能得现果。若施五种补特伽罗。皆得现果。一从灭定起。二从慈定起。三从无诤定起。四从见道起。五从初得尽智起复次若施五种补特伽罗。能得大果。一父。二母。三病者。四说法师。五近佛地菩萨

问灭尽定于众同分为亦能引。为但满耶。答此但能满而不能引所以者何。唯业能引众同分。此非业故。问此定为顺现法受。为顺次生受。为顺后次受。为顺不定受耶。答此定或顺次生受。或顺后次受。或顺不定受。非顺现法受。已生有顶不起此定故。问此于何处受何异熟。答此于非想非非想处受四蕴异熟。问诸成就灭定。亦成就彼异熟耶。答应作四句。有成就灭定非彼异熟。谓生欲色界已得灭定。及得已不退。命终生非想非非想处。灭定异熟不现在前。有成就彼异熟。非灭定。谓得灭定已而退。命终生非想非非想处。灭定异熟现在前。有成就灭定。亦彼异熟。谓得灭定已不退。命终生非想非非想处。灭定异熟现在前。有非成就灭定。亦非彼异熟。谓生欲色界不得灭定。设得已退。若生空处识处无所有处。若不得灭定。生非想非非想处。及得已而退。命终生非想非非想处。灭定异熟不现在前。问诸退灭定。亦退阿罗汉果耶。答应作四句。有退灭定。非阿罗汉果。谓学者退灭定。及无学者退灭定。而不起结。有退阿罗汉果。非灭定。谓慧解脱阿罗汉退。及先学位起灭定已。得阿罗汉果。起上位结退。有退灭定亦阿罗汉果。谓先学位起灭定已。得阿罗汉果。起下位结退。及无学位起灭定已。起三界结随一而退。有非退灭定。亦非阿罗汉果。谓除前相。阿罗汉有六种。谓退法。思法。护法。安住法。堪达法。不动法。问诸退法彼一切俱解脱耶。答应作四句。有退法非俱解脱。谓退法不得灭定。有俱解脱非退法谓思法乃至不动法。已得灭定。有退法亦俱解脱。谓退法已得灭定。有非退法非俱解脱。谓思法乃至不动法不得灭定。如退法阿罗汉对俱解脱作四句。余五阿罗汉对俱解脱亦尔。如是成六四句。如无学道有六种阿罗汉。学道亦有六种种性。谓退法种性。乃至不动法种性。问诸退法学彼一切身证耶。答应作四句有退法学非身证。谓退法学不得灭定。有身证非退法学。谓思法学。乃至不动法学。已得灭定有退法学亦身证。谓退法学已得灭定。有非退法学亦非身证。谓思法学乃至不动法学不得灭定。如退法学对身证作四句。余五种性对身证亦尔。如是亦成六四句

问若法是心等无间。彼法是心无间耶。答应作四句。有法是心等无间。非心无间谓除灭定初刹那。及余有心位诸余灭定刹那。及出灭定心心所法。有法是心无间。非心等无间。谓灭定初刹那。及余有心位。彼生老住无常。有法是心等无间。亦心无间。谓灭定初刹那。及余有心位心心所法。有法非心等无间。亦非心无间。谓除灭定初刹那。及余有心位。彼生老住无常。诸余灭定刹那。及出灭定心位。彼生老住无常。问若法是心等无间。彼法是灭定无间耶。答应作四句。有法是心等无间。非灭定无间。谓灭定初刹那。及余有心位心心所法。有法是灭定无间。非心等无间。谓除灭定初刹那及余有心位。彼生老住无常。诸余灭定刹那。及出灭定心位。彼生老住无常。有法是心等无间。亦灭定无间。谓除灭定初刹那及余有心位。诸余灭定刹那。及出灭定心心所法。有法非心等无间。亦非灭定无间。谓灭定初刹那。及余有心位。彼生老住无常。生无想天几根灭。答八。谓眼耳鼻舌身命意舍根。问此说从何处生无想天耶。答此说从无想中有生无想生有问尔时亦有信等五根现在前灭。何故不说。答此文应作是说。或八或十三。中有最后心无记者八。善者十三。而不作是说者。应知此义有余。有作是说。此中但依灭位。生位皆有者说信等五根。唯灭位有。非生位有。是故不说。何系心心所灭。答色界系。几根现前。答八如前说。何系心心所现前。答色界系。死生必起自地心故。无想天殁几根灭。答八如前说。何系心心所灭。答色界系。几根现前。答或八或九或十。无形八。谓眼耳鼻舌身命意舍根。一形九加男女根随一。二形十加男女根。何系心心所现前。答欲界系。由此证知从无想天殁定生欲界。问定生何处。有说。生地狱。有说。生恶趣。如是说者定生欲界处所不定。或生恶趣。或天或人。问何故从无想天殁定生欲界。答由异熟因势力尔故。随异熟因所有势力。唯令如是异熟起故。有余师说。无想寿尽余处寿业不增长故。谓先增长无想寿业今已受尽。余处寿业先不增长故。从彼殁定生欲界。问彼亦曾起下三静虑。何故不引彼地寿果。答彼虽曾起下三静虑。非坚执故不引彼寿。唯坚执着第四静虑故引彼寿。有说。彼虽曾起下三静虑。而非所求。彼唯求于第四静虑。有说。彼虽曾起下三静虑。但如所涉路而非所趣。第四静虑是正所趣。非如所涉路故引彼寿。有说。若造无想天顺次生受业者。法尔亦造欲界顺后次受业。如造北俱卢洲顺次生业者。法尔亦造欲界天顺后次受业。有说。欲界是一切有情退所归处。谓诸有情由业力修力。往色无色界。彼业若尽还堕欲界。譬如大地是诸飞鸟退所归处。谓诸飞鸟由翅翮力飞腾虚空。翮力尽时还堕于地。有说。无想有情经五百劫住于无想。如熟睡眠。觉已不能取余异熟。便堕欲界。如人在树端倚枝而眠。多时欻觉手忘攀揽即便堕地。彼亦如是。有说。求无想者执无想定为真道。彼异熟为涅槃。乃至生彼天中。此执随逐彼后从无想出将命终时。见当生相便作是念。定无涅槃。若实有者。我已证得。于今何故生相现前。由谤涅槃及圣道故。从彼处殁生恶趣中。尊者妙音亦作是说。彼谤涅槃及圣者故。从彼命终定生恶趣

问无想定无想事何差别。答名则差别。此名无想定。此名无想事。复次因是无想定。果是无想事。复次异熟法是无想定。异熟是无想事。复次无想定是善。无想事是无记。复次无想定是定。无想事是生。复次无想定加行功用作意所起。无想事非加行功用作意所起。复次无想定通在此彼。得此彼现在前。无想事唯在彼得彼现在前。复次无想定是加行得。无想事是生得。是谓无想定无想事差别。问无想天在何处摄。外国师说。第四静虑处别有九此是一处。迦湿弥罗国诸论师言。即广果天摄。然以高胜寂静故别立名。犹如村边阿练若处。问彼天身量云何。答五百踰缮那。问彼寿量云何。答五百劫。问作何等威仪住。有说。结加趺坐如沙门释子。有说。却踞而坐如婆罗门。如是说者。如先入此定所住威仪。则以此威仪于彼五百劫住

无想有情生时。当言有想耶。无想耶。乃至广说。问何故作此论。答欲止他宗显己义故。谓或有说。无想有情生时死时俱无心想。为遮彼意显彼有情生时死时俱有心想非无心想有死生故。或复有说。无想有情生时有心死时无心。为遮彼意显彼死时亦有心想非无心想有命终故。或复有说。无想有情生时死时虽俱有心。然唯一念非久相续为遮彼意显彼生时生已经久心犹相续后方无想从无想出有心多时后方舍命。是故如是说。颇有处唯二刹那有心。谓结生及命终时耶。答应说无。尊者妙音说有。谓即无想天。颇有处结生心为等无间缘命终心起耶。答应说无。尊者妙音说有。谓即无想天。颇有处结生心为四缘。命终心起耶。答应说无。尊者妙音说有。谓即无想天。为遮此等故作斯论。无想有情生时当言有想耶。无想耶。答当言有想。此则遮止执无想天生时无心者意。如世尊说。彼诸有情由想起故从彼处殁。从彼殁时彼想当言灭耶。不灭耶。答当言灭。此则遮止执无想天死时无心者意。当言住何处彼想灭耶。答当言则住彼处。此则遮止执无想有情唯死时生时一念有心者意。问无想有情前心多耶。后心多耶。有说。前心多非后心。以彼未入无想位时。异熟相续势力猛盛故。多时有心方入无想。出无想已异熟相续势力衰微。故少时有心则便舍命。有说。后心多非前心。以彼未入无想位时。欣求无想其心猛利。故少时有心则入无想。出无想已无所欣求故多时有心然后舍命。如是说者。此事不定。或前多后少。或前少后多。随彼意乐有差别故

彼想当言善。为无记耶。答或善。或无记。彼想几随眠随增。答色界有漏缘。几结系耶。答六。彼想者。谓出无想想。或善或无记者。善谓生得善。无记谓有覆无记。或无覆无记。色界有漏缘者。谓第四静虑有漏缘随眠。问何故无漏缘随眠于彼想不随增耶。答彼计无想为涅槃。无想定为真道。乃至生彼。及从彼殁。唯如是执还复随转。于真灭道不谤为无故。无漏缘尔时不起。六结系者。除恚嫉悭有余结系。问出无想想为五部所断为但修所断耶。若尔何失。若五断者。十门所说当云何通。如说。过去法为等无间生二心。若修断者。此文复云何通。如说。彼想色界有漏缘随眠随增。有作是说。此通五断。问十门所说当云何通。答彼文应言过去法为等无间生六心。谓色界五。无色界一。而不作是说者有何意耶。当知彼文但依二无心定出心而说。不说无想。所以者何。一无心定加行功用作意。而起。无想不尔。有余师言。唯修所断。问此文所说当云何通。答此文应言彼想色界遍行。及修所断随眠随增。而不作是说者有何意耶。当知此中兼说和合。彼有命终时心通于五部。非但说出无想心。以命终心是前眷属故此兼说。评曰。应知前说者好。无别道理遮余心故。如世尊说。一切有情皆由食住。无想有情由何食住。答触意思识。问何故作此论。答欲令疑者得决定故。谓无想天必无段食触意思识亦灭无余。勿有疑彼无食而住。则不可通世尊所说一切有情皆由食住。为除彼疑显无想处虽无段食而有余三。与经相应故作斯论。问彼无想位三食亦灭。云何说有。答食有二种。一先时能引。二现在任时。彼位虽无现任持食。而有先时能引之食故名有食。有说彼中有三种食。一业食。二生食。三等无间缘食。业食者。谓先所造彼地业能引彼生故。生食者。谓结生心及俱有法。引彼一期令相续故。等无间缘食者。谓入无想触意思识为等无间缘。能引无想出心心所。令必当起不永断故。由此故说一切有情皆由食住。问眼根摄几根。乃至具知根摄几根。答眼根摄眼根。乃至广说。问何故作此论。答欲止说诸法唯摄他性者意。显一切法有摄自性故作此论。眼根摄眼根者。此依种类总相而说。若别说者眼有二种。谓左与右。左摄左右摄右。左复有二。谓所长养及异熟生。所长养摄所长养。异熟生摄异熟生。异熟生复有二种。谓善业异熟。不善业异熟。善业异熟摄善业异熟。不善业异熟摄不善业异熟。善业异熟复有二种。谓人与天。人摄人。天摄天。天复有二。谓欲界色界。欲界摄欲界。色界摄色界。色界复四。谓四静虑。初静虑摄初静虑。乃至第四静虑摄第四静虑。不善业异熟复有三种。所谓地狱傍生鬼界。地狱摄地狱。乃至鬼界摄鬼界。如是左眼并诸差别各有三世。过去摄过去。未来摄未来。现在摄现在。过去复有无量刹那。一一刹那各各自摄。如过去未来亦然。如左右亦尔。此中但依种类总说。如眼根。耳鼻舌命苦忧根亦尔。此皆各摄自一根故。身根摄三根。谓身女男根。女根摄女根身根少分。如女根男根亦尔。意根摄意根三根少分。谓三无漏根。由彼三根九法为体摄意非余故言少分。如意根。乐喜舍根信等五根亦尔。未知当知根摄未知当知根。九根少分。谓意。三受。信等五根。此九皆通有漏无漏。今唯摄无漏。于无漏中复有三道。今唯摄见道故言少分。如未知当知根。已知根具知根亦尔。信力乃至慧力念等觉支。乃至舍等觉支。正见乃至正定法智。乃至道智空无愿无相摄几根。答信力摄一根三根少分。谓三无漏根。此三各以九法为性。摄信非余故言少分。如信力余四力亦尔念等觉支摄四根少分。谓念根三无漏根。念根通有漏无漏。今唯摄无漏三根九法为性。今唯摄念故言少分。如念等觉支。择法精进喜定等觉支亦尔。余不摄根。谓安舍等觉支不摄根无根相故。正见摄四根少分。谓慧根三无漏根。如正见。正勤念定亦尔。余不摄根。谓正思惟正语业命不摄根无根相故。法智摄四根少分。谓慧根三无漏根。如法智。类智苦集灭道智亦尔。他心智摄三根少分。谓慧根。已知。具知根。云何摄慧根少分。谓慧根通缘一法多法。自相共相。现在三世。他身自身。相应不相应境。此唯摄缘一法。自相。现在。他身相应境慧。故言少分。二无漏根九法为性。此唯摄慧。慧中差别如前。此唯摄缘一法慧等故言少分。世俗智摄一根少分。谓慧根。以慧根通有漏无漏。今唯摄有漏故言少分。空摄四根少分。谓定根三无漏根如空。无愿无相亦尔。意根几根相应。乃至具知根几根相应。答意根十根三根少分相应。乃至广说。问何故作此论。答有迷相应执相应法非实有性。为止彼意显相应法体是实有故作斯论。意根十根相应者。谓五受信等五根。三根少分相应者。谓三无漏根。以彼三根九法为性。除意自体与余相应故言少分。乐喜舍根九根少分相应。谓意信等五三无漏根。与意信等五少分相应者。彼六根皆与五受根俱生。今乐喜舍各唯与自根俱生者相应故言少分。与三无漏根少分相应者。彼三根九法为性三受俱生。今乐喜舍唯与自根俱生者相应故言少分。苦根忧根六根少分相应。谓意根信等五根。云何与彼少分相应。谓彼六根五受俱生。今苦忧根唯与自根俱生者相应故言少分。信根四根九根少分相应。四根者。谓精进念定慧。九根少分相应者。谓意五受三无漏根。与意五受少分相应者。彼六根通染不染。今信根唯与不染善者相应故言少分。与三无漏根少分相应者。彼三根九法为性。今除信自体与余相应故言少分。如信根精进念定慧根亦尔。未知当知根与未知当知根九根少分相应。与未知当知根相应者。此根九法为性。一一除自与余相应皆名此根。此根相应九根少分相应者。谓意乐喜舍信等五根。云何与彼少分相应。谓彼九根通有漏无漏。今唯与彼无漏相应。于无漏中通见道修道无学道。今唯与彼见道相应故言少分。如未知当知根。已知根具知根亦尔。唯位有别余皆同故

信力乃至慧力念等觉支。乃至舍等觉支。正见乃至正定法智。乃至道智空无愿无相。几根相应。答信力四根九根少分相应。四根者。谓精进念定慧九根少分相应者。谓意五受三无漏根义如前说。如信力。余四力亦尔。谓精进念定慧念等觉支十一根少分相应。谓意乐喜舍信等。四三无漏根与意三受信等四少分相应者。彼八根通有漏无漏。今唯与彼无漏相应故言少分。与三无漏根少分相应者。彼三根九法为性。今除念自性与余相应故言少分。如念等觉支。择法精进定等觉支亦尔。喜等觉支九根少分相应。谓意信等五三无漏根。与意信等五少分相应者。彼六根通有漏无漏。今唯与彼无漏相应。于无漏中通依九地。谓未至。静虑中间四静虑。下三无色。今唯与彼依初二静虑者相应故言少分。与三无漏根少分相应者。彼三根通乐喜舍。及彼俱生。今唯与喜根俱生者相应故言少分。安舍等觉支三根九根少分相应。三根者。谓三无漏根。九根少分相应者。谓意乐喜舍信等五根。云何与彼少分相应。谓彼九根通有漏无漏。今唯与彼无漏相应故言少分。正见十一根少分相应。谓意乐喜舍信等四三无漏根。义如念等觉支说。如正见。正思惟正勤正定亦尔。然正思惟少有差别。谓意喜舍信等五三无漏根。是谓十一。此十一根通依诸地。今唯与依未至初静虑者相应故言少分。余非根相应。谓正语业命非根相应。非相应法故。法智十一根少分相应。如正见说。如法智。类智苦集灭道智亦尔。他心智十根少分相应。谓意乐喜舍信等四已知具知根。义如摄中说。世俗智二根八根少分相应。二根者。谓苦忧根。八根少分相应者。谓意乐喜舍信等四根。云何与彼少分相应。谓彼八根通有漏无漏。今唯与彼有漏相应故言少分。空无愿无相十一根少分相应。如念等觉支说

说一切有部发智大毗婆沙论卷第一百五十四阿毗达磨大毗婆沙论卷第一百五十五

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    根蕴第六中等心纳息第四之五

欲界殁生欲界时。几根灭。乃至广说。此中显示多门差别。谓界差别。补特伽罗差别。根差别。死有差别。中有差别。生有差别。渐命终差别。顿命终差别。欲界殁生欲界时。几根灭。答或四。或九。或八。或十三。或九。或十四。或十。或十五。渐命终者。无记心四。谓身命意舍。善心九。谓前四加信等五。顿命终者。若无形无记心八。谓眼耳鼻舌身命意舍根。善心十三。谓前八加信等五。若一形无记心九。谓前八加一形。善心十四。谓前九加信等五。若二形者无记心十。谓前九复加一形。善心十五。谓前十加信等五。何系心心所灭。答欲界系。几根现前。答或八。或九。或十。无形八。谓眼耳鼻舌身命意舍根。一形九。谓前八加一形。二形十。谓前九复加一形。何系心心所现前。答欲界系。欲界殁生色界时。几根灭。答或四或九。或九。或十四。渐命终者无记心四。谓身命意舍。善心九谓前四加信等五。顿命终者无记心九。谓眼耳鼻舌身命意舍。及女男根随一。善心十四。谓前九加信等五。何系心心所灭。答欲界系。几根现前。答八。谓眼耳鼻舌身命意舍根。何系心心所现前答色界系。欲界殁生无色界时。几根灭。答或四。或九。或九。或十四。如前说。何系心心所灭。答欲界系。几根现前。答三。谓命意舍根。何系心心所现前。答无色界系。色界没生色界时。几根灭。答或八。或十三。无记心八。谓眼耳鼻舌身命意舍。善心十三。谓前八加信等五。何系心心所灭。答色界系。几根现前。答八如前说。何系心心所现前。答色界系。色界没生欲界时几根灭。答或八。或十三。如前说何系心心所灭。答色界系。几根现前。答或八。或九。或十。如前说。何系心心所现前。答欲界系。色界殁生无色界时。几根灭。答或八。或十三。如前说。何系心心所灭答色界系。几根现前。答三如前说。何系心心所现前。答无色界系。无色界殁生无色界时。几根灭。答或三。或八。无记心三。谓命意舍。善心八。谓前三加信等五。何系心心所灭答无色界系。几根现前。答三如前说。何系心心所现前。答无色界系。无色界殁生欲界时。几根灭。答或三。或八。如前说。何系心心所灭。答无色界系。几根现前。答或八。或九。或十。如前说。何系心心所现前。答欲界系。无色界殁生色界时。几根灭。答或三。或八如前说。何系心心所灭。答无色界系。几根现前答八如前说。何系心心所现前。答色界系

阿罗汉般涅槃时。几根最后灭。答或四。或九。或八。或三。欲界渐般涅槃者四。谓身命意舍。顿般涅槃者九。谓眼耳鼻舌身命意舍。及女男根随一。色界八。谓眼耳鼻舌身命意舍。无色界三。谓命意舍。问何因缘故一切有情命终结生必住舍受。答于五受中无有行相昧劣如舍受者。于十时中无有昧劣。如死及生时者。故住舍受命终结生

    根蕴第六中一心纳息第五之一

诸法与心一起一住一灭。彼法与心相应耶。如是等章。及解章义既领会已。当广分别。问何故作此论。答欲止说相应非实者意。乃至广说。故作斯论。诸法与心一起一住一灭。彼法与心相应耶。答若法与心相应。彼法与心一起一住一灭。谓一切心所法。有法与心一起一住一灭。彼法非心相应。谓随心转色。心不相应行。此中起者。谓生。住者谓老。灭者谓无常。诸法与心一起一住一灭。彼法与心一所缘耶。答若法与心一所缘。彼法与心一起一住一灭。谓一切心所法。有法与心一起一住一灭。彼法非心一所缘。谓随心转色。心不相应行。问何故复作此论。答欲止说所缘非实者意。乃至广说。故作斯论。随心转义有十种。谓一起一住一灭一果一等流一异熟。善则善。不善则不善。无记则无记。堕一世中。一果者。谓离系果。一等流者。谓等流果。一异熟者。谓异熟果。堕一世中者。谓同一世摄。此总相说。若别说者有漏断结道中有八随转义。谓一起一住一灭。一果一等流一异熟。是善堕一世。有漏加行解脱胜进道中。及余有漏善心品。有七随转义。谓一起一住一灭。一等流一异熟是善堕一世。无漏断结道中亦有七随转义。谓一起一住一灭。一果一等流。是善堕一世。无漏加行解脱胜进道中有六随转义。谓一起一住一灭一等流。是善堕一世。不善心品有七随转义。谓一起一住一灭一等流一异熟。是不善堕一世。无记心品有六随转义。谓一起一住一灭一等流。是无记堕一世。又心心所法展转相望。由五因缘说名随转。谓所依故。所缘故。行相故。果故。异熟故。心与随心转色。心不相应行展转相望。由二因缘说名随转。谓果故。异熟故。随转义广说如杂蕴。诸法与心俱起。不离心。彼法与心俱住俱灭。不离心耶。乃至广说。问何故复作此论。答前纳息中。虽明心心所法等刹那灭。未辩色等。今欲辩之故作斯论又为遮止三刹那论沙门执故。谓有沙门说诸色法三刹那住。说心心所刹那则灭。彼复二种。一杂生论。二次第论。杂生论者作如是言。依初眼根生初眼识。彼俱生已眼根住眼识灭。依第二眼根生第二眼识。彼俱生已眼根住眼识灭。依第三眼根生第三眼识。彼俱生已眼根住眼识灭。当知则与初眼俱灭。问彼有何过。答彼初眼识有所依生。无所依灭。第二眼识亦尔。第三眼识有所依生。虽有所依灭而是他所依。是谓彼过。识随所依有生灭故。次第论者作如是言。依初眼根生初眼识。彼俱生已。眼根住眼识灭。次复依彼生第二眼识。眼根住眼识灭。后复依彼生第三眼识。此识与眼俱时而灭。问彼有何过。答彼初眼识有所依生。无所依灭。第二眼识无所依生。无所依灭。第三眼识无所依生。有所依灭。是谓彼过。识随所依有生灭故。又彼二论有余共过。谓人趣没生地狱时。人趣未舍已得地狱。如是则趣杂乱。身杂乱。趣杂乱者。谓彼有情是地狱趣。亦是人趣。身杂乱者。谓彼有情有地狱身亦有人身。便为大过。依彼论意若入无想灭尽定时。诸根大种与心俱起不离心。然彼离心而住离心而灭。为遮彼执故作斯论。诸法与心俱起不离心。彼法与心俱住俱灭不离心耶。答欲色界有情。不住无想灭尽定者。诸根大种与心俱起不离心。与心俱住俱灭不离心。若住无想灭尽定者彼便离心。问云何离心。答彼离心而起。离心而住。离心而灭。心心所断彼相续故。如说。不修眼根乃至意根。云何不修眼根。乃至广说。修有四种。谓得修。习修。对治修。除遣修。具辩如智蕴。今依后二修而作论。问眼等根云何不修。复云何修。答乃至眼等诸根对治道未生名不修根。此依对治修说。又乃至缘眼等所有烦恼。未断未知名不修根。此依除遣修说。若眼等诸根对治道已生名为修根。此依对治修说。又缘眼等所有烦恼。已断已知名为修根。此依除遣修说。是谓此处略毗婆沙。云何不修眼根乃至身根。答若于眼根未离贪。未离欲润喜渴。又无间道能尽色贪。彼于此道未修未安。如不修眼根不修耳鼻舌身根亦尔。若于眼根未离贪者。谓于眼未离爱。未离欲者。谓于爱欲未断未知。未离润者。谓于爱润未断未知。未离喜者。谓于爱喜未断未知。未离渴者。谓于爱渴未断未知。又无间道能尽色贪者。谓无间道能尽色界爱。彼于此道未修未安者。谓未修习。及未安息修。谓习修安谓得修。又起名修灭名安。又已生名修。已灭名安。应知此中若于眼根未离贪等者。依对治修说。或依除遣修说。又无间道能尽色贪等者。依除遣修说。或依对治修说。有说。若于眼根未离贪等者。谓缘眼根爱未断未知。又无间道能尽色贪等者。谓缘眼根余烦恼未断未知。有说。若于眼根未离贪等者。谓未断系得。又无间道能尽色贪等者。谓未证离系得。如未断系得。未证离系得如是。未损减过失。未修习功德。未弃下劣。未证胜妙。未舍无义。未得有义。未除有爱热恼。未受无爱快乐。应知亦尔。有说。若于眼根未离贪等者。谓无间道未起作用。又无间道能尽色贪等者。谓解脱道未起作用。有说。若于眼根未离贪等者。谓未能离欲界。乃至第三静虑染。又无间道能尽色贪等者。谓未能离第四静虑染。如不修眼根。不修余四根亦尔。云何不修意根。答若于意根未离贪。未离欲润喜渴。又无间道能尽无色贪。彼于此道未修未安。若于意根未离贪者。谓于意未离爱。余句如前。又无间道能尽无色贪者。谓无间道能尽无色界爱。未修未安如前说。应知此中若于意根未离贪等者。依对治修说。或依除遣修说。又无间道能尽无色贪等者。依除遣修说。或依对治修说。次有三说如前应知。第五有说。若于意根未离贪等者。谓未能离欲界乃至无所有处染。又无间道能尽无色贪等者。谓未能离非想非非想处染

如说。修眼根乃至意根。云何修眼根乃至身根。答若于眼根已离贪。已离欲润喜渴。又无间道能尽色贪。彼于此道已修已安。如修眼根。修耳鼻舌身根亦尔。云何修意根。答若于意根已离贪。已离欲润喜渴。又无间道能尽无色贪。彼于此道已修已安。此诸文句应与前不修相违。广说

诸不成就学根得学根。乃至广说。问何故作此论。答愚于退者执退非有。为遮彼意显退实有故作斯论。诸不成就学根得学根。彼一切入正性离生耶。答若入正性离生。彼一切不成就学根得学根。有不成就学根得学根。彼非入正性离生。谓退阿罗汉果时。彼诸学根先舍今得。诸不成就学根。得学根。彼一切世第一法等无间耶。答若世第一法等无间。彼一切不成就学根得学根。有不成就学根得学根。彼非世第一法等无间。谓退阿罗汉果时。彼诸学根先舍今得。问何故复作此论。答前虽显示入正性离生自体。而未显示入彼等无间缘。今欲显之故作斯论

诸舍无漏根。得无漏根。彼一切从果至果耶。答若从果至果。彼一切舍无漏根。得无漏根谓预流者证一来果时。舍预流果摄及胜果道无漏诸根得一来果。摄无漏诸根。从果至果者。从预流果至一来果。一来者证不还果时。不还者证阿罗汉果时。应知亦尔。如证果时退果时亦尔。有舍无漏根得无漏根。彼非从果至果。谓现观边道类智起时。若时解脱阿罗汉。练根作不动时。问道类智起时可尔。时解脱阿罗汉练根作不动时云何可尔。答此文但应说现观边道类智起时。不应说余。而说余者。欲显此中但说从异类果至异类果。时解脱阿罗汉练根作不动时。性类虽别果类不别故。不名从果至果。诸舍无漏根得无漏根。彼一切无漏根灭。无漏根起耶。答应作四句。有舍无漏根得无漏根。彼非无漏根灭无漏根起。谓退阿罗汉不还一来果时。及以世俗道得一来不还果时。尔时无漏不现前故。有无漏根灭无漏根起。彼非舍无漏根得无漏根。谓已得无漏根现前。灭起则先已得一切果向无漏诸根相续起灭彼非得起曾得道现在前故。亦非舍圣道唯三时舍。彼非此时故。一退时。二得果时。三练根时。有舍无漏根得无漏根。彼亦无漏根灭无漏根起。谓现观边道类智起时。及以无漏道得一来不还果时。得阿罗汉果时。时解脱阿罗汉练根作不动时。现观边道类智起时。舍无漏根者。谓见道所摄。得无漏根者。谓修道所摄。无漏根灭者。谓道类忍俱生品。无漏根起者。谓道类智俱生品。以无漏道得一来果时。舍无漏根者。谓预流果摄。及胜果道。得无漏根者。谓一来果摄。无漏根灭者。谓第六无间道摄。无漏根起者。谓第六解脱道摄。以无漏道得不还果随应亦尔。得阿罗汉果时舍无漏根者。谓不还果摄。及胜果道。得无漏根者。谓阿罗汉果摄。无漏根灭者。谓金刚喻定俱生品。无漏根起者。谓初尽智俱生品时解脱阿罗汉练根作不动时。舍无漏根者。谓时解脱道摄。得无漏根者。谓不时解脱道摄。无漏根灭者。谓第九无间道摄。无漏根起者。谓第九解脱道摄。余位练根略故不说。有非舍无漏根得无漏根。彼亦非无漏根灭无漏根起。谓除前相。此中相声依所名转。则前三句所不摄法为第四句。此复云何。谓诸异生位。乃至增上忍位。于无漏根非舍非得。非灭非起。住世第一法时。于无漏根非舍而得。非灭而起。若诸圣者住苦法智忍。乃至道法智时。于无漏根非舍而得。亦灭亦起。住道类智忍时。于无漏根亦舍亦得。亦灭亦起。从预流果证一来果时。以世俗道者。若无漏道为加行。住加行道时。于无漏根非舍而得。灭而非起。若世俗道为加行。住加行道五无间道五解脱道时。于无漏根非舍而得。非灭非起。住第六无间道时。于无漏根亦舍亦得。非灭非起以无漏道者。若世俗道为加行。住加行道时。于无漏根非舍而得。非灭而起。若无漏道为加行。住加行道五无间道五解脱道时。非舍而得。亦灭亦起。住第六无间道时。于无漏根亦舍亦得。亦灭亦起。从一来果证不还果随应亦尔。从不还果证阿罗汉果。离初静虑染时。以世俗道者。若无漏道为加行。住加行道时。于无漏根非舍而得。灭而非起。若世俗道为加行。住加行道九无间道九解脱道时。于无漏根非舍而得。非灭非起。以无漏道者。若世俗道为加行。住加行道时。于无漏根非舍而得。非灭而起。若无漏道为加行。住加行道九无间道九解脱道时。于无漏根非舍而得。亦灭亦起。如离初静虑染。乃至离无所有处染亦尔。离非想非非想处染时。若世俗道为加行。住加行道时。于无漏根非舍而得。非灭而起。若无漏道为加行。住加行道八无间道八解脱道时。于无漏根非舍而得。亦灭亦起。住第九无间道时。于无漏根亦舍亦得。亦灭亦起。信解练根作见至时。若世俗道为加行。住加行道时。于无漏根非舍而得。非灭而起。若无漏道为加行。住加行道时。于无漏根非舍而得。亦灭亦起。住无间道时。于无漏根亦舍亦得。亦灭亦起。时解脱阿罗汉练根作不动时。如离非想非非想处染。说杂修静虑初刹那时。于无漏根非舍而得。灭而非起。第二刹那时。于无漏根非舍而得。非灭而起。第三刹那时。如初刹那说。若引发五通五无间道三解脱道时。若起无量。世俗解脱。胜处。遍处。不净观。持息念。世俗念住。世俗无碍解。无诤愿智。边际定。空空无愿无愿。无相无相。入灭定想微细等时。于无漏根非舍而得。非灭非起。若起无漏他心通时。若起无漏念住。无漏解脱。无漏无碍解等时。于无漏根非舍而得亦灭亦起。若起微微心时。若起闻思慧等时。于无漏根非舍非得。非灭非起。于如是等差别位中随其所应为第四句。是故略说。除前相言

诸未知当知根。乃至广说。问何故作此论。答为令疑者得决定故。如品类足说。云何未知当知根。答未已见谛。未已现观者。诸学慧慧根。若诸根随信随法行。于未现观四圣谛能现观。是名未知当知根。彼文但说现在和合。能荷担有作用。未知当知根。非过去未来。勿有生疑。唯现在和合。能荷担有作用。是未知当知根。非过去未来。为令彼疑得决定故。显在三世皆是此根故作斯论。诸未知当知根。彼一切于未现观四圣谛能现观耶。答应作四句。有未知当知根。彼非于未现观四圣谛能现观。谓未知当知根。在过去或未来。彼有未知当知根相故。亦名未知当知根。然非于未现观四圣谛能现观。过去作用已息。未来作用未起故。有于未现观四圣谛能现观。彼非未知当知根。谓诸非根法于未现观四圣谛能现观此复云何。谓想思触作意。欲胜解惭愧。无贪无嗔轻安。舍不放逸不害。寻伺随心转色心不相应行。如是诸法于未现观四圣谛。虽能现观而非未知当知根。以合九根为此根故。有未知当知根。彼亦于未现观四圣谛能现观。谓未知当知根于未现观四圣谛能现观。则现在和合能荷担有作用未知当知根。有非未知当知根。彼亦非于未现观四圣谛能现观。谓除前相。则前三句所不摄法为第四句。此复云何。谓除三世未知当知根自性。及现在此根相应俱有非根法。诸余过去未来此根相应俱有非根法。及已知根具知根俱生品。一切有漏心心所法。余色心不相应行。及无为皆是第四句。故言除前相。如未知当知根。已知具知根随其所应广说亦尔

尽智当言尽智乃至道智耶。乃至广说。问何故此中分别三智。答是本论师意欲尔故。乃至广说。答尽智当言尽智。谓自了知我已遍知苦。我已永断集。我已证灭我已修道。或法智。谓自了知我已遍知欲界系苦。我已永断欲界系集。我已证欲界系诸行灭。我已修断欲界系诸行道。或类智谓自了知我已遍知色无色界系苦。我已永断色无色界系集。我已证色无色界系诸行灭。我已修断色无色界系诸行道。或苦智谓自了知我已遍知三界系苦。或集智谓自了知我已永断三界系集。或灭智谓自了知我已证三界系诸行灭。或道智谓自了知我已修断三界系诸行道。问何故尽智非他心智。答尽智非见自性。他心智是见自性故。何故非世俗智。答尽智是无漏。世俗智是有漏故。显自性已当显地。或有寻有伺。谓依未至初静虑。或无寻唯伺。谓依静虑中间。或无寻无伺。谓依上三静虑下三无色。显地已当显相应。或乐根相应。谓依第三静虑。或喜根相应。谓依初二静虑。或舍根相应。谓依未至静虑中间。第四静虑。下三无色。显相应已当显行相。或无愿相应。谓十行相。或无相相应。谓四行相。问何故尽智非空相应。答空是胜义涉胜义。尽智是胜义涉世俗故。如说了知我生已尽。涉我解故非空相应。显行相已当显所缘。或缘欲界系。或缘色无色界系。此谓缘苦集。或缘不系。此谓缘灭道。如尽智。无生智亦尔。然有差别。谓无生智当言无生智。谓自了知我不复遍知苦。不复永断集不复证灭。不复修道。无学正见当言无学正见。谓以四行相知五取蕴。以四行相知五取蕴因。以四行相知五取蕴灭。以四行相知断五取蕴道。或法智。谓知欲界四谛。或类智。谓知色无色界四谛。或他心智。谓知他无漏心心所法。或苦集灭道智。谓别知三界四谛。问何故无学正见非世俗智。答此无漏彼有漏故。显自性已地等四问如前说。差别者。此亦与空相应。亦作空非我行相转故。诸最初尽智。乃至广说。问何故作此论。答前明三智。未辩等无间缘及所缘差别。今欲辩之故作斯论。诸最初尽智。彼一切无间道等无间耶。答如是。以初尽智必从金刚喻定等无间起故。设无间道等无间彼一切尽智耶。答如是。以金刚喻定等无间必起尽智故。诸最初无生智。彼一切尽智等无间耶。答如是。最初无生智必从尽智等无间起故。设尽智等无间彼一切无生智耶。答或尽智。谓时解脱。或无生智。谓不时解脱。或无学正见。谓时解脱诸缘彼无间道起则缘彼初尽智起耶。答若缘生无间道起则缘彼初尽智起。若不缘生无间道起则不缘彼初尽智起。谓金刚喻定六智相应则灭道法智。及四类智。最初尽智二智所摄则苦集类智。若金刚喻定苦集类智相应者则与初尽智所缘境共。以俱缘非想非非想处四蕴生故。彼四蕴名生生死摄故。若金刚喻定灭道法类智相应者则与初尽智所缘境异。彼缘三界灭道。此缘有顶苦集故诸缘彼尽智起则缘彼无生智起耶。答如是。设缘彼无生智起则缘彼尽智起耶。答如是。此二智俱以十四行相缘四谛故

说一切有部发智大毗婆沙论卷第一百五十五阿毗达磨大毗婆沙论卷第一百五十六

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    根蕴第六中一心纳息第五之二

诸法无学正见相应。彼法无学正思惟相应耶。答应作四句。此中无学正见一切地可得。非一切无漏心。无学正思惟一切无漏心可得非一切地。是故得作大四句。有法无学正见相应。非无学正思惟。谓无学正见相应正思惟。及无学正思惟不相应无学正见相应法。无学正见相应正思惟者。谓无学正见聚中正思惟。此但与无学正见相应。非无学正思惟。自体与自体由三因缘不相应故。一无二自性俱起故。二前后刹那不并故。三诸法不观自体与他为缘故。及无学正思惟不相应无学正见相应法者。谓静虑中间。上三静虑。下三无色。无学正见相应法。此非无学正思惟相应。彼地无正思惟故。有法无学正思惟相应。非无学正见。谓无学正思惟相应正见。及无学正见不相应。无学正思惟相应法。无学正思惟相应正见者。谓无学正思惟聚中正见此但与无学正思惟相应。非无学正见。自体与自体由三因缘不相应故。及无学正见不相应。无学正思惟相应法者。谓未至初静虑。尽无生智聚中。正思惟相应法。此非无学正见相应彼聚中无正见故。有法无学正见正思惟相应。谓除无学正见相应正思惟。及除无学正思惟相应正见。诸余无学正见正思惟相应法。谓此聚中除二自体。余心心所与二相应。此复云何。谓九大地法。十大善地法心及伺。有法非无学正见正思惟相应。谓无学正见不相应正思惟。无学正思惟不相应正见。及前所不摄心心所法。并色无为心不相应行。无学正见不相应正思惟者。谓尽无生智聚中正思惟。此非无学正见相应。彼聚中无正见故。亦非无学正思惟相应。自体与自体不相应故。无学正思惟不相应正见者。谓静虑中间。上三静虑。下三无色。无学正见。此非正见相应。自体与自体不相应故。亦非无学正思惟相应。彼地中无正思惟故。及前所不摄心心所法者。谓静虑中间。上三静虑。下三无色。尽无生智聚心心所法。及一切学有漏心心所法。并色无为心不相应行。当知皆是第四句摄。诸法无学正见相应。彼法无学正勤相应耶。答应作四句。此中无学正见一切地可得。非一切无漏心。无学正勤一切地。一切无漏心可得。是故得作中四句。有法无学正见相应非无学正勤。谓无学正见相应正勤。此非无学正勤相应。自体与自体不相应故。有法无学正勤相应。非无学正见。谓无学正见及无学正见不相应。无学正勤相应法。无学正见者。自体与自体不相应故。无学正见不相应无学正勤相应法者。谓尽无生智聚中正勤相应法。此非正见相应。彼聚中无正见故。有法无学正见正勤相应。谓除无学正见相应正勤诸余无学正见相应法。正勤多故于此偏除。然此聚中除二自体余心心所皆二相应。此复云何。谓九大地法九大善地法心及寻伺。有法非无学正见正勤相应。谓无学正见不相应正勤。及前所不摄心心所法。并色无为心不相应行。无学正见不相应正勤者。谓尽无生智聚中正勤。此非正见相应。彼聚中无正见故。亦非正勤相应。自体与自体不相应故。及前所不摄心心所法者。此中无余无学心心所法前所不摄。但有一切学有漏心心所法是前所不摄。并色无为心不相应行。当知皆是第四句摄。如对正勤对正念正定正解脱亦尔。此皆得作中四句故。诸法无学正见相应。彼法非无学正智相应。诸法无学正智相应彼法非无学正见相应。以此二法不俱起故

诸法无学正思惟相应。彼法无学正勤相应耶。答应作四句。此中无学正思惟。一切无漏心可得非一切地。无学正勤一切地一切无漏心可得。是故亦得作中四句。文如正见对正勤说。如对正勤对正念正定正解脱亦尔。诸法无学正思惟相应。彼法无学正智相应耶。答应作四句。此中无学正思惟。一切无漏心可得非一切地。无学正智一切地可得非一切无漏心。是故亦得作大四句。文如正见对正思惟说

诸法无学正勤相应彼法无学正念相应耶。答应作四句。此中无学正勤正念俱一切地一切无漏心可得。是故得作小四句。有法无学正勤相应。非无学正念。谓无学正念此与无学正勤相应非正念。自体与自体不相应故。有法无学正念相应。非无学正勤。谓无学正勤。此与无学正念相应非正勤。自体与自体不相应故。有法无学正勤正念相应。谓除无学正勤正念。诸余无学正勤正念相应法。谓此聚中除二自体。余心心所与二相应。此复云何。谓九大地法九大善地法心及寻伺。有法非无学正勤正念相应。谓前所不摄心心所法。并色无为心不相应行。此中无余无学心心所法前所不摄。但有一切学有漏心心所法。是前所不摄。并色无为心不相应行。当知皆是第四句摄。如对正念对正定正解脱亦尔。此皆得作小四句故。诸法无学正勤相应。彼法无学正智相应耶。答应作四句。此中正勤一切地一切无漏心可得。正智一切地可得。非一切无漏心。亦作中四句文如正思惟对正勤说。如正勤正念正定亦尔

诸法无学正解脱相应。彼法无学正智相应耶。答应作四句。此中无学正解脱。一切地一切无漏心可得。无学正智。一切地可得。非一切无漏心。亦作中四句文如正勤对正智说

    根蕴第六中鱼纳息第六

若成就眼根。彼于二十二根。几成就几不成就。如是等章。及解章义既领会已。当广分别。问此纳息何故名鱼。答多位转移难执取故。何谓多位。谓具根不具根位。无形一形二形位。有心无心位。定不定位。生界地差别位。断善不断善位。离染未离染位。善染无记心位。异生圣者位。见道修道无学道位。于此等位二十二根成与不成转移不定。如鱼难执故立此名。若成就眼根。彼于二十二根。几成就几不成就。乃至具知根问亦尔。答若成就眼根。彼定成就五余不定。成就五者。谓眼身命意舍根。余不定者余十七根。或成就或不成就。谓耳鼻舌根身根。具者则成就。不具者不成就。女根男根若一形随成就一。若二形俱成就。若无形俱不成就。谓本不得或得已由渐命终。或余缘故失。乐根若生遍净及下。若圣者生第四静虑则成就。若异生生第四静虑则不成就。苦根若生欲界则成就。若生色界则不成就。喜根若生极光净及下。若圣者生第三第四静虑则成就。若异生生第三第四静虑则不成就忧根若未离欲染则成就。若已离欲染则不成就。信等五根若不断善则成就。若断善则不成就。未知当知根住见道则成就余则不成就。已知根住修位则成就。余则不成就。具知根住无学位则成就。余则不成就。是故说余不定。如眼根。耳鼻舌根亦尔。皆色界定成就。无色界定不成就。欲界不定故。若成就身根彼定成就四余不定。成就四者。谓身命意舍根。余不定者。余十八根或成就或不成就。眼根眼根具者则成就。不具者不成就。余十七根如前说。若成就女根彼定成就八余不定。成就八者。谓女身命意乐苦喜舍根。余不定者。余十四根或成就或不成就如前应知。如女根男根亦尔。若成就男女二根。彼定成就十五根。谓男女身命意五受信等五根。定不成就三根。谓三无漏根。余不定如前应知。若成就命根彼定成就三余不定。成就三者。谓命意舍根。余不定者。余十九根或成就或不成就。谓眼耳鼻舌根生色界则成就。生无色界则不成就。生欲界或成就或不成就如前说。身根生欲色界则成就。生无色界则不成就。女根男根生色无色界则不成就。生欲界或成就或不成就如前说。乐根若生遍净及下。若圣者生上则成就。若异生生上则不成就。苦根若生欲界则成就。若生色无色界则不成就。喜根若生极光净及下。若圣者生上则成就。若异生生上则不成就余如前说。如命根意根舍根亦尔。皆三界有情定成就故。若成就乐根彼定成就四余不定。成就四者。谓乐命意舍根。余不定者。余十八根或成就或不成就如前应知。若成就苦根彼定成就七余不定。成就七者。谓身命意四受除忧。余不定者。余十五根或成就或不成就如前应知。若成就喜根彼定成就五余不定。成就五者。谓命意乐喜舍根。余不定者。余十七根或成就或不成就如前应知。若成就忧根彼定成就八。定不成就一。余不定。成就八者。谓身命意五受根。不成就一者。谓具知根。余不定者。余十三根或成就或不成就如前应知。若成就信根彼定成就八余不定。成就八者。谓命意舍信等五根。余不定者。余十四根或成就或不成就如前应知。如信根。精进念定慧根亦尔。若成就未知当知根。彼定成就十三。定不成就二。余不定。成就十三者。谓身命意四受除忧信等五。未知当知根。不成就二者。谓已知具知根。余不定者。余七根或成就或不成就如前应知。若成就已知根彼定成就十一。定不成就二。余不定。成就十一者。谓命意乐喜舍。信等五。已知根。不成就二者。谓未知当知具知根。余不定者余九根或成就或不成就如前应知。若成就具知根彼定成就十一。定不成就三。余不定。成就十一者。谓命意乐喜舍。信等五。具知根。不成就三者。谓忧前二无漏根。余不定者。余八根或成就或不成就如前应知

若成就眼根。彼于三世二十二根。几成就几不成就。乃至具知根问亦尔。答若成就眼根。彼定不成就过去未来八。谓命等八无记根唯成就现在。非过去未来势羸劣故。定成就过去未来二现在三。过未二者。谓意舍根此于现在非定成就。以彼或住无心位故。现三者。谓眼身命根余不定如前说。如眼根。耳鼻舌亦尔。若成就身根彼定不成就过去未来八。谓命等。定成就过去未来二现在二。过未二者。谓意舍。现二者。谓身命余不定如前说。若成就女根彼定不成就过去未来八。谓命等。定成就过去未来五。现在三。过未五者。谓意四受除忧。现三者。谓女身命。余不定如前说。如女根。男根亦尔。若成就男女二根彼定不成就过去未来八三世三。过未八者。谓命等。三世三者。谓三无漏。定成就过去未来九。三世二。现在四。过未九者谓四受信等五。三世二者。谓意一受现在四者。谓男女身命余不定如前说。西方师言。应说过未定成就十。谓五受信等五。三世定成就一。谓意。受名不定故。迦湿弥罗国诸论师言。名虽不定而数则定。必有一受现在前故。此中说数不说名。若成就命根。彼定不成就过去未来八。谓命等。定成就过去未来二。现在一。过未二者。谓意舍。现一者。谓命。余不定如前说。如命根。意根舍根亦尔。若成就乐根。彼定不成就过去未来八。谓命等。定成就过去未来二。未来一。现在一。过未二者谓意舍。未一者。谓乐。现一者。谓命。余不定如前说。若成就苦根。彼定不成就过去未来八。谓命等。定成就过去未来五。现在二。过未五者。谓意四受除忧。现二者。谓身命余不定如前说。若成就喜根彼定不成就过。去未来八。谓命等。定成就过去未来二。未来二。现在一。过未二者。谓意舍。未二者。谓乐喜。现一者。谓命。余不定如前说。若成就忧根。彼定不成就过去未来八三世一。过未八者。谓命等。三世一者。谓具知。定成就过去未来四。三世二。现在二。过未四者。谓四受。三世二者。谓意一受现二者。谓身命。余不定如前说。健驮罗国说。此文应言过未成五。谓五受。三世成一。谓意受名不定。故迦湿弥罗说。名虽不定以数定故应如前说。若成就信根彼定不成就过去未来八。谓命等。定成就过去未来七。现在一。过未七者。谓意舍信等五。现一者谓命。余不定如前说。如信根。精进念定慧根亦尔。若成就未知当知根。彼定不成就过去未来八。三世二。现在二。过未八者谓命等。三世二者。谓已知具知。现二者。谓苦忧。定成就三世七。过去未来三。未来现在一。现在二。三世七者。谓意一受信等五。过未三者。谓三受。未现一者。谓未知当知。现二者。谓身命此中二说如前。余不定如前说。若成就已知根。彼定不成就过去未来八。三世二。过未八者。谓命等。三世二者。谓余二无漏。定成就过去未来七。未来三。现在一。过未七者。谓意舍信等五。未三者。谓乐喜已知。现一者谓命。余不定如前说。若成就具知根。彼定不成就过去未来八。三世三。过未八者。谓命等。三世三者。谓忧余二无漏。定成就过去未来七。未来三。现在一。过未七者。谓意舍信等五。未三者。谓乐喜具知。现一者。谓命。余不定如前说。若不成就眼根。彼于二十二根。几不成就几成就。乃至具知根问亦尔。答若不成就眼根。彼定不成就一。谓眼。定成就三。谓命意舍。余不定如前说。如眼根。耳鼻舌女男根三无漏根亦尔。若不成就身根。彼定不成就十。谓七色苦忧未。知当知。定成就八。谓命意舍信等五。余不定如前说。若男女根俱不成就。彼定不成就二。谓男女。定成就三。谓命意舍。余不定如前说。命意舍根无不成就。若不成就乐根。彼定不成就九。谓女男四受除舍三无漏。定成就八。谓命意舍信等五。余不定如前说。若不成就苦根。彼定不成就五。谓女男苦忧未知当知。定成就八。谓命意舍信等五。余不定如前说。若不成就喜根。彼定不成就八。谓女男苦喜忧三无漏。定成就八。谓命意舍信等五。余不定如前说。若不成就忧根。彼定不成就一。谓忧。定成就八。谓命意舍信等五余。不定如前说。若不成就信根。彼定不成就八。谓信等五三无漏。定成就八。谓身命意五受。余不定如前说。如信根。精进念定慧根亦尔。若不成就眼根。彼于三世二十二根。几不成就几成就。乃至具知根问亦尔。答若不成就眼根。彼定不成就三世一。过去未来七。三世一者。谓眼。过未七者。谓命等七。定成就过去未来二。现在一。过未二者。谓意舍。现一者。谓命。余不定如前说。如眼根。耳鼻舌女男根亦尔若不成就身根。彼定不成就三世十。过去未来一。三世十者。谓七色苦忧未知当知。过未一者谓命。定成就过去未来五。三世二。现在一。过未五者。谓信等五。三世二者。谓意舍。现一者。谓命。余不定如前说。若男女根俱不成就。彼定不成就三世二。过去未来六。三世二者。谓男女。过未六者。谓五色命。定成就过去未来二。现在一。过未二者。谓意舍。现一者。谓命。余不定如前说。命意舍根无不成就。若不成就乐根。彼定不成就三世九。过去未来六。三世九者。谓女男四受除舍三无漏。过未六者。谓五色命。定成就过去未来七。现在一。过未七者。谓意舍信等五。现一者。谓命。余不定如前说。若不成就苦根。彼定不成就三世五。过去未来六三世五者。谓女男苦忧未知当知。过未六者。谓五色命。定成就过去未来七。现在一。过未七者。谓意舍信等五。现一者。谓命。余不定如前说。若不成就喜根。彼定不成就三世八。过去未来六。三世八者。谓女男苦忧喜三无漏。过未六者。谓五色命。定成就过去未来七。现在一。过未七者。谓意舍信等五。现一者。谓命。余不定如前说。若不成就忧根彼定不成就三世一。过去未来八。三世一者。谓忧。过未八。谓命等。定成就过去未来七。现在一。过未七者。谓意舍信等五。现一。谓命。余不定如前说。若不成就信根。彼定不成就三世八。过去未来八。三世八者。谓信等五三无漏。过未八者。谓命等。定成就过去未来四。三世二。现在二。过未四者。谓四受。三世二者。谓意一受。现二者。谓身命余不定如前说。如信根。精进念定慧根亦尔。若不成就未知当知根。彼定不成就三世一。过去未来八。三世一者。谓未知当知。过未八者。谓命等。定成就过去未来二。现在一。过未二者。谓意舍。现一者。谓命。余不定如前说。如未知当知根。已知具知根亦尔。诸根善彼根因善根耶。设根因善根彼根善耶。答诸根善彼根。因善根谓八根全。及六根少分。此以善根为三因。即相应俱有同类。有根因善根彼根非善。谓善根所引异熟生根。即善根所引异熟命等八根。及意乐喜舍根。此以善根为一因。谓异熟因。此中无贪无嗔无痴名因善根

诸根不善彼根因不善根耶。设根因不善根彼根不善耶。答诸根不善彼根因不善根。谓六根少分。此以不善根为四因。即相应俱有同类遍行。有根因不善根。彼根非不善。谓不善根所引异熟一生根。即不善根所引命等八根。及意苦根。此以不善根为一因。谓异熟因。及欲界有身见边执见相应根。此以不善根为二因。谓同类遍行。此中贪嗔痴名因不善根

诸根无记彼根因无记根耶。设根因无记根。彼根无记耶。答应作四句。迦湿弥罗国毗婆沙师说。无记根有三。谓无记爱慧无明。无记爱者。谓色无色界五部爱。无记慧者。谓有覆无记慧。无覆无记慧。有覆无记慧。谓欲界有身见边执见。及色无色界五部染污慧。无覆无记慧。谓威仪路工巧处异熟生变化心俱生慧。无记无明者。谓欲界有身见边执见相应无明。及色无色界五部无明。此中无记贪相应心。由三无记根故名有根心。所余有覆无记心由二无记根故名有根心。谓无记慧无明一切无覆无记心。由一无记根故名有根心。谓无记慧。依此以释四句义者。有根无记。彼根非因无记根。谓无缘根即命等八根。此根无记而不以无记根为因。有根因无记根彼根非无记。谓不善根。即六少分。此根不善而以无记根为二因。谓同类遍行。有根无记彼根亦因无记根。谓无记有缘根。即五少分。此根无记亦以无记根为四因。谓相应俱有同类遍行。有根非无记。彼根亦非因无记根。谓善根。即八全六少分。此根非无记。亦不以无记根为因。颇有根非因善根。非因不善根。非因无记根。彼根非无因耶。答有。谓无缘根。即命等八根。以色心不相应行为因。此非三性根为因而以色心不相应行为三因。谓俱有同类异熟。西方诸师说。无记根有四。谓无记爱见慢无明。无记爱者。谓色无色界五部爱。无记见者。谓欲界有身见边执见。及色无色界五见。无记慢者。谓色无色界五部慢。无记无明者。谓欲界有身见边执见相应无明。及色无色界五部无明。此中无记贪相应心。由二无记根故名有根心。谓无记爱无明。无记见慢相应心。亦各由二无记根故名有根心。谓即彼及无明。所余有覆无记心。由一无记根故名有根心。谓无记无明。依彼以释四句义者。此文应作是说。有根无记彼根非因无记根。谓无覆无记根。此根无记而不以无记为根因。有根因无记根彼根非无记。谓不善根。此根非无记而以无记根为二因。谓同类遍行。有根无记彼根亦因无记根。谓有覆无记根。此根无记亦以无记根为四因。谓相应俱有同类遍行。有根非无记彼根亦非因无记根。谓善根此根非无记。亦不以无记根为因。颇有根非因善根。非因不善根。非因无记根。彼根非无因耶。答有。谓无覆无记根。以色心不相应行等为因。此根不以三性根为因。而以色心不相应行。无覆无记心心所为四因。谓相应俱有同类异熟。此即总说然相应根具有四因。不相应根唯三因。除相应因。问何故西方诸师。立慢为无记根。答彼说力坚强义是根义。慢力坚强故立为根。谓瑜伽师。所以退失百千善品皆由慢力。问何故此国诸师不立为根耶。答此说下义是根义。慢令心举于下下顺故不立根。问何故此国诸师立无覆无记慧为无记根。答此说为依因义是根义。无覆无记慧为依因胜故立为根。问何故西方诸师不立为根。答彼说力坚强义是根义。无覆无记慧势力羸劣故不立根。问何故此彼国师俱不立疑为无记根。答俱说定住义是根义。疑不定住二门转故。不立为根。如是说者。如善不善根俱有三种。无记根亦应尔。又如不善慢不立不善根。无记慢亦应尔故。无记根唯三者善

    根蕴第六中因缘纳息第七

诸根因过去。彼根缘过去耶。如是等章。及解章义既领会已。当广分别。问何故作此论。答为止拨无去来二世及拨无因缘者意。乃至广说故作斯论。此中依二缘作论。谓因缘所缘缘。问何故不依余二缘作。论耶。答等无间缘唯一刹那增上缘通一切法。若依彼作论则文义不婉博故。此但依二缘作论。此中应作略毗婆沙。谓二十二根中。十四有所缘。八无所缘。有所缘中。五识身相应品过去缘过去。现在缘现在。未来生法缘未来。不生法缘三世。意识身相应品随在何世。若生不生皆缘三世及无为法。又见苦见集所断根通缘五部。见灭见道所断根唯缘自部及不断修断。不断根通缘五部及不断。又欲色界系及不系根。通缘三界系及不系。无色界系根唯缘色无色界系及不系。因缘差别亦应准知。是谓此中略所说义。随文广释如理应知。于中一切初翻因略而缘广。一切后翻缘略而因广。此中诸忍以智名说智眷属故

说一切有部发智大毗婆沙论卷第一百五十六阿毗达磨大毗婆沙论卷第一百五十七

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    定蕴第七中得纳息第一之一

诸得过去法。彼得过去耶。如是等章及解章义。既领会已应广分别。问何故作此论。答欲止他宗显己义故。谓或有执。过未是无而说现在是无为法。为遮彼执显过未有现非无为故作斯论。所以者何。若无过去未来者。应无有情成就彼法。及不成就如第二头。第三手。第六蕴。第十三处。第十九界等。无有成就不成就者。然有成就过去未来。及不成就故知实有。或复有执。成就非实有法。如譬喻者作如是论。诸有情类不离彼法。说名成就此无实体。但是观待分别假立。如五指合名之为拳。离即非拳故非实有。如是有情不离彼法说名成就。离即不成就故体非实有。问彼何故立此论耶。答依契经故。如契经说有转轮王成就七宝。若此成就是实有者。应成就他身及非有情数。谓彼轮王若成就轮宝神珠宝者则法坏。亦是有情数法。亦是非有情数法。若成就象宝马宝者则趣坏。亦是人趣亦傍生趣。若成就女宝者则身坏。亦是男身亦是女身。若成就主藏臣宝兵将宝者则业坏。亦是王亦是臣。勿有此过故成就非实有。为止彼宗显成就体是实有故而作斯论。若成就体非实有者便违经说。如说有学成就八支。漏尽阿罗汉成就十支。若成就非实者。彼圣者有漏心现前。及无心时便不成就三世圣道。云何成就八支十支。以支皆是无漏法故。又若成就非实有者。复违余经。如余经说。此补特伽罗成就善法及不善法。若成就非实有者。彼起善法时应不成就不善法。起不善法时应不成就善法。起无记法时应俱不成就。又若成就非实有者。复违余经。如说若苾刍成就七妙法者。于现法中多住喜乐。彼应成就一妙法或不成就。谓七妙法随一现前。时彼苾刍但成就一。以七妙法皆慧为性。尚无二慧俱起况当有七。若起余法现在前时则七妙法皆不成就。又若成就非实有者。复违余经。如说如来应正等觉成就十力。彼应但说成就一力。或不成就。谓若随起一力现前。余九离身便不成就。以十力皆慧为体。无二慧俱起故。若起余法现在前时。是则十力皆不成就。又若成就非实有者。复有余过异生应名离三界染。诸阿罗汉应名异生。谓诸异。生起善无覆无记心。及无心时身中现无烦恼。复不成就过去未来。岂不名为离三界染。诸阿罗汉起有漏心及无心时。现无圣道。复不成就过去未来。岂非异生无圣法故若尔便为大过。是故成就决定实有。问若成就是实有者。譬喻者所引经云何通。答彼说自在名为成就。谓转轮王于自七宝摄御自在。假说成就非如成就学八支等。或复有执。成就虽实有体。而不成就。无有实体。为遮彼执显不成就亦有实体故作斯论。若不成就无实体者。成就亦无实体。观不成就说成就故。如观夜立昼。观闇立明。皆实有体。此。亦如是。又不成就是成就近对治。更互相违。如贪无贪嗔无嗔痴无痴定乱等。若无实体何所相违成近对治。又不成就若无体者。应不施设断诸烦恼。谓圣道起断诸烦恼。非如以刀割物以石磨物但断系得证离系得令诸烦恼不成就起说名为断。故知实有不成就性。或复为欲断疑网故而作斯论。谓杂蕴说过去法生老住无常当言过去。乃至广说。勿有生疑。如相与法不异世。不异刹那。得与法亦尔。如得与法有异世有异刹那。相与法亦尔。为令此疑得决定故。明相与法定不异世。不异刹那。而得与法有同有异。谓三世法一一各有三世得故。问何故相与所相世及刹那决定无异。得与所得或同或异耶。答相与所相。必同一果。相随行不相离。无前后。于同聚法不能弃舍。得与所得不同一果。非定相随非不相离。或有前后。于同聚法或能弃舍。如诸树皮性离于树。是故为止他宗显于己义及令疑者得决定故。设不止他显己令疑决定。但于法相相应义中。应显所明故作斯论

诸得过去法彼得过去耶。此中得言欲何所显。谓获成就。云何知然。如施设论说。得云何谓获成就。获云何。谓得成就。成就云何。谓获得。得获成就声虽有别而义无异。所得法类有十一种。欲界有四。谓善不善。有覆无记。无覆无记。色界有三。除不善。无色界亦尔。及无漏法。欲界善不善无覆无记各具五蕴。有覆无记唯有四蕴。色界三各具五蕴。无色界三各唯四蕴。无漏法具五蕴。及择灭非择灭。除虚空无为非所得法故。此中欲界善不善色。若在过去有三世得。若在未来唯有未来得。若在现在有二世得。谓未来现在。善不善有覆无记四蕴。及无覆无记中。通果心俱生品四蕴。彼得世杂刹那杂。谓在过去未来现在。皆具三世得故。无覆无记一切色蕴异熟生四蕴。及威仪路。工巧处。多分四蕴彼得世不杂刹那不杂。若在过去得亦过去。若在未来得亦未来。若在现在得亦现在。威仪路四蕴中。善串习者如佛马胜。及余有情所善串习。并工巧处四蕴中善串习者。如佛妙业天子。及余有情所善串习。彼得亦皆世杂刹那杂。谓在三世各有三世得。故色界善五蕴有覆无记。及无覆无记中。通果心俱生品四蕴。彼得世杂刹那杂。谓在三世各有三世得故不定。善色蕴如欲界善不善色蕴。说一切有覆无记无覆无记色蕴。及威仪路异熟生四蕴。彼得世不杂刹那不杂。随在彼世。即唯有彼世得。故无色界善有覆无记四蕴彼得世杂刹那杂。谓在三世各有三世得故。异熟生四蕴彼得世不杂刹那不杂。随在彼世。即唯有彼世得故。无漏五蕴彼得。亦世杂刹那杂。谓在三世各有三世得故。此则总说。若别说者。诸未曾得无漏五蕴。及未曾得有漏修所成。并未曾得闻思所成。彼最初得。若在未来彼法唯有未来得。若在现在彼法则有未来现在得。若在过去彼法则有三世得。择灭非择灭法虽非三世摄而有三世得。然择灭得有二种。谓有漏无漏。有漏择灭得。由离欲界染乃至无所有处染故起。是世俗道类。若未离染彼灭唯有过去未来得。若已离染彼灭。即有三世得。无漏择灭得。由离三界见修所断染故起。是圣道类欲界见苦所断法择灭。若苦法智未现在前彼灭唯有未来得。若现在前彼灭则有未来现在得。若已灭。彼灭则有三世得。如是乃至有顶第九品法择灭。若尽智未现前等如理应知。非择灭得唯是有漏。彼最初得。若在未来彼灭唯有未来得。若在现在彼灭则有未来现在得若在过去彼灭则有三世得。此中初问答显一一世法有三世得。第二问答显一一世得得三世及离世法。是谓此处略毗婆沙

诸得过去法彼得过去耶。答彼得或过去。或未来。或现在。得过去法过去得者。谓过去三界一切诸蕴。及无漏蕴彼所有过去得。得过去法。未来得者。谓过去欲界善不善五蕴。有覆无记四蕴。无覆无记中通果心俱生品。及威仪路工巧处一分四蕴。色界善五蕴。有覆无记及无覆无记中。通果心俱生品四蕴。无色界善有覆无记四蕴。无漏五蕴彼所有未来得。得过去法。现在得者。谓过去欲界善不善五蕴。乃至广说。如未来彼所有现在得。设得过去彼得过去法耶。答彼法或过去。或未来。或现在。或无为过去得。得过去法者。谓过去得。得过去三界一切诸蕴。及无漏蕴。过去得。得未来法者。谓过去得。得未来欲界善不善有覆无记四蕴。无覆无记中通果心俱生品。及威仪路工巧处一分四蕴。色界善五蕴。有覆无记。及无覆无记中。通果心俱生品四蕴。无色界善有覆无记四蕴。无漏五蕴。过去得。得现在法者。谓过去得。得现在欲界善。乃至广如得未来说。过去得。得无为法者。谓过去得。得择灭非择灭

诸得未来法。彼得未来耶。答彼得或未来。或过去。或现在。得未来法。未来得者。谓未来三界一切诸蕴。及无漏蕴。彼所有未来得。得未来法。过去得者。谓未来欲界善不善有覆无记四蕴。无覆无记中。通果心俱生品。及威仪路工巧处一分四蕴。色界善五蕴。有覆无记及无覆无记中。通果心俱生品四蕴。无色界善有覆无记四蕴。无漏五蕴彼所有过去得。得未来法。现在得者。谓未来欲界善。乃至广说如过去。彼所有现在得。设得未来彼得未来法耶。答彼法或未来。或过去。或现在。或无为。未来得。得未来法者。谓未来得。得未来三界一切诸蕴及无漏蕴。未来得。得过去法者。谓未来得。得过去欲界善不善五蕴有覆无记四蕴。无覆无记中。通果心俱生品。及威仪路工巧处一分四蕴。色界善五蕴。有覆无记及无覆无记中。通果心俱生品四蕴。无色界善有覆无记四蕴。无漏五蕴。未来得。得现在法者。谓未来得。得现在欲界善。乃至广如得过去说。未来得。得无为者。谓未来得。得择灭非择灭。诸得现在法彼得现在耶。答彼得或现在。或过去。或未来。得现在法。现在得者。谓现在三界一切诸蕴。及无漏蕴彼所有现在得。得现在法。过去得者。谓现在欲界善不善有覆无记四蕴。无覆无记中。通果心俱生品。及威仪路工巧处一分四蕴。色界善五蕴。有覆无记及无覆无记中。通果心俱生品四蕴无色界善有覆无记四蕴。无漏五蕴。彼所有过去得。得现在法。未来得者。谓现在欲界善不善五蕴。有覆无记四蕴。余如过去得说。彼所有未来得。设得现在。彼得现在法耶。答彼法或现在。或过去或未来。或无为现在得。得现在法者。谓现在得。得现在三界一切诸蕴。及无漏蕴现在得。得过去法者。谓现在得。得过去欲界善不善五蕴有覆无记四蕴。无覆无记中。通果心俱生品。及威仪路工巧处一分四蕴。色界善五蕴。有覆无记。及无覆无记中。通果心俱生品四蕴。无色界善有覆无记四蕴。无漏五蕴现在得。得未来法者。谓现在得。得未来欲界善不善有覆无记四蕴。余如得过去说。现在得。得无为者。谓现在得得择灭非择灭。诸得善法彼得善耶。答如是以善法得必是善故。设得善彼得善法耶。答如是。以诸善得唯得善法故。不善无记问答亦尔。能得所得性必同故。诸得欲界法。彼得欲界耶。答如是。以欲界法得必是欲界故。设得欲界彼得欲界法耶。答彼法或欲界。或不系。欲界者。谓欲界五蕴。不系者谓诸非择灭。以生欲界补特伽罗。于三界系及不系法得非择灭。彼得皆是欲界系故。诸得色界法。彼得色界耶。答如是。以色界法得必是色界故。设得色界。彼得色界法耶。答彼法或色界或不系。色界者。谓色界五蕴。不系者。谓诸择灭非择灭。择灭者。谓欲界下三静虑五蕴择灭。彼世俗道类。得皆色界系。以下地择灭有漏得皆上地近分摄故非择灭者。谓生色界补特伽罗。于三界系及不系法得非择灭。彼得皆是色界系故。诸得无色界法。彼得无色界耶。答如是。以无色界法得皆是无色界系故。设得无色界彼得无色界法耶。答彼法或无色界或不系。无色界者。谓无色界四蕴。不系者。谓诸择灭非择灭。择灭者。谓第四静虑地系五蕴。及下三无色地系四蕴择灭。后世俗道类得皆无色界系。所以如前。非择灭者。谓生无色界补特伽罗。于三界系及不系法得非择灭。彼得皆是无色界系故。诸得学法彼得学耶。答如是。以学法得必是学故。设得学彼得学法耶。答彼法或学。或非学非无学学者谓学五蕴。非学非无学者。谓诸学得。所得择灭。诸得无学法彼得无学耶。答如是。以无学法得必是无学故。设得无学彼得无学法耶。答彼法或无学。或非学非无学。无学者。谓无学五蕴。非学非无学者。谓诸无学得所得择灭

诸得非学非无学法。彼得非学非无学耶。答彼得或非学非无学。或学或无学。非学非无学者。谓有漏五蕴四蕴。得一切非择灭。得诸择灭世俗道类。得学者。谓诸择灭。学道类。得无学者。谓诸择灭。无学道类得。设得非学非无学。彼得非学非无学法耶。答如是。以诸非学非无学得。唯得非学非无学法故。诸得见所断法。彼得见所断耶。答如是。以见所断法得必是见所断故。设得见所断彼得见所断法耶。答如是。以见所断得。唯得见所断法故。诸得修所断法。彼得修所断耶。答如是。以修所断法得必是修所断故。设得修所断。彼得修所断法耶。答彼法或修所断。或不断。修所断者。谓修所断五蕴。不断者谓一切非择灭。及世俗道类所得择灭。诸得不断法。彼得不断耶。答彼得或不断。或修所断。不断者。谓无漏五蕴得。及诸择灭无漏道类得。修所断者。谓一切非择灭得。及诸择灭世俗道类得。设得不断。彼得不断法耶。答如是。以不断得唯得不断法故。已随本文辩诸得相。当更随义显诸非得。若法有得。彼法有非得。若法无得。彼法无非得。获成就非获非成就说亦尔。由此一切有情数法。及择灭非择灭。有得非得有获非获。有成就非成就。一切非有情数法。及虚空无为。则皆无有得非得等。又于自相续法。有得。有非得等。于他相续法。无得非得等。此中过去未来法。各有三世非得。现在法唯有过未二世非得。以可成就法在现在世必成就故。得与非得更互相违不俱起故。善不善无记法非得。皆唯无记。三界法非得皆通三界。学无学非学非无学法非得。皆唯非学非无学。见所断修所断不断法非得。皆唯修所断。是谓非得略毗婆沙诸不得过去法。彼非得过去耶。答彼非得或过去。或未来。或现在。不得过去法。过去非得者。谓过去善不善有覆无记。无覆无记。无漏五蕴。彼所有过去非得。此中断善根者。善五蕴离欲染者。不善五蕴。诸阿罗汉有覆无记五蕴。一切有情多分无覆无记五蕴。以无覆无记法。已过刹那及未至刹那。多分不成就故。诸异生类无漏五蕴。是谓总相所不得法。不得过去法未来非得者。谓过去善不善有覆无记无覆无记无漏五蕴。彼所有未来非得。如前释。不得过去法现在非得者。谓过去善不善有覆无记无覆无记。无漏五蕴。彼所有现在非得。随所应如前释。设非得过去彼不得过去法耶。答彼法或过去。或未来。或现在。或无为。过去非得。不得过去法者。谓过去非得不得过去善乃至无漏五蕴。如前释。过去非得不得未来法者。谓过去非得不得未来善。乃至无漏五蕴。如前释。过去非得不得现在法者。谓过去非得不得现在善乃至无漏五蕴。如前释。过去非得不得无为法者。谓过去非得不得择灭非择灭法。谓具缚者。于择灭。一切有情于非择灭。诸不得未来法。彼非得未来耶。答彼非得。或未来。或过去。或现在。不得未来法。未来非得者。谓未来善乃至无漏五蕴。彼所有未来非得。如前释。不得未来法过去非得者。谓未来善乃至无漏五蕴。彼所有过去非得。如前释。不得未来法现在非得者。谓未来善乃至无漏五蕴。彼所有现在非得。如前释。设非得未来。彼不得未来法耶。答彼法或未来。或过去。或现在。或无为。未来非得。不得未来法者。谓未来非得。不得未来善。乃至无漏五蕴。如前释。未来非得。不得过去法者。谓未来非得。不得过去善乃至无漏五蕴。如前释。未来非得。不得现在法者。谓未来非得。不得现在善乃至无漏五蕴。如前释。未来非得。不得无为法者。谓未来非得。不得择灭非择灭。如前释。诸不得现在法。彼非得现在耶。答彼非得或过去。或未来。非现在相违故。不得现在法。过去非得者。谓现在善乃至无漏五蕴。彼所有过去非得。如前释。不得现在法。未来非得者。谓现在善乃至无漏五蕴。彼所有未来非得。如前释。设非得现在。彼不得现在法耶。答彼法或过去。或未来。或无为。非现在相违故。现在非得。不得过去法者。谓现在非得。不得过去善乃至无漏五蕴。随所应。如前释。现在非得。不得未来法者。谓现在非得。不得未来善乃至无漏五蕴。如前释。现在非得不得无为法者。谓现在非得。不得择灭非择灭。如前释

诸不得善法。彼非得善耶。答不尔。以彼非得是无记非善性故。设非得无记。彼不得善法耶。答彼法或善或不善。或无记。以无记非得不得三性法故。诸不得不善法。彼非得不善耶。答不尔。以彼非得是无记非不善性故。设非得无记。彼不得不善法耶。答彼法。或善或不善。或无记。以无记非得不得三性法故。诸不得无记法。彼非得无记耶。答如是。以诸非得唯无记故。设非得无记彼不得无记法耶。答彼法。或善。或不善。或无记。以无记非得不得三性法故。诸不得欲界法。彼非得欲界耶。答彼非得或欲界。或色界。或无色界。不得欲界法。欲界非得者。谓生欲界。欲界诸蕴非得。不得欲界法。色界非得者。谓生色界欲界诸蕴非得。不得欲界法无色界非得者。谓生无色界。欲界诸蕴非得。设非得欲界。彼不得欲界法耶。答彼法或欲界。或色界或无色界。或不系。欲界非得。不得欲界法者。谓生欲界不得欲界诸蕴。欲界非得。不得色界法者。谓生欲界不得色界诸蕴。欲界非得。不得无色界法者。谓生欲界不得无色界诸蕴。欲界非得。不得不系法者。谓生欲界不得无漏诸蕴。及择灭非择灭。诸不得色界法彼非得色界耶。答彼非得。或欲界。或色界。或无色界。不得色界法。欲界非得者。谓生欲界色界诸蕴非得。不得色界法。色界非得者。谓生色界色界诸蕴非得。不得色界法。无色界非得者。谓生无色界色界诸蕴非得。设非得色界。彼不得色界法耶。答彼法或欲界。或色界。或无色界。或不系。色界非得不得欲界法者。谓生色界不得欲界诸蕴。色界非得。不得色界法者。谓生色界不得色界诸蕴。色界非得。不得无色界法者。谓生色界不得无色界诸蕴。色界非得。不得不系法者。谓生色界不得无漏诸蕴。及择灭非择灭。诸不得无色界法。彼非得无色界耶。答彼非得或欲界。或色界。或无色界。不得无色界法。欲界非得者。谓生欲界无色界诸蕴非得。不得无色界法。色界非得者。谓生色界无色界诸蕴非得。不得无色界法。无色界非得者。谓生无色界无色界诸蕴非得。设非得无色界。彼不得无色界法耶。答彼法或欲界。或色界。或无色界。或不系。无色界非得。不得欲界法者。谓生无色界。不得欲界诸蕴。无色界非得。不得色界法者。谓生无色界。不得色界诸蕴。无色界非得。不得无色界法者。谓生无色界。不得无色界诸蕴。无色界非得。不得不系法者。谓生无色界。不得无漏诸蕴。及择灭非择灭。诸不得学法。彼非得学耶。答不尔。以彼非得是非学非无学非是学故。设非得非学非无学。彼不得学法耶。答彼法或学。或无学或非学非无学。以非学非无学非得不得三种法故。诸不得无学法。彼非得无学耶。答不尔。以彼非得是非学非无学非是无学故。设非得非学非无学。彼不得无学法耶。答彼法或学。或无学。或非学非无学。以非学非无学非得不得三种法故。诸不得非学非无学法。彼非得非学非无学耶。答如是。以诸非得唯是非学非无学故。设非得非学非无学。彼不得非学非无学法耶。答彼法或学。或无学。或非学非无学。以非学非无学非得不得三种法故。诸不得见所断法。彼非得见所断耶。答不尔。以彼非得是修所断非见所断故。设非得修所断。彼不得见所断法耶。答彼法或见所断。或修所断。或不断。以修所断非得不得三种法故。诸不得修所断法。彼非得修所断耶。答如是。以诸非得唯修所断故。设非得修所断。彼不得修所断法耶。答彼法或见所断。或修所断。或不断。以修所断非得不得三种法故。诸不得不断法。彼非得不断耶。答不尔以彼非得是修所断非不断故。设非得修所断。彼不得不断法耶。答彼法或见所断。或修所断。或不断。以修所断非得不得三种法故

说一切有部发智大毗婆沙论卷第一百五十七阿毗达磨大毗婆沙论卷第一百五十八

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    定蕴第七中得纳息第一之二

问得非得何差别。答名即差别。谓名得。名非得。复次得有漏无漏。非得唯有漏。复次得善不善无记。非得唯无记。复次得三界系及不系。非得唯三界系。复次得学无学非学非无学。非得唯非学非无学。复次得见所断。修所断。不断。非得唯修所断。复次得染污不染污。非得唯不染污。复次得异熟非异熟。非得唯非异熟。复次得有异熟无异熟。非得唯无异熟。复次得与所得。法或俱起。或不俱起。非得与所不得法必不俱起。复次得苦集道三谛摄。非得唯苦集谛摄。以如是等门。应知得非得差别

问何故得与所得法性类。或同或异耶。答得有三种。一有为法得。二择灭得。三非择灭得。有为法得。随所得法性类差别。以有为法能有作用引自得故。择灭得随能证道性类差别。以诸择灭自无作用。但由道力求证。彼时引彼得故。非择灭得。随自所依性类差别。以非择灭自无作用。非道所求。彼得但依命根众同分而现前故。问非得随何性类差别。答彼定不随所不得法以相违故。又不随道非道所求故。但依命根众同分转故。随所依性类差别。问若诸非得非择灭得。俱随所依性类差别者。所依或异熟。或唯等流。此二随何性类差别。答随等流性以义遍故。异熟非遍故不随立。问非得若随所不得法。性类差别有何过耶。答断善根者应成就善。已离欲染者应成就不善。诸无学者应成就染。异生应成就三乘无漏法。退果应成果。舍向应成向。二灭非得应是无为。由此等过。非得不可随所不得性类有异

问所说得为更有得为无耶。若更有得者得传有得。何非无穷。若更无得者。此得由何可说成就。答应说得。复有得。问若尔应成无穷。答无穷亦无有过。由此生死难断。难越。或无量得皆一刹那俱生。而灭无无穷过。如是说者。一刹那中但有三法。一彼法。二得。三得得。由得故成就彼法及得得。由得得故成就得。由更互相得故非无穷。是故说色蕴行蕴一得得。乃至识蕴行蕴一得得。有为无为一得得。问为一一法各别有得。为不尔耶。或有说者。俱有法同一得得。问若尔不应作如是说。色蕴行蕴一得得等。答欲显法与得得。无异得故作如是说。然实不无五蕴四蕴一得得义。有说。一一法各别得得。唯除得得。与彼法同一得得。问若尔便有无穷过失。以得皆有生住异灭。生等复有得与得得。彼得得得复有生等。如是展转成无穷故。答无穷复有何过。由此生死难断难越。或此诸法皆一刹那俱生而灭无无穷过。如是说者。法与生等同一得得。相与所相极亲近故。由此善通色蕴行蕴一得得等。又去如前无穷过失。如说得如是非得与得相违。应随广说。然无同时非得非得。有情数法现在前时必与得俱。是故非得起时决定不与非得非得及彼法俱起。由此三法互相违故。异时说有此则不遮

问过去未来得。为成就。为不成就。若成就者。则为无穷。谓一刹那三法俱起。一法。二得。三得得。此三灭位有六得生。谓三得。三得得。此六灭位十二得起。谓六得六得得。十二灭位。二十四得起。谓二十得十二得得。如是展转无始时来。乃至后际念念倍起其得无限。邻次刹那倍增尚尔况于隔越前前刹那诸得倍增。是故展转有无穷过。若不成就便与此蕴后说相违。如说从无色界殁生欲界时。所得蕴界处。大种。善根。不善根。无记根。结缚随眠。随烦恼缠。当言曾得得未曾得得。答善染污法当言曾得得。异熟法当言未曾得得。如此则非不成就。以得亦有善染污故。答应作是说。过去未来得有成就者。以善及染污法等有三世得故。问若尔岂非无穷。答无穷复有何过。由此生死难断难越。或彼诸得一刹那生无无穷过。又此诸得但可言多。而非无穷犹有分限故。有余师说。无有成就过去未来得者。是故无无穷过。问此蕴后说当云何通。答此蕴后文说所得法。非能得得。斯有何咎。如是说者。应如初说得如所得应成就故。又以得故名沙门果。若过未得不成就者。诸沙门果应刹那舍刹那得。然无是事。又诸圣道有三时舍。谓退时。得果时。练根时。若过未得不成就者。则圣道应刹那刹那舍。非谓三时欲令无如是过。故有成就过未诸得。若成就所得法亦成就彼得。若所得法舍彼得亦舍。以法与得舍得同故。然得总有四种。一在彼法前。二在彼法后。三与彼法俱。四非彼法前后及俱。若所得法则有六种。一有所得法唯有俱得。如异熟生等。二有所得法唯有前得。如三类智边世俗智等。有说。此等亦有俱得。三有所得法唯有俱得后得。如别解脱戒等。四有所得法唯有俱得前得。如道类智忍等。五有所得法具有前后俱得。如所余善染污等。六有所得法不可说有前后俱得。而有诸得。谓择灭非择灭。必无有法唯有法后得者。现在前时必有得故。一切非得总有三种。一在彼法前。二在彼法后三非彼法前后及俱。所不得法亦有三种。一有所不得法。唯有彼前非得谓未来情数毕竟不生法。及入无余涅槃最后刹那心等。二有所不得法。通有彼前彼后非得。谓余随应有情数法。三有所不得法。无彼前后及俱非得而有非得。谓择灭非择灭。必无非得可与法俱。以法现在前时。是所得者必有得故。非所得者。无得无非得故。亦无唯有彼后非得。非无始来恒成就彼。未舍必起彼类尽故。然诸非得性羸劣故。唯成就现在。一一刹那得已即舍。于未得彼法及已舍位。恒有此非得。应知。见道所起得有十五类。即十五心时俱起诸得。见道灭位与自所起诸得俱灭。如日没时与自所起光明俱没。然苦法智忍有十五得。苦法智有十四得。乃至道类智忍但有一得。问见道得为但有尔所。为更有余。有说。但有尔所。有说。更有余。未来世不生诸得而不可说。此不应理。宁当说无。不应言有而不可说。如是说者。更有余未来得。苦法智忍一得俱生。忍得相望互无因义。苦法智三得俱生。二道得。一离系得。二道得者。谓苦法智忍得。苦法智得。一离系得者。谓欲界见苦所断十系得灭。十离系得起。苦法智与彼三得互不为因。苦法智忍与彼三得皆有因义。苦类智忍四得俱生。三道得一离系得。苦类智忍与彼四得互不为因。苦法智忍为四得因。苦法智为三得因。除苦法智忍得。以加行善法胜非劣因故。有为法得随法胜劣故。苦类智六得俱生。四道得。二离系得。苦类智与彼六得互不为因苦法智忍为六得因。苦法智为五得因。除苦法智忍得。以彼劣故。苦类智忍为三得因。除前三得以彼劣故。问不与前二道得作因。是事可尔彼所得劣故。不与前离系得作因。云何可尔。彼所得最胜故。答有为法得随所得法胜劣彼所引故。无为法得随道胜劣道所引故。彼道劣故彼得非因。如是乃至道类智忍二十二得俱生。十五道得。七离系得。道类智忍与彼诸得互不为因。苦法智忍皆与二十二得作因。苦法智与二十一得作因。除苦法智忍得乃至道法智。但与三得作因。谓二道得。一离系得。非前十九得因以彼劣故。由此故说颇有前生无漏法。非后生无漏法因耶。答有。谓胜于劣

苦法智忍现在前时。修未来无量苦法智忍。此现在忍与所修为因。彼是此果。有说。此现在忍非所修为因彼非此果。以彼竟无一刹那现在前故。评曰。应说此为彼因彼是此果。一相续摄非劣道故。如是乃至金刚喻定现在前时。修未来无量金刚喻定。此现在定与所修为因彼是此果。有说。此现在定非所修因彼非此果。以彼竟无一刹那现在前故。评曰。应说此为彼因彼是此果。一相续摄非劣道故。已生苦法智忍。与不生苦法智忍为因。亦与苦法智等一切学无学道为因。已生苦法智与不生苦法智为因。亦与苦类智忍等。一切学无学道为因。不与苦法智忍为因。如是乃至已生尽智。与未生尽智为因。亦与后已生未生一切无学道为因。不与一切学道为因。由此故说颇有已生无漏法。非未生无漏法因耶。答有。谓已生苦法智。非未生苦法智忍因。乃至已生尽智。非未生金刚喻定因。胜道不与劣道为因故

苦集谛是有漏彼诸得亦有漏。灭谛是无漏。彼诸得或有漏。或无漏道谛是无漏。彼诸得亦无漏。又苦集谛是善不善无记彼诸得亦尔。灭谛道谛是善。彼诸得亦是善。又苦集谛是三界系。彼诸得亦尔。灭谛是不系。彼诸得或色界系。或无色界系。或不系。道谛是不系。彼诸得亦不系。又苦集谛是非学非无学。彼诸得亦尔。灭谛是非学非无学。彼诸得或学或无学。或非学非无学。道谛是学无学。彼诸得亦尔。又苦集谛是见所断修所断。彼诸得亦尔。灭谛是不断。彼诸得或修所断。或不断。道谛是不断。彼诸得亦不断。又苦集谛是染污不染污。彼诸得亦尔。灭谛道谛是不染污。彼诸得亦尔。又苦集谛是有异熟。无异熟。彼诸得亦尔。灭谛是无异熟。彼诸得或有异熟或无异熟。道谛是无异熟。彼诸得亦尔。又苦集谛是苦集谛摄。彼诸得亦尔。灭谛是灭谛摄。彼诸得是苦集道三谛摄道谛是道谛摄。彼诸得亦尔。所得四谛与能得得。有如是等诸门同异

问何地所系法。有几种离系得。答欲界乃至无所有处。见修所断法皆有三种离系得。谓学无学非学非无学。非想非非想处见所断法。及前八品修所断法。皆有二种离系得。谓学无学。彼第九品修所断法。唯有一种离系得。谓无学。无学初心方初起故。问何地所系法。有几地无漏离系得。或有说者。诸离系得随断对治。彼作是说。欲界见修所断法无漏离系得。未至定摄。初静虑见修所断法。无漏离系得三地摄。第二静虑见修所断法。无漏离系得四地摄。第三静虑见修所断法。无漏离系得五地摄。第四静虑见修所断法。及无色界见所断法。无漏离系得六地摄。空无边处修所断法。无漏离系得七地摄。识无边处修所断法。无漏离系得八地摄。无所有处非想非非想处。无漏离系得九地摄。复有说者。诸离系得随坏对治。彼作是说。欲色界见修所断法。无漏离系得皆六地摄。空无边处见修所断法。无漏离系得七地摄。识无边处见修所断法。无漏离系得八地摄。无所有处非想非非想处。见修所断法。无漏离系得九地摄。有作是说。若地有法智品道。彼地有欲界见修所断法无漏离系得。若地有类智品道彼地有色无色界。见修所断法无漏离系得。彼作是说。欲界见修所断法。无漏离系得六地摄。色无色界见修所断法。无漏离系得九地摄。评曰。此中初说为善。诸离系得必由断对治力所引起故。问若以灭道法智离色无色界修所断染时。彼色无色界修所断法。无漏离系得。为法智品摄。为类智品摄耶。若法智品摄此不应理。彼法及断类智所知故。若类智品摄亦不应理。彼断及得法智所证故。有作是说。彼离系得类智品摄。问岂不彼断及得法智所证耶。答虽法智所证而类智摄。类智所知故。有余师说彼无漏离系得法智品摄。问岂不彼法及断类智所知耶。答虽类智所知而法智摄。法智所证故。评曰。此中初说为善。以类智品是彼不共决定对治故。问圣者以世俗道离诸地染时。为是曾得道未曾得道耶。有作是说。是曾得道。由此道无始时来。串习曾得今现前故。彼作是说。圣者以世俗道。离欲界修所断上上品染时。于欲界修所断上上品法。得二种离系得。一世俗得。二无漏得。世俗得是曾得。道类无漏得是圣道类。以世俗道现在前时。亦修未来无漏道故。于欲界见所断上上品法。得一种离系得。谓世俗得是曾得道类不得。无漏得先已得故。问若尔云何共对治道。转成不共对治。谓此曾得道。先时总以欲界见修所断诸法为九品断。今时此道唯断欲界修所断故。答此道犹名共对治道。以此恒有俱断力故。此见所断先已断故。今无可断非不能断。是故恒名共对治道。如离上上品。乃至离下下品亦尔。如离欲界修所断。乃至离无所有处修所断亦尔。有余师说。是未曾得道。由此道无始时来。未习未得唯圣所起故。彼作是说。圣者以世俗道。离欲界修所断上上品染时。于欲界修所断上上品法。得二种离系得。一世俗得。二无漏得。世俗得是未曾得。道类无漏得是圣道类。以世俗道现在前时。亦修未来无漏道故。于欲界见所断上上品法。不得离系得。不得世俗得者未曾得道非彼对治故。不得无漏得者先已得故如离上上品乃至离下中品亦尔。如离欲界修所断八品。离初静虑修所断八品。乃至离无所有处修所断八品亦尔。离欲界修所断。第九品解脱道时。未来修曾得未曾得二世俗道。尔时于欲界修所断法。得三种离系得。一世俗曾得得。谓曾得道类。二世俗未曾得得谓未曾得道类。三无漏得。谓圣道类于欲界见所断法。得二种离系得。除未曾得世俗得。问云何知第九解脱时。能修未来曾得未曾得二世俗道。答以说若成就现在他心智。彼定成就过去他心智故。问何故离前八品染时。修未曾得道。离第九品染解脱道时。修曾得未曾得道耶。答离染道异得地亦异。谓离染道唯未曾得。未来所修亦未曾得。若得地时现离染道虽未曾得得根本地故。通修未来曾得未曾得道。如离欲界修所断第九品。乃至离无所有处修所断第九品亦尔。评曰。应作是说。圣者以世俗道离诸地染时。应言是未曾得道。昔来未得唯圣所起故。然于未来通修曾得未曾得道。所对治同故。应作是说。圣者以世俗道。离欲界修所断上上品染时。于欲界修所断上上品法。得三种离系得。一世俗曾得得。谓曾得道类。二世俗未曾得得。谓未曾得道类。三无漏得。谓圣道类。于欲界见所断上上品法。得一种离系得。谓曾得世俗道类。不得未曾得得者。未曾得道非彼对治故。不得无漏得者。先已得故。如离上上品。乃至离下下品亦尔。如离欲界修所断。乃至离无所有处修所断亦尔。由此故说颇有不退。不得果。不转根。非见道现在前。亦非异生类。而于见所断法得离系得耶。答有。谓前所说。唯除离欲染第六九品时

依所说义应作是说颇有离系得。得而不舍。舍而不得耶。答应作四句。有离系得。得而不舍。谓诸异生离欲界。乃至无所有处染时。及诸圣者非得果离染时。有离系得舍而不得。谓诸异生从离欲界乃至无所有处染退时。及诸圣者非失果退时。若从欲界殁生第二静虑以上时。从初静虑殁生第二静虑以上时。乃至从无所有处殁生非想非非想处时。从色无色界诸地殁生欲界时。有离系得亦得亦舍。谓进得四沙门果时。信胜解练根成见至时。退法种性阿罗汉等。练根成思法等时。从离染或种性退。若三若四沙门果时。若色无色界上地殁生下地时。有离系得非得非舍。谓除前相。问若先离欲界五品染。后入正性离生。苦法智生时。于先所断见苦所断五品法。及今所断见苦所断四品法。皆得无漏离系得乃至道法智生时。于先所断见道所断五品法。及今所断见道所断四品法。皆得无漏离系得。道类智生时。于三界见所断法皆得无漏离系得。彼先所断欲界修所断五品法。无漏离系得何时当得。尊者僧伽筏苏作如是说。道类智时得。以尔时名预流果。亦名一来向故。彼说不然。所以者何。以于尔时得预流果于一来果向道乃至未起一刹那现前。如何可说为一来向。有作是说。起一来果加行道时得。以是一来向所摄故。有余师说。得一来果时得。以住第六无间道时。能引三界见所断。及欲界修所断前六品法。无漏离系得。令起得一来果故。如是说者。从预流果决定起胜进道。彼现前时得。以从下果起趣上胜进道时。必修先所断上位诸结对治道故。问颇有一刹那顷于无漏离系得有身作证。而慧不见有慧见而身不作证乃至作四句耶。答有。谓道类智忍灭。道类智生时。应作四句。有无漏离系得。身作证而慧不见。谓欲界见所断法无漏离系得。有无漏离系得。慧见而身不作证。谓色无色界修所断法无漏离系得。有无漏离系得。身作证慧亦见。谓色无色界见所断法无漏离系得。有无漏离系得。身不作证慧亦不见。谓欲界修所断法无漏离系得。问颇有一刹那顷于信等五根。得而不舍舍而不得。乃至作四句耶。答有。谓圣者离欲界染。住最后无间道时。应作四句。得而不舍者。谓三地世俗道。二地无漏道所摄信等五根。舍而不得者。谓欲界恶作忧根俱生信等五根。亦得亦舍者。谓未至地无漏道所摄信等五根。舍无间道所摄。得解脱道所摄。非得非舍者。谓除前相。问若法过去彼得过去耶。设得过去彼法过去耶。答应作四句。有法过去。彼得非过去。谓过去有情数法。彼得在未来现在。有得过去。彼法非过去。谓过去得得未来现在有情数法。及择灭非择灭。有法过去。彼得亦过去。谓过去有情数法。彼得在过去。有法非过去。彼得亦非过去。谓未来现在得得未来现在有情数法。及择灭非择灭。如过去作四句。未来现在各作四句。如理应知。问若法在过去。彼法有过去得耶。设法有过去得。彼法在过去耶。答应作四句。有法在过去。彼法无过去得。谓过去非有情数法。有法有过去得。彼法不在过去。谓择灭非择灭。及未来现在有情数法。有过去得。有法在过去。彼法亦有过去得。谓过去有情数法。有法非在过去。彼法亦非有过去得。谓未来现在非有情数法。及虚空无为并未来现在有情数法。及择灭非择灭无过去得。如过去作四句。未来现在各作四句。如理应知。问若法不在过去。彼法无过去得耶。设法无过去得。彼法不在过去耶。答应作四句。前第二句作此第一句。前第一句作此第二句。前第四句作此第三句。前第三句作此第四句。如前应知如过去作四句未来现在各作四句。如理应知。问若法有得彼法有离系得耶。设法有离系得。彼法有得耶。答应作四句。有法有得彼法非有离系得。谓无漏有为法。及择灭非择灭。有法有离系得。彼法非有得。谓非有情数法。有法有得彼法亦有离系得。谓有漏有情数法。有法非有得。彼法亦非有离系得。谓虚空无为。问若法无得彼法无离系得耶。设法无离系得。彼法无得耶。答应作四句。前第二句作此第一句。前第一句作此第二句前第四句作此第三句。前第三句作此第四句。如前应知

问若法应修彼法得应修耶。设法得应修彼法应修耶。答若法应修彼法得亦应修。有法得应修。彼法非应修。谓择灭。问若法应断。彼法得应断耶。设法得应断。彼法应断耶。答若法应断彼法得亦应断有法得应断。彼法非应断谓择灭。一分。及非择灭。问若法应厌。彼法得应厌耶。设法得应厌。彼法应厌耶。答若法应厌。彼法得亦应厌。有法得应厌。彼法非应厌。谓择灭一分。及非择灭。问何故诸得随所得法。成善等性而不成色等耶。答善等是诸法性类。诸法性类可相随转。色等是诸法自体。诸法自体无相随义。有说。善等是共相可随而转。色等是自相无相随义。问何故诸得随所得法定是善等。不随所得法定是过去等耶。答所得诸法行世不定故。能得得世亦不定。所得诸法善等性定故。能得得善等亦定。问诸得几识所识。几智所知。几随眠之所随增耶。答诸得一识所识。谓意识法界法处行蕴摄故。八智所知除灭智。他心智以是有为不相应故。三界五部有漏缘随眠之所随增。以于得中无相应随增故。问诸非得几识所识。几智所知。几随眠之所随增耶。答诸非得一识所识。谓意识。亦法界法处行蕴摄故。七智所知。除灭智道智他心智。以是有漏不相应故。三界修所断。及诸遍行随眠之所随增。以非得唯修所断故。问颇有舍得而不得非得耶。答有。谓入无余涅槃时。舍诸法得而不得非得所依断故。问颇有诸法先起非得。一得以去更不起非得耶。答有。谓诸非择灭。及无生智等。一得以去乃至无余涅槃前恒成就故。问颇有诸法本来有得无非得耶。有说无。以有得者必有非得故。有说。有。如三类智边世俗智等。非择灭法本来有得无有非得。以彼本来定不生故。问如有一得能得彼法及得得亦有一非得能舍彼法及非得非得耶。答无。以非得同时无非得非得故。以现在非得必成就故。问颇有法无得无非得。彼法灭有得有非得耶。答有。谓一切非有情数法

说一切有部发智大毗婆沙论卷第一百五十八阿毗达磨大毗婆沙论卷第一百五十九

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    定蕴第七中得纳息第一之三

诸法善无色起。彼法善心俱耶。乃至广说问何故作此论。答欲止说无相应法无生老住灭无退者意。及欲显说自宗正理相应法故而作斯论。问何故此中唯问无色起不问色耶。答彼作论者意欲尔故。随彼意欲而作此论。但不违法相便不应责。有说。若法一切界。一切地。一切部。一切心中可得者。此中问之。色法非一切界。乃至非一切心中可得故。此不问。有说。若法多分是心俱有。由心力生随心而转。此中则问。色法多分非心俱有。非心力生。非随心转。如苦法智忍时有九十八随眠得起。然彼诸得非忍俱有。非忍力生。非随忍转。虽与忍俱同无色法尚不说。彼与忍心俱。况诸色法是故不问。此中所说无色法起善等心俱者。要是彼心势力所引。诸无色法

诸法善无色起。彼法善心俱耶。答诸法善无色起。彼法或善心俱。或不善心俱。或无记心俱。云何善心俱。答诸法彼心相应。彼心俱有。善无色彼心相应。善无色者。谓善心所法。彼心俱有。善无色者。谓彼法生老住无常。此中亦有同类得起略故不说彼应准知。云何不善心俱。答如不善心。若退若生。善法得起不善心退善得起者。谓诸圣者已离欲染。若起欲界下下下中二品缠退时。彼心与一来果及胜果道。并善恶作忧根俱生品四蕴诸得俱起。若起下上品缠退时。犹能护加行者。彼心亦与如前善得俱起。其有不能护加行者。除一来胜果道。彼心与余如前善得俱起。问此中云何名护加行不护加行耶。答令于修断彼加行有能护烦恼势力现在前时。有不能护故。若起中下乃至上中五品缠退时。彼心与预流果。及胜果道。并善恶作忧根俱生品四蕴诸得俱起。若起上上品缠退时。犹能护加行者。彼心亦与如前善得俱起。其有不能护加行者。除预流胜果道。彼心与余如前善得俱起。若一来者前六品缠随起何退。除善恶作忧根俱生品得。彼心随其所应与余如前善得俱起。若诸异生已离欲染。随起何品不善缠退时。彼心与善恶作忧根俱生品四蕴诸得俱起。不善心生善得起者。谓从色无色界殁生欲界。以不善心结生时。彼心与欲界生得善四蕴诸得俱起。有说。彼心亦有与一分闻思所成四蕴诸得俱起。云何无记心俱。答如无记心若退若生。善法得起。无记心退善得起者。谓阿罗汉退胜根住劣根时。彼无记心与劣根品善得俱起。学退胜种性。住劣种性亦尔若阿罗汉起非想非非想处缠退时。彼心与不还果及胜果道。并非想非非想处顺退分诸得俱起。如是乃至起初静虑后八品缠退时。彼心与不还果。及胜果道。并初静虑顺退分诸得俱起。若起初静虑上上品缠退时。犹能护加行者。彼心亦与如前善得俱起。其有不能护加行者。除不还胜果道。彼心与余如前善得俱起。若不还者及诸异生。已离无所有处染。起无所有处缠退时。彼心与无所有处顺退分诸得俱起。如是乃至起初静虑缠退时。彼心与初静虑顺退分诸得俱起。如已离无所有处染。若已离识处染。乃至已离初静虑染应知亦尔。若诸异生已离欲染。起欲界有身见边执见缠退时。彼心与善恶作忧根俱生品四蕴诸得俱起。无记心生善得起者。谓无色界上地殁生下地时。彼心与彼地善四蕴诸得俱起。若从无色界。及上静虑地殁。生下诸静虑地时。彼心与彼地善五蕴诸得俱起。若从色无色界殁生欲界。以有身见边执见结生时。彼心与欲界生得善四蕴诸得俱起。有说。彼心亦有与一分闻思所成诸得俱起。若从欲界殁生上二界。及上二界下地殁生上地时。彼心与彼地生得善四蕴诸得。俱起

设法善心俱起。彼法善无色耶。答诸法善心俱起。彼法或善无。色或无记无色。云何善无色。答诸法彼心相应。彼心俱有善无色。义如前释。云何无记无色。答如善心胜进。无记法得起。及住善心无记诸根长养大种增益。彼法得生老住无常。善心胜进无记得起者。谓离欲染第九无间道灭。解脱道起时。彼心与初静虑果。无记通果心品诸得俱起。乃至离第三静虑染。第九无间道灭。解脱道起时。彼心与第四静虑果。无记通果心品诸得俱起。金刚喻定灭。尽智起时。彼心与随所应静虑果。无记通果心品诸得俱起。已离欲染。信胜解练根作见至加行道时。有说。及解脱道时。彼心与随所应静虑果。无记通果心品诸得俱起。时解脱阿罗汉练根作不动。依未至定乃至第四静虑。加行道时彼心与随所应静虑果。无记通果心品诸得俱起及依一切地第九解脱道时。彼心与四静虑果。无记通果心品诸得俱起。引发五通诸加行道五无间道。三解脱道时。杂修静虑初后无间解脱道时。起四无量。初三解脱。八胜处。前八遍处时。起无碍解。及依未至定。乃至第四静虑增长时起无诤愿智边际定。及增长时依未至定乃至第四静虑起空空无愿无愿无相无相等诸功德及增长时彼心与随所应静虑果。无记通果心品诸得俱起。及住善心乃至彼法得生老住无常者。谓生欲色界善心流注久相续起时。诸根大种长养增益彼心。与彼得四相俱起。诸根长养大种增益。问答解释如大种蕴

诸法不善无色起彼法不善心俱耶。答诸法不善无色起。彼法或不善心俱。或无记心俱。云何不善心俱。答诸法彼心相应。彼心俱有不善无。色义如前释。云何无记心俱。答如无记心若退若生不善法得起无记心退不善得起者。谓诸异生已离欲染。起欲界有身见边执见缠退时。彼心与见修所断。不善四蕴诸得俱起。无记心生不善得起者。谓从色无色界殁生欲界。以有身见边执见结生时。彼心与见修所断不善四蕴诸得俱起。设法不善心俱起。彼法不善无色耶。答诸法不善心俱起。彼法或不善无色。或善无色。或无记无色。云何不善无色。答诸法彼心相应。彼心俱有不善无色。义如前释。云何善无色。答如不善心若退若生善法得起。此如前善无色起不善心俱释。云何无记无色。答如不善心若退若生。无记法得起及住不善心无记诸根长养大种增益。彼法得生老住无常。不善心退无记得起者。谓阿罗汉起欲界缠退时。彼心与上八地修所断无记四蕴诸得俱起。诸不还者。若已离无所有处染。起欲界缠退时。彼心与七地修所断无记四蕴诸得俱起。乃至若已离初静虑染。未离第二静虑染。起欲界缠退时。彼心与一地修所断无记四蕴诸得俱起。诸异生类若已离无所有处染。起不善缠退时。彼心与七地见修所断。及欲界见所断。无记四蕴诸得俱起。乃至若已离初静虑染。未离第二静虑染。起不善缠退时。彼心与一地见修所断。及欲界见所断。无记四蕴诸得俱起。若已离欲界染。未离初静虑染。起不善缠退时。彼心与欲界见所断无记四蕴诸得俱起。不善心生无记得起者。谓非想非非想处殁生欲界。以不善心结生时彼心与七地见修所断。及欲界见所断无记四蕴。修所断无记色行二蕴诸得俱起。有说。亦与欲界修所断。无记心心所诸得俱起。谓善串习威仪路工巧处四蕴。乃至初静虑殁生欲界。以不善心结生时。彼心与欲界见所断无记四蕴。修所断无记色行二蕴诸得俱起。有说。亦与欲界修所断无记心心所诸得俱起。如前说。及住不善心。乃至彼法得生老住无常者。谓诸异生三十四随眠。圣者四随眠随一流注久相续起时。诸根大种长养增益。彼心与彼得四相俱起。余如前说

诸法无记无色起。彼法无记心俱耶。答诸法无记无色起。彼法或无记心俱。或善心俱。或不善心俱。云何无记心俱。答诸法彼心相应。彼心俱有无记无色。义如前释。云何善心俱。答如善心胜进无记法得起。及住善心无记诸根长养大种增益。彼法得生老住无常。此如前善心俱起无记无色释。云何不善心俱。答如不善心若退若生无记法得起。及住不善心。无记诸根长养大种增益。彼法得生老住无常。此如前不善心俱起无记无色释。设法无记心俱起。彼法无记无色耶。答诸法无记心俱起。彼法或无记无色或善无色。或不善无。色云何无记无色。答诸法彼心相应。彼心俱有无记无色。义如前释。云何善无色。答如无记心若退若生善法得起。此如前善无色起无记心俱释。云何不善无色。答如无记心若退若生不善法得起。此如前不善无色起无记心俱释。诸法欲界无色起彼法欲界心俱耶。答诸法欲界无色起。彼法或欲界心俱。或色界心俱。或无色界心俱。或不系心俱。云何欲界心俱。答诸法彼心相应彼心俱有。欲界无色彼心相应。欲界无色者。谓欲界心所法彼心俱有。欲界无色者。谓彼法生老住无常。此中亦有同类得起。略故不说。云何色界心俱。答如色界心若生若胜进欲界法得起。及住色界心欲界诸根长养大种增益。彼法得生老住无常。色界心生欲界得起者。谓无色界殁。若生第四静虑时。彼心与第四静虑果。欲界通果心品诸得俱起。乃至若生初静虑时。彼心与初静虑果。欲界通果心品诸得俱起。如无色界殁生色界。上地殁生下地亦尔。色界心胜进欲界得起者。谓以世俗道离欲界染。第九无间道灭。解脱道起时。彼心与初静虑果。欲界通果心品诸得俱起。乃至以世俗道离第三静虑染。第九无间道灭。解脱道起时。彼心与第四静虑果。欲界通果心品诸得俱起。已离欲染信胜解练根作见至。世俗加行道时。彼心与随所应静虑果。欲界通果心品诸得俱起。依未至定。乃至第四静虑。时解脱阿罗汉练根作不动世俗加行道时。彼心与随所应静虑果。欲界通果心品诸得俱起。引发五通诸加行道五无间道。二解脱道。及世俗他心智通。解脱道时。杂修静虑中间心时起四无量。初三解脱。八胜处前八遍处时起无碍解及依未至定乃至第四静虑。世俗无碍解增长时起无诤愿智边际定。及增长时依未至定乃至第四静虑。起空空无愿无愿无相无相等世俗诸功德。及增长时彼心与随所应静虑果。欲界通果心品诸得俱起。及住色界心。乃至彼法得生老住无常者。谓生欲界入色界定时。诸根大种长养增益。彼心与彼得四相俱起。云何无色界心俱。答如住无色界心。欲界诸根长养大种增益。彼法得生老住无常。谓生欲界入无色界定时。诸根大种长养增益彼心与彼得四相俱起。云何不系心俱。答如不系心胜进欲界法得起。及住不系心欲界诸根长养大种增益。彼法得生老住无常。不系心胜进欲界法得起者。谓住见道三类智时。彼心与苦集灭二现观边。所修欲界世俗智品诸得俱起。以无漏道离欲界染。第九无间道灭。解脱道起时。彼心与初静虑果。欲界通果心品诸得俱起。乃至以无漏道离第三静虑染。第九无间道灭。解脱道起时。彼心与第四静虑果。欲界通果心品诸得俱起。金刚喻定灭。尽智起时。彼心与随所应静虑果。欲界通果心品诸得。及尔时所得欲界善法诸得俱起。已离欲染。信胜解练根作见至。无漏加行道时。有说。及解脱道时。彼心与随所应静虑果。欲界通果心品诸得俱起。时解脱阿罗汉练根作不动。依未至定乃至第四静虑无漏加行道时。彼心与随所应静虑果。欲界通果心品诸得俱起。依一切地第九解脱道时。彼心与四静虑果。欲界通果心品诸得。及尔时所得欲界善法诸得俱起起无漏他心智通时。杂修静虑初后心时。依未至定乃至第四静虑无漏无碍解等增长时。彼心与随所应静虑果。欲界通果心品诸得俱起及住不系心。乃至彼法得生老住无常者。谓生欲界入无漏未至乃至无所有处定时。诸根大种长养增益。彼心与彼得四相俱起。设法欲界心俱起。彼法欲界无色耶。答诸法欲界心俱起。彼法或欲界无色。或色界无色。或无色界无色。或不系无色。云何欲界无色。答诸法彼心相应彼心俱有。欲界无色义如前释。云何色界无色。答如欲界心。若退若生色界法得起。欲界心退色界得起者。谓诸圣者已离色染。起欲界缠退时。彼心与色界四地修所断法诸得俱起。乃至已离初静虑染。未离第二静虑染。起欲界缠退时彼心与色界一地。修所断法诸得俱起。若诸异生已离色染。起欲界缠退时。彼心与色界四地见修所断法诸得俱起。乃至已离初静虑染。未离第二静虑染。起欲界缠退时。彼心与色界一地见修所断法诸得俱起。欲界心生色界得起者。谓从无色界殁生欲界时。彼心与色界四地。见修所断法诸得俱起。乃至从第二静虑殁生欲界时。彼心与色界一地。见修所断法诸得俱起。云何无色界无色。答如欲界心若退若生无色界法得起。欲界心退无色界得起者。谓阿罗汉起欲界缠退时。彼心与无色界四地修所断法诸得俱起。若不还者已离无所有处染。起欲界缠退时。彼心与无色界三地。修所断法诸得俱起。乃至已离空无边处染。未离识无边处染。起欲界缠退时。彼心与无色界一地。修所断法诸得俱起。若诸异生已离无所有处染。起欲界缠退时。彼心与无色界三地。见修所断法诸得俱起。乃至已离空无边处染。未离识无边处染。起欲界缠退时。彼心与无色界一地。见修所断法诸得俱起。欲界心生无色界得起者。谓从非想非非想处殁生欲界时。彼心与无色界三地。见修所断法诸得俱起。乃至从识无边处殁生欲界时。彼心与无色界一地。见修所断法诸得俱起。云何不系无色。答如欲界心退不系法得起。谓阿罗汉退胜根住劣根时。彼欲界心与劣根品不系得俱起。学退胜种性住劣种性亦尔。若诸圣者已离欲染。起欲界下下下中二品缠退时。彼心与一来果及胜果道诸得俱起。若起下上品缠退时。犹能护加行者。彼心亦与如前诸不系得俱起。其有不能护加行者。彼心唯与一来果诸得俱起。若起中下乃至上中五品缠退时。彼心与预流果及胜果道诸得俱起。若起上上品缠退时。犹能护加行者。彼心亦与如前诸不系得俱起。其有不能护加行者。彼心唯与预流果诸得俱起。若一来者前六品缠随起何退。彼心随应亦与如前诸不系得俱起。问欲界心胜进不系法得亦起。如或由施。或由戒。或由闻。或由思故。令于恶趣等得非择灭。此中何故不说。有说。应说而不说者。当知此义有余。如是说者。非择灭虽不系。而彼得非不系。此中说不系得起是故不说

诸法色界无色起。彼法色界心俱耶。答诸法色界无色起。彼法或色界心俱。或欲界心俱。或无色界心俱。或不系心俱。云何色界心俱。答诸法彼心相应彼心俱有。色界无色义如前释。云何欲界心俱。答如欲界心若退若生。色界法得起。此如前欲界心俱起色界无色说。云何无色界心俱。答如住无色界心。色界诸根长养大种增益。彼法得生老住无常。谓生色界入无色界定时。诸根大种长养增益。彼心与彼得四相俱起。云何不系心俱。答如不系心胜进色界法得起。及住不系心。色界诸根长养大种增益。彼法得生老住无常。不系心胜进色界得起者。谓住见道三类智时。彼心与苦集灭三现观边所修色界世俗智品诸得俱起。以无漏道离欲界染。若无漏为加行。诸加行道九无间道。九解脱道时。彼心与未来所修色界道诸得俱起。第九解脱道时。亦与初静虑果。色界通果心品诸得俱起。以无漏道离初静虑。乃至第三静虑染时。若无漏为加行。诸加行道九无间道。九解脱道时。彼心与未来所修色界道诸得俱起。最后解脱道时。亦与第二静虑乃至第四静虑果。色界通果心品诸得俱起。以无漏道离第四静虑染。及依未至定。乃至第四静虑。离空无边处乃至非想非非想处染。若无漏为加行诸加行道时。彼心与未来所修色界道诸得俱起。金刚喻定灭。尽智起时。彼心与尔时所得色界善诸得俱起。亦与随所应静虑果。色界通果心品诸得俱起。未离欲染信胜解练根作见至。若无漏为加行彼加行道时。有说。及解脱道时。彼心与未来所修色界道诸得俱起。已离欲染信胜解练根作见至。若无漏为加行彼加行道时。有说。及解脱道时。彼心与未来所修色界道诸得。及随所应静虑果。色界通果心品诸得俱起。时解脱阿罗汉练根作不动。依未至定乃至第四静虑无漏加行道时。彼心与未来所修色界道诸得。及随所应静虑果。色界通果心品诸得俱起。依一切地第九解脱道时。彼心与尔时所得色界善诸得。及四静虑果。色界通果心品诸得俱起。起无漏他心智通时。杂修静虑初后心时。依未至定。乃至第四静虑无漏。无碍解增长时。即依彼诸地起无漏念住时。彼心与未来所修色界道诸得。及随所应静虑果。色界通果心品诸得俱起。及住不系心。乃至彼法得生老住无常者。谓生色界入无漏未至。乃至无所有处定时。诸根大种长养增益。彼心与彼得四相俱起。设法色界心俱起。彼法色界无色耶。答诸法色界心俱起。彼法或色界无色。或欲界无色。或无色界无。色或不系无色。云何色界无色。答诸法彼心相应。彼心俱有色界无色义如前释。云何欲界无色。答如色界心若生若胜进。欲界法得起。及住色界心欲界。诸根长养大种增益。彼法得生老住无常。此如前欲界无色起色界心俱释。云何无色界无色。答如色界心若退若生。无色界法得起。色界心退无色界得起者。谓阿罗汉起色界缠退时。彼心与无色界四地。修所断法诸得俱起。诸不还者已离无所有处染。起色界缠退时。彼心与无色界三地。修所断法诸得俱起。乃至已离空无边处染。未离识无边处染。起色界缠退时。彼心与无色界一地。见修所断法诸得俱起。若诸异生已离无所有处染。起色界缠退时。彼心与无色界三地。见修所断法诸得俱起。乃至已离空无边处染。未离识无边处染。起色界缠退时。彼心与无色界一地。见修所断法诸得俱起。色界心生无色界得起者。谓从非想非非想处殁生色界时。彼心与无色界三地。见修所断法诸得俱起。乃至识无边处殁生色界时。彼心与无色界一地。见修所断法诸得俱起。云何不系无色。答如色界心若退若胜进。不系法得起。色界心退不系得起者。谓阿罗汉起色界缠退时。彼心与不还果。及胜果道诸得俱起。色界心胜进不系得起者。谓诸圣者以世俗道离欲界乃至第三静虑染。若世俗为加行。一切加行无间解脱道时。彼心与未来所修不系法诸得俱起。依未至定乃至第四静虑。离第四静虑乃至非想非非想处染。若世俗为加行。诸加行道时。彼心与未来所修不系法诸得俱起。信胜解练根作见至。及依未至定乃至第四静虑。时解脱阿罗汉练根作不动。若世俗为加行。诸加行道时。彼心与未来所修不系法诸得俱起。若诸圣者引发诸通诸加行道。五无间道二解脱道。及世俗他心智通。解脱道时。杂修静虑中间心时。若诸圣者起四无量。初三解脱。八胜处前八遍处时。起无碍解及依未至定乃至第四静虑。世俗无碍解增长时起无诤愿智。边际定及增长时。依未至定乃至第四静虑。起空空无愿无愿无相无相时。及圣者即依彼地。起不净观。持息念。世俗念住等诸功德。及增长时。彼心与未来所修不系法诸得俱起。问色界心生时不系法得亦起。如无色界殁生第四静虑时。彼心与第三静虑见修所断蕴择灭得俱起。乃至上地殁生初静虑时。彼心与欲界见修所断蕴择灭得俱起。此中何故不说。答有说。应说而不说者当知此义有余。如是说者。尔时所得择灭虽不系而彼诸得是色界系。非不系是故不说

说一切有部发智大毗婆沙论卷第一百五十九阿毗达磨大毗婆沙论卷第一百六十

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    定蕴第七中得纳息第一之四

诸法无色界无色起。彼法无色界心俱耶。答诸法无色界无色起。彼法或无色界心俱。或欲界心俱。或色界心俱。或不系心俱。云何无色界心俱。答诸法彼心相应。彼心俱有无色界无色义如前释。云何欲界心俱。答如欲界心若退若生。无色界法得起。此如前欲界心俱起无色界无色释。云何色界心俱。答如色界心若退若生。无色界法得起。此如前色界心俱起无色界无色释。云何不系心俱。答如不系心胜进。无色界法得起。谓以无漏道离第四静虑染。九无间道。九解脱道时。彼心与未来所修无色界道诸得俱起。以无漏道离空无边处。乃至无所有处染。若无漏为加行。诸加行道。九无间道。九解脱道时。彼心与未来所修无色界道诸得俱起。此是总说。于中若依未至定。乃至第四静虑。离下三无色染者。除加行道。依下三无色离非想非非想处染。若无漏为加行。彼加行道时。彼心与未来所修无色界道诸得俱起。及依一切地。离非想非非想处染。最后解脱道尽智起时。彼心与尔时所得无色界善诸得俱起。时解脱阿罗汉练根作不动。若依三无色。无漏为加行。彼加行道时。彼心与未来所修无色界道诸得俱起。及依一切地最后解脱道时。彼心与尔时所得无色界善诸得俱起。起无漏解脱时。依无色定无漏无碍解增长时。起无色无漏念住时。彼心与未来所修无色界道诸得俱起。设法无色界心俱起。彼法无色界无色耶。答诸法无色界心俱起。彼法或无色界无色。或欲界无色。或色界无色。或不系无色。云何无色界无色。答诸法彼心相应。彼心俱有无色界无色义如前释。云何欲界无色。答如住无色界心。欲界诸根长养大种增益。彼法得生老住无常。此如前欲界无色起无色界心俱释。云何色界无色。答如住无色界心。色界诸根长养大种增益。彼法得生老住无常。此如前色界无色起无色界心俱释。云何不系无色。答如无色界心若退若胜进。不系法得起。无色界心退不系得起者。谓阿罗汉起无色界缠退时。彼心与不还果及胜果道诸得俱起。无色界心胜进不系得起者。谓诸圣者以世俗道。离第四静虑染。若空无边处近分为加行。彼加行道。九无间道。九解脱道时。及圣者以世俗道。离下三无色染。若世俗为加行。一切加行无间解脱道时。并依无色定离非想非非想处染。若世俗为加行彼加行道时。彼心与未来所修不系法诸得俱起。时解脱阿罗汉练根作不动。依无色定。若世俗为加行彼加行道时。若圣者起无色有漏解脱二遍处时。依无色定有漏无碍解增长时。依无色定起世俗念。住空空无愿无愿无相无相时。起入灭定想微细心时。彼心与未来所修不系法诸得俱起。问无色界心生时。不系法得亦起。如无色界上地殁生下地时。彼心与所生次下地见修所断诸染择灭得俱起。此中何故不说。有说。应说而不说者当知此义有余。如是说者。尔时所得择灭虽不系。而得是无色界系非不系。是故不说

诸法学无色起。彼法学心俱耶。答诸法学无色起。彼法或学心俱。或非学非无学心俱。云何学心俱。答诸法彼心相应。彼心俱有。学无色彼心相应。学无色者。谓学心所法彼心俱有。学无色者。谓彼法生老住无常。此中亦有同类得起。略故不说。云何非学非无学心俱。起如非学非无学心。若退若胜进。学法得起非学非无学心退。学得起者。谓阿罗汉起非想非非想处。乃至初静虑后八品缠退时。彼心与不还果及胜果道诸得俱起。若起初静虑上上品缠退时。犹能护加行者。彼心亦与如前学得俱起。其有不能护加行者

彼心唯与不还果诸得俱起。诸不还者若起欲界下下下中二品缠退时。彼心与一来果及胜果道诸得俱起。若起下上品缠退时。犹能护加行者。彼心亦与如前学得俱起。其有不能护加行者。彼心唯与一来果诸得俱起。若起中下乃至上中五品缠退时。彼心与预流果及胜果道诸得俱起。若起上上品缠退时。犹能护加行者。彼心亦与如前学得俱起。其有不能护加行者。彼心唯与预流果诸得俱起。若一来者前六品缠。随起何退彼心随其所应亦与如前学得俱起。非学非无学心胜进学得起者。谓诸学者以世俗道离欲界乃至无所有处染。若世俗为加行。一切加行无间解脱道时。及离非想非非想处染。若世俗为加行。彼加行道时。彼心与未来所修学法诸得俱起。信胜解练根作见至。若世俗为加行彼加行道时。即此学者引发诸通。诸加行道。五无间道。二解脱道。及世俗他心智通解脱道时。学者杂修静虑中间心时。学者起四无量。世俗解脱。八胜处。十遍处时。学者起入灭定想微细心时。学者修不净观持息念。世俗念住时。彼心与未来所修学法诸得俱起设法学心俱起。彼法学无色耶。答诸法学心俱起。彼法或学无色。或非学非无学无色。云何学无色。答诸法彼心相应。彼心俱有。学无色义如前释。云何非学非无学无色。答如学心胜进非学非无学法得起。及住学心。非学非无学。诸根长养大种增益。彼法得生老住无常。学心胜进非学非无学得起者。谓住见道三类智时。彼心与苦集灭三现观边所修世俗智品诸得俱起。以无漏道。离欲界乃至无所有处染。若无漏为加行。一切加行无间解脱道时。及离非想非非想处染。若无漏为加行。彼加行道时。彼心与未来所修世俗道诸得俱起。离欲界乃至第三静虑染。第九解脱道时。彼心亦与通果心品诸得俱起。俱胜解练根作见至。若无漏为加行。彼加行道时。有说。及解脱道时。彼心与未来所修世俗道。及通果心品诸得俱起。学者起无漏他心智通时。学者杂修静虑初后心时。学者起无漏念住时。彼心与未来所修世俗道。及通果心品诸得俱起。学者起无漏解脱时。除通果心。与如前说诸得俱起。及住学心乃至彼法得生老住无常者。谓诸学者生欲色界。住色无色无漏定时。诸根大种长养增益。彼心与彼得四相俱起

诸法无学无色起。彼法无学心俱耶。答诸法无学无色起。彼法或无学心俱。或非学非无学心俱。云何无学心俱。答诸法彼心相应。彼心俱有无学无色义如前释。云何非学非无学心俱。答如非学非无学心。若退若胜进无学法得起。非学非无学心退。无学得起者。谓阿罗汉退胜根住劣根时。彼非学非无学心。与劣根品无学法诸得俱起。有说。唯烦恼现前故退者。彼说此中但应言胜进。不应言退。如是说者。住无覆无记心亦退故。此中亦应说退。谓住无覆无记心。退堪达根住住法根。乃至退思法根住退法根。非学非无学心。胜进无学得起者。谓时解脱阿罗汉练根作不动。若世俗为加行。彼加行道时。彼心与未来所修无学法诸得俱起。阿罗汉引发诸通。诸加行道。五无间道。二解脱道。及世俗他心智通。解脱道时。阿罗汉杂修静虑中间心时。阿罗汉起四无量。世俗解脱。八胜处。十遍处时。起无碍解。及世俗无碍解增长时。起无诤愿智边际定。空空无愿无愿无相无相。及增长时阿罗汉起不净观。持息念。世俗念住。并入灭尽定想微细心时。彼心与未来所修无学法诸得俱起。设法无学心俱起。彼法无学无色耶。答诸法无学心俱起。彼法或无学无色。或非学非无学无色。云何无学无色。答诸法彼心相应。彼心俱有无学无色。义如前释。云何非学非无学无色。答如无学心胜进。非学非无学法得起。及住无学心非学非无学诸根长养大种增益。彼法得生老住无常。无学心胜进非学非无学得起者。谓金刚喻定灭。尽智起时。彼心与尔时所得世俗善。及或亦与通果心品诸得俱起。时解脱阿罗汉练根作不动。若无漏为加行。彼加行道时。彼心与未来所修世俗道。及或亦与通果心品诸得俱起。最后解脱道时。彼心与尔时所得世俗善。及通果心品诸得俱起。阿罗汉起无漏他心智通时。阿罗汉杂修静虑初后心时。阿罗汉依色界定起无漏念住。及无漏无碍解增长时。彼心与未来所修世俗道。及通果心品诸得俱起。阿罗汉起无漏解脱。及依无色定起无漏念住。并无漏无碍解增长时。除通果心。彼心与余如前诸得俱起。及住无学心乃至彼法得生老住无常者。谓生欲色界阿罗汉。住色无色无漏定时。诸根大种长养增益。彼心与彼得四相俱起。诸法非学非无学无色起。彼法非学非无学心俱耶。答诸法非学非无学无色起。彼法或非学非无学心俱。或学心俱。或无学心俱。云何非学非无学心俱。答诸法彼心相应。彼心俱有非学非无学无色义如前释。云何学心俱。答如学心胜进。非学非无学法得起。及住学心非学非无学诸根长养大种增益。彼法得生老住无常。此如前学心俱起非学非无学无色释。云何无学心俱。答如无学心胜进非学非无学法得起。及住无学心。非学非无学诸根长养大种增益。彼法得生老住无常。此如前无学心俱起非学非无学无色释。设法非学非无学心俱起。彼法非学非无学无色耶。答诸法非学非无学心俱起。彼法或非学非无学无色。或学无色。或无学无色。云何非学非无学无色。答诸法彼心相应。彼心俱有非学非无学无色义如前释。云何学无色。答如非学非无学心。若退若胜进学法得起。此如前学无色起非学非无学心俱释。云何无学无色。答如非学非无学心。若退若胜进。无学法得起。此如前无学无色起非学非无学心俱释

诸法见所断无色起。彼法见所断心俱耶。答诸法见所断无色起。彼法或见所断心俱。或修所断心俱。云何见所断心俱。答诸法彼心相应。彼心俱有见所断无色彼心相应。见所断无色者。谓见所断心所法彼心俱有。见所断无色者。谓彼法生老住无常。此中亦有同类得起。略故不说。云何修所断心俱。答如修所断心若退若生。见所断法得起。修所断心退。见所断得起者。谓诸异生已离无所有处染。或起无所有处修所断缠退。或乃至起欲界修所断缠退时。彼心或与一地见所断法。或乃至与八地见所断法诸得俱起。乃至已离欲界染。未离初静虑染。起欲界修所断缠退时。彼心与一地见所断法诸得俱起。修所断心生见所断得起者。谓从非想非非想处殁。或生无所有处。以无所有处修所断心结生。或乃至生欲界以欲界修所断心结生时。彼心或与一地见所断法。或乃至与八地见所断法诸得俱起。乃至初静虑殁生欲界。以欲界修所断心结生时。彼心与一地见所断法诸得俱起。设法见所断心俱起。彼法见所断无色耶。答诸法见所断心俱起。彼法或见所断无色。或修所断无色。云何见所断无色。答诸法彼心相应。彼心俱有见所断无色义如前释。云何修所断无色。答如见所断心若退若生。修所断法得起。及住见所断心。修所断诸根长养大种增益。彼法得生老住无常。见所断心退修所断得起者。谓诸异生已离无所有处染。起无所有处见所断缠退。或乃至起欲界见所断缠退时。彼心与一地修所断法。或乃至八地修所断法诸得俱起。乃至已离欲界染。未离初静虑染。起欲界见所断缠退时。彼心与一地修所断法诸得俱起。见所断心生修所断得起者。谓从非想非非想处殁。或生无所有处。以无所有处见所断心结生。或乃至生欲界。以欲界见所断心结生时。彼心或与一地修所断法或乃至与八地修所断法诸得俱起。乃至初静虑殁生欲界。以欲界见所断心结生时。彼心与一地修所断法诸得俱起。及住见所断心。乃至彼法得生老住无常者。谓生欲色界见所断烦恼现在前时。诸根大种长养增益。彼心与彼得四相俱起

诸法修所断无色起。彼法修所断心俱耶。答诸法修所断无色起。彼法或修所断心俱。或见所断心俱。或不断心俱。云何修所断心俱。答诸法彼心相应彼心俱有。修所断无色义如前释。云何见所断心俱。答如见所断心若退若生。修所断法得起。及住见所断心。修所断诸根长养大种增益彼法得生老住无常。此如前见所断心俱起修所断无色释。云何不断心俱。答如不断心胜进修所断法得起。及住不断心。修所断诸根长养大种增益。彼法得生老住无常。不断心胜进修所断得起者。谓住见道三类智时。彼心与苦集灭三现观边所修世俗智品诸得俱起以无漏道离欲界乃至无所有处染。若无漏为加行。一切加行无间解脱道时。及离非想非非想处染。若无漏为加行。彼加行道时。彼心与未来所修世俗道诸得俱起。离欲界乃至第三静虑染。第九解脱道时。彼心亦与通果心品诸得俱起。金刚喻定灭尽智起时。彼心与尔时所得世俗善。及或亦与通果心品诸得俱起。信胜解练根作见至。若无漏为加行。彼加行道时。有说。及解脱道时。彼心与未来所修世俗道。及或亦与通果心品诸得俱起。时解脱阿罗汉练根作不动。若无漏为加行。彼加行道时。彼心与未来所修世俗道。及或亦与通果心品诸得俱起。最后解脱道时。彼心与尔时所得世俗善。及通果心品诸得俱起。起无漏他心智通时。杂修静虑初后心时。依色界定起无漏念住。及无漏无碍解增长时。彼心与未来所修世俗道。及通果心品诸得俱起。起无漏解脱。及依无色定起无漏念住。并无漏无碍解增长时。除通果心品。彼心与余如前诸得俱起。及住不断心。乃至彼法得生老住无常者。谓生欲色界住色无色无漏定时。诸根大种长养增益。彼心与彼得四相俱起。设法修所断心俱起。彼法修所断无色耶。答诸法修所断心俱起。彼法或修所断无色。或见所断无色。或不断无色。云何修所断无色。答诸法彼心相应。彼心俱有修所断无色义如前释。云何见所断无色。答如修所断心若退若生。见所断法得起。此如前见所断无色起修所断心俱释。云何不断无。色答如修所断心。若退若胜进。不断法得起。修所断心退不断得起者。谓阿罗汉退胜根住劣根时。彼修所断心与劣根品不断法诸得俱起。学退胜种性住劣种性亦尔。阿罗汉起非想非非想处。乃至初静虑后八品缠退时。彼心与不还果及胜果道诸得俱起。若起初静虑上上品缠退。犹能护加行者。彼心亦与如前不断得俱起。其有不能护加行者。彼心唯与不还果诸得俱起。诸不还者起欲界下下下中二品缠退时。彼心与一来果及胜果道诸得俱起。若起下上品缠退。犹能护加行者。彼心亦与如前不断得俱起。其有不能护加行者。彼心唯与一来果诸得俱起。若起中下乃至上中五品缠退时。彼心与预流果及胜果道诸得俱起。若起上上品缠退。犹能护加行者。彼心亦与如前不断得俱起。其有不能护加行者。彼心唯与预流果诸得俱起。修所断心胜进不断得起者。谓诸圣者以世俗道离欲界。乃至无所有处染。若世俗为加行。一切加行无间解脱道时。及离非想非非想处染。若世俗为加行。彼加行道时。彼心与未来所修不断法诸得俱起。信胜解练根作见至。及时解脱阿罗汉练根作不动。若世俗为加行。彼加行道时。彼心与未来所修不断法诸得俱起。若圣者引发诸通诸加行道。五无间道。二解脱道。及世俗他心智通。解脱道时。杂修静虑中间心时。圣者起四无量。世俗解脱。八胜处。十遍处时。起无碍解及世俗无碍解增长时。起无诤愿智边际定。空空无愿无愿无相无相及增长时。圣者起不净观。持息念。世俗念住时。起入灭定想微细心时。彼心与未来所修不断法诸得俱起

诸法不断无色起。彼法不断心俱耶。答诸法不断无色起。彼法或不断心俱。或修所断心俱。云何不断心俱。答诸法彼心相应。彼心俱有。不断无色义如前释。云何修所断心俱。答如修所断心若退若胜进。不断法得起。此如前修所断心俱起不断无色释。设法不断心俱起。彼法不断无色耶。答诸法不断心俱起。彼法或不断无色。或修所断无色。云何不断无色。答诸法彼心相应。彼心俱有。不断无色义如前释。云何修所断无色。答如不断心胜进修所断法得起。及住不断心修所断诸根长养大种增益。彼法得生老住无常。此如前修所断无色起不断心俱释

一切初静虑皆有五支耶。乃至广说。问何故作此论。有说。欲止他所说故。如分别论者。唯许初静虑建立支非余。所以者何。依契经故。如契经说。毗舍佉邬波索迦。往达磨阵那苾刍尼所问言。圣者初静虑有几支。答言具寿有五支。谓寻伺喜乐心一境性。彼邬波索迦既不问上静虑支。彼苾刍尼又不说。故知上诸静虑不建立支。为遮彼意显上诸静虑亦建立支故作斯论。问若上诸静虑亦立支者。何故毗舍佉不问。苾刍尼不说耶。有说。彼疑者问。不疑者不问。随问者说。不问者不说。由此不应责其所以。有说。毗舍佉欲试彼苾刍尼于此事为能知不。且问初静虑支彼既无滞而说。邬波索迦便作是念。此尊者于初静虑既能无滞而说于余静虑必亦能知。是故不问。由彼更不问故苾刍尼亦不复说。有说。毗舍佉是利根性。闻初静虑即知余三故更不问。苾刍尼亦知彼已悟更不为说。有说。毗舍佉是钝根性。极作意力才能问初静虑。无力更能问余。是故不问。苾刍尼亦知彼齐是能受持。于余非器故更不说。有余师说。为令疑者得决定解故作斯论。谓彼经但说初静虑有五支。不说上地。又但说支不说染与不染。今欲显示上地亦有支唯不染污中具有。令诸疑者生决定解故作斯论。一切初静虑皆有五支耶。答不染污有五。染污无五。无何等。答无离生喜乐。问何故染污喜于染静虑不说支耶。有说。此文但应说无乐。以轻安乐染中无故。若作是说。彼不染初静虑具五支。染初静虑有四支。有说。此文即是但说无乐。由此乐从离生故。喜相应故。名离生喜乐。是故此文不言无喜。有说。染静虑中虽亦有喜。无支相故不立为支。若作是说。不染初静虑具五支。染初静虑唯有三支。一切第二静虑皆有四支耶。答不染污有四。染污无四。无何等。答无内等净。问内等净是信。信通染污不染污。何故于染静虑不说支耶。有说。此文应说无乐。以轻安乐染中无故。若作是说。不染第二静虑具四支。染第二静虑有三支。有说。染信名不信。此于染中虽有无支相故不立为支。若作是说。不染第二静虑具四支。染第二静虑唯有二支。一切第三静虑皆有五支耶。答不染污有五。染污无五。无何等。答无正念正知。问念慧皆通染污中有。何故不立染静虑支。有说。此文应说无舍。大善地法染中无故。若作是说。不染第三静虑具五支。染第三静虑有四支。有说。染念名失念。染慧名不正知。此于染中虽有无支相故不立为支。若作是说。不染第三静虑具五支。染第三静虑唯有二支。一切第四静虑皆有四支耶。答不染污有四。染污无四。无何等。答无舍念清净。问念通染污。于染静虑何故非支。有说。此文但应说无舍。大善地法染中无故。若作是说。不染第四静虑具四支。染第四静虑有三支。有说。染念名失念。不名念清净。此于染中虽有无支相故不立为支。若作是说。不染第四静虑具四支。染第四静虑唯有二支。此中有作是说。诸染静虑皆不立支。而唯说无喜乐等者。随明了义说。谓初静虑离生喜乐。有离生言故。第二静虑内等净。有净言故。第三静虑正念正知。有正言故。第四静虑舍念清净。有清净言故。此皆于染明了相违故偏说无。而实染中一切支皆非。有说。随胜者说。谓初静虑出欲界重苦利益支胜。上三静虑于胜妙离染对治支胜。是故于染静虑随胜者说无。然其余支于染静虑亦不建立

说一切有部发智大毗婆沙论卷第一百六十阿毗达磨大毗婆沙论卷第一百六十一

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    定蕴第七中得纳息第一之五

味相应初静虑。入当言味耶。出当言味耶。乃至广说。问何故作此论。答欲令疑者得决定故。谓品类足说。初静虑云何。答初静虑所摄善色受想行识。乃至第四静虑云何。答第四静虑所摄善色受想行识。勿令生如是疑静虑唯善。欲显静虑非唯是善故作斯论。以静虑通善染无覆无记故味相应。初静虑入当言味耶。出当言味耶。答于能味当言入。于所味当言出。乃至味相应非想非非想处。入当言味耶。出当言味耶。答于能味当言入。于所味当言出。此中爱名为味三摩地。名初静虑等即爱相应。诸三摩地名味相应静虑无色。问何故但说与爱相应非余烦恼。答是作论者意欲尔故。乃至广说。有说。亦应说余烦恼。谓应说有身见相应初静虑。入当言取我我所耶。出当言取我我所耶。答于能取当言入。于所取当言出。广说乃至无明相应初静虑入当言愚耶。出当言愚耶。答于能愚当言入。于所愚当言出。乃至非想非非想处说亦如是。而不作是说者应知此义有余。有说。此中举爱为门。令知余烦恼亦尔。有说。此中说相似者。谓爱与定相似非余烦恼。所以者何。定于所缘流注相续爱亦如是。复次定于所缘审谛而取爱亦如是。复次定于所缘系心不离。爱亦如是。复次定于所缘摄受而转爱亦如是。复次定能长益诸根大种。爱亦如是。诸余烦恼无此相故不说相应。问味是爱非静虑等不应言入。以于定有入言故。静虑等是定非爱。不应言味。以于爱有味言故。何故二法更互得名。答由此二法展转相应更互受名斯有何过。谓定爱相应故亦可名味。爱定相应故。亦可言入。此中入出者入出有五种。一地。二行相。三所缘。四异类心。五刹那。地入出者。谓初静虑等无间第二静虑现在前时。名入第二静虑。出初静虑乃至无所有处。等无间非想非非想处现在前时。名入非想非非想处。出无所有处。如顺次入出。如是逆次入出及顺逆超入出亦尔。行相入出者。谓无常行相等无间。苦行相现在前时。名入苦行相。出无常行相。余行相亦尔。所缘入出者。谓缘色定等无间。缘受定现在前时。名入缘受定。出缘色定缘。余定亦尔。异类心入出者。谓欲界心等无间。色界或不系心现在前时。名入色界或不系心。出欲界心。色界心等说亦尔。如欲界等心。学等心亦如是。余善等心随应亦尔。刹那入出者。谓初刹那等无间第二刹那现在前时。名入第二刹那。出初刹那。余刹那亦尔。于五入出中此依刹那入出而作论。于能味当言入。于所味当言出者。有作是说。此中说味相应定。流注相续现在前时。皆以前刹那为所味是所缘故。后刹那为能味是能缘故。于能味当言入者。谓后后刹那。味相应静虑无色现在前时。名于能味已入。于已起位方成能味故。于所味当言出者。谓前前刹那味相应静虑无色。已谢灭时名于所味。已出于已灭位方成所味故。问爱相应定能缘三世。何故唯说缘过去耶。有说。此依多分而说。谓有情类法尔。多缘曾所受顺境生爱味故。有说。过去定于相续中已作饶益。现在定从彼而起追恋生爱。有说。此中依入出定而为问答。未来定未名入出。现在定名入未名出。过去定名入已出。今欲显于已出位生味故。但说缘过去。有余师说。此中说净定无间起味相应定。净定为所味是所缘故。味相应定是能味是能缘故。余如前说。评曰。应知初说为善。此中入出皆依味定而作论故。诸味相应初静虑皆有覆无记耶。乃至广说。问何故作此论。答前文唯说爱相应定。今欲显定亦与余烦恼相应故作斯论。诸味相应初静虑皆有覆无记耶。设有覆无记初静虑皆味相应耶。答诸味相应初静虑皆有覆无记。有有覆无记初静虑。非味相应。谓除爱余烦恼现前。乃至诸味相应。非想非非想处皆有覆无记耶。设有覆无记非想非非想处。皆味相应耶。答诸味相应非想非非想处。皆有覆无记。有有覆无记。非想非非想处非味相应。谓除爱余烦恼现前。此中味相应静虑无色。皆有覆无记者。能障圣道及圣道加行故名有覆。不招异熟果故名无记。余烦恼者。谓见疑慢无明。此诸烦恼与不染污静虑无色。展转相续而现在前。令瑜伽师名爱上静虑。见上静虑。疑上静虑。慢上静虑者。亦有余缠随烦恼垢共相应义。烦恼胜故但说烦恼。颇有不入初静虑。入第二静虑耶。答入。乃至颇有不入无所有处。入非想非非想处耶。答入。问何故作此论。答欲令疑者得决定故。如品类足说。初者谓次第随顺。相续连合中数为初故。复次次第随顺。相续连合入诸定时此最初故。诸契经中亦说九次第定。或有生如是疑。若不入初静虑等。便不能入第二静虑等。今欲令彼生决定解。不入初静虑等。亦能入第二静虑等故作斯论。颇有不入初静虑。入第二静虑耶。答入。云何入。谓从未至定。或静虑中间。或第二静虑近分。或第二静虑。或第三静虑近分。或第三静虑。或第四静虑等无间第二静虑现在前。此中有说。欲界善心等无间。唯能入未至定。有说。亦能入初静虑。有说。亦能入静虑中间。尊者僧伽伐苏说曰。亦能入第二静虑如超定者。从初静虑等无间。超第二静虑。入第三静虑。如是亦应从欲界善心等无间。超初静虑入第二静虑此不应理。欲界善心非定心故。不可得说与诸定心同其势力。颇有不入第二静虑。入第三静虑耶。答入。云何入谓从初静虑。或第三静虑近分。或第三静虑。或第四静虑近分。或第四静虑。或空无边处。有说。亦从第二静虑近分等无间。第三静虑现在前。颇有不入第三静虑入第四静虑耶。答入。云何入。谓从第二静虑。或第四静虑近分。或第四静虑。或空无边处近分。或空无边处。或识无边处。有说。亦从第三静虑近分等无间。第四静虑现在前。如是乃至颇有不入无所有处入非想非非想处耶。答入。云何入。谓从识无边处。或非想非非想处近分。或非想非非想处。有说。亦从无所有处近分等无间。非想非非想处现在前。此中遮刹那。不遮相续。不遮分位。不遮众同分。不遮无始时来。谓入此定前刹那。不入彼定。非余刹那亦不曾入故。相续等于此不遮。由斯理趣应知。亦有遮二遮三乃至遮七。谓颇有不入初第二静虑入第三静虑耶。答入。谓依未至定离欲界。乃至第二静虑染。命终生第三静虑。或从上地殁生第三静虑。即于彼第三静虑现在前。乃至颇有不入四静虑下三无色。入非想非非想处耶。答入。谓依未至定离欲界。乃至无所有处染。命终生非想非非想处。即于彼非想非非想处定现在前。此依遮刹那乃至遮众同分。不遮无始时来。说其有亦不遮众同分。或亦不遮分位。义亦无违应准前说

颇有不入初静虑。生梵世耶。答生。乃至颇有不入非想非非想处。生非想非非想处耶。答生。问何故作此论。答欲令疑者得决定故。如契经说。先此入定后生彼中。乃至广说。或有生疑。要入彼定方得生彼。欲令此疑得决定故。显虽不入彼定亦得生彼故作斯论。问若尔经说当云何通。答有诸有情先入彼定。后生彼中。有诸有情不入彼定而亦生彼。契经说入定生彼者。阿毗达磨说不入定生彼者。如是则二说善通。问若不入彼定亦得生彼。何故世尊唯说入定生彼处耶。答有诸外道。谓梵天等非修定得故。世尊说先此入定后方生彼。令决定信果由因得。复次有诸有情耽着现在少分欲乐。不乐当来离欲胜果。世尊为彼毁呰欲乐赞离欲果。彼有情闻已忻乐请说所因故。佛为说先入彼定后生彼处。复次有诸有情。闻说上界离欲胜果不生信解。佛意欲显若能入彼根本定时现受胜乐。令知彼果更为胜妙故。佛为说先此入定后生彼中。复次有瑜伽师能入彼定。虽乐生彼。而不现入故。佛为说先此入定后方生彼。复次有瑜伽师。虽厌欲界苦求离欲乐。而于离欲法懈怠不修故。佛为说先此入定后生彼处。颇有不入初静虑生梵世耶。答生。云何生。谓依未至定离欲界染。最后解脱道。及后时不入初静虑彼若未离初静虑染命终。必当生于梵世。或上地殁生彼天中。问不起彼定云何生彼无异熟因故。答顺后次受业为异熟因故得生彼。颇有不入第二静虑。生极光净耶。答生。云何生。谓依未至初静虑。静虑中间。第二静虑近分随一。离初静虑染。不入第二静虑。彼若未离第二静虑染命终。必当生极光净。或上地殁生彼天中。颇有不入第三静虑。生遍净耶。答生。云何生。谓依未至初静虑。静虑中间。第二静虑。第三静虑近分随一。离第二静虑染。不入第三静虑。彼若未离第三静虑染命终。必当生于遍净。或上地殁生彼天中。如是乃至颇有不入非想非非想处。生非想非非想处耶。答生。云何生。谓依未至定乃至无所有处随一。离无所有处染。未离上染。不入非想非非想处命终。必生非想非非想处。此中遮刹那。遮相续。遮分位。遮众同分。不遮无始时来

若得初静虑非第二静虑。彼命终生何处。乃至广说。问何故作此论。答欲令疑者得决定故。如世尊说苾刍当知。我说依初静虑能尽诸漏。依第二静虑。乃至无所有处能尽诸漏。勿有生疑唯依根本定能尽诸漏非未至等。为令此疑得决定故。显依九地皆能尽漏。谓七根本未至中间余近分地。虽不能尽而亦能断故作斯论。然得有二种。一现前得。二成就得。此中依现前得而作论。若得初静虑非第二静虑彼命终生何处。答或梵世。或极光净。或遍净。或广果。或空无边处。或识无边处。或无所有处。或非想非非想处。或无处。所谓现前得初静虑。非第二静虑者。决定已离欲界染而上地不定。于中若未离初静虑染。彼命终生梵世。若依未至定。或初静虑。或静虑中间或第二静虑近分随一。离初静虑染最后解脱道。及后时不入第二静虑。未离第二静虑染。彼命终生极光净。即彼若依未至。初静虑。静虑中间随一。离第二静虑染。未离上染彼命终生遍净。若即依前三地随一。离第三静虑染。未离上染彼命终生广果。如是乃至若即依前三地随一。离非想非非想处染。彼命终无生处。已离三界染故。若得第二静虑。非第三静虑。彼命终生何处。答或极光净。或遍净。乃至或非想非非想处。或无处。所谓现前得第二静虑。非第三静虑者。决定已离初静虑染。而上地不定。于中若未离第二静虑染。彼命终生极光净。若依未至。初静虑。静虑中间。第二静虑。第三静虑近分随一。离第二静虑染。不入第三静虑。未离第三静虑染。彼命终生遍净。即彼若依未至。初静虑。静虑中间。第二静虑随一。离第三静虑染。未离上染。彼命终生广果。若即依前四地随一。离第四静虑染。未离上染彼命终生空无边处。如是乃至。若即依前四地随一。离非想非非想处染。彼命终无生处。若得第三静虑。非第四静虑。彼命终生何处。答或遍净。或广果。乃至或非想非非想处。或无处。所谓现前得第三静虑。非第四静虑者。决定已离第二静虑染。而上地不定。于中若未离第三静虑染。彼命终生遍净。若依未至定。乃至第三静虑随一离第三静虑染。未离上染。彼命终生广果。若即依前五地随一。离第四静虑染。未离上染。彼命终生空无边处。如是乃至若即依前五地随一。离非想非非想处染。彼命终无生处。若得第四静虑。非空无边处。彼命终生何处。答或广果。乃至或非想非非想处。或无处。所谓现前得第四静虑。非空无边处者。决定已离第三静虑染。而上地不定。于中若未离第四静虑染。彼命终生广果。若依未至定。乃至第四静虑随一。离第四静虑染。未离上染。彼命终生空无边处。若即依前六地随一。离空无边处染。未离上染。彼命终生识无边处。如是乃至若即依前六地随一。离非想非非想处染。彼命终无生处。若得空无边处。非识无边处彼命终生何处。答或空无边处。乃至或无处。所谓现前得空无边处。非识无边处者。决定已离第四静虑染。而上地不定。于中若未离空无边处染。彼命终生空无边处。若依未至定。乃至空无边处随一。离空无边处染。未离上染。彼命终生识无边处。如是乃至若即依前七地随一。离非想非非想处染。彼命终无生处。若得识无边处。非无所有处。彼命终生何处。答或识无边处。乃至或无处。所谓现前得识无边处。非无所有处者。决定已离空无边处染。而上地不定。于中若未离识无边处染。彼命终生识无边处。若依未至定。乃至识无边处随一。离识无边处染。未离上染。彼命终生无所有处。如是乃至若即依前八地随一。离非想非非想处染。彼命终无生处。若得无所有处。非非想非非想处。彼命终生何处。答或无所有处。乃至或无处。所谓现前得无所有处。非非想非非想处者。决定已离识无边处染。而上地不定。于中若未离无所有处染。彼命终生无所有处若依未至定。乃至无所有处随一。离无所有处染。未离上染。彼命终生非想非非想处。若即依前九地随一。离非想非非想处染。彼命终无生处。由斯理趣应知亦有得二得三乃至得七。遮亦如是。答理无异故不具说。问若得欲界善心。非初静虑。此中何故不问。彼命终生何处耶。有说。亦应说若得欲界善心。非初静虑彼命终生何处。答或欲界。或梵世。乃至或非想非非想处。或无处所。谓现前得欲界善心。非初静虑者。彼决定在欲界而离染不定。谓彼若未离欲界染。命终还生欲界。若依未至定离欲界染。最后解脱道。及后时不入初静虑。未离初静虑染。彼命终生梵世。即彼若依未至定。离初静虑染。未离上染。彼命终生极光净。乃至若依未至定。离无所有处染。未离上染。彼命终生非想非非想处。若依未至定。离非想非非想处染。彼命终无生处应作是说。而不说者当知此义有余。有说。彼不应问答欲界。以此是定蕴。正问答定及定果。欲界非定非定果是故不说。问得初静虑非第二静虑等。彼命终亦生欲界等。此中何故不说。有说。亦应说彼生一切下地。而不说者当知此义有余。有说此是定蕴正显生定地。若说生下则有生欲界不定地过是故不说。有说。此中说得诸定而死生者。诸生下者退舍诸定是以不说。问诸生上者于命终时。亦舍诸定何故则说。答诸生上者虽有所舍犹名胜进。况有所得。诸生下者虽有所得尚名退堕。况有所舍。今是定蕴正显胜进是故不说。问契经但说依初静虑乃至无所有处能尽诸漏。云何知有静虑中间。及未至定依之尽漏。答世尊。说有三三摩地能尽诸漏。谓有寻有伺无寻唯伺无寻无伺。余经又说。初静虑名有寻有伺。第二静虑以上名无寻无伺。若无静虑中间更说何等名无寻唯伺。由此知有静虑中间依之尽漏。又契经说佛告苾刍。我不唯说依离欲恶不善法有寻有伺。离生喜乐初静虑具足住等能尽诸漏。然由慧见亦能尽漏。此经则显有未至定依之尽漏。又未离欲染圣者。未得静虑而见圣谛。若无未至定依何得起圣道永断诸漏。由此故知有未至定依之尽漏。问何不即说初静虑等能尽诸漏而说依耶。有说。静虑有先曾得。若世尊说初静虑等能尽诸漏。则无知者。谓得静虑皆已尽漏。是故佛说依静虑等。起无漏道方能尽漏。有说。诸定唯是奢摩他要毗钵舍那方能尽漏。故说依定应须起慧。有说。诸定多是曾得勿有恋着不欲进修。故说依之进求胜道不应生着。问如契经说。非想非非想处俱行修念等觉支。余经复说。乃至想定能正通达能辩圣旨。前经亦说依初静虑。乃至无所有处能尽诸漏。如是二说岂不相违。答初经说能引发。后二经说即依彼。又初经说方便。后二经说成满。问若尔何故说俱行耶。答于前后义俱声亦转。如世尊说。曼驮多王起此想俱即便堕落。又经复说起此想俱。彼诸有情即便殒殁。又余经说。毗摩质多罗王。起此心俱寻见自身被五系系。此皆前后而说俱声。修觉支经应知亦尔。问若法初静虑为因。彼法是初静虑果耶。设法是初静虑果。彼法初静虑无因耶。答诸法初静虑为因。彼法是初静虑果。有法是初静虑果。彼法非初静虑为因。谓三界结断。及初静虑果。欲界通果心品。乃至第四静虑亦应作此问答。于无色定唯应说结断。问诸舍初静虑地心。得第二静虑地心。皆初静虑地心灭。第二静虑地心起耶。答应作四句。第一句者。谓依未至定。或静虑中间。或第二静虑近分。离梵世染。不入根本地。尔时舍初静虑地染污心。得第二静虑地不染污心。而非彼灭此起。第二句者。谓非离染次第入定时。第三句者。谓初静虑殁生第二静虑时。第四句者。谓除前相。问诸舍第二静虑地心。得初静虑地心。皆第二静虑地心灭。初静虑地心起耶。答应作四句。第一句者。谓起欲界缠退第二静虑时。第二句者。谓逆次第入定时。第三句者。谓生时。第四句者。谓除前相。问诸舍初静虑烦恼。彼得第二静虑地善法耶。答应作四句。第一句者。谓依未至定。或初静虑。静虑中间。入见道四心顷。第二句者。谓依第二第三第四静虑入见道时。及圣者离上七地染时。第三句者。谓离静虑染时。第四句者。谓除前相。问诸舍第二静虑地功德。彼得初静虑地烦恼耶。答应作四句。第一句者。谓退上地对治。及上地所修第二静虑地功德时。第二句者。谓上地殁生欲界及梵世时。第三句者。谓极光净殁生欲界及梵世时。及起下地烦恼。退第二静虑时。第四句者。谓除前相。于余定随其所应。亦应作此问答分别

说一切有部发智大毗婆沙论卷第一百六十一阿毗达磨大毗婆沙论卷第一百六十二

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    定蕴第七中得纳息第一之六

思惟何等入慈定。答与有情乐。思惟何等入悲定。答拔有情苦。思惟何等入喜定。答庆诸有情。思惟何等入舍定。答于有情舍。问此中为说等无间缘行相。为说慈等俱生行相。若说等无间缘行相者。慈等现前复何行相。若说慈等俱生行相者。何故作是说。思惟何等入慈定。乃至广说。有说。此中说等无间缘行相。问若尔慈等现前复何行相。答即作如是四种行相。谓与有情乐。乃至于有情舍。有说。此说慈等俱生行相。问若尔何故作是说。思惟何等入慈定。乃至广说。答此中说已入名入。于近说远声。如说大王从何处来。此于已来名来。如说依空三摩地入正决定。此亦已入名入。所以者何。非世第一法空三摩地相应故。如说入正性离生得现观边世俗智。此亦已入名入。所以者何。三类智忍时。方得彼智故。如说受乐受时如实知我受乐受。此亦说已受名受。所以者何。无有自知现在受故。如说断乐断苦先喜忧没。不苦不乐舍念清净。入第四静虑具足住。此亦已断名断。所以者何。离欲界染时已断苦根故。如说阿罗汉心解脱欲漏心解脱有漏无明漏。此亦已解脱名解脱。所以者何。离欲界染时已解脱欲漏故。此中亦尔已入名入是故无过。问慈无量等等无间缘。为亦但作如此行相。为更作余行相耶。答初修业者。唯作如是四种行相能引慈等。若已成满随其所欲。亦作所余苦等行相引生慈等。慈等起时唯作如前四种行相

慈断何系结。答无。悲喜舍断何系结。答无。问何故四无量不断烦恼。答行相异故。谓十九行相能断烦恼。无量非彼行相。四行相是无量。断烦恼不以此行相故。复次无量是胜解作意。唯真实作意能断烦恼。复次无量是增益作意。唯不增益作意能断烦恼。复次无量唯缘现在。要缘三世。或无为道能断烦恼。复次无量缘有情。要法想能断烦恼。复次无量缘一分境。非缘一分境道能断烦恼。复次无间道能断烦恼。无量是解脱道时得故。问若无量不能断烦恼者。经说云何通。如说慈若习。若修。若多修习。则能断嗔。悲若习若修。若多修习。则能断害。喜若习若修。若多修习。能断不乐。舍若习若修。若多修习。能断贪恚。答断有二种。一暂时断。二究竟断。契经说。暂时断此。阿毗达磨遮究竟断。如是则二说善通。如暂时断究竟断。如是有余断。无余断。有影断。无影断。有随缚断。无随缚断。摧枝叶断。拔根本断。制伏缠断。害随眠断。应知亦尔

净初静虑断何系结。答无。乃至净非想非非想处断何系结。答无。此中净初静虑等。谓根本地非近分。问何故净初静虑等不断烦恼。答下地烦恼虽所应断。而彼断已此方现前。无复可断自地烦恼。虽现可得非所对治无力能断。于上亦然故不断烦恼。问不能断上是义可尔。何故不能断于自地。答自地烦恼所系缚故。如人被缚不能自解。又与自地诸烦恼等。同一缚故无力胜彼。又自地爱所亲爱故。如人亲友虽劣不舍。又自地烦恼所陵杂故。谓展转无间而现在前故不能断。又自地善法与自地烦恼。不相忌难犹如夫妻。又如旃荼罗子与长者子交不相敬惮故不能断。又无间道能断烦恼。净根本地非无间道故不能断。又无所顾乃能断之。于自地法非无所顾故不能断。问何故有漏道不能断自地。及上地无漏道则能断耶。答以无漏道是不系法。于有漏法无非是胜是故能断。又有漏道作六行相。厌下地欣自地故唯断。下无漏道作十六行相。厌背一切地故能遍断。问有漏道亦作十六行相。何故不能遍断。答彼虽学作圣道行相。不明了故不断烦恼如师子子未能害兽

初第二第三解脱断何系结答无。问何故此三不断烦恼。答行相异故。谓若以此行相断烦恼不以此行相作前三解脱。若以此行相作前三解脱。不以此行相断烦恼。又前三解脱是胜解作意。唯真实作意能断烦恼。又前三解脱是增益作意。唯不增益作意能断烦恼。又前三解脱缘自相境。唯共相境道能断烦恼。又前三解脱唯缘现在。要缘三世。或无为道能断烦恼。又前三解脱唯缘一蕴少分。要缘五蕴四蕴。或非蕴道能断烦恼。又前三解脱缘一分境。非缘一分境能断烦恼。又无间道能断烦恼。前三解脱解脱道时得故。空无边处解脱断何系结。答或空无边处。或识无边处。或无所有处。或非想非非想处。或无。或空无边处者。谓依空无边处解脱。离空无边处染。诸无间道乃至或非想非非想处者。谓依空无边处解脱。离非想非非想处染。诸无间道或无者。谓此诸加行解脱胜进道所摄。空无边处解脱。及世俗空无边处解脱。识无边处解脱断何系结。答或识无边处。或无所有处。或非想非非想处。或无。或识无边处者。谓依识无边处解脱。离识无边处染。诸无间道。乃至或非想非非想处者。谓依识无边处解脱。离非想非非想处染。诸无间道。或无者。谓此诸加行解脱胜进道所摄。识无边处解脱。及世俗识无边处解脱。无所有处解脱。断何系结。答或无所有处。或非想非非想处。或无。或无所有处者。谓依无所有处解脱。离无所有处染诸无间道。或非想非非想处者。谓依无所有处解脱。离非想非非想处染诸无间道。或无者。谓此诸加行解脱胜进道所摄。无所有处解脱。及世俗无所有处解脱。非想非非想处解脱。灭受想解脱。断何系结。答无。以非想非非想处无无漏故。初胜处断何系结。答无。乃至第八胜处断何系结。答无。此中所以如前三解脱说。初遍处断何系结答无。乃至第十遍处。断何系结。答无。此中前八如八胜处。后二随应亦如前说

法智断何系结。答或欲界。或色界。或无色界。或无或欲界者。谓四法智随一现前。离欲界染诸无间道。或色界。或无色界者。谓灭道法智随一现前离色界。或无色界染诸无间道。或无者。谓此诸加行解脱胜进道所摄。法智类智断何系结。答或色界。或无色界。或无。或色界或无色界者。谓四类智随一现前离色界。或无色界染诸无间道。或无者。谓此诸加行解脱胜进道所摄。类智他心智断何系结。答无。问何故他心智不断烦恼。有说。他心智缘一物为境。非缘一物道能断烦恼。有说。他心智缘自相境。唯共相境道能断烦恼。有说。他心智缘现在。要缘三世。或无为道能断烦恼。有说。他心智但缘心心所法为境。要缘四蕴。或五蕴或无为道能断烦恼。有说。他心智唯缘他相续为境。要缘自他相续。或非相续境道。能断烦恼。有说。无间道断烦恼。他心智解脱道时得故。世俗智断何系结。答或欲界。或色界。或无色界。或无。或欲界者。谓离欲界染世俗无间道。或色界者。谓离色界染世俗无间道。或无色界者。谓离下三无色染世俗无间道。或无者。谓此诸加行解脱胜进道所摄世俗智及余欲界善世俗智。诸根本地善世俗智。并一切染污无覆无记世俗智。如世俗智。苦集灭道智空无愿无相三摩地亦尔。差别者。此诸无漏智三摩地。皆能通断九地。而不能遍断五部。于中四谛智能断九地修所断烦恼。空三摩地能断九地见苦所断。及修所断烦恼。无愿三摩地能断九地见苦集道所断及修所断烦恼。无相三摩地。能断九地见灭所断及修所断烦恼。此是无间道。与前差别。于或无中。唯有此诸加行解脱胜进道所摄非余。问若三三摩地亦能断烦恼者。契经所说当云何通。如说。苾刍我说。知故见故能尽诸漏。又说。我圣弟子。以般若剑断烦恼怨。有说唯慧能断烦恼。诸余觉分助断名断。如是说者。慧俱生品四蕴五蕴皆能断烦恼。以共相念住断烦恼故。然佛或时称赞般若。或称赞定。或称赞余。皆为饶益他有情故。慈异熟何处受。乃至广说。问何故作此论。答是作论者意欲尔故。乃至广说。复次欲止他所说故。谓或有说。诸善不善无异熟果。或复有说。诸有为法皆有异熟。或复有说。一切不善及有漏善定得异熟。为止如是种种异说。显唯不善善有漏法定有异熟。而得不定故作斯论。然此中有二种定。一异熟定二生定。异熟定者。一切不善善有漏法皆有异熟故。生定者。若彼异熟生者名或梵世等。若不生者名无处所。是谓此处略毗婆沙。慈异熟何处受。答或梵世。或极光净。或遍净。或广果。或无处所。或梵世乃至或广果者。谓四静虑慈无量异熟果生者。或无处所者。谓四静虑。慈无量异熟果堕不生者。如慈。悲舍亦尔。皆通四静虑故。喜异熟何处受。答或梵世。或极光净。或无处所。或梵世。或极光净者。谓初第二静虑。喜无量异熟果生者。或无处所者。谓初第二静虑。喜无量异熟果。堕不生者。净初静虑异熟何处受。答或梵世。或无处所。或梵世者。谓善有漏初静虑异熟果生者。或无处所者。谓善有漏初静虑异熟果。堕不生者。如净初静虑。如是净第二静虑。乃至净非想非非想处亦尔。差别者说自名。初第二解脱异熟何处受。答或梵世。或极光净。或无处所。此如喜无量说。俱在初二静虑地故。净解脱异熟何处受。答或广果。或无处所。或广果者。谓净解脱异熟果生者。或无处所者。谓净解脱异熟果。堕不生者。空无边处解脱。乃至非想非非想处解脱。异熟何处受。答或自地。或无处所。或自地者。谓四地有漏解脱。各自异熟果生者。或无处所者。谓三地无漏解脱。及四地有漏解脱。各自异熟果。堕不生者。灭受想解脱。异熟何处受。答或非想非非想处。或无处所。此如非想非非想处解脱说。初四胜处。异熟何处受。答或梵世。或极光净。或无处所。此如初第二解脱说。后四胜处。异熟何处受。答或广果。或无处所。此如净解脱说。如后四胜处。前八遍处亦尔。后二遍处。异熟何处受。答或自地。或无处所。此如净初二无色说。他心智异熟何处受。答或梵世。或极光净。或遍净。或广果。或无处所。或梵世乃至或广果者。谓四静虑有漏他心智。各自异熟果生者。或无处所者。谓无漏他心智。及有漏他心智异熟果。堕不生者。世俗智异熟何处受。答或欲界。或色界。或无色界。或无处所。或欲界乃至或无色界者。谓三界有漏善。及不善世俗智。各自异熟果生者。或无处所者。谓三界无记世俗智。及不善善有漏世俗智异熟果。堕不生者。余无漏智无异熟故此中不说

    定蕴第七中缘纳息第二之一

有八等至。谓四静虑。四无色。有三等至。谓味想应净无漏。此中前七各具三种。第八唯二。谓除无漏。如是等章及解章义既领会已。应广分别。问何故作此论。答欲止他宗显己义故。谓或有说。八等至不摄一切等至。或有说。等至唯净无漏非味相应。或有说。欲界非想非非想处亦有无漏。或有说。无成就等法。为止如是种种异执。显八等至摄一切等至乃至有成就等故作斯论。问若八等至摄一切等至者。毗奈耶说当云何通。如说。佛所入等至。一切声闻独觉尚不知其名。独觉所入等至。一切声闻不知。舍利子所入。诸余声闻不知。大目揵连所入。除舍利子。余声闻不知。何故言八等至摄一切等至耶。答一切等至无不摄在八等至中。然由种性般若有差别故。令所入出等至亦有胜劣。劣者。于胜不能测知故作是说。由此故说佛般涅槃时。入不动明等至。舍利子般涅槃时。入师子奋迅等至。大目揵连般涅槃时。入香象频申等至。尊者阿难陀般涅槃时。入旋风等至。皆由根慧有差别故。乃至般涅槃时。所入等至亦有差别。问等持等至有何差别。答有说。等持一物为体。等至五蕴为体。有说。等持一刹那。等至相续。有说。诸等持即等至。有等至非等持。谓无想等至。灭尽等至。有说。亦有等持非等至。谓不定心相应等持。由此应作四句。有等至非等持。谓二无心定。有等持非等至。谓不定心相应等持。有等至亦等持。谓一切有心定。有非等至亦非等持。谓除前相。初静虑有三种。谓味相应净无漏。味相应者。谓爱相应。爱能持心于境流注。其相顺定故独受其名。所余因缘如前已说。净谓善有漏。无漏谓圣道。问善有漏定。有垢有浊有毒有刺有漏有过失。云何名净。答虽非究竟净。而以少分净故名净。谓不杂烦恼故。烦恼相违故。引发无漏胜义净故。顺圣道故。无漏眷属故。问无漏等至是胜义。净何故不名为净。有说。应说而不说者。当知有余。有说。无漏名净。共所了知。有漏名净。非所共知。是以偏说。有说。立名依差别义。善有漏定初违染法。净义为胜故说名净。圣道断漏。无漏义胜故名无漏。如初静虑三种。乃至无所有处三种亦尔。非想非非想处唯有二种。谓除无漏。欲界有顶无圣道故。问何故彼二地无圣道耶。答非田非器。乃至广说。复次欲界非定地。非修地。非离染地。有顶味钝羸劣。要定地。修地。离染地。明利强盛乃有圣道。有说。欲界掉举增上。有顶沉寂增上。要不多掉举。不多沉寂地方有圣道。有说。欲界散乱。有顶犹豫。要寂静决定地方有圣道。有说。欲界有顶是下上边。圣道居中。不在边故。有说。欲界有顶是有根本故无圣道。谓生死树。或根在下。茎等在上。或根在上。茎等在下。欲界是喧杂根本说为下。根具五趣故。有顶是难离根本说为上。根最后离故。若依喧杂根本为生死树。则欲界为根。四静虑为茎。三无色为枝。有顶为条叶。若依难离根本。为生死树。则有顶为根。三无色为茎。四静虑为枝。欲界为条叶。故说欲界有顶为有根本。以是有根本故无有圣道

颇有成就味相应初静虑。非净无漏耶。答有。谓欲爱未尽。以下地爱未尽者。必成就上地爱。必未得上根本净无漏故。颇有成就净初静虑。非味相应无漏耶。答有。谓异生生欲界梵世。梵世爱尽以生此地或下地。而此地爱尽者。必成就此地净。必不成就此地味相应故。又以异生故不成就无漏。颇有成就无漏初静虑非味相应净耶。答有。谓圣者生梵世上。以圣者生上地必成就下地无漏。必不成就下地味相应净故。味相应已断故。净越界地舍故。问生上地者。亦成就下地通果心。何故说不成就下地净耶。答有说。无覆无记亦名为净。而此中不说者。以彼是上地果故。不名下地净。又一切地可得者此中说之。通果心无色界无。是故不说。如是说者。此中净定说有漏善。是故非难。颇有成就味相应净初静虑。非无漏耶。答有。谓异生生欲界。欲界爱尽梵世爱未尽。及生梵世梵世爱未尽。以生此地或下地而此地爱未尽者。必成就此地味相应净故。又以异生故不成就无漏。颇有成就味相应无漏初静虑。非净耶。答无。以成就此地味相应无漏。必成就此地净故。颇有成就净无漏初静虑。非味相应耶。答有。谓圣者生欲界梵世。梵世爱尽。以圣者生此地或下地而此地爱尽者。必成就此地净无漏。非味相应故。颇有成就味相应净无漏初静虑耶。答有。谓圣者生欲界。欲界爱尽。梵世爱未尽。及生梵世梵世爱未尽。以圣者生此地或下地。而下地爱尽。此地爱未尽者。必成就此地三种故。颇有不成就味相应初静虑。非净无漏耶。答有。谓圣者生欲界梵世。梵世爱尽。如是等文如本论说。随其所应与成就相违应广说。问梵世爱尽者。亦不成就净退分初静虑。此中何故不说。有说。应说而不说者。当知此义有余。有说。此中说全不成就。彼虽不成就顺退分。而成就余。是故不说。问何故净定越界地舍。非无漏耶。答净定有漏。堕在界地生上厌下。又无用故则舍无漏。虽堕地。而不堕界。生上不厌下。虽无用而不舍

颇有得味相应初静虑。非净无漏耶。答有。谓从梵世爱尽退时。及梵世上殁生欲界时。问梵世爱尽退时。亦得净退分初静虑。此中何故不说。有说。应说而不说者。当知此义有余。有说。此中说全得者。彼唯得少分。是故不说。颇有得净初静虑。非味相应无漏耶。答有。谓异生欲爱尽时。以彼离欲染第九解脱道时。得根本净初静虑故。颇有得无漏初净虑。非味相应静耶。答有。谓依静虑静虑中间。入正性离生。及得阿罗汉果时。问入正性离生者。亦得净初静虑。谓现观边世俗智。此中何故不说。有说。应说而不说者。当知有余。有说。此中说全得者。彼唯得少分。是故不说。有说。入正性离生位中多分不得。唯三刹那得。是故不说。有说。唯世第一法灭。苦法智忍生时。名入正性离生。尔时唯得无漏故不说净。问得阿罗汉果时。先已得无漏初静虑。谓入正性离生时。何故复说得无漏耶。答此文但应说入正性离生时。不应说得阿罗汉果。而作是说者。欲显先时虽得学无漏未得无学。是故复说。问若尔亦应说起梵世上缠。退阿罗汉果时。尔时还得学无漏故。答理亦应说而不说者。欲显无漏是胜功德。于胜进时显得则顺。退时显得则不顺。是故不说。问若尔得学果时。及信胜解练根作见至时。俱得胜无漏。此中何故不说。答此先是学今所得亦是学。是故不说。以是故亦不说无学练根。问得阿罗汉果时。亦得无量有漏善法。何故不说亦得净耶。有说。应说而不说者。当知有余。有说。无漏舍先得后。是故则说有漏不舍先而得后。是故不说。有说。今所得者。与先所得俱名为净。义无差别。不如学与无学有差别相。是故不说。有说虽得以不定故不说。谓生欲界梵世得阿罗汉果者得。生上地者则不得故。有说此中说一切得者。彼少分得。是故不说。颇有得味相应净初静虑非无漏耶。答有。谓梵世上殁生梵世时。以中有生时二俱得故。颇有得味相应无漏初静虑非净耶。答无。问阿罗汉起梵世缠退时。俱得二种何故言无。答应说有。即向所说者是。而言无者。当知有余。有说。先不成就今成就者。名得无漏初静虑。先已成就是故不说。有说。前已说无漏是胜功德。于胜进时显得则顺。退时显得则不顺。是故不说。颇有得净无漏初静虑。非味相应耶。答有。谓圣者欲界爱尽时。以得不还果时二俱得故。颇有得味相应净无漏初静虑耶。答无。问起梵世缠退阿罗汉果时。三种俱得何故不说。答尔时净以少分得故不说。无漏如前说

问得与成就有何差别。有说。名即差别。谓名得。名成就。有说。未得而得名得。已得而得名成就。有说。最初得名得。后数数得名成就。有说。先不成就而成就名得。先成就而成就名成就。有说。先无系属而有系属名得。先有系属而有系属名成就。有说初得名得。得已不断名成就。有说。初获名得。得已不失名成就。是故得唯在初成就。通初后得成就。是谓差别颇有舍味相应初静虑非净无漏耶。答有。谓梵世爱尽时。如是等文如本论说。随其所应与得相违应广说。问梵世爱尽时亦舍退分净。何故不说。答此中说一切舍。彼唯少分舍。是故不说。问得果练根及退位。皆有唯舍无漏初静虑非余。此中何故不说。有说。应说而不说者。当知有余。有说。此中说舍而不得者。彼舍还得。是故不说。问舍不成就有何差别。答名即差别。名舍名不成就。如是等如前得成就相违应广说

颇有退味相应初静虑。非净无漏耶。答无。以舍烦恼不名退故。颇有退净初静虑。非味相应无漏耶。答有。谓异生从欲界爱尽退时。颇有退净无漏初静虑非味相应耶。答有。谓圣者从欲界爱尽退时。颇有余退耶。答无。问起上二界缠退无学果。及从种性退时。皆有退无漏初静虑非余。此中何故不说。有说。应说而不说者。当知此义有余。有说。此中说退而不得者。彼虽退而还得。是故不说。问舍退何差别。有说。名即差别。谓名为舍。名为退。有说。舍通胜进及退时。退唯退时。有说。舍通损减及增益时。退唯损减时。有说。舍通上下时。退唯下时。有说。舍通盛衰时。退唯衰时。有说。舍通味相应等三。退唯二种除味相应。有说。舍通利钝根。退唯钝根。是谓舍退差别

应知此中有六成就。六不成就。五得三舍二退。以明初静虑味相应等三种差别。如说。初静虑乃至无所有处说亦如是。此是总说。于中差别如理应知。非想非非想处不具三种故不类显。然于所有二种亦准上应知

说一切有部发智大毗婆沙论卷第一百六十二阿毗达磨大毗婆沙论卷第一百六十三

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    定蕴第七中缘纳息第二之二

净初静虑有四种。谓顺退分。顺住分。顺胜进分。顺决择分。顺退分者。谓若住此多分退失。顺住分者。谓若住此多分不退失不胜进。顺胜进分者。谓若住此多分胜进。顺决择分者。谓若住此多分能入正性离生。复次顺退分者。与诸烦恼相陵相杂烦恼无间此现前此无间烦恼现前。顺住分者。能观下地为粗苦障而生厌背。能观自地为静妙离而乐安住。顺胜进分者。能观自地为粗苦障而生厌背。能观上地为静妙离而生欣乐。顺决择分者。即暖顶忍世第一法等。复次顺退分者。随顺烦恼。顺住分者。随顺自地。顺胜进分者。随顺上地。顺决择分者。随顺圣道。此分或作圣行相。或作余行相而向圣道趣于解脱。如初静虑乃至有顶随应亦尔

颇有净初静虑。离染故得。离染故舍。退故得。退故舍。生故得生故舍耶。答有。谓顺退分初静虑离欲界染时得。离梵世染时舍。起梵世缠退时得。起欲界缠退时舍。从上地殁生梵世时得。从梵世殁生欲界时舍。乃至有顶随应亦尔。问若欲界没生第二静虑。第二静虑殁生初静虑者。彼于初静虑何法往殁时舍。还生时不得。何法还生时得。往没时不舍。何法往没时舍。还生时得。何法往没时不舍。还生时不得耶。答彼于初静虑顺胜进分顺决择分往没时舍。还生时不得。顺退分及生得还生时得。往没时不舍。顺住分往没时舍。还生时得。除前相所余法。往没时不舍。还生时不得。问若初静虑没生第二静虑。第二静虑没生初静虑者。彼于初静虑何法往没时舍。还生时不得。何法还生时得。往没时不舍。何法往没时舍。还生时得。何法往没时不舍。还生时不得耶。答彼于初静虑。顺胜进分。顺决择分。往没时舍。还生时不得。顺退分还生时得。往没时不舍。顺住分及生得往没时舍。还生时得。除前相所余法。往没时不舍。还生时不得。如初静虑于第二静虑如是。乃至无所有处。于非想非非想处亦尔。如根本地。如是诸近分地亦应广说。颇有起第二静虑缠退。无漏初静虑耶。答有。谓无学初静虑。及上七地对治学初静虑等。颇有起第二静虑缠退。净初静虑耶。答有。谓阿罗汉所修净初静虑。及杂修净初静虑等

若修净初静虑。彼亦修无漏耶。乃至广说。修有四种。谓得修。习修。对治修。除遣修。此中前二修。谓有为善法。后二修。谓有漏法。外国师说。修有六种。谓前四。及防护修。分别修。防护修者。即是修根。如契经说。若于六根善调善覆善防善护。善修者能引后乐。分别修者即是修身。如契经说。于此身中有发毛爪齿。乃至广说。此后二修应知即是对治修除遣修摄。是故修唯有四。此中依二修作论。谓得修习修。如余处说。若修法智彼亦修类智耶。乃至广说。彼亦依二修作论。谓得修习修。余处复说。若道过去彼道一切已修已安耶。乃至广说。彼亦依二修作论。谓得修习修。如余处说。若修身彼修戒耶。乃至广说。彼依二修作论。谓对治修除遣修。余处复说。若修眼根彼修耳根耶。乃至广说。彼亦依二修作论。谓对治修除遣修。如余处说。若修空三摩地。彼亦修无愿三摩地耶。乃至广说。余处复说。若修身念住。彼亦修受念住耶。乃至广说。彼亦皆依二修作论。谓得修习修。如余处说。若修无常想。彼思惟无常想耶。乃至广说。有说。彼依得修作论。有说。彼依习修作论。有说。彼依二修作论。谓得修习修。如余处说。云何应修法。谓善有为法。此法虽复具四修义。而彼但依二修作论。谓得修习修。由此义故应作四句。有法有前二修无后二修。谓有为无漏法。有法有后二修无前二修。谓染污无覆无记法。有法具有四修。谓善有漏法。有法俱无四修。谓无为法。问何故名修。答遍修故名修。数习故名修。熏故名修。学故名修。令光净故名修。应知此中现在习修所显。未来得修所显。复次现在习故名修。未来得故名修。复次现在受用故名修。未来引发故名修。复次现在办事故名修。未来与欲故名修。复次现在身中故名修。未来得自在故名修。复次现在现前故名修。未来成就故名修。问何故已得善法现在前时不修未来耶。答已衰歇故。已受用故。已作事故。已与果故。复次已修故。已息故。势用减故。复次已得法现前受用时。唯有渐尽更无余势。云何能修未来。如人受用先所积财。唯有渐减更无增益。复次作功用起者能修未来。非起曾得法。须作功用故不修未来。复次若已得法现在前。复能修未来者。则佛般涅槃时。现起一切静虑解脱等持等至。尔时亦应更修未来。如此则尽智时。应不具得一切功德。云何得名所作究竟。勿有此过故已得法现在前时。不修未来诸余功德。若修净初静虑。彼亦修无漏耶。设修无漏初静虑。彼亦修净耶。答应作四句。有修净初静虑。非无漏。谓已得净初静虑现在前。若未得净初静虑现在前。而不修无漏。若未得非初静虑世俗智现在前。而修净初静虑非无漏。已得净初静虑现在前者。谓异生及圣者。或学或无学。或声闻。或独觉。或如来。或为现法乐住故。或为观本所作故。或为游戏功德故。或为受用圣财故。起曾得世俗初静虑现在前时。彼势分尚不及自第二刹那。况能修余未来功德。然现前位即是习修故。得名修净初静虑。若未得净初静虑现在前而不修无漏者。谓异生离欲界染。若最后解脱道。起根本初静虑现在前时。即异生为离初静虑染。依初静虑为加行道时。即异生依初静虑引发五通。诸加行道五无间道三解脱道时。即异生依初静虑起四无量。初二解脱。前四胜处。不净观。念住。三义观。暖顶忍世第一法。有说。亦起持息念时。如是等时。虽起未曾得净初静虑。而不修无漏。若未得非初静虑。世俗智现在前而修净初静虑。非无漏者。此中余地以智名说即未至定静虑中间。谓异生离欲界染即依未至定。起第九解脱道时。即异生为离初静虑染。依未至定起加行道时。即异生已离欲染。依未至定起三无量。初二解脱。前四胜处。不净观。持息念。念住。三义观时。即异生为离初静虑染。依静虑中间起加行道时。即异生依静虑中间起三无量。初二解脱。前四胜处。不净观。持息念。念住。三义观时。如是等时。起未曾得非初静虑世俗智现在前。而修净初静虑非无漏。有修无漏初静虑非净。谓已得无漏初静虑现在前。若未得无漏初静虑现在前。而不修净。若未得非初静虑世俗智。及未得非初静虑无漏智。彼现在前而修无漏初静虑非净。已得无漏初静虑现在前者。谓诸圣者或学。乃至或如来。或为现法乐住故。乃至或为受用圣财故。起曾得无漏初静虑现在前时。彼势分尚不及自第二刹那。况能修余未来功德。然现前位即是习修故。得名修无漏初静虑。若未得无漏初静虑现在前。而不修净者。谓依初静虑入正性离生。苦集灭现观各三心顷。道现观四心顷。圣者依初静虑离初静虑乃至无所有处染。九无间道。九解脱道时。及离非想非非想处染。九无间道。八解脱道时。信胜解依初静虑练根作见至。无间道。解脱道时。有说。除解脱道时。以此时亦修世俗道故。如是说者。尔时唯修无漏道。以同见道得果故。时解脱阿罗汉。依初静虑练根作不动。九无间道。八解脱道时。于如是时起未曾得无漏。初静虑现在前而不修净。若未得非初静虑世俗智现在前。而修无漏初静虑。非净者。此中余地以智名说即从第二静虑近分。乃至非想非非想处。谓圣者以世俗道离初静虑染。若即第二静虑近分为加行。彼加行道。九无间道。九解脱道时。即圣者依第二静虑近分起三无量。初二解脱。前四胜处。不净观。持息念。念住。三义观时。即圣者依第二静虑。为离第二静虑乃至非想非非想处染。若世俗为加行。彼加行道时。依第二静虑。信胜解练根作见至。时解脱练根作不动。若世俗为加行。彼加行道时。杂修第二静虑中间心时。即圣者依第二静虑。引发五通诸加行道。五无间道。二解脱道。及世俗他心智通解脱道时。即圣者依第二静虑。起四无量。初二解脱。前四胜处。不净观。世俗念住。三义观七处善。有说。亦起持息念时。依第二静虑起无碍解。及世俗无碍解增长时。依第二静虑。起空空无愿无愿无相无相。及增长时。即圣者以世俗道离第二静虑染。若即第三静虑近分为加行。彼加行道。九无间道。九解脱道时。即圣者依第三静虑近分。起三无量。不净观。持息念。念住三义观时。即圣者依第三静虑。为离第三静虑。乃至非想非非想处染。若世俗为加行。彼加行道时。依第三静虑信胜解练根作见至。乃至起空空无愿无愿无相无相。及增长时。广如第二静虑说。差别者除解脱胜处喜无量。余皆如前。即圣者以世俗道。离第三静虑染。若即第四静虑近分为加行。彼加行道。九无间道。九解脱道时。即圣者依第四静虑近分。起三无量。净解脱。后四胜处。前八遍处。不净观。念住三义观时。即圣者依第四静虑。为离第四静虑。乃至非想非非想处染。若世俗为加行。彼加行道时。依第四静虑信胜解练根作见至。时解脱练根作不动。若世俗为加行。彼加行道时。杂修第四静虑中间心时。即圣者依第四静虑。引发五通诸加行道。五无间道。二解脱道。及世俗他心智通解脱道时。即圣者依第四静虑。起三无量。净解脱。后四胜处。前八遍处。不净观。世俗念住。三义观。七处善时。依第四静虑。起无碍解。及世俗无碍解增长时。起无诤愿智边际定。及增长时。依第四静虑。起空空无愿无愿无相无相。及增长时。即圣者以世俗道。离第四静虑染。若即空无边处近分为加行。彼加行道。九无间道九解脱道时。即圣者依空无边处。为离空无边处。乃至非想非非想处染。若世俗为加行。彼加行道时。依空无边处。时解脱阿罗汉练根作不动。若世俗为加行。彼加行道时。即圣者起空无边处。世俗解脱遍处。世俗念住时。依空无边处起二无碍解。及世俗无碍解增长时。依空无边处。起空空无愿无愿无相无相及增长时。即圣者以世俗道。离空无边处染。若即识无边处近分为加行。彼加行道。九无间道。九解脱道时。即圣者依识无边处。为离识无边处。乃至非想非非想处染。若世俗为加行。彼加行道时。余广如空无边处说。即圣者以世俗道。离识无边处染。若即无所有处近分为加行。彼加行道。九无间道。九解脱道时。即圣者依无所有处。为离无所有处。及非想非非想处染。若世俗为加行。彼加行道时。余亦广如空无边处说。差别者除遍处。即圣者以世俗道。离无所有处染。若即非想非非想处近分为加行。彼加行道。九无间道。九解脱道时。即圣者依非想非非想处。为离非想非非想处染。加行道时。时解脱阿罗汉练根作不动。以非想非非想处为加行。彼加行道时。即圣者起非想非非想解脱念住时。依非想非非想处。起二无碍解。空空。无愿无愿。无相无相。及增长时。起入灭定想微细心时。于如是时起未曾得。非初静虑世俗智现在前。而修无漏初静虑。非净及未得非初静虑无漏智现在前。而修无漏初静虑。非净者此中余地以智名说。即从未至定除初静虑乃至无所有处。谓已离欲染依未至定入正性离生。道类智时依未至定离初静虑。乃至无所有处染。一切无间解脱道时。离非想非非想处染。九无间道。八解脱道时。已离欲染信胜解。依未至定练根作见至。无间解脱道时。时解脱阿罗汉。依未至定练根作不动。九无间道。八解脱道时。依静虑中间入正性离生。苦集灭现观。各三心顷。道现观四心顷。依静虑中间。离初静虑。乃至无所有处染。一切无间解脱道时。离非想非非想处染。九无间道。八解脱道时。依静虑中间信胜解练根作见至。无间解脱道时。时解脱阿罗汉练根作不动。九无间道。八解脱道时。依第二静虑入正性离生。苦集灭现观。各三心顷。道现观四心顷。依第二静虑。离第二静虑。乃至无所有处染。若无漏为加行。一切加行无间解脱道时。离非想非非想处染。若无漏为加行。诸加行道。九无间道。八解脱道时。依第二静虑。信胜解练根作见至。若无漏为加行。彼加行无间解脱道时。时解脱阿罗汉练根作不动。若无漏为加行。彼加行道。九无间道。八解脱道时。杂修第二静虑初后心时。依第二静虑起无漏他心智通。无漏念住。及无漏二无碍解增长时。如依第二静虑。如是依第三静虑。依第四静虑。广说亦尔。差别者即离彼上染。依空无边处离空无边处。乃至无所有处染。若无漏为加行。一切加行无间解脱道时。离非想非非想处染。若无漏为加行。彼加行道。九无间道。八解脱道时。依空无边处。时解脱阿罗汉练根作不动。若无漏为加行。彼加行道。九无间道。八解脱道时。起无漏空无边处解脱无漏念住。及无漏二无碍解增长时。如依空无边处。如是依识无边处。依无所有处亦尔。差别者即离彼上染。于如是时起未曾得。非初静虑无漏智现在前。而修无漏初静虑非净。有修净初静虑亦无漏。谓未得净初静虑现在前。而修无漏若未得无漏初静虑现在前。而修净若未得非初静虑世俗智无漏智彼现在前。而修净初静虑及无漏。若未得净初静虑现在前而修无漏者。谓圣者以世俗道离欲界染。最后起根本地解脱道时。即圣者依初静虑为离初静虑乃至非想非非想处染。若世俗为加行。彼加行道时依初静虑信胜解练根作见至。时解脱练根作不动。若世俗为加行。彼加行道时。杂修初静虑中间心时。即圣者依初静虑。引发五通诸加行道。五无间道。二解脱道。及世俗他心智通解脱道时。即圣者依初静虑起四无量。初二解脱。前四胜处。不净观。世俗念住。三义观。七处善。有说。亦起持息念时。依初静虑起无碍解。及世俗无碍解增长时。依初静虑起空空无愿无愿无相无相。及增长时。于如是时起未曾得。净初静虑现在前而修无漏。若未得无漏初静虑现在前。而修净者。谓依初静虑入正性离生。苦集灭现观各一心顷。若以无漏道离欲界染。最后起根本地解脱道时。依初静虑为离初静虑。乃至非想非非想处染。若无漏为加行。彼加行道时。依初静虑得阿罗汉果。初尽智起时。依初静虑信胜解练根作见至。若无漏为加行。彼加行道时。时解脱阿罗汉练根作不动。若无漏为加行。彼加行道及最后解脱道时。杂修初静虑初后心时。依初静虑起无漏他心智通。无漏念住无漏无碍解增长时。于如是时起未曾得。无漏初静虑现在前。而修净。若未得非初静虑世俗智现在前。而修净初静虑及无漏者。此中余地以智名说。即未至定静虑中间。谓圣者以世俗道离欲界染。即依未至定起最后解脱道时。依未至定为离初静虑。乃至非想非非想处染。若世俗为加行。彼加行道时。依未至定已离欲染。信胜解练根作见至。时解脱练根作不动。若世俗为加行。彼加行道时。已离欲染圣者。依未至定起三无量。初二解脱。前四胜处。不净观。持息念。世俗念住。三义观。七处善。起无碍解。及世俗无碍解增长时。起空空无愿无愿无相无相。及增长时。即圣者依静虑中间。为离初静虑。乃至非想非非想处染。若世俗为加行。彼加行道时。依静虑中间。信胜解练根作见至。时解脱练根作不动。若世俗为加行。彼加行道时。即圣者依静虑中间。起三无量。初二解脱。前四胜处。不净观。持息念。世俗念住。三义观。七处善。起无碍解。及世俗无碍解增长时。起空空无愿无愿无相无相。及增长时。于如是时起未曾得。非初静虑世俗智现在前。而修净初静虑及无漏。及未得非初静虑无漏智现在前。而修净初静虑及无漏者。此中余地以智名说。即从未至定除初静虑。乃至无所有处。谓以无漏道离欲界染。即依未至定起最后解脱道时。依未至定为离初静虑。乃至非想非非想处染。若无漏为加行。彼加行道时。依未至定得阿罗汉果。初尽智起时。依未至定已离欲染。信胜解练根作见至。若无漏为加行。彼加行道时。时解脱练根作不动。若无漏为加行。彼加行道。及最后解脱道时。已离欲染圣者。依未至定起无漏念住。及无漏无碍解增长时。依静虑中间入正性离生。苦集灭现观各一心顷。依静虑中间为离初静虑。乃至非想非非想处染。若无漏为加行。彼加行道时。依静虑中间得阿罗汉果。初尽智起时。依静虑中间信胜解练根作见至。若无漏为加行。彼加行道时。时解脱练根作不动。若无漏为加行。彼加行道。及最后解脱道时。依静虑中间起无漏念住。及无漏无碍解增长时。依第二静虑入正性离生。苦集灭现观各一心顷。依第二静虑。得阿罗汉果初尽智起时。依第二静虑时解脱练根作不动。最后解脱道时。如说。依第二静虑。依第三第四静虑亦应如是说。依空无边处得阿罗汉果。初尽智起时。依空无边处时解脱练根作不动。最后解脱道时。如说。依空无边处。依识无边处。无所有处。亦应如是说。于如是时起未曾得。非初静虑无漏智现在前。而修净初静虑及无漏

说一切有部发智大毗婆沙论卷第一百六十三阿毗达磨大毗婆沙论卷第一百六十四

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    定蕴第七中缘纳息第二之三

有不修净初静虑亦非无漏。谓已得非初静虑世俗智无漏智现在前。若未得非初静虑世俗智无漏智。彼现在前而不修净初静虑及无漏。若一切染污心。无记心现在前。若住无想定灭尽定。生无想天。已得非初静虑世俗智现在前者。此中余地以智名说。即从欲界未至定除初静虑。乃至非想非非想处。谓此诸地曾得世俗功德现在前时。彼势分尚不及自第二刹那。况能修余未来功德。又非初静虑故于净无漏初静虑俱无修义。已得非初静虑无漏智现在前者。此中余地亦以智名说。即从未至定除初静虑乃至无所有处。谓此诸地曾得无漏功德现在前时。彼势分尚不及自第二刹那。况能修余未来功德。又非初静虑故。于净无漏初静虑俱无修义。若未得非初静虑世俗智现在前而不修净初静虑及无漏者。此中余地亦以智名说。即从欲界未至定。除初静虑乃至非想非非想处。谓异生起欲界未曾得。不净观。持息念。念住。三义观。及余闻思所成慧。现在前时。异生离欲界染。诸加行道。九无间道。八解脱道时。即异生未离欲染。依未至定起三无量。初二解脱。前四胜处。不净观。持息念。念住。三义观。暖顶忍世第一法时。已离欲染依未至定。起暖顶忍世第一法时。依静虑中间。起暖顶忍世第一法时。即异生依第二静虑近分为加行。离初静虑染。彼加行道。九无间道。九解脱道时。即异生依第二静虑。引发五通诸加行道。五无间道。三解脱道时。起四无量。初二解脱。前四胜处。不净观。念住。三义观。暖顶忍世第一法。有说。亦起持息念时。即异生离第二静虑染。一切加行无间解脱道时。即异生依第三静虑。引发五通诸加行道。五无间道。三解脱道时。起三无量。不净观。念住。三义观。暖顶忍世第一法。有说。亦起持息念时。即异生离第三静虑染。一切加行无间解脱道时。即异生依第四静虑。引发五通诸加行道。五无间道。三解脱道时。起三无量。净解脱。后四胜处。前八遍处。不净观。念住。三义观。[熛-示+大]顶忍世第一法时。即异生离第四静虑染。一切加行无间解脱道时。即异生起空无边处。解脱遍处。及念住时。即异生离空无边处。识无边处。无所有处染。一切加行无间解脱道时。即异生起识无边处。无所有处。非想非非想处。解脱。念住。及识无边处。遍处时。若诸圣者起欲界未曾得。不净观。持息念。念住。三义观。及余闻思所成慧。现在前时。即圣者以世俗道离欲界染。若世俗为加行。诸加行道。九无间道。八解脱道时。以无漏道离欲界染。若世俗为加行。彼加行道时未离欲染。信胜解练根作见至。若世俗为加行。彼加行道时。即圣者未离欲染依未至定。起三无量。初二解脱。前四胜处。不净观。持息念。世俗念住。三义观。七处善时起入灭定微微心时。于如是时起未曾得非初静虑世俗智现在前。不修净初静虑及无漏。若未得非初静虑无漏智现在前。而不修净初静虑及无漏者。此中余地亦以智名说。谓未离欲染入正性离生四谛现观各四心顷。已离欲染依未至定入正性离生。苦集灭现观各四心顷。道现观三心顷。以无漏道离欲界染若无漏为加行。诸加行道。九无间道。八解脱道时。未离欲染信胜解练根作见至。若无漏为加行。彼加行无间解脱道时。未离欲染起无漏念住时。于如是时起未曾得。非初静虑无漏智现在前。不修净初静虑及无漏。若一切染污心现在前者。谓三界烦恼随烦恼相应心。以彼顺退体性沉重懈怠相应。要顺胜进体性轻举精进相应方能修故。一切无记心现在前者。谓三界无覆无记心。以彼不坚不住不实其性羸劣如朽败种。要坚住实其性强盛方能修故。若住无想定灭尽定者。以彼无心要由有心方能修故。生无想天者。有说。彼天尽众同分善心不起。有说。彼天善心虽起而非修所依故无修义。此中但说生在修地而不修者。然生余处亦有不修。易知故不说。如说。初静虑第二第三静虑说亦如是。以此诸地于离下地染最后解脱道时。皆有入根本地有不入故

若修净第四静虑。彼亦修无漏耶。设修无漏第四静虑。彼亦修净耶。答应作四句。有修净第四静虑非无漏。谓已得净第四静虑现在前。若未得净第四静虑现在前。而不修无漏。已得净第四静虑现在前者。谓异生及圣者。或学乃至或如来。为现法乐住等故。起曾得世俗第四静虑现在前时。彼势分尚不及自第二刹那。况能修余未来功德。然现前位即是习修故。得名修净第四静虑。若未得净第四静虑现在前。而不修无漏者。谓异生离第三静虑染。最后解脱道。及为离第四静虑染。若第四静虑为加行。彼加行道时。即异生依第四静虑。引发五通诸加行道。五无间道。三解脱道时。起三无量。净解脱。后四胜处。前八遍处。不净观。念住三义观。暖顶忍世第一法时。于如是时起未曾得。净第四静虑现在前。而不修无漏。有修无漏第四静虑非净。谓已得无漏第四静虑现在前。若未得无漏第四静虑现在前而不修净。若未得非第四静虑世俗智。及未得非第四静虑无漏智。彼现在前而修无漏第四静虑非净。已得无漏第四静虑现在前者。谓诸圣者。或学乃至或如来为现法乐住等故。起曾得无漏第四静虑现在前时。彼势分尚不及自第二刹那。况能修余未来功德。然现前位即是习修故。得名修无漏第四静虑。若未得无漏第四静虑现在前。而不修净者。谓依第四静虑入正性离生。苦集灭现观各三心顷。道现观四心顷。圣者依第四静虑离第四静虑。乃至无所有处染。一切无间解脱道时。离非想非非想处染。九无间道八解脱道时依第四静虑信胜解练根作见至。无间解脱道时。时解脱阿罗汉练根作不动。九无间道八解脱道时。于如是时起未曾得无漏第四静虑现在前而不修净。若未得非第四静虑世俗智现在前。而修无漏第四静虑非净者。此中余地以智名说。即从未至定除第四静虑。乃至非想非非想处。谓圣者依未至定。为离第四静虑。乃至非想非非想处染。若世俗为加行。彼加行道时。依未至定已离第三静虑染。信胜解练根作见至。时解脱练根作不动。若世俗为加行。彼加行道时已离第三静虑染。圣者依未至定。起三无量。初二解脱。前四胜处。不净观。持息念。世俗念住。三义观。七处善时。起无碍解及世俗无碍解增长时。起空空无愿无愿无相无相。及增长时。即圣者依初静虑为离第四静虑。乃至非想非非想处染。若世俗为加行。彼加行道时。依初静虑已离第三静虑染。信胜解练根作见至。时解脱练根作不动。若世俗为加行。彼加行道时。杂修初静虑中间心时。已离第三静虑染。圣者依初静虑引发五通诸加行道五无间道。二解脱道。及世俗他心智通解脱道时。即彼依初静虑起四无量。初二解脱。前四胜处。不净观。世俗念住。三义观。七处善。有说。亦起持息念时。起无碍解及世俗无碍解增长时。起空空无愿无愿无相无相。及增长时。即圣者依静虑中间。为离第四静虑。乃至非想非非想处染。若世俗为加行。彼加行道时。依静虑中间已离第三静虑染。信胜解练根作见至。时解脱练根作不动。若世俗为加行。彼加行道时。已离第三静虑染。圣者依静虑中间。起三无量。初二解脱。前四胜处。不净观。持息念。世俗念住。三义观。七处善时。起无碍解及世俗无碍解增长时。起空空无愿无愿无相无相及增长时。如说。依初静虑。如是依第二静虑。第三静虑说亦尔。差别者依第三静虑除喜无量。初二解脱。前四胜处。余皆如前说。即圣者以世俗道离第四静虑染。若即以空无边处近分为加行。一切加行无间解脱道时。即彼以世俗道。离空无边处。识无边处。无所有处染。若世俗为加行。一切加行无间解脱道时。即彼依无色定。以无漏道离四无色染。若世俗为加行。彼加行道时依无色定。时解脱阿罗汉练根作不动。若世俗为加行。彼加行道时。即圣者起无色世俗解脱及后二遍处时。即彼依无色定。起世俗念住。二无碍解。及世俗二无碍解增长时。起空空无愿无愿无相无相及增长时。起入灭定想微细心时。于如是时起未曾得。非第四静虑世俗智现在前。而修无漏第四静虑。非净及未得非第四静虑无漏智现在前。而修无漏第四静虑。非净者此中余地以智名说。即从未至定除第四静虑乃至无所有处。谓依未至定离第四静虑。乃至无所有处染。若无漏为加行。一切加行无间解脱道时。离非想非非想处染。若无漏为加行。彼加行道。九无间道。八解脱道时。依未至定已离第三静虑染。信胜解练根作见至。若无漏为加行。彼加行无间解脱道时。时解脱阿罗汉练根作不动。若无漏为加行。彼加行道九无间道。八解脱道时。即圣者已离第三静虑染。依未至定起无漏念住无漏无碍解增长时。即圣者依初静虑。离第四静虑。乃至无所有处染。若无漏为加行。一切加行无间解脱道时。离非想非非想处染。若无漏为加行。彼加行道。九无间道。八解脱道时。依初静虑已离第三静虑染。信胜解练根作见至。若无漏为加行。彼加行无间解脱道时。时解脱阿罗汉练根作不动。若无漏为加行。彼加行道。九无间道。八解脱道时。杂修初静虑初后心时。即圣者已离第三静虑染。依初静虑起无漏他心智通。无漏念住。及无漏无碍解增长时。静虑中间如未至定说。第二第三静虑如初静虑说。即圣者依空无边处。离空无边处。乃至无所有处染。若无漏为加行。一切加行无间解脱道时。离非想非非想处染。若无漏为加行。彼加行道。九无间道。八解脱道时。依空无边处时解脱阿罗汉练根作不动。若无漏为加行。彼加行道。九无间道。八解脱道时。起无漏空无边处解脱。依空无边处。起无漏念住。及无漏二无碍解增长时。如说。依空无边处。如是依识无边处。无所有处亦尔。差别者。即离彼上染。于如是时。起未曾得非第四静虑无漏智现在前。而修无漏第四静虑非净

有修净第四静虑亦无漏。谓未得净第四静虑现在前而修无漏。若未得无漏第四静虑现在前而修净。若未得非第四静虑无漏智现在前。而修净第四静虑。及无漏。未得净第四静虑现在前而修无漏者。谓圣者以世俗道离第三静虑染。最后解脱道时。即彼依第四静虑。为离第四静虑。乃至非想非非想处染。若世俗为加行。彼加行道时依第四静虑。信胜解练根作见至。时解脱练根作不动。若世俗为加行。彼加行道时。杂修第四静虑中间心时。即圣者依第四静虑。引发五通。诸加行道。五无间道。二解脱道。及世俗他心智通解脱道时。即圣者依第四静虑。起三无量净解脱。后四胜处。前八遍处。不净观。世俗念住。三义观。七处善时。依第四静虑起无碍解。及世俗无碍解增长时起无诤愿智边际定。及增长时。依第四静虑起空空无愿无愿无相无相。及增长时。于如是时起未曾得净第四静虑现在前。而修无漏。若未得无漏第四静虑现在前而修净者。谓依第四静虑入正性离生。苦集灭现观各一心顷。依第四静虑。为离第四静虑。乃至非想非非想处染。若无漏为加行。彼加行道时。依第四静虑得阿罗汉果。初尽智起时。依第四静虑。信胜解练根作见至。若无漏为加行。彼加行道时。时解脱阿罗汉练根作不动。若无漏为加行。彼加行道。及最后解脱道时。杂修第四静虑初后心时。依第四静虑。起无漏他心智通。无漏念住。及无漏无碍解增长时。于如是时起未曾得无漏第四静虑现在前而修净。若未得非第四静虑无漏智现在前。而修净第四静虑及无漏者。此中余地以智名说。即从未至定除第四静虑。乃至无所有处。谓依未至定。乃至第三静虑。离第三静虑染。最后解脱道时。即依彼地得阿罗汉果初尽智时。及依彼地时解脱阿罗汉。练根作不动。最后解脱道时。依无色定得阿罗汉果初尽智时。即依彼地。时解脱阿罗汉练根作不动。最后解脱道时。于如是时起未曾得。非第四静虑无漏智现在前而修净。第四静虑。及无漏

有不修净第四静虑。亦非无漏。谓已得非第四静虑。世俗智无漏智现在前。若未得非第四静虑。世俗智。无漏智。彼现在前而不修净第四静虑及无漏。若一切染污心无记心现在前。若住无想定灭尽定生无想天。已得非第四静虑世俗智现在前者。此中余地以智名说。即从未至定除第四静虑。乃至非想非非想处。谓此诸地曾得世俗功德现在前时。彼势分尚不及自第二刹那。况能修余未来功德。又非第四静虑。故于净无漏第四静虑俱无修义。已得非第四静虑无漏智现在前者。此中亦以智名而说余地。即从未至定除第四静虑。乃至无所有处。谓此诸地曾得无漏功德现在前时。彼势分尚不及自第二刹那。况能修余未来功德。又非第四静虑。故于净无漏第四静虑俱无修义

若未得非第四静虑世俗智现在前而不修净第四静虑及无漏者。此中亦说余地名智。即从欲界除第四静虑乃至非想非非想处。谓异生起欲界未曾得不净观。持息念。念住三义观。及余闻思所成慧现在前时。即异生离欲界染。一切加行无间解脱道时。即异生依未至定起三无量。初二解脱。前四胜处。不净观。持息念。念住。三义观。暖顶忍世第一法时。即异生依初静虑。为离初静虑染。起加行道时依初静虑引发五通。诸加行道。五无间道。三解脱道时。起四无量。初二解脱。前四胜处。不净观。念住。三义观。暖顶忍世第一法。有说。亦起持息念时。即异生依静虑中间。为离初静虑染。起加行道时。依静虑中间起三无量。初二解脱。前四胜处。不净观。持息念。念住。三义观。暖顶忍世第一法时。如说。依初静虑。如是依第二静虑。第三静虑说亦尔。差别者即离彼上染及第三静虑。除解脱胜处喜无量。即异生依第四静虑近分。离第三静虑染。彼加行道。九无间道。八解脱道时。即异生依空无边处近分。离第四静虑染。彼加行道。九无间道。八解脱道时。即异生依空无边处起离下地染。第九解脱道及起为离自地染加行道时起空无边处解脱。遍处。及念住时即异生依识无边处近分。离空无边处染。彼加行道。九无间道。八解脱道时。如依空无边处。如是依识无边处。无所有处亦尔。差别者无所有处除遍处。即异生依非想非非想处近分。离无所有处染。彼加行道。九无间道。八解脱道时。即异生依非想非非想处。起离下地染第九解脱道。及起非想非非想处解脱。及念住时

若圣者起欲界未曾得不净观。持息念。念住三义观。及余闻思所成慧现在前时。即彼圣者以世俗道。离欲界乃至第二静虑染。若世俗为加行。一切加行。无间解脱道时。以无漏道离欲界乃至第二静虑染。若世俗为加行。彼加行道时即彼圣者以世俗道。离第三静虑染。若世俗为加行。彼加行道九无间道。八解脱道时。以无漏道离第三静虑染。若世俗为加行。彼加行道时。未离第三静虑染。信胜解依未至定练根作见至。若世俗为加行。彼加行道时。即彼圣者未离第三静虑染。依未至定起三无量。初二解脱。前四胜处。不净观。持息念。世俗念住。三义观。七处善时。未离第三静虑染。信胜解依初静虑练根作见至。若世俗为加行。彼加行道时。即彼圣者未离第三静虑染。依初静虑引发五通。诸加行道。五无间道。二解脱道。及世俗他心智通。解脱道时。即彼依初静虑。起四无量。初二解脱。前四胜处。不净观。世俗念住。三义观。七处善。有说。亦起持息念时。未离第三静虑染。信胜解依静虑中间练根作见至。若世俗为加行。彼加行道时。即彼圣者未离第三静虑染。依静虑中间。起三无量。初二解脱。前四胜处。不净观。持息念。世俗念住。三义观。七处善时。未离第三静虑染。信胜解依第二静虑练根作见至。若世俗为加行。彼加行道时。即彼圣者未离第三静虑染。依第二静虑。引发五通诸加行道。五无间道。二解脱道。及世俗他心智通。解脱道时。即依第二静虑。起四无量。初二解脱。前四胜处。不净观。世俗念住。三义观。七处善。有说。亦起持息念时。未离第三静虑染。信胜解依第三静虑练根作见至。若世俗为加行。彼加行道时。即彼圣者未离第三静虑染。依第三静虑引发五通。诸加行道。五无间道。三解脱道。及世俗他心智通。解脱道时。即依第三静虑。起三无量。不净观。世俗念住。三义观。七处善。有说。亦起持息念时。起入灭定微微心时。于如是时起未曾得。非第四静虑世俗智现在前不修净。第四静虑及无漏及未得非第四静虑无漏智现在前而不修净。第四静虑及无漏者。此中余地亦以智名说。即从未至定。乃至第三静虑。谓依未至定。乃至第三静虑。入正性离生四谛现观。各四心顷。以无漏道离欲界染。若无漏为加行。一切加行无间解脱道时。以世俗道离欲界染。若无漏为加行。彼加行道时依未至定离初第二静虑染。若无漏为加行。一切加行无间解脱道时。离第三静虑染。若无漏为加行。彼加行道。九无间道。八解脱道时。未离第三静虑染。信胜解依未至定练根作见至。若无漏为加行。彼一切加行。无间解脱道时。即彼圣者未离第三静虑染。依未至定起无漏念住时。依初静虑离初第二静虑染。若无漏为加行。一切加行无间解脱道时。离第三静虑染。若无漏为加行。彼加行道。九无间道。八解脱道时。未离第三静虑染。信胜解依初静虑练根作见至。若无漏为加行。彼加行无间解脱道时。即彼圣者未离第三静虑染。依初静虑起无漏他心智通及无漏念住时。依静虑中间离初第二静虑染。若无漏为加行。一切加行无间解脱道时。离第三静虑染。若无漏为加行。彼加行道。九无间道。八解脱道时。未离第三静虑染。信胜解依静虑中间练根作见至。若无漏为加行。彼加行无间解脱道时。即彼圣者未离第三静虑染。依静虑中间起无漏念住时。依第二静虑离第二静虑染若无漏为加行。一切加行无间解脱道时。离第三静虑染。若无漏为加行。彼加行道。九无间道。八解脱道时。未离第三静虑染。信胜解依第二静虑练根作见至。若无漏为加行。彼加行无间解脱道时。即彼圣者未离第三静虑染。依第二静虑起无漏他心智通。及无漏念住时。依第三静虑离第三静虑染。若无漏为加行。彼加行道。九无间道。八解脱道时。未离第三静虑染。信胜解依第三静虑练根作见至。若无漏为加行。彼加行无间解脱道时。即彼圣者未离第三静虑染。依第三静虑起无漏他心智通。及无漏念住时。于如是时起未曾得。非第四静虑无漏智现在前而不修净。第四静虑及无漏若一切染污心。乃至生无想天者如前初静虑中说。如说。第四静虑乃至无所有处。说亦如是。以此诸地于离下地染最后解脱道时。皆必入根本地故。问何故依近分离欲界乃至第二静虑染最后解脱道。或即近分。或入根本。离第三静虑。乃至无所有处染。最后解脱道决定入根本地耶。答下三近分与根本地受有差别故。于求得根本地时。有即能入者。有不能入者。上五近分与根本地受无差别故。于求得根本地时定即能入。诸瑜伽师依近分地离下染者。必于自根本地生欣乐。心力能起者必即起故

说一切有部发智大毗婆沙论卷第一百六十四阿毗达磨大毗婆沙论卷第一百六十五

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    定蕴第七中缘纳息第二之四

若最初入无漏初静虑。乃至广说。初有四种。一入正性决定初。二得果初。三离染初。四转根初。此中依二初作论。谓得果及转根。得果初者。谓得阿罗汉果初尽智时。转根初者。谓时解脱阿罗汉练根作不动最后解脱道时。问何故于四初中但依二初作论。答若尔时修一切地功德者。此中依之作论。唯二初位能如是修故依作论。若最初入无漏初静虑。尔时所得诸余未来无漏心心所法。彼一切当言有寻有伺耶。答彼或有寻有伺。或无寻唯伺。或无寻无伺。有寻有伺者。谓所修未至定。及初静虑。无寻唯伺者。谓所修静虑中间。无寻无伺者。谓所修上三静虑。下三无色。若最初入无漏第二静虑。尔时所得诸余未来无漏心心所法。彼一切当言喜根相应耶。答彼或乐根相应。或喜根相应。或舍根相应。乐根相应者。谓所修第三静虑。喜根相应者。谓所修初及第二静虑。舍根相应者。谓所修未至定。静虑中间。第四静虑。下三无色。若最初入无漏第三静虑。尔时所得诸余未来无漏心心所法。彼一切当言乐根相应耶。答彼或乐根相应。或喜根相应。或舍根相应。义如前释。若最初入无漏第四静虑。尔时所得诸余未来无漏心心所法。彼一切当言舍根相应耶。答彼或乐根相应。或喜根相应。或舍根相应。义如前释。若最初入无漏空无边处。尔时所得诸余未来无漏心心所法。彼一切当言空无边处摄耶。答彼或空无边处摄。或识无边处摄。或无所有处摄。空无边处摄者。谓所修空无边处。识无边处摄者。谓所修识无边处。无所有处摄者。谓所修无所有处。若最初入无漏识无边处。尔时所得诸余未来无漏心心所法。彼一切当言识无边处摄耶。答彼或空无边处摄。或识无边处摄。或无所有处摄。义如前释。若最初入无漏无所有处。尔时所得诸余未来无漏心心所法。彼一切当言无所有处摄耶。答彼或空无边处摄。或识无边处摄。或无所有处摄。义如前释。问何故此中于静虑问相应。于无色问摄。答彼作论者意欲尔故。随彼意而作论。但不违法相便不应责。有说。于静虑无色并应俱问。而不问者当知此义有余。有说。为现种种文种种说。由种种文种种说故义则易解。有说。为现二门二略二阶二炬二明二光二种文影。如于静虑说相应。于无色亦尔。如于无色说摄。于静虑亦尔。有说。静虑粗显易见易知。故问相应。无色微细难了难觉。故但问摄。有说。静虑有种种相互不相似。故问相应。无色不尔。故但问摄。有说。静虑有种种受种种根。故问相应。无色不尔。有说。静虑有多功德多胜利。故问相应。无色不尔。有说。静虑有遍缘智。故问相应。无色但有缘自上智。故但问摄。问何故此中于静虑亦摄无色。于无色不摄静虑耶。答彼作论者意欲尔故。乃至广说。有说。于静虑无色并应俱摄。而不说摄者当知此义有余。有说。为现种种文种种说。由种种文种种说故义则易解。有说。为现二门二略二影二光。乃至广说。有说。无色依属静虑。以先得静虑后得无色故。于静虑亦摄无色。静虑不依属无色。故于无色不摄静虑。有说。于静虑亦不摄无色。以无寻无伺等言有别意故。谓无寻无伺者。唯说后三静虑。舍根相应者。唯说未至静虑中间及第四静虑。以静虑无色其相各异。虽互相修而不相摄。有说。于无色亦应摄静虑。应作是说。或未至定摄。乃至或无所有处摄。而不说者欲显无色非入静虑加行。以静虑现前不必因无色故。有说。生静虑地能起无色。生无色地。不能起静虑。有说。圣者生静虑后容生无色。生无色后无容生静虑

是故于静虑摄无色。于无色不摄静虑

味相应初静虑乃至广说。问何故作此论。答欲止譬喻者意。以彼于缘性中不明了故。说缘非实有。今欲显示诸缘自性。令知诸缘皆是实有。故作斯论。味相应初静虑。与味相应初静虑等为几缘。答与自地味相应为因等无间所缘增上。因者三因。即相应俱有同类因。等无间者。谓味相应初静虑等无间。味相应初静虑现在前。所缘者。谓味相应初静虑与味相应初静虑为所缘。增上者。谓不碍生。及唯无障。此中因缘如种子法。等无间缘如开避法。所缘缘如任杖法。增上缘如与欲法。与自地净为等无间。所缘增上等无间者。谓味相应。初静虑等无间净初静虑现在前。如爱见慢疑。上静虑者。烦恼等无间净定现在前。此则总说。若别说者。净有四种。谓顺退分。顺住分。顺胜进分。顺决择分。此中有说。味相应等无间。唯顺退分现在前。有说。亦起顺住分所缘者。谓味相应初静虑。与净初静虑为所缘。增上者。谓不碍生及唯无障。非因者。以染污法与善法非如种子法故。由此义故味相应与自地净。若总说为三缘。若别说或三或二。谓与前二分为三缘。与后二分为二缘。与自地无漏。为所缘增上。所缘者。谓与苦集类忍类智品为所缘。增上者如前说。非因者。有漏法与无漏法非如种子法故。非等无间者。烦恼等无间不起圣道现在前故。由此义故味相应与自地无漏。若总说为二缘。若别说或二或一。谓与苦集类忍智品为二缘。与灭道类忍类智品及一切法忍法智品。为一缘。与净无漏上三静虑为所缘增上。所缘者。彼缘下地味相应故。增上者。谓不碍生及唯无障故。非因缘者。染于不染非种子法故。非等无间缘者。已离下染方能起上根本地净无漏故。与余为一增上。余谓味相应上三静虑。及一切无色。增上义如前说。非因缘者。异界地法因果断故。及异类法非种子故。非等无间缘者。已离下染上地染方现前故。及相违故。非所缘者。上地烦恼。及根本无色。不缘下地有漏法故。净初静虑与净初静虑等为几缘。答与自地净为因等无间所缘增上。因者三因。即相应俱有同类因。等无间者。谓净初静虑等无间。净初静虑现在前。所缘者。谓与净初静虑为所缘。增上义如前说。此即总说。若别说者。净有四分。顺退分与顺退分为四缘。与顺住分亦尔。与余二分为三缘。除等无间。顺住分与顺住分为四缘。与顺胜进分亦尔。与顺决择分为三缘。除等无间。与顺退分为三缘。除因缘。胜非劣因故。顺胜进分与顺胜进分为四缘。与顺决择分亦尔。与顺退分。有说。但为所缘增上。顺胜进分无间顺退分不现前故。如是说者。亦现在前。是故与顺退分为三缘。除因缘。以彼劣故。与顺住分亦尔。顺决择分与顺决择分为四缘。与顺退分为所缘增上。与顺住分。有说。但为所缘增上。以顺决择分无间顺住分不现在前故。如是说者。亦现在前。是故与彼为三缘。除因缘。与顺胜进分亦尔。与自地无漏。为等无间所缘增上。等无间者。谓净初静虑等无间。无漏初静虑现在前。此但从顺决择分。有说。亦从顺胜进分。所缘者。谓与无漏初静虑为所缘。增上者如前说。非因缘者。有漏法非无漏因故。与自地味相应为等无间所缘增上。等无间者。如爱见慢疑。上静虑者净定等无间烦恼现在前。当知此从顺退分。或顺住分。起由已离未离自地染者。起自地烦恼有差别故。所缘者。味着自地净静虑故。余如前说。与净无漏第二第三静虑为等无间所缘增上。等无间者。于第二顺次入故。于第三顺起入故。当知从顺胜进分入上净非余。余如前说。与净无漏第四静虑为所缘增上。无等无间者。以极远故。余如前说。与余为一增上。余谓味相应三静虑。及一切无色。增上义如前说。是中差别者。谓与净无漏无色。非等无间者。以极远故。余如前说。问亦有等无间缘。谓初静虑善心命终生上地时。此中何故不说。答应说与彼为等无间增上。而不说者。当知义则有余。有说。此定蕴中唯说定善及定烦恼命终。结生但是生善及生烦恼。是故不说。有说。此定蕴中唯说根本善及烦恼命终。结生唯住近分不住根本。是以不说。无漏初静虑与无漏初静虑等为几缘。答与自地无漏为因等无间所缘增上。因者三因。即相应俱有同类因。所缘者。谓与道忍道智品为所缘。余说如前。此即总说。若别说者。法智品与法智品为四缘。与类智品为三缘。除所缘。类智品与类智品为四缘。与法智品为三缘。除所缘。苦集灭智品与苦集灭智品为三缘。除所缘。与道智品为四缘。道智品与道智品为四缘。与苦集灭智品为三缘。除所缘。未知当知根品与未知当知根品为四缘。与已知根品亦尔。与具知根品为三缘。除等无间。已知根品与已知根品为四缘。与具知根品亦尔。与未知当知根品为二缘。除因等无间。除因者。后生于前。生非因故。除等无间者。修道等无间。见道不现在前故。具知根品与具知根品为四缘。与未知当知根品及已知根品为二缘。除因等无间。无学法智品与学类智品为一增上。无学类智品与学法智品为一增上。是故以总说故云与自地无漏为四缘。若差别说。则有如是或四三二一。与无漏第二第三静虑。为因等无间所缘增上。以无漏法不堕界故。异地为因缘如前说。与自地净及净第二第三静虑。为等无间所缘增上。此中于自地净。有说。除顺退分与余三分为等无间。有说。唯与后二分为等无间。于上地净亦尔。如是说者。渐次入时。亦与胜进分为等无间。超越入时唯与顺决择分为等无间。问何故超越入时唯顺决择分。与无漏道互为等无间缘。余时不尔。答于超越时。唯有猛盛坚固善根。能相引发顺决择分猛盛坚固。余分不尔。与净第四静虑及净无色。为所缘增上。以初静虑类智品是无色对治故。与净无色亦为所缘。余如前说。与无漏第四静虑及无漏无色为因所缘增上。以无色道类智品亦缘初静虑类智品故。余如前说。与余为增上。余谓与一切味相应。增上义如前说。由无漏与味极相违故无等无间。贪不能缘无漏法故非所缘。无漏与染非种子法故非因。问若无漏与味极相违者。云何作增上。答于无间起虽极相违。而正生时去来无障。故得展转互为增上

味相应。第二静虑与味相应第二静虑等为几缘。答与自地味相应。为因等无间所缘增上。与净初二静虑为等无间所缘增上。与一切无漏静虑及净第三第四静虑为所缘增上。与余为一增上。余谓味相应初第三第四静虑。及一切无色。此中与净初静虑为等无间者。谓瑜伽师第二静虑净定无间。起诸烦恼。其心热恼如为火烧。遂即归投净初静虑。故契经说。宁起厌作。意俱初静虑。不起劣作意俱第二静虑。问彼起何等净初静虑。有说。起顺住分。以易起故。有说。起顺胜进分。防护上地故。又此所说与味相应初静虑为一增上

问第二静虑染心命终生初静虑。则有等无间缘。何故不说。答应说与彼为等无间增上。而不说者。当知此义有余。有说。此定蕴中唯说定烦恼命终。结生是生烦恼。是故不说。有说。此定蕴中但说根本地烦恼命终。结生唯住近分地烦恼。是故不说。余随所应如前说。净第二静虑与净第二静虑等为几缘。答与自地净为因等无间所缘增上。与一切无漏静虑及净初第三第四静虑。并自地味相应。为等无间所缘增上。与余为一增上。此亦如前随应广说。无漏第二静虑与无漏第二静虑等为几缘。答与一切无漏静虑。为因等无间所缘增上。与一切净静虑为等无间所缘增上。与净无色。为所缘增上。与无漏无色。为因所缘增上。与余为一增上。此亦随应广如前说。从第三静虑。乃至非想非非想处。有五三一二问答。广说如本论应知。问如以世俗道离第四静虑及下三无色染时。一切无间道皆缘下地。何故不说第四静虑下三无色味相应净与上地净为所缘耶。答此亦应说。而不说者。当知有余。有说。此定蕴中唯说根本地。九无间道但是近分地。是故不说。问何等无漏第三第四静虑。与净无漏无色为等无间耶。答唯类智品。问何故非法智品。有说。法智品依下缘下故。谓法智品但依欲界。但缘欲界诸行。及彼因彼灭彼对治道。净无漏无色不尔。故法智品非彼等无间缘。有说。法智品但缘欲界及彼灭道。缘欲界及彼灭道无间。不得即缘无色地境。以极远故。由此法智品非无色等无间缘。有说。无色地非法智品所依所缘及地故。谓四静虑虽非法智品所依所缘。而是法智品地。欲界虽非法智品地。而是法智品所依所缘。诸无色地无如是事。故非法智品无间所起。问何故净无漏无色。但缘下地类智品道。非法智品道耶。答法智品道非彼地对治故。问岂不法智品道亦对治彼耶。答虽对治彼而非根本亦非全。是故不说。谓虽是彼修所断法对治。而非彼见所断法对治。又虽灭道法智是彼对治。而非苦集法智。有说。类智品是彼主对治。法智品是彼客对治故非彼所缘然净无漏静虑无色或下或上无间而起。从下起者名顺次顺超。从上起者名逆次逆超同类起者名纯。异类起者名杂。地无间者名次地。有间者名超。有间唯能越于一地。是谓此处略毗婆沙

问所说超定加行云何。答修超定时。彼修定者。先起欲界善心。从此无间入有漏初静虑。次入有漏第二静虑。次第乃至入非想非非想处。从彼还入有漏无所有处。次第乃至复还入有漏初静虑。于此诸地循环修习。令善淳熟如王路已。复入无漏初静虑。次入无漏第二静虑次第乃至入无漏无所有处。从彼还入无漏。识无边处。次第乃至复还入无漏初静虑。于此诸地循环修习。令善淳熟如王路已。复入有漏初静虑。从有漏初静虑。超入有漏第三静虑。从有漏第三静虑。超入有漏空无边处。从有漏空无边处。超入有漏无所有处。从有漏无所有处。还超入有漏空无边处。从有漏空无边处。超入有漏第三静虑。从有漏第三静虑。超入有漏初静虑。于此诸地循环修习。令善淳熟如王路已。复入无漏初静虑。从无漏初静虑。超入无漏第三静虑。从无漏第三静虑。超入无漏空无边处。从无漏空无边处。超入无漏。无所有处。从无漏无所有处。还超入无漏空无边处。从无漏空无边处。超入无漏第三静虑。从无漏第三静虑超入无漏初静虑。于此诸地循环修习。令善淳熟犹如王路。齐此超定加行成满。从此复入有漏初静虑。从有漏初静虑。超入无漏第三静虑。从无漏第三静虑。超入有漏空无边处。从有漏空无边处。超入无漏无所有处。从无漏无所有处。还超入有漏空无边处。从有漏空无边处。超入无漏第三静虑。从无漏第三静虑。超入有漏初静虑。如是名为超定成满。有余师说。修超定时。先起欲界善心。从此无间入有漏初静虑。次入有漏第二静虑。次第乃至入非想非非想处。从彼还入有漏无所有处。次第乃至复还入有漏初静虑。于此诸地善串习已复入无漏初静虑。次入无漏第二静虑。次第乃至入无漏无所有处。从彼还入无漏识无边处。次第乃至复还入无漏初静虑。于此诸地善串习已。复入有漏初静虑。次入无漏第二静虑。次入有漏第三静虑。次入无漏第四静虑。次入有漏空无边处。次入无漏识无边处。次入有漏无所有处。从彼还入无漏识无边处。次第乃至复还入有漏初静虑。于此诸地善串习已。复入无漏初静虑。次入有漏第二静虑。次入无漏第三静虑。次入有漏第四静虑。次入无漏空无边处。次入有漏识无边处。次入无漏无所有处。次入非想非非想处。从彼还入无漏无所有处。次第乃至复还入无漏初静虑。于此诸地善串习已。复入有漏初静虑。从有漏初静虑。超入有漏第三静虑。从有漏第三静虑。超入有漏空无边处。从有漏空无边处。超入有漏无所有处。从有漏无所有处。还入有漏空无边处。从有漏空无边处。超入有漏第三静虑。从有漏第三静虑。超入有漏初静虑。于此诸地善串习已。复入无漏初静虑。从无漏初静虑。超入无漏第三静虑。从无漏第三静虑。超入无漏空无边处。从无漏空无边处。超入无漏无所有处。从无漏无所有处。还入无漏空无边处。从无漏空无边处。超入无漏第三静虑。从无漏第三静虑。超入无漏初静虑。于此诸地善串修习。是名超定加行成满。从此复入有漏初静虑从有漏初静虑。超入无漏第三静虑。从无漏第三静虑。超入有漏空无边处。从有漏空无边处。超入无漏无所有处。从无漏无所有处。还超入有漏空无边处。从有漏空无边处。超入无漏第三静虑。从无漏第三静虑。超入有漏初静虑。从此复入无漏初静虑。从无漏初静虑。超入有漏第三静虑。从有漏第三静虑。超入无漏空无边处。从无漏空无边处。超入有漏无所有处。从有漏无所有处。还超入无漏空无边处。从无漏空无边处。超入有漏第三静虑。从有漏第三静虑。超入无漏初静虑。如是名为超定成满。复有说者。前来所说皆是加行。从此位后自在循环超入诸定。无所挂碍乃名成满。然必不能超入第四。问何故不能超入第四。答过殑伽沙数诸佛世尊及圣弟子超入诸定法皆如是。故不应问。有说。诸超定者本应渐起。若从彼超法唯超一。势不过故。如登梯时亦应渐上。其有越者莫能越二。势不及故。有说。后起径路法皆如前故但超一。谓观行者初超定时。从五入五从四入四。支数等故易可超入。后亦如是故不超二。有说。如所缘缘故唯超一。谓观行者不念作意。于所缘缘唯能超一。问云何观行者于所缘超。答彼由不念作意以初静虑。于九地境一一别缘。于中唯能超缘一地。谓缘欲界无间能上缘初静虑。或第二静虑非余。缘初静虑无间能下缘欲界。上缘第二静虑。或第三静虑非余。缘第二静虑无间能下缘欲界。或初静虑。上缘第三静虑或第四静虑非余。缘第三静虑无间能下缘初静虑。或第二静虑。上缘第四静虑或空无边处非余。如是乃至缘非想非非想处无间能下缘识无边处。或无所有处非余。如依初定。如是依余定。随其所应于所缘缘皆应广说。如不能越二地所缘。超定亦尔。故不入第四。问若尔。何故说净解脱次起五心。净解脱心缘于欲界。第四静虑遍行随眠能缘自上乃至有顶。岂非能越二地所缘。答说不染心不能超二。彼心是染故不相违。问如苦法智缘欲界无间起苦类忍。乃至缘有顶云何说不染污心不能超二。答彼但是总缘不名为超。亦俱缘余地故是故非难

问何处能超定。答在欲界非色无色。在人趣非余趣。在三洲非北洲。男子女人俱能超定。尊者僧伽筏苏说曰。唯赡部洲唯男子能超定。余洲及女人所依劣故不能。如是说者。余洲及女人亦能超定。彼于三摩地亦得心自在故。问何等补特伽罗能超定。答是圣者非异生。是无学非学。无学中是不时解脱非时解脱。于不时解脱中。要得愿智边际定等殊胜功德然后能超。问何故唯无学不时解脱能超定耶。答要相续中无诸烦恼。于定自在乃能超定。学相续中犹有烦恼。时解脱于定不得自在故并不能超定。问何等善根无间能超定耶。答无量解脱胜处遍处诸通等善根无间皆不能超定。唯无常等行相善根无间能超。所以者何。要猛利增上善根能超定故

说一切有部发智大毗婆沙论卷第一百六十五阿毗达磨大毗婆沙论卷第一百六十六

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    定蕴第七中摄纳息第三之一

十想谓无常想。无常苦想。苦无我想。死想。不净想。厌食想。一切世间不可乐想。断想。离想。灭想。如是等章及解章义。既领会已应广分别。问何故此中先依十想作论。答彼作论者意欲尔故。随彼意欲而作斯论。但不违法相便不应责。有说。为欲分别契经义故。如契经中说。有十想无常想乃至灭想。契经虽作是说。而不广辩。今欲辩之故作斯论。问何故此中但说十想。答此不应问以是佛经所说故。佛于处处经中唯说十想。作论者于佛所说中不能增一说十一想。不能减一说于九想。所以者何。佛所说法无增减故不可增减。如无增无减无多无少无缺无长。无量无边亦尔。无量者义难测故。无边者文难了故。譬如大海无量无边。无量者深。无边者广。假使百千那庾多数诸大论师如舍利子。于佛所说二句经中造百千论。分别解释尽其觉性。亦不能穷其边量况复多耶。问置作论者。何故世尊但说十想。答所化有情齐此所说事究竟故。谓佛世尊凡所说法。皆观有情所应作事令善究竟。齐此而止不增不减。譬如良医观有病者。随应授药不增不减。佛亦如是。有说。世尊为显圣道圣道加行及圣道果故说十想。谓说无常想无常苦想苦无我想死想则显圣道。说不净想厌食想一切世间不可乐想则显圣道加行。说断想离想灭想则显圣道果。有说。世尊为显圣道圣道资粮及圣道果故说十想。此中配释如前应知。有说。世尊为显奢摩他毗钵舍那。及二果故说于十想。谓说不净想厌食想一切世间不可乐想则显奢摩他。说无常想无常苦想苦无我想死想则显毗钵舍那说断想离想灭想则显彼二果。有说。世尊为显此岸彼岸及船筏故说于十想。谓说不净想厌食想一切世间不可乐想则显此岸。说断想离想灭想则显彼岸。说无常想无常苦想苦无我想死想则显船筏。有说。世尊为显诸蕴诸界过失及彼还灭果故说十想。谓说无常想无常苦想苦无我想则显诸蕴过失。说不净想厌食想则显欲界过失。说一切世间不可乐想。则显色界过失。说死想则显无色界过失。说断想离想灭想则显彼还灭果。有说。世尊为显入正性离生离三界染及彼道果故说十想。谓说无常想无常苦想苦无我想。则显入正性离生。说不净想厌食想则显离欲界染。以欲界有淫欲及段食欲。于彼染习不能离欲界染故。说一切世间不可乐想则显离色界染。以色界有生死中最胜喜受。最胜乐受。及第四静虑最胜轻安乐。于彼耽着不能离色界染故。说死想则显离无色界染。以无色界寿量长远。于彼保着不能离无色界染故。说断想离想灭想则显彼道果。有说。世尊为显近对治所治障故说于十想。谓说无常想显近对治于诸行中我慢障。说无常苦想显近对治懈怠障。说苦无我想显近对治我见障。说不净想显近对治色贪障。说厌食想显近对治耽美食障。说一切世间不可乐想。显近对治贪着世间可爱事障。说死想显近对治恃命憍逸障。说断想显近对治诸非法障。说离想显近对治染着障。说灭想显近对治所依障。有说。世尊为显对治外道执见故说十想。谓诸外道于无常蕴中多起常执。对治彼故说无常想。彼由于蕴起常执故便计为乐。对治彼故说无常苦想。彼由于蕴执有乐故便计有我。对治彼故说苦无我想。彼由执有我故便计有净。对治彼故说不净想及厌食想。彼由执有净故便乐着生死。对治彼故说一切世间不可乐想。彼由着生死故便不求涅槃。对治彼故说断想离想灭想。彼由不求涅槃故保爱寿命。对治彼故说于死想。有说。世尊为显厌逆过失远离过失。及证离彼所得功德故说十想。谓说不净想厌食想一切世间不可乐想则显厌逆过失。说无常想无常苦想苦无我想死想则显远离过失。说断想离想灭想。则显证离彼所得功德。有说。世尊为显暂时断究竟断故说十想。谓说不净想厌食想一切世间不可乐想显暂时断。说余七想显究竟断。如暂时断究竟断。如是有影断。无影断。有余断。无余断。有缚断。无缚断。摧枝叶断。拔根本断。制伏缠断。害随眠断亦尔。有说。世尊为显离三界染加行。离三界染道。离三界染故说十想。谓说不净想厌食想显离欲界染加行。说无常想显离欲界染道。说断想显离欲界染。说一切世间不可乐想显离色界染加行。说无常苦想。显离色界染道。说离想显离色界染。说死想显离无色界染加行。说苦无我想显离无色界染道。说灭想显离无色界染

如是十想界分别者。不净想厌食想一切世间不可乐想欲色界。余三界及非界

地者。不净想厌食想在十地。谓欲界。静虑中间。四静虑。及四近分。一切世间不可乐想在七地。谓欲界。未至。静虑中间。根本四静虑。余七想有漏者。在十一地。谓欲界。未至。静虑中间。根本四静虑。四无色。无漏者。在九地。谓未至。静虑中间。根本四静虑。下三无色。所依者。不净想厌食想一切世间不可乐想依欲界。余依三界

行相者无常想作无常行相。无常苦想作苦行相。苦无我想作无我行相。不净想作不净行相。厌食想作厌逆行相。一切世间不可乐想作不可乐行相。死想作死行相。断想作断行相。离想作离行相。灭想作灭行相。有说。后三一切皆作灭静妙离四种行相。问死想亦通无漏。云何圣道作死行相耶。答死为所缘故名死想。然彼还作无常行相。问若尔死想无常想有何差别。有说。观察诸行最后无常此想名死想。观察诸行刹那无常此想名无常想。有说。观察有执受诸行无常此想名死想。观察有执受无执受诸行无常此想名无常想。有说。于有情处转名死想。于法处转名无常想。问若厌食想作厌逆行相者。彼不净想亦作厌逆行相。此二有何差别。答不净想厌逆于色。厌食想厌逆于味。有说。不净想对治淫贪。厌食想对治食贪。诸有欲令十六行相外无圣道者。彼说无漏断离灭想。即作灭谛四种行相。诸有欲令十六行相外有圣道者。彼说无漏断想即作断行相。乃至无漏灭想即作灭行相

所缘者无常想。有漏者。三谛为所缘。无漏者。苦谛为所缘。无常苦想有漏者。二谛为所缘。无漏者。苦谛为所缘。苦无我想有漏者。一切法为所缘。无漏者。苦谛为所缘。然佛此中所说三想唯说缘苦谛非余。不净想眼识为加行所引发故。色处为所缘。厌食想厌段食故。香味触处为所缘。有说。此想亦眼识为加行所引发故。但以色处为所缘。一切世间不可乐想。有说。唯缘欲界。以说此想对治缘世间可爱事贪欲。此贪欲唯在欲界故。此中有说。唯缘世间可爱事。有说。亦缘可爱事所起贪欲。问若唯缘欲界者。云何名一切世间不可乐想。答一切有二种。一一切一切。二少分一切。此中说少分一切是故无过。有说。此想通缘三界。以名一切世间不可乐想故。问若尔何故说此想对治世间。可爱事贪欲。彼贪欲唯在欲界故。答彼经显示初起趣入加行故作是说

若已数习成满者。亦能断色无色界贪欲是故无过。死想有说。以最后刹那命根为所缘。有说。以最后刹那命根无常为所缘。有说。以最后刹那命根俱生五蕴为所缘。有说。以最后刹那命根俱生五蕴无常为所缘。有说。以一切众同分命根为所缘。有说。以一切众同分命根无常为所缘。有说。以一切众同分命根。俱生五蕴为所缘。有说。以一切众同分命根。俱生五蕴无常为所缘。如是说者。以最后命根俱生五蕴无常为所缘。断想以断为所缘。离想以离为所缘。灭想以灭为所缘。此后三想随别如此。即是皆以灭谛涅槃为所缘义

念住者。无常想。无常苦想。苦无我想。四念住俱。不净想厌食想。身念住俱。一切世间不可乐想。有说。身念住俱。有说。法念住俱。死想断离灭想法念住俱

智者无常想。无常苦想。苦无我想。死想。四智相应。谓法智类智苦智世俗智。不净想。厌食想。一切世间不可乐想。一智相应。谓世俗智。断离灭想四智相应。谓法智类智灭智世俗智。三摩地者。无常想。无常苦想。死想。无漏者与无愿三摩地相应。苦无我想无漏者。与空三摩地相应。断离灭想无漏者。与无相三摩地相应。不净想。厌食想。一切世间不可乐想。及余七想中有漏者。皆不与三摩地相应。根者。总说皆与三根相应。谓乐喜舍根。世者皆堕三世。缘世者。无常想。无常苦想。苦无我想。缘三世。不净想。厌食想。一切世间不可乐想。过去缘过去。现在缘现在。未来生者缘未来。不生者缘三世。死想有说。缘三世。有说。缘未来。断离灭想缘非世

善等者一切皆善。缘善等者。无常想。无常苦想苦无我想。不净想。缘善不善无记。厌食想缘无记。一切世间不可乐想。有说。缘三种。有说。缘不善无记。死想有说。缘无记。有说。缘三种。断离灭想唯缘善。三界系不系者。不净想。厌食想。一切世间不可乐想。欲色界系。余三界系及不系。缘三界系不系者。无常想。无常苦想。苦无我想。死想缘三界系。不净想。厌食想。缘欲界系。一切世间不可乐想。有说。缘欲界。以说此想对治缘可爱事贪欲。此贪欲唯在欲界故。有说。缘三界。以此名一切世间不可乐想故。如是说者。初说为善。断离灭想缘不系

学等者。不净想。厌食想。一切世间不可乐想。唯非学非无学。余通三种。谓学无学非学非无学。缘学等者。一切皆缘非学非无学。见所断等者。不净想。厌食想。一切世间不可乐想。唯修所断。余通修所断及不断。缘见所断等者。无常想。无常苦想。苦无我想。缘见修所断。不净想。厌食想。一切世间不可乐想。缘修所断。死想有说。缘修所断。有说缘见修所断。断离灭想。缘不断

缘名义者。无常想。无常苦想。苦无我想。通缘名义。死想有说。唯缘义。有说通缘名义。余六想但缘于义

缘自相续等者。前七想缘自他相续。后三想缘非相续

加行得。离染得。生得者。一切加行得。离染得。非生得

有漏无漏者。不净想。厌食想。一切世间不可乐想。唯有漏。余有漏无漏。外国师说。死想唯有漏。所以者何。非诸圣道作我当死行相转故。评曰。应说此想有漏无漏。以此想加行时虽作我等当死行相。若成满时即于彼境还作无常行相转故。缘有漏无漏者。前七想缘有漏。后三想缘无漏。问此十想几有漏缘无漏。几无漏缘有漏。几有漏缘有漏。几无漏缘无漏。答三少分是有漏缘无漏。四少分是无漏缘有漏。三全四少分是有漏缘有漏。三少分是无漏缘无漏。问此十想几非有漏。非不缘有漏。乃至广作四句。前第二句作此第一句。前第一句作此第二句。前第四句作此第三句。前第三句作此第四句。有为无为者。一切皆是有为。缘有为无为者。前七想缘有为。后三想缘无为。问此十想几自性断。非所缘断。几所缘断非自性断。几自性断亦所缘断。几非自性断。亦非所缘断。答三少分自性断非所缘断。四少分所缘断非自性断。三全四少分亦自性断亦所缘断。三少分非自性断亦非所缘断。问此十想几非自性断。非不所缘断。乃至广作四句。前第二句作此第一句。前第一句作此第二句。前第四句作此第三句。前第三句作此第四句

问此十想几是转。几是随转。答三是转。谓不净想。厌食想。死想。余七是随转。问若尔何想转时几想随转。答不净想厌食想转时。各四想随转。谓一切世间不可乐想。及断离灭想。死想转时。七想随转。谓无常想。无常苦想。苦无我想。一切世间不可乐想。及断离灭想。云何不净想转时四想随转。谓修行者起不净想时。先往冢间观不净相。所谓死尸青瘀膖胀脓烂。或虫兽食啖血肉狼藉支节分离。或肉尽筋连。唯观骨锁次第连接。取是相已至一近处闭目思惟。若皆分明现前者善。若不明了当更往观。如此。善观不净相已。疾还所止洗足敷座。结跏趺坐调滑身心。令身心柔软身心堪能。身心无热身心离盖。既令身心离诸盖已。取先外相以方己身。如彼此亦尔。如此彼亦尔。谓我此身具有如前诸不净相。因于足骨以拄踝骨。因于踝骨以拄胫骨。因于胫骨以拄膝骨。因于膝骨以拄髀骨。因于髀骨以拄髋骨。因于髋骨以拄腰骨。因于腰骨以拄脊骨。因于脊骨傍连肋骨。又因手骨以拄肘骨。因于肘骨以拄臂骨。因于臂骨以拄肩骨。因于肩骨以拄脊骨。复因脊骨以拄项骨。因于项骨以拄颔轮。因于颔轮以拄齿鬘。上有髑髅于此身中骨锁次第。善取相已系念眉间。然其所乐有广有略。若乐略者即从眉间入身念住。从身念住入受念住。从受念住入心念住。从心念住入法念住若乐广者从眉间起。复观髑髅齿鬘颔轮。次第观察乃至足骨。次由胜解作意力故。令所观骨锁渐增渐广。遍满一床一房一院一僧伽蓝一村一田一城一国。乃至大海边际所有大地。皆为白骨周匝遍满。复以胜解作意力故。从彼渐略舍大地骨观于一国。舍一国观一城。乃至舍一房观一床。复舍一床所有骨相。但观身骨。谓观足骨次观踝骨。次观胫骨。乃至最后观髑髅骨舍髑髅骨系念眉间。彼瑜伽师若于如是广略自在。是名不净观成。然此不净观有所缘少。非自在少。应作四句。有所缘少非自在少。谓但思惟自身骨锁相。而能数数入出。彼观有自在少非所缘少。谓能思惟大地骨锁相。而不能数数入出。彼观有自在少。亦所缘少。谓但思惟自身骨锁相。亦不能数数入出。彼观有非自在少。亦非所缘少。谓能思惟大地骨锁相。亦能数数入出。彼观又此不净观。有所缘无量。非自在无量。应作四句。谓前第二句作此第一句。前第一句作此第二句。前第四句作此第三句。前第三句作此第四句。彼瑜伽师如是观察不净相已。作是思惟。生死诸行。何可欣乐。尔时便于欲色无色三界诸行都不贪乐。由如此故彼先所修一切世间不可乐想便得圆满。彼由不欣乐生死故便欣乐涅槃。由此因缘先所修习断离灭想皆得圆满。如是不净想转时四想随转。云何厌食想转时四想随转。谓修行者起厌食想时。观手中若钵中食从何而成。知从谷等。复观谷等从何而来知从田中种子差别。复观种子由谁故生知由种种泥土粪秽。如是观已便作是念。此食展转从不净生。复能展转生诸不净。谁有智者于中贪着。又彼行者或常乞食。或僧中食。常乞食者。晨旦澡漱嚼杨枝时。于水作尿想。于杨枝作指骨想。着衣持钵往聚落时。于衣作湿人皮想。于腰绦作人肠想。于钵作髑髅想于锡杖作胫骨想。于道路间所见砾石作骸骨想。既至聚落见诸城壁作冢墓想。见诸男女作骨锁想。于乞食时若得饼作人肚想。若得糗作骨粖想。若得盐作人齿想。若得饭作蛆虫想。若得诸菜作人发想。若得羹臛作下汁想。若得乳酪作人脑想。若得酥蜜作人脂膏想。若得鱼及肉作人肉想。若得诸饮作人血想。若得欢喜丸等作干粪想。其僧中食者。若得净草作死人发想。所处床座作骨聚想。于所得饮食作不净想。皆如前说。问行者何故于饮食等作不净想耶。答彼作如是思惟。我无始生死由于不净作净想故。轮回五趣受诸苦恼。今欲违彼趣涅槃乐。是故于中观为不净。复次彼行者作是念。莫令我于饮食生净想故。增益贪心障碍圣道故。于饮食作不净想。由不净想便能厌离。彼瑜伽师如是于食起厌想已作是思惟。生死诸行何可欣乐。便于三界诸行生厌。由如此故彼先所修一切世间不可乐想便得圆满。彼由厌生死故便乐涅槃。由此因缘先所修习断离灭想皆得圆满。如是厌食想转时四想随转。云何死想转时七想随转。谓修行者起死想时。观察诸法念念生灭。彼于春时见诸卉木。生花生叶鲜荣红绀如妙宝色。河池津液水渐盈满鱼鸟喧戏。便作是念。今外物生。彼入聚落见诸男女。歌舞跳跃饮食喜庆。即前问之。此何故尔。答曰。此处生男生女。便作是念。今内法生。复于夏时见诸卉木柯条耸密花叶茂盛。河池泛溢波涛轮转查沫陵岸。便作是念。此诸外法今已兴盛。彼入聚落见诸男女。击鼓吹贝歌舞欢笑车马杂沓。即前问之此何。故尔。答曰。此中有嫁娶事。便作是念。此诸内法今已壮盛。复于秋时见诸草木。为秋日所曝凉风所吹青色销尽叶皆黄悴。河池流水渐渐减缩。便作是念。此诸外物今已衰悴。彼入聚落见诸男女。发白面皱扶杖而行。身形曲偻咳逆上气。便作是念。此诸内法今已衰老。复于冬时见诸草木。霜风飘击叶皆在地摧折枯死。河池流水渐皆竭尽乃至干涸。便作是念。此诸外法今已复灭。彼入聚落见诸男女。被发跳踊捶胸号叫宛转在地。即前问之此何故尔。答曰。此处父母死丧。便作是念。此诸内法今已复灭。彼于如是内外无常。善取相已还其所止。洗足敷座结跏趺坐。调滑身心令身心柔渜身心堪能身心无热身心离盖。既令身心离诸盖已。内住其心修于死想。谓如所见诸无常想。观察内身一期诸蕴结生时生。乃至老死时灭。复于一期有尔所位诸蕴各异。舍余随观一位诸蕴前生后灭。复于一位有尔所岁诸蕴各异。舍余随观一岁诸蕴前生后灭。复于一岁有尔所时诸蕴各异。舍余随观一时诸蕴前生后灭。复于一时有尔所月诸蕴各异。舍余随观一月诸蕴前生后灭。复于一月有尔所昼夜诸蕴各异。舍余随观一昼夜蕴前生后灭。复于一昼夜有尔所牟呼栗多诸蕴各异。舍余随观一牟呼栗多蕴前生后灭。复于一牟呼栗多有尔所腊缚诸蕴各异。舍余随观一腊缚蕴前生后灭。复于一腊缚有尔所怛刹那诸蕴各异。舍余随观一怛刹那蕴前生后灭。复于一怛刹那有尔所刹那诸蕴各异。以刹那最多故于中渐渐略观。乃至观蕴二刹那生二刹那灭。是名生灭观加行圆满。从此无间能观诸蕴一刹那生一刹那灭。是名生灭观成。尔时名为死想圆满。以诸位灭即是死故。彼修行者如是谛观蕴生灭已。便作是念。世尊所说诸行无常诚为善说。以生灭即无常故。如是行者死想转时。令先所修诸无常想皆得圆满。行者复观诸蕴相续前刹那蕴。由后刹那蕴所逼迫故生已即灭。如是观已便作是念。世尊所说无常故苦诚为善说。以逼迫即是苦故。如是行者死想转时。令先所修无常苦想而得圆满。行者复观前刹那蕴才灭后刹那蕴即生。假使前蕴念言我今不灭后蕴念言我今不生。彼于所欲皆不自在。前蕴后所逼故必灭。后蕴前所牵故必生。如是观已便作是念。世尊所说苦无我想诚为善说。以不自在即无我故。如是行者死想转时。令先所修苦无我想而得圆满。行者复观诸行生灭不自在故。于空行聚中不生贪乐。由此便于三界诸行不生乐着。如是死想转时。令先所修一切世间不可乐想而得圆满。彼修行者既于生死不乐着故便乐涅槃。如是死想转时令先所修断离灭想皆得圆满。由此故说死想转时七想随转。问修诸想时有胜解作意有真实作意。彼胜解作意所观不实何非颠倒。答彼修行者知非真实不生实执故非颠倒。问若知不实何故犹作。答为伏烦恼是故须作。问此若不实云何能伏烦恼。答由作彼想。便能制伏。如于余女作母想时不生贪染。于怨憎所作亲想时不生嗔恚。于下人所作尊想时不生憍慢。此亦如是故须观察

说一切有部发智大毗婆沙论卷第一百六十六阿毗达磨大毗婆沙论卷第一百六十七

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    定蕴第七中摄纳息第三之二

无常想等摄几静虑等耶。答无常想摄四静虑四无色四解脱。乃至广说。问何故作此论。答欲止他宗显己义故。如分别论者。许他性摄遮自性摄。今止彼意许自性摄遮他性摄故作斯论。问何故此中不说想还摄想。答有说。是作论者意欲尔故。乃至广说。有说。此中应作是问。无常想等摄几想等耶。答无常想摄无常想。乃至一切世间不可乐想。摄一切世间不可乐想。应作是说而不说者当知此义有余。有说。此中欲成立未成立义。想还摄想不待成立是故不说。问若尔后文亦不应说初静虑等。还摄初静虑等。有说。静虑等摄多法体非于多法。自性摄义不说自成想唯一法是故非难。有说。彼亦不应说静虑等摄静虑等。而说者欲现种种文种种说。由种种文种种说庄严于义。义则易解。有说。为现二门二略二阶二炬二明二光二种文影。如不说想摄想。如是亦应不说静虑摄静虑等。如后说静虑摄静虑等。如是亦应说想摄想。欲令彼此二义俱通。故作二文互相影发。有说。此中辩摄及相应义。以想对想但有摄义。无相应义是故不说。此不应理于智等持。亦不应说无相应故。应作是说。想自性无杂于摄易了是故不说。智与等持或自性有杂。或行相有杂。于摄难了是故则说。无常想摄四静虑者。此即总说。然诸静虑皆五蕴性。此无常想唯摄相蕴不摄余蕴。于想蕴中唯摄无常想不摄余想。于无常想中过去摄过去。未来摄未来。现在摄现在。有漏摄有漏。无漏摄无漏。学摄学。无学摄无学。非学非无学摄非学非无学。退法摄退法。乃至不动法摄不动法。于中在初静虑者摄初静虑。乃至在第四静虑者摄第四静虑。是故总说摄四静虑。如说摄四静虑。摄四无色四解脱亦尔。差别者。四无色四解脱四蕴为性。余想随应亦准此说。然诸想皆以想为自性故。皆不摄智三摩地第八解脱。问无常想亦通欲界系。此中何故不说。答有说应说而不说者当知。此义有余。有说。无常想在欲界者。是加行非根本。此中唯说根本是故不说。有说。今此定蕴唯说定地法故不说欲界。有说。此中以十想对静虑等门为问。欲界非静虑等门是故不说。余想不说义亦同此。如无常想。无常苦想苦无我想死想断想离想灭想亦尔。皆在八等至通有漏无漏故。此七想以所缘行相异故。不摄初三解脱。八胜处。十遍处。及无量不净想。摄第三第四静虑初二解脱。问四静虑中皆有不净想。何故唯说摄第三第四静虑耶。答亦应说摄初第二静虑。而不说者。当知此义有余。有说。若说摄初二解脱。当知已说摄初二静虑。以初二解脱在初二静虑故。有说。此中举后显初。举离喜地显有喜地故。有说。初二静虑无不净想是故不说。所以者何。彼二地皆有喜根一切喜根欣欢行转。不净想厌戚行转非一心中二行转故。问若尔者此想所摄初二解脱在何地耶。答在二近分非根本地。亦以与喜受相违故。问若尔后文不应说初二静虑。摄初二解脱前四胜处。答彼说静虑亦摄眷属。如说城邑亦摄城邑边。问若尔不应说不净想摄第三静虑。以彼地有乐受亦与不净想相违故。答第三静虑言亦摄眷属。非根本地是故无过。若尔此中亦应说不净想摄初二静虑。以汝俱许在近分地无差别故。如是说者。初二静虑根本地中。亦有不净想及初二解脱。若谓无者应无有能离此地染。以此地有增上喜动踊其心。若无不净想初二解脱制伏彼者。诸瑜伽师岂能离彼地染。又彼亦应无苦集忍智以彼厌行转故。由此亦应无无常想无常苦想。问云何喜受作厌行转耶。答能自在厌故亦生喜。即生喜时于彼亦厌。如胜怨时亦厌亦喜。有说。如王与将士摧怨敌已共受喜乐。如是行者以不净想等摧欲界已。于初静虑等共受喜乐。有说。初静虑中初二解脱及不净想。对治欲界鼻舌二识。第二静虑初二解脱及不净想。对治初静虑眼耳身识。是故初二静虑中定有初二解脱及不净想。然此中略故不说不净想摄初二静虑。有说。不净想实在四静虑。然此唯说摄第三第四静虑者。以第三静虑有生死中殊胜受乐。第四静虑有生死中殊胜轻安乐。难厌难舍故于是中说不净想。初二静虑中无如是乐故不说摄。问何故不净想但说摄初二解脱。不说摄前四胜处耶。答不净想是初修总观与初二解脱相似故摄。胜处是后起别观故不相摄。如不净想厌食想亦尔。问厌食想非解脱自性。云何亦摄初二解脱。答此文但应说厌食想摄第三第四静虑。而说如不净想者。欲显厌食想以不净想为加行。说厌食想及加行。故说如不净想。有说。厌食想与不净想相杂相引有相摄义。是故说摄如不净想。有说。厌食想亦作不净行转。如说若得饭时作虫蛆想。乃至广说。是故亦摄初二解脱俱观色处不净转故。问若厌食想与不净想俱观色处不净转者。世尊所说厌食想不净想何差别。答体实无别但以所对治爱有差别故建立二想。谓不净想对治淫欲爱。厌食想对治段食爱。评曰。不应作如是说。佛所安立十想各各异故。又段食爱缘段食起。香味触处是段食性。若许此想对治彼爱。云何说同不净想观色处故摄初二解脱耶。是故应知初说为善。此二想所缘行相。及地异故。不摄余解脱胜处及遍处无量一切世间不可乐想。摄第三第四静虑。问初第二静虑亦有此想何故不说摄耶。答此文应说摄四静虑。而但说摄后二者。当知此义有余。有说。此中举后显初。有说。上二静虑是殊胜可爱乐地。以有最胜受乐及最胜轻安乐故。于如是地说有此想。显修行者于胜乐地中。尚能起不可乐想。况于余处是故唯说摄此二地。有说。初静虑为寻伺风所动。第二静虑为极喜水所漂。虽有不净厌食一切世间不可乐想。而不明净。后二静虑与此相违故说摄彼此想所缘行相及地异故。不摄一切解脱胜处遍处无量

初静虑等摄几静虑等耶。答初静虑摄初静虑四无量初二解脱前四胜处八智三三摩地。第二静虑摄第二静虑四无量。初二解脱前四胜处八智三三摩地。第三静虑摄第三静虑三无量八智三三摩地。第四静虑摄第四静虑三无量净解脱后四胜处前八遍处八智三三摩地。此中四静虑皆以自根本地五蕴为性。故得摄此诸门功德。应知皆是自性摄非他性摄

慈无量等摄几无量等耶。答慈摄慈世俗智乃至舍摄舍世俗智。此中四无量皆以俱生品诸蕴为性故。得摄世俗智总缘有情为境故。不摄解脱胜处遍处及他心智有漏故。不摄余智三三摩地

空无边处等摄几无色等耶。答空无边处摄空无边处。及彼解脱彼遍处六智三三摩地。识无边处摄识无边处及彼解脱彼遍处六智三三摩地。无所有处摄无所有处及彼解脱六智三三摩地。非想非非想处摄非想非非想处及彼解脱灭想受解脱世俗智。此中四无色皆以自根本地四蕴为性故。得摄此所有功德。六智者。除法智他心智。此二不依无色地故

初解脱等摄几解脱等耶。答初第二第三解脱摄初第二第三解脱世俗智。空无边处解脱摄空无边解脱及彼遍处六智三三摩地。识无边处解脱摄识无边处解脱及彼遍处六智三三摩地。无所有处解脱。摄无所有处解脱六智三三摩地。非想非非想处解脱。摄非想非非想处解脱世俗智。灭想受解脱摄灭想受解脱。此中前三解脱皆以俱生品五蕴为性故。得摄世俗智。是初总观故不摄胜处遍处。是有漏故。不摄余智三三摩地。缘色故不摄他心智。四无色解脱各以自地加行善四蕴为性。是故得摄后二遍处及六智三三摩地

初胜处等摄几胜处等耶。答初胜处摄初胜处世俗智乃至第八胜处。摄第八胜处世俗智。此中八胜处皆以俱生品五蕴为性故。得摄世俗智胜处。是中观故不摄遍处。有漏故不摄余智三三摩地。缘色故不摄他心智。初遍处等摄几遍处等耶。答初遍处摄初遍处世俗智乃至第十遍处。摄第十遍处世俗智。此中十遍处皆以俱生品五蕴四蕴为性故。得摄世俗智。有漏故不摄余智三三摩地。缘色及地异故不摄他心智

法智等摄几智等耶。答法智摄法智五智少分。乃至广说。法智摄法智者。法智在六地。谓未至定。静虑中间。及四静虑。未至定摄未至定。乃至第四静虑摄第四静虑。又法智在三道。谓见道修道无学道。见道摄见道。乃至无学道摄无学道。又法智缘四谛。苦法智摄苦法智。乃至道法智摄道法智。又法智在四道。谓加行无间解脱胜进道。加行道摄加行道。乃至胜进道摄胜进道。又法智堕三世。过去摄过去。未来摄未来。现在摄现在。于中乃至此刹那摄此刹那。彼刹那摄彼刹那。此中总说故但言法智摄。法智摄五智少分者。谓法智亦摄他心智。四谛智少分。他心智通有漏无漏。此唯摄无漏。无漏中有法智类智。此唯摄法智故言少分。四谛智各通法智类智。此唯摄法智故言少分。类智摄类智五智少分者。如法智说。差别者。此在九地。他心智摄他心智者。他心智在四根本静虑。初静虑摄初静虑。乃至第四静虑摄第四静虑。又他心智通有漏无漏。有漏摄有漏。无漏摄无漏。又他心智有法智类智。法智摄法智。类智摄类智。又他心智有学无学非学非无学。学摄学。乃至非学非无学摄非学非无学。又他心智堕三世。过去摄过去。未来摄未来。现在摄现在。于中乃至此刹那摄此刹那。彼刹那摄彼刹那。此中总说故。但言他心智摄他心智。摄四智少分者。谓他心智亦摄法智类智世俗智道智小分。法智类智各缘四谛。此唯摄缘道谛少分。故言少分世俗智在十八地。谓欲界静虑中间四静虑。四无色。及彼近分。此唯摄四静虑。于四静虑中。有善染污无覆无记。此唯摄善。于善中有生得闻所成修所成。此唯摄修所成。于修所成中有加行无间解脱胜进道。此唯摄胜进。于胜进道中。有顺退分顺住分顺胜进分顺决择分。此唯摄顺住分。于顺住分中。有缘过去未来现在及离世。此唯摄缘现在。于缘现在中有缘自相续缘他相续。此唯摄缘他相续。缘他相续中有缘心心所。有缘五蕴。此唯摄缘心心所缘。心心所中有缘一法有缘多法。此唯摄缘一法。缘一法中。有是他心智。有非他心智。此唯摄他心智。由如是义故言少分。道智在九地。谓未至定。静虑中间四静虑。三无色。此唯摄四静虑。于四静虑中。有见道修道无学道。此唯摄修道无学道。于此二中有加行无间解脱胜进道。此唯摄胜进道。于胜进道中有缘过去未来现在。此唯摄缘现在。于缘现在中。有缘自相续有缘他相续。此唯摄缘他相续。于缘他相续中有缘心心所法。有缘五蕴。此唯摄缘心心所法。于缘心心所法中。有缘一法有缘多法。此唯摄缘一法。于缘一法中。有是他心智有非他心智。此唯摄他心智。由如此义故言少分。世俗智摄世俗智者。世俗智在十八地如前说。欲界摄欲界。乃至非想非非想处摄非想非非想处。又世俗智有善染污无覆无记。善摄善。乃至无覆无记摄无覆无记。于善中有加行得离染得生得。加行得摄加行得。乃至生得摄生得。复有顺退分乃至顺决择分。顺退分摄顺退分。乃至顺决择分摄顺决择分。复有加行道乃至胜进道。加行道摄加行道。乃至胜进道摄胜进道。复有过去未来现在。过去摄过去。乃至现在摄现在。于中乃至此刹那摄此刹那。彼刹那摄彼刹那。此中总说故言世俗智摄世俗智。一智少分者。谓世俗智亦摄他心智少分。他心智通有漏无漏。此唯摄有漏故言少分。苦智摄苦智者。苦智在九地。在三道。在四道。堕三世。堕刹那。随在何地何道。堕何世。何刹那。即彼地。彼道。彼世。彼刹那摄。此中总说故言苦智摄苦智。二智少分者。谓苦智亦摄法智类智少分。法智类智各缘四谛。此唯摄缘苦谛故言少分。集智摄集智二智少分。灭智摄灭智二智少分者。皆如苦智说。道智摄道智者。亦如苦智说。三智少分者。谓道智亦摄法智类智他心智少分。法智类智各缘四谛。此唯摄缘道谛。他心智通有漏无漏。此唯摄缘无漏故言少分。空三摩地等摄几三摩地耶。答空摄空。无愿摄无愿。无相摄无相。空三摩地缘苦谛二行相转。无愿三摩地缘三谛十行相转。无相三摩地缘灭谛四行相转。于中一一行相皆在九地。在三道。在四道。堕三世。堕刹那。随何行相。在何地。何道。堕何世。何刹那。即彼行相。彼地。彼道。彼世。彼刹那摄。此中总说故言空摄空。乃至无相摄无相。三三摩地虽通有漏。此中依解脱门说故唯摄无漏

如摄可得亦尔由自体于自体可得是摄义故。谓自体于自体。是有。自体于自体。是实。自体于自体。是现有。是不异。是不外。是不相离。是不解脱。是无差别。是不空。是不无非客非远非二非诤。诸如是等皆是可得义故。诸法自体摄自体。非如以手摄食以指摄衣。但一切法障碍自体。令究竟不舍故名为摄。有余师说。此自体摄有四种。谓各别界。各别物。各别刹那。各别相续。各别界者。谓眼界摄眼界。乃至法界摄法界。各别物者。谓法界中有七物。即色受想行。及三无为。色摄色。乃至非择灭摄非择灭。各别刹那者。谓色中有过去未来现在。过去摄过去。乃至现在摄现在。各别相续者。谓现在色有堕自相续。有堕他相续。自相续摄自相续。他相续摄他相续。由此理趣余应准知。故言如摄可得亦尔。摄与可得义无异故。无常想等与几静虑等相应耶。答无常想与四静虑四无色四解脱四智一三摩地相应。乃至广说。问何故作此论。答为止愚于相应法执相应法非实有者意显相应法是实有故。而作斯论。无常想与四静虑相应者。四静虑皆五蕴性。此想与彼二蕴全。一蕴少分相应。与四无色四解脱相应者。四无色及四无色解脱皆四蕴性。此想与彼二蕴全。一蕴少分相应。与四智相应者。谓与法智类智。世俗智苦智。相应。一三摩地相应者。谓缘苦无愿。如无常想。无常苦想。苦无我想。死想。断想。离想。灭想。亦尔者。此依皆与四智一三摩地相应。数同故言亦尔。于中一切同者。谓死想行想异而名同者。谓无常苦想智名同。余不同者。谓苦无我想。与空三摩地相应故。唯有数同余皆不同者。谓断离灭想。与灭智无相三摩地相应故。不净想与后二静虑初二解脱世俗智相应者。此想与四静虑相应。而但言后二静虑相应者。如摄中说。如不净想厌食想亦尔者。此想实不与初二解脱相应。而说与相应者。亦如摄中说。一切世间不可乐想。与后二静虑世俗智相应者。此想亦与四静虑相应。而但言与后二相应者亦如摄中说。初静虑等与几静虑等相应耶。答初静虑与初静虑四无量初二解脱前四胜处八智三三摩地相应。第二静虑与第二静虑四无量初二解脱前四胜处八智三三摩地相应。第三静虑与第三静虑三无量八智三三摩地相应。第四静虑与第四静虑三无量净解脱后四胜处前八遍处八智三三摩地相应。此中四静虑皆以自地五蕴为性。一一地俱生四蕴展转相应故。言初静虑与初静虑。乃至第四静虑与第四静虑相应。非自性与自性有相应义。又以一一静虑摄多法。故得与诸无量等功德相应。三无量者除喜无量。后二静虑无喜根故。诸有欲令喜无量不以喜受为自性者。亦说此与喜受相应故。彼二地唯三无量

慈无量等与几无量等相应耶。答慈与慈世俗智相应。乃至舍与舍世俗智相应。慈等虽以无嗔善根等为自性。而此中所说总摄自性相应俱有。为慈等体故说慈与慈相应。乃至舍与舍相应。即是俱生四蕴互相应义。空无边处等。与几无色等相应耶。答空无边处与空无边处及彼解脱彼遍处六智三三摩地相应。识无边处与识无边处及彼解脱彼遍处六智三三摩地相应。无所有处与无所有处及彼解脱六智三三摩地相应。非想非非想处与非想非非想处及彼解脱世俗智相应。此中四无色皆以自地四蕴为性。一一地俱生四蕴展转相应故。言空无边处与空无边处。乃至非想非非想处与非想非非想处相应。又以一一无色摄多法故。得与余所说功德相应。六智者如摄中说

初解脱等与几解脱等相应耶。答初第二第三解脱。与初第二第三解脱世俗智相应。空无边处解脱与空无边处解脱及彼遍处六智三三摩地相应。识无边处解脱与识无边处解脱及彼遍处六智三三摩地相应。无所有处解脱与无所有处解脱六智三三摩地相应。非想非非想处解脱与非想非非想处解脱世俗智相应。灭想受解脱非相应。前三解脱虽皆以无贪善根为自性。而此中所说总以自性相应俱有法为体故。说初第二第三解脱与初第二第三解脱相应。即是俱生四蕴互相应义。四无色解脱如四无色说。灭想受解脱虽有多法如心心所不相离俱时起。而无所依所缘行相同义故非相应

初胜处等与几胜处等相应耶。答初胜处与初胜处世俗智相应。乃至第八胜处与第八胜处世俗智相应。此中八胜处虽皆无贪善根为自性。而此中所说总以自性相应俱有法为体故。说初胜处与初胜处。乃至第八胜处与第八胜处相应

初遍处等与几遍处等相应耶。答初遍处与初遍处世俗智相应。乃至第十遍处与第十遍处世俗智相应。前八遍处虽以无贪善根为自性。此中所说总以自性相应俱有法为体。后二遍处总以俱生四蕴为性。故言初遍处与初遍处。乃至第十遍处与第十遍处相应。法智等与几三摩地相应耶。答法智与三三摩地少分相应。乃至广说。法智与三三摩地少分相应者。此智不与类智及一切忍俱三三摩地相应故言少分。如法智类智亦尔者。此智不与法智及一切忍俱三三摩地相应故言亦尔。他心智与一三摩地少分相应者。此智与苦集灭智及他心智所不摄道智。并一切忍俱。三摩地不相应故言少分。即是与一缘道无愿三摩地少分相应义如他心智。集灭道智亦尔者。此依数同故说亦尔。然集智唯与缘集无愿三摩地少分相应。灭智唯与无相三摩地少分相应。道智唯与缘道无愿三摩地少分相应。皆除忍俱三摩地故。苦智与二三摩地少分相应者。此智唯与智俱。空三摩地。及苦智俱无愿三摩地相应故言少分。三三摩地门不别说相应者。对前诸门具已说故。于自门中无相应故

说一切有部发智大毗婆沙论卷第一百六十七阿毗达磨大毗婆沙论卷第一百六十八

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    定蕴第七中摄纳息第三之三

若成就初静虑等。乃至广说。问何故作此论。答为止拨无成就不成就性者意显成就不成就性是实有故而作斯论。若成就初静虑等。彼于四静虑等。几成就几不成就。答若成就初静虑。彼于四静虑或一二三四。一者谓梵世爱未尽。此即异生圣者生欲界梵世。若生欲界于初静虑唯离染得故成就。若生梵世于初静虑有离染得有生得故成就。彼梵世爱未尽故不成就上三静虑。二者谓梵世爱尽上爱未尽。此即异生圣者生欲界梵世。及圣者生极光净。若生欲界于初二静虑唯离染得故成就。若生梵世于初静虑有离染得有生得故成就于第二静虑唯离染得故成就。若生极光净于初静虑唯成就无漏。非有漏以越地舍故于第二静虑唯离染得故成就。彼极光净爱未尽故不成就上二静虑。三者谓极光净爱尽上爱未尽。此即异生圣者生欲界梵世。及圣者生极光净遍净。若生欲界于下三静虑唯离染得故成就。若生梵世于初静虑有离染得有生得故成就。于第二第三静虑唯离染得故成就。若生极光净于初静虑唯成就无漏。于第二第三静虑唯离染得故成就。若生遍净于初二静虑唯成就无漏。于第三静虑唯离染得故成就。彼遍净爱未尽故不成就第四静虑。四者谓遍净爱尽。此即异生圣者生欲界梵世。及圣者生极光净。乃至非想非非想处。若生欲界于四静虑皆唯离染得故成就。若生梵世于初静虑有离染得有生得故成就。于上三静虑唯离染得故成就。若生极光净于初静虑唯成就无漏。于上三静虑唯离染得故成就。若生遍净于初二静虑唯成就无漏。于第三第四静虑唯离染得故成就。若生广果于下三静虑唯成就无漏。于第四静虑唯离染得故成就。若生无色界于四静虑唯成就无漏。于四无量或无或三或四。无者谓生无色界。此即圣者生彼四地成就无漏初静虑。非四无量以越界舍故。三者谓生遍净广果。此即圣者生彼二地成就无漏初静虑及三无量除喜以越地舍故。四者谓生欲界梵世极光净。此即异生圣者生欲界梵世。及圣者生极光净。若生欲界梵世成就有漏无漏初静虑及四无量。若生极光净成就无漏初静虑及四无量。于四无色或无或一二三四。无者谓色爱未尽。此即异生圣者。欲爱尽色爱未尽故成就初静虑非无色。一者谓色爱尽上爱未尽。此即异生圣者。生欲界梵世。及圣者生极光净。乃至空无边处。彼皆成就初静虑及一无色。若生欲界梵世。成就有漏无漏初静虑初无色。若生极光净乃至空无边处。成就无漏初静虑有漏无漏初无色。彼上爱未尽故不成就上三无色。二者谓空无边处爱尽上爱未尽。此即异生圣者生欲界梵世。及圣者生极光净乃至识无边处。彼皆成就初静虑及二无色。若生欲界梵世。成就有漏无漏初静虑初二无色。若生极光净。乃至空无边处。成就无漏初静虑。有漏无漏初二无色。若生识无边处成就无漏初静虑初无色。有漏无漏第二无色。彼上爱未尽故不成就上二无色。三者谓识无边处爱尽上爱未尽。此即异生圣者生欲界梵世。及圣者生极光净。乃至无所有处。彼皆成就初静虑及三无色。若生欲界梵世。成就有漏无漏初静虑初三无色。若生极光净。乃至空无边处。成就无漏初静虑有漏无漏初三无色。若生识无边处。成就无漏初静虑初无色。有漏无漏第二第三无色。若生无所有处。成就无漏初静虑初二无色。有漏无漏第三无色。彼上爱未尽故不成就上一无色。四者谓无所有处爱尽。此即异生圣者生欲界梵世。及圣者生极光净。乃至非想非非想处。彼皆成就初静虑及四无色。若生欲界梵世。成就有漏无漏初静虑三无色。有漏一无色。若生极光净乃至空无边处。成就无漏初静虑。有漏无漏三无色。有漏一无色。若生识无边处。成就无漏初静虑一无色。有漏无漏二无色。有漏一无色。若生无所有处。成就无漏初静虑。二无色。有漏无漏一无色。有漏一无色。若生非想非非想处。成就无漏初静虑三无色。有漏一无色。于八解脱或无或一二三四五六七八。无者谓生遍净。即彼爱未尽。此即圣者生遍净。成就无漏初静虑。而不成就解脱。初二解脱越地舍故。后六解脱未离遍净染未得故是故言无。一者谓生遍净。即彼爱尽上爱未尽。若生广果即彼爱未尽。若生空无边处。即彼爱未尽。此即圣者生彼诸地成就无漏初静虑及一解脱。此中若生遍净即彼爱尽上爱未尽彼成就净解脱。非余前二越地舍故。后五未得故。若生广果即彼爱未尽彼亦成就净解脱。非余如前释。若生空无边处即彼爱未尽彼成就有漏无漏空无边处解脱。非余前三越地舍故。后四未得故。二者谓生欲界梵世。极光净遍净爱未尽。若生遍净广果。广果爱尽上爱未尽。若生空无边处即彼爱尽上爱未尽。若生识无边处即彼爱未尽。此即异生圣者生欲界梵世。及圣者生极光净。乃至识无边处。彼皆成就初静虑及二解脱。于中若生欲界梵世。遍净爱未尽彼成就有漏无漏初静虑及初二解脱。非余未得故。若生极光净。遍净爱未尽彼成就无漏初静虑。余如前说。若生遍净广果。广果爱尽上爱未尽彼成就无漏初静虑及第三解脱。有漏无漏第四解脱。非余初二已舍故。后四未得故。若生空无边处即彼爱尽上爱未尽彼成就无漏初静虑及有漏无漏第四第五解脱。非余初三已舍故。后三未得故。若生识无边处即彼爱未尽彼成就无漏初静虑及无漏第四解脱。有漏无漏第五解脱。非余如前释。三者谓生欲界梵世。极光净遍净爱尽上爱未尽。若生遍净广果。空无边处爱尽上爱未尽若生空识无边处。识无边处爱尽上爱未尽。若生无所有处即彼爱未尽。此即异生圣者生欲界梵世。及圣者生极光净。乃至无所有处。皆成就初静虑及三解脱。于中若生欲界梵世。遍净爱尽上爱未尽。彼成就有漏无漏初静虑及前三解脱。非余未得故。若生极光净。遍净爱尽上爱未尽。彼成就无漏初静虑。余如前说。若生遍净广果。空无边处爱尽上爱未尽。彼成就无漏初静虑及第三解脱。有漏无漏第四第五解脱非余前二已舍故。后三未得故。若生空无边处。识无边处爱尽上爱未尽彼成就无漏初静虑。有漏无漏初三无色解脱。非余前三已舍故。后二未得故。若生识无边处即彼爱尽上爱未尽彼成就无漏初静虑第四解脱有漏无漏第五第六解脱。非余如前说。若生无所有处即彼爱未尽。彼成就无漏初静虑。第四第五解脱。有漏无漏第六解脱非余如前说。四者谓生欲界梵世极光净。广果爱尽上爱未尽。若生遍净广果。识无边处爱尽上爱未尽。若生空识无边处无所有处。无所有处爱尽。若生非想非非想处不得灭尽定。此即异生圣者生欲界梵世。及圣者生极光净。乃至非想非非想处。皆成就初静虑及四解脱。于中若生欲界梵世。广果爱尽上爱未尽彼成就有漏无漏初静虑及前三解脱。有漏无漏第四解脱。非余未得故。若生极光净。广果爱尽上爱未尽。彼成就无漏初静虑。余如前说。若生遍净广果。识无边处爱尽上爱未尽。彼成就无漏初静虑及第三解脱。有漏无漏初三无色解脱。非余前二已舍故。后二未得故。若生空无边处。无所有处爱尽彼成就无漏初静虑。有漏无漏初三无色解脱并第七解脱非余前三已舍故。后一未得故。若生识无边处。无所有处爱尽。彼成就无漏。初静虑第四解脱。有漏无漏第五第六解脱。并第七解脱。非余如前说。若生无所有处即彼爱尽。彼成就无漏初静虑。及第四第五解脱。有漏无漏第六解脱。并第七解脱。非余如前说。若生非想非非想处。不得灭尽定。彼成就无漏初静虑。三无色解脱。并第七解脱。非余前三已舍故。后一未得故。或已舍故。五者谓生欲界梵世。极光净空无边处爱尽上爱未尽。若生遍净广果。无所有处爱尽不得灭尽定。若生非想非非想处得灭尽定。此即异生圣者生欲界梵世。及圣者生极光净遍净广果非想非非想处。皆成就初静虑及五解脱。于中若生欲界梵世。空无边处爱尽上爱未尽。彼成就有漏无漏初静虑及前三解脱。有漏无漏第四第五解脱。非余未得故。若生极光净。空无边处爱尽上爱未尽。彼成就无漏初静虑。余如前说。若生遍净广果。无所有处爱尽不得灭尽定。彼成就无漏初静虑及第三解脱。有漏无漏初三无色解脱。并第七解脱。非余前二已舍故。后一不得故。若生非想非非想处得灭尽定。彼成就无漏初静虑。初三无色解脱及后二解脱。非余已舍故。六者谓生欲界梵世。极光净识无边处爱尽上爱未尽。若生遍净广果得灭尽定。此即异生圣者生欲界梵世。及圣者生极光净遍净广果。皆成就初静虑及六解脱。于中若生欲界梵世。识无边处爱尽上爱未尽。彼成就有漏无漏初静虑及前三解脱。有漏无漏初三无色解脱。非余未得故。若生极光净。识无边处爱尽上爱未尽。彼成就无漏初静虑。余如前说。若生遍净广果得灭尽定。彼成就无漏初静虑及第三解脱。有漏无漏初三无色解脱并后二解脱。非余已舍故。七者谓生欲界梵世。极光净无所有处爱尽不得灭尽定。此即异生圣者生欲界梵世。及圣者生极光净。皆成就初静虑及七解脱。于中若生欲界梵世。无所有处爱尽不得灭尽定。彼成就有漏无漏初静虑。及前三解脱。有漏无漏初三无色解脱并第七解脱。非第八未得故。若生极光净。无所有处爱尽不得灭尽定。彼成就无漏初静虑。余如前说。八者谓生欲界梵世。极光净得灭尽定。此即圣者生欲界梵世极光净。皆成就初静虑及八解脱。于中若生欲界梵世得灭尽定。彼成就有漏无漏初静虑及一切八解脱。若生极光净得灭尽定。彼成就无漏初静虑。及一切八解脱。于八胜处或无。或四或八。无者谓生遍净即彼爱未尽。若生无色界。此即圣者生遍净及无色界。俱成就无漏初静虑。非八胜处以生遍净即彼爱未尽者。前四已舍后四未得故。生无色界者皆已舍故。四者谓生欲界梵世。极光净。遍净爱未尽。若生遍净即彼爱尽。若生广果。此即异生圣者。生欲界梵世。及圣者生极光净遍净广果。皆成就初静虑及四胜处。于中若生欲界梵世。遍净爱未尽。彼成就有漏无漏初静虑及前四胜处。非余未得故。若生极光净。遍净爱未尽。彼成就无漏初静虑。余如前说。若生遍净即彼爱尽。及生广果。彼成就无漏初静虑及后四胜处。非余已舍故。八者谓生欲界梵世。极光净遍净爱尽。此即异生圣者生欲界梵世。及圣者生极光净。皆成就初静虑。及八胜处。于中若生欲界梵世。遍净爱尽。彼成就有漏无漏初静虑及八胜处。若生极光净。遍净爱尽。彼成就无漏初静虑及八胜处。于十遍处或无或一二八九十。无者谓生欲界梵世极光净遍净。遍净爱未尽。若生无所有处。非想非非想处。此即异生圣者生欲界梵世。及圣者生极光净遍净。后二无色皆成就初静虑非十遍处。于中若生欲界梵世。遍净爱未尽。彼成就有漏无漏初静虑。非十遍处未得故。若生极光净遍净。遍净爱未尽。彼成就无漏初静虑。非十遍处未得故。若生后二无色。彼成就无漏初静虑。非十遍处已舍故。一者谓生空无边处即彼爱未尽。若生识无边处。此即圣者生彼二地。俱成就无漏初静虑及一遍处。于中若生空无边处。即彼爱未尽彼成就一空无边处遍处。非余前八已舍故。后一未得故。若生识无边处。彼成就一识无边处遍处。非余已舍故。二者谓生空无边处。即彼爱尽。此即圣者生彼成就无漏初静虑及后二遍处。非余已舍故。八者谓生欲界梵世极光净遍净。遍净爱尽上爱未尽。若生广果即彼爱未尽。此即异生圣者生欲界梵世。及圣者生极光净遍净广果皆成就初静虑。及前八遍处。于中若生欲界梵世。遍净爱尽上爱未尽。彼成就有漏无漏初静虑。及前八遍处。非余未得故。若生极光净遍净。遍净爱尽上爱未尽。及生广果即彼爱未尽。彼成就无漏初静虑。余如前说。九者谓生欲色界。色爱尽上爱未尽。此即异生圣者生欲界梵世。及圣者生极光净遍净广果。皆成就初静虑及前九遍处。于中若生欲界梵世。色爱尽上爱未尽。彼成就有漏无漏初静虑及前九遍处。非第十未得故。若生极光净遍净广果。色爱尽上爱未尽。彼成就无漏初静虑。余如前说。十者谓生欲色界。空无边处爱尽。此即异生圣者生欲界梵世。及圣者生极光净遍净广果。皆成就初静虑及十遍处。于中若生欲界梵世。空无边处爱尽。彼成就有漏无漏初静虑及十遍处。若生极光净遍净广果。空无边处爱尽。彼成就无漏初静虑及十遍处。于八智或二四五六七八。二者谓异生及苦法忍位。此中异生及先离欲染。依未至定苦法忍位成就有漏初静虑。若依上五地苦法忍位成就有漏无漏初静虑。彼一切皆成就二智。谓他心智。世俗智。四者谓苦法智苦类忍位。此位若依未至定则成就有漏初静虑。若依上五地则成就有漏无漏初静虑。彼皆成就四智。谓他心智世俗智苦智法智。五者谓苦类智集法忍位。此二位所成就有漏无漏初静虑如前分别。彼皆成就五智。谓前四加类智。六者谓集法智乃至灭法忍位。此诸位所成就初静虑如前说。彼皆成就六智。谓前五加集智。七者谓灭法智乃至道法忍位。此诸位所成就初静虑如前说。彼皆成就七智。谓前六加灭智。八者谓道法智以上诸位。此中道法智道类忍位所成就初静虑亦如前说。道类智位必成就有漏无漏初静虑。其道类智上诸位中生欲界梵世者。定皆成就有漏无漏初静虑。生极光净以上诸地者。唯成就无漏初静虑。彼一切皆成就八智。谓前七加道智。于三三摩地。或无或二或三。无者谓诸异生彼成就有漏初静虑。非三摩地不得故。二者谓诸圣者灭法忍未生此前诸位。若依未至定唯成就有漏初静虑。若依上五地成就有漏无漏初静虑。彼皆成就二三摩地。谓空无愿。三者谓灭法忍已生。此中从灭法忍乃至道类忍智所成就初静虑如前说。道类智位必成就有漏无漏初静虑。其道类智上诸位中。生欲界梵世者定皆成就有漏无漏初静虑。生极光净以上诸地者唯成就无漏初静虑。彼一切皆成就三三摩地。如成就初静虑乃至成就第四静虑。随所应亦尔。谓如以初静虑对四静虑。乃至三三摩地辩成就如是。乃至以第四静虑。对四静虑。乃至三三摩地辩成就随其所应。若异生。若圣者。若离染得故。若生得故。若有漏若无漏若无若分若具等。皆应广说

七补特伽罗。谓随信行随法行信胜解见至身证慧解脱俱解脱。问随信行等于味相应等四静虑四无色。几成就几不成就。答随信行于味相应四静虑。或无或一二三四。无者谓色爱尽彼离染时皆已断故。一者谓遍净爱尽上爱未尽。彼唯成就上一静虑地味。二者谓极光净爱尽上爱未尽。彼唯成就上二静虑地味。三者谓梵世爱尽上爱未尽。彼唯成就上三静虑地味。四者谓梵世爱未尽。彼俱成就四静虑地味。下染未尽必成就上味。下染已尽必不成就下味故。于净四静虑或无或一二三四。无者谓欲爱未尽于净静虑皆未得故。一者谓欲爱尽上爱未尽。彼成就下一地净。二者谓梵世爱尽上爱未尽。彼唯成就下二地净。三者谓极光净爱尽上爱未尽。彼唯成就下二地净。四者谓遍净爱尽。彼具成就四地净。下染未尽必不成就上净。上染已尽身在下者。必成就下净故。以随信行必在欲界故作是说。于无漏四静虑或无或一二三四。无者谓依未至定入正性离生。此中或未离欲染故。或虽离欲染不能修故皆不成就。一者谓依初静虑或静虑中间入正性离生。彼成就下一地无漏非余。或未得或不能修故。二者谓依第二静虑入正性离生。彼成就下二地无漏非余如前说。三者谓依第三静虑入正性离生。彼成就下三地无漏。非余如前说。四者谓依第四静虑入正性离生。彼具成就四地无漏皆已得能修故。见道依下必不修上。以是初得道故。无漏依上必修下地以自在不系故。于味相应四无色。或一二三四。一者谓无所有处爱尽上爱未尽。彼成就上一地味。彼必未离有顶染故。二者谓识无边处爱尽上爱未尽。彼成就上二地味。三者谓空无边处爱尽上爱未尽。彼成就上三地味。四者谓空无边处爱未尽。彼具成就四地味。所以如前说。于净四无色或无或一二三四。无者谓色爱未尽于净无色皆未得故。一者谓色爱尽上爱未尽。彼成就下一地净。二者谓空无边处爱尽上爱未尽。彼成就下二地净。三者谓识无边处爱尽上爱未尽。彼成就下三地净。四者谓无所有处爱尽彼具成就四地净。所以如前说。于无漏三无色皆不成就彼无见道故如随信行随法行亦尔。以此二补特伽罗。若道若地若定若离染若所依。皆不异唯根异故。信胜解于味相应四静虑。或无或一二三四。无者谓色爱尽。一者谓遍净爱尽上爱未尽。二者谓极光净爱尽上爱未尽。三者谓梵世爱尽上爱未尽。四者谓梵世爱未尽彼成就。及所以皆如前说。于净四静虑或无或一二三四。无者谓欲爱未尽。若生无色界欲爱未尽者皆未得故。生无色界者皆已舍故。一者谓生欲界欲爱尽上爱未尽。若生梵世即彼爱未尽。若生极光净即彼爱未尽。若生遍净即彼爱未尽。若生广果。二者谓生欲界梵世。梵世爱尽上爱未尽。若生极光净。即彼爱尽上爱未尽。若生遍净即彼爱尽。三者谓生欲界梵世。极光净爱尽上爱未尽。若生极光净遍净爱尽。四者谓生欲界梵世遍净爱尽。此中信胜解容有生一切地义。有漏善法生上必舍下。是故得作如前所说。于无漏四静虑或无或一二三四。无者谓欲爱未尽。一者谓欲爱尽上爱未尽。二者谓梵世爱尽上爱未尽。三者谓极光净爱尽上爱未尽。四者谓遍净爱尽。此中依渐次得果离染者说。或依随所得胜静虑。即依彼入正性离生者说。若不尔者。此文不应作如是说。以有梵世爱尽而不成就二。极光净爱尽而不成就三。遍净爱尽而不成就四故。何者是耶。谓有离梵世乃至遍净染。依初静虑乃至第三静虑入正性离生。至道类智时不成就无漏二乃至四静虑故。或此所说道类智时。虽不成就二乃至四。而从此后不久定成故。于尔时亦说成就。谓道类智后不久必起胜果道时即修彼故。于味相应四无色或一二三四。乃至广说。于净四无色或无或一二三四。乃至广说。此中广释如静虑中。应知于无漏三无色。或无或一二三。无者谓色爱未尽。一者谓色爱尽上爱未尽。二者谓空无边处爱尽上爱未尽。三者谓识无边处爱尽。此中亦依渐次得果离染者说。若不尔者。此文不应作如是说。以有色爱尽而不成就一。空无边处爱尽而不成就二。识无边处爱尽而不成就三故。何者是耶。谓有离色界乃至识无边处染入正性离生。至道类智时不成就无漏无色故。或彼不久必起胜果道即成就彼故于尔时亦说成就。如信胜解见至亦尔。以此二补特伽罗。若道若地若定若离染若所依。皆不异唯根异故。身证于味相应四静虑。皆不成就于净四静虑。或无或一二三四。乃至广说。于无漏四静虑皆成就。于味相应四无色。成就一不成就三。于净四无色或一或四。一者谓生非想非非想处。四者谓生欲色界。于无漏三无色皆成就。慧解脱于味相应四静虑皆不成就。于净四静虑或无或一二三四。乃至广说。于无漏四静虑皆成就。于味相应四无色皆不成就。于净四无色或一二三四。乃至广说。于无漏三无色皆成就。俱解脱于味相应四静虑皆不成就。于净四静虑或无或一二三四。乃至广说。于无漏四静虑皆成就。于味相应四无色皆不成就。于净四无色或一或四。一者谓生非想非非想处。四者谓生欲色界。于无漏三无色皆成就。此中广释如前应知

说一切有部发智大毗婆沙论卷第一百六十八阿毗达磨大毗婆沙论卷第一百六十九

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    定蕴第七中摄纳息第三之四

颇有成就味相应四静虑非净非无漏耶。答有。谓欲爱未尽。彼于四静虑所有善法皆未得故。无净无漏即以此故成就味相应四静虑。颇有成就净四静虑非味相应非无漏耶。答有。谓异生生欲界梵世色爱尽。异生故无无漏色爱尽故无味相应。生欲界梵世色爱尽故成就净四静虑。颇有成就无漏四静虑非味相应非净耶。答有。谓圣者生无色界。以圣者生彼故成就无漏四静虑。即以生彼处故无味相应净。问若色爱尽依未至定初静虑静虑中间入正性离生。或练根作见至。彼得果已不起胜果道。命终生无色界。彼皆不成就无漏上三静虑。何故说四耶。答有说。此依渐次得果者说不依余故。有说。彼入正性离生者得不还果已。必起胜果道修无漏四静虑然后生上。若不尔者应有圣者生广果以上不成就乐根。若尔便违十门所说。其信胜解练根作见至者。有说。彼得果已亦必起胜果道如前说。修无漏四静虑然后命终生无色界。有说。彼练根时即亦修上无漏静虑是故无过

颇有成就净无漏四静虑非味相应耶。答有。谓圣者生欲界梵世色爱尽。问若色爱尽依未至定入正性离生。十五心顷不成就无漏静虑。至道类智但成就一即彼乃至。依第三静虑入正性离生。十六心顷但成就三何故说四耶。答有说。此中依渐次得果离染者说。有说。彼得果已不久必起胜果道现前修上无漏。是故于十六心时虽未成就。必当得故亦说成就颇有成就余二或三耶。答无谓成就味相应四静虑者。必不成就四净四无漏故。颇有不成就味相应四静虑非净非无漏耶。答有。谓圣者生欲界梵世色爱尽。此如前成就中第六句释。颇有不成就净四静虑非味相应非无漏耶。答无。颇有不成就无漏四静虑。非味相应非净耶。答无。此皆如前成就中所无第四第五句释。颇有不成就味相应净四静虑非无漏耶。答有。谓圣者生无色界。此如前成就中第三句释。颇有不成就味相应无漏四静虑非净耶。答有。谓异生生欲界梵世色爱尽。此如前成就中第二句释。颇有不成就净无漏四静虑非味相应耶。答有。谓欲爱未尽。此如前成就中初句释。颇有不成就味相应净无漏四静虑耶。答有。谓异生生无色界。异生故无无漏四静虑。生无色界故无味净四静虑

颇有成就味相应四无色非净非无漏耶。答有。谓色爱未尽彼于四无色所有善法皆未得故。无净无漏即以此故成就味相应四无色。颇有成就净无漏四无色非味相应耶。答有。谓生欲色界空无边处阿罗汉。阿罗汉故无味相应。生彼地故具成就四净三无漏。颇有成就余耶。答无。此中无第二句唯成就四净者。以必有无漏味随一或俱故无第三句。唯成就三无漏者以必有净故无第四句。成就四味净非无漏及无第五句。成就四味三无漏非净者。以成就四味时必不成就四净或三无漏故。即由此义无第七句。颇有不成就味相应四无色非净非无漏耶。答有。谓生欲色界空无边处阿罗汉。此如前成就中第六句释。颇有不成就净无漏四无色非味相应耶。答有。谓色爱未尽。此如前成就中初句释。颇有不成就余耶。答无。此中无唯不成就四净者。以彼必亦不成就无漏故。无唯不成就三无漏者。如成就中所无第四句释。无不成就四味净非无漏者。如成就中。所无第三句释。无不成就四味三无漏非净者。如成就中所无第二句释。无一切皆不成就者。以于三中随一或二必成就故。于此静虑无色成就不成就中。具成就者名成就。具不成就者名非成就。及具不成就者名不成就。具成就者名非不成就应知

颇有得味相应四静虑非净非无漏耶。答有。谓色爱尽起欲界。缠退时。若无色界殁生欲界时。此中退者通异生及圣者。或学或无学起彼缠时。具得四味非净无漏。生者。唯异生于结生时具得四味非净无漏。颇有得无漏四静虑非味相应非净耶。答有。谓依第四静虑入正性离生。若得阿罗汉果时。此中入正性离生时者。谓苦法忍起时。尔时无漏。四静虑先无。而得非味非净。得阿罗汉果时者。谓尽智起时。尔时无漏四静虑皆舍。而得非味非净。虽净四静虑。尔时亦有得者。然其种类先有不舍。今但更得少分。于净四静虑无一名得。何况四耶。是故说非味非净。有说。此依生无色界得阿罗汉果者说。问学练根时亦有于无漏四静虑皆舍而得。何故不说耶。答应说而不说者。当知此义有余。有说。此中略举初后以显中间。故不具说。有说。彼所舍所得俱是学类。非全别类。是以不说。由此亦不说无学练根。颇有得余耶。答无。此中无第二句。唯得四净及无第六句。得四净无漏非味者。无有俱时得四净故。问依第四静虑见道三类智时。及得阿罗汉果时。岂非具得四净及无漏耶。何故不说。答彼于尔时于净四静虑皆先得不舍。今虽更得少分。犹于净四静虑无一名得。况复四耶。是故不说。无第四句。得四味净非无漏。及无第五句。得四味无漏。非净者。以得四味时必不得四净或四无漏故。即由此义亦无第七句。颇有舍味相应四静虑。非净非无漏耶。答无。无有俱时离四地染故。颇有舍净四静虑。非味相应。非无漏耶。答有。谓异生遍净爱尽。起欲界缠退时。若欲界梵世殁生无色界时。此中生无色界通异生及圣者。颇有舍净无漏四静虑。非味相应耶。答有。谓圣者遍净爱尽。起欲界缠退时。颇有舍余耶。答无。此中无第三句。唯舍四无漏者。以退舍时或非全舍故。或彼时还得故。或兼舍净故。得果舍时还即得故。无第四第五第七句者。无有俱时断四味故。颇有得味相应四无色。非净非无漏耶。答有。谓阿罗汉起欲色界缠退时。尔时具得四味非净无漏。颇有得无漏三无色。非味相应非净耶。答有。谓得阿罗汉果时。如前静虑中释。颇有得余耶。答无。此中无第二句。唯得四净者。无有俱时得四净故。无第四第五第七句者。以得四味时必不得四净三无漏故无第六句。得四净三无漏非味相应者。以于得三无漏时。虽亦少分得净。而不名得故。具如前释。颇有舍味相应四无色。非净非无漏耶。答无。以无俱时离四地染故。颇有舍净四无色。非味相应。非无漏耶。答有。谓异生无所有处爱尽。起欲色界缠退时。颇有舍净无漏四无色。非味相应耶。答有。谓圣者无所有处爱尽。起欲色界缠退时。颇有舍余耶。答无。此中无第三句。唯舍三无漏者。如静虑中说。无第四第五第七句者。以无俱时断四味故。于此静虑无色得及舍中。全得者名得。全不得者名非得。全舍者名舍。全不舍者名非舍。应知

颇有退味相应四静虑。非净非无漏耶。答无。以于功德法有退非于过失法故。亦无俱时舍四味故。颇有退净四静虑非味相应。非无漏耶。答有。谓异生遍净爱尽。起欲界缠退时。颇有退净无漏四静虑。非味相应耶。答有。谓圣者遍净爱尽。起欲界缠退时。颇有退余耶。答无。此中无第三句。唯退无漏四静虑者。或与净俱退故。或不全退故。或退时还得彼地故。无第四第五第七句者于味无退故。无唯退四无漏故。颇有退味相应四无色。非净非无漏耶。答无。如前说。颇有退净四无色。非味相应非无漏耶。答有。谓异生无所有处爱尽。起欲色界缠退时。颇有退净无漏四无色。非味相应耶。答有。谓圣者无所有处爱尽。起欲色界缠退时。颇有退余耶。答无。此中无第三句。唯退无漏三无色者。或与净俱退故。或非全退故。无第四第五第七句者。如静虑中说

问颇有退无漏静虑。非净耶。答有。谓学者起无色缠退时。尔时退彼对治无漏静虑非净故。问颇有不起无色缠。而退无漏静虑非净耶。答有。谓无学练根未至第九解脱道位。不起烦恼而退所得。无间解脱道时。问颇有不起缠而退无漏静虑非净耶。答有。即前所说。及学练根未至见至位不起烦恼而退。所得无间解脱道时。问颇有退七地所摄无漏功德。而非净耶。答有。谓少分离非想非非想处染。还起彼地所断品缠退时。问颇有唯舍无漏静虑而得净无漏耶。答有。谓得阿罗汉果时。问颇有舍净无漏静虑。唯得无漏耶。答有。谓阿罗汉起无色缠退时。问颇有无漏静虑与净俱时得而别舍耶。答有。谓得阿罗汉果。及依静虑得不还果。并学者练根时。问颇有净静虑与无漏俱时得而别舍耶。答有。谓圣者离自地染。及生上地时。问颇有净无漏静虑别时得俱时舍耶。答有。谓圣者离自地染起下地缠退时。问颇有净无漏静虑俱时得俱时舍耶。答有。谓圣者已离下地染起下地缠退时。如问静虑。如是无色亦应准问

复次如前所说等至。略有二十三种。谓静虑有十二。即四味相应四净四无漏。无色有十一即四味相应四净三无漏。此二十三若广建立成六十五等至。谓前二十三加四无量。四无碍解。八解脱。八胜处。十遍处。六通。无诤愿智所依。问此六十五几唯缘自地。几唯缘下地。几缘自地及下地。几缘自地及上地。几缘一切地。答十等至唯缘自地。谓八味相应。及空识无边处遍处。二十四等至唯缘下地。谓四无量。初三解脱。八胜处。前八遍处。及无诤。或有欲令无诤缘欲色界者。除无诤。七等至缘自地及下地。谓法词二无碍解。五通所依。九等至缘自地及上地。谓净无漏三无色。及下三无色解脱。此依缘有漏者说。十二等至缘一切地。谓净无漏四静虑义辩二无碍解漏尽通愿智所依。此亦但依缘有漏者说。若通依缘无漏者说。则有二十三等至缘一切地。谓即前十二加十一无色。谓净无漏无色及无色解脱

问若等至随以何味相应静虑为因。即以彼为等无间耶。设等至随以何味相应静虑为等无间。即以彼为因耶。答诸等至随以彼味相应静虑为因。亦即以彼为等无间。有等至以彼味相应静虑为等无间。而不以彼为因。于中若等至以味相应初静虑为等无间。而不以彼为因者有十六。谓净初静虑。四无量。初二解脱。前四胜处。五通所依。若等至以味相应第二静虑为等无间。而不以彼为因者有十七。谓净第二静虑。四无量。初二解脱。前四胜处。五通所依。及净初静虑。若等至以味相应第三静虑为等无间。而不以彼为因者有十。谓净第三静虑。三无量。五通所依。及净第二静虑。若等至以味相应第四静虑为等无间。而不以彼为因者有二十三。谓净第四静虑。三无量。净解脱。后四胜处。前八遍处。五通所依。及净第三静虑

问若等至随以何味相应无色为因。即以彼为等无间耶。设等至随以何味相应无色为等无间。即以彼为因耶。答诸等至随以彼味相应无色为因。亦即以彼为等无间。有等至以彼味相应无色为等无间。而不以彼为因。于中若等至以味相应空无边处为等无间。而不以彼为因者有四。谓净空无边处。即彼解脱即彼遍处。及净第四静虑。若等至以味相应识无边处为等无间。而不以彼为因者有五。谓净识无边处即彼解脱。即彼遍处。及净空无边处。即彼解脱。若等至以味相应无所有处为等无间。而不以彼为因者有四。谓净无所有处。即彼解脱及净识无边处。即彼解脱。若等至以味相应非想非非想处为等无间。而不以彼为因者有四。谓净非想非非想处。即彼解脱。及净无所有处。即彼解脱。问若等至随以何净静虑为因。即以彼为等无间耶。设等至随以何净静虑为等无间。即以彼为因耶。答诸等至随以彼净静虑为因。亦即以彼为等无间。有等至以彼净静虑为等无间。而不以彼为因。于中若等至以净初静虑为等无间。而不以彼为因者有六。谓自地味相应无漏。及净无漏第二第三静虑。若等至以净第二静虑为等无间。而不以彼为因者有八。谓自地味相应无漏。及净无漏初第三第四静虑。若等至以净第三静虑为等无间。而不以彼为因者有十一。谓自地味相应无漏。及净无漏初第二第四静虑。空无边处即彼解脱。若等至以净第四静虑为等无间。而不以彼为因者有十二。谓自地味相应无漏。及净无漏第二第三静虑。空识无边处即彼解脱

问若等至随以何净无色为因。即以彼为等无间耶。设等至随以何净无色为等无间。即以彼为因耶。答诸等至随以彼净无色为因。亦即以彼为等无间。有等至以彼净无色为等无间。而不以彼为因。于中若等至以净空无边处为等无间。而不以彼为因者有十二。谓自地味相应无漏。及净无漏第三第四静虑。识无边处。无所有处。即彼二处解脱。若等至以净识无边处为等无间。而不以彼为因者有十二。谓自地味相应无漏。及净无漏第四静虑。空无边处。无所有处。即彼二处解脱。净非想非非想处。即彼解脱。若等至以净无所有处为等无间。而不以彼为因者有十。谓自地味相应无漏。及净无漏空识无边处。即彼解脱。净非想非非想处。即彼解脱。若等至以净非想非非想处为等无间。而不以彼为因者有七。谓自地味相应。及净无漏识无边处。无所有处。即彼二处解脱

问若等至随以何无漏静虑为因。即以彼为等无间耶。设等至随以何无漏静虑为等无间。即以彼为因耶。答依一一无漏静虑皆应作四句。依无漏初静虑作四句者。有等至以无漏初静虑为因。非等无间。此有七。谓无漏第四静虑。三无色。及三无色解脱。有等至以无漏初静虑为等无间非因。此有十九。谓净初第二第三静虑。四无量。初二解脱。前四胜处。二无碍解。四通所依。有等至以无漏初静虑为因。亦等无间此有七。谓无漏初第二第三静虑。二无碍解。他心漏尽通所依。有等至不以无漏初静虑为因。亦非等无间。此有三十二。谓八味相应净第四静虑。四无色。三解脱。后四胜处。十遍处。无诤愿智所依。依无漏第二静虑作四句者。有等至以无漏第二静虑为因。非等无间。此有六。谓无漏三无色。及三无色解脱。有等至以无漏第二静虑为等无间非因。此有十九。谓净四静虑。四无量初二解脱。前四胜处。法无碍解。四通所依。有等至以无漏第二静虑为因。亦等无间。此有八。谓无漏四静虑。二无碍解。他心漏尽通所依。有等至不以无漏第二静虑为因。亦非等无间。此有三十二。谓八味相应净四无色。三解脱。后四胜处。十遍处。词无碍解。无诤愿智所依。依无漏第三静虑作四句者。有等至以无漏第三静虑为因。非等无间。此有四。谓无漏识无边处。无所有处。即彼二处解脱。有等至以无漏第三静虑为等无间非因。此有十三。谓净四静虑。空无边处。三无量。法无碍解。四通所依。有等至以无漏第三静虑为因。亦等无间。此有十一。谓无漏四静虑。空无边处。即彼解脱。二无碍解。他心漏尽通所依。有等至不以无漏第三静虑为因。亦非等无间。此有三十八。谓八味相应。上三净无色。喜无量。五解脱。八胜处。十遍处。词无碍解。无诤愿智所依。依无漏第四静虑作四句者。有等至以无漏第四静虑为因。非等无间。此有三。谓无漏初静虑。无所有处。及无所有处解脱。有等至以无漏第四静虑为等无间非因。此有二十八。谓净第二第三第四静虑。空识无边处。三无量。净解脱。后四胜处。前八遍处。法无碍解。四通无诤愿智所依。有等至以无漏第四静虑为因。亦等无间。此有十一。谓无漏第二第三第四静虑。空识无边处。即彼解脱。二无碍解。他心漏尽通所依。有等至不以无漏第四静虑为因。亦非等无间。此有二十三。谓八味相应。净初静虑。无所有处。非想非非想处。喜无量。四解脱。前四胜处。后二遍处。词无碍解所依

问若等至随以何无漏无色为因。即以彼为等无间耶。设等至随以何无漏无色为等无间。即以彼为因耶。答依一一无漏无色皆应作四句。依无漏空无边处作四句者。有等至以无漏空无边处为因。非等无间。此有三。谓无漏初第二静虑。及他心通所依。有等至以无漏空无边处为等无间非因。此有六。谓净第三第四静虑。下三无色。及空无边处。遍处。有等至以无漏空无边处为因。亦等无间。此有十一。谓无漏第三第四静虑。三无色。及下三无色解脱。二无碍解。漏尽通所依。有等至不以无漏空无边处为因。亦非等无间。此有四十五。谓八味相应。净初第二静虑。非想非非想处。四无量。五解脱。八胜处。九遍处。二无碍解。四通无诤愿智所依。依无漏识无边处作四句者。有等至以无漏识无边处为因。非等无间。此有四。谓无漏初第二第三静虑。他心通所依有等至以无漏。识无边处为等无间非因。此有七。谓净第四静虑。四无色。非想非非想处解脱。识无边处遍处。有等至以无漏识无边处为因。亦等无间。此有十。谓无漏第四静虑。三无色。及下三无色解脱。二无碍解。漏尽通所依。有等至不以无漏识无边处为因。亦非等无间。此有四十四。谓八味相应净初第二第三静虑。四无量。四解脱。八胜处。九遍处。二无碍解。四通无诤愿智所依。依无漏无所有处作四句者。有等至以无漏无所有处为因。非等无间。此有五。谓无漏四静虑。及他心通所依。有等至以无漏无所有处为等无间非因。此有五。谓净四无色。及非想非非想处解脱。有等至以无漏无所有处为因。亦等无间。此有九。谓无漏三无色。下三无色解脱。二无碍解。漏尽通所依。有等至不以无漏无所有处为因。亦非等无间。此有四十六。谓八味相应净四静虑。四无量。四解脱。八胜处。十遍处。二无碍解。四通无诤愿智所依

问若等至随以何味相应静虑为因。即以彼为所缘耶。设等至随以何味相应静虑为所缘。即以彼为因耶。答诸等至随以彼味相应静虑为因。亦即以彼为所缘。有等至以彼味相应静虑为所缘。而不以彼为因。于中若等至以味相应初静虑为所缘。而非因者有十三。谓净无漏四静虑。义无碍解。三通愿智所依。或有欲令无诤亦缘色界者。彼说有十四。加无诤。如是说者。初说为善。如味相应初静虑。味相应第二第三第四静虑亦尔

问若等至随以何味相应无色为因。即以彼为所缘耶。设等至随以何味相应无色为所缘。即以彼为因耶。答诸等至随以彼味相应无色为因。亦即以彼为所缘。有等至以彼味相应无色为所缘。而不以彼为因。于中若等至以味相应空无边处为所缘。而不以彼为因者。有十五。谓净无漏四静虑。义无碍解。漏尽通。愿智所依。净无漏空无边处。即彼解脱遍处。若等至以味相应识无边处为所缘。而不以彼为因者。有十八。谓净无漏四静虑。义无碍解漏尽通。愿智所依。净无漏空识无边处。即彼解脱。识无边处。遍处。若等至以味相应无所有处为所缘。而不以彼为因者。有二十。谓净无漏四静虑。义无碍解。漏尽通。愿智所依。净无漏下三无色。及下三无色解脱。若等至以味相应非想非非想处为所缘。而不以彼为因者。有二十二。谓即前二十加净非想非非想处。及彼解脱

说一切有部发智大毗婆沙论卷第一百六十九阿毗达磨大毗婆沙论卷第一百七十

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    定蕴第七中摄纳息第三之五

问若等至随以何净静虑为因。即以彼为所缘耶。设等至随以何净静虑为所缘。即以彼为因耶。答依一一净静虑。皆应作四句。依净初静虑作四句者。有等至以净初静虑为因。而非所缘。此有十五。谓四无量。二解脱。四胜处。二无碍解。三通所依。有等至以净初静虑为所缘。而非因。此有九。谓味相应初静虑。净上三静虑无漏四静虑愿智所依。有等至以净初静虑为因。亦作所缘。此有六。谓净初静虑。二无碍解。三通所依。有等至不以净初静虑为因。亦非所缘。此有三十五。谓七味相应净四无色。无漏三无色。后四胜处。六解脱。十遍处。无诤所依。依净第二静虑作四句者。有等至以净第二静虑为因。而非所缘。此有十四。谓四无量。二解脱。四胜处。法无碍解。三通所依。有等至以净第二静虑为所缘。而非因。此有九。谓味相应第一静虑。净初第三第四静虑。无漏四静虑愿智所依。有等至以净第二静虑为因。亦作所缘。此有六。谓净第二静虑。二无碍解。三通所依。有等至不以净第二静虑为因。亦非所缘。此有三十六。谓七味相应。净四无色。无漏三无色。后四胜处。六解脱。十遍处。无诤词无碍解所依。依净第三静虑作四句者。有等至以净第三静虑为因。而非所缘。此有七。谓三无量。法无碍解。三通所依。有等至以净第三静虑为所缘。而非因。此有九。谓自地味相应。净初第二第四静虑。无漏四静虑愿智所依。有等至以净第三静虑为因。亦作所缘。此有六。谓净第三静虑。二无碍解。三通所依。有等至不以净第三静虑为因。亦非所缘。此有四十三。谓七味相应。净四无色。无漏三无色。喜无量。八胜处。八解脱。十遍处。无诤词无碍解所依。依净第四静虑作四句者。有等至以净第四静虑为因。而非所缘。此有二十一。谓三无量。净解脱。后四胜处。前八遍处。法无碍解。无诤三通所依。有等至以净第四静虑为所缘。而非因。此有八。谓味相应第四静虑。净下三静虑。无漏四静虑。有等至以净第四静虑为因。亦作所缘。此有七。谓净第四静虑。二无碍解。三通愿智所依。有等至不以净第四静虑为因。亦非所缘。此有二十九。谓七味相应。净四无色。无漏三无色。喜无量。七解脱。前四胜处。后二遍处。词无碍解所依

问若等至随以何净无色为因。即以彼为所缘耶。设等至随以何净无色为所缘。即以彼为因耶。答下三净无色。若等至随以彼为因。亦即以彼为所缘。有等至以彼为所缘。而不以彼为因。净非想非非想处。应作四句。于中若等至以净空无边处为所缘。而不以彼为因者。有十一。谓净无漏四静虑。自地味相应。无漏愿智所依。若等至以净识无边处为所缘。而不以彼为因者。有十四。谓净无漏四静虑。无漏初二无色。净空无边处。即彼解脱。自地味相应愿智所依。若等至以净无所有处为所缘。而不以彼为因者。有十七。谓净无漏四静虑。无漏三无色。净初二无色。及初二无色解脱。自地味相应愿智所依。依净非想非非想处作四句者。有等至以净非想非非想处为因。而非所缘。此有一。谓灭想受解脱。有等至以净非想非非想处为所缘。而非因此有十九。谓净无漏四静虑。三无色。及三无色解脱。自地味相应。愿智所依。有等至以净非想非非想处为因。亦作所缘。此有五。谓净非想非非想处。即彼解脱二无碍解。漏尽通所依。有等至不以净非想非非想处为因。亦非所缘。此有四十。谓七味相应四无量。初三解脱。八胜处。十遍处。二无碍解。无诤。五通所依

问若等至随以何无漏静虑为因。即以彼为所缘耶。设等至随以何无漏静虑为所缘。即以彼为因耶。答诸等至随以彼无漏静虑为因。亦即以彼为所缘。有等至以彼无漏静虑为所缘。而不以彼为因。于中若等至以无漏初静虑为所缘。而不以彼为因者。有十。谓净四静虑。四无色。非想非非想处。解脱。愿智所依。如无漏初静虑。无漏第二第三第四静虑亦尔

问若等至随以何无漏无色为因。即以彼为所缘耶。设等至随以何无漏无色为所缘。即以彼为因耶。答依一一无漏无色皆应作四句。依无漏空无边处作四句者。有等至以无漏空无边处为因。而非所缘。此有一。谓他心通所依。有等至以无漏空无边处为所缘。而非因。此有十。谓净四静虑。四无色。非想非非想处。解脱愿智所依。有等至以无漏空无边处为因。亦作所缘。此有十三。谓无漏四静虑。三无色。下三无色解脱。二无碍解。漏尽通所依。有等至不以无漏空无边处为因。亦非所缘。此有四十一。谓八味相应四无量。四解脱。八胜处。十遍处。二无碍解。无诤。四通所依。如无漏空无边处。无漏识无边处无所有处亦尔

问若等至随以何味相应静虑为等无间。即以彼为所缘耶。设等至随以何味相应静虑为所缘。即以彼为等无间耶。答依一一味相应静虑皆应作四句。依味相应初静虑作四句者。有等至以味相应初静虑为等无间。而非所缘。此有十三。谓四无量。初二解脱。前四胜处。三通所依。有等至以味相应初静虑为所缘。而非等无间。此有十。谓净上三静虑。无漏四静虑。义无碍解。漏尽通。愿智所依。有等至以味相应初静虑为等无间。亦作所缘。此有四。谓自地味相应。净二通所依。有等至不以味相应初静虑为等无间。亦非所缘。此有三十八。谓七味相应净四无色。无漏三无色。六解脱。后四胜处。十遍处。无诤。三无碍解所依。依味相应第二静虑作四句者。有等至以味相应第二静虑为等无间。而非所缘。此有十三。谓四无量。初二解脱。前四胜处。三通所依。有等至以味相应第二静虑为所缘。而非等无间。此有九。谓净上二静虑。无漏四静虑。义无碍解。漏尽通。愿智所依。有等至以味相应第二静虑为等无间。亦作所缘。此有五。谓自地味相应。净初二静虑。二通所依。有等至不以味相应第二静虑为等无间。亦非所缘。此有三十八。谓七味相应。净四无色。无漏三无色。六解脱。后四胜处。十遍处。无诤。三无碍解所依。依味相应第三静虑作四句者。有等至以味相应第三静虑为等无间。而非所缘。此有六。谓三无量。三通所依。有等至以味相应第三静虑为所缘。而非等无间。此有九。谓净二静虑。无漏四静虑。义无碍解。漏尽通。愿智所依。有等至以味相应第三静虑为等无间。亦作所缘。此有五。谓自地味相应净第二第三静虑。二通所依。有等至不以味相应第三静虑为等无间。亦非所缘。此有四十五。谓七味相应。净四无色。无漏三无色。喜无量。八解脱。八胜处。十遍处。无诤。三无碍解所依。依味相应第四静虑作四句者。有等至以味相应第四静虑为等无间。而非所缘。此有十九。谓三无量。净解脱。后四胜处。前八遍处。三通所依。有等至以味相应第四静虑为所缘。而非等无间。此有九。谓净二静虑。无漏四静虑。义无碍解。漏尽通。愿智所依。有等至以味相应第四静虑为等无间。亦作所缘。此有五。谓自地味相应。净第三第四静虑。二通所依。有等至不以味相应第四静虑为等无间。亦非所缘。此有三十二。谓七味相应。净四无色。无漏三无色。喜无量。七解脱。前四胜处。后二遍处。无诤。三无碍解所依

问若等至随以何味相应无色为等无间。即以彼为所缘耶。设等至随以何味相应无色为所缘。即以彼为等无间耶。答诸等至随以彼味相应无色为等无间。亦即以彼为所缘。有等至以彼味相应无色为所缘而不以彼为等无间。于中若等至以味相应空无边处为所缘。而不以彼为等无间者。有十一。谓净三静虑。无漏四静虑。自地无漏。义无碍解。漏尽通。愿智所依。若等至以味相应识无边处为所缘。而不以彼为等无间者。有十三。谓净无漏。四静虑。无漏初二无色义无碍解漏尽通。愿智所依。若等至以味相应无所有处为所缘。而不以彼为等无间者。有十六。谓净无漏。四静虑。净空无边处。即彼解脱。无漏三无色。义无碍解。漏尽通。愿智所依。若等至以味相应非想非非想处为所缘而不以彼为等无间者。有十八。谓净无漏。四静虑。初二净无色。即彼解脱。无漏三无色。义无碍解。漏尽通。愿智所依

问若等至随以何净静虑为等无间。即以彼为所缘耶。设等至随以何净静虑为所缘。即以彼为等无间耶。答依一一净静虑皆应作四句。依净初静虑作四句者。有等至以净初静虑为等无间。而非所缘。此有十五。谓四无量。初二解脱。前四胜处。二无碍解。三通所依。有等至以净初静虑为所缘。而非等无间。此有三。谓净无漏第四静虑。愿智所依。有等至以净初静虑为等无间。亦作所缘。此有十三。谓自地味相应。及净无漏初三静虑。二无碍解。三通所依。有等至不以净初静虑为等无间。亦非所缘。此有三十五。谓七味相应。净四无色。无漏三无色。六解脱。四胜处。十遍处。无诤所依。依净第二静虑作四句者。有等至以净第二静虑为等无间。而非所缘。此有十四。谓四无量。初二解脱。前四胜处。法无碍解。三通所依。有等至以净第二静虑为所缘。而非等无间。此有一。谓愿智所依。有等至以净第二静虑为等无间。亦作所缘。此有十四。谓自地味相应。及净无漏。四静虑二无碍解三通所依。有等至不以净第二静虑为等无间。亦非所缘。此有三十五。谓七味相应净四无色。无漏三无色。六解脱。四胜处。十遍处。无诤。词无碍解所依。依净第三静虑作四句者。有等至以净第三静虑为等无间。而非所缘。此有十。谓三无量净。无漏空无边处。即彼解脱。法无碍解。三通所依。有等至以净第三静虑为所缘。而非等无间。此有一。谓愿智所依。有等至以净第三静虑为等无间。亦作所缘。此有十四。谓自地味相应。及净无漏。四静虑。二无碍解。三通所依。有等至不以净第三静虑为等无间。亦非所缘。此有四十。谓七味相应。净上三无色。无漏上二无色。喜无量。七解脱。八胜处。十遍处。无诤。词无碍解所依。依净第四静虑作四句者。有等至以净第四静虑为等无间。而非所缘。此有二十七。谓三无量。净解脱。后四胜处。前八遍处。无诤。法无碍解。三通所依。净无漏初二无色。即彼解脱。有等至以净第四静虑为所缘。而非等无间。此有二。谓净无漏。初静虑。有等至以净第四静虑为等无间。亦作所缘。此有十三。谓自地味相应。及净无漏。上三静虑。二无碍解。愿智。三通所依。有等至不以净第四静虑为等无间。亦非所缘。此有二十三。谓七味相应。净上二无色。无漏上一无色。喜无量。五解脱。前四胜处。后二遍处。词无碍解所依

问若等至随以何净无色为等无间。即以彼为所缘耶。设等至随以何净无色为所缘。即以彼为等无间耶。答依一一净无色皆应作四句。依净空无边处作四句者。有等至以净空无边处为等无间。而非所缘。此有六。谓净无漏识无边处。无所有处。即彼解脱。有等至以净空无边处为所缘。而非等无间。此有五。谓净无漏。初第二静虑。愿智所依。有等至以净空无边处为等无间。亦作所缘。此有十二。谓自地味相应。及净无漏。上二静虑。空无边处。即彼解脱。遍处。二无碍解。漏尽通所依。有等至不以净空无边处为等无间。亦非所缘。此有四十二。谓七味相应。净非想非非想处。四无量。五解脱。八胜处。九遍处。二无碍解。无诤。五通所依。依净识无边处作四句者。有等至以净识无边处为等无间。而非所缘。此有五。谓净无漏。无所有处。净非想非非想处。及彼二解脱。有等至以净识无边处为所缘。而非等无间。此有七。谓净无漏。初三静虑。愿智所依。有等至以净识无边处为等无间。亦作所缘。此有十三。谓自地味相应。及净无漏。第四静虑。初二无色。及初二无色解脱。识无边处。遍处。二无碍解。漏尽通所依。有等至不以净识无边处为等无间。亦非所缘。此有四十。谓七味相应。四无量。四解脱。八胜处。九遍处。二无碍解。无诤。五通所依。依净无所有处作四句者。有等至以净无所有处为等无间。而非所缘。此有二。谓净非想非非想处。即彼解脱。有等至以净无所有处为所缘。而非等无间。此有九。谓净无漏四静虑。愿智所依。有等至以净无所有处为等无间。亦作所缘。此有十三。谓自地味相应。及净无漏初三无色。即彼三解脱。二无碍解。漏尽通所依。有等至不以净无所有处为等无间。亦非所缘。此有四十一。谓七味相应。四无量。四解脱。八胜处。十遍处。二无碍解。无诤。五通所依。依净非想非非想处作四句者。有等至以净非想非非想处为等无间。而非所缘。此有一。谓灭想受解脱。有等至以净非想非非想处为所缘。而非等无间。此有十二。谓净无漏。四静虑。空无边处。及空无边处解脱。愿智所依。有等至以净非想非非想处为等无间。亦作所缘。此有十二。谓自地味相应。及净上三无色。即彼三解脱。无漏上二无色。二无碍解。漏尽通所依。有等至不以净非想非非想处为等无间。亦非所缘。此有四十。谓七味相应。四无量。三解脱。八胜处。十遍处。二无碍解。无诤。五通所依

问若等至随以何无漏静虑为等无间。即以彼为所缘耶。设等至随以何无漏静虑为所缘。即以彼为等无间耶。答依一一无漏静虑皆应作四句。依无漏初静虑作四句者。有等至以无漏初静虑为等无间。而非所缘。此有十六。谓四无量。初二解脱。前四胜处。二无碍解。四通所依。有等至以无漏初静虑为所缘。而非等无间。此有十四。谓净无漏。第四静虑。净四无色。无漏三无色。四无色。解脱。愿智所依。有等至以无漏初静虑为等无间。亦作所缘。此有十。谓净无漏。初三静虑。二无碍解。二通所依。有等至不以无漏初静虑为等无间。亦非所缘。此有二十五。谓八味相应。二解脱。后四胜处。十遍处。无诤所依。依无漏第二静虑作四句者。有等至以无漏第二静虑为等无间。而非所缘。此有十五。谓四无量。初二解脱。前四胜处。法无碍解。四通所依。有等至以无漏第二静虑为所缘。而非等无间。此有十二。谓净四无色。无漏三无色。四无色解脱。愿智所依。有等至以无漏第二静虑为等无间亦作所缘。此有十二。谓净无漏。四静虑。二无碍解。二通所依。有等至不以无漏第二静虑为等无间。亦非所缘。此有二十六。谓八味相应。二解脱。后四胜处。十遍处。无诤。词无碍解所依。依无漏第三静虑作四句者。有等至以无漏第三静虑为等无间。而非所缘。此有八。谓三无量。法无碍解。四通所依。有等至以无漏第三静虑为所缘。而非等无间。此有九。谓净上三无色。即彼三解脱。无漏上二无色。愿智所依。有等至以无漏第三静虑为等无间。亦作所缘。此有十五。谓净无漏。四静虑。空无边处。及空无边处解脱。二无碍解。二通所依。有等至不以无漏第三静虑为等无间。亦非所缘。此有三十三。谓八味相应。喜无量。四解脱。八胜处。十遍处。无诤。词无碍解所依。依无漏第四静虑作四句者。有等至以无漏第四静虑为等无间。而非所缘。此有二十二。谓三无量。净解脱。后四胜处。前八遍处。法无碍解。无诤。四通所依。有等至以无漏第四静虑为所缘。而非等无间。此有七。谓净无漏。初静虑净上二无色。及彼二解脱。无漏上一无色。有等至以无漏第四静虑为等无间。亦作所缘。此有十七。谓净无漏。上三静虑。初二无色。及初二无色解脱。二无碍解。二通愿智所依。有等至不以无漏第四静虑为等无间。亦非所缘。此有十九。谓八味相应。喜无量。三解脱。前四胜处。后二遍处。词无碍解所依

问若等至随以何无漏无色为等无间。即以彼为所缘耶。设等至随以何无漏无色为所缘。即以彼为等无间耶。答依无漏初二无色各应作四句。依无漏后一无色应作顺前句。依无漏空无边处作四句者。有等至以无漏空无边处为等无间。而非所缘。此有一。谓空无边处遍处。有等至以无漏空无边处为所缘。而非等无间。此有七。谓净无漏。初二静虑。净非想非非想处。及彼解脱。愿智所依。有等至以无漏空无边处为等无间。亦作所缘。此有十六。谓净无漏。后二静虑。初三无色。即彼解脱。二无碍解。漏尽通所依。有等至不以无漏空无边处为等无间。亦非所缘。此有四十一。谓八味相应。四无量。四解脱。八胜处。九遍处。二无碍解。无诤。五通所依。依无漏识无边处作四句者。有等至以无漏识无边处为等无间。而非所缘。此有一。谓识无边处遍处。有等至以无漏识无边处为所缘。而非等无间。此有七。谓净无漏。初三静虑。愿智所依。有等至以无漏识无边处为等无间。亦作所缘。此有十六。谓净无漏。第四静虑。下三无色。净非想非非想处。四无色解脱。二无碍解。漏尽通所依。有等至不以无漏识无边处为等无间。亦非所缘。此有四十一。谓八味相应。四无量。四解脱。八胜处。九遍处。二无碍解。无诤。五通所依。依无漏无所有处作顺前句者。谓若等至以无漏无所有处为等无间。亦即以彼为所缘。有等至以无漏无所有处为所缘。而不以彼为等无间。此有九。谓净无漏。四静虑。愿智所依

问颇有一等至现在前时。三十三等至舍而不得。八等至得而不舍。二等至亦舍亦得。二等至少分舍。少分得。少分不舍不得。十三等至少分舍而不得。少分不舍不得。七等至非舍非得耶。答有。谓慧解脱阿罗汉。起味相应初静虑退。尔时于六十五等至中。三十三舍而不得。谓净无漏。上三静虑。净无漏无色。五解脱。后四胜处。十遍处。漏尽通所依。八得而不舍。谓味相应静虑无色。二亦舍亦得。谓无漏净初静虑。舍无学及上所修。得学及退分故。二少分舍少分得。少分不舍不得。谓有欲令亦有无漏宿住随念智通者。依彼可得作此问答。谓宿住随念。他心智通。尔时少分舍。即一切无学上地有漏及无学位等所修初静虑有漏者少分得。即初静虑学少分不舍不得。即初静虑余有漏者。若有欲令宿住随念智通唯有漏者。依彼不应作此问答。以宿住随念智通。尔时但有少分舍。及少分不舍不得故。十三少分舍而不得。少分不舍不得。谓四无量。初二解脱。前四胜处。三通所依。即上地一切。及自地无学位等所修者舍而不得。余自地者不舍不得。七非舍非得。谓四无碍解。无诤愿智所依。灭尽解脱。以本未得故。问颇有得一等至而无所舍耶。答有。谓得灭尽解脱时。问颇有顿得六等至。而无所舍耶。答有。谓阿罗汉初起愿智时。顿得六等至。谓四无碍解。无诤愿智所依。问颇有舍一等至而无所得耶。答有。谓遍净殁生广果时舍。净第三静虑而无所得。问四向四果补特伽罗于六十五等至。谁成就几不成就几。答预流向成就八。谓八味相应。余不成就。如预流向预流果。一来向一来果亦尔。不还向极少成就八。如前说。即渐次者。极多成就四十七。即已离无所有处染。依第四静虑入正性离生者。谓净无漏。四静虑。净四无色。味相应。非想非非想处。四无量。七解脱。八胜处。十遍处。五通所依。不还果极多。如向说。极少成就二十五。谓八味相应。净无漏。初静虑。四无量。初二解脱。前四胜处。五通所依。或减一二味。增一二净。皆亦二十五阿罗汉向极少成就十三。即生非想非非想处。不得灭尽解脱者。谓无漏四静虑。三无色。味相应净。非想非非想处。四解脱。若生无所有处未离自地染者。亦成就十三。谓增一味。减一解脱。极多成就五十一。即生欲界梵世。身证谓一味。八净。七无漏。四无量。八解脱。八胜处。十遍处。五通所依。阿罗汉果极少成就十三。即生非想非非想处。慧解脱阿罗汉。谓七无漏。一净四解脱。漏尽通所依。极多成就五十七。谓得无碍解无诤愿智者。唯除八味相应。余皆具有。佛定成就五十七。独觉中部行者如欲界声闻。麟角喻者如佛

说一切有部发智大毗婆沙论卷第一百七十阿毗达磨大毗婆沙论卷第一百七十一

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    定蕴第七中摄纳息第三之六

颇有味相应四静虑顿得耶。答有。谓色爱尽起欲界梵世缠退时。若无色界殁生欲界梵世时。问何故复作此论。答前虽明得舍。而未分别渐顿。今欲显示渐顿差别。又复前以味等三种相对分别。今欲于中唯明自类。故作斯论。顿谓俱时。渐谓先后。此中显味相应四静虑于二时顿得。谓退时生时。退者从色爱尽。生者从无色殁。彼起欲界梵世缠退。及生欲界梵世时。于四味相应俱时得故。颇有味相应四静虑顿舍耶。答无。以无俱时能离四地染故。颇有味相应四静虑渐得耶。答有。此亦二时渐得。谓退及生。退者从色爱尽。次第起下一一静虑缠退时。生者从无色殁。次第生下一一静虑地时。彼于四味相应。渐次而得。颇有味相应四静虑渐舍耶。答有。以必先离初静虑染。乃至后离第四静虑染故。颇有净四静虑顿得耶。答无。以无先不成就净四静虑。今俱时得故。颇有净四静虑顿舍耶。答有。谓遍净爱尽。起欲界缠退时。若欲界梵世殁生无色界时。此中显净四静虑于二时顿舍。谓退时越界地时。应准配释。颇有净四静虑渐得耶。答有。谓先离欲界染时得初静虑。乃至后离第三静虑染时得第四静虑故。从无色界殁次第生下四静虑时。虽亦名渐得。而得一舍一故。非此所说。颇有净四静虑渐舍耶。答有。此亦二时渐舍。谓退时越界地时。退者谓渐次起下地缠退时。越界地者。谓从下渐次生上地时。从上静虑次第生下静虑地时。虽亦名渐舍。而舍一得一故。非此所说。颇有无漏四静虑顿得耶。答有。谓依第四静虑入正性离生。若得阿罗汉果。有余于此不说得阿罗汉果。以先学位已得无漏四静虑故。然于此应说得阿罗汉果。以学所得皆舍今顿得无学故。颇有无漏四静虑顿舍耶。答有。谓圣者遍净爱尽起欲界缠退时。虽得果练根及即彼不起欲界缠。而退时亦有顿舍无漏四静虑。而即时还得。是故不说。颇有无漏四静虑渐得耶。答有。以圣者离下地染及有起胜果道时渐次得故。颇有无漏四静虑渐舍耶。答有。以圣者遍净爱尽渐次起下地缠退时。渐舍无漏四静虑故。颇有味相应四无色顿得耶。答有。谓阿罗汉起欲色界空无边处缠退时。此中无容有生时得。颇有味相应四无色顿舍耶。答无。如前释。颇有味相应四无色渐得耶。答有。此中若退时于四有渐得。生时于三有渐得。颇有味相应四无色渐舍耶。答有。如前释。颇有净四无色顿得耶。答无。以无先不成就净四无色今俱时得故。问得果练根时。于净四静虑净四无色。皆有顿修。何故前静虑中及此无色。皆答无耶。答彼皆先有不舍。今但更得少分故非此中所说得义。颇有净四无色顿舍耶。答有。谓无所有处爱尽起欲色界缠退时。此中无容有越界地舍。颇有净四无色渐得耶。答有。如前释。颇有净四无色渐舍耶。答有。此中退时于四有渐舍。越地时于三有渐舍。颇有无漏三无色顿得耶。答有。谓得阿罗汉果时。无学练根时。虽亦顿得而非别类。是故不说。又彼亦名得阿罗汉果时。故不别说。颇有无漏三无色顿舍耶。答有。谓圣者识无边处爱尽。起欲色界缠退时。所释如前。颇有无漏三无色渐得耶。答有。以离下地染。及有起胜果道时。渐次得故。颇有无漏三无色渐舍耶。答有。以圣者识无边处爱尽。渐次起下地缠退时。渐舍无漏三无色故

身语表无表依何定灭。答身语表依初或未至。身语无表依四或未至。问何故作此论。答为止说表无表业非实有者意。明表无表业皆是实有。又为遮说身语表业。乃至第四静虑无表业。乃至有顶。今欲显身语表乃至梵世无表。乃至第四静虑。故作斯论。问何故上三静虑无身语表业耶。答身语表业寻伺所等起。若地寻伺可得。则有身语表业故。契经言。寻伺已语非不寻伺。身表亦应寻伺已作非不寻伺。上三静虑寻伺灭故无身语表。问何故上地无寻伺耶。答寻伺粗动不寂静。上地微细寂静故。问何故身语无表唯至第四静虑。非上地耶。答善无表业对治不善无表故。有不善无表唯在欲界无色界。于欲界四远所远故彼不有。复有说者。色界乃至第四静虑。皆能厌恶欲界恶业。上地不尔。有说。无表依色身大种。彼无色身及大种故亦无无表。此中身语表业有善不善无记。不善者欲界系依未至定灭。善无记者欲界初静虑系。欲界系者依未至定灭。初静虑系者。依未至定初静虑。静虑中间。第二静虑近分灭。未至言通八近分。及静虑中间。以皆非至根本定故。然此中所说定者。有说。依无漏定说。有说。依有漏无漏定说。若说依无漏定说者。彼说未至言显未至定静虑中间。若说依有漏无漏定说者。彼说未至言显未至定。静虑中间及第二静虑近分。又此中所说灭者。有说。通依种类灭说。有说。唯依究竟灭说。若说通依种类灭说者。彼说未至言摄三地。于未至定中摄有漏无漏。以此能灭欲界初静虑系身语表故。若说唯依究竟灭说者。彼说未至言亦摄三地。于未至定中唯摄无漏。以此能灭初静虑系身语表故。由此故说身语表依初或未至灭。身语无表有善不善。不善者欲界系。依未至定灭善者欲界四静虑系。及不系。欲界系者。依未至定灭。初静虑系者。依初静虑未至定静虑中间第二静虑近分灭。乃至第四静虑系者。依四静虑未至定静虑中间及空无边处近分灭。然此中所说定者。若说依无漏定说者。彼说未至言显未至定静虑中间。若说依有漏无漏定说者。彼说未至言显未至定。静虑中间。及上四近分。又此中所说灭者。若说依种类灭说者。彼说未至言摄未至定。静虑中间。上四近分。于未至定中摄有漏无漏。依此能灭欲界系。乃至第四静虑系身语无表故。若说依究竟灭说者。彼说未至言唯摄未至定。静虑中间。空无边处近分。于未至定中唯摄无漏。依此能灭第四静虑系身语无表故。由此故说身语无表依四或未至灭。表无表业广说如业蕴

三恶行三妙行三不善根三善根依何定灭。答依未至。此中三恶行欲界系。依未至定灭。身语二妙行欲界四静虑系及不系。欲界系者。依未至定灭初静虑系者。依初静虑未至定静虑中间第二静虑近分灭。乃至第四静虑系者。依四静虑未至定静虑中间空无边处近分灭。意妙行九地系及不系。欲界系者。依未至定灭。初静虑系者。依初静虑。未至定静虑中间第二静虑近分灭。乃至无所有处系者。依七根本未至定静虑中间非想非非想处近分灭。非想非非想处系者依七根本未至定静虑中间灭。然此中依三恶行近对治说三妙行故。但言依未至灭三不善根。欲界系依未至定灭。三善根九地系及不系。所依定灭。如意妙行说。此中亦依三不善根近对治说三善根。故亦但言依未至灭三恶行。乃至三善根如业蕴等广说。四非圣语四圣语。四生。四种入胎。四识住。依何定灭。答四非圣语。四圣语。胎卵湿生。四种入胎。依未至。化生后三识住依七或未至。色识住依四或未至。四非圣语者。谓不见言见。不闻言闻。不觉言觉。不知言知。问何故作此论。答为欲分别契经义故。如契经说。四非圣语。谓不见言见乃至广说。契经虽作是说。而不广分别。契经是此论所依根本。彼所不说者。今应分别。故作斯论。云何不见言见非圣语。答非眼所得。非眼识所了。名非所见。此非所见说名不见。若有于所不见不见想转。他问言。汝于是事曾见不。彼或自为或为他。或为名利。便覆此想此忍此欲。答言我见。是名不见言见非圣语。复有此类于见不见想转。而言见成非圣语。问何故复说此耶。答为显希有事故。如说。颇有于见言见。亦如于不见言见。成非圣语耶。答有。谓如有一于所见事不见想转。他问言汝于是事曾见不。彼或自为。或为他。或为名利。便覆此想此忍此欲。答言我见。彼于尔时如不见言见成非圣语。是亦名为不见言见非圣语。如广说不见言见非圣语。如是不闻言闻。不觉言觉。不知言知非圣语。广说亦尔。复有四非圣语。谓见言不见。闻言不闻。觉言不觉。知言不知。云何见言不见非圣语。答若眼所得眼识所了说名所见。此所见说名见。若有于所见见想转。他问汝于是事曾见不。彼或自为。或为他。或为名利。便覆此想此忍此欲。答言不见。是名见言不见非圣语复有此类。于不见见想转。而言不见。成非圣语。问何故复说此耶。答为显希有事故。如说。颇有于不见言不见。亦如于见言不见成非圣语耶。答有。谓如有一于所不见事见想转。他问言。汝于是事曾见不。彼或自为。或为他。或为名利。便覆此想此忍此欲。答言不见。彼于尔时如见言不见成非圣语。是亦名为见言不见非圣语。如广说见言不见非圣语。如是闻言不闻。觉言不觉。知言不知非圣语。广说亦尔。问如是所说便有八非圣语。或十六。何故但说四耶。答以所依事唯有四故。谓一切非圣语皆依见闻觉知事起故唯说四。复次略故说四。广则有八或十六。复次总故说四。别则有八或十六。如总别如是。不分别分别。不遍言遍言。无异言有异言。顿说渐说应知亦尔。问非圣语以何为自性。答以虚诳语为自性。问何故此语名非圣耶。答以不善故名非圣。复次于非圣相续中。现前故名非圣。复次非圣所成就故名非圣。复次非圣所说故名非圣。复次非圣由此得非圣名故名非圣。集异门说。何故名非圣。答由此能引不可爱。不可喜。不可乐不悦意不如意果。故名非圣。此显等流果。复次由此能招不可爱不可喜不可乐不悦意不如意异熟。故名非圣。此显异熟果。此非圣语或不律仪所摄。或非律仪非不律仪所摄。是业道唯不善。问颇有非圣语非业道。是无记色界系耶。答有。如大梵王对马胜苾刍所说语等。彼虽亦名非圣语。然非此中非圣语摄。以此中所说事或颠倒或不颠倒而想必颠倒故。阿罗汉独觉等亦有不见言见等事。而亦非此非圣语摄。以非覆想说故。如人想见杌而说见人。又如尊者目连记当生男而后生女。又言我住无所有处定。闻曼陀抧尼池中有多龙象振鼻哮吼。应知彼说皆非妄语以事虽倒而想无倒故。唯佛世尊无有如是错谬所说。永拔一切无知习故。现前了达三世境故。四圣语者。谓不见言不见。不闻言不闻。不觉言不觉。不知言不知。问何故复作此论。答为欲分别契经义故。如契经说四圣语。谓不见言不见。乃至广说。契经虽作是说。而不广分别。今欲分别故作斯论。云何不见言不见圣语。答不见义如前释。若有于所不见不见想转。他问言。汝于是事曾见不。彼不自为。不为他。不为名利。即时如实不覆此想此忍此欲。答言不见。是名不见言不见圣语。复有此类于见不见想转。而言不见成圣语。问何故复说此耶。答为显希有事故。如说颇有于见言不见。亦如于不见言不见成圣语耶。答有。谓如有一于所见事不见想转。他问言。汝于是事曾见不。彼不自为不为他。不为名利。即时如实不覆此想此忍此欲。答言不见。彼于尔时如于不见言不见成圣语。是亦名为不见言不见圣语。如广说不见言不见圣语。如是不闻言不闻。不觉言不觉。不知言不知。圣语广说亦尔。复有四圣语。谓见言见。闻言闻。觉言觉。知言知。云何见言见圣语。答见义如前释。若有于所见事见想转。他问言汝于是事曾见不。彼不自为。不为他。不为名利。即时如实不覆此想此忍此欲。答言我见。是名见言见圣语。复有此类。于不见见想转。而言见成圣语。问何故复说此耶。答为显希有事故。如说颇有于不见言见。亦如于见言见成圣语耶。答有。谓如有一于所不见事见想转。他问言。汝于是事曾见不。彼不自为。不为他。不为名利。即时如实不覆此想此忍此欲。答言我见。彼于尔时如于见言见成圣语。是亦名为见言见圣语。如广说见言见圣语。如是闻言闻。觉言觉。知言知圣语。广说亦尔。问如是所说便有八圣语或十六。何故但说四耶。答以所依事唯有四故。谓一切圣语皆依见闻觉知事起故唯说四。复次略故说四。广则有八或十六。复次总故说四。别则有八或十六。如总别如是。不分别分别。不遍言遍言。无异言有异言。顿说渐说。应知亦尔。问圣语以何为自性。答实语为自性。问何故此语名圣耶。答以善故名圣。复次于圣者相续中现前故名圣。复次圣者所成就故名圣。复次圣者所说故名圣。复次圣者由此得圣名故名圣。集异门说。何故名圣。答由此能引可爱可喜可乐悦意如意果故名圣。此显等流果。复次由此能招可爱可喜。可乐悦意如意异熟故名圣。此显异熟果。此圣语。或律仪所摄。或非律仪非不律仪所摄。是业道唯是善四非圣语唯欲界系依未至定灭。四圣语欲界初静虑系。欲界系者。依未至定灭。初静虑系者。依初静虑未至定静虑中间第二静虑近分灭。然此中依四非圣语近对治。说四圣语。故但言依未至灭

四生中胎卵湿生唯欲界系故。依未至定灭。化生依七或未至灭。谓化生九地系。欲界系者。依未至定灭。初静虑系者。依初静虑未至定静虑中间第二静虑近分灭。乃至非想非非想处系者。依七根本未至定静虑中间灭。然此中所说定者。若说依无漏定说者。彼说未至言显未至定静虑中间。若说依有漏无漏定说者。彼说未至言显未至定静虑中间上七近分。又此中所说灭者。若说依种类灭说者。彼说未至言。摄未至定静虑中间上七近分。于未至定中摄有漏无漏。依此能灭欲界系乃至非想非非想处系化生故。若说依究竟灭说者。彼说未至言。唯说未至定静虑中间。于未至定中唯摄无漏。依此能灭非想非非想处系化生故。由此故说化生依七或未至灭。四生如大种蕴广说

四种入胎者。有不正知入母胎。住出亦尔。是第一入胎。有正知入母胎。不正知住。不正知出。是第二入胎。有正知入母胎。亦正知住。不正知出。是第三入胎。有正知入母胎。住出亦尔。是第四入胎。问何故作此论。答为欲分别契经义故。如契经说。有四种入母胎。乃至广说。契经虽作是说而不广分别。契经是此论所依根本。彼不说者今欲说之。故作斯论。云何不正知入母胎住出亦尔。答此有二种。谓若薄福者于入胎时起颠倒想。颠倒胜解。见天阴惨寒切风雨。多人闹乱大众聚集。便念我今且入如是草棘丛中。或稠林间草窟叶窟。或住如是墙间树下以避风雨及诸喧乱。念已即见身往其中。彼住胎时。亦起如是倒想胜解。谓我今住如是丛林草窟叶窟墙间树下须臾止息。彼出胎时。亦有如是倒想胜解。谓我今出如是丛林草窟叶窟。或舍墙间树下而去。若福德者于入胎时。亦起颠倒想颠倒胜解。见天阴惨寒切风雨多人闹乱大众聚集。便念我应入此园苑。或花林间。或升殿堂。或登楼阁。以避风雨及诸闹乱。念已即见身入园中乃至登阁。于住胎时。亦起如是倒想胜解。谓我今住如是园苑花林堂阁跏趺而坐。于出胎时。亦有如是倒想胜解。谓我今出如是园苑。乃至从于楼阁而下。是名第一不正知入母胎住出亦尔。云何正知入母胎不正知住不正知出。答有多福者。入母胎时。不起颠倒想颠倒胜解。能自了知我今入母胎。彼住胎出胎便不正知。如前广说。是名第二正知入母胎不正知住不正知出。云何正知入母胎亦正知住不正知出。答有多福者。于入母胎住母胎时。皆不起颠倒想颠倒胜解。能自了知我今入母胎我今住母胎。然于出时便不正知。广如前说。是名第三正知入母胎亦正知住不正知出。云何正知入母胎住出亦尔。答有多福者。入母胎时。住母胎时。出母胎时。皆不起颠倒想颠倒胜解。能自了知。我今入母胎。我今住母胎。我今出母胎。是名第四正知入母胎住出亦尔。问何入胎是谁耶。答有说。第四入胎谓菩萨。第三入胎谓独觉。第二入胎谓轮王。第一入胎谓余有情。有说。第四入胎谓菩萨。第三入胎谓独觉。第二入胎谓波罗蜜多声闻。第一入胎谓余有情。有说。第四入胎谓菩萨。第三入胎谓独觉。第二入胎谓预流一来。第一入胎谓余有情。有说。诸有情中有求妙智业亦清净。有求妙智而业不净。有业清净而不求智。有不求智业亦不净。初有情作最后入胎。第二有情作第三入胎。第三有情作第二入胎。最后有情作最初入胎。谓初有情入母胎时。母腹安静离诸娆触。住母胎时。胎藏宽博清净无恼。出母胎时产门开舒不遭迫迮。故入住出皆不失念。第二有情。于入胎时及住胎时。如前安隐而不失念。但于出时。产门狭小被迫迮故即便失念。第三有情。于入胎时亦无娆触。如前安隐而不失念。然住胎时。胎藏窄隘杂秽所恼。及出胎时。产门狭小极为迫迮。故于住出俱令失念。第四有情入母胎时。母腹喧动惊恐不安。及住出时如前逼恼。故于三时皆令失念。复次此四种入胎皆谓菩萨。于中有说。第四入胎是第三阿僧企耶菩萨。第三入胎是第二阿僧企耶菩萨。第二入胎是初阿僧企耶菩萨。第一入胎是此前菩萨。有说。第四入胎是最后身菩萨。谓从睹史多天殁下生净饭王宫时。第三入胎是一生所系菩萨。谓当从赡部洲殁生睹史多天时。第二入胎是次此前生菩萨。谓所从殁生赡部洲迦叶波佛法中修梵行时。第一入胎。谓此前菩萨。评曰。不应作如是说。以菩萨从九十一劫来常忆宿命于死有中有生有本有常无倒想不失念故。由此因缘前说为善。问诸结生位必起染心。一切染心皆与不正知相应。云何得说正知入母胎耶。答所说正知。谓无颠倒想颠倒胜解。非要无明不相应故。名为正知。然菩萨于结生时。亦起自体爱父母爱故。亦有染心。问若尔。与余有情何异。答如余有情将入胎时。父非父想母非母想。由如此故。男则于父生恚于母生爱。起颠倒想。谓与母会。女则于母生恚于父生爱起颠倒想。谓与父会。由此倒想而便结生。菩萨不尔。将入胎时。于父父想于母母想。我依彼故增长后蕴。当于赡部洲中受尊胜报依此证得阿耨多罗三藐三菩提。与诸有情作饶益事。作是念已。便于父母等生亲爱。由此结生。是故正知。谓无倒想非要无染。此四种入胎唯欲界系。是故但依未至定灭

四识住中后三识住依七或未至灭。谓后三识住九地系。欲界系者。依未至定灭。初静虑系者。依初静虑。未至定静虑中间第二静虑近分灭。乃至非想非非想处系者。依七根本未至定静虑中间灭。然此中所说定者。若说依无漏定说者。彼说未至言显未至定静虑中间。若说依有漏无漏定说者。彼说未至言显未至定静虑中间上七近分。又此中所说灭者。若说依种类灭说者。彼说未至言摄未至定静虑中间上七近分。于未至定中摄有漏无漏。依此能灭欲界系乃至非想非非想处系后三识住故。若说依究竟灭说者。彼未至言摄未至定静虑中间。于未至定中唯摄无漏。依此能灭非想非非想处系后三识住故。由此故言依七或未至灭。色识住依四或未至灭。谓色识住五地系。欲界系者。依未至定灭。乃至第四静虑系者。依四静虑未至定静虑中间空无边处近分灭。然此中所说定者。有说。依无漏定说。有说。依有漏无漏定说。随其所应如前分别。又此中所说灭者。若说依种类灭说者。彼说未至言摄未至定静虑中间上四近分。于未至定中摄有漏无漏。依此能灭欲界系乃至第四静虑系色识住故。若说依究竟灭说者。彼说未至言。摄未至定静虑中间空无边处近分。依此能灭第四静虑系色识住故。由此故言依四或未至灭四识住。广说如大种蕴

说一切有部发智大毗婆沙论卷第一百七十一阿毗达磨大毗婆沙论卷第一百七十二

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    定蕴第七中摄纳息第三之七

五蕴五取蕴五趣五妙欲五学处。依何定灭。答色蕴色取蕴依四或未至。四蕴四取蕴天趣。依七或未至。余四趣五妙欲五学处依未至。此中五蕴五取蕴。广说如十门纳息。然色蕴五地系及不系。色取蕴唯五地系。此俱依四或未至灭。谓欲界系者。依未至定灭。乃至第四静虑系者。依四静虑未至定静虑中间空无边处近分灭。然此中所说定者。有说。无漏。有说。有漏无漏。如前分别。所说灭者。若说此依种类灭说者。彼说未至言。摄未至定静虑中间上四近分。于未至定中摄有漏无漏。依此能灭欲界系乃至第四静虑系色蕴色取蕴故。若说此依究竟灭说者。彼说未至言。摄未至定静虑中间空无边处近分。于未至定中唯摄无漏。依此能灭第四静虑系色蕴色取蕴故。由此故说依四或未至灭。四蕴九地系及不系。四取蕴九地系。此俱依七或未至灭。谓欲界系者。依未至定灭。乃至非想非非想处系者。依七根本未至定静虑中间灭。然此中所说定者。有说。无漏。有说。有漏无漏。亦如前分别。所说灭者。若说此依种类灭说者。彼说未至言。摄未至定静虑中间上七近分。于未至定中摄有漏无漏。依此能灭欲界系乃至非想非非想处系四蕴四取蕴故。若说此依究竟灭说者。彼说未至言。摄未至定静虑中间。于未至定中唯摄无漏。依此能灭非想非非想处系四蕴四取蕴故。由此故言依七或未至灭

五趣谓奈落迦傍生鬼人天趣。问何故作此论。答为欲分别契经义故。如契经说。五趣谓地狱趣乃至天趣。契经虽作是说。而不广分别。契经是此论所依根本。彼所不说者今应分别。故作斯论。问趣体性是何。为无记为三种。若无记者。品类足论当云何通。如说。五趣一切随眠之所随增。若三种者。云何诸趣不相杂乱。谓地狱趣成就乃至他化自在天业烦恼。乃至他化自在天。成就乃至地狱趣业烦恼故。答应作是说。趣体唯是无覆无记。问若尔。则诸趣不相杂乱。然品类足说当云何通。答彼文应说。四趣是欲界遍行及修所断随眠随增。天趣是三界遍行及修所断随眠随增。而不作此说者。当知是诵者错谬。有说。彼论通说五趣眷属。谓结生位五部烦恼相应之心。彼心是一切随眠所随增故。有说。趣体通善染无记。问若尔则品类足说善通。云何诸趣不相杂乱。答若以成就则有杂乱。若以现行则无杂乱。谓地狱趣于地狱趣业烦恼成就亦现行。于乃至他化自在天业烦恼成就不现行。乃至他化自在天。于他化自在天业烦恼成就亦现行。于乃至地狱趣业烦恼成就不现行。是故诸趣无杂乱过。评曰应说趣体唯是无覆无记。云何知然。如契经中尊者舍利子作是言。若地狱诸漏现在前时。造作增长顺地狱受业。彼身语意曲秽浊故。于捺落迦中受五蕴异熟。异熟起已名奈落迦。除此五蕴彼奈落迦都不可得。乃至天趣说亦如是。由此故知趣体唯是无覆无记。问已知趣体唯是无覆无记。于中为但是异熟。为通长养。若但是异熟者。品类足说当云何通。如说。五趣摄五蕴十二处十八界。声处声界非异熟故。若通长养者。则趣体杂乱。以人趣中亦能引起色界长养诸根大种故。答应作是说。诸趣体性唯是异熟。问品类足说当云何通。答彼文应说。五趣摄五蕴十一处十七界少分。而不作是说者。当知是诵者错谬。有说彼论通说五趣眷属感五趣业及能防护。非唯说趣。是故无过。然由烦恼界有差别。由异熟蕴趣有差别。是故趣体唯是异熟。问何故名趣。趣是何义。答所往义是趣义是诸有情所应往。所应生。结生处。故名趣。已总说诸趣。彼一一异相今当说。云何奈落迦趣。答诸奈落迦一类伴侣众同分。依得事得处得。及已生奈落迦无覆无记色受想行识。是名奈落迦趣。此中一类伴侣众同分言。显彼众同分。依得事得处得言。显彼界蕴处得。及已生奈落迦无覆无记色受想行识言。显彼自体是异熟非余。问何故彼趣名奈落迦。答是奈落迦所趣处故。以奈落迦为所有故名奈落迦。彼诸有情无悦无爱无味无利无喜乐故。名奈落迦。或有说者。由彼先时造作增长增上暴恶身语意恶行。往彼生彼令彼生相续。故名奈落迦。有说。奈落迦者。是假名假想名施设想施设。一切名想随欲而立不必如义。有说。彼趣以卑下故名奈落迦。谓五趣中无有卑下如彼趣者。有说。彼趣以颠坠故名奈落迦。如有颂言

  颠坠于地狱　　足上而头下
  由毁谤诸仙　　乐寂修苦行

有说。奈落名人。迦名为恶。恶人生彼处故名奈落迦。有说。落迦名可乐。奈是不义。彼处不可乐故名奈落迦。有说。落迦名喜乐。奈是坏义。彼处坏喜乐故名奈落迦。有说。落迦名归趣。奈是无义。彼处有情重苦所逼无归趣。故名奈落迦。有说。落迦名救济。奈是无义。彼处有情众苦所逼。无救济者。故名奈落迦。问何故彼趣最下最大者名无间耶。答彼是假名假想。名施设想施设。一切名想随欲而立。不必如义。彼处或名百钉钉身。或名六苦触处。或名自受苦受。或名无间。虽亦有间假说无间。有说。彼处恒受苦受无喜乐间故名无间。问余地狱中岂有歌舞饮食受喜乐异熟故不名无间耶。答余地狱中虽无异熟喜乐。而有等流喜乐。如施设论说等活地狱中有时凉风所吹血肉还生。有时出声唱言等活。彼诸有情欻然还活。唯于如是血肉生时及还活时。暂生喜乐。间苦受故不名无间。有说。众多有情造作恶业相续生彼。满彼处所故名无间。评曰不应作是说。生余地狱多生无间者少。所以者何以造作增长上品身语意恶业者乃生彼处。有情造作增长上品恶业生彼处者少。造作增长中下品恶业生余地狱者多。如造作增长上品善业生有顶者小。造作增长中下品善业生余处者多故。应作是说。由造作增长增上不善业。生彼所得身形广大。一一有情据多处所。中无间隙。故名无间。问地狱在何处。答多分在此赡部洲下。云何安立答有说。从此洲下四万踰缮那至无间地狱底。无间地狱纵广高下各二万踰缮那。次上一万九千踰缮那中。安立余七地狱。谓次上有极热地狱。次上有热地狱。次上有大[口*睪]叫地狱。次上有[口*睪]叫地狱。次上有众合地狱。次上有黑绳地狱。次上有等活地狱。此七地狱一一纵广万踰缮那。次上余有一千踰缮那五百踰缮那是白墡。五百踰缮那是泥。有说。从此洲下四万踰缮那至无间地狱。此无间地狱纵广高下各二万踰缮那。次上有三万五千踰缮那安立余七地狱。一一纵广高下各五千踰缮那。次上余有五千踰缮那。千踰缮那青色土。千踰缮那黄色土。千踰缮那赤色土。千踰缮那白色土。五百踰缮那白墡。五百踰缮那是泥。有说。无间地狱在于中央。余七地狱周回围绕。如今聚落围绕大城。问若尔者。施设论说当云何通。如说赡部洲周围六千踰缮那。三踰缮那半。一一地狱其量广大。云何于此洲下得相容受。如有颂言

  热铁地如血　　猛火恒洞然
  多百踰缮那　　周遍焰交彻

答此赡部洲上尖下阔。犹如谷聚。故得容受。由此经中说四大海渐入渐深。又一一大地狱有十六增。谓各有四门。一一门外各有四增。一煻煨增。谓此增内煻煨没膝。二尸粪增。谓此增内尸粪泥满。三锋刃增。谓此增内复有三种。一刀刃路。谓于此中仰布刀刃以为道路。二剑叶林。谓此林上纯以铦利剑刃为叶。三铁刺林。谓此林上有利铁。刺长十六指。刀刃路等三种虽殊而铁枝同故一增摄。四烈河增。谓此增内有热碱水。并本地狱以为十七。如是八大地狱并诸眷属。便有一百三十六所。是故经说有一百三十六奈落迦。问何故眷属地狱说名为增。答有说。本地狱中一种苦具治诸有情。此眷属中种种苦具治诸有情故名为增。是故天使经说。眷属地狱中以种种苦具治有罪者。有说。此是增受苦处故说名增。谓本地狱中被逼切已。复于此处重遭苦故。非谓多种苦具名增。本地狱中亦多苦具故。施设论说眷属地狱中唯有一种煻煨等故。问诸地狱卒。为是有情数。非有情数耶。若是有情数者。彼多造恶。复于何处受异熟耶。若非有情数者。大德法善现颂当云何通。如说

  心常怀忿毒　　好集诸恶业
  见他苦生悦　　死作琰魔卒

有说。是有情数。问彼多造恶。复于何处受异熟耶。答即于彼地狱受。以彼中尚容无间业等极重异熟。况复此耶。有说。此是非有情数。由诸罪者业增上力。令非有情似有情现。以诸苦具残害其身。问若尔大德法善现颂当云何通。答此不必须通。以非素怛缆毗奈耶阿毗达磨所说。但是造制文颂。夫造文颂或增或减。不必如义何须通耶。若必欲通者。彼有别意。谓若以铁锁系缚初生地狱有情。往琰魔王所者是有情数。若以种种苦具于地狱中害有情者。是非有情数。大德依有情数作如是说。赡部洲下有大地狱。赡部洲上亦有边地狱。及独地狱或在谷中。或在山上。或在旷野。或在空中。于余三洲唯有边地狱独地狱无大地狱。所以者何。唯赡部洲人造善猛利。彼作恶业亦复猛利。非余洲故。有说。北拘卢洲亦无边地狱等。是受淳净业果处故。问若余洲无大地狱者。彼诸有情造无间业。断善根等当于何处受异熟耶。答即于此赡部洲下大地狱。受问地狱有情其形云何。答其形如人。问语言云何。答彼初生时皆作圣语。后受苦时虽出种种受苦痛声。乃至无有一言可了。唯有斫刺破裂之声

云何傍生趣。答诸傍生一类伴侣众同分。依得事得处得。及已生傍生无覆无记色受想行识。是名傍生趣。解释如前。问何故彼趣名傍生。答其形傍故行亦傍。以行傍故形亦傍。是故名傍生。有说。傍生者是假名假想。名施设想施设。一切名想随欲而立不必如义。有说。彼诸有情由造作增长增上愚痴身语意恶行。往彼生彼。令彼生相续。故名傍生趣。有说彼趣闇钝故名傍生。闇钝者即是无智。一切趣中无有无智如彼趣者。有说。流遍诸处故名傍生。谓此遍于五趣皆有。奈落迦中有无足者。如娘矩吒虫等。有二足者。如铁嘴鸟等。有四足者。如黑驳狗等。有多足者。如百足等。于鬼趣中有无足者。如毒蛇等。有二足者。如乌鸱等。有四足者。如狐狸象马等。有多足者。如六足百足等。于人趣三洲中有无足者。如一切腹行虫。有二足者。如鸿雁等。有四足者。如象马等。有多足者。如百足等。于北拘卢洲中有二足者。如鸿雁等。有四足者。如象马等。无有无足及多足者。彼是受无恼害业果处。故四大王众天及三十三天中。有二足者。如妙色鸟等。有四足者。如象马等。余无者如前释。上四天中唯有二足者。如妙色鸟等。余皆无者。空居天处转胜妙故。问彼处若无象马等者。以何为乘。亦闻彼天乘象马等。云何言无。答由彼诸天福业力故。作非情数象马等形。而为御乘以自娱乐。问傍生本住何处。答本所住处在大海中。后时流转遍在诸趣。问其形云何。答多分傍侧。亦有竖者。如紧奈落。毕舍遮。醯卢索迦等。问语言云何。答劫初成时皆作圣语。后以饮食时分有情不平等故。及谄诳增上故便有种种语。乃至有不能言者

云何鬼趣。答诸鬼一类伴侣众同分。乃至广说。问何故彼趣名闭戾多。答施设论说。如今时鬼世界王名琰魔。如是劫初时有鬼世界王名秕多。是故往彼生彼诸有情类皆名闭戾多。即是秕多界中所有义。从是以后皆立此名。有说。闭戾多者是假名假想。乃至广说。有说。由造作增长增上悭贪身语意恶行。往彼生彼令彼生相续。故名鬼趣。有说。饥渴增故名鬼。由彼积集感饥渴业。经百千岁不闻水名。岂能得见。况复得触。或有腹大如山咽如针孔。虽遇饮食而不能受。有说。被驱役故名鬼。恒为诸天处处驱役常驰走故。有说。多希望故名鬼。谓五趣中从他有情希望多者无过此故。由此因缘故名鬼趣。问鬼住何处。答赡部洲下五百踰缮那有琰魔王界。是一切鬼本所住处。从彼流转亦在余处。于此洲中有二种鬼。一有威德。二无威德。有威德者。或住花林果林种种树上好山林中。亦有宫殿在空中者。乃至或住余清净处受诸福乐。无威德者。或住厕溷粪壤水窦坑堑之中。乃至或住种种杂秽诸不净处。薄福贫穷饥渴所苦。东毗提诃。西瞿陀尼。亦有此二。北拘卢洲唯有大威德者。有说。全无。以诸鬼趣悭贪所感。北拘卢洲是无所摄受有情生处故。四大王众天及三十三天中。虽有大威德鬼。与诸天众守门防逻导从给使。有说。于此赡部洲西有五百渚两行而住。于两行渚中有五百城。二百五十城有威德鬼住。二百五十城无威德鬼住。是故昔有转轮王名尔弥。告御者摩怛梨曰。吾欲游观。汝可引车从是道去。令我见诸有情受善恶果。时摩怛梨即如王教引车从于二渚中过。时王见彼有威德鬼。首冠花鬘身着天衣。食甘美食犹如天子。乘象马车各各游戏。见无威德鬼。头发蓬乱裸形无衣。颜色枯悴以发自覆。执持瓦器而行乞丐。见已深信善恶业果。问鬼趣形状云何。答多分如人。亦有傍者。或面似猪。或似种种余恶禽兽。如今壁上彩画所作。问语言云何。答劫初成时皆作圣语。后时随处作种种言。或有说者。随从何处命终生此即作彼形即作彼语。评曰。不应作是说。若从无色界殁来生此趣可无形无言耶。应作是说。随所生处形言亦尔

云何人趣。答人一类伴侣众同分。乃至广说。问何故此趣名末奴沙。答昔有转轮王名曼驮多。告诸人曰。汝等欲有所作应先思惟称量观察。尔时诸人即如王教。欲有所作皆先思惟称量观察。便于种种工巧业处而得善巧。以能用意思惟观察所作事故。名末奴沙。从是以来传立斯号。先未号此末奴沙时。人或相呼以为云颈。或名多罗胫。或名底落迦。或名阿沙荼。有说。末奴沙者是假名假想。乃至广说。有说。先造作增长下身语意妙行。往彼生彼令彼生相续。故名人趣。有说多憍慢故名人。以五趣中憍慢多者无如人故。有说。能寂静意故名人。以五趣中能寂静意无如人者。故契经说。人有三事胜于诸天。一勇猛。二忆念。三梵行勇猛者。谓不见当果而能修诸苦行。忆念者。谓能忆念久时所作。所说等事分明了了。梵行者。谓能初种顺解脱分顺决择分等殊胜善根。及能受持别解脱戒。由此因缘故名人趣。问人住何处。答住四大洲。谓赡部洲。毗提诃洲。瞿陀尼洲。拘卢洲。亦住八中洲。何等为八。谓拘卢洲有二眷属。一矩拉婆洲。二憍拉婆洲。毗提诃洲有二眷属。一提诃洲。二苏提诃洲。瞿陀尼洲有二眷属。一舍搋洲。二嗢怛罗漫怛里拏洲。赡部洲有二眷属。一遮末罗洲。二筏罗遮末逻洲。此八洲中人形短小如此方侏儒。有说。七洲是人所住。遮末罗洲唯罗刹娑居。有说。此所说八即是四大洲之异名。以一一洲皆有二异名故。如是说者。应如初说此八中洲一一复有五百小洲以为眷属。于中或有人住。或非人住。或有空者。问人趣形貌云何。答其形上立。然赡部洲人面如车箱。毗提诃人面如半月。瞿陀尼人面如满月。拘卢洲人面如方池。问语言云何。答世界初成时一切皆作圣语。后以饮食时分有情不平等故。及谄诳增上故便有种种语。乃至有不能言者

云何天趣。答天一类伴侣。乃至广说。问何故彼趣名天。答于诸趣中彼趣最胜。最乐最善最妙最高故名天趣。有说。先造作增长上身语意妙行往彼生彼。令彼生相续故名天趣。有说。天者是假名假想乃至广说。有说。光明增故名天。以彼自然身光恒照昼夜等故。声论者说能照故名天。以现胜果照了先时所修因故。复次戏乐故名天。以恒游戏受胜乐故。问诸天住在何处。答四大王众天住七金山。及妙高山四层级上。并日月星中。三十三天住妙高山顶。夜摩乃至色究竟天。皆在空中密云如地。各有宫殿于中居止。差别广说如大种蕴。无色界天无形色故无别住处。问诸天形相云何。答其形上立。问语言云何。答皆作圣语

已说五趣一一差别。于彼中有阿素洛今当说。谓有余部立阿素洛为第六趣。彼不应作是说。契经唯说有五趣故。问何故名阿素洛。答素洛是天。彼非天故名阿素洛。复次素洛名端政。彼非端政故名阿素洛。以彼憎嫉诸天令所得身形不端政故。复次素洛名同类。彼先与天相近而住。然类不同故名阿素洛。谓世界初成时诸阿素洛先住苏迷卢顶。后有极光净天寿尽业尽福尽故从彼天殁来生是中。胜妙宫殿自然而出。诸阿素洛心生嫉恚即便避之。此后复有第二天生彼更移处。如是乃至三十三天遍妙高山顶次第而住。彼极嗔恚即便退下。然诸天众于初生时咸指之言。此非我类此非我类。由斯展转名非同类。复由生嫉恚故形不端政。即以此故名非端政。问诸阿素洛退住何处。答有说。妙高山中有空缺处如覆宝器。其中有城是彼所住。问何故经说阿素洛云我所住海同一碱味。答彼所部村落住碱海中。而阿素落王住彼山内。有说。大碱海中于金轮上有大金台。高广各五百踰缮那。台上有城是彼所住。问若尔何故施设论说内海诸龙见阿素洛军。着金银吠琉璃颇胝迦铠。执金银等种种器仗。从阿素洛城出便告诸天耶。答天以诸龙在金山上而为守逻。彼时遥见大碱海中阿素洛军从城而出便告天众。如三十三天有四妙苑。谓众车粗恶杂林喜林。阿素洛王亦有四苑。一名庆悦。二名欢喜。三名极喜。四名可爱。如三十三天有波利夜怛罗树。阿素洛王亦有质怛罗波吒梨树。如三十三天帝释为主。诸阿素洛毗摩质怛罗为主。问阿素洛其形云何。答其形上立。问语言云何。答皆作圣语。问诸阿素洛何趣所摄。答有说。是天趣摄。问若尔何故不能入正性离生。答谄曲所覆故。其事云何。答彼常疑佛朋党诸天。若佛为其说四念住。彼作是念。佛为我等说四念住。必为诸天说五念住。乃至若佛为说三十七助道法。彼作是念。佛为我等说三十七。必为诸天说三十八。以为如是谄曲心所覆故。不能入正性离生。复次不可以不能入正性离生故便谓恶趣所摄。如诸达絮及篾戾车人亦不能入正性离生。而非恶趣所摄彼亦应尔。如是说者。是鬼趣摄。问若尔何故经说。帝释语毗摩质怛罗阿素洛王言。汝本是此处天。答帝释应言汝本是此处鬼。而言天者以尊敬妇公故作此爱语。又令设芝闻生欢喜。问若是鬼者何以与诸天交亲耶。答诸天贪美色故不为族姓。如设芝阿素洛女端政无比。是故帝释纳以为妻。亦如大树紧捺洛王女名为夺意端政无双。虽是傍生趣摄。而苏迷王太子苏达那菩萨求娉为妻此亦如是。问何以复能与天斗战。答亦有劣者与胜者共诤。如奴与主斗狗与人斗

问亦有人所承事以为天者。如筏栗达那神。旃稚迦神。旃荼履迦神。布刺拏跋达罗神。摩尼跋达罗神。诃利底神。末度塞建陀神等。为是天趣为鬼趣耶。若是天趣何故夺人精气。亦断人命受人祠祀。以诸天观人饮食犹如粪秽。不应贪餮以为香美故。若是鬼趣诃利底神所说颂云何通。如说

  可爱汝应默　　嗢怛罗亦然
  我若见谛时　　亦令汝等见

末度塞建陀神所说复云何通。如说。长者勿怖长者勿怖。我次前生名末度塞建陀。与长者常为亲友。今生四大王众天中。恒住此始缚迦门上守护人众耶。答有说。彼是天趣。问若尔何故夺人精气。亦断人命受人祠祀耶。答彼无是事。但彼所领鬼神有夺人精气等事。如是说者。彼是鬼趣。问诃利底神颂当云何通。答彼于谛愚实不能见。而以深信故发此言。又于尔时闻说四谛起增上慢生见谛想故作是说。问末度塞建陀所说复云何通。答彼于趣愚实不能辩。以自高故说我生天。如今富人向仆隶边自称高贵彼亦如是。又彼承事四大王众天。而以自身摄同所事故作是说。诸依地住神如鸠畔荼药叉逻刹娑羯吒布怛那等皆鬼趣摄。若紧捺落毕舍遮醯卢索迦婆路尼折罗颇勒窭罗等皆傍生趣摄。彼形虽上立而犹有傍生相。谓或有耳尖。或有戴角。或执险杖。或作诸鸟兽头。或作傍生蹄具。是故皆是傍生趣摄

此中前四趣唯欲界系故依未至定灭。天趣依七或未至灭。然天趣九地系。欲界系者依未至定灭。乃至非想非非想处系者依七根本。未至定静虑中间灭然。此中所说定者。有说无漏。有说有漏无漏。如前分别。所说灭者。若说此依种类灭说者。彼说未至言摄未至定静虑中间上七近分。于未至定中摄有漏无漏。依此能灭欲界系。乃至非想非非想处系天趣故。若说此依究竟灭说者。彼说未至言摄未至定。静虑中间。于未至定中唯摄无漏。依此能灭非想非非想处系天趣故。由此故言依七或未至灭

说一切有部发智大毗婆沙论卷第一百七十二阿毗达磨大毗婆沙论卷第一百七十三

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    定蕴第七中摄纳息第三之八

五妙欲者。谓眼所识可爱可喜可乐。如意能引欲可染着色。乃至身所识可爱可喜可乐。如意能引欲可染着触。问何故作此论。答为欲分别契经义故。如契经说。眼所识可爱可喜乃至广说。契经虽作是说而不广分别。契经是此论所依根本。彼所不说者今应说之故作斯论。云何眼所识色妙欲。答若色欲界眼触所生爱所缘境。云何耳所识声妙欲。答若声欲界耳触所生爱所缘境。云何鼻所识香妙欲。答若香鼻触所生爱所缘境。云何舌所识味妙欲。答若味舌触所生爱所缘境。云何身所识触妙欲。答若触欲界身触所生爱所缘境。问意所识法何故不立妙欲耶。答皆是爱所缘者立妙欲。意所识法有非爱所缘故不立妙欲。复次若法为二种爱所缘者立妙欲。谓眼触所生爱。意触所生爱。乃至身触所生爱。意触所生爱。意所识法但为一种爱所缘。谓意触所生爱是故不立妙欲。问若尔者初静虑色声触应立妙欲。亦为二种爱所缘故。答若法为二种爱所缘。而彼爱是不善者立妙欲。初静虑色声触。虽为二种爱所缘。而彼爱是无记故不立妙欲。如不善无记欲爱。色爱说亦尔。有说。若法为二种爱所缘。而是淫因缘爱者立妙欲。初静虑色声触。虽为二种爱所缘。而非淫因缘爱故不立妙欲。以是义故意所识法不立妙欲。复次若法是共所受用者立妙欲。如女相续男所受用。男相续女所受用等。意所识法非共受用故不立妙欲。复次若法体相粗显多生爱者立妙欲。意所识法体相微细。非多生爱故不立妙欲。已说自性所以今当说。问何故名妙欲。答此欲妙故名为妙欲。问此皆有漏多诸过失。有何功德说名为妙。答此中亦有少分功德。谓能生喜乐是故云妙。复次诸欲下贱而耽欲者。分别增益取为净妙故说为妙。复次诸欲称可欲贪者意故说为妙。复次诸欲是耽欲者。保护希尚故说为妙。复次此能随顺增长贪欲爱味故说为妙。尊者妙音说曰。此是愚夫起妙想处故名为妙。尊者世友说曰。此是诸习欲者所爱所喜所乐所求故名妙欲。尊者觉天说曰。诸欲虽非胜义妙。而是世俗妙。虽非究竟妙。而是暂时妙。谓能少时引生喜乐息诸苦故。大德说曰。诸欲下劣而似净妙故说为妙。由此因缘故名妙欲。如契经说。具寿迦莫迦往至佛所。顶礼佛足白佛言。世尊。佛常说欲欲为显何事。佛言。欲者即五妙欲。何等为五。谓眼所识可爱可喜可乐。如意能引欲可染着色。乃至广说。问胜义欲者。谓爱何故世尊说色等名欲。答是欲具故名欲。如乐具名乐。垢具名垢。漏具名漏。此亦如是。问何以得知胜义欲唯是爱。答由阿笈摩故。如尊者舍利子说伽他言

  世诸妙境非真欲　　真欲谓人分别贪
  妙境如本住世间　　智者于中已除欲

尔时有一邪命外道不远而住。即时以颂诘舍利子言

  若世妙境非真欲　　说欲是人分别贪
  苾刍应名受欲人　　起恶分别寻思故

时舍利子报外道言。起恶寻思实名受欲。复为外道说伽他言

  若世妙境是真欲　　说欲非人分别贪
  汝师应名受欲人　　恒观可意妙色故

时彼外道默不能报。故知实欲是爱非境。契经中说欲生有三。一有诸有情乐受现前诸妙欲境。彼于如是现欲境中自在而转。谓人及天一分。人者全摄人趣。天一分者谓下四天。二有诸有情乐受。自化诸妙欲境。彼于自化妙欲境中自在而转。谓第五乐变化天。三有诸有情乐受。他化诸妙欲境。彼于他化妙欲境中自在而转。谓第六他化自在天。问依何建立此三欲生。答依受如生现前欲境故立第一。依受如乐自化欲境故立第二。依受如乐他化欲境故立第三。问何故人及前四天众合立欲生。后二天众各别建立。答人及前四天烦恼粗。后二天烦恼细。复次人及前四天烦恼利。后二天烦恼数。复次人及前四天烦恼重。后二天众烦恼轻。是故人及前四天总立。后二天别立。有说。人及前四天境不炽盛。后二天境界炽盛。复次人及前四天境不丰盈。后二天境界丰盈。复次人及前四天境不净妙。后二天境界净妙。复次人及前四天境不夺心。后二天境界夺心。复次人及前四天境不能令诸根醉闷。后二天境界能令诸根醉闷。是故人及前四天合立。后二天别立。有说。人及前四天去离欲道。远淫事难息是故合立。后二天去离欲道。近淫事易息是故别立。有说。人及前四天相触成淫是故合立。第五天共笑成淫。第六天相视成淫故各别立。此依喻显淫事时量差别而说如前已辩。有说。人及前四天。同乐受用自然生境故合立一。第五天众独乐受用自所化境。第六天众独乐受用他所化境故各立一。此五妙欲唯欲界系。是故但依未至定灭

五学处者。谓离断生命。离不与取。离欲邪行。离虚诳语。离饮诸酒。此五广说如业蕴。皆欲界系故唯依未至定灭。六内处。六外处。六识身。六触身。六受身。六想身。六思身。六爱身。依何定灭。答五内处色声触外处。依四或未至。意内处。法外处。意识身。及彼相应触受想思爱身。依七或未至。香味外处鼻舌识身。及彼相应触受想思爱身依未至。眼耳身识身。及彼相应触受想思爱身。依初或未至。问何故于此依六法而作论。答彼作论者意欲尔故随彼意而作论。但不违法相便不应责。复次不应问作论者意。此是契经所说故。佛于经中处处说此诸六法门而不广分别。契经是此论所依根本。彼所不分别者今应分别故作斯论。问置作论者意。即佛经中何故说此六法门耶。答有说。为显五蕴及彼因故。谓若说前五内处前五外处。及法处一分则显色蕴。若说六受身及法处一分则显受蕴。若说六想身及法处一分则显想蕴。若说六触身及法处一分则显行蕴。若说六识身及意处则显识蕴。若说六思身六爱身则显五蕴因。如契经说业为生因爱为起因生起即是所得五蕴。有说。为显业烦恼苦三种集故。谓若说。六思身则显业集。若说六爱身则显烦恼集。若说余六则显苦集。如为显业等三集。如是为显业等三生。业等三道应知亦尔。诸六自性杂蕴等已说。然前五内处。及色声触外处皆五地系故。依四或未至灭。于中欲界系者依未至定灭。乃至第四静虑系者。依四静虑。未至定。静虑中间。空无边处近分灭。然此中所说定者。有说。依无漏定说。有说。依有漏无漏定说。如前分别。所说灭者。若说依种类灭说者。彼说未至言摄未至定。静虑中间。上四近分。于未至定中摄有漏无漏。依此能灭欲界系。乃至第四静虑系。五内处及色声触外处故。若说依究竟灭说者。彼说未至言摄未至定。静虑中间。空无边处近分。于未至定中唯摄无漏。依此能灭第四静虑系。五内处。及色声触外处故。由此故言依四或未至灭。意内处法外处。意识身及彼相应触受想思爱身皆九地系。及有不系者。彼九地系者依七或未至灭。于中欲界系者依未至定灭。乃至非想非非想处系者。依七根本。未至定。静虑中间灭。然此中所说定者。有说无漏。有说。有漏无漏如前分别。所说灭者。若说依种类灭说者。彼说未至言摄未至定。静虑中间。上七近分。于未至定中摄有漏无漏。依此能灭欲界系。乃至非想非非想处系意处等故。若说依究竟灭说者。彼说未至言摄未至定。静虑中间。于未至定中唯摄无漏。依此能灭非想非非想处系意处等故。由此故言依七或未至灭。香味外处鼻舌识身。及彼相应触受想思爱身。皆欲界系故唯依未至定灭。眼耳身识身。及彼相应触受想思爱身。皆二地系故。依初或未至灭。于中欲界系者依未至定灭。初静虑系者依初静虑。未至定。静虑中间。第二静虑近分灭。然此中所说定者。有说无漏。有说。有漏无漏如前分别。所说灭者。有说。依种类灭说。有说。依究竟灭说。随其所应亦如前分别。由此故言依初或未至灭

七识住。八世法。九有情居。十业道。依何定灭。答初识住。八世法。初有情居。十业道。依未至。第二识住。有情居。依初或未至。第三识住有情居。依二或未至。第四识住有情居。依三或未至。第五有情居。依四或未至。第五识住。第六有情居。依五或未至。第六识住。第七有情居。依六或未至。第七识住。第八第九有情居。依七或未至。七识住如大种蕴广说。于中初识住唯欲界系故。但依未至定灭。第二识住初静虑系故。依初静虑。未至定。静虑中间。第二静虑近分灭。第三识住第二静虑系故。依初二静虑。未至定。静虑中间。第三静虑近分灭。第四识住第三静虑系故。依初三静虑。未至定。静虑中间。第四静虑近分灭。第五识住空无边处系故。依五根本。未至定。静虑中间。识无边处近分灭。第六识住识无边处系故。依六根本。未至定。静虑中间。无所有处近分灭。第七识住无所有处系故。依七根本。未至定。静虑中间。非想非非想处近分灭。然此中所说定者。有说无漏。有说。有漏无漏如前分别。所说灭者。此中无有种类灭究竟灭二说差别。以各各但是一地系故

八世法者。一利二无利三誉四非誉五赞六毁七乐八苦。问何故作此论。答欲止他宗显己义故。谓分别论者。及大众部师执。佛生身是无漏法。彼何故作是说。依契经故如契经说。如来生世住世出现世间。不为世法所染。彼依此故说佛生身是无漏法。又彼说言佛一切烦恼并习气皆永断故。云何生身当是有漏。为止彼意显佛生身但是有漏非无漏法故作斯论。问云何知佛生身是有漏法。答如契经说。苾刍当知。无明所覆。爱结所系。愚夫感得有识之身。聪明者亦然。佛生身既是无明爱果故知非无漏法。又契经说。十处二少分是有漏。由此故知佛生身定是有漏。若佛生身是无漏者。无比女不应生贪。央掘利魔罗不应生嗔。邬卢频螺迦叶波。不应生痴。傲慢婆罗门不应生慢。以佛生身生他贪嗔痴慢故知定是有漏。问若尔者彼所引经当云何通。答彼经密意说佛法身。谓如来生世住世者。说佛生身出现世间。不为世法所染者说佛法身。复次世法者。即世八法。如来不为世八法所染故。言世法不染非谓无漏。谓世八法随顺世间有情。世间有情亦随顺世八法。世八法随顺如来。如来不随顺世八法。故说如来非世法所染。复次如来离世八法。故言不染非谓无漏。问如来亦有世八法何故言离。有利者。如邬揭罗长者。于一日中以三百千衣服施佛。时缚迦医王等八十人于一日中。各奉佛百千双憍舍耶衣。无利者。如佛一时着衣持钵。入娑罗婆罗门村乞食。空钵而入空钵而出。有誉者。佛初生时名至他化自在天。得阿耨多罗三藐三菩提时。名至色究竟天。转法轮时名至梵天。非誉者。如佛一日遭战遮婆罗门女诽谤。又于一时因孙陀利女恶声闻于十六大国。有毁者。如跋罗惰阇恶口婆罗门。以五百颂现前骂佛。有赞者。如即彼婆罗门。以佛容色不异故便生净信。复以五百颂现前赞佛。尊者舍利子以众多颂。现前赞佛无上功德。尊者阿难陀以众多颂。现前赞佛希有妙法。如是邬波离婆耆奢尼罗部底等诸大论师。皆以百千伽他现前赞佛。有乐者。佛有殊胜身心受乐及轻安乐。一切有情所不能及。有苦者。世尊亦有背痛头痛朅他罗刺伤足。及迸石伤指出血。如是等法世尊皆有。何故言离。答彼皆不能令佛生染故名为离。谓佛世尊虽遇利等四法而心不高。虽遭无利等四法而心不下。又虽遇利等四法而心不欢。虽遭无利等四法而心不戚。又虽遇利等四法。而心不染故生喜。虽遭无利等四法而心不憎故生忧。又虽遇利等四法而不生爱。虽遭无利等四法而不生恚。譬如妙高山王住金轮上。八方猛风不能倾动。世尊亦尔。安住戒金轮上世间八风所不能动。是故名为不为世法之所染污。非谓生身是无漏故说为不染。问如来于一切烦恼并习气皆已永断。云何当说是有漏耶。答虽自身中诸漏永断。而能增长他身漏故。又从先时诸漏生故说为有漏。是故为止他宗显己义故而作斯论。此中利者。有二种。一有命。二无命。有命利者。谓得象马牛羊妻子僮仆等。无命利者。谓得金银等宝衣服等物。无利者谓即不得前二种。利誉者谓不现前赞美。非誉者谓不现前毁呰。赞者谓现前赞美。毁者谓现前毁呰。乐者谓欲界身心乐。有说。唯取五识相应乐。苦者谓欲界身心苦。有说。唯取五识相应苦。问此八世法几界几处几蕴所摄。答有命利十七界十一处五蕴所摄除声。声非恒有故。即属身故。无命利四界四处一蕴所摄。谓色香味触界处色蕴。无利誉非誉赞毁乐苦二界二处三蕴所摄。谓声法界处色受行蕴。此中无利法界法处行蕴所摄。以无利是不成就故。誉非誉赞毁声界声处色蕴所摄。乐苦法界法处受蕴所摄。若总说八世法则十八界十二处五蕴所摄。有说利无利俱十八界十二处五蕴所摄。以所得及所不得俱通十八界等故。余如前说。有说。利无利俱法界法处行蕴所摄。以利无利用成就不成就性为体故。余如前说。问何故此八说名世法。答世间有情所随顺故名为世法。世间有情若遇利等四法其心则高。若遭无利等四法其心则下。又若遇利等四法心则生欢。若遭无利等四法心则生戚。又若遇利等四法心则染故生喜。若遭无利等四法心则憎故生忧。又若遇利等四法心则生爱。若遭无利等四法心则生恚。故此八种名为世法。如来于此心不随顺故。说不为世法所染。问声闻独觉爱恚断故亦不随顺如是八法。何故不说。答彼不定故。谓有不染如不动法者。或复有染如退法等。复次二乘犹有相似法故。谓阿罗汉爱恚虽断。而有爱恚相似余习。如二阿罗汉俱是不时解脱。同止一处一则多得敬养名称。一则不得。彼得者便似自高如有喜爱。彼不得者便似自下如有忧戚。故不说为世法不染。唯佛永拔爱恚习气。假使一切有情皆得胜利恭敬名誉。如来不得一毫之分。终无自下似忧戚相反生庆悦。设佛独得一切胜利恭敬名誉。诸余有情无一毫分。终无自高如喜爱相反生慈愍故佛独称世法不染。又佛世尊得利不高慢习断故。无利不下乐远离故。得誉不欢爱习断故。非誉不戚得无畏故。赞不生喜憍习断故。毁不生忧住空三摩地故。乐不生爱住无愿三摩地故。苦不生恚住无相三摩地故。此八世法唯欲界系故。但依未至定灭

九有情居广说如大种蕴。于中七种灭义如七识住说。第五有情居第四静虑系故。依四静虑。未至定。静虑中间。空无边处近分灭。第九有情居非想非非想处系故。依七根本。未至定。静虑中间灭。然此中所说定者。有说无漏。有说。有漏无漏如前分别。此中亦无种类灭究竟灭二说差别。以各各但是一地系故。十业道广说如业蕴。于中十不善业道。唯欲界系故但依未至定灭。前七善业道五地系及不系。欲界系者。依未至定灭。乃至第四静虑系者。依四静虑。未至定。静虑中间。空无边处近分灭。后三善业道九地系及不系。欲界系者依未至定灭。乃至非想非非想处系者。依七根本。未至定。静虑中间灭。然此中依不善业道近对治欲界善业道说故。但言依未至定灭

四静虑。四无量四无色。八解脱。八胜处。十遍处依何定灭。答初静虑依初或未至。第二静虑喜无量初二解脱。前四胜处依二或未至。第三静虑依三或未至。第四静虑三无量净解脱。后四胜处前八遍处。依四或未至。空无边处。及彼解脱遍处。依五或未至。识无边处。及彼解脱遍处。依六或未至。后二无色。后三解脱。依七或未至。此中四静虑乃至十遍处。如余处广说。其四静虑各自地系及不系。自地系者。各依自下根本地。未至定。静虑中间。及次上近分灭。然所说定者。有漏无漏如前分别。所说灭者。此中无有种类灭究竟灭二说差别。以各各但是一地系故。四无量中喜无量初二静虑系故。依二或未至灭。余三无量四地系故。依四或未至灭。于中差别随应如前。然所说定者有漏无漏如前分别。所说灭者。有说依种类灭说。有说依究竟灭说。随其所应如前分别。然于未至定中皆唯摄无漏应知。四无色中前三无色。各自地系及不系。自地系者各依自下根本地。未至定。静虑中间。及次上近分灭。后一无色唯有自地系。依七根本。未至定。静虑中间灭。然所说定者。有漏无漏如前分别。于后一无色唯应依无漏定说。所说灭者。此中亦无种类灭究竟灭二说差别。亦各唯是一地系故。八解脱中初二解脱。如喜无量说。下三无色解脱如下三无色说。后二解脱如第四无色说。净解脱第四静虑地系故。依四静虑。未至定。静虑中间。空无边处近分灭。此中所说定。及所说灭。皆如第四静虑说。八胜处中前四胜处。如初二解脱说。后四胜处如净解脱说。十遍处中前八遍处如后四胜处说。空无边处遍处唯自地系故。依五根本。未至定。静虑中间。识无边处近分灭。识无边处遍处亦唯自地系故。依六根本。未至定。静虑中间。无所有处近分灭。然此中所说定者。有漏无漏如前分别。所说灭者。亦无种类灭究竟灭二说差别。亦各唯是自地系故

他心智世俗智依何定灭。答他心智依四或未至。世俗智依七或未至。此中他心智世俗智如余处广说。然他心智四地系及不系。初静虑系者。依初静虑。未至定。静虑中间。第二静虑近分灭。乃至第四静虑系者。依四静虑。未至定。静虑中间。空无边处近分灭。然此中所说定者。有漏无漏如前分别。所说灭者。有说。依种类灭说。有说。依究竟灭说。亦随所应如前分别。世俗智九地系。欲界系者依未至定灭。乃至非想非非想处系者。依七根本。未至定。静虑中间灭。然此中所说定。及所说灭皆随所应如前分别。由此故言依七或未至灭

说一切有部发智大毗婆沙论卷第一百七十三阿毗达磨大毗婆沙论卷第一百七十四

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    定蕴第七中不还纳息第四之一

有五不还。谓中般涅槃。生般涅槃。有行般涅槃。无行般涅槃。上流往色究竟。为五摄一切。为一切摄五耶。如是等章及解章义既领会已应广分别。问何故作此论。答为欲分别契经义故。如契经说有五不还。谓中般涅槃。乃至广说。彼经虽作是说。而不明为五摄一切。为一切摄五。亦未曾显胜劣差别。今欲具明故作斯论

为五摄一切一切摄五耶。答一切摄五。非五摄一切。不摄何等。谓现法般涅槃。及往无色不还。此中一切多非五故。一切摄五非五摄一切。犹如大器覆于小器非小器覆大。一切者谓七不还即前五。并现法般涅槃。及往无色不还。于中后二非五所摄故名为多。问亦有不定般涅槃者。谓或于欲界而般涅槃。或于色界而般涅槃。或于无色界而般涅槃。此中何故不说。答应说而不说者当知此义有余。复次彼即摄在七不还中故不别说。谓彼若在欲界般者。即现法般涅槃摄。色界般者即五不还摄。无色界般者即往无色不还摄。问亦有转生般涅槃者。谓彼或从极七返有。或从家家。或从一来。或从一间得不还果。彼得果已必于此生得般涅槃。彼非现法般涅槃。以契经说云何现法般涅槃。谓即此生得预流果。进断余结得一来不还阿罗汉果。由此因缘转生般者非七所摄。此中何故不说。答应说而不说者当知有余。复次彼由厌受生故得不还果已。未经几时即般涅槃。于其中间时极促故。不容建立是以不说。复次彼亦摄在现法般涅槃中故不别说。以依此生得不还果。即于此生般涅槃故

中般涅槃生般涅槃何者为胜。答若住等断则中般涅槃为胜。若生般涅槃断结多则彼为胜。谓此二不还若并具初静虑缚。乃至若俱断第四静虑前八品结。则中般涅槃由三事故胜。一受苦少此受一有苦。彼受二有苦故。二速灭烦恼火。三疾舍蕴担。若中般涅槃具初静虑缚。乃至断第四静虑前七品结。生般涅槃断初静虑一品结。乃至断第四静虑前八品结。则生般涅槃由一事故胜。谓住多断。中般涅槃。乃至上流。往色究竟。何者为胜。答若住等断则中般涅槃为胜。若乃至上流往色究竟断结多则彼为胜。谓中般涅槃。若对有行般涅槃无行般涅槃。皆如对生般涅槃说。若对上流往色究竟则于受苦有差别。谓此唯受一有苦。彼极少受四有苦故。余如前说。如是生般涅槃。乃至上流往色究竟有行般涅槃。乃至上流往色究竟无行般涅槃上流往色究竟何者为胜。答若住等断则生般涅槃等为胜。若有行般涅槃等断结多则彼为胜。谓此诸不还随所相对。若并具初静虑缚。乃至若俱断第四静虑前八品结。则生般涅槃于有行般涅槃由一事故胜。谓生般涅槃有勤修道及速进道。有行般涅槃唯有勤修道无速进道。于无行般涅槃由二事故胜。彼无勤修道亦无速进道故。于上流往色究竟由一事故胜。谓受苦少此受二有苦。彼极少受四有苦故。有行般涅槃于无行般涅槃由一事故胜。此有勤修道。彼俱无故。于上流往色究竟由一事故胜。无行般涅槃于上流往色究竟亦由一事故胜。皆如前说。若生般涅槃等具初静虑缚。乃至断第四静虑前七品结。有行般涅槃等断初静虑一品结。乃至断第四静虑前八品结。则有行般涅槃等。于生般涅槃等由一事故胜。谓住多断

复次集异门说。有五种不还补特伽罗。谓中般涅槃。乃至上流往色究竟。云何中般涅槃。谓有补特伽罗前生中于五顺下分结已断已遍知。于五顺上分结未断未遍知。造作增长顺起有受业。不造作增长顺生有受业。从彼命终起色界中有。即住彼中有得如是种类无漏道。由此道力进断余结。于无余依涅槃界而般涅槃。是名中般涅槃问何故名中般涅槃。答此补特伽罗已过欲界。未到色界住彼中有而般涅槃故名中般涅槃。复次此补特伽罗利根软烦恼故。能于中有而般涅槃故名中般涅槃。复次此补特伽罗先得有心。有心无间得学心。学心无间得无学心。无学心无间得非学非无学心。即住彼心而般涅槃故名中般涅槃。问此言欲差别谁。答欲差别余圣者。谓余圣者学心无间或起无学心。或起非学非无学心。此即不尔学心无间必起无学心。余圣者非学非无学心无间或般涅槃。或更起无学心。此则不尔。非学非无学心无间定般涅槃。以余圣者数起圣道现在前。此不数起故

云何生般涅槃。谓有补特伽罗。前生中于五顺下分结已断已遍知。于五顺上分结未断未遍知。造作增长顺起有受业。顺生有受业。从彼命终起色界中有生色界天。生已未久得如是种类无漏道。由此道力进断余结。于有余依般涅槃界而般涅槃。是名生般涅槃。问何故名生般涅槃。答此补特伽罗。生彼未久得阿罗汉果而般涅槃。故名生般涅槃。复次此补特伽罗。生彼未久得阿罗汉果。尽其寿量方般涅槃。故名生般涅槃。问若彼尽寿力般涅槃者。何故名生般涅槃。答依烦恼涅槃说。非蕴涅槃故无过。云何有行般涅槃。谓有补特伽罗前生中依有行道恒时作意。依不息加行三摩地。于五顺下分结已断已遍知。于五顺上分结未断未遍知。造作增长顺起有受业。顺生有受业。从彼命终起色界中有生色界天。生已多时。复依有行道。恒时作意。依不息加行三摩地进断余结。于有余依般涅槃界而般涅槃。是名有行般涅槃。问何故名有行般涅槃。答此补特伽罗由有行道。断余烦恼而般涅槃。故名有行般涅槃。复次此补特伽罗由有行道得阿罗汉果。尽其寿量而般涅槃。故名有行般涅槃。复次此补特伽罗依有为缘道。进断余结而般涅槃。故名有行般涅槃。云何无行般涅槃。谓有补特伽罗前生中依无行道不恒时作意。依止息加行三摩地。于五顺下分结已断已遍知。于五顺上分结未断未遍知。造作增长顺起有受业。顺生有受业。从彼命终起色界中有生色界天。生已多时。复依无行道不恒时作意。依止息加行三摩地进断余结。于有余依般涅槃界而般涅槃。是名无行般涅槃。问何故名无行般涅槃。答此补特伽罗由无行道。断余烦恼而般涅槃。故名无行般涅槃。复次此补特伽罗由无行道得阿罗汉果。尽其寿量而般涅槃。故名无行般涅槃。复次此补特伽罗依无为缘道。进断余结而般涅槃。故名无行般涅槃。云何上流往色究竟。谓有补特伽罗前生中于五顺下分结已断已遍知。于五顺上分结未断未遍知。得世俗四静虑。将命终时退上三静虑住初静虑。由即彼爱及彼地造作增长顺起有受业。顺生有受业。故从彼命终起色界中有生梵众天。生已复能入世俗第二静虑。由即彼爱及彼地。造作增长顺起有受业。顺生有受业故。从彼命终生极光净天。生已复能入世俗第三静虑。由即彼爱乃至从彼命终生遍净天。生已复能入世俗第四静虑。由即彼爱乃至从彼命终生广果天。生已复能起下品杂修世俗第四静虑。由即彼爱乃至从彼命终生无烦天。如是乃至于余四品杂修世俗第四静虑。次第遍起于余四天次第遍生。是名上流往色究竟。问何故名上流往色究竟。答流有二种。一生死爱。二后有业。此补特伽罗于二种流并未断未遍知。由此为缘及为因故。上行上随行。上往上随往。上受上随受。上流上随流。故名上流往色究竟。复次此补特伽罗不下行唯胜进行得转上转妙转胜定。及生入彼定受彼生。故名上流往色究竟。复次此补特伽罗上流上生令上生相续故名上流。问异生亦有上流上生令上生相续。何故不名上流耶。答若唯上流不下流者名为上流。异生上流亦下流故不名上流。有说。若上流遍一切处无碍者名为上流。异生不能遍一切处无碍故不名上流。彼于净居则有碍故。问圣者上流亦于二处有碍。谓大梵王及无想处。何故得名上流。答彼无别处即梵辅广果二处摄故。犹得名为遍一切处。有说。若上流能越界得果。永断顺五下分结者说名上流。异生虽能越界而不得果。亦不永断顺五下分结故不名上流。有说。具三种流者说名上流。谓业烦恼及与圣道。异生唯有业烦恼流无圣道流是以不名上流

复次上流有二种。一行色界。二行无色界。行色界者乃至色究竟天。行无色界者乃至非想非非想天。又行色界者有杂修静虑。行无色界者无杂修静虑。复次上流有三种。一全超二半超三一切处殁。全超者谓欲界殁生梵众天。梵众天殁生色究竟。或生非想非非想处而般涅槃。半超者谓欲界殁生梵众天。梵众天殁于上一切天处或更生一处或二或三或四或五。乃至或唯超一处遍生余处然后生色究竟。或生非想非非想处而般涅槃。一切处殁者谓欲界殁生梵众天。梵众天殁生梵光行天如是次第生上诸处乃至生广果天。从此以上有二路别。一入净居。二入无色。入净居者广果天殁生无烦天。次第乃至生色究竟而般涅槃。入无色者广果天殁生空无边处。次第乃至生非想非非想处而般涅槃。如一切处殁有二路别。应知全超半超亦尔。问何等上流入净居。何等上流入无色。答有二上流谓毗钵舍那行奢摩他行。毗钵舍那行者入净居。奢摩他行者入无色。复次有二上流谓乐胜定及乐胜生。乐胜定者入净居。乐胜生者入无色。复次有二上流谓乐决择及乐寂静。乐决择者入净居。乐寂静者入无色。复次有二上流谓杂修不杂修。杂修者入净居。不杂修者入无色。又一切处殁上流有来所显非去。有去所显非来。有来所显亦去所显。有来所显非去者。谓生色究竟或非想非非想处。有去所显非来者。谓生梵众天。有来所显亦去所显者。谓生中间诸处。非来所显非去所显者无。问如前说往色究竟者。先得世俗四静虑。后退住初静虑。彼往非想非非想处者。亦先得世俗四无色。后退住初静虑为不耶。答亦有。如先得世俗四静虑。后退住初静虑命终生梵世。展转乃至生色究竟。如是亦有先得世俗四静虑四无色。后退住初静虑命终生梵世。展转乃至生非想非非想处。但不必须尔。问何故不说彼退初静虑耶。答无有退初静虑而命终者是以不说。又此中显不还差别彼退初静虑者非复不还是故不说。问如说退住初静虑生梵众天作全超半超。一切处殁上流。彼若退住第二静虑生少光天。退住第三静虑生少净天。退住第四静虑生无云天等。彼亦得作全超半超。一切处殁上流不耶。答有说不得。以生梵世于上不还所应生处无缺减故。依彼建立全超半超。一切处殁若退生上地处便缺减。故不依彼立全超等。有说。彼亦得名半超以超少分中间处故。有说。亦得具名三种彼说从欲界殁随生何处。即于彼上所应生处亦可施设全超半超一切处殁故。问若不还者欲界殁生无色界亦得作全超等不。答有说不得。有说。彼亦得名半超。有说。彼亦具名三种此中所以皆如前释。问如往色究竟上流。必先得四静虑退生梵世。然后能往色究竟天。彼往非想非非想处上流。亦必先得四无色退生梵世。然后能往非想非非想处耶。答不必尔。以生色界不能初起杂修静虑。要欲界时曾起今复重修方能往色究竟。生无色者更无如是殊胜类业。要于欲界曾起今更重修然后能生有顶。是故往有顶者若先得无色而退。若先不得彼欲界殁生梵众天皆能往非想非非想处。问所说上流为但是信胜解。为亦有见至耶。答若不退上定而上流者此通二种。若退上定而上流者唯信胜解。复次即退上定而上流者亦通二种。问彼见至云何退耶。答彼非本性见至。但于退后未命终顷从信胜解练根作见至。然后命终而生上界为上流故

问如色界有中般涅槃欲界亦有耶。答无。问何故。答欲界是不定界非修地非离染地多诸过失灾横留难。住本有时尚难得果。况住中有微劣身耶。色界不尔故住中有能般涅槃。复次若住欲界中有般涅槃者则依中有能越三界。然无依中有身能越三界者。复次若住欲界中有般涅槃者。则中有中能断三界烦恼。然无住中有身能断三界烦恼者。复次若住欲界中有般涅槃者则中有中能断不善无记二种烦恼。然无住中有身能断不善无记二种烦恼者。复次若住欲界中有般涅槃者则中有中能证若二若三沙门果。然无住中有身能证若二若三沙门果者。以是义故唯色界有中般涅槃欲界则无。复次中般涅槃必于前生已离欲界染。已离欲界染者必不起欲界中有。故于欲界无中般涅槃。复次欲界烦恼业重。非于中有微劣身中所能除断。复次中有非得不还果所依。但是得阿罗汉果所依。复次欲界中有必不能起圣道现前以劣弱故。色界不尔。由此义故欲界无有中般涅槃。复次中有微劣唯能起自根本地圣道现前非未至等以难起故。若欲界中有般涅槃者则与此相违故必无有。复次欲界有违顺相应烦恼。有外六门烦恼有能引二果烦恼。有无惭无愧相应烦恼。及有忿等种种杂类诸随烦恼。难破难断难越难离。住本有中作大功用。尚难除断况在中有。故无欲界中般涅槃。复次要曾具修九品对治方于中有能般涅槃。欲界中有必未具修九品对治故彼中有不般涅槃。问如欲界殁受色界中有得般涅槃。如是从色界殁受色界中有亦般涅槃不。答不。所以者何。彼于欲界多苦多障多诸灾横可厌之身极生厌逆。既舍离已起色界中有现在前时。于当所受长时异熟亦生厌患便般涅槃。色界无有如是灾横极可厌事令生厌逆。如于本有有缘碍故不般涅槃。今中有亦尔。故从彼殁所起中有不般涅槃。复次若色界殁即彼中有般涅槃者。应亦名上流则五不还便成杂乱。谓彼无有差别因缘。唯欲界殁住中有中般涅槃者名中般涅槃。非色界殁者。又无因缘从彼趣上不名上流。由此过失故彼中有不般涅槃。问若欲界殁起色界中有由厌逆故得涅槃者。何不即于欲界本有得涅槃耶。增厌逆故。答彼住本有得不还果已起阿罗汉果。加行圆满于未起圣道顷即便命终故。由前势力能于中有进断余结而般涅槃。问彼加行圆满何故不起圣道而便命终。答彼或寿尽故或业尽故或福尽故或他所害故或为饶益他故。或非意遇恶缘故。不及起圣道而便命终。有说。彼得不还果。已修后加行将圆满时便遭长病。或阙资具。或遇命等诸难因缘未能尽漏从彼展转遂至命终。既得色界中有新蕴诸根大种增上力故。速能引起圣道现前进断余结而般涅槃。问若欲界殁生无色界亦有生般涅槃等不。答有。以欲界殁生上二界更不再生般涅槃者。随在何处即彼生中皆可建立生等三种二生。以上随在何处皆可建立为上流故。问乐慧上流不至色究竟。乐定上流不至有顶。于下诸处般涅槃者亦得名为乐慧乐定二上流不。答彼亦随类得二种名。然说乐慧至色究竟。乐定至有顶者依极处说。过此更无行处故。如预流者或名极七返有。而于中间般涅槃者亦得此名彼亦如是问何故圣者于上二界一一生处但受一生于欲界中不如是耶。答欲界是不定界是杂乱地诸烦恼业相陵相杂无分齐法式故。令圣者从下生上上复生下。或于一处而受多生。色无色界是定界非杂乱地。诸烦恼业不相陵杂有分齐法式故。令圣者唯上不下一处一生

复次生欲界圣者不名不还。而名极七返有等故生上下亦一处重生。生上界圣者名曰不还故唯生上亦不重生。由此义故不还义满。以尚不生本处况有还生下者

复次不还补特伽罗广说有无量种。今且分别行色界五种。当知此依界建立故说一。生不生建立故说二。分位差别建立故说五。谓中般涅槃乃至上流。往色究竟即此根建立故说十五。谓下中上根。各五地建立故说二十。谓初静虑乃至第四静虑。各五种性建立故说三十。谓退法种性乃至不动法种性。各五处建立故说八十。谓梵众天乃至色究竟天。各五种性根建立故说九十。谓退法种性下中上根。各有五乃至不动法种性亦尔。地种性建立故说百二十。谓初静虑六种性各有五乃至第四静虑亦尔。地种性根建立故说三百六十。谓初静虑六种性三根各五乃至第四静虑亦尔。处种性建立故说四百八十。谓梵众天六种性各五乃至色究竟天亦尔。处种性根建立故说一千四百四十。谓梵众天六种性三根各五乃至色究竟天亦尔。离染处种性根建立故说一万二千九百六十。谓前一千四百四十各有九种离染差别。复次一中般涅槃差别建立亦有多种。谓界故说一。根故说三。地故说四。种性故说六。离染故说九。处故说十六。种性根故说十八。地种性故说二十四。地离染故说三十六。地种性根故说七十二。处种性故说九十六。地离染根故说一百八。处离染故说一百四十四。种性离染根故说一百六十二。地离染种性故说二百一十六。处种性根故说二百八十八。地离染种性根故说六百四十八。处种性离染故说八百六十四。处种性离染根故说二千五百九十二。如中般涅槃有尔所乃至上流亦尔。如是总有一万二千九百六十不还差别。如行色界不还差别建立。如是行无色不还差别建立随应亦尔

说一切有部发智大毗婆沙论卷第一百七十四阿毗达磨大毗婆沙论卷第一百七十五

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    定蕴第七中不还纳息第四之二

如契经说。佛告苾刍。有七善士趣。能进断余结得般涅槃。问云何建立七善士趣。为以界沙门果故。为以地处所故。为以根烦恼故而建立耶。设尔何过。若以界沙门果故而建立者应但说一。谓行色界不还。若以地处所故而建立者但应说四或说十六。若以根烦恼故而建立者应说有九。以彼各有九品故。答皆不以此三缘建立。但以生不生品上行故建立七种。若由此故立初生品。则由此故立初不生品。若由此故立第二生品。则由此故立第二不生品。若由此故立第三生品。则由此故立第三不生品。复以上行义胜立上流为一。由此建立七善士趣。谓生者或有勤修道有速进道。或有勤修道无速进道。或无勤修道无速进道。初为第一次为第二后为第三。如生有三不生亦尔。复以上行义胜立上流为一。由此建立七善士趣。复次生者有上根有中根有软根如次为三。如生有三不生亦尔。余如前说。烦恼差别与此相违说亦尔。复次生者有上品道有中品道有下品道如次为三。如生有三不生亦尔余如前说。复次生者有上品业有中品业有下品业如次为三。此依无漏业说。若依有漏业说则后为第一次为第二初为第三如生有三不生亦尔。余如前说。有说。生者有精进增上亦得胜慧。有精进增上不得胜慧。有得胜慧非精进增上如次为三。如生有三不生亦尔。余如前说。有说。生者有常加行亦顿加行。有常加行不顿加行。有顿加行不常加行。如次为三。如生有三不生亦尔余如前说。有说。生者有于生死见上品过患。有于生死见中品过患。有于生死见下品过患。如次为三。如生有三不生亦尔。余如前说。于涅槃作功德胜解差别说亦尔。有说。生者或有上品奢摩他毗钵舍那。或有中品或有下品如次为三。如生有三不生亦尔。余如前说。余善根差别说亦如是。有说。世尊显示从七分位七种性七门七阶七迹七路。而越非想非非想处难断难坏修所断结。得阿罗汉果故说如是七善士趣

问如生不生各有三种上流亦尔。谓全超半超一切处殁。何故但说一耶。答生不生各是一有相续。于中分位差别难知欲令知故各说三种上流。三种生数自辩差别易知。是故但随上行义胜合说一种。复次生与不生一期时促差别义少分齐易知。是故分三上流时。长差别多种分齐难辩故合立一。复次生不生亦有等义。上流亦有别义。欲以二文互相显故作如是说。复次生与不生善士趣相现前易了。以彼速趣般涅槃故各分为三。其上流者善士趣相微隐难知。以彼尚经多生死故但合说一

问何故经中不生三种以三喻显。于生三种则不尔耶。答如以三喻显不生三。当知亦已显生三种是故前说。若由此故立初生品则由此故立初不生乃至广说。复次以不生者趣生处时如涉路者。于中有去未远便般涅槃。有去少远而般涅槃。有去已远垂至生处而般涅槃。是故世尊以三喻显生中三种皆至生处。更无所趣远近差别故无别喻。复次不生三种微细不现难觉难了故以喻显。生中三种粗现易知不以喻显。复次不生三种界摄非趣。生摄非趣相不圆满故以喻显。生三不尔故无喻显。复次佛观未来有僻执者于中有中而生诽谤。如分别论师等。佛因欲决定中有义故以三譬喻显灭差别。于生有等无此诽谤故于生三不复说喻。复次中般涅槃于生般等有三事胜。一受苦少。二速灭烦恼火。三疾舍蕴担故。以三喻显之。生等不尔故无喻显

问中般涅槃起何地圣道进断余结得阿罗汉果耶。答起自地圣道。谓若住初静虑地中有般涅槃者。彼起初静虑地圣道。乃至若住第四静虑地中有般涅槃者。彼起第四静虑地圣道。问彼得果已亦有起未至定静虑中间圣道耶。答有说。亦有起者。谓若先依彼得不还果者今亦能起。如是说者。应说不起。所以者何。由法尔故。复次以时促故彼得果已疾般涅槃何容更起余地无漏。复次中有唯于根本地圣道随顺非近分地。以近分地圣道苦道所摄难现前故。复次若地有定亦有生者住中有中起彼圣道。未至定有定无生。静虑中间虽亦有生而是异生所生非圣者。四根本静虑有定有生故住中有起彼圣道。问彼何故不起无色圣道答初时未得故。后时无用故。复次彼他地摄难现前故。复次彼苦道摄不欲起故

问何故不说预流一来为善士趣耶。答应说而不说者当知此义有余。有说。世尊此中以七善士趣赞美中子。或时有处赞美长子。如伽他言

  阿罗汉极乐　　以无贪爱心
  及我慢已断　　永绝痴网故

或时有处赞美幼子如池喻经广说。今此亦以赞美中子。是故不说预流一来。有说。本为差别预流一来。世尊说此七善士趣。谓彼虽得名为善士如契经言云何善士。谓若成就有学正见。乃至正定法云何胜善士。谓若成就无学正见乃至正定。然其不得名善士趣。以彼尚远非能近趣胜善士故。唯不还者名为善士亦名善士趣彼是善士。又能邻趣胜善士故。由此义故预流一来非善士趣。有说。有学位中若已越界已得果者立善士趣。预流一来虽已得果而未越界。有说。有学位中若已越界永断不善烦恼业者立善士趣。预流一来二俱不尔。有说。有学位中若已得果及永断不善烦恼业者立善士趣。预流一来不能如是故不立善士趣。如不善烦恼业。如是有异熟无惭无愧相应二果烦恼业亦尔。有说。有学位中若以越界。及永断五顺下分结者立善士趣。预流一来不尔。有说。有学位中若已得果。及永断五顺下分结者立善士趣。预流一来不尔。有说。有学位中若已永断非善士共有法者立善士趣。何等名为非善士共有法。谓乐在家爱恋妻子。贪着卧具衣服饮食。好着种种花鬘璎珞及诸香等涂饰其身。贮畜一切不净财物。所谓金银珍宝仓库田宅奴仆作使诸象马等。及以染心摩触骨琐众恶所集不净之身而生净想染习欲事。或时发怒起加拳等苦楚有情诸损恼业预流一来犹有此事故不说在善士趣中。有说。于有学位若更不入黑闇牢狱母胎藏中禀诸不净。而为身分生熟二藏中间住者立善士趣。预流一来尚有斯事是故不立七善士趣。尊者妙音作如是说。若学已断欲贪嗔恚不于母胎受迫迮苦者立善士趣。预流一来不尔。有说。若学不为违顺境界娆触心者立善士趣。预流一来不尔。有说。若趣上生不退还者立善士趣。预流一来不尔。有说。若学已得杂修静虑虽退而不失静虑者立善士趣预流一来不尔。有说。若学唯行善士法不行不善士法者立善士趣。预流一来亦行不善士法。由如此义预流一来不立善士趣。问行无色不还于行色界不还有五事胜。谓界胜地胜断烦恼胜损减蕴胜三摩钵底胜。何故不立为善士趣答应说而不说者当知此义有余。有说。若粗现易了立善士趣。彼不显了是故不说。有说。佛为劝诱未离欲界多过患处染圣者令速离故。说行色界不还为善士趣。不为劝诱未离色界少过患处染圣者令速离故。不说行无色不还为善士趣。有说。若有色身依有色处有来去等寂静威仪可令他知是善士者立善士趣。行无色者无如是事故不立善士趣。有说。若处有五不还可施设七善趣者立善士趣。行无色不还不具五种不可施设七善士趣是故不说。有说。若彼界有唯圣者生处立善士趣。无色界不尔。有说。若已得杂修静虑虽退而不失静虑者立善士趣。行无色者不尔。有说。若界已离不善士法有诸善士往还谈论于是界中立善士趣。无色界不尔故不立善士趣。问何故阿罗汉非善士趣。答亦应说阿罗汉为善士趣。而不说者当知此义有余。复次趣上生者立善士趣。阿罗汉无生是故不立。复次趣上果者立善士趣。阿罗汉则是上果更无上果可趣是故不立。问时解脱阿罗汉亦趣上果。谓求不动何故非善士趣。答彼趣上种性非趣上果。复次若圣者成就烦恼而不成就非善士法者立善士趣。阿罗汉不成就烦恼是故不说。复次有学位中有成就非善士法者。对彼施设七善士趣。无学位不尔是故不说。复次不还是善士趣。阿罗汉是胜善士趣。若当说为善士趣者便是损减非谓如实是故不说

问如所说杂修静虑以何为自性。答以五蕴为自性。问何故名为杂修静虑彼杂修言欲何所显。答遍熏故名杂修。合熏故名杂修。令严好故名杂修。令明净故名杂修。譬喻者说缘彼故名杂修。遍熏故名杂修者如衣置于一箧以香遍熏。诸瑜伽师亦复如是。以前后二刹那无漏遍熏中间。一刹那有漏合熏故名杂修者。如花与苣蕂合熏令发香。彼瑜伽师亦复如是。以二刹那无漏邻杂熏发。一刹那有漏令严好故名杂修者。如以众花散制多上令其严好。如是行者以二刹那无漏散一刹那有漏上。令其妙好令明净故名杂修者。如以金等置于炉中调炼销镕令转明净。如是行者以一刹那有漏置于无漏二刹那中。数数调炼令转净妙缘彼故名杂修者。彼说以二刹那无漏缘一刹那有漏故名杂修界者。所杂修堕色界能杂修不堕界地者。能所杂修皆在根本四静虑地。问有杂修无色不。答有说无。以难见故微细故。有说。佛于无色有杂修。非声闻独觉所依者依欲色界行相者。有说。能杂修所杂修皆作十六圣行相。所以者何。以圣行相无间能起圣道。圣道无间复起圣行相故。如是说者。能杂修作十六行相。所杂修或作十六行相。或作余行相。谓无量解脱胜处等所缘者。有说。能杂修以所杂修为所缘所杂修所缘不定。如是说者。能杂修缘四圣谛。所杂修缘一切法念住者。有说。若能杂修若所杂修皆作法念住。有说。所杂修四念住。能杂修唯法念住。如是说者。能杂修所杂修皆容作四念住智者。有说。能杂修是苦集类智。所杂修是世俗智。如是说者。能杂修是四法四类智。所杂修是世俗智。若总说者有学七智。无学九智除他心智。三摩地俱者。有说。能杂修空无愿三摩地俱。所杂修非三摩地俱。如是说者。能杂修三三摩地俱所杂修非三摩地俱。根相应者总而言之。能所杂修皆与乐喜舍三根相应。过去未来现在者能所杂修俱三世。缘三世者。有说。能杂修缘过未。所杂修缘三世及离世。如是说者。俱缘三世及离世。前已说能杂修缘四谛故不应异说。善不善无记者。能所杂修俱是善缘。善等者俱缘三种三界系不系者所杂修色界系。能杂修是不系。缘界系不系者。俱缘三界系及不系。学无学非学非无学者。能杂修或学或无学。所杂修非学非无学。缘学等者俱缘三种见所断修所断不断者。所杂修是修所断。能杂修是不断缘见所断等者俱缘三种。缘名缘义者俱缘名义。缘自相续他相续非相续者俱缘三种。何处起者欲色界起。然初起在欲界人趣三洲。于此起已或退不退。后生色界复起现前。加行得离染得生得者。佛离染得余加行得。云何加行谓瑜伽师先入第四静虑起多刹那无漏。从此则起多刹那有漏。此后复起多刹那无漏。如是旋还后后渐减乃至最后二刹那无漏无间二刹那有漏现前。二刹那有漏无间复二刹那无漏现前。齐此名为杂修静虑加行圆满。从此已后不由功用能从一刹那无漏无间起一刹那有漏。则此无间复起一刹那无漏。如是中间刹那有漏前后刹那无漏杂故名杂修静虑。尔时名为杂修静虑根本成就。如是杂修第四静虑已乘此势力随其所应亦能杂修下三静虑先依欲界人趣三洲如是杂修诸静虑已后生色界。由串习力复能如前随其所应杂修静虑。问何等补特伽罗杂修静虑。答是圣者非异生亦学亦无学谓信胜解见至时解脱不时解脱皆能杂修。问彼何故杂修静虑。答三因缘故杂修静虑。一乐等至故。二怖烦恼故。三乐受生故。乐等至者谓为现法乐住故。或为受用圣法财故。或为游戏功德故。或为观本所作故。或为引胜功德故。怖烦恼者谓惧退起烦恼现前失胜德故。或畏退起烦恼现前烧身心故。乐受生者谓乐生彼不共异生五净居故。信胜解具由三因缘杂修静虑。见至由二因缘杂修静虑。除怖烦恼不退法故。时解脱由二因缘杂修静虑除乐受生背一切生故。不时解脱由一因缘杂修静虑除怖烦恼及乐受生。不退法故背一切生故。问杂修静虑有几品耶。答有五。一下品二中品三上品四上胜圆满品五上极圆满品。此一一品于成满位皆有三心。一心有漏二心无漏。如是总说有十五心五心有漏十心无漏。问此十五心为不起定。为起定耶。答有说。不起定。譬如见道相续现前。有说。起定譬如修道数起数入。如是说者。此则不定或有不起定能十五心相续而转。或复起定于中或有起三心已而便起定。或有起六心已而便起定。或有起九心已而便起定。或有起十二心已而便起定。是故于彼五品中间或起不起杂修成满。问此十五心几是曾得。几是未曾得。答有说。五是未曾得。十是曾得。谓前五现在前时余十未来修故。有说。十是未曾得五是曾得。谓前十现在前时后五未来修故。如是说者。此则不定或有十五皆未曾得。或有十五皆是曾得。或有少分曾得少分未曾得。问此十五心几是转。几是随转。答有说。前五是转后十是随转。有说。前十是转后五是随转。如是说者。此则不定。或一切皆是转或一切皆是随转。或少分是转少分是随转。问若此品类转则此品类随转亦余品类耶。答有说。若此品类转则此品类随转。谓智所缘行相念住前后相顺方成杂修。是故若此转必此随转不尔便于杂修为障。有说。若此品类转余品类随转。谓智所缘行相念住异类相间方成杂修。是故若此转必余随转不尔便应乖杂修义。如是说者。此则不定。谓若法智为转。或法智或类智为随转。若类智为转。或类智或法智为随转。余智亦尔。若缘有为为转。或缘有为或缘无为为随转。缘余法亦尔。若无常行相为转。或无常或苦等行相为随转。余行相亦尔。若身念住为转。或身念住或受念住等为随转。余念住亦尔。问若转随转或不同者行相所缘有杂乱故。云何不于杂修静虑而作留难。答先加行位已熟修故。迳路已成虽复杂乱而于杂修不作留难。如见道中及世俗道杂染。虽行相所缘上下杂乱。而无留难此亦如是。问若转随转或亦同者云何得名杂修静虑非于一类行相所缘得名杂故。答有漏无漏相间相杂说名杂修。非谓智等前后异故说名为杂。问何故修杂修静虑要有漏无漏相杂起耶。答欲显于此二类静虑中俱得入出自在故。复次欲以无漏置于前后。熏中间有漏令转胜妙生净居故。复次无始时来净静虑为味相应静虑之所陵杂。今欲令与无漏静虑更相入出。令味相应不复相杂展转远故。复次行者久入静虑时极受长养遍身充密。欲令身中暂时开畅故与无漏相杂而起。诸欲杂修四静虑者。要先杂修第四静虑彼成满已。次复杂修第三静虑。次复杂修第二静虑。后杂修初静虑。若不先杂修第四静虑。彼终不能杂修下地。问因论生论何故必先杂修第四。然后能修下三地耶。答第四静虑诸静虑中最圆满故。是起功德最胜依故。能引最胜轻安乐故。令所依身遍充密故。是多功德所依止故。是不动定故。乐行中最胜故。最有堪能故。复次第四静虑于无漏定最居中故。于上于下各三地故。复次第四静虑过殑伽沙数如来应正等觉。并皆依之得阿耨多罗三藐三菩提故。复次第四静虑具五种因五种果故。五种因者谓五品杂修五种果者谓五净居天。问杂修下三静虑有几品耶。答有说。但有三品谓下中上。下地无有五净居故。如是说者。亦有五品。问彼无五果何故有五品因。答虽无五果而其彼定法有五品。复次下地虽无五净居果而有五品根故。问因论生论下三静虑既有五品杂修。何缘无有五净居果答非其田非其器。乃至广说。复次圣者厌患异生共生处故求生净居。若下地有净居者便于异生共生处所不能厌离。于上处所未离染故。复次圣者欲超异生受生处所故生净居。若下地有净居者便为不能超过异生受生处所。于上犹有异生处故。复次圣者厌灾患处故求生净居。下三地中皆有灾患故无净居。复次净居胜业所感寿量长远。若下地有者三灾起时彼定寿者为命终不。若命终者彼寿量定不应中夭。若不命终应与灾起而作留难。如说若处有一有情下至蚁卵灾终不坏。欲令无如是过故下地无净居。尊者世友说曰。何故下地无净居者。以杂修静虑乃生净居。杂修静虑时必已离下三地染。非于已离染地而得受生。是故净居非下地所有。又利根者乃能杂修。能杂修者必能速超下不净地至纯净处故下地无净居。又彼要得边际定所依地乃能杂修。能杂修者乃生彼处故于下地无有净居。大德说曰。下地有情多于世界坏时生上成时生下。生净居者无如是事是故下地无净居天。问何故净居唯五不增不减。胁尊者言。此不应问。所以者何。若多若少俱亦生疑不以疑故便为乖理。然于法相如实义中唯应有五不增不减。有说。为对异生不共生处唯有五。故圣者生处亦唯有五。异生不共生处五者谓三恶趣北洲无想天。有说。杂修静虑有五品故所感净居亦唯有五。问则杂修静虑何故唯五不增减耶。答杂修势力唯尔所故。如见道十五心势唯尔所不增不减。如是杂修静虑势力亦十五心而无增减。复次杂修静虑是胜功德非下中品所摄。唯有上下上中上上上胜上极故唯有五。有余师说。杂修静虑则是调练信等五根。如其次第随一增上而成五品故唯有五。是故由杂修有五品故净居亦唯有五。有说。第四静虑有九品善根次第生于九处。谓下下善根生无云天。下中善根生福生天。乃至上上善根生色究竟。于此诸处不可增减。是故净居唯应有五。有说。第四静虑有九品烦恼。若于九品全未伏者生无云天。伏上上品者生福生天。乃至伏下中品者生色究竟。无有伏下下品而受生者是故净居唯有五种。问颇有杂修静虑而不生净居耶。答有。谓杂修静虑已或成现法般涅槃或退生下地。或进生无色界。此谓不乐净居而杂修静虑者。问颇有具起五品杂修静虑而生无云天等耶。答有。谓有先生无云。次生福生。次生广果。后乃次第生五净居

说一切有部发智大毗婆沙论卷第一百七十五阿毗达磨大毗婆沙论卷第一百七十六

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    定蕴第七中不还纳息第四之三

如施设论说有五净居。谓无烦无热善现善见色究竟天。云何无烦天。谓无烦天一类伴侣众同分。依得事得处得。及已生彼天无覆无记。色受想行识是名无烦天。问彼天何故名无烦耶。答彼是假名假想名施设想施设随欲而立。不必如名悉有其义。复次彼天身无烦扰心无烦扰。一期领受纯寂静乐非下所有故名无烦。复次彼天审见苦真是苦集真是集灭真是灭道真是道。离下所起粗重烦恼故名无烦。复次烦者谓广即广果天。今此天最初超彼故名无烦天。云何无热天。谓无热天一类伴侣乃至广说。问彼天何故名无热耶。答彼是假名假想乃至广说。复次彼天身无热恼心无热恼。一期领受纯清凉乐非下所有故名无热。复次彼天审见苦真是苦乃至道真是道。离下所起烦恼蒸热故名无热。复次无烦天中邻逼下地所起增上烦恼火故犹名为热。此超彼故名无热天。云何善现天。谓善现天一类伴侣乃至广说。问彼天何故名善现耶。答彼是假名假想乃至广说。复次彼天形色端正妙好。过下二天故名善现。复次彼天审见苦真是苦乃至道真是道。离诸垢浊心净显了故名善现。复次彼得上品杂修静虑善粗显故名善现天。云何善见天。谓善见天一类伴侣乃至广说。问彼天何故名善见耶。答彼是假名假想乃至广说。复次彼天形色转复妙好众所乐观故名善见。复次彼天审见苦真是苦乃至道真是道。离诸垢浊心转净了故名善见。复次彼得上胜圆满品杂修静虑所得善法转粗显故名善见天。云何色究竟天。谓色究竟天。一类伴侣乃至广说。问彼天何故名色究竟。答彼是假名假想乃至广说。复次彼天形色最为胜妙余不及故名色究竟。复次彼天审见苦真是苦乃至道真是道。离诸垢浊诸余色天所不及故名色究竟。复次彼得上极圆满品杂修静虑。余色界善根所不能及故名色究竟。复次彼天于有色界最尊最胜最极故名色究竟。复次彼亦名为碍究竟天。碍者谓积集色。彼于此碍最尊最胜最极故名碍究竟。复次彼亦名为顶究竟天。是一切有色顶亦是究竟故

问净居天生为由业感。为由杂修静虑耶。若尔何失。若由业者杂修静虑则为唐捐。若由杂修静虑者便与品类足论所说相违。如彼说杂修静虑及由业故生净居天乃至广说。答有作是说。彼由业感。问杂修静虑岂不唐捐。答由杂修静虑业得决定故非唐捐。复次要杂修静虑后乃能引彼思业现前由此能引彼众同分。有余师说。由杂修静虑。问品类足说当云何通。答即杂修静虑以业声说。复次彼论先说杂修静虑者。为显先时入彼定故。后说及由业故生净居者。为显后时即由彼力生净居故。如是说者。亦由业力亦由杂修静虑。谓虽有思业现前若不杂修静虑则不得生彼。虽有杂修静虑若无思业现前亦不得生彼。是故要有思业牵引杂修静虑令其决定。方得生彼

诸学彼一切为得未得而学耶。设为得未得而学彼一切学耶。答应作四句。问何故作此论。答始缚迦经是此论根本。彼说学所学故名学。勿有生疑。诸有学者学所学时乃名为学。住本性时不名为学。诸无学者住本性时乃名无学。学所学时不名无学。欲令此疑得决定故。显诸学者有住本性。诸无学者亦学所学故作斯论。有学非为得未得而学。谓学住本性有二因缘名住本性。一守贤善性而无退转。二守自分德而不进修。今但说不进修名住本性。谓预流者不进修一来果加行。一来者不进修不还果加行。不还者不进修阿罗汉果加行。信胜解不求作见至。又诸学者不求起所未得不净观持息念念住三义观七处善静虑无量无色解脱胜处遍处。不引发诸通。不杂修静虑。不入灭尽定。不受持读诵素怛缆毗奈耶阿毗达磨亦不授与他。不住阿练若处思惟观察素怛缆毗奈耶阿毗达磨。亦不经营佛法僧事。是谓学非为得未得而学。问彼何因缘不学所学。答彼或长病。或阙资缘。作是思惟我已越度无量生死。唯余七有。或余一有。或念我已出欲淤泥。唯余上界少许生在今既患苦。或资缘阙幸可少息何遽进修。由此学者不学所学。有为得未得而学彼非学。谓阿罗汉及异生进求上法。此中上法谓胜功德即时解脱求作不动。及阿罗汉起所未得不净观。持息念。念住三义观。七处善。静虑。无量。无色解脱。胜处遍处。引发诸通。杂修静虑入灭尽定。起无碍解无诤愿智边际定空空无愿无愿无相无相。受持读诵素怛缆毗奈耶阿毗达磨。若授与他若住阿练若处。思惟观察素怛缆毗奈耶阿毗达磨。或复经营佛法僧事。及异生求离欲染色染无色一分染。或起不净观。持息念。念住。三义观。七处善。暖顶忍世第一法。静虑无量无色解脱胜处遍处引发诸通入无想定。受持读诵素怛缆毗奈耶阿毗达磨。若授与他若住阿练若处。思惟观察素怛缆毗奈耶阿毗达磨或复经营佛法僧事。是谓为得未得而学彼非学。问何故阿罗汉复学所学。答彼虽不为断烦恼故学。而以爱乐胜功德故。学有学亦为得未得而学。谓学进求上法。即预流者进修一来果加行。广说乃至或复经营佛法僧事。是谓学亦为得未得而学。有非学亦非为得未得而学。谓阿罗汉及异生住本性。即时解脱不求作不动。广说乃至亦不经营佛法僧事。及异生不求离欲界染。广说乃至亦不经营佛法僧事。是谓非学亦非为得未得而学

诸无学彼一切不为得未得而学耶。设不为得未得而学。彼一切无学耶。答应作四句。有无学非不为得未得而学。谓阿罗汉进求上法即时解脱求作不动及阿罗汉起所未得不净观持息念。广说乃至或复经营佛法僧事。是谓无学非不为得未得而学。有不为得未得而学彼非无学。谓学及异生住本性即预流者不进修一来果加行。广说乃至亦不经营佛法僧事。及异生不为离欲界染。广说乃至亦不经营佛法僧事。是谓不为得未得而学彼非无学。有无学亦不为得未得而学。谓阿罗汉住本性即时解脱不求作不动及阿罗汉。不求起所未得不净观持息念。广说乃至亦不经营佛法僧事。是谓无学亦不为得未得而学。有非无学亦非不为得未得而学。谓学及异生进求上法。即预流者进修一来果加行。广说乃至或复经营佛法僧事。及异生求离欲界染。广说乃至或复经营佛法僧事。是谓非无学亦非不为得未得而学。问为学所学故名学。为得学法故名学。设尔何失。若学所学故名学者此文云何通。如说学住本性。若得学法故名学者经说云何通。如说学所学故名学。答有说。得学法故名学。谓若学若不学但成就学法即名为学。问若尔。经说当云何通。答彼经但依现学者说。不说一切。复次彼经依意乐不息故作是说。谓诸学者若起善心。若起不善无记心。若起加行。若不起加行。彼一切学意乐未尝废息。以不永舍加行。故如行路者暂休息时他问何往。答言往某。彼亦以意乐不息。故虽住言往此亦如是。有说。学所学故名学。问若尔。此文云何通。如说学住本性。答此依暂息加行而说。然以意乐。不舍学故名学所学。复次学住本性时虽不起学心心所等。而其学得恒时现行。依此义故名学所学。问若学者不学无学者学。云何建立学无学异。答于圣位中约断烦恼立学无学。不依修胜功德。是故有异

顺流是何义。乃至广说。问何故作此论。答为欲分别契经义故。如契经说。有四补特伽罗。一顺流。二逆流。三中住。四到彼岸。契经虽作是说而不广分别。彼经是此论所依根本。彼所不说者今应说之。故作斯论。问顺流是何义。答于诸生诸趣诸有诸种类诸生死。为支为门为事为道为迹向是顺流义。逆流是何义。答于诸生灭趣灭有灭种类灭生死灭。为支为门为事为道为迹向。是逆流义。流有多种。或说圣道名流。或说业名流或说爱名流。或说生死名流。此中流者。但说生死。又契经说顺流云何。谓习诸欲及造恶业。逆流云何。谓不习诸欲不造恶业。当知彼经依一生建立顺流逆流。此中所说依多生建立顺流逆流。复次彼经依暂时起欲恶离欲恶。建立顺流逆流。是故未离欲染圣者亦名顺流。已离欲染异生亦名逆流。此中所说依长时向生死背生死建立顺流逆流。是故有已离色染者而名顺流。有未离欲染者而名逆流。诸生者谓四生。诸趣者谓五趣。诸有者谓三有。诸种类者谓地处等种类差别。诸生死者。谓无始时来乃至后际流转差别。为支者谓十二有支。为门者谓业烦恼。为事者谓所依止。为道者谓趣生死道。为迹向者谓趣萨迦耶进迹向。此中前五句显生死。后五句显生死长养。生死摄受。生死任持。生死无断绝。生死增益随顺。如引河流而无有尽。逆流义中生等五种如前说。差别者于彼得灭。为支者谓八圣道支。为门者谓不净观持息念等。为事者谓三解脱门。为道者谓趣生死灭道。为迹向者谓趣萨迦耶灭迹向。此中前五句显生死灭。后五句显能摧灭生死非长养。能弃背生死非摄受。能散坏生死非任持。能断绝生死非无断绝。能损减违逆生死非增益随顺。如决陂潢渐令枯涸。问齐何名顺流逆流者。有说。乃至苦法智忍未生名顺流者。已生名逆流者。有说。乃至世第一法未生名顺流者。已生名逆流者。有说。乃至增上忍未生名顺流者。已生名逆流者。有说。乃至忍法。有说乃至顶法。有说。乃至暖法。有说。乃至念住。有说。乃至不净观持息念等未生名顺流者。已生。名逆流者。如是说者。若未种顺解脱分善根名顺流者。已种顺解脱分善根名逆流者。所以者何。无量有情虽能惠施沙门婆罗门贫穷孤独远行疲极。及苦行者种种饮食衣服卧具医药房舍灯明香花。及诸珍宝种种所须。又设无遮祠祀大会。如吠罗摩不刚强等。彼由不种顺解脱分善根故。于生死长夜受彼果已还生饿鬼中受饥渴苦经百千岁。乃至不闻饮食之名。或生人中贫穷下贱多诸苦恼。或复见有无量有情护持禁戒学习多闻。受持读诵素怛缆毗奈耶阿毗达磨。通达文义分别解说。又能傍通世俗诸论。所谓记论因论王论诸医方论工巧论等。或复兼善外道诸论。所谓胜论数论明论顺世间论离系论等。彼由不种顺解脱分善根故。于生死长夜受彼果已。还生傍生趣中。作诸牛羊驼驴身等。愚痴盲瞑乃至不能言。或生人中盲聋喑哑闇钝无智。或复见有无量有情。修习诸定。或离欲染。或离色染。或离无色一分染住八等至。起四无量引发五通。彼由不种顺解脱分善根故。于生死长夜受彼果已。还生地狱受诸剧苦。或傍生趣作大蟒身。吐毒炽然崩岩裂石。或生人中作旃茶罗补羯娑等造秽恶业。诸如是等虽暂受福还退堕故皆名顺流。若诸有情或但惠施一抟之食。或唯受持一日夜戒。或乃至诵四句伽他。或须臾间修定加行而能种殖顺解脱分善根。由此后时虽因烦恼造作种种身语意恶行。或作无间业。或复断灭一切善根。乃至身中无有少许白法种子。堕无间狱受种种苦。而得名为住涅槃岸。以彼必得般涅槃故。此中有喻。如钓鱼人以食为饵。置于钩上着深水中。有鱼吞之。彼鱼尔时虽复游戏或入穴中。当知已名在彼人手。不久定当至岸上故。由此故说。宁作提婆达多堕无间狱。不作嗢达洛迦遏逻摩子生非想非非想天。所以者何。提婆达多虽造三无间业断诸善根堕无间狱。而于人寿四万岁时当得独觉菩提。利根胜舍利子等。嗢达洛迦遏逻摩子。虽离八地染住八等至极奢摩他垂越三有近甘露门。生非想非非想处经八万大劫受寂静乐。从彼命终。由恶业力生彼阿练若苦行林中。作着翅飞狸捕食禽兽水陆空行无得免者。由此恶行命终当堕无间地狱。具受种种难忍处苦。佛不记彼得解脱时。由此故说。虽住苦行林中而名顺流者。虽处五欲境界而名逆流者。此中有喻。如人赍二器行。一金二瓦。脚跌而倒二器俱破。其人尔时不惜金器而惜瓦器。以是嗟恨。人问其故彼具答之。人复诘言。金器破坏汝能不惜。何乃伤惜一瓦器耶。彼复答言。汝诚愚痴。所以者何。金器破已虽失器形不失器体。还付金师可令如本或胜于本。瓦器破已形体俱失。虽付陶师。乃至不堪复作灯盛。况本器乎。是故我今不叹金器而惜瓦器。如是天授已种顺解脱分善根故。虽造众恶生地狱中。而当成独觉胜舍利子等。如彼金器破已还成。猛喜子不种顺解脱分善根故。虽离八地染生有顶天。而终堕恶趣未期解脱。如彼瓦器破已不收。是故未种顺解脱分善根者名为顺流。已种顺解脱分善根者名为逆流。问顺解脱分善根在有情身其相微细。已种未种云何可知。答以相故知。彼有何相。谓若闻善友说正法时。身毛为竖悲泣流泪。厌离生死欣乐涅槃。于法法师深生爱敬。当知决定已种顺解脱分善根。若不能如是当知未种。此中有喻。如人于田畦中下种子已经久生疑。我此畦中曾下种不。踌躇未决。傍人语言。何足犹豫。汝今但可以水灌渍以粪覆之。彼若生芽则知已种。不然则不。彼如其言便得决定。如是行者。自疑身中曾种解脱种子已不。时彼善友而语之言。汝今可往至说法所。若听法时身毛为竖悲泣流泪。乃至于法法师生爱敬者。当知已种解脱种子。不然则不。故由此相可得了知

自住是何义。答非于诸生乃至诸生死为支。乃至为迹向亦非于生灭乃至生死灭为支。乃至为迹向是自住义。此谓少分所作已办。或一切所作已办。意乐暂息或究竟息。不同顺流及逆流者。于生死涅槃各作所作意乐不息故名自住。即是住自分义。问诸阿罗汉彼一切自住耶。设自住彼一切阿罗汉耶。答诸阿罗汉彼一切皆自住。彼为住何处。谓住离非想非非想处染。阿罗汉果一切结尽断遍知中。有自住非阿罗汉。谓不还。彼为住何处。谓住离欲染不还果五顺下分结尽断遍知中。如世尊言

  永断五烦恼　　学满无引法
  得自在定根　　是人名自住

五烦恼者。谓五盖及五顺下分结。不还已尽故。言永断。学满者。谓果满根满非等至满。无引法者。谓欲界业烦恼所不能引。得自在者。谓得心自在即是于他心智证通得自在究竟义。得定根者。谓成就静虑所摄三摩地根。是人名自住者。谓住离欲染不还果五顺下分结尽断遍知中

诸得极禁。彼一切得极迹耶。设得极迹彼一切得极禁耶。答诸得极禁彼一切得极迹。所以者何。无学尸罗名为极禁。四种神足名为极迹。诸有已得无学尸罗。必亦逮得四神足故。有得极迹非得极禁。谓不还如世尊言。云何苾刍得极迹。谓于五顺下分结永断遍知。所以者何。以不还者。已得四神足未得无学尸罗故。或作是说。诸得极迹彼一切到彼岸耶。设到彼岸彼一切得极迹耶。答诸得极迹彼一切到彼岸。所以者何。一切结尽名为极迹。如契经说。迹谓涅槃。永断五结不复轮回生死名到彼岸。诸阿罗汉身已作证名得极迹。已断五顺上分结。不复轮回三界生死名到彼岸。有到彼岸非得极迹。谓不还。如世尊言。云何苾刍名到彼岸。谓于五顺下分结永断遍知。以断此故不复轮回欲界生死名到彼岸。复次阿罗汉于三界再到彼岸。谓断三界见所断修所断时。不还者。于欲界亦再到彼岸。谓断欲界见所断修所断时。而未得涅槃故不名得极迹。或作是说。诸阿罗汉彼一切尽源底耶。设尽源底彼一切阿罗汉耶。答诸阿罗汉彼一切尽源底。有尽源底非阿罗汉。谓不还。如世尊言。云何苾刍尽源底。谓于五顺下分结永断遍知。此中二释如到彼岸说

齐何名菩萨。乃至广说。问何故作此论。答为欲分别契经义故。如契经言。有一有情。是不愚类是聪慧类。谓菩提萨埵。虽作是说而不分别。齐何名菩萨。得何名菩萨。彼契经是此论所依根本。彼所不说者今应说之。故作斯论。复次为断实非菩萨起菩萨增上慢故而作斯论。所以者何。有诸有情。以一食施。或以一衣或一住处。乃至或以一杨枝施。或受持一戒。或诵一伽他。或一摄心观不净等。便师子吼作如是言。我因此故定当作佛。为断如是增上慢故。显虽经于三无数劫具修种种难行苦行。若未修习妙相业者犹未应言我是菩萨况彼极劣增上慢者。是故菩萨乃至初无数劫满时。虽具修种种难行苦行。而未能决定自知作佛。第二无数劫满时。虽能决定自知作佛。而犹未敢发无畏言我当作佛。第三无数劫满已修妙相业时。亦决定知我当作佛。亦发无畏师子吼言。我当作佛。齐何名菩萨。答齐能造作增长相异熟业。问若诸有情发阿耨多罗三藐三菩提心能不退转。从此便应说为菩萨。何故乃至造作增长相异熟业方名菩萨耶。答若于菩提决定及趣决定乃名真实菩萨。从初发心乃至未修妙相业来。虽于菩提决定。而趣未决定。未得名为真实菩萨。要至修习妙相业时。乃于菩提决定。趣亦决定。是故齐此方名菩萨。复次修妙相业时。若人若天共识知彼是菩萨故名真菩萨。未修妙相业时唯天所知。是故未得名真菩萨。复次修妙相业时。舍五劣事得五胜事。一舍诸恶趣恒生善趣。二舍下劣家恒生贵家。三舍非男身恒得男身。四舍不具根恒具诸根。五舍有忘失念恒得自性生念。由此得名真实菩萨。未修妙相业时与此相违。是故不名真实菩萨。问菩萨得此自性生念有何利益耶。答菩萨得此自性生念离有情过。积集多闻深信因果。善摄徒众所说教诫终不唐捐。菩提资粮转复圆满是为利益。得何名菩萨。答得相异熟业。问何故复作此论。答欲令疑者得决定故。谓先作是说。齐能造作增长相异熟业名为菩萨。勿有生疑。虽齐此位名为菩萨。而菩萨名或由证得其余胜法。欲显即由相异熟业得菩萨名不由余法。故作斯论。问由阿耨多罗三藐三菩提故名菩提萨埵。何故未证得时此名随转。及证得已便不随转而更名佛陀耶。答由此萨埵未得阿耨多罗三藐三菩提时。以增上意乐恒随顺菩提。趣向菩提。亲近菩提。爱乐菩提。尊重菩提。渴仰菩提。求证欲证不懈不息。于菩提中心无暂舍。是故名为菩提萨埵。彼既证得阿耨多罗三藐三菩提已。于求菩提意乐加行并皆止息。唯于成就觉义为胜。一切染污不染污痴皆永断故觉了一切胜义世俗诸尔焰故复能觉悟。无量有情随根欲性作饶益故。由如是等觉义胜故。名为佛陀。不名菩萨。复次萨埵是勇猛者义。未得阿耨多罗三藐三菩提时。恒于菩提精进勇猛。求欲速证。是故名为菩提萨埵。既得阿耨多罗三藐三菩提已。便于菩提勇猛心息。唯觉义胜故名佛陀。以能成就最胜觉故

说一切有部发智大毗婆沙论卷第一百七十六阿毗达磨大毗婆沙论卷第一百七十七

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    定蕴第七中不还纳息第四之四

问相异熟业以何为自性。为身业。为语业。为意业耶。答三业为自性然意业增上。有说。唯意业为自性。非身语业。所以者何。此业猛利。身语业钝故。问相异熟业为在意地。为五识身耶。答在意地。非五识身。所以者何。此业有分别。要观察已行。五识无分别。随境界力起故。问相异熟业。为加行得为离染得。为生得耶。答唯加行得。非离染得非生得。所以者何。此业必在三无数劫修诸波罗蜜多。圆满身中加行功用作意后而得故。有说。此业加行得亦生得。但非离染得。问相异熟业为闻所成思所成修所成耶。答唯思所成。非闻非修。所以者何。此业胜故非闻所成。欲界系故非修所成。有说。此业通闻思所成。但非修所成。问相异熟业何处起耶。答在欲界。非余界。在人趣非余趣在赡部洲非余洲。依何身起者。依男身起非女身等。于何时起者。佛出世时非无佛世。缘何境起者现前缘佛起胜思愿。不缘余境。问三十二大丈夫相。为一思所引。为多思耶。若尔何失。若一思所引者。云何少业能引多果。施设论说复云何通。如说。如是类业能感足下平满善住相。乃至如是类业能感顶上乌瑟腻沙相。若多思所引者。云何一众同分不分分别引耶。答有说。一思所引。问云何少业能感多果。答先以一思牵引。后以多思圆满。是故无过。譬如画师先以一色作摸后填众彩。问施设论说复云何通。答彼论说圆满业不说牵引业。故无过。然三十二大丈夫相是众同分圆满业果。非众同分牵引业果。有说。多思所引。问云何一众同分不分分别引耶。答尔时菩萨能一注心于一所依所缘行相有多思转。于中有思能感足下平满善住相。乃至有思能感顶上乌瑟腻沙相。如是说者。三十二思引三十二大丈夫相。一一复以多业圆满。问菩萨所起三十二思。于诸相中先引何相。答有说。先引足下平满善住相。后引余相。先安其足后乃余故。有说。先引目绀青相。先以慈眼观世间故。如是说者。此则不定。随此相缘合则引此相

三十二大丈夫相者。一足善住相。谓佛足下平满不凹不凸。于践蹑时等按触地。是故唯佛迹相分明。恶心欲去终不能灭。诸在家者若有此相。必为人王宾伏率土。诸出家者若有此相。必为法王化导一切。二者千辐轮相。谓佛于双足下有文。如轮千辐具足毂辋圆满分明巧妙。妙业天子虽极作意不能拟之而别化作。所以者何。妙业天子所化作事是无覆无记智所引。此相是纯净业所引故。复次彼天所作是生得智所引。此相是增上加行智所引故。复次彼天所作是一生所习智所引。此相是无量生所习智所引故。三者指纤长相。谓佛其指纤长佣而渐锐。节不粗现。并时无隙。安布得中光泽圆满。四者足跟圆长相。谓佛足跟圆长端严广直。五者手足细软相。谓佛手足细软如妒罗绵。六者手足网缦相。谓佛手足指间皆有网缦。犹如鹅王指。若合时网即不现而无皱缓。开时便现而无挛急。七者足趺端厚相。谓佛足趺圆厚向指佣写两边端直。与跟相称。蹑时不广。足下如红莲华色。网内边如彩树文爪甲如赤铜叶色。网外边作真金色。细毛绀润如吠琉璃故。佛双足犹如宝履众宝庄严光明微妙。八者翳泥耶[跳-兆+專]相。谓佛[跳-兆+專]胫圆直。渐下佣细。如翳泥耶鹿王[跳-兆+專]。九者势峰藏密相。谓佛势峰藏密犹如马王。若尔云何所化得见。有说。世尊愍所化故方便示之。有说。世尊化作象马阴藏殊妙告所化言。如彼我亦尔。十者身分圆满相。谓佛身分圆满如诺瞿陀树。如从脐至顶。如是从脐至足上下相称。十一者身毛上靡相。十二者孔生一毛相。十三者身毛右旋相。谓佛身诸毛孔各生一毛。如吠琉璃其色绀润宛转右旋毛端上靡。所以一一毛孔唯一毛者。以菩萨时不乱说法故。十四者身真金色相。谓佛身真金色。映夺世间一切金光令不复现。如今时人所用铁等。于今时所用金边威光不现。今时所用金至佛在世时所用金边威光不现。佛在世时所用金若至大海转轮王路金砂赡部捺陀金边威光不现。此金砂金若至七金山金边威光不现。七金山金至妙高山王金边威光不现。妙高山王金至三十三天庄严具金边威光不现。如是展转乃至乐变化天庄严具金至他化自在天庄严具金边威光不现。此他化自在天庄严具金若至佛身金边威光不现。是故佛身金色最胜。映夺一切世间金色。十五者常光一寻相。谓佛身分周匝常有光明。面各一寻昼夜恒照。十六者皮肤细滑相。谓佛皮肤细滑尘水不住。如吠琉璃及莲华叶。设佛以足蹈于尘山。吠岚婆风于中击坌。欲令佛身及佛足下一尘染着无有是处。十七者七处充满相。谓佛七处充满。于余身分此为少增。两手两足两肩及项是为七处。十八者身广洪直相。谓佛身广洪直不偃不偻。亦不傍敧端雅充实。十九者师子上身相。谓佛胸臆分齐方广威肃。如师子王上半身分。二十者肩髆圆满相。谓佛肩髆圆满。非诸捔力姝壮力士之所能及。二十一者立手摩膝相。谓佛平立舒手摩自膝轮。二十二者师子颔轮相。谓佛颔轮广好如师子王。二十三者具四十齿相。二十四者齿齐平密相。二十五者牙齿鲜白有光明相。谓佛具四十齿皆悉齐平。中无间隙如毛发许。其色鲜白光明皎映如雪山王。问余人但有三十二齿。而说彼身中有一百三骨。佛具四十齿。何故亦言身中有一百三骨。而不增耶。答余人头骨九分合成。世尊头骨但有一段。是以俱有一百三骨。二十六者得最上味相。谓佛舌根净故。令所饮食变成上味。有说。佛舌根上有一切世间悦意美妙胜味种子。若诸苦酢等物至舌根时。此种杂变皆成上味。有说。如来舌根有如是势力。若诸饮食来至舌根。于中悦意美妙性者便生舌识。粗鄙性者不生舌识。有说。佛咽喉中有二乳泉。若饮食时其乳流出。杂诸饮食皆成上味。然于此中舌根净故令味殊胜。此理应然。二十七者广长舌相。谓佛舌相薄软。广长出时覆面至耳发际。若还入口而于口中无所妨碍。二十八者目绀青相。谓佛眼目修广。其色绀净如苏阇多青莲花叶。二十九者牛王睫相。谓佛眼睫安布善好犹如牛王。三十者乌瑟腻沙相。谓佛顶髻骨肉合成。量如覆拳青圆殊妙。三十一者眉间白毫相。谓佛眉间白毫长半寻量。右旋宛转光明清彻。三十二者得梵音声相。谓佛于喉藏中有妙大种。能发悦意和雅梵音。如羯罗频迦鸟。及发深远雷震之声。如帝释鼓。如是音声具八功德。一者深远。二者和雅。三者分明。四者悦耳。五者入心。六者发喜。七者易了。八者无厌

问相是何义。答幖帜义是相义。殊胜义是相义。祥瑞义是相义

问何故大丈夫相唯三十二不增不减耶。胁尊者说曰。若增若减俱亦生疑。唯三十二亦不违法相。有说。三十二者世间共许是吉祥数。故不增减。有说。若三十二相庄严佛身则于世间最胜无比。若当减者便为阙少。若更增者则亦杂乱。皆非殊妙故唯尔所。如佛说法不可增减。佛相亦尔。无减可增无增可减故。问八十随好为在何处。答在诸相间随诸相转庄严佛身令极妙好。问相与随好不相障夺耶。答不尔。相与随好更相显发如林中花显发诸树。佛身如是相好庄严。又如金山众宝杂饰。如是佛身威光奇特。以如来身极鉴净故。诸祥瑞物皆现其中。如至那镜极磨莹已。随物远近影像皆现。佛身亦尔。是故一切诸魔外道怀恶心者。至佛处时无不瞻仰。睹之无厌右绕而去。问菩萨于身为有爱慢而庄严耶。答不尔。问云何。答菩萨为欲降伏世间恃色憍慢不受化者令受化故。以诸相好而庄严身。复次为显佛所有法皆殊胜故。谓色力族姓眷属名誉财富自在。智见功德皆悉殊胜。若不尔者。则所说法无人信受。是故菩萨庄严其身。复次欲与阿耨多罗三藐三菩提作所依器故。所以者何。殊胜功德决定依止殊胜之身。彼未来阿耨多罗三藐三菩提义。语菩萨言。汝欲令我在身中者。先令汝身清净殊胜。以诸相好而庄严之。若不尔者。我亦不能于汝身生。譬如有人欲娉王女迎至室宅。彼密遣使而语之言。汝欲令我至舍宅者。先应洒扫除去鄙秽。悬缯幡盖烧香散花种种庄严。吾乃可往。若不尔者。我亦不能至汝舍宅。是故菩萨庄严其身。问菩萨造作增长相异熟业已中间。或作转轮王时。为即所修相异熟业。感彼相果。为余业耶。答有说。即以所修相异熟业。以此业功能广大。假设至今恒作轮王。而彼业势亦不尽故。如是说者。彼以余业。所以者何。菩萨修相异熟业皆为于最后身受殊胜果未便受用。然由彼业为增上造余善业感轮王相果。譬如大富长者多诸珍宝。其中大价宝珠未便出用。余轻价者随时贸易。彼亦如是。问菩萨所得三十二相与轮王相有何差别。答菩萨所得有四事胜。一炽盛。二分明。三圆满。四得处。复次有五事胜。一得处。二极端严。三文象深。四随顺胜智。五随顺离染。问菩萨造作增长相异熟业已。未至最后身来。于诸有情有异相可识知不。答有。谓生贵族形貌端严具丈夫身诸根圆满。得宿命念深信因果。喜乐多闻尊重正法。智见猛利有胜辩才。志性调柔言音和雅。所作决定终无退屈。见他受苦情不堪忍。要当拔济。所修无不回向菩提。乐与有情作饶益事。而不求报。此等名为彼菩萨相

问如契经说佛一一相百福庄严。何谓百福。答此中百思名为百福。何谓百思。谓如菩萨造作增长足善住相业时。先起五十思。修治身器令净调柔。次起一思正牵引彼。后复起五十思令其圆满。譬如农夫先治畦垄次下种子后以粪水而覆溉之。彼亦如是。如足善住相业有如是百思庄严。乃至顶上乌瑟腻沙相业亦复如是。由此故说。佛一一相百福庄严。问何者是五十思耶。答依十业道各有五思。谓依离杀业道有五思。一离杀思。二劝导思。三赞美思。四随喜思。五回向思。谓回所修向菩提故。乃至正见亦尔。是名五十思。有说。依十业道各起下中上上胜上极。五品善思如杂修静虑。有说。依十业道各起五思。一加行净。二根本净。三后起净。四非寻所害。五念摄受。有说。缘佛一相起五十刹那。未曾习思相续而转。问如是百福一一量云何。答有说。若业能感转轮王位。于四大洲自在而转。是一福量。有说。若业能感天帝释位。于二天众自在而转。是一福量。有说。若业能感他化自在天王位。于一切欲界天众自在而转。是一福量。有说。若业能感大梵天王位。于初静虑及欲界天众自在而转。是一福量。有说。娑诃世界主大梵天王。劝请如来转法轮福。是一福量

问彼请佛时是欲界系无覆无记心。云何名福。答有说。彼住梵世。欲来请时先起如是善心。我当为诸有情作大饶益请佛转法轮。尔时即名得彼梵福。此不应理。所以者何。非未作时已成就故。如是说者。彼请佛已还至梵宫。后世尊转法轮时地神先唱。如是展转声彻梵宫。梵王闻已欢喜自庆。发淳净心而生随喜。尔时乃名成就此福。有说。世界成时一切有情业增上力。能感三千大千世界。是一福量。有说。除近佛地菩萨余一切有情。所有能感富乐果业。是一福量。有说。此中一一福量应以喻显。假使一切有情皆悉生盲。有一有情以大方便令俱得眼。彼有情福是一福量。复次假使一切有情皆饮毒药闷乱将死。有一有情令皆除毒心得醒悟。彼有情福是一福量。复次假使一切有情皆被缚录临当断命。有一有情俱令解脱一时得命。彼有情福是一福量。复次假使一切有情坏戒坏见。有一有情能令俱时戒见具足。彼有情福是一福量。评曰。如是所说皆是淳净意乐。方便赞美菩萨福量。然皆未得其实。如实义者。菩萨所起一一福量无量无边。以菩萨三无数劫积集圆满诸波罗蜜多已。所引思愿极广大故。唯佛能知。非余所测。如是所说广大。量福。具足满百庄严一相。展转乃至三十二相皆具百福。佛以如是三十二百福庄严相。及八十随好庄严其身故于天上人中最尊最胜

问此相异熟业经于几时修习圆满。答多分经百大劫。唯除释迦菩萨。以释迦菩萨极精进故超九大劫。但经九十一劫修习圆满。便得无上正等菩提。其事云何。如契经说。过去有佛号曰底砂。或曰补砂。彼佛有二菩萨弟子勤修梵行。一名释迦牟尼。二名梅怛俪药。尔时彼佛观二弟子谁先根熟。即如实知慈氏先熟。能寂后熟。复观二士所化有情谁根先熟。又如实知释迦所化应先根熟。知已即念。我今云何令彼机感相会遇耶。然令一人速熟则易。非令多人。作是念已。便告释迦。吾欲游山汝可随去。尔时彼佛取尼师檀。随路先往既至山上。入吠琉璃龛敷尼师檀。结跏趺坐入火界定。经七昼夜受妙喜乐。威光炽然。释迦须臾亦往山上处处寻佛。如犊求母。展转遇至彼龛室前。欻然见佛威仪端肃光明照曜。专诚恳发喜叹不堪。于行无间忘下一足。瞻仰尊颜目不暂舍。经七昼夜。以一伽他赞彼佛曰

  天地此界多闻室　　逝宫天处十方无
  丈夫牛王大沙门　　寻地山林遍无等

如是赞已便超九劫。于慈氏前得无上觉。问近佛地菩萨必于名句文身。得未曾得巧妙自在。应以别颂异门赞佛。何故经七昼夜唯以一颂而赞佛耶。答菩萨尔时思愿胜故不重文颂。若改文颂则思愿不淳。复次菩萨尔时怖畏散乱。如颂差别心亦异故。云何而得一心流注。复次菩萨显己心无厌倦能于一颂新新发起胜思愿故。问何故慈氏菩萨自根先熟所化后熟。释迦菩萨则与此相违耶。答慈氏菩萨多自饶益少饶益他。释迦菩萨多饶益他少自饶益。是故皆与所化不并。问如契经说。菩萨经三劫阿僧企耶。修行四波罗蜜多方得圆满。此是何等劫耶。答有说是中劫。有说。是成劫。有说。是坏劫。如是说者此是大劫。积此大劫至一阿僧企耶。如是至三阿僧企耶修习圆满。问此劫阿僧企耶量云何可知。答有说。以大劫为一。积此一至百千名洛叉。至百百千名俱胝。百千俱胝名那庾多。百千那庾多名频婆。百千频婆名建他。此后非算数智所及。至此所不及位名一劫阿僧企耶量。第二第三劫阿僧企耶量亦尔。有说。以大劫为一。积此一至百千名洛叉。至百百千名俱胝。百千俱胝名俱胝俱胝。百千俱胝俱胝名阿哲哲俱胝。百千阿哲哲俱胝名阿吒吒俱胝。百千阿吒吒俱胝名阿庾多。百千阿庾多名阿庾多分。百千阿庾多分名那庾多。百千那庾多名那庾多分。百千那庾多分名俱物陀。百千俱物陀名俱物陀分。百千俱物陀分名钵特摩。百千钵特摩名钵特摩分。百千钵特摩分名迦末罗。百千迦末罗名迦末罗分。百千迦末罗分名捺稚那。百千捺稚那名捺稚那分。百千捺稚那分名睹胝。百千睹胝名睹胝分。百千睹胝分名阿波波。百千阿波波名阿波波分。百千阿波波分名吒吒。百千吒吒名吒吒分。百千吒吒分名邬伽。百千邬伽名邬伽分。百千邬伽分名跋罗。百千跋罗名跋罗分。百千跋罗分名婆揭罗。从此以后非算数智所及。至此所不及位名一劫阿僧企耶量。第二第三劫阿僧企耶量亦尔。有说。非算数智所不及故名阿僧企耶。然有契经说六十数。于中有一数名阿僧企耶积大劫数至此数时名一劫阿僧企耶。如彼经言。有一无余数始为一。十一为十。十十为百。十百为千。十千为钵罗薜陀。十钵罗薜陀为洛叉。十洛叉为頞底洛叉。十頞底洛叉为俱胝。十俱胝为末陀。十末陀为阿庾多。十阿庾多为大阿庾多。十大阿庾多为那庾多。十那庾多为大那庾多。十大那庾多为钵罗那庾多。十钵罗那庾多为大钵罗那庾多。十大钵罗那庾多为矜羯罗。十矜羯罗为大矜羯罗。十大矜羯罗为频跋罗。十频跋罗为大频跋罗。十大频跋罗为阿刍婆。十阿刍婆为大阿刍婆。十大阿刍婆为毗婆诃。十毗婆诃为大毗婆诃。十大毗婆诃为嗢蹭伽。十嗢蹭伽为大嗢蹭伽。十大嗢蹭伽为婆喝那。十婆喝那为大婆喝那。十大婆喝那为地致婆。十地致婆为大地致婆。十大地致婆为醯都。十醯都为大醯都。十大醯都为羯腊婆。十羯腊婆为大羯腊婆。十大羯腊婆为印达罗。十印达罗为大印达罗。十大印达罗为三磨钵耽。十三磨钵耽为大三磨钵耽。十大三磨钵耽为揭底。十揭底为大揭底。十大揭底为枯筏罗阇。十枮筏罗阇为大枮筏罗阇。十大枮筏罗阇为姥达罗。十姥达罗为大姥达罗。十大姥达罗为跋蓝。十跋蓝为大跋蓝。十大跋蓝为珊若。十珊若为大珊若。十大珊若为毗步多。十毗步多为大毗步多。十大毗步多为跋逻搀。十跋逻搀为大跋逻搀。十大跋逻搀为阿僧企耶。此后更有八数及前为六十数积一大劫。至此第五十二阿僧企耶数。时名一劫阿僧企耶。第二第三劫阿僧企耶亦复如是。有说。尊者舍利子依第四静虑起宿住随念智通。缘过去世齐所及劫为一劫阿僧企耶量。第二第三劫阿僧企耶量亦尔。彼不应作是说。以劫阿僧企耶量非舍利子等宿住智境故。此中或说三劫阿僧企耶量。皆是舍利子宿住智境故。不应言齐彼智所及劫为一劫阿僧企耶量有说。依一施行分别三劫阿僧企耶量。谓若时菩萨虽行惠施。而未能舍一切物施一切田。齐此名为初劫阿僧企耶。若时菩萨能行惠施。亦能舍一切物而未能施一切田。或能施一切田而未能舍一切物。齐此名为第二劫阿僧企耶。若时菩萨能行惠施。亦能舍一切物及能施一切田。齐此名为第三劫阿僧企耶。有说。依所逢事佛分别三劫阿僧企耶量。谓过去久远人寿百岁时。有佛名释迦牟尼。出现于世。生刹帝利释迦种中。母名摩诃摩耶。父名净饭。子名罗怙罗。城名劫比罗筏窣睹多诸释种。侍者弟子名阿难陀。第一双弟子名舍利子大目揵连。尔时世间五浊增盛。为生老死之所逼迫。愚痴盲瞑无将导者。彼佛世尊以悲愿力于中出现。精进增上化导有情未曾暂息。由如此故为风所薄。肩背有疾。时有陶师名曰广炽。佛知时至即告侍者阿难陀言。吾今身疾不安。汝可往广炽陶师家求胡麻油及暖水。为吾涂洗。侍者敬诺往陶师家。住广炽前爱语问讯已。方便赞佛种种功德胜戒定慧。三十二相八十随好圆光赫奕。智见无碍辩才无滞。复告广炽。如是世尊若不出家。当为轮王王四洲界。我及汝等一切世间皆为仆使。然今弃舍如是王位出家苦行。得阿耨多罗三藐三菩提。具一切智见。断一切疑网。施一切决定。能尽一切问论源底。视诸有情犹如一子。今者在此不远而住。然为拔济汝等苦故恒涉道路。为风所薄肩背劳积。须油暖水故相造诣。颇能施耶。尔时广炽闻已踊跃叹未曾有。如何人间有是功德。即报尊者。仁今且还。我当如命自往佛所。其去未久。广炽即办生胡麻油及暖香水持往佛所。佛遥见之。为令彼人种善根故脱去余衣。唯留衬身踞机而待。广炽到已发淳净心。以所持油恭敬善巧。涂佛肩背种种摩搦。复以暖水香汤灌洗。佛时风疾释然除愈。以慈软音慰喻广炽。彼闻欢喜即发愿言。愿我未来当得作佛。名号眷属时处弟子。如今世尊等无有异。当知彼陶师者即释迦菩萨。由本愿故今名号等如昔不异。然从彼佛发是愿后。乃至逢事宝髻如来。是名初劫阿僧企耶满。从此以后乃至逢事然灯如来。是名第二劫阿僧企耶满。复从此后乃至逢事胜观如来。是名第三劫阿僧企耶满。此后复经九十一劫修妙相业。至逢事迦叶波佛时方得圆满。有说。有三种阿僧企耶。一劫阿僧企耶。二生阿僧企耶。三妙行阿僧企耶。劫阿僧企耶者。谓以大劫为一积至洛叉俱胝。展转乃至过婆揭罗数。生阿僧企耶者。谓一一劫经无数生。妙行阿僧企耶者。谓一一劫修无数妙行。由此三种阿僧企耶证无上觉。此不应理。如实义者。此中但说经三劫阿僧企耶。修行圆满

说一切有部发智大毗婆沙论卷第一百七十七阿毗达磨大毗婆沙论卷第一百七十八

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    定蕴第七中不还纳息第四之五

问如说菩萨经三劫阿僧企耶。修四波罗蜜多而得圆满。谓施波罗蜜多。戒波罗蜜多。精进波罗蜜多。般若波罗蜜多。当言于何时分修何波罗蜜多而得圆满。答有说。若菩萨行布施时。不为悭吝之所屈伏。当言施波罗蜜多圆满。持净戒时不为恶戒之所陵杂。当言戒波罗蜜多圆满。起精进时不为懈怠之所退败。当言精进波罗蜜多圆满。修般若时不为恶慧之所娆浊。当言般若波罗蜜多圆满。有说。若时菩萨但以悲心能施一切一切种物。乃至身命头目髓脑都无少许恋着之心。齐此名为施波罗蜜多圆满。若时菩萨横被有情斩截手足。割劓耳鼻。或斫身分。乃至无完如芥子许。尔时无有一念嗔心。况欲加报。齐此名为戒波罗蜜多圆满。若时菩萨心勇猛故。经七昼夜一足而立不瞚而视。以一伽他赞叹于佛。而无一念懈倦之心。齐此名为精进波罗蜜多圆满。若时菩萨名瞿频陀精求菩提。聪慧第一论难无敌。世共称仰。齐此名为般若波罗蜜多圆满。或说。乃至坐金刚座入金刚喻定。将证无上正等菩提。齐此方名般若波罗蜜多圆满。如是说者。此等所说皆依一时。一行增上说为圆满。如实义者。得尽智时此四波罗蜜多方得圆满。外国师说。有六波罗蜜多。谓于前四加忍静虑。迦湿弥罗国诸论师言。后二波罗蜜多即前四所摄。谓忍摄在戒中。静虑摄在般若。戒慧满时即名彼满故。复有别说。六波罗蜜多。谓于前四加闻及忍。若时菩萨能遍受持如来所说十二分教。齐此闻波罗蜜多名为圆满。若时菩萨自称忍辱被羯利王割截支体。曾无一念忿恨之心。反以慈言誓饶益彼。齐此忍波罗蜜多名为圆满。此二亦在前四中摄。忍如前说闻摄在慧。虽诸功德皆可名为波罗蜜多。而依显了增上义说。故唯有四。问修此四波罗蜜多时。于一一劫阿僧企耶逢事几佛。答初劫阿僧企耶逢事七万五千佛。最初名释迦牟尼最后名宝髻。第二劫阿僧企耶逢事七万六千佛。最初即宝髻最后名然灯。第三劫阿僧企耶逢事七万七千佛。最初即然灯最后名胜观。于修相异熟业九十一劫中逢事六佛。最初即胜观最后名迦叶波。当知此依释迦菩萨说。若余菩萨不定。如是释迦菩萨于迦叶波佛时。四波罗蜜多先随分满。相异熟业今善圆满。从此赡部洲殁生睹史多天。受天趣最后异熟。问何故菩萨唯于睹史多天受天趣最后异熟。不于余天耶。胁尊者言。此不应问。若上若下俱亦生疑。然生彼天不违法相。有说。睹史多天是千世界天趣之中犹如齐法。是故菩萨唯生彼天。有说。下天放逸上天根钝。唯睹史多天离二过失。菩萨怖畏放逸厌患钝根。故唯生彼。有说。下天烦恼利上天烦恼数。睹史多天离此二种。菩萨厌此二类烦恼。故生彼天。有说。菩萨唯造作增长彼天处业。故唯生彼。有说。唯睹史多天寿量与菩萨成佛及赡部洲人见佛业熟时分相称。谓人间经五十七俱胝六十千岁。能化所化善根应熟。彼即是睹史多天寿量。是故菩萨唯生彼天。若生上天寿量未尽善根已熟。若生下天寿量已尽善根未熟。故不生彼。有说。为化睹史多天无量乐法菩萨众故。谓彼天中有九廊院。廊各十二踰缮那量。乐法菩萨常满其中。补处菩萨昼夜六时恒为说法。上下天处无如是事。有说。菩萨恒时乐处中行。故于最后生处中睹史多天。从彼殁已生中印度劫比罗筏窣睹城。于夜中分踰城出家。依处中行成等正觉。为诸有情说处中法。于夜中分入般涅槃。由此唯生睹史多天。非余天处。问何缘菩萨于最后有唯从天殁不从人来。答有说。于诸趣中天趣胜故。有说。从天上来人所重故。有说。从天来时有神变事。从人趣来无如是事。有说。人中无有如是寿量如睹史多与善根熟时相称可故。有说。睹史多天乐法菩萨业增上力。令此菩萨必生彼天为说法故。有说。菩萨彼有生天业定应受故。有说。若菩萨频生人中而成佛者。则生厌贱不受化故。问何不即于睹史多天成正等觉。而必来人间耶。答随诸佛法故。谓过殑伽沙数诸佛世尊。皆于人中而取正觉故。复次天趣身非阿耨多罗三藐三菩提所依止故。复次唯人智见猛利能得阿耨多罗三藐三菩提故。复次诸天耽着妙欲。于入正性离生得果离染等事非增上故。复次人趣根性猛利多分能受如来正法。天趣不尔。复次最后有菩萨必受胎生。天趣唯化生故。复次有二事处佛出世间。一有厌心。二有猛利智。当知此二唯人趣有。复次人天并是法器。为欲俱摄故来人间。若在天上则人无由往。又不可令天上成佛。来人间化人当疑佛。是幻所作不受法故。是以菩萨人间成佛。然菩萨住睹史多宫。彼寿量尽将下生时。先观四事。一观时分。二观处所。三观种姓。四观依器。观时分者。观诸世间于何时中佛应出世。即知从人寿八万岁。乃至百岁时佛应出世。今正是时。观处所者。谓观世间于何方处佛应出世。即知于赡部洲中印度佛应出世。非边地达絮蔑戾车中。观种姓者。谓观世间何种姓中佛应出世。即知或刹帝利或婆罗门种姓中佛应出世。随彼时强胜者即生其中。观依器者。谓观世间何等女人。父母种姓并皆清净。胎藏宽博无诸过失。能持菩萨那罗延力所合成身经十月日。即知赡部洲中有是女人名字某甲堪为依器。菩萨如是观四事已。即告行道天子言。汝可巡告睹史多天众。却后七日。补处菩萨当从此殁生赡部洲中印度劫比罗筏窣睹城。广作佛事。诸欲随者当发往愿。行道天子欢喜敬诺。乘己所有迅疾神通。遍告睹史多天众言。天仙当知。却后七日补处菩萨当下赡部洲。生中印度劫比罗筏窣睹城。广作佛事。仁等天众欲随从者当发往愿。尔时便有五百天子。寻声即发随下生愿。至第七日。菩萨便与五百天子。一时从睹史多天没。于赡部洲中印度劫比罗筏窣睹城俱时而生。皆为释种助宣佛事。当知此说释迦菩萨。若余菩萨随其所应

如说慈氏。汝于来世当得作佛。乃至广说。问何故作此论。答为欲分别契经故。如世尊说。于未来世人寿八万岁时。此赡部洲其地宽广。人民炽盛安隐丰乐。村邑城廓鸡鸣相接。女人年五百岁尔乃行嫁。彼时诸人身虽胜妙然有三患。一者大小便利。二者寒热饥渴。三者贪淫老病。有转轮王名曰饷佉。威伏四方如法化世。成就七宝。所谓轮宝象宝马宝珠宝女宝主藏臣宝主兵臣宝。千子具足。勇健端政能摧怨敌。极大海际地平如掌。无有丘坑砂砾毒刺。人皆和睦慈心相向。兵戈不用以正自守。王有宝台。高千寻量广十六分。种种庄严持施福田兴大福业。其后不久剃除须发。以信出家勤修梵行。于现法中成阿罗汉。即能自知。我生已尽梵行已立所作已办不受后有。得般涅槃。时佛说是语已。众中阿氏多苾刍。即从座起恭敬合掌而白佛言。世尊。愿我于未来世当得作彼饷佉轮王。威伏四方如法化世。广说乃至得般涅槃。尔时世尊呵叱彼曰。痴人云何不欲一死而求再死愿于来世作饷佉轮王。乃至广说。然阿氏多如汝所愿。汝于来世定得作彼饷佉轮王。降伏四方如法化世。广说乃至得般涅槃。复告大众。未来人寿八万岁时有佛出世。名曰慈氏如来应正等觉明行圆满善逝世间解无上丈夫调御士天人师佛薄伽梵。如我今者十号具足。彼佛复于此世间天魔大梵沙门婆罗门天人众中。自称我是。如来应正等觉。乃至佛薄伽梵。具足证得自在通慧。亦自了知我生已尽梵行已立所作已办不受后有得大涅槃。复为有情宣说正法。开示初善中善后善。文义巧妙纯一圆满清白梵行。为诸人天正开梵行令广修学。无量百千徒众围绕。无量慈种弟子侍卫。作大饶益。如我今者亦于此世间天魔大梵。广说乃至。无量释种弟子侍卫作大饶益。时佛说是语已。众中慈氏菩萨即从座起。恭敬合掌而白佛言。世尊。愿我于未来世当得作彼慈氏如来应正等觉。广说乃至。如今世尊亦为无量释种弟子侍卫作大饶益。尔时世尊闻彼语已起前际智。审观慈氏三无数劫修四波罗蜜多得圆满不。即如实知皆已圆满。复审观彼百大劫中修相异熟业得圆满不。即如实知除金色相业余皆圆满。由此佛告大生主乔答弥言。汝今可以此金色衣布施众僧。若供养僧当知亦名供养于我佛时预知众僧得此金色衣已。有是因缘应慈氏得慈氏得已必当施我。乃至广说。由此因缘金色业满。此中或说。佛欲令彼金色业满。告阿难陀言。汝可为我觅新金色衣。吾欲持与慈氏。时阿难陀如教即得。寻时跪进。世尊得已命慈氏言。汝可取此新金色衣。慈氏承命然不敢取。佛言。但取。任汝奉施佛上首僧。所以者何。汝于未来当由此福饶益世间故。慈氏敬诺取已奉施佛上首僧。由此因缘。金色业满。有说。慈氏金色相业亦先圆满。然佛令彼施金色衣者。欲显功德虽满而无厌足劝引他故。世尊起前际智观慈氏前际已。复起后际智审观未来人寿八万岁时。慈氏有得阿耨多罗三藐三菩提所依身不。即知彼有。复审观察彼于尔时为有堪能得菩提不。即知彼能。世尊观彼前后际已。即赞慈氏菩萨言。善哉善哉。汝能发此广大思愿为欲饶益无量有情。诚为快善。复告慈氏。如汝所愿。汝于来世人寿八万岁时。当得作佛名曰慈氏如来应正等觉。广说乃至。无量慈种弟子侍卫作大饶益。如我今者亦为无量释种弟子侍卫作大饶益。问阿氏多及慈氏俱求未来八万岁时身。何故世尊诃阿氏多而赞慈氏。答阿氏多苾刍于有起意乐起胜解起欣慕起希望起寻求故佛诃之。慈氏菩萨不于有起意乐。乃至寻求。然于利乐诸有情事起意乐。乃至寻求故佛赞之。复次阿氏多求世间轮王位故佛诃之。慈氏求出世法轮王位故佛赞之。如是求流转王位。求还灭王位说亦尔。复次阿氏多求自利乐故佛诃之。慈氏求利乐他故佛赞之。如是求自饶益求饶益他说亦尔。契经虽作是说。慈氏汝于来世人寿八万岁时当得作佛。名慈氏如来应正等觉。乃至广说。而不分别此何智于何转。契经是此论所依根本。彼所不分别者今应分别。故作斯论。问如说慈氏汝于来世当得作佛。名慈氏如来应正等觉。此何智。答因智道智。此即如来观察慈氏前后际智。问此于何转。答有于相异熟业转。由此名因智。有于无漏根力觉支道支得阿耨多罗三藐三菩提转由此名道智。此即如来观察慈氏前际相异熟业圆满不。圆满智于因转故说名因智。及是观察慈氏后际。无漏根力觉支道支得无上正等菩提。智于道转故说名道智。然此二智俱是世俗智摄。以非十六行相智故。或有身中虽有三十二相而无圣法。谓异生转轮王。或有身中虽有圣法而无三十二相。谓非轮王声闻等。或有身中有三十二相亦有圣法而非佛。谓饷佉王等得圣道已。或有身中无三十二相亦无圣法。谓余异生。一切佛身必有无上三十二相及无上圣法。谓正等菩提。问何故此中唯说于相异熟业转名因智。不说于四波罗蜜多转名因智耶。答应说而不说者。当知此义有余。复次相异熟业近。四波罗蜜多远此中说近不说远。复次相异熟业修时显了人天共知。四波罗蜜多不尔。此中随显而说。复次修相异熟业时。菩提决定趣亦决定。修四波罗蜜多时。虽菩提决定。而趣未决定。是故不说。复次此中说知身近因菩提近因。相异熟业是身近因。无漏根力等是菩提近因。四波罗蜜多及不净观等非二近因。是故不说

如说。此苾刍即于现法当辨圣旨。乃至广说。问何故作此论。答为欲分别契经义故。如自恣经说。此苾刍即于现法当辨圣旨能自了知。我生已尽梵行已立所作已办。不受后有得般涅槃。彼经虽作是说。而不分别此何智于何转。彼经是此论所依根本。彼所不说者今应说之。故作斯论。问如说此苾刍即于现法当辨圣旨此何智。答道智。问此于何转。答此于无漏根力觉支道支得诸漏永尽转由此名道智。此即如来观诸苾刍无漏根力觉支道支得诸漏永尽智于道转故说名道智。此亦是世俗智摄。以非无漏十六行相智故。问此中何故不说因智。答有说。此中应作是说。此何智。答因智道智。此于何转。答有于顺解脱分善根等转由此名因智。有于无漏根力觉支道支得诸漏永尽转由此名道智。而不作是说者。当知此义有余。有说。无上菩提加行广大三无数劫百劫乃成彼因可重。是故说观彼智。声闻菩提加行狭小。谓极速者三生便得。第一生下种。第二生成熟。第三生解脱。因非可重故不说观彼智。有说。菩萨相异熟业所依种性等决定故说知彼智。声闻顺解脱分善根所依种性等不决定故不说知彼智。有说。佛有二事胜。一所依身。二所得菩提。故观彼所因具说知二种因智。声闻但有所得菩提胜。非所依身故但说知菩提因智。有说。知顺解脱分善根等智前亦不说。故于此中不应为问。愿智云何。乃至广说。问何故作此论。答前虽说愿智作用。而未说彼自性。今欲说之故作斯论。问愿智云何。答如阿罗汉成就神通得心自在。随欲知义发正愿已。便入边际第四静虑。从定起已如愿皆知。随欲知义者。问何故阿罗汉欲知义耶。答三因缘故。一为饶益弟子故。二为住持佛法故。三为知世间安不安故。饶益弟子者。谓阿罗汉于诸弟子修观行时。法应观彼入圣久近。我寿尽来某甲能入正性离生不。设不能入者我命终后。有余能教令得入不。如此皆以愿智故知。是等名为饶益弟子。住持佛法者。谓阿罗汉或有经营窣堵波毗诃罗僧伽蓝等佛法僧事时。法应观察久近成办。尽我寿来为能办不。设不办者我命终后。为有余人能续办不。或有国王大臣长者及商主等欲于佛法作衰损事。有阿罗汉念欲化之。即便观察彼可化不。设可化者为久近耶。我寿尽未化事果不。设不果者我命终后有能续不。此等皆以愿智故知。诸如是事名住持佛法。知世间安不安者。谓阿罗汉或时观察所在国土及时分中。当有丰俭怖畏安隐疾疫等事。欲令自他知趣舍故起愿智知。如昔于此迦湿弥罗国有王名铄迦。为缚喝国王入境侵夺。时王铄迦即率兵士欲与交战。彼王本性慈仁恒惧恶业。窃作是念。不知我今战必得胜存王位不。脱当不遂徒杀人民。更招殃罪死堕地狱。曾闻某甲僧伽蓝中。有阿罗汉得妙愿智。我当往问。念已即往。归诚礼敬请决所疑。彼阿罗汉便答王曰。我虽曾得此智然资缘阙故。身力羸劣久不现前。时王即以种种饮食上妙资具而供给之。尊者未几能起愿智即为观察。便见彼缚喝王必当夺得铄迦王位作大饶益。见已即报铄迦王言。王当失国愿自思勉。铄迦敬诺。即率左右及将眷属。舍国而去往投他土。由此因缘诸阿罗汉欲知彼义。入边际第四静虑者。问何故名边际第四静虑耶。答此于第四静虑。为表为极为稠林。故名边际第四静虑。即是最胜品第四静虑义。犹如树端树中最胜名树边际。有说。此是表智极智稠林智等诸功德法所依处。故名边际第四静虑。谓无量等种种功德熏相续已。方起此定故。依此定所起功德。于诸功德为表为极为稠林。犹如醍醐牛味中胜。有说。此应名后际第四静虑。际有三。一前际二中际三后际。此三即过去现在未来。如其次第。此中前际二智所知。谓宿住随念智。及愿智。中际亦二智所知。谓他心智及愿智。后际唯愿智所知。以未来境中唯有此智。是故此智名后际智。能起此定名为后际第四静虑。有说。此应名未至际第四静虑。际有三种。一未至际二至际三至已际。此三即未来现在过去。如其次第。如知现在名至际智。知过去名至已际智。如是此智多分知未来故名未至际智。能起此定名未至际第四静虑。有说。此但应名边际第四静虑。所以者何。边者名现在蕴界处。际者名过去未来。如于现在蕴界处有现见智转。如是于过去未来亦有现见智转。故此智名边际智。能起此定名为边际第四静虑。从定起已如愿皆知者。问为在定知为起定知。若尔何失。若在定知。何故此中说从定起已如愿皆知。若起定知。何故须入边际第四静虑耶。答即在定能知。问何故此中说从定起已如愿皆知。答此于说时名知由说显知故。复次尔时令他知故说名为知。有说。起定能知。问何故复入第四静虑。答边际第四静虑是知方便。要入彼定此智生故。如是说者。初说为善以在定能知起定说故

问愿智自性是何。答自性是慧。如自性如是我物性相本性亦尔。已说自性。所以今当说。问何故名愿智。答如愿能知故名愿智。问为如自愿能知。为如他愿能知耶。答如自愿亦知。如他愿亦知。随所有愿皆能知故。复次知所有愿故名愿智。愿有二种。谓菩提愿及有愿。菩提愿者如慈氏等愿。有愿者如阿氏多等愿。知此等愿故名愿智。复次智随愿起故名愿智。谓此智殊胜。要由先愿作意加行所引发故。如来虽无作意加行。而亦必有心愿为先。有说。此应名期智以所知境微细甚深。必起要期方能知故。有说。此应名妙智以诸智中此最胜故。如世间说妙饮食妙衣服等。彼于胜说妙声。此亦如是。然此愿智。界者色界。地者在第四静虑地。所依者依欲界身。行相者作十六行相。或余行相所缘者缘一切法。念住者通四念住。智者旧阿毗达磨者说唯一世俗智。有余师说。八智性除尽无生。所以者何。彼非见性愿智是见性故。如是说者。唯一世俗智。三摩地俱者不与三摩地俱。唯有漏故。根相应者舍根相应。世者堕三世。缘三世及离世。善不善无记者是善缘三种。三界系不系者唯色界系。缘三界系及不系。学无学非学非无学者是非学非无学。缘三种。见所断修所断不断者是修所断。缘三种。缘名缘义者通缘名义。缘自相续他相续非相续者通缘三种。何处起者。欲界起非色无色界。欲界中唯人趣非余。人趣中唯三洲非北洲。三洲中男女身俱能起。尊者瞿沙筏摩作如是说。唯赡部洲能起非余洲。唯男子能起非女人。所以者何。愿智殊胜。要依增上猛利之身。余二洲及女身皆羸劣故。如是说者初说为善。三洲男女身皆增上猛利。以皆能得心自在及定自在故。若不尔者。经不应说大生主为上首五百苾刍尼。于一日中俱舍寿行而般涅槃。彼若不得边际第四静虑则不能舍于寿行。既于此得何独不能发起愿智。问何等补特伽罗能起此智。答圣者非异生。圣中无学。非有学。无学中唯不时解脱。非时解脱。所以者何。若于定得自在及相续。不为烦恼所持者能起愿智。诸异生及信胜解二事俱无。见至虽于定得自在。而相续为烦恼所持。时解脱虽相续不为烦恼所持。而于定不得自在。是故皆不能发起。愿智唯有不时解脱于定得自在。及相续不为烦恼所持故。能起愿智

说一切有部发智大毗婆沙论卷第一百七十八阿毗达磨大毗婆沙论卷第一百七十九

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    定蕴第七中不还纳息第四之六

问愿智。为加行得。为离染得。答有加行得。有离染得。此中有说。佛离染得。尽智时得故。声闻独觉加行故得。加行故现在前。有说。佛及独觉俱离染得。尽智时得故。声闻加行故得。加行故现在前。有说。佛独觉到究竟声闻皆离染得。尽智时得故。余声闻加行故得。加行故现在前。如是说者。若决定可得者彼离染得。尽智时得故。后作加行方现在前。佛不由加行。独觉下加行。声闻或中或上。然有愿智由边际定加行故得。加行故现在前。问此愿智加行云何。答以一切地及边际定为加行。谓修行者将起此愿智时。先起欲界善心。次此无间入初静虑。次入第二静虑。次第乃至入非想非非想处。从非想非非想处起还入无所有处。次第乃至入初静虑。从初静虑起复入第二静虑。次第乃至入第四静虑。彼既如是于上下地一切等至。循环入出令极调顺第四静虑已。复于第四静虑从下入中从中入上。如是上品名为边际第四静虑。从此次第引起愿智。是故尊者世友作如是言。诸阿罗汉为饶益他故。于上下地循环入出令调柔随顺第四静虑。若时加行流注无滞。尔时名为加行成满。从此能引愿智现前。大德说曰。于无间灭无间起及俱生中了知方便。若时加行流注无滞。尔时名为加行成满。从此引起愿智现前

问宿住随念智与缘过去愿智何差别。答名即差别。谓此名宿住随念智。此名缘过去愿智。复次宿住随念智知前际有漏五蕴。此愿智知有漏无漏诸蕴。复次宿住随念智知欲色界前际五蕴。此愿智知三界及不系诸蕴。复次宿住随念智知诸蕴共相。此愿智知诸蕴自相及共相。复次宿住随念智此法者有外法者亦有。此愿智唯此法者有。复次宿住随念智异生有圣者亦有。此愿智唯圣者有。复次宿住随念智学无学非学非无学者皆有。此愿智唯无学者有。复次宿住随念智时解脱不时解脱相续中皆有。此愿智唯不时解脱相续中有。复次宿住随念智依四根本静虑。此愿智唯依第四根本静虑。复次宿住随念智通曾得未曾得曾习未曾习共不共。此愿智唯未曾得未曾习不共。复次宿住随念智初引发时唯能生生次第随念后成满时。若生生次第若超百生千生等。随其所欲皆能随念。此愿智初引发时及成满时。若次第若超越如其所愿皆如实知。复次此愿智但于宿住随念智所知境转者。即有六事胜。一炽盛胜。二增上胜。三微妙胜。四清净胜。五明白胜。六迅速胜。况余多耶。是谓宿住随念智缘过去愿智差别

问他心智与缘现在愿智何差别。答名即差别。谓此名他心智。此名缘现在愿智。复次他心智缘一物为境。此愿智缘一物或多物为境。复次他心智缘自相境。此愿智缘自共相境。复次他心智缘他相续。此愿智缘自他相续。复次他心智缘心心所法。此愿智缘五蕴。复次他心智依四根本静虑。此愿智唯依第四根本静虑。复次他心智此法者有外法者亦有。此愿智唯此法者有。复次他心智异生有。圣者亦有。此愿智唯圣者有。复次他心智学无学非学非无学者皆有。此愿智唯无学者有。复次他心智时解脱不时解脱相续中皆有。此愿智唯不时解脱相续中有。复次他心智通曾得未曾得曾习未曾习共不共。此愿智唯未曾得未曾习不共。复次他心智有漏无漏。此愿智唯有漏。复次他心智缘欲色界系及不系法为境。此愿智缘三界系及不系法为境。复次此愿智但于他心智所知境转者。即有六事胜。谓炽盛胜等如前说。况余多耶。是谓他心智缘现在愿智差别

问云何愿智能知未来。答有说。以过去现在比知未来。譬如田夫下种子已。比知定有如是果生。彼亦如是。有说。若尔愿智应是比量智非现量智。应作是说。此愿智不待观因而能知果。不待观果而能知因。是故此智是现量智。非比量智。问云何愿智知无色界。答有说。由观等流及行差别。如观行路之人知所从至。有说。若尔愿智应是比量智非现量智。应作是说。此愿智不观因而知果。不观果而知因。故此智是现量智。非比量智。然声闻独觉有余习过患故。于所愿境加行乃知。如来余习过患永尽。故于所愿举心即知。问世尊愿智云何能知一切有情心相差别。答有说。此不必须问。所以者何。此是诸佛境界不可思议故。有说。先已品量而今能知。有说。由取一分所识知有情心相差别。类知余者。如世界坏时有情多分生极光净天。于彼展转访宿住事。后以宿住随念智知。佛亦如是。有说。佛于缘起善达故知。有说。佛于愿智自在故知。有说。佛于自业善达故知。有说。佛于等流善达故知。有说。佛于行差别善达故知。尊者说曰。佛于有情心界欲知便知。不因加行无烦责问。以初得阿耨多罗三藐三菩提时。此种类智皆已得故。问何缘发起如是愿智。答为饶益他故。谓先起愿智观诸有情意乐差别。后随所应作饶益事。譬如良医先观病者差别相已然后授药

问愿智当言善耶。无记耶。答或善。或无记。此中有说。愿智唯一。谓在第四静虑唯是善。有说。愿智有二。谓在第四静虑及欲界各唯善。有说。愿智有三。谓第四静虑善欲界善无记。有说。愿智有五。谓四静虑及欲界各唯善。有说。愿智有六。谓四静虑善欲界善无记。有说。愿智有七。谓上三静虑唯善。初静虑及欲界各善无记。有说。愿智有十。谓四静虑及欲界各有善无记。如是说者。应知如前说六者善。问愿智唯在第四静虑又唯是善。何故乃言四静虑善欲界善无记耶。答愿智实在第四静虑及唯是善。然此中依密意说。愿智及愿智后同缘起说智。皆名愿智故。其事云何。谓瑜伽师先依第四静虑发起愿智知所知法。即缘此法入第三静虑。次第乃至即缘此法。起欲界善心。从此无间即缘此法起欲界善或无记心说所知法。此中若根本若后起皆说名愿智。是故说或善或无记

云何无诤行。乃至广说。问何故作此论。答为欲分别契经义故。如契经说。我弟子中善现苾刍住无诤行第一。虽作是说。而不广辩。云何无诤行无诤名何法。彼经是此论所依根本。彼所不说者。今应说之。故作斯论。问云何无诤行。答一切阿罗汉善达内时外不如是。若亦善达外时名无诤行。云何内时。谓自相续中所有烦恼。云何外时。谓他相续中所有烦恼。遮此烦恼名为善达。一切阿罗汉于自相续所有烦恼皆已遮断。于他相续所有烦恼则不决定。若亦能遮名无诤行。有说。时谓三时。即日初分日中分日后分。于此三时制诸烦恼。名为善达。一切阿罗汉于自相续三时烦恼皆已制断。于他相续三时烦恼则不决定。若亦能制名无诤行。有说。时谓六时。即日夜各初中后分。于此六时制诸烦恼名为善达。一切阿罗汉于自相续六时烦恼皆已制断。于他相续六时烦恼则不决定。若亦能制名无诤行。尊者妙音说曰。非谓无有自相续中烦恼故名无诤行。但以能遮他相续中烦恼诤故名无诤行。所以者何。诤是对他之名。非对自故。问何故遮制烦恼。名为善达。答要由方便觉慧现前。方能遮制自他烦恼故名善达

问无诤名何法。答令他相续无杂秽转。谓诸烦恼能为津润垢腻杂秽。得无诤者不为他相续中烦恼之所津润垢腻杂秽。即是远离他相续中诸烦恼义。有说。此文应言于他相续无遗余转。谓得无诤者。如于自相续烦恼永断无余。如是于他相续烦恼亦能遮制令无有余。即是遍遮他相续中应令彼起诸烦恼义。有说。此文应言于他相续无差别转。谓得无诤者如能遮亲相续中烦恼令其不生。如是亦能遮怨及中相续中烦恼令其不起。即是平等遮制他相续中诸烦恼义。问善达外时无杂秽转有何差别。答善达外时。谓慧无杂秽转。谓烦恼不起

复次彼阿罗汉行五种法。令他相续烦恼不起。何等为五。一净威仪路。二应时语默。三善量去住。四分别应受不应受。五观察补特伽罗。净威仪路者。彼阿罗汉先一处坐。若他来者即观其心。以何威仪令不起结。若知由此生彼结者。即便舍此住余威仪。若不起结即如本住先住。余威仪亦尔。应时语默者。彼阿罗汉见他来时便观其意。为应与语为应默耶。观已若见语起彼结。虽极欲语即便默然。若见由默起彼结者。虽不欲言而便与语。若涉道路见二人来。即观谁应先可与语。观已若见与此语时彼起结者。即与彼语与彼亦然。若俱与语而起结者。即便默然俱默亦尔。若语若默俱起结者。即为避路令不起结。善量去住者。彼阿罗汉随所住处即便观察。我为应住。为应去耶。若见住时起他结者处虽安隐资具丰饶随顺善品而便舍去。若见由去生他结者。处虽不安资缘匮乏不顺善品而便强住。分别应受不应受者。彼阿罗汉若有施主以资具施。即观其心为应受为不应受。观已若见受起彼结。虽是所须而便不受。若见不受起彼结者。虽所不须而便故受。观察补特伽罗者。彼阿罗汉为乞食故将入城邑里巷他家。观察此中男女大小。勿有因我起诸烦恼。若知不起便入乞食。若知起者。虽复极饥而便不入。无如是事为分别故。假使一切有情。因见我故起烦恼者。我即往一无有情处断食而死。终不令他因我起结。彼阿罗汉修行如是五种行法。则能遮他相续烦恼令不现前

问何故阿罗汉已得解脱而修此法自拘缚耶。答彼阿罗汉先是菩萨种性。不忍有情造恶招苦。为拔彼故恒作是念。我无始来与诸有情互起缠缚。轮回五趣受诸剧苦。我幸得免复应救彼。又作是念。我无始来或作倡妓或淫女等鄙秽之身。百千众生于我起结。尚由此故长夜受苦。况我今者离贪恚痴为世福田。于我起结而不招苦。故我今者不应复作烦恼因缘。故阿罗汉虽自解脱而为有情起无诤行

问彼为遮他自相烦恼。为共相耶。答唯自相可遮。非共相。所以者何。共相烦恼随其所应。一时总缘一界一地一处一类。一所得身执我我所。或执断常。或拨为无。或执第一。或执能净。或起犹豫。无明不了一切有情恒任运起不可遮止。是故唯遮自相烦恼。问无诤行自性云何。为是定。为是慧耶。设尔何失。若是定者此文云何通。如说善达外时名无诤行。善达是慧。若是慧者余说云何通。如说应习静定无诤。答应说是慧。问若尔。何故说应习静定无诤耶。答彼应说应习静慧无诤。而说应习静定无诤者。欲显与定俱故名定。而实是慧。是名无诤自性。如自性我物等亦尔。已说自性。所以今当说。问云何名无诤行。答此行能对治他烦恼诤故。名无诤行。然诤有三。一烦恼诤。二蕴诤。三斗诤。烦恼诤者谓百八烦恼。蕴诤者谓死。斗诤者谓诸有情互相陵辱言语相违。应知此中说烦恼诤。为遮有情起烦恼故。复有说者。由此能令自他诤无故名无诤行。即是善修无我行义。是故尊者善现曾于日暮至一毗诃罗扣门而立。门内苾刍问言是谁。尊者善现由住无诤久时熟修无我行故。默不能答言我是善现。良久乃曰。此是世间假所立名为善现者。又彼尊者曾路行遇雨。至一外道门侧避之。外道问言。仁字何等。尊者善现由住无诤久时熟修无我行故。默不能答我是善现。再三问已。乃徐答言。此是世间假名善现。故知善修无我行者。令自他诤无说名无诤行。有说。诸瑜伽师由住此故于爱不爱。宜不宜。可意不可意。有利无利苦乐具中。悉皆无诤故名无诤行

复次无诤界者堕色界。有说。堕欲色界。如是说者。初说为善。地者在第四静虑。有说。在五地。谓四静虑及欲界。如是说者。谓初说善。所依者依欲界身。行相者是不分明行相。所缘者缘欲界。于欲界中但缘烦恼。有说。通缘欲界五蕴。如是说者。初说为善。念住者是法念住。有说。通四念住。如是说者。法念住。善智者是世俗智。三摩地俱者非三摩地俱。根相应者舍根相应。世者堕三世缘未来。善不善无记者是善缘不善。有说。通缘不善无记而多缘不善。三界系不系者。色界系缘欲界系。学无学非学非无学者。是非学非无学缘非学非无学。见所断修所断不断者。是修所断缘修所断。有说。通缘见修所断多缘修所断。缘名缘义者但缘义缘自相续他相续非相续者。但缘他相续。有说。通缘自他相续而多缘他相续。何处起者。应言欲界起。非色无色界。欲界中唯人趣非余趣。人趣中唯三洲非北洲。三洲中男子女人俱能起。尊者众世说曰。唯赡部洲唯男子能起。如是说者初说为善。何等补特伽罗起者。是圣者非异生。唯无学非学。无学中唯不时解脱非时解脱。所以者何。以要得自在定及相续不为烦恼所持者方能起故。问佛独觉到究竟声闻。为亦住无诤不。设尔何失。若彼亦住无诤者。无诤能遮他相续烦恼。何故犹起百千众生而缘彼起烦恼。若彼不住无诤者。契经说云何通。如说尊者善现住无诤第一。彼根性劣尚能住无诤。佛独觉等根胜。而彼何故不能住于无诤耶。答应言佛等亦住无诤。问若尔。何故犹起百千众生而缘彼起烦恼耶。答佛及到究竟声闻。俱是说法教化他者皆得愿智。观察有情我今为能令彼于我不起烦恼而种善不。若知能者便往化之。若知不能不起彼结但能令彼种善根者。即念宁起彼结要当令种善根。所以者何。彼若能起毛许胜善。必能摧灭如山烦恼诸恶行故。若知俱不能者则方便避之。胜于善现过百千倍。有说。佛及到究竟声闻不住无诤。问何故善现能住无诤。佛等根胜不能住耶。答尊者善现于无诤中爱乐尊重恒时修习。佛等不尔。非于无诤起极尊重想故。然非不能住。如是说者。佛等亦住无诤然不多住为化有情故。所以者何。诸受化者根性不等。或宜慰喻。或宜诃责。或宜称赞。然后入法。彼虽或于诃责等位起贪嗔慢。然必因此种诸善根。是故如来舍利子等虽能恒住无诤行。为化有情而不多住

问无诤。为加行得。为离染得。答有加行得。有离染得。此中有说。佛离染得。尽智时得故。声闻独觉加行故得。加行故现在前。有说。佛及独觉俱离染得。尽智时得故。声闻加行故得。加行故现在前。有说。佛独觉到究竟声闻皆离染得。尽智时得故。余声闻加行故得。加行故现在前。如是说者。若决定可得者彼离染得。尽智时得故。后加行现在前。佛不加行。独觉下加行。声闻或中或上。然有无诤由边际定加行故得。加行故现在前。问此无诤加行云何。答以一切地及边际定为加行。如愿智中广说

如契经说。善现苾刍修无诤行证法随法。问无诤不能断诸烦恼。世尊何故作如是说。答彼尊者于无诤行从昔以来。爱乐修习由此展转能起圣道。断诸烦恼成阿罗汉。从此能起无诤现前。依此密意故作是说。非谓无诤能断烦恼。其事云何。曾闻尊者昔由二缘。于无诤中发起正愿。一由见二由闻。由见者。谓于往昔见佛弟子由住无诤。每至城邑衢路市里。将护有情令不起结。由闻者。谓于往昔闻佛弟子由住无诤。余说如前。既见闻已起正忆念。随所修习施戒多闻精勤梵行。一切皆以回向无诤。愿我未来作佛弟子恒住无诤。将护有情如所见闻。诸佛弟子。由彼愿力感众同分。于释迦牟尼佛法中。为住无诤第一弟子。为无诤故速疾证得阿罗汉果。以无诤必依无学身故。由斯密意。契经说言。修无诤行证法随法。问无诤作何行。答作寂静行。为寂静他诸烦恼故

如说我弟子中因儒童黠慧第一。乃至广说。问何故作此论。答为欲分别契经义故。如契经中。世尊记说五百弟子。各随所能双双第一。今本论师欲于相似双中显差别故。而作斯论。问何故世尊说诸弟子双双第一。尊者世友说曰。世尊欲显善说法中师与弟子贤和无诤互不相隐真实功德。非如外道为名利故心怀嫉姤弟子与师互相非毁。复次世尊欲显善说法中弟子尚有真实功德可称可记。何况于师。恶说法中师尚无有实德可记。何况弟子。复次欲显善说法中悭垢永断师与弟子互相称扬真实功德。非如外道有悭垢故。师于弟子。弟子于师。尚不欲闻他人称赞。何况自说。复次世尊显已所应作事皆已成办舍教授担而自安故。复次欲显苾刍修正加行。有所归趣非悠悠故。复次世尊欲令于所赞德随彼爱乐多住中者生敬重心意望满故。复次佛为勉励新学苾刍令生希慕翘勤修故。大德说曰。由二因缘世尊记说弟子功德。一者显己现法乐住。二者哀愍后世有情。复次世尊自显于九十六诸外道众中我众最胜故。复次世尊欲显佛出世间有大饶益。谓佛出世乃有如是诸第一双开士出现非无佛时。复次世尊欲令于诸功德差别门中别别乐者欢喜勤修舍诸懈怠疾证得故。复次世尊欲以弟子所得证已所说是真实故。复次欲止诽谤善说法中无有现证上人法者故。复次世尊欲止见诸苾刍形容憔悴生轻慢者。显此皆有殊胜功德。阿毗达磨诸论师言。随诸佛法故。谓过殑伽沙数如来应正等觉出现世间法。皆记说弟子众中所有多双第一功德今佛亦尔。复次欲令世间别别爱乐诸功德者闻生欢喜。于佛正法。起尊重心种诸善根获大饶益故。复次欲与未来诸佛庄严徒众故。谓佛记说诸弟子已无量有情若见若闻皆生欢喜发起正愿。随所修习施戒多闻正勤梵行皆以回向第一功德。愿我来世于佛法中得预如斯诸正士数。则为庄严彼佛徒众。复次欲令所记弟子自庆愿满故。谓因儒童等五百苾刍曾于过去五百佛所。若见若闻彼佛记说弟子功德欢喜发愿。随我所有施戒多闻正勤梵行愿于来世佛正法中得预如是大弟子数今既愿满。复闻佛记欢喜踊跃深自庆幸故有是说。一一如来大弟子众皆于过去五百佛所大誓庄严方得成就。由如是等种种因缘佛记弟子双双第一

问如说我弟子中因儒童黠慧第一。婆呬迦等敏捷第一。此二何差别。答尊者因儒童心直心无曲心淳质增上。尊者婆呬迦等心濡心调柔心和顺增上由此俱名第一。此中黠慧即是敏捷敏捷即是黠慧。而佛各称第一故须问其异相。尊者因儒童心直心无曲心淳质增上者。直无曲淳质名异义一如其次第以后释前。或心直者是总句。心无曲者别。显心无谄心淳质者别显心无诳。如黠慧马善识人意。虽或惊触无损于人。尊者因儒童亦复如是由黠慧故善知佛意。于诘问时随顺正答。其事云何如契经说。彼在家时丰饶财宝亲属豪贵。常事日天彼以盛年时当娉妇。广请外道婆罗门众于自宅中大设祠祀。佛于化事终不失时。是日晨朝为化彼故着衣持钵命阿难陀。汝可随我入城乞食。命已便入室罗筏城至因儒童宅门而住。外道梵志遥见叱言。今日此家设吉祥会此不祥物何用来为。佛闻便告阿难陀曰。汝往语彼诸外道等。三界大师吉祥中最。汝不欲见吉事。岂成此因儒童定于今日弃舍汝等投我出家。尽汝技术能留难不。时阿难陀受佛教敕如师子王无所畏难往如群鹿外道众中告言。如来善达因果所言诚谛语汝等曰。三界大师吉祥中最。汝不欲见吉事。岂成此因儒童定于今日弃舍汝等投我出家。尽汝伎术能留难不。外道闻已相视笑言。沙门乔答摩随情诡说。何有将临祀会延屈我等内外庆集而归汝出家耶。奇哉沙门如是妄语。时有婆罗门名为五顶。曾见世尊记事不谬告外道众曰。此因儒童定当出家莫生异念。外道咸曰。设有斯事我等必能为作留难。即共相率弹指拊掌。绕因儒童室七重而住。须臾日出此因儒童着新净衣。至重阁上。烧香发愿跪拜日轮。尔时世尊知化时至便自化作婆罗门形。着乌鹿皮金绳络体。手执金杖。从日轮来至因儒童前敷座而坐。儒童接足归诚顶敬。外道喜曰。儒童福人感大梵天亲临礼席事今已办。快哉沙门所言无实。时佛即以所化作形告儒童言。今作何事如是喧扰。儒童羞赧俯首答曰。今随俗法正欲娶妇。佛问所费。答言我费三百千金。复问所用。答言百千与妇作庄严具。百千为众办诸饮食。百千用施诸婆罗门。佛言汝设饮食施婆罗门用二百千。当获爱果事容可尔。余百千者用买妇耶。彼心直故即答言买。佛言汝妇直尔许耶。且汝妇发为直几许。儒童答言此无多直若诸倡伎淫女置之。直一迦羯尼。或唯直半。复问彼爪为直几耶。儒童答言此无所直。佛复次第举彼身中三十六物一一问之。儒童亦一一而答皆言此无所直。然因儒童曾于过去迦叶波佛法中。经十千岁修界方便观因佛别问不净物故。过去所习善品现前遂伏欲贪。离欲界染。世尊于是还复本形。为因儒童说四真谛。彼闻即得不还果证。佛时便执因儒童手上升虚空。说伽他曰

  虽极庄严而行法　　静调息务修梵行
  一切世间累皆舍　　即是净志沙门僧

由此故知彼心质直。若不尔者。化人问时彼应答言。汝是梵志何用知我娶妇事。为娶妇法然云何名买。由质直故随问而答。善品成熟得不还果。是故世尊赞因儒童黠慧第一

说一切有部发智大毗婆沙论卷第一百七十九阿毗达磨大毗婆沙论卷第一百八十

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    定蕴第七中不还纳息第四之七

尊者婆呬迦等心濡心调柔心和顺增上者。等言即摄尊者颇洛迦。尊者至履迦。此中心濡心调柔心和顺名异义一。如其次第以后释前。或心濡者是总句。心调柔者别显无憍心心和顺者别显无慢。云何得知婆呬迦等有心濡等事。曾闻彼三人闻佛出世。访知佛在室罗筏城。三人相随从王舍城往室罗筏。世尊知彼经涉往反善根方熟。即取别路从室罗筏往王舍城。婆呬迦等至室罗筏。闻佛已复往王舍城。即复相将还趣王舍。至已闻佛已往瞻波。复更相将往瞻波国。至已寻访闻佛已往婆罗痆斯。三人相随复往彼国。至已承佛已往劫比罗筏窣睹城。复共诣彼承佛已往吠舍离城。如是世尊于六大城循环六反。婆呬迦等亦恒寻佛六反往还。佛知彼人根熟时。至于室罗筏与其相见。佛方入城彼从城出忽遥见佛欢喜不堪。足未至地得预流果。于后不久成阿罗汉。然彼三人若不心濡调柔和顺便应趣在一城待佛。岂能寻佛遍六大城循环六反。初无一念劳倦之心。才见佛时便证圣果故。佛赞言。婆呬迦等敏捷第一

问如说我弟子中小路于心回善。大路于想回善。此二何差别。答尊者小路多住于心循心观念住。尊者大路多住于法循法观念住。问何故尊者小路多住心念住。尊者大路多住法念住耶。答由彼尊者意乐异故。复次尊者小路是爱行者。彼由心力无始时来于生死中多受苦恼。今成无学常诃责心由此多住心念住观。尊者大路是见行者彼由想力无始时来于生死中多受苦恼。今成无学常诃责想由此多住法念住观。问此二尊者何故立此名耶。答曾闻室罗筏有婆罗门妇数生男生已辄死。其妇未几复产一男。即时遣人弃之大路。经久不死故立此名。彼妇后时复生一子还即遣人弃之小路。亦经久不死因立此名。尊者大路利根见行。至年长大归佛出家。精进修行成阿罗汉。尊者小路爱行钝根。乐处居家保恋亲属。广致财产位望奢豪。宗族炽盛受诸欲乐后皆衰减。如伽他曰

  财积后必尽　　位高后必退
  亲合后必离　　寿住后必死

由此小路于后未几父母丧亡。财宝散失退舍豪位。眷属乖离形容憔悴。其兄大路见而愍之度令出家受具足戒。授俱迦声颂令习诵之

  身语意莫作　　一切世间恶
  离欲念正知　　不受苦无义

彼极闇钝受此伽他。雨四月中勤苦习诵。牧牛羊者在路闻之诵皆通利。彼犹未得过雨四月。处处苾刍为谒世尊皆来集会。每日晨旦新学苾刍。皆往邬波陀耶阿遮利耶所受文请义理所废忘。小路尔时亦效他往将出房户。兄即问言汝欲何往。答言欲往邬波陀耶阿遮利耶所受文请义理所废忘。其兄语言我即是汝邬波陀耶。更何所往然彼小路是应诃摈而入道者。大路即时手搦其项曳出房外叱言。愚人。我四月中授汝一颂。牧牛羊者诵皆通利。汝犹未得而今乃言欲往他处受文请义理所忘耶。小路既被兄诃摈已至誓多林间啼泣而住。佛时从外入誓多林见而问之。可怜小路汝何以啼泣。彼以上事具白世尊。佛便语言。汝能随我理所忘不。彼答言能。尔时世尊即以神力转彼所有诵伽他障更为授之。寻时诵得过前四月所用功劳。复别授以除尘垢颂而语之言。今日苾刍从外来者汝皆可为拭革屣上所有尘垢。小路敬诺如教奉行。至日暮时有一苾刍。革屣极为尘垢所著。小路拭之一只极净一只苦拭而不能净即作是念。外物尘垢暂时染着犹不可净。况内贪欲嗔痴等垢长夜染心何由能净。作是念时。彼不净观及持息念便现在前。次第即得阿罗汉果。问小路何缘如是闇钝。答尊者小路于昔迦叶波佛法中。具足受持彼佛三藏。由法悭垢覆蔽其心。曾不为他授文解义及理废忘。由彼业故今得如是极闇钝果。有说。彼尊者曾于婆罗痆斯城作贩猪人。缚五百猪口运置船上度至彼岸。及下船时气不通故猪皆已死。由彼业力如是闇钝。有说。彼尊者昔余生中曾闭塞瞿陀兽窟门令不得出在中而死。由彼业故闇钝如是。如世尊说苾刍当知。我不见一法速疾回转犹如心者。所以者何。心速疾回转难作譬喻。是故汝等应学善知心善知心回转。问所说心速疾回转为以世为以所缘。设尔何失。若以世者则一切有为法皆于世速疾回转。若以所缘则一切心心所法皆于所缘速疾回转。何故但说心耶。答亦以世亦以所缘说心速疾回转。然依相续不依刹那。若依刹那说心速疾回转者则应于世有少分速疾回转。少分不速疾回转。亦无于所缘速疾回转。以说若法为彼所缘此法无时非彼所缘故。由此但依相续说心速疾回转。谓一身中心或时善或时不善或时无记。或时依眼乃至或时唯依于意。或时缘色乃至或时缘法。一一类中复转易故。问诸心所法亦有如是速疾回转。何故但说心耶。答亦应说心所而不说者。应知是佛有余之说。亦是随缘简略之说。有说。此中举心亦摄心所以同聚故。有说。此中说最胜者如说王来。有说。心所依心以心故名心所。以心是大地故心所名大地所有。故说心时亦说心所。有说。他心智证通无间道但缘于心是故偏说。有说。此中心声总说一切心及心所。以彼皆有积集义故。有说。心是前导故但说心。如伽他言意为法前导等。有说。心名远行。如伽他言心远行独行等。有说。心名为王。如伽他言第六增上王等。复次心名为依。如契经说五根行处境界各别。意兼受用五根行处及彼境界彼依意故。复次心名城主如契经说。言城主者即有取识由如是义故但说心。复有说者。心能发起善戒恶戒是故偏说。如契经说善戒恶戒俱依心起。有说。心崄生恶趣。心平生善趣。故但说心如契经说。都提耶子鹦鹉儒童。以于佛边起恶心故身坏命终。如掷贝珠顷当堕地狱。彼复于佛起善心故身坏命终如掷贝珠顷当生天中。有说。心是内法遍一切处。能有所缘是故偏说。心是内法者内处摄故。遍一切处者下从无间上至有顶皆遍有故。能有所缘者能缘一切法故。有说。心恒相续心所不尔。复次心无增减心所不尔。有说。心于如是所依所缘行相转时。心所随转如雄鱼行处雌鱼皆随。是故偏说。有说。若心不调伏不密不护不防不修。不调柔者即便朽败心所亦尔。若心调伏密护防修而调柔者。便不朽败。心所亦尔是故偏说。复次若心不制驰散五境。心所亦尔。若心由制不驰五境。心所亦尔。如滤水筒上开则漏上闭则止。是故但说心非心所。问佛于余处说心犹如猿猴。何故乃言心速疾回转难作譬喻。答非随人随力随时随慧能作彼喻故说难作不言无喻。非随人者。非诸异生随闻寻思劣定者能作。唯佛独觉及圣弟子。善知诸心自相共相者能作。非随力者非不作意无加行作。要由作意加行能作。非随时者。非无佛时能作。要佛日出世方能作故。非随慧者非粗浅慧能作。唯深细觉慧乃能作故。有说。若有于心善知起善知住善知出善知增善知损善知方便善知时分善知所行善知引发者。乃能作彼喻故说难作。有说。谁能作彼喻谓佛。谁知能作彼喻谓即佛。此二不俱故说难作。有说。谁能作彼喻。谓善知心刹那无间生灭者。谁知能作彼喻。谓善知心刹那无间生灭者。此二不俱故说难作。有说。彼喻或等或相似。等者如说心如心。相似者如说心如受等。此俱摄在心速疾中。是故前说此中心声总摄一切心及心所。此外更无等及相似故说难作。有说。若法如心取境势用可为彼喻。然无此法故说难作。虽契经说心如猿猴。然彼舍一枝取一枝顷有百千心。于境回转故说难作。有说。世尊但说难作。譬喻以无证知者故不说全无譬喻。谓佛力能化作一刹那树以喻于心。然无知者故说难作。问尊者舍利子可不知耶。答有说。不知极迅速故有说。能知但不作意知以无用故。胁尊者曰。世尊说心如猿猴者。即是以心喻心。猿猴腾跃轻躁皆心所为故。问所说善知心善知心回转有何差别。答有说。无差别。善知心即是善知心回转。有说。亦有差别。谓名即差别名善知心。名善知心回转。复次观心自性名善知心。观心行相名善知心回转。复次观心性差别名善知心。观心行境差别名善知心回转。复次观心自相名善知心。观心共相名善知心回转。有说。心念住观名善知心。法念住观名善知心回转。复次唯观识食识蕴意处七心界名善知心。总观四食五蕴十二处十八界名善知心回转。有说。观心名善知心观心所名善知心回转。有说。观识名善知心。观识住名善知心回转。胁尊者曰。观有贪心名善知心。观转有贪心为离贪心。名善知心回转。如有贪离贪。应知有嗔离嗔有痴离痴。散略下举小大掉不掉不寂静寂静不定定不修修不解脱解脱染不染有漏无漏缚解系不系亦尔

如说我弟子中舍利子具大慧辩。执大藏得无碍解。此二何差别。答尊者舍利子多住义无碍解。尊者执大藏多住四无碍解。是故世尊各说第一。问若尔。尊者执大藏胜舍利子耶。答舍利子胜以能自在住四但舍而住一故问何故舍利子多住于义。执大藏多住四耶。答尊者舍利子厌离名言爱重于义。尊者执大藏于义名言皆生爱重。有说。尊者舍利子于四无碍解皆得自在。而随乐住一义无碍解。彼一切时但求义故。尊者执大藏于四无碍解皆未自在。世尊说彼得无碍解。彼作是思勿我于此四无碍解入住出心有所忘失不称所记。是故于四循环多住。如二苾刍俱诵四阿笈摩一皆通利一则生梗。彼通利者随乐讽一。其生梗者循环遍理此亦如是。故二尊者所住各异。问四无碍解自性是何。答自性是慧。云何知然如品类足说。法无碍解云何。谓于名句文身不退转智。义无碍解云何谓于胜义不退转智。词无碍解云何。谓于言词不退转智辩无碍解云何。谓于无滞应理说。及自在定慧中不退转智。由此故知慧为自性智即慧故。是谓无碍解自性是我是物是性是相是本性。已说自性所以今当说。问何故名无碍解。答于所知境通达无滞名无碍解。谓法无碍解于名句文身义无碍解。于涅槃胜义词无碍解。于诸方言辞辩无碍解。于正说及道以不退智解无滞碍。有说。于所知境现见而知名无碍解。如世于一现见事中云我于此解知无碍。有说。此应名深密解。谓解阿毗达磨深密处故。有说。此应名随应解。谓随于何境如应解故。界者法词二无碍解堕欲色界。义辩二无碍解堕三界及不堕界。地者法无碍解。有说。在二地谓欲界初静虑。有说。在五地谓欲界四静虑。有说。在七地谓欲界未至静虑中间及四静虑。义辩二无碍解有漏者。在十一地。谓欲界未至静虑中间四静虑四无色。无漏者。在九地。谓未至静虑中间四静虑三无色。词无碍解在二地。谓欲界初静虑。所依者。四无碍解并依欲界。行相者。法词二无碍解不明了行相。义无碍解。诸有欲令唯涅槃是胜义者。彼说作灭四行相及不明了行相。诸有欲令一切法是胜义者。彼说作十六行相及不明了行相。辩无碍解。有说。作十二行相及不明了行相。有说。作道四行相及不明了行相。所缘者。法无碍解缘名句文身。义无碍解或有欲令唯缘灭谛。或有欲令缘一切法。词无碍解缘言词。辩无碍解缘道及说。念住者。法无碍解法念住。义无碍解或有欲令唯法念住。或有欲令具四念住。词无碍解身念住。辩无碍解四念住。智者。法词二无碍解世俗智。义无碍解。诸有欲令唯涅槃是胜义者。有说。六智性谓法智类智世俗智灭智尽智无生智。有说。四智性除尽无生。无碍解是见性故。诸有欲令一切法皆是胜义者。有说。十智性。有说。八智性除尽无生智辩无碍解。有说。九智性除灭智。有说。七智性又除尽无生智。有说。六智性。谓法智类智世俗智道智尽智无生智。有说。四智性又除尽无生智。三摩地俱者。法词二无碍解非三摩地俱。义无碍解。或有欲令唯无相及非三摩地俱。或有欲令三三摩地。及非三摩地俱。辩无碍解。有说。空无愿及非三摩地俱。有说。唯道无愿及非三摩地俱。根相应者。总说与三根相应。然欲界者喜舍相应。初二静虑喜根相应。第三静虑乐根相应。在余地者。唯舍根相应。世者。皆堕三世。法辩二无碍解缘三世。词无碍解过去缘过去。现在缘现在。未来生者缘未来。不生者缘三世。有说。法与词同。有说。法词辩三无碍解过去现在缘过去。未来缘三世。义无碍解。或有欲令唯缘离世。或有欲令缘三世及离世。善等者皆是善。法无碍解缘无记。义无碍解。或有欲令唯缘善。或有欲令缘三种。词辩二无碍解缘三种。欲界系等者。法词二无碍解欲色界系。义辩二无碍解三界系及不系。法无碍解。诸有欲令无色界。亦有名句文身者。彼说缘三界系。诸有欲令无色界无名句文身者。彼说缘欲色界系。义无碍解。或有欲令唯缘不系。或有欲令缘三界系及不系。词无碍解缘欲色界系辩无碍解。有说。缘三界系及不系。有说。缘欲色界系及不系。学等者。法词二无碍解是非学非无学缘亦尔。义辩二无碍解是无学及非学非无学义无碍解。或有欲令唯缘非学非无学。或有欲令缘三种。辩无碍解缘三种。见所断等者。法词二无碍解修所断缘亦尔。义辩二无碍解有漏者修所断。无漏者不断。义无碍解。或有欲令唯缘不断。或有欲令缘三种。辩无碍解缘修所断及不断。缘名缘义者。法无碍解唯缘名。义无碍解。或有欲令唯缘义。或有欲令通缘名义词辩二无碍解唯缘于义。缘自相续等者。法词辩三无碍解缘自相续他相续。有说。但缘自相续。义无碍解。或有欲令但缘非相续。或有欲令缘三种。加行得离染得者。通加行得及离染得。于中有说。佛离染得尽智时得故。声闻独觉加行故得加行故现在前。有说。佛独觉离染得尽智时得故。声闻加行故得加行故现在前。有说。佛独觉到究竟声闻离染得尽智时得故。余声闻加行故得。加行故现在前。如是说者。若定应得彼离染得尽智时得故。后加行现在前。佛不加行。独觉下加行。声闻或中或上。有无碍解由加行故得加行故现在前。问四无碍解加行云何。答有说。法无碍解以习数论为加行。义无碍解以习佛语为加行。词无碍解以习声论为加行。辩无碍解以习因论为加行。于此四处若未善巧必不能生无碍解故。有说。法词二无碍解以习外论为加行。义辩二无碍解以习内论为加行。如是说者。四无碍解皆以习佛语为加行。如于一伽他中应如是说彼名习如是说名是法无碍解加行。应如是解彼义习如是解义是义无碍解加行。应如是训彼词习如是训词是词无碍解加行。应如是无滞说。习如是无滞说是辩无碍解加行是故四无碍解皆以习佛语为加行。问依何引发此无碍解。答依第四静虑边际定慧之所引发。胁尊者言。依四静虑通慧引发。问何处能起此无碍解。答唯欲界能起。欲界中唯人趣三洲。女身男身俱能起。尊者众世说曰。唯赡部洲唯男子能起。如是说者初说为善。以三洲男子俱能留舍寿故。问何等补特伽罗能起无碍解。答圣者非异生。无学非学。不时解脱非时解脱。所以者何。要相续不为烦恼所持。及得自在定者方能起故。信胜解二事俱无。见至虽得自在定而相续为烦恼所持。时解脱虽相续不为烦恼所持而不得自在定。唯不时解脱具有二事是故能起。问四无碍解次第云何。为如说而起为不尔耶。答有说。如说而起。如契经中先说义无碍解是故前起。乃至后说辩无碍解是故后起。谓瑜伽师为知义故先起义无碍解。虽已知义而于名等未善安布。是故次起法无碍解。虽于名等已善安布而于言词未能训释。是故次起词无碍解。虽于言词已能训释而未能无滞应理而说。是故后起辩无碍解。有说。如说。而起如阿毗达磨中先说。法无碍解是故前起。乃至后说辩无碍解。是故后起。谓瑜伽师为知名等次第安布。是故先起法无碍解。虽知名等次第安布。而未了所诠义。是故次起义无碍解。后二如前说。有说。不如说而起。谓先起词次起法次起义后起辩。所以者何。以彼行者先应了达世俗言词。次知言词所依名等。次知名等所依义趣。知三事已方能无滞应理而说。是故词能引法法能引义义能引辩。问四无碍解一一而得为不尔耶。答若得一时必具得四。如四圣种一时而得。随所爱乐次第现前。问独觉到究竟声闻得无碍解不。若得者无退转智名无碍解。此智所知应无谬失。何故尊者大目揵连记他生男而后生女。记天当雨而竟不雨。记王舍城军胜而后反为吠舍离军所败。独觉何缘不能说法。伽他所说复云何通

  唯佛称无学　　得无碍解者
  到功德彼岸　　永无诸误失

若不得者。何故经言。我弟子中摩诃俱瑟耻罗得无碍解。彼尊者根劣佛尚说得大目揵连根胜。于彼何故不得耶。答应言。独觉到究竟声闻亦得无碍解。问无退转智名无碍解。何故尊者大目揵连所记有谬。答彼于自分所观境中智无退转。非于异分不观境中故无有过。如彼所记。先实是男后转为女。时天亦雨。但罗怙罗阿素洛王接置大海。又二国将欲战时护国药叉先斗王舍城药叉初胜后败国人亦尔。非初不胜。然彼尊者于此所记男等事中。但观前位而不观后。若观后者记亦无谬。问若独觉亦得无碍解者。何故不能为他说法。答彼爱寂静乐独处故。怖畏喧杂厌众集故。见远离功德愦闹过失故。心背徒众岂能说法。有说。一切独觉皆是奢摩他行。要毗钵舍那行方能说法。有说。一切独觉不乐安布名身等故。有说。彼审观察设我说法。彼即能入正性离生。得果离染及漏尽者我亦当说。然不能如是。我何能唐捐其功耶。是故不说。有说。一切独觉能审度量世间。唯有二种所化。一者佛所化。二者声闻所化。无有独觉所化有情故不说法。有说。夫说法者。由二因缘。一者力所引发。二者由随他教。独觉无力不随他教。又一者无畏引发。二者由随他教。独觉无无畏不随他教。又一者大悲引发。二者由随他教。独觉无大悲不随他教。是故彼不能说法。问说法具由一切佛法。何故但说力无异大悲非余耶。答力能安立自论。无畏能摧他论。大悲能起说法欲更不待余故唯说此。有说。彼独觉作是思惟。能说法者。所谓法王及法王子。我非法王亦非法王子。何能说法是故不说。有说。彼独觉作是念。我从昔来不曾习学诸说法事是故不说。有说。若自觉而于三种正调伏事得善巧者乃能说法。独觉不尔。有说。自觉而能具一切智一切种智者方能说法。独觉不尔。有说。夫说正法皆为破我独觉出世时。众生着我坚固难破故不说法。有说。彼自觉者于说法时心必依趣涅槃。独觉若起趣涅槃心时。第二刹那便入寂灭极乐解脱故。如来不尔。虽乐解脱而为大悲大舍所持能久住说。有说。自觉而能成就无忘失法乃能说法。独觉若在空闲林中能以无碍解安布蕴界处等名句文身。若入聚落行乞食时前所安布或有忘失。彼作是念。我既不得无忘失法何用说法是故不说。有说。独觉种性法应如是。虽得无碍解而不乐说法。欲有饶益唯现神通。或但为他授八斋戒。问若声闻独觉亦得无碍解。伽他所说复云何通。答唯佛所得究竟圆满最胜自在无有错谬故作是说非谓二乘皆不成就。若不尔者。二乘亦应不得无学。以伽他说唯佛是无学故。有余师言。声闻独觉一切不得四无碍解。问何故经言。我弟子中摩诃俱瑟耻罗得无碍解。彼根非胜。佛尚说得独觉到究竟声闻根胜。于彼何故言一切不得耶。答彼所说得是无碍解相似善根而非真实。以彼尊者于长夜中爱乐此法精勤修习。佛随其意故说彼得。余虽得此相似善根。非极爱乐勤修习故不说彼得。问何故二乘一切不得无碍解耶。答无退转智名无碍解。声闻独觉于诸境界智有退转。以所记说有误失故非无碍解。如是说者。初说为善。以声闻独觉于自分境中智无退故

此中愿智摄愿智边际智无诤智四无碍解。如愿智应知义无碍解亦尔。边际智不摄词。余如愿智说。无诤智摄无诤智愿智边际智。义无碍解不摄法词辩三无碍解。如无诤。应知法词辩三无碍解亦尔。如其所应各说自摄除无诤词无碍解。又不摄边际智。此七种皆依边际定得。边际定力所引发故。边际静虑体有六种。谓七除词。以第四静虑最上品名边际故。有余师说。四静虑最上品皆名边际。是故彼说边际静虑具有七种七智相摄。亦有差别准上应知。然能引发唯是第四静虑边际非余

说一切有部发智大毗婆沙论卷第一百八十阿毗达磨大毗婆沙论卷第一百八十一

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    定蕴第七中不还纳息第四之八

如说我弟子中大迦叶波少欲喜足具杜多行。薄矩罗少病节俭具净戒行。此二何差别。答尊者大迦叶波所得饮食。若粗若妙随次第食无所简别。犹如良马随得而食。尊者薄矩罗所得饮食或粗或妙。简去妙者而食粗者。问何故尊者大迦叶波粗妙等食。尊者薄矩罗简妙食粗。答尊者大迦叶波具妙乐欲住沙门法。具妙乐欲。故不简妙食。住沙门法故不简粗食。但随所得次第而食。尊者薄矩罗具粗乐欲住沙门法。具粗乐欲故简去妙者。住沙门法故而食粗者。复次尊者大迦叶波。广识大福易得衣服饮食卧具医药及余资具先不受。杜多功德而能奉行。彼由二缘极为难事。谓易得利养不受。杜多功德而能奉行。尊者薄矩罗。非广识大福难得衣服饮食卧具医药及余资具先受。杜多功德亦能奉行。少识苾刍受杜多功德。于中随转此不为难。彼由二缘非为难事。谓难得利养先受。杜多功德随而奉行。有于此文作相违诵。谓尊者大迦叶波。广识大福易得衣服饮食卧具医药及余资具先受。杜多功德随而奉行。尊者薄矩罗非广识大福。难得衣服饮食卧具医药及余资具先不受。此杜多功德随而奉行。少识苾刍不受。杜多功德于中随转。此不为难彼由二缘非为难事。谓难得利养先不受。杜多功德于中奉行。此显迦叶波由三事故胜。谓具妙乐欲易得利养受行杜多功德。问何故尊者薄矩罗。简去妙食而食粗者。答意乐力故。有情意乐不同随所意乐而食。不可责其所以。有说。精妙饮食多用功成不欲劳费是故不食。有说。精妙饮食增长贪爱多由起诤是故不食。有说。好食乃是富家所有为益贫家是以不食。有说。美食必因害多生命断百千头在于地上。以多身分血肉所成。愍彼有情是故不食。有说。美食多生种种过患是以不食。问如所说。薄矩罗简去妙者为初。即不受为受已弃之。设尔何失。若初即不受云何名受行。次第乞食杜多行者。若受已弃之。云何不损坏施主施物。答应言初即不受。问若尔云何名受行次第乞食杜多行者。答彼尊者得天眼愿智将乞食时。先观何方何村邑里巷唯有粗食。知已便往次第行乞。如契经说有四圣种。一依随所得食喜足圣种。二依随所得衣喜足圣种。三依随所得卧具喜足圣种。四依有无有乐断乐修圣种。问世尊何故说此契经。答为诸弟子安立产业及所作故。谓前三安立产业第四安立所作。前三安立产业者。谓舍四种业行。一种业舍。四种业者。一农务为业。二商估为业。三佣作为业。四自在为业。于此皆舍行一种业者唯以乞求为业。有说。为显示无尽资业及所应作故。复次为显示无罪资业及所应作故。复次为显示无损害资业及所应作故。复次为显示不共外道资业及所应作故。此中资业谓前三所应作谓第四。有说。为显示道及道资粮故。此中前三显道资粮后一显道。如道及道资粮如是沙门沙门资粮。婆罗门婆罗门资粮。梵行梵行资粮应知亦尔。由此等义故。佛说此圣种契经。问圣种自性云何。答皆以无贪善根为自性。有说。前三是无贪善根后一是精进。如是说者初说为善。皆对治贪故。问若尔依何别义说四种耶。答为对治四种爱故。谓于衣喜足对治衣服爱。于食喜足对治饮食爱。于卧具喜足对治卧具爱。乐断乐修对治有无有爱由此故说皆无贪性。若兼相应随转。则欲色界五蕴性。无色界四蕴性。此是圣种自性是我是物是性是相是本性。已说自性。所以今当说。问何故名圣种。有说。亦圣亦种故名圣种。谓善故名圣。无漏故名圣。即此能生诸功德法相续不断故名为种。有说。圣之种故名为圣种。圣谓一切无倒善法。此四能生而相续故说名为种。有说。此于圣者相续中行令彼不断故名圣种。有说。此于圣者相续中可得令彼不断故名圣种。有说。圣谓可爱可喜可乐可意之果此能生彼相续不断故名圣种。此依等流果说。有说。圣名可爱可喜可乐可意异熟。此能引彼相续不断故名圣种。此依异熟果说。有说。圣者即是佛独觉声闻。彼从此生相续不断故名圣种。有说。正法名圣。此能任持令久相续故名圣种。是以正法住世经于千载而不灭者皆是圣种之力。如椽梁持舍使不散坏。由此等缘故名圣种。界者皆堕三界及不堕界。问色界无饮食。无色界无前三。云何三界皆具四种。答彼虽无食等而有彼喜足功德。有说。由下界具四种故展转引生上界者亦具四种。尊者世友作如是说。上界虽无食等而有彼对治。然对治有四种。谓断对治厌坏对治持对治远分对治。色界于食等具四对治。欲界有三除断对治。无色界有二。谓持及远分。尊者觉天说曰。如虽无有无漏衣食等而有无漏圣种。如是虽无色无色界食等而有彼界圣种。大德说曰。不顾恋身之资具尚名住圣种者。况彼亦不顾恋身而当无圣种耶。地者有漏在十一地。无漏在九地。所依者皆依三界。行相者皆作十六行相及余行相。所缘者皆缘一切法。念住者皆四念住。智者皆八智或十智。三摩地俱者皆三三摩地俱及非俱。根者总说皆与三根相应。谓乐喜舍。世者皆堕三世缘三世及离世。善等者皆是善缘三种。欲界系等者皆三界系及不系缘亦尔。问若尔施设论说云何通。如说四圣种皆不为烦恼所染所杂。答彼遮烦恼相应不遮有漏故无过。学等者皆通三种缘三种。见所断等者皆修所断及不断缘三种。缘名缘义者皆缘名义。缘自相续他相续非相续者皆缘三种。加行得离染得生得者是加行得离染得非生得。有说。亦是生得。如是说者初说为善。若生得善亦是圣种者蚁卵蚊蛾等亦成就圣种耶。是故圣种不摄生得善。问圣种为闻为思为修所成耶。答通三种摄。为意地为五识。答唯意地非五识。有说。亦通五识。评曰。不应作是说。所以者何。五识中善唯生得故。问若是加行善者外道所得。静虑无量无色解脱胜处遍处等亦是圣种耶。答彼非圣种。所以者何。若欣乐解脱厌背生死彼善根是圣种。外道所乐皆是生死故彼善根不名圣种。复次于有有具生喜足名圣种。外道善根与此相违故非圣种。以五顶外道等亦求生天受欲乐故。复次圣种皆是出家品善根。外道善根皆是在家品摄故非圣种

问少欲喜足俱对治贪无贪为性。何故喜足立圣种非少欲耶。答少欲之名有过失有增益。喜足不尔。有过失者但言少欲不言无欲故。有增益者于实无欲而名少欲故。于喜足中无如是事故立圣种。有说。少欲于未来处未得事转。喜足于现在处已得事转。不取现在一迦履沙钵拏为难非于未来。转轮王位以喜足难故立为圣种。有说。为异外道故。不说少欲为圣种。若说少欲为圣种者。诸外道辈当作是言我等真是住圣种者。所以者何。汝等犹着粪扫衣而我等露形无衣。汝等犹乞食自活。而我等多自饿不食。汝等犹坐树下而我等或常举手蹻足而住。是故我等真名住圣种者。为遮彼故但说喜足为圣种。外道于有有具不喜足故

问少欲喜足何差别。有说。少欲唯在意地。喜足通六识身。有说。少欲唯欲界。喜足通欲色界。有说。少欲唯欲色界。喜足通三界。有说。少欲堕三界。喜足三界系及不系。如是说者少欲喜足俱通三界系及不系。问若尔何差别。答少欲于未来处未得事转。喜足于现在处已得事转。是谓差别

问病缘医药所生喜足何故不说圣种耶。答亦应说圣种而不说者当知有余。有说。已摄在前所说中。谓病缘医药有二种。一可食二不可食。可食者摄食中。不可食者摄衣服卧具中。有说。为欲饶益病苾刍故不说于药喜足为圣种。谓有苾刍身虽有病以少务故不求医药。若佛立此为圣种者。彼便守病不能勤修圣道加行。为饶益彼令勤修道是故不说彼为圣种。有说。若受用时能生放逸于彼喜足立为圣种。病缘医药于受用时但能除病不增放逸是故不说。有说。若一切处一切人一切时受用者于彼喜足立为圣种。病缘医药非有如是一切受用故彼喜足不立圣种。是以尊者薄矩罗言。我于佛法中出家年过八十。曾不忆身有疾疹乃至头痛。亦不忆受用病缘医药乃至诃梨怛鸡。生欲界者尚然何况生色无色界。问何故别解脱律仪唯无表立圣种非表耶。答前说相续不断名为圣种。表非相续不断是故不说。有说。无表可与圣道俱故立圣种。表不与圣道俱是故不说。出家者有四圣种。在家者亦有四圣种。然出家者二因缘故名有圣种。一意乐故。二受用故。诸在家者由一因缘名有圣种。谓意乐故非受用故。如天帝释处妙花座有十二那庾多侍女围绕六万音乐而自娱乐。于四圣种恒有意乐而无受用。频毗娑罗等诸国王苏达多等诸长者亦尔。问为有一一圣种即名住圣种者耶。答不尔。要具四种方名住圣种者。然得一圣种时必具得四。如无碍解得一必具四

过去诸佛皆称赞粪扫衣而不许着。今释迦佛亦称赞粪扫衣而便许着。问何故尔耶。答过去时人贪心微薄虽得价直百千衣服。染着之心不如今人染着凡衣故。有说。彼时人众丰饶财宝。诸苾刍等欲求价直百千衣服。易于今时求粪扫衣故。尊者世友说曰。过去时人意乐广大。见诸苾刍畜上妙资具。便生欢喜信敬之心。今时人意乐狭劣。若见苾刍畜粗弊资具。乃至欢喜信敬之心故。尊者觉天说曰。往昔时人身体细濡若受用粗弊物者则不能自存。今世时人身体粗[革*卬]虽受用粗弊则能自存故。大德说曰。过去诸佛称赞粪扫衣当知即是亦许受用。若不尔者何故称赞。诸佛不以无事而有所说故

如世尊说粪扫衣少易得无罪。云何少云何易得云何无罪。尊者世友说曰。少用功而办故。非多人受用故名少。随彼彼时处皆可得故名易得。佛所听许故智者受用故名无罪。大德说曰。少价量故名少。不从他求故名易得。无摄受故名无罪。由二因缘佛说于衣喜足为圣种。一为诃责于衣不喜足如难陀等。二为赞美于衣喜足如大迦叶波等。由二因缘佛说于食喜足为圣种。一为诃责于食不喜足如婆拖梨等。二为赞美于食喜足如薄矩罗等。由二因缘佛说于卧具喜足为圣种。一为诃责于卧具不喜足。如愚王苾刍等。如契经说愚王苾刍白佛言。唯愿世尊观我床座粗弊如是。二为赞美于卧具喜足如颉戾茷多等。由二因缘佛说乐断乐修为圣种。一为诃责懈怠如阐陀等。二为赞美精进如室路拏等。由四因缘则知彼是安住圣种补特伽罗。一不乐闻他说得利养。二不乐亲近贪美食人。三所畜资具少而清净不生染着。四于诸利养得与不得不生爱憎

如世尊言此四圣种是最胜知。是种性知是可乐知是无杂染。不可诃责一切世间。若沙门若婆罗门若天若魔若梵若余世间。无能如法说其过者。云何名最胜知。有说。此四圣种能引最胜故得最胜果故趣向最胜故随顺最胜故名为最胜。佛所施设佛所知故说名为知。有说。佛说五百声闻各有最胜之法。此四堕在彼最胜法中故名最胜。佛知此四是真喜足故名为知。有说。佛及弟子名最胜者彼所赞述名最胜知。有说。佛知此四是胜宝藏能令住者意望满足故名最胜知。谓诸有情多分意望不满而死。唯住圣种者无不意望满足而死。有说。佛知此四是无尽藏令诸智者受用无尽故名最胜知。谓住此者不假多求及多积聚。亦无防守门户关钥随意受用终。无有尽。如转轮王王四洲界。所用财宝可速穷尽。受用此四而无有尽。云何名种性知。答过殑伽沙等诸佛及佛弟子皆从此生故名种性。智者所了故名为知。有说。种性者是能持义。谓能住持圣教令久不灭故名种性。是佛所了故名为知。云何名可乐知。答此四是智者所乐智者所知故名可乐知。有说。佛知此四皆能资助乐断乐修故名可乐知。有说。佛知此四是于昼夜各三时中。智者随应爱乐安住而无懈倦故名可乐知。有说。佛知此四是修行者所乐久住。谓从此日后分结跏趺坐安住其中乃至明日初分。余缘所夺方从彼起。云何名无杂染。答此四圣种不为烦恼恶业所倰杂故。云何名不可诃责。答若住此四恒为住正法者之所赞美未尝诃责。即由此故一切世间沙门婆罗门天魔梵等。无能如法说其过者。尊者世友作如是言。佛知此四能入圣胎故名最胜知。一切圣者皆从此生故名种性知。是修行者昼夜所乐故名可乐知。远离四种世间事业故名无杂染。四事业者谓农务商估佣作自在。一切功德由此具故名不可诃责。于自于他俱无损害故。一切世间沙门。婆罗门天魔梵等无能如法说其过者

如薄伽梵于契经中说伽他言

  诸有伏爱憎　　常居边卧具
  恒住不放逸　　拔有贪随眠

问此伽他中为辩何义答爱谓贪爱。憎谓憎恚。佛圣弟子若伏此二。居边卧具住不放逸。便能永拔有贪随眠。复次若于正法毗奈耶中。随有所得味着心转说名为爱。于所未得愁戚心转说名为憎。佛圣弟子于已得不味于未得不戚。故能俱伏。由俱伏故居边卧具。住不放逸则能永拔有贪随眠。复次若于上妙衣服饮食贪求名爱。若于粗弊衣服饮食嫌逆名憎。佛圣弟子二俱能伏。此句显示于衣服饮食喜足圣种。第二句显示于卧具喜足圣种。后二句显示乐断乐修圣种

问乐断乐修有何差别。答乐断烦恼。乐修圣道。复次无间道名乐断。解脱道名乐修。复次见道名乐断。修道名乐修。如见道修道。如是见地修地未知当知根已知根应知亦尔。复次乐断者显诸忍。乐修者显诸智。乐断乐修是谓差别

如说大名学多住五盖渐断乃至广说。问何故作此论。答为欲分别契经故。如契经说。佛告大名。学多住五盖渐断。契经虽作是说而不分别。云何学云何学多住五盖渐断。彼经是此论所依根本。彼所未说者今应说之故作斯论。如说大名学多住五盖渐断。此中云何学。答预流或一来。云何学多住五盖渐断。答渐断渐离渐伏渐背。问何故此中不说随信随法行名学多。住五盖渐断耶。答应说而不说者当知此义有余。有说。随信随法行有住五盖已断者。有住五盖渐断者。以不定故不说。预流一来不尔决定唯住五盖渐断是以说之。有说。若彼身中五盖烦恼可现行。而渐断者此中则说。随信随法行有漏善心无覆无记心尚无容现行。何况烦恼。是故不说。问预流一来身中疑盖已断。恶作虽未断而更不现行。何故说彼多住五盖渐断。而复说可现行耶。答前文应作是说。学多住诸盖渐断不应言五。而言五者事有五故。谓贪欲嗔恚睡眠惛沉掉举。有说。先断今断总说断五。如言断五顺下分结得不还果。多住者谓数数住。问断离伏背有何差别。有说。无差别俱显断故有说。亦有差别谓断彼缚故名断。离彼得故名离。令不行故名伏。厌逆彼故名背。复次依无间道说断。依解脱道说离。此二依永断说依近加行说伏。依远加行说背。此二依暂断说。复次依无间道说断。依解脱道说离。此二依正断说。依加行道说伏。依胜进道说背。此二依助断说。复次断者依断对治说。离者依持对治说。伏者依远分对治说。背者依厌坏对治说。断离伏背是谓差别

如说苾刍法珊度沙故毗奈耶珊度沙。毗奈耶珊度沙故法珊度沙乃至广说。问何故作此论。答为欲分别契经义故。经说未来有诸苾刍不修身戒心慧。彼不修身戒心慧者法珊度沙故乃至广说。契经虽作是说而不分别。云何法。云何毗奈耶。云何法珊度沙故。乃至广说。彼经是此论所依根本。彼所不说者今悉应说故作斯论。云何法。答八支圣道。云何毗奈耶。答贪嗔痴灭。云何法珊度沙故毗奈耶珊度沙。毗奈耶珊度沙故法珊度沙。答若于八支圣道不修习时。彼于贪嗔痴灭不能作证。若于贪嗔痴灭不作证时。彼于八支圣道不能修习。由此因缘故作是说。此中珊度沙言。有说显喜足。有说显毁坏。若说显喜足者彼说云何法珊度沙故毗奈耶珊度沙。谓于见道生喜足。故便于修道不能修习。若于修道不修习时便于修所断烦恼断不能作证。如是法珊度沙故毗奈耶珊度沙。云何毗奈耶珊度沙故法珊度沙。谓于见所断烦恼断生喜足故。便于修所断烦恼断不能作证。若于修所断烦恼断不作证时。便于修道不能修习。如是毗奈耶珊度沙故法珊度沙。若说显毁坏者。彼说由毁坏圣道故。于贪嗔痴灭不能作证故说法珊度沙故毗奈耶珊度沙。由毁坏贪嗔痴灭故。便于圣道不能修习故。说毗奈耶珊度沙故法珊度沙。问圣道与灭无有过失不可毁坏如何言毁坏圣道灭耶。答毁坏彼相续说毁坏。彼非彼自体实可毁坏。谓由烦恼现在前。故毁坏相续。由相续毁坏。故令圣道转远。由圣道转远故于贪嗔痴灭不能作证故说毁坏。如契经说此是法。此是毗奈耶。此是大师教。问此三何差别。答法谓八支圣道。毗奈耶谓贪嗔痴灭。大师教谓佛语。有说。法谓阿毗达磨藏。毗奈耶谓毗奈耶藏。大师教谓素怛缆藏。是谓此三差别

如说法随法行乃至广说。问何故作此论。答为欲分别契经义故。如契经说法随法行虽作是说而不分别。云何法。云何随法。云何法随法行。彼经是此论所依根本。彼所不说者今应说之故作斯论。云何法。答寂灭涅槃。云何随法。答八支圣道。云何法随法行。答若于此中随义而行。所谓为求涅槃故修习八支圣道故名法随法行。能安住此名法随法行者。问何故涅槃独名为法。八支圣道名随法耶。答于诸法中涅槃胜故。生老病死不能侵故独得法名。八支圣道次彼顺彼如王大臣故名随法。故契经说一切法中涅槃最胜。有为法中圣道最胜。然舍利子赞学经中说言具寿法之随法。所谓离系。彼契经中。圣道名法。涅槃名随法。以先得圣道后证涅槃故。前经依胜劣次第显法随法。后经依证得次第显法随法。复次别解脱名法。别解脱律仪名随法。若于此中随义而行名法随法行。谓为求别解脱故受别解脱律仪。得已随护无有毁犯名法随法行。能安住此名法随法行者。复次身律仪语律仪命清净名法受此名随法。若于此中随义而行名法随法行。谓为求身语律仪命清净故受及受已随护名法随法行。能安住此名法随法行者。问身语律仪命清净即是别解脱律仪所摄何故重说耶。答前是不分别说今是分别说。前是总说今是别说。有说。前是律仪所摄妙行所摄非离律仪所摄。今是律仪所摄妙行所摄亦离律仪所摄。有说。前显示所发起。今显示能发起。前为护所发起故护能发起。今为护能发起故护所发起。有说。前为护果故随护于因。今为护因故随护于果。如因果能作所作亦尔。此中别解脱戒表及初念无表。是尸罗是律仪是妙行是般罗底木叉是般罗底木叉律仪是业是业道。此后无表是尸罗是律仪是妙行是般罗底木叉律仪。非般罗底木叉非初解脱。故是业非业道。究竟思不于此转故。如说具寿我今当说般罗底木叉。汝等谛听此中何法名般罗底木叉。为是尸罗。为是说戒者语。若是尸罗彼不可说。何故言我当说般罗底木叉。若是说戒者语。彼或善心说。或不善无记心说。毗柰耶说云何通。如说般罗底木叉是诸善法首上首前行。有说是尸罗。问尸罗不可说云何言我当说耶。答依展转因故名为说。如子孙法谓语能起名名能显义。有说。是说戒者语。问彼或善心说。或不善无记心说。云何言是诸善法首上首前行耶。答彼毗柰耶依不障因故作是说。谓说戒者随何心说。听者若能如说修行。皆能与彼一切功德作无障因。故言般罗底木叉为诸善法首上首等

说一切有部发智大毗婆沙论卷第一百八十一阿毗达磨大毗婆沙论卷第一百八十二

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    定蕴第七中不还纳息第四之九

云何法轮乃至广说。问何故作此论。答为欲分别契经义故。如契经说世尊转法轮诸余世间沙门婆罗门天魔梵等皆无有能如法转者。契经虽作是说而不分别。云何法轮齐何当言转法轮。契经是此论所依根本。彼所不说者今应说之故作斯论。云何法轮。答八支圣道。若兼相应随转则五蕴性。此是法轮自性。是我是物是相是性是本性。已说自性所以今当说。问何故名法轮。答此轮是法所成法为自性故名法轮。如世间轮金等所成金等为性名金等轮。此亦如是。有说。此轮于诸法性能简择极简择能觉悟极觉悟现观作证故名法轮。有说。此轮能净圣慧法眼故名法轮。有说。此轮能治非法轮故名法轮。非法轮者谓布刺拏等六师所转八邪支轮。问何故名轮轮是何义。答动转不住义是轮义。舍此趣彼义是轮义。能伏怨敌义是轮义。由斯等义故名为轮。如大四十法门经说。有二十善品二十不善品此名梵轮。乃至广说。问二十善品可尔。二十不善品云何名梵轮耶。答佛意不说彼为梵轮。但说于善不善品法有忍智转名为梵轮。问此何故名梵。答极寂静故离灾横故无罪累故不恼害故说名为梵。问何故名梵轮。答以梵世在初可得及具圣道故名梵轮。第二第三静虑非初可得亦不具圣道。第四静虑虽是佛身初得而不具圣道故不名轮。唯有梵世是初可得及亦具足故名梵轮。有说。修梵行者相续中可得故名梵轮。有说。对治非梵行故名为梵轮。有说。对治三界见所断非梵烦恼故名梵轮。有说。此因梵王劝请而转故名梵轮。有说。佛是大梵佛所宣说分别开示故名梵轮。有说。梵音演说故名梵轮。有说。唯梵世圣道能对治众多非梵法故名为梵轮。众多非梵法者谓三界见修所断烦恼。或不善无记烦恼。或有异熟无异熟烦恼。或生二果生一果烦恼。或无惭无愧相应。无惭无愧不相应烦恼。或有事无事烦恼。或忍所治智所治烦恼。如是等名众多非梵法。有说。唯梵世有多梵行果故名梵轮。多梵行果者谓四沙门果。上三静虑唯有二沙门果。无色唯有一沙门果。唯梵世中具有四果。或九遍知果。上三静虑唯有五遍知果。无色唯有二遍知果。唯梵世具有九遍知果。或八十九沙门果唯梵世具有非于上地。是故圣道说名梵轮。问何故唯说见道名法轮非余耶。答前说动转不住义是轮义。见道是速疾道不起期心道于动转不住。最为随顺故独名法轮。有说。前说舍此趣彼义是轮义。见道中舍苦现观趣集现观。乃至舍灭现观趣道现观。是故见道独名法轮。有说。以四事故名轮。一舍此。二趣彼。三未降伏者降伏。四已降伏者守护。见道中亦尔。舍此者舍苦现观。趣彼者趣集现观。未降伏者降伏即集现观。已降伏者守护即苦现观。乃至灭道说亦如是故名法轮。有说。回转义是轮义。犹如车轮周旋回转。如是见道忍智循环。谓忍后智现前智后忍复现前。法品类品循环亦尔故名法轮。有说。上下义是轮义。犹如车轮或上或下如是见道缘境上下。谓缘欲界已即缘有顶。缘有顶已复缘欲界。对治上下说亦如是故名法轮。有说。见道犹如辐毂辋法故说为轮。犹如车轮毂最居中辐依毂住辋摄于辐。如是见道苦集忍智如辐。灭忍灭智如毂。道忍道智如辋。遍缘道故。或有说者。苦集灭忍智如辐三谛如毂道谛如辋。或有说者。三谛忍智如辐道忍道智如辋四谛如毂。或有说者。正见正思惟正勤如辐正语业命如毂正念正定如辋。或有说者。正思惟正勤正念正定如辐正语业命如毂正见如辋。或有说者。唯正定如辋余如前说。有说。降伏四方义是轮义。如转轮王所有轮宝。降伏四洲所有怨敌。如是行者以见道轮降伏四谛所有烦恼故名法轮。有说。见所断烦恼名非法轮。能起八邪支故。见道是彼近对治故说名法轮。尊者妙音说曰。学八支道展转和合一时至他相续中转故名法轮。此八支道见道位胜是故见道独名法轮。齐何当言转法轮。答若时具寿阿若多憍阵那见法。问何故复作此论。答前虽显法轮自性而未显作用。今欲显之故作斯论。有说。为止摩诃僧祇部说法轮语为自性。彼作是说一切佛语皆是法轮。若谓圣道是法轮者则菩提树下已转法轮。何故至婆罗痆斯方名转法轮耶。为止彼意显法轮体但是圣道非佛语性。若是佛语者则应菩提树边为商人说法已名转法轮。何故后至婆罗痆斯国乃言转法轮耶。故知尔时令他身中有圣道起方名转法轮。法轮圣道为体故。说齐阿若多憍阵那见法名佛转法轮。问若尔佛于菩提树下已名转法轮。何故于婆罗痆斯国乃言初转法轮耶。答转法轮有二种。一自相续中转。二令他相续中转。菩提树下是自转法轮。婆罗痆斯是令他转法轮。佛以饶益他为正事故。依令他转说初转法轮。有说。转法轮有二种。一共二不共。菩提树下所转法轮与二乘共自利法故。婆罗痆斯国所转法轮不与二乘共利他法故。依不共说故言彼处初转法轮。有说。与此相违名共不共依共说转。如共不共曾未曾亦尔。有说。若于转时胜独觉者乃言初转。谓诸独觉亦能自转。但不令他。唯佛亦能令他转故。有说。若于转时有人为证乃说初转。谓五苾刍证无我理方能为佛作证转法轮人。有说。婆罗痆斯所转法轮是佛昔日三无数劫所修苦行功劳之果故说初转。所以者何。佛若欲于过去佛所般涅槃者即得随意。所以经于三无数劫精勤修习百千苦行。于蕴处界求善巧者皆为饶益所化有情恒作是愿。若我证得无上菩提当为有情开甘露门。令皆解脱生死牢狱。故今所转正是昔日苦行之果。有说。若能降伏他身烦恼方名法轮正所作用。如王轮宝降伏他土非但降伏自所住宫。如来法轮亦复如是。依此说佛初转法轮。问若彼身中圣道生时即彼名为转法轮者。何故说佛转法轮耶。答依能转因故作是说。谓彼身中所有圣道世尊若不以言说手为其转者。则彼圣道无因得生。彼圣道生皆由佛力。是故说佛初转法轮。如转轮王未已轮宝置于左手右手转之。则诸天神亦不能转。要王转已彼能转之故说轮王能转非彼此亦如是。有说。依开觉缘故作是说。谓彼身中虽有圣道乃至若未以佛语光而照触者无由得生。彼圣道生皆是佛力是故说佛初转法轮。譬如池中嗢钵罗等种种莲花。乃至若未以日光而照触者则不开不敷不香。日光照时则开敷香此亦如是。有说。依除障缘故作是说。谓彼身中虽有圣道。若佛不以未曾有善巧名句文身除彼身中所有障者。则彼圣道无由得生。彼圣道生由佛除障。是故说佛初转法轮。有说。依资助缘故作是说。谓彼身中虽有圣道。若佛不以法水灌之则圣道芽无由得生。彼得生者由佛资助。是故说佛初转法轮。如仓中种子阙众缘故芽则不生。当知芽生由资助力。此亦如是。有说。依示导缘故作是说。谓彼身中虽有圣道。若无如来言说示导彼者则彼身中圣道不转。佛开示故彼圣道转。是故说佛初转法轮。如闇室中以灯昭了便见种种可取之物。此亦如是有说。二因二缘生于正见一闻他法音二如理作意。由闻他法音故说佛初转。由如理作意故说彼自转。有说。若人具足四法名多有所作。谓亲近善士听闻正法如理作意法随法行。由亲近善士听闻正法故说佛转法轮。由如理作意法随法行故说彼自转法轮

问憍阵那住苦法智忍即应说佛初转法轮。何故乃至道类智时方名为转。答苦法智忍时虽得名转。而未究竟道类智时于转究竟。有说。道类智时三因缘具故说名转。一舍曾道二得未曾道三结断一味证。有说。道类智时五因缘具故名为转。一舍曾道二得未曾道三结断一味证四顿得八智五一时修十六行相。舍曾道者谓舍见道。得未曾道者谓得修道。结断一味证者谓集证三界见所断断。顿得八智者谓顿得四法智四类智。一时修十六行相者。谓一时修苦四行相乃至道四行相。有说。道类智时已断一切见所断烦恼。无事烦恼忍所治烦恼永害见邪性故。于尔时方说为转。有说。此所言转依至果位可称可数。有相可说可得施设法补特伽罗而说非于先时不名为转。有说。此所言转约可命终受生处说。非于先时不名为转

如契经说佛说此法门时。具寿憍阵那及八万诸天。远尘离垢于诸法中生净法眼。此中远尘者谓远随眠。离垢者谓离缠垢。于诸法中者谓于四圣谛中。生净法眼者谓见四圣谛净法眼生。问佛说此法门时五苾刍皆见法。何故但说憍阵那耶。答以憍阵那先见法故。谓憍阵那已入见道。余四犹在顺决择分善根位中。有说。世尊于彼有宿愿故以彼为首而转法轮是故偏说。由此佛告憍阵那言汝已解耶。彼言已解。第二第三亦复如是。因斯号彼为阿若多。问世尊何故三问彼耶。答彼憍阵那见圣谛已。世尊便起前后际智作是观察。为憍阵那所应受恶趣相续蕴界处多。为我过去三无数劫所经刹那腊缚牟呼栗多多耶。观已即见憍阵那所应受无间地狱相续蕴界处多。非我过去三无数劫所经刹那腊缚牟呼栗多多。见已便作是念我于三无数劫修无量百千难行苦行。今得无上正等菩提。但令憍阵那尔所无间地狱相续蕴界处住不生法中。设我即般涅槃于我劬劳已为果满况作余事以庆慰故三反问之。复次佛见从不可知本际以来。憍阵那起烦恼缚一切有情。一切有情亦起烦恼缚憍阵那。又见憍阵那于一切有情相续中受胎。一切有情于憍阵那相续中受胎。更相损害更相食啖说亦如是。如见前际见后际亦尔。佛见此已便作是念。我但令憍阵那一人于一切有情离如是事。于我三无数劫所修苦行便为果满。况更饶益无量有情欣慰情深是以三问。有说。为止诽谤是以三问。谓佛为菩萨时厌老病死出劫比罗伐窣堵城求无上智时。净饭王遣释种五人随逐给侍。二是母亲三是父亲。母亲二人执受欲得净。父亲三人执苦行得净。当于菩萨修苦行时。母亲二人心不忍可即便舍去。菩萨知后苦行非道舍而受食羹饭酥乳。以油涂身习处中行。父亲三人咸谓菩萨狂乱失志亦复舍去。于是二女所谓难陀难陀跋罗俱来给侍。尔时菩萨便作是念。若彼五人不舍我者岂令女人来相亲近。菩萨受食十六转乳糜已身力转增。从吉祥人边受取草已诣菩提树自敷草座结跏趺坐。立如是誓我今要当不起此座。降魔军众永断诸漏证取无上正等菩提。立此誓已寻时摧破三十六俱胝恶魔军众。以三十四心得阿耨多罗三藐三菩提。佛眼遍观一切世界谁应最初闻我正法我当为说。观已便知嗢达洛迦曷逻摩子应先闻我法。是时有天即白佛言。嗢达洛迦曷逻摩子昨日命过。有说七日。尔时世尊亦起智见知彼命过便伤叹言。彼失大利。若彼闻我所说法者当得正解。世尊复观除彼谁应初闻我法我当为说。观已便知頞逻茶迦。逻摩应先闻我法。天复白言頞逻荼迦逻摩命过来已经七日。有说昨日。尔时世尊亦起智见知彼命过而伤叹言。彼失大利若彼闻我所说法者当得正解。问佛初得阿耨多罗三藐三菩提时。何故不为二人说法。而令命过不得闻法将非教化失时耶。有说。世尊初成佛时未起为他说法心。又未以大悲缘有情界故。无化道失时之咎。尊者妙音说曰。佛初得无上菩提时爱重法故多日思念。尚不及起饮食之心。况能起心为他说法。复有说者。初成佛时未建立有情三聚差别。未知所应化导及非所应故无有失。有说彼时二人善根未熟未堪闻法。所以者何。佛成道已彼初一人若更经五十七日有余命者应堪闻法。有说。五十六日。有说四十九日。彼第二人若更经五十一日有余命者应堪闻法。有说。五十日有说。四十三日。由此非佛教化失时。世尊或时留自寿行待所化者如待苏跋达罗等。若能留他寿行无有是处。问佛何故伤叹耶。答佛先以彼二人为师习世俗定不得真法。今佛自证无上真法欲令彼知。又欲以己所证饶益于彼而彼命终是以伤叹。问前说彼若闻我法者当得正解依何位说得正解耶。有说。此说入正性离生位。有说。住顺决择分善根位。有说。起顺解脱分善根位。如是说者。乃至令彼除一切智增上慢。知唯佛世尊具一切智。尔时名得正解。世尊复观除彼二人谁复最初应闻我法我当为说。观已即知憍阵那等五人应先闻法。即作是念。彼皆是我父母亲族先来恭敬供养于我。今欲酬报为何所在。天即白言今在婆罗痆斯国仙人鹿苑。尔时世尊亦起智见知在彼处。便舍菩提树步涉而往婆罗痆斯。问佛具最胜神足何以步涉往耶。答敬重法故不以神足。然于行时足常去地如四指量。一一足迹皆有喜旋吉祥可爱。千辐轮相分明如画。身影所触乃至七日能令有情至其处者诸根安悦。渐次行到婆罗痆斯。尔时五人忽遥见佛遂共立制。彼憍答摩懈慢多求狂乱失志空无所获。而今复来欲相呼诱。我等宜各勿与言谈恭敬问讯。但敷一常座任其坐不。尔时世尊渐行近彼威德所逼。令舍本期不觉一时从座而起趍走迎逆合掌归命。于中或有改敷净座。或取佛衣或取佛钵。或有供水。或有洗足。俱白佛言唯愿就座。佛便作念如是痴人自立制约须臾还破。时佛就座安详而坐。威光奇特如妙高山。是时五人虽复恭敬而犹呼佛为具寿。或复称佛为乔答摩。佛即告言汝等勿呼如来为具寿亦勿称触姓名。若故尔者当于长夜获无义利受诸剧苦。所以者何。如来已证无上菩提安隐涅槃。度生老病死觉一切法性。救护一切为三界尊。成就无边功德法故。时五人言。具寿犹是昔乔答摩。身形所作不异往日。懈慢多求狂乱失志。舍于苦行受好饮食以油涂身皮肤充悦。虽知具寿自称证得无上菩提安隐涅槃谁当相信。而不许我称触名姓。世尊告曰。汝今观我面貌威光诸根容止岂与昔日同耶。五人答言。我观具寿实异于昔。佛言。我若不证法者岂得如是。汝应以此证知我得无上菩提。何故犹于如来而生不信。世尊于是渐渐化诱令其调伏。于日初分为二人说法教诫教授。令余三人入村乞食彼所乞食充足六人。于日后分为三人说法教诫教授。令余二人入村乞食。所乞饮食充足五人。世尊性离非时食故。如是教化经于三月。有说四月。令彼五人善根熟已。于迦栗底迦月白半八日如来为彼转正法轮。时憍阵那最初见法。佛便三问汝已解耶。此意问言汝今观我是懈慢多求狂乱失志不证无上菩提涅槃而诳汝耶。故三问解不。彼还三反答言已解此意。答言我今观佛实非懈慢多求。亦非狂乱失志。又实证得菩提涅槃而非诳我。我今为佛证人故三答已解。是故为止诽谤佛三问之。有说。为显本愿满足是以三问。其事云何。曾闻过去此贤劫中有王名羯利。时有仙人号为忍辱。住一林中勤修苦行。时羯利王除去男子。与内宫眷属作诸伎乐游戏林间纵意娱乐经久疲厌而便睡眠。内宫诸女为花果故游诸林间。遥见仙人于自所止端身静思便驰趣之。皆集其所到已顶礼围绕而坐。仙人即为说欲之过。所谓诸欲皆是不净臭秽之法。是可诃责是可厌患。谁有智者当习近之。诸姊皆应生厌舍离。王从睡觉不见诸女便作是念。将无有人诱夺去耶。即拔利剑处处求觅。乃见诸女在仙人边围绕而坐。生大嗔恚是何大鬼诱我诸女。即前问之汝是谁耶。答言我是仙人。复问在此作何事耶。答言修忍辱道。王作是念。此人见我嗔故便言我修忍辱。我今试之即复问言。汝得非想非非想处定耶。答言不得。次第责问乃至汝得初静虑耶。答言不得。王倍嗔忿语言。汝是未离欲人云何恣情观我诸女。复言我是修忍辱人。可伸一臂试能忍不。尔时仙人便伸一臂。王以利剑斩之。如断藕根堕于地上。王复责问汝是何人。答言我是修忍辱人。时王复令伸余一臂即复斩之如前责问。仙人亦如前答我是修忍辱人。如是次斩两足复截两耳。又割其鼻一一责问答皆如前。令仙人身七分堕地作七疮已王心便止。仙人告言。王今何故自生疲厌。假使断我一切身分犹如芥子乃至微尘。我亦不生一念嗔忿。所言忍辱终无有二。复发是愿。如汝今日我实无辜。而断我身令成七分作七疮孔。我未来世。得阿耨多罗三藐三菩提时。以大悲心不待汝请最初令汝修七种道断七随眠。当知尔时忍辱仙人者即今世尊释迦牟尼是。羯利王者即今具寿憍阵那是。故憍阵那见圣谛已佛以神力除彼闇障。令其忆念过去世事。彼便自见为羯利王佛为仙人。自以利剑断佛七支作七疮孔。佛不嗔恨反以誓愿欲饶益之。故佛世尊三问解不。此意问言我岂违背昔愿。岂不如本誓愿已酬满耶。时憍阵那极怀耻愧合掌恭敬亦三答已解。此意答言实知世尊不违昔愿如本誓愿皆已酬满。我本愚痴作斯极恶。唯愿哀愍赦我重罪。是故为满本愿佛三问之。有说。世尊显己说法有善巧力故三问之。谓此意言我于三无数劫。修无量百千难行苦行。所证得法由巧说故令彼须臾即得悟解是故三问。有说。世尊令余四人闻生勇励速入见道故三问之。有说。世尊欲显善说法中师及弟子。于所证法审谛真实离增上慢。不同外道于未得法。起增上慢谓为已得。是以三问。问佛初转法轮时有八万诸天亦同见法。何故但说为憍阵那等五人转法轮耶。答此中但说正所为者。诸天因五人故得闻非正所为是以不说。有说。人先见法故偏说之。有说。人见现见天非现见。有说。佛与人趣身相威仪所作悉同天则不尔。有说。若于是处名为法灭即于是处名转法轮。谓虽天中有证甘露若人中无便名法灭。是故但说为人转法轮。有说。人中佛弟子有四众差别天中不尔。有说。佛转法轮以人为证不以天证。有说。人中有能转者及所为者是以说之。天中唯有所为无能转者是故不说。有说。人中能得种种殊胜功德。天中不尔。是故但说为人转法轮

说一切有部发智大毗婆沙论卷第一百八十二阿毗达磨大毗婆沙论卷第一百八十三

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    定蕴第七中不还纳息第四之十

转法轮已地神唱声展转宣告乃至广说问会中亦有余天神众发声相告。何缘但说地神唱声。答由彼地神先发声故。问地神何故先发声耶。答以彼最近佛所住故。复次彼恒随佛而作卫故。谓从菩萨处胎初生踰城出家及修苦行乃至成佛转法轮时。恒随卫护令无留难。今见如来转法轮已欢喜踊跃。自庆先来所施功劳今得果满故先唱告。复次时会虽有余天神众而彼地神性轻躁故是以先唱。如今众中性轻躁者多喜高声彼亦如是。复次地神性多喜庆。见此希有极怀欢喜故先发声。复次此是近远次第法故。谓地神先唱。次虚空神。次四大王众天。如是展转经须臾顷声至梵世。问声是刹那性若此处生必此处灭。云何可说至梵世耶。答依展转义故作是说。谓地神唱已虚空神唱展转宣告乃至梵天如燃灯法展转增广有说。转法轮时无量天众皆悉来集既闻法已各还所住。宣告自部故说展转声至梵世。有说。彼时发声亦无决定先后但是说者叙述次第法应如是故作是说。地神先唱乃至广说

如契经说转轮王出世时声至他化自在天。佛为憍阵那等转法轮时声至梵世。佛得阿耨多罗三藐三菩提时声至色究竟天。问何故如是三种差别。答转轮王出世时以十善法。教导有情。此法必于欲界天中受异熟果。六欲天众皆生欢喜我等眷属不久增多。是故轮王出世声至他化自在天。梵天王请佛转法轮彼闻佛转法轮深庆随喜。是故转法轮时声至梵世。净居天觉悟菩萨令踰城出家求无上智。彼闻菩萨得阿耨多罗三藐三菩提极怀喜慰。是故初成佛时声至色究竟天。复次转轮王是受欲者故出世时声极欲界不至离欲地。佛转法轮时于一众会有尊卑胜劣。此事唯至梵世。是故转法轮时声至梵天。唯有如来名声高远无所不至。是故佛得无上菩提时其声遍及所应至处。乃至色究竟天。设当有顶有情有耳识者声亦彻彼。所以者何。如来久修名称业故。复次诸有情类造作增长大名称业有上中下。下者如转轮王。中者如憍阵那等。上者谓佛。是故于彼声有近远。复次诸有情类造作增长净尊贵业有上中下。下者如转轮王中者如憍阵那等。上者谓佛。是故声至有近有远。尊者世友说曰。诸有情类恭敬赞叹父母师长。沙门婆罗门佛独觉。及佛弟子。身语意业有上中下。下者如转轮王。中者如憍阵那等。上者谓佛。是故声至三处不同

问上地亦有声何故转法轮时声唯至梵世。答语表业声唯至彼故。复次语言行唯至彼地语言行者所谓寻伺。复次乃至彼地得有耳识非上地故。有说。唯至梵世得具起善染污无覆无记语有表声非上地故。复次唯至梵世得具起善染污无覆无记耳识现前非上地故。有说。若处有众生差别转法轮时声则至彼。复次若处作三千世界分齐者声至于彼。有说。梵世是世间有情所尊重处。是故转法轮时声但至彼。复有说者。上地诸天亦名为梵。是故转法轮时声至梵世者。不唯至初静虑地

问佛所说法尽名法轮耶。答不也。唯令入见道者乃名法轮。问若尔闻佛说法入见道者多。何故不皆名法轮耶。答彼一切虽皆是法轮而最初最后得正解者说为法轮。初谓憍阵那等。后谓苏跋达罗

问一切佛转法轮处为定不耶。若定者然灯佛本事当云何通。如说然灯佛于灯光城喝利多罗山转正法轮。乃至广说。若不定者达摩苏部底所说颂云何通。如说

  应念过去佛　　于此迦尸宫
  仙论施鹿林　　亦初转妙法

有说。应言转法轮处定问若尔然灯佛本事当云何通。答此不必须通。所以者何。此非素怛缆毗柰耶阿毗达磨所说。但是传说诸传所说或然不然。若必欲通者应知过去灯光城即是今婆罗痆斯。过去喝利多罗山即是今仙人鹿苑。若作是说。佛转法轮处定者。彼说有四处定二处不定。四处定者谓菩提树处。转法轮处。天上来下处。现大神变处。二处不定者谓佛生处及般涅槃处。云何得知菩提树处定。答曾闻过去有转轮王。导从四兵飞空而过至菩提树上。其轮便止欲前不得。王遂惶恐作是思惟。我今将无欲失王位或命难耶。时菩提树神即白王曰。大王勿怪王不失位亦无命难。王不见下菩提树耶。此中有金刚座一切菩萨皆于此座证得无上正等菩提。王欲过者可避此处从余道往。时王便下种种供养菩提树已从余道去。以是事故知菩提树处定。转法轮处定者如前所引法善现颂。复云何知天上来下处定。答曾闻佛去世后此处有难事起诸苾刍等并皆舍去。外道异学来居其中。后诸苾刍来索其处。语外道曰。此是我师天上来处可速避去。诸外道言。此是我等常所住处。因此二众大兴斗诤。近住城中长者居士诸官僚等来解其诤而不能得。乃至王自解之亦不能定。时诸苾刍告外道曰。今当与汝俱设诚言应属谁者当有瑞相。外道言尔。彼遂先请而空无验。苾刍即复作诚谛言。此处若是一切如来升三十三天为慈母说法经三月已下来处者当现瑞相。时彼住处大石柱上有石师子即便哮吼。外道惊恐即时舍去。从师子口复出众宝花鬘缠绕石柱皆悉周遍。时众观者叹未曾有。于是苾刍遂共居止。以是故知佛从天上来下处定。复云何知现大神变处定。答曾闻外道于六大城被佛追寻无所投迹。遂共聚集请与如来捔其神变。佛皆不许。后至室罗茷悉底城方始许可为现神变。无量外道归佛出家以此故知现大神变处定。有说。诸佛转法轮处不定。所以者何。若嗢达洛迦曷逻摩子。及頞逻茶迦罗摩不命终者。佛岂舍摩揭陀国往婆罗痆斯。故知但随应初闻法者所在即于彼处而转法轮。问若尔法善现颂当云何通。答此不必须通。所以者何。此非素怛缆毗柰耶阿毗达磨所说。但是文颂。夫造文颂或增或减。若必欲通者过去亦曾有佛于此初转法轮。非谓一切故非决定。若作是说。转法轮处不定者。彼说有三处定三处不定。三处定者谓菩提树处。天上来下处。现大神变处。三处不定者谓生处。转法轮处。般涅槃处。如所说佛于婆罗痆斯仙人论处施鹿林中。为憍阵那等转正法轮。问何故名婆罗痆斯。答此是河名去其不远造立王城。是故此城亦名婆罗痆斯。问何故名仙人论处。答若作是说。诸佛定于此处转法轮者。彼说佛是最胜仙人皆于此处初转法轮故名仙人论处。若作是说。诸佛非定于此转法轮者。彼说应言仙人住处。谓佛出世时有佛大仙及圣弟子仙众所住。佛不出世时有独觉仙所住。若无独觉时有世俗五通仙住。以此处恒有诸仙已住今住当住故名仙人住处。有说。应言仙人堕处。昔有五百仙人飞行空中至此遇退因缘一时堕落。问何故名施鹿林。答恒有诸鹿游止此林故名鹿林。昔有国王名梵达多。以此林施与群鹿故名施鹿林。如羯兰铎迦长者。于王舍城竹林园中穿一池以施羯兰铎迦鸟。令其游戏因名施羯兰铎迦池。此亦如是故名施鹿林

云何正法。答无漏根力觉支道支。问何故作此论。答为欲分别契经义故。如伽他说

  三世三佛陀　　能破诸愁毒
  彼皆重正法　　恒住于法性

又契经说。有二补特伽罗能住持正法。谓说者行者。毗柰耶说我之正法应住千岁。或复过此由度女人出家便减五百。世尊虽于处处说正法言。而不分别。云何正法。契经是此论所依根本。彼所未说者今应说之故作斯论。问有漏根力道支是正法不。若是者。此中何故不说。若非者何故无漏是正法有漏非耶。有说。彼亦是正法。问此中何故不说。答应说而不说者当知此义有余。复次有漏根等是无漏加行。若说根本则已摄加行故不别说。复次有漏根等是无漏加行故亦名无漏。是故已摄在前所说中。有说。有漏根等非是正法。问何故无漏是正法有漏非耶。答以有漏法有过患故。要无过患乃名正法。复次是清净是可称赞名为正法。有漏法与此相违故非正法。复次正法者能永出生死得般涅槃。有漏不尔故不名正法。问念住正断神足为亦是正法不。若是者此中何故不说。若非者何故根力觉支道支是正法念住等非耶。答彼亦是正法。问若尔此中何故不说。答应说而不说者当知此义有余。复次若说根等则于此文随顺念住等非顺此文是故不说。复次念住正断神足皆亦摄在此所说中。谓四念住即慧根慧力择法觉支正见所摄。四正断即精进根精进力精进觉支正勤所摄。四神足即定根定力定觉支正定所摄

齐何当言正法住。答若时行法者住。齐何当言正法灭。答若时行法者灭。问何故复作此论。答为欲分别契经义故。如契经说。迦叶波当知如来所觉所说法毗柰耶。非地界水界火界风界所能灭没。然有一类补特伽罗当出于世。恶欲恶行成就恶法非法说法法说非法。非毗柰耶说毗柰耶。于毗柰耶说非毗柰耶。彼能灭我三无数劫所集正法令无有余。契经虽作是说而不分别。齐何当言正法住。齐何当言正法灭。彼经是此论所依根本。彼所不分别者今应分别故作斯论。此中有二种正法。一世俗正法。二胜义正法。世俗正法谓名句文身。即素怛缆毗柰耶阿毗达磨。胜义正法谓圣道即无漏根力觉支道支。行法者亦有二种。一持教法。二持证法。持教法者谓读诵解说素怛缆等。持证法者谓能修证无漏圣道。若持教者相续不灭能令世俗正法久住。若持证者相续不灭能令胜义正法久住。彼若灭时正法则灭。故契经说我之正法不依墙壁柱等而住。但依行法有情相续而住。问何故世尊不决定说法住时分耶。答欲显正法随行法者住久近故。谓行法者若行正行恒如佛在世时。及如灭度未久时者则佛正法常住于世无有灭没。若无如是行正法者则彼正法速疾灭没。如佛告阿难陀言。于我善说法毗柰耶中。若当不度女人出家者我之正法应住千岁。或复过此。由度女人出家故令我正法减五百岁。问若正法住犹满千年何故世尊作如是说。答此依解脱坚固密意而说。谓若不度女人出家应经千岁解脱坚固。而今后五百岁唯有戒闻等持坚固非解脱者。皆是度女人出家之过失耳。有余师说。此依若不行八尊重法密意而说。谓若度女人出家不令行八尊重法者则佛正法应减五百岁住。由佛令彼行八尊重法故正法住世还满千岁

问如来正法云何灭耶。答如来正法将欲灭时此赡部洲当有三王出世。一王有法。二王无法。其有法者生在东方威德慈仁伏五印度。其无法者生在达絮篾戾车中。性皆顽嚣憎贱佛法相与合纵。从西侵食渐入印度转至东方。志与佛法为大衰损。随所到处破窣堵波坏僧伽蓝。杀苾刍众多闻持戒无得免者。烧灭经典无有遗余。时东方王闻彼达絮篾戾车王侵食印度渐至东方。乃率兵士与之交战。彼王军众即时退走擒获二王皆断其命。寻时遣使遍诸方维召命一切沙门释子。请都集会住我国中。我当尽形供给奉施衣服饮食卧具汤药。及余所须令无乏短。于是一切赡部洲中所有苾刍皆来集会憍饷弥国。时王日日设五年会种种供养。然诸苾刍由多得利养故。及由多有先为活命而出家故。不能精勤读诵经典。不乐独处静虑思惟。昼则群聚谈说世事扰动喧杂。夜则疲怠耽着睡眠无所觉察。由此于佛所有教诫。皆悉慢缓而不遵行。是时赡部洲中唯有二行法者。一是阿罗汉名苏剌多。一是三藏名室史迦。亦名般株。而为众首。即于是日正法将灭。日初分时憍饷弥城中王为上首。五百净信长者。同时造立五百僧伽蓝。以彼先闻法将灭故举手议言。佛涅槃时以法付嘱二部弟子。一者在家二者出家。勿谓今由在家弟子。不能给施诸出家人。令乏短故正法灭没。但由仁等出家弟子无正行故令正法灭。有说。如待客法初及后时皆设丰膳。如是正法初出现时及后将灭。皆致丰厚资缘供养。有说。彼作是念乃至佛法未灭世间犹有无量福田。佛法若灭世间但有有量福田。我等幸因佛法未灭。当共及时作所应作。有说。释迦为菩萨时见过去佛或由资缘阙故。或由遭疾疫故令正法灭。即时发愿。愿我成佛勿由此事令法灭尽。故法虽灭而资缘丰厚住处增广。是夜僧伽蓝内为布洒陀故。无量苾刍皆共聚集。时悦众者请众首三藏室史迦为众说般罗底木叉三藏许之而欲略说。时阿罗汉苏剌多从座而起。偏袒一肩顶礼三藏合掌白言。唯愿上座为众广说三藏。答言。于此众中谁能具行般罗底木叉戒而请我广说。阿罗汉曰。如佛在世诸苾刍等。于诸学处所行边际我皆能行。若此名为能具行者愿为广说。作是语时三藏弟子生大嗔恚即叱之言。是何苾刍。故于众前违反我师不受教诲。寻共害彼阿罗汉命。胜义正法从斯灭没。时有敬重彼阿罗汉天龙药叉。兴大嗔忿杀彼三藏。有说。即彼阿罗汉弟子为报仇故害三藏命。有说。王闻彼阿罗汉无辜被杀追恋。懊恼而杀三藏。世俗正法从斯灭没。尔时世间胜义世俗二种正法皆灭没。已经七昼夜天地冥闇而其世间犹故未知正法已灭。所以者何。由佛往昔为菩萨时好掩他恶。亦不举他所隐覆事。由此业故法灭七日无有知者。过七日已大地震动殒星雨火烧诸方维。空中天鼓发声振吼甚可怖畏。天魔眷属生大欢喜。于虚空中张大白盖。空中复有大声唱言。释迦大仙所有正法从今永灭。更无能入正性离生。妙甘露门于斯永闭。大苦黑闇遍满世间。更无救护将导之者。有作是说。尔时一切律仪羯磨结界皆舍。如是说者从此以后更无结界羯磨受戒。然先所有今时不舍。或有诸佛未般涅槃正法便灭。或有诸佛般涅槃后经于七日正法便灭。然我世尊释迦牟尼般涅槃后乃至千岁正法方灭。彼未般涅槃及般涅槃已经于七日正法灭者。依更无有入正性离生说名为灭。释迦如来正法灭者依甘露界断说名为灭。虽天中犹有甘露界在。然依人中灭故名灭。问何故过去诸佛有未般涅槃正法即灭。有于般涅槃后七日即灭。今释迦佛千岁方灭耶。答过去诸佛寿量长远。于彼正教所应作者佛在世时多已究竟故法速灭。今世尊释迦牟尼出百年时寿量短促。正教所作虽佛涅槃多未究竟。乃至千岁于中有种善根者。有成熟者有解脱者。是故经于多时正法方灭。有说。过去诸佛所有弟子爱重奢摩他非毗钵舍那。由重奢摩他故恒住寂止。不乐传说契经等十二分教故法速灭。今世尊弟子爱重毗钵舍那非奢摩他。由重毗钵舍那故。多住观察皆乐传授契经等十二分教。是故正法多时乃灭。问正法灭已无得圣者耶。答亦有从预流果得一来果。从一来果得不还果。从不还果得阿罗汉果。而无从顺决择分入正性离生者。唯由此故名正法灭

若初入无漏初静虑乃至广说。问何故作此论。答欲止他宗显己义故。谓或有说。无未来修。或有说。圣道是无为。或有说。圣道是一。为止彼意显有未来修。亦显圣道是有为而非是一。故作斯论。若无未来修者则功德法无增益义。佛尽智时应不具一切智。若圣道是无为者便不可修。以无为法非所修故。若圣道是一者则无三世差别。经不应说有三世佛等。问若圣道是有为而非一者。何故经说我证得旧道唯一无二。答由五因缘故作是说。谓加行相似行相相似等广说如智蕴。若初入无漏初静虑。由得此故得诸余无漏心心所法彼何世摄。答未来。若初入乃至无漏无所有处。由得此故得诸余无漏心心所法彼何世摄。答未来。此中初者有四种。一入正性离生初。二得果初。三离染初。四转根初。广说如智蕴。未来生时说名为得。若至现在名为已得。故今得者是说生时

诸生何世摄乃至广说。问何故作此论。答欲止他宗显己义故。谓譬喻者说有为法但有二时。一未生时。二已生时。除此更无正生正灭。今显实有正生正灭时故作斯论。复次为止拨无去来世执现在是无为法。今说未来有生现在有灭故。即显去来非无而现在是有为故作斯论。复次为止执有为法唯转变隐显而体无生灭。今说未来生现在灭。故即显有为法非但转变而实有生灭故作斯论。诸生何世摄。答未来。诸灭何世摄。答现在。以未来名正生。现在名正灭。现在名已生。过去名已灭故

    定蕴第七中一行纳息第五之一

三三摩地谓空无愿无相乃至广说。问何故作此论。答为欲分别契经义故。如契经说有三三摩地。所谓空无愿无相。契经虽作是说而不分别。若成就空彼无愿耶。如是等。彼经是此论所依根本。彼所不说者今应说之故作斯论。复次为止拨无不成就性。说成就性但是假有。欲显成就不成就性俱是实有故作斯论。复次为止拨无去来二世。执现在是无为法。显有二世现是有为故作斯论

若成就空彼无愿耶。答如是。设成就无愿彼空耶。答如是。以此三三摩地俱时得故。同对治故。俱时得者谓若依空三摩地入正性离生苦现观四心顷亦得无愿。若依无愿三摩地入正性离生苦现观四心顷亦得空及于修道。无学道中若得一必具二。同对治者。谓彼俱能对治见苦所断烦恼及修所断。虽于见道集现观四心顷。道现观三心顷时得无愿非空。而先于不成就得成就时。必俱得故恒俱成就若成就空彼无相耶。答若得此中得谓已得。即灭法智忍已生此后恒成就无相。设成就无相彼空耶。答如是。以成就无相时必先得空故。若成就无愿彼无相耶。答若得。设成就无相彼无愿耶。答如是此如以空对无相说

若成就过去空彼未来耶。答如是。问此说在何位。答此说依空三摩地入正性离生。苦现观三心顷集灭现观各四心顷。道现观三心顷及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱阿罗汉练根作不动。彼空三摩地已起灭不失。设成就未来空彼过去耶。答若已灭不失则成就。若未已灭设已灭而失则不成就。问此说在何位。答若已灭不失则成就者。此说即前所说诸位。若未已灭设已灭而失则不成就者。此说若依空三摩地入正性离生苦现观一心顷。若依无愿三摩地入正性离生。苦集灭现观各四心顷。道现观三心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。空三摩地未已起灭。已起灭者由得果转根故失。若成就过去空彼现在耶。答若现在前谓不起无愿。或无相或有漏心亦非无心故言若现在前。问此说在何位。答此说依空三摩地入正性离生苦现观三心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。空三摩地已起灭不失。及现在前。设成就现在空彼过去耶。答若已灭不失则成就。若未已灭设已灭而失则不成就。问此说在何位。答若已灭不失则成就者。此说即前所说诸位。若未已灭设已灭而失则不成就者。此说依空三摩地入正性离生苦现观一心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。空三摩地现在前。而未已灭先已灭者。由得果转根故失。若成就未来空彼现在耶。答若现在前。谓不起无愿或无相或有漏心亦非无心故。言若现在前。问此说在何位。答此说依空三摩地入正性离生苦现观四心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。空三摩地现在前。设成就现在空彼未来耶。答如是。问此说在何位。答此说即前所说诸位

若成就过去空彼未来现在耶。答未来成就现在。若现在前。问此说在何位。答此说依空三摩地入正性离生苦现观三心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。若时解脱练根作不动。空三摩地已起灭不失亦现在前。设成就未来现在空彼过去耶。答若已灭不失则成就。若未已灭设已灭而失则不成就。问此说在何位。答若已灭不失则成就者。此说即前所说诸位。若未已灭设已灭而失则不成就者。如前现在对过去说。若成就未来空彼过去现在耶。答有成就未来空非过去现在。有及过去非现在。有及现在非过去。有及过去现在成就未来空非过去现在者。谓已得空未已灭。设已灭而失不现在前。问此说在何位。答此说依无愿三摩地入正性离生苦集灭现观各四心顷。道现观三心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。若时解脱练根作不动。空三摩地未已起灭。先已起灭者由得果转根故失亦不现在前。及过去非现在者。谓空已灭不失不现在前。问此说在何位。答此说依空三摩地入正性离生集灭现观各四心顷。道现观三心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。若时解脱练根作不动。空三摩地已起灭不失不现在前。及现在非过去者。谓空现在前未已灭设已灭而失。问此说在何位。答此说依空三摩地入正性离生苦现观一心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。空三摩地未已起灭先已起灭者。由得果转根故失而现在前。及过去现在者。谓空已灭不失现在前。问此说在何位。答此说依空三摩地入正性离生苦现观三心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。空三摩地已起灭不失亦现在前。设成就过去现在空彼未来耶。答如是。此谓即前所说诸位。诸成就过去现在必成就未来故。若成就现在空彼过去未来耶。答未来成就过去。若已灭不失则成就。若未已灭设已灭而失则不成就未来成就者。如前现在对未来说。过去若已灭不失等者如前现在对过去说。设成就过去未来空彼现在耶。答现在前此如前未来对现在说。差别者此中必成就过去。如空历作六句应知无愿无相亦尔。随其所应尽当知

说一切有部发智大毗婆沙论卷第一百八十三阿毗达磨大毗婆沙论卷第一百八十四

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    定蕴第七中一行纳息第五之二

若成就过去空彼过去无愿耶。答若已灭不失则成就。若未已灭设已灭而失则不成就。问此说在何位。答若已灭不失则成就者。此说依空三摩地入正性离生集现观三心顷。灭现观四心顷道现观三心顷。及得预流果阿罗汉果。时解脱练根作不动。空三摩地已起已灭。若得一来果不还果信胜解练根作见至。空无愿三摩地已起已灭。若未已灭设已灭而失则不成就者。此说依空三摩地入正性离生苦现观三心顷。集现观一心顷。及得一来果不还果。信胜解练根作见至。空三摩地已起灭不失。无愿三摩地未已起灭。先已起灭者。由得果转根故失。设成就过去无愿彼过去空耶。答若已灭不失则成就。若未已灭设已灭而失则不成就。问此说在何位。答若已灭不失则成就者。此位如答次前问说。若未已灭设已灭而失则不成就者。此说依无愿三摩地入正性离生苦现观三心顷。集灭现观各四心顷。道现观三心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。无愿三摩地已起灭不失。空三摩地未已起灭。先已起灭者由得果转根故失。若成就过去空彼未来无愿耶。答如是。此二决定俱时得故。问此说在何位。答此说依空三摩地入正性离生苦现观三心顷。集灭现观各四心顷。道现观三心顷。若得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。空三摩地已起灭不失。设成就未来无愿彼过去空耶。答若已灭不失则成就。若未已灭设已灭而失则不成就。问此说在何位。答若已灭不失则成就者。此说即前所说诸位。若未已灭设已灭而失则不成就者。此说若依空三摩地入正性离生苦现观一心顷。若依无愿三摩地入正性离生苦集灭现观各四心顷。道现观三心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。空三摩地未已起灭先已起灭者。由得果转根故失。若成就过去空彼现在无愿耶。答若现在前。谓若不起空或无相或有漏心亦非无心故言若现在前。问此说在何位。答此说依空三摩地入正性离生集现观四心顷。道现观三心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。空三摩地已起灭不失无愿现在前。设成就现在无愿彼过去空耶。答若已灭不失则成就。若未已灭设已灭而失则不成就。问此说在何位。答若已灭不失则成就者。此说即前所说诸位。若未已灭设已灭而失则不成就者。此说依无愿三摩地入正性离生苦集现观各四心顷。道现观三心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。空三摩地未已起灭先已起灭者。由得果转根故失无愿现在前。若成就过去空彼过去现在无愿耶。答有成就过去空非过去现在无愿。有及过去非现在。有及现在非过去。有及过去现在。成就过去空非过去现在无愿者。谓空已灭不失无愿未已灭。设已灭而失不现在前。问此说在何位。答此说依空三摩地入正性离生苦现观三心顷。及得一来果不还果。信胜解练根作见至。空三摩地已起灭不失无愿未已起灭先已起灭者。由得果。转根故失亦不现在前。及过去非现在者。谓空无愿已灭不失无愿不现在前。问此说在何位。答此说依空三摩地入正性离生灭现观四心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。空无愿三摩地已起灭不失。无愿不现在前。及现在非过去者。谓空已灭不失无愿现在前。未已灭设已灭而失。问此说在何位。答此说若依空三摩地入正性离生集现观一心顷。及得一来果不还果。信胜解练根作见至。空三摩地已起灭不失。无愿未已起灭先已起灭者。由得果转根故失而现在前。及过去现在者。谓空无愿已灭不失无愿现在前。问此说在何位。答此说依空三摩地入正性离生集道现观各三心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。空无愿三摩地已起灭不失无愿现在前。设成就过去现在无愿彼过去空耶。答若已灭不失则成就。若未已灭设已灭而失则不成就。问此说在何位。答若已灭不失则成就者。此说即前所说诸位。若未已灭设已灭而失则不成就者。此说依无愿三摩地入正性离生苦现观三心顷集现观四心顷。道现观三心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。无愿三摩地已起灭不失。空三摩地未已起灭。先已起灭者由得果转根故失无愿现在前。若成就过去空彼未来现在无愿耶。答未来成就现在。若现在前。问此说在何位。答此说依空三摩地入正性离生集现观四心顷。道现观三心顷及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。空三摩地已起灭不失无愿现在前。设成就未来现在无愿彼过去空耶。答若已灭不失则成就。若未已灭设已灭而失则不成就。问此说在何位。答若已灭不失则成就者。此说即前所说诸位。若未已灭设已灭而失则不成就者。此说依无愿三摩地入正性离生苦集现观各四心顷。道现观三心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。空三摩地未已起灭先已起灭者。由得果转根故失无愿现在前。若成就过去空彼过去未来无愿耶。答未来成就过去。若已灭不失则成就。若未已灭设已灭而失则不成就。问此说在何位。答未来成就过去。若已灭不失则成就者。此说依空三摩地入正性离生集现观三心顷。灭现观四心顷。道现观三心顷。及得预流果阿罗汉果。时解脱练根作不动。空三摩地已起灭不失。若得一来果不还果。信胜解练根作见至。空无愿三摩地已起灭不失。若未已起灭。设已起灭而失则不成就者。此说依空三摩地入正性离生苦现观三心顷。集现观一心顷。及得一来果不还果。信胜解练根作见至。空三摩地已起灭不失。无愿未已起灭先已起灭者由得果转根故失。设成就过去未来无愿彼过去空耶。答若已灭不失则成就。若未已灭设已灭而失则不成就。问此说在何位。答若已灭不失则成就者。此位如答次前问说。若未已灭设已灭而失则不成就者。此说依无愿三摩地入正性离生苦现观三心顷。集灭现观各四心顷。道现观三心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。无愿三摩地已起灭不失。空未已起灭先已起灭者。由得果转根故失。若成就过去空彼过去未来现在无愿耶。答有成就过去空及未来无愿非过去现在。有及未来现在非过去。有及过去未来非现在。有及过去未来现在。成就过去空及未来无愿。非过去现在者。谓空已灭不失无愿未已灭设已灭而失不现在前。问此说在何位。答此说依空三摩地入正性离生苦现观三心顷。及得一来果不还果。信胜解练根作见至。空三摩地已起灭不失。无愿未已起灭先已起灭者。由得果转根故失亦不现在前。及未来现在非过去者。谓空已灭不失无愿现在前。非已灭设已灭而失。问此说在何位。答此说依空三摩地入正性离生集现观一心顷。及得一来果不还果。信胜解练根作见至。空三摩地已起灭不失。无愿未已起灭先已起灭者。由得果转根故失。而现在前及过去未来非现在者。谓空无愿已灭不失无愿不现在前。问此说在何位。答此说若依空三摩地入正性离生灭现观四心顷。及得预流果阿罗汉果。时解脱练根作不动。空三摩地已起灭不失。无愿不现在前。若得一来果不还果。信胜解练根作见至。空无愿三摩地已起灭不失。无愿不现在前。及过去未来现在者。谓空无愿已灭不失。无愿现在前。问此说在何位。答此说依空三摩地入正性离生集道现观各三心顷。及得预流果阿罗汉果。时解脱练根作不动。空三摩地已起灭不失。无愿现在前。若得一来果不还果。信胜解练根作见至。空无愿已起灭不失。无愿现在前。设成就过去未来现在无愿彼过去空耶。答若已灭不失则成就。若未已灭设已灭而失则不成就。问此说在何位。答若已灭不失则成就者。此说即前所说诸位。若未已灭设已灭而失则不成就者。此说若依无愿三摩地入正性离生苦现观三心顷。集现观四心顷。道现观三心顷。及得预流乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。无愿已起灭不失。空未已起灭先已起灭者。由得果转根故失无愿现在前

若成就过去空彼过去无相耶。答若已灭。不失则成就。若未已灭设已灭而失则不成就。问此说在何位。答若已灭不失则成就者。此说依空三摩地入正性离生灭道现观各三心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。空无相已起灭不失。若未已灭设已灭而失则不成就者。此说依空三摩地入正性离生苦现观三心顷。集现观四心顷。灭现观一心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。空三摩地已起灭不失。无相未已起灭先已起灭者。由得果转根故失。设成就过去无相彼过去空耶。答若已灭不失则成就。若未已灭设已灭而失则不成就。问此说在何位。答若已灭不失则成就者。此位如答次前问说。若未已灭设已灭而失则不成就者。此说依无愿三摩地入正性离生灭道现观各三心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。无相已起灭不失。空未已起灭失已起灭者。由得果转根故失。若成就过去空彼未来无相耶。答若得此谓已得名得即灭法智忍已生。问此说齐何位。答此说依空三摩地入正性离生灭现观四心顷道现观三心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。空三摩地已起灭不失。设成就未来无相彼过去空耶。答若已灭不失则成就。若未已灭设已。灭而失则不成就。问此说在何位。答若已灭不失则成就者。此说即前所说诸位。若未已灭设已灭而失则不成就者。此说依无愿三摩地入正性离生灭现观四心顷。道现观三心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。空三摩地未已起灭。先已起灭者由得果转根故失。若成就过去空彼现在无相耶。答若现在前谓不起空。或无愿或有漏心亦非无心故。言若现在前。问此说在何位。答此说若依空三摩地入正性离生灭现观四心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。空三摩地已起灭不失。无相现在前。设成就现在无相彼过去空耶。答若已灭不失则成就。若未已灭设已灭而失则不成就。问此说在何位。答已灭不失则成就者。此说即前所说诸位。若未已灭设已灭而失则不成就者。此设若依无愿三摩地入正性离生灭现观四心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。空三摩地未已起灭。先已起灭者。由得果转根故失无相现在前。若成就过去空彼过去现在无相耶。答有成就过去空非过去现在无相。有及过去非现在。有及现在非过去有及过去现在成就过去空。非过去现在无相者。谓空已灭不失无相未已灭设已灭而失不现在前。问此说在何位。答此说依空三摩地入正性离生苦现观三心顷。集现观四心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。空三摩地已起灭不失。无相未已起灭。先已起灭者。由得果转根故失亦不现在前。及过去非现在者。谓空无相已灭不失无相不现在前。问此说在何位。答此说依空三摩地入正性离生道现观三心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。空无相已起灭不失。无相不现在前。及现在非过去者谓空已灭不失无相现在前。未已灭设已灭而失。问此说在何位。答此说依空三摩地入正性离生灭现观一心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。空三摩地已起灭不失。无相未已起灭。先已起灭者。由得果转根故失无相现在前。及过去现在者谓空无相已灭不失无相现在前。问此说在何位。答此说依空三摩地入正性离生灭现观三心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。空无相已起灭不失无相现在前。设成就过去现在无相彼过去空耶。答若已灭不失则成就。若未已灭设已灭而失则不成就。问此说在何位。答若已灭不失则成就者。此说即前所说诸位。若未已灭设已灭而失则不成就者。此说依无愿三摩地入正性离生灭现观三心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。空三摩地未已起灭。先已起灭者由得果转根故失。无相已起灭不失亦现在前。若成就过去空彼未来现在无相耶。答有成就过去空非未来现在无相。有及未来非现在。有及未来现在。成就过去空非未来现在。无相者。谓空已灭不失未得无相。与已得相违说名未得。即灭法智忍未已生时。问此说齐何位。答此说依空三摩地入正性离生苦现观三心顷。集现观四心顷非余位。以彼必成就未来无相故。及未来非现在者。谓空已灭不失。已得无相不现在前。问此说在何位。答此说依空三摩地入正性离生。道现观三心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。空三摩地已起灭不失。无相不现在前。及未来现在者。谓空已灭不失无相现在前。问此说在何位。答此说依空三摩地入正性离生灭现观四心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。空三摩地已起灭不失。无相现在前。但成就现在必成就未来故不别说。设成就未来现在无相彼过去空耶。答若已灭不失则成就。若未已灭设已灭而失则不成就。问此说在何位。答若已灭不失则成就者此说即前所说诸位。若未已灭设已灭而失则不成就者。此说依无愿三摩地入正性离生灭现观四心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。空三摩地未已起灭。先已起灭者由得果转根故失。无相现在前。若成就过去空彼过去未来无相耶。答有成就过去空非过去未来无相。有及未来非过去。有及过去未来成就过去空。非过去未来无相者。谓空已灭不失未得无相。问此说在何位。答此说依空三摩地入正性离生苦现观三心顷。集现观四心顷。及未来非过去者谓空已灭不失。已得无相未已灭设已灭而失。问此说在何位。答此说依空三摩地入正性离生灭现观一心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。空三摩地已起灭不失。无相未已起灭先已起者由得果转根故失。及过去未来者谓空无相已灭不失。问此说在何位。答此说依空三摩地入正性离生灭道现观各三心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。空无相已起灭不失。设成就过去未来无相彼过去空耶。答若已灭不失则成就。若未已灭设已灭而失则不成就。问此说在何位。答若已灭不失则成就者。此说即前所说诸位。若未已灭设已灭而失则不成就者。此说依无愿三摩地入正性离生灭道现观各三心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。无相已起灭不失。空未已起灭先已起灭者由得果转根故失。若成就过去空彼过去未来现在无相耶。答有成就过去空非过去未来现在无相。有及未来非过去现在。有及未来现在非过去。有及过去未来非现在。有及过去未来现在。成就过去空。非过去未来现在无相者。谓空已灭不失未得无相。问此说在何位。答此说依空三摩地入正性离生苦现观三心顷。集现观四心顷。及未来非过去现在者。谓空已灭不失已得无相未已灭。设已灭而失不现在前。问此说在何位。答此说若得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。空三摩地已起灭不失。无相三摩地未已起灭。先已起灭者由得果转根故失。亦不现在前。及未来现在非过去者。谓空已灭不失。无相现在前未已灭设已灭而失。问此说在何位。答此说依空三摩地入正性离生灭现观一心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。空三摩地已起灭不失。无相未已起灭先已起灭者。由得果转根故失而现在前。及过去未来非现在者。谓空无相已灭不失无相不现在前。问此说在何位。答此说依空三摩地入正性离生道现观三心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。空无相已起灭不失。无相不现在前。及过去未来现在者。谓空无相已灭不失。无相现在前。问此说在何位。答此说依空三摩地入正性离生灭现观三心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。空无相已起灭不失。无相现在前。设成就过去未来现在无相彼过去空耶。答若已灭不失则成就。若未已灭设已灭而失则不成就。问此说在何位。答若已灭不失则成就者。此说即前所说诸位。若未已灭。设已灭而失则不成就者。此说若依无愿三摩地入正性离生灭现观三心顷。及得预流果乃至阿罗汉果。若信胜解练根作见至。时解脱练根作不动。无相已起灭不失亦现在前。空未已起灭先已起灭者。由得果练根故失。如空对无相作七句。应知无愿对无相亦尔。随其所应尽当知。如小七应知大七亦尔。差别者以二对一。如以过去空无愿对过去无相有七。有说。此是大七种性故不应言对过去无相。所以者何。此但是一句故应作是说。如以过去空无愿对无相有七。以此中具有七句故。有说。此中不应言有七。所以者何。此但是大七种性故。应作是说。如以过去空无愿对过去无相。次对未来。次对现在。次对过去现在。次对未来现在。次对过去未来。后对过去未来现在

无相有七以此中有一七句问。一七句答故。有说。此中所说显于初句即有七句。所以者何。此中有七七句问七七句答。故如以过去空无愿对过去无相作初句。次对未来。次对现在。次对过去现在。次对未来现在。次对过去未来。后对过去未来现在。无相为第七句。复以过去空无愿对未来无相作初句。次对现在乃至后对过去无相为第七句。复以过去空无愿对现在无相作初句。次对过去乃至后对未来无相为第七句。复以过去空无愿对过去现在无相作初句。次对未来现在。乃至后对现在无相为第七句。复以过去空无愿对未来现在无相作初句。次对过去未来。乃至后对过去现在无相为第七句。复以过去空无愿对过去未来无相作初句。次对过去未来现在。乃至后对未来现在无相为第七句。复以过去空无愿。对过去未来现在无相作初句。次对过去乃至后对过去未来无相为第七七句。若作是说则唐捐其功于文无益于义无益。亦不成七七句。若欲于文有益于义有益亦成七七句者。应作是说。如以过去空无愿对过去无相作初句。次对未来。次对现在。次对过去现在。次对未来现在。次对过去未来。后对过去未来现在无相为第七句。复以未来空无愿对未来无相作初句。次对现在乃至后对过去无相为第七句。复以现在空无愿对现在无相作初句。次对过去现在乃至后对未来无相为第七句。复以过去现在空无愿对过去现在无相作初句。次对未来现在乃至后对现在无相为第七句。复以未来现在空无愿对未来现在无相作初句。次对过去未来乃至后对过去现在无相为第七句。复以过去未来空无愿对过去未来无相作初句。次对过去未来现在乃至后对未来现在无相为第七句。复以过去未来现在空无愿。对过去未来现在无相作初句。次对过去乃至后对过去未来无相为第七七句。若作是说则于文有益于义有益成七七句。应知诸七义则如是。问此中一行历六小七大七何差别。答名即差别。此名一行乃至此名大七。复次以一行道理为问名一行。以六句为问名历六。以七句为问以一问一名小七。以七句为问以二问一名大七。复次问不相似法不以世定名一行。问相似法以世定名历六。问不相似法以世定。以一问一名小七。问不相似法以世定以二问一名大七。一行历六小七大七是谓差别

说一切有部发智大毗婆沙论卷第一百八十四阿毗达磨大毗婆沙论卷第一百八十五

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    定蕴第七中一行纳息第五之三

若修空彼无愿耶。乃至广说。问何故作此论。答为止拨无去来二世。及说无未来修者意。欲显有去来世亦有未来修故作斯论。修有四种。一得修。二习修。三对治修。四除遣修。此中依二修作论。谓得修习修。若修空彼无愿耶。设修无愿彼空耶。答应作四句。有修空非无愿。谓已得空现在前。此是佛或独觉声闻为现法乐住等故。起已得空三摩地现在前。尔时彼势力尚不及自类无间刹那。况能修余未来功德。然现前位即是修习。有修无愿非空。谓已得无愿现在前。若未得无愿现在前不修空。已得无愿现在前者。如前释。未得无愿现在前不修空者。谓见道中集现观四心顷。道现观三心顷。以见道中对治决定及是不共对治故。不异谛修有俱修。谓未得空现在前。若未得无愿现在前修空。若未得无相及未得世俗智现在前修空。无愿未得空现在前者。谓依空三摩地入正性离生苦现观四心顷。若依空三摩地离欲界乃至无所有处染。或以空为加行彼一切加行无间解脱道。及离非想非非想处染。除最后解脱道。若依空三摩地信胜解练根作见至。或以空为加行彼加行无间解脱道。及时解脱练根作不动。除最后解脱道。若依空三摩地杂修静虑初后心顷。若依空三摩地起念住无色解脱义辩二无碍解。有说。唯义无碍解于如是时未得空现在前。亦修无愿未得无愿现在前。修空者谓依无愿三摩地入正性离生。苦现观四心顷道类智时。若依无愿离欲界乃至非想非非想处染。或无愿为加行。彼一切加行无间解脱道。若依无愿信胜解练根作见至。时解脱练根作不动。或无愿为加行。彼一切加行无间解脱道。若依无愿杂修静虑初后心顷。若起无漏他心智通。若依无愿起念住无色解脱义辩二无碍解。于如是时未得无愿现在前亦修空未得无相现在前。修空无愿者见道中无于修道无学道中。若依无相离欲界乃至无所有处染。或无相为加行彼一切加行无间解脱道。及离非想非非想处染。除最后解脱道。若依无相信胜解练根作见至。或无相为加行彼一切加行无间解脱道及时解脱练根作不动。除最后解脱道。若依无相杂修静虑初后心顷。若依无相起念住无色解脱义无碍解。于如是时未得无相现在前。修空无愿。未得世俗智现在前修空无愿者。谓圣者以世俗道离欲界乃至无所有处染。或世俗道为加行彼一切加行无间解脱道。及离非想非非想处染。及信胜解练根作见至。时解脱练根作不动。以世俗为加行彼加行道杂修静虑中间心顷引发五通诸加行道。五无间道二解脱道。及有漏他心智通解脱道。起无量世俗解脱胜处遍处不净观持息念。世俗念住七处善三义观世俗无碍解无诤愿智边际智。空空无愿无愿无相无相入灭定想微细心。于如是时未得世俗智现在前。修空及无愿有俱不修。谓已得无相现在前。若未得无相现在前不修空无愿。若已得世俗智现在前。若未得世俗智现在前不修空无愿。一切异生染污心无记心在无想定灭尽定。生无想天已得无相现在前者如前释。未得无相现在前不修空无愿者。谓见道中灭现观四心顷。不修空无愿如前释。已得世俗智现在前者如前释。未得世俗智现在前不修空无愿者。谓圣者闻思所成慧入灭定微微心。一切异生者谓此中所说三三摩地唯无漏故。异生皆无故无修义。染污心者谓染污心是顺退分性。沉重懈怠相应。要顺胜进性轻举精进相应心方能修故。无记心者谓无记心不坚不住不实羸劣如朽败种。要坚住实强盛心。方能修故。在无想定灭尽定者。谓彼无心。要有心位方能修故。生无想天者。有说。生彼于一切时不起善心。有说。生彼虽起善心而非修所依。虽前已遮一切异生。而复遮无想定。无想天者以彼是世俗所尚。或疑有修故于如是时不修空及无愿

若修空彼无相耶。设修无相彼空耶。答应作四句。有修空非无相。谓已得空现在前。若未得空现在前不修无相。若未得无愿现在前修空非无相。已得空现在前者如前释。未得空现在前不修无相者。谓依空三摩地入正性离生苦现观四心顷。未得无愿现在前。修空非无相者。谓依无愿入正性离生苦现观四心顷。有修无相非空。谓已得无相现在前。若未得无相现在前不修空。已得无相现在前者如前释。未得无相现在前不修空者。谓见道中灭现观四心顷。有俱修谓未得空现在前修无相。若未得无相现在前修空。若未得无愿及未得世俗智现在前修空无相。未得空现在前修无相者。谓依空三摩地离欲界乃至无所有处染。广如前兼修无愿说。未得无相现在前修空者。谓依无相三摩地离欲界乃至无所有处染。或无相为加行彼一切加行无间解脱道。及离非想非非想处染。除最后解脱道。若依无相练根作见至。以无相为加行彼加行无间解脱道。及时解脱练根作不动。除最后解脱道。若依无相杂修静虑初后心顷。若依无相起念住无色解脱义无碍解。于如是时未得无相现在前亦修空。未得无愿现在前修空无相者。谓道类智时。若依无愿三摩地离欲界乃至非想非非想处染。广如前兼修空说。未得世俗智现在前修空无相者。谓圣者以世俗道离欲界乃至无所有处染。广如前兼修空无愿说。有俱不修。谓已得无愿现在前。若未得无愿现在前不修空无相。若已得世俗智现在前。若未得世俗智现在前不修空无相。一切异生染污心无记心在无想定灭尽定。生无想天已得无愿现在前者如前释。未得无愿现在前不修空无相者。谓见道中集现观四心顷。道现观三心顷。已得世俗智现在前者如前释。未得世俗智现在前不修空无相者。谓圣者闻思所成慧入灭定微微心。一切异生乃至生无想天者如前释

若修无愿彼无相耶。设修无相彼无愿耶。答应作四句。有修无愿非无相。谓已得无愿现在前。若未得无愿及未得空现在前不修无相。已得无愿现在前者如前释。未得无愿现在前不修无相者。谓依无愿入正性离生苦现观四心顷。集现观四心顷。道现观三心顷。未得空现在前不修无相者。谓依空三摩地入正性离生苦现观四心顷。有修无相非无愿。谓已得无相现在前。若未得无相现在前不修无愿。已得无相现在前者如前释。未得无相现在前不修无愿者。谓见道中灭现观四心顷。有俱修谓未得无愿现在前修无相。若未得无相现在前修无愿。若未得空及未得世俗智现在前修无愿无相。此随所应如前广释。有俱不修。谓已得空及已得世俗智现在前。若未得世俗智现在前不修无愿无相。一切异生染污心无记心。在无想定灭尽定生无想天。此亦随应如前广释

颇有结空所断非无愿无相耶。乃至广说。有二种决定。一对治决定。二作用决定。此中依对治决定而作论非作用决定。所以者何。无有道理。二三摩地俱时作用。何况有三。颇有结空所断非无愿无相耶。答无。以无如是类结唯是空所对治故。颇有结无愿所断非空无相耶。答有。谓见集见道所断结无愿断。以彼唯是无愿所对治故。颇有结无相所断非空无愿耶。答有。谓见灭所断结无相断。以彼唯是无相所对治故。颇有结空无愿所断非无相耶。答有谓见苦所断结空无愿断。以彼唯是空无愿所对治故颇有结空无相所断非无愿耶。答无以无如是类结唯是空无相所对治非无愿故。颇有结无愿无相所断非空耶。答无。以无如是类结唯是无愿无相所对治非空故。颇有结空无愿无相所断耶。答有。谓学见迹修所断结。空无愿无相断即是圣者三界修所断结。以彼是三三摩地所对治故。颇有结非空无愿无相所断。而是所断耶。答有。谓异生所断结。即诸异生欲界乃至无所有处见修所断结。是世俗道所对治故。问彼结岂非空无愿无相所对治耶。答是所对治。然在圣者非异生。彼在异生故说非空等断。有说。前依对治决定而作论。今依作用决定作论。异生相续中三三摩地定无作用故。说彼结非空等断。问若尔者。圣相续中欲界乃至无所有处。修所断结亦世俗道断。何故但说空等断耶。答前文应说彼结亦是世俗道断。而不说者有何意耶。应知圣者无漏道所显故不说世俗道。异生无无漏道故依世俗道说。是以前说无过

云何作意入正性离生。乃至广说。问何故作此论。答欲止他宗显己义故。谓或有说。三三摩地随一皆能入正性离生。今遮彼意显唯二三摩地随一能入。而非无相故作斯论。或复有说。唯无相三摩地能入正性离生。如达摩鞠多部说。彼说以无相三摩地于涅槃起寂静作意入正性离生。为遮彼执显唯无相三摩地不能入正性离生故作斯论。云何作意入正性离生。答或无常或苦或空或无我。由此则止三三摩地及唯无相。能入正性离生者意。此中无常苦作意与无愿三摩地相应。空无我作意与空三摩地相应。问何故唯此行相入正性离生非余耶。答入正性离生者有二种。一爱行。二见行。爱行者依无愿入见行者依空入。菩萨虽是爱行而能依空入正性离生。爱行者复有二种。谓我慢增。懈怠增。我慢增者以无常行相入。懈怠增者以苦行相入。见行者亦有二种。谓我见增。我所见增。我见增者以无我行相入。我所见增者以空行相入。是故唯作此四行相。问此四行相与何位法相应。有说。与世第一法相应。以说入正性离生故。有说。与苦法智忍相应。问若尔。何故言入。答此说已入名入。于近说远声。如言大王从何处来。彼于已来名来。此亦如是。问尔时亦有余心所法。何故但说作意耶。答以唯作意能引发心心所故。有说。作意于入正性离生最随顺故

思惟何系行入正性离生。乃至广说。问何故作此论。答欲止尊者达磨怛逻多说顿思惟三界行入正性离生。又为止说思惟涅槃入正性离生者意故作斯论。问思惟何系行入正性离生。答欲界系。由此则止如前二执。问何故但思惟欲界系行入正性离生耶。答欲界苦粗显现见易观察故。有说。欲界苦是彼相续现成就故。有说。欲界系行具三苦故。是以阿毗达磨者。说观三苦诸行入正性离生。非如譬喻者唯说观行苦诸行入正性离生。此中不可意诸行名苦苦。可意诸行名坏苦。顺舍诸行名行苦。有说。欲界苦于修行者现为逼恼极所厌背故。先观彼入正性离生。问涅槃亦是极所欣乐。何不观彼入正性离生耶。答诸有情类厌苦心胜非欣涅槃。所以者何。现逼恼故。不现见故。如诸有情无不畏苦有不贪乐。问缘何谛忍后能入正性离生。有说。缘道谛。如是说者。缘苦谛。广说如杂蕴初纳息

尽智当言于身循身观念住耶。乃至当言于法循法观念住耶。答尽智应言或于身循身观念住。或于受或于心或于法循法观念住。如尽智无生智亦尔。问何故作此论。答为令疑者得决定故。谓有生如是疑。尽无生智非见性故。亦应非念住性。今欲决定明此二智。虽非见性。而是念住故作斯论。复次见蕴中分别见自性念住。今定蕴中分别非见自性念住。故作斯论。复次加行地中说修念住有因此故。谓无学地无有念住。今欲明无学地中有念住故而作此论。复次经说尽无生智。缘生及后有为境。有因此故。谓彼但缘生及后有。今欲显彼缘一切法。唯除虚空及非择灭。故作斯论。复次有执。尽无生智唯总缘五蕴。今遮彼意显尽无生智。或总缘五蕴或复别缘。故为此论。尽智应言或于身循身观念住者谓缘色蕴。或于受循受观念住者谓缘受蕴。或于心循心观念住者谓缘识蕴。或于法循法观念住者谓缘想蕴行蕴及择灭。此说不杂缘法念住。若杂缘法念住则于五蕴。或二二缘。或三三缘。或四四缘。或五总缘。二二缘者谓色受缘。色想缘色行缘。色识缘。受想缘。受行缘。受识缘。想行缘。想识缘。行识缘。三三缘者。谓色受想缘。色受行缘。色受识缘。色想识缘。色行识缘。受想行缘。受想识缘。受行识缘。想行识缘。四四缘者。谓色受想行缘。色受想识缘。色受行识缘。色想行识缘。受想行识缘。或五总缘者。谓色受想行识一切总缘。其择灭无为若有漏法念住。亦与色等余法合缘。此中所说是无漏故唯不杂缘。诸无漏初静虑乐诸轻安等觉支乐。此何差别。答无差别。诸无漏第二静虑乐。诸轻安等觉支乐。此何差别答无差别。问何故作此论。答为止说初二静虑有无漏乐根者意。显彼二地无无漏乐根故作斯论。若有者不应答言此无差别。所以者何。轻安等觉支乐。大善地法中轻安为自性。无漏乐根大地法中受为自性故。又轻安等觉支乐行蕴摄。无漏乐根受蕴摄。如是二乐便有差别。而说无差别。故知彼二地无漏乐者即轻安乐。是故无漏乐根非彼地所有。若从等持出彼所缘耶。乃至广说出有五种。一地二行相三所缘四异类心五刹那。此中但依二出作论。谓地所缘。若从等持出彼所缘耶。设从所缘出彼等持耶。答应作四句。有从等持出非所缘。谓如有一思惟此相入初静虑。彼复思惟此相入第二静虑。此中所缘以相声说。如缘色蕴初静虑等无间缘色蕴。第二静虑现在前。缘余蕴亦尔。是名从等持出非所缘。问第二静虑亦是等持。何故言出。答以地别故。是故前说依二出作论。谓地所缘。有从所缘出非等持。谓如有一思惟此相入初静虑。彼不出初静虑。复思惟余相如缘色蕴。初静虑等无间缘受蕴初静虑现在前。缘余蕴亦尔。是名从所缘出非等持。有从等持出亦所缘。谓如有一思惟此相入初静虑。彼思惟余相入第二静虑。如缘色蕴。初静虑等无间缘受蕴。第二静虑现在前。缘余蕴亦尔。是名从等持出亦所缘。有非从等持出亦非所缘。谓如有一思惟此相入初静虑。住经多时如缘色蕴。初静虑流注相续多时现前。缘余蕴亦尔。如蕴非蕴亦尔。如初静虑乃至无所有处亦尔。复有别义。若从等持出彼行相耶。答应作四句。有从等持出非行相。谓如有一以此行相入初静虑。彼复以此行相入第二静虑。如无常行相。初静虑等无间无常行相第二静虑现在前。余行相亦尔。有从行相出非等持。谓如有一以此行相入初静虑。彼不出初静虑复作余行相。如无常行相初静虑等无间苦行相初静虑现在前。余行相亦尔。有从等持出亦行相。谓如有一以此行相入初静虑。以余行相入第二静虑。如无常行相初静虑等无间苦行相第二静虑现在前余行相亦尔。有非从等持出亦非行相。谓如有一以此行相入初静虑住经多时。如无常行相初静虑流注相续多时现前。余行相亦尔。如初静虑乃至无所有处亦尔。复有别义。若从行相出彼所缘耶。答应作四句。有从行相出非所缘。谓如有一以此行相思惟此相。彼不舍此相复作余行相。如缘色蕴无常行相等无间缘色蕴苦行相现在前。缘余蕴余行相亦尔。有从所缘出非行相。谓如有一以此行相思惟此相。即以此行相复思惟余相。如缘色蕴无常行相等无间缘受蕴无常行相。现在前。缘余蕴余行相亦尔。有从行相出亦所缘。谓如有一以此行相思惟此相。复以余行相思惟余相。如缘色蕴无常行相等无间缘受蕴苦行相现在前。缘余蕴余行相亦尔。有非从行相出亦非所缘。谓如有一以此行相思惟此相住经多时。如缘色蕴无常行相流注相续多时现前。缘余蕴余行相亦尔。如蕴非蕴亦尔

如说苾刍乃至想定能达圣旨。世尊弟子生非想非非想处。彼依何定得阿罗汉果。答无所有处。问何故作此论。答欲令疑者得决定故。如契经说。有七依定。我说依彼能尽诸漏。谓初静虑乃至无所有处。又契经说。苾刍乃至想定能达圣旨。想定者。谓四静虑三无色。能达圣旨者。谓能起智断烦恼修道尽漏。或有生如是疑。非想非非想处既无圣道。若世尊弟子生彼处者。依何能尽诸漏。将无彼类不由圣道得阿罗汉耶。为令此疑得决定故。说彼依无所有处得阿罗汉果。复次为止分别论者说齐有顶阿罗汉故。彼说世尊弟子生非想非非想处。于命终时烦恼业命三事俱尽。不由圣道得阿罗汉果。为止彼意显尽非俱必由圣道。故作斯论。问何故但说依无所有处。非余地耶。答此于有顶最邻近故。问生下诸地亦有邻近。下地无漏何故不说依之尽漏。而但说生有顶者耶。答下诸地中有自地惑上地圣道易可现前非于下地。所以者何。下地系善皆已舍故圣道难起。由此无有起现前者。生有顶不尔。自地无圣道。又无上地可依不可不由圣道而能尽漏。是故下地虽难而起。然彼圣道由因力强非加行力。暂起现前断余烦恼。得阿罗汉果已。设更住寿经八万劫。终不重起以无用故。如说尊者大目揵连言。具寿我自忆住无所有处定。闻曼陀抧尼池边有众多龙象哮吼等声。彼尊者为在定闻。为起定耶。答起定闻。非在定。问何故作此论。答为令疑者得决定故。如毗柰耶说。尊者大目揵连告诸苾刍言。具寿我自忆在鹫峰山住无所有处定。闻曼陀抧尼池边有众多龙象哮吼等声。时诸苾刍共相谓言。今此大目揵连自称得过人法必无是事。应共坏之。所以者何。住初静虑者尚不闻声。何况住无所有处定。便以此事白佛。佛时告曰。汝等不应坏大目揵连。所以者何。大目揵连如想而说。故毗柰耶虽作是说而不分别。由此或有疑。彼尊者在定闻声。欲令此疑得决定故。显彼尊者起定闻声。故作斯论。问诸余声闻亦知在定不闻声故尚无此说。况大目揵连是最胜声闻。何故乃于苾刍众中说不应说。有说。此不必须通。所以者何。此是伪毗柰耶故。谓佛灭后有于素怛缆中置伪素怛缆。毗柰耶中置伪毗柰耶。阿毗达磨中置伪阿毗达磨。诸伪文句不应通释。有说。定海甚深。声闻如兔不得其底。唯佛能尽故。彼尊者虽作是说亦无有过。问彼尊者岂不知在定不闻声耶。何故作如是说。答彼尊者于定自在入出迅疾。虽起定闻作住定想。谓彼先从欲界善心入初静虑。从初静虑入第二静虑。如是乃至入无所有处。从无所有处起还入识处。如是乃至入初静虑。从此欲界善心现前闻龙象等声不起分别。复还从欲界善心入初静虑。从初静虑入第二静虑。如是乃至入无所有处。从无所有处起还入识处。如是乃至入初静虑。从此欲界善心现前。不审分别便作是语。我自忆在无所有处定闻曼陀抧尼池。边龙象等声。彼但于二心起分别知。谓初入定心及后出定心。于其中间诸心相续。不审分别故作是说。亦无有过

说一切有部发智大毗婆沙论卷第一百八十五阿毗达磨大毗婆沙论卷第一百八十六

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    定蕴第七中一行纳息第五之四

诸不定彼一切非聪慧无明趣耶乃至广说。问何故作此论。答为欲分别契经义故。如契经说。诸有情类有定有不定。有聪慧明趣。有非聪慧无明趣。虽作是说而不分别相摄差别。彼经是此论所依根本。彼所不说者今尽应说。故作斯论。问诸不定彼一切非聪慧无明趣耶。答诸不定彼一切非聪慧无明趣。有非聪慧无明趣而非不定。谓邪定。问诸定彼一切聪慧明趣耶。答诸聪慧明趣彼一切定。有定彼非聪慧明趣。谓邪定。此中非聪慧者谓愚夫异生无圣慧故。聪慧者谓诸圣者有圣慧故。云何知然。契经说故。如契经说。佛告苾刍。于汝意云何。诸有于苦圣谛如实知。于苦集圣谛苦灭圣谛。趣苦灭行圣谛如实知。或有于此不如实知。此中说何是聪慧者。苾刍白佛。如我解佛所说义者。诸有于苦圣谛。乃至于趣苦灭行圣谛如实知名聪慧者。非不如实知。由此故知圣是聪慧异生非聪慧。聪慧者是明趣明所依故。非聪慧者是无明趣无明所依故。诸不定彼一切非聪慧。无明趣者谓诸不定必是异生。一切异生皆非聪慧。无明趣摄。有非聪慧无明趣而非不定。谓邪定者谓诸邪定亦必异生。彼于邪性定故不名不定。诸聪慧明趣彼一切定者。谓诸圣者于正性定故说名为定

诸不定彼一切不成就等觉支耶。答诸不定彼一切不成就等觉支。有不成就等觉支而非不定。谓邪定是异生故邪性定故。诸定彼一切成就等觉支耶。答诸成就等觉支彼一切定。有定而不成就等觉支。谓邪定如前释。有三聚。一邪性定聚。二正性定聚。三不定聚邪性定聚。谓成就五无间业。正性定聚谓成就学无学法。不定聚谓唯成就余有漏法及无为。是名三聚自性。界者邪性定聚一界少分。谓欲界。正性定聚三界少分。不定聚亦尔。趣者邪性定聚一趣少分。谓人。正性定聚二趣少分。谓人天。不定聚三趣全。谓地狱傍生饿鬼。二趣少分。谓人天。生者邪性定聚一生少分。谓胎生。正性定聚二生少分。谓胎生化生。不定聚二生全。谓卵生湿生。二生少分。谓余二生。有说。邪性定聚三生少分。除化生。正性定聚四生少分不定聚亦尔。处者有说。邪性定聚三处少分。正性定聚五处全。二十四处少分。不定聚五处全。二十四处少分。如是说者。诸行有四十处。不定聚十一处全。二十四处少分。譬喻者说。从无间地狱乃至有顶皆有三聚。彼说般涅槃法名正性定聚。不般涅槃法名邪性定聚。不决定者名不定聚。评曰。如前说者好。此依集异门说。若依施设论说。邪性定聚谓五无间业。若彼因彼果彼等流彼异熟及成就彼法补特伽罗。正性定聚谓学无学法。若彼因彼果彼等流。及成就彼法补特伽罗。不定聚谓诸余法。若彼因彼果。彼等流彼异熟。及成就彼法补特伽罗。是名三聚自性。界者如前说。趣者邪性定聚二趣少分。谓地狱及人。正性定聚亦二趣少分。谓人天。不定聚二趣全。谓傍生饿鬼。三趣少分。谓地狱人天。生者邪性定聚二生少分。谓胎生化生。正性定聚四生少分。不定聚亦尔。处所分别如应当知。毗奈耶说。世尊于菩提树下建立一切有情为三聚。谓齐尔许名邪定聚。齐尔许名正定聚。齐尔许名不定聚。问为依有情分齐建立。为依法分齐耶。若依有情者。云何非是得有情海边际耶。若依法者。声闻亦能如是建立。佛与声闻有何不共。有说。依有情建立。问若尔。云何非是得有情海边际耶。答佛得有情海边际亦无有过。然总相得非别相。谓一切有情不出四生。如是而得。有说。依法建立。问若尔。声闻亦能如是建立。佛与声闻有何不共。答声闻因从佛闻。佛无师自能建立。是为不共。有说。若三千世界及千岁以来依有情建立。若余世界及余时依法建立。问若佛于菩提树下已建立有情为三聚者。何故复言昼夜六时以佛眼观世间耶。答先虽建立三聚。而未观分位差别。谁于何时从邪定聚入不定聚。谁于何时从不定聚入邪定聚或正定聚。欲知此故复以佛眼昼夜观察。有说。欲显佛于一切时分恒乐思惟利他事故。有说。欲显世尊大悲熏心无懈倦故。尊者世友说曰。有诸有情数数从余世界来生此土。由先未建立故。今以佛眼观之重为建立。尊者觉天说曰。佛以法为师。欲恭敬承事法故。昼夜六时以佛眼观察世间。尊者妙音说曰。佛欲显己所作审谛故。虽建立而复观察

诸成就等觉支。彼成就无漏法耶。答诸成就等觉支彼成就无漏法。以等觉支是无漏故。有成就无漏法非等觉支。谓诸异生。以诸异生皆成就非择灭。随离何品染亦成就择灭故。诸不成就等觉支。彼不成就无漏法耶。答无不成就无漏法。以必成就非择灭故。有不成就等觉支。谓诸异生。以诸异生必不成就有为无漏法故

诸得等觉支彼得无漏法耶。答诸得等觉支彼得无漏法。有得无漏法非等觉支。谓诸异生。问等觉支言得。是事可尔。入正性离生时未曾得而得故。无漏法云何言得。无有本来不成就非择灭故。有说。此文但应言得等觉支。不应言得无漏法。有说。此中无漏法有二品。一觉支二择灭。入正性离生时得觉支。随离何品染时得择灭。异生于八地见修所断随离何品皆得择灭。故作是说。有说。此中无漏法有三品。一觉支二择灭三非择灭。入正性离生时得觉支。随离何品染时得择灭。随于何时得非择灭。问岂不异生本皆成就非择灭耶。何故言得。答虽本成就而依胜进位中亦可言得。如或以施。或以戒。或以闻。或以思。或以不净观持息念念住。或以暖顶忍世第一法等故。令恶趣等法得非择灭。复次若以种类言之不应言得。若以事差别言之亦可言得。刹那刹那随彼彼事各别得故。诸舍等觉支彼舍无漏法耶。答无全舍等觉支。亦无全舍无漏法。必无圣者还为异生故。亦无有情不成就非择灭故。然非不有随分舍义故言无全舍。诸退等觉支彼退无漏法耶。答无全退等觉支。亦无全退无漏法。义如前释。复次为止摩诃僧祇部说预流果有退。及止譬喻者不许有非择灭法。故作是说。无全舍全退等觉支及无漏法。诸未断彼未遍知耶。乃至广说。此中依二种遍知作论。一智遍知。二断遍知。于智遍知中。有说。唯无漏智。有说。通有漏无漏智。诸说唯无漏智者。彼说苦现观时于五所断法由智遍知故名遍知。于见苦所断法由断遍知故名断。集现观时亦尔。差别者说自谛。灭现观时于灭谛由智遍知故名遍知。于见灭所断法由断遍知故名断。道现观时亦尔。差别者说自谛。修道中随起何智于随何所缘法。由智遍知故名遍知。于随何所断法。由断遍知故名断。是谓此处略毗婆沙。诸未断彼未遍知耶。答诸未遍知彼未断。要由智知乃能断故。有未断非未遍知。谓苦智遍知故已遍知。非断遍知故已断此谓苦智已生集智未生。于四所断法由智遍知故已遍知。非断遍知故已断。集智已生灭智未生。于三所断法灭智已生道智未生。于二所断法道智已生未离修所断染。于一所断法由智遍知故已遍知。非断遍知故已断。即彼已离欲界染未离上染。于色无色界修所断法已离色染未离上染。于无色界修所断法由智遍知故已遍知。非断遍知故已断。诸已断彼已遍知耶。答诸已断彼已遍知。谓苦智已生集智未生。于一所断法由智遍知故已遍知。断遍知故已断。集智已生灭智未生。于二所断法灭智已生道智未生。于三所断法道智已生未离修所断染。于四所断法由智遍知故已遍知。断遍知故已断。即彼已离欲界染未离上染。于三界见所断。及欲界修所断法。已离色界染未离上染。于三界见所断。及欲色界修所断法尽智已生。于三界见修所断法由智遍知故已遍知。断遍知故已断。有已遍知非已断。谓若智遍知故已遍知。非断遍知故已断此。谓苦智已生集智未生。于四所断法等广说如上。诸说智遍知通有漏无漏智者。彼说顺决择分善根位。于五所断法由智遍知故名遍知。非断遍知故名断。见道修道位如前说

问岂不念住位中于一切法已名遍知耶。答虽亦名遍知而非胜进。此中说胜进者。若行相与圣道同者名胜进。有说。若闻所成思所成修所成慧。若暖顶忍世第一法。于有漏事遍知自相共相故皆名智遍知。是谓此处略毗婆沙。诸未断彼未遍知耶。答诸未遍知彼未断。以先于彼得智遍知后方于彼断遍知故。有未断非未遍知。谓若智遍知故已遍知。非断遍知故已断。此谓顺决择分善根已生见道未生。于五所断法由智遍知故已遍知。非断遍知故已断。余广说如上。诸已断彼已遍知耶。答诸已断彼已遍知。此如前释。有已遍知非已断。谓若智遍知故已遍知。非断遍知故已断。此谓顺决择分善根已生等。广说如上。异生虽有断而非断遍知。是故不说。以非智遍知所证故。智遍知者唯圣行相故

诸有此生眼不见色。彼依何法引发天眼耶。乃至广说。问何故作此论。答欲令疑者得决定故。如施设论说。死生智证通云何加行。云何引发死生智证通。谓初修业者于世俗三摩地。已善修习善得自在令起现前。为欲引发天眼通故。先取净镜面相。或日月轮星宫药草灯烛末尼诸光明相。或大火聚烧诸城邑多踰缮那焰洞然相。取是相已由假想作意力。于不见位能起光明。胜解相续引发天眼。有时即于常眼处所有色界大种所造。净天眼起能见众色若好若恶。乃至广说。或有生如是疑。诸有此生眼不见色。彼便不能引天眼耶。为令此疑得决定故。显虽此生眼不见色而彼亦能引发天眼。故作斯论。又施设论说。天耳智证通云何加行。云何引发天耳智证通。谓初修业者于世俗三摩地。已善修习善得自在令起现前。为欲引发天耳通故先取象马车声。或钟鼓蠡贝箫笛歌咏赞诵等声。或四大聚互相扣击所发音声。善取如是诸声相已。由假想作意力于离闻时能起诸声。胜解相续引发天耳。有时即于常耳处。所有色界大种所造净天耳起。能闻众声或人非人。乃至广说。由此复有生如是疑。诸有此生耳不闻声。彼应不能引发天耳。欲令此疑得决定故。显虽此生耳不闻声。而彼亦能引发天耳。故作斯论。诸有此生眼不见色。彼依何法引发天眼耶。答如有一得自性生念。先余生中眼曾见色。彼依此故引发天眼。诸有此生耳不闻声。彼依何法引发天耳耶。答如有一得自性生念。先余生中耳曾闻声。彼依此故引发天耳。问诸有获得宿住随念智者。亦能引发天眼天耳此中何故不说。答应说而不说者。当知此义有余。有说。若于生盲者天眼生聋者天耳俱能引发者此中说之。宿住随念智。唯能引发彼类天眼非天耳。所以者何。诸生聋者无宿住随念智故。要由他教此智生故。是以不说

问何故天眼唯在四根本静虑非近分地耶。答非其田非其器。乃至广说。复次若地有通所依三摩地则有天眼。近分地无通所依三摩地故无天眼。复次若地有支所摄三摩地则有天眼。近分地不尔。有说。若地有乐通行道则有天眼。近分地不尔。如是天眼或说唯一。谓天眼。或说二。谓曾得未曾得。或说三。谓软中上。或说四。谓四静虑果。或说六。谓软中上各有曾得未曾得。或说八。谓四静虑果各有曾得未曾得。或说九。谓软软乃至上上。或说十二。谓四静虑果各有软中上。或说十八。谓软软乃至上上各有曾得未曾得。或说二十四。谓四静虑各有前六。或说三十二。谓十六生得。及十六修得。有说。四静虑果各有软中上为十二。复各有五品杂修静虑果为二十。是谓三十二。或说三十六。谓四静虑果各有软软乃至上上。或说七十二。谓四静虑各有前十八。若以相续及刹那则有无量。今但总说一天眼。如天眼天耳亦尔。问何故有不同分天眼耳现在前。而无不同分天鼻舌身现在前耶。答眼耳二根取不至境。欲远见远闻故起不同分天眼耳现前。鼻舌身根唯取至境。于不同分无别用故不起现前。有说。若起不同分鼻舌二根现在前者。则世所嗤诮。云何此人重鼻两舌。若有不同分身根现在前者。世亦嗤诮。云何此人如双生者有两身耶。是故鼻等无不同分。又天眼左右胜劣品类必同。谓非左劣右胜等。又现前时必皆具足。无瞎无阙亦无眩乱及彼同分。余如根蕴触纳息中广说

问何故异生退时见修所断结增益。世尊弟子退时唯修所断结增益耶。答异生用此道断见所断结。即用此道断修所断结故。彼退时二结俱增益。世尊弟子用此道断见所断结。彼于此道定不退。用余道断修所断结。彼于余道有退有不退。世尊弟子设用此道断见所断结。即用此道断修所断结者彼亦无退。何故作此论。答为止拨无退性者意。显实有退故作斯论。此中诸得以增益名说积集生。故有处说得。名为近生近彼法生故。如施设论说。异生欲贪随眠起时有五法起。一者欲贪随眠。二者欲贪随眠近生。三者无明随眠。四者无明随眠近生。五者掉举。此中异生用此道断见所断结。即用此道断修所断结者。谓用九品道俱时断见修所断结故。彼退时二结得俱起。世尊弟子用此道断见所断结者。谓用一品道断见所断结。彼于此道定不退。用余道断修所断结者。谓用九品道断修所断结。彼于余道有退有不退。世尊弟子设用此道断见所断结。即用此道断修所断结者彼亦无退者。谓设用一品道俱时断见修所断结者彼亦无退。以世尊。弟子见所断结必不退故。不可俱断而别退故。又佛弟子先异生时用九品道俱断见修所断结。今亦不退二道所镇故。复次异生用修道俱时断见修所断结故。彼退时二结得俱起。世尊弟子用见道断见所断结。彼于此道定不退。用修道断修所断结。彼于此道有退有不退。余准前说。复次异生用智俱时断见修所断结故。彼退时二结得俱起。世尊弟子用忍断见所断结。彼于此道定不退。用智断修所断结。彼于此道有退有不退。余准前说。复次异生不观谛俱时断见修所断结故。彼退时二结得俱起。世尊弟子观谛断见所断结。彼于此道定不退。或观谛或不观谛断修所断结。彼于此道有退有不退。余准前说。复次异生用起不起道俱时断见修所断结。故彼退时二结得俱起。世尊弟子用不起道断见所断结。彼于此道定不退。用起不起道断修所断结。彼于此道有退有不退。余准前说。复次异生用不猛利道俱时断见修所断结。故彼退时二结得俱起。世尊弟子用猛利道断见所断结。彼于此道定不退。用不猛利道断修所断结。彼于此道有退有不退。余准前说。有说。异生用有漏道俱时断见修所断结。故彼退时二结得俱起。世尊弟子用无漏道断见所断结。彼于此道定不退。用有漏无漏道断修所断结。彼于此道有退有不退。然彼说用无漏道断者决定不退。问若尔。应无退阿罗汉果者。以有顶结唯无漏道断故。答若阿罗汉先以有漏道断下八地修所断结者。彼容有退。以根本不坚牢故。若先以无漏道断下八地修所断结者。彼必不退。以根本坚牢故。问何故无有退见道者耶。答以根本坚牢故。云何根本。谓求解脱者所有若施若戒若修若营佛法僧事。若给侍老病若读诵圣言。为他演说如理作意。若修不净观持息念念住三义观七处善暖顶忍世第一法。如是皆名见道根本。有说。见道猛利捷疾能以一品道断九品结。是故不退。有说。见道唯一刹那忍智现前。是故不退。有说。若见道有退即所修梵行不可保信。以退见道为异生故。问所说圣者用余道断修所断结。彼于余道有退有不退者。谁退谁不退耶。答时解脱退。不动法不退。复次钝根者退。利根者不退。复次内因力断者不退。外缘力断者退。有说。不净观为加行断者退。持息念为加行断者不退。有说。若以世俗道断下八地修所断结者有退。若以出世道断者不退。譬如台观基危可倾。牢则不尔

问何故上三果有退非预流果耶。答修所断结依有事起。谓有净相有不净相。彼由非理作意观净相时。便于不净想退。见所断结。依无事起。无有一法是我我所。可令彼观于无我见退。问何故作此论。答欲止摩诃僧祇部说预流果有退。显预流果决定无退故作斯论。修所断结依有事起者。谓所执取发毛爪等非无世间少分净相。若非理作意思惟此时便于所修不净想退。起先所断修所断结。见所断结依无事起者。谓所执取我我所相毕竟无有。故契经说。法无作用亦无有情命者养者。补特伽罗作者受者。唯集诸行中无有我。如以空拳诳诸童稚。智者了达如见舒指。是故见无我已必无有退。故无退失预流果者

退上三果时。诸所得无漏根力觉支道支。乃至广说。问何故作此论。答为止尊者设摩达多说退阿罗汉果时。唯得未来先所舍学法不得过去。所以者何。以彼毕竟不现前故。今欲显退阿罗汉果时。得过去未来先所舍学法。过去虽不可现前而可成就。由此因缘故作斯论。退上三果时诸所得无漏根力觉支道支。当言曾得得未曾得得耶。答当言曾得得。谓先得果时舍。今退时还得故。诸未曾得圣道唯胜进时得故

无色界殁生欲界时诸所得蕴界处。乃至广说。问何故作此论。答亦为遮止设摩达多说无色界殁生欲界时。唯得先所舍未来法不得过去。所以者何。以彼毕竟不现前故。今欲显无色界殁生欲界时。得过去未来先所舍法故作斯论。若不尔者从无色界殁生欲界初结生时。但应成就二世生死。然无有情但成就二世生死者。决定成就三世有漏法故。无色界殁生欲界时。诸所得蕴界处善不善无记根。结缚随眠随烦恼缠。当言曾得得未曾得得耶。答应言善染污法曾得得。异熟法未曾得得。善染污法曾得得者。善谓生得善四蕴。有说。亦得串习闻思所成四蕴。此诸善法先由越界地故舍。今界地来还故得染污。谓不善有覆无记四蕴此染污法。先由离染故舍。今界地来还故得。问威仪路工巧处四蕴串习者亦应得。何故不说。答应说而不说者。当知此义有余。有说。无覆无记法中多分不得。谓异熟生通果全及余少分。故虽少得而亦不说。有余师说。串习者亦不得。以羸劣故。异熟法未曾得得者。谓无始来未曾得唯现在成就故。问长养诸蕴亦未曾得得何故不说耶。答应说而不说者。当知此义有余。复次若说异熟应知亦已说长养。以长养防护异熟。如人重人。如墙重墙。必相随故。尔时亦有等流法未曾得得。如异生性等以少故不说。无色界殁生色界时诸所得蕴界处。善无记。根结缚随眠随烦恼缠。当言曾得得未曾得得耶。答应言善染污法曾得得。异熟法未曾得得。善染污法曾得得者。善谓生得善四蕴。加行善五蕴。此诸善法先由越界地故舍。今界地来还故得。染污谓有覆无记四蕴。此染污法先由离染故舍。今界地来还故得。无覆无记法中通果四蕴亦曾得得。以少故不说。长养及等流如前释。色界殁生欲界时诸所得蕴界处等。如无色界殁生欲界说。此中解释亦如前应知

依初静虑引发神境通道时。彼极远至何处耶。答乃至梵世。依初静虑引发天耳通道时。彼极远闻何系声耶。答乃至梵世。依初静虑引发他心通道时。彼极远知何系心心所法耶。答乃至梵世。依初静虑引发宿住随念通道时。彼极远忆何系宿住事耶。答乃至梵世。依初静虑引发天眼通道时。彼极远见何系色耶。答乃至梵世。如依初静虑乃至依第四静虑。各随自处广说亦尔。问何故作此论。答欲令疑者得决定故。如素怛缆毗奈耶说。具神通者乃至梵世身自在转。或有生如是疑。神通自在但至梵世非至上地。欲令此疑得决定故。说乃至依第四静虑所起神通。乃至广果或色究竟身自在转故作斯论。问若尔。素怛缆毗奈耶说当云何通。答若处有自地身表者。世尊说之。第二静虑以上无自地身表。是以不说。有说。彼中佛说最初所得上地非初所得。有说。梵世言摄四静虑以皆有支所摄受清净三摩地故。问乃至初静虑有语表故。依初静虑发天耳闻彼声上地既无语表。依第二静虑等引发天耳闻何等声耶。答如生初静虑者依初静虑语表业等起心发语。如是生上三静虑者亦依初静虑语表业等起心发语。即是彼地天耳所闻。有说。上地虽无语表声。而有余声是彼所闻。故无有失。问若生欲界依初静虑发天耳通。能闻上三静虑诸天语表声不。有说不闻。以处远故。或微细故。有说。若极作意者亦能闻。以是同地法故。问随依何静虑发神境通能至何处。答依初静虑发者能至梵世。乃至依第四静虑发者能至广果或色究竟声闻不作意傍极小千世界。作意极中千世界。独觉不作意极中千世界。作意极大千世界佛不作意极大千世界。作意能极无边世界。如神境通四通亦尔。广释六通如大种蕴

若于苦思惟苦得阿罗汉果。彼思惟何系苦。答无色界系苦。此随界总说。若随地者应言非想非非想处系苦即苦类智。若于集思惟集得阿罗汉果彼思惟何系集。答无色界系集。此亦随界总说。若随地者应言非想非非想处系集即集类智。若于灭思惟灭得阿罗汉果。彼思惟何系诸行灭。答或欲界系。或色无色界系。诸行灭即灭法智灭类智。若于道思惟道得阿罗汉果。彼思惟何系诸行能断道。答或欲界或色无色界系。诸行能断道即道法智道类智。如是六智各四行相作无间道。断非想非非想处下下品烦恼与金刚喻三摩地俱。此能证得阿罗汉果金刚喻三摩地。广说如杂蕴第三纳息。杂色无色修所断染皆用六智为无间道。谓四类智灭道法智此说无漏道。若有漏道唯世俗智。彼不遍故非此所说。依初静虑起苦类智无间道时。有唯缘自地苦。有唯缘第二静虑苦乃至有唯缘非想非非想处苦无合缘二。乃至缘八。粗细异故地别断故。如苦类智集类智亦尔。起灭类智无间道时。有唯缘自地诸行灭。有唯缘第二静虑诸行灭。乃至有唯缘非想非非想处诸行灭有合缘二。乃至缘八。等微妙故。皆违染故。起道类智无间道时。皆缘九地类智品道互相因故。种类等故。起灭法智无间道时。唯缘欲界诸行灭。起道法智无间道时。皆缘六地法智品道。如依初静虑。乃至依无所有处亦尔。差别者依三无色无二法智不缘下灭。此中一切地不缘下苦集。已离下染起无用故

依初静虑起无间道离初静虑染时。苦集类智唯缘初静虑苦集。灭类智有唯缘初静虑诸行灭。有缘初第二静虑诸行灭。有缘初第二第三静虑诸行灭。有缘初第二第三第四静虑诸行灭。有缘初静虑乃至空无边处诸行灭。有缘初静虑乃至识无边处诸行灭。有缘初静虑乃至无所有处诸行灭。有缘初静虑乃至非想非非想处诸行灭。道类智总缘九地类智品道。灭法智唯缘欲界诸行灭。道法智总缘六地法智品道。依初静虑起无间道。离第二静虑染时。苦集类智唯缘第二静虑苦集灭类智。有唯缘初静虑诸行灭。有唯缘第二静虑诸行灭。有缘初第二静虑诸行灭。有缘第二第三静虑诸行灭。有缘初第二第三静虑诸行灭。有缘第二第三第四静虑诸行灭。有缘初第二第三第四静虑诸行灭。有缘第二静虑乃至空无边处诸行灭。有缘初静虑乃至空无边处诸行灭。有缘第二静虑乃至识无边处诸行灭。有缘初静虑乃至识无边处诸行灭。有缘第二静虑乃至无所有处诸行灭。有缘初静虑乃至无所有处诸行灭。有缘第二静虑乃至非想非非想处诸行灭。有缘初静虑乃至非想非非想处诸行灭。道类智灭道法智如前说。依初静虑起无间道离第二静虑染时。苦集类智唯缘第三静虑苦集灭类智。有唯缘初静虑诸行灭。有唯缘第二静虑诸行灭。有唯缘第三静虑诸行灭。有缘初第二静虑诸行灭。有缘第二第三静虑诸行灭。有缘第三第四静虑诸行灭。有缘初第二第三静虑诸行灭。有缘第二第三第四静虑诸行灭。有缘第三第四静虑空无边处诸行灭。有缘初第二第三第四静虑诸行灭。有缘第二静虑乃至空无边处诸行灭。有缘第三静虑乃至识无边处诸行灭。有缘初静虑乃至空无边处诸行灭。有缘第二静虑乃至识无边处诸行灭。有缘第三静虑乃至无所有处诸行灭。有缘初静虑乃至识无边处诸行灭。有缘第二静虑乃至无所有处诸行灭。有缘第三静虑乃至非想非非想处诸行灭。有缘初静虑乃至无所有处诸行灭。有缘第二静虑乃至非想非非想处诸行灭。有缘初静虑乃至非想非非想处诸行灭。道类智灭道法智如前说。依初静虑起无间道离第四静虑染时。苦集类智唯缘第四静虑苦集。灭类智有唯缘初静虑诸行灭。乃至有唯缘第四静虑诸行灭。有缘初第二静虑诸行灭。有缘第二第三静虑诸行灭。有缘第三第四静虑诸行灭。有缘第四静虑空无边处诸行灭。有缘初第二第三静虑诸行灭。有缘第二第三第四静虑诸行灭。有缘第三第四静虑空无边处诸行灭。有缘第四静虑空识无边处诸行灭。有缘初乃至第四静虑诸行灭。有缘第二静虑乃至空无边处诸行灭。有缘第三静虑乃至识无边处诸行灭。有缘第四静虑乃至无所有处诸行灭。五六七八地合缘如前说。道类智灭道法智亦如前说。依初静虑起无间道离空无边处染时。苦集类智唯缘空无边处苦集。灭类智有唯缘初静虑诸行灭。乃至有唯缘空无边处诸行灭。有缘初第二静虑诸行灭。有缘第二第三静虑诸行灭。有缘第三第四静虑诸行灭。有缘第四静虑空无边处诸行灭。有缘空识无边处诸行灭。有缘初第二第三静虑诸行灭。有缘第二第三第四静虑诸行灭。有缘第三第四静虑空无边处诸行灭。有缘第四静虑空识无边处诸行灭。有缘空识无边处无所有处诸行灭。四五六七八地合缘如前说。道类智灭道法智亦如前说。依初静虑起无间道离识无边处染时。苦集类智唯缘识无边处苦集。灭类智有唯缘初静虑诸行灭。乃至有唯缘识无边处诸行灭。有缘初第二静虑诸行灭。有缘第二第三静虑诸行灭。有缘第三第四静虑诸行灭。有缘第四静虑空无边处诸行灭。有缘空识无边处诸行灭。有缘识无边处无所有处诸行灭。有缘初第二第三静虑诸行灭。有缘第二第三第四静虑诸行灭。有缘第三第四静虑空无边处诸行灭。有缘第四静虑空识无边处诸行灭。有缘空识无边处无所有处诸行灭。有缘识无边处无所有处非想非非想处诸行灭。四五六七八地合缘如前说。道类智灭道法智亦如前说。依初静虑起无间道离无所有处染时。苦集类智唯缘无所有处苦集。灭类智有唯缘初静虑诸行灭。乃至有唯缘无所有处诸行灭。有缘初第二静虑诸行灭。有缘第二第三静虑诸行灭。有缘第三第四静虑诸行灭。有缘第四静虑空无边处诸行灭。有缘空识无边处诸行灭。有缘识无边处无所有处诸行灭。有缘无所有处非想非非想处诸行灭。三四五六七八地合缘如前说。道类智灭道法智亦如前说。依初静虑起无间道离非想非非想处染时。苦集类智唯缘非想非非想处苦集。灭类智有唯缘初静虑诸行灭。乃至有唯缘非想非非想处诸行灭。二三四五六七八地合缘如前说。道类智灭道法智亦如前说。如是依第二静虑起无间道离第二静虑乃至非想非非想处染。乃至依无所有处起无间道。离无所有处及非想非非想处染。如其所应皆当广说。有差别者。三无色地。除二法智。及不能缘下地灭。如是即说生欲界者。若生色无色界一切法智皆不现起。生彼上地不缘下灭。如无间道。解脱道亦尔。唯除离非想非非想处下下品染解脱道。唯容得有苦集类智

说一切有部发智大毗婆沙论卷第一百八十六阿毗达磨大毗婆沙论卷第一百八十七

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    见蕴第八中念住纳息第一之一

有四念住。谓身受心法念住。如是等章。及解章义既领会已。应广分别。问何故作此论。答为欲解释契经义故。如契经说。有四念住。谓身念住。乃至法念住。虽作是说而不分别。若修身念住彼受耶。乃至广说。彼经是此论所依根本。彼所不分别者。今尽应说故作斯论。然佛说有三种念住。一自性念住。二相杂念住。三所缘念住。于何处说自性念住耶。答如契经说。有一趣道能令有情清净超灭忧苦。谓四念住。何等为四。谓于身循身观念住。乃至于法循法观念住。复何处说相杂念住耶。答如契经说。若有说。善法聚者即四念住。是为正说。所以者何。淳具圆满善法聚者唯四念住。何等为四。谓于身循身观。乃至广说。复何处说所缘念住耶。答如契经说。若有说。一切法即四念住。是为正说。所以者何。具足摄受一切法者唯四念住。何等为四。谓于身循身观念住。乃至广说。此中三经标句如其次第。别说自性相杂所缘念住。释句皆说自性念住。以循观言俱目慧故。问何故世尊于标句中。或说自性念住。或说相杂念住。或说所缘念住。于释句中唯说自性念住耶。答欲令胜义念住无失坏故。念住有二种。一胜义。二世俗。自性念住是胜义。余是世俗。胜义念住于一切时不可失坏。故佛于释句中皆说自性。有说。由自性念住力故相杂所缘说名念住。有说。欲显三种念住俱以慧为自性故。谓一慧性由俱有法相杂助伴。能有所作即名相杂念住。由所缘力能遍随观即名所缘念住。由佛于契经中说此三种念住故。阿毗达磨者亦于处处依三种念住而作论。云何知然。如说。云何身念住。谓缘身慧。乃至云何法念住。谓缘法慧。是谓说自性念住处。此即契经所说。有一趣道乃至广说。如说。云何身念住。谓身增上道所生有漏无漏善。乃至云何法念住。谓法增上道所生有漏无漏善是。谓说相杂念住处。此即契经所说。善法聚者。即四念住。乃至广说。如说。云何身念住。谓十色处及法处所摄色。云何受念住。谓六受身。云何心念住。谓六识身。云何法念住。谓受蕴所不摄非色法处是。谓说所缘念住处。此即契经所说。一切法者。即四念住。如是阿毗达磨所说与契经相应。是故此中亦依三种念住而作论

问世尊为何等有情说自性念住。乃至为何等有情说所缘念住耶。答为即愚彼三种有情说三念住。谓愚自性念住者为说自性念住。乃至愚所缘念住者为说所缘念住。复次有情行有差别。谓初业等。为初业者说所缘念住。为已习行说相杂念住。为已超作意说自性念住。复次有情乐欲有差别。谓广略中乐略者为说自性念住。乐中者为说相杂念住。乐广者为说所缘念住。复次有情根有差别。谓利中钝为利根说自性念住。为中根说相杂念住。为钝根说所缘念住。复次有情智有差别。谓开发生智分别生智引导生智。开发生智为说自性念住。分别生智为说相杂念住。引导生智。为说所缘念住。为如是等所化有情故。佛说此三种念住

问此三念住谁断烦恼。答唯相杂念住能断烦恼非余。问何故自性念住不能断烦恼耶。答若离助伴唯慧不能断烦恼故。问何故所缘念住不能断烦恼耶。答彼作意普散故。唯总略所缘作意能断烦恼。问何故相杂念住能断烦恼耶。答具二缘故。谓摄受助伴故。及总略所缘作意故。问若尔。修余念住应成无用。答彼能引发相杂念住非为无用。有说。断有二种。一暂时断。二究竟断。修余念住能暂时断故非无用。相杂念住复有三种。谓闻思修所成差别。问此三何者能断烦恼。答修所成能断烦恼非余。问何故闻所成不能断烦恼耶。答此必依名乃于义转。唯不待名于义转道能断烦恼。问何故思所成不能断烦恼耶。答由此作意是不定地所摄故。唯定地所摄道能断烦恼。问何故修所成能断烦恼耶。答具二缘故。谓不待名于义转故。及定地所摄故。问若尔。修余二种应成无用。答彼能引发修所成故。谓闻所成能引发思所成。思所成能引发修所成。修所成能断烦恼。故非无用。有说。断有二种。如前广说。修所成念住复有四种。谓身受心法。问此四何者能断烦恼。答法念住能断烦恼非余。问何故前三念住不能断烦恼耶。答彼是自相作意所摄故。唯共相作意所摄道能断烦恼。有说。彼一一蕴各别缘故。要总缘四蕴五蕴或离蕴道能断烦恼。问若尔。修前三种应成无用。答能引发法念住故。谓身念住能引受念住。受念住能引心念住。心念住能引法念住。法念住能断烦恼。故非无用。有说。要先分别诸蕴。后方能总缘而断烦恼。故非无用。有说。断有二种。如前广说。法念住复有二种。一杂缘。二不杂缘。若缘想行蕴及无为名不杂缘。若于五蕴或二二缘或三三缘或四四缘或五总缘及无为名为杂缘。问此中何等法念住。能断烦恼。答二俱能断。谓若缘苦集道谛断烦恼道。是杂缘法念住。若缘灭谛断烦恼道。是不杂缘法念住

此中或总说一念住。谓大地法慧根慧力正见择法觉支。或说二。谓有漏无漏缚解系不系。或说三。谓软中上品。或闻思修所成。或说四。谓身受心法。或说五。谓三界系学无学。或说六。谓有漏无漏各有软中上品。或说八。谓身受心法各有有漏无漏。或说九。谓软软乃至上上。或说十二。谓身受心法各有软中上品。复有别说十二。如契经说。于内身住循身观。于外身住循身观。于内外身住循身观。如身三种。乃至法亦尔。或说十八。谓有漏无漏各有软软乃至上上品。或说二十四。谓身受心法软中上品各有有漏无漏。或说三十六。谓身受心法各有软软乃至上上品。复有别说三十六。如契经说。于内身住厌逆想。于内身住不厌逆想。于内身住俱离舍正念正知。如于内身。于外身内外身亦尔。如于身有九。乃至于法亦尔。或说七十二。谓身念住有漏无漏各有软软乃至上上品。如身念住有十八。乃至法念住亦尔。若约相续刹那分别则有无量念住。问若尔者。世尊何故于一等广说四念住。于无量略说四念住耶。答为对治四颠倒故。谓对治于不净净想颠倒故说身念住。对治于苦乐想颠倒故说受念住。对治于无常常想颠倒故说心念住。对治于无我我想颠倒故说法念住。有说。为对治四食故。谓对治段食故说身念住。对治触食故说受念住。对治识食故说心念住。对治意思食故说法念住。有说。为对治四识住故。谓对治色近行识住故说身念住。对治受近行识住故说受念住。对治住彼识故说心念住。对治想近行行近行识住故说法念住。有说。为对治五蕴故。谓对治色蕴故说身念住。对治受蕴故说受念住。对治识蕴故说心念住。对治想蕴行蕴故说法念住。有说。为对治四种不修故。谓对治不修身故说身念住。对治不修戒故说受念住。对治不修心故说心念住。对治不修慧故说法念住。有说。与四修同法故。说四念住。谓与修身同法故说身念住。与修戒同法故说受念住。与修心同法故说心念住。与修慧同法故说法念住。问念住以何为自性。为以念为以慧耶。若以念者。此说云何通。如说于身循身观。乃至广说。若以慧者。何故名念住。又契经说当云何通。如说于何处应观念根。谓于四念住。答应说慧为自性。问若尔。何故名念住耶。答念于此住等住。各住故名念住。如象马等所住处名象马等住。此亦如是。有说。此由念力能于所缘起差别广博作用。而不失坏故名念住。有说。由念力故此瑜伽师审记所缘。于所缘境忘已还忆。故名念住。有说。此修行者于所缘中先以念安住然后观察。复于所缘先通达已后以念安住为守护故。如守门者故名念住。有说。此修行者于所缘境。先以念摄持。后以慧观察。而断烦恼。譬如田夫先以左手揽取草等。后以右手执镰刈之。此亦如是。故名念住。有说。此瑜伽师被念铠甲。于心相续上。执慧刀杖在生死阵中。不为烦恼怨所降伏。而能降伏于彼故名念住。有说。为遮取自性过故说名念住。若名慧住者便有取自性过失。有说。为显非唯自性能有所作故名念住。由是等缘。但名念住不名慧住。问契经所说复云何通。如说于何处应观念根谓于四念住。答以念根于念住位作用增上故作是说。如信根于四证净位作用增上故。佛复说。于何处应观信根谓于四证净。如是精进根于四正断。定根于四静虑。慧根于四圣谛亦尔。故世尊乃至复说。于何处应观慧根于四圣谛。此亦如是。是谓念住自性

已说自性。所以今当说。何故名念住。念住是何义。答念于此住等住各住。广说如前。已总说念住所以。一一所以今当说。问何故名身念住。答此念住缘身故名身念住。问余念住亦缘身。谓受念住缘六受身。心念住缘六识身。法念住缘六想身六思身等。何故不皆名身念住耶。答此中所说缘身者。谓缘色身。余念住缘非色身故不名身念住。有说。若缘粗显易见。现见身者名身念住。余念住缘微隐难见难觉。不现见身故不名身念住。有说。若所缘身是极微聚所成者彼名身念住。余所缘身非极微聚所成故。彼不名身念住。有说。若缘于身而能知所知俱时生者名身念住。余虽缘身而能知所知不俱生故不名身念住。虽法念住中有俱生者以少故不说。如缘身故名身念住。如是缘受故名受念住。缘心故名心念住。缘法故名法念住。问一切皆是法一切皆唯有法故。何故唯一名法念住非余耶。答虽一切皆是法。而但立一为法念住。如十八界皆是法。而但立一为法界。十二处皆是法。而但立一为法处如法界法处如是法智择法觉支。法随念法证净法无碍解法宝法归亦尔。有说。法念住有一名。余念住有二名。有说。法念住有共名。余念住有共不共名。有说。一切有为法由生所起。生是彼所缘故名法念住。有说。一切法由名所显。名是彼所缘故名法念住。有说。诸有为相是一切有为法之幖帜。印此诸相堕在彼所缘中故名法念住。有说。空解脱门觉诸法法性。此空摄在彼所缘中。故名法念住。问若尔者。萨迦耶见亦觉诸法补特伽罗性。何故不依彼立名耶。答彼非真实觉。此是真实觉。故无有过。有说。慧能分别诸法自相共相。安立诸法自相共相。损害事愚及所缘愚。于诸法中不增减转。此慧堕在彼所缘中。故名法念住。有说。灭谛涅槃是胜义法常住不变。此法摄在彼所缘中。故名法念住。有说。此念住能缘多法。谓色非色相应不相应。有所依无所依。有行相无行相。有所缘无所缘。有警觉无警觉。是故名法念住。有说。身念住缘身不缘缘身慧。受念住缘受不缘缘受慧。心念住缘心不缘缘心慧。法念住缘身亦缘缘身慧。缘受心法亦缘缘受心法慧。是故唯此名法念住。有说。身念住缘身不缘身生老无常。受念住缘受不缘受生老无常。心念住缘心不缘心生老无常。法念住缘身亦缘身生老无常。缘受心法亦缘受心法生老无常。是故唯此名法念住。有说。齐此诸瑜伽师我想一合想皆得止息。法想差别想修习圆满。故名法念住。谓瑜伽师分析身已便计受为我分析受已。便计心为我分析心已。便计法为我分析法已。便知一切非我有情唯空行聚。是故齐此法想圆满名法念住。已说念住一一所以。彼次第今当说。何故世尊先说身念住。乃至后说法念住耶。答显示随顺故。谓若如是次第显示则于文字言说随顺。有说。说受随顺故。谓若作如是次第。则于师说及弟子受皆得随顺。有说。此依生起次第故。次第有三种。一生起次第。二显示次第。三现观次第。生起次第者。如此念住。及静虑无量无色解脱胜处遍处等。显示次第者。谓正断神足根力觉支道支等。现观次第者。谓四圣谛。以瑜伽师先起身念住故佛前说。乃至后起法念住故佛后说。问因论生论。何故诸瑜伽师先起身念住。乃至后起法念住耶。答依粗细次第故。谓五蕴中色蕴最粗。故先观察起身念住。四无色蕴中受蕴最粗。故次观察起受念住。问受等无方所。如何可施设粗细耶。答虽无方所粗细而有行相粗细。亦可施设。此中受行相粗如说我手足等痛。又说我受如是如是苦故。受等蕴虽非色而如色施设粗细。四无色蕴中识蕴最细。而先想行蕴观察起心念住者。以想行蕴与涅槃最微细法合施设故。彼最后观察起法念住。有说。从不可知本际以来男为女色女为男色。是生染处。故先观色起身念住。染着此色由贪乐受。故次观受。起受念住。贪乐由于心不调伏。故次观心起心念住。心不调伏由烦恼未断。故最后观法起法念住。有说以色可施设有增减。有取舍相似相续故。先观色起身念住。于观色时起身轻安及心轻安。由此为先引起乐受。故次观受起受念住。于观受时。引起胜义境界了别。故次观识起心念住。彼作是念。若处起心亦起心所。故最后观法起法念住。有说。身愚能持受愚乃至心愚能持法愚。非身愚不转能转受愚。乃至非心愚不转能转法愚故。四念住如是次第起。有说。身不愚能引受不愚。乃至心不愚能引法不愚。非身不愚不起能起受不愚。乃至非心不愚不起能起法不愚。故四念住如是次第起。有说。身观能引受观。乃至心观能引法观。非身观不起能起受观。广说如上。有说。身观与受观为因为根为眼为道为渐为能作为缘生为起集为等起。受观与心观。心观与法观亦尔。余如前说。有说。身观与受观。为加行为门为依。乃至心观与法观亦尔。余如前说。有说。身观与受观。为依止为迹处。乃至心观与法观亦尔。余如前说。问若尔。身观复以谁为依止迹处耶。答以先所得奢摩他相。为依止为迹处。如说。彼先得不动奢摩他故。身轻暖相从足至顶周遍积聚。由此能起身念住乃至法念住。有说。彼于相续中分别诸处起四念住。谓瑜伽师先欲知诸色处故。先分别十色处及念处所摄色。是故先起身念住。次即于法处分别诸受故。次起受念住。次即于法处。分别想行蕴及三无为故。次起法念住。彼复作是念。除此有何。即如实知余有意处。由此即分别意处。故最后起心念住。诸瑜伽师若依自相观则先起法念住。后起心念住。若依共相观则先起心念住。后起法念住。故四念住如是次第起。问为先起缘内念住。为先起缘外念住耶。若尔有何过。若先起缘内念住者。经说云何通。如说新学苾刍具净尸罗意乐圆满。欲疾除断欲贪嗔者。应往澹泊路诣死尸所善取其相。或青淤或脓烂。乃至广说。若先起缘外念住者。余经说复云何通。如说先于内身住循身观。次于外身。乃至广说。答应作是说。先起缘内念住。所以者何。以有我故有我所。有我执故有我所执。有我见故有我所见。有五我见故有十五我所见。有我愚故有我所愚。有我爱故有众具爱。为长养内我求外资具故。问若尔。前所引经云何通。答彼是念住加行非根本念住。云何知然。即彼经说善取相已速还本处。忆念先所取相。若能者善。若不能者复往尸所。更善取相驰还本处。洗足入房敷座而坐。以胜解作意令所取相明了现前。是名念住加行。若时以外所取相置于内身。而观察者乃名入根本念住。有说。彼契经说。果胜作意非念住位。云何知然。即彼经说。彼新学苾刍得学意已。若欲往澹泊路者随欲而往。此中新学苾刍即预流者。及一来者。故知彼契经说果胜作意非念住位

如契经说。于内身住循身观。于外身住循身观。于内外身住循身观。乃至广说。问此中何者名内身等。何者名外身等答自相续所摄色名内身。他相续所摄色。及非有情数色名外身。内法外法说亦尔。自相续所摄受名内受。他相续所摄受名外受。内心外心说亦尔。有余师说。有情数色名内身。非有情数色名外身。内法外法说亦尔。受心如前说。胁尊者言。现在名内。过去未来及无为名外。问何故现在名内。过去未来及无为名外耶。答以现在法多令有情摄受贪着。非过去未来及无为故。此中于内身住循身观者。住内身自相观。于外身住循身观者。住外身自相观。于内外身住循身观者。住内外身共相观。乃至法亦尔。有说。于内身住循身观者。住内身广观。于外身住循身观者。住外身广观。于内外身住循身观者。住内外身略观。乃至法亦尔。有说。于内身住循身观者。对治我执。于外身住循身观者。对治我所执。于内外身住循身观者。对治我我所执。乃至法亦尔。如我执我所执。我见我所见说亦如是。有说。于内身住循身观者。对治五我见。于外身住循身观者。对治十五我所见。于内外身住循身观者。对治二十种萨迦耶见。乃至法亦尔。如我见我所见。如是我愚我所愚说亦尔。有说。于内身住循身观者。对治我爱。于外身住循身观者。对治众具爱。于内外身住循身观者。对治俱爱。乃至法亦尔。问齐何当言身念住。乃至法念住圆满耶。答由二缘故当知圆满。一分别所缘。二善根增。分别所缘者。谓若时能以刹那极微分析所缘。或唯以刹那分析所缘。善根增者。谓依下生中依中生上。齐此应知念住圆满。有说。由转加行应知圆满。谓瑜伽师先分别身。分别身已转身觉慧次分别受。分别受已转受觉慧次分别心。分别心已转心觉慧分别于法。譬如农夫引水溉田。初畦满已引溉第二。第二满已引溉第三。第三满已引溉第四。此亦如是。有说。齐怨害相成应知圆满。怨害相有二种。一令不喜乐。二令生嗔恚。此中但说令不喜乐名怨害相。谓瑜伽师分别身已便于身不生喜乐。而喜乐受等。分别受已复于受不生喜乐。而喜乐心等。分别心已复于心不生喜乐。而喜乐于法。分别法已。便于一切境界不生喜乐应知。尔时念住圆满

说一切有部发智大毗婆沙论卷第一百八十七阿毗达磨大毗婆沙论卷第一百八十八

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    见蕴第八中念住纳息第一之二

复次有三种念住。谓闻思修所成差别。此中有说。于佛所说十二分教。受持读诵思量分别名闻所成念住。依闻起思。依思起修。依修能断烦恼。如依金矿出金。依金出金刚。依金刚能坏石等坚物。胁尊者言。于佛所说十二分教。受持读诵思量分别。是生得慧。依生得慧起闻所成念住。依闻起思。依思起修。依修能断烦恼。如依种子生芽。依芽生茎。依茎生枝叶。依枝叶生花果。问此三念住何差别。有说。名则差别。谓此名闻所成念住。乃至此名修所成念住。有说。闻所成念住一切时依名于义转。谓素怛缆说有何义。毗柰耶说有何义。阿毗达磨说有何义。邬波拖耶说有何义。阿遮利耶说有何义。余书论说有何义。思所成念住或依名。或不依名于义而转。修所成念住一切时离名于义转。譬如三人俱在池浴。初人未学浮。第二半学。第三善学。未学浮者一切时依岸浴。半学浮者或依岸或离岸而浴。善学浮者恒时离岸在中而浴。如第一人闻所成亦尔。如第二人。思所成亦尔。如第三人修所成亦尔。是谓此三念住差别

问此闻思修所成念住。何界有几种。答欲界有二。谓闻思所成非修。所以者何。欲界是不定界非修地非离染地。作意修时便堕思中故。色界有二。谓闻修所成非思。所以者何。色界是定界是修地是离染地。作意思时便堕修中故。无色界有一。谓修所成。然修所成亦不堕界。有余师说。欲界具有三种。余如前说。有说。欲色界各具三种。余如前说。有说。三界皆具三种。唯修所成亦不堕界。评曰。初说者好。问此诸念住谁为谁因。答闻为三种因。思唯思因非闻因。以彼劣故非修因。以界别故。修唯修因非闻因。以彼劣故非思因。以彼劣及界别故。谁为谁果。答闻唯闻果思闻思果非修。修闻修果非思

问此三念住谁现前修几。答闻所成现前时唯修闻非思修。思所成现前时唯修思非闻修。此中闻思刹那现前时以习修故名修。非修未来以势劣故。则以此故唯修自不修他。修所成现前时能修三种。闻思自力虽不能修未来。而由他力有未来修义

问闻思修所成念住。佛独觉声闻各有几种。答佛具三种而修所成为胜。以自然觉及具力无畏等功德故。独觉亦具有三而思所成为胜。以自思惟觉而无力无畏等功德故。声闻亦具三种而闻所成为胜。以从闻他音入圣道故。如说

我圣弟子闻杖具足断不善法修习善法。复有三种念住。谓言说究竟念住。思惟究竟念住。出离究竟念住。应知此三则闻思修所成念住。如其次第。然闻等三种念住一切皆可名闻所成。如说

  多闻能知法　　多闻能离罪
  多闻舍无义　　多闻得涅槃

一切皆可名思所成。如说。思者是业。虑者是慧。彼所说虑则思所成。一切皆可名。修所成如说。云何应修法。谓一切善有为法

问何谓念住加行。云何自相种性杂缘。及闻思修所成念住生起次第。答不净观持息念界作意。是谓念住加行。则此为先入自相种性身念住。则身念住为先入自相种性受念住。则受念住为先入自相种性心念住。则心念住为先入自相种性法念住。从自相种性法念住起杂缘法念住。从杂缘法念住起三义观。从三义观有闻所成身念住。先作无常乃至无我行相缘苦谛起次作因。乃至缘行相缘集谛起。次作道乃至出行相缘道谛起。从此无间有闻所成受念住心念住。各作十二行相缘三谛起亦尔。从此无间有闻所成法念住。先作无常乃至无我行相缘苦谛起次作因。乃至缘行相缘集谛起次作灭。乃至离行相缘灭谛起次作道。乃至出行相缘道谛起。从闻所成法念住无间。有思所成身念住作十二行相缘三谛起。从此无间有受念住作十二行相缘三谛起。从此无间有心念住作十二行相缘三谛起从此无间有法念住作十六行相缘四谛起。从思所成法念住有修所成法念住先作无常。乃至无我行相缘苦谛起次作因。乃至缘行相缘集谛起次作灭。乃至离行相缘灭谛起次作道。乃至出行相缘道谛起。如是缘四谛作十六行相法念住名为初暖。是谓念住加行所引自相种性杂缘。及闻思修所成念住生起次第。问何故闻思所成念住皆初起身念住缘三谛作十二行相。后乃起余念住。而修所成念住初则起法念住缘四谛作十六行相耶。答未曾得种性故。渐次得行相故。先观粗蕴后观细蕴。于五蕴中色蕴最粗。先观彼故初起身念住。然身受心皆三谛摄故。身念住缘三谛作十二行相。如是闻所成身念住。引起闻所成受念住。闻所成受念住引起闻所成心念住。闻所成心念住引起闻所成法念住。此闻所成法念住缘四谛作十六行相。闻所成四念住渐圆满已。便能引起思所成四念住。思所成四念住渐圆满已。复能引起修所成法念住。此曾得种性故于一切蕴行相坚住。故初则起法念住。先缘苦谛作四行相。乃至后缘道谛作四行相。如契经说。如是修直正愿念住能破无明发起于明。此中说。何名修直正愿念住耶。有作是说。此中说苦法智忍以此能破无明。则欲界见苦所断十随眠发起于明则苦法智。有说。此中说道类智忍以此能破无明。则色无色界见道所断十四随眠发起于明则道类智。有说。此中说金刚喻定以此能破无明。则非想非非想处软软品烦恼发起于明则尽智。有说。此中说一切无间道以此能破无明。则彼所断烦恼品发起于明则彼品解脱道胁尊者言。此中说方便善巧所摄受善慧名修直正愿念住。以此能破无明。则三不善根发起于明则三善根

如薄伽梵说伽他言

  若丛网便着　　无爱谁能将
  佛所行无边　　无迹何迹引

此中佛所行者。谓四念住。问佛为得念住边际而般涅槃。为不得边际而便般涅槃耶。设尔有何过。若言得者。何故说佛所行无边。若不得者。何故说佛得尽智时事善究竟。答有因缘故可言得边际。有因缘故可言不得边际。谓依牵引故可言得边际。依受用故可言不得边际。复次依获得故可言得边际。依在身故可言不得边际。复次依成就故可言得边际。依现前故可言不得边际

如契经说。何谓非苾刍所行处。应言五妙欲。是何谓是苾刍所行处。应言四念住是。问五妙欲亦随入念住中。何故说非所行处耶。答依能观者故作是说。谓若不如理观名非所行处。若如理观名所行处

如契经说。有三念住圣者应习。若有圣者善习此时乃应御众。云何为三。谓如来为弟子说法时起深怜愍义利悲心告言。此为利益此为安乐此为利益安乐。若弟子众恭敬属耳住奉教心。行法随法不越圣教受学学处。如来于彼亦不喜庆心不踊悦。唯住正舍正念正知。是名第一念住。若有圣者善习此时乃应御众。复次如来为弟子说法时起深怜愍。乃至义利悲心告言。此为利益此为安乐此为利益安乐。若弟子众不恭敬不属耳不住奉教心。不行法随法违越圣教不受学学处。如来于彼亦不恚恨心无忧戚。唯住正舍正念正知。是名第二念住。若有圣者善习此时乃应御众。复次如来为弟子说法时起深怜愍。乃至此为利益安乐。若一分弟子众恭敬属耳乃至受学学处。一分弟子众不恭敬不属耳乃至亦不受学学处。如来尔时于敬受者亦不欢喜心不踊悦。于不敬受者亦不恚恨心无忧戚。唯住正舍正念正知。是名第三念住。若有圣者善习此时乃应御众。问若尔者。但应有二念住。谓于敬受及于不敬受。云何说三种耶。答随众会有三故说三种。谓有众会一切敬受。有众会一切不敬受。有众会一分敬受。一分不敬受。是故随彼说三念住。问若尔。便应说七念住。谓前四及此三种。答此中三种则入前四。以俱是前杂缘外法念住所摄故。问佛说法时若皆敬受便应无三念住。若有不敬受者。将无世尊于非田非器雨正法雨。如是佛说法则为唐捐。答世尊为人说法欲令人解。若当人不解者亦有天能解之。如是念住有三。亦非佛唐捐说法。所以者何。以人不解故念住有三。天能解故不于非田非器而雨法雨。有说。佛说法时欲令彼彼有情得阿罗汉果。彼不得阿罗汉果而得不还果。故念住有三。亦非佛唐捐说法。所以者何。以不得阿罗汉果故。念住有三。以得不还果故。不唐捐说法。复次佛说法时欲令彼彼有情得不还果。彼不得不还果而得一来果。广说如前。如是欲令得一来果。预流果。顺决择分善根。顺解脱分善根顺福分善根。展转次第广说亦尔。复次佛说法时欲令彼彼有情得现法果。彼不得现法果而能种当来善根故。念住有三亦非佛唐捐说法。广说如前。问何故弟子敬受教时。佛不生喜。不敬受时佛不生忧耶。答佛知有情有如是种性差别。恶意乐者行恶。善意乐者行善。若当恶意乐者行善可于彼生喜。善意乐者行恶可于彼生忧。但不如是。种性别故。如知外物种性差别。铁矿出铁金矿出金是故于销炼时。从铁矿得铁心不生忧。从金矿得金心不生喜。若当与此相违得者可生忧喜。然无是事种性异故。世尊亦尔。知诸有情种。性差别不生忧喜。有作是说。佛已善断爱恚法故。谓喜似爱忧似恚。佛于爱恚皆已善断。故无忧喜。复有说者。佛已善修空为根本而作是念。谁为恭敬者。谁为不恭敬者。唯空行聚故于众会不生忧喜

如契经说。有一趣道能令有情清净。谓四念住。乃至广说。问云何名一趣道。为以能超越一界故名一趣道。为以能超越一趣故。为以能超越一生故为以能通达一谛故。为以能趣一究竟故。名一趣道。为以但有一道故名一趣道耶。设尔何过。若以能超越一界故名一趣道者。则非一趣道界有三故。若以能超越一趣故名一趣道者。亦非一趣道趣有五故。若以能超越一生故名一趣道者。亦非一趣道生有四故。若以能通达一谛故名一趣道者。亦非一趣道谛有四故。若以能趣一究竟故名一趣道者。亦非一趣道。以究竟有二种。一事究竟。二功用究竟故。若以但有一道故名一趣道者。亦非一趣道以道有多种。谓随信行道随法行道信胜解道见至道时解脱道不时解脱道故。云何言有一趣道耶。答则由前所说缘及余缘故名一趣道。由前所说缘者。谓以能超越一界故名一趣道。则无色界。以超此界者。更不生三界故。亦以能超越一趣故名一趣道。则天趣。以超此趣者更不往五趣故。亦以能超越一生故名一趣道。则化生。以超此生者更不受四生故。亦以能通达一谛故名一趣道。则道谛。以此谛从无始时来未曾得故。及未曾通达故。亦以趣一究竟故名一趣道。则事究竟。以修功用究竟皆为得事究竟故。亦以但有一道故名一趣道。则圣道。问岂不有随信行道乃至不时解脱道如是便有多道耶。答一切皆是趣苦灭行故说名一道。如趣苦灭行。如是趣有灭。世间灭。生死灭。流转灭。生老病死灭行说亦尔。是名由前所说缘故。名一趣道。及余缘故者。谓无异趣故不退还故。至不退解脱故。至背五趣之一趣故。如说涅槃是阿罗汉趣。由如是义名一趣道。复有说者。能对治异道故名一趣道。谓诸外道或执不食为道。或执随日转为道。或执卧灰饮风服水茹菜啖果裸形粗衣卧不平等各以为道。佛为对治彼异道故说一趣道。此意义言。彼种种道皆非真道但是恶邪妄道。是不善士所习近道。非诸善士所习近道。所以者何。真道唯一。谓四念住。或有说者。能趣一解脱宫门故名一趣道。此中应引嗢底迦经所说喻。如彼说。佛告嗢底迦。如国边城。其墙坚厚却敌楼橹埤堄寮窗并皆严备。唯有一门委一人捉。其人聪慧多闻善习应入者听不应者止。彼每巡城察之乃至不见兽往来处。况余门耶。嗢底迦当知。彼守门者。虽不知日日有尔所有情入城出城。然其定知诸有入出皆由此门不从余门。如是如来虽不作意知尔所有情已般涅槃。尔所有情当般涅槃。然其定知诸有情类已般涅槃未般涅槃。皆由此道不依余道。是故以能趣一解脱宫门故名一趣道

问正断神足根力觉支道支为是一趣道不。若是者。何故彼经唯说念住名一趣道。不说余耶。若非者何故唯念住是一趣道非余耶。答应说彼亦是一趣道。问若尔者何故彼经而不说耶。答应说而不说者。当知此义有余。有说。若说念住当知亦已说正断等。有说。念住是一趣亦是道。正断等是一趣而非道。以非一切皆是慧故。有说。念住从初业地乃至尽无生智作用恒胜。正断等不尔。有说。念住能分别诸法自相共相能建立诸法自相共相。能害事愚及所缘愚。于诸法中不增减转。正断等不尔。有说。念住如有目者能将导所余如盲。菩提分法趣涅槃宫而无异趣。如明眼者引诸盲人令随正路不行非道。念住亦尔。是故。彼经唯说念住名一趣道而不说余

如契经说。有一趣道能令有情清净超灭忧苦。乃至能证随正理法。谓圣正三摩地及彼因缘彼众具。问何故世尊或说般若为一趣道。或说等持为一趣道耶。答随所化有情所未具者而说故。谓所化有情或有阙奢摩他。或有阙毗钵舍那。若阙奢摩他者为说等持为一趣道。若阙毗钵舍那者。为说般若为一趣道。般若者则前所说念住。以念住慧为性故

如契经说。若有能办四念住则能办正如理。若能办正如理则能办圣道。若能办圣道则能办甘露。若能办甘露则能解脱生老病死愁叹忧苦诸热恼法。问念住正如理圣道。甘露何差别。答名则差别谓名念住乃至名甘露。有说。念住则显念住。正如理显正断神足根力觉支。圣道显道支甘露显彼果。有说。念住显所缘念住。正如理显相杂念住。圣道显自性念住。甘露显彼果。有说。念住显闻所成念住。正如理显思所成念住。圣道显修所成念住。甘露显彼果。有说。念住显言说究竟念住。正如理显思惟究竟念住。圣道显出离究竟念住。甘露显彼果。有说。念住显见道。正如理显修道。圣道显无学道。见地修地无学地说亦尔。甘露显彼果。有说。念住显未知当知根正如理显已知根。圣道显具知根。甘露显彼果。是谓念住正如理圣道甘露差别

若修身念住彼受耶。乃至广说。修有四种。谓得修习修对治修除遣修。得修习修谓一切善有为法。对治修除遣修谓一切有漏法。西方师言。修有六种。谓前四及防护修分别修。防护修者。谓修根如说。如是六根善调善护善守善防能感当来乐受异熟。分别修者。谓修身如说此身发毛爪齿。乃至广说。迦湿弥罗国诸师言。此后二修则前对治除遣修摄四修义如智蕴等处广说。此中依二修作论。谓得修习修。依此二修于诸位中修念住有差别。谓初暖位中缘三谛法。念住现在修。未来修四。一行相现在修。未来修四。同分修非不同分。缘灭谛法念住现在修则此未来修。一行相现在修。未来修四。亦同分修非不同分。非初蕴灭观。能修缘蕴道。故增长暖缘三谛。四念住随一现在修。未来修四。同分不同分修。一行相现在修。未来修十六。缘灭谛法念住现在修。未来修四。一行相现在修。未来修十六。问何故初暖唯同分修非不同分。增长暖同分不同分修耶。答初暖是未曾得种性。初缘谛起行相势力劣故唯同分修非不同分。增长暖是曾得种性。已缘谛起行相势力强胜故能同分不同分修。初顶位中缘四谛法念住现在修。未来修四。同分不同分修。一行相现在修。未来修十六。增长顶位缘三谛四念住随一现在修。未来修四。同分不同分修。一行相现在修。未来修十六。缘灭谛法念住现在修。未来修四。一行相现在修。未来修十六。初忍及增长位俱缘四谛法念住现在修。未来修四。同分不同分修。一行相现在修。未来修十六。问何故初忍及增长位皆唯法念住现在修耶。答以忍近见道故与见道相似。如见道中唯法念住现在修忍亦尔。尊者妙音说曰。顺决择分善根二在欲界。谓暖顶。二在色界谓忍世第一法。若依彼说初忍缘三谛法念住现在修。未来修四。一行相现在修。未来修四同分修非不同分。缘灭谛法念住现在修则此未来修非初蕴灭观能修缘蕴道。故一行相现在修。未来修四。同分修非不同分。增长忍缘三谛四念住随一现在修。未来修四。同分不同分修。一行相现在修。未来修十六。缘灭谛法念住现在修。未来修四。一行相现在修。未来修十六。问何故初忍唯同分修。增长忍亦不同分修耶。答如前广说。评曰。前说者好然顺决择分善根顺见道故。初起位中现在皆唯修法念住。于增长住有四念住随一现前。从初忍位近见道故于一切时现在唯修法念住。世第一法位亦唯法念住现在修。未来修四。一行相现在修。未来修四。同分修非不同分。问世第一法亦是曾得种性已缘谛起行相。何故唯同分。修非不同分耶。答世第一法是极邻近见道善根最与见道相似。如见道中唯同分修非不同分。世第一法亦尔。有说。世第一法是见道前行修治道者故。如见道唯同分修。有说。世第一法唯有尔所行相可修。如裸形者无衣可夺。应知增上忍亦尔。余忍位中随减所缘则不修彼念住行相。如应当知

说一切有部发智大毗婆沙论卷第一百八十八阿毗达磨大毗婆沙论卷第一百八十九

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    见蕴第八中念住纳息第一之三

若入正性离生苦集现观各四心顷。道现观三心顷。法念住现在修未来修四一行相。现在修未来修四同分修非不同分。灭现观四心顷。法念住现在修即此未来修。非初无漏蕴灭观即能修缘蕴道故一行相现在修未来修四同分修非不同分。以初得无漏种性力未广故。道类智法念住现在修未来修四同分不同分修一行相现在修未来修十六已得无漏种性势增广故。从此以上一切圣者起未曾得善根现在前时。未来皆修四念住十六行相。唯除闻思所成慧。及入灭定微微心时。余一切异生又无圣行相。是故从此以后但说修念住多少不说行相

若诸异生离欲界染加行道时。四念住随一现在修未来修四。九无间道九解脱道时法念住现在修未来修四。如离欲界染乃至离第三静虑染亦尔。离第四静虑染。若则以第四静虑为加行。彼加行道时四念住随一现在修未来修四。若以空无边处近分为加行诸有欲令彼近分地有别缘者彼加行道时。四念住随一现在修未来修四。九无间道八解脱道时。法念住现在修未来修四。第九解脱道时法念住现在修未来修三除身念住。诸有欲令彼近分地唯总缘者。彼加行道九无间道八解脱道时。法念住现在修则此未来修。第九解脱道时法念住现在修未来修三除身念住。如离第四静虑染乃至离无所有染亦尔。差别者除身念住。则诸异生起不净观持息念。身念住初三解脱八胜处前八遍处。及引发神境天眼天耳通时。身念住现在修未来修四。起后三念住随一现在修未来修四。起四无量引发宿住随念通。时法念住现在修未来修四。引发他心通时心念住或受心法念住随一现在修未来修四。若起无色解脱及后三念住时。后三念住随一现在修未来修三除身念住。若起空无边处识无边处遍处时。法念住现在修未来修三除身念住。是谓异生位所修差别。若诸圣者离欲界乃至非想非非想处染一切加行道时。四念住随一现在修未来修四。一切无间解脱道时。法念住现在修未来修四。信胜解练根作见至。时解脱练根作不动。一切加行道时四念住随一现在修未来修四。一切无间道解脱道时法念住现在修未来修四。若诸圣者起不净观持息念身念住初三解脱八胜处前八遍处。及引发神境天眼天耳通。及起词无碍解时身念住现在修未来修四。若杂修静虑及诸有欲令一切法皆是胜义者。起义无碍解辩无碍解愿智边际定无色解脱。入灭定想微细心时。四念住随一现在修未来修四。若起四无量宿住随念通。及诸有欲令唯涅槃是胜义者。起义无碍解法无碍解无诤后二遍处空空无愿无愿无相无相时。法念住现在修未来修四。若引发他心通时。心念住或受心法念住及起后三念住时随一现在修未来修四。是谓此处略毗婆沙

若修身念住彼受耶。设修受念住彼身耶。答应作四句。有修身念住非受。谓已得身念住现在前。以曾得法现在前时。无力能及未来故不修受念住。然现前是习修故说修身念住。问亦有未得身念住现在前不修受。如未曾得闻思所成身念住现在前时。此中何故不说。答应说而不说者当知此义有余。有说。此中依修所成念住而作论。无有未得修所成身念住现在前时不修受念住者是故不说。有修受念住非身。谓已得受念住现在前。若未得受念住现在前不修身。若未得心法念住现在前修受非身。已得受念住现在前者如前释。未得受念住现在前不修身者。谓诸异生离空无边处乃至无所有处染。若以受念住为加行。彼加行道时若诸异生起受念住无色解脱时。于如是时未得受念住现在前修受非身。未得心念住现在前修受非身者。谓诸异生离空无边处乃至无所有处染。若以心念住为加行。彼加行道时若诸异生起心念住无色解脱时。于如是时未得心念住现在前修受非身。未得法念住现在前修受非身者。谓诸异生离第四静虑染最后解脱道时。离空无边处乃至无所有处染。若依下根本地起法念住为加行。彼加行道时若依上近分地为加行。诸有欲令无色近分有别缘者。若以法念住为加行。彼加行道九无间道九解脱道时。诸有欲令无色近分唯总缘者唯第九解脱道时。若诸异生起法念住无色解脱。及起后二遍处时。于如是时未得法念住现在前修受非身。有俱修谓未得身念住现在前。若未得受念住现在前修身。若未得心法念住现在前修身受。未得身念住现在前者。谓增长暖顶位身念住现在前。若离欲界乃至非想非非想处染。身念住为加行彼加行道时。若信胜解练根作见至。时解脱练根作不动。身念住为加行彼加行道时。若起不净观持息念身念住。初三解脱八胜处前八遍处引发神境天眼天耳通。起词无碍解时。若以身念住杂修静虑时。诸有欲令一切法是胜义者。彼起身念住义无碍解及身念住辩无碍解愿智边际定无色解脱入灭定想微细心时。于如是时未得身念住现在前修身受。未得受念住现在前修身者。谓增长暖顶位受念住现在前时。若离欲界乃至非想非非想处染。受念住为加行彼加行道时。若信胜解练根作见至。时解脱练根作不动。受念住为加行。彼加行道时若引发他心通受念住现在前时。若以受念住杂修静虑时。诸有欲令一切法是胜义者。彼起受念住义无碍解及受念住辩无碍解。愿智边际定无色解脱入灭定想微细心时。于如是时未得受念住现在前修身受未得心念住现在前修身受者。谓增长暖顶位心念住现在前时。若离欲界乃至非想非非想处染心念住为加行。彼加行道时若信胜解练根作见至。时解脱练根作不动。心念住为加行彼加行道时。若引发他心通心念住现在前时。若以心念住杂修静虑时。诸有欲令一切法是胜义者。起心念住义无碍解。及心念住辩无碍解愿智边际定无色解脱入灭定想微细心时。于如是时未曾得心念住现在前修身受。未得法念住现在前修身受者。谓初暖位缘三谛增长暖缘四谛法念住现在前时。若初及增长顶缘四谛法念住现在前时。若一切忍及世第一法时。若入正性离生苦集道现观各四心顷。若离欲界乃至非想非非想处染法念住为加行。彼一切加行无间解脱道时。若信胜解练根作见至。时解脱练根作不动。法念住为加行。彼一切加行无间解脱道时。若引发他心通法念住现在前及引发宿住随念通起四无量时。若以法念住杂修静虑时。诸有欲令一切法是胜义者。彼起法念住义无碍解时。诸有欲令唯涅槃是胜义者。彼起义无碍解法无碍解无诤。后二遍处空空无愿无愿无相无相时。若起法念住辩无碍解愿智边际定无色解脱入灭定想微细心时。于如是时未得法念住现在前修身受。有俱不修。谓已得心法念住现在前。若未得法念住现在前。不修身受一切染污心。无记心在无想定灭尽定生无想天。已得心法念住现在前者如前释。未得法念住现在前不修身受者。谓初暖位缘灭谛若入正性离生灭现观四心顷。若诸异生离第四静虑乃至无所有处染。诸有欲令无色近分唯总缘者。若上地近分为加行彼一切加行道九无间道八解脱道时。于如是时未得法念住现在前。不修身受。一切染污心者。谓染污心皆顺退分性沉重懈怠相应。要顺胜进性轻举精进相应。心方能修故。无记心者。谓无记心其性羸劣腐败萎歇要住强势坚胜之心方能修故。在无想定灭尽定者。谓彼无心要有心者方能修故。生无想者。有说。生彼于一切时善心不起。有说。虽起而非修所依以不能修未来法故。于如是时不修身受。问亦有未得心念住现在前不修身受。如未曾得闻思所成心念住现在前时。此中何故不说。答应说而不说者当知此义有余。有说。此中说未曾得念住现在前时。能修未来而不修身受者。无未曾得心念住现在前时。能修未来而不修身受者是故不说。问若尔亦应说一切散善心何故但说染污心无记心耶。答应说而不说者当知此义有余。有说。彼不决定难用称说。谓若以修言之则彼无力能修未来。若以不修言之则现前时是习修摄。是故于此修不修中皆不说。彼如身念住受念住。应知身念住心念住亦尔。以未来受念住心念住修不修必俱故

若修身念住彼法耶。设修法念住彼身耶。答应作四句。有修身念住非法。谓已得身念住现在前此如前释。有修法念住非身。谓已得法念住现在前。若未得法念住现在前不修身。若未得受心念住现在前修法非身。已得法念住现在前者如前释。未得法念住现在前不修身者。谓初暖位缘灭谛。若入正性离生灭现观四心顷。若诸异生离第四静虑染。诸有欲令空无边处近分唯总缘者。若以彼为加行彼加行道九无间道九解脱道时。若诸异生离空无边处乃至无所有处染。以法念住为加行彼一切加行无间解脱道时。若诸异生起法念住无色解脱。及起后二遍处时。于如是时。未得法念住现在前不修身。未得受念住现在前修法非身者。如前未得受念住现在前不修身说。未得心念住现在前修法非身者即如受说有俱修。谓未得身念住现在前。若未得法念住现在前修身。若未得受心念住现在前修身法。未得身念住现在前者如前未得身念住现在前说。未得法念住现在前修身者如前未得法念住现在前修身受说。未得受心念住现在前修身法者。谓增长暖顶位受心念住现在前时。若离欲界乃至非想非非想处染。受心念住为加行彼加行道时。若信胜解练根作见至。时解脱练根作不动。受心念住为加行彼加行道时若引发他心通受心念住现在前时。若以受心念住杂修静虑时。诸有欲令一切法是胜义者。彼起受心念住义无碍解。及受心念住辩无碍解愿智边际定无色解脱入灭定想微细心时。于如是时未得受心念住现在前修身法。有俱不修。谓已得受心念住现在前一切染污心无记心在无想定灭尽定生无想天皆如前释

若修受念住彼心耶。设修心念住彼受耶。答应作四句。有修受念住非心。谓已得受念住现在前。有修心念住非受。谓已得心念住现在前皆如前释。有俱修谓未得身受心念住现在前。若未得法念住现在前修受心。未得身念住现在前者如前诸未得身念住现在前说。未得受心念住现在前者如前诸未得受心念住现在前说。未得法念住现在前修受心者如前诸未得法念住现在前修余念住说。有俱不修谓已得身法念住现在前。若未得法念住现在前不修受心。一切染污心无记心在无想定灭尽定生无想天。未得法念住现在前不修受心者。如前诸未得法念住现在前不修余念住说余如前释

若修受念住彼法耶。设修法念住彼受耶。答应作四句。有修受念住非法。谓已得受念住现在前此如前释。有修法念住非受。谓已得法念住现在前。若未得法念住现在前不修受。已得法念住现在前者如前释。未得法念住现在前不修受者。如前诸未得法念住现在前不修余念住说。有俱修谓未得身受心念住现在前。若未得法念住现在前修受。未得身念住现在前者。如前诸未得身念住现在前说。未得受心念住现在前者如前诸未得受心念住现在前说。未得法念住现在前修受者。如前诸未得法念住现在前。修余念住说。有俱不修谓已得身心念住现在前。一切染污心无记心在无想定灭尽定生无想天。皆如前释。如受念住法念住应知。心念住法念住亦尔。以未来受念住心念住修不修必俱故

于身循身观念住当言法智。乃至广说。问此文应先修而说。所以者何。以有自性乃可修故而不先说者有何意耶。答阿毗达磨应以相求不以次第。以阿毗达磨正欲分别诸法性相但不违其义。若先若后说皆无失。有余师说。欲显此中唯分别修所成念住非闻思所成等故。先说修后明自性。于身循身观念住当言法智。谓知欲界系及一分无漏色当言类智。谓知色界系及一分无漏色。不说他心智者他心智知心心所。法身念住唯知色法故。当言世俗智。谓知一切色当言苦智。谓知有漏色作非常苦空非我行相当言集智。谓知有漏色作因集生缘行相。不说灭智者灭智唯知无为法身念住。知有为法故当言道智。谓知无漏色作道如行出行相。此中不说。尽无生智者以此是见蕴但说诸见性智。彼智非见性是故不说。显自性已当显地。当言有寻有伺。谓依未至初静虑当言无寻唯伺。谓依静虑中间当言无寻无伺。谓依上三静虑及四无色。显地已当显相应。当言乐根相应。谓依第三静虑当言喜根相应。谓依初及第二静虑。当言舍根相应。谓依未至静虑中间第四静虑及四无色。显相应已当显行相。当言空三摩地俱。谓二行相当言无愿三摩地俱。谓十行相不说无相三摩地俱者如不说灭智说。显行相已当显所缘当言缘欲色界系。谓缘苦集。当言缘不系谓缘道。于受循受观念住当言法智。谓知欲界系及一分无漏。受当言类智。谓知色无色界系及一分无漏。受当言他心智。谓知欲色界系及一分无漏他相续现在前。受当言世俗智。谓知一切。受当言苦智。谓知有漏。受作非常等四行相。当言集智谓知有漏。受作因等四行相。不说灭智者以受念住唯知有为法故。当言道智谓知无漏。受作道等四行相。不说余智者如前释。显自性已地相应行相皆如前说。当显所缘。当言缘三界系。谓缘苦集。当言缘不系。谓缘道如于受于心亦尔。此一所缘常相应故于法修法观念住当言法智。谓知欲界系诸行及彼因彼灭彼一切法智品。当言类智谓知色无色界系诸行及彼因彼灭彼一切类智品。当言他心智谓知欲色界系及一分无漏他相续现在前。除受及心余心所法当言世俗智。谓知一切法当言苦智。谓知五取蕴作无常等四行相。当言集智谓知有漏因作因等四行相当言灭智。谓知择灭作灭等四行相当言道智。谓知无漏五蕴作道等四行相不说余智者亦如前释。显自性已。地相应如前说。当显行相当言空无愿三摩地俱亦如前释。当言无相三摩地俱。谓四行相显行相已当显所缘。当言缘三界系。谓缘苦集。当言缘不系。谓缘灭道

如说受乐受时。如实知我受乐受。此四智。乃至广说。问何故此中再度分别受心法念住。一度分别身念住耶。答彼作论者意欲尔故。乃至广说。有说。此中世尊亦应作是说。彼行住等时如实知我行住等此四智。乃至广说。而不说者有何意耶。答若法微细难见难觉不明了。不现见者则重分别身念住粗显。乃至现见故不重说。有说。若依彼起种种不相似异相文句。及异相智者则重分别身念住。若分别时文句不异智亦不异故不重说。问受乐受时则不如实知。如实知时则不受乐受。所以者何。受乐受时彼受在现在非尔时能如实知。不知相应故无二心品俱行故。如实知时彼受在过去未来。非尔时名受乐受无作用故。苦受不苦不乐受说亦尔。佛何故说受乐受时如实知我受乐受等耶。有说。此中应作是说。受乐受已如实知我已受乐受受苦受不苦不乐受已如实知我已受苦受不苦不乐受。而不作是说者有何意耶。应知此中说已受名受于过去说现在声。如说大王从何方来。此说已来名来。又如说菩萨入正性离生时得现观边世俗智。此说已入名入彼亦如是。尊者世友说曰。诸受在过去未来时则不可受。在现在时唯自性转亦不可受。云何说受乐受苦耶。当知彼观乐苦众具相续而说。谓观乐具相续言我受乐。观苦具相续言我受苦。复次彼观乐苦因缘相续而说。谓观摄受因缘相续言我受乐。观损害因缘相续言我受苦。复次彼于诸受相续转时中间数起彼境意识。便谓此于所依为益为损故言我今受乐受苦。大德说曰。彼于乐苦受所依大种相续转中谓之为受故言我今受乐受苦

如说受乐受时如实知我受乐受。此四智谓法类世俗道。问何故此中不说他心智。答他心智知他相续心心所法。此中如实智知自相续心心所法是故不说。复次他心智知现在心心所法。此中如实智知过去心心所法。复次他心智但知心心所法。此中如实智亦知心心所法所依所缘。复次他心智一一法缘。此中如实智亦多法总缘以是故不说他心智。问此中复何故不说苦集智耶。有说。此中亦应说苦集智而不说者当知此义有余。有说。苦集智是厌行相智。此中如实智是欣行相智是故不说。有说。苦集智缘所厌事。此中如实智缘所欣事。有说。苦集智憎恶所缘而转。此中如实智爱乐所缘而转。有说。此中说如实知有漏无漏心心所法。然有漏心心所法无始数知。又粗近易了起世俗智则能了知不待起无漏智。是故无有舍世俗智而以苦集智知者。无漏心心所法昔来未知。又微细难了起无漏智乃能知之。是故此中如实知有漏心心所法。唯世俗智如实知无漏心心所法。谓余三智由此不说有苦集智。有说。此中说如实知有漏无漏心心所法事差别相。彼有漏者。起世俗智则知更不起苦集智以难起故。及起时但知总相故。彼无漏者起世俗智不能知故便起道智。然道智生虽不如前唯差别知。然以总相知差别事故有道智无苦集智。有说。此中说。如实知有漏无漏心心所法行相差别。然有漏心心所法多非缘谛行相。设所有者亦未善成就故。但以世俗智作非谛行相。如实知其行相差别。无漏心心所法皆是缘谛行相极善成就故。还以道智作谛行相如实知其行相差别。是故此中无苦集智不说尽无生智者。此是见蕴但说诸见性智。彼非见性智是故不说。此中法智者。谓知法智品乐受。类智者。谓知类智品乐受。世俗智者。谓知有漏乐受。道智者。谓知无漏乐受。虽无一乐受四智所知。谓有漏者一智知。无漏者三智知。然以总说故言四智如实知乐受。有说。无漏乐受四智所知。受苦受时如实知受苦受此一智谓世俗。以苦受唯有漏故世俗智知。受不苦不乐受时如实知受不苦不乐受。此四智谓法类世俗道。如知乐受说

说一切有部发智大毗婆沙论卷第一百八十九阿毗达磨大毗婆沙论卷第一百九十

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    见蕴第八中念住纳息第一之四

受乐身受苦身受不苦不乐身受。及苦心受时如实知。此一智谓世俗一切身受及苦心受唯有漏故。起世俗智则如实知受乐心受不苦不乐心受时此四智。谓法类世俗道此二心受通有漏无漏故。以四智知广释如上。问此中何者名身受何者名心受耶。答若受在五识身名身受。在意地名心受。复次若受无分别名身受。有分别名心受。复次若受取自相境名身受。取自共相境名心受复次若受取现在境名身受。取三世及非世境名心受。复次若受取事别境名身受。取事别及和合境名心受。复次若受一堕境者名身受。数数堕境者名心受。复次若受于境率尔转者名身受。思度转者名心受。复次若受以色为所依色为所缘者名身受

以非色为所依色非色为所缘者名心受

如色非色。如是有对无对积聚非积聚和合不和合广说亦尔。尊者世友说曰。如佛所说。彼于尔时受于二受。谓身受心受。云何身受。云何心受。答无有受是身受一切受皆是心受。所以者何。心相应故。然诸受若依五根转此受名身受。恒以身为增上故。若依意根转此受名心受。恒以心为增上故。复作是说。无有受是身受。一切受皆是心受心相应故。然诸受依取至境三根转此受名身受恒作想故。依取不至境三根转此受名心受不恒作想故。大德说曰。若是身受彼亦心受耶。答若是身受彼亦心受。有是心受而非身受。谓若计度外事于内取相及于事取补特伽罗并法处所摄色。心不相应行无为相。如此类受皆名心受。以于非实有境分别转故。是谓身受心受差别

受乐有味受。苦有味受。不苦不乐有味受。及苦无味受时如实知。此一智。谓世俗。以一切有味受及苦无味受皆有漏故。起世俗智则如实知。受乐无味受不苦不乐无味受时如实知。此四智谓法类世俗道。此二无味受通有漏无漏故以四智知。广释如上。此中味者是爱味着性故。若受与彼为安足处名有味受。有说。味名一切烦恼取着性故。若受与彼为安足处名有味受。若受不与爱或一切烦恼为安足处名无味受。问若尔者则一切苦受皆名有味。皆能与爱或一切烦恼为安足处故。又如品类足说。云何有味法。谓有漏法。云何无味法谓无漏法。何故此中说有苦无味受耶。答苦受虽有漏而有少无味依性依彼故说苦无味依受。谓彼有与烦恼相违及与烦恼不相杂性。有余师说。苦受虽皆是有漏而有能引发随顺胜义无味无漏受者。依彼故说苦无味受。以能暂时伏诸味故

受乐耽嗜依。受苦耽嗜依。受不苦不乐耽嗜依。受及苦出离依。受时如实知。此一智谓世俗。以一切耽嗜依。受及苦出离依受皆有漏故。起世俗智则如实知受乐出离依。受不苦不乐出离依受时如实知此四智。谓法类世俗道如前释。此中耽嗜谓爱耽着性故。若受与彼为安足处名耽嗜依受。有说。耽嗜名一切烦恼执着性故。若受与彼为安足处名耽嗜依受。苦受不与爱或一切烦恼为安足处名出离依受。问若尔一切苦受皆应名耽嗜依。皆能与爱或一切烦恼为安足处故。又如品类足说。云何耽嗜依法谓有漏法。云何出离依法谓无漏法。何故此中说有苦出离依受耶。答苦受虽有漏而有少出离依性。依彼故说苦出离依受。谓彼有与烦恼相违及与烦恼不相杂性。有余师说。苦受虽皆是有漏而有能引发随顺胜义出离依无漏受者。依彼故说苦出离依受以能暂时伏诸耽嗜故

如说有贪心如实知有贪心。乃至广说。有二义故。心名有贪一贪相杂故。二贪所系故。有说。此中依相杂有贪而作论。有说。此中依二种有贪而作论。所以者何。若唯依相杂有贪而作论者则有漏善。及无覆无记心等应亦名离贪心。然彼亦是有贪心贪所系故。如有贪心应知有嗔心等亦尔。此中贪所系故名有贪心。贪对治故名离贪心。如是说者好。谓贪所系故名有贪心。贪对治故名离贪心。若说贪相应故名有贪心。贪不相应故名离贪心者则贪不相应余烦恼相应心等应名离贪心。然彼亦是有贪心贪所系故。若说贪相应故名有贪心。贪对治故名离贪心者。则贪不相应染污心及无覆无记一分善心。应非有贪心亦非离贪心。然彼亦是有贪心贪所系故。有贪心如实知有贪心。此一智谓世俗智。离贪心如实知离贪心。此四智谓法类世俗道皆如前释。嗔所系故名有嗔心。嗔对治故名离嗔心广说如贪。有嗔心如实知有嗔心。此一智谓世俗如前释。离嗔心如实知离嗔心。此三智谓法世俗道。此中依近对治说故不说类智。以类智品道非欲界近对治故余如前释。痴所系故名有痴心。痴对治故名离痴心。如是说者好。谓痴所系故名有痴心。痴对治故名离痴心。若说痴相应故名有痴心。痴不相应故名离痴心者。则无覆无记一分善心。亦应名离痴心。然彼亦名有痴心痴所系故。若说痴相应故名有痴心。痴对治故名离痴心者。则无覆无记一分善心应非有痴心。亦非离痴心。然彼亦是有痴心痴所系故。有痴心如实知有痴心。此一智谓世俗。离痴心如实知离痴心。此四智谓法类世俗道如前释。染心者谓染污心烦恼相应故。不染心者谓善心烦恼相违故。有说。善心无覆无记心皆名不染心烦恼不相应故。染心如实知染心此一智谓世俗。不染心如实知不染心。此四智谓法类世俗道如前有痴离痴心释。略心者。谓善心于所缘略摄故。散心者谓染污心于所缘驰散故。略心如实知略心。此四智谓法类世俗道。散心如实知散心此一智谓世俗。此随所应如前释。迦湿弥罗外诸师言。略心者谓眠相应心以说心略名眠故。如说眠云何。谓眠者所有眠梦不能持身心略为性。问若尔者。此中所说云何通。如说略心如实知略心此四智。乃至广说。答此文应作是说。略心散心下心如实知略心散心下心此一智谓世俗。举心如实知举心此四智如前说。评曰。彼不应作是说。若作是说则染污眠相应心应亦名略心眠相应故。亦名散心以染污故。由此应知前说者好。下心者谓染污心懈怠相应故。举心者谓善心精进相应故。下心如实知下心此一智谓世俗。举心如实知举心此四智谓法类世俗道如前释。小心者谓染污心小生所习故。大心者谓善心大生所习故。问今现见无量有情作恶。少有情习善。云何染心小生所习耶。答此中不以类少名小。但以净法少故名小。谓若净法少生之所习者名小心。净法多生之所习者名大心。是故遍生死海中唯佛多修善法而名为大。非一切有情。有说。染污心小价得故名小。善心大价得故名大。以染污心因少所为便起无量非理作意。令烦恼恶行起如河流。善心不尔。虽舍百千珍宝或有能起或有不能起者。有说。染污心少根故名小。善心多根故名大。谓染污心或唯一根或复至二善心。一切皆具三根。有说。染污心少随转故名小。善心多随转故名大。谓染污心唯三蕴随转。善心或三蕴或四蕴随转。有说。染污心少眷属故名小。善心多眷属故名大。谓染污心无未来修故。善心有未来修故。有说。染污心少对治故名小。善心多对治故名大。如一刹那苦法智忍生。能顿永断欲界见苦所断十随眠等。此一力胜非彼一切如一力士能伏千人。而无一刹那染污心生有此势力。复次染污心中所有上首阙于眼足。彼上首者则是无明。如说无明为上首为前因故生无量种恶不善法。及彼种类无惭无愧善心中所有上首具有眼足彼上首则是明。如说明为上首为前因故。生无量种善法及彼种类惭愧。复次无始时来所习不善法。暂时习善则令永断。犹如室中多时积闇。灯明暂照则便除遣。如于多时习无盐想暂尝盐时彼想便舍。此亦如是。不善断善无如是事。复次善于不善能毕竟伏。或毕竟断。不善于善则不如是。由此等缘染污心名小善心名大。小心如实知小心此一智谓世俗。大心如实知大心此四智谓法类世俗道皆如前释。掉心者谓染污心掉举相应故。不掉心者谓善心奢摩他相应故。掉心如实知掉心。此一智谓世俗。不掉心如实知不掉心此四智谓法类世俗道皆如前释。不寂静心者。谓染污心恒喧动故。寂静心者谓善心背喧动故。不寂静心如实知不寂静心此一智谓世俗。寂静心如实知寂静心。此四智谓法类世俗道皆如前释。不定心者。谓染污心散乱相应故。定心者谓善心背散乱故。不定心如实知不定心此一智谓世俗。定心如实知定心此四智谓法类世俗道皆如前释。不修心者谓于得修习修俱不修心。修心者谓于得修习修或俱或随一修心。不修心如实知不修心此一智谓世俗。修心如实知修心此四智谓法类世俗道皆如前释。不解脱心者。谓于自性解脱相续解脱俱不解脱心。解脱心者谓于自性解脱相续解脱。或俱或随一解脱心。不解脱心如实知不解脱心此一智谓世俗。解脱心如实知解脱心此四智谓法类世俗道皆如前释

如说有内贪欲盖。乃至广说。此圣教中内有二种。一内处摄故名内。如说此六内处。乃至广说。二自相续摄故名内。如说于内身循身观。乃至广说。此中依相续内而作论不依处内。所以者何。若依处内而作论者。则不应言有内贪欲盖等。以贪欲盖等皆是外法处摄故。然彼虽是外处而以自相续摄故说名为内。如说有内贪欲盖。如实知有内贪欲盖。此一智谓世俗。此中有者谓自相续中贪欲盖现行可得。或未离彼得获成就。或彼对治道未生。此一智者以有漏故起世俗智。则如实知无内贪欲盖。如实知无内贪欲盖。此三智谓法世俗道。此中无者谓自相续中贪欲盖非现行可得。或已离彼得获成就。或彼对治道已生。此三智者谓贪欲盖唯欲界故。彼近对治非类智品。如未生内贪欲盖而生。如实知此一智谓世俗。此中未生而生者。谓由彼彼因彼彼缘内贪欲盖生。此一智者如前释。生已便断断已后不复生。如实知此三智谓法世俗道。此中生已便断者。谓彼对治道已生贪欲盖断。断已后不复生者。谓或毕竟不生。或乃至未退彼对治道。此三智者如前释。如贪欲盖应知嗔恚惛沉睡眠掉举恶作疑盖亦尔。以彼皆是欲界系故

如说有内眼结。如实知有内眼结此一智谓世俗。此中亦依相续内而作论。不依处内。广说如前所说。有者亦谓自相续中眼结现行可得。或未离彼得获成就。或彼对治道未生。此一智者如前释。无内眼结如实知无内眼结。此四智谓法类世俗道。此中无者亦谓自相续中眼结非现行可得。或已离彼得获成就。或彼对治道已生。此四智者谓内眼结欲色界系故。彼近对治通法类智品。如未生内眼结而生如实知。此一智谓世俗。此中未生而生者。谓由彼彼因彼彼缘内眼结生。此一智者如前释。生已便断断已后不复生。如实知此四智谓法类世俗道。此中生已便断者。谓彼对治道已生内眼结断。断已后不复生者。谓或毕竟不生。或乃至未退彼对治道。此四智者如前释。如眼结应知耳身意结亦尔。彼近对治俱通法类智品故。鼻舌结如盖说。皆唯欲界系故。如说有内念等觉支。如实知有内念等觉支。此四智谓法类世俗道。此中有者谓自相续中念等觉支现行可得。或已有彼得获成就。或彼所对治障已断。此四智者。有说。此中真实念等觉支三智知谓法类道智。相似念等觉支一智知谓世俗智。有说。此中唯说真实念等觉支则此为四智知。谓世俗智不明了知。法类道智明了知。无内念等觉支如实知无内念等觉支。此一智谓世俗。此中无者谓自相续中念等觉支非现行可得。或未有彼得获成就。或彼所对治障未断。一智者如前说。如未生念等觉支而生。生已住不忘令圆满倍增广智作证。此四智谓法类世俗道。此中未生而生者谓由彼彼因彼彼缘内念等觉支生。生已住不忘等者。问如尔所生则尔所灭。刹那后必不住如何可说生已住不忘等耶。答此中说二种善根。谓顺住分及顺胜进分。生已住不忘者说顺住分善根。生已令圆满倍增广者说顺胜进分善根。四智者如前释。如念等觉支应知择法精进喜安定舍等觉支亦尔。以种类同故。问喜等觉支则是受。前受念住中已观。今何故重观察耶。答前以受念住门观察。今以法念住门观察。复次前独观察。今与余觉支观察。复次前观察彼自相。今观察彼共相。复次前观察有漏无漏。今观察无漏。有说。此中亦观察有漏无漏。以通观察真实及相似觉支故

如说等随观自贪嗔痴增。乃至广说。问何故作此论。答为欲分别佛经义故。如契经说。诸苾刍苾刍尼等随观自贪增时。彼应知退诸善法佛说名退嗔痴亦尔。契经虽作是说而不广分别。云何贪增乃至痴增。彼经是此论所依根本。彼所不分别者今应分别故作斯论。云何贪嗔痴增。答有下贪嗔痴缠故中。有中。故上是谓增。此中有说。依世所现见贪嗔痴增而作论。贪增者如诸男子于童子位起下贪缠。于少年位起中贪缠。于盛年位起上贪缠。于彼妻亦尔。嗔增者如诸男子展转斗诤。未发粗语起下嗔缠。发粗语时起中嗔缠。结憾谋害起上嗔缠。痴增者如有男子生外道家。未学彼书论起下痴缠。学而未达其义起中痴缠。若究竟通达起上痴缠。有说。此中依观待道理而作论。谓观下品贪缠故施设中。观中故施设上。嗔痴亦尔。有说。此中依退作论。谓从下品贪缠退故中。从中退故上。嗔痴亦尔

如说等随观自贪嗔痴减。乃至广说。问何故复作此论。答欲分别即前经中余所说义故。如彼说。诸苾刍苾刍尼等随观自贪减时。彼应知不退善法。佛说名不退嗔痴亦尔。彼经虽作是说而不广分别。云何贪减乃至痴减。彼经是此论所依根本。彼所不说者今悉应说故作斯论。云何贪嗔痴减。答无上贪嗔痴缠故中。无中故下是谓减。有说。此中依世所现见贪嗔痴减而作论。贪减者如诸男子。于盛年位起上贪缠。于中年位起中贪缠。于老年位起下贪缠。于彼妻亦尔。嗔减者如诸男子展转结憾相谋害时起上嗔缠。为兴斗诤遣使往返起中嗔缠。正斗诤时起下嗔缠。痴减者如诸男子。生外道家学彼书论。已通达时起上痴缠。若闻佛语心中住时起中痴缠。若于佛语少生信时起下痴缠。有说。此中依观待道理而作论。谓观上品贪缠故施设中。观中故施设下。嗔痴亦尔。有说。此中依离染作论谓上品贪缠减故中。中减故下

云何死边际受。乃至广说。问何故作此论。答为欲解释契经义故。如契经说。阿难陀当知昔有转轮王名曰善见。有如是类死边际受。犹如壮士多食美食须臾迷闷。又契经说。我今已生猛利损害死边际受。契经虽作是说而不分别。云何死边际受。齐何当言死边际受。乃至广说。故作斯论。有说。所以作论者为止世间于非死边际受。起死边际受想故。如世间说。我已受死边际受。今受当受彼于非死边际受起死边际受想。所以者何。若受此受不久便命终者乃名死边际受故。云何死边际受。答由此末摩断命根灭。问此受何故名死边际耶。答由此引至死边际位故名死边际受。问若尔应说最后受名死边际受。不应说由此末摩断。所以者何。末摩断已或经昼夜方命终故。答则断末摩受亦名最后受。以断末摩后不久必命终故。有说。一众同分中有二种受。一身受。二心受。断末摩受是身受。最后命根灭受是心受。最后

齐何当言死边际受。答齐此末摩断命根灭。问何故复作此论。答前说死边际受自性。而未显位今欲显之故作斯论。死边际受何处摄。答法处。几识相应。答身识意识。谓初末摩断受身识相应。最后受意识相应。问几大种能断末摩。答三谓水火风。问何故地大种不能断末摩。答非田非器。乃至广说。有说。猛利大种能断末摩地大种不猛利。有说。若诸大种能坏。外分能为外灾彼亦能坏内分能断末摩地大种不能坏外分不能为外灾故。亦不能坏内分不能断末摩。此中水大种断末摩者。谓将死时于内身中。水界增盛。由此浸渍令一切筋烂。诸筋烂故支节解。支节解故不久命终。火大种断末摩者。谓将死时于内身中火界增盛。由此烧逼令一切筋燋。诸筋燋故支节解。支节解故不久命终。风大种断末摩者。谓将命终时于内身中风界增盛。由此鼓击令一切筋碎。诸筋碎故支节解。支节解故不久命终。亦有欲令地大种能断末摩。彼作是说。将命终时。身中地界增盛能令一切窍穴闭塞。诸穴塞故支节解。支节解故不久命终。问何处有断末摩。答在欲界非色无色界。于欲界中地狱无断末摩以恒断故。傍生饿鬼有断末摩。人中三洲非北拘卢洲。欲界诸天亦无断末摩。彼非恼乱业果故

问何等补特伽罗有断末摩。答异生圣者皆有。于圣者中预流一来不还阿罗汉独觉皆有。唯除世尊无恼乱业故。诸佛世尊无断末摩。声音不坏无渐命终。以佛世尊诸根顿灭故。或阿罗汉有断末摩。非屠羊人等。以断末摩是恼乱业果。故若有恼乱业者虽阿罗汉而断末摩。若无恼乱业虽屠羊人等亦无断末摩事

问末摩中间云何安布。答象马牛等诸大力兽末摩中间骨节相拄而复坚固。大诺健那骨节相接。犹如接版钵罗塞建提骨节相钩。如铁钩相钩。那罗延身骨节连锁犹如铁锁。佛身骨节展转盘结犹如盘龙。诸余有情骨节相离而不坚固。是故彼类其力最劣

说一切有部发智大毗婆沙论卷第一百九十阿毗达磨大毗婆沙论卷第一百九十一

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    见蕴第八中念住纳息第一之五

阿罗汉般涅槃心当言善耶无记耶。答当言无记。问何故作此论。答欲令疑者得决定故。谓阿罗汉已断不善法成就善法。或有便疑。若尔阿罗汉应住善心而般涅槃。欲令此疑得决定故。明阿罗汉虽断不善法成就善法。然住无记心而般涅槃非善。若先不作此论者则乃至于今若作是问。阿罗汉般涅槃心当言善耶无记耶。彼不解故。或作是答。是善非无记。以阿罗汉已断一切不善法成就善法故。由先作此论故。乃至于今皆得正解。由是因缘故造斯论。问何故阿罗汉唯住无记心而般涅槃。答唯无记心顺心断故。谓善心强盛坚住难坏能令余心长时续起。于心断不顺。无记心羸劣如朽败种不坚住易坏。不能令余心长时续起故。于心断最为随顺。有说。以无记心起过患少故。谓善不善心由二门于生死中起多过患。一由异熟果门。二由等流果门。无记心但由等流果门起过患非异熟果。有说。以阿罗汉背一切生故。谓余有情将命终时为当生故极作意力。令善心起。勿我当堕诸非爱趣。阿罗汉背一切生故不复作意。但住无记心而般涅槃。有说。以阿罗汉不求趣异熟器故。谓余有情求趣当来异熟器故将命终时以极加行令善心起。阿罗汉不求趣如是异熟器故但住无记心而般涅槃。有说。阿罗汉住自性心入于涅槃。自性心者则无记心。以生生中未尝无故。或有一众同分中无善心起。谓已断善根未相续者。或有一众同分中无不善心起。谓已离欲界染者。无有一众同分中不起无记心者。是以说无记心名自性心。唯住此心入于涅槃。有说。阿罗汉要住如上亲友心而涅槃故。如人欲适他土亲友追送其下亲友至门而返。中至村界上至国境。如是阿罗汉趣涅槃时不善染污心如下亲友。于离欲界及非想非非想处染时即便舍离。善心如中亲友。于起无记心时而便舍离。无记心如上亲友。于般涅槃时乃便舍离。有说。此是阿罗汉渐舍生死法故。谓离欲界染时舍一切不善心。离非想非非想处染时舍一切染污心。起无记心时舍一切善心。入无余依涅槃时舍一切无记心。尊者妙音说曰。一切善心皆是作功用起将命终时不能复作功用。是故唯住无记心而般涅槃

问阿罗汉最后心为何所缘耶。有说。缘自身中诸根大种。有说。缘内六处。有说。缘外六处。有说。缘十二处。尊者说曰。阿罗汉最后心为何所缘。答缘自身彼于自身作无命离命者想。空解脱门现在前而般涅槃。有说。彼心缘一切行以于诸行深见过失。无愿解脱门现在前而般涅槃。有说。彼心缘涅槃以于涅槃观寂静功德。无相解脱门现在前而般涅槃。应知此中依阿罗汉相续命终心说。非刹那最后心以彼心唯无记故。大德说曰。阿罗汉最后心缘所见闻觉知境。以彼心是异熟生自体所摄。由先业行尽故自然断灭。如陶家轮势极则止

何故双贤弟子先般涅槃然后佛耶。答彼二尊者先长夜中造作增长感无断业勿空无果异熟故。由二因缘彼二尊者求如是处发起此业。一以见为先故。二以闻为先故。见为先者彼二尊者过去曾见先三藐三佛陀双贤弟子先般涅槃然后彼佛。闻为先者彼二尊者过去曾闻先三藐三佛陀双贤弟子先般涅槃然后彼佛。既见闻已而便引起随顺彼因。诸我所行若戒若禁苦行梵行一切回向。愿我未来得作如斯善士行类。恒与大师现受法乐而无间断。若佛先般涅槃然后双贤弟子者。则彼所造作增长感无断业应空无果异熟。问一切造作增长感无断业无如佛者。若双贤弟子先般涅槃则佛感无断业便空无果异熟。岂双贤弟子感无断业于佛为胜耶。答弟子于师有二种受用胜。一财受用。二法受用。师于弟子有一种受用胜。谓财非法。然造作增长感无断业但为法故非为财故是以无前过失。问双贤弟子中般若胜者复先涅槃非神通胜者。神通胜者于彼既失法受用义。云何非感无断业空无果异熟耶。答般若胜者无如世尊。彼虽涅槃以世尊在故于法受用非空无果。复次由法尔故双贤弟子先佛般涅槃。何谓法尔。谓法应如是不可改易不可征诘是法尔义。此显一切诸佛双贤弟子法应先佛而般涅槃此理无异。有说。与转轮王相似法故。如转轮王欲往彼彼未至方域必令前军勇将先导而往。如是十力法转轮王欲往未至无余依涅槃界。亦令如前军勇将双贤弟子先导而往。有说。欲令所化有情入佛法故。谓有所化有情虽近佛而住尽众同分。不欲来诣佛所受行佛法。若见双贤弟子般涅槃时便于生死厌怖。来诣佛所受行佛法。有说。为解所化有情愁忧心故。谓若佛先般涅槃则无有能解所化有情愁忧心者。若双贤弟子先般涅槃则有如来能于雨四月中。依彼及自说无常教解彼愁忧令修胜行。有说。欲令所化有情于佛当般涅槃预系念住。故谓由双贤弟子先般涅槃。所化有情便作是念。佛亦不久当般涅槃。以双贤弟子已涅槃故。如天欲雷必先掣电。若不以电为先而震雷者则令怯弱。有情闻之惊慑或复致死。是故天欲雷时愍有情故先流电耀。彼既知已虚心待之。虽闻吒雷则无惊骇。如是若佛先般涅槃者则令一类于佛慕恋渴仰有情惊怛闷绝。若双贤弟子先涅槃者。则令彼类预起如来般涅槃想。至佛涅槃则无闷绝故。有颂言

  恒作无常想　　变坏则无忧
  如睹电为先　　闻雷不惊怖

有说。为息谤故。谓有外道恒谤佛言。沙门乔答摩摄受邬波底沙及俱履多故。夜从咨受昼为他说。若彼二人般涅槃已世尊说法不异先时则诸外道诽谤皆息。有说。为显世尊不久住世必当般涅槃故。如世界将欲坏时。苏迷卢山数为难陀邬波难陀二大龙王缠绕舍去。诸天见已即知世界不久当坏。如是尊者舍利子大目揵连先般涅槃。世便知佛不久灭度由如是等种种因缘故。双贤弟子先般涅槃然后佛灭

问何故具寿苏跋陀罗先般涅槃然后佛耶。答亦由法尔故。谓诸佛法尔最后弟子先般涅槃然后佛。问何谓法尔。答法应如是不可改易故名法尔。此显一切诸佛法应后最后弟子而般涅槃此理无异。有说。与转轮王相似法故。如转轮王欲入园苑胜地游戏。必以诸庄严具严饰最小王子令其先入然后自往。如是十力无上法王。将欲入如园苑胜地无余依涅槃界。亦先以菩提分法庄严最后弟子令先涅槃。然后自往。有说。尊者苏跋陀罗作是念。一切同梵行者皆在我前入有余依涅槃界。我当复在一切同梵行者前入无余依涅槃界。由其志愿故彼先佛而般涅槃。有说。彼尊者作是念。如受尔所圣教功德。还受尔所生死过患。我既不能领受圣教众多功德。何须久住领受生死众多过患。故彼先佛而般涅槃。有说。彼尊者怖畏多受利养恭敬故。谓拘尸城诸力士等先于彼尊者起大师想。复知彼得阿罗汉果。彼尊者作是念。若佛般涅槃后彼必于我大设供养。幸因佛未涅槃诸力士等供养世尊。未暇相及我当先佛而般涅槃。有说。彼欲断绝诤根本故。谓彼尊者作如是念。若我后佛般涅槃者。外道谓我是彼同类。诸苾刍复言是我同类。因此便兴种种斗诤。彼观未来有如是事是故先佛而般涅槃。有说。欲显世尊于最后位教化功德亦无减故。谓或有作是念。世尊功德退减而般涅槃故。彼尊者欲显世尊于最后位亦能教化有情令功德圆满。谓令入无余依涅槃界。由如是等种种因缘故彼先佛而般涅槃。如说世尊依不动寂静定而般涅槃世间眼灭。此为在定为出定耶。答出定。问何故作此论。答欲令疑者得决定故。谓契经说世尊依不动寂静定而般涅槃世间眼灭。或有疑佛在定而般涅槃。欲令此疑得决定故明佛出定而般涅槃故作斯论。此中不动寂静定者。谓有欲界无覆无记心相应定。似第四静虑故名不动寂静。佛依此而般涅槃。西方健驮罗国诸师作如是说。如说世尊入第四静虑而般涅槃世间眼灭。此为在定为出定耶。答出定。问佛具入四静虑而般涅槃何故但言入第四静虑耶。答虽亦入前三静虑而非坚着。若入第四静虑即便坚着故偏说之。有说。为入第四静虑故入前三静虑是故偏说第四。有说。前三静虑犹如在路第四静虑是正所往是以偏说。有说。佛将般涅槃时从第四静虑起入第三静虑近分。从第三静虑近分起入第二静虑近分。从第二静虑近分起入初静虑近分。从初静虑近分起欲界善心现在前。欲界善心无间欲界无覆无记心现在前。即住此心而般涅槃。以前三静虑但入出近分非根本。第四静虑入出根本是故偏说。尊者妙音说曰。佛将入涅槃时。第四静虑无间欲界善心现在前。欲界善心无间欲界无覆无记心现在前。则住此心而般涅槃。问岂有能从第四静虑无间则起欲界善心耶。答有。谓佛非余。问何故佛般涅槃时最后入第四静虑耶。答过殑伽沙数。如来应正等觉法皆如是。次第入定而般涅槃。谓一切佛般涅槃时最后法尔入第四静虑。从彼起已而般涅槃。有说。欲显佛于彼定极自在故虽将涅槃而犹现入。若不尔者应不能现前。有说。佛欲悲愍后世生故。谓佛灭后有诸众生当作是念。世尊具一切智临涅槃时尚入第四静虑。况我等不于诸等至中勤作加行耶。由此勤修一切等至。有说。与转轮王相似法故。如转轮王若先于此地灌顶而受王位。后即于此地而命终。如是十力无上法王先依第四静虑受法王位。后还依此地而般涅槃。有说。与大富商主相似法故。如富商主最后转易大价珍宝而无恋着。如是世尊最后弃舍殊胜第四静虑而无恋着。世尊临般涅槃时先起欲界善心。从此无间入初静虑。从初静虑入第二静虑。如是次第乃至从无所有处入非想非非想处。从非想非非想处无间入灭受想定。从灭受想定无间入无所有处。从无所有处入非想非非想处。从非想非非想处入识无边处。从识无边处入无所有处。从无所有处入空无边处。从空无边处入识无边处从识无边处入第四静虑。从第四静虑入空无边处。从空无边处入第三静虑。从第三静虑入第四静虑。从第四静虑入第二静虑。从第二静虑入第三静虑。从第三静虑入初静虑。从初静虑入第二静虑。从第二静虑入第三静虑。从第三静虑入第四静虑。从第四静虑起便般涅槃。如是世尊临涅槃时四度入第四静虑。前三入时未名不动寂静定。第四入时乃名不动寂静定。所以者何。前三入时不缘涅槃。第四入时乃缘涅槃故。问何故世尊临涅槃时不顺超入诸定。而但逆超入耶。答过殑伽沙数如来应正等觉法皆如是超入诸定。有说。欲显世尊于诸定得自在故。所以者何。若有于定得自在者。乃能不因顺超入而便逆超入。若于诸定不自在者尚不能顺超。况能逆超而入诸定。有说。欲显世尊能作难作事故。谓不顺超而能逆超入诸定者此事为难。非如顺超入已方逆超者。有说。欲显世尊威力大故。世尊威力乃能不顺超而逆超。声闻独觉若不顺超则不能逆超而入诸定。有说。为欲兼入灭尽定故。谓佛尔时若顺超入诸定者则无容入灭尽定。所以者何。以灭尽定要从渐次非想非非想处心无间现在前故。如是佛般涅槃时则不应现入一切静虑解脱等持等至。然佛般涅槃时决定现入一切静虑解脱等持等至。是故不顺超入诸定而逆超入诸定。问世尊何故临般涅槃现入一切静虑解脱等持等至耶。答过殑伽沙数如来应正等觉法皆尔故。谓一切佛临般涅槃法皆现入一切静虑等持等至。有说。欲显世尊于诸定得自在故。谓若于诸定得自在者临般涅槃时犹能现入。若于诸定不得自在余时尚不能现入况临般涅槃。有说。佛为悲愍后时诸有情故。谓佛般涅槃后有诸有情当作是念。世尊具一切智临般涅槃尚现入一切静虑解脱等持等至。况我等于彼不勤作加行耶。由此勤修静虑解脱等持等至。有说。为欲重修所留设利罗故。又为资养羸瘦身故。又为准陀工巧之子福田增广故。又为止息因碎身所生身中诸苦受故。有说。与大富商主相似法故。如巨富商主临命终时开诸库藏观阅财宝付嘱子孙然后舍命。如是世尊为无上正法商主。临涅槃时开功德库藏。观阅一切静虑解脱等持等至诸法财宝。付嘱弟子然后涅槃。尊者妙音说曰。世尊自显不退法故。谓佛成就一切功德于一切境智得自在临般涅槃。犹能现起一切静虑解脱等持等至。如契经说。世尊在拘尸城力士生处双娑罗林间而般涅槃。问世尊何故在拘尸城般涅槃耶。答为欲化度拘尸城中诸力士故。又为摄化外道苏跋陀罗故又为令大力士补羯娑。种独觉菩提种子故。又令彼妻种无上正等菩提种子故。有说。为止拘尸城中诸力士等被轻蔑事故。谓佛若于余大城中般涅槃者。此小城中诸力士等便被轻蔑。不得如来遗身一分故佛于此而般涅槃。有说。为广流布佛身界故。若佛于余大城般涅槃者彼诸人众难可摧伏。于佛身界或生保吝则不可分布。若拘尸城般涅槃者。诸力士等身心勇健心勇健故乐为分布。身勇健故不为他伏乐分布故。令佛身界广得流布。有说。欲显佛虽临般涅槃而于世间犹受增上富贵果故。谓佛若于诸余大城般涅槃者。则所受供养虽过轮王多百千倍未为奇特。若虽于此极小边城入于涅槃。而所受供养犹过轮王多百千倍乃为奇特。有说。佛曾于此数数舍身命故。如彼经说。佛告阿难乃至拘尸城有金河双娑罗林。诸力士冠增制多界分周匝正等十二踰缮那地。如来于此六返舍转轮王身命。今第七返舍如来应正等觉身命。阿难当知我不见于此地处。或东或南或西或北如来更舍第八身命。所以者何。如来诸有道断生死永尽无后有故

如说佛告阿难。汝应往双娑罗林间为佛敷设北首卧床。如来于今日中夜当于无依涅槃界而般涅槃乃至广说。问世尊何故令敷设北首卧床而卧耶。答欲显彼国论师法应尔故。谓彼国论师皆敷设北首床而卧。世尊亦尔。以佛能伏诸论师故即是无上第一。论师故令随彼敷设而卧。有说。欲显远离世所妄执吉祥事故。谓彼国死者乃令床上北首而卧。佛为破彼妄吉祥执是故未般涅槃则令敷设北首床而卧。有说。欲止拘尸城中诸力士等不净心故。谓彼国俗皆于北方建立天祠。若佛北足而卧者。即诸力士生不净心。云何欺蔑我等所事北足而卧。有说。为欲显佛恭敬正法故。谓佛预知般涅槃后无上法炬北方炽然久久不灭故于床上北首而卧。有说。佛欲显己于一切时所作渐胜故。谓佛三无数劫来所起善根。渐渐增胜无有萎歇故。令首趣胜方而卧。以北方是胜方故。有说。佛欲显北方人众渐增广故。谓佛预知般涅槃后北方人众渐渐增广故令敷设北首床而卧。如说尔时世尊趣所敷床右胁在下累足西面北首而卧。住光明想具念正知乃至广说。问世尊何故右胁而卧。答欲显佛如师子王而卧故。如契经说。卧有四种谓师子王卧天卧鬼卧耽欲者卧。师子王右胁而卧。天即仰面。鬼则伏面。耽欲者卧左胁着地。佛是无上人中师子故右胁而卧。有说。欲显世尊如说而作故。谓契经说。佛告阿难。汝等应学师子王卧。佛是如说而作者既劝人右胁而卧故自亦为之。问世尊何故卧般涅槃而不坐耶。答欲令大众于佛一切身分易了知故。有说。若佛卧涅槃者即身度量现可了知不待分别。有说。欲显如来离矫诳故。若佛坐涅槃者即不信者当作是言。此是矫诳何有死人而能端坐。有说。为止当来于诸圣者生诽谤故。若坐般涅槃者即于今时诸阿罗汉身力羸劣卧入涅槃。世便谤言非阿罗汉若是者何不同佛坐涅槃耶。有说。为断恃力者憍慢心故。谓彼见佛卧般涅槃咸作是念。世尊一一身分皆具那罗延力尚为无常所逼不能正坐。况我等辈凡下微弱而恃少力生憍慢耶

问世尊何故于中夜分而般涅槃。答以此时最寂静故。谓彼土暑热昼时不堪作务。多于初夜后夜分中作诸事业。唯中夜分一切寂然。如来恒时爱乐寂静赞美寂静故于中夜而般涅槃。有说。欲显佛于增减事善节量中不须臾舍离故。谓佛留初夜分命舍后夜分寿。复于中夜分中留前舍后于其中分而般涅槃。有说。佛欲令大众于生死黑闇起大厌怖故。谓佛于迦栗底迦月白半八日中夜而般涅槃。尔时月轮没于山顶。如是佛正遍知月亦隐静虑大涅槃山则时二种黑闇俱起。谓色性闇及无明闇。时诸大众睹斯事已。便于生死起大厌怖。故于中夜而般涅槃。有说。佛一切时乐处中行故。谓佛昔为菩萨时于最后天生中生处中睹史多天处。于最后人生中生中印度劫比罗筏窣堵城。于中夜分。踰城出家习处中行。证无上觉为益有情。说离有无处中妙法。于夜中分而般涅槃

如说尔时阿难白佛言。世尊。此拘尸城中有如是如是力士。并男女大小僮仆作使亲友眷属一切。归依世尊及法并苾刍僧。受诸学处乃至广说。问别解脱律仪由自表得。云何彼力士等所受戒由他表得耶。答佛神力故谓戒皆由自表而得。然佛临涅槃时以佛威力令力士等戒亦由他表而得。有说。尊者阿难先曾入拘尸城已授诸力士等三归学处。今但白佛令知欲显诸力士等是佛真实弟子。及显如来于最后位犹能摄受诸新学辈。是故世尊弟子具足非如外道至临终时弟子离散。有说。别解脱律仪亦更有余从他表得。如半迦尸女等虽自表不大明了而由他表力故亦得别解脱律仪

如说佛告苾刍。从今以往及我灭度后不应辄度外道出家与受具戒。唯除释种及事火多发外道。若有释种作外道服来求出家。汝等即应度令出家与受具戒。所以者何。我之眷属应开许故。乃至广说。问世尊成就遍行大悲何故唯令开许自眷属耶。答有诸释种先归依外道未归依佛。今方便摄受故发此言。谓因恶王毗卢释迦。诛戮劫比罗筏窣堵城诸释种故。有余释种以怖畏故依外道出家偷存身命佛为彼故义言汝等以怖畏故。依外道出家受彼法服。今无怖畏必应还来归依佛法。故我敕诸弟子持令度彼因此无量释种外道来归佛法。有说。为欲诱引未入佛法增上慢释种令入佛法故。谓有释种增上慢缠心故尽众同分不来见佛。如来说此语已便般涅槃。彼后闻之当作是念。佛岂不以我为眷属故临般涅槃犹垂哀愍。由此无不发淳净心来归佛法出家受戒。尊者世友说曰。如来为令释种眷属积集增广殊胜善根故临涅槃以为付嘱。如契经说。尔时世尊袒上身分告苾刍众曰。汝应观我汝应察我。所以者何。如来应正等觉。难可出现。难可得见。过沤昙跋罗华。问世尊何故袒上身分告苾刍众汝应观我乃至广说。答假如有人习奢摩他满十二岁。所生善品不如于须臾顷观察佛相好之身所获功德。此中佛语义言我三无数劫所集福聚乃至未作灰聚以来。汝等宜应谛仰观察求坚固法。问汝应观我汝应察我有何差别。答汝应观我者谓以眼识。汝应察我者谓以意识。复次应观我者谓以无分别心。应察我者。谓以有分别心。复次应观我者。谓于现在。应察我者。谓于未来。复次应观我者。谓于生身。应察我者。谓于法身。复次观我者。谓观所集。察我者。谓察所证。复次观我者。谓观所厌。察我者。谓察所欣。复次观我者。谓观相好。察我者。谓察功德。是谓观察差别

如契经说。汝等苾刍且可裁默应观诸行是尽灭法。此是世尊最后教诲。问世尊何故说此语耶。答诸苾刍等以佛将涅槃故极怀愁恼展转悲号。佛欲止其悲哀令生观行故说是语。此中汝等苾刍且可裁默者令住正念应观诸行是尽灭法者令起正知。复次可裁默者。令修奢摩他观诸行者令修毗钵舍那。复次可裁默者。令止忧悲观诸行者令起观行。尊者妙音说曰。汝等苾刍且可裁默者。欲止他悲哀应观诸行是尽灭法者显自成就无忘失法。此中佛语义言我成佛未久已作是说

  诸行无常　　有生灭法
  以起尽故　　彼寂为乐

今复依彼说言诸行是尽灭法。岂非我成就无忘失法耶

说一切有部发智大毗婆沙论卷第一百九十一阿毗达磨大毗婆沙论卷第一百九十二

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    见蕴第八中念住纳息第一之六

尔时世尊说此语已便入初静虑。次第乃至入灭尽定。时尊者阿难则问尊者阿泥律陀言。世尊今者已般涅槃耶。答言未也。但是入灭尽定耳。复问云何知耶。答言我亲从佛闻。世尊入第四静虑依不动寂静定而般涅槃世间眼灭。问尊者阿难为知故问为不知耶。若知者何故复问。若不知者云何名知佛心耶。有说。彼尊者知之问

若尔者何故复问。答亦有知而故问为发起言论故。如说世尊知而故问。复次尊者阿难欲显尊者阿泥律陀有胜德故虽知而问。谓彼尊者虽有胜德而众不知。欲令其知是以故问。有说。彼尊者不知问。若尔者云何名知佛心耶。答佛出定已阿难知其前心而彼时不知者以佛犹在定故。复次彼尊者若住常性心时能知佛心。尔时彼心由二忧恼所覆没故不知佛心。一者失眷属忧恼。二者失大师忧恼。问尊者阿泥律陀云何知耶。有说。世尊临涅槃时入共声闻等至故彼得知。评曰。不应作是说。以佛尔时现入不共一切声闻独觉静虑解脱等持等至故。问若然者彼云何知。答世尊尔时起共声闻独觉入出定心。彼由此知是彼境故。犹如象王渡深河时。若正在河中则人无知者。但观入出水迹则知象王所入出处。如是世尊若住甚深等至河时。一切声闻独觉不能现见。但观如入出水迹入出定心便知。入如是定从如是定出

如说尔时尊者大迦叶波作是念。我当以何灭焚如来身火。寻作是念。我今应以香乳灭之。则起心时便有四道香乳从空而下由此令焚如来身火一时而灭。问何故必以香乳灭焚如来身火耶。答欲显与诸仙人相似法故。谓彼国俗若仙人命终则以乳灭焚身之火。若受欲者命终则以酒灭焚身之火。佛于诸仙中胜则是第一仙人。故今亦以香乳灭火。复次欲令佛设利罗极清净故以乳灌之。复次佛生身是乳所长养故。今设利罗亦以乳浴之。复次乳性肥而能灭火。或有物虽性肥而不能灭火。乃令其炽如酥油等。有物虽能灭火而性不肥如水酒等。唯乳性肥又能灭火故唯以乳。由此义故尊者大迦叶波。现四道香乳用灭如来焚身之火

如说尔时尊者阿难佛涅槃已经七昼夜右绕焚如来火聚。说伽他言

  千衣缠佛葬　　唯二衣不烧
  谓外及衬身　　此为奇特事

问何故世尊唯二衣不烧耶。答有信敬佛诸天神等威力所持令不烧故。有说。是佛愿力所持令内外净故。谓一衣在内持如来驮都令不散染

一衣在外持所有灰令不飘坌。有说。此表如来正法有内外二种护故。内护者谓清净苾刍苾刍尼等。外护者谓净信国王大臣等。此则正法威力令其不烧。有说。此表如来内心外身俱清净故。心清净者谓已永离一切烦恼并习气故。身清净者谓从最胜相异熟业所引生故

如说四有。谓本有中有生有死有。有声目多义如前广说。此中有声说属众同分有情数五蕴名有。云何本有。答除生分死分诸蕴中间诸有。此则一期五蕴四蕴为性。问何故此有说名本有。答此是前时所造业生故名本有。问若尔余有亦是本有皆前时所造业所生故。答若是前时所造业生粗显易觉明了现见者说名本有。余虽前时所造业生而微隐难觉非明了现见是以不说。云何死有。答死分诸蕴则命终时五蕴四蕴为性。云何中有。答除死分生分诸蕴中间诸有则二有中间五蕴为性。问何故此有说名中有。答此于二有中间生故。名中有。问若尔余有亦是中有皆于二有中间生故。答若于二有中间生非趣所摄者名中有。余虽二有中间生而是趣摄不名中有。云何生有。答生分诸蕴则结生时五蕴四蕴为性。问此四有几刹那几相续。答二刹那谓死有生有二相续谓余有。问此四有几染污几不染污。答皆通二种。问此四有心几染污几不染污。答生有心唯染污。余心染污不染污。问此四有几有漏几无漏。答皆唯有漏。问此四有时心几有漏几无漏。答二唯有漏谓死有生有时心。二通有漏无漏谓余有时心。问此四有时几起同分心几起不同分心。答二唯起同分心谓死有生有时。二起同分不同分心谓余有时

诸欲有彼一切有五行耶乃至广说。此中诸蕴以行声说。过去如来应正等觉说蕴为行。今释迦牟尼如来应正等觉说行为蕴。以先佛说五行今佛说五取蕴故。此阿毗达磨中说五行者。欲显今佛所说五蕴则是先佛所说五行故。问何故先佛说蕴为行今佛说行为蕴耶。答佛观所化有情随所应而说故。谓先佛所化应闻说行而得正解。今佛所化应闻说蕴而得正解。问何故名行。答流转故名行谓前生诸蕴由后生诸蕴故流转。或后生诸蕴由前生诸蕴故流转。若生欲界以欲界心为同分心与彼命根众同分为同分故。以色无色界及无漏心为不同分心。不与彼命根众同分为同分故。若生色界以色界心为同分心。以欲无色界及无漏心为不同分心。若生无色界以无色界心为同分心。以无漏心为不同分心

诸欲有彼一切五行耶。设五行彼一切欲有耶。答应作四句。有欲有非五行。谓欲界有情住不同分心及住无想灭尽定。彼时欲有唯二行故。有五行非欲有。谓色界有想天住同分心。若无想天不得无想。尔时皆具五行彼无想天有心位。必不起不同分心故而彼行非欲有。有欲有亦五行。谓欲界有情住同分心。彼时欲有具五行故。有非欲有亦非五行。谓色界有想天住不同分心及住无想灭尽定。若无想天得无想若生无色界。尔时但有二行或四行或一行。彼行又非欲有故。诸色有有想天彼一切五行耶。设五行彼一切色有有想天耶。答应作四句。有色有有想天非五行。谓色界有想天住不同分心。及住无想灭尽定。尔时色有有想天皆唯二行故。有五行非色有有想天。谓欲界有情住同分心。若无想天不得无想。尔时虽皆五行。而彼行非色有有想天故。有色有有想天亦五行。谓色界有想天住同分心。尔时色有有想天具五行故。有非色有有想天亦非五行。谓欲界有情住不同分心。及住无想灭尽定。若无想天得无想若生无色界。尔时但有二行或四行或一行。彼行又非色有有想天故。诸色有无想天彼一切二行耶。设二行彼一切色有无想天耶。答应作四句。有色有无想天非二行。谓无想天不得无想。尔时彼色有无想天具五行故所以如前。有二行非色有无想天。谓欲界有情住不同分心。及住无想灭尽定。若色界有想天住不同分心。及住无想灭尽定。尔时虽皆二行而彼行非色有无想天故。有色有无想天亦二行。谓无想天得无想。尔时彼色有无想天唯二行故。有非色有无想天亦非二行。谓欲界有情及色界有想天住同分心若生无色界。尔时乃有五行或四行或一行。彼行又非色有无想天故。诸无色有彼一切四行耶。设四行彼一切无色有耶。答诸四行彼一切无色有。非欲色界有情有四行故。有无色有非四行。谓无色界有情住不同分心。尔时彼无色有唯一行故。颇有有五行耶。乃至广说。问何故复作此论。答前文虽成立有二行有而未遮止有三行有。亦未成立有一行有今为遮止有三行有。及欲成立有一行有故作斯论。颇有有五行耶。答有。谓欲界有情及色界有想天住同分心。若无想天不得无想彼必有自地现在五行故。颇有有四行耶。答有。谓无色界有情住同分心。颇有有三行耶。答无。以无有情三蕴成故。所以者何。心心所法定不相离受想思等恒相应故。颇有有二行耶。答有。谓欲界有情及色界有想天住不同分心。若住无想灭尽定。若无想天得无想彼但有二行故。颇有有一行耶。答有。谓无色界有情住不同分心彼但有一行故。颇有有无行耶。答无。以无有情非蕴成故。一切有情必有自地命根等故

    见蕴第八中三有纳息第二之一

诸舍欲有欲有相续。彼一切欲界法灭。欲界法现在前耶。如是等章及解章义既领会已。应广分别然有声目多义。此中说属众同分有情数五蕴名有。如说欲界死生欲界。彼一切欲有相续耶。乃至广说。彼亦说属众同分有情数五蕴名有。如说诸缠所缠地狱有相续。彼初所得诸根大种与此心心所法为一增上。乃至广说。又复如说欲有相续时。最初得几业所生根。乃至广说。又如说四有。谓本有死有中有生有。当知彼文皆说属众同分有情数五蕴名有。如说颇勒窭那识食所引能感后有令其现前。彼说续生时心眷属名有。如说阿难陀。如是业有能牵后有。彼说牵后有思名有。如说取缘有彼说分位五蕴名有。尊者妙音说曰。彼说牵后有业名有。如说云何有法谓一切有漏。彼说诸有漏法名有。如说七有谓地狱有傍生有鬼界有人有天有业有中有。彼说五趣五趣因五趣方便名有。如说欲有云何。谓业能感欲界后有。乃至广说。彼说业及异熟名有。不说取所缘有。问若尔彼后所说当云何通。如说欲有欲界一切随眠随增。乃至广说。欲有五部业皆能感异熟可说欲界一切随眠随增。色无色有唯修所断业能感异熟。如何可说色无色界一切随眠随增耶。答后文应作是说。欲有欲界一切随眠随增。色无色有色无色界遍行。及修所断随眠随增。应作是说。而不说者当知彼说有及眷属悉名为有。和合有法亦名有故。有余师说。前说业及异熟名有。不说取所缘有。后说业及异熟名有。亦说取所缘有。彼不应作是说。诸作论者。依章立门不可章所说异门所说异。是故如前所说者好。问何故名有。答能有能非有故名有。问若尔圣道应名有圣道亦是能有能非有故。答若能有能非有能长养摄益任持诸有者名有。圣道虽能有能非有而于诸有损坏离散故不名有。复次若能有能非有能令诸有相续流转令老死道不断者名有。圣道虽能有能非有而令诸有不相续不流转。断老死道故不名有。复次若能有能非有是趣苦集行趣有世间。流转生死老死集行者名有。圣道虽能有能非有。而是趣苦灭行趣有世间流转生死老死灭行故不名有。复次若能有能非有。是有身见事颠倒事随眠事爱事。贪嗔痴安足处。有垢有毒诸有所摄。堕苦集谛者名有。圣道虽能有能非有而非有身见事乃至爱事非贪嗔痴安足处。无垢无秽无浊无毒非诸有摄。不堕苦集谛故不名有。有余师说。是苦器故名有。问若尔此亦是乐器。如说大名若色一向是苦非乐非随顺乐不增长喜乐。唯是离乐因者则诸有情不应于色起贪起染。大名以色非一向苦亦是乐亦随顺乐亦增长喜乐。非唯是离乐因故。有情于色起贪起染。又佛决定建立三受不相杂乱。谓乐受苦受不苦不乐受。如是有漏法亦是乐器。何故但说是苦器故名为有耶。答以苦多故。谓生死中苦多乐少顺苦法多顺乐法少。以乐少故置在苦品。如一渧蜜堕毒器中不名蜜器。犹名毒器。以毒多故此亦如是。复有说者。可怖畏故名有。问若尔涅槃应亦名。有如说苾刍诸愚夫类无闻异生于涅槃中生大怖畏。谓我不有我所不有我当不有我所当不有。彼于涅槃既生怖畏是则涅槃亦应名有。答于有生怖是则为正。于涅槃生怖是则为邪。以涅槃非可怖故。由此不名为有。复次若令异生圣者皆生怖畏乃名为有。涅槃但令异生生怖故不名有

相续有五。一中有相续。二生有相续。三分位相续。四法相续。五刹那相续。中有相续者。谓死有蕴灭中有蕴生。死有诸蕴由中有诸蕴说名相续故名中有相续。生有相续者。谓中有蕴灭生有蕴生。中有诸蕴由生有诸蕴说名相续故名生有相续。分位相续者。谓羯逻蓝分位灭頞部昙分位生。羯逻蓝分位由頞部昙分位说名相续。乃至壮年分位灭老年分位生。壮年分位由老年分位说名相续。故名分位相续。法相续者。谓善法无间染或无记法现在前。善法由染及无记法说名相续。染法无记法无间各二现前广说亦尔故名法相续。刹那相续者。前刹那无间后刹那现在前。前刹那由后刹那说名相续故名刹那相续。此五相续皆摄二相续中。谓法相续刹那相续。以中有生有分位相续皆名为法及刹那故。欲界具五相续。色界有四除分位。无色界有三除中有及分位。天那落迦及化生有四相续除分位。余皆具五。有说。天及化生亦具五相续。于五相续中。此中依二相续而作论。谓中有生有。诸舍欲有。欲有相续。彼一切欲界法灭。欲界法现在前耶。答诸舍欲有。欲有相续彼一切欲界法灭。欲界法现在前。谓欲界命终还生欲界。从死有往中有时。舍欲有者。谓欲界死有。欲有相续者谓欲界中有。欲界法灭者谓欲界死有诸蕴。欲界法现在前者谓欲界中有诸蕴。若从中有往生有时。舍欲有者谓欲界中有。欲有相续者谓欲界生有。欲界法灭者

谓欲界中有诸蕴。欲界法现在前者谓欲界生有诸蕴。问若住欲界无覆无记心命终者住中有时。不成就死有住生有时。不成就中有可名为舍。若住善或染心而命终者住中有时。成就死有。住生有时。成就中有。云何名舍。有说。此中但依住无覆无记心命终者。说是故无过。有说。此中依现行舍说虽住中有成就死有住生有成就中有。而不现行故说为舍。有说。此中弃背前蕴说名为舍。不说成就不成就义。有欲界法灭欲界法现在前。而非舍欲有欲有相续。谓不命终而欲界法灭欲界法现在前其事云何。谓羯逻蓝位无间頞部昙位现在前。乃至庄年位无间老年位现在前。善法无间染或无记法现在前。染法无间善或无记法现在前。无记法无间善及染法现在前。前刹那无间后刹那现在前。诸舍欲有色有相续。彼一切欲界法灭色界法现在前耶。答诸舍欲有色有相续。彼一切欲界法灭色界法现在前。谓欲界命终生色界。从死有往中有时舍欲有者。谓欲界死有。色有相续者谓色界中有。欲界法灭者谓欲界死有诸蕴。色界法现在前者谓色界中有诸蕴。有欲界法灭色界法现在前。而非舍欲有色有相续。谓不命终欲界法灭色界法现在前其事云何。此中有说。欲界善心无间未至定现在前。有说。欲界善心无间未至定初静虑现在前。有说。欲界善心无间未至定初静虑静虑中间现在前。尊者妙音说曰。欲界善心无间未至定初静虑静虑中间第二静虑现在前。所以者何。如超定时。初静虑无间第三静虑现在前此亦应尔。又欲界有四种变化心。谓初静虑果乃至第四静虑果。欲界初静虑果变化心无间净初静虑现在前。乃至欲界第四静虑果变化心无间净第四静虑现在前。诸舍欲有无色有相续。彼一切欲界法灭无色界法现在前耶。答如是。设欲界法灭无色界法现在前。彼一切舍欲有无色有相续耶。答如是。问此中何故不说不命终欲界法灭。无色界法现在前耶。答理必无有在无色界不命终而有欲界法灭。无色界法现在前故。问岂不容有在欲界不命终。而欲界得灭无色界得现在前耶。答此中说同类法灭同类法现在前。无有在欲界。不命终而欲界同类法得灭。无色界同类法得而现在前是以不说。有说。此中说心心所法灭。心心所法现在前无有在欲界不命终而欲界心心所法灭。无色界心心所法现在前是故不说。诸舍色有色有相续。彼一切色界法灭色界法现在前耶。答诸舍色有色有相续彼一切色界法灭。色界法现在前。谓色界命终还生色界。从死有往中有时。舍色有者谓色界死有。色有相续者谓色界中有。色界法灭者谓色界死有诸蕴。色界法现在前者谓色界中有诸蕴。从中有往生有时。舍色有者谓色界中有。色有相续者谓色界生有。色界法灭者谓色界中有诸蕴。色界法现在前者谓色界生有诸蕴。此中若住无覆无记心命终。及住善心或染心命终时皆名舍色有。问答分别如前应知。有色界法灭色界法现在前。而非舍色有色有相续。谓不命终色界法灭。色界法现在前其事云何。谓初静虑无间第二第三静虑现在前。第二静虑无间初第三第四静虑现在前。第三静虑无间初第二第四静虑现在前。第四静虑无间第二第三静虑现在前。善法无间染或无记法现在前。染法无记法说亦尔。前刹那无间后刹那现在前。诸舍色有欲有相续。彼一切色界法灭欲界法现在前耶。答诸舍色有欲有相续。彼一切色界法灭欲界法现在前。谓色界命终生欲界。从死有往中有时。舍色有者谓色界死有。欲有相续者谓欲界中有。色界法灭者谓色界死有诸蕴。欲界法现前者谓欲界中有诸蕴。有色界法灭欲界法现在前。而非舍色有欲有相续。谓不命终而色界法灭欲界法现在前其事云何。此中有说。未至定无间欲界善心现在前。有说。未至定初静虑无间欲界善心现在前。有说。未至定初静虑静虑中间无间欲界善心现在前。尊者妙音说曰。未至定初静虑静虑中间第二静虑无间欲界善心现在前。所以者何。如超定时第三静虑无间初静虑现在前此亦应尔。又欲界有四种变化心。谓初静虑果乃至第四静虑果。净初静虑无间欲界初静虑果变化心现在前。乃至净第四静虑无间欲界第四静虑果变化心现在前。诸舍色有无色有相续。彼一切色界法灭无色界法现在前耶。答诸舍色有无色有相续。彼一切色界法灭无色界法现在前。谓色界命终生无色界从死有往生有时。舍色有者谓色界死有。无色有相续者谓无色界生有。色界法灭者谓色界死有诸蕴。无色界法现在前者谓无色界生有诸蕴。有色界法灭无色界法现在前。而非舍色有无色有相续。谓不命终色界法灭。无色界法现在前其事云何。谓第三静虑无间空无边处现在前。第四静虑无间空识无边处现在前

诸舍无色有无色有相续。彼一切无色界法灭无色界法现在前耶。答诸舍无色有无色有相续。彼一切无色界法灭无色界。法现在前谓无色界命终。还生无色界。从死有至生有时。舍无色有者谓无色界死有。无色有相续者谓无色界生有。无色界法灭者谓无色界死有诸蕴。无色界法现在前者谓无色界生有诸蕴。有无色界法灭无色界法现在前。而非舍无色有无色有相续。谓不命终无色界法灭无色界法现在前其事云何。谓空无边处无间识无边处无所有处现在前。识无边处无间空无边处无所有处非想非非想处现在前。无所有处无间空识无边处非想非非想处现在前。非想非非想处无间识无边处无所有处现在前。善法无间染或无记法现在前。染法无记法说亦尔。前刹那无间后刹那现在前。诸舍无色有欲有相续。彼一切无色界法灭欲界法现在前耶。答如是。设无色界法灭欲界法现在前。彼一切舍无色有欲有相续耶。答如是。问此中何故不说不命终无色界法灭欲界法现在前耶。答理必无有在无色界不命终。而有无色界法灭欲界法现在前故。余问答如前。诸舍无色有色有相续。彼一切无色界法灭色界法现在前耶。答诸舍无色有色有相续。彼一切无色界法灭色界法现在前。谓无色界命终生色界。从死有往中有时。舍无色有者谓无色界死有。色有相续者谓色界中有。无色界法灭者谓无色界死有诸蕴。色界法现在前者谓色界中有诸蕴。有无色界法灭色界法现在前而非舍无色有色有相续。谓不命终而无色界法灭色界法现在前其事云何。谓识无边处无间第四静虑现在前。空无边处无间第三第四静虑现在前

且随本文分别义已当随其义复广分别。问若欲界命终还生欲界。彼何所舍何所得何法灭何法现在前。乃至若无色界命终生色界。彼何所舍何所得何法灭何法现在前。答诸欲界命终还生欲界。若本住别解脱律仪无不善身语表。设有已失者若住善心命终。彼舍善蕴二无记蕴二。得无记蕴二。即于彼时善五蕴染一蕴无记二蕴灭。善一蕴染四蕴无记二蕴现在前。若住染心命终。彼舍善蕴二无记蕴二。得无记蕴二。即于彼时善二蕴染四蕴无记二蕴灭。善一蕴染四蕴无记二蕴现在前。若住无记心命终。彼舍善蕴二无记蕴五。得无记蕴二。即于彼时善二蕴染一蕴无记五蕴灭。善一蕴染四蕴无记二蕴现在前。则彼若有不善身语表不失者。若住善心命终。彼舍善蕴二染蕴二无记蕴二。得无记蕴二。则于彼时善五蕴染二蕴无记二蕴灭。善一蕴染四蕴无记二蕴现在前。若住染心命终。彼舍善蕴二染蕴二无记蕴二。得无记蕴二。则于彼时善二蕴染五蕴无记二蕴灭。善一蕴染四蕴无记二蕴现在前。若住无记心命终。彼舍善蕴二染蕴二无记蕴五。得无记蕴二。则于彼时善二蕴染二蕴无记五蕴灭。善一蕴染四蕴无记二蕴现在前。若本住不律仪无善身语表。设有已失者

若住善心命终。彼舍染蕴二无记蕴二。得无记蕴二。则于彼时善四蕴染二蕴无记二蕴灭。善一蕴染四蕴无记。二蕴现在前。若住染心命终。彼舍染蕴二无记蕴二。得无记蕴二。则于彼时善一蕴。染五蕴无记二蕴灭。善一蕴染四蕴无记二蕴现在前。若住无记心命终。彼舍染蕴二无记蕴五。得无记蕴二。则于彼时善一蕴染二蕴无记五蕴灭。善一蕴染四蕴无记二蕴现在前。即彼若有善身语表不失者。若住善心命终等广如住别解脱律仪。有不善身语表说。若本住非律仪非不律仪无善不善身语表设有已失者。若住前心命终。彼舍无记蕴二。得无记蕴二。则于彼时善四蕴染一蕴无记二蕴灭。善一蕴染四蕴无记二蕴现在前。若住染心命终。彼舍无记蕴二得无记蕴二。则于彼时善一蕴染四蕴无记二蕴灭。善一蕴染四蕴无记二蕴现在前。若住无记心命终。彼舍无记蕴五。得无记蕴二。则于彼时善一蕴染一蕴无记五蕴灭。善一蕴染四蕴无记二蕴现在前。即彼若有善身语表不失。无不善身语表设有已失者。若住善染无记心命终。如住别解脱律仪。无不善身语表设有已失者住三种心命终说。即彼若有不善身语表不失无善身语表设有已失者。若住善染无记心命终。如住不律仪无善身语表设有已失者。住三种心命终说。则彼若有善不善身语表不失者。若住善染无记心命终。如住别解脱律仪。有不善身语表不失者。及住不律仪有善身语表不失者。住三种心命终说

说一切有部发智大毗婆沙论卷第一百九十二阿毗达磨大毗婆沙论卷第一百九十三

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    见蕴第八中三有纳息第二之二

诸欲界命终生初静虑。若本住别解脱律仪。或不住别解脱律仪。有善身语表不失者。若住善心命终。彼舍善蕴五无记蕴二。有说。五得善蕴四无记蕴二。即于彼时善五蕴染一蕴无记二蕴灭。善一蕴染四蕴无记二蕴现在前。若住无记心命终。彼舍善蕴五无记蕴五。得善蕴四无记蕴二。即于彼时善二蕴染一蕴无记五蕴灭。善一蕴染四蕴无记二蕴现在前。若本不住别解脱律仪。无善身语表设有已失者。若住善心命终。彼舍善蕴四无记蕴二。有说。五得善蕴四无记蕴二。则于彼时善四蕴染一蕴无记二蕴灭。善一蕴染四蕴无记二蕴现在前。若住无记心命终。彼舍善蕴四无记蕴五。得善蕴四无记蕴二。即于彼时善一蕴染一蕴无记五蕴灭。善一蕴染四蕴无记二蕴现在前。诸欲界命终生第二第三第四静虑。若本住别解脱律仪。或不住别解脱律仪。有善身语表不失者。若住善心命终。彼舍善蕴五无记蕴五。得善蕴四无记蕴二。即于彼时善五蕴染一蕴无记二蕴灭。善一蕴染四蕴无记二蕴现在前。若住无记心命终。彼舍善蕴五无记蕴五。得善蕴四无记蕴二。即于彼时善二蕴染一蕴无记五蕴灭。善一蕴染四蕴无记二蕴现在前。若本不住别解脱律仪。无善身语表设有已失者。若住善心命终。彼舍善蕴五无记蕴五。得善蕴四无记蕴二。即于彼时善四蕴染一蕴无记二蕴灭。善一蕴染四蕴无记二蕴现在前。若住无记心命终。彼舍善蕴五无记蕴五。得善蕴四无记蕴二。即于彼时善一蕴染一蕴无记五蕴灭。善一蕴染四蕴无记二蕴现在前。诸欲界命终生无色界。若本住别解脱律仪。或不住别解脱律仪。有善身语表不失者。若住善心命终。彼舍善蕴五无记蕴五。得善蕴四无记蕴一。即于彼时善五蕴染一蕴无记二蕴灭。善一蕴染四蕴无记一蕴现在前。若住无记心命终。彼舍善蕴五无记蕴五。得善蕴四无记蕴一。即于彼时善二蕴染一蕴无记五蕴灭。善一蕴染四蕴无记一蕴现在前。若本不住别解脱律仪。无善身语表设有已失者。若住善心命终。彼舍善蕴五无记蕴五。得善蕴四无记蕴一。即于彼时善四蕴染一蕴无记二蕴灭。善一蕴染四蕴无记一蕴现在前。若住无记心命终。彼舍善蕴五无记蕴五。得善蕴四无记蕴一。即于彼时善一蕴染一蕴无记五蕴灭。善一蕴染四蕴无记一蕴现在前。诸色界命终还生色界。即此地没还生此地者。若住善心命终。彼舍无记蕴二。得无记蕴二。即于彼时善四蕴染一蕴无记二蕴灭。善一蕴染四蕴无记二蕴现在前。若住染心命终。彼舍无记蕴二。得无记蕴二。即于彼时善一蕴染四蕴无记二蕴灭。善一蕴染四蕴无记二蕴现在前。若住无记心命终。彼舍无记蕴五。得无记蕴二。即于彼时善一蕴染一蕴无记五蕴灭。善一蕴染四蕴无记二蕴现在前。色界下地没生上地者。若住善心命终。彼舍善蕴五无记蕴五。得善蕴四无记蕴二。即于彼时善四蕴染一蕴无记二蕴灭。善一蕴染四蕴无记二蕴现在前。若住无记心命终。彼舍善蕴五无记蕴五。得善蕴四无记蕴二。则于彼时善一蕴染一蕴无记五蕴灭。善一蕴染四蕴无记二蕴现在前。色界上地没生下地者。若住善心命终。彼舍善蕴五无记蕴五。得善蕴五染蕴四无记蕴五。即于彼时善四蕴染一蕴无记二蕴灭。善一蕴染四蕴无记二蕴现在前。若住染心命终。彼舍善蕴五无记蕴五。得善蕴五染蕴四无记蕴五。则于彼时善一蕴染四蕴无记二蕴灭。善一蕴染四蕴无记二蕴现在前。若住无记心命终。彼舍善蕴五无记蕴五。得善蕴五染蕴四无记蕴五。即于彼善一蕴染一蕴无记五蕴灭。善一蕴染四蕴无记二蕴现在前。诸色界命终生欲界者。若住善心命终彼舍善蕴五无记蕴五。得善蕴四染蕴四无记蕴二。有说五。则于彼时善四蕴染一蕴无记二蕴灭。善一蕴染四蕴无记二蕴现在前。若住染心命终。彼舍善蕴五无记蕴五。得善蕴四染蕴四无记蕴二。有说五。即于彼时善一蕴染四蕴无记二蕴灭。善一蕴染四蕴无记二蕴现在前。住无记心命终。彼舍善蕴五无记蕴五。得善蕴四染蕴四无记蕴二。有说五。即于彼时善一蕴染一蕴无记五蕴灭。善一蕴染四蕴无记二蕴现在前

诸色界命终生无色界。若住善心命终。彼舍善蕴五无记蕴五。得善蕴四无记蕴一。即于彼时善四蕴染一蕴无记二蕴灭。善一蕴染四蕴无记一蕴现在前。若住无记心命终。彼舍善蕴五无记蕴五。得善蕴四无记蕴一。即于彼时善一蕴染一蕴无记五蕴灭。善一蕴染四蕴无记一蕴现在前。诸无色界命终生无色界。即此地没还生此地者。若住善心命终。彼舍无记蕴一得无记蕴一。即于彼时善四蕴染一蕴无记一蕴灭。善一蕴染四蕴无记一蕴现在前。若住染心命终。彼舍无记蕴一。得无记蕴一。即于彼时善一蕴染四蕴无记一蕴灭。善一蕴染四蕴无记一蕴现在前若住无记心命终。彼舍无记蕴四。得无记蕴一。即于彼时善一蕴染一蕴无记四蕴灭。善一蕴染四蕴无记一蕴现在前。无色界下地没生上地者。若住善心命终。彼舍善蕴四无记蕴一。得善蕴四无记蕴一。即于彼时善四蕴染一蕴无记一蕴灭。善一蕴染四蕴无记一蕴现在前。若住无记心命终。彼舍善蕴四无记蕴四。得善蕴四无记蕴一。即于彼时善一蕴染一蕴无记四蕴灭。善一蕴染四蕴无记一蕴现在前。无色界上地没生下地者。若住善心命终。彼舍善蕴四无记蕴一。得善蕴四染蕴四无记蕴一。则于彼时善四蕴染一蕴无记一蕴灭。善一蕴染四蕴无记一蕴现在前。若住染心命终。彼舍善蕴四无记蕴一。得善蕴四染蕴四无记蕴一。则于彼时善一蕴染四蕴无记一蕴灭。善一蕴染四蕴无记一蕴现在前。若住无记心命终。彼舍善蕴四无记蕴四。得善蕴四染蕴四无记蕴一。则于彼时善一蕴染一蕴无记四蕴灭。善一蕴染四蕴无记一蕴现在前

诸无色界命终生欲界者。若住善心命终。彼舍善蕴四无记蕴一。得善蕴四染蕴四无记蕴二。有说五。则于彼时善四蕴染一蕴无记一蕴灭。善一蕴染四蕴无记二蕴现在前。若住染心命终。彼舍善蕴四无记蕴一。得善蕴四染蕴四无记蕴二。有说五。即于彼时善一蕴染四蕴无记一蕴灭。善一蕴染四蕴无记二蕴现在前。若住无记心命终。彼舍善蕴四无记蕴四。得善蕴四染蕴四无记蕴二。有说五。即于彼时善一蕴染一蕴无记四蕴灭。善一蕴染四蕴无记二蕴现在前。诸无色界命终生色界者。若住善心命终。彼舍善蕴四无记蕴一。得善蕴五染蕴四无记蕴五。即于彼时善四蕴染一蕴无记一蕴灭。善一蕴染四蕴无记二蕴现在前。若住染心命终。彼舍善蕴四无记蕴一。得善蕴五染蕴四无记蕴五。即于彼时善一蕴染四蕴无记一蕴灭。善一蕴染四蕴无记二蕴现在前。若住无记心命终。彼舍善蕴四无记蕴四。得善蕴五染蕴四无记蕴五。即于彼时善一蕴染一蕴无记四蕴灭。善一蕴染四蕴无记二蕴现在前

何故欲界随眠不于色界法随增耶。乃至广说。问何故作此论。答欲令疑者得决定故。谓前结蕴有情纳息中说。欲界异生有九十八随眠随增九结系。色界异生有六十二随眠随增六结系。无色界异生有三十一随眠随增六结系。或有生疑。欲界异生为色无色界随眠随增。色界异生为无色界随眠随增。欲令此疑得决定故。显成就彼非彼随增。谓欲界异生但为欲界随眠随增非色无色界。色界异生但为色界随眠随增非无色界。由此因缘故作斯论。何故欲界随眠不于色界法随增耶。答界应杂乱及不可施设离欲染故。界杂乱者。谓彼亦是欲界亦是色界。则不可说欲色界异。及不可施设离欲染者。谓离欲界贪时不名离欲界染。离色界贪时乃名离欲界染。此不应理。何故欲界随眠不于无色界法随增耶。答界应杂乱。及不可施设离欲染故。界杂乱者。谓彼亦是欲界亦是无色界。则不可说欲无色界异。及不可施设离欲染者。谓离欲界贪时不名离欲界染。离无色界贪时乃名离欲界染。此不应理。何故色界随眠不于欲界法随增耶。答界应杂乱。及彼非此所缘故。界杂乱者。谓彼亦是色界亦是欲界。则不可说色欲界异及彼非此所缘故者。谓无上地烦恼缘下地法故。何故色界随眠不于无色界法随增耶。答界应杂乱。及不可施设离色染故。界杂乱者。谓彼亦是色界亦是无色界。则不可说色无色界异。及不可施设离色染者。谓离色界贪时不名离色界染。离无色界贪时乃名离色界染。此不应理。何故无色界随眠不于欲界法随增耶。答界应杂乱。及彼非此所缘故。何故无色界随眠不于色界法随增耶。答界应杂乱。及彼非此所缘故。皆如前应知

问所说三界云何建立。为以地为以处为以爱断耶。设尔何失。若以地者应说九界地有九故。谓欲界四静虑四无色。若以处者。应说四十界有四十处故。谓欲界二十处。色界十六处。无色界四处。若以爱断者。亦应说九界。谓欲界爱乃至非想非非想处爱。各分齐有异故。答应说以爱断故建立三界。问若尔。应立九界。答同类爱断故唯立三界。谓从无间地狱乃至他化自在天皆由欲爱所差别故建立欲界。从梵众天乃至色究竟天。皆由色爱所差别故建立色界。从空无边处乃至非想非非想处皆由无色爱所差别故建立无色界。复次若处有色有欲立欲界。有色无欲立色界。无色无欲立无色界。复次若处有色有第二立欲界。有色无第二立色界。无色无第二立无色界。复次若处有色有境立欲界。有色无境立色界。无色无境立无色界。复次若处有色有众具立欲界。有色无众具立色界。无色无众具立无色界。复次若处有色有欲有我执立欲界。有色无欲有我执立色界。无色无欲有我执立无色界。复次若处有色有第二有我执立欲界。有色无第二有我执立色界。无色无第二有我执立无色界。境及众具说亦尔。复次若处有色无惭无愧相应立欲界有色无惭无愧不相应立色界。无色无惭无愧不相应立无色界。复次若处有色悭嫉相应立欲界。有色悭嫉不相应立色界。无色悭嫉不相应立无色界。复次若处有色忧苦根相应立欲界。有色忧苦根不相应立色界。无色忧苦根不相应立无色界。复次若处有色段食淫爱相应立欲界。有色段食淫爱不相应立色界。无色段食淫爱不相应立无色界。复次若处有五蕴异熟因五蕴异熟果。不善无记随眠随增立欲界。有五蕴异熟因五蕴异熟果。唯无记随眠随增立色界。有四蕴异熟因四蕴异熟果。唯无记随眠随增立无色界。复次若处有四蕴异熟因得一果。不善无记随眠随增立欲界。有五蕴异熟因得一果。唯无记随眠随增立色界。有四蕴异熟因得一果。唯无记随眠随增立无色界。复次若处有三受异熟因三受异熟果。不善无记随眠随增立欲界。有二受异熟因二受异熟果。唯无记随眠随增立色界。有一受异熟因一受异熟果。唯无记随眠随增立无色界。复次若处有五受异熟因四受异熟果。不善无记随眠随增立欲界。有三受异熟因三受异熟果。唯无记随眠随增立色界。有一受异熟因一受异熟果。唯无记随眠随增立无色界。复次若处有有色无色异熟因有色无色异熟果。不善无记随眠随增立欲界。有有色无色异熟因有色无色异熟果。唯无记随眠随增立色界。有无色异熟因无色异熟果。唯无记随眠随增立无色界。如有色无色如是。有见无见有对无对说亦尔。问所说三界云何安立。为上下重累。为邻次傍布。若上下者。云何施设遍离彼染。云何神通能遍至彼。若傍布者。陀罗达多所说当云何通。如说下方世界无边上方世界无边。此中有说。上下重累。谓从此界风轮之下虚空悬远有下方色究竟天。彼下展转乃至风轮次下复有色究竟天。展转向下乃至风轮。如是展转下方世界乃至无边。又从此界色究竟上虚空悬远有上方风轮。彼上展转乃至色究竟天。次上复有风轮展转向上乃至色究竟天。如是展转上方世界乃至无边。问若尔。云何施设遍离彼染。云何神通能遍至彼。答若有离一欲界染时。即名离一切欲界染。以相同故。然依初定所发神通。但能至一欲界梵世非余。以处别故。如是离色界染及依余定发通。随应亦尔。有余师说。邻次傍布。问若尔。陀罗达多所说当云何通。答彼应作是说。下方欲界无边。上方色界无边。此中欲界诸处同一随眠。色无色界随地差别各别随眠。问何故欲界诸处同一随眠。色无色界随地各别。答欲界是不定界非修地非离染地。此中烦恼如无辔马自在奔逸。故一切处同一随眠。色无色界是定界是修地是离染地。此中烦恼如有辔马不自在转。故上下地各别随眠。复次欲界不善根强盛善根羸劣。故一切处。同一随眠。色无色界无不善根善根强盛。故上下地各别随眠。复次欲界不善增长善法退减。色无色界无不善法善法增长。复次欲界不善如主。善法如客。色无色界无不善法。善法如主。复次欲界有不善根能断善根。色无色界无不善根能断善根。复次欲界礼仪无忌犹如夫妻。故一切处同一随眠。色无色界礼仪有隔犹如母子。故上下地各别随眠。复次欲界善法威仪有杂。犹如王子与旃荼罗子同禁囹圄。故一切处同一随眠。色无色界善法威仪无杂。犹如王子与长者子同禁囹圄。故上下地各别随眠。问三界中间有物间不。若有者。彼有二物界应成五。即五中间复有四物。界应成九。如是展转便为无穷。若无者。云何不三界合成一耶。答应言彼中更无物间。问若尔。三界云何不成一耶。答于彼中间虽无物间而不成一。如十八界十二处五蕴三世四大种等。虽无物间而不成一。此亦如是。复次性相异故物类别故。虽无物间而不成一。问若尔。他化自在天上初静虑下中间悬远。有无量空界色。云何可知此是欲界此是色界分齐差别耶。答二界轮际俱有光网。二光分齐粗妙不等。由此了知此是欲界此是色界。复次若欲界生得天眼所能见处是欲界。不能见处是色界。复次若欲界生得神通所能到处是欲界。不能到处是色界。复次若处欲界爱所缘是欲界。色界爱所缘是色界。是谓二界分齐差别

何故欲界不遍行随眠不遍于欲界法随增耶。答此应成遍行及彼非此所缘故。此应成遍行者。谓此欲界不遍行随眠。若遍于欲界法随增者。亦应成遍行。则不可施设遍行随眠不遍行随眠相用差别。及彼非此所缘故者。谓彼异部诸法非此不遍行随眠所缘。此但以自部法为所缘故。所以者何。由不遍行随眠势力。建立五部诸法有异。若不遍行随眠亦遍缘五部者。则于五部应遍随增。如是便为五部杂乱。五部杂乱故则对治杂乱。对治杂乱故则现观杂乱。现观杂乱故则不可施设遍知差别。沙门果差别。欲令无如是过。是故欲界不遍行随眠不遍于欲界法随增。何故色界不遍行随眠。不遍于色界法随增耶。答此应成遍行。及彼非此所缘故。何故无色界不遍行随眠不遍于无色界法随增耶。答此应成遍行。及彼非此所缘故。皆如前释。遍行因义广说如杂蕴智纳息。及结蕴不善纳息。有十想谓无常想乃至灭想。此如定蕴摄纳息中已广分别。若修无常想彼思惟无常想耶。乃至广说。修有四种。谓得修习修对治修除遣修。四修义如智蕴他心智纳息中广说。此中有说。但依习修作论。有说。通依得修习修作论。诸有欲令此中但依习修作论者。彼说若修无常想者。谓无常想现在前。彼思惟无常想者。谓以无常想为所缘。即是无常想现在前时缘无常想义。若修无常想彼思惟无常想耶。答应作四句。有修无常想不思惟无常想

谓缘余法修无常想。如缘色受行识蕴。除无常想缘余想蕴起无常想。问此说在何位。答在增长暖顶位起无常行相身受心念住及缘余法法念住。若离欲界乃至非想非非想处染。起无常行相身受心念住。及缘余法法念住为加行。彼加行道时若信胜解练根作见至。时解脱练根作不动。起无常行相身受心念住。及缘余法法念住为加行。彼加行道时。若起无常行相身受心念住。及缘余法法念住时。若即以此类念住杂修静虑时。诸有欲令一切法是胜义者。即起此类念住义无碍解时。及起此类念住辩无碍解愿智边际定无色解脱入灭尽定想微细心时。如是等时修无常想。无常想现在前故。不思惟无常想缘余法故。有思惟无常想不修无常想。谓缘无常想修余想。余想者。谓无常苦想苦无我想及余善染无记想。此中善想者。谓加行善。及生得善想加行善想。谓闻思修所成。闻所成者。谓缘无常想起非无常行相闻所成想。思所成者。谓缘无常想起非无常行相思所成想。修所成者。谓缘无常想起非无常行相。问此修所成想说在何位。答在暖顶忍初及增长位。缘无常想起非无常行相法念住。若世第一法位起三行相法念住。若已入正性离生苦现观四心顷。起三行相法念住。集道现观各四心顷。起四行相法念住。若以缘无常想非无常行相法念住。离欲界乃至非想非非想处染。若即以此为加行。彼一切加行无间解脱道时。若以缘无常想非无常行相法念住。信胜解练根作见至。时解脱练根作不动。若即以此为加行。彼一切加行无间解脱道时。若以缘无常想非无常行相法念住。杂修静虑及起他心智宿住随念智通时。起缘无常想非无常行相法念住时。起四无量时。诸有欲令一切法是胜义者。即起此类法念住义无碍解时。及起此类法念住辩无碍解。愿智边际定无色解脱空识无边处遍处入灭尽定想微细心时。是名善想。染想者。谓缘无常想起萨迦耶见。执我我所起边执见。执断常起邪见。执无因无作及损减起见取。执上妙胜第一起戒禁取。执净解脱出离起疑犹豫不决。起无明无智黑闇愚痴。起贪爱乐悦意。起嗔不爱乐不悦意。起慢高举。如是等时是名染想。无记想者。谓缘无常想起非如理非不如理想。是名思惟无常想。缘无常想故不修无常想起余想故。有修无常想亦思惟无常想。谓缘无常想修无常想。如无常想长时相续现在前时。缘自相续过去未来。及他相续三世无常想。问此说在何位。答在暖顶忍初及增长位。缘无常想起无常行相法念住。若世第一法位起无常行相法念住。若已入正性离生苦现观四心顷。起无常行相法念住。若以缘无常想无常行相法念住。离欲界乃至非想非非想处染。若即以此为加行。彼一切加行无间解脱道时。若以此类法念住信胜解练根作见至。时解脱练根作不动。若即以此为加行。彼一切加行无间解脱道时。若以此类法念住杂修静虑。及有欲令一切法是胜义者。起义无碍解。及起愿智边际定无色解脱入灭尽定想微细心时。有说。及起无愿无愿三摩地时。如是等时修无常想无常想现在前故。亦思惟无常想缘无常想故。有不修无常想亦不思惟无常想。谓除前相。问此说在何位。答在初暖顶忍及增长忍。起缘灭谛法念住。若增长暖顶不缘无常想起非无常行相诸念住时。若已入正性离生灭现观四心顷。若于修位无学位中。起一切不缘无常想非无常行相诸念住时。如是等时不修无常想。无常想不现前故。亦不思惟无常想。不缘无常想故。迦湿弥罗国外诸师作如是说。有不修无常想亦不思惟无常想。谓缘余法修余想。如缘色受行识蕴除无常想。余想蕴起余想。缘无为起余想。余想者。谓无常苦想苦无我想。及余一切非无常想。广说应知如无常想。无常苦想苦无我想亦尔。差别者。说自名。及第三句中皆除无愿无愿不净想厌食想一切世间不可乐想死想断想离想灭想。随应当知者。谓若修不净想。彼不思惟不净想。以不净想现在前时缘显形色故。若思惟不净想。彼不修不净想。以缘不净想时余想现在前故。余想者。谓无常想无常苦想苦无我想。及余善染无记想。如不净想厌食想一切世间不可乐想死想断想离想灭想亦尔。差别者。说自所缘。谓若修厌食想。彼不思惟厌食想。以彼想现在前时缘香味触故。若思惟厌食想。彼不修厌食想。以缘彼想时余想现在前故。余想者如前说。若修一切世间不可乐想。彼不思惟一切世间不可乐想。以一切世间不可乐想现在前时缘诸世间可爱事故。若思惟一切世间不可乐想。彼不修一切世间不可乐想。以缘彼世间不可乐想时余想现在前故。余想者如前说。若修死想彼不思惟死想。以死想现在前时缘命根及命根俱生无常性故。若思惟死想彼不修死想。以缘彼死想时余想现在前故。余想者如前说。若修断想彼不思惟断想。以断想现在前时缘涅槃故。若思惟断想彼不修断想。以缘彼断想时余想现在前故。余想者如前说。如断想离想。灭想亦尔

说一切有部发智大毗婆沙论卷第一百九十三阿毗达磨大毗婆沙论卷第一百九十四

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    见蕴第八中三有纳息第二之三

诸有欲令此中通依得修习修作论者。彼说若修无常想者。谓无常想若现前若不现前。而修彼思惟无常想者。谓以无常想为所缘即是无常想。修时缘无常想义。若修无常想彼思惟无常想耶。答应作四句。有修无常想不思惟无常想。谓缘余法修无常想。如缘色受行识蕴。除无常想余想蕴。修无常想缘无为修无常想。问此说在何位。答此说在增长暖顶位。起身受心念住。及缘余法法念住。若初顶忍及增长忍起缘灭谛法念住。若以灭智离欲界乃至无所有处染。以身受心念住及缘余法法念住为加行。彼一切加行无间解脱道时。离非想非非想处染说亦尔。唯除第九解脱道时。若以缘灭谛法念住。信胜解练根作见至。若以身受心念住。及缘余法法念住为加行。彼加行无间解脱道时。无学练根说亦尔。唯除第九解脱道。若以身受心念住。及缘余法法念住杂修静虑时。若引发神境天眼天耳通时。若以受心念住及缘余法法念住起他心智通时。若起不净观持息念初三解脱八胜处前八遍处法词二无碍解时。起无诤空空无愿无愿无相无相时。有说。除起无愿无愿时。起身受心念住及缘余法法念住时。诸有欲令一切法是胜义者。起身受心念住及缘余法法念住义无碍解。及有欲令唯涅槃是胜义者。起义无碍解时起身受心念住。及缘余法法念住辩无碍解愿智边际定无色解脱入灭尽定想微细心时。于如是时修无常想不思惟无常想。有思惟无常想不修无常想。谓缘无常想修余想。余想者。谓无常苦想苦无我想及余善染无记想。此中善想者。谓加行善及生得善想加行善想。谓闻思修所成。闻思所成如前说。修所成者。谓缘无常想起非无常行相。修所成想而不修无常想。问此说在何位。答在初暖位缘集道谛时。若已入正性离生集现观四心顷。道现观三心顷。若异生离欲界乃至无所有处染。若以缘无常想法念住为加行。彼一切加行无间解脱道时。即异生引发缘无常想法念住。他心智宿住随念智通时。即异生起四无量及缘无常想法念住时。即异生起缘无常想法念住无色解脱。及起空识无边处遍处时。是名善想染及无记想。如前说。是名思惟无常想不修无常想。有修无常想亦思惟无常想。谓缘无常想修无常想。如无常想相续现在前时。缘自相续过未及他相续三世无常想。问此说在何位。答此说在初暖位。起缘苦谛法念住增长暖顶起缘无常想法念住初顶忍。及增长忍。起缘三谛法念住。若起世第一法。若已入正性离生苦现观四心顷。及道类智时。若以缘无常想法念住。离欲界乃至非想非非想处染。若即以此为加行。彼一切加行无间解脱道时。若以缘无常想法念住。信胜解练根作见至。时解脱练根作不动。若即以此为加行。彼一切加行无间解脱道时。若以缘无常想法念住杂修静虑时。若起缘无常想他心智宿住随念智通时。起四无量时。诸有欲令一切法是胜义者。起缘无常想义无碍解及辩无碍解。愿智边际定无色解脱。入灭尽定想微细心时。起空识无边处遍处时。有说。及起无愿无愿时。于如是时修无常想亦思惟无常想。有不修无常想亦不思惟无常想。谓除前相。问此说在何位。答此说在初暖位。起缘灭谛法念住时。若已入正性离生灭现观四心顷。及余一切不缘无常想。亦不修无常想位。如其所应尽当知。外国师诵亦如前应知。如无常想无常苦想苦无我想亦尔。差别者。说自名及第三句中除有说无愿无愿不净想厌食想一切世间不可乐想死想断想离想灭想。随应当知者。谓不净想等亦应作四句。而有差别。谓若修不净想彼思惟不净想耶。答应作四句。有修不净想彼不思惟不净想。谓缘余法修不净想。问此说在何位。答此说若以灭道智离欲界。乃至第三静虑染。若以身受心念住。及缘余法法念住为加行。彼一切加行道最后解脱道时。有说。一切解脱道时。若依有色定离第四静虑乃至非想非非想处染。若以身受心念住。及缘余法法念住为加行。彼一切加行道时。若生欲色界得阿罗汉果最后解脱道时若以灭道智。信胜解练根作见至。以身受心念住。及缘余法法念住为加行。彼加行道时解脱道不定如前说。时解脱练根作不动。若依有色定。以身受心念住。及缘余法法念住为加行。彼加行道及最后解脱道时。若以身受心念住。及缘余法法念住杂修静虑时。若引发神境天眼天耳他心智通四无间道一解脱道。及缘余法他心智通解脱道时。若起不净观持息念初三解脱八胜处前八遍处法词二无碍解时。若依有色定起身受心念住。及缘余法法念住时。诸有欲令一切法是胜义者。依有色定起身受心念住。及缘余法法念住义无碍解时。及有欲令唯涅槃是胜义者。起义无碍解时。若依有色定起辩无碍解。及起身受心念住。及缘余法法念住愿智边际定时。若起无诤时。若依有色定起空空无愿无愿无相无相时。于如是时修不净想不思惟不净想。有思惟不净想不修不净想。谓缘不净想修余想。余想者。谓无常想无常苦想苦无我想。及余善染无记想。此中善想者。谓加行善及生得善想加行善想。谓闻思修所成。闻所成者。谓缘不净想起闻所成想。思所成者。谓缘不净想起思所成想。修所成者。谓缘不净想起修所成想。而不修不净想。问此说在何位。答此说在初暖顶忍及增长忍位缘苦集谛。增长暖顶起缘不净想法念住。若起世第一法。若已入正性离生苦集现观各四心顷。若以世俗道或苦集智。离欲界乃至第三静虑染。一切九无间道八解脱道时。有说。唯无间道时。若以世俗道离第四静虑染。以空无边处近分缘不净想。法念住为加行。彼一切加行无间道时。若以苦集智离第四静虑染九无间道九解脱道时。若以苦集智。信胜解练根作见至。彼无间道时解脱道不定如前说。若依空无边处近分。起缘不净想法念住时。是名善想。染及无记想如前说。差别者缘不净想。于如是时思惟不净想不修不净想。有修不净想亦思惟不净想。谓缘不净想修不净想。问此说在何位。答此说若以世俗道或苦集智。离欲界乃至第三静虑染。以缘不净想法念住为加行。彼一切加行道最后解脱道时。有说。及一切解脱道时。若依有色定离第四静虑乃至非想非非想处染。若即依此以缘不净想法念住为加行。彼一切加行道时。若以缘苦集谛法念住。信胜解练根作见至。以缘不净想法念住为加行。彼加行道时解脱道不定如前说。若依有色定。时解脱练根作不动。以缘不净想法念住为加行。彼加行道时若以缘不净想法念住杂修静虑时。若起缘不净想他心智通时。若起宿住随念智通时。若起四无量时。若依有色定起缘不净想法念住时。诸有欲令一切法是胜义者。依有色定起缘不净想义无碍解时。若起缘不净想愿智边际定时。于如是时修不净想亦思惟不净想。有不修不净想亦不思惟不净想。谓除前相。问此说在何位。答此说初暖顶忍及增长忍起缘灭道谛法念住。若增长暖顶起身受心念住。及缘余法法念住。若已入正性离生灭道现观各四心顷。若以灭道智离欲界乃至第三静虑染。彼一切九无间道八解脱道时。有说。唯无间道时。若以灭道智离第四静虑染九无间道九解脱道时。若以世俗道离第四静虑染。即依空无边处近分。以身受心念住。及缘余法法念住为加行。彼加行道九解脱道时。若依有色定离空无边处乃至非想非非想处染。一切无间解脱道时。唯除离非想非非想处染最后解脱道。若依无色定离空无边处染。以身受心念住。及缘余法法念住为加行。彼一切加行无间解脱道时。若依无色定离上三无色染。彼一切加行无间解脱道时。唯除生欲色界离非想非非想染最后解脱道。若以缘灭道谛法念住。信胜解练根作见至。无间道时解脱道不定如前说。时解脱练根作不动。若依无色以身受心念住。及缘余法法念住为加行。彼一切加行无间解脱道时。唯除最后解脱道。若起无色解脱后二遍处时。若依无色起身受心念住。及缘余法法念住时。若依无色起义无碍解辩无碍解空空无愿无愿。无相无相。及起入灭尽定想微细心时。善位如是。若染污及无记位不缘不净想。并一切无心位。于如是时不修不净想亦不思惟不净想。如不净想厌食想乃至灭想亦尔。皆作四句。于中差别如理应思

若起欲寻彼思惟欲寻耶。答应作四句。有起欲寻不思惟欲寻。谓缘余法起欲寻。如缘色受想识蕴。除欲寻余行蕴起欲寻是名起欲寻不思惟欲寻。缘余法故。有思惟欲寻不起欲寻。谓缘欲寻起余寻。此有三种。谓善染无记。善者。谓加行善及生得善。加行善中通闻思修所成。闻所成者。谓缘欲寻起闻所成。思所成者。谓缘欲寻起思所成。修所成者。谓缘欲寻起修所成。问此说在何位。答此说初暖顶忍。及增长忍起缘欲界法念住。若增长暖顶起缘欲寻法念住。若起世第一法。若已入正性离生苦现观二心顷。谓苦法智忍苦法智集现观二心顷。谓集法智忍集法智。若以苦集智离欲界染。以缘欲寻法念住为加行。彼加行道九无间道九解脱道时。若以世俗智离欲界染。以缘欲寻法念住为加行。彼加行道九无间道时。若依未至定为离初静虑乃至非想非非想处染。以缘欲寻法念住为加行。彼一切加行道时。乃至若依第四静虑为离第四静虑乃至非想非非想处染。以缘欲寻法念住为加行。彼一切加行道时。若以苦集法智信胜解练根作见至。以缘欲寻法念住为加行。彼加行无间解脱道时。若时解脱练根作不动。若以缘欲寻法念住为加行。彼加行道时。若以缘欲寻法念住杂修静虑时。起缘欲寻他心智通时。起缘欲界宿住随念智通时。起四无量时。起缘欲寻法念住时。诸有欲令一切法是胜义者。起缘欲寻法念住义无碍解时。若起缘欲寻法念住无诤愿智边际定时。是名善。染污者。谓缘欲寻起萨迦耶见执我我所。广说如前。无记者谓缘欲寻起非如理非不如理作意。于如是时思惟欲寻不起欲寻。有起欲寻亦思惟欲寻。谓缘欲寻起欲寻。如欲寻长时相续现在前时。缘自相续过未及他相续三世欲寻。有不起欲寻亦不思惟欲寻。谓除前相外方师诵。谓缘余法起余寻。此中如缘色受想识蕴。除欲寻余行蕴起余寻。缘无为起诸寻。及余一切不起欲寻不思惟欲寻位。如欲寻恚寻害寻亦尔。差别者说自名。若起出离寻。彼思惟出离寻耶。答应作四句有起出离寻不思惟出离寻。谓缘余法起出离寻。如缘色受想识蕴。除出离寻。余行蕴起出离寻缘无为起出离寻。问此说在何位。答此说依未至初静虑初暖顶忍及增长忍。起缘灭谛法念住。若增长暖顶起身受心念住及缘余法法念住。若已入正性离生灭现观四心顷。若依未至定以灭智离欲界及初静虑染。及依初静虑以灭智离初静虑染。若以身受心念住及缘余法法念住为加行。彼一切加行无间解脱道时。即依彼二地以苦集灭智离第二静虑乃至非想非非想处染。若以身受心念住及缘余法法念住为加行。彼一切加行无间解脱道时。即依彼地以灭智信胜解练根作见至。若以身受心念住及缘余法法念住为加行。彼加行无间解脱道时。即依彼地以苦集灭智时解脱练根作不动。若以身受心念住及缘余法法念住为加行。彼一切加行无间解脱道时。若以身受心念住及缘余法法念住杂修初静虑时。若依初静虑引发神境天眼天耳他心智通。四无间道一解脱道。及缘余法他心智通解脱道时。若依未至起持息念时。若依未至初静虑。起初二解脱前四胜处不净观身受心念住。及缘余法法念住。诸有欲令一切法是胜义者。起身受心念住及缘余法法念住义无碍解。及有欲令唯涅槃是胜义者。起义无碍解时。即依彼二地起法无碍解词无碍解。若身受心念住及缘余法法念住辩无碍解时。即依彼二地起空空无愿无愿无相无相时。有说。但起无相无相时。于如是时起出离寻不思惟出离寻缘余法故

有思惟出离寻不起出离寻。谓缘出离寻起余寻。此有三种。谓善染无记。善者除思所成。余如前说。于修所成中此说在何位。答此说依静虑中间。及上三静虑初暖顶忍。及增长忍位。起缘三谛法念住。若增长暖顶位起缘出离寻法念住。若起世第一法。若已入正性离生。若集道现观各四心顷。若依静虑中间。以苦集道智离初静虑染。若即以此及缘出离寻世俗法念住为加行。彼一切加行无间解脱道时。即依静虑中间以道智离第二静虑乃至非想非非想处染。若即以此及缘出离寻苦集智世俗法念住为加行。彼一切加行无间解脱道时。唯除离有顶染最后解脱道。若依第二静虑近分离初静虑染。若即依此以缘出离寻法念住为加行。彼一切加行无间道时。若依第二静虑以道智离第二静虑乃至非想非非想处染。若即以此及缘出离寻苦集智世俗法念住为加行。彼一切加行无间解脱道时。唯除离有顶染最后解脱道。如依第二静虑。依第三第四静虑亦尔。若依空无边处以道智离空无边处乃至非想非非想处染。若即以此及缘出离寻世俗法念住为加行。彼一切加行无间解脱道时。唯除离有顶染最后解脱道。如依空无边处。依识无边处无所有处亦尔。若依非想非非想处为离彼染。以缘出离寻法念住为加行。彼加行道时。若依静虑中间乃至第四静虑。以苦集道智信胜解练根作见至。若即以此及缘出离寻世俗法念住为加行。彼加行无间解脱道时。即依彼诸地以道智时解脱练根作不动。若即以此及缘出离寻苦集智世俗法念住为加行。彼加行道九无间道八解脱道时。若依无色定以道智时解脱练根作不动。若即以此及缘出离寻世俗法念住为加行。彼加行道九无间道八解脱道时。若以缘出离寻苦集道智。世俗法念住杂修上三静虑时。若依上三静虑。引发缘出离寻他心智通宿住随念智通时。若依静虑中间乃至第四静虑起无量时。若起缘出离寻无色解脱时。若依静虑中间乃至非想非非想处。起缘出离寻法念住时。诸有欲令一切法是胜义者。依静虑中间乃至第四静虑。起缘出离寻苦集道智世俗法念住义无碍解时。依无色定起缘出离寻道智世俗法念住义无碍解时。若依静虑中间乃至非想非非想处。起缘出离寻辩无碍解时。若起缘出离寻愿智边际定。及入灭尽定想微细心时。是名善。染污者。谓缘出离寻起萨迦耶见执我我所。广说如前。无记者。谓缘出离寻起非如理非不如理作意。于如是时思惟出离寻不起出离寻

有起出离寻亦思惟出离寻。谓缘出离寻起出离寻。如出离寻长时相续现在前时。缘自相续过去未来及他相续三世出离寻。问此说在何位。答此说依未至初静虑初暖顶忍及增长忍位。起缘三谛法念住。若增长暖顶位起缘出离寻法念住。若起世第一法若已入正性离生苦集道现观各四心顷。若以世俗道苦集道智离欲界染。若即以此为加行。彼一切加行无间解脱道时。若依未至初静虑。以苦集道智离初静虑染。若即以此及缘出离寻世俗法念住为加行。彼一切加行无间解脱道时。即依彼二地以道智离第二静虑乃至非想非非想处染。若即以此及缘出离寻苦集智世俗法念住为加行。彼一切加行无间解脱道时。唯除离有顶染最后解脱道。即依彼二地以苦集道智信胜解练根作见至。若即以此及缘出离寻世俗法念住为加行。彼一切加行无间解脱道时。即依彼二地以道智时解脱练根作不动。若即以此及缘出离寻苦集智世俗法念住为加行。彼加行道九无间道八解脱道时。若以缘出离寻苦集道智世俗法念住杂修初静虑时。若依初静虑引发缘出离寻他心智宿住随念智通时。若依未至初静虑起无量时。及缘出离寻法念住时。诸有欲令一切法是胜义者。依未至初静虑。起缘出离寻苦集道智世俗法念住义无碍解时。即依彼二地起缘出离寻辩无碍解时。有说。即依彼二地起空空无愿无愿时。如是等时起出离寻亦思惟出离寻。有不起出离寻亦不思惟出离寻。谓除前相。问此说在何位。答此说依静虑中间乃至第四静虑。初暖顶忍及增长忍位。起缘灭谛法念住。若增长暖顶位起身受心念住及缘余法法念住。若已入正性离生灭现观四心顷。若依静虑中间。以灭智离初静虑染。以身受心念住及缘余法法念住为加行。彼一切加行无间解脱道时。即依静虑中间。以苦集灭智。离第二静虑乃至非想非非想处染。以身受心念住及缘余法法念住为加行。彼一切加行无间解脱道时。若依第二静虑近分离初静虑染。以身受心念住及缘余法法念住为加行。彼加行道解脱道时。若依第二静虑。以苦集灭智。离第二静虑乃至非想非非想处染。以身受心念住及缘余法法念住为加行。彼一切加行无间解脱道时。如依第二静虑乃至依无所有处亦尔。若依第三静虑近分离第二静虑染。若即依此以身受心念住及余法法念住为加行。彼一切加行无间解脱道时。如依第三静虑近分。依第四静虑近分亦尔。若依空无边处近分离第四静虑染。诸说无色近分有别缘者。彼说若即依此以身受心念住及缘余法法念住为加行。诸说无色近分无别缘者。彼说若即依此以缘余法法念住为加行。彼一切加行无间解脱道时。如依空无边处近分。乃至依非想非非想处近分亦尔。若依非想非非想处为离彼染起身受心念住。及缘余法法念住为加行。彼加行道时。若依静虑中间乃至第四静虑。以灭智信胜解练根作见至。以身受心念住及缘余法法念住为加行。彼加行无间解脱道时。若依静虑中间乃至无所有处。以苦集灭智。时解脱练根作不动。以身受心念住及缘余法法念住为加行。彼一切加行无间解脱道时。若依非想非非想处。时解脱为练根作不动故。以身受心念住及缘余法法念住为加行。彼加行道时。若以身受心念住及缘余法法念住杂修上三静虑时。若依上三静虑引发神境天眼天耳。及缘余法他心智宿住随念智通时。若依静虑中间第二静虑。起初二解脱前四胜处时。若起第三第八解脱后四胜处十遍处时。若起身受心念住。及缘余法法念住四无色解脱时。若依静虑中间乃至第四静虑起不净观。及依静虑中间第二第三静虑近分起持息念时。若依静虑中间乃至非想非非想处。起身受心念住及缘余法法念住时。诸有欲令一切法是胜义者。依静虑中间乃至非想非非想处。起身受心念住及缘余法法念住义无碍解。及有欲令唯涅槃是胜义者。即依彼诸地起义无碍解时。即依彼诸地起身受心念住。及缘余法法念住辩无碍解时。依静虑中间乃至第四静虑起法无碍解时。有说。及依静虑中间起词无碍解时。若起身受心念住。及缘余法法念住愿智边际定。及入灭尽定想微细心时。若起无诤时。若依静虑中间乃至非想非非想处。起空空无愿无愿无相无相时。如是等时不起出离寻。亦不思惟出离寻。如出离寻。无恚寻无害寻亦尔。三恶寻三善寻广说如杂蕴思纳息

说一切有部发智大毗婆沙论卷第一百九十四阿毗达磨大毗婆沙论卷第一百九十五

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    见蕴第八中三有纳息第二之四

诸法因无明此法缘无明耶。乃至广说。问何故此中依明无明而作论。答彼作论者意欲尔故。乃至广说。有说。此二是杂染清净根本法故。谓一切杂染无明为根本。如说。所有种种恶不善法。若生若长。皆以无明为根。为集为种类为等起。一切清净明为根本。如说所有种种善法。若生若长。无不以明为根为集为种类为等起。有说。此二俱是上首法故。谓世尊于契经中说此二种为上首法。如说。苾刍。无明为上首。无明为前相。种种恶不善法皆得生起。又由此成无惭愧者明为上首明为前相。种种善法皆得生起。又由此成有惭愧者。有说。此二是近相障对治法故。谓无明是明近障。明是无明近对治。有说。此二是所共知相违法故。谓无明违明。明违无明。有说。此二俱缘相摄不相摄四圣谛故。俱缘不相摄有漏无漏法故。俱缘不相摄有为无为法故。由此等种种因缘故。作论者依明无明而作斯论

然明无明为因缘法品类差别有十一种。彼欲界系有四种。谓善不善有覆无记无覆无记。色界系有三种除不善。无色界系亦尔。及无漏法。此中欲界系善法明无明俱非其因并作三缘。谓等无间所缘增上。不善法无明为其四因谓相应俱有同类遍行。亦为作四缘。明非其因为作二缘。谓所缘增上。欲界系有覆无记法无明为其四因。谓相应俱有同类遍行。亦为作四缘。明非其因为作一增上缘。欲界无覆无记法除无明异熟。无明非其因为作三缘。谓等无间所缘增上。明非其因为作一增上缘。无明异熟无明为作一异熟因。为作三缘。谓因等无间增上。非所缘。以彼异熟在五识故。明非其因为作一增上缘。色界系善法明无明俱非其因。并作三缘。谓等无间所缘增上。色界有覆无记法无明为其四因。谓相应俱有同类遍行。亦为作四缘。明非其因为作二缘。谓所缘增上。色界系无覆无记法无明非其因为作三缘。谓等无间所缘增上。明非其因为作一增上缘。如色界三种。无色三种亦尔。无漏法无明非其因。为作二缘。谓所缘增上除初无漏。余无漏法明为其三因。谓相应俱有同类为作四缘。除初明。余初无漏法明为其二因。谓相应俱有。或一因谓俱有。为作二缘谓因增上。初明明非其因。为作一增上缘。是谓此处略毗婆沙

诸法因无明彼法缘无明耶。答若法因无明彼法缘无明。此中因无明诸法以种类言之。彼法以无明为五因。谓相应俱有同类遍行异熟。缘无明者即因无明法以种类言之。无明为其四缘。有法缘无明不因无明。谓除无明异熟。诸余无覆无记行及善行。无明于彼法或为三缘或为二缘或为一缘而非其因。诸法因明彼法缘明耶。答若法因明彼法缘明。此中因明诸法以种类言之。彼法以明为三因。谓相应俱有同类。缘明者即因明法以种类言之。明为其四缘有法缘明不因明。谓初明及诸有漏行。明于彼法或为三缘或为二缘或为一缘而非其因

诸法因无明彼法缘明耶。答若法因无明彼法缘明。此中因无明诸法以种类言之。彼法以无明为五因如前说。缘明者即因无明法以种类言之。明为其二缘。谓所缘增上。有法缘明不因无明。谓除无明异熟。诸余无覆无记行及善行。明于彼法或为四缘或为三缘或为二缘或为一缘。无明非其因

诸法因明彼法缘无明耶。答若法因明彼法缘无明。此中因明诸法以种类言之。彼法以明为三因。谓相应俱有同类。缘无明者即因明法以种类言之。无明为其二缘。谓所缘增上。有法缘无明不因明。谓初明及诸有漏行。无明于彼法或为四缘或为三缘或为二缘或为一缘。明非其因

诸法因无明彼法不善耶。答若法。不善彼法因无明。此中因无明不善法。以种类言之。彼法以无明为四因。谓相应俱有同类遍行。有法因无明非不善。谓无明异熟及有覆无记行。此中无明异熟以无明为一异熟因。有覆无记行。种类言之。以无明为四因。谓相应俱有同类遍行。而彼法非不善。是无记故

诸法因明彼法善耶。答若法因明彼法善。此中因明善法。以种类言之。彼法以明为三因。谓相应俱有同类。有法善不因明。谓初明及善有漏行。此中初明是善而不以明为因。无前及俱明故。善有漏行亦不以明为因。无因义故

颇有不因明不因无明彼法非无因耶。答有。谓除无明异熟。诸余无覆无记行及初明善有漏行。如是诸法不因明不因无明而非无因。于中除无明异熟。诸余无覆无记行。以种类言之有四因。谓相应俱有同类异熟。初明有二因。谓相应俱有。善有漏行以种类言之有三因。谓相应俱有同类。问初明俱无漏得。亦不因明不因无明而非无因。此中何故不说。答此文应作是说及初明彼俱无漏得。而不说者当知此义有余。有说。此得摄在初明俱有因中是以不说。彼不应作是说。得非初明俱有因故。应言摄在初明品中。若说初明当知已说彼聚。诸法明无明义广说如杂蕴缘起纳息。

    见蕴第八中想纳息第三之一

诸法无常想生彼法无常想相应耶。如是等章及解章义既领会已。应广分别。问何故作此论。答为止愚相应法执相应法非实者意。显相应法决定实有。故作斯论。诸法无常想生彼法无常想相应耶。答应作四句。有法无常想生非无常想相应。谓无常想现前必灭余想现前必生彼相应法。此中说无常想无间无常苦想。乃至灭想随一现在前。彼相应法者。谓除想余九大地法。十大善地法。有寻有伺地。寻伺无寻。唯伺地伺及心。如是诸法无常想生无常想为等无间缘而起故。非无常想相应与苦无我想乃至灭想。随一相应故。有法无常想相应非无常想生。谓余想现前必灭无常想现前必生。彼相应法。此中说无常苦想乃至灭想随一无间无常想现在前

彼相应法者。谓除想余九大地法等。广说如上。如是诸法无常想相应非无常想生。无常苦想乃至灭想随一为等无间缘而起故。有法无常想生亦无常想相应。谓无常想现前必灭。无常想现前必生。彼相应法。此中说后无常想聚中。除无常想余心心所法。广说如上。如是诸法无常想生无常想为等无间缘而起故。亦无常想相应。彼聚中有故。无常想虽从无常想生。而非无常想相应。以自性于自性三因缘故不相应。如前说。有法非无常想生亦非无常想相应。谓余想现前必灭余想现前必生。彼相应法。此中说无常苦想。乃至灭想随一无间随一现在前。彼诸想相应法。广说如上。如是诸法非无常想生。余想为等无间缘而起故。亦非无常想相应。与余想相应故。如无常想乃至灭想亦尔。随其所应皆作四句。如是便有十种四句

诸法无常想生彼法无常想一缘耶。乃至广说。问何故作此论。答欲止愚于所缘体性执所缘性非实有法。显所缘性决定实有。故作斯论。诸法无常想生彼法无常想一缘耶。答应作四句。有法无常想生非无常想一缘。谓无常想现前必灭。余想现前必生。彼有余缘。此中说缘色蕴无常想无间缘受等蕴。无常苦想苦无我想随一现在前。缘余蕴及界处说亦尔。彼法从无常想生非无常想一缘。缘余法故。有法无常想一缘非无常想生。谓余想现前必灭无常想现前必生。彼有此缘。此中说缘色等蕴无常苦想苦无我想。随一无间即缘彼蕴无常想现在前。界处说亦尔。彼法无常想一缘不从无常想生。无常苦想苦无我想随一为等无间缘而起故。问此中说何想与何想同一缘耶。为说无常想与无常想同一缘。为说无常想与余想同一缘。设尔何失。二俱有过。若说无常想与无常想同一缘者。此文云何通。如说彼有此缘。若说无常想与余想同一缘者。此文复云何通。如说彼法非无常想生。有时彼想从无常想生故。答此中说无常想与无常想同一缘故言无常想一缘。问若尔。此文云何通。如说彼有此缘。有说。此文应作是说。谓余想现前必灭无常想现前必生。彼相应法。此则说无常想相应法与无常想相应。如是说者。此中摄三想。谓无常想后起余想。余想后复起无常想。于中说后起无常想与前无常想同缘故言无常想一缘。如是则二文善通。或有于此作如是问。今应思择。此中说何想与何想同一缘耶。为说无常想与余想同一缘。为说余想与无常想同一缘。耶。此二何差别。若说无常想与余想同一缘者。此文云何通。如说有法无常想一缘。若苦无我想无间无常想生。彼与苦无我想同一缘非无常想。若说余想与无常想同一缘者。有时彼法从无常想生。则不应说非无常想生。有说。此中说无常想与余想同一缘。问若尔者。此文云何通。如说有法无常想一缘。答应作是说。谓余想现前必灭无常想现前必生。彼想相应法。若尔彼法应从无常想生。亦与无常想同一缘。如是说者。此中应说无常想与无常想同一缘。是故此中总摄三想。谓初无常想。次起余想。余想无间复起无常想。此中说后生无常想与前生无常想同一缘。如是则二过俱离。有法无常想生无常想一缘。谓无常想现前必灭。无常想现前必生。彼有此缘。此中说缘色等蕴无常想无间即缘彼蕴无常想现在前。界处说亦尔。彼法从无常想生亦与无常想同一缘。有法非无常想生亦非无常想一缘。谓余想现前必灭余想现前必生。彼有余缘。此中说缘余蕴无常苦想苦无我想。随一无间缘余蕴无常苦想苦无我想随一现在前。界处说亦尔。彼法非无常想生。余想为等无间缘而起故。亦非无常想一缘。余想余缘故。如无常想乃至灭想亦尔。问此所说中余想可尔。不净想厌食想。过去缘过去。现在缘现在。未来生者缘未来。云何得成第三句耶。答依相似说亦无有过。谓前不净想缘骨琐而灭后不净想复缘骨琐而生。以境相相似故。亦名一厌食想亦尔

诸法由心起非不由心乃至广说。前业蕴中显示爱非爱果由心而起分位差别。此中显示身语二业由心而起分位差别。心有二种。谓转随转。转谓能引身语二业在彼前起。随转谓助身语二业。与彼俱生。此中说转不说随转。问所说诸法谓是何耶。或有说者。是别解脱律仪。若作是说。诸法是别解脱律仪者。彼说诸法由心起者。谓别解脱律仪心力所引起。非不由心者。无有离心力而得彼律仪。若时心起尔时彼法耶。答心先起后彼法。谓先起如是心。我当受别解脱律仪后便正起律仪表业。若时心灭尔时彼法耶。答心先灭后彼法。谓彼心先生已灭。后彼律仪表业生已复灭。所以者何。诸行无常所吞生已无力能暂停住刹那无间必谢灭故。若时心得尔时彼法耶。答心先得后彼法。谓彼善心由二缘故得。一善心相续。二界地来还彼律仪由表故得。若时心舍尔时彼法耶。答彼法先舍后乃心。谓彼律仪由四缘故舍。一舍学处。二二形生。三善根断。四舍众同分。有说。犯根本罪时亦舍。彼心由二缘舍。一善根断。二越界地。问若欲界命终还生欲界者。可先舍彼法后乃心。若欲界命终生色无色界及般涅槃者。彼法与心俱时而舍。云何得说彼法先舍后乃心。耶。答此中但说欲界命终还生欲界者。彼命终时舍众同分故别解脱律仪亦舍。虽舍众同分而不舍心。有说。欲界命终生色无色界及般涅槃者。亦是此中所说。彼将死时身力羸劣。或断末摩苦所触故。便失所受身语律仪。后命终时其心方舍。问若尔云何可说某苾刍命终。答仍本名故无过。如王失位犹名为王。问彼衣钵等诸出家者云何得分。答彼于昔时亦曾分他如是财物。今时命过他还分之。又是先来递传所许。曾闻昔有仙人命终。同梵行者以其财物输纳于王而作是言。此是某仙所有资产。彼无继嗣。今持与王愿为纳受。王令持还而语之言。诸出家者所受用物。我等俗人不应受用。从今以去诸出家者若当命终。所有资具同梵行者应共分之。由是开许故无有过。评曰。如前所说者好。所以者何。苦触非是舍戒缘故。本所要期乃至命终非命未终。离断善等而令戒舍。是最后命终刹那心与律仪一时俱失。若时心受异熟尔时彼法耶。答或尔时或余时。尔时者。谓一刹那或一相续或一分位或一众同分。余时者。谓异刹那或异相续或异分位或异众同分

以现在时有四种故。复有说者。诸法谓不律仪若作是说。诸法是不律仪者。彼说诸法由心起者。谓不律仪心力所引起。非不由心者。无有离心力而得不律仪。若时心起尔时彼法耶。答心先起后彼法。谓先起如是心。我当受作如是事业后便正起不律仪表业。若时心灭尔时彼法耶。答心先灭后彼法。谓彼心先生已灭。后不律仪生已复灭。所释如前。若时心得尔时彼法耶。答心先得后彼法。谓彼不善心由二缘故得。一从离欲退二界地来还彼不律仪由表故得。若时心舍尔时彼法耶。答彼法先舍后乃心。谓不律仪由四缘故舍。一受律仪。二得静虑。三二形生。四舍众同分。彼不善心由一缘舍。谓离欲染时。若时心受异熟尔时彼法耶。答或尔时或余时。如前释。复有说者。诸法谓非律仪非不律仪所有身语妙行恶行。若作是说。诸法是非律仪非不律仪。所有身语妙行恶行者。彼说诸法由心起者。谓彼身语妙行恶行心力所引起。非不由心者。无有离心力而得彼身语妙行恶行。若时心起尔时彼法耶。答心先起后彼法。谓先起如是心。我当作如是如是事业。后便正起彼身语表。若时心灭尔时彼法耶。答心先灭后彼法。如前释。若时心得尔时彼法耶。答心先得后彼法。谓彼善心二缘故。得。一善根相续。二界地来还。彼不善心亦二缘故得。一从离欲退。二界地来还彼身语妙行恶行由表故得。若时心舍尔时彼法耶。答彼法先舍后乃心。谓彼身语妙行恶行三缘故舍。一意乐息。二舍加行。三势力尽。彼善心二缘故舍。不善心一缘故舍。皆如前说。若时心受异熟尔时彼法耶。答或尔时或余时。如前释。颇有法是所通达所遍知。乃至广说。问何故作此论。答欲止他宗显己义故。谓或有说。所通达所遍知非实有法。或复有说。无漏有为亦是所断。或复有说。加行所起无覆无记亦是所修。或复有说。唯有涅槃是所作证。欲止此等意趣明所通达所遍知是实有法。所断唯是有漏。所修唯善。有为所证通一切善。及依定所起无覆无记。故造斯论。所通达者。谓一切法皆是善慧所通达故。所遍知者。谓一切法皆智遍知所遍知故。如说所通达云何。谓一切法。所遍知云何。谓一切法。所断者谓一切有漏法是对治道所应断故。如说所断法云何。谓一切有漏法。所修者谓一切善有为法。是得修习修随一或俱故。如说所修法云何。谓一切善有为法。所作证者。谓一切善及依定所起无覆无记是可欣尚求得彼故。如说所作证法云何。谓一切善法及依三摩钵底所起无覆无记天眼天耳。颇有法是所通达所遍知。非所断非所修非所作证耶。答有。谓虚空非择灭。如是二法是所通达。是善慧所通达故。亦是所遍知是智遍知所遍知故。非所断无漏故。非所修无为故。非所作证非可欣尚求得法故。颇有法是所通达所遍知。非所断非所修是所作证耶。答有。谓择灭此是所证是可欣尚求得法故。余如前释。颇有法是所通达所遍知。非所断是所修是所作证耶。答有。谓无漏有为法。此是所修善有为故。余如前释。颇有法是所通达所遍知是所断是所修是所作证耶。答有。谓善有漏行。此是所断有漏故。余如前释。颇有法是所通达所遍知是所断非所修是所作证耶。答有。谓定所起天眼耳。此是所断有漏故。非所修无记故。是所作证。依定所起求得彼故。余如前释。颇有法是所通达所遍知是所断非所修非所作证耶。答有。谓除定所起天眼耳。余无记行不善法。义如前释。问外国诸师说。所作证无覆无记法有八种。谓依定所起天眼天耳。及彼二识无覆无记法词二无碍解愿智变化心。此中何故但说天眼天耳非余法耶。答外国诸师所诵文句作如是说。所作证法云何。谓一切善法及依三摩钵底所起无覆无记法。迦湿弥罗国诸师亦应作是说。而不说者。有别意趣。谓依定所起天眼耳识摄在所说天眼耳中。若说所依当知已说依者法词二无碍解。及愿智皆唯是善亦是所修非此所摄。不应责问。变化心似工巧转非甚欣尚。此中不说。以是故不随彼所说。复次若依加行正所求得者是增上故。此中说之。天眼耳识无别加行。但因所求天眼耳得。诸变化心因起加行求离染得皆非增上。故此不说。复次天眼天耳广设加行暂时成就是为希有故此说之。彼识及变化心因离欲染或界地还时不用功而得。得已恒时三世成就非谓希有。故此不说。复次天眼天耳是修果故。是摄受支定果故。离欲染后能现前故。于一切时识不空故。起必无有。彼同分故。但成就者必作用故。是眼耳通所依止故。是厌生死胜根本故。此中说之。余法不尔。是故不说。此中所说非择灭者。谓灭非离系非择法所得诸补特伽罗得时不离系缚。所说择灭者谓灭是离系是择法所得诸补特伽罗得时便离系缚。此二灭广说如杂蕴爱敬纳息。颇有法无缘因缘无缘法缘无缘法俱生乃至广说。问何故作此论。答欲止他宗显己义故。谓或有说。诸有为相无实体性。如譬喻者所说。所以者何。彼说诸有为相是不相应行行蕴所摄。诸不相应行皆无实体。或复有说诸有为相是无为法。如分别论者所说。所以者何。彼作是说。若有为相是有为者。其力羸劣何能生他。乃至令灭。以是无为故便能生法乃至灭法。或复有说。有为相中生老住是有为。灭是无为。所以者何。彼说诸法令生老住则易。令灭则难。若无常相是有为者。其性羸劣何能灭他。以是无为故其性强盛能灭诸法。或复有说。色法生老住无常体即是色。余亦如是。或复有说。诸有为相是相应法。为止如是种种异执。显有为相是实有性非无为法。非即色等是不相应。故造斯论

颇有法无缘因缘无缘法缘无缘法俱生。是有是有性。非无非无性。异色异受想识异相应行耶。答有。谓五识身彼相应法及缘色无为心不相应行意识身彼相应法所有生老住无常此法无缘。是不相应行无所缘故。此因缘无缘法缘无缘法俱生。以前所说六识身及相应法为因。即与彼俱生故。由此已遮执有为相是无为者意。非无为法从因生故。此是有非无法故。是有性非假法故。非无非无性。此为决定前所说义。复次前二句成立己论。后二句遮破他论。成立己论者。如善说法者成立善说法宗。恶说法者成立恶说法宗。应理论者成立应理论宗。分别论者成立分别论宗。遮破他论者。如善说法者遮破恶说法宗。恶说法者遮破善说法宗。应理论者遮破分别论宗。分别论者遮破应理论宗。今此亦然。前二句成立自宗。后二句遮破他宗。若不成立自宗便破他者。则为空论。无所依故。若但成立自宗不破他者。则于自宗非善成立。是故先立己宗后破他论。义言此生老住无常有如是理趣。法尔是有是有性。非无非无性。由此已遮执有为相非实有者意。此异色非色法故。异受想识。非受想识法故。由此已遮执色等相即是色等此异相应行是不相应法故。由此已遮执有为相是相应法。此法于彼法当言因当言缘耶。答当言因当言缘。此中何谓此法何谓彼法。有作是说。生老住无常是此法。此俱六识身及相应法是彼法。若作是说者。彼说若此法于俱起彼法当言因当言缘。因者一因谓俱有。缘者二缘。谓因增上。若此法于后起彼法亦当言因当言缘。因者三因。谓同类遍行异熟。缘者三缘。除等无间。若此法于前起彼法当言缘不当言因。缘者二缘。谓所缘增上。若此法总于彼法当言因当言缘。因者四因。谓俱有同类遍行异熟。缘者三缘。除等无间。复有说者。前所说六识身及相应法。是此法此俱生老住无常是彼法。若作是说者。彼说若此法于俱起彼法当言因当言缘。因者一因。谓俱有。缘者二缘。谓因增上。若此法于后起彼法当言因当言缘。因者三因。谓同类遍行异熟。缘者二缘。谓因增上。若此法于前起彼法当言缘不当言因。缘者一缘。谓增上。若此法总于彼法当言因当言缘。因者四因。谓俱有同类遍行异熟。缘者二缘。谓因增上。复有说者。即前生老住无常是此法此同类生老住无常是彼法。若作是说者。彼说若此法于俱起彼法当言因当言缘。因者一因。谓俱有。缘者二缘。谓因增上。若此法于后起彼法当言因当言缘。因者三因。谓同类遍行异熟。缘者二缘。谓因增上。若此法于前起彼法当言缘不当言因。缘者一缘。谓增上。若此法总于彼法当言因当言缘。因者四因。谓俱有同类遍行异熟。缘者二缘。谓因增上。复有说者。即前所说生老住无常是此法。此生同类生乃至此无常同类无常是彼法。若作是说者。彼说若此法于俱起彼法当言因当言缘。因者一因。谓俱有。缘者二缘。谓因增上。若此法于后起彼法当言因当言缘。因者三因。谓同类遍行异熟。缘者二缘。谓因增上。若此法于前起彼法当言缘不当言因。缘者一缘。谓增上。若此法总于彼法当言因当言缘。因者四因。谓俱有同类遍行异熟。缘者二缘。谓因增上。此法当言善耶不善耶无记耶。答于善法当言善。于不善法当言不善。于无记法当言无记。以生所生乃至灭所灭性类必同故。此法几随眠随增。几结系耶。答三界有漏缘随眠随增九结系。问何故不说此法无漏缘随眠随增耶。答由二缘。故随眠随增。一所缘故。二相应故。无漏缘随眠无所缘故。随增境解脱故。虽有相应故随增而于此无不与此相应故。此中依种类总说故言三界有漏缘随眠随增九结系。若别说者欲界于欲界。乃至无色界于无色界。见苦所断一切及见集所断遍行。于见苦所断。见集所断一切。及见苦所断遍行。于见集所断。见灭所断有漏缘及遍行。于见灭所断。见道所断有漏缘及遍行。于见道所断。修所断一切及遍行于修所断。欲界九结。于欲界。色界六结。于色界。无色界六结。于无色界。如是三界有漏缘随眠及九结。于此法皆由所缘故随增及系非相应故。诸有为相广说如杂蕴色纳息

说一切有部发智大毗婆沙论卷第一百九十五阿毗达磨大毗婆沙论卷第一百九十六

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    见蕴第八中想纳息第三之二

见相应受几随眠随增乃至广说。问何故作此论。答为止拨无世俗正见者意。显实有世俗正见是修所断及遍行随眠之所随增。又遮说有修所断疑随眠者意。显疑随眠唯见所断。故作斯论。问如夜见物。杌耶人耶。此疑岂非修所断耶。答此于彼事未了故疑。了时便断非随眠性。问此中何故但依见疑而作论。答彼作论者意欲尔故。乃至广说。复次唯此二种互不相应而俱缘四谛。俱通遍行。俱缘有漏无漏。俱缘有为无为。于余烦恼为胜。贪嗔慢虽互不相应。而不能通缘四谛。唯不遍行。但缘有漏。但缘有为无明虽缘四谛。亦是遍行通缘有为无为有漏无漏。而与一切烦恼相应皆非增胜。是故此中但依见疑而作论。见相应受几随眠随增。答三界有漏缘及无漏缘见彼相应无明随眠随增此则总说。若别说者见相应受差别有五。谓见苦所断乃至修所断。此中见苦所断见相应受见苦所断一切。及见集所断遍行随眠随增。见集所断见相应受见集所断。一切见苦所断遍行随眠随增。见灭所断见相应受。见灭所断无漏缘见彼相应无明见灭所断。一切有漏缘。及遍行随眠随增。见道所断见相应受见道所断无漏缘见彼相应无明见道所断。一切有漏缘及遍行随眠随增。修所断见相应受修所断一切。及遍行随眠随增。此中随增差别应作四句。或有随眠于见相应受所缘故随增非相应故。或有随眠于见相应受相应故随增非所缘故。或有随眠于见相应受所缘故随增亦相应故。或有随眠于见相应受非所缘故随增亦非相应故。初句者谓除有漏缘见彼相应无明。诸余有漏缘随眠。第二句者谓无漏缘见彼相应无明。第三句者谓。有漏缘见彼相应无明。第四句者谓除无漏缘见彼相应无明。诸余无漏缘随眠

见不相应受几随眠随增。答除无漏缘见彼相应无明。余随眠随增。此则总说。若别说者。见不相应。受差别有五。谓见苦所断乃至修所断。此中见苦所断见不相应受。见苦所断一切及见集所断遍行随眠随增见集所断见不相应受。见集所断一切。及见苦所断遍行随眠随增。见灭所断见不相应受。除见灭所断邪见彼相应无明诸余见灭所断及遍行随眠随增。见道所断见不相应受。除见道所断邪见彼相应无明。诸余见道所断。及遍行随眠随增。修所断见不相应受。修所断一切及遍行随眠随增。此中随增差别亦作四句。或有随眠于见不相应受。所缘故随增非相应故。乃至广作四句。第一句者谓有漏缘见彼相应无明。第二句者谓除无漏缘见彼相应无明。诸余无漏缘随眠。第三句者谓除有漏缘见彼相应无明。诸余有漏缘随眠。第四句者谓无漏缘见彼相应无明

疑相应受几随眠随增。答三界见所断有漏缘。及无漏缘疑彼相应无明随眠随增。此则总说。若别说者疑相应受差别有四。谓见苦集灭道所断。此中见苦所断见集所断如前说。见灭所断疑相应受。见灭所断疑彼相应无明见灭所断一切有漏缘。及遍行随眠随增。见道所断疑相应受。见道所断疑彼相应无明。见道所断一切有漏缘。及遍行随眠随增。此中随增差别亦作四句。或有随眠。于疑相应受。所缘故随增非相应故。乃至广作四句。第一句者谓除有漏缘疑彼相应无明。诸余见所断有漏缘随眠。第二句者谓无漏缘疑彼相应无明。第三句者谓有漏缘疑彼相应无明。第四句者谓除无漏缘疑彼相应无明。诸余无漏缘随眠

疑不相应受几随眠随增。答除无漏缘疑彼相应无明。余随眠随增。此则总说。若别说者疑不相应受差别有五。谓见苦所断乃至修所断。此中见苦所断见集所断如前说。见灭所断疑不相应受。除见灭所断疑彼相应无明。诸余见灭所断。及遍行随眠随增。见道所断疑不相应受。除见道所断疑彼相应无明。诸余见道所断。及遍行随眠随增。修所断疑不相应受。修所断一切及遍行随眠随增。此中随增差别亦作四句。或有随眠于疑不相应受所缘故。随增非相应故。乃至广作四句。第一句者谓有漏缘疑彼相应无明。第二句者谓除无漏缘疑彼相应无明。诸余无漏缘随眠。第三句者谓除有漏缘疑彼相应无明。诸余有漏缘随眠。第四句者无漏缘疑彼相应无明

因道缘起法几界几处几蕴摄。答十八界十二处五蕴。此中因者六因。谓相应乃至能作。道者八支圣道。谓正见乃至正定。缘起者十二支缘起。谓无明乃至老死。此因道缘起具摄一切界处蕴法。问因及缘起可尔。道云何亦具摄耶。答此文应作是说。因及缘起十八界十二处五蕴摄。道三界二处五蕴摄。而不作是说者。当知此中总说因道缘起摄一切界处蕴非一一摄。复有说者。因道缘起法皆谓六因此皆因之差别名故。如施设论说。因道路等尽同一义。是以皆摄十八界等。有作是说。因谓一切有为法。如品类足说。因法云何。谓一切有为法由此具摄十八界等。道即是因此因与谁为道与所得果。由此亦摄十八界等。缘起亦是一切有为法。如品类足说。缘起法云何。谓一切有为法。由此亦摄十八界等。除眼触等起想受心相应法及耳触等起想受心不相应法。余法几界几处几蕴摄。答十八界十二处五蕴等起有二种。谓因及刹那。此中但说刹那等起。以说相应不相应故。问此所说中除何相应不相应法。取何余法界处蕴摄耶。答此中除眼触聚中非触想受心。余相应法及耳触聚中生老住无常。取所余法界处蕴摄。所以者何。此所说中若法是眼触等起想受心相应。及耳触等起想受心不相应者。是所除彼眼触聚中触虽与想受心相应。而非眼触等起自体。于自体无等起义故。想虽眼触等起及受心相应。而非想相应自体。于自体无相应义故。受心说亦尔。是故眼触聚中触想受心皆非所除。余相应法眼触等起及想受心相应故乃是所除。耳触聚中触非耳触等起。亦非想受心不相应。想虽耳触等起及想不相应。而与受心相应。受心说亦尔。余心所法虽耳触等起。而与想受心相应。是故耳触聚中心心所法皆非所除。彼俱起生老住无常耳触等起。及想受心不相应故乃是所除是名所除法。余法云何。谓六触身六想身六受身六识身。及耳鼻舌身意触聚中余相应行蕴。除耳触聚中生老住无常。余不相应行蕴一切色无为。如是余法十八界十二处五蕴摄。乃至除身触等起想受心相应法。及意触等起想受心不相应法。余法几界几处几蕴摄。答十八界十二处五蕴。此中展转相望所除所取准前应广释。有余于此作差别说。谓除眼触等起想受心不相应法。及耳触等起想受心相应法。余法十八界十二处五蕴摄乃至除身触等起想受心不相应法。及意触等起想受心相应法。余法摄如前说复有于此作差别说。谓除眼触等起想受心相应法。及耳触等起想受心相应法。余法摄如前说。乃至除身触等起想受心相应法。及意触等起想受心相应法余法摄如前说。复有于此作差别说。谓除眼触等起想受心不相应法。及耳触等起想受心不相应法。余法摄如前说。乃至除身触等起想受心不相应法。及意触等起想受心不相应法。余法摄如前说

    见蕴第八中智纳息第四之一

若事能通达彼事能遍知耶。如是等章及解章义。既领会已次应广释。问何故作此论。答欲止他说忍即是智性者意。显示诸忍与自所断疑得俱生。未重审决不得名智。故作斯论。事有五种一自性事二系事三所缘事四因事五摄受事。自性事者如世尊说。我当为汝说四十四智事。及七十七智事。谓缘有支智以事声说。尊者妙音作如是说。彼经说所缘事。谓诸有支是智所缘故说名事。然彼契经说智为事非诸有支。以后释中但说智故。系事者如前一行中说。若事爱结系彼事亦恚结系耶。谓五部烦恼于五部法或所缘故系。或相应故系。彼五部法以事声说。所缘事者如品类足说。一切法皆智所知随其事。云何随其事。谓随其所行随其境界随其所缘。诸智所行境界所缘以事声说。因事者如品类足说。有事法无事法即是有因法无因法又如世尊伽他中说

  苾刍心寂静　　能永断诸事
  生死毕竟灭　　更不受诸有

此中诸因以事声说。一切生死无不由因。诸因若断生死便灭不受诸有得般涅槃。摄受事者如契经说。弃舍所摄受田事宅事财宝等事。又如世尊伽他中说

  人于田事财　　牛马童仆等
  男女诸亲欲　　各别而耽爱

又在家者作如是言。我已取彼尔所事。彼犹负我尔所事。诸如是等名摄受事。复有五种事。一界事二处事三蕴事四世事五刹那事。于十种事中此中依自性事而作论。谓忍智等自性以事名说

若事能通达彼事能遍知耶。答应作四句。此中能通达依无漏道智遍知说能如实知故能遍知。依无漏道证断遍知说能永断烦恼。故此二互有长短故应作四句。有事能通达非遍知。谓苦集灭道智不断诸烦恼。此则见道中诸所有智。及修道等中除正断烦恼道余四谛智。如是诸智是能通达如实智性故非遍知。不断烦恼故。有事能遍知非能通达。谓苦集灭道忍断诸烦恼。此则见道中断烦恼诸忍。若未离欲染者通法忍类忍。若已离欲染者唯类忍。如是诸忍是能遍知永断烦恼故非能通达非如实智性故。问若诸忍非能通达者品类足说当云何通。如彼说能通达云何。谓善慧。所通达云何。谓一切法忍是善慧自性。何故此中说非能通达耶。答此文应作是说。若事是能通达彼事亦是能遍知。若事是能遍知彼事亦是能通达。而不作是说者有别意趣。谓此中依智遍知说能通达。依能证断遍知说能遍知故不应难。有事能通达亦能遍知。谓苦集灭道智断诸烦恼此则修道中正断烦恼。道苦等四智是能通达如实智性故亦能遍知永断烦恼故。有事非能通达亦非能遍知。谓苦集灭道忍不断诸烦恼。此则已离欲染者于见道中四法忍非能通达。非如实智性。故亦非能遍知不永断诸烦恼故。彼所对治烦恼先已断故

若事能厌彼事能离耶。答应作四句。此中厌者于有漏法厌行相转。离者能离所断烦恼。此二互有长短故应作四句。有事能厌非能离。谓苦集忍智不断诸烦恼。此则已离欲染入见道者。于见道中苦集法忍。及一切苦集智。于修道等中除正断烦恼道。余苦集智是能厌缘可厌事转故。非能离不断烦恼故。有事能离非能厌。谓灭道忍智断诸烦恼。此则未离欲染者。见道中灭道法忍。及一切灭道类忍。于修道中正断烦恼。灭道二智。如是忍智是能离能断烦恼故。非能厌缘可欣事转故。有事能厌亦能离。谓苦集忍智断诸烦恼。此则未离欲染者。于见道中苦集法忍。及一切苦集类忍。于修道中正断烦恼道苦集二智。如是忍智是能厌缘可厌事转故。亦能离断诸烦恼故。有事非能厌亦非能离。谓灭道忍智不断诸烦恼。此则已离欲染者。于见道中灭道法忍及一切灭道智。于修道等中除正断烦恼道余灭道智。如是忍智非能厌缘可欣事转故。亦非能离不断烦恼故。若事能厌彼事修厌耶。答若事能厌彼事亦修厌。此中修者得修习修。于见道中苦集忍智。于修道等中唯苦集智。如是忍智是能厌缘可厌事转故。亦能修厌以厌行相于现在未来或一或俱修故。有事修厌非能厌。谓灭道智断诸烦恼。此则于修道中以灭道智离三界染时。于未来世修苦集智厌行相故说名修厌。缘灭道谛可欣事转故不名能厌。问有灭道智现在前时。不断烦恼而亦能修厌。如在修道无学道中一切离染加行解脱胜进道时。灭道二智及则以此二智练根杂修静虑。引发诸通诸无碍解无色解脱。及念住等诸功德时。亦能修厌而非能厌。此中何故不说耶。答亦应说而不说者当知此义有余。有说。此中说决定者。谓灭道智断诸烦恼。无间道时决定能修苦集二智。唯未曾得而现前故。余时不定或是曾得或未曾得。若是曾得则不能修是故不说。有说。此中说最初位不说余位。有说。此中随其显相以要言之。是故不说余位修厌

若事能离彼修厌耶。答应作四句。有事能离非修厌。谓灭道忍断诸烦恼此则未离欲染者。于见道中灭道法忍。及一切灭道类忍。如是诸忍是能离断烦恼故非修厌。尔时唯修欣行相故。有事修厌非能离。谓苦集忍智不断诸烦恼。此则已离欲染者见道中苦集法忍。及一切苦集智。于修道等中除正断烦恼道余苦集智。如是忍智是修厌。尔时能修厌行相故。非能离不断烦恼故。问有灭道智现在前时。不断烦恼亦修厌非离。如在修道无学道中。一切离染加行解脱胜进道时。灭道二智及则以此二智练根杂修静虑。引发诸通诸无碍解无色解脱。及念住等诸功德时。亦修厌而非离此中何故不说。答亦应说。而不说者当知此义有余。有说。此中说决定者。谓彼诸位苦集二智决定。修厌灭道二智则不决定。以曾得者现在前时不修厌故。有事能离亦修厌。谓苦集忍智及灭道智断诸烦恼。此则未离欲染者于见道中苦集法忍。及一切苦集类忍。于修道中正断烦恼道苦集灭道智。如是忍智是能离断诸烦恼故亦修厌。尔时能修厌行相故。有事非能离亦非修厌。谓灭道忍智不断诸烦恼。此则已离欲染者于见道中灭道法忍。及一切灭道智。于修道等中曾得灭道智现在前时。如是忍智非离不断烦恼故亦非修厌。尔时不修厌行相故。前来所说厌离及修诸句差别。皆依无漏法类忍智分位差别。不依余者乘前通达遍知事故。通达遍知唯无漏故

问如所说厌体性是何。为是无贪为是慧耶。设尔何失。若是无贪此文所说当云何通。如说有事能厌亦能离。谓苦集忍智断诸烦恼。杂蕴所说复云何通。如说云何习厌离贪。谓无学厌相应无贪无嗔无痴。非无贪与无贪可说相应。自性与自性不相应故。若是慧者则上所说复云何通。如说云何习厌离贪。谓无学厌相应无贪无嗔无痴。无痴则慧非慧与慧可说相应。所以如前。此中有说。厌体性是无贪。问若尔者此文所说当云何通。如说有事能厌亦能离乃至广说。答彼中说厌相杂法名厌。谓无贪与忍智相应说为忍智。问杂蕴所说复云何通。如说云何习厌离贪乃至广说。答彼文应作是说。厌相应无嗔无痴善根。不应说无贪而说者当知是诵者随言势增益。有作是说。厌体是慧。问若尔者则杂蕴所说复云何通。如说云何习厌离贪乃至广说。答彼文应作是说。厌相应无贪无嗔不应说无痴。而说者当知是诵者随言势增益。评曰。应说厌体性异非无贪非慧。别有心所法名厌与心相应。此则摄在复有所余心所法中。此中说无漏厌。然亦有有漏厌。谓与不净观持息念。念住三义观七处善。暖顶忍世第一法。见道中现观边世俗智。修道等中如病如痈如箭行相静虑无量无色解脱胜处遍处等相应。广说过四大海今略说尔所。如是厌所厌事应作四句。有厌非所厌。谓无漏厌。有所厌非厌谓除有漏厌余有漏法。有厌亦所厌谓世俗厌。有非厌非所厌谓除无漏厌余无漏法。问若缘一切法作无我行相。当说是欣相作意厌相作意耶。设尔何失。若是欣相作意者。云何亦缘厌事转耶。若是厌相作意者云何亦缘欣事转耶。答应作是说是欣相作意。问若尔云何亦缘厌事转耶。答彼观行者于可欣事深乐观察。虽缘无量可厌事犹故生欣。如于铜钱聚上置一金钱。以金钱故而于彼聚生欣乐心。此亦如是

若法与彼法作因。或时此法不与彼法。作因耶。答无时非因。问何故作此论。答为止愚于因缘法执因缘性非实有者意。显因缘法体性实有故作斯论。有说。此中依一因作论。谓相应因。以相应因诸心心所同取一缘恒不相离通三世故。有说。此中依二因作论。谓相应俱有。以此二因俱通三世不相离故。有说。此中依三因作论。谓相应俱有异熟。此三于果有胜功能通三世故。有说此中依四因作论。谓相应俱有异熟能作。以此四因通三世故。有说。此中依五因作论。谓除遍行因。有说。此中依六因作论。问若法未至已生位则不能为同类遍行因。至已生位方能为因。如何依六因作论说无时非因耶。答此依最后位说。谓未来法至正生位定能为因。从此以后无时非因故作是说。问若尔者等无间缘何故不作是说。如说若法与彼法作等无间。或时此法不与彼法作等无间耶。答若时此法未至已生。然心心所法应为等无间缘者。至正生位定能为缘。何故不说无时非等无间耶。答彼亦应作是说而不说者。当知欲现种种文种种说庄严于义令易解故。复次欲现二门二略二阶二影二明二炬互相显示。如此彼亦尔。如彼此亦尔故。余义广说如杂蕴智纳息

若法与彼法作等无间。或时此法不与彼法作等无间耶。答若时此法未至已生。问何故作此论。答为止愚于等无间缘法执等无间缘法非实有者意。显等无间缘法体是实有故作斯论。问若时此法未至已生者此法是何。为前为后为前法未至已生位不与后法作等无间。若至便作等无间耶。为后法未至已生位。不与前法作等无间。若至便作等无间耶。如世第一法生苦法智忍为世第一法未至已生位。不与苦法智忍为等无间。若至便作等无间耶。为苦法智忍未至已生位。不与世第一法为等无间若至便作等无间耶。若前法未至已生位。不与后法作等无间。若至便作者有心位可尔。无心位云何可尔。如入无想定或灭尽定经七昼夜或复多时。若入定心至已生位。则与出定心为等无间者应第二刹那出定心则生。所以者何。若法与彼法为等无间缘取彼为果必无有法。或诸有情若药草若咒术若佛若独觉若到究竟声闻。有能障彼令第二刹那不得生者。是则二无心定应永不起。若后法未至已生位不与前法作等无间。若至便作者岂不苦法智忍未至已生位。亦与世第一法为等无间耶。此中有说。若前法未至已生位。不与后法作等无间。若至便作。问若然者有心位可尔无心位云何可尔。答此中说有心位不说余位。有说。设依无心位说亦无有过。谓入定心现在前时顿取诸定及出心果。亦与最初刹那定果后诸定刹那。及出定心生时与果非取先已取故。评曰。彼不应作是说。所以者何。无有等无间缘异时取果异时与果。若此时取果。则此时与果故。有作是说。若后法未至已生位不与前法作等无间。若至便作。问岂不苦法智忍未至已生位亦与世第一法为等无间耶。答尔时虽与世第一法作等无间。而非等无间缘。若至已生位亦名等无间亦名等无间缘。如等无间等无间缘。如是等无间有等无间相续有相续亦尔。余义广说如杂蕴智纳息

说一切有部发智大毗婆沙论卷第一百九十六阿毗达磨大毗婆沙论卷第一百九十七

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    见蕴第八中智纳息第四之二

若法与彼法作所缘或时此法与彼法非所缘耶。答无时非所缘。问何故作此论。答欲止愚于所缘缘法执所缘缘法无实体性。显所缘缘是实有法故作斯论。此中无时非所缘者以心心所法于所缘定故。问云何心心所法于所缘定。为于处定。为于青等定。为于刹那定耶。此中有说。心心所法但于处定非于青等及刹那定。所以者何。若于青等及刹那定者则无量心心所法住不生法中。欲令无如是过故唯于处定。问若唯于处定者彼色处中有青黄等多种色性。若于此不定者彼了青觉则了。黄等余亦如是。不可一觉有多了性无二决定故。有说。心心所法于处定。亦于青等定非于刹那定。所以者何。若于刹那定者则无量心心所法住不生法中。勿有斯过是故不说于刹那定。问若尔者如青色中有多种青。谓青根青茎青枝青叶青花青果。若当于此不说定者彼了根觉则了。茎等余亦如是。不可一觉有多了性无二决定故。如是说者。心心所法于三事定。问若尔者则应无量心心所法住不生法中。答即无量心心所法住不生法中复有何过。未来世宽无容处耶。然彼本来已有住处。问心心所法如于所缘定亦于所依定耶。答于所依亦定。谓眼等五识及相应法。在未来世与所依远。现在则俱过去复远。有说。未来与所依远。现在过去与所依俱。余义广说如杂蕴智纳息

若法与彼法作增上。或时此法与彼法非增上耶。答无时非增上。问何故作此论。答为止愚于增上缘性执增上缘非实有者意。显增上缘体性实有故作斯论。问缘和合故诸法生灭。此缘无有不和合时。诸法云何不恒生灭。尊者世友作如是言。诸法生灭和合各异。谓余缘和合故诸法生。余缘和合故诸法灭。是故不恒生灭。复次此法生已余法随生有多刹那次第邻逼。是故无有重生功能如人堕涯隤壤所压欲起复压。彼人尔时尚不能动何况得起。诸法亦然。是故无有恒生灭过。余义广说如杂蕴智纳息。诸意触彼一切三和合触耶。乃至广说。问何故作此论。答欲止他宗显己义故。谓或有执。心所则心。或有说。触则根境识。为止彼意显心所非心别有触体与心相应。又为止他疑故。谓或有疑眼触乃至身触名三和合是义可尔。彼根境识俱时生故意触亦名三和合触云何可尔。所以者何。意根过去意识现在法或三世或离世故。今欲决定显意触亦名三和合。触以互不相违共生一果名为和合非唯俱起名和合故。由此因缘故作斯论。诸意触彼一切三和合触耶。答诸意触彼一切三和合触。无触不因三和合故。有三和合触非意触。谓五识身相应触。故世尊说苾刍当知。有意界有法界有无明界。无明触所生受。受所触故无闻愚夫便执有执无。或执有无。此中有意界者谓过去意界。有法界者谓三世法界。有无明界者谓现在无明界。无明触等者谓于无我事愚。便执有者。谓起常见。便执无者谓起断见。或执有无者谓起断常见。胁尊者言。此中意说。于自体愚名无明界。彼无间灭六识身名意界。尔时心心所法所于转者名法界。无明触等如前说。问五识相应触由现在根境识。有名三和合触是义可尔。意识相应触根在过去境或未来识在现在云何名三和合触。答和合有二种。一俱起不相离名和合。二不相违同办一事名为和合。五识相应触由二和合故名和合。意识相应触由办一事和合故名和合。所以者何。如五识根境现在所有作用如是。意识根境异世作用亦尔。是故尊者妙音作如是说。以根境识同办一事故名和合。非以俱起不相离故名为和合。如此三法随在何时皆能展转办一事故尽名和合。有余于此作增益文。诸眼触乃至身触彼一切三和合触耶。答诸眼触乃至身触彼一切三和合触。有三和合触非眼触乃至身触。谓意识身相应触然今不作如是说者有何意耶。欲显此中但成立不极成义。眼触乃至身触名三和合触义自成立故不说之。意触名三和合触义非极成是以故。说由此如前所诵者好。诸慢彼一切自执耶。乃至广说。问此见蕴中但应分别见何故分别慢耶。答彼作论者意欲尔故乃至广说。有说。以相似故谓一切烦恼中无有烦恼非见自性。而似见转犹如慢者。有说。先已说一一蕴中分别一切法。若此蕴中不分别慢者。云何名一一蕴分别一切法耶。是故此中亦分别慢诸慢彼一切自执耶。答诸慢彼一切自执。以慢是自举自恃执竞法故。有自执非慢。谓诸见趣。故世尊说苾刍当知。自执有我自执有我所。此中自执有我者显示我见。自执有我所者显示我所见。复次自执有我者显示五我见。自执有我所者显示十五我所见。复次自执有我者显示我执行相。自执有我所者显示我所执行相。有作是说。自执有我者显示我爱。自执有我所者显示我所爱。有余师说。自执有我者显示我愚。自执有我所者显示我所愚

复有说者。自执有我者显示无别异事萨迦耶见。自执有我所者显示有别异事萨迦耶见。一切烦恼中无有烦恼非慢自性而似慢转。犹如见者故说见趣自执非慢

诸慢彼一切不寂静耶。问何故复作此论。答前唯分别慢与见相似行相。未分别与一切烦恼相似行相。今欲分别故作斯论。诸慢彼一切不寂静耶。答诸慢彼一切不寂静。以慢是自举自恃执竞法故。有不寂静非慢。谓余烦恼现在前。故世尊说苾刍当知。动为魔所缚不动脱恶者。此中余烦恼者。谓见疑无明贪嗔缠垢。现在前者显不寂静相。问何故现在烦恼有不寂静相非过去未来耶。答现在烦恼于自身中障碍圣道及圣道加行。过去未来烦恼不尔。复次现在烦恼于自身中能取果与果。过去未来烦恼不尔。复次现在烦恼于自身中能取等流果异熟果。过未烦恼不尔。复次现在烦恼能令自身成可诃责可厌贱可远离。过未烦恼不尔。复次现在烦恼烧然自身损坏自身逼恼自身。过未烦恼不尔。复次现在烦恼自害害他。或复俱害。过未烦恼不尔。复次现在烦恼是不寂静性。有不寂静用是故说之。过去未来烦恼是不寂静性。无不寂静用是以不说。动为魔所缚等者。此中初句显不寂静者为烦恼魔所缚。后句显寂静者解脱天魔。性弊恶者唯天魔故。有余师说。此中二句皆显示烦恼魔性。以诸烦恼害善法故说名为魔。起恶业故复名恶者。若诸有情不寂静时为烦恼所缚。若能寂静修习对治则于烦恼便得解脱。诸业彼不律仪耶。答应作四句。有业非不律仪。谓身语律仪。有不律仪非业谓根不律仪。有业亦不律仪谓身语不律仪。有非业亦非不律仪谓根律仪。诸业彼律仪耶。答应作四句。有业非律仪谓身语不律仪。有律仪非业谓根律仪。有业亦律仪谓身语律仪。有非业亦非律仪谓根不律仪。问此中根律仪根不律仪以何为自性。有作是说。根律仪以念正知为自性。根不律仪以忘念不正知为自性。云何知然。经为量故。如契经说。时有天神告苾刍曰。苾刍苾刍莫生疮疣。苾刍答曰我当覆之。天复问言疮疣既大以何能覆。苾刍答言我当以念正知覆之。天则赞言善哉善哉。能如是覆是为善覆。由此故知根律仪以念正知为自性。根不律仪以忘念不正知为自性。问若然者经云何通。如契经说念及正知满足故能满足根律仪。岂以自性满足自性耶。答念及正知有因性有果性。因性者以念正知名说。果性者以律仪名说。以因满故令果圆满是故无过。有说。根律仪以不放逸为自性。根不律仪以放逸为自性。有说。根律仪以六恒住法为自性。根不律仪以依六根生诸烦恼为自性。有说。根律仪以根永断遍知诸妙行善根为自性。根不律仪以根不永断不遍知诸烦恼恶行不善根为自性。如是则以妙行恶行为根律仪根不律仪体。有说。根律仪以不成就根不永断不遍知。及成就彼对治道为自性。根不律仪以成就根不永断不遍知。及不成就彼对治道为自性。如是根律仪根不律仪俱以成就不成就为体。有说。根律仪以不染污法为自性。根不律仪以染污法为自性。如是根律仪根不律仪俱以五蕴为其体性。昔迦湿弥罗国招吉祥僧伽蓝中有兄弟二阿罗汉。俱是法师世称为难地迦子。彼说根律仪根不律仪。俱以无覆无记不相应行蕴中根律仪。根不律仪为自性。此自性成立谓体是实有。此则摄在复有所余心不相应行中。问若根律仪根不律仪。俱以无覆无记行蕴为自性者。此有何差别。答此无覆无记行蕴有随顺善品者。有随顺烦恼品者。顺善品者名根律仪。顺烦恼品者名根不律仪

若事未得彼不成就耶乃至广说。于前所说五种十种事中。此中依自性事而作论。欲止说无成就不成就性者意。显成就不成就性是实有故。若事未得彼不成就耶。答若事未得彼不成就。谓不净观持息念念住三义观七处善。暖顶忍世第一法。见道修道无学道。如是等事若未得彼不成就。有事不成就非未得。谓得已失此谓则前不净观等。非未得而不成就。若事已得彼成就耶。答若事成就彼已得。谓则前不净观等得已不失。有事已得而不成就。谓得已失此谓则前不净观等已得而失

除苦圣谛及法处乃至广说。问何故作此论。答为止他宗显己义故。谓或有说。诸法摄他性不摄自性。集谛唯爱。道谛唯是八支圣道。或说法处摄一切法。或说法处唯是非色。或复说无去来二世。或说五识唯无记性。为遮此等种种僻执。及显法相相应义故而作斯论。除言有二意趣。一欲安立。二欲遮遣。此中除言为欲遮遣除苦圣谛及法处余法二界一处一蕴摄。此中苦圣谛谓一切有漏法则十五界。三界少分。十处二处少分。五蕴少分。法处谓七种法则想受行蕴无表色三无为。余法谓无漏心。是故此法二界谓意界意识界。一处谓意处。一蕴谓识蕴摄。除集圣谛及法处说亦尔。苦集义异体不异故。除灭圣谛及法处余法十七界十一处二蕴摄。此中灭圣谛谓择灭无为。则法界法处少分。法处谓七种法如前说。余法谓有对色及一切心是故此法十七界十一处二蕴摄。除道圣谛及法处说亦尔。此中以所摄量同故言亦尔。然道圣谛谓无漏有为法。则三界意界意识界法界。二处则意处法处。五蕴少分法处如前说。余法谓有对色及有漏心。是故此法十七界十一处二蕴摄

除有色法及法处。余法七界一处一蕴摄。此中有色法谓四大种及所造则十界。一界少分十处一处少分一蕴法处如前说。余法谓一切心是故此法七心界一处一蕴摄。除无色法及法处。余法十界十处一蕴摄。此中无色法。谓心心所法不相应行无为则七心界。一界少分一处一处少分。四蕴除色蕴法处如前说。余法谓一切有对色是故此法十界十处一蕴摄。除有见法及法处。余法十六界十处二蕴摄。此中有见法谓眼所行则一界一处及一蕴少分。法处如前说。余法谓无见有对色及一切心。是故此法十六界除色界法界。十处除色处法处。二蕴所摄色识。除无见法及法处。余法一界一处一蕴摄。此中无见法谓除眼所行。余一切法则十七界。十一处四蕴一蕴少分。法处如前说。余法谓眼所行是故此法一界一处一蕴摄。除有对法及法处。余法七界一处一蕴摄。此中有对法谓除无表。余一切色则十界十处及一蕴少分。法处如前说。余法谓一切心是故此法七心界一处一蕴摄。除无对法及法处。余法十界十处一蕴摄。此中无对法谓除有对色。余一切法则八界二处四蕴一蕴少分。法处如前说。余法谓一切有对色是故此法十界十处一蕴摄。除有漏法及法处。余法二界一处一蕴摄。此中有漏法谓苦集谛。则十五界。三界少分十处二处少分五蕴少分。法处如前说。余法谓无漏心。是故此法二界一处一蕴摄。除无漏法及法处。余法十七界十一处二蕴摄。此中无漏法谓灭道谛及二无为。则三界二处五蕴少分。法处如前说。余法谓有对色及有漏心。是故此法十七界十一处二蕴摄。除有为法及法处。此除一切法而问余法是无事空论。此中有为法谓苦集道谛则十七界。一界少分十一处一处少分五蕴。法处如前说。除此更无余法可摄。是故此名无事空论。除无为法及法处。余法十七界十一处二蕴摄。此中无为法谓虚空择灭非择灭则一界一处少分。法处如前说。余法谓有对色及一切心。是故此法十七界十一处二蕴摄。除过去法及法处。余法十七界十一处二蕴摄。此中过去法谓已生已灭诸法则十八界十二处五蕴少分。法处如前说。余法谓未来现在有对色及心。是故此法十七界十一处二蕴摄。除未来法现在法及法处说亦尔。时别类不别故除善法及法处。余法十七界十一处二蕴摄。此中善法谓能得爱果自性安隐法。则十界四处五蕴少分。法处如前说。余法谓不善无记有对色及心。是故此法。十七界十一处二蕴摄。除不善法及法处说亦尔。类别摄不别故。除无记法及法处。余法九界三处二蕴摄。此中无记。法谓不得爱不爱果。及非自性安隐法。即八界十界少分八处四处少分五。蕴少分。法处如前说。余法谓善不善有对色及心。是故此法九界三处二蕴摄。除欲界系法及法处。余法十三界九处一蕴摄。此中欲界系法。谓欲爱所随增即四界十四界少分二处十处少分五蕴少分。法处如前说。余法谓色界系有对色及色无色界系不系心。是故此法十三界九处二蕴摄。除色界系法及法处。余法十七界十一处二蕴摄。此中色界系法谓色爱所随增。则十四界十处五蕴少分。法处如前说。余法谓欲界系有对色及欲无色界系不系心。是故此法十七界十一处二蕴摄。无色界系法学法无学法及法处说亦尔。此以所摄数量同故。除非学非无学法及法处。余法二界一处一蕴摄。此中非学非无学法谓一切有漏及无为法。则十五界三界少分十处二处少分五蕴少分。法处如前说。余法谓无漏心。是故此法二界一处一蕴摄。除见所断法及法处。余法十七界十一处二蕴摄。此中见所断法谓忍所对治。即三界二处四蕴少分。法处如前说。余法谓一切有对色。及修所断不断心。是故此法十七界十一处二蕴摄。除修所断法及法处。余法二界一处一蕴摄。此中修所断法谓智所对治。则十五界三界少分十处二处少分五蕴少分。法处如前说。余法谓见所断不断心。是故此法二界一处一蕴摄。除不断法及法处。余法十七界十一处二蕴摄。此中不断法谓一切无漏法。即三界二处五蕴少分。法处如前说。余法谓一切有对色及有漏心。是故此法十七界十一处二蕴摄

除已生法及定不生法。余法十八界十二处五蕴摄。此中已生法谓过去现在即十八界十二处五蕴少分。定不生法谓过去现在法。及未来必不生法。并无为已生故得不生故无生故。决定不生此亦十八界十二处五蕴少分。余法谓正生及可生法。是故此法亦十八界十二处五蕴摄。除非已生法及定不生法。此除一切法。问余法是无事空论。此中非已生法谓未来法及无为。即十八界十二处五蕴少分。定不生法如前说。除此更无余法可摄。是故说为无事空论。除有色法及定不生法。余法八界二处四蕴摄。此中有色法及定不生法如前说。余法谓正生可生诸心心所心不相应行。是故此法八界二处四蕴摄。除无色法及定不生法。余法十一界十一处一蕴摄。此中无色法及定不生法如前说。余法谓正生可生诸有色法。是故此法十一界十一处一蕴摄。除有见法及定不生法。余法十七界十一处五蕴摄。此中有见法及定不生法如前说。余法谓正生可生诸无见法。是故此法十七界十一处五蕴摄。除无见法及定不生法。余法一界一处一蕴摄。此中无见法及定不生法如前说。余法谓正生可生诸有见色。是故此法一界一处一蕴摄。除有对法及定不生法。余法八界二处五蕴摄。此中有对法及定不生法如前说。余法谓正生可生诸无对法。是故此法八界二处五蕴摄。除无对法及定不生法。余法十界十处一蕴摄。此中无对法及定不生法如前说。余法谓正生可生诸有对色。是故此法十界十处一蕴摄。除有漏法及定不生法。余法三界二处五蕴摄。此中有漏法及定不生法如前说。余法谓正生可生诸无漏法。是故此法三界二处五蕴摄。除无漏法及定不生法。余法十八界十二处五蕴摄。此中无漏法及定不生法如前说。余法谓正生可生诸有漏法。是故此法十八界十二处五蕴摄。除有为法及定不生法此除一切法。问余法是无事空论。此中有为法及定不生法如前说。除此更无余法可摄。是故说为无事空论。除无为法及定不生法。余法十八界十二处五蕴摄。此中无为法及定不生法如前说。余法谓正生可生诸有为法。是故此法十八界十二处五蕴摄。除过去法现在法及定不生法说亦尔。此中余法俱谓正生可生诸有为法。是故此法。皆十八界十二处五蕴摄。除未来法及定不生法此除一切法问余法是无事空论。此中未来法及定不生法具摄一切有为无为法。除此更无余法可摄是故说为无事空论。除善法及定不生法。余法十八界十二处五蕴摄。此中善法及定不生法如前说。余法谓正生可生诸不善无记法。是故此法十八界十二处五蕴摄。除不善法及定不生法说亦尔。以于余法所摄同故。除无记法及定不生法。余法十界四处五蕴摄。此中无记法及定不生法如前说。余法谓正生可生善不善法。是故此法十界四处五蕴摄。除欲界系法及定不生法。余法十四界十处五蕴摄。此中欲界系法及定不生法如前说。余法谓正生可生色无色界系及不系法。是故此法十四界十处五蕴摄。除色界系法及定不生法。余法十八界十二处五蕴摄。此中色界系法及定不生法如前说。余法谓正生可生欲无色界系不系法。是故此法十八界十二处五蕴摄。除无色界系法学法无学法。及定不生法说亦尔。以于余法摄数同故。除非学非无学法及定不生法。余法三界二处五蕴摄。此中非学非无学法。及定不生法如前说。余法谓正生可生学无学法。是故此法三界二处五蕴摄。除见所断法及定不生法。余法十八界十二处五蕴摄。此中见所断法及定不生法如前说。余法谓正生可生修所断不断法。是故此法十八界十二处五蕴摄。除修所断法及定不生法。余法三界二处五蕴摄。此中修所断法及定不生法如前说。余法谓正生可生见所断不断法。是故此法三界二处五蕴摄。除不断法及定不生法。余法十八界十二处五蕴摄。此中不断法及定不生法如前说。余法谓正生可生见修所断法。是故此法十八界十二处五蕴摄

颇有一界一处一蕴摄一切法耶。答有。一界谓法界。一处谓意处。一蕴谓色蕴。如是则摄一切法尽。所以者何。一切法不出五事。谓色心心所法不相应行无为色蕴摄色。意处摄心。法处摄余。是故摄一切法。复次一切法不出十八界。于中色蕴摄十色界。意处摄七心界。法界摄法界故摄一切法。复次一切法皆入蕴界处中。此三展转相摄。谓色蕴摄十色界十色处法界法处少分。意处摄七心界。识蕴法界摄法处受想行蕴色蕴少分。是故此三摄一切法

说一切有部发智大毗婆沙论卷第一百九十七阿毗达磨大毗婆沙论卷第一百九十八

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    见蕴第八中见纳息第五之一

诸有此见无施与乃至广说。问何故作此论。答欲释契经中所说见趣令知断故。所以者何。于生死中起大执着引大无义。为大依取者莫如见趣。此等广说如智蕴五事纳息。诸有此见无施与无爱乐无祠祀无妙行恶行。此谤因邪见见集所断。无施与等如上释。此邪见者显彼自性。见集所断者显彼对治。谓于集谛忍智已生于彼所有不正推寻不正分别。颠倒见不平等取便永断灭没。复次此见依集处转故见集时则断。如草头露日出则干。此亦如是无妙行恶行果此谤果邪见见苦所断。此邪见者显彼自性。见苦所断者显彼对治。谓于苦谛忍智已生。于彼所有不正推寻不正分别颠倒见不平等取便永断灭没。复次此见依苦处转故见苦时即断。如草头露日出则干。此亦如是。然此但说彼见自性及对治。不说等起。彼等起云何。尊者世友说曰。有诸外道现见世间有杀生长寿离杀短寿。有盗丰财离盗乏财。有悭而富乐施而贫。有损恼他无病安乐。有不恼他而多疾苦。见如是等相违事已便作是念。无施与无爱乐乃至无妙行恶行果。若有者则应杀生一切短寿。乃至不恼他者无病安乐。现见相违故知决定无施与乃至广说。然彼外道不善了知妙行恶行果有远近故。于现见事中不如理寻思而起此见。有说。外道得世俗定见少时分不知终始因果差别。见行恶者有得生天。见造善者有堕恶趣。便作是念无施与无爱乐乃至广说。或有说者。有诸外道不因现见亦不因定。但由随顺恶友教故说无施与乃至广说

无此世无他世无化生有情。此谤因邪见或见集所断。或谤果邪见见苦所断。问他世是不现见说无可尔。此世现见何故言无。答彼诸外道无明所盲于现见事亦复非拨不应责。无明者愚盲者堕坑。复有说者。彼诸外道但谤因果不谤法体。无此世者谓无此世为他世因。或无此世为他世果。无他世者谓无他世为此世因。或无他世为此世果。无化生有情者有诸外道作如是说。诸有情生皆因现在精血等事。无有无缘忽然生者。譬如芽生必因种子水土时节无有无缘而得生者。故定无有化生有情。此或拨无感化生业。或复拨无所感化生。或有说者。化生有情所谓中有。无此世他世者谤无生有。无化生有情者谤无中有。有诸外道言中有无。彼说但应从此世间至彼世间更无第三世间可得。此或拨无感中有业。或复拨无所感中有。或拨中有为生有因。或拨中有为死有果。此邪见者显彼自性。或见集所断或见苦所断者显彼对治广说如前。无父无母此谤因邪见见集所断。问世间父母皆所现见彼以何故谤言无耶。答彼诸外道无明所盲乃至广说。有说。彼诸外道谤无父母感子之业不谤其体。彼作是论父母自以爱染心故不为子故。然以精血和合缘故彼类自生非谓父母有感子业。如因湿叶粪土等故有诸虫生。非湿叶等有感虫业此亦如是。故彼外道有如是颂

  男女染心合　　女值时无病
  我从此自有　　彼于我何为

或有说者。彼诸外道谤父母义不谤其体。如因湿叶粪等生虫。叶等于虫非父非母。如是因彼不净而生。彼复何缘独于生者有重恩德名父母耶。是故彼类说无父母。此邪见者显彼自性见集所断者显彼对治广说如前。此中但说彼自性对治不说等起。彼等起云何。尊者世友说曰。有诸外道天暴雨时见诸浮泡便作是念。此从何来灭至何所。但因水雨忽起忽灭。如是有情缘合故生。缘离故死。不从前世来至此生。亦非此生往至后世便决定说无此世无他世。又见世间父母生子水土生芽所见皆从缘合而有。便作是念何处当有化生有情。又见虫生因湿叶等广如前说。然彼外道不知情与非情生类有别四生有情。藉缘不等内法外法缘性各异。故于少分相似事中不正寻思起此诸见。复有说者。彼诸外道得世俗定有诸有情从上地及余世界殁来生此间。或此间殁生于上地及余世界。彼观此类不见所从及所往处。便起此见无此世无他世。又彼获得粗浅定故观去来世时但见生有。不见中间中有之身以微细故。由此便说无化生有情。又因定力观诸有情或从怨家来作父母。或从妻子兄弟姊妹来作父母。乃至或从驼驴狗等杂类之身来作父母。复从父母作彼形类便作是念。此如客舍有何决定。由此便说无父无母。复有说者。彼诸外道不因现见亦不因定。但由随顺恶友教故说无此世乃至广说

诸有此见世间无阿罗汉。此谤道邪见见道所断。此谤道邪见者显彼自性。见道所断者显彼对治。谓于道谛忍智已生。于彼所有不正推寻不正分别颠倒见不平等取便永断灭没。复次此见于道处转故见道时即断。如草头露日出则干。此亦如是无正至。此谤灭邪见见灭所断。正至谓涅槃是无漏道所应至故。此谤灭邪见者显彼自性。见灭所断者显彼对治。谓于灭谛忍智已生。于彼所有不正推寻不正分别颠倒见不平等取便永断灭没。复次此见于灭处转故见灭时即断。如草头露日出则干。此亦如是无正行此世他世则于现法知自通达作证具足住。我生已尽梵行已立所作已办不受后有。如实知此谤道邪见见道所断。无正行此世他世者谓彼拨无四种正行。则苦迟通等此是谤有学道。余是谤无学道。此谤道邪见者显彼自性。见道所断者显彼对治广说如前。此中但说彼见自性及对治。不说等起。彼等起云何。尊者世友说曰。有诸外道见阿罗汉有老病死及受诸苦。同余有情便说世间无阿罗汉。即是谤无阿罗汉法。又闻涅槃诸根永灭便作是念彼应是苦。复闻涅槃诸行寂灭便作是念彼应是无。又见圣者形貌饮食同余有情便谓彼无一切圣道。然彼外道不知圣者有漏身异无漏身异涅槃寂乐。非苦非无故起如是差别邪见。有说。外道得世俗定不能观见圣道涅槃。便作是言无阿罗汉乃至广说。有说。外道不因现见亦不因定。但由随顺恶友教故。便言世间无阿罗汉乃至广说。有说。此中应说始骞持事。彼事即是此见等起诸有此见。乃至活有命者死已断坏。无有此四大种士夫身广说乃至。此边执见断见摄。见苦所断此中乃至活有命者死已断坏无有者。彼执有我名为命者。此命者乃至此生未死恒有。死已更不相续名断坏。无有此四大种土夫身者。彼所说士夫身亦余法成而唯说四大种者以粗现故。死时地身归地水身归水火身归火风身归风根随空转者。彼说众生死时内大种身归外地等。根无大种为所依故便随空转。譬如树倒鸟则飞空。此边执见常见摄见苦所断。以执我所是常住故。舆为第五者。谓四肘半舆四人舁之以送死尸。故言舆为第五持彼死尸往弃冢间。即施身处或烧尸处。名为冢间。未烧可知者。谓乃至未烧差别可见烧已成灰。余鸽色骨者谓若烧已便成灰烬。此中烧言若谓烧薪等者此则正见。若谓即烧火者此则邪智非见。若谓烧有漏业者此谤因邪见见集所断。若谓烧无漏业者此谤道邪见见道所断。愚者赞施智者赞受。愚谓无智或恶慧者。智谓有智及善慧者。彼外道言诸愚痴者赞叹行施。诸智慧者赞叹受施。然佛独觉及圣弟子诸智慧者皆赞行施。彼拨为愚此即谤无成智者法。此谤道邪见见道所断。诸有论者一切空虚妄语乃至活有愚智者死已断坏无有者。说有后世名有论者彼皆谤之为空妄语云乃至活有愚智者死已一切断坏无有。然佛独觉及圣弟子说有后世。彼拨为妄此即谤无实语者法。此谤道邪见见道所断。此边执见断见摄者显彼自性。此中虽有余邪见等。而但显示断坏无有故。断见摄。见苦所断者显彼对治广说如前。此但说彼自性对治不说等起。彼等起云何。尊者世友说曰。有诸外道不忆前际不见后际。计诸有情皆以此生得胎为初死为最后。又诸命终无有还者故说乃至活有命者。死已断坏无有犹如草木无有后世。有说。外道得世俗定。或有众生从此间殁生于上地及余世界。彼观此类不知所往便作是说。乃至活有命者。乃至广说。有说。外道不因余事但由恶友邪教授故便作是言。乃至活有命者乃至广说。诸有此见无因无缘令有情杂染。非因非缘而有情杂染。此谤因邪见见集所断。此谤因邪见者显彼自性。见集所断者显彼对治广说如前。彼等起云何。尊者世友说曰。有诸外道现见世间。有居阿练若处而生杂染。有住城邑而不起染。便作是念无因无缘令有情杂染。非因非缘而有情杂染。若有者则应住阿练若处者不生杂染。住城邑者皆生杂染现见相违。是故决定无因无缘乃至广说。然由三事故有情杂染。一由因力。二由加行力。三由境界力。彼住阿练若处者虽无境界而由因力加行力故生诸杂染。住城邑者虽有因及境界。由无加行力故不生杂染。彼于此事不能通达便起此见无因无缘乃至广说。有说。外道因得世俗粗浅定故。观见有情起诸杂染。而不见其因缘差别。便起是见无因无缘乃至广说。有说。外道不因现见亦不因定。但因恶友而起此见无因无缘令有情清净。非因非缘而有情清净。此谤道邪见见道所断。此谤道邪见者显彼自性。见道所断者显彼对治广说如前。彼等起云何。尊者世友说曰。有诸外道现见世间有住城邑而得清净。有居阿练若处而不清净。便作是念无因无缘令有情清净。非因非缘而有情清净。若有者则应住阿练若斯皆清净。住城邑者皆不清净。现见相违。是故决定无因无缘乃至广说。然由三事故有情清净。一由因力。二由加行力。三由缘力。彼住阿练若处者虽有因缘或由阙加行故不得清净。住城邑者虽或阙缘而由因及加行力故而得清净。彼于此事不能通达便起此见。无因无缘乃至广说。有说。外道因得世俗粗浅定故。观见有情证得清净而不见彼得净因缘。便起是见无因无缘乃至广说。有说。外道不因现见亦不因定但因恶友而起此见

无因无缘令有情无智无见。非因非缘而有情无智无见。此谤因邪见见集所断。此谤因邪见者显彼自性。见集所断者显彼对治广说如前。彼等起云何。尊者世友说曰。有诸外道现见世间。不为求无智无见故起诸加行。而彼有情自然无智无见便作是念无因无缘乃至广说。若有者则应作加行求无智见者。起无智见不求者不起。现见相违故知决定无因无缘乃至广说。然由三事故有情无智无见。一由乐着阿赖耶故。二于所作多疑惑故。三于有情不谦敬故。有说。由五事故。三如前说。四由不勤求故。五由无方便故。彼于此事不善了知便起此见无因无缘乃至广说。有说。外道得世俗粗浅定观见有情无智无见。而不见其因缘差别便起此见无因无缘乃至广说。有说。外道不因现见亦不因定。但因恶友而起此见无因无缘令有情智见。非因非缘而有情智见。此谤道邪见见道所断。此谤道邪见者显彼自性。见道所断者显彼对治广说如前。彼等起云何。尊者世友说曰。有诸外道现见世间。有求智见起大加行而不生智见。有不起加行而生智见。便作是念无因无缘乃至广说。若有者则应为求智见起加行者生于智见不起加行者不生智见。现见相违故知决定无因无缘乃至广说。然由四事故有情智见。一善取其名。二善取其义。三乐多推寻。四乐简择是理非理彼于此事不善了知便言无因无缘乃至广说。有说。外道得世俗粗浅定观见有情得胜智见。而不见其因缘差别便起此见。无因无缘乃至广说。有说。外道不因现见亦不因定。但因恶友而起此见

诸有此见无力无精进。无力精进无士无威势无士威势。无自作无他作无自他作。一切有情一切生一切种。无力无自在无精进无威势定合性变。于六胜生受诸苦乐。此若谤有漏力精进等。即谤因邪见见集所断。若谤无漏力精进等即谤道邪见见道所断。此中力精进士威势体一义异。皆谓诸法功能差别。力者势力是难屈伏义。精进者是发趣义。士者士用是雄猛义。威势者是能伏他义。彼说诸法无如是义。即是总谤诸法功能。无自作者谤自相续诸法功能。无他作者谤他相续诸法功能。无自他作者谓俱谤。此是无衣迦叶波计如后当说。一切有情者谓有识类。一切生者谓即有情名曰众生。一切种者谓即众生为种相续。力自在等亦体一义异。即诸有情功能差别。自在者是能役他义。力等如前释。彼说有情无有如是功德差别。定谓决定是法尔义合谓和合是缘会义。性谓本性。变谓转变。彼说有情有如是理趣法尔缘会则本性转变。于六胜生受诸苦乐。非由彼有力自在等能受苦乐六胜生后当说。此则谤因或谤道邪见者。显彼自性。见集或见道所断者显彼对治。广说如前。彼等起云何。尊者世友说曰有诸外道现见世间。为求富贵广施功力而不能得。有不希求自然而得。便作是念无力无精进乃至广说。若有者应求乃得不求不得。现见相违故知无也。然世福乐必由先时定不定业有施功力而不获者以无先时业故。有不施功而便得者以有先时决定因故。彼于此事不善了知便谓无力无精进乃至广说。由定及由恶友应准前说。前杂蕴中说颠倒处。唯明拨有漏因故见集所断。此中通明谤有漏无漏因故。见集见道所断。诸有此见造教造煮教煮害教。害杀诸众生。不与取。欲邪行。知而妄语。故饮诸酒。穿墙解结尽取所有守阨断道。害村害城害国生命以刀以轮拥略大地。所有众生断截分解聚集团积为一肉聚应知由此无恶无恶缘。于殑伽南断截挝打。于殑伽北惠施修福应知由此无罪福。亦无罪福缘。布施爱语利行同事摄诸有情皆无有福。此谤因邪见见集所断此中无恶者无恶自性。无恶缘者不能感恶果。无罪福亦无罪福缘应知亦尔。于殑伽南断截挝打者以殑伽南多有药叉祠。于中杀害众生故。于殑伽北惠施修福者。以殑伽北多有天祠于中惠施修福故。此谤因邪见者显彼自性。见集所断者显彼对治广说如前。彼等起云何。尊者世友说曰。有诸外道现见世间。有造恶者受诸快乐。有修善者多遭忧苦。便作是念造教造广说乃至皆无有福。若有者应造恶受苦。修善得乐。现见相违故知决定造教造乃至皆无有福。然善恶业果有远近彼不善知便起此见。由定及由恶友应准前说

诸有此见此七士身不作作不化化。不可害常安住如伊师迦安住不动无有转变互不相触。何等为七。谓地水火风及苦乐命。此七士身非作乃至如伊师迦安住不动。若罪若福若罪福若苦若乐若苦乐不能转变。亦不能令互相触碍。设有士夫断士夫头亦不名为害世间生。若行若住七身中间刀刃虽转而不害命。此中无能害无所害。无能捶无所捶。无表无表处。此边执见常见摄见苦所断。七士身者谓我所执持。七士夫身不作者。谓无作者。能作。此身作者谓虽不作而似作显现。不化者谓无化者能化此身。化者谓虽不化而似化显现。如伊师迦者谓如伊师伽木。或如伊师迦山坚固难坏。无有转变者谓我常住虽有隐显而无转变。互不相触者无有能令互相触碍。若行若住者行谓人等。住谓树等彼说树等亦名士夫。计彼类中有寿命故。七身中间虽有孔隙容刀刃转。而不害命以常住我所任持命不可害故。无表者无能害能捶业故。无表处者无所害所捶境故。此边执见常见摄者显彼自性。见苦所断者显彼对治广说如前。彼等起云何。尊者世友说曰。有诸外道于四大种及苦乐命相续。依因依缘和合故有刹那不住中不善了知。便计有我于中执持令无损害。彼所说命谓识相续。然彼不见身心相续。刹那刹那因果转中所有间隙。便执有我持令常住。舍此身已受彼身时。如树倒时鸟集余树故说此七士身乃至广说。由定及由恶友应准前说

诸有此见有十四亿六万六百生门。五业三业二业业半业六十二行迹。六十二中劫。百三十六地狱。百二十根。三十六尘界。四万九千龙家。四万九千妙翅鸟家。四万九千异学家。四万九千活命家。七有想藏。七无想藏。七离系藏。七阿素洛。七毕舍遮。七天七人七梦七百梦七觉七百觉七池七百池七险七百险七减七百减七增七百增六胜生类八大士地。于如是处经八万四千大劫。若愚若智往来流转乃决定能作苦边际。如掷缕丸缕尽便住此中无有沙门若婆罗门。能作是说我以尸罗或以精进或以梵行令所有业未熟者熟。熟者触已即便变吐。以如是斛度量生死苦乐边际不可施设。有增有减亦不可说。或然不然此非因计因戒禁取见苦所断。十四亿六万六百生门者。如正法中有四生门。谓胎卵湿化是诸有情共所经受。其量决定不过不减。如是外道无胜发褐计有尔所杂类生门。一一有情遍所经历数量决定亦不增减。五业乃至业半业者如正法中感四生门。及于生门所造不出五业等业。如是外道所说感尔所生门。及于尔所生门所造亦不过于五业等业。五业者如正法中。说感五趣五趣加行五趣处所。如是外道所说五业。谓举下屈申行为第五。或语手足大小门五。三业者如正法中身语意业。彼说亦尔但语为初。二业者如正法中思思已业。彼说所谓黑业白业。业半业者如正法中牵引业名业。圆满业名半业。或具二种名业。随但有一名半业。如是外道说有二业。一者双业二者只业。牵引业名双业。圆满业名只业。或具二种名双业。随但有一名只业。诸双名业只名半业。又彼外道说有二业。谓堕业近堕业。若害婆罗门若行父母师友女人。盗金饮酒名为堕业。其余恶业名近堕业。初名为业后名半业。又说语身业名业损益自他故。意业名半业唯自损益故。又说感生有业名业。感中有业名半业。又说于未生感众同分业名业。于生已受异熟业名半业。又说于业具足造名业。少分造名半业。六十二行迹者。如正法中说四行迹名清净道。如是外道说六十二行迹名清净道。六十二中劫者。如正法中说八十中劫为一分齐。如是外道说六十二中劫为一分齐。于此时中修六十二行迹作苦边际。百三十六地狱者。如正法中说八大地狱一一各有十六眷属。如是外道所说亦尔。然说有情遍生其中然后解脱。百二十根者如正法中说有二十二根。如是外道说有百二十根。谓眼耳鼻各二为六。舌身意命及五受根信等五根总为二十六。趣各二十为百二十六。趣者谓阿素洛为第六。彼说有情要于六趣受尔所根不过不减。有说。根者是增上义有情要于百二十处为主已然后解脱。三十六尘界者如正法中说有九十八随眠为一切杂染依处。如是外道说有三十六尘界为杂染依处。四万九千龙家者。家谓族类如正法中龙有四族即胎卵湿化。如是外道说有四万九千龙家。一一有情于彼族类无不经受。四万九千妙翅鸟家者。如正法中妙翅鸟有四族谓胎卵湿化。如是外道说有四万九千妙翅鸟家。一一有情于彼族类无不经受。四万九千异学家者。谓出家外道有尔所类。彼说一一有情于彼族类应遍出家。四万九千活命家者。谓习工巧处以自活命有尔所类。彼说有情于彼处所皆应遍学。七有想藏者彼说有七有想定。七无想藏者彼说有七无想定。如是诸定一一有情皆应遍起。七离系藏者即前所说诸定加行。彼说有情于彼加行应离诸系摄心修习。七阿素洛七毕舍遮者。彼说有情于阿素洛毕舍遮处七返往还方得解脱。七天七人者彼说有情于天人处七返往还方得解脱。七梦七百梦者彼说有情生处差别大梦有七。小梦七百。所更所见各各不同。一一有情皆具经历。七觉七百觉者。彼说有情生处差别随尔所大小梦。还有尔所大小觉。所更所见亦各不同。一一有情皆具经历。七池七百池者。彼说世间灭罪泉池大者有七。小有七百。一一有情皆遍洗浴方得解脱。七险七百险者。险谓坑谷山岩河岸。彼说如此灭罪险处。大者有七。小有七百。一一有情遍于其中经舍身命乃得解脱。七减七百减者。减谓退失功德。彼说有情退功德处。大者有七。小有七百。一一有情皆应于中退失功德。七增七百增者增谓增进功德。彼说有情进功德处。大者有七。小有七百。一一有情遍于其处随退还进方得解脱。六胜生类者谓满迦叶波外道施设六胜生类。谓黑青黄赤白极白。生类差别黑胜生类谓杂秽业者即屠脍等。青胜生类谓余在家活命。黄胜生类谓余出家活命。赤胜生类谓沙门释子。白胜生类谓诸离系。极白胜生类谓难陀伐蹉末塞羯利瞿赊利子等。彼说有情于此六种皆应具受然后解脱。佛亦施设六胜生类。一者有黑胜生类补特伽罗生长黑法。二者有黑胜生类补特伽罗生长白法。三者有黑胜生类补特伽罗生长不黑不白得涅槃法。四者有白胜生类补特伽罗生长白法。五者有白胜生类补特伽罗生长黑法。六者有白胜生类补特伽罗生长不黑不白得涅槃法。八大士地者。如正法中有四静虑四无色具功德处。如是外道说有八梵胜处名八大士地。有情于中皆应遍得于如是处经八万四千大劫。若愚若智往来流转。乃决定能作苦边际者。彼说黑胜生类经十四千大劫往来流转。然后得入青胜生类。即青胜生类经十四千大劫往来流转。然后得入黄胜生类。即黄胜生类复经十四千大劫往来流转。然后得入赤胜生类。即赤胜生类复经十四千大劫往来流转。然后得入白胜生类。即白胜生类复经十四千大劫往来流转。然后得入极白胜生类。即极白胜生类复经十四千大劫往来流转。然后乃能作苦边际。如掷缕丸缕尽便止者。如在山上掷大缕丸乃至缕尽然后方止。如是有情经八万四千大劫上诸生处往来流转然后乃能作苦边际。以如是斛度量生死苦乐边际不可施设有增有减亦不可说。或然不然者如以斛函量稻麦等。知数量已不可增减亦不生疑。如是彼说有情经八万四千大劫于上所说诸处往来流转。然后解脱不过不减亦不应疑。有说。倍此所说数量于中流转方得解脱。以彼说有往来言故此非因计因。戒禁取者显彼自性。见苦所断者显彼对治广说如前。彼等起云何。谓有外道或因不正寻思。或因得世俗定。或因亲近恶友而起此见如前应知

诸有此见一切士夫补特伽罗诸有所受。无不皆以宿作为因。此非因计因戒禁取。见苦所断诸有所受谓一切现在所受苦乐。无不皆以宿作为因者。谓此皆以过去业为因。问此正法中亦说所受苦乐过去业为因而非恶见。彼外道亦作是说。何故名恶见耶。答此正法中说现所受有以过去业为因。有是现在士用果者。彼说一切皆以过去所作业为因。不说现在有士用果故名恶见。问彼既谤无现在因果。应名邪见何故名戒禁取耶。答今不说彼谤现因果名戒禁取。但说彼计余因所生法以余法为因故是戒禁取摄。此非因计因戒禁取者显彼自性。见苦所断者显彼对治广说如前。彼等起云何。谓彼外道现见世间有设功用而不获果。有不希求自然而得。便作是念当知皆是宿作为因非现功力。然彼不知善恶业类定与不定。及时分差别故起此执。有说。外道得世俗定念知过去所起诸业。便谓一切皆由宿作。有说。外道但因恶友广说如前

说一切有部发智大毗婆沙论卷第一百九十八阿毗达磨大毗婆沙论卷第一百九十九

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    见蕴第八中见纳息第五之二

诸有此见一切士夫补特伽罗。诸有所受皆以自在变化为因。此非因计因戒禁取见苦所断。此非因计因戒禁取者显彼自性。见苦所断者显彼对治广说如前。彼等起云何。谓有外道或因不正寻思。或因得定或因恶友而起此见如前应知。然诸法生非因自在渐次生故。谓诸世间若因自在变化生者则应一切俱时而生。彼因皆有无能障碍令不生故。若谓自在更待余因方能生者便非自在如余因故。若谓诸法皆从自在欲乐而生故不顿起。自在欲乐何不顿生彼生欲乐自在恒有无能障故。若谓自在更待余因方生欲乐便非自在。又应无穷彼因复待余因生故。又若自在生诸法者因无别故法应无别。若谓自在生初一法后从彼法转复生多。彼法云何能生多法亦如自在体是一故。又所生法亦应是常果似因故。又自在体应不能生彼体是常如虚空故

诸有此见一切士夫补特伽罗所受皆是无因无缘。此谤因邪见见集所断。此谤因邪见者显彼自性。见集所断者显彼对治广说如前。彼等起云何。谓有外道见诸世间因果形相非定相似。诸有营求或不果遂便拨所受无因无缘。然诸所受非无因缘。现见诸法因缘生故非一切法一时生故。若无因缘应皆顿起应一切法无差别故。若无因缘。由何差别故诸所受非无因缘

诸有此见自作苦乐他作苦乐自他作苦乐。此非因计因戒禁取见苦所断。诸有此见所受苦乐非自作非他作无因而生。此谤因邪见见集所断。此非因计因戒禁取。及谤因邪见者显彼自性。见苦及见集所断者显彼对治广说如前。彼等起云何。谓无衣迦叶波因缘是此见等起。彼无衣迦叶波昔在家时曾为商主。数入海采宝最初入时逢诸海难辛苦得出便作是念。此难苦者是我自作坐入海时不洗浴故。彼于第二入时便自洗浴。既入海已遇难如前辛苦得还复作是念。此难苦者是他所作坐入海时不祠天故。彼于第三入时便自洗浴。及亦祠天既至海中如前遇难。困而得免。便作是念如是艰苦自作他作。坐入海时洗浴祠天不殷重故。彼于最后便极殷重洗浴祠天然后入海。入已遇难亦复如前仅得回还便作是念。此所遭苦不由自他。但无因得。彼由此故便见居家摄受过失。即往无衣外道法中出家。后于王舍城见佛便问苦由谁作。尔时世尊以四记论法而调伏之。广说如无衣迦叶波经。故彼因缘是此见等起。前来所说诸戒禁取皆见苦所断者。依我常倒起于果处转故。虽非因计因而见苦所断。谓戒禁取总有二类。一非因计因。二非道计道。非因计因复有二类。一迷所执我常法起。二迷宿作苦行等起。前依我常倒亦于果处转故。随二倒见苦所断后唯于果处转。果相粗显易可见故。计因为因非全邪故。既迷果相故亦见苦所断。非道计道亦有二类。一执有漏戒等为道。此迷粗显果相起故见苦谛时便能永断。二执谤道谤邪见等为道。此亲违道于因果相不别迷执故见道时方能永断。谤集灭时既拨所断所证法相。若执为道便为无用。定依所断及所证法而立道故。又彼所拨与道相异必无彼无间执彼为道者。若于后时执彼为道定于果处而起道执。见苦谛时此见便断故。无戒禁取见集灭所断。见取所执无所待对但执为胜诸邪见后皆得现前故通四部。此中所说诸戒禁取唯非因计因故见苦所断

诸有此见我及世间常恒坚住无变易法正尔安住。此边执见常见摄见苦所断。此边执见常见摄者显彼自性。见苦所断者显彼对治。广说如前。彼等起云何。谓有外道或因不正寻思。或因得定或因恶友而起此见。如前应知。然彼所执我及世间皆非常住。实我我所不可得故。现见一切有情世间器世间物有转变故。因缘生故。诸有生者。一切皆当有灭坏故。不应执我及世间常恒坚等。言皆显常义诸有此见谛故。住故我有我。此边执见常见摄。见苦所断谛故者。谓实义故。住故者。谓法尔故。我有我者谓我恒有。此边执见常见摄者显彼自性。见苦所断者显彼对治。广说如前。彼等起云何。谓有外道或因不正寻思。乃至广说。诸有此见谛故住故我无我。此边执见断见摄见苦所断谛故住故如前释。我无我者。谓我当无。问此正法中亦说无我而非恶见。彼外道亦说无我何故名恶见耶。答此正法中于无我空行聚。见空无我说言无我故非恶见。彼外道于无我空行聚中妄谓有我。但说彼我当来不有故是恶见。此边执见断见摄者显彼自性。见苦所断者显彼对治。广说如前。彼等起云何。谓有外道或因不正寻思。乃至广说。诸有此见我观我眼色即我。此有身见见苦断。我观我者谓有外道执我遍内外法故。眼见色时谓我观我眼根及色俱即我故。诸有此见我观无我眼即我色为众具。此有身见见苦断。我观无我者谓有外道以眼是不共。又是内法故执之为我。色与此相违但是我众具故眼见色时。谓我观于无我诸有此见无我观我色即我眼为众具。此有身见见苦所断。无我观我者。谓有外道现见世间大地诸山经久不异。谓与我理相应便执为我。眼与此相违但是众具故眼见色时谓无我观我。问何故不说无我观无我。答以一切法实无有我。若说无我观无我者便是正见故此不说。问若有外道执耳声等是我非余故。眼见色时说无我观无我此岂正见耶。答彼执耳声等是我虽是恶见若说无我观无我即是正见是故不说。此中诸有身见者显彼自性。诸见苦所断者显彼对治。广说如前。等起差别亦如前应知。诸有此见此是我是有情命者生者养育者。补特伽罗意生儒童作者教者生者等生者起者等起者语者觉者等领受者。非不曾有。非不当有。于彼彼处造善恶业。于彼彼处受果异熟。舍此蕴续余蕴。此边执见常见摄见苦所断。此边执见常见摄者显彼自性。见苦所断者显彼对治。广说如前。等起差别亦如前应知。问初所说常论与此所说有何差别。有说。初者依定此依寻思。有说。初者是师后是弟子。有说。初是轨范后是近住。有说。初是尊重后是学者。有说。初是证者亦是说者。后是证者而非说者。有说。初执我从前际至今际恒有后执我从今际至后际恒有。是谓初后常论差别。问云何建立如是六见。为以自性为以所依所缘。设尔何过。若以自性者但应有二。谓有身见边执见。若以所依所缘者应有十八。谓依眼色有三乃至依意法亦三。或成三十六。谓依眼色有六乃至依意法亦六。答此中以所依所缘故建立六种。问岂不已说应成十八或三十六耶。答不尔。所以者何。此中总依觉所觉根。根义有境界境界差别行相而建立故。若依相续刹那差别则有无量。今略说尔所

诸有。此见受妙五欲名得第一现法涅槃。此取劣法为胜见取见苦所断。诸有此见离欲恶不善法有寻有伺。离生喜乐入初静虑具足住名得第一现法涅槃。寻伺寂静内等净心。一趣性无寻无伺。定生喜乐入第二静虑具足住名得第一现法涅槃。离喜住舍正念正知身受乐。圣说能舍具念乐住入第三静虑具足住。名得第一现法涅槃。断乐断苦先喜忧没不苦不乐舍念清净。入第四静虑具足住名得第一现法涅槃。此取劣法为胜见取见苦所断。受妙五欲者。谓人及欲界天。有说。唯欲界天以彼五欲极胜妙故。现法涅槃者谓于现身所得涅槃。问此何故成见取。答五妙欲有垢有秽有毒有浊是鄙劣法。彼执同于出离等乐或涅槃乐故成见取。问入四静虑具足住是胜功德。何故取为现法涅槃亦名见取。答世俗静虑有垢有秽有毒有浊是鄙劣法。彼执同于离垢秽乐或涅槃乐故成见取。问亦有外道执无色定为涅槃者。此中何故不说。答彼诸外道多执静虑为涅槃少执无色。此中依多分说是以无过。复次彼执无色为究竟涅槃。此中说现法涅槃故不说彼。复次四根本静虑是乐道所摄故。诸外道计为现法涅槃。四无色是苦道所摄故。彼不执为现法涅槃。复次无色定微细诸外道于彼不了达故。谓为断灭深生怖畏故不说。为现法涅槃。以是故不说无色。此取劣法为胜。见取者显彼自性。见苦所断者显彼对治。广说如前。彼等起云何。谓有外道闻说涅槃是胜妙乐。便谓若得欲界色界五地乐者。即名已得现法涅槃故起此见。有说。外道得世俗定见五地中诸有情类受诸快乐。便谓获得现法涅槃故起此见。有说。外道由近恶友故起此见。问何故此见取见苦所断耶。答此见依我见转执有我体受涅槃乐故。复次此于果处转执有漏果为涅槃故。复次此迷苦谛以苦法为乐故有九慢类乃至广说。问何故作此论。答为欲分别契经义故。谓契经中说九慢类而不广分别。今欲分别故作斯论。问此见纳息中但应分别诸见。何故分别诸慢类耶。答前已说一一蕴中说一切法。是故一一纳息亦说多法而无有过。尊者世友说曰。此纳息中正分别诸恶见。亦分别似恶见诸烦恼中无似恶见如诸慢者。故于此中亦分别慢。大德说曰。以诸慢类依有身见。是有身见之所长养。有身见后而现在前。已见谛者不复起故。由是此中正分别见亦分别慢。尊者觉天说曰。诸见慢类俱令有情难入佛法是以皆说。谓诸有情若无恶见及诸慢类。则能归依如来正法修习梵行出生死苦得涅槃乐。由有见慢便不归依如来正法失于胜利。尊者妙音说曰。恶见慢类俱障有情亲近善士听闻正法如理作意。法随法行过失尤重是以俱说。我胜者彼于等谓己胜。是依见起过慢者。是依有身见所起过慢。于等谓己胜是过慢摄故。我等者彼于等谓己等。是依见起慢者是依有身见所起慢。于等谓己等而高举是慢摄故。我劣者彼于胜谓己劣。是依见起卑慢者是依有身见所起卑慢。于多胜谓己少劣是卑慢摄故。有胜我者。彼谓有他胜己。即是于胜谓己劣。余如前说。有等我者。彼谓有他等己。即是于等谓己等余如前说。有劣我者。彼谓有他劣己即是于等谓己胜余如前说无胜我者。彼谓无他胜己即是于等谓己等余如前说。无等我者。彼谓无他等己即是于等谓己胜。余如前说。无劣我者。彼谓无他劣己即是于胜谓己劣。余如前说。此九慢类即七慢中三慢所摄。谓慢过慢卑慢。依此本论所释如是。依品类足论我胜慢类中摄三种慢。若于劣谓己胜即是慢。若于等谓己胜即是过慢。若于胜谓己胜即是慢过慢。余八慢类如理应说。此九皆通见修所断而此中不说者。有说。以是傍论故。有说。彼非见相似故

诸有此见风不吹河不流火不然乳不注胎不孕日月不出不没。杂染清净自性安住不增不减。此边执见常见摄见苦所断。此边执见常见摄者显彼自性。见苦所断者显彼对治广说如前。彼等起云何。尊者世友说曰。有诸外道因不正寻思执有实我。微细常住遍一切处。于诸法中冥伏作动见风河等吹流等时谓是我作。非彼能尔如见树动知风所为。机关动时知人所作。大德说曰。有诸外道因恶寻思执有实我。微细常住有胜作用转变诸法。见风河等吹流等时。谓我令彼现如是相。如树等动见影亦动。化主语时化身亦语。有说。外道得世俗定见诸有情诸趣流转相续不断。见风河等随处随时有无不定。便谓有我微细常住有胜作用。令风河等种种转变或有或无。有说。外道亲近恶友随恶友教。发起此见

众生执我作。乃至广说。此中略释诸契经中呵责恶见伽他中义。执我能作等者。执内身中有胜义。我能作能生能化诸物。执他能作等者执外身中有胜义我。能作能生能化诸物。能作者作内恒有法。能生者生外恒有法。能化者化为内外非恒有法。复次能作者作自身诸法。能生者生他身诸法。能化者化为非情诸法。各谓一一非一切者。显诸外道一一别执非一切。同箭谓恶见能中伤故者。显此恶见行相猛利远有所伤。犹如毒箭。彼诸外道无明所盲。不能如实观知过患。当观此是箭。乃至广说。此中劝彼应观恶见是真毒箭。与老病死为前导故者。如世毒箭引生众苦。如是恶见引老病等种种苦恼具慢众生。乃至广说。此中显示具慢七者慢所缚着故。于断常见互相违逆不能越度无际生死。七慢如上说。著者少分着。多著者多分着。遍著者周遍着。缚等亦尔。问着与缚何差别。答名即差别。复次义亦有别。着谓坚着是难洗除义。缚谓缠缚是难解脱义。复次著者是相应缚。缚者是所缘缚。谓七慢类具二缚故。于彼众生能着能缚。复次着谓着其心缚谓缚其身。是谓缚着二义差别。断常见类互相违逆者。如在家者由贪缚着故于所摄受互相违逆。诸出家者由慢缚着故于断常见互相违逆。无际生死者诸趣诸生流转不息是生死义。如是生死无有前际不可知故。有先因故而有后际以般涅槃为后边故。复次生死其量长远不知得解脱时故名无际。得当得俱坌。乃至广说。此显外道于已得当得蕴界处中。为贪嗔痴尘之所坌故。于苦乐行二边过失不如实见。以不见故极沈极走沈。谓大缓不能进趣。走谓太急不能达到。颂中余义如论具释

如契经说诸有沙门婆罗门等。各依胜解起诸诤论。一切皆于五处而转。何等为五。一者执我死后有想。唯此谛实余皆愚妄。二者执我死后无想。三者执我死后非有想非无想。四者执我死后断灭。五者说有现法涅槃。彼五即三三即彼五。彼五即三者。谓彼有想论无想论非有想非无想论即此常见。彼断灭论即此断见。彼现法涅槃论即此见取。三即彼五者。谓此常见即彼有想论无想论。非有想非无想论。此断见即彼断灭论。此见取即彼现法涅槃论

又梵网经说六十二诸恶见趣。皆有身见为本。六十二见趣者。谓前际分别见有十八。后际分别见有四十四。前际分别见有十八者。谓四遍常论。四一分常论。二无因生论。四有边等论。四不死矫乱论。后际分别见有四十四者。谓十六有想论。八无想论。八非有想非无想论。七断灭论。五现法涅槃论。此中依过去起分别见名前际分别见。依未来起分别见名后际分别见。若依现在起分别见此则不定。或名前际分别见或名后际分别见。以现在世是未来前过去后故。或未来因过去果故。前际分别见中四遍常论者。一由能忆一坏成劫。或二或三乃至八十。彼便执我世间俱常。问彼何故作是执。答彼计转变或隐显故。转变论者。作如是执乳变为酪。种变为芽。薪变为灰。如是等类。若续彼而有者皆是彼所转变。非彼法灭有此法生故。一切法自性常住。隐显论者。作如是执。诸法自性或隐或显。彼见此处先有如是形显分量大地洲渚妙高山王余山大海诸树等坏。后于此处复有如是形显分量大地等成。便作是念。彼于中间不可见者非性坏灭。然坏劫时彼性潜隐至成劫位彼性复显。又七士身常无动转互不相触命不可害故作是念。我及所忆二俱是常。由斯便见我及世间俱是常住。二由能忆一生或二或三乃至百千生事。彼便执我世间俱常。由计转变或隐显故。彼若能忆外器坏成。由见此处先有如是形显分量大地洲渚。如前乃至命不可害。若不能忆外器坏成执世间常理不待说。故作是念。我及所忆二俱是常。由斯便见我及世间俱是常住。问此与第一义有何异。答前虽忆多而于能忆诸生无间未得自在。今虽忆少而于能忆。诸生无间已得自在。三由天眼见诸有情死时生时诸蕴相续。谓见死有诸蕴无间中有现前。复见中有诸蕴无间生有现前。又见生有诸蕴无间本有现前。本有诸蕴分位相续乃至死有。譬如水流灯焰相续。由不觉知微细生灭于诸蕴中遂起常想故。便执我世间俱常。由计转变或隐显故。如刀于鞘蛇于其穴人于闇室入出隐显。故作是念。我及所见二俱是常。由斯便见我及世间俱是常住。四由寻伺不如实知。谓我世间俱是常住。彼作是念。有法常有。无法恒无无不可生有不可灭。彼执因果从无始来性唯是一无灭无起。故是前际分别见摄。彼若执色以为我者。由见显形恒相似故便执为常。若执心等以为我者。由心等法无间生故相似生故恒时生故。不能了知细生灭故。能忆往昔所更事故。前后事业互相似故他不碍故。便执为常。彼由如是虚妄寻伺。执我世间俱是常住。如是四种前际分别执遍常论。由劫及生死生寻伺四事而起

四一分常论者。一从梵世殁来生此间。由得宿住随念通故作如是执。我等皆是大梵天王之所化作。梵王能化在彼常住。我等所化故是无常。二闻梵王有如是见立如是论。大种无常。心是常住。或翻此说心是无常大种常住同彼忍者或住梵世或生此间。或展转闻如是道理便作是执。我以大梵天王为量。是故世间一分常住一分无常。三有先从戏忘天殁来生此间。由得宿住随念通故便作是执。彼天诸有不极游戏忘失念者在彼常住。我等先由极戏忘念从彼处殁故是无常。四有先从意愤天殁来生此间。由得宿住随念通故便作是执。彼天诸有不极意愤角眼相视在彼常住。我等先由意极相愤角眼相视从彼处殁故是无常。问如是诸天住在何处。有说。彼住妙高层级。有说。彼是三十三天。如是四种前际分别一分常论。由执大梵大种或心戏忘愤恚四事而起

二无因生论者。一从无想有情天殁来生此间。由得宿住随念通故虽能忆彼出无想心及后诸位。而不能忆出心以前所有诸位。便作是念。我于彼时本无而起。诸法如我亦应一切本无而生。由斯便执我及世间皆无有因自然生起。二由寻伺虚妄推求。今身所更既皆能忆前身。若有彼所更事今此身中亦应能忆。既不能忆故知彼无。又作是念。若依彼生诸有情类必还似彼。如酪中虫还似于酪。牛粪中虫还似牛粪。青叶中虫还似青叶。父母生子还似父母。非即酪等是虫等因。故知一切身及诸根觉慧等法皆无因起。又作是念。现见孔雀鸾凤鸡等山石草木花果刺等。色形差别皆不由因自然而有。彼作是说。谁铦诸刺谁画禽兽谁积山原谁凿涧谷谁复雕镂草木花果。如是一切皆不由因于造世间无自在者由斯便执我及世间皆无因生自然而有。如是二种前际分别无因生论。由无想天虚妄寻伺二事而起

四有边等论者。一由天眼见下唯至无间地狱。见上唯至初静虑天。执我于中悉皆遍满。彼作是念。过此若有我及世间我亦应见。既更不见故知非有。由斯便执我及世间俱是有边。即是二种有分限义。二由依止胜分静虑发净天眼傍见无边执我于中悉皆遍满。由斯便执我及世间俱是无边。即是二种无分限义。三由天眼及神境通。由天眼通见下唯至无间地狱。见上唯至初静虑天。由神境通运身傍去不得边际。遂于上下起有边想。于傍世界起无边想。执我于中悉皆遍满。由斯便执我及世间亦有边亦无边。即是二种俱有分限无分限义。四非有边非无边者即遮第三为此第四。彼作是念。我及世间俱不可说定是有边定是无边。然皆实有。或有说者。彼见世间横无边故。执我世间俱非有边。彼见世间竖有边故。执我世间俱非无边虽无决定而实有我。复有说者。彼执我体或舒或卷不可定说。舒无边故说非有边。卷有边故说非无边。问如是四种既缘现在。云何说为前际分别。答彼待未来亦名前际。复有说者。此四由忆成劫坏劫而建立故。皆得说为前际分别。谓第一论由忆过去成劫之时。我及世间竖有分限故便起有边想。若第二论由忆过去成劫之时。我及世间横无分限故便起无边想。若第三论由忆过去成劫之时。我及世间竖有分限横无分限。起亦有边亦无边想。若第四论由忆过去坏劫之时。我及世间虽不可得分量狭广。而是实有起非有边非无边想。有作是说。执有边者即是断见。执无边者即是常见。执亦有边亦无边者。即是一分断见一分常见。执非有边非无边者。即是唯起萨迦耶见。如是四种前际分别有边等论。依前所说多四事起

四不死矫乱论者。不死谓天。以天长寿外道执为常住不死。有诸外道求生彼天。闻外道论作如是说。若有能答彼不死天。无乱问者得生彼天。若不能答彼不死天。无乱问者无得生义。然无乱有二种。一有相有分别。二无相无分别。有真见者无相无分别无所依故。无真见者有相有分别有所依故。彼外道辈于诸不死无乱问中。以言矫乱。一作是念。我不如实知若善若不善及四圣谛。有余沙门婆罗门等于如是义求如实知。彼若问我如是义者。我若决定答彼所问。便为妄语。由妄语故我便不得生于彼天。彼怖妄语故于不死无乱问中以言矫乱谓作是说。我于诸天秘密义中不应皆说。或自所证或清净道。二作是念我不如实知若善若不善及四圣谛。有余沙门婆罗门等于如是义求如实知。彼若问我如是义者我若拨无彼所问义便为邪见。由邪见故我便不得生于彼天。彼怖邪见故于不死无乱问中以言矫乱余如前说。三作是念。我不如实知若善若不善及四圣谛。有余沙门婆罗门等。于如是义求如实知。彼若问我如是义者。我若不实印彼所问。彼或诘问。我便不知。由无知故我便不得生于彼天。彼怖无知故于不死无乱问中以言矫乱。余如前说。四作是念。我性昧劣不能构集矫乱言词。又作是念。若一向执非为妙善。以一向执非皆称顺诸有情心。若于他心有所违逆。我便不得生于彼天。故我应依不相违理。若有问我有后世耶。应返问言。汝何所欲。若言欲有应印彼言。我于后世亦许为有。如是问无亦有亦无非有非无。或问如是或不如是或异或不异。皆应返问随彼所欲我便印之。又作是念。我性愚痴。若违拒他彼便别我。怖愚痴故于诸不死无乱问中。以言矫乱。问如是四种是何见摄。答彼四于天起不死想皆常见摄。计答他问为生天因是戒禁取。问此四宁是前际分别。答此四皆于现在事转。待未来故立前际名。或有说者。此四皆缘先所闻教。谓彼外道先闻自师所说至教。要由如是答他所问生不死天。彼不死天要由如是答问故得。故此四种皆是前际分别见摄。如是四种前际分别。不死矫乱依怖妄语邪见无知愚钝事起

说一切有部发智大毗婆沙论卷第一百九十九此卷第二十三幅十六行。戒禁取问(之下)善及染污(乃至)故说命根缘缘识三界四部随眠随增(等)一百四十六字者。即是此论第八十七卷。卷末文耳。宋藏错写焉。此中二本即云。此四宁是前际分别。答此四皆于现在事转。待未来故立前际名。或有说者。此四皆缘先所闻教。谓彼外道先闻自师所说至教。要由如是。答他所问生不死天。彼不死天。要由如是答问故得。故此四种皆是前际分别见摄。如是四种前际分别。不死矫乱依怖妄语邪见无知愚钝事起(已上)此一百九字。乃正文也阿毗达磨大毗婆沙论卷第二百

        五百大阿罗汉等造

        三藏法师玄奘奉　诏译

    见蕴第八中见纳息第五之三

后际分别见中十六有想论者。谓初四种依三见立。如说一类补特伽罗。起如是见立如是论。命者即身。复有一类补特伽罗。起如是见立如是论。命者异身。复有一类补特伽罗。起如是见立如是论。此总是我。遍满无二无异无缺。依第一见建立第一我有色死后有想论。谓彼外道执色为我。执余四蕴以为我所。彼所执我以色为性。故名有色。取诸法相说名为想。此有色我有彼想故说名有想。以执四蕴为我所故。彼作是念。此有色我死后有想。此在欲界全色界一分。除无想天。许无色界亦有色者。此亦在彼前三无色。此有想故不在后一。依第二见建立第二我无色死后有想论。谓彼外道执无色为我。执色或余四蕴以为我所。谓若除想执余三蕴总别为我。即执想色蕴为我所。若执想蕴为我。即执余蕴为我所。彼所执我无色为性故名无色。取诸法相说名为想。此无色我或想为性。或有想用说名有想。或有彼想说名有想。以执想蕴为我所故。彼作是念。此无色我死后有想。此在欲界乃至无所有处。除无想天。依第三见建立第三我。亦有色亦无色死后有想论。谓彼外道执色无色为我。如谛语外道等。总于五蕴起一我想。由彼各别分别诸蕴不得实我。犹如各别分别甘酢碱辛苦淡。无总实有一味可得。彼于诸蕴起一想已总执为我。彼所执我以色无色为性。故名亦有色亦无色。取诸法相说名为想。此亦有色亦无色我。或以想为性。或有想用说名有想。或有彼想说名有想。以执自身诸蕴为我。执他诸蕴为我所故。有余外道。于有色我见过失已。依无色我而住。于无色我见过失已。复依有色我而住。彼诸外道我见未断。虽执有我而不决定。说所执我唯是有色或唯是无色。然作是念。此亦有色亦无色。我死后有想此在欲界全随其所应。乃至广说。第四我非有色非无色死后有想论。即遮第三无别依见。彼作是念。我虽实有而不可说定亦有色亦无色。彼见实我定亦有色亦无色。俱有过失故。作是说。此我非有色非无色死后有想。余如前说。如是四种或依寻伺或依等至皆容得起。执我有边死后有想论者。若执色为我。彼所执我体有分限。或在心中如指节量光明炽盛。或在身中称身形量内外明彻。如说我我形相端严光明炽盛清净第一。乔答摩尊宁说无我。若执非色为我。彼所执我亦有分限。以非色法所依所缘有分限故。亦名有边。彼依寻伺起如是执。若依等至起此执者必未得遍处定。如是二种俱作是念。我定有边死后有想。此在欲界全色界一分。除无想天。许无色界亦有色者此亦在彼前三无色。执我无边死后有想论者。若执色为我。彼所执我遍一切处。如明论说。有我士夫其量广大边际难测。光色如日。诸冥闇者虽住其前而不能见。要知此我方能越度生老病死。异此更无越度理趣。又如有说。地即是我我即是地。其量无边。若执无色为我。彼作是念。如不至火终不能烧。若不至刀终不能割。若不至水终不能润。如是若有不至我者终不能取无边分量。彼依寻伺起如是执。若依等至起此执者必已得遍处定。如是二种俱作是念。我定无边死后有想。此在欲界全随其所应。乃至广说。执我亦有边亦无边死后有想论者。若执色为我。彼所执我随所依身。或卷或舒其量不定。彼作是念。身若有量我即有边。身若无量我即无边。若执无色为我。彼作是念。若随有量所依所缘我即有边。若随无量所依所缘我即无边。如是二种俱作是念。我亦有边亦无边死后有想。此在欲界全随其所应。乃至广说。执我非有边非无边死后有想论者。即遮第三为此第四。三门异说如前应知。如是四种或依寻伺或依等至。皆容得起

依想受异故作是说。我有一想我有种种想我有小想我有无量想。我纯有乐我纯有苦。我有苦有乐我无苦无乐死后有想。此中我有一想者。谓在前三无色。由彼诸想一门转故说名一想。我有种种想者。谓在欲色界。除无想天。由彼诸想六门四门转故。及缘种种境故名种种想。依寻伺者我亦有差别。谓有一种工巧智者名有一想。若有种种工巧智者名有种种想。我有小想者。谓执少色为我。或执少无色为我。若执少色为我。彼执色我其量狭小。如指节等。彼执想为我。所依小身故缘少境故。说为小想。我与彼合名有小想。此在欲界全色界一分。除无想天。许无色界亦有色者。此亦在彼前三无色。若执少无色为我。彼或执受为我想为我所。依小身故。缘少境故。说为小想。我与彼合名有小想。执行为我执识为我。广说亦尔。若执想为我。彼想依小身故缘少境故。说为小想。彼执小想为我性故。或有想用名有小想。此在欲界乃至无所有处。除无想天。我有无量想者。谓执无量色为我或执无量无色为我。若执无量色为我。彼执色我遍一切处。彼执想为我。所依无量身故缘无量境故名无量想。我与彼合名有无量想。此在欲界全色界一分。除无想天。许无色界亦有色者。此亦在彼前三无色。若执无量无色为我。彼或执受为我想为我所。彼想依无量身故缘无量境故名无量想。我与彼合故名有无量想。执行为我执识为我。广说亦尔。若执想为我。彼想依无量身故缘无量境故名无量想。彼执无量想为我性故。或有想用故名有无量想。此在欲界乃至无所有处。除无想天。如是四种或依寻伺或依等至皆容得起。我纯有乐者。谓在前三静虑。诸得定者以天眼通见三静虑恒时受乐。后从彼殁来生此间。便作是念我纯有乐。诸等伺者见诸有情于一切时与乐具合。便作是念我纯有乐。如于此世他世亦尔。我纯有苦者。谓在地狱。诸得定者以天眼通见在地狱恒时受苦。后从彼殁来生此间。便作是念我纯有苦。诸寻伺者见诸有情于一切时与苦具合。便作是念我纯有苦。如于此世他世亦尔。我有苦有乐者。谓在傍生鬼界人及欲界天。诸得定者以天眼通见彼有情苦乐杂受。后从彼殁来生此间。便作是念我有苦有乐。诸寻伺者见诸有情有时与苦具合有时。与乐具合。便作是念我有苦有乐。如于此世他世亦尔。我无苦无乐者。谓在第四静虑乃至无所有处。诸得定者知彼有情无苦无乐。后从彼殁来生此间。便作是念我无苦无乐。诸寻伺者作如是念。我体是常不明了转。虽有暂与苦乐相应而彼是客我非有彼。此十六种后际分别。诸有想论依前所说十六事起。八无想论者。谓有色等四有边等四。有色等四者。一执我有色死后无想。谓彼执色为我得无想定。及见他得彼定生无想有情天便作是念。我有色死后无想。当生无想有情天中想不起故。诸寻伺者执色为我。见有风痫熟眠闷绝苦受所切似全无想便作是念。我虽有色而无其想。如于此世他世亦尔。二执我无色死后无想。谓彼执命根为我得无想定。及见他得彼定生无想有情天。便作是念。我无色死后无想当生无想有情天中。想不起故。诸寻伺者执命根为我。见有风痫熟眠闷绝苦受所切似全无想。便作是念。我无色亦无想。如于此世他世亦尔。有寻伺者除想执余三蕴为我。亦容执我无色死后无想。三执我亦有色亦无色死后无想。谓彼执色命根为我。彼于此二起一我想。由彼各别分别此二不得实我。犹如各别分别甘等不得总味。彼执此二为一我已得无想定。及见他得彼定生无想有情天。便作是念。我亦有色亦无色死后无想。当生无想有情天中。想不起故。诸寻伺者执色命根为我。见有风痫熟眠闷绝苦受所切似全无想。便作是念。我亦有色亦无色而全无想。如于此世他世亦尔。有寻伺者除想执余四蕴为我亦容执我亦有色亦无色死后无想。四执我非有色非无色死后无想。即遮第三为此第四。三门异说如前应知。有边等四者。一执我有边死后无想。谓若执色为我。彼执色我其量狭小。如指节等。若执无色为我。彼执命根为我。遍在身中称身形量。如是执已得无想定。及见他得彼定生无想有情天。便作是念。我有边死后无想。当生无想有情天中。想不起故。诸寻伺者亦执彼为我见有风痫。随其所应。广如前说。二执我无边死后无想。谓若执色为我。彼执色我遍一切处。若执无色为我。彼执命根为我。亦遍一切处。如是执已得无想定。及见他得彼定生无想有情天。便作是念。我无边死后无想。当生无想有情天中。想不起故。诸寻伺者亦执彼为我。见有风痫。随其所应广如前说。三执我亦有边亦无边死后无想。谓若执色为我。彼执色我或卷或舒。若执无色为我。彼执命根为我。亦如身色或卷或舒。如是执已得无想定。及见他得彼定生无想有情天。便作是念。我亦有边亦无边死后无想。当生无想有情天中。想不起故。诸寻伺者亦执彼为我。随其所应广如前说。四执我非有边非无边死后无想。即遮第三为此第四。三门异说如前应知。如是八种后际分别。诸无想论依前所说。八种事起

八非有想非无想论者。谓有色等四有边等四。有色等四者。一执我有色死后非有想非无想。谓寻伺者执色为我。彼见有情想不明了。便作是念。我有色非有想非无想。如于此世他世亦尔。非得彼定可有此执。所以者何。要已离无所有处染者。方可执非想非非想处诸蕴为我。彼既无色此执理无有依别义说。得彼定亦有此执。谓生欲色界已离无所有处染者。执非想非非想处诸蕴为我。彼所执我体虽非色。而与色合名有色我。如说有髻人而人体非髻。彼虽不执色为我所。而所执我未离色身。乃至命终犹随身故说我有色。彼由所入非想非非想处定想不明了故。执我现在非有想非无想死后亦然。许无色界亦有色者。彼许有执非想非非想处我实有色。而非有想亦非无想。二执我无色死后非有想非无想。谓得彼定者执非想非非想处诸无色蕴为我。或为我所。彼所执我以无色为性。或有无色故名无色我。彼由所入非想非非想处定想不明了故。执我现在非有想非无想死后亦然。诸寻伺者执无色为我。彼见有情想不明了便作是念。我无色非有想非无想。如于此世他世亦尔。三执我亦有色亦无色死后非有想非无想。谓寻伺者执色无色为我。彼见有情想不明了。便作是念。我亦有色亦无色非有想非无想。如于此世他世亦尔。非得彼定可有此执。所以者何。要已离无所有处染者。方可执非想非非想处诸蕴为我。彼既无色此执理无有。依别义说。得彼定亦有此执。谓生欲色界已离无所有处染者。执非想非非想处诸蕴为我。彼所执我体虽非色而与色合名有色我。如说有髻人而人体非髻彼虽不执色为我所。而所执我未离色身。乃至命终犹随身故说我亦有色。执无色为我故说我亦无色。彼由所入非想非非想处定想不明了故。执我现在非有想非无想死后亦然。许无色界亦有色者。彼许有执非想非非想处我实亦有色亦无色。而非有想亦非无想。四执我非有色非无色。死后非有想非无想。即遮第三为此第四。三门异说如前应知

有边等四者。一执我有边死后非有想非无想。二执我无边死后非有想非无想。三执我亦有边亦无边。死后非有想非无想。四执我非有边非无边。死后非有想非无想。如是一切皆执无色为我。已得非想非非想处定者皆容有此执。又此一切皆容执非想非非想处。四无色蕴为我我所。一由彼定时分促故。以一一蕴为所缘故执我有边。二由彼定时分长故。总以四蕴为所缘故执我无边。三由彼定时分或促或长故。或一一蕴或总四蕴为所缘故。执我亦有边亦无边。即遮第三为其第四。三门异说如前应知。此中一切皆由所入非想非非想处定想不明了故。执我现在非有想非无想死后亦然。诸寻伺者及许无色界亦有色者。执色无色为我。随其所应广如前说。如是八种后际分别非有想非无想论。依前所说八事而起。问何故无想论及非有想非无想论中。不说我有一想等八耶。答若亦说者一切皆应名有想论。以有想受者非无想等故。如是一切有想等论说死后故。皆是后际分别见摄

七断灭论者。一作是念。此我有色粗四大种所造为性。死后断灭毕竟无有。齐此名为我正断灭。彼见此生受胎为初死时为后便作是念。我受胎时本无而有。若至死位有已还无名善断灭。二作是念。此我欲界天死后断灭毕竟无有。齐此名为我正断灭。彼作是念。我既不因产门而生。本无而有。有已还无。如彗星等名善断灭。三作是念。此我色界天死后断灭毕竟无有。齐此名为我正断灭。彼作是念。我既不因产门而生。本无而有。由等至力。有已还无名善断灭。或有说者。此三断见皆缘已离初静虑染有情而起。彼断见者。虽已得定而未能离初静虑染。所发天眼唯见下地。前三有情既命终已皆生上地。所受中有生有等身。非彼境界便作是念。得静虑者既命终已悉皆断灭。四作是念。此我空无边处天死后断灭毕竟无有。齐此名为我正断灭。五作是念。此我识无边处天死后断灭毕竟无有。齐此名为我正断灭。六作是念。此我无所有处天死后断灭毕竟无有。齐此名为我正断灭。七作是念。此我非想非非想处天死后断灭毕竟无有。齐此名为我正断灭。此中后四有执空无边处为生死顶。乃至有执非想非非想处为生死顶。若执空无边处为生死顶。彼执空无边处死后无有名善断灭。乃至若执非想非非想处为生死顶。彼执非想非非想处死后无有名善断灭。如是七种后际分别诸断灭论。依前所说七事而起。如是七种皆说死后。故是后际分别见摄。五现法涅槃论者。谓外道执。若于现在我受安乐名得涅槃。若我有苦尔时不名得涅槃者不安乐故。初作是念。此我清净解脱出离一切灾横。谓现受用妙五欲乐尔时名得现法涅槃。第二能见诸欲过失彼作是念。欲所生乐众苦所随多诸怨害。定所生乐微妙寂静无众苦随离诸怨害。复作是念。此我清净解脱出离一切灾横。谓现安住最初静虑。尔时名得现法涅槃第三能见诸欲寻伺俱有过失。彼作是念。此我清净解脱出离一切灾横。谓现安住第二静虑尔时名得现法涅槃。第四能见诸欲寻伺及喜过失。彼作是念。此我清净解脱出离一切灾横。谓现安住第三静虑尔时名得现法涅槃。第五能见诸欲寻伺喜入出息皆有过失。彼作是念。此我清净解脱出离一切灾横。谓现安住第四静虑尔时名得现法涅槃。问云何此五现法涅槃论是后际分别见摄答此五虽缘现在而待过去名后。是故说为后际分别。复有说者。此五执我现既有乐后亦有乐。故是后际分别见摄问若尔。何故说为现法涅槃论者。答现乐为先而执后乐。现居先故用标论名。如是五种后际分别。现涅槃论依前所说五事而起。如契经说。苾刍当知。世间沙门婆罗门等。所依诸见皆入二见。谓有见无有见。今应分别。云何诸见一切皆入此二见中。答非此入言显摄彼体。但显彼入二见品中。所以者何。有见者即常见。无有见者即断见。诸恶见趣虽有多种无不皆入此二品类。如此品初补剌拏说无施与等。五类邪见入断见品。以执无故。有说。入二品。由执我常谤因等故。次说乃至活有命者死后断坏无有等断见摄故即断见品。有作是说。此四大种士夫身乃至智者赞受入二品中。次说无因无缘等是末塞羯梨见。次说造教造等是珊阇夷见。此二俱入断见品。以执无故。有说。入二品。由执我常谤因等故。次说此七士身等常见摄故即常见品。次说有十四亿等是无胜发褐见。次说一切士夫诸有所受无不皆以宿作为因等。是离系亲子见。此二俱入二品。以执有我后断灭故。次说一切士夫所受皆是无因无缘等。是犎迦多衍那见。入断见品。以执无故。有说。入二品。以执我常谤无因故。次说自作苦乐等此入二品。以执有我后断灭故。次说所受苦乐非自作等入断见品。以执无故。有说。入二品。以执我常谤无因故。次说我及世间常等常见摄故即常见品。次说谛故住故我有我等常见摄故即常见品。次说谛故住故我无我等断见摄故即断见品。次说我观我等入常见品。次说受妙五欲等入常见品。执有我常得涅槃故。有说。入二品。以执有我后断灭故。次说风不吹等常见摄故即常见品。次说众生执我作等入二见品。以执有我后断灭故。后说诸欲净妙快意受用而无过失等入常见品。执有我常受胜欲故。有说。入二品。以执有我后断灭故。契经中说。我有想见我无想见我非有想非无想见断灭见现法涅槃见。此五入一见品。谓前三入常见品。第四入断见品。第五。有说。入常见品。有说。入二品。梵网经中所说六十二见。亦总入此二见品中。谓前际分别见中四遍常论入常见品。四一分常论。有说。入常见品。有说。入二品以执有常有无常故。二无因论入断见品。有说。入二品。以执我常谤无因故。有边等四论。及不死矫乱四论入常见品。有说。入二品以执我常后亦断故。后际分别见中有想无想非有想非无想论。皆常见摄故即常见品。七断灭论断见摄故即断见品。五现法涅槃论入常见品。执有我常得涅槃故。有说。入二品。以执有我现得涅槃后断灭故。迦多衍那契经中说。世有二见。一者有见。二者无见。如次摄入常断见品。师子吼经说。一切见皆依二见。谓有见无有见。依有见者耽著有见憎无有见。依无有见者耽着无有见憎有见。此二如次亦即摄入常断见品。如契经说。常见外道或执转变。或执隐显。或执往来意界常等。如是一切常见摄故即常见品。如契经说。有外道执命者即身。命者异身。命者非即身。命者非异身。问外道何故执命者即身耶。尊者世友作如是说。彼见世间身生时说有情生。身坏时说有情死故。复次彼见世间于有色根身说有命者。于无色根身说无命者故。复次彼见世间于身相差别起男女想故。复次彼见世间于身力强弱说强弱者故。复次彼见世间身形长短粗细肥瘦白黑等异说长短等者故。复次彼见世间于身一分有被损害时。遍身皆受不安隐苦故。复次彼见世间忧及喜时。流泪毛竖颜色怡悦故。复次彼见世间皆于身起我名想故。有余师说。彼见世间守宫蚸蜴等尾。若断时各能动转故。大德说曰。彼见世间于有色根身说有情形相。有情言音。有情好丑。有情威仪。有情作业等故。由如是等种种因缘。诸外道说命者即身。问外道何故执命者异身耶。尊者世友作如是说。彼诸外道执色为身。执心心所以为命者。色与心等相续各异。彼觉色身前后转变。不觉心等前后异相。故起此见复次彼见身粗心心所细。命者是细故异于身。复次彼见威仪随意欲转。即执意欲以为命者。威仪即身转变差别。复次彼见死者身相无异。便作是念。命者离身说名为死故与身异。复次彼见色身与心心所分位前后转变各异。彼执心等即是命者故异于身。复次彼见色身有多分。而命者是一故异于身。复次彼诸外道见舍前有身受中有身。复舍中有身受今有身。如是展转身虽有异而命者一故异于身。有余师说。彼见睡眠时身亦有动转。故知其中别有命者。复次彼见梦时。身在本处而有命者游历他方。故知异身别有命者。复有说者。彼见依定能忆过去。及知未来多身差别便作是念。身虽有多而命者一。故知各异。复次彼见世间身无动转。能忆过去及知未来。故知离身别有命者。有作是说。彼见世间。忆先所作及所更事。而身不动。故知离身别有命者。或有说者。彼见身形前后位异。工巧智等随转无别。故知离身别有命者。大德说曰。彼见世间不自在者及自在者。身俱动摇。故知彼身由命者转。问外道何故执命者非即身。尊者世友作如是说。彼见世间身多分异。命者不异故非即身。复次彼见世间身随缘转。命者不尔故非即身。复次彼见世间身有增减损益等异。命者不尔故非即身。大德说曰。彼见世间一身而有种种相异。命者不尔故非即身。问外道何故执命者非异身。尊者世友作如是说。彼见异身无别实物命者可得。故执命者非异于身。所余如前即身中说。大德说曰。彼见世间于自身上而起我爱。不于余法故执命者非异于身。所余如前即身中说。然诸愚夫于色心等刹那相续不善了知。说有命者即异身等。若说即身及非异身入断见品。若说异身及非即身入常见品。故诸外道诸恶见趣无不皆入断常品中。一切如来应正等觉对治彼故宣说中道。谓色心等非断非常

问云何应知死后非断。尊者世友作如是言。见今时心多念相续。由前前灭有后后生。后心必依前心而起。前心有力必引后心。遇极厌缘后方不起。由斯此世初受生心定有前心为因引起。将命终位无极厌缘。正死时心定能引后。前身既能引今身起。今身何故不引后身。由是应知死后非断。复次见今根觉依已起根复能为因引意觉起。故知胎中最初意觉必因过去根觉引生。前生既能引今生起。今生何故不引后生。由是应知死后非断。大德说曰。非离余心有余心转。亦见有色随心而生。复见有心依色而起。由烦恼故有色心生由是应知死后非断。复次现见前念有烦恼身必能引生后念心色。知命终位有烦恼者定能引后心色令生。由是应知死后非断。问诸色心等何故非常。答转变非恒。岂是常住。问宁知转变不由隐显而执彼体有生灭耶。尊者世友作如是说。若彼转变但由隐显。则处胎藏婴孩童子少中老位皆应顿起。然渐次起。故知转变体有生灭不由隐显。复次若彼转变但由隐显。则处胎藏婴孩童子少中老位应有间断。然无间断。故知转变体有生灭不由隐显。大德说曰。世间现见众缘合时有诸法起。缘若乖离诸法便坏。非隐显者有此差别。故知转变不由隐显。但由彼体有生有灭。复次法转变时前后相别体亦应别。相体一故。若法常住虽有隐显分位差别而相无异。故知转变体有生灭伽他纳息所有义趣。如文易了故不复释

三藏法师玄奘译斯论讫说二颂言

  佛涅槃后四百年　　迦腻色加王赡部
  召集五百应真士　　迦湿弥罗释三藏
  其中对法毗婆沙　　具获本文今译讫
  愿此等润诸含识　　速证圆寂妙菩提

说一切有部发智大毗婆沙论卷第二百


阿毗达磨发智论

    No. 1544 [No. 1543]

阿毗达磨发智论卷第一

        尊者迦多衍尼子造

        三藏法师玄奘奉　诏译

    杂蕴第一中世第一法纳息第一

  世第一法七　　顶二暖身见
  十一见摄断　　此章愿具说

云何世第一法。答若心心所法。为等无间。入正性离生。是谓世第一法。有作是说。若五根为等无间。入正性离生。是谓世第一法。于此义中。若心心所法。为等无间。入正性离生。是谓世第一法。何故名世第一法。答如是心心所法。于余世间法。为最为胜。为长为尊。为上为妙。故名世第一法。复次如是心心所法。为等无间。舍异生性。得圣性。舍邪性。得正性。能入正性离生。故名世第一法。世第一法。当言欲界系色界系无色界系耶。答应言色界系。何故此法不应言欲界系耶。答非以欲界道。能断盖制缠。令欲界缠。不复现起。乃以色界道。能断盖制缠。令欲界缠。不复现起。若以欲界道。能断盖制缠。令欲界缠。不复现起。如是世第一法。应言欲界系。然非以欲界道。能断盖制缠。令欲界缠。不复现起。乃以色界道能断盖制缠。令欲界缠。不复现起。是故世第一法。不应言欲界系。何故此法不应言无色界系耶。答入正性离生。先现观欲界苦为苦。后合现观色无色界苦为苦圣道起。先辩欲界事。后合辩色无色界事。若入正性离生。先现观无色界苦为苦。后合现观欲色界苦为苦圣道起。先辩无色界事。后合辩欲色界事。如是世第一法。应言无色界系。然入正性离生。先现观欲界苦为苦。后合现观色无色界苦为苦圣道起。先辩欲界事。后合辩色无色界事。是故世第一法。不应言无色界系。复次入无色定。除去色想。非除色想。能知欲界若缘此法。起苦法智忍。即缘此法。起世第一法。世第一法。当言有寻有伺。无寻唯伺。无寻无伺耶。答应言或有寻有伺。或无寻唯伺。或无寻无伺。云何有寻有伺。答若依有寻有伺三摩地。入正性离生。彼所得世第一法。云何无寻唯伺。答若依无寻。唯伺三摩地。入正性离生。彼所得世第一法。云何无寻无伺。答若依无寻无伺三摩地。入正性离生。彼所得世第一法。世第一法。当言乐根相应。喜根相应。舍根相应耶。答应言或乐根相应。或喜根相应。或舍根相应。云何乐根相应。答若依第三静虑。入正性离生。彼所得世第一法。云何喜根相应。答若依初二静虑。入正性离生。彼所得世第一法。云何舍根相应。答若依未至第四静虑。入正性离生。彼所得世第一法。世第一法。当言一心多心耶。答应言一心。何故此法非多心耶。答从此心心所法。无间不起余世间心。唯起出世心。若当起余世间心者。为劣为等为胜。若当劣者。应不能入正性离生。何以故。非以退道能入正性离生故。若当等者。亦不能入正性离生。何以故。先以此类道。不能入正性离生故。若当胜者。先应非世第一法。后方是世第一法。世第一法。当言退不退耶。答应言不退。何故此法定不退耶。答世第一法。随顺谛。趣向谛。临入谛。此彼中间。无容得起不相似心。令不得入圣谛现观。譬如壮士度河度谷度山度崖。中间无能回转。彼身还至本处。或往余处。先所发起。增上身行未至所趣。必不止息。世第一法。亦复如是。随顺谛。趣向谛。临入谛。此彼中间。无容得起不相似心。令不得入圣谛现观。如赡部洲。有五大河。一名殑伽。二名阎母那。三名萨洛踰。四名阿氏罗筏底。五名莫醯。如是五河。随顺大海。趣向大海。临入大海。中间无能回转彼流还至本处或往余处。彼决定能流入大海。世第一法。亦复如是。随顺谛。趣向谛。临入谛。彼此中间。无容得起不相似心。令不得入圣谛现观。复次世第一法。与苦法智忍。作等无间缘。无有一法速疾回转过于心者。可于尔时能作障碍。令不得入圣谛现观。是故此法。决定不退。云何顶。答于佛法僧。生小量信。如世尊为波罗衍拏摩纳婆说

  若于佛法僧　　生起微小信
  儒童应知彼　　名已得顶法

云何顶堕。答如有一类。亲近善士。听闻正法。如理作意。信佛菩提法。是善说僧。修妙行。色无常。受想行识无常。善施设苦谛。善施设集灭道谛。彼于异时。不亲近善士。不听闻正法。不如理作意。于已得世俗信。退没破坏。移转亡失。故名顶堕。如佛即为波罗衍拏摩纳婆说

  若人于如是　　三法而退失
  我说彼等类　　应知名顶堕

云何暖。答若于正法毗奈耶中。有少信受。如世尊为马师井宿二苾刍说。此二愚人。离我正法及毗奈耶。譬如大地去虚空远。此二愚人。于我正法毗奈耶中。无少分暖

此二十句萨迦耶见。几我见。几我所见耶。答五我见。谓等随观色是我。受想行识是我。十五我所见。谓等随观我有色。色是我所。我在色中。我有受想行识。受想行识是我所。我在受想行识中。若非常常见于五见。何见摄。何见所断。答边执见常见摄见苦所断若常非常见。于五见。何见摄。何见所断。答邪见摄。见灭所断。若苦乐见。于五见。何见摄。何见所断。答取劣法为胜。见取摄。见苦所断。若乐苦见。于五见。何见摄。何见所断。答邪见摄。见灭所断。若不净净见。于五见。何见摄。何见所断。答取劣法为胜。见取摄。见苦所断。若净不净见。于五见。何见摄。何见所断。答邪见摄。此有二种。若谓灭为不净。见灭所断。若谓道为不净。见道所断。若非我我见。于五见。何见摄。何见所断。答有身见摄。见苦所断。若非因因见。于五见。何见摄。何见所断。答非因。谓因戒禁取摄。见苦所断。若因非因见。于五见。何见摄。何见所断。答邪见摄。见集所断。若有无见。于五见。何见摄。何见所断。答邪见摄。此有四种。若谓无苦。见苦所断。若谓无集。见集所断。若谓无灭。见灭所断。若谓无道。见道所断。若无有见。于五见。何见摄。何见所断。答此非见是邪智

    杂蕴第一中智纳息第二

  一智识因缘　　二心念祭祀
  三根用过去　　疑名句文身
  佛诃责六因　　随眠心及断
  因境断识义　　此章愿具说

颇有一智知一切法耶。答无。若此智生一切法非我。此智何所不知。答不知自性。及此相应俱有诸法。颇有一识了一切法耶。答无。若此识生一切法非我。此识何所不了。答不了自性。及此相应俱有诸法。颇有二心展转相因耶。答无。所以者何。无一补特伽罗。非前非后。二心俱生。又非后心为前心因。颇有二心展转相缘耶。答有。如有心起无未来心。即思惟此。起第二心。如有心起有未来心。即思惟此。起第二心。如有心起无未来道心。即思惟此。起第二心。如有心起有未来道心。即思惟此。起第二心。如有二知他心者。彼二心展转相缘。何故无一补特伽罗非前非后二心俱生。答无第二等无间缘故。有情一一心相续转故。补特伽罗。既不可得。又无前心往后心。理何缘能忆本所作事。答有情于法。由串习力。得如是同分智。随所更事。能如是知。如有二造印者。能了自他所造印字。虽彼二人不往相。问汝云何造此字亦不相。答我如是造此字。而彼二人。由串习力。得如是同分智。能了自他所造印字。有情亦尔。由串习力。得如是同分智。随所更事能如是知。又如有二知他心者。互相知心。虽彼二人不往相。问汝云何知我心亦不相。答我如是知汝心。而彼二人由串习力。得如是同分智。互相知心。有情亦尔。由串习力。得如是同分智。随所更事。能如是知。复次一切心心所法。于所缘定。安住所缘。又以受意为因力。强念便不忘。何缘有情忘而复忆。答有情同分相续转时。于法能起相属智见。又以受意为因力。强念便不忘。何缘有情忆而复忘。答有情异分相续转时。于法不起相属智见。又以受意。为因力。劣念便忘失。何缘祭祀饿鬼则到。非余趣耶。答彼趣法尔得如是处事生我分。是故祭祀则到非余。如鹅雁孔雀鹦鹉舍利命命鸟等。虽如意自在飞翔虚空。而神力威德。不大于人。然彼趣法尔得如是处事生我分。能飞翔虚空。鬼趣亦尔。由法尔力。祭祀则到。余趣不尔。又如一类那洛迦。能忆宿住。亦知他心。一类傍生。一类饿鬼。能忆宿住。亦知他心。及起烟焰。兴云致雨。作寒热等。虽能作是事。而神力威德。不大于人。然彼趣法尔得如是处事生我分。能作是事。鬼趣亦尔。由法尔力。祭祀则到。余趣不尔。复次有人。长夜起如是欲如是爱乐。我当娶妇。为儿娶妇。为孙娶妇。令生子孙绍继不绝。我命终已。若生鬼趣。彼念我故。当祭祀我由彼长夜有此欲乐。是故祭祀则到。非余。当言一眼见色二眼见色耶。答应言二眼见色。所以者何。若合一眼。起不净识。开二眼时。起净识故。设合一眼。起如是识。开二眼时。亦起此识。则不应言二眼见色。然合一眼。起不净识。开二眼时。便起净识。是故应言二眼见色。如合覆损破坏亦尔。如眼见色。耳闻声。鼻嗅香亦尔

诸过去彼一切不现耶。答应作四句。有过去非不现。谓如具寿邬陀夷言

  一切结过去　　从林离林来
  乐出离诸欲　　如金出山顶

有不现非过去。谓如有一。或以神通。或以咒术。或以药物。或以如是生处得智。有所隐没。令不显现。有过去亦不现。谓所有行已起等起。已生等生。已转现转。已集已现。已过去。已尽灭。已离变。是过去。过去分。过去世摄。有非过去亦非不现。谓除前相。诸过去彼一切尽耶。答应作四句。有过去非尽。谓如具寿邬陀夷言。一切结过去。乃至广说。有尽非过去。谓如佛言。此圣弟子。已尽地狱。已尽傍生。已尽饿鬼。已尽所有崄恶趣坑。有过去亦尽。谓所有行已起等起。乃至广说。有非过去亦非尽。谓除前相。复次若依结断说者。有结过去非尽。谓结过去未断未遍知。未灭未变吐。有结尽非过去。谓结未来。已断已遍知。已灭已变吐。有结过去亦尽。谓结过去。已断已遍知。已灭已变吐。有结非过去亦非尽。谓结未来。未断未遍知。未灭未变吐。及结现在。诸过去彼一切灭耶。答应作四句。有过去非灭。谓如具寿邬陀夷言。一切结过去。乃至广说。有灭非过去。谓依世俗。小街小舍。小器小眼。言是灭街。乃至灭眼。有过去亦灭。谓所有行已起等起。乃至广说。有非过去亦非灭。谓除前相。复次若依结断说者有结过去非灭。谓结过去。未断未遍知。未灭未变吐。有结灭非过去。谓结未来。已断已遍知。已灭已变吐。有结过去亦灭。谓结过去。已断已遍知。已灭已变吐。有结非过去亦非灭。谓结未来。未断未遍知。未灭未变吐。及结现在

若于苦生疑。此是苦耶。此非苦耶。当言一心多心耶。答应言多心。谓此是苦耶。是一心此非苦耶。是第二心。于集灭道生疑亦尔。颇有一心。有疑无疑耶。答无。所以者何。谓于苦谛。若言此是苦耶。此心有疑。若言此是苦。此心无疑。若言此非苦耶。此心有疑。若言此非苦。此心无疑。于集灭道。应知亦尔

云何多名身。答谓多名号。异语增语。想等想假施设。是谓多名身。云何多句身。答诸句能满未满足。义于中连合。是谓多句身。如世尊说

  诸恶莫作　　诸善奉行　　自净其心
  是诸佛教

如是四句。各能满足未满足。义于中连合。是谓多句身。云何多文身。答诸字众。是谓多文身。如世尊说

  欲为颂本　　文即是字　　颂依于名
  及造颂者

如佛世尊诃诸弟子称言痴人。此有何义。答是诃责语。谓佛世尊。诃责弟子。称言痴人。如今亲教及轨范师。若有近住依止弟子。起诸过失。便诃责言。汝为愚痴。不明不善。世尊亦尔。诃诸弟子。称言痴人。何故世尊诃诸弟子。称言痴人。答彼于世尊教诫教授。不随义行。不随顺。不相续。复次彼于圣教。作愚痴事。空无有果。无出无味。无有胜利。违越佛教。于诸学处。不能受学。故佛诃彼。称言痴人。有六因。谓相应因。乃至能作因。云何相应因。答受与受相应法。为相应因。受相应法与受。为相应因。想思触作意欲胜解念三摩地。慧与慧相应法。为相应因。慧相应法与慧。为相应因。是谓相应因。云何俱有因。答心与心所法。为俱有因。心所法与心。为俱有因。心与随心转身业语业。为俱有因。心与随心转不相应行。为俱有因。随心转不相应行与心。为俱有因。复次俱生四大种展转为俱有因。是谓俱有因。云何同类因。答前生善根。与后生自界善根及相应法。为同类因。过去善根。与未来现在自界善根及相应法。为同类因。现在善根。与未来自界善根及相应法。为同类因。如善根。不善无记根亦尔。差别者。不善中除自界是谓同类因。云何遍行因。答前生见苦所断遍行随眠。与后生自界见集灭道修所断随眠及相应法。为遍行因。过去见苦所断遍行随眠。与未来现在自界见集灭道修所断随眠及相应法。为遍行因。现在见苦所断遍行随眠。与未来自界见集灭道修所断随眠及相应法。为遍行因。如见苦所断见集所断亦尔。是谓遍行因。云何异熟因。答诸心心所法。受异熟色。心心所法。心不相应行。此心心所法。与彼异熟。为异熟因。复次诸身语业。受异熟色。心心所法。心不相应行。此身语业。与彼异熟。为异熟因。复次诸心不相应行。受异熟色。心心所法。心不相应行。此心不相应行。与彼异熟为异熟因。是谓异熟因。云何能作因。答眼及色为缘生眼识。此眼识以彼眼色彼相应法。彼俱有法。及耳声耳识。鼻香鼻识。舌味舌识。身触身识意法意识。有色无色。有见无见。有对无对。有漏无漏。有为无为等一切法。为能作因。除其自性。如眼识耳鼻舌身意识亦尔。是谓能作因

诸心由随眠故。名有随眠心。彼随眠。于此心随增耶。答或随增。或不随增。云何随增。谓彼随眠。与此心相应未断。及缘此心。云何不随增。谓彼随眠。与此心相应已断。设随眠于心随增。此心但由彼随眠。故名有随眠心耶。答或由彼非余。或由彼及余。云何由彼非余。谓此心未断。云何由彼及余。谓苦智已生。集智未生。若心见苦所断。见集所断。随眠所缘。诸心由随眠故。名有随眠心。彼随眠于此心当断耶。答或当断或不当断。云何当断。谓彼随眠缘此心。云何不当断。谓彼随眠与此心相应。诸随眠因何当断。答因所缘。汝说随眠。因所缘当断耶。答如是。若尔诸随眠。见灭道所断。有漏缘彼随眠因何当断。若言此断彼断。俱不应理。答见灭道所断无漏缘随眠。因所缘故断。由此断故彼亦断。设随眠于心当断。此心但由彼随眠故。名有随眠心耶。答或由彼非余。或由彼及余。云何由彼非余。谓心不染污修所断。云何由彼及余。谓心染污

云何因境断识。答苦智已生。集智未生。若心见集所断。见苦所断缘是谓因境断识。于此识。几随眠随增。答十九一心耶。答不尔。谓未离欲染。苦法智已生。集法智未生。若心欲界见集所断见苦所断缘。此因境断识。欲界见集所断。七随眠随增。已离欲染。未离色染苦类智已生。集类智未生。若心色界见集所断见苦所断缘。此因境断识色界见集所断。六随眠随增。已离色染。苦类智已生。集类智未生。若心无色界见集所断见苦所断缘。此因境断识。无色界见集所断。六随眠随增

    杂蕴第一中补特伽罗纳息第三

  缘起缘息依　　心依无有爱
  心脱依界想　　此章愿具说

一补特伽罗。于此生十二支缘起。几过去。几未来。几现在耶。答二过去。谓无明行。二未来。谓生老死。八现在。谓识名色六处触受爱取有。如世尊说。无明缘行。取缘有。云何无明缘行。云何取缘有。答无明缘行者。此显示业先余生中。造作增长。得今有异熟及已受异熟。取缘有者。此显示业现在生中。造作增长。得当有异熟。无明缘行。取缘有。何差别。答无明缘行者。广说如前。此业缘。世尊说一烦恼。谓无明。取缘有者。广说如前。此业缘。世尊说一切烦恼谓诸取。是谓差别。颇有行缘无明不缘明耶。答无。颇有行缘明不缘无明耶。答无。颇有行缘无明亦缘明耶。答有。颇有行不缘无明亦不缘明耶。答无。所以者何。无一有情。从久远来。不于圣道谤言非道。先谤道已。彼于后时。造作增长。感大地业。或于后时。造作增长。感小王业。或于后时。造作增长。感大王业。或于后时。造作增长。转轮王业。由此因。由此缘。由彼圣道。展转感得大地所有城邑聚落人非人畜谷稼药草树木丛林增长滋茂。如是前心四缘。于后心但为一增上缘。复次若依因缘说者。颇有行缘无明不缘明耶。答有。谓无明异熟。及染污行。颇有行缘明不缘无明耶。答有。谓除初明诸余无漏行。颇有行缘无明亦缘明耶。答无。颇有行不缘无明亦不缘明耶。答有。谓除无明异熟。诸余无覆无记行。及初明善有漏行入息出息。当言依身转耶依心转耶。答应言亦依身转亦依心转。如其所应。若入出息。但依身转。不依心转。则在无想定灭尽定位。入出息亦应转。若入出息。但依心转。不依身转。则无色界有情。入出息亦应转。若入出息但依身心转。不如所应。则在卵[穀-禾+卵]及母胎中。羯剌蓝頞部昙闭尸键南。诸根未满未熟。并在第四静虑。入出息亦应转。以入出息亦依身转亦依心转。及如所应。是故下从无间地狱上至遍净。其中有情。诸根满熟。入息出息。依身心转

如有色有情心相续依身转。无色有情心相续依何转耶。答依命根众同分。及余如是类。心不相应行。无有爱当言见所断修所断耶。答应言修所断。有作是说。无有爱。或见所断。或修所断。云何见所断。谓于见所断法。无有而贪。云何修所断。谓于修所。断法。无有而贪。于此义中。无有爱。但应言修所断。汝说无有爱唯修所断。诸预流者。未断此爱耶。答如是汝何所欲。诸预流者。为起如是心。若我死后。断坏无有。岂不安乐耶。答不尔。听我所说。若无有爱。唯修所断。诸预流者。未断此爱。则应说预流者起如是心。若我死后。断坏无有。岂不安乐。若预流者。不起如是心。若我死后。断坏无有。岂不安乐。则不应说无有爱唯修所断。诸预流者。未断此爱。作如是说。俱不应理。汝等亦说。地狱傍生鬼异熟爱。唯修所断。诸预流者。未断此爱耶。答如是。汝何所欲。诸预流者。为起如是心。我当作哀罗筏拏龙王。善住龙王。琰魔鬼王。统摄鬼界诸有情耶。答不尔。听我所说。若地狱傍生鬼异熟爱。唯修所断。诸预流者。未断此爱。则应说预流者起如是心。我当作哀罗筏拏龙王。乃至广说。若预流者。不起如是心。我当作哀罗筏拏龙王。乃至广说。则不应说地狱傍生鬼异熟爱唯修所断。诸预流者。未断此爱。作如是说。俱不应理。汝等亦说。诸缠所缠故。害父母命。此缠唯修所断。诸预流者。未断此缠耶。答如是。汝何所欲。诸预流者。为起如是缠故。害父母命耶。答不尔。听我所说。若缠所缠故。害父母命。此缠唯修所断。诸预流者。未断此缠。则应说预流者起如是缠故害父母命。若预流者。不起如是缠故。害父母命。则不应说诸缠所缠故害父母命。此缠唯修所断。诸预流者。未断此缠。作如是说。俱不应理。汝等亦说。于修所断法。无有而贪。此贪唯修所断。诸预流者。未断此贪耶。答如是。汝何所欲。诸预流者。为缘此起爱耶。答不尔。听我所说。若于修所断法。无有而贪。此贪唯修所断。诸预流者。未断此贪。则应说预流者缘此起爱。若预流者。不缘此起爱。则不应说于修所断法无有而贪此贪唯修所断。诸预流者。未断此贪。作如是说。俱不应理。彼既应理。此亦应然。无有名何法。答三界无常。如世尊说。心解脱贪嗔痴。何等心得解脱。有贪嗔痴心耶。离贪嗔痴心耶。答离贪嗔痴。心得解脱。有作是说。贪嗔痴相应心得解脱。彼不应作是说。所以者何。非此心与贪嗔痴相合。相应相杂。而贪嗔痴未断。心不解脱。贪嗔痴断。心便解脱。世尊亦说。苾刍当知。此日月轮。五翳所翳。不明不照。不广不净。何等为五。一云二烟三尘四雾五曷逻呼阿素洛手如日月轮。非与五翳相合相应相杂彼翳未离。此日月轮。不明不照。不广不净。彼翳若离。此日月轮。明照广净。如是非此心与贪嗔痴相合。相应相杂。而贪嗔痴未断。心不解脱。贪嗔痴断。心便解脱。何等心解脱。过去耶。未来耶。现在耶。答未来无学心生时。解脱一切障。其事如何。答如无间道金刚喻定。将灭解脱道。尽智将生。若无间道金刚喻定。正灭解脱道。尽智正生。尔时名未来无学心生时解脱一切障。未解脱心。当言解脱。已解脱心。当言解脱耶。答已解脱心当言解脱。若已解脱。不应言解脱。若解脱不应言已解脱。已解脱心。而言解脱。不应正理。今应问彼。如世尊说

  若断爱无余　　如莲华处水
  苾刍舍此彼　　如蛇脱故皮

汝许此说是善说耶。答如是。汝何所欲。为已舍言舍未舍言舍耶。答已舍言舍。听我所说。若已舍不应言舍。若舍不应言已舍。已舍而言舍。不应正理。又世尊说

  断慢自善定　　善心一切脱
  一静居不逸　　越死到彼岸

汝许此说是善说耶。答如是。汝何所欲。为已到言到未到言到耶。答已到言到。听我所说。若已到不应言到。若到不应言已到。已到而言到。不应正理。彼既应理。此亦应然。故于契经。应分别义。如世尊说

  兽归林薮　　鸟归虚空　　圣归涅槃
  法归分别

如世尊说。苾刍当知。依厌离染。依离染解脱。依解脱涅槃。云何厌。答若于诸行无学厌恶违逆。是谓厌。云何依厌离染。答若厌相应。无贪无等贪。无嗔无等嗔。无痴无等痴善根。是谓依厌离染。云何依离染解脱。答若离染相应心。已胜解。今胜解。当胜解。是谓依离染解脱。云何依解脱涅槃。答若贪永断。嗔永断。痴永断。一切烦恼永断。是谓依解脱涅槃

如世尊说有三界。谓断界离界灭界。云何断界。答除爱结余结断。名断界。云何离界。答爱结断。名离界。云何灭界。答诸余顺结法断。名灭界。诸断界是离界耶。答如是。设离界是断界耶。答如是。诸断界是灭界耶。答如是。设灭界是断界耶。答如是。诸离界是灭界耶。答如是。设灭界是离界耶。答如是

如世尊说有三想。谓断想离想灭想。云何断想。答除爱结余结断诸想解。名断想。云何离想。答爱结断诸想解。名离想。云何灭想。答诸余顺结法断诸想解。名灭想

说一切有部发智论卷第一阿毗达磨发智论卷第二

        尊者迦多衍尼子造

        三藏法师玄奘奉　诏译

    杂蕴第一中爱敬纳息第四

  爱养敬力灭　　涅槃蕴究竟
  取遍知三归　　此章愿具说

云何爱。答诸爱等爱喜等喜。乐等乐。是谓爱。云何敬。答诸有敬有敬性。有自在有自在性。于自在者。有怖畏转。是谓敬。云何爱敬。答如有一类。于佛法僧。亲教轨范。及余随一有智尊重同梵行者。爱乐心悦。恭敬而住。若于是处。有爱及敬是谓爱敬。云何供养。答此有二种。一财供养。二法供养。云何恭敬。答诸有恭敬有恭敬性。有自在有自在性。于自在者有怖畏转。是谓恭敬。云何供养恭敬。答如有一类。于佛法僧。亲教轨范。及余随一有智尊重同梵行者。施设供养恭敬而住。若于是处。有供养及恭敬。是谓供养恭敬。云何身力。答诸身勇猛强健轻捷。能有所办。是谓身力。云何身劣。答诸身不勇不猛。不强不健。不轻不捷。无所能办。是谓身劣。身力身劣。几处摄。几识识。答一处摄。谓触处。二识识。谓身识及意识。如二力士相叉扑时。手腕才交。互知强弱。又如强者执弱者持。力之胜劣。相知亦尔

云何择灭。答诸灭是离系。云何非择灭。答诸灭非离系。云何无常灭。答诸行散坏破没亡退。是谓无常灭。非择灭。无常灭。何差别。答非择灭者。不由择力。解脱疫疠灾横愁恼种种魔事。行世苦法。非于贪欲调伏断越。无常灭者。诸行散坏破没亡退。是谓二灭差别

如契经说。有二涅槃界。谓有余依涅槃界。及无余依涅槃界。云何有余依涅槃界。答若阿罗汉。诸漏永尽。寿命犹存。大种造色。相续未断。依五根身。心相续转。有余依故。诸结永尽。得获触证。名有余依涅槃界。云何无余依涅槃界。答即阿罗汉。诸漏永尽。寿命已灭。大种造色相续已断。依五根身。心不复转。无余依故。诸结永尽。名无余依涅槃界。涅槃当言学耶无学耶。非学非无学耶。答涅槃应言非学非无学。有作是说。涅槃有学有无学。有非学非无学。云何学。谓学得诸结断。得获触证。云何无学。谓无学得诸结断。得获触证。云何非学非无学。谓有漏得诸结断。得获触证。于此义中。涅槃但应言非学非无学。而汝说涅槃。有学有无学。有非学非无学耶。答如是。汝何所欲。诸先以世俗道。永断欲贪嗔恚得。非学非无学离系得。彼于四谛。未得现观。修习现观。得现观已。证不还果。转成学耶。答如是。又何所欲。诸先以世俗道。永断欲贪嗔恚得。非学非无学离系得。后证不还果时。即彼离系应转成学若彼今时。转成学者。先应是学体常住故。未证不还果。未有学得。已名为学。不应正理。汝何所欲。阿罗汉向。学诸结断。证阿罗汉果。彼转成无学耶。答如是。又汝何所欲。阿罗汉向。学诸结断。证阿罗汉果时。即彼结断应转成无学。若彼今时成无学者。先应是无学体常住故。未证阿罗汉果。无无学得。已名无学。不应正理。汝何所欲。诸阿罗汉。无学结断。退阿罗汉果时。彼转成学耶。答如是。又何所欲。诸阿罗汉。无学结断。退阿罗汉果时。即彼结断应转成学。若彼今时转成学者。先应是学体常住故。未退阿罗汉果。无有学得。已名为学。不应正理。复次涅槃不应先是非学非无学。后转成学。先是学。后转成无学。先是无学。复转成学。又涅槃不应有学有无学有非学非无学。若如是者。应成二分诸法。不决定故。应有杂乱。是则不应施设诸法性相决定。佛亦不说涅槃有学有无学性。以涅槃恒是非学非无学诸法决定。无有杂乱。恒住自性。不舍自性。涅槃常住。无有变易。是故涅槃但应言非学非无学

如契经说。彼成就无学戒蕴定蕴慧蕴解脱蕴解脱智见蕴。云何无学戒蕴。答无学身律仪。语律仪。命清净。云何无学定蕴。答无学三三摩地。谓空无愿无相。云何无学慧蕴。答无学正见智。云何无学解脱蕴。答无学作意相应心。已胜解。今胜解。当胜解。云何无学解脱智见蕴。答尽智无生智。无学慧蕴。与解脱智见蕴。有何差别。答无学苦集智。是无学慧蕴。无学灭道智。是无学解脱智见蕴。复次无学苦集灭智是无学慧蕴。无学道智。是无学解脱智见蕴。复次无学苦集道智。是无学慧蕴。无学灭智。是无学解脱智见蕴。是谓差别

如世尊说苾刍当知。唯一究竟。无别究竟。此中何法名究竟耶。答世尊或时于道说究竟声。或时于断说究竟声。于道说究竟声者。如世尊说

  一类聪慢者　　不能知究竟
  彼不证道故　　不调伏而死

于断说究竟声者。如世尊说

  已到究竟者　　无怖无疑悔
  永拔有箭故　　彼住后边身
  此是最究竟　　无上寂静迹
  清净不死迹　　诸相皆尽故

又契经说。有一梵志。名数目连。来诣佛所。请问佛曰。乔答摩尊。教授教诫。诸苾刍等。彼受教已。皆能证得最极究竟涅槃界不。世尊告曰。此事不定。一类能证。一类不能

如契经说。佛告苾刍。有诸外道。虽同施设断知诸取。而彼不能具足施设。谓但施设断知欲取见取戒取非我语取。此有何义有作是说。此是世尊。率尔说法。彼不应作是说。所以者何。世尊说法。非全无因。或少因故。复有说者。此言显彼少分断者。彼不应作是说。所以者何。异生亦有能断少分。我语取故。然佛世尊。为天人等。无量大众广说法要。无倒开示。令随类解。有诸外道。窃闻佛说蕴界处盖念住乃至觉支等名。或有具足。或不具足。是诸外道。若有得闻欲取名者。便作是言。我亦施设断知欲取。若有得闻见取名者。便作是言。我亦施设断知见取。若有得闻戒取名者。便作是言。我亦施设断知戒取。如多苾刍集在一处有诸外道。来作是言。如乔答摩。为诸弟子。宣说法要。谓作是说。汝等苾刍。应断五盖如是五盖。能染污心。令慧力劣。损害觉分。障碍涅槃。于四念住。应善住心。于七觉支。应勤修习。我等亦能为诸弟子。说此法要。则乔答摩所说法要。与我何别。而今汝等独归彼耶。然彼外道。尚不能识五盖名相。况能了达。住四念住。修七觉支。然窃佛语。故作是说。施设断取。应知亦然。又如外道摩健地迦。不了自身。众病所集。刹那不住苦空非我。来诣佛所。鼓腹而言。吾今此身。既无诸病。应知即是究竟涅槃。彼尚不知无病名相。况能了达究竟涅槃。然窃佛语。故作是说。施设断取。应知亦然。何缘外道。但有施设断知三取非我语取。答彼于长夜。执有真实。我及有情。命者生者。能养育者。补特伽罗。彼既执有真实。我等宁肯施设断我语取。说同施设断知诸取。斯有何义。答是佛世尊。随彼言说。如世尊说。彼诸外道。施设实有有情断坏。然依胜义。无实有情。但随彼言。而作是说。此亦如是。故无有过。如契经说。有二遍知。谓智遍知。及断遍知。云何智遍知。答诸智见明觉现观。是谓智遍知

云何断遍知。答诸贪永断。嗔痴永断。一切烦恼永断。是谓断遍知。世尊或时于智说遍知声。或时于断说遍知声。于智说遍知声者。如伽他说

  儒童贤寂静　　能益诸世间
  有智能遍知　　贪爱生众苦
  有智言应作　　不作不应言
  智者应遍知　　有言无作者

于断说遍知声者。如契经说。佛告苾刍。当为汝说。所遍知法。遍知自性。能遍知者。所遍知法。谓五取蕴。遍知自性。谓贪永断。嗔痴永断。一切烦恼永断。能遍知者。谓阿罗汉。诸漏永尽不执如来死后有等。不应记法

诸归依佛者。何所归依。答若法实有现有想等想。施设言说。名为佛陀。归依彼所有无学成菩提法。名归依佛。诸归依法者。何所归依。答若法实有现有想等想。施设言说。名为达磨。归依如是爱尽离灭涅槃。名归依法

诸归依僧者。何所归依。答若法实有现有想等想。施设言说。名为僧伽。归依彼所有学无学成僧伽法。名归依僧

    杂蕴第一中无惭纳息第五

  黑白二根心　　掉悔惛睡梦
  盖无明不共　　此章愿具说

云何无惭。答诸无惭无所惭无异惭。无羞无所羞无异羞。无敬无敬性。无自在无自在性。于自在者。无怖畏转。是谓无惭

云何无愧。答诸无愧无所愧无异愧。无耻无所耻无异耻。于诸罪中。不怖不畏。不见怖畏。是谓无愧。无惭无愧。有何差别。答于自在者。无怖畏转。是无惭。于诸罪中。不见怖畏。是无愧。如是差别

云何惭。答诸有惭有所惭有异惭。有羞有所羞有异羞。有敬有敬性。有自在有自在性于自在者。有怖畏转。是谓惭

云何愧。答诸有愧。有所愧有异愧。有耻有所耻有异耻。于诸罪中。有怖有畏。深见怖畏。是谓愧。惭愧何差别。答于自在者。有怖畏转是惭。于诸罪中。深见怖畏是愧。如是差别

云何增上不善根。答诸不善根。能断善根及离欲染时。最初所舍。云何微俱行不善根。答诸不善根离欲染时。最后所舍。由舍彼故。名离欲染。云何欲界增上善根。答菩萨入正性离生时。所得欲界现观边世俗智。及如来得尽智时。所得欲界无贪无嗔无痴善根。云何微俱行善根。答断善根时。最后所舍。由舍彼故。名断善根

诸心过去彼心变坏耶。答诸心过去。彼心皆变坏。有心变坏。彼心非过去。谓未来现在贪嗔相应心。如世尊说。汝等苾刍。设被怨贼锯解汝身。或诸支节。汝等于彼。心勿变坏。亦当护口勿出恶言。若心变坏。及出恶言。于自所求。深为障碍。又世尊说。汝等苾刍。于妙欲境。不应发起变坏之心。诸心染着彼心变坏耶。答诸心染着。彼心皆变坏。有心变坏。彼心非染着。谓过去贪不相应心。及未来现在嗔相应心。如世尊说。汝等苾刍。设被怨贼广说乃至。于自所求。深为障碍

云何掉举。答诸心不寂静。不止息。轻躁掉举。心躁动性。是谓掉举。云何恶作。答诸心燋灼懊变恶作。心追悔性。是谓恶作。诸心有掉举彼心恶作相应耶。答应作四句。有心有掉举非恶作相应。谓无恶作心有躁动性。有心有恶作非掉举相应。谓无染污心有追悔性。有心有掉举亦恶作相应。谓染污心有追悔性。有心无掉举亦非恶作相应。谓除前相

云何惛沈。答诸身重性。心重性。身不调柔。心不调柔。身[夢-夕+登]瞢。心[夢-夕+登]瞢。身愦闷。心愦闷。心惛重性。是谓惛沈

云何睡眠。答诸心睡眠惛微而转。心昧略性。是谓睡眠。诸心有惛沈彼心睡眠相应耶。答应作四句。有心有惛沈非睡眠相应。谓无睡眠心有惛沈性。有心有睡眠非惛沈相应。谓无染污心有睡眠性。有心有惛沈亦睡眠相应。谓染污心有睡眠性。有心无惛沈亦非睡眠相应。谓除前相睡眠。当言善耶不善耶无记耶。答睡眠应言或善或不善或无记。云何善。谓善心睡眠惛微而转。心昧略性。云何不善。谓不善心睡眠惛微而转。心昧略性。云何无记。谓无记心睡眠惛微而转。心昧略性

梦中当言福增长耶。非福增长耶。非福非非福增长耶。答梦中应言或福增长。或非福增长。或非福。非非福增长。福增长者。如有梦中布施作福受持斋戒。或余随一福相续转。非福增长者。如有梦中害生命不与取欲邪行。故妄语。饮诸酒。或余随一非福相续转。非福非非福增长者。如有梦中非福非非福相续转。梦名何法。答诸睡眠时。心心所法。于所缘转。彼觉已随忆。能为他说我已梦见如是如是事。是谓梦

如契经说。有五盖。为五盖摄诸盖。为诸盖摄五盖答诸盖摄五盖。非五盖摄诸盖。不摄何等。谓无明盖。如世尊说

  无明盖所覆　　爱结所系缚
  愚智俱感得　　如是有识身

诸盖彼覆耶。答应作四句。有盖非覆。谓过去未来五盖。有覆非盖。谓除五盖。诸余烦恼现在前。有盖亦覆。谓五盖随一现在前。有非盖非覆。谓除前相。诸欲界系。无明随眠。彼一切不善耶。答诸不善无明随眠。皆欲界系。有欲界系无明随眠非不善。谓欲界系。有身见边执见相应无明。诸色无色界系无明随眠。彼一切无记耶。答诸色无色界系。无明随眠。皆是无记。有无记无明随眠。非色无色界系。谓欲界系。有身见边执见相应无明诸见。苦集所断。无明随眠彼皆是遍行耶。答诸是遍行无明随眠。皆见苦集所断有见苦集所断。无明随眠非遍行。谓见苦集所断非遍行。随眠相应无明诸见。灭道所断。无明随眠。彼皆非遍行耶。答诸见灭道所断。无明随眠。皆非遍行。有非遍行无明随眠。非见灭道所断。谓见苦集所断非遍行。随眠相应无明

云何不共无明随眠。答诸无明于苦不了。于集灭道不了。云何不共掉举缠。答无不共掉举缠

    杂蕴第一中相纳息第六

  二三相同异　　老死无常强
  三相一刹那　　此章愿具说

色法生住老无常。当言色耶非色耶。答应言非色。非色法生住老无常。当言非色耶色耶。答应言非色。有见法生住老无常。当言有见耶无见耶。答应言无见。无见法生住老无常。当言无见耶有见耶。答应言无见。有对法生住老无常。当言有对耶无对耶。答应言无对。无对法生住老无常。当言无对耶有对耶。答应言无对。有漏法生住老无常。当言有漏耶无漏耶。答应言有漏。无漏法生住老无常。当言无漏耶有漏耶。答应言无漏。有为法生住老无常。当言有为耶无为耶。答应言有为。无为法生住老无常。当言无为耶有为耶。答应言无为法。无生住老无常。过去法生住老无常。当言过去耶未来现在耶。答应言过去。未来法生住老无常。当言未来耶过去现在耶。答应言未来。现在法生住老无常。当言现在耶过去未来耶。答应言现在。善法生住老无常。当言善耶不善无记耶。答应言善不善法生住老无常。当言不善耶善无记耶。答应言不善。无记法生住老无常。当言无记耶善不善耶。答应言无记。欲界系法生住老无常。当言欲界系耶色无色界系耶。答应言欲界系。色界系法生住老无常。当言色界系耶欲无色界系耶。答应言色界系。无色界系法生住老无常。当言无色界系耶。欲色界系耶。答应言无色界系。学法生住老无常。当言学耶无学非学非无学耶。答应言学。无学法生住老无常。当言无学耶学非学非无学耶。答应言无学。非学非无学法生住老无常。当言非学非无学耶学无学耶。答应言非学非无学。见所断法生住老无常。当言见所断耶修所断不断耶。答应言见所断。修所断法生住老无常。当言修所断耶见所断不断耶。答应言修所断。不断法生住老无常。当言不断耶见修所断耶。答应言不断

云何老。答诸行向背熟变相。是谓老。云何死。答彼彼有情。从彼彼有情众同分。移转坏没。舍寿暖命根。灭弃诸蕴。身殒丧。是谓死。云何无常。答诸行散坏破没亡退。是谓无常。死无常何差别。答诸死是无常。有无常非死。谓除死余行灭。业力强耶。无常力强耶。答业力强。非无常力。有作是说。无常力强。非业力。所以者何。业亦无常故。于此义中。业力强。非无常力。所以者何。业能灭三世行。无常唯灭现在行故

如世尊说。有三有为之有为相。有为之起亦可了知。尽及住异。亦可了知。一刹那中。云何起。答生。云何尽。答无常。云何住异。答老

    杂蕴第一中无义纳息第七

  无义念无相　　知法轮漏尽
  多欲足满养　　此章愿具说

如世尊说

  修诸余苦行　　当知无义俱
  彼不获利安　　如陆挥船棹

何故世尊。作如是说。修余苦行无义俱耶。答彼行趣死近死至死。非如是苦行能超越死故。又世尊说。结跏趺坐。端身正愿。住对面念

云何名住。对面念耶。答修观行者。系念眉间。或观青淤。或观膖胀。或观脓烂。或观破坏。或观异赤。或观被食。或观分离。或观白骨。或观骨琐。此等名为住对面念。又世尊说。大目干连。底沙梵天。不说第六无相住者耶

云何名第六无相住者耶。答随信行。随法行。名为第六无相住者。所以者何。此二无相。不可安立。不可施设。在此在彼。若苦法智忍。若苦法智。广说乃至。若道类智忍。以此无相不可安立不可施设在此在彼。故名第六无相住者

如契经说。佛转法轮。憍陈那等苾刍。见法地神药叉。举声遍告。世尊。今在婆罗痆斯仙人鹿苑。三转法轮。具十二相。为彼地神有正智见。知佛转法轮。苾刍见法不。答无。彼云何知。答信世尊故。谓佛起世俗心。我转法轮。苾刍见法。由是彼知。或佛告他。我转法轮。苾刍见法故。彼得闻。或从大德天仙所闻。或彼尊者憍陈那等。起世俗心。佛转法轮。我等见法。由是彼知。或彼告他。地神得闻。又契经说。有诸苾刍得阿罗汉。诸漏已尽。三十三天。数数云集善法堂中。称说某处有某尊者。或彼弟子。剃除须发。被服袈裟。正信出家。勤修圣道。诸漏已尽证得无漏。心慧解脱。于现法中。能自通达。证具足住。又自了知。我生已尽。梵行已立。所作已办。不受后有。为彼诸天有正智见。知诸苾刍得阿罗汉诸漏尽不。答无。彼云何知。答信世尊故。谓佛起世俗心。是诸苾刍。得阿罗汉。诸漏已尽。由是彼知。或佛告他。是诸苾刍。得阿罗汉。诸漏已尽。故彼得闻。或从大德天仙所闻。或彼尊者。起世俗心。我已漏尽得阿罗汉。由是彼知。或彼告他。诸天得闻

如契经说。摩揭陀国。诸辅佐臣。或是化法调伏。或是法随法行。云何彼名化法调伏。云何彼名法随法行。答若在天中。而见法者。名化法调伏。若在人中。而见法者。名法随法行。复次若不受持戒。而见法者。名化法调伏。若受持戒。而见法者。名法随法行。云何多欲。答诸欲已欲当欲。是谓多欲。云何不喜足。答诸不喜不等喜。不遍喜。不已喜。不当喜。是谓不喜足。多欲不喜足何差别。答于未得可爱色声香味触衣服饮食床座医药及余资具诸希求寻索思慕方便。是谓多欲。于已得可爱色声香味触。衣服饮食床座医药及余资具。诸复希复欲复乐复求。是谓不喜足。如是差别。云何少欲。答诸不欲不已欲不当欲。是谓少欲

云何喜足。答诸喜等喜遍喜。已喜当喜。是谓喜足。少欲喜足何差别。答于未得可爱色声香味触。衣服饮食床座医药及余资具。诸不希不求不寻不索不思慕不方便。是谓少欲。于已得可爱色声香味触。衣服饮食床座医药及余资具。诸不复希不复欲。不复乐不复求。是谓喜足。如是差别。云何难满。答诸重食重啖多食多啖大食大啖。非少能济。是谓难满。云何难养。答诸饕餮极饕餮。耽极耽。嗜极嗜。好咀嚼。好尝啜。选择而食。选择而啖。非趣能济。是谓难养。难满难养。有何差别。答即前所说。是谓差别。云何易满答诸不重食。不重啖。不多食。不多啖。不大食。不大啖。少便能济。是谓易满。云何易养。答诸不饕餮。不极饕餮。不耽不极耽不嗜。不极嗜。不好咀嚼。不好尝啜。不选择而食。不选择而啖。趣得便济。是谓易养。易满易养。有何差别。答即前所说。是谓差别

    杂蕴第一中思纳息第八

  思寻掉等别　　愚知憍慢害
  多行根性邪　　此章愿具说

云何思。答诸思等思增思。思性思类。心行意业。是谓思。云何虑。答诸虑等虑增虑。称量筹度观察。是谓虑。思虑何差别。答思者业。虑者慧。是谓差别。云何寻。答诸心寻求辩了显示。推度构画。分别性。分别类。是谓寻。云何伺。答诸心伺察。随行随转。随流随属。是谓伺。寻伺何差别。答心粗性名寻。心细性名伺。是谓差别。云何掉举。答诸心不寂静。不止息。躁动掉举。心躁动性。是谓掉举。云何心乱。答诸心散乱流荡不住。非一境性。是谓心乱。掉举心乱。有何差别。答不寂静相名掉举。非一境相名心乱。是谓差别

云何无明。答三界无智。云何不正知。答非理所引慧。汝说不正知是非理所引慧耶。答如是。汝何所欲。诸有正知而妄语者。彼皆失念不正知故而妄语耶。答如是。又何所欲。无有正知而妄语耶。答不尔。应听我语。若言不正知是非理所引慧。诸有正知而妄语。彼皆失念不正知故。而妄语者。则应说无有正知而妄语。若不说无有正知而妄语者。则不应言不正知是非理所引慧。诸有正知而妄语。彼皆失念不正知故而妄语。作如是说。俱不应理。应诘彼言。诸无明皆不正知相应耶。答如是。汝何所欲。诸有正知而妄语者。皆无明趣。无明所缠。失念不正知故而妄语耶。答如是。又何所欲。无有正知而妄语耶。答不尔。应听我说。若言一切无明皆不正知相应。诸有正知而妄语。皆无明趣。无明所缠。失念不正知故而妄语者。则应说无有正知而妄语。若不说无有正知而妄语者。则不应言一切无明皆不正知相应。诸有正知而妄语。皆无明趣。无明所缠。失念不正知故而妄语。作如是说。亦俱不应理。云何憍。答诸憍醉极醉闷极闷。心傲逸。心自取。是谓憍。云何慢。答诸慢已慢当慢。心举恃。心自取。是谓慢。憍慢何差别。答若不方他。染着自法。心傲逸相。名憍。若方于他。自举恃相。名慢。是谓差别。若起增上慢。我见苦是苦或见集是集。此何所缘。答如有一类。亲近善士听闻正法。如理作意。由此因缘。得谛顺忍。苦现观边者。于苦忍乐显了是苦。集现观边者。于集忍乐显了是集。彼由此忍。作意持故。或由中间不作意故。见疑不行。设行不觉。便作是念。我于苦见是苦。或于集见是集。由此起慢。已慢当慢。心举恃。心自取。名增上慢。此即缘苦。或即缘集。若起增上慢。我见灭是灭。或见道是道。此何所缘。答如有一类。亲近善士听闻正法。如理作意。由此因缘。得谛顺忍。灭现观边者。于灭忍乐显了是灭。道现观边者。于道忍乐显了是道。彼由此忍。作意持故。或由中间不作意故。见疑不行。设行不觉。便作是念。我于灭见是灭。或于道见是道。由此起慢。已慢当慢。心举恃。心自取。名增上慢。此即缘彼心心所法。若起增上慢。我生已尽。此何所缘。答如有一类。作是念言。此是道。此是行。我依此道。此行已遍知苦。已永断集。已证灭。已修道。我生已尽。由此起慢。已慢当慢。心举恃。心自取。名增上慢。此即缘生。若起增上慢。我梵行已立。此何所缘。答如有一类。作是念言。此是道此是行。我依此道。此行已遍知苦。已永断集。已证灭。已修道。我梵行已立。由此起慢。已慢当慢。心举恃。心自取。名增上慢。此即缘彼心心所法。若起增上慢。我所作已办。此何所缘。答如有一类。作是念言。此是道此是行。我依此道。此行已遍知苦。已永断集。已证灭。已修道。我已断随眠。已害烦恼。已吐结。已尽漏。所作已办。由此起慢。已慢当慢。心举恃。心自取。名增上慢。此即缘彼心心所法。若起增上慢。我不受后有。此何所缘。答如有一类。作是念言。此是道。此是行。我依此道。此行已遍知苦。已永断集。已证灭。已修道。我生已尽。梵行已立。所作已办。不受后有。由此起慢。已慢当慢。心举恃。心自取。名增上慢。此即缘有。云何自谓卑而起慢耶。答如有一类。见他胜己。种姓族类。财位技艺。及田宅等。作是念言。彼少胜我。我少劣彼。然劣于他。多百千倍。由此起慢。已慢当慢。心举恃心自取。是名自谓卑而起慢

如契经说。若起欲寻恚寻害寻。或自害。或害他。或俱害。云何欲寻自害。答如有一类。起贪缠故。身劳心劳。身烧心烧。身热心热。身燋心燋。复由此缘。当受长夜非爱非乐非喜非悦诸异熟果。如是自害。云何欲寻害他。答如有一类。起贪缠故。观视他妻。彼夫见已。心生嗔忿。结恨愁恼。如是害他。云何欲寻俱害。答如有一类。起贪缠故。污夺他妻。彼夫觉已。遂于其妻。及于其人。打缚断命。或夺财宝。如是俱害。云何恚寻自害。答如有一类。起嗔缠故。身劳心劳。身烧心烧。身热心热。身焦心焦。复由此缘。当受长夜非爱非乐非喜非悦诸异熟果。如是自害。云何恚寻害他。答如有一类。起嗔缠故。断害他命。如是害他。云何恚寻俱害。答如有一类。起嗔缠故。断害他命。亦复被他断害其命。如是俱害。云何害寻自害。答如有一类。起害缠故。身劳心劳。身烧心烧。身热心热。身燋心燋。复由此缘。当受长夜非爱非乐非喜非悦诸异熟果。如是自害。云何害寻害他。答如有一类。起害缠故。打缚于他。如是害他。云何害寻俱害。答如有一类。起害缠故。打缚于他。亦复被他之所打缚。如是俱害

智多耶境多耶。答境多非智。所以者何。智亦境故。智多耶识多耶。答识多非智。所以者何。诸智皆识相应。非诸识皆智相应。忍相应。识非智相应故。有漏行多耶。无漏行多耶。答有漏行多。非无漏行。所以者何。有漏行摄十处二处。少分无漏行。唯摄二处少分故。云何行圆满。答无学身律仪。语律仪。命清净。云何护圆满。答无学根律仪。云何异生性。答若于圣法圣暖圣见圣忍圣欲圣慧。诸非得已非得当非得。是谓异生性。此异生性。当言善耶不善耶无记耶。答应言无记。何故异生性非善耶。答善法。或由加行故得。或由余缘故得。无设加行求作异生。又断善时。善法皆舍。得诸善法不成就性。若异生性。是善性者。断善根者。应非异生。何故异生性非不善耶。答离欲染时。不善皆舍。得不善法不成就性。若异生性。是不善者。诸异生离欲染。应非异生。此异生性。当言欲界系耶。色界系耶。无色界系耶。答应言或欲界系或色界系或无色界系。何故异生性。非唯欲界系耶。答欲界没生无色界时。欲界法皆舍。得欲界法不成就性。若异生性。唯欲界系者。诸异生欲界没生无色界。应非异生。何故异生性非唯色界系耶。答色界没生无色界时。色界法皆舍。得色界法不成就性。若异生性。唯色界系者。诸异生色界没生无色界。应非异生。何故异生性非唯无色界系耶。答入正性离生。先现观欲界苦。后合现观色无色界苦。圣道起先办欲界事。后合办色无色界事。是故异生性。非唯无色界系。此异生性。当言见所断耶修所断耶。答应言修所断。何故异生性非见所断耶。答见所断法皆染污。异生性不染污故。又世第一法正灭。苦法智忍正生。尔时舍三界异生性。得彼不成就性。非于尔时见所断法而有舍故。异生性名何法。答三界不染污。心不相应行。诸法邪见相应。彼法邪思惟相应耶。答应作四句。有法邪见相应非邪思惟。谓邪见相应邪思惟。及余邪思惟不相应邪见相应法。有法邪思惟相应非邪见。谓邪思惟相应邪见。及余邪见不相应邪思惟相应法。有法邪见相应亦邪思惟。谓除邪见相应邪思惟。及除邪思惟相应邪见。诸余邪见邪思惟相应法。有法非邪见相应亦非邪思惟。谓邪见不相应邪思惟。邪思惟不相应邪见。及诸余心心所法色无为。心不相应行。诸法邪见相应彼法邪精进相应耶。答应作四句。有法邪见相应非邪精进。谓邪见相应邪精进。有法邪精进相应非邪见。谓邪见及余邪见不相应邪精进相应法。有法邪见相应亦邪精进。谓除邪见相应邪精进。诸余邪见相应法。有法非邪见相应亦非邪精进。谓邪见不相应邪精进。及诸余心心所法色无为。心不相应行。如以邪见对邪精进。以邪见对邪念邪定亦尔。如以邪见对邪精进邪念邪定。以邪思惟对邪精进邪念邪定亦尔。诸法邪精进相应彼法邪念相应耶答应作四句。有法邪精进相应非邪念。谓邪念。有法邪念相应非邪精进。谓邪精进。有法邪精进相应亦邪念。谓邪精进邪念相应。法有法非邪精进相应亦非邪念。谓诸余心心所法色无为。心不相应行。如以邪精进对邪念。以邪精进对邪定亦尔。如以邪精进对邪念邪定。以邪念。对邪定亦尔

说一切有部发智论卷第二阿毗达磨发智论卷第三

        尊者迦多衍尼子造

        三藏法师玄奘奉　诏译

    结蕴第二中不善纳息第一

  三结等性熟　　断见有根系
  是在具成缘　　此章愿具说

有三结。谓有身见结。戒禁取结。疑结。三不善根。谓贪不善根。嗔不善根。痴不善根。三漏。谓欲漏。有漏。无明漏。四瀑流。谓欲瀑流。有瀑流。见瀑流。无明瀑流。四轭。谓欲轭。有轭。见轭。无明轭。四取。谓欲取。见取。戒禁取。我语取。四身系。谓贪欲身系嗔恚身系。戒禁取身系。此实执身系。五盖。谓贪欲盖。嗔恚盖。惛沉睡眠盖。掉举恶作盖。疑盖。五结。谓贪结。嗔结。慢结。嫉结。悭结。五顺下分结。谓贪欲顺下分结。嗔恚顺下分结。有身见顺下分结。戒禁取顺下分结。疑顺下分结。五顺上分结。谓色贪顺上分结。无色贪顺上分结。掉举顺上分结。慢顺上分结。无明顺上分结。五见。谓有身见。边执见。邪见。见取。戒禁取。六爱身。谓眼触所生爱身。耳鼻舌身意触所生爱身。七随眠。谓欲贪随眠。嗔恚随眠。有贪随眠。慢随眠。无明随眠。见随眠。疑随眠。九结。谓爱结。恚结。慢结。无明结。见结。取结。疑结。嫉结。悭结。九十八随眠。谓欲界系。三十六随眠。色无色界系。各三十一随眠

三结乃至九十八随眠。几不善。几无记。答三结中。一无记。二应分别。谓戒禁取疑结。或不善。或无记。欲界是不善。色无色界是无记。三不善根。唯不善。三漏中。一无记。二应分别。谓欲漏。或不善。或无记。无惭无愧。及彼相应。是不善。余是无记。无明漏。或不善。或无记。无惭无愧相应。是不善。余是无记。四瀑流中。一无记。三应分别谓欲瀑流。或不善。或无记。无惭无愧。及彼相应。是不善。余是无记。见瀑流。或不善。或无记。欲界三见。是不善。欲界二见。色无色界五见。是无记。无明瀑流。或不善。或无记。无惭无愧相应。是不善。余是无记。如四瀑流。四轭。亦尔四取中。一无记。三应分别。谓欲取。或不善。或无记。无惭无愧。及彼相应。是不善。余是无记。见取。或不善。或无记。欲界二见。是不善。欲界二见。色无色界四见。是无记。戒禁取。或不善。或无记。欲界是不善。色无色界。是无记。四身系中。二不善。二应分别。谓戒禁取。此实执身系。欲界是不善。色无色界是无记。五盖唯不善。五结中。三不善。二应分别。谓贪慢结。或不善。或无记。欲界是不善。色无色界是无记。五顺下分结中。二不善。一无记。二应分别。谓戒禁取疑结。或不善。或无记。欲界是不善。色无色界是无记。五顺上分结。唯无记。五见中。二无记。三应分别。谓邪见见取戒禁取。或不善。或无记。欲界是不善。色无色界是无记。六爱身中。二不善。四应分别。谓眼耳身触所生爱身。或不善。或无记。欲界是不善。梵世是无记。意触所生爱身。或不善。或无记。欲界是不善。色无色界是无记。七随眠中。二不善。一无记。四应分别。谓慢疑随眠。或不善。或无记。欲界是不善。色无色界是无记。无明随眠。或不善。或无记。无惭无愧相应。是不善。余是无记。见随眠。或不善。或无记。欲界三见。是不善。欲界二见。色无色界五见。是无记。九结中。三不善。六应分别。谓爱慢取疑结。或不善。或无记。欲界是不善。色无色界是无记。无明结。或不善。或无记。无惭无愧相应。是不善。余是无记。见结。或不善。或无记。欲界一见。是不善。欲界二见。色无色界三见。是无记。九十八随眠中。三十三不善。六十四无记。一应分别。谓欲界见苦所断无明随眠。或不善。或无记。无惭无愧相应。是不善。余是无记。三结。乃至九十八随眠。几有异熟。几无异熟。答诸不善有异熟。诸无记无异熟

三结。乃至九十八随眠。几见所断。几修所断。答三结中。有身见结。见为前行。有二句。或见所断。或见修所断。若有身见。非想非非想处系。随信随法行。现观边苦忍断。是见所断。余若异生断修所断。世尊弟子。断见所断。如有身见结。五顺下分结中。有身见结五见中。有身见边执见亦尔。戒禁取疑结。见为前行。有二句。或见所断。或见修所断。若戒禁取疑。非想非非想处系。随信随法行。现观边诸忍断。是见所断。余若异生断修所断。世尊弟子。断见所断。如戒禁取疑结四瀑流轭中。见瀑流轭。四取中。见取戒禁取。四身系中。戒禁取。此实执身系。五顺下分结中。戒禁取疑结。五见中。邪见见取戒禁取。七随眠中。见疑随眠。九结中。见取疑结。亦尔。贪不善根。修为前行。有二句。或修所断。或见修所断。若贪不善根。学见迹诸智断。是修所断。余若异生断。修所断。世尊弟子。断见所断。如贪不善根嗔痴不善根。三漏中。欲漏。四瀑流轭中。欲瀑流轭。四取中。欲取。四身系中。贪欲嗔恚身系。五盖中。除恶作疑余盖。五结中。嗔结。五顺下分结中。贪欲嗔恚结。七随眠中。欲贪嗔恚随眠。九结中。恚结亦尔。有漏无明漏。见为前行。有三句。或见所断。或修所断。或见修所断。若有漏无明漏。非想非非想处系。随信随法行。现观边诸忍断。是见所断。若有漏无明漏。学见迹诸智断。是修所断。余若异生断。修所断。世尊弟子。断见所断。如有漏无明漏。四瀑流轭中。有无明瀑流轭。四取中。我语取。五结中。贪慢结。六爱身中。意触所生爱身。七随眠中。有贪慢无明随眠。九结中。爱慢无明结亦尔。恶作盖修所断。如恶作盖。五结中。嫉悭结。五顺上分结。六爱身中。前五爱身。九结中。嫉悭结亦尔。疑盖若异生断。修所断。世尊弟子。断见所断。九十八随眠中。二十八见所断。十修所断。余若异生断。修所断。世尊弟子。断见所断

三结乃至九十八随眠。几见苦所断。乃至几修所断答三结中。有身见结。见苦所断。如有身见结。五顺下分结中。有身见结。五见中。有身见边执见亦尔。戒禁取结有二种。或见苦所断。或见道所断。如戒禁取结。四取中。戒禁取。四身系中。戒禁取身系。五顺下分结中。戒禁取结。五见中。戒禁取亦尔。疑结有四种。或见苦所断。乃至或见道所断。如疑结。四瀑流轭中。见瀑流轭。四取中。见取。四身系中。此实执身系。五盖中。疑盖。五顺下分结中。疑结。五见中。邪见见取。七随眠中。见疑随眠。九结中。见取疑结亦尔。三不善根有五种。或见苦所断。乃至或修所断。如三不善根。三漏四瀑流轭中。除见余瀑流轭。四取中。欲取我语取。四身系中。贪欲嗔恚身系。五盖中。除恶作疑余盖。五结中。贪嗔慢结。五顺下分结中。贪欲嗔恚结。六爱身中。意触所生爱身。七随眠中。除见疑余随眠。九结中。爱恚慢无明结亦尔。恶作盖。修所断。如恶作盖。五结中。嫉悭结。五顺上分结。六爱身中。前五爱身。九结中。嫉悭结亦尔。九十八随眠中。二十八见苦所断。十九见集所断。十九见灭所断。二十二见道所断。十修所断

三结乃至九十八随眠。几见几非见。答三结中。二见。一非见。三不善根非见。三漏中。一非见。二应分别。谓欲漏。或见。或非见。欲界五见是见。余非见。有漏或见。或非见。色无色界五见是见。余非见。四瀑流轭中。一见。三非见。四取。四身系中。俱二见。二非见。五盖五结。俱非见。五顺下分结中。二见。三非见。五顺上分结非见。五见是见。六爱身非见。七随眠中。一见六非见。九结中。二见七非见。九十八随眠中。三十六是见。六十二非见

三结乃至九十八随眠。几有寻有伺。几无寻唯伺。几无寻无伺。答三结三种。三不善根。及欲漏。有寻有伺。有漏无明漏。除欲瀑流轭取。余瀑流轭取。三种欲瀑流轭。及欲取。有寻有伺。余三取。及三身系。有寻有伺。余二身系。三种五盖。及三结。有寻有伺。余二结。及三顺下分结三种。余二顺下分结。有寻有伺。五顺上分结中。无色贪。无寻无伺。余四及五见三种。前五爱身。及欲贪嗔随眠。有寻有伺。第六爱身。及余五随眠三种。九结中嗔嫉悭结。有寻有伺。余六三种。九十八随眠中。欲界三十六。有寻有伺。色界三十一三种。无色界三十一。无寻无伺

三结乃至九十八随眠。几乐根相应。几苦喜忧舍根相应。答三结中。有身见。戒禁取结。三根相应。除苦忧根。疑结四根相应。除苦根。三不善根中。贪不善根。三根相应。除苦忧根。嗔不善根。三根相应。除乐喜根。痴不善根。及欲漏无明漏。五根相应。有漏三根相应。除苦忧根。四瀑流轭中。欲无明瀑流轭。五根相应。有瀑流轭。三根相应。除苦忧根。见瀑流轭。四根相应。除苦根。四取中欲取。五根相应见取。四根相应。除苦根。戒禁我语取。三根相应。除苦忧根。嗔恚身系。三根相应。除乐喜根。余三身系。及贪欲盖。三根相应。除苦忧根。嗔恚盖。三根相应。除乐喜根。惛沉掉举盖。五根相应。睡眠盖。三根相应。除乐苦根。恶作疑盖。二根相应。谓忧舍根。五结中。贪慢结。三根相应。除苦忧根。嗔结三根相应。除乐喜根。嫉结二根相应。谓忧舍根。悭结二根相应。谓喜舍根。五顺下分结中。嗔恚结。三根相应。除乐喜根。疑结四根相应。除苦根。余三结。三根相应。除苦忧根。五顺上分结中。无色贪结。一根相应。谓舍根。余四结。及四见。三根相应。除苦忧根。邪见四根相应。除苦根。六爱身中。前五爱身。二根相应。谓乐舍根。第六爱身。及欲有贪慢随眠。三根相应。除苦忧根。嗔恚随眠。三根相应。除乐喜根。见疑随眠。四根相应。除苦根。无明随眠。五根相应。九结中。爱慢取结。三根相应。除苦忧根。恚结三根相应。除乐喜根。无明结。五根相应。见疑结。四根相应。除苦根。嫉结二根相应。谓忧舍根。悭结二根相应。谓喜舍根。九十八随眠中。欲界四见慢。及见所断贪。二根相应。谓喜舍根。疑及见所断嗔。二根相应。谓忧舍根。邪见及见所断无明。三根相应。除乐苦根。修所断贪。三根相应。除苦忧根。嗔三根相应。除乐喜根。无明五根相应。色界三十一随眠。三根相应。除苦忧根。无色界三十一随眠。一舍根相应

三结乃至九十八随眠。几欲界系。几色界系。几无色界系。答三结三种。三不善根。及欲漏。欲界系。有漏二种。或色界系。或无色界系。无明漏三种。欲瀑流轭。及欲取。欲界系。有瀑流轭。及我语取。二种。或色界系。或无色界系。余瀑流轭。及余二取三种。四身系中。贪欲嗔恚。及五盖欲界系。余二身系三种。五结中贪慢。及三顺下分结三种。余三结。及贪欲嗔恚。顺下分结。欲界系。五顺上分结中。色贪色界系。无色贪无色界系。余三结二种。或色界系。或无色界系。五见及第六爱身三种。眼耳身触所生爱身二种。或欲界系。或色界系。鼻舌触所生爱身。欲界系。七随眠中。欲贪嗔恚。欲界系。有贪二种。或色界系。或无色界系。余随眠三种。九结中。恚嫉悭结。欲界系。余结三种。九十八随眠中。三十六。欲界系。三十一。色界系。三十一。无色界系

诸结堕欲界彼结在欲界耶。答应作四句。有结堕欲界彼结非在欲界。谓缠所缠色界没。起欲界中有。及恶魔住梵世。缠所缠故。诃拒如来。有结在欲界彼结非堕欲界。谓缠所缠欲界没。起色界中有及住欲界。色无色界结现在前。有结堕欲界彼结亦在欲界。谓缠所缠欲界没。起欲界中有生有。及住欲界。欲界结现在前。有结非堕欲界彼结亦非在欲界。谓缠所缠色界没。起色界中有生有。色界没生无色界。无色界没。生无色界。无色界没。生色界。及住色界。色无色界结现在前。住无色界。无色界结现在前。诸结堕色界彼结在色界耶。答应作四句。有结堕色界彼结非在色界。谓缠所缠欲界没。起色界中。有及住欲界。色界结现在前。有结在色界彼结非堕色界。谓缠所缠色界没。起欲界中有。及恶魔住梵世缠所缠故。诃拒如来。及住色界。无色界结现在前。有结堕色界彼结亦在色界。谓缠所缠色界没。起色界中有生有。及住色界。色界结现在前。有结非堕色界亦非在色界。谓缠所缠欲界没。起欲界中有生有。欲界没。生无色界。无色界没。生无色界。无色界没。生欲界。及住欲界。欲无色界结现在前。住无色界。无色界结现在前。诸结堕无色界彼结在无色界耶。答诸结在无色界。彼结堕无色界。有结堕无色界彼结非在无色界。谓住欲色界。无色界结现在前。诸结非堕欲界彼结非在欲界耶。答应作四句。翻上应知。诸结非堕色界彼结非在色界耶。答应作四句。翻上应知。诸结非堕无色界彼结非在无色界耶。答如是。有结非在无色界彼结非不堕无色界。谓住欲色界。无色界结现在前

具见世尊弟子。诸色未断彼色系耶。答如是。设色系彼色未断耶。答如是。诸受想行识未断彼受想行识系耶。答如是。有受想行识系彼受想行识非未断谓家家。或一来。或一间。欲界修所断。上中品结。已断遍知。彼相应受想行识。下品结系

具见世尊弟子。诸色已断。彼色离系耶。答如是。设色离系彼色已断耶。答如是。诸受想行识已断。彼受想行识离系耶。答诸受想行识离系。彼受想行识已断。有受想行识已断非离系。谓家家。或一来。或一间。欲界修所断上中品结。已断遍知。彼相应受想行识。下品结系

有五补特伽罗。谓随信行。随法行。信胜解。见至。身证此五补特伽罗。于三结乃至九十八随眠。几成就。几不成就。答随信行。于三结。苦类智未已生皆成就。苦类智已生。二成就。一不成就。于三不善根。未离欲染。皆成就。已离欲染。皆不成就。于三漏。未离欲染。皆成就。已离欲染。二成就。一不成就。于四瀑流轭取。未离欲染。皆成就。已离欲染。三成就。一不成就。于四身系。未离欲染。皆成就。已离欲染。二成就。二不成就。于五盖。未离欲染。道法智未已生。皆成就。道法智已生。四成就。一不成就已离欲染。皆不成就。于五结。未离欲染。皆成就。已离欲染。二成就。三不成就。于五顺下分结。未离欲染。苦类智未已生。皆成就。苦类智已生。四成就。一不成就。已离欲染。苦类智未已生三成就。二不成就。苦类智已生。二成就。三不成就。于五顺上分结。未离色染。皆成就。已离色染。四成就。一不成就。于五见。苦类智未已生。皆成就。苦类智已生。三成就。二不成就。于六爱身。未离欲染。皆成就。已离欲染。未离梵世染。四成就。二不成就。已离梵世染。一成就。五不成就。于七随眠。未离欲染。皆成就。已离欲染。五成就。二不成就。于九结。未离欲染。皆成就。已离欲染。六成就。三不成就。于九十八随眠。未离欲染。苦法智未已生。皆成就。苦法智已生。苦类智未已生。欲界见苦所断。皆不成就。余皆成就。苦类智已生。集法智未已生。三界见苦所断。皆不成就。余皆成就。集法智已生。集类智未已生。三界见苦所断。及欲界见集所断。皆不成就。余皆成就。集类智已生。灭法智未已生。三界见苦集所断。皆不成就。余皆成就。灭法智已生。灭类智未已生。三界见苦集所断。及欲界见灭所断。皆不成就。余皆成就。灭类智已生。道法智未已生。三界见苦集灭所断。皆不成就。余皆成就。道法智已生。三界见苦集灭所断。及欲界见道所断。皆不成就。余皆成就。已离欲染。未离色染。苦类智未已生欲界一切不成就。余皆成就。苦类智已生。集类智未已生。欲界一切。及色无色界见苦所断不成就。余皆成就。集类智已生。灭类智未已生。欲界一切。及色无色界见苦集所断。不成就。余皆成就。灭类智已生。欲界一切。色无色界见苦集灭所断。不成就。余皆成就。已离色染。苦类智未已生。欲色界一切。不成就。余皆成就。灭类智已生。集类智未已生。欲色界一切。及无色界。见苦所断。不成就。余皆成就。集类智已生。灭类智未已生。欲色界一切。及无色界见苦集所断。不成就。余皆成就。灭类智已生。欲色界一切。及无色界见苦集灭所断。不成就。余皆成就。如随信行。随法行亦尔。信胜解。于三结。皆不成就。于三不善根。未离欲染。皆成就已离欲染。皆不成就。于三漏。未离欲染。皆成就。已离欲染。二成就。一不成就。于四瀑流轭。未离欲染。三成就。一不成就。已离欲染。二成就。二不成就。于四取。未离欲染。二成就。二不成就。已离欲染。一成就。三不成就。于四身系。未离欲染。二成就。二不成就。已离欲染。皆不成就。于五盖。未离欲染。四成就。一不成就。已离欲染。皆不成就。于五结。未离欲染。皆成就。已离欲染。二成就。三不成就。于五顺下分结。未离欲染。二成就。三不成就。已离欲染。皆不成就。于五顺上分结。未离色染。皆成就。已离色染。四成就。一不成就。此于五见。皆不成就于六爱身。未离欲染。皆成就。已离欲染。未离梵世染。四成就。二不成就。已离梵世染。一成就。五不成就。于七随眠。未离欲染。五成就。二不成就。已离欲染。三成就。四不成就。于九结。未离欲染。六成就。三不成就。已离欲染。三成就。六不成就。于九十八随眠。未离欲染。十成就。八十八不成就。已离欲染。未离色染。六成就。九十二不成就。已离色染。三成就。九十五不成就。如信胜解见至亦尔。身证于三结三不善根。皆不成就。于三漏。二成就。一不成就。于四瀑流轭。二成就。二不成就。于四取。一成就。三不成就。于四身系及五盖。皆不成就。于五结。二成就。三不成就。于五顺下分结。皆不成就。于五顺上分结。四成就。一不成就。于五见。皆不成就。于六爱身。一成就。五不成就。于七随眠。三成就。四不成就。于九结。三成就。六不成就。于九十八随眠。三成就。九十五不成就

有身见与有身见为几缘。有身见与戒禁取。乃至无色界修所断无明随眠为几缘。乃至无色界修所断无明随眠。与无色界修所断无明随眠为几缘。无色界修所断无明随眠。与有身见。乃至无色界修所断慢随眠为几缘。答有身见。与有身见。为或四三二一缘。云何四。如有身见无间。起有身见。即思惟彼前生与后生为四缘。云何三。如有身见无间。起有身见。不思惟彼前生与后生为三缘。除所缘。或有身见无间起余心。后起有身见。即思惟彼前生与后生为三缘。除等无间。云何二。如有身见无间起余心。后起有身见。不思惟彼前生与后生为二缘。谓因增上。云何一。后生有身见。与前生有身见。若作所缘。为所缘增上。不作所缘。一增上。未来有身见。与过去现在有身见。若作所缘。为所缘增上。不作所缘。一增上。未来现在有身见。与过去有身见。若作所缘。为所缘增上。不作所缘。一增上。欲界有身见。与色无色界有身见。为一增上。色无色界有身见。与欲界有身见。若作等无间。为等无间增上。不作等无间。一增上。色界有身见。与无色界有身见。为一增上。无色界有身见。与色界有身见。若作等无间。为等无间增上。不作等无间一增上。如有身见。与有身见。应知有身见。与余一切非遍行。余一切非遍行。与一切非遍行。一切遍行。与一切非遍行亦尔。有身见与戒禁取。为或四三二一缘。云何四。如有身见无间起戒禁取。即思惟彼前生与后生为四缘。云何三。如有身见无间起戒禁取。不思惟彼前生与后生为三缘。除所缘。或有身见无间起余心。后起戒禁取。即思惟彼前生与后生为三缘。除等无间。云何二。如有身见无间起余心。后起戒禁取。不思惟彼前生与后生为二缘。谓因增上。云何一。后生有身见。与前生戒禁取。若作所缘。为所缘增上。不作所缘。一增上。未来有身见。与过去现在戒禁取。若作所缘。为所缘增上。不作所缘。一增上。未来现在有身见。与过去戒禁取。若作所缘。为所缘增上。不作所缘。一增上。欲界有身见。与色无色界戒禁取。为一增上。色无色界有身见。与欲界戒禁取。若作所缘。非等无间。为所缘增上。若作等无间非所缘。为等无间所缘增上。若作等无间及所缘。为等无间所缘增上。不作等无间及所缘。一增上。色界有身见。与无色界戒禁取。为一增上。无色界有身见。与色界戒禁取。若作所缘。非等无间。为所缘增上。若作等无间。非所缘。为等无间增上。若作等无间及所缘。为等无间所缘增上。不作等无间及所缘。一增上。如有身见。与戒禁取。应知。有身见。与余一切遍行。一切遍行与一切遍行。余一切非遍行。与一切遍行亦尔。

    结蕴第二中一行纳息第二之一

  结一行历六　　小大七摄有
  依系道遍知　　此章愿见说

有九结。谓爱结。乃至悭结。若于此事。有爱结系。亦有恚结系耶。答若于此事。有恚结系。必有爱结系。或有爱结系。无恚结系。谓于色无色界法。有爱结未断。若于此事。有爱结系。亦有慢结系耶。答如是。设有慢结系。复有爱结系耶。答如是。若于此事。有爱结系。亦有无明结系耶。答若于此事。有爱结系。必有无明结系。或有无明结系。无爱结系。谓苦智已生。集智未生。于见苦所断法。有见集所断无明结未断。若于此事。有爱结系。亦有见结系耶。答应作四句。或有爱结系无见结系。谓集智已生。灭智未生。于见灭道所断见结不相应法。及于修所断法。有爱结未断。灭智已生。道智未生。于见道所断见结不相应法。及于修所断法。有爱结未断。具见世尊弟子。于修所断法。有爱结未断。或有见结系。无爱结系。谓苦智已生。集智未生。于见苦所断法。有见集所断见结未断。或有二俱系。谓具缚者。于见修所断法。有二结系。苦智已生。集智未生。于见集灭道修所断法。有二结系。集智已生。灭智未生。于见灭道所断见结相应法。有二结系。灭智已生。道智未生。于见道所断见结相应法。有二结系。或有二俱不系。谓集智已生。灭智未生。于见苦集所断法。无二结系。灭智已生。道智未生。于见苦集灭所断法。无二结系。具见世尊弟子。于见所断法。无二结系。已离欲染。于欲界法。无二结系。已离色染。于欲色界法。无二结系。已离无色染。于三界法。无二结系。如对见结。对疑结亦尔。若于此事。有爱结系。亦有取结系耶。答应作四句。或有爱结系。无取结系。谓集智已生。灭智未生。于修所断法。有爱结未断灭智已生。道智未生。于修所断法。有爱结未断。具见世尊弟子。于修所断法。有爱结未断。或有取结系。无爱结系。谓苦智已生。集智未生。于见苦所断法。有见集所断取结未断。或有二俱系。谓具缚者。于见修所断法有二结系。苦智已生。集智未生。于见集灭道修所断法。有二结系。集智已生。灭智未生。于见灭道所断法。有二结系。灭智已生。道智未生。于见道所断法。有二结系。或有二俱不系。谓集智已生。灭智未生。于见苦集所断法。无二结系。灭智已生。道智未生。于见苦集灭所断法。无二结系。具见世尊弟子。于见所断法。无二结系。已离欲染。于欲界法。无二结系。已离色染。于欲色界法。无二结系。已离无色染。于三界法。无二结系。若于此事。有爱结系。亦有嫉结系耶。答若于此事。有嫉结系。必有爱结系。或有爱结系无嫉结系。谓于欲界见所断法。及于色无色界法。有爱结未断。如对嫉结。对悭结亦尔。如爱结对后作一行。慢结对后作一行亦尔。若于此事。有恚结系。亦有慢结系耶。答若于此事。有恚结系。必有慢结系。或有慢结系。无恚结系。谓于色无色界法。有慢结未断。若于此事。有恚结系。亦有无明结系耶。答若于此事。有恚结系。必有无明结系。或有无明结系。无恚结系。谓未离欲染。苦智已生。集智未生。于欲界见苦所断法。有见集所断无明结未断。于色无色界法。有无明结未断。若于此事。有恚结系。亦有见结系耶。答应作四句。或有恚结系。无见结系。谓未离欲染。集智已生。灭智未生。于欲界见灭道所断见结不相应法。及于欲界修所断法。有恚结未断。灭智已生。道智未生。于欲界见道所断见结不相应法。及于欲界修所断法。有恚结未断。具见世尊弟子。未离欲染。于欲界修所断法。有恚结未断。或有见结系无恚结系。谓未离欲染。苦智已生。集智未生。于欲界见苦所断法。有见集所断见结未断。于色无色界法。有见结未断。或有二俱系。谓具缚者。于欲界见修所断法。有二结系。未离欲染。苦智已生。集智未生。于欲界见集灭道修所断法。有二结系。集智已生。灭智未生。于欲界见灭道所断见结相应法。有二结系。灭智已生。道智未生于欲界见道所断见结相应法。有二结系。或有二俱不系。谓集智已生。灭智未生。于见苦集所断法。及于色无色界见灭道所断见结不相应法。并于色无色界修所断法无二结系。灭智已生道智未生于见苦集灭所断法。及于色无色界见道所断见结不相应法。并于色无色界修所断法。无二结系。具见世尊弟子未离欲染。于见所断法。及于色无色界修所断法。无二结系。已离欲染于欲界法无二结系。已离色染。于欲色界法无二结系。已离无色染。于三界法无二结系。如对见结。对疑结亦尔。若于此事有恚结系。亦有取结系耶。答应作四句或有恚结系。无取结系。谓未离欲染。集智已生灭智未生。于欲界修所断法。有恚结未断。灭智已生。道智未生。于欲界修所断法。有恚结未断具见世尊弟子。未离欲染。于欲界修所断法。有恚结未断。或有取结系。无恚结系。谓未离欲染。苦智已生。集智未生。于欲界见苦所断法。有见集所断取结未断。于色无色界法。有取结未断。或有二俱系。谓具缚者。于欲界见修所断法。有二结系。未离欲染。苦智已生。集智未生。于欲界见集灭道修所断法。有二结系。集智已生。灭智未生。于欲界见灭道所断法。有二结系。灭智已生。道智未生。于欲界见道所断法有二结系。或有二俱不系。谓未离欲染。集智已生。灭智未生。于见苦集所断法。及于色无色界修所断法。无二结系。灭智已生。道智未生。于见苦集灭所断法。及于色无色界修所断法。无二结系。具见世尊弟子。未离欲染。于见所断法。及于色无色界修所断法。无二结系。已离欲染。于欲界法。无二结系。已离色染。于欲色界法。无二结系。已离无色染。于三界法。无二结系。若于此事。有恚结系。亦有嫉结系耶。答若于此事。有嫉结系。必有恚结系。或有恚结系。无嫉结系。谓于欲界见所断法。有恚结未断。如对嫉结。对悭结亦尔

说一切有部发智论卷第三阿毗达磨发智论卷第四

        尊者迦多衍尼子造

        三藏法师玄奘奉　诏译

    结蕴第二中一行纳息第二之二

若于此事。有无明结系。亦有见结系耶。答若于此事。有见结系。必有无明结系。或有无明结系。无见结系。谓集智已生。灭智未生。于见灭道所断见结不相应法。及于修所断法。有无明结未断。灭智已生。道智未生。于见道所断见结不相应法。及于修所断法。有无明结未断。具见世尊弟子。于修所断法。有无明结未断。如对见结。对疑结亦尔。若于此事。有无明结系。亦有取结系耶。答若于此事。有取结系。必有无明结系。或有无明结系。无取结系。谓集智已生。灭智未生。于修所断法。有无明结未断。灭智已生。道智未生。于修所断法。有无明结未断。具见世尊弟子。于修所断法。有无明结未断。若于此事。有无明结系。亦有嫉结系耶。答若于此事。有嫉结系。必有无明结系。或有无明结系。无嫉结系。谓于欲界见所断法。及于色无色界法。有无明结未断。如对嫉结。对悭结亦尔。若于此事。有见结系。亦有取结系耶。答若于此事。有见结系。必有取结系。或有取结系。无见结系。谓集智已生。灭智未生。于见灭道所断见结不相应法。有取结未断。灭智已生。道智未生。于见道所断见结不相应法。有取结未断。若于此事。有见结系。亦有疑结系耶。答应作四句。或有见结系。无疑结系。谓集智已生。灭智未生。于见灭道所断见结相应法。有见结未断。灭智已生。道智未生。于见道所断见结相应法。有见结未断。或有疑结系。无见结系。谓集智已生。灭智未生。于见灭道所断疑结相应法。有疑结未断。灭智已生。道智未生。于见道所断疑结相应法。有疑结未断。或有二俱系。谓具结者。于见修所断法。有二结系。苦智已生。集智未生。于见苦集灭道修所断法。有二结系。或有二俱不系。谓集智已生灭智未生。于见苦集所断法。及于见灭道所断见疑一结不相应法。并于修所断法。无二结系。灭智已生。道智未生。于见苦集灭所断法。及于见道所断见疑二结不相应法。并于修所断法。无二结系。具见世尊弟子。于见修所断法。无二结系。已离欲染。于欲界法无二结系。已离色染。于欲色界法。无二结系。已离无色染。于三界法。无二结系。若于此事。有见结系。亦有嫉结系耶。答应作四句。或有见结系。无嫉结系。谓于欲界见所断法。及于色无色界法。有见结未断。或有嫉结系。无见结系。谓未离欲染。集智已生。灭智未生。于欲界修所断法。有嫉结未断。灭智已生。道智未生。于欲界修所断法。有嫉结未断。具见世尊弟子。未离欲染。于欲界修所断法。有嫉结未断。或有二俱系。谓具缚者。于欲界修所断法。有二结系。未离欲染。苦智已生。集智未生。于欲界修所断法。有二结系。或有二俱不系。谓未离欲染。集智已生。灭智未生。于见苦集所断法。及于见灭道所断见结不相应法。并于色无色界修所断法。无二结系。灭智已生。道智未生。于见苦集灭所断法。及于见道所断见结不相应法。并于色无色界修所断法。无二结系。具见世尊弟子。未离欲染。于见所断法。及于色无色界修所断法。无二结系。已离欲染。于欲界法。无二结系。已离色染。于欲色界法。无二结系。已离无色染。于三界法。无二结系。如对嫉结。对悭结亦尔。如见结对后作一行。疑结对后作一行亦尔。若于此事。有取结系。亦有疑结系耶。答若于此事。有疑结系。必有取结系。或有取结系。无疑结系。谓集智已生。灭智未生。于见灭道所断疑结不相应法。有取结未断。灭智已生。道智未生。于见道所断疑结不相应法。有取结未断。若于此事。有取结系。亦有嫉结系耶。答应作四句。或有取结系。无嫉结系。谓于欲界见所断法。及于色无色界法。有取结未断。或有嫉结系。无取结系。谓未离欲染。集智已生。灭智未生。于欲界修所断法。有嫉结未断。灭智已生。道智未生。于欲界修所断法。有嫉结未断。具见世尊弟子。未离欲染。于欲界修所断法。有嫉结未断。或有二俱系。谓具缚者。于欲界修所断法。有二结系。未离欲染。苦智已生集智未生。于欲界修所断法。有二结系。或有二俱不系。谓未离欲染。集智已生。灭智未生。于见苦集所断法。及于色无色界修所断法。无二结系。灭智已生。道智未生。于见苦集灭所断法。及于色无色界修所断法。无二结系。具见世尊弟子。未离欲染。于见所断法。及于色无色界修所断法。无二结系。已离欲染。于欲界法。无二结系。已离色染。于欲色界法。无二结系。已离无色染。于三界法。无二结系。如对嫉结。对悭结亦尔。若于此事。有嫉结系。亦有悭结系耶。答如是。设有悭结系。复有嫉结系耶。答如是

若于此事。有过去爱结系。亦有未来耶。答如是。设有未来。复有过去耶。答若前生未断则系。若前未生。设生已断则不系。若于此事。有过去爱结系。亦有现在耶。答若现在前。设有现在复有过去耶。答若前生未断则系。若前未生。设生已断则不系。若于此事。有未来爱结系。亦有现在耶。答若现在前。设有现在。复有未来耶。答如是。若于此事。有过去爱结系。亦有未来现在耶。答未来必系。现在若现在前。设有未来现在。复有过去耶。答若前生未断即系。若前未生。设生已断即不系。若于此事。有未来爱结系。亦有过去现在耶。答或有未来。无过去现在。谓于此事。爱结未断。而前未生。设生已断不现在前。或有未来及过去。无现在。谓于此事。有爱结前生未断不现在前。或有未来及现在。无过去。谓于此事。有爱结现在前。而前未生。设生已断。或有未来及过去现在。谓于此事。有爱结前生未断。亦现在前。设有过去现在。复有未来耶。答如是。若于此事。有现在爱结系。亦有过去未来耶。答未来必系。过去若前生未断则系。若前未生。设生已断则不系。设有过去未来。复有现在耶。答若现在前。如爱结历六。应知。恚慢嫉悭非遍行。无明结历六亦尔。若于此事。有过去见结系。亦有未来耶。答如是。设有未来。复有过去耶。答如是。若于此事。有过去见结系。亦有现在耶。答若现在前。设有现在。复有过去耶。答如是。若于此事。有未来见结系。亦有现在耶。答若现在前。设有现在。复有未来耶。答如是若于此事。有过去见结系。亦有未来现在耶。答未来必系。现在若现在前。设有未来现在。复有过去耶。答如是。若于此事。有未来见结系。亦有过去现在耶。答过去必系。现在若现在前。设有过去现在。复有未来耶。答如是。若于此事。有现在见结系。亦有过去未来耶。答如是。设有过去未来。复有现在耶。答若现在前。如见结历六。应知。取疑遍行无明结历六亦尔

若于此事。有过去爱结系。亦有过去恚结系耶。答若前生未断则系。若前未生。设生已断则不系。设有过去恚结系。复有过去爱结系耶。答若前生未断则系。若前未生。设生已断则不系。若于此事。有过去爱结系。亦有未来恚结系耶。答若未断。设有未来恚结系。复有过去爱结系耶。答若前生未断则系。若前未生。设生已断则不系。若于此事。有过去爱结系。亦有现在恚结系耶。答若现在前。设有现在恚结系。复有过去爱结系耶。答若前生未断则系。若前未生。设生已断则不系。若于此事。有过去爱结系。亦有过去现在恚结系耶。答或有过去爱结系。无过去现在恚结系。谓于此事。有爱结前生未断。无恚结前生。设生已断不现在前。或有过去爱结系。及有过去恚结系。无现在。谓于此事。有爱结恚结前生未断。无恚结现在前。或有过去爱结系。及有现在恚结系。无过去。谓于此事。有爱结前生未断。有恚结现在前。而前未生。设生已断。或有过去爱结系。及有过去现在恚结系。谓于此事。有爱结恚结前生未断。及有恚结现在前。设有过去现在恚结系。复有过去爱结系耶。答若前生未断则系。若前未生。设生已断则不系。若于此事。有过去爱结系。亦有未来现在恚结系耶。答或有过去爱结系。无未来现在恚结系。谓于色无色界法。有爱结前生未断。或有过去爱结系。及有未来恚结系。无现在。谓于此事。有爱结前生未断。及有恚结未断不现在前。或有过去爱结系。亦有未来现在恚结系。谓于此事。有爱结前生未断。及有恚结现在前。设有未来现在恚结系。复有过去爱结系耶。答若前生未断则系。若前未生。设生已断则不系。若于此事。有过去爱结系。亦有过去未来恚结系耶。答或有过去爱结系。无过去未来恚结系。谓于色无色界法。有爱结前生未断。或有过去爱结系。及有未来恚结系。无过去。谓于此事。有爱结前生未断。及有恚结未断。而无恚结前生。设生已断。或有过去爱结系。亦有过去未来恚结系。谓于此事。有爱结恚结前生未断。设有过去未来恚结系。复有过去爱结系耶。答若前生未断则系。若前未生。设生已断则不系。若于此事。有过去爱结系。亦有过去未来现在恚结系耶。答或有过去爱结系。无过去未来现在恚结系。谓于色无色界法。有爱结前生未断。或有过去爱结系。及有未来恚结系。无过去现在。谓于此事。有爱结前生未断。及有恚结未断。而前未生。设生已断。不现在前。或有过去爱结系。及有未来现在恚结系。无过去。谓于此事。有爱结前生未断。及有恚结现在前。而前未生。设生已断。或有过去爱结系。及有过去未来恚结系。无现在。谓于此事。有爱结恚结。前生未断。而无恚结现在前。或有过去爱结系。亦有过去未来现在恚结系。谓于此事。有爱结恚结前生未断。及有恚结现在前。设有过去未来现在恚结系。复有过去爱结系耶。答若前生未断则系。若前未生。设生已断则不系。如对恚结。对嫉结悭结亦尔。差别者。于欲界见所断法。及于色无色界法。有爱结前生未断。无过去未来现在嫉结悭结。若于此事。有过去爱结系。亦有过去慢结系耶。答若前生未断则系。若前未生。设生已断则不系。设有过去慢结系。复有过去爱结系耶。答若前生未断则系。若前未生。设生已断则不系。若于此事。有过去爱结系。亦有未来慢结系耶。答如是。设有未来慢结系。复有过去爱结系耶。答若前生未断则系。若前未生。设生已断则不系。若于此事。有过去爱结系。亦有现在慢结系耶。答若现在前。设有现在慢结系。复有过去爱结系耶。答若前生未断则系。若前未生。设生已断则不系。若于此事。有过去爱结系。亦有过去现在慢结系耶。答或有过去爱结系。无过去现在慢结系。谓于此事。有爱结前生未断。无慢结前生。设生已断不现在前。或有过去爱结系。及有过去慢结系。无现在。谓于此事。有爱结慢结前生未断。无慢结现在前。或有过去爱结系。及有现在慢结系。无过去谓于此事。有爱结前生未断。及有慢结现在前。而前未生。设生已断。或有过去爱结系。亦有过去现在慢结系。谓于此事。有爱结慢结前生未断。及有慢结现在前。设有过去现在慢结系。复有过去爱结系耶。答若前生未断则系。若前未生。设生已断则不系。若于此事。有过去爱结系。亦有未来现在慢结系耶。答未来必系。现在若现在前。设有未来现在慢结系。复有过去爱结系耶。答若前生未断则系。若前未生。设生已断则不系。若于此事。有过去爱结系。亦有过去未来慢结系耶。答未来必系。过去若前生未断则系。苦前未生。设生已断则不系。设有过去未来慢结系。复有过去爱结系耶。答若前生未断则系。若前未生。设生已断则不系。若于此事。有过去爱结系。亦有过去未来现在慢结系耶。答或有过去爱结系。及有未来慢结系。无过去现在。谓于此事。有爱结前生未断。无慢结前生。设生已断不现在前。或有过去爱结系。及有过去未来慢结系。无现在。谓于此事。有爱结慢结前生未断。无慢结现在前。或有过去爱结系。及有未来现在慢结系。无过去。谓于此事。有爱结前生未断。及有慢结现在前。而无前生。设生已断。或有过去爱结系。亦有过去未来现在慢结系。谓于此事。有爱结慢结前生未断。及有慢结现在前。设有过去未来现在慢结系。复有过去爱结系耶。答若前生未断则系。若前未生。设生已断则不系。若于此事。有过去爱结系。亦有过去无明结系耶。答如是。设有过去无明结系。复有过去爱结系耶。答若前生未断则系。若前未生。设生已断则不系。若于此事。有过去爱结系。亦有未来无明结系耶。答如是。设有未来无明结系。复有过去爱结系耶。答若前生未断则系。若前未生。设生已断则不系。若于此事。有过去爱结系。亦有现在无明结系耶。答若现在前。设有现在无明结系。复有过去爱结系耶。答若前生未断则系。若前未生。设生已断则不系。若于此事。有过去爱结系。亦有过去现在无明结系耶。答过去必系。现在若现在前。设有过去现在无明结系。复有过去爱结系耶。答若前生未断则系。若前未生。设生已断则不系。若于此事。有过去爱结系。亦有未来现在无明结系耶。答未来必系。现在若现在前。设有未来现在无明结系。复有过去爱结系耶。答若前生未断则系。若前未生。设生已断则不系。若于此事。有过去爱结系。亦有过去未来无明结系耶。答如是。设有过去未来无明结系。复有过去爱结系耶。答若前生未断则系。若前未生。设生已断则不系。若于此事。有过去爱结系。亦有过去未来现在无明结系耶。答过去未来必系。现在若现在前。设有过去未来现在无明结系。复有过去爱结系耶。答若前生未断则系。若前未生。设生已断则不系。若于此事。有过去爱结系。亦有过去见结系耶。答若未断。设有过去见结系。复有过去爱结系耶。答若前生未断则系。若前未生。设生已断则不系。若于此事。有过去爱结系。亦有未来见结系耶。答若未断。设有未来见结系。复有过去爱结系耶。答若前生未断则系。若前未生。设生已断则不系。若于此事。有过去爱结系。亦有现在见结系耶。答若现在前。设有现在见结系。复有过去爱结系耶。答若前生未断则系。若前未生。设生已断则不系。若于此事。有过去爱结系。亦有过去现在见结系耶。答或有过去爱结系。无过去现在见结系。谓于此事。有爱结前生未断。而见结已断。或有过去爱结系。及有过去见结系无现在。谓于此事。有爱结前生未断。及有见结未断。而不现在前。或有过去爱结系。亦有过去现在见结系。谓于此事。有爱结前生未断。亦有见结现在前。设有过去现在见结系。复有过去爱结系耶。答若前生未断则系。若前未生。设生已断则不系。若于此事。有过去爱结系。亦有未来现在见结系耶。答或有过去爱结系。无未来现在见结系。谓于此事。有爱结前生未断。而见结已断。或有过去爱结系。及有未来见结系。无现在。谓于此事。有爱结前生未断。及有见结未断。而不现在前。或有过去爱结系。亦有未来现在见结系。谓于此事。有爱结前生未断。及有见结现在前。设有未来现在见结系。复有过去爱结系耶。答若前生。未断则系。若前未生。设生已断则不系。若于此事。有过去爱结系。亦有过去未来见结系耶。答若未断。设有过去未来见结系。复有过去爱结系耶。答若前生未断则系。若前未生。设生已断则不系。若于此事。有过去爱结系。亦有过去未来现在见结系耶。答或有过去爱结系。无过去未来现在见结系。谓于此事。有爱结前生未断。而见结已断。或有过去爱结系。及有过去未来见结系。无现在。谓于此事。有爱结前生未断。及有见结未断。而不现在前。或有过去爱结系。亦有过去未来现在见结系。谓于此事。有爱结前生未断。亦有见结现在前。设有过去未来现在见结系。复有过去爱结系耶。答若前生未断则系。若前未生。设生已断则不系。如对见结。对取结疑结亦尔。如爱结对后作小七。乃至嫉结对悭结。随其所应。作小七亦尔。如小七。大七亦尔。差别者。以二对一。乃至以八对一。如过去爱等为首有七。乃至过去未来现在爱等为首。亦各有七。如是应知。有七七句

三结乃至九十八随眠。于九十八随眠中。一一摄几随眠。答一切应分别。谓三结中。有身见结摄三。戒禁取结摄六。疑结摄十二。三不善根中。贪嗔不善根。各摄五。痴不善根摄四。一少分。三漏中。欲漏摄三十一。有漏摄五十二。无明漏摄十五。四瀑流中。欲瀑流摄十九。有瀑流摄二十八。见瀑流摄三十六。无明瀑流摄十五。如四瀑流。四轭亦尔。四取中。欲取摄二十四。见取摄三十。戒禁取摄六。我语取摄三十八。四身系中。贪欲嗔恚身系。各摄五。戒禁取身系摄六。此实执身系摄十二。五盖中。贪欲嗔恚盖。各摄五。疑盖摄四。余盖无所摄。五结中。贪慢结。各摄十五。嗔结摄五。嫉悭结无所摄。五顺下分结中。贪欲嗔恚结。各摄五。有身见结摄三。戒禁取结摄六。疑结摄十二。五顺上分结中。色贪结摄一少分。无色贪结摄一少分。掉举结无所摄。慢结摄二少分。无明结摄二少分。五见中。有身见边执见。各摄三。邪见见取。各摄十二。戒禁取摄六。六爱身中。眼耳身触所生爱身。各摄二少分。鼻舌触所生爱身。各摄一少分。意触所生爱身。摄十三。二少分。七随眠中。欲贪嗔恚随眠。各摄五。有贪随眠摄十。慢无明随眠。各摄十五。见随眠摄三十六。疑随眠摄十二。九结中。爱慢无明结。各摄十五。恚结摄五。见取结。各摄十八。疑结摄十二。嫉悭结。无所摄。九十八随眠中。欲界有身见。摄欲界有身见。乃至无色界修所断无明。摄无色界修所断无明

三结乃至九十八随眠。为前摄后。后摄前耶。答三结三不善根。互不相摄。三结三漏。三结二漏。少分互相摄。余不相摄。三结四瀑流。三结三瀑流。少分互相摄。余不相摄。如对四瀑流。对四轭亦尔。三结四取。三结一取。三少分互相摄。余不相摄。三结四身系。一结一身系。互相摄。余不相摄。三结五盖。一结少分一盖。互相摄。余不相摄。三结五结。互不相摄。三结五顺下分结。三结三顺下分结。互相摄。余不相摄。三结五顺上分结。互不相摄。三结五见。二结二见。互相摄。余不相摄。三结六爱身。互不相摄。三结七随眠。三结一随眠一少分。互相摄。余不相摄。三结九结。三结一结二少分。互相摄。余不相摄。三结九十八随眠。三结二十一随眠。互相摄。余不相摄。如是乃至九结九十八随眠。七结九十八随眠。互相摄。余不相摄

三结乃至九十八随眠。几令欲有相续。几令色有相续。几令无色有相续。答一切应分别。谓三结令三有相续。三不善根。及欲漏。令欲有相续。有漏令色无色有相续。无明漏令三有相续。四瀑流轭中。欲瀑流轭。令欲有相续。有瀑流轭。令色无色有相续。见无明瀑流轭。令三有相续。四取中。欲取令欲有相续。见戒禁取令三有相续。我语取令色无色有相续。四身系中。初二令欲有相续。后二令三有相续。五盖令欲有相续。五结中。贪慢结令三有相续。余三结令欲有相续。五顺下分结中。初二令欲有相续。后三令三有相续。五顺上分结中。色贪令色有相续。无色贪令无色有相续。余三令色无色有相续。五见令三有相续。六爱身中。眼耳身触所生爱身。令欲色有相续。鼻舌触所生爱身。令欲有相续。意触所生爱身。令三有相续。七随眠中。欲贪嗔恚。令欲有相续。有贪令色无色有相续。余四令三有相续。九结中。嫉恚悭结。令欲有相续。余六结令三有相续。九十八随眠中。欲界三十六。令欲有相续。色界三十一。令色有相续。无色界三十一。令无色有相续

三结乃至九十八随眠。依何定灭。答三结或依四。或依未至灭。三不善根及欲漏。依未至灭。有漏无明漏。或依七。或依未至灭。四瀑流轭中。欲瀑流轭。依未至灭。有无明瀑流轭。或依七。或依未至灭。见瀑流轭。或依四。或依未至灭。四取中。欲取依未至灭。见戒禁取。或依四。或依未至灭。我语取。或依七。或依未至灭。四身系中。初三依未至灭。后二或依四。或依未至灭。五盖依未至灭。五结中。贪慢结。或依七。或依未至灭。余三结。依未至灭。五顺下分结中。初二依未至灭。后三或依四。或依未至灭。五顺上分结中。色贪或依四。或依未至灭。余四或依七。或依未至灭。五见或依四。或依未至灭。六爱身中。鼻舌触所生爱身。依未至灭。眼耳身触所生爱身。或依初。或依未至灭。意触所生爱身。或依七。或依未至灭。七随眠中。欲贪嗔恚。依未至灭。有贪慢无明。或依七。或依未至灭。见疑或依四。或依未至灭。九结中。爱慢无明。或依七。或依未至灭。恚嫉悭。依未至灭。见取疑。或依四。或依未至灭。九十八随眠中。欲界三十六。依未至灭。色界三十一。及无色界。见所断。或依四。或依未至灭。无色界修所断。或依七。或依未至灭。诸结过去。彼结已系耶。答诸结过去。彼结已系。有结已系。彼结非过去。谓结未来现在已系。诸结未来彼结当系耶。答应作四句。有结未来彼结非当系。谓结未来已断已遍知已灭已吐。定不当退。有结当系彼结非未来。谓结过去已断已遍知已灭已吐。定当退。有结未来彼结亦当系。谓结未来已断已遍知已灭已吐。定当退。有结非未来彼结亦非当系。谓结过去已断已遍知已灭已吐。定不当退。及现在结。诸结现在。彼结今系耶。答诸结现在。彼结今系。有结今系。彼结非现在。谓结过去未来今系

诸用此道。断欲界结。退此道时。还得彼结系不。答还得彼结系。诸用此道。断色无色界结。退此道时。还得彼结系不。答还得彼结系。有九遍知。谓欲界见苦集所断结尽。第一遍知。色无色界见苦集所断结尽。第二遍知。欲界见灭所断结尽。第三遍知。色无色界见灭所断结尽。第四遍知。欲界见道所断结尽。第五遍知。色无色界见道所断结尽。第六遍知。五顺下分结尽。第七遍知。色爱结尽。第八遍知。一切结尽。第九遍知。为九遍知摄一切遍知。为一切遍知摄九遍知。答一切摄九。非九摄一切。不摄何等。谓苦智已生。集智未生。三界见苦所断结尽。非九所摄。具见世尊弟子。未离欲染。欲界修所断结尽。非九所摄。已离欲染。未离色染。色界修所断结尽。非九所摄。已离色染。未离无色染。无色界修所断结尽。非九所摄

有八补特伽罗。一预流向。二预流果。三一来向。四一来果。五不还向。六不还果。七阿罗汉向。八阿罗汉果。此八补特伽罗

于九遍知。几成就。几不成就。答预流向。或不成就。或成就一二三四五。谓苦法智忍。乃至集法智忍位。不成就。集法智集类智忍位。成就一。集类智灭法智忍位。成就二。灭法智灭类智忍位。成就三。灭类智道法智忍位。成就四。道法智道类智忍位。成就五。预流果成就六。一来向。若倍离欲染。入正性离生者。如预流向。若从预流果。趣一来果者。及一来果。成就六。不还向。若已离欲染。入正性离生者。如预流向。若从一来果。趣不还果者。成就六。不还果。成就一。谓五顺下分结尽。阿罗汉向。或成就一。或成就二。谓未离色染者。成就一。已离色染者。成就二。阿罗汉果。成就一。谓一切结尽

说一切有部发智论卷第四阿毗达磨发智论卷第五

        尊者迦多衍尼子造

        三藏法师玄奘奉　诏译

    结蕴第二中有情纳息第三

  顿渐系离系　　果摄七成三
  死生不六种　　此章愿具说

三界各有二部结。谓见修所断。于欲界见修所断二部结。颇有顿得系耶。答有。谓已离欲染异生。从离欲染退时。及色无色界没。生欲界时。颇有顿离系耶。答有。谓异生离欲染时。颇有渐得系耶。答无。颇有渐离系耶。答有。谓世尊弟子。先离彼见所断结。后离彼修所断结。于色界见修所断二部结。颇有顿得系耶。答有。谓已离色染异生。从离色染退时。及无色界没。生欲色界时。颇有顿离系耶。答有。谓异生离色染时。颇有渐得系耶。答无。颇有渐离系耶。答有。谓世尊弟子。先离彼见所断结。后离彼修所断结。于无色界见修所断二部结。颇有顿得系耶。答无。颇有顿离系耶。答无。颇有渐得系耶。答无。颇有渐离系耶。答有。谓世尊弟子。先离彼见所断结。后离彼修所断结。欲界见所断结尽。何果摄。答四沙门果。或无处。欲界修所断结尽。何果摄。答不还阿罗汉果。或无处。色界见所断结尽。何果摄。答四沙门果。或无处。色界修所断结尽。何果摄。答阿罗汉果。或无处。无色界见所断结尽。何果摄。答四沙门果。无色界修所断结尽。何果摄。答阿罗汉果

有五部结。谓见苦所断结。乃至修所断结。见苦所断结尽。何果摄。答四沙门果。或无处。见集所断结尽。何果摄。答四沙门果。或无处。见灭所断结尽。何果摄。答四沙门果。或无处见道所断结尽。何果摄。答四沙门果。修所断结尽。何果摄。答阿罗汉果

有九部结。谓苦法智所断结。乃至修所断结。苦法智所断结尽。何果摄。答四沙门果。或无处。苦类智。乃至道法智所断结尽。何果摄。答四沙门果。或无处。道类智所断结尽。何果摄。答四沙门果。修所断结尽。何果摄。答阿罗汉果

有十五部结。谓三界各有五部。见苦所断结。乃至修所断结。欲界见苦集灭道所断结尽。何果摄。答四沙门果。或无处。欲界修所断结尽。何果摄。答不还阿罗汉果。或无处。色界见苦集灭道所断结尽。何果摄。答四沙门果。或无处。色界修所断结尽。何果摄。答阿罗汉果。或无处。无色界见苦集灭所断结尽。何果摄。答四沙门果。或无处。无色界见道所断结尽。何果摄。答四沙门果。无色界修所断结尽。何果摄。答阿罗汉果

三结乃至九十八随眠。一一尽。何果摄。答三结中。有身见尽。四沙门果摄。或无处。如三结中有身见尽应知。五顺下分结中。有身见。五见中。有身见边执见尽亦尔。戒禁取疑尽。四沙门果摄。如三结中戒禁取疑尽应知。四瀑流轭中。见瀑流轭。四取中。见取戒禁取。四身系中。戒禁取。此实执身系。五顺下分结中。戒禁取疑。五见中。邪见见取戒禁取。七随眠中。见疑随眠。九结中。见取疑结尽亦尔。三不善根尽。不还阿罗汉果摄。或无处。如三不善根尽。应知。三漏中。欲漏。四瀑流轭中。欲瀑流轭。四取中欲取。四身系中。贪欲嗔恚五盖中前四盖。五结中嗔嫉悭结。五顺下分结中。贪欲嗔恚。六爱身中。鼻舌触所生爱身。七随眠中。欲贪嗔恚。九结中。恚嫉悭结尽亦尔。有漏无明漏尽。阿罗汉果摄。如有漏无明漏尽。应知。四瀑流轭中。有无明瀑流轭。四取中。我语取。五结中。贪慢结。五顺上分结中。除色贪余四。六爱身中。意触所生爱身。七随眠中。有贪无明慢。九结中。爱慢无明结尽亦尔。疑盖尽。四沙门果摄。或无处。色贪顺上分结尽。阿罗汉果摄。或无处。如色贪顺上分结尽。应知。眼耳身触所生爱身尽亦尔。九十八随眠中。欲界见苦集灭道所断随眠尽。四沙门果摄。或无处。欲界修所断随眠尽。不还阿罗汉果摄。或无处色界见苦集灭道所断随眠尽。四沙门果摄。或无处。色界修所断随眠尽。阿罗汉果摄。或无处。无色界见苦集灭所断随眠尽。四沙门果摄。或无处。无色界见道所断随眠尽。四沙门果摄。无色界修所断随眠尽。阿罗汉果摄。

预流向中。诸结尽。何果摄。答无处。预流果中。诸结尽。何果摄。答预流果。一来向中。诸结尽。何果摄。答预流果。或无处。一来果中。诸结尽。何果摄。答一来果。不还向中。诸结尽。何果摄。答一来果。或无处。不还果中。诸结尽。何果摄。答不还果。阿罗汉向中。诸结尽。何果摄。答不还果。或无处。阿罗汉果中。诸结尽。何果摄。答阿罗汉果

具见世尊弟子。未离欲染。欲界修所断诸结尽。何果摄。答一来果。或无处。已离欲染。未离色染。色界修所断诸结尽。何果摄。答无处

已离色染。未离无色染。无色修所断诸结尽。何果摄。答无处

诸预流者所成就学法。此法预流果摄耶。答或摄。或不摄。云何摄。答有为预流果。已得不失。云何不摄。答诸预流者。所得胜进无漏根等有为法。设法预流果摄。此是学法耶。答或学。或非学非无学。云何学。答有为预流果。云何非学非无学。答无为预流果。诸一来者。所成就学法。此法一来果摄耶。答或摄。或不摄。云何摄。答有为一来果。已得不失。云何不摄。答诸一来者。所得胜进无漏根等有为法。设法一来果摄。此是学法耶。答或学。或非学非无学。云何学。答有为一来果。云何非学非无学。答无为一来果。诸不还者。所成就学法。此法不还果摄耶。答或摄。或不摄。云何摄。答有为不还果。已得不失。云何不摄。答诸不还者。所得胜进无漏根等有为法。设法不还果摄。此是学法耶。答或学。或非学非无学。云何学。答有为不还果。云何非学非无学。答无为不还果。诸阿罗汉所成就无学法。此法阿罗汉果摄耶。答如是。设法阿罗汉果摄。此是无学法耶。答或无学。或非学非无学。云何无学。答有为阿罗汉果。云何非学非无学。答无为阿罗汉果

诸预流者所成就无漏法。此法预流果摄耶。答或摄。或不摄。云何摄。答有为无为预流果。已得不失。云何不摄。答诸预流者。所得胜进无漏根等有为法。及彼所证诸结尽。并预流者所成就非择灭。设法预流果摄。此是无漏法耶。答如是。诸一来者所成就无漏法。此法一来果摄耶。答或摄。或不摄。云何摄。答有为无为一来果。已得不失。云何不摄。答诸一来者。所得胜进无漏根等有为法。及彼所证诸结尽。并一来者所成就非择灭。设法一来果摄。此是无漏法耶。答如是。诸不还者所成就无漏法。此法不还果摄耶。答或摄。或不摄。云何摄。答有为无。为不还果。已得不失。云何不摄。答诸不还者所得胜进无漏根等有为法。及彼所证诸结尽。并不还者所成就非择灭。设法不还果摄。此是无漏法耶。答如是。诸阿罗汉所成就无漏法。此法阿罗汉果摄耶。答或摄。或不摄。云何摄。答有为无为阿罗汉果。已得不失。云何不摄。答阿罗汉所成就非择灭。设法阿罗汉果摄。此是无漏法耶。答如是

诸法预流者成就。此法预流果摄耶。答应作四句。有法预流者成就非预流果摄。谓预流者所得胜进无漏根等有为法。及彼所证诸结尽。并预流者所成就非择灭有漏法。有法预流果摄非预流者成就。谓预流果未得已失。有法预流者成就亦预流果摄。谓预流果已得不失。有法非预流者成就亦非预流果摄。谓除前相。诸法一来者成就此法。一来果摄耶。答应作四句。有法一来者成就非一来果摄。谓一来者所得胜进无漏根等有为法。及彼所证诸结尽。并一来者所成就非择灭有漏法。有法一来果摄非一来者成就。谓一来果未得已失。有法一来者成就亦一来果摄。谓一来果已得不失。有法非一来者成就亦非一来果摄。谓除前相。诸法不还者成就。此法不还果摄耶。答应作四句。有法不还者成就非不还果摄。谓不还者所得胜进无漏根等有为法。及彼所证诸结尽。并不还者所成就非择灭有漏法。有法不还果摄非不还者成就。谓不还果未得已失。有法不还者成就亦不还果摄。谓不还果已得不失。有法非不还者成就亦非不还果摄。谓除前相。诸法阿罗汉成就。此法阿罗汉果摄耶。答应作四句。有法阿罗汉成就非阿罗汉果摄。谓阿罗汉所成就非择灭有漏法。有法阿罗汉果摄非阿罗汉成就。谓阿罗汉果未得已失。有法阿罗汉成就亦阿罗汉果摄。谓阿罗汉果已得不失。有法非阿罗汉成就亦非阿罗汉果摄。谓除前相

诸在欲界死生者。皆受欲有耶。答应作四句。有在欲界死生非受欲有。谓欲界没。起色界中有。有受欲有非在欲界死生。谓色界没。起欲界中有。有在欲界死生亦受欲有。谓欲界没。起欲界中有生有。有非在欲界死生亦非受欲有。谓色界没。生色无色界。无色界没。生无色色界。诸在色界死生者。皆受色有耶。答应作四句。有在色界死生非受色有。谓色界没。起欲界中有。有受色有非在色界死生。谓欲界没。起色界中有。有在色界死生亦受色有。谓色界没。起色界中有生有。有非在色界死生亦非受色有。谓欲界没。生欲无色界。无色界没。生无色欲界。诸在无色界死生者。皆受无色有耶。答诸在无色界死生者。皆受无色有。有受无色有非在无色界死而在无色界生。谓欲色界没。生无色界。诸在欲界死生者。有几耶。答四。谓欲色界异生圣者。诸在色界死生者。有几耶。答三。谓欲界异生。色界异生圣者。诸在无色界死生者。有几耶。答二。谓无色界异生圣者

诸非在欲界死生者。皆非受欲有耶。答应作四句。有非在欲界死生非不受欲有。谓色界没。起欲界中有。有非受欲有非不在欲界死生。谓欲界没。起色界中有。有非在欲界死生亦非受欲有。谓色界没。生色无色界。无色界没。生无。色界。有非不在欲界死生亦非不受欲有。谓欲界没。起欲界中有生有。诸非在色界死生者。皆非受色有耶。答应作四句。有非在色界死生非不受色有。谓欲界没。起色界中有。有非受色有非不在色界死生。谓色界没。起欲界中有。有非在色界死生亦非受色有。谓欲界没。生欲无色界。无色界没。生无色欲界。有非不在色界死生亦非不受色有。谓色界没。起色界中　　有生有。诸非在无色界死生者。皆非受无色有耶。答诸非在无色界死生者。皆非受无色有。有非受无色有非不在无色界死而非在无色界生。谓无色界没。生欲色界。诸非在欲界死生者。有几耶。答五。谓欲界异生。色无色界异生圣者。诸非在色界死生者。有几耶。答六。谓三界异生圣者。诸非在无色界死生者。有几耶。答四。谓欲色界异生圣者

颇有欲界死不生欲界耶。答有。谓起欲色界中有。生无色界。或般涅槃。颇有欲界死不生色界耶。答有。谓起欲色界中有。生无色界。或般涅槃。颇有欲界死不生无色界耶。答有。谓起欲色界中有。或般涅槃。颇有色界死不生色界耶。答有。谓起欲色界中有。生无色界。或般涅槃。颇有色界死不生欲界耶。答有。谓起欲色界中有。生无色界。或般涅槃。颇有色界死不生无色界耶。答有。谓起欲色界中有。或般涅槃。颇有无色界死不生无色界耶。答有。谓起欲色界中有。或般涅槃。颇有无色界死不生欲界耶。答有。谓起欲色界中有。生无色界。或般涅槃。颇有无色界死不生色界耶。答有。谓起欲色界中有。生无色界。或般涅槃。诸欲界死不生欲界者。有几耶。答六。谓三界异生圣者。诸欲界死不生色界者。有几耶。答六。谓三界异生圣者。诸欲界死不生无色界者。有几耶。答四。谓欲色界异生圣者。诸色界死不生色界者。有几耶。答五。谓欲界异生。色无色界异生圣者。诸色界死不生欲界者。有几耶。答五。谓欲界异生。色无色界异生圣者。诸色界死不生无色界者。有几耶。答三。谓欲界异生。色界异生圣者。诸无色界死不生无色界者。有几耶。答二。谓欲色界异生。诸无色界死不生欲界者。有几耶。答四。谓无色界异生圣者。欲色界异生。诸无色界死不生色界者。有几耶。答四。谓无色界异生圣者。欲色界异生

颇有欲界死不生三界耶。答有。谓起欲色界中有。或般涅槃。颇有色界死不生三界耶。答有。谓起欲色界中有。或般涅槃。颇有无色界死不生三界耶。答有。谓起欲色界中有。或般涅槃。诸欲界死不生三界者。有几耶。答四。谓欲色界异生圣者。诸色界死不生三界者。有几耶。答三。谓欲界异生。色界异生圣者。诸无色界死不生三界者。有几耶。答二。谓欲色界异生

颇有未离欲染命终不生欲界耶。答有。谓起欲界中有。颇有未离色染命终不生欲色界耶。答有。谓起欲色中有。颇有未离无色染命终不生三界耶。答有。谓起欲色界中有。诸未离欲染命终不生欲界者。有几耶。答二。谓欲界异生圣者。诸未离色染命终不生欲色界者。有几耶。答四。谓欲色界异生圣者。诸未离无色染命终不生三界者。有几耶。答四。谓欲色界异生圣者。此中欲界异生圣者。几随眠随增。几结系耶。答异生九十八随眠随增。九结系。圣者十随眠随增。六结系。色界异生圣者。几随眠随增。几结系耶。答异生六十二随眠随增。六结系。圣者六随眠随增。三结系。无色界异生圣者。几随眠随增。几结系耶。答异生三十一随眠随增。六结系。圣者三随眠随增。三结系

    结蕴第二中十门纳息第四之一

  四十二随增　　二缘无间有
  根成不知证　　此章愿具说

二十二根。十八界。十二处。五蕴。五取蕴。六界。有色无色法。有见无见法。有对无对法。有漏无漏法。有为无为法。过去未来现在法。善不善无记法。欲界色界无色界系法。学无学非学非无学法。见所断修所断无断法。四谛。四静虑。四无量。四无色。八解脱。八胜处。十遍处。八智。三三摩地。三重三摩地。三结。三不善根。三漏。四瀑流。四轭。四取。四身系。五盖。五结。五顺下分结。五顺上分结。五见。六爱身。七随眠。九结。九十八随眠

眼根。乃至无色界修所断无明随眠。于九十八随眠中。一一有几随眠随增耶。答眼根欲色界遍行。及修所断随眠随增。耳鼻舌身根亦尔。女根欲界遍行。及修所断随眠随增。男苦根亦尔。命根三界遍行。及修所断随眠随增。信等五根亦尔。意根一切随眠随增。舍根亦尔。乐根色界一切欲界遍行。及修所断随眠随增。喜根色界一切欲界。除无漏缘疑。及彼相应无明。余一切随眠随增。忧根欲界一切随眠随增。三无漏根。无随眠随增。眼耳鼻舌身色声触眼耳身识界。欲色界遍行。及修所断随眠随增。眼耳鼻舌身色声触处。色蕴色取蕴前五界。有色有见有对法亦尔。香味鼻舌识界。欲界遍行。及修所断随眠随增。香味处亦尔。意法意识界。一切随眠随增。意法处后四蕴后四取蕴识界。无色无见无对有漏有为法过去未来现在非学非无学法亦尔。无漏无为法。无随眠随增。学无学无断法亦尔。善及修所断法。三界遍行。及修所断随眠随增不善及欲界系法。欲界一切随眠随增。无记法。色无色界一切。欲界二部。及见集所断遍行。随眠随增。色界系法。色界一切随眠随增。无色界系法。无色界一切随眠随增。见所断法。见所断一切随眠随增。苦集谛一切随眠随增。灭道谛无随眠随增。法类苦集灭道智三三摩地亦尔。四静虑色界。一切随眠随增。四无量色界遍行。及修所断随眠随增。前三解脱。八胜处。前八遍处。他心智亦尔。四无色无色界。一切随眠随增。后五解脱。后二遍处。无色界遍行。及修所断随眠随增。世俗智。除无漏缘见。余一切随眠随增。三重三摩地。三界遍行。及修所断随眠随增。有身见结。见苦所断一切。及见集所断遍行。随眠随增。有身见顺下分结。有身见边执见亦尔。戒禁取结见苦所断一切。及见集所断遍行。见道所断有漏缘。随眠随增戒禁取。及戒禁取。身系顺下分结。戒禁取亦尔。疑结见所断有漏缘。及疑相应无漏缘无明。随眠随增。疑顺下分结。疑随眠疑结亦尔。贪嗔不善根。欲界有漏缘。随眠随增。前二身系。前二盖嗔结。前二顺下分结。前二随眠恚结亦尔。痴不善根欲界除无漏缘无明。余一切随眠随增。欲漏欲界一切随眠随增。欲瀑流轭。取惛沉睡眠掉举盖亦尔。有漏色无色界一切随眠随增。有瀑流轭我语取亦尔。无明漏除无漏缘无明。余一切随眠随增。无明瀑流轭。无明随眠无明结亦尔。见瀑流轭。见所断有漏缘。及见相应无漏缘无明。随眠随增。见取邪见见随眠见结亦尔。此实执身系。见所断有漏缘。随眠随增。见取取结亦尔。恶作盖欲界遍行。及修所断随眠随增。嫉悭结。鼻舌触所生爱身嫉悭结亦尔。疑盖欲界见所断有漏缘。及疑相应无漏缘无明。随眠随增。贪慢结三界有漏缘。随眠随增。意触所生爱身慢随眠爱慢结亦尔

色贪色界遍行。及修所断随眠随增。无色贪无色界遍行。及修所断随眠随增。后三顺上分结。色无色界遍行。及修所断随眠随增。眼耳身触所生爱身欲色界遍行。及修所断随眠随增。有贪随眠。色无色界有漏缘随眠随增。欲界见苦所断随眠。欲界见苦所断一切。及见集所断遍行。随眠随增。欲界见集所断随眠。欲界见集所断一切。及见苦所断遍行。随眠随增。欲界见灭所断随眠。欲界见灭所断除无漏缘。不共无明。余一切。及遍行。随眠随增。欲界见道所断随眠。欲界见道所断。除无漏缘。不共无明。余一切及遍行。随眠随增。欲界修所断随眠。欲界修所断一切。及遍行。随眠随增。色无色界五部随眠。广说亦尔。差别者。应说自界

眼根。乃至无色界修所断无明随眠缘识。及缘缘识。于九十八随眠中。一一有几随眠随增耶。答眼根缘识。欲色界三部。无色界遍行。及修所断缘缘识。三界四部。耳鼻舌身根亦尔。女根缘识。欲界三部。色界遍行。及修所断缘缘识。欲界四部。色界三部。无色界遍行。及修所断。男苦根亦尔。命根缘识。三界三部。缘缘识。三界四部。意根缘识。缘缘识。有为缘。舍根亦尔。乐根缘识。欲界四部。色界有为缘。无色界二部。及遍行。缘缘识。欲无色界四部。色界有为缘。喜根缘识。欲色界有为缘。无色界二部。及遍行。缘缘识。欲色界有为缘。无色界四部。忧根缘识。欲界有漏缘。色界遍行。及修所断。缘缘识。欲界有为缘。色界三部。无色界遍行。及修所断。信等五根。缘识缘缘识。三界四部。三无漏根缘识。三界二部。及遍行。缘缘识。三界四部。眼耳鼻舌身色声触界缘识。欲色界三部。无色界遍行。及修所断缘缘识。三界四部。眼耳鼻舌身色声触处。色取蕴。前五界。有见有对法亦尔。香味鼻舌识界缘识。欲界三部。色界遍行。及修所断。缘缘识。欲界四部。色界三部。无色界遍行。及修所断。香味处亦尔。眼耳身识界缘识。欲色界三部。缘缘识欲色界四部。无色界二部。及遍行意界意识界。缘识缘缘识。有为缘意处。后四蕴有为法。过去未来现在法亦尔。法界缘识。三界一切缘缘识。有为缘法处。无色无见无对善法亦尔。色蕴缘识。欲色界四部。无色界二部。及遍行。缘缘识三界四部。有色法亦尔。后四取蕴。缘识有漏缘缘识。有为缘识界。有漏法。见所断法亦尔。无漏法缘识。三界三部。及遍行。缘缘识。有为缘。无断法亦尔。无为法缘识。三界二部。及遍行缘缘识。有为缘。不善法缘识。欲界有漏缘色界遍行。及修所断缘缘识。欲界有为缘。色界三部。无色界遍行。及修所断。欲界系法亦尔。无记法缘识。欲界三部色无色界有漏缘缘缘识。欲界四部。色无色界有为缘。色界系法缘识。欲界三部。色界有漏缘。无色界遍行。及修所断缘缘识。欲界三部。色界有为缘。无色界四部。无色界系法缘识。欲色界三部。无色界有漏缘。缘缘识。欲界三部。色界四部。无色界有为缘。学无学法缘识。三界二部。及遍行。缘缘识。三界四部。非学非无学法缘识。三界四部。及见道所断有漏缘缘缘识。有为缘。修所断法缘识。三界三部缘缘识。三界四部。苦集谛缘识。有漏缘缘缘识。有为缘。世俗智亦尔。灭谛缘识。三界二部。及遍行。缘缘识。有为缘。道谛缘识。三界二部。及遍行缘缘识。三界四部。苦集灭道智。及三三摩地亦尔。四静虑缘识。欲界四部。色界有为缘。无色界二部。及遍行缘缘识。欲无色界四部。色界有为缘。慈悲舍无量缘识。欲色界三部。无色界遍行。及修所断缘缘识。欲界三部。色无色界四部。净解脱。后四胜处。前八遍处亦尔。喜无量缘识。欲色界三部。缘缘识。欲界三部。色界四部。无色界二部。及遍行。初二解脱。前四胜处亦尔。前三无色缘识缘缘识。欲界三部。色界四部。无色界有为缘。非想非非想处缘识。欲色界三部。无色界有漏缘缘缘识。欲界三部。色界四部。无色界有为缘空。识无边处无所有处解脱缘识缘缘识。欲界三部。色无色界四部。后二解脱。及后二遍处缘识。三界三部缘缘识。欲界三部。色无色界四部。法智缘识。欲界二部。及遍行。色界遍行。及修所断缘缘识。欲界四部。色界三部。无色界遍行。及修所断类智缘识。色无色界二部。及遍行。欲界遍行。及修所断缘缘识。欲界三部。色无色界四部。他心智缘识。欲色界四部。无色界二部。及遍行缘缘识。三界四部。三重三摩地缘识。三界三部缘缘识。三界四部。有身见结缘识。三界三部缘缘识。三界四部有身见。顺下分结。有身见边执见亦尔。戒禁取结缘识。三界三部。及见道所断。有漏缘缘缘识。三界四部。戒禁取。及戒禁取身系。戒禁取。顺下分结。戒禁取亦尔。疑结缘识。有漏缘缘缘识。有为缘。无明漏瀑流轭见取此实执身系。贪慢结疑。顺下分结。邪见见取意触所生爱身慢无明见疑随眠爱慢无明见取疑结亦尔。三不善根。及欲漏缘识欲界有漏缘。色界遍行及修所断缘缘识。欲界有为缘。色界三部。无色界遍行。及修所断欲瀑流轭取前二身系除恶作余盖嗔结。前二顺下分结。欲贪嗔恚随眠恚结亦尔。有漏缘识欲界三部。色无色界有漏缘缘缘识。欲界三部。色无色界有为缘有瀑流轭我语取有贪随眠亦尔。恶作盖缘识欲界三部。色界遍行及修所断缘缘识欲界四部。色界三部。无色界遍行及修所断嫉悭结鼻舌触所生爱身嫉悭结亦尔。色贪顺上分结缘识。欲色界三部。无色界遍行及修所断缘缘识。欲界三部。色无色界四部。后四顺上分结缘识。三界三部。缘缘识。欲界三部。色无色界四部。眼耳身触所生爱身缘识。欲色界三部。缘缘识。欲色界四部。无色界遍行及修所断。欲界见苦集及修所断随眠缘识。欲界三部。色界遍行及修所断缘缘识。欲界四部。色界三部。无色界遍行及修所断。欲界见灭所断随眠缘识。欲界三部。及见灭所断有漏缘。色界遍行及修所断缘缘识。欲界有为缘。色界三部。无色界遍行及修所断。欲界见道所断随眠缘识。欲界三部。及见道所断有漏缘。色界遍行及修所断缘缘识。欲界四部。色界三部。无色界遍行。及修所断。色界见苦集及修所断随眠缘识。欲色界三部。无色界遍行及修所断缘缘识。欲界三部。色无色界四部。色界见灭所断随眠缘识。欲色界三部。及色界见灭所断有漏缘。无色界遍行及修所断缘缘识。欲界三部。色界有为缘。无色界四部。色界见道所断随眠缘识。欲色界三部。及色界见道所断有漏缘。无色界遍行及修所断缘缘识。欲界三部。色无色界四部。无色界见苦集及修所断随眠缘识。三界三部。缘缘识。欲界三部。色无色界四部。无色界见灭所断随眠缘识。三界三部。及无色界见灭所断有漏缘缘缘识。欲界三部。色界四部。无色界有为缘。无色界见道所断随眠缘识。三界三部。及无色界。见道所断有漏缘缘。缘识欲界三部。色无色界四部

说一切有部发智论卷第五阿毗达磨发智论卷第六

        尊者迦多衍尼子造

        三藏法师玄奘奉　诏译

    结蕴第二中十门纳息第四之二

意根乃至无色界修所断。无明随眠。于三界十五部心中。一一等无间。生几心耶。答意根等无间生十五心。舍及信等五根亦尔。乐根等无间。生十一心。苦根等无间。生五心。忧根亦尔。喜根等无间。生十心。未知当知根等无间。不生心。已知具知根等无间。生三心。眼耳身识界等无间。生十心。鼻舌识界等无间。生五心。不善法亦尔。意法意识界等无间。生十五心。意法处。后四蕴。后四取蕴。识界无色。无见无对。有漏有为法。现在善无记。三界系非学非无学。见修所断法亦尔。无漏法等无间。生三心。学无学无断法亦尔。过去法等无间。生二心。未来法不生心。苦集谛等无间。生十五心。四静虑。四无色。世俗智亦尔。道谛等无间。生三心。类苦集灭道智。三三摩地亦尔。四无量等无间。生六心。第一第二第四第五解脱。前四胜处。他心智亦尔。第三第六第七解脱等无间。生五心。后四胜处。十遍处亦尔。第八解脱。不生心。法智等无间。生二心。三结等无间。生十五心。有无明漏。有见无明瀑流轭。后三取。后二身系。贪慢结。后三顺下分结。后四顺上分结。五见。意触所生爱身。后五随眠。爱等六结亦尔。三不善根。及欲漏等无间。生五心。欲瀑流轭。取前二。身系五盖嗔嫉悭结。前二顺下分结。鼻舌触所生爱身。欲贪嗔恚随眠恚嫉悭结亦尔。色无色贪顺上分结等无间。生十心。后四顺上分结等无间。生三心。眼耳身触所生爱身亦尔。欲界三十六随眠等无间。生五心。色界三十一随眠等无间。生十心。无色界三十一随眠等无间。生十五心

眼根乃至无色界修所断。无明随眠。一一所增随眠。当言有寻有伺无寻唯伺无寻无伺耶。答应言眼根所增随眠具三。耳鼻舌身命意乐喜信等五根所增随眠亦尔。女根所增随眠。有寻有伺。男苦忧根所增随眠亦尔。眼耳鼻舌身色声触意法意识界所增随眠具三。眼耳鼻舌身色声触意法处五蕴五取蕴六界有色无色有见无见有对无对有漏有为法。过去未来现在善无记色界系非学非无学见修所断法所增随眠亦尔。香味鼻舌识界所增随眠。有寻有伺。香味处不善欲界系法所增随眠亦尔。眼耳身识界所增随眠。或有寻有伺。或无寻唯伺。无色界系法所增随眠。无寻无伺。苦集谛所增随眠具三。四无量初二解脱前四胜处他心世俗智三重三摩地所增随眠亦尔。初静虑所增随眠。或有寻有伺。或无寻唯伺。后三静虑所增随眠。无寻无伺。四无色后六解脱后四胜处十遍处所增随眠亦尔。三结所增随眠具三。有无明漏后三瀑流轭取后二身系贪慢结后三顺下分结除无色贪余四顺上分结五见第六爱身后五随眠爱等六结所增随眠亦尔。三不善根所增随眠。有寻有伺。欲漏瀑流轭取前二身系五盖嗔嫉悭结前二顺下分结鼻舌触所生爱。身初二随眠恚嫉悭结所增随眠亦尔。无色贪所增随眠。无寻无伺。眼耳身触所生爱身所增随眠。或有寻有伺。或无寻唯伺。欲界三十六随眠所增随眠。有寻有伺。色界三十一随眠所增随眠具三。无色界三十一随眠所增随眠。无寻无伺

眼根乃至无色界修所断无明随眠。一一所增随眠。当言乐根苦根喜根忧根舍根相应耶。答应言眼根所增随眠四根相应。除苦根。耳鼻舌身命乐舍信等五根所增随眠亦尔。女根所增随眠。三根相应。除乐苦根。男喜忧根所增随眠亦尔。意根所增随眠。五根相应苦根所增随眠。四根相应。除乐根。眼耳鼻舌身及意识界所增随眠。四根相应。除苦根。眼耳鼻舌身处见所断法所增随眠亦尔。色声香味触眼耳鼻舌身识意法界所增随眠。五根相应。色声香味触意法处五蕴五取蕴六界有色无色有见无见有对无对有漏有为法过去未来现在善不善无记欲界系非学非无学修所断法所增随眠亦尔。色界系法所增随眠。三根相应。除苦忧根。无色界系法所增随眠舍根相应。苦集谛所增随眠。五根相应。世俗智所增随眠亦尔。初静虑所增随眠。三根相应。除苦忧根。慈悲舍无量他心智所增随眠亦尔。第二静虑所增随眠。喜舍根相应。喜无量初二解脱前四胜处所增随眠亦尔。第三静虑所增随眠。乐舍根相应。第四静虑所增随眠。舍根相应。四无色后六解脱后四胜处十遍处所增随眠亦尔。三重三摩地所增随眠。四根相应。除苦根。三结所增随眠。四根相应。除苦根。贪不善根见瀑流轭取戒禁取贪欲戒禁取此实执身系。贪欲盖贪慢结贪欲有身见戒禁取疑。顺下分结五见六爱身欲贪慢见疑随眠爱慢见取疑结所增随眠亦尔。嗔不善根所增随眠。四根相应。除乐根。嗔恚身系嗔恚盖嗔恚结嗔恚顺下分结嗔恚随眠恚结所增随眠亦尔。痴不善根所增随眠。五根相应。欲无明漏瀑流轭欲取惛沉掉举盖无明随眠结所增随眠亦尔。有漏所增随眠。三根相应。除苦忧根。有瀑流轭我语取色贪掉举慢无明顺上分结有贪随眠所增随眠亦尔。睡眠恶作疑盖所增随眠。三根相应。除乐苦根。嫉悭结及九结中嫉悭结所增随眠亦尔。无色贪所增随眠。舍根相应。欲界见所断一切及修所断慢随眠所增随眠。三根相应。除乐苦根。欲界修所断贪随眠所增随眠。四根相应。除苦根。欲界修所断嗔随眠所增随眠。四根相应。除乐根。欲界修所断无明随眠所增随眠。五根相应。色界三十一随眠所增。随眠三根相应。除苦忧根。无色界三十一随眠所增随眠。舍根相应。眼根乃至无色界修所断。无明随眠。谁成就。谁不成就。答眼根色界及欲界。已得不失成就。无色界及欲界未得已失不成就。耳鼻舌根亦尔。身根欲色界成就无色界不成就。女男根欲界已得不失成就。色无色界及欲界未得已失不成就。命意舍根一切有情皆成就。乐根遍净以下。及圣者生上成就。异生生上不成就。苦根欲界成就。色无色界不成就。喜根极光净以下。及圣者生上成就。异生生上不成就。忧根未离欲染成就。已离欲染不成就。信等五根。不断善根成就。已断善根不成就。三无漏根。已得不失成就。未得已失不成就。眼耳鼻舌界。色界及欲界已得不失成就。无色界及欲界未得已失不成就。眼耳鼻舌处亦尔。身色声触界。欲色界成就。无色界不成就。身色声触处色取蕴前五界有见有对法欲色界系法亦尔。香味鼻舌识界。欲界成就。色无色界不成就。香味处亦尔。眼耳身识界。梵世以下及生上三静虑现在前成就。不现在前及无色界不成就。意法意识界。一切有情皆成就。意法处后四蕴四取蕴识界。无色无见无对有漏。无漏有为无为法过去未来现在无记无色界系非学非无学修所断无断法亦尔。色蕴欲色界及无色界圣者成就。无色界异生不成就。有色法亦尔。善法不断善根成就。已断善根不成就。不善法未离欲染成就。已离欲染不成就。学无学法已得不失成就。未得已失不成就。见所断法道类智未已生成就。已生不成就。苦集谛一切有情皆成就。非想非非想处世俗智亦尔。灭谛已得不失成就。未得已失不成就。四无量八解脱八胜处十遍处他心智亦尔。道谛已得成就。未得不成就。法类苦集灭道智三三摩地三重三摩地亦尔。初静虑梵世以下及圣者生上成就。异生生上不成就。第二静虑极光净以下。及圣者生上成就。异生生上不成就。第三静虑遍净以下。及圣者生上成就。异生生上不成就。第四静虑广果以下。及圣者生上成就。异生生上不成就。空无边处空无边处以下。及圣者生上成就。异生生上不成就。识无边处识无边处以下。及圣者生上成就。异生生上不成就。无所有处无所有处以下。及圣者生上成就。异生生上不成就。有身见结苦类智未已生成就。已生不成就。有身见顺下分结有身见边执见亦尔。戒禁取疑结道类智未已生成就。已生不成就。见瀑流轭取戒禁取后二身系戒禁取疑顺下分结后三见见疑随眠见取疑结亦尔。三不善根未离欲染成就。已离欲染不成就。欲漏瀑流轭取前二身系前四盖嗔嫉悭结前二顺下分结鼻舌触所生爱身欲贪嗔恚随眠恚嫉悭结亦尔。有无明漏未离无色染成就。已离无色染不成就。有无明瀑流轭我语取贪慢结后四顺上分结意触所生爱身有贪慢无明随眠爱慢无明结亦尔。疑盖未离欲染异生及未离欲染圣者道法智未已生成就。已离欲染异生圣者及未离欲染圣者道法智已生不成就。色贪顺上分结未离色染成就。已离色染不成就。眼耳身触所生爱身未离梵世染成就。已离梵世染不成就。欲界见苦所断随眠未离欲染异生。及未离欲染圣者苦法智未已生成就。已离欲染异生圣者。及未离欲染圣者苦法智已生不成就。欲界见集所断随眠未离欲染异生。及未离欲染圣者集法智未已生成就。已离欲染异生圣者。及未离欲染圣者集法智已生不成就。欲界见灭所断随眠未离欲染异生。及未离欲染圣者灭法智未已生成就。已离欲染异生圣者。及未离欲染圣者灭法智已生不成就。欲界见道所断随眠未离欲染异生。及未离欲染圣者道法智未已生成就。已离欲染异生圣者。及未离欲染圣者道法智已生不成就。欲界修所断随眠未离欲染成就。已离欲染不成就。色界见苦所断随眠未离色染异生。及未离色染圣者苦类智未已生成就。已离色染异生圣者。及未离色染圣者苦类智已生不成就。色界见集所断随眠未离色染异生。及未离色染圣者集类智未已生成就。已离色染异生圣者。及未离色染圣者集类智已生不成就。色界见灭所断随眠未离色染异生。及未离色染圣者灭类智未已生成就。已离色染异生圣者。及未离色染圣者。灭类智已生不成就。色界见道所断随眠未离色染异生。及未离色染圣者道类智未已生成就。已离色染异生圣者。及未离色染圣者道类智已生不成就。色界修所断随眠未离色染成就。已离色染不成就。无色界见苦所断随眠苦类智未已生成就。已生不成就。无色界见集所断随眠集类智未已生成就。已生不成就。无色界见灭所断随眠灭类智未已生成就。已生不成就。无色界见道所断随眠道类智未已生成就。已生不成就。无色界修所断随眠未离无色染成就。已离无色染不成就

眼根乃至无色界修所断无明随眠。一一得遍知时。于九十八随眠中。几随眠得遍知。于九结中。几结尽。答眼根得遍知时色爱尽。异生三十一随眠。得遍知无结尽。圣者三随眠得遍知无结尽。耳鼻舌身根亦尔。女男根得遍知时欲爱尽。异生三十六随眠得遍知三结尽。圣者四随眠得遍知三结尽。苦忧根亦尔。命根得遍知时。无色爱尽。三随眠得遍知三结尽。意舍信等根亦尔。乐根得遍知时。遍净爱尽。即乐根得遍知无结尽。喜根得遍知时。极光净爱尽。即喜根得遍知无结尽。眼耳鼻舌身色声触界。得遍知时。色爱尽。异生三十一随眠。得遍知无结尽。圣者三随眠。得遍知无结尽。眼耳鼻舌身色声触处色蕴色取蕴前五界有色有见有对法色界系法亦尔。香味鼻舌识界。得遍知时。欲爱尽。异生三十六随眠。得遍知三结尽。圣者四随眠。得遍知三结尽。香味处不善欲界系法亦尔。眼耳身识界。得遍知时。梵世爱尽。即眼耳身识界。得遍知无结尽。意法意识界。得遍知时。无色爱尽。三随眠得遍知三结尽。意法处后四蕴四取蕴识界无色无见无对有漏有为法过去未来现在善无记无色界系非学非无学修所断法亦尔。见所断法。得遍知时。未离色爱者。道类智现在前十四随眠。得遍知三结尽。已离色爱者道类智现在前七随眠。得遍知三结尽。苦集谛得遍知时。无色爱尽。三随眠得遍知三结尽。非想非非想处后二解脱世俗智三重三摩地亦尔。初静虑得遍知时。梵世爱尽。即初寂虑得遍知无结尽。第二静虑得遍知时。极光净爱尽。即第二静虑得遍知无结尽。喜无量初解脱前四胜处亦尔。第三静虑得遍知时。遍净爱尽。即第三静虑得遍知无结尽。第四静虑得遍知时。色爱尽。异生三十一随眠。得遍知无结尽。圣者三随眠。得遍知无结尽。三无量净解脱后四胜处前八遍处他心智亦尔。空无边处得遍知时。空无边处爱尽。即空无边处。得遍知无结尽。空无边处解脱遍处亦尔。识无边处。得遍知时。识无边处爱尽。即识无边处。得遍知无结尽。识无边处解脱遍处亦尔。无所有处。得遍知时。无所有处爱尽。即无所有处。得遍知无结尽。无所有处解脱亦尔。有身见结。得遍知时。苦类智现在前未离色染者。十八随眠。得遍知无结尽。已离色染者九随眠。得遍知无结尽。有身见顺下分结有身见边执见亦尔。戒禁取疑结得遍知时。道类智现在前。未离色染者。十四随眠。得遍知三结尽。已离色染者七随眠。得遍知三结尽。见瀑流轭取戒禁取后二身系后二顺下分结后三见见疑随眠见取疑结亦尔。三不善根及欲漏得遍知时。欲爱尽。异生三十六随眠。得遍知三结尽。圣者四随眠得遍知三结尽。欲瀑流轭取前二身系前四盖嗔嫉悭结前二顺下分结鼻舌触所生爱身欲贪嗔恚随眠恚嫉悭结亦尔。有漏无明漏。得遍知时。无色爱尽。三随眠得遍知三结尽。有无明瀑流轭我语取贪慢结后四顺上分结意触所生爱身有贪慢无明随眠爱慢无明结亦尔。疑盖得遍知时异生欲爱尽。三十六随眠。得遍知三结尽。圣者道法智现在前八随眠。得遍知无结尽。色贪得遍知时。色爱尽。异生三十一随眠。得遍知无结尽。圣者三随眠。得遍知无结尽。眼耳身触所生爱身。得遍知时。梵世爱尽。即三爱身。得遍知无结尽。欲界见苦所断随眠。得遍知时。异生欲爱尽。三十六随眠。得遍知三结尽。圣者苦法智现在前十随眠。得遍知无结尽。欲界见集所断随眠。得遍知时。异生欲爱尽。三十六随眠。得遍知三结尽。圣者集法智现在前七随眠。得遍知无结尽。欲界见灭所断随眠。得遍知时。异生欲爱尽。三十六随眠。得遍知三结尽。圣者灭法智现在前七随眠。得遍知无结尽。欲界见道所断随眠。得遍知时。异生欲爱尽。三十六随眠。得遍知三结尽。圣者道法智现在前八随眠。得遍知无结尽。欲界修所断随眠。得遍知时。欲爱尽。异生三十六随眠。得遍知三结尽。圣者四随眠。得遍知三结尽。色界见苦所断随眠。得遍知时。异生色爱尽。三十一随眠。得遍知无结尽。圣者苦类智现在前十八随眠。得遍知无结尽。色界见集所断随眠。得遍知时。异生色爱尽。三十一随眠。得遍知无结尽。圣者集类智现在前十二随眠。得遍知无结尽。色界见灭。所断随眠。得遍知时。异生色爱尽。三十一随眠。得遍知无结尽。圣者灭类智现在前十二随眠。得遍知无结尽。色界见道所断随眠。得遍知时。异生色爱尽。三十一随眠。得遍知无结尽。圣者道类智现在前十四随眠。得遍知三结尽。色界修所断随眠。得遍知时。色爱尽。异生三十一随眠。得遍知无结尽。圣者三随眠。得遍知无结尽。无色界见苦所断随眠。得遍知时。苦类智现在前。未离色染者十八随眠。得遍知无结尽。已离色染者九随眠。得遍知无结尽。无色界见集所断随眠。得遍知时。集类智现在前。未离色染者十二随眠。得遍知无结尽。已离色染者六随眠。得遍知无结尽。无色界见灭所断随眠。得遍知时。灭类智现在前。未离色染者十二随眠。得遍知无结尽。已离色染者六随眠。得遍知无结尽。无色界见道所断随眠。得遍知时。道类智现在前。未离色染者十四随眠。得遍知三结尽。已离色染者七随眠。得遍知三结尽。无色界修所断随眠。得遍知时。无色爱尽。三随眠得遍知三结尽

眼根乃至无色界修所断无明随眠。一一灭作证时。于九十八随眠中。几随眠灭作证。于九结中几结尽。答眼根灭作证时。色爱尽。异生三十一随眠。灭作证无结尽。圣者三随眠。灭作证无结尽。至阿罗汉九十八随眠。灭作证九结尽。耳鼻舌身根亦尔。女男根灭作证时。欲爱尽。异生三十六随眠。灭作证三结尽。圣者得不还果九十二随眠。灭作证六结尽至阿罗汉九十八随眠。灭作证九结尽。苦忧根亦尔。命根灭作证时。得阿罗汉果。九十八随眠。灭作证九结尽意舍信等五根亦尔。乐根灭作证时。遍净爱尽即乐根灭作证无结尽。至阿罗汉。九十八随眠。灭作证九结尽。喜根灭作证时。极光净爱尽。即喜根灭作证无结尽。至阿罗汉果九十八随眠。灭作证九结尽。眼耳鼻舌身色声触界。灭作证时。色爱尽。异生三十一随眠。灭作证无结尽。圣者三随眠。灭作证无结尽。至阿罗汉九十八随眠。灭作证九结尽。眼耳鼻舌身色声触处色蕴色取蕴前五界有色有见有对法色界系法亦尔。香味鼻舌识界。灭作证时。欲爱尽。异生三十六随眠。灭作证三结尽。圣者得不还果。九十二随眠。灭作证六结尽。至阿罗汉。九十八随眠。灭作证九结尽。香味处不善欲界系法亦尔。眼耳身识界。灭作证时。梵世爱尽。即三识界。灭作证无结尽。至阿罗汉。九十八随眠。灭作证九结尽。意法意识界。灭作证时。得阿罗汉果。九十八随眠。灭作证九结尽。意法处后四蕴四取蕴识界无色无见无对。有漏有为法过去未来现在善无记无色界系非学非无学修所断法亦尔。见所断法。灭作证时。得预流果。八十八随眠。灭作证三结尽。至一来果亦尔。至不还果。九十二随眠。灭作证六结尽。至阿罗汉。九十八随眠。灭作证九结尽。苦集谛灭作证时。得阿罗汉果。九十八随眠。灭作证九结尽。非想非非想处。后二解脱世俗智三重三摩地亦尔。初静虑灭作证时。梵世爱尽。即初静虑。灭作证无结尽。至阿罗汉。九十八随眠。灭作证九结尽。第二静虑灭作证时。极光净爱尽。即第二静虑灭作证无结尽。至阿罗汉。九十八随眠。灭作证九结尽。喜无量初二解脱前四胜处亦尔。第三静虑。灭作证时。遍净爱尽。即第三静虑。灭作证无结尽。至阿罗汉。九十八随眠。灭作证九结尽。第四静虑。灭作证时。色爱尽。异生三十一随眠。灭作证无结尽。圣者三随眠。灭作证无结尽。至阿罗汉。九十八随眠。灭作证九结尽。三无量净解脱后四胜处前八遍处他心智亦尔。空无边处。灭作证时。空无边处爱尽。即彼灭作证无结尽。至阿罗汉。九十八随眠。灭作证九结尽。空无边处解脱遍处亦尔。识无边处。灭作证时。识无边处爱尽。即彼灭作证无结尽。至阿罗汉。九十八随眠。灭作证九结尽。识无边处解脱遍处亦尔。无所有处灭作证时。无所有处爱尽。即彼灭作证无结尽。至阿罗汉。九十八随眠。灭作证九结尽。无所有处解脱亦尔。有身见结。灭作证时。苦类智现在前。十八随眠。灭作证无结尽。至预流果。八十八随眠。灭作证三结尽。至一来果亦尔。至不还果。九十二随眠。灭作证六结尽。至阿罗汉。九十八随眠。灭作证九结尽。有身见顺下分结有身见边执见亦尔。戒禁取疑结。灭作证时。得预流果。八十八随眠。灭作证三结尽。至一来果亦尔至不还果时。九十二随眠。灭作证六结尽。至阿罗汉。九十八随眠。灭作证九结尽。见瀑流轭取戒禁取后二身系戒禁取疑顺下分结后三见见疑随眠见取疑结亦尔。三不善根及欲漏。灭作证时。异生欲爱尽。三十六随眠。灭作证三结尽。圣者得不还果。九十二随眠。灭作证六结尽。至阿罗汉。九十八随眠。灭作证九结尽欲瀑流轭取前二身系前四盖嗔嫉悭结前二顺下分结鼻舌触所生爱身欲贪嗔恚随眠恚嫉悭结亦尔。有漏无明漏。灭作证时。得阿罗汉果。九十八随眠。灭作证九结尽。有无明瀑流轭我语取贪慢结后四顺上分结意触所生爱身有贪慢无明随眠爱慢无明结亦尔疑盖。灭作证时。异生欲爱尽。三十六随眠。灭作证三结尽。圣者道法智现在前八随眠。灭作证无结尽。至预流果。八十八随眠。灭作证三结尽。至一来果亦尔。至不还果。九十二随眠。灭作证六结尽。至阿罗汉。九十八随眠。灭作证九结尽。色贪。灭作证时。色爱尽。异生三十一随眠。灭作证无结尽。圣者三随眠。灭作证无结尽。至阿罗汉。九十八随眠。灭作证九结尽。眼耳身触所生爱身。灭作证时。梵世爱尽。即三爱身。灭作证无结爱尽。至阿罗汉。九十八随眠。灭作证九结尽。欲界见苦所断随眠。灭作证时。异生欲爱尽。三十六随眠。灭作证三结尽。圣者苦法智现在前十随眠。灭作证无结尽。至预流果。八十八随眠。灭作证三结尽。至一来果亦尔。至不还果。九十二随眠。灭作证六结尽。至阿罗汉果。九十八随眠。灭作证九结尽。欲界见集所断随眠。灭作证时。异生欲爱尽。三十六随眠。灭作证三结尽。圣者集法智现在前七随眠。灭作证无结尽。至预流果。八十八随眠。灭作证三结尽。至一来果亦尔。至不还果。九十二随眠。灭作证六结尽至阿罗汉果。九十八随眠。灭作证九结尽。欲界见灭所断随眠。灭作证时。异生欲爱尽。三十六随眠。灭作证三结尽。圣者灭法智现在前七随眠。灭作证无结尽。至预流果。八十八随眠。灭作证三结尽。至一来果亦尔。至不还果。九十二随眠。灭作证六结尽。至阿罗汉。九十八随眠。灭作证九结尽。欲界见道所断随眠。灭作证时。异生欲爱尽。三十六随眠。灭作证三结尽。圣者道法智现在前八随眠。灭作证无结尽。至预流果。八十八随眠。灭作证三结尽。至一来果亦尔。至不还果。九十二随眠。灭作证六结尽。至阿罗汉。九十八随眠。灭作证九结尽。欲界修所断随眠。灭作证时。异生欲爱尽。三十六随眠。灭作证三结尽。圣者得不还果。九十二随眠。灭作证六结尽。至阿罗汉。九十八随眠。灭作证九结尽。色界见苦所断随眠。灭作证时。异生色爱尽。三十一随眠。灭作证无结尽。圣者苦类智现在前十八随眠。灭作证无结尽。至预流果。八十八随眠。灭作证三结尽。至一来果亦尔。至不还果。九十二随眠。灭作证六结尽。至阿罗汉。九十八随眠。灭作证九结尽。色界见集所断随眠。灭作证时。异生色爱尽。三十一随眠。灭作证无结尽。圣者集类智现在前十二随眠。灭作证无结尽。至预流果。八十八随眠。灭作证三结尽。至一来果亦尔。至不还果。九十二随眠。灭作证六结尽。至阿罗汉。九十八随眠。灭作证九结尽。色界见灭所断随眠。灭作证时。异生色爱尽。三十一随眠。灭作证无结尽。圣者灭类智现在前十二随眠。灭作证无结尽。至预流果。八十八随眠。灭作证三结尽。至一来果亦尔。至不还果。九十二随眠。灭作证六结尽。至阿罗汉。九十八随眠。灭作证九结尽。色界见道所断随眠。灭作证时。异生色爱尽。三十一随眠。灭作证无结尽。圣者得预流果。八十八随眠。灭作证三结尽。至一来果亦尔。至不还果。九十二随眠。灭作证六结尽。至阿罗汉。九十八随眠。灭作证九结尽。色界修所断随眠。灭作证时。色爱尽。异生三十一随眠。灭作证无结尽。圣者三随眠。灭作证无结尽。至阿罗汉。九十八随眠。灭作证九结尽。无色界见苦所断随眠。灭作证。苦类智现在前十八随眠。灭作证无结尽。至预流果。八十八随眠。灭作证三结尽。至一来果亦尔。至不还果。九十二随眠。灭作证六结尽。至阿罗汉果。九十八随眠。灭作证九结尽。无色界见集所断随眠。灭作证时。集类智现在前十二随眠。灭作证无结尽。至预流果。八十八随眠。灭作证三结尽。至一来果亦尔。至不还果。九十二随眠。灭作证六结尽。至阿罗汉。九十八随眠。灭作证九结尽。无色界见灭所断随眠。灭作证时。灭类智现在前。十二随眠。灭作证无结尽。至预流果。八十八随眠。灭作证三结尽。至一来果亦尔。至不还果。九十二随眠。灭作证六结尽。至阿罗汉。九十八随眠。灭作证九结尽。无色界见道所断随眠。灭作证时。得预流果。八十八随眠。灭作证三结尽。至一来果亦尔。至不还果。九十二随眠。灭作证六结尽。至阿罗汉。九十八随眠。灭作证九结尽。无色界修所断随眠。灭作证时。得阿罗汉果。九十八随眠。灭作证九结尽

说一切有部发智论卷第六阿毗达磨发智论卷第七

        尊者迦多衍尼子造

        三藏法师玄奘奉　诏译

    智蕴第三中觉支纳息第一

  八学十无学　　见等觉道三
  俗无漏见智　　此章愿具说

如世尊说。学见迹成就学八支。彼成就。过去几。未来几。现在几。答若依有寻有伺定。初学见现在前。过去无。未来现在八。彼灭已不失。若复依有寻有伺定。学见现在前。过去未来现在八。彼灭已不失。若依无寻无伺定。学见现在前。过去未来八。现在七。彼灭已不失。若依无色定。学见现在前。过去未来八。现在四。彼灭已不失。若入灭定。或世俗心现在前。过去未来八。现在无。若依无寻无伺定。初学见现在前。过去无。未来八。现在七。彼灭已不失。若复依无寻无伺定。学见现在前。过去现在七。未来八。彼灭已不失。若依无色定。学见现在前。过去七。未来八。现在四。彼灭已不失。若入灭定。或世俗心现在前。过去七。未来八。现在无。彼灭已不失。若依有寻有伺定。学见现在前。过去七。未来现在八。若依无色定。初学见现在前。过去无。未来八。现在四。彼灭已不失。若复依无色定。学见现在前。过去现在四。未来八。彼灭已不失。若入灭定。或世俗心现在前。过去四。未来八。现在无。彼灭已不失。若依有寻有伺定。学见现在前。过去四。未来现在八。彼灭已不失。若依无寻无伺定。学见现在前。过去四。未来八。现在七

如世尊说。漏尽阿罗汉。成就十无学支。彼成就。过去几。未来几。现在几。答若依有寻有伺定。初无学智现在前。过去无。未来十。现在九。彼灭已不失。若复依有寻有伺定。无学智现在前。过去现在九。未来十。彼灭已不失。若依无寻无伺定。无学智现在前。过去九。未来十。现在八。彼灭已不失。若依无色定。无学智现在前。过去九。未来十。现在五。彼灭已不失。若入灭定。或世俗心现在前。过去九。未来十。现在无。彼灭已不失。若依有寻有伺定。初无学知见现在前。过去现在九。未来十。彼灭已不失。若复依有寻有伺定。无学若智若见现在前。过去未来十。现在九。彼灭已不失。若依无寻无伺定。无学若智若见现在前。过去未来十。现在八。彼灭已不失。若依无色定。无学若智若见现在前。过去未来十。现在五。彼灭已不失。若入灭定。或世俗心现在前。过去未来十。现在无。若依无寻无伺定。初无学智现在前。过去无。未来十。现在八。彼灭已不失。若复依无寻无伺定。无学智现在前。过去现在八。未来十。彼灭已不失。若依无色定。无学智现在前。过去八。未来十。现在五。彼灭已不失。若入灭定。或世俗心现在前。过去八。未来十。现在无。彼灭已不失。若依有寻有伺定。无学智现在前。过去八。未来十。现在九。彼灭已不失。若依无寻无伺定。初无学见现在前。过去现在八。未来十。彼灭已不失。若复依无寻无伺定。无学若智若见现在前。过去九。未来十。现在八。彼灭已不失。若依无色定。无学若智若见现在前。过去九。未来十。现在五。彼灭已不失。若入灭定。或世俗心现在前。过去九。未来十。现在无。彼灭已不失。若依有寻有伺定。无学若智若见现在前。过去现在九。未来十。若依无色定。初无学智现在前。过去无。未来十。现在五。彼灭已不失。若复依无色定。无学智现在前。过去现在五。未来十。彼灭已不失。若入灭定。或世俗心现在前。过去五。未来十。现在无。彼灭已不失。若依有寻有伺定。无学智现在前。过去五。未来十。现在九。彼灭已不失。若依无寻无伺定。无学智现在前。过去五。未来十。现在八。彼灭已不失。若依无色定。初无学见现在前。过去现在五。未来十。彼灭已不失。若复依无色定。无学若智若见现在前。过去六。未来十。现在五。彼灭已不失。若入灭定。或世俗心现在前。过去六。未来十。现在无。从灭已不失。若依有寻有伺定。无学若智若见现在前。过去六。未来十。现在九。彼灭已不失。若依无寻无伺定。无学若智若见现在前。过去六。未来十。现在八

云何见。答眼根五见。世俗正见。学无学见云何智。答五识相应慧。除无漏忍余意识相应慧。云何慧。答六识相应慧。诸见是智耶。答应作四句。有见非智。谓眼根及无漏忍。有智非见。谓五识身相应慧。尽无生智。除五见及世俗正见。余意识相应有漏慧。有见亦智。谓五见。世俗正见。除无漏忍。及尽无生智。余无漏慧。有非见非智。谓除前相。诸见是慧耶答应作四句。有见非慧。谓眼根。有慧非见。谓五识身相应慧。尽无生智。除五见。及世俗正见。余意识相应有漏慧。有见亦慧。谓除尽无生智。余无漏慧。及五见世俗正见。有非见非慧。谓除前相。诸智彼慧耶。答诸智皆是慧。有慧非智。谓无漏忍。见摄智智摄见耶。答应作四句。有见非智摄。谓眼根及无漏忍。有智非见摄。谓五识相应慧。尽无生智。除五见及世俗正见。余意识相应有漏慧。有见亦智摄。谓五见世俗正见。除无漏忍及尽无生智余无漏慧。有非见亦非智摄。谓除前相。见摄慧慧摄见耶。答应作四句。有见非慧摄。谓眼根。有慧非见摄。谓五识相应慧尽无生智。除五见及世俗正见余意识相应有漏慧。有见亦慧摄。谓五见世俗正见。除尽无生智余无漏慧。有非见亦非慧摄。谓除前相。智摄慧慧摄智耶。答慧摄智。非智摄慧不摄何等。谓无漏忍诸成就见彼智耶。答如是。设成就智彼见耶。答如是。诸成就见彼慧耶。答如是。设成就慧彼见耶。答如是。诸成就智彼慧耶。答如是。设成就慧彼智耶。答如是。诸见已断已遍知彼智耶。答如是。设智已断已遍知彼见耶。答如是。诸见已断已遍知彼慧耶。答如是。设慧已断已遍知彼见耶。答如是。诸智已断已遍知彼慧耶。答如是。设慧已断已遍知彼智耶。答如是。诸正见是择法觉支耶。答应作四句。有正见非择法觉支。谓世俗正见。有择法觉支非正见。谓尽无生智。有正见亦择法觉支。谓除尽无生智。余无漏慧。有非正见亦非择法觉支。谓除前相。诸正智是择法觉支耶。答应作四句。有正智非择法觉支。谓世俗正智。有择法觉支非正智。谓无漏忍。有正智亦择法觉支。谓除无漏忍。余无漏慧。有非正智亦非择法觉支。谓除前相

七觉支。八道支。一一现在前时。几觉支几道支现在前耶。答若依未至定。念觉支现在前时。学六觉支八道支现在前。无学六觉支九道支现在前。若依初静虑。念觉支现在前时。学七觉支八道支现在前。无学七觉支九道支现在前。若依静虑中间。念觉支现在前时。学六觉支七道支现在前。无学六觉支八道支现在前。依第三第四静虑亦尔。若依第二静虑。念觉支现在前时。学七觉支七道支现在前。无学七觉支八道支现在前。若依无色定。念觉支现在前时。学六觉支四道支现在前。无学六觉支五道支现在前。择法精进轻安定舍觉支正见正精进正念正定道支亦尔。若依初静虑喜觉支现在前时。学七觉支八道支现在前。无学七觉支九道支现在前。若依第二静虑。喜觉支现在前时。学七觉支七道支现在前。无学七觉支八道支现在前。若依未至定。正思惟现在前时。学六觉支八道支现在前。无学六觉支九道支现在前。若依初静虑。正思惟现在前时。学七觉支八道支现在前。无学七觉支九道支现在前。若依去至定。正语现在前时。学六觉支八道支现在前。无学六觉支九道支现在前。若依初静虑。正语现在前时。学七觉支八道支现在前。无学七觉支九道支现在前。若依静虑中间。正语现在前时。学六觉支七道支现在前。无学六觉支八道支现在前。依第三第四静虑亦尔。若依第二静虑。正语现在前时。学七觉支七道支现在前。无学七觉支八道支现在前。正业正命亦尔

诸法念觉支相应。彼法择法觉支相应耶。答应作四句。有法念相应非择法。谓择法觉支。有法择法相应非念。谓念觉支。有法念相应亦择法。谓二相应法。有法非念相应亦非择法。谓余心心所法。色无为。心不相应行。如对择法觉支。对精进轻安定舍觉支正精进正定亦尔。诸法念觉支相应。彼法喜觉支相应耶。答应作四句。有法念相应非喜。谓喜觉支。及喜不相应念觉支相应法有法喜相应非念。谓喜觉支相应念。有法念相应亦喜。谓二相应法。有法非念相应亦非喜。谓喜不相应念觉支。及余心心所法。色无为。心不相应行。如对喜觉支。对正见正思惟亦尔。诸法念觉支相应彼法正念相应耶。答如是。诸法正念相应彼法念觉支相应耶。答如是。诸法择法觉支相应。彼法精进觉支相应耶。答应作四句。有法择法相应非精进。谓精进觉支。有法精进相应非择法。谓择法觉支。有法择法相应亦精进。谓二相应法。有法非择法相应亦非精进。谓余心心所法。色无为。心不相应行。如对精进觉支。对轻安定舍觉支正精进正念正定亦尔。诸法择法觉支相应。彼法喜觉支相应耶。答应作四句。有法择法相应非喜。谓喜觉支。及喜不相应择法觉支相应法。有法喜相应非择法。谓喜觉支相应择法。有法择法相应亦喜。谓二相应法。有法非择法相应亦非喜。谓喜不相应择法觉支。及余心心所法。色无为。心不相应行。如对喜觉支。对正思惟亦尔。诸法择法觉支相应彼法正见相应耶。答诸法正见相应。亦择法相应。有法择法相应非正见相应。谓正见所不摄择法觉支相应法。诸法精进觉支相应。彼法喜觉支相应耶。答应作四句。有法精进相应非喜。谓喜觉支。及喜不相应精进觉支相应法。有喜相应非精进。谓喜觉支相应精进。有法精进相应亦喜。谓二相应法。有法非精进相应亦非喜。谓喜不相应精进觉支。及余心心所法。色无为。心不相应行。如对喜觉支。对正见正思惟亦尔。诸法精进觉支相应。彼法轻安觉支相应耶。答应作四句。有法精进相应非轻安。谓轻安觉支。有法轻安相应非精进。谓精进觉支。有法精进相应亦轻安。谓二相应法。有法非精进相应亦非轻安。谓余心心所法。色无为。心不相应行。如对轻安觉支。对定舍觉支正念正定亦尔。诸法精进觉支相应彼法正精进相应耶。答如是。设法正精进相应彼法精进觉支相应耶。答如是。诸法喜觉支相应。彼法轻安觉支相应耶。答应作四句。有法喜相应非轻安谓喜相应轻安觉支。有法轻安相应非喜。谓喜觉支及喜不相应轻安觉支相应法。有法喜相应亦轻安。谓二相应法。有法非喜相应亦非轻安。谓喜不相应轻安觉支。及余心心所法。色无为。心不相应行。如对轻安觉支。对定舍觉支正精进正念正定亦尔。诸法喜觉支相应。彼法正见相应耶。答应作四句。有法喜相应非正见。谓喜觉支相应正见。及正见不相应喜觉支相应法。有法正见相应非喜。谓正见相应喜觉支。及喜觉支不相应正见相应法。有法喜相应亦正见。谓二相应法。有法非喜相应亦非正见。谓喜觉支不相应正见。正见不相应喜觉支。及余心心所法色无为。心不相应行。如对正见。对正思惟亦尔。诸法轻安觉支相应。彼法定觉支相应耶。答应作四句。有法轻安相应非定。谓定觉支。有法定相应非轻安。谓轻安觉支。有法轻安相应亦定。谓二相应法。有法非轻安相应亦非定。谓余心心所法。色无为。心不相应行。如对定觉支。对舍觉支正精进正念正定亦尔。诸法轻安觉支相应。彼法正见相应耶。答应作四句。有法轻安相应非正见。谓正见及正见不相应轻安觉支相应法。有法正见相应非轻安。谓正见相应轻安觉支。有法轻安相应亦正见。谓二相应法。有法非轻安相应亦非正见。谓正见不相应轻安觉支。及余心心所法。色无为。心不相应行。如对正见。对正思惟亦尔。诸法定觉支相应。彼法舍觉支相应耶。答应作四句。有法定相应非舍。谓舍觉支。有法舍相应非定。谓定觉支。有定相应亦舍。谓二相应法。有法非定相应亦非舍。谓余心心所法。色无为。心不相应行。如对舍觉支。对正精进正念亦尔。诸法定觉支相应。彼法正见相应耶。答应作四句。有法定相应非正见。谓正见及正见不相应定觉支相应法。有法正见相应非定。谓正见相应定觉支。有法定相应亦正见。谓二相应法。有法非定相应亦非正见谓正见。不相应定觉支。及余心心所法。色无为。心不相应行。如对正见。对正思惟亦尔。诸法定觉支相应彼法正定相应耶。答如是。设法正定相应彼法定觉支相应耶。答如是。诸法舍觉支相应。彼法正见相应耶。答应作四句。有法舍相应非正见。谓正见及正见不相应舍觉支相应法。有法正见相应非舍。谓正见相应舍觉支。有法舍相应亦正见。谓二相应法。有法非舍相应亦非正见。谓正见不相应舍觉支。及余心心所法。色无为。心不相应行。如对正见。对正思惟亦尔。诸法舍觉支相应。彼法正精进相应耶。答应作四句。有法舍相应非正精进。谓正精进。有法正精进相应非舍。谓舍觉支。有法舍相应亦正精进。谓二相应法。有法非舍相应亦非正精进。谓余心心所法色无为。心不相应行。如对正精进。对正念正定亦尔。诸法正见相应。彼法正思惟相应耶。答应作四句。有法正见相应非正思惟。谓正见相应正思惟。及正思惟不相应正见相应法。有法正思惟相应非正见。谓正思惟相应正见。及正见不相应正思惟相应法。有法正见相应亦正思惟。谓二相应法。有法非正见相应亦非正思惟。谓正见不相应正思惟正思惟不相应正见。及余心心所法。色无为。心不相应行。诸法正见相应。彼法正精进相应耶。答应作四句。有法正见相应非正精进。谓正见相应正精进。有法正精进相应非正见。谓正见及正见不相应正精进相应法。有法正见相应亦正精进。谓二相应法。有法非正见相应亦非正精进。谓正见不相应正精进。及余心心所法。色无为。心不相应行。如对正精进。对正念正定亦尔。诸法正思惟相应。彼法正精进相应耶。答应作四句。有法正思惟相应非正精进。谓正思惟相应正精进。有法正精进相应非正思惟。谓正思惟。及正思惟不相应正精进相应法。有法正思惟相应亦正精进。谓二相应法。有非正思惟相应亦非正精进。谓正思惟不相应正精进。及余心心所法。色无为。心不相应行。如对正精进。对正念正定亦尔。诸法正精进相应。彼法正念相应耶。答应作四句。有法正精进相应非正念。谓正念。有法正念相应非正精进。谓正精进。有法正精进相应亦正念。谓二相应法。有法非正精进相应亦非正念。谓余心心所法。色无为。心不相应行。如对正念对正定亦尔。诸法正念相应。彼法正定相应耶。答应作四句。有法正念相应非正定。谓正定。有法正定相应非正念。谓正念。有法正念相应亦正定。谓二相应法。有法非正念相应亦非正定。谓余心心所法。色无为。心不相应行

云何世俗正见。答意识相应善有漏慧。云何世俗正智。答五识相应善慧。及意识相应善有漏慧。诸世俗正见。是世俗正智耶。答诸世俗正见是世俗正智。有世俗正智非世俗正见。谓五识相应善慧。世俗正见。摄世俗正智。世俗正智。摄世俗正见耶。答世俗正智。摄世俗正见。非世俗正见摄世俗正智。不摄何等。谓五识相应善慧。诸成就世俗正见。彼世俗正智耶。答如是。设成就世俗正智。彼世俗正见耶。答如是。诸世俗正见已断已遍知。彼世俗正智耶。答如是。设世俗正智已断已遍知。彼世俗正见耶。答如是

云何无漏见。答除尽无生智。余无漏慧。云何无漏智。答除无漏忍。余无漏慧。诸无漏见。是无漏智耶。答应作四句。有无漏见非无漏智。谓无漏忍。有无漏智非无漏见。谓尽无生智。有无漏见亦无漏智。谓除无漏忍。尽无生智。余无漏慧。有非无漏见亦非无漏智。谓除前相。无漏见摄无漏智。无漏智摄无漏见耶。答应作四句。有无漏见非无漏智摄。谓无漏忍。有无漏智非无漏见摄。谓尽无生智。有无漏见亦无漏智摄。谓除无漏忍尽无生智。余无漏慧。有非无漏见亦非无漏智摄。谓除前相。诸成就无漏见。彼无漏智耶。答诸成就无漏智。亦无漏见。有成就无漏见非无漏智。谓苦法智忍现在前时

    智蕴第三中五种纳息第二

  邪正见智五　　左慧学等三
  梵忍五恶见　　此章愿具说

云何邪见。答若不安立。则五见皆名邪见。若安立。则唯无施与。无爱乐。无祠祀。无妙行。无恶行。无妙恶行。业果异熟等见。名邪见。云何邪智。答六识相应染污慧。诸邪见是邪智耶。答诸邪见是邪智。有邪智非邪见。谓五识相应染污慧。及除五见。余意识相应染污慧。邪见摄邪智。邪智摄邪见耶。答邪智摄邪见。非邪见摄邪智。不摄何等。谓五识相应染污慧。及除五见。余意识相应染污慧。诸成就邪见。彼邪智耶。答诸成就邪见。亦邪智。有成就邪智非邪见。谓学见迹。诸邪见已断已遍知。彼邪智耶。答诸邪智已断已遍知。亦邪见。有邪见已断已遍知非邪智。谓学见迹

云何正见。答尽无生智所不摄意识相应善慧。云何正智。答五识相应善慧。及无漏忍所不摄意识相应善慧。诸正见是正智耶。答应作四句。有正见非正智。谓无漏忍。有正智非正见。谓五识相应善慧。及尽无生智。有正见亦正智。谓无漏忍。及尽无生智所不摄意识相应善慧。有非正见亦非正智。谓除前相。正见摄正智。正智摄正见耶。答应作四句。有正见非正智摄。谓无漏忍。有正智非正见摄。谓五识相应善慧。及尽无生智。有正见亦正智摄。谓无漏忍。尽无生智所不摄意识相应善慧。有非正见亦非正智摄。谓除前相。诸成就正见。彼正智耶。答如是。设成就正智。彼正见耶。答如是。诸正见已断已遍知。彼正智耶。答如是。设正智已断已遍知。彼正见耶。答如是。诸左慧皆是结耶。答应作四句。有左慧非结。谓除二结。余染污慧。有结非左慧。谓七结。有左慧亦结。谓二结。有非左慧亦非结。谓除前相

云何学见。答学慧。云何学智。答学八智。云何学慧。答学见学智。总名学慧。诸学见是学智耶。答诸学智亦学见。有学见非学智。谓无漏忍。诸学见是学慧耶。答如是。设学慧是学见耶。答如是。诸学智是学慧耶。答诸学智亦学慧。有学慧非学智。谓无漏忍。学见摄学智。学智摄学见耶。答学见摄学智。非学智摄学见。不摄何等。谓无漏忍。学见摄学慧。学慧摄学见耶。答展转相摄学智摄学慧。学慧摄学智耶。答学慧摄学智。非学智摄学慧。不摄何等。谓无漏忍。诸成就学见。彼学智耶。答诸成就学智。亦学见。有成就学见非学智。谓苦法智忍现在前时。诸成就学见彼学慧耶。答如是。设成就学慧。彼学见耶。答如是。诸成就学智。彼学慧耶。答诸成就学智。亦学慧。有成就学慧非学智。谓苦法智忍现在前时。云何无学见。答尽无生智所不摄无学慧。云何无学智。答无学八智。云何无学慧。答无学见无学智。总名无学慧。诸无学见。是无学智耶。答诸无学见。亦无学智。有无学智非无学见。谓尽无生智。诸无学见。是无学慧耶。答诸无学见。亦无学慧有无学慧非无学见。谓尽无生智。诸无学智。是无学慧耶。答如是。设无学慧。是无学智耶。答如是。无学见摄无学智。无学智摄无学见耶。答无学智摄无学见。非无学见摄无学智。不摄何等。谓尽无生智。无学见摄无学慧无学慧摄无学见耶。答无学慧摄无学见。非无学见摄无学慧。不摄何等。谓尽无生智。无学智摄无学慧。无学慧摄无学智耶。答展转相摄。诸成就无学见。彼无学智耶。答如是。设成就无学智。彼无学见耶。答如是。诸成就无学见。彼无学慧耶。答如是。设成就无学慧。彼无学见耶。答如是。诸成就无学智。彼无学慧耶。答如是。设成就无学慧。彼无学智耶。答如是。云何非学非无学见。答眼根五见。世俗正见。云何非学非无学智。答五识相应慧。及意识相应有漏慧。云何非学非无学慧。答五识相应慧。及意识相应有漏慧。诸非学非无学见。是非学非无学智耶。答应作四句。有非学非无学见非非学非无学智。谓眼根。有非学非无学智非非学非无学见。谓五识相应慧。及除五见世俗正见。余意识相应有漏慧。有非学非无学见亦非学非无学智。谓五见。世俗正见有非非学非无学见亦非非学非无学智。谓除前相。诸非学非无学见。是非学非无学慧耶。答应作四句。有非学非无学见非非学非无学慧。谓眼根。有非学非无学慧非非学非无学见。谓五识相应慧。及除五见世俗正见。余意识相应有漏慧。有非学非无学见亦非学非无学慧。谓五见。世俗正见。有非非学非无学见亦非非学非无学慧。谓除前相。诸非学非无学智。是非学非无学慧耶。答如是。设非学非无学慧。是非学非无学智耶。答如是。非学非无学见。摄非学非无学智。非学非无学智。摄非学非无学见耶。答应作四句。有非学非无学见非非学非无学智摄。谓眼根。有非学非无学智非非学非无学见摄。谓五识相应慧。及除五见世俗正见。余意识相应有漏慧。有非学非无学见亦非学非无学智摄。谓五见。世俗正见。有非非学非无学见亦非非学非无学智摄。谓除前相。非学非无学见。摄非学非无学慧。非学非无学慧。摄非学非无学见耶。答应作四句。有非学非无学见非非学非无学慧摄。谓眼根。有非学非无学慧非非学非无学见摄。谓五识相应慧。及除五见世俗正见。余意识相应有漏慧。有非学非无学见亦非学非无学慧摄。谓五见。世俗正见。有非非学非无学见亦非非学非无学慧摄。谓除前相。非学非无学智。摄非学非无学慧非学非无学慧摄。非学非无学智耶。答展转相摄诸成就非学非无学见。彼非学非无学智耶。答如是。设成就非学非无学智。彼非学。非无学见耶。答如是。诸成就非学非无学见。彼非学非无学慧耶。答如是。设成就非学非无学慧。彼非学非无学见耶。答如是。诸成就非学非无学智。彼非学非无学慧耶。答如是。设成就非学非无学慧。彼非学非无学智耶。答如是。诸非学非无学见已断已遍知。彼非学非无学智耶。答如是。设非学非无学智已断已遍知。彼非学非无学见耶。答如是。诸非学非无学见已断已遍知。彼非学非无学慧耶。答如是。设非学非无学慧已断已遍知。彼非学非无学见耶。答如是。诸非学非无学智已断已遍知。彼非学非无学慧耶。答如是。设非学非无学慧已断已遍知。彼非学非无学智耶。答如是

如大梵天。作如是说。我是梵。是大梵。得自在。我于世间。能造化。能出生。是彼父。此于五见。何见摄。见何谛。断此见耶。答我是梵是大梵得自在者。取劣法为胜。见取摄。见苦所断。我于世间能造化能出生是彼父者。非因计因。戒禁取摄。见苦所断。如梵众天。作如是说。此是梵。是大梵。得自在。此于世间。能造化。能出生。是我等父。此于五见。何见摄。见何谛。断此见耶。答此是梵是大梵得自在者。取劣法为胜。见取摄。见苦所断。此于世间能造化能出生是我等父者。非因计因。戒禁取摄。见苦所断诸起此见。我一切忍。此于五见。何见摄。见何谛。断此见耶。答边执见中。常见摄。见苦所断。诸起此见。我一切不忍。此于五见。何见摄。见何谛。断此见耶。答边执见中。断见摄。见苦所断。诸起此见。我一分忍。一分不忍。此于五见。何见摄。见何谛。断此见耶。答一分忍者。边执见中。常见摄。一分不忍者。边执见中。断见摄。俱见苦所断

诸起此见有阿罗汉。天魔所娆。漏失不净。此于五见。何见摄。见何谛。断此见耶。答非因计因。戒禁取摄。见苦所断。诸起此见。有阿罗汉。于自解脱。犹有无知。此于五见。何见摄。见何谛。断此见耶。答诸阿罗汉。无漏智见。邪见摄。见道所断。诸起此见。有阿罗汉。于自解脱。犹有疑惑。此于五见。何见摄。见何谛。断此见耶。答诸阿罗汉。越度疑惑。邪见摄。见道所断。诸起此见。有阿罗汉。但由他度。此于五见。何见摄。见何谛。断此见耶。答诸阿罗汉。无障无背。现量慧眼。身证自在。邪见摄。见道所断。诸起此见。道及道支苦言所召。此于五见。何见摄。见何谛。断此见耶。答非因计因。戒禁取摄。见苦所断

说一切有部发智论卷第七阿毗达磨发智论卷第八

        尊者迦多衍尼子造

        三藏法师玄奘奉　诏译

    智蕴第三中他心智纳息第三

  二智二解脱　　明智三证净
  颠倒等持修　　此章愿具说

云何他心智。答若智修所成。是修果。依止修。已得不失。能知他相续现在欲色界心心所法。或无漏心心所法。是谓他心智。云何宿住随念智。答若智修所成。是修果。依止修。已得不失。能随忆知诸宿住事种种相状及所言说。是谓宿住随念智。诸他心智。皆现知他心心所法耶。答应作四句。有他心智非现知他心心所法。谓过去未来他心智。有现知他心心所法非他心智。谓如有一。或睹相。或闻语。或得如是生处得智。能现知他心心所法。有他心智亦现知他心心所法。谓若智修所成。是修果。依止修。已得不失。能现知他现在欲色界心心所法。或无漏心心所法。有非他心智亦非现知他心心所法。谓除前相。诸宿住随念智。皆现忆知诸宿住事耶。答应作四句。有宿住随念智非现忆知诸宿住事。谓过去未来宿住随念智。有现忆知诸宿住事非宿住随念智。谓如有一。得自性念生智。或得如是生处得智。能现忆知诸宿住事。有宿住随念智亦现忆知诸宿住事。谓若智修所成。是修果。依止修。已得不失。能现忆知诸宿住事种种相状。及所言说。有非宿住随念智亦非现忆知诸宿住事。谓除前相。诸宿住随念智。皆知他过去蕴处界心相续耶。答应作四句。有宿住随念智非知他过去蕴处界心相续。谓若智修所成。是修果。依止修。已得不失。知自前生过去蕴处界心相续。有知他过去蕴处界心相续非宿住随念智。谓若智修所成。是修果。依止修。已得不失。知他此生过去蕴处界心相续。有宿住随念智亦知他过去蕴处界心相续。谓若智修所成。是修果。依止修。已得不失。知他前生过去蕴处界心相续。有非宿住随念。智亦非知他过去蕴处界心相续。谓若智修所成。是修果。依止修。已得不失。知自此生过去蕴处界心相续

云何时爱心解脱。答时解脱阿罗汉尽智。或无学正见相应心胜解已胜解当胜解。云何不动心解脱。答不动法阿罗汉尽智无生智。或无学正见相应心胜解已胜解当胜解。诸时爱心解脱。皆尽智相应耶。答应作四句。有时爱心解脱非尽智相。应谓时解脱阿罗汉无学正见相应心胜解已胜解当胜解。有尽智相应非时爱心解脱。谓不动法阿罗汉尽智相应心胜解已胜解当胜解。有时爱心解脱亦尽智相应。谓时解脱阿罗汉尽智相应心胜解已胜解当胜解。有非时爱心解脱亦非尽智相应。谓不动法阿罗汉无生智。或无学正见相应心胜解已胜解当胜解。诸不动心解脱。皆无生智相应耶。答诸无生智相应。皆不动心解脱。有不动心解脱非无生智相应。谓不动法阿罗汉尽智。或无学正见相应心胜解已胜解当胜解。何缘时心解脱名爱耶。答时解脱阿罗汉。恒于此法殷勤守护。宝爱执藏。勿我遇缘退失此法。如一目人。自及亲友。殷勤守护。宝爱执藏。勿遇寒热尘翳等缘。令此一目。更当失坏。彼亦如是。故名为爱

云何学明。答学慧。云何学智。答学八智。云何无学明。答无学慧。云何无学智。答无学八智。谛现观时。于何最初。而得证净。佛耶法耶僧耶。答苦集灭现观时。于法最初。得证净。道现观时。于佛法僧最初。得证净

诸预流者。于四颠倒。几已断。几未断耶。答一切已断

诸预流者。于空无愿无相三三摩地成就。过去几。未来几。现在几。答未来一切。过去若已灭不失。现在若现在前

诸道过去。皆已修已息耶。答诸道过去。皆已修已息。有道已修已息非过去。谓道未来已修已息。诸道未来。皆未已修已息耶。答应作四句。有道未来非未已修已息。谓道未来已修已息。有道未已修已息非未来。谓未曾得道初现在前。有道未来亦未已修已息。谓道未来未已修已息。有道非未来亦非未已修已息。谓道过去。及曾得道。今现在前。诸道现在。皆正修耶。答诸道现在。皆正修。有道正修非现在。谓未曾得道。初现在前。所修未来。彼种类道

    智蕴第三中修智纳息第四之一

  八智摄成修　　相缘缘断证
  智知想七善　　此章愿具说

有八智。谓法智乃至道智。云何法智。答于欲界诸行。诸行因诸行灭。诸行能断道。所有无漏智。又于法智及法智地。所有无漏智。是谓法智。云何类智。答于色无色界诸行。诸行因诸行灭。诸行能断道。所有无漏智。又于类智及类智地。所有无漏智。是谓类智。云何他心智。答若智是修果。知他现在心心所法。云何世俗智。答三界有漏慧。云何苦智。答于诸行。作苦非常空非我行相转智。云何集智。答于诸行。因作因集生缘行相转智。云何灭智。答于诸行。灭作灭静妙离行相转智。云何道智。答于诸行。对治道作道如行出行相转智

法智乃至道智。于八智中。一一摄几。答法智摄法智五智少分。谓他心智。苦集灭道智。类智。摄类智。五智少分。谓他心智。苦集灭道智。他心智。摄他心智。四智少分。谓法类世俗道智。世俗智。摄世俗智。他心智。少分苦智。摄苦智。二智少分。谓法类智。集智摄集智。二智少分。谓法类智。灭智摄灭智。二智少分。谓法类智。道智摄道智。三智少分。谓法类他心智。若成就法智。于此八智。几成就。几不成就。答或三四五六七八。谓苦法智苦类智忍时。无他心智。成就三。有他心智。成就四。苦类智集法智忍时。无他心智。成就四。有他心智。成就五。集法智。乃至灭法智忍时。无他心智。成就五。有他心智。成就六。灭法智。乃至道法智忍时。无他心智。成就六。有他心智。成就七。道法智。乃至道类智时。无他心智。成就七。有他心智。成就八。若成就类智。于此八智。几成就。几不成就。答或四五六七八。谓苦类智集法智忍时。无他心智。成就四。有他心智。成就五。集法智。乃至灭法智忍时。无他心智。成就五。有他心智。成就六。灭法智。乃至道法智忍时。无他心智。成就六。有他心智。成就七。道法智。乃至道类智时。无他心智。成就七。有他心智。成就八。若成就他心智。于此八智。几成就。几不成就。答或二四五六七八。谓异生及圣者。苦法智忍时。成就二。苦法智苦类智忍时。成就四。苦类智集法智忍时。成就五。集法智。乃至灭法智忍时。成就六。灭法智。乃至道法智忍时。成就七。道法智。乃至道类智时。成就八。若成就世俗智。于此八智。几成就。几不成就。答或一二三四五六七八。谓异生及圣者。苦法智忍时。无他心智。成就一。有他心智。成就二。苦法智苦类智忍时。无他心智。成就三。有他心智。成就四。苦类智集法智忍时。无他心智。成就四。有他心智。成就五。集法智。乃至灭法智忍时。无他心智。成就五。有他心智。成就六。灭法智。乃至道法智忍时。无他心智。成就六。有他心智。成就七。道法智。乃至道类智时。无他心智。成就七。有他心智。成就八。若成就苦智。于此八智。几成就。几不成就。答或三四五六七八。谓苦法智苦类智忍时。无他心智。成就三。有他心智。成就四。苦类智集法智忍时。无他心智。成就四。有他心智。成就五。集法智。乃至灭法智忍时。无他心智。成就五。有他心智。成就六。灭法智。乃至道法智忍时。无他心智。成就六。有他心智。成就七。道法智。乃至道类智时。无他心智。成就七。有他心智。成就八。若成就集智。于此八智。几成就。几不成就。答或五六七八。谓集法智。乃至灭法智忍时。无他心智。成就五。有他心智。成就六。灭法智。乃至道法智忍时。无他心智。成就六。有他心智。成就七。道法智。乃至道类智时。无他心智。成就七。有他心智。成就八。若成就灭智。于此八智。几成就。几不成就。答或六七八。谓灭法智。乃至道法智忍时。无他心智。成就六。有他心智。成就七。道法智乃至道类智时。无他心智。成就七。有他心智。成就八。若成就道智。于此八智。几成就。几不成就。答或七八。谓无他心智。成就七。有他心智。成就八

若修法智亦类智耶。答应作四句。有修法智非类智。谓入现观苦集灭道法智时。学见迹阿罗汉。已得法智现在前时。有修类智非法智。谓入现观苦集灭类智时。学见迹阿罗汉。已得类智现在前时。有俱修。谓入现观道类智时。学见迹阿罗汉。未得无漏智现在前时。未得世俗智现在前。能俱修时。有俱不修。谓学见迹阿罗汉。已得世俗智。现在前时。未得世俗智。现在前。俱不修时。一切异生。染污心。无记心。无想定。灭定。无想天。无漏忍时。若修法智。亦他心智耶。答应作四句。有修法智非他心智。谓入现观苦集灭道法智时。未离欲染者。入现观道类智时。学见迹阿罗汉。已得法智。现在前。非他心智时。未得无漏智现在前。不修他心智时。未得世俗智现在前。修法智非他心智时。有修他心智非法智。谓异生已得未得他心智现在前时。未得世俗智现在前修他心智时。学见迹阿罗汉。已得他心智现在前。非法智时。有俱修。谓已离欲染。入现观道类智时。学见迹阿罗汉。已得法智现在前是他心智时。未得无漏智现在前。修他心智时。未得世俗智现在前。能俱修时。有俱不修。谓入现观苦集灭类智时。学见迹阿罗汉。已得无漏智现在前。非法智他心智时。已得世俗智现在前。非他心智时。未得世俗智现在前。俱不修时。异生不修他心智时。一切染污心。无记心。无想定。灭定。无想天。无漏忍时

若修法智亦世俗智耶。答应作四句。有修法智非世俗智。谓入现观苦集灭道法智道类智时。学见迹阿罗汉。已得法智现在前时。未得无漏智现在前。不修世俗智时有修。世俗智非法智。谓诸异生。已得未得世俗智现在前时。入现观苦集灭类智时。学见迹阿罗汉。已得世俗智现在前时。未得世俗智现在前。不修法智时。有俱修。谓学见迹阿罗汉。未得无漏智现在前。修世俗智时。未得世俗智现在前。修法智时。有俱不修。谓学见迹阿罗汉。已得无漏智现在前。非法智时。一切染污心。无记心。无想定。灭定。无想天。无漏忍时

若修法智亦苦智耶。答应作四句。有修法智非苦智。谓入现观集灭道法智时。学见迹阿罗汉。已得法智现在前。非苦智时。有修苦智非法智。谓入现观苦类智时。学见迹阿罗汉。已得苦智现在前。非法智时。有俱修。谓入现观苦法智。及道类智时。学见迹阿罗汉。已得苦法智现在前时。未得无漏智现在前时。未得世俗智现在前。能俱修时。有俱不修。谓入现观集灭类智时。学见迹阿罗汉已得无漏智现在前。非法苦智时。已得世俗智现在前时。未得世俗智现在前。不修法苦智时。一切异生染污心无记心。无想定。灭定。无想天。无漏忍时

若修法智亦集智耶。答应作四句。有修法智非修智。谓入现观苦灭道法智时。学见迹阿罗汉。已得法智现在前。非集智时。有修集智非法智。谓入现观集类智时。学见迹阿罗汉已得集智现在前。非法智时。有俱修。谓入现观集法智道类智时。学见迹阿罗汉。已得集法智现在前时。未得无漏智现在前时。未得世俗智现在前。修法集智时。有俱不修。谓入现观苦灭类智时。学见迹阿罗汉。已得无漏智现在前。非法集智时。已得世俗智现在前时。未得世俗智现在前。不修法集智时。一切异生染污心。无记心。无想定。灭定。无想天。无漏忍时

若修法智亦灭智耶。答应作四句。有修法智非灭智。谓入现观苦集道法智时。学见迹阿罗汉。已得法智现在前。非灭智时。有修灭智非法智谓入现观灭类智时。学见迹阿罗汉。已得灭智现在前。非法智时。有俱修。谓入现观灭法智道类智时。学见迹阿罗汉。已得灭法智现在前时。未得无漏智现在前时。未得世俗智现在前。能俱修时。有俱不修。谓入现观苦集类智时。学见迹阿罗汉。已得无漏智现在前。非法灭智时。已得世俗智现在前时。未得世俗智现在前。俱不修时。一切异生染污心。无记心。无想定。灭定无想天。无漏忍时。若修法智亦道智耶。答应作四句。有修法智非道智。谓入现观苦集灭法智时。学见迹阿罗汉。已得法智现在前。非道智时。有修道智非法智。谓学见迹阿罗汉。已得道智现在前。非法智时。有俱修。谓入现观道法智道类智时。学见迹阿罗汉。已得道法智现在前时。未得无漏智现在前时。未得世俗智现在前。能俱修时。有俱不修。谓入现观苦集灭类智时。学见迹阿罗汉。已得无漏智现在前。非法道智时。已得世俗智现在前时。未得世俗智现在前。俱不修时。一切异生染污心。无记心。无想定。灭定。无想天。无漏忍时

若修类智亦他心智耶。答应作四句。有修类智非他心智。谓入现观苦集灭类智时。未离欲染者。道类智时。学见迹阿罗汉。已得类智现在前。非他心智时。未得无漏智现在前。不修他心智时。未得世俗智现在前。修类智非他心智时。有修他心智非类智。谓异生已得未得他心智现在前时。未得世俗智现在前。修他心智时。学见迹阿罗汉。已得他心智现在前。非类智时。有俱修。谓已离欲染者。入现观道类智时。学见迹阿罗汉。已得类智现在前。是他心智时。未得无漏智现在前。修他心智时。未得世俗智现在前。能俱修时。有俱不修。谓入现观苦集灭道法智时。学见迹阿罗汉。已得无漏智现在前。非类他心智时。已得世俗智现在前。非他心智时。未得世俗智现在前。俱不修时。异生不修他心智时。一切染污心。无记心无想定灭定。无想天。无漏忍时。若修类智亦世俗智耶。答应作四句。有修类智非世俗智。谓入现观道类智时。学见迹阿罗汉。已得类智现在前时。未得无漏智现在前。不修世俗智时。有修世俗智非类智。谓异生已得未得世俗智现在前时。学见迹阿罗汉。已得世俗智现在前时。未得世俗智现在前。不修类智时。有俱修。谓入现观苦集灭类智时。学见迹阿罗汉。未得无漏智现在前修世俗智时。未得世俗智现在前。修类智时。有俱不修。谓入现观苦集灭道法智时。学见迹阿罗汉。已得无漏智现在前。非类智时。一切染污心。无记心。无想定。灭定。无想天。无漏忍时

若修类智亦苦智耶。答应作四句。有修类智非苦智。谓入现观集灭类智时。学见迹阿罗汉。已得类智现在前。非苦智时。有修苦智非类智。谓入现观苦法智时。学见迹阿罗汉。已得苦智现在前。非类智时。有俱修。谓入现观苦道类智时。学见迹阿罗汉。已得苦类智现在前时。未得无漏智现在前时。未得世俗智现在前。能俱修时。有俱不修。谓入现观集灭道法智时。学见迹阿罗汉。已得无漏智现在前。非类苦智时。已得世俗智现在前时。未得世俗智现在前。俱不修时。一切异生染污心。无记心。无想定。灭定。无想天。无漏忍时

若修类智亦集智耶。答应作四句。有修类智非集智。谓入现观苦灭类智时。学见迹阿罗汉。已得类智现在前。非集智时。有修集智非类智。谓入现观集法智时。学见迹阿罗汉。已得集智现在前。非类智时。有俱修。谓入现观集道类智时。学见迹阿罗汉。已得集类智现在前时。未得无漏智现在前时。未得世俗智现在前。能俱修时。有俱不修。谓入现观苦灭道法智时。学见迹阿罗汉。已得无漏现在前。非类集智时。已得世俗智现在前时。未得世俗智现在前。俱不修时。一切异生染污心。无记心。无想定。灭定。无想天。无漏忍时

若修类智亦灭智耶。答应作四句。有修类智非灭智。谓入现观苦集类智时。学见迹阿罗汉。已得类智现在前。非灭智时。有修灭智非类智。谓入现观灭法智时。学见迹阿罗汉。已得灭智现在前。非类智时。有俱修。谓入现观灭道类智时学见迹阿罗汉。已得灭类智现在前时。未得无漏智现在前时。未得世俗智现在前。能俱修时。有俱不修。谓入现观苦集道法智时。学见迹阿罗汉。已得无漏智现在前。非类灭智时。已得世俗智现在前时。未得世俗智现在前。俱不修时。一切异生染污心。无记心。无想定。灭定。无想天。无漏忍时

若修类智亦道智耶。答应作四句。有修类智非道智。谓入现观苦集灭类智时。学见迹阿罗汉。已得类智现在前。非道智时。有修道智非类智。谓入现观道法智时。学见迹阿罗汉。已得道智现在前。非类智时。有俱修。谓入现观道类智时。学见迹阿罗汉。已得道类智现在前时。未得无漏智现在前时。未得世俗智现在前。能俱修时。有俱不修。谓入现观苦集灭法智时。学见迹阿罗汉。已得无漏智现在前。非道类智时。已得世俗智现在前时。未得世俗智现在前。俱不修时一切异生染污心。无记心。无想定。灭定。无想天。无漏忍时

若修他心智亦世俗智耶。答应作四句。有修他心智非世俗智。谓已离欲染者。入现观道类智时。学见迹阿罗汉。已得他心智现在前。非世俗智时。未得无漏智现在前。修他心智非世俗智时。有修世俗智非他心智。谓无他心智异生已得未得世俗智现在前时。有他心智异生已得世俗智现在前。非他心智时。未得世俗智现在前。不修他心智时。入现观苦集灭类智时。学见迹阿罗汉。已得世俗智现在前。非他心智时。未得世俗智现在前。不修他心智时。未得无漏智现在前。修世俗智非他心智时。有俱修。谓异生已得未得他心智现在前时。未得世俗智现在前。修他心智时。学见迹阿罗汉。已得世俗他心智现在前时。未得世俗智现在前。修他心智时。未得无漏智现在前。能俱修时。有俱不修。谓入现观苦集灭道法智时。未离欲染者。入现观道类智时。学见迹阿罗汉。已得无漏智现在前。非他心智时。未得无漏智现在前。俱不修时。一切染污心。无记心。无想定。灭定。无想天。无漏忍时

若修他心智亦苦智耶。答应作四句。有修他心智非苦智。谓异生已得未得他心智现在前时。未得世俗智现在前修他心智时。学见迹阿罗汉。已得他心智现在前时。有修苦智非他心智。谓入现观苦法类智时。未离欲染者。入现观道类智时。学见迹阿罗汉。已得苦智现在前时。未得无漏智现在前。不修他心智时。未得世俗智现在前。修苦智非他心智时有俱修。谓已离欲染者。入现观道类智时。学见迹阿罗汉。未得无漏智现在前。修他心智时。未得世俗智现在前。能俱修时有俱不修。谓入现观集灭法类智道法智时。学见迹阿罗汉。已得无漏智现在前。非他心苦智时。已得世俗智现在前。非他心智时。未得世俗智现在前。俱不修时异生不修他心智时。一切染污心。无记心。无想定。灭定。无想天。无漏忍时

若修他心智亦集智耶。答应作四句。有修他心智非集智。谓异生已得未得他心智现在前时。未得世俗智现在前修他心智时。学见迹阿罗汉。已得他心智现在前时。有修集智非他心智。谓入现观集法类智时。未离欲染者。入现观道类智时。学见迹阿罗汉。已得集智现在前时。未得无漏智现在前。不修他心智时。未得世俗智现在前。修集智非他心智时有俱修。谓已离欲染者入现观道类智时。学见迹阿罗汉。未得无漏智现在前。修他心智时。未得世俗智现在前。能俱修时有俱不修。谓入现观苦灭法类智道法智时。学见迹阿罗汉。已得无漏智现在前。非他心集智时。已得世俗智现在前。非他心智时。未得世俗智现在前俱不修时。异生不修他心智时。一切染污心。无记心。入无想定。灭定。无想天。无漏忍时

若修他心智亦灭智耶。答应作四句。有修他心智非灭智。谓异生已得未得他心智现在前时。未得世俗智现在前。修他心智时。学见迹阿罗汉。已得他心智现在前时。有修灭智非他心智。谓入现观灭法类智时。未离欲染者。入现观道类智时。学见迹阿罗汉。已得灭智现在前时。未得无漏智现在前。不修他心智时。未得世俗智现在前。修灭智非他心智时有俱修。谓已离欲染者。入现观道类智时。学见迹阿罗汉。未得无漏智现在前。修他心智时。未得世俗智现在前。能俱修时有俱不修谓入现观苦集法类智道法智时。学见迹阿罗汉。已得无漏智现在前。非他心灭智时。已得世俗智现在前。非他心智时。未得世俗智现在前俱不修时。异生不修他心智时。一切染污心无记心。无想定灭定。无想天无漏忍时

若修他心智亦道智耶。答应作四句。有修他心智非道智。谓异生已得未得他心智现在前时。未得世俗智现在前。修他心智时。学见迹阿罗汉。已得他心智现在前。非道智时。有修道智非他心智。谓入现观道法智时。未离欲染者。入现观道类智时。学见迹阿罗汉。已得道智现在前。非他心智时。未得无漏智现在前。不修他心智时。未得世俗智现在前。修道智非他心智时有俱修。谓已离欲染者。入现观道类智时。学见迹阿罗汉。已得他心道智现在前时。未得无漏智现在前。修他心智时。未得世俗智现在前。能俱修时有俱不修。谓入现观苦。集灭法类智时。学见迹阿罗汉。已得无漏智现在前。非他心道智时。已得世俗智现在前。非他心智时。未得世俗智现在前俱不修时。异生不修他心智时。一切染污心无记心。无想定灭定。无想天无漏忍时

若修世俗智亦苦智耶。答应作四句。有修世俗智非苦智。谓异生已得未得世俗智现在前时。入现观集灭类智时。学见迹阿罗汉。已得世俗智现在前时。未得世俗智现在前。不修苦智时。有修苦智非世俗智。谓入现观苦法智道类智时。学见迹阿罗汉。已得苦智现在前时。未得无漏智现在前。不修世俗智时有俱修。谓入现观苦类智时。学见迹阿罗汉。未得无漏智现在前。修世俗智时。未得世俗智现在前。修苦智时有俱不修。谓入现观集灭道法智时。学见迹阿罗汉。已得无漏智现在前。非苦智时。一切染污心无记心。无想定灭定。无想天无漏忍时

若修世俗智亦集智耶。答应作四句。有修世俗智非集智。谓异生已得未得世俗智现在前时。入现观苦灭类智时。学见迹阿罗汉。已得世俗智现在前时。未得世俗智现在前。不修集智时。有修集智非世俗智。谓入现观集法智道类智时。学见迹阿罗汉。已得集智现在前时。未得无漏智现在前。不修世俗智时有俱修。谓入现观集类智时。学见迹阿罗汉。未得无漏智现在前。修世俗智时。未得世俗智现在前。修集智时有俱不修。谓入现观苦。灭道法智时。学见迹阿罗汉。已得无漏智现在前。非集智时。一切染污心无记心。无想定灭定。无想天无漏忍时

若修世俗智亦灭智耶。答应作四句。有修世俗智非灭智。谓异生已得未得世俗智现在前时。入现观苦集类智时。学见迹阿罗汉。已得世俗智现在前时。未得世俗智现在前。不修灭智时。有修灭智非世俗智。谓入现观灭法智道类智时。学见迹阿罗汉。已得灭智现在前时。未得无漏智现在前。不修世俗智时。有俱修。谓入现观灭类智时。学见迹阿罗汉。未得无漏智现在前。修世俗智时未得世俗。智现在前。修灭智时。有俱不修。谓入现观苦集道法智时。学见迹阿罗汉。已得无漏智现在前。非灭智时。一切染污心。无记心。无想定。灭定。无想天。无漏忍时

若修世俗智亦道智耶。答应作四句。有修世俗智非道智。谓异生已得未得世俗智现在前时。入现观苦集灭类智时。学见迹阿罗汉。已得世俗智现在前时。未得世俗智现在前。不修道智时。有修道智非世俗智。谓入现观道法类智时。学见迹阿罗汉。已得道智现在前时。未得无漏智现在前。不修世俗智时。有俱修。谓学见迹阿罗汉已得无漏智现在前。修世俗智时。未得世俗智现在前。修道智时。有俱不修。谓入现观苦集灭法智时。学见迹阿罗汉。已得无漏智现在前。非道智时。一切染污心。无记心。无想定。灭定。无想天。无漏忍时

说一切有部发智论卷第八阿毗达磨发智论卷第九

        尊者迦多衍尼子造

        三藏法师玄奘奉　诏译

    智蕴第三中修智纳息第四之二

若修苦智亦集智耶。答应作四句。有修苦智非集智。谓入现观苦法类智时。学见迹阿罗汉。已得苦智现在前时。有修集智非苦智。谓入现观集法类智时。学见迹阿罗汉。已得集智现在前时。有俱修。谓入现观道类智时。学见迹阿罗汉。未得无漏智现在前时。未得世俗智现在前。能俱修时。有俱不修。谓入现观灭法类智道法智时。学见迹阿罗汉。已得无漏智现在前。非苦集智时。已得世俗智现在前时。未得世俗智现在前。俱不修时。一切异生染污心。无记心。无想定。灭定。无想天。无漏忍时

若修苦智亦灭智耶。答应作四句。有修苦智非灭智。谓入现观苦法类智时。学见迹阿罗汉。已得苦智现在前时。有修灭智非苦智。谓入现观灭法类智时。学见迹阿罗汉。已得灭智现在前时。有俱修。谓入现观道类智时。学见迹阿罗汉。未得无漏智现在前时。未得世俗智现在前。能俱修时。有俱不修。谓入现观集法类智道法智时。学见迹阿罗汉。已得无漏智现在前。非苦灭智时。已得世俗智现在前时。未得世俗智现在前。俱不修时。一切异生染污心。无记心。无想定。灭定。无想天。无漏忍时

若修苦智亦道智耶。答应作四句。有修苦智非道智。谓入现观苦法类智时。学见迹阿罗汉。已得苦智现在前时。有修道智非苦智。谓入现观道法智时。学见迹阿罗汉。已得道智现在前时。有俱修。谓入现观道类智时。学见迹阿罗汉。未得无漏智现在前时。未得世俗智现在前。能俱修时。有俱不修。谓入现观集灭法类智时。学见迹阿罗汉。已得无漏智现在前。非苦道智时。已得世俗智现在前时。未得世俗智现在前。俱不修时。一切异生染污心。无记心。无想定。灭定。无想天。无漏忍时

若修集智亦灭智耶。答应作四句。有修集智非灭智。谓入现观集法类智时。学见迹阿罗汉。已得集智现在前时。有修灭智非集智。谓入现观灭法类智时。学见迹阿罗汉。已得灭智现在前时。有俱修。谓入现观道类智时。学见迹阿罗汉。未得无漏智现在前时。未得世俗智现在前。能俱修时。有俱不修。谓入现观苦法类智道法智时。学见迹阿罗汉。已得无漏智现在前。非集灭智时。已得世俗智现在前时。未得世俗智现在前。俱不修时。一切异生染污心。无记心。无想定。灭定。无想天。无漏忍时

若修集智亦道智耶。答应作四句。有修集智非道智。谓入现观集法类智时。学见迹阿罗汉。已得集智现在前时。有修道智非集智。谓入现观道法智时。学见迹阿罗汉。已得道智现在前时。有俱修。谓入现观道类智时。学见迹阿罗汉。未得无漏智现在前时。未得世俗智现在前。能俱修时。有俱不修。谓入现观苦。灭法类智时。学见迹阿罗汉。已得无漏智现在前。非集道智时。已得世俗智现在前时。未得世俗智现在前。俱不修时。一切异生染污心。无记心。无想定。灭定。无想天。无漏忍时

若修灭智亦道智耶。答应作四句。有修灭智非道智。谓入现观灭法类智时。学见迹阿罗汉。已得灭智现在前时。有修道智非灭智。谓入现观道法智时。学见迹阿罗汉。已得道智现在前时。有俱修。谓入现观道类智时。学见迹阿罗汉。未得无漏智现在前时。未得世俗智现在前。能俱修时。有俱不修。谓入现观苦集法类智时。学见迹阿罗汉。已得无漏智现在前。非灭道智时。已得世俗智现在前时。未得世俗智现在前。俱不修时。一切异生染污心。无记心。无想定。灭定。无想天。无漏忍时

法智乃至道智。于八智中。一一缘几智耶。答法智缘七智。除类智。类智缘七智。除法智。他心智。世俗智。俱缘八智。苦智集智。俱缘二智。谓他心世俗智。灭智不缘智。道智缘七智。除世俗智

法智乃至道智。自他相望。为几缘耶。答法智与法智为四缘。与类智为三缘。除所缘。与他心智为四缘。若与彼为因等无间。非所缘。若与彼为所缘。非因等无间。与世俗智为三缘除因。与苦集灭智为三缘除所缘。与道智为四缘。类智与类智为四缘。与他心智为四缘。若与彼为因等无间非所缘。若与彼为所缘。非因等无间。与世俗智为三缘除因。与苦集灭智为三缘除所缘。与道智为四缘。与法智为三缘除所缘。他心智与他心智为四缘。若与彼为因等无间非所缘。若与彼为所缘非因等无间。与世俗智为四缘。与苦集智为四缘。若与彼为因非所缘。若与彼为所缘非因。与灭智为三缘除所缘。与道法类智为四缘。世俗智与世俗智为四缘。与苦集智为三缘除因。与灭道智为二缘。谓等无间增上。与法类智为三缘除因。与他心智为四缘。若与彼为因等无间非所缘。若与彼为所缘。非因等无间。苦智与苦智。及集灭智为三缘除所缘。与道法类智为四缘与他心智为四缘。若与彼为因等无间非所缘。若与彼为所缘。非因等无间。与世俗智为三缘除因。集智与集智。及灭智为三缘除所缘。与道法类智为四缘。与他心智为四缘。若与彼为因等无间非所缘。若与彼为所缘。非因等无间。与世俗智为三缘除因。与苦智为三缘除所缘。灭智与灭智为三缘除所缘。与道法类智为四缘。与他心智为四缘。若与彼为因等无间。非所缘。若与彼为所缘。非因等无间。与世俗智为三缘除因。与苦集智为三缘除所缘。道智与道智。及法类智为四缘。与他心智为四缘。若与彼为因等无间非所缘。若与彼为所缘。非因等无间。与世俗智为三缘除因。与苦集灭智为三缘除所缘

诸结欲界系。彼结法智断耶。答应作四句。有结欲界系非法智断。谓欲界结。或忍断。或余智断。或不断。有结法智断非欲界系。谓色无色界结。法智断。有结欲界系亦法智断。谓欲界结。法智断。有结非欲界系亦非法智断。谓色无色界结。或忍断。或余智断。或不断。诸结色无色界系。彼结类智断耶。答诸结类智断。彼结色无色界系。有结色无色界系非类智断。谓色无色界结。或忍断。或余智断。或不断。诸结见苦所断。彼结苦智断耶。答诸结见苦所断。彼结非苦智断。或忍断。或余智断。或不断。设结苦智断。彼结见苦所断耶。答诸结苦智断。彼系非见苦所断。见修所断。诸结见集灭道所断。彼结集灭道智断耶。答诸结见集灭道。所断。彼结非集灭道智断。或忍断。或余智断。或不断。设结集灭道智断。彼结见集灭道所断耶。答诸结集灭道智断。彼结非见集灭道所断。是修所断

诸结法智断。彼结灭法智作证耶。答诸结法智断。彼结灭法智作证。有结灭法智作证。彼结非法智断。谓或忍断。或余智断。彼结灭法智作证。诸结类智断。彼结灭类智作证耶。答诸结类智断。彼结灭类智作证。有结灭类智作证。彼结非类智断。谓或忍断。或余智断。彼结灭类智作证。诸结苦智断。彼结灭苦智作证耶。答诸结苦智断。彼结灭苦智作证。有结灭苦智作证。彼结非苦智断。谓或忍断。或余智断。彼结灭苦智作证。诸结集灭道智断。彼结灭集灭道智作证耶。答诸结集灭道智断。彼结灭集灭道智作证。有结灭集灭道智作证。彼结非集灭道智断。谓或忍断。或余智断。彼结灭集灭道智作证

眼根乃至无色界修所断无明随眠。于十智中。几智知耶。答眼根七智知。除他心灭道智。耳鼻舌身命根亦尔。女根六智知。除类他心灭道智。男根亦尔。意根九智知。除灭智。乐喜舍信等五根亦尔。苦根七智知。除类灭道智。忧根亦尔。三无漏根七智知。除苦集灭智。眼耳鼻舌身色声触界七智知。除他心灭道智。眼耳鼻舌身色声触处色取蕴前五界有见有对法亦尔。香味界六智知。除类他心灭道智。香味处亦尔。眼耳身识界八智知。除灭道智。后四取蕴识界有漏法无记见修所断法亦尔。鼻舌识界七智知。除类灭道智。不善欲界。系法亦尔。意界意识界九智知。除灭智意处后四蕴有为法过去未来现在法亦尔。法界十智知。法处无色无见无对法善法亦尔。色蕴八智知。除他心灭智有色法亦尔。无漏法八智知。除苦集智无断法亦尔。无为法六智知。除他心苦集道智。色界系法七智知。除法灭道智。无色界系法六智知。除法他心灭道智。学无学法七智知。除苦集灭智。非学非无学法九智知。除道智。苦集谛八智知。除灭道智。世俗智三重三摩地亦尔。灭谛六智知。除他心苦集道智。道谛七智知除苦集灭智。苦集灭道智三三摩地亦尔。四静虑九智知。除灭智。他心智亦尔。四无量七智知。除法灭道智。初三解脱八胜处前八遍处亦尔。下三无色七智知。除法他心灭智。第四第五第六解脱亦尔。第四无色六智知。除法他心灭道智。第七第八解脱后二遍处亦尔。法智六智知。除类苦集灭智。类智六智知。除法苦集灭智。三结八智知。除灭道智。无明漏见无明瀑流轭。见戒禁取。后二身系贪慢结。后三顺下分结五见。眼耳身意触所生爱身。后四随眠爱慢无明见取疑结亦尔。三不善根七智知。除类灭道智。欲漏瀑流。轭取前二身系。五盖嗔嫉悭结。前二顺下分结。鼻舌触所生爱身。欲贪嗔恚随眠恚嫉悭结亦尔。有漏七智知。除法灭道智。有瀑流轭我语取除无色贪。余四顺上分结有贪随眠亦尔。无色贪六智知。除法他心灭道智。欲界三十六随眠七智知。除类灭道智。色界三十一随眠七智知。除法灭道智。无色界三十一随眠六智知。除法他心灭道智

如说无常想。若习若修若多所作。能除一切欲贪色贪无色贪掉举慢无明。此想当言几智相应耶。答应言。能除欲贪者。法智苦智相应。能除色无色贪者。类智苦智相应。能除掉举慢无明者。法智类智苦智相应。此想当言有寻有伺无寻唯伺无寻无伺耶。答应言。能除欲贪者。有寻有伺。能除色无色贪掉举慢无明者。或有寻有伺。或无寻唯伺。或无寻无伺。此想当言几根相应耶。答应言。能除欲贪者。舍根相应。能除色无色贪掉举慢无明者。乐喜舍根相应。此想当言空无愿无相俱耶

答应言无愿俱。此想当言缘何界系耶。答应言。能除欲贪者。缘欲界系。能除色贪者。缘色界系。能除无色贪者。缘无色界系。能除掉举慢无明者。缘三界系

如说七处善三义观。能于此法毗奈耶中。速尽诸漏。云何为七。谓如实知色色集色灭趣色灭行色味色患色出。如实知受想行识七亦尔。此智当言法智乃至道智耶。答应言如实知色是四智。谓法类世俗苦智。如实知色集是四智。谓法类世俗集智。如实知色灭是四智。谓法类世俗灭智。如实知趣色灭行是四智。谓法类世俗道智。如实知色味是四智。谓法类。世俗集智。如实知色患是四智。谓法类世俗苦智。如实知色出是四智。谓法类世俗灭智。如实知受想行识七亦尔。色乃至识灭。色乃至识出。何差别耶。答若由此爱。诸色集起。彼断名色灭。若诸余爱。缘色增广。彼断名色出。复次若由此业烦恼。诸色集起。彼断名色灭。若余业烦恼。缘色增广。彼断名色出。复次若由此爱及业烦恼。诸色集起。彼断名色灭。若诸余爱及业烦恼。缘色增广。彼断名色出。受想行识灭出亦尔。是谓差别

    智蕴第三中七圣纳息第五之一

  七圣于五德　　二成现三现
  相应事四门　　此章愿具说

随信行乃至俱解脱。于八智。几成就。几不成就。答随信行于八智。或成就一二三四五六七八。谓苦法智忍时。无他心智一。有他心智二。苦法智苦类智忍时。无他心智三。有他心智四。苦类智集法智忍时。无他心智四。有他心智五。集法智乃至灭法智忍时。无他心智五。有他心智六。灭法智乃至道法智忍时。无他心智六。有他心智七。道法智道类智忍时。无他心智七。有他心智八。随法行亦尔。信胜解于八智。或成就七八。谓无他心智七。有他心智八。见至亦尔。身证慧解脱俱解脱。于八智皆成就

随信行乃至俱解脱。于八智成就。过去几。未来几。现在几。答随信行于八智。苦法智忍时。无他心智。过去未来一。现在无。有他心智。过去未来二。现在无。苦法智时。无他心智。过去一。未来三。现在二。有他心智。过去二。未来四。现在二。苦类智忍时。无他心智。过去未来三。现在无有他心智。过去未来四。现在无。苦类智时。无他心智。过去三。未来四。现在二。有他心智。过去四。未来五。现在二。集法智忍时。无他心智。过去未来四。现在无。有他心智。过去未来五。现在无。集法智时。无他心智过去四。未来五。现在二。有他心智。过去五。未来六。现在二。集类智忍时。无他心智。过去未来五。现在无。有他心智。过去未来六。现在无。集类智时。无他心智。过去未来五。现在二。有他心智。过去未来六。现在二。灭法智忍时。无他心智。过去未来五。现在无。有他心智。过去未来六。现在无。灭法智时。无他心智。过去五。未来六。现在二。有他心智。过去六。未来七。现在二。灭类智忍时。无他心智。过去未来六。现在无。有他心智。过去未来七。现在无。灭类智时。无他心智。过去未来六。现在二。有他心智。过去未来七。现在二。道法智忍时。无他心智。过去未来六。现在无。有他心智。过去未来七。现在无。道法智时。无他心智。过去六。未来七。现在二。有他心智。过去七。未来八。现在二。道类智忍时。无他心智。过去未来七。现在无。有他心智。过去未来八。现在无。随法行亦尔。信胜解于八智。无他心智。未来七。有他心智。未来八。过去若已灭不失。现在若现在前。见至亦尔。身证慧解脱俱解脱于八智。皆未来八。过去若已灭不失。现在若现在前

随信行乃至俱解脱法智。乃至道智。现在前时。几智现在前耶。答随信行法智现在前时。二智现在前。谓法苦智二。法集智二。法灭智二。法道智二。类智现在前时。二智现在前。谓类苦智二。类集智二。类灭智二。苦智现在前时。二智现在前。谓苦法智二。苦类智二。集智现在前时。二智现在前。谓集法智二。集类智二。灭智现在前时。二智现在前。谓灭法智二。灭类智二。道智现在前时。二智现在前。谓道法智二。随法行亦尔。信胜解法智现在前时。或二三智现在前。谓法苦智二。法集智二。法灭智二。法道智非他心智二。是他心智三。类智现在前时。或二三智现在前。谓类苦智二。类集智二。类灭智二。类道智非他心智二是他心智三。他心智现在前时。或二三智现在前。谓他心世俗智二。他心道法智三。他心道类智三。世俗智现在前时。或一二智现在前。谓世俗智非他心智一是他心智二。苦智现在前时。二智现在前。谓苦法智二。苦类智二。集智现在前时。二智现在前。谓集法智二。集类智二。灭智现在前时。二智现在前。谓灭法智二。灭类智二。道智现在前时。或二三智现在前。谓道法智非他心智二。是他心智三。道类智非他心智二。是他心智三。见至身证亦尔。慧解脱法智现在前时。或二三智现在前。谓法苦智非尽无生智二。是尽或无生智三。法集智非尽无生智二。是尽或无生智三。法灭智非尽无生智二。是尽或无生智三。法道智非尽无生他心智二。是尽或无生。或他心智三。类智现在前时。或二三智现在前。谓类苦智非尽无生智二。是尽或无生智三。类集智非尽无生智二。是尽或无生智三。类灭智非尽无生智二。是尽或无生智三。类道智非尽无生他心智二。是尽或无生。或他心智三。他心智现在前时。或二三智现在前。谓他心世俗智二。他心道法智三。他心道类智三。世俗智现在前。或一二智现在前。谓世俗智非他心智一。是他心智二。苦智现在前时。或二三智现在前。苦法智非尽无生智二。是尽或无生智三。苦类智非尽无生智二。是尽或无生智三。集智现在前时。或二三智现在前。谓集法智非尽无生智二。是尽或无生智三。集类智非尽无生智二。是尽或无生智三。灭智现在前时。或二三智现在前。谓灭法智非尽无生智二。是尽或无生智三。灭类智非尽无生智二。是尽或无生智三。道智现在前时。或二三智现在前。谓道法智非尽无生他心智二。是尽或无生。或他心智三。道类智非尽无生他心智二。是尽或无生。或他心智三。俱解脱亦尔

随信行乃至俱解脱。于三三摩地。几成就。几不成就。答随信行。于三三摩地。灭法智忍。未已生成就二。已生成就三。随法行亦尔。信胜解乃至俱解脱。于三三摩地。皆成就

随信行乃至俱解脱。于三三摩地成就。过去几。未来几。现在几。答随信行。于三三摩地。若依空入正性离生。苦法智忍时。过去无。未来二。现在一。苦法智。乃至集法智忍时。过去一。未来二。现在一。集法智乃至集类智时。过去未来一现在一。灭法智忍时。过去二。未来三。现在一。灭法智乃至道类智忍时。过去未来三。现在一。若依无愿入正性离生苦法智忍时。过去无。未来二。现在一。苦法智乃至集类智时。过去一。未来二。现在一。灭法智忍时。过去一。未来三。现在一。灭法智乃至道类智忍时。过去二。未来三。现在一。随法行亦尔。信胜解乃至俱解脱。于三三摩地。皆未来三。过去若已灭不失。现在若现在前

随信行乃至俱解脱。空无愿无相三摩地现在前时。几智现在前耶。答随信行空三摩地现在前时。或二。或无。谓苦法智二。苦类智二。三忍时无。无愿三摩地现在前时。或二。或无。谓苦法智二。苦类智二。集法智二。集类智二。道法智二。六忍时无。无相三摩地现在前时。或二。或无。谓灭法智二。灭类智二。二忍时无。随法行亦尔。信胜解空三摩地现在前时。二智现在前。谓苦法智二。苦类智二。无愿三摩地现在前时。或二。或三。谓苦法智二。苦类智二。集法智二。集类智二。道法智非。他心智二。是他心智三。道类智非。他心智二。是他心智三。无相三摩地现在前时。二智现在前。谓灭法智二。灭类智二。见至身证亦尔。慧解脱空三摩地现在前时。二智现在前。谓苦法智二。苦类智二。无愿三摩地现在前时。或二。或三。谓苦法智非。尽无生智二。是尽或无生智三。苦类智非。尽无生智二。是尽或无生智三。集法智非尽无生智二。是尽或无生智三。集类智非。尽无生智二。是尽或无生智三。道法智非。尽无生他心智二。是尽或无生。或他心智三。道类智非。尽无生他心智二。是尽或无生。或他心智三。无相三摩地现在前时。或二。或三。谓灭法智非。尽无生智二。是尽或无生智三。灭类智非。尽无生智二。是尽或无生智三。俱解脱亦尔

随信行乃至俱解脱。三无漏根。七觉支。八道支。随应现在前时。几智现在前耶。答随信行。未知当知根现在前时。或二。或无。谓苦法智二。苦类智二。集法智二。集类智二。灭法智二。灭类智二。道法智二。八忍时无。七觉支八道支。现在前时亦尔。如随信行。随法行亦尔。信胜解已知根现在前时。或二。或三。谓苦法智二。苦类智二。集法智二。集类智二。灭法智二。灭类智二。道法智非。他心智二。是他心智三。道类智非。他心智二。是他心智三。七觉支八道支现在前时亦尔。如信胜解见至身证亦尔。慧解脱具知根现在前时。或二。或三。谓苦法智非。尽无生智二。是尽或无生智三。苦类智非。尽无生智二。是尽或无生智三。集法智非。尽无生智二。是尽或无生智三。集类智非。尽无生智二。是尽或无生智三。灭法智非。尽无生智二。是尽或无生智三。灭类智非。尽无生智二。是尽或无生智三。道法智非。尽无生他心智二。是尽或无生。或他心智三。道类智非。尽无生他心智二。是尽或无生。或他心智三。七觉支七道支亦尔。正见现在前时。或二。或三。苦法智二。苦类智二。集法智二。集类智二。灭法智二。灭类智二。道法智非。他心智二。是他心智三。道类智非。他心智二。是他心智三。如慧解脱。俱解脱亦尔

诸法法智相应。彼法类智相应耶。答不尔。设法类智相应。彼法法智相应耶。答不尔。对世俗智亦尔。诸法法。智相应。彼法他心智相应耶。答应作四句。有法法智相应非他心智。谓他心智所不摄法智相应法。有法他心智相应非法智。谓法智所不摄。他心智相应法有法。法智相应亦他心智。谓法智所摄他心智相应法。有法非法智相应亦非他心智。谓法智他心智。及法智他心智不摄。不相应诸余心心所法。色无为。心不相应行。对苦集灭道智及正见亦尔。诸法法智相应。彼法空三摩地相应耶。答应作四句。有法法智相应非空。谓法智相应空及空不相应法智相应法。有法空相应非法智。谓空相应法智。及法智不相应空相应法。有法法智相应亦空。谓二相应法。有法非法智相应亦非空。谓法智不相应空。空不相应法智。及法智空不摄不相应诸余心心所法。色无为。心不相应行。对无愿无相喜觉支正思惟亦尔。诸法法智相应。彼法未知当知根相应耶。答应作四句。有法法智相应非未知当知根。谓未知当知根所不摄法智相应法。有法未知当知根相应非法智。谓未知当知根所摄法智。及法智不摄不相应未知当知根相应法。有法法智相应亦未知当知根。谓未知当知根所摄法智相应法。有法非法智相应亦非未知当知根。谓未知当知根所不摄法智。及法智未知当知。根不摄不相应诸余心心所法。色无为。心不相应行。对已知具知根亦尔。诸法法智相应。彼法念觉支相应耶。答应作四句。有法法智相应非念。谓法智相应念觉支。有法念觉支相应非法智。谓法智及法智。不相应念觉支相应法。有法法智相应亦念。谓二相应法。有法非法智相应亦非念。谓法智不相应念觉支。及余心心所法。色无为。心不相应行。对精进轻安定舍觉支正精进正念正定亦尔。诸法法智相应。彼法择法觉支相应耶。答诸法法智相应。亦择法觉支。有法择法觉支相应非法智。谓法智所不摄择法觉支相应法。如法智对后。类智对后亦尔

说一切有部发智论卷第九阿毗达磨发智论卷第十

        尊者迦多衍尼子造

        三藏法师玄奘奉　诏译

    智蕴第三中七圣纳息第五之二

诸法他心智相应。彼法世俗智相应耶。答应作四句。有法他心智相应非世俗智。谓世俗智所不摄他心智相应法。有法世俗智相应非他心智。谓他心智所不摄世俗智相应法。有法他心智相应亦世俗智。谓他心智所摄世俗智相应法。有法非他心智相应亦非世俗智。谓他心世俗智。及他心世俗智不摄不相应诸余心心所法。色无为。心不相应行对道智择法觉支正见亦尔。诸法他心智相应。彼法苦智相应耶。答不尔。设法苦智相应。彼法他心智相应耶。答不尔。对集灭智空无相三摩地未知当知根亦尔。诸法他心智相应。彼法无愿三摩地相应耶。答应作四句。有法他心智相应非无愿。谓他心智相应无愿。及无愿不相应他心智相应法。有法无愿相应非他心智。谓无愿相应他心智。及他心智不相应无愿相应法。有法他心智相应亦无愿。谓二相应法。有法非他心智相应亦非无愿。谓他心智不相应无愿。无愿不相应他心智。及诸余心心所法。色无为。心不相应行。对念精进喜轻安定舍觉支正思惟正精进正念正定亦尔。诸法他心智相应。彼法已知根相应耶。答应作四句。有法他心智相应非已知根。谓已知根所不摄他心智相应法。有法已知根相应非他心智。谓已知根所摄他心智。及他心智不摄不相应已知根相应法。有法他心智相应亦已知根。谓已知根所摄他心智相应法。有法非他心智相应亦非已知根。谓已知根所不摄他心智。及他心智已知根不摄不相应诸余心心所法。色无为。心不相应行。对具知根亦尔

诸法世俗智相应。彼法苦智乃至正定相应耶。答不尔。设法苦智乃至正定相应。彼法世俗智相应耶。答不尔

诸法苦智相应。彼法集智相应耶。答不尔。设法集智相应。彼法苦智相应耶。答不尔。对灭道智无相三摩地亦尔。诸法苦智相应。彼法空三摩地相应耶。答应作四句。有法苦智相应非空。谓苦智相应空。及空不相应苦智相应法。有法空三摩地相应非苦智。谓空相应苦智。及苦智不相应空相应法。有法苦智相应亦空。谓二相应法有法非苦智相应亦非空。谓苦智不相应空。空不相应苦智。及诸余心心所法。色无为。心不相应行。对无愿亦尔。对三无漏根七觉支八道支。如法智说

诸法集智相应。彼法灭智相应耶。答不尔。设法灭智相应。彼法集智相应耶。答不尔。对道智空无相三摩地亦尔。诸法集智相应。彼法无愿三摩地相应耶。答应作四句。有法集智相应非无愿。谓集智相应无愿。有法无愿相应非集智。谓集智及集智不相应无愿相应法。有法集智相应亦无愿。谓二相应法。有法非集智相应亦非无愿。谓集智不相应无愿。及诸余心心所法。色无为。心不相应行。对三无漏根七觉支八道支。如法智说

诸法灭智相应。彼法道智相应耶。答不尔。设法道智相应。彼法灭智相应耶。答不尔。对空无愿三摩地亦尔。诸法灭智相应。彼法无相三摩地相应耶。答应作四句。有法灭智相应非无相。谓灭智相应无相。有法无相三摩地相应非灭智。谓灭智及灭智不相应无相相应法。有法灭智相应亦无相。谓二相应法。有法非灭智相应亦非无相。谓灭智不相应无相。及诸余心心所法。色无为。心不相应行。对三无漏。根七觉支八道支。如法智说

诸法道智相应。彼法空三摩地相应耶。答不尔。设法空三摩地相应。彼法道智相应耶。答不尔。对无相三摩地亦尔。诸法道智相应。彼法无愿三摩地相应耶。答应作四句。有法道智相应非无愿。谓道智相应无愿。有法无愿相应非道智。谓道智及道智不相应无愿相应法。有法道智相应亦无愿。谓二相应法。有法非道智相应亦非无愿。谓道智不相应无愿。及诸余心心所法。色无为。心不相应行。对三无漏根七觉支八道支。如法智说

诸法空三摩地相应。彼法无愿三摩地相应耶。答不尔。设法无愿三摩地相应。彼法空三摩地相应耶。答不尔。对无相亦尔。诸法空三摩地相应。彼法未知当知根相应耶。答应作四句。有法空相应非未知当知根。谓未知当知根所不摄空相应法。有法未知当知根相应非空。谓未知当知根所摄空。及空不摄不相应未知当知根相应法。有法空相应亦未知当知根。谓未知当知根所摄空相应法。有法非空相应亦非未知当知根。谓未知当知根所不摄空。及空未知当知根不摄不相应诸余心心所法。色无为。心不相应行。对已知具知根亦尔。诸法空三摩地相应。彼法念觉支相应耶。答应作四句。有法空相应非念觉支。谓空相应念觉支。有法念觉支相应非空。谓空及空不相应念觉支相应法。有法空相应亦念觉支。谓二相应法。有法非空相应亦非念觉支。谓空不相应念觉支。及诸余心心所法。色无为。心不相应行。对择法精进轻安舍觉支正见正精进正念亦尔。诸法空三摩地相应。彼法喜觉支相应耶。答应作四句。有法空相应非喜。谓空相应喜觉支。及喜不相应空相应法。有法喜觉支相应非空。谓喜觉支相应空。及空不相应喜觉支相应法。有法空相应亦喜。谓二相应法。有法非空相应亦非喜。谓空不相应喜觉支。喜觉支不相应空。及诸余心心所法。色无为。心不相应行。对正思惟亦尔。诸法空三摩地相应。彼法定觉支相应耶。答诸法空相应。彼法亦定觉支相应。有法定觉支相应非空。谓空所不摄定觉支相应法。对正定亦尔。如空对后。无愿无相对后亦尔。有差别者。如空对喜觉支。正思惟无愿无相对喜觉支正见正思惟亦尔

诸法未知当知根相应。彼法已知根相应耶。答不尔。设法已知根相应。彼法未知当知根相应耶。答不尔。对具知根亦尔。诸法未知当知根相应。彼法念觉支相应耶。答应作四句。有法未知当知根相应非念。谓未知当知根所摄念觉支有法念觉支相应非未知当知根。谓未知当知根所不摄念觉支相应法。有法未知当知根相应亦尔。谓未知当知根所摄念觉支相应法。有法非未知当知根相应亦非念。谓未知当知根所不摄念觉支。及诸余心心所法。色无为。心不相应行。对择法精进定觉支正见正精进正念正定亦尔。诸法未知当知根相应。彼法喜觉支相应耶。答应作四句。有法未知当知根相应非喜。谓未知当知根所摄喜觉支。及喜觉支不摄不相应未知当知根相应法。有法喜觉支相应。非未知当知根。谓未知当知根所不摄喜觉支相应法。有法未知当知根相应亦喜。谓未知当知根。所摄喜觉支相应法。有法非未知当知根相应亦非喜。谓未知当知根所不摄喜觉支。及喜觉支未知当知根不摄不相应诸余心心所法。色无为。心不相应行。诸法未知当知根相应。彼法轻安觉支相应耶。答应作四句。有法未知当知根相应非轻安。谓未知当知根相应轻安觉支。有法轻安相应非未知当知根。谓未知当知根。不相应轻安觉支相应法。有法未知当知根相应亦轻安。谓未知当知根相应轻安觉支相应法。有法非未知当知根相应亦非轻安。谓未知当知根不相应轻安觉支。及诸余心心所法。色无为。心不相应行。对舍觉支亦尔。诸法未知当知根相应。彼法正思惟相应耶。答应作四句。有法未知当知根相应非正思惟。谓未知当知根相应正思惟。及正思惟不相应。未知当知根相应法。有法正思惟相应非未知当知根。谓未知当知根不相应正思惟相应法。有法未知当知根相应亦正思惟。谓未知当知根相应正思惟相应法。有法非未知当知根相应亦非正思惟。谓未知当知根不相应正思惟。及未知当知根正思惟。不相应诸余心心所法。色无为。心不相应行。如未知当知根对后。已知具知根对后亦尔。有差别者。具知根对正见应作四句。有法具知根相应非正见。谓具知根所摄正见。及正见不摄不相应具知根相应法。有法正见相应非具知根。谓具知根所不摄正见相应法。有法具知根相应亦正见。谓具知根所摄正见相应法。有法非具知根相应亦非正见。谓具知根所不摄正见。及正见具知根不摄不相应诸余心心所法。色无为。心不相应行。念觉支乃至正念对后广说如觉支纳息

如说苾刍。吾当为汝说四十四智事。汝应谛听极善作意。云何四十四智事。谓知老死智。知老死集智。知老死灭智。知趣老死灭行智。如是知生有取爱受触六处名色识行智。知行集智。知行灭智。知趣行灭行智。是名四十四智事。此中知老死智等四十四智事。当言法智乃至道智耶。答应言知老死智是四智。谓法类世俗苦智。知老死集智是四智。谓法类世俗集智。知老死灭智是四智。谓法类世俗灭智。知趣老死灭行智是四智。谓法类世俗道智。生乃至行四智亦尔

如说苾刍。吾当为汝说七十七智事。汝应谛观极善作意。云何七十七智事。谓知生缘老死智。知非不生缘老死智。知过去生缘老死智。知彼非不生缘老死智。知未来生缘老死智。知彼非不生缘老死智。及法住智。遍知此事无常有为心所作从缘生尽法灭法离法灭法。如是知有取爱受触六处名色识行无明缘行智。知非不无明缘行智。知过去无明缘行智。知彼非不无明缘行智。未来无明缘行智。非不无明缘行智。及法住智。遍知此事是无常有为心所作从缘生尽法灭法离法灭法。此中知生缘老死智等七十七智事。当言法智乃至道智耶。答应言知生缘老死等前六智。皆是四智。谓法类世俗集智。第七法住智。是一世俗智。如知生缘老死七智。乃至知无明缘行七智亦尔

若成就法智。彼类智耶。答若得。设成就类智。彼法智耶。答如是。若成就法智。彼他心智耶。答若得不失。设成就他心智。彼法智耶。答若得。若成就法智。彼世俗智耶。答如是。设成就世俗智。彼法智耶。答若得。若成就法智。彼苦智耶。答如是。设成就苦智。彼法智耶。答如是。若成就法智。彼集智耶。答若得。设成就集智。彼法智耶。答如是。若成就法智。彼灭智耶。答若得。设成就灭智。彼法智耶。答如是。若成就法智。彼道智耶。答若得。设成就道智。彼法智耶。答如是。若成就类智。彼他心智耶。答若得不失。设成就他心智。彼类智耶。答若得。若成就类智。彼世俗智耶。答如是。设成就世俗智。彼类智耶。答若得。若成就类智。彼苦智耶。答如是。设成就苦智。彼类智耶。答若得。若成就类智。彼集智耶。答若得。设成就集智。彼类智耶。答如是。若成就类智。彼灭智耶。答若得。设成就灭智。彼类智耶。答如是。若成就类智。彼道智耶。答若得。设成就道智。彼类智耶。答如是。若成就他心智。彼世俗智耶。答如是。设成就世俗智。彼他心智耶。答若得不失。若成就他心智。彼苦智耶。答若得。设成就苦智。彼他心智耶。答若得不失。若成就他心智。彼集智耶。答若得。设成就集智。彼他心智耶。答若得不失。若成就他心智。彼灭智耶。答若得。设成就灭智。彼他心智耶。答若得不失。若成就他心智。彼道智耶。答若得。设成就道智。彼他心智耶。答若得不失。若成就世俗智。彼苦智耶。答若得。设成就苦智。彼世俗智耶。答如是。若成就世俗智。彼集智耶。答若得。设成就集智。彼世俗智耶。答如是。若成就世俗智。彼灭智耶。答若得。设成就灭智。彼世俗智耶。答如是。若成就世俗智。彼道智耶。答若得。设成就道智。彼世俗智耶。答如是。若成就苦智。彼集智耶。答若得。设成就集智。彼苦智耶。答如是。若成就苦智。彼灭智耶。答若得。设成就灭智。彼苦智耶。答如是。若成就苦智。彼道智耶。答若得。设成就道智。彼苦智耶。答如是。若成就集智。彼灭智耶。答若得。设成就灭智。彼集智耶。答如是。若成就集智。彼道智耶。答若得。设成就道智。彼集智耶。答如是。若成就灭智。彼道智耶。答若得。设成就道智。彼灭智耶。答如是。若成就过去法智。彼未来耶。答如是。设成就未来。彼过去耶。答若已灭不失则成就。若未灭。设灭已失则不成就。若成就过去法智。彼现在耶。答若现在前。设成就现在。彼过去耶。答若已灭不失则成就。若未灭。设灭已失则不成就。若成就未来法智。彼现在耶。答若现在前。设成就现在。彼未来耶。答如是。若成就过去法智。彼未来现在耶。答未来定成就现在。若现在前。设成就未来现在。彼过去耶。答若已灭。不失则成就。若未灭。设灭已失则不成就。若成就未来法智。彼过去现在耶。答有未来非过去现在。谓彼已得未灭。设灭已失。不现在前。有未来及过去非现在。谓彼已灭不失。不现在前。有未来及现在非过去。谓彼现在前未灭。设灭已失。有未来及过去现在。谓彼已灭不失亦现在前。设成就过去现在。彼未来耶。答如是。若成就现在法智。彼过去未来耶。答未来定成就过去。若已灭。不失则成就。若未灭。设灭已失则不成就。设成就。过去未来。彼现在耶。答若现在前。如法智历六类苦集灭道智亦尔。若成就过去他心智。彼未来耶。答如是。设成就未来。彼过去耶。答若已灭。不失则成就。若未灭。设灭已失则不成就。若成就过去他心智。彼现在耶。答若现在前。设成就现在。彼过去耶。答如是。若成就未来他心智。彼现在耶。答若现在前。设成就现在。彼未来耶。答如是。若成就过去他心智。彼未来现在耶。答未来定成就现在。若现在前。设成就未来现在。彼过去耶。答如是。若成就未来他心智。彼过去现在耶。答有未来非过去现在。谓彼已得不失未灭。设灭已失。不现在前。有未来及过去非现在。谓彼已灭不失不现在前。有未来及过去现在。谓彼现在前。设成就过去现在。彼未来耶。答如是。若成就现在他心智。彼过去未来耶。答如是。设成就过去未来。彼现在耶。答若现在前。若成就过去世俗智。彼未来耶。答如是。设成就未来。彼过去耶。答如是。若成就过去世俗智。彼现在耶。答若现在前。设成就现在。彼过去耶。答如是。若成就未来世俗智。彼现在耶。答若现在前。设成就现在。彼未来耶。答如是。若成就过去世俗智。彼未来现在耶。答未来定成就现在。若现在前。设成就未来现在。彼过去耶。答如是。若成就未来世俗智。彼过去现在耶。答过去定成就现在。若现在前。设成就过去现在。彼未来耶。答如是。若成就现在世俗智。彼过去未来耶。答如是。设成就过去未来。彼现在耶。答若现在前

若成就过去法智。彼过去类智耶。答若已灭。不失则成就。若未灭。设灭已失则不成就。设成就过去类智。彼过去法智耶。答若已灭。不失则成就。若未灭。设灭已失则不成就。若成就过去法智。彼未来类智耶。答若得。设成就未来类智。彼过去法智耶。答若已灭。不失则成就。若未灭。设灭已失则不成就。若成就过去法智。彼现在类智耶。答若现在前。设成就现在类智。彼过去法智耶。答若已灭。不失则成就。若未灭。设灭已失则不成就。若成就过去法智。彼过去现在类智耶。答有过去法智非过去现在类智。谓法智已灭不失类智未灭。设灭已失不现在前。有过去法智及过去类智非现在。谓法类智已灭不失。类智不现在前。有过去法智及现在类智非过去。谓法智已灭不失。类智现在前未灭。设灭已失。有过去法智及过去现在类智。谓法类智已灭不失类智现在前。设成就过去现在类智。彼过去法智耶。答若已灭。不失则成就。若未灭。设灭已失则不成就。若成就过去法智。彼未来现在类智耶。答有过去法智非未来现在类智。谓法智已灭。不失未得类智。有过去法智及未来类智非现在。谓法智已灭不失已得类智不现在前。有过去法智及未来现在类智。谓法智已灭不失类智现在前。设成就未来现在类智。彼过去法智耶。答若已灭不失则成就。若未灭。设灭已失则不成就。若成就过去法智。彼过去未来类智耶。答有过去法智非过去未来类智。谓法智已灭不失未得类智。有过去法智及未来类智非过去。谓法智已灭不失已得类智未灭设灭已失。有过去法智及过去未来类智。谓法类智已灭不失。设成就过去未来类智。彼过去法智耶。答若已灭不失则成就。若未灭设灭已失则不成就。若成就过去法智。彼过去未来现在类智耶。答有过去法智非过去未来现在类智。谓法智已灭不失未得类智。有过去法智及未来类智非过去现在。谓法智已灭不失已得类智未灭。设灭已失不现在前。有过去法智及未来现在类智非过去。谓法智已灭不失类智现在前未灭设灭已失。有过去法智及过去未来类智非现在。谓法类智已灭不失类智不现在前。有过去法智及过去未来现在类智。谓法类智已灭不失类智现在前。设成就过去未来现在类智。彼过去法智耶。答若已灭不失则成就。若未灭设灭已失则不成就。如对类智作小七。对集灭道智亦尔。若成就过去法智。彼过去他心智耶。答若已灭不失则成就。若未灭设灭已失则不成就。设成就过去他心智。彼过去法智耶。答若已灭不失则成就。若未灭设灭已失则不成就。若成就过去法智。彼未来他心智耶。答若已得不失。设成就未来他心智。彼过去法智耶。答若已灭不失则成就。若未灭设灭已失则不成就。若成就过去法智。彼现在他心智耶。答若现在前。设成就现在他心智。彼过去法智耶。答若已灭不失则成就。若未灭设灭已失则不成就。若成就过去法智。彼过去现在他心智耶。答有过去法智非过去现在他心智。谓法智已灭不失他心智。未灭设灭已失不现在前。有过去法智及过去他心智非现在。谓法他心智已灭不失他心智不现在前。有过去法智及过去现在他心智。谓法智已灭不失他心智现在前。设成就过去现在他心智。彼过去法智耶。答若已灭不失则成就。若未灭设灭已失则不成就。若成就过去法智。彼未来现在他心智耶。答有过去法智非未来现在他心智。谓法智已灭不失未得他心智设得已失。有过去法智及未来他心智非现在。谓法智已灭不失。他心智已得不失不现在前。有过去法智及未来现在他心智。谓法智已灭不失他心智现在前。设成就未来现在他心智。彼过去法智耶。答若已灭不失则成就。若未灭设灭已失则不成就。若成就过去法智。彼过去未来他心智耶。答有过去法智非过去未来他心智。谓法智已灭不失。未得他心智设得已失。有过去法智及未来他心智非过去。谓法智已灭不失。他心智已得不失。未灭设灭已失。有过去法智及过去未来他心智。谓法他心智已灭不失。设成就过去未来他心智。彼过去法智耶。答若已灭不失则成就。若未灭设灭已失则不成就。若成就过去法智。彼过去未来现在他心智耶。答有过去法智非过去未来现在他心智。谓法智已灭不失。未得他心智设得已失。有过去法智及未来他心智非过去现在。谓法智已灭不失他心智已得不失。未灭设灭已失不现在前。有过去法智及过去未来他心智非现在。谓法他心智已灭不失他心智不现在前。有过去法智及过去未来现在他心智。谓法智已灭不失他心智现在前。设成就过去未来现在他心智。彼过去法智耶。答若已灭不失则成就。若未灭设灭已失则不成就。若成就过去法智。彼过去世俗智耶。答如是。设成就过去世俗智。彼过去法智耶。答若已灭不失则成就。若未灭设灭已失则不成就。若成就过去法智。彼未来世俗智耶。答如是。设成就未来世俗智。彼过去法智耶。答若已灭不失则成就。若未灭设灭已失则不成就。若成就过去法智。彼现在世俗智耶。答若现在前。设成就现在世俗智。彼过去法智耶。答若已灭不失则成就。若未灭设灭已失则不成就。若成就过去法智。彼过去现在世俗智耶。答过去定成就现在。若现在前设成就过去现在世俗智。彼过去法智耶。答若已灭不失则成就。若未灭设灭已失则不成就。若成就过去法智。彼未来现在世俗智耶。答未来定成就现在。若现在前。设成就未来现在世俗智。彼过去法智耶。答若已灭不失则成就。若未灭设灭已失则不成就。若成就过去法智。彼过去未来世俗智耶。答如是。设成就过去未来世俗智。彼过去法智耶。答若已灭不失则成就。若未灭设灭已失则不成就。若成就过去法智。彼过去未来现在世俗智耶。答过去未来定成就现在。若现在前。设成就过去未来现在世俗智。彼过去法智耶。答若已灭不失则成就。若未灭设灭已失则不成就。若成就过去法智。彼过去苦智耶。答若已灭不失则成就。若未灭设灭已失则不成就。设成就过去苦智。彼过去法智耶。答若已灭不失则成就。若未灭设灭已失则不成就。若成就过去法智。彼未来苦智耶。答如是。设成就未来苦智。彼过去法智耶。答若已灭不失则成就。若未灭设灭已失则不成就。若成就过去法智。彼现在苦智耶。答若现在前。设成就现在苦智。彼过去法智耶。答若已灭不失则成就。若未灭设灭已失则不成就。若成就过去法智。彼过去现在苦智耶。答有过去法智非过去。现在苦智。谓法智已灭不失苦智未灭。设灭已失不现在前。有过去法智及过去苦智非现在。谓法苦智已灭不失苦智不现在前。有过去法智及现在苦智非过去。谓法智已灭不失苦智现在前未灭设灭已失。有过去法智及过去现在苦智。谓法苦智已灭不失苦智现在前。设成就过去现在苦智。彼过去法智耶。答若已灭不失则成就。若未灭设灭已失则不成就。若成就过去法智。彼未来现在苦智耶。答未来定成就现在。若现在前。设成就未来现在苦智。彼过去法智耶。答若已灭不失则成就。若未灭设灭已失则不成就。若成就过去法智。彼过去未来苦智耶。答未来定成就过去。若已灭不失则成就。若未灭设灭已失则不成就。设成就过去未来苦智。彼过去法智耶。答若已灭不失则成就。若未灭设灭已失则不成就。若成就过去法智。彼过去未来现在苦智耶。答有过去法智及未来苦智非过去现在。谓法智已灭不失苦智未灭。设灭已失不现在前。有过去法智及未来现在苦智非过去。谓法智已灭不失苦智现在前。未灭设灭已失。有过去法智及过去未来苦智非现在。谓法苦智已灭不失苦智不现在前。有过去法智及过去未来现在苦智。谓法苦智已灭不失苦智现在前。设成就过去未来现在苦智。彼过去法智耶。答若已灭不失则成就。若未灭设灭已失则不成就。如法智对后作小七。乃至灭智对道智。随其所应作小七亦尔。如小七。大七亦尔。差别者。以二或多对一。或以一对二或多。如过去为首有七。未来乃至过去未来现在为首。亦各有七。如应当知

说一切有部发智论卷第十阿毗达磨发智论卷第十一

        尊者迦多衍尼子造

        三藏法师玄奘奉　诏译

    业蕴第四中恶行纳息第一

  三行对三根　　及对十业道
  三业对十道　　九门业相摄
  身心受四句　　三障体云何
  何大罪大果　　此章愿具说

三恶行。三不善根。为前摄后后摄前耶。答应作四句。有恶行非不善根。谓身语恶行邪见不善思。有不善根非恶行。谓痴不善根。有恶行亦不善根。谓贪欲嗔恚。有非恶行非不善根。谓除前相。三妙行。三善根。为前摄后。后摄前耶。答应作四句。有妙行非善根。谓身语妙行及善思。有善根非妙行。谓正见不摄无痴善根。有妙行亦善根。谓无贪无嗔正见。有非妙行非善根。谓除前相。三恶行。十不善业道。为三摄十十摄三耶。答三摄十。非十摄三。不摄者何。谓除业道所摄身语意恶行。所余身语意恶行。三妙行。十善业道。为三摄十十摄三耶。答三摄十。非十摄三。不摄者何。谓除业道所摄身语意妙行。所余身语意妙行三业十业道。为三摄十十摄三耶。答应作四句。有业非业道。谓意业及业道所不摄身语业。有业道非业。谓后三业道。有业亦业道。谓前七业道。有非业非业道。谓除前相。三业谓身语意业。四业谓黑黑异熟业。白白异熟业。黑白黑白异熟业。非黑非白无异熟业。能尽诸业。为三摄四四摄三耶。答三摄四。非四摄三。不摄者何。谓除能断诸业学思余无漏业无色界系善业一切无记业。三业谓身语意。复有三业。谓顺现法受业。顺次生受业。顺后次受业。为前摄后后摄前耶。答前摄后。非后摄前。不摄者何。谓不定业。无记业。无漏业。三业谓身语意。复有三业。谓顺乐受业。顺苦受业。顺不苦不乐受业。为前摄后后摄前耶。答前摄后。非后摄前。不摄者何。谓无记业。无漏业。三业谓身语意。复有三业。谓过去未来现在业。复有三业。谓善不善无记业。复有三业。谓学无学非学非无学业。复有三业。谓见所断修所断无断业。为前摄后后摄前耶。答随其事。展转相摄。三业谓身语意。复有三业。谓欲色无色界系业。为前摄后后摄前耶。答前摄后。非后摄前。不摄者何。谓无漏业。四业如前说。三业谓顺现法受等。为四摄三三摄四耶。答应作四句。有四非三。谓能断诸业学思欲界系善不善不定业及色界系善不定业。有三非四。谓无色界系善决定业。有四亦三。谓欲界系善不善决定业。及色界系善决定业。有非四非三。谓除能断诸业学思余无漏业。无色界系善不定业。及无记业。四业如前说。三业谓顺乐受等。为四摄三三摄四耶。答应作四句。有四非三。谓能断诸业学思。有三非四。谓无色界系善业。有四亦三。谓欲界系善不善业色界系善业。有非四非三。谓除能断诸业学思余无漏业。及无记业。四业如前说。三业谓过去等善等学等见断等业。为四摄三三摄四耶。答三摄四。非四摄三。不摄者何。谓除能断诸业学思余无漏业。无色界系善业。及无记业。四业如前说。三业谓欲界系等。为四摄三。三摄四耶。答应作四句。有四非三。谓能断诸业学思。有三非四。谓无色界系善业。及无记业。有四亦三。谓欲界系善不善业。色界系善业。有非四非三。谓除能断诸业学思余无漏业。三业谓顺现法受等。复有三业。谓顺乐受等。为前摄后后摄前耶。答后摄前。非前摄后。不摄者何。谓不定业。三业谓顺现法受等。复有诸三业。谓过去等善等学等见断等为前摄后后摄前耶。答后摄前。非前摄后。不摄者何。谓不定业。无记业。无漏业。三业谓顺现法受等。复有三业。谓欲界系等。为前摄后后摄前耶。答后摄前。前非摄后。不摄者何。谓不定业。无记业

三业谓顺乐受等复有诸三业。谓过去等善等学等见断等为前摄后后摄前耶。答后摄前。非前摄后。不摄者何。谓无记业。无漏业。三业谓顺乐受等复有三业。谓欲界系等为前摄后。后摄前耶。答后摄前。非前摄后。不摄者何。谓无记业。三业谓过去等复有诸三业。谓善等学等见断等为前摄后后摄前耶。答随其事。展转相摄。三业谓过去等复有三业。谓欲界系等为前摄后后摄前耶。答前摄后。非后摄前。不摄者何。谓无漏业

三业谓善等复有三业。谓欲界系等为前摄后后摄前耶。答前摄后。非后摄前。不摄者何。谓无漏业。三业谓善等复有诸三业。谓学等见断等。为前摄后后摄前耶。答随其事。展转相摄。三业谓欲界系等复有诸三业。谓学等见断等为前摄后后摄前耶。答后摄前。非前摄后。不摄者何。谓无漏业。三业谓学等复有三业。谓见断等为前摄后后摄前耶。答随其事。展转相摄

颇有业感身受非心耶。答有。谓不善业。颇有业感心受非身耶。答有。谓善无寻业。颇有业感身心受耶。答有。谓善有寻业。颇有业不感身心受而感异熟耶。答有。谓诸业感色心不相应行异熟。如说三障。谓烦恼障。业障。异熟障。云何烦恼障。谓如有一本性具足炽然贪嗔痴烦恼。由如此故。难生厌离。难可教诲。难可开悟。难得免离。难得解脱。云何业障。谓五无间业。云何异熟障。谓诸有情处。那落迦。傍生。鬼界。北拘卢洲。无想天处

三恶行中。何者最大罪。谓破僧虚诳语。此业能取无间地狱一劫寿果。三妙行中。何者最大果。谓第一有等至中思。此业能取非想非非想处八万劫寿果

    业蕴第四中邪语纳息第二

  三邪正一异　　三恶行曲等
  妙净默相摄　　非理等六句
  业得果三世　　八句异熟果
  五业非前后　　此章愿具说

诸邪语。彼邪命耶。设邪命。彼邪语耶。答应作四句。有邪语非邪命。谓除贪所起语四恶行诸余语恶行。有邪命非邪语。谓贪所起身三恶行有邪语亦邪命。谓贪所起语四恶行。有非邪语非邪命。谓除贪所起身三恶行。诸余身恶行。诸邪业彼邪命耶。设邪命彼邪业耶。答应作四句。有邪业非邪命。谓除贪所起身三恶行。诸余身恶行。有邪命非邪业。谓贪所起语四恶行。有邪业亦邪命。谓贪所起身三恶行。有非邪业非邪命。谓除贪所起语四恶行。诸余语恶行。诸正语彼正命耶。设正命彼正语耶。答应作四句。有正语非正命。谓除无贪所起语四妙行。诸余语妙行。有正命非正语。谓无贪所起身三妙行。有正语亦正命。谓无贪所起语四妙行。有非正语非正命。谓除无贪所起身三妙行。诸余身妙行诸正业彼正命耶。设正命彼正业耶。答应作四句。有正业非正命。谓除无贪所起身三妙行。诸余身妙行。有正命非正业。谓无贪所起语四妙行。有正业亦正命。谓无贪所起身三妙行。有非正业非正命。谓除无贪所起语四妙行。诸余语妙行。三恶行三曲秽浊。谓身曲身秽身浊。语曲语秽语浊。意曲意秽意浊。三曲云何。谓谄所起身语意业秽云何。谓嗔所起身语意业浊云何。谓贪所起身语意业。为三恶行摄曲秽浊为曲秽浊摄恶行耶。答应作四句。有恶行非曲秽浊。谓除欲界谄嗔贪所起身语意恶行。诸余身语意恶行。有曲秽浊非恶行。谓初静虑谄贪所起身语意业。及余色无色界贪所起意业。有恶行亦曲秽浊。谓欲界谄嗔贪所起身语意恶行。有非恶行非曲秽浊。谓除前相

三妙行三净。谓身语意净。为妙行摄净。为净摄妙行耶。答随其事。展转相摄。三妙行三寂默。谓身语意寂默。为妙行摄寂默。为寂默摄妙行耶。答应作四句。有妙行非寂默。谓除无学身语妙行。诸余身语妙行。及一切意妙行。有寂默非妙行。谓无学心。有妙行亦寂默。谓无学身语妙行。有非妙行非寂默。谓除前相。三净三寂默。为净摄寂默。为寂默摄净耶。答应作四句。有净非寂默。谓除无学身语净。诸余身语净。及一切意净。有寂默非净。谓无学心。有净亦寂默。谓无学身语净。有非净非寂默。谓除前相

诸身恶行。彼尽非理所引身业耶。设非理所引身业彼尽身恶行耶。答诸身恶行。彼尽非理所引身业。有非理所引身业非身恶行。谓有覆无记身业。及无覆无记非理所引身业。诸语恶行。彼尽非理所引语业耶。设非理所引语业。彼尽语恶行耶。答诸语恶行彼尽非理所引语业。有非理所引语业非语恶行。谓有覆无记语业。及无覆无记非理所引语业。诸意恶行。彼尽非理所引意业耶。设非理所引意业。彼尽意恶行耶。答应作四句。有意恶行非非理所引意业。谓贪欲嗔恚邪见。有非理所引意业非意恶行。谓有覆无记意业。及无覆无记非理所引意业。有意恶行亦非理所引意业。谓不善意业。有非意恶行亦非非理所引意业。谓除前相

诸身妙行。彼尽如理所引身业耶。设如理所引身业。彼尽身妙行耶。答诸身妙行。彼尽如理所引身业。有如理所引身业非身妙行。谓无覆无记如理所引身业。诸语妙行。彼尽如理所引语业耶。设如理所引语业。彼尽语妙行耶。答诸语妙行。彼尽如理所引语业。有如理所引语业非语妙行。谓无覆无记如理所引语业。诸意妙行。彼尽如理所引意业耶。设如理所引意业。彼尽意妙行耶。答应作四句。有意妙行非如理所引意业。谓无贪无嗔正见。有如理所引意业非意妙行。谓无覆无记如理所引意业。有意妙行亦如理所引意业。谓善意业。有非意妙行。亦非如理所引意业。谓除前相。诸法由业得。彼法当言是善不善无记耶。答依异熟果诸法由业得。彼法是无记定作是说依异熟果诸法由业得。彼法是无记耶。答如是。为何所欲如来善心说语妙音美音和雅音悦意音。此语是善耶。答如是。若作是说。依异熟果诸法由业得彼法是无记。则不应言如来善心说语妙音美音和雅音悦意音此语是善。作是说者。不应道理。若作是说。如来善心说语妙音美音和雅音悦意音。此语是善。则不应言。依异熟果诸法由业得彼法是无记。而作是说。不应道理。应作是说。菩萨昔余生中。造作增长感异熟果大宗叶业。由是因缘。展转出生。如来咽喉微妙大种。从此能生妙语音声。而声非异熟

诸业过去。彼果过去耶。答彼果或过去。或未来。或现在。诸业未来。彼果未来耶。答如是。诸业现在。彼果现在耶。答彼果或现在或未来。颇有如身业感异熟语意业不尔耶。答有如身不护语护。彼于尔时。有善心。或无记心。又如身护语不护。彼于尔时。有不善心。或无记心。颇有如语业感异熟身意业不尔耶。答有如身护语不护。彼于尔时。有善心。或无记心。此相违说亦尔。颇有如意业感异熟身语业不尔耶。答有。如身护语护。彼于尔时。有不善心。如身不护语不护。彼于尔时。有善心。颇有如身业语业感异熟果意业不尔耶。答有。如身不护语不护。彼于尔时。有善心。或无记心。如身护语护。彼于尔时。有不善心。或无记心。颇有如身业意业感异熟果语业不尔耶。答有。如身不护语护。彼于尔时。有不善心。如身护语不护。彼于尔时。有善心。颇有如语业意业感异熟果身业不尔耶。答有。如身护语不护。彼于尔时。有不善心。如身不护语护。彼于尔时。有善心。颇有如身业语业感异熟果意业亦尔耶。答有。如身不护语不护。彼于尔时。有不善心。如身护语护。彼于尔时。有善心

颇有非身语意业。感异熟而感异熟耶。答有。谓心不相应行。感异熟色。心心所法。心不相应行

颇有顺现法受等三业非前非后受异熟果耶。答有。谓顺现法受业色。顺次生受业心心所法。顺后次受业心不相应行。又顺现法受业。心不相应行顺次生受业。色顺后次受业心心所法。又顺现法受业。心心所法。顺次生受业。心不相应行。顺后次受业色。颇有顺乐受等三业非前非后受异熟果耶。答有。谓顺乐受业色。顺苦受业心心所法。顺不苦不乐受业心不相应行。又顺乐受业心不相应行。顺苦受业色。顺不苦不乐受业心心所法。又顺乐受业心心所法。顺苦受业心不相应行。顺不苦不乐受业色

颇有三界业非前非后受异熟果耶。答有。谓欲界系业色。色界系业心心所法。无色界系业心不相应行。又欲界系业心不相应行。色界系业色。无色界系业心心所法。又欲界系业心心所法。色界业心不相应行。无色系业色

颇有善不善业非前非后受异熟果耶。答有。谓善业色。不善业心心所法心不相应行。又善业心心所法心不相应行。不善业色

颇有见修所断业非前非后受异熟果耶。答有。谓见所断业色。修所断业心心所法心不相应行。又见所断业。心心所法心不相应行。修所断业色

    业蕴第四中害生纳息第三

  害生命四种　　二熟二防护
  身及业成就　　杂染果异熟
  不善颠倒等　　系不系成就
  命终受生处　　此章愿具说

颇有已害生杀生未灭耶。答有。如已断他命彼加行未息。颇有未害生杀生已灭耶。答有。如未断他命彼加行已息。颇有已害生杀生已灭耶。答有。如已断他命彼加行已息。颇有未害生杀生未灭耶。答有。如未断他命彼加行未息

颇有未害生杀生未灭。此业异熟定生地狱耶。答有。如作无间业加行时命终。颇有业不善顺苦受。异熟未熟非不初受异熟果。而起染污心耶。答有。如造作增长无间业已。此业最初受彼地狱中。有异熟果生

颇有故思害生命后。不受远离而于一切有情得防护耶。答有。如起杀加行。致彼必死而中间证见法性。若于一切有情得防护。彼于一切有情受远离耶。答应作四句。有于一切有情得防护非受远离。如不受学处而证见法性。有于一切有情受远离非得防护如受学处而犯远离。有于一切有情得防护亦受远离。如受学处不犯远离。有非于一切有情得防护亦非受远离。谓除前相

若成就身。彼成就身业耶。答应作四句。有成就身非身业。谓处卵[穀-禾+卵]。若异生住胎若生欲界住非律仪非不律仪。无身表。设有而失。有成就身业非身。谓圣者生无色界。有成就身亦身业。谓圣者住胎藏中。若生欲界。住律仪不律仪。及住非律仪非不律仪。现有身表。或先有不失。若生色界。有非成就身亦非身业。谓异生生无色界。若成就身。彼成就语业耶。答应作四句。有成就身非语业。谓处卵[穀-禾+卵]。若诸异生住胎藏中。若生欲界。住非律仪非不律仪。都无语表。设有而失。有成就语业非身。谓诸圣者。生无色界。有成就身亦语业。谓诸圣者住胎藏中。若生欲界住律仪。若住不律仪。若住非律仪非不律仪。现有语表。或先有不失。若生色界。有非成就身亦非语业。谓诸异生生无色界

若成就身。彼成就意业耶。答诸成就身。彼定成就意业有成就意业非身谓生无色界

若成就身。彼成就身业语业耶。答有成就身非身业语业。谓处卵[穀-禾+卵]。若异生住胎。若生欲界。住非律仪非不律仪。无身语表。设有而失。有成就身及身业非语业。谓生欲界。住非律仪非不律仪。现有身表。或先有不失。无语表。设有而失。有成就身及语业非身业。谓生欲界。住非律仪非不律仪。现有语表。或先有不失无身表。设有而失有成就身及身业语业。谓圣者住胎。若生欲界。住律仪若住不律仪。及住非律仪非不律仪。现有身语表。或先有不失。若生色界。设成就身业语业。彼成就身耶。答或成就。或不成就。云何成就。谓如前说。云何不成就。谓圣者生无色界

若成就身。彼成就身业意业耶。答有成就身及意业非身业。谓处卵[穀-禾+卵]。若异生住胎。若生欲界。住非律仪非不律仪。无身表。设有而失。有成就身及身业意业。谓圣者住胎若生欲界。住律仪不律仪。及住非律仪非不律仪。现有身表。或先有不失。若生色界。设成就身业意业。彼成就身耶。答或成就。或不成就。云何成就。谓如前说。云何不成就。谓圣者生无色界。若成就身。彼成就语业意业耶。答有成就身及意业非语业。有成就身及语业意业。此皆如前身对身业意业中说。差别者。此说语表。设成就语业意业。彼成就身耶。答或成就。或不成就。亦如彼说。若成就身。彼成就身业语业意业耶。答有成就身及意业非身业语业。有成就身及身业意业非语业。有成就身及语业意业非身业。有成就身及身业语业意业。此皆如前身对身业。语业中说。设成就身业语业意业。彼成就身耶。答或成就。或不成就。亦如彼说

若成就身业。彼成就语业耶。答应作四句。有成就身业非语业。谓生欲界。住非律仪非不律仪。现有身表。或先有不失。无语表。设有而失。有成就语业非身业。谓生欲界。住非律仪非不律仪。现有语表。或先有不失。无身表。设有而失。有成就身业及语业谓圣者住胎。若生欲界。住律仪不律仪。及住非律仪非不律仪。现有身语表。或先有不失。若生色界。若圣者生无色界。有非成就身业及语业谓处卵[穀-禾+卵]。若异生住胎若生欲界。住非律仪非不律仪。无身语表。设有而失。若异生生无色界。若成就身业。彼成就意业耶。答设成就身业。彼成就意业。有成就意业非身业。谓处卵[穀-禾+卵]。若异生住胎若生欲界。住非律仪非不律仪。无身表设有而失。若异生生无色界

若成就身业。彼成就语业意业耶。答有成就身业及意业非语业。谓生欲界。住非律仪非不律仪。现有身表。或先有不失。无语表。设有而失。有成就身业及语业意业。谓圣者住胎若生欲界。住律仪不律仪。及住非律仪非不律仪。现有身语表。或先有不失。若生色界。若圣者生无色界。设成就语业意业。彼成就身业耶。答或成就。或不成就。云何成就。谓如前说。云何不成就。谓生欲界。住非律仪非不律仪。现有语表。或先有不失。无身表。设有而失

若成就语业。彼成就意业耶。答诸成就语业。彼成就意业。有成就意业非语业。此如前身业对意业说。差别者。此说语表

若业未离染。彼异熟未离染耶。答诸业未离染。彼异熟未离染。或有异熟未离染彼业已离染。谓预流者见所断。业已离染。彼异熟未离染

若业已离染。彼异熟已离染耶。答诸异熟已离染。彼业已离染。或有业已离染彼异熟未离染。谓预流者见所断。业已离染。彼异熟未离染

若业有果。彼业皆有异熟耶。答诸业有异熟。彼业皆有果。或有业有果彼业无异熟。谓无记业。无漏业

若业无果。彼业皆无异熟耶。答无有业无果。或有业无异熟。谓无记业。无漏业

若业不善。彼业皆颠倒耶。答应作四句。有业不善彼业非颠倒。谓如有一起此见立此论。有业有业果异熟而行身语意恶行。又如有一于见有不见想。于闻觉知。有不闻觉知想。彼覆此想此忍此欲。说言我见我闻觉知。或于不见有见想。于不闻觉知。有闻觉知想。彼覆此想此忍此欲。言我不见不闻觉知有业颠倒彼业非不善。谓如有一起此见立此论。无业无业果异熟。而行身语意妙行。又如有一于见有不见想。于闻觉知。有不闻觉知想。彼不覆此想此忍此欲。说言我不见我不闻觉知。或于不见有见想。于不闻觉知。有闻觉知想。彼不覆此想此忍此欲。说言我见我闻觉知。有业不善亦颠倒。谓如有一起此见立此论。无业无业果异熟。复行身语意恶行。又如有一于见有见想。于闻觉知有闻觉知想。彼覆此想此忍此欲。言我不见不闻觉知。或于不见有不见想。于不闻觉知。有不闻觉知想。彼覆此想此忍此欲。说言我见我闻觉知。有业非不善非颠倒。谓如有一起此见立此论。有业有业果异熟。复行身语意妙行。又如有一于见有见想。于闻觉知。有闻觉知想。彼不覆此想此忍此欲。说言我见我闻觉知。或于不见有不见想。于不闻觉知。有不闻觉知想。彼不覆此想此忍此欲。言我不见不闻觉知。若业善彼业不颠倒耶。答应作四句。前第二句。作此第一句。前第一句。作此第二句。前第四句。作此第三句。前第三句。作此第四句。广如前说。若成就不善业。彼成就色无色界系业耶。答诸成就不善业。彼定成就色无色界系业。有成就色无色界系业非不善业。谓生欲界已离欲界染。若生色界

若成就欲界系善业。彼成就色无色界系业耶。答诸成就欲界系善业。彼定成就色无色界系业。有成就色无色界系业非欲界系善业。谓断善根补特伽罗。若生色界

若成就欲界系善业。彼成就色无色界系善业耶。答应作四句。有成就欲界系善业非色无色界系善业。谓生欲界。不断善根。未得色界善心。有成就色无色界系善业非欲界系善业。谓生色界。得无色界善心。有成就欲界系善业亦色无色界系善业。谓生欲界。得无色界善心。有非成就欲界系善业亦非色无色界系善业。谓断善根补特伽罗

若成就欲界系业。彼成就色界系业耶。答如是。设成就色界系业。彼成就欲界系业耶。答如是

若成就欲界系业。彼成就无色界系业耶。答诸成就欲界系业。彼定成就无色界系业。有成就无色界系业非欲界系业。谓生无色界补特伽罗

若成就欲界系业。彼成就不系业耶。答应作四句。有成就欲界系业非不系业。谓异生生欲色界。有成就不系业非欲界系业。谓圣者生无色界。有成就欲界系业亦不系业。谓圣者生欲色界。有非成就欲界系业亦非不系业。谓异生生无色界

若成就色界系业。彼成就无色界系业耶。答诸成就色界系业。彼定成就无色界系业。有成就无色界系业非色界系业。谓诸有情生无色界。若成就色界系业。彼成就不系业耶。答应作四句。有成就色界系业非不系业。谓异生生欲色界。有成就不系业非色界系业。谓圣者生无色界。有成就色界系业亦不系业。谓圣者生欲色界。有非成就色界系业亦非不系业。谓异生生无色界。若成就无色界系业。彼成就不系业耶。答诸成就不系业彼定成就无色界系业。有成就无色界系业非不系业。谓诸异生。若成就欲界色界无色界系不系业。彼命终生何处。答或欲界。或色界。或无色界。或无生处

说一切有部发智论卷第十一阿毗达磨发智论卷第十二

        尊者迦多衍尼子造

        三藏法师玄奘奉　诏译

    业蕴第四中表无表纳息第四

  表无表总别　　四性三世成
  业果界是非　　有漏等学等
  身戒与心慧　　总别修不修
  戒类三世成　　此章愿具说

若成就身表。彼成就此无表耶。答应作四句。有成就身表非此无表。谓生欲界。住非律仪非不律仪。现有身表。不得此无表。或先有此表不失。不得此无表。有成就身无表非此表。谓圣者住胎若生欲界。住律仪。不得别解脱律仪。无身表。设有而失。若生色界。无身表。设有而失。若圣者生无色界。有成就身表亦此无表。谓生欲界住律仪。不得别解脱律仪。现有身表。亦得此无表。或先有此表不失。亦得此无表。若住别解脱律仪。若住不律仪。若住非律仪非不律仪。现有身表。亦得此无表。或先有此表不失。亦得此无表。若生色界。现有身表。或先有此表不失。有非成就身表亦非此无表。谓住卵[穀-禾+卵]。若异生住胎若生欲界。住非律仪非不律仪。无身表。设有而失。若异生生无色界

若成就善身表。彼成就此无表耶。答应作四句。有成就善身表非此无表。谓生欲界。住不律仪及非律仪非不律仪。现有善身表。不得此无表。或先有此表不失。不得此无表。有成就善身无表非此表。谓圣者住胎若生欲界。住律仪。不得别解脱律仪。无善身表。设有而失。若生色界。无善身表。设有而失。若圣者生无色界。有成就善身表亦此无表。谓生欲界住律仪。不得别解脱律仪。现有善身表。亦得此无表。或先有此表不失。亦得此无表。若住别解脱律仪。若住不律仪及非律仪非不律仪。现有善身表。亦得此无表。或先有此表不失。亦得此无表。若生色界。现有善身表。或先有此表不失。有非成就善身表亦非此无表。谓处卵[穀-禾+卵]。若异生住胎若生欲界。住不律仪及非律仪非不律仪。无善身表。设有而失。若异生生无色界

若成就不善身表。彼成就此无表耶。答诸成就不善身无表。彼成就此表。有成就不善身表非此无表。谓生欲界。住律仪及非律仪非不律仪。现有不善身表。不得此无表。或先有此表不失。不得此无表

若成就有覆无记身表。彼成就此无表耶。答无成就有覆无记身无表。有成就此表。谓生色界。现有有覆无记身表

若成就无覆无记身表。彼成就此无表耶。答无成就无覆无记身无表有成就此表。谓生欲色界。现有无覆无记身表

若成就过去身表。彼成就此无表耶。答应作四句。有成就过去身表非此无表。谓生欲界。住非律仪非不律仪。先有身表不失。不得此无表。有成就过去身无表非此表。谓圣者住胎。若生欲界。住律仪不得别解脱律仪。先无身表。设有而失。若生色界。先无身表。设有而失。若学者生无色界。有成就过去身表亦此无表。谓生欲界。住律仪不得别解脱律仪。先有身表不失。亦得此无表。若住别解脱律仪。若住不律仪。若住非律仪非不律仪。先有身表不失。亦得此无表。若生色界。先有身表不失。有非成就过去身表亦非此无表。谓处卵[穀-禾+卵]。若异生住胎。若生欲界。住非律仪非不律仪。先无身表。设有而失。若阿罗汉及异生。生无色界

若成就过去善身表。彼成就此无表耶。答应作四句。有成就过去善身表非此无表。谓生欲界。住不律仪及非律仪非不律仪。先有善身表不失。不得此无表。有成就过去善身无表非此表。谓圣者住胎若生欲界。住律仪不得别解脱律仪。先无善身表。设有而失。若生色界。先无善身表。设有而失。若学者生无色界。有成就过去善身表及此无表。谓生欲界。住律仪不得别解脱律仪。先有善身表不失。亦得此无表。若住别解脱律仪。若住不律仪及非律仪非不律仪。先有善身表不失。亦得此无表。若生色界。先有善身表不失。有非成就过去善身表亦非此无表。谓处卵[穀-禾+卵]。若异生住胎。若生欲界。住不律仪及非律仪非不律仪。先无善身表。设有而失。若阿罗汉及异生。生无色界

若成就过去不善身表。彼成就此无表耶。答诸成就过去不善身无表。彼成就此表。有成就过去不善身表。非此无表。谓生欲界。住律仪及非律仪非不律仪。先有不善身表不失。不得此无表

若成就过去有覆无记身表。彼成就此无表耶。答无成就过去有覆无记身表及此无表。若成就过去无覆无记身表。彼成就此无表耶。答无成就过去无覆无记身表及此无表。若成就未来身表。彼成就此无表耶。答无成就未来身表有成就此无表。谓圣者住胎若生欲界已。得色界善心。若生色界。若圣者生无色界

若成就未来善身表。彼成就此无表耶。答无成就未来善身表有成就此无表。谓圣者住胎若生欲界已。得色界善心。若生色界。若圣者生无色界。若成就未来不善身表。彼成就此无表耶。答无成就未来不善身表及此无表

若成就未来有覆无记身表。彼成就此无表耶。答无成就未来有覆无记身表及此无表。若成就未来无覆无记身表。彼成就此无表耶。答无成就未来无覆无记身表及此无表。若成就现在身表。彼成就此无表耶。答应作四句。有成就现在身表非此无表。谓生欲界。住律仪不得别解脱律仪。现有身表。不得此无表。设先有身表不失。而不得此无表。若住非律仪非不律仪。现有身表。不得此无表。设先有身表不失。而不得此无表。若生色界。现有身表。有成就现在身无表非此表。谓生欲界。住律仪。不得别解脱律仪。正在定。设不在定。现无身表。先有身表不失。得此无表。若住别解脱律仪及不律仪。现无身表。若住非律仪非不律仪。现无身表。先有身表不失。得此无表。若生色界。正在定。有成就现在身表亦此无表。谓生欲界。住律仪。不得别解脱律仪。现有身表。得此无表。或先有身表不失。得此无表。若住别解脱律仪及不律仪。现有身表。若住非律仪非不律仪。现有身表。得此无表。或先有身表不失。得此无表。有非成就现在身表亦非此无表。谓处卵[穀-禾+卵]。及住胎中。若生欲界。住律仪。不得别解脱律仪。不在定。现无身表。设先有身表不失。而不得此无表。若住非律仪非不律仪。现无身表。设先有身表不失。而不得此无表。若生色界。不在定。现无身表。若生无色界。若成就现在善身表。彼成就此无表耶。答应作四句。有成就现在善身表非此无表。谓生欲界。住律仪。不得别解脱律仪。现有善身表。不得此无表。设先有善身表不失。而不得此无表。若住不律仪及非律仪非不律仪。现有善身表。不得此无表。设先有善身表不失。而不得此无表。若生色界。现有善身表。有成就现在善身无表非此表。谓生欲界。住律仪。不得别解脱律仪。正在定。设不在定。现无善身表。先有善身表不失。而得此无表。若住别解脱律仪。现无善身表。若住不律仪及非律仪非不律仪。现无善身表。先有善身表不失。而得此无表。若生色界。正在定。有成就现在善身表亦此无表。谓生欲界住律仪。不得别解脱律仪。现有善身表。亦得此无表。先有善身表不失。得此无表。若住别解脱律仪。现有善身表。若住不律仪及住非律仪非不律仪。现有善身表。亦得此无表。先有善身表不失。得此无表。有非成就现在善身表亦非此无表。谓处卵[穀-禾+卵]。及住胎中。若生欲界住律仪。不得别解脱律仪。不在定。现无善身表。设先有善身表不失。而不得此无表。若住不律仪及非律仪非不律仪。现无善身表。设先有善身表不失。而不得此无表。若生色界。不在定。现无善身表。若生无色界

若成就现在不善身表。彼成就此无表耶。答应作四句。有成就现在不善身表非此无表。谓生欲界。住律仪及非律仪非不律仪。现有不善身表。不得此无表。设先有不善身表不失。而不得此无表。有成就现在不善身无表非此表。谓生欲界住不律仪。现无不善身表。若住律仪及非律仪非不律仪。现无不善身表。先有不善身表不失。得此无表。有成就现在不善身表。亦此无表。谓生欲界。住律仪及非律仪非不律仪。现有不善身表。亦得此无表。先有不善身表不失。得此无表。若住不律仪。现有不善身表。有非成就现在不善身表亦非此无表。谓处卵[穀-禾+卵]。若住胎中。若生欲界。住律仪及非律仪非不律仪。现无不善身表。设先有不善身表不失。而不得此无表。若生色无色界

若成就现在有覆无记身表。彼成就此无表耶。答无成就现在有覆无记身无表。有成就此表。谓生色界。现有有覆无记身表

若成就现在无覆无记身表。彼成就此无表耶。答无成就现在无覆无记身无表有成就此表。谓生欲色界。现有无覆无记身表。如广说身表无表。如是语表无表。广说亦尔

若业欲界系。彼业果欲界系耶。答诸业欲界系。彼业果亦尔。有业果欲界系非彼业。谓由色界道。作欲界化。发欲界语。若业色界系。彼业果色界系耶。答诸业果色界系。彼业亦尔。有业色界系非彼业果。谓由色界道。作欲界化。发欲界语。及由色界道。证诸结断。若业无色界系。彼业果无色界系耶。答诸业果无色界系。彼业亦尔。有业无色界系非彼业果。谓由无色界道。证诸结断。若业不系。彼业果不系耶。答诸业不系。彼业果亦尔。有业果不系非彼业。谓由色无色界道。证诸结断

若业非欲界系。彼业果非欲界系耶。答诸业果非欲界系。彼业亦尔。有业非欲界系非彼业果。谓由色界道。作欲界化。发欲界语。若业非色界系。彼业果非色界系耶。答诸业非色界系。彼业果亦尔。有业果非色界系非彼业。谓由色界道。作欲界化。发欲界语。及由色界道。证诸结断。若业非无色界系。彼业果非无色界系耶。答诸业非无色界系。彼业果亦尔。有业果非无色界系非彼业。谓由无色界道。证诸结断。若业非不系。彼业果非不系耶。答诸业果非不系。彼业亦尔。有业非不系非彼业果。谓由色无色界道。证诸结断

颇业有漏。有漏果耶。答有。谓等流异熟果。颇业有漏。无漏果耶。答有。谓离系果。颇业有漏。有漏无漏果耶。答有。谓等流异熟离系果。颇业无漏。无漏果耶。答有。谓等流离系果。颇业无漏。有漏果耶。答无。颇业无漏有漏无漏果耶。答无。颇业有漏无漏有漏无漏果耶。答无。颇业有漏无漏。有漏果耶答无。颇业有漏无漏。无漏果耶。答无。颇业学。学果耶。答有。谓等流果。颇业学。无学果耶。答有。谓等流果。颇业学。非学非无学果耶。答有。谓离系果。颇业无学。无学果耶。答有。谓等流果。颇业无学。学果耶。答无。颇业无学。非学非无学果耶。答无。颇业非学非无学。非学非无学果耶。答有。谓等流异熟离系果。颇业非学无学。学果耶。答无。颇业非学非无学。无学果耶。答无

如世尊说。不修身。不修戒。不修心。不修慧。云何不修身。答若于身未离贪欲润喜渴。又无间道。能尽色贪。彼于此道。未修未安。云何不修戒。答若于戒未离贪。广说如身。云何不修心。答若于心未离贪欲润喜渴。又无间道。能尽无色贪。彼于此道。未修未安。云何不修慧。答若于慧未离贪。广说如心。若不修身。彼不修戒耶。答如是。设不修戒。彼不修身耶。答如是。若不修身。彼不修心耶。答诸不修身。彼不修心。有不修心非不修身。谓已离色染。未离无色染。若不修身。彼不修慧耶。答诸不修身。彼不修慧。有不修慧非不修身。如前说。若不修戒。彼不修心耶。答诸不修戒。彼不修心。有不修心非不修戒。如前说。若不修戒。彼不修慧耶。答诸不修戒。彼不修慧。有不修慧非不修戒。如前说。若不修心。彼不修慧耶。答如是设不修慧。彼不修心耶。答如是

如世尊说。修身修戒。修心修慧。云何修身。答若于身已离贪欲润喜渴。又无间道。能尽色贪。彼于此道。已修已安。云何修戒。答若于戒已离贪广说如身。云何修心。答若于心已离贪欲润喜渴。又无间道。能尽无色贪。彼于此道已修已安。云何修慧。答若于慧已离贪。广说如心。若修身。彼修戒耶。答如是。设修戒。彼修身耶。答如是。若修身。彼修心耶。答诸修心。彼修身。有修身非修心。谓已离色染。未离无色染。若修身。彼修慧耶。若诸修慧。彼修身。有修身非修慧。如前说。若修戒。彼修心耶。答诸修心。彼修戒。有修戒非修心。如前说。若修戒。彼修慧耶。答诸修慧。彼修戒。有修戒非修慧。如前说。若修心。彼修慧耶。答如是。设修慧。彼修心耶。答如是

若成就过去戒。彼成就未来现在此类戒耶。答有成就过去戒非未来现在此类戒。谓表戒已灭不失。此类戒不现前。有及未来非现在。谓静虑无漏戒已灭不失。此类戒不现前。有及现在非未来。谓表戒已灭不失。此类戒现前。有及未来现在。谓静虑无漏戒已灭不失。此类戒现前

若成就未来戒。彼成就过去现在此类戒耶。答有成就未来戒非过去现在此类戒。谓阿罗汉生无色界。有及过去非现在。谓静虑无漏戒已灭不失。此类戒不现前。有及现在非过去。谓无漏戒初现前。有及过去现在。谓静虑无漏戒。已灭不失。此类戒现前。若成就现在戒。彼成就过去未来此类戒耶。答有成就现在戒非过去未来此类戒。谓表戒初现。前有及过去非未来。谓表戒已灭不失。此类戒现前。有及未来非过去。谓无漏戒初现前。有及过去未来。谓静虑无漏戒。已灭不失。此类戒现前

    业蕴第四中自业纳息第五

  自业义世成　　对异熟成堕
  智谋害留舍　　心乱缠佛教
  书数算印诗　　世间工业处
  成就学等戒　　此章愿具说

云何自业。答若业已得今有异熟。及业异熟已生正受。自业是何义。答是得自果自等流自异熟义。复次此业所招异熟。于自相续。现熟非余。于自相续。养随养。育随育。护随护。转随转。益随益。故名自业

若业是自业。此业当言过去耶未来耶现在耶。答此业当言过去。

若业是自业。此业成就耶。答应作四句。有业是自业此业不成就。谓业已得。今有异熟。及业异熟已生正受。此业已失。有业成就此业非自业。谓业非已得今有异熟。及业异熟。非已生正受。此业不失。有业是自业此业亦成就。谓业已得今有异熟。及业异熟已生正受。此业不失。有业非自业此业不成就。谓业非已得今有异熟。及业异熟非已生正受。此业已失非亦有。四句与前相违应广说

若业是自业。此业定当受异熟耶。答应作四句。有业是自业。此业定当不受异熟。谓业已得今有异熟。及业异熟已生正受已。至最后位。有业定当受异熟。此业非自业。谓业非已得今有异熟。及业异熟非已生正受。此业异熟未熟。有业是自业此业定当受异熟。谓业已得今有异熟。及业异熟已生正受。未至最后位。有业非自业此业定当不受异熟。谓业非已得今有异熟。及业异熟非已生正受此业异熟已熟。非亦有四句。与前相违。应广说。若业成就。此业定当受异熟耶。答应作四句。有业成就此业定当不受异熟。谓业过去不善善有漏异熟。已熟。此业不失。若业未来不善善有漏已得。而定不生。若业无记无漏成就。有业定当受异熟此业不成就。谓业过去不善善有漏异熟未熟。此业已失。若业未来不善善有漏不得。而定当生。有业成就此业定当受异熟。谓业过去不善善有漏异熟未熟。此业不失。若业未来不善善有漏已得。亦定当生。若业现在不善善有漏有业不成就此业定当不受异熟。谓业过去不善善有漏异熟已熟。此业已失。若业未来不善善有漏不得。亦定不生。若业无记无漏不成就。非亦有四句。与前相违应广说

若预流者。有不善业。能顺苦受。异熟未熟。彼既成熟。应堕恶趣。何道障故而不堕耶。答由二部结缚诸有情令堕恶趣。谓见所断修所断结。诸预流者。虽未永断修所断结。而已永断见所断结。阙一资粮。不堕恶趣。如车具二轮有所运载。鸟有二翼能飞虚空。阙一不然。此亦如是

如世尊说。我圣弟子。应自审记已尽地狱傍生饿鬼崄恶趣坑。诸预流者。为有现智能自审知尽地狱等而自记耶。答不能。若尔彼云何知。答信佛语故。谓世尊说。若有多闻诸圣弟子。能随观察。见自身中。有四证净现在前者。应自审记已尽地狱傍生饿鬼险恶趣坑。又预流者。已得四智。谓苦集灭道智。未得尽智无生智。故

如世尊说。由学谋害那伽谛观却后七日憍萨罗家。必当殄灭。云何学谋害。答如有学者。未离欲染。他加害时。便作念言。当令衰坏母失爱子。又如学者。已离欲染。他加害时。从离欲退。作是念言。当令衰坏母失爱子

诸学谋害。必果遂耶。答此不决定。若诸有情。造作增长大威势业异熟现前。便不果遂

云何苾刍留多寿行。答谓阿罗汉。成就神通得心自在。若于僧众若别人所。以衣以钵。或以随一沙门命缘众具布施。施已发愿。即入边际第四静虑。从定起已。心念口言。诸我能感富异熟业。愿此转招寿异熟果。时彼能招富异熟业。则转能招寿异熟果

云何苾刍舍多寿行。答谓阿罗汉。成就神通。得心自在。如前布施。施已发愿。即入边际第四静虑。从定起已。心念口言。诸我能感寿异熟业。愿此转招富异熟果。时彼能招寿异熟业。则转能招富异熟果

云何心狂乱。答谓由四缘势力所逼。令心狂乱。一由非人现恶色像遇已惊恐。令心狂乱。二由非人忿打支节苦受所逼。令心狂乱。三由大种乖违。令心狂乱。四由先业异熟。令心狂乱何缠相应法。皆不善耶。答无惭无愧。佛教云何。答谓佛语言评论唱词语路语音语业语表。是谓佛教。佛教当言善耶无记耶。答或善。或无记。云何善。谓佛善心所发语言。乃至语表。云何无记。谓佛无记心所发语言。乃至语表

佛教名何法。答名身句身文身。次第行列。次第安布。次第连合

契经应颂记说伽他自说因缘譬喻本事本生方广希法。论议名何法。答名身句身文身。次第行列。次第安布。次第连合。书名何法。答如理转变身业及此所依诸巧便智。数名何法。答如理转变意业及此所依诸巧便智。算名何法。答如理转变语业及此所依诸巧便智。印名何法。答如理转变身业及此所依诸巧便智。诗名何法。答如理转变语业及此所依诸巧便智。世间种种工巧业处。名何法。答谓慧为先造作彼彼工巧业处。及此所依诸巧便智

若成就学戒。彼成就非学非无学戒耶。答应作四句。有成就学戒非非学非无学戒。谓学者生无色界。有成就非学非无学戒非学戒。谓阿罗汉。及诸异生。生欲色界。有成就学戒亦非学非无学戒。谓学者生欲色界。有非成就学戒亦非非学非无学戒。谓阿罗汉。及诸异生。生无色界

若成就无学戒。彼成就非学非无学戒耶。答应作四句。有成就无学戒非非学非无学戒。谓阿罗汉。生无色界。有成就非学非无学戒非无学戒。谓诸学者。及诸异生。生欲色界。有成就无学戒亦非学非无学戒。谓阿罗汉。生欲色界。有非成就无学戒亦非非学非无学戒。谓诸学者。及诸异生。生无色界

说一切有部发智论卷第十二阿毗达磨发智论卷第十三

        尊者迦多衍尼子造

        三藏法师玄奘奉　诏译

    大种蕴第五中大造纳息第一

  大种所造处　　几四二五三
  大造成不成　　成大对造四
  唯成所造四　　大种等七种
  依定灭住果　　此章愿具说

大种所造处。几有见。答一。几无见。答八二少分。几有对。答九一少分。几无对。答一少分。几有漏。答九二少分。几无漏。答一少分。几有为。答九二少分。几无为。答无。几过去。答十一少分。几未来。答十一少分。几现在。答十一少分。几善。答三少分。几不善。答三少分。几无记。答七三少分。几欲界系。答二九少分。几色界系。答九少分。几无色界系。答无。几学。答一少分。几无学。答一少分。几非学非无学。答九一少分。几见所断。答无。几修所断。答九二少分。几不断。答一少分

若成就大种。彼成就所造色耶。答诸成就大种。彼定成就所造色。有成就所造色非大种谓圣者生无色界。若不成就大种。彼不成就所造色耶。答诸不成就所造色。彼不成就大种。有不成就大种非所造色。谓圣者生无色界

若成就大种。彼成就善色耶。答应作四句。有成就大种非善色。谓处卵[穀-禾+卵]。若异生住胎若生欲界。住不律仪及非律仪非不律仪。无善身语表。设有而失。有成就善色非大种。谓圣者生无色界。有成就大种亦善色。谓圣者住胎若生欲界。住律仪。若住不律仪及非律仪非不律仪。现有善身语表。或先有不失。若生色界。有非成就大种及善色。谓异生生无色界

若成就大种。彼成就不善色耶。答诸成就不善色。彼定成就大种。有成就大种非不善色。谓处卵[穀-禾+卵]。及住胎中。若生欲界。住律仪及非律仪非不律仪。无不善身语表。设有而失。若生色界。若成就大种。彼成就有覆无记色耶。答诸成就有覆无记色。彼定成就大种。有成就大种非有覆无记色。谓生欲界。若生色界。现无有覆无记身语表。若成就大种。彼成就无覆无记色耶。答如是。设成就无覆无记色。彼成就大种耶。答如是。若成就大种。彼成就善不善色耶。答有成就大种非善不善色。谓处卵[穀-禾+卵]。若异生住胎若生欲界。住非律仪非不律仪。无善不善身语表。设有而失。有成就大种亦善色非不善色。谓圣者住胎若生欲界。住律仪。无不善身语表设有而失。若住非律仪非不律仪。现有善身语表。或先有不失。无不善身语表。设有而失。若生色界。有成就大种亦不善色非善色。谓生欲界。住不律仪。无善身语表。设有而失。若住非律仪非不律仪。现有不善身语表。或先有不失。无善身语表。设有而失。有成就大种亦善不善色。谓生欲界住律仪。现有不善身语表。或先有不失。若住不律仪。现有善身语表。或先有不失。若住非律仪非不律仪。现有善不善身语表。或先有不失。设成就善不善色。彼成就大种耶。答如是

若成就大种。彼成就善有覆无记色耶。答有成就大种非善有覆无记色。谓处卵[穀-禾+卵]。若异生住胎。若生欲界。住不律仪及非律仪非不律仪。无善身语表。设有而失。有成就大种亦善色非有覆无记色。谓圣者住胎。若生欲界住律仪。若住不律仪及非律仪非不律仪。现有善身语表。或先有不失。若生色界。现无有覆无记身语表。有成就大种亦善有覆无记色。谓生色界。现有有覆无记身语表。设成就善有覆无记色。彼成就大种耶。答如是。若成就大种。彼成就善无覆无记色耶。答有成就大种亦无覆无记色非善色。谓处卵[穀-禾+卵]。若异生住胎。若生欲界。住不律仪及非律仪非不律仪。无善身语表。设有而失。有成就大种亦善无覆无记色。谓圣者住胎若生欲界。住律仪。若住不律仪及非律仪非不律仪。现有善身语表。或先有不失。若生色界。设成就善无覆无记色。彼成就大种耶。答如是

若成就大种。彼成就不善有覆无记色耶。答无

若成就大种。彼成就不善无覆无记色耶。答有成就大种亦无覆无记色非不善色。谓处卵[穀-禾+卵]。及住胎中。若生欲界。住律仪及非律仪非不律仪。无不善身语表。设有而失。若生色界。有成就大种亦不善无覆无记色。谓生欲界。住不律仪。若住律仪及非律仪非不律仪。现有不善身语表。或先有不失。设成就不善无覆无记色。彼成就大种耶。答如是

若成就大种。彼成就有覆无记无覆无记色耶。答有成就大种亦无覆无记色非有覆无记色。谓生欲界。若生色界。现无有覆无记身语表。有成就大种亦有覆无记无覆无记色。谓生色界。现有有覆无记身语表。设成就有覆无记无覆无记色。彼成就大种耶。答如是。若成就大种。彼成就善不善有覆无记色耶。答无

若成就大种。彼成就善不善无覆无记色耶。答有成就大种亦无覆无记色非善不善色。谓处卵[穀-禾+卵]。若异生住胎。若生欲界。住非律仪非不律仪。无善不善身语表。设有而失。有成就大种亦善无覆无记色非不善色。谓圣者住胎若生欲界。住律仪。无不善身语表。设有而失。若住非律仪非不律仪。现有善身语表。或先有不失。无不善身语表。设有而失。若生色界。有成就大种亦不善无覆无记色非善色。谓生欲界。住不律仪。无善身语表。设有而失。若住非律仪非不律仪。现有不善身语表。或先有不失。无善身语表。设有而失。有成就大种亦善不善无覆无记色。谓生欲界。住律仪。现有不善身语表。或先有不失。若住不律仪。现有善身语表。或先有不失。若住非律仪非不律仪。现有善不善身语表。或先有不失。设成就善不善无覆无记色。彼成就大种耶。答如是

若成就大种。彼成就善有覆无记无覆无记色耶。答有成就大种亦无覆无记色非善有覆无记色。谓处卵[穀-禾+卵]。若异生住胎。若生欲界。住不律仪及非律仪非不律仪。无善身语表。设有而失。有成就大种亦善无覆无记色非有覆无记色。谓圣者住胎。若生欲界住律仪。若住不律仪及非律仪非不律仪。现有善身语表。或先有不失。若生色界。现无有覆无记身语表。有成就大种亦善有覆无记无覆无记色。谓生色界。现有有覆无记身语表。设成就善有覆无记无覆无记色。彼成就大种耶。答如是

若成就大种。彼成就不善有覆无记无覆无记色耶。答无

若成就大种。彼成就善不善有覆无记无覆无记色耶。答无

若成就善色。彼成就不善色耶。答应作四句。有成就善色非不善色。谓圣者住胎。若生欲界住律仪。无不善身语表。设有而失。若住非律仪非不律仪。现有善身语表。或先有不失。无不善身语表。设有而失。若生色界。若圣者生无色界。有成就不善色非善色。谓生欲界。住不律仪。无善身语表。设有而失。若住非律仪非不律仪。现有不善身语表。或先有不失。无善身语表。设有而失。有成就善色亦不善色。谓生欲界。住律仪。现有不善身语表。或先有不失。若住不律仪。现有善身语表。或先有不失。若住非律仪非不律仪。现有善不善身语表。或先有不失。有非成就善色及不善色。谓处卵[穀-禾+卵]。若异生住胎。若生欲界。住非律仪非不律仪。无善不善身语表。设有而失。若异生生无色界

若成就善色。彼成就有覆无记色耶。答诸成就有覆无记色。彼定成就善色。或成就善色非有覆无记色。谓圣者住胎若生欲界。住律仪。若住不律仪及非律仪非不律仪。现有善身语表。或先有不失。若生色界。现无有覆无记身语表。若圣者生无色界

若成就善色。彼成就无覆无记色耶。答应作四句。有成就善色非无覆无记色。谓圣者生无色界。有成就无覆无记色非善色。谓处卵[穀-禾+卵]。若异生住胎。若生欲界。住不律仪及非律仪非不律仪。无善身语表。设有而失。有成就善色。亦无覆无记色。谓圣者住胎。若生欲界住律仪。若住不律仪及非律仪非不律仪。现有善身语表。或先有不失。若生色界。有非成就善色及无覆无记色。谓异生生无色界

若成就善色。彼成就不善有覆无记色耶。答无。若成就善色。彼成就不善无覆无记色耶。答有成就善色非不善无覆无记色。谓圣者生无色界。有成就善色亦无覆无记色非不善色。谓圣者住胎若生欲界住律仪。无不善身语表。设有而失。若住非律仪非不律仪。现有善身语表。或先有不失。无不善身语表。设有而失。若生色界。有成就善色亦不善无覆无记色。谓生欲界住律仪。现有不善身语表。或先有不失。若住不律仪。现有善身语表。或先有不失。若住非律仪非不律仪。现有善不善身语表。或先有不失。设成就不善无覆无记色。彼成就善色耶。答或成就。或不成就。云何成就。即如上说。云何不成就。谓生欲界。住不律仪。无善身语表。设有而失。若住非律仪非不律仪。现有不善身语表。或先有不失。无善身语表。设有而失。若成就善色。彼成就有覆无记无覆无记色耶。答有成就善色非有覆无记无覆无记色。谓圣者生无色界。有成就善色亦无覆无记色非有覆无记色。谓圣者住胎。若生欲界住律仪。若住不律仪及非律仪非不律仪。现有善身语表。或先有不失。若生色界。现无有覆无记身语表。有成就善色亦有覆无记无覆无记色。谓生色界。现有有覆无记身语表。设成就有覆无记无覆无记色。彼成就善色耶答如是

若成就善色。彼成就不善有覆无记无覆无记色耶。答无

若成就不善色。彼成就有覆无记色耶。答无。若成就不善色。彼成就无覆无记色耶。答诸成就不善色。彼定成就无覆无记色。有成就无覆无记色非不善色。谓处卵[穀-禾+卵]。及住胎中。若生欲界。住律仪及非律仪非不律仪。无不善身语表。设有而失。若生色界

若成就不善色。彼成就有覆无记无覆无记色耶。答无

若成就有覆无记色。彼成就无覆无记色耶。答诸成就有覆无记色。彼成就无覆无记色。有成就无覆无记色非有覆无记色。谓生欲界若生色界。现无有覆无记身语表

诸四大种。及所造色。依何定灭。答依四定。或依未至灭。寻伺有对触。依何定灭。答依初定。或依未至灭。乐根依何定灭。答依三定。或依未至。灭喜根依何定灭。答依二定。或依未至灭。苦根忧根段食依何定灭。答依未至灭。舍根触思识食依何定灭。答依七定。或依未至灭。诸四大种。及所造色寻伺有对触乐根喜根。已断已遍知。当言住何果。答阿罗汉果。或无所住。苦根忧根段食。已断已遍知。当言住何果。答不还果。或阿罗汉果。或无所住。舍根触思识食。已断已遍知。当言住何果。答阿罗汉果

    大种蕴第五中缘纳息第二

  大造心处根　　相对缘有几
  相应造三世　　世界辩成缘
  大种与造色　　界世为同异
  四体摄识门　　此章愿具说

大种与大种为几缘。答因增上。大种与造色。为几缘。答因增上造色与造色。为几缘。答因增上。造色与大种。为几缘。答因增上。大种与心心所法。为几缘。答所缘增上。心心所法。与心心所法。为几缘。答因等无间所缘增上。心心所法。与大种。为几缘。答因增上。大种与眼处。为几缘。答因增上。眼处与眼处为。几缘。答因增上。眼处与大种。为几缘。答一增上。如眼处。耳鼻舌身香味处亦尔。大种与色处。为几缘。答因增上。色处与色处。为几缘。答因增上。色处与大种。为几缘。答因增上。如色处。声触处亦尔。大种与意处。为几缘。答所缘增上。意处与意处。为几缘。答因等无间所缘增上。意处与大种。为几缘。答因增上。大种与法处。为几缘。答因所缘增上。法处与法处。为几缘。答因等无间所缘增上。法处与大种。为几缘。答因增上。大种与眼根。为几缘。答因增上。眼根与大种。为几缘。答一增上。如眼根。耳鼻舌身男女根亦尔。大种与命根。为几缘。答一增上。命根与大种。为几缘。答一增上。大种与意根。为几缘。答所缘增上。意根与大种。为几缘。答因增上。如意根。乐苦喜忧舍信精进念定慧根亦尔。大种与未知当知根。为几缘。答所缘增上。未知当知根与大种。为几缘。答一增上。如未知当知根。已知根具知根亦尔

何故四大种一生一住一灭而不相应。心心所法。一生一住一灭。说名相应。答如四大种。或减或增。心心所法。则不如是。又心心所法。皆有所缘。四大种无所缘。非无所缘法可说相应。颇有过去大种。造过去色耶。造未来色耶。造现在色耶。答皆有。颇有未来大种造未来色耶。造过去色耶。造现在色耶。答未来有。过现无。颇有现在大种。造现在色耶造过去色耶造未来色耶。答现未有。过去无

若成就过去大种。彼成就过去造色耶。答无成就过去大种。有成就过去造色。谓圣者住胎。若生欲界。住律仪。若住不律仪。及住非律仪非不律仪。先有身语表不失若生色界。若诸学者生无色界。若成就过去大种。彼成就未来大种耶。答无成就过去未来大种。若成就过去大种。彼成就未来造色耶。答无成就过去大种。有成就未来造色。谓圣者住胎若生欲界。得色界善心。若生色界。若圣者生无色界。若成就过去大种。彼成就现在大种耶。答无成就过去大种。有成就现在大种。谓生欲色界。若成就过去大种。彼成就现在造色耶。答无成就过去大种。有成就现在造色。谓生欲色界。若成就过去造色。彼成就未来大种耶。答无成就未来大种。有成就过去造色。谓圣者住胎。若生欲界。住律仪。若住不律仪。若住非律仪非不律仪。先有身语表不失。若生色界。若学者生无色界。若成就过去造色。彼成就未来造色耶。答应作四句。有成就过去造色。非未来造色。谓生欲界。住律仪。不得色界善心。若住不律仪。若住非律仪非不律仪。先有身语表不失。有成就未来造色非过去造色。谓阿罗汉生无色界。有成就过去造色亦未来造色。谓圣者住胎。若生欲界。得色界善心。若生色界。若学者生无色界。有非成就过去造色亦非未来造色。谓处卵[穀-禾+卵]。若异生住胎。若生欲界。住非律仪非不律仪。先无身语表。设有而失。若异生生无色界。若成就过去造色。彼成就现在大种耶。答应作四句。有成就过去造色非现在大种。谓学者生无色界。有成就现在大种非过去造色。谓处卵[穀-禾+卵]。若异生住胎若生欲界。住非律仪非不律仪。先无身语表。设有而失。有成就过去造色亦现在大种。谓圣者住胎。若生欲界。住律仪。若住不律仪。若住非律仪非不律仪。先有身语表不失。若生色界。有非成就过去造色亦非现在大种。谓阿罗汉。若异生生无色界。若成就过去造色。彼成就现在造色耶。答应作四句。有成就过去造色非现在造色。谓学者生无色界。有成就现在造色非过去造色。谓处卵[穀-禾+卵]。若异生住胎若生欲界。住非律仪非不律仪。先无身语表。设有而失。有成就过去造色亦现在造色。谓圣者住胎。若生欲界住律仪。若住不律仪。若住非律仪非不律仪。先有身语表不失。若生色界。有非成就过去造色亦非现在造色。谓阿罗汉。若异生。生无色界

若成就未来大种。彼成就未来造色耶。答无成就未来大种。有成就未来造色。谓圣者住胎。若生欲界。得色界善心若生色界。若圣者生无色界。若成就未来大种。彼成就现在大种耶。答无成就未来大种。有成就现在大种。谓生欲色界。若成就未来大种。彼成就现在造色耶。答无成就未来大种。有成就现在造色。谓生欲色界。若成就未来造色。彼成就现在大种耶。答应作四句。有成就未来造色非现在大种。谓圣者生无色界。有成就现在大种非未来造色。谓处卵[穀-禾+卵]。若异生住胎若生欲界。不得色界善心。有成就未来造色亦现在大种。谓圣者住胎若生欲界。得色界善心。若生色界。有非成就未来造色亦非现在大种。谓异生生无色界。若成就未来造色。彼成就现在造色耶。答应作四句。有成就未来造色非现在造色。谓圣者生无色界。有成就现在造色非未来造色。谓处卵[穀-禾+卵]。若异生住胎。若生欲界不得色界善心。有成就未来造色亦现在造色。谓圣者住胎若生欲界。得色界善心。若生色界。有非成就未来造色亦非现在造色。谓异生生无色界

若成就现在大种。彼成就现在造色耶。答如是。设成就现在造色。彼成就现在大种耶。答如是

过去大种。与过去大种。为几缘。答因增上。过去大种。与过去造色。为几缘。答因增上。过去造色。与过去造色。为几缘。答因增上。过去造色。与过去大种。为几缘。答因增上。过去大种。与未来大种。为几缘。答因增上。未来大种。与未来大种。为几缘。答因增上。未来大种。与过去大种。为几缘。答一增上。过去大种。与未来造色。为几缘。答因增上。未来造色。与未来造色。为几缘。答因增上。未来造色。与过去大种。为几缘。答一增上。过去大种。与现在大种。为几缘。答因增上。现在大种。与现在大种。为几缘。答因增上。现在大种。与过去大种。为几缘。答一增上。过去大种。与现在造色。为几缘。答因增上。现在造色。与现在造色。为几缘。答因增上。现在造色。与过去大种。为几缘。答一增上。过去造色。与未来大种。为几缘。答因增上。未来大种。与过去造色。为几缘。答一增上。过去造色。与未来造色。为几缘。答因增上。未来造色。与过去造色。为几缘。答一增上。过去造色。与现在大种。为几缘。答因增上。现在大种。与过去造色。为几缘。答一增上。过去造色。与现在造色。为几缘。答因增上。现在造色。与过去造色。为几缘。答一增上

未来大种。与未来造色。为几缘。答因增上。未来造色。与未来大种。为几缘。答因增上。未来大种。与现在大种。为几缘。答一增上。现在大种。与未来大种。为几缘。答因增上。未来大种。与现在造色。为几缘。答一增上。现在造色。与未来大种。为几缘。答因增上。未来造色。与现在大种。为几缘。答一增上。现在大种。与未来造色。为几缘。答因增上。未来造色。与现在造色。为几缘。答一增上。现在造色。与未来造色。为几缘。答因增上

现在大种。与现在造色。为几缘。答因增上。现在造色。与现在大种。为几缘。答因增上

若成就欲界系大种。彼成就欲界系造色耶。答如是。设成就欲界系造色。彼成就欲界系大种耶。答如是。若成就欲界系大种。彼成就色界系大种耶。答应作四句。有成就欲界系大种非色界系大种。谓生欲界。色界大种。不现在前。有成就色界系大种非欲界系大种。谓生色界。不作欲界化。不发欲界语。有成就欲界系大种亦色界系大种。谓生欲界。色界大种。现在前。若生色界。作欲界化。发欲界语。有非成就欲界系大种及色界系大种。谓生无色界。若成就欲界系大种。彼成就色界系造色耶。答应作四句。有成就欲界系大种非色界系造色。谓生欲界。不得色界善心。有成就色界系造色非欲界系大种。谓生色界。不作欲界化。不发欲界语。有成就欲界系大种亦色界系造色。谓生欲界。得色界善心。若生色界。作欲界化。发欲界语。有非成就欲界系大种及色界系造色。谓生无色界

若成就欲界系造色。彼成就色界系大种耶。答应作四句。有成就欲界系造色非色界系大种谓生欲界。色界大种。不现在前。有成就色界系大种非欲界系造色。谓生色界。不作欲界化。不发欲界语。有成就欲界系造色亦色界系大种。谓生欲界。色界。大种。现在前。若生色界。作欲界化。发欲界语。有非成就欲界造色及色界大种。谓生无色界

若成就欲界系造色。彼成就色界系造色耶。答应作四句。有成就欲界系造色非色界系造色。谓生欲界。不得色界善心。有成就色界系造色非欲界系造色。谓生色界。不作欲界化。不发欲界语。有成就欲界系。造色亦色界系造色。谓生欲界。得色界善心。若生色界作欲界化。发欲界语。有非成就欲界系造色及色界系造色。谓生无色界

若成就色界系大种。彼成就色界系造色耶。答诸成就色界系大种。彼定成就色界系造色。有成就色界系造色非色界系大种。谓生欲界。得色界善心。色界大种。不现在前

欲界系大种。与欲界系大种。为几缘。答因增上。欲界系大种。与欲界系造色。为几缘。答因增上。欲界系造色。与欲界系造色。为几缘。答因增上。欲界系造色。与欲界系大种。为几缘。答因增上。欲界系大种。与色界系大种。为几缘。答一增上。色界系大种。与色界系大种。为几缘。答因增上。色界系大种。与欲界系大种。为几缘。答一增上。欲界系大种。与色界系造色。为几缘。答一增上。色界系造色。与色界系造色。为几缘。答因增上。色界系造色。与欲界系大种。为几缘。答一增上。欲界系造色。与色界系大种。为几缘。答一增上。色界系大种。与欲界系造色。为几缘。答一增上。欲界系造色。与色界系造色。为几缘。答一增上。色界系造色。与欲界系造色。为几缘。答一增上。色界系大种。与色界系造色。为几缘。答因增上。色界系造色。与色界系大种。为几缘答因增上

诸色欲界系。彼色一切欲界系大种造耶。答应作四句。有色欲界系非欲界系大种造。谓欲界系大种。有色欲界系大种造非欲界系。谓色不系欲界系大种造。有色欲界系欲界系大种造。谓色欲界系欲界系大种造。有色非欲界系非欲界系大种造。谓色界系大种。若色色界系色界系大种造。若色不系色界系大种造诸色色界系。彼色一切色界系大种造耶。答应作四句。有色色界系非色界系大种造。谓色界系大种。有色色界系大种造非色界系。谓色不系色界系大种造。有色色界系色界系大种造。谓色色界系色界系大种造。有色非色界系非色界系大种造。谓欲界系大种。若色欲界系欲界系大种造。若色不系欲界系大种造

诸色过去。彼色一切过去大种造耶。答应作四句。有色过去非过去大种造。谓过去大种。有色过去大种造非过去。谓色未来现在过去。大种造。有色过去过去大种造。谓色过去。过去大种造。有色非过去非过去大种造。谓未来现在大种。若色未来现在现在大种造。若色未来未来大种造。诸色未来。彼色一切未来大种造耶。答诸色未来大种造。彼色一切未来。有色未来非未来大种造。谓未来大种。若色未来过去现在大种造诸色现在。彼色一切现在大种造耶。答应作四句。有色现在非现在大种造。谓现在大种。若色现在过去大种所造。有色现在大种造非现在。谓色未来现在大种造。有色现在现在大种造。谓色现在现在大种造。有色非现在非现在大种造。谓过去未来大种。若色过去未来过去大种造。若色未来未来大种造

地云何。答显形色。地界云何。答坚性触。水云何。答显形色。水界云何。答湿性触。火云何。答显形色。火界云何。答暖性触。风云何。答即风界。风界云何。答动性触

地水火风。几处所摄。几识所识。答地水火。一处摄。谓色处。二识识。谓眼识意识。风一处摄。谓触处。二识识。谓身识意识。地水火风界。几处摄。几识识。答一处摄。谓触处。二识识。谓身识意识

    大种蕴第五中具见纳息第三

  六色何大造　　三色孰为因
  化九中有七　　世劫心三分
  缘因缘各四　　无色除色想
  互摄四七九　　此章愿具说

已具见谛世尊弟子。未离欲染所成就色界系身语业色。何大种造。答色界系。生欲界入有漏四静虑身语业色。何大种造。答色界系。生欲界入无漏四静虑身语业色。何大种造。答欲界系。生色界入有漏四静虑身语业色。何大种造。答色界系。生色界入无漏四静虑身语业色。何大种造。答色界系。世尊弟子。生无色界。所成就无漏身语业色。何大种造。答或欲界系。或色界系

无色界没生欲界。最初所得诸根大种。何大种为因。答欲界系。无色界没生色界。最初所得诸根大种。何大种为因。答色界系。色界没生欲界。最初所得诸根大种。何大种为因。答欲界系。生欲界。作色界化。发色界语。彼身语色。何大种造。答色界系。生色界。作欲界化。发欲界语。彼身语色。何大种造。答欲界系。化当言有大种无大种耶。答当言有大种。化当言有造色无造色耶。答当言有造色。化当言有心无心耶。答当言无心。化当言谁心所转耶。答当言化主

中有当言有大种无大种耶。答当言有大种。中有当言有造色无造色耶。答当言有造色。中有当言有心无心耶。答当言有心。中有当言谁心所转耶。答当言自心。世名何法。答此增语所显行。劫名何法。答此增语所显半月月时年心起住灭。分名何法。答此增语所显刹那腊缚牟呼栗多

颇有法四缘生耶。答有。谓一切心心所法。颇有法三缘生耶。答有。谓无想等至灭尽等至。颇有法二缘生耶。答有。谓除无想灭尽等至诸余心不相应行。及一切色。颇有法一缘生耶。答无

云何因相应法。答一切心心所法。云何因不相应法。答色无为。心不相应行。云何因相应。因不相应法。答即心心所法。少分因相应。少分因不相应。云何非因相应。非因不相应法。答即心心所法。少分非因相应。少分非因不相应

云何缘有缘法。答若意识。并相应法。缘心心所法。云何缘无缘法。答五识身。并相应法。若意识。并相应法。缘色无为心不相应行。云何缘有缘缘无缘法。答若意识。并相应法。缘心心所法。及色无为。心不相应行。云何非缘有缘非缘无缘法。答色无为。心不相应行

如世尊说。内无色想观外色。云何内无色想观外色耶。答谓有苾刍。起如是胜解。今我此身将死。已死。将上舆。已上舆。将往冢间。已往冢间。将置地。已置地。将为种种虫食。已为种种虫食。彼于最后。不见内身。唯见外虫。复有苾刍。起如是胜解。今我此身将死。已死。将上舆。已上舆。将往冢间。已往冢间。将置薪[卄/積]。已置薪[卄/積]。将为火焚。已为火焚。彼于最后。不见内身。唯见外火。复有苾刍。起如是胜解。今我此身甚为虚伪。如雪或雪抟。如沙糖。或沙糖抟。如生熟酥。或生熟酥抟。将为火炙。已为火炙。将融销。已融销。彼于最后。不见内身。唯见外火。是名内无色想观外色

如世尊说。有除色想。云何除色想耶。答谓有苾刍。起如是胜解。今我此身。将死已死。将上舆已上舆。将往冢间已往冢间。将置地已置地。将为种种虫食已为种种虫食。此种种虫。将散已散。彼于最后。不见自身。亦不见虫。复有苾刍。起如是胜解。今我此身。将死已死。将上舆已上舆。将往冢间已往冢间将置薪[卄/積]已置薪[卄/積]。将为火焚已为火焚。此焚尸火。将灭已灭。彼于最后。不见自身。亦不见火。复有苾刍。起如是胜解。今我此身。甚为虚伪。如雪或雪抟。如生酥。或生酥抟。如熟酥。或熟酥抟。将为火炙已为火炙。将融销已融销。此能销火。将灭已灭。彼于最后。不见自身。亦不见火。是名除色想。诸无除色想。皆未离色染耶。答诸未离色染。皆无除色想。有无除色想非未离色染。谓已离色染。而未入彼定。诸有除色想。皆已离色染耶。答诸有除色想。皆已离色染。有已离色染。非有除色想。谓已离色染。而未入彼定

四识住。七识住。为四摄七七摄四耶。答应作四句。有四非七。谓地狱傍生鬼界广果色受想行。及非想非非想处受想行。有七非四。谓人欲界天梵众极光净遍净空无边处识无边处无所有处心。有亦四亦七。谓人欲界天梵众极光净遍净色受想行。及空无边处识无边处无所有处受想行。有非四非七。谓地狱傍生鬼界广果非想非非想处心

四识住。九有情居。为四摄九九摄四耶。答应作四句。有四非九。谓地狱傍生鬼界无想天所不摄广果色受想行。有九非四。谓人欲界天梵众极光净遍净无想天四无色心。有亦四亦九。谓人欲界天梵众极光净遍净无想天色受想行。及四无色受想行。有非四非九。谓地狱傍生鬼界无想天所不摄广果心

七识住。九有情居。为七摄九九摄七耶。答九摄七。非七摄九。何所不摄。答二处。谓无想天处。及非想非非想处

说一切有部发智论卷第十三阿毗达磨发智论卷第十四

        尊者迦多衍尼子造

        三藏法师玄奘奉　诏译

    大种蕴第五中执受纳息第四

  十七对几缘　　对自他有八
  唯对他有九　　八何义内外
  八门受相摄　　九位十五门
  现在未来修　　此章愿具说

有执受大种。与有执受大种。为几缘。答因增上。有执受大种。与无执受大种。为几缘。答因增上。无执受大种。与无执受大种。为几缘。答因增上。无执受大种。与有执受大种。为几缘。答因增上。因相应法。与因相应法。为几缘。答因等无间所缘增上。因相应法。与因不相应法。为几缘。答因等无间增上。因不相应法。与因不相应法。为几缘。答因增上。因不相应法。与因相应法。为几缘。答因所缘增上。有所缘法。与有所缘法。为几缘。答因等无间所缘增上。有所缘法。与无所缘法。为几缘。答因等无间增上。无所缘法。与无所缘法。为几缘。答因增上。无所缘法。与有所缘法。为几缘。答因所缘增上。有色法。与有色法。为几缘。答因增上。有色法。与无色法。为几缘。答因所缘增上。无色法。与无色法。为几缘。答因等无间所缘增上。无色法。与有色法。为几缘。答因增上。有见法。与有见法。为几缘。答因增上。有见法。与无见法。为几缘。答因所缘增上。无见法。与无见法。为几缘。答因等无间所缘增上。无见法。与有见法。为几缘。答因增上。有对法。与有对法。为几缘。答因增上。有对法。与无对法。为几缘。答因所缘增上。无对法。与无对法。为几缘。答因等无间所缘增上。无对法。与有对法。为几缘。答因增上。有漏法。与有漏法。为几缘。答因等无间所缘增上。有漏法。与无漏法。为几缘。答等无间所缘增上。无漏法。与无漏法。为几缘。答因等无间所缘增上。无漏法。与有漏法。为几缘。答等无间所缘增上。有为法。与有为法。为几缘。答因等无间所缘增上。有为法。与无为法。为几缘。答无。无为法。与无为法。为几缘。答无。无为法。与有为法。为几缘。答所缘增上

诸缠所缠续地狱有最初所得诸根大种。彼诸根大种与彼心心所法。为几缘。答一增上。彼心心所法。与彼诸根大种。为几缘。答一增上。诸缠所缠续傍生有鬼有人有天有最初所得诸根大种。彼诸根大种。与彼心心所法。为几缘。答一增上。彼心心所法。与彼诸根大种。为几缘。答一增上。生欲界。入有漏初静虑乃至非想非非想处。长养诸根。增益大种。彼诸根大种。与彼心心所法。为几缘。答一增上。彼心心所法。与彼诸根大种。为几缘。答一增上。生欲界。入无漏初静虑乃至无所有处。长养诸根。增益大种。彼诸根大种。与彼心心所法。为几缘。答一增上。彼心心所法。与彼诸根大种。为几缘。答一增上。生色界。入有漏初静虑乃至非想非非想处。长养诸根。增益大种。彼诸根大种。与彼心心所法。为几缘。答一增上。彼心心所法。与彼诸根大种。为几缘。答一增上。生色界。入无漏初静虑乃至无所有处。长养诸根。增益大种。彼诸根大种。与彼心心所法。为几缘。答一增上。彼心心所法。与彼诸根大种。为几缘。答一增上

有执受是何义。答此增语所显堕自体法。无执受是何义。答此增语所显非堕自体法。顺取是何义。答此增语所显有漏法。非顺取是何义。答此增语所显无漏法。顺结是何义。答此增语所显有漏法。非顺结是何义。答此增语所显无漏法。见处是何义。答此增语所显有漏法。非见处是何义。答此增语所显无漏法

若法是内。彼法内处摄耶。答应作四句。有法是内非内处摄。如说于内受内法住循法观。有法内处摄非内。如说于外身外心住循心观。有法是内亦内处摄。如说于内身内心住循心观。有法非内非内处摄。如说于外受外法住循法观。若法是外。彼法外处摄耶。答应作四句。有法是外非外处摄。如说于外身外心住循心观。有法外处摄非外。如说于内受内法住循法观。有法是外亦外处摄。如说于外受外法住循法观。有法非外非外处摄。如说于内身内心住循心观

有二受。谓身受心受。有三受。谓乐受苦受不苦不乐受。为二摄三。三摄二耶。答互相摄。随其事二受如前说。有四受。谓三界系受。及不系受。为二摄四四摄二耶。答互相摄。随其事二受如前说。有五受。谓乐根苦根喜根忧根舍根。为二摄五五摄二耶。答互相摄。随其事二受如前说。有六受。谓眼触所生受。耳鼻舌身意触所生受。为二摄六六摄二耶。答互相摄。随其事二受如前说。有十八受。谓六喜意近行六忧意近行六舍意近行。为二摄十八十八摄二耶。答二摄十八。非十八摄二。何所不摄。谓有漏乐根苦根五识相应舍根。及无漏受。二受如前说。有三十六受。谓六依耽嗜喜。六依出离喜。六依耽嗜忧。六依出离忧。六依耽嗜舍。六依出离舍。为二摄三十六。三十六摄二耶。答二摄三十六。非三十六摄二。何所不摄。谓如前说。二受如前说。有百八受。谓依三世。各三十六。为二摄百八百八摄二耶。答二摄百八。非百八摄二。何所不摄。谓如前说三受四受。为三摄四四摄三耶。答互相摄。随其事三受五受六受。为三摄五六五六摄三耶。答互相摄。随其事三受十八受三十六受百八受。为三摄十八等十八等摄三耶。答三摄十八等。非十八等摄三。何所不摄。谓如前说四受五受六受。为四摄五六五六摄四耶。答互相摄。随其事四受十八受三十六受百八受。为四摄十八等十八等摄四耶。答四摄十八等。非十八等摄四。何所不摄。谓如前说五受六受。为五摄六六摄五耶。答互相摄。随其事五受十八受三十六受百八受。为五摄十八等十八等摄五耶。答五摄十八等。非十八等摄五。何所不摄。谓如前说六受十八受三十六受百八受。为六摄十八等十八等摄六耶。答六摄十八等。非十八等摄六。何所不摄。谓如前说十八受三十六受百八受。为十八摄三十六等二十六等摄十八耶。答互相摄。随其事三十六受百八受。为三十六摄百八百八摄三十六耶。答互相摄。随其事。以无间道。证预流果。修彼道时。四念住。几现在修。几未来修。四正断。四神足。五根五力。七觉支。八道支。四静虑。四无量。四无色。八解脱。八胜处。十遍处。八智三等持。几现在修。几未来修。答念住。现在一。未来四。正断神足。现在未来四。根力。现在未来五。觉支。现在未来六。道支。现在未来八。无静虑。无无量。无无色。无解脱。无胜处。无遍处。无智。等持。现在未来一。以无间道。证一来果。修彼道时。四念住。乃至三等持。几现在修。几未来修。答若倍离欲染入正性离生。修彼道时。念住。现在一。未来四。正断神足。现在未来四。根力。现在未来五。觉支现在未来六。道支。现在未来八。无静虑。无无量。无无色。无解脱。无胜处。无遍处。无智。等持。现在未来一。若从预流果。以世俗道。证一来果。修彼道时。念住。现在一。未来四。正断神足。现在未来四。根力。现在未来五。觉支。现在无。未来六。道支。现在无。未来八。无静虑。无无量。无无色。无解脱。无胜处。无遍处智。现在一未来七。等持。现在无。未来三。若从预流果。以无漏道。证一来果。修彼道时。念住。现在一。未来四。正断神足。现在未来四。根力。现在未来五。觉支。现在未来六。道支。现在未来八。无静虑。无无量。无无色。无解脱。无胜处。无遍处智。现在二。未来七。等持。现在一。未来三

以无间道。证不还果。修彼道时。四念住。乃至三等持。几现在修。几未来修。答若已离欲染。依未至定。入正性离生。修彼道时。念住。现在一。未来四。正断神足。现在未来四。根力。现在未来五。觉支。现在未来六。道支。现在未来八。无静虑。无无量。无无色。无解脱。无胜处。无遍处。无智。等持。现在未来一

若依初静虑。入正性离生。修彼道时。念住。现在一。未来四。正断神足。现在未来四。根力。现在未来五。觉支。现在未来七。道支。现在未来八。静虑。现在未来一。无无量。无无色。无解脱。无胜处。无遍处。无智。等持。现在未来一。若依静虑中间。入正性离生。修彼道时。念住。现在一。未来四。正断神足。现在未来四。根力。现在未来五。觉支。现在六。未来七。道支。现在七。未来八。静虑。现在无。未来一。无无量。无无色。无解脱。无胜处。无遍处。无智。等持。现在未来一。若依第二静虑。入正性离生。修彼道时。念住。现在一。未来四。正断神足。现在未来四。根力。现在未来五。觉支。现在未来七。道支。现在七。未来八。静虑。现在一。未来二。无无量。无无色。无解脱。无胜处。无遍处。无智。等持。现在未来一。若依第三静虑。入正性离生。修彼道时。念住。现在一。未来四。正断神足。现在未来四。根力。现在未来五。觉支。现在六。未来七。道支。现在七。未来八。静虑。现在一。未来三。无无量。无无色。无解脱。无胜处。无遍处。无智。等持。现在未来一。若依第四静虑。入正性离生。修彼道时。念住现在一。未来四。正断神足。现在未来四。根力。现在未来五。觉支。现在六。未来七。道支。现在七。未来八。静虑。现在一。未来四。无无量。无无色。无解脱。无胜处。无遍处。无智。等持。现在未来一。若从一来果。以世俗道。证不还果。修彼道时。念住。现在一。未来四。正断神足。现在未来四。根力。现在未来五。觉支。现在无。未来六。道支。现在无。未来八。无静虑。无无量。无无色。无解脱。无胜处。无遍处智。现在一。未来七。等持。现在无。未来三。若从一来果。以无漏道。证不还果。修彼道时。念住。现在一。未来四。正断神足。现在未来四。根力。现在未来五。觉支。现在未来六。道支。现在未来八。无静虑。无无量。无无色。无解脱。无胜处。无遍处智。现在二。未来七。等持。现在一。未来三

以无间道。证神境智通。修彼道时。四念住。乃至三等持。几现在修。几未来修。答若诸异生。依初静虑。修彼道时。念住。现在一。未来四。正断神足。现在未来四。根力。现在未来五。无觉支。无道支。静虑。现在未来一。无量。现在无。未来四。无无色解脱。现在无。未来二。胜处。现在无。未来四。无遍处智。现在未来一。无等持。若诸圣者。依初静虑。修彼道时。念住。现在一未来四。正断神足。现在未来四。根力。现在未来五。觉支。现在无。未来七。道支。现在无。未来八。静虑。现在未来一。无量。现在无。未来四。无无色解脱。现在无。未来二。胜处。现在无。未来四。无遍处智。现在一。未来七。等持。现在无。未来三。若诸异生。依第二静虑。修彼道时。念住。现在一。未来四。正断神足。现在未来四。根力。现在未来五。无觉支。无道支。静虑。现在未来一。无量。现在无。未来四。无无色。解脱。现在无。未来二。胜处。现在无。未来四。无遍处智。现在未来一。无等持。若诸圣者。依第二静虑。修彼道时。念住。现在一。未来四。正断神足。现在未来四。根力。现在未来五。觉支。现在无。未来七。道支。现在无。未来八。静虑。现在一。未来二。无量。现在无。未来四。无无色。解脱。现在无。未来二。胜处。现在无未来四。无遍处智。现在一。未来七。等持。现在无。未来三。若诸异生。依第三静虑。修彼道时。念住。现在一。未来四。正断神足。现在未来四。根力。现在未来五。无觉支。无道支。静虑。现在未来一。无量。现在无。未来三。无无色。无解脱。无胜处。无遍处智。现在未来一。无等持。若诸圣者。依第三静虑。修彼道时。念住。现在一。未来四。正断神足。现在未来四。根力。现在未来五。觉支。现在无。未来七。道支。现在无。未来八。静虑。现在一。未来三。无量。现在无。未来三。无无色。无解脱。无胜处。无遍处智。现在一。未来七。等持。现在无。未来三。若诸异生。依第四静虑。修彼道时。念住。现在一。未来四。正断神足。现在未来四。根力。现在未来五。无觉支。无道支。静虑。现在未来一。无量。现在无。未来三。无无色。解脱。现在无。未来一。胜处。现在无。未来四。遍处。现在无。未来八。智现在未来一。无等持。若诸圣者。依第四静虑。修彼道时。念住。现在一。未来四。正断神足。现在未来四。根力。现在未来五。觉支。现在无。未来七。道支。现在无。未来八。静虑。现在一。未来四。无量。现在无。未来三。无无色。解脱。现在无。未来一。胜处。现在无。未来四。遍处。现在无。未来八。智现在一。未来七。等持。现在无。未来三

以无间道。证天耳智通他心智通宿住随念智通死生智通。修彼道时。四念住。乃至三等持。几现在修。几未来修。答如神境智通。应随相说

以无间道。证漏尽智通。修彼道时。四念住。乃至三等持。几现在修。几未来修。答若依未至定。证阿罗汉果。修彼道时。念住。现在一。未来四。正断神足。现在未来四。根力。现在未来五。觉支现在六。未来七。道支。现在未来八。静虑。现在无。未来四。无无量。无色。现在无。未来三。解脱。现在无。未来三。无胜处。无遍处智。现在二。未来六。等持。现在一。未来三。若依初静虑。证阿罗汉果。修彼道时。念住。现在一。未来四。正断神足。现在未来四。根力。现在未来五。觉支。现在未来七。道支。现在未来八。静虑现在一。未来四。无无量。无色。现在无。未来三。解脱。现在无。未来三。无胜处。无遍处智。现在二。未来六。等持。现在一。未来三。若依静虑中间。证阿罗汉果。修彼道时。念住。现在一。未来四。正断神足。现在未来四。根力。现在未来五。觉支。现在六。未来七。道支现在七。未来八。静虑。现在无。未来四。无无量。无色。现在无。未来三。解脱。现在无。未来三。无胜处。无遍处智。现在二。未来六。等持。现在一。未来三。若依第二静虑。证阿罗汉果。修彼道时。念住。现在一。未来四。正断神足。现在未来四。根力。现在未来五。觉支。现在未来七。道支。现在七。未来八。静虑。现在一。未来四。无无量。无色。现在无。未来三。解脱。现在无。未来三。无胜处。无遍处智。现在二。未来六。等持。现在一。未来三。若依第三第四静虑。证阿罗汉果。修彼道时。念住。现在一。未来四。正断神足。现在未来四。根力。现在未来五。觉支。现在六。未来七。道支。现在七。未来八。静虑。现在一。未来四。无无量。无色。现在无。未来三。解脱。现在无。未来三。无胜处。无遍处智。现在二。未来六。等持。现在一。未来三。若依无色定。证阿罗汉果。修彼道时。念住。现在一。未来四。正断神足。现在未来四。根力。现在未来五。觉支。现在六。未来七。道支。现在四。未来八。静虑。现在无。未来四。无无量。无色。现在一。未来三。解脱。现在一。未来三。无胜处。无遍处智。现在二。未来六。等持。现在一。未来三

    根蕴第六中根纳息第一

  根学善等三　　异熟三六断
  见等有寻等　　受相应界系
  因缘四凡圣　　蕴摄七摄三
  为缘生几缘　　此章愿具说

二十二根。眼根耳根鼻根舌根身根女根男根命根意根乐根苦根喜根忧根舍根信根精进根念根定根慧根未知当知根已知根具知根。此二十二根。几学。几无学。几非学非无学。答二学。一无学。十非学非无学。九应分别。谓意根。或学。或无学。或非学非无学。云何学。谓学作意相应意根。云何无学。谓无学作意相应意根。云何非学非无学。谓有漏作意相应意根。如意根。乐根喜根舍根信根精进根念根定根慧根亦尔

诸根学。彼是学者根耶。答应作四句。有根学彼非学者根。谓学根学者不成就。有是学者根彼根非学。谓非学非无学根学者成就。有根学彼亦学者根。谓学根学者成就。有根非学彼亦非学者根。谓无学根及非学非无学根学者不成就。诸根无学。彼是无学者根耶。答应作四句。有根无学彼非无学者根。谓无学根无学者不成就。有是无学者根彼根非无学。谓非学非无学根无学者成就。有根无学彼亦无学者根。谓无学根无学者成就。有根非无学彼亦非无学者根。谓学根及非学非无学根无学者不成就。诸根非学非无学。彼是非学非无学者根耶。答诸非学非无学者根。彼是非学非无学。有根非学非无学彼非非学非无学者根。谓非学非无学根非学非无学者不成就

此二十二根。几善。几不善。几无记。答八善。八无记。六应分别。谓意根。或善。或不善。或无记。云何善。谓善作意相应意根。云何不善。谓不善作意相应意根。云何无记。谓无记作意相应意根。如意根。乐根苦根喜根舍根亦尔。忧根。或善。或不善。云何善。谓善作意相应忧根。云何不善。谓不善作意相应忧根

此二十二根。几有异熟。几无异熟。答一有异熟。十一无异熟。十应分别。谓意根。或有异熟。或无异熟。云何有异熟。谓不善善有漏意根。云何无异熟。谓无记无漏意根。如意根。乐根喜根舍根亦尔。苦根。或有异熟。或无异熟。云何有异熟。谓善不善苦根。云何无异熟。谓无记苦根。信根精进根念根定根慧根。或有异熟。或无异熟。云何有异熟。谓有漏信等五根。云何无异熟。谓无漏信等五根

此二十二根。几见所断。几修所断。几不断。答九修所断。三不断。十应分别。谓意根。或见所断。或修所断。或不断。云何见所断。谓意根随信随法行。现观边忍所断。此复云何。谓见所断八十八随眠相应意根。云何修所断。谓意根学见迹修所断。此复云何。谓修所断十随眠相应意根。及不染污有漏意根。云何不断。谓无漏意根。如意根。舍根亦尔。乐根。或见所断。或修所断。或不断。云何见所断。谓乐根随信随法行。现观边忍所断。此复云何。谓见所断二十八随眠相应乐根。云何修所断。谓乐根学见迹修所断。此复云何。谓修所断五随眠相应乐根。及不染污有漏乐根。云何不断。谓无漏乐根喜根。或见所断。或修所断。或不断。云何见所断。谓喜根随信随法行现观边忍所断。此复云何。谓见所断五十二随眠相应喜根。云何修所断。谓喜根学见迹随所断。此复云何。谓修所断六随眠相应喜根。及不染污有漏喜根。云何不断。谓无漏喜根忧根。或见所断。或修所断。云何见所断。谓忧根随信随法行。现观边忍所断。此复云何。谓见所断十六随眠相应忧根。云何修所断。谓忧根学见迹修所断。此复云何。谓修所断二随眠相应忧根。及不染污忧根。信根精进根念根定根慧根。或修所断。或不断。云何修所断。谓有漏信等五根。云何不断。谓无漏信等五根。此二十二根。几见苦所断。几见集所断。几见灭所断。几见道所断。几修所断。几不断。答九修所断。三不断。十应分别。谓意根。或见苦所断。或见集见灭见道所断。或修所断。或不断。云何见苦所断。谓意根随信随法行。苦现观边忍所断。此复云何。谓见苦所断二十八随眠相应意根。云何见集所断。谓意根随信随法行。集现观边忍所断。此复云何。谓见集所断十九随眠相应意根。云何见灭所断。谓意根随信随法行。灭现观边忍所断。此复云何。谓见灭所断十九随眠相应意根。云何见道所断。谓意根随信随法行。道现观边忍所断。此复云何。谓见道所断二十二随眠相应意根。云何修所断。谓意根学见迹修所断。此复云何。谓修所断十随眠相应意根。及不染污有漏意根。云何不断。谓无漏意根。如意根。舍根亦尔。乐根。或见苦所断。或见集见灭见道所断。或修所断。或不断。云何见苦所断。谓乐根随信随法行。苦现观边忍所断。此复云何。谓见苦所断九随眠相应乐根。云何见集所断。谓乐根随信随法行。集现观边忍所断。此复云何。谓见集所断六随眠相应乐根。云何见灭所断。谓乐根随信随法行。灭现观边忍所断。此复云何。谓见灭所断六随眠相应乐根。云何见道所断。谓乐根随信随法行。道现观边忍所断。此复云何。谓见道所断七随眠相应乐根。云何修所断。谓乐根学见迹修所断。此复云何。谓修所断五随眠相应乐根。及不染污有漏乐根。云何不断。谓无漏乐根喜根。或见苦所断。或见集见灭见道所断。或修所断。或不断。云何见苦所断。谓喜根随信随法行。苦现观边忍所断。此复云何。谓见苦所断十七随眠相应喜根。云何见集所断。谓喜根随信随法行。集现观边忍所断。此复云何。谓见集所断十一随眠相应喜根。云何见灭所断。谓喜根随信随法行。灭现观边忍所断。此复云何。谓见灭所断十一随眠相应喜根。云何见道所断。谓喜根随信随法行。道现观边忍所断。此复云何。谓见道所断十三随眠相应喜根。云何修所断。谓喜根学见迹修所断。此复云何。谓修所断六随眠相应喜根。及不染污有漏喜根。云何不断。谓无漏喜根。忧根。或见苦所断。或见集见灭见道所断。或修所断。云何见苦所断。谓忧根随信随法行。苦现观边忍所断。此复云何。谓见苦所断四随眠相应忧根。云何见集所断。谓忧根随信随法行。集现观边忍所断。此复云何。谓见集所断四随眠相应忧根。云何见灭所断。谓忧根随信随法行。灭现观边忍所断。此复云何。谓见灭所断四随眠相应忧根。云何见道所断。谓忧根随信随法行。道现观边忍所断。此复云何。谓见道所断四随眠相应忧根。云何修所断。谓忧根学见迹修所断。此复云何。谓修所断二随眠相应忧根。及不染污忧根信等五根。或修所断。或不断。云何修所断。谓有漏信等五根。云何不断。谓无漏信等五根

此二十二根。几见。几非见。答一见。十七非见。四应分别。慧根。或见。或非见。云何见。谓尽智无生智所不摄意识相应慧根。云何非见。谓余慧根。未知当知根。或见。或非见。云何见。谓未知当知根所摄慧根。云何非见。谓未知当知根所摄余根。如未知当知根。已知根亦尔。具知根。或见。或非见。云何见。谓尽智无生智所不摄具知根所摄慧根。云何非见。谓具知根所摄余根

此二十二根。几有寻有伺。几无寻唯伺。几无寻无伺。答二有寻有伺。八无寻无伺十二应分别。意根。或有寻有伺。或无寻唯伺。或无寻无伺。云何有寻有伺。谓有寻有伺作意相应意根。云何无寻唯伺。谓无寻唯伺作意相应意根。云何无寻无伺。谓无寻无伺作意相应意根。如意根。舍根信根精进根念根定根慧根未知当知根已知根具知根亦尔。乐根。或有寻有伺。或无寻无伺。云何有寻有伺。谓有寻有伺作意相应乐根。云何无寻无伺。谓无寻无伺作意相应乐根。如乐根。喜根亦尔

此二十二根。几乐根相应。几苦根相应。几喜根相应。几忧根相应。几舍根相应。答乐根喜根舍根。九根少分相应。苦根忧根。六根少分相应

此二十二根。几欲界系。几色界系。几无色界系。几不系。答四欲界系。三不系。十五应分别。眼根。或欲界系。或色界系。云何欲界系。谓欲界系大种所造眼根。云何色界系。谓色界系大种所造眼根。如眼根。耳根鼻根舌根身根亦尔。命根。或欲界系。或色界系。或无色界系。云何欲界系。谓欲界系寿。云何色界系。谓色界系寿。云何无色界系。谓无色界系寿。意根。或欲界系。或色界系。或无色界系。或不系。云何欲界系。谓欲界系作意相应意根。云何色界系。谓色界系作意相应意根。云何无色界系。谓无色界系作意相应意根。云何不系。谓无漏作意相应意根。如意根。舍根信根精进根念根定根慧根亦尔。乐根。或欲界系。或色界系。或不系。云何欲界系。谓欲界系作意相应乐根。云何色界系。谓色界系作意相应乐根。云何不系。谓无漏作意相应乐根。如乐根。喜根亦尔

此二十二根。几因相应。答十四。几因不相应。答八。几因相应因不相应。答即前十四。少分因相应。少分因不相应。几非因相应。非因不相应。答即前十四。少分非因相应。少分非因不相应。此二十二根。几缘有缘。答十三少分。几缘无缘。答一十三少分。几缘有缘缘无缘。答即前十三少分。几非缘有缘非缘无缘。答八

诸根此法。彼根异生耶。设根异生。彼根此法耶。答诸根此法。彼根非异生。诸根异生。彼根非此法

色蕴摄几根。答七。受蕴摄几根。答五三少分。想蕴摄几根。答无。行蕴摄几根。答六三少分。识蕴摄几根。答一三少分

善根。几界几处几蕴摄。答八界二处三蕴。唯善根。有几界几处几蕴摄。答无。不善根。几界几处几蕴摄。答八界二处二蕴。唯不善根。有几界几处几蕴摄。答无。有覆无记根。几界几处几蕴摄。答六界二处二蕴。唯有覆无记根。有几界几处几蕴摄。答无无覆无记根。几界几处几蕴摄。答十三界七处四蕴。唯无覆无记根。有几界几处几蕴摄。答五界五处。非蕴根法。几界几处几蕴摄。答十三界七处四蕴。唯根法。有几界几处几蕴摄。答十二界六处二蕴。非根法。几界几处几蕴摄。答六界六处三蕴。唯非根法。有几界几处几蕴摄。答五界五处一蕴。根非根法。几界几处几蕴摄。答十八界十二处五蕴。唯根非根法。有几界几处几蕴摄。答一界一处二蕴

颇根为缘生根耶。答生。生非根耶。答生。生根非根耶。答生。颇非根为缘生非根耶。答生。生根耶。答生。生根非根耶。答生。颇根非根为缘生根非根耶。答生。生根耶。答生。生非根耶。答生

颇眼根为缘生眼根耶。答生。生耳根乃至具知根耶。答生。颇乃至具知根为缘生具知根耶。答生。生眼根乃至已知根耶。答生

眼根与眼根。为几缘。与耳根乃至具知根。为几缘。乃至具知根。与具知根。为几缘。与眼根乃至已知根。为几缘。答眼根与眼根。为因增上。与余色根命根苦根。为一增上。与余根为所缘增上。如眼根耳鼻舌根亦尔。身根与身根女根男根。为因增上。与余色根命根苦根。为一增上。与余根为所缘增上。女根与女根身根。为因增上。与余色根命根苦根。为一增上。与余根为所缘增上。如女根。男根亦尔。命根与命根。为因增上。与七色根苦根。为一增上。与余根。为所缘增上。意根与意根。为因等无间所缘增上。与七色根命根。为因增上。与苦根。为因等无间增上。非所缘。与余根。为因等无间所缘增上。如意根。乐根喜根舍根信根精进根念根定根慧根亦尔。苦根与苦根。为因等无间增上。非所缘。与七色根命根。为因增上。与三无漏根。为所缘增上。与余根。为因等无间所缘增上。忧根与忧根。为因等无间所缘增上。与七色根命根。为因增上。与苦根。为因等无间增上。非所缘。与三无漏根。为所缘增上。与余根为因等无间所缘增上。未知当知根。与未知当知根。为因等无间所缘增上。与具知根。为因所缘增上。非等无间。与七色根命根苦根。为一增上。与忧根为所缘增上。与余根。为因等无间所缘增上。已知根。与已知根。为因等无间所缘增上。与七色根命根苦根。为一增上。与忧根未知当知根。为所缘增上。与余根。为因等无间所缘增上。具知根。与具知根。为因等无间所缘增上。与七色根命根苦根。为一增上。与忧根未知当知根已知根。为所缘增上。与余根。为因等无间所缘增上

说一切有部发智论卷第十四阿毗达磨发智论卷第十五

        尊者迦多衍尼子造

        三藏法师玄奘奉　诏译

    根蕴第六中有纳息第二

  得一遍知三　　沙门果九节
  四智法类智　　缘相应五门
  学无学根得　　无间证四果
  几根断灭起　　此章愿具说

欲有相续。最初得几业所生根。答卵生胎生湿生得二。化生得六或七或八。无形六。一形七。二形八。色有相续。最初得几业所生根。答六。无色有相续。最初得几业所生根。答一。颇思惟欲界系法。遍知欲界耶。答遍知。遍知色界耶。答不遍知。遍知无色界耶。答不遍知。颇思惟色界系法。遍知色界耶。答遍知。遍知欲界耶。答遍知。遍知无色界耶。答不遍知。颇思惟无色界系法。遍知无色界耶。答遍知。遍知欲界耶。答不遍知。遍知色界耶。答遍知。几根遍知欲界。答世俗道七。无漏道八。几根遍知色界。答世俗道七。无漏道十。几根遍知无色界。答十一。遍知欲界时。遍知几根。答四。遍知色界时。遍知几根。答五。遍知无色界时。遍知几根。答八。

几根得预流果。答九。几根得一来果。答若倍离欲染入正性离生者九。若从预流果。得一来果者。世俗道七。无漏道八。几根得不还果。答若已离欲染入正性离生者九。若从一来果。得不还果者。世俗道七。无漏道八。几根得阿罗汉果。答十一。得预流果。遍知几根。答无。得一来果遍知几根。答无。得不还果。遍知几根。答若已离欲染入正性离生者无。若从一来果。得不还果者四。得阿罗汉果。遍知几根。答八。诸根得预流果。此根得彼果已。当言成就。当言不成就。答解脱道摄者。当言成就。无间道摄者。当言不成就。诸根得一来果不还果阿罗汉果。此根得彼果已。当言成就。当言不成就。答解脱道摄者。当言成就。无间道摄者。当言不成就。诸根得预流果。此根断何界结。答色无色界或无。此根何果摄。答预流果或无。诸根得一来果。此根断何界结。答欲界或色无色界或无。此根何果摄。答一来果或无。诸根得不还果。此根断何界结。答欲界或色无色界或无。此根何果摄。答不还果或无。诸根得阿罗汉果。此根断何界结。答无色界或无。此根何果摄。答阿罗汉果或无。得预流果时。所舍诸根。此根断何界结。答欲界或色无色界或无。此根何果摄。答无。得一来果时。所舍诸根。此根断何界结。答欲界或色无色界或无。此根何果摄。答预流果或无。得不还果时。所舍诸根。此根断何界结。答欲界或色无色界或无。此根何果摄。答一来果或无。得阿罗汉果时。所舍诸根。此根断何界结。答色界或无色界或无。此根何果摄。答不还果或无。得预流果时。所得诸根。此根断何界结。答无。此根何果摄。答预流果或无。得一来果时。所得诸根。此根断何界结。答无。此根何果摄。答一来果或无。得不还果时。所得诸根。此根断何界结。答无。此根何果摄。答不还果或无。得阿罗汉果时。所得诸根。此根断何界结。答无。此根何果摄。答阿罗汉果或无。诸预流者。所成就根。此根断何界结。答欲界或无。此根。何果摄。答预流果或无。诸一来者。所成就根。此根断何界结。答欲界或无。此根何果摄。答一来果或无。诸不还者。所成就根。此根断何界结。答色界或无色界或无。此根何果摄。答不还果或无。诸阿罗汉。所成就根。此根断何界结。答无。此根何果摄。答阿罗汉果或无。诸预流者。断结诸根。此根断何界结。答欲界。此根何果摄。答无。诸一来者。断结诸根。此根断何界结。答欲界。此根何果摄。答无。诸不还者。断结诸根。此根断何界结。答色界或无色界。此根何果摄。答无。诸预流果。所摄诸根。此根断何界结。答无。诸一来果。不还果。阿罗汉果。所摄诸根。此根断何界结。答无

诸苦智。是于苦无漏智耶。设于苦无漏智。是苦智耶。答诸苦智。是于苦无漏智。有于苦无漏智非苦智。谓于苦知集智诸集智。是于集无漏智耶。设于集无漏智。是集智耶。答诸集智。是于集无漏智。有于集无漏智非集智。谓于集知苦智诸灭智。是于灭无漏智耶。答如是。设于灭无漏智。是灭智耶。答如是。诸道智。是于道无漏智耶。答如是。设于道无漏智。是道智耶。答如是

诸根无漏。缘欲界系。此根法智相应耶。设根无漏法智相应。此根缘欲界系耶。答应作四句。有根无漏缘欲界系。此根非法智相应。谓苦法智忍。及相应根苦法智。集法智忍。及相应根集法智。有根无漏法智相应。此根不缘欲界系。谓灭道法智相应根。有根无漏缘欲界系。此根亦法智相应。谓苦集法智相应根。有根无漏不缘欲界系。此根亦非法智相应。谓苦类智忍苦类智。及二相应根。集类智忍集类智。及二相应根。灭法智忍。及相应根灭法智。灭类智忍灭类智。及二相应根。道法智忍。及相应根道法智。道类智忍道类智。及二相应根

诸根无漏缘色无色界系。此根类智相应耶。设根无漏类智相应。此根缘色无色界系耶。答应作四句。有根无漏缘色无色界系。此根非类智相应。谓苦类智忍。及相应根苦类智。集类智忍。及相应根集类智。有根无漏类智相应。此根不缘色无色界系。谓灭道类智相应根。有根无漏缘色无色界系。此根亦类智相应。谓苦集类智相应根。有根无漏不缘色无色界系。此根亦非类智相应。谓苦法智忍苦法智。及二相应根。集法智忍集法智。及二相应根。灭法智忍灭法智。及二相应根。灭类智忍。及相应根灭类智。道法智忍道法智。及二相应根。道类智忍。及相应根道类智。法智。当言法智耶。当言类智他心智世俗智苦智集智灭智道智耶。答当言法智。或他心智。苦智。集智。灭智。道智。当言有寻有伺无寻唯伺无寻无伺耶。答当言三种。当言乐根相应喜根相应舍根相应耶。答当言三种。当言空无愿无相相应耶。答当言三种。当言缘欲界系缘色界系缘无色界系缘不系耶。答当言缘欲界系。或不系

类智。当言类智耶。当言法智他心智世俗智苦智集智灭智道智耶。答当言类智。或他心智苦智集智灭智道智。当言有寻有伺无寻唯伺无寻无伺耶。答当言三种。当言乐根相应喜根相应舍根相应耶。答当言三种。当言空无愿无相相应耶。答当言三种。当言缘欲界系缘色界系缘无色界系缘不系耶。答当言缘色无色界系。或不系时心解脱。当言学根得无学根得学无学根得耶。答当言学无学根得。不动心解脱。当言学根得无学根得学无学根得耶。答若本得不动。当言学无学根得。若时解脱阿罗汉得不动。当言无学根得。一切结尽。当言学根得无学根得学无学根得耶。答当言学无学根得。以无间道。证预流果。乃至阿罗汉果。此道当言法智相应类智他心智世俗智苦智集智灭智道智相应耶。当言有寻有伺无寻唯伺无寻无伺耶。当言乐根喜根舍根相应耶。当言空无愿无相相应耶。当言缘欲界系色界系无色界系不系耶。答以无间道。证预流果。此道当言忍相应有寻有伺舍根相应无愿相应缘不系。以无间道。证一来果。若倍离欲染入正性离生者。如证预流果说。若从预流果。以世俗道。证一来果。此道当言世俗智相应有寻有伺舍根相应缘欲界系。若从预流果。以无漏道。证一来果。此道当言。法智相应。或苦智。或集智。或灭智。或道智相应。有寻有伺舍根相应。或空或无愿。或无相相应。或缘欲界系。或缘不系。以无间道。证不还果。若已离欲染入正性离生。此道当言忍相应。或有寻有伺。或无寻唯伺。或无寻无伺。或乐根相应。或喜根相应。或舍根相应。无愿相应。缘不系。若从一来果。以世俗道。证不还果者。如以世俗道证一来果说。若从一来果。以无漏道。证不还果者。如以无漏道证一来果说。以无间道。证阿罗汉果。此道当言。或法智相应。或类智。或苦智。或集智。或灭智。或道智相应。或有寻有伺。或无寻唯伺。或无寻无伺。或乐根。或喜根。或舍根相应。或空或无愿。或无相相应。或缘无色界系。或缘不系

几根永断灭。起得预流果。答无根永断。七根灭起。一灭不起。一起不灭。得预流果。几根永断灭起。得一来果。答若倍离欲染入正性离生者。如证预流果说。若从预流果。以世俗道。证一来果。无根永断。七根灭起。得一来果。若从预流果。以无漏道。证一来果。无根永断。八根灭起。得一来果。几根永断灭起。得不还果。答若已离欲染。入正性离生。无根永断。七根灭起。一灭不起。一起不灭。得不还果。若从一来果。以世俗道。证不还果。不入静虑。四根永断。七根灭起。得不还果。若入静虑。四根永断。六根灭起。一灭不起。一起不灭。得不还果。若从一来果。以无漏道。证不还果。不入静虑。四根永断。八根灭起。得不还果。若入静虑。四根永断。七根灭起。一灭不起。一起不灭。得不还果。几根永断灭起。得阿罗汉果。答若依未至。证阿罗汉果。一根永断。七根永断灭起。一灭不起。一起不灭。得阿罗汉果。如依未至。依静虑中间第四静虑三无色定亦尔。若依初静虑。证阿罗汉果。二根永断。六根永断灭起。一根灭起。一灭不起。一起不灭。得阿罗汉果。如依初静虑。依第二第三静虑亦尔

    根蕴第六中触纳息第三

  十六触相摄　　根相应成就
  遍知灭作证　　此章愿具说

有十六触。谓有对触。增语触。明触。无明触。非明非无明触。爱触。恚触。顺乐受触。顺苦受触。顺不苦不乐受触。眼触。耳触。鼻触。舌触。身触。意触。云何有对触。答五识身相应触。云何增语触。答意识身相应触。云何明触。答无漏触。云何无明触。答染污触。云何非明非无明触。答不染有漏触。云何爱触。答贪相应触。云何恚触。答嗔相应触。云何顺乐受触。答乐受相应触。云何顺苦受触。答苦受相应触。云何顺不苦不乐受触。答不苦不乐受相应触。云何眼触。答眼识身相应触。云何耳触。答耳识身相应触。云何鼻触。答鼻识身相应触。云何舌触。答舌识身相应触。云何身触。答身识身相应触。云何意触。答意识身相应触

有对触摄几触。乃至意触摄几耶。答有对触。摄六触全七触少分。增语触。摄三触全七触少分。明触。摄明触全四触少分。无明触。摄三触全十一触少分。非明非无明触。摄非明非无明触全十一触少分。爱触。摄爱触全十一触少分。恚触。摄恚触全十一触少分。顺乐受触。摄顺乐受触全十二触少分。顺苦受触。摄顺苦受触全十一触少分。顺不苦不乐受触。摄顺不苦不乐受触全十三触少分。眼触摄眼触全八触少分。如眼触。耳鼻舌身触亦尔。意触摄三触全七触少分

有对触。几根相应。乃至意触。几根相应耶。答有对触。一根全八根少分相应。增语触。五根全八根少分相应。明触。三根全九根少分相应。无明触。六根少分相应。非明非无明触。十一根少分相应。爱触。四根少分相应。恚触。四根少分相应。顺乐受触。二根全九根少分相应。顺苦受触。二根全六根少分相应。顺不苦不乐受触。一根全。九根少分相应。眼触。九根少分相应。如眼触。耳鼻舌身触亦尔。意触。五根全八根少分相应

诸根因有对触。此根有对触相应耶。设根有对触相应。此根因有对触耶。答诸根有对触相应。此根因有对触。有根因有对触此根非有对触相应。诸根因有对触。余触相应。及异熟生无所缘。如有对触除二触余十三触亦尔。诸根因明触。此根明触相应耶。答如是。设根明触相应。此根因明触耶。答如是。诸根因非明非无明触。此根非明非无明触相应耶。设根非明非无明触相应。此根因非明非无明触耶。答诸根非明非无明触相应。此根因非明非无明触。有根因非明非无明触。此根非非明非无明触相应。谓根因非明非无明触。异熟生无所缘。诸成就此类眼根。彼成就此类身根耶。设成就此类身根。彼成就此类眼根耶。答应作四句。有成就此类眼根非此类身根。谓生欲界。不得眼根。设得已失。得色界眼。有成就此类身根非此类眼根。谓生欲界。不得眼根。设得已失。不得色界眼。有成就此类眼根亦此类身根。谓生欲界。眼根已得不失。若生色界。有非成就此类眼根亦非此类身根。谓生无色界。如眼根。耳根亦尔。诸成就此类鼻根。彼成就此类身根耶。设成就此类身根。彼成就此类鼻根耶。答若成就此类鼻根。彼成就此类身根。有成就此类身根不成就此类鼻根。谓生欲界。不得鼻根设得已失。如鼻根。舌根亦尔

地狱成就几根。傍生乃至诸无色。随信行。乃至俱解脱。成就几根。答地狱。极多十九。极少八。傍生。极多十九。极少十三。鬼界亦尔。断善根者。极多十三。极少八。邪定聚。极多十九。极少八。正定聚。极多十九。极少十一。不定聚。极多十九。极少八赡部洲。极多十九。极少八。毗提诃洲瞿陀尼洲亦尔。俱卢洲。极多十八。极少十三。四大王众天。极多十九。极少十七。三十三天夜摩天睹史多天乐变化天他化自在天亦尔。梵众天。极多十六。极少十五。极光净天亦尔。遍净天。极多十六。极少十四。广果天。极多十六。极少十三。中有。极多十九。极少十三。诸无色。极多十一。极少八。随信行。极多十九。极少十三。随法行亦尔。信胜解。极多十九。极少十一。见至亦尔。身证。极多十八。极少十一。慧解脱俱解脱亦尔

眼根乃至慧根。得遍知时。几根得遍知耶。答眼根得遍知时。至离色染。五根得遍知。耳鼻舌身根亦尔。女根得遍知时。至离欲染。四根得遍知。男根苦根忧根亦尔。命根得遍知时。至离无色染。八根得遍知。意根舍根信等五根亦尔。乐根得遍知时。至离遍净染。即乐根得遍知。喜根得遍知时。至离极光净染。即喜根得遍知

眼根乃至慧根。灭作证时。几根灭作证耶。答眼根灭作证时。至离色染。五根灭作证。至阿罗汉。十九根灭作证。耳鼻舌身根亦尔。女根灭作证时。至离欲染。四根灭作证。至阿罗汉。十九根灭作证。男根苦根忧根亦尔。命根灭作证时。至阿罗汉。十九根灭作证。意根舍根信等五根亦尔。乐根灭作证时。至离遍净染。即乐根灭作证。至阿罗汉。十九根灭作证。喜根灭作证时。至离极光净染。即喜根灭作证。至阿罗汉。十九根灭作证。

    根蕴第六中等心纳息第四

  等心寿二定　　无想摄相应
  界死生涅槃　　此章愿具说

一切有情心。当言等起等住等灭耶。答如是。有贪心离贪心。当言等起等住等灭耶。答如是。有嗔离嗔。有痴离痴。略散下举小大掉不掉不静静不定定不修修不解脱解脱心。当言等起等住等灭耶。答如是

寿当言随心转不随心转耶。答不随心转。当言随相续转为一起便住耶。答若欲界有情。不住无想灭尽等至。当言随相续转。若住无想灭尽等至。及色无色界有情。当言一起便住。住无想灭尽等至。寿当言转为住耶。答当言转。如世尊说。人寿渐尽。如小河水。若诸有情。寿起便住。云何知彼寿渐尽耶。答由世尽劫尽故

入无想定。几根灭。答七。何系心心所灭。答色界系。出无想定。几根现前。答七。何系心心所现前。答色界系。入灭尽定。几根灭。答七。何系心心所灭。答无色界系。出灭尽定。几根现前。答或七或八。有漏心七。无漏心八。何系心心所现前。答或无色界系。或不系

生无想天。几根灭。答八。何系心心所灭。答色界系。几根现前。答八。何系心心所现前。答色界系。无想天没。几根灭。答八。何系心心所灭。答色界系。几根现前。答或八或九或十。无形八。一形九。二形十。何系心心所现前。答欲界系。无想有情生时。当言有想耶无想耶。答当言有想。如世尊说。彼诸有情。由想起故。从彼处没。从彼没时。彼想当言灭耶不灭耶。答当言灭。当言住何处。彼想灭耶。答当言即住彼处。彼想当言善为无记耶。答或善或无记。彼想几随眠随增。答色界有漏缘。几结系。答六。如世尊说。一切有情。皆由食住。无想有情。由何食住答触意思识

眼根摄几根。乃至具知根摄几根。答眼根摄眼根。如眼根。耳鼻舌命苦忧根亦尔。身根摄三摄。女根摄女根身根少分。如女根。男根亦尔。意根摄意根三根少分。如意根。乐喜舍根信等五根亦尔。未知当知根。摄未知当知根九根少分。如未知当知根。已知根具知根亦尔。信力乃至慧力念等觉支。乃至舍等觉支。正见乃至正定。法智乃至道智。空无愿无相。摄几根。答信力摄一根三根少分。如信力。余四力亦尔。念等觉支摄四根少分。如念等觉支。择法精进喜定等觉支亦尔。余不摄根。正见摄四根少分。如正见。正勤念定亦尔。余不摄根。法智摄四根少分。如法智。类智苦集灭道智亦尔。他心智摄三根少分。世俗智摄一根少分。空摄四根少分。如空。无愿无相亦尔

意根几根相应。乃至具知根几根相应。答意根十根三根少分相应。乐喜舍根九根少分相应。苦根忧根六根少分相应。信根四根九根少分相应。如信根。精进念定慧根亦尔。未知当知根。与未知当知根。九根少分相应。如未知当知根。已知根具知根亦尔。信力乃至慧力念等觉支。乃至舍等觉支。正见乃至正定。法智乃至道智。空无愿无相。几根相应。答信力四根九根少分相应。如信力。余四力亦尔。念等觉支。十一根少分相应。如念等觉支。择法精进定等觉支亦尔。喜等觉支。九根少分相应。安舍等觉支三根九根少分相应。正见十一根少分相应。如正见。正思惟正勤正定亦尔。余非根相应。法智十一根少分相应。如法智。类智苦集灭道智亦尔。他心智十根少分相应。世俗智二根八根少分相应。空无愿无相十一根少分相应

欲界没生欲界时。几根灭。答或四。或九。或八。或十三。或九。或十四。或十。或十五。渐命终者。无记心四。善心九。顿命终者。若无形。无记心八。善心十三。若一形。无记心九。善心十四。若二形。无记心十。善心十五何系心心所灭。答欲界系。几根现前。答或八或九或十。无形八。一形九。二形十。何系心心所现前。答欲界系。欲界没生色界时。几根灭。答或四或九或九或十四。渐命终者。无记心四。善心九。顿命终者。无记心九。善心十四。何系心心所灭。答欲界系几根现前。答八。何系心心所现前。答色界系。欲界没生无色界时。几根灭。答或四或九或九或十四。如前说。何系心心所灭。答欲界系。几根现前。答三。何系心心所现前。答无色界系。色界没生色界时。几根灭。答或八或十三。无记心八。善心十三。何系心心所灭。答色界系。几根现前。答八。何系心心所现前。答色界系。色界没生欲界时。几根灭。答或八或十三。如前说。何系心心所灭。答色界系。几根现前。答或八或九或十如前说。何系心心所现前。答欲界系。色界没生无色界时。几根灭。答或八或十三。如前说。何系心心所灭。答色界系。几根现前。答三。何系心心所现前。答无色界系。无色界没生无色界时。几根灭。答或三或八。无记心三。善心八。何系心心所灭。答无色界系。几根现前。答三。何系心心所现前。答无色界系。无色界没生欲界时。几根灭。答或三或八。如前说。何系心心所灭。答无色界系。几根现前。答或八或九或十。如前说。何系心心所现前。答欲界系。无色界没生色界时。几根灭。答或三或八。如前说。何系心心所灭。答无色界系。几根现前。答八。何系心心所现在前。答色界系。阿罗汉般涅槃时。几根最后灭。答或四或九或八或三。欲界渐般涅槃者四。顿般涅槃者九。色界八。无色界三

    根蕴第六中一心纳息第五

  相应缘不离　　不修修得根
  舍得未知根　　五门辩二智
  初尽无生智　　尽无生所缘
  七正互相应　　此章愿具说

诸法与心一起一住一灭。彼法与心相应耶。答若法与心相应。彼法与心一起一住一灭。有法与心一起一住一灭。彼法非心相应。谓随心转色心不相应行。诸法与心一起一住一灭。彼法与心一所缘耶。答若法与心一所缘。彼法与心一起一住一灭。有法与心一起一住一灭。彼法非心一所缘。谓随心转色心不相应行。诸法与心俱起不离心。彼法与心俱住俱灭不离心耶。答欲色界有情。不住无想灭尽定者。诸根大种。与心俱起不离心。与心俱住俱灭不离心。若住无想灭尽定者。彼便离心

如说不修眼根。乃至身根。云何不修眼根乃至身根。答若于眼根。未离贪。未离欲润喜渴又无间道。能尽色贪。彼于此道。未修未安。如不修眼根。不修耳鼻舌身根亦尔。如说不修意根。云何不修意根。答若于意根。未离贪。未离欲润喜渴。又无间道。能尽无色贪。彼于此道。未修未安。如说修眼根乃至身根。云何修眼根乃至身根。答若于眼根。已离贪。已离欲润喜渴。又无间道。能尽色贪。彼于此道。已修已安。如修眼根。修耳鼻舌身根亦尔。如说修意根。云何修意根。答若于意根。已离贪。已离欲润喜渴。又无间道。能尽无色贪。彼于此道。已修已安

诸不成就学根得学根。彼一切入正性离生耶。答若入正性离生。彼一切不成就学根得学根。有不成就学根得学根彼非入正性离生。谓退阿罗汉果时。诸不成就学根得学根。彼一切世第一法等无间耶。答若世第一法等无间。彼一切不成就学根得学根。有不成就学根得学根彼非世第一法等无间。谓退阿罗汉果时

诸舍无漏根。得无漏根。彼一切从果至果耶。答若从果至果。彼一切舍无漏根。得无漏根。有舍无漏根得无漏根彼非从果至果。谓现观边道类智起时。若时解脱阿罗汉。练根作不动时。诸舍无漏根。得无漏根。彼一切无漏根灭。无漏根起耶。答应作四句。有舍无漏根得无漏根彼非无漏根灭无漏根起。谓退阿罗汉不还一来果时。及以世俗道。得一来不还果时。有无漏根灭无漏根起彼非舍无漏根得无漏根。谓已得无漏根。现前灭起。有舍无漏根得无漏根彼亦无漏根灭无漏根起。谓现观边道类智起时。及以无漏道。得一来不还果时。得阿罗汉果时。时解脱阿罗汉。练根作不动时。有非舍无漏根得无漏根彼亦非无漏根灭无漏根起。谓除前相

诸未知当知根。彼一切于未现观四圣谛。能现观耶。答应作四句。有未知当知根彼非于未现观四圣谛能现观。谓未知当知根。在过去或未来。有于未现观四圣谛能现观彼非未知当知根。谓诸非根法。于未现观四圣谛。能现观。有未知当知根彼亦于未现观四圣谛能现观。谓未知当知根。于未现观四圣谛。能现观。有非未知当知根彼亦非于未现观四圣谛能现观。谓除前相

尽智当言尽智乃至道智耶。当言有寻有伺乃至无寻无伺耶。当言乐根乃至舍根相应耶。当言空乃至无相相应耶。当言缘欲界系乃至缘不系耶。如尽智。无生智无学正见亦尔。答尽智当言尽智。或法类智。或苦集灭道智。或有寻有伺。或无寻唯伺。或无寻无伺。或乐根相应。或喜舍根相应。或无愿相应。或无相相应。或缘欲界系。或缘色无色界系。或缘不系。如尽智。无生智亦尔。无学正见。当言无学正见。或法类他心智。或苦集灭道智。或有寻有伺。或无寻唯伺。或无寻无伺。或乐根相应。或喜舍根相应。或空相应。或无愿无相相应。或缘欲界系。或缘色无色界系。或缘不系。诸最初尽智。彼一切无间道等无间耶。答如是。设无间道等无间。彼一切尽智耶。答如是。诸最初无生智。彼一切尽智等无间耶。答如是。设尽智等无间。彼一切无生智耶。答或尽智。或无生智。或无学正见。诸缘彼无间道起。即缘彼初尽智起耶。答若缘生无间道起。即缘彼初尽智起。若不缘生无间道起。即不缘彼初尽智起。诸缘彼尽智起。即缘彼无生智起耶。答如是。设缘彼无生智起。即缘彼尽智起耶。答如是。诸法无学正见相应。彼法无学正思惟相应耶。答应作四句。有法无学正见相应非无学正思惟。谓无学正见相应正思惟。及无学正思惟不相应无学正见相应法。有法无学正思惟相应非无学正见。谓无学正思惟相应正见。及无学正见不相应无学正思惟相应法。有法无学正见正思惟相应。谓除无学正见相应正思惟。及除无学正思惟相应正见。诸余无学正见正思惟相应法。有法非无学正见正思惟相应。谓无学正见不相应正思惟。无学正思惟不相应正见。及前所不摄心心所法。并色无为。心不相应行。诸法无学正见相应。彼法无学正勤相应耶。答应作四句。有法无学正见相应非无学正勤。谓无学正见相应正勤。有法无学正勤相应非无学正见。谓无学正见。及无学正见不相应无学正勤相应法。有法无学正见正勤相应。谓除无学正见相应正勤。诸余无学正见相应法。有法非无学正见正勤相应。谓无学正见不相应正勤。及前所不摄心心所法。并色无为。心不相应行。如对正勤。对正念正定正解脱亦尔。诸法无学正见相应。彼法非无学正智相应。诸法无学正智相应。彼法非无学正见相应。诸法无学正思惟相应。彼法无学正勤相应耶。答应作四句。有法无学正思惟相应非无学正勤。谓无学正思惟相应正勤。有法无学正勤相应非无学正思惟。谓无学正勤相应正思惟。及无学正思惟不相应无学正勤相应法。有法无学正思惟正勤相应。谓除无学正思惟相应正勤。诸余无学正思惟相应法。有法非无学正思惟正勤相应。谓无学正思惟不相应正勤。及前所不摄心心所法。并色无为。心不相应行。如对正勤。对正念正定正解脱亦尔。诸法无学正思惟相应。彼法无学正智相应耶。答应作四句。有法无学正思惟相应非无学正智。谓无学正思惟相应正智。及无学正智不相应无学正思惟相应法。有法无学正智相应非无学正思惟。谓无学正智相应正思惟。及无学正思惟不相应无学正智相应法。有法无学正思惟正智相应。谓除无学正思惟相应正智。及除无学正智相应正思惟。诸余无学正思惟正智相应法。有法非无学正思惟正智相应。谓无学正思惟不相应无学正智。无学正智不相应无学正思惟。及前所不摄心心所法。并色无为。心不相应行。诸法无学正勤相应。彼法无学正念相应耶。答应作四句。有法无学正勤相应非无学正念。谓无学正念。有法无学正念相应非无学正勤。谓无学正勤。有法无学正勤正念相应。谓除无学正勤正念。诸余无学正勤正念相应法。有法非无学正勤正念相应。谓前所不摄心心所法。并色无为。心不相应行。如对正念。对正定正解脱亦尔。诸法无学正勤相应。彼法无学正智相应耶。答应作四句。有法无学正勤相应非无学正智。谓无学正智。及无学正智不相应无学正勤相应法。有法无学正智相应非无学正勤。谓无学正智相应正勤。有法无学正勤正智相应。谓除无学正智相应正勤。诸余无学正智相应法。有法非无学正勤正智相应。谓无学正智不相应正勤。及前所不摄心心所法。并色无为。心不相应行。如正勤。正念正定亦尔。诸法无学正解脱相应。彼法无学正智相应耶。答应作四句。有法无学正解脱相应非无学正智。谓无学正智。及无学正智不相应无学正解脱相应法。有法无学正智相应非无学正解脱。谓无学正智相应正解脱。有法无学正解脱正智相应。谓除无学正智相应正解脱。诸余无学正智相应法。有法非无学正解脱正智相应。谓无学正智不相应正解脱。及前所摄心心所法。并色无为。心不相应行

说一切有部发智论卷第十五阿毗达磨发智论卷第十六

        尊者迦多行尼子造

        三藏法师玄奘奉　诏译

    根蕴第六中鱼纳息第六

  总三世成就　　不成就亦然
  善等根为因　　此章愿具说

若成就眼根。彼于二十二根。几成就。几不成就。乃至具知根。问亦尔。答若成就眼根。彼定成就五。余不定。耳鼻舌根亦尔。若成就身根。彼定成就四。余不定。若成就女根。彼定成就八。余不定。男根亦尔。若成就命根。彼定成就三。余不定。意根舍根亦尔。若成就乐根。彼定成就四。余不定。若成就苦根。彼定成就七。余不定。若成就喜根。彼定成就五。余不定。若成就忧根。彼定成就八。定不成就一。余不定。若成就信根。彼定成就八。余不定。精进念定慧根亦尔。若成就未知当知根。彼定成就十三。定不成就二。余不定。若成就已知根。彼定成就十一。定不成就二。余不定。若成就具知根。彼定成就十一。定不成就三。余不定。若成就眼根。彼于三世二十二根。几成就。几不成就。乃至具知根。问亦尔。答若成就眼根。彼定不成就过去未来八。定成就过去未来二现在三。余不定。耳鼻舌根亦尔。若成就身根。彼定不成就过去未来八。定成就过去未来二现在二。余不定。若成就女根。彼定不成就过去未来八。定成就过去未来五现在三。余不定。男根亦尔。若成就命根。彼定不成就过去未来八。定成就过去未来二现在一。余不定。意根舍根亦尔。若成就乐根。彼定不成就过去未来八。定成就过去未来二未来一现在一。余不定。若成就苦根。彼定不成就过去未来八。定成就过去未来五现在二。余不定。若成就喜根。彼定不成就过去未来八。定成就过去未来二未来二现在一。余不定。若成就忧根。彼定不成就过去未来八三世一。定成就过去未来四三世二现在二。余不定。若成就信根。彼定不成就过去未来八。定成就过去未来七现在一。余不定。精进念定慧根亦尔。若成就未知当知根。彼定不成就过去未来八三世二现在二。定成就三世七过去未来三未来现在一现在二。余不定。若成就已知根。彼定不成就过去未来八三世二。定成就过去未来七未来三现在一。余不定。若成就具知根。彼定不成就过去未来八三世三。定成就过去未来七未来三现在一。余不定

若不成就眼根。彼于二十二根。几不成就。几成就。乃至具知根问亦尔。答若不成就眼根。彼定不成就一。定成就三。余不定。耳鼻舌女男三无漏根亦尔。若不成就身根。彼定不成就十。定成就八。余不定。命意舍根。无不成就。若不成就乐根。彼定不成就九。定成就八。余不定。若不成就苦根。彼定不成就五。定成就八。余不定。若不成就喜根。彼定不成就八。定成就八。余不定。若不成就忧根。彼定不成就一。定成就八。余不定。若不成就信根。彼定不成就八。定成就八。余不定。精进念定慧根亦尔。若不成就眼根。彼于三世二十二根。几不成就。几成就。乃至具知根。问亦尔。答若不成就眼根。彼定不成就三世一过去未来七。定成就过去未来二现在一。余不定。耳鼻舌女男根亦尔。若不成就身根。彼定不成就三世十过去未来一。定成就过去未来五三世二现在一。余不定。命意舍根。无不成就。若不成就乐根。彼定不成就三世九过去未来六。定成就过去未来七现在一。余不定。若不成就苦根。彼定不成就三世五过去未来六。定成就过去未来七现在一。余不定。若不成就喜根。彼定不成就三世八过去未来六。定成就过去未来七现在一。余不定。若不成就忧根。彼定不成就三世一过去未来八。定成就过去未来七现在一。余不定。若不成就信根。彼定不成就三世八过去未来八。定成就过去未来四三世二现在二。余不定。精进念定慧根亦尔。若不成就未知当知根。彼定不成就三世一过去未来八。定成就过去未来二现在一。余不定。已知具知根亦尔

诸根善。彼根因善根耶。设根因善根。彼根善耶。答诸根善。彼根因善根。有根因善根彼根非善。谓善根所引异熟生根。诸根不善。彼根因不善根耶。设根因不善根。彼根不善耶。答诸根不善。彼根因不善根。有根因不善根彼根非不善。谓不善根所引异熟生根。及欲界有身见边执见相应根。诸根无记。彼根因无记根耶。设根因无记根。彼根无记耶。答应作四句。有根无记彼根非因无记根。谓无缘根。有根因无记根彼根非无记。谓不善根。有根无记彼根亦因无记根。谓无记有缘根。有根非无记彼根亦非因无记根。谓善根。颇有根非因善根非因不善根非因无记根。彼根非无因耶。答有。谓无缘根因色心不相应行

    根蕴第六中因缘纳息第七

  五三四四八　　八八八四门
  辩根因所缘　　此章愿具说

诸根因过去。彼根缘过去耶。答诸根因过去。彼根或缘过去。或缘未来。或缘现在。或缘无为。或无所缘。诸根因过去缘过去者。谓根过去缘过去。及根未来现在。因过去。缘过去。因过去缘未来者。谓根过去缘未来。及根未来现在。因过去。缘未来。因过去缘现在者。谓根过去缘现在。及根未来现在。因过去。缘现在。因过去缘无为者。谓根过去缘无为。及根未来现在。因过去。缘无为。因过去无所缘者。谓无缘根。因过去。设根缘过去。彼根因过去耶。答诸根缘过去。彼根或因过去。或因未来。或因现在。诸根缘过去因过去者。谓根过去缘过去。及根未来现在。因过去。缘过去。缘过去因未来者。谓根未来缘过去。缘过去因现在者。谓根现在缘过去。及根未来。因现在。缘过去。诸根因未来。彼根缘未来耶。答诸根因未来。彼根或缘未来。或缘过去。或缘现在。或缘无为。或无所缘。诸根因未来缘未来者。谓根未来缘未来。因未来缘过去者。谓根未来缘过去。因未来缘现在者。谓根未来缘现在。因未来缘无为者。谓根未来缘无为。因未来无所缘者。谓无缘根。因未来。设根缘未来。彼根因未来耶。答诸根缘未来。彼根或因未来。或因过去。或因现在。诸根缘未来因未来者。谓根未来缘未来。缘未来因过去者。谓根过去缘未来。及根未来现在。因过去。缘未来。缘未来因现在者。谓根现在缘未来。及根未来。因现在。缘未来。诸根因现在。彼根缘现在耶。答诸根因现在。彼根或缘现在。或缘过去。或缘未来。或缘无为。或无所缘。诸根因现在缘现在者。谓根现在缘现在。及根未来。因现在。缘现在。因现在缘过去者。谓根现在缘过去。及根未来。因现在。缘过去。因现在缘未来者。谓根现在缘未来。及根未来。因现在。缘未来。因现在缘无为者。谓根现在缘无为。及根未来。因现在。缘无为。因现在无所缘者。谓无缘根因现在。设根缘现在。彼根因现在耶。答诸根缘现在。彼根或因现在。或因过去。或因未来。诸根缘现在因现在者。谓根现在缘现在。及根未来。因现在。缘现在。缘根在因过去者。谓根过去缘现在。及根未来现在。因过去。缘现在。缘现在因未来者。谓根未来。缘现在

诸根因善。彼根缘善耶。答诸根因善。彼根或缘善。或缘不善。或缘无记。或无所缘。诸根因善缘善者。谓根善缘善。及根无记。因善。缘善。因善缘不善者。谓根善缘不善。又根无记。因善。缘不善。因善缘无记者。谓根善缘无记。及根无记。因善。缘无记。因善无所缘者。谓无缘根。因善。设根缘善。彼根因善耶。答诸根缘善。彼根或因善。或因不善。或因无记。诸根缘善因善者。谓根善缘善。及根无记。因善。缘善。缘善因不善者。谓根不善缘善。及根无记。因不善。缘善。缘善因无记者。谓根无记缘善。及根不善。因无记。缘善。诸根因不善。彼根缘不善耶。答诸根因不善。彼根或缘不善。或缘善。或缘无记。或无所缘。诸根因不善缘不善者。谓根不善缘不善。及根无记。因不善。缘不善。因不善缘善者。谓根不善缘善。及根无记。因不善。缘善。因不善缘无记者。谓根不善缘无记及根无记。因不善。缘无记。因不善无所缘者。谓无缘根。因不善。设根缘不善。彼根因不善耶。答诸根缘不善。彼根或因不善。或因善。或因无记。诸根缘不善因不善者。谓根不善缘不善。及根无记。因不善。缘不善。缘不善因善者。谓根善缘不善。及根无记。因善。缘不善。缘不善因无记者。谓根无记。缘不善。及根不善。因无记。缘不善。诸根因无记。彼根缘无记耶。答诸根因无记。彼根或缘无记。或缘善。或缘不善。或无所缘。诸根因无记缘无记者。谓根无记缘无记。及根不善。因无记。缘无记。因无记缘善者。谓根无记缘善。及根不善。因无记。缘善。因无记缘不善者。谓根无记缘不善。及根不善。因无记。缘不善。因无记无所缘者。谓无缘根。因无记。设根缘无记。彼根因无记耶。答诸根缘无记。彼根或因无记。或因善。或因不善。诸根缘无记因无记者。谓根无记缘无记。及根不善。因无记。缘无记。缘无记因善者。谓根善缘无记。及根无记。因善。缘无记。缘无记因不善者。谓根不善缘无记。及根无记。因不善。缘无记

诸根。因欲界。彼根缘欲界耶。答诸根因欲界。彼根或缘欲界。或缘色界。或缘无色界。或缘不系。或无所缘。诸根因欲界缘欲界者。谓根欲界缘欲界。因欲界缘色界者。谓根欲界缘色界。因欲界缘无色界者。谓根欲界缘无色界。因欲界缘不系者。谓根欲界缘不系。因欲界无所缘者。谓无缘根因欲界。设根缘欲界。彼根因欲界耶。答诸根缘欲界。彼根或因欲界。或因色界。或因不系。诸根缘欲界因欲界者。谓根欲界缘欲界。缘欲界因色界者。谓根色界缘欲界。缘欲界因不系者。谓根不系缘欲界。诸根因色界。彼根缘色界耶。答诸根因色界。彼根或缘色界。或缘欲界。或缘无色界。或缘不系。或无所缘。诸根因色界缘色界者。谓根色界缘色界。因色界缘欲界者。谓根色界缘欲界。因色界缘无色界者。谓根色界缘无色界。因色界缘不系者。谓根色界缘不系。因色界无所缘者。谓无缘根因色界。设根缘色界。彼根因色界耶。答诸根缘色界。彼根或因色界。或因欲界。或因无色界。或因不系。诸根缘色界因色界者。谓根色界缘色界。缘色界因欲界者。谓根欲界缘色界。缘色界因无色界者。谓根无色界缘色界。缘色界因不系者。谓根不系缘色界。诸根因无色界。彼根缘无色界耶。答诸根因无色界。彼根或缘无色界。或缘色界。或缘不系。或无所缘。诸根因无色界缘无色界者。谓根无色界缘无色界。因无色界缘色界者。谓根无色界缘色界。因无色界缘不系者。谓根无色界缘不系。因无色界无所缘者。谓无缘根因无色界。设根缘无色界。彼根因无色界耶。答诸根缘无色界。彼根或因无色界。或因欲界。或因色界或因不系。诸根缘无色界因无色界者。谓根无色界缘无色界。缘无色界因欲界者。谓根欲界缘无色界。缘无色界因色界者。谓根色界缘无色界。缘无色界因不系者。谓根不系缘无色界。诸根因学。彼根缘学耶。答诸根因学。彼根或缘学。或缘无学。或缘非学非无学。诸根因学缘学者。谓根学缘学。及根无学因学。缘学。因学缘无学者。谓根学缘无学。及根无学因学。缘无学。因学缘非学非无学者。谓根学缘非学非无学。及根无学。因学。缘非学非无学。设根缘学。彼根因学耶。答诸根缘学。彼根或因学。或因无学。或因非学非无学。诸根缘学因学者。谓根学缘学。及根无学。因学。缘学。缘学因无学者。谓根无学。缘学。缘学。因非学非无学者。谓根非学非无学。缘学。诸根因无学。彼根缘无学耶。答诸根因无学。彼根或缘无学。或缘学。或缘非学非无学。诸根因无学缘无学者。谓根无学。缘无学。因无学缘学者。谓根无学。缘学。因无学缘非学非无学者。谓根无学。缘非学非无学。设根缘无学。彼根因无学耶。答诸根缘无学。彼根或因无学。或因学。或因非学非无学。诸根缘无学因无学者。谓根无学。缘无学。缘无学因学者。谓根学缘无学。及根无学。因学。缘无学。缘无学因非学非无学者。谓根非学非无学。缘无学。诸根因非学非无学彼根缘非学非无学耶。答诸根因非学非无学。彼根或缘非学非无学。或缘学。或缘无学。或无所缘。诸根因非学非无学。缘非学非无学者。谓根非学非无学。缘非学非无学。因非学非无学缘学者。谓根非学非无学。缘学。因非学非无学缘无学者。谓根非学非无学。缘无学。因非学。非无学无所缘者。谓无缘根。因非学非无学。设根缘非学非无学。彼根因非学非无学耶。答诸根缘非学非无学。彼根或因非学非无学。或因学。或因无学。诸根缘非学非无学。因非学非无学者。谓根非学非无学。缘非学非无学。缘非学非无学因学者。谓根学。缘非学非无学。及根无学。因学。缘非学非无学。缘非学非无学因无学者。谓根无学。缘非学非无学

诸根因见断。彼根缘见断耶。答诸根因见断。彼根或缘见断。或缘修断。或缘不断。或无所缘。诸根因见断缘见断者。谓根见断。缘见断。因见断缘修断者。谓根见断缘修断。及根修断。因见断。缘修断。因见断缘不断者。谓根见断。缘不断。因见断无所缘者。谓无缘根。因见断。设根缘见断。彼根因见断耶。答诸根缘见断。彼根或因见断。或因修断。或因不断。诸根缘见断因见断者。谓根见断。缘见断。缘见断因修断者。谓根修断。缘见断。缘见断因不断者。谓根不断。缘见断。诸根因修断。彼根缘修断耶。答诸根因修断。彼根或缘修断。或缘见断。或缘不断。或无所缘。诸根因修断缘修断者。谓根修断。缘修断。因修断缘见断者。谓根修断。缘见断。因修断缘不断者。谓根修断。缘不断。因修断无所缘者。谓无缘根因修断。设根缘修断。彼根因修断耶。答诸根缘修断。彼根或因修断。或因见断。或因不断。诸根缘修断因修断者。谓根修断。缘修断。缘修断因见断者。谓根见断。缘修断。及根修断。因见断。缘修断。缘修断因不断者。谓根不断。缘修断。诸根因不断彼根缘不断耶。答诸根因不断。彼根或缘不断。或缘见断。或缘修断。诸根因不断缘不断者。谓根不断缘不断。因不断缘见断者。谓根不断缘见断。因不断缘修断者。谓根不断缘修断。设根缘不断彼根因不断耶。答诸根缘不断彼根或因不断或因见断或因修断。诸根缘不断。因不断者。谓根不断缘不断。缘不断因见断者。谓根见断缘不断。缘不断因修断者。谓根修断缘不断

诸根因见苦断。彼根缘见苦断耶。答诸根因见苦断。彼根或缘见苦断。或缘见集断。或缘见灭断。或缘见道断。或缘修断。或缘不断。或无所缘。诸根因见苦断缘见苦断者。谓根见苦断缘见苦断。及根见集断。因见苦断。缘见苦断。因见苦断。缘见集断者。谓根见苦断。缘见集断。及根见集断。因见苦断。缘见集断。因见苦断。缘见灭断者。谓根见苦断。缘见灭断。及根见集见灭断。因见苦断。缘见灭断。因见苦断。缘见道断者。谓根见苦断。缘见道断。及根见集见道断。因见苦断。缘见道断。因见苦断。缘修断者。谓根见苦断。缘修断。及根见集修断。因见苦断。缘修断。因见苦断。缘不断者。谓根见灭见道断。因见苦断。缘不断。因见苦断。无所缘者。谓无缘根因见苦断。设根缘见苦断。彼根因见苦断耶。答诸根缘见苦断彼根或因见苦断。或因见集断。或因修断。或因不断。诸根缘见苦断。因见苦断者。谓根见苦断。缘见苦断。及根见集断。因见苦断。缘见苦断。缘见苦断。因见集断者。谓根见集断。缘见苦断。及根见苦断。因见集断。缘见苦断。缘见苦断因修断者。谓根修断。缘见苦断。缘见苦断因不断者。谓根不断。缘见苦断。如见苦断。见集断亦尔。诸根因见灭断彼根缘见灭断耶。答诸根因见灭断。彼根或缘见灭断。或缘修断。或缘不断。或无所缘。诸根因见灭断缘见灭断者。谓根见灭断。缘见灭断。因见灭断缘修断者。谓根修断。因见灭断。缘修断。因见灭断缘不断者。谓根见灭断。缘不断因见灭断无所缘者。谓无缘根因见灭断。设根缘见灭断。彼根因见灭断耶。答诸根缘见灭断。彼根或因见灭断。或因见苦断。或因见集断。或因修断。或因不断。诸根缘见灭断因见灭断者。谓根因见灭断。缘见灭断。缘见灭断因见苦断者。谓根见苦断。缘见灭断。及根见集见灭断。因见苦断。缘见灭断。缘见灭断因见集断者。谓根见集断。缘见灭断。及根见苦见灭断。因见集断。缘见灭断。缘见灭断因修断者。谓根修断。缘见灭断。缘见灭断因不断者。谓根不断。缘见灭断。如见灭断。见道断亦尔

诸根因见苦断。彼根缘苦法智断耶。答诸根因见苦断。彼根或缘苦法智断。或缘苦类智断。或缘集法智断。或缘集类智断。或缘灭法智断。或缘灭类智断。或缘道法智断。或缘道类智断。或缘修断。或缘不断。或无所缘。诸根因见苦断。缘苦法智断者。谓根见苦断。缘苦法智断。及根见集断。因见苦断。缘苦法智断。因见苦断缘苦类智断者。谓根见苦断。缘苦类智断。及根见集断。因见苦断。缘苦类智断。因见苦断缘集法智断者。谓根见苦断。缘集法智断。及根见集断。因见苦断。缘集法智断。因见苦断缘集类智断者。谓根见苦断。缘集类智断。及根见集断。因见苦断。缘集类智断。因见苦断。缘灭法智断者。谓根见苦断。缘灭法智断。及根见集见灭断。因见苦断。缘灭法智断。因见苦断。缘灭类智断者。谓根见苦断。缘灭类智断。及根见集见灭断。因见苦断。缘灭类智断。因见苦断。缘道法智断者。谓根见苦断。缘道法智断。及根见集见道断。因见苦断。缘道法智断。因见苦断。缘道类智断者。谓根见苦断。缘道类智断。及根见集见道断。因见苦断。缘道类智断。因见苦断。缘修断者。谓根见苦断。缘修断。及根见集修断。因见苦断。缘修断。因见苦断。缘不断者。谓根见灭见道断。因见苦断。缘不断。因见苦断。无所缘者。谓无缘根因见苦断。设根缘苦法智断。彼根因见苦断耶。答诸根缘苦法智断。彼根或因见苦断。或因见集断。或因修断。或因不断。诸根缘苦法智断因见苦断者。谓根见苦断。缘苦法智断。及根见集断。因见苦断。缘苦法智断。缘苦法智断因见集断者。谓根见集断。缘苦法智断。及根见苦断。因见集断。缘苦法智断。缘苦法智断因修断者。谓根修断。缘苦法智断。缘苦法智断因不断者。谓根不断。缘苦法智断。诸根因见苦断。彼根缘苦类智断耶。答诸根因见苦断。彼根或缘苦类智断。或缘苦法智断。或缘集法智断。或缘集类智断。或缘灭法智断。或缘灭类智断。或缘道法智断。或缘道类智断。或缘修断。或缘不断。或无所缘。诸根因见苦断缘苦类智断者。谓根见苦断。缘苦类智断。及根见集断。因见苦断。缘苦类智断。因见苦断缘苦法智断者。谓根见苦断。缘苦法智断。及根见集断。因见苦断。缘苦法智断。因见苦断缘集法智断者。谓根见苦断。缘集法智断。及根见集断。因见苦断。缘集法智断。因见苦断缘集类智断者。谓根见苦断。缘集类智断。及根见集断。因见苦断。缘集类智断。因见苦断缘灭法智断者。谓根见苦断。缘灭法智断。及根见集见灭断。因见苦断。缘灭法智断。因见苦断缘灭类智断者。谓根见苦断。缘灭类智断。及根见集见灭断。因见苦断。缘灭类智断。因见苦断缘道法智断者。谓根见苦断。缘道法智断。及根见集见道断。因见苦断。缘道法智断。因见苦断缘道类智断者。谓根见苦断。缘道类智断。及根见集见道断。因见苦断。缘道类智断。因见苦断缘修断者。谓根见苦断。缘修断。及根见集修断因见苦断。缘修断。因见苦断缘不断者。谓根见灭见道断。因见苦断。缘不断。因见苦断。无所缘者。谓无缘根因见苦断。设根缘苦类智断。彼根因见苦断耶。答诸根缘苦类智断。彼根或因见苦断。或因见集断。或因修断。或因不断。诸根缘苦类智断因见苦断者。谓根见苦断。缘苦类智断。及根见集断。因见苦断。缘苦类智断。缘苦类智断因见集断者。谓根见集断。缘苦类智断。及根见苦断。因见集断。缘苦类智断。缘苦类智断因修断者。谓根修断。缘苦类智断。缘苦类智断因不断者。谓根不断。缘苦类智断。如于苦于集亦尔。诸根因见灭断。彼根缘灭法智断耶。答诸根因见灭断。彼根或缘灭法智断。或缘灭类智断。或缘修断。或缘不断。或无所缘。诸根因见灭断缘灭法智断者。谓根见灭断。缘灭法智断。因见灭断缘灭类智断者。谓根见灭断。缘灭类智断。因见灭断缘修断者。谓根修断。因见灭断缘修断。因见灭断缘不断者。谓根见灭断。缘不断。因见灭断无所缘者。谓无缘根因见灭断设根缘灭法智断。彼根因见灭断耶。答诸根缘灭法智断。彼根或因见灭断。或因见苦断。或因见集断。或因修断。或因不断。诸根缘灭法智断因见灭断者。谓根见灭断。缘灭法智断。缘灭法智断因见苦断者。谓根见苦断。缘灭法智断。及根见集见灭断。因见苦断。缘灭法智断。缘灭法智断因见集断者。谓根见集断。缘灭法智断。及根见苦见灭断。因见集断。缘灭法智断。缘灭法智断因修断者。谓根修断。缘灭法智断。缘灭法智断因不断者。谓根不断。缘灭法智断。诸根因见灭断。彼根缘灭类智断耶。答诸根因见灭断。彼根或缘灭类智断。或缘灭法智断。或缘修断。或缘不断。或无所缘。诸根因见灭断缘灭类智断者。谓根见灭断。缘灭类智断。因见灭断缘灭法智断者。谓根见灭断。缘灭法智断。因见灭断缘修断者。谓根修断。因见灭断。缘修断。因见灭断缘不断者。谓根见灭断。缘不断因见灭断无所缘者。谓无缘根因见灭断。设根缘灭类智断。彼根因见灭断耶。答诸根缘灭类智断。彼根或因见灭断。或因见苦断。或因见集断。或因修断或因不断。诸根缘灭类智断因见灭断者。谓根见灭断。缘灭类智断。缘灭类智断因见苦断者。谓根见苦断。缘灭类智断。及根见集见灭断。因见苦断。缘灭类智断。缘灭类智断因见集断者。谓根见集断。缘灭类智断。及根见苦见灭断。因见集断。缘灭类智断。缘灭类智断因修断者。谓根修断。缘灭类智断。缘灭类智断因不断者。谓根不断。缘灭类智断。如于灭于。道亦尔

诸根因苦法智断。彼根缘苦法智断耶。答诸根因苦法智断。彼根或缘苦法智断或缘苦类智断。或缘集法智断。或缘集类智断。或缘灭法智断。或缘灭类智断。或缘道法智断。或缘道类智断或缘修断。或缘不断。或无所缘。诸根因苦法智断缘苦法智断者。谓根苦法智断。缘苦法智断。及根集法智断。因苦法智断。缘苦法智断。因苦法智断缘苦类智断者谓根苦法智断。缘苦类智断。及根集法智断。因苦法智断。缘苦类智断。因苦法智断缘集法智断者。谓根苦法智断。缘集法智断。及根集法智断。因苦法智断。缘集法智断。因苦法智断缘集类智断者。谓根苦法智断。缘集类智断。及根集法智断。因苦法智断。缘集类智断。因苦法智断缘灭法智断者。谓根苦法智断。缘灭法智断。及根集灭。法智断。因苦法智断。缘灭法智断。因苦法智断缘灭类智断者。谓根苦法智断。缘灭类智断。及根集法智断。因苦法智断。缘灭类智断。因苦法智断缘道法智断者。谓根苦法智断。缘道法智断。及根集道法智断。因苦法智断。缘道法智断。因苦法智断缘道类智断者。谓根苦法智断。缘道类智断。及根集法智断。因苦法智断。缘道类智断。因苦法智断缘修断者。谓根苦法智断。缘修断及根集法智修断。因苦法智断。缘修断。因苦法智断缘不断者。谓根灭道法智断。因苦法智断。缘不断因苦法智断无所缘者。谓无缘根因苦法智断。设根缘苦法智断。彼根因苦法智断耶。答诸根缘苦法智断。彼根或因苦法智断。或因集法智断。或因修断。或因不断。缘苦法智断因苦法智断者。谓根苦法智断。缘苦法智断。及根集法智断。因苦法智断。缘苦法智断。缘苦法智断因集法智断者。谓根集法智断。缘苦法智断。及根苦法智断。因集法智断。缘苦法智断。缘苦法智断因修断者。谓根修断。缘苦法智断。缘苦法智断因不断者。谓根不断。缘苦法智断。诸根因苦类智断。彼根或缘苦类智断耶。答诸根因苦类智断。彼根或缘苦类智断。或缘集类智断。或缘灭类智断。或缘道类智断。或缘修断。或缘不断。诸根因苦类智断缘苦类智断者。谓根苦类智断。缘苦类智断。及根集类智断因苦类智断。缘苦类智断。因苦类智断缘集类智断者。谓根苦类智断。缘集类智断。及根集类智断。因苦类智断。缘集类智断。因苦类智断缘灭类智断者。谓根苦类智断。缘灭类智断。及根集灭类智断。因苦类智断。缘灭类智断。因苦类智断缘道类智断者。谓根苦类智断。缘道类智断。及根集道类智断。因苦类智断。缘道类智断。因苦类智断缘修断者。谓根苦类智断。缘修断。及根集类智修断。因苦类智断。缘修断。因苦类智断。缘不断者。谓根灭道类智断。因苦类智断。缘不断。设根缘苦类智断。彼根因苦类智断耶。答诸根缘苦类智断。彼根或因苦类智断。或因苦法智断。或因集法智断。或因集类智断。或因修断。或因不断。缘苦类智断因苦类智断者。谓根苦类智断。缘苦类智断。及根集类智断。因苦类智断。缘苦类智断。缘苦类智断因苦法智断者。谓根苦法智断。缘苦类智断。及根集法智断因苦法智断。缘苦类智断。缘苦类智断因集法智断者。谓根集法智断。缘苦类智断。及根苦法智断。因集法智断。缘苦类智断。缘苦类智断因集类智断者。谓根集类智断。缘苦类智断。及根苦类智断。因集类智断。缘苦类智断。缘苦类智断因修断者。谓根修断。缘苦类智断。缘苦类智断因不断者。谓根不断。缘苦类智断。如于苦于集断亦尔

诸根因灭法智断。彼根缘灭法智断耶。答诸根因灭法智断。彼根或缘灭法智断。或缘修断。或缘不断。或无所缘。诸根因灭法智断缘灭法智断者。谓根灭法智断。缘灭法智断。因灭法智断缘修断者。谓根修断。因灭法智断。缘修断因灭法智断缘不断者。谓根灭法智断。缘不断。因灭法智断无所缘者。谓无缘根因灭法智断。设根缘灭法智断。彼根因灭法智断耶。答诸根缘灭法智断。彼根或因灭法智断。或因苦法智断。或因集法智断。或因修断。或因不断。诸根缘灭法。智断因灭法智断者。谓根灭法智断。缘灭法智断。缘灭法智断因苦法智断者。谓根苦法智断。缘灭法智断。及根集灭法智断。因苦法智断。缘灭法智断。缘灭法智断因集法智断者。谓根集法智断。缘灭法智断。及根苦法智断。灭法智断。因集法智断。缘灭法智断。缘灭法智断因修断者。谓根修断。缘灭法智断。缘灭法智断。因不断者。谓根不断。缘灭法智断。诸根因灭类智断。彼根缘灭类智断耶。答诸根因灭类智断。彼根或缘灭类智断。或缘不断。诸根因灭类智断缘灭类智断者。谓根灭类智断。缘灭类智断。因灭类智断缘不断者。谓根灭类智断。缘不断。设根缘灭类智断。彼根因灭类智断耶。答诸根缘灭类智断。彼根或因灭类智断。或因苦法智断。或因苦类智断。或因集法智断。或因集类智断。或因修断。或因不断。诸根缘灭类智断因灭类智断者。谓根灭类智断。缘灭类智断。缘灭类智断因苦法智断者。谓根苦法智断缘灭类智断。及根集法智断。因苦法智断。缘灭类智断。缘灭类智断因苦类智断者。谓根苦类智断。缘灭类智断。及根集灭类智断。因苦类智断。缘灭类智断。缘灭类智断因集法智断者。谓根集法智断。缘灭类智断。及根苦法智断因集法智断。缘灭类智断。缘灭类智断因集类智断者。谓根集类智断。缘灭类智断。及根苦灭类智断。因集类智断。缘灭类智断。缘灭类智断因修断者。谓根修断。缘灭类智断。缘灭类智断。因不断者。谓根不断。缘灭类智断。如于灭于道亦尔

诸根因苦法智断。彼根缘见苦断耶。答诸根因苦法智断。彼根或缘见苦断。或缘见集断。或缘见灭断。或缘见道断或缘修断。或缘不断。或无所缘。诸根因苦法智断缘见苦断者。谓根苦法智断。缘见苦断。及根集法智断。因苦法智断。缘见苦断。因苦法智断缘见集断者。谓根苦法智断。缘见集断。及根集法智断。因苦法智断。缘见集断。因苦法智断缘见灭断者。谓根苦法智断。缘见灭断。及根集灭法智断因苦法智断。缘见灭断。因苦法智断缘见道断者。谓根苦法智断。缘见道断及根集道法智断。因苦法智断。缘见道断。因苦法智断缘修断者。谓根苦法智断。缘修断。及根集法智断。修断因苦法智断。缘修断。因苦法智断缘不断者。谓根灭道法智断。因苦法智断。缘不断。因苦法智断无所缘者。谓无缘根因苦法智断。设根缘见苦断。彼根因苦法智断耶。答诸根缘见苦断。彼根或因苦法智断。或因苦类智断。或因集法智断。或因集类智断。或因修断。或因不断。诸根缘见苦断因苦法智断者。谓根苦法智断。缘见苦断。及根集法智断。因苦法智断。缘见苦断。缘见苦断因苦类智断者。谓根苦类智断。缘见苦断。及根集类智断。因苦类智断。缘见苦断。缘见苦断因集法智断者。谓根集法智断。缘见苦断。及根苦法智断。因集法智断。缘见苦断。缘见苦断因集类智断者。谓根集类智断。缘见苦断。及根苦类智断。因集类智断。缘见苦断。缘见苦断因修断者。谓根修断。缘见苦断。缘见苦断因不断者。谓根不断。缘见苦断。诸根因苦类智断。彼根缘见苦断耶。答诸根因苦类智断。彼根或缘见苦断。或缘见集断。或缘见灭断。或缘见道断。或缘修断。或缘不断。诸根因苦类智断缘见苦断者。谓根苦类智断。缘见苦断。及根集类智断。因苦类智断。缘见苦断因苦类智断缘见集断者。谓根苦类智断。缘见集断。及根集类智断。因苦类智断。缘见集断。因苦类智断缘见灭断者。谓根苦类智断。缘见灭断。及根集灭类智断。因苦类智断。缘见灭断因苦类智断缘见道断者。谓根苦类智断。缘见道断。及根集道类智断。缘见道断。因苦类智断缘修断者。谓根苦类智断。缘修断。及根集类智断。修断。因苦类智断。缘修断。因苦类智断缘不断者。谓根灭道类智断。因苦类智断。缘不断。设根缘见苦断。彼根因苦类智断耶。答诸根缘见苦断。彼根或因苦类智断。或因苦法智断。或因集法智断。或因集类智断。或因修断。或因不断。诸根缘见苦断因苦类智断者。谓根苦类智断。缘见苦断。及根集类智断。因苦类智断。缘见苦断。缘见苦断因苦法智断者。谓根苦法智断。缘见苦断。及根集法智断。因苦法智断。缘见苦断。缘见苦断因集法智断者。谓根集法智断。缘见苦断。及根苦法智断。因集法智断。缘见苦断。缘见苦断因集类智断者。谓根集类智断。缘见苦断。及根苦类智断。因集类智断。缘见苦断。缘见苦断因修断者。谓根修断。缘见苦断。缘见苦断因不断者。谓根不断。缘见苦断。如于苦于集亦尔

诸根因灭法智断。彼根缘见灭断耶。答诸根因灭法智断。彼根或缘见灭断。或缘修断。或缘不断。或无所缘。诸根因灭法智断缘见灭断者。谓根灭法智断。缘见灭断。因灭法智断缘修断者。谓根修断。因灭法智断。缘修断。因灭法智断缘不断者。谓根灭法智断。缘不断。因灭法智断无所缘者。谓无缘根因灭法智断。设根缘见灭断。彼根因灭法智断耶。答诸根缘见灭断。彼根或因灭法智断。或因灭类智断。或因苦法智断。或因苦类智断。或因集法智断。或因集类智断。或因修断。或因不断。诸根缘见灭断因灭法智断者。谓根灭法智断。缘见灭断。缘见灭断因灭类智断者。谓根灭类智断缘见灭断。缘见灭断因苦法智断者。谓根苦法智断。缘见灭断。及根集灭法智断。因苦法智断。缘见灭断。缘见灭断因苦类智断者。谓根苦类智断。缘见灭断。及根集灭类智断。因苦类智断。缘见灭断。缘见灭断因集法智断者。谓根集法智断。缘见灭断。及根苦灭法智断。因集法智断。缘见灭断。缘见灭断因集类智断者。谓根集类智断。缘见灭断。及根苦灭类智断。因集类智断。缘见灭断。缘见灭断因修断者。谓根修断。缘见灭断。缘见灭断因不断者。谓根不断。缘见灭断。诸根因灭类智断。彼根缘见灭断耶。答诸根因灭类智断。彼根或缘见灭断。或缘不断。诸根因灭类智断缘见灭断者。谓根因灭类。智断缘见灭断因灭类智断缘不断者。谓根灭类智断。缘不断。设根缘见灭断。彼根因灭类智断耶。答诸根缘见灭断。彼根或因灭类智断。或因灭法智断。或因苦法智断。或因苦类智断。或因集法智断。或因集类智断。或因修断。或因不断。诸根缘见灭断因灭类智断者。谓根灭类智断。缘见灭断。缘见灭断因灭法智断者。谓根灭法智断。缘见灭断。缘见灭断因苦法智断者。谓根苦法智断。缘见灭断。及根集灭法智断。因苦法智断。缘见灭断。缘见灭断因苦类智断。者谓根苦类智断。缘见灭断。及根集灭类智断。因苦类智断。缘见灭断。缘见灭断因集法智断者。谓根集法智断。缘见灭断。及根苦灭法智断。因集法智断。缘见灭断。缘见灭断因集类智断者。谓根集类智断。缘见灭断。及根苦灭类智断。因集类智断。缘见灭断。缘见灭断因修断者。谓根修断。缘见灭断。缘见灭断因不断者。谓根不断。缘见灭断。如于灭于道亦尔

说一切有部发智论卷第十六阿毗达磨发智论卷第十七

        尊者迦多衍尼子造

        三藏法师玄奘奉　诏译

    定蕴第七中得纳息第一

  五得四起支　　味入生无量
  断结受果处　　此章愿具说

诸得过去法。彼得过去耶。答彼得。或过去。或未来。或现在。设得过去。彼得过去法耶。答彼法。或过去。或未来。或现在。或无为。诸得未来法。彼得未来耶。答彼得。或未来。或过去。或现在。设得未来。彼得未来法耶。答彼法。或未来。或过去。或现在。或无为。诸得现在法。彼得现在耶。答彼得。或现在。或过去。或未来。设得现在。彼得现在法耶。答彼法。或现在。或过去。或未来。或无为。诸得善法。彼得善耶。答如是。设得善。彼得善法耶。答如是。诸得不善法。彼得不善耶。答如是。设得不善。彼得不善法耶。答如是。诸得无记法。彼得无记耶。答如是。设得无记。彼得无记法耶。答如是。诸得欲界法。彼得欲界耶。答如是。设得欲界。彼得欲界法耶。答彼法。或欲界。或不系。诸得色界法。彼得色界耶。答如是。设得色界。彼得色界法耶。答彼法。或色界。或不系。诸得无色界法。彼得无色界耶。答如是。设得无色界。彼得无色界法耶。答彼法。或无色界。或不系。诸得学法。彼得学耶。答如是。设得学。彼得学法耶。答彼法。或学。或非学非无学。诸得无学法。彼得无学耶。答如是。设得无学。彼得无学法耶。答彼法。或无学。或非学非无学。诸得非学非无学法。彼得非学非无学耶。答彼得。或非学非无学。或学。或无学。设得非学非无学。彼得非学非无学法耶。答如是。诸得见所断法。彼得见所断耶。答如是。设得见所断。彼得见所断法耶。答如是。诸得修所断法。彼得修所断耶。答如是。设得修所断。彼得修所断法耶。答彼法。或修所断。或不断。诸得不断法。彼得不断耶。答彼得。或不断。或修所断。设得不断。彼得不断法耶。答如是

诸法善无色起。彼法善心俱耶。答诸法善无色起。彼法。或善心俱。或不善心俱。或无记心俱。云何善心俱。答诸法彼心相应。彼心俱有善无色。云何不善心俱。答如不善心。若退若生。善法得起。云何无记心俱。答如无记心。若退若生。善法得起。设法善心俱起。彼法善无色耶。答诸法善心俱起。彼法。或善无色。或无记无色。云何善无色。答诸法彼心相应。彼心俱有善无色。云何无记无色。答如善心胜进。无记法得起。及住善心。无记诸根长养。大种增益。彼法得生老住无常。诸法不善无色起。彼法不善心俱耶。答诸法不善无色起。彼法。或不善心俱。或无记心俱。云何不善心俱。答诸法彼心相应。彼心俱有不善无色。云何无记心俱。答如无记心。若退若生。不善法得起。设法不善心俱起。彼法不善无色耶。答诸法不善心俱起。彼法。或不善无色。或善无色。或无记无色。云何不善无色。答诸法彼心相应。彼心俱有不善无色。云何善无色。答如不善心。若退若生。善法得起。云何无记无色。答如不善心。若退若生。无记法得起。及住不善心。无记诸根长养。大种增益。彼法得生老住无常。诸法无记无色起。彼法无记心俱耶。答诸法无记无色起。彼法。或无记心俱。或善心俱。或不善心俱。云何无记心俱。答诸法彼心相应。彼心俱有无记无色。云何善心俱。答如善心胜进。无记法得起。及住善心。无记诸根长养。大种增益。彼法得生老住无常。云何不善心俱。答如不善心。若退若生无记法得起。及住不善心无记。诸根长养。大种增益。彼法得生老住无常。设法无记心俱起。彼法无记无色耶。答诸法无记心俱起。彼法。或无记无色。或善无色。或不善无色。云何无记无色。答诸法彼心相应。彼心俱有无记无色。云何善无色。答如无记心。若退若生。善法得起。云何不善无色。答如无记心。若退若生。不善法得起。诸法欲界无色起。彼法欲界心俱耶。答诸法欲界无色起。彼法。或欲界心俱。或色界心俱。或无色界心俱。或不系心俱。云何欲界心俱。答诸法彼心相应。彼心俱有欲界无色。云何色界心俱。答如色界心。若生若胜进。欲界法得起。及住色界心。欲界诸根长养。大种增益。彼法得生老住无常。云何无色界心俱。答如住无色界心。欲界诸根长养。大种增益。彼法得生老住无常。云何不系心俱。答如不系心胜进。欲界法得起。及住不系心。欲界诸根长养。大种增益。彼法得生老住无常。设法欲界心俱。起彼法欲界无色耶。答诸法欲界心俱起。彼法。或欲界无色。或色界无色。或无色界无色。或不系无色。云何欲界无色。答诸法彼心相应。彼心俱有欲界无色。云何色界无色。答如欲界心。若退若生。色界法得起。云何无色界无色。答如欲界心。若退若生。无色界法得起。云何不系无色。答如欲界心退。不系法得起。诸法色界无色起。彼法色界心俱耶。答诸法色界无色起。彼法。或色界心俱。或欲界心俱。或无色界心俱。或不系心俱。云何色界心俱。答诸法彼心相应。彼心俱有色界无色。云何欲界心俱。答如欲界心。若退若生。色界法得起。云何无色界心俱。答如住无色界心色界。诸根长养。大种增益。彼法得生老住无常。云何不系心俱。答如不系心胜进。色界法得起。及住不系心。色界诸根长养。大种增益。彼法得生老住无常。设法色界心俱起。彼法色界无色耶。答诸法色界心俱起。彼法。或色界无色。或欲界无色。或无色界无色。或不系无色。云何色界无色。答诸法彼心相应。彼心俱有色界无色。云何欲界无色。答如色界心。若生若胜进。欲界法得起。及住色界心。欲界诸根长养。大种增益。彼法得生老住无常。云何无色界无色。答如色界心。若退若生。无色界法得起。云何不系无色。答如色界心。若退若胜进。不系法得起。诸法无色界无色起。彼法无色界心俱耶。答诸法无色界无色起。彼法。或无色界心俱。或欲界心俱。或色界心俱。或不系心俱。云何无色界心俱。答诸法彼心相应。彼心俱有无色界无色。云何欲界心俱。答如欲界心。若退若生。无色界法得起。云何色界心俱。答如色界心。若退若生。无色界法得起。云何不系心俱。答如不系心胜进。无色界法得起。设法无色界心俱起。彼法无色界无色耶。答诸法无色界心俱起。彼法。或无色界无色。或欲界无色。或色界无色。或不系无色。云何无色界无色。答诸法彼心相应。彼心俱有无色界无色。云何欲界无色。答如住无色界心。欲界诸根长养。大种增益。彼法得生老住无常。云何色界无色。答如住无色界心。色界诸根长养。大种增益。彼法得生老住无常。云何不系无色。答如无色界心。若退若胜进。不系法得起

诸法学无色起。彼法学心俱耶。答诸法学无色起。彼法。或学心俱。或非学非无学心俱。云何学心俱。答诸法彼心相应。彼心俱有学无色。云何非学非无学心俱。答如非学非无学心。若退若胜进。学法得起。设法学心俱起。彼法学无色耶。答诸法学心俱起。彼法。或学无色。或非学非无学无色。云何学无色。答诸法彼心相应。彼心俱有学无色。云何非学非无学无色。答如学心胜进。非学非无学法得起。及住学心。非学非无学诸根长养。大种增益。彼法得生老住无常。诸法无学无色起。彼法无学心俱耶。答诸法无学无色起。彼法或无学心俱。或非学非无学心俱。云何无学心俱。答诸法彼心相应。彼心俱有无学无色。云何非学非无学心俱。答如非学非无学心。若退若胜进。无学法得起。设法无学心俱起。彼法无学无色耶。答诸法无学心俱起。彼法。或无学无色。或非学非无学无色。云何无学无色。答诸法彼心相应。彼心俱有无学无色。云何非学非无学无色。答如无学心胜进。非学非无学法得起。及住无学心。非学非无学诸根长养。大种增益。彼法得生老住无常。诸法非学非无学无色起。彼法非学非无学心俱耶。答诸法非学非无学无色起。彼法。或非学非无学心俱。或学心俱。或无学心俱。云何非学非无学心俱。答诸法彼心相应。彼心俱有非学非无学无色。云何学心俱。答如学心胜进。非学非无学法得起。及住学心。非学非无学诸根长养。大种增益。彼法得生老住无常。云何无学心俱。答如无学心胜进。非学非无学法得起。及住无学心。非学非无学诸根长养。大种增益。彼法得生老住无常。设法非学非无学心俱起。彼法非学非无学无色耶。答诸法非学非无学心俱起。彼法。或非学非无学无色。或学无色。或无学无色。云何非学非无学无色。答诸法彼心相应。彼心俱有非学非无学无色。云何学无色。答如非学非无学心。若退若胜进。学法得起。云何无学无色。答如非学非无学心。若退若胜进。无学法得起

诸法见断无色起。彼法见断心俱耶。答诸法见断无色起。彼法。或见断心俱。或修断心俱。云何见断心俱。答诸法彼心相应。彼心俱有见断无色。云何修断心俱。答如修断心。若退若生。见断法得起。设法见断心俱起。彼法见断无色耶。答诸法见断心俱起。彼法。或见断无色。或修断无色。云何见断无色。答诸法彼心相应。彼心俱有见断无色。云何修断无色。答如见断心。若退若生。修断法得起。及住见断心。修断诸根长养。大种增益。彼法得生老住无常。诸法修断无色起。彼法修断心俱耶。答诸法修断无色起。彼法。或修断心俱。或见断心俱。或不断心俱。云何修断心俱。答诸法彼心相应。彼心俱有修断无色。云何见断心俱。答如见断心。若退若生。修断法得起。及住见断心。修断诸根长养。大种增益。彼法得生老住无常。云何不断心俱。答如不断心胜进。修断法得起。及住不断心。修断诸根长养。大种增益。彼法得生老住无常。设法修断心俱起。彼法修断无色耶。答诸法修断心俱起。彼法或修断无色。或见断无色。或不断无色。云何修断无色。答诸法彼心相应。彼心俱有修断无色。云何见断无色。答如修断心。若退若生。见断法得起。云何不断无色。答如修断心。若退若胜进。不断法得起。诸法不断无色起。彼法不断心俱耶。答诸法不断无色起。彼法。或不断心俱。或修断心俱。云何不断心俱。答诸法彼心相应。彼心俱有不断无色。云何修断心俱。答如修断心。若退若胜进。不断法得起。设法不断心俱起。彼法不断无色耶。答诸法不断心俱起。彼法。或不断无色。或修断无色。云何不断无色。答诸法彼心相应。彼心俱有不断无色。云何修断无色。答如不断心胜进。修断法得起。及住不断心。修断诸根长养。大种增益。彼法得生老住无常

一切初静虑。皆有五支耶。答不染污有五。染污无五。无何等。答无离生喜乐。一切第二静虑。皆有四支耶。答不染污有四。染污无四。无何等。答无内等净。一切第三静虑。皆有五支耶。答不染污有五。染污无五。无何等。答无正念正知。一切第四静虑。皆有四支耶。答不染污有四。染污无四。无何等。答无舍念清净

味相应初静虑。入当言味耶。出当言味耶。答于能味。当言入。于所味。当言出。乃至味相应非想非非想处。入当言味耶。出当言味耶。答于能味。当言入。于所味。当言出。诸味相应初静虑。皆有覆无记耶。设有覆无记初静虑。皆味相应耶。答诸味相应初静虑。皆有覆无记。有有覆无记初静虑。非味相应。谓除爱余烦恼现前。乃至诸味相应非想非非想处。皆有覆无记耶。设有覆无记非想非非想处。皆味相应耶。答诸味相应非想非非想处。皆有覆无记。有有覆无记非想非非想处。非味相应。谓除爱余烦恼现前。颇有不入初静虑入第二静虑耶。答入。乃至颇有不入无所有处入非想非非想处耶。答入。颇有不入初静虑生梵世耶。答生。乃至颇有不入非想非非想处生非想非非想处耶。答生。若得初静虑。非第二静虑。彼命终生何处。答或梵世。或极光净。或遍净。或广果。或空无边处。或识无边处。或无所有处。或非想非非想处。或无处所。乃至若得无所有处非想非非想处。彼命终生何处。答或无所有处。或非想非非想处。或无处所

思惟何等入慈定。答与有情乐。思惟何等入悲定。答拔有情苦。思惟何等入喜定。答庆诸有情。思惟何等入舍定。答于有情舍慈。断何系结。答无。悲喜舍。断何系结。答无。净初静虑。断何系结。答无。乃至净非想非非想处。断何系结。答无。初第二第三解脱。断何系结。答无。空无边处解脱。断何系结。答或空无边处。或识无边处。或无所有处。或非想非非想处。或无。识无边处解脱。断何系结。答或识无边处。或无所有处。或非想非非想处。或无。无所有处解脱。断何系结。答或无所有处。或非想非非想处。或无。非想非非想处解脱。灭受想解脱。断何系结。答无。初胜处。断何系结。答无。乃至第八胜处。断何系结。答无。初遍处。断何系结。答无。乃至第十遍处。断何系结。答无。法智。断何系结。答或欲界。或色界。或无色界。或无类智。断何系结。答或色界。或无色界。或无。他心智。断何系结。答无世俗智。断何系结。答或欲界。或色界。或无色界或无。如世俗智。苦集灭道智空无愿无相三摩地亦尔

慈异熟何处受。答或梵世。或极光净。或遍净。或广果。或无处所。如慈悲舍亦尔。喜异熟何处受。答或梵世。或极光净。或无处所。净初静虑异熟何处受。答或梵世。或无处所。净第二静虑异熟何处受。答或极光净。或无处所。净第三静虑异熟何处受。答或遍净。或无处所。净第四静虑异熟何处受。答或广果。或无处所。净空无边处异熟何处受。答或空无边处。或无处所。净识无边处异熟何处受。答或识无边处。或无处所。净无所有处异熟何处受。答或无所有处。或无处所。净非想非非想处异熟何处受。答或非想非非想处。或无处所。初第二解脱异熟何处受。答或梵世。或极光净。或无处所。净解脱异熟何处受。答或广果。或无处所。空无边处解脱。乃至非想非非想处解脱异熟何处受。答或自地。或无处所。灭受想解脱异熟何处受。答或非想非非想处。或无处所。初四胜处异熟何处受。答或梵世。或极光净。或无处所。后四胜处异熟何处受。答或广果。或无处所。如后四胜处。前八遍处亦尔。后二遍处异熟何处受。答或自地。或无处所。他心智异熟何处受。答或梵世。或极光净。或遍净。或广果。或无处所。世俗智异熟何处受。答或欲界。或色界。或无色界。或无处所

    定蕴第七中缘纳息第二

  八味净无漏　　成不成得舍
  退修初入缘　　此章愿具说

有八定。谓四静虑。四无色。有三定。谓味相应净无漏。此中前七。各具三种。第八唯二。谓除无漏。颇有成就味相应初静虑非净无漏耶。答有。谓欲界爱未尽。颇有成就净初静虑非味相应无漏耶。答有。谓异生生欲界梵世。梵世爱尽。颇有成就无漏初静虑非味相应净耶。答有。谓圣者生梵世上。颇有成就味相应净初静虑非无漏耶。答有。谓异生生欲界。欲界爱尽。梵世爱未尽。及生梵世。梵世爱未尽。颇有成就味相应无漏初静虑非净耶。答无。颇有成就净无漏初静虑非味相应耶。答有。谓圣者生欲界梵世。梵世爱尽。颇有成就味相应净无漏初静虑耶。答有。谓圣者生欲界。欲界爱尽。梵世爱未尽。及生梵世。梵世爱未尽

颇有不成就味相应初静虑非净无漏耶。答有。谓圣者生欲界梵世。梵世爱尽。颇有不成就净初静虑非味相应无漏耶。答无。颇有不成就无漏初静虑非味相应净耶。答有。谓异生生欲界。欲界爱尽。梵世爱未尽。及生梵世。梵世爱未尽。颇有不成就味相应净初静虑非无漏耶。答有。谓圣者生梵世上。颇有不成就味相应无漏初静虑非净耶。答有。谓异生生欲界梵世。梵世爱尽。颇有不成就净无漏初静虑非味相应耶。答有。谓欲界爱未尽。颇有不成就味相应净无漏初静虑耶。答有。谓异生生梵世上

颇有得味相应初静虑非净无漏耶。答有。谓从梵世爱尽退时。及梵世上没。生欲界时。颇有得净初静虑非味相应无漏耶。答有。谓异生欲界爱尽时。颇有得无漏初静虑非味相应净耶。答有。谓依静虑静虑中间。入正性离生。及得阿罗汉果时。颇有得味相应净初静虑非无漏耶。答有。谓梵世上没。生梵世时。颇有得味相应无漏初静虑非净耶。答无。颇有得净无漏初静虑非味相应耶。答有。谓圣者欲界爱尽时。颇有得味相应净无漏初静虑耶。答无

颇有舍味相应初静虑非净无漏耶。答有。谓梵世爱尽时。颇有舍净初静虑非味相应无漏耶。答有。谓异生从欲界爱尽退时。及欲界梵世没。生梵世上时。并梵世没。生欲界时。颇有舍净无漏初静虑非味相应耶。答有。谓圣者从欲界爱尽退时。颇有余舍耶。答无

颇有退味相应初静虑非净无漏耶。答无。颇有退净初静虑非味相应无漏耶。答有。谓异生从欲界爱尽退时。颇有退净无漏初静虑非味相应耶。答有。谓圣者。从欲界爱尽退时。颇有余退耶。答无。如说初静虑。乃至无所有处说亦如是

若修净初静虑。彼亦修无漏耶。设修无漏初静虑。彼亦修净耶。答应作四句。有修净初静虑非无漏。谓已得净初静虑。现在前。若未得净初静虑现在前。而不修无漏。若未得非初静虑世俗智现在前。而修净初静虑非无漏。有修无漏初静虑非净。谓已得无漏初静虑现在前。若未得无漏初静虑现在前。而不修净。若未得非初静虑世俗智。及未得非初静虑无漏智彼现在前。而修无漏初静虑非净。有修净初静虑亦无漏。谓未得净初静虑现在前。而修无漏。若未得无漏初静虑现在前而修净。若未得非初静虑世俗智无漏智。彼现在前。而修净初静虑及无漏。有不修净初静虑亦非无漏。谓已得非初静虑世俗智无漏智现在前。若未得非初静虑世俗智无漏智。彼现在前。而不修净初静虑及无漏。若一切染污心。无记心。现在前。若住无想定灭尽定。生无想天。如说初静虑。第二第三静虑说。亦如是。若修净第四静虑。彼亦修无漏耶。设修无漏第四静虑。彼亦修净耶。答应作四句。有修净第四静虑非无漏。谓已得净第四静虑现在前。若未得净第四静虑现在前。而不修无漏。有修无漏第四静虑非净。谓已得无漏第四静虑现在前。若未得无漏第四静虑现在前。而不修净。若未得非第四静虑世俗智。及未得非第四静虑无漏智。彼现在前。而修无漏第四静虑非净。有修净第四静虑亦无漏。谓未得净第四静虑现在前。而修无漏。若未得无漏第四静虑现在前而修净。若未得非第四静虑无漏智现在前。而修净第四静虑及无漏。有不修净第四静虑亦非无漏。谓已得非第四静虑世俗智无漏智现在前。若未得非第四静虑世俗智无漏智。彼现在前。而不修净第四静虑及无漏。若一切染污心无记心现在前。若住无想定灭尽定。生无想天。如说第四静虑。乃至无所有处说亦如是

若最初入无漏初静虑。尔时所得诸余未来无漏心心所法。彼一切当言有寻有伺耶。答彼或有寻有伺。或无寻唯伺。或无寻无伺。若最初入无漏第二静虑。尔时所得诸余未来无漏心心所法。彼一切当言喜根相应耶。答彼或乐根相应。或喜根相应。或舍根相应。若最初入无漏第三静虑。尔时所得诸余未来无漏心心所法。彼一切当言乐根相应耶。答彼或乐根相应。或喜根相应。或舍根相应。若最初。入无漏第四静虑。尔时所得诸余未来无漏心心所法。彼一切当言舍根相应耶。答彼或乐根相应。或喜根相应。或舍根相应。若最初入无漏空无边处。尔时所得诸余未来无漏心心所法。彼一切当言空无边处摄耶。答彼或空无边处摄。或识无边处摄或无所有处摄。若最初入无漏识无边处。尔时所得诸余未来无漏心心所法。彼一切当言识无边处摄耶。答彼或空无边处摄。或识无边处摄。或无所有处摄。若最初入无漏无所有处

尔时所得诸余未来无漏心心所法。彼一切当言无所有处摄耶。答彼或空无边处摄。或识无边处摄。或无所有处摄

味相应初静虑。与味相应初静虑等。为几缘。答与自地味相应。为因等无间所缘增上。与自地净。为等无间所缘增上。与自地无漏。及净无漏上三静虑。为所缘增上。与余为一增上。净初静虑。与净初静虑等。为几缘。答与自地净。为因等无间所缘增上。与自地无漏味相应。及净无漏第二第三静虑。为等无间所缘增上。与净无漏第四静虑。为所缘增上。与余为一增上。无漏初静虑。与无漏初静虑等。为几缘。答与自地无漏。及无漏第二第三静虑为因。等无间所缘增上。与自地净。及净第二第三静虑。为等无间所缘增上。与净第四静虑。及净无色。为所缘增上。与无漏第四静虑。及无漏无色。为因所缘增上。与余为一增上。味相应第二静虑。与味相应第二静虑等。为几缘。答与自地味相应为因。等无间所缘增上。与净初二静虑。为等无间所缘增上。与一切无漏静虑。及净第三第四静虑。为所缘增上。与余为一增上。净第二静虑。与净第二静虑等。为几缘。答与自地净为因。等无间所缘增上。与一切无漏静虑。及净初第三第四静虑。并自地味相应。为等无间所缘增上。与余为一增上。无漏第二静虑。与无漏第二静虑等。为几缘。答与一切无漏静虑为因。等无间所缘增上。与一切净静虑。为等无间所缘增上。与净无色。为所缘增上。与无漏无色为因。所缘增上与余为一增上。味相应第三静虑。与味相应第三静虑等。为几缘。答与自地味相应为因。等无间所缘增上。与净第二第三静虑。为等无间所缘增上。与一切无漏静虑。及净初第四静虑。为所缘增上。与余为一增上。净第三静虑。与净第三静虑等。为几缘。答与自地净为因。等无间所缘增上。与一切无漏静虑。及净初第二第四静虑。并自地味相应。为等无间所缘增上。与净无漏空无边处。为等无间增上。与余为一增上。无漏第三静虑。与无漏第三静虑等。为几缘。答与无漏四静虑空无边处为因。等无间所缘增上。与净四静虑空无边处。为等无间所缘增上。与净上三无色。为所缘增上。与无漏上二无色为因。所缘增上。与余为一增上。味相应第四静虑。与味相应第四静虑等。为几缘。答与自地味相应为因。等无间所缘增上。与净第三第四静虑。为等无间所缘增上。与无漏四静虑。及净初第二静虑。为所缘增上。与余为一增上。净第四静虑。与净第四静虑等。为几缘。答与自地净为因。等无间所缘增上。与无漏上三静虑。及净第二第三静虑。并自地味相应。为等无间所缘增上。与净无漏初二无色。为等无间增上。与净无漏初静虑。为所缘增上。与余为一增上。无漏第四静虑。与无漏第四静虑等。为几缘。答与无漏上三静虑下二无色为因。等无间所缘增上。与净上三静虑初二无色。为等无间所缘增上。与净初静虑后二无色。为所缘增上。与无漏初静虑无所有处为因。所缘增上。与余为一增上。味相应空无边处。与味相应空无边处等。为几缘。答与自地味相应为因。等无间所缘增上。与自地净。及净第四静虑。为等无间所缘增上。与一切无漏静虑。及净下三静虑。为所缘增上。与余为一增上。净空无边处。与净空无边处等。为几缘。答与自地净为因。等无间所缘增上。与自地无漏。及净无漏第三第四静虑。并自地味相应。为等无间所缘增上。与净无漏识无边处无所有处。为等无间增上。与净无漏初第二静虑。为所缘增上。与余为一增上。无漏空无边处。与无漏空无边处等。为几缘。答与无漏三无色后二静虑为因。等无间所缘增上。与净下三无色后二静虑。为等无间所缘增上。与净初二静虑。及净非想非非想处。为所缘增上。与无漏初二静虑为因。所缘增上与余为一增上。味相应识无边处。与味相应识无边处等。为几缘。答与自地味相应为因。等无间所缘增上。与净下二无色。为等无间所缘增上。与净无漏四静虑。及无漏下二无色。为所缘增上。与余为一增上。净识无边处。与净识无边处等。为几缘。答与自地净为因。等无间所缘增上。与自地无漏。及净无漏第四静虑空无边处。并自地味相应。为等无间所缘增上。与净无漏无所有处。及净非想非非想处。为等无间增上。与净无漏下三静虑。为所缘增上。与余为一增上。无漏识无边处。与无漏识无边处等。为几缘。答与无漏第四静虑三无色为因。等无间所缘增上。与净第四静虑四无色。为等无间所缘增上。与净下三静虑。为所缘增上。与无漏下三静虑为因。所缘增上。与余为一增上。味相应无所有处。与味相应无所有处等。为几缘。答与自地味相应为因。等无间所缘增上。与自地净及净识无边处。为等无间所缘增上。与一切地无漏及净四静虑空无边处。为所缘增上。与余为一增上。净无所有处。与净无所有处等。为几缘。答与自地净为因。等无间所缘增上。与无漏三无色。及净下二无色。并自地味相应。为等无间所缘增上。与净非想非非想处。为等无间增上。与净无漏四静虑。为所缘增上。与余为一增上。无漏无所有处。与无漏无所有处等。为几缘。答与无漏三无色为因。等无间所缘增上。与净四无色。为等无间所缘增上。与净四静虑。为所缘增上。与无漏四静虑为因。所缘增上。与余为一增上。味相应非想非非想处。与味相应非想非非想处等。为几缘。答与自地味相应。为因等无间所缘增上。与净上二无色。为等无间所缘增上。与一切地无漏。及下六地净。为所缘增上。与余为一增上。净非想非非想处。与净非想非非想处等。为几缘。答与自地净为因。等无间所缘增上。与净无漏识无边处无所有处。及自地味相应。为等无间所缘增上。与下五地净无漏。为所缘增上。与余为一增上

说一切有部发智论卷第十七阿毗达磨发智论卷第十八

        尊者迦多衍尼子造

        三藏法师玄奘奉　诏译

    定蕴第七中摄纳息第三

  摄可得相应　　成不得舍退
  顿渐灭依定　　此章愿具说

十想。谓无常想。无常苦想。苦无我想。死想。不净想。厌食想。一切世间不可乐想。断想。离想。灭想。四静虑。四无量。四无色。八解脱。八胜处。十遍处。八智。三三摩地。无常想等。摄几静虑等耶。答无常想。摄四静虑四无色四解脱。如无常想。无常苦想。苦无我想。死想。断想离想。灭想。亦尔。不净想。摄第三第四静虑初二解脱。如不净想。厌食想亦尔。一切世间不可乐想。摄第三第四静虑。初静虑等。摄几静虑等耶。答初静虑。摄初静虑四无量初二解脱前四胜处八智三三摩地。第二静虑。摄第二静虑四无量初二解脱。前四胜处八智三三摩地。第三静虑。摄第三静虑三无量八智三三摩地。第四静虑摄第四静虑三无量净解脱。后四胜处前八遍处八智三三摩地。慈无量等。摄几无量等耶。答慈摄慈世俗智。乃至舍摄舍世俗智。空无边处等。摄几无色等耶。答空无边处。摄空无边处。及彼解脱。彼遍处六智三三摩地。识无边处摄识无边处及彼解脱彼遍处六智三三摩地。无所有处。摄无所有处及彼解脱六智三三摩地。非想非非想处。摄非想非非想处及彼解脱灭想受解脱世俗智。初解脱等。摄几解脱等耶。答初第二第三解脱。摄初第二第三解脱世俗智。空无边处解脱。摄空无边处解脱及彼遍处六智三三摩地。识无边处解脱。摄识无边处解脱及彼遍处六智三三摩地。无所有处解脱。摄无所有处解脱六智三三摩地。非想非非想处解脱。摄非想非非想处解脱世俗智。灭想受解脱。摄灭想受解脱。初胜处等。摄几胜处等耶。答初胜处。摄初胜处世俗智。乃至第八胜处。摄第八胜处世俗智。初遍处等。摄几遍处等耶。答初遍处。摄初遍处世俗智。乃至第十遍处。摄第十遍处世俗智。法智等。摄几智等耶。答法智。摄法智五智少分。类智摄类智五智少分。他心智。摄他心智四智少分。世俗智。摄世俗智一智少分。苦智。摄苦智二智少分。集智。摄集智二智少分。灭智。摄灭智三智少分。道智。摄道智三智少分。空三摩地等。摄几三摩地耶。答空摄空。无愿摄无愿。无相摄无相。如摄可得亦尔

无常想等。与几静虑等相应耶。答无常想。与四静虑四无色四解脱四智一三摩地相应。如无常想。无常苦想苦无我想死想断想离想灭想亦尔。不净想。与后二静虑初二解脱世俗智相应。如不净想。厌食想亦尔。一切世间不可乐想。与后二静虑世俗智相应。初静虑等。与几静虑等相应耶。答初静虑。与初静虑四无量初二解脱前四胜处八智三三摩地相应。第二静虑。与第二静虑四无量初二解脱前四胜处八智三三摩地相应。第三静虑。与第三静虑三无量八智三三摩地相应。第四静虑。与第四静虑三无量净解脱后四胜处前八遍处八智三三摩地相应。慈无量等。与几无量等相应耶。答慈与慈世俗智相应。乃至舍与舍世俗智相应。空无边处等。与几无色等相应耶。答空无边处。与空无边处及彼解脱彼遍处六智三三摩地相应。识无边处。与识无边处及彼解脱彼遍处六智三三摩地相应。无所有处。与无所有处及彼解脱六智三三摩地相应。非想非非想处。与非想非非想处及彼解脱世俗智相应。初解脱等。与几解脱等相应耶。答初第二第三解脱。与初第二第三解脱世俗智相应。空无边处解脱。与空无边处解脱及彼遍处六智三三摩地相应。识无边处解脱。与识无边处解脱及彼遍处六智三三摩地相应。无所有处解脱。与无所有处解脱六智三三摩地相应。非想非非想处解脱。与非想非非想处解脱世俗智相应。灭想受解脱非相应。初胜处等。与几胜处等相应耶。答初胜处。与初胜处世俗智相应。乃至第八胜处。与第八胜处世俗智相应。初遍处等。与几遍处等相应耶。答初遍处。与初遍处世俗智相应。乃至第十遍处。与第十遍处世俗智相应。法智等。与几三摩地相应耶。答法智。与三三摩地少分相应。如法智。类智亦尔。他心智。与一三摩地少分相应。如他心智。集灭道智亦尔。苦智与二三摩地少分相应

若成就初静虑等。彼于四静虑等。几成就。几不成就。答若成就初静虑。彼于四静虑。或一二三四。一者谓梵世爱未尽。二者谓梵世爱尽。上爱未尽。三者谓极光净爱尽。上爱未尽。四者谓遍净爱尽。于四无量。或无或三或四。无者谓生无色界。三者谓生遍净广果。四者谓生欲界梵世极光净。于四无色。或无或一二三四。无者谓色爱未尽。一者谓色爱尽。上爱未尽。二者谓空无边处爱尽。上爱未尽。三者谓识无边处爱尽。上爱未尽。四者谓无所有处爱尽。于八解脱。或无或一二三四五六七八。无者谓生遍净。遍净爱未尽。一者谓生遍净。遍净爱尽。上爱未尽。若生广果。即彼爱未尽。若生空无边处。即彼爱未尽。二者谓生欲界梵世极光净遍净爱未尽。若生遍净广果。广果爱尽。上爱未尽。若生空无边处。即彼爱尽。上爱未尽。若生识无边处。即彼爱未尽。三者谓生欲界梵世极光净遍净爱尽。上爱未尽。若生遍净广果空无边处爱尽。上爱未尽。若生空识无边处识无边处爱尽。上爱未尽。若生无所有处。即彼爱未尽。四者谓生欲界梵世极光净广果爱尽。上爱未尽。若生遍净广果识无边处爱尽。上爱未尽。若生空识无边处无所有处。无所有处爱尽。若生非想非非想处。不得灭尽定。五者谓生欲界梵世极光净空无边处爱尽。上爱未尽。若生遍净广果无所有处爱尽。不得灭尽定。若生非想非非想处。得灭尽定。六者谓生欲界梵世极光净识无边处爱尽。上爱未尽。若生遍净广果。得灭尽定。七者谓生欲界梵世极光净无所有处爱尽。不得灭尽定。八者谓生欲界梵世极光净。得灭尽定。于八胜处。或无或四或八。无者谓生遍净。即彼爱未尽。若生无色界。四者谓生欲界梵世极光净遍净爱未尽。若生遍净。即彼爱尽。若生广果。八者谓生欲界梵世极光净遍净爱尽。于十遍处。或无或一二八九十。无者谓生欲界梵世极光净遍净遍净爱未尽。若生无所有处非想非非想处。一者谓生空无边处。即彼爱未尽。若生识无边处。二者谓生空无边处。即彼爱尽。八者谓生欲界梵世极光净遍净遍净爱尽。上爱未尽。若生广果。即彼爱未尽。九者谓生欲色界欲色爱尽。上爱未尽。十者谓生欲色界空无边处爱尽。于八智。或二四五六七八。二者谓异生苦法忍位。四者谓苦法智苦类忍位。五者谓苦类智集法忍位。六者谓集法智。乃至灭法忍位。七者谓灭法智。乃至道法忍位。八者谓道法智。以上诸位。于三三摩地。或无或二或三。无者谓诸异生。二者谓诸圣者灭法忍未生。三者谓灭法忍已生。如成就初静虑。乃至成就第四静虑。随所应亦尔

七补特伽罗。谓随信行。随法行。信胜解。见至。身证。慧解脱。俱解脱。随信行等。于味相应等四静虑四无色。几成就。几不成就。答随信行。于味相应四静虑。或无或一二三四。无者谓色爱尽。一者谓遍净爱尽。上爱未尽。乃至四者谓梵世爱未尽。于净四静虑。或无或一二三四。无者谓欲爱未尽。一者谓欲爱尽。上爱未尽。乃至四者谓遍净爱尽。于无漏四静虑。或无或一二三四。无者谓依未至定。入正性离生。一者谓依初静虑或静虑中间。入正性离生。乃至四者谓依第四静虑。入正性离生。于味相应四无色。或一二三四。一者谓无所有处爱尽。上爱未尽。乃至四者谓空无边处爱未尽。于净四无色。或无或一二三四。无者谓色爱未尽。一者谓色爱尽。上爱未尽。乃至四者谓无所有处爱尽。于无漏三无色。皆不成就。如随信行。随法行亦尔。信胜解。于味相应四静虑。或无或一二三四。无者谓色爱尽。一者谓遍净爱尽。上爱未尽。乃至四者谓梵世爱未尽。于净四静虑。或无或一二三四。无者谓欲爱未尽。若生无色界。一者谓生欲界。欲爱尽。上爱未尽。若生梵世。即彼爱未尽。若生极光净。即彼爱未尽。若生遍净。即彼爱未尽。若生广果。二者谓生欲界梵世梵世爱尽。上爱未尽。若生极光净。即彼爱尽。上爱未尽。若生遍净。即彼爱尽。三者谓生欲界梵世极光净爱尽。上爱未尽。若生极光净遍净爱尽。四者谓生欲界梵世遍净爱尽。于无漏四静虑。或无或一二三四。无者谓欲爱未尽。一者谓欲爱尽。上爱未尽。乃至四者谓遍净爱尽。于味相应四无色。或一二三四。一者谓无所有处爱尽。上爱未尽。乃至四者谓空无边处爱未尽。于净四无色。或无或一二三四。无者谓生欲色界。色爱未尽。一者谓生欲色界。色爱尽。上爱未尽。若生空无边处。即彼爱未尽。若生识无边处。即彼爱未尽。若生无所有处。即彼爱未尽。若生非想非非想处。二者谓生欲色界空无边处空无边处爱尽。上爱未尽。若生识无边处。即彼爱尽。上爱未尽。若生无所有处。即彼爱尽。三者谓生欲色界空无边处识无边处爱尽。上爱未尽。若生识无边处无所有处爱尽。四者谓生欲色界空无边处无所有处爱尽。于无漏三无色。或无或一二三。无者谓色爱未尽。一者谓色爱尽。上爱未尽。乃至三者谓识无边处爱尽。如信胜解。见至亦尔。身证于味相应四静虑。皆不成就。于净四静虑。或无或一二三四。无者谓生非想非非想处。一者谓生广果。乃至。四者谓生欲界梵世。于无漏四静虑。皆成就。于味相应四无色。成就一。不成就三。于净四无色。或一或四。一者谓生非想非非想处。四者谓生欲色界。于无漏三无色。皆成就。慧解脱。于味相应四静虑。皆不成就。于净四静虑。或无或一二三四。无者谓生无色界。一者谓生广果。乃至四者谓生欲界梵世。于无漏四静虑皆成就。于味相应四无色皆不成就。于净四无色。或一二三四。一者谓生非想非非想处。乃至四者谓生欲色界空无边处。于无漏三无色皆成就。俱解脱于味相应四静虑皆不成就。于净四静虑。或无或一二三四。无者谓生非想非非想处。一者谓生广果。乃至四者谓生欲界梵世。于无漏四静虑皆成就。于味相应四无色皆不成就。于净四无色。或一或四。一者谓生非想非非想处。四者谓生欲色界。于无漏三无色皆成就。颇有成就味相应四静虑非净非无漏耶。答有。谓欲爱未尽。颇有成就净四静虑非味相应非无漏耶。答有。谓异生生欲界梵世。色爱尽。颇有成就无漏四静虑非味相应非净耶。答有。谓圣者生无色界。颇有成就净无漏四静虑非味相应耶。答有。谓圣者生欲界梵世。色爱尽。颇有成就余二或三耶。答无。颇有不成就味相应四静虑非净非无漏耶。答有。谓圣者生欲界梵世。色爱尽。颇有不成就净四静虑非味相应非无漏耶。答无。颇有不成就无漏四静虑非味相应非净耶。答无。颇有不成就味相应净四静虑非无漏耶。答有。谓圣者生无色界。颇有不成就味相应无漏四静虑非净耶。答有。谓异生生欲界梵世。色爱尽。颇有不成就净无漏四静虑非味相应耶。答有。谓欲爱未尽。颇有不成就味相应净无漏四静虑耶。答有。谓异生生无色界。颇有成就味相应四无色非净非无漏耶。答有。谓色爱未尽。颇有成就净无漏四无色非味相应耶。答有。谓生欲色界空无边处阿罗汉。颇有成就余耶。答无。颇有不成就味相应四无色非净非无漏耶。答有。谓生欲色界空无边处阿罗汉。颇有不成就净无漏四无色非味相应耶。答有。谓色爱未尽。颇有不成就余耶。答无。颇有得味相应四静虑非净非无漏耶。答有。谓色爱尽。起欲界缠退时。若无色没。生欲界时。颇有得净四静虑非味相应非无漏耶。答无。颇有得无漏四静虑非味相应非净耶。答有。谓依第四静虑。入正性离生。若得阿罗汉果时。颇有得余耶。答无。颇有舍味相应四静虑非净非无漏耶。答无。颇有舍净四静虑非味相应非无漏耶。答有。谓异生遍净爱尽。起欲界缠退时。若欲界梵世没。生无色界时。颇有舍净无漏四静虑非味相应耶。答有。谓圣者遍净爱尽。起欲界缠退时。颇有舍余耶。答无。颇有得味相应四无色非净非无漏耶。答有。谓阿罗汉。起欲色界缠退时。颇有得无漏三无色非味相应非净耶。答有。谓得阿罗汉果时。颇有得余耶。答无。颇有舍味相应四无色非净非无漏耶。答无。颇有舍净四无色非味相应非无漏耶。答有。谓异生无所有处爱尽。起欲色界缠退时。颇有舍无漏三无色非味相应非净耶。答有。谓信胜解识无边处爱尽练根时。颇有舍净无漏四无色非味相应耶。答有。谓圣者无所有处爱尽。起欲色界缠退时。颇有舍余耶。答无

颇有退味相应四静虑非净非无漏耶。答无。颇有退净四静虑非味相应非无漏耶。答有。谓异生遍净爱尽。起欲界缠退时。颇有退净无漏四静虑非味相应耶。答有。谓圣者遍净爱尽。起欲界缠退时。颇有退余耶。答无。颇有退味相应四无色非净非无漏耶。答无。颇有退净四无色非味相应非无漏耶。答有。谓异生无所有处爱尽。起欲色界缠退时。颇有退净无漏四无色非味相应耶。答有。谓圣者无所有处爱尽。起欲色界缠退时。颇有退余耶。答无

颇有味相应四静虑顿得耶。答有。谓色爱尽。起欲界梵世缠退时。若无色界没。生欲界梵世时。颇有味相应四静虑顿舍耶。答无。颇有味相应四静虑渐得耶。答有。颇有味相应四静虑渐舍耶。答有。颇有净四静虑顿得耶。答无。颇有净四静虑顿舍耶。答有。谓遍净爱尽。起欲界缠退时。若欲界梵世没。生无色界时。颇有净四静虑渐得耶。答有。颇有净四静虑渐舍耶。答有。颇有无漏四静虑顿得耶。答有。谓依第四静虑。入正性离生。若得阿罗汉果。颇有无漏四静虑顿舍耶。答有。谓圣者遍净爱尽。起欲界缠退时。颇有无漏四静虑渐得耶。答有。颇有无漏四静虑渐舍耶。答有。颇有味相应四无色顿得耶。答有。谓阿罗汉。起欲色界空无边处缠退时。颇有味相应四无色顿舍耶。答无。颇有味相应四无色渐得耶。答有。颇有味相应四无色渐舍耶。答有。颇有净四无色顿得耶。答无。颇有净四无色顿舍耶。答有。谓无所有处爱尽。起欲色界缠退时。颇有净四无色渐得耶。答有。颇有净四无色渐舍耶。答有。颇有无漏三无色顿得耶。答有。谓得阿罗汉果时。颇有无漏三无色顿舍耶。答有。谓圣者识无边处爱尽。起欲色界缠退时。颇有无漏三无色渐得耶。答有。颇有无漏三无色渐舍耶。答有

身语表无表。依何定灭。答身语表。依初或未至。身语无表。依四或未至。三恶行。三妙行。三不善根。三善根。依何定灭。答依未至。四非圣语。四圣语。四生四种。入胎四识。住依何定灭。答四非圣语。四圣语。胎卵湿生。四种入胎。依未至。化生后三识住。依七或未至。色识住。依四或未至。五蕴。五取蕴。五趣。五妙欲。五学处。依何定灭。答色蕴色取蕴。依四或未至。四蕴四取蕴天趣。依七或未至。余四趣五妙欲五学处。依未至。六内处。六外处。六识身。六触身。六受身。六想身。六思身。六爱身。依何定灭。答五内处色声触外处。依四或未至。意内处法外处意识身。及彼相应触受想思爱身。依七或未至。香味外处鼻舌识身。及彼相应触受想思爱身。依未至。眼耳身识身。及彼相应触受想思爱身。依初或未至。七识住。八世法。九有情居。十业道。依何定灭。答初识住。八世法。初有情居。十业道。依未至。第二识住。有情居。依初或未至。第三识住。有情居。依二或未至。第四识住。有情居。依三或未至。第五有情居。依四或未至。第五识住。第六有情居。依五或未至。第六识住。第七有情居。依六或未至。第七识住。第八第九有情居。依七或未至。四静虑。四无量。四无色。八解脱。八胜处。十遍处。依何定灭。答初静虑。依初或未至。第二静虑。喜无量。初二解脱。前四胜处。依二或未至。第三静虑。依三或未至。第四静虑。三无量。净解脱。后四胜处。前八遍处。依四或未至。空无边处。及彼解脱遍处。依五或未至。识无边处。及彼解脱遍处。依六或未至。后二无色。后三解脱。依七或未至。他心智世俗智。依何定灭。答他心智。依四或未至。世俗智。依七或未至

    定蕴第七中不还纳息第四

  不还学无学　　顺逆住极二
  菩萨记愿智　　无诤四双别
  住断法调伏　　法随法及行
  法轮正法世　　此章愿具说

有五不还。谓中般涅槃。生般涅槃。有行般涅槃。无行般涅槃。上流往色究竟。为五摄一切。为一切摄五耶。答一切摄五。非五摄一切。不摄何等。谓现法般涅槃。及往无色不还。中般涅槃。生般涅槃。何者为胜。答若住等断。则中般涅槃为胜。若生般涅槃断结多。则彼为胜。中般涅槃。乃至上流往色究竟。何者为胜。答若住等断。则中般涅槃为胜。若乃至上流往色究竟断结多。则彼为胜。如是生般涅槃。乃至上流往色究竟有行般涅槃。乃至上流往色究竟无行般涅槃。上流往色究竟。何者为胜。答若住等断。则生般涅槃等为胜。若有行般涅槃等。断结多。则彼为胜

诸学。彼一切为得未得而学耶。设为得未得而学。彼一切学耶。答应作四句。有学非为得未得而学。谓学住本性。有为得未得而学彼非学。谓阿罗汉。及异生。进求上法。有学亦为得未得而学。谓学进求上法。有非学亦非为得未得而学。谓阿罗汉。及异生。住本性。诸无学。彼一切不为得未得而学耶。设不为得未得而学。彼一切无学耶。答应作四句。有无学非不为得未得而学。谓阿罗汉。进求上法。有不为得未得而学非无学。谓学及异生。住本性。有无学亦不为得未得不学。谓阿罗汉。住本性。有非无学亦非不为得未得而学。谓学及异生。进求上法

顺流。是何义。答于诸生诸趣诸有诸种类诸生死。为支。为门。为事。为道。为迹向。是顺流义。逆流。是何义。答于生灭趣灭有灭种类灭生死灭。为支。为门为事。为道。为迹向。是逆流义。自住。是何义。答非于诸生乃至诸生死为支乃至为迹向。亦非于生灭乃至生死灭为支乃至为迹向。是自住义。诸阿罗汉。彼一切自住耶。设自住。彼一切阿罗汉耶答诸阿罗汉。彼一切皆自住。有自住非阿罗汉。谓不还。如世尊言

  永断五烦恼　　学满无引法
  得自在定根　　是人名自住

诸得极禁。彼一切得极迹耶。设得极迹。彼一切得极禁耶。答诸得极禁。彼一切得极迹。有得极迹非得极禁。谓不还。如世尊言。云何苾刍。得极迹。谓于五顺下分结。永断遍知

齐何名菩萨。答齐能造作增长相异熟业得何名菩萨。答得相异熟业。如说慈氏汝于来世。当得作佛名慈氏如来应正等觉。此何智。答因智道智。此于何转。答有于相异熟业转。由此名因智。有于无漏根力觉支道支。得阿耨多罗三藐三菩提转。由此名道智。如说此苾刍即于现法。当辨圣旨。此何智。答道智。此于何转。答此于无漏根力觉支道支。得诸漏永尽转。由此名道智

愿智云何。答如阿罗汉。成就神通。得心自在。随欲知义。发正愿已。便入边际第四静虑。从定起已。如愿皆知愿智。当言善耶无记耶。答或善。或无记

云何无诤行。答一切阿罗汉。善达内时。外不如是。若亦善达外时。名无诤行。无诤名何法。答令他相续无杂秽转如说。我弟子中。因儒童黠慧第一。婆呬迦等敏捷第一。此二何差别。答尊者因儒童心直心无曲心淳质增上。尊者婆呬迦等心濡心调柔心和顺增上。如说。我弟子中。小路于心回善。大路于想回善。此二何差别。答尊者小路。多住于心循心观念住。尊者大路。多住于法循法观念住。如说。我弟子中。舍利子。具大慧辩。执大藏。得无碍解。此二何差别。答尊者舍利子。多住义无碍解。尊者执大藏。多住四无碍解。如说。我弟子中。大迦叶波。少欲知足。具杜多行。薄矩罗。少病节俭。具净戒行。此二何差别。答尊者。大迦叶波。所得饮食。若粗若妙。随次第食。无所简别。尊者薄矩罗。所得饮食。或粗或妙。简去妙者。而食粗者。复次尊者大迦叶波。广识大福。易得衣服饮食卧具医药及余资具。先不受杜多功德。而能奉行。尊者薄矩罗。非广识大福。难得衣服饮食卧具医药及余资具。先受杜多功德。亦能奉行。少识苾刍。受杜多功德。于中随转。此不为难。如说。大名学。多住五盖渐断。此中云何学。答预流。或一来。云何学多住五盖渐断。答渐断渐离渐伏渐背

如说。苾刍法舍故毗柰耶舍。毗柰耶舍故法舍。云何法。答八支圣道。云何毗柰耶。答贪嗔痴灭。云何法舍故毗柰耶舍。毗柰耶舍故法舍答。若于八支圣道。不修习时。彼于贪嗔痴灭。不能作证。若于贪嗔痴灭。不作证时。彼于八支圣道。不能修习。由此因缘故作是说。如说。法随法行云何法。答寂灭涅槃。云何随法。答八支圣道。云何法随法行。答若于此中。随义而行。复次别解脱。名法别解脱。律仪名随法。若于此中。随义而行。名法随法行。复次身律仪语律仪命清净名法受。此名随法。若于此中。随义而行。名法随法行

云何法轮。答八支圣道。齐何当言转法轮。答若时具寿阿若多憍陈那见法。云何正法。答无漏根力觉支道支。齐何当言正法住。答若时行法者住。齐何当言正法灭。答若时行法者灭

若初入无漏初静虑。由得此故。得诸余无漏心心所法。彼何世摄。答未来。若初入乃至无漏无所有处。由得此故。得诸余无漏心心所法。彼何世摄。答未来。诸生何世摄。答未来。诸灭何世摄。答现在

说一切有部发智论卷第十八二者谓极光净爱尽上爱未尽。三者谓梵世爱尽上爱未尽。四者谓梵世爱未尽。于净四静虑。或无或一二三四。无者谓欲爱未尽。一者谓欲爱尽上爱未尽。二者谓梵世爱尽上爱未尽。三者谓极光净爱尽遍净爱上爱未尽。四者谓遍净爱尽。于无漏四静虑。或无或一二三四。无者谓依未至定入正性离生。一者谓依初静虑。或静虑中间入正性离生。二者谓依第二静虑入正性离生。三者谓依第三静虑入正性离生。四者谓依第四静虑入正性离生。于味相应四无色。或一二三四。一者谓无所有处爱尽上爱未尽。二者谓识无边处爱尽上爱未尽。三者谓空无边处爱尽上爱未尽。四者谓空无边处爱未尽。于净四无色。或无或一二三四。无者谓色爱未尽。一者谓色爱尽上爱未尽。二者谓空无边处爱尽上爱未尽。三者谓识无边处爱尽上爱未尽。四者谓无所有处爱尽。于无漏三无色皆不成就。如随信行随法行亦尔。信胜解于味相应四静虑。或无或一二三四。无者谓色爱尽。一者谓遍净爱尽上爱未尽。二者谓极光净爱尽上爱未尽。三者谓梵世爱尽上爱未尽。四者谓梵世爱未尽。于净四静虑。或无或一二三四。无者谓欲爱未尽若生无色界。一者谓生欲界欲爱尽上爱未尽。若生梵世即彼爱未尽。若生极光净即彼爱未尽。若生遍净即彼爱未尽。若生广果。二者谓生欲界梵世。梵世爱尽上爱未尽。若生极光净即彼爱尽上爱未尽。若生遍净即彼爱尽。三者谓生欲界梵世极光净爱尽上爱未尽。若生极光净遍净爱尽。四者谓生欲界梵世遍净爱尽。于无漏四静虑或无或一二三四。无者谓欲爱未尽。一者谓欲爱尽上爱未尽。二者谓梵世爱尽上爱未尽。三者谓极光净爱尽上爱未尽。四者谓遍净爱尽。于味相应四无色或一二三四。一者谓无所有处爱尽上爱未尽。二者谓识无边处爱尽上爱未尽。三者谓空无边处爱尽上爱未尽。四者谓空无边处爱未尽。于净四无色。或无或一二三四。无者谓生欲色界色爱未尽。一者谓生欲色界色爱尽上爱未尽。若生空无边处即彼爱未尽。若生识无边处即彼爱未尽。若生无所有处即彼爱未尽。若生非想非非想处。二者谓生欲色界空无边处。空无边处爱尽上爱未尽。若生识无边处即彼爱尽上爱未尽。若生无所有处即彼爱尽。三者谓生欲色界空无边处识无边处爱尽上爱未尽。若生识无边处无所有处爱尽。四者谓生欲色界空无边处无所有处爱尽。于无漏三无色或无或一二三。无者谓色爱未尽。一者谓色爱尽上爱未尽。二者谓空无边处爱尽上爱未尽。三者谓识无边处爱尽。如信胜解见至亦尔。身证于味相应四静虑皆不成就。于净四静虑。或无或一二三四。无者谓生非想非非想处。一者谓生广果。二者谓生遍净。三者谓生极光净。四者谓生欲界梵世。于无漏四静虑皆成就。于味相应四无色成就一不成就三。于净四无色。或一或四。一者谓生。非想非非想处。四者谓生欲色界于无漏三无色皆成就。慧解脱于味相应四静虑皆不成就。于净四静虑。或无或一二三四。无者谓生无色界。一者谓生广果。二者谓生遍净。三者谓生极光净。四者谓生欲界梵世。于无漏四静虑皆成就。于味相应四无色皆不成就。于净四无色。或一二三四。一者谓生非想非非想处。二者谓生无所有处。三者谓生识无边处。四者谓生欲色界空无边处。于无漏三无色皆成就。俱解脱于味相应四静虑皆不成就。于净四静虑。或无或一二三四。无者谓生非想非非想处。一者谓生广果。二者谓生遍净。三者谓生极光净阿毗达磨发智论卷第十九

        尊者迦多衍尼子造

        三藏法师玄奘奉　诏译

    定蕴第七中一行纳息第五

  一行六七修　　断正性二智
  二乐异二起　　相定出定闻
  定不定觉支　　断知天眼耳
  退得五通果　　此章愿具说

三三摩地。谓空无愿无相。若成就空。彼无愿耶。答如是。设成就无愿。彼空耶。答如是。若成就空。彼无相耶。答若得。设成就无相。彼空耶。答如是。若成就无愿。彼无相耶。答若得。设成就无相。彼无愿耶。答如是

若成就过去空。彼未来耶。答如是。设成就未来空。彼过去耶。答若已灭不失则成就。若未已灭。设已灭而失。则不成就若成就过去空。彼现在耶。答若现在前。设成就现在空。彼过去耶。答若已灭不失则成就。若未已灭。设已灭而失。则不成就。若成就未来空。彼现在耶。答若现在前。设成就现在空。彼未来耶。答如是。若成就过去空。彼未来现在耶。答未来成就现在。若现在前。设成就未来现在空。彼过去耶。答若已灭不失则成就。若未已灭。设已灭而失。则不成就。若成就未来空。彼过去现在耶。答有成就未来空非过去现在。有及过去非现在。有及现在非过去。有及过去现在。成就未来空。非过去现在者。谓已得空未已灭。设已灭而失。不现在前。及过去非现在者。谓空已灭不失。不现在前。及现在非过去者。谓空现在前。未已灭。设已灭而失。及过去现在者。谓空已灭不失现在前。设成就过去现在空。彼未来耶。答如是。若成就现在空。彼过去未来耶。答未来成就过去。若已灭不失则成就。若未已灭。设已灭而失。则不成就。设成就过去未来空。彼现在耶。答若现在前。如空历作六句应知。无愿无相亦尔

若成就过去空。彼过去无愿耶。答若已灭不失则成就。若未已灭。设已灭而失。则不成就。设成就过去无愿。彼过去空耶。答若已灭不失则成就。若未已灭。设已灭而失。则不成就。若成就过去空。彼未来无愿耶。答如是。设成就未来无愿。彼过去空耶。答若已灭不失则成就。若未已灭。设已灭而失。则不成就。若成就过去空。彼现在无愿耶。答若现在前。设成就现在无愿。彼过去空耶。答若已灭不失则成就。若未已灭。设已灭而失。则不成就。若成就过去空。彼过去现在无愿耶。答有成就过去空非过去现在无愿。有及过去非现在。有及现在非过去。有及过去现在。成就过去空非过去现在无愿者。谓空已灭不失。无愿未已灭。设已灭而失。不现在前。及过去非现在者。谓空无愿已灭不失。无愿不现在前。及现在非过去者。谓空已灭不失。无愿现在前。未已灭。设已灭而失。及过去现在者。谓空无愿已灭不失。无愿现在前。设成就过去现在无愿。彼过去空耶。答若已灭不失则成就。若未已灭。设已灭而失。则不成就。若成就过去空。彼未来现在无愿耶。答未来成就现在。若现在前。设成就未来现在无愿。彼过去空耶。答若已灭不失则成就。若未已灭。设已灭而失。则不成就。若成就过去空。彼过去未来无愿耶。答未来成就过去。若已灭不失则成就。若未已灭。设已灭而失。则不成就。设成就过去未来无愿。彼过去空耶。答若已灭不失则成就。若未已灭。设已灭而失。则不成就。若成就过去空。彼过去未来现在无愿耶。答有成就过去空及未来无愿非过去现在。有及未来现在非过去。有及过去未来非现在。有及过去未来现在。成就过去空及未来无愿非过去现在者。谓空已灭不失。无愿未已灭。设已灭而失。不现在前。及未来现在非过去者。谓空已灭不失。无愿现在前。非已灭。设已灭而失。及过去未来非现在者。谓空无愿已灭不失。无愿不现在前。及过去未来现在者。谓空无愿已灭不失。无愿现在前。设成就过去未来现在无愿。彼过去空耶。答若已灭不失则成就。若未已灭。设已灭而失。则不成就

若成就过去空。彼过去无相耶。答若已灭不失则成就。若未已灭。设已灭而失。则不成就。设成就过去无相。彼过去空耶。答若已灭不失则成就。若未已灭。设已灭而失。则不成就。若成就过去空。彼未来无相耶。答若得。设成就未来无相。彼过去空耶。答若已灭不失则成就。若未已灭。设已灭而失。则不成就。若成就过去空。彼现在无相耶。答若现在前。设成就现在无相。彼过去空耶。答若已灭不失则成就。若未已灭。设已灭而失。则不成就。若成就过去空。彼过去现在无相耶。答有成就过去空非过去现在无相。有及过去非现在。有及现在非过去。有及过去现在。成就过去空非过去现在无相者。谓空已灭不失。无相未已灭设已灭而失。不现在前。及过去非现在者。谓空无相已灭不失。无相不现在前。及现在非过去者。谓空已灭不失。无相现在前。未已灭。设已灭而失。及过去现在者。谓空无相已灭不失。无相现在前。设成就过去现在无相。彼过去空耶。答若已灭不失则成就。若未已灭。设已灭而失。则不成就。若成就过去空。彼未来现在无相耶。答有成就过去空非未来现在无相。有及未来非现在。有及未来现在。成就过去空非未来现在无相者。谓空已灭。未得无相。及未来非现在者。谓空已灭不失。已得无相。不现在前。及未来现在者。谓空已灭不失。无相现在前。设成就未来现在无相。彼过去空耶。答若已灭不失则成就。若未已灭。设已灭而失。则不成就。若成就过去空。彼过去未来无相耶。答有成就过去空非过去未来无相。有及未来非过去。有及过去未来。成就过去空非过去未来无相者。谓空已灭。未得无相。及未来非过去者。谓空已灭不失。已得无相。未已灭。设已灭而失。及过去未来者。谓空无相已灭不失。设成就过去未来无相。彼过去空耶。答若已灭不失则成就。若未已灭。设已灭而失。则不成就。若成就过去空。彼过去未来现在无相耶。答有成就过去空非过去未来现在无相。有及未来非过去现在。有及未来现在非过去。有及过去未来非现在。有及过去未来现在。成就过去空非过去未来现在无相者。谓空已灭未得无相。及未来非过去现在者。谓空已灭不失。已得无相。未已灭。设已灭而失。不现在前。及未来现在非过去者。谓空已灭不失。无相现在前。未已灭。设已灭而失。及过去未来非现在者。谓空无相已灭不失。无相不现在前。及过去未来现在者。谓空无相已灭不失。无相现在前。设成就过去未来现在无相。彼过去空耶。答若已灭不失则成就。若未已灭。设已灭而失。则不成就。如空对无相。应知无愿对无相亦尔。如小七。应知大七亦尔。差别者。以二对一。如以过去空过去无愿对过去无相有七

若修空。彼无愿耶。设修无愿。彼空耶。答应作四句。有修空非无愿。谓已得空现在前。有修无愿非空。谓已得无愿现在前。若未得无愿现在前。不修空。有俱修。谓未得空现在前。若未得无愿现在前修空。若未得无相及未得世俗智现在前。修空无愿。有俱不修。谓已得无相现在前。若未得无相现在前。不修空无愿。若已得世俗智现在前。若未得世俗智现在前。不修空无愿。一切异生。染污心。无记心。在无想定灭尽定。生无想天。若修空彼。无相耶。设修无相。彼空耶。答应作四句。有修空非无相。谓已得空现在前。若未得空现在前。不修无相。若未得无愿现在前。修空非无相。有修无相非空。谓已得无相现在前。若未得无相现在前。不修空。有俱修。谓未得空现在前。修无相。若未得无相现在前修空。若未得无愿及未得世俗智现在前。修空无相。有俱不修。谓已得无愿现在前。若未得无愿现在前。不修空无相。若已得世俗智现在前。若未得世俗智现在前。不修空无相。一切异生。染污心。无记心。在无想定灭尽定。生无想天。若修无愿。彼无相耶。设修无相。彼无愿耶。答应作四句。有修无愿非无相。谓已得无愿现在前。若未得无愿及未得空现在前。不修无相。有修无相非无愿。谓已得无相现在前。若未得无相现在前。不修无愿。有俱修。谓未得无愿现在前。修无相。若未得无相现在前。修无愿。若未得空及未得世俗智现在前。修无愿无相。有俱不修。谓已得空及已得世俗智现在前。若未得世俗智现在前。不修无愿无相。一切异生。染污心。无记心。在无想定灭尽定。生无想天

颇有结空所断非无愿无相耶。答无。颇有结无愿所断非空无相耶。答有。谓见集见道所断结。无愿断。颇有结无相所断非空无愿耶。答有。谓见灭所断结。无相断。颇有结空无愿所断非无相耶。答有。谓见苦所断结。空无愿断。颇有结空无相所断非无愿耶。答无。颇有结无愿无相所断非空耶。答无。颇有结空无愿无相所断耶。答有。谓学见迹修所断结。空无愿无相断。颇有结非空无愿无相所断而是所断耶。答有。谓异生所断结

云何作意入正性离生。答或无常。或苦。或空。或无我思惟。何系行入正性离生。答欲界系。尽智当言于身循身观念住耶。乃至当言于法循法观念住耶。答尽智应言。或于身循身观念住。或于受。或于心。或于法。循法观念住。如尽智。无生智亦尔

诸无漏初静虑乐。诸轻安等觉支乐。此何差别。答无差别。诸无漏第二静虑乐。诸轻安等觉支乐。此何差别。答无差别

若从等持出。彼所缘耶。设从所缘出。彼等持耶。答应作四句。有从等持出非所缘。谓如有一思惟此相。入初静虑。彼复思惟此相。入第二静虑。有从所缘出非等持。谓如有一思惟此相入初静虑。彼不出初静虑。复思惟余相。有从等持出亦所缘。谓如有一思惟此相。入初静虑。彼思惟余相。入第二静虑。有非从等持出亦非所缘。谓如有一思惟此相。入初静虑。住经多时。如说苾刍。乃至想定。能达圣旨。世尊弟子。生非想非非想处。彼依何定。得阿罗汉果。答无漏无所有处

如说尊者大目干连言。具寿我自忆住无所有处定。闻曼陀枳尼池侧有众多龙象哮吼等声。彼尊者为在定闻。为起定耶。答起定闻非在定

诸不定。彼一切非聪慧无明趣耶。答诸不定。彼一切非聪慧无明趣。有非聪慧无明趣而非不定。谓邪定。诸定。彼一切聪慧明趣耶。答诸聪慧明趣彼一切定有定。彼非聪慧无明趣。谓邪定。诸不定。彼一切不成就等觉支耶。答诸不定。彼一切不成就等觉支。有不成就等觉支而非不定。谓邪定。诸定。彼一切成就等觉支耶。答诸成就等觉支。彼一切定。有定而不成就等觉支。谓邪定

诸成就等觉支。彼成就无漏法耶。答诸成就等觉支。彼成就无漏法。有成就无漏法非等觉支。谓诸异生。诸不成就等觉支。彼不成就无漏法耶。答无不成就无漏法。有不成就等觉支。谓诸异生。诸得等觉支。彼得无漏法耶。答诸得等觉支。彼得无漏法。有得无漏法非等觉支。谓诸异生。诸舍等觉支。彼舍无漏法耶。答无全舍等觉支。亦无全舍无漏法。诸退等觉支。彼退无漏法耶。答无全退等觉支。亦无全退无漏法

诸未断。彼未遍知耶。答诸未遍知。彼未断。有未断非未遍知。谓若智遍知故已遍知非断。遍知故已断。诸已断。彼已遍知耶。答诸已断。彼已遍知。有已遍知非已断。谓若智遍知故已遍知非断。遍知故已断

诸有此生眼不见色。彼依何法。引发天眼耶。答如有一得自性生。念先余生中。眼曾见色。彼依此故。引发天眼。诸有此生。耳不闻声。彼依何法。引发天耳耶。答如有一得自性生。念先余生中。耳曾闻声。彼依此故。引发天耳。何故异生退时。见修所断结增益。世尊弟子退时。唯修所断结增益耶。答异生用此道。断见所断结。即用此道。断修所断结。故彼退时。二结俱增益。世尊弟子。用此道。断见所断结。彼于此道。定不退。用余道。断修所断结。彼于余道。有退有不退。世尊弟子。设用此道。断见所断结。即用此道。断修所断结者。彼亦无退。何故上三果有退。非预流果耶。答修所断结。依有事起。谓有净相。有不净相。彼由非理。作意观净相时。便于不净想退。见所断结。依无事起。无有一法是我我所。可令彼观于无我见退

退上三果时。诸所得无漏根力觉支道支。当言曾得得。未曾得得耶。答应言曾得得。无色界没。生欲界时。诸所得蕴界处。善不善无记根。结缚随眠。随烦恼缠。当言曾得得。未曾得得耶。答应言善染污法曾得得。异熟法未曾得得。无色界没。生色界时。诸所得蕴界处。善无记根。结缚随眠。随烦恼缠。当言曾得得。未曾得得耶。答应言善染污法曾得得。异熟法未曾得得。色界没生。欲界时诸所得。蕴界处等如无色界没生欲界说

依初静虑。引发神境通道时。彼极远至何处耶。答乃至梵世。依初静虑。引发天耳通道时。彼极远闻。何系声耶。答乃至梵世。依初静虑。引发他心通道时。彼极远知何系心心所法耶。答乃至梵世。依初静虑。引发宿住随念通道时。彼极远忆。何系宿住事耶。答乃至梵世。依初静虑。引发天眼通道时。彼极远见。何系色耶。答乃至梵世。如依初静虑。乃至依第四静虑。各随自处。广说亦尔

若于苦思惟苦。得阿罗汉果。彼思惟何系苦。答无色界系苦。若于集思惟集。得阿罗汉果。彼思惟何系集。答无色界系集。若于灭思惟灭。得阿罗汉果。彼思惟何系诸行灭。答或欲界系。或色无色界系诸行灭。若于道思惟道。得阿罗汉果。彼思惟何系诸行能断道。答或欲界系。或色无色界系诸行能断道

    见蕴第八中念住纳息第一

  念住有六门　　如实知有八
  贪嗔痴增减　　死受涅槃心
  弟子先涅槃　　佛涅槃出定
  四有三有行　　此章愿具说

四念住。谓身受心法念住。若修身念住。彼受耶。设修受念住。彼身耶。答应作四句。有修身念住非受。谓已得身念住现在前。有修受念住非身。谓已得受念住现在前。若未得受念住现在前。不修身。若未得心法念住现在前。修受非身。有俱修。谓未得身念住现在前。若未得受念住现在前修身。若未得心法念住现在前。修身受。有俱不修。谓已得心法念住现在前。若未得法念住现在前。不修身受。一切染污心。无记心。在无想定灭尽定。生无想天。如身念住受念住。应知。身念住心念住亦尔。若修身念住。彼法耶。设修法念住。彼身耶。答应作四句。有修身念住非法。谓已得身念住现在前。有修法念住非身。谓已得法念住现在前。若未得法念住现在前。不修身。若未得受心念住现在前。修法非身。有俱修谓未得身念住现在前。若未得法念住现在前。修身。若未得受心念住现在前。修身法。有俱不修。谓已得受心念住现在前。一切染污心。无记心。在无想定灭尽定。生无想天。若修受念住。彼心耶。设修心念住。彼受耶。答应作四句。有修受念住非心。谓已得受念住现在前。有修心念住非受。谓已得心念住现在前。有俱修。谓未得身受心念住现在前。若未得法念住现在前。修受心。有俱不修。谓已得身法念住现在前。若未得法念住现在前。不修受心。一切染污心。无记心。在无想定灭尽定。生无想天。若修受念住。彼法耶。设修法念住。彼受耶。答应作四句。有修受念住非法。谓已得受念住现在前。有修法念住非受。谓已得法念住现在前。若未得法念住现在前。不修受。有俱修。谓未得身受心念住现在前。若未得法念住现在前。修受。有俱不修。谓已得身心念住现在前。一切染污心。无记心。在无想定灭尽定。生无想天。如受念住法念住。应知。心念住法念住亦尔

于身修身观念住。当言法类世俗苦集道智。当言有寻有伺无寻唯伺无寻无伺。当言乐喜舍根相应。当言空无愿三摩地俱。当言缘欲色界系及不系。于受修受观念住。当言法类他心世俗苦集道智。当言有寻有伺等三。当言乐喜舍根相应。当言空无愿三摩地俱。当言缘三界系不系。如于受。于心亦尔。于法修此观念住。当言法类他心世俗苦集灭道智。当言有寻有伺等三。当言乐喜舍根相应。当言空无愿无相三摩地俱。当言缘三界系不系。如说受乐受时。如实知我受乐受。此四智。谓法类世俗道。受苦受时。如实知我受苦受。此一智。谓世俗。受不苦不乐受时。如实知我受不苦不乐受。此四智。谓法类世俗道。受乐身受苦身受不苦不乐身受及苦心受时。如实知。此一智。谓世俗。受乐心受不苦不乐心受时。如实知。此四智。谓法类世俗道。受乐有味受苦有味受不苦不乐有味受及苦无味受时。如实知。此一智。谓世俗。受乐无味受不苦不乐无味受时。如实知。此四智。谓法类世俗道。受乐耽嗜依受苦耽嗜依受不苦不乐耽嗜依受及苦出离依受时。如实知。此一智。谓世俗。受乐出离依受不苦不乐出离依受时。如实知。此四智。谓法类世俗道

如说有贪心。如实知有贪心。此一智。谓世俗。离贪心。如实知离贪心。此四智。谓法类世俗道。如有贪心离贪心。应知。有痴心。离痴心。染心不染心。略心散心。下心举心。小心大心。掉心不掉心。不寂静心寂静心。不定心定心。不修心修心。不解脱心解脱心亦尔。有嗔心。如实知有嗔心。此一智。谓世俗。离嗔心。如实知离嗔心。此三智。谓法世俗道

如说有内贪欲盖。如实知有内贪欲盖。此一智。谓世俗。无内贪欲盖。如实知无内贪欲盖。此三智。谓法世俗道。如未生内贪欲盖而生。如实知。此一智。谓世俗。生已便断。断已后不复生。如实知。此三智。谓法世俗道。如贪欲盖。应知。嗔恚惛沉睡眠掉举恶作疑盖亦尔。如说有内眼结。如实知有内眼结。此一智。谓世俗。无内眼结。如实知无内眼结。此四智。谓法类世俗道。如未生内眼结而生。如实知。此一智。谓世俗。生已便断。断已后不复生。如实知。此四智。谓法类世俗道。如眼结。应知。耳身意结亦尔。鼻舌结如盖说

如说有内念等觉支。如实知有内念等觉支。此四智。谓法类世俗道。无内念等觉支。如实知无内念等觉支。此一智。谓世俗。如未生念等觉支而生。生已住不忘。令圆满倍增广智作证。此四智。谓法类世俗道。如念等觉支。应知择法精进喜安定舍等觉支亦尔

如说等随观自贪嗔痴增。云何贪嗔痴增。答有下贪嗔痴缠故中。有中故上。是谓增。如说等随观自贪嗔痴减。云何贪嗔痴减。答无上贪嗔痴缠故中。无中故下。是谓减

云何死边际受。答由此末摩断命根灭。齐何当言死边际受。答齐此末摩断命根灭。何处摄。答法处。几识相应。答身识意识。初末摩断受。身识相应。最后受。意识相应

阿罗汉般涅槃心。当言善耶无记耶。答当言无记

何故双贤弟子。先般涅槃。然后佛耶。答彼二尊者。先长夜中。造作增长感无断业。勿空无果异熟故。复次由法尔故

如说世尊依不动寂静定。而般涅槃。世间眼灭。此为在定。为出定耶。答出定。如说四有。谓本有死有中有生有。云何本有。答除生分死分诸蕴中间诸有。云何死有。答死分诸蕴。云何中有。答除死分生分诸蕴中间诸有。云何生有。答生分诸蕴

诸欲有。彼一切五行耶。设五行。彼一切欲有耶。答应作四句。有欲有非五行。谓欲界有情。住不同分心。及住无想灭尽定。有五行非欲有。谓色界有想天。住同分心。若无想天。不得无想。有欲有亦五行。谓欲界有情。住同分心。有非欲有亦非五行。谓色界有想天。住不同分心。及住无想灭尽定。若无想天得无想。若生无色界。诸色有有想天。彼一切五行耶设五行。彼一切色有有想天耶。答应作四句。有色有有想天非五行。谓色界有想天。住不同分心。及住无想灭尽定。有五行非色有有想天。谓欲界有情。住同分心。若无想天不得无想。有色有有想天亦五行谓色界有想天。住同分心。有非色有有想天亦非五行。谓欲界有情。住不同分心。及住无想灭尽定。若无想天得无想。若生无色界。诸色有无想天。彼一切二行耶设二行。彼一切色有无想天耶。答应作四句。有色有无想天非二行。谓无想天不得无想。有二行非色有无想天。谓欲界有情。色界有想天。住不同分心。及住无想灭尽定。有色有无想天亦二行。谓无想天得无想。有非色有无想天亦非二行。谓欲界有情。色界有想天。住同分心。若生无色界。诸无色有。彼一切四行耶。设四行。彼一切无色有耶。答诸四行。彼一切无色有。有无色有非四行。谓无色界有情。住不同分心

颇有有五行耶。答有。谓欲界有情。及色界有想天。住同分心。若无想天不得无想。颇有有四行耶。答有。谓无色界有情。住同分心。颇有有三行耶。答无。颇有有二行耶。答有。谓欲界有情。及色界有想天。住不同分心。若住无想灭尽定。若无想天得无想。颇有有一行耶。答有。谓无色界有情。住不同分心。颇有有无行耶。答无

    见蕴第八中三有纳息第二

  三有随眠想　　六寻明无明
  对因等有无　　此章愿具说

诸舍欲有欲有相续。彼一切欲界法灭。欲界法现在前耶。答诸舍欲有欲有相续。彼一切欲界法灭。欲界法现在前。有欲界法灭欲界法现在前而非舍欲有欲有相续。谓不命终。而欲界法灭。欲界法现在前。诸舍欲有色有相续。彼一切欲界法灭。色界法现在前耶。答诸舍欲有色有相续。彼一切欲界法灭色界法现在前。有欲界法灭色界法现在前而非舍欲有色有相续。谓不命终。欲界法灭。色界法现在前。诸舍欲有无色有相续。彼一切欲界法灭。无色界法现在前耶答如是。设欲界法灭。无色界法现在前。彼一切舍欲有无色有相续耶。答如是。诸舍色有色有相续。彼一切色界法灭。色界法现在前耶。答诸舍色有色有相续。彼一切色界法灭。色界法现在前。有色界法灭色界法现在前而非舍色有色有相续。谓不命终。色界法灭色界法现在前。诸舍色有欲有相续。彼一切色界法灭。欲界法现在前耶。答诸舍色有欲有相续。彼一切色界法灭。欲界法现在前。有色界法灭欲界法现在前而非舍色有欲有相续。谓不命终。而色界法灭。欲界法现在前。诸舍色有无色有相续。彼一切色界法灭。无色界法现在前耶。答诸舍色有无色有相续。彼一切色界法灭。无色界法现在前。有色界法灭无色界法现在前而非舍色有无色有相续。谓不命终。色界法灭。无色界法现在前。诸舍无色有无色有相续。彼一切无色界法灭。无色界法现在前耶。答诸舍无色有无色有相续。彼一切无色界法灭。无色界法现在前。有无色界法灭无色界法现在前而非舍无色有无色有相续。谓不命终。无色界法灭。无色界法现在前。诸舍无色有欲有相续。彼一切无色界法灭。欲界法现在前耶。答如是。设无色界法灭。欲界法现在前。彼一切舍无色有欲有相续耶。答如是。诸舍无色有色有相续。彼一切无色界法灭。色界法现在前耶。答诸舍无色有色有相续。彼一切无色界法灭。色界法现在前。有无色界法灭色界法现在前而非舍无色有色有相续。谓不命终。而无色界法灭。色界法现在前。何故欲界随眠。不于色无色界法随增耶。答界应杂乱。及应不可施设。离欲染故。何故色界随眠。不于欲界法随增耶。答界应杂乱。及彼非此所缘故。何故色界随眠。不于无色界法随增耶。答界应杂乱。亦不可知。离色染故。何故无色界随眠。不于欲界色界法随增耶。答界应杂乱。及彼非此所缘故。何故欲界不遍行随眠。不遍于欲界法随增耶。答此应成遍行。及彼非此所缘故。何故色界不遍行随眠。不遍于色界法随增耶。答如前说无色界不遍行随眠说亦尔

有十想。谓无常想。乃至灭想。若修无常想。彼思惟无常想耶。答应作四句。有修无常想不思惟无常想。谓缘余法修无常想。有思惟无常想不修无常想。谓缘无常想修余想。有修无常想亦思惟无常想。谓缘无常想。修无常想。有不修无常想亦不思惟无常想。谓除前相。如无常想。无常苦想苦无我想亦尔。余想亦随应当知

若起欲寻。彼思惟欲寻耶。答应作四句。有起欲寻不思惟欲寻。谓缘余法起欲寻。有思惟欲寻不起欲寻。谓缘欲寻起余寻。有起欲寻亦思惟欲寻。谓缘欲寻起欲寻。有不起欲寻亦不思惟欲寻。谓除前相。如欲寻。恚寻害寻出离寻无恚寻无害寻亦尔

诸法因无明。彼法缘无明耶。答若法因无明。彼法缘无明。有法缘无明不因无明谓除无明异熟。诸余无覆无记行。及善行。诸法因明。彼法缘明耶。答若法因明。彼法缘明。有法缘明不因明。谓初明。及诸有漏行。诸法因无明。彼法缘明耶。答若法因无明。彼法缘明。有法缘明不因无明。谓除无明异熟。诸余无覆无记行。及善行。诸法因明。彼法缘无明耶。答若法因明。彼法缘无明。有法缘无明不因明。谓初明。及诸有漏行。诸法因无明。彼法不善耶。答若法不善。彼法因无明有法因无明非不善。谓无明异熟。及有覆无记行。诸法因明。彼法善耶。答若法因明。彼法善。有法善不因明。谓初明及善有漏行。颇有法。不因明不因无明。彼法非无因耶。答有。谓除无明异熟。诸余无覆无记行。及初明善有漏行

    见蕴第八中想纳息第三

  想心知等四　　无缘法见疑
  因道等摄三　　此章愿具说

诸法无常想生。彼法无常想相应耶。答应作四句。有法无常想生非无常想相应。谓无常想现前必灭。余想现前必生彼相应法。有法无常想相应非无常想生。谓余想现前必灭。无常想现前必生彼相应法。有法无常想生亦无常想相应。谓无常想现前必灭。无常想现前必生彼相应法。有法非无常想生亦非无常想相应。谓余想现前必灭。余想现前必生彼相应法。如无常想。乃至灭想亦尔。诸法无常想生。彼法无常想一缘耶。答应作四句。有法无常想生非无常想一缘。谓无常想现前必灭。余想现前必生。彼有余缘。有法无常想一缘非无常想生。谓余想现前必灭。无常想现前必生。彼有此缘。有法无常想生无常想一缘。谓无常想现前必灭。无常现前必生。彼有此缘。有法非无常想生亦非无常想一缘。谓余想现前必灭。余想现前必生。彼有余缘。如无常想。乃至灭想亦尔

诸法由心起。非不由心。若时心起。尔时彼法耶。答心先起后彼法。若时心灭。尔时彼法耶。答心先灭后彼法。若时心得。尔时彼法耶。答心先得后彼法。若时心舍。尔时彼法耶。答彼法先舍后乃心。若时心受异熟。尔时彼法耶。答或尔时。或余时

颇有法是所通达所遍知非所断非所修非所作证耶。答有。谓虚空非择灭。颇有法是所通达所遍知非所断非所修是所作证耶。答有。谓择灭。颇有法是所通达所遍知非所断是所修是所作证耶。答有。谓无漏有为法。颇有法是所通达所遍知是所断是所修是所作证耶。答有。谓善有漏行。颇有法是所通达所遍知是所断非所修是所作证耶。答有。谓定所起天眼耳。颇有法是所通达所遍知是所断非所修非所作证耶。答有。谓除定所起天眼耳。余无记行不善法

颇有法无缘因缘无缘法缘无缘法俱生是有是有性非无非无性异色异受想识异相应行耶。答有。谓五识身。彼相应法。及缘。色无为。心不相应行。意识身。彼相应法。所有生老住无常。此法无缘因缘无缘法缘无缘法俱生。是有。是有性。非无非无性。异色。异受想识。异相应行。此法。于彼法。当言因。当言缘耶。答当言因。当言缘。此法当言善耶。不善耶。无记耶。答于善当言善。于不善当言不善。于无记当言无记。此法几随眠随增。几结系。答三界有漏缘。随眠随增。九结系。见相应受。几随眠随增。答三界有漏缘。及无漏缘见。彼相应无明。随眠随增。见不相应受。几随眠随增。答除无漏缘见。彼相应无明。余随眠随增。疑相应受。几随眠随增。答三界见所断有漏缘。及无漏缘疑。彼相应无明。随眠随增。疑不相应受。几随眠随增。答除无漏缘疑彼相应无明。余随眠随增。因道缘起法几界。几处。几蕴摄。答十八界。十二处。五蕴。除眼触等起想受。心相应法。及耳触等起想受。心不相应法。余法。几界。几处。几蕴摄。答十八界。十二处。五蕴。乃至除身触等起想受。心相应法。及意触等起想受。心不相应法。余法。几界。几处。几蕴摄。答十八界。十二处。五蕴

说一切有部发智论卷第十九阿毗达磨发智论卷第二十

        尊者迦多衍尼子造

        三藏法师玄奘奉　诏译

    见蕴第八中智纳息第四

  智断厌离修　　缘触慢业事
  摄余摄一切　　此章愿具说

若事能通达。彼事能遍知耶。答应作四句。有事能通达非能遍知。谓苦集灭道智。不断烦恼。有事能遍知非能通达。谓苦集灭道忍。断烦恼。有事能通达亦能遍知。谓苦集灭道智。断烦恼。有事非能通达非能遍知。谓苦集灭道忍。不断烦恼。若事能厌。彼事能离耶。答应作四句。有事能厌非能离。谓苦集忍智。不断烦恼。有事能离非能厌。谓灭道忍智。断烦恼。有事能厌亦能离。谓苦集忍智。断烦恼。有事非能厌非能离。谓灭道忍智。不断烦恼。若事能厌。彼事修厌耶。答若事能厌。彼事亦修厌。有事修厌非能厌。谓灭道智。断烦恼。若事能离。彼事修厌耶。答应作四句。有事能离非修厌。谓灭道忍。断烦恼。有事修厌非能离。谓苦集忍智。不断烦恼。有事能离亦修厌。谓苦集忍智。及灭道智。断烦恼。有事非能离亦非修厌。谓灭道忍智。不断烦恼

若法与彼法作因。或时此法与彼法非因耶。答无时非因。若法与彼法作等无间。或时此法与彼法非等无间耶。答若时此法未至已生。若法与彼法作所缘。或时此法与彼法非所缘耶。答无时非所缘。若法与彼法作增上。或时此法与彼法非增上耶。答无时非增上。诸意触。彼一切三和合触耶。答诸意触。彼一切三和合触。有三和合触非意触。谓五识身相应触。故世尊说。苾刍当知。有意界。有法界。有无明界。无明触所生。受所触故。无闻愚夫。便执有执无。或执有无。诸慢。彼一切自执耶。答诸慢。彼一切自执。有自执非慢。谓诸见趣。故世尊说。苾刍当知自执有我。自执有我所。诸慢。彼一切不寂静耶。答诸慢。彼一切不寂静。有不寂静非慢谓余烦恼现在前。故世尊说。苾刍当知。动为魔所缚。不动脱恶者。诸业。彼不律仪耶。答应作四句。有业非不律仪。谓身语律仪有不律仪非业。谓根不律仪。有业亦不律仪。谓身语不律仪。有非业亦非不律仪。谓根律仪。诸业。彼律仪耶。答应作四句。有业非律仪谓身语不律仪。有律仪非业。谓根律仪。有业亦律仪。谓身语律仪。有非业亦非律仪。谓根不律仪。若事未得。彼不成就耶。答若事未得。彼不成就。有事不成就非未得。谓得已失。若事已得。彼成就耶。答若事成就。彼已得。有事已得而不成就。谓得已失

除苦圣谛及法处。余法二界一处一蕴摄。除集圣谛及法处说亦尔。除灭圣谛及法处。余法十七界十一处二蕴摄。除道圣谛及法处说亦尔。除有色法及法处。余法七界一处一蕴摄。除无色法及法处。余法十界十处一蕴摄。除有见法及法处。余法十六界十处二蕴摄。除无见法及法处。余法一界一处一蕴摄。除有对法及法处。余法七界一处一蕴摄。除无对法及法处。余法十界十处一蕴摄。除有漏法及法处。余法二界一处一蕴摄。除无漏法及法处。余法十七界十一处二蕴摄。除有为法及法处。此除一切法。而问余法是无事空论。除无为法及法处。余法十七界十一处二蕴摄。除过去法及法处。余法十七界十一处二蕴摄。除未来法现在法及法处说亦尔。除善法及法处。余法十七界十一处二蕴摄。除不善法及法处说亦尔。除无记法及法处。余法九界三处二蕴摄。除欲界系法及法处。余法十三界九处二蕴摄。除色界系法及法处。余法十七界十一处二蕴摄。除无色界系。法学法无学法及法处说亦尔。除非学非无学法及法处。余法二界一处一蕴摄。除见所断法及法处。余法十七界十一处二蕴摄。除修所断法及法处。余法二界一处一蕴摄。除不断法及法处。余法十七界十一处二蕴摄。除已生法及定不生法。余法十八界十二处五蕴摄。除非已生法及定不生法。此除一切法。而问余法。是无事空论。除有色法及定不生法。余法八界二处四蕴摄。除无色法及定不生法。余法十一界十一处一蕴摄。除有见法及定不生法。余法十七界十一处五蕴摄。除无见法及定不生法。余法一界一处一蕴摄。除有对法及定不生法。余法八界二处五蕴摄。除无对法及定不生法。余法十界十处一蕴摄。除有漏法及定不生法。余法三界二处五蕴摄。除无漏法及定不生法。余法十八界十二处五蕴摄。除有为法及定不生法。此除一切法。而问余法。是无事空论。除无为法及定不生法。余法十八界十二处五蕴摄。除过去法现在法及定不生法说亦尔。除未来法及定不生法。此除一切法。而问余法。是无事空论。除善法及定不生法。余法十八界十二处五蕴摄。除不善法及定不生法说亦尔。除无记法及定不生法。余法十界四处五蕴摄。除欲界系法及定不生法。余法十四界十处五蕴摄。除色界系法及定不生法。余法十八界十二处五蕴摄。除无色界系法学法无学法及定不生法说亦尔。除非学非无学法及定不生法。余法三界二处五蕴摄。除见所断法及定不生法。余法十八界十二处五蕴摄。除修所断法及定不生法。余法三界二处五蕴摄。除不断法及定不生法。余法十八界十二处五蕴。颇有一界一处一蕴摄一切法耶。答有。一界谓法界。一处谓意处。一蕴谓色蕴

    见蕴第八中见纳息第五

  邪断邪常见　　戒邪戒邪常
  六见五涅槃　　九慢类常见
  迷执自他作　　悟则二非有
  具慢及得等　　此章愿具说

诸有此见。无施与。无爱乐。无祠祀。无妙行恶行。此谤因邪见。见集所断。无妙行恶行果。此谤果邪见。见苦所断。无此世。无他世。无化生有情。此或见集所断。或见苦所断。无父。无母。此谤因邪见。见集所断。诸有此见。世间无阿罗汉。此谤道邪见。见道所断。无正至。此谤灭邪见。见灭所断。无正行此世他世。即于现法。知自通达。作证具足住。我生已尽。梵行已立。所作已办。不受后有。如实知。此谤道邪见。见道所断。诸有此见。乃至活有命者。死已断坏。无有此四大种。士夫身死时。地身归地。水身归水。火身归火。风身归风。根随空转。舆为第五。持彼死尸。往弃冢间。未烧可知烧已成灰。余鸽色骨。愚者赞施。智者赞受。诸有论者。一切空虚妄语。乃至活有。愚智者死已。断坏无有。此边执见断见摄。见苦所断

诸有此见。无因无缘。令有情杂染。非因非缘。而有情杂染。此谤因邪见。见集所断。无因无缘。令有情清净。非因非缘。而有情清净。此谤道邪见。见道所断。无因无缘。令有情无智无见。非因非缘。而有情无智无见。此谤因邪见。见集所断。无因无缘。令有情智见。非因非缘。而有情智见。此谤道邪见。见道所断。诸有此见。无力。无精进。无力精进。无士。无威势。无士威势。无自作。无他作。无自他作。一切有情。一切生。一切种。无力。无自在。无精进。无威势。定合性变。于六胜生。受诸苦乐。此邪见。若谤有漏力精进等。则谤因邪见。见集所断。若谤无漏力精进等。则谤道邪见。见道所断。诸有此见。造教造煮。教煮害教。害杀诸众生不与取。欲邪行。知而妄语。故饮诸酒。穿墙解结。尽取所有。守阨断道。害村害城。害国生命。以刀以轮。拥略大地。所有众生断截分解。聚集团积。为一肉聚。应知。由此无恶无恶缘。于殑伽南。断截挝打。于殑伽北。惠施修福。应知由此无罪福。亦无罪福缘。布施爱语利行同事。摄诸有情。皆无有福。此谤因邪见。见集所断

诸有此见。此七士身。不作作。不化化。不可害。常安住。如伊师迦。安住不动。无有转变。互不相触。何等为七。谓地水火风及苦乐命。此七士身。非作乃至如伊师迦。安住不动。若罪若福。若罪福。若苦苦乐。若苦乐。不能转变。亦不能令互相触碍。设有士夫。断士夫头。亦不名为害世间生。若行若住。七身中间。刀刃虽转。而不害命。此中无能害。无所害。无能捶。无所捶。无表。无表处。此边执见。常见摄。见苦所断。诸有此见。有十四亿六万六百生门。五业三业二业一业半业。六十二行迹。六十二中劫。百三十六地狱。百二十根。三十六尘界。四万九千龙家。四万九千妙翅鸟家。四万九千异学家。四万九千活命家。七有想藏。七无想藏。七离系藏。七阿素洛。七毕舍遮。七天。七人。七梦。七百梦。七觉。七百觉。七池。七百池。七险。七百险。七减。七百减。七增。七百增。六胜生类。八大士地。于如是处。经八万四千大劫。若愚若智。往来流转。乃决定能作苦边际。如掷缕丸。缕尽便住。此中无有沙门若婆罗门能作是说。我以尸罗。或以精进。或以梵行。令所有业未熟者熟。熟者触已。即便变吐。以如是斟量生死苦乐边际。不可施设。有增有减。亦不可说。或然不然。此非因计因。戒禁取。见苦所断。诸有此见。一切士夫补特伽罗。诸有所受。无不皆以宿作为因。此非因计因。戒禁取见。苦所断。诸有此见。一切士夫补特伽罗。诸有所受。无不皆以自在变化为因。此非因计因。戒禁取。见苦所断。诸有此见。一切士夫补特伽罗。所受皆是无因无缘。此谤因邪见。见集所断。诸有此见。自作苦乐。他作苦乐。自他作苦乐。此非因计因。戒禁取。见苦所断。诸有此见。所受苦乐。非自作。非他作。无因而生。此谤因邪见。见集所断。诸有此见。我及世间。常恒坚住。无变易法。正尔安住。此边执见常见摄。见苦所断。诸有此见。谛故住故我有我。此边执见常见摄。见苦所断。诸有此见。谛故住故我无我。此边执见断见摄。见苦所断。诸有此见。我观我眼色即我。此有身见。见苦所断。诸有此见。我观无我眼即我。色为众具。此有身见。见苦所断。诸有此见。无我观我色即我。眼为众具。此有身见。见苦所断。诸有此见。此是我。是有情。命者。生者。养育者。补特伽罗。意生儒童。作者。教者。生者。等生者。起者。等起者。语者。觉者。等领受者。非曾不有。非当不有。于彼彼处。造善恶业。于彼彼处。受果异熟。舍此蕴。续余蕴。此边执见常见摄。见苦所断。诸有此见。受妙五欲。名得第一现法涅槃。此取劣法为胜。见取。见苦所断。诸有此见。离欲恶不善法有寻有伺。离生喜乐。入初静虑具足住。名得第一现法涅槃。寻伺寂静。内等净心一趣性。无寻无伺。定生喜乐。入第二静虑具足住。名得第一现法涅槃。离喜住舍正念正知身受乐圣说能舍具念乐住。入第三静虑具足住。名得第一现法涅槃。断乐断苦。先喜忧没。不苦不乐。舍念清净。入第四静虑具足住。名得第一现法涅槃。此取劣法为胜。见取。见苦所断。有九慢类。谓我胜。我等。我劣。有胜我。有等我。有劣我。无胜我。无等我。无劣我。我胜者。是依见起过慢。我等者。是依见起慢。我劣者。是依见起卑慢。有胜我者。是依见起卑慢。有等我者。是依见起慢。有劣我者。是依见起过慢。无胜我者。是依见起慢。无等我者。是依见起过慢。无劣我者。是依见起卑慢。诸有此见。风不吹。河不流。火不然。乳不注。胎不孕。日月不出不没。染净自性住。不增不减。此边执见常见摄。见苦所断。如契经中说

  众生执我作　　执他作亦然
  各不能如实　　观知此是箭

此言有何义。答众生谓外道。彼作是执。我能作。我能生。我能化。故言众生执我作。复有外道。执他能作他能生他能化。故言执他作亦然。各谓一一非一切箭。谓恶见能中伤故。彼于此见。不能如实观知是箭

  当观此是箭　　众生坚执着
  如是则无有　　我作及他作

当观此是箭者。谓应如实观知此见是真毒箭。与老病死为前导故。众生坚执著者。众生谓外道。彼于见趣中。坚固执着。不能出离。若能如是如实观知。则不复有我作我生我化执。亦不复有他作他生他化执。知于非有妄执有故

  具慢众生　　慢着慢缚　　于见相逆
  不越生死

具慢者。显成就七慢。众生者。谓外道。彼于七慢。着多着遍着。故言慢着。缚多缚遍缚。故言慢缚。于见相逆者。谓断常见类。互相违逆。不越生死者。谓彼于无际生死。不能越度而取涅槃

  得当得俱坌　　劣学戒禁浴
  梵苦事一边　　受欲净第二
  不见极沈走　　明眼见能异
  于彼无尘慢　　绝路至苦边

得者。显示已得诸蕴界处。当得者。显示未得诸蕴界处。俱坌者。此二俱为贪嗔痴。尘坌遍坌极坌。劣有二义。一目病者。二目外道。今说外道为劣者。彼于此随学故言劣学。彼作是说。诸补特伽罗。学乘象马船车辇舆。执持弓杖钩轮罥索书印算数。皆令善巧。由此便得净脱出离至苦乐边。此非因计因。戒禁取。见苦所断。戒者。有诸外道。起此见。立此论。诸补特伽罗。受持牛鹿狗戒露形戒等。由此便得净脱出离至苦乐边。此非因计因。戒禁取。见苦所断。禁者。有诸外道。起此见。立此论。诸补特伽罗。受持乌禁鸺鹠禁默然禁等。由此便得净脱出离至苦乐边。此非因计因。戒禁取。见苦所断。浴者。有诸外道。起此见。立此论。诸补特伽罗。于摩捺娑比摩捺娑殑伽河门三池中浴。由此便得净脱出离至苦乐边。此非因计因。戒禁取。见苦所断。梵谓梵行。有诸外道。起此见。立此论。诸补特伽罗。受持梵行。远离淫欲。由此便得净脱出离至苦乐边。此非因计因。戒禁取。见苦所断。苦谓苦行。有诸外道。起此见。立此论。诸补特伽罗。受种种苦行。由此便得净脱出离至苦乐边。此非因计因。戒禁取。见苦所断。事谓承事。有诸外道。起此见。立此论。诸补特伽罗。调象马牛事日月星火珠药等。由此便得净脱出离至苦乐边。此非因计因。戒禁取。见苦所断。一边者。谓上所说是苦行边。受欲净者。有诸外道。起此见。立此论。诸欲净妙。快意受用。而无过失。此取劣法为胜。见取。见苦所断。第二者。谓此所说是乐行边。不见者。谓诸外道。于上二边。不如实见。极沈走者。谓彼外道。由不见故。一类起爱。故名极沈。一类起见。故名极走。复次一类懈怠。故名极沈。一类掉举。故名极走。复次一类起慢。故名极沈。一类起过慢。故名极走。明眼见者。明眼谓佛及佛弟子。见谓于上所说二边。如实知见。能异者。由如实知见故。不同彼极沈极走。以能不起爱见等故。于彼无尘者。谓于已得未得蕴界处。不起贪嗔痴尘。于彼无慢者。谓于二边。虽俱远离。而心不恃。绝路者。若能如是便绝三路。谓烦恼业苦。至苦边者。苦谓五取蕴苦。边谓涅槃。若绝三路。便得至此苦蕴边际

    见蕴第八中伽他纳息第六

  见梵父胜网　　车本信流转
  母王慧脱根　　此章愿具胜
  已见者能见　　已见及不见
  不见者不见　　不见及已见

已见者者。谓诸已见苦集灭道。能见已见及不见者。谓彼能见。诸余已见。及不见苦集灭道。不见者者。谓诸不见苦集灭道。不见不见及已见者。谓彼不见。诸余不见及以见苦集灭道

  不应害梵志　　亦复不应舍
  若害彼或舍　　俱世智所诃

不应害梵志者。梵志即阿罗汉。谓不应以手块刀杖害阿罗汉。亦复不应舍者。谓于阿罗汉。应以衣服饮食卧具医药及余资具。恭敬供养。不应弃舍。若害彼或舍俱世智所诃者。谓于阿罗汉。若以手块等害。或复弃舍而不敬养。俱为世间诸有智者诃责毁訾

  逆害于父母　　王及二多闻
  诛国及随行　　无碍过梵志

逆害于父母王及二多闻者。母即喻爱。以能生故。如世尊说

  士夫爱所生　　由心故驰走
  有情处生死　　苦为大怖畏

父即喻有漏业。以能引故。如世尊说。苾刍如是有情。造善有漏。修所成业。得生于彼。受果异熟。故我说彼随业而行。王即喻有取识。如世尊说

  第六增上王　　染时染自取
  无染而有染　　染者谓愚夫

又世尊说。苾刍当知。我说城主。即有取识。二多闻。即喻见取戒禁取。如祠祀静默。二多闻士。于尘秽中。共为嬉戏。如是二取。于有漏法执。为第一胜上。或复净脱出离。弃舍永断爱业识取。故名逆害。国喻烦恼。随行喻彼相应寻伺。诛谓诛戮。弃舍永断烦恼寻伺。故名为诛。无碍者。碍有三种。谓贪嗔痴。彼于此三。已断遍知。故名无碍。过者出也。彼无碍故。出过三界。永除恶法。故名梵志。如世尊说

  佛恒住正念　　游化于世间
  灭恶法尽结　　故名为梵志
  逆害于父母　　王及二多闻
  除虎第五怨　　是人说清净

此中上半义如前说。虎喻嗔缠。如虎禀性暴恶凶崄饮啖血肉。嗔缠亦尔。暴恶凶崄。灭诸善根。第五怨者。喻五盖中第五盖。或喻五顺下分结中第五结。弃舍永断。故说为除。是人永断贪嗔痴故。说为清净

  胜已不复胜　　已胜无所随
  佛所行无边　　无迹由何往

胜已者。谓诸烦恼已断遍知。彼有复胜。有不复胜。谁复胜。谓已断烦恼后还退者。谁不复胜。谓已断烦恼不复退者。不复胜者。简异复胜。已胜无所随者。谓若烦恼未断遍知。即随三界。循环流转。既诸烦恼已断遍知。故无所随。佛所行无边者。谓佛世尊。无学智见。明觉菩提。慧照现观。起得成就。故名为佛。四种念住。名佛所行。此四念住。行相所缘。俱无边际。故名无边。无迹由何往者。迹谓足迹。即喻烦恼。若诸烦恼未断遍知。由彼往于三界恶趣。既诸烦恼已断遍知。故无由往

  诸网不可布　　爱无何所将
  佛所行无边　　无迹由何往

诸网不可布者。网即喻爱。如世尊说。我说爱网弥覆林池。爱若未断遍知。则可弥布网罗三界。既已断遍知。故不可布。爱无何所将者。爱若未断遍知。则可将往三界。既已断遍知。故无所将往。颂中后半义。如前说

  已坏车断索　　流注及随行
  度堑于世间　　唯佛称梵志

已坏车断索流注及随行者。车喻我慢。索即喻爱。如车所载物由车故高。以索缚持。远有所至。有情亦尔。由慢故高。爱所缚持。流转生死。流注即喻一切烦恼。随行喻彼相应寻伺。已断遍知慢爱烦恼相应寻伺。名已断坏。度堑者。堑喻无明。已断遍知。故名度。如世尊说。齐何名为已度堑。谓已断遍知无明。于世间唯佛称梵志者。佛与梵志。义如前释。于诸世间。唯佛得称真实梵志无上觉者。方能永灭诸恶法故

  一本二洄洑　　三垢五流转
  大海十二崄　　牟尼皆已度

一本者喻无明。是生死根本故。如世尊说

  诸所有恶趣　　此世及后生
  皆无明为本　　欲贪等资助

二洄洑者。即喻名色。有情于中。难可出故。三垢者。谓贪嗔痴垢。五流转者。即喻五趣。有情于中。恒流转故。大海者。喻六内处。十二者。即十二相。此喻六内及六外处。崄者。崄坑喻诸烦恼。牟尼皆已度者。牟尼有二。一学。二无学。学于彼正度。无学于彼已度

  不信不知恩　　断密无容处
  恒希望变吐　　是最上丈夫

不信者。谓阿罗汉。彼于三宝四谛。皆自证知。非信他语。不知恩者。恩谓有为。有作用故。涅槃名非恩。诸阿罗汉。有胜智见。知非恩故。名不知恩。断密者。密谓相续。此有二种。一欲色界相续。二色无色界相续。彼阿罗汉。离此相续。故名断密。无容处者。谓阿罗汉。离相续故。于三界中。无容生处。恒希望变吐者。希望有二。一希望财位。二希望寿命。彼阿罗汉。于此二种。已断遍知。故名变吐。即是弃舍恒希望义。是最上丈夫者。谓阿罗汉。得上所说最上最胜第一功德故。丈夫中名为第一最胜最上

  三十六驶流　　意所引增盛
  恶见者乘御　　分别着所依

三十六驶流者。喻三十六爱行。意所引者。谓意为集。意所生起。是意种类。增盛者。谓上品猛利圆满。恶见者者。谓诸外道。彼乘御此。往捺洛迦傍生鬼界。故名乘御。分别者谓三种分别。一欲分别。二恚分别。三害分别。着所依者。着谓贪欲嗔恚愚痴。此依彼起。故名所依

  弃身恶行　　及语恶行　　弃意恶行
  及余过失

弃身恶行者。谓断身三恶行。及语恶行者。谓断语四恶行。弃意恶行者。谓断意三恶行。及余过失者。谓断除前十种恶行诸余过失

  汝于所见闻　　唯有所见闻
  及于所觉知　　唯有所觉知
  由汝唯有故　　无此彼近远
  亦无二中间　　便至苦边际

如是二颂。重显经中。佛告大母。汝于所见。唯有所见。汝于所闻。唯有所闻。汝于所觉。唯有所觉。汝于所知。唯有所知。由汝唯有所见闻等故汝无此。由汝无此故汝无彼。由汝无彼故。汝无近无远。无二中间。由是因缘。至苦边际。此中眼识所受所了别名所见。有于所见。唯有所见。有于所见非唯有所见。谁于所见。唯有所见。谓于眼识所受所了别。不起烦恼。谁于所见非唯有所见。谓于眼识所受所了。起诸烦恼。耳识所受所了别名所闻。有于所闻唯有所闻。有于所闻非唯有所闻。谁于所闻。唯有所闻。谓于耳识所受所了别。不起烦恼。谁于所闻非唯有所闻。谓于耳识所受所了别。起诸烦恼。鼻舌身三识所受所了别名所觉。有于所觉唯有所觉。有于所觉非唯有所觉。谁所觉唯有所觉。谓于三识所受所了别。不起烦恼。谁于所觉非唯有所觉。谓于三识所受所了别。起诸烦恼。意识所受所了别名所知。有于所知唯有所知。有于所知非唯有所知。谁于所知。唯有所知。谓于意识所受所了别。不起烦恼。谁于所知。非唯有所知。谓于意识所受所了别。起诸烦恼。由彼于所见闻觉知。唯有所见闻觉知。不起烦恼。故无有此。谓不起慢憍傲心高举心决勇。由其无此故无有彼。谓不起贪嗔痴。由其无彼故。无近无远。无二中间。谓于欲界色无色界。皆无生处。由如是理。便得至苦边际。苦者。谓五取蕴。此苦边际即是弃舍一切所依。爱尽离染永灭涅槃

  医泥及谜泥　　蹋铺达鞢铺
  勿希应喜寂　　遍离至苦边

如是一颂。重显经中。佛为护世二王作蔑戾车语说四圣谛等。彼便领会。医泥者。显苦圣谛。谜泥者。显集圣谛。蹋铺者。显灭圣谛。达鞢铺者。显道圣谛。勿希者。劝彼勿希求欲界色无色界。应喜者。劝彼若闻佛证菩提法。是善说僧修妙行色无常。受想行识无常。善施设苦谛。善施设集灭道谛。应生欢喜。应寂者。劝彼若起贪嗔痴时。应寂等寂最极寂静。应遍离者。劝励彼心应离欲界色无色界。至苦边者。谓彼若能如是。便得至苦边际。苦边际言义如前说

  知身如聚沫　　亦觉同阳焰
  断魔花小花　　不见死王使

知身如聚沫者。谓如实知身如聚沫。无力虚劣不可撮磨。亦觉同阳焰者。谓如实觉身同阳焰。因热恼生。迁流不住。断魔花小花者。魔有四种。谓烦恼魔。蕴魔。死魔。自在天魔。应知此中说烦恼魔。见所断者。名魔花。修所断者。名小花于彼弃舍永断名断。不见死王使者。无常能灭。名曰死王。老病迫逐。称死王使

  观住觉近远　　应喜诸业无
  知世有兴衰　　善心普解脱

观住者。谓应观察。住有三种。一空。二无愿。三无相。觉近远者。觉谓觉慧。聪明委具。于内外境。应正生起。应喜者。谓若闻说佛证菩提法。是善说僧修妙行色无常。受想行识无常。善施设苦谛。善施设集灭道谛。应生欢喜。诸业无者。谓不成就。能感后生身语意业。知世有兴衰者。知谓了达。世谓五取蕴。兴衰谓生灭。即是随观有漏五蕴有起尽义。善心者。谓决择心。善巧心。调柔心。普解脱者。谓于诸趣诸有诸生。已解脱。遍解脱。极解脱

  虽脱而坠堕　　饕餮复来还
  得安仍乐乐　　乘乐至乐所

虽脱者。谓诸外道。虽脱欲界。而坠堕者。谓彼而坠色无色界生。及堕彼受生贪。饕餮复来还者。谓彼于顺五下分结。虽少分断。而余多故。后必起贪。还生欲界。得安者。安谓有余依涅槃界。诸阿罗汉。已证故名得。仍乐乐者。乐谓无余依涅槃界。彼恒欣慕故名乐。乘乐至乐所者。谓乘道乐。至涅槃乐

  无根于地界　　无叶亦无枝
  彼雄猛脱缚　　谁复应讥毁

根者。喻有取识。地界者。喻四识住。如世尊说。五种子者。显有取识。地界者。显四识住。叶者。喻我慢。如世尊说。云何烧叶。谓我慢已断已遍知。枝者。喻爱。如世尊说

  五妙色宫内　　若有爱枝生
  牟尼见彼生　　以慧速除断

诸阿罗汉。于四识住中。无牵后有有取之识。无慢无爱。故说无根于地界无叶亦无枝。彼雄猛者。谓彼阿罗汉成就。能成雄猛法故。亦名雄猛。脱缚者。缚有三种。谓贪嗔痴。彼于此缚。已解脱。遍解脱。极解脱。谁复应讥毁者。谓如是类补特伽罗。唯应称誉。不应讥毁。若致讥毁。获罪无边。损坏世间真福田故。如世尊说

  若应毁而誉　　及应誉而毁
  彼口集殃祸　　必不受安乐

说一切有部发智论卷第二十


阿毗达磨法蕴足论

    No. 1537

阿毗达磨法蕴足论卷第一

        尊者大目干连造

        三藏法师玄奘奉　诏译

    学处品第一

  稽首佛法僧　　真净无价宝
  今集诸法蕴　　普施诸群生
  阿毗达磨如大海　　大山大地大虚空
  具摄无边圣法财　　今我正勤略显示

嗢拖南曰

  学支净果行圣种　　正胜足念谛静虑
  无量无色定觉支　　杂根处蕴界缘起

一时薄伽梵。在室罗筏。住逝多林给孤独园。尔时世尊。告苾刍众。诸有于彼五怖罪怨不寂静者。彼于现世。为诸圣贤同所诃厌。名为犯戒自损伤者。有罪有贬。生多非福。身坏命终。堕险恶趣。生地狱中。何等为五。谓杀生者。杀生缘故。生怖罪怨。不离杀生。是名第一。不与取者。劫盗缘故。生怖罪怨。不离劫盗。是名第二。欲邪行者。邪行缘故。生怖罪怨。不离邪行。是名第三。虚诳语者。虚诳缘故。生怖罪怨。不离虚诳。是名第四。饮味诸酒放逸处者。饮味诸酒放逸处缘故。生怖罪怨。不离饮酒诸放逸处。是名第五。有于如是五怖罪怨不寂静者。彼于现世。为诸圣贤同所诃厌。名为犯戒自损伤者。有罪有贬。生多非福。身坏命终。堕险恶趣。生地狱中

诸有于彼五怖罪怨能寂静者。彼于现世。为诸圣贤同所钦叹。名为持戒自防护者。无罪无贬。生多胜福。身坏命终。升安善趣。生于天中。何等为五。谓离杀生者。离杀生缘故。灭怖罪怨。能离杀生。是名第一。离不与取者。离劫盗缘故。灭怖罪怨。能离劫盗。是名第二。离欲邪行者。离邪行缘故。灭怖罪怨。能离邪行。是名第三。离虚诳语者。离虚诳缘故。灭怖罪怨。能离虚诳。是名第四。离饮诸酒放逸处者。离饮诸酒放逸处缘故。灭怖罪怨。能离饮酒诸放逸处。是名第五。有于如是五怖罪怨能寂静者。彼于现世。为诸圣贤同所钦叹。名为持戒自防护者。无罪无贬。生多胜福。身坏命终。升安善趣。生于天中。尔时世尊。为摄前义。而说颂曰

  诸行杀盗淫　　虚诳耽诸酒
  五怖罪怨缚　　圣贤所诃厌
  名犯戒自伤　　有罪招非福
  死堕险恶趣　　生诸地狱中
  诸离杀盗淫　　虚诳耽诸酒
  五怖罪怨脱　　圣贤所钦叹
  名持戒自防　　无罪感胜福
  死升安善趣　　生诸天界中

齐何名曰邬波索迦。谓诸在家白衣男子。男根成就。归佛法僧。起殷净心。发诚谛语。自称我是邬波索迦。愿尊忆持慈悲护念。齐是名曰邬波索迦。此何名为能学一分。谓前所说邬波索迦。归佛法僧。发诚言已。唯能离杀。不离余四。如是名为能学一分。复何名为能学少分。谓如前说。邬波索迦。归佛法僧。发诚言已。能离杀盗。不离余三。如是名为能学少分。复何名为能学多分。谓前所说邬波索迦。归佛法僧。发诚言已。离杀盗淫。不离余二。如是名为能学多分。复何名为能学满分。谓前所说邬波索迦。归佛法僧。发诚言已。具能离五。如是名为能学满分

成就五法邬波索迦。唯能自利不能利他。何等为五。谓前所说邬波索迦。自离杀生乃至饮酒诸放逸处。不能劝他令离杀生乃至饮酒诸放逸处。如是名为成就五法邬波索迦。唯能自利不能利他。成就十法邬波索迦。能利自他不能广利。何等为十。谓前所说邬波索迦。自离杀生乃至饮酒诸放逸处。亦能劝他令离杀生乃至饮酒诸放逸处。不能见余能离杀等欢喜庆慰。如是名为成就十法邬波索迦。能利自他不能广利。成就十五法邬波索迦。能利自他。亦能广利。何等十五。谓前所说邬波索迦。自离杀生乃至饮酒诸放逸处。亦能劝他令离杀生乃至饮酒诸放逸处。及能见余离杀生等。欢喜庆慰。如是名为成就十五法邬波索迦。能利自他亦能广利。成就八法邬波索迦。唯能自利。不能利他。何等为八。谓前所说邬波索迦。自具净信。不能劝他令具净信。自具净戒。不能劝他令具净戒。自具惠舍。不能劝他令具惠舍。自能策励。数往伽蓝。礼觐有德诸苾刍众。不能劝他令其策励数往伽蓝。礼觐有德诸苾刍众。自能至诚听闻正法。不能劝他令其至诚听闻正法。自闻法已能持不忘。不能劝他令持不忘。自持法已能思择义。不能劝他令思择义。自思择已为证法义。能正勤修法随法行。成和敬。行随法行者。不能劝他令正勤修。法随法行。成和敬行随法行者。如是名为。成就八法。邬波索迦唯能自利。不能利他。成就十六法邬波索迦。能利自他不能广利。何等十六。谓前所说邬波索迦。自具净信。亦能劝他令具净信。广说乃至自思择已。为证法义。能正勤修法随法行成和敬行随法行者。亦能劝他令正勤修法随法行成和敬行随法行者。不能见余具净信等欢喜庆慰。如是名为成就十六法邬波索迦。能利自他。不能广利。成就二十四法邬波索迦。能利自他。亦能广利。何等名为二十四法。谓前所说邬波索迦。自具净信。亦能劝他令具净信。广说乃至自思择已。为证法义。能正勤修法随法行成和敬行随法行者。亦能劝他令正勤修法随法行成和敬行随法行者。及能见余具净信等。欢喜庆慰。如是名为成就二十四法邬波索迦。能利自他。亦能广利

成就十法。身坏命终。堕险恶趣。生地狱中。何等为十。一杀生。二不与取。三欲邪行。四虚诳语。五离间语。六粗恶语。七杂秽语。八贪欲。九嗔恚。十邪见。若有成就如是十法。身坏命终。堕险恶趣。生地狱中

成就十法。身坏命终。升安善趣。生于天中。何等为十。一离杀生。二离不与取。三离欲邪行。四离虚诳语。五离离间语。六离粗恶语。七离杂秽语。八无贪。九无嗔。十正见。若有成就如是十法。身坏命终。升安善趣。生于天中

成就二十法。身坏命终。堕险恶趣。生地狱中。何等二十。谓自杀生。亦劝他杀。广说乃至自起邪见。亦复劝他令起邪见。若有成就此二十法。身坏命终。堕诸恶趣。生地狱中

成就二十法。身坏命终。升安善趣。生于天中。何等二十。谓自离杀。亦能劝他。令其离杀。广说乃至自起正见。亦能劝他令起正见。若有成就此二十法。身坏命终。升安善趣。生于天中

成就三十法。身坏命终。堕险恶趣。生地狱中。何等三十。谓自不离杀。劝他令杀。见不离杀。欢喜慰喻。广说乃至自起邪见。亦复劝他令起邪见。见起邪见。欢喜慰喻。若有成就此三十法。身坏命终。堕险恶趣。生地狱中

成就三十法。身坏命终。升安善趣。生于天中。何等三十。谓自离杀生。劝他离杀。见余离杀。欢喜慰喻。广说乃至自起正见。亦复劝他令起正见。见起正见。欢喜慰喻。若有成就此三十法。身坏命终。升安善趣。生于天中

成就四十法。身坏命终。堕险恶趣。生地狱中。何等四十。谓自不离杀。劝他令杀。见不离杀。欢喜慰喻。称扬赞叹杀生者事。广说乃至自起邪见。亦复劝他令起邪见。见起邪见。欢喜慰喻。称扬赞叹邪见者事。若有成就此四十法。身坏命终。堕险恶趣。生地狱中

成就四十法。身坏命终。升安善趣。生于天中。何等四十。谓自离杀生。劝他离杀。见余离杀。欢喜慰喻。称扬赞叹离杀者事。广说乃至自起正见亦复劝他令起正见。见起正见。欢喜慰喻。称扬赞叹正见者事。若有成就此四十法。身坏命终。升安善趣。生于天中。邬波索迦。有五学处。何等为五。乃至命终。远离杀生。是名第一。乃至命终。离不与取。是名第二。乃至命终。离欲邪行。是名第三。乃至命终。离虚诳语。是名第四。乃至命终。离饮诸酒诸放逸处。是名第五。于第一中。且何名为能杀生者。如世尊说。有杀生者。暴恶血手。耽着杀害。于诸有情众生胜类。无羞无愍。下至捃多比毕洛迦。皆不离杀。如是名为能杀生者。何等名为有杀生者。谓于杀生。不深厌患。不远不离。安住成就。如是名为有杀生者。何名暴恶。谓集种种弓刀杖等诸杀害具。是名暴恶。何名血手。谓诸屠羊屠鸡屠猪捕鸟捕鱼猎师劫盗魁脍缚龙守狱煮狗施罝弶等。是名血手。何故此等名为血手。谓彼虽数沐浴涂香服鲜净衣首冠花鬘身饰严具。而名血手。所以者何。彼于恶事。不深厌患。不远不离。令有情血起等起生等生积集流出。故名血手。何等名为耽着杀害。谓于众生。有害非杀。有害亦杀。害非杀者。谓以种种弓刀杖等诸杀害具。逼恼众生。未全断命。如是名为有害非杀。害亦杀者。谓以种种弓刀杖等诸杀害具。逼恼众生。亦全断命。如是名为有害亦杀。于杀害事。耽乐执着。如是名为耽着杀害。何等名为于诸有情众生胜类无羞无愍。且辩众生胜类差别。谓诸异生。说名众生。世尊弟子。说名胜类。又诸有情。有贪嗔痴。说名众生。若诸有情。离贪嗔痴。说名胜类。又诸有情。有爱有取。说名众生若诸有情。离爱离取。说名胜类。又诸有情。有顺无违。说名众生。若诸有情。无顺有违。说名胜类。又诸有情。无聪慧有无明。说名众生。若诸有情。聪慧有明。说名胜类。又诸有情。未离欲贪。说名众生。若诸有情。已离欲贪。说名胜类。又诸有情。已离欲贪。非佛弟子。说名众生。若诸有情。已离欲贪。是佛弟子。说名胜类。今此义中。若诸异生。说名众生。世尊弟子。说名胜类。所以者何。胜谓涅槃。彼能获得成就触证。故名胜类。如有颂言

  普随顺世间　　周遍历方邑
  欲求于胜我　　无所证无依

故此义中。若诸异生。说名众生。世尊弟子。说名胜类。于此有情众生胜类。应羞应愍。而于其中。无惭无羞。无愧无耻。无哀无愍。无伤无念。如是名为于诸有情众生胜类无羞无愍。何等名为下至捃多比毕洛迦皆不离杀。言捃多者。谓蚊蚋等诸小虫类。比毕洛迦。即诸蚁子。下至此类微碎众生。皆起恶心。欲兴杀害。是故名为能杀生者。即于此中。何名为生。何名杀生。何等名为远离杀生而说名为乃至命终远离杀生邬波索迦第一学处。所言生者。谓诸众生。有众生想。若诸有情。有有情想。若诸命者。有命者想。若诸养育。有养育想。若补特伽罗。有补特伽罗想。是名为生。言杀生者。谓于众生。起众生想。于诸有情。起有情想。于诸命者。起命者想。于诸养育。起养育想。于补特伽罗。起补特伽罗想。复起恶心不善心损心害心杀心现前。依如是业如是加行如是思惟如是策励如是勇猛。杀害众生。故思断命。由如是业如是加行如是思惟如是策励如是勇猛。杀害众生。故思断命。名为杀生。即前所说邬波索迦。于此杀生。能善思择。厌患远离。止息防护。不作不为。不行不犯。弃舍堰塞。不拒不逆。不违不越。如是名为远离杀生。是故说名乃至命终远离杀生邬波索迦第一学处

于第二中。且何名为不与取者。如世尊说。有不与取者。或城邑中。成阿练若。不与物数。劫盗心取。不离劫盗。如是名为不与取者。何等名为有不与取者。谓于不与取。不深厌患。不远不离。安住成就。如是名为有不与取者。何等名为或城邑中。谓有城墙周匝围绕。何等名为或阿练若。谓无城墙周匝围绕。何名不与。谓他摄受。不舍不弃不惠不施。何等名物。谓他摄受。有情无情。诸资生具。即此名为不与物数。何等名为劫盗心取不离劫盗。谓即所说。不与物数。怀贼心取。不厌远离。如是名为不与物数劫盗心取不离劫盗。是故名为不与取者。即于此中。何名不与。何名不与取。何名离不与取而说名为乃至命终离不与取邬波索迦第二学处言不与者。谓他摄受有情无情。诸资生具。不舍不弃。不惠不施。是名不与。不与取者。谓于他摄受诸资生具。起他摄受。及不与想。复起恶心不善心劫心盗心执心着心取心现前。依如是业如是加行如是思惟如是策励如是勇猛如是门如是路。于他摄受诸资生具。以执着取。劫盗故思。举离本处。由如是业如是加行如是思惟如是策励如是勇猛如是门如是路。于他摄受诸资生具。以执着取。劫盗故思。举离本处。名不与取。即前所说邬波索迦。于不与取。能善思择。厌患远离。止息防护。不作不为。不行不犯。弃舍堰塞。不拒不逆。不违不越。如是名为离不与取。是故说名乃至命终离不与取邬波索迦第二学处

于第三中。且何名为欲邪行者。如世尊说。有欲邪行者。于他女妇他所摄受。谓彼父母兄弟姊妹舅姑亲眷宗族守护。有罚有障。有障罚俱。下至授掷花鬘等信。于是等类。起欲烦恼。招诱强抑。共为邪行。不离邪行。如是名为欲邪行者。何等名为有欲邪行者。谓于欲邪行。不深厌患。不远不离。安住成就。如是名为有欲邪行者。他女妇者。谓七种妇。何等为七。一授水妇。二财货妇。三军掠妇。四意乐妇。五衣食妇。六同活妇。七须臾妇。授水妇者。谓女父母。授水与男。以女妻之。为彼家主。名授水妇。财货妇者。谓诸丈夫。以少多财。贸易他女。将为己妇。名财货妇。军掠妇者。谓有丈夫。因伐他国。抄掠他女。将为己妇。复有国王。因破敌国。取所欲已。余皆舍弃。有诸丈夫。力摄他女。将为己妇。如是等类。名军掠妇。意乐妇者。谓有女人。于男子家。自信爱乐。愿住为妇。名意乐妇。衣食妇者。谓有女人。于男子家。为衣食故。愿住为妇。名衣食妇。同活妇者。谓有女人。诣男子家。谓男子曰。我持此身。愿相付托。彼此所有。共为无二。互相存济。以尽余年。冀有子孙。殁后承祭。名同活妇。须臾妇者。谓有女人。乐与男子。暂时为妇。名须臾妇。他摄受中。母守护者。谓有女人。其父或狂。或复心乱。或忧苦逼。或已出家。或远逃逝。或复命终。其母孤养。防守遮护。私诫女言。诸有所作。必先白我。然可得为。名母守护。父守护者。谓有女人。其母或狂。或复心乱。广说乃至。或复命终。其父孤养。防守遮护。私诫如前。名父守护。兄弟守护者。谓有女人。父母或狂。或复心乱。广说乃至。或复命终。兄弟孤养。防守遮护。私劝诫言。诸有所作。必先告白。然可得为。名兄弟守护。姊妹守护者。谓有女人。父母或狂。或复心乱。广说乃至。或复命终。姊妹孤养。防守遮护。劝诫如前。名姊妹守护。舅姑守护者。谓有女人。其夫或狂。或复心乱。广说乃至。或复命终。依舅姑居。舅姑喻曰。尔勿愁恼。宜以自安。衣食之资。悉以相给。我当忧念。如子不殊。舅姑恩恤。防守遮护。私诫之言。诸有所作。必先咨白。然可得为。名舅姑守护。亲眷守护者。谓有女人。除母及夫。余异姓亲。名为亲眷。而此女人。为彼亲眷。防守遮护。名亲眷守护。宗族守护者。谓有女人。除父兄等。余同姓亲。名为宗族。而此女人。为彼宗族。防守遮护。名宗族守护。言有罚者。谓有女人。自无眷属。又非淫女。若有凌逼。为王所知。或杀或缚。或复驱摈。或夺资财。名为有罚。言有障者。谓有女人。身居卑贱。虽无亲族。而有主碍。名为有障。有障罚俱者。谓有女人。自无眷属。又非卑贱。依恃他居。为他所碍。若有陵逼所依恃者。便为加罚。名障罚俱。又上所说。一切女人。随所依止。皆有障罚。所以者何。由诸女人。法有拘碍。非礼行者。便遭杀缚。或夺资财。或被退毁。是故一切名障罚俱。何等名为下至授掷花鬘等信。谓有女人。已受男子。或花或鬘。或诸璎珞。或涂香末香。或随一信物。如是名为下至授掷花鬘等信。何等名为于是等类。谓诸男子。诸半择迦。诸修梵行。何等名为修梵行者。谓诸苾刍尼。正学勤策女。及邬波斯迦。出家外道女。下至在家修苦行女。谓有男子。舍自妻媵。告言善贤。放汝自在修诸梵行。彼闻受持。苦行无怠。何等名为起欲烦恼广说乃至不离邪行。谓起欲界淫贪现前。于不应行。招诱强抑。共为邪行。不厌远离。如是名为起欲烦恼广说乃至不离邪行。是故名为欲邪行者。即于此中。何等名欲。何名欲邪行。何名离欲邪行。而说名为乃至命终离欲邪行邬波索迦第三学处。所言欲者。谓是淫贪。或所贪境。欲邪行者。谓于上说。所不应行。而暂交会。下至自妻。非分非礼。及非时处。皆名欲邪行。即前所说邬波索迦。于欲邪行。能善思择。厌患远离。止息防护。不作不为。不行不犯。弃舍堰塞。不拒不逆。不违不越。如是名为离欲邪行。是故说名乃至命终离欲邪行邬波索迦第三学处

于第四中。且何名为虚诳语者。如世尊说。有虚诳语者。或对平正。或对大众。或对王家。或对执理。或对亲族。同检问言。咄哉男子。汝知当说。不知勿说。汝见当说。不见勿说。彼得问已。不知言知。知言不知。见言不见。不见言见。彼或为己。或复为他。或为名利。故以正知。说虚诳语。不离虚诳。如是名为虚诳语者。何等名为有虚诳语者。谓于虚诳语。不深厌患。不远不离。安住成就。如是名为有虚诳语者。何等名为或对平正。平正有三。一村平正。二城平正。三国平正。此诸平正。聚集现前。同检问时。名对平正。何等名为或对大众。大众有四。一刹帝利众。二婆罗门众。三居士众。四沙门众。此诸大众。聚集现前。同检问时。名对大众。何等名为或对王家。谓诸国王。及余宰辅。理公务者。彼若聚集。现前检问。名对王家。何等名为或对执理。谓闲法律。固正断者。此执理众。聚集现前。同检问时。名对执理。何等名为或对亲族。谓诸亲族聚集现前。同检问时。名对亲族。何等名为同检问等。谓或为证。或究其身。众集量宜。同检问曰。咄哉男子。今对众前。应以诚言具款情实。若于是事。见闻觉知。宜当宣说施设摽示。若于是事。无见闻等。勿当宣说施设摽示。如是名为同检问等。何等名为不知言知。谓为耳识曾受曾了。名为已闻。彼无耳识曾受曾了。隐藏如是想忍见乐。言我已闻。如是名为不知言知。何等名为知言不知。谓为耳识曾受曾了。名为已闻。彼有耳识曾受曾了。隐藏如是想忍见乐。言我不闻。如是名为知言不知。何等名为不见言见。谓为眼识曾受曾了。名为已见。彼无眼识曾受曾了。隐藏如是想忍见乐。言我已见。如是名为不见言见。何等名为见言不见。谓为眼识曾受曾了。名为已见。彼有眼识曾受曾了。隐覆如是想忍见乐。言我不见。如是名为见言不见。何等名为彼或为己。谓有一类。身行劫盗。王等执问。汝为贼不。彼得问已。窃自思惟。若实答者。必为王等。或杀或缚。或复驱摈。或夺资财。我今宜应自隐自覆自藏实事。故以正知。说虚诳语。既思惟已。答王等言。我实不为不与取事。是名为己。何等名为或复为他。谓有一类亲族知友。行于劫盗。王等为证。执问彼言。汝知此人行劫盗不。彼得问已。窃自思惟。若实答者。我诸亲友。必为王等。或杀或缚。或复驱摈。或夺资财。我今宜应隐覆藏彼。故以正知。说虚诳语。既思惟已。答王等言。我知亲友。决定不为不与取事。是名为他。何等名为或为名利。谓有一类。多有所欲。多有所思。多有所愿。作是思惟。我当施设如是如是虚诳方便。必当获得可意色声香味触等。既思惟已。方便追求。故以正知。说虚诳语。如是名为或为名利。何等名为故以正知说虚诳语。谓自隐藏想忍见乐故思明了。数数宣说施设摽示违想等事。如是名为故以正知说虚诳语。即于此中。何名虚诳。何名虚诳语。何名离虚诳语。而说名为乃至命终离虚诳语邬波索迦第四学处。言虚诳者。谓事不实。名虚想等。不实名诳。是名虚诳。虚诳语者。以贪嗔痴。违事想说令他领解。名虚诳语。即前所说邬波索迦。于虚诳语。能善思择。厌患远离。止息防护。不作不为。不行不犯。弃舍堰塞。不拒不逆。不违不越。如是名为离虚诳语。是故说名乃至命终离虚诳语邬波索迦第四学处

于第五中。何名诸酒。何名饮诸酒。何名放逸处。何名离饮诸酒诸放逸处。而说名为乃至命终离饮诸酒诸放逸处邬波索迦第五学处。言诸酒者。谓窣罗酒。迷丽耶酒。及末沱酒。言窣罗者。谓米麦等。如法蒸煮。和麴糵汁。投诸药物。酝酿具成。酒色香味。饮已惛醉。名窣罗酒。迷丽耶者。谓诸根茎。叶花果汁。不和麴糵酝酿具成。酒色香味。饮已惛醉。名迷丽耶酒。言末沱者。谓蒲萄酒。或即窣罗迷丽耶酒。饮已令醉。总名末沱饮诸酒者。谓饮咽啜。如上诸酒。名饮诸酒。放逸处者。谓上诸酒。饮已能令心生憍傲。惛醉狂乱。不识尊卑。重惑恶业。皆因此起。放逸所依。名放逸处。即前所说邬波索迦。于饮诸酒。能善思择。厌患远离。止息防护。不作不为。不行不犯。弃舍堰塞。不拒不逆。不违不越。如是名为离饮诸酒诸放逸处。是故说名乃至命终离饮诸酒诸放逸处邬波索迦第五学处

如是五种。云何名学。云何名处。言学处耶。所言学者。谓于五处。未满为满。恒勤坚正。修习加行。故名为学。所言处者。即离杀等。是学所依。故名为处。又离杀等。即名为学。亦即名处。故名学处

一切邬波索迦。皆归佛法僧耶。除诸世俗邬波索迦。一切皆归佛法僧宝。有归佛法僧宝而非邬波索迦。谓苾刍苾刍尼。正学勤策勤策女邬波斯迦等

一切邬波索迦。皆世尊弟子耶。应作四句。有邬波索迦非世尊弟子。谓邬波索迦。未得见谛。于未来果。未能现观。有世尊弟子非邬波索迦。谓苾刍苾刍尼。正学勤策勤策女邬波斯迦等。已得见谛。于未来果。已能现观。有邬波索迦亦世尊弟子。谓邬波索迦。已得见谛。于未来果。已能现观。有非邬波索迦非世尊弟子。谓苾刍苾刍尼。正学勤策勤策女邬波斯迦。未得见谛。于未来果。未能现观。及余异生未见谛者

一切堕僧宝摄。皆得僧和敬耶。应作四句。有堕僧宝摄非得僧和敬。谓正学勤策勤策女邬波索迦等。已得见谛。于未来果。已能现观。有得僧和敬非堕僧宝摄。谓苾刍苾刍尼。未得见谛。于未来果。未能现观。有堕僧宝摄亦得僧和敬。谓苾刍苾刍尼。已得见谛。于未来果。已能现观。有非堕僧。宝摄非得僧和敬。谓正学勤策勤策女邬波索迦邬波斯迦未得见谛。于未来果。未能现观及余异生未见谛者

说一切有部法蕴足论卷第一阿毗达磨法蕴足论卷第二

        尊者大目干连造

        三藏法师玄奘奉　诏译

    预流支品第二

一时薄伽梵。在室罗筏。住逝多林给孤独园。尔时世尊。告苾刍众。有四种法。若正勤修是人名为多有所作。何等为四。谓亲近善士。听闻正法。如理作意。法随法行。汝等苾刍。应如是学。我当亲近供养善士恭敬一心。听闻正法。如理观察甚深妙义。精进修行。法随法行。尔时世尊。为摄前义。而说颂曰

  善哉见善士　　能断疑增慧
  令愚成智人　　慧者应亲近
  善士应亲近　　以亲近彼时
  令疑断慧增　　使愚成智故

云何为善士。谓佛及弟子。又诸所有补特伽罗。具戒具德。离诸瑕秽。成调善法。堪绍师位。成就胜德。知羞悔过。善守好学。具知具见。乐思择爱称量。喜观察性。聪敏具觉。慧息追求有慧类。离贪趣贪灭。离嗔趣嗔灭。离痴趣痴灭。调顺趣调顺。寂静趣寂静。解脱趣解脱。越度趣越度。妙觉趣妙觉。涅槃趣涅槃。乐调顺谛。离憍放逸。好慧忍辱柔和。升直道如见。专自调伏。专自寂静。专自涅槃。为才支身。游诸国邑王都聚落。求衣食等具。质直具。调顺具足。质直及调顺具。忍辱具。柔和具足。忍辱及柔和具。供养具。恭敬具足。供养及恭敬具。正行具。守根具足。正行及守根具。轨范具。所行具足。轨范及所行具。信尸罗。及闻舍慧。自具净信。亦能劝励安立有情。同具净信。自具尸罗。及闻舍慧。亦能劝励安立有情。同具尸罗。及闻舍慧。是名善士。何故名善士。以所说善士。离非善法。成就善法。具足成就四念住四正胜四神足五根。五力七等觉支八圣道支。故名善士。若能于此所说善士。亲近承事恭敬供养。如是名为亲近善士。云何名为听闻正法。谓所亲近供养善士。未显了处为正显了。未开悟处。为正开悟。以慧通达深妙句义。方便为其宣说施设安立开示。以无量门。正为开示。苦真是苦。集真是集。灭真是灭。道真是道。云何名为以无量门。正为开示。苦真是苦。谓正开示生苦老苦病苦死苦怨憎会苦爱别离苦求不得苦。略说一切五取蕴苦。如有颂言

  诸蕴起为苦　　生及出亦苦
  生已有老苦　　病苦与死苦
  烦恼生为苦　　生已住亦苦
  非聪敏悔苦　　不调伏死苦
  无智有情苦　　增羯吒私苦
  愚夫生死苦　　多劫驰流苦

此等名为以无量门正为开示苦真是苦。云何名为以无量门正为开示集真是集。谓正开示。爱后有爱。喜俱行爱。彼彼喜爱。为去来今。众苦因本。道路由绪。能作生缘。起集等起。能起集等。起现法中诸苦身坏。后苦由是出生。如有颂言

  因爱弃良医　　痈本榛藤渴
  未调伏一切　　数数感众苦
  如树根未拔　　虽斫斫还生
  未拔爱随眠　　数数感众苦
  如毒箭在身　　损坏色力等
  众生内有爱　　损坏诸善根

此等名为以无量门正为开示集真是集。云何名为以无量门正为开示灭真是灭。谓正开示。即上所说。爱后有爱。喜俱行爱。彼彼喜爱。无余永断。弃舍变吐。尽离染灭。寂静永没。名为舍宅。亦名洲渚。亦名救护。亦名归依。亦名所趣。亦名无忧。亦名无病。亦名无动。亦名无没。亦名无炽。亦名无热。亦名安隐。亦名惔怕。亦名善事。亦名吉祥。亦名涅槃。如有颂言

  究竟沙门果　　调伏所称赞
  我慢灭无余　　永证甘露迹
  所归住趣宅　　胜宫佛所赞
  惔怕灭无边　　彼岸常安隐
  所依尽苦灭　　脱无窟究竟
  胜义旨应供　　智所习圣欣
  都无老病死　　无愁叹苦忧
  微难见无边　　灭谛无同类

此等名为以无量门正为开示灭真是灭。云何名为以无量门正为开示道真是道。谓正开示。此道此行。于去来今众苦。能断能弃。能吐能尽。能离染。能灭能寂静。能令永灭没。此复云何。谓八支圣道。正见正思惟正语正业正命正精进正念正定。如有颂言

  此威猛一趣　　如鸟路清虚
  牟尼定所行　　为众数宣说
  哀愍说一趣　　见道尽生边
  此道于瀑流　　去来今能度
  能究竟调静　　能尽生死流
  能通达多界　　能开明眼道
  如殑伽驶流　　速趣于大海
  开示广慧道　　速证于涅槃
  哀愍一切众　　转未闻法轮
  教导诸天人　　稽首度有海

此等名为以无量门正为开示道真是道。若于此等所说正法。乐听乐闻。乐受持。乐究竟。乐解了。乐观察。乐寻思。乐推究。乐通达。乐触。乐证。乐作证。为闻法故。履艰险径。涉边表路。游平坦道。皆无忌难。为受持故。数以耳根。对说法音。发胜耳识。如是名为听闻正法

云何名为如理作意。谓从善士。闻正法已。内自庆慰。欢喜踊跃。奇哉世尊。能说如是深妙正法。佛所说苦。实为真苦。佛所说集。实为真集。佛所说灭。实为真灭。佛所说道。实为真道。彼由如是内自庆慰欢喜踊跃。引摄其心。随摄等摄。作意发意。审正观察深妙句义。如是名为如理作意

云何名为法随法行。谓彼旋环如理作意。审正观察深妙义已。便生出离远离所生五胜善法。谓信精进。及念定慧。彼于自内所生出离远离所生五胜善法。修习坚住。无间修习。增上加行。如是名为法随法行。精进修行。法随法行。便得趣入正性离生

所以得入正性离生。由精进修法随法行。所以能修法随法行。由如理观甚深妙义。所以能观甚深妙义。由能恭敬听闻正法。所以复能听闻正法。由能亲近供养善士。若能亲近供养善士。便闻正法。闻正法已。便能如理观深妙义。如理观察深妙义已。便能进修法随法行。既精进修法随法行。便得趣入正性离生。如山顶上。天雨霖霪。先溪涧满。溪涧满已。小沟渎满。小沟渎满已。大沟渎满。大沟渎满已。小河满。小河满已。大河满。大河满已。大海满。大海如是渐次方满。圣道大海。亦复如是。要先亲近供养善士。方闻正法。闻正法已。方能如理观深妙义。如理观察深妙义已。方能进修法随法行。精进修行法随法行得圆满已。方得趣入正性离生。既得趣入正性离生。便名已生八支圣道。谓正见等。如前已说。如是四种。名预流支

由此四种。于圣道流。能获能得。能至随至。能办能满。能触能证。能作证故。名预流支。又此四种。于所求义。由修习多修习。能获能得。能至随至。能办能满。能触能证。能作证故。名预流支。又此四种。于圣道流。能随顺能增长能严饰。能磨莹。能为常安助资粮故。名预流支。又此四种。由语增语。由想等想施设言说。为预流支故。名预流支

    证净品第三之一

一时薄伽梵。在室罗筏。住逝多林给孤独园。尔时世尊。告苾刍众。若诸有情。于汝言教。信心听受。能奉行者。汝当哀愍方便劝励。安立令住四证净中。何等为四。谓佛证净法证净僧证净圣所爱戒。所以者何。诸有地界水火风界。是四大种。容可改易。若有成就此四证净。诸圣弟子。必无改易。由此多闻诸圣弟子。成就如是四证净故。若堕地狱傍生鬼界。无有是处。是故若有于汝言教。信心听受能奉行者。汝当哀愍方便劝励安立。令住四证净中

云何佛证净。如世尊言。此圣弟子。以如是相。随念诸佛。谓此世尊。是如来阿罗汉正等觉明行圆满善逝世间解无上丈夫调御士天人师佛薄伽梵。所言此者。谓此欲界。或此世界。此赡部洲。又言此者。谓即此身持等持躯等躯聚得自体。又言此者。谓此处生。佛及弟子。诸仙牟尼。诸聪睿者。善调伏者。善调顺者。又言此者。谓即于此教授教诫善说法中。是故言此。言圣弟子者。圣谓佛法僧。归依佛法僧故。名圣弟子。以如是相随念佛者。谓以此相此门此理。于诸佛所。起念随念。专念忆念。不忘不失。不遗不漏。不失法性。心明记性。是故名为以如是相随念诸佛。所言谓者。谓如是相。如是状。如是种。如是类。是故言谓所言此者。谓如是戒。如是法。如是慧。如是通。如是解脱。如是多住。是故言此。言世尊者。如后当释。言如来者。如世尊言。从菩萨证无上正等菩提夜。乃至佛无余依般涅槃界夜。于其中间。诸有所说。宣畅敷演。一切皆如。无有虚妄。无有变异。谛实如理。无有颠倒。皆以如是如实正慧。见已而说故。名如来。阿罗汉者。略有二种阿罗汉性。一者有为。二者无为。云何有为阿罗汉性。谓彼果得。及彼得得。无学根力。无学尸罗。无学善根。十无学法。及彼种类诸无学法。是名有为阿罗汉性。云何无为阿罗汉性。谓贪嗔痴。一切烦恼皆悉永断超一切趣。断一切道。三火永静。焦渴永息。憍逸永离。窟宅永破。度四瀑流。无上究竟。无上寂静。无上爱尽。离灭涅槃。是名无为阿罗汉性。如来具足圆满成就。如是所说有为无为阿罗汉性。故名阿罗汉。又贪嗔痴。及余烦恼。皆悉应断。如来于彼。永断遍知。如多罗树永断根顶无复遗余。皆得当来永不生法。故名阿罗汉。又身语意三种恶行。皆应永断。如来于彼。永断遍知乃至广说。故名阿罗汉。又过去佛。皆已远离恶不善法。所有杂染。后有炽然。苦异熟果。皆得当来永不生法。今佛亦尔。故名阿罗汉。又佛世尊。成就最胜吉祥功德。应受上妙衣服饮食诸坐卧具医药资缘种种供养。故名阿罗汉。如有颂言

  世所应受用　　种种上妙物
  如来皆应受　　故名阿罗汉

正等觉者。如世尊言。诸所有法。一切正性。如来一切知见解了正等觉。故名正等觉。又等法者。谓四念住。四正胜。四神足。五根五力。七等觉支。八圣道支。如来一切知见解了正等觉。故名正等觉。又于一切苦集灭道。能现观道。能证预流果一来果不还果阿罗汉果道。能证神境智作。证通天耳智作。证通他心智作。证通宿住随念智作。证通死生智作。证通漏尽智作。证通道能尽贪嗔痴慢憍垢道。如来一切皆正等觉。至诚坚住。殷重作意。以因以门。以理以相正等觉故。名正等觉。明行圆满者。何等为明。谓佛所有无学三明。一者无学宿住随念智作证明。二者无学死生智作证明。三者无学漏尽智作证明。是谓为明。何等为行。谓佛所有无学身律仪。语律仪。命清净。是谓为行。又佛所有上妙威仪。往来顾视。屈伸俯仰。服僧伽胝。执持衣钵。悉皆严整。是谓为行。此行前明。总谓明行。如来具足圆满成就如是明行。一向鲜白。一向微妙。一向无罪。是故名为明行圆满。言善逝者。谓佛成就极乐安隐无艰无难往趣妙法。故名善逝。又贪嗔痴。及余烦恼所生。种种难往趣法。如来于彼。永断遍知。如多罗树永断根顶无复遗余。皆得当来永不生法。故名善逝。又如过去诸佛世尊。皆乘如实。无虚妄道。趣出世间。殊胜功德。一至永至。无复退还今佛亦然。故名善逝。世间解者。谓五取蕴。名为世间。如来于彼。知见解了正等觉。故名世间解。又说五趣。名为世间。如来于彼。知见解了正等觉。故名世间解。又说六处。名为世间。如来于彼。知见解了正等觉。故名世间解。又说三界所摄诸处。名为世间。从彼而生。从彼而起。从彼而出。因彼而生。因彼而起。因彼而出。如来于彼。知见解了正等觉。故名世间解。无上丈夫者。如世尊言。所有有情。无足二足。四足多足。有色无色。有想无想。非想非非想。如来于中。最称第一。最胜最尊。最上无上。由此故说无上丈夫。调御士者。谓佛世尊。略以三种巧调御事。调御一切所化有情。一于一类。一向柔软。二于一类。一向粗犷。三于一类。柔软粗犷。云何如来于彼一类一向柔软。谓为彼说此身妙行。此身妙行所感异熟。此语妙行。此语妙行所感异熟。此意妙行。此意妙行所感异熟。此天此人。此善趣。此乐世。此涅槃。是名如来于彼一类一向柔软。云何如来于彼一类一向粗犷。谓为彼说。此身恶行。此身恶行所感异熟。此语恶行。此语恶行。所感异熟。此意恶行。此意恶行。所感异熟此地狱。此傍生。此鬼界。此险难。此恶趣。此堕落。是名如来于彼一类一向粗犷。云何如来于彼一类柔软粗犷。谓于时时为说。身妙行。语妙行。意妙行。或于时时为说。身妙行语妙行。意妙行。所感异熟。或于时时为说。身恶行。语恶行。意恶行。或于时时为说。身恶行。语恶行。意恶行。所感异熟。或于时时为说。天人善趣。乐世涅槃。或于时时为说。地狱傍生。鬼界险难。恶趣堕落。是名如来于彼一类柔软粗犷。如来于彼。以此三种巧调御事。如是调伏。如是止息。如是寂静。如是令其无余。永舍贪嗔痴等一切烦恼。如是令其无余。永尽贪嗔痴等一切烦恼。令永调伏。令永止息。令永寂静。得上调御。得胜调御。得胜清凉。永除曲秽。善灭慢覆及谄垢浊。是故如来名调御士。天人师者。如世尊告阿难陀言。我非但与苾刍苾刍尼邬波索迦邬波斯迦四众为师。然我亦与诸天魔梵沙门婆罗门等诸天人众。为师为胜师。为随师。为范为胜范。为随范。为将为导。是故如来名天人师。所言佛者。谓于如来无学智见明鉴觉慧照现观等已能具起及得成就。故名为佛。且如有一大婆罗门。来诣佛所。以妙伽他。赞问佛曰

  稽首世导师　　名最上觉者
  何缘父母等　　号尊名佛陀

世尊哀愍彼婆罗门。亦以伽他而告彼曰

  婆罗门当知　　我如去来佛
  成就觉者相　　故我名佛陀
  婆罗门当知　　我观三世行
  皆有生灭法　　故我名佛陀
  婆罗门当知　　我于应知断
  证修事已办　　故我名佛陀
  婆罗门当知　　我于一切境
  具一切智见　　故我名佛陀
  婆罗门当知　　我于无量劫
  修诸纯净行　　经无量死生
  今于最后身　　离尘垢毒箭
  证得无上觉　　故我名佛陀

薄伽梵者。谓有善法。名薄伽梵。成就无上诸善法故。或修善法。名薄伽梵。已修无上诸善法故。又佛世尊。圆满修习身戒心慧。成就大悲。我无限无量。成无量法。名薄伽梵。又佛世尊。具大威德。能往能至。能坏能成。能自在转。名薄伽梵。又佛世尊。永破一切贪嗔痴等恶不善法。永破杂染后有炽然苦异熟果。永破当来生老病死。名薄伽梵。如有颂言

  永破贪嗔痴　　恶不善法等
  具胜无漏法　　故名薄伽梵

又佛世尊。于未闻法。能自通达。得最上觉。成现法智。无障碍智。善解当来。修梵行果。为诸弟子。分别解说。设大法会。普施有情。名薄伽梵。如有颂言

  如来设法会　　普哀愍无依
  如是天人师　　稽首度有海

又佛世尊。为诸弟子。随宜说法皆令欢喜。恭敬信受。如教修行。名称普闻。遍诸方域。无不赞礼。名薄伽梵。若圣弟子。以如是相随念诸佛。见为根本。证智相应诸信信性。现前信性。随顺印可爱慕爱慕性。心证心净。是名佛证净。若能于此。劝励安立。当知是名方便劝励安立令住佛证净中

云何法证净。如世尊言。此圣弟子。以如是相。随念正法。谓佛正法善说现见无热应时引导近观智者内证。所言此者。谓此欲界或此世界此赡部洲。又言此者。谓即此身持等持躯等躯聚得自体。又言此者。谓此处生。佛及弟子。诸仙牟尼。诸聪睿者。善调伏者。善调顺者。又言此者。谓即于此教授教诫善说法中。是故言此。言圣弟子者。圣谓佛法僧。归依佛法僧。故名圣弟子。以如是相随念法者。谓以此相此门此理。于正法所。起念随念。专念忆念。不忘不失。不遗不漏。不失法性。心明记性。是故名为以如是相随念正法。言善说者。谓佛所说。苦真是苦。集真是集。灭真是灭。道真是道。故名善说。若佛世尊。非苦说苦。非集说集。非灭说灭。非道说道。可非善说。以佛世尊。苦说为苦。集说为集。灭说为灭。道说为道。故佛正法名为善说。言现见者。谓正修习世尊所说苦集灭道。现观道时。于现法中。即入苦集灭道。现观故名现见。若正修习世尊所说苦集灭道。现观道时。非现法中。即入苦集灭道。现观世尊正法可非现见。以正修习世尊所说苦集灭道。现观道时。于现法中。即入苦集灭道现观。故佛正法名为现见。又正修习世尊所说。能断见苦见集见灭见道所断及修所断随眠道时。于现法中。即断见苦见集见灭见道所断及修所断一切随眠。故名现见。若正修习世尊所说。能断见苦见集见灭见道所断及修所断随眠道时。非现法中。即断见苦见集见灭见道所断及修所断一切随眠。世尊正法。可非现见。以正修习世尊所说。能断见苦见集见灭见道所断及修所断随眠道时。于现法中。即断见苦见集见灭见道所断及修所断一切随眠故佛正法名为现见。又正修习世尊所说。能证见苦见集见灭见道所断及修所断随眠灭道时于现法中。即证见苦见集见灭见道所断及修所断诸随眠灭。故名现见。若正修习世尊所说。能证见苦见集见灭见道所断及修所断随眠灭道时。非现法中。即证见苦见集见灭见道所断及修所断诸随眠灭。世尊正法。可非现见以正修习世尊所说。能证见苦见集见灭见道所断及修所断随眠灭道时。即证见苦见集见灭见道所断及修所断诸随眠灭。故佛正法名为现见。言无热者。谓八支圣道。名为无热。所以者何。热谓烦恼。八支圣道中。一切烦恼。无得无近得无有无等有。故佛正法名为无热。言应时者。谓八支圣道。名为应时。所以者何。由正修习世尊所说苦集灭道现观道时。即入苦集灭道现观。故名应时。若正修习世尊所说苦集灭道现观道。后方入苦集灭道现。观世尊正法可非应时。以正修习世尊所说苦集灭道现观道时。即入苦集灭道现观。故佛正法名为应时。又正修习世尊所说。能断见苦见集见灭见道所断及修所断随眠道时。即断见苦见集见灭见道所断及修所断一切随眠。故名应时。若正修习世尊所说。能断见苦见集见灭见道所断及修所说随眠道。后方断见苦见集见灭见道所断及修所断一切随眠。世尊正法。可非应时。以正修习世尊所说。能断见苦见集见灭见道所断及修所断随眠道时。即断见苦见集见灭见道所断及修所断一切随眠。故佛正法名为应时。又正修习世尊所说。能证见苦见集见灭见道所断及修所断随眠灭道时。即证见苦见集见灭见道所断及修所断诸随眠灭。故名应时。若正修习世尊所说。能证见苦见集见灭见道所断及修所断随眠灭道。后方证见苦见集见灭见道所断及修所断诸随眠灭。世尊正法。可非应时。以正修习世尊所说。能证见苦见集见灭见道所断及修所断随眠灭道时。即证见苦见集见灭见道所断及修所断诸随眠灭。故佛正法名为应时。言引导者。谓八支圣道。名为引导所以者何。以八支圣道习修多修习。能于苦集灭道。现观能引能导能随能逐。故佛正法名为引导。言近观者。谓八支圣道。名为近观。所以者何。以八支圣道修习多修习。能于苦集灭道。如实知见苦集灭道。故佛正法名为近观。智者内证者。佛及佛弟子。名为智者。世尊所说苦集灭道。智者自内知见解了正等觉为苦集灭道。故佛正法。名智者内证。若圣弟子。以如是相随念正法见为根本证智相应诸信信性现前信性随顺印可爱慕爱慕性心证心净。是名法证净。若能于此劝励安立。当知是名方便劝励安立令住法证净中

云何僧证净。如世尊言。此圣弟子。以如是相。随念于僧。谓佛弟子。具足妙行质直行如理行法随法行和敬行随法行。于此僧中。有预流向。有预流果。有一来向。有一来果。有不还向。有不还果。有阿罗汉向。有阿罗汉果。如是总有四双八只补特伽罗。佛弟子众。戒具足。定具足。慧具足。解脱具足。解脱智见具足。应请应屈应恭敬无上福田世所应供。所言此者。谓此欲界。或此世界。此赡部洲。又言此者。谓即此身持等持躯等躯聚得自体。又言此者。谓此处生。佛及弟子。诸仙牟尼。诸聪睿者。善调伏者。善调顺者。又言此者。谓即于此教授教诫善说法中。是故言此。言圣弟子者。圣谓佛法僧。归依佛法僧故名圣弟子。以如是相随念僧者。谓以此相此门此理。于诸僧所。起念随念。专念忆念。不忘不失。不遗不漏。不失法性心明记性。是故名为以如是相随念于僧。言妙行者。谓世尊说有四种行。一苦迟通行。二苦速通行。三乐迟通行。四乐速通行。佛弟子众。于此中行。故名妙行。又世尊说有四种行。一不安隐行。二安隐行。三调伏行。四寂静行。佛弟子众。唯行后三。故名妙行。质直行者。谓八支圣道。名为质直。所以者何。以八支圣道不迂不曲不回质直平坦一趣。佛弟子众。于此中行。名质直行。如理行者。谓八支圣道。名为如理。佛弟子众。于此中行。名如理行。又世尊说四念住四正胜四神足五根五力七等觉支及正定并资并具。名为如理。如世尊言。此一趣道。令诸有情。皆得清净。超诸愁叹。灭诸忧苦。证如理法。谓圣正定并资并具七圣道支。名圣正定资之与具。何等为七。谓初正见。乃至正念。以圣正定。由七道支。引导修治。方得成满。故说名圣正定资具。佛弟子众。于此中行。名如理行。法随法行者。谓涅槃名法。八支圣道名随法。佛弟子众。于此中行。名法随法行。又别解脱名法别解脱律仪名随法。佛弟子众。于此中行。名法随法行。又身律仪语律仪命清净名法。受持此法名随法。佛弟子众。于此中行。名法随法行。和敬行者。谓佛弟子众。一戒一学。一说一别解脱。同戒同学。同说同别解脱。受具百岁。所应学处。初受具者。亦于中学。初受具者。所应学处。受具百岁。亦于中学。如受具百岁所应学法。初受具者。亦如是学。如初受具者所应学法。受具百岁。亦如是学。佛弟子众。能于此中。一戒性。一学性。一说性。一别解脱性。同戒性。同学性。同说性。同别解脱性。名和敬行。又佛弟子众。互相恭敬。互相推让。于长宿者。起迎合掌。慰问礼拜。表相和敬。佛弟子众。如是而行。名和敬行。随法行者。谓八支圣道。名为随法。佛弟子众。于中随顺游历涉行。名随法行

说一切有部法蕴足论卷第二阿毗达磨法蕴足论卷第三

        尊者大目干连造

        三藏法师玄奘奉　诏译

    证净品第三之余

于此僧中者。佛弟子众中。此即显聚显蕴显部显要略义。预流向者。已得无间道。能证预流果。谓此无间证预流果。彼于欲界贪欲嗔恚。由世间道。先未能断多分品类。于四圣谛。先未现观。今修现观。名预流向。预流果者。谓现法中。已于三结。永断遍知。谓有身见。戒禁取疑。彼住此断中。未能进求一来果证。名预流果。一来向者。已得无间道。能证一来果。谓此无间证一来果。彼于欲界贪欲嗔恚。由世间道。或先已断多分品类。于四圣谛。先未现观。今修现观。或住预流果已。能进求一来果证。名一来向。一来果者。谓现法中。已于三结。永断遍知。及断多分贪欲嗔恚。彼住此断中。未能进求不还果证。名一来果。不还向者。已得无间道。能证不还果。谓此无间证不还果。彼于欲界贪欲嗔恚。由世间道或先永断。于四圣谛。先未现观。今修现观。或住一来果已。能进求不还果证。名不还向。不还果者。谓现法中。于五顺下分结。已永断遍知。谓有身见。戒禁取疑。贪欲嗔恚。彼住此断中。未能进求阿罗汉果证。名不还果。阿罗汉向者。已得无间道。能证阿罗汉果。谓此无间证得最上阿罗汉果。或住不还果已。能进求阿罗汉果证。名阿罗汉向。阿罗汉果者。谓现法中。贪嗔痴等。一切烦恼。皆已永断名阿罗汉果言。四双补特伽罗者。谓预流向预流果。是第一双。一来向一来果。是第二双。不还向不还果。是第三双。阿罗汉向阿罗汉果。是第四双。八只补特伽罗者。谓显安立。预流向等补特伽罗。八种各别佛弟子众者。显示开晓佛弟子众具胜功德。戒具足者。谓学无学僧。成就具足学无学戒。定具足者。谓学无学僧。成就具足学无学定。慧具足者。谓学无学僧。成就具足学无学慧。解脱具足者。谓学无学僧。成就具足学无学解脱。解脱智见具足者。谓学无学僧。成就具足学无学解脱智见言应请者。谓应惠施应供养应祠祀。故言应请。言应屈者。谓已惠施。善惠施已供养。善供养已祠祀。善祠祀少作功劳。获大果利。故名应屈。应恭敬者。谓若识知。若不识知。皆应起迎曲躬合掌稽首接足。而赞问言。正至正行。得安乐不。名应恭敬。言无上者。如世尊告苾刍众言。一切和合部类众中。佛弟子众。最为第一。最尊最胜。最上无上。故名无上。言福田者。如世尊告阿难陀言。我不见有诸天魔梵沙门婆罗门等天人众中堪受已惠施善惠施已供养善供养已祠祀善祠祀如我僧者。阿难当知。若于我僧。已惠施。善惠施已供养。善供养已祠祀。善祠祀作少功劳。获大果利。又如天帝至鹫峰山。以妙伽他。赞问佛曰

  稽首能辩说　　到诸法彼岸
  超一切恐怖　　大乔答摩尊
  有无量众生　　乐福修布施
  恒发至诚信　　修诸有依福
  愿佛垂哀愍　　说真胜福田
  令无量众生　　少施获大果

世尊。哀愍诸众生故以妙伽他。告天帝曰

  若无量众生　　乐福修布施
  恒发至诚信　　修有依福者
  我今为汝等　　说真胜福田
  令无量众生　　少施获大果
  若行四圣向　　及住四圣果
  是应供真僧　　具胜戒定慧
  此真胜僧田　　功德甚广大
  能无量润益　　犹如四大海
  调御胜弟子　　已发法光明
  堪受胜供养　　及受胜祠祀
  于少僧行施　　即施一切僧
  必当获大果　　一切智称赞
  于诸福田中　　僧田最为胜
  诸佛所称叹　　施获最上福
  于佛弟子众　　少施获大果
  故诸聪慧人　　当供养僧众
  圣众持妙法　　具明行等持
  故于僧宝中　　行施最为上
  以三种净心　　施僧衣饮食
  必获殊胜报　　成人天善士
  定于生生中　　离尘垢毒箭
  超过诸恶趣　　受人天胜乐
  自正集珍财　　自手而行施
  为利自他故　　必获于大果
  诸有聪慧人　　净信心行施
  当生安乐界　　受妙乐聪明

由如是说。故名福田。世应供者。谓圣弟子。能净世间。应供器故。已行应供。清净道故。成就应供。三净业故。名世应供。若圣弟子。以如是相随念僧伽。见为根本证智相应诸信信性现前信性随顺印可。爱慕爱慕性心证心净。是名僧证净。若能于此劝励安立。当知是名方便劝励安立令住僧证净中

云何圣所爱戒。谓无漏身律仪语律仪命清净。是名圣所爱戒。何故名为圣所爱戒。谓诸佛及弟子名为圣。彼于此戒。爱慕欣喜。忍顺不逆。是故名为圣所爱戒。若能于此。劝励安立。当知是名方便劝励安立令住圣所爱戒中

    沙门果品第四

一时薄伽梵。在室罗筏。住逝多林给孤独园。尔时世尊。告苾刍众。有四沙门果。何等为四。谓预流果。一来果。不还果。阿罗汉果

云何预流果。谓预流果。略有二种。一者有为。二者无为。所言有为预流果者。谓彼果得。及彼得得。有学根力。有学尸罗。有学善根。八有学法。及彼种类诸有学法。是名有为预流果。所言无为预流果者。谓于此中。三结永断。及彼种类结法永断。即是八十八诸随眠永断。及彼种类结法永断。是名无为预流果

云何一来果。谓一来果。略有二种。一者有为。二者无为。所言有为一来果者。谓彼果得。及彼得得。有学根力有学尸罗。有学善根。八有学法。及彼种类诸有学法。是名有为一来果。所言无为一来果者。谓于此中。三结永断。及彼种类结法永断。即是八十八诸随眠永断。及彼种类结法永断。并贪嗔痴多分永断。及彼种类结法多分永断。是名无为一来果。云何不还果。谓不还果。略有二种。一者有为。二者无为。所言有为不还果者。谓彼果得。及彼得得。有学根力。有学尸罗。有学善根。八有学法。及彼种类诸有学法。是名有为不还果。所言无为不还果者。谓于此中。五顺下分结永断。及彼种类结法永断。即是九十二诸随眠永断。及彼种类结法永断。是名无为不还果。云何阿罗汉果。谓阿罗汉果。略有二种。一者有为。二者无为。所言有为阿罗汉果者。谓彼果得。及彼得得。无学根力。无学尸罗。无学善根。十无学法。及彼种类诸无学法。是名有为阿罗汉果。所言无为阿罗汉果者。谓于此中。贪嗔痴等。一切烦恼。皆已永断。超一切趣。断一切道。三火永静。渡四瀑流。憍逸永离。燋渴永息。窟宅永破。无上究竟。无上寂静无上爱尽。离灭涅槃。是名无为阿罗汉果

    通行品第五

一时薄伽梵。在室罗筏。住逝多林给孤独园。尔时世尊。告苾刍众。有四通行。何等为四。谓苦迟通行。苦速通行。乐迟通行。乐速通行。云何名为苦迟通行。如世尊说。诸有苾刍。由五取蕴。陵辱伤毁。彼因如是五种取蕴。逼切拘执。如扼重担。乃至命终。恒常随逐。便于如是五取蕴中。深生厌贱。呵毁拒逆。即于如是五取蕴中。所生厌贱。呵毁拒逆。此中名苦。由此便起昧钝羸劣信等五根。如是五根。昧故钝故。羸故劣故。能迟证得无上漏尽。此言迟者。非急非疾。非驶非易。非速证得。言无上者。如世尊说。于诸有为无为法中。我说离染。最为第一。最尊最胜。最上无上。于无上法。能得随得。能触等触。能证作证。故名证得。言漏尽者。漏谓三漏。欲有无明。于此三漏。能尽等尽。遍尽永尽。灭尽圆尽。故名漏尽。言通行者。谓即此行。超越勇猛。精进策励。生欲翘勤。于四圣谛。修现观行。于预流果一来不还阿罗汉果。修作证行。于贪嗔痴慢憍垢等。修永尽行。以极恭敬安住殷重思惟。遍摄诸心所已。因故门故。理故相故。修通达行。是故名为苦迟通行。又如是行。于所求义。由修习多修习。能得随得。能触等触。能证作证。是故名为苦迟通行。又如是行。由语增语。由想等想。施设言说。为苦迟通行。是故名为苦迟通行。云何名为苦速通行。如世尊说。诸有苾刍。由五取蕴。陵辱伤毁。彼因如是五种取蕴逼切拘执。如扼重担。乃至命终。恒常随逐。便于如是五取蕴中。深生厌贱。呵毁拒逆。即于如是五取蕴中。所生厌贱。呵毁拒逆。此中名苦。由此便起明利强盛信等五根。如是五根。明故利故强故盛故。能速证得无上漏尽。此言速者。能急能疾能驶能易能速证得。言无上者。如世尊说。于诸有为无为法中。我说离染。最为第一。最尊最胜。最上无上。于无上法能得随得。能触等触。能证作证。故名证得。言漏尽者。漏谓三漏。于此三漏。能尽等尽遍尽永尽灭尽圆尽故名漏尽。言通行者。谓即此行。超越勇猛。精进策励。生欲翘勤。于四圣谛。修现观行。于预流果一来不还阿罗汉果。修作证行。于贪嗔痴慢憍垢等。修永尽行。以极恭敬安住殷重思惟。遍摄诸心所已。因故门故理故相故。修通达行。是故名为苦速通行。又如是行。于所求义由修习多修习。能得随得。能触等触。能证作证。是故名为苦速通行。又如是行。由语增语。由想等想施设言说。为苦速通行。是故名为苦速通行

云何名为乐迟通行。如世尊说。诸有苾刍。离欲恶不善法。有寻有伺。离生喜乐。于初静虑。具足安住。寻伺止息。内等净心一趣。无寻无伺。定生喜乐。于第二静虑。具足安住。离喜住舍。正念正知。身受乐圣所说。具舍念安乐住。于第三静虑。具足安住。断乐断苦。先喜忧没。不苦不乐。舍念清净。于第四静虑。具足安住。彼于尔时。非思自害。非思害他。非思俱害。能思自利。能思利他。能利多生。能乐多生。能愍世间。能义利乐。诸天人众。诸无害等。此中名乐。由此便起昧钝羸劣信等五根。如是五根。昧故钝故羸故劣故。能迟证得无上漏尽。此言迟者。非急非疾。非驶非易。非速证得。言无上者。如世尊说。于诸有为无为法中。我说离染。最为第一最尊最胜最上无上。于无上法。能得随得。能触等触。能证作证。故名证得。言漏尽者。漏谓三漏。于此三漏。能尽等尽。遍尽永尽。灭尽圆尽。故名漏尽。言通行者。谓即此行。超越勇猛。精进策励。生欲翘勤。于四圣谛。修现观行。于不还果阿罗汉果。修作证行。于神境智作证通。及天耳智作证通。心差别智作证通。宿住随念智作证通。死生智作证通。漏尽智作证通修作证行。于贪嗔痴慢憍垢等。修永尽行。以极恭敬安住殷重思惟。遍摄诸心所已。因故门故。理故相故。修通达行。是故名为乐迟通行。又如是行。于所求义。由修习多修习。能得随得。能触等触。能证作证。是故名为乐迟通行。又如是行。由语增语。由想等想。施设言说。为乐迟通行。是故名为乐迟通行

云何名为乐速通行。如世尊说。诸有苾刍。离欲恶不善法。广说乃至于第四静虑。具足安住。彼于尔时。非思自害。非思害他。非思俱害。能思自利。能思利他。能利多生。能乐多生。能愍世间。能义利乐。诸天人众。诸无害等。此中名乐。由此便起。明利强盛信等五根。如是五根。明故利故。强故盛故。能速证得无上漏尽。此言速者。能急能疾。能驶能易。能速证得。言无上者。如世尊说。于诸有为无为法中。我说离染。最为第一。最尊最胜。最上无上。于无上法。能得随得。能触等触。能证作证。故名证得。言漏尽者。漏谓三漏。于此三漏。能尽等尽遍尽永尽。灭尽圆尽。言通行者。谓即此行。超越勇猛。精进策励。生欲翘勤。于四圣谛。修现观行。于不还果阿罗汉果。修作证行。于神境智作证通。及天耳智作证通。心差别智作证通。宿住随念智作证通。死生智作证通。漏尽智作证通。修作证行。于贪嗔痴慢憍垢等。修永尽行。以极恭敬安住殷重思惟。遍摄诸心所已。因故门故。理故相故。修通达行。是故名为乐速通行。又如是行。于所求义。由修习多修习。能得随得。能触等触。能证作证。是故名为乐速通行。又如是行。由语增语。由想等想。施设言说。为乐速通行。是故名为乐速通行

此中若于苦迟通行。修习多修习。能令苦速通行。速得圆满。若于乐迟通行。修习多修习。能令乐速通行。速得圆满。又若于彼苦迟通行。修习多修习。能令乐迟通行。速得圆满。若于苦速通行。修习多修习。能令乐速通行。速得圆满

    圣种品第六

一时薄伽梵。在室罗筏。住逝多林给孤独园。尔时世尊。告苾刍众。有四圣种。是最胜。是种姓。是可乐。现无杂秽。曾无杂秽。当无杂秽。一切沙门。或婆罗门。或天魔梵。或余世间。无能以法而讥毁者。何等为四。谓我多闻贤圣弟子。随得衣服。便生喜足。赞叹喜足。不为求觅衣服因缘。令诸世间而生讥论。若求不得。终不懊叹。引颈悕望。拊胸迷闷。若求得已。如法受用。不生染着。耽嗜迷闷。藏护贮积。于受用时。能见过患。正知出离。彼由随得衣服喜足。终不自举陵蔑于他。而能策勤。正知系念。是名安住古昔圣种。如是弟子。随得饮食。便生喜足。广说如前。如是弟子。随得卧具。便生喜足。广说如前。如是弟子。爱断乐断。精勤随学。于断爱乐。爱修乐修。精勤随学。于修爱乐。彼由如是断修爱乐终不自举陵蔑于他。而能策勤。正知系念。是名安住古昔圣种。谓我多闻贤圣弟子。成就如是四圣种者。若依东西南北方住。不乐居彼。而彼乐居。于乐不乐。俱能含忍。尔时世尊。为摄前义。而说颂曰

  勇不乐居彼　　而彼乐勇居
  于乐不乐中　　勇者俱含忍
  既弃舍诸欲　　无物能拘碍
  如赡部真金　　谁复应讥毁

有四圣种是最胜者。谓四圣种。是一切佛。及诸弟子。共所施设。为最胜故。是种姓者。谓四圣种。是一切佛。及诸弟子古昔不共家种姓故。是可乐者。谓四圣种。是一切佛。及诸弟子。久远已来。昼夜等时。可乐法故。现无杂秽者。谓四圣种不为现在恶不善法。亲近涂染。性不杂彼。能远离故。曾无杂秽者。谓四圣种。不为过去。恶不善法。亲近涂染性不杂彼。能远离故。当无杂秽者。谓四圣种。不为未来恶不善法。亲近涂染。性不杂彼。能远离故诸沙门等。无能以法而讥毁者。谓四圣种。非一切佛及诸弟子。或诸贤贵。或诸善士。而能讥毁。谓此圣种。是不善法。是下贱者。信解受持。能为自害。能为他害。能为俱害。能灭智慧。能碍彼类。能障涅槃。受持此法。不生通慧。不引菩提。不证涅槃。圣种非彼讥毁法故。随得衣服。便生喜足者。谓随所得粪扫衣服。或随所得施主衣服。若好若恶。便生喜足。取得蔽身。障寒等故。赞叹喜足者。谓数赞叹。于随所得衣服喜足。谓此喜足。能引长夜。少欲喜足。易满易养。损减诸恶。增长诸善。能速圆满。杜多功德。于诸资具。能善知量。能令自他。身心严净。数赞叹者。非数发言。但有此见。随缘而说。令他钦重此喜足故。非为求觅衣服因缘。令诸世间生讥论者。谓佛弟子。非如一类。为求衣服往施主家。诈现威仪。矫设言论。现相研磨。以利求利。令诸世间多生讥论。诸佛弟子。与彼相违故。不令他生诸讥论。若求不得终不懊叹等者。谓佛弟子。求觅衣食。不遂意时。终不懊叹。引颈悕望。拊胸迷闷。懊谓心热等热遍热。内愤燋惶。愁忧悔恨。如箭入心。不能自处。烦冤恳切。总名为懊。叹谓如是心热恼已。作是思惟。我无衣服。当设何等方略自济。因斯发起种种语言。述所思惟。总名为叹。引颈悕望者。谓懊叹已。复引颈悕望施主回意。拊胸迷闷者。谓久待不得。绝所悕望。拊胸迷闷。诸佛弟子。皆无是事。若求得已。如法受用。不生染着等者。谓佛弟子。求得衣服。如法受用。心无染着。耽嗜迷闷。藏护贮积。染着等言。皆显贪爱。前后轻重。分位差别。于受用时。能见过患。正知出离者。谓佛弟子。受用所得。诸衣服时。能见过患。谓此衣服。无常转动。求时劳倦。受用非理。生长疾病。是失坏法。是增减法。暂得还失。迅速不停。本无今有。有已还无。不可保信。又受用时。正知出离。成就趣向。出离慧故。为趣涅槃。受用衣服。又受用时。先调贪欲。次断贪欲。后出贪欲。由此因缘。心于衣服。离染解脱。彼由随得衣服喜足。终不自举陵蔑他者。谓佛弟子。虽于所得衣服喜足。而不自举陵蔑于他。非如一类由此喜足而自憍举。作是念言。我有如是少欲喜足少事少务少所作少顾恋。易满易养。损减诸恶。增长诸善。能速圆满。杜多功德。于诸资具。能善知量。能善为他赞叹喜足。非如一类由此喜足陵蔑于他。作是念言。余苾刍等。皆无如是少欲喜足少事少务。广说乃至能善为他赞叹喜足。诸佛弟子。皆无是事。而能策勤。正知系念者。谓佛弟子。于随所得衣服喜足。如法受用不生染着。能见过患。正知出离。不自憍举。不陵蔑他。复能策勤。正知系念。言策勤者。显正精进。正知者。显正见。系念者。显正念。此略显示三种道支。是名安住。古昔圣种者。初是名言。显佛弟子。成就前说调善意乐。后古昔圣种言。显去来今。一切贤圣。皆于如是圣种修习及多修习。方至究竟。中安住言。显佛弟子。于随所得衣服喜足。增上所生善有漏道及无漏道。安住等住遍住近住。如是弟子。随得饮食。便生喜足者。谓佛多闻贤圣弟子。于随乞丐所得饮食。或随迎请。所得饮食。若好若恶。便生喜足。取得支身。除饥渴故。广说如前者。赞叹喜足等。广说如前。于随所得衣服喜足。如是弟子。随得卧具。便生喜足者。谓佛多闻贤圣弟子。于随所得树下卧具。或随所得房阁卧具。若好若恶。便生喜足。取得资身。除劳倦故。广说如前者。赞叹喜足等。广说如前。于随所得衣服喜足。如是弟子爱断等者。谓佛多闻贤圣弟子。爱断爱修。乐断乐修。精勤随学。断修爱乐。云何爱断爱修。谓若未断恶不善法。未修善法。彼于断修。无爱无胜爱。有引颈悕望。若有已断恶不善法已修善法。彼于断修。有爱有胜爱。无引颈悕望。云何乐断乐修。谓于断修。有乐有胜乐。云何精勤随学。断修爱乐。谓于断修爱乐。为增上故。精勤随学。彼由如是断修爱乐。终不自举陵蔑他者。谓佛弟子。虽于断修爱乐精勤随学。而不自举陵蔑于他。非如一类由此爱乐而自憍举。作是念言。我有如是少欲喜足。少事少务。少所作少顾恋。易满易养。损减诸恶。增长诸善。爱断爱修。乐断乐修。精勤随学。断修爱乐。非如一类由此爱乐陵蔑于他。作是念言。余苾刍等。皆无如是少欲喜足少事少务。广说乃至。爱断爱修。乐断乐修。精勤随学。断修爱乐。诸佛弟子。皆无是事。而能策勤。正知系念。是名安住。古昔圣种。广释如前。有差别者。中安住言。显佛弟子。于断修爱乐。增上所生善有漏道及无漏道。安住等住。遍住近住

    正胜品第七之一

一时薄伽梵。在室罗筏。住逝多林给孤独园。尔时世尊。告苾刍众。有四正胜。何等为四。谓有苾刍。为令已生恶不善法断故。起欲发勤精进。策心持心。是名第一。为令未生恶不善法不生故。起欲发勤精进。策心持心。是名第二。为令未生善法生故。起欲发勤精进。策心持心。是名第三。为令已生善法坚住不忘修满倍增。广大智作证故。起欲发勤精进。策心持心。是名第四。尔时世尊。为摄前义。而说颂曰

  初修正胜时　　已胜生死有
  若修至彼岸　　能摧灭魔军
  离尘垢诸德　　非恶缘所退
  到彼岸涅槃　　证无余极乐

为令已生恶不善法断故。起欲发勤精进。策心持心者。云何已生恶不善法。谓过去现在五盖。一贪欲盖。二嗔恚盖。三惛沉睡眠盖。四掉举恶作盖。五疑盖云何为令已生恶不善法断故正胜。谓有苾刍。为断已生贪欲盖故。如理思惟。彼贪欲盖。多诸过患。谓是不善法。是下贱者。信解受持。佛及弟子。贤贵善士。共所诃厌。能为自害。能为他害。能为俱害。能灭智慧。能碍彼类。能障涅槃。受持彼法。不生通慧。不引菩提。不证涅槃。如是思惟。发勤精进。勇健势猛。炽盛难制。励意不息。此道名为能令已生诸贪欲盖。永断正胜。彼于此道生已。修习多修习故。便断已生诸贪欲盖。起欲者。谓为断已生贪欲盖故。便起等起。及生等生。聚集出现。欲乐欣喜。求趣悕望。彼由生起此诸欲故。便断已生诸贪欲盖。发勤精进者。谓为断已生贪欲盖故。发勤精进。广说乃至。励意不息。彼由此故。便断已生诸贪欲盖。策心者。谓为断已生贪欲盖故。精勤修习。喜俱行心。欣俱行心。策励俱行心。不下劣俱行心。不闇昧俱行心。舍俱行心。定俱行心。彼由修习如是心故。便断已生诸贪欲盖。持心者。谓为断已生贪欲盖故。持心修习八支圣道。所谓正见。乃至正定。彼于此道。持心修习多修习故。便断已生诸贪欲盖。复有苾刍。为断已生贪欲盖故。如理思惟出家功德。如是出家。是真善法。是尊胜者。信解受持。佛及弟子。贤贵善士。共所欣赞。不为自害。不为他害。不为俱害。增长智慧。不碍彼类。不障涅槃。能生通慧。能引菩提。能证涅槃。如是思惟。发勤精进。广说乃至。励意不息此道名为能令已生。诸贪欲盖。永断正胜。彼于此道。生已修习多修习故。便断已生诸贪欲盖。起欲乃至策心持心。皆如前说。复有苾刍。为断已生贪欲盖故。如理思惟彼贪欲盖。如病如痈。如箭恼害。无常苦空非我转动。劳倦羸笃。是失坏法。迅速不停。衰朽非恒。不可保信。是变坏法。如是思惟。发勤精进。广说乃至。励意不息。此道名为能令已生诸贪欲盖。永断正胜。彼于此道。生已修习多修习故。便断已生诸贪欲盖。起欲乃至策心持心。皆如前说。复有苾刍。为断已生诸贪欲盖。如理思惟。灭为寂静。道能出离。如是思惟。发勤精进。广说乃至。励意不息。此道名为能令已生诸贪欲盖。永断正胜。彼于此道。生已修习多修习故。便断已生诸贪欲盖。起欲乃至策心持心。皆如前说。如贪欲盖。余四亦尔。有差别者。应说自名。复有苾刍。为断已生随一种类恶不善法。如理思惟。彼恶不善法。多诸过患。谓是不善法。是下贱者。信解受持。广说乃至不证涅槃。如是思惟。发勤精进。广说乃至。励意不息。此道名为能令已生随一种类恶不善法。永断正胜。彼于此道。生已修习多修习故。便断随一种类已生恶不善法。起欲者。谓为断已生随一种类恶不善法。便起等起。广说乃至。求趣悕望。彼由生起此诸欲故。便断随一种类已生恶不善法。发勤精进者。谓为断已生随一种类恶不善法。发勤精进。广说乃至。励意不息。彼由此故。便断随一种类已生恶不善法。策心者。谓为断已生随一种类恶不善法。精勤修习。喜俱行心。广说乃至。定俱行心。彼由修习如是心故。便断随一种类已生恶不善法。持心者。谓为断已生随一种类恶不善法。持心修习八支圣道。彼于此道。持心修习多修习故。便断随一种类已生恶不善法。复有苾刍。为断已生随一种类恶不善法。如理思惟出家功德。如是出家。是真善法。是尊胜者。信解受持。广说乃至。能证涅槃。如是思惟。发勤精进。广说乃至。励意不息。此道名为能令已生随一种类恶不善法。永断正胜。彼于此道。生已修习多修习故。便断随一种类已生恶不善法。起欲乃至策心持心。皆如前说。复有苾刍。为断已生随一种类恶不善法。如理思惟。彼恶不善法。如病如痈。广说乃至。是变坏法。如是思惟。发勤精进。广说乃至。励意不息。此道名为能令已生随一种类恶不善法永断正胜。彼于此道。生已修习多修习故。便断随一种类已生恶不善法。起欲乃至策心持心。皆如前说。复有苾刍。为断已生随一种类恶不善法。如理思惟。灭为寂静。道能出离。如是思惟。发勤精进。广说乃至。励意不息。此道名为能令已生随一种类恶不善法永断正胜。彼于此道。生已修习多修习故。便断随一种类已生恶不善法。起欲乃至策心持心。皆如前说

说一切有部法蕴足论卷第三阿毗达磨法蕴足论卷第四

        尊者大目干连造

        三藏法师玄奘奉　诏译

    正胜品第七之余

为令未生恶不善法不生故。起欲发勤精进策心持心者。云何未生恶不善法。谓未来五盖。云何为令未生恶不善法不生故正胜。谓有苾刍。为令未生诸贪欲盖永不生故。如理思惟。彼贪欲盖多诸过患。谓是不善法。是下贱者。信解受持。佛及弟子。贤贵善士。共所诃厌。能为自害。能为他害。能为俱害。能灭智慧。能碍彼类。能障寂灭。受持彼法。不生通慧。不引菩提。不证涅槃。如是思惟。发勤精进。勇健势猛。炽盛难制。励意不息。此道名为能令未生诸贪欲盖。不生正胜。彼于此道。生已修习多修习故。便令未生诸贪欲盖永不复生。起欲者。谓为令未生诸贪欲盖永不生故。便起等起及生等生。聚集出现。欲乐欣喜。求趣悕望。彼由生起此诸欲故。便令未生诸贪欲盖永不复生。发勤精进者。谓为令未生诸贪欲盖永不生故。发勤精进。广说乃至。励意不息。彼由此故。便令未生诸贪欲盖永不复生。策心者。谓为令未生诸贪欲盖永不生故。精勤修习。喜俱行心。欣俱行心。策励俱行心。不下劣俱行心。不闇昧俱行心。舍俱行心。定俱行心。彼由修习如是心故。便令未生诸贪欲盖永不复生。持心者。谓为令未生诸贪欲盖永不生故。持心修习八支圣道。彼于此道。持心修习多修习故。便令未生诸贪欲盖永不复生。复有苾刍。为令未生诸贪欲盖永不生故。如理思惟。出家功德。如是出家。是真善法。是尊胜者。信解受持。广说乃至。能证涅槃。如是思惟。发勤精进。广说乃至。励意不息。此道名为能令未生诸贪欲盖不生正胜。彼于此道。生已修习多修习故。便令未生诸贪欲盖永不复生。起欲乃至策心持心。皆如前说。复有苾刍。为令未生诸贪欲盖永不生故。如理思惟。彼贪欲盖。如病如痈。广说乃至。是变坏法。如是思惟。发勤精进。广说乃至。励意不息。此道名为能令未生诸贪欲盖不生正胜。彼于此道。生已修习多修习故。便令未生诸贪欲盖永不复生。起欲乃至策心持心。皆如前说。复有苾刍。为令未生诸贪欲盖永不生故。如理思惟。灭为寂静。道能出离。如是思惟。发勤精进。广说乃至。励意不息。此道名为能令未生诸贪欲盖不生正胜。彼于此道。生已修习多修习故。便令未生诸贪欲盖永不复生。起欲乃至策心持心。皆如前说。如贪欲盖。余四亦尔。有差别者。应说自名。复有苾刍。为令未生随一种类恶不善法永不生故。如理思惟。彼恶不善法。多诸过患。谓是不善法。是下贱者。信解受持。广说乃至不证涅槃。如是思惟。发勤精进。广说乃至励意不息。此道名为能令未生随一种类恶不善法不生正胜。彼于此道。生已修习多修习故。便令未生随一种类恶不善法永不复生起欲者。谓为令未生随一种类恶不善法永不生故。便起等起。广说乃至求趣悕望。彼由生起此诸欲故。便令未生随一种类恶不善法永不复生。发勤精进者。谓为令未生随一种类恶不善法永不生故。发勤精进。广说乃至。励意不息。彼由此故。便令未生随一种类恶不善法永不复生策心者。谓为令未生随一种类恶不善法永不生故。精勤修习。喜俱行心。广说乃至。定俱行心。彼由修习如是心故。便令未生随一种类恶不善法永不复生。持心者。谓为令未生随一种类恶不善法永不生故。持心修习八支圣道。彼于此道。持心修习多修习故。便令未生随一种类恶不善法永不复生。复有苾刍。为令未生随一种类恶不善法永不生故。如理思惟出家功德。如是出家。是真善法。是尊胜者。信解受持。广说乃至。能证涅槃。如是思惟。发勤精进。广说乃至。励意不息。此道名为能令未生随一种类恶不善法不生正胜。彼于此道。生已修习多修习故。便令未生随一种类恶不善法永不复生。起欲乃至策心持心。皆如前说。复有苾刍。为令未生随一种类恶不善法永不生故。如理思惟。彼恶不善法。如病如痈。广说乃至。是变坏法。如是思惟。发勤精进。广说乃至。励意不息。此道名为能令未生随一种类恶不善法不生正胜。彼于此道。生已修习多修习故。便令未生随一种类恶不善法永不复生。起欲乃至策心持心。皆如前说。复有苾刍。为令未生随一种类恶不善法永不生故。如理思惟。灭为寂静。道能出离。如是思惟。发勤精进。广说乃至。励意不息。此道名为能令未生随一种类恶不善法不生正胜。彼于此道。生已修习多修习故。便令未生随一种类恶不善法永不复生。起欲乃至策心持心。皆如前说

为令未生善法生故。起欲发勤精进策心持心者。云何未生善法。谓未来四静虑三无色。及余随一种类出家远离所生善法。云何为令未生善法生故正胜。谓有苾刍。为生未生初静虑故。如理思惟。生初静虑。诸行相状。如是思惟。发勤精进。勇健势猛。炽盛难制。励意不息。此道名为能生未生初静虑正胜。彼于此道。生已修习多修习故。便令未生初静虑生。起欲者。谓为生未生初静虑故。便起等起。及生等生。聚集出现欲。乐欣喜。求趣悕望。彼由生起此诸欲故。便令未生初静虑生。发勤精进者。谓为生未生初静虑故。发勤精进。广说乃至。励意不息。彼由此故。便令未生初静虑生。策心者。谓为生未生初静虑故。精勤修习喜俱行心。欣俱行心。策励俱行心。不下劣俱行心。不闇昧俱行心。舍俱行心。定俱行心。彼由修习如是心故。便令未生初静虑生。持心者。谓为生未生初静虑故。持心修习八支圣道。彼于此道。持心修习多修习故。便令未生初静虑生。如初静虑第二静虑亦尔。有差别者。应说自名。复有苾刍。为生未生第三静虑故。如理思惟。生第三静虑。诸行相状。如是思惟。发勤精进。广说乃至。励意不息。此道名为能生未生第三静虑正胜。彼于此道。生已修习多修习故。便生未生第三静虑。起欲者。谓为生未生第三静虑故。便起等起。广说乃至。求趣悕望。彼由生起此诸欲故。便生未生第三静虑。发勤精进者。谓为生未生第三静虑故。发勤精进广说乃至。励意不息。彼由此故。便生未生第三静虑。策心者。谓为生未生第三静虑故。精勤修习。喜俱行心。广说乃至。定俱行心。彼由修习如是心故。便生未生第三静虑。持心者。谓为生未生第三静虑故。持心修习八支圣道。彼于此道。持心修习多修习故。便生未生第三静虑。如第三静虑。乃至无所有处。广说亦尔。有差别者。应说自名。复有苾刍。为生未生随一种类出家远离所生善法故。如理思惟。生彼善法诸行相状。如是思惟。发勤精进。广说乃至。励意不息。此道名为能生未生随一种类出家远离所生善法正胜。彼于此道。生已修习多修习故。便生未生随一种类出家远离所生善法。起欲者。谓为生未生随一种类出家远离所生善法故。便起等起。广说乃至。求趣悕望。彼由生起此诸欲故。便生未生随一种类出家远离所生善法。发勤精进者。谓为生未生随一种类出家远离所生善法故。发勤精进。广说乃至。励意不息。彼由此故。便生未生随一种类出家远离所生善法。策心者。谓为生未生随一种类出家远离所生善法故。精勤修习。喜俱行心广说乃至。定俱行心。彼由修习如是心故。便生未生随一种类出家远离所生善法。持心者。谓为生未生随一种类出家远离所生善法故。持心修习八支圣道。彼于此道。持心修习多修习故。便生未生随一种类出家远离所生善法。为令已生善法坚住不忘修。满倍增广。大智作证故。起欲发勤精进策心持心者。云何已生善法。谓过去现在。四静虑三无色。及余随一种类出家远离所生善法。云何为令已生善法坚住不忘修满倍增广大。智作证故正胜。谓有苾刍。为令已生初静虑坚住乃至智作证故。如理思惟。能令已生初静虑坚住乃至智作证诸行相状。如是思惟。发勤精进。勇健势猛。炽盛难制。励意不息。此道名为能令已生初静虑坚住乃至智作证正胜。彼于此道。生已修习多修习故。便令已生初静虑坚住乃至智作证。起欲者。谓为令已生初静虑坚住乃至智作证故。便起等起。及生等生。聚集出现。欲乐欣喜。求趣悕望。彼由生起此诸欲故。便令已生初静虑坚住乃至智作证。发勤精进者。谓为令已生初静虑坚住乃至智作证故。发勤精进。广说乃至。励意不息。彼由此故便令已生初静虑坚住乃至智作证策心者。谓为令已生初静虑坚住乃至智作证故。精勤修习。喜俱行心。欣俱行心。策励俱行心。不下劣俱行心。不闇昧俱行心。舍俱行心。定俱行心。彼由修习如是心故。便令已生初静虑坚住乃至智作证。持心者。谓为令已生初静虑坚住乃至智作证故。持心修习八支圣道。彼于此道。持心修习多修习故。便令已生初静虑坚住乃至智作证。如初静虑。第二静虑亦尔。有差别者。应说自名。复有苾刍。为令已生第三静虑坚住乃至智作证故。如理思惟。能令已生第三静虑坚住乃至智作证诸行相状。如是思惟发勤精进。广说乃至。励意不息此道名为能令已生第三静虑坚住乃至智作证正胜。彼于此道。生已修习多修习故。便令已生第三静虑坚住乃至智作证。起欲者。谓为令已生第三静虑坚住乃至智作证故。便起等起。广说乃至。求趣悕望。彼由生起此诸欲故。便令已生第三静虑坚住乃至智作证。发勤精进者。谓为令已生第三静虑坚住乃至智作证故。发勤精进。广说乃至。励意不息。彼由此故。便令已生第三静虑坚住乃至智作证。策心者。谓为令已生第三静虑坚住乃至智作证故。精勤修习。喜俱行心。广说乃至。定俱行心。彼由修习如是心故。便令已生第三静虑坚住乃至智作证。持心者。谓为令已生第三静虑坚住乃至智作证故。持心修习八支圣道。彼于此道。持心修习多修习故。便令已生第三静虑坚住乃至智作证。如第三静虑。乃至无所有处。广说亦尔。有差别者。应说自名。复有苾刍。为令已生随一种类出家远离所生善法坚住不忘修满倍增广大智作证故。如理思惟。能令已生随一种类出家远离所生善法坚住乃至智作证诸行相状。如是思惟。发勤精进。广说乃至。励意不息。此道名为能令已生随一种类出家远离所生善法坚住乃至智作证正胜。彼于此道。生已修习多修习故。便令已生随一种类出家远离所生善法坚住乃至智作证。起欲者。谓为令已生随一种类出家远离所生善法坚住乃至智作证故。便起等起。广说乃至。求趣悕望。彼由生起此诸欲故。便令已生随一种类出家远离所生善法坚住乃至智作证。发勤精进者。谓为令已生随一种类出家远离所生善法坚住乃至智作证故。发勤精进。广说乃至。励意不息。彼由此故。便令已生随一种类出家远离所生善法坚住乃至智作证。策心者。谓为令已生随一种类出家远离所生善法坚住乃至智作证故。精勤修习。喜俱行心。广说乃至。定俱行心。彼由修习如是心故。便令已生随一种类出家远离所生善法坚住乃至智作证。持心者。谓为令已生随一种类出家远离所生善法坚住乃至智作证故。持心修习八支圣道。彼于此道持心修习多修习故。便令已生随一种类出家远离所生善法坚住乃至智作证。云何此四名为正胜。谓此四种。无颠倒故。说名为正。有增上力。断恶修善。故名为胜。复次此四。平等非不平等。实故谛故。如正理故。无颠倒故。说名为正。增故上故。最故妙故。具大功能。故名为胜。复次四正胜者。是假建立名想言说。谓为正胜过殑伽沙佛及弟子。皆共施设如是名故。复次四正胜者。为断已生恶不善法。生起诸欲。发勤精进。策心持心。为令未生恶不善法得不生故。生起诸欲。发勤精进。策心持心。为生未生诸善法故。生起诸欲。发勤精进。策心持心。为令已生善法坚住不忘修满倍增广大智作证故。生起诸欲。发勤精进。策心持心。具如是能。故名正胜。亦名正断。断懈怠故

    神足品第八之一

一时薄伽梵。在室罗筏。住逝多林给孤独园。尔时世尊。告苾刍众。有四神足。何等为四。谓欲三摩地胜行成就神足。是名第一。勤三摩地胜行成就神足。是名第二。心三摩地胜行成就神足。是名第三。观三摩地胜行成就神足。是名第四。欲三摩地胜行成就神足者。云何欲。云何三摩地。云何胜。云何胜行而名欲三摩地胜行成就神足耶。此中欲者。谓依出家远离所生善法所起。欲乐欣喜。求趣悕望。是名欲。三摩地者。谓欲增上所起。心住等住。近住安住。不散不乱。摄止等持心一境性。是名三摩地。胜者。谓欲增上所起八支圣道。是名胜。胜行者。谓有苾刍。依过去欲得三摩地。是谓欲三摩地。彼成就欲三摩地已。为令已生恶不善法断故。起欲发勤精进。策心持心。为令未生恶不善法不生故。起欲发勤精进。策心持心。为令未生善法生故。起欲发勤精进。策心持心。为令已生善法坚住不忘修满倍增广大智作证故。起欲发勤精进。策心持心。彼所有欲若勤若信若轻安若念若正知若思若舍。是名胜行。即此胜行。及前所说欲三摩地。总名欲三摩地胜行成就神足。如依过去欲。依未来现在。善不善无记。欲界系。色界系。无色界系。学无学。非学非无学。见所断修所断。非所断欲广说亦尔。复有苾刍。于诸善法。住不乐欲。彼作是念。我今不应于诸善法住不乐欲。然我理应于诸善法安住乐欲。彼由此欲增上力故。得三摩地。是谓欲三摩地。彼成就欲三摩地已。为令已生恶不善法断故。起欲广说乃至。为令已生善法坚住。乃至持心。彼所有欲若勤若信乃至若舍是名胜行。即此胜行。及前所说欲三摩地。总名欲三摩地胜行成就神足。复有苾刍。生起恶欲。彼作是念。我今不应生起恶欲。然我理应断除恶欲修集善欲彼由此欲增上力故。得三摩地。是谓欲三摩地。彼成就欲三摩地已。为令已生恶不善法断故。起欲广说乃至。为令已生善法坚住。乃至持心。彼所有欲若勤若信乃至若舍。是名胜行。即此胜行。及前所说欲三摩地。总名欲三摩地胜行成就神足。复有苾刍。生起贪嗔痴俱行恶欲。彼作是念。我今不应生起贪嗔痴俱行恶欲。然我理应断除贪嗔痴俱行恶欲。修集无贪无嗔无痴俱行善欲。彼由此欲增上力故。得三摩地。是谓欲三摩地。彼成就欲三摩地已。为令已生恶不善法断故。起欲广说乃至。为令已生善法坚住。乃至持心。彼所有欲若勤若信乃至若舍。是名胜行。即此胜行。及前所说欲三摩地。总名欲三摩地胜行成就神足。复有苾刍。生起不离贪嗔痴恶欲。彼作是念。我今不应生起不离贪嗔痴恶欲。然我理应断除不离贪嗔痴恶欲。修集离贪嗔痴善欲。彼由此欲增上力故。得三摩地。是谓欲三摩地。彼成就欲三摩地已。为令已生恶不善法断故。起欲广说乃至。为令已生善法坚住。乃至持心。彼所有欲若勤若信乃至若舍。是名胜行。即此胜行。及前所说欲三摩地。总名欲三摩地胜行成就神足。复有苾刍。于诸善法安住乐欲。彼作是念。我于善法安住乐欲。甚为应理。彼由此欲增上力故。得三摩地。是谓欲三摩地。彼成就欲三摩地已。为令已生恶不善法断故。起欲广说乃至。为令已生善法坚住。乃至持心。彼所有欲若勤若信乃至若舍。是名胜行。即此胜行。及前所说欲三摩地。总名欲三摩地胜行成就神足。复有苾刍。生起善欲。彼作是念。我今生起如是善欲。甚为应理。彼由此欲增上力故。得三摩地。是谓欲三摩地。彼成就欲三摩地已。为令已生恶不善法断故。起欲广说乃至。为令已生善法坚住。乃至持心。彼所有欲若勤若信乃至若舍。是名胜行。即此胜行。及前所说欲三摩地。总名欲三摩地胜行成就神足。复有苾刍。生起无贪无嗔无痴俱行善欲。彼作是念。我今生起无贪无嗔无痴俱行善欲。甚为应理。彼由此欲增上力故。得三摩地。是谓欲三摩地。彼成就欲三摩地已。为令已生恶不善法断故。起欲广说乃至。为令已生善法坚住。乃至持心彼所有欲若勤若信乃至若舍。是名胜行。即此胜行。及前所说欲三摩地。总名欲三摩地胜行成就神足。复有苾刍。生起离贪嗔痴善欲。彼作是念。我今生起离贪嗔痴善欲。甚为应理。彼由此欲增上力故。得三摩地。是谓欲三摩地。彼成就欲三摩地已。为令已生恶不善法断故。起欲广说乃至。为令已生善法坚住。乃至持心。彼所有欲若勤若信乃至若舍。是名胜行。即此胜行。及前所说欲三摩地。总名欲三摩地胜行成就神足。一切欲三摩地。皆从欲起。是欲所集。是欲种类。是欲所生。故名欲三摩地胜行成就神足

勤三摩地胜行成就神足者。云何勤。云何三摩地。云何胜。云何胜行。而名勤三摩地胜行成就神足耶。此中勤者。谓依出家远离所生善法。所起勤精进。勇健势猛。炽盛难制。励意不息。是名勤。三摩地者。谓勤增上所起。心住等住。近住安住。不散不乱。摄止等持。心一境性。是名三摩地。胜者。谓勤增上所起八支圣道。是名胜。胜行者。谓有苾刍。依过去勤得三摩地。是谓勤三摩地。彼成就勤三摩地已。为令已生恶不善法断故。起欲广说乃至。为令已生善法坚住。乃至持心。彼所有欲若勤若信乃至。若舍。是名胜行。即此胜行。及前所说勤三摩地。总名勤三摩地胜行成就神足。如依过去勤。依未来现在。善不善无记。欲界系。色界系。无色界系。学无学。非学非无学。见所断修所断非所断勤。广说亦尔。复有苾刍。于诸善法住下羸劣弱极弱勤。彼作是念。我今不应于诸善法住下羸劣弱极弱勤。然我理应于诸善法。安住不下不羸不劣不弱不极弱勤。彼由此勤增上力故。得三摩地。是谓勤三摩地。彼成就勤三摩地已。为令已生恶不善法断故。起欲广说乃至。为令已生善法坚住乃至持心。彼所有欲若勤若信。乃至若舍。是名胜行。即此胜行。及前所说勤三摩地。总名勤三摩地胜行成就神足。复有苾刍。生起恶勤。彼作是念。我今不应生起恶勤。然我理应断除恶勤修集善勤。彼由此勤增上力故。得三摩地。是谓勤三摩地。彼成就勤三摩地已。为令已生恶不善法断故。起欲广说乃至。为令已生善法坚住。乃至持心。彼所有欲若勤若信。乃至若舍。是名胜行。即此胜行。及前所说勤三摩地。总名勤三摩地胜行成就神足。复有苾刍。生起贪嗔痴俱行恶勤。彼作是念。我今不应生起贪嗔痴俱行恶勤。然我理应断除贪嗔痴俱行恶勤。修集无贪无嗔无痴俱行善勤。彼由此勤增上力故。得三摩地。是谓勤三摩地。彼成就勤三摩地已。为令已生恶不善法断故。起欲广说乃至。为令已生善法坚住。乃至持心。彼所有欲若勤若信。乃至若舍。是名胜行。即此胜行。及前所说勤三摩地。总名勤三摩地胜行成就神足。复有苾刍。生起不离贪嗔痴恶勤。彼作是念。我今不应生起不离贪嗔痴恶勤。然我理应断除不离贪嗔痴恶勤。修集离贪嗔痴善勤。彼由此勤增上力故。得三摩地。是谓勤三摩地。彼成就勤三摩地已。为令已生恶不善法断故。起欲广说乃至。为令已生善法坚住。乃至持心。彼所有欲若勤若信。乃至若舍。是名胜行。即此胜行。及前所说勤三摩地。总名勤三摩地胜行成就。神足。复有苾刍。于诸善法安住不下乃至不极弱勤。彼作是念。我于善法。安住不下乃至不极弱勤甚为应理。彼由此勤增上力故。得三摩地。是谓勤三摩地。彼成就勤三摩地已。为令已生恶不善法断故。起欲广说乃至。为令已生善法。坚住。乃至持心。彼所有欲若勤若信。乃至若舍。是名胜行。即此胜行。及前所说勤三摩地。总名勤三摩地胜行成就神足。复有苾刍。生起善勤。彼作是念。我今生起如是善勤。甚为应理。彼由此勤增上力故。得三摩地。是谓勤三摩地。彼成就勤三摩地已。为令已生恶不善法断故。起欲广说乃至。为令已生善法坚住。乃至持心。彼所有欲若勤若信。乃至若舍。是名胜行。即此胜行。及前所说勤三摩地。总名勤三摩地胜行成就神足。复有苾刍。生起无贪无嗔无痴俱行善勤。彼作是念。我今生起无贪无嗔无痴俱行善勤。甚为应理。彼由此勤增上力故。得三摩地。是谓勤三摩地。彼成就勤三摩地已。为令已生恶不善法断故。起欲广说乃至。为令已生善法坚住。乃至持心。彼所有欲若勤若信。乃至若舍。是名胜行。即此胜行。及前所说勤三摩地。总名勤三摩地胜行成就神足。复有苾刍。生起离贪嗔痴善勤。彼作是念。我今生起离贪嗔痴善勤。甚为应理。彼由此勤增上力故。得三摩地。是谓勤三摩地。彼成就勤三摩地已。为令已生恶不善法断故。起欲广说乃至。为令已生善法坚住。乃至持心。彼所有欲。若勤若信乃至若舍。是名胜行。即此胜行。及前所说勤三摩地。总名勤三摩地胜行成就神足。一切勤三摩地。皆从勤起。是勤所集。是勤种类。是勤所生。故名勤三摩地胜行成就神足

说一切有部法蕴足论卷第四阿毗达磨法蕴足论卷第五

        尊者大目干连造

        三藏法师玄奘奉　诏译

    神足品第八之余

心三摩地胜行成就神足者。云何心。云何三摩地。云何胜。云何胜行。而名心三摩地胜行成就神足耶。此中心者。谓依出家远离所生善法。所起心意识。是名心。三摩地者。谓心增上所起。心住等住。近住安住。不散不乱。摄止等持。心一境性。是名三摩地。胜者。谓心增上所起八支圣道。是名胜。胜行者。谓有苾刍。依过去心得三摩地。是谓心三摩地。彼成就心三摩地已。为令已生恶不善法断故。起欲广说乃至。为令已生善法坚住。乃至持心。彼所有欲若勤若信。乃至若舍。是名胜行。即此胜行。及前所说心三摩地。总名心三摩地胜行成就神足。如依过去心。依未来现在善不善无记欲界系色界系无色界系学无学非学非无学见所断修所断非所断心。广说亦尔。复有苾刍。于诸善法住下羸劣弱极弱心。彼作是念。我今不应于诸善法住下羸劣弱极弱心然。我理应于诸善法安住不下不羸不劣不弱不极弱心。彼由此心增上力故。得三摩地。是谓心三摩地。彼成就心三摩地已。为令已生恶不善法断故。起欲广说乃至。为令已生善法坚住。乃至持心。彼所有欲若勤若信。乃至若舍。是名胜行。即此胜行。及前所说心三摩地。总名心三摩地胜行成就神足。复有苾刍。生起恶心。彼作是念。我今不应生起恶心。然我理应断除恶心修集善心。彼由此心增上力故。得三摩地。是谓心三摩地。彼成就心三摩地已。为令已生恶不善法断故。起欲广说乃至。为令已生善法坚住。乃至持心。彼所有欲若勤若信。乃至若舍。是名胜行。即此胜行。及前所说。心三摩地总名心三摩地胜行成就神足。复有苾刍。生起贪嗔痴俱行恶心。彼作是念。我今不应生起贪嗔痴俱行恶心。然我理应断除贪嗔痴俱行恶心修集无贪无嗔无痴俱行善心。彼由此心增上力故。得三摩地。是谓心三摩地。彼成就心三摩地已。为令已生恶不善法断故。起欲广说乃至。为令已生善法坚住。乃至持心。彼所有欲若勤若信。乃至若舍。是名胜行。即此胜行及前所说心三摩地。总名心三摩地胜行成就神足。复有苾刍。生起不离贪嗔痴恶心。彼作是念。我今不应生起不离贪嗔痴恶心。然我理应断除不离贪嗔痴恶心修集离贪嗔痴善心。彼由此心增上力故。得三摩地。是谓心三摩地。彼成就心三摩地已。为令已生恶不善法断故。起欲广说乃至。为令已生善法坚住。乃至持心。彼所有欲若勤若信。乃至若舍。是名胜行。即此胜行。及前所说心三摩地。总名心三摩地胜行成就神足。复有苾刍。于诸善法安住不下乃至不极弱心。彼作是念。我于善法安住不下乃至不极弱心。甚为应理。彼由此心增上力故。得三摩地。是谓心三摩地。彼成就心三摩地已。为令已生恶不善法断故。起欲广说乃至。为令已生善法坚住。乃至持心。彼所有欲若勤若信。乃至若舍。是名胜行。即此胜行。及前所说心三摩地。总名心三摩地胜行成就神足。复有苾刍。生起善心。彼作是念。我今生起如是善心。甚为应理。彼由此心增上力故。得三摩地。是谓心三摩地。彼成就心三摩地已。为令已生恶不善法断故。起欲广说乃至。为令已生善法坚住乃至持心。彼所有欲若勤若信。乃至若舍。是名胜行。即此胜行。及前所说心三摩地。总名心三摩地胜行成就神足。复有苾刍。生起无贪无嗔无痴俱行善心。彼作是念。我今生起无贪无嗔无痴俱行善心。甚为应理。彼由此心增上力故。得三摩地。是谓心三摩地。彼成就心三摩地已。为令已生恶不善法断故。起欲广说乃至。为令已生善法坚住。乃至持心。彼所有欲若勤若信。乃至若舍。是名胜行。即此胜行。及前所说心三摩地。总名心三摩地胜行成就神足。复有苾刍。生起离贪嗔痴善心。彼作是念。我今生起离贪嗔痴善心。甚为应理。彼由此心增上力故。得三摩地。是谓心三摩地。彼成就心三摩地已。为令已生恶不善法断故。起欲广说乃至。为令已生善法坚住。乃至持心。彼所有欲若勤若信。乃至若舍。是名胜行。即此胜行。及前所说心三摩地。总名心三摩地胜行成就神足。一切心三摩地。皆从心起。是心所集。是心种类。是心所生。故名心三摩地胜行成就神足

观三摩地胜行成就神足者。云何观。云何三摩地。云何胜。云何胜行。而名观三摩地胜行成就神足耶。此中观者。谓依出家远离所生善法所起。于法简择。极简择。最极简择。解了等了近了。机黠通达。审察聪睿。觉明慧行。毗钵舍那。是名观。三摩地者。谓观增上所起。心住等住。近住安住。不散不乱。摄止等持。心一境性。是名三摩地。胜者。谓观增上所起八支圣道。是名胜。胜行者。谓有苾刍。依过去观。得三摩地。是谓观三摩地。彼成就观三摩地已。为令已生恶不善法断故。起欲广说乃至。为令已生善法坚住。乃至持心。彼所有欲若勤若信。乃至若舍。是名胜行。即此胜行。及前所说观三摩地。总名观三摩地胜行成就神足。如依过去观。依未来现在善不善无记欲界系色界系无色界系学无学非学非无学见所断修所断非所断观。广说亦尔。复有苾刍。于诸善法。住不审观。彼作是念。我今不应于诸善法住不审观。然我理应于诸善法安住审观。彼由此观增上力故。得三摩地。是谓观三摩地。彼成就观三摩地已。为令已生恶不善法断故。起欲广说乃至。为令已生善法坚住乃至持心。彼所有欲若勤若信。乃至若舍。是名胜行。即此胜行。及前所说观三摩地。总名观三摩地胜行成就神足。复有苾刍。生起恶观。彼作是念。我今不应生起恶观。然我理应断除恶观修集善观。彼由此观增上力故。得三摩地。是谓观三摩地。彼成就观三摩地已。为令已生恶不善法断故。起欲广说乃至。为令已生善法坚住乃至持心。彼所有欲若勤若信。乃至若舍。是名胜行。即此胜行。及前所说观三摩地。总名观三摩地胜行成就神足。复有苾刍。生起贪嗔痴俱行恶观。彼作是念。我今不应生起贪嗔痴俱行恶观。然我理应断除贪嗔痴俱行恶观。修集无贪无嗔无痴俱行善观。彼由此观增上力故。得三摩地。是谓观三摩地。彼成就观三摩地已。为令已生恶不善法断故。起欲广说乃至。为令已生善法坚住乃至持心。彼所有欲若勤若信。乃至若舍。是名胜行。即此胜行。及前所说观三摩地。总名观三摩地胜行成就神足。复有苾刍。生起不离贪嗔痴恶观。彼作是念。我今不应生起不离贪嗔痴恶观。然我理应断除不离贪嗔痴恶观修集离贪嗔痴善观。彼由此观增上力故。得三摩地。是谓观三摩地。彼成就观三摩地已。为令已生恶不善法断故。起欲广说乃至。为令已生善法坚住乃至持心。彼所有欲若勤若信。乃至若舍。是名胜行。即此胜行。及前所说观三摩地。总名观三摩地胜行成就神足。复有苾刍。于诸善法。安住审观。彼作是念。我于善法。安住审观。甚为应理。彼由此观增上力故。得三摩地。是谓观三摩地。彼成就观三摩地已。为令已生恶不善法断故。起欲广说乃至。为令已生善法坚住。乃至持心。彼所有欲若勤若信。乃至若舍。是名胜行。即此胜行。及前所说观三摩地。总名观三摩地胜行成就神足。复有苾刍。生起善观。彼作是念。我今生起如是善观。甚为应理。彼由此观增上力故。得三摩地。是谓观三摩地。彼成就观三摩地已。为令已生恶不善法断故。起欲广说乃至。为令已生善法坚住。乃至持心。彼所有欲若勤若信。乃至若舍。是名胜行。即此胜行。及前所说观三摩地。总名观三摩地胜行成就神足。复有苾刍。生起无贪无嗔无痴俱行善观。彼作是念。我今生起无贪无嗔无痴俱行善观。甚为应理。彼由此观增上力故。得三摩地。是谓观三摩地。彼成就观三摩地已。为令已生恶不善法断故。起欲广说乃至。为令已生善法坚住。乃至持心。彼所有欲若勤若信。乃至若舍。是名胜行。即此胜行。及前所说观三摩地。总名观三摩地胜行成就神足。复有苾刍。生起离贪嗔痴善观。彼作是念。我今生起离贪嗔痴善观。甚为应理。彼由此观增上力故。得三摩地。是谓观三摩地。彼成就观三摩地已。为令已生恶不善法断故。起欲广说乃至。为令已生善法坚住乃至持心。彼所有欲若勤若信。乃至若舍。是名胜行。即此胜行。及前所说观三摩地。总名观三摩地胜行成就神足。一切观三摩地。皆从观起。是观所集。是观种类。是观所生。故名观三摩地胜行成就神足

云何此四。名为神足。此中神者谓所有神。已有神性。当有神性。今有神性。彼法即是变一为多。变多为一。或显或隐。智见所变。墙壁石等。坚厚障物。身过无碍。如履虚空。能于地中。或出或没。自在无碍。如身处水。能于坚障。或在虚空。引水令流。如依迥地。结跏趺坐。凌空往还。都无滞碍。犹如飞鸟。此日月轮。有大神用。具大威德。申手扪摸。如自应器。不以为难。乃至梵世。转变自在。妙用难测。故名为神。此中足者。谓于彼法。精勤修习。无间无断。至成就位。能起彼法。能为彼依。故名为足。复次此四胜定。亦名为神。亦名为足。用难测故。能为胜德所依处故。复次四神足者。是假建立。名想言说。谓为神足。过殑伽沙佛及弟子。皆共施设如是名故。复次四神足者。即前所说欲勤心观四三摩地胜行成就总名神足

    念住品第九之一

一时薄伽梵。在室罗筏。住逝多林给孤独园。尔时世尊告苾刍众。吾当为汝略说修习四念住法。谓有苾刍。于此内身。住循身观。若具正勤正知正念。除世贪忧。于彼外身住循身观。若具正勤正知正念。除世贪忧。于内外身住循身观。若具正勤正知正念。除世贪忧。于内外俱受心法三。广说亦尔。是现修习四念住法。过去未来苾刍修习四念住法。应知亦尔。云何于此内身住循身观。若具正勤正知正念。除世贪忧。内身者。谓自身。若在现相续中。已得不失。于此内身。循身观者。谓有苾刍。于此内身。从足至顶。随其处所。观察思惟。种种不净。秽恶充满。谓此身中。唯有种种发毛爪齿尘垢皮肉筋脉骨髓髀肾心肺肝胆肠胃肪膏脑膜脓血肚脂泪汗涕唾生熟二藏大小便利。如是思惟不净相时。所起于法简择极简择。最极简择。解了等了近了。机黠通达。审察聪睿。觉明慧行。毗钵舍那。是循内身观。亦名身念住。成就此观。现行随行。遍行遍随行。动转解行。说名为住。彼观行者。能发起勤精进。勇健势猛炽盛难制。励意不息。复能于此。急疾迅速。名具正勤。彼观行者。能起于法简择。乃至毗钵舍那。复能于此所起胜慧。转成上品上胜上极。能圆满极圆满。名具正知。彼观行者。具念随念。专念忆念。不忘不失。不遗不漏。不失法性。心明记性。名具正念。于诸欲境诸贪等贪。执藏防护坚着。爱乐迷闷。耽嗜遍耽嗜。内缚悕求。耽湎苦集。贪类贪生。总名为贪。顺忧受触。所起心忧。不平等受。戚受所摄。总名为忧。彼观行者。修此观时。于世所起贪忧二法。能断能遍知。远离极远离。调伏极调伏。隐没除灭。是故说彼除世贪忧。复有苾刍。于此内身。观察思惟诸界差别。谓此身中。唯有种种地界水界火界风界空界识界。如是思惟诸界相时。所起于法简择。乃至毗钵舍那。是循内身观。亦名身念住。住具正勤正知正念。除世贪忧。皆如前说。复有苾刍。于此内身。观察思惟多诸过患。谓此身者。如病如痈。如箭恼害。无常苦空非我转动。劳疲羸笃。是失坏法。迅速不停衰朽非恒。不可保信。是变坏法。如是思惟身过患时。所起于法简择。乃至毗钵舍那。是循内身观。亦名身念住。住具正勤正知正念。除世贪忧。亦如前说。云何于彼外身。住循身观。若具正勤正知正念。除世贪忧。外身者。谓自身。若在现相续中未得已失。及他有情所有身相。于彼外身。循身观者。谓有苾刍。于他身内。从足至顶。随其处所。观察思惟。种种不净。秽恶充满。谓彼身中。唯有种种发毛爪齿。广说乃至。大小便利。如是思惟不净相时。所起于法简择。乃至毗钵舍那。是循外身观。亦名身念住。住具正勤正知正念。除世贪忧。亦如前说。复有苾刍。于他身内。观察思惟诸界差别。谓彼身中。唯有种种地界水界火界风界空界识界。如是思惟诸界相时。所起于法简择。乃至毗钵舍那。是循外身观。亦名身念住。住具正勤正知正念。除世贪忧。亦如前说。复有苾刍。于他身内。观察思惟多诸过患。谓彼身者。如病如痈。广说乃至。是变坏法。如是思惟身过患时。所起于法简择。乃至毗钵舍那。是循外身观。亦名身念住。住具正勤正知正念。除世贪忧。亦如前说。云何于内外身。住循身观。若具正勤正知正念。除世贪忧。内身者。谓自身。若在现相续中。已得不失。外身者。谓自身。若在现相续中。未得已失。及他有情所有身相。合说二种。名内外身。于内外身。循身观者。谓有苾刍。合自他身。总为一聚。从足至顶。随其处所。观察思惟。种种不净。秽恶充满。谓此彼身。唯有种种发毛爪齿。广说乃至大小便利。如是思惟不净相时。所起于法简择。乃至毗钵舍那。是循内外身观。亦名身念住住具正勤正知正念。除世贪忧。亦如前说。复有苾刍。合自他身。总为一聚。观察思惟诸界差别。谓此彼身。唯有种种地界水界火界风界空界识界。如是思惟诸界相时。所起于法简择。乃至毗钵舍那。是循内外身观。亦名身念住。住具正勤正知正念。除世贪忧。亦如前说。复有苾刍。合自他身。总为一聚。观察思惟。多诸过患。谓此彼身。如病如痈。广说乃至是变坏法。如是思惟身过患时。所起于法简择。乃至毗钵舍那。是循内外身观。亦名身念住。住具正勤正知正念。除世贪忧。亦如前说。云何于此内受。住循受观。若具正勤正知正念。除世贪忧。内受者。谓自受。若在现相续中。已得不失于此内受。循受观者。谓有苾刍。于此内受。观察思惟内受诸相。受乐受时。如实知我受乐受。受苦受时。如实知我受苦受。受不苦不乐受时。如实知我受不苦不乐受。受乐身受时。如实知我受乐身受。受苦身受时。如实知我受苦身受。受不苦不乐身受时。如实知我受不苦不乐身受。受乐心受时。如实知我受乐心受。受苦心受时。如实知我受苦心受。受不苦不乐心受时。如实知我受不苦不乐心受。受乐有味受时。如实知我受乐有味受。受苦有味受时。如实知我受苦有味受。受不苦不乐有味受时。如实知我受不苦不乐有味受。受乐无味受时。如实知我受乐无味受。受苦无味受时。如实知我受苦无味受。受不苦不乐无味受时。如实知我受不苦不乐无味受。受乐耽嗜依受时。如实知我受乐耽嗜依受。受苦耽嗜依受时。如实知我受苦耽嗜依受。受不苦不乐耽嗜依受时。如实知我受不苦不乐耽嗜依受。受乐出离依受时。如实知我受乐出离依受。受苦出离依受时。如实知我受苦出离依受。受不苦不乐出离依受时。如实知我受不苦不乐出离依受。如是思惟内受相时。所起于法简择乃至毗钵舍那。是循内受观。亦名受念住。成就此观现行随行。乃至解行。说名为住。彼观行者。能发起勤精进。乃至复能于此。急疾迅速。名具正勤。彼观行者。能起于法简择。乃至能圆满极圆满。名具正知。彼观行者。具念随念。乃至心明记性名具正念。于诸欲境诸贪等贪。乃至贪类贪生。总名为贪。顺忧受触。所起心忧。不平等受。戚受所摄。总名为忧。彼观行者。修此观时。于世所起贪忧二法。能断能遍知。乃至隐没除灭。是故说彼除世贪忧。复有苾刍。于内诸受。观察思惟。多诸过患。谓此诸受。如病如痈。广说乃至是变坏法。如是思惟受过患时。所起于法简择。乃至毗钵舍那。是循内受观。亦名受念住。住具正勤正知正念。除世贪忧。皆如前说。云何于彼外受。住循受观。若具正勤正知正念。除世贪忧。外受者。谓自受。若在现相续中。未得已失。及他有情所有诸受。于彼外受。循受观者。谓有苾刍。于他诸受。观察思惟外受诸相。受乐受时。如实知彼受乐受。受苦受时。如实知彼受苦受。受不苦不乐受时。如实知彼受不苦不乐受。广说乃至。受乐出离依受时。如实知彼受乐出离依受。受苦出离依受时。如实知彼受苦出离依受。受不苦不乐出离依受时。如实知彼受不苦不乐出离依受。如是思惟外受相时。所起于法简择。乃至毗钵舍那。是循外受观。亦名受念住。住具正勤正知正念。除世贪忧。亦如前说。复有苾刍。于外诸受。观察思惟。多诸过患。谓彼诸受。如病如痈。广说乃至是变坏法。如是思惟受过患时。所起于法简择。乃至毗钵舍那。是循外受观。亦名受念住。住具正勤正知正念。除世贪忧。亦如前说。云何于内外受。住循受观。若具正勤正知正念。除世贪忧。内受者。谓自受。若在现相续中。已得不失。外受者。谓自受。若在现相续中。未得已失。及他有情所有诸受。合说二种。名内外受。于内外受。循受观者。谓有苾刍合自他受。总为一聚。观察思惟自他受相。受乐受时。如实知受乐受。受苦受时。如实知受苦受。受不苦不乐受时。如实知受不苦不乐受。广说乃至。受乐出离依受时。如实知受乐出离依受。受苦出离依受时。如实知受苦出离依受。受不苦不乐出离依受时。如实知受不苦不乐出离依受。如是思惟诸受相时。所有于法简择。乃至毗钵舍那。是循内外受观。亦名受念住。住具正勤正知正念。除世贪忧。亦如前说。复有苾刍。合自他受。总为一聚。观察思惟诸受过患。谓此彼受。如病如痈。广说乃至是变坏法。如是思惟受过患时。所起于法简择。乃至毗钵舍那。是循内外受观。亦名受念住。住具正勤正知正念。除世贪忧。亦如前说

云何于此内心。住循心观。若具正勤正知正念。除世贪忧。内心者。谓自心。若在现相续中。已得不失。于此内心。循心观者。谓有苾刍。于此内心。观察思惟内心诸相。于内有贪心。如实知是内有贪心。于内离贪心。如实知是内离贪心。于内有嗔心。如实知是内有嗔心。于内离嗔心。如实知是内离嗔心。于内有痴心。如实知是内有痴心。于内离痴心。如实知是内离痴心。于内聚心。如实知是内聚心。于内散心。如实知是内散心。于内沉心。如实知是内沉心。于内策心。如实知是内策心。于内小心。如实知是内小心。于内大心。如实知是内大心。于内掉心。如实知是内掉心。于内不掉心。如实知是内不掉心。于内不静心。如实知是内不静心。于内静心。如实知是内静心。于内不定心。如实知是内不定心。于内定心。如实知是内定心。于内不修心。如实知是内不修心。于内修心。如实知是内修心。于内不解脱心。如实知是内不解脱心。于内解脱心。如实知是内解脱心。如是思惟内心相时。所有于法简择。乃至毗钵舍那。是循内心观。亦名心念住。成就此观。现行随行。乃至解行。说名为住。彼观行者。能发起勤精进。乃至复能于此急疾迅速。名具正勤。彼观行者。能起于法简择。乃至能圆满极圆满。名具正知。彼观行者。具念随念。乃至心明记性。名具正念。于诸欲境诸贪等贪。乃至贪类贪生总名为贪。顺忧受触。所起心忧。不平等受。戚受所摄。总名为忧。彼观行者。修此观时。于世所起贪忧二法。能断能遍知。乃至隐没灭除。是故说彼除世贪忧。复有苾刍。于内诸心。观察思惟多诸过患。谓此心者。如病如痈。广说乃至是变坏法。如是思惟心过患时。所起于法简择。乃至毗钵舍那。是循内心观。亦名心念住。住具正勤正知正念。除世贪忧。皆如前说。云何于彼外心。住循心观。若具正勤正知正念。除世贪忧。外心者。谓自心。若在现相续中。未得已失。及他有情所有诸心。于彼外心。循心观者。谓有苾刍。于他诸心。观察思惟外心诸相。于外有贪心。如实知是外有贪心。广说乃至。于外解脱心。如实知是外解脱心。如是思惟外心相时。所起于法简择。乃至毗钵舍那。是循外心观。亦名心念住。住具正勤正知正念。除世贪忧。亦如前说。复有苾刍。于外诸心。观察思惟多诸过患。谓彼心者。如病如痈。广说乃至是变坏法。如是思惟心过患时。所起于法简择。乃至毗钵舍那。是循外心观。亦名心念住。住具正勤正知正念。除世贪忧。亦如前说。云何于内外心。住循心观。若具正勤正知正念。除世贪忧。内心者。谓自心。若在现相续中。已得不失。外心者。谓自心。若在现相续中。未得已失。及他有情所有诸心。合此二种。名内外心。于内外心。循心观者。谓有苾刍。合自他心。总为一聚。观察思惟自他心相。于有贪心。如实知是有贪心。广说乃至于解脱心。如实知是解脱心。如是思惟诸心相时。所有于法简择。乃至毗钵舍那。是循内外心观。亦名心念住。住具正勤正知正念。除世贪忧。亦如前说。复有苾刍。合自他心。总为一聚。观察思惟多诸过患。谓此彼心。如病如痈。广说乃至。是变坏法。如是思惟心过患时。所起于法简择。乃至毗钵舍那。是循内外心观。亦名心念住。住具正勤正知正念。除世贪忧亦如前说

说一切有部法蕴足论卷第五阿毗达磨法蕴足论卷第六

        尊者大目干连造

        三藏法师玄奘奉　诏译

    念住品第九之余

云何于此内法。住循法观。若具正勤正知正念。除世贪忧。内法者。谓自想蕴行蕴。若在现相续中。已得不失。于此内法。循法观者。谓有苾刍。于内五盖法。观察思惟内法诸相。于有内贪欲盖。如实知我有内贪欲盖。于无内贪欲盖。如实知我无内贪欲盖。复如实知内贪欲盖。未生者生。已生者断。断已于后不复更生。如是思惟此内法时。所起于法简择。乃至毗钵舍那。是循内法观。亦名法念住。成就此观现行随行乃至解行。说名为住。彼观行者。能发起勤精进。乃至复能于此急疾迅速。名具正勤。彼观行者。能起于法简择。乃至能圆满极圆满。名具正知。彼观行者。具念随念。乃至心明记性。名具正念。于诸欲境诸贪等贪。乃至贪类贪生。总名为贪。顺忧受触。所起心忧。不平等。忧戚忧所摄。总名为忧。彼观行者。修此观时。于世所起贪忧二法。能断能遍知。乃至隐没除灭。是故说彼除世贪忧。如说内贪欲盖。说内嗔恚惛沉睡眠掉举恶作疑盖亦尔。复有苾刍。于内六结法。观察思惟内法诸相。于有内眼结如实知我有内眼结。于无内眼结。如实知我无内眼结。复如实知此内眼结。未生者生。已生者断。断已于后不复更生。如是思惟此内法时。所起于法简择。乃至毗钵舍那。是循内法观。亦名法念住。住具正勤正知正念。除世贪忧。皆如前说。如说内眼结。说内耳鼻舌身意结亦尔。复有苾刍。于内七觉支法。观察思惟内法诸相。于有内念觉支。如实知我有内念觉支。于无内念觉支。如实知我无内念觉支。复如实知内念觉支。未生者生。生已坚住不忘。修满倍增广大智作证故。如是思惟此内法时。所起于法简择。乃至毗钵舍那。是循内法观。亦名法念住。住具正勤正知正念。除世贪忧。亦如前说。如说内念觉支。说余内六觉支等亦尔。复有苾刍。于所说内想蕴行蕴。观察思惟多诸过患。谓此法者。如病如痈。广说乃至是变坏法。如是思惟法过患时。所起于法简择。乃至毗钵舍那。是循内法观。亦名法念住。住具正勤正知正念。除世贪忧。亦如前说。云何于彼外法。住循法观。若具正勤正知正念。除世贪忧。外法者。谓自想蕴行蕴。若在现相续中。未得已失。及他有情想蕴行蕴。于彼外法。循法观者。谓有苾刍。于他五盖法。观察思惟外法诸相。于有外贪欲盖。如实知彼有外贪欲盖。于无外贪欲盖。如实知彼无外贪欲盖。复如实知外贪欲盖。未生者生。已生者断。断已于后不复更生。如是思惟此外法时。所起于法简择。乃至毗钵舍那。是循外法观。亦名法念住。住具正勤正知正念。除世贪忧。亦如前说。如说外贪欲盖。说余外四盖亦尔。复有苾刍。于他六结法。观察思惟外法诸相。于有外眼结。如实知彼有外眼结。于无外眼结。如实知彼无外眼结。复如实知彼外眼结。未生者生。已生者断。断已于后不复更生。如是思惟彼外法时。所起于法简择。乃至毗钵舍那。是循外法观。亦名法念住。住具正勤正知正念。除世贪忧。亦如前说。如说外眼结。说余外五结亦尔。复有苾刍。于他七觉支法。观察思惟外法诸相。于有外念觉支。如实知彼有外念觉支。于无外念觉支。如实知彼无外念觉支。复如实知外念觉支。未生者生。生已坚住。广说乃至智作证故。如是思惟彼外法时。所起于法简择。乃至毗钵舍那。是循外法观。亦名法念住。住具正勤正知正念。除世贪忧。亦如前说。如说外念觉支。说余外六觉支等亦尔。复有苾刍。于所说外想蕴行蕴。观察思惟多诸过患。谓彼法者。如病如痈。广说乃至是变坏法。如是思惟法过患时。所起于法简择。乃至毗钵舍那。是循外法观。亦名法念住。住具正勤正知正念。除世贪忧。亦如前说。云何于内外法。住循法观。若具正勤正知正念。除世贪忧。内法者。谓自想蕴行蕴。若在现相续中。已得不失。外法者。谓自想蕴行蕴。若在现相续中。未得已失。及他有情想蕴行蕴。合此二种。名内外法。于内外法。循法观者。谓有苾刍。合前自他想蕴行蕴。总为一聚。观察思惟自他法相。谓前所说内外五盖。六结七觉支等。此彼有无未生生断不复生相。如是思惟内外法时。所起于法简择。乃至毗钵舍那。是循内外法观。亦名法念住。住具正勤正知正念。除世贪忧。亦如前说。复有苾刍。合前自他想蕴行蕴。总为一聚。观察思惟多诸过患。谓此彼法。如病如痈。广说乃至是变坏法。如是思惟法过患时。所起于法简择。乃至毗钵舍那。是循内外法观。亦名法念住。住具正勤正知正念。除世贪忧。亦如前说

    圣谛品第十

一时薄伽梵。住婆罗痆斯仙人论处施鹿林中。尔时世尊告苾刍众。此苦圣谛。若于如是未曾闻法。如理思惟。定能发生眼智明觉。此苦集圣谛。若于如是未曾闻法。如理思惟。定能发生眼智明觉。此苦灭圣谛。若于如是未曾闻法。如理思惟。定能发生眼智明觉。此趣苦灭道圣谛。若于如是未曾闻法。如理思惟。定能发生眼智明觉。复次苾刍。此苦圣谛以通慧应遍知。若于如是未曾闻法。如理思惟。定能发生眼智明觉。此苦集圣谛。以通慧应永断。若于如是未曾闻法。如理思惟。定能发生眼智明觉。此苦灭圣谛。以通慧应作证。若于如是未曾闻法。如理思惟。定能发生眼智明觉。此趣苦灭道圣谛。以通慧应修习。若于如是未曾闻法。如理思惟。定能发生眼智明觉。复次苾刍。此苦圣谛。我通慧已遍知。若于如是未曾闻法。如理思惟。定能发生眼智明觉。此苦集圣谛。我通慧已永断。若于如是未曾闻法。如理思惟。定能发生眼智明觉。此苦灭圣谛。我通慧已作证。若于如是未曾闻法。如理思惟。定能发生眼智明觉。此趣苦灭道圣谛。我通慧已修习。若于如是未曾闻法。如理思惟。定能发生眼智明觉。苾刍当知。我于如是四圣谛中。若未三转十二行相。谓未发生眼智明觉。未能于此天人世间魔梵沙门婆罗门等。解脱出离。未除颠倒。多住心故。亦未如实能自称言我证无上正等菩提。我于如是四圣谛中。若已三转十二行相。谓已发生眼智明觉。便能于此天人世间魔梵沙门婆罗门等。解脱出离。已除颠倒。多住心故。亦已如实能自称言我证无上正等菩提。说此法时。具寿憍陈那。及八万天子。远尘离垢。于诸法中。生净法眼。尔时佛告憍陈那言。于所说法。汝已解耶。憍陈那言。我今已解。第二第三。亦复如是。以憍陈那先解法故。世共号彼。为阿若多。地神药叉。闻是语已。欢喜踊跃。高声唱言。佛今于此婆罗痆斯仙人论处施鹿林中。怜愍世间诸众生故。欲令获得利乐事故。三转法轮。其轮具足十二相行。世闻沙门及婆罗门天魔梵等。皆无有能如法转者。由佛转此无上法轮。憍陈那等。已见圣谛。从今天众渐当增益。阿素洛众渐当损减。因斯展转诸天及人。皆获殊胜利益安乐。空行药叉。闻是声已。欢喜传告四大王天。彼复举声。展转相告。经须臾顷。声至梵天。时大梵王。闻已欢喜。庆佛为转无上法轮利乐无边诸有情故。此中宣说转法轮事。是故名曰转法轮经。时五苾刍。八万天子。闻经欢喜。信受奉行

云何苦圣谛。谓生苦老苦病苦死苦。怨憎会苦。爱别离苦。求不得苦。略说一切五取蕴苦。云何生苦。生谓彼彼诸有情类。即于彼彼有情聚中。诸生等生趣入出现蕴得界得处得诸蕴生命根起。总名为生。何因缘故。说生为苦。有情生时。领纳摄受种种身苦事故。领纳摄受种种心苦事故。领纳摄受种种身心苦事故。领纳摄受种种身热恼事故。领纳摄受种种心热恼事故。领纳摄受种种身心热恼事故。领纳摄受种种身烧然事故。领纳摄受种种心烧然事故。领纳摄受种种身心烧然事故。说生为苦。复次生时。受二种苦。一者苦苦。二者行苦。故名生苦。云何老苦。老谓老时。发落发白。皮缓面皱。身曲背偻。喘息逾急。扶杖而行。支体斑黑。衰退暗钝。根熟变坏。诸行故败。朽坏羸损。总名为老。何因缘故。说老为苦。有情老时。领纳摄受种种身苦事故。广说乃至。领纳摄受种种身心烧然事故。说老为苦。复次老时。受三种苦。一者苦苦。二者行苦。三者坏苦。故名老苦。云何病苦。病谓头痛。眼痛耳痛。鼻痛舌痛。面痛唇痛。齿痛齶痛。喉痛心痛。风病嗽病。气病噫病。癞病痔病。痢病麻病。寒病热病。瘨病痫病。欧逆疮肿。癣疥[病-丙+追]瘿。[病-丙+帶]下漏泄。痃癖枯痟。及余种种依身心起。身心疹疾。总名为病。何因缘故。说病为苦。有情病时。领纳摄受种种身苦事故广说乃至领纳摄受。种种身心烧然事故。说病为苦

复次病时。受二种苦。一者苦苦。二者行苦。故名病苦。云何死苦。死谓彼彼诸有情类。即从彼彼诸有情聚。移转坏没。退失别离。寿暖识灭。命根不转。诸蕴破坏。夭丧殉逝。总名为死。何因缘故。说死为苦。有情死时。领纳摄受种种身苦事故。广说乃至领纳摄受种种身心烧然事故。说死为苦。复次死时。受三种苦。一者苦苦。二者行苦。三者坏苦。故名死苦。云何怨憎会苦。怨憎会。谓诸有情等。不可爱。不可乐。不可喜。不可意。而与彼俱。一处为伴。不别不异。不离不散。聚集和合。总名怨憎会何因缘故。说怨憎会为苦。谓诸有情。怨憎会时。领纳摄受种种身苦事故。广说乃至领纳摄受种种身心烧然事故。说彼为苦

复次怨憎会时。受二种苦。一者苦苦。二者行苦。故名怨憎会苦。云何爱别离苦。爱别离。谓诸有情等。可爱可乐。可喜可意。不与彼俱。不同一处。不为伴侣。别异离散。不聚集。不和合。总名爱别离。何因缘故。说爱别离为苦。谓诸有情。爱别离时。领纳摄受种种身苦事故。广说乃至。领纳摄受种种身心烧然事故。说彼为苦。复次爱别离时。受三种苦。一者苦苦。二者行苦。三者坏苦。故名爱别离苦。云何求不得苦。求不得。谓悕求可意色声香味触衣服饮食卧具医药。诸资身具。不得不获。不会不遇。不成就。不和合。总名求不得。何因缘故。说求不得为苦。谓诸有情。求不得时。领纳摄受种种身苦事故。广说乃至领纳摄受种种身心烧然事故。说彼为苦。复次求不得时。受二种苦。一者苦苦。二者行苦。故名求不得苦。云何略说一切五取蕴苦。五取蕴。谓色取蕴受想行识取蕴。总名五取蕴。何因缘故。略说一切五取蕴为苦。谓五取蕴。无常转动。劳倦羸笃。是失坏法。迅速不停。衰朽非恒。不可保信。是变坏法。有增有减。暂住速灭。本无而有。有已还无。由此因缘。略说一切五取蕴为苦。如说取蕴皆性是苦。不安隐故。违圣心故。如是诸苦。名苦谛者。谓此名无常真实。是无常此名为苦。真实是苦。若佛出世。若不出世。如是苦法。法住法界。一切如来。自然通达。等觉宣说。施设建立。分别开示。令其显了。谓此是无常。此是苦。此是无常性。此是苦性。是真是实。是谛是如。非妄非虚。非倒非异。故名苦谛。名圣谛者。圣谓诸佛。及佛弟子。此是彼谛。谓彼于此。知见解了。正觉为谛。由是因缘。名苦圣谛。复次苦圣谛者。是假建立名想言说。谓苦圣谛。过殑伽沙佛及弟子。皆共施设如是名故

云何苦集圣谛。谓所有诸爱。后有爱喜俱行爱。彼彼喜爱。如是略说苦集圣谛。若广说者。则二爱三爱。复有三爱四爱五爱六爱。及一切不善法。一切有漏善法。一切结缚随眠随烦恼缠等。皆名苦集圣谛。何因缘故。所有诸爱。后有爱喜俱行爱彼彼喜爱。皆名苦集圣谛。谓此四爱。皆是过去未来现在。苦因根本道路缘起。广说乃至。此身坏后由此为因。苦果生起。故说此名苦集圣谛。何因缘故。二爱三爱。复有三爱四爱五爱六爱。及一切不善法。一切有漏善法。一切结缚随眠随烦恼缠等。皆名苦集圣谛。谓此诸法。皆是过去未来现在。苦因根本道路缘起。广说乃至。此身坏后。由此为因。苦果生起。如说爱等。皆是苦因。能为根本。引众苦故。如是爱等。名集谛者。谓此名爱等真实。是爱等此名为集。真实是集。若佛出世。若不出世。如是集法。法住法界一切如来。自然通达。等觉宣说。施设建立。分别开示。令其显了。谓此是爱等。此是集。此是爱等性。此是集性。是真是实。是谛是如。非妄非虚。非倒非异。故名集谛。名圣谛者。圣谓诸佛及佛弟子。此是彼谛。谓彼于此。知见解了。正觉为谛。由是因缘。名苦集圣谛。复次苦集圣谛者。是假建立名想言说。谓苦集圣谛。过殑伽沙佛及弟子。皆共施设如是名故。云何苦灭圣谛。谓即诸爱。后有爱喜俱行爱。彼彼喜爱无余永断。弃舍变吐。尽离染灭。寂静隐没。如是略说苦灭圣谛。若广说者。则二爱三爱。复有三爱四爱五爱六爱。及一切不善法。一切有漏善法。一切结缚随眠随烦恼缠等。无余永断。弃舍变吐。尽离染灭。寂静隐没。皆名苦灭圣谛。何因缘故。即诸爱后有爱喜俱行爱。彼彼喜爱。无余永断。弃舍变吐。尽离染灭。寂静隐没。皆名苦灭圣谛。谓此四爱。若未断。未遍知。未灭未吐。后有苦果。相续生起。若已断。已遍知。已灭已吐。后有苦果。不复生起。故此永断等。名苦灭圣谛。何因缘故。即二爱三爱。复有三爱四爱五爱六爱及一切不善法。一切有漏善法。一切结缚随眠随烦恼缠等。无余永断。弃舍变吐。尽离染灭。寂静隐没。皆名苦灭圣谛。谓此诸法。若未断未遍知。未灭未吐。后有苦果。相续生起。若已断已遍知。已灭已吐。后有苦果。不复生起。故此永断等。名苦灭圣谛。即此苦灭圣谛。亦名室宅。亦名洲渚。亦名救护。亦名归依。亦名应趣。亦名无忧。亦名无病。亦名不死。亦名无炽然。亦名无热恼。亦名安隐。亦名清凉。亦名寂静。亦名善事。亦名吉祥。亦名安乐。亦名不动。亦名涅槃。如说涅槃是真苦灭。是诸沙门究竟果故。如是断等。名灭谛者。谓此名涅槃真实。是涅槃此名为灭。真实是灭。若佛出世。若不出世。如是灭法。法住法界。一切如来。自然通达。等觉宣说。施设建立。分别开示。令其显了。谓此是涅槃。此是灭。此是涅槃性。此是灭性。是真是实。是谛是如。非妄非虚。非倒非异。故名灭谛。名圣谛者。圣谓诸佛及佛弟子。此是彼谛。谓彼于此。知见解了。正觉为谛。由是因缘。名苦灭圣谛。复次苦灭圣谛者。是假建立名想言说。谓苦灭圣谛。过殑伽沙佛及弟子。皆共施设如是名故

云何趣苦灭道圣谛。谓若道若圣行。于过去未来现在。苦能永断。能弃舍。能变吐。能尽。能离染。能灭。能寂静。能隐没。此复是何谓八支圣道。则是正见正思惟正语正业正命正勤正念正定。云何正见。谓圣弟子。于苦思惟苦。于集思惟集。于灭思惟灭。于道思惟道。无漏作意相应。所有于法简择。极简择。最极简择。解了等了近了。机黠通达。审察聪睿。觉明慧行。毗钵舍那。是名正见。云何正思惟。谓圣弟子。于苦思惟苦。乃至于道思惟道。无漏作意相应所有思惟。等思惟近思惟。寻求。等寻求。近寻求。推觅。等推觅。近推觅。令心于法粗动而转。是名正思惟。云何正语。谓圣弟子。于苦思惟苦。乃至于道思惟道。无漏作意相应思择力故。除趣邪命语四恶行。于余语恶行所得无漏。远离。胜远离。近远离。极远离。寂静律仪。无作无造。弃舍防护。船筏桥梁。堤塘墙堑。于所制约。不踰不踰性。不越不越性。无表语业。是名正语。云何正业。谓圣弟子。于苦思惟苦。乃至于道思惟道。无漏作意相应思择力故。除趣邪命身三恶行。于余身恶行所得无漏。远离乃至无表身业。是名正业。云何正命。谓圣弟子。于苦思惟苦。乃至于道思惟道。无漏作意相应思择力故。于趣邪命身语恶行所得无漏。远离乃至身语无表业。是名正命。云何正勤。谓圣弟子。于苦思惟苦。乃至于道思惟道。无漏作意相应所有勤精进。勇健势猛。炽盛难制。励意不息。是名正勤。云何正念。谓圣弟子。于苦思惟苦。乃至于道思惟道。无漏作意相应所有念。随念专念忆念。不忘不失。不遗不漏。不失法性。心明记性。是名正念。云何正定。谓圣弟子。于苦思惟苦。乃至于道思惟道。无漏作意相应所有心住。等住。近住安住。不散不乱。摄止等持。心一境性。是名正定。如是所说八支圣道。及余无漏行。名趣苦灭道。如说圣行是真实。道究竟离苦趣涅槃。故如是圣行。名道谛者。谓此名圣行真实。是圣行此名为道。真实是道。若佛出世。若不出世。如是道法。法住法界。一切如来。自然通达。等觉宣说。施设建立。分别开示。令其显了。谓此是圣行。此是道。此是圣行性。此是道性。是真是实。是谛是如。非妄非虚。非倒非异。故名道谛。名圣谛者。圣谓诸佛及佛弟子。此是彼谛。谓彼于此知见解了。正觉为谛。由是因缘。名趣苦灭道圣谛。复次趣苦灭道圣谛者。是假建立名想言说。谓趣苦灭道圣谛。过殑伽沙佛及弟子。皆共施设如是名故

    静虑品第十一之一

一时薄伽梵。在室罗筏。住逝多林给孤独园。尔时世尊。告苾刍众。有四天道。令诸有情。未净者净。净者鲜白。何等为四。谓有一类离欲恶不善法。有寻有伺。离生喜乐。初静虑具足住。是名第一天道。复有一类。寻伺寂静。内等净心一趣性。无寻无伺。定生喜乐。第二静虑具足住。是名第二天道。复有一类离喜住舍。正念正知。身受乐圣说应舍。第三静虑具足住。是名第三天道。复有一类断乐断苦。先喜忧没。不苦不乐。舍念清净。第四静虑具足住。是名第四天道。如是四种。皆令有情未净者净净者鲜白

离欲恶不善法者。云何欲。谓贪亦名欲。欲界亦名欲。五妙欲境亦名欲。今此义中。意说五妙欲境名欲。所以者何。以五妙欲极可爱故。极可醉故。极可欲故。极可乐故。极可贪故。极可求故。极可闷故。极可缚故。极可希故。极可系故。此中名欲。然五妙欲。非真欲体。真欲体者。是缘彼贪。如世尊说

  世诸妙境非真欲　　真欲谓人分别贪
  妙境如本住世间　　智者于中已除欲

此颂意言。可爱妙色声香味触。非真欲体。真欲体者。谓缘彼生分别贪着。欲境如本。智者于中名离欲故。尊者舍利子。有时为人说如是颂。尔时有一邪命外道。不远而住。以颂难诘舍利子言

  若世妙境非真欲　　真欲谓人分别贪
  苾刍应名受欲人　　起恶分别寻思故

时舍利子报外道言。起恶寻思。实名受欲。非诸苾刍于世妙境。皆起不善分别寻思故。汝不应作斯难诘。以颂反诘彼外道言

  若世妙境是真欲　　说欲非人分别贪
  汝师应名受欲人　　恒观可意妙色故

时彼外道。默不能答。彼师实观可爱色故。由此知欲是贪非境。尔时有一汲水女人。闻上伽他。便说颂曰

  欲我知汝本　　汝从分别生
  我更不分别　　汝复从谁起

时复有一遏吒罗种。闻上伽他。亦说颂曰

  牟尼安隐眠　　遇恶无愁恼
  心乐静虑者　　不游戏诸欲

此颂意言。可爱妙境。皆非真欲。于彼所起分别贪爱。乃是真欲。是故此中应作四句。一有一类补特伽罗。于诸欲境。身离非心。谓如有一剃除须发。披服袈裟。正信出家。身参法侣。心犹顾恋所受诸欲。数复发起猛利贪爱。彼身出家。心犹未出。是名于欲身离非心。二有一类补特伽罗。于诸欲境。心离非身。谓如有一。虽有妻子。受用上妙田宅卧具香鬘璎珞衣服饮食受畜种种金银珍宝驱役奴婢僮仆作使。或时发起打骂等业。而于诸欲。不生耽染。不数发起猛利贪爱。彼身在家。其心已出。是名于欲心离非身。三有一类补特伽罗。于诸欲境。身心俱离。谓如有一剃除须发披服袈裟正信出家身参法侣。于诸欲境。心无顾恋。不数发起缘彼贪爱。失念暂起。深生悔愧。彼身出家。其心亦出。是名于欲身心俱离。四有一类补特伽罗。于诸欲境。身心俱不离。谓如有一畜妻养子。受用上妙田宅卧具香鬘璎珞衣服饮食受畜种种金银珍宝驱役奴婢僮仆作使。发起种种打骂等业。复于诸欲。深生耽染。数数发起猛利贪爱。彼身心二种。俱不出家。是名于欲身心俱不离。云何离欲谓于诸欲。远离极远离。空不可得。故名离欲。云何恶不善法。谓五盖。即贪欲盖。嗔恚盖。惛沉睡眠盖。掉举恶作盖。疑盖。云何贪欲盖。谓于诸欲诸贪。等贪执藏。防护坚着。爱乐迷闷。耽嗜遍耽嗜。内缚悕求。耽湎苦集。贪类贪生。总名贪欲。如是贪欲。覆心蔽心。障心缠心。隐心映心。里心盖心。故名为盖。盖即贪欲。故名贪欲盖。云何嗔恚盖。谓于有情。欲为损害内怀栽杌。欲为扰恼。已嗔恚。当嗔恚。现嗔恚。乐为过患。极为过患。意极愤恚。于诸有情。各相违戾。欲为过患。已为过患。当为过患。现为过患。总名嗔恚。如是嗔恚。覆心蔽心。乃至里心盖心。故名为盖。盖即嗔恚。故名嗔恚盖。云何惛沉睡眠盖。谓身重性。心重性。身无堪任性。心无堪任性。身惛沈性。心惛沈性。[夢-夕+登]瞢愦闷。总名惛沈。染污心品。所有眠梦。不能任持。心昧略性。总名睡眠。如是所说。惛沉睡眠。覆心蔽心。乃至里心盖心。故名为盖。盖即惛沉睡眠。故名惛沉睡眠盖。云何掉举恶作盖。谓心不寂静掉举等掉举心掉举性。总名掉举。染污心品所有心变心懊心悔我恶作恶作性。总名恶作。如是所说掉举恶作。覆心蔽心。乃至里心盖心。总名为盖。盖即掉举恶作故。名掉举恶作盖。云何疑盖。谓于佛法僧。及苦集灭道。生起疑惑。二分二路。犹豫疑箭。不决定。不究竟。不审决。非已一趣。非当一趣。非现一趣。总说为疑。如是疑性。覆心蔽心。乃至里心盖心。故名为盖。盖即是疑。故名疑盖。云何离恶不善法。谓于如是恶不善法。远离极远离。空不可得。故名离恶不善法

说一切有部法蕴足论卷第六阿毗达磨法蕴足论卷第七

        尊者大目干连造

        三藏法师玄奘奉　诏译

    静虑品第十一之余

有寻有伺者。云何寻。谓离欲恶不善法者。心寻求。遍寻求。近寻求。心显了。极显了。现前显了。推度构画。思惟分别。总名为寻。云何伺。谓离欲恶不善法者。心伺察。遍伺察。近伺察。随行随转。随流随属。总名为伺。寻与伺。何差别。令心粗性是寻令。心细性是伺。此复如何。如打钟时。粗声暂发。细声随转。粗声喻寻。细声喻伺。摇铃扣钵。吹螺击鼓。放箭震雷。粗细二声为喻亦尔。又如众鸟飞翔虚空。鼓翼踊身。方得随意。鼓翼喻寻。踊身喻伺。是谓寻伺二相差别。云何有寻有伺。谓离欲恶不善法者。心相应品。具有寻伺。离生喜乐者。云何离。谓离欲。亦名离。离恶不善法。亦名离。出家亦名离。色界善根。亦名离。初静虑亦名离。今此义中意。说初静虑名离。云何喜。谓离欲恶不善法者。心欣极欣。现前极欣。欣性欣类。适意悦意。喜性喜类。乐和合。不别离。欢欣悦豫。有堪任性。踊跃踊跃性。欢喜欢喜性。总名为喜。云何乐。谓离欲恶不善法者。已断身重性心重性。身不堪任性。心不堪任性。所得身滑性。心滑性。身软性。心软性。身堪任性。心堪任性。身离盖性。心离盖性。身轻安性。心轻安性。身无燋恼性。心无燋恼性。身调柔性。心调柔性。总名为乐。云何离生喜乐。谓前喜乐。因离依离。离所建立。由离势力起等起生等生。趣入出现。故说此名离生喜乐。初者谓此静虑。顺次数中。最居首故。复次此于九种次第定中。最在前故。静虑者。谓在此定中。寻伺喜乐。心一境性。总此五支。名初静虑。如有颂言

  心随贪欲行　　或复随嗔恚
  而修静虑者　　诸佛不称誉
  惛睡盖缠心　　无知修静虑
  身相虽安静　　诸佛不称誉
  掉悔盖缠心　　诸根不寂静
  虽勤修静虑　　诸佛不称誉
  三宝四谛中　　心怀犹豫者
  虽勤修静虑　　诸佛不称誉
  远离欲及恶　　寻伺皆如理
  身柔软安静　　受离生喜乐
  身如沐浴团　　遍体皆津腻
  不强亦不弱　　爱水不能漂
  寻伺等五支　　贤圣仙所证
  总名初静虑　　诸佛所称誉

在此定中。诸心意识。名初静虑。俱有之心。诸思等思。现前等思。已思当思。造心意业。名初静虑。俱有意业。诸心胜解。已胜解。当胜解。名初静虑。俱有胜解。在此定中。若受若想。若欲若作意。若念若定。若慧等名。初静虑俱有诸法。如是诸法。亦得名初静虑。此静虑名。依何义立。谓能寂静恶不善法。及余杂染。后有炽然。当苦异熟。生老死等诸有漏法。故名静虑。复次寂静种种恶不善法。及余杂染。后有炽然。当苦异熟。生老死等。有漏法已。此静虑。起等起生等生。趣入出现。故名静虑。复次寂静种种恶不善法及余杂染后有炽然当苦异熟生老死等有漏法已。此静虑。明盛遍照。故名静虑。具足者。谓此依出家。及依远离所生善法。精勤修习。无间无断。方得圆满。故名具足。住者。谓成就此静虑现行随行遍行遍随行动转解行。故名为住

寻伺寂静者。寻及伺。如前说第二静虑。此二寂静遍寂静。近寂静。空无所有。故名寻伺寂静。内等净者。云何内等净。谓寻伺寂静。故诸信信性。现前信性。随顺印可爱慕爱慕性。心澄心净。总名内等净。心一趣性者。云何心一趣性。谓寻伺寂静故。心不散不乱不流。安住一境。故名心一趣性。无寻无伺者。谓第二静虑。寻伺不可得不现行非有非等有。故名无寻无伺。定生喜乐者。云何定。谓寻伺寂静者。心住等住。近住安住。不散不乱。摄止等持。心一境性。总名为定。云何喜。谓寻伺寂静者。心欣极欣。广说乃至。欢喜欢喜性。总名为喜。云何乐。谓寻伺寂静者。已断身重性心重性。广说乃至。身调柔性。心调柔性。总名为乐。云何定生喜乐。谓前喜乐。因定依定。定所建立。由定势力。起等起生等生。趣入出现。故说此名定生喜乐。第二者。谓此静虑。顺次数中。居第二故。复次此于九种次第定中。在第二故。静虑者。谓在此定中。内等净喜乐心一境性。总此四支。名第二静虑。如有颂言

  寻伺俱寂静　　如雨息埃尘
  内净心一趣　　触菩提妙乐
  无寻伺有喜　　乐内净及定
  名第二静虑　　诸佛所称誉

在此定中。诸心意识。名第二静虑。俱有之心。诸思等思。乃至造心意业。名第二静虑。俱有意业。诸心胜解。已胜解。当胜解。名第二静虑。俱有胜解。在此定中。若受若想。乃至若慧等。名第二静虑。俱有诸法。如是诸法。亦得名为第二静虑。此静虑名。所依之义。具足及住。皆如前说

离喜者。云何喜。谓心欣极欣。乃至欢喜欢喜性。总名为喜。心于此喜。离染解脱。故名离喜。住舍正念正知者。彼于尔时。安住行舍正念正知。云何舍。谓离喜时。心平等性。心正直性。心无警觉寂静住性。总名为舍。云何正念。谓离喜时。诸念随念。乃至心明记性。总名正念。云何正知。谓离喜时。所起于法简择。乃至毗钵舍那。总名正知。身受乐者。身谓意身。由意身中。有受乐故。四大种身。亦得安适。由此因缘。名身受乐。此中乐者。谓离喜时。已断身重性心重性。乃至身调柔性。心调柔性。总名为乐。此是受乐。非轻安乐。圣说应舍者。圣谓诸佛。及佛弟子。说谓宣说。分别开示劝修定者。应舍此乐。不应耽味。唯应住舍正念正知。第三者。谓此静虑。顺次数中。居第三故。复次此于九种次第定中。在第三故。静虑者。谓在此定中。行舍正念正知身受乐。心一境性。总此五支。名第三静虑。如有颂言

  离喜最上迹　　舍念知乐定
  名第三静虑　　诸佛所称誉

在此定中。诸心意识名第三静虑。俱有之心。诸思等思。乃至造心意业。名第三静虑。俱有意业。诸心胜解。已胜解。当胜解。名第三静虑。俱有胜解。在此定中。若受若想。乃至若慧等。名第三静虑。俱有诸法。如是诸法。亦得名为第三静虑。此静虑名。所依之义。具足及住。亦如前说

断乐者。云何乐。谓顺乐触所起身乐心乐。平等受受所摄。总名为乐。复次修第三静虑时。顺乐受触所起心乐。平等受受所摄。是名乐。断苦者。云何苦。谓顺苦触所起身苦。不平等受受所摄。是名苦。此苦及乐。尔时俱得。断遍知。远离极远离。调伏极调伏。隐没除灭。是故说为断乐断苦。先喜忧没者。云何喜。谓顺喜触所起心喜。平等受受所摄。是名喜。复次修第二静虑时。顺喜受触所起心喜平等受受所摄。是名喜。云何忧。谓顺忧触所起心忧。平等受受所摄。是名忧。此及前喜。尔时俱得断遍知。乃至隐没除灭。是故说为先喜忧没。复次入初静虑时。忧得断遍知。入第二静虑时。苦得断遍知。入第三静虑时。喜得断遍知。入第四静虑时。若乐若苦。若喜若忧。皆得断遍知。远离极远离。调伏极调伏。隐没除灭。是故说为断乐断苦。先喜忧没不苦不乐者。显此中无苦乐二受。唯有第三非苦非乐受舍念清净者。云何舍。谓彼尔时心平等性。心正直性。心无警觉寂静住性总名为舍。云何念。谓彼尔时诸念随念。广说乃至。心明记性。总名为念。彼于尔时。若舍若念。俱得清净乐苦喜忧。寻伺二息。皆远离故。说名清净。第四者。谓此静虑。顺次数中。居第四故。复次此于九种次第定中。在第四故。静虑者。谓在此定中。不苦不乐。受舍念。心一境性。总此四支。名第四静虑。如有颂言

  乐苦等已灭　　心坚住不动
  得清净天眼　　能广见众色
  不苦不乐受　　净舍念及定
  名第四静虑　　诸佛所称誉

在此定中。诸心意识。名第四静虑。俱有之心。诸思等思。乃至造心意业。名第四静虑。俱有意业。诸心胜解。已胜解。当胜解。名第四静虑。俱有胜解。在此定中。若受若想。乃至若慧等。名第四静虑。俱有诸法。如是诸法。亦得名为第四静虑。此静虑名。所依之义。具足及住。皆如前说

    无量品第十二

一时薄伽梵。在室罗筏。住逝多林给孤独园。尔时世尊。告苾刍众。有四无量。何等为四。谓有一类慈俱行心。无怨无敌。远离恼害。广大无量。善修习故。想对一方。胜解遍满。具足而住。及对第二第三第四上下或傍。一切世间亦复如是。是名第一。复有一类悲俱行心。无怨无敌。远离恼害。广大无量。善修习故。想对一方。胜解遍满。具足而住。及对第二第三第四。上下或傍。一切世间。亦复如是。是名第二。复有一类喜俱行心。无怨无敌。远离恼害。广大无量。善修习故。想对一方。胜解遍满。具足而住。及对第二第三第四。上下或傍。一切世间。亦复如是。是名第三。复有一类舍俱行心。无怨无敌。远离恼害。广大无量。善修习故。想对一方。胜解遍满。具足而住。及对第二第三第四。上下或傍。一切世间。亦复如是。是名第四

云何为慈。谓有一类。作是思惟。愿诸有情。皆得胜乐。彼依出家。或依远离。由思择力。内所发起。色界定善诸慈性。名哀怜哀怜性。名愍念愍念性。总名为慈。复次与慈相应受想行识。及所等起身语二业。不相应行。亦名为慈。云何慈心定加行。修何加行。入慈心定。谓有一类。起如是心。愿诸有情。皆得胜乐。虽有此心。而无胜解。愿诸有情。皆得如是如是胜乐。彼心虽善净妙随顺磨莹增长严饰应供。常委助伴资粮。而未名慈心定加行。亦未名入慈心定。复有一类。发如是言。愿诸有情。皆得胜乐。虽有此言。而无胜解。愿诸有情。皆得如是如是胜乐。彼言虽善净妙乃至资粮。而未名慈。心定加行。亦未名入慈心定。复有一类。起如是心。发如是言。愿诸有情。皆得胜乐。虽有此心及有此言。而无胜解。愿诸有情。皆得如是如是胜乐。彼心及言。虽皆是善净妙乃至资粮。而未名慈心定加行。亦未名入慈心定。复有一类。起如是心。发如是言。及有胜解。愿诸有情。皆得如是如是胜乐。彼心言及胜解。虽皆是善净妙乃至资粮。而未名慈心定加行。亦未名入慈心定。其事如何。如有一类。寒苦所逼。得暖生乐。取此乐相。起如是心。发如是言。愿诸有情。皆得如是如是胜乐。彼心言及胜解。虽皆是善净妙乃至资粮。而未名慈心定加行。亦未名入慈心定。复有一类。热苦所逼。得冷生乐。取此乐相。起如是心。发如是言。愿诸有情。皆得如是如是胜乐。彼心言及胜解。虽皆是善净妙乃至资粮。而未名慈心定加行。亦未名入慈心定。复有一类。饥苦所逼。得食生乐。取此乐相。起如是心。发如是言。愿诸有情。皆得如是如是胜乐。彼心言及胜解。虽皆是善净妙乃至资粮。而未名慈心定加行。亦未名入慈心定。复有一类。渴苦所逼。得饮生乐。取此乐相。起如是心。发如是言。愿诸有情。皆得如是如是胜乐。彼心言及胜解。虽皆是善净妙乃至资粮。而未名慈心定加行。亦未名入慈心定。复有一类。身体垢秽。支节劳倦乏诸资具。亲友乖离。遇得沐浴案摩资具。亲友和合。发生诸乐。取此乐相。起如是心。发如是言。愿诸有情。皆得如是如是胜乐。彼心言及胜解。虽皆是善净妙乃至资粮。而未名慈心定加行。亦未名入慈心定。复有一类。盛夏热时。炎炽日光所逼切故。热渴迷闷。身心燋恼。遇清凉池。投身沐浴。饮用生乐。取此乐相。起如是心。发如是言。愿诸有情。皆得如是如是胜乐。彼心言及胜解。虽皆是善净妙乃至资粮。而未名慈心定加行。亦未名入慈心定。如是所受欲界乐具。及三静虑所受胜乐。取彼乐相。起心发言。愿诸有情。皆得如是如是胜乐。彼心言及胜解。虽皆是善净妙乃至资粮。而未名慈心定加行。亦未名入慈心定。若有此生。近曾现入。第三静虑。取彼乐相。起如是心。发如是言。愿诸有情。皆得如是如是胜乐。彼心言及胜解。皆是胜善净妙随顺。乃至资粮。乃可名慈心定加行。亦名入慈心定。又此定中。诸心意识。名慈俱有心。诸思等思。现前等思。已思当思。造心意业。名慈俱有意业。诸心胜解。已胜解。当胜解。名慈俱有胜解。又此定中。若受若想。若欲若作意。若念若定。若慧等。名慈俱有诸法。如是诸法。亦得名慈心定加行。亦名入慈心定。复次慈心定有二种。一狭小。二无量。云何狭小慈心定加行。修何加行。入狭小慈心定。谓有一类。于诸可爱可乐可喜可意有情。谓父母兄弟姊妹。及余随一亲属朋友。彼于如是狭小有情。令狭小慈俱心住等住近住安住调伏寂静最极寂静。一趣等持。愿彼有情。皆得胜乐。彼于尔时。若心散乱。驰流余境。不能一趣。不能守念。令住一缘。而愿狭小有情得乐。齐此未名狭小慈心定加行。亦未名入狭小慈心定。彼若尔时。摄录自心。令不散乱。驰流余境。能令一趣住念一缘。思惟狭小诸有情相。而愿狭小有情得乐。如是思惟。发勤精进。勇健势猛。炽盛难制。励意不息。是名狭小慈心定加行。亦名入狭小慈心定。彼于此道。生已修习。多修习故。便令心住等住近住安住一趣等持无二无退。愿彼狭小有情得乐。齐此名为已入狭小慈心定。又此定中。诸心意识。名狭小慈俱有心。诸思等思。乃至造心意业。名狭小慈俱有意业。诸心胜解。已胜解。当胜解。名狭小慈俱有胜解。又此定中。若受若想。乃至若慧等。名狭小慈俱有诸法。如是诸法。亦得名狭小慈心定加行。亦名入狭小慈心定。云何无量慈心定加行。修何加行。入无量慈心定。谓即于狭小慈心定。数数修习。令心随顺调伏寂静。数复调练。令其质直柔软堪能。与后胜定作所依止。然后渐令胜解遍满。于东方等无量有情。皆愿得乐。彼于尔时。若心散乱。驰流余境。不能一趣。不能守念。令住一缘。而愿无量有情得乐。齐此未名无量慈心定加行。亦未名入无量慈心定。彼若尔时。摄录自心。令不散乱。驰流余境。能令一趣住念一缘。思惟无量诸有情相。而愿无量有情得乐。如是思惟。发勤精进。乃至励意不息。是名无量慈心定加行。亦名入无量慈心定。彼于此道。生已修习。多修习故。便令心住等住近住安住一趣等持无二无退。愿彼无量有情得乐。齐此名为已入无量慈心定。又此定中。诸心意识。名无量慈俱有心。诸思等思。乃至造心意业。名无量慈俱有意业。诸心胜解。已胜解。当胜解。名无量慈俱有胜解。又此定中。若受若想。乃至若慧等。名无量慈俱有诸法。如是诸法。亦得名无量慈心定加行。亦名入无量慈心定

云何为悲。谓有一类。作是思惟。愿诸有情。皆得离苦。彼依出家。或依远离。由思择力。内所发起。色界定善。诸悲悲性。若恻怆恻怆性。若酸楚酸楚性。总名为悲。复次与悲相应受想行识。及所等起身语二业。不相应行。亦名为悲。复次悲心定。有二种一狭小。二无量。云何狭小悲心定加行。修何加行。入狭小悲心定。谓有一类。于诸可爱可乐可喜可意有情。谓父母兄弟姊妹。及余随一。亲属朋友。彼于如是狭小有情。令狭小悲俱心住等住近住安住调伏寂静最极寂静一趣等持。愿彼有情。皆得离苦。彼于尔时。若心散乱。驰流余境不能一趣。不能守念令住一缘。而愿狭小有情离苦。齐此不名狭小悲心定加行。亦未名入狭小悲心定。彼若尔时。摄录自心。令不散乱。驰流余境。能令一趣住念一缘。思惟狭小诸有情相。而愿狭小有情离苦。如是思惟。发勤精进。乃至励意不息。是名狭小悲心定加行。亦名入狭小悲心定。彼于此道。生已修习。多修习故。便令心住等住近住安住一趣等持无二无退。愿彼狭小有情离苦。齐此名为已入狭小悲心定。又此定中。诸心意识。名狭小悲俱有心。诸思等思。乃至造心意业。名狭小悲俱有意业。诸心胜解。已胜解。当胜解。名狭小悲俱有胜解。又此定中。若受若想。乃至若慧等。名狭小悲俱有诸法。如是诸法。亦得名狭小悲心定加行。亦名入狭小悲心定。云何无量悲心定加行。修何加行。入无量悲心定。谓即于狭小悲心定。数数修习。令心随顺调伏寂静。数复调练。令其质直柔软堪能。与后胜定作所依止。然后渐令胜解遍满。于东方等无量有情。皆愿离苦。彼于尔时。若心散乱。驰流余境。不能一趣。不能守念。令住一缘。而愿无量有情离苦。齐此未名无量悲心定加行。亦未名入无量悲心定。彼若尔时。摄录自心。令不散乱。驰流余境。能令一趣。住念一缘。思惟无量诸有情相。而愿无量有情离苦。如是思惟。发勤精进。乃至励意不息。是名无量悲心定加行。亦名入无量悲心定。彼于此道。生已修习。多修习故。便令心住等住近住安住一趣等持无二无退。愿彼无量有情离苦。齐此名为已入无量悲心定。又此定中。诸心意识。名无量悲俱有心。诸思等思。乃至造心意业。名无量悲俱有意业。诸心胜解。已胜解。当胜解。名无量悲俱有胜解。又此定中。若受若想。乃至若慧等。名无量悲俱有诸法。如是诸法亦得名无量悲心定加行。亦名入无量悲心定

云何为喜。谓有一类。作是思惟。有情获益。深可欣慰。彼依出家。或依远离。由思择力。内所发起。色界定善心欣极欣现前极欣欣性。欣类适意悦意喜性。喜类乐和合不别离。欢欣悦豫有堪任性。踊跃踊跃性。欢喜欢喜性。总名为喜。复次与喜相应受想行识。及所等起身语二业。不相应行。亦名为喜。复次喜心定。有二种。一狭小。二无量。云何狭小喜心定加行。修何加行。入狭小喜心定。谓有一类。于诸可爱可乐可喜可意有情。谓父母兄弟姊妹。及余随一亲属朋友。彼于如是狭小有情。令狭小喜俱心住等住近住安住调伏寂静最极寂静一趣等持。度彼有情得乐离苦。彼于尔时。若心散乱。驰流余境。不能一趣。不能守念。令住一缘。而度狭小有情获益。齐此未名狭小喜心定加行。亦未名入狭小喜心定。彼若尔时。摄录自心。令不散乱。驰流余境。能令一趣。住念一缘。思惟狭小诸有情相。欣慰狭小诸有情相欣慰狭小有情获益。如是思惟。发勤精进。乃至励意不息。是名狭小喜心定加行。亦名入狭小喜心定。彼于此道。生已修习。多修习故。便令心住等住近住安住一趣等持无二无退。欣慰狭小有情获益。齐此名为已入狭小喜心定。又此定中。诸心意识。名狭小喜俱有心。诸思等思。乃至造心意业。名狭小喜俱有意业。诸心胜解。已胜解。当胜解。名狭小喜俱有胜解。又此定中。若受若想。乃至若慧等。名狭小喜俱有诸法。如是诸法。亦得名狭小喜心定加行。亦名入狭小喜心定。云何无量喜心定加行。修何加行。入无量喜心定。谓即于狭小喜心定。数数修习。令心随顺调伏寂静。数复调练。令其质直柔软堪能。与后胜定作所依止。然后渐令胜解遍满。于东方等无量有情。欣慰获益。彼于尔时。若心散乱。驰流余境。不能一趣。不能守念。令住一缘。欣慰无量有情获益。齐此未名无量喜心定加行。亦未名入无量喜心定。彼若尔时。摄录自心。令不散乱。驰流余境。能令一趣。住念一缘。思惟无量诸有情相。欣慰无量有情获益。如是思惟。发勤精进乃至励意不息。是名无量喜心定加行。亦名入无量喜心定。彼于此道。生已修习。多修习故。便令心住等住近住安住一趣等持无二无退。欣慰无量有情获益。齐此名为已入无量喜心定。又此定中。诸心意识。名无量喜俱有心。诸思等思。乃至造心意业。名无量喜俱有意业。诸心胜解。已胜解。当胜解。名无量喜俱有胜解。又此定中。若受若想。乃至若慧等。名无量喜俱。有诸法。如是诸法。亦得名无量喜心定加行。亦名入无量喜心定

云何为舍。谓有一类。作是思惟。应于有情。住平等舍。彼依出家。或依远离。由思择力。内所发起色界定善心平等性。心正直性。心无警觉寂静住性。总名为舍。复次与舍相应受想行识。及所等起身语二业。不相应行。亦名为舍。云何舍心定加行。修何加行。入舍心定。谓有一类。虽见可爱可乐可喜可意等有情。而不起分别。此是我母。此是我父。乃至此是我朋友等。唯起平等有情胜解。如无求士遇入一林。虽见娑罗树。或多罗树。或夜鬘树。或马相树。或邬昙跋罗树。或诺瞿陀树等。而不起分别。此是娑罗树。此是多罗树。乃至此是诺瞿陀树等。唯起平等树林胜解。修舍行者。于诸有情。不起分别。应知亦尔。是名舍心定加行。亦名入舍心定。复次舍心定。有二种。一狭小。二无量。云何狭小舍心定加行。修何加行。入狭小舍心定。谓有一类。于诸可爱可乐可喜可意等有情。谓父母兄弟姊妹。及余随一亲属朋友等。彼于如是狭小有情。令狭小舍俱心住等住近住安住调伏寂静最极寂静一趣等持。于彼有情。住平等舍。彼于尔时。若心散乱。驰流余境。不能一趣。不能守念。令住一缘。于彼有情。住平等舍。齐此未名狭小舍心定加行。亦未名入狭小舍心定。彼若尔时。摄录自心。令不散乱。驰流余境。能令一趣。住念一缘。思惟狭小诸有情相。于彼有情。住平等舍。如是思惟。发勤精进。乃至励意不息。是名狭小舍心定加行。亦名入狭小舍心定。彼于此道。生已修习。多修习故。便令心住等住近住安住一趣等持无二无退。于彼有情。住平等舍。齐此名为已入狭小舍心定。又此定中。诸心意识。名狭小舍俱有心。诸思等思。乃至造心意业。名狭小舍俱有意业。诸心胜解已胜解。当胜解。名狭小舍俱有胜解。又此定中。若受若想。乃至若慧等。名狭小舍俱有诸法。如是诸法。亦得名狭小舍心定加行。亦名入狭小舍心定。云何无量舍心定加行。修何加行。入无量舍心定。谓即于狭小舍心定。数数修习。令心随顺调伏寂静。数复调练。令其质直柔软堪能。与后胜定作所依止。然后渐令胜解遍满。于东方等无量有情。住平等舍。彼于尔时。若心散乱。驰流余境。不能一趣。不能守念。令住一缘。于彼有情。住平等舍。齐此未名无量舍心定加行。亦未名入无量舍心定。彼若尔时。摄录自心。令不散乱。驰流余境。能令一趣。住念一缘思惟无量诸有情相于彼有情。住平等舍。如是思惟。发勤精进。乃至励意不息。是名无量舍心定加行。亦名入无量舍心定。彼于此道。生已修习多修习故。便令心住等住近住安住一趣等持无二无退。于彼有情。住平等舍。齐此名为已入无量舍心定。又此定中。诸心意识。名无量舍俱有心。诸思等思。乃至造心意业。名无量舍俱有意业。诸心胜解。已胜解。当胜解。名无量舍俱有胜解。又此定中。若受若想。乃至若慧等。名无量舍俱有诸法。如是诸法。亦得名无量舍心定加行亦名入无量舍心定

说一切有部法蕴足论卷第七阿毗达磨法蕴足论卷第八

        尊者大目干连造

        三藏法师玄奘奉　诏译

    无色品第十三

一时薄伽梵。在室罗筏。住逝多林给孤独园。尔时世尊。告苾刍众。有四无色。何等为四。谓有苾刍。超诸色想。灭有对想。不思惟种种想。入无边空。空无边处具足住。是名第一。复有苾刍。超一切种空无边处入无边识。识无边处具足住。是名第二。复有苾刍。超一切种识无边处。入无所有。无所有处具足住是名第三。复有苾刍。超一切种无所有处。入非想非非想处具足住。是名第四

超诸色想者。云何诸色想。谓眼识相应想。等想现前等想。解了取像已想当想。总名色想有作是说与五识。相应想等想。乃至已想当想。总名色想。今此义中。唯眼识相。应想等想。乃至已想当想。总名色想。如是色想。尔时超越等超越。故名超诸色想灭。有对想者。云何有对想。谓耳等四识相应想等想。乃至已想当想。总名有对想。有作是说。嗔恚相应想等想。乃至已想当想。总名有对想。今此义中。耳等四识相应想等想。乃至已想当想。总名有对想。如是有对想。尔时断遍知。远离极远离。调伏极调伏。隐没除灭。故名灭有对想。不思惟种种想者。云何种种想。谓有盖缠者。所有染污色声香味触想。所有不善想。所有非理所引想。所有障碍定想。总名种种想。彼想尔时。不复引发。不复忆念。不复思惟。不复已思惟。不复当思惟。故名不思惟种种想。入无边空空无边处具足住者。云何空无边处定加行。修何加行。入空无边处定。谓于此定。初修业者。先应思惟。第四静虑为粗苦障。次应思惟空无边处。为静妙离。彼于尔时。若心散乱。驰流余境。不能一趣。不能守念。令住一缘。修空无边处定齐此未名空无边处定加行。亦未名入空无边处定。彼若尔时摄录自心。令不散乱。驰流余境。能令一趣。住念一缘。思惟修习空无边处定相。如是思惟发勤精进。勇健势猛。炽盛难制。励意不息。是名空无边处定加行。亦名入空无边处定。彼于此道。生已修习多修习故。便令心住等住近住安住一趣等持无二无退。齐此名为已入空无边处定。又此定中。诸心意识。名空无边处定俱有心。诸思等思。乃至造心意业。名空无边处定俱有意业。诸心胜解。已胜解。当胜解。名空无边处定俱有胜解。又此定中。若受若想。乃至若慧等。名空无边处定俱有诸法。如是诸法。亦名空无边处定

超一切种空无边处者。谓彼尔时。于空无边处想超越等超越。故名超一切种空无边处。入无边识识无边处具足住者。云何识无边处定加行修何加行。入识无边处定。谓于此定。初修业者。先应思惟。空无边处。为粗苦障。次应思惟。识无边处。为静妙离。余广说如空无边处。超一切识无边处者。谓彼尔时。于识无边处想超越等超越。故名超一切种识无边处。入无所有无所有处具足住者。云何无所有处定加行。修何加行。入无所有处定。谓于此定初修业者。先应思惟。识无边处为粗苦障。次应思惟。无所有处为静妙离。余广说如空无边处。超一切种无所有处者。谓彼尔时。于无所有处想超越等超越故名超一切种无所有处。入非想非非想处具足住者。云何非想非非想处定加行。修何加行。入非想非非想处定。谓于此定初修业者。先应思惟。无所有处为粗苦。障次应思惟非想非非想处。为静妙离。余广说如空无边处

    修定品第十四

一时薄伽梵。在室罗筏住。逝多林给孤独园。尔时世尊。告苾刍众。有四修定。何等为四。谓有修定。若习若修。若多所作。能令证得现法乐住。复有修定。若习若修。若多所作。能令证得殊胜智见。复有修定。若习若修。若多所作。能令证得胜分别慧。复有修定。若习若修。若多所作。能令证得诸漏永尽。云何修定。若习若修。若多所作。能令证得现法乐住。谓有苾刍。即于自身。离生喜乐。滋润遍滋润。充满遍充满。适悦遍适悦。故离生喜乐。于自身中。无有少分而不充满。是名修定。若习若修。若多所作。能令证得现法乐住。云何修定。若习若修。若多所作。能令证得殊胜智见。谓有苾刍。于光明想。善摄受。善思惟。善修习。善通达。若昼若夜。无有差别。若前若后。无有差别。若下若上。无有差别。开心离盖。修照俱心。除闇昧心。修无量定。是名修定。若习若修。若多所作。能令证得殊胜智见。云何修定若习若修。若多所作。能令证得胜分别慧。谓有苾刍。善知受生。善知受住。善知受灭尽没。于此住念非不住念。及善知想善知寻。于此住念非不住念。是名修定。若习若修。若多所作。能令证得胜分别慧。云何修定。若习若修。若多所作。能令证得诸漏永尽。谓有苾刍。于五取蕴。数数随观。生灭而住。谓此是色。此是色集。此是色灭。此是受想行识。此是受想行识集。此是受想行识灭。是名修定。若习若修。若多所作。能令证得诸漏永尽。尔时世尊。为摄前义。而说颂言

  断欲想忧恼　　离惛沉恶作
  得清净舍念　　法寻伺前行
  现法乐为初　　次胜知见慧
  破无明等漏　　后证解脱果

即于自身者。谓身亦名身。根亦名身。五色根亦名身。四大种所造聚亦名身。今此义中意说四大种所造聚名身。离生喜乐者。谓初静虑所有喜乐平等受。受所摄身轻安心轻安。是名喜乐。如是喜乐。从离欲恶不善法。起等起。生等生。聚集出现。故名离生喜乐。滋润遍滋润。充满遍充满。适悦遍适悦者。谓即于自四大种所造聚身。离生喜乐。起等起。生等生。聚集出现。滋润遍滋润。是一义。充满遍充满。是一义。适悦遍适悦。是一义。由下中上。长养差别。譬如农夫。初以少水。溉灌畦垄尔时畦垄。滋润遍滋润。次以中水。灌溉畦垄。尔时畦垄充满遍充满。后以多水。溉灌畦垄。尔时畦垄。适悦遍适悦。苾刍亦尔。初以下品离生喜乐。长养大种所造聚身。尔时自身。滋润遍滋润。次以中品离生喜乐。长养大种所造聚身。尔时自身。充满遍充满。后以上品离生喜乐。长养大种所造聚身。尔时自身。适悦遍适悦离生喜乐。于自身中。无有少分而不充满者。谓从足至顶。离生喜乐。作长养事。无不充满。是名修定者。云何为定。谓即于自身离生喜乐。滋润遍滋润。充满遍充满。适悦遍适悦。故心住等住近住安住不散不乱摄止等持心一境性。总名为定。云何为修。谓于此定。若修若习。恒作常作。加行不舍。总名为修。若习若修。若多所作者。显于此定。能得自在。能令证得现法乐住者。谓于此定。若习若修。若多所作。于现法中。证得乐住。可爱可乐。可欣可意。无所悕望。无所思慕。寂静安隐故名乐住。于此乐住。得获成就。亲近触证。故名证得。复次初静虑所摄离生喜乐俱行心一境性。说名为定。即于此定若修若习。恒作常作。加行不舍。说名为修。若习若修。若多所作。显彼自在。能令证得现法乐住义如前说

于光明想善摄受等者。云何光明定加行。修何加行。入光明定。谓于此定。初修业者。先应善取净月轮相。或复善取净日轮相。或复善取药物末尼诸天宫殿星宿光明。或复善取灯烛光明。或复善取焚烧城邑川土光明。或复善取焚烧山泽旷野光明。或复善取焚烧十担。或二十担。或三十担。或四十担。或五十担。或百担。或千担。或百千担。或无量百担。或无量千担。或无量百千担。薪火光明。此火光明。炽盛极炽盛。洞然遍洞然。随取一种光明相已。审谛思惟解了观察胜解坚住。而分别之。彼于尔时。若心散乱。驰流余境。不能一趣。不能守念。令住一缘。思惟所取诸光明相齐此未名光明定加行。亦未名入光明定。彼若尔时摄录自心。令不散乱驰流余境。能令一趣。住念一缘。思惟如是诸光明相。如是思惟。发勤精进。乃至励意不息。是名光明定加行。亦名入光明定。彼于此道。生已修习多修习故。便令心住等住近住安住一趣等持无二无退。思惟如是诸光明相齐此名为已入光明定。而未名为光明定想。云何名为光明定想。谓即依止前光明定。思惟如前诸光明相。诸想等想。解了取像。已想当想。名光明定想。此光明定想。名光明想。于光明想。善摄受者。谓于此想。恭敬摄受。殷勤摄受。尊重摄受。思惟彼因彼门彼理彼方便彼行相。故名善摄受。善思惟者。谓数数起光明想已。数数思惟光明相想。善修习者。谓于此想。数习数修。数多所作。故名善修习。善通达者。谓于此想。等了审了。等审观察。故名善通达。若昼若夜。无有差别者。谓如昼分。审谛思惟解了观察胜解坚住分别。如前诸光明相。夜分亦尔。如于夜分。审谛思惟解了观察胜解坚住分别。如前诸光明相。昼分亦尔。故名若昼若夜无有差别。若前若后。无有差别者。谓如对面审谛思惟解了观察胜解坚住分别。如前诸光明相。背面亦尔。如于背面。对面亦尔。复次如于前时审谛思惟解了观察胜解坚住分别。如前诸光明相。今时亦尔。如于今时。前时亦尔故名若前若后无有差别。若下若上无有差别者。谓如于下方审谛思惟解了观察胜解坚住分别。如前诸光明相。于上方亦尔。如于上方于下方亦尔。故名若下若上无有差别。开心者。谓发起光明照了鲜净俱行之心。离盖者。谓远离惛沉睡眠缠盖心。用明了修照俱心者。谓修习光明照了鲜净俱行之心。除闇昧心者。谓此心中。不起闇昧相。唯起光明相。如灯烛光照了除闇。修无量定者。谓修无量光明相定。是名修。定者。云何为定。谓即于光明。审谛思惟解了观察胜解坚住分别所起心住等住。乃至心一境性。总名为定。云何为修。谓于此定。若修若习。恒作常作加行不舍。总名为修。若习若修。若多所作者。显于此定能得自在。能令证得殊胜智见者。云何名为殊胜智见。谓于此定。若习若修。若多所作。至圆满位。于旧眼边。发起色界大种所造清净天眼。依此天眼。生净眼识。依此眼识。能遍观察前后左右上下诸色。如如色界大种所造清净天眼旧眼边起。如是如是。生净眼识。依此眼识。领受观察彼彼诸色。是名此中殊胜智见。有作是说。由意净故。胜解观见。即人肉眼。变成天眼。名胜智见。今此义中。即前所说。清净眼识相应胜慧。说名为智。亦名为见。谓天眼识相应胜慧。领受观察彼彼诸色。是名此中殊胜智见。彼于此定。若习若修。若多所作。能令证得殊胜智见。得获成就亲近触证殊胜智见。故名证得。复次光明想俱行心一境性。说名为定。即于此定。若修若习。恒作常作。加行不舍。说名为修。若习若修若多所作。显彼自在。能令证得殊胜智见。义如前说

善知受生。善知受住。善知受灭。尽没者。谓审观受生。审观受住。审观受灭。尽没于此。住念非不住念者。谓审观受生时。具念正知。审观受住时。具念正知。审观受灭尽没时。具念正知。及善想善知寻者谓审观想寻生审观想寻住。审观想寻灭尽没于此。住念非不住念者。谓审观想寻生时。具念正知。审观想寻住时具念正知审观想寻灭尽没时。具念正知。是名修。定者。云何为定。谓彼尔时。作如是念。我于诸法。应正思惟。不起不善法。起诸善法。不起无记法。起有记法。令不善法不久住。令诸善法得久住令无记法不久住。令有记法得久住。彼于尔时。亦观察心。亦观察心所法。彼观察心心所法时。所起心住等住。乃至心一境性。总名为定。云何为修。谓于此定。若修若习。恒作常作。加行不舍。总名为修。若习若修若多所作者。谓于此定。能得自在。能令证得胜分别慧者。谓于此定。若习若修。若多所作。能令一切不善慧。非理所引慧。所有不善障碍定慧。皆悉破坏。舍置不起此相违慧。生长坚住。由此故说。能令证得。胜分别慧。即于此慧。得获成就亲近触证。故名证得。复次审观受想寻俱行心一境性。说名为定。即于此定。若修若习。恒作常作。加行不舍。说名为修。若习若修。若多所作。显彼自在。能令证得胜分别慧。义如前说

于五取蕴。数数随观生灭而住等者。谓如实知色生及变坏。如实知受想行识生及变坏。是名修。定者云何为定。谓于五取蕴。数数随观生灭。而住所起心住等住。乃至心一境性。总名为定。云何为修。谓于此定。若修若习。恒作常作。加行不舍。总名为修。若习若修。若多所作者。显于此定能得自在。能令证得诸漏永尽者。漏谓三漏。即欲漏有漏无明漏。彼于此定。若习若修。若多所作。能令三漏尽等尽遍尽究竟尽。故名诸漏永尽。于此永尽。得获成就亲近触证。故名证得。复次第四静虑所摄清净舍念俱行。趣阿罗汉。无间道所摄心一境性。说名为定。即于此定。若修若习恒作常作。加行不舍说名为修。若习若修。若多所作。显彼自在。能令证得。诸漏永尽。义如前说

    觉支品第十五之一

一时薄伽梵。在室罗筏住逝多林给孤独园。时有苾刍。来诣佛所。到已顶礼世尊双足。却住一面。而白佛言。世尊。尝说觉支。觉支此言何义。世尊告曰。此觉支。言显七觉支。何等为七。谓念觉支。择法觉支。精进觉支。喜觉支。轻安觉支。定觉支。舍觉支。如是觉支。渐次而起。渐次而得。修令圆满。时彼苾刍。复白佛言。云何觉支。渐次而起。渐次而得。修令圆满佛告苾刍。若有于身。住循身观。安住正念。远离愚痴。尔时便起念觉支。得念觉支。修令圆满。彼由此念。于法简择极简择。遍寻思。遍伺察。审谛伺察。尔时便起择法觉支。得择法觉支。修令圆满。彼由择法。发勤精进。心不下劣。尔时便起精进觉支。得精进觉支。修令圆满。彼由精进。发生胜喜。远离爱味。尔时便起喜觉支。得喜觉支。修令圆满。彼由此喜。身心轻安。远离粗重。尔时便起轻安觉支。得轻安觉支。修令圆满。彼由轻安。便受快乐。乐故心定。尔时便起定觉支。得定觉支。修令圆满。彼由心定。能灭贪忧。住增上舍。尔时便起舍觉支。得舍觉支。修令圆满。于受心法。住循受心法观广说亦尔。如是觉支。渐次而起。渐次而得。修令圆满

云何念觉支。谓世尊说。若圣弟子。于此内身。住循身观。若具正勤正知正念。除世贪忧。于彼外身。住循身观。若具正勤正知正念。除世贪忧。于内外身。住循身观。若具正勤正知正念。除世贪忧。于内外俱受心法三。广说亦尔。修习如是四念住时。所有无漏作意相应。诸念随念。专念忆念。不忘不失。不遗不漏。不失法性。心明记性。总名为念。亦名念根。亦名念力。亦名念觉支。亦名正念。是圣出世无漏无取道随行道俱有道随转。能正尽苦。作苦边际。诸有学者如所见诸行思惟观察。令至究竟。于诸行中深见过患。于永涅槃深见功德。若阿罗汉。如解脱心。思惟观察。令至究竟。所有无漏作意相应。诸念随念。乃至心明记性。是名念觉支

云何择法觉支。谓世尊说。若圣弟子。能如实知善不善法。有罪无罪法。应修不应修法。下劣胜妙法。黑白法。有敌对法。缘生法。能如实知善不善法者。云何善法。谓善身语业。善心心所法。善心不相应行。及择灭是名善法。云何不善法。谓不善身语业。不善心心所法。不善心不相应行。是名不善法。彼于如是善不善法。以如实正慧。简择极简择。遍寻思。遍伺察。审谛伺察。是名能如实知善不善法。能如实知有罪无罪法者。云何有罪法。谓三恶行。三不善根。十不善业道。是名有罪法。云何无罪法。谓三妙行。三善根。十善业道。是名无罪法。彼于如是有罪无罪法。以如实正慧。简择极简择。遍寻思。遍伺察。审谛伺察。是名能如实知有罪无罪法。能如实知应修不应修法者。云何应修法。谓三妙行。三善根。十善业道。亲近善士。听闻正法。如理作意。法随法行。恭敬听闻。密护根门。饮食知量。初夜后夜。曾不睡眠。勤修诸善。是名应修法。复次四念住。四正胜。四神足。五根五力。七等觉支。八支圣道。四正行。四法迹。奢摩他毗钵舍那。亦名应修法。云何不应修法。谓三恶行。三不善根十不善业道。亲近不善士。听闻不正法。不如理作意。行非法行。不恭敬听。不恭敬问。不密护根门。饮食不知量初夜后夜。常习睡眠。不勤修善。是名不应修法。彼于如是应修不应修法。以如实正慧。简择极简择。遍寻思。遍伺察。审谛伺察。是名能如实知应修不应修法。能如实知下劣胜妙法者。云何下劣法。谓不善法。及有覆无记。是名下劣法云何胜妙法。谓诸善法。及无覆无记。是名胜妙法。彼于如是下劣胜妙法。以如实正慧。简择极简择。遍寻思。遍伺察。审谛伺察。是名能如实知下劣胜妙法。能如实知黑白法者。云何黑白法。谓不善法名黑。善法名白。有罪法名黑。无罪法名白。不应修法名黑。应修法名白。下劣法名黑胜妙法名白。是名黑白法。彼于如是黑白法。以如实正慧。简择极简择。遍寻思。遍伺察。审谛伺察。是名能如实知黑白法。能如实知有敌对法者。云何有敌对法。谓贪无贪互相敌对。嗔无嗔互相敌对。痴无痴互相敌对。是名有敌对法。彼于如是有敌对法。以如实正慧。简择极简择。遍寻思。遍伺察。审谛伺察。是名能如实知有敌对法。能如实知缘生法者。云何缘生法。谓缘起法。及缘已生法。总名缘生法。彼于如是缘生法。以如实正慧。简择极简择。遍寻思。遍伺察。审谛伺察。是名能如实知缘生法。彼如实知善不善法。广说乃至缘生法时。所有无漏作意相应。于法简择极简择。最极简择。解了等了近了。机黠通达。审察聪睿。觉明慧行。毗钵舍那。总名为慧。亦名慧根。亦名慧力。亦名择法觉支。亦名正见。是圣出世无漏无取道随行道俱有道随转。能正尽苦。作苦边际。诸有学者如所见诸行。思惟观察。令至究竟。于诸行中深见过患。于永涅槃深见功德。若阿罗汉。如解脱心。思惟观察。令至究竟。所有无漏作意相应。于法简择。乃至毗钵舍那。是名择法觉支

云何精进觉支。谓世尊说。若圣弟子。为令已生恶不善法断故。起欲发勤精进策心持心。为令未生恶不善法不生故。起欲发勤精进策心持心。为令未生善法生故。起欲发勤精进策心持心。为令已生善法坚住不忘修满倍增广大智作证故。起欲发勤精进策心持心。彼修如是四正胜时。所有无漏作意相应。诸勤精进。勇健势猛。炽盛难制。励意不息。总名精进。亦名精进根。亦名精进力。亦名精进觉支。亦名正勤。是圣出世无漏无取道随行道俱有道随转。能正尽苦。作苦边际。诸有学者如所见诸行。思惟观察。令至究竟。于诸行中深见过患。于永涅槃深见功德。若阿罗汉。如解脱心。思惟观察。令至究竟。所有无漏作意相应。诸勤精进。乃至励意不息。是名精进觉支

云何喜觉支。谓世尊说。大名当知。若圣弟子。以如是相随念诸佛。谓此世尊。是如来阿罗汉正等觉明行圆满善逝世间解无上丈夫调御士天人师佛薄伽梵。彼圣弟子。以如是相随念佛时。贪不缠心。嗔不缠心。痴不缠心。于如来所。其心正直。心正直故。得义威势。得法威势。于如来所。能引起欣。欣故生喜心。喜故身安。身安故受乐。乐故心定。心定故于不平等诸有情类。得住平等。于有恼害诸有情类。住无恼害。得预法流于诸佛所修随念故。乃至能证究竟涅槃。复次大名。若圣弟子。以如是相随念正法。谓佛正法。善说现见。无热应时。引导近观。智者内证。彼圣弟子。以如是相随念法时。贪不缠心。嗔不缠心。痴不缠心。于正法所。其心正直。心正直故。得义威势。得法威势。于正法所。能引起欣欣故生喜心。喜故身安。身安故受乐。乐故心定。心定故于不平等诸有情类。得住平等。于有恼害诸有情类。住无恼害。得预法流。于正法所。修随念故。乃至能证究竟涅槃

复次大名。若圣弟子。以如是相随念僧伽。谓佛弟子。具足妙行。质直行。如理行。法随法行。和敬行。随法行。又佛弟子。有预流向。有预流果。有一来向。有一来果。有不还向。有不还果。有阿罗汉向。有阿罗汉果。如是总有四双八只补特伽罗。如是僧伽。戒具足。定具足。慧具足。解脱具足。解脱智见具足。应请应屈。应恭敬无上福田。世所应供。彼圣弟子。以如是相随念僧时。贪不缠心。嗔不缠心。痴不缠心。于僧伽所。其心正直。心正直故。得义威势。得法威势。于僧伽所。能引起欣。欣故生喜。心喜故身安。身安故受乐。乐故心定。心定故于不平等诸有情类。得住平等。于有恼害诸有情类。住无恼害。得预法流。于僧伽所。修随念故。乃至能证究竟涅槃。复次大名。若圣弟子。以如是相随念自戒谓我净戒。不缺不穿。不杂不秽。堪受供养无隐昧。善究竟。善受持。智者称赞。常无讥毁。彼圣弟子。以如是相随念自戒时。贪不缠心。嗔不缠心。痴不缠心。于自戒所。其心正直。心正直故。得义威势。得法威势。于自戒所。能引起欣。欣故生喜。心喜故身安身安故受乐。乐故心定。心定故于不平等诸有情类。得住平等。于有恼害诸有情类。住无恼害。得预法流。于自戒所。修随念故。乃至能证究竟涅槃。复次大名。若圣弟子。以如是相随念自施。谓我今者善得胜利。虽居无量悭垢所缠众生众中。而心远离一切悭垢。能行惠施。虽处居家。而能不着一切财宝。舒手布施。作大祠祀。供养福田。惠舍具足。乐等分布。彼圣弟子。以如是相随念自施时。贪不缠心。嗔不缠心。痴不缠心。于自施所。其心正直。心正直故。得义威势。得法威势。于自施所。能引起欣。欣故生喜。心喜故身安。身安故受乐。乐故心定。心定故于不平等诸有情类。得住平等。于有恼害诸有情类。住无恼害。得预法流。于自施所。修随念故。乃至能证究竟涅槃。复次大名。若圣弟子。以如是相随念诸天。谓有四大王众天。三十三天。夜摩天。睹史多天。乐变化天。他化自在天。如是诸天。成就信故戒故闻故舍故慧故。从此处没。生彼天中。受诸快乐。我亦有信。戒闻舍慧。亦当生彼。与诸天众。同受快乐。彼圣弟子。以如是相随念天时。贪不缠心。嗔不缠心。痴不缠心。于诸天所。其心正直。心正直故。得义威势。得法威势。于诸天所。能引起欣。欣故生喜。心喜故身安。身安故受乐。乐故心定。心定故于不平等诸有情类。得住平等。于有恼害诸有情类。住无恼害。得预法流。于诸天所。修随念故。乃至能证究竟涅槃。彼修如是六随念时。所有无漏作意相应。心欣极欣。现前极欣。欣性欣类。适意悦意。喜性喜类。乐和合不别离。欢欣悦预。有堪任性。踊跃踊跃性。欢喜欢喜性。总名为喜。亦名喜觉支。是圣出世无漏无取道随行道俱有道随转。能正尽苦。住苦边际。诸有学者如所见诸行。思惟观察。令至究竟。于诸行中深见过患。于永涅槃深见功德。若阿罗汉。如解脱心。思惟观察。令至究竟。所有无漏作意相应。心欣极欣。乃至欢喜欢喜性。是名喜觉支

说一切有部法蕴足论卷第八阿毗达磨法蕴足论卷第九

        尊者大目干连造

        三藏法师玄奘奉　诏译

    觉支品第十五之余

云何轻安觉支。谓世尊说。庆喜当知。入初静虑时。语言静息。由此为缘。余法亦静息。此名第一顺轻安相。入第二静虑时。寻伺静息。由此为缘。余法亦静息。此名第二顺轻安相。入第三静虑时。诸喜静息。由此为缘。余法静息。此名第三顺轻安相。入第四静虑时。入出息静息。由此为缘。余法亦静息。此名第四顺轻安相。入灭想受定时。想受静息。由此为缘。余法亦静息。此名第五顺轻安相。庆喜当知。复有第六上妙轻安。是胜是最胜。是上是无上。如是轻安。最上最妙。无余轻安能过此者。此复是何。谓心从贪离染解脱。及从嗔痴离染解脱。此名第六顺轻安相。思惟此相。所有无漏作意相应。诸身轻安。心轻安。轻安性。轻安类。总名轻安。亦名轻安觉支。是圣出世无漏无取道随行道俱有道随转。能正尽苦。作苦边际。诸有学者如所见诸行。思惟观察。令至究竟。于诸行中深见过患。于永涅槃深见功德。若阿罗汉。如解脱心。思惟观察令至究竟。所有无漏作意相应。诸身轻安。心轻安。轻安性。轻安类。是名轻安觉支。云何定觉支。谓世尊说。苾刍当知。我说依初静虑。能尽诸漏。如是我说。依第二第三第四静虑。空无边处。识无边处。无所有处。能尽诸漏。苾刍当知我依何故。作如是说。依初静虑。能尽诸漏。谓有苾刍。先由如是诸行相状。离欲恶不善法。有寻有伺。离生喜乐。初静虑具足住。彼不思惟如是诸行相状。但思惟彼所得所趣色受想行识。谓此诸法。如病如痈如箭恼害。无常苦空非我。彼于此法。深心厌患。怖畏遮止。然后摄心。置甘露界。思惟此界。寂静微妙。舍一切依爱尽离染。永灭涅槃。如善射师。或彼弟子。先学近射泥团草人。后能远射大坚固物。亦令破坏。苾刍亦尔。先由如是诸行相状。离欲恶不善法。有寻有伺。离生喜乐。初静虑具足住。彼不思惟如是诸行相状。但思惟彼所得所趣色受想行识。谓此诸法。如病如痈。如箭恼害。无常苦空非我。彼于此法。深心厌患。怖畏遮止。然后摄心。置甘露界。思惟此界寂静微妙。舍一切依爱尽离染。永灭涅槃。彼如是知如是见故。便从欲漏心得解脱。亦从有漏及无明漏。心得解脱。既解脱已。能自知见。我得解脱。我生已尽。梵行已立。所作已办。不受后有。我依此故。作如是说。依初静虑。能尽诸漏。如说依初静虑能尽诸漏。说依第二第三第四静虑。空无边处。识无边处。无所有处。能尽诸漏。随所应亦尔。谓第二静虑。应作是说。复有苾刍。先由如是诸行相状。寻伺寂静。内等净心一趣性。无寻无伺。定生喜乐。第二静虑具足住。彼不思惟如是诸行相状。乃至广说。乃至无所有处。应作是说。复有苾刍。先由如是诸行相状。超一切种识无边处。入无所有无所有处具足住。彼不思惟如是诸行相状。但思惟彼所得所趣受想行识。乃至广说。苾刍当知。乃至想定能办如是所应作事。复有非想非非想处。及灭尽定。我说于彼修定苾刍。应数入出彼修如是七依定时。所有无漏作意相应。心住等住。乃至心一境性。总名为定。亦名定根。亦名定力。亦名定觉支。亦名正定。是圣出世无漏无取道随行道俱有道随转。能正尽苦。作苦边际。诸有学者如所见诸行。思惟观察。令至究竟。于诸行中深见过患。于永涅槃深见功德。若阿罗汉。如解脱心。思惟观察。令至究竟。所有无漏作意相应。心住等住。乃至心一境性。是名定觉支

云何舍觉支。谓有苾刍。思惟断界离界灭界。由此发起心平等性。心正直性。心无警觉寂静住性。彼作是念。我今应于顺贪顺嗔顺痴诸法。离贪嗔痴。由此发起心平等性心正直性心无警觉寂静住性。复作是念。我今应于贪嗔痴法。心不摄受。由此发起心平等性心正直性心无警觉寂静住性。彼审思惟六顺舍法所有无漏作意相应。心平等性。心正直性。心无警觉寂静住性。总名为舍。亦名舍觉支。是圣出世无漏无取道随行道俱有道随转。能正尽苦。作苦边际。诸有学者如所见诸行。思惟观察。令至究竟。于诸行中。深见过患。于永涅槃。深见功德。若阿罗汉。如解脱心。思惟观察。令至究竟。所有无漏作意相应。心平等性。心正直性。心无警觉寂静住性。是名舍觉支

    杂事品第十六

一时薄伽梵。在室罗筏住逝多林给孤独园。尔时世尊告苾刍众。汝等若能永断一法。我保汝等定得不还一法。谓贪若永断者。我能保彼定得不还。如是嗔痴忿恨覆恼嫉悭诳谄无惭无愧慢过慢慢过慢我慢增上慢卑慢邪慢憍放逸傲愤发矫妄诡诈现相激磨以利求利恶欲大欲显欲不喜足不恭敬起恶言乐恶友不忍耽嗜遍耽嗜染贪非法。贪着贪恶贪有身见有见无有见贪欲嗔恚惛沉睡眠掉举恶作疑瞢愦不乐频申欠呿食不调性心昧劣性种种想不作意粗重抵突饕餮不和软性不调柔性不顺同类欲寻恚寻害寻亲里寻国土寻不死寻陵蔑寻假族寻愁叹苦忧扰恼。于此一法。若永断者。我能保彼定得不还。尔时世尊。为摄前义。而说颂曰

  贪所系有情　　数往诸恶趣
  智者能正断　　不还此世间

如是嗔痴乃至扰恼。一一别颂。如贪应知

云何贪。谓于欲境。诸贪等贪。执藏防护。坚着爱乐迷闷。耽嗜遍耽嗜。内缚悕求。耽湎苦集。贪类贪生。总名为贪。云何嗔。谓于有情。欲为损害。内怀栽杌。欲为扰恼。已嗔当嗔现嗔。乐为过患。极为过患。意极愤恚。于诸有情。各相违戾。欲为过患。已为过患。当为过患。现为过患。总名为嗔。云何痴。谓于前际无知。后际无知。前后际无知。于内无知。外无知内外无知。于业无知。异熟无知。业异熟无知。于善作业无知。恶作业无知。善恶作业无知。于因无知。因所生法无知。于佛无知。法无知。僧无知。于苦无知。集无知。灭无知。道无知。于善法无知。不善法无知。于有罪法无知。无罪法无知。于应修法无知。不应修法无知。于下劣法无知。胜妙法无知。于黑法无知。白法无知。于有敌对法无知。于缘生法无知。于六触处如实无知。如是无知无见。非现观黑闇愚痴。无明盲冥。罩网缠里。顽騃浑浊。障盖发盲。发无眼。发无智。发劣慧。障碍善品。令不涅槃。无明漏。无明瀑流。无明轭。无明毒根。无明毒茎。无明毒枝。无明毒叶。无明毒花。无明毒果。痴等痴极痴。欣等欣极欣。痴类痴生。总名为痴

云何忿。谓忿有二种。一属爱忿。二属非爱忿。属爱忿者。谓于父母兄弟姊妹妻妾男女。及余随一亲属朋友。所发生忿怒。有忿言。如何不与我此物。而与我如是物。如何不与我作此事。而与我作如是事。由此发生诸忿。等忿遍忿极忿。已忿当忿现忿。热极热。烟极烟。焰极焰。凶勃粗恶。心愤发。起恶色。出恶言。是名属爱忿。属非爱忿者。谓有一类。作是思惟。彼今于我欲为无义。欲为不利益。欲为不安乐。欲为不滋润。欲为不安隐。然彼于我已作无义。当作无义。现作无义。诸有于我欲为无义。乃至不安隐。而复于彼欲为有义。欲为利益。欲为安乐。欲为滋润。欲为安隐。然复于彼已作有义。当作有义。现作有义。诸有于我欲为有义。乃至安隐。而复于彼欲为无义。乃至不安隐。由此发生诸忿。等忿乃至起恶色出恶言。是名属非爱忿。此属爱非爱。总名为忿。云何恨。谓有一类。作是思惟。彼既于我欲为无义。广说如前。我当于彼亦如是作。此能发忿。从嗔而生。常怀愤结诸恨。等恨遍恨极恨。作业难回。为业缠缚。起业坚固。起怨起恨。心怨恨性。总名为恨。云何覆。谓有一类。破戒破见。破净命。破轨范。于本受戒不能究竟。不能纯净。不能圆满。彼既自觉所犯已久。作是思惟。我若向他。宣说开示施设建立所犯诸事。则有恶称恶誉。被弹被厌。或毁或举。便不为他恭敬供养。我宁因此堕三恶趣。终不自陈上所犯事。彼既怖得恶称恶誉。乃至怖失恭敬供养。于自所犯。便起诸覆等覆遍覆。隐等隐遍隐。护等护遍护。藏等藏遍藏。已覆当覆现覆。总名为覆。云何恼。谓有一类。于僧等中。因法非法。而兴斗讼。诸苾刍等为和息故。劝谏教诲。而固不受。此不受劝谏性。不受教诲性。极执性。极取性。左取性。不右取性。难劝舍性。拙应对性。师子执性。心蛆螫性。心佷戾性。总名为恼。云何嫉。谓有一类。见他获得恭敬供养尊重赞叹可爱五尘衣服饮食卧具医药及余资具。作是思惟。彼既已获恭敬等事。而我不得。由此发生诸戚极戚。苦极苦。妒极妒。嫉极嫉。总名为嫉。云何悭。谓悭有二种。一财悭。二法悭。财悭者。谓于诸所有可爱五尘衣服饮食卧具医药及余资具。障碍遮止令他不得。于自所有可爱资具。不施不遍施。不随遍施。不舍不遍舍。不随遍舍。心吝惜性。是名财悭。法悭者。谓所有素怛缆。毗奈耶。阿毗达磨。或亲教轨范教授教诫。或展转传来诸秘要法。障碍遮止令他不得。于自所有。如上诸法。不授与他。亦不为说。不施不遍施。不随遍施。不舍不遍舍。不随遍舍。心吝惜性。是名法悭。此财法悭。总名为悭。云何诳谓。于他所以。伪斗伪斛伪秤。诡言施诧诳诱。令他谓实。诸诳等诳遍诳极诳。总名为诳。云何谄。谓心隐匿性。心屈曲性。心洄复性。心沉滞性。心不显性。心不直性。心无堪性。总名为谄。云何无惭。谓无惭。无所惭。无别惭。无羞无所羞无别羞。无敬无敬性。无自在无自在性。于自在者。无怖畏转。总名无惭。云何无愧。谓无愧无所愧无别愧。无耻无所耻无别耻。于诸罪中。不怖不畏。不见怖畏。总名无愧。云何慢。谓于劣谓己胜。或于等谓己等由此起慢。已慢当慢。心举恃。心自取。总名为慢。云何过慢。谓于等谓己胜。或于胜谓己等。由此起慢。乃至心自取。总名过慢。云何慢过慢。谓于胜谓己胜。由此起慢。乃至心自取。总名慢过慢。云何我慢。谓于五取蕴等。随观见我或我所。由此起慢。乃至心自取。总名我慢。云何增上慢。谓未得谓得。未获谓获。未触谓触。未证谓证。由此起慢。乃至心自取。总名增上慢。云何卑慢。谓于多胜谓己少劣。由此起慢。乃至心自取总名卑慢。云何邪慢。谓己无德。而谓有德。由此起慢。乃至心自取。总名邪慢。云何憍。谓有一类。作是思惟。我之种姓。家族色力。工巧事业。若财若位。戒定慧等。随一殊胜。由此起憍极憍醉极醉闷极闷。心傲逸。心自取。起等起。生等生。高等高。举等举。心弥漫性。总名为憍。云何放逸。谓于断不善法集善法中。不修不习。不恒作。不常作。舍加行。总名放逸。云何傲。谓有一类。应供养者而不供养。应恭敬者而不恭敬。应尊重者而不尊重。应赞叹者而不赞叹。应问讯者而不问讯。应礼拜者而不礼拜。应承迎者而不承迎。应请坐者而不请坐。应让路者而不让路。由此发生。身不卑屈。不等卑屈。不极卑屈。身傲心傲。自傲诞性。总名为傲。云何愤发。谓身擒害性。心擒害性。身战怒性。心战怒性。身愤发心愤发。已愤发。当愤发。总名愤发

云何矫妄。谓多贪者。为供养故。为资具故。为恭敬故。为名誉故。拔发燂髭。卧灰露体。徐行低视。高声现威。显自伎能。苦行等事。总名矫妄。云何诡诈。谓多贪者。为得如前供养等故。往至他家作如是语。汝等今者善得人身。诸有诵持经律对法。善说法要。妙闲传记。制造疏论。乐阿练若。乐但三衣。乐常旋礼。乐粪扫衣。乐行乞食。乐一钵食。乐一受食。乐一坐食。乐居树下。乐居露地。乐处冢间。乐坐不卧。乐随得坐。得不净观。得持息念。得四静虑。得四无量。得四无色。得四圣果。得六通慧。得八解脱。此等贤圣。但入汝家。皆得汝等供养恭敬尊重赞叹。为作依怙。我之行德未减前人。今至汝家。固望同彼。是名诡诈。复有诡诈。谓多贪者。为得如前供养等故。往至他家作如是语。汝应于我如父母想。我亦于汝如男女想。自今已后。共为亲眷。忧喜荣辱咸悉是同。先来世间。泛号于我。为沙门释子。从今向去。皆悉称我为汝家沙门。凡我所须资身众具。衣药等物。汝皆见供。汝若不能。我脱别往余敬信家。汝岂不辱。如是所作。种种不实。方便语言。总名诡诈。云何现相。谓多贪者。为得如前供养等故。往至他家作如是语。贤士贤女。此衣此钵。此坐卧具。此衫裙等。我若得之。甚为济要。当常宝护。以福于汝。除汝能舍。谁当见惠。作此方便而获利者。总名现相。云何激磨。谓多贪者。为得如前供养等故。往至他家。作如是语。汝父母等。具足净信戒闻舍惠。乘斯善业。已生人天。及得解脱。而汝无信戒闻舍慧。既无善业。后若命终。定生恶趣。其如之何。如是赞毁以求利者。总名激磨。云何以利求利。谓有一类。先从余家。求得衣钵。及余随一支身命缘。持往余家。而现之曰。彼某甲家。与我此物。然彼施主。于长时中。恒资给我衣钵等物。汝家若能如彼施者。便亦是我所依止处。因前方便。获后利者。如是总名以利求利。云何恶欲。谓有一类。实不诵持经律对法。广说乃至。实非证得八解脱者。而欲令他知已实是诵持经律对法等者。因斯而得供养恭敬尊重赞叹。为作依怙。又自实无出家远离所生善法。而为他人。宣说开示显己证得。如斯等类。总名恶欲。云何大欲。谓多贪者。为得广大财利等故。而起于欲。已欲当欲。总名大欲。云何显欲。谓有一类。实是诵持经律对法。广说乃至。得持息念。及得预流一来果者。但无名誉。人所不知。意欲令他。知有此德。因斯便获供养恭敬尊重赞叹。为作依怙。又自实有出家远离所生善法。而为他人。宣说开示显己证得。如斯等类。总名显欲。云何不喜足。谓有一类。于已获得色香味触及余资具。不生喜足。复悕复欲。复乐复求。总名不喜足。云何不恭敬。谓有一类。若亲教亲教类。轨范轨范类。及余随一尊重可信。往还朋友。如法告言。汝从今去。勿坏身业。勿坏语业。勿坏意业。勿行不应行处。勿亲近恶友。勿作三恶趣业。如是教诲。称法应时。于所修道。随顺磨莹。增长严饰。宜便常委。助伴资粮。而彼有情。不欣不喜。不爱不乐。于师等言。违戾左取。而不右取。毁訾非拨。诸如是等。名不恭敬。云何起恶言。谓有一类。若亲教亲教类。轨范轨范类。及余随一尊重可信。往还朋友。如法告言。汝从今去。勿坏身业。勿坏语业。勿坏意业。勿行不应行处。勿亲近恶友。勿作三恶趣业。如是教诲。称法应时。于所修道。随顺磨莹。增长严饰。宜便常委。助伴资粮。而彼有情。不欣不喜。不爱不乐。于师等言。违戾左取。而不右取。毁訾非拨。及于师等。起勃詈言。诸如是等名起恶言。云何乐恶友。谓有一类。好近恶友。言恶友者。谓诸屠羊屠鸡屠猪。捕鸟捕鱼。猎兽劫盗。魁脍典狱。缚龙煮狗。及罝弶等。是名恶友。复有一类。毁犯尸罗。习行恶法。内怀腐败。外现坚贞。类秽蜗牛。螺音狗行。实非沙门。自称沙门。实非梵行。自称梵行。亦名恶友。于如是等诸恶友所。亲近承事。随顺爱乐。名乐恶友。云何不忍。谓有一类。不能堪忍寒热饥渴风雨蚊虻蛇蝎恶触。及余苦事。复有一类。于他暴恶。能发自身猛利刚犷切心夺命辛楚苦受凶勃秽言。不能堪忍。即此及前。总名不忍。云何耽嗜遍耽嗜。谓下品贪嗔痴缠。名耽嗜。即此中品。名遍耽嗜。复次中品贪嗔痴缠。名耽嗜。即此上品。名遍耽嗜。云何染贪。谓于诸欲诸贪等贪。乃至贪类贪生。总名染贪。云何非法贪。谓于母女姊妹。及余随一亲眷。起贪等贪。执藏防护。坚着爱染。名非法贪。云何着贪。于自财物。及所摄受。起贪等贪。执藏防护。坚着爱染。是名著贪。云何恶贪谓于他财物。及所摄受。起贪等贪。执藏防护。坚着爱染。是名恶贪。复有恶贪规他生命。贪皮角等。饮血啖肉。如是二种。总名恶贪。云何有身见。谓于五取蕴。起我我所想。由此生忍乐惠观见。名有身见。云何有见。谓于我及世间。起常恒想。由此生忍乐慧观见。是名有见。云何无有见。谓于我及世间。起非常非恒想。由此生忍乐慧观见。名无有见。云何贪欲。谓于诸欲境。起欲乐欣喜。求趣悕望。是名贪欲。有作是说。于诸欲境。诸贪等贪。乃至贪类贪生。总名贪欲。云何嗔恚。谓于诸有情。欲为损害。内怀栽杌。乃至现为过患。总名嗔恚。云何惛沈。谓身重性。心重性。乃至[夢-夕+登]瞢愦闷。总名惛沈。云何睡眠。谓诸眠梦。不能任持。心昧略性。总名睡眠。云何掉举。谓心不寂静。掉举等掉举。心掉举性。总名掉举。云何恶作。谓心变心懊。心悔我恶作。恶作性。总名恶作。云何疑。谓于佛法僧。及苦集灭道。生起疑惑。二分二路。乃至非现一趣。总名为疑。云何瞢愦。谓身重性。心重性。身无堪任性。心无堪任性。身瞢愦性。心瞢愦性。已瞢愦。当瞢愦。现瞢愦。总名瞢愦。云何不乐。谓有一类。得好亲教亲教类。轨范轨范类。及余随一尊重可信。往还朋友。教诫教授。系念思惟。房舍卧具。而心不喜。不爱不乐。怅望惨戚。总名不乐。云何频申欠呿。谓身低举手足卷舒。名曰频申。鼻面开蹙。唇口喎张。名为欠呿。云何食不调性。谓以不食。或食过量。或食匪宜。而生苦受。总名食不调性。云何心昧劣性。谓心惛昧劣弱卷局。总名心昧劣性。云何种种想。谓有盖缠者。所有染污。色声香味触想。不善想。非理所引想。障碍定想。总名种种想。云何不作意。谓于出家远离所生善法。不引发。不忆念。不思惟。不已思惟。不当思惟。心无警觉。总名不作意。云何粗重。谓身重性。心重性。身无堪任性。心无堪任性。身刚强性。心刚强性。身不调柔性。心不调柔性。总名粗重。云何抵突。谓有一类。于授食时。索熟与生。索生与熟。索粗与细。索细与粗。与不平等。与不如法。于识不识。而与不与。于中数起相违语言。是名抵突。复有一类。若亲教亲教类。轨范轨范类。及余随一尊重可信。往还朋友。告言。具寿。汝于如是如是事业。应次第作。彼作是念。何事众业。令我如是次第而作。于中数起相违语言。是名抵突。复有一类。或自来谢过。或他教谢过。或自有启请。或他教启请。于中数起相违语言。是名抵突。如是或因料理衣服。营造事业。于中数起相违语言。总名抵突。云何饕餮。谓有一类。分财利时。舍一取一。情贪无定。是名为饕。前后食时。往饮食所。尝此歠彼。好恶不定。是名为餮。此即及前。总名饕餮。云何不和软性。谓心刚强。心坚鞕。心[怡-台+龍]悷。心不明净。心不润滑。心不柔软。心无堪任。总名不和软性。云何不调柔性。谓身刚强。身坚鞕。身[怡-台+龍]悷。身不明净。身不润滑。身不柔软。身无堪任。总名不调柔性。云何不顺同类。谓有一类。于亲教亲教类。轨范轨范类。及余随一尊重可信。往还朋友。不正随顺。是名不顺同类

云何欲寻。谓欲贪相应诸心寻求。遍寻求。近寻求。心显了。极显了。现前显了。推度构画。思惟分别。总名欲寻。云何恚寻。谓嗔恚相应诸心寻求遍寻求。乃至思惟分别。总名恚寻。云何害寻。谓害相应诸心寻求遍寻求。乃至思惟分别。总名害寻。云何亲里寻。谓于亲里。欲令安乐。得胜朋伴。无有恼害。成就一切无恼害法。王臣爱重。国人敬慕。五谷丰熟。降泽以时。缘此等故。起心寻求遍寻求。乃至思惟分别。总名亲里寻。云何国土寻。谓于所爱国土人众。欲令安乐。广说乃至。降泽以时。缘此等故。起心寻求遍寻求。乃至思惟分别。总名国土寻。云何不死寻。谓有一类。作是思惟。我于佛教所说胜定。且未修习。先应诵持经律对法。为诸有情。宣说法要。学诸传记制造疏论。居阿练若。但持三衣。广说乃至。随得而坐。作此事已。然后习定。复有一类。作是思惟。我于佛教所说胜定。且未修习。先应历观山川国土园林池沼岩窟冢间。礼旋制多。游观诸寺。为此事已。然后习定。复有一类。作是思惟。我于佛教所说胜定。且未修习。待过七年六年五年四年三年二年一年。或过七月乃至一月。或过七日乃至一日。或过此昼。或过此夜。过此时已。然后习定。如是思惟。于自身命。不了危脆。起心寻求遍寻求。乃至思惟分别。总名不死寻。云何陵蔑寻。谓有一类。作是思惟。我之种姓。家族色力。工巧事业。若财若位。戒定慧等。随一殊胜。恃此方他。而生陵蔑。由此等故。起心寻求遍寻求。乃至思惟分别。总名陵蔑寻。云何假族寻。谓有一类。于非亲族。托为亲族。欲令安乐。得胜朋伴。无有恼害。成就一切无恼害法。王臣爱重。国人敬慕。五谷丰熟。降泽以时。缘此等故。起心寻求遍寻求。乃至思惟分别。总名假族寻

云何愁。谓有一类。或因父母兄弟姊妹师友死故。或因亲族灭亡都尽。或因财位一切丧失。便发自身猛利刚犷切心夺命辛楚苦受彼于尔时。心热等热。内热遍热。便发于愁。已愁当愁。心中愁箭。总名为愁。云何叹。谓有一类。或因父母兄弟姊妹师友死等。便发自身乃至苦受。彼于尔时。心热乃至心中愁箭。由此缘故。而伤叹言。苦哉苦哉。我父我母。广说乃至。我财我位。如何一旦。忽至于此。其中所有伤怨言词。种种语业。总名为叹。云何苦。谓五识相应不平等受。总名为苦。云何忧。谓意识相应不平等受。总名为忧。云何扰恼。谓心扰恼。已扰恼。当扰恼。扰恼性。扰恼类。总名扰恼。从贪嗔痴。乃至扰恼。皆名杂事。于此杂事。若永断一。定得不还。以一断时。余容随断。故佛保彼定得不还

说一切有部法蕴足论卷第九阿毗达磨法蕴足论卷第十

        尊者大目干连造

        三藏法师玄奘奉　诏译

    根品第十七

一时薄伽梵。在室罗筏住逝多林给孤独园。时有梵志。名曰生闻。来诣佛所。合掌恭敬。而白佛言。我欲少问。乔答摩尊。唯愿听许。尔时世尊告彼梵志。恣汝意问。吾当为说。梵志问言。根有几种。世尊告曰。有二十二。何等二十二。谓眼根。耳根。鼻根。舌根。身根。意根。女根。男根。命根。乐根。苦根。喜根。忧根。舍根。信根。精进根。念根。定根。慧根。未知当知根。已知根。具知根。此二十二。摄一切根。时彼梵志。闻佛所说。欢喜踊跃。恭敬而去

云何眼根。谓眼于色。已正当见。及彼同分。是名眼根。又眼增上发眼识。于色已正当了别及彼同分。是名眼根。又眼于色。已正当碍。及彼同分。是名眼根。又眼于色。已正当行。及彼同分。是名眼根。如是过去未来现在诸所有眼。名为眼根。亦名所知。所识。所通达。所遍知。所断所解。所见所得。所觉所现等觉。所了所等了。所观所等观。所审察。所决择。所触所等触。所证所等证。此复云何。谓四大种所造净色。或地狱。或傍生。或鬼界。或天或人或中有。及修所成。所有名号。异语增语。想等想。施设言说。谓名眼。名眼处。名眼界。名眼根。名见名道路。名引导。名白名净。名藏名门。名田名事。名流名池。名海名疮。名疮门。名此岸。如是眼根。是内处摄。云何耳根。谓耳于声。已正当闻。及彼同分。是名耳根。又耳增上发耳识。于声已正当了别。及彼同分。是名耳根。又耳于声。已正当碍。及彼同分。是名耳根。又耳于声。已正当行。及彼同分。是名耳根。如是过去未来现在诸所有耳。名为耳根。亦名所知。乃至所等证。此复云何。谓四大种所造净色。或地狱。乃至及修所成所有名号。异语增语。想等想。施设言说。谓名耳。名耳处。名耳界。名耳根。名闻名道路。乃至名此岸。如是耳根。是内处摄。云何鼻根。谓鼻于香。已正当嗅。及彼同分。是名鼻根。鼻根增上发鼻识。于香已正当了别。及彼同分。是名鼻根。又鼻于香。已正当碍。及彼同分。是名鼻根。又鼻于香。已正当行。及彼同分。是名鼻根。如是过去未来现在诸所有鼻。名为鼻根。亦名所知。乃至所等证。此复云何。谓四大种所造净色。或地狱。乃至或中有。非修所成。所有名号。异语增语。想等想。施设言说。谓名鼻。名鼻处名鼻界。名鼻根。名嗅名道路。乃至名此岸。如是鼻根。是内处摄。云何舌根。谓舌于味。已正当尝。及彼同分。是名舌根。又舌增上发舌识。于味已正当了别。及彼同分。是名舌根。又舌于味。已正当碍。及彼同分。是名舌根。又舌于味。已正当行。及彼同分。是名舌根。如是过去未来现在诸所有舌。名为舌根。亦名所知。乃至所等证。此复云何。谓四大种所造净色。或地狱。乃至中有。非修所成。所有名号。异语增语。想等想。施设言说。谓名舌。名舌处。名舌界。名舌根。名尝名道路。乃至名此岸。如是舌根。是内处摄。云何身根。谓身于触。已正当觉。及彼同分。是名身根。又身增上发身识。于触已正当了别。及彼同分。是名身根。又身于触已正当碍。及彼同分。是名身根。又身于触。已正当行。及彼同分。是名身根。如是过去未来现在诸所有身。名为身根。亦名所知。乃至所等证。此复云何。谓四大种所造净色。或地狱。乃至中有。非修所成。所有名号。异语增语。想等想。施设言说。谓名身。名身处。名身界。名身根。名觉名道路。乃至名此岸。如是身根。是内处摄。云何女根。谓女女体女性。女势分。女作用。此复云何。谓脐轮下。膝轮上。所有肉身。筋脉流注。若于是处。与男交会。发生平等领纳乐受。是名女根。云何男根。谓男男体男性。男势分。男作用。此复云何。谓脐轮下。膝轮上。所有肉身。筋脉流注。若于是处。与女交会。发生平等领纳乐受。是名男根。云何命根。谓彼彼有情。在彼彼有情聚中。不移不转。不破不没。不失不退寿住存活。护随护。转随转。是命。是命根。是名命根

云何意根。谓意于法。已正当知。及彼同分。是名意根。又意增上发意识。于法已正当了别。及彼同分。是名意根。又意于法。已正当碍。及彼同分。是名意根。又意于法。已正当行。及彼同分。是名意根。如是过去未来现在诸所有意。名为意根。亦名所知。乃至等所证。此复云何。谓心意识。或地狱。乃至或中有。或修所成。所有名号。异语增语。想等想。施设言说。谓名意。名意处。名意界。名意根。名知名道路。乃至名此岸。如是意根是内处摄。云何乐根。谓顺乐触所生身乐心乐。平等受。受所摄。是名乐根。复次修第三静虑。顺乐触所生心乐。平等受。受所摄。是名乐根。云何苦根。谓顺苦触所生身苦。不平等受。受所摄。是名苦根。云何喜根。谓顺喜触所生心喜。平等受。受所摄。是名喜根。复次修初二静虑。顺喜触所生心喜。平等受。受所摄。是名喜根。云何忧根。谓顺忧触所生心忧。不平等受。受所摄。是名忧根。云何舍根。谓顺舍触所生身舍心舍。非平等非不平等受。受所摄。是名舍根。复次修未至定静虑中间第四静虑。及无色定。顺不苦不乐触所生心舍。非平等非不平等受。受所摄。是名舍根。云何信根。谓依出家远离所生善法。所起诸信信性。现前信性。随顺印可。爱慕爱慕性。心澄净。是名信根。复次学信无学信。及一切非学非无学信。皆名信根。云何精进根。谓依出家远离所生善法。所起勤精进。勇健势猛。炽盛难制。励意不息。是名精进根。复次学精进无学精进。及一切非学非无学精进。皆名精进根。云何念根。谓依出家远离所生善法。所起诸念随念。专念忆念。不忘不失。不遗不漏。不失法性。心明记性。是名念根。复次学念无学念。及一切善非学非无学念。皆名念根。云何定根。谓依出家远离所生善法。所起心住等住。近住安住。不散不乱。摄正等持。心一境性。是名定根。复次学定无学定。及一切善非学非无学定。皆名定根。云何慧根。谓依出家远离所生善法。所起于法简择。极简择。最极简择。解了等了近了。机黠通达。审察聪睿。觉明慧行。毗钵舍那。是名慧根。复次学慧无学慧。及一切善非学非无学慧。皆名慧根。云何未知当知根。谓已入正性离生者。所有学慧慧根。及随信随法行。于四圣谛。未现观。为现观故诸根转。是名未知当知根。云何已知根。谓已见谛者。所有学慧慧根。及信胜解。见至身证。于四圣谛。已现观。而现观为断余烦恼故。诸根转。是名已知根。云何具知根。谓阿罗汉。所有无学慧慧根。及慧解脱。俱解脱。于四圣谛。已现观。而现观。为得现法乐住故。诸根转。是名具知根

    处品第十八

一时薄伽梵。在室罗筏住逝多林给孤独园。时有梵志。名曰生闻。来诣佛所。合掌恭敬。以诸爱语。慰问世尊。佛亦爱言。而慰问彼。相慰问已。退坐一面。曲躬合掌。而白佛言。我欲少问。乔答摩尊。唯愿听许。略为宣说。尔时世尊告彼梵志。恣汝意问。吾当为说。梵志问言。一切法者。何谓一切。世尊告曰。一切法者。谓十二处。何等十二。谓眼处。色处。耳处。声处。鼻处。香处。舌处。味处。身处。触处。意处。法处。是谓十二。若有说言。此非一切。言一切者。更别有法。彼但有言。而无实事。若还诘问。便不能了。彼后审思。自生迷闷。以一切法。非彼境故。时彼梵志。闻佛所说。欢喜踊跃。恭敬而去

云何眼处。谓如眼根。应说其相。云何色处。谓色为眼。已正当见。及彼同分。是名色处。又色为眼增上发眼识。已正当了别。及彼同分。是名色处。又色于眼。已正当碍。及彼同分。是名色处。又色为眼。已正当行。及彼同分。是名色处。如是过去未来现在诸所有色名为色处。亦名所知。乃至所等证。此复云何。谓四大种所造。青黄赤白云烟尘雾长短方圆高下。正不正影光明暗空一显色。相杂红紫。碧绿皂褐。及余所有。眼根所见。眼识所了。所有名号。异语增语。想等想。施设言说。谓名色。名色界。名色处。名彼岸。如是色处。是外处摄。云何耳处。谓如耳根。应说其相。云何声处。谓声为耳。已正当闻。及彼同分。是名声处。又声为耳增上发耳识。已正当了别。及彼同分。是名声处。又声于耳。已正当碍。及彼同分。是名声处。又声为耳。已正当行。及彼同分。是名声处。如是过去未来现在诸所有声。名为声处。亦名所知。乃至所等证。此复云何。谓四大种所造。象声马声。车声步声。蠡声铃声。大小鼓声。歌声咏声。赞声梵声。及四大种互相触声。于昼夜分。语言音声。及余所有耳根所闻。耳识所了。所有名号。异语增语。想等想。施设言说。谓名声。名声界。名声处。名彼岸。如是声处。是外处摄。云何鼻处。谓如鼻根应说其相。云何香处。谓香为鼻。已正当嗅。及彼同分。是名香处。又香为鼻。增上发鼻识。已正当了别。及彼同分。是名香处。又香于鼻。已正当碍。及彼同分。是名香处。又香为鼻。已正当行。及彼同分。是名香处。如是过去未来现在诸所有香。名为香处。亦名所知。乃至所等证。此复云何。谓四大种所造。根香茎香。枝香叶香。花香果香。好香恶香。平等香。及余所有鼻根所嗅。鼻识所了。所有名号。异语增语。想等想。施设言说。谓名香。名香界。名香处。名彼岸。如是香处。是外处摄。云何舌处。谓如舌根。应说其相。云何味处。谓味为舌。已正当尝。及彼同分。是名味处。又味为舌增上发舌识。已正当了别。及彼同分。是名味处。又味于舌。已正当碍。及彼同分。是名味处。又味为舌。已正当行。及彼同分。是名味处。如是过去未来现在诸所有味。名为味处。亦名所知。乃至所等证。此复云何。谓四大种所造。根味茎味。枝味叶味。花味果味。食味饮味。及诸酒味。苦味酢味。甘味辛味。碱味淡味。可意味不可意味。顺舍处味。及余所有舌根所尝。舌识所了。所有名号。异语增语。想等想。施设言说。谓名味。名味界。名味处。名彼岸。如是味处。是外所摄。云何身处。谓如身根。应说其相。云何触处。谓触为身。已正当觉。及彼同分。是名触处。又触为身增上发身识。已正当了别。及彼同分。是名触处。又触于身。已正当碍。及彼同分。是名触处。又触为身。已正当行。及彼同分。是名触处。如是过去未来现在。诸所有触。名为触处。亦名所知。乃至所等证。此复云何。谓四大种。及四大种所造。滑性。涩性。轻性。重性。冷暖饥渴。及余所有身根所觉身识所了。所有名号。异语增语。想等想。施设言说。谓名触。名触界。名触处。名彼岸。如是触处。是外所摄。云何意处。谓如意根。应说其相。云何法处。谓法为意。已正当知。是名法处。又法为意增上发意识已正当了别。是名法处。又法于意。已正当碍。是名法处。又法为意。已正当行。是名法处。如是过去未来现在诸所有法。名为法处。亦名所知。乃至所等证。此复云何。谓受想思触作意欲胜解。信精进念定慧。寻伺放逸不放逸。善根不善根无记根。一切结缚随眠随烦恼缠。诸所有智见现观。得无想定灭定无想事。命根众同分住。得事得处得生老住无常。名身句身文身。虚空择灭非择灭。及余所有意根所知意识所了。所有名号。异语增语。想等想。施设言说。谓名法。名法界。名法处。名彼岸。如是法处。是外处摄

    蕴品第十九

一时薄伽梵。在室罗筏住逝多林。给孤独园。尔时世尊。告苾刍众。有五种蕴。何等为五。谓色蕴。受蕴。想蕴。行蕴。识蕴。是名五蕴。云何色蕴。谓诸所有色。一切皆是四大种。及四大种所造。是名色蕴。云何受蕴。谓诸受等受。别受受性。受所摄。是名受蕴。复有二受。说名受蕴。谓身受心受。云何身受。谓五识身相应诸受。乃至受所摄。是名身受。云何心受。谓意识相应诸受。乃至受。所摄。是名心受。复有二受。说名受蕴。谓有味受。无味受。云何有味受。谓有漏作意相应诸受。乃至受所摄。是名有味受。云何无味受。谓无漏作意相应诸受。乃至受所摄。是名无味受。有作是说。欲界作意相应受。名有味受。色无色界作意相应受。名无味受。今此义中。有漏作意相应受。名有味受。无漏作意相应受。名无味受。如有味受无味受。如是堕受。不堕受。耽嗜依受出离依受。顺结受。不顺结受。顺取受。不顺取受。顺缠受。不顺缠受。世间受。出世间受。亦尔。复有三受。说名受蕴。谓乐受。苦受。不苦不乐受。云何乐受。谓顺乐触所生身乐心乐平等受。受所摄。是名乐受。复次修初第二第三静虑。顺乐受触所起心乐平等受。受所摄。是名乐受。云何苦受。谓顺苦触所生身苦心苦不平等受。受所摄。是名苦受。云何不苦不乐受。谓顺不苦不乐触所生身舍心舍非平等非不平等受。受所摄。是名不苦不乐受。复次修未至定。静虑中间。第四静虑。及无色定。顺不苦不乐触所生心舍非平等非不平等受。受所摄。是名不苦不乐受。复有四受。说名受蕴。谓欲界受。色界受。无色界受。不系受。云何欲界受。谓欲界作意相应诸受。乃至受所摄。是名欲界受。云何色界受。谓色界作意相应诸受。乃至受所摄。是名色界受。云何无色界受。谓无色界作意相应诸受。乃至受所摄。是名无色界受。云何不系受。谓无漏作意相应诸受。乃至受所摄。是名不系受。复有五受。说为受蕴。谓乐受。苦受。喜受。忧受。舍受。如是五受。广说如根品。复有六受。说为受蕴。谓眼触所生受。耳鼻舌身意触所生受。云何眼触所生受。谓眼及色为缘生眼识。三和合故生触。触为缘故生受。此中眼为增上。色为所缘。眼触为因。眼触为等起。是眼触种类。是眼触所生。与眼触所生作意相应。于眼识所了别色诸受。乃至受所摄。是名眼触所生受。如是耳鼻舌身意触所生受。广说亦尔。是名受蕴。如受蕴。如是想蕴识蕴。如其所应。广说亦尔。云何行蕴。谓行蕴有二种。一心相应行蕴。二心不相应行蕴。云何心相应行蕴。谓思触作意。广说乃至。诸所有智见现观。复有所余如是类法。与心相应。是名心相应行蕴。云何心不相应行蕴。谓得无想定。广说乃至文身。复有所余如是类法。不与心相应。是名心不相应行蕴。如是心相应行蕴及心不相应行蕴总名行蕴

    多界品第二十之一

一时薄伽梵。在室罗筏。住逝多林给孤独园。时阿难陀。独居静室。作是思惟。诸起怖畏。及起灾患扰恼事者。皆是愚夫。非诸智者。既思惟已。于日后分。从静室出。往世尊所。顶礼双足。退住一面。以所思事。具白世尊。佛印可言。如是如是。诸起怖畏。及起灾患扰恼事者。皆是愚夫。非诸智者。如置火在干芦草舍。楼堂台观。亦被焚烧。愚夫亦尔。以无智故。起诸怖畏及灾患等。庆喜当知。过去未来现在。怖畏灾患扰恼。皆愚夫生。非诸智者。以诸智者不起彼故。庆喜当知。愚夫有怖畏智者无怖畏。愚夫有灾患。智者无灾患。愚夫有扰恼。智者无扰恼。是故庆喜应知。愚夫及智者。法知已远离诸愚夫法。于智者法。应正受行。阿难陀言。齐何施设诸愚夫数。佛言。若有于界处蕴。及于缘起。处非处法不善巧者。是愚夫数。阿难陀言。齐何施设诸智者数。佛言。若有于界处蕴。及于缘起。处非处法。得善巧者。是智者数。阿难陀言。云何智者于界善巧。佛言。智者于十八界。如实知见。是界善巧。谓如实知见。眼界色界眼识界。耳界声界耳识界。鼻界香界鼻识界。舌界味界舌识界。身界触界身识界。意界法界意识界。复于六界。如实知见。是界善巧。谓如实知见地界水界火界风界空界识界。复于六界。如实知见。是界善巧。谓如实知见欲界恚界害界无欲界无恚界无害界。复于六界。如实知见。是界善巧。谓如实知见乐界苦界。喜界忧界舍界无明界。复于四界。如实知见。是界善巧。谓如实知见受界想界行界识界。复于三界。如实知见。是界善巧。谓如实知见欲界色界无色界。复于三界。如实知见。是界善巧。谓如实知见色界无色界灭界。复于三界。如实知见。是界善巧。谓如实知见过去界未来界现在界。复于三界。如实知见。是界善巧。谓如实知见劣界中界妙界。复于三界。如实知见是界善巧。谓如实知见善界不善界无记界。复于三界。如实知见。是界善巧。谓如实知见学界无学界非学非无学界。复于二界。如实知见。是界善巧。谓如实知见有漏界无漏界。复于二界。如实知见。是界善巧。谓如实知见有为界无为界。是名智者于界善巧。阿难陀言。云何智者于处善巧。佛言。智者于十二处。如实知见。是处善巧。谓如实知见眼处色处耳处声处鼻处香处舌处味处身处触处意处法处。是名智者于处善巧。阿难陀言。云何智者于蕴善巧。佛言。智者于五蕴。如实知见。是蕴善巧。谓如实知见色蕴受蕴想蕴行蕴识蕴。是名智者于蕴善巧。阿难陀言。云何智者于缘起善巧。佛言。智者于十二支缘起顺逆。如实知见。是缘起善巧。谓如实知见依此有彼有。此生故彼生。谓无明缘行。行缘识。识缘名色。名色缘六处。六处缘触。触缘受。受缘爱。爱缘取。取缘有。有缘生。生缘老死。发生愁叹苦忧扰恼。如是便集纯大苦蕴。及如实知依此无彼无。此灭故彼灭。谓无明灭故行灭。行灭故识灭。识灭故名色灭。名色灭故六处灭。六处灭故触灭。触灭故受灭。受灭故爱灭。爱灭故取灭。取灭故有灭。有灭故生灭。生灭故老死愁叹苦忧扰恼灭。如是便灭纯大苦蕴。是名智者于缘起善巧。阿难陀言。云何智者于处非处善巧。佛言。智者于处非处。如实知见是处非处善巧。谓如实知。无处无容身语意恶行。感可爱可乐可欣可意异熟。有处有容身语意恶行。感不可爱不可乐不可欣不可意异熟。无处无容身语意妙行。感不可爱不可乐不可欣不可意异熟。有处有容身语意妙行。感可爱可乐可欣可意异熟。无处无容行身语意恶行已。由此因缘。身坏命终。生诸善趣。有处有容行身语意恶行已。由此因缘。身坏命终。堕诸恶趣。无处无容行身语意妙行已。由此因缘。身坏命终。堕诸恶趣。有处有容行身语意妙行已。由此因缘。身坏命终。生诸善趣。是处非处善巧。复如实知见无处无容非前非后。有二轮王生一世界。有处有容。非前非后。有一轮王。生一世界。无处无容。非前非后。有二如来。生一世界。有处有容。非前非后。有一如来。生一世界。是处非处善巧。复如实知见无处无容女作轮王帝释魔王梵王。及证独觉菩提。或证无上正等菩提。有处有容男作轮王帝释魔王梵王。及证独觉菩提。或证无上正等菩提。是处非处善巧。复如实知见无处无容具圣见者故思害母害父。害阿罗汉。破和合僧。及起恶心。出佛身血。有处有容诸异生者。作五无间。无处无容具圣见者。故思断众生命。有处有容诸异生者。故思断众生命。无处无容具圣见者。故思越诸学处。有处有容诸异生者。故思越诸学处。无处无容具圣见者。舍胜学处趣劣学处。或求外道为师。或求外道为福田。或瞻仰外道沙门婆罗门面。或种种占卜诸吉祥事。执为清净。或受第八有。有处有容诸异生者。有如是事。是处非处善巧。复如实知见无处无容。未断五盖。令心染污。令慧力羸。障碍道品。违涅槃者。心善安住四念住中。有处有容已断五盖。令心染污令慧力羸。障碍道品。违涅槃者。心善安住四念住中。无处无容未断五盖。广说乃至违涅槃者。心未善住四念住中。而能修习七等觉支。有处有容已断五盖。广说乃至违涅槃者。心已善住四念住中。乃能修习七等觉支。无处无容未断五盖。广说乃至违涅槃者。心未善住四念住中。而能修习七等觉支。而证声闻独觉无上菩提。有处有容已断五盖。广说乃至违涅槃者。心已善住四念住中已。能修习七等觉支。乃能证得声闻独觉无上菩提。是名智者于处非处善巧。阿难陀曰。今此法门。其名何等。云何奉持。佛告庆喜。今此法门。名为四转。亦名大法镜。亦名甘露鼓。亦名多界。应如是持。时阿难陀。欢喜敬受

云何眼界。谓如眼根。云何色界。谓如色处。云何眼识界。谓眼色为缘所生眼识。此中眼为增上。色为所缘。于眼所识色。诸了别异了别各别了别色。是名眼识界。余五三界。随其所应。广说亦尔

云何地界。谓地界有二种。一内。二外。云何内地界。谓此身内所有各别坚性坚类有执有受。此复云何。谓发毛爪齿。乃至粪秽。复有所余身内各别坚性坚类有执有受。是名内地界。云何外地界。谓此身外诸外所摄坚性坚类无执无受。此复云何。谓大地山。诸石瓦砾蚌蛤蜗牛。铜铁锡镴。末尼真珠。琉璃螺贝。珊瑚璧玉。金银石藏杵藏。颇胝迦。赤珠右旋。沙土草木。枝叶花果。或复有地依水轮住。复有所余在此身外坚性坚类无执无受。是名外地界。前内此外。总名地界。云何水界。谓水界有二种。一内。二外。云何内水界。谓此身内所有各别湿性湿类有执有受。此复云何。谓诸泪汗。乃至小便。复有所余身内各别湿性湿类有执有受。是名内水界。云何外水界。谓此身外诸外所摄湿性湿类无执无受。此复云何。谓根茎枝叶花果等汁露。酒乳酪酥油蜜糖。池沼陂湖殑伽河。盐母那河。萨剌渝河。頞氏罗筏底河。莫呬河。东海西海南海北海。四大海水。或复有水依风轮住。复有所余在此外湿性湿类无执无受。是名外水界。前内此外。总名水界。云何火界。谓火界有二种。一内。二外。云何内火界。谓此身内所有各别暖性暖类有执有受。此复云何。谓此身中诸所有热等热遍热。由此所食所啖所饮。正易消化。若此增盛。令身燋热。复有所余身内各别暖性暖类有执有受。是名内火界。云何外火界。谓此身外诸外所摄暖性暖类无执无受。此复云何。谓地暖火日药末尼宫殿星宿火聚灯焰烧村烧城烧川烧野烧。十二十三十四十五十百千。或无量担。薪草等火炽盛烔然。或在山泽河池岩窟房舍殿堂楼观。草木根茎枝叶花果等暖。复有所余热性热类无执无受。是名外火界。前内此外。总名火界。云何风界。谓风界有二种。一内二外。云何内风界。谓此身内所有各别动性动类有执有受。此复云何。谓此身中。或上行风。或下行风。或傍行风。胁风背风。胸风肚风。心风脐风。嗢钵罗风。荜钵罗风。刀风剑风。针风结风。缠风掣风。努风。强风。随支节风。入出息风。复有所余身内各别动性动类有执有受。是名内风界。云何外风界。谓此身外诸外所摄动性动类无执无受。此复云何。谓东风西风南风北风有尘风无尘风旋风暴风吠岚婆风小风大风无量风风轮风依空行风。复有所余动性动类无执无受。是名外风界。前内此外。总名风界。云何空界。谓空界有二种。一内。二外。云何内空界。谓此身内所有各别空性空类有执有受。此复云何。谓此身中随皮肉血骨髓等空眼穴耳穴鼻穴面门咽喉心肠肠肚等穴。由此通贮所饮所食。及令下弃。复有所余身内各别空性空类。是名内空界。云何外空界。谓此身外诸外所摄空性空类无执无受。此复云何。谓外空迥邻呵伽色。是名外空界。前内此外。总名空界。云何识界。谓五识身。及有漏意识。是名识界

说一切有部法蕴足论卷第十阿毗达磨法蕴足论卷第十一

        尊者大目干连造

        三藏法师玄奘奉　诏译

    多界品第二十之余

云何欲界。谓于欲境诸贪等贪。乃至贪类贪生。总名欲界。复次欲贪及欲贪相应受想行识。并所等起身业语业。不相应行。总名欲界。云何恚界。谓于有情。欲为损害。乃至现为过患。总名恚界。复次嗔恚及嗔恚相应受想行识。并所等起身业语业。不相应行。总名恚界。云何害界。谓以手块刀杖等物。随一苦具。捶打有情。诸损等损害等害。嗔恚所起。能起苦事。总名害界。复次诸害及害相应受想行识并所等起身业语业。不相应行。总名害界。云何无欲界。谓于欲界。思惟过患。如是欲界。是不善法。是下贱者。信解受持。佛及弟子。贤贵善士。共所呵厌。能为自害。能为他害。能为俱害。能灭智慧。能碍彼类。能障涅槃。受持此法。不生通慧。不引菩提。不证涅槃。如是思惟。发勤精进。乃至励意不息。是名无欲界。复次为断欲界。于无欲界。思惟功德。如是无欲界。是善法。是尊胜者。信解受持。佛及弟子。贤贵善士。共所欣赞。不为自害。不为他害。不为俱害。增长智慧。不碍彼类。不障涅槃。受持此法。能生通慧。能引菩提。能证涅槃。如是思惟。发勤精进。乃至励意不息。是名无欲界。复次思惟欲界。如病如痈。如箭恼害。无常苦空非我转动。劳倦羸笃。是失坏法。迅速不停。衰朽非恒。不可保信。是变坏法。如是思惟。发勤精进。是名无欲界。复次为断欲界。思惟彼灭是灭是离。思惟彼道是道是出。如是思惟。发勤精进。乃至励意不息。是名无欲界。复次若思惟。舍心定及道。舍心定相应。并无想定。灭定择灭。如是思惟。发勤精进。乃至励意不息。是名无欲界。复次无欲及无欲相应受想行识。并所发起身业语业。不相应行。总名无欲界。云何无恚界。谓于恚界。思惟过患。如是恚界。是不善法。乃至不证涅槃。如是思惟。发勤精进。乃至励意不息。是名无恚界。复次为断恚界。于无恚界。思惟功德。如是无恚界。是善法。乃至能证涅槃。如是思惟。发勤精进。乃至励意不息。是名无恚界。复次思惟恚界。如病如痈。乃至是变坏法。如是思惟。发勤精进。是名无恚界。复次为断恚界。思惟彼灭是灭是离。思惟彼道是道是出。如是思惟。发勤精进。乃至励意不息。是名无恚界。复次若思惟。慈心定及道。慈心定相应。如是思惟。发勤精进。乃至励意不息。是名无恚界。复次无恚及无恚相应受想行识。并所等起身业语业。不相应行总名无恚界。云何无害界。谓于害界。思惟过患。如是害界。是不善法。乃至不证涅槃。如是思惟。发勤精进。乃至励意不息。是名无害界。复次为断害界。于无害界。思惟功德。如是不害界。是善法。乃至能证涅槃。如是思惟。发勤精进。乃至励意不息。是名无害界。复次思惟害界。如病如痈。乃至是变坏法。如是思惟。发勤精进。是名无害界。复次为断害界。思惟彼灭是灭是离。思惟彼道是道是出。如是思惟。发勤精进。乃至励意不息。是名无害界。复次若思惟。悲心定及道。悲心定相应。如是思惟。发勤精进。乃至励意不息。是名无害界。复次无害及无害相应受想行识。并所等起身业语业。不相应行。总名无害界

云何乐界。谓顺乐触所起身乐心乐平等受。受所摄。是名乐界。复次修第三静虑顺乐受触所起心乐平等受。受所摄。是名乐界。云何苦界。谓顺苦触所起身苦不平等受。受所摄。是名苦界。云何喜界。谓顺喜触所起心喜平等受。受所摄。是名喜界。复次修初二静虑。顺喜触所起心喜平等受。受所摄。是名喜界。云何忧界。谓顺忧触所起心忧不平等受。受所摄。是名忧界。云何舍界。谓顺舍触所起身舍心舍非平等非不平等受。受所摄。是名舍界。复次修未至定静虑中间第四静虑。及无色定。顺不苦不乐触所起心舍非平等非不平等受。受所摄。是名舍界。云何无明界。谓三界无知。是名无明界

云何受界。谓六受身。即眼触所生受。乃至意触所生受。是名受界。云何想界。谓六想身。即眼触所生想。乃至意触所生想。是名想界。云何行界。谓六思身。即眼触所生思。乃至意触所生思。是名行界。云何识界。谓六识身。即眼识乃至意识。是名识界

云何欲界。谓有诸法。欲贪随增。是名欲界。复次欲界系。十八界十二处五蕴。是名欲界。复次下从无间地狱。上至他化自在天。于中所有色受想行识。是名欲界。云何色界。谓有诸法。色贪随增。是名色界。复次色界系。十四界十处五蕴。是名色界。复次下从梵众天。上至色究竟天。于中所有色受想行识。是名色界。云何无色界。谓有诸法。无色贪随增。是名无色界。复次无色界系。三界二处四蕴。是名无色界。复次如欲色界。处定建立。不相杂乱。非无色界有如是事。然依定生。胜劣差别。建立上下。下从空无边处。上至非想非非想处。于中所有受想行识。是名无色界。云何色界。谓欲色界。总名色界。云何无色界。谓四无色。是名无色界。云何灭界。谓择灭非择灭。是名灭界。复次诸有色法。总名色界。除择灭非择灭。余无色法。是名无色界。择灭非择灭。是名灭界。云何过去界。谓过去五蕴。是名过去界。云何未来界。谓未来五蕴。是名未来界。云何现在界。谓现在五蕴。是名现在界。云何劣界。谓不善有覆无记法。是名劣界。云何中界。谓有漏善。及无覆无记法。是名中界。云何妙界。谓无漏善法。是名妙界。云何善界。谓善身语业。心心所法。不相应行。及择灭。是名善界。云何不善界。谓不善身语业。心心所法。不相应行。是名不善界。云何无记界。谓无记色心心所法不相应行。及虚空非择灭。是名无记界。云何学界。谓学五蕴。是名学界。云何无学界。谓无学五蕴。是名无学界。云何非学非无学界。谓有漏五蕴。及虚空择灭非择灭。是名非学非无学界

云何有漏界。谓有漏五蕴。是名有漏界。云何无漏界谓无漏五蕴。及虚空择灭非择灭。是名无漏界。云何有为界。谓五蕴。是名有为界。云何无为界。谓虚空及二灭。是名无为界。嗢拖南曰

  界有六十二　　十八界为初
  三六一四种　　六三两种二

    缘起品第二十一之一

一时薄伽梵。在室罗筏。住逝多林给孤独园。尔时世尊。告苾刍众。吾当为汝。宣说缘起缘已生法汝应谛听。极善作意。云何缘起。谓依此有彼有。此生故彼生。谓无明缘行。行缘识。识缘名色。名色缘六处。六处缘触。触缘受。受缘爱。爱缘取。取缘有。有缘生。生缘老死。发生愁叹苦忧扰恼。如是便集纯大苦蕴。苾刍当知。生缘老死。若佛出世。若不出世。如是缘起法住法界。一切如来。自然通达。等觉宣说。施设建立。分别开示。令其显了。谓生缘老死。如是乃至。无明缘行。应知亦尔。此中所有法性法定法理法趣。是真是实。是谛是如。非妄非虚。非倒非异。是名缘起。云何名为缘已生法。谓无明行识名色六处触受爱取有生老死。如是名为缘已生法。苾刍当知。老死是无常。是有为是所造作。是缘已生。尽法没法。离法灭法。生有取爱受触六处名色识行无明亦尔。苾刍当知。我诸多闻贤圣弟子。于此缘起缘已生法。能以正慧。如实善见善知善了。善思惟。善通达。不依前际而起愚惑谓。我于过去世。为曾有非有。何等我曾有。云何我曾有。不依后际而起愚惑谓。我于未来世。为当有非有。何等我当有。云何我当有。亦不依内而起愚惑谓。何等是我此我。云何我谁所有。我当有谁。今此有情。从何而来。于此处没。当往何所。彼如是知如是见故。所有世间。各别见趣。谓我论相应有情论相应命者论相应吉凶论相应莹饰防护。执为己有。有苦有碍。有灾有热。彼于尔时。得断遍知。如断树根及多罗顶。无复势力。后永不生。所以者何。谓我多闻贤圣弟子。于此缘起缘已生法。能以正慧。如实善见善知善了。善思惟。善通达故。时诸苾刍。欢喜敬受

此中缘起缘已生法。其体虽一。而义有异。谓或有缘起非缘已生法。或有缘已生法非缘起。或有缘起亦缘已生法。或有非缘起亦非缘已生法。或有缘起非缘已生法者无也。或有缘已生法非缘起者。谓无明行识名色六处触受爱取有生老死。或有缘起亦缘已生法者。谓生定能生于老死。如是生支。定能为缘。是缘起性。及缘已生法性。如是有取爱受触六处名色识行无明。应知亦尔。非缘起非缘已生法者。谓除前相。又生缘老死者。谓此生支。虽异生异灭。而缘起理。恒时决定。若过去生非老死缘者。应未来生亦非老死缘。若未来生非老死缘者。应过去生亦非老死缘。若过去生非老死缘者。应现在生亦非老死缘。若现在生非老死缘者。应过去生亦非老死缘。若未来生非老死缘者。应现在生亦非老死缘。若现在生非老死缘者。应未来生亦非老死缘。若佛出世时生非老死缘者。应佛不出世时生亦非老死缘。若佛不出世时生非老缘者。应佛出世时生亦非老缘。若缘起理。有颠倒者。应成二分。不决定故。应可破坏。理杂乱故。若尔不应施设缘起佛不应说生缘老死。然佛所说生缘老死。理趣决定。去来今世。有佛无佛。曾无改转。法性恒然。不隐不没。不倾不动。其理湛然。前圣后圣。同所游履。是真是实。是谛是如。非妄非虚。非倒非异。是故佛说生缘老死。如是有取爱受触六处名色识行无明缘行亦尔

复次无明缘行者。云何无明。谓于前际无知。后际无知。前后际无知。于内无知。外无知。内外无知。于业无知。异熟无知。业异熟无知。于善作业无知。恶作业无知。善恶作业无知。于因无知。因所生法无知。于佛法僧无知。于苦集灭道无知。于善不善法无知。于有罪无罪法无知。于应修不应修法无知。于下劣胜妙法无知。于黑白法无知。于有敌对法无知。于缘生无知。于六触处如实无知。如是无知无见非现观。黑闇愚痴。无明盲冥。罩网缠里。顽騃浑浊。障盖发盲。发无明。发无智。发劣慧。障碍善品。令不涅槃。无明漏。无明瀑流。无明轭。无明毒根。无明毒茎。无明毒枝。无明毒叶。无明毒花。无明毒果。痴等痴极痴。欣等欣极欣。痴类痴生。总名无明。云何无明缘行。谓世尊说。苾刍当知。无明为因。无明为缘。故贪嗔痴起。此贪嗔痴性。是名无明缘。行复次如世尊说。苾刍当知。无明为前行。无明为幖帜。故起无量种恶不善法。谓无惭无愧等。由无惭无愧故起诸邪见。由邪见故起邪思惟。由邪思惟故起邪语。由邪语故起邪业。由邪业故起邪命。由邪命故起邪勤。由邪勤故起邪念。由邪念故起邪定。此邪见邪思惟邪语邪业邪命邪勤邪念邪定。是名无明缘行。复次如世尊说。苾刍当知。起无量种恶不善法。一切皆以无明为根。无明为集。是无明类。从无明生。堕无明趣者。不如实知善不善法。有罪无罪法。应修不应修法。下劣胜妙法。黑白法。有敌对法。缘生诸法。不如实知此诸法故。便起邪见邪思惟。乃至邪念邪定。是名无明缘行。复次瓮喻经中。佛作是说。无明为缘。造福非福及不动行。云何福行。谓有漏善身业语业。心心所法。不相应行。如是诸行。长夜能招可爱可乐可欣可意诸异熟果此果名福亦名福果。以是福业。异熟果故是名福行。云何非福行。谓诸不善身业语业。心心所法。不相应行。如是诸行。长夜能招不可爱不可乐不可欣不可意诸异熟果。此果名非福。亦名非福果。是非福业异熟果故。是名非福行。云何不动行。谓四无色定。诸有漏善。是名不动行。云何无明为缘造非福行。谓有一类。由贪嗔痴缠缚心故。造身语意三种恶行。此三恶行。名非福行。由此因缘。身坏命终。堕于地狱。于彼复造非福行等。是名无明为缘造非福行。如说地狱。傍生鬼界。应知亦尔。云何无明为缘造福行谓有一类。于人趣乐。系心悕求。彼作是念。愿我当生人趣同分。与诸人众。同受快乐。因此悕求。造能感人趣身语意妙行。此三妙行。名为福行。由此因缘。身坏命终。生于人趣。与诸人众。同受快乐。于彼复造诸福行等。是名无明为缘造福行。有不系心悕求人乐。但由无明蔽动心故。造身语意三种妙行。此三妙行。名为福行。由此因缘。身坏命终。生于人趣。于彼复造诸福行等。是名无明为缘造福行。如说人趣。四大王众天。三十三天。夜摩天。睹史多天。乐变化天。他化自在天。应知亦尔。复有一类。于梵众天。系心悕求。彼作是念。愿我当生梵众天众同分中。因此悕求。勤修加行。离欲恶不善法。有寻有伺离生喜乐。初静虑具足住。于此定中。诸身律仪。语律仪。命清净。名为福行。由此因缘。身坏命终。生梵众天众同分中。于彼复造诸福行等。是名无明为缘造福行。有不系心悕求生彼。但由无明蔽动心故。勤修加行。离欲恶不善法。有寻有伺。离生喜乐。初静虑具足住。于此定中。诸身律仪。语律仪。命清净。名为福行。由此因缘。身坏命终。生梵众天众同分中。于彼复造诸福行等。是名无明为缘造福行。如说梵众天。梵辅天。大梵天。少光天。无量光天。极光净天。少净天。无量净天。遍净天。无云天。福生天。广果天。随其所应。广说亦尔。复有一类。于无想天。系心悕求。彼作是念。愿我当生无想天众同分中。因此悕求。勤修加行。思惟诸想。是粗苦障。思惟无想是静妙离。由此思惟。能灭诸想。安住无想。彼诸想灭。住无想时。名无想定。入此定时。诸身律仪。语律仪。命清净。名为福行。由此因缘。身坏命终。生无想天众同分中。于彼亦能造少福行。是名无明为缘造福行。有不系心悕求生彼。但由无明蔽动心故。勤修加行。思惟诸想是粗苦障。思惟无想是静妙离。由此思惟。能灭诸想。安住无想。彼诸想灭。住无想时。名无想定。入此定时。诸身律仪。语律仪。命清净。名为福行。由此因缘。身坏命终。生无想天众同分中。于彼亦能造少福行。是名无明为缘造福行。云何无明为缘造不动行。谓有一类。于空无边处天。系心悕求。彼作是念。愿我当生空无边处天众同分中。因此悕求。勤修加行。超诸色想。灭有对想。不思惟种种想。入无边空。空无边处具足住。于此定中。诸思等思现前。等思已思当思。思性思类。造心意业。名不动行。由此因缘。身坏命终。生空无边处天众同分中。于彼复能造不动行。是名无明为缘造不动行。有不系心悕求生彼。但由无明蔽动心故。勤修加行。超诸色想。灭有对想。不思惟种种想。入无边空。空无边处具足住。于此定中。诸思等思现前。等思已思当思。思性思类。造心意业。名不动行。由此因缘。身坏命终。生空无边处天众同分中。于彼复能造不动行。是名无明为缘造不动行。如说空无边处。识无边处。无所有处。非想非非想处。应知亦尔。如是诸行。无明为缘。无明为依。无明为建立。故起等起生等生。聚集出现。故名无明缘行。云何行缘识。谓有一类。贪嗔痴俱生思为缘故。起贪嗔痴俱生诸识。是名行缘识。复有一类。无贪无嗔无痴俱生思为缘故。起无贪无嗔无痴俱生诸识。是名行缘识。复次眼及色为缘生眼识。此中眼是内有为行。色为外缘生眼识。是名行缘识。乃至意及法为缘生意识。此中意是内有为行。法为外缘生意识。是名行缘识。复次瓮喻经中。佛作是说。造福非福不动行已。有随福非福不动识。云何造非福行已有随非福识。谓有一类。由贪嗔痴缠缚心故。造身语意三种恶行。此三恶行。名非福行。由此因缘。身坏命终。堕于地狱。于彼起识。是名造非福行已有随非福识。如说地狱。傍生鬼界。应知亦尔。云何造福行已有随福识。谓有一类。于人趣乐。系心悕求。彼作是念。愿我当生人趣同分。与诸人众。同受快乐。因此悕求。造能感人趣身语意妙行。此三妙行。名为福行。由此因缘。身坏命终。生于人趣。于彼起识。是名造福行已有随福识。有不系心悕求人乐。但由无明蔽动心故。造身语意三种妙行。此三妙行。名为福行。由此因缘。身坏命终。生于人趣。于彼起识。是名造福行已有随福识。如说人趣。四大王众天。乃至他化自在天。应知亦尔。复有一类。于梵众天。系心悕求。彼作是念。愿我当生梵众天众同分中。因此悕求。勤修加行。离欲恶不善法。有寻有伺。离生喜乐。初静虑具足住。于此定中。诸身律仪。语律仪命清净。名为福行。由此因缘。身坏命终。生梵众天众同分中。于彼起识。是名造福行已有随福识。有不系心悕求生彼。但由无明蔽动心故。勤修加行。离欲恶不善法。乃至命清净。名为福行。由此因缘。身坏命终。生梵众天众同分中。于彼起识。是名造福行已有随福识。如说梵众天。梵辅天乃至无想天。应知亦尔。云何造不动行已有随不动识。谓有一类。于空无边处天。系心悕求彼作是念。愿我当生空无边处天众同分中。因此欣求。勤修加行。超诸色想。灭有对想。不思惟种种想。入无边空空无边处具足住。于此定中。诸思等思。现前等思。已思当思。思性思类。造心意业。名不动行。由此因缘。身坏命终。生空无边处天众同分中。于彼起识。是名造不动行已有随不动识。有不系心悕求生彼。但由无明蔽动心故。勤修加行。超诸色想。乃至造心意业。名不动行。由此因缘。身坏命终。生空无边处天众同分中。于彼起识。是名造不动行已有随不动识。如说空无边处天。乃至非想非非想天。应知亦尔。如是诸识。行为缘。行为依。行为建立。故起等起生等生。聚集出现。故名行缘识。云何识缘名色。谓有一类。贪嗔痴俱生识为缘故。起贪嗔痴俱生身业语业。名为色。即彼所生受想行识。名为名。是名识缘名色。复有一类。无贪无嗔无痴俱生识为缘故。起无贪无嗔无痴俱生身业语业。名为色。即彼所生受想行识。名为名。是名识缘名色。复次教诲那地迦经中。佛作是说。若那地迦所爱亲友。变坏离散。便生愁叹苦忧扰恼。此愁俱生识为缘故。起愁俱生身业语业。名为色。即彼所生受想行识。名为名。是名识缘名色。复次教诲颇勒窭那经中。佛作是说。颇勒窭那识为食故。后有生起。此识云何。谓健达缚最后心。心意识增长坚住。未断未遍知。未灭未变吐。此识无间。于母胎中。与羯剌蓝自体和合。此羯剌蓝自体和合。名为色。即彼所生受想行识。名为名。是名识缘名色。复次教诲莎底经中。佛作是说。三事和合。入母胎藏。云何为三。谓父母和合俱起染心。其母是时调适。及健达缚。正现在前。如是三事和合。入母胎藏。此中健达缚最后心意识。增长坚住。未断未遍知。未灭未变吐。此识无间。入母胎藏。此所托胎。名为色。即彼所生受想行识。名为名。是名识缘名色。复次大因缘经中。尊者庆喜问佛。名色为有缘不。佛言有缘。此缘谓识。佛告庆喜。识若不入母胎藏者。名色得成羯剌蓝不。阿难陀曰。不也世尊。识若不入母胎藏者。名色得生此界中不。不也世尊。识若初时已断坏者。后时名色得增长不。不也世尊。识若全无为可施设有名色不。不也世尊。是故庆喜。一切名色。皆识为缘。是名识缘名色。如是名色。识为缘。识为依。识为建立。故起等起生等生。聚集出现。故名识缘名色

云何名色缘识。谓眼色为缘生眼识。此中眼及色。名为色。即彼所生受想行识。名为名。于中作意等。能助生眼识。是名名色缘识。乃至意法为缘生意识。此中诸意识所了色。名为色。即彼所生受想行识。名为名。于中作意等能助生意识。是名名色缘识。复次教诲颇勒窭那经中。佛作是说。颇勒窭那。识为食故。后有生起。此识云何。谓健达缚。广说乃至。与羯剌蓝自体和合。此羯剌蓝自体和合。名为色。即彼所生受想行识。名为名。尔时非理作意俱生名色为缘。起俱生识。是名名色缘识。复次教诲莎底经中。佛作是说。三事和合。入母胎藏。广说乃至。此识无间。入母胎藏。此所托胎。名为色。即彼所生受想行识。名为名。尔时非理作意俱生名色为缘。起俱生识。是名名色缘识。复有一类。由贪嗔痴缠缚心故。造身语意三种恶行。此中身语恶行。名为色。意恶行。名为名。由此恶行名色为缘。身坏命终。堕于地狱。于彼起识。是名名色缘识。如说地狱。傍生鬼界。应知亦尔。复有一类。于人趣乐。系心悕求。因此悕求。造能感人趣身语意妙行。此中身语妙行。名为色。意妙行。名为名。由此妙行名色为缘。身坏命终。生于人趣。于彼起识。是名名色缘识。有不系心希求人乐。但由无明蔽动心故。造身语意三种妙行。此中身语妙行。名为色。意妙行。名为名。由此妙行名色为缘。身坏命终。生于人趣。于彼起识。是名名色缘识。如说人趣。四大王众天。乃至他化自在天。应知亦尔。复有一类。于梵众天。系心希求。因此希求。勤修加行。离欲恶不善法。乃至初静虑具足住。于此定中。诸身律仪。语律仪。命清净。名为色。即彼所生受想行识。名为名。由此为缘。身坏命终。生梵众天众同分中。于彼起识。是名名色缘识。如说梵众天。梵辅天。乃至非想非非想处。随其所应。当知亦尔。复次大因缘经中。尊者庆喜问佛。诸识为有缘不。佛言有缘。此谓名色。佛告庆喜。若无名色。诸识转不。阿难陀曰。不也世尊。若无名色为所依止。后世所受生老死识。为得生不。不也世尊。若诸名色。都无所有为可施设。有诸识不。不也世尊。是故庆喜。诸识皆以名色为缘。是名名色缘识。如是诸识。名色为缘。名色为依。名色为建立。故起等起生等生。聚集出现。故名名色缘识

云何名色缘六处。谓有一类。为寒所逼。希求于暖。得好暖故。便起身中暖俱大种。此中若暖若暖俱大种名为色。即彼所生受想行识。名为名。由此名色。眼耳鼻舌身及意根。皆得增长。是名名色缘六处。为热所逼。希求于冷。应知亦尔。复有一类。为饥所逼。希求于食。得好食故。便起身中食俱大种。此中若食若食俱大种。名为色。即彼所生受想行识。名为名。由此名色。六根增长。是名名色缘六处。复有一类。为渴所逼。希求于饮。得好饮故。便起身中饮俱大种。此中若饮若饮俱大种。名为色。即彼所生受想行识。名为名。由此名色。六根增长。是名名色缘六处。复有一类。劳倦所逼。希求止息。按摩睡眠。由遂意故。便起身中彼俱大种。此中若按摩等。若彼俱大种。名为色。即彼所生受想行识。名为名。由此名色。六根增上。是名名色缘六处。复有一类。于盛热时。热渴所逼。入清凉池。恣意饮浴。便起身中彼俱大种。此中若清冷水。若彼俱大种。名为色。即彼所生受想行识。名为名。由此名色。六根增长。是名名色缘六处。复次教诲颇勒窭那经中。佛作是说。颇勒窭那。识为食故。后有生起。此识云何。谓健达缚。广说乃至。与羯剌蓝自体和合。此羯剌蓝自体和合。名为色。即彼所生受想行识。名为名。尔时非理作意俱生名色为缘。母胎藏中。六根生起。是名名色缘六处。复次教诲莎底经中。佛作是说。三事和合。入母胎藏。广说乃至。此识无间。入母胎藏。此所托胎。名为色。即彼所生受想行识。名为名。尔时非理作意俱生名色为缘。母胎藏中。六根生起。是名名色缘六处。复有一类。由贪嗔痴缠缚心故。造身语意三种恶行。此中身语恶行。名为色。意恶行。名为名由此恶行。名色为缘。身坏命终。堕于地狱。六根生起。是名名色缘六处。如说地狱。傍生鬼界。应知亦尔。复有一类。于人趣乐。系心希求。因此希求。造能感人趣身语意妙行。此中身语妙行。名为色。意妙行。名为名。由此妙行名色为缘。身坏命终。生于人趣。六根生起。是名名色缘六处。如说人趣。四大王众天。乃至他化自在天。应知亦尔。复有一类。于梵众天。系心希求。因此希求。勤修加行。离欲恶不善法。乃至初静虑具足住。于此定中。诸身律仪。语律仪。命清净。名为色。即彼所生受想行识。名为名。由此为缘。身坏命终。生梵众天众同分中。六根生起。是名名色缘六处。如说梵众天。梵辅天。乃至非想非非想处天。随其所应。当知亦尔。是名名色缘六处。如是六处。名色为缘。名色为依。名色为建立。故起等起生等生。聚集出现。故名名色缘六处

说一切有部法蕴足论卷第十一阿毗达磨法蕴足论卷第十二

        尊者大目干连造

        三藏法师玄奘奉　诏译

    缘起品第二十一之余

云何名色缘触。谓眼及色为缘生眼识。三和合故生触。此中眼及色。名为色。即彼所生受想行识。名为名。如是名色为缘生眼触。是名名色为缘触。乃至意及法为缘生意识。三和合故生触。此中诸意识所了色。名为色。即彼所生受想行识。名为名。如是名色为缘生意触。是名名色缘触。复次教诲颇勒窭那经中。佛作是说。颇勒窭那。识为食故后有生起。此识云何。谓健达缚。广说乃至。与羯剌蓝自体和合。此羯剌蓝自体和合。名为色。即彼所生受想行识。名为名。尔时非理作意俱生名色为缘。母胎藏中。诸触生起。是名名色缘触。复次教诲莎底经中。佛作是说。三事和合。入母胎藏。广说乃至。此识无间。入母胎藏。此所托胎。名为色。即彼所生受想行识名为名。尔时非理作意俱生名色为缘。母胎藏中。诸触生起。是名名色缘六处。复有一类。由贪嗔痴缠缚心故。造身语意三种恶行。此中身语恶行。名为色。意恶行。名为名。由此恶行名色为缘。身坏命终。堕于地狱。诸触生起。是名名色缘触。如说地狱。傍生鬼界。应知亦尔。复有一类。于人趣乐。系心希求。因此希求。造能感人趣身语意妙行。此中身语妙行。名为色。意妙行。名为名。由此妙行名色为缘。身坏命终。生于人趣。诸触生起。是名名色缘触。如说人趣。四大王众天。乃至他化自在天。应知亦尔。复有一类。于梵众天。系心悕求。因此悕求。勤修加行。离欲恶不善法。乃至初静虑具足住。于此定中。诸身律仪。语律仪。命清净。名为色。即彼所生受想行识。名为名。由此为缘。身坏命终。生梵众天众同分中。诸触生起。是名名色缘触。如说梵众天梵辅天乃至非想非非想天。随其所应。当知亦尔。复次大因缘经中。尊者庆喜问佛。诸触为有缘不。佛言有缘。此谓名色。广说乃至。若依止此相。施设名身。此相若无为可施设增语触不。不也世尊。若依止此相。施设色身。此相若无为可施设有对触不。不也世尊。若名色身。都无所有为可施设有诸触不。不也世尊。是故庆喜。诸触皆以名色为缘。是名名色缘触。如是诸触。名色为缘。名色为依。名色为建立。故起等起生等生。聚集出现。故名名色缘触

云何六处缘触。谓眼及色为缘生眼识。三和合故生触。乃至意及法为缘生意识。三和合故生触。是名六处缘触。复次眼及色为缘生眼识。三和合故生触。此中眼为内缘。色为外缘。生眼触。乃至意及法为缘生意识。三和合故生触。此中意为内缘。法为外缘。生意触。是名六处缘触。复次眼及色为缘生眼识。三和合故生触。此中眼触。以眼色眼识为缘。乃至意及法为缘生意识。三和合故生触。此中意触。以意法意识为缘。是名六处缘触。复次眼及色为缘生眼识。三和合故生触。此中眼色眼识。皆非是触。由三和合。而有触生乃至意及法为缘生意识。三和合故生触。此中意法意识。皆非是触。由三和合。而有触生。是名六处缘触。如是诸触。六处为缘。六处为依。六处为建立。故起等起生等生。聚集出现。故名六处缘触

云何触缘受。谓眼及色为缘生眼识。三和合故生触。触为缘生受。乃至意及法为缘生意识。三和合故生触。触为缘故生受。是名触缘受。复次眼及色为缘生眼识。三和合故生触。或顺乐受。或顺苦受。或顺不苦不乐受。顺乐受触为缘生乐受。顺苦受触为缘生苦受。顺不苦不乐受触为缘。生不苦不乐受。乃至意及法为缘生意识。三和合故生触。或顺乐受。或顺苦受。或顺不苦不乐受。顺乐受触为缘生乐受。顺苦受触为缘生苦受。顺不苦不乐受触为缘。生不苦不乐受。是名触缘受。复次如契经说。尊者庆喜。告瞿史罗长者言。眼界。色界。眼识界。自体各别。顺乐受二为缘生眼识。三和合故生触。名顺乐受触。此顺乐受触为缘生乐受。顺苦受二为缘生眼识。三和合故生触。名顺苦受触。此顺苦受触为缘生苦受。顺不苦不乐受二为缘生眼识。三和合故生触。名顺不苦不乐受触。此顺不苦不乐受触为缘。生不苦不乐受。余五三界。广说亦尔。是名触缘受。复次大因缘经中。尊者庆喜问佛。诸受为有缘不。佛言有缘。此缘谓触。广说乃至。若无眼触。为有眼触为缘。生内乐受苦受不苦不乐受不。不也世尊。乃至若无意触。为有意触为缘。生内乐受苦受不苦不乐受不。不也世尊。若全无触为可施设。有诸受不。不也世尊。是故庆喜。诸受无不以触为缘。是名触缘受。如是诸受。触为缘。触为依。触为建立。故起等起生等生。聚集出现。故名触缘受。云何受缘爱。谓眼及色为缘生眼识。三和合故生触。触为缘故生受。受为缘故生爱。乃至意及法为缘生意识。三和合故生触。触为缘故生受。受为缘生爱。是名受缘爱。复次眼味受为缘故。数复于眼随顺而住。由随顺故。数复于眼。起贪等贪执藏防护坚着爱染。乃至意味受为缘故。数复于意。随顺而住。由随顺故。数复于意。起贪等贪。执藏防护坚着爱染。是名受缘爱。复次取蕴经中。佛作是说。苾刍当知。我于色味。已审寻思。诸有于色。或已起味。或今起味。我以正慧。审见审知。彼以色味受为缘故。数复于色。随顺而住。由随顺故。数复于色。起贪等贪执藏防护坚着爱染。乃至我于识味。以审寻思。诸有于识。或已起味。或今起味。我以正慧。审见审知。彼以识味。受为缘故。数复于识。随顺而住。由随顺故。数复于识。起贪等贪执藏防护坚着爱染。是名受缘爱。复次取蕴经中。世尊又说。苾刍当知。若诸色中。都无味者。有情不应于色起染。以诸色中非都无味。是故有情于色起染。彼以色味受为缘故。数复于色。随顺而住。由随顺故。数复于色。起贪等贪执藏防护坚着爱染。乃至若诸识中。都无味者。有情不应于识起染。以诸识中非都无味。是故有情。于识起染。彼以识味受为缘故。数复于识。随顺而住。由随顺故。起贪等贪执藏防护坚着爱染。是名受缘爱。复次六处经中。佛作是说。苾刍当知。我于眼味。已审寻思。诸有于眼。或已起味。或今起味。我以正慧。审见审知。彼以眼味受为缘故。数复于眼。随顺而住。由随顺故。数复于眼。起贪等贪执藏防护坚着爱染。乃至我。于意味。已审寻思。诸有于意。或已起味。或今起味。我以正慧。审见审知。彼以意味。受为缘故。数复于意。随顺而住。由随顺故。数复于意。起贪等贪执藏防护坚着爱染。是名受缘爱。复次六处经中。世尊又说。苾刍当知。若诸眼中。都无味者。有情不应于眼起染。以诸眼中非都无味。是故有情。于眼起染。彼以眼味受为缘故。数复于眼。随顺而住。由随顺故。数复于眼。起贪等贪执藏防护坚着爱染。乃至若诸意中。都无味者。有情不应于意起染。以诸意中非都无味。是故有情。于意起味。彼以意味受为缘故。数复于意。随顺而住。由随顺故。数复于意。起贪等贪执藏防护坚着爱染。是名受缘爱。复次六处经中。世尊复说。苾刍当知。我于色味。已审寻思。诸有于色。或已起味。或今起味。我以正慧审见审知。彼以色味受为缘故。数复于色。随顺而住。由随顺故。数复于色。起贪等贪执藏防护坚着爱染。乃至我于法味。已审寻思。诸有于法。或已起味。或今起味。我以正慧。审见审知。彼以法味受为缘故。数复于法。随顺而住。由随顺故。数复于法。起贪等贪执藏防护坚着爱染。是名受缘爱。复次六处经中。世尊又说。苾刍当知。若诸色中。都无味者。有情不应于色起染。以诸色中非都无味。是故有情。于色起染。彼以色味受为缘故。数复于色。随顺而住。由随顺故。数复于色。起贪等贪执藏防护坚着爱染。乃至若诸法中。都无味者。有情不应于法起染。以诸法中非都无味。是故有情。于法起染。彼以法味受为缘故。数复于法。随顺而住。由随顺故。数复于法起贪等贪执藏防护坚着爱染。是名受缘爱。复次佛为大名离呫毗说。大名当知。若色一向是苦非乐。非乐所随。非乐喜受之所缠执。应无有情为求乐故。于诸色中。起贪起染。烦恼缠缚。大名以色。非一向苦。彼亦是乐。是乐所随。是乐喜受之所缠执。故有有情。为求乐故。于诸色中。起贪起染。烦恼缠缚。彼以色味受为缘故。数复于色。随顺而住。由随顺故。数复于色。起贪等贪执藏防护坚着爱染。乃至若识一向是苦非乐。非乐所随。非乐喜受之所缠执。应无有情为求乐故。于诸色中。起贪起染。烦恼缠缚。大名以识。非一向苦。彼亦是乐。是乐所随。是乐喜受之所缠执。故有有情。为求乐故。于诸识中。起贪起染。烦恼缠缚。彼以识味受为缘故。数复于识。随顺而住。由随顺故。数复于识。起贪等贪执藏防护坚着爱染。是名受缘爱。复次满月经中。佛作是说。苾刍当知。色为缘故。起乐生喜。是名色味。彼以色味受为缘故。数复于色。随顺而住。由随顺故。数复于色。起贪等贪执藏防护坚着爱染。乃至识为缘故。起乐生喜。是名识味。彼以识味受为缘故。数复于识。随顺而住。由随顺故。起贪等贪执藏防护坚着爱染。是名受缘爱。复次大因缘经中。佛告庆喜。爱为缘故求。求为缘故得。得为缘故集。集为缘故着。着为缘故贪。贪为缘故悭。悭为缘故摄受。摄受为缘故防护。因防护故。执持刀仗。斗讼诤竞。谄诈虚诳。生无量种恶不善法。佛告庆喜。执持刀仗。斗讼诤竞。谄诈虚诳。生无量种恶不善法。皆因防护。防护为缘。有如是事。防护若无。有此事不。阿难陀曰。不也世尊。是故执持刀仗等事。防护为由绪。防护为因。防护为集。防护为缘。而得生起。如是防护。因于摄受。摄受为缘。而有防护。摄受若无。有防护不。不也世尊。是故防护摄受为由绪。摄受为因。摄受为集。摄受为缘。而得生起。广说乃至。如是诸求。皆因于爱。爱为缘故。而有诸求。此爱若无。为有求不。不也世尊。是故诸求。爱为由绪。爱为其因。爱为其集。爱为其缘。而得生起。庆喜当知。爱有二种。一者欲爱。二者有爱。此二种爱。依受而有。受若无者。二爱亦无是名受缘爱。如是诸爱。受为缘。受为依。受为建立。故起等起生等生。聚集出现。故名受缘爱

云何爱缘取。谓彼初生。说名为爱。爱增盛位。转名为取。此复如何。谓如有一。于诸欲境。系心观察。起欲贪缠。彼从此缠复起余缠。增上转增上。猛利转猛利。圆满转圆满。前所起缠。说名为爱。后所起缠。转名为取。是名爱缘取。复如有一。于诸色境。或无色境。系心观察。起色贪缠。或无色贪缠。彼从此缠。复起余缠增上转增上。猛利转猛利。圆满转圆满。前所起缠。说名为爱。后所起缠。转名为取。是名爱缘取。复次险坑经中。佛作是说。吾为汝等诸苾刍众。宣说简择诸蕴法要。谓四念住。四正胜。四神足。五根五力。七等觉支。八支圣道。如是宣说简择诸蕴正法要时。而有一类怀愚痴者。于我所说。不住猛利信爱恭敬。彼迟证得无上漏尽。复有一类怀聪睿者。于我所说。能住猛利信爱恭敬。彼速证得无上漏尽。复有一类。于我所说色蕴法中等随观我。此能观行。以谁为缘。用谁为集。是谁种类。从谁而生。谓无明触所生诸受。为缘生爱。此所生行。以彼为缘。用彼为集。是彼种类。从彼而生。此能生爱。以谁为缘。用谁为集。是谁种类。从谁而生。谓无明触所生诸受。此所生爱。以受为缘。用受为集。是受种类。从受而生。此能生受。以谁为缘。用谁为集。是谁种类。从谁而生。谓无明触。此所生受。以触为缘。用触为集。是触种类。从触而生。此能生触。以谁为缘。用谁为集。是谁种类。从谁而生。谓六处。此所生触。以六处为缘。用六处为集。是六处种类。从六处而生。如是六处。无常有为。是所造作。从众缘生。如是触受。爱能观行。亦无常有为。是所造作。从众缘生。此等随观。色为我者。是有身见。现所起缠。彼从此缠。复起余缠。增上转增上。猛利转猛利。圆满转圆满。前所起缠。说名为爱。后所起缠。转名为取。是名爱缘取。有不于色等随观我而等随观。我有诸色有不等随观。我有诸色而等随观。色是我所有不等随观。色是我所而等随观。我在色中有不等随观。我在色中而等随观。受想行识为我有不等随观。受想行识为我而等随观。我有受想行识有不等随观。我有受想行识而等随观。受想行识是我所有不等随观。受想行识是我所而等随观。我在受想行识中有不等随观。我在受想行识中而起疑惑。有不起疑惑。而起有见无有见。有不起有见无有见。而不离我慢。故由等随观。我及我所。而起我慢。此我慢行。以谁为缘。用谁为集。是谁种类。从谁而生。谓无明触所生。诸受为缘生爱。此所生行。以彼为缘。用彼为集。是彼种类。从彼而生。广说乃至。如是六处。无常有为。是所造作。从众缘生。如是触受爱我慢行。亦无常有为。是所造作。从众缘生。如是我慢。是有身见。所起慢缠。彼从此缠。复起余缠。增上转增上。猛利转猛利。圆满转圆满。前所起缠。说名为爱。后所起缠。转名为取。是名爱缘取。复次有执世间常。或无常。或亦常亦无常。或非常非无常。执世间有边。或无边。或亦有边亦无边。或非有边非无边。执命者即身。执命者异身。执如来死后是有。或非有。或亦有亦非有。或非有非非有。皆是边执见。现所起缠。彼从此缠。复起余缠。增上转增上。猛利转猛利。圆满转圆满。前所起缠。说名为爱。后所起缠。转名为取。是名爱缘取。复次有执世尊非如来应正等觉乃至非天人师。执佛正法非善说现见乃至非智者内证。执佛弟子非具足妙行乃至非随法行。或执无苦无集无灭无道。或执无一切行无常。无一切法无我。无涅槃寂静。皆是邪见。现所起缠。彼从此缠。复起余缠。增上转增上。猛利转猛利。圆满转圆满。前所起缠。说名为爱。后所起缠。转名为取。是名爱缘取。复次有执世间是常。此实余迷谬。或是无常。乃至如来死后非有非非有。此实余迷谬。皆是见取。现所起缠。彼从此缠。复起余缠。增上转增上。猛利转猛利。圆满转圆满。前所起缠。说名为爱。后所起缠。转名为取。是名爱缘取。复次有起戒取。或起禁取。或起戒禁取。谓此戒此禁此戒禁。能清净。能解脱。能出离。能超苦乐。至超苦乐处。皆是戒禁取。现所起缠。彼从此缠。复起余缠。增上转增上。猛利转猛利。圆满转圆满。前所起缠。说名为爱。后所起缠。转名为取。是名爱缘取。复次有于世尊而起犹预。为是如来应正等觉。为非如来应正等觉。乃至为是天人师。为非天人师。于佛正法。而起犹预。为是善说现见。为非善说现见。乃至为是智者内证。为非智者内证。于佛弟子。而起犹预。为是具足妙行。为非具足妙行。乃至为是随法行。为非随法行。于四圣谛。而起犹预。为是苦。为非苦。乃至为是道。为非道。于三法印。而起犹预。为一切行无常。为非一切行无常。为一切法无我。为非一切法无我。为涅槃寂静。为非涅槃寂静。此皆是疑。现所起缠。彼从此缠。复起余缠。增上转增上。猛利转猛利。圆满转圆满。前所起缠。说名为爱。后所起缠。转名为取。是名爱缘取。复次一切四取。皆以爱为缘。用爱为集。是爱种类。从爱而生。何等四取。一欲取。二见取。三戒禁取。四我语取。云何欲取。谓欲界系。除诸见余结缚随眠随烦恼缠。是名欲取。云何见取。谓有身见。边执见。邪见。见取。如是四见。是名见取。云何戒禁取。谓有一类。取戒取禁取戒禁。为能清净能解脱能出离能超苦乐至超苦乐处。是名戒禁取。云何我语取。谓色无色界系。除诸见余结缚随眠随烦恼缠。是名我语取。复次大因缘经中。尊者庆喜问佛。诸取为有缘不。佛言有缘。此缘谓爱。广说乃至。若全无爱为可施设。有诸取不。不也世尊。是故庆喜。诸取皆以爱为其缘。是名爱缘取。如是诸取。爱为缘。爱为依。爱为建立。故起等起生等生。聚集出现。故名爱缘取

云何取缘有。谓取为缘施设多有。谓佛或说三界五蕴名有。或说能感后有业名有。或说生分五蕴名有。云何说三界五蕴名有。如说三有。谓欲有色有无色有。云何说能感后有业名有。如世尊告阿难陀言。若业能感后有名有。云何说生分五蕴名有。如世尊告颇勒窭那。识为食故。后有生起。复次大因缘经中。尊者庆喜问佛。诸有为有缘不。佛言有缘。此缘谓取。广说乃至。若全无取为可施设有诸有不。不也世尊。是故庆喜。诸有皆以取为其缘。是名取缘有。如是诸有。取为缘。取为依。取为建立。故起等起生等生。聚集出现。故名取缘有

云何有缘生。谓有一类。由贪嗔痴缠缚心故。造身语意三种恶行。此三恶行。说名业有。由此因缘。身坏命终。堕于地狱。于彼诸生等生。趣入出现。蕴得界得处得诸蕴生命根起。说名生。此生缘有故起。是名有缘生。如说地狱。傍生鬼界。应知亦尔。复有一类。于人趣乐。系心希求。彼作是念。愿我当生人趣同分。与诸人众。同受快乐。因此希求。造能感人趣身语意妙行。此三妙行。说名业有。由此因缘。身坏命终。生于人趣众同分中。于彼诸生等生。乃至命根起说名生。此生缘有故起。是名有缘生。如说人趣。四大王众天。乃至他化自在天。应知亦尔。复有一类。于梵众天。系心希求。彼作是念。愿我当生梵众天众同分中。因此希求。勤修加行。离欲恶不善法。有寻有伺。离生喜乐。初静虑具足住。于此定中。诸身律仪。语律仪。命清净。说名业有。由此因缘。身坏命终。生梵众天众同分中。于彼诸生等生。乃至命根起。说名生。此生缘有故起。是名有缘生。如说梵众天。梵辅天乃至广果天。应知亦尔。复有一类。于无想天。系心希求。彼作是念。愿我当生无想天众同分中。因此希求。勤修加行。思惟诸想。是粗苦障。思惟无想是静妙离。由此思惟。能灭诸想。安住无想。彼诸想灭。住无想时。名无想定。入此定时。诸身律仪。语律仪。命清净。说名业有。由此因缘。身坏命终。生无想天众同分中。于彼诸生等生。乃至命根起。说名生。此生缘有故起。是名有缘生。复有一类。于空无边处天。系心希求。彼作是念。愿我当生空无边处天众同分中。因此希求。勤修加行。超诸色想。灭有对想。不思惟种种想。入无边空空无边处具足住。于此定中。诸思等思。现前等思。已思当思。思性思类。造心意业。说名业有。由此因缘。身坏命终。生空无边处众同分中。于彼诸生等生。乃至命根起。说名生。此生缘有故起。是名有缘生。如说空无边处。乃至非想非非想处。应知亦尔。复次大因缘经中。尊者庆喜问佛。诸生为有缘不。佛言有缘。此缘谓有。广说乃至。若无业有。鱼鸟蛇蝎。那伽药叉部多。食香诸天人等。无足二足。多足异类。彼彼有情。于彼彼聚生等生等。为得有不。不也世尊。若全无有为可施设。有诸生不。不也世尊。是故庆喜。诸生皆以有为其缘。是名有缘生。如是诸生。有为缘。有为依。有为建立。故起等起生等生。聚集出现。故名有缘生

云何生缘老死。谓彼彼有情。即于彼彼有情聚中。诸生等生。趣入出现。蕴得界得处得诸蕴生命根起。说名生。发落发白。皮缓面皱。身曲背偻。喘息逾急。扶杖而行。肢体斑黑。衰退闇钝。根熟变坏。诸行故败。朽坏羸损。说名老。彼彼有情。即于彼彼诸有情聚。移转坏没。退失别离。寿暖识灭。命根不转。诸蕴破坏。夭丧殒逝。说名死。如是老死。缘生故起。是名生缘老死。复次大因缘经中。尊者庆喜问佛。老死为有缘不。佛言有缘。此缘谓生。广说乃至。若无有生。鱼鸟蛇蝎。那伽药叉部多。食香诸天人等。无足二足。多足异类。彼彼有情。于彼彼聚。所有老死。为得有不。不也世尊。若全无生。为可施设有老死不。不也世尊。是故庆喜。老死皆以生为其缘。是名生缘老死。如是老死。生为缘。生为依。生为建立。故起等起生等生。聚集出现。故名生缘老死

云何发生愁叹苦忧扰恼。谓有一类。或因父母兄弟姊妹师友死故。或因亲族灭亡都尽。或因财位一切丧失。便发自身猛利刚犷切心夺命辛楚苦受。彼于尔时。心热等热。内热遍热。便发于愁。已愁当愁。心中愁箭。说名愁。复有一类。或因父母兄弟姊妹师友死等。便发自身猛利刚犷切心夺命辛楚苦受。彼于尔时。心热等热。内热遍热。便发于愁。已愁当愁。心中愁箭。由此缘故。而伤叹言。苦哉苦哉。我父我母。广说乃至。我财我位。如何一旦忽至于此。其中所有伤怨言词。种种语业。说名叹。五识相应不平等受。说名苦。意识相应不平等受。说名忧。诸心扰恼。已扰恼。当扰恼。扰恼性。扰恼类。说名扰恼。于老死位。发生如是种种愁叹苦忧扰恼

云何如是便集纯大苦蕴。谓于如是老死位中。积集一类大灾大横具大过患众苦蕴聚。复次无明苦蕴为缘。起行苦蕴。行苦蕴为缘。起识苦蕴。识苦蕴为缘。起名色苦蕴。名色苦蕴为缘。起六处苦蕴。六处苦蕴为缘。起触苦蕴。触苦蕴为缘。起受苦蕴。受苦蕴为缘。起爱苦蕴。爱苦蕴为缘。起取苦蕴取苦蕴为缘。起有苦蕴。有苦蕴为缘。起生苦蕴。生苦蕴为缘。起老死苦蕴。由老死故。发生种种愁叹苦忧扰恼苦蕴。故总说言如是便集纯大苦蕴

说一切有部法蕴足论卷第十二

    法蕴足论后序

        沙门靖迈制

法蕴足论者。盖阿毗达磨之权舆。一切有部之洪源也。无上等觉入室之神足。摩诃目干连之所制矣。镜六通之妙慧。晢三达之智明。桴金鼓于大千。声玉螺于百亿。摘藏海之奇玩。鸠教山之胜珍。欲使天镜常悬。法幢永树。众邪息蕃蓠之望。诸子骋游戏之欢。而为此论也。是以佛泥越后。百有余年。叠启五分之殊。解开二九之异。虽各擅连城之贵。俱称照乘之珍。唯一切有部。卓乎迥秀。若妙高之处宏海。犹朗月之冠众星者。岂不以本弘基永者欤。至如八种揵度鹜徽于发智之场。五百应真驰誉于广说之苑。斯皆挹此涓波。分斯片玉。遂得驾群部而高蹈。接天衢而布武。是知登昆阆者。必培塿于众山。游溟渤者。亦[土*幻]塘于群澍。谅其然矣。矧乎顺正理以析疑。显真宗以副惑。莫不镜此彝伦。鉴斯洪范。故使耆德婆薮屈我众贤上坐幽宗见负弘致者也。题称阿毗达磨者。形二藏以简殊也。一切有部者。对十七以标异也。法蕴足者。显此论之胜名也。能持自性。轨范称法。法有积集。崇聚为蕴。此论攸宗。法聚三七。皆与对法为依。故目之为足。三藏玄奘法师。以　皇唐显庆四年九月十四日。奉　诏于大慈恩寺弘法苑译讫。大慈恩寺沙门。释光笔受靖迈饰文


阿毗达磨集异门足论

    No. 1536

阿毗达磨集异门足论卷第一

        尊者舍利子说

        三藏法师玄奘奉　诏译

    缘起品第一

世尊一时。游力士生处。至波波邑。住折路迦林。时彼邑中诸力士众。于恒聚戏东西村间。嗢跋诺迦旧制多所。共造台观莹饰初成。未有沙门婆罗门等。及诸力士曾所受用。时力士众闻佛世尊。将苾刍僧住近林内。互相庆慰咸共议言。我等所修胜妙台观。应先请佛及苾刍僧。无上福田于中止住。然后我等随胜善业。所获资财于中受用。由斯我等长夜获得。利益安乐岂不善哉。诸力士众作是议已。各集徒侣并诸眷属。出波波村往如来所。到已顶礼世尊双足。右绕三匝退坐一面。时薄伽梵以慈软音。慰问力士并诸眷属。复以种种微妙法门。示现教导赞励庆喜。说是事已默然而住。诸力士辈闻佛所说。欢喜踊跃即从座起。合掌恭敬俱白佛言。我此邑中诸力士众。于恒聚戏东西村间。嗢跋诺迦旧制多所。共造台观莹饰初成。未有沙门婆罗门等。及诸力士曾所受用。唯愿世尊哀愍我等。将诸弟子于中止住。令我长夜利益安乐。尔时如来哀愍彼故。将诸弟子往住其中。复以妙音。为诸力士宣扬种种施果差别。问答往还过初夜分。诸力士辈并其眷属。闻法欢喜礼佛而去

尔时世尊告舍利子。吾今背痛暂当寝息。汝可代吾为苾刍众宣说法要勿空度也。时舍利子默然受教。佛便四叠嗢怛罗僧。敷为卧具大衣为枕。端身累足右胁而卧。如理作意住光明想。及当起想具念正知。如大宝山寂然无动

尔时舍利子。告苾刍众言。此波波村离系亲子。处无惭众自号为师。其人命终未逾旬月。诸弟子辈两两结朋。诤讼纷纭互相陵蔑。各言法律我解非余。如我所知是法是律。我之所说应理合仪。汝等于斯悉皆绝分。于其师教各随己执。回换前后或减或增。破析支离遂成多部。欲知胜负便共激论。为脱过难递相诽斥。虽有论言而无论道。口出刀槊以相残害。诸有白衣信彼法者。见其弟子乖诤如斯。皆共嗔嫌毁而舍去

时舍利子复告众言。此波波村离系亲子。所有法律恶说恶受。不能出离不趣正觉。是可坏法无趣无依。我等如来应正等觉大师法律。善说善受能永出离。能趣正觉非可坏法有趣有依。我等今应闻佛住世。和合结集法毗奈耶。勿使如来般涅槃后。世尊弟子有所乖诤。当令随顺梵行法律。久住利乐无量有情。哀愍世间诸天人众。令获殊胜义利安乐

    集异门足论一法品第二

时舍利子复告众言。具寿当知佛于一法。自善通达现等觉已。为诸弟子宣说开示。我等今应和合结集。佛灭度后勿有乖诤。当令随顺梵行法律。久住利乐无量有情。哀愍世间诸天人众。令获殊胜义利安乐。一法云何。嗢柁南曰

  一法谓有情　　依食依行住
  于一切善法　　不放逸为尊

一切有情皆依食住。一切有情皆依行住。于诸善法不放逸胜是谓一法。一切有情依食住者。何等是食而言有情皆依食住。如世尊说。苾刍当知食有四种。能令部多有情安住。及能资益诸求生者。何谓四食。一者段食若粗若细。二者触食。三者意思食。四者识食。由此四食说诸有情皆依食住。何缘故知诸有情类皆依食住。谓诸有情于彼彼聚。由此诸食未尽为因。有想等想施设言说。活住存济差别而转。若诸有情于彼彼聚。由此诸食已尽为因。有想等想施设言说。死殁殒逝差别而转。由此故知诸有情类皆依食住

问如是四食当言有为当言无为。答应言有为。问如是四食当言常当言无常。答应言无常。问如是四食当言恒当言非恒。答应言非恒。问如是四食当言变易当言不变易。答应言变易。问如是四食当言缘已生。当言非缘已生。答应言缘已生。问如是四食当言名摄当言色摄。答段食应言色摄。余三食应言名摄。问如是四食当言有见当言无见。答应言无见。问如是四食当言有对当言无对。答段食应言有对。余三食应言无对。问如是四食当言是心当言非心。当言是心所当言非心所。当言心相应当言心不相应。答段食应言非心非心所心不相应。触意思食应言是心所与心相应。识食应言唯是心。问如是四食当言善。当言不善当言无记。答段食应言无记。余三食应言或善或不善或无记。云何善触食。答若善有漏触为缘。能令诸根长养大种增益。又能滋润随滋润。充悦随充悦。护随护转随转。持随持是谓善触食。云何不善触食。答若不善触为缘。能令诸根长养大种增益。又能滋润随滋润。乃至持随持是谓不善触食。云何无记触食。答若无记触为缘。能令诸根长养大种增益。又能滋润随滋润。乃至持随持是谓无记触食。云何善意思食。答若善有漏触相应诸思等。思现前等。思已思思类造心意业。是谓善意思食。云何不善意思食。答若不善触相应诸思等。思乃至意业是谓不善意思食。云何无记意思食。答若无记触相应诸思等。思乃至意业是谓无记意思食。云何善识食。答若善有漏思相应诸心意识。是谓善识食。云何不善识食。答若不善思相应。诸心意识是谓不善识食。云何无记识食。答若无记思相应。诸心意识是谓无记识食。问如是四食当言有漏。当言无漏。答应言有漏。问如是四食当言学当言无学。当言非学非无学。答应言非学非无学。问如是四食当言欲界系。当言色界系。当言无色界系。答段食应言欲界系。余三食应言或欲界系。或色界系。或无色界系

问诸食皆是段食耶。答诸段食皆是食。有是食非段食。谓余三食及世俗。问诸食皆是触食耶。答诸触食皆是食。有是食非触食。谓余三食及世俗。问诸食皆是意思食耶。答诸意思食皆是食。有是食非意思食。谓余三食及世俗。问诸食皆是识食耶。答诸识食皆是食。有是食非识食。谓余三食及世俗。问诸段皆是食耶。答应作四句。有是段而非食。谓段为缘诸根损减大种变坏。有是食而非段。谓余三食及世俗。有是段亦是食。谓段为缘诸根长养大种增益。又能滋润随滋润。乃至持随持。有非段亦非食。谓除前相。问诸触皆是食耶。答应作四句。有是触而非食。谓无漏触及有漏触为缘。诸根损减大种变坏。有是食而非触。谓余三食及世俗。有是触亦是食。谓有漏触为缘。诸根长养大种增益。又能滋润随滋润乃至持随持。有非触亦非食。谓除前相。如触食有四句。意思识食应知亦尔。颇有食为缘。生食生非食生食非食耶。答生。云何食为缘生食。答段食为缘生余三食。云何食为缘生非食。答段食为缘。生受想作意等。云何食为缘。生食非食。答段食为缘。生余三食及受想作意等。颇有非食为缘。生非食生食生食非食耶。答生。云何非食为缘生非食。答如眼及色为缘。生受想作意等。云何非食为缘生食。答如眼及色为缘。生触意思识食。云何非食为缘。生食非食。答如眼及色为缘。生触意思识食。及受想作意等。颇有食非食为缘。生食非食。生食生非食耶。答生。云何食非食为缘。生食非食。答如眼及色眼识为缘。生触意思识食。及受想作意等。云何食非食为缘生食。答如眼及色眼识为缘。生触意思识食。云何食非食为缘。生非食。答如眼及色眼识为缘。生受想作意等。问若段食已断已遍知。触食亦尔耶。答若触食已断已遍知。段食亦尔。有段食已断已遍知。非触食。谓已离欲染未离上染。如以段食对触食。对意思识食亦尔。问若触食已断已遍知。意思食亦尔耶。答如是。如以触食对意思食。对识食亦尔。问若意思食已断已遍知。识食亦尔耶。答如是。问若于食已断已遍知。彼于欲色无色界已离染耶。答若于段食已断已遍知。彼于欲界已离染。非于色无色界。若于余三食已断已遍知。彼于欲色无色界皆已离染。尔时于一切一切事一切种一切位一切处一切结。皆已离染故

一切有情依行住者。何等是行。而言有情皆依行住。如世尊说。苾刍当知。若诸有情于彼彼聚不死不殒。不破不没不失不退。皆由寿住命根相续。此寿命根说名为行。由此行故一切有情存济住活。此行于彼能护随护能转随转。由此故说一切有情皆依行住。何缘故知诸有情类皆依行住。谓诸有情于彼彼聚。由此寿行未尽为因。有想等想施设言说活住存济差别而转。若诸有情于彼彼聚。由此寿行已尽为因。有想等想施设言说。死没殒逝差别而转。由此故知诸有情类皆依行住

问如是寿行当言有为。当言无为。答应言有为。问如是寿行当言常。当言无常。答应言无常。问如是寿行当言恒当言非恒。答应言非恒。问如是寿行当言变易。当言不变易。答应言变易。问如是寿行当言缘已生。当言非缘已生。答应言缘已生。问如是寿行当言名摄。当言色摄。答应言名摄。问如是寿行当言有见。当言无见。答应言无见。问如是寿行当言有对。当言无对。答应言无对。问如是寿行当言是心当言非心。当言是心所。当言非心所。当言心相应。当言心不相应。答应言非心非心所心不相应。问如是寿行当言善。当言不善。当言无记。答应言无记。问如是寿行当言有漏。当言无漏。答应言有漏。问如是寿行当言学当言无学。当言非学非无学。答应言非学非无学。问如是寿行当言欲界系。当言色界系。当言无色界系。答应言或欲界系。或色界系。或无色界系。云何欲界系。答欲界寿云何色界系。答色界寿。云何无色界系。答无色界寿

问若欲界寿已断已遍知。色界寿亦尔耶。答若色界寿已断已遍知。欲界寿亦尔。有欲界寿已断已遍知。非色界寿。谓已离欲染未离色染。问若欲界寿已断已遍知。无色界寿亦尔耶。答若无色界寿已断已遍知。欲界寿亦尔。有欲界寿已断已遍知。非无色界寿。谓已离欲染未离无色染。问若色界寿已断已遍知。无色界寿亦尔耶。答若无色界寿已断已遍知。色界寿亦尔。有色界寿已断已遍知。非无色界寿。谓已离色染未离无色染。问若于寿行已断已遍知。彼于欲色无色界。已离染耶。答若于欲界寿行已断已遍知。彼于欲界已离染。非于色无色界。若于色界寿行已断已遍知。彼于欲色界已离染。非无色界。若于无色界寿行已断已遍知。彼于欲色无色界皆已离染。尔时于一切一切事一切种一切位一切处一切结。皆已离染故

于一切善法不放逸胜者。云何不放逸。答若为断不善法。为圆满善法。常习常修坚作恒作。数修不止名不放逸

    集异门足论二法品第三之一

时舍利子复告众言。具寿当知。佛于二法自善通达。现等觉已。为诸弟子宣说开示。我等今应和合结集。佛灭度后勿有乖诤。当令随顺梵行法律。久住利乐无量有情。哀愍世间诸天人众。令获殊胜义利安乐。二法云何。嗢柁南曰

  二法谓名色　　乃至尽无生
  总二十七门　　应随次别释

有二法。谓名色。复有二法。谓无明有爱。复有二法。谓有见无有见。复有二法。谓无惭无愧。复有二法。谓惭愧。复有二法。谓恶言恶友。复有二法。谓善言善友。复有二法。谓入罪善巧出罪善巧。复有二法。谓入定善巧出定善巧。复有二法。谓界善巧作意善巧。复有二法。谓质直柔和。复有二法。谓堪忍可乐

复有二法。谓和顺供养。复有二法。谓具念正知。复有二法。谓思择力修习力。复有二法。谓不护根门。食不知量。复有二法。谓能护根门。于食知量。复有二法。谓匮戒匮见。复有二法。谓破戒破见。复有二法。谓具戒具见。复有二法。谓净戒净见。复有二法。谓见如理胜。复有二法。谓厌如理胜。复有二法。谓于善不喜足。于断不遮止。复有二法。谓奢摩他毗钵舍那。复有二法。谓明解脱。复有二法。谓尽智无生智。此中有二法。谓名色者。名云何。答受蕴想蕴行蕴识蕴。及虚空择灭非择灭。是谓名。色云何。答四大种及所造色。是谓色

复有二法。谓无明有爱者。无明云何。答如法蕴论说。有爱云何。答色无色界诸贪等。贪执藏防护耽着爱染。是谓有爱

复有二法。谓有见无有见者。有见云何。答若谓我世间常。由此发起忍乐观见是谓有见。云何无有见。答若谓我世间断。由此发起忍乐观见。是谓无有见

复有二法。谓无惭无愧者。无惭云何。答如世尊说。有无惭者。于可惭法而不生惭。可惭法者。谓诸恶不善法。顺杂染顺后有。有炽然苦异熟。顺当来生老死。彼于如是恶不善法生时。无惭无所惭无别惭。无羞无所羞。无别羞无崇敬。无所崇敬。无随属无所随属。于自在者无怖畏转。是谓无惭。无愧云何。答如世尊说。有无愧者于可愧法而不生愧。可愧法者。谓诸恶不善法。乃至顺当来生老死。彼于如是恶不善法生时。无愧无所愧。无别愧无耻无所耻无别耻。于诸罪中不怖不畏。不见怖畏是谓无愧

复有二法。谓惭愧者。惭云何。答如世尊说。诸有惭者于可惭法而生于惭。可惭法者。谓诸恶不善法。乃至顺当来生老死。彼于如是恶不善法生时。有惭有所惭有别惭。有羞有所羞有别羞有崇敬有所崇敬。有随属有所随属。于自在者有怖畏转。是谓惭。愧云何。答如世尊说。诸有愧者于可愧法而生于愧。可愧法者。谓诸恶不善法。乃至顺当来生老死。彼于如是恶不善法生时。有愧有所愧有别愧。有耻有所耻有别耻。于诸罪中有怖有畏。能见怖畏是谓愧

复有二法。谓恶言恶友者。恶言云何。答如法蕴论说。恶友云何。答亦如法蕴论说

复有二法。谓善言善友者。善言云何。答如有一类。若亲教若同亲教。若轨范若同轨范。若余随一尊重可信往还朋友。如法告言。汝从今去。勿坏身业。勿坏语业。勿坏意业。勿行不应行处。勿亲近恶友。勿作三恶趣业。如是教诲称法应时。于所修道随顺磨莹。增长严饰宜便常委。助伴资粮于此教诲。欣喜爱乐信受随顺。不左取而右取。不拒逆不毁訾不非拨。是谓善言。善友云何。答如法蕴论说

复有二法。谓入罪善巧出罪善巧者。入罪善巧云何。答罪谓五部五蕴罪。何等为五。一者他胜。二者众余。三者堕煮。四者对首。五者恶作。入罪善巧。谓如实知见。如是苾刍犯他胜罪。如是苾刍犯众余罪。如是苾刍犯堕煮罪。如是苾刍犯对首罪。如是苾刍犯恶作罪。复次如实知见。如是苾刍犯趣他胜罪。如是苾刍犯趣众余罪。如是苾刍犯趣堕煮罪。如是苾刍犯趣对首罪。如是苾刍犯趣恶作罪。复次如实知见。此苾刍犯如是他胜罪。此苾刍犯如是众余罪。此苾刍犯如是堕煮罪。此苾刍犯如是对首罪。此苾刍犯如是恶作罪。复次如实知见。此苾刍犯趣如是他胜罪。此苾刍犯趣如是众余罪。此苾刍犯趣如是堕煮罪。此苾刍犯趣如是对首罪。此苾刍犯趣如是恶作罪。复次如实知见。诸苾刍所犯罪若重若轻。若深若浅若有余若无余。若隐覆若不隐覆。若显了若不显了。若已发露若未发露。若已除灭若未除灭。若可说若不可说。若可作若不可作。于如是入种种罪中。解了等了近了遍了。机黠通达审察聪睿。觉明慧行毗钵舍那。是谓入罪善巧。出罪善巧云何。答罪谓五部五蕴罪。如前说出。罪善巧。谓如实知见众余。堕煮。对首。恶作四罪。可出其事云何。如有说言。我如是说如是显。于如是罪非说非显。我如此说如此显。于如是罪是说是显。我如是显了如是发露。如是作法于如是罪。非发露非除灭。我如此显了如此发露。如此作法于如是罪。是发露是除灭。于如是出种种罪中解了。乃至毗钵舍那。是谓出罪善巧

说一切有部集异门足论卷第一阿毗达磨集异门足论卷第二

        尊者舍利子说

        三藏法师玄奘奉　诏译

    二法品第三之二

复有二法。谓入定善巧出定善巧者。入定善巧云何。答定谓八部八蕴定。即四静虑四无色定入定善巧。谓如实知见如是补特伽罗。入初静虑定。如是补特伽罗。乃至入非想非非想处定。复次如实知见如是补特伽罗。于初静虑定有善巧作意。如是补特伽罗。乃至于非想非非想处定有善巧作意。复次如实知见如是补特伽罗。入初静虑道。如是补特伽罗。乃至入非想非非想处道。复次如实知见如是补特伽罗。于入初静虑道。有善巧作意。如是补特伽罗。乃至于入非想非非想处道。有善巧作意。其事云何。如有说言。我如是作意如此作意。于入初静虑定。乃至入非想非非想处定。善等了善近了善分别。善思惟善通达。我如是想如是观。如是胜解如是任持如是分别。于入初静虑定。乃至入非想非非想处定。善等了乃至善通达。我如是摄心策心伏心。持心举心舍心制心纵心。于入初静虑定。乃至入非想非非想处定善等了乃至善通达。我如是法于入定。及入定善巧。无作用无利益。无多所作但为障碍。我于此法善等了乃至善通达。我如是法于入定。及入定善巧有作用有利益。有多所作不为障碍。我于此法。善等了乃至善通达。于如是入种种定中。解了等了近了遍了。机黠通达审察聪睿。觉明慧行毗钵舍那。是谓入定善巧。出定善巧云何。答定谓八部八蕴定。即四静虑四无色定出定善巧。谓如实知见如是补特伽罗。出初静虑定。如是补特伽罗。乃至出非想非非想处定。复次如实知见如是补特伽罗。于出初静虑定有善巧作意。如是补特伽罗。乃至于出非想非非想处定。有善巧作意。复次如实知见如是补特伽罗。出初静虑道。如是补特伽罗。乃至出非想非非想处道。复次如实知见如是补特伽罗。于出初静虑道。有善巧作意。如是补特伽罗。乃至于出非想非非想处道。有善巧作意。其事云何。如有说言我如是作意。如此作意于出初静虑定。乃至出非想非非想处定。善等了善近了善分别。善思惟善通达。我如是想如是观。如是胜解如是任持如是分别。于出初静虑定。乃至出非想非非想处定。善等了乃至善通达。我如是摄心策心伏心。持心举心舍心制心纵心。于出初静虑定。乃至出非想非非想处定。善等了乃至善通达。我如是法于出定。乃至出定善巧无作用。无利益无多所作但为障碍。我于此法善等了乃至善通达。我如是法于出定。乃至出定善巧有作用。有利益有多所作不为障碍。我于此法善等了。乃至善通达。于如是出种种定中解了。乃至毗钵舍那。是谓出定善巧。复有二法。谓界善巧作意善巧者。界善巧云何。答如有苾刍如实知见十八界。谓眼界色界眼识界。耳界声界耳识界。鼻界香界鼻识界。舌界味界舌识界。身界触界身识界。意界法界意识界。复次如实知见六界。谓地界水界火界风界空界识界。复次如实知见六界。谓欲界恚界害界。出离界无恚界无害界。复次如实知见六界。谓乐界苦界喜界忧界舍界无明界。复次如实知见四界。谓受界想界行界识界。复次如实知见三界。谓欲界色界无色界。复次如实知见三界。谓色界无色界灭界。复次如实知见三界。谓过去界未来界现在界。复次如实知见三界。谓劣界中界妙界。复次如实知见三界。谓善界不善界无记界。复次如实知见三界。谓学界无学界非学非无学界。复次如实知见二界。谓有漏界无漏界。复次如实知见二界。谓有为界无为界。于如是种种界。解了等了近了遍了。机黠通达审察聪睿。觉明慧行毗钵舍那。是谓界善巧作意。善巧云何。答如有苾刍。或受持素呾缆。或受持毗奈耶。或受持阿毗达磨。或闻亲教师说。或闻轨范师说。或闻展转传授藏说。或闻随一如理者说。依止如是如理所引闻所成慧。于眼界乃至意识界。有善巧作意。思惟非常苦空非我。于地界乃至识界有善巧作意。思惟非常苦空非我。于欲恚害界有善巧作意。思惟非常苦空非我。于出离无恚无害界。有善巧作意。思惟非常空非我。于乐苦喜忧舍无明界。有善巧作意。思惟非常苦空非我。于受想行识界。有善巧作意。思惟非常苦空非我。于欲色无色界。有善巧作意。思惟非常苦空非我。于色无色界有善巧作意。思惟非常苦空非我。于灭界有善巧作意。思惟空非我。于过去未来现在界有善巧作意。思惟非常苦空非我。于劣中界有善巧作意。思惟非常苦空非我。于妙界有善巧作意。思惟非常。苦空非我。于善不善无记界有善巧作意。思惟非常苦空非我。于学无学界有善巧作意。思惟非常空非我。于非学非无学界有善巧作意。思惟非常苦空非我。于有漏界有善巧作意。思惟非常苦空非我。于无漏界有善巧作意。思惟非常苦空非我。于有为界有善巧作意。思惟非常苦空非我。于无为界有善巧作意。思惟空非我。复次如有苾刍。如实知见过去未来现在作意。善不善无记作意。欲界系色界系无色界系作意。学无学非学非无学作意。见所断修所断非所断作意。于如是等种种作意。解了乃至毗钵舍那。是谓作意善巧

复有二法。谓质直柔和者。质直云何。答心不刚性。心不强性。心不硬性。心纯质性。心正直性。心润滑性。心柔软性。心调顺性。是谓质直。柔和云何。答身不刚性。身不强性。身不硬性。身纯质性。身正直性。身润滑性。身柔软性。身调顺性。是谓柔和

复有二法。谓堪忍可乐者。堪忍云何。答谓能忍受。寒热饥渴风日蚊虻蛇蝎等触。又能忍受他粗恶语。能起身中猛利切心夺命苦受。是谓堪忍。可乐云何。答设有事至。不可容纳不可矜持。不可回转不可忍耐。而能于彼不暴不恶。不粗不犷堪忍可乐。易可共住止息众恶。若有事至。可能容纳可能矜持。可能回转可能忍耐。亦能于彼不暴不恶。不粗不犷堪忍可乐。易可共住止息众恶。是谓可乐

复有二法。谓和顺供养者。和顺云何。答若有乐作可喜乐语可爱味语。容貌熙怡远离频蹙。先言慰问具寿善来。事可忍不。可存济不。安乐住不。食易得不。乐作如是可喜语等诸悦豫事。是谓和顺。供养云何。答供养有二种。一财供养。二法供养。财供养云何。答以可意色声香味触。衣服饮食卧具医药及余资具。于他有情能惠能施能随惠施。能弃能舍能遍弃舍。是谓财供养。法供养云何。答以素呾缆或毗奈耶或阿毗达磨。或亲教语或轨范语或传授藏。或余随一可信者。语于他有情。能惠能施能随惠施。能弃能舍能遍弃舍。是谓法供养。如是二种总名供养

复有二法。谓具念正知者。具念云何。答若依出离远离善法。诸念随念专念忆念。不忘不失不遗不漏。不失法性心明记性。是谓具念。正知云何。答若依出离远善法。于法拣择极拣择最极拣择。解了等了近了遍了。机黠通达审察聪睿。觉明慧行毗钵舍那。是谓正知

复有二法。谓思择力修习力者。思择力云何。答如世尊说。苾刍当知。诸多闻圣弟子应如是学。诸身恶行现法当来招恶异熟。谓我若行身恶行者。现自厌毁。亦复为他天神诸佛之所诃责。亦为有智同梵行者以法讥嫌。一切世界恶名流布。身坏命终堕崄恶趣生于地狱。由正了知诸身恶行。现法当来招恶异熟。故能勤断诸身恶行。亦能勤修诸身妙行。于语恶行及意恶行广说亦尔。乃至勤修语意妙行。若能如是因思择。依思择住思择。断不善法修诸善法。说名思择亦名为力。是谓思择力。修习力云何。答如世尊说。苾刍当知。诸多闻圣弟子修念等觉支。依止厌依止离。依止灭回向于舍。修择法精进喜轻安定舍等觉支。依止厌依止离。依止灭回向于舍。若能如是因修习。依修习住修习。断不善法修诸善法。说名修习亦名为力。是谓修习力。问何故名力。答以因此力依此力住此力。能断能碎能破。一切结缚随眠随烦恼缠。故名为力

复有二法。谓不护根门食不知量者。不护根门云何。答如世尊说。苾刍当知。无闻异生眼见色已。由眼根故取相随好。即于是处不护眼根。由住不护起世贪忧。恶不善法随心生长。彼于眼根不防不守。由斯故说不护眼根。以不护眼根贪嗔痴生长。耳鼻舌身意根亦尔。且说意根者。谓意了法已由意根故取相随好。即于是处不护意根。由住不护起世贪忧。恶不善法随心生长。彼于意根不防不守。由斯故说不护意根。以不护意根贪嗔痴生长。彼由发起非理思择眼。见诸色耳闻诸声。鼻嗅诸香舌尝诸味。身觉诸触意了诸法。于六根门不防不等防。不遍防不藏。不覆不蔽不寂静。不调伏不守护。是谓不护根门。食不知量云何。答如世尊说。苾刍当知。无闻异生不思择而食。为勇健故为傲逸故。为颜貌故为端严故。而食所食不思择而食者。谓住非理所引思择而食所食。为勇健故食所食者。谓如一类食所食时。起如是心我食此食必使饱满令身勇健。能作重业能荷重担。资益寿量久住世间。能摧怨敌能越车乘。能远跳掷能作种种世间掉戏。为傲逸故食所食者。谓如一类食所食时。起如是心我食此食必使饱满令我傲逸憍醉之心起等起生等生。相续引发陵蔑一切。随情所乐作纵逸业。为颜貌故食所食者。谓如一类食所食时起如是心我食此食。必使饱满当令我身容貌光鲜肤体润滑。为端严故食所食者。谓如一类食所食时。起如是心。我食此食必使饱满。当令我身成就第一美妙形色众所爱敬。诸有如是爱重饮食。于诸饮食不平等性。不知量性不黠慧性。不了其相不了相已不自裁量。我今但应食尔所食。是谓食不知量。复有二法。谓能护根门。于食知量者能护根门云何。答如世尊说苾刍当知。诸多闻圣弟子。眼见色已由眼根故。不取其相不取随好。即于是处能护眼根。由住能护不起世贪。忧恶不善法不随心生长。彼于眼根能防能守。由斯故说能护眼根。以能护眼根贪嗔痴不起。耳鼻舌身意根亦尔。且说意根者。谓意了法已由意根故。不取其相不取随好。即于是处能护意根。由住能护不起世贪忧恶不善法。不随心生长。彼于意根能防能守。由斯故说能护意根。以能护意根贪嗔痴不起。彼由发起如理思择。眼见诸色。耳闻诸声。鼻嗅诸香。舌尝诸味。身觉诸触。意了诸法。于六根门能防能等防能遍防。能藏能覆能蔽能寂静。能调伏能守护。是谓能护根门。于食知量云何。答如世尊说。苾刍当知。诸多闻圣弟子能思择而食。不为勇健不为傲逸。不为颜貌不为端严。而食所食但为此身。暂住存济止息饥渴。摄受梵行而食所食。为断故受不起新受。无罪存济力乐安住而食所食。能思择而食者。谓住如理所引。思择而食所食。不为勇健食所食者。非如一类食所食时。起如是心我食此食。必使饱满令身勇健。能作重业能荷重担。资益寿量久住世间。能摧怨敌能越车乘。能远跳掷能作种种世间掉戏。不为傲逸食所食者。非如一类食所食时。起如是心我食此食。必使饱满令我傲逸。憍醉之心起等起生等生。相续引发陵蔑一切。随情所乐作纵逸业。不为颜貌食所食者。非如一类食所食时。起如是心我食此食。必使饱满当令我身。容貌光鲜肤体润滑。不为端严食所食者。非如一类食所食时。起如是心我食此食。必使饱满当令我身成就第一美妙形色众所爱敬。但为此身暂住存济。食所食者。谓身亦名身身根亦名身。五色根亦名身。四大种所造聚亦名身。于此义中说四大种所造聚身。诸圣弟子食所食时。但起是心我食此食。令四大种所造聚身。暂住等住近住安住故名暂住。诸圣弟子食所食时。但起是心我食此食。令四大种所造聚身存随存济。随济护随护转随转故名存济。但为止息饥渴食所食者。此中饥渴所起苦受说名饥渴。诸圣弟子食所食时。但起是心我食此食。当令饥渴所起苦受。暂时止息不为恼害。但为摄受梵行食所食者。谓离淫欲亦名梵行。八支圣道亦名梵行。于此义中八支圣道说名梵行。诸圣弟子食所食时。但起是心我食此食。为欲摄受随顺增益八支圣道。为断故受不起新受食所食者。不食为缘所起苦受说名故受。饱食为缘所起苦受说名新受。诸圣弟子食所食时。但起是心我食此食。为断故受不起新受。非为充悦为无罪。存济而食所食者。存济有二种。一有罪存济。二无罪存济。云何有罪存济。答如有一类矫妄诡诈现相激磨。以利求利而求饮食。如是方便得饮食已欢喜受用。贪爱迷闷耽着不舍。不见过患不知出离。如是名为有罪存济。云何无罪存济。答非如一类矫妄诡诈现相激磨。以利求利而求饮食。如实方便得饮食已如法受用。不贪不爱不迷不闷不耽不着。能见过患善知出离。如是名为无罪存济。诸圣弟子但为如是无罪存济。而食所食为力乐故食所食者。谓圣弟子食所食时。但起是心我食此食。欲令身力得不衰退。心受喜乐能办善事。为安住故食所食者。谓圣弟子食所食时。但起是心我食此食。欲令行立坐卧读诵。修定等时身心安隐。诸有如是不重饮食。于诸饮食有平等性。有知量性有黠慧性。能了其相既了相已。能自裁量我今但应食尔所食。是谓于食知量。复有二法。谓匮戒匮见者。匮戒云何。答断生命不与取欲邪行。虚诳语离间语粗恶语杂秽语。复次若断生命若不与取若非梵行。复次诸所有不善戒。诸所有非理所引戒。诸所有障碍定戒。是谓匮戒。问何故名匮戒。答此法自性不可爱。不可乐不可喜。不可意不安隐。不正直不可欣。不悦意违正理。复次此法能得不可爱果。不可乐果不可喜果。不可意果不安隐果。不正直果不可欣果。不悦意果违正理果。复次此法能感不可爱异熟。不可乐异熟不可喜异熟。不可意异熟不安隐异熟。不正直异熟不可欣异熟。不悦意异熟违正理异熟故名匮戒匮见云何。答诸所有见无惠施。无亲爱无祠祀。无妙行无恶行。无妙行恶行业果异熟。无此世无他世。无母无父无化生有情。无世间阿罗汉正至正行。谓于此世他世。自通达作证证知。我生已尽梵行已立。所作已办不受后有。复次诸所有不善见。诸所有非理所引见。诸所有障碍定见。是谓匮见。问何故名匮见。答此法自性不可爱。乃至违正理。复次此法能得不可爱果。乃至违正理果。复次此法能感不可爱异熟。乃至违正理异熟故名匮见。如匮戒匮见。应知破戒破见亦尔

复有二法。谓具戒具见者。具戒云何。答离断生命离不与取。离欲邪行离虚诳语离离间语。离粗恶语离杂秽语。复次离断生命离不与取离非梵行。复次诸所有学戒。诸所无学戒诸所有善非学非无学戒。是谓具戒。问何故名具戒。答此法自性可爱。可乐可喜可意安隐。正直可欣悦意随顺正理。复次此法能得可爱果。可乐果可喜果。可意果安隐果。正直果可欣果。悦意果顺正理果。复次此法能感可爱异熟。可乐异熟可喜异熟。可意异熟安隐异熟。正直异熟可欣异熟。悦意异熟顺正理异熟。故名具戒。具见云何。答诸所有见。有惠施有亲爱。有祠祀有妙行有恶行。有妙行恶行业果异熟。有此世有他世。有母有父有化生有情。有世间阿罗汉正至正行。谓于此世他世自通达。作证具足住如实证知。我生已尽梵行已立。所作已办不受后有。复次诸所有学见。诸所有无学见。诸所有善非学非无学见。是谓具见。问何故名具见。答此法自性可爱。乃至随顺正理。复次此法能得可爱果。乃至顺正理果。复次此法能感可爱异熟。乃至顺正理异熟。故名具见。如具戒具见。应知净戒净见亦尔

复有二法。谓见如理胜者。见云何。答谓依出离远离善法。于法拣择极拣择最极拣择。解了等了近了遍了。机黠通达审察聪睿。觉明慧行毗钵舍那。是谓见。如理胜云何。答谓有苾刍如其所见。若由如是诸行相状。世间正见未生而生。彼便如理思惟如是诸行相状彼由如理思惟如是诸行相状。便令圣道起等起生等生转现转修集出现。是名道如理胜。复次若有苾刍如其所见。若由如是诸行相状随一出离。远离善法未生而生。彼便如理思惟如是诸行相状。彼由如理思惟如是诸行相状。便令圣道起等起生等。生转现转修集出现。是名道如理胜。如是二种总名如理胜

复有二法。谓厌如理胜者。厌云何。答谓依四种顺厌处法而生于厌。如理胜云何。答谓正思惟引生圣道。何等为四顺厌处法。一自衰损顺厌处法。二他衰损顺厌处法。三自兴盛顺厌处法。四他兴盛顺厌处法。依自衰损顺厌处法。而生于厌如理胜者。如有一类等随观见。自身恶行语恶行意恶行。究竟圆满增上淳熟。便作是念。我因放逸。依放逸住放逸。由放逸故造斯恶事。我今当令恶不善法。未生者不生。已生者永断。彼由如是出离勇猛。所引生厌是名为厌。既生厌已如理思惟。复令圣道起等起生等。生转现转修集出现。是名道如理胜。如是名为依自衰损厌如理胜。依他衰损顺厌处法。而生于厌如理胜者。如有一类等随观见。自他身恶行语恶行意恶行。究竟圆满增上淳熟。便作是念。彼因放逸。依放逸住放逸。由放逸故造斯恶事。我今当令恶不善法。未生者不生已生者永断。彼由如是出离勇猛。所引生厌是名为厌。既生厌已如理思惟。复令圣道起等起生等。生转现转修集出现。是名道如理胜。如是名为依他衰损厌如理胜。依自兴盛顺厌处法而生于厌如理胜者。如有一类等随观见。自身妙行语妙行意妙行。究竟圆满增上淳熟。便作是念。我因不放逸。依不放逸住不放逸。由不放逸故作斯善事。我今当令诸胜善法。未生者生已生者倍复增广。彼由如是出离勇猛所引生厌。是名为厌。既生厌已如理思惟。复令圣道起等起生等。生转现转修集出现。是名道如理胜。如是名为依自兴盛厌如理胜。依他兴盛顺厌处法而生于厌如理胜者。如有一类等随观见。他身妙行语妙行意妙行。究竟圆满增上淳熟。便作是念。彼因不放逸。依不放逸住不放逸。由不放逸故作斯善事。我今当令诸胜善法。未生者生已生者倍复增广。彼由如是出离勇猛所引生厌。是名为厌。既生厌已如理思惟。复令圣道起等起生等。生转现转修集出现。是名道如理胜。如是名为依他兴盛厌如理胜

复有二法。谓于善不喜足。于断不遮止者。于善不喜足云何。答于善喜足者。如有一类唯得少戒便生喜足。唯得少禁便生喜足。唯得离欲便生喜足。唯得不净观便生喜足。唯得持息念等便生喜足。或唯得初静虑。乃至第四静虑便生喜足。或唯得慈无量。乃至舍无量便生喜足。或唯得空无边处定。乃至非想非非想处定便生喜足。或唯得预流果。一来果。不还果。便生喜足。或唯得神境智证通。天耳智证通。他心智证通。宿住随念智证通。死生智证通。便生喜足。此等名为于善喜足。于善不喜足者。如有一类非唯得少戒便生喜足。广说乃至非唯得死生智证通便生喜足。彼作是念。我修诸善。乃至未得阿罗汉果。于其中间终不喜足。是名于善不喜足。于断不遮止云何。答于断遮止者。如有一类为断不善法。为圆满善法。勇猛精进炽然爱乐。勤修不息。作是念言。云何令我速疾证得如理善法。彼于如是勇猛精进炽然爱乐。勤修习时未能证得如理善法。便作是念。我所修断。空虚无果无利无义无味无益。由彼于断谓无胜利。便生厌患诽谤毁呰。如是名为于断遮止。复有一类为断不善法。为圆满善法。勇猛精进炽然爱乐勤修不息。作是念言。云何令我速疾证得如理善法。彼于如是勇猛精进。炽然爱乐勤修习时。未能证得如理善法。或虽证得而不了知。便作是念。我所修断。空虚无果无利无义无味无益。由彼于断谓无胜利。便生厌患诽谤毁呰。如是亦名于断遮止

说一切有部集异门足论卷第二阿毗达磨集异门足论卷第三

        尊者舍利子说

        三藏法师玄奘奉　诏译

    二法品第三之余

于断不遮止者。如有一类为断不善法。为圆满善法。勇猛精进炽然爱乐勤修不息。作是念言。云何令我速疾证得如理善法。彼于如是勇猛精进。炽然爱乐勤修习时。未能证得如理善法。便作是念。如世尊说无处无容。善男子等勤修正行。而不证得如理善法。由我所修正行未满。是故未证如理善法。我所修断定应不空不虚。有果有利有义有味有益。由彼于断知有胜利。不生厌患诽谤毁呰。是名于断不遮止。复有一类为断不善法。为圆满善法。勇猛精进炽然爱乐勤修不息。作是念言。云何令我速疾证得如理善法。彼于如是勇猛精进。炽然爱乐勤修习时。未能证得如理善法。或虽证得而不了知。便作是念。如世尊说无处无容。善男子等勤修正行。而不证得如理善法。由我所修正行未满。是故未证如理善法。我所修断定应不空不虚。有果有利有义有味有益。由彼于断知有胜利。不生厌患诽谤毁呰。是名于断不遮止。复有一类为断不善法。为圆满善法。勇猛精进炽然爱乐勤修不息。作是念言。云何令我速疾证得如理善法。彼于如是勇猛精进。炽然爱乐勤修习时。遂能证得如理善法。便作是念。我所修断决定不空不虚。有果有利有义有味有益。由彼于断知有胜利。不生厌患诽谤毁呰。是名于断不遮止

复有二法。谓奢摩他毗钵舍那者。奢摩他云何。答善心一境性是谓奢摩他。毗钵舍那云何。答奢摩他相应。于法拣择极拣择最极拣择。解了等了近了遍了。机黠通达审察聪睿。觉明慧行毗钵舍那。是谓毗钵舍那。如世尊说

  非有定无慧　　非有慧无定
  要有定有慧　　方证于涅槃

非有定无慧者。谓若有如是类慧。则有获得如是类定。若无如是类慧。则无获得如是类定。故说非有定无慧。非有慧无定者。谓若有慧是定所生以定为集。是定种类由定而发。若有如是类定。则有获得如是类慧。若无如是类定。则无获得如是类慧。故说非有慧无定。要有定有慧方证于涅槃者。爱尽离灭名曰涅槃。要具定慧方能证得。若随阙一必不能证。由此因缘故作是说。要有定有慧方证于涅槃。复次或有补特伽罗。得内心止不得增上慧法观。或有补特伽罗。得增上慧法观不得内心止。或有补特伽罗。不得内心止。亦不得增上慧法观。或有补特伽罗。得内心止亦得增上慧法观。何等补特伽罗。得内心止不得增上慧法观。答若补特伽罗。得世间四静虑。不得出世圣慧。何等补特伽罗。得增上慧法观。不得内心止。答若补特伽罗。得出世圣慧。不得世间四静虑。何等补特伽罗。不得内心止。亦不得增上慧法观。答若补特伽罗。不得世间四静虑。亦不得出世圣慧。何等补特伽罗。得内心止亦得增上慧法观。答若补特伽罗。得世间四静虑。亦得出世圣慧。如说世间四静虑相应。心住等住近住安住。不散不乱摄止等持。心一境性者。此显内心止。如说出世圣慧所摄。于法拣择极拣择最极拣择。解了等了近了遍了。机黠通达审察聪睿。觉明慧行毗钵舍那者。此显增上慧法观。是名奢摩他毗钵舍那

复有二法。谓明解脱者。明云何。答无学三明。何等为三。一者无学宿住随念智作证明。二者无学死生智作证明。三者无学漏尽智作证明。是谓明。解脱云何。答三种解脱。何等为三。一者心解脱。二者慧解脱。三者无为解脱。心解脱者。谓无贪善根相应心。已胜解当胜解今胜解。是名心解脱。慧解脱者。谓无痴善根相应心。已胜解当胜解今胜解。是名慧解脱。无为解脱者。谓择灭。是名无为解脱。此中心解脱或学或无学或非学非无学。云何学。答学无贪善根相应心。已胜解当胜解今胜解。是谓学。云何无学。答无学无贪善根相应心。已胜解当胜解今胜解。是谓无学。云何非学非无学。答有漏无贪善根相应心。已胜解当胜解今胜解。是谓非学非无学。慧解脱或学或无学。或非学非无学。云何学。答学无痴善根相应心。已胜解当胜解今胜解。是谓学。云何无学。答无学无痴善根相应心。已胜解当胜解今胜解。是谓无学。云何非学非无学。答有漏无痴善根相应心。已胜解当胜解今胜解。是谓非学非无学。无为解脱唯非学非无学。是名明解脱。复有二法。谓尽智无生智者。尽智云何。答谓如实知我已知苦。我已断集。我已证灭。我已修道。此所从生智见明觉解慧光观。是名尽智。无生智云何。答谓如实知我已知苦不复当知。我已断集不复当断。我已证灭不复当证。我已修道不复当修。此所从生智见明觉解慧光观。是名无生智。复次若如实知已尽欲漏有漏无明漏。是名尽智。若如实知所尽三漏不复当生是无生智。复次若如实知已尽一切结缚随眠随烦恼缠。是名尽智。若如实知所尽。一切结缚随眠随烦恼缠不复当起。是名无生智

    集异门足论三法品第四之一

时舍利子复告众言。具寿当知。佛于三法自善通达。现等觉已。为诸弟子宣说开示。我等今应和合结集。佛灭度后勿有乖诤。当令随顺梵行法律。久住利乐无量有情。哀愍世间诸天人众。令获殊胜义利安乐。三法云何。此中有五嗢柁南颂。初嗢柁南曰

  初三法有十　　谓根寻行界
  前三各有二　　后一有四种

有三不善根三善根。三不善寻三善寻。三恶行三妙行。欲恚害三界出离无恚无害三界欲色无色三界色无色灭三界

三不善根者。谓贪不善根。嗔不善根。痴不善根。贪不善根者。贪云何。答谓于欲境诸贪等贪执藏防护坚着爱乐迷闷耽嗜遍耽嗜内缚欲求耽湎苦集贪类贪生总名为贪。不善根云何。答谓此贪法是不善性能为无量不善法根。是故此法能为病根痈根箭根恼根苦根秽根浊根诸杂染根不清净根不鲜白根。是故名为贪不善根。嗔不善根者。嗔云何。答谓于有情欲为损害。内怀栽杌欲为扰恼。已嗔当嗔现嗔。乐为过患极为过患意极忿恚于诸有情各相违戾欲为过患。已为过患当为过患现为过患。总名为嗔。不善根云何。答谓此嗔法是不善性。能为无量不善法根。是故此法能为病根痈根箭根恼根苦根秽根。浊根诸杂染根不清净根不鲜白根。是故名为嗔不善根。痴不善根者。痴云何。答谓于前际无知。后际无知。前后际无知。于内无知。外无知。内外无知。于业无知。异熟无知业异熟无知。于善作业无知。恶作业无知。善恶作业无知。于因无知因所生法无知。于佛无知法无知僧无知。于苦无知集无知灭无知道无知。于善法无知不善法无知。于有罪法无知无罪法无知。于应修法无知不应修法无知。于下劣法无知胜妙法无知。于黑法无知白法无知。于有敌对法无知。于缘生法无知。于六触处如实无知。如是无知无见非现观。黑闇愚痴无明盲冥。罩网缠裹顽騃浑浊障盖。发盲发无明发无智。灭胜慧障碍善品令不涅槃。无明漏无明暴流无明轭。无明毒根无明毒茎。无明毒枝无明毒叶。无明毒花无明毒果。痴等痴极痴改等改极改。痴类痴生改类改生。总名为痴。不善根云何。答谓此痴法是不善性。能为无量不善法根。是故此法能为病根痈根箭根恼根苦根秽根浊根诸杂染根。不清净根不鲜白根。是故名为痴不善根。如世尊说

  诸恶贪嗔痴　　恼害自心者
  如树心有蝎　　皮果等皆衰

三善根者。谓无贪善根。无嗔善根。无痴善根。无贪善根者。无贪云何。答谓于欲境诸不贪。不等贪不执藏不防护不坚着不爱不乐。不迷心闷不耽嗜不遍耽嗜不内缚不欲不求不耽湎。非苦集非贪类非贪生总名无贪。善根云何。答谓无贪法是善性。能为无量善法根。是故此法能为无病根。无痈根无箭根无秽根无浊根不杂染根清净根鲜白根。是故名为无贪善根。无嗔善根者。无嗔云何。答谓于有情不欲损害。不怀栽杌不欲扰恼。非已嗔非当嗔非现嗔。不乐为过患不极为过患意不愤恚。于诸有情不相违戾不欲为过患。非已为过患。非当为过患。非现为过患。总名无嗔。善根云何。答谓无嗔法是善性。能为无量善法根。是故此法能为无病根。无痈根无箭根无秽根无浊根不杂染根清净根鲜白根。是故名为无嗔善根。无痴善根者。无痴云何。答谓知前际智。后际智前后际智。知内智外智内外智。知业智异熟智业异熟智。知善作业智恶作业智善恶作业智。知因智因所生法智。知佛智法智僧智。知苦智集智灭智道智。知善法智不善法智。知有罪法智无罪法智。知应修法智不应修法智。知下劣法智胜妙法智。知黑法智白法智。知有敌对法智。知缘生法智。知六触处如实智。如是智见明觉解慧光观总名无痴。善根云何。答谓无痴法是善性。能为无量善法根。是故此法能为无病根。无痈根无箭根无秽根无浊根不杂染根清净根鲜白根。是故名为无痴善根。如世尊说

  若离贪嗔痴　　说名为智者
  亦名为上士　　不恼害自心
  是故应远离　　贪嗔及无明
  勤修起慧明　　速得众苦尽

三不善寻者。谓欲寻恚寻害寻。欲寻云何。答欲贪相应诸心寻求。遍寻求近寻求。心显了极显了现前显了。推度构画思惟分别总名欲寻。恚寻云何。答嗔相应诸心寻求。遍寻求近寻求。心显了极显了现前显了。推度构画思惟分别总名恚寻。害寻云何。答害相应诸心寻求。遍寻求近寻求。心显了极显了现前显了。推度构画思惟分别。总名害寻。如世尊说

  恶寻伏众生　　令于秽见净
  倍增长贪爱　　自为坚固缚

三善寻者。谓出离寻无恚寻无害寻。出离寻云何。答于诸欲寻思惟过患。谓此欲寻是不善法。诸下贱者信解受持。一切如来及诸弟子。贤贵善士共所呵厌。能为自害。能为他害。能为俱害。能灭智慧。能碍彼品。能障涅槃。受持此法不生通慧。不引菩提不证涅槃。如是思惟诸欲寻过患时。诸心寻求遍寻求近寻求。心显了极显了现前显了。推度构画思惟分别名出离寻。复次为断欲寻于出离寻思惟功德。谓出离寻是胜善法。是尊胜者信解受持。一切如来及诸弟子贤贵善士共所称赞。不为自害。不为他害。不为俱害。不灭智慧。不碍彼品。不障涅槃。受持此法能生通慧。能引菩提能证涅槃。如是思惟出离寻功德时。诸心寻求乃至分别名出离寻。复次思惟欲寻如病。如痈如箭恼害。无常苦空非我转动。劳倦羸笃是失坏法。迅速不停衰朽非恒。不可保信是变坏法。如是思惟诸欲寻时。诸心寻求乃至分别名出离寻。复次为断欲寻思惟彼灭。是真寂静思惟彼道是真出离。如是思惟彼灭道时。诸心寻求乃至分别名出离寻。复次思惟舍心定。及道舍心定相应。无想定灭定择灭。如是思惟时诸心寻求。乃至分别名出离寻。复次思惟出离。及出离相应受想行识。及彼等起身语业心不相应行时。诸心寻求乃至分别名出离寻。无恚寻云何。答于诸恚寻思惟过患。谓此恚寻是不善法。诸下贱者信解受持。一切如来及诸弟子。贤贵善士共所呵厌。能为自害。能为他害。能为俱害。能灭智慧。能碍彼品。能障涅槃。受持此法不生通慧。不引菩提不证涅槃。如是思惟诸恚寻过患时。诸心寻求遍寻求近寻求。心显了极显了现前显了。推度构画思惟分别名无恚寻。复次为断恚寻于无恚寻思惟功德。谓无恚寻是胜善法。是尊胜者信解受持。一切如来及诸弟子。贤贵善士共所称赞。不为自害。不为他害。不为俱害。不灭智慧。不碍彼品。不障涅槃。受持此法能生通慧。能引菩提。能证涅槃。如是思惟无恚寻功德时。诸心寻求乃至分别名无恚寻。复次思惟恚寻如病。如痈如箭恼害。无常苦空非我转动劳倦羸笃是失坏法。迅速不停衰朽非恒。不可保信是变坏法。如是思惟诸恚寻时。诸心寻求乃至分别名无恚寻。复次为断恚寻思惟彼灭是真寂静。思惟彼道是真出离。如是思惟彼灭道时。诸心寻求乃至分别名无恚寻。复次思惟慈心定。及道慈心定相应。无想定灭定择灭。如是思惟时诸心寻求。乃至分别名无恚寻。复次思惟无恚。及无恚相应受想行识。及彼等起身语业心不相应行时。诸心寻求。乃至分别名无恚寻。无害寻云何。答于诸害寻思惟过恚。谓此害寻是不善法诸下贱者信解受持。一切如来及诸弟子。贤贵善士共所呵厌。能为自害。能为他害。能为俱害。能灭智慧。能碍彼品。能障涅槃。受持此法不生通慧。不引菩提。不证涅槃。如是思惟诸害寻过患时。诸心寻求遍寻求近寻求。心显了极显了现前显了。推度构画思惟分别名无害寻。复次为断害寻。于无害寻思惟功德。谓无害是胜善法。是尊胜者信解受持。一切如来及诸弟子。贤贵善士共所称赞。不为自害。不为他害。不为俱害。不灭智慧。不碍彼品。不障涅槃。受持此法能生通慧。能引菩提。能证涅槃。如是思惟无害寻功德时。诸心寻求乃至分别名无害寻。复次思惟害寻如病。如痈如箭恼害。无常苦空非我转动。劳倦羸笃是失坏法。迅速不停衰朽非恒。不可保信。是变坏法。如是思惟诸害寻时。诸心寻求乃至分别名无害寻。复次为断害寻。思惟彼灭是真寂静。思惟彼道是真出离。如是思惟彼灭道时。诸心寻求乃至分别名无害寻。复次思惟悲心定。及道悲心定相应。无想定灭定择灭。如是思惟时诸心寻求。乃至分别名无害寻。复次思惟无害。及无害相应受想行识。及彼等起身语业心不相应行时。诸心寻求乃至分别名无害寻。如世尊说

  乐灭诸恶寻　　勤修不净观
  常念断贪爱　　能坏坚固缚

三恶行者。谓身恶行语恶行意恶行。身恶行云何。答断生命不与取欲邪行。复次断生命不与取非梵行。复次诸所有不善身业。诸所有非理所引身业。诸所有身业能障碍定。总名身恶行。语恶行云何。答虚诳语离间语粗恶语杂秽语。复次诸所有不善语业。诸所有非理所引语业。诸所有语业能障碍定。总名语恶行。意恶行云何。答贪欲嗔恚邪见。复次诸所有不善意业。诸所有非理所引意业。诸所有意业能障碍定。总名意恶行。如世尊说

  若造身恶行　　语意恶行已
  不修对治者　　当堕于地狱

三妙行者。谓身妙行语妙行意妙行。身妙行云何。答离断生命离不与取离欲邪行。复次离断生命离不与取离非梵行。复次诸学身业诸无学身业。诸善非学非无学身业。总名身妙行。语妙行云何。答离虚诳语离离间语离粗恶语离杂秽语。复次诸学语业诸无学语业诸善非学非无学语业。总名语妙行。意妙行云何。答无贪无嗔正见。复次诸学意业。诸无学意业。诸善非学非无学意业。总名意妙行。如世尊说

  若修身妙行　　语意妙行已
  无余缘碍者　　当生天受乐

欲界恚界害界。及出离界无恚界无害界。如法蕴论说。欲界色界无色界。亦如法蕴论说。如世尊说

  诸有能遍知　　欲色无色界
  超一切依故　　当触无余依
  身证甘露界　　无漏不思议
  世尊说涅槃　　为饶益含识

色界无色界灭界。亦如法蕴论说。如世尊说

  住色界有情　　及住无色界
  不证知灭故　　定当往后有
  若遍知色界　　不住于无色
  趣向究竟灭　　后解脱生死

第二嗢柁南曰

  二三法有十　　世言依处行
  心数趣上座　　聚举不护三

有三世三言依三色处三行三心。三补特伽罗三上座三聚三举罪事三不护

三世者。谓过去世未来世现在世。过去世云何。答诸行已起已等起。已生已等生。已转已现转。已聚集已出现。落谢过去尽灭离变。过去性过去类过去世摄。是谓过去世。未来世云何。答诸行未已起未已等起。未已生未已等生。未已转未已现转。未聚集未出现。未来性未来类。未来世摄。是谓未来世。现在世云何。答诸行已起已等起。已生已等生。已转已现转。聚集出现。住未已谢。未已尽灭。未已离变和合现前。现在性现在类现在世摄。是谓现在世。问世是何义。答世是显示诸行增语。三言依者。谓过去言依未来言依现在言依。过去言依者云何。过去云何言云何依。而说过去言依耶。答诸行已起已等起。已生已等生。已转已现转。已聚集已出现。落谢过去尽灭离变。过去性过去类过去世摄。是谓过去。即依如是过去诸行所起。语言唱词评论呼召宣说显示教诲。语路语音语业语表是谓言。即前所说过去诸行亦名为依。是言因本眼路缘起无间引发。能作生缘集等起故。依过去行起诸言说故。过去诸行名过去言依。未来言依者云何。未来云何言云何依。而说未来言依耶。答诸行未已起未已等起。未已生未已等生。未已转未已现转。未聚集未出现。未来性未来类未来世摄。是谓未来。即依如是未来诸行所起。语言唱词评论呼召宣说显示教诲。语路语音语业语表是谓言。即前所说未来诸行亦名为依。是言因本眼路缘起无间引发。能作生缘集等起故。依未来行起论言说故。未来诸行名未来言依。现在言依者。云何现在云何言云何依。而说现在言依耶。答诸行已起已等起。已生已等生。已转已现转。聚集出现。住未已谢未已尽灭。未已离变和合现前现在性现在类。现在世摄。是谓现在。即依如是现在诸行所起。语言唱词评论呼召宣说显示教诲。语路语音语业语表是谓言。即前所说现在诸行亦名为依。是言因本眼路缘起无间引发。能作生缘集等起故。依现在行起诸言说故。现在诸行名现在言依。无第四第五者依有为说。谓有为法唯有三种更无第四第五可得。有说此依一切法说。诸无为法即是现在言依摄故。更无第四第五可得。如世尊说

  乐言想有情　　恒依言想住
  未遍知言想　　趣生死无穷
  若遍知言想　　于他无所说
  亦不乐他说　　常欣修静虑
  寂定勤精进　　见生死尽边
  摧伏诸魔军　　至生死彼岸

三色处者。谓有三处摄一切色。何等为三。一者有色有见有对。二者有色无见有对。三者有色无见无对。云何有见有对色。答一处。云何无见有对色。答九处。云何无见无对色。答一处。少分

三行者。谓身行语行意行。身行云何。答身亦名身行。身业亦名身行。入息出息亦名身行。于此义中意说入息出息身行。所以者何。入息者呼吸外风令入身内。出息者引发内风令出身外。由此势力令身动转通畅安隐。故入出息说为身行。语行云何。答语亦名语行。语业亦名语行。寻伺亦名语行。于此义中意说寻伺语行。所以者何。要寻伺已能发语言非无寻伺是故寻伺说为语行。意行云何。答意亦名意行。意业亦名意行。想思亦名意行。于此义中意说想思意行。所以者何。以想及思是心所法。依止于心系属于心。依心而转扶助于心。是故想思说为意行

三心者。一漏疮喻心。二电光喻心。三金刚喻心。漏疮喻心云何。答如世尊说。苾刍当知。世有一类补特伽罗。禀性暴恶言喜粗犷。少有触恼便多愤恚。结怨佷[仁-二+戾]语言凶勃。如恶漏疮才被物触。便多流出脓血不止。彼心亦尔少遇违缘。即便愤恚怨恨不息。问何故彼心名漏疮喻。答彼心意识暂触违缘。便速发生种种秽恶。是故名曰漏疮喻心

说一切有部集异门足论卷第三阿毗达磨集异门足论卷第四

        尊者舍利子说

        三藏法师玄奘奉　诏译

    三法品第四之二

电光喻心云何。答如世尊说。苾刍当知。世有一类补特伽罗。居阿练若或居树下或住空闲。精勤修习多修习故。证得如是寂静心定。依是定心能永断五顺下分结得不还果。受上化生即住上界。得般涅槃不复还来生于欲界。如过夏分至秋初时。从大云台电光发已。暂现色像速还隐没。如是一类补特伽罗。居阿练若乃至广说。彼所得心名电光喻。问何故彼心名电光喻。答彼心意识证不还果。暂能照了速还隐没。是故名曰电光喻心。金刚喻心云何。答如世尊说。苾刍当知。世有一类补特伽罗。居阿练若或居树下或住空闲。精勤修习多修习故。证得如是寂静心定。依是定心能尽诸漏。证得无漏心慧解脱。于现法中以胜通慧。自证觉受圆满功德。谓自证知我生已尽。梵行已立所作已办不受后有。譬如金刚无有少物。而不能断或穿或破。所谓若铁若牙若贝。若角若珠若玉石等。如是一类补特伽罗。居阿练若乃至广说。彼所得心名金刚喻。问何故彼心名金刚喻。答彼心意识证无学果。无结缚等而不能坏。是故名曰金刚喻心

三补特伽罗者。一者覆慧补特伽罗。二者膝慧补特伽罗。三者广慧补特伽罗。云何覆慧补特伽罗。答如世尊说。苾刍当知。世有一类补特伽罗。为听法故苾刍前坐。苾刍哀愍为说法要。开示初善中善后善。文义巧妙纯一圆满。清白梵行彼在法座。于所说法初中后分皆不能知。从座起已于所说法。初中后分亦不能了。所以者何。彼都无慧犹如覆器亦如覆瓶。虽多溉水竟无受入。如是一类补特伽罗。为听法故苾刍前坐。广说乃至彼都无慧。是名覆慧补特伽罗。问何故名覆慧补特伽罗。答彼有是慧在法座时。于所说法初中后分。虽皆欲知而无慧故皆不能知。彼有是慧从座起已。于所说法初中后分。虽皆欲了而无慧故。亦不能了故名覆慧补特伽罗。云何膝慧补特伽罗。答如世尊说。苾刍当知。世有一类补特伽罗。为听法故苾刍前坐。苾刍哀愍为说法要。开示初善中善后善。文义巧妙纯一圆满。清白梵行彼在法座。于所说法初中后分。虽皆能知而从座起。于所说法初中后分皆不能了。先虽领受而后忘失。譬如有人得妙饮食。置于膝上以失念故。欻从座起皆悉坠落。如是一类补特伽罗。为听法故苾刍前坐。广说乃至而后忘失。是名膝慧补特伽罗。问何故名膝慧补特伽罗。答彼有是慧在法座时。于所说法初中后分。随所欲知以有慧故。虽皆能知彼有是慧。而从座起于所说法初中后分虽皆欲了。而无慧故皆不能了。先虽领受而后忘失。故名膝慧补特伽罗。云何广慧补特伽罗。答如世尊说。苾刍当知。世有一类补特伽罗。为听法故苾刍前坐。苾刍哀愍为说法要。开示初善中善后善。文义巧妙纯一圆满。清白梵行彼在法座。于所说法初中后分皆悉能知。从座起已于所说法初中后分亦悉能了。复能善知所说义趣。如刹帝利女或婆罗门女。或长者女或居士女。清水沐浴妙香涂身。梳剪发爪莹饰眉面。服鲜净衣着诸缨络。以环钏等而自庄严。唯少花鬘未冠其首。有诸尊者持妙花鬘。谓嗢钵罗瞻博迦等。随其所好而授与之。诸女尔时欢喜踊跃。恭敬受取冠在顶上。深心爱玩终无遗失。如是一类补特伽罗。为听法故苾刍前坐。乃至善知所说义趣。是名广慧补特伽罗。问何故名广慧补特伽罗。答彼有是慧在法座时。于所说法初中后分随所欲知。以有慧故皆悉能知。彼有是慧从座起已。于所说法初中后分随所欲了。以有慧故亦悉能了。复能善知所说义趣。故名广慧补特伽罗。如世尊说

  覆慧不聪明　　虽数多闻法
  无智不能了　　如灌覆瓶器
  膝慧胜于前　　坐听虽能了
  而起已皆忘　　如遗膝上食
  广慧最为胜　　在法座若起
  于文义俱了　　如女冠花鬘
  具持念辩才　　乐修净业染
  断憍慢放逸　　能舍诸恶趣

三上座者。谓生年上座世俗上座法性上座。云何生年上座。答诸有生年尊长耆旧。是谓生年上座。云何世俗上座。答如有知法富贵长者共立制言。诸有知法大财大位。大族大力大眷属大徒众。胜我等者我等皆应推为上座。供养恭敬尊重赞叹。由此因缘虽年二十或二十五。若能知法得大财位大族大力。有大眷属大徒众者。皆应和合推为上座。供养恭敬尊重赞叹。如诸国土城邑王都。其有多闻妙解算数辩才书印。或随一一工巧业处。胜余人者皆共和合推为上座。供养恭敬尊重赞叹。如商侣中有多财者众人和合推为上座。供养恭敬尊重赞叹。如得为王或大臣等。众人皆共供养恭敬尊重赞叹。如难陀王长发王种欲兴战争。召马胜王刹帝利种。重赐财宝令其示现种种技能。知彼胜已告大臣曰。封主当知吾欲敬礼刹帝利种马胜王足。大臣白言。天不应礼刹帝利种马胜王足。所以者何。彼是臣佐君不应礼臣佐之足。如是等事有无量种。今此意说长发王种。难陀王时世俗上座。云何法性上座。答诸受具戒耆旧长宿是谓法性上座。有说此亦是生年上座。所以者何。佛说出家受具足戒名真生故。若有苾刍得阿罗汉诸漏永尽。已作所作已办所办。弃诸重担逮得己利。尽诸有结正智解脱。心善自在此中意说。如是名为法性上座。如世尊说上座颂言

  心掉多绮语　　染意乱思惟
  虽久隐园林　　而非真上座
  具戒智正念　　寂静心解脱
  彼于法能观　　是名真上座

三聚者。谓邪性定聚正性定聚不定聚。云何邪性定聚。答五无间业。云何正性定聚。答学无学法。云何不定聚。答除五无间业。余有漏法及无为

三举罪事者。谓见举罪事闻举罪事疑举罪事。见举罪事者。云何见云何举罪云何事。而说见举罪事耶。答见谓见有苾刍故思断生命。不与物而取。行非梵行淫欲法正知而说。虚诳语故思出不净。非时食饮诸酒。自手掘地。坏生草木。歌舞作乐冠饰花鬘放逸纵荡。是名为见举罪。谓五种举罪。一者觉察举罪。二者忆念举罪。三者应告羯磨举罪。四者布洒他时安立举罪。五者于恣举时安立举罪。云何觉察举罪。答谓有觉察他苾刍言。具寿已犯如是如是罪。应发露勿覆藏。发露则安隐不发露罪益深。是名觉察举罪。云何忆念举罪。答谓有教他令自忆念。告言具寿汝已曾犯如是如是罪。应发露勿覆藏。发露则安隐不发露罪益深。是名忆念举罪。云何应告羯磨举罪。答谓应告言。具寿不应不令我觉默然。从此住处出去。我于具寿欲有少言。是名应告羯磨举罪。云何布洒他时安立举罪。答谓布洒他时所差举者。作如是言。此苾刍众和合共坐作布洒他。我某苾刍为布洒他之所差举。是名布洒他时安立举罪。云何于恣举时安立举罪。答谓恣举时所差举者作如是言。此苾刍众和合共坐作恣举事。我某苾刍为恣举众之所差举。是名于恣举时安立举罪。是名举罪事。谓即前所见犯事是名为事。如是合名见举罪事。闻举罪事者。云何闻云何举罪云何事。而说闻举罪事耶。答闻谓闻有苾刍故思断生命。不与物而取。行非梵行淫欲法。正知而说虚诳语。故思出不净。非时食。饮诸酒。自手掘地。坏生草木。歌舞作乐冠饰花鬘放逸纵荡。是名为闻举罪。谓五种举罪如前说。是名举罪事。谓即前所闻犯事是名为事。如是合名闻举罪事。疑举罪事者。云何疑云何举罪云何事。而说疑举罪事耶。答疑谓五缘而生于疑。一由色故。二由声故。三由香故。四由味故。五由触故。由色故者。谓见苾刍非时入聚落非时出聚落。或与女人入出丛林。或亲狎外道。或亲狎扇搋半择迦。或亲狎苾刍尼。或亲狎淫女。或亲狎小男。或亲狎大女。或亲狎寡妇。见如是等可疑事已。便生疑念观此具寿。现行如是不清净。非沙门非随顺行。如是具寿定应已犯非梵行法。是名由色而生于疑。由声故者。谓闻苾刍非时入聚落非时出聚落。或闻与女人入出丛林或闻亲狎外道。亲狎扇搋半择迦。亲狎苾刍尼。亲狎淫女。亲狎小男。亲狎大女。亲狎寡妇。闻如是等可疑事已便生疑念。闻此具寿现行如是不清净。非沙门非随顺行。如是具寿定应已犯非梵行法。是名由声而生于疑。由香故者。如有苾刍或为澡手。或为洗面。或为饮水。或随一缘入余苾刍所住之处嗅杂染香。谓女人香或酒肉香。或涂薰香或余随一淫泆之香嗅是香已便生疑念。今此具寿所住之处。既有如是不清净。非沙门非随顺香。定应已犯非梵行法。是名由香而生于疑。由味故者。如有苾刍或为澡手。或为洗面或为饮水。或随一缘入余苾刍所住之处。见彼苾刍口中含嚼杂染诸味。谓耽餔罗龙脑豆宼或余随一淫泆之味。见彼苾刍尝是味已。便生疑念今此具寿。舌尝如是不清净非沙门非随顺味。定应已犯非梵行法。是名由味而生于疑。由触故者。如有苾刍或为澡手或为洗面。或为饮水。或随一缘入余苾刍所住之处。见彼苾刍所止床座。宝香挍饰细软杂彩。锦绣绫罗以为敷具。于床两头俱置丹枕。迦陵伽褐而覆其上。于彼住处复见女人。端正少年或坐或卧。见是事已便生疑念。今此具寿身触如是不清净。非沙门非随顺触。定应已犯非梵行法。是名由触而生于疑。是名为疑举罪。谓五种举罪如前说。是名举罪事。谓即前所疑犯事是名为事。如是合名疑举罪事

三不护者。谓诸如来三业无失。可有隐藏恐他觉知故名不护。何等为三。一者如来所有身业。清净现行无不清净。现行身业恐他觉知须有藏护。二者如来所有语业。清净现行无不清净。现行语业恐他觉知须有藏护。三者如来所有意业。清净现行无不清净。现行意业恐他觉知须有藏护。云何如来所有身业清净现行。答身业清净现行者。谓离断生命。离不与取。离欲邪行。复次离断生命。离不与取。离非梵行。复次所有学身业清净现行。所有无学身业清净现行。所有善非学非无学身业清净现行。总名身业清净现行。于此义中意说如来。所有无学身业清净现行。及所有善非学非无学身业清净现行。如来具足圆满成就如是身业清净现行。故说如来所有身业清净现行。云何如来无不清净现行身业。答不清净现行身业者。谓断生命。不与取。欲邪行。复次断生命不与取非梵行。复次所有不善身业。所有非理所引身业。所有身业能障碍定。总名不清净现行身业。如来于此不清净现行身业。已断已遍知。如断草根多罗树头。令永于后成不生法。由此如来无可隐匿覆蔽藏护。勿他见我此秽身业。故说如来无不清净现行身业。云何如来所有语业清净现行。答语业清净现行者。谓离虚诳语离离间语离粗恶语离杂秽语。复次所有学语业清净现行。所有无学语业清净现行。所有善非学非无学语业清净现行。总名语业清净现行。于此义中意说如来。所有无学语业清净现行。及所有善非学非无学语业清净现行。如来具足圆满成就如是语业清净现行。故说如来所有语业清净现行。云何如来无不清净现行语业。答不清净现行语业者。谓虚诳语离间语粗恶语杂秽语。复次所有不善语业。所有非理所引语业。所有语业能障碍定总名不清净现行语业。如来于此不清净现行语业。已断已遍知。如断草根多罗树头。令永于后成不生法。由此如来无可隐匿覆蔽藏护。勿他见我此秽语业。故说如来无不清净现行语业。云何如来所有意业清净现行。答意业清净现行者。谓无贪无嗔正起。复次所有学意业清净现行。所有无学意业清净现行。所有善非学非无学意业清净现行。总名意业清净现行。于此义中意说如来。所有无学意业清净现行。及所有善非学非无学意业清净现行。如来具足圆满成就如是意业清净现行。故说如来所有意业清净现行。云何如来无不清净现行意业。答不清净现行意业者。谓贪嗔邪见。复次所有不善意业。所有非理所引意业。所有意业能障碍定。总名不清净现行意业。如来于此不清净现行意业。已断已遍知。如断草根多罗树头。令永于后成不生法。由此如来无可隐匿覆蔽藏护。勿他见我此秽意业。故说如来无不清净现行意业

第三嗢柁南曰

  三三法有九　　谓三爱漏求
  及有黑闇身　　怖受苦慢类

有三爱三漏三求三有三黑闇身三怖三受三苦性三慢类

三爱者。一欲爱。二色爱。三无色爱。欲爱云何。答于诸欲中诸贪等贪。执藏防护耽着爱染。是谓欲爱。复次于欲界系十八界十二处五蕴诸法中诸贪等贪。执藏防护耽着爱染。是谓欲爱。复次下从无间大地狱。上至他化自在天。于此所摄色受想行识诸法中诸贪等贪。执藏防护耽着爱染。是谓欲爱。色爱云何。答于诸色中诸贪等贪。执藏防护耽着爱染。是谓色爱。复次于色界系十四界十处五蕴诸法中诸贪等贪。执藏防护耽着爱染。是谓色爱。复次下从梵众天上至色究竟天。于此所摄色受想行识。诸法中诸贪等贪。执藏防护耽着爱染。是谓色爱。无色爱云何。答于无色中诸贪等贪。执藏防护耽着爱染。是谓无色爱。复次于无色界系三界二处四蕴诸法中诸贪等贪。执藏防护耽着爱染。是谓无色爱。复次如欲色界决定处所上下差别不相杂乱。无色界中无如是事。然可依定依生胜劣说有下上。谓下从空无边处天。上至非想非非想处天。于此所摄受想行识诸法中诸贪等贪。执藏防护耽着爱染。是谓无色爱。如世尊说

  有爱诸士夫　　长世数流转
  数受胎藏苦　　往还诸有中
  断爱诸有情　　瀑流已断故
  无爱润生故　　不流转后有

复有三爱。一欲爱。二有爱。三无有爱。欲爱云何。答于诸欲中诸贪等贪。执藏防护耽着爱染。是谓欲爱。有爱云何。答色无色界诸贪等贪。执藏防护耽着爱染。是谓有爱。无有爱云何。答欣无有者。于无有中诸贪等贪。执藏防护耽着爱染。是谓无有爱。此复如何。如有一类怖畏所逼。怖畏所恼。忧苦所逼。忧苦所恼。苦受触故。作是念言。云何当令我身死后断坏无有。永绝众病岂不乐哉。彼欣无有。于无有中诸贪等贪。执藏防护耽着爱染。是谓无有爱。如世尊说

  爱所执有情　　心贪有无有
  魔轭所轭故　　身常不安乐
  流转诸有中　　生已归老死
  如犊子爱乳　　随母尝不离

三漏者。一欲漏。二有漏。三无明漏。欲漏云何。答除欲界系无明。诸余欲界系结缚随眠随烦恼缠。是谓欲漏。有漏云何。答除色无色界系无明。诸余色无色界系结缚随眠随烦恼缠。是谓有漏。无明漏云何。答三界无智。是谓无明漏。如世尊说

  若苾刍已断　　欲有无明漏
  诸漏永尽故　　无影般涅槃

三求者。一欲求。二有求。三梵行求。欲求云何。答住欲有者于欲界法未得为得。诸求随求平等随求。悕求欣求思求勤求。是谓欲求。有求。云何。答住色无色有者于色无色界法未得为得。诸求乃至勤求是谓有求。梵行求云何。答离二交会说名梵行。八支圣道亦名梵行。于此义中意说八支圣道梵行。诸有于此八支圣道未得为得。诸求乃至勤求。是谓梵行求。复次欲求者。非求死后当生诸有。然于现在可意色声香味触衣服饮食卧具病缘医药诸资生具未得为得诸求乃至勤求。是名欲求。有求者。有谓五取蕴。何等为五。谓色取蕴。受取蕴。想取蕴。行取蕴。识取蕴如有一类作是念言。云何令我得未来世如是类色受想行识。彼于死后当生诸有。色等五蕴。诸求乃至勤求。是名有求。梵行求者。从世第一法趣苦法智忍时。有梵行求非有梵行。所以者何。八支圣道说名梵行。彼于尔时未得未近得。未有未现有。从苦法智忍趣苦法智时。有梵行求亦有梵行。所以者何。八支圣道说名梵行。彼于尔时已得已近得。已有已现有。如是从苦法智趣苦类智忍。从苦类智忍趣苦类智。从苦类智趣集法智忍。从集法智忍趣集法智。从集法智趣集类智忍。从集类智忍趣集类智。从集类智趣灭法智忍。从灭法智忍趣灭法智。从灭法智趣灭类智忍。从灭类智忍趣灭类智。从灭类智趣道法智忍。从道法智忍趣道法智。从道法智趣道类智忍。从道类智忍趣道类智。从道类智趣道类智。或趣所余无漏智时。有梵行求亦有梵行。所以者何。八支圣道说名梵行。彼于尔时已得已近得。已有已现有。复次若世间道。证一来果不还果时。有梵行求非有梵行。所以者何。八支圣道说名梵行。彼于尔时未得未近得。未有未现有。若无漏道证预流果。或证一来不还阿罗汉果时。有梵行求亦有梵行。所以者何。八支圣道说名梵行。彼于尔时已得已近得。已有已现有。如世尊说

  具念定正知　　诸佛真弟子
  正知求圣道　　终不求余事
  若悕求已灭　　圣道当趣尽
  苾刍求尽故　　无影般涅槃

三有者。一欲有。二色有。三无色有。欲有云何。答若业欲界系取为缘欲感当有。彼业异熟。是谓欲有。色有云何。答若业色界系取为缘欲感当有。彼业异熟。是谓色有。无色有云何。答若业无色界系取为缘欲感当有。彼业异熟。是谓无色有

三黑闇身者。一过去黑闇身。二未来黑闇身。三现在黑闇身。过去黑闇身者。云何过去云何黑闇云何身。而说过去黑闇身耶。答过去者。谓诸行已起已等起。已生已等生。已转已现转。已聚集已出现。落谢过去尽灭离变。过去性过去类过去世摄。是谓过去。黑闇者。谓于过去行。发起种种求解异慧。广说乃至疑犹豫箭。是谓黑闇身者有说与疑相应无明名身。于此义中即疑名身。所以者何。黑谓无智。由黑故闇。说名黑闇。此即是疑即此黑闇说名为身。故名过去黑闇身。未来黑闇身者。云何未来云何黑闇云何身。而说未来黑闇身耶。答未来者。谓诸行未已起未已等起。未已生未已等生。未已转未已现转。未聚集未出现。未来性未来类未来世摄。是谓未来。黑闇者。谓于未来行发起种种求解异慧。广说乃至疑犹豫箭。是谓黑闇。身者有说与疑相应无明名身。于此义中即疑名身。所以者何。黑谓无智。由黑故闇。说名黑闇。此即是疑即此黑闇。说名为身。故名未来黑闇身。现在黑闇身者。云何现在云何黑闇云何身。而说现在黑闇身耶。答现在者。谓诸行已起已等起。已生已等生已转已现转。聚集出现住。未已谢未已尽灭。未已离变和合现前。现在性现在类现在世摄。是谓现在。黑闇者。谓于现在行发起种种求解异慧。广说乃至疑犹豫箭。是谓黑闇。身者有说与疑相应无明名身。于此义中即疑名身。所以者何。黑名无智。由黑故闇。说名黑闇。此即是疑即此黑闇。说名为身。故名现在黑闇身

三怖者。一病怖。二老怖。三死怖。病怖者云何病。答头痛等。广说如法蕴论。是谓病。云何怖。答如有一类见他病已深生厌患。自念我身亦有此分。亦有此性亦有此法未越此法。由此便生惊恐怖畏。惶惧毛竖。是谓怖。由病起怖故名病怖。老怖者云何老。答发落等。广说如法蕴论。是谓老。云何怖。答如有一类见他老已深生厌患。广说乃至惶惧毛竖。是谓怖。由老起怖故名老怖。死怖者云何死。答彼彼有情即于彼彼诸有情聚移转坏没。广说如法蕴论。是谓死。云何怖。答如有一类见他死已深生厌患。广说乃至惶惧毛竖。是谓怖。由死起怖故名死怖。如世尊说

  诸异生虽能　　厌病老死法
  而不能如实　　厌此所依身
  我能厌此身　　深了知此法
  故不乐久住　　速入无余依
  我观一切种　　无疾少年命
  病老死所坏　　唯出离安隐
  我已勤精进　　通达究竟迹
  虽不习诸欲　　而舍修梵行

说一切有部集异门足论卷第四阿毗达磨集异门足论卷第五

        尊者舍利子说

        三藏法师玄奘奉　诏译

    三法品第四之三

三受者。一乐受。二苦受。三不苦不乐受。乐受云何。答顺乐受触所生身乐心乐平等受受所摄。是谓乐受。复次修初第二第三静虑时。顺乐受触所生身乐心乐平等受受所摄。是谓乐受。苦受云何。答顺苦受触所生身苦心苦不平等受受所摄。是谓苦受。不苦不乐受云何。答顺不苦不乐受触所生身舍心舍非平等非不平等受受所摄。是谓不苦不乐受。如世尊说

  具念定正知　　诸佛真弟子
  能正知诸受　　令贪等不生
  于诸受及道　　俱令渐次灭
  苾刍受尽故　　无影般涅槃

三苦性者。一苦苦性。二坏苦性。三行苦性。苦苦性云何。答欲界诸行由苦苦故苦。坏苦性云何。答色界诸行由坏苦故苦。行苦性云何。答无色界诸行由行苦故苦。复次不可意诸行由苦苦故苦。可意诸行由坏苦故苦。顺舍诸行由行苦故苦。复次若诸苦受。若彼相应法。若彼俱有法。若从彼生。若彼种类不可爱异熟果由苦苦故苦。若诸乐受。若彼相应法。若彼俱有法。若从彼生。若彼种类可爱异熟果由坏苦故苦。若不苦不乐受。若彼相应法。若彼俱有法。若从彼生。若彼种类非可爱非不可爱异熟果由行苦故苦。复次苦苦性云何。答诸身所有由苦苦故苦。所以者何。依身生起老病死等种种苦故。坏苦性云何。答如世尊说可意朋友可意眷属可意境界。若变坏时。若遭毁谤陵蔑等时。发生愁叹忧苦悲恼。彼于尔时由坏苦故苦。行苦性云何。答除苦苦性及坏苦性。诸余有漏行由行苦故苦。三慢类者。一我胜慢类。二我等慢类。三我劣慢类。我胜慢类云何。答如有一类作是念言。我之种族形色作业工巧财位寿量力等。或总或别皆胜于彼。由此起慢。已慢当慢。心高举心恃蔑。是谓我胜慢类。我等慢类云何。答如有一类作是念言。我之种族形色作业工巧财位寿量力等。或总或别皆等于彼。由别因缘而起于慢。已慢当慢。心高举心恃蔑。是谓我等慢类。我劣慢类云何。答如有一类作是念言。我之种族形色作业工巧财位寿量力等。或总或别皆劣于彼。由别因缘而起于慢。已慢当慢。心高举心恃蔑。是谓我劣慢类

第四嗢柁南曰

  四三法有十　　谓火福欲乐
  及慧根眼仗　　六一火慧二

有三火三福业事三欲生三乐生三慧三根三眼三仗。火慧各二。余六各一。初三火者。一贪火。二嗔火。三痴火。贪火云何。答谓于欲境诸贪等贪。执藏防护坚着爱乐。迷闷耽嗜遍耽嗜内缚欲求耽湎。苦集贪类贪生。总名为贪。由此贪爱所蔽伏者。发生种种身热心热身心俱热。身烧心烧身心俱烧。身恼心恼身心俱恼。又由贪爱缠为缘故。长夜领受不可爱不可乐。不可欣不可意异熟果。是谓贪火。嗔火云何。答谓于有情欲为损害。内怀栽杌欲为扰恼。已嗔当嗔现嗔。乐为过患极为过患意极忿恚于诸有情各相违戾欲为过患。已为过患当为过患现为过患。总名为嗔。由此嗔恚所蔽伏者。发生种种身热心热身心俱热。身烧心烧身心俱烧。身恼心恼身心俱恼又由嗔恚缠为缘故。长夜领受不可爱不可乐不可欣不可意异熟果。是谓嗔火。痴火云何。答谓于前际无知后际无知前后际无知。广说乃至痴类痴生改类改生。总名为痴。由此愚痴所蔽伏者。发生种种身热心热身心俱热。身烧心烧身心俱烧。身恼心恼身心俱恼。又由愚痴缠为缘故。长夜领受不可爱不可乐。不可欣不可意异熟果。是谓痴火。如世尊说

  诸有愚夫类　　贪嗔痴火烧
  如次耽欲境　　害生憎圣法
  于三毒炽火　　若不如实知
  便耽著有身　　不能趣寂灭
  由斯履邪路　　堕三恶趣中
  受剧苦沦回　　不解脱魔缚
  正等觉弟子　　昼夜常精进
  以秽想慈慧　　如次灭三火
  从斯入圣道　　降伏诸魔军
  证得二涅槃　　清凉无取漏

后三火者。一应奉事火。二应给施火。三应供养火。应奉事火云何。答父母是子所应奉事。如世尊为高直身形婆罗门说。云何名为应奉事火。谓世父母应受其子种种乐具。随处随时无倒奉事。云何其子以诸乐具。随处随时无倒奉事应奉事火。谓族姓子以精进力。及手足力若汗血力。如法所得财物乐具。随处随时无倒奉事供养父母。何故名为应奉事火。谓族姓子从彼而生。由彼长养乃得成立。是故父母诸佛说为应奉事火。应给施火云何。答妻子奴婢作使亲友。是其家主所应给施。如世尊为高直身形婆罗门说。云何名为应给施火。谓世妻子奴婢作使及诸亲友。应受家主种种乐具随处随时无倒给施。云何家主以诸乐具。随处随时无倒给施应给施火。谓族姓子以精进力。及手足力若汗血力。如法所得财物乐具。随处随时无倒给施妻子奴婢作使亲友。何故名为应给施火。谓族姓子如法居家。其妻子等无倒承事。如教为作所应作业。令无匮乏速得成办。是故妻子奴婢作使及诸亲友。诸佛说为应给施火。应供养火云何。答真沙门婆罗门。是诸施主所应供养。如世尊为高直身形婆罗门说。云何名为应供养火。谓沙门婆罗门。若已离贪或复修行调伏贪行。若已离嗔或复修行调伏嗔行。若已离痴或复修行调伏痴行。如是沙门及婆罗门。应受施主种种乐具。随处随时无倒供养。云何施主以诸乐具。随处随时无倒供养应供养火。谓族姓子以精进力。及手足力若汗血力。如法所得财物乐具。随处随时无倒供养。如前所说。诸沙门婆罗门。何故名为应供养火谓族姓子供养阿罗汉及诸有学者。彼是世间真福田故。能令施主于中树福。感得最胜此世他世富乐异熟及解脱果。是故真沙门及真婆罗门。诸佛说为应供养火。余世间火非应奉事给施供养。彼不能令诸有情类得胜果故。如世尊说

  智者能如法　　祭事前三火
  生有乐世间　　证无苦解脱

三福业事者。一施类福业事。二戒类福业事。三修类福业事。施类福业事者。云何施类云何福云何业云何事。而说施类福业事耶。答施类者。谓施主布施诸沙门婆罗门贫穷苦行道行乞者。饮食汤药衣服华鬘涂散等香。房舍卧具灯烛等物。是名施类。复次或由身布施。谓或施身或施身业。或施所舍物。或由语布施。谓或施语或施语业。或施所舍物或由意布施。谓或施意或施意业。或施舍心。是名施类。福者谓施俱行身律仪语律仪命清净。是名福。业者谓施俱行诸思等思现等思已思思类作心意业。是名业。事者谓施主受者及所施物。是名事。此中施类名施类亦名福亦名业亦名事。此中福名为福亦名业亦名事亦名施类。此中业名为业亦名事亦名施类亦名福。此中事唯名事。戒类福业事者。云何戒类云何福云何业云何事。而说戒类福业事耶。答戒类者。谓离害生命。离不与取。离欲邪行。离虚妄语。离饮窣罗迷丽耶末陀放逸处酒。是名戒类。福者。谓戒俱行身律仪语律仪命清净。是名福。业者谓戒俱行诸思等思。现等思已思思类作心意业。是名业。事者谓若防若止若遮。若离害生命事。是离害生命事。若防若止若遮。若离不与取事。是离不与取事。若防若止若遮。若离欲邪行事。是离欲邪行事。若防若止若遮。若离虚妄语事。是离虚妄语事。若防若止若遮。若离饮窣罗迷丽耶末陀放逸处酒事。是离饮诸酒事。是名事。此中戒类名为戒类。亦名福亦名业亦名事。此中福名为福亦名业亦名事亦名戒类。此中业名为业亦名事亦名戒类亦名福。此中事名为事亦名戒类亦名福亦名业。修类福业事者。云何修类云何福云何业云何事。而说修类福业事耶。答修类者。谓慈悲喜舍四无量。是名修类。福者谓无量俱行身律仪语律仪命清净。是名福。业者谓无量俱行诸思等思现等思已思思类作心意业。是名业。事者谓所缘事缘彼而起四无量。是名事。此中修类名为修类。亦名福亦名业亦名事。此中福名为福亦名业亦名事亦名修类。此中业名为业亦名事亦名修类亦名福。此中事唯名事。如世尊说

  智者能依法　　勤学施戒修
  生无苦世间　　受三种乐果

三欲生者。有诸有情。乐受现前诸妙欲境。彼于现前诸妙欲境富贵自在转。谓人全天一分是第一欲生。有诸有情乐受自化诸妙欲境。彼于自化诸妙欲境富贵自在转。谓乐变化天是第二欲生。有诸有情乐受他化诸妙欲境。彼于他化诸妙欲境富贵自在转。谓他化自在天是第三欲生。此中有诸有情者。谓诸有情谛义胜义。不可得不可近得。非有非现有但于诸蕴界处。由想等想假言说转谓为有情那罗意生儒童命者生者养者士夫补特伽罗。由斯故说有诸有情乐受现前。诸妙欲境者。谓彼有情恒乐受用藏护积集委寄安置。随本所生现前欲境。彼于现前诸妙欲境富贵自在转者。谓彼有情于所受用。藏护积集委寄安置。随本所生现前欲境。有势力得自在随意受用。谓人全者。显一切人。天一分者。显欲界下四天。是第一者。谓随算数渐次顺次相续次。第此居第一。欲生者。谓此于欲界生。复次有诸有情者。谓诸有情谛义胜义不可得。广说如前。乐受自化诸妙欲境者。谓乐变化天造化增长如是类业。彼由此业随所爱乐。化作种种男女等事而自娱乐。谓若天女化作天男而自娱乐。若诸天男化作天女而自娱乐。彼于自化诸妙欲境富贵自在转者。谓乐变化天造作增上如是类业。彼由此业随所爱乐。化作种种男女等事。彼于此事有势力得自在随意受用。谓乐变化天者。显一切乐变化天。是第二者。谓随算数渐次顺次相续次第。此居第二。欲生者。谓此于欲界生。复次有诸有情者。谓诸有情谛义胜义不可得。广说如前。乐受他化诸妙欲境者。谓他化自在天造作增长如是类业。彼由此业与诸他化自在天。虽同一类身同一趣同一生同一进趣。而有高下胜劣差别。诸下劣天子化作种种色声香味触诸妙欲境。令高胜天子于中受用。彼于他化诸妙欲境富贵自在转者。谓他化自在天造作增长如是类业。彼由此业随所爱乐。令他下劣天子化作种种色声香味触诸妙欲境。彼高胜天子于此欲境有势力得自在随意受用。譬如梵天虽同类同一趣同一生同一进趣。而有高下胜劣差别。谓梵众天下劣梵辅天高胜。梵辅天下劣大梵天高胜。他化自在天亦复如是。造作增长如是类业。彼由此业。广说如前。谓他化自在天者。显一切他化自在天。是第三者。谓随算数渐次顺次相续次第。此居第三。欲生者。谓此于欲界生

三乐生者有诸有情。即如是身离生喜乐之所滋润遍滋润。适悦遍适悦。充满遍充满。滋润乃至遍充满已安乐而住。谓梵众天是第一乐生。有诸有情。即如是身定生喜乐之所滋润遍滋润。适悦遍适悦。充满遍充满。滋润乃至遍充满已安乐而住。谓极光净天是第二乐生。有诸有情。即如是身离喜之乐之所滋润遍滋润。适悦遍适悦。充满遍充满滋润乃至遍充满已安乐而住。谓遍净天是第三乐生。此中有诸有情者。谓诸有情谛义胜义。不可得不可近得非有非现有。但于诸蕴界处。由想等想假言说转。谓为有情那罗意生儒童命者生者养者士夫补特伽罗。由斯故说有诸有情。即如是身者。身名为身。身业亦名身。身根亦名身。五有色根亦名身。四大种聚亦名身。今此义中意说四大种聚身。故说即如是身。离生喜乐者。谓初静虑中所可得乐平等受受所摄。是名离生喜乐之所滋润遍滋润适悦遍适悦。充满遍充满者。谓梵众天于此离生喜乐随欲而得。无艰无难即此离生喜乐。起等起。生等生。聚集出现。能令如是四大种聚身。滋润遍滋润。适悦遍适悦。充满遍充满。滋润乃至遍充满已安乐住者。谓彼尔时由离生喜乐。身心无苦恼安乐而住。如世尊于分别生记经中说。苾刍当知。如修定者从此处没生梵众天。数现受离生喜乐。彼先住此入初静虑。亦数现受离生喜乐。彼先后所受离生喜乐无异无差别。依定等故。谓先此间于初静虑。若习若修若多所作。后方生彼梵众天故。二所受离生喜乐品类相似。谓梵众天者显初静虑。梵众等天是第一者。谓随算数渐次顺次相续次第此居第一。乐生者。谓此生处长时受安隐乐。离苦乐乐受乐故名乐生。复次有诸有情者。谓诸有情谛义胜义不可得广说如前。即如是身者。身名为身。乃至广说。定生喜乐者。谓第二静虑中所可得乐平等受受所摄。是名定生喜乐之所滋润遍滋润。适悦遍适悦。充满遍充满者。谓极光净天于此定生喜乐随欲而得。无艰无难即此定生喜乐起等起。生等生。聚集出现。能令如是四大种聚身。滋润遍滋润。适悦遍适悦。充满遍充满。滋润乃至遍充满已安乐住者。谓彼尔时由定生喜乐。身心无苦恼安乐而住。如世尊于分别生记经中说。苾刍当知。如修定者。从此处没生极光净天。数数现受定生喜乐。彼先住此入第二静虑。亦数现受定生喜乐。彼先后所受定生喜乐。无异无差别。依定等故。谓先此间于第二静虑。若习若修若多所作。后方生彼极光净天故。二所受定生喜乐品类相似。谓极光净天者。显第二静虑极光净等天。是第二者谓随算数渐次顺次相续次第。此居第二。乐生者。谓此生处长时受安隐乐。离苦乐乐受乐故名乐生。复次有诸有情者。谓诸有情谛义胜义不可得。广说如前。即如是身者。身名为身乃至广说。离喜之乐者谓第三静虑中所可得乐平等受受所摄。是名离喜之乐之所滋润遍滋润。适悦遍适悦。充满遍充满者。谓遍净天于此离喜之乐随欲而得。无艰无难即此离喜之乐。起等起。生等生。聚集出现。能令如是四大种聚身。滋润遍滋润。适悦遍适悦。充满遍充满。滋润乃至遍充满已安乐住者。谓彼尔时由离喜之乐。身心无苦恼安乐而住。如世尊于分别生记经中说。苾刍当知。如修定者。从此处没生遍净天。数数现受离喜之乐。彼先住此入第三静虑。亦数现受离喜之乐。彼先后所受离喜之乐。无异无差别。依定等故。谓先此间于第三静虑。若习若修若多所作。后方生彼遍净天故。二所受离喜之乐品类相似。谓遍净天者。显第三静虑遍净等天。是第二者。谓随算数渐次顺次相续次第。此居第三。乐生者。谓此生处长时受安隐乐。离苦乐乐受乐故名乐生

初三慧者。一闻所成慧。二思所成慧。三修所成慧。闻所成慧云何。答因闻依闻由闻建立。于彼彼处有势力得自在正遍通达。其事如何。如有苾刍。或受持素呾缆。或受持毗奈耶。或受持阿毗达磨。或闻亲教师说。或闻轨范师说。或闻展转传授藏说。或闻随一如理者说。是名为闻。因此闻依此闻由此闻建立故。于彼彼处有势力得自在正遍通达。是名闻所成慧。思所成慧云何。答因思依思由思建立。于彼彼处有势力。得自在正遍通达。其事如何。谓如有一如理思惟书数算印。或随一一所作事业。是名为思。因此思依此思由此思建立故。于彼彼处有势力得自在正遍通达。是名思所成慧。修所成慧云何。答因修依修由修建立。于彼彼处有势力得自在正遍通达。其事如何。谓如有一方便善巧。自勤修习诸离染道。由此所修离染道故。离欲恶不善法。有寻有伺离生喜乐。入初静虑具足住。广说乃至入第四静虑具足住。是名为修。因此修依此修由此修建立故。于彼彼处有势力。得自在正遍通达。是名修所成慧。有作是说。如此亦是思所成慧。所以者何。唯依佛法不共所修。乃可名为修所成慧。今此义中依诸等引所起寂静慧。皆名修所成慧

后三慧者。一学慧。二无学慧。三非学非无学慧。学慧云何。答学作意相应。于法栋择极栋择最极栋择。解了等了近了遍了。机黠通达审察聪睿。觉明慧行毗钵舍那。是名学慧。无学慧云何。答无学作意相应。于法栋择。广说乃至毗钵舍那。是名无学慧。非学非无学慧云何。答有漏作意相应。于法栋择广说乃至毗钵舍那。是名非学非无学慧

三根者。一未知当知根。二已知根。三具知根。如法蕴论广说其相。如世尊说

  学者学诸根　　恒随正直道
  常委勤精进　　守护于自心
  初慧根无间　　生第二慧根
  若第三慧根　　解脱位方有
  不动解脱位　　诸有结永尽
  无漏根圆满　　乐止息诸根
  将入永寂灭　　任持最后身
  降伏诸魔军　　证毕竟常乐

三眼者。一肉眼。二天眼。三圣慧眼。肉眼云何。答杂骨肉血净四大种所造。眼界眼处眼根。是名肉眼。天眼云何。答不杂骨肉血极净四大种所造眼界眼处眼根。是名天眼。圣慧眼云何。答诸有学慧及无学慧。并一切善非学非无学慧。是名圣慧眼。如世尊说

  肉眼最为劣　　天眼名次上
  圣慧眼最胜　　有三种差别
  诸世间善慧　　能顺趣决择
  学无学正知　　尽生老病死
  大觉天人中　　名称最高远
  亦由慧速证　　妙觉庄严身

三仗者。一闻仗。二离仗。三慧仗。闻仗云何。答多闻闻持闻积集者。若所说法初中后善。文义巧妙纯一圆满清白梵行。于如是法具足多闻。忆持所闻言教纯熟专意观察所闻言教。于诸法义见善通达。是名为闻。因此闻由此闻建立故。能断不善法能修诸善法。此名为闻。亦名为仗。亦名闻仗。故名闻仗。离仗云何。答离欲恶不善法有寻有伺离生喜乐。入初静虑具足住。广说乃至入第四静虑具足住。是名为离。因此离依此离由此离建立故。能断不善法能修诸善法。此名为离。亦名为仗。亦名离仗。故名离仗。慧仗云何。答如实了知此是苦圣谛。此是苦集圣谛。此是苦灭圣谛。此是趣苦灭道圣谛。是名为慧。因此慧依此慧由此慧建立故。能断不善法能修诸善法。此名为慧。亦名为仗。亦名慧仗。故名慧仗。如世尊说

  闻仗最为劣　　离仗名次上
  慧仗最为胜　　精进力具足
  具念乐静定　　知世间生灭
  于一切解胜　　至世边彼岸

第五嗢柁南曰

  五三法有十　　谓学修住定
  导净默增上　　无上明各三

有三学三修三住三定三示导三清净三寂默三增上三无上三明

三学者。一增上戒学。二增上心学。三增上慧学。增上戒学云何。答安住具戒守护别解脱律仪。轨则所行悉皆具足。于微小罪见大怖畏。受学学处。是名增上戒学。增上心学云何。答离欲恶不善法有寻有伺离生喜乐。入初静虑具足住。广说乃至入第四静虑具足住。是名增上心学。增上慧学云何。答如实了知此是苦圣谛。此是苦集圣谛。此是苦灭圣谛。此是趣苦灭道圣谛。是名增上慧学。如世尊说

  苾刍具三学　　乐修如理行
  增上戒心慧　　恒相续现行
  具精进势力　　及明盛静虑
  常守护诸根　　勤行不放逸
  如昼夜亦然　　如夜昼亦尔
  如前后亦尔　　如后前亦然
  如下上亦然　　如上下亦尔
  胜伏诸方所　　由不放逸定
  说此为学迹　　不放逸而住
  由能了能舍　　故得心解脱
  世说为等觉　　雄猛至行边
  明行俱圆满　　恒住无忘失
  命根不相续　　爱尽解脱故
  如灯火涅槃　　究竟心解脱

三修者。一修戒。二修定。三修慧。修戒云何。答于诸善戒亲近数习。殷重无间勤修不舍。是名修戒。修定云何。答于诸善定亲近数习。殷重无间勤修不舍。是名修定。修慧云何。答于诸善慧亲近数习。殷重无间勤修不舍。是名修慧。如世尊说

  善修戒定慧　　至极究竟者
  已永尽诸有　　无垢亦无忧
  于着得解脱　　具利慧深定
  超众魔境界　　遍照如日轮

说一切有部集异门足论卷第五阿毗达磨集异门足论卷第六

        尊者舍利子说

        三藏法师玄奘奉　诏译

    三法品第四之余

三住者。一天住。二梵住。三圣住。天住云何。答谓四静虑。何等为四。谓离欲恶不善法有寻有伺离生喜乐。入初静虑具足住。广说乃至入第四静虑具足住。如世尊为吠那补梨婆罗门说。梵志当知。若时我于世间四静虑中。随为一静虑故行。尔时我为天住而行。若时我于世间四静虑中。随为一静虑故住或坐或卧。尔时我为天住而住或坐或卧。如是世间四静虑中。随于一静虑亲近数习。殷重无间勤修不舍。是名天住。梵住云何。答谓四无量。何等为四。谓慈悲喜舍。如世尊为吠那补梨婆罗门说。梵志当知。若时我于四无量中。随为一无量故行。尔时我为梵住而行。若时我于四无量中。随为一无量故住或坐或卧。尔时我为梵住而住或坐或卧。如是四无量中随于一无量亲近数习殷重无间勤修不舍。是名梵住。圣住云何。答谓四念住四正断四神足五根五力七等觉支八圣道支。如世尊为吠那补梨婆罗门说。梵志当知。若时我于出离远离所生善法中。随为一出离远离所生善法故行。尔时我为圣住而行。若时我于出离远离所生善法中。随为一出离远离所生善法故住或坐或卧。尔时我为圣住而住或坐或卧。如是出离远离所生善法中。随于一出离远离所生善法亲近数习殷重无间勤修不舍。是名圣住

三定者。一有寻有伺三摩地。二无寻唯伺三摩地。三无寻无伺三摩地。云何有寻有伺三摩地。答若三摩地寻俱伺俱。寻等起伺等起。寻相应伺相应。依寻伺转心住等住。广说乃至心一境性。是名有寻有伺三摩地。云何无寻唯伺三摩地。答若三摩地非寻俱唯伺俱。非寻等起唯伺等起。寻不相应唯伺相应。寻已止息唯依伺转心住等住。广说乃至心一境性。是名无寻唯伺三摩地。云何无寻无伺三摩地。答若三摩地非寻俱非伺俱。非寻等起非伺等起。寻不相应伺不相应。若寻若伺俱已止息心住等住。广说乃至心一境性。是名无寻无伺三摩地

三示导者。一神变示导。二记心示导。三教诫示导。神变示导者。云何神变云何示导。而说神变示导耶。答神变者。谓诸神变现神变已神变当神变。谓诸所有变一为多变多为一。或显或隐。若知若见。各别领受墙壁山岩崖岸等障身过无碍。如是广说乃至梵世身自在转。是名神变。示导者。谓有苾刍虽于多种神变境界各别领受。若不令他知见。但名神变自在。不名示导。若有苾刍能于多种神变境界各别领受。亦能令他知见名神变自在。亦名示导。是故所说神变示导。要能令他见等见了等了调伏随顺。乃名神变。亦名示导。由此说名神变示导。记心示导者。云何记心云何示导。而说记心示导耶。答记心者。如世尊说。苾刍当知。谓有一类或。由占相或由言说。随记他心。彼意如此。彼意如是。彼意转变。或随记过去。或随记未来。或随记现在。或随记久所作。或随记久所说。或随记少。谓随记心。或随记多。谓随记心所法。诸所随记一切如实非不如实。或有一类不由占相不由言说随记他心。然由天神或由非人。闻彼声故随记他心。彼意如此。彼意如是。彼意转变。广说如前。或有一类不由天神不由非人。闻彼声故随记他心。然由内心知他有情心所寻伺。随记他心。彼意如此。彼意如是。彼意转变。广说如前。复有一类不由内心。知他有情心所寻伺。随记他心。然由现见他有情住无寻无伺三摩地。见已念言。如是具寿。无寻无伺意行微妙。如是具寿从此定出。当起如此如此寻伺。诸所随记一切如实非不如实。如是具寿从此定出。当起如是如是寻伺。诸所随记一切如实非不如实。是名记心。示导者。谓有苾刍。虽由占相或由言说随记他心。广说乃至。如是具寿从此定出。当起如是如是寻伺。诸所随记一切如实非不如实。若不令他知见。但名记心自在。不名示导若。有苾刍或由。占相或由言说随记他心。广说乃至。如是具寿从此定出。当起如是如是寻伺。诸所随记一切如实非不如实。亦能令他知见名记心自在。亦名示导。是故所说记心示导。要能令他见等见了等了调伏随顺。乃名记心亦名示导。由此说名记心示导。教诫示导者。云何教诫云何示导。而说教诫示导耶。答教诫者如世尊说。苾刍当知。谓有苾刍为他宣说。此是苦圣谛应遍知。此是苦集圣谛应永断。此是苦灭圣谛应作证。此是趣苦灭道圣谛应修习。是名教诫。示导者。谓有苾刍虽能为他宣说。此是苦圣谛应遍知。乃至此是趣苦灭道圣谛应修习。若他闻已不起谛顺忍。不得现观边世俗智。但名教诫自在不名示导。若有苾刍能为他宣说。此是苦圣谛应遍知。乃至此是趣苦灭道圣谛应修习。亦能令他闻已起谛顺忍。得现观边世俗智。名教诫自在亦名示导。是故所说教诫示导。要能令他见等见了等了调伏随顺。乃名教诫亦名示导。由此说名教诫示导

三清净者。一身清净。二语清净。三意清净。身清净云何。答离害生命。离不与取。离欲邪行。复次离害生命离不与取离非梵行。复次诸所有学身业。诸所有无学身业。诸所有善非学非无学身业。如是一切名身清净。语清净云何。答离虚诳语。离离间语。离粗恶语。离杂秽语。复次诸所有学语业。诸所有无学语业。诸所有善非学非无学语业。如是一切名语清净。意清净云何。答无贪无嗔正见。复次诸所有学意业。诸所有无学意业。诸所有善非学非无学意业。如是一切名意清净。如是世尊说

  身语意净中　　我说无漏净
  名圆满清净　　能永净诸恶

三寂默者。一身寂默。二语寂默。三意寂默。身寂默云何。答无学身律。仪名身寂默。语寂默云何。答无学语律仪。名语寂默。意寂默云何。答无学心。名意寂默。如世尊说

  身语意默中　　我说无漏默
  名圆满寂默　　永寂诸恶故

三增上者。一世增上。二自增上。三法增上。世增上云何。答如世尊说。有诸苾刍居阿练若。或在树下或住空闲。学所学法应作是念。今此世间有多众集。夫众集处必有天神。成就天眼具他心智。若近若远皆能睹见。心劣心胜悉能了知。我若发生不善寻伺。能为诸恶耽嗜所依。则诸天神现知见我。既知见已互相谓言。今应共观此善男子。已能厌俗正信出家。云何复生不善寻伺。能为诸恶耽嗜所依。又于世间大众集处。或现有佛及佛弟子。成就天眼具他心智。若近若远皆能睹见。心劣心胜悉能了知。我若发生不善寻伺。能为诸恶耽嗜所依。则诸圣众现知见我。既知见已互相谓言。今应共观此善男子。已能厌俗正信出家。云何复生不善寻伺。能为诸恶耽嗜所依。复作是念。彼诸世间虽见知我而不及我自审了知。故我今应自审观察。勿生如是不善寻伺。能为诸恶耽嗜所依。彼因如是自审知见。发勤精进身心轻安。远离惛沈安住正念。心定一趣制伏愚痴。彼由世间增上力故。能断不善修诸善法。如是世间增上势力。起善有漏或无漏道。名世增上。自增上云何。答如世尊说。有诸苾刍居阿练若。或在树下或住空闲。学所学法应作是念。我已厌俗正信出家。不应复生不善寻伺。能为诸恶耽嗜所依。数数宜应自审观察。勿生如是不善寻伺。能为诸恶耽嗜所依。彼因如是自审知见。发勤精进身心轻安。远离惛沈安住正念。心定一趣制伏愚痴。彼由自我增上力故。能断不善修诸善法。如是自我增上势力。起善有漏或无漏道。名自增上。法增上云何。答如世尊说。有诸苾刍居阿练若。或在树下或住空闲。学所学法应作是念。一切如来应正等觉。所说之法善说现见。离诸热恼随顺应时。来观来尝智者内证。如是正法我已了知。不应复生不善寻伺。能为诸恶耽嗜所依。数数宜应自审观察。勿生如是不善寻伺。能为诸恶耽嗜所依。彼因如是自审知见。发勤精进身心轻安。远离惛沈安住正念。心定一趣制伏愚痴。彼由正法增上力故。能断不善修诸善法。如是正法增上势力。起善有漏或无漏道。名法增上。如世尊说

  世无有智者　　乐作诸恶业
  彼能自通达　　谛实虚妄故
  贤善者能证　　不应自轻篾
  应常省己恶　　有便无隐覆
  世现有天神　　佛及佛弟子
  恒见知愚者　　造作诸恶行
  是故世增上　　自法增上力
  能断不善法　　修法随法行
  我说有勇健　　能摧伏魔军
  度生老病死　　证彼永寂灭

三无上者。一行无上。二智无上。三解脱无上。行无上云何。答无学八支圣道。是名行无上。智无上云何。答无学八智。是名智无上。解脱无上云何。答尽智无生智。是名解脱无上

三明者。谓无学三明。一无学宿住随念智作证明。二无学死生智作证明。三无学漏尽智作证明。云何无学宿住随念智作证明。答如实忆知诸宿住事。谓如实忆知过去世。或一生。或十生。或百生。或千生。或百千生。或多百生。或多千生。或多百千生。或坏劫或成劫。或坏成劫。或多坏劫。或多成劫。或多坏成劫。我于如是有情聚中。曾作如是名如是种如是姓。曾食如是食。曾受如是苦如是乐。曾如是长寿如是久住如是寿量边际。我曾从彼处死生于此处。复从此处死生于彼处。于如是等若形相若因缘若言说无量种宿住事。皆能随念如实忆知。是名无学宿住随念智作证明。问此中何者是明。答知前生相续智。是名明。云何无学死生智作证明。答以净天眼超过于人。见诸有情死时生时。若好色若恶色。若劣若胜。若往善趣。若往恶趣。如是有情成就身恶行。成就语恶行。成就意恶行。发起邪见毁谤贤圣。成就邪见业法受因。由此因缘身坏命终。堕诸恶趣生地狱中。如是有情成就身妙行。成就语妙行。成就意妙行。发起正见赞叹贤圣。成就正见业法受因。由此因缘身坏命终。升诸善趣生于天中。于如是等诸有情类业果差别。皆如实知。是名无学死生智作证明。问此中何者是明。答知自业智。是名明。云何无学漏尽智作证明。答如实知此苦圣谛。此苦集圣谛。此苦灭圣谛。此趣苦灭道圣谛。彼如是知如是见。心解脱。欲漏心解脱。有漏心解脱。无明漏心解脱。已如实知见。我生已尽梵行已立。所作已办不受后有。是名无学漏尽智作证明。问此中何者是明。答知漏尽智。是名明。如世尊说

  牟尼如宿住　　见善恶趣别
  了生死已尽　　得究竟通慧
  知心永解脱　　贪等一切漏
  成就三明故　　名具三明者

    集异门足论四法品第五之一

时舍利子。复告众言。具寿当知。佛于四法自善通达现等觉已。为诸弟子宣说开示。我等今应和合结集。佛灭度后勿有乖诤。当令随顺梵行法律久住利乐无量有情。哀愍世间诸天人众。令获殊胜义利安乐。四法云何。此中有五嗢拖南颂初嗢拖南曰

  初四法有十　　念断神虑谛
  想无量无色　　圣种果各四

有四念住。四正断。四神足。四静虑。四圣谛。四想。四无量。四无色。四圣种。四沙门果

四念住者。一身念住。二受念住。三心念住。四法念住。身念住云何。答十有色处及法处所摄色。是名身念住。受念住云何。答六受身。谓眼触所生受。乃至意触所生受。是名受念住。心念住云何。答六识身。谓眼识乃至意识。是名心念住。法念住云何。答受蕴所不摄无色法处。是名法念住。复次身增上所生诸善有漏及无漏道。是名身念住。受增上所生诸善有漏及无漏道。是名受念住。心增上所生诸善有漏及无漏道。是名心念住。法增上所生诸善有漏及无漏道。是名法念住。复次缘身慧名身念住。缘受慧名受念住。缘心慧名心念住。缘法慧名法念住

四正断者。为令已生恶不善法断故。起欲发勤精进策心持心。是名第一。为令未生恶不善法不生故。起欲发勤精进策心持心。是名第二。为令未生善法生故。起欲发勤精进策心持心。是名第三。为令已生善法坚住不忘修满倍增广大智作证故。起欲发勤精进策心持心。是名第四。为令已生恶不善法断故。起欲发勤精进策心持心。正断云何。答为断已生恶不善法。增上所起诸善有漏及无漏道。如是名为第一正断。为令未生恶不善法不生故。起欲发勤精进策心持心。正断云何。答为遮未生恶不善法。增上所起诸善有漏及无漏道。如是名为第二正断。为令未生善法生故。起欲发勤精进策心持心。正断云何。答为起未生善法增上所起诸善有漏及无漏道。如是名为第三正断。为令已生善法坚住不忘修满倍增广大智作证故。起欲发勤精进策心持心。正断云何。答为增已生善法增上所起诸善有漏及无漏道。如是名为第四正断

四神足者。一欲三摩地断行成就神足。二勤三摩地断行成就神足。三心三摩地断行成就神足。四观三摩地断行成就神足。云何欲三摩地断行成就神足。答欲增上所生诸善有漏及无漏道。是名欲三摩地断行成就神足。云何勤三摩地断行成就神足。答勤增上所生诸善有漏及无漏道。是名勤三摩地断行成就神足。云何心三摩地断行成就神足。答心增上所生诸善有漏及无漏道。是名心三摩地断行成就神足。云何观三摩地断行成就神足。答观增上所生诸善有漏及无漏道。是名观三摩地断行成就神足

四静虑者。谓初静虑。第二静虑。第三静虑。第四静虑。云何初静虑。答初静虑所摄善五蕴。是名初静虑。云何第二静虑。答第二静虑所摄善五蕴。是名第二静虑。云何第三静虑。答第三静虑所摄善五蕴。是名第三静虑。云何第四静虑。答第四静虑所摄善五蕴。是名第四静虑

四圣谛者。一苦圣谛。二苦集圣谛。三苦灭圣谛。四趣苦灭道圣谛。云何苦圣谛。答五取蕴。谓色取蕴。受取蕴。想取蕴。行取蕴。识取蕴。是名苦圣谛。云何苦集圣谛。答诸有漏因。是名苦集圣谛。云何苦灭圣谛。答择灭无为。是名苦灭圣谛。云何趣苦灭道圣谛。答诸学法无学法是名趣苦灭道圣谛

四想者。一小想二大想。三无量想。四无所有想。小想云何。答作意思惟狭小诸色。谓或思惟青瘀。或思惟脓烂。或思惟破坏。或思惟膖胀。或思惟骸骨。或思惟骨锁。或思惟地。或思惟水。或思惟火。或思惟风。或思惟青。或思惟黄。或思惟赤。或思惟白。或思惟诸欲过患。或思惟出离功德。与此俱行诸想等想。现前等想已想当想。是名小想。大想云何。答作意思惟广大诸色而非无边。谓或思惟青瘀。广说如前。是名大想。无量想云何。答作意思惟广大诸色其量无边。谓或思惟青瘀。广说如前。是名无量想。无所有想云何。答此即显示无所有处想

四无量者。一慈无量。二悲无量。三喜无量。四舍无量。慈无量云何。答诸慈及慈相应受想行识。若彼等起身语业。若彼等起心不相应行。是名慈无量。悲无量云何。答诸悲及悲相应受想行识。若彼等起身语业。若彼等起心不相应行。是名悲无量。喜无量云何。答诸喜及喜相应受想行识。若彼等起身语业。若彼等起心不相应行。是名喜无量。舍无量云何。答诸舍及舍相应受想行识。若彼等起身语业。若彼等起心不相应行。是名舍无量

四无色者。一空无边处。二识无边处。三无所有处。四非想非非想处。空无边处云何。答空无边处略有二种。一定二生。若定若生所有受想行识。是名空无边处。识无边处云何。答识无边处略有二种。一定二生。若定若生所有受想行识。是名识无边处。无所有处云何。答无所有处略有二种。一定二生。若定若生所有受想行识。是名无所有处。非想非非想处云何。答非想非非想处略有二种。一定二生。若定若生所有受想行识。及有一类定所等起心不相应行。即灭想受定。是名非想非非想处

四圣种者。一有苾刍。随得衣服便生喜足。赞叹喜足不为求觅衣服因缘。令诸世间而生讥论。若求不得终不懊叹。引颈希望抚胸迷闷。若求得已如法受用。不生染着耽嗜迷闷藏护贮积。于受用时能见过患。正知出离。彼由随得衣服喜足。终不自举陵篾于他。而能策勤正知系念。是名安住古昔圣种。二有苾刍。随得饮食便生喜足。广说如前。三有苾刍。随得卧具便生喜足。广说如前。四有苾刍。爱断乐断精勤随学于断爱乐。爱修乐修精勤随学于修爱乐。彼由如是断修爱乐。终不自举陵篾于他。而能策勤正知系念。是名安住古昔圣种。随得衣服喜足圣种云何。答随得衣服喜足增上。所生诸善有漏及无漏道。是名随得衣服喜足圣种。随得饮食喜足圣种云何。答随得饮食喜足增上。所生诸善有漏及无漏道。是名随得饮食喜足圣种。随得卧具喜足圣种云何。答随得卧具喜足增上。所生诸善有漏及无漏道。是名随得卧具喜足圣种。爱乐断修圣种云何。答爱乐断修增上所生诸善有漏及无漏道。是名爱乐断修圣种

四沙门果者。一预流果。二一来果。三不还果。四阿罗汉果。预流果云何。答预流果有二种。一有为二无为。有为预流果者。谓证预流果时所有学法。或已得或今得或当得。是名有为预流果。无为预流果者。谓证预流果时所有择灭。或已得或今得或当得。是名无为预流果。一来果不还果应知亦尔。阿罗汉果云何。答阿罗汉果有二种。一有为二无为。有为阿罗汉果者。谓证阿罗汉果时所有无学法。或已得或今得或当得。是名有为阿罗汉果。无为阿罗汉果者。谓证阿罗汉果时所有择灭。或已得或今得或当得。是名无为阿罗汉果

第二嗢柁南曰

  二四法有九　　谓支净智力
  处蕴依迹法　　各四智有二

有四预流支四证净四智四力四处四蕴四依四法迹四应证法。智有二门余八各一

四预流支者。一亲近善士。二听闻正法。三如理作意。四法随法行。云何亲近善士。答善士者。谓佛及弟子。复次诸有补特伽罗具戒具德。离诸瑕秽成调善法。堪绍师位成就胜德。知羞悔过善守好学。具知具见乐思择爱称量喜观察。性聪敏具觉慧。息追求有慧类。离贪趣贪灭。离嗔趣嗔灭。离痴趣痴灭。调顺趣调顺。寂静趣寂静。解脱趣解脱。具如是等诸胜功德。是名善士。若能于此所说善士。亲近承事恭敬供养。如是名为亲近善士。云何听闻正法。答正法者谓前说善士未显了处为正显了。未开悟处为正开悟。以慧通达深妙句义。方便为他宣说施设安立开示。以无量门正为开示。苦真是苦。集真是集。灭真是灭。道真是道。如是等名正法。若能于此所说正法。乐听乐闻。乐受持乐究竟。乐解了乐观察。乐寻思乐推究。乐通达乐触乐证乐作证。为闻法故不惮艰辛。为受持故数以耳根。对说法音发胜耳识。如是名为听闻正法。云何如理作意。答于耳所闻耳识所了无倒法义。耳识所引令心专注。随摄等摄作意发意。审正思惟心警觉性。如是名为如理作意。云何法随法行。答如理作意所引出离。远离所生诸胜善法。修习坚住无间精勤。如是名为法随法行

四证净者。如契经说。成就四法说名预流。何等为四。一佛证净。二法证净。三僧证净。四圣所爱戒。云何佛证净。答如世尊说。苾刍当知。此圣弟子以如是相随念诸佛。谓此世尊是如来。阿罗汉正等觉明行圆满善逝世间解无上丈夫调御士天人师佛薄伽梵。彼以此相随念诸佛。见为根本证智相应诸信信性。现前信性随顺印可。爱慕爱慕性心澄心净。是名佛证净。云何法证净。答如世尊说。苾刍当知。此圣弟子以如是相随念正法。谓佛正法善说现见无热应时。引导近观智者内证。彼以此相随念正法。见为根本证智。相应诸信信性。现前信性随顺印可。爱慕爱慕性心澄心净。是名法证净。云何僧证净。答如世尊说。苾刍当知。此圣弟子以如是相随念于僧。谓佛弟子具足妙行质直行。如理行法随法行和敬行。随法行。于此僧中有预流向有预流果。有一来向有一来果。有不还向有不还果。有阿罗汉向有阿罗汉果。如是总有四双八只补特伽罗佛弟子众。戒具足。定具足。慧具足。解脱具足。解脱智见具足。应请应屈应恭敬无上福田。世所应供。彼以此相随念于僧。见为根本证智相应诸信信性。现前信性随顺印可。爱慕爱慕性心澄心净。是名僧证净。云何圣所爱戒。答无漏身律仪语律仪命清净。是名圣所爱戒。问何故名为圣所爱戒。答圣谓诸佛及佛弟子。彼于此戒爱慕欣喜忍顺不逆。是故名为圣所爱戒。诸预流者成就此四

说一切有部集异门足论卷第六阿毗达磨集异门足论卷第七

        尊者舍利子说

        三藏法师玄奘奉　诏译

    四法品第五之二

四智者。谓法智类智他心智世俗智。法智云何。答缘欲界行诸无漏智。缘欲界行因诸无漏智。缘欲界行灭诸无漏智。缘欲界行能断道诸无漏智。复次缘法智及缘法智地诸无漏智。是名法智。类智云何。答缘色无色界行诸无漏智。缘色无色界行因诸无漏智。缘色无色界行灭诸无漏智。缘色无色界行能断道诸无漏智。复次缘类智及缘类智地诸无漏智。是名类智。他心智云何。答若智修所成是修果。依止修已得不失。能知欲色界和合现前他心心所。及一分无漏他心心所。是名他心智。世俗智云何。答诸有漏慧。是名世俗智

复有四智。谓苦智集智灭智道智。苦智云何。答于五取蕴。思惟非常苦空非我所起无漏智。是名苦智。集智云何。答于有漏因思惟因集生缘所起无漏智。是名集智。灭智云何。答于诸择灭思惟灭静妙离所起无漏智。是名灭智。道智云何。答于无漏道思惟道如行出所起无漏智。是名道智

四力者。一信力。二精进力。三定力。四慧力。信力云何。答依诸如来应正等觉所殖净信。是有根生安立坚固。一切沙门及婆罗门诸天魔梵。若余世间。皆无有能如法牵夺。是名信力。精进力云何。答为令已生恶不善法断故。起欲发勤精进策心持心。为令未生恶不善法不生故。起欲发勤精进策心持名。为令未生善法生故。起欲发勤精进策心持心。为令已生善法坚住不忘修满倍增广大智作证故。起欲发勤精进策心持心。是名精进力。定力云何。答离欲恶不善法有寻有伺离生喜乐。入初静虑具足住。广说乃至入第四静虑具足住。是名定力。慧力云何。答如实了知是苦圣谛。如实了知是苦集圣谛。如实了知是苦灭圣谛。如实了知是趣苦灭道圣谛。是名慧力。问何故名力。答以因此力依此力住此力。能断能碎能破一切结缚随眠随烦恼缠。故名为力

四处者。一慧处。二谛处。三舍处。四寂静处。慧处云何。答如薄伽梵于辩六界记别经中为具寿池坚说。苾刍当知。最胜慧处。谓漏尽智。是故苾刍应成就漏尽智。若成就漏尽智。说名成就最胜慧处。是名慧处。谛处云何。答如薄伽梵于辩六界记别经中为具寿池坚说苾刍当知。最胜谛处。谓不动解脱。谛者。谓如实法。诳者。谓虚妄法。是故苾刍应成就不动解脱。若成就不动解脱。说名成就最胜谛处。是名谛处。舍处云何。答如薄伽梵于辩六界记别经中为具寿池坚说。苾刍当知。先所执受无智无明越正路法。今时应舍应变吐应除弃。苾刍当知。最胜舍处。谓弃舍一切依。爱尽离染永灭涅槃。是故苾刍应成就此涅槃。若成就此涅槃。说名成就最胜舍处。是名舍处。寂静处云何。答如薄伽梵于辩六界记别经中为具寿池坚说。苾刍当知。贪染恼心令不解脱。嗔染恼心令不解脱。痴染恼心令不解脱。苾刍当知。此贪嗔痴无余永断变吐除弃爱尽离染永灭静没。名真寂静。是故苾刍应成就真寂静。若成就真寂静。说名成就最胜寂静处。是名寂静处

四蕴者。一戒蕴。二定蕴。三慧蕴。四解脱蕴。戒蕴云何。答如薄伽梵于辩三蕴记别经中作如是说。苾刍当知。我说学戒若无学戒。若一切善非学非无学戒。皆是戒蕴。是名戒蕴。定蕴云何。答如薄伽梵于辩三蕴记别经中作如是说。苾刍当知。我说学定若无学定。若一切善非学非无学定。皆是定蕴。是名定蕴。慧蕴云何。答如薄伽梵于辩三蕴记别经中作如是说。苾刍当知。我说学慧。若无学慧。若一切善非学非无学慧。皆是慧蕴。是名慧蕴。解脱蕴云何。答如薄伽梵于辩三蕴记别经中作如是说。苾刍当知。我说学解脱。若无学解脱。若一切善非学非无学解脱。皆是解脱蕴。是名解脱蕴

四依者。一思择一法应远避。二思择一法应受用。三思择一法应除遣。四思择一法应忍受。云何思择一法应远避。答如薄伽梵于防诸漏记别经中作如是说。汝等苾刍。应审思择。恶象恶马恶牛恶狗恶水牛等当远避之。应审思择株杌毒刺。坑堑崖谷井厕河等当远避之。应审思择恶行恶威仪。恶友恶伴侣恶行处恶卧具等当远避之。恶卧具者。谓若受用如是卧具。为诸有智同梵行者。不应分别处。而生分别。不应测量处。而生测量。不应猜疑处。而生猜疑。如是卧具我说为恶。汝等苾刍。应当远避。是名思择一法应远避。云何思择一法应受用。答如薄伽梵于防诸漏记别经中作如是说。汝等苾刍。应审思择。如法衣服当受用之。不为勇健。不为傲逸。不为颜貌。不为端严。但为遮防蛟虻寒热蛇蝎等触。及为覆蔽。深可羞耻丑陋身形。应审思择如法饮食当受用之。不为勇健。不为傲逸。不为颜貌。不为端严。但为此身暂住存济。止息饥渴摄受梵行。为断故受不起新受。无罪存济力乐安住。应审思择如法卧具当受用之。不为勇健。不为傲逸。不为颜貌。不为端严。但为遮防寒热风雨。及得最胜安隐寂静。应审思择如法医药当受用之。不为勇健。不为傲逸。不为颜貌。不为端严。但为止息未起已起。所有疾病得修善业。是名思择一法应受用。云何思择一法应除遣。答如薄伽梵于防诸漏记别经中作如是说。汝等苾刍。已起欲寻恚寻害寻。不应韫畜。应速断灭变吐除遣。是名思择一法应除遣。云何思择一法应忍受。答如薄伽梵于防诸漏记别经中作如是说。汝等苾刍应起精进。有势有勤。勇悍坚猛。不舍善轭。假使我身。血肉枯竭。唯皮筋骨连拄而存。若本所求胜法未获。终不止息所起精进。又精进时身心疲惓。终不由斯而生懈怠。应深忍受寒热饥渴蛇蝎蚊虻风雨等触。又应忍受他人所发能生身中猛利辛楚夺命苦受毁辱语言。是名思择一法应忍受

四法迹者。一无贪法迹。二无嗔法迹。三正念法迹。四正定法迹。云何无贪法迹。答无贪者。谓于欲境诸不贪不等贪。广说乃至非贪类非贪生。是名无贪。法迹者。谓即无贪亦名为法。亦名为迹。亦名法迹。是故名为无贪法迹。云何无嗔法迹。答无嗔者。谓于有情不欲损害。不怀栽杌。不欲扰恼。广说乃至非已为过患。非当为过患。非现为过患。是名无嗔。法迹者。谓即无嗔亦名为法。亦名为迹。亦名法迹。是故名为无嗔法迹。云何正念法迹。答正念者。谓依出离远离所生善法。诸念随念。广说乃至心明记性。是名正念。法迹者。谓即正念亦名为法。亦名为迹。亦名法迹。是故名为正念法迹。云何正定法迹。答正定者。谓依出离远离所生善法。诸定令心住。广说乃至心一境性。是名正定。法迹者。谓即正定亦名为法。亦名为迹。亦名法迹。是故名为正定法迹

四应证法者。谓或有法是身应证。或复有法是念应证。或复有法是眼应证。或复有法是慧应证。云何有法是身应证。答谓八解脱。是身应证。云何有法是念应证。答谓宿住事。是念应证。云何有法是眼应证。答谓死生事。是眼应证。云何有法是慧应证。答谓诸漏尽。是慧应证

第三嗢拖南曰

  三四法有九　　行修业受轭
  离系与瀑流　　取系各四种

有四行四修定四业四法受四轭四离系四瀑流四取四身系

四行者。一苦迟通行。二苦速通行。三乐迟通行。四乐速通行。云何苦迟通行。答静虑不摄下品五根。是名苦迟通行。云何苦速通行。答静虑不摄上品五根。是名苦速通行。云何乐迟通行。答静虑所摄下品五根。是名乐迟通行。云何乐速通行。答静虑所摄上品五根。是名乐速通行

复有四行。一不堪忍行。二堪忍行。三调伏行。四寂静行。云何不堪忍行。答谓不堪忍寒热饥渴蛇蝎蚊虻风雨等触。又不堪忍他人所发能生身中辛楚猛利夺命苦受骂辱语言。如是种类。是名不堪忍行。云何堪忍行。答谓能堪忍寒热饥渴蛇蝎蚊虻风雨等触。又能堪忍他人所发能生身中辛楚猛利夺命苦受骂辱语言。如是种类。是名堪忍行。云何调伏行。答眼见色时专意系念。防护眼根。调伏其心。不令发起烦恼恶业。耳闻声时。鼻嗅香时舌尝味时。身觉触时。意了法时。专意系念防护耳根。广说乃至防护意根。调伏其心。不令发起烦恼恶业。是名调伏行。云何寂静行。答谓四念住。四正断。四神足。五根五力。七等觉支。八圣道支。四通行四法迹。奢摩他毗钵舍那。是名寂静行。问何故说此名寂静行。答以于此行若习若修。若多所作。能令已生贪欲嗔恚愚痴慢等。寂静等寂静。最极寂静。是故说此名寂静行

四修定者。一有修定若习若修若多所作。为能获得现法乐住。二有修定若习若修若多所作。为能获得最胜知见。三有修定若习若修若多所作。为能获得胜分别慧。四有修定若习若修若多所作。为能获得诸漏永尽。云何修定若习若修若多所作为能获得现法乐住。答于初静虑所摄离生喜乐。俱行心一境性。若习若修坚作常作精勤修习。是名修定若习若修若多所作为能获得现法乐住。云何修定若习若修若多所作为能获得最胜知见。答于光明想俱行心一境性。若习若修坚作常作精勤修习。是名修定若习若修若多所作为能获得最胜知见。云何修定若习若修若多所作为能获得胜分别慧。答于受想寻观俱行心一境性。若习若修坚作常作精勤修习。是名修定若习若修若多所作为能获得胜分别慧。云何修定若习若修若多所作为能获得诸漏永尽。答于第四静虑所摄。清净舍念俱行。阿罗汉果无间道。摄心一境性。若习若修坚作常作精勤修习。是名修定若习若修若多所作为能获得诸漏永尽。如薄伽梵于波罗衍拏起问中说

  断欲想忧怖　　离惛沉睡眠
  及恶作掉举　　得舍念清净
  法轮为上首　　得正智解脱
  我说断无明　　得胜分别慧

四业者。一黑黑异熟业。二白白异熟业。三黑白黑白异熟业。四非黑非白无异熟业能尽诸业。云何黑黑异熟业。答如世尊为持俱胝牛戒布剌拏说。圆满当知。世有一类补特伽罗。造有损害身语意行。彼造有损害身语意行已。积集增长有损害法。彼积集增长有损害法已。感得有损害自体。彼感得有损害自体已。生有损害世间。彼生有损害世间已。触有损害触。彼触有损害触已。受有损害受。一向不可爱。一向不可乐。一向不可喜。一向不可意。如那落伽诸有情类。彼由此类有此类生。生已复触如是类触。是故我说彼诸有情随自造业。圆满当知。是名黑黑异熟业。造有损害身语意行者。谓造不善身语意行。于此义中意说不善身语意行。名有损害身语意行。彼造有损害身语意行已。积集增长有损害法者。谓造不善身语意行已。造作增长不远离法。于此义中意说造作增长不远离法。名积集增长有损害法。彼积集增长有损害法已。感得有损害自体者。谓造作增长不远离法已。感得地狱中有。于此义中意说地狱中有。名有损害自体。所以者何。谓住彼中有中。眼所见色。耳所闻声。鼻所嗅香。舌所尝味。身所觉触。意所了法。一切不可意非可意。不悦意非悦意。不可意相非可意相。不平等相非平等相。彼由此缘纯受忧苦。彼感得有损害自体已。生有损害世间者。谓感得地狱中有已。生地狱趣。于此义中意说地狱趣名有损害世间。所以者何。谓生地狱趣已。眼所见色。乃至意所了法。一切不可意非可意。广说乃至不平等相非平等相。彼由此缘纯受忧苦。彼生有损害世间已。触有损害触者。谓生地狱趣已触地狱触。于此义中意说地狱触名有损害触。彼触有损害触已。受有损害受者。谓触如是类触。定受如是类受。触顺苦受触时必受苦受。由此故说触有损害触已。受有损害受。一向不可爱。一向不可乐。一向不可喜。一向不可意者。谓彼苦受一切有情皆共不爱不乐不喜。亦不可意。由此故说一向不可爱乃至不可意。如那落迦诸有情类者。谓显趣向地狱世间诸有情类。由此故说如那落迦诸有情类。彼由此类有此类生者。谓彼有情有所依事有因有缘而生于彼。由此故说彼由此类有此类生。生已复触如是类触者。谓生地狱已复触地狱触。由此故说生已复触如是类触。是故我说彼诸有情随自造业者。谓设若造有损害身语意行。若不造有损害身语意行。俱积集增长有损害法。或俱不积集增长有损害法。若积集增长有损害法。若不积集增长有损害法。俱感得有损害自体。或俱不感得有损害自体。若感得有损害自体。若不感得有损害自体。俱生有损害世间。或俱不生有损害世间。若生有损害世间。若不生有损害世间。俱触有损害触。或俱不触有损害触。若触有损害触。若不触有损害触。俱受有损害受。或俱不受有损害受。则不应言。是故我说彼诸有情随自造业。以若造有损害身语意行。则积集增长有损害法。若不造有损害身语意行。则不积集增长有损害法。若积集增长有损害法。则感得有损害自体。若不积集增长有损害法。则不感得有损害自体。若感得有损害自体。则生有损害世间。若不感得有损害自体。则不生有损害世间。若生有损害世间。则触有损害触。若不生有损害世间。则不触有损害触。若触有损害触。则受有损害受。若不触有损害触。则不受有损害受。由此应言。是故我说彼诸有情随自造业。是名黑黑异熟业者。谓此业是不善感非爱异熟。云何白白异熟业。答如世尊为持俱胝牛戒补剌拏说。圆满当知。世有一类补特伽罗。造无损害身语意行。彼造无损害身语意行已。积集增长无损害法。彼积集增长无损害法已。感得无损害自体。彼感得无损害自体已。生无损害世间。彼生无损害世间已。触无损害触。彼触无损害触已。受无损害受。一向可爱。一向可乐。一向可喜。一向可意。如超段食天诸有情类。彼由此类有此类生。生已复触如是类触。是故我说。彼诸有情随自造业。圆满当知。是名白白异熟业。造无损害身语意行者。谓造善身语意行。于此义中意说善身语意行。名无损害身语意行。彼造无损害身语意行已。积集增长无损害法者。谓造善身语意行已。造作增长远离法。于此义中意说造作增长远离法。名积集增长无损害法。彼积集增长无损害法已。感得无损害自体者。谓造作增长远离法已。感得色界中有。于此义中意说色界中有。名无损害自体。所以者何。谓住彼中有中。眼所见色。耳所闻声。身所觉触。意所了法。一切可意非不可意。悦意非不悦意。可意相非不可意相。平等相非不平等相。彼由此缘纯受喜乐。彼感得无损害自体已。生无损害世间者。谓感得色界中有已。生色界天趣。于此义中意说色界天趣。名无损害世间。所以者何。生色界天趣已。眼所见色乃至意所了法。一切可意非不可意。广说乃至平等相非不平等相。彼由此缘纯受喜乐。彼生无损害世间已。触无损害触者。谓生色界天趣已。触色界天触。于此义中意说色界天触。名无损害触。彼触无损害触已。受无损害受者。谓触如是类触。定受如是类受。触顺乐受触时必受乐受。由此故说触无损害触已受无损害受。一向可爱一向可乐一向可喜一向可意者。谓彼乐受无量有情。皆共可爱可乐可喜可意。由此故说一向可爱乃至可意。如超段食天诸有情类者。谓显趣向色界世间。由此故说如超段食天诸有情类。彼由此类有此类生者。谓彼有情有所依事。有因有缘而生于彼。由此故说彼由此类有此类生。生已复触如是类触者。谓生色界已复触色界触。由此故说生已复触如是类触。是故我说彼诸有情随自造业者。谓设若造无损害身语意行。若不造无损害身语意行。俱积集增长无损害法。或俱不积集增长无损害法。若积集增长无损害法。若不积集增长无损害法。俱感得无损害自体。或俱不感得无损害自体。若感得无损害自体。若不感得无损害自体。俱生无损害世间。或俱不生无损害世间。若生无损害世间。若不生无损害世间。俱触无损害触。或俱不触无损害触。若触无损害触。若不触无损害触。俱受无损害受。或俱不受无损害受。则不应言。是故我说彼诸有情随自造业。以若造无损害身语意行。则积集增长无损害法。若不造无损害身语意行。则不积集增长无损害法。若积集增长无损害法。则感得无损害自体。若不积集增长无损害法。则不感得无损害自体。若感得无损害自体。则生无损害世间。若不感得无损害自体。则不生无损害世间。若生无损害世间。则触无损害触。若不生无损害世间。则不触无损害触。若触无损害触。则受无损害受。若不触无损害触。则不受无损害受。由此应言。是故我说彼诸有情随自造业。是名白白异熟业者。谓此业是善感可爱异熟。云何黑白黑白异熟业。答如世尊为持俱胝牛戒补剌拏说。圆满当知。世有一类补特伽罗。造有损害无损害身语意行。彼造有损害无损害身语意行已。积集增长有损害无损害法。彼积集增长有损害无损害法已。感得有损害无损害自体。彼感得有损害无损害自体已。生有损害无损害世间。彼生有损害无损害世间已。触有损害无损害触。彼触有损害无损害触已。受有损害无损害受。相间相杂如人及一分天诸有情类。彼由此类有此类生。生已复触如是类触。是故我说。彼诸有情随自造业。圆满当知。是名黑白黑白异熟业。造有损害无损害身语意行者。谓造善不善身语意行。于此义中意说善不善身语意行。名有损害无损害身语意行。彼造有损害无损害身语意行已。积集增长有损害无损害法者。谓造善不善身语意行已。造作增长远离不远离法。于此义中。意说造作增长远离不远离法。名积集增长有损害无损害法。彼积集增长有损害无损害法已。感得有损害无损害自体者。谓造作增长远离不远离法已。感得人及欲界天中有。于此义中。意说人及欲界天中有。名有损害无损害自体。所以者何。谓住彼中有中。眼所见色。耳所闻声。鼻所嗅香。舌所尝味。身所觉触。意所了法。一切可意亦不可意。悦意亦不悦意。可意相亦不可意相。平等相亦不平等相。彼由此缘杂受苦乐。彼感得有损害无损害自体已。生有损害无损害世间者。谓感得人及欲界天中有已。生人及欲界天趣。于此义中。意说人及欲界天趣。名有损害无损害世间。所以者何。谓生人及欲界天趣已。眼所见色。乃至意所了法。一切可意亦不可意。广说乃至平等相亦不平等相。彼由此缘杂受苦乐。彼生有损害无损害世间已。触有损害无损害触者。谓生人及欲界天趣已。触人及欲界天触。于此义中。意说人及欲界天触。名有损害无损害触。彼触有损害无损害触已。受有损害无损害受者。谓触如是类触。定受如是类受。触顺苦乐触时。必受苦乐受由此故说。触有损害无损害触已。受有损害无损害受。相间相杂者。谓苦乐受相间相杂而现在前。由此故说相间相杂。彼由此类有此类生者。谓彼有情有所依事。有因有缘而生于彼。由此故说彼由此类有此类生。生已复触如是类触者。谓生人及欲界天已。复触人及欲界天触。由此故说生已复触如是类触。是故我说彼诸有情随自造业者。谓设若造有损害无损害身语意行。若不造有损害无损害身语意行。俱积集增长有损害无损害法。或俱不积集增长有损害无损害法。若积集增长有损害无损害法。若不积集有损害无损害法。俱感得有损害无损害自体。或俱不感得有损害无损害自体。若感得有损害无损害自体。若不感得有损害无损害自体。俱生有损害无损害世间。或俱不生有损害无损害世间。若生有损害无损害世间。若不生有损害无损害世间。俱触有损害无损害触。或俱不触有损害无损害触。若触有损害无损害触。若不触有损害无损害触。俱受有损害无损害受。或俱不受有损害无损害受。则不应言。是故我说。彼诸有情随自造业

说一切有部集异门足论卷第七阿毗达磨集异门足论卷第八

        尊者舍利子说

        三藏法师玄奘奉　诏译

    四法品第五之三

以若造有损害无损害身语意行。则积集增长有损害无损害法。若不造有损害无损害身语意行。则不积集增长有损害无损害法。若积集增长有损害无损害法。则感得有损害无损害自体。若不积集增长有损害无损害法。则不感得有损害无损害自体。若感得有损害无损害自体。则生有损害无损害世间。若不感得有损害无损害自体。则不生有损害无损害世间。若生有损害无损害世间。则触有损害无损害触。若不生有损害无损害世间。则不触有损害无损害触。若触有损害无损害触。则受有损害无损害受。若不触有损害无损害触。则不受有损害无损害受。由此应言。是故我说彼诸有情随自造业。是名黑白黑白异熟业者。谓此业是善不善。感可爱非可爱异熟。云何不黑不白无异熟业能尽诸业。答如世尊为持俱胝牛戒补剌拏说。圆满当知。若能尽黑黑异熟业思。若能尽白白异熟业思。若能尽黑白黑白异熟业思。是名不黑不白无异熟业能尽诸业。此中不黑者。谓此业非如不善业。由不可意黑说名为黑。故名不黑。不白者。谓此业非如有漏善业。由可意白说名为白。故名不白。无异熟者。谓此业非如前三业能感异熟。故名无异熟业。能尽诸业者。谓此业是学思能趣损减。所以者何。谓若学思能趣损减。于前三业能尽遍尽随得永尽。于此义中意说名业能尽诸业。由此故说不黑不白无异熟业能尽诸业

四法受者。一有法受能感现乐后苦异熟。二有法受能感现苦后乐异熟。三有法受能感现苦后苦异熟。四有法受能感现乐后乐异熟。云何法受能感现乐后苦异熟。答如世尊说。苾刍当知。如有一类补特伽罗。与喜乐俱害生命。不与取欲邪行。虚诳语离间语。粗恶语杂秽语。贪欲嗔恚邪见。彼害生命。广说乃至邪见为缘。得喜得乐。如是种类身乐心乐是不善。不善类究竟摄受。能障通慧能障等觉能障涅槃。是名法受能感现乐后苦异熟。云何法受能感现苦后乐异熟。答如世尊说。苾刍当知。如有一类补特伽罗。与忧苦俱离害生命。离不与取离欲邪行。离虚诳语离离间语。离粗恶语离杂秽语。无贪无嗔正见。彼离害生命。广说乃至正见为缘。得忧得苦。如是种类身苦心苦是善。善类究竟摄受。能引通慧能证等觉能得涅槃。是名法受能感现苦后乐异熟。云何法受能感现苦后苦异熟。答如世尊说。苾刍当知。如有一类补特伽罗。与忧苦俱害生命。不与取欲邪行。虚诳语离间语。粗恶语杂秽语。贪欲嗔恚邪见。彼害生命。广说乃至邪见为缘。得忧得苦。如是种类身苦心苦是不善。不善类究竟摄受。能障通慧能障等觉能障涅槃。是名法受能感现苦后苦异熟。云何法受能感现乐后乐异熟。答如世尊说。苾刍当知。如有一类补特伽罗。与喜乐俱离害生命。离不与取离欲邪行。离虚诳语离离间语。离粗恶语离杂秽语。无贪无嗔正见。彼离害生命。广说乃至正见为缘。得喜得乐。如是种类身乐心乐是善。善类究竟摄受。能引通慧能证等觉能得涅槃。是名法受能感现乐后乐异熟

四轭者。一欲轭。二有轭。三见轭。四无明轭。云何欲轭。答如世尊说。苾刍当知。有诸愚夫无闻异生。于欲集没味患出离不如实知。彼于欲集没味患出离。不如实知故。于诸欲中所有欲。贪欲欲欲亲欲爱欲乐欲。闷欲耽欲嗜欲喜欲藏欲随欲。着缠压于心。是名欲轭。云何有轭。答如世尊说。苾刍当知。有诸愚夫无闻异生。于有集没味患出离。不如实知。彼于有集没味患出离。不如实知故。于诸有中所有有。贪有欲有亲有爱有乐有。闷有耽有嗜有喜有藏有随有。着缠压于心。是名有轭。云何见轭。答如世尊说。苾刍当知。有诸愚夫无闻异生。于见集没味患出离。不如实知。彼于见集没味患出离。不如实知故。于诸见中所有见。贪见欲见亲见爱见乐见。闷见耽见嗜见喜见藏见随见。着缠压于心。是名见轭。云何无明轭。答如世尊说。苾刍当知。有诸愚夫无闻异生。于六触处集没味患出离不如实知。彼于六触处集没味患出离。不如实知故。于六触处所有执着。无明无智随眠随增。是名无明轭。如世尊说

  有情与欲轭　　有见轭相应
  愚痴为上首　　于生死流住

四离系者。一于欲轭离系。二于有轭离系。三于见轭离系。四于无明轭离系。云何于欲轭离系。答如世尊说。苾刍当知。有多闻圣弟子。于欲集没味患出离。能如实知。彼于欲集没味患出离。如实知故。于诸欲中所有欲。贪欲欲欲亲欲爱欲乐欲。闷欲耽欲嗜欲喜欲藏欲随欲。着不缠压心。是名于欲轭离系。云何于有轭离系。答如世尊说。苾刍当知。有多闻圣弟子。于有集没味患出离。能如实知。彼于有集没味患出离。如实知故。于诸有中所有有。贪有欲有亲有爱有乐有。闷有耽有嗜有喜有藏有随有。着不缠压心。是名于有轭离系。云何于见轭离系。答如世尊说。苾刍当知。有多闻圣弟子。于见集没味患出离。能如实知。彼于见集没味患出离。如实知故。于诸见中所有见。贪见欲见亲见爱见乐见。闷见耽见嗜见喜见藏见随见。着不缠压心。是名于见轭离系。云何于无明轭离系。答如世尊说。苾刍当知。有多闻圣弟子。于六触处集没味患出离。能如实知。彼于六触处集没味患出离。如实知故。于六触处所有执着无明无智。不缠压心。是名于无明轭离系。如世尊说

  若断欲有轭　　及超越见轭
  远离无明轭　　便得安隐乐
  彼于现法中　　证得永寂灭
  远离一切轭　　必不往后有

四瀑流者。一欲瀑流。二有瀑流。三见瀑流。四无明瀑流。云何欲瀑流。答除欲界系诸见无明。诸余欲界系结缚随眠随烦恼缠。是名欲瀑流。云何有瀑流。答除色无色界系诸见无明。诸余色无色界系结缚随眠随烦恼缠。是名有瀑流。云何见瀑流。答谓五见。一有身见。二边执见。三邪见。四见取。五戒禁取。如是五见。名见瀑流。云何无明瀑流。答三界无智。是名无明瀑流

四取者。一欲取。二见取。三戒禁取。四我语取。云何欲取。答除欲界系诸见及戒禁取。诸余欲界系结缚随眠随烦恼缠。是名欲取。云何见取。答谓四见。一有身见。二边执见。三邪见。四见取。如是四见合名见取。云何戒禁取。答如有一类于戒执取。谓执此戒能清净。能解脱能出离。能超苦乐至超苦乐边。或于禁执取。谓执此禁能清净。能解脱能出离。能超苦乐至超苦乐边。或于戒禁俱执取。谓执此戒禁俱能清净。能解脱能出离。能超苦乐至超苦乐边。是名戒禁取。云何我语取。答除色无色界系诸见及戒禁取。诸余色无色界系。结缚随眠随烦恼缠。是名我语取

四身系者。一贪身系。二嗔身系。三戒禁取身系。四此实执取身系。云何贪身系。答贪者。谓于欲境诸贪等贪。广说乃至贪类贪生。是名为贪。身系者。谓此贪未断未遍知。于彼彼有情彼彼身。彼彼聚彼彼所得。自体为因为缘系等。系各别系相连相续方得久住。如巧鬘师或彼弟子聚花置前。以长缕结作种种鬘。此花用缕为因为缘结等。结各别结相连相续方得成鬘。此贪亦尔未断未遍知。于彼彼有情彼彼身彼彼聚彼彼所得。自体为因为缘系等。系各别系相连相续乃得久住。是名身系。云何嗔身系。答嗔者。谓于有情欲为损害。广说乃至现为过患。是名为嗔。身系者如前说。云何戒禁取身系。答戒禁取及身系。俱如前说。云何此实执取身系。答此实执取者。谓或有执我及世间常。此实余痴妄。或复有执我及世间无常。此实余痴妄。或复有执我及世间亦常亦无常。此实余痴妄。或复有执我及世间非常非无常。此实余痴妄。或复有执我及世间有边。此实余痴妄。或复有执我及世间无边。此实余痴妄。或复有执我及世间亦有边亦无边。此实余痴妄。或复有执我及世间非有边非无边。此实余痴妄。或复有执命者即身。此实余痴妄。或复有执命者异身。此实余痴妄。或复有执如来死后有。此实余痴妄。或复有执如来死后非有。此实余痴妄。或复有执如来死后亦有亦非有。此实余痴妄。或复有执如来死后非有非非有。此实余痴妄。如是等。名此实执取身系者。谓此实执取未断未遍知。于彼彼有情等。如前广说。是名身系

第四嗢拖南曰

  四四法有十　　谓大种食住
  爱不应行问　　施摄生自体

有四大种四食四识住四爱四不应行而行四记问四种施四摄事四生四得自体

四大种者。一地界。二水界。三火界。四风界。此四广如法蕴论六界中说

四食者。一段食或粗或细。二触食。三意思食。四识食。云何段食或粗或细。答若段为缘能令诸根长养大种增益。又能滋润随滋润。充悦随充悦。护随护。转随转。持随持。是名段食。云何施设段食粗细。答依所资养有情。大小及段渐次施设。粗细其事如何。答如灯只罗兽等所食为粗。尼民只罗兽等所食为细。尼民只罗兽等所食为粗。泥弥兽等所食为细。泥弥兽等所食为粗。龟鳖鱼等所食为细。龟鳖鱼等所食为粗。余水生虫所食为细。复次象马牛等所食为粗。羊鹿猪等所食为细。羊鹿猪等所食为粗。野干狗等所食为细。野干狗等所食为粗。雁孔雀等所食为细。雁孔雀等所食为粗。余陆生虫所食为细

复次若诸有情。食诸草木枝条叶等。彼食是粗。若诸有情食饭粥等。彼食是细。若诸有情食饭粥等。彼食是粗。若诸有情食酥油等。彼食是细

复次若诸有情以口嘴舌。摄取段食用齿咀嚼而吞食之。彼食是粗。若诸有情在胎卵中段食津液。从脐而入资养其身。彼食是细

复次若诸有情食有便秽。彼食是粗。若诸有情食无便秽。彼食是细。如有食香酥陀味等。虽有所食而无便秽。如是施设段食粗细。云何触食。答若有漏触为缘。能令诸根长养大种增益。又能滋润随滋润。乃至持随持。是名触食。其事如何。答如鹅雁。孔雀鹦鹉鸲鹆春鹦离黄命命鸟等。既生卵已。时时亲附。时时覆育。时时温暖。令生乐触。若彼诸鸟于所生卵。不时时亲附覆育温暖令生乐触。卵便腐坏。若彼诸鸟于所生卵。时时亲附覆育温暖令生乐触。卵不腐坏。如是等类。说名触食。云何意思食。答若有漏思为缘。能令诸根长养大种增益。又能滋润随滋润。乃至持随持。是名意思食。其事如何。答如鱼龟鳖室首摩罗部卢迦等。出至陆地生诸卵已细沙覆之。复还入水。若彼诸卵。思母不忘便不腐坏。若彼诸卵不思念母即便腐坏。如是等类。名意思食。云何识食。答若有漏识为缘。能令诸根长养大种增益。又能滋润随滋润。乃至持随持。是名识食。其事如何。答如世尊教。颇勒窭那记经中说。颇勒窭那当知。识食能令当来后有生起。如是等类。说名识食

四识住者。一色识住。二受识住。三想识住。四行识住。云何色识住。答若色有漏随顺诸取。于彼诸色若过去若未来若现在。或生起欲或贪或嗔或痴。或随一一心所随烦恼。是名色识住。受想行识住。广说亦尔

四爱者。一有苾刍苾刍尼等。因衣服爱。应生时生。应住时住。应执时执。二有苾刍苾刍尼等。因饮食爱。应生时生。应住时住。应执时执。三有苾刍苾刍尼等。因卧具爱。应生时生。应住时住。应执时执。四有苾刍苾刍尼等。因有无有爱。应生时生。应住时住。应执时执。云何苾刍苾刍尼等。因衣服爱应生时生应住时住应执时执。答此中衣服者。谓毛所成。或扇那所成。或刍摩所成。或麻所成。或建鼓罗所成。或丝所成。或绵所成。或[疊*毛]所成。或憍砧娑所成。或突窭罗所成。或阿遮烂陀所成。又衣服者。谓总覆衣出着衣内服衣。单裙复裙单掩腋复掩腋。于如是等种种衣服。诸贪等贪执藏防护坚着染爱。是名苾刍苾刍尼等。因衣服爱应生时生应住时住应执时执。云何苾刍苾刍尼等因饮食爱。应生时生应住时住应执时执。答此中饮食者。谓五种应啖。五种应食。五种应啖者。一根二茎三叶四花五果。五种应食者。一饭二粥三饼糗四鱼肉五羹臛。于如是等种种饮食。诸贪等贪执藏防护坚着染爱。是名苾刍苾刍尼等因饮食爱应生时生应住时住应执时执。云何苾刍苾刍尼等因卧具爱应生时生应住时住应执时执。答此中卧具者。谓院宇房堂楼阁台观。长廊圆室龛窟厅庌。草叶等庵。土石等穴。又卧具者。谓床座[毯-炎+瞿]褥眠单卧被。[毯-炎+瞿][叟*毛]緂罽枕褐机橙。于如是等种种卧具。诸贪等贪执藏防护坚着染爱。是名苾刍苾刍尼等因卧具爱应生时生应住时住应执时执。云何苾刍苾刍尼等因有无有爱应生时生应住时住应执时执。答此中有者。谓五取蕴。即是色受想行识取蕴。无有者。谓此五取蕴当来断灭。如有一类作是念言。愿我当来五蕴生起。复有一类作是念言。愿我死后五蕴断灭。于有无有。诸贪等贪执藏防护坚着染爱。是名苾刍苾刍尼等因有无有爱应生时生应住时住应执时执

四不应行而行者。一贪欲故不应行而行。二嗔恚故不应行而行。三愚痴故不应行而行。四怖畏故不应行而行。云何贪欲故不应行而行。答如有一类。或亲教师。或轨范师。或同亲教。或同轨范。或随一一往还亲友。于僧众中有诤事起。彼作是念。若与师等共为朋党便堕非法。若与师等不为朋党便堕不义。虽作是念。而为贪欲所蔽伏故。起恶身语。是名贪欲故不应行而行。云何嗔恚故不应行而行。答如有一类。有怨嫌者。于僧众中。有诤事起。彼作是念。若助怨嫌。于情不可。若为乖反。于理有违。虽作是念。而为嗔恚所蔽伏故。起恶身语。是名嗔恚故不应行而行。云何愚痴故不应行而行。答如有一类。禀性闇钝。或亲教师。或轨范师。或同亲教。或同轨范。或随一一往还亲友。于僧众中有诤事起。彼作是念。我今不知是非好恶。但应朋助亲教师等。彼为愚痴所蔽伏故。起恶身语。是名愚痴故不应行而行。云何怖畏故不应行而行。答如有一类。或国王亲友。或大臣亲友。或强贼亲友。于僧众中有诤事起。彼作是念。若我不助有势力者。由是因缘。或失名利。或失衣钵。或失身命。是故我今定应朋助有势力者。彼由怖畏所蔽伏故。起恶身语。是名怖畏故不应行而行。如世尊说

  诸有贪嗔痴　　怖故违法者
  彼退失名利　　犹如黑分月

四记问者。一应一向记问。二应分别记问。三应反诘记问。四应舍置记问。云何应一向记问。答若有问言。世尊是如来阿罗汉正等觉明行圆满善逝世间解无上丈夫调御士天人师佛薄伽梵耶。佛所说法是善说。现见无热应时引导。近观智者内证耶。佛弟子众具足妙行。质直行如理行。法随法行。和敬行随法行耶。苦集灭道是圣谛耶。一切行无常耶一切法无我耶。涅槃寂静耶。如是等问有无量门应一向记。世尊是如来阿罗汉。广说乃至涅槃是寂静等。是名应一向记问。何故此问应一向记。答以于此问若一向记。能引义利能引善法。能引梵行能发通慧。能生等觉能证涅槃。故于此问应一向记。云何应分别记问。答若有问言。云何为法。得此问时应分别记。法有多种。或过去或未来或现在。或善或不善或无记。或欲界系或色界系或无色界系。或学或无学或非学非无学。或见所断或修所断或非所断。如是等法。有无量门。应分别记。是名应分别记。问何故此问应分别记。答以于此问若分别记。能引义利能引善法。能引梵行能发通慧。能生等觉能证涅槃。故于此问应分别记。云何应反诘记问。答若有问言。为我说法。得此问时应反诘记。法有多种汝问何法。为过去为未来为现在。为善为不善为无记。为欲界系为色界系为无色界系。为学为无学为非学非无学。为见所断为修所断为非所断。如是等法有无量门。应反诘记。是名应反诘记。问何故此问应反诘记。答以于此问若反诘记。能引义利能引善法。能引梵行能发通慧。能生等觉能证涅槃。故于此问应反诘记。云何应舍置记问。答若有问言。世间常耶。无常耶。亦常亦无常耶。非常非无常耶。世间有边耶。无边耶。亦有边亦无边耶。非有边非无边耶。命者即身耶。命者异身耶。如来死后有耶。非有耶。亦有亦非有耶。非有非非有耶。于如是等不应理问。应舍置记。谓应记言。佛说此问。是不应记。常无常等不应理故。是名应舍置记。问何故此问应舍置记。答以于此问。若舍置记。能引义利能引善法。能引梵行能发通慧。能生等觉能证涅槃。故于此问应舍置记。如世尊说

  初应一向记　　次应分别记
  三应反诘记　　四应舍置记
  于如此四问　　知次而记者
  引义利善法　　及梵行纯净
  甚深难降伏　　知义非义俱
  舍非义取义　　审观名智者

四种施者。一者有施。施者清净。受者不清净。二者有施。受者清净施者不清净。三者有施。施者受者俱清净。四者有施。施者受者俱不清净。云何有施施者清净受者不清净。答如世尊说。苾刍当知。若有施主具净戒住律仪。有依见有果见。依如是见说如是言。决定有施有果异熟。能受施者不具净戒不住律仪。无依见无果见。依如是见说如是言。决定无施无果异熟。是名有施施者清净受者不清净。何故此施施者清净受者不清净。答诸支分诸资粮施者应修集。彼支分彼资粮施者成就。诸支分诸资粮受者应修集。彼支分彼资粮受者不成就是故此施施者清净受者不清净。云何有施受者清净施者不清净。答如世尊说。苾刍当知。若有施主不具净戒不住律仪。无依见无果见。依如是见说如是言。决定无施无果异熟。能受施者具净戒住律仪。有依见有果见。依如是见说如是言。决定有施有果异熟。是名有施受者清净施者不清净。何故此施受者清净施者不清净。答诸支分诸资粮施者应修集。彼支分彼资粮施者不成就。诸支分诸资粮受者应修集。彼支分彼资粮受者成就。是故此施受者清净施者不清净。云何有施施者受者俱清净。答如世尊说。苾刍当知。若有施者具净戒住律仪。有依见有果见。依如是见说如是言。决定有施有果异熟。能受施者亦具净戒住律仪。有依见有果见。依如是见说如是言。决定有施有果异熟。是名有施施者受者俱清净。何故此施施者受者俱清净。答诸支分诸资粮施者应修集。彼支分彼资粮施者成就诸支分诸资粮受者应集。彼支分彼资粮受者亦成就。是故此施施者受者俱清净。云何有施施者受者俱不清净。答如世尊说。苾刍当知。若有施者不具净戒不住律仪。无依见无果见。依如是见说如是言。决定无施无果异熟。能受施者亦不具净戒不住律仪。无依见无果见。依如是见说如是言。决定无施无果异熟。是名有施施者受者俱不清净。何故此施施者受者俱不清净。答诸支分诸资粮施者应修集。彼支分彼资粮施者不成就。诸支分诸资粮受者应修集。彼支分彼资粮受者亦不成就。是故此施施者受者俱不清净。如世尊说

  具戒施缺戒　　清净而证法
  信业果异熟　　是唯施者净
  缺戒施具戒　　不净引非法
  谤业果异熟　　是唯受者净
  缺戒施缺戒　　不净引非法
  谤业果异熟　　我说无大果
  具戒施具戒　　清净而证法
  信业果异熟　　我说有大果
  信业果异熟　　施自所尊重
  父母僮仆等　　智者咸称赞
  身语意无著　　行苾刍妙行
  不求自富贵　　而能广施他
  诸有已离欲　　施已离欲者
  我说如是施　　财施中最尊

说一切有部集异门足论卷第八阿毗达磨集异门足论卷第九

        尊者舍利子说

        三藏法师玄奘奉　诏译

    四法品第五之四

四摄事者。一布施摄事。二爱语摄事。三利行摄事。四同事摄事。云何布施摄事。答此中布施者。谓诸施主布施沙门及婆罗门。贫穷苦行道行乞者。饮食汤药衣服花鬘。涂散等香。房舍卧具灯烛等物。是名布施。复次如世尊为手长者说。长者。当知诸布施中法施最胜。是名布施。摄事者。谓由此布施于他等。摄近摄近持令相亲附。如是布施于他有情。能等摄能近摄。能近持能令亲附。是故名为布施摄事。云何爱语摄事。答此中爱语者谓可喜语可味语。舒颜平视语远离颦蹙语含笑前行语。先言庆慰语可爱语善来语。谓作是言善来具寿。汝于世事可忍。可度安乐住不。汝于饮食衣服卧具。及余资缘勿有乏少。诸如是等种种安慰。问讯语言名善来语。此及前说总名爱语。复次如世尊为手长者说。长者。当知诸爱语中最为胜者。谓善劝导诸善男子善女人等。属耳听法时时说法。时时教诲时时决择。是名爱语。摄事者。谓由此爱语于他等。摄近摄近持令相亲附。如是爱语于他有情。能等摄能近摄能近持能令亲附。是故名为爱语摄事。云何利行摄事。答此中利行者。谓诸有情或遭重病。或遭厄难困苦无救。便到其所起慈愍心。以身语业方便供侍。方便救济是名利行。复次如世尊为手长者说。长者。当知诸利行中最为胜者。谓不信者方便劝导。调伏安立令信圆满。若破戒者方便劝导。调伏安立令戒圆满。若悭贪者方便劝导。调伏安立令施圆满。若恶慧者方便劝导。调伏安立令慧圆满。诸如是等说名利行。摄事者。谓由此利行于他等。摄近摄近持令相亲附。如是利行于他有情。能等摄能近摄能近持能令亲附。是故名为利行摄事。云何同事摄事。答此中同事者。谓于断生命深厌离者。为善助伴令离断生命。若于不与取深厌离者。为善助伴令离不与取。若于欲邪行深厌离者。为善助伴令离欲邪行。若于虚诳语深厌离者。为善助伴令离虚诳语。若于饮诸酒深厌离者。为善助伴令离饮诸酒。诸如是等说名同事。复次如世尊为手长者说。长者。当知诸同事中最为胜者。谓阿罗汉不还一来预流果等。与阿罗汉不还一来预流果等。而为同事是名同事摄事者。谓由此同事于他等。摄近摄近持令相亲附。如是同事于他有情。能等摄能近摄能近持能令亲附。是故名为同事摄事。如世尊说

  布施及爱语　　利行与同事
  如应处处说　　普摄诸世间
  如是四摄事　　在世间若无
  子于其父母　　亦不欲孝养
  以有摄事故　　有法者随转
  故得大体者　　观益而施设

四生者。一卵生二胎生三湿生四化生。云何卵生。答若诸有情从卵而生。谓在卵[穀-禾+卵]先为卵[穀-禾+卵]之所缠裹。后破卵[穀-禾+卵]方得出生。此复云何。如鹅雁孔雀鸲鹆鹦鹉春鹦离黄命命鸟等。及一类龙一类妙翅并一类人。复有所余诸有情类从卵而生。谓在卵[穀-禾+卵]先为卵[穀-禾+卵]之所缠裹。后破卵[穀-禾+卵]方出生者皆名卵生。云何胎生。答若诸有情从胎而生谓在胎藏先为胎藏之所缠裹。后破胎藏方得出生。此复云何。如象马驼牛驴羊鹿水牛猪等。及一类龙一类妙翅一类鬼一类人。复有所余诸有情类从胎而生。谓在胎藏先为胎藏之所缠裹。后破胎藏方出生者皆名胎生。云何湿生。答若诸有情展转温暖。展转润湿展转集聚。或依粪聚或依注道。或依秽厕或依腐肉。或依陈粥或依丛草。或依稠林或依草庵。或依叶窟或依池沼。或依陂湖或依江河。或依大海润湿地等方得出生。此复云何。如蟋蟀飞蛾蚊虻蠓蚋麻生虫等。及一类龙一类妙翅并一类人。复有所余诸有情类展转温暖广说乃至或依大海润湿地等。方得生者皆名湿生。云何化生。答若诸有情支分具足根不缺减。无所依托欻尔而生。此复云何。谓一切天一切地狱一切中有。及一分龙一分妙翅一分鬼一分人。复有所余诸有情类。支分具足根不缺减。无所依托欻尔生者皆名化生

四得自体者。一有得自体。唯可自害非可他害。二有得自体。唯可他害非可自害。三有得自体。自他俱可害。四有得自体。自他俱不可害。云何有得自体唯可自害非可他害。答若诸有情自有势力。能断自命他无势力能断其命。此复云何。谓有欲界戏忘念天或时游戏最极娱乐。经于多时身疲念失。由此缘故则便命终。复有欲界意愤恚天。或时忿怒最极愤懑。角眼相视经于多时。由此缘故则便殒没。复有所余诸有情类。自有势力能断自命。他无势力能断其命。是名有得自体唯可自害非可他害。云何有得自体唯可他害非可自害。答若诸有情自无势力能断自命。他有势力能断其命。此复云何。谓处卵[穀-禾+卵]或母胎中。若羯剌蓝。若頞部昙。若闭尸。若键南。若钵罗奢佉。诸根未满诸根未熟。复有所余诸有情类。自无势力能断自命。他有势力能断其命。是名有得自体。唯可他害非可自害。云何有得自体。自他俱可害。答若诸有情自有势力能断自命。他亦有势力能断其命。此复云何。谓象马驼牛驴羊鹿水牛猪等。复有所余诸有情类。自有势力能断自命。他亦有势力能断其命。是名有得自体。自他俱可害。云何有得自体。自他俱不可害。答若诸有情自无势力能断自命。他亦无势力能断其命。此复云何。谓一切色无色界天。住无想定灭定慈定中有有情。住最后有诸有情类。佛使佛记诸转轮王。及轮王母怀彼胎时。后身菩萨及菩萨母怀彼胎时。殑耆罗嗢怛罗婆罗痆斯长者子。王舍城长者子。耶舍童命哀罗伐拏龙王。善住龙王。婆罗呼马王。琰摩王等一切地狱。复有所余诸有情类。自无势力能断自命。他亦无势力能断其命。是名有得自体自他俱不可害

第五嗢柁南曰

  五四法有八　　谓流利趣苦
  四语恶妙行　　四非圣圣言

有顺流行等四补特伽罗。自利行等四补特伽罗。从闇趣闇等四补特伽罗。自苦等四补特伽罗。四语恶行。四语妙行。四非圣言。四圣言。顺流行等四补特伽罗者。一顺流行补特伽罗。二逆流行补特伽罗。三自住补特伽罗。四到彼岸补特伽罗。云何顺流行补特伽罗。答如世尊说苾刍当知。世有一类补特伽罗。染习诸欲造不善业。是名顺流行补特伽罗。问何故名顺流行补特伽罗。答爱是生死流。此补特伽罗顺彼趣。彼临至于彼。是彼道路是彼行迹。故名顺流行补特伽罗。云何逆流行补特伽罗。答如世尊说苾刍当知。世有一类补特伽罗。于贪嗔痴为性猛利。数数厌患贪嗔痴生作意忧苦。彼由厌患作意忧苦。乃至命终常勤修习。纯一圆满清白梵行。是名逆流行补特伽罗。问何故名逆流行补特伽罗。答爱是生死流。此补特伽罗于断爱法。随顺趣向临至于彼。是彼道路是彼行迹。故名逆流行补特伽罗。云何自住补特伽罗。答如世尊说苾刍当知。世有一类补特伽罗。住阿练若或居树下或处空闲。若习若修若多所作若正思惟。证得如是寂静心定。随此定心断五顺下分结当受化生。即于彼处得般涅槃。不复退还生此欲界。是名自住补特伽罗。问何故名自住补特伽罗。答此补特伽罗自住化生界得般涅槃。不复退还生此欲界。故名自住补特伽罗。云何到彼岸补特伽罗。答如世尊说苾刍当知。世有一类补特伽罗。住阿练若或居树下或处空闲。若习若修若多所作。若正思惟证得如是寂静心定。随此定心永尽诸漏证得无漏。心慧解脱于现法中自证通慧。具足领受能正了知。我生已尽梵行已立。所作已办不受后有。是名到彼岸补特伽罗。问何故名到彼岸补特伽罗。答生死有身名为此岸。爱尽离染永灭涅槃名为彼岸。此补特伽罗于彼爱尽离染永灭。涅槃彼岸能得能获能触能证故。名到彼岸补特伽罗。如世尊说

  于欲未伏离　　没欲界爱中
  我说名顺流　　数数受生死
  若安住正念　　不染习欲恶
  厌舍欲忧苦　　我说名逆流
  学断五烦恼　　满无退五法
  得心胜定根　　我说名自住
  普于胜劣法　　解脱灭无余
  智者至世边　　我说到彼岸

自利行等四补特伽罗者。一有补特伽罗有自利行无利他行。二有补特伽罗有利他行无自利行。三有补特伽罗有自利行亦有利他行。四有补特伽罗无自利行亦无利他行。云何有补特伽罗有自利行无利他行。答如世尊说苾刍当知。世有一类补特伽罗。自于诸善法有速谛察忍。彼于诸法为知义故为知法故。精勤修习法随法行和敬行随法行。而言词不调善语具不圆满。亦不成就上首语美妙语。显了语易解语。无依语无尽语。乃至于义为令他知。不能示现不能教导。不能赞励不能庆慰不能赞叹。示现教导赞励庆慰。修善者者。不能勤为四众说法。是名有补特伽罗有自利行无利他行。云何有补特伽罗有利他行无自利行。答如世尊说苾刍当知。世有一类补特伽罗。自于诸善法无速谛察忍。彼于诸法不为知义不为知法。不勤修习法随法行和敬行随法行。而言词调善语具圆满。亦成就上首语美妙语。显了语易解语。无依语无尽语。乃至于义为令他知。能示现能教导能赞励能庆慰。亦能赞叹。示现教导赞励庆慰。修善者者。亦能勤为四众说法。是名有补特伽罗有利他行无自利行。云何有补特伽罗有自利行亦有利他行。答如世尊说苾刍当知。世有一类补特伽罗。自于诸善法有速谛察忍。彼于诸法为知义故为知法故。精勤修习法随法行。和敬行随法行。言词调善语具圆满。亦成就上首语美妙语。显了语易解语。无依语无尽语。乃至于义为令他知。能示现能教导能赞励能庆慰。亦能赞叹示现教导赞励庆慰。修善者者。亦能勤为四众说法。是名有补特伽罗有自利行亦有利他行。云何有补特伽罗。无自利行亦无利他行。答如世尊说苾刍当知。世有一类补特伽罗。自于诸善法无速谛察忍。彼于诸法不为知义不为知法。不勤修习法随法行。和敬行随法行。言词不调善语具不圆满。亦不成就上首语美妙语。显了语易解语乃至于义为令他知。不能示现不能教导不能赞励。不能庆慰不能赞叹。示现教导赞励庆慰。修善者者。不能勤为四众说法。是名有补特伽罗无自利行亦无利他行。从闇趣闇等四补特伽罗者。一有补特伽罗从闇趣闇。二有补特伽罗从闇趣明。三有补特伽罗从明趣闇。四有补特伽罗从明趣明。云何有补特伽罗从闇趣闇。答如世尊说苾刍当知。世有一类补特伽罗。生贫贱家谓旃荼罗家。补羯娑家工巧家妓乐家。及余随一种姓。秽恶贫穷困苦衣食乏少下贱家生。形色丑陋人所轻贱。众共策使是名为闇。彼依此闇造身恶行。造语恶行造意恶行。彼由如是恶行因缘。身坏命终堕崄恶趣生地狱中。当知如是补特伽罗。譬如有人从黑闇处往黑闇处。从粪秽厕堕粪秽厕。从恶瀑流入恶瀑流。脱一牢狱趣一牢狱。用臭秽血洗臭秽血。依贫贱身造恶行者亦复如是。是名从闇趣闇补特伽罗。云何从闇趣明补特伽罗。答如世尊说苾刍当知。世有一类补特伽罗。生贫贱家谓旃荼罗家。广说乃至是名为闇。彼依此闇造身妙行造语妙行造意妙行。彼由如是妙行因缘。身坏命终超升善趣生于天中。当知如是补特伽罗。譬如有人从地上蹬从蹬上座。从座上舆从舆上马。从马上象从象升殿。依贫贱身造妙行者亦复如是。是名从闇趣明补特伽罗。云何从明趣闇补特伽罗。答如世尊说苾刍当知。世有一类补特伽罗。生富贵家。谓刹帝利大族姓家。或婆罗门大族姓家。或诸长者大族姓家。或诸居士大族姓家。或余随一大族姓家。其家多有种种珍宝。衣服饮食奴婢作使。象马牛羊库藏财谷。及余资具无不充满。生是家已形相端严。言词威肃众所敬爱是名为明。彼依此明造身恶行造语恶行造意恶行。彼由如是恶行因缘。身坏命终堕崄恶趣生地狱中。当知如是补特伽罗。譬如有人下殿乘象。下象乘马下马乘舆。下舆居座下座居蹬从橙堕地。依富贵身造恶行者亦复如是。是名从明趣闇补特伽罗。云何从明趣明补特伽罗。答如世尊说苾刍当知。世有一类补特伽罗生富贵家。谓刹帝利大族姓家。广说乃至是名为明。彼依此明造身妙行造语妙行造意妙行。彼由如是妙行因缘。超升善趣生于天中。当知如是补特伽罗。譬如有人从蹬趣蹬从座趣座。从舆趣舆。舍马乘马舍象乘象从殿趣殿。依富贵身造妙行者亦复如是。是名从明趣明补特伽罗。如世尊说

  诸有贫贱人　　无信有嗔忿
  悭贪乐作恶　　好妄想邪见
  见沙门梵志　　具戒多闻者
  不恭敬呵毁　　言我无可施
  毁施受施具　　彼死生随业
  堕恶趣地狱　　是从闇趣闇
  诸有贫贱人　　有信无嗔忿
  具惭愧正见　　乐施离悭贪
  见沙门梵志　　具戒多闻者
  欢喜而迎奉　　等供养恭敬
  赞施受施具　　彼死生随业
  升善趣天处　　是从闇趣明
  诸有富贵人　　无信有嗔忿
  悭贪乐作恶　　好妄想邪见
  见沙门梵志　　具戒多闻者
  不恭敬呵毁　　言我无可施
  毁施受施具　　彼死生随业
  堕恶趣地狱　　是从明趣闇
  诸有富贵人　　有信无嗔忿
  具惭愧正见　　乐施离悭贪
  见沙门梵志　　具戒多闻者
  欢喜而迎奉　　等供养恭敬
  赞施受施具　　彼死生随业
  升善趣天处　　是从明趣明

自苦等四补特伽罗者。一有补特伽罗。自苦自勤苦非苦他非勤苦他。二有补特伽罗。苦他勤苦他非自苦非自勤苦。三有补特伽罗。自苦自勤苦亦苦他勤苦他。四有补特伽罗。非自苦非自勤苦。亦非苦他非勤苦他。云何自苦自勤苦非苦他非勤苦他补特伽罗。答如世尊说苾刍当知。世有一类补特伽罗。受持苦行恶自存活。露体无衣不居宅舍。手捧饮食不须器等。受饮食时非隔刀杖。非隔铛釜非隔盆瓮。非狗在门所受饮食。非蝇依附非杂秽非分段非缠裹非覆蔽。授饮食者不言进来。不言退去不言止住。非怀胎孕非新产生。非饮儿乳所得饮食。非故为造亦非变坏。不食肉不食鱼不食脯腊不饮酒不饮浆。或全不饮或一受食。或二或三或四或五或六或七。或一家乞或二或三或四或五或六或七。或食一抟或二或三或四或五或六或七。或隔日食或二或三或四或五或六或七或隔半月或隔一月。或食草菜或食稗莠。或食牛粪。或食果蓏。或食糠秕或食米脐。或食麦脐或食稆豆。或处旷野食诸根果。乃至或食零果落叶。有虽被服而着麻枲。或着[卄/頃]纻或着茅蒲或着莎蔍或着毛褐。或着緂罽或着兽皮。或着鸟羽或着简牍。或着树皮。或有被发或复蓬头。或作小髻或作大髻。或剃须留发或剃发留须。或二处俱留或五处俱剃。或唯拔发或唯拔须。或须发俱拔。或常举两手或恒翘一足。或乐常立或舍床座。或乐蹲坐而修苦行。或依卧刺或依卧灰。或依卧杵或依卧板。或适牛粪涂地而卧。或乐事火乃至日三事火。或乐升水乃至日三升水。或翘一足随日转视行。如是等无量勤苦等苦遍苦自苦诸行。是名自苦自勤苦非苦他非勤苦他补特伽罗。问何故如是补特伽罗名自苦自勤苦非苦他非勤苦他。答由彼自苦而活其命故。名自苦自勤苦非苦他非勤苦他补特伽罗。云何苦他勤苦他非自苦非自勤苦补特伽罗。答若屠羊若屠鸡若屠猪。若捕鸟若捕鱼若猎兽。若作贼若魁脍若缚龙若司狱。若煮狗若罝弶等。是名苦他勤苦他非自苦非自勤苦补特伽罗。问何故如是补特伽罗名苦他勤苦他非自苦非自勤苦。答由彼苦他而自活命。故名苦他勤苦他非自苦非自勤苦补特伽罗。云何自苦自勤苦亦苦他勤苦他补特伽罗。答如王祠主欲祠祀时。先于城内结置祠坛。以诸酥油自涂支体。散发露顶被黑鹿皮。手执鹿角揩磨支体。或时祀火或时祭天。于祠坛中自饿自苦。以金色犊母牛置前先构一乳。用祀火天。第二为王第三为后第四为宰辅。余为余亲爱。于祠坛中杀害种种牛王水牛牸牛犊子鸡猪羊等诸傍生类。责罚恐怖亲属左右。令其悲泣忧苦愁叹。是名自苦自勤苦亦苦他勤苦他补特伽罗。问何故如是补特伽罗名自苦自勤苦亦苦他勤苦他。答由彼自苦亦苦于他而活其命。故名自苦自勤苦亦苦他勤苦他补特伽罗。云何非自苦非自勤苦亦非苦他非勤苦他补特伽罗。答谓诸如来应正等觉明行圆满善逝世间解无上丈夫调御士天人师佛薄伽梵。出现世间宣说正法。开示初善中善后善。文义巧妙纯一圆满清白梵行。诸善男子或善女人。闻是法已深生净信。生净信已作是思惟。在家迫迮多诸尘秽犹如牢狱。出家宽旷离诸諠杂犹若虚空。染室家者不能相续。尽其形寿精勤修习。纯一圆满清白梵行。是故我今应以正信。剃除须发被服袈裟。弃舍家法出趣非家。既思惟已财位亲属。若少若多悉皆弃舍。既弃舍已以正信心。剃除须发被服袈裟。远离家法出趣非家。既出家已受持净戒。精勤守护别解律仪。轨则所行无不圆满。于微小罪深见怖畏。于诸学处能具受学。离害生命弃诸刀杖。有惭有愧具慈具悲。于诸有情下至蚁卵。亦深怜愍终不损害。毕竟远离害生命法。离不与取能施乐施。若净施物知量而受。于诸所有不生染着。摄受清净无罪自体。毕竟远离不与取法。离非梵行常修梵行。远行妙行其心清洁。远离生臭淫欲秽法。毕竟远离非梵行法。离虚诳语常乐实语。谛语信语可承受语世无诤语。毕竟远离虚诳语法。离离间语不破坏他。不闻彼语为破坏故向此而说。不闻此语为破坏故向彼而说。常乐和合已破坏者。诸和好者赞令坚固。常乐宣说和合他语不破坏语。毕竟远离离间语法。离粗恶语所发语言。不粗不矿亦不苦楚令他嫌恨。亦令多人不爱不乐不欣不喜。障碍修习等引等持。于如是等诸粗恶语。皆能断灭所发语言。和软顺耳悦意可乐圆满清美。明显易了令他乐闻。无依无尽令多有情可爱可乐可欣可喜。能令修习等引等持。于如是等诸美妙语。常乐发起毕竟远离粗恶语法。离杂秽语凡所发言。应时应处称法称义。有实有真能寂能静。有次序有所为。应理合仪无杂无秽能引义利。毕竟远离杂秽语法。远离买卖伪秤伪斗伪斛函等。终不摄养象马牛驴鸡猪狗等诸傍生类。亦不摄养奴婢作使男女大小朋友亲属。终不受畜谷麦豆等。亦不受畜金银等宝。不非时食或唯一食。非时非处终不游行。若语若默不生讥论。于衣喜足粗得蔽身。于食喜足才除饥渴。凡所游住衣钵自随。如鸟飞止不舍嗉翼。彼由此故成就戒蕴。密护根门安住正念。由正念力防守其心。眼见诸色耳闻诸声。鼻嗅诸香舌尝诸味。身觉诸触意了诸法。不取其相不执随好。于此诸处住根律仪。防护贪忧恶不善法。毕竟不令随心生长。彼由戒蕴密护根门。观顾往来屈申俯仰。着衣持钵皆住正知。彼既成就清净戒蕴。密护根门正念正知。随所依止城邑聚落。于日初分执持衣钵。守护诸根安住正念。威仪庠序修行乞食。既得食已还至本处。饭食讫收衣钵洗足。已持坐具往阿练若。旷野山林远恶有情。舍诸卧具其处唯有非人所居。或住空闲或在树下。结加趺坐端直其身。舍异攀缘住对面念。心恒专注远离贪嗔惛沉睡眠掉举恶作疑惑犹豫。诸随烦恼能碍善品。令慧力羸不证涅槃。住生死者由斯离欲恶不善法。乃至得住第四静虑。彼由如是殊胜定心。清白无秽离随烦恼。柔软堪能得住无动。其心趣向能证漏尽智见明觉。能如实知见此是苦圣谛此是集圣谛。此是灭圣谛此是道圣谛。由如是知如是见故。心解脱欲漏有漏无明漏。既解脱已如实知见。我生已尽梵行已立。所作已办不受后有。是名非自苦非自勤苦亦非苦他非勤苦他补特伽罗。问何故如是补特伽罗名非自苦非自勤苦亦非苦他非勤苦他。答由彼不自苦亦不苦他而活其命。故名非自苦非自勤苦亦非苦他非勤苦他补特伽罗

说一切有部集异门足论卷第九阿毗达磨集异门足论卷第十

        尊者舍利子说

        三藏法师玄奘奉　诏译

    四法品第五之五

四语恶行者。一虚诳语。二离间语。三粗恶语。四杂秽语。云何虚诳语恶行。答如世尊说苾刍当知。有虚诳语者。或在质谅者前。或在大众中。或在王家。或在执理家。或在亲友家。为令证故作是问言。汝善男子应自忆念。若知便说不知勿说。若见便说不见勿说。彼得此问不知言知。或知言不知。不见言见或见言不见。彼或自为或复为他或为财利。正知而说虚诳语。不离虚诳语。此中有虚诳语者。谓不离虚诳语者不断虚诳语者。不厌虚诳语者。安住虚诳语者。成就虚诳语者。是名有虚诳语者。或在质谅者前者。谓或村落质谅者。或城邑质谅者。或邦国质谅者。如是等质谅者。若会遇若和合若现前。是名或在质谅者前。或在大众中者。谓或刹帝利众或婆罗门众。或长者众或沙门众。如是等诸大众。若会遇若和合。若现前是名或在大众中。或在王家者。谓有国王辅臣围绕。若会遇若和合若现前。是名或在王家。或在执理家者。谓执理众聚集评议。若会遇若和合若现前。是名或在执理家。或在亲友家者。谓诸亲友聚集言论。若会遇若和合若现前。是名或在亲友家。为令证故作是问言者。谓劝请彼说诚谛言。欲决是非故共审问。汝善男子应自忆念。若知便说不知勿说。若见便说不见勿说者。谓令忆念先所受境依实而说。可为明证此劝诫言。若于是事已见已闻已觉已知。便可宣说建立开示。若于是事不见不闻不觉不知。勿谬宣说建立开示。故作是言。汝善男子应自忆念。若知便说不知勿说若见便说不见勿说。彼得此问不知言知。或知言不知。不见言见。或见言不见者。此中不知言知者。谓耳识所受耳识所了说为所闻。彼实耳识未闻未了而隐覆此想。此忍此见此质直事。言我已闻。此等名为不知言知。或知言不知者。谓彼耳识已受已了而隐覆此想。此忍此见此质直事言我不闻。此等名为或知言不知。不见言见者。谓眼识所受眼识所了说为所见。彼实眼识未受未了。而隐覆此想。此忍此见此质直事言我已见。如是名为不见言见。或见言不见者。谓彼眼识已受已了而隐覆此想。此忍此见此质直事言我不见。如是名为或见言不见。彼或自为或复为他或为财利。正知而说虚诳语者。此中彼或自为者。如有一类自行劫盗被执送王。王亲检问。咄哉男子。汝于他物实作贼耶。彼作是念我若实答。王定嗔忿重加刑罚。或打或缚或驱出国。或夺资财或复断命。我当自覆自等覆。自藏自等藏。自护自等护。作虚诳语可免刑罚。作是念已便白王言。我于他物曾不劫盗。愿王鉴照我实非贼。如是名为彼或自为。或复为他者。如有一类亲友作贼被执送王。王亲检问不得情实。为作证故追检。问言汝之亲友实作贼不。彼作是念。我若实答王定嗔忿。令我亲友重遭刑罚。或打或缚或驱出国。或夺资财或复断命。我为亲友应覆等覆。应藏等藏。应护等护。作虚诳语令免刑罚。作是念已便白王言。我之亲友于他财物曾不劫盗。愿王鉴照彼实非贼。如是名为或复为他。或为财利者。如有一类心怀贪欲作是思惟。我当施设虚诳妄语方便求觅。可爱色声香味触境。衣服饮食卧具医药及余资财。作是念已即便追觅。由此因缘作虚诳语。如是名为或为财利。正知而说虚诳语者。谓审决已数数宣说。演畅表示虚诳语言。是名正知而说虚诳语。不离虚诳语者。谓于恶心不善心所起。恶行不善行所摄虚诳语。不离不断不厌不息。如是语言唱词评论。语音语路语业语表。名虚诳语恶行

云何离间语恶行。答如世尊说苾刍当知。有离间语者。闻此语向彼说。为破此故闻彼语向此说。为破彼故诸和合者令其乖离。已乖离者令永间隔。爱乐离间说离间语。不离离间语。此中有离间语者者。谓不离离间语者。不断离间语者。不厌离间语者。安住离间语者。成就离间语者。是名有离间语者。闻此语向彼说为破此故者。谓闻此说顺破坏语。顺不坚语。顺不摄语。顺不喜语。向彼宣说令彼闻已。便于此处乖反背叛。是名闻此语向彼说为破此故。闻彼语向此说为破彼故者。谓闻彼说。顺破坏语。顺不坚语。顺不摄语。顺不喜语。向此宣说令此闻已。便于彼处乖反背叛。是名闻彼语向此说为破彼故。诸和合者令其乖离者。谓往此彼展转和合。随顺喜乐无诤者所。方便破坏令其乖离。是名诸和合者令其乖离。已乖离者令永间隔者。谓往此彼已相乖反背叛者所。作如是言善哉汝等。已能展转乖反背叛。所以者何。汝等长夜更相呰毁。言不具信戒闻舍慧故。能展转乖反背叛甚为善哉。此彼闻已转相乖反转相背叛。是名已乖离者令永间隔。爱乐离间者。谓于此彼乖反背叛。深生爱乐不厌不舍是名爱乐离间。说离间语者。谓数宣说演畅表示。离间语言是名说离间语。不离离间语者。谓于恶心不善心。所起恶行不善行所摄离间语。不离不断不厌不息。如是语言唱词评论。语音语路语业语表。名离间语恶行

云何粗恶语恶行。答如世尊说苾刍当知。有粗恶语者。彼所发语能恼涩强。令他辛楚令他愤恚。众生不爱众生不乐。众生不喜众生不悦。令心扰乱能障等持。说粗恶语不离粗恶语。此中有粗恶语者者。谓不离粗恶语者。不断粗恶语者。不厌粗恶语者。安住粗恶语者。成就粗恶语者。是名有粗恶语者。彼所发语能恼者。谓所发语鄙秽粗矿。是名能恼。涩强者。谓所发语不滑不软亦不调顺。是名涩强。令他辛楚者。谓所发语令能闻者无利无乐。是名令他辛楚。令他愤恚者。谓所发语先自愤恚忿恼忧戚。亦令他生愤恚等事。是名令他愤恚。众生不爱众生不乐众生不喜众生不悦者。谓所发语令多有情不爱不乐不喜不悦。是名众生不爱乃至不悦。令心扰乱者。谓所发语令心躁动扰浊不得安定。是名令心扰乱。能障等持者。谓所发语令他闻已。其心躁动扰浊不得安定。是名能障等持。说粗恶语者。谓数宣说演畅表示粗恶语言。是名说粗恶语。不离粗恶语者。谓于恶心不善心所起。恶行不善行所摄粗恶语。不离不断不厌不息。如是语言唱词评论。语音语路语业语表。名粗恶语恶行

云何杂秽语恶行。答如世尊说苾刍当知。有杂秽语者。说非时语非实语非真语。无法语无义语。不寂语不静语。无喻无释不相应不相近。杂乱无法能引无义。说杂秽语不离杂秽语。此中有杂秽语者者。谓不离杂秽语者。不断杂秽语者。不厌杂秽语者。安住杂秽语者。成就杂秽语者。是名有杂秽语者。说非时语者。谓所说语。非时不应时。非节不应节。非分不应分。是名说非时语。非实语者。谓所说语不实不称实。是名非实语。非真语者。谓所说语虚妄变异。是名非真语。无法语者。谓所说语宣说显了表示开发纯非法事。是名无法语。无义语者。谓所说语宣说显了表示开发纯无义事。是名无义语。不寂语者。谓所说语。非诸智者先思而说率尔而说。是名不寂语。不静语者。谓所说语数数宣唱告示諠杂。是名不静语。无喻者谓所说语。无譬喻无释者。谓所说语无解释。不相应者谓所说语。义不应文文不应义。是名不相应。不相近者。谓所说语。前后不相续或意趣有异。是名不相近。杂乱者。谓所说语不一不定。名为杂乱。若所说语纯一决定名无杂乱。无法者。谓所说语越素呾缆及毗柰耶阿毗达磨。是名无法。能引无义者。谓所说语能引种种不饶益事。是名能引无义语。杂秽语者。谓数宣说演畅表示杂秽语言。是名说杂秽语。不离杂秽语者。谓于恶心不善心所起。恶行不善行所摄杂秽语。不离不断不厌不息。如是语言唱词评论。语音语路语业语表。名杂秽语恶行

四语妙行者。一离虚诳语。二离离间语。三离粗恶语。四离杂秽语。云何离虚诳语妙行。答如世尊说苾刍当知。有断虚诳语离虚诳语者。谛语乐实可信可保可住世间无诤说。如是语离虚诳语。此中有断虚诳语离虚诳语者者。谓断虚诳语者。离虚诳语者。厌虚诳语者。安住不虚诳语者。成就不虚诳语者。是名断虚诳语离虚诳语者。谛语者谓所说语。是实非不实。是真非不真。不虚妄不变异是名谛语。乐实者谓乐谛语。爱谛语。不厌不舍是名乐实。可信可保可住世间无诤者。谓由谛语。若天若魔若梵若沙门若婆罗门。若余世间天人众生皆共信保安住无诤。是名可信可保可住世间无诤说。如是语者。谓数宣说演畅表示不虚诳语。离虚诳语者。谓于善心调柔心所起善行。调柔行所摄离虚诳语。不离不断不厌不息。如是语言唱词评论。语音语路语业语表。是名离虚诳语妙行

云何离离间语妙行。答如世尊说苾刍当知。有断离间语离离间语者。不欲破坏不闻此语向彼说。为破坏此不闻彼语向此说。为破坏彼诸乖离者令其和合。已和合者令永坚固。爱乐和合说如是语离离间语。此中有断离间语离离间语者者。谓断离间语者。离离间语者。厌离间语者。安住不离间语者。成就不离间语者。是名有断离间语。离离间语者。不欲破坏者。谓欲和合不闻此语向彼说。为破坏此者。谓闻此说顺破坏语。顺不坚语。顺不摄语。顺不喜语。不向彼说勿彼闻已便于此处乖反背叛。是名不闻此语向彼说。为破坏此不闻彼语向此说为破坏彼者。谓闻彼说顺破坏语顺不坚语顺不摄语顺不喜语。不向此说勿此闻已便于彼处乖反背叛。是名不闻彼语向此说。为破坏彼诸乖离者。令其和合者。谓往此彼展转乖反背叛者所。种种方便令其和好。更相爱乐。是名诸乖离者令其和合。已和合者令永坚固者。谓往此彼展转和合随顺喜乐无诤者所。作如是言善哉汝等。能共和合随顺喜乐不相乖诤。所以者何。汝等长夜更相赞美。言具净信戒闻舍慧故无乖诤甚为善哉。此彼闻已转共和合随顺喜乐永无乖诤。是名已和合者令永坚固。爱乐和合者。谓于此彼和合随顺喜乐无诤。深生爱乐不厌不舍。是名爱乐和合。说如是语者。谓数宣说演畅表示不离间语。离离间语者。谓于善心调柔心所起。善行调柔行所摄。离离间语。不离不断不厌不息。如是语言唱词评论。语音语路语业语表。名离离间语妙行

云何离粗恶语妙行。答如世尊说苾刍当知。有断粗恶语离粗恶语者。彼所发语。无过悦耳入心高胜美妙明了。易解乐闻可尚无依。众生所爱众生所乐。众生所喜众生所悦。令心无乱能顺等持。说如是语离粗恶语。此中有断粗恶语离粗恶语者者。谓离粗恶语者。断粗恶语者。厌粗恶语者。安住离粗恶语者。成就离粗恶语者。是名有断粗恶语离粗恶语者。彼所发语无过者。谓所发语无曲秽浊。亦不刚强是名无过。悦耳者谓所发语能令闻者利益安乐是名悦耳。入心者谓所发语令心离盖及随烦恼。安隐而住是名入心。高胜者谓宫城语如宫城中人所发语。于余城邑人所发语。为最为胜为尊为高为上为妙。故名高胜。离粗恶语亦复如是。于余语言为最为胜为尊为高为上为妙。是名高胜。美妙者谓所发语。不疏不密不隐不显是名美妙。明了者。谓所发语不急不缓是名明了。易解者谓所发语易可了知是名易解。乐闻者。谓所发语软滑调顺是名乐闻。可尚者谓所发语应可供养。是名可尚。无依者谓所发语不希名利。是名无依。众生所爱众生所乐众生所喜众生所悦者。谓所发语令多有情爱乐喜悦。是名众生所爱乃至所悦。令心无乱者。谓所发语。令心安定无躁无动亦无扰浊。是名令心无乱。能顺等持者。谓所发语令他闻已其心安定。无躁无动亦无扰浊。是名能顺等持说。如是语者。谓数宣说演畅表示不粗恶语。离粗恶语者。谓于善心调柔心所起。善行调柔行所摄。离粗恶语。不离不断不厌不息。如是语言唱词评论。语音语路语业语表。是名离粗恶语妙行

云何离杂秽语妙行。答如世尊说苾刍当知。有断杂秽语离杂秽语者。彼有时语实语真语法语义语寂语静语有喻有释相应相近无杂乱有法能引义说如是语离杂秽语。此中有断杂秽语离杂秽语者者。谓离杂秽语者。断杂秽语者。厌杂秽语者。安住离杂秽语者。成就离杂秽语者。是名有断杂秽语离杂秽语者。彼有时语者。谓所说语。应时离非时。应节离非节。应分离非分。是名时语。实语者。谓所说语称实离非实。是名实语。真语者。谓所说语。不虚妄不变异是名真语。法语者。谓所说语。宣说显了表示开发。纯如法事是名法语。义语者。谓所说语。宣说显了表示开发。纯有义事是名义语。寂语者。谓所说语。是诸智者先思而说非率尔说。是名寂语。静语者谓所说语非数宣唱告示諠杂。是名静语。有喻有释者。谓所说语有譬喻有解释。是名有喻有释。相应者。谓所说语义应于文文应于义。是名相应。相近者。谓所说语前后相续意趣无异。是名相近。无杂乱者。谓所说语纯一决定名无杂乱。若所说语。不一不定名为杂乱。有法者。谓所说语。不越素呾缆及毗柰耶阿毗达磨。是名有法。能引义者。谓所说语能引种种有饶益事。是名能引义。说如是语者。谓数宣说演畅表示不杂秽语。离杂秽语者。谓于善心调柔心所起。善行调柔行所摄离杂秽语。不离不断不厌不息。如是语言唱词评论。语音语路语业语表。名离杂秽语妙行。四非圣言者。一不见言见。二不闻言闻。三不觉言觉。四不知言知。云何不见言见非圣言。答眼识所受眼识所了说为所见。有实眼识未受未了而隐覆此想。此忍此见此质直事言我已见。如是名为不见言见非圣言。有实已见起不见想而隐覆。此想此忍此见此质直事言我已见。如是虽名非圣言而不名不见言见。彼实已见故。云何不闻言闻非圣言。答耳识所受耳识所了说为所闻。有实耳识未受未了而隐覆此想。此忍此见此质直事言我已闻。如是名为不闻言闻非圣言。有实已闻起不闻想而隐覆此想。此忍此见此质直事。如是虽名非圣言。而不名不闻言闻。彼实已闻故。云何不觉言觉非圣言。答三识所受三识所了说为所觉。有实三识未受未了而隐覆此想。此忍此见此质直事。如是名为不觉言觉非圣言。有实已觉起不觉想。而隐覆此想。此忍此见此质直事。言我已觉。如是虽名非圣言。而不名不觉言觉。彼实已觉故。云何不知言知非圣言。答意识所受意识所了说为所知。有实意识未受未了而隐覆此想。此忍此见此质直事。言我已知。如是名为不知言知非圣言。有实已知起不知想而隐覆此想。此忍此见此质直事。言我已知。如是虽名非圣言。而不名不知言知。彼实已知故

四圣言者。一不见言不见二不闻言不闻。三不觉言不觉。四不知言不知。云何不见言不见圣言。答眼识所受眼识所了说为所见。有实眼识未受未了。彼不隐覆此想。此忍此见此质直事。言我未见。如是名为不见言不见圣言。有实已见起不见想彼不隐覆此想。此忍此见此质直事。言我不见。如是虽名圣言而不名不见言不见。彼实已见故。云何不闻言不闻圣言。答耳识所受耳识所了说为所闻。有实耳识未受未了。彼不隐覆此想。此忍此见此质直事。言我不闻。如是名为不闻言不闻圣言。有实已闻起不闻想。彼不隐覆此想。此忍此见此质直事。言我不闻。如是虽名圣言。而不名不闻言不闻。彼实已闻故。云何不觉言不觉圣言。答三识所受三识所了说为所觉。有实三识未受未了。彼不隐覆此想。此忍此见此质直事。言我不觉。如是名为不觉言不觉圣言。有实已觉起不觉想彼不隐覆此想。此忍此见此质直事。言我不觉。如是虽名圣言。而不名不觉言不觉。彼实已觉故。云何不知言不知圣言。答意识所受意识所了说为所知。有实意识未受未了。彼不隐覆此想。此忍此见此质直事。言我不知。如是名为不知言不知圣言。有实已知起不知想。彼不隐覆此想。此忍此见此质直事。言我不知。如是虽名圣言。而不名不知言不知。彼实已知故

复次四非圣言者。一见言不见。二闻言不闻。三觉言不觉。四知言不知。云何见言不见非圣言。答眼识所受眼识所了说为所见。有实眼识已受已了而隐覆此想。此忍此见此质直事。言我不见。如是名为见言不见非圣言。有实不见而起见想。彼隐覆此想。此忍此见此质直事。言我不见。如是虽名非圣言。而不名见言不见。彼实不见故。云何闻言不闻非圣言。答耳识所受耳识所了说为所闻。有实耳识已受已了而隐覆此想。此忍此见此质直事。言我不闻。如是名为闻言不闻非圣言。有实不闻而起闻想。彼隐覆此想。此忍此见此质直事。言我不闻。如是虽名非圣言。而不名闻言不闻。彼实不闻故。云何觉言不觉非圣言。答三识所受三识所了说为所觉。有实三识已受已了而隐覆此想。此忍此见此质直事。言我不觉。如是名为觉言不觉非圣言。有实不觉而起觉想。彼隐覆此想。此忍此见此质直事。言我不觉。如是虽名非圣言。而不名觉言不觉。彼实不觉故。云何知言不知非圣言。答意识所受意识所了说为所知。有实意识已受已了而隐覆此想。此忍此见此质直事。言我不知。如是名为知言不知非圣言。有实不知而起知想。彼隐覆此想。此忍此见此质直事。言我不知。如是虽名非圣言。而不名知言不知。彼实不知故

复次四圣言者。一见言见。二闻言闻。三觉言觉。四知言知。云何见言见圣言。答眼识所受眼识所了说为所见。有实眼识已受已了。彼不隐覆此想。此忍此见此质直事。言我已见如是名为见言见圣言。有实不见而起见想。彼不隐覆此想。此忍此见此质直事。言我已见。如是虽名圣言。而不名见言见。彼实不见故。云何闻言闻圣言。答耳识所受耳识所了说为所闻。有实耳识已受已了。彼不隐覆此想。此忍此见此质直事。言我已闻。如是名为闻言闻圣言。有实不闻而起闻想。彼不隐覆此想。此忍此见此质直事。言我已闻。如是虽名圣言。而不名闻言闻。彼实不闻故。云何觉言觉圣言。答三识所受三识所了说为所觉。有实三识已受已了彼不隐覆此想。此忍此见此质直事。言我已觉。如是名为觉言觉圣言。有实不觉而起觉想。彼不隐覆此想。此忍此见此质直事。言我已觉。如是虽名圣言。而不名觉言觉。彼实不觉故。云何知言知圣言。答意识所受意识所了说为所知。有实意识已受已了。彼不隐覆此想。此忍此见此质直事。言我已知。如是名为知言知圣言。有实不知而起知想。彼不隐覆此想。此忍此见此质直事。言我已知。如是虽名圣言。而不名知言知。彼实不知故

说一切有部集异门足论卷第十阿毗达磨集异门足论卷第十一

        尊者舍利子说

        三藏法师玄奘奉　诏译

    五法品第六之一

时舍利子复告众言。具寿当知。佛于五法自善通达。现等觉已为诸弟子宣说开示。我等今应和合结集。佛灭度后勿有乖诤。当令随顺梵行法律。久住利乐无量有情。哀愍世间诸天人众。令获殊胜义利安乐。五法云何。此中有二嗢拖南颂。初嗢拖南曰

  初五法十种　　谓蕴取妙欲
  悭趣盖栽缚　　下上结各五

有五蕴五取蕴五妙欲五悭五趣五盖五心栽五心缚五顺下分结五顺上分结

五蕴者。一色蕴二受蕴三想蕴四行蕴五识蕴。云何色蕴。答诸所有色。若过去若未来若现在。若内若外若粗若细。若劣若胜。若远若近。如是一切略为一聚说名色蕴。云何受蕴。答诸所有受。若过去若未来若现在。若内若外若粗若细。若劣若胜若远若近。如是一切略为一聚说名受蕴。云何想蕴。答诸所有想。若过去若未来若现在。若内若外若粗若细若劣若胜若远若近。如是一切略为一聚说名想蕴。云何行蕴。答诸所有行。若过去若未来若现在。若内若外若粗若细。若劣若胜若远若近。如是一切略为一聚说名行蕴。云何识蕴。答诸所有识。若过去若未来若现在。若内若外若粗若细。若劣若胜若远若近。如是一切略为一聚说名识蕴。此中诸所有色者。云何名为诸所有色。答尽所有色。谓四大种及四大种所造诸色。如是名为诸所有色。复次尽所有色。谓十色处及法处所摄色。如是名为诸所有色。若过去若未来若现在者。云何过去色。答若色已起已等起。已生已等生。已转已现转。已聚集已出现。落谢过去尽灭离变。过去性过去类过去世摄。是名过去色。云何未来色。答若色未已起未已等起。未已生未已等生。未已转未已现转。未聚集未出现。未来性未来类未来世摄。是名未来色。云何现在色。答若色已起已等起。已生已等生。已转已现转。聚集出现住未已谢。未已尽灭未已离变和合现前。现在性现在类现在世摄。是名现在色。若内若外者。云何内色。答若色在此相续已得不失是名内色。云何外色。答若色在此相续。或本未得或得已失。若他相续若非情数。是名外色。若粗若细者。云何施设粗色细色。答观待施设粗色细色。复如何等。答若观待无见有对色。则有见有对色名粗。若观待有见有对色。则无见有对色名细。若观待无见无对色。则无见有对色名粗。若观待无见有对色。则无见无对色名细。若观待色界色。则欲界色名粗。若观待欲界色。则色界色名细。若观待不系色。则色界色名粗。若观待色界色。则不系色名细。如是施设粗色细色。如是名为若粗若细。若劣若胜者云何施设劣色胜色。答观待施设劣色胜色。复如何等。答若观待有覆无记色。则不善色名劣。若观待不善色则有覆无记色名胜。若观待无覆无记色。则有覆无记色名劣。若观待有覆无记色。则无覆无记色名胜。若观待有漏善色。则无覆无记色名劣。若观待无覆无记色。则有漏善色名胜。若观待无漏善色。则有漏善色名劣。若观待有漏善色。则无漏善色名胜。若观待色界色。则欲界色名劣。若观待欲界色则色界色名胜。若观待不系色。则色界色名劣。若观待色界色。则不系色名胜。如是施设劣色胜色。如是名为若劣若胜。若远若近者云何远色。答过去未来色。云何近色。答现在色。复次云何远色。答若色过去非无间灭。若色未来非现前起是名远色。云何近色。答若色过去无间已灭。若色未来现前正起是名近色。如是名为若远若近。如是一切略为一聚者。云何一切略为一聚。答推度思惟称量观察集为一聚。是故名为如是一切略为一聚。说名色蕴者云何说名色蕴。答于此色蕴显色显蕴显身显聚。是故名为说名色蕴。诸所有受者。云何名为诸所有受。答尽所有受。谓六受身。何等为六。谓眼触所生受。耳鼻舌身意触所生受。如是名为诸所有受。若过去若未来若现在者。云何过去受。答若受已起已等起。已生已等生。已转已现转。已聚集已出现。落谢过去尽灭离变。过去性过去类过去世摄。是名过去受。云何未来受。答若受未已起未已等起。未已生未已等生。未已转未已现转。未聚集未出现。未来性未来类未来世摄。是名未来受。云何现在受。答若受已起已等起。已生已等生。已转已现转。聚集出现住未已谢。未已尽灭。未已离变和合现前。现在性现在类现在世摄。是名现在受。若内若外者。云何内受。答若受在此相续已得不失。是名内受。云何外受。答若受在此相续。或本未得或得已失。若他相续是名外受。若粗若细者。云何施设粗受细受。答观待。施设粗受细受复如何等。答若观待无寻唯伺受。则有寻有伺受名粗。若观待有寻有伺受。则无寻唯伺受名细。若观待无寻无伺受。则无寻唯伺受名粗。若观待无寻唯伺受。则无寻无伺受名细。若观待色界受。则欲界受名粗。若观待欲界受。则色界受名细。若观待无色界受。则色界受名粗。若观待色界受。则无色界受名细。若观待不系受。则无色界受名粗。若观待无色界受。则不系受名细。如是施设粗受细受。如是名为若粗若细。若劣若胜者云何施设劣受胜受。答观待施设劣受胜受。复如何等。答若观待有覆无记受。则不善受名劣。若观待不善受则有覆无记受名胜。若观待无覆无记受。则有覆无记受名劣。若观待有覆无记受。则无覆无记受名胜。若观待有漏善受。则无覆无记受名劣。若观待无覆无记受。则有漏善受名胜。若观待无漏善受。则有漏善受名劣。若观待有漏善受。则无漏善受名胜。若观待色界受。则欲界受名劣。若观待欲界受。则色界受名胜。若观待无色界受。则色界受名劣。若观待色界受。则无色界受名胜。若观待不系受。则无色界受名劣。若观待无色界受。则不系受名胜。如是施设劣受胜受。如是名为若劣若胜。若远若近者云何远受。答过去未来受。云何近受。答现在受。复次云何远受。答若受过去非无间灭。若受未来非现前起是名远受。云何近受。答若受过去无间已灭。若受未来现前正起是名近受。如是名为若远若近。如是一切略为一聚者。云何一切略为一聚。答推度思惟称量观察集为一聚。是故名为如是一切略为一聚说名受蕴者。云何说名受蕴。答于此受蕴显受显蕴显身显聚。是故名为说名受蕴。诸所有想者。云何名为诸所有想。答尽所有想。谓六想身何等为六。谓眼触所生想。耳鼻舌身意触所生想。如是名为诸所有想。若过去若未来若现在者。云何过去想。答若想已起已等起。已生已等生。已转已现转。已聚集已出现。落谢过去尽灭离变。过去性过去类过去世摄。是名过去想。云何未来想。答若想未已起未已等起。未已生未已等生。未已转未已现转。未聚集未出现。未来性未来类未来世摄。是名未来想。云何现在想。答若想已起已等起。已生已等生。已转已现转。聚集出现。住未已谢。未已尽灭。未已离变和合现前。现在性现在类现在世摄。是名现在想。若内若外者。云何内想。答若想在此相续已得不失是名内想。云何外想。答若想在此相续。或本未得或得已失。若他相续是名外想。若粗若细者。云何施设粗想细想。答观待施设粗想细想。复如何等。答若观待无寻唯伺想。则有寻有伺想名粗。若观待有寻有伺想。则无寻唯伺想名细。若观待无寻无伺想。则无寻唯伺想名粗。若观待无寻唯伺想。则无寻无伺想名细。若观待色界想。则欲界想名粗。若观待欲界想。则色界想名细。若观待无色界想。则色界想名粗。若观待色界想。则无色界想名细。若观待不系想。则无色界想名粗。若观待无色界想。则不系想名细。如是施设粗想细想。如是名为若粗若细。若劣若胜者。云何施设劣想胜想。答观待施设劣想胜想。复如何等。答若观待有覆无记想。则不善想名劣。若观待不善想。则有覆无记想名胜。若观待无覆无记想。则有覆无记想名劣。若观待有覆无记想。则无覆无记想名胜。若观待有漏善想。则无覆无记想名劣。若观待无覆无记想。则有漏善想名胜。若观待无漏善想。则有漏善想名劣。若观待有漏善想。则无漏善想名胜。若观待色界想。则欲界想名劣。若观待欲界想则色界想名胜。若观待无色界想。则色界想名劣。若观待色界想。则无色界想名胜。若观待不系想。则无色界想名劣。若观待无色界想。则不系想名胜。如是施设劣想胜想。如是名为若劣若胜。若远若近者。云何远想。答过去未来想。云何近想。答现在想。复次云何远想。答若想过去非无间灭。若想未来非现前起是名远想。云何近想。答若想过去无间已灭。若想未来现前正起是名近想。如是名为若远若近。如是一切略为一聚者。云何一切略为一聚。答推度思惟称量观察。集为一聚。是故名为如是一切略为一聚说名想蕴者。云何说名想蕴。答于此想蕴。显想显蕴显身显聚。是故名为说名想蕴。诸所有行者。云何名为诸所有行。答尽所有行谓六行身。何等为六。谓眼触所生行耳鼻舌身意触所生行。如是名为诸所有行。若过去若未来若现在者。云何过去行。答若行已起已等起。已生已等生。已转已现转。已聚集已出现。落谢过去尽灭离变。过去性过去类过去世摄。是名过去行。云何未来行。答若行未已起未已等起。未已生未已等生。未已转未已现转。未聚集未出现。未来性未来类未来世摄。是名未来行。云何现在行。答若行已起已等起。已生已等生。已转已现转。聚集出现住未已谢未已尽灭。未已离变和合现前。现在性现在类现在世摄。是名现在行。若内若外者。云何内行。答若行在此相续。已得不失是名内行。云何外行。答若行在此相续。或本未得或得已失。若他相续若非情数。是名外行。若粗若细者。云何施设粗行细行。答观待施设粗行细行。复如何等。答若观待无寻唯伺行。则有寻有伺行名粗。若观待有寻有伺行。则无寻唯伺行名细。若观待无寻无伺行。则无寻唯伺行名粗。若观待无寻唯伺行。则无寻无伺行名细。若观待色界行则欲界行名粗。若观待欲界行则色界行名细。若观待无色界行则色界行名粗。若观待色界行。则无色界行名细。若观待不系行则无色界行名粗。若观待无色界行则不系行名细。如是施设粗行细行。如是名为若粗若细。若劣若胜者。云何施设劣行胜行。答观待施设劣行胜行。复如何等。答若观待有覆无记行。则不善行名劣。若观待不善行则有覆无记行名胜。若观待无覆无记行。则有覆无记行名劣。若观待有覆无记行。则无覆无记行名胜。若观待有漏善行。则无覆无记行名劣。若观待无覆无记行。则有漏善行名胜。若观待无漏善行则有漏善行名劣。若观待有漏善行。则无漏善行名胜。若观待色界行。则欲界行名劣。若观待欲界行。则色界行名胜。若观待无色界行。则色界行名劣。若观待色界行。则无色界行名胜。若观待不系行。则无色界行名劣。若观待无色界行。则不系行名胜。如是施设劣行胜行。如是名为若劣若胜。若远若近者。云何远行

答过去未来行。云何近行。答现在行。复次云何远行。答若行过去非无间灭。若行未来非现前起。是名远行。云何近行

答若行过去无间已灭。若行未来现前正起是名近行。如是名为若远若近。如是一切略为一聚者。云何一切略为一聚。答推度思惟称量观察集为一聚。是故名为如是一切略为一聚。说名行蕴者。云何说名行蕴。答于此行蕴显行显蕴显身显聚。是故名为说名行蕴。诸所有识者。云何名为诸所有识。答尽所有识。谓六识身。何等为六。谓眼识耳鼻舌身意识。如是名为诸所有识。若过去若未来若现在者。云何过去识。答若识已起已等起。已生已等生。已转已现转。已聚集已出现。落谢过去尽灭离变。过去性过去类过去世摄。是名过去识。云何未来识。答若识未已起未已等起。未已生未已等生。未已转未已现转。未聚集未出现。未来性未来类未来世摄。是名未来识。云何现在识。答若识已起已等起。已生已等生。已转已现转。聚集出现住未已谢。未已尽灭未已离变和合现前。现在性现在类现在世摄。是名现在识。若内若外者。云何内识。答若识在此相续已得不失是名内识。云何外识。答若识在此相续。或本未得或得已失。若他相续是名外识。若粗若细者。云何施设粗识细识。答观待施设粗识细识。复如何等。答若观待无寻唯伺识。则有寻有伺识名粗。若观待有寻有伺识。则无寻。唯伺识名细。若观待无寻无伺识。则无寻唯伺识名粗。若观待无寻唯伺识。则无寻无伺识名细。若观待色界识。则欲界识名粗。若观待欲界识。则色界识名细。若观待无色界识。则色界识名粗。若观待色界识。则无色界识名细。若观待不系识则无色界识名粗。若观待无色界识。则不系识名细。如是施设粗识细识。如是名为若粗若细。若劣若胜者。云何施设劣识胜识。答观待施设劣识胜识复如何等。答若观待有覆无记识。则不善识名劣。若观待不善识。则有覆无记识名胜。若观待无覆无记识。则有覆无记识名劣。若观待有覆无记识。则无覆无记识名胜。若观待有漏善识。则无覆无记识名劣。若观待无覆无记识。则有漏善识名胜。若观待无漏善识。则有漏善识名劣。若观待有漏善识。则无漏善识名胜。若观待色界识。则欲界识名劣。若观待欲界识。则色界识名胜。若观待无色界识。则色界识名劣。若观待色界识。则无色界识名胜。若观待不系识。则无色界识名劣。若观待无色界识。则不系识名胜。如是施设劣识胜识。如是名为若劣若胜。若远若近者。云何远识。答过去未来识。云何近识答现在识。复次云何远识。答若识过去非无间灭。若识未来非现前起。是名远识。云何近识。答若识过去无间已灭。若识未来现前正起。是名近识。如是名为若远若近。如是一切略为一聚者。云何一切略为一聚。答推度思惟称量观察集为一聚。是故名为如是一切略为一聚。说名识蕴者。云何说名识蕴。答于此识蕴显识显蕴显身显聚。是故名为说名识蕴

五取蕴者。一色取蕴。二受取蕴。三想取蕴。四行取蕴。五识取蕴。云何色取蕴。答若色有漏随顺诸取于此诸色。若过去若未来若现在。欲生时生或贪或嗔或痴。或随一一心所随烦恼。是名色取蕴。云何受取蕴。答若受有漏随顺诸取于此诸受。若过去若未来若现在。欲生时生或贪或嗔或痴。或随一一心所随烦恼。是名受取蕴。云何想取蕴。答若想有漏随顺诸取于此诸想。若过去若未来若现在。欲生时生或贪或嗔或痴。或随一一心所随烦恼。是名想取蕴。云何行取蕴。答若行有漏随顺诸取于此诸行。若过去若未来若现在。欲生时生或贪或嗔或痴。或随一一心所随烦恼。是名行取蕴。云何识取蕴。答若识有漏随顺诸取于此诸识。若过去若未来若现在。欲生时生或贪或嗔或痴。或随一一心所随烦恼。是名识取蕴

五妙欲者。一眼所识色。可爱可乐可喜可意。此可爱色能引诸欲随顺染着。名眼所识色妙欲。二耳所识声。可爱可乐可喜可意。此可爱声能引诸欲随顺染着。名耳所识声妙欲。三鼻所识香。可爱可乐可喜可意。此可爱香能引诸欲随顺染着。名鼻所识香妙欲。四舌所识味。可爱可乐可喜可意。此可爱味能引诸欲随顺染着。名舌所识味妙欲。五身所识触。可爱可乐可喜可意。此可爱触能引诸欲随顺染着。名身所识触妙欲。云何眼所识色妙欲。答若色欲界系眼触所生爱所缘。是名眼所识色妙欲。云何耳所识声妙欲。答若声欲界系耳触所生爱所缘。是名耳所识声妙欲。云何鼻所识香妙欲。答若香欲界系鼻触所生爱所缘。是名鼻所识香妙欲。云何舌所识味妙欲。答若味欲界系舌触所生爱所缘。是名舌所识味妙欲。云何身所识触妙欲。答若触欲界系身触所生爱所缘。是名身所识触妙欲

五悭者。一住处悭。二家悭。三色赞悭。四利养悭。五法悭。云何住处悭。答若于住处顾恋系心。谓如有一作如是念。愿此住处属我非余。我于此处经行敷设。居止受用勿余复得。彼于住处顾恋系心。于他有情障碍遮止。不施不惠不随施惠。不弃不舍不遍弃舍。是名住处悭。云何家悭。答若于施主家顾恋系心。谓如有一作如是念愿。此施主家属我非余。我于此家独入独出。往还亲昵居止受用勿余复得。彼于施主家顾恋系心。于他有情障碍遮止。不施不惠不随施惠。不弃不舍不遍弃舍。是名家悭。云何色赞悭。答若于色赞顾恋系心。谓如有一作如是念。愿我独得微妙好色。众所乐见颜貌端正。成就第一清净圆满。诸显形色余无及者。愿我独得广大名称善声善誉。遍诸方维一切世间。皆共赞颂余无及者。唯我善知受用饮食。及余资具令所饮食。随时消化资具长养。面色光泽皮肤细软。众所爱乐余不能及。唯我善知冠带衣服。及诸严具庄饰形貌。令极显好余皆不及。彼于色赞顾恋系心。于他有情障碍遮止。不施不惠不随施惠。不弃不舍不遍弃舍。是名色赞悭。云何利养悭。答若于利养顾恋系心。谓如有一作如是念。愿我独得世间利养。余不能得愿独差我。受诸利养不差余人。愿独知我具大福慧。随时布施衣服饮食。卧具医药及余资财。一切世间无及我者。彼于利养顾恋系心。于他有情障碍遮止。不施不惠不随施惠。不弃不舍不遍弃舍。是名利养悭。云何法悭。答若于教法顾恋系心。谓如有一作如是念。愿我独能宣说正法。余皆不能愿我独能。令他诵念余皆不能。愿我独能。问答决择余皆不能。愿我独能持素怛缆。及毗奈耶阿毗达磨。余皆不能。愿我独能分别解释善理教者。所造诸论及自能造。余皆不能。彼于教法顾恋系心。于他有情障碍遮止不施不惠。不随施惠不弃不舍不遍弃舍。是名法悭

五趣者。一地狱趣。二傍生趣。三鬼趣。四人趣。五天趣。云何地狱趣。答与诸地狱一性一类。众同分等依得事得处得。若诸所有生地狱已。无覆无记色受想行识。是名地狱趣。复次由上品身恶行语恶行意恶行。若习若修若多所作。往于地狱生地狱中结地狱生。是名地狱趣。复次地狱趣者。是名是号异语增语。想等想施设言说。故名地狱趣。云何傍生趣。答与诸傍生一性一类。众同分等依得事得处得。若诸所有生傍生已。无覆无记色受想行识是名傍生趣。复次由愚钝身恶行语恶行意恶行。往于傍生生傍生中结傍生生。是名傍生趣。复次傍生趣者。是名是号异语增语。想等想施设言说。故名傍生趣。云何鬼趣。答与诸鬼众一性一类。众同分等依得事得处得。若诸所有生鬼界已。无覆无记色受想行识是名鬼趣。复次由悭吝身恶行语恶行意恶行。若习若修若多所作。往于鬼界生鬼界中结鬼界生。是名鬼趣。复次鬼趣者。是名是号异语增语。想等想施设言说。故名鬼趣。云何人趣。答与诸人众一性一类。众同分等依得事得处得。若诸所有生人中已。无覆无记色受想行识是名人趣。复次由下品身妙行语妙行意妙行。若习若修若多所作。往于人中生于人中结人中生。是名人趣。复次人趣者。是名是号异语增语。想等想施设言说。故名人趣。云何天趣。答与诸天众一性一类。众同分等依得事得处得。若诸所有生天上已。无覆无记色受想行识。是名天趣。复次由上品身妙行语妙行意妙行。若习若修若多所作。往于天上生于天上结天上生。是名天趣。复次天趣者。是名是号异语增语。想等想施设言说。故名天趣

说一切有部集异门足论卷第十一阿毗达磨集异门足论卷第十二

        尊者舍利子说

        三藏法师玄奘奉　诏译

    五法品第六之二

五盖者。一贪欲盖。二嗔恚盖。三惛沉睡眠盖。四掉举恶作盖。五疑盖。贪欲盖者。云何贪欲。答于诸欲境诸贪等贪执藏防护。坚着爱乐迷闷耽嗜。遍耽嗜内缚希求。耽湎苦集贪类贪生。是名贪欲。云何贪欲盖。答由此贪欲障心蔽心。镇心隐心盖心覆心缠心裹心。故名贪欲盖。嗔恚盖者。云何嗔恚。答于诸有情欲为损害。内怀栽[卄/(阿-可+辛)/子]欲为扰恼。已嗔当嗔现嗔。乐为过患极为过患意极愤恚。于诸有情各相违戾欲为过患。已为过患当为过患现为过患。是名嗔恚。云何嗔恚盖。答由此嗔恚障心蔽心镇心。隐心盖心覆心缠心裹心。故名嗔恚盖。惛沉睡眠盖者。云何惛沈。答所有身重性心重性。身不调柔性心不调柔性。身惛沉心惛沈[夢-夕+登]瞢愦闷。是名惛沈。云何睡眠。答染污心中所有眠梦。不能任持心昧略性是名睡眠。云何惛沉睡眠盖。答由此惛沉睡眠障心蔽心镇心。隐心盖心覆心缠心裹心。故名惛沉睡眠盖。掉举恶作盖者。云何掉举。答诸有令心不寂不静。掉举等掉举心掉举性。是名掉举。云何恶作。答染污心中所有令心变悔恶作恶作性。是名恶作。云何掉举恶作盖。答由此掉举恶作障心蔽心镇心。隐心盖心覆心缠心裹心。故名掉举恶作盖。疑盖者云何疑。答于佛法僧及苦集灭道。生起疑惑二分二路。踌躇犹豫犹豫箭不悦。不悦行不决度不悟入。非已一趣非当一趣非现一趣。是名疑。云何疑盖。答由此疑故障心蔽心镇心。隐心盖心覆心缠心裹心。故名疑盖

五心栽者。云何为五。具寿当知。如有一类于大师所。疑惑犹豫不悟入。无胜解无净信。若于大师疑惑犹豫。不悟入无胜解无净信。是名第一。于大师所心栽未断未遍知。如有一类于正法所。疑惑犹豫不悟入。无胜解无净信。若于正法疑惑犹豫。不悟入无胜解无净信。是名第二。于正法所心栽未断未遍知。如有一类于所学处。疑惑犹豫不悟入。无胜解无净信。若于所学疑惑犹豫。不悟入无胜解无净信。是名第三。于所学处心栽未断未遍知。如有一类于教诫所。疑惑犹豫不悟入。无胜解无净信。若于教诫疑惑犹豫。不悟入无胜解无净信。是名第四。于教诫所心栽未断未遍知。如有一类。于诸苾刍上座聪慧。久入佛法久修梵行。乃至大师及诸有智。同梵行者共所称赞护念敬爱。于是有智梵行者所。嗔恚毁骂陵辱触恼。不悟入无胜解无净信。若于苾刍上座聪慧。久入佛法久修梵行乃至大师。及诸有智同梵行者。共所称赞护念敬爱。如是有智梵行者所。嗔恚毁骂陵辱触恼不悟入无胜解无净信。是名第五。于诸有智梵行者所。心栽未断未遍知。若于大师疑惑犹豫。不悟入无胜解无净信。是名第一。于大师所。心栽未断未遍知者。云何大师。答谓诸如来应正等觉是名大师。云何于大师所疑惑犹豫。答于诸如来应正等觉。发起种种疑惑犹豫。是名于大师所疑惑犹豫。云何不悟入无胜解无净信。答若于大师生起种种疑惑犹豫。便于彼断不能发起。随顺心随顺欲随顺信。随顺胜解已胜解当胜解。是名不悟入无胜解无净信。云何是名第一。答渐次顺次相续次第数为第一。云何于大师所心栽。答若于如来应正等觉。生起种种疑惑犹豫。便于彼心自作栽事。譬如农夫虽有良田。若不耕垦即便坚硬。多诸栽[卄/(阿-可+辛)/子]秽草不植何况嘉苗。于大师所疑惑犹豫亦复如是。覆蔽其心令心刚强作栽[卄/(阿-可+辛)/子]事。尚不令心得邪决定况正决定。是名于大师所心栽。云何未断未遍知。答彼于心栽未降伏未永害。是名未断未遍知。若于正法疑惑犹豫不悟入无胜解无净信。是名第二。于正法所心栽未断未遍知者。云何正法。答爱尽离灭究竟涅槃。是名正法。云何于正法疑惑犹豫。答若于爱尽离灭究竟涅槃。生起种种疑惑犹豫。是名于正法疑惑犹豫。云何不悟入无胜解无净信。答若于正法生起种种疑惑犹豫。便于彼断不能发起。随顺心随顺欲。随顺信随顺胜解。已胜解当胜解。是名不悟入无胜解无净信。云何是名第二。答渐次顺次相续次第数为第二。云何于正法所心栽。答若于爱尽离灭究竟涅槃。生起种种疑惑犹豫。便于彼心自作栽事。譬如农夫虽有良田。若不耕垦即便坚硬。多诸栽[卄/(阿-可+辛)/子]秽草不植何况嘉苗。于正法所疑惑犹豫亦复如是。覆蔽其心令心刚强。作栽[卄/(阿-可+辛)/子]事尚不令心得邪决定。况正决定。是名于正法所心栽。云何未断未遍如。答彼于心栽未降伏未永害。是名未断未遍知。若于所学疑惑犹豫。不悟入无胜解无净信。是名第三。于所学处心栽未断未遍知者。云何所学。答若诸如来应正等觉。正知正见施设学处。是名所学。如说我如是学我学此事。于理善法不能证得。我如是学我学此事。于理善法则能证得。云何于所学疑惑犹豫。答于诸如来应正等觉。施设学处生起种种疑惑犹豫。是名于所学疑惑犹豫。云何不悟入无胜解无净信。答若于所学生。起种种疑惑犹豫。便于彼断不能发起。随顺心随顺欲随顺信。随顺胜解已胜解当胜解。是名不悟入无胜解无净信。云何是名第三。答渐次顺次相续次第数为第三。云何于所学心栽。答若于如来应正等觉。正知正见施设学处。生起种种疑惑犹豫。便于彼心自作栽事。譬如农夫虽有良田。若不耕垦即便坚硬。多诸栽[卄/(阿-可+辛)/子]秽草不植何况嘉苗。于所学处疑惑犹豫亦复如是。覆蔽其心令心刚强。作栽[卄/(阿-可+辛)/子]事尚不令心得邪决定。况正决定。是名于所学处心栽。云何未断未遍知。答彼于心栽未降伏未永害。是名未断未遍知。若于教诫疑惑犹豫。不悟入无胜解无净信。是名第四。于教诫所心栽。未断未遍知者。云何教诫。答若诸如来应正等觉。正知正见半月半月。所说别解脱戒经。是名教诫。如说我如是教诫。我教诫此事于理善法不能证得。我如是教诫我教诫此事。于理善法则能证得。云何于教诫疑惑犹豫。答于诸如来应正等觉。半月半月所说别解脱戒经。生起种种疑惑犹豫。是名于教诫疑惑犹豫。云何不悟入无胜解无净信。答若于教诫生起种种疑惑犹豫。便于彼断不能发起。随顺心随顺欲随顺信。随顺胜解已胜解当胜解。是名不悟入无胜解无净信。云何是名第四。答渐次顺次相续次第数为第四。云何于教诫所心栽。答若于如来应正等觉。正知正见半月半月。所说别解脱戒经。生起种种疑惑犹豫。便于彼心自作栽事。譬如农夫虽有良田。若不耕垦即便坚硬。多诸栽[卄/(阿-可+辛)/子]秽草不植何况嘉苗。于教诫所疑惑犹豫亦复如是。覆蔽其心令心刚强作栽[卄/(阿-可+辛)/子]事。尚不令心得邪决定。况正决定。是名于教诫所心栽。云何未断未遍知。答彼于心栽未降伏未永害。是名未断未遍知。若于苾刍上座聪慧。久入佛法久修梵行。乃至大师及诸有智。同梵行者共所称赞护念敬爱。如是有智梵行者所。嗔恚毁骂陵辱触恼。不悟入无胜解无净信。是名第五。于诸有智梵行者所。心栽未断未遍知者。云何大师。答谓诸如来应正等觉。云何有智同梵行者。答谓舍利子。大采菽氏。大营构氏。大饮光。大执藏。大劫庀那。大迦多衍那。大准陀。大善见。大路。大名。无灭欲乐金毗罗等。贤圣弟子是名有智同梵行者。若为大师及诸有智同梵行者。共所称赞护念敬爱。是名苾刍上座聪慧久入佛法久修梵行。即此苾刍名有智梵行者。云何如是有智梵行者。所嗔恚毁骂陵辱触恼。答于彼有智梵行者所。起嗔恚心发不随顺语。不随顺语表毁辱陵突。是名如是有智梵行者所。嗔恚毁骂陵辱触恼。云何不悟入无胜解无净信。答若于有智梵行者所。嗔恚毁骂陵辱触恼。便于彼断不能发起。随顺心随顺欲随顺信。随顺胜解已胜解当胜解。是名不悟入无胜解无净信。云何是名第五。答渐次顺次相续次第数为第五。云何于诸有智梵行者所心栽。答若于有智梵行者所。嗔恚毁骂陵辱触恼。便于彼心自作栽事。譬如农夫虽有良田若不耕垦。即便坚硬多诸栽[卄/(阿-可+辛)/子]。秽草不植何况嘉苗。于诸有智梵行者所。嗔恚毁骂陵辱触恼亦复如是。覆蔽其心令心刚强。作栽[卄/(阿-可+辛)/子]事。尚不令心得邪决定。况正决定。是名于诸有智梵行者所心栽。云何未断未遍知。答彼于心栽未降伏未永害。是名未断未遍知

五心缚者。云何为五。具寿当知。如有一类于身未离贪。未离欲未离亲未离爱未离渴。彼由于身未离贪等故。便于炽然加行。永断寂静证得上义。心不悟入无净信不安住无胜解。若于炽然加行等。心不悟入乃至无胜解。是名第一。于身未离贪等。心缚未降伏未永害。复次具寿。如有一类。于诸欲境未离贪。未离欲未离亲未离爱未离渴。彼由于欲未离贪等故。便于炽然加行永断寂静证得上义。心不悟入无净信。不安住无胜解。若于炽然加行等。心不悟入乃至无胜解。是名第二。于欲未离贪等。心缚未降伏未永害。复次具寿。如有一类。乐与在家出家离住。于乐同乐于苦同苦。同喜同忧。于诸事务皆共兴起。究竟随转不相舍离。彼由乐与在家出家杂住等故。便于炽然加行永断寂静证得上义。心不悟入无净信。不安住无胜解。若于炽然加行等。心不悟入乃至无胜解。是名第三。乐相杂住。心缚未降伏未永害。复次具寿。如有一类。于诸正论是圣除遣。能趣向心离盖可乐所。谓戒论定论慧论解脱论解脱智见论。少欲论喜足论损减论省事论。永断论离染论寂灭论。随顺缘性缘起等论。彼于宣说如是论时。不恭敬听不属耳听。不住受教心不行法随法越大师教。于诸学处不乐受学。彼由宣说如是论时。不恭敬听等故。便于炽然加行永断寂静证得上义。心不悟入无净信。不安住无胜解。若于炽然加行等。心不悟入乃至无胜解。是名第四。于诸正论心缚未降伏未永害。复次具寿。如有一类少小证得。虽有后时所作胜事。而中止息。彼由少小证得等故。便于炽然加行永断寂静证得上义。心不悟入无净信。不安住无胜解。若于炽然加行等。心不悟入乃至无胜解。是名第五。于后胜所作。心缚未降伏未永害。此中于身未离贪。未离欲未离亲未离爱未离渴者。谓顾恋身令心被缚不得出离故。说于身未离贪等。便于炽然加行永断寂静证得上义者。云何便于炽然。谓若于身生顾恋者。便于永断精勤勇猛。势用策励不可制伏策心相续。是名炽然。彼于此中不起欲乐。由斯故说便于炽然。云何便于加行。谓若于身生顾恋者。便于永断。若习若修若多所作是名加行。彼于此中不起欲乐。由斯故说便于加行。云何便于永断。谓若于身生顾恋者。便于永断八圣道支是名永断。彼于此中不起欲乐。由斯故说便于永断。云何便于寂静。谓若于身生顾恋者。便于永断住空闲室是名寂静。彼于此中不起欲乐。由斯故说便于寂静。云何便于证得上义。谓若于身生顾恋者。便于永断证得爱尽离灭涅槃。是名证得上义。彼于此中不起欲乐。由斯故说便于证得上义。心不悟入。无净信不安住无胜解者。谓若于身生顾恋者。彼于永断不起。随顺心随顺信。随顺欲随顺心。胜解已胜解当胜解。是故说心不悟入等。是名第一者。渐次顺次相续次第数为第一。于身未离贪等心缚者。谓若于身深生顾恋。彼心被缚甚缚极缚。如被壮人以坚绳索缚已水浇。彼名被缚甚缚极缚。如是于身深生顾恋。彼心被缚甚缚极缚。言未降伏未永害者。谓未断未遍知。于欲未离贪等。心缚广说亦尔。乐与在家出家杂住者。谓常乐与在家出家諠杂。而住于乐同乐。于苦同苦者。谓于乐事同受其乐。于诸苦事同受其苦。同喜同忧者。谓于喜事同生欢喜。于诸忧事同起愁忧。于诸事务皆共兴起。究竟随转不相舍离者。谓于种种所作事业。皆共相助身心无怠。余如前说。于诸正论者。云何正论。谓依出离远离。所生善法发起语论。言说宣唱评议显了。词辩语路语音语业语表。是名正论。言是圣者有二种。圣谓由善故及无漏故。此中言论由善故圣。非由无漏故说是圣言。除遣者。谓此正论。长夜能引少欲喜足。易满易养损减除遣。杜多功德知量清净。故名除遣。能趣向心离盖可乐者。今此义中说心名心。谓此正论令心断盖清净可乐。由斯故说能趣向心离盖可乐。言戒论者谓此正论。能正显了。犯戒过患持戒功德。故名戒论。言定论者。谓此正论能正显了。散动过患正定功德。故名定论。言慧论者。谓此正论能正显了。恶慧过患妙慧功德。故名慧论解脱论者。谓此正论能正显了。邪解脱过患正解脱功德。故名解脱论。解脱智见论者。谓此正论能正显了。邪智过患正智功德。故名解脱智见论。少欲论者。谓此正论能正显了。多欲过患少欲功德。故名少欲论。喜足论者。谓此正论能正显了。不喜足过患喜足功德。故名喜足论。损减论者。谓此正论能正显了。增益生死过患损减生死功德。故名损减论。省事论者。谓此正论能正显了。多事过患省事功德。故名省事论。永断论者。谓此正论能正显了诸结过患断结功德。故名永断论。离染论者。谓此正论能正显了。贪染过患离染功德。故名离染论。寂灭论者。谓此正论能正显了。有身过患灭有身功德。故名寂灭论。随顺缘性缘起论者。谓此正论能正宣说施设建立显了。缘起缘已生法。及彼善忍故名随顺缘性缘起论。彼于宣说如是论时。不恭敬听不属耳听。不住受教心。不行法随法。越大师教于论学处不乐受学者。谓缠所缠于诸正论。不能恭敬属耳听等。便于炽然者。谓缠所缠于诸正论。不能恭敬属耳听等。便于永断精勤勇猛势用。策励不可制伏策心相续是名炽然。彼于此中不起欲乐。由斯故说便于炽然便于加行者。谓缠所缠于诸正论。不能恭敬属耳听等。便于永断若习若修若多所作。是名加行彼于此中不起欲乐。由斯故说便于加行。便于永断者。谓缠所缠于诸正论。不能恭敬属耳听等。便于永断八圣道支。是名永断。彼于此中不起欲乐。由斯故说便于永断。便于寂静者。谓缠所缠于诸正论。不能恭敬属耳听等。便于永断住空闲室。是名寂静。彼于此中不起欲乐。由斯故说便于寂静。便于证得上义者。谓缠所缠于诸正论。不能恭敬属耳听等。便于永断证得爱尽。离灭涅槃。是名证得上义。彼于此中不起欲乐。由斯故说便于证得上义。心不悟入无净信不安住无胜解者。谓缠所缠于诸正论。不能恭敬属耳听等。便于永断不起随顺心。随顺信随顺欲随顺心胜解已胜解当胜解。是故说心不悟入等。是名第四。及心缚言准前应说。少小证得虽有后时所作胜事。而中止息者。云何少小证得。谓如一类唯得戒禁便生喜足。或复乃至唯证少分。死生智通便生喜足。如是等名少小证得。虽有后时所作胜事者。谓彼未能永断烦恼。亦未证得诸烦恼断。由斯故说。虽有后时所作胜事。而中止息者。谓舍善轭精进懈废。由此故名而中止息。便于炽然者。谓于此界。未作劬劳未断诸结。便于永断。精勤勇猛势用策励。不可制伏策心相续。是名炽然。彼于此中不起欲乐。由斯故说便于炽然。便于加行永断寂静证得上义等。皆准前应说。是名第五者。渐次顺次相续次第数为第五。于后胜所作心缚者。谓于此界未作劬劳未断诸结。心便被缚甚缚极缚。如被壮人以坚绳索缚已水浇。彼名被缚甚缚极缚。如是有后胜所作者。彼于此界未作劬劳未断诸结。心便被缚甚缚极缚。言未降伏未永害者。谓未断未遍知

五顺下分结者。云何为五。一欲贪顺下分结。二嗔恚顺下分结。三有身见顺下分结。四戒禁取顺下分结。五疑顺下分结。欲贪顺下分结者。欲贪云何答于诸欲境诸贪等贪。广说乃至。贪类贪生。是名欲贪。顺下分结者。下分谓欲界。上分谓色无色界。由此欲贪未断未遍知故。便往欲界生于欲界结欲界生。故名欲贪顺下分结。嗔恚顺下分结者。嗔恚云何。答于诸有情欲为损害。广说乃至现为过患。是名嗔恚顺下分结。广说如前。有身见顺下分结者。有身见云何。答于五取蕴等。随观见我或我所。从此起忍欲慧观见。是名有身见顺下分结。广说如前。戒禁取顺下分结者。戒禁取云何。答如有一类执取于戒。谓由此戒能得清净解脱出离。超诸苦乐及能证得超苦乐处。复有一类执取于禁。谓由此禁能得清净。解脱出离超诸苦乐。及能证得超苦乐处。或有一类执取戒禁。谓由戒禁能得清净。解脱出离超诸苦乐。及能证得超苦乐处。是名戒禁取顺下分结。广说如前。疑顺下分结者。疑云何。答于佛法僧及苦集灭道生起疑惑。广说乃至非现一趣。是名疑顺下分结者。下分谓欲界。上分谓色无色界。由此疑未断未遍知。故便往欲界生于欲界结欲界生。故名疑顺下分结

五顺上分结者。云何为五。一色贪顺上分结。二无色贪顺上分结。三掉举顺上分结。四慢顺上分结。五无明顺上分结色贪顺上分结者。色贪云何。答于色界系修所断法诸贪等贪。执藏防护耽着贪爱。是名色贪顺上分结者。下分谓欲界。上分谓色无色界。由此色贪未断未遍知。故便往色界生于色界结色界生。故名色贪顺上分结。无色贪顺上分结者。无色贪云何。答于无色界系修所断法。诸贪等贪执藏防护耽着贪爱。是名无色贪。顺上分结者。下分谓欲界。上分谓色无色界。由此无色贪未断未遍知。故便往无色界生于无色界结无色界生。故名无色贪顺上分结。掉举顺上分结者。掉举云何。答于色无色界系修所断法。诸不寂静不极寂静。掉举生性等。掉举生性心躁扰性。是名掉举顺上分结者。下分谓欲界。上分谓色无色界。由此掉举未断未遍知。故便往色无色界。生于色无色界。结色无色界生。故名掉举顺上分结。慢顺上分结者。慢云何。答于色无色界系修所断法。诸慢恃执慢性心高举心轻蔑。是名慢顺上分结。广说如前。无明顺上分结者。无明云何。答于色无色界系修所断法。诸无智愚痴无明黑闇。是名无明顺上分结者。下分谓欲界。上分谓色无色界。由此无明未断未遍知故。便往色无色界。生于色无色界。结色无色界生。故名无明顺上分结

后嗢拖南曰

  后五法十四　　谓不忍及忍
  损减与圆满　　语路无能处
  胜支解脱想　　解脱处根力
  不还及净居　　出离界各五

有五不忍过失。五能忍功德。五损减。五圆满。五语路。五无堪能处。五胜支。五成熟解脱想。五解脱处。五根五力。五不还。五净居天。五出离界

五不忍过失者。云何为五。一者暴恶。二者忧悔。三者众生不爱不乐。四者十方恶名流布。五者身坏命终当堕恶趣地狱。云何暴恶。答诸不能忍补特伽罗不忍因缘。集诸刀杖乐为损害。故名暴恶。云何忧悔。答诸不能忍补特伽罗。不忍因缘行身恶行行语恶行行意恶行。彼行身语意恶行已。多生忧悔。身心热恼。故名忧悔。云何众生不爱不乐。答诸不能忍补特伽罗。不忍因缘若被他骂即还反骂。若被他嗔即还反嗔。若被他打即还反打。若被他害即还反害。若被他弄即还反弄。由此众生不爱不乐。彼由如是反骂等缘故。说众生不爱不乐。云何十方恶名流布。答诸不能忍补特伽罗。不忍因缘常与斗诤。好相言。讼轻弄毁蔑。由此恶名十方流布。彼由如是斗诤等缘。故说十方恶名流布。云何身坏命终当堕恶趣地狱。答诸不能忍补特伽罗。不忍因缘多行增上身恶行语恶行意恶行。彼行增上身语意恶行已。身坏命终当堕恶趣大地狱中受诸剧苦故。说身坏命终当堕恶趣地狱

说一切有部集异门足论卷第十二阿毗达磨集异门足论卷第十三

        尊者舍利子说

        三藏法师玄奘奉　诏译

    五法品第六之三

五能忍功德者。一者不暴恶。二者不忧悔。三者众生爱乐。四者十方善名流布。五者身坏命终当生善趣天上。云何不暴恶。答诸有能忍补特伽罗。能忍因缘不集刀杖不为损害名不暴恶。云何不忧悔。答诸有能忍补特伽罗。能忍因缘行身妙行。行语妙行。行意妙行。彼行身语意妙行已。不生忧悔身心清凉名不忧悔。云何众生爱乐。答诸有能忍补特伽罗。能忍因缘骂不反骂。嗔不反嗔。打不反打。害不反害。弄不反弄。由此众生悉皆爱乐。彼由如是不反骂等缘故。名众生爱乐。云何十方善名流布。答诸有能忍补特伽罗。能忍因缘常无斗诤。不相言讼轻弄毁蔑。由此十方善名流布。彼由如是无斗诤等缘故。说十方善名流布。云何身坏命终当生善趣天上。答诸有能忍补特伽罗。能忍因缘多行增上。身妙行语妙行意妙行。彼行增上身语意妙行已。身坏命终当生善趣天世界中受诸妙乐。故说身坏命终当生善趣天上

五损减者。云何为五。一者亲属损减。二者财富损减。三者无病损减。四者戒损减。五者见损减。亲属损减云何。答若有亲属遭诸灾害。谓由王故贼故火故水故死故。又少亲属亦得名为亲属损减。如是名为亲属损减。问何故名为亲属损减。答以如是法非可爱非可乐非可忍。无救护有违损不可意。是故名为亲属损减。财富损减云何。答若有财富遭诸灾害。谓由王故贼故火故水故怨故。又少财宝亦得名为财富损减。如是名为财富损减。问何故名为财富损减。答以如是法非可爱非可乐非可喜非可意。余如前说。无病损减云何。答若于身中遭如是病。谓头痛等广说如前。又此身中多有疹疾。亦得名为无病损减。如是名为无病损减。问何故名为无病损减。答以如是法非可爱等广说如前。戒损减云何。答害生命。不与取。欲邪行。虚诳语。离间语。粗恶语。杂秽语。又诸所有不善戒。若诸所有非理所引戒。若诸所有障碍定戒。如是一切名戒损减。问何故名为戒损减耶。答以如是法非可爱非可乐非可忍。无救护有违损不可意。以如是法非可爱果。非可乐果。非可喜果。非可意果。非适意果。不悦意果。以如是法。非可爱异熟。非可乐异熟。非可喜异熟。非可意异熟。非适意异熟。不悦意异熟。是故名为戒损减。见损减云何。答诸所有见。无施与无祠祀无爱乐。乃至广说。又诸所有不善见。若诸所有非理所引见。若诸所有障碍定见。如是一切名见损减。问何故名为见损减耶。答以如是法非可爱。广说乃至不悦意异熟。是故名为见损减

五圆满者。云何为五。一者亲属圆满。二者财富圆满。三者无病圆满。四者戒圆满。五者见圆满。亲属圆满云何。答若有亲属无诸灾害。谓非王故贼故火故水故死故。又多亲属亦得名为亲属圆满。如是名为亲属圆满。问何故名为亲属圆满。答以如是法可爱可乐可忍。有救护无违损称可意。是故名为亲属圆满。财富圆满云何。答若有财富无诸灾害谓非王故贼故火故水故怨故。又多财宝亦得名为财富圆满。如是名为财富圆满。问何故名为财富圆满。答以如是法可爱可乐可喜可意。余如前说。无病圆满云何。答若于身中无如是病。谓头痛等广说如前。又此身中无诸疹疾。亦得名为无病圆满。如是名为无病圆满。问何故名为无病圆满。答以如是法是可爱等广说如前。戒圆满云何。答离断生命。离不与取。离欲邪行。离虚诳语。离离间语。离粗恶语。离杂秽语。又诸所有善戒。若诸所有如理所引戒。若诸所有不障碍定戒。如是一切名戒圆满。问何故名为戒圆满耶。答以如是法可爱可乐可忍。有救护无违损称可意。以如是法可爱果。可乐果。可喜果。可意果。适意果。悦意果。以如是法可爱异熟。可乐异熟。可喜异熟。可意异熟。适意异熟。悦意异熟。是故名为戒圆满。见圆满云何。答诸所有见。有施与有祠祀有爱乐。乃至广说。又诸所有善见。若诸所有如理所引见。若诸所有不障碍定见。如是一切名见圆满。问何故名为见圆满耶。答以如是法是可爱。广说乃至悦意异熟。是故名为见圆满

五语路者。云何为五。一者或时语或非时语。二者或实语或不实语。三者或引义利语。或引无义利语。四者或细软语或粗犷语。五者或慈愍语或嗔恚语。或时语或非时语者。问云何非时语。答有二种非时。一者内二者外。内非时云何。答且如举他罪苾刍。或贪缠所缠。或嗔缠所缠。或痴缠所缠。或遭剧苦。或有重病。或复不能与他言论。是为内非时。外非时云何。答且如举他罪苾刍所欲举者。或贪缠所缠或嗔缠所缠或痴缠所缠。或遭剧苦或有重病。或复不能受他言论。或未受具补特伽罗现在前住。是名外非时。此中所有若内非时若外非时。总略为一数为非时。如是时语名非时语。问云何时语。答有二种时。一者内二者外。内时云何。答且如举他罪苾刍。非贪缠所缠非嗔缠所缠。非痴缠所缠。无剧苦无重病。复有堪能与他言论。是名内时。外时云何。答且如举他罪苾刍所欲举者。非贪缠所缠。非嗔缠所缠非痴缠所缠。无剧苦无重病。复有堪能受他言论。无未受具补特伽罗现在前住。是名外时。此中所有内时外时。总略为一数之为时。如是时语名为时语。是故名为或时语或非时语。或实语或不实语者。问云何不实语。答且如苾刍举他苾刍不见不闻。不疑犯戒犯见犯轨则犯净命罪。彼如是语名不实语。问云何实语。答且如苾刍举他苾刍实见实闻实疑。犯戒犯见犯轨则犯净命罪。彼如是语名为实语。是故名为或实语或不实语。或引义利语或引无义利语者。问云何引无义利语。答且如苾刍举他苾刍犯戒犯见犯轨则犯净命罪。然他苾刍于如是罪。已陈首已发露已显示已悔除。实无余言有余。彼如是语名引无义利语。问云何引义语。答且如苾刍举他苾刍犯戒犯见犯轨则犯净命罪。然他苾刍于如是罪。未陈首未发露未显示未悔除。或有余言有余。彼如是语名引义利语。是故名为或引义利语或引无义利语。或细软语或粗犷语者。问云何粗犷语。答且如苾刍于他苾刍。结恨愤发凶暴恶意。作如是言。汝见如是所犯罪。不汝是恶沙门。愚钝沙门无羞耻。沙门难调难伏。汝应陈首如是诸罪。勿有覆藏彼如是语名粗犷语。问云何细软语。答且如苾刍往他苾刍所。作如是言。具寿已犯如是如是罪。应陈首应发露勿覆藏。陈首则安乐不陈首不安乐。彼如是语名细软语。是故名为或细软语或粗犷语。或慈愍语或嗔恚语者。问云何嗔恚语。答且如苾刍于他苾刍。有嗔恚心有损害心。而举犯戒犯见犯轨则犯净命罪。彼如是语名嗔恚语。问云何慈愍语。答且如苾刍于他苾刍。有慈愍心与慈愍具。往至其所举所犯戒犯见犯轨则犯净命罪。彼如是语名慈愍语。是故名为或慈愍语或嗔恚语

五无堪能处者。云何为五。谓阿罗汉苾刍诸漏已尽。无复堪能故思断生命。无复堪不与物盗心取。无复堪行非梵行习淫欲法。无复堪能正知说虚诳语。无复堪能贮积受用诸欲乐具。阿罗汉苾刍诸漏已尽。无复堪能故思断生命者。谓由彼因彼缘。故思断生命阿罗汉苾刍。诸漏已尽故。于彼因缘已永断已遍知。如断树根截多罗顶。令后有趣成不生法故。名阿罗汉苾刍诸漏已尽。无复堪能故思断生命。阿罗汉苾刍诸漏已尽。无复堪能不与物盗心取。行非梵行习淫欲法。正知说虚诳语亦尔。阿罗汉苾刍诸漏已尽。无复堪能贮积受用诸欲乐具者。谓由彼因彼缘贮积受用诸欲乐具。阿罗汉苾刍诸漏已尽故。于彼因缘已永断已遍知。如断树根截多罗顶。令后有趣成不生法故。名阿罗汉苾刍诸漏已尽。无复堪能贮积受用诸欲乐具

五胜支者。云何为五。具寿当知诸圣弟子。于如来所修植净信根生安住。不为沙门或婆罗门或天魔梵或余世间如法引夺。是名第一胜支。复次具寿诸圣弟子。无谄无诳淳直性类。于大师有智同梵行者所。如实自显。是名第二胜支。复次具寿诸圣弟子。少疾无病成等熟腹非极冷热。时节调和无诸苦恼。由斯饮食易正消化。是名第三胜支。复次具寿诸圣弟子。勤精进住有势有勤。有勇坚猛。于诸善法常不舍轭。假使唯余皮筋骨在。身诸血肉皆悉干枯。为得所求殊胜善法。发勤精进有势有勤。有勇坚猛不舍善轭。若求证得精进炽然终无中废。是名第四胜支。复次具寿诸圣弟子。具慧安住成就世间。有出没慧圣慧出慧善通达慧。彼所作慧正尽苦慧。是名第五胜支。于如来所修植净信者。如来云何。答应正等觉说名如来。净信云何。答若依出离远离所生善法诸信。信性随顺性印可性。已爱乐当爱乐现爱乐性。心清净性故名净信。即此净信于如来所。已修植当修植现修植。由斯故说于如来所修植净信。言根生者。谓此净信有二种根。一者无漏智。二者无漏善根。故名根生。言安住者。谓由如是行相根生。即由如是行相安住。若由如是行相安住。即由如是行相根生故名安住。不能引夺者。谓由成就如是净信。一切世间若天若魔若梵若沙门若婆罗门若余众生诸天人类。皆不能引不能夺。不能引夺不能倾。不能等倾不能等极倾。不能摇不能等摇。不能等极。不能动不能等动。不能等极动。是故说为不能引夺。是名第一者。渐次顺次相续次第数为第一。言胜支者。谓由净信增盛。诸善男子或善女人。后后转胜故名胜支。言无谄者。谄云何。答诸心险性若心奸性。若心曲性心杂乱性。心不显了性心不正直性。心不调善性皆名为谄。无如是谄故名无谄。言无诳者诳云何。答伪斗伪秤伪函伪。语于他罔帽极罔帽遍罔帽。罔帽业欺弄迷惑。皆名为诳。无如是诳故名无诳。淳直性类者。谓重显了无谄诳性。是故复说淳直性类。于大师有智同梵行者所。如实自显者。大师云何。答谓诸如来应正等觉说名大师。有智同梵行者云何。答谓舍利子。大采菽氏。大营构氏。大迦叶波。大执藏。大劫庀那。大迦多衍那。大准陀。大善见。大路。大名。无灭欲乐金毗罗等。皆名有智同梵行者。若彼具寿多贪嗔痴有所违犯。便于大师及诸有智同梵行所。如实陈首施设建立分别显了。发露开示无所覆藏。由斯故说于大师有智同梵行者所。如实自显是名第二者。渐次顺次相续。次第数为第二。言胜支者。谓由无谄诳增盛。诸善男子或善女人。后后转胜故名胜支。言少疾者多疾云何。答谓头痛等乃至广说。及余多种逼恼疹疾能生种种不安隐触。住在身中皆名多疾。如是疾无故名少疾。言无病者。重显少疾成等熟腹非极冷热。时节调和无诸苦恼。由斯饮食易正消化者。谓彼成就非极冷热。平等成就生熟二藏。若有成就极冷藏者。诸所饮啖极迟成就。令身沉重无所堪任。不能精勤修胜断行。若有成就极热藏者。诸所饮啖极速成熟。令身羸劣无所堪任。不能精勤修胜断行由彼成就。非极冷热生熟二藏。时节调和无诸苦恼。有所饮啖易正消化。令身强盛有所堪任故。能精勤修胜断行。是名第三者。渐次顺次相续次第数为第三。言胜支者。谓由少疾等增盛。诸善男子或善女人。后后转胜故名胜支。勤精进住者。精进云何。答若于出离远离所生善法。精勤勇猛势用策励。不可制伏策心相续。是名精进。由彼成就如是精进。于所修习能行胜行。进趣证会是故说为勤精进。住言有势者。谓彼上品精进圆满故名有势言。有勤者。谓即显示精进坚固故名有勤。言有勇坚猛者。谓由成就精进力故。勇决而取坚住。而取猛利而取诸有所取。是善非恶随所取相。守护不舍如获他国。善能守护是故说为有勇坚猛。于诸善法常不舍轭者。谓于善法不舍勤勇精进无断。是故说为于诸善法常不舍轭。为得所求殊胜善法。若未证得精进炽然终无中废者。谓若未得阿罗汉果。精进炽然常无懈废。由斯故说为得所求殊胜善法。若未证得精进炽然终无中废。是名第四者。渐次顺次相续次第数为第四。言胜支者。谓由精进增盛。诸善男子或善女人。后后转胜故名胜支。具慧安住者。慧云何。答若依出离远离所生善法。于诸法相能简择极简择。广说乃至毗钵舍那是名为慧。言安住者。谓由成就如是慧故。于诸法相能行胜行进趣证会。由斯故说具慧安住。成就世间有出没慧者。世间谓五取蕴。云何为五。谓色取蕴受想行识取蕴。彼由成就如是慧故。能如实知此五取蕴生及变坏。由斯故说成就世间有出没慧。言圣慧者有二种圣。一者善故圣。二者无漏故圣。此慧具由二种圣故。说名为圣故名圣慧。言出慧者。谓彼成就如是慧故。能出离欲界。及能出离色无色界故名出慧。善通达慧者。谓彼成就如是慧故。于苦集灭道谛。由苦集灭道相能通达。善通达各别通达。是故名为善通达慧。彼所作慧者。谓彼所引学无间道所有胜慧。此中说为彼所作慧。正尽苦慧者。正云何。答因故门故理趣故行相故说名为正。尽苦慧者。五取蕴名为苦。此慧能令五取蕴尽。等尽遍尽证永尽。故名尽苦慧。是名第五者。渐次顺次相续次第数为第五。言胜支者。谓由具慧增盛。诸善男子或善女人。后后转胜故名胜支

五成熟解脱想者。云何为五。一无常想。二无常苦想。三苦无我想。四厌逆食想。五死想。无常想云何。答一切行皆无常。于无常行由无常故。如理思惟诸想等。想现前而想已想当想现。想是名无常想无常。苦想云何。答一切行皆无常由。无常故有是苦者。于诸苦行由苦相故。如理思惟诸想等想现前。而想已想当想现想。是名无常苦想。苦无我想云何。答一切行皆无常。无常故苦。苦故无我。于无我行由无我故。如理思惟诸想等想现前。而想已想当想现想。是名苦无我想。厌逆食想云何。答诸苾刍等应于段食。发起厌逆俱行作意。及起毁呰俱行作意。以不净想思惟段食。其事云何。答于诸糜饭。应起膖胀死尸胜解。于粥羹臛。应起人之稀粪胜解。于生酥乳酪。应起人之髓脑胜解。于熟酥油沙糖及蜜。应起人之肪膏胜解。于糗应起骨屑胜解。于饼应起人皮胜解。于盐应起碎齿胜解。于莲根茎生菜枝叶。应起连发髑髅胜解。于诸浆饮。应起人之脓血胜解。彼于段食发起如是厌逆毁呰俱行作意。以不净相思惟段食。诸想等想现前。而想已想当想现想。是名厌逆食想。死想云何。答于自身命极善作意。思惟无常诸想等想现前。而想已想当想现想。是名死想。如是五种名成熟解脱想。问何缘此五名成熟解脱想耶。答解脱有三种一心解脱。二慧解脱。三无为解脱。由此五想有为解脱。未生令生。生已增长坚固广大。由斯速证无为解脱。由此因缘名成熟解脱想

五解脱处者云何为五。具寿当知若诸苾刍苾刍尼等。或有大师为说法要。或有随一尊重有智同梵行者为说法要如如大师。或有随一尊重有智同梵行者为说法要。如是如是于彼法要能正了知。若法若义由正了知。若法若义便发起欣。欣故生喜。心喜故身轻安。身轻安故受乐。受乐故心定。心定故如实知见。如实知见故生厌。厌故能离。离故得解脱。是名第一解脱处。是诸苾刍苾刍尼等。安住此处念未住者能住正念。心未定者能住正定。漏未尽者能尽诸漏。未得无上安隐涅槃者。疾能证得。复次具寿若诸苾刍苾刍尼等。虽无大师或余随一尊重有智同梵行者。为说法要而能以大音声读诵。随曾所闻究竟法要。如如以大音声读诵。随曾所闻究竟法要。如是如是于彼法要能正了知。若法若义由正了知。若法若义便发起欣。欣故生喜。心喜故身轻安。身轻安故受乐。受乐故心定。心定故如实知见。如实知见故生厌。厌故能离。离故得解脱。是名第二解脱处。是诸苾刍苾刍尼等。安住此处念未住者能住正念。心未定者能住正定。漏未尽者能尽诸漏。未得无上安隐涅槃者疾能证得。复次具寿若诸苾刍苾刍尼等。虽无大师。或余随一尊重有智同梵行者。为说法要亦不以大音声读诵。随曾所闻究竟法要。而能为他广说开示。随曾所闻究竟法要。如如为他广说开示。随曾所闻究竟法要。如是如是于彼法要能正了知。若法若义由正了知。若法若义便发起欣。欣故生喜。心喜故身轻安。身轻安故受乐。受乐故心定。心定故如实知见。如实知见故生厌。厌故能离。离故得解脱。是名第三解脱处。是诸苾刍苾刍尼等。安住此处念未住者能住正念。心未定者能住正定。漏未尽者能尽诸漏。未得无上安隐涅槃者疾能证得。复次具寿若诸苾刍苾刍尼等。虽无大师。或余随一尊重有智同梵行者。为说法要亦不以大音声读诵。随曾所闻究竟法要。亦不为他广说开示。随曾所闻究竟法要。而能独处寂静思惟筹量观察。随曾所闻究竟法要。所有义趣如如独处。寂静思惟筹量观察。随曾所闻究竟法要。所有处趣如是如是。于彼法要能正了知。若法若义由正了知。若法若义便发起欣。欣故生喜。心喜故身轻安。身轻安故受乐。受乐故心定。心定故如实知见。如实知见故生厌。厌故能离。离故得解脱。是名第四解脱处。是诸苾刍苾刍尼等。安住此处念未住者能住正念。心未定者能住正定。漏未尽者能尽诸漏未得无上安隐涅槃者疾能证得

说一切有部集异门足论卷第十三阿毗达磨集异门足论卷第十四

        尊者舍利子说

        三藏法师玄奘奉　诏译

    五法品第六之四

复次具寿若诸苾刍苾刍尼等。虽无大师。或余随一尊重有智同梵行者。为说法要亦不以大音声读诵。随曾所闻究竟法要。亦不为他广说开示。随曾所闻究竟法要。亦不独处寂静思惟筹量观察。随曾所闻究竟法要。所有义趣而能善取随一定相。于彼定相能善思惟。又善了知复善通达。如如善取随一定相。于彼定相能善思惟。又善了知复善通达。如是如是于彼法要能正了知。若法若义由正了知。若法若义便发起欣。欣故心喜。生喜故身轻安。身轻安故受乐。受乐故心定。心定故如实知见。如实知见故生厌。厌故能离。离故得解脱。是名第五解脱处。是诸苾刍苾刍尼等。安住此处念未住者能住正念。心未定者能住正定。漏未尽者能尽诸漏。未得最上安隐涅槃者疾能证得。此中大师或有随一尊重有智同梵行者。为说法要者。问大师云何。答即诸如来应正等觉说名大师。问尊重有智同梵行者云何。答解憍陈那马胜贤胜雾气大名那舍圆满无垢妙臂牛主舍利子大采菽氏大迦叶波大劫庀那大营构氏大迦多衍那大执藏大善见大路随顺无灭欲乐金毗罗等。皆名尊重有智同梵行者。问法云何。答名身句身文身是名为法。即前大师尊重有智同梵行者。以诸名身句身文身。为彼宣说施设建立。开显分别明了开示。由此故言为说法要。如如大师或有随一尊重有智同梵行者。为说法要如是如是。彼于法要能正了知。若法若义者问能正了知。若法云何。答名身句身文身是名为法。彼于此法等了近了明了。通达品类差别。获得无二无退转智故。名能正了知若法。问能正了知若义云何。答名身句身文身。所显所了所说所遍说。所示所等示。所开名义彼于此义。等了近了明了通达品类差别。获得无二无退转智。是名能正了知。若义由正了知若法若义便发起欣者。最初所发喜名为欣。彼于此欣起等起。生等生。转现转。聚集出现。由斯故说便发起欣。欣故生喜者。谓上品欣转名为喜。彼于此喜。起等起。生等生。转现转。聚集出现。由斯故说欣故生喜。心喜故身轻安者。谓彼从欣生心喜故。于现法中身重性断。心重性断。身有堪能。心有堪能身细滑。心细滑。身轻软心轻。软身离盖。心离盖。身无懒惰心无懒惰。身无疲倦心无疲倦。由斯故说心喜故身轻安。身轻安故受乐者。谓由身有堪能心有堪能。广说乃至身无疲倦心无疲惓故。身便有乐心受妙喜。由斯故说身轻安故受乐。受乐故心定者。谓受乐故远离劳倦。无劳倦法平等行故。心住等住近住一趣得三摩地。由斯故说受乐故心定。心定故如实知见者。谓彼若时心住等住无二无转。尔时于苦如实知见苦。于集灭道如实知见集灭道。由斯故说心定故如实知见。如实知见故生厌者。谓彼若时于苦如实知见苦。于集灭道如实知见集灭道。尔时于五取蕴便生厌毁违逆而住。由斯故说如实知见故生厌。厌故能离者。谓彼若时于五取蕴能生厌毁违逆而住。尔时便于贪嗔痴三不善根。能损能薄令渐缺减。如人以水浸渍黄衣置日光中染色速脱。如是若时于五取蕴。能生厌毁违逆而住。尔时便于三不善根能损能薄令渐缺减。由斯故说厌故能离。离故得解脱者。谓彼若时能损能薄能渐缺减三不善根。尔时便于贪嗔痴等心得解脱。由斯故说离故得解脱。是名第一者。渐次顺次相续次第数为第一。解脱处者。此中何谓解脱处耶。答此中七法名解脱处。一者正了知法。二者正了知义。三者欣。四者喜。五者轻安。六者乐。七者定。是诸苾刍苾刍尼等者。谓若能引学无间道。于此义中说为苾刍苾刍尼等。安住此处者。谓住此处等住近住。是故说为安住此处。念未住者能住正念者。谓能住四念住。心未定者能住正定者。谓能住四静虑。漏未尽者能尽诸漏者。问诸漏云何。答有三漏。谓欲漏有漏无明漏。彼于此三漏能尽等尽遍尽现尽当尽速尽。由斯故说漏未尽者能尽诸漏。未得无上安隐涅槃者能疾证得者。谓诸爱尽离灭涅槃。说为无上安隐涅槃。彼速于此能得随得能触能证。由斯故说未得无上安隐涅槃者。能疾证得而能以大音声读诵随曾所闻究竟法要者。谓以广大音声读诵。如先所闻究竟法要。而能为他广说开示。随曾所闻究竟法要者。谓彼而能为他宣说施设建立。开显分别明了显示。如先所闻究竟法要而能独处。寂静思惟筹量观察。随曾所闻究竟法要所有义趣者。谓能独处寂静。寻思遍寻思。简择遍简择观察遍观察。如先所闻究竟法要所有义趣。而能善取随一定相。于彼定相能善思惟。又善了知复善通达者。谓能善取定及定相。于彼定相能善思惟。又善了知复善通达入住出相。余如前说。五根者

云何为五。一信根。二精进根。三念根。四定根。五慧根。此五根相。如前广说。五力者。云何为五。一信力。二精进力。三念力。四定力。五慧力。问信力云何。答于如来所修植净信根生安住。不为沙门或婆罗门或天魔梵或余世间如法引夺。是名信力。问精进力云何。答于己生不善法为永断故。生欲策励。乃至广说四种正断是名精进力。问念力云何。答于内身住循身观。乃至广说四种念住是名念力。问定力云何。答离欲恶不善法。乃至广说四种静虑是名定力。问慧力云何。答如实了知。此是苦圣谛。此是苦集圣谛。此是苦灭圣谛。此是趣苦灭行圣谛。是名慧力。问何故名力。答因如是力。依如是力。住如是力。一切结缚随眠随烦恼缠。皆可断截摧伏破坏故名为力

五不还者云何为五。一者中般涅槃补特伽罗。二者生般涅槃补特伽罗。三者有行般涅槃补特伽罗。四者无行般涅槃补特伽罗。五者上流补特伽罗。云何中般涅槃补特伽罗。答诸有补特伽罗。即于现法已断五顺下分结。未断五顺上分结。造作增长。起异熟业。非生异熟业。身坏命终彼色界天中有起已。便得如是无漏道力。进断余结而般涅槃。是名中般涅槃补特伽罗。问何故名中般涅槃补特伽罗。答由此补特伽罗。根极猛利结极微薄。已超欲界未至色界。于其中间便得如是无漏道力。进断余结而般涅槃故。名中般涅槃补特伽罗。云何生般涅槃补特伽罗。答诸有补特伽罗。即于现法五顺下分结。已断已遍知。五顺上分结未断未遍知。造作增长起异熟业及生异熟业。身坏命终彼生色界天中有起。已往生色界生已不久。便得如是无漏道力。进断余结而般涅槃。是名生般涅槃补特伽罗。问何故名生般涅槃补特伽罗。答由此补特伽罗。才生未久便得如是无漏道力。进断余结而般涅槃故。名生般涅槃补特伽罗。复次有说如是补特伽罗。才生未久便得如是无漏道力。进断余结此后乃至尽寿而住。方入无余般涅槃界故。名生般涅槃补特伽罗。云何有行般涅槃补特伽罗。答诸有补特伽罗。即于现法五顺下分结。已断已遍知。五顺上分结未断未遍知。造作增长起异熟业。及生异熟业。身坏命终彼色界天中有起已。往生色界生已后时。依有行道以有勤行有勤作意。修不息加行道。进断余结而般涅槃。是名有行般涅槃补特伽罗。问何故名有行般涅槃补特伽罗。答由此补特伽罗。依有行道以有勤行有勤作意。修不息加行道。进断余结而般涅槃故。名有行般涅槃补特伽罗。复次有说。由此补特伽罗。依有为缘定。进断余结而般涅槃故。名有行般涅槃补特伽罗。云何无行般涅槃补特伽罗。答诸有补特伽罗。即于现法五顺下分结。已断已遍知。五顺上分结未断未遍知。造作增长起异熟业及生异熟业。身坏命终彼色界天中有起已。往生色界生已后时依无行道。以无勤行无勤作意。修止息加行道进断余结。入无余依般涅槃界。是名无行般涅槃补特伽罗。问何故名无行涅槃补特伽罗。答由此补特伽罗。依无行道以无勤行无勤作意。修止息加行道。进断余结而般涅槃故。名无行般涅槃补特伽罗。复次有说。由此补特伽罗。依无为缘定。进断余结入无余依般涅槃界故。名无行般涅槃补特伽罗。云何上流补特伽罗。答诸有补特伽罗。即于现法五顺下分结已断已遍知。五顺上分结未断未遍知。乃至现入杂修世俗第四静虑。将命终时退三静虑。住初静虑临命终时。造作增长。起异熟业及生异熟业。身坏命终彼色界天中有起已。往生色界梵众天中。生已后时现入世俗第二静虑。临命终时造作增长。起异熟业及生异熟业。身坏命终彼色界天中有起已。往生色界光音天中。生已后时现入世俗第三静虑。临命终时造作增长。起异熟业及生异熟业。身坏命终彼色界天中有起已。往生色界遍净天中。生已后时现入世俗第四静虑。临命终时造作增长。起异熟业及生异熟业。身坏命终彼色界天中有起已。往生色界广果天中。生已后时现入下品杂修世俗第四静虑。临命终时造作增长。起异熟业及生异熟业。身坏命终彼色界天中有起已。往生色界无烦天中。生已后时现入中品杂修世俗第四静虑。临命终时造作增长。起异熟业及生异熟业。身坏命终彼色界天中有起已。往生色界无热天中。生已后时现入上品杂修世俗第四静虑。临命终时造作增长。起异熟业及生异熟业。身坏命终彼色界天中有起已。往生色界善现天中。生已后时入上胜品杂修世俗第四静虑。临命终时造作增长。起异熟业及生异熟业。身坏命终彼色界天中有起已。往生色界善见天中。生已后时入上上品最极圆满杂修世俗第四静虑。临命终时造作增长。起异熟业及生异熟业。身坏命终彼色界天中有起已。往生色界色究竟天。生已后时方得如是无漏道力。进断余结入无余依般涅槃界。是名上流补特伽罗。问何故名上流补特伽罗。答有二种流。谓生死业及彼烦恼。彼于此二俱未断未遍知。彼由此因及此缘故。上行随行上流随流故。名上流补特伽罗。复次有作是言。说由此不还补特伽罗。渐次胜进于后后定。能领随领能受随受。永无退转故名上流。复次上流略有二种。何谓为二。一者行色界。二者行无色界。行色界者。以色究竟天为最极处。行无色界者。以非想非非想处天。为最极处

五净居天者。云何为五。答一无烦天。二无热天。三善现天。四善见天。五色究竟天。云何无烦天。答谓此与彼诸无烦天。是一类为伴侣共众同分。依得事得处得皆同。又若生在无烦天中。所有无覆无记色受想行识蕴。是名无烦天。复次以无烦天。于苦见苦于集见集于灭见灭于道见道故。名无烦天。复次以无烦天。身无烦扰心无烦扰。由彼身心无烦扰故。领受寂静遍净无漏微妙诸受故。名无烦天。复次此是彼名异语增语诸想等想。施设言说谓无烦天故。名无烦天。云何无热天。答谓此与彼诸无热天。同一类为伴侣共众同分。依得事得处得皆同。又若生在无热天中。所有无覆无记色受想行识蕴。是名无热天。复次以无热天。于苦见苦于集见集于灭见灭于道见道故。名无热天。复次以无热天。身无热恼心无热恼。由彼身心无热恼故。领受寂静遍净无漏微妙诸受故。名无热天。复次此是彼名异语增语诸想等想。施设言说谓无热天故。名无热天。云何善现天。答谓此与彼诸善现天同一类。为伴侣共众同分依得事得处得皆同。又彼生在善现天中。所有无覆无记色受想行识蕴。是名善现天。复次以善现天。于苦见苦于集见集于灭见灭于道见道故。名善现天。复次以善现天形色微妙。众所乐观清净端严。超过无烦无热天众故。名善现天。复次此是彼名异语增语诸想等想。施设言说谓善现天故。名善现天。云何善见天。答谓此与彼诸善见天同一类。为伴侣共众同分依得事得处得皆同。又彼生在善见天中。所有无覆无记。色受想行识蕴。是名善见天。复次以善见天。于苦见苦于集见集于灭见灭于道见道故。名善见天。复次以善见天形色转微妙。众所转乐观转清净端严。超过无烦无热善现天众故。名善见天。复次此是彼名异语增语诸想等想。施设言说谓善见天故。名善见天。云何色界究竟天。答谓此与彼诸色究竟天同一类。为伴侣共众同分依得事得处得皆同。又复生在色究竟天中。所有无覆无记。色受想行识蕴。是名色究竟天。复次以色究竟天。于苦见苦于集见集于灭见灭于道见道故。名色究竟天。复次以色究竟天所得自体。于生色趣最胜第一故。名色究竟天。复次此天亦名碍究竟天。碍谓碍身。此是碍身最究竟处故。名碍究竟天。复次此是彼名异语增语诸想等想。施设言说谓色究竟天。或谓碍究竟天故。名色究竟天。或名碍究竟天

五出离界者。云何为五。具寿当知。诸有多闻圣弟子众具猛利见。若念诸欲便于诸欲心不趣入不信乐。不安住无胜解。卷缩不伸弃舍而住。厌恶毁呰制伏违逆。如烧筋羽卷缩不伸。如是多闻圣弟子众具猛利见。若念诸欲便于诸欲心不趣入乃至广说。若念出离。便于出离深心趣入信乐安住。有胜解不卷缩恒舒泰。心不厌毁任运现行。其心安乐易善修习。于诸欲缘所起诸漏。损害热恼皆得解脱。从彼起已离系解脱。不受彼因彼缘诸受。如是名为于欲出离。于恚无恚于害无害于色无色。应知亦尔。具寿当知诸有多闻圣弟子众具猛利见若念有身。便于有身心不趣入不信乐。不安住无胜解。卷缩不伸弃舍而住。厌恶毁呰制伏违逆。如烧筋羽卷缩不伸。如是多闻圣弟子众具猛利见。若念有身。便于有身心不趣入乃至广说。若念有身灭涅槃。便于有身灭涅槃。深心趣入信乐安住。有胜解不卷缩恒舒泰。心不厌毁任运现行。其心安乐易善修习。于有身缘所起诸漏。损害热恼皆得解脱。从彼起已离系解脱。不受彼因彼缘诸受。如是名为有身出离。此中诸有者。谓如是名如是姓如是类如是食。如是受苦乐如是长寿。如是寿边际故名诸有。多闻者。谓闻多正法。多正法者谓契经。应诵。记别。讽颂。自说。因缘。譬喻。本事。本生。方广。希法。论议。闻此诸法故名多闻。圣弟子者圣谓诸佛。佛之弟子名圣弟子。诸能归依佛法僧者。一切皆得圣弟子名故。名圣弟子具猛利见者。云何猛利。答上品圆满故名猛利。云何为见。答若依出离远离所生善法。于法简择极简择。广说乃至毗钵舍那故名为见。若念诸欲者。云何名诸欲。答欲亦名诸欲。欲界亦名诸欲。五妙欲境亦名诸欲。今此义中意说五妙欲境名诸欲。由此故名若念诸欲。便于诸欲心不趣入不信乐不安住无胜解者。谓圣弟子于妙欲境。以称赞俱行作意审思惟时。不起随顺心随顺信随顺欲随顺心。胜解已胜解当胜解。由此故名便于诸欲心不趣入不信乐不安住无胜解卷缩不伸者。谓圣弟子于诸妙欲。以称赞俱行作意审思惟时。心不乐住不随顺。不趣向不临入故名卷缩。不伸弃舍而住厌恶毁呰制伏违逆者。谓圣弟子于诸妙欲。以称赞俱行作意审思惟时。于诸妙欲弃舍而住。厌恶毁呰制伏违逆故。名弃舍而住厌恶毁呰制伏违逆。若念出离者。云何出离。答出离亦名出离。出离界亦名出离。色界善根亦名出离。初静虑亦名出离。今此义中意说初静虑名出离。由此故名若念出离。便于出离深心趣入。信乐安住有胜解者。谓圣弟子于此出离。以胜解俱行作意审思惟时。便生随顺心随顺信随顺欲随顺心。胜解已胜解当胜解。由此故名便于出离深心趣入信乐安住。有胜解不卷缩恒舒泰者。谓圣弟子于此出离。以称赞俱行作意审思惟时。心乐安住顺趣临入故名不卷缩恒舒泰。心不厌毁任运现行者。谓圣弟子于此出离。以称赞俱行作意审思惟时。非如于欲心不乐住。厌恶毁呰制伏违逆。由此故言心不厌毁任运现行。其心安乐者。谓圣弟子当于尔时。其心安乐无劳无损成无倦法。由此故言其心安乐。易修习者。谓圣弟子当于尔时。数数修习数数作意。相应修习故名易修习。善修习者。谓圣弟子当于尔时。因故门故理故行故。殷重修习。坚住修习。恭敬修习。作意修习故。名善修习。于诸欲缘所起诸漏。损害热恼皆得解脱。从彼起已离系解脱者。谓圣弟子由此因缘。于诸欲中心得解脱。从彼起已离系解脱。由斯故说于诸欲缘所起诸漏。损害热恼皆得解脱。从彼起已离系解脱。不受彼因彼缘诸受者。谓于诸欲若未断未遍知便受苦受。若已断已遍知不受苦受。由斯故说不受彼因彼缘诸受。如是名为于欲出离者。问今于此中何谓出离。答永断诸欲亦名出离。超过诸欲亦名出离。舍离尘俗亦名出离。色界善根亦名出离。初静虑亦名出离。今此义中意说初静虑名出离。于恚无恚者。问恚云何。答恚亦名恚。恚界亦名恚。今此义中意说恚界名恚。问无恚云何。答无恚亦名无恚。无恚界亦名无恚。慈心定亦名无恚。今此义意说慈心定名无恚。于害无害者。问害云何。答害亦名害。害界亦名害。今此义中意说害界名害。问无害云何。答无害亦名无害。无害界亦名无害。悲心定亦名无害。今此义中意说悲心定名无害。于色无色者。问色云何。答色亦名色。色界亦名色。四静虑亦名色。今此义中意说四静虑名色。问无色云何。答无色亦名无色。无色界亦名无色。四无色亦名无色。今此义中意说四无色名无色。诸有多闻圣弟子众具猛利见者如前说。若念有身者。有身亦名有身。五取蕴亦名有身。今此义中意说五取蕴名有身。便于有身心不趣入等如前欲说。若念有身灭者。有身灭亦名灭。择灭亦名灭。今此义中意说择灭名灭非余

说一切有部集异门足论卷第十四此卷宋本第八幅第八九行云彼色界天中有起(之下便云)坏命终彼色界天(乃至)第九幅原五行补特伽罗复(之下便云)已往生色界(乃至)第十一幅第七行生异熟业身(之下便云)次有作是言说(等)如是三节文断义绝不相连续今捡二本则宋本错将生异熟业身(之下)坏命终彼色界天(乃至)补特伽罗复(等)凡三十四行之文进而写之于彼色界天中有起(之下)却将中有起(之下)已往生色界(乃)生异熟业身(等)三十四行之文退而写之于补特伽罗复(之下)致令如是今依二本进退而正之第十二幅原六行善现天中所有无(之下)国本宋本并脱覆无记(乃至)便于诸欲心(等)凡三十五行之文今依丹本足之阿毗达磨集异门足论卷第十五

        尊者舍利子说

        三藏法师玄奘奉　诏译

    六法品第七之一

时舍利子复告众言。具寿当知。佛于六法自善通达现等觉已。为诸弟子宣说开示。我等今应和合结集。佛灭度后勿有乖诤。当令随顺梵行法律。久住利乐无量有情。哀愍世间诸天人众。令获殊胜义利安乐。六法云何。此中有二嗢柁南颂。初嗢柁南曰

  初六法十种　　谓内外识触
  及受想思爱　　退不退各六

有六内处。六外处。六识身。六触身。六受身。六想身。六思身。六爱身。六顺退法。六顺不退法。六内处者云何为六。答一眼内处。二耳内处。三鼻内处。四舌内处。五身内处。六意内处。云何眼内处。答若眼于色。或已见或今见或当见。或彼同分是名眼内处。耳鼻舌身意内处。随所应当广说

六外处者云何为六。答一色外处。二声外处。三香外处。四味外处。五触外处。六法外处。云何色外处。答若色为眼。或已见或今见或当见。或彼同分。是名色外处。声香味触法外处。随所应当广说

六识身者云何为六。答一眼识身。二耳识身。三鼻识身。四舌识身。五身识身。六意识身。云何眼识身。答眼及诸色为缘生眼识。此中眼为增上色为所缘。于眼所识色。诸了别性。极了别性。了别色性。是名眼识身。耳鼻舌身意识身。随所应当广说

六触身者云何为六。答一眼触身。二耳触身。三鼻触身。四舌触身。五身触身。六意触身。云何眼触身。答眼及诸色为缘生眼识。三和合故触。此中眼为增上色为所缘。于眼所识色。诸触等触等触性。已触当触。是名眼触身。耳鼻舌身意触身。随所应当广说

六受身者云何为六。答一眼触所生受身。二耳触所生受身。三者鼻触所生受身。四舌触所生受身。五身触所生受身。六意触所生受身。云何眼触所生受身。答眼及诸色为缘生眼识。三和合故触。触为缘故受。此中眼为增上色为所缘。眼触为因眼触等起。眼触种类眼触所生。眼触所起作意相应。于眼所识色诸受等受。别受已受当受。是名眼触所生受身。耳鼻舌身意触所生受身。随所应当广说。六想身者云何为六。答一眼触所生想身。二耳触所生想身。三鼻触所生想身。四舌触所生想身。五身触所生想身。六意触所生想身。云何眼触所生想身。答眼及诸色为缘生眼识。三和合故触。触为缘故想。此中眼为增上色为所缘。眼触为因眼触等起。眼触种类眼触所生。眼触所起作意相应。于眼所识色诸想等想。现前等想已想当想。是名眼触所生想身。耳鼻舌身意触所生想身。随所应当广说

六思身者云何为六。答一眼触所生思身。二耳触所生思身。三鼻触所生思身。四舌触所生思身。五身触所生思身。六意触所生思身。云何眼触所生思身。答眼及诸色为缘生眼识。三和合故触。触为缘故思。此中眼为增上色为所缘。眼触为因眼触等起。眼触种类眼触所生眼触所起作意相应。于眼所识色。诸思等思。现前等思已思当思。作心意业。是名眼触所生思身。耳鼻舌身意触所生思身。随所应当广说

六爱身者云何为六。答一眼触所生爱身。二耳触所生爱身。三鼻触所生爱身。四舌触所生爱身。五身触所生爱身。六意触所生爱身。云何眼触所生爱身。答眼及诸色为缘生眼识。三和合故触。触为缘故受。受为缘故爱。此中眼为增上色为所缘。于眼所识色诸贪等贪。执藏防护耽着爱乐。是名眼触所生爱身。耳鼻舌身意触所生爱身。随所应当广说

六顺退法者云何为六。答一于佛不恭敬住。二于法不恭敬住。三于僧不恭敬住。四于学不恭敬住。五具恶言。六遇恶友。于佛不恭敬住者。云何于佛不恭敬性。答于佛世尊诸不恭敬性。不等恭敬性。不与自在性。不等与自在性。是名于佛不恭敬性。于法于僧于学亦尔。具恶言者。云何恶言性。答如前恶语说。遇恶友者云何恶友性。答如前恶友说

六顺不退法者云何为六。答一于佛有恭敬住。二于法有恭敬住。三于僧有恭敬住。四于学有恭敬住。五具善言。六遇善友。于佛有恭敬住者。云何于佛有恭敬性。答于佛世尊诸恭敬性。有恭敬性。有与自在性。有怖随自在转性。是名于佛有恭敬性。于法于僧于学亦尔。具善言者云何善言性。答如前善语说。遇善友者云何善友性。答善友谓佛及佛弟子。广说乃至行远离痴调伏痴行。是名善友性。若于如是善友。诸习近等习近。亲近等亲近。恭敬承事。是名遇善友。后嗢柁南曰

  后六有十四　　谓喜忧舍恒
  界出根喜通　　明念上观类

有六喜近行。六忧近行。六舍近行。六恒住。六界。六出离界。六诤根法。六可喜法。六通。六顺明分想。六随念。六无上法。六观待。六生类

六喜近行者。云何为六。答一眼见色已顺喜处色近行。二耳闻声已顺喜处声近行。三鼻嗅香已顺喜处香近行。四舌尝味已顺喜处味近行。五身觉触已顺喜处触近行。六意了法已顺喜处法近行。眼见色已顺喜处色近行者。谓眼见色已。于一向可爱一向可乐一向可欣一向可意色。以顺喜处作意思惟。若于此色由顺喜处作意思惟。所生喜受。是名眼见色已顺喜处色近行。耳鼻舌身意喜近行亦尔

六忧近行者。云何为六。答一眼见色已顺忧处色近行。二耳闻声已顺忧处声近行。三鼻嗅香已顺忧处香近行。四舌尝味已顺忧处味近行。五身觉触已顺忧处触近行。六意了法已顺忧处法近行。眼见色已顺忧处色近行者。谓眼见色已。于一向不可爱一向不可乐一向不可欣一向不可意色。以顺忧处作意思惟。若于此色由顺忧处作意思惟。所生忧受。是名眼见色已顺忧处色近行。耳鼻舌身意忧近行亦尔

六舍近行者。云何为六。答一眼见色已顺舍处色近行。二耳闻声已顺舍处声近行。三鼻嗅香已顺舍处香近行。四舌尝味已顺舍处味近行。五身觉触已顺舍处触近行。六意了法已顺舍处法近行。眼见色已顺舍处色近行者。谓眼见色已。于非可爱非不可爱。非可乐非不可乐。非可欣非不可欣。非可意非不可意色。以顺舍处作意思惟。若于此色由顺舍处。作意思惟所生舍受。是名眼见色已顺舍处色近行。耳鼻舌身意舍近行亦尔

六恒住者。云何为六。答一眼见色已不喜不忧。具念正知恒安住舍。二耳闻声已不喜不忧。具念正知恒安住舍。三鼻嗅香已不喜不忧。具念正知恒安住舍。四舌尝味已不喜不忧。具念正知恒安住舍。五身觉触已不喜不忧。具念正知恒安住舍。六意了法已不喜不忧。具念正知恒安住舍。眼见色已不喜不忧。具念正知恒安住舍者。谓眼见色于可爱不可爱。可乐不可乐。可欣不可欣。可意不可意。或所依止。或等无间。或所缘。或处所。或增上色。以顺舍处作意思惟。若于此色由顺舍处作意思惟。所生妙舍。是名眼见色已不喜不忧具念正知恒安住舍。耳鼻舌身意恒住亦尔。问此中舍者何所谓耶。答心平等性。心正直性。心无惊觉任运住性。应知此中说名为舍。复次有说。六识相应缘色声香味触法境。舍受名舍。今此义中应知意说。心平等性。心正直性。心无惊觉任运住性。行舍名舍。六界者云何为六。答一地界。二水界。三火界。四风界。五空界。六识界。分别此六如法蕴论。六出离界者。云何为六。答一有具寿作如是言。我于慈心定。虽已习已修已多所作。而我心犹为嗔所缠缚。应告彼曰。勿作是言。所以者何。若有具寿。于慈心定。已习已修。已多所作。无处无容。其心犹为嗔所缠缚。若心犹为嗔所缠缚。无有是处。谓慈心定必能出离一切嗔缚。问此中出离何所谓耶。答嗔缚永断亦名出离。超越嗔缚亦名出离。诸慈心定亦名出离。今此义中意说慈心定名出离。二有具寿作如是言。我于悲心定。虽已习已修已多所作。而我心犹为害所缠缚。应告彼曰勿作是言。所以者何。若有具寿。于悲心定。已习已修。已多所作。无处无容。其心犹为害所缠缚。若心犹为害所缠缚。无有是处。谓悲心定必能出离一切害缚。问此中出离何所谓耶。答害缚永断亦名出离。超越害缚亦名出离。诸悲心定亦名出离。今此义中意说悲心定名出离。三有具寿作如是言。我于喜心定。虽已习已修已多所作。而我心犹为不乐缠缚。应告彼曰勿作是言。所以者何。若有具寿。于喜心定。已习已修。已多所作。无处无容。其心犹为不乐缠缚。若心犹为不乐缠缚。无有是处。谓喜心定必能出离一切不乐。问此中出离何所谓耶。答不乐永断亦名出离。超越不乐亦名出离。诸喜心定亦名出离。今此义中意说喜心定名出离。四有具寿作如是言。我于舍心定虽已习已修已多所作。而我心犹为欲贪嗔缠缚。应告彼曰勿作是言。所以者何。若有具寿。于舍心定。已习已修。已多所作。无处无容。其心犹为欲贪嗔缠缚。若心犹为欲贪嗔缠缚。无有是处。谓舍心定必能出离一切欲贪嗔。问此中出离何所谓耶。答欲贪嗔永断亦名出离。超越欲贪嗔亦名出离。诸舍心定亦名出离。今此义中意说舍心定名出离。五有具寿作如是言。我于无相心定。虽已习已修已多所作。而我心犹为随相识缠缚。应告彼曰勿作是言。所以者何。若有具寿。于无相心定。已习已修。已多所作。无处无容。其心犹为随相识缠缚。若心犹为随相识缠缚。无有是处。谓无相心定必能出离一切随相识。问此中出离何所谓耶。答随相识永断亦名出离。超越随相识亦名出离。无相心定亦名出离。今此义中意说无相心定名出离。六有具寿作如是言。我虽远离我慢不观见我我所。而我心犹为疑犹豫箭缠缚损害。应告彼曰勿作是言。所以者何。若有具寿。远离我慢不观见我我所。无处无容。其心犹为疑犹豫箭缠缚损害。若心犹为疑犹豫箭缠缚损害。无有是处。谓远离我慢不观见我我所者。必能出离一切疑犹豫箭。问此中出离何所谓耶。答我慢永断亦名出离。超越我慢亦名出离。今此义中意说。超越诸慢名出离

六诤根法者。云何为六。答谓有一类有忿有恨。若有忿恨。便于大师。不能恭敬供养尊重赞叹。若于大师不能恭敬供养尊重赞叹。即不见法。若不见法即不顾沙门。若不顾沙门便起染着。轻弄斗诤由起染着。轻弄斗诤为所依止。令多众生无义无利受诸苦恼。由此能引无量天人。无义无利诸苦恼事。如是诤根汝等若见。或内或外有所未断。即应聚集和合精勤。方便求断无得放逸。汝等应使如是诤根无余断灭。如先未起如是诤根。汝等若见或内或外皆悉已断。即应发起正念正知。猛利之心精勤防护。令当来世永不复起。是为正断。善断诤根如有忿恨。若有覆恼若有嫉悭。若有诳谄若有邪见倒见广说亦尔。复有一类取着自见。起坚固执难教弃舍。若取着自见起坚固执难教弃舍。便于大师不能恭敬供养尊重赞叹。若于大师不能恭敬供养尊重赞叹。即不见法。若不见法即不顾沙门。若不顾沙门便起染着轻弄斗诤。由起染着轻弄斗诤为所依止。令多众生无义无利受诸苦恼由此能引无量天人无义无利诸苦恼事。如是诤根汝等若见或内或外。有所未断。即应聚集和合精勤。方便求断无得放逸。汝等应使如是诤根无余断灭。如先未起如是诤根。汝等若见或内或外皆悉已断。即应发起正念正知猛利之心。精勤防护令当来世永不复起。是为正断善断诤根。有忿有恨若有覆恼。若有嫉悭若有诳谄。如是一切皆如前说。有邪见倒见者。云何邪见。答诸所有见。无施与无祠祀。无爱乐。广说乃至无自觉知我生已尽梵行已立所作已办不受后有。是名邪见。言倒见者。谓即邪见所见颠倒。取着自见起坚固执难教弃舍者。云何取着自见。答执我及世间常。唯此谛实余皆愚妄。广说乃至执如来死后非有非非有。唯此谛实余皆愚妄。是名取着自见。云何起坚固执。答即由取着自见。是故起坚执。云何难教弃舍。答由于自见起爱乐等爱乐现前爱乐。是故难教厌离解脱

六可喜法者。云何为六。答若有苾刍。于大师所。及诸有智同梵行者。起慈身业。是名第一可喜法。由此法故能发可爱。能发尊重能发可意。能引可爱尊重可意悦意。摄受欢喜无违无诤一趣。复有苾刍。于大师所。及诸有智同梵行者。起慈语业。是名第二可喜法。由此法故能发可爱。广说乃至无诤一趣。复有苾刍。于大师所。及诸有智同梵行者。起慈意业。是名第三可喜法。由此法故能发可爱。广说乃至无诤一趣。复有苾刍。以法获得如法利养。下至钵中所受饮食。于此利养与诸有智同梵行者。等共受用不别藏隐。是名第四可喜法。由此法故能发可爱。广说乃至无诤一趣。复有苾刍。诸所有戒。无缺无隙无杂无秽。应供无执善究竟善。受取诸有智者称赞无毁。于如是戒与诸有智同梵行者。等共受持无所藏隐。是名第五可喜法。由此法故能发可爱。广说乃至无诤一趣。复有苾刍。诸所有见。是圣出离能善通达。若起作彼能正尽苦。于如是见与诸有智同梵行者。等共修学无所藏隐。是名第六可喜法。由此法故能发可爱。能发尊重能发可意。能引可爱尊重可意悦意。摄受欢喜无违无诤一趣。于大师所者。云何大师。答一切如来应正等觉。说名大师。及诸有智同梵行者。云何有智同梵行者。答解憍阵那乃至广说。是名有智同梵行者。起慈身业者。云何慈身业。答兴起俱行哀愍俱行所有身业。此中意说名慈身业。于大师所。及诸有智同梵行者。此慈身业和合现前。由斯故说于大师所及诸有智同梵行者起慈身业是名第一可喜法者。谓如是法是能随顺甚可爱乐。长养端严应供常委支具资粮。是故名可喜法。能发可爱者。谓由此法。能发可爱。能发尊重者。谓由此法能发尊重。能发可意者。谓由此法能发可意。能引可爱尊重可意悦意摄受欢喜无违无诤一趣者。谓由此法能引可爱尊重可意悦意摄受欢喜无违无诤一趣此中摄受。谓令和合。言一趣者。谓趣一境一味现前。如慈身业。慈语意业应知亦尔。以法获得如法利养者。云何以法获得如法利养。答若诸利养不由矫妄而得。不由诡诈而得。不由现相而得。不由激发而得。不由以利求利而得。然受用时无罪生长。故名以法获得如法利养。下至钵中所受饮食者。谓下至堕钵中饮食。尚共受用。况余财物。于此利养与诸有智同梵行者。等共受用不别藏隐者。谓以法获得如法利养。是名于此利养。若苾刍苾刍尼。正学勤策勤策女。近事近事女。是名有智同梵行者。以法所得如法利养。应与有智同梵行者。等共受用不应各别藏隐受用。是名第四可喜法等。如前广说。诸所有戒者。云何名为诸所有戒。答无漏身业语业。及命清净。一切皆名诸所有戒。无缺无隙无杂无秽者。谓于此戒恒随作恒随转。平等共作平等共转。故名无缺无隙。无杂无秽。言应供者。谓诸有情有贪嗔痴名为给使。若诸有情离贪嗔痴名为应供。应受给使以衣服饮食卧具医药等常供养故。言无执者。谓圣弟子于戒不起若取若执。善究竟者。谓于此戒善守善护至极究竟。善受取者。谓于此戒殷重恭敬。具足摄受诸有智者。称赞无毁者。谓诸佛及弟子名有智者。此诸智者皆共称赞。无诃毁者。由斯故说诸有智者称赞无毁。于如是戒与诸有智同梵行者等共受持无所藏隐者。云何名为于如是戒。答谓平等戒。平等戒者。谓八圣道支中正语正业正命名平等戒。与诸有智同梵行者。谓解憍陈那等。皆名有智同梵行者。等共受持无所藏隐者。谓于此戒与诸有智同梵行者。共一义利共一所趣。彼此相似。是名第五可喜法等。如前广说。诸所有见者。云何名为诸所有见。答若依出离远离所生善法。于诸法相诸简择极简择。乃至广说。如是名为诸所有见。是圣出离等。如前广说。于如是见与诸有智同梵行者。等共修学无所藏隐者。云何名为于如是见。答谓平等见。平等见者。谓八圣道支中正见名平等见。余如前说。如是亦名六和敬法

六通者。云何为六。一神境智证通。二天耳智证通。三他心智证通。四宿住智证通。五死生智证通。六漏尽智证通。云何神境智证通。答领受示现种种神境。乃至广说。是名神境智证通。问此中通者何所谓耶。答于诸神境所有妙智。云何天耳智证通。答以天耳闻种种音声。谓人声非人声远声近声等。是名天耳智证通。问此中通者何所谓耶。答于天耳境所有妙智。云何他心智证通。答于他有情补特伽罗寻伺心等。皆如实知。谓有贪心如实知。有贪心离贪心如实知。离贪心。如是。有嗔心离嗔心。有痴心离痴心。略心散心。下心举心。掉心不掉心。寂静心不寂静心。不定心定心。不修心修心。不解脱心解脱心。皆如实知。是名他心智证通。问此中通者何所谓耶。答于他心等所有妙智。云何宿住智证通。答能随忆念过去无量诸宿住事。谓或一生。乃至广说。是名宿住智证通。问此中通者何所谓耶。答于诸宿住所有妙智。云何死生智证通。答如明广说。云何漏尽智证通。答亦如明广说

说一切有部集异门足论第十五阿毗达磨集异门足论卷第十六

        尊者舍利子说

        三藏法师玄奘奉　诏译

    六法品第七之二

六顺明分想者。云何为六。答一无常想。二无常苦想。三苦无我想。四厌食想。五一切世间不可乐想。六死想。此中五想如成熟解脱想说。云何一切世间不可乐想。答世间谓五取蕴。即色取蕴乃至识取蕴。有诸苾刍于五取蕴。以有思虑俱行作意审谛思惟。以有恐惧俱行作意审谛思惟。以不可乐俱行作意。审谛思惟。以不可喜俱行作意审谛思惟。彼于五取蕴如是思惟时。诸想等想。现前等想。已想当想。是名一切世间不可乐想。问何故名为顺明分想。答明有三种。一无学宿住智证明。二无学死生智证明。三无学漏尽智证明。由前六想。令此三明未生者生已生者增长广大故。名顺明分想

六随念者。云何为六。答一佛随念。二法随念。三僧随念。四戒随念。五舍随念。六天随念。云何佛随念。答如世尊说。苾刍当知。有圣弟子于世尊所。以如是相随念诸佛。谓此世尊是如来阿罗汉。广说乃至佛薄伽梵。若圣弟子以如是相随念诸佛。见为根本证智相应。诸念随念别念忆念。念性随念性别念性不忘性。不忘法性心明记性。是名佛随念。云何法随念。答如世尊说。苾刍当知。有圣弟子以如是相随念正法。谓佛正法善说。乃至知者内证。若圣弟子以如是相。随念正法见为根本。证智相应广说如前。是名法随念。云何僧随念。答如世尊说。苾刍当知。有圣弟子以如是相随念诸僧。谓佛弟子具足妙行。广说乃至无止福田世所应供。若圣弟子以如是相。随念诸僧。见为根本证智相应。广说如前。是名僧随念。云何戒随念。答如世尊说。苾刍当知。有圣弟子以如是相随念自戒。谓此净戒无缺无隙。广说乃至诸有智者称赞无毁。若圣弟子以如是相。随念自戒。见为根本。证智相应。广说如前。是名戒随念。云何舍随念。答如世尊说。苾刍当知。有圣弟子以如是相随念自舍。谓我善得无染财利。我于悭垢所缚众中。能离悭垢心无染着。舒手惠施所有财物。弃舍财物心无所顾。分布施与心无偏党。若圣弟子以如是相随念自舍。见为根本证智相应。广说如前。是名舍随念。云何天随念。答如世尊说。苾刍当知。有圣弟子以如是相随念诸天。谓有四大王众天。有三十三天。有夜摩天。有睹史多天。有乐变化天。有他化自在天。若有成就无倒信戒。闻舍慧者从此舍命得生彼天。我亦成就无倒信戒。闻舍慧善云何不得当生彼天。若圣弟子以如是相。随念诸天。见为根本。证智相应。诸念随念。别念忆念。念性随念性。别念性不忘性。不忘法性心明记性。是名天随念

六无上法者。云何为六。一见无上。二闻无上。三利无上。四学无上。五行无上。六念无上。云何见无上。答如世尊说。苾刍当知。如有一类补特伽罗。往观轮宝象宝马宝珠宝女宝主藏臣宝主兵臣宝。或复往观若沙门若婆罗门。发起邪见邪见行者。我说彼类虽有所见非无所见。而是下贱本性异生非贤圣见。若有修植清净信爱。往观如来或佛弟子。我说彼类为无上见。能自利益能自安乐。能令自身安隐而住超越灾愁灭诸忧苦。疾能证得如理法要。是名见无上。云何闻无上。答如世尊说。苾刍当知。如有一类补特伽罗。往听象声马声车声步声螺声大小鼓声呼叫声歌舞声伎乐声。或复往听若沙门若婆罗门发起邪见邪见行者所说邪法。我说彼类。虽有所闻非无所闻。而是下贱本性异生非贤圣闻。若有修植清净信爱。往听如来或佛弟子所说正法。我说彼类为无上闻。能自利益。广说乃至疾能证得如理法要。是名闻无上。云何利无上。答如世尊说。苾刍当知。如有一类补特伽罗。或得妻子或得珍财。或得诸谷。或行亲友。或于沙门若婆罗门。发起邪见邪见行者得深信乐。我说彼类。虽名得利非不得利。而是下贱本性异生非贤圣利。若有修植清净信爱。能于如来及佛弟子。得深信乐。我说彼类。得无上利。能自利益。广说乃至疾能证得如理法要。是名利无上。云何学无上。答如世尊说。苾刍当知。如有一类补特伽罗。或学乘象或学乘马。或学乘车或学弯弓。或学放箭或学执钩。或学执索或学执排。或学上乘或学下乘。或学驰走或学跳踯。或学书数或学算印。或学沙门若婆罗门发起邪见邪见行者所说学处。我说彼类。虽有所学非无所学。而是下劣本性异生非贤圣学。若有修植清净信爱。能学如来及佛弟子所说学处。我说彼类为无上学。能自利益。广说乃至能疾证得如理法要。是名学无上。云何行无上。答如世尊说。苾刍当知。如有一类补特伽罗。行调象行或调马行。或调人行或调牛行。或事火行。或事月行或事日行。或事药行或事珠行。或事星宿宫殿等行或行。沙门若婆罗门发起邪见邪见行者所受持行。我说彼类。虽有所行非无所行。而是下贱本性异生非贤圣行。若有修植清净信爱。能行如来及佛弟子所行之行。我说彼类为行无上。能自利益。广说乃至疾能证得如理法要。是名行无上。云何念无上。答如世尊说。苾刍当知。如有一类补特伽罗。或念妻子或念财谷。或念亲友。或念沙门若婆罗门发起邪见邪见行者及彼邪法。我说彼类。虽有所念非无所念。而是下贱本性异生非贤圣念。若有修植清净信爱。能念如来及佛弟子。我说彼类为念无上。能自利益能自安乐。能令自身安隐而住。超越灾愁灭诸忧苦。疾能证得如理法要。是名念无上。此中世尊说伽他曰

  若得离相应　　安隐无上见
  闻利学行念　　必得趣无忧

六观待者。云何为六。答一观待色。二观待声三观待香。四观待味。五观待触。六观待法。云何观待色。答若色有漏有取。于此诸色若过去若未来若现在。或欲或贪或嗔或痴。或随一一心所。随烦恼应生时生。是名观待色。声香味触观待亦尔。云何观待法。答若法有漏有取。于此诸法若过去若未来若现在。或欲或贪或嗔或痴。或随一一心所。随烦恼应生时生。是名观待法

六生类者。云何为六。答一有黑生类补特伽罗生起黑法。二有黑生类补特伽罗生起白法。三有黑生类补特伽罗。生起非黑非白涅槃法。四有白生类补特伽罗生起白法。五有白生类补特伽罗生起黑法。六有白生类补特伽罗。生起非黑非白涅槃法。云何黑生类补特伽罗生起黑法。答如有一类生贫贱家。谓旃荼罗家。广说乃至少饮食家。彼生此家。形容丑陋。人不喜见。众共诃毁。多分为他作诸事业。故名为黑。如是黑类。行身恶行行语恶行行意恶行。由行三种恶行因缘。身坏命终堕于恶趣。生地狱中受诸剧苦。是名黑生类补特伽罗生起黑法。云何黑生类补特伽罗生起白法。答如有一类生贫贱家。谓旃荼罗家。广说乃至少饮食家。彼生此家。形容丑陋。人不喜见。众共诃毁。多分为他作诸事业。故名为黑。如是黑类。行身妙行行语妙行行意妙行。由行三种妙行因缘。身坏命终生于善趣。天世界中受诸妙乐。是名黑生类补特伽罗生起白法。云何黑生类补特伽罗。生起非黑非白涅槃法。答如有一类生贫贱家。谓旃荼罗家。广说乃至少饮食家。彼生此家。形容丑陋。人不喜见。众共诃毁。多分为他作诸事业。故名为黑。如是黑类闻有如来为众宣说如实所证法毗柰耶。便往听受。既听受已得净信心。彼成如是净信心故。作是思惟。居家迫迮譬如牢狱。多诸尘秽。出家宽广犹若虚空。一切善法因之生长。又作是念。耽着居家。彼尚不能恒修世善。况能尽命精勤修学。纯一圆满清白梵行。是故我应剃除须发。身被法服正信舍家。出趣非家勤修梵行。既思念已。便于后时。弃舍亲财剃除须发。身被法服正信舍家。出趣非家受持净戒。精勤守护别解脱律仪。轨则所行无不具足。于微小罪见大怖畏。受学学处常无毁犯。依斯戒蕴渐次勤修。乃至证得第四静虑。由定心故乃至漏尽。证得无漏心慧解脱。广说乃至不受后有。是名黑生类补特伽罗生起非黑非白涅槃法。云何白生类补特伽罗生起白法。答如有一类生富贵家。请刹帝利大族。或婆罗门大族。或长者大族。或居士大族。或余随一富贵家生。多饶财宝仓库盈溢。彼生此家。形容端正。人皆乐见。众共称美。故名为白。如是白类。行身妙行行语妙行行意妙行。由行三种妙行因缘。身坏命终生于善趣。天世界中受诸妙乐。是名白生类补特伽罗生起白法。云何白生类补特伽罗生起黑法。答如有一类生富贵家。谓刹帝利大族。或婆罗门大族。或长者大族。或居士大族。或余随一富贵家生。多饶财宝仓库盈溢。彼生此家。形容端正。人皆乐见。众共称美。故名为白。如是白类。行身恶行行语恶行行意恶行。由行三种恶行因缘。身坏命终堕于恶趣。生地狱中受诸剧苦。是名白生类补特伽罗生起黑法。云何白生类补特伽罗生起非黑非白涅槃法。答如有一类生富贵家。谓刹帝利大族。或婆罗门大族。或长者大族。或居士大族。或余随一富贵家生。多饶财宝仓库盈溢。故名为白。如是白类。闻有如来为众宣说如实所证法毗柰耶。便往听受。既听受已得净信心。彼成如是净信心故。作是思惟。居家迫迮譬如牢狱。多诸尘秽。出家宽广犹若虚空。一切善法因之生长。又作是念。耽着居家。彼尚不能恒修世善。况能尽命精勤修学。纯一圆满清白梵行。是故我应剃除须发。身被法服正信舍家。出趣非家勤修梵行。既思念已。便于后时。弃舍亲财剃除须发。身被法服正信舍家。出趣非家受持净戒。精勤守护别解脱律仪。轨则所行无不具足。于微小罪具大怖畏。受诸学处常无毁犯。依斯戒蕴修根律仪。具念正知断盖证得四种静虑。由斯展转乃至漏尽。得心解脱及慧解脱。于现法中自证通慧。具足觉知。我生已尽。梵行已立。所作已办。不受后有。是名白生类补特伽罗生起非黑非白涅槃法

    七法品第八之一

时舍利子复告众言。具寿当知。佛于七法自善通达现等觉已。为诸弟子宣说开示。我等今应和合结集。佛灭度后勿有乖诤。当令随顺梵行法律。久住利乐无量有情。哀愍世间诸天人众。令获殊胜义利安乐。七法云何。嗢拖南曰

  支数具财力　　非妙妙各二
  识住与随眠　　事止诤各七

有七等觉支。七补特伽罗。七定具。七财七力。七非妙法七妙法。复有七非妙法。复有七妙法。七识住七随眠。七无过失事。七止诤法。七等觉支者。云何为七。答一念等觉支。二择法等觉支。三精进等觉支。四喜等觉支。五轻安等觉支。六定等觉支。七舍等觉支。云何念等觉支。答诸圣弟子。于苦思惟苦。于集思惟集。于灭思惟灭。于道思惟道无漏。作意相应诸念随念。广说乃至心明记性。是名念等觉支。云何择法等觉支。答诸圣弟子。于苦思惟苦。于集思惟集。于灭思惟灭。于道思惟道无漏。作意相应诸简择法。广说乃至毗钵舍那。是名择法等觉支。云何精进等觉支。答诸圣弟子。于苦思惟苦。于集思惟集。于灭思惟灭。于道思惟道无漏。作意相应诸勤精进。广说乃至励意不息。是名精进等觉支。云何喜等觉支。答诸圣弟子。于苦思惟苦。于集思惟集。于灭思惟灭。于道思惟道无漏。作意相应心欣极欣。数欣欣性欣类。适意悦意可意踊跃非不踊跃。悦受适悦调柔性堪任性。欢悦欢悦性。欢喜欢喜性。是名喜等觉支。云何轻安等觉支。答诸圣弟子。于苦思惟苦。于集思惟集。于灭思惟灭。于道思惟道无漏。作意相应身轻安心轻安。轻安性轻安类。是名轻安等觉支。云何定等觉支。答诸圣弟子。于苦思惟苦。于集思惟集。于灭思惟灭。于道思惟道无漏。作意相应心住等住。广说乃至心一境性。是名定等觉支。云何舍等觉支。答诸圣弟子。于苦思惟苦。于集思惟集。于灭思惟灭。于道思惟道无漏。作意相应心平等性。心正直性。心无警觉寂静住性。是名舍等觉支

七补特伽罗者。云何为七。答一随信行补特伽罗。二随法行补特伽罗。三信胜解补特伽罗。四见至补特伽罗。五身证补特伽罗。六慧解脱补特伽罗。七俱分解脱补特伽罗。云何随信行补特伽罗。答此随信行补特伽罗。先凡位中禀性多信。多爱多净多胜解多慈愍。少思惟少称量少观察少简择少推求。彼由多信多爱多净多胜解多慈愍故。得遇如来或佛弟子。宣说正法教授教诫。由遇如来或佛弟子。宣说正法教授教诫。以无量门分别开示。苦真是苦集真是集。灭真是灭道真是道。便作是念。善哉善哉。所言谛实定不虚妄。苦真是苦集真是集。灭真是灭道真是道。我于今者应勤观察。诸行无常有漏行苦。一切法空无我。作是念已遂勤观察。诸行无常有漏行苦。一切法空无我。由勤观察诸行无常有漏行苦一切法空无我故。便于后时后分。修得世第一法。从此无间生苦法智忍。相应圣道观欲界行。为无常或苦或空或无我。随一现前乃至未起道类智现在前。尔时名随信行。是名随信行补特伽罗。云何随法行补特伽罗。答此随法行补特伽罗。先凡位中禀性多思惟。多称量多观察多简择多推求。少信少爱少净少胜解少慈愍。彼由多思惟多称量多观察多简择多推求故。得遇如来或佛弟子。宣说正法教授教诫。由遇如来或佛弟子。宣说正法教授教诫。以无量门分别开示。苦真是苦集真是集。灭真是灭道真是道。便作是念。善哉善哉。所言谛实定不虚妄。苦真是苦集真是集。灭真是灭道真是道。我于今者应自审知。应自审见应自审察。诸行无常有漏行苦。一切法空无我。作是念已便自审察。诸行无常有漏行苦。一切法空无我。由自审察诸行无常有漏行苦一切法空无我故。便于后时后分。修得世第一法。从此无间生苦法智忍。相应圣道观欲界行。为无常或苦或空或无我。随一现前乃至未起道类智现在前。尔时名随法行。是名随法行补特伽罗。云何信胜解补特伽罗。答即随信行补特伽罗。得道类智故舍随信行性。入信胜解数。是名信胜解补特伽罗。云何见至补特伽罗。答即随法行补特伽罗。得道类智故。舍随法行性。入见至数是名见至补特伽罗。云何身证补特伽罗。答若补特伽罗。虽于八解脱身已证具足住。而未以慧永慧诸漏。是名身证补特伽罗。云何慧解脱补特伽罗。答若补特伽罗。虽于八解脱身未证具足住。而已以慧永尽诸漏。是名慧解脱补特伽罗。云何俱分解脱补特伽罗。答若补特伽罗。于八解脱身已证具足住。而复以慧永尽诸漏。是名俱解脱分补特伽罗。问何故名俱分解脱补特伽罗。答有二分障。一烦恼分障。二解脱分障。是名俱分。此补特伽罗于彼二分障。心俱解脱极解脱永解脱。是名俱分解脱补特伽罗。七定具者。云何为七。答一正见。二正思惟。三正语。四正业。五正命。六正勤。七正念。如是七种即七道支。应如彼相一一别说是名定具。问何故名定具。答定谓正定。由七道支资助围绕。令彼增盛具大势力。自在运转究竟圆满。故名定具

七财者。云何为七。一者信财。二者戒财。三者惭财。四者愧财。五者闻财。六者舍财。七者慧财。云何信财。答如世尊说。苾刍当知。有圣弟子。于如来所修植净信根生安住。不为沙门或婆罗门或天魔梵或余世间如法引夺。是名信财。云何戒财。答如世尊说。苾刍当知。有圣弟子。离断在命。离不与取。离欲邪行。离虚诳语。离饮诸酒。是名戒财。云何惭财。答如世尊说。有具惭者。于可惭羞恶不善法。有诸杂染能感后有。有极炽然苦异熟果。能引后世生老死法。深起惭羞。是名惭财。云何愧财。答如世尊说。有住愧者。于可愧耻恶不善法。有诸杂染能感后有。有极炽然苦异熟果。能引后世生老死法。深生愧耻。是名愧财。云何闻财。答如世尊说。苾刍当知。有圣弟子。多闻闻持其闻积集。谓佛所说无上法要。初中后善文义巧妙。纯一圆满清白梵行。彼于如是无上法要。具足多闻能持语义。极善通利心无散乱见善通达。是名闻财。云何舍财。答如世尊说。苾刍当知。有圣弟子。于为悭垢所缠众中能离悭垢。虽住居家而心无著。能行惠舍能舒手施。常乐弃舍好设祠祀。惠舍具足。于行施时平等分布。是名舍财。云何慧财。答如世尊说。苾刍当知。有圣弟子。能如实知。此是苦圣谛。此是苦集圣谛。此是苦灭圣谛。此是趣苦灭道圣谛。是名慧财。此中世尊说伽他曰

  男子或女人　　具信戒惭愧
  闻舍慧财者　　真富贵应知
  我说彼大士　　不虚度一生
  常生天人中　　受富贵妙乐

七力者。云何为七。答一信力。二精进力。三惭力。四愧力。五念力。六定力。七慧力。云何信力。答如世尊告诸苾刍言。有圣弟子。于如来所修植净信。乃至广说。是名信力。云何精进力。答如世尊说。为令已生恶不善法断故起欲。乃至广说四种正胜。是名精进力。云何惭力。答如世尊说。有具惭者。于可惭羞恶不善法。乃至广说。是名惭力。云何愧力。答如世尊说。有住愧者。于可愧耻恶不善法。乃至广说。是名愧力。云何念力。答如世尊说。于此内身住循身观。乃至广说四种念住。是名念力。云何定力。答如世尊说。离欲恶不善法。有寻有伺离生喜乐。初静虑具足住。广说乃至第四静虑具足住。是名定力。云何慧力。答如世尊告诸苾刍言。有圣弟子。能如实知此是苦圣谛。乃至广说。是名慧力。此中世尊说伽他曰

  若有诸苾刍　　具信勤惭愧
  及念定慧力　　速得尽众苦

说一切有部集异门足论卷第十六阿毗达磨集异门足论卷第十七

        尊者舍利子说

        三藏法师玄奘奉　诏译

    七法品第八之二

七非妙法者云何为七。答一不信。二无惭。三无愧。四懈怠。五失念。六不定。七恶慧。云何不信。答诸不信不信性。不现前信性。不随顺不印可。不已忍乐。不当忍乐。不现忍乐心不清净。是名不信。云何无惭。答诸无惭乃至广说是名无惭。云何无愧。答诸无愧乃至广说是名无愧。云何懈怠。答诸下精进性。劣精进性。怯精进性。惧精进性。广说乃至心懈怠懈怠性。心不勇悍不勇悍性。是名懈怠。云何失念。答诸空念性虚念性失念性心外念性。是名失念。云何不定。答心散乱性。云何心散乱性。答诸心散性。若心乱性心躁扰性。心流荡性不一境性。不安住性。是名心散乱性。云何恶慧。答于不如理所引简择。执为如理所引。于如理所引简择。执为不如理所引。是名恶慧。如是七种名非妙法。问何缘是七名非妙法。答非妙谓非善士。此是彼法名非妙法。谓此诸法非善士边可获可得。此是彼士所有现有故。说是七名非妙法

七妙法者云何为七。答一信二惭三愧四精进五念六定七慧。云何信。答诸信信性。现前信性随顺印可。已忍乐。当忍乐。现忍乐心清净。是名信。云何惭。答诸惭惭性。乃至广说是名惭。云何愧。答诸愧愧性。乃至广说是名愧。云何精进。答诸非下精进性。乃至广说是名精进。云何念。答诸念随念广说乃至。心明记性是名念。云何定。答诸心住广说乃至心一境性。是名定。云何慧。答于如理所引简择觉。为如理所引。于不如理所引简择觉。为不如理所引。是名慧。如是七种名为妙法。问何缘是七名为妙法。答妙谓善士。此是彼法故名妙法。谓此诸法唯善士边可获可得。此是彼士所有现有故。说是七名为妙法

复有七非妙法者云何为七。答一不知法。二不知义。三不知时。四不知量。五不自知。六不知众。七不知补特伽罗有胜有劣。不知法者。谓不了知如来教法。谓契经应诵记说伽他自说因缘譬喻本事本生方广希法论议。是名不知法。不知义者。谓不了知彼彼语义。谓如是如是语。有如是如是义。是名不知义。不知时者。谓不了知是时非时。谓此时应修止相。此时应修举相。此时应修舍相等。是名不知时。不知量者。谓不了知种种分量。谓所饮所食所尝所啖。若行若住若坐若卧。若睡若觉若语若默。若解劳闷等所有分量。是名不知量。不自知者。谓不了知自德多少。谓自所有若信若戒。若闻若舍若慧若教。若证若念若族姓若辩才等。是名不自知。不知众者。谓不了知众会胜劣。谓此是刹帝利众。此是婆罗门众。此是长者众。此是居士众。此是沙门众。此是外道众。我于此中应如是行。应如是住。应如是坐。应如是语。应如是默等。是名不知众。不知补特伽罗有胜有劣者。谓不了知补特伽罗德行胜劣。谓如是如是补特伽罗。有如是如是德行或胜或劣。是名不知补特伽罗有胜有劣。如是七种名非妙法。问何缘是七名非妙法。答非妙谓非善士。此是彼法名非妙法。谓此诸法非善士边可获可得。此是彼士所有现有故。说是七名非妙法。复有七妙法者。云何为七。答一知法。二知义。三知时。四知量。五自知。六知众。七知补特伽罗有胜有劣。知法者。谓正了知如来教法。谓契经应诵记说伽他自说因缘譬喻本事本生方广希法论议。是名知法。知义者。谓正了知彼彼语义。谓如是如是语。有如是如是义。是名知义。知时者。谓正了知是时非时。谓此时应修止相。此时应修举相。此时应修舍相等。是名知时。知量者。谓正了知种种分量。谓所饮所食所尝所啖。若行若住若坐若卧。若睡若觉若语若默。若解劳闷等所有分量是名知量。自知者。谓正了知自德多少。谓自所有若信若戒若闻若舍。若慧若教若证若念。若族姓若辩才等。是名自知。知众者。谓正了知众会胜劣。谓此是刹帝利众。此是婆罗门众。此是长者众。此是居士众。此是沙门众。此是外道众。我于此中应如是行。应如是住。应如是坐。应如是语。应如是默等。是名知众。知补特伽罗有胜有劣者。谓正了知补特伽罗德行胜劣。谓如是如是补特伽罗。有如是如是德行或胜或劣。是名知补特伽罗有胜有劣。如是七种名为妙法。问何缘是七名为妙法。答妙谓善士。此是彼法故名妙法。谓此诸法唯善士边可获可得。此是彼士所有现有。故名妙法。七识住者。云何为七。答有色有情种种身种种想。如人及一分天。是名第一识住。有色有情种种身一种想。如梵众天劫初起位。是名第二识住。有色有情一种身种种想如光音天。是名第三识住。有色有情一种身一种想如遍净天。是名第四识住。无色有情超一切色想灭有对想。不思惟种种想入无边空空无边处具足住。如空无边处天。是名第五识住。无色有情超一切空无边处。入无边识识无边处具足住。如识无边处天是名第六识住。无色有情超一切识无边处入无所有无所有处具足住。如无所有处天。是名第七识住。此中有色者。谓彼有情有色。施设有色身。有有色处有有色界。有色蕴故名有色。有情者。谓谛义胜义。虽诸有情不可获不可得无所有非现有。而依蕴界处假立有情。诸想等想施设言说转。谓有情人意。生儒童命者生者养者士夫补特伽罗。故名有情。种种身者。谓彼有情有种种显色身。种种相种种形非一显色。非一相非一形。故名种种身。种种想者。谓彼有情有乐想苦想不苦不乐想。故名种种想。如人及一分天者。谓总显示人及欲界天。故名如人及一分天。是名第一者渐次顺次相续次第数为第一。识住者云何识住。答即此所系。所有色受想行识蕴总名识住。有色者。谓彼有情有色施设有色身。有有色处有有色界。有色蕴故名有色。有情者。谓谛义胜义。虽诸有情不可获不可得无所有非现有。而依蕴界处假立有情诸想等想。施设言说转。谓有情人意生儒童命者生者养者士夫补特伽罗。故名有情种种身者。谓彼有情有种种显色身。种种相种种形非一。显色非一相非一形故。名种种身。一种想者。谓诸有情有时有分。于此世界劫将坏时。多往生上光音等天众同分中。于彼具足意成色身根无缺减。支分圆满形显清净。喜为所啖喜为所食。长寿久住有时有分。于此世界劫初成时。于下空中有空宫殿欻然而起。有一有情由寿尽故业尽故福尽故。先从光音等天众同分没。生下梵世空宫殿中。独一无二无诸侍者长寿久住。时彼有情长时住已。欻然生爱及生不乐。作如是念。云何当令诸余有情生我同分为我伴侣。当彼有情起此心愿。有余有情亦寿尽故业尽故福尽故。复从光音等天众同分没。生下梵宫与前有情共为伴侣。时前生者便作是念。我先于此独一无二见寿久住。长时住已欻然生爱及生不乐。作如是念。云何当令诸余有情生我同分为我伴侣。我起如是心愿之时。是诸有情便生此处。满我意愿为我伴侣。是故当知此有情类是我所化。我于此类及余世间。是自在者作者化者。生者起者是真父祖。时诸有情亦作是念。我等曾见如是有情。独一无二长寿久住。时彼有情长时住已。欻然生爱及生不乐。作如是念。云何当令诸余有情生我同分为我伴侣。于彼正起此心愿时。我等便生彼同分内为彼伴侣。由斯我等是彼所化。彼于有情及世间物。是自在者作者化者。生者起者是真父祖。故名一想。如梵众天者。谓此义中总显生在梵众等天。有种种身唯有一想。劫初起住者。谓劫初生时是名第二者。渐次顺次相续次第数为第二。识住者。云何识住。答即此所系所有色受想行识蕴。总名识住。有色者。谓彼有情有色施设。有色身有有色处有有色界有色蕴。故名有色。有情者。谓谛义胜义。虽诸有情不可获不可得无所有非现有。而依蕴界处假立有情。诸想等想施设言说转。谓有情人意生儒童命者生者养者士夫补特伽罗。故名有情。一种身者。谓彼有情有一显色身一种相一种形。无种种显色。无种种相无种种形。故名一种身。种种想者。谓彼有情有乐想不苦不乐想故。名种种想。如光音天者。谓总显示光音等天。是名第三者。渐次顺次相续次第数为第三。识住者云何识住。答即此所系。所有色受想行识蕴。总名识住。有色者。谓彼有情有色施设。有色身有有色处有有色界有色蕴。故名有色。有情者。谓谛义胜义。虽诸有情不可获不可得无所有非现有。而依蕴界处假立有情。诸想等想施设言说转。谓有情人意生儒童命者生者养者士夫补特伽罗。故名有情。一种身者。谓彼有情有一显色身一种相一种形。无种种显色。无种种相。无种种形。故名一种身。一种想者。谓彼有情唯有乐想故名一种想。如遍净天者。谓总显示遍净等天。是名第四者。渐次顺次相续次第数为第四。识住者云何识住。答即此所系。所有色受想行识蕴。名识住。无色者谓彼有情无色施设。无色身无有色处。无有色界无色蕴。故名无色。有情者。谓谛义胜义。虽诸有情不可获不可得无所有非现有。而依蕴界处假立有情。诸想等想施设言说转。谓有情人意生儒童命者生者养者士夫补特伽罗。故名有情。超一切色想者。谓超一切眼识身相应想。灭有对想者。谓灭四识身相应想。不思惟种种想者。谓无五身识所引意识相应。缘色等种种障碍定想。入无边空空无边处具足住。如空无边处天者。谓总显示空无边天。是名第五者。渐次顺次相续次第数为第五。识住者。云何识住。答即此所系。所有受想行识蕴。总名识住。无色者。谓彼有情无色施设。无色身无有色处无有色界。无色蕴故名无色。有情者谓谛义胜义。虽诸有情不可获不可得无所有非现有。而依蕴界处假立有情。诸想等想施设言说转。谓有情人意生儒童命者生者养者士夫补特伽罗。故名有情。超一切空无边处入无边识识无边处具足住。如识无边处天者。谓总显示识无边处天。是名第六者。渐次顺次相续次第数为第六。识住者。云何识住。答即此所系。所有受想行识蕴。总名识住。无色者。谓彼有情无色施设。无色身无有色处无有色界。无色蕴故名无色。有情者。谓谛义胜义。虽诸有情不可获不可得无所有非现有。而依蕴界处假立有情。诸想等想施设言说转。谓有情人意生儒童命者生者养者士夫补特伽罗。故名有情。超一切识无边处。入无所有无所有处具足住。如无所有处天者。谓总显示无所有处天。是名第七者。渐次顺次相续次第数为第七。识住者云何识住。答即此所系。所有受想行识蕴。总名识住

七随眠者。云何为七。答一欲贪随眠。二嗔随眠。三有贪随眠。四慢随眠。五无明随眠。六见随眠。七疑随眠。云何欲贪随眠。答若于诸欲诸贪等贪。乃至广说是名欲贪随眠。云何嗔随眠。答若于有情欲为损害。乃至广说是名嗔随眠。云何有贪随眠。答于色无色诸贪等贪。乃至广说是名有贪随眠。云何慢随眠。答诸慢恃执。乃至广说是名慢随眠。云何无明随眠。答三界无智是名无明随眠。云何见随眠。答五见是名见随眠。谓有身见边执见邪见见取戒禁取。如是五见名见随眠。云何疑随眠。答于谛犹豫。是名疑随眠

七无过失事者。云何为七。具寿当知有圣弟子。于如来所修植净信根生安住。不为沙门或婆罗门。或天魔梵或余世间如法引夺。是名第一无过失事。复次具寿有圣弟子。安住净戒精勤守护。别解脱律仪轨则所行无不具足。于微小罪见大怖畏。受学学处常无毁犯。是名第二无过失事。复次具寿有圣弟子。亲近善友善为伴侣。与善交通。是名第三无过失事。复次具寿有圣弟子。乐居闲寂具二远离。谓身远离及心远离。是名第四无过失事。复次具寿有圣弟子。勤精进住有势有勤有勇坚猛。于诸善法常不舍轭。是名第五无过失事。复次具寿有圣弟子。具念安住成就最胜常委念支。久作久说皆能忆念。是名第六无过失事。复次具寿有圣弟子。具慧安住成就世间。有出没慧圣慧出慧善通达慧。彼所作慧正尽苦慧。是名第七无过失事。于如来所修植净信者云何如来。答应正等觉说名如来。云何净信。答若依出离远离所生善法诸信信性。广说乃至心清净性故名净信。即此净信于如来所。已修植当修植现修植。是故说为于如来所修植净信根生等言。如前广说。是名第一者。渐次顺次相续次第数为第一。无过失事者。谓能显示清净永断。安住净戒者。云何净戒。答诸所作业。谓身律仪语律仪命清净是名净戒。安住者。谓成就净戒修行胜行进趣契会。故名安住。精勤守护别解脱律仪者。云何别解脱。答谓诸如来应正等觉广说。乃至佛薄伽梵自知自见。为诸苾刍半月半月。常所宣说别解脱契经。是名别解脱。问何缘说此名别解脱。答最胜善法由此为门此为上首此为初缘。别行别住由斯故立别解脱名。精勤守护此律仪者。谓于如是别解脱法。恒随作恒随转。由斯故说精勤守护别解脱律仪。轨则所行无不具足者。谓诸苾刍众有五非轨则及五非所行。云何名为五非轨则。答一他胜罪。二众余罪。三堕煮罪。四别首罪。五恶作罪。云何名为五非所行。答一国王家。二执恶家。三淫女家。四音乐家。五酤酒家。诸圣弟子于此所说五非轨则五非所行常乐远离止息弃舍。于正轨则及正所行具足成就。由斯故说轨则所行无不具足。于微小罪见大怖畏者。谓于小罪起极怖想。由斯故说于微小罪见大怖畏。受学学处常无毁犯者。谓圣弟子不作是念。我于如是如是学处应勤修学。我于如是如是学处不勤修学。诸圣弟子常作是念。一切如来应正等觉。广说乃至佛薄伽梵自知自见。凡所制立一切学处。我皆受学常无毁犯。由斯故说受学学处常无毁犯。是名第二者。渐次顺次相续次第数为第二。无过失事者。谓能显示清净永断。亲近善友者。云何善友答一切如来应正等觉。及佛弟子皆名善友。复次若有补特伽罗具戒具德。乃至广说故名善友。于斯善友亲近等亲近极亲近。随顺承奉供养恭敬。是故说为亲近善友。云何名为善为伴侣。答于断生命。若不与取。若欲邪行。若虚诳语。若饮诸酒。皆能远离止息弃舍。厌患永断说名谓善。与此善者为伴为侣。随顺趣向身心无二。是故说为善为伴侣。云何名为与善交通。答若于具信具戒多闻具舍具慧。随转随属随顺不逆。是故说为与善交通。复次若于具足出离远离善法。随转随属随顺不逆。是故说为与善交通。复次若于具足出离远离善法。一乐一欲一喜一爱。同乐同欲同喜同爱。是故说为与善交通。是名第三者。渐次顺次相续次第数为第三。无过失事者。谓能显示清净永断。乐居闲寂者。云何名为乐居闲寂。答诸空迥舍皆名闲寂。若住此中欢喜爱乐。不生愁思心无厌怖。是故说为乐居闲寂。具二远离谓身远离乃心远离者。谓住此中能勤修学。内心寂止不离静虑。成就妙观长空迥舍勤修自义。能勤修学内心寂止者。谓住此中能勤精进。修学世间四种静虑。不离静虑者谓于世间。四种静虑常勤思慕。不下不劣。无怯无断是故说为不难静虑。成就妙观者。谓于世间四种静虑。相应妙慧具足成就。是故说为成就妙观。长空迥舍者。谓住闲寂空迥舍中。由简择力欢喜爱乐。不生愁思心无厌怖。增长身心及诸善法。是故说为长空迥舍。勤修自义者。谓诸爱尽。离灭涅槃名最上义亦名自义。于如是义精勤修学求疾证得。是故说为勤修自义。是名第四者。渐次顺次相续次第数为第四。无过失事者。谓能显示清净增语勤精进住者。云何精进。答若于出离远离所生善法。精勤勇猛势用策励。不可制伏策心相续是名精进。由彼成就如是精进。于所修习能行胜行进趣证会。是故说为勤精进。住有势者。谓彼上品精进圆满故名有势。有勤者。谓即显示精进坚固故名有勤。有勇坚猛者。谓由成就精进力故。勇决而取坚住而取猛利而取。诸有所取是善非恶。随所取相守护不舍。如获他国善能守护。是故说为有勇坚猛。于诸善法常不舍轭者。谓于善法不舍勤勇。炽然精进无间无断。是故说为于诸善法常不舍轭。是名第五者。渐次顺次相续次第数为第五。无过失事者。谓能显示清净增语。具念安住者。云何为念。答若依出离远离所生善法诸念随念。乃至广说是名为念。成就最胜常委念支者。谓八支圣道说名常委。此念是彼一支所摄。谓正念支。是故说为成就最胜常委念支。久作久说皆能忆念者。谓由此念于曾更事。不忘不失令心明记。是故记为久作久说皆能忆念。是名第六者。渐次顺次相续次第数为第六。无过失事者。谓能显示清净增语。具慧安住者。云何名慧。答若依出离远离所生善法。于诸法相能简择极简择。广说乃至毗钵舍那。是名为慧言安住者。谓由成就如是慧故。于诸法相能行胜行进趣证会。由斯故说具慧安住。成就世间有出没慧者。世间谓五取蕴。云何为五。谓色取蕴受想行识取蕴。彼由成就如是慧故。能如实知此五取蕴生及变坏。由斯故说成就世间有出没慧。言圣慧者。有二种圣。一者善故圣。二者无漏故圣。此慧具由二种圣故。说名为圣故名圣慧。言出慧者。谓彼成就如是慧故。能出离欲界及能出离色无色界。故名出慧。善通达慧者。谓彼成就如是慧故。于苦集灭道谛由苦集灭道相。能通达善通达各别通达。是故名为善通达慧。彼所作慧者。谓彼所引学无间道所有胜慧。此中说为彼所作慧。正尽苦慧者云何名正。答因故门故理趣故行相故说名为正。尽苦慧者。五取蕴名为苦。此慧能令五取蕴尽等尽遍尽。证永尽故名尽苦慧。是名第七者。渐次顺次相续次第数为第七。无过失事者。谓能显示清净增语。此中世尊说伽他曰

  具信戒善友　　居寂乐精勤
  成就念正知　　名七无过事

七止诤法者。云何为七。答一现前毗柰耶。二忆念毗柰耶。三不痴毗柰耶。四求彼自性毗柰耶。五取多人语毗柰耶。六取自言持毗柰耶。七如草覆地毗柰耶。如是名为七止诤法。问何缘是七名止诤法。答诤谓彼此斗讼违诤。由斯七法随一现前。令所起诤皆调止息。由此因缘名止诤法

说一切有部集异门足论卷第十七阿毗达磨集异门足论卷第十八

        尊者舍利子说

        三藏法师玄奘奉　诏译

    八法品第九之一

时舍利子复告众言。具寿当知。佛于八法自善通达现等觉已。为诸弟子宣说开示。我等今应和合结集。佛灭度后勿有乖诤。当令随顺梵行法律。久住利乐无量有情。哀愍世间诸天人众。令获殊胜义利安乐。八法云何。嗢柁南曰

  道支数取施　　懈怠精进福
  众世法解脱　　胜处各八种

有八道支。八补特伽罗。八种施。八懈怠事。八精进事。八福生。八种众。八世法。八解脱。八胜处

八道支者。云何为八。答一正见二正思惟三正语四正业五正命六正勤七正念八正定。此八道支如前广说

八补特伽罗者。云何为八。答一证预流果向。二证预流果。三证一来果向。四证一来果。五证不还果向。六证不还果。七证阿罗汉果向。八证阿罗汉果。如是八种补特伽罗。如法蕴论广说其相

八种施者。云何为八。答一随至施。二怖畏施。三报恩施。四求报施。五习先施。六要名施。七希天施。八为庄严心为资助心。为资瑜伽为得通慧。菩提涅槃上义故施。云何随至施。答如有一类施邻近者。施亲近者。施现至者。谓作是念。云何乞者现来至此而不施耶。是名随至施。云何怖畏施。答如有一类有怖故施有畏故施。由怖畏缠而行惠施。彼作是念若不行施。勿有如是如是衰损。是名怖畏施。云何报恩施。答如有一类作是念言。彼既曾施我如是如是物。我亦应施彼如是如是物。岂得彼恩而不酬报。是名报恩施。云何求报施。答如有一类作是念言。我今若施彼如是如是物。彼亦当施我如是如是物。期他反报而行惠施。是名求报施。云何习先施。答如有一类作是念言。我之父祖常行惠施。我家长夜惠施无断。我今生在信家施家。我家本来常乐布施。我若不施便断种族。为护种族而行惠施。是名习先施。云何要名施。答如有一类为得广大妙善称誉声颂美名。遍诸方域而行惠施。是名要名施。云何希天施。答如有一类希求生天胜异熟果。而行惠施。谓我命终当生天上。由今布施受天妙乐。是名希天施。云何为庄严心为资助心为资瑜伽为得通慧菩提涅槃上义故施。答如有一类作是念言。我心长夜为贪嗔痴之所杂染。心杂染故有情杂染。心清净故有情清净。若行惠施便发起欣。欣故生喜心喜故身轻安。身轻安故受乐。受乐故心定。心定故如实知见。如实知见故生厌。厌故能离。离故得解脱。解脱故证涅槃。如是布施渐次增长诸胜妙法。展转证得菩提涅槃微妙上义。世尊于此说伽他言

  于众相圆满　　所舍离悭贪
  施质直应时　　必获于大果
  智者善净心　　施可祠可爱
  以心清净故　　遂证得于欣
  即从此欣心　　复发生胜喜
  由此心喜故　　又起身轻安
  从此身轻安　　智者心受乐
  由心受乐故　　定心一境转
  依如是胜定　　心净无染浊
  调顺有堪能　　发如实知见
  由如实知见　　便厌患于身
  既厌患于身　　智者正能离
  以能远离故　　解脱贪嗔痴
  智者自应知　　梵行立生尽
  如是大利益　　应知由布施
  若缘此修行　　必证得常乐

八懈怠事者云何为八。具寿当知如有一类。依止城邑或聚落住。于日初分着衣持钵。入城邑等巡行乞食。彼乞食时作如是念。愿得美妙众多饮食。若不遂心便作是念。我食既少身力羸劣。不能进修所修胜行。且应偃卧以自将息。作是念已遂不精勤。求得未得求至未至求证未证。是名第一懈怠事。复次具寿如有一类。依止城邑或聚落住。于日初分着衣持钵。入城邑等巡行乞食。彼乞食时作如是念。愿得美妙众多饮食。若得遂心便作是念。我食既多身饱闷重。不能进修所修胜行。且应偃卧以自将息。作是念已遂不精勤。求得未得求至未至求证未证。是名第二懈怠事。复次具寿如有一类。昼营事业作如是念。我于昼时既营事业身力劳倦。今于夜分不能进修行修胜行。且应偃卧以自将息。作是念已遂不精勤。求得未得求至未至求证未证。是名第三懈怠事。复次具寿如有一类。期至明日作诸事业。便作是念。我既明日当作事业。不应进修所修胜行。且应偃卧长养身力。作是念已遂不精勤。求得未得求至未至求证未证。是名第四懈怠事。复次具寿如有一类。昼行道路作如是念。我于昼时既行道路身力劳倦。今于夜分不能进修所修胜行。且应偃卧以自将息。作是念已遂不精勤。求得未得求至未至求证未证。是名第五懈怠事。复次具寿如有一类。期至明日当行道路。便作是念。我既明日当行道路。不应进修所修胜行。且应偃卧长养身力。作是念已遂不精勤。求得未得求至未至求证未证。是名第六懈怠事。复次具寿如有一类。正为病苦之所婴缠作如是念。我正病苦之所婴缠。身力羸劣不任进修所修胜行。且应偃卧以自将息。作是念已遂不精勤。求得未得求至未至求证未证。是名第七懈怠事。复次具寿如有一类。病苦婴缠虽愈未久。作如是念我遭病苦之所婴缠。虽愈未久身力羸劣。不任进修所修胜行。且应偃卧以自将息。作是念已遂不精勤。求得未得求至未至求证未证。是名第八懈怠事。如是八种名懈怠事。问何缘此八名懈怠事。答懈怠者谓懈惰。由斯八事未生而生生已倍复增长广大。由此因缘名懈怠事

八精进事者云何为八。具寿当知如有一类。依止城邑或聚落住。于日初分着衣持钵。入城邑等巡行乞食。彼乞食时作如是念。愿得美妙众多饮食。若不遂心便作是念。我食虽小而身轻利。堪能进修所修胜行。作是念已精进炽然。求得未得求至未至求证未证。是名第一精进事。复次具寿如有一类。依止城邑或聚落住。于日初分着衣持钵。入城邑等巡行乞食。彼乞食时作如是念。愿得美妙众多饮食。若得遂心便作是念。我食既多身力强盛。堪能进修所修胜行。作是念已精进炽然。求得未得求至未至求证未证。是名第二精进事。复次具寿如有一类。昼营事业作如是念。我于昼时既营事业。无暇修学大师圣教。今于夜分应自策勤补先间缺。作是念已精进炽然。求得未得求至未至求证未证。是名第三精进事。复次具寿如有一类。期至明日作诸事业。便作是念我既明日。当作事业无暇修学大师圣教。今于夜分应预精勤补当间缺。作是念已精进炽然。求得未得求至未至求证未证。是名第四精进事。复次具寿如有一类。昼行道路作如是念。我于昼时既行道路。无暇修学大师圣教。今于夜分应自策勤补先间缺。作是念已精进炽然。求得未得求至未至求证未证。是名第五精进事。复次具寿如有一类。期至明日当行道路。便作是念。我既明日当行道路。无暇修学大师圣教。今于夜分应预精勤补当间缺。作是念已精进炽然。求得未得求至未至求证未证。是名第六精进事。复次具寿如有一类。正为病苦之所婴缠。便作是念。我既病苦之所婴缠。或有是处因斯病苦之所婴缠。便舍身命于大师教空无所得。作是念已精进炽然。求得未得求至未至求证未证。是名第七精进事。复次具寿如有一类。病苦婴缠虽愈未久。作如是念。我遭病苦之所婴缠。虽愈未久或有是处病苦还起。因斯病苦便舍身命。于大师教空无所得。作是念已精进炽然。求得未得求至未至求证未证。是名第八精进事。如是八种名精进事。问何缘此八名精进事。答精进者谓策励。由此八事未生而生。生已倍复增长广大。由此因缘名精进事

八福生者云何为八。具寿当知如有一类。施诸沙门或婆罗门。贫穷苦行道行乞者苦行。衣服饮食及诸香华。房舍卧具并灯明等资生什物。见富贵人便作是念。由此布施所集善根。愿我来生当得如是富贵人类。彼于此心若习若修若多所作。由彼于心若习若修若多所作。先虽爱乐下劣諠杂。后便欣求胜妙寂静。彼有是处身坏命终。还生人中。得富贵类。虽受富贵自在安乐。而具尸罗心愿清净。先人身中尸罗净故。是名第一福生。如愿生人得富贵类。如是愿生四大王众天。三十三天。夜摩天。睹史多天。乐变化天。他化自在天。梵众天。应知亦尔。然梵众天有差别者应说离欲。此中是名第一乃至第八者。渐次顺次相续次第数为第一乃至第八。言福生者问何故说此名为福生。答摄受福果生于此处。故名福生

八种众者云何为八。答一刹帝利众。二婆罗门众。三长者众。四沙门众。五四大王众天众。六三十三天众。七魔天众。八梵天众。云何刹帝利众。答显示彼色显示彼蕴显示彼部。是名刹帝利众。乃至梵众广说亦尔

八世法者云何为八。答一得二不得三毁四誉五称六讥七苦八乐。云何名得。答若于可爱色声香味触。衣服饮食卧具病缘。医药资生什物。诸得别得已得当得。是名为得。云何不得。答若于可爱色声香味触。衣服饮食卧具病缘。医药资生什物。诸不得不别得不已得不当得。是名不得。云何名毁。答诸有隐背不现在前。不称不赞不叹不美。亦不揄扬言。彼信戒闻舍慧等皆不具足。是名为毁。云何名誉。答诸有隐背不现在前。称赞叹美亦复揄扬言。彼信戒闻舍慧等悉皆具足。是名为誉。云何名称。答诸不隐背正现在前。不诃不毁不骂不辱。称赞叹美亦复揄扬言。汝信戒闻舍慧等悉皆具足。故名为称。云何名讥。答诸不隐背正现在前。诃毁骂辱不称不赞。不叹不美亦不揄扬言。汝信戒闻舍慧等皆不具足。是名为讥。云何名苦。答顺苦受触所触故。生身及心苦不平等受受类所摄。是名为苦。云何名乐。答顺乐受触所触故。生身及心乐是平等受受类所摄。是名为乐。世尊于此说伽他言

  得不得毁誉　　及称讥苦乐
  无常意生欲　　变坏法难保
  智者如实知　　现见伏生死
  于爱非爱法　　心不生欣恚
  彼虽逢顺违　　而能弃伏灭
  于一切解脱　　至世边彼岸

八解脱者云何为八。答若有色观诸色。是第一解脱。内无色想观外诸色。是第二解脱。净解脱身作证具足住。是第三解脱。超一切色想灭有对想。不思惟种种想。入无边空空无边处具足住。是第四解脱。超一切空无边处。入无边识识无边处具足住。是第五解脱。超一切识无边处。入无所有无所有处具足住。是第六解脱。超一切无所有处。入非想非非想处具足住。是第七解脱。超一切非想非非想处。入想受灭身作证具足住。是第八解脱。若有色观诸色者。谓彼于内各别色想。未远离未别远离。未调伏未别调伏。未灭没未破坏。彼由于内各别色想。未远离未别远离。未调伏未别调伏。未灭没未破坏故。由胜解力观外诸色。或作青瘀或作脓烂。或作破坏或作离散。或作啄啖或作异赤。或作骸骨或作骨锁。是名若有色观诸色。第一者谓诸定中渐次顺次相续次第数为第一。解脱者谓此定中所有善色受想行识。是名解脱。内无色想观外诸色者。谓彼于内各别色想。已远离已别远离。已调伏已别调伏。已灭没已破坏。彼由于内各别色想。已远离已别远离。已调伏已别调伏。已灭没已破坏故。由胜解力观外诸色。或作青瘀或作脓烂。或作破坏或作离散。或作啄啖或作异赤。或作骸骨或作骨锁。是名内无色想观外诸色。第二者谓诸定中渐次顺次相续次第数为第二。解脱者谓此定中所有善色受想行识。是名解脱。净解脱身作证具足住者。问此净解脱加行云何。修观行者由何方便入净解脱定。答初修业者创修观时。取青树相。所谓青茎青枝青叶青花青果。或取青衣青严具相。或取所余种种青相。既取如是诸青相已。由胜解力思惟想念。观察安立信解此色是某青相。彼既如是由胜解力。思惟想念观察安立。信解此色是某青故。心便散动驰流诸相。不能一趣系念一境。思惟此色是青非余。彼心散动驰流诸相。不能一趣系念一境。思惟此色定是青故。未能住心入净解脱。定为摄散动驰流心。故于一青相系念思惟。谓此是青非非青相。思惟此相精勤勇猛。乃至令心相续久住。由斯加行入净解脱定。精勤数习此加行已。复进修行此定方便。谓于加行所引生道。数习数修数多所作。既于加行所引生道。数习数修数多所作。心便安住等住近住。相续一趣系念一境。思惟此色定是青相。由心安住等住近住。相续一趣系念一境。思惟青相无二无转。便能证入净解脱定。如观青相观黄赤白。随其所应亦复如是。第三者谓诸定中。渐次顺次相续次第数为第三。解脱者。谓此定中所有善色受想行识。是名解脱。超一切色想者。云何色想。答眼识身相应诸想等想性。现想性已想性。已现想性当想性。当现想性是名色想。复次有说。五识身相应诸想等想。乃至广说是名色想。今此义中眼识身相应诸想等想。乃至广说是名色想。入此定时于彼色想。皆能超越平等超越最极超越。是故说超一切色想灭。有对想者云何有对想。答四识身相应诸想等想。乃至广说是名有对想。复次有说。五识身相应诸想等想。乃至广说。是名有对想。复次有说。嗔恚相应诸想等想。乃至广说是名有对想。今此义中。四识身相应诸想等想。乃至广说是名有对想。入此定时彼有对想。已断已遍知。已远离已别远离。已调伏已别调伏。已灭没已破坏。是故说为灭有对想。不思惟种种想者。云何种种想。答有覆缠者所有染污色想。声想香想。味想触想诸所有想。若不善诸所有想。若非理所引诸所有想能障碍定。如是一切名种种想。入此定时于种种想。不引发不随引发。不等引发。不思惟不已思惟。不当思惟。由斯故说不思惟种种想。入无边空空无边处具足住者。问此空无边处解脱加行云何。修观行者由何方便入空无边处解脱定。答初修业者创修观时。先应思惟第四静虑为粗苦障。后应思惟空无边处为静妙离。彼既思惟第四静虑为粗苦障。亦复思惟空无边处为静妙离。故心便散动驰流诸相。不能一趣系念一境相续。思惟空无边处。彼心散动驰流诸相。不能一趣系念一境相续。思惟空无边处。故未能住心入空无边处解脱定。为摄散动驰流心故。专系念思惟空无边处相。思惟此相精勤勇猛。乃至令心相续久住。由斯加行入空无边处解脱定。精勤数习此加行已。复进修行此定方便。谓于加行所引生道。数习数修数多所作。既于加行所引生道。数习数修数多所作。心便安住等住近住。相续一趣系念一境。思惟此是空无边处。由心安住等住近住。相续一趣系念一境。思惟如是空无边处。无二无转便能证入空无边处解脱定。第四者。谓诸定中。渐次顺次相续次第数为第四。解脱者。谓此定中。所有善受想行识皆名解脱。超一切空无边处者。云何超一切空无边处。答将欲趣入识无边处时。于一切空无边处想。皆能超越平等超越最极超越。是故说为超一切空无边处。入无边识识无边处具足住者。问此识无边处解脱加行云何。修观行者由何方便入识无边处解脱定。答初修业者创修观时。先应思惟空无边处为粗苦障。后应思惟识无边处为静妙离。彼既思惟空无边处为苦粗障。亦复思惟识无边处为静妙离。故心便散动驰流诸相。不能一趣系念一境。相续思惟识无边处。彼心散动驰流诸相。不能一趣系念一境。相续思惟识无边处。故未能住心入识无边处解脱定。为摄散动驰流心故。专系念思惟识无边处相。思惟此相精勤勇猛。乃至令心相续久住。由斯加行入识无边处解脱定。精勤数习此加行已。复进修行此定方便。谓于加行所引生道。数习数修数多所作。既于加行所引生道。数习数修数多所作。心便安住等住近住。相续一趣系念一境。思惟此是识无边处。由心安住等住近住。相续一趣系念一境。思惟如是识无边处。无二无转便能证入。识无边处解脱定。第五者。谓诸定中。渐次顺次相续次第数为第五。解脱者。谓此定中所有善受想行识皆名解脱。超一切识无边处者。云何超一切识无边处。答将欲趣入无所有处时。于一切识无边处想。皆能超越平等超越最极超越。是故说为超一切识无边处。入无所有无所有处具足住者。问此无所有处解脱加行云何。修观行者由何方便。入无所有处解脱定。答初修业者创修观时。先应思惟识无边处为苦粗障。后应思惟无所有处为静妙离。彼既思惟识无边处为苦粗障。亦复思惟无所有处为静妙离。故心便散动驰流诸相。不能一趣系念一境。相续思惟无所有处。彼心散动驰流诸相。不能一趣系念一境。相续思惟无所有处。故未能住心入无所有处解脱定。为摄散动驰流心故。专系念思惟无所有处相。思惟此相精勤勇猛。乃至令心相续久住。由斯加行入无所有处解脱定。精勤数习此加行已。复进修行此定方便。谓于加行所引生道。数习数修数多所作。既于加行所引生道。数习数修数多所作。心便安住等住近住。相续一趣系念一境。思惟此是无所有处。由心安住等住近住。相续一趣系念一境。思惟如是无所有处无二无转。便能证入无所有处解脱定。第六者。谓诸定中。渐次顺次相续次第数为第六。解脱者。谓此定中所有善受想行识。皆名解脱。超一切无所有处者。云何超一切无所有处。答将欲趣入非想非非想处时。于一切无所有处。皆能超越平等超越最极超越。是故说为超一切无所有处。入非想非非想处具足住者。问此非想非非想处解脱加行云何。修观行者由何方便。入非想非非想处解脱定。答初修业者创修观时。先应思惟无所有处为苦粗障。后应思惟非想非非想处为静妙离。彼既思惟无所有处为苦粗障。亦复思惟非想非非想处为静妙离。故心便散动驰流诸相。不能一趣系念一境。相续思惟非想非非想处。彼心散动驰流诸相。不能一趣系念一境。相续思惟非想非非想处。故未能住心入非想非非想处解脱定。为摄散动驰流心故。专系念思惟非想非非想处相。思惟此相精勤勇猛。乃至令心相续久住。由斯加行入非想非非想处解脱定。精勤数习此加行已。复进修行此定方便。谓于加行所引生道。数习数修数多所作。既于加行所引生道。数习数修数多所作。心便安住等住近住。相续一趣系念一境。思惟此是非想非非想处。由心安住等住近住。相续一趣系念一境。思惟如是非想非非想处无二无转。便能证入非想非非想处解脱定。第七者。谓诸定中。渐次顺次相续次第数为第七。解脱者。谓此定中所有善受想行识。皆名解脱。超一切非想非非想处者。云何超一切非想非非想处。答将欲趣入想受灭解脱时。于一切非想非非想处想。皆能超越平等超越最极超越。是故说为超一切非想非非想处。入想受灭身作证具足住者。问此想受灭解脱加行云何。修观行者由何方便入想受灭解脱定。答初修业者创修观时。于一切行不愿造作不欲思觉。而入于定但作是念。云何当令未生想受暂时不生。已生想受暂时息灭。彼于诸行不愿造作不欲思觉。而入于定但作是念。云何当令未生想受暂时不生。已生想受暂时息灭。故随心所愿有时能令未生想受暂时不生。已生想受暂时息灭。齐此名入想受灭解脱定。第八者。谓诸定中。渐次顺次相续次第数为第八。解脱者。谓此定中诸解脱异解脱异极解脱。已解脱当解脱是名解脱。复次若法想微细为因。想微细为等无间。由想不和合义。非不成就义。是名解脱。此中想受灭解脱定者。云何想受灭。云何想受灭解脱。云何想受灭解脱定。而说想受灭解脱定耶。答想受灭者。谓想及受灭寂静没是名想受灭。想受灭解脱者。谓想受灭诸解脱。异解脱。异极解脱。已解脱当解脱。是名想受灭解脱。想受灭解脱定者。谓想受灭及想受灭解脱。不隐不背现前自在身所证得。是名想受灭解脱定

说一切有部集异门足论卷第十八阿毗达磨集异门足论卷第十九

        尊者舍利子说

        三藏法师玄奘奉　诏译

    八法品第九之二

八胜处者云何为八。答内有色想观外色少。若好若恶于彼诸色。胜知胜见有如是想。是第一胜处。内有色想观外色多。若好若恶于彼诸色。胜知胜见有如是想是第二胜处。内无色想观外色少。若好若恶于彼诸色。胜知胜见有如是想。是第三胜处。内无色想观外色多。若好若恶于彼诸色。胜知胜见有如是想。是第四胜处。内无色想观外诸色。若青青显青现青光。犹如乌莫迦花。或如婆罗痆斯深染青衣。若青青显青现青光。内无色想观外诸色。若青青显青现青光亦复如是。于彼诸色胜知胜见有如是想。是第五胜处。内无色想观外诸色。若黄黄显黄现黄光。犹如羯尼迦花。或如婆罗痆斯深染黄衣。若黄黄显黄现黄光。内无色想观外诸色。若黄黄显黄现黄光亦复如是。于彼诸色胜知胜见有如是想。是第六胜处。内无色想观外诸色。若赤赤显赤现赤光。犹如槃豆时缚迦花。或如婆罗痆斯深染赤衣。若赤赤显赤现赤光。内无色想观外诸色。若赤赤显赤现赤光亦复如是。于彼诸色胜知胜见有如是想。是第七胜处。内无色想观外诸色。若白白显白现白光。犹如乌沙斯星色。或如婆罗痆斯极鲜白衣若白白显白现白光。内无色想观外诸色。若白白显白现白光亦复如是。于彼诸色胜知胜见有如是想。是第八胜处。内有色想者。谓彼于内各别色想。未远离未别远离。未调伏未别调伏。未灭没未破坏。由彼于内各别色想未远离未别远离。未调伏未别调伏。未灭没未破坏名内有色想。故观外色少者。谓所观色其量甚小。微细非多故名为少。若好者。谓所观色已善磨莹。青黄赤白故名若好。若恶者。谓所观色未善磨莹。青黄赤白故名若恶。于彼诸色胜知胜见者。谓即于彼所观诸色。已伏欲贪。已断欲贪。已超欲贪。于彼已得胜知胜见。降伏自在都无所畏。如贵胜人或贵胜子。以胜知见执取僮仆。降伏自在都无所畏。诸瑜伽师亦复如是。于所观色已伏欲贪。已断欲贪已超欲贪。于彼已得胜知胜见。降伏自在都无所畏。有如是想者。谓如实想正现在前。第一者。谓诸定中。渐次顺次相续次第数为第一。胜处者。谓此定中所有善色受想行识。皆名胜处。内无色想观外色多等者。谓所观色其量广大。无边无际故名为多。余如前说。内无色想者。谓彼于内各别色想。已远离已别远离。已调伏已别调伏。已灭没已破坏。由彼于内各别色想。已远离已别远离。已调伏已别调伏。已灭没已破坏。故名内无色想。观外色少多等皆如前说。内无色想观外诸色若青者。谓总显示所有青色青聚青众。故说若青。青显者。谓此青色是显非形故说青显。青现者。谓此青色如是眼识所行境界。亦是意识所行境界。故说青现。青光者。谓此青色能现能发种种光明。故说青光。余如前说。如说若青等。若黄等亦尔

    九法品第十

时舍利子复告众言。具寿当知。佛于九法自善通达现等觉已。为诸弟子宣说开示。我等今应和合结集。佛灭度后勿有乖诤。当令随顺梵行法律。久住利乐无量有情。哀愍世间诸天人众。令获殊胜义利安乐。九法云何。此中略有二种九法。所谓九结九有情居。九结者云何为九。答一爱结。二恚结。三慢结。四无明结。五见结。六取结。七疑结。八嫉结。九悭结。云何爱结。答三界贪是名爱结。云何恚结。答于诸有情欲为损害。内怀栽孽欲为扰恼。已嗔当嗔现嗔。乐为过患极为过患。意极愤恚于诸有情各相违戾欲为过患。已为过患当为过患现为过患。是名恚结。云何慢结。答有七慢类说名慢结。云何为七。答一慢。二过慢。三慢过慢。四我慢。五增上慢。六卑慢。七邪慢。此七慢类合为慢结。云何无明结。答三界无智名无明结。云何见结。答三种见名见结。云何为三。答一萨迦耶见。二边执见。三邪见。如是三见合为见结。云何取结。答二种取名取结。云何为二。答一见取。二戒禁取。如是二取合为取结。云何疑结。答于谛犹豫是名疑结。云何嫉结。答心不忍许是名嫉结。云何悭结。答心有秘吝是名悭结

九有情居者云何为九。答有色有情。有种种身有种种想。如人及一分天。是第一有情居。有色有情。有种种身有一种想。如梵众天劫初起位。是第二有情居。有色有情。有一种身有种种想。如光音天是第三有情居。有色有情。有一种身有一种想如遍净天。是第四有情居。有色有情。无想无别想如无想有情天。是第五有情居。无色有情。超一切色想灭有对想。不思惟种种想入无边空。空无边处具足住。如空无边处天。是第六有情居。无色有情。超一切空无边处。入无边识识无边处具足住。如识无边处天。是第七有情居。无色有情。超一切识无边处。入无所有无所有处具足住。如无所有处天。是第八有情居。无色有情。超一切无所有处。入非想非非想处具足住。如非想非非想处天。是第九有情居。此中有色者。谓彼有情有色施设有色身有有色处有有色界有色蕴。故名有色。有情者。谓谛义胜义。虽诸有情不可获不可得无所有非现有。而依蕴界处假立有情。诸想等想施设言说转。谓有情人意生儒童命者生者养者士夫补特伽罗。故名有情。种种身者。谓彼有情有种种显色。身种种相种种形。非一显色非一相非一形故。名种种身。种种想者。谓彼有情有乐想苦想不苦不乐想故名种种想。如人及一分天者。谓总显示人及欲界天。故名如人及一分天。是第一者。渐次顺次相续次第数为第一。有情居者。谓诸有情所居所住所依所止所乐生处即总显示此中所有有漏色受想行识蕴名有情居。有色有情种种身者义如前说。一种想者。谓诸有情有时有分。于此世界劫将坏时。多往生上光音等天众同分中。于彼具足意成色身。根无缺减支分圆满。形显清净长寿久住。有时有分于此世界劫初成时。于下空中有空宫殿欻然而起。有一有情寿业福尽。从彼处没生下梵世空宫殿中。独一无侣长寿久住。时彼有情长时住已。欻然生爱及生不乐作如是念。云何当令诸余有情。生我同分为我伴侣。当彼有情起此心愿。有余有情寿业福尽。复从彼没生下梵宫。与前有情共为伴侣。时前生者便作是念。此有情类是我所化。我于此类及余世间。是自在者作者化者。生者起者是真父祖。时诸有情亦作是念。我等有情是彼所化。彼于有情及世间物。是自在者作者化者生者起者是真父祖。故名一想。如梵众天者。谓此义中总显生在梵众等天。有种种身唯有一想。劫初起位者。谓劫初生时是第二等。义如前说。有色有情者。亦如前说。一种身者。谓彼有惰有一显色。身一种相一种形无种种显色。无种种相无种种形。故名一种身。种种想者。谓彼有情有乐想不苦不乐想故名种种想。余如前说。有色有情一种身者亦如前说。一种想者。谓彼有情唯有乐想故名一种想。余如前说。有色有情者亦如前说。言无想者总显无想。无别想者别显无想。此中以想而为上首。显无一切心心所法。如无想有情天者。谓别显示无想有想天。是第五等义如前说。无色者。谓彼有情无色施设。无色身无有色处。无有色界无色蕴故名无色。有情者如前说超一切色想等如八解脱中广说。然于此中唯取有漏受想行识为有情居

    十法品第十一之一

时舍利子复告众言。具寿当知。佛于十法自善通达现等觉已。为诸弟子宣说开示。我等今应和合结集。佛灭度后勿有乖诤。当令随顺梵行法律。久住利乐无量有情。哀愍世间诸天人众。令获殊胜义利安乐。十法云何。此中略有二种。十法谓十遍处十无学法。十遍处者云何为十。具寿当知。地遍一想如是上下傍布无二无边无际。是第一遍处。复次具寿。水遍一相如是上下傍布无二无边无际。是第二遍处。复次具寿。火遍一想如是上下傍布无二无边无际是第三遍处。复次具寿。风遍一想如是上下傍布无二无边无际。是第四遍处。复次具寿。青遍一想如是上下傍布无二无边无际是第五遍处。复次具寿。黄遍一想如是上下傍布无二无边无际。是第六遍处。复次具寿。赤遍一想如是上下傍布无二无边无际。是第七遍处。复次具寿。白遍一想如是上下傍布无二无边无际。是第八遍处。复次具寿。空遍一想如是上下傍布无二无边无际。是第九遍处。复次具寿。识遍一想如是上下傍布无二无边无际。是第十遍处

问地遍处定加行云何。修观行者由何方便。而能证入地遍处定。答初修业者创修观时。于此大地彼彼方所。若高若下若刺若杌若碱若榛若险若秽。如是等处皆不思惟。于此大地彼彼方所。平坦显了犹如掌中。具净园林可爱乐处。随取一相以胜解力。系念思惟假想观察安立信解是某地相。彼由于此以胜解力系念思惟假想观察安立信解是某地故。心便散动驰流诸相。不能一趣系念一境。思惟此境是地非余。彼心散动驰流诸相。不能一趣系念一境思惟此境定是地故。未能证入地遍处定。为摄散动驰流心故。于一地相系念思惟。谓此是地非为水等。思惟此相精勤勇猛。乃至令心相续久住。由斯加行能入地定。精勤数习此加行己。复进修行此定方便。谓于加行所引生道。数习数修数多所作。既于加行所引生道。数习数修数多所作。心便安住等住近住。相续一趣系念一境。思惟此境定是地相。由心安住等住近住。相续一趣系念一境。思惟此境定是地相。无二无转能入地定。而未能入地遍处定。问若此未能入地遍处定者。地遍处定加行云何。修观行者由何方便乃能。证入地遍处定。答即依如前所入地定。令心随顺调伏趣向。渐次柔和周遍柔和。一趣定已复想此地。渐次增广东南西北遍皆是地彼想此地。渐次增广东南西北。遍是地故心便散动驰流诸相。不能一趣系念一境思惟此境。遍皆是地彼心散动驰流诸相。不能一趣系念一境思惟此境。遍是地故未能证入地遍处定。为摄散动驰流心故。于遍地相系念思惟此遍是地非遍水等。思惟此相精进勇猛。乃至令心相续久住。由斯加行乃渐能入地遍处定。精勤数习此加行已。复进修行此定方便。谓于加行所引生道。数习数修数多所作。既于加行所引生道。数习数修数多所作。心便安住等住近住。相续一趣系念一境思惟此境。遍皆是地。由心安住等住近住。相续一趣系念一境。思惟此境遍皆是地无二无转。从此乃入地遍处定。言上下者。谓上下方。言傍布者。谓东南等。言无二者。谓无间杂。无边无际者。谓边际难测。是第一者。谓诸定中渐次顺次相续次第数为第一。言遍处者。谓此定中所有善色受想行识。皆名遍处

问水遍处定加行云何。修观行者由何方便而能证入水遍处定。答初修业者创修观时。于此世界或取大水注相。或取大泉水相。或取大池水相。或取大陂水相。或取大湖水相。或取殑伽水相。或取盐母那水相。或取设腊婆水相。或取阿视罗筏底水相。或取莫醯河水相。乃至或取东大海水相。或取南大海水相。或取西大海水相。或取北大海水相。或取四大海水相。或取大水轮相。于如是等随取一相。以胜解力系念思惟。假想观察安立信解是某水相。彼由于此以胜解力系念思惟。假想观察安立信解是某水故。心便散动驰流诸相。不能一趣系念一境思惟此境是水非余。彼心散动驰流诸相。不能一趣系念一境思惟此境定是水故。未能证入水遍处定。为摄散动驰流心故。于一水相系念思惟。谓此是水非为地等思惟此相。精勤勇猛乃至令心相续久住。由斯加行能入水定精勤数习。此加行已复进修行此定方便。谓于加行所引生道。数习数修数多所作。既于加行所引生道。数习数修数多所作。心便安住等住近住。相续一趣系念一境。思惟此境定是水相。由心安住等住近住相续一趣系念一境。思惟此境定是水相无二无转。能入水定而未能入水遍处定。问若此未能入水遍处定者。水遍处定加行云何。修观行者由何方便乃能证入水遍处定。答即依如前所入水定。令心随顺调伏趣向。渐次柔和周遍柔和。一趣定已复想此水。渐次增广东南西北。遍皆是水彼想此水。渐次增广东南西北遍是水故。心便散动驰流诸相。不能一趣系念一境。思惟此境遍皆是水。彼心散动驰流诸相。不能一趣系念一境。思惟此境遍是水故。未能证入水遍处定。为摄散动驰流心故。于遍水相系念思惟。此遍是水非遍地等。思惟此相精勤勇猛。乃至令心相续久住。由斯加行乃渐能入水遍处定。精勤数习此加行已。复进修行此定方便。谓于加行所引生道。数习数修数多所作。既于加行所引生道。数习数修数多所作。心便安住等住近住。相续一趣系念一境。思惟此境遍皆是水。由心安住等住近住。相续一趣系念一境。思惟此境遍皆是水无二无转。从此乃入水遍处定。言上下者。谓上下方。言傍布者。谓东南等。言无二者谓无间杂。无边无际者。谓边际难测。是第二者。谓诸定中渐次顺次相续次第数为第二。言遍处者。谓此定中所有善色受想行识。皆名遍处

问火遍处定加行云何。修观行者由何方便。而能证入火遍处定。答初修业者创修观时。于此世界或取清净日轮火相。或取妙药光明火相。或取神珠光明火相。或取星宿宫殿火相。或取火聚大猛焰相。或取烧村大火焰相。或取烧城大火焰相。或取烧川大火焰相。或取烧野大火焰相。或取烧十载木大火焰相。或取烧二十载木大火焰相。或取烧三十载木大火焰相。或复取烧四十载木大火焰相。或复取烧五十载木大火焰相。或复取烧百载木大火焰相。或取烧千载木大火焰相。或取烧百千载木大火焰相。或取烧无量百载木大火焰相。或取烧无量千载木大火焰相。或取烧无量百千载木大火焰相。彼见如是诸火焰相。先渐炽然。复极炽然。转遍炽然后皆洞然。于如是等随取一相。以胜解力系念思惟假想观察。安立信解是某火相。彼由于此以胜解力系念思惟。假想观察安立信解是某火故。心便散动驰流诸相。不能一趣系念一境。思惟此境是火非余。彼心散动驰流诸相。不能一趣系念一境。思惟此境定是火故。未能证入火遍处定。为摄散动驰流心故。于一火相系念思惟。谓此是火非为水等。思惟此相精勤勇猛。乃至令心相续久住。由斯加行能入火定。精勤数习此加行已。复进修行此定方便。谓于加行所引生道。数习数修数多所作。既于加行所引生道。数习数修数多所作。心便安住等住近住。相续一趣系念一境。思惟此境定是火相。由心安住等住近住。相续一趣系念一境。思惟此境定是火相。无二无转能入火定。而未能入火遍处定。问若此未能入火遍处定者。火遍处定加行云何。修观行者由何方便。乃能证入火遍处定。答即依如前所入火定。令心随顺调伏趣向。渐次柔和周遍柔和一趣定已。复想此火渐次增广。东南西北遍皆是火。彼想此火渐次增广。东南西北遍是火故。心便散动驰流诸相。不能一趣系念一境。思惟此境遍皆是火。彼心散动驰流诸相。不能一趣系念一境。思惟此境遍是火故。未能证入火遍处定。为摄散动驰流心故。于遍火相系念思惟。此遍是火非遍水等。思惟此相精勤勇猛。乃至令心相续久住。由斯加行乃渐能入火遍处定。精勤数习此加行已。复进修行此定方便。谓于加行所引生道。数习数修数多所作。既于加行所引生道。数习数修数多所作。心便安住等住近住。相续一趣系念一境。思惟此境遍皆是火。由心安住等住近住。相续一趣系念一境。思惟此境遍皆是火无二无转。从此乃入火遍处定。言上下者。谓上下方。言傍布者。谓东南等。言无二者。谓无间杂。无边无际者。谓边际难测。是第三者。谓诸定中。渐次顺次相续次第数为第三。言遍处者。谓此定中。所有善色受想行识。皆名遍处

问风遍处定加行云何。修观行者由何方便。而能证入风遍处定。答初修业者创修观时。于此世界或取东方所有风相。或取南方所有风相。或取西方所有风相。或取北方所有风相。或取有尘风相。或取无尘风相。或取吠湿摩风相。或取吠岚婆风相。或取小风相。或取大风相。或取无量风相。或取大风轮相。于如是等随取一相。以胜解力系念思惟。假想观察安立信解是某风相。彼由于此以胜解力。系念思惟假想观察。安立信解是某风故。心便散动驰流诸相。不能一趣系念一境。思惟此境是风非余。彼心散动驰流诸相。不能一趣系念一境。思惟此境定是风故。未能证入风遍处定。为摄散动驰流心故。于一风相系念思惟。谓此是风非为火等。思惟此相精勤勇猛。乃至令心相续久住。由斯加行能入风定。精勤数习此加行已。复进修行此定方便。谓于加行所引生道。数习数修数多所作。既于加行所引生道。数习数修数多所作。心便安住等住近住。相续一趣系念一境。思惟此境定是风相。由心安住等住近住。相续一趣系念一境。思惟此境定是风相。无二无转能入风定。而未能入风遍处定。问若此未能入风遍处定者。风遍处定加行云何。修观行者由何方便。乃能证入风遍处定。答即依如前所入风定。令心随顺调伏趣向。渐次柔和周遍柔和。一趣定已复想此风。渐次增广东南西北。遍皆是风彼想此风。渐次增广东南西北遍是风故。心便散动驰流诸相。不能一趣系念一境。思惟此境遍皆是风。彼心散动驰流诸相。不能一趣系念一境。思惟此境遍是风故。未能证入风遍处定。为摄散动驰流心故。于遍风相系念思惟。此遍是风非遍火等。思惟此相精勤勇猛。乃至令心相续久住。由斯加行乃渐能入风遍处定。精勤数习此加行已。复进修行此定方便。谓于加行所引生道。数习数修数多所作。既于加行所引生道。数习数修数多所作。心便安住等住近住。相续一趣系念一境。思惟此境遍皆是风。由心安住等住近住。相续一趣系念一境。思惟此境遍皆是风无二无转。从此乃入风遍处定。言上下者。谓上下方。言傍布者。谓东南等。言无二者。谓无间杂。无边无际者。谓边际难测。是第四者。谓诸定中渐次顺次相续次第数为第四。言遍处者。谓此定中所有善色受想行识。皆名遍处

说一切有部集异门足论卷第十九阿毗达磨集异门足论卷第二十

        尊者舍利子说

        三藏法师玄奘奉　诏译

    十法品第十一之二

问青遍处定加行云何。修观行者由何方便。而能证入青遍处定。答初修业者创修观时。于此世界或取青树。或取青叶或取青花或取青果。或取青衣或取种种青庄严具。或取青云或取青水。或取种种诸余青物。彼于如是随取一相。以胜解力系念思惟。假想观察安立信解是某青相。彼由于此以胜解力。系念思惟假想观察。安立信解是某青故。心便散动驰流诸相。不能一趣系念一境。思惟此境是青非余。彼心散动驰流诸相。不能一趣系念一境。思惟此境定是青故。未能证入青遍处定。为摄散动驰流心故。于一青相系念思惟。谓此是青非为黄等。思惟此相精勤勇猛。乃至令心相续久住。由斯加行能入青定。精勤数习此加行已。复进修行此定方便。谓于加行所引生道。数习数修数多所作。既于加行所引生道。数习数修数多所作。心便安住等住近住。相续一趣系念一境。思惟此境定是青相。由心安住等住近住。相续一趣系念一境。思惟此境定是青相。无二无转能入青定。而未能入青遍处定。问若此未能入青遍处定者。青遍处定加行云何。修观行者由何方便。乃能证入青遍处定。答即依如前所入青定。令心随顺调伏趣向。渐次柔和周遍柔和。一趣定已。复想此青渐次增广。东南西北遍皆是青。彼想此青渐次增广。东南西北遍是青故。心便散动驰流诸相。不能一趣系念一境。思惟此境遍皆是青。彼心散动驰流诸相。不能一趣系念一境。思惟此境遍是青故。未能证入青遍处定。为摄散动驰流心故。于遍青相系念思惟。此遍是青非遍黄等。思惟此相精勤勇猛。乃至令心相续久住。由斯如行乃渐能入。青遍处定精勤数习。此加行已复进修行此定方便。谓于加行所引生道。数习数修数多所作。既于加行所引生道。数习数修数多所作。心便安住等住近住。相续一趣系念一境。思惟此境遍皆是青。由心安住等住近住。相续一趣系念一境。思惟此境遍皆是青无二无转。从此乃入青遍处定。言上下者。谓上下方。言傍布者。谓东南等。言无二者。谓无间杂。无边无际者。谓边际难测。是第五者。谓诸定中。渐次顺次相续次第数为第五。言遍处者。谓此定中。所有善色受想行识。皆名遍处

问黄遍处定加行云何。修观行者由何方便。而能证入黄遍处定。答初修业者创修观时。于此世界或取黄树。或取黄叶或取黄花或取黄果。或取黄衣或取种种黄庄严具。或取黄云或取黄水。或取种种诸余黄物。彼于如是随取一相。以胜解力系念思惟。假想观察安立信解是某黄相。彼由于此以胜解力。系念思惟。假想观察安立信解是某黄故。心便散动驰流诸相。不能一趣系念一境。思惟此境是黄非余。彼心散动驰流诸相。不能一趣系念一境。思惟此境定是黄故。未能证入黄遍处定。为摄散动驰流心故。于一黄相系念思惟。谓此是黄非为青等。思惟此相精勤勇猛。乃至令心相续久住。由斯加行能入黄定。精勤数习此加行已。复进修行此定方便。谓于加行所引生道。数习数修数多所作。既于加行所引生道。数习数修数多所作。心便安住等住近住。相续一趣系念一境。思惟此境定是黄相。由心安住等住近住。相续一趣系念一境。思惟此境定是黄相。无二无转能入黄定。而未能入黄遍处定。问若此未能入黄遍处定者。黄遍处定加行云何。修观行者由何方便。乃能证入黄遍处定。答即依如前所入黄定。令心随顺调伏趣向。渐次柔和周遍柔和。一趣定已复想此黄。渐次增广东南西北。遍皆。是黄彼想此黄。渐次增广东南西北遍是黄故。心便散动驰流诸相。不能一趣系念一境。思惟此境遍皆是黄。彼心散动驰流诸相。不能一趣系念一境。思惟此境遍是黄故。未能证入黄遍处定。为摄散动驰流心故。于遍黄相系念思惟。此遍是黄非遍青等。思惟此相精勤勇猛。乃至令心相续久住。由斯加行乃渐能入黄遍处定。精勤数习此加行已。复进修行此定方便。谓于加行所引生道。数习数修数多所作。既于加行所引生道。数习数修数多所作。心便安住等住近住。相续一趣系念一境。思惟此境遍皆是黄。由心安住等住近住。相续一趣系念一境。思惟此境遍皆是黄。无二无转从此乃入黄遍处定。言上下者。谓上下方。言傍布者。谓东南等。言无二者。谓无间杂。无边无际者。谓边际难测。是第六者。谓诸定中渐次顺次相续次第数为第六。言遍处者。谓此定中所有善色受想行识。皆名遍处

问赤遍处定加行云何。修观行者由何方便。而能证入赤遍处定。答初修业者创修观时。于此世界或取赤树。或取赤叶或取赤花或取赤果。或取赤衣。或取种种赤庄严具。或取赤云或取赤水。或取种种诸余赤物。彼于如是随取一相。以胜解力系念思惟。假想观察安立信解是某赤相。彼由于此以胜解力。系念思惟假想观察。安立信解是某赤故。心便散动驰流诸相。不能一趣系念一境。思惟此境是赤非余。彼心散动驰流诸相。不能一趣系念一境。思惟此境定是赤故。未能证入赤遍处定。为摄散动驰流心故。于一赤相系念思惟。谓此是赤非为黄等。思惟此相精勤勇猛。乃至令心相续久住。由斯加行能入赤定。精勤数习此加行已。复进修行此定方便。谓于加行所引生道。数习数修数多所作。既于加行所引生道。数习数修数多所作。心便安住等住近住。相续一趣系念一境。思惟此境定是赤相。由心安住等住近住。相续一趣系念一境。思惟此境定是赤相。无二无转能入赤定。而未能入赤遍处定。问若此未能入赤遍处定者。赤遍处定加行云何。修观行者由何方便。乃能证入赤遍处定。答即依如前所入赤定。令心随顺调伏趣向。渐次柔和周遍柔和。一趣定已复想此赤。渐次增广东南西北遍皆是赤彼想此赤。渐次增广东南西北遍是赤故。心便散动驰流诸相。不能一趣系念一境。思惟此境遍皆是赤。彼心散动驰流诸相。不能一趣系念一境。思惟此境遍是赤故。未能证入赤遍处定。为摄散动驰流心故。于遍赤相系念思惟。此遍是赤非遍黄等。思惟此相精勤勇猛。乃至令心相续久住。由斯加行乃渐能入赤遍处定。精勤数习此加行已。复进修行此定方便。谓于加行所引生道。数习数修数多所作。既于加行所引生道。数习数修数多所作。心便安住等住近住。相续一趣系念一境。思惟此境遍皆是赤。由心安住等住近住。相续一趣系念一境思惟此境。遍皆是赤无二无转。从此乃入赤遍处定。言上下者谓上下方。言傍布者谓东南等。言无二者谓无间杂。无边无际者谓边际难测。是第七者谓诸定中。渐次顺次相续次第数为第七。言遍处者谓此定中所有善色受想行识。皆名遍处

问白遍处定加行云何。修观行者由何方便。而能证入白遍处定。答初修业者创修观时。于此世界或取白树。或取白叶或取白花或取白果。或取白衣或取种种白庄严具。或取白云或取白水。或取种种诸余白物。彼于如是随取一相。以胜解力系念思惟。假想观察安立信解是某白相。彼由于此以胜解力。系念思惟假想观察。安立信解是某白故。心便散动驰流诸相。不能一趣系念一境。思惟此境是白非余。彼心散动驰流诸相。不能一趣系念一境。思惟此境定是白故。未能证入白遍处定。为摄散动驰流心故。于一白相系念思惟。谓此是白非为赤等。思惟此相精勤勇猛。乃至令心相续久住。由斯加行能入白定。精勤数习此加行已。复进修行此定方便。谓于加行所引生道。数习数修数多所作。既于加行所引生道。数习数修数多所作。心便安住等住近住。相续一趣系念一境。思惟此境定是白相。由心安住等住近住。相续一趣系念一境。思惟此境定是白相。无二无转能入白定。而未能入白遍处定。问若此未能入白遍处定者。白遍处定加行云何。修观行者由何方便。乃能证入白遍处定。答即依如前所入白定。令心随顺调伏趣向。渐次柔和周遍柔和。一趣定已复想此白。渐次增广东南西北。遍皆是白彼想此白。渐次增广东南西北遍是白故。心便散动驰流诸相。不能一趣系念一境。思惟此境遍皆是白。彼心散动驰流诸相。不能一趣系念一境。思惟此境遍是白故。未能证入白遍处定。为摄散动驰流心故。于遍白相系念思惟。此遍是白非遍赤等。思惟此相精勤勇猛。乃至令心相续久住。由斯加行乃渐能入白遍处定。精勤数习此加行已。复进修行此定方便。谓于加行所引生道。数习数修数多所作。既于加行所引生道。数习数修数多所作。心便安住等住近住。相续一趣系念一境。思惟此境遍皆是白。由心安住等住近住。相续一趣系念一境。思惟此境遍皆是白。无二无转从此乃入白遍处定。言上下者谓上下方。言傍布者谓东南等。言无二者谓无间杂。无边无际者谓边际难测。是第八者谓诸定中。渐次顺次相续次第数为第八。言遍处者谓此定中所有善色受想行识。皆名遍处

问空遍处定加行云何。修观行者由何方便。而能证入空遍处定。答初修业者创修观时。于此世界取舍上空。或地上空或树上空。或岩上空或山上空。或川中空或谷中空。于此等空随取一相。以胜解力系念思惟。假想观察安立信解是某空相。彼由于此以胜解力。系念思惟假想观察。安立信解是某空故。心便散动驰流诸相。不能一趣系念一境。思惟此境是空非余。彼心散动驰流诸相。不能一趣系念一境。思惟此境定是空故。未能证入空遍处定。为摄散动驰流心故。于一空相系念思惟。谓此是空非为识等。思惟此相精勤勇猛。乃至令心相续久住。由斯加行能入空定。精勤数习此加行已。复进修行此定方便。谓于加行所引生道。数习数修数多所作。既于加行所引生道。数习数修数多所作。心便安住等住近住。相续一趣系念一境。思惟此境定是空相。由心安住等住近住。相续一趣系念一境。思惟此境定是空相。无二无转能入空定。而未证入空遍处定。问若此未能入空遍处定者。空遍处定加行云何。修观行者由何方便。乃能证入空遍处定。答即依如前所入空定。令心随顺调伏趣向。渐次柔和周遍柔和。一趣定已复想此空。渐次增广东南西北遍皆是空。彼想此空渐次增广东南西北遍是空故。心便散动驰流诸相。不能一趣系念一境。思惟此境遍皆是空。彼心散动驰流诸相。不能一趣系念一境。思惟此境遍是空故。未能证入空遍处定。为摄散动驰流心故。于遍空相系念思惟。此遍是空非遍识等。思惟此相精勤勇猛。乃至令心相续久住。由斯加行乃渐能入空遍处定。精勤数习此加行已。复进修行此定方便。谓于加行所引生道。数习数修数多所作。既于加行所引生道。数习数修数多所作。心便安住等住近住。相续一趣系念一境。思惟此境遍皆是空。由心安住等住近住。相续一趣系念一境。思惟此境遍皆是空。无二无转从此乃入空遍处定。言上下者谓上下方。言傍布者谓东南等。言无二者谓无间杂。无边无际者谓边际难测。是第九者谓诸定中。渐次顺次相续次第数为第九。言遍处者谓此空无边处定中所有善色受想行识。皆名遍处

问识遍处定加行云何。修观行者由何方便。而能证入识遍处定。答初修业者创修观时。于此身中或取清净眼识相。或取清净耳识相。或取清净鼻识相。或取清净舌识相。或取清净身识相。或取清净意识相。于此诸识随取一相。以胜解力系念思惟。假想观察安立信解是某识相。彼由于此以胜解力。系念思惟假想观察。安立信解是某识故。心便散动驰流诸相。不能一趣系念一境。思惟此境是识非余。彼心散动驰流诸相。不能一趣系念一境。思惟此境定是识故。未能证入识遍处定。为摄散动驰流心故。于一识相系念思惟。谓此是识非为空等。思惟此相精勤勇猛。乃至令心相续久住。由斯加行能入识定。精勤数习此加行已。复进修行此定方便。谓于加行所引生道。数习数修数多所作。既于加行所引生道。数习数修数多所作。心便安住等住近住。相续一趣系念一境。思惟此境定是识相。由心安住等住近住。相续一趣系念一境。思惟此境定是识相。无二无转能入识定。而未能入识遍处定。问若此未能入识遍处定者。识遍处定加行云何。修观行者由何方便。乃能证入识遍处定。答即依如前所入识定。令心随顺调伏趣向。渐次柔和周遍柔和。一趣定已复想此识。渐次增广东南西北。遍皆是识彼想此识。渐次增广东南西北遍是识故。心便散动驰流诸相。不能一趣系念一境。思惟此境遍皆是识。彼心散动驰流诸相。不能一趣系念一境。思惟此境遍皆识故。未能证入识遍处定。为摄散动驰流心故。于遍识相系念思惟。此遍是识非遍空等。思惟此相精勤勇猛。乃至令心相续久住。由斯加行乃渐能入识遍处定。精勤数习此加行已。复进修行此定方便。谓于加行所引生道。数习数修数多所作。既于加行数习数修数多所作。心便安住等住近住。相续一趣系念一境。思惟此境。遍皆是识。由心安住等住近住。相续一趣系念一境。思惟此境遍皆是识。无二无转从此乃入识遍处定。言上下者谓上下方。言傍布者谓东南等。言无二者谓无间杂。无边无际者谓边际难测。是第十者谓诸定中。渐次顺次相续次第数为第十。言遍处者谓此识无边处定中。所有善受想行识。皆名遍处。十无学法者云何为十。答一无学正见。二无学正思惟。三无学正语。四无学正业。五无学正命。六无学正勤。七无学正念。八无学正定。九无学正解脱。十无学正智。云何无学正见。答尽智无生智。尽所不摄无学慧是名无学正见。云何无学正思惟。答诸圣弟子于苦思惟苦。于集思惟集。于灭思惟灭。于道思惟道。无学作意相应所有思惟。等思惟近思惟。寻求等寻求近寻求。推觅等推觅近推觅。令心于法粗动而转。是名无学正思惟。云何无学正语。答诸圣弟子。于苦思惟苦。于集思惟集。于灭思惟灭。于道思惟道。无学作意相应简择力故。除趣邪命语四恶行。于余语恶行所得。无学远离胜远离近远离极远离。寂静律仪无作无造。弃舍防护不行不犯。船筏桥梁堤塘墙堑。于所制约不踰不踰性。不越不越性无表语业。是名无学正语。云何无学正业。答诸圣弟子于苦思惟苦。于集思惟集。于灭思惟灭。于道思惟道。无学作意相应简择力故。除趣邪命身三恶行。于余身恶行所得。无学远离胜远离近远离极远离。寂静律仪无作无造。弃舍防护不行不犯。船筏桥梁堤塘墙堑。于所制约不踰不踰性。不越不越性。无表身业是名无学正业。云何无学正命。答诸圣弟子。于苦思惟苦。于集思惟集。于灭思惟灭。于道思惟道。无学作意相应简择力故。于趣邪命身语恶行所得。无学远离胜远离近远离极远离。寂静律仪无作无造。弃舍防护不行不犯。船筏桥梁堤塘墙堑。于所制约不踰不踰性。不越不越性无表身语业。是名无学正命。云何无学正勤。答诸圣弟子。于苦思惟苦。于集思惟集。于灭思惟灭。于道思惟道。无学作意相应所有勤精进。勇健势猛炽盛难制励意不息。是名无学正勤。云何无学正念。答诸圣弟子。于苦思惟苦。于集思惟集。于灭思惟灭。于道思惟道。无学作意相应所有念。随念专念忆念。不忘不失不遗不漏。不失法性心明记性。是名无学正念。云何无学正定。答诸圣弟子。于苦思惟苦。于集思惟集。于灭思惟灭。于道思惟道。无学作意相应所有心。住等住近住安住。不散不乱摄止等持心一境性。是名无学正定。云何无学正解脱。答诸圣弟子。于苦思惟苦。于集思惟集。于灭思惟灭。于道思惟道。无学作意相应所有心胜解。已胜解当胜解是名无学正解脱。云何无学正智。答尽智无生智是名无学正智

尔时舍利子告苾刍众言。具寿当知。佛于一法乃至十法现等觉已。为诸弟子宣说开示。我与大众皆共和合。亲对世尊已结集竟。诸苾刍众皆应受持。为他演说广令流布。佛灭度后勿有乖违。当令随顺梵行法律。久住利乐无量有情。哀愍世间诸天人众。令获殊胜义利安乐

    赞劝品第十二

尔时世尊。知舍利子为苾刍众说法已讫。从卧而起身心调畅。整理衣服结加趺坐。赞舍利子善哉善哉。汝今善能于此台观与苾刍众和合。结集如来所说增一法门。汝可从今为诸大众数复宣说如是法门。此法能令诸天人等长夜证会义利安乐世尊复告苾刍众言。汝等皆应受持读诵。舍利子说集异法门。如是法门。能引大善大义大法清白梵行。复证通慧菩提涅槃。净信出家诸善男子。受持读诵如是法门。不久定当办所办事。时薄伽梵说是语已。诸苾刍众欢喜踊跃顶礼佛足信受奉行

说一切有部集异门足论卷第二十


阿毗达磨界身足论

    No. 1540

阿毗达磨界身足论卷上

        尊者世友造

        三藏法师玄奘奉　诏译

    本事品第一

  三地各十种　　五烦恼五见
  五触五根法　　六六身相应

有十大地法。十大烦恼地法。十小烦恼地法。五烦恼。五见。五触。五根。五法。六识身。六触身。六受身。六想身。六思身。六爱身。十大地法云何。一受。二想。三思。四触。五作意。六欲。七胜解。八念。九三摩地。十慧。十大烦恼地法云何。一不信。二懈怠。三失念。四心乱。五无明。六不正知。七非理作意。八邪胜解。九掉举。十放逸。十小烦恼地法云何。一忿。二恨。三覆。四恼。五嫉。六悭。七诳。八谄。九憍。十害。五烦恼云何。一欲贪。二色贪。三无色贪。四嗔。五疑。五见云何。一有身见。二边执见。三邪见。四见取。五戒禁取。五触云何。一有对触。二增语触。三明触。四无明触。五非明非无明触。五根云何。一乐根。二苦根。三喜根。四忧根。五舍根。五法云何。一寻。二伺。三识。四无惭。五无愧。六识身云何。一眼识。二耳识。三鼻识。四舌识。五身识。六意识。六触身云何。一眼触。二耳触。三鼻触。四舌识。五身触。六意触。六受身云何。一眼触所生受。二耳触所生受。三鼻触所生受。四舌触所生受。五身触所生受。六意触所生受。六想身云何。一眼触所生想。二耳触所生想。三鼻触所生想。四舌触所生想。五身触所生想。六意触所生想。六思身云何。一眼触所生思。二耳触所生思。三鼻触所生思。四舌触所生思。五身触所生思。六意触所生思。六爱身云何。一眼触所生爱。二耳触所生爱。三鼻触所生爱。四舌触所生爱。五身触所生爱。六意触所生爱。受云何。谓受等受各等受已受当受。受所摄是名受。想云何。谓想等想现想已想当想。是名想。思云何。谓思等思现思已思当思。思所摄造心意业。是名思。触云何。谓触等触现触已触当触是名触。作意云何。谓心引于随引等随引。现作意已作意当作意。警觉心是名作意。欲云何。谓欲能欲性。现欲性。喜乐性。趣向性。希欲性。欣求性。欲有所作性是名欲。胜解云何。谓心胜解性。已胜解当胜解。是名胜解。念云何。谓念随念别念忆念。忆念性不忘性。不忘法不失性。不失法不忘失性。心明记是名念。三摩地云何。谓心住等住。现住近住。不乱不散。摄持寂止等持。心一境性。是名三摩地。慧云何。谓于法简择。最极简择极简择。法了相近了相等了相。聪睿通达。审察决择。觉明慧行。毗钵舍那是名慧。不信云何。谓不信不信性。不现信性。不印不可。不已委信。不当委信。不现委信。令心不净是名不信。懈怠云何。谓不精进性。劣精进性。昧精进性。障碍精进。止息精进。心不勇悍。不已勇悍。不当勇悍。是名懈怠。失念云何。谓空念性。虚念性。忘念性。失念性。心不明记性。是名失念。心乱云何。谓心散性。心乱性。心异念性。心迷乱性。心不一境性。不住一境性。是名心乱。无明云何。谓三界无智。不正知云何。谓非理所引慧。非理作意云何。谓染污作意。邪胜解云何。谓染污作意相应。心胜解心印顺。是名邪胜解。掉举云何。谓心不寂静。不极寂静。不寂静性。嚣举等嚣举。心嚣举性。是名掉举。放逸云何。谓于断不善法引集善法。不坚住作。不恒常作。不亲不近。不修不习。是名放逸。忿云何。谓忿等忿遍忿极忿。已忿当忿是名忿。恨云何。谓心结恨。等遍结恨。心怨结性是名恨。覆云何。谓隐所作罪。恼云何。谓心愤恼。坚执尤蛆。心俍戾性。是名恼。嫉云何。谓心不忍他之荣利。悭云何。谓于财法心着不舍。诳云何。谓矫惑他谄云何。谓心曲。憍云何。谓如有一作如是念。我具妙色财位技艺净命功德。形貌端严众所乐见。由此因缘便起憍傲极憍傲。醉闷等醉闷。靦眩等靦眩。心踞傲性是名憍。害云何。谓于有情乐为捶挞诸损恼事是名害。欲贪云何。谓于诸欲起贪等贪。执藏防护爱乐耽着。是名欲贪。色贪云何。谓于诸色起贪等贪。执藏防护。爱乐耽着。是名色贪。无色贪云何。谓于诸无色起贪等贪。执藏防护。爱乐耽着。是名无色贪。嗔云何。谓于有情欲为逼害。内怀栽檗。极嗔恚。遍嗔恚等嗔恚。嗔极嗔意愤恚。现嗔恚已嗔恚当嗔恚。是名嗔。疑云何。谓于诸谛犹豫。有身见云何。谓于五取蕴等。随观执我或我所由此起忍乐慧观见。是名有身见。边执见云何。谓于五取蕴等。随观执或断或常。由此起忍乐慧观见。是名边执见。邪见云何。谓谤因谤果。或谤作用。或坏实事。由此起忍乐慧观见。是名邪见。见取云何。谓于五取蕴等。随观执为最为胜为妙第一。由此起忍乐慧观见。是名见取。戒禁取云何。谓于五取蕴等。随观执为清净为解脱为出离。由此起忍乐慧观见。是名戒禁取。有对触云何。谓五识相应触。增语触云何。谓意识相应触。明触云何。谓无漏触。无明触云何。谓染污触。非明非无明触云何。谓不染有漏触。乐根云何。谓触顺乐受。触者所起身心乐平等受。受所摄是名乐根。苦根云何。谓触顺苦受。触者所起身苦不平等受。受所摄是名苦根。喜根云何。谓触顺喜受。触者所起心喜平等受。受所摄。是名喜根。忧根云何。谓触顺忧受。触者所起心忧不平等受。受所摄。是名忧根。舍根云何。谓触顺不苦不乐受。触者所起身心舍非平等非不平等受。受所摄。是名舍根。寻云何。谓心推觅遍推觅显示极显示。现前显示。寻求遍寻求。算计遍算计。构画遍构画。分别等分别。等分别性是名寻。伺云何。谓心巡行遍巡行。随遍巡行。伺察遍伺察。随遍伺察。随转随流。随属彼性是名伺。识云何。谓六识身。所谓眼识乃至意识。无惭云何。谓无惭无所惭无别惭。无羞无所羞无别羞。无敬无所敬无别敬。无自在无所自在无别自在。无所畏惮自在而转。是名无惭。无愧云何。谓无愧无所愧无别愧。无耻无所耻无别耻。于罪不怖性。于罪不畏性。于诸罪中不见怖畏。是名无愧。眼识云何。谓眼及色为缘所生眼识。此中眼为增上色为所缘。于眼所识色所有了别。各别了别。是名眼识。耳鼻舌身意识云何。谓意及法为缘所生意识。此中意为增上法为所缘。于意所识法所有了别。各别了别。是名意识。眼触云何。谓眼及色为缘生于眼识。三和合故触。此中眼为增上色为所缘。于眼所识色诸触等触现触已触当触。是名眼触。耳鼻舌身意触云何。谓意及法为缘生于意识。三和合故触。此中意为增上法为所缘。于意所识法诸触等触现触已触当触。是名意触。眼触所生受云何。谓眼及色为缘生于眼识。三和合故触。触为缘受。此中眼为增上色为所缘。眼触为因。眼触为集。眼触种类。眼触为缘。眼触所生。作意相应。于眼所识色诸受等受各别等受已受当受受所摄。是名眼触所生受。耳鼻舌身意触所生受云何。谓意及法为缘生于意识。三和合故触。触为缘受。此中意为增上法为所缘。意触为因。意触为集。意触种类。意触为缘。意触所生作意相应。于意所识法。诸受等受各别等受已受当受受所摄。是名意触所生受。眼触所生想云何。谓眼及色为缘生于眼识。三和合故触。触为缘想。此中眼为增上色为所缘。眼触为因。眼触为集。眼触种类。眼触为缘。眼触所生作意相应。于眼所识色诸想等想各别等想。现前等想已想当想。是名眼触所生想。耳鼻舌身意触所生想云何。谓意及法。为缘生于意识。三和合故触。触为缘想。此中意为增上法为所缘。意触为因。意触为集。意触种类。意触为缘。意触所生作意相应。于意所识法。诸想等想各别等想。现前等想已想当想。是名意触所生想。眼触所生思云何。谓眼及色为缘生于眼识。三和合故触。触为缘思。此中眼为增上色为所缘。眼触为因。眼触为集。眼触种类。眼触为缘。眼触所生作意相应。于眼所识色。诸思等思各别等思。现前等思已思当思。思所摄造心意业。是名眼触所生思。耳鼻舌身意触所生思云何。谓意及法为缘生于意识。三和合故触。触为缘思。此中意为增上法为所缘。意触为因。意触为集。意触种类。意触为缘。意触所生作意相应。于意所识法。诸思等思各别等思。现前等思已思当思。思所摄造心意业。是名意触所生思。眼触所生爱云何。谓眼及色为缘生于眼识。三和合故触。触为缘故受。受为缘爱。此中眼为增上色为所缘。于眼所识色。诸贪等贪。执藏防护。爱乐耽着。是名眼触所生爱。耳鼻舌身意触所生爱云何。谓意及法为缘生于意识。三和合故触。触为缘受。受为缘爱。此中意为增上法为所缘。于意所识法。诸贪等贪。执藏防护。爱乐耽着。是名意触所生爱

    分别品第二中初门

  门有八十八　　初异类三门
  谓受并识身　　及无惭无愧
  余门八十五　　谓受等次第
  相应不相应　　一行界处蕴

五受根。谓乐根苦根喜根忧根舍根。大地法受与五受根。几相应几不相应。乃至意触所生爱与五受根。几相应几不相应。大地法受五受根无相应者。皆不相应。大地法想五受根。一切相应。无不相应者。如想思触作意欲胜解念三摩地慧亦尔。不信五受根。五根相应。五根不相应。如不信。余大烦恼地法亦尔。忿恨恼嫉害。二根相应。谓忧舍。五根不相应。覆诳谄三根相应。除乐苦。五根不相应。憍四根相应除苦。五根不相应。悭二根相应。谓喜舍。五根不相应。欲贪色贪。三根相应除苦忧。五根不相应。无色贪一根相应。谓舍。五根不相应。嗔三根相应。除乐喜。五根不相应。疑四根相应。除苦。五根不相应。五见中邪见。四根相应。除苦。五根不相应。余四见三根相应。除苦忧。五根不相应。有对触三根相应。除喜忧。四根不相应。除苦。增语触四根相应除。苦三根不相应除喜忧。明触三根相应。除苦忧。五根不相应。无明触及非明非无明触。五根相应。五根不相应。乐根无相应者。皆不相应。如乐根。苦根喜根忧根舍根亦尔。寻伺五根相应。三根不相应。除苦忧。识五根相应。无不相应者。无惭无愧五根相应。五根不相应。眼识三根相应。除喜忧。五根不相应。如眼识耳鼻舌身识亦尔意识四根相应。除苦三根不相应。除喜忧。如六识身。六触身六想身六思身亦尔。眼触所生受五受根无相应者。皆不相应。如眼触所生受余受身亦尔眼触所生爱二根相应。谓乐舍。五根不相应。如眼触所生爱。耳鼻舌身触所生爱亦尔。意触所生爱三根相应。除苦忧五根不相应

    分别品第二中第二门

六识身。谓眼识耳识鼻识舌识身识意识。大地法受与六识身。几相应几不相应。乃至意触所生爱与六识身。几相应几不相应。大地法受六识身。一切相应。无不相应者。如大地法受。余大地法亦尔。不信六识相应。六识不相应。如不信。余大烦恼地法亦尔。忿一识相应。谓意。六识不相应。如忿余小烦恼地法亦尔。欲贪六识相应。六识不相应。如欲贪嗔亦尔。色贪四识相应。除鼻舌。六识不相应。无色贪疑一识相应。谓意。六识不相应。五见一识相应。谓意。六识不相应。有对触五识相应。除意。一识不相应。谓意。增语触一识相应。谓意。五识不相应。除意。明触一识相应。谓意。六识不相应。无明触及非明非无明触。六识相应。六识不相应。乐根舍根六识相应。六识不相应。苦根五识相应。除意。六识不相应。喜根忧根一识相应。谓意。六识不相应。寻伺六识相应。一识不相应。谓意。识法六识身。无相应者。皆不相应。无惭无愧。六识相应。六识不相应。眼识六识身。无相应者。皆不相应。如眼识耳鼻舌身意识亦尔。眼触一识相应。谓眼。五识不相应。除眼。如眼触耳鼻舌身意触随所应亦尔。如六触身。六受身六想身六思身亦尔。眼触所生爱一识相应。谓眼。六识不相应。如眼触所生爱。耳鼻舌身意触所生爱随所应亦尔

    分别品第二中第三门

二法。谓无惭无愧。大地法受。与此二法。几相应几不相应。乃至意触所生爱。与此二法。几相应几不相应。大地法受。诸不善者二法相应。无不相应者。余受无相应者。皆不相应。如大地法受。余大地法亦尔。不信诸不善者二法相应。无不相应者。余不信无相应者。皆不相应。如不信余大烦恼地法亦尔。忿恨覆恼嫉悭害。皆二法相应。无不相应者。诳谄憍诸不善者二法相应。无不相应者。余诳谄憍无相应者。皆不相应。欲贪嗔恚。俱二法相应。无不相应者。色贪无色贪。无相应者。俱不相应。疑诸不善者。二法相应。无不相应者。余疑无相应者。定不相应。五见中二见无相应者。俱不相应。三见诸不善者。皆二法相应。无不相应者。余三见无相应者。皆不相应。有对增语无明触。诸不善者皆二法相应。无不相应者。余三触无相应者。皆不相应。明触非明非无明触。无相应者。俱不相应。乐根诸不善者。二法相应。无不相应者。余乐根无相应者。定不相应。如乐根苦喜忧舍根亦尔。寻伺识法诸不善者。皆二法相应。无不相应者。余寻伺识法。无相应者。皆不相应。无惭与无愧定相应。无不相应者。与无惭定不相应。无相应者。无愧与无惭定相应。无不相应者。与无愧定不相应。无相应者。眼识诸不善者。二法相应。无不相应者。余眼识无相应者。皆不相应。如眼识耳鼻舌身意识亦尔。如六识身。六触身六受身六想身六思身亦尔。眼耳身意触所生爱。诸不善者。皆二法相应。无不相应者。余眼耳身意触所生爱。无相应者。皆不相应。鼻舌触所生爱。俱二法相应。无不相应者

说一切有部界身足论卷上阿毗达磨界身足论卷中

        尊者世友造

        三藏法师玄奘奉　诏译

    分别品第二中第四门

受相应。想不相应。十八界十二处五蕴受相应。何所摄。谓心心所法。八界二处三蕴。此何为余。谓受自性。色无为心不相应行。十一界。十一处三蕴。想不相应。何所摄。谓想自性。色无为心不相应行。十一界。十一处三蕴。此何所问。谓除受相应及想不相应法。即除一切法十八界十二处五蕴此下二事虽各除一而文影略显各除二不尔不应除一切法受等自体不被除故想相应。受不相应。十八界十二处五蕴想相应。何所摄。谓心心所法。八界二处三蕴。此何为余。谓想自性。色无为心不相应行十一界十一处三蕴。受不相应。何所摄。谓受自性。色无为。心不相应行。十一界。十一处三蕴。此何所问。谓除想相应及受不相应法。即除一切法十八界十二处五蕴。如以受对想。乃至以受对慧亦尔。受相应不信不相应。十八界十二处五蕴受相应。何所摄。谓心心所法。八界二处三蕴。此何为余。谓受自性。色无为。心不相应行。十一界。十一处三蕴。不信不相应。何所摄。谓不信自性。色无为心不相应行十八界十二处五蕴。此何所问。谓除受相应及不信不相应法。即除一切法十八界十二处五蕴。不信相应。受不相应。十八界十二处五蕴不信相应。何所摄。谓心心所法。八界二处四蕴。此何为余。谓不信自性。色无为心不相应行十八界十二处五蕴。受不相应。何所摄。谓受自性。色无为心不相应行十一界十一处三蕴。此何所问。谓除不信相应及受不相应法。即除一切法十八界十二处五蕴。如以受对不信。对余大烦恼地法欲贪嗔无明触非明非无明触无惭无愧亦尔。受相应忿不相应。十八界十二处五蕴受相应。何所摄。谓心心所法。八界二处三蕴。此何为余。谓受自性。色无为心不相应行十一界十一处三蕴。忿不相应。何所摄。谓忿自性。色无为心不相应行。十八界十二处五蕴。此何所问。谓除受相应及忿不相应法。即除一切法十八界十二处五蕴。忿相应受不相应。十八界十二处五蕴忿相应。何所摄。谓心心所法。三界二处四蕴。此何为余。谓忿自性。色无为心不相应行。十八界十二处五蕴受不相应。何所摄。谓受自性。色无为心不相应行。十一界十一处三蕴。此何所问。谓除忿相应及受不相应法。即除一切法十八界十二处五蕴。如以受对忿。对余小烦恼地法无色贪疑五见明触六爱身亦尔。受相应。色贪不相应。十八界十二处五蕴受相应。何所摄。谓心心所法。八界二处三蕴。此何为余。谓受自性。色无为心不相应行十一界十一处三蕴。色贪不相应。何所摄。谓色贪自性。色无为心不相应行。十八界十二处五蕴。此何所问。谓除受相应及色贪不相应法。即除一切法十八界十二处五蕴。色贪相应。受不相应。十八界十二处五蕴色贪相应。何所摄。谓心心所法。六界二处四蕴。此何为余。谓色贪自性。色无为心不相应行。十八界十二处五蕴。受不相应。何所摄。谓受自性。色无为心不相应行。十一界十一处三蕴。此何所问。谓除色贪相应及受不相应法。即除一切法十八界十二处五蕴。受相应有对触不相应。十八界十二处五蕴。受相应。何所摄。谓心心所法。八界二处三蕴。此何为余。谓受自性。色无为心不相应行。十一界十一处三蕴。有对触不相应。何所摄。谓有对触自性。色无为心不相应行。十三界十二处五蕴。此何所问。谓除受相应及有对触不相应法。即除一切法十八界十二处五蕴。有对触相应。受不相应。十八界十二处五蕴。有对触相应。何所摄。谓心心所法。七界二处四蕴。此何为余。谓有对触自性。色无为心不相应行。十三界十二处五蕴。受不相应。何所摄。谓受自性。色无为心不相应行。十一界十一处三蕴。此何所问。谓除有对触相应及受不相应法。即除一切法十八界十二处五蕴。受相应。增语触不相应。十八界十二处五蕴受相应。何所摄。谓心心所法。八界二处三蕴。此何为余。谓受自性。色无为心不相应行。十一界十一处三蕴。增语触。不相应。何所摄。谓增语触自性。色无为心不相应行。十七界十二处五蕴。此何所问。谓除受相应及增语触不相应法。即除一切法十八界十二处五蕴。增语触相应。受不相应。十八界十二处五蕴。增语触相应。何所摄。谓心心所法。三界二处四蕴。此何为余。谓增语触自性。色无为心不相应行。十七界十二处五蕴。受不相应。何所摄。谓受自性。色无为心不相应行。十一界十一处三蕴。此何所问。谓除增语触相应及受不相应法。即除一切法十八界十二处五蕴。受相应。寻不相应。十八界十二处五蕴。受相应。何所摄。谓心心所法。八界二处三蕴。此何为余。谓受自性。色无为心不相应行。十一界十一处三蕴。寻不相应。何所摄。谓寻自性。色无为心不相应行。十三界十二处五蕴。此何所问。谓除受相应及寻不相应法。即除一切法十八界十二处五蕴。寻相应。受不相应。十八界十二处五蕴。寻相应。何所摄。谓心心所法。八界二处四蕴。此何为余。谓寻自性。色无为心不相应行。十三界十二处五蕴。受不相应。何所摄。谓受自性。色无为心不相应行。十一界十一处三蕴。此何所问。谓除寻相应及受不相应法。即除一切法十八界十二处五蕴。如以受对寻。对伺亦尔。受相应。识不相应。十八界十二处五蕴。受相应。何所摄。谓心心所法。八界二处三蕴。此何为余。谓受自性。色无为心不相应行。十一界十一处三蕴。识不相应。何所摄。谓识自性。色无为心不相应行。十八界十二处三蕴。此何所问。谓除受相应及识不相应法。即除一切法十八界十二处五蕴。识相应。受不相应。十八界十二处五蕴识相应。何所摄。谓心所法。一界一处三蕴。此何为余。谓识自性。色无为心不相应行。十八界十二处三蕴。受不相应。何所摄。谓受自性。色无为心不相应行。十一界十一处三蕴。此何所问。谓除识相应及受不相应法。即除一切法十八界十二处五蕴。受相应眼识不相应。十八界十二处五蕴。受相应。何所摄。谓心心所法。八界二处三蕴。此何为余。谓受自性。色无为心不相应行。十一界十一处三蕴。眼识不相应。何所摄。谓眼识自性。色无为心不相应行。十八界十二处五蕴。此何所问。谓除受相应及眼识不相应法。即除一切法十八界十二处五蕴。眼识相应。受不相应。十八界十二处五蕴。眼识相应。何所摄。谓心所法。一界一处三蕴。此何为余。谓眼识自性。色无为心不相应行。十八界十二处五蕴。受不相应。何所摄。谓受自性色无为心不相应行。十一界十一处三蕴。此何所问。谓除眼识相应及受不相应法。即除一切法十八界十二处五蕴。如以受对眼识。乃至对意识亦尔。受相应眼触不相应。十八界十二处。五蕴受相应。何所摄。谓心心所法。八界二处三蕴。此何为余。谓受自性。色无为心不相应行。十一界十一处三蕴。眼触不相应。何所摄。谓眼触自性。色无为心不相应行。十七界十二处五蕴。此何所问。谓除受相应及眼触不相应法。即除一切法十八界十二处五蕴。眼触相应。受不相应。十八界十二处五蕴。眼触相应。何所摄。谓心心所法。三界二处四蕴。此何为余。谓眼触自性。色无为心不相应行。十七界十处五蕴。受不相应。何所摄。谓受自性色无为心不相应行。十一界十一处三蕴此何所问。谓除眼触相应及受不相应法。即除一切法十八界十二处五蕴。如以受对眼触。乃至对意触亦尔。如以受对六触身。对六想身六思身。广说亦尔

    分别品第二中第五门

想相应。思不相应十八界十二处五蕴想相应。何所摄。谓心心所法。八界二处三蕴。此何为余。谓想自性。色无为心不相应行。十一界十一处三蕴思不相应。何所摄。谓思自性。色无为心不相应行。十一界十一处二蕴。此何所问。谓除想相应及思不相应法。即除一切法十八界十二处五蕴。思相应。想不相应。十八界十二处五蕴思相应。何所摄。谓心心所法。八界二处四蕴。此何为余。谓思自性。色无为心不相应行。十一界十一处二蕴想不相应。何所摄。谓想自性。色无为心不相应行。十一界十一处三蕴。此何所问。谓除思相应及想不相应法。即除一切法十八界十二处五蕴。如以想对思。乃至对慧亦尔。想相应不信不相应。十八界十二处五蕴想相应。何所摄。谓心心所法。八界二处三蕴。此何为余。谓想自性。色无为心不相应行。十一界十一处三蕴。不信不相应。何所摄。谓不信自性。色无为心不相应行。十八界十二处五蕴。此何所问。谓除想。相应及不信不相应法。即除一切法十八界十二处五蕴。不信相应想不相应。十八界十二处五蕴。不信相应。何所摄。谓心心所法。八界二处四蕴。此何为余。谓不信自性。色无为心不相应行。十八界十二处五蕴。想不相应。何所摄。谓想自性。色无为心不相应行。十一界十一处三蕴。此何所问。谓除不信相应及想不相应法。即除一切法十八界十二处五蕴。如以想对不信。对余大烦恼地法欲贪嗔无明触非明非无明触无惭无愧亦尔。想相应。忿不相应。十八界十二处五蕴想相应。何所摄。谓心心所法。八界二处三蕴。此何为余。谓想自性。色无为心不相应行。十一界十一处三蕴。忿不相应。何所摄。谓忿自性。色无为心不相应行。十八界十二处五蕴。此何所问。谓除想相应及忿不相应法。即除一切法十八界十二处五蕴。忿相应。想不相应。十八界十二处五蕴。忿相应。何所摄。谓心心所法。三界二处四蕴。此何为余。谓忿自性。色无为心不相应行。十八界十二处五蕴。想不相应。何所摄。谓想自性。色无为心不相应行。十一界十一处三蕴。此何所问。谓除忿相应及想不相应法。即除一切法十八界十二处五蕴。如以想对忿。对余小烦恼地法无色贪疑五见明触六爱身亦尔。想相应。色贪不相应。十八界十二处五蕴想相应。何所摄。谓心心所法。八界二处三蕴。此何为余。谓想自性。色无为心不相应行。十一界十一处三蕴。色贪不相应。何所摄。谓色贪自性。色无为心不相应行。十八界十二处五蕴。此何所问。谓除想相应及色贪不相应法。即除一切法十八界十二处五蕴。色贪相应。想不相应。十八界十二处五蕴。色贪相应。何所摄。谓心心所法。六界二处四蕴。此何为余。谓色贪自性。色无为心不相应行。十八界十二处五蕴。想不相应。何所摄。谓想自性。色无为心不相应行。十一界十一处三蕴。此何所问。谓除色贪相应想不相应。即除一切法十八界十二处五蕴。想相应。有对触不相应。十八界十二处五蕴想相应。何所摄。谓心心所法。八界二处三蕴。此何为余。谓想自性。色无为心不相应行。十一界十一处三蕴。有对触不相应。何所摄。谓有对自性。色无为心不相应行。十三界十二处五蕴。此何所问。谓除想相应及有对触不相应法。即除一切法十八界十二处五蕴。有对触相应。想不相应。十八界十二处五蕴。有对触相应。何所摄。谓心心所法。七界二处四蕴。此何为余。谓有对触自性。色无为心不相应行。十三界十二处五蕴。想不相应。何所摄。谓想自性。色无为心不相应行。十一界十一处三蕴。此何所问。谓除有对触相应及想不相应法。即除一切法十八界十二处五蕴。想相应。增语触不相应。十八界十二处五蕴想相应。何所摄。谓心心所法。八界二处三蕴。此何为余。谓想自性。色无为心不相应行。十一界十一处三蕴。增语触不相应。何所摄。谓增语触自性。色无为心不相应行。十七界十二处五蕴。此何所问。谓除想相应及增语触不相应法。即除一切法十八界十二处五蕴。增语触相应。想不相应。十八界十二处五蕴。增语触相应。何所摄。谓心心所法。三界二处四蕴。此何为余。谓增语触自性。色无为心不相应行。十七界十二处五蕴。想不相应何所摄。谓想自性。色无为心不相应行。十一界十一处三蕴。此何所问。谓除增语触相应及想不相应法。即除一切法十八界十二处五蕴

想相应。乐根不相应。十八界十二处五蕴想相应。何所摄。谓心心所法。八界二处三蕴。此何为余。谓想自性。色无为心不相应行。十一界十一处三蕴。乐根不相应。何所摄。谓乐根自性。色无为心不相应行。十八界十二处五蕴。此何所问。谓除想相应及乐根不相应法。即除一切法十八界十二处五蕴。乐根相应。想不相应。十八界十二处五蕴。乐根相应。何所摄。谓心心所法。八界二处三蕴。此何为余。谓乐根自性。色无为心不相应行。十八界十二处五蕴。想不相应。何所摄。谓想自性。色无为心不相应行。十一界十一处三蕴。此何所问。谓除乐根相应及想不相应法。即除一切法十八界十二处五蕴。如以想对乐根。对舍根亦尔想相应。苦根不相应。十八界十二处五蕴想相应何所摄。谓心心所法八界二处三蕴。此何为余。谓想自性。色无为心。不相应行。十一界十一处三蕴。苦根不相应何所摄。谓苦根自性。色无为心不相应行。十八界十二处五蕴。此何所问。谓除想相应及苦根不相应法。即除一切法十八界十二处五蕴。苦根相应。想不相应。十八界十二处五蕴。苦根相应。何所摄。谓心心所法。七界二处三蕴。此何为余。谓苦根自性。色无为心不相应行。十八界十二处五蕴。想不相应。何所摄。谓想自性。色无为心不相应行。十一界十一处三蕴。此何所问。谓除苦根相应及想不相应法。即除一切法十八界十二处五蕴。想相应。喜根不相应。十八界十二处五蕴想相应。何所摄。谓心心所法。八界二处三蕴。此何为余。谓想自性。色无为心不相应行。十一界十一处三蕴。喜根不相应。何所摄。谓喜根自性。色无为。心不相应行。十八界十二处五蕴。此何所问。谓除想相应及喜根不相应法。即除一切法十八界十二处五蕴。喜根相应。想不相应。十八界十二处五蕴。喜根相应。何所摄。谓心心所法。三界二处三蕴。此何为余。谓喜根自性。色无为。心不相应行。十八界十二处五蕴。想不相应。何所摄。谓想自性。色无为心不相应行。十一界十一处三蕴。此何所问。谓除喜根相应及想不相应法。即除一切法十八界十二处五蕴。如以想对喜根。对忧根亦尔。以思对寻伺识法六识身六触身六思身。皆如受门中说。唯于受处应说其想。想相应。眼触所生受不相应。十八界十二处五蕴想相应。何所摄。谓心心所法。八界二处三蕴。此何为余。谓想自性。色无为心不相应行。十一界十一处三蕴。眼触所生受不相应。何所摄。谓眼触所生受自性。色无为心不相应行。十七界十二处五蕴。此何所问。谓除想相应及眼触所生受不相应法。即除一切法十八界十二处五蕴。眼触所生受相应。想不相应。十八界十二处五蕴。眼触所生受相应。何所摄。谓心心所法。三界二处三蕴。此何为余。谓眼触所生受自性。色无为心不相应行。十七界十二处五蕴。想不相应。何所摄。谓想自性。色无为心不相应行。十一界十一处三蕴。此何所问。谓除眼触所生受相应及想不相应法。即除一切法十八界十二处五蕴。如以想对眼触所生受。乃至对意触所生受。随其所应广说亦尔

    分别品第二中第六门

思相应。触不相应。十八界十二处五蕴思相应。何所摄。谓心心所法。八界二处四蕴。此何为余。谓思自性。色无为心不相应行。十一界十一处二蕴。触不相应。何所摄。谓触自性。色无为心不相应行。十一界十一处二蕴。此何所问。谓除思相应及触不相应法。即除一切法十八界十二处五蕴。触相应。思不相应。十八界十二处五蕴触相应。何所摄。谓心心所法。八界二处四蕴。此何为余。谓触自性。色无为。心不相应行。十一界十一处二蕴。思不相应。何所摄。谓思自性。色无为。心不相应行。十一界十一处二蕴。此何所问。谓除触相应及思不相应法。即除一切法十八界十二处五蕴。如以思对触。乃至对慧亦尔。思相应。不信不相应。十八界十二处五蕴思相应。何所摄。谓心心所法。八界二处四蕴。此何为余。谓思自性。色无为。心不相应行。十一界十一处二蕴。不信不相应。何所摄。谓不信自性。色无为。心不相应行。十八界十二处五蕴。此何所问。谓除思相应及不信不相应法。即除一切法十八界十二处五蕴。不信相应。思不相应。十八界十二处五蕴。不信相应。何所摄。谓心心所法。八界二处四蕴。此何为余。谓不信自性。色无为心不相应行。十八界十二处五蕴。思不相应。何所摄。谓思自性。色无为心不相应行。十一界十一处二蕴。此何所问。谓除不信相应及思不相应法。即除一切法十八界十二处五蕴。如以思对不信。对余大烦恼地法欲贪嗔无明触非明非无明触无惭无愧亦尔。思相应。忿不相应。十八界十二处五蕴思相应。何所摄。谓心心所法。八界二处四蕴。此何为余。谓思自性。色无为心不相应行。十一界十一处二蕴。忿不相应。何所摄。谓忿自性。色无为心不相应行。十八界十二处五蕴。此何所问。谓除思相应及忿不相应法。即除一切法十八界十二处五蕴。忿相应。思不相应。十八界十二处五蕴。忿相应。何所摄。谓心心所法。三界二处四蕴。此何为余。谓忿自性。色无为。心不相应行。十八界十二处五蕴。思不相应。何所摄。谓思自性。色无为心不相应行十一界十一处二蕴此何所问。谓除忿相应及思不相应法。即除一切法十八界十二处五蕴。如以思对忿。对余小烦恼地法无色贪疑五见明触六爱身亦尔。思相应。色贪不相应。十八界十二处五蕴思相应。何所摄。谓心心所法。八界二处四蕴。此何为余。谓思自性。色无为心不相应行。十一界。十一处。二蕴。色贪不相应。何所摄。谓色贪自性。色无为心不相应行。十八界十二处五蕴。此何所问。谓除思相应及色贪不相应法。即除一切法十八界十二处五蕴。色贪相应。思不相应。十八界十二处五蕴。色贪相应。何所摄。谓心心所法。六界二处四蕴。此何为余。谓色贪自性。色无为心不相应行。十八界十二处五蕴。思不相应。何所摄。谓思自性。色无为心不相应行。十一界十一处二蕴。此何所问。谓除色贪相应及思不相应法。即除一切法十八界十二处五蕴。思相应。有对触不相应。十八界十二处五蕴思相应。何所摄。谓心心所法。八界二处四蕴。此何为余。谓思自性。色无为心不相应行。十一界十一处二蕴。有对触不相应。何所摄。谓有对触自性。色无为心不相应行。十三界十二处五蕴。此何所问。谓除思相应及有对触不相应法。即除一切法十八界十二处五蕴。有对触相应。思不相应。十八界十二处五蕴。有对触相应。何所摄。谓心心所法。七界二处四蕴。此何为余。谓有对触自性。色无为心不相应行。十三界十二处五蕴。思不相应何所摄。谓思自性。色无为心不相应行。十一界十一处二蕴。此何所问。谓除有对触相应及思不相应法。即除一切法十八界十二处五蕴。思相应。增语触不相应。十八界十二处五蕴。思相应如前。乃至二蕴增语触不相应如前。乃至五蕴如思相应。增语触不相应如是。增语触相应。思不相应随所应当广说。思相应。乐根不相应。乐根相应。思不相应。随所应当广说。如以思对乐根。对舍根亦尔。思相应苦根不相应。苦根相应思不相应。随所应当广说。思相应。喜根不相应。喜根相应。思不相应。随所应当广说。如以思对喜根。对忧根亦尔。以思对寻伺识法六识身六触身六受身六想身。随所应当广说

说一切有部界身足论卷中阿毗达磨界身足论卷下

        尊者世友造

        三藏法师玄奘奉　诏译

    分别品第二中第七门

触相应。作意不相应。十八界十二处五蕴。触相应如前。乃至二蕴。作意不相应。何所摄。谓作意自性。色无为。心不相应行。十一界十一处二蕴。此何所问。谓除触相应及作意不相应法。即除一切法十八界十二处五蕴。作意相应。触不相应。十八界十二处五蕴。作意相应。何所摄。谓心心所法。八界二处四蕴。此何为余。谓作意自性。色无为心不相应行。十一界十一处二蕴。触不相应等如前说。如以触对作意。乃至对慧亦尔。触相应。不信不相应。不信相应。触不相应。随所应当广说。如以触对不信。对余大烦恼地法欲贪嗔无惭无愧亦尔。触相应忿不相应。忿相应触不相应。随所应当广说。如以触对忿。对余小烦恼地法无色贪疑五见六爱身亦尔。触相应。色贪不相应。色贪相应。触不相应。随所应当广说。触相应。乐根不相应。乐根相应。触不相应。随所应当广说。如以触对乐根。对舍根亦尔。触相应。苦根不相应。苦根相应。触不相应。随所应当广说。触相应。喜根不相应。喜根相应。触不相应。随所应当广说。如以触对喜根。对忧根亦尔。以触对寻伺识法六识身六受身六想身六思身。随所应当广说

    分别品第二中第八门

作意相应。欲不相应。十八界十二处五蕴。作意相应等如前说。欲不相应。何所摄。谓欲自性。色无为。心不相应行。十一界十一处二蕴。此何所问。如前说。欲相应。作意不相应。十八界十二处五蕴欲相应。何所摄。谓心心所法。八界二处四蕴。此何为余。谓欲自性。色无为。心不相应行。十一界十一处二蕴。作意不相应等如前说。如以作意对欲。乃至对慧亦尔。作意相应。不信不相应。不信相应。作意不相应。随所应当广说。如以作意对不信。对余大烦恼地法欲贪嗔无明。触非明非无明触无惭无愧亦尔。作意相应。忿不相应。忿相应。作意不相应。随所应当广说。如以作意对忿。对余小烦恼地法无色贪疑五见明触六爱身亦尔。作意相应。色贪不相应。色贪相应。作意不相应。随所应当广说。作意相应。有对触不相应。有对触相应。作意不相应。随所应当广说。作意相应。增语触不相应。增语触相应。作意不相应。随所应当广说。作意相应。乐根不相应。乐根相应。作意不相应。随所应当广说。如以作意对乐根。对舍根亦尔。作意相应。苦根不相应。苦根相应。作意不相应。随所应当广说。作意相应。喜根不相应。喜根相应。作意不相应。随所应当广说。如以作意对喜根。对忧根亦尔。以作意对寻伺识法六识身六触身六受身六想身六思身。随所应当广说

    分别品第二中第九门

欲相应。胜解不相应。十八界十二处五蕴。欲相应等如前说。胜解不相应。何所摄。谓胜解自性。色无为心不相应行。十一界十一处二蕴。此何所问。谓除欲相应及胜解不相应法。即除一切法十八界十二处五蕴胜解相应。欲不相应。十八界十二处五蕴。胜解相应。何所摄。谓心心所法。八界二处四蕴。此何为余。谓胜解自性。色无为。心不相应行。十一界十一处二蕴。欲不相应等如前说。如以欲对胜解。对念三摩地慧亦尔。欲相应。不信不相应。不信相应。欲不相应。随所应当广说。如以欲对不信。对余大烦恼地法欲贪嗔无明触非明非无明触无惭无愧亦尔。欲相应。忿不相应。忿相应。欲不相应。随所应当广说。如以欲对忿。对余小烦恼地法无色贪疑五见明触六爱身亦尔。欲相应。色贪不相应。色贪相应欲不相应。随所应当广说。欲相应。有对触不相应。有对触相应。欲不相应。随所应当广说。欲相应增语触不相应。增语触相应。欲不相应。随所应当广说。欲相应。乐根不相应。乐根相应。欲不相应。随所应当广说。如以欲对乐根。对舍根亦尔。欲相应。苦根不相应。苦根相应。欲不相应。随所应当广说。欲相应。喜根不相应。喜根相应。欲不相应。随所应当广说。如以欲对喜根。对忧根亦尔。以欲对寻伺识法六识身六触身六受身六想身六思身。随所应当广说

    分别品第二中第十门

胜解相应。念不相应。十八界十二处五蕴。胜解相应等如前说。念不相应。何所摄。谓念自性。色无为心不相应行。十一界十一处二蕴。此何所问。如前说。念相应。胜解不相应。十八界十二处五蕴念相应。何所摄。谓心心所法。八界二处四蕴。此何为余。谓念自性。色无为。心不相应行。十一界十一处二蕴。胜解不相应等如前说。如以胜解对念。对三摩地慧亦尔。胜解相应。不信不相应。不信相应。胜解不相应。随所应当广说。如以胜解对不信。对余大烦恼地法欲贪嗔无明触非明非无明触无惭无愧亦尔。胜解相应。忿不相应。忿相应。胜解不相应。随所应当广说。如以胜解对忿。对余小烦恼地法无色贪疑五见明触六爱身亦尔。胜解相应。色贪不相应。色贪相应。胜解不相应。随所应当广说。胜解相应。有对触不相应。有对触相应。胜解不相应。随所应当广说。胜解相应。增语触不相应。增语触相应。胜解不相应。随所应当广说。胜解相应。乐根不相应。乐根相应。胜解不相应。随所应当广说。如以胜解对乐根。对舍根亦尔。胜解相应。苦根不相应。苦根相应。胜解不相应。随所应当广说。胜解相应。喜根不相应。喜根相应。胜解不相应。随所应当广说。如以胜解对喜根。对忧根亦尔。以胜解对寻伺识法六识身六触身六受身六想身六思身。随所应当广说

    分别品第二中第十一门

念相应。三摩地不相应。十八界十二处五蕴。念相应等如前说。三摩地不相应。何所摄。谓三摩地自性。色无为。心不相应行。十一界十一处二蕴。此何所问。如前说。三摩地相应。念不相应。十八界十二处五蕴。三摩地相应。何所摄。谓心心所法。八界二处四蕴。此何为余。谓三摩地自性。色无为。心不相应行。十一界十一处二蕴。念不相应等如前说。如以念对三摩地。对慧亦尔。念相应。不信不相应。不信相应。念不相应。随所应当广说。如以念对不信。对余大烦恼地法。欲贪嗔无明触非明非无明触无惭无愧亦尔。念相应。忿不相应。忿相应。念不相应。随所应当广说。如以念对忿。对余小烦恼地法无色贪疑五见明触六爱身亦尔。念相应。色贪不相应。色贪相应。念不相应。随所应当广说。念相应。有对触不相应。有对触相应。念不相应。随所应当广说。念相应。增语触不相应。增语触相应。念不相应。随所应当广说。念相应。乐根不相应。乐根相应。念不相应。随所应当广说。如以念对乐根。对舍根亦尔。念相应。苦根不相应。苦根相应。念不相应。随所应当广说。念相应。喜根不相应。喜根相应。念不相应。随所应当广说。如以念对喜根。对忧根亦尔。以念对寻伺识法六识身六触身六受身六想身六思身。随所应当广说

    分别品第二中第十二门

三摩地相应。慧不相应。十八界十二处五蕴。三摩地相应等如前说。慧不相应。何所摄。谓慧自性。色无为。心不相应行。十一界十一处二蕴。此何所问。如前说。慧相应。三摩地不相应。十八界十二处五蕴慧相应。何所摄。谓心心所法。八界二处四蕴。此何为余。谓慧自性。色无为心不相应行。十一界十一处二蕴。三摩地不相应等如前说。三摩地相应。不信不相应。不信相应。三摩地不相应。随所应当广说。如以三摩地对不信。对余大烦恼地法欲贪嗔无明触非明非无明触无惭无愧亦尔。三摩地相应。忿不相应。忿相应。三摩地不相应。随所应当广说。如以三摩地对忿。对余小烦恼地法无色贪疑五见明触六爱身亦尔。三摩地相应。色贪不相应。色贪相应。三摩地不相应。随所应当广说。三摩地相应。有对触不相应。有对触相应。三摩地不相应。随所应当广说。三摩地相应。增语触不相应。增语触相应。三摩地不相应。随所应当广说。三摩地相应。乐根不相应。乐根相应。三摩地不相应。随所应当广说。如以三摩地对乐根。对舍根亦尔。三摩地相应。苦根不相应。苦根相应。三摩地不相应。随所应当广说。三摩地相应。喜根不相应。喜根相应。三摩地不相应。随所应当广说。如以三摩地对喜根。对忧根亦尔。以三摩地。对寻伺识法六识身六触身六受身六想身六思身。随所应当广说

    分别品第二中第十三门

慧相应。不信不相应。不信相应。慧不相应。随所应当广说。如以慧对不信。对余大烦恼地法欲贪嗔无明触非明非无明触无惭无愧亦尔。慧相应。忿不相应。忿相应。慧不相应。随所应当广说。如以慧对忿余小烦恼地法无色贪疑五见明触六爱身亦尔。慧相应。色贪不相应。色贪相应。慧不相应。随所应当广说。慧相应。有对触不相应。有对触相应。慧不相应。随所应当广说。慧相应。增语触不相应。增语触相应。慧不相应。随所应当广说。慧相应。乐根不相应。乐根相应。慧不相应。随所应当广说。如以慧对乐根。对舍根亦尔。慧相应。苦根不相应。苦根相应。慧不相应。随所应当广说。慧相应。喜根不相应。喜根相应。慧不相应。随所应当广说。如以慧对喜根。对忧根亦尔。以慧对寻伺识法六识身六触身六受身六想身六思身。随所应当广说

    分别品第二中第十四门

不信相应。懈怠不相应。十八界十二处五蕴。不信相应等如前说。懈怠不相应。何所摄。谓懈怠自性。色无为。心不相应行。十八界十二处五蕴。此何所问。如前说。懈怠相应。不信不相应。十八界十二处五蕴。懈怠相应。何所摄。谓心心所法八界二处四蕴。此何为余。谓懈怠自性色无为心不相应行。十八界十二处五蕴。不信不相应等如前说。如以不信对懈怠。对余大烦恼地法欲贪嗔无明触。非明非无明触无惭无愧亦尔。不信相应。忿不相应。忿相应。不信不相应。随所应当广说。如以不信对忿。对余小烦恼地法无色贪疑五见明触六爱身亦尔。不信相应。色贪不相应。色贪相应。不信不相应。随所应当广说。不信相应。有对触不相应。有对触相应。不信不相应。随所应当广说。不信相应增语触不相应。增语触相应。不信不相应。随所应当广说。不信相应。乐根不相应。乐根相应。不信不相应。随所应当广说。如以不信对乐根。对舍根亦尔。不信相应苦根不相应。苦根相应。不信不相应。随所应当广说。不信相应。喜根不相应。喜根相应。不信不相应。随所应当广说。如以不信对喜根。对忧根亦尔。以不信对寻伺识法六识身六触身六受身六想身六思身。随所应当广说

    分别品第二中第十五门

由斯理趣。其懈怠等诸差别门。应依前说一行方便。如理当思此诸门中。有差别者。相似异位。皆不应说。乃至眼识相应。眼触不相应。十八界十二处五蕴。眼识相应。何所摄。谓心所法。一界一处三蕴。此何为余谓眼识自性。色无为。心不相应行。十八界十二处五蕴。眼触不相应。何所摄。谓眼触自性。色无为。心不相应行。十七界十二处五蕴。此何所问。谓除眼识相应及眼触不相应法。即除一切法十八界十二处五蕴。眼触相应。眼识不相应。十八界十二处五蕴。眼触相应。何所摄。谓心心所法。三界二处四蕴。此何为余。谓眼触自性色无为。心不相应行。十七界十二处五蕴。眼识不相应。何所摄。谓眼识自性。色无为。心不相应行。十八界十二处五蕴。此何所问。谓除眼触相应及眼识不相应法。即除一切法十八界十二处五蕴。如以眼识对眼触。乃至对意触六思身。随所应当广说。眼识相应。眼触所生受不相应。十八界十二处五蕴。眼识相应。何所摄。谓心所法。一界一处三蕴。此何为余。谓眼识自性。色无为。心不相应行。十八界十二处五蕴。眼触所生受不相应。何所摄。谓眼触所生受自性。色无为心不相应行。十七界十二处五蕴。此何所问谓除眼识相应及眼触所生受不相应法。即除一切法十八界十二处五蕴。眼触所生受相应。眼识不相应。十八界十二处五蕴。眼触所生受相应。何所摄。谓心心所法。三界二处三蕴。此何为余。谓眼触所生受自性。色无为心不相应行。十七界十二处五蕴。眼识不相应。何所摄。谓眼识自性。色无为心不相应行。十八界十二处五蕴。此何所问。谓除眼触所生受相应及眼识不相应法。即除一切法十八界十二处五蕴。如以眼识对眼触所生受乃至对意触所生受六想身。随所应当广说。眼识相应。眼触所生爱不相应。十八界十二处五蕴。眼识相应。何所摄。谓心所法。一界一处三蕴。此何为余。谓眼识自性。色无为。心不相应行。十八界十二处五蕴。眼触所生爱不相应。何所摄。谓眼触所生爱自性。色无为。心不相应行。十八界十二处五蕴。此何所问。谓除眼识相应及眼触所生爱不相应法。即除一切法十八界十二处五蕴。眼触所生爱相应。眼识不相应。十八界十二处五蕴。眼触所生爱相应。何所摄。谓心心所法。三界二处四蕴。此何为余。谓眼触所生爱自性。色无为。心不相应行。十八界十二处五蕴。眼识不相应。何所摄。谓眼识自性。色无为心不相应行。十八界十二处五蕴。此何所问。谓除眼触所生爱相应及眼识不相应法。即除一切法十八界十二处五蕴。如以眼识对眼触所生爱乃至对意触所生爱亦尔

    分别品第二中第十六门

如眼识门。如是乃至意识五门。随所应当广说。如六识身六门六触身六门。随所应当广说。眼触所生受相应。眼识所生想不相应。十八界十二处五蕴。眼触所生受相应。何所摄。谓心心所法。三界二处三蕴。此何为余。谓眼触所生受自性。色无为。心不相应行。十七界十二处五蕴。眼触所生想不相应。何所摄。谓眼触所生想自性。色无为。心不相应行。十七界十二处五蕴。此何所问。谓除眼触所生受相应。及眼触所生想不相应法。即除一切法十八界十二处五蕴。眼触所生想相应。眼触所生受不相应。十八界十二处五蕴。眼触所生想相应。何所摄。谓心心所法。三界二处三蕴。此何为余。谓眼触所生想自性。色无为心不相应行。十七界十二处五蕴。眼触所生受不相应。何所摄。谓眼触所生受自性。色无为心不相应行。十七界十二处五蕴。此何所问。谓除眼触所生想相应及眼触所生受不相应法。即除一切法十八界十二处五蕴。如以眼触所生受对眼触所生想。乃至对意触所生想亦尔。眼触所生受相应。眼触所生思不相应。十八界十二处五蕴。眼触所生受相应。何所摄。谓心心所法。三界二处三蕴。此何为余。谓眼触所生受自性。色无为心不相应行。十七界十二处五蕴。眼触所生思不相应。何所摄。谓眼触所生思自性。色无为心不相应行。十七界十二处五蕴。此何所问。谓除眼触所生受相应及眼触所生思不相应法。即除一切法十八界十二处五蕴。眼触所生思相应。眼触所生受不相应。十八界十二处五蕴。眼触所生思相应。何所摄。谓心心所法。三界二处四蕴。此何为余。谓眼触所生思自性。色无为心不相应行。十七界十二处五蕴。眼触所生受不相应。何所摄。谓眼触所生受自性。色无为。心不相应行。十七界十二处五蕴。此何所问。谓除眼触所生思相应及眼触所生受不相应法。即除一切法十八界十二处五蕴。如以眼触所生受对眼触所生思。乃至对意触所生思亦尔。眼触所生受相应。眼触所生爱不相应。十八界十二处五蕴。眼触所生受相应。何所摄。谓心心所法。三界二处三蕴。此何为余。谓眼触所生受自性。色无为心不相应行。十七界十二处五蕴。眼触所生受不相应。何所摄。谓眼触所生爱自性。色无为。心不相应行。十八界十二处五蕴。此何所问。谓除眼触所生爱相应及眼触所生爱不相应法。即除一切法十八界十二处五蕴。眼触所生爱相应。眼触所生受不相应。十八界十二处五蕴。眼触所生爱相应。何所摄。谓心心所法。三界二处四蕴。此何为余。谓眼触所生爱自性。色无为心不相应行。十八界十二处五蕴。眼触所生受不相应。何所摄。谓眼触所生受自性。色无为。心不相应行。十七界十二处五蕴。此何所问。谓除眼触所生爱相应。及眼触所生受不相应法。即除一切法十八界十二处五蕴。如以眼触所生受对眼触所生爱。乃至对意触所生爱亦尔。如眼触所生受门。如是乃至意触所生受五门。随所应当广说。如六受身六门。六想身六门六思身六门。随所应当广说。如是略说有十六门。若广说有八十八门

说一切有部界身足论卷下

    界身足论后序

        沙门释基制

界身足论者。说一切有部发智六足之一足也。详夫邃旨冲微。非大圣无以扬其奥。梵言幽秘。非上哲何以绎其真。是以夕[穴/(爿*未)]金容。晨驰白马。译经者结辙。津义者联踪。至于婆沙八蕴。缺五蕴之幽趣。发智六足。无五足之玄文。余旨虽存。尚多纰绠。故使三秦匠彦。穿凿于异端。九土缁英。滞惑于真伪。故我亲教三藏法师玄奘。业该群籍。志隆弘抚。欲使有宗俊颖。不延颈于五天。对法雄杰。怀慷慨于四主。遂以大

唐龙朔三年六月四日。于玉华宫八桂亭。终译此论。原其大本。颂有六千。后以文繁。或致删略。为九百颂。五百颂者。今此所翻。有八百三十颂。文遗广略。义离增减。详其论始。说起能仁。大德流通遂师名称。尊者世友之所作也。既而道满待机。因圆伫列。神功妙思。繄可殚言。但基虚簉操觚。谬倍函丈。承晖雕斲。受旨执文。惟恐爱海波腾。玄源秘泄。瞩法舟之沦丧。故叙其时事云


阿毗达磨俱舍论

    No. 1558 [No. 1559; cf. Nos. 1560, 1561]

阿毗达磨俱舍论卷第一

        尊者世亲造

        三藏法师玄奘奉　诏译

    分别界品第一

  诸一切种诸冥灭　　拔众生出生死泥
  敬礼如是如理师　　对法藏论我当说

论曰。今欲造论。为显自师其体尊高超诸圣众。故先赞德方申敬礼。诸言所表谓佛世尊。此能破闇故称冥灭。言一切种诸冥灭者。谓灭诸境一切品冥。以诸无知能覆实义及障真见。故说为冥。唯佛世尊得永对治于一切境一切种冥。证不生法故称为灭。声闻独觉虽灭诸冥。以染无知毕竟未断故非一切种。所以者何。由于佛法极远时处及诸义类无边差别。不染无知犹未断故。已赞世尊自利德满。次当赞佛利他德圆。拔众生出生死泥者。由彼生死是诸众生沉溺处故难可出故。所以譬泥。众生于中沦没无救。世尊哀愍随授所应正法教手拔济令出。已赞佛德。次申敬礼。敬礼如是如理师者。稽首接足故称敬礼。诸有具前自他利德。故云如是。如实无倒教授诫勖。名如理师。如理师言显利他德。能方便说如理正教。从生死泥拔众生出。不由威力与愿神通。礼如理师欲何所作。对法藏论我当说者。教诫学徒故称为论。其论者何。谓对法藏。何谓对法。颂曰

  净慧随行名对法　　及能得此诸慧论

论曰。慧谓择法。净谓无漏。净慧眷属名曰随行。如是总说无漏五蕴名为对法。此则胜义阿毗达磨。若说世俗阿毗达磨即能得此。诸慧及论。慧谓得此有漏修慧思闻生得慧及随行。论谓传生无漏慧教。此诸慧论。是彼资粮故亦得名阿毗达磨。释此名者能持自相。故名为法。若胜义法唯是涅槃。若法相法通四圣谛。此能对向或能对观。故称对法。已释对法。何故此论名对法藏。颂曰

  摄彼胜义依彼故　　此立对法俱舍名

论曰。由彼对法论中胜义入此摄故。此得藏名。或此依彼。从彼引生。是彼所藏。故亦名藏。是故此论名对法藏。何因说彼阿毗达磨。谁复先说阿毗达磨。而今造论恭敬解释。颂曰

  若离择法定无余　　能灭诸惑胜方便
  由惑世间漂有海　　因此传佛说对法

论曰。若离择法无胜方便能灭诸惑。诸惑能令世间漂转生死大海。因此传佛说彼对法。欲令世间得择法故。离说对法。弟子不能于诸法相如理简择。然佛世尊处处散说阿毗达磨。大德迦多衍尼子等诸大声闻结集安置。犹如大德法救所集无常品等邬拖南颂。毗婆沙师传说如此。何法名为彼所简择。因此传佛说对法耶。颂曰

  有漏无漏法　　除道余有为
  于彼漏随增　　故说名有漏
  无漏谓道谛　　及三种无为
  谓虚空二灭　　此中空无碍
  择灭谓离系　　随系事各别
  毕竟碍当生　　别得非择灭

论曰。说一切法略有二种。谓有漏无漏。有漏法云何。谓除道谛余有为法。所以者何。诸漏于中等随增故。缘灭道谛诸漏虽生。而不随增故非有漏。不随增义随眠品中自当显说。已辩有漏。无漏云何。谓道圣谛及三无为。何等为三。虚空二灭。二灭者何。择非择灭。此虚空等三种无为及道圣谛。名无漏法。所以者何。诸漏于中不随增故。于略所说三无为中。虚空但以无碍为性。由无障故色于中行。择灭即以离系为性。诸有漏法远离系缚证得解脱。名为择灭。择谓简择即慧差别。各别简择四圣谛故。择力所得灭名为择灭。如牛所驾车名曰牛车。略去中言故作是说。一切有漏法同一择灭耶。不尔。云何随系事别。谓随系事量。离系事亦尔。若不尔者于证见苦所断烦恼灭时。应证一切所断诸烦恼灭。若如是者。修余对治则为无用。依何义说灭无同类。依灭自无同类因义亦不与他。故作是说。非无同类。已说择灭。永碍当生得非择灭。谓能永碍未来法生。得灭异前名非择灭。得不因择但由阙缘。如眼与意专一色时余色声香味触等谢。缘彼境界五识身等。住未来世毕竟不生。由彼不能缘过去境。缘不具故得非择灭。于法得灭应作四句。或于诸法唯得择灭。谓诸有漏过现生法。或于诸法唯非择灭。谓不生法无漏有为。或于诸法俱得二灭。谓彼不生诸有漏法。或于诸法不得二灭。谓诸无漏过现生法。如是已说三种无为。前说除道余有为法。是名有漏。何谓有为。颂曰

  又诸有为法　　谓色等五蕴
  亦世路言依　　有离有事等

论曰。色等五蕴谓初色蕴乃至识蕴。如是五法具摄有为。众缘聚集共所作故。无有少法一缘所生。是彼类故。未来无妨。如乳如薪。此有为法亦名世路。已行正行当行性故。或为无常所吞食故。或名言依。言谓语言。此所依者即名俱义。如是言依具摄一切有为诸法。若不尔者应违品类足论所说。彼说言依十八界摄。或名有离。离谓永离。即是涅槃。一切有为有彼离故。或名有事。以有因故。事是因义。毗婆沙师传说如此。如是等类是有为法差别众名。于此所说有为法中。颂曰

  有漏名取蕴　　亦说为有诤
  及苦集世间　　见处三有等

论曰。此何所立。谓立取蕴亦名为蕴。或有唯蕴而非取蕴。谓无漏行。烦恼名取。蕴从取生故名取蕴。如草糠火。或蕴属取故名取蕴。如帝王臣。或蕴生取故名取蕴。如花果树。此有漏法亦名有诤。烦恼名诤。触动善品故。损害自他故。诤随增故。名为有诤。犹如有漏。亦名为苦。违圣心故。亦名为集。能招苦故。亦名世间。可毁坏故。有对治故。亦名见处。见住其中随增眠故。亦名三有。有因有依三有摄故。如是等类是有漏法随义别名。如上所言。色等五蕴名有为法。色蕴者何。颂曰

  色者唯五根　　五境及无表

论曰。言五根者。所谓眼耳鼻舌身根。言五境者。即是眼等五根境界。所谓色声香味所触。及无表者。谓无表色。唯依此量立色蕴名。此中先应说五根相。颂曰

  彼识依净色　　名眼等五根

论曰。彼谓前说色等五境。识即色声香味触识。彼识所依五种净色。如其次第应知。即是眼等五根。如世尊说。苾刍当知。眼谓内处四大所造净色为性。如是广说。或复彼者。谓前所说眼等五根。识即眼耳鼻舌身识。彼识所依五种净色名眼等根。是眼等识所依止义。如是便顺品类足论。如彼论说。云何眼根。眼识所依净色为性。如是广说。已说五根。次说五境。颂曰

  色二或二十　　声唯有八种
  味六香四种　　触十一为性

论曰。言色二者。一显二形。显色有四。青黄赤白。余显是此四色差别。形色有八。谓长为初不正为后。或二十者。即此色处复说二十。谓青黄赤白长短方圆高下正不正。云烟尘雾影光明闇。有余师说。空一显色第二十一。此中正者。谓形平等。形不平等名为不正。地水气腾说之为雾。日焰名光。月星火药宝珠电等诸焰名明。障光明生于中余色可见名影。翻此为闇。余色易了故今不释。或有色处有显无形。谓青黄赤白影光明闇。或有色处有形无显。谓长等一分身表业性。或有色处有显有形。谓所余色。有余师说。唯光明色有显无形。现见世间青等色处有长等故。如何一事具有显形。由于此中俱可知故。此中有者是有智义非有境义。若尔身表中亦应有显智。已说色处。当说声处。声唯八种。谓有执受。或无执受大种为因。及有情名非有情名差别为四。此复可意及不可意差别成八。执受大种为因声者。谓言手等所发音声。风林河等所发音声。名无执受大种为因。有情名声。谓语表业。余声则是非有情名。有说。有声通有执受及无执受大种为因。如手鼓等合所生声。如不许一显色极微二四大造。声亦应尔。已说声处。当说味处。味有六种。甘醋碱辛苦淡别故。已说味处。当说香处。香有四种。好香恶香等不等香有差别故。本论中说。香有三种。好香恶香及平等香。已说香处。当说触处。触有十一。谓四大种滑性涩性重性轻性及冷饥渴。此中大种后当广说。柔软名滑。粗强为涩。可称名重。翻此为轻。暖欲名冷。食欲名饥。饮欲名渴。此三于因立果名故。作如是说。如有颂言

  诸佛出现乐　　演说正法乐
  僧众和合乐　　同修勇进乐

于色界中无饥渴触有所余触。彼界衣服别不可称。聚则可称。冷暖于彼虽无能损而有能益。传说如此。此中已说多种色处。有时眼识缘一事生。谓于尔时各别了别。有时眼识缘多事生。谓于尔时不别了别。如远观察军众山林无量显形珠宝聚等。应知耳等诸识亦尔。有余师说。身识极多缘五触起。谓四大种滑等随一。有说。极多总缘一切十一触起。若尔五识总缘境故。应五识身取共相境非自相境。约处自相。许五识身取自相境非事自相斯有何失。今应思择。身舌二根两境俱至。何识先起。随境强盛彼识先生。境若均平舌识先起。食饮引身令相续故。已说根境及取境相。无表色相今次当说。颂曰

  乱心无心等　　随流净不净
  大种所造性　　由此说无表

论曰。乱心者。谓此余心。无心者。谓入无想及灭尽定。等言显示不乱有心。相似相续说名随流。善与不善名净不净。为简诸得相似相续。是故复言大种所造。毗婆沙说。造是因义。谓作生等五种因故。显立名因故言由此。无表虽以色业为性如有表业。而非表示令他了知。故名无表。说者显此是师宗言。略说表业及定所生善不善色名为无表。既言无表大种所造。大种云何。颂曰

  大种谓四界　　即地水火风
  能成持等业　　坚湿暖动性

论曰。地水火风能持自相及所造色。故名为界。如是四界亦名大种。一切余色所依性故。体宽广故。或于地等增盛聚中。形相大故。或起种种大事用故。此四大种能成何业。如其次第能成持摄熟长四业。地界能持。水界能摄。火界能熟。风界能长。长谓增盛。或复流引。业用既尔。自性云何。如其次第即用坚湿暖动为性。地界坚性。水界湿性。火界暖性。风界动性。由此能引大种造色。令其相续生至余方。如吹灯光。故名为动。品类足论及契经言。云何名风界。谓轻等动性。复说轻性为所造色。故应风界动为自性。举业显体故亦言轻。云何地等地等界别。颂曰

  地谓显形色　　随世想立名
  水火亦复然　　风即界亦尔

论曰。地谓显形。色处为体。随世间想假立此名。由诸世间相示地者。以显形色。而相示故。水火亦然。风即风界。世间于动立风名故或如地等随世想名。风亦显形。故言亦尔。如世间说黑风团风。此用显形。表示风故。何故此蕴无表为后说为色耶。由变坏故。如世尊说。苾刍当知。由变坏故名色取蕴。谁能变坏。谓手触故即便变坏。乃至广说。变坏即是可恼坏义。故义品中作如是说

  趣求诸欲人　　常起于希望
  诸欲若不遂　　恼坏如箭中

色复云何欲所恼坏。欲所扰恼变坏生故。有说。变碍故名为色。若尔极微应不名色。无变碍故。此难不然。无一极微各处而住。众微聚集变碍义成。过去未来应不名色。此亦曾当有变碍故。及彼类故。如所烧薪。诸无表色应不名色。有释。表色有变碍故。无表随彼亦受色名。譬如树动影亦随动。此释不然。无变碍故。又表灭时无表应灭。如树灭时影必随灭。有释所依大种变碍故。无表业亦得色名。若尔所依有变碍故。眼识等五应亦名色。此难不齐。无表依止大种转时。如影依树光依珠宝。眼等五识依眼等时则不如是。唯能为作助生缘故。此影依树光依宝言。且非符顺毗婆沙义。彼宗影等显色极微。各自依止四大种故。设许影光依止树宝。而无表色不同彼依。彼许所依大种虽灭而无表色不随灭故。是故所言未为释难。复有别释彼所难言。眼识等五所依不定。或有变碍。谓眼等根。或无变碍。谓无间意。无表所依则不如是。故前所难定为不齐。变碍名色理得成就。颂曰

  此中根与境　　许即十处界

论曰。此前所说色蕴性中。许即根境为十处界。谓于处门立为十处。眼处色处广说乃至身处触处。若于界门立为十界。眼界色界广说乃至身界触界。已说色蕴并立处界。当说受等三蕴处界。颂曰

  受领纳随触　　想取像为体
  四余名行蕴　　如是受等三
  及无表无为　　名法处法界

论曰。受蕴谓三。领纳随触。即乐及苦不苦不乐。此复分别成六受身。谓眼触所生受乃至意触所生受。想蕴谓能取像为体。即能执取青黄长短男女怨亲苦乐等相。此复分别成六想身。应如受说。除前及后色受想识。余一切行名为行蕴。然薄伽梵于契经中说六思身为行蕴者。由最胜故。所以者何。行名造作。思是业性造作义强。故为最胜。是故佛说若能造作有漏有为名行取蕴。若不尔者。余心所法及不相应。非蕴摄故。应非苦集。则不可为应知应断。如世尊说。若于一法未达未知。我说不能作苦边际。未断未灭说亦如是。是故定应许除四蕴余有为行皆行蕴摄。即此所说受想行蕴。及无表色。三种无为。如是七法。于处门中立为法处。于界门中立为法界。已说受等三蕴处界。当说识蕴并立处界。颂曰

  识谓各了别　　此即名意处
  及七界应知　　六识转为意

论曰。各各了别彼彼境界。总取境相故名识蕴。此复差别有六识身。谓眼识身至意识身。应知如是所说识蕴。于处门中立为意处。于界门中立为七界。谓眼识界至意识界。即此六识转为意界。如是此中所说五蕴。即十二处并十八界。谓除无表诸余色蕴即名十处。亦名十界。受想行蕴无表无为总名法处。亦名法界。应知识蕴即名意处。亦名七界。谓六识界及与意界。岂不识蕴唯六识身。异此说何复为意界。更无异法。即于此中颂曰

  由即六识身　　无间灭为意

论曰。即六识身无间灭已。能生后识故名意界。谓如此子即名余父。又如此果即名余种。若尔实界应唯十七或唯十二。六识与意更相摄故。何缘得立十八界耶。颂曰

  成第六依故　　十八界应知

论曰。如五识界。别有眼等五界为依。第六意识无别所依。为成此依故说意界。如是所依能依境界。应知各六界成十八。若尔无学最后念心应非意界。此无间灭后识不生。非意界故。不尔。此已住意性故。阙余缘故后识不生。此中蕴摄一切有为。取蕴唯摄一切有漏。处界总摄一切法尽。别摄如是。总摄云何。颂曰

  总摄一切法　　由一蕴处界
  摄自性非余　　以离他性故

论曰。由一色蕴意处法界。应知总摄一切法尽。谓于诸处就胜义说。唯摄自性不摄他性。所以者何。法与他性恒相离故。此离于彼。而言摄者。其理不然。且如眼根。唯摄色蕴眼处眼界苦集谛等。是彼性故。不摄余蕴余处界等。离彼性故。若于诸处就世俗说。应知亦以余法摄余。如四摄事摄徒众等。眼耳鼻三处各有二。何缘界体非二十一。此难非理。所以者何。颂曰

  类境识同故　　虽二界体一

论曰。类同者。谓二处同是眼自性故。境同者。谓二处同用色为境故。识同者。谓二处同为眼识依故。由此眼界虽二而一。耳鼻亦应如是安立。若尔何缘生依二处。颂曰

  然为令端严　　眼等各生二

论曰。为所依身相端严故。界体虽一而两处生。若眼耳根处唯生一。鼻无二穴身不端严。此释不然。若本来尔谁言丑陋。又猫鸱等虽生二处有何端严。若尔三根何缘生二。为所发识明了端严。现见世间。闭一目等了别色等便不分明。是故三根各生二处。已说诸蕴及处界摄。当说其义。此蕴处界别义云何。颂曰

  聚生门种族　　是蕴处界义

论曰。诸有为法和合聚义是蕴义。如契经言。诸所有色。若过去若未来若现在。若内若外。若粗若细。若劣若胜。若远若近。如是一切略为一聚。说名色蕴。由此聚义蕴义得成。于此经中。无常已灭名过去。若未已生名未来。已生未谢名现在。自身名内。所余名外。或约处辩。有对名粗。无对名细。或相待立。若言相待。粗细不成。此难不然。所待异故。待彼为粗未尝为细。待彼为细未尝为粗。犹如父子苦集谛等染污名劣。不染名胜。去来名远。现在名近。乃至识蕴应知亦然。而有差别。谓依五根名粗。唯依意根名细。或约地辩。毗婆沙师所说如是。大德法救复作是言。五根所取名粗色。所余名细色。非可意者名劣色。所余名胜色。不可见处名远色。在可见处名近色。过去等色如自名显受等亦然。随所依力应知远近粗细同前。心心所法生长门义是处义。训释词者。谓能生长心心所法故名为处。是能生长彼作用义。法种族义是界义。如一山中有多铜铁金银等族说名多界。如是一身。或一相续有十八类诸法种族名十八界。此中种族是生本义。如是眼等谁之生本。谓自种类同类因故。若尔无为应不名界。心心所法生之本故。有说。界声表种类义。谓十八法种类自性各别不同名十八界。若言聚义是蕴义者。蕴应假有。多实积集共所成故。如聚如我。此难不然。一实极微亦名蕴故。若尔不应言聚义是蕴义。非一实物有聚义故。有说。能荷重担义是蕴义。由此世间说肩名蕴。物所聚故。或有说者。可分段义是蕴义。故世有言。汝三蕴还我当与汝。此释越经。经说聚义是蕴义故。如契经言。诸所有色若过去等。广说如前。若谓此经显过去等一一色等各别名蕴。是故一切过去色等一一实物各各名蕴。此执非理。故彼经言。如是一切略为一聚说名蕴故。是故如聚。蕴定假有。若尔应许诸有色处亦是假有。眼等极微。要多积聚成生门故。此难非理。多积聚中一一极微。有因用故。若不尔者。根境相助共生识等。应非别处。是则应无十二处别。然毗婆沙作如是说。对法诸师若观假蕴。彼说极微一界一处一蕴少分。若不观者。彼说极微即是一界一处一蕴。此应于分假谓有分。如烧少衣亦说烧衣。何故世尊于所知境。由蕴等门作三种说。颂曰

  愚根乐三故　　说蕴处界三

论曰。所化有情有三品故。世尊为说蕴等三门。传说。有情愚有三种。或愚心所总执为我。或唯愚色。或愚色心。根亦有三。谓利中钝。乐亦三种。谓乐略中及广文故。如其次第世尊为说蕴处界三。何缘世尊说余心所总置行蕴。别分受想为二蕴耶。颂曰

  诤根生死因　　及次第因故
  于诸心所法　　受想别为蕴

论曰。诤根有二。谓着诸欲及着诸见。此二受想。如其次第为最胜因。味受力故贪着诸欲。倒想力故贪着诸见。又生死法以受及想为最胜因。由耽着受起倒想故。生死轮回。由此二因及后当说次第因故。应知别立受想为蕴。其次第因。邻次当辩。何故无为说在处界。非蕴摄耶。颂曰

  蕴不摄无为　　义不相应故

论曰。三无为法不可说在色等蕴中。与色等义不相应故。谓体非色乃至非识。亦不可说为第六蕴。彼与蕴义不相应故。聚义是蕴。如前具说。谓无为法。非如色等有过去等品类差别可略一聚名无为蕴。又言取蕴为显染依。染净二依蕴言所显。无为于此二义都无。义不相应故不立蕴。有说。如瓶破非瓶。如是蕴息应非蕴。彼于处界例应成失。如是已说诸蕴废立。当说次第。颂曰。

  随粗染器等　　界别次第立

论曰。色有对故诸蕴中粗。无色中粗唯受行相。故世说我手等痛言。待二想粗。男女等想易了知故。行粗过识。贪嗔等行易了知故。识最为细。总取境相难分别故。由此随粗立蕴次第。或从无始生死已来。男女于色更相爱乐。此由耽着乐受味故。耽受复因倒想生故。此倒想生由烦恼故。如是烦恼依识而生。此及前三皆染污识。由此随染立蕴次第。或色如器。受类饮食。想同助味。行似厨人。识喻食者。故随器等立蕴次第。或随界别立蕴次第。谓欲界中有诸妙欲。色相显了。色界静虑有胜喜等。受相显了。三无色中取空等相。想相显了。第一有中思最为胜。行相显了。此即识住。识住其中显似世间田种次第。是故诸蕴次第如是。由此五蕴无增减过。即由如是诸次第因。离行别立受想二蕴。谓受与想。于诸行中相粗生染。类食同助。二界中强故别立蕴。处界门中应先辨说六根次第。由斯境识次第可知。颂曰

  前五境唯现　　四境唯所造
  余用远速明　　或随处次第

论曰。于六根中。眼等前五唯取现境。是故先说。意境不定。三世无为。或唯取一或二三四。所言四境唯所造者。前流至此。五中前四境唯所造。是故先说。身境不定。或取大种。或取造色。或二俱取。余谓前四。如其所应用远速明。是故先说。谓眼耳根取远境故。在二先说。二中眼用远故先说。远见山河不闻声故。又眼用速。先远见人撞击钟鼓后闻声故。鼻舌两根用俱非远。先说鼻者。由速明故。如对香美诸饮食时。鼻先嗅香舌后尝味。或于身中随所依处上下差别说根次第。谓眼所依最居其上。次耳鼻舌身多居下。意无方处。有即依止诸根生者。故最后说。何缘十处皆色蕴摄。唯于一种立色处名。又十二处体皆是法。唯于一种立法处名。颂曰

  为差别最胜　　摄多增上法
  故一处名色　　一名为法处

论曰。为差别者。为令了知境有境性种种差别。故于色蕴就差别相建立十处不总为一。若无眼等差别想名。而体是色立名色处。此为眼等名所简别。虽标总称而即别名。又诸色中色处最胜。故立通名。由有对故。手等触时即便变坏。及有见故。可示在此在彼差别。又诸世间唯于此处同说为色。非于眼等。又为差别立一法处。非于一切。如色应知。又于此中摄受想等众多法故。应立通名。又增上法。所谓涅槃。此中摄故独立为法。有余师说。色处中有二十种色最粗显故。肉天圣慧三眼境故。独立色名。法处中有诸法名故。诸法智故。独立法名。诸契经中。有余种种蕴及处界名想可得。为即此摄。为离此耶。彼皆此摄。如应当知。且辩摄余诸蕴名想。颂曰

  牟尼说法蕴　　数有八十千
  彼体语或名　　此色行蕴摄

论曰。诸说佛教语为体者。彼说法蕴皆色蕴摄。诸说佛教名为体者。彼说法蕴皆行蕴摄。此诸法蕴其量云何。颂曰

  有言诸法蕴　　量如彼论说
  或随蕴等言　　如实行对治

论曰。有诸师言。八万法蕴一一量等法蕴足论。谓彼一一有六千颂。如对法中法蕴足说。或说。法蕴随蕴等言一一差别数有八万。谓蕴．处．界．缘起．谛．食．静虑．无量．无色．解脱．胜处．遍处．觉品．神通．无诤．愿智．无碍解等。一一教门名一法蕴。如实说者。所化有情有贪嗔等八万行别。为对治彼八万行故。世尊宣说八万法蕴。如彼所说八万法蕴皆此五中二蕴所摄。如是余处诸蕴处界类亦应然。颂曰

  如是余蕴等　　各随其所应
  摄在前说中　　应审观自相

论曰。余契经中诸蕴处界。随应摄在前所说中。如此论中所说蕴等。应审观彼一一自相。且诸经中说余五蕴。谓戒定慧解脱解脱智见五蕴。彼中戒蕴此色蕴摄。彼余四蕴此行蕴摄。又诸经说十遍处等。前八遍处。无贪性故此法处摄。若兼助伴五蕴性故。即此意处法处所摄。摄八胜处应知亦尔。空识遍处。空无边等四无色处四蕴性故。即此意处法处所摄。五解脱处慧为性故。此法处摄。若兼助伴。即此声意法处所摄。复有二处。谓无想有情天处。及非想非非想处。初处即此十处所摄。无香味故。后处即此意法处摄。四蕴性故。又多界经说界差别。有六十二。随其所应当知皆此十八界摄。且彼经中所说六界。地水火风四界已说。空识二界未说其相。为即虚空名为空界。为一切识名识界耶。不尔云何。颂曰

  空界谓窍隙　　传说是明闇
  识界有漏识　　有情生所依

论曰。诸有门窗及口鼻等。内外窍隙名为空界。如是窍隙云何应知。传说。窍隙即是明闇。非离明闇窍隙可取。故说空界明闇为体。应知此体不离昼夜。即此说名邻阿伽色。传说。阿伽谓积集色。极能为碍故名阿伽。此空界色与彼相邻。是故说名邻阿伽色。有说。阿伽即空界色。此中无碍故名阿伽。即阿伽色余碍相邻。是故说名邻阿伽色。诸有漏识名为识界。云何不说诸无漏识为识界耶。由许六界是诸有情生所依故。如是诸界从续生心。至命终心恒持生故。诸无漏法则不如是。彼六界中。前四即此触界所摄。第五即此色界所摄。第六即此七心界摄。彼经余界如其所应。皆即此中十八界摄

说一切有部俱舍论卷第一阿毗达磨俱舍论卷第二

        尊者世亲造

        三藏法师玄奘奉　诏译

    分别界品第一之二

复次于前所说十八界中。几有见几无见。几有对几无对。几善几不善几无记。颂曰

  一有见谓色　　十有色有对
  此除色声八　　无记余三种

论曰。十八界中色界有见。以可示现此彼差别。由此义准说余无见。如是已说有见无见。唯色蕴摄十界有对。对是碍义。此复三种。障碍境界所缘异故。障碍有对。谓十色界。自于他处被碍不生。如手碍手或石碍石或二相碍。境界有对。谓十二界法界一分。诸有境法于色等境。故施设论作如是言。有眼于水有碍非陆。如鱼等眼。有眼于陆有碍非水。从多分说。如人等眼。有眼俱碍。如毕舍遮室兽摩罗及捕鱼人虾蟆等眼。有俱非碍。谓除前相。有眼于夜有碍非昼。如诸蝙蝠鸺鹠等眼。有眼于昼有碍非夜。从多分说。如人等眼。有眼俱碍。如狗野干马豹豺狼猫狸等眼。有俱非碍。谓除前相。此等名为境界有对。所缘有对。谓心心所于自所缘。境界所缘复有何别。若于彼法此有功能。即说彼为此法境界。心心所法执彼而起。彼于心等名为所缘。云何眼等于自境界所缘转时说名有碍。越彼于余此不转故。或复碍者是和会义。谓眼等法于自境界及自所缘和会转故。应知此中唯就障碍有对而说。故但言十有色有对。更相障故。由此义准说余无对。若法境界有对。亦障碍有对耶。应作四句。谓七心界法界一分诸相应法是第一句。色等五境是第二句。眼等五根是第三句。法界一分非相应法是第四句。若法境界有对。亦所缘有对耶。应顺后句。谓若所缘有对。定是境界有对。有虽境界有对而非所缘有对。谓眼等五根。此中大德鸠摩逻多作如是说

  是处心欲生　　他碍令不起
  应知是有对　　无对此相违

此是所许。如是已说有对无对。于此所说十有对中。除色及声余八无记。谓五色根。香味触境。不可记为善不善性故名无记。有说。不能记异熟果故名无记。若尔无漏应唯无记。其余十界通善等三。谓七心界与无贪等相应名善。贪等相应名为不善。余名无记。法界若是无贪等性相应等起择灭名善。若贪等性相应等起名为不善。余名无记。色界声界若善不善心力等起身语表摄。是善不善。余是无记。已说善等。十八界中几欲界系。几色界系。几无色界系。颂曰

  欲界系十八　　色界系十四
  除香味二识　　无色系后三

论曰。系谓系属即被缚义。欲界所系具足十八。色界所系唯十四种。除香味境及鼻舌识。除香味者段食性故。离段食欲方得生彼。除鼻舌识无所缘故若尔触界于彼应无。如香味境段食性故。彼所有触非段食性。若尔香味类亦应然。香味离食无别受用。触有别用持根衣等。彼离食欲香味无用。有根衣等故触非无。有余师说。住此依彼静虑等至见色闻声。轻安俱起有殊胜触摄益于身。是故此三生彼静虑犹相随逐。香味不尔。故在彼无。若尔鼻舌彼应非有。如香味境彼无用故。不尔二根于彼有用。谓起言说及庄严身。若为严身及起说用。但须依处。何用二根。如无男根亦无依处。二根无者依处亦无。于彼可无男根依处。彼无用故。鼻舌依处彼有用故。离根应有。有虽无用而有根生。如处胞胎定当死者。有虽无用而非无因。彼从何因得有根起。于根有爱发殊胜业。若离境爱于根定然。彼离境贪应无鼻舌。或应许彼男根亦生。若谓不生由丑陋者。阴藏隐密何容丑陋。又诸根生非由有用。若有因力无用亦生。男根于彼虽为丑陋。设许有因于彼应起。男根非有鼻舌应无。若尔便违契经所说。彼无支缺不减诸根。随彼诸根应可有者。说为不减。何所相违。若不许然男根应有。如是说者鼻舌二根于彼非无。但无香味。以六根爱依内身生非依境界而得现起。其男根爱依淫触生。淫触彼无。男根非有。故于色界十八界中。唯十四种理得成立。无色界系唯有后三。所谓意法及意识界。要离色欲于彼得生。故无色中无十色界依缘无故五识亦无。故唯后三无色界系。已说界系。十八界中几有漏几无漏。颂曰

  意法意识通　　所余唯有漏

论曰。意及意识道谛摄者。名为无漏。余名有漏。法界若是道谛无为。名为无漏。余名有漏。余十五界唯名有漏。如是已说有漏无漏。十八界中几有寻有伺。几无寻唯伺。几无寻无伺。颂曰

  五识唯寻伺　　后三三余无

论曰。眼等五识有寻有伺。由与寻伺恒共相应。以行相粗外门转故。显义决定。故说唯言。后三谓是意法意识。根境识中各居后故。此后三界皆通三品。意界意识界及相应法界除寻与伺。若在欲界初静虑中有寻有伺。静虑中间无寻唯伺。第二静虑以上诸地乃至有顶无寻无伺。法界所摄非相应法。静虑中间伺亦如是。寻一切时无寻唯伺。无第二寻故。但伺相应故。伺在欲界初静虑中三品不收。应名何等。此应名曰无伺唯寻。无第二伺故。但寻相应故。由此故言有寻伺地有四品法。一有寻有伺。谓除寻伺余相应法。二无寻唯伺。谓即是寻。三无寻无伺。谓即一切非相应法。四无伺唯寻。谓即是伺。余十色界寻伺俱无。常与寻伺不相应故。若五识身有寻有伺。如何得说无分别耶。颂曰

  说五无分别　　由计度随念
  以意地散慧　　意诸念为体

论曰。传说。分别略有三种。一自性分别。二计度分别。三随念分别。由五识身虽有自性而无余二。说无分别。如一足马名为无足。自性分别体唯是寻。后心所中自当辩释。余二分别如其次第。意地散慧诸念为体。散谓非定。意识相应散慧。名为计度分别。若定若散意识相应诸念。名为随念分别。如是已说有寻伺等。十八界中几有所缘几无所缘。几有执受几无执受。颂曰

  七心法界半　　有所缘余无
  前八界及声　　无执受余二

论曰。六识意界及法界摄诸心所法。名有所缘。能取境故。余十色界及法界摄不相应法。名无所缘。义准成故。如是已说有所缘等。十八界中九无执受。前七心界及法界全。此八及声皆无执受。所余九界各通二门。谓有执受无执受故。眼等五根住现在世名有执受。过去未来名无执受。色香味触住现在世不离五根名有执受。若住现在非不离根过去未来。名无执受。如在身内除与根合。发毛爪齿大小便利洟唾血等。及在身外地水等中色香味触虽在现世而无执受。有执受者。此言何义。心心所法共所执持摄为依处名有执受。损益展转更相随故。即诸世间说有觉触。众缘所触觉乐等故。与此相违名无执受。如是已说有执受等。十八界中几大种性几所造性。几可积集几非积集。颂曰

  触界中有二　　余九色所造
  法一分亦然　　十色可积集

论曰。触界通二。谓大种及所造。大种有四。谓坚性等。所造有七。谓滑性等。依大种生故名所造。余九色界唯是所造。谓五色根色等四境。法界一分无表业色亦唯所造。余七心界法界一分。除无表色俱非二种。尊者觉天作如是说。十种色处唯大种性。彼说不然。契经唯说坚等四相为大种故。此四大种唯触摄故。非坚湿等眼等所取。非色声等身根所觉。是故彼说理定不然。又契经说。苾刍当知。眼谓内处四大种所造净色。有色无见有对。乃至身处广说亦尔。苾刍当知。色谓外处四大种所造。有色有见有对。声谓外处四大种所造。有色无见有对。香味二处广说亦尔。触谓外处。是四大种及四大种所造。有色无见有对。如是经中唯说触处摄四大种。分明显示余有色处皆非大种。若尔何故。契经中言谓于眼肉团中若内各别坚性坚类。乃至广说。彼说不离眼根肉团有坚性等。无相违过。入胎经中。唯说六界为士夫者。为显能成士夫本事。非唯尔所。彼经复说六触处故。又诸心所应非有故。亦不应执心所即心。以契经言想受等心所法依止心故。又亦说有贪心等故。由此如前所说诸界大种所造差别义成。如是已说大种性等。十八界中。五根五境十有色界。是可积集。极微聚故。义准余八非可积集。非极微故。如是已说可积集等。十八界中。几能斫几所斫。几能烧几所烧。几能称几所称。颂曰

  谓唯外四界　　能斫及所斫
  亦所烧能称　　能烧所称诤

论曰。色香味触成斧薪等。此即名为能斫所斫。何法名斫。薪等色聚相逼续生。斧等分隔令各续起。此法名斫。身等色根不名所斫。非可全断令成二故。非身根等可成二分。支分离身则无根故。又身根等亦非能斫。以净妙故如珠宝光。如能斫所斫体唯外四界。所烧能称其体亦尔。谓唯外四界名所烧能称。身等色根亦非二事。以净妙故如珠宝光。声界总非。不相续故。能烧所称有异诤论。谓或有说。能烧所称体亦如前。唯外四界。或复有说。唯有火界可名能烧。所称唯重。如是已说能所斫等。十八界中几异熟生。几所长养。几等流性。几有实事。几一刹那。颂曰

  内五有熟养　　声无异熟生
  八无碍等流　　亦异熟生性
  余三实唯法　　刹那唯后三

论曰。内五即是眼等五界。有异熟生及所长养无等流者。离异熟生及所长养无别性故。异熟因所生名异熟生。如牛所驾车名曰牛车。略去中言故作是说。或所造业至得果时变而能熟故名异熟。果从彼生名异熟生。彼所得果与因别类。而是所熟故名异熟。或于因土假立果名。如于果上假立因名。如契经说。今六触处。应知即是昔所造业。饮食资助眠睡等持胜缘所益名所长养。有说。梵行亦能长养。此唯无损非别有益。长养相续常能护持异熟相续。犹如外郭防援内城。声有等流及所长养无异熟生。所以者何。随欲转故。若尔不应施设论说善修远离粗恶语故。感得大士梵音声相。有说。声属第三传故。虽由彼生而非异熟。谓从彼业生诸大种。从诸大种缘击发声。有说。声属第五传故。虽由彼生而非异熟。谓彼业生异熟大种。从此传生长养大种。此复传生等流大种。此乃生声。若尔身受从业所生大种生故。应非异熟。若受如声便违正理。八无碍者。七心法界。此有等流异熟生性。同类遍行因所生者是等流性。若异熟因所引生者名异熟生。诸无碍法无积集故非所长养。余谓余四色香味触。皆通三种。有异熟生。有所长养。有等流性。实唯法者。实谓无为。以坚实故。此法界摄故。唯法界独名有实。意法意识名为后三。于六三中最后说故。唯此三界有一刹那。谓初无漏苦法忍品。非等流故名一刹那。此说究竟非等流者。余有为法无非等流。苦法忍相应心名意界意识界。余俱起法名为法界。如是已说异熟生等。今应思择。若有眼界先不成就今得成就亦眼识耶。若眼识界先不成就今得成就亦眼界耶。如是等问。今应略答。颂曰

  眼与眼识界　　独俱得非等

论曰。独得者。谓或有眼界先不成就今得成就非眼识。谓生欲界渐得眼根。及无色没生二三四静虑地时。或有眼识先不成就今得成就非眼界。谓生二三四静虑地眼识现起。及从彼没生下地时。俱得者。谓或有二界先不成就今得成就。谓无色没生于欲界及梵世时。非者俱非。谓除前相。等谓若有成就眼界亦眼识耶。应作四句。第一句者。谓生二三四静虑地眼识不起。第二句者。谓生欲界未得眼根及得已失。第三句者。谓生欲界得眼不失。及生梵世若生二三四静虑地正见色时。第四句者。谓除前相。如是眼界与色界眼识与色界得成就等如理应思。为摄如是所未说义。是故颂中总复言等。如是已说得成就等。十八界中几内几外。颂曰

  内十二眼等　　色等六为外

论曰。六根六识十二名内。外谓所余色等六境。我依名内。外谓此余。我体既无内外何有。我执依止故。假说心为我。故契经说

  由善调伏我　　智者得生天

世尊余处说调伏心。如契经言

  应善调伏心　　心调能引乐

故但于心假说为我。眼等为此所依亲近。故说名内。色等为此所缘疏远。故说名外。若尔六识应不名内。未至意位非心依故。至意位时不失六识界。未至意位亦非越意相。若异此者。意界唯应在过去世六识唯在现在未来。便违自宗许十八界皆通三世。又若未来现在六识无意界相过去意界亦应不立。相于三世无改易故。已说内外。十八界中几是同分。几彼同分。颂曰

  法同分余二　　作不作自业

论曰。法同分者。谓一法界唯是同分。若境与识定为所缘。识于其中已生生法。此所缘境说名同分。无一法界不于其中已正当生无边意识。由诸圣者决定生心。观一切法皆为无我。彼除自体及俱有法。余一切法皆为所缘。如是所除亦第二念心所缘境。此二念心缘一切境无不周遍。是故法界恒名同分。余二者。谓余十七界皆有同分及彼同分。何名同分彼同分耶。谓作自业不作自业。若作自业名为同分。不作自业名彼同分。此中眼界于有见色已正当见名同分眼。如是广说。乃至意界各于自境应说自用。迦湿弥罗国毗婆沙师说。彼同分眼但有四种。谓不见色已正当灭及不生法。西方诸师说有五种。谓不生法复开为二。一有识属。二无识属。乃至身界应知亦然。意彼同分唯不生法。色界为眼已正当见名同分色。彼同分色亦有四种。谓非眼见已正当灭及不生法。广说乃至触界亦尔。各对自根应说自用。应知同分及彼同分。眼若于一是同分。于余一切亦同分。彼同分亦如是。广说乃至意界亦尔。色即不然于见者是同分。于不见者是彼同分。所以者何。色有是事。谓一所见亦多所见。如观月舞相扑等色。眼无是事。谓一眼根二能见色。眼不共故。依一相续建立同分及彼同分。色是共故。依多相续建立同分及彼同分。如说色界声香味触应知亦尔。声可如色。香味触三至根方取。是不共故。一取非余。理应如眼等。不应如色说。虽有是理而容有共。所以者何。香等三界于一及余。皆有可生鼻等识义。眼等不然。故知色说。眼等六识同分彼同分生不生法故。如意界说。云何同分彼同分义。根境识三更相交涉故名为分。或复分者是己作用。或复分者是所生触。同有此分故名同分。与此相违名彼同分。由非同分与彼同分种类分同。名彼同分。已说同分及彼同分。十八界中几见所断。几修所断。几非所断。颂曰

  十五唯修断　　后三界通三
  不染非六生　　色定非见断

论曰。十五界者。谓十色界及五识界。唯修断者。此十五界唯修所断。后三界者。意界法界及意识界。通三者。谓此后三界各通三种。八十八随眠及彼俱有法并随行得。皆见所断。诸余有漏皆修所断。一切无漏皆非所断。岂不更有见所断法。谓异生性及招恶趣身语业等。此与圣道极相违故。虽尔此法非见所断。略说彼相。谓不染法。非六生色。定非见断。其异生性是不染污无记性摄。已离欲者断善根者犹成就故。此异生性若见所断。苦法忍位应是异生。六谓意处异此而生名非六生。是从眼等五根生义。即五识等。色谓一切身语业等。前及此色。定非见断。所以者何。非迷谛理亲发起故。如是已说见所断等。十八界中几是见几非见。颂曰

  眼法界一分　　八种说名见
  五识俱生慧　　非见不度故
  眼见色同分　　非彼能依识
  传说不能观　　彼障诸色故

论曰。眼全是见。法界一分八种是见。余皆非见。何等为八。谓身见等五染污见。世间正见。有学正见。无学正见。于法界中此八是见。所余非见。身见等五随眠品中时至当说。世间正见。谓意识相应善有漏慧。有学正见。谓有学身中诸无漏见。无学正见。谓无学身中诸无漏见。譬如夜分昼分有云无云睹众色像明昧有异。如是世间诸见有染无染。学无学见。观察法相明昧不同。何故世间正见唯意识相应。以五识俱生慧不能决度故。审虑为先决度名见。五识俱慧无如是能。以无分别是故非见。准此所余染无染慧及诸余法非见应知。若尔眼根不能决度。云何名见。以能明利观照诸色故亦名见。若眼见者余识行时亦应名见。非一切眼皆能现见。谁能现见。谓同分眼与识合位能见非余。若尔则应彼能依识见色非眼。不尔眼识定非能见。所以者何。传说。不能观障色故。现见壁等所障诸色则不能观。若识见者识无对故。壁等不碍应见障色。于被障色眼识不生。识既不生如何当见。眼识于彼何故不生。许眼见者眼有对故于彼障色无见功能。识与所依一境转故。可言于彼眼识不生。许识见者何缘不起。眼岂如身根境合方取而言有对故不见彼耶。又颇胝迦琉璃云母水等所障云何得见。是故不由眼有对故于彼障色无见功能。若尔所执眼识云何。若于是处光明无隔。于彼障色眼识亦生。若于是处光明有隔。于彼障色眼识不生。识既不生故不能见。然经说眼能见色者。是见所依故说能见。如彼经言意能识法。非意能识。以过去故。何者能识。谓是意识。意是识依故说能识。或就所依说能依业。如世间说床座言声。又如经言眼所识色可爱可乐。然实非此可爱乐色是眼所识。又如经说。梵志当知。以眼为门唯为见色。故知眼识依眼门见。亦不应言门即是见。岂容经说以眼为见唯为见色。若识能见谁复了别。见与了别二用何异。以即见色名了色故。譬如少分慧名能见亦能简择。如是少分识名能见亦能了别。有余难言。若眼能见。眼是见者谁是见用。此言非难如共许识是能了别。然无了者了用不同。见亦应尔。有余复言。眼识能见。是见所依故。眼亦名能见。如鸣所依故亦说钟能鸣。若尔眼根识所依故应名能识。无如是失。世间同许眼识是见。由彼生时说能见色不言识色。毗婆沙中亦作是说。若眼所得眼识所受说名所见。是故但说眼名能见。不名能识。唯识现前说能识色。譬如说日名能作昼。经部诸师有作是说。如何共聚楂掣虚空眼色等缘生于眼识。此等于见孰为能所。唯法因果实无作用。为顺世情假兴言说。眼名能见。识名能了。智者于中不应封着。如世尊说。方域言词不应坚执。世俗名想不应固求。然迦湿弥罗国毗婆沙宗。说眼能见耳能闻鼻能嗅舌能尝身能觉意能了。于见色时。为一眼见。为二眼见。此无定准。颂曰

  或二眼俱时　　见色分明故

论曰。阿毗达磨诸大论师咸言。或时二眼俱见。以开二眼见色分明。开一眼时不分明故。又开一眼触一眼时。便于现前见二月等。闭一触一此事则无。是故或时二眼俱见。非所依别识成二分。住无方故不同碍色。若此宗说眼见耳闻乃至意了。彼所取境根正取时。为至不至。颂曰

  眼耳意根境　　不至三相违

论曰。眼耳意根取非至境。谓眼能见远处诸色。眼中药等则不能观。耳亦能闻远处声响。逼耳根者则不能闻。若眼耳根唯取至境。则修定者应不修生天眼耳根。如鼻根等。若眼能见不至色者。何故不能普见一切远有障等不至诸色。如何磁石吸不至铁。非吸一切不至铁耶。执见至境亦同此难。何故不能普见一切眼药筹等至眼诸色。又如鼻等能取至境。然不能取一切与根俱有香等。如是眼根虽见不至而非一切。耳根亦尔。意无色故非能有至。有执。耳根通取至境及不至境。自耳中声亦能闻故。所余鼻等三有色根。与上相违唯取至境。如何知鼻唯取至香。由断息时不嗅香故。云何名至。谓无间生。又诸极微为相触不。迦湿弥罗国毗婆沙师说不相触。所以者何。若诸极微遍体相触。即有实物体相杂过。若触一分成有分失。然诸极微更无细分。若尔何故相击发声。但由极微无间生故。若许相触击石拊手体应相糅。不相触者聚色相击云何不散。风界摄持故令不散。或有风界能有坏散。如劫坏时。或有风界能有成摄。如劫成时。云何三根由无间生名取至境。即由无间名取至境。谓于中间都无片物。又和合色许有分故相触无失。由许此理。毗婆沙文义善成立。故彼问言。诸是触物为是触为因故生。为非触为因故生。诸非触物为问亦尔。彼就此理为不定答。有时是触为因生于非触。谓和合物正离散时。有时非触为因生于是触。谓离散物正和合时。有时是触为因生于是触。谓和合物复和合时。有时非触为因生于非触。谓向游尘同类相续。尊者世友说。诸极微相触即应住至后念。然大德说。一切极微实不相触。但由无间假立触名。此大德意应可爱乐。若异此者是诸极微应有间隙。中间既空谁障其行许为有对。又离极微无和合色。和合相触即触极微。如可变碍此亦应尔。又许极微若有方分。触与不触皆应有分。若无方分设许相触亦无斯过。又眼等根。为于自境唯取等量速疾转故如旋火轮见大山等。为于自境通取等量不等量耶。颂曰

  应知鼻等三　　唯取等量境

论曰。前说至境鼻等三根。应知唯能取等量境。如根微量境微亦然。相称合生鼻等识故。眼耳不定。谓眼于色有时取小如见毛端。有时取大如暂开目见大山等。有时取等如见蒲桃。如是耳根听蚊雷等所发种种小大音声。随其所应小大等量。意无质碍。不可辩其形量差别。云何眼等诸根极微安布差别。眼根极微在眼星上傍布而住。如香荾花。清澈映覆令无分散。有说。重累如丸而住。体清澈故。如颇胝迦不相障碍。耳根极微居耳穴内旋环而住。如卷桦皮。鼻根极微居鼻頞内背上面下。如双爪甲。此初三根横作行度处无高下。如冠花鬘。舌根极微布在舌上。形如半月。传说。舌中如毛端量非为舌根极微所遍。身根极微遍住身分。如身形量。女根极微形如鼓[壴*桑]。男根极微形如指[韋*沓]。眼根极微有时一切皆是同分。有时一切皆彼同分。有时一分是彼同分余是同分。乃至舌根极微亦尔。身根极微定无一切皆是同分。乃至极热捺落迦中猛焰缠身。犹有无量身根极微是彼同分。传说。身根设遍发识身应散坏。以无根境各一极微为所依缘能发身识。五识决定积集多微。方成所依所缘性故。即由此理亦说极微名无见体。不可见故。如前所说。识有六种。谓眼识界乃至意识。为如五识唯缘现在意识通缘三世非世。如是诸识依亦尔耶。不尔云何。颂曰

  后依唯过去　　五识依或俱

论曰。意识唯依无间灭意。眼等五识所依或俱。或言表此亦依过去。眼是眼识俱生所依。如是乃至身是身识俱生所依。同现世故。无间灭意是过去依。此五识身所依各二。谓眼等五是别所依。意根为五通所依性。故如是说。若是眼识所依性者。即是眼识等无间缘耶。设是眼识等无间缘者。复是眼识所依性耶。应作四句。第一句谓俱生眼根。第二句谓无间灭心所法界。第三句谓过去意根。第四句谓除所说法。乃至身识亦尔。各各应说自根。意识应作顺前句答。谓是意识所依性者。定是意识等无间缘。有是意识等无间缘非与意识为所依性。谓无间灭心所法界。何因识起俱托二缘。得所依名在根非境。颂曰

  随根变识异　　故眼等名依

论曰。眼等即是眼等六界。由眼等根有转变故。诸识转异。随根增损识明昧故。非色等变令识有异。以识随根不随境故。依名唯在眼等非余。何缘色等正是所识。而名眼识乃至意识不名色识乃至法识。颂曰

  彼及不共因　　故随根说识

论曰。彼谓前说眼等名依。根是依故随根说识。及不共者。谓眼唯自眼识所依。色亦通为他身眼识及通自他意识所取。乃至身触应知亦尔。由所依胜及不共因故。识得名随根非境。如名鼓声及麦牙等。随身所住眼见色时。身眼色识地为同不。应言此四或异或同。谓生欲界。若以自地眼见自地色。四皆自地。若以初静虑眼见欲界色。身色欲界眼识初定。见初定色。身属欲界三属初定。若以二静虑眼见欲界色。身色欲界眼属二定识属初定。见初定色。身属欲界眼属二定色识初定。见二定色。身属欲界眼色二定识属初定。如是若以三四静虑地眼。见下地色或自地色。如理应思。生初静虑。若以自地眼见自地色。四皆同地。见欲界色。三属初定色属欲界。若以二静虑眼见初定色。三属初定眼属二定。见欲界色。身识初定色属欲界眼属二定。见二定色。身识初定眼色二定。如是若以三四静虑地眼。见自地色或下上色。如理应思。如是生二三四静虑。以自他地眼。见自他地色。如理应思。余界亦应如是分别。今当略辩此决定相。颂曰

  眼不下于身　　色识非上眼
  色于识一切　　二于身亦然
  如眼耳亦然　　次三皆自地
  身识自下地　　意不定应知

论曰。身眼色三皆通五地。谓在欲界四静虑中。眼识唯在欲界初定。此中眼根望身生地或等或上终不居下。色识望眼等下非上。下眼不能见上色故。上识不依下地眼故。色望于识通等上下。色识于身如色于识。广说耳界应知如眼。谓耳不下于身。声识非上耳。声于识一切。二于身亦然随其所应广如眼释。鼻舌身三总皆自地。于中别者。谓身与触其地必同。识望触身或自或下。自谓若生欲界初定。生上三定谓之为下。应知意界四事不定。谓意有时与身识法四皆同地。有时上下。身唯五地。三通一切。于游等至及受生时。随其所应或同或异。如后定品当广分别。为舍繁文故今未辩。前后再述用少功多。傍论已周。应辩正论。今当思择。十八界中谁六识内几识所识。几常几无常。几根几非根。颂曰

  五外二所识　　常法界无为
  法一分是根　　并内界十二

论曰。十八界中。色等五界如其次第眼等五识各一所识。又总皆是意识所识。如是五界各六识中二识所识。由此准知。余十三界一切唯是意识所识。非五识身所缘境故。十八界中无有一界全是常者。唯法一分无为是常。义准。无常法余余界。又经中说二十二根。谓眼根耳根鼻根舌根身根意根女根男根命根乐根苦根喜根忧根舍根信根勤根念根定根慧根未知当知根已知根具知根。阿毗达磨诸大论师。皆越经中六处次第。于命根后方说意根。有所缘故。如是所说二十二根。十八界中内十二界法一分摄。法一分者。命等十一后三一分。法界摄故。内十二者。眼等五根如自名摄。意根通是七心界摄。后三一分意意识摄。女根男根即是身界一分所摄。如后当辩。义准。所余色等五界法界一分皆体非根

说一切有部俱舍论卷第二阿毗达磨俱舍论卷第三

        尊者世亲造

        三藏法师玄奘奉　诏译

    分别根品第二之一

如是因界已列诸根。即于此中根是何义。最胜自在光显名根。由此总成根增上义。此增上义谁望于谁。颂曰

  传说五于四　　四根于二种
  五八染净中　　各别为增上

论曰。眼等五根各于四事能为增上。一庄严身。二导养身。三生识等。四不共事。且眼耳根庄严身者。谓若盲聋身丑陋故。导养身者。谓因见闻避险难故。生识等者。谓发二识及相应故。不共事者。谓能见色闻声别故。鼻舌身根庄严身者。如眼耳说。导养身者。谓于段食能受用故。生识等者。谓发三识及相应故。不共事者。谓嗅尝觉香味触故。女男命意。各于二事能为增上。且女男根二增上者。一有情异。二分别异。有情异者。由此二根令诸有情女男类别。分别异者。由此二根形相言音乳房等别。有说。此于染净增上故言于二。所以者何。本性损坏扇搋半择及二形人无不律仪无间断善诸杂染法。亦无律仪得果离染诸清净法。命根二者。谓于众同分能续及能持。意根二者。谓能续后有及自在随行。能续后有者。如契经言。时健达缚于一心内随一现前。谓或爱俱。或恚俱等。自在随行者。如契经言

  心能导世间　　心能遍摄受
  如是心一法　　皆自在随行

乐等五受。信等八根。于染净中如次增上。乐等五受染增上者。贪等随眠所随增故。信等八根净增上者。诸清净法随生长故。有余师说。乐等于净亦为增上。如契经说。乐故心定。苦为信依。亦出离依喜及忧舍。毗婆沙师传说如此。有余师说。能导养身非眼等用。是识增上。识了方能避于险难。受段食故。见色等用亦非异识。故不共事于眼等根。不可立为别增上用。故非由此眼等成根。若尔云何。颂曰

  了自境增上　　总立于六根
  从身立二根　　女男性增上
  于同住杂染　　清净增上故
  应知命五受　　信等立为根
  未当知已知　　具知根亦尔
  于得后后道　　涅槃等增上

论曰。了自境者。谓六识身。眼等五根于能了别各别境识有增上用。第六意根于能了别一切境识有增上用。故眼等六各立为根。岂不色等于能了识亦有增上应立为根。境于识中无增上用。夫增上用谓胜自在。眼于所发了色识中最胜自在故名增上。于了众色为通因故。识随眼根有明昧故。色则不然。二相违故。乃至意根于法亦尔。从身复立女男根者。女男性中有增上故。女男根体不离身根。身一分中立此名故。如其次第。女男身中。此女男根有增上用。此处少异余处身根。故从身根别立为二。女身形类音声作业志乐差别。名为女性。男身形类音声作业志乐不同。名为男性。二性差别由女男根故说女男根于二性增上。于众同分住中命根有增上用。于杂染中乐等五受有增上用。所以者何。由契经说于乐受贪随增。于苦受嗔随增。于不苦不乐受无明随增故。于清净中信等五根有增上用。所以者何。由此势力伏诸烦恼引圣道故。言应知者。劝许一一各能为根。三无漏根于得后后道涅槃等有增上用。言亦尔者。类显一一各能为根。谓未知当知根于得已知根道有增上用。已知根于得具知根道有增上用。具知根于得涅槃有增上用。非心未解脱能般涅槃故。等言为显复有异门。云何异门。谓见所断烦恼灭中。未知当知根有增上用。于修所断烦恼灭中。已知根有增上用。于现法乐住中。具知根有增上用。由此能领受解脱喜乐故。若增上故立为根者。无明等性应立为根。无明等因于行等果。各各别有增上用故。又语具等应立为根。语具手足大小便处。于语执行弃乐事中。如其次第有增上故。如是等事不应立根。由所许根有如是相。颂曰

  心所依此别　　此住此杂染
  此资粮此净　　由此量立根

论曰。心所依者。眼等六根。此内六处是有情本。此相差别由女男根。复由命根此一期住。此成杂染由五受根。此净资粮由信等五。此成清净由后三根。由此立根事皆究竟。是故不应许无明等及语具等亦立为根。彼无此中增上用故。复有余师别说根相。颂曰

  或流转所依　　及生住受用
  建立前十四　　还灭后亦然

论曰。或言显此是余师意。约流转还灭立二十二根。流转所依谓眼等六。生由女男从彼生故。住由命根仗彼住故。受用由五受因彼领纳故。约此建立前十四根。还灭位中即约此四义类别故立后八根。还灭所依谓信等五。于三无漏由初故生。由次故住。由后受用。根量由此无减无增。即由此缘经立次第。不应语具于语为根。待学差别语方成故。手足不应于执行事各立为根。无异性故。谓即手足异处异相差别生时名执行故。又离手足亦有执行。如腹行类。是故手足不可于彼建立为根。出大便处于能弃事不应立根。重物于空遍堕落故。又由风力引令出故。出小便处于生乐事不应立根。即女男根起此乐故。又诸喉齿眼睑支节应立为根。于能吞嚼开闭屈申有力用故。或一切因于自所作有力用故皆应立根。彼虽有用非增上故不立根者。此语具等亦非增上不应立根。此中眼等乃至男根如前已说。命根体是不相应故。不相应中自当广辩。信等体是心所法故。心所法中亦当广辩。乐等五受三无漏根。更无辩处故今应释。颂曰

  身不悦名苦　　即此悦名乐
  及三定心悦　　余处此名喜
  心不悦名忧　　中舍二无别
  见修无学道　　依九立三根

论曰。身谓身受。依身起故。即五识相应受。言不悦是损恼义。于身受内能损恼者名为苦根。所言悦者是摄益义。即身受内能摄益者名为乐根。及第三定心相应受能摄益者亦名乐根。第三定中无有身受。五识无故心悦名乐。即此心悦除第三定。于下三地名为喜根。第三静虑心悦安静离喜贪故唯名乐根。下三地中心悦粗动有喜贪故唯名喜根。意识相应能损恼受。是心不悦名曰忧根。中谓非悦非不悦即是不苦不乐受。此处中受名为舍根。如是舍根为是身受为是心受。应言通二。何因此二总立一根。此受在身心同无分别故。在心苦乐多分别生。在身不然。随境力故。阿罗汉等亦如是生故。此立根身心各别。舍无分别任运而生。是故立根身心合一。又苦乐受在身在心为损为益。其相各异故别立根。舍在身心同无分别。非损非益其相无异。故总立根。意乐喜舍信等五根。如是九根在于三道。如次建立三无漏根。谓在见道依意等九立未知当知根。若在修道即依此九立已知根。在无学道亦依此九立具知根。如是三名因何而立。谓在见道有未曾知当知行转故。说彼名未知当知。若在修道无未曾知。但为断除余随眠故。即于彼境复数了知。是故说彼名为已知。在无学道知己已知故名为知。有此知者名为具知。或习此知已成性者名为具知。谓得尽智无生智故如实自知。我遍知苦不复遍知。乃至广说。彼所有根名为未知当知根等。如是已释根体不同。当辩诸门义类差别。此二十二根中几有漏几无漏。颂曰

  唯无漏后三　　有色命忧苦
  当知唯有漏　　通二余九根

论曰。次前所说最后三根体唯无漏。是无垢义。垢之与漏名异体同。七有色根及命忧苦一向有漏。七有色者。眼等五根及女男根。色蕴摄故。意乐喜舍信等五根。此九皆通有漏无漏。有余师说。信等五根亦唯无漏。故世尊说。若全无此信等五根。我说彼住外异生品。此非诚证。依无漏根说此言故。云何知然。先依无漏信等五根。建立诸圣位差别已说此言故。或诸异生略有二种。一内二外。内谓不断善根。外谓善根已断。依外异生作如是说。若全无此信等五根。我说彼住外异生品。又契经说。有诸有情处在世间。或生或长。有上中下诸根差别。是佛犹未转法轮时。故知信等亦通有漏。又世尊说。我若于此信等五根。未如实知是集没味过患出离。未能超此天人世间及魔梵等。乃至未能证得无上正等菩提。乃至广说。非无漏法可作如是品类观察故。信等五根通有漏无漏。如是已说有漏无漏。二十二根中几是异熟几非异熟。颂曰

  命唯是异熟　　忧及后八非
  色意余四受　　一一皆通二

论曰。唯一命根定是异熟。若如是者。诸阿罗汉留多寿行此即命根。如是命根谁之异熟。如本论说。云何苾刍留多寿行。谓阿罗汉成就神通得心自在。若于僧众若于别人以诸命缘衣钵等物随分布施。施已发愿。即入第四边际静虑。从定起已心念口言。诸我能感富异熟业。愿皆转招寿异熟果。时彼能感富异熟业。则皆转招寿异熟果。复有欲令引取宿业残异熟果。彼说前生曾所受业有残异熟。由今所修边际定力引取受用。云何苾刍舍多寿行。谓阿罗汉成就神通得心自在。于僧众等如前布施。施已发愿。即入第四边际静虑。从定起已心念口言。诸我能感寿异熟业。愿皆转招富异熟果。时彼能感寿异熟业。则皆转招富异熟果。尊者妙音作如是说。彼起第四边际定力引色界大种令身中现前。而彼大种或顺寿行或违寿行。由此因缘或留寿行或舍寿行。应如是说。彼阿罗汉由此自在三摩地力转去曾得宿业所生诸根大种住时势分。引取未曾定力所起诸根大种住时势分。故此命根非是异熟。所余一切皆是异熟。因论生论。彼阿罗汉有何因缘留多寿行。谓为利益安乐他故。或为圣教久住世故。观知自身寿行将尽。观他无此二种堪能。复何因缘舍多寿行。彼阿罗汉自观住世于他利益安乐事少。或为病等苦逼自身。如有颂言

  梵行妙成立　　圣道已善修
  寿尽时欢喜　　犹如舍众病

此中应知。依何处所谁能如是留舍寿行。谓三洲人女男相续。不时解脱得边际定诸阿罗汉。由彼身中有自在定无烦恼故。经说。世尊留多命行舍多寿行。命寿何别。有言。无别。如本论言。云何命根。谓三界寿。有余师说。先世业果名为寿行。现在业果名为命行。有说。由此众同分住名为寿行。由此暂住名为命行。多言为显留舍多念命行寿行非一刹那。命行寿行有留舍故。有说。此言为遮有一命寿实体经多时住。有说。此言为显无一实命寿体。但于多行假立如是命寿二名。若谓不然。不应言行。世尊何故舍多寿行留多命行。为显于死得自在故舍多寿行。为显于活得自在故留多命行。唯留三月不增减者。越此更无所化事故。减此利生不究竟故。又为成立先自称言我善修行四神足故。欲住一劫或一劫余。如心所期则便能住。毗婆沙师作如是说。显今能伏蕴死二魔。世尊先于菩提树下。已伏天魔烦恼魔故。傍论已竟。正论应辩。忧根及后信等八根皆非异熟。是有记故。余皆通二。义准已成。谓七色意根除忧余四受十二一一皆通二类。七有色根若所长养则非异熟。余皆异熟。意及四受若善染污。若威仪路及工巧处。并能变化。随其所应亦非异熟。余皆异熟。若说忧根非异熟者。此经所说当云何通。如契经言。有三种业。顺喜受业。顺忧受业。顺舍受业。依受相应言顺无过。谓业与忧相应故名顺忧受业。如触与乐相应说名顺乐受触。若尔顺喜顺舍受业亦应如是。一经说故。随汝所欲于我无违。异熟相应理皆无失。无逃难处。作此通经理实何因。忧非异熟。以忧分别差别所生。止息亦然。异熟不尔。若尔喜根应非异熟。亦由分别生及止息故。若许忧根是异熟者。造无间业已因即生忧。此业尔时应名果已熟。亦应如是征难喜根。若许喜根是异熟者。造胜福业已因即生喜。此业尔时应名果已熟。毗婆沙师咸作是说。已离欲者无忧根故。异熟不然故非异熟。若尔应说离欲有情异熟喜根何相知有。随彼有相此相亦然。谓善喜根此位容有。无记异熟应类非无。于此位中忧一切种无容有故定非异熟。眼等八根。若在善趣是善异熟。若在恶趣是恶异熟。意根随在善趣恶趣。是俱异熟。喜乐舍根随在何趣是善异熟。苦根随在善趣恶趣是恶异熟。于善趣中有二形者唯根处所。不善业招善趣色根。善业引故。如是已说是异熟等。二十二根中几有异熟几无异熟。颂曰

  忧定有异熟　　前八后三无
  意余受信等　　一一皆通二

论曰。如前所诤忧根。当知定有异熟。依唯越义颂说定声。谓显忧根唯有异熟兼具二义故越次说。具二义者。忧非无记。强思起故。亦非无漏。唯散地故。由此越次先说忧根定有异熟。眼等前八及最后三定无异熟。八无记故。三无漏故。余皆通二。义准已成。谓意根余四受信等言等取精进等四根。此十一一皆通二类。意乐喜舍若不善善有漏有异熟。若无记无漏无异熟。苦根若善不善有异熟。若无记无异熟。信等五根若有漏有异熟。若无漏无异熟。如是已说有异熟等。二十二根中几善几不善几无记。颂曰

  唯善后八根　　忧通善不善
  意余受三种　　前八唯无记

论曰。信等八根一向是善。数次虽居后乘前故先说。忧根唯通善不善性。意及余受一一通三。眼等八根唯无记性。如是已说善不善等。二十二根中。几欲界系。几色界系。几无色界系。颂曰

  欲色无色界　　如次除后三
  兼女男忧苦　　并除色喜乐

论曰。欲界除后三无漏根。由彼三根唯不系故。准知欲界系唯有十九根。色界如前。除三无漏兼除男女忧苦四根。准知十五根亦通色界系。除女男者。色界已离淫欲法故。由女男根身丑陋故。若尔何故说彼为男。于何处说。契经中说。如契经言。无处无容女身为梵。有处有容男身为梵。别有男相。谓欲界中男身所有。无苦根者身净妙故。又彼无有不善法故。无忧根者由奢摩他润相续故。又彼定无恼害事故。无色如前。除三无漏女男忧苦。并除五色及喜乐根。准知余八根通无色界系。谓意命舍信等五根。如是已说欲界系等。二十二根中。几见所断。几修所断。几非所断。颂曰

  意三受通三　　忧见修所断
  九唯修所断　　五修非三非

论曰。意喜乐舍一一通三。皆通见修非所断故。忧根唯通见修所断。非无漏故。七色命苦唯修所断。不染污故。非六生故。皆有漏故。信等五根或修所断。或非所断。非染污故。皆通有漏及无漏故。最后三根唯非所断。皆无漏故。非无过法是所断故。已说诸门义类差别。何界初得几异熟根。颂曰

  欲胎卵湿生　　初得二异熟
  化生六七八　　色六上唯命

论曰。欲胎卵湿生初受生位。唯得身与命二异熟根。由此三生根渐起故。彼何不得意舍二根。此续生时定染污故。化生初位得六七八。谓无形者初得六根。如劫初时。何等为六。所谓眼耳鼻舌身命。若一形者初得七根。如诸天等。若二形者初得八根。岂有二形受化生者。恶趣容有二形化生。说欲界中初得根已。今次当说色无色界。欲界欲胜故但言欲。色界色胜故但言色。契经亦言。寂静解脱过色无色。色界初得六异熟根。如欲化生无形者说。上唯命者。谓无色界定胜生胜故说上言。无色界中最初所得异熟根者。唯命非余。说异熟根最初得已。何界死位几根后灭。颂曰

  正死灭诸根　　无色三色八
  欲顿十九八　　渐四善增五

论曰。在无色界将命终时。命意舍三于最后灭。若在色界将命终时。即前三根及眼等五。如是八种于最后灭。一切化生必具诸根而生死故。若在欲界顿命终时。十九八根于最后灭。谓二形者后灭十根即女男根并前八种。若一形者后灭九根。于女男中随除一种。若无形者后灭八根。谓无女男唯有前八。如是所说依顿命终。若渐命终后唯舍四。谓在欲界渐命终时。身命意舍于最后灭。此四必无前后灭义。如是所说。应知但依染无记心而命终者。若在三界善心死时。信等五根必皆具有。故于前说一切位中。其数皆应加信等五。谓于无色增至八根。乃至欲界渐终至九。中间多少如理应知。分别根中一切根法皆应思择。二十二根几能证得何沙门果。颂曰

  九得边二果　　七八九中二
  十一阿罗汉　　依一容有说

论曰。边谓预流阿罗汉果。于沙门果居初后故。中谓一来及不还果。此观初后在中间故。初预流果由九根得。谓意及舍信等五根未知当知已知为九未知根在无间道。已知根在解脱道。此二相资得最初果。如其次第。于离系得能为引因依因性故。阿罗汉果亦九根得。谓意信等五已知具知及喜乐舍中随一为九。已知根在无间道。具知根在解脱道。此二相资得最后果。如其次第。于离系得能为引因依因性故。中间二果随其所应各为七八九根所得。所以者何。且一来果次第证者。依世间道由七根得。谓意及舍信等五根。依出世道由八根得。谓即前七根已知根第八。倍离欲贪超越证者。如预流果由九根得。若不还果次第证者。依世间道由七根得。依出世道由八根得。如前次第得一来果。全离欲贪超越证者。由九根得。如前超越得一来果。总说虽然而有差别。谓此依地有差别故。乐喜舍中可随取一。前果超越唯一舍根。又次第证不还果者。若于第九解脱道中入根本地依世间道由八根得。彼无间道舍受相应。解脱道中复有喜受。此二相资得第三果。于离系得二因如前。依出世道由九根得。八根如前已知第九。无间解脱此俱有故。岂不根本阿毗达磨。问由几根得阿罗汉。答十一根。云何乃言由九根得。实得第四但由九根。而本论言十一根者。依一身中容有故说。谓容有一补特伽罗从无学位数数退已。由乐喜舍随一现前。数复证得阿罗汉果。由斯本论说十一根。然无一时三受俱起。是故今说定由九根。于不还果中何不如是说。以无乐根证不还果。而于后时得有退义。亦无退已。由乐复得非先离欲超证第三有还退义。此离欲果二道所得极坚牢故。今应思择。成就何根。彼诸根中几定成就。颂曰

  成就命意舍　　各定成就三
  若成就乐身　　各定成就四
  成眼等及喜　　各定成五根
  若成就苦根　　彼定成就七
  若成女男忧　　信等各成八
  二无漏十一　　初无漏十三

论曰。命意舍中随成就一。彼定成就如是三根。非此三中随有所阙。可有成就所余根者。除此三根余皆不定。谓或成就或不成就。此中眼耳鼻舌四根。生无色界定不成就。若生欲界未得已失亦不成就。身根唯有生无色界定不成就。女男二根生上二界定不成就。若生欲界未得已失亦不成就。乐根异生生第四定及无色界定不成就。喜根异生生三四定及无色界定不成就。苦根若生色无色界定不成就。忧根一切离欲贪者定不成就。信等五根善根断者定不成就。初无漏根一切异生及已住果定不成就。次无漏根一切异生见道无学定不成就。后无漏根一切异生及有学位定不成就。于非遮位应知如前所说诸根皆定成就。若成乐根定成就四。谓命意舍及此乐根。若成身根亦定成四。谓命意舍及此身根。若成眼根定成就五。谓命意舍身根眼根。耳鼻舌根应知亦五。前四如眼。第五自根。若成喜根亦定成五。谓命意舍乐根喜根。第二静虑地生未得第三静虑。舍下未得上。此成何乐根。当言成就第三静虑染污乐根。余未得故。若成苦根定成就七。谓身命意四受。除忧。若成女根定成就八。七如苦说。第八女根。若成男根亦定成八。七如苦说。第八男根。若成忧根亦定成八。七如苦说。第八忧根。若成信等亦各成八。谓命意舍信等五根。若成具知根定成就十一。谓命与意乐喜舍根信等五根及具知根。若成已知根亦定成十一。十根如上及已知根。若成未知根定成就十三。谓身命意苦乐喜舍信等五根及未知根。诸极少者成就几根。颂曰

  极少八无善　　成受身命意
  愚生无色界　　成善命意舍

论曰。已断善根名为无善。彼若极少成就八根。谓五受根及身命意。受谓能受。能领纳故。或是受性故名为受。如圆满性立圆满名。如断善根极少成八。愚生无色亦成八根。愚谓异生。未见谛故。何等为八。谓信等五命意舍根。信等五根。一向善故总名为善。若尔应摄三无漏根。不尔此中依八根故。又说愚生无色界故。诸极多者成就几根。颂曰

  极多成十九　　二形除三净
  圣者未离欲　　除二净一形

论曰。诸二形者具眼等根。除三无漏成余十九。无漏名净。离二缚故。二形必是欲界异生。未离欲贪故有十九。唯此具十九为更有耶。圣者未离欲亦具十九。谓圣有学未离欲贪成就极多亦具十九。除二无漏及除一形。若住见道。除已知根及具知根。若住修道。除未知根及具知根。女男二根随除一种。以诸圣者无二形故。因分别界根非根差别。乘兹广辩二十二根竟

说一切有部俱舍论卷第三阿毗达磨俱舍论卷第四

        尊者世亲造

        三藏法师玄奘奉　诏译

    分别根品第二之二

今应思择。一切有为如相不同。生亦各异。为有诸法决定俱生。有定俱生。谓一切法略有五品。一色。二心。三心所。四心不相应行。五无为。无为无生此中不说。今先辩色决定俱生。颂曰

  欲微聚无声　　无根有八事
  有身根九事　　十事有余根

论曰。色聚极细立微聚名。为显更无细于此者。此在欲界无声无根。八事俱生随一不减。云何八事。谓四大种及四所造色香味触。无声有根诸极微聚。此俱生事或九或十。有身根聚九事俱生。八事如前。身为第九。有余根聚十事俱生。九事如前加眼等一。眼耳鼻舌必不离身。展转相望处各别故。于前诸聚若有声生。如次数增九十十一。以有声处不离根生。谓有执受大种因起。若四大种不相离生。于诸聚中坚湿暖动。云何随一可得非余。于彼聚中势用增者明了可得。余体非无。如觉针锋与筹合触。如尝盐味与糗合味。云何于彼知亦有余。由有摄熟长持业故。有说。遇缘坚等便有流等相故。如水聚中由极冷故有暖相起。虽不相离而冷用增。如受及声用有胜劣。有余师说。于此聚中余有种子未有体相故。契经说。于木聚中有种种界。界谓种子。如何风中知有显色。此义可信。不可比知。或所合香现可取故。香与显色不相离故。前说色界香味并无故。彼无声有六七八。有声有七八九俱生。此可准知故不别说。此中言事为依体说。为依处说。若尔何过。二俱有过。若依体说。八九十等便为太少。由诸微聚必有形色有多极微共积集故。重性轻性定随有一。滑性涩性随一亦然。或处有冷有饥有渴。是则所言有太少过。若依处说。八九十等便为太多。由四大种触处摄故。应说四等。是则所言有太多失。二俱无过。应知此中所言事者。一分依体说。谓所依大种。一分依处说。谓能依造色。若尔大种事应成多。造色各别依一四大种故。应知此中依体类说。诸四大种类无别故。何用分别如是语为。语随欲生。义应思择。如是已辩色定俱生。余定俱生今次当辩。颂曰

  心心所必俱　　诸行相或得

论曰。心与心所必定俱生。随阙一时余则不起。诸行即是一切有为。谓色心心所心不相应行。前必俱言流至于此。谓色心等诸行生时。必与有为四相俱起。言或得者。谓诸行内唯有情法与得俱生。余法不然。是故言或。向言心所。何者是邪。颂曰

  心所且有五　　大地法等异

论曰。诸心所法且有五品。何等为五。一大地法。二大善地法。三大烦恼地法。四大不善地法。五小烦恼地法。地谓行处。若此是彼所行处。即说此为彼法地。大法地故名为大地。此中若法大地所有名大地法。谓法恒于一切心有。彼法是何。颂曰

  受想思触欲　　慧念与作意
  胜解三摩地　　遍于一切心

论曰。传说。如是所列十法。诸心刹那和合遍有。此中受谓三种领纳苦乐俱非有差别故。想谓于境取差别相。思谓能令心有造作。触谓根境识和合生。能有触对。欲谓希求所作事业。慧谓于法能有简择。念谓于缘明记不忘。作意谓能令心警觉。胜解谓能于境印可。三摩地谓心一境性。诸心心所异相微细。一一相续分别尚难。况一刹那俱时而有。有色诸药色根所取。其味差别尚难了知。况无色法唯觉慧取。如是已说十大地法。大善法地名大善地。此中若法大善地所有名大善地法。谓法恒于诸善心有。彼法是何。颂曰

  信及不放逸　　轻安舍惭愧
  二根及不害　　勤唯遍善心

论曰。如是诸法唯遍善心。此中信者。令心澄净。有说。于谛实业果中现前忍许故名为信。不放逸者。修诸善法离诸不善法。复何名修。谓此于善专注为性。余部经中有如是释。能守护心名不放逸。轻安者。谓心堪任性。岂无经亦说有身轻安耶。虽非无说。此如身受应知亦尔。如何可立此为觉支。应知此中身轻安者身堪任性。复如何说此为觉支。能顺觉支故无有失。以身轻安能引觉支心轻安故。于余亦见有是说耶。有如经说。喜及顺喜法名喜觉支。嗔及嗔因缘名嗔恚盖。正见正思惟正勤名慧蕴。思惟及勤虽非慧性随顺慧故亦得慧名。故身轻安顺觉支故得名无失。心平等性无警觉性说名为舍。如何可说于一心中有警觉性无警觉性。作意与舍二相应起。岂不前说诸心心所其相微细难可了知。有虽难了由审推度而复可知。此最难知。谓相违背而不乖反。此有警觉于余则无。二既悬殊有何乖反。若尔不应同缘一境。或应一切皆互相应。如是种类所余诸法此中应求。如彼理趣。今于此中应知亦尔。惭愧二种如后当释。二根者。谓无贪无嗔无痴善根慧为性故。前已说在大地法中。不重说为大善地法。言不害者。谓无损恼。勤谓令心勇悍为性。如是已说大善地法。大烦恼法地名大烦恼地。此中若法大烦恼地所有名大烦恼地法。谓法恒于染污心有。彼法是何。颂曰

  痴逸怠不信　　惛掉恒唯染

论曰。此中痴者。所谓愚痴。即是无明无智无显。逸谓放逸。不修诸善。是修诸善所对治法。怠谓懈怠心不勇悍。是前所说勤所对治。不信者谓心不澄净。是前所说信所对治。惛谓惛沈。对法中说。云何惛沈。谓身重性心重性。身无堪任性心无堪任性。身惛沈性心惛沈性。是名惛沈。此是心所。如何名身。如身受言。故亦无失。掉谓掉举令心不静。唯有如是六种。名大烦恼地法。岂不根本阿毗达磨中说有十种大烦恼地法。又于彼论不说惛沈。何者十。谓不信懈怠失念心乱无明不正知非理作意邪胜解掉举放逸。天爱。汝今但知言至不闲意旨。意旨者何。谓失念心乱不正知非理作意邪胜解。已说彼在大地法中。不应重立为大烦恼地法。如无痴善根慧为体故非大善地法。彼亦应尔。即染污念名为失念。染污等持名为心乱。诸染污慧名不正知。染污作意胜解名为非理作意及邪胜解故说。若是大地法亦大烦恼地法耶。应作四句。第一句谓受想思触欲。第二句谓不信懈怠无明掉举放逸。第三句谓如前说。念等五法。第四句谓除前相。有执。邪等持非即是心乱。彼作四句。与此不同。又许惛沈通与一切烦恼相应。不说在大烦恼地法。于谁有过。有作是言。应说在此。而不说者顺等持故。彼谓诸有惛沈行者速发等持。非掉举行。谁惛沈行非掉举行。谁掉举行非惛沈行。此二未尝不俱行故。虽尔应知随增说行。虽知说行随用偏增。而依有体建立地法。故此地法唯六义成。此唯遍染心俱起非余故。如是已说大烦恼地法。大不善法地名大不善地。此中若法大不善地所有名大不善地法。谓法恒于不善心有。彼法是何。颂曰

  唯遍不善心　　无惭及无愧

论曰。唯二心所但与一切不善心俱。谓无惭愧。故唯二种名此地法。此二法相如后当辩。如是已说大不善地法。小烦恼法地名小烦恼地。此中若法小烦恼地所有名小烦恼地法。谓法少分染污心俱。彼法是何。颂曰

  忿覆悭嫉恼　　害恨谄诳憍
  如是类名为　　小烦恼地法

论曰。如是类法唯修所断。意识地起。无明相应。各别现行。故名为小烦恼地法。此法如后随烦恼中当广分别。如是已说五品心所。复有此余不定心所。恶作睡眠寻伺等法。此中应说。于何心品有几心所决定俱生。颂曰

  欲有寻伺故　　于善心品中
  二十二心所　　有时增恶作
  于不善不共　　见俱唯二十
  四烦恼忿等　　恶作二十一
  有覆有十八　　无覆许十二
  睡眠遍不违　　若有皆增一

论曰。且欲界中心品有五。谓善唯一。不善有二。谓不共无明相应。及余烦恼等相应。无记有二。谓有覆无记及无覆无记。然欲界心定有寻伺故。善心品必二十二心所俱生。谓十大地法十大善地法及不定二。谓寻与伺。非诸善心皆有恶作。有时增数至二十三。恶作者何。恶所作体名为恶作。应知此中缘恶作法说名恶作。谓缘恶作心追悔性。如缘空解脱门说名为空。缘不净无贪说为不净。又见世间约所依处说能依事。如言一切村邑国土皆来集会。恶作即是追悔所依。故约所依说为恶作。又于果体假立因名。如说此六触处应知名宿作业。若缘未作事云何名恶作。于未作事亦立作名。如追悔言我先不作如是事业是我恶作。何等恶作说名为善。谓于善恶不作作中心追悔性。与此相违名为不善。此二各依二处而起。若于不善不共心品。必有二十心所俱生。谓十大地法。六大烦恼地法。二大不善地法。并二不定谓寻与伺。何等名为不共心品。谓此心品唯有无明。无有所余贪烦恼等。于不善见相应心品。亦有二十心所俱生。名即如前不共品说。非见增故有二十一。以即于十大地法中慧用差别说为见故。言不善见相应心者。谓此心中或有邪见。或有见取。或戒禁取。于四不善贪嗔慢疑烦恼心品。有二十一心所俱生。二十如不共。加贪等随一。于前所说忿等相应随烦恼品亦二十一心所俱生。二十如不共。加忿等随一。不善恶作相应心品亦二十一心所俱生。谓即恶作第二十一。略说不善不共及见相应品中唯有二十。余四烦恼及随烦恼相应品中有二十一。若于无记有覆心品。唯有十八心所俱生。谓十大地法六大烦恼地法并二不定谓寻与伺。欲界无记有覆心者。谓与萨迦耶见及边执见相应。此中见不增。应知如前释。于余无记无覆心品。许唯十二心所俱生。谓十大地法并不定寻伺。外方诸师欲令恶作亦通无记。此相应品便有十二心所俱起。应知睡眠与前所说一切心品皆不相违。通善不善无记性故。随何品有即说此增。谓二十二至二十三。若二十三至二十四不善无记如例应知。已说欲界心所俱生诸品定量。当说上界。颂曰

  初定除不善　　及恶作睡眠
  中定又除寻　　上兼除伺等

论曰。初静虑中于前所说诸心所法。除唯不善恶作睡眠。余皆具有。唯不善者。谓嗔烦恼除谄诳憍所余忿等及无惭愧。余皆有者。如欲界说。中间静虑除前所除。又更除寻。余皆具有。第二静虑以上乃至无色界中除前所除。又除伺等。等者显除谄诳。余皆如前具有。经说。谄诳极至梵天。众相依故。上地无有。以大梵王处自梵众。忽被马胜苾刍问言。此四大种当于何位尽灭无余。梵王不知无余灭位。便矫乱答。我于此梵众是大梵自在作者化者生者养者。是一切父。作是语已。引出众外谄言愧谢。令还问佛。如是已说于诸界地诸心品中心所数量。今次当说于前所辩诸心所中少分差别。无惭无愧爱之与敬差别云何。颂曰

  无惭愧不重　　于罪不见怖
  爱敬谓信惭　　唯于欲色有

论曰。此中无惭无愧别者于诸功德及有德者。无敬无崇无所忌难无所随属说名无惭。即是恭敬所敌对法。为诸善士所诃厌法说名为罪。于此罪中不见怖畏说名无愧。此中怖言。显非爱果。能生怖故。不见怖言欲显何义。为见而不怖名不见怖。为不见彼怖名不见怖。若尔何失。二俱有过。若见而不怖应显智慧。若不见彼怖应显无明。此言不显见与不见。何所显耶。此显有法是随烦恼。为彼二因说名无愧。有余师说。于所造罪自观无耻名曰无惭。观他无耻说名无愧。若尔此二所观不同。云何俱起。不说此二一时俱起别观自他。然有无耻。观自时胜说名无惭。复有无耻。观他时增说为无愧。惭愧差别翻此应知。谓翻初释有敬有崇有所忌难有所随属说名为惭。于罪见怖说名为愧。翻第二释于所造罪。自观有耻说名为惭。观他有耻说名为愧。已说无惭无愧差别。爱敬别者。爱谓爱乐。体即是信。然爱有二。一有染污。二无染污。有染谓贪如爱妻子等。无染谓信如爱师长等。有信非爱谓缘苦集信。有爱非信谓诸染污爱。有通信爱谓缘灭道信。有非信爱谓除前三相。有说。信者忍许有德。由此为先方生爱乐。故爱非信。敬谓敬重。体即是惭。如前解惭谓有敬等。有惭非敬谓缘苦集惭。有通惭敬谓缘灭道惭。有说。敬者有所崇重。由此为先方生惭耻。故敬非惭。望所缘境补特伽罗。爱敬有无应作四句。有爱无敬。谓于妻子共住门人等。有敬无爱。谓于他师有德贵人等。有爱有敬。谓于自师父母伯叔等。无爱无敬。谓除前三相。如是爱敬欲色界有。无色界无。岂不信惭大善地法无色亦有。爱敬有二。谓缘于法补特伽罗。缘法爱敬通三界有。此中意说缘补特伽罗者。故欲色有。无色界无。如是已说爱敬差别。寻伺慢憍差别云何。颂曰

  寻伺心粗细　　慢对他心举
  憍由染自法　　心高无所顾

论曰。寻伺别者。谓心粗细。心之粗性名寻。心之细性名伺。云何此二一心相应。有作是释。如冷水上浮以熟酥上烈日光之所照触。酥因水日非释非凝。如是一心有寻有伺。心由寻伺不遍细粗。故于一心俱有作用。若尔寻伺是粗细因。非粗细体。如水日光是凝释曰体非凝释。又粗细性相待而立。界地品别上下相形。乃至有顶应有寻伺。又粗细性无别体类。不可依之以别寻伺。复有释言。寻伺二法是语言行。故契经言。要有寻伺方有语言。非无寻伺此语言行。粗者名寻。细者名伺。于一心内别法是粗别法是细。于理何违。若有别体类理实无违。然无别体类故成违理。一体类中无容上下俱时起故。若言体类亦有差别。应说体类别相云何。此二体类别相难说。但由上下显其别相。非由上下能显别相。一一类中有上下故。由是应知。寻伺二法定不可执一心相应。若尔云何契经中说于初静虑具足五支。具五支言。就一地说非一刹那故无有过。如是已说寻伺差别。慢憍别者。慢谓对他心自举性。称量自他德类差别。心自举恃陵蔑于他故名为慢。憍谓染着自法为先令心傲逸无所顾性。有余师说。如因酒生欣举差别说名为醉。如是贪生欣举差别说名为憍。是谓慢憍差别之相。如是已说诸心心所品类不同俱生异相。然心心所于契经中随义建立种种名想。今当辩此名义差别。颂曰

  心意识体一　　心心所有依
  有缘有行相　　相应义有五

论曰。集起故名心。思量故名意。了别故名识。复有释言。净不净界种种差别故名为心。即此为他作所依止故名为意。作能依止故名为识。故心意识三名所诠。义虽有异而体是一。如心意识三名所诠义异体一诸心心所名有所依所缘行相相应亦尔。名义虽殊而体是一。谓心心所皆名有所依托所依根故。或名有所缘取所缘境故。或名有行相即于所缘品类差别等起行相故。或名相应等和合故。依何义故名等和合。有五义故。谓心心所五义平等故说相应。所依所缘行相时事皆平等故。事平等者。一相应中如心体一。诸心所法各各亦尔。已说心心所广分别义。心不相应行何者是耶。颂曰

  心不相应行　　得非得同分
  无想二定命　　相名身等类

论曰。如是诸法心不相应非色等性。行蕴所摄。是故名心不相应行。于中且辩得非得相。颂曰

  得谓获成就　　非得此相违
  得非得唯于　　自相续二灭

论曰。得有二种。一者未得已失今获。二者得已不失成就。应知非得与此相违。于何法中有得非得。于自相续及二灭中。谓有为法若有堕在自相续中有得非得。非他相续。无有成就他身法故。非非相续。无有成就非情法故。且有为法决定如是。无为法中唯于二灭有得非得。一切有情无不成就非择灭者。故对法中传说。如是谁成无漏法。谓一切有情。除初刹那具缚圣者及余一切具缚异生。诸余有情皆成择灭。决定无有成就虚空。故于虚空不言有得。以得无故非得亦无。宗明得非得相翻而立故。诸有得者亦有非得。义准可知。故不别释。何缘知有别物名得。契经说故。如契经言。圣者于彼十无学法以生以得以成就故。已断五支。乃至广说。若尔非情及他相续亦应成就。所以者何。契经说故。如契经说。苾刍当知。有转轮王成就七宝。乃至广说。此中自在说名成就。谓转轮王于彼七宝有自在力。随乐转故。此既自在说名成就。余复何因知有别物。许有别物有何非理。如是非理。谓所执得无体可知。如色声等或贪嗔等。无用可知如眼耳等。故无容有别物名得。执有别物是为非理。若谓此得亦有作用。谓作所得诸法生因。是则无为应无有得。又所得法未得已舍界地转易及离染故。彼现无得。当云何生。若俱生得为生因者。生与生生复何所作。又非情法应定不生。又具缚者。下中上品烦恼现起差别应无。得无别故。若由余因有差别者。即应由彼诸法得生。得复何用。故彼所言得有作用。谓作所得诸法生因理不成立。谁言此得作法生因。若尔此得有何作用。谓于差别为建立因。所以者何。若无有得。异生圣者起世俗心。应无异生及诸圣者建立差别。岂不烦恼已断未断有差别故。应有差别。若执无得。如何可说。烦恼已断及与未断。许有得者断未断成。由烦恼得离未离故。此由所依有差别故。烦恼已断未断义成。谓诸圣者见修道力。令所依身转变异本。于彼二道所断惑中无复功能令其现起。犹如种子火所焚烧转变异前无能生用。如是圣者所依身中无生惑能名烦恼断。或世间道损所依中烦恼种子亦名为断。与上相违名为未断。诸未断者说名成就。诸已断者名不成就。如是二种但假非实。善法有二。一者不由功力修得。二者要由功力修得。即名生得及加行得。不由功力而修得者。若所依中种未被损名为成就。若所依中种已被损名不成就。谓断善者由邪见力损所依中善根种子。应知名断。非所依中善根种子毕竟被害说名为断。要由功力而修得者。若所依中彼法已起生彼功力自在无损说名成就。与此相违名不成就。如是二种亦假非实。故所依中唯有种子未拔未损增长自在。于如是位立成就名。无有别物。此中何法名为种子。谓名与色于生自果。所有展转邻近功能。此由相续转变差别。何名转变。谓相续中前后异性。何名相续。谓因果性三世诸行。何名差别。谓有无间生果功能。然有处说。若成就贪便不能修四念住者。彼说。既着贪烦恼者不能厌舍故名成就。由随耽着贪爱时分。于四念住必不能修。如是成就遍一切种唯假非实。唯遮于此名不成就。亦假非实。毗婆沙师说。此二种皆有别物实而非假。如是二途皆为善说。所以者何。不违理故。我所宗故。已辩自性。差别云何。且应辩得。颂曰

  三世法各三　　善等唯善等
  有系自界得　　无系得通四
  非学无学三　　非所断二种

论曰。三世法得各有三种。谓过去法有过去得有未来得有现在得。如是未来及现在法各有三得。又善等法得唯善等。谓善不善及无记法。如其次第有善不善无记三得。又有系法得唯自界。谓欲色界无色界法如其次第唯有欲色无色三得。若无系法得通四种。谓无漏法。总而言之得有四种。即三界得及无漏得。别分别者。非择灭得通三界系。若择灭得色无色系及与无漏。道谛得唯无漏故。无系法得有四种。又有学法得唯有学。若无学法得唯无学。非学非无学得有差别。谓此法得总说有三。别分别者一切有漏及三无为。皆名非学非无学法。且有漏法唯有非学非无学得。非择灭得及非圣道所引择灭得亦如是。若有学道所引择灭得即有学。若无学道所引择灭得即无学。又见修所断法如其次第有见修所断得。非所断法得有差别。谓此法得总说有二。别分别者诸无漏法名非所断。非择灭得唯修所断。若非圣道所引择灭得亦如是。圣道所引择灭之得及道谛得皆非所断。前虽总说三世法各三。今应简别其中差别相。颂曰

  无记得俱起　　除二通变化
  有覆色亦俱　　欲色无前起

论曰。无覆无记得唯俱起。无前后生。势力劣故。法若过去得亦过去。法若未来得亦未来。法若现在得亦现在。一切无覆无记法得皆如是耶。不尔。云何除眼耳通及能变化。谓眼耳通慧及能变化心势力强故。加行差别所成办故。虽是无覆无记性收。而有前后及俱起得。若工巧处及威仪路极数习者得亦许尔。唯有无覆无记法得但俱起耶。不尔。云何。有覆无记色得亦尔。谓诸有覆无记表色得亦如前。但有俱起。虽有上品而亦不能发无表故势力微劣。由此定无法前后得。如无记法得有别异善不善得亦有异耶。亦有。云何。谓欲界系善不善色得无前起。唯有俱生及后起得。非得如得亦有如上品类别耶。不尔。云何。颂曰

  非得净无记　　去来世各三
  三界不系三　　许圣道非得
  说名异生性　　得法易地舍

论曰。性差别者。一切非得皆唯无覆无记性摄。世差别者。过去未来各有三种。谓现在法决定无有现在非得。唯有过去未来非得。过去未来一一各有三世非得。界差别者。三界系法及不系法各三非得。谓欲界系法有三界非得。色无色界系及不系亦尔。定无非得是无漏者。所以者何。由许圣道非得说名异生性故。如本论言。云何异生性。谓不获圣法。不获即是非得异名。非说异生性是无漏应理。不获何圣法名异生性。谓不获一切。不别说故。此不获言表离于获。若异此者。诸佛世尊亦不成就声闻独觉种性圣法。应名异生。若尔彼论应说纯言。不要须说。此一句中含纯义故。如说此类食水食风。有说。不获苦法智忍及俱生法名异生性。不可难言道类智时舍此法故应成非圣。前已永害彼非得故。若尔此性既通三乘。不获何等名异生性。此亦应言不获一切。若尔此应同前有难。此难复应如前通释。若尔重说唐捐其功。如经部师所说为善。经部所说其义云何。谓曾未生圣法相续分位差别名异生性。如是非得何时当舍。此法非得得此法时或转易地舍此非得。如圣道非得说名异生性。得此圣道时或易地便舍。余法非得。类此应思。若非得得断。非得非得生。如是名为舍于非得。得与非得。岂复有余得与非得。应言此二各复有余得及非得。若尔岂不有无穷过。无无穷过。许得展转更相成故。以法生时并其自体三法俱起。第一本法。第二法得。第三得得。谓相续中法得起故成就本法及与得得。得得起故。成就法得。是故此中无无穷过。如是若善若染污法。一一自体初生起时并其自体三法俱起。第二刹那六法俱起。谓三法得及三得得。第三刹那十八俱起。谓于第一第二刹那所生诸法有九法得及九得得。如是诸得后后转增。一切过去未来烦恼及随烦恼并生得善刹那刹那相应俱有无始无终生死轮转有无边得。且一有情生死相续刹那刹那起无边得。如是一切有情相续一一各别。刹那刹那无量无边诸得俱起。如是诸得极多集会。无对碍故互相容受。若不尔者。一有情得虚空不容。况第二等

说一切有部俱舍论卷第四阿毗达磨俱舍论卷第五

        尊者世亲造

        三藏法师玄奘奉　诏译

    分别根品第二之三

如是已辩得非得相。同分者何。颂曰

  同分有情等

论曰。有别实物名为同分。谓诸有情展转类等。本论说此名众同分。此复二种。一无差别。二有差别。无差别者。谓诸有情有情同分。一切有情各等有故。有差别者。谓诸有情界地趣生种姓男女近事苾刍学无学等各别同分。一类有情各等有故。复有法同分。谓随蕴处界。若无实物无差别相名同分者。展转差别诸有情中。有情有情等无差别。觉及施设不应得有。如是蕴等等无差别觉及施设如理应知。颇有死生不舍不得有情同分。应作四句。第一句者。谓是处死还生是处。第二句者。谓入正性离生位时。舍异生同分。得圣者同分。第三句者。谓是趣死生余趣等。第四句者。谓除前相。若别有实物名异生同分。何用别立异生性耶。非异人同分别有人性故。又非世间现见同分。以非色故亦非觉慧所能了别无别用故。世虽不了有情同分。而于有情谓无差别。故设有体亦何所用。又何因不许有无情同分。诸谷麦豆金铁庵罗半娜婆等。亦有自类互相似故。又诸同分展转差别。如何于彼更无同分。而起无别觉施设耶。又应显成胜论所执。彼宗执有总同句义。于一切法总同言智由此发生。彼复执有同异句义。于异品类同异言智由此发生。毗婆沙师作如是说。彼执与此义类不同。以说一物于多转故。又纵于彼若显不显。然此同分必有实物。契经说故。如世尊言。若还来此得人同分。乃至广说。虽有是说而不说言别有实物名为同分。若尔所说同分是何。即如是类诸行生时。于中假立人同分等。如诸谷麦豆等同分。此非善说。违我宗故。已辩同分。无想者何。颂曰

  无想无想中　　心心所法灭
  异熟居广果

论曰。若生无想有情天中。有法能令心心所灭名为无想。是实有物。能遮未来心心所法令暂不起如堰江河。此法一向是异熟果。谁之异熟。谓无想定。无想有情居在何处。居在广果。谓广果天中有高胜处如中间静虑名无想天。彼为恒无想为亦有想耶。生死位中多时有想。言无想者。由彼有情中间长时想不起故。如契经说。彼诸有情由想起故从彼处没。然彼有情如久睡觉。还起于想。从彼没已必生欲界。非余处所。先修定行势力尽故。于彼不能更修定故。如箭射空力尽便堕。若诸有情应生彼处必有欲界顺后受业。如应生彼北俱卢洲必定应有生天之业。已辩无想。二定者何。谓无想定及灭尽定。初无想定其相云何。颂曰

  如是无想定　　后静虑求脱
  善唯顺生受　　非圣得一世

论曰。如前所说有法能令心心所灭名为无想。如是复有别法能令心心所灭名无想定。无想者定名无想定。或定无想名无想定。说如是声。唯显此定灭心心所与无想同。此在何地。谓后静虑。即在第四静虑非余。修无想定为何所求。谓求解脱。彼执无想是真解脱。为求证彼修无想定。前说无想是异熟故。无记性摄。不说自成。今无想定一向是善。此是善故。能招无想有情天中五蕴异熟。既是善性为顺何受。唯顺生受。非顺现后及不定受。若起此定后虽退失。传说现身必还能起。当生无想有情天中。故得此定必不能入正性离生。又许此定唯异生得非诸圣者。以诸圣者于无想定如见深坑不乐入故。要执无想为真解脱。起出离想而修此定。一切圣者不执有漏为真解脱及真出离故。于此定必不修行。若诸圣者修得第四静虑定时。为如静虑亦得去来无想定不。余亦不得。所以者何。彼虽曾习以无心故。要大加行方便修得。故初得时唯得一世。谓得现在。如初受得别解脱戒。得此定已。第二念等乃至未舍。亦成过去。以无心故。无未来修。次灭尽定其相云何。颂曰

  灭尽定亦然　　为静住有顶
  善二受不定　　圣由加行得
  成佛得非前　　三十四念故

论曰。如无想定灭定亦然。此亦然声为例何义。例无想定心心所灭。如说复有别法能令心心所灭名无想定。如是复有别法能令心心所灭名灭尽定。如是二定差别相者。前无想定为求解脱。以出离想作意为先。此灭尽定为求静住。以止息想作意为先。前无想定在后静虑。此灭尽定唯在有顶。即是非想非非想处。此同前定性唯是善非无记染。善等起故。前无想定唯顺生受。此灭尽定通顺生后及不定受。谓约异熟有顺生受。或顺后受。或不定受。或全不受。谓若于下得般涅槃。此定所招何地几蕴。唯招有顶四蕴异熟。前无想定唯异生得。此灭尽定唯圣者得。非异生能起。怖畏断灭故。唯圣道力所能起故。现法涅槃胜解入故。此亦如前。非离染得。由何而得。由加行得。要由加行方证得故。又初得时唯得现在。不得过去不修未来。要由心力方能修故。第二念等乃至未舍亦成过去。世尊亦以加行得耶。不尔。云何。成佛时得。谓佛世尊尽智时得。佛无一德由加行得。暂起欲乐现在前时。一切圆德随乐而起故。佛众德皆离染得。世尊曾未起灭尽定。得尽智时云何得成俱分解脱。于起灭定得自在故。如已起者。成俱解脱。西方师说。菩萨学位先起此定后得菩提。云何此中不许彼说。若许彼说便顺尊者邬波鞠多理目足论。如彼论说。当言如来先起灭定后生尽智。迦湿弥罗国毗婆沙师说。非前起灭定后方生尽智。所以者何。传说。菩萨三十四念得菩提故。谛现观中有十六念。离有顶贪有十八念。谓断有顶九品烦恼起九无间九解脱道。如是十八足前十六成三十四。一切菩萨决定先于无所有处。已得离贪方入见道。不复须断下地烦恼。于此中间无容得起不同类心。故诸菩萨学位不应起灭尽定。外国诸师作如是说。若中间起不同类心。斯有何过。若尔便有越期心过。然诸菩萨不越期心。理实菩萨不越期心。然非不越无漏圣道。若尔期心如何不越。谓我未得诸漏永尽。终不解斯结加趺坐。决定不越如是期心。唯于一坐时诸事究竟故。前说为善我所宗故。虽已说二定有多同异相而于其中复有同异。颂曰

  二定依欲色　　灭定初人中

论曰。言二定者。谓无想定及灭尽定。此二俱依欲色二界而得现起。若有不许亦依色界起无想定。便违此文。谓本论言。或有是色有此有非五行。谓色缠有情或生有想天住不同类心。若入无想定。若入灭尽定。或生无想天已得入无想。是谓是色有此有非五行。由此证知。如是二定俱依欲色而得现起。是名同相。言异相者。谓无想定欲色二界皆得初起。灭定初起唯在人中。此在人中初修起已由退为先方生色界。依色界身后复修起。此灭尽定亦有退耶应言亦有。若不尔者即便违害邬陀夷经。经言。具寿有诸苾刍先于此处具净尸罗具三摩地具般罗若能数入出灭受想定斯有是处。应如实知。彼于现法或临终位。不能勤修令解满足。从此身坏超段食天。随受一处意成天身。于彼生已复数入出灭受想定亦有是处。应如实知。此意成天身。佛说是色界。灭受想定唯在有顶。若得此定必无退者。如何得往色界受生。有余部执第四静虑亦有灭定。依彼所执灭定无退。此义亦成。第四静虑有灭尽定义必不成。所以者何。九次第定契经说故。此若必然如何得有超越定义。此定次第依初学说。得自在时随乐超入。如是二定有多种异。谓地有异。第四静虑有顶地故。加行有异。出离止息想作意为先故。相续有异。异生圣者相续起故。异熟有异。无想有顶异熟果故。顺受有异。顺定不定生二受故。初起有异。二界人中最初起故。二定总以心心所灭为其自性。何缘但说名为无想灭受想耶。二定加行中唯厌逆此故。如亦知受等唯名他心智。今二定中心久时断。如何于后心复得生。毗婆沙师许过去有前心为后等无间缘。有余师言。如生无色色久时断。如何于后色复得生。彼生定应由心非色。如是出定心亦应然。由有根身非由心起。故彼先代诸轨范师咸言。二法互为种子。二法者。谓心有根身。尊者世友问论中说。若执灭定全无有心可有此过。我说灭定犹有细心故无此失。尊者妙音说。此非理。所以者何。若此定中犹有识者三和合故必应有触。由触为缘应有受想。如世尊说。意及法为缘生于意识。三和合触俱起受想思。则此定中受想等法亦应不灭。若谓如经说受缘爱。然阿罗汉虽有诸受而不生爱。触亦应尔。非一切触皆受等缘。此例不然。有差别故。经自简言。若无明触所生诸受为缘生爱。曾无有处简触生受故有差别。由此道理。毗婆沙师说。灭定中诸心皆灭。若都无心如何名定。此令大种平等行故说名为定。或由心力平等至此故名为定。如是二定为是实有。为是假有。应言实有。能遮碍心令不生故。有说。此证理不应然。由前定心能遮碍故。谓前定心与所余心相违而起。由此起故。唯令余心暂时不转。此能引发违心所依令相续故。唯不转位假立为定。无别实体。此唯不转分位假定。入前出后两位皆无。故假说此是有为摄。或即所依由定心引令如是起。假立为定。应知无想亦复如是。谓由前心与所余心。相违而起。由此起故。唯令余心暂时不转。唯不转位假立无想。余说如前。此非善说违我宗故。已辩二定。命根者何。颂曰

  命根体即寿　　能持暖及识

论曰。命体即寿。故对法言。云何命根。谓三界寿。此复未了。何法名寿。谓有别法能持暖识说名为寿。故世尊言

  寿暖及与识　　三法舍身时
  所舍身僵仆　　如木无思觉

故有别法。能持暖识相续住因说名为寿。若尔此寿何法能持。即暖及识还持此寿。若尔三法更互相持。相续转故。何法先灭。由此灭故余二随灭。是则此三应常无谢。既尔此寿应业能持。随业所引相续转故。若尔何缘不许唯业。能持暖识而须寿耶。理不应然。勿一切识从始至终恒异熟故。既尔应言业能持暖暖复持识。何须此寿。如是识在无色界中应无能持。彼无暖故。应言彼识业为能持。岂得随情数为转计。或说此识唯暖能持。或复说言唯业持识。又前已说。前说者何。谓前说言。勿一切识从始至终皆是异熟。是故定应许有别法。能持暖识说名为寿。今亦不言全无寿体。但说寿体非别实物。若尔何法说名寿体。谓三界业所引同分住时势分说为寿体。由三界业所引同分住时势分相续决定随应住时。尔所时住故。此势分说为寿体。如谷种等所引乃至熟时势分。又如放箭所引乃至住时势分。有谓有行是德差别依箭等生由彼力故。乃至未堕恒行不息。彼体一故。无障碍故。往趣余方急缓至时分位差别应不得有。又应毕竟无堕落时。若谓由风所障碍故。应初即堕或无堕时。能障碍风无差别故。有别实物能持暖识名为寿体。是说为善。为寿尽故死为更有余因。施设论说。有寿尽故死非福尽故死广作四句。第一句者。感寿异熟业力尽故。第二句者。感富乐果业力尽故。第三句者。能感二种业俱尽故。第四句者。不能避脱抂横缘故。又亦应言舍寿行故。寿尽位中福尽于死无复功能。故俱尽时有死说为俱尽故死。发智论说。此寿当言随相续转。为复当言一起便住。欲缠有情不入无想定不入灭尽定。当言此寿随相续转。若入无想定若入灭尽定及色无色缠一切有情。当言此寿一起便住。彼言何义。若所依身可损害故寿随损害。是名第一随相续转。若所依身不可损害如起而住。是名第二一起便住。迦湿弥罗国毗婆沙师言。初显有障。后显无障。由此决定有非时死。故契经说。有四得自体。谓有得自体唯可自害非可他害。广作四句。唯可自害非他害者。谓生欲界戏忘念天意愤恚天。彼由发起增上喜怒。是故于彼殒没非余。又应说诸佛自般涅槃故。唯可他害非自害者。谓处胎卵诸有情类。俱可害者。谓余多分欲界有情。俱非害者。谓在中有色无色界一切有情及在欲界一分有情。如那落迦北俱卢洲。正住见道慈定灭定。及无想定王仙佛使。佛所记别达弭罗嗢怛罗。殑耆罗长者子耶舍鸠磨罗时婆。最后身菩萨。及此菩萨母怀菩萨胎时。一切转轮王。及此轮王母怀轮王胎时。若尔何故契经中言。大德何等有情所得自体非可自害非可他害。舍利子。谓在非想非非想处受生有情。传说。所余无色静虑所得自体。可为自地圣道所害亦上他地近分所害。有顶自上二害俱无。是故说为俱非可害。岂不有顶亦为他地圣道所害应名他害。如是应说举后显初。如或有处举初显后。或复有处举后显初。云何有处举初显后。如契经说。如梵众天是名第一乐生天。云何有处举后显初。如契经说。如极光净天是名第二乐生天。彼经如声显譬喻义。可作是说。举一显余。喻法举一显同类故。此无如声不可例彼。若显喻义方得有如声。是则如声余经应不有。如余经说。有色有情身异想异如人一分天是第一识住。故知非喻亦有如声。傍论且止。已辩命根。诸相者何。颂曰

  相谓诸有为　　生住异灭性

论曰。由此四种是有为相法。若有此应是有为。与此相违是无为法。此于诸法能起名生。能安名住。能衰名异。能坏名灭。性是体义。岂不经说有三有为之有为相。于此经中应说有四。不说者何。所谓住相。然经说住异。是此异别名。如生名起灭名为尽。如是应知。异名住异。若法令行三世迁流。此经说为有为之相。令诸有情生厌畏故。谓彼诸行生力所迁。令从未来流入现在。异及灭相力所迁迫。令从现在流入过去。令其衰异及坏灭故。传说。如有人处稠林。有三怨敌欲为损害。一从稠林牵之令出。一衰其力。一坏命根。三相于行应知亦尔。住于彼行摄受安立。常乐与彼不相舍离。故不立在有为相中。又无为法有自相住。住相滥彼故经不说。有谓。此经说住与异总合为一名住异相。何用如是总合说为。住是有情所爱着处。为令厌舍与异合说。如示黑耳与吉祥俱。是故定有四有为相。此生等相既是有为。应更别有生等四相。若更有相便致无穷。彼复有余生等相故。应言更有。然非无穷。所以者何。颂曰

  此有生生等　　于八一有能

论曰。此谓前说四种本相。生生等者。谓四随相。生生住住异异灭灭。诸行有为由四本相。本相有为由四随相。岂不本相如所相法一一应有四种随相。此复各四展转无穷。无斯过失。四本四随于八于一功能别故。何谓功能。谓法作用或谓士用。四种本相一一皆于八法有用。四种随相一一皆于一法有用。其义云何。谓法生时并其自体九法俱起。自体为一相随相八。本相中生除其自性生余八法。随相生生于九法内唯生本生。谓如雌鸡有生多子有唯生一。生与生生生八生一其力亦尔。本相中住亦除自性住余八法。随相住住于九法中唯住本住。异及灭相随应亦尔。是故生等相复有相。随相唯四无无穷失。经部师说何缘如是分析虚空。非生等相有实法体如所分别。所以者何。无定量故。谓此诸相非如色等有定现比或至教量证体实有。若尔何故契经中言有为之起亦可了知。尽及住异亦可了知。天爱汝等执文迷义。薄伽梵说义是所依。何谓此经所说实义。谓愚夫类无明所盲。于行相续执我我所。长夜于中而生耽着。世尊为断彼执着故显行相续体是有为及缘生性。故作是说。有三有为之有为相。非显诸行一刹那中具有三相。由一刹那起等三相不可知故。非不可知应立为相。故彼契经复作是说。有为之起亦可了知。尽及住异亦可了知。然经重说有为言者。令知此相表是有为。勿谓此相表有为有如居白鹭表水非无。亦勿谓表有为善恶如童女相表善非善。诸行相续初起名生。终尽位中说名为灭。中间相续随转名住。此前后别名为住异。世尊依此说难陀言。是善男子善知受生。善知受住及善知受衰异坏灭。故说颂言

  相续初名生　　灭谓终尽位
  中随转名住　　住异前后别

复有颂言

  本无今有生　　相续随转住
  前后别住异　　相续断名灭

又有颂言

  由诸法刹那　　无住而有灭
  彼自然灭故　　执有住非理

是故唯于相续说住。由斯对法所说理成。故彼论言。云何名住。谓一切行已生未灭。非生已不灭名刹那法性。虽发智论作如是说。于一心中谁起谓生。谁尽谓死。谁住异谓老。而彼论文依众同分相续心说。非一刹那。又一一刹那诸有为法。离执实有物四相亦成。云何得成。谓一一念本无今有名生。有已还无名灭。后后刹那嗣前前起名为住。即彼前后有差别故名住异。于前后念相似生时。前后相望非无差别。彼差别相云何应知。谓金刚等有掷未掷。及强力掷与弱力掷速迟堕落时差别故。大种转变差别义成。诸行相似相续生时。前后相望无多差别。故虽有异而见相似。若尔最后声光刹那及涅槃时最后六处无后念故应无住异。是则所立相应不遍有为。此不说住为有为相。其义云何。谓住之异故。若有住亦必有异。由此立相无不遍失。然此经中世尊所说。有为之相略显示者。谓有为法本无今有。有已还无及相续住。即此前后相望别异。此中何用生等别物。云何所相法即立为能相。如何大士相非异于大士。角犎[古*頁]蹄尾牛相非异牛。又如坚等地等界相非异地等。远见上升知是烟相非异烟体。此有为相理亦应然。虽了有为色等自性。乃至未了先无后无相续差别。仍未知彼体是有为故非彼性即有为相。然非离彼性有生等实物。若离有为色等自性。有生等物复何非理。一法一时应即生住衰异坏灭许俱有故。此难不然。用时别故。谓生作用在于未来。现在已生不更生故。诸法生已正现在时。住等三相作用方起。非生用时有余三用。故虽俱有而不相违。且应思择。未来法体为有为无。然后可成生于彼位有用无用。设许未来生有作用。如何成未来。应说未来相。法现在时生用已谢。如何成现在应说现在相。又住等三用俱现在应一法体一刹那中即有安住衰异坏灭。若时住相能住此法。即时异灭能衰坏者。尔时此法为名安住为名衰异为名坏灭。诸说住等用不同时。彼说便违刹那灭义。若言我说一法诸相用皆究竟名一刹那。汝今应说。何缘住相与二俱生而住先能住所住法非异非灭。若住力强能先用者。后何成劣而并本法。俱遭异灭所衰坏耶。若言住相已起作用不应更起犹如生者。生应可然。夫生用者。谓引所生令入现在已入不应复引入故。住不应尔。夫住用者。谓安所住令不衰灭。已住可令永安住故。由斯住相用应常起。不可例生令无再用。又谁障住用令暂有还无。若言异灭能为障者。异灭力应强。何不于先用。又住用息。异灭本法自然不住。异灭二相何处如何而起作用。复有何事须二用耶。由住摄持诸法生已暂时不灭。住用既舍法定不住即自然灭。故异灭用更无所为。又应一法生已未坏名住住已坏时名灭。理且可然。异于一法。进退推征理不应有。所以者何。异谓前后性相转变非即此法可言异此。故说颂言

  即前异不成　　异前非一法
  是故于一法　　立异终不成

虽余部说遇灭因缘灭相方能灭所灭法。而彼所说。应如有言服泻药时天来令利。即灭因缘应灭所灭。何须别执有灭相为。又心心所许刹那灭。更不须待余灭因缘。应灭与住用无先后。是则一法于一时中亦住亦灭不应正理。故依相续说有为相。不违正理善顺契经。若生在未来生所生法。未来一切法何不俱生。颂曰

  生能生所生　　非离因缘合

论曰。非离所余因缘和合唯生相力能生所生故诸未来非皆顿起。若尔我等唯见因缘有生功能。无别生相有因缘合。诸法即生无即不生。何劳生相。故知唯有因缘力起。岂诸有法皆汝所知。法性幽微甚难知故。虽现有体而不可知。生相若无应无生觉。又第六转言不应成。谓色之生受之生等。如不应说色之色言。如责无生乃至无灭。皆如是责随其所应。若尔为成空无我觉法外应执空无我性。为成一二大小各别合离彼此有性等觉应如外道法外执有数量各别合离彼此有等别性。又为成立第六转言。应执别有色之聚性。又如说言色之自性。此第六转言何得成。是故生等唯假建立无别实物。为了诸行本无今有假立为生。如是本无今有生相。依色等法种类众多。为简所余说第六转言色之生受之生等。为令他知此生唯色非余受等。余例亦然。如世间说栴檀之香石子之体。此亦应尔。如是住等随应当知。若行离生相而得生者。虚空无为等何故不生。诸行名生由本无今有。无为体常有。何得言生。又如法尔不说一切皆有生。如是应许非一切法皆可生。又如有为同有生相而许因缘望有为法。或有功能或无功能。如是应许一切有为及无为法同无生相而诸因缘望彼二法一有生用一无生用。毗婆沙师说。生等相别有实物其理应成。所以者何。岂容多有设难者。故便弃所宗。非恐有鹿而不种麦。惧多蝇附不食美团。故于过难。应勤通释。于本宗义应顺修行。如是已辩诸有为相。名身等类其义云何。颂曰

  名身等所谓　　想章字总说

论曰。等者等取句身文身。应知此中。名谓作想。如说色声香味等想。句者谓章。诠义究竟。如说诸行无常等章。或能辩了业用德时相应差别。此章称句。文者谓字。如说[褒-保+可]阿壹伊等字。岂不此字亦书分名。非为显书分制造诸字。但为显诸字制造书分。云何当令虽不闻说而亦得解。故造书分。是故诸字非书分名。云何名等身。谓想等总说。言总说者是合集义。于合集义中说嗢遮界故。此中名身者。谓色声香等。句身者谓诸行无常一切法无我涅槃寂静等。文身者。谓迦佉伽等。岂不此三语为性故用声为体色自性摄。如何乃说为心不相应行。此三非以语为自性。语是音声。非唯音声即令了义。云何令了。谓语发名。名能显义。乃能令了。非但音声皆称为语。要由此故义可了知。如是音声方称语故。何等音声令义可了。谓能说者。于诸义中已共立为能诠定量。且如古者于九义中共立一瞿声为能诠定量。故有颂言

  方兽地光言　　金刚眼天水
  于斯九种义　　智者立瞿声

诸有执名能显义者。亦定应许如是义名。谓共立为能诠定量。若此句义由名能显。但由音声显用已办。何须横计别有实名。又未了此名如何由语发。为由语显。为由语生。若由语生。语声性故。声应一切皆能生名。若谓生名声有差别。此足显义。何待别名。若由语显。语声性故。声应一切皆能显名。若谓显名声有差别。此足显义。何待别名。又诸念声不可聚集。亦无一法分分渐生。如何名生可由语发。云何待过去诸表刹那。最后表刹那能生无表。若尔最后位声乃生名。但闻最后声应能了义。若作是执语能生文文复生名名方显义。此中过难应同前说。以诸念文不可集故。语显名过。应例如生。又异语文诸明慧者注心思择莫辩其相。又文由语若显若生。准语于名皆不应理。又若有执名如生等与义俱生。现在世名目去来义不应得有。又父母等随意所欲立子等名。云何可言名如生等与义俱起。又无为法应无有名。无生义故而不应许。然世尊说颂依于名及文生者。此于诸义共立分量。声即是名。此名安布差别为颂。由如是义。说颂依名。此颂是名安布差别。执有实物不应正理。如树等行及心次第。或唯应执别有文体即总集此为名等身。更执有余便为无用。毗婆沙师说。有别物为名等身。心不相应行蕴所摄。实而非假。所以者何。非一切法皆是寻思所能了故。此名身等何界所系。为是有情数。为非有情数。为是异熟生为是所长养。为是等流性。为善为不善。为无记。此皆应辩。颂曰

  欲色有情摄　　等流无记性

论曰。此名身等唯是欲色二界所系。有说。亦通无色界系。然不可说。又名身等有情数摄。能说者成非所显义。又名身等唯是等流。又唯无覆无记性摄。如上所说。余不相应所未说义今当略辩。颂曰

  同分亦如是　　并无色异熟
  得相通三类　　非得定等流

论曰。亦如是言。为显同分如名身等通于欲色有情等流无覆无记。并无色言显非唯欲色。言并异熟显非唯等流。是界通三。类通二义。得及诸相类并通三。谓有刹那等流异熟非得二定唯是等流。唯言为明非异熟等。已说如是所未说义。无想命根如前已辩。何缘不说得等唯是有情数摄。已说有情所成等故。何缘不说相通有情非有情数。已说一切有为俱故。余所未说随应准知

说一切有部俱舍论卷第五阿毗达磨俱舍论卷第六

        尊者世亲造

        三藏法师玄奘奉　诏译

    分别根品第二之四

如是已说不相应行。前言生相生所生时非离所余因缘和合。此中何法说为因缘。且因六种。何等为六。颂曰

  能作及俱有　　同类与相应
  遍行并异熟　　许因唯六种

论曰。因有六种。一能作因。二俱有因。三同类因。四相应因。五遍行因。六异熟因。对法诸师许因唯有如是六种。且初能作因相云何。颂曰

  除自余能作

论曰。一切有为唯除自体以一切法为能作因。由彼生时无障住故。虽余因性亦能作因。然能作因更无别称。如色处等总即别名。岂不未知诸漏当起。由已知故诸漏不生。智于漏生能为障碍。日光能障现睹众星。如何有为唯除自体以一切法为能作因。应知此生时彼皆无障住。故彼于此是能作因。若于此生彼能为障。而不为障可立为因。譬如国人以其国主不为损害。咸作是言。我因国主而得安乐。若于此生彼无障用。设不为障何得为因。且如涅槃及不生法普于一切有为生中。那落迦等有情相续于无色界诸蕴生中。有如非有无能障用。虽无障用而亦为因。如无力国王亦得如前说。此即通说诸能作因。就胜为言非无生力。如眼色等于眼识等生饮食于身种等于牙等。有作是难。若一切法无障住故皆能作因。何缘诸法非皆顿起。一杀生时何缘一切非如杀者皆成杀业。此难不然。但由无障许一切法为能作因。非由于生有亲作力。有余师说。诸能作因皆于果生有能作力。且涅槃等于眼识生云何名为有能作力。意识缘彼为境而生或善或恶。因此意识后时眼识次第得生。展转因故。彼涅槃等于眼识生有能作力。如是余法由此方隅展转应知有能生力。如是已说能作因相。第二俱有因相云何。颂曰

  俱有互为果　　如大相所相
  心于心随转

论曰。若法更互为士用果彼法更互为俱有因。其相云何。如四大种更互相望为俱有因。如是诸相与所相法心与心随转亦更互为因。是则俱有因由互为果遍摄有为法如其所应。法与随相非互为果。然法与随相为俱有因。非随相于法。此中应辩。何等名为心随转法。颂曰

  心所二律仪　　彼及心诸相
  是心随转法

论曰。一切所有心相应法。静虑无漏二种律仪。彼法及心之生等相。如是皆谓心随转法。如何此法名心随转。颂曰

  由时果善等

论曰。略说由时果等善等故说此法名心随转。且由时者。谓此与心一生住灭及堕一世。由果等者。谓此与心一果异熟及一等流。应知此中前一后一显俱显共其义不同。由善等者。谓此与心同善不善无记性故。由此十因名心随转。此中心王极少犹与五十八法为俱有因。谓十大地法。彼四十本相。心八本随相。名五十八法。五十八中除心四随相。余五十四为心俱有因。有说。为心因唯十四法。谓十大地法并心本相。此说非善。所以者何。违品类足论所说故。如彼论言。或有苦谛以有身见为因。非与有身见为因。除未来有身见及彼相应法生老住非常诸余染污苦谛。或有苦谛以有身见为因。亦与有身见为因。即所除法。有余师不诵及彼相应法。迦湿弥罗国毗婆沙师言。彼文必应作如是诵。或应准义知说有余。诸由俱有因故成因彼必俱有。或有俱有非由俱有因故成因。谓诸随相各于本法。此诸随相各互相对。随心转法随相于心。此诸随相展转相对。一切俱生有对造色展转相对。少分俱生无对造色展转相对。一切俱生造色大种展转相对。一切俱生得与所得展转相对。如是等诸法虽名俱有而非由俱有因故成因。非一果异熟及一等流故。得与所得非定俱行。或前或后或俱生故。如是一切理且可然。而诸世间种等芽等极成因果相生事中未见如斯同时因果故。今应说。云何俱起诸法聚中有因果义。岂不现见。灯焰灯明芽影同时亦为因果。此应详辩。为即灯焰与明为因。为由前生因缘和合焰明俱起。余物障光明而有影现。如何说此影用芽为因。理不应然。随有无故。善因明者。说因果相言若此有无彼随有无者。此定为因彼定为果。俱有法中一有一切有。一无一切无。理成因果。俱起因果理且可然。如何可言互为因果。即由前说此亦无违。若尔如前所说造色互不相离应互为因。如是造色与诸大种心随相等与心等法皆不相离应互为因。若谓如三杖互相依住如是俱有法因果义成。此应思惟。如是三杖为由俱起相依力住。为由前生因缘合力令彼三杖俱起住耶。又于彼中亦有别物绳钩地等连持令住。此亦有余同类因等。是故俱有因义得成。如是已说俱有因相。第三同类因相云何。颂曰

  同类因相似　　自部地前生
  道展转九地　　唯等胜为果
  加行生亦然　　闻思所成等

论曰。同类因者。谓相似法与相似法为同类因。谓善五蕴与善五蕴展转相望为同类因。染污与染污无记与无记五蕴相望应知亦尔。有余师说。净无记蕴五是色果。四非色因。有余师说。五是四果色非四因。有余师说。色与四蕴相望展转皆不为因。又一身中羯刺蓝位能与十位为同类因。頞部昙等九位一一皆除前位与余为因。若对余身同类十位一一皆与十位为因。由此方隅外麦稻等自类自类应广思择。若不许色为色同类因彼执便违本论文所说故。本论说。过去大种未来大种因增上等。为诸相似于相似法皆可得说为同类因。不尔。云何。自部自地唯与自部自地为因。是故说言自部自地。部谓五部即见苦所断乃至修所断。地谓九地即欲界为一静虑无色八。此中见苦所断法还与见苦所断为同类因非余。如是乃至修所断还与修所断法为同类因非余。于中一一若欲界地还与欲界为同类因。初静虑地与初静应为同类因。乃至有顶与有顶地为同类因。异地相望皆无因义。又此非一切。何者。谓前生唯诸前生与后相似生未生法为同类因。云何知然。本论说故。如发智论说。云何同类因。谓前生善根与后生自界善根及彼相应法为同类因。如是过去与余二世过去现在与未来等皆应广说。然即彼论作是问言。若法与彼法为因。或时此法与彼非因耶。彼即答言无时非因者。此依俱有相应异熟三因密说故无有过。有谓未来正生位法定能与彼为同类因。是故彼文依最后位密作是答无时非因。彼于所难非为善释。以未来法正生位前非同类因后方成故。又若尔者。彼复问言。若法与彼法为等无间。或时此法与彼非等无间耶。彼即答言。若时此法未至已生。若如彼释。应亦答言无时非缘。如何乃答若时此法未至已生。然彼复释。为现二门。如彼处说此亦应尔。如此处说彼亦应尔。如是作文获何功德。唯显论主非善于文。是故应知。前释为善。若尔何故品类足说。或有苦谛以有身见为因。非与有身见为因。除未来有身见及彼相应苦谛诸余染污苦谛。或有苦谛以有身见为因。亦与有身见为因。即所除法。彼文应说除未来有身见相应苦谛。设有如彼说。由义应知非。复云何通施设足论。彼说诸法四事决定。所谓因果所依所缘。应知彼文。因者谓能作俱有相应异熟因。果者。谓增上士用异熟果。所依者谓眼等六根。所缘者谓色等六境。若尔同类因应本无而有。许故无过。约位非体。由和合作用位果非体果。若同类因未来世有如异熟因当有何过。未来若有。本论应说。本论唯说能取与果诸同类因故无有失。无如是义。以同类因引等流果此未来有理必不然。无前后故。不应已生法为未生等流。如过去法非现在果。勿有果先因后过失故。未来世无同类因。若尔异熟因应未来非有。不应异熟果因前及俱故。未来世法无前后故。无如是失。不相似故。谓同类因与果相似。若无前后应互为因。既互为因应互为果。互为因果与理相违。非异熟因与果相似。虽离前后而无上过。故同类因就位建立未来非有。若异熟因就相建立未来非无。言同类因唯自地者定依何说。定依有漏。若无漏道展转相望一一皆与九地为因。谓未至定静虑中间四本静虑三本无色九地道谛皆互为因。所以者何。此于诸地皆如客住不堕界摄。非诸地爱执为己有。是故九地道虽地不同而展转为因。由同类故。然唯得与等胜为因。非为劣因。加行生故。且如已生苦法智忍还与未来苦法智忍为同类因是名为等。又即此忍复能与后从苦法智至无生智为同类因。是名为胜。如是广说。乃至已生诸无生智。唯与等类为同类因。更无胜故。又诸已生见道修道及无学道。随其次第与三二一为同类因。又于此中诸钝根道与钝及利为同类因。若利根道唯利道因。如随信行及信胜解时解脱道随其次第与六四二为同类因。若随法行及见至非时解脱道随其次第与三二一为同类因。诸上地道为下地因云何名为或等或胜。由因增长及由根故。谓见道等下下品等。后后位中因转增长。虽一相续中无容可得随信随法行二道现起而已生者为未来因。为唯圣道但与等胜为同类因。不尔。云何。余世间法加行生者亦与等胜为因非劣。加行生法其体云何。谓闻所成思所成等。等者等取修所成等。因闻思修所生功德名彼所成。加行生故唯与等胜为因非劣。如欲界系闻所成法能与自界闻思所成为同类因。非修所成因。欲界无故。思所成法与思所成为同类因。非闻所成因。以彼劣故。若色界系闻所成法。能与自界闻修所成为同类因。非思所成因。色界无故。修所成法唯与自界修所成法为同类因。非闻所成因。以彼劣故。无色界系修所成法。唯与自界修所成法为同类因。非闻思所成因。以无故劣故。如是诸法复有九品。若下下品为九品因。下中八因。乃至上上唯上上因。除前劣故。生得善法九品相望展转为因。染污亦尔。无覆无记总有四种。谓异熟生威仪路工巧处化心俱品。随其次第。能与四三二一为因。又欲界化心有四静虑果。非上静虑果下静虑果因。非加行因得下劣果。如勤功力种稻麦等。勿设劬劳而无所获。因如是义故。有问言。颇有已生诸无漏法非未生位无漏法因。有。谓已生苦法智品于未生位苦法忍品。又一切胜于一切劣。颇有一身诸无漏法前所定得非后生因。有。谓未来苦法忍品于后已生苦法智品。以果必无在因前故。或同类因未来无故。颇有前生诸无漏法非后已起无漏法因。有。谓前生胜无漏法于后已起劣无漏法。如退上果下果现前。又前已生苦法智得于后已生苦法忍得非同类因。以彼劣故。如是已说同类因相。第四相应因相云何。颂曰

  相应因决定　　心心所同依

论曰。唯心心所是相应因。若尔所缘行相别者。亦应更互为相应因。不尔所缘行相同者乃可得说为相应故。若尔异时所缘行相同者应说为相应因。不尔要须所缘行相及时同者乃相应故。若尔异身所缘行相及时同者应说相应。如众同观初月等事为以一言总遮如是众多妨难故说同依。谓要同依心心所法方得更互为相应因。此中同言显所依一。谓若眼识用此刹那眼根为依相应受等亦即用此眼根为依。乃至意识及相应法同依意根。应知亦尔。相应因体即俱有因。如是二因义何差别。由互为果义立俱有因。如商侣相依共游险道。由五平等共相应义立相应因。即如商侣同受同作食等事业。其中阙一皆不相应。是故极成互为因义。如是已说相应因相。第五遍行因相云何。颂曰

  遍行谓前遍　　为同地染因

论曰。遍行因者。谓前已生遍行诸法。与后同地染污诸法为遍行因。遍行诸法。随眠品中遍行义处当广分别。此与染法为通因故。同类因外更别建立。亦为余部染法因故。由此势力余部烦恼及彼眷属亦生长故。圣者身中诸染污法岂亦用此为遍行因。迦湿弥罗国毗婆沙师说。一切染污法见所断为因。故品类足说如是言。云何见所断为因法。谓诸染污法及见所断法所感异熟。云何无记为因法。谓诸无记有为法及不善法。或有苦谛以有身见为因。非与有身见为因。广说乃至。除未来有身见及彼相应法生老住无常诸余染污苦谛。若尔云何通施设足论说。如彼论说。颇有法是不善唯不善为因耶。有。谓圣人离欲退最初已起染污思。依未断因密作是说。见所断法虽是此因而由已断故废不说。如是已说遍行因相。第六异熟因相云何。颂曰

  异熟因不善　　及善唯有漏

论曰。唯诸不善及善有漏是异熟因。异熟法故。何缘无记不招异熟。由力劣故。如朽败种。何缘无漏不招异熟。无爱润故。如贞实种无水润沃。又非系地。如何能招系地异熟。余法具二。是故能招。如贞实种水所沃润。异熟因义如何可了。为异熟之因名异熟因。为异熟即因名异熟因。义兼两释斯有何过。若异熟之因名异熟因。圣教不应言异熟生眼。若异熟即因名异熟因。圣教不应言业之异熟。两释俱通。已如前辩。所言异熟其义云何。毗婆沙师作如是释。异类而熟。是异熟义。谓异熟因唯异类熟。俱有等因唯同类熟。能作一因兼同异熟故。唯此一名异熟因。熟果不应余因所得。果具二义方得熟名。一由相续转变差别其体得生。二由随因势力胜劣时有分限。非彼俱有相应二因所生果体要由相续转变差别方乃得生。由取果时即与果故。又非能作同类遍行三因之果亦由随因势力胜劣时有分限。由善恶等穷生死边果数数生时无限故。由此但应作如是释。变异而熟。是异熟义。不应但异简别余因。于欲界中。有时一蕴为异熟因共感一果。谓有记得及彼生等。有时二蕴为异熟因共感一果。谓善不善身业语业及彼生等。有时四蕴为异熟因共感一果。谓善不善心心所法及彼生等。于色界中。有时一蕴为异熟因共感一果。谓有记得无想等至及彼生等。有时二蕴为异熟因共感一果。谓初静虑善有表业及彼生等。有时四蕴为异熟因共感一果。谓非等引善心心所及彼生等。有时五蕴为异熟因共感一果。谓是等引心心所法并随转色及彼生等。无色界中。有时一蕴为异熟因共感一果。谓有记得灭尽等至及彼生等。有时四蕴为异熟因共感一果。谓一切善心心所法及彼生等。有业唯感一处异熟。谓感法处即命根等。若感意处定感二处。谓意与法。若感触处应知亦尔。若感身处定感三处。谓身触法。感色香味应知亦尔。若感眼处定感四处。谓感眼处及身触法。感耳鼻舌应知亦尔。有业能感或五或六或七或八或九或十或十一处。业或少果或多果故。如外种果或少或多。种果少者如谷麦等。种果多者如莲石榴诺瞿陀等。有一世业三世异熟无三世业一世异熟。勿设劬劳果减因故。有一念业多念异熟无多念业一念异熟。此中所以如上应知。然异熟果无与业俱。非造业时即受果故。亦非无间。由次刹那等无间缘力所引故。又异熟因感异类果必待相续方能办故。如是六因定居何世。因居世定义虽已说而未颂摄。故应重辩。颂曰

  遍行与同类　　二世三世三

论曰。遍行同类唯居过现未来世无。理如前说。相应俱有异熟三因于三世中皆悉遍有。颂既不说能作因所居。义准应知。通三世非世。已说六因相别世定。何等为果对彼成因。颂曰

  果有为离系　　无为无因果

论曰。如本论说。果法云何。谓诸有为及与择灭。若尔无为许是果故则应有因。要对彼因乃可得说此为果故。又此无为许是因故亦应有果。要对彼果乃可得说此为因故。唯有为法有因有果非诸无为。所以者何。无六因故无五果故。何缘不许诸无间道与离系果为能作因。于生不障立能作因。无为无生道何所作。若尔谁果。果义如何。谓是道果。道力得故。若尔道果应唯是得。道于得有能非于择灭故。不尔于得于择灭中道之功能有差别故。云何于得道有功能。谓能生故。云何于灭道有功能。谓能证故。由此理故。道虽非灭因而可得说择灭为道果。既诸无为无增上果。如何可说为能作因。以诸无为于他生位不为障故立能作因。然无果者。由离世法无能取果与果用故。经部师说。无为非因。无经说因是无为故。有经说因唯有为故。何处经说。如有经说。诸因诸缘能生色者皆是无常。无常因缘所生诸色如何是常。广说乃至识亦如是。若尔无为亦应不与能缘识等作所缘缘。唯说能生故得作所缘缘。谓经唯说诸因诸缘能生识者皆是无常。不说一切为识缘者皆是无常故不成难。岂不亦说唯能生因是无常故不拨。无为唯不障故为能作因。有契经中说无为法为所缘缘。无契经中说无为法为能作因故。不应立为唯不障因性。虽无经说亦无处遮。又无量经今已隐没。云何定判无经说耶。若尔何法名为离系。即本论中所说择灭。岂不先问何谓择灭。答是离系。今问何法名为离系。答是择灭。如是二答。更互相依。于此自性竟不能显故应别门开显自性。此法自性实有离言。唯诸圣者各别内证。但可方便总相说言。是善是常别有实物名为择灭亦名离系。经部师说。一切无为皆非实有如色受等别有实物。此所无故。若尔何故名虚空等。唯无所触说名虚空。谓于暗中无所触对。便作是说。此是虚空。已起随眠生种灭位由简择力余不更生说名择灭。离简择力由阙缘故余不更生名非择灭。如残众同分中夭者余蕴。余部师说。由慧功能随眠不生名为择灭。随眠缘阙后苦不生不由慧能名非择灭。离简择力此灭不成故此不生即择灭摄。有说。诸法生已后无。自然灭故名非择灭。如是所执非择灭体应是无常。未灭无故。岂不择灭择为先故。先无后有应亦无常。非择为先方有择灭。如何择灭亦是无常。所以者何。非先有择后未生法方有不生。何者。不生本来自有。若无简择诸法应生。简择生时法永不起。于此不起择有功能。谓于先时未有生障。今为生障非造不生。若唯不生是涅槃者。此经文句当云何通。经言。五根若修若习若多修习。能令过去未来现在众苦永断。此永断体即是涅槃。唯于未来有不生义非于过现。岂不相违。虽有此文而不违义。此经意说。缘过现苦烦恼断故名众苦断。如世尊言。汝等于色应断贪欲。贪欲断时便名色断及色遍智。广说乃至识亦如是。过现苦断义亦应然。设有余经言断过去未来现在诸烦恼者。准前理释。义亦无违。或此经中别有意趣。过去烦恼谓过去生所起烦恼。现在烦恼谓现在生所起烦恼。如爱行中十八爱行。过去世起者依过去生说。未来现在应知亦尔。如是二世所起烦恼。为生未来诸烦恼故。于现相续引起种子。此种断故彼亦名断。如异熟尽时亦说名业尽。未来众苦及诸烦恼。由无种故毕竟不生。说名为断。若异此者。过去现在何缘须断。非于已灭及正灭时。须设劬劳为令其灭。若无为法其体都无。何故经说所有诸法。若诸有为若诸无为。于中离染最为第一。如何无法可于无中立为第一。我亦不说诸无为法其体都无。但应如我所说而有。如说此声有先非有。有后非有。不可非有说为有故有义得成。说有无为。应知亦尔。有虽非有而可称叹。故诸灾横毕竟非有名为离染。此于一切有非有中最为殊胜。为令所化深生欣乐故应称叹此为第一。若无为法唯非有者。无故不应名灭圣谛。且言圣谛其义云何。岂不此言属无倒义。圣见有无皆无颠倒。谓圣于苦见唯是苦。于苦非有见唯非有。此于圣谛义有何违。如何非有而可立为第三圣谛。第二无间圣见及说故成第三。若无为法其体唯无。空涅槃识应缘无境。此缘无境亦无有过。辩去来中当应思择。若许无为别有实体。当有何失。复有何德。许便拥护毗婆沙宗是名为德。若有可护天神定知自当拥护。然许实有明虚妄计是名为失。所以者何。此非有体可得如色受等。亦非有用可得如眼耳等。又若别有。如何可立彼事之灭第六转声。由灭与事非互相属。此彼相望非因果故。唯遮彼事。第六可成。彼事之无名为灭故。灭虽别有而由彼事或得断时方得此灭可言此灭属于彼事。何因此灭定属此得。如契经言。苾刍获得现法涅槃。如何非有可言获得。由得对治便获永违烦恼。后有所依身故名得涅槃。复有圣教能显涅槃唯以非有为其自性。谓契经言。所有众苦皆无余断。各别舍弃尽离染灭静息永没。余苦不续不取不生。此极寂静。此极美妙。谓舍诸依及一切爱尽离染灭名为涅槃。云何不许言不生者依此无生故言不生。我等见此第七转声于证灭有都无功力。何意故说依此无生。若依此言属已有义。应本不生。涅槃常故。若依此言属已得义。是则应许依道之得。故唯依道或依道得令苦不生。汝应信受。由此善释经说喻言。如灯焰涅槃心解脱亦尔。此经意说。如灯涅槃唯灯焰谢无别有物。如是世尊心得解脱。唯诸蕴灭更无所有。阿毗达磨亦作是言。无事法云何。谓诸无为法。言无事者。谓无体性毗婆沙师不许此释。若尔彼释事义云何。彼言事者略有五种。一自性事。如有处言。若已得此事彼成就此事。二所缘事。如有处言。一切法智所知随其事。三系缚事。如有处言。若于此事爱结所系。彼于此事恚结系耶。四所因事。如有处言。有事法云何。谓诸有为法。五所摄事。如有处言。田事宅事妻子等事。今于此中说因名事。显无为法都无有因。是故无为虽实有物。常无用故无因无果。总论已竟。于诸果中应说何果何因所得颂曰

  后因果异熟　　前因增上果
  同类遍等流　　俱相应士用

论曰。言后因者。谓异熟因。于六因中最后说故。初异熟果此因所得。言前因者。谓能作因。于六因中最初说故。后增上果此因所得。增上之果名增上果。唯无障住有何增上。即由无障得增上名。或能作因亦有胜力。如十处界于五识身。诸有情业于器世界。耳等对于眼识生等。亦有展转增上生力。闻已便生欣见欲故。此等增上如应当思。同类遍行得等流果。此二因果皆似因故。俱有相应得士用果。非越士体有别士用。即此所得名士用果。此士用名为目何法。即目诸法所有作用。如士用故得士用名。如世间说鸦足药草醉象将军。为唯此二有士用果为余亦然。有说。余因亦有此果。唯除异熟。由士用果与因俱生或无间生。异熟不尔。有余师说。此异熟因亦有隔越远士用果。譬如农夫所收果实。异熟等果其相云何。颂曰

  异熟无记法　　有情有记生
  等流似自因　　离系由慧尽
  若因彼力生　　是果名士用
  除前有为法　　有为增上果

论曰。唯于无覆无记法中有异熟果。为此亦通非有情数。唯局有情。为通等流及所长养。应知唯是有记所生。一切不善及善有漏能记异熟故名有记。从彼后时异熟方起。非俱无间名有记生。如是名为异熟果相。非有情数亦从业生。何非异熟。以共有故。谓余亦能如是受用。夫异熟果必无有余共受用义。非余造业余可因斯受异熟果。其增上果亦业所生。何得共受。共业生故。似自因法名等流果。谓似同类遍行二因。若遍行因亦得等流果。何不许此即名同类因。此果但由地等染故与因相似不由种类。若由种类果亦似因。此果所因乃名同类。故作是问。若是同类因亦遍行因耶。应作四句。第一句者。非遍行法为同类因。第二句者。他部遍法为遍行因。第三句者。自部遍法为遍行因。第四句者。除前诸相由慧尽法名离系果。灭故名尽。择故名慧。即说择灭名离系果。若法因彼势力所生。即说此法名士用果。如因下地加行心力上地有漏无漏定生。及因清净静虑心力变化心生。如是等类择灭应言由道力得。诸有为法。除前已生。是余有为之增上果。士用增上二果何殊。士用果名唯对作者。增上果称通对此余。如匠所成。对能成匠。具得士用增上果名。对余非匠唯增上果。于上所说六种因中。何位何因取果与果。颂曰

  五取果唯现　　二与果亦然
  过现与二因　　一与唯过去

论曰。五因取果唯于现在。定非过去。彼已取故。亦非未来。彼无用故。亦应如是说。能作因非定有果故此不说。俱有相应与果亦尔。唯于现在。由此二因取果与果必俱时故。同类遍行二因与果通于过现。过去可然。如何现在与等流果。有等流果无间生故。若果已生。因便过去。名已与果。不应更与。善同类因有时取果而非与果。应作四句。第一句者。谓断善根时最后所舍得。第二句者。谓续善根时最初所得得。应说尔时续者前得。第三句者。谓不断善根于所余诸位。第四句者。谓除前相。又于不善同类因中亦有四句。第一句者。谓离欲贪时最后所舍得。第二句者。谓退欲贪时最初所得得。应说尔时退者前得。第三句者。谓未离欲贪于所余诸位。第四句者。谓除前相。有覆无记同类因中。亦有四句。于阿罗汉得时退时未得及余。如理应说。无覆无记同类因中有顺后句。谓与果时必亦取果。或时取果而非与果。谓阿罗汉最后诸蕴。约有所缘刹那差别。善同类因亦有四句。第一句者。谓善心无间起染无记心。第二句者。谓与上相违。第三句者。谓善心无间还起善心。第四句者。谓除前相。不善心等如其所应。亦有四句。准例应说。取果与果其义云何。能为彼种故名取果。正与彼力故名与果。异熟与果唯于过去。由异熟果无与因俱及无间故。复有余师。前五果外别说四果。一安立果。谓如水轮为风轮果。乃至草等为大地果。二加行果。谓如无生智等远为不净等果。三和合果。谓如眼识等为眼根等果。四修习果。谓如化心等为诸静虑果。如是四果皆是士用增上果摄。说因果已。复应思择。此中何法几因所生。法略有四。谓染污法。异熟生法。初无漏法。三所余法。余法者何。谓除异熟余无记法。除初无漏诸余善法。如是四法。颂曰

  染污异熟生　　余初圣如次
  除异熟遍二　　及同类余生
  此谓心心所　　余及除相应

论曰。诸染污法除异熟因余五因生。异熟生法除遍行因余五因生。三所余法双除异熟遍行二因余四因生。初无漏法。双除前二及同类因余三因生。如是四法为说何等。谓心心所不相应行及色四法。复几因生。如心心所所除因外及除相应。应知余法从四三二余因所生。此中染污异熟生法余四因生。三所余法余三因生。初无漏法余二因生。一因生法决定无有

说一切有部俱舍论卷第六阿毗达磨俱舍论卷第七

        尊者世亲造

        三藏法师玄奘奉　诏译

    分别根品第二之五

广说因已。缘复云何。颂曰

  说有四种缘　　因缘五因性
  等无间非后　　心心所已生
  所缘一切法　　增上即能作

论曰。于何处说。谓契经中。如契经中说四缘性。谓因缘性。等无间缘性。所缘缘性。增上缘性。此中性者是缘种类。于六因内除能作因。所余五因是因缘性。除阿罗汉临涅槃时最后心心所法诸余已生心心所法。是等无间缘性。此缘生法等而无间。依是义立等无间名。由此色等皆不可立等无间缘。不等生故。谓欲界色。或无间生欲界色界二无表色。或无间生欲界无漏二无表色。以诸色法杂乱现前等无间缘生无杂乱。故色不立等无间缘。尊者世友作如是言。于一身中一长养色相续不断。复有第二长养色生不相违害故不可立等无间缘。大德复言。以诸色法无间生起或少或多。谓或有时从多生少。如烧稻秆大聚为灰。或时复有从少生多。如细种生诺瞿陀树。根茎枝叶渐次增荣。耸干垂条多所荫映。岂不心所无间生时亦有少多品类非等。谓善不善无记心中。有寻有伺三摩地等。此于异类实有少多。然自类中无非等义。谓无少受无间生多。或复从多无间生少。想等亦尔。无非等过。岂唯自类前能为后等无间缘。不尔。云何。前心品法总为后品等无间缘。非唯自类。且于受等自体类中无少生多以说等义。唯执同类相续者。说唯自类有等无间缘。心唯生心受唯生受。乃至广说若从无染无间染生。此染心中所有烦恼用先灭烦恼为等无间缘。如出灭定心还用先灭正入灭定心为缘故起。彼说非善。初无漏心应阙此缘而得生故。不相应行亦如诸色。杂乱现前故非等无间缘。三界及不系可俱现前故。何缘不许未来世有等无间缘。以未来法杂乱而住无前后故。如何世尊知未来世此法无间此法应生。比过现法而现知故。传说。世尊见从过去如此类业此类果生。是法无间生如是法。又从现在如此类业此类果生。是法无间生如是法。如是见已。便于未来诸乱住法。能正了达此法无间此法应生。虽如是知而非比智。由佛比类过去现在因果次第。便于未来乱住诸法能现了达。谓未来世如是有情造如是业招如是果。是愿智摄故非比智。若尔世尊未见前际。于后际法应不能知。有余复言。有情身内有未来世果因先兆。是不相应行蕴差别。佛唯观此便知未来。非要现游静虑通慧。若尔诸佛便于未来占相故知。非为现证。故如经部诸师所言。世尊举意遍知诸法非比非占。此说为善。如世尊说。诸佛德用诸佛境界不可思议。若于未来无定前后次第安立。何故但言世第一法无间唯生苦法智忍不生余法。如是广说。乃至金刚喻定无间。唯生尽智不生余法。若此法生系属彼法要彼无间此乃得生。如芽等生要藉种等。然此非有等无间缘。诸阿罗汉最后心心所。何缘故说非等无间缘。无余心等续此起故。岂不如是无间灭心亦名为意。后心无间识既不生应不名意。意是依所显非作用所显。此最后心有所依义。余缘阙故后识不生。等无间缘作用所显。若法此缘取为果已。定无诸法及诸有情能为障碍令彼不起。故最后心虽得名意而不可说等无间缘。若法与心为等无间。彼法亦是心无间耶。应作四句。第一句者。谓无心定出心心所。及第二等二定刹那。第二句者。谓初所起二定刹那。及有心位诸心心所生住异灭。第三句者。谓初所起二定刹那。及有心位心心所法。第四句者。谓第二等二定刹那。及无心定出心心所生住异灭。若法与心为等无间。与无心定为无间耶。应作四句。谓前第三第四句为今第一第二句。即前第一第二句为今第三第四句。从二定出诸心心所望入定心中间远隔。如何为彼等无间耶。中间不隔心心所故。如是已释等无间缘。所缘缘性。即一切法望心心所随其所应。谓如眼识及相应法以一切色为所缘缘。如是耳识及相应法以一切声。鼻识相应以一切香。舌识相应以一切味。身识相应以一切触。意识相应以一切法为所缘缘。若法与彼法为所缘。无时此与彼非所缘。于不缘位亦所缘摄。被缘不缘其相一故。譬如薪等于不烧时亦名所烧。相无异故。心心所法。如于所缘处事刹那三皆决定。于所依亦有如是决定耶。应言亦有如是决定。然于现在亲附自所依。过去未来与所依相离。有说。在过去亦亲附所依。如是已释所缘缘性。增上缘性即能作因。以即能作因为增上缘故。此缘体广名增上缘。一切皆是增上缘故。既一切法亦所缘缘。此增上缘何独体广。俱有诸法未尝为所缘。然为增上故。唯此体广。或所作广名增上缘。以一切法各除自性与一切有为为增上缘故。颇有法于法全非四缘不。有谓自性于自性。于他性亦有。谓有为于无为。无为于无为。如是诸缘于何位法而兴作用。颂曰

  二因于正灭　　三因于正生
  余二缘相违　　而兴于作用

论曰。前说五因为因缘性。二因作用于正灭时。正灭时言显法现在灭现前故名正灭时。俱有相应于法灭位方兴作用。由此二因令俱生果有作用故。所言三因于正生者。谓未来法于正生位。生现前故名正生时。同类遍行异熟三种。于法生位作用方兴。已说因缘二时作用。二缘作用与此相违。等无间缘于法生位而兴作用。以彼生时前心心所与其处故。若所缘缘能缘灭位而兴作用。以心心所要现在时方取境故。唯增上缘于一切位皆无障住故。彼作用随无障位一切无遮。已说诸缘及兴作用。应言何法由几缘生。颂曰

  心心所由四　　二定但由三
  余由二缘生　　非天次等故

论曰。心心所法由四缘生。此中因缘谓五因性。等无间缘谓前无间已生。非后心心所法。所缘缘者谓随所应或色等五。或一切法。增上缘者谓随所应各除自性余一切法。灭尽无想二定由三除所缘缘。非能缘故。由因缘者。谓由二因。一俱有因。谓生等相。二同类因。谓前已生同地善法。等无间缘谓入定心及相应法。增上缘者。谓如前说。如是二定心等引生碍心等起故。与心等但为等无间。非等无间缘。余不相应及诸色法由因增上二缘所生。一切世间唯从如上所说诸因诸缘所起。非自在天我胜性等一因所起。此有何因。若一切成许由因者。岂不便舍一切世间由自在等一因生论。又诸世间非自在等一因所起。次第等故。谓诸世间若自在等一因生者。则应一切俱时而生非次第起。现见诸法次第而生。故知定非一因所起。若执自在随欲故然。谓彼欲令此法今起此法今灭此于后时。是则应成非一因起。亦由乐欲差别生故。或差别欲应一时生。所因自在无差别故。若欲差别更待余因不俱起者。则非一切唯用自在一法为因。或所待因亦应更待余因差别方次第生。则所待因应无边际。若更不待余差别因。此因应无次第生义。则差别欲非次第生。若许诸因展转差别无有边际信无始故。徒执自在为诸法因不越释门因缘正理。若言自在欲虽顿生而诸世间不俱起者。由随自在欲所生故。理亦不然。彼自在欲前位与后无差别故。又彼自在作大功力。生诸世间得何义利。若为发喜生诸世间。此喜离余方便不发。是则自在于发喜中既必待余。应非自在。于喜既尔。余亦应然。差别因缘不可得故。或若自在生地狱等无量苦具逼害有情。为见如斯发生自喜。咄哉何用此自在为。依彼颂言。诚为善说

  由险利能烧　　可畏恒逼害
  乐食血肉髓　　故名鲁达罗

又若信受一切世间唯自在天一因所起。则为诽拨现见世间所余因缘人功等事。若言自在待余因缘助发功能方成因者。但是朋敬自在天言。离所余因缘不见别用故。或彼自在要余因缘助方能生。应非自在。若执初起自在为因余后续生待余因者。则初所起不待余因。应无始成犹如自在。我胜性等随其所应如自在天应广征遣。故无有法唯一因生。奇哉世间不修胜慧。如愚禽兽。良足可悲。彼彼生中别别造业。自受异熟及士用果。而妄计有自在等因。且止破邪应辩正义。前言余法由二缘生。于中云何大种所造。自他相望互为因缘。颂曰

  大为大二因　　为所造五种
  造为造三种　　为大唯一因

论曰。初言大为大二因者。是诸大种更互相望。但为俱有同类因义。大于所造能为五因。何等为五。谓生依立持养别故。如是五因。但是能作因之差别。从彼起故说为生因。生已随逐大种转故。如依师等说为依因。能任持故。如壁持画说为立因。不断因故说为持因。增长因故说为养因。如是则显大与所造为起变持住长因性。诸所造色自互相望容有三因。所谓俱有同类异熟。其能作因无差别转故不恒数。俱有因者。谓随心转身语二业。非余造色。同类因者。一切前生于后同类。异熟因者。谓身语业能招异熟眼根等果。所造于大但为一因。谓异熟因。身语二业能招异熟大种果故。前已总说诸心心所前能为后等无间缘。未决定说何心无间有几心生复从几心有何心起。今当定说。谓且略说有十二心。云何十二。颂曰

  欲界有四心　　善恶覆无覆
  色无色除恶　　无漏有二心

论曰。且于欲界有四种心。谓善不善有覆无记无覆无记。色无色界各有三心。谓除不善。余如上说。如是十种说有漏心。若无漏心唯有二种。谓学无学。合成十二。此十二心互相生者。颂曰

  欲界善生九　　此复从八生
  染从十生四　　余从五生七
  色善生十一　　此复从九生
  有覆从八生　　此复生于六
  无覆从三生　　此复能生六
  无色善生九　　此复从六生
  有覆生从七　　无覆如色辨
  学从四生五　　余从五生四

论曰。欲界善心无间生九。谓自界四色界二心。于入定时及续生位。如其次第生善染心。无色界一于续生位。欲善无间生彼染心。不生彼善以极远故。无色于欲四远故远。一所依远。二行相远。三所缘远。四对治远。及学无学。谓入观时。即此复从八无间起。谓自界四色界二心。于出定时从彼善起。彼染污定所逼恼时。从彼染心生于下善。为依下善防彼退故。及学无学。谓出观时。染谓不善有覆无记二各从十无间而生。谓十二中除学无学。于续生位。三界诸心皆可无间生欲界染心故。即此无间能生四心。谓自界四。余无生理。余谓欲缠无覆无记。此心从五无间而生。谓自界四及色界善。欲界化心从彼生故。即此无间能生七心。谓自界四及色界二善与染污。欲界化心还生彼善。于续生位生彼染心。并无色一于续生位此无覆心能生彼染。色界善心无间生十一。谓除无色无覆无记心。即此复从九无间起。谓除欲界二染污心。及除无色无覆无记。有覆从八无间而生。除欲二染及学无学。即此无间能生六心。谓自界三欲善不善有覆无记。无覆从三无间而起。谓唯自界。余无生理。即此无间能生六心。谓自界三欲无色染。无色界善无间生九心。谓除欲善及欲色无覆。即此从六无间而生。谓自界三及色界善并学无学。有覆无间能生七心。谓自界三及色界善欲色界染。即此亦从七无间起。谓除欲色染及学无学心。无覆如色说从三无间生。谓自界三。余皆非理。即此无间能生六心。谓自界三及欲色染。学心从四无间而生。谓即学心及三界善。即此无间能生五心。谓前四心及无学一。余谓无学从五无间生。谓三界善及学无学二。即此无间能生四心。谓三界善及无学一。说十二心互相生已。云何分此为二十心。颂曰

  十二为二十　　谓三界善心
  分加行生得　　欲无覆分四
  异熟威仪路　　工巧处通果
  色界除工巧　　余数如前说

论曰。三界善心各分二种。谓加行得生得别故。欲界无覆分为四心。一异熟生。二威仪路。三工巧处。四通果心。色无覆心分为三种。除工巧处。上界都无造作种种工巧事故。如是十二为二十心。谓善分六。无覆分八。无色界无威仪路等余数如上故成二十。威仪路等三无覆心色香味触为所缘境。工巧处等亦缘于声。如是三心唯是意识。威仪路工巧处加行亦通四识五识。有余师说有威仪路及工巧处所引意识能具足缘十二处境。如是二十互相生者。且说欲界八种心中。加行善心无间生十。谓自界七除通果心。及色界一加行善心并学无学。即此复从八无间起。谓自界四二善二染。及色界二加行善心有覆无记。并学无学。生得善心无间生九。谓自界七除通果心。及色无色有覆无记。即此复从十一心起。谓自界七除通果心。及色界二加行善心有覆无记。并学无学。二染污心无间生七。谓自界七除通果心。即此复从十四心起。谓自界七除通果心。及色界四除加行善与通果心。并无色三。除加行善。异熟威仪无间生八。谓自界六除加行善与通果心。及色无色有覆无记。即此复从七无间起。谓自界七除通果心。工巧处心无间生六。谓自界六除加行善与通果心。即此复从七无间起。谓自界七除通果心。从通果心无间生二。谓自界一即通果心。及色界一即加行善。即此亦从二无间起。谓即前说自色二心。次说色界六种心中。从加行善心无间生十二。谓自界六及欲界三加行生得与通果心。并无色一加行善心学无学心。即此复从十无间起。谓自界四。除威仪路与异熟生。及欲界二加行通果。并无色二加行有覆学无学心。生得善心无间生八。谓自界五除通果心及欲界二不善有覆。并无色一有覆无记。即此复从五无间起。谓自界五除通果心。有覆无记无间生九。谓自界五除通果心。及欲界四二善二染。即此复从十一心起。谓自界五除通果心。及欲界三生得善心威仪异熟。并无色三除加行善。异熟威仪无间生七。谓自界四除加行善与通果心。及欲界二不善有覆。并无色一有覆无记。即此复从五无间起。谓自界五除通果心。从通果心无间生二。谓自界二加行通果。即此亦从二无间起。谓即前说自界二心。次说无色四种心中。加行善心无间生七。谓自界四及色界一加行善心。并学无学。即此复从六无间起。谓自界三唯除异熟。及色界一加行善心。并学无学。生得善心无间生七。谓自界四及色界一有覆无记。并欲界二不善有覆。即此复从四无间起。谓自界四。有覆无记无间生八。谓自界四及色界二加行有覆。并欲界二不善有覆。即此复从十无间起。谓自界四及色界三生得异熟与威仪路。并欲界三名如色说。异熟生心无间生六。谓自界三除加行善。及色界一有覆无记。并欲界二不善有覆。即此复从四无间起。谓自界四。次说无漏二种心中。从有学心无间生六。谓通三界加行善心及欲生得。并学无学。即此复从四无间起。谓三加行及有学心。从无学心无间生五。谓前有学所生六中除有学一。即此复从五无间起。谓三加行及学无学。复有何缘。加行无间能生异熟工巧威仪。非彼无间生加行善。势力劣故。非作功用所引发故。乐作功用引发工巧威仪转故。不能顺起加行善心。出心不由功用转故。加行无间可能生彼。若尔染污无间。不应生加行善。不相顺故。虽尔厌倦烦恼现行为欲了知容起加行。欲界生得以明利故。可有从彼学无学心色界加行无间而起。非作功用所引发故。不能从此引生彼心。又欲生得以明利故。可从色染无间而生。色界生得不明利故。非无色染无间而起。作意有三。一自相作意。谓如观色变碍为相。乃至观识了别为相。如是等观相应作意。二共相作意。谓十六行相应作意。三胜解作意。谓不净观及四无量有色解脱胜处遍处。如是等观相应作意。如是三种作意无间圣道现前。圣道无间亦能具起三种作意。若作是说便顺此言。不净观俱行修念等觉分。有余师说。唯从共相作意无间圣道现前。圣道无间通起三种。修不净观调伏心已。方能引生共相作意。从此无间圣道现前。依此传传密意故。说不净观俱行修念等觉分。有余复言。唯从共相作意无间圣道现前。圣道无间亦唯能起共相作意。若尔有依未至定等三地证入正性离生。圣道无间可生欲界共相作意。若依第二第三第四静虑证入正性离生。圣道无间起何作意。非起欲界共相作意。以极远故。非于彼地已有曾得共相作意。异于曾得顺决择分。非诸圣者顺决择分可复现前。非得果已可重发生加行道故。若谓有别共相作意。顺决择分俱时已修。由系属彼是彼类故。如观诸行皆是无常。观一切法皆是非我涅槃寂静。圣道无间引彼现前。毗婆沙师不许此义。违正理故。若依未至定得阿罗汉果后出观心或即彼地或是欲界。依无所有处得阿罗汉果后出观心或即彼地或是有顶。若依余地得阿罗汉果后出观心唯自非余地。于欲界中有三作意。一闻所成。二思所成。三生所得。色界亦有三种作意。一闻所成。二修所成。三生所得。无思所成。举心思时即入定故。无色唯有二种作意。一修所成。二生所得。此中五种作意无间圣道现前。除生所得圣道。系属加行心故。圣道无间亦得发生。欲界生得以明利故。于前所说十二心中何心现前几心可得。颂曰

  三界染心中　　得六六二种
  色善三学四　　余皆自可得

论曰。欲界染心正现前位。十二心内容得六心。彼先不成今得成故。由疑续善及界退还。欲界善心尔时名得。由起惑退及界退还得欲二心。不善有覆及得色界一有覆心。由起惑退得无色界一有覆心。及得学心。故名得六。色界染心正现前位。十二心内亦得六心。由界退还得欲界一无覆无记及色界三。色界染心亦由退得。由起惑退得无色界一有覆心。及得学心。故名得六。无色染心正现前位。十二心内唯得二心。由起惑退得彼染心。及得学心。故名得二。色界善心正现前位。十二心内容得三心。谓彼善心及欲色界无覆无记。由升进故。若有学心正现前位。十二心内容得四心。谓有学心及欲色界无覆无记并无色善。由初证入正性离生。及由圣道离欲色染。余谓前说染等心余。不说彼心正现前位得心差别。应知彼心正现前位。唯自可得。有余于此总说。颂曰

  慧者说染心　　现起时得九
  善心中得六　　无记唯无记

于善心中应言得七。谓由正见续善根时。欲界善心起位名得。离欲界染究竟位中。顿得欲色无覆无记。得色无色三摩地时。彼二善心说名为得。初入离生位证阿罗汉时。学无学心说名为得。余准前释应知其相。为摄前义。复说颂言

  由托生入定　　及离染退时
  续善位得心　　非先所成故

说一切有部俱舍论卷第七阿毗达磨俱舍论卷第八

        尊者世亲造

        三藏法师玄奘奉　诏译

    分别世品第三之一

已依三界分别心等。今次应说。三界是何。各于其中处别有几。颂曰

  地狱傍生鬼　　人及六欲天
  名欲界二十　　由地狱洲异
  此上十七处　　名色界于中
  三静虑各三　　第四静虑八
  无色界无处　　由生有四种
  依同分及命　　令心等相续

论曰。地狱等四及六欲天并器世间。是名欲界。六欲天者。一四大王众天。二三十三天。三夜摩天。四睹史多天。五乐变化天。六他化自在天。如是欲界处别有几。地狱洲异故成二十八大地狱名地狱异。一等活地狱。二黑绳地狱。三众合地狱。四号叫地狱。五大叫地狱。六炎热地狱。七大热地狱。八无间地狱。言洲异者。谓四大洲。一南赡部洲。二东胜身洲。三西牛货洲。四北俱卢洲。如是十二并六欲天傍生饿鬼处成二十。若有情界从自在天至无间狱。若器世界乃至风轮皆欲界摄。此欲界上处有十七。谓三静虑处各有三。第四静虑处独有八。器及有情总名色界。第一静虑处有三者。一梵众天。二梵辅天。三大梵天。第二静虑处有三者。一少光天。二无量光天。三极光净天。第三静虑处有三者。一少净天。二无量净天。三遍净天。第四静虑处有八者。一无云天。二福生天。三广果天。四无烦天。五无热天。六善现天。七善见天。八色究竟天。迦湿弥罗国诸大论师皆言。色界处但有十六。彼谓。即于梵辅天处有高台阁。名大梵天。一主所居非有别地。如尊处座四众围绕。无色界中都无有处。以无色法无有方所。过去未来无表无色不住方所。理决然故。但异熟生差别有四。一空无边处。二识无边处。三无所有处。四非想非非想处。如是四种名无色界。此四非由处有上下。但由生故胜劣有殊。复如何知彼无方处。谓于是处得彼定者。命终即于是处生故。复从彼没生欲色时。即于是处中有起故。如有色界一切有情要依色身心等相续。于无色界受生有情。以何为依心等相续。对法诸师说。彼心等依众同分及与命根而得相续。若尔有色有情心等何不但依此二相续。有色界生此二劣故。无色此二因何故强。彼界二从胜定生故。由彼等至能伏色想。若尔于彼心等相续。但依胜定何用别依。又今应说。如有色界受生有情同分命根依色而转。无色此二以何为依。此二更互相依而转。有色此二何不相依。有色界生此二劣故。无色此二因何故强。彼界此二种从胜定生故。前说彼定能伏色想。是则还同心相续难。或心心所唯互相依故。经部师说。无色界心等相续无别有依。谓若有因未离色爱引起心等。所引心等与色俱生。依色而转。若因于色已得离爱。厌背色故。所引心等非色俱生不依色转。何故名为欲等三界。能持自相故名为界。或种族义如前已释。欲所属界说名欲界。色所属界说名色界。略去中言故作是说。如胡椒饮如金刚环。于彼界中色非有故名为无色。所言色者。是变碍义。或示现义。彼体非色立无色名。非彼但用色无为体。无色所属界说名无色界。略去中言喻如前说。又欲之界名为欲界。此界力能任持欲故。色无色界应知亦然。此中欲言为说何法略说段食淫所引贪。如经颂言

  世诸妙境非真欲　　真欲谓人分别贪
  妙境如本住世间　　智者于中已除欲

邪命外道便诘尊者舍利子言

  若世妙境非真欲　　说欲是人分别贪
  比丘应名受欲人　　起恶分别寻思故

时舍利子反质彼言

  若世妙境是真欲　　说欲非人分别贪
  汝师应名受欲人　　恒观可意妙色故

若法于彼三界现行。此法即说三界系不。不尔。云何于中随增三界贪者是三界系。此中何法名三界贪。谓三界中各随增者。今此所言同缚马答。犹如有问缚马者谁。答言马主。即彼复问马主是谁。答言缚者。如是二答皆不令解。今此所言不同彼答。谓于前说欲界诸处未离贪者贪名欲贪。此所随增名欲界系。于前所说色无色中随其所应当知亦尔。或不定地贪名欲贪。此所随增名欲界系。诸静虑地贪名色贪。此所随增名色界系。诸无色地贪名无色贪。此所随增名为无色界系。于欲化心上如何起欲贪。从他所闻。或自退失生爱味故。或观化者自在势力于彼化心生贪爱故。若心能化香味二法。此能化心是欲界系。色界心不能化作香味故。如是三界唯有一耶。三界无边如虚空量。故虽无有始起有情。无量无边佛出于世。一一化度无数有情令证无余般涅槃界而不穷尽犹若虚空。世界当言云何安住。当言傍住故。契经言。譬如天雨滴如车轴。无间无断从空下澍。如是东方无间无断无量世界或坏或成。如于东方。南西北方亦复如是。不说上下。有说亦有上下二方。余部经中说十方故。色究竟上复有欲界。于欲界下有色究竟。若有离一欲界贪时。诸欲界贪皆得灭离。离色无色应知亦尔。依初静虑起通慧时。所发神通但能往至自所生界梵世非余。所余通慧应知亦尔。已说三界。五趣云何。颂曰

  于中地狱等　　自名说五趣
  唯无覆无记　　有情非中有

论曰。于三界中说有五趣。即地狱等如自名说。谓前所说地狱傍生鬼及人天是名五趣。唯于欲界有四趣全。三界各有天趣一分。为有三界非趣所摄。而于界中说有五趣。有谓善染外器中有虽是界性而非趣摄。五趣体唯无覆无记。若异此者趣应相杂。于一趣中具有五趣业烦恼故。五趣唯是有情数摄。体非中有。施设足论作如是说。四生摄五趣非五摄四生。不摄者何。所谓中有。法蕴足论亦作是言。眼界云何。谓四大种所造净色是眼。眼根眼处眼界地狱傍生鬼人天趣修成中有。契经亦简中有异趣。是何契经。谓七有经。彼说七有。谓地狱有傍生有饿鬼有天有人有业有中有。彼经中说五趣及因并趣方便。故趣唯是无覆无记其理极成。简业有因异诸趣故。迦湿弥罗国诵如是契经。尊者舍利子作是言。具寿。若有地狱诸漏现前故造作增长顺地狱受业。彼身语意曲秽浊故于奈落迦中受五蕴异熟。异熟起已名那落迦。除五蕴法彼那落迦都不可得。故趣唯是无覆无记若如是者。品类足论当云何通。彼说五趣一切随眠所随增故。彼说五趣续生心中容有五部一切烦恼趣及入心。总说为趣。无相违失。譬如村落及村落边总名村落。有说。趣体亦通善染。然七有经简业有者。非别说故定非彼摄。如五浊中烦恼与见别说为浊。非别说故。彼见定非烦恼所摄。如是业有虽亦是趣。为显趣因。是故别说。若尔中有亦应是趣。不尔。趣义不相应故。趣谓所往不可说言中有是所往。即死处生故。若尔无色亦应非趣。即于死处而受生故。既尔中有名中有故不应名趣。二趣中故名为中有。此若趣摄非中间故。是则不应说名中有。然彼尊者舍利子言异熟起已名地狱者。说异熟起方名地狱。非说地狱唯是异熟。然复说言除五蕴法彼那落迦不可得者。为遮实有能往诸趣补特伽罗故作是说。非遮余蕴故作是言。毗婆沙师说。趣唯是无覆无记。有说。一向是异熟生。有余师言。亦通长养。即于三界及五趣中。如其次第识住有七。其七者何颂曰

  身异及想异　　身异同一想
  翻此身想一　　并无色下三
  故识住有七　　余非有损坏

论曰。契经中说。有色有情身异想异如人一分天。是第一识住。一分天者。谓欲界天及初静虑除劫初起。言身异者。谓彼色身种种显形状貌异故。彼由身异。或有异身故彼有情说名身异。言想异者。谓彼苦乐不苦不乐想差别故。彼由想异。或有异想故彼有情说名想异。有色有情身异想一如梵众天谓劫初起。是第二识住。所以者何。以劫初起。彼诸梵众起如是想。我等皆是大梵所生。大梵尔时亦起此想。是诸梵众皆我所生。同想一因故名想一。大梵王身其量高广。容貌威德言语光明衣冠等事。一一皆与梵众不同故名身异。经说。梵众作是念言。我等曾见如是有情长寿久住。乃至起愿。云何当令诸余有情生我同分。于彼正起此心愿时。我等便生彼同分内。梵众何处曾见梵王。有余师言。住极光净。从彼天没来生此故。云何今时不得第二静虑。而能忆念彼地宿住事耶。若彼已得第二静虑。云何缘大梵犹起戒禁取。有余师说。住中有中。彼住中有中无长时住义。以于受生无障碍故。如何梵众可作念言。我等曾见如是有情长寿久住。是故梵众即住自天忆念此生前所更事。谓先见彼长寿久住。后重见时起如是念。有色有情身一想异如极光净天。是第三识住。此中举后兼以摄初。应知具摄第二静虑。若不尔者。彼少光天无量光天何识住摄。彼天显形状貌不异故名身一。乐非苦乐二想交参故名想异。传说。彼天厌根本地喜根已起近分地舍根现前。厌近分地舍根已起根本地喜根现前。如富贵人厌欲乐已便受法乐。厌法乐已复受欲乐。岂不遍净想亦应然。非遍净天曾有厌乐。以乐寂静曾无厌时。喜则不然扰动心故。经部师说。有余契经释彼天中有想异义。谓极光净有天新生。未善了知世间成坏。彼见下地火焰洞然。见已便生惊怖厌离。勿彼火焰烧尽梵宫令彼皆空上侵我处。彼极光净有旧生天。已善了知世间成坏。便慰喻彼惊怖天言。净仙净仙。勿怖勿怖。昔彼火焰烧尽梵宫。令其皆空即于彼灭。彼于火焰有来不来想及怖不怖想故名想异。非由有乐非苦乐想有交参故得想异名。有色有情身一想一如遍净天。是第四识住。唯有乐想故名想一。初静虑中由染污想故言想一。第二静虑由二善想故言想异。第三静虑由异熟想故言想一。下三无色名别。如经即三识住是名为七。此中何法名为识住。谓彼所系五蕴四蕴。如其所应是名识住。所余何故非识住耶。于余处皆有损坏识法故。余处者何。谓诸恶处第四静虑及与有顶。所以者何。由彼处有损坏识法故非识住。何等名为损坏识法。谓诸恶处有重苦受能损于识。第四静虑有无想定及无想事。有顶天中有灭尽定能坏于识令相续断故非识住。复说。若处余处有情心乐来止。若至于此不更求出。说名识住。于诸恶处二义俱无。第四静虑心恒求出。谓诸异生求入无想。若诸圣者乐入净居或无色处。若净居天乐证寂灭。有顶昧劣故非识住。如是分别七识住已。因兹复说九有情居。其九者何。颂曰

  应知兼有顶　　及无想有情
  是九有情居　　余非不乐住

论曰。前七识住及第一有无想有情。是名为九。诸有情类唯于此九欣乐住故。立有情居。余处皆非。不乐住故。言余处者。谓诸恶处。非有情类自乐居中。恶业罗刹逼之令住故。彼如牢狱不立有情居。第四静虑除无想天。余非有情居。如识住中释。前所引经说七识住。复有余经说四识住。其四者何。颂曰

  四识住当知　　四蕴唯自地
  说独识非住　　有漏四句摄

论曰。如契经言。识随色住。识随受住。识随想住。识随行住。是名四种。如是四种其体云何。谓随次第有漏四蕴。又此唯在自地非余。识所依著名识住故。非于异地色等蕴中识随爱力依着于彼。如何不说识为识住。由离能住立所住故。非能住识可名所住。如非即王可名王座。或若有法识所乘御如人船理说名识住。非识即能乘御自体。是故不说识为识住。毗婆沙师所说如是。若尔何故余契经言。于识食中有喜有染。有喜染故识住其中识所乘御。又如何言前七识住五蕴为体。虽有是说。而于生处所摄蕴中不别分析。总生喜染故。识转时亦名识住。非独说识。然色等蕴一一能生种种喜染令识依着。独识不然故言非住。是故于此四识住中识非识住。于余可说。又佛意说。此四识住犹如良田。总说一切有取诸识犹如种子。不可种子立为良田。仰测世尊教意如是。又法与识可俱时生为识良田。可立识住。识蕴不尔。故非识住。如是所说七种四种识住虽殊而皆有漏。为七摄四四摄七耶。非遍相摄。可为四句。谓审观察应知二门体互宽陜得成四句。或有七摄非四摄等。第一句者。谓七中识。第二句者。谓诸恶处第四静虑及有顶中除识余蕴。第三句者。七中四蕴。第四句者。谓除前相。于前所说诸界趣中。应知其生略有四种。何等为四。何处有何。颂曰

  于中有四生　　有情谓卵等
  人傍生具四　　地狱及诸天
  中有唯化生　　鬼通胎化二

论曰。谓有情类卵生胎生湿生化生。是名为四。生谓生类。诸有情中虽余类杂而生类等。云何卵生。谓有情类生从卵[穀-禾+卵]是名卵生。如鹅孔雀鹦鹉雁等。云何胎生。谓有情类生从胎藏是名胎生。如象马牛猪羊驴等。云何湿生。谓有情类生从湿气是名湿生。如虫飞蛾蚊蚰蜒等。云何化生。谓有情类生无所托是名化生。如那落迦天中有等。具根无缺支分顿生。无而欻有故名为化。人傍生趣各具四种。人卵生者。谓如世罗邬波世罗生从鹤卵。鹿母所生三十二子。般遮罗王五百子等。人胎生者。如今世人。人湿生者。如曼驮多遮卢邬波遮卢。鸽鬘庵罗卫等。人化生者。唯劫初人。傍生三种共所现见。化生如龙揭路荼等。一切地狱诸天中有皆唯化生。鬼趣唯通胎化二种。鬼胎生者。如饿鬼女白目连云

  我夜生五子　　随生皆自食
  昼生五亦然　　虽尽而无饱

一切生中何生最胜。应言最胜唯是化生。若尔何缘后身菩萨得生自在而受胎生。现受胎生有大利故。谓为引导诸大释种亲属相因令入正法。又引余类令知菩萨是轮王种生敬慕心。因得舍邪趣于正法。又令所化生增上心。彼既是人。能成大义。我曹亦尔。何为不能因发正勤专修正法。又若不尔族姓难知。恐疑幻化为天为鬼。如外道论矫设谤言。过百劫后当有大幻出现于世啖食世间。故受胎生息诸疑谤。有余师说。为留身界故受胎生。令无量人及诸异类一兴供养千返生天及证解脱。若受化生无外种故。身才殒逝无复遗形。如灭灯光即无所见。若人信佛有持愿通能久留身。此不成释因论生论。若化生身如灭灯光死无遗者。何故契经说化生揭路荼取化生龙为充所食。以不知故为食取龙。不说充饥。斯有何失。或龙未死暂得充饥。死已还饥。暂食何咎。于四生内何者最多。唯化生。何以故。三趣少分及二趣全一切中有皆化生故。此中何法说名中有。何缘中有非即名生。颂曰

  死生二有中　　五蕴名中有
  未至应至处　　故中有非生

论曰。于死有后在生有前。即彼中间有自体起。为至生处故起此身。二趣中间故名中有。此身已起何不名生。生谓当来所应至处。依所至义建立生名。此中有身其体虽起而未至彼。故不名生。何谓当来所应至处。所引异熟究竟分明。是谓当来所应至处。有余部说。从死至生处容间绝。故无中有。此不应许。所以者何。依理教故。理教者何。颂曰

  如谷等相续　　处无间续生
  像实有不成　　不等故非譬
  一处无二并　　非相续二生
  说有健达缚　　及五七经故

论曰。且依正理中有非无。现见世间相续转法。要处无间刹那续生。且如世间谷等相续。有情相续理亦应然。刹那续生处必无间。岂不现见有法续生而于其中处亦有间。如依镜等从质像生。如是有情死有生有。处虽有间何妨续生。实有诸像理不成故。又非等故为喻不成。谓别色生说名为像。其体实有理所不成。设成非等。故不成喻。言像不成故非喻者。以一处所无二并故。谓于一处镜色及像并见现前。二色不应同处并有。依异大故。又陜水上两岸色形。同处一时俱现二像。居两岸者互见分明。曾无一处并见二色。不应谓此二色俱生。又影与光未尝同处。然曾见镜悬置影中。光像显然现于镜面。不应于此谓二并生。或言一处无二并者。镜面月像谓之为二。近远别见如观井水。若有并生如何别见。故知诸像于理实无。然诸因缘和合势力令如是见。以诸法性功能差别难可思议。已辩不成所以非喻。言非等故亦非喻者。以质与像非相续故。谓质与像非一相续。唯依镜等有像现故。像与本质俱时有故。如死生有是一相续前后无间余处续生。质像相望无此相续。以不相似故不成喻。又所现像由二生故。谓二缘故诸像得生。一者本质。二者镜等。二中胜者像依彼生。生有无容由二缘起。唯有死有无别胜依。故所引喻非等于法。亦不可说以外非情精血等缘为胜依性。由化生者空中欻生。于中计何为胜依性。已依正理对破彼宗从死至生处容间绝。是故中有决定非无。次依圣教证有中有。谓契经言。有有七种。即五趣有业有中有。若此契经彼部不诵。岂亦不诵健达缚经。如契经言。入母胎者要由三事俱现在前。一者母身是时调适。二者父母交爱和合。三健达缚正现在前。除中有身何健达缚。前蕴已坏何现在前。若此契经彼亦不诵。复云何释掌马族经。如彼经言。汝今知不。此健达缚正现前者。为婆罗门。为刹帝利。为是吠舍。为戍达罗。为东方来。为南西北。前蕴已坏不可言来。此所言来固唯中有。若复不诵如是契经。五不还经当云何释。如契经说。有五不还。一者中般。二者生般。三无行般。四有行般。五者上流。中有若无何名中般。有余师执。有天名中。住彼般涅槃。是故名中般。是则应许有生等天。既不许然故执非善。又经说有七善士趣。谓于前五中般分三。由处及时近中远故。譬如札火小星迸时才起近即灭。初善士亦尔。譬如铁火小星迸时起至中乃灭。二善士亦尔。譬如铁火大星迸时远未堕而灭。三善士亦尔。非彼所执别有中天。有此时处三品差别。故彼所执定非应理。有余复说。或寿量中间。或近天中间。断余烦恼成阿罗汉。是名中般。由至界位或想或寻而般涅槃。故有三品。或取色界众同分已即般涅槃。是名第一。从是次后受天乐已方般涅槃。是名第二。复从此后入天法会乃般涅槃。是名第三。入法会已复经多时方般涅槃。是名生般。或减多寿方般涅槃。非创生时故名生般。如是所说与火星喻皆不相应。所以者何。以彼处行无差别故。又无色界亦应说有中般涅槃。由彼亦有寿量中间般涅槃故。然不说彼有中般者。如嗢拖南伽他中说

  总集众圣贤　　四静虑各十
  三无色各七　　唯六谓非想

故彼所执皆是虚妄。若复不诵如是等经。无上法王久已灭度。诸大法将亦般涅槃。圣教支离已成多部。其于文义异执交驰。取舍任情于今转盛。哀哉汝等固守愚迷违理拒教。可伤之甚。诸有冯前理教为量。中有于彼实有极成。若尔云何契经中说造极恶业度使魔罗。现身颠坠无间地狱。此经意说。彼命未舍。地狱猛焰已烧其身。因此命终受彼中有。乘兹仍堕无间地狱。由彼恶业势力增强。不待命终苦相已至。先受现受后受生受。何故经说。一类有情于五无间业作及增长已。无间必定生那落迦。此经意遮彼往异趣。及显彼业定顺生受。若但执文。应要具五方生地狱。非随阙一。或余业因便成大过。又言。无间生那落迦。应作即生不待身坏。或谁不许中有是生。那落迦名亦通中有。死有无间中有起时亦得名生。生方便故。经言无间生那落迦。不言尔时即是生有。若尔。经颂复云何通。如经颂言

  再生汝今过盛位　　至衰将近琰魔王
  欲往前路无资粮　　求住中间无所止

若有中有。如何世尊言彼中间无有所止。此颂意显彼于人中速归磨灭无暂停义。或彼中有为至所生亦无暂停。行无碍故。宁知经意如此非余。汝复焉知。如余非此。二责既等。何乃偏征。二释于经并无违害。如何偏证中有是无。凡引证言理无异趣。此有异趣为证不成

说一切有部俱舍论卷第八阿毗达磨俱舍论卷第九

        尊者世亲造

        三藏法师玄奘奉　诏译

    分别世品第三之二

当往何趣。所起中有形状如何。颂曰

  此一业引故　　如当本有形
  本有谓死前　　居生刹那后

论曰。若业能引当所往趣。彼业即招能往中有。故此中有若往彼趣。即如所趣当本有形。若尔于一狗等腹中容有五趣中有顿起。既有地狱中有现前。如何不能焚烧母腹。彼居本有亦不恒烧。如暂游园。况在中有。设许能烧如不可见亦不可触。以中有身极微细故。所难非理。诸趣中有虽居一腹非互触烧。业所遮故。欲中有量虽如小儿年五六岁而根明利。菩萨中有如盛年时形量周圆具诸相好。故住中有将入胎时照百俱胝四大洲等。若尔何故菩萨母梦中见白象子来入己右胁。此吉瑞相非关中有。菩萨久舍傍生趣故。如讫栗枳王梦所见十事

  谓大象井糗　　栴檀妙园林
  小象二猕猴　　广坚衣斗诤

如是所梦。但表当来余事先兆。非如所见。又诸中有从生门入。非破母腹而得入胎。故双生者前小后大。法善现说复云何通

  白象相端严　　具六牙四足
  正知入母腹　　寝如仙隐林

不必须通。非三藏故。诸讽颂言。或过实故。若必须通如菩萨母所见梦相。造颂无失。色界中有量圆满如本有。与衣俱生。惭愧增故。菩萨中有亦与衣俱。鲜白苾刍尼由本愿力故。彼于世世有自然衣。恒不离身随时改变。乃至最后般涅槃时。即以此衣缠尸焚葬。所余欲界中有无衣。由皆增长无惭愧故。所似本有其体是何。谓死有前生有后蕴。总说有体是五取蕴。于中位别分析为四。一者中有。义如前说。二者生有。谓于诸趣结生刹那。三者本有。除生刹那死前余位。四者死有。谓最后念。次中有前。有色有情具足四有。若在无色中阙具三。已说形量。余义当辩。颂曰

  同净天眼见　　业通疾具根
  无对不可转　　食香非久住
  倒心趣欲境　　湿化染香处
  天首上三横　　地狱头归下

论曰。此中有身同类相见。若有修得极净天眼。亦能得见。诸生得眼皆不能观。以极细故。有余师说。天中有眼具足能见。五趣中有。人鬼傍生地狱中有见四三二一。谓自下除上。一切通中业通最疾。陵虚自在是谓通义。通由业得名为业通。此通势用速故名疾。中有具得最疾业通。上至世尊无能遮抑。以业势力最强盛故。一切中有皆具五根。对谓对碍。此金刚等所不能遮故名无对。曾闻析破炎赤铁团见于其中有虫生故。应往彼趣中有已生。一切种力皆不能转。谓不可令人中有没余中有起。余类亦然。为往彼趣中有已起。但应往彼。定不往余。欲中有身资段食不。虽资段食然细非粗。其细者何。谓唯香气。由斯故得健达缚名。诸字界中义非一故。而音短者如设建途及羯建途。略故无过。诸少福者唯食恶香。其多福者好香为食。如是中有为住几时。大德说言。此无定限。生缘未合中有恒存。由彼命根非别业引。与所趣人等众同分一故。若异此者中有命根最后灭时应立死有。设有肉聚等妙高山。至夏雨时变成虫聚。应言诸中有渐待此时。为说从何方顿来至此。虽无经论诚文判释。然依正理应作是言。有杂类生数无边际贪着香味寿量短促。彼诸有情因嗅此气贪香味故俱时命终。由爱觉先感虫身业同时于此受细虫身。或多有情应俱生此。多缘未合住中有中。今遇多缘方顿生此。应俱生者定不异时。如有能招转轮王业。要至人寿八万岁时或过此时方顿与果。非于余位。此亦应然。故世尊言。诸有情类业果差别不可思议。尊者世友言。此极多七日。若生缘未合。便数死数生。有余师言。极七七日。毗婆沙说。此住少时。以中有中乐求生有故非久住。速往结生。其有生缘未即和合。若定此处此类应生。业力即令此缘和合。若非定托此和合缘。便即寄生余处余类。有说转受相似类生。且如家牛及狗熊马欲增次属夏秋冬春。野牛野干罴驴无定。前四中有若不遇时。如次转生后四同类。岂不中有必无与生众同分别。一业引故。如何可言转受相似

如是中有为至所生。先起倒心驰趣欲境。彼由业力所起眼根虽住远方能见生处父母交会而起倒心。若男缘母起于男欲。若女缘父起于女欲。翻此缘二俱起嗔心。故施设论有如是说。时健达缚于二心中随一现行。谓爱或恚。彼由起此二种倒心。便谓己身与所爱合。所憎不净泄至胎时。谓是已有便生喜慰。从兹蕴厚中有便没生有起已名已结生。若男处胎依母右胁向背蹲坐。若女处胎依母左胁向腹而住。若非男女住母胎时。随所起贪如应而住。必无中有非女非男。以中有身必具根故。由处中有或女或男故入母胎随应而住。后胎增长或作不男。于此义中复应思择。为由业力精血大种即成根依。为业别生根依大种依精血住。有言。精血即成根依谓前无根中有俱灭。后有根者无间续生。如种与芽灭生道理。由斯初位名羯剌蓝。亦妙顺成此经文句。父母不净生羯剌蓝。又告苾刍。汝等长夜执受血滴增羯吒私。有余师言。别生大种。如依叶粪别有虫生。不净聚中生羯剌蓝。故说父母不净生羯剌蓝。故与彼经无相违失。如是且说胎卵二生。余随所应今次当说。若湿生者染香故生。谓远嗅知生处香气便生爱染往彼受生。随业所应香有净秽。若化生者染处故生。谓远观知当所生处。便生爱染往彼受生。随业所应处有净秽。岂于地狱亦生爱染。由心倒故起染无失。谓彼中有。或见自身冷雨寒风之所逼切。见热地狱火焰炽然。情欣暖触投身于彼。或见自身热风盛火之所逼害。见寒地狱心欲清凉投身于彼。先旧诸师作如是说。由见先造感彼业时己身伴类驰往赴彼。又天中有首正上升如从坐起。人鬼傍生中有行相还如人等。地狱中有头下足上颠坠其中。故伽他说

  颠坠于地狱　　足上头归下
  由毁谤诸仙　　乐寂修苦行

前说倒心入母胎藏。一切中有皆定尔耶。不尔。经言。入胎有四。其四者何。颂曰

  一于入正知　　二三兼住出
  四于一切位　　及卵恒无知
  前三种入胎　　谓轮王二佛
  业智俱胜故　　如次四余生

论曰。有诸有情。多集福业勤修念慧。故死生时念力所持正知无乱。于中或有正知入胎。或有正知住胎兼入。或正知出兼知入住。兼言为显后必带前。有诸有情福智俱少。入住出位皆不正知。入不正知住出必尔。顺结颂法故逆说四。诸卵生者入胎等位皆恒无知。如何卵生从卵而出言入胎藏。以卵生者先必入胎。或据当来名卵生者。如契经说造作有为。世间亦言煮饭磨糗故说卵生入胎无失。云何三位正不正知。且诸有情若福微薄入母胎位起倒想解。见大风雨毒热严寒或大军众声威乱逼。遂见自入密草稠林叶窟茅庐投树墙下。住时见已住在此中。出位见身从此处出。若福增多入母胎位起倒想解。自见己身入妙园林升花台殿居胜床等。住出如前。是谓三时不正知者。若于三位皆能正知。于入等时无倒想解。谓入胎位知自入胎。住出胎时自知住出。又别显示四入胎者。且前三种谓转轮王独觉大觉。如其次第。初入胎者。谓转轮王。入位正知非住非出。二入胎者。谓独胜觉。入住正知非于出位。三入胎者。谓无上觉。入住出位皆能正知。此初三人以当名显。何缘如是三品不同。由业智俱如次胜故。第一业胜。谓转轮王宿世曾修广大福故。第二智胜。谓独胜觉久习多闻。胜思择故。第三俱胜。谓无上觉。旷劫修行胜福智故。除前三种余胎卵生福智俱劣合成第四。此中外道执我者言。若许有情转趣余世。即我所执有我义成。今为遮彼。颂曰

  无我唯诸蕴　　烦恼业所为
  由中有相续　　入胎如灯焰
  如引次第增　　相续由惑业
  更趣于余世　　故有轮无初

论曰。汝等所执我为何相。能舍此蕴能续余蕴。内用士夫此定非有如色眼等不可得故。世尊亦言。有业有异熟作者不可得。谓能舍此蕴及能续余蕴。唯除法假。法假谓何。依此有彼有。此生故彼生。广说缘起。若尔何等我非所遮。唯有诸蕴。谓唯于蕴假立我名非所遮遣。若尔应许诸蕴即能从此世间转至余世。蕴刹那灭于轮转无能。数习烦恼业所为故。令中有蕴相续入胎。譬如灯焰虽刹那灭。而能相续转至余方。诸蕴亦然。名转无失。故虽无我而由惑业诸蕴相续入胎义成。如业所引次第转增诸蕴相续。复由烦恼业力所为转趣余世。谓非一切所引诸蕴增长相续修促量齐。引寿业因有差别故。随能引业势力增征。齐尔所时次第增长。云何次第。如圣说言

  最初羯剌蓝　　次生頞部昙
  从此生闭尸　　闭尸生键南
  次钵罗奢佉　　后发毛爪等
  及色根形相　　渐次而转增

谓母腹中分位有五。一羯剌蓝位。二頞部昙位。三闭尸位。四键南位。五钵罗奢佉位。此胎中箭渐次转增。乃至色根形相满位。由业所起异熟风力转胎中箭令趣产门。如强粪团过量閟涩。从此转堕剧苦难任。其母或时威仪饮食执作过分。或由其子宿罪业力死于胎内。时有女人或诸医者。妙通产法善养婴儿。温以稣油睒未梨汁用涂其手执小利刀。内如粪坑最极猥贱杂秽充塞。黑闇所居无量千虫之所依止。常流恶汁恒须对治。精血垢腻溃烂臭滑。不净流溢鄙秽叵观。穿漏薄皮以覆其上。宿业所引。身疮孔中分解肢节牵出于外。然此胎子乘宿所为顺后受业所趣难了。或复无难安隐得生。体如新疮细软难触。或母爱子或余女人以如刀灰粗涩两手执取洗拭而安处之。次含清酥饮以母乳渐令习受细粗饮食。次第转增至根熟位。复起烦恼积集诸业。由此身坏。复有如前中有相续更趣余世。如是惑业为因故生。生复为因起于惑业。从此惑业更复有生。故知有轮旋环无始。若执有始始应无因。始既无因余应自起。现见芽等因种等生。由处及时俱决定故。又由火等熟变等生。由此定无无因起法。说常因论如前已遣。是故生死决定无初。然有后边由因尽故。生依因故。因灭坏时生果必亡。理定应尔。如种灭坏芽必不生。如是蕴相续说三生为位。颂曰

  如是诸缘起　　十二支三际
  前后际各二　　中八据圆满

论曰。十二支者。一无明二行三识四名色五六处六触七受八爱九取十有十一生十二老死。言三际者。一前际二后际三中际。即是过未及现三生。云何十二支于三际建立。谓前后际各立二支。中际八支。故成十二。无明行在前际。生老死在后际。所余八在中际。此中际八一切有情此一生中皆具有不。非皆具有。若尔何故说有八支。据圆满者。此中意说。补特伽罗历一切位名圆满者。非诸中夭及色无色。但据欲界补特伽罗。大缘起经说具有故。彼说。佛告阿难陀言。识若不入胎得增广大不。不也世尊。乃至广说。有时但说二分缘起。一前际摄。二后际摄。前七支前际摄。谓无明乃至受。后五支后际摄。谓从爱至老死。前后因果二分摄故。无明等支何法为体。颂曰

  宿惑位无明　　宿诸业名行
  识正结生蕴　　六处前名色
  从生眼等根　　三和前六处
  于三受因异　　未了知名触
  在淫爱前受　　贪资具淫爱
  为得诸境界　　遍驰求名取
  有谓正能造　　牵当有果业
  结当有名生　　至当受老死

论曰。于宿生中诸烦恼位至今果熟总谓无明。彼与无明俱时行故。由无明力彼现行故。如说王行非无导从王俱胜故总谓王行。于宿生中福等业位至今果熟总得行名。初句位言流至老死。于母胎等正结生时一刹那位五蕴名识。结生识后六处生前中间诸位总称名色。此中应说四处生前而言六者据满立故。眼等已生至根境识未和合位得六处名。已至三和未了三受因差别位总名为触。已了三受因差别相未起淫贪此位名受。贪妙资具淫爱现行未广追求此位名爱。为得种种上妙境界周遍驰求。此位名取。因驰求故积集能牵当有果业此位名有。由是业力从此舍命正结当有此位名生。当有生支即如今识生刹那后渐增乃至当来受位总名老死。如是老死即如今世名色六处触受四支。辩十二支体别如是。又诸缘起差别说四。一者刹那。二者连缚。三者分位。四者远续。云何刹那。谓刹那顷由贪行杀具十二支。痴谓无明。思即是行。于诸境事了别名识。识俱三蕴总称名色。住名色根说为六处。六处对余和合有触。领触名受。贪即是爱。与此相应诸缠名取。所起身语二业名有。如是诸法起即名生。熟变名老灭坏名死。复有说者。刹那连缚如品类足。俱遍有为。十二支位所有五蕴皆分位摄。即此悬远相续无始说名远续。世尊于此意说者何。颂曰

  传许约位说　　从胜立支名

论曰。传许。世尊唯约分位说诸缘起有十二支。若支支中皆具五蕴。何缘但立无明等名。以诸位中无明等胜故。就胜立无明等名。谓若位中无明最胜。此位五蕴总名无明。乃至位中老死最胜。此位五蕴总名老死。故体虽总名别无失。何缘经说此十二支与品类足所说有异。如彼论说。云何为缘起。谓一切有为乃至广说。素怛缆言因别意趣。阿毗达磨依法相说如是宣说。分位刹那远续连缚唯有情数。情非情等是谓差别。契经何故唯说有情。颂曰

  于前后中际　　为遣他愚惑

论曰。为三际中遣他愚惑。三际差别唯在有情。如何有情前际愚惑。谓于前际生如是疑。我于过去世为曾有非有。何等我曾有。云何我曾有。如何有情后际愚惑。谓于后际生如是疑。我于未来世为当有非有。何等我当有。云何我当有。如何有情中际愚惑。谓于中际生如是疑。何等是我。此我云何。我谁所有。我当有谁。为除如是三际愚惑故。经唯说有情缘起。如其次第说无明行及生老死并识至有。所以者何。以契经说。苾刍谛听。若有苾刍。于诸缘起缘已生法。能以如实正慧观见。彼必不于三际愚惑谓我于过去世为曾有非有等。有余师说爱取有三亦为除他后际愚惑。此三皆是后际因故。又应知。此说缘起门虽有十二支而三二为性。三谓惑业事。二谓果与因。其义云何。颂曰

  三烦恼二业　　七事亦名果
  略果及略因　　由中可比二

论曰。无明爱取烦恼为性。行及有支以业为性。余识等七以事为性。是烦恼业所依事故。如是七事即亦名果。义准余五即亦名因以烦恼业为自性故。何缘中际广说果因。开事为五惑为二故。后际略果。事唯二故。前际略因。惑唯一故。由中际广可以比度前后二际。广义已成故不别说。说便无用。若缘起支唯十二者。不说老死果。生死应有终。不说无明因。生死应有始。或应更立余缘起支。余复有余成无穷失。不应更立。然无前过。此中世尊由义已显。云何已显。颂曰

  从惑生惑业　　从业生于事
  从事事惑生　　有支理唯此

论曰。从惑生惑谓爱生取。从惑生业谓取生有。无明生行。从业生事谓行生识及有生生。从事生事谓从识支生于名色。乃至从触生于受支及从生支生于老死。从事生惑谓受生爱。由立有支其理唯此。已显老死为事惑因。及显无明为事惑果。无明老死事惑性故。岂假更立余缘起支。故经言如是纯大苦蕴集。若不尔者此言何用

有余释言。余契经说。非理作意为无明因。无明复生非理作意。非理作意亦取支摄。故亦说在此契经中。此非理作意如何取支摄。若言由此与彼相应。则爱无明亦应彼摄。设许彼摄。云何能证非理作意为无明因。若但彼摄即证因果。爱与无明亦彼摄故。应不别立为缘起支

余复释言。余契经说。非理作意为无明因。无明复生非理作意。非理作意说在触时故。余经说。眼色为缘生痴所生染浊作意。此于受位必引无明故。余经言。由无明触所生诸受为缘生爱。是故触时非理作意与受俱转无明为缘。由此无明无无因过。亦不须立余缘起支。又缘起支无无穷失。非理作意从痴生故。如契经说。眼色为缘生痴所生染浊作意。余经虽有如是诚言。然此经中应更须说。不须更说。如何证知。由理证知。何等为理。非离无明受能为爱缘。以阿罗汉受不生爱故。又非无倒触能为染受缘。亦非离无明触可成颠倒。阿罗汉触非颠倒故。由如是理为证。故知若尔便应有太过失。诸由正理可得证知。一切皆应不须更说。故彼所说不成释难。然上所言。经不别说老死有果无明有因生死便成有终始者。此难非理。经意别故。亦非所说理不圆满。所以者何。此经但欲除所化者三际愚故。由所化者唯生是疑。云何有情三世连续。谓从前世今世得生。今世复能生于后世。如来但为除彼疑情。说十二支如前已辩。谓前后中际为遣他愚惑。如世尊告诸苾刍言。吾当为汝说缘起法缘已生法。此二何异。且本论文此二无别。以俱言摄一切法故。如何未来未已起法可同过现说缘已生。云何未来未已作法。得同过现说名有为。由能作思力已造故。若尔无漏如何有为。彼亦善思力已造故。若尔就得涅槃应然。理实应言依种类说。如未变坏亦得色名。由种类同所说无失。然今正释契经意者。颂曰

  此中意正说　　因起果已生

论曰。诸支因分说名缘起由此为缘能起果故。诸支果分说缘已生。由此皆从缘所生故。如是一切二义俱成。诸支皆有因果性故。若尔安立应不俱成。不尔所观有差别故。谓若观此名缘已生。非即观斯复名缘起。犹如因果父子等名。尊者望满意谓。诸法有是缘起非缘已生。应作四句。第一句者。谓未来法。第二句者。谓阿罗汉最后心位过现诸法。第三句者。余过现法。第四句者。诸无为法。经部诸师作如是白。此中所说为述己情为是经义。若是经义。经义不然。所以者何。且前所说分位缘起十二五蕴为十二支违背契经。经异说故。如契经说。云何为无明。谓前际无智乃至广说。此了义说不可抑令成不了义。故前所说分位缘起。经义相违。非一切经皆了义说。亦有随胜说。如象迹喻经。云何内地界。谓发毛爪等。虽彼非无余色等法而就胜说。此亦应尔。所引非证。非彼经中欲以地界辩发毛等成非具说。然彼经中以发毛等分别地界。非有地界越发毛等。故彼契经是具足说。此经所说无明等支。亦应如彼成具足说。除所说外无复有余。岂不地界越发毛等洟泪等中其体亦有。洟等皆亦说在彼经。如说复有身中余物。设复同彼有余无明。今应显示。若引异类置无明中此有何益。虽于诸位皆有五蕴然随此有无彼定有无者。可立此法为彼法支。或有五蕴而无有行随福非福不动行识乃至爱等。是故经义即如所说。所说四句理亦不然。若未来诸法非缘已生者。便违契经。经说。云何缘已生法。谓无明行至生老死。或应不许二在未来。是则坏前所立三际。有说。缘起是无为法。以契经言如来出世若不出世。如是缘起法性常住。由如是意理则可然。若由别意理则不然。云何如是意。云何为别意而说可然及不可然。谓若意说。如来出世若不出世。行等常缘无明等起非缘余法。或复无缘故言常住。如是意说。理则可然。若谓意说有别法体名为缘起湛然常住。此别意说理则不然。所以者何。生起俱是有为相故。非别常法为无常相可应正理。又起必应依起者立。此常住法彼无明等何相关预而说此法依彼而立为彼缘起。又名缘起而谓目常。如是句义无相应理。此中缘起是何句义。钵刺底是至义。医底界是行义。由先助力界义转变。故行由至转变成缘。参是和合义。嗢是上升义。钵地界是有义。有藉合升转变成起。由此有法至于缘已和合升起。是缘起义。如是句义理不应然所以者何。依一作者有二作用。于前作用应有已言。如有一人浴已方食。无少行法有在起前。先至于缘后时方起。非无作者可有作用。故说颂曰

  至缘若起先　　非有不应理
  若俱便坏已　　彼应先说故

无如是过。且应反诘声论诸师。法何时起。为在现在为在未来。设尔何失。起若现在起非已生。如何成现。现是已生复如何起。已生复起便致无穷。起若未来尔时未有何成作者。作者既无何有作用。故于起位即亦至缘。起位者何。谓未来世诸行正起。即于此位亦说至缘。又声论师妄所安立作者作用理实不成。有是作者起是作用。非于此中见有作者。异起作用真实可得。故此义言于俗无谬。此缘起义即是所说。依此有彼有。此生故彼生。故应引彼释缘起义。故说颂言

  如非有而起　　至缘应亦然
  生已起无穷　　或先有非有
  俱亦有言已　　闇至已灯灭
  及开口已眠　　若后眠应闭

有执。更以余义释难。钵刺底是种种义。医底界是不住义。不住由种种助故变成缘。参是聚集义。嗢是上升义。钵地界是行义。由嗢为先行变成起。此说种种缘和合已令诸行法聚集升起。是缘起义

如是所释于此可然。眼色各为缘起于眼识等。此中种种聚集岂成。何故世尊说前二句。谓依此有彼有。及此生故彼生。为于缘起知决定故。如余处说。依无明有诸行得有。非离无明可有诸行。又为显示诸支传生。谓依此支有彼支得有。由彼支生故余支得生。又为显示三际传生。谓依前际有中际得有。由中际生故后际得生。又为显示亲传二缘。谓有无明无间生行。或展转力诸行方生。有余师释。如是二句为破无因常因二论。谓非无因诸行可有。亦非由常自性我等无生因故诸行得生。若尔便成前句无用。但由后句此生故彼生。能具破前无因常因故。然或有执有我为依行等得有。由无明等因分生故行等得生。是故世尊为除彼执决判果有即由生因。若此生故彼生。即依此有彼有。非谓果有别依余因。谓无明缘行。乃至如是纯大苦蕴集轨范诸师释。此二句为显因果不断及生。谓依无明不断诸行不断。即由无明生故诸行得生。如是展转皆应广说。有释。为显因果住生。谓乃至因相续有果相续亦有。及即由因分生故诸果分亦生。此欲辩生。何缘说住。又佛何故破次第说。先说住已而后说生。复有释言。依此有彼有者。依果有因有灭。此生故彼生者。恐疑果无因生。是故复言由因生故果方得起。非谓无因。经义若然应作是说。依此有彼灭无。又应先言因生故果生。已后乃可说依果有因灭无。如是次第方名善说。若异此者。欲辩缘起。依何次第。先说因灭。故彼所释非此经义

复次云何无明缘行。广说乃至生缘老死。我今略显符顺经义。谓诸愚夫于缘生法不知唯行。妄起我见及我慢执。为自受乐非苦乐故。造作身等各三种业。谓为自身受当乐故造诸福业。受当来乐非苦乐故造不动业。受现乐故造非福业。如是名为无明缘行。由引业力识相续流如火焰行。往彼彼趣凭附中有驰赴所生结生有身。名行缘识。若作此释善顺契经分别识支通于六识。识为先故。于此趣中有名色生。具足五蕴展转相续。遍一期生。于大因缘辩缘起等诸经皆有如是说故。如是名色渐成熟时具眼等根说为六处。次与境合便有识生。三和故有顺乐等触。依此便生乐等三受。从此三受引生三爱。谓由苦逼有于乐受发生欲爱。或有于乐非苦乐受发生色爱。或有唯于非苦乐受生无色爱。从欣受爱起欲等取。此中欲者谓五妙欲。见谓六十二见。如梵网经广说。戒谓远离恶戒。禁谓狗牛等禁。如诸离系及婆罗门播输钵多般利伐罗勺迦等异类外道受持种种露形拔发披乌鹿皮持髻涂灰执三杖剪须发等无义苦行。我语谓内身依之说我故。有余师说。我见我慢名为我语。云何此二独名我语。由此二种说有我故。我非有故说名我语。如契经说。苾刍当知。愚昧无闻诸异生类随假言说起于我执。于中实无我及我所。于前四种。取谓欲贪。故薄伽梵诸经中释。云何为取。所谓欲贪。由取为缘积集种种招后有业说名为有。如世尊告阿难陀言。招后有业说名为有。有为缘故。识相续流趣未来生。如前道理具足五蕴说名为生。以生为缘便有老死。其相差别广说如经。如是纯言显唯有行无我我所。大苦蕴言显苦积集无初无后。集言为显诸苦蕴生。毗婆沙宗如前已说

说一切有部俱舍论卷第九阿毗达磨俱舍论卷第十

        尊者世亲造

        三藏法师玄奘奉　诏译

    分别世品第三之三

无明何义。谓体非明。若尔无明应是眼等。既尔。此义应谓明无。若尔无明体应非有。为显有体义不滥余。颂曰

  明所治无明　　如非亲实等

论曰。如诸亲友所对怨敌亲友相违名非亲友。非异亲友。非亲友无。谛语名实。此所对治虚诳言论名为非实。非异于实。亦非实无。等言为显非法非义非事等性非异非无。如是无明别有实体。是明所治非异非无。云何知然。说行缘故。复有诚证。颂曰

  说为结等故　　非恶慧见故
  与见相应故　　说能染慧故

论曰。经说无明以为结缚随眠及漏轭瀑流等。非余眼等及体全无可得说为结缚等事。故有别法说名无明。如恶妻子名无妻子。如是恶慧应名无明。彼非无明有是见故。诸染污慧名为恶慧。于中有见故非无明。若尔非见慧应许是无明。不尔。无明见相应故。无明若是慧应见不相应。无二慧体共相应故。又说无明能染慧故。如契经言。贪欲染心令不解脱。无明染慧令不清净。非慧还能染于慧体。如贪异类能染于心。无明亦应异慧能染。如何不许诸染污慧间杂善慧令不清净说为能染。如贪染心令不解脱。岂必现起与心相应方说能染。然由贪力损缚于心令不解脱。后转灭彼贪熏习时心便解脱。如是无明染污于慧令不清净。非慧相应。但由无明损浊于慧。如是分别何理相违。谁复能遮自所分别。然异慧类别有无明。如贪异心此说为善。有执烦恼皆是无明。此亦应同前理遮遣。若诸烦恼皆是无明。于结等中不应别说。亦不应与见等相应。见等不应自相应故。或亦应说无明染心。若谓此中就差别说。应于染慧不说总名。既许无明别法为体应说此体。其相云何。谓不了知谛实业果。未测何相名不了知。为异了知。为此非有。二俱有过。如无明说。此谓了知所治别法。此复难测。其相是何。此类法尔应如是说。如余处言。云何为眼。谓清净色眼识所依。无明亦然。唯可辩用。大德法救说。此无明是诸有情恃我类性。异于我慢类体是何。经言。我今如是知已如是见已。诸所有爱。诸所有见。诸所有类性。诸我我所执。我慢执。随眠。断遍知故无影寂灭。故知类性异于我慢。宁知类性即是无明。不可说为余烦恼故。岂不可说为余慢等。若更于此巨细研寻。言论繁杂故应且止。名色何义。色如先辩。今唯辩名。颂曰

  名无色四蕴

论曰。无色四蕴何故称名。随所立名根境势力于义转变故说为名。云何随名势力转变。谓随种种世共立名。于彼彼义转变诠表。即如牛马色味等名。此复何缘标以名称。于彼彼境转变而缘。又类似名。随名显故。有余师说。四无色蕴舍此身已转趣余生。转变如名。故标名称。触何为义。颂曰

  触六三和生

论曰。触有六种。所谓眼触乃至意触。此复是何。三和所生。谓根境识三和合故有别触生。且五触生可三和合。许根境识俱时起故。意根过去。法或未来。意识现在。如何和合。此即名和合。谓因果义成。或同一果故名和合。谓根境识三同顺生触故。诸师于此觉慧不同。有说。三和即名为触。彼引经证。如契经言。如是三法聚集和合说名为触。有说。别法与心相应三和所生说名为触。彼引经证。经言。云何六。六法门。一六内处。二六外处。三六识身。四六触身。五六受身。六六爱身。此契经中根境识外别说六触。故触别有。说即三和名为触者。释后所引六六经言。非由别说便有别体。勿受及爱非法处摄无如是失。离爱受触别有所余法处体故。汝宗离触无别有三。可触及三差别而说。虽有根境不发于识。而无有识不托根境。故已说三更别说触便成无用。有余救言。非诸眼色皆诸眼识因。非诸眼识皆诸眼色果。非因果者别说为三。因果所收总立为触。说离三和有别触者。释前所引如是三法聚集和合名触。经言我部所诵经文异此。或于因上假说果名。如说诸佛出现乐等。如是展转更相难释。言论烦多故应且止。然对法者说有别触。即前六触复合为二。颂曰

  五相应有对　　第六俱增语

论曰。眼等五触说名有对。以有对根为所依故。第六意触说名增语。所以然者。增语谓名。名是意触所缘长境故偏就此名增语触。如说眼识但能了青不了是青。意识了青亦了是青。故名为长。故有对触名从所依。增语触名就所缘立。有说。意识语为增上方于境转。五识不然。是故意识独名增语。与此相应名增语触。故有对触名从所依。增语触名就相应立。即前六触随别相应复成八种。颂曰

  明无明非二　　无漏染污余
  爱恚二相应　　乐等顺三受

论曰。明无明等相应成三。一明触。二无明触。三非明非无明触。此三如次应知。即是无漏染污余相应触。余谓无漏及染污余。即有漏善无覆无记。无明触中一分数起。依彼复立爱恚二触。爱恚随眠共相应故。总摄一切复成三触。一顺乐受触。二顺苦受触。三顺不苦不乐受触。此三能引乐等受故。或是乐等受所领故。或能为受行相依故名为顺受。如何触为受所领行相依。行相极似触。依触而生故。如是合成十六种触。受何为义。颂曰

  从此生六受　　五属身余心

论曰。从前六触生于六受。谓眼触所生受至意触所生受。六中前五说为身受。依色根故。意触所生说为心受。但依心故。受生与触为后为俱。毗婆沙师说。俱时起触受展转俱有因故。云何二法俱时而生能生所生义可成立。如何不立。无功能故。于已生法余法无能。此与立宗义意无别。如言二法俱时而生能生所生义不成立。于已生法余法无能。义意同前。重说何用。若尔便有互相生失。许故非失。我宗许二为俱有因。亦互为果。仁虽许尔。而契经中不许此二互为因果。契经但说眼触为缘生眼触所生受。曾无经说眼受为缘生眼受所生触。又此义非理。越能生法故。若法极成能生彼法。此法与彼时别极成。如先种后芽先乳后酪先击后声先意后识等。先因后果非不极成。亦有极成同时因果。如眼识等眼色等俱。四大种俱有所造色。此中亦许前根境缘能发后识。前大造聚生后造色。何理能遮。如影与身。岂非俱有。有说。触后方有受生。根境为先次有识起。此三合故即名为触。第三刹那缘触生受。若尔应识非皆有受。诸识亦应非皆是触。无如是失。因前位触故。后触位受生故。诸触时皆悉有受。所有识体无非是触。此不应理。何理相违。谓或有时二触境别。因前受位触生后触位受。如何异境受从异境触生。或应许受此心相应非与此心同缘一境。既尔。若许有成触识是触无受。于此位前有识有受而体非触。缘差故然。斯有何过。若尔便坏十大地法。彼定一切心品恒俱。彼定恒俱依何教立。依本论立。我等但以契经为量。本论非量。坏之何咎。故世尊言。当依经量。或大地法义非要遍诸心。若尔何名大地法义。谓有三地。一有寻有伺地。二无寻唯伺地。三无寻无伺地。复有三地。一善地。二不善地。三无记地。复有三地。一学地。二无学地。三非学非无学地。若法于前诸地皆有。名大地法。若法唯于诸善地中有。名大善地法。若法唯于诸染地中有。名大烦恼地法。如是等法各随所应更代而生。非皆并起。余说如是大不善地法。因诵引来。是今所增益非本所诵。若于触后方有受生。经云何释。如契经说。眼及色为缘生于眼识。三和合触俱起受想思。但言俱起不说触俱。此于我宗何违须释。又于无间亦有俱声。如契经说。与慈俱行修念觉支。故彼非证。若尔何故。契经中言。是受是想是思是识。如是诸法相杂不离。故无有识离于受等。今应审思。相杂何义。此经复说。诸所受即所思。诸所思即所想。诸所想即所识。未了于此为约所缘。为约刹那作如是说。于寿与暖俱时起中。亦有如斯相杂言。故例知。此说定约刹那。又契经言三和合触。如何有识而非三和。或是三和而不名触。故应定许一切识俱悉皆有触诸所有触无不皆与受等俱生。傍论已终。应辩本义。颂曰

  此复成十八　　由意近行异

论曰。于前略说一心受中。由意近行异复分成十八。应知此复声显乘前起后。此意近行十八云何。谓喜忧舍各六近行。此复何缘立为十八。若由自性应但有三。喜忧舍三自性异故。若由相应应唯有一。一切皆与意相应故。若由所缘应但有六。色等六境为所缘故。此成十八。具足由三。于中十五色等近行名不杂缘。境各别故。三法近行皆通二种。意近行名为目何义。传说。喜等意为近缘于诸境中数游行故。有说。喜等能为近缘令意于境数游行故。如何身受非意近行。非唯依意故不名近。由无分别故亦非行。第三静虑意地乐根。意近行中何故不摄。传说。初界意识相应无乐根故。又无所对苦根所摄意近行故。若唯意地何故经言眼见色已于顺喜色起喜近行。广说如经。依五识身所引意地喜等近行故作是说。如依眼识引不净观。此不净观唯意地摄。又彼经言眼见色已乃至广说。故不应难。若虽非见乃至触已。而起喜忧舍亦是意近行。若异此者。在欲界中应无缘色界色等意近行。又在色界。应无缘欲香味触境诸意近行。见色等言随明了说见色等已于声等中起喜忧舍亦意近行。随无杂乱故作是说。于中建立根境定故。为有色等于喜等三唯能顺生一近行不。有就相续非约所缘。诸意近行中。几欲界系。欲界意近行几何所缘。色无色界为问亦尔。颂曰

  欲缘欲十八　　色十二上三
  二缘欲十二　　八自二无色
  后二缘欲六　　四自一上缘
  初无色近分　　缘色四自一
  四本及三边　　唯一缘自境

论曰。欲界所系具有十八。缘欲界境其数亦然。缘色界境唯有十二。除香味六彼无境故。缘无色境唯得有三。彼无色等五所缘故说欲界系已。当说色界系。初二静虑唯有十二。谓除六忧缘欲界境亦有十二。除香味四余八自缘。二缘无色。谓法近行。三四静虑唯六。谓舍缘欲界境亦得有六。除香味二余四自缘。一缘无色谓法近行。说色界系已。当说无色系。空处近分唯有四种。谓舍但缘色声触法。缘第四静虑亦具有四种。此就许有别缘者说。若执彼地唯总缘下。但有杂缘法意近行。缘无色界唯一。谓法四根本地及上三边唯一。谓法但缘自境。无色根本不缘下故。彼上三边不缘色故。不缘下义如后当辩。此意近行通无漏耶。颂曰

  十八唯有漏

论曰。无意近行通无漏者。故言十八唯是有漏。谁成就几意近行耶。谓生欲界。若未获得色界善心。成欲一切初二定八三四定四无色界一。所成上界皆不下缘。唯染污故。若已获得色界善心未离欲贪。成欲一切初静虑十。余说如前。初静虑中唯成四喜。染不缘下香味境故。舍具成六。未至定中善心得缘香味境故。余随此理如应当知。若生色界。唯成欲界一舍法近行。谓通果心俱。有说。如是诸意近行。毗婆沙师随义而立。然我所见经义有殊。所以者何。非于此地已得离染。可缘此境起意近行。故非有漏喜忧舍三皆近行摄。唯杂染者与意相牵数行所缘。是意近行。云何与意相牵数行。或爱或憎或不择舍。为对治彼说六恒住。谓见色已不喜不忧。心恒住舍具念正智。广说乃至知法亦尔。非阿罗汉无有世间缘善法喜。但为遮止杂染近行故作是说。又即喜等为三十六师句。谓为耽嗜出离依别。此句差别。大师说故。耽嗜依者。谓诸染受。出离依者。谓诸善受。如是所说受。有支中应知。义门无量差别。何缘不说所余有支。颂曰

  余已说当说

论曰。所余有支。或有已说。或有当说。故此不论。此中识支如先已说识谓各了别此即名意处等。其六处支如先已说彼识依净色名眼等五根等。行有二支业品当说。爱取二支随眠品当说。此诸缘起略立为三。谓烦恼业异熟果事。应寄外喻显别功能。颂曰

  此中说烦恼　　如种复如龙
  如草根树茎　　及如糠裹米
  业如有糠米　　如草药如花
  诸异熟果事　　如成熟饮食

论曰。如何此三种等相似。如从种子芽叶等生。从烦恼生烦恼业事。如龙镇池水恒不竭。烦恼镇业生续无穷。如草根未拔苗剪剪还生。未拔烦恼根趣灭灭还起。如从树茎频生枝花果。从诸烦恼数起惑业事如糠裹米能生芽等。非独能生。或得裹业能感余生。非独能感。惑如种等应如是知。如米有糠能生芽等。业有烦恼能招异熟。如诸草药果熟为后边。业果熟已更不招异熟。如花于果为生近因。业为近因能生异熟。业如米等。应如是知。如熟饮食但应受用。不可复转成余饮食。异熟果事既成熟已。不能更招余生异熟。若诸异熟复感余生。余复感余应无解脱。事如饮食应如是知。如是缘起烦恼业事。生生相续不过四有。中生本死。如前已释。染不染义三界有无。今当略辩。颂曰

  于四种有中　　生有唯染污
  由自地烦恼　　余三无色三

论曰。于四有中生有唯染。由何烦恼自地诸惑。谓此地生此地一切烦恼染污此地生有。故对法者咸作是言。诸烦恼中无一烦恼于结生位无润功能。然诸结生唯烦恼力。非由自力现起缠垢。虽此位中心身昧劣。而由数起或近现行引发力故。烦恼现起。应知中有初续刹那亦必染污。犹如生有。然余三有一一通三。谓本死中三。各善染无记。于无色界除中有三。非彼界中有处隔别。为往余处可立中有。颂中不说欲色二界。故知于中许具四有。有情缘起已广分别。是诸有情由何而住。颂曰

  有情由食住　　段欲体唯三
  非色不能益　　自根解脱故
  触思识三食　　有漏通三界
  意成及求生　　食香中有起
  前二益此世　　所依及能依
  后二于当有　　引及起如次

论曰。经说。世尊自悟一法正觉正说。谓诸有情一切无非由食而住。何等为食。食有四种。一段二触三思四识。段有二种。谓细及粗。细谓中有食。香为食故。及天劫初食。无变秽故。如油沃砂。散入支故。或细污虫婴儿等食说名为细。翻此为粗。如是段食唯在欲界。离段食贪生上界故。唯欲界系。香味触三。一切皆为段食自体。可成段别而饮啖。故谓以口鼻分分受之。光影炎凉如何成食。传说。此语从多为论。又虽非饮啖而能持身。亦细食所摄。如涂洗等。色亦可成段别饮啖。何缘非食。此不能益自所对根解脱者故。夫名食者。必先资益自根大种。后乃及余。饮啖色时于自根大尚不为益。况能及余。由彼诸根境各别故。有时见色生喜乐者。缘色触生。是食非色。又不还者及阿罗汉解脱食贪。虽见种种上妙饮食而无益故。触谓三和所生诸触。思谓意业。识谓识蕴。此三唯有漏通三界皆有。如何食体不通无漏。毗婆沙师作如是释。能资诸有是其食义。无漏修生为灭诸有。又契经说。食有四种。能令部多有情安住。及能资益诸求生者。无漏不然。故非食体。言部多者。显已生义。诸趣生已皆谓已生。复说求生为何所目。此目中有。由佛世尊以五种名说中有故。何等为五。一者意成。从意生故。非精血等所有外缘合所成故。二者求生。常喜寻察当生处故。三者食香。身资香食往生处故。四者中有。二趣中间所有蕴故。五者名起。对向当生暂时起故。如契经说。有坏自体起。有坏世间生。起谓中有。又经说。有补特伽罗。已断起结未断生结。于此经中广说四句。离二界贪诸上流者为第一句。中般涅槃为第二句。诸阿罗汉为第三句。除前诸相为第四句。又部多者。谓阿罗汉。余有爱者说名求生。几食能令部多安住。几食资益求生有情。毗婆沙师说。皆具四。诸有爱者。亦由段食为缘资益令招从有。以世尊说四食皆为病痈箭根老死缘故。亦见思食安住现身。世传有言。昔有一父。时遭饥馑。欲造他方。自既饥羸。二子婴稚。意欲携去力所不任。以囊盛灰挂于壁上。慰喻二子云是糗囊。二子希望多时延命。后有人至取囊为开。子见是灰望绝便死。又于大海有诸商人。遭难败船饮食俱失。遥瞻积沫疑为海岸。意望速至命得延时。至触知非望绝便死。集异门足说。大海中有大众生。登岸生卵埋于砂内还入海中。母若常思卵便不坏。如其失念卵即败亡。此不应然。违食义故。岂他思食能持自身。理实应言卵常思母得不烂坏。忘则命终。起念母思在于触位。诸有漏法皆滋长有。如何世尊说食唯四。虽尔就胜说四无失。谓初二食能益此身所依能依。后之二食能引当有能起当有。言所依者。谓有根身。段食于彼能为资益。言能依者。谓心心所。触食于彼能为资益。如是二食于已生有资益功能最为殊胜。言当有者。谓未来生。于彼当生思食能引。思食引已。从业所熏识种子力后有得起。如是二食于未生有引起功能最为殊胜。故虽有漏皆滋长有而就胜能唯说四食。前二如养母养已生故。后二如生母生未生故。诸所有段皆是食耶。有段非食应作四句。第一句者。谓所饮啖为缘损坏诸根大种。第二句者。谓余三食。第三句者。谓所饮啖为缘资益诸根大种。第四句者。除前诸相。如是触等随其所应一一当知。皆有四句。颇有触等为缘资益诸根大种而非食耶。有谓异地无漏触等。诸有食已捐食者身亦名为食。初资益故。毗婆沙说。食于二时能为食事。俱得名食。一初食时能除饥渴。二消化已资根及大。何趣何生各具几食。五趣四生皆具四食。如何地狱有段食耶。铁丸洋铜岂非段食。若能为害亦是食者。则与前说四句相违。又品类足言。云何为段食。谓能资益诸根大种。广说乃至识食亦尔。彼说且依能资益者说名为食故不相违。然地狱中热铁丸等虽于食已能为损害。而能暂时解除饥渴。得食相故亦名为食。又孤地狱段食如人。故五趣中皆有四食。世尊所说。有人能施一百外道离欲仙食。若能施一赡部林中异生者食。其果胜彼。何谓赡部林中异生。有作是释。所有一切住赡部洲诸有腹者。彼释非理。说一言故。又于此中有施无量异生者食。理胜以食施少外道离欲仙人。何足为奇挍量叹胜。有言。彼是近佛菩萨。理亦不然。施彼获福胜施俱胝阿罗汉故。毗婆沙者说。此异生是已获得顺决择分。此名与义亦不相应。曾无契经或本论说得顺决择分居赡部林中。当知彼唯自所分别。后身菩萨居赡部林名彼异生。此说应理。尔时菩萨同离欲仙故。对彼仙挍量叹胜。虽施菩萨福胜无边。乘前挍量且言胜百。理必应尔。由后世尊除彼异生还将外道对预流向挍量胜劣。若不尔者世尊则应将彼异生对预流向。已说有情缘起及住。如先所说寿尽死等。今应正办。何识现前何受相应有死生等。颂曰

  断善根与续　　离染退死生
  许唯意识中　　死生唯舍受
  非定无心二　　二无记涅槃
  渐死足齐心　　最后意识灭
  下人天不生　　断末摩水等

论曰。断善续善离界地染从离染退命终受生。于此六位法尔唯许意识非余。所说生言应知。亦摄初结中有。死生唯许舍受相应。舍相应心不明利故。余受明利不顺死生。又此二时唯散非定。要有心位必非无心。非在定心有死生义。界地别故。加行生故。能摄益故。亦非无心有死生义。以无心位命必无损。若所依身将欲变坏。必定还起属所依心。然后命终。更无余理。又无心者不能受生。以无因故。离起烦恼无受生故。虽说死有通三性心。然入涅槃唯二无记。若说欲界有舍异熟。彼说欲界入涅槃心亦具威仪异熟无记。若说欲界无舍异熟。彼说欲界入涅槃心但有威仪而无异熟。何故唯无记得入涅槃。无记势力微顺心断故。于命终位何身分中识最后灭。顿命终者意识身根欻然总灭。若渐死者往下人天。于足齐心如次识灭。谓堕恶趣说名往下。彼识最后于足处灭。若往人趣识灭于脐若往生天识灭心处。诸阿罗汉说名不生。彼最后心亦心处灭。有余师说。彼灭在顶。正命终时于足等处身根灭故。意识随灭。临命终时身根渐灭。至足等处欻然都灭。如以少水置炎石上。渐减渐消一处都尽。又渐命终者。临命终时多为断末摩苦受所逼。无有别物名为末摩。然于身中有异支节触便致死。是谓末摩。若水火风随一增盛。如利刀刃触彼末摩。因此便生增上苦受。从斯不久遂致命终。非如斩薪说名为断。如断无觉故得断名。地界何缘无斯断用。以无第四内灾患故。内三灾患。谓风热淡水火风增随所应起。有说。此似外器三灾。此断末摩天中非有。然诸天子将命终时。先有五种小衰相现。一者衣服严具出非爱声。二者自身光明忽然昧劣。三者于沐浴位水渧着身。四者本性嚣驰今滞一境。五者眼本凝寂今数瞬动。此五相现非定当死。复有五种大衰相现。一者衣染埃尘。二者花鬘萎悴。三者两腋汗出。四者臭气入身。五者不乐本座。此五相现必定当死。世尊于此有情世间生住没中建立三聚。何谓三聚。颂曰

  正邪不定聚　　圣造无间余

论曰。一正性定聚。二邪性定聚。三不定性聚。何名正性。谓契经言。贪无余断。嗔无余断。痴无余断。一切烦恼皆无余断。是名正性。定者谓圣。圣谓已有无漏道生。远诸恶法故名为圣。获得毕竟离系得故。定尽烦恼故名正定。诸已获得顺解脱分者。亦定得涅槃。何非正定。彼后或堕邪定聚故。又得涅槃时未定故。非如预流者极七返有等。又彼未能舍邪性故。不名正定。何名邪性。谓诸地狱傍生饿鬼。是名邪性。定谓无间。造无间者必堕地狱故名邪定。正邪定余名不定性。彼待二缘可成二故

说一切有部俱舍论卷第十阿毗达磨俱舍论卷第十一

        尊者世亲造

        三藏法师玄奘奉　诏译

    分别世品第三之四

如是已说有情世间。器世间今当说。颂曰

  安立器世间　　风轮最居下
  其量广无数　　厚十六洛叉
  次上水轮深　　十一亿二万
  下八洛叉水　　余凝结成金
  此水金轮广　　径十二洛叉
  三千四百半　　周围此三倍

论曰。许此三千大千世界如是安立形量不同。谓诸有情业增上力。先于最下依止虚空有风轮生广无数。厚十六亿踰缮那。如是风轮其体坚密。假设有一大诺健那。以金刚轮奋威悬击。金刚有碎风轮无损。又诸有情业增上力。起大云雨澍风轮上。滴如车轴积水成轮。如是水轮于未凝结位深十一亿二万踰缮那。如何水轮不傍流散。有余师说。一切有情业力所持令不流散。如所饮食未熟变时。终不流移堕于熟藏。有余部说。由风所持令不流散。如篅持谷。有情业力感别风起。搏击此水上结成金。如熟乳停上凝成膜。故水轮减唯厚八洛叉。余转成金。厚三亿二万。二轮广量其数是同。谓径十二亿三千四百半。周围其边数成三倍。谓周围量成三十六亿一万三百五十踰缮那。颂曰

  苏迷卢处中　　次踰健达罗
  伊沙驮罗山　　朅地洛迦山
  苏达梨舍那　　頞湿缚羯拏
  毗那怛迦山　　尼民达罗山
  于大洲等外　　有铁轮围山
  前七金所成　　苏迷卢四宝
  入水皆八万　　妙高出亦然
  余八半半下　　广皆等高量

论曰。于金轮上有九大山。妙高山王处中而住。余八周匝绕妙高山。于八山中前七名内。第七山外有大洲等。此外复有铁轮围山。周匝如轮围一世界。持双等七唯金所成。妙高山王四宝为体。谓如次四面北东南西金银吠琉璃颇胝迦宝。随宝威德色显于空。故赡部洲空似吠琉璃色。如是宝等从何而生。亦诸有情业增上力。复大云起雨金轮上滴如车轴。积水奔涛。其水即为众宝种藏。由具种种威德猛风钻击变生众宝类等。如是变水生宝等时。因灭果生。体不俱有。非如数论转变所成。数论云何执转变义。谓执有法自性常存有余法生有余法灭。如是转变何理相违。谓必无容有法常住可执别有法灭法生。谁言法外别有有法。唯即此法于转变时异相所依名为有法。此亦非理。非理者何。即是此物而不如此。如是言义曾所未闻。如是变生金宝等已。复由业力引起别风。简别宝等。摄令聚集成山成洲。分水甘碱令别成立内海外海。如是九山住金轮上。入水量皆等八万踰缮那。苏迷卢山出水亦尔。余八出水半半渐卑。谓初持双出水四万。乃至最后铁轮围山出水三百一十二半。如是九山一一广量。各各与自出水量同。颂曰

  山间有八海　　前七名为内
  最初广八万　　四边各三倍
  余六半半陜　　第八名为外
  三洛叉二万　　二千踰缮那

论曰。妙高为初轮围最后。中间八海。前七名内。七中皆具八功德水。一甘。二冷。三软。四轻。五清净。六不臭。七饮时不损喉。八饮已不伤腹。如是七海初广八万。约持双山内边周量。于其四面数各三倍。谓各成二亿四万踰缮那。其余六海量半半陜。谓第二海量广四万。乃至第七量广一千二百五十。此等不说周围量者。以烦多故。第八名外。碱水盈满。量广三亿二万二千。颂曰

  于中大洲相　　南赡部如车
  三边各二千　　南边有三半
  东毗提诃洲　　其相如半月
  三边如赡部　　东边三百半
  西瞿陀尼洲　　其相圆无缺
  径二千五百　　周围此三倍
  北俱卢畟方　　面各二千等
  中洲复有八　　四洲边各二

论曰。于外海中大洲有四。谓于四面对妙高山。南赡部洲北广南陜。三边量等。其相如车。南边唯广三踰缮那半。三边各有二千踰缮那。唯此洲中有金刚座。上穷地际下据金轮。一切菩萨将登正觉。皆坐此座上起金刚喻定。以无余依及余处所有坚固力能持此故。东胜身洲东陜西广。三边量等。形如半月。东三百五十。三边各二千。西牛货洲圆如满月。径二千五百。周围七千半。北俱卢洲形如方座。四边量等。面各二千。等言为明无少增减。随其洲相人面亦然。复有八中洲。是大洲眷属。谓四大洲侧各有二中洲。赡部洲边二中洲者。一遮末罗洲。二筏罗遮末罗洲。胜身洲边二中洲者。一提诃洲。二毗提诃洲。牛货洲边二中洲者。一舍搋洲。二嗢怛罗漫怛里拏洲。俱卢洲边二中洲者。一矩拉婆洲。二憍拉婆洲。此一切洲皆人所住。有说。唯一逻刹娑居。颂曰

  此北九黑山　　雪香醉山内
  无热池纵广　　五十踰缮那

论曰。此赡部洲从中向北。三处各有三重黑山。有大雪山。在黑山北。大雪山北有香醉山。雪北香南有大池水。名无热恼。出四大河。一殑伽河。二信度河。三徙多河。四缚刍河。无热恼池纵广正等。面各五十踰缮那量。八功德水盈满其中。非得通人无由能至。于此池侧有赡部林树形高大其果甘美。依此林故名赡部洲。或依此果以立洲号。复于何处置奈落迦大奈落迦。何量有几。颂曰

  此下过二万　　无间深广同
  上七奈落迦　　八增皆十六
  谓煻煨尸粪　　锋刃烈河增
  各住彼四方　　余八寒地狱

论曰。此赡部洲下过二万。有阿鼻旨大奈落迦。深广同前。谓各二万故。彼底去此四万踰缮那。以于其中受苦无间非如余七大奈落迦受苦非恒故名无间。且如等活奈落迦中。诸有情身虽被种种斫刺磨捣。而彼暂遇凉风所吹还活如本。由斯理故立等活名。阿鼻旨中无如是事。有余师说。阿鼻旨中无乐间苦。故名无间。余地狱中有乐间起。虽无异熟而有等流。七奈落迦在无间上重累而住。其七者何。一者极热。二者炎热。三者大叫。四者号叫。五者众合。六者黑绳。七者等活。有说。此七在无间傍。八奈落迦增各十六。故薄伽梵说此颂言

  此八奈落迦　　我说甚难越
  以热铁为地　　周匝有铁墙
  四面有四门　　关闭以铁扇
  巧安布分量　　各有十六增
  多百踰缮那　　满中造恶者
  周遍焰交彻　　猛火恒洞然

十六增者。八奈落迦四面门外各有四所。一煻煨增。谓此增内煻煨没膝。有情游彼才下足时。皮肉与血俱燋烂坠。举足还生平复如本。二尸粪增。谓此增内尸粪泥满。于中多有娘矩吒虫。[此/束]利如针身白头黑。有情游彼皆为此虫钻皮破骨[口*(一/巾)]食其髓。三锋刃增。谓此增内复有三种。一刀刃路。谓于此中仰布刀刃以为大道。有情游彼才下足时。皮肉与血俱断碎坠。举足还生平复如本。二剑叶林。谓此林上纯以铦利剑刃为叶。有情游彼风吹叶坠。斩刺肢体骨肉零落。有乌驳狗摣掣食之。三铁刺林。谓此林上有利铁刺。长十六指。有情被逼上下树时。其刺铦锋下上镵刺。有铁[此/束]鸟。探啄有情眼睛心肝争竞而食。刀刃路等三种虽殊而铁杖同故一增摄。四烈河增。谓此增量广满中热碱水。有情入中或浮或没。或逆或顺或横或转。被蒸被煮骨肉糜烂。如大镬中满盛灰汁置麻米等。猛火下燃。麻等于中上下回转举体糜烂。有情亦燃。设欲逃亡。于两岸上有诸狱卒。手执刀枪御捍令回。无由得出。此河如堑。前三似园。四面各四增故言皆十六。此是增上被刑害所。故说名增。本地狱中适被害已重遭害故。有说。有情从地狱出更遭此苦。故说为增。今于此中因论生论。诸地狱卒是有情不。有说。非情。如何动作。有情业力。如成劫风。若尔云何。通彼大德法善现说。如彼颂言

  心常怀忿毒　　好集诸恶业
  见他苦欣悦　　死作琰魔卒

琰魔王使诸逻刹娑。掷诸有情置地狱者名琰魔卒。是实有情。非地狱中害有情者。故地狱卒非实有情。有说有情。若尔此恶业何处受异熟。即地狱中。以地狱中尚容无间所感异熟。此何理遮。若尔何缘火不烧彼。此定由业力所隔碍故。或感异大种故不被烧。热奈落迦已说有八。复有余八寒奈落迦。其八者何。一頞部陀。二尼剌部陀。三頞唽吒。四臛臛婆。五虎虎婆。六嗢钵罗。七钵特摩。八摩诃钵特摩。此中有情严寒所逼随身声变以立其名。此八并居赡部洲下如前所说大地狱傍。此赡部洲其量无几。下宁容受无间等耶。洲如谷聚。上尖下阔。是故大海渐陜渐深。如上所论十六地狱一切有情增上业感。余孤地狱各别业招。或多或二或一所止。差别多种。处所不定。或近江河山边旷野。或在地下空及余处。诸地狱器安布如是。本处在下。支泒不定。傍生住处。谓水陆空。本处大海。后流余处。诸鬼本处琰魔王国。于此赡部洲下过五百踰缮那有琰魔王国。纵广量亦尔。从此展转散居余处。或有端严具大威德。受诸富乐自在如天。或有饥羸颜貌丑陋。如是等类广说如经。日月所居量等义者。颂曰

  日月迷卢半　　五十一五十
  夜半日没中　　日出四洲等
  雨际第二月　　后九夜渐增
  寒第四亦然　　夜减昼翻此
  昼夜增腊缚　　行南北路时
  近日自影覆　　故见月轮缺

论曰。日月众星依何而住。依风而住。谓诸有情业增上力共引风起。绕妙高山空中旋环。运持日等令不停坠。彼所住去此几踰缮那。持双山顶齐妙高山半。日月径量几踰缮那。日五十一。月唯五十。星最小者唯一俱卢舍。其最大者十六踰缮那。日轮下面颇胝迦宝火珠所成能热能照。月轮下面颇胝迦宝水珠所成能冷能照。随有情业增上所生。能于眼身果花稼穑药草等物。如其所应为益为损。唯一日月普于四洲作所作事。一日所作事为四洲同时不。不尔。云何。北洲夜半东洲日没。南洲日中西洲日出。此四时等。余例应知。日行此洲路有差别故令昼夜有减有增。从雨际第二月后半第九日夜渐增。从寒际第四月后半第九日夜渐减。昼增减位与此相违。夜渐增时昼便渐减。夜若渐减昼则渐增。昼夜增时一昼夜增几。增一腊缚。昼夜减亦然。日行此洲向南向北。如其次第夜增昼增。何故月轮于黑半末白半初位。见有缺耶。世施设中作如是释。以月宫殿行近日轮。月被日轮光所侵照。余边发影自覆月轮。令于尔时见不圆满。先旧师释。由日月轮行度不同现有圆缺。日等宫殿何有情居。四大天王所部天众。是诸天众唯住此耶。若空居天唯住如是日等宫殿。若地居天住妙高山诸层级等。有几层级。其量云何。何等诸天住何层级。颂曰

  妙高层有四　　相去各十千
  傍出十六千　　八四二千量
  坚手及持鬘　　恒憍大王众
  如次居四级　　亦住余七山

论曰。苏迷卢山有四层级。始从水际尽第一层。相去十千踰缮那量。如是乃至从第三层尽第四层亦十千量。此四层级从妙高山傍出围绕尽其下半。最初层级出十六千。第二第三第四层级。如其次第。八四二千。有药叉神名为坚手住初层级。有名持鬘住第二级。有名恒憍住第三级。此三皆是四大天王所部天众。第四层级四大天王及诸眷属共所居止故。经依此说四大王众天。如妙高山四外层级四大王众及眷属居。如是持双持轴山等七金山上亦有天居。是四大王所部封邑。是名依地住四大王众天。于欲天中此天最广。三十三天住在何处。颂曰

  妙高顶八万　　三十三天居
  四角有四峰　　金刚手所住
  中宫名善见　　周万踰缮那
  高一半金城　　杂饰地柔软
  中有殊胜殿　　周千踰缮那
  外四苑庄严　　众车粗杂喜
  妙池居四方　　相去各二十
  东北圆生树　　西南善法堂

论曰。三十三天住迷卢顶。其顶四面各八十千。与下四边其量无别。有余师说。周八十千别说四边各唯二万。山顶四角各有一峰。其高广量各有五百。有药叉神名金刚手。于中止住守护诸天。于山顶中有宫名善见。面二千半。周万踰缮那。金城量高一踰缮那半。其地平坦亦真金所成。俱用百一杂宝严饰。地触柔软如妒罗绵。于践蹑时随足高下。是天帝释所都大城。于其城中有殊胜殿。种种妙宝具足庄严。蔽余天宫故名殊胜。面二百五十。周千踰缮那。是谓城中诸可爱事。城外四面四苑庄严。是彼诸天共游戏处。一众车苑。二粗恶苑。三杂林苑。四喜林苑。此为外饰庄严大城。四苑四边有四妙池。中间各去苑二十踰缮那。是彼诸天胜游戏处。诸天于彼捔胜欢娱。城外东北有圆生树。是三十三天受欲乐胜所。盘根深广五十踰缮那。耸干上升枝条傍布。高广量等百踰缮那。挺叶开花妙香芬馥。顺风熏满百踰缮那。若逆风时犹遍五十。顺风可尔。云何逆熏。有余师言。香无逆熏义。依不越树界故说逆熏。理实圆生有如是德。所流香气能逆风熏。虽天和风力所拥遏。然能相续流趣余方。渐劣渐微近处便歇。非能远至如顺风熏。如是花香。为依自地随风相续转至余方。为但熏风别生香气。此义无定。诸轨范师于此二门俱许无失。若尔何故薄伽梵言

  花香不能逆风熏　　根茎等香亦复尔
  善士功德香芬馥　　逆风流美遍诸方

据人间香故作是说。以世共了无如是能。化地部经说。此香气顺风熏满百踰缮那。若无风时唯遍五十。外西南角有善法堂。三十三天时集于彼详论如法不如法事。如是已辩三十三天所居外器。余有色天众所住器云何。颂曰

  此上有色天　　住依空宫殿

论曰。此前所说三十三天上有色诸天。住依空宫殿。云何名上有色诸天。谓夜摩天。睹史多天。乐变化天。他化自在天。及前所说梵众天等有十六处。并前合有二十二天。皆依外器。如是所说诸天众中。颂曰

  六受欲交抱　　执手笑视淫

论曰。唯六欲天受妙欲境。于中初二依地居天。形交成淫与人无别。然风气泄热恼便除。非如人间有余不净。夜摩天众才抱成淫。睹史多天但由执手。乐变化天唯相向笑。他化自在相视成淫。毗婆沙师作如是释六天皆以形交成淫。世施设中说相抱等。但为显彼时量差别。以上诸天欲境转妙贪心转捷故使之然。随彼诸天男女膝上。有童男童女欻尔化生。即说为彼天所生男女。初生天众身量云何。颂曰

  初如五至十　　色圆满有衣

论曰。且六欲诸天初生如次如五六七八九十岁人。生已身形速得成满。色界天众于初生时身量周圆具妙衣服。一切天众皆作圣言。谓彼言词同中印度。欲乐生别云何应知。颂曰

  欲生三人天　　乐生三九处

论曰。欲生三者。有诸有情乐受现前诸妙欲境。彼于如是现欲境中自在而转。谓全人趣及下四天。有诸有情乐受自化诸妙欲境。彼于自化妙欲境中自在而转。谓唯第五乐变化天。有诸有情乐受他化诸妙欲境。彼于他化妙欲境中自在而转。谓第六他化自在天。依受如生现前欲境故。依受如乐自化欲境故。依受如乐他化欲境故。于欲界中分别欲生差别三种。乐生三者。三静虑中于九处生受三种乐。谓彼安住离生喜乐定生喜乐离喜乐故。长时安住。长时离苦。长时受乐。故名乐生。生静虑中间都无喜乐应思。何故亦号乐生天。所说诸天二十二处上下相去其量云何。颂曰

  如彼去下量　　去上数亦然

论曰。一一中间踰缮那量。非易可数。但可总举彼去下量。去上例然。随从何天去下海量。彼上所至与去下同。谓妙高山从第四层级。去下大海四万踰缮那。是四大王本所住处。从彼上去三十三天亦如彼天去下海量。如三十三天去下大海上去夜摩天其量亦尔。如是乃至如善见天去下大海踰缮那量从彼上去色究竟天亦与彼天去下海等。从此向上无复所居。此处最高名色究竟。有余师说。彼名碍究竟天。彼谓。碍名目积集色。至彼碍尽得究竟名。于下处生升见上不。颂曰

  离通力依他　　下无升见上

论曰。三十三天由自通力能从本处升夜摩天。或复依他。谓得通者及上天众接往夜摩。所余诸天升上例尔。若来若至下见上天。然下眼不能睹上界上地。非其境界故。如不觉彼触。是故从上地来下地时非自身来。要作下地化。有余部说。彼下地天随乐亦能见上地色。如生此界下见上天。夜摩等天宫依处量有几。有余师说。此上四天依处量同妙高山顶。有余师说。上倍倍增。有余师言。初静虑地宫殿依处等一四洲。第二静虑等小千界。第三静虑等中千界。第四静虑等大千界。有余师言。下三静虑如次量等小中大千。第四静虑量无边际。齐何量说小中大千。颂曰

  四大洲日月　　苏迷卢欲天
  梵世各一千　　名一小千界
  此小千千倍　　说名一中千
  此千倍大千　　皆同一成坏

论曰。千四大洲乃至梵世。如是总说为一小千。千倍小千名一中千界。千中千界总名一大千。如是大千同成同坏。同成坏相后当广辩。如外器量别。身量亦别耶。亦别。云何。颂曰

  赡部洲人量　　三肘半四肘
  东西北洲人　　倍倍增如次
  欲天俱卢舍　　四分一一增
  色天踰缮那　　初四增半半
  此上增倍倍　　唯无云减三

论曰。赡部洲人身多长三肘半。于中少分有长四肘。东胜身人身长八肘。西牛货人长十六肘。北俱卢人三十二肘。欲界六天最下身量一俱卢舍四分之一。如是后后一一分增。至第六天身一俱卢舍半。色天身量初梵众天半踰缮那。梵辅全一。大梵一半。少光二全。此上余天皆增倍倍。唯无云减三踰缮那。谓无量光天倍增二至四。乃至色究竟增满万六千。身量既殊。寿量别不。亦别。云何。颂曰

  北洲定千年　　西东半半减
  此洲寿不定　　后十初叵量
  人间五十年　　下天一昼夜
  乘斯寿五百　　上五倍倍增
  色无昼夜殊　　劫数等身量
  无色初二万　　后后二二增
  少光上下天　　大全半为劫

论曰。北俱卢人定寿千岁。西牛货人寿五百岁。东胜身人寿二百五十岁。南赡部人寿无定限。劫减最后极寿十年。于劫初时人寿无量。百千等数不能计量。已说人间寿量长短。要先建立天上昼夜。方可算计天寿短长。天上云何建立昼夜。人五十岁为六天中最在下天一昼一夜。乘斯昼夜三十为月十二月为岁。彼寿五百年。上五欲天渐俱增倍。谓人百岁为第二天一昼一夜。乘此昼夜成月及年彼寿千岁。夜摩等四随次如人。二四八百千六百岁为一昼夜。乘此昼夜成月及年。如次彼寿二四八千万六千岁。持双以上日月并无。彼天云何建立昼夜及光明事依何得成。依花开合建立昼夜。如拘物陀钵特摩等。又依诸鸟鸣静差别。或依天众寤寐不同。依自身光明成外光明事。已说欲界天寿短长。色界天中无昼夜别。但以劫数知寿短长。彼劫寿短长与身量数等。谓若身量半踰缮那。寿量半劫。若彼身量一踰缮那。寿量一劫。乃至身量长万六千。寿量亦同万六千劫。已说色界天寿短长。无色四天从下如次寿量二四六八万劫。上所说劫其量云何。为坏为成。为中为大。少光以上大全为劫。自下诸天大半为劫。即由此故说。大梵王过梵辅天寿一劫半。谓以成住坏各二十中劫六十中劫为一劫半。故以大半四十中劫。为下三天所寿劫量。已说善趣寿量短长。恶趣云何。颂曰

  等活等上六　　如次以欲天
  寿为一昼夜　　寿量亦同彼
  极热半中劫　　无间中劫全
  傍生极一中　　鬼月日五百
  頞部陀寿量　　如一婆诃麻
  百年除一尽　　后后倍二十

论曰。四大王等六欲天寿。如其次第为等活等六奈落迦一昼一夜。寿量如次亦同彼天。谓四大王寿量五百于等活地狱为一昼一夜。乘此昼夜成月及年以如是年彼寿五百。乃至他化寿万六千于炎热地狱为一昼一夜。乘此昼夜成月及年。彼寿如斯万六千岁。极热地狱寿半中劫。无间地狱寿一中劫。傍生寿量多无定限。若寿极长亦一中劫。谓难陀等诸大龙王。故世尊言。大龙有八。皆住一劫能持大地。鬼以人间一月为一日。乘此成月岁寿五百年。寒那落迦云何寿量。世尊寄喻显彼寿言。如此人间佉梨二十成摩揭陀国一麻婆诃量。有置巨胜平满其中。设复有能百年除一。如是巨胜易有尽期。生頞部陀寿量难尽。此二十倍为第二寿。如是后后二十倍增。是谓八寒地狱寿量。此诸寿量有中夭耶。颂曰

  诸处有中夭　　除北俱卢洲

论曰。诸处寿量皆有中夭。唯北俱卢定寿千岁。此约处说。非别有情。有别有情不中夭故。谓住睹史多天。一生所系菩萨。及最后有佛记佛使随信法行菩萨轮王母怀彼二胎时。此等如应皆无中夭

说一切有部俱舍论卷第十一阿毗达磨俱舍论卷第十二

        尊者世亲造

        三藏法师玄奘奉　诏译

    分别世品第三之五

如是已约踰缮那等。辩器世间身量差别。约年等辩寿量有殊。二量不同未说应说。此二建立无不依名。前二及名未详极少。今应先辩三极少量。颂曰

  极微字刹那　　色名时极少

论曰。分析诸色至一极微。故一极微为色极少。如是分析诸名及时至一字刹那。为名时极少。一字名者。如说瞿名。何等名为一刹那量。众缘和合法得自体顷。或有动法行度一极微。对法诸师说。如壮士一疾弹指顷六十五刹那。如是名为一刹那量。已知三极少。前二量云何。今且辩前踰缮那等。颂曰

  极微微金水　　兔羊牛隙尘
  蚁虱麦指节　　后后增七倍
  二十四指肘　　四肘为弓量
  五百俱卢舍　　此八踰缮那

论曰。极微为初。指节为后。应知后后皆七倍增。谓七极微为一微量。积微至七为一金尘。积七金尘为水尘量。水尘积至七为一兔毛尘。积七兔毛尘为羊毛尘量。积羊毛尘七为一牛毛尘。积七牛毛尘为隙游尘量。隙尘七为虮。七虮为一虱。七虱为穬麦。七麦为指节。三节为一指。世所极成。是故于颂中不别分别。二十四指横布为肘。竖积四肘为弓。谓寻。竖积五百弓为一俱卢舍。一俱卢舍许是从村至阿练若中间道量。说八俱卢舍为一踰缮那。如是已说踰缮那等。今当辩后年等量别。颂曰

  百二十刹那　　为怛刹那量
  腊缚此六十　　此三十须臾
  此三十昼夜　　三十昼夜月
  十二月为年　　于中半减夜

论曰。刹那百二十为一怛刹那。六十怛刹那为一腊缚。三十腊缚为一牟呼栗多。三十牟呼栗多为一昼夜。此昼夜有时增有时减有时等。三十昼夜为一月。总十二月为一年。于一年中分为三际。谓寒热雨各有四月。十二月中六月减夜。以一年内夜总减六。云何如是。故有颂言

  寒热雨际中　　一月半已度
  于所余半月　　智者知夜减

如是已辩刹那至年。劫量不同今次当辩。颂曰

  应知有四劫　　谓坏成中大
  坏从狱不生　　至外器都尽
  成劫从风起　　至地狱初生
  中劫从无量　　减至寿唯十
  次增减十八　　后增至八万
  如是成已住　　名中二十劫
  成坏坏已空　　时皆等住劫
  八十中大劫　　大劫三无数

论曰。言坏劫者。谓从地狱有情不复生至外器都尽。坏有二种。一趣坏。二界坏。复有二种。一有情坏。二外器坏。谓此世间过于二十中劫住已。从此复有等住二十坏劫便至。若时地狱有情命终无复新生。为坏劫始。乃至地狱无一有情。尔时名为地狱已坏。诸有地狱定受业者。业力引置他方狱中。由此准知傍生鬼趣。然各先坏本处住者。人天杂居者与人天同坏。若时人趣此洲一人无师法然得初静虑。从静虑起唱如是言。离生喜乐甚乐甚静。余人闻已皆入静虑。命终并得生梵世中。乃至此洲有情都尽。是名已坏赡部洲人。东西二洲例此应说。北洲命尽生欲界天。由彼无能入定离欲。乃至人趣无一有情。尔时名为人趣已坏。若时天趣四大王天随一法然得初静虑。乃至并得生梵世中。尔时彼天有情都尽。是名已坏大王众天。余五欲天例同此说。乃至欲界无一有情。名欲界中有情已坏。若时梵世随一有情无师法然得二静虑。从彼定起唱如是言。定生喜乐甚乐甚静。余天闻已皆入彼静虑。命终并得生极光净天。乃至梵世中有情都尽。如是名已坏有情世间。唯器世间空旷而住。余十方界一切有情感此三千世界业尽。于此渐有七日轮现。诸海干竭众山洞然。洲渚三轮并从焚燎。风吹猛焰烧上天宫。乃至梵宫无遗灰烬。自地火焰烧自地宫。非他地灾能坏他地。由相引起故作是言。下火风飘梵烧上地。谓欲界火猛焰上升为缘引生色界火焰。余灾亦尔。如应当知。如是始从地狱渐减乃至器尽总名坏劫。所言成劫。谓从风起乃至地狱始有情生。谓此世间灾所坏已。二十中劫唯有虚空。过此长时次应复有等住二十成劫便至。一切有情业增上力。空中渐有微细风生。是器世间将成前相。风渐增盛成立如前所说风轮水金轮等。然初成立大梵王宫乃至夜摩宫。后起风轮等。是谓成立外器世间。初一有情极光净殁生大梵处为大梵王。后诸有情亦从彼殁有生梵辅。有生梵众。有生他化自在天宫。渐渐下生乃至人趣俱卢牛货胜身赡部。后生饿鬼傍生地狱。法尔后坏必最初成。若初一有情生无间狱二十中成劫应知已满。此后复有二十中劫名成已住。次第而起。谓从风起造器世间。乃至后时有情渐住。此洲人寿经无量时至住劫初寿方渐减。从无量减至极十年即名为初一住中劫。此后十八皆有增减。谓从十年增至八万。复从八万减至十年。尔乃名为第二中劫次后十七例皆如是。于十八后从十岁增极至八万岁名第二十劫。一切劫增无过八万。一切劫减唯极十年。十八劫中一增一减时。量方等初减后增故。二十劫时量皆等。此总名为成已住劫。所余成坏及坏已空并无减增二十差别。然由时量与住劫同。准住各成二十中劫。成中初劫起器世间。后十九中有情渐住。坏中后劫减器世间。前十九中有情渐舍。如是所说成住坏空。各二十中积成八十。总此八十成大劫量。劫性是何。谓唯五蕴。经说三劫阿僧企耶精进修行方得成佛。于前所说四种劫中。积何劫成三劫无数。累前大劫为十百千。乃至积成三劫无数。既称无数何复言三。非无数言显不可数。解脱经说六十数中。阿僧企耶是其一数。云何六十。如彼经言。有一无余数始为一。一十为十。十十为百。十百为千。十千为万。十万为洛叉。十洛叉为度洛叉。十度洛叉为俱胝。十俱胝为末陀。十末陀为阿庾多。十阿庾多为大阿庾多。十大阿庾多为那庾多。十那庾多为大那庾多。十大那庾多为钵罗庾多。十钵罗庾多为大钵罗庾多。十大钵罗庾多为矜羯罗。十矜羯罗为大矜羯罗。十大矜羯罗为频跋罗。十频跋罗为大频跋罗。十大频跋罗为阿刍婆。十阿刍婆为大阿刍婆。十大阿刍婆为毗婆诃。十毗婆诃为大毗婆诃。十大毗婆诃为嗢蹭伽。十嗢蹭伽为大嗢蹭伽。十大嗢蹭伽为婆喝那。十婆喝那为大婆喝那。十大婆喝那为地致婆。十地致婆为大地致婆。十大地致婆为醯都。十醯都为大醯都。十大醯都为羯腊婆。十羯腊婆为大羯腊婆。十大羯腊婆为印达罗。十印达罗为大印达罗。十大印达罗为三磨钵耽。十三磨钵耽为大三磨钵耽。十大三磨钵耽为揭底。十揭底为大揭底。十大揭底为拈筏罗阇。十拈筏罗阇为大拈筏罗阇。十大拈筏罗阇为姥达罗。十姥达罗为大姥达罗。十大姥达罗为跋蓝。十跋蓝为大跋蓝。十大跋蓝为珊若。十珊若为大珊若。十大珊若为毗步多。十毗步多为大毗步多。十大毗步多为跋逻搀。十跋逻搀为大跋逻搀十大跋逻搀为阿僧企耶。于此数中忘失余八。若数大劫至此数中阿僧企耶名劫无数。此劫无数复积至三。经中说为三劫无数。非诸算计不能数知。故得说为三劫无数。何缘菩萨发愿长时精进修行方期佛果。如何不许愿长时修。无上菩提甚难可得。非多愿行无容得成。菩萨要经三劫无数。修大福德智慧资粮六波罗蜜多多百千苦行方证无上正等菩提。是故定应发长时愿。若余方便亦得涅槃。何用为菩提久修多苦行。为欲利乐一切有情故求菩提发长时愿。云何令我具大堪能。于苦瀑流济诸含识。故舍涅槃道求无上菩提。济他有情于己何益。菩萨济物遂己悲心。故以济他即为己益。谁信菩萨有如是事。有怀润己无大慈悲。于如是有情此事实难信。无心润己有大慈悲。于如是有情此事非难信。如有久习无哀愍者。虽无益己而乐损他。世所同悉如是。菩萨久习慈悲。虽无利己而乐他益。如何不信。又如有情由数习力于无我行不了有为。执以为我而生爱着。由此为因甘负众苦。智者同悉如是。菩萨数习力故。舍自我爱增恋他心。由此为因甘负众苦。如何不信。又由种姓异有此志愿起。以他苦为己苦。用他乐为己乐。不以自苦乐为己苦乐事。不见异益他而别有自益。依如是义故。有颂言

  下士勤方便　　恒求自身乐
  中士求灭苦　　非乐苦依故
  上士恒勤求　　自苦他安乐
  及他苦永灭　　以他为己故

如是已辩劫量差别。诸佛独觉出现世间。为劫增时为劫减位。颂曰

  减八万至百　　诸佛现世间
  独觉增减时　　麟角喻百劫

论曰。从此洲人寿八万岁。渐减乃至寿极百年。于此中间诸佛出现。何缘增位无佛出耶。有情乐增难教厌故。何缘减百无佛出耶。五浊极增难可化故。言五浊者。一寿浊。二劫浊。三烦恼浊。四见浊。五有情浊。劫减将末。寿等鄙下如滓秽故。说名为浊。由前二浊。如其次第。寿命资具极被衰损。由次二浊。善品衰损。以耽欲乐自苦行故。或损在家出家善故。由后一浊衰损自身。谓坏自身身量色力念智勤勇及无病故。独觉出现通劫增减。然诸独觉有二种殊。一者部行。二麟角喻。部行独觉先是声闻得胜果时转名独胜。有余说。彼先是异生。曾修声闻顺决择分。今自证道得独胜名。由本事中说。一山处总有五百苦行外仙。有一猕猴曾与独觉相近而住。见彼威仪。展转游行至外仙所。现先所见独觉威仪。诸仙睹之咸生敬慕。须臾皆证独觉菩提。若先是圣人不应修苦行。麟角喻者。谓必独居。二独觉中麟角喻者。要百大劫修菩提资粮。然后方成麟角喻独觉。言独觉者。谓现身中离禀至教唯自悟道。以能自调不调他故。何缘独觉言不调他。非彼无能演说正法。以彼亦得无碍解故。又能忆念过去所闻诸佛所宣圣教理故。又不可说彼无慈悲。为摄有情现神通故。又不可说无受法机。尔时有情亦有能起世间离欲对治道故。虽有此理。由彼宿习少欣乐胜解无说希望故。又知有情难受深法。以顺流既久难令逆流故。又避摄众故。不为他宣说正法。怖諠杂故。轮王出世为在何时。几种几俱何威何相。颂曰

  轮王八万上　　金银铜铁轮
  一二三四洲　　逆次独如佛
  他迎自往伏　　诤阵胜无害
  相不正圆明　　故与佛非等

论曰。从此洲人寿无量岁。乃至八万岁有转轮王生。减八万时。有情富乐寿量损减。众恶渐盛。非大人器故无轮王。此王由轮旋转应导威伏一切名转轮王。施设足中说有四种。金银铜铁轮应别故。如其次第胜上中下。逆次能王领一二三四洲。谓铁轮王王一洲界。铜轮王二。银轮王三。若金轮王王四洲界。契经就胜但说金轮。故契经言。若王生在刹帝利种绍洒顶位。于十五日受斋戒时。沐浴首身受胜斋戒。升高台殿臣僚辅翼。东方忽有金轮宝现。其轮千辐具足毂辋。众相圆净如巧匠成。舒妙光明来应王所。此王定是转金轮王。转余轮王应知亦尔。轮王如佛无二俱生。故契经言。无处无位非前非后有二如来应正等觉出现于世。有处有位唯一如来。如说如来轮王亦尔。应审思择。此唯一言为据一三千。为约一切界。有说。余界定无佛生。所以者何。勿薄伽梵功能有碍。唯一世尊普于十方能教化故。若有一处一佛于中无教化能。余亦应尔。又世尊告舍利子言。设复有人来至汝所。问言颇有梵志沙门。正于今时与乔答摩氏平等平等得无上觉耶。汝得彼问当云何答。时舍利子白世尊言。我得彼问当如是答。今时无有梵志沙门得无上菩提与我世尊等。所以然者。我从世尊亲闻亲持。无处无位非前非后有二如来应正等觉出现于世。有处有位唯一如来。若尔何缘梵王经说我今于此三千大千诸世界中得自在转。彼有密意。密意者何。谓若世尊不起加行。唯能观此三千大千。若时世尊发起加行。无边世界皆佛眼境。天耳通等例此应知。有余部师说。余世界亦别有佛出现世间。所以者何。有多菩萨。现俱修习菩提资粮。一界一时可无多佛。多界多佛何理能遮。故无边界中有无边佛现。若唯一佛设住一劫时。尚不遍为一世界佛事。况同人寿能益无边。然诸有情居无边界。时处根性差别无边。佛应遍观此有情类。如是时处应见世尊。佛便应机现通说法。令其过失未生不生。诸有已生能令断灭。令其功德未生得生。诸有已生能令圆满。如何一佛此事顿成。是故同时定有多佛。然彼所引无处无位非前非后。有二如来出于世等。应共思择。此言为说一界多界。若说多界则转轮王余世界中亦应非有。以说如佛遮俱生故。若许轮王余界别有如何不许别界佛耶。佛出世间具吉祥福。多界多佛何过而遮。谓多界中诸佛俱现。便能饶益无量有情令得增上生及决定胜道。若尔何故一世界中无二如来俱时出现。以无用故。谓一界中一佛足能饶益一切。又愿力故。谓诸如来为菩萨时先发誓愿。愿我当在无救无依盲闇界中成等正觉。利益安乐一切有情。为救为依为眼为导。又令敬重故。谓一界中唯有一如来便深敬重。又令速行故。谓令如是知一切智尊甚为难遇。彼所立教应速修行勿般涅槃。或往余处。便令我等无救无依。故一界中无二佛现。如是所说四种轮王威定诸方亦有差别。谓金轮者诸小国王各自来迎作如是请。我等国土宽广丰饶。安隐富乐多诸人众。唯愿天尊亲垂教敕。我等皆是天尊翼从。若银轮王自往彼土。威严近至彼方臣伏。若铜轮王至彼国已。宣威竞德彼方推胜。若铁轮王亦至彼国。现威列阵克胜便止。一切轮王皆无伤害。令伏得胜已各安其所居。劝化令修十善业道。故轮王死定得生天。经说轮王出现于世便有七宝出现世间。其七者何。一者轮宝。二者象宝。三者马宝。四者珠宝。五者女宝。六者主藏臣宝。七者主兵臣宝。象等五宝有情数摄。如何他业生他有情。非他有情从他业起。然由先造互相属业。于中若一禀自业生。余亦俱时乘自业起。如是所说诸转轮王。非唯有七宝与余王别。亦有三十二大士相殊。若尔轮王与佛何异。佛大士相处正明圆。王相不然故有差别。劫初人众为有王无。颂曰

  劫初如色天　　后渐增贪味
  由堕贮贼起　　为防雇守田

论曰。劫初时人皆如色界。故契经说。劫初时人有色意成。肢体圆满诸根无缺。形色端严身带光明。腾空自在饮食喜乐长寿久住。有如是类地味渐生。其味甘美其香郁馥。时有一人禀性耽味。嗅香起爱取尝便食。余人随学竞取食之。尔时方名初受段食。资段食故身渐坚重。光明隐没黑闇便生。日月众星从兹出现。由渐耽味地味便隐。从斯复有地皮饼生。竞耽食之。地饼复隐。尔时复有林藤出现。竞耽食故林藤复隐。有非耕种香稻自生。众共取之以充所食。此食粗故残秽在身为欲蠲除便生二道。因斯遂有男女根生。由二根殊形相亦异。宿习力故便相瞻视。因此遂生非理作意。欲贪鬼魅惑乱身心。失意猖狂行非梵行。人中欲鬼初发此时。尔时诸人随食早晚随取香稻无所贮积。后时有人禀性懒惰。长取香稻贮拟后食。余人随学渐多停贮。由此于稻生我所心。各纵贪情多收无厌。故随收处无复再生。遂共分田虑防远尽。于己田分生吝护心。于他分田有怀侵夺。劫盗过起始于此时。为欲遮防共聚详议。铨量众内一有德人。各以所收六分之一。雇令防护封为田主。因斯故立刹帝利名。大众钦承恩流率土。故复名大三末多王。自后诸王此王为首。时人或有情厌居家。乐在空闲精修戒行。因斯故得婆罗门名。后时有王贪吝财物。不能均给国土人民。故贫匮人多行贼事。王为禁止行轻重罚。为杀害业始于此时。时有罪人心怖刑罚。覆藏其过异想发言。虚诳语生此时为首。于劫减位有小三灾。其相云何。颂曰

  业道增寿减　　至十三灾现
  刀疾饥如次　　七日月年止

论曰。从诸有情起虚诳语。诸恶业道后后转增。故此洲人寿量渐减。乃至极十小三灾现。故诸灾患二法为本。一耽美食。二性懒惰。此小三灾中劫末起。三灾者。一刀兵二疾疫。三饥馑。谓中劫末十岁时。人为非法贪染污相续。不平等爱映蔽其心。邪法萦缠嗔毒增上。相见便起猛利害心。如今猎师见野禽兽。随手所执皆成利刀。各逞凶狂互相残害。又中劫末十岁时人。由具如前诸过失故。非人吐毒疾疫流行。遇辄命终难可救疗。又中劫末十岁时人。亦具如前诸过失故。天龙忿责不降甘雨。由是世间久遭饥馑。既无支济多分命终。是故说言。由饥馑故便有聚集白骨运筹。由二种因名有聚集。一人聚集。谓彼时人由极饥羸聚集而死。二种聚集。谓彼时人为益后人辍其所食置于小箧拟为种子。故饥馑时名有聚集。言有白骨亦由二因。一彼时人身形枯燥命终未久白骨便现。二彼时人饥馑所逼聚集白骨煎汁饮之。有运筹言亦二因故。一由粮少行筹食之。谓一家中从长至幼随筹至日得少粗餐。二谓以筹挑故场蕴。得少谷粒多用水煎。分共饮之以济余命。然有至教说治彼方。谓若有能一昼一夜持不杀戒。于未来生决定不逢刀兵灾起。若能以一诃梨怛鸡。起殷净心奉施僧众。于当来世决定不逢疾疫灾起。若有能以一抟之食起殷净心奉施僧众。于当来世决定不逢饥馑灾起。此三灾起各经几时。刀兵灾起极唯七日。疾疫灾起七月七日。饥馑七年七月七日。度此便止。人寿渐增。东西二洲有似灾起。谓嗔增盛身力羸劣。数加饥渴。北洲总无。前说火灾梵烧世界。余灾亦尔。如应当知。何者为余。今当具辩。颂曰

  三灾火水风　　上三定为顶
  如次内灾等　　四无不动故
  然彼器非常　　情俱生灭故
  要七火一水　　七水火后风

论曰。此大三灾逼有情类。令舍下地集上天中。初火灾兴由七日现。次水灾起由雨霖淫。后风灾生由风相击。此三灾力坏器世间。乃至极微亦无余在。一类外道执极微常。彼谓。尔时余极微在。何缘彼执犹有余极微。勿后粗事生无种子故。岂不前说。由诸有情业所生风能为种子。或此即以前灾顶风为缘。引生风为种子。又化地部契经中言。风从他方飘种来此。虽尔不许芽等生时是种等因亲所引起。若尔芽等从何而生。从自分生。如是自分复从自分。展转乃至最细有分从极微生。于芽等生中种等有何力。除能引集芽等极微种等更无生芽等力。何缘定作如是执耶。从异类生定不应理。不应何理。应无定故。功能定故无不定失。如声熟变等从异类定生。德法有殊。实法不尔。现见实法唯从同类生。如藤生枝及缕生衣等。此非应理。非理者何。引不极成为能立故。今此所引何不极成。非许藤枝缕衣别故。即藤缕合安布不同得枝衣名。如蚁行等。云何知尔。一缕合中曾不得衣。唯得缕故。有谁为障令不得衣。若一缕中无全衣转。则应一缕上有衣分无衣。应许全衣唯集诸分。非更别有有分名衣。又如何知衣分异缕。若谓衣要待多所依合。于唯多经合应亦得衣。或应毕竟无得衣理。中及余边不对根故。若谓渐次皆可对根。则应眼身唯得诸分。不应说彼得有分衣故。即于诸分渐次了别。总起有分觉。如旋火轮。谓若离缕异色类业衣色等三不可得故。若锦衣上色等属衣。则应许实从异类起。一一缕色等无种种异故。或于一分无异色等边应不见衣。由彼显衣故。或即彼分应见异色等。以衣必有异色等相故。彼许有分体唯是一而有种种色类业殊。审有如斯甚为灵异。又于一火光明界中。远近不同烧照有异。触色差别应不得成。各别极微虽越根境而共聚集可现根证。如彼所宗合能生果。或如眼等合能发识。又如翳目视散发时。若多相邻彼则能见。一一远住便无见能。极微对根理亦应尔。又即于色等立极微名故。色等坏时极微亦坏。极微实摄。色等德收。异体不应定俱时灭。此二体别理必不然。以审观时非离色等有别地等。故非体别。又彼宗中自许地等眼身所取宁异色触。又烧毛[疊*毛]红花等时。彼觉则无故。毛等觉但缘色等差别而起。熟变生时形量等故。犹如行伍记识瓶盆。若不观形不记识故。谁当采录愚类狂言。故对彼宗广诤应止。此三灾顶为在何处。第二静虑为火灾顶。此下为火所焚烧故。第三静虑为水灾顶。此下为水所浸烂故。第四静虑为风灾顶。此下为风所飘散故。随何灾上名彼灾顶。何缘下三定遭火水风灾。初二三定中内灾等彼故。谓初静虑寻伺为内灾。能烧恼心等外火灾故。第二静虑喜受为内灾。与轻安俱润身如水故。遍身粗重由此皆除故。经说苦根第二静虑灭。第三静虑动息为内灾。息亦是风。等外风炎故。若入此静虑有如是内灾。生此静虑时遭是外灾坏。何缘不立地亦为灾。以器世间即是地故。但可火等与地相违。不可说言地还违地。第四静虑何为外灾。彼无外灾。离内灾故。由此佛说彼名不动。内外三灾所不及故。有说。彼地有净居天故。彼不遭诸灾所坏。由彼不可生无色天。亦复不应更往余处。若尔彼地器应是常。不尔。与有情俱生俱灭故。谓彼天处无总地形。但如众星居处各别。有情于彼生时死时。所住天宫随起随灭。是故彼器体亦非常。所说三灾云何次第。要先无间起七火灾。其次定应一水灾起。此后无间复七火灾。度七火灾。还有一水。如是乃至满七水灾。复七火灾。后风灾起。如是总有八七火灾一七水灾一风灾起。何缘如是。由彼有情所修定因于上渐胜故。感身寿其量渐长。由是所居亦渐久住。由此善释施设足文遍净天寿六十四劫

说一切有部俱舍论卷第十二阿毗达磨俱舍论卷第十三

        尊者世亲造

        三藏法师玄奘奉　诏译

    分别业品第四之一

如前所说有情世间及器世间各多差别。如是差别由谁而生。颂曰

  世别由业生　　思及思所作
  思即是意业　　所作谓身语

论曰。非由一主先觉而生。但由有情业差别起。若尔何故。俱从业生郁金栴檀等甚可爱乐。而内身形等与彼相违。以诸有情业类如是。若造杂业感内身形。于九疮门常流不净。为对治彼感外具生色香味触甚可爱乐。诸天众等造纯净业故彼所招二事俱妙。此所由业其体是何。谓心所思及思所作。故契经说。有二种业。一者思业。二思已业。思已业者谓思所作。如是二业分别为三。谓即有情身语意业。如何建立此三业耶。为约所依。为据自性。为就等起。纵尔何违。若约所依应唯一业。以一切业并依身故。若据自性应唯语是业。以三种中唯语即业故。若就等起亦应唯一业。以一切业皆意等起故。毗婆沙师说。立三业如其次第由上三因。然心所思即是意业。思所作业分为身语二业。是思所等起故。身语二业自性云何。颂曰

  此身语二业　　俱表无表性

论曰。应知如是所说诸业中。身语二业俱表无表性。且身语表其相云何。颂曰

  身表许别形　　非行动为体
  以诸有为法　　有刹那尽故
  应无无因故　　生因应能灭
  形亦非实有　　应二根取故
  无别极微故　　语表许言声

论曰。由思力故。别起如是如是身形名身表业。有余部说。动名身表。以身动时由业动故。为破此故。说非行动。以一切有为皆有刹那故刹那何。谓得体无间灭。有此刹那法名有刹那。如有杖人名为有杖。诸有为法才得自体。从此无间必灭归无。若此处生即此处灭。无容从此转至余方。故不可言动名身表。若有为法皆有刹那。不至余方义可成立。诸有为法皆有刹那。其理极成。后必尽故。谓有为法灭不待因。所以者何。待因谓果。灭无非果故不待因灭既不待因。才生已即灭。若初不灭后亦应然。以后与初有性等故。既后有尽知前有灭若后有异方可灭者。不应即此而名有异。即此相异。理必不然。岂不世间现见薪等由与火合故致灭无。定无余量过现量者。故非法灭皆不待因。如何知薪等由火合故灭。以薪等火合后便不见故。应共审思。如是薪等为由火合灭故不见。为前薪等生已自灭后不更生无故不见。如风手合灯焰铃声。故此义成应由比量。何谓比量。谓如前说。灭无非果故不待因。又若待因薪等方灭。应一切灭无不待因。如生待因无无因者。然世现见觉焰音声。不待余因刹那自灭。故薪等灭亦不待因。有执觉声前因后灭。彼亦非理。二不俱故。疑智苦乐及贪嗔等自相相违理无俱义。若复有位明了觉声无间便生不明了者。如何同类不明了法能灭明了同类法耶。最后觉声复由谁灭。有执。灯焰灭以住无为因。有执。焰灭时由法非法力。彼俱非理。无非因故。非法非法为生灭因。以刹那刹那顺违相反故。或于一切有为法中。皆可计度有此因义。既尔本诤便应止息。许不待余因皆有刹那故。又若薪等灭火合为因。于熟变生中有下中上。应生因体即成灭因。所以者何。谓由火合能令薪等有熟变生。中上熟生下中熟灭。或即或似生上中因即能为因灭下中熟则生因体应即灭因。或灭生因应相无别。不应由即此或似此彼有。彼复由即此或似此非有。设于火焰差别生中容计能生能灭因异。于灰雪酢日水地合。能令薪等熟变生中。如何计度生灭因异。若尔现见煎水减尽。火合于中为何所作。由事火合火界力增。由火界增能令水聚于后后位生渐渐微。乃至最微后便不续。是名火合于中所作。故无有因令诸法灭。法自然灭。是坏性故。自然灭故。才生即灭。由才生即灭。刹那灭义成。有刹那故定无行动。然于无间异方生中如烧草焰行起行增上慢。既由斯理行动定无。身表是形理得成立。然经部说。形非实有。谓显色聚一面多生。即于其中假立长色。待此长色于余色聚一面少中假立短色。于四方面并多生中假立方色。于一切处遍满生中假立圆色。所余形色随应当知如见火[火*曹]。于一方面无间速运。便谓为长。见彼周旋谓为圆色。故形无实别类色体。若谓实有别类形色。则应一色二根所取。谓于色聚长等差别。眼见身触俱能了知。由此应成二根取过。理无色处二根所取。然如依触取长等相。如是依显能取于形。岂不触形俱行一聚。故因取触能忆念形。非于触中亲取形色。如见火色便忆火暖。及嗅花香能念花色。此中二法定不相离故因取一可得念余。无触与形定不相离。如何取触能定忆形。若触与形非定同聚。然由取触能忆念形。显色亦应因触定忆。或应形色如显无定。则取触位。应不了形。而实不然。故不应说因取于触能忆念形。或锦等中见多形故。便应一处有多实形。理不应然。如众显色。是故形色非实有体。又诸所有有对实色。必应有实别类极微。然无极微名为长等。故即多物如是安布差别相中假立长等。若谓即以形色极微如是安布名为长等。此唯朋党。非极成故。谓若形色有别极微自相极成。可得聚集如是安布以为长等。非诸形色有别极微自相极成犹如显色。云何得有聚集安布。岂不现见诸土器等有显相同而形相异。为不已辩。即于多物安布差别。假立长等。如众蚁等有相不殊。然有行轮安布形别。形依显等理亦应然。岂不闇中或于远处观杌等物了形非显。宁即显等安布为形。以闇远中观显不了。是故但起长等分别。如于远闇观众树人。但了行军不知别相。理必应尔。以或有时不了显形唯知总聚。既已遮遣行动及形。汝等经部宗立何为身表。立形为身表。但假而非实。既执但用假为身表。复立何法为身业耶。若业依身立为身业。谓能种种运动身思。依身门行故名身业。语业意业随其所应立差别名当知亦尔。若尔何故契经中说有二种业。一者思业。二思已业。此二何异。谓前加行起思惟思。我当应为如是如是所应作事名为思业。既思惟已起作事思。随前所思作所作事。动身发语名思已业。若尔表业则为定无。表业既无。欲无表业亦应非有。便成大过。如是大过有理能遮。谓从如前所说二表殊胜思故。起思差别名为无表。此有何过。此应名为随心转业。如定无表心俱转故。无如是过。审决胜思动发胜思所引生故。设许有表。亦待如前所说思力。以性钝故。毗婆沙师说。形是实故。身表业形色为体。语表业体谓即言声。无表业相如前已说。经部亦说。此非实有。由先誓限唯不作故。彼亦依过去大种施设。然过去大种体非有故。又诸无表无色相故。毗婆沙说。此亦实有。云何知然。颂曰

  说三无漏色　　增非作等故

论曰。以契经说色有三种。此三为处摄一切色。一者有色有见有对。二者有色无见有对。三者有色无见无对。又契经中说有无漏色。如契经说。无漏法云何。谓于过去未来现在诸所有色不起爱恚。乃至识亦然。是名无漏法除无表色。何法名为无见无对及无漏色。又契经说有福增长。如契经言。诸有净信。若善男子或善女人成就有依七福业事。若行若住若寐若觉。恒时相续福业渐增福业续起。无依亦尔。除无表业。若起余心或无心时。依何法说福业增长。又非自作。但遣他为。若无无表业不应成业道。以遣他表非彼业道摄。此业未能正作所作故。使作所作已。此性无异故。又契经说。苾刍当知。法谓外处。是十一处所不摄法无见无对。不言无色。若不观于法处所摄无表色者。此言阙减便成无用。又若无无表应无八道支。以在定时语等无故。若尔何故契经中言。彼如是知彼如是见。修习正见正思惟正精进正念正定皆至圆满。正语业命先时已得清净鲜白。此依先时已得世间离染道说。无相违过。又若拨无无表色者。则亦应无有别解脱律仪。非受戒后有戒相续虽起异缘心而名苾刍等。又契经说。离杀等戒名为堤塘戒。能长时相续堰遏犯戒过故。非无有体可名堤塘。由此等证知实有无表色。经部师说。此证虽多种种希奇。然不应理。所以然者。所引证中且初经言有三色者。瑜伽师说。修静虑时定力所生定境界色。非眼根境故名无见。不障处所故名无对。若谓既尔如何名色。释如是难与无表同。又经所言无漏色者。瑜伽师说。即由定力所生色中依无漏定者即说为无漏。有余师言。无学身色及诸外色皆是无漏。非漏依故得无漏名。何故经言有漏法者诸所有眼乃至广说。此非漏对治故得有漏名。是则此应言有漏亦无漏。若尔何过。有相杂失。若依此理说为有漏。曾不依此说为无漏。无漏亦然。有何相杂。若色处等一向有漏。此经何缘差别而说。如说有漏有取诸色心栽覆事。声等亦尔。又经所说福增长言。先轨范师作如是释。由法尔力福业增长。如如施主所施财物。如是如是受者受用。由诸受者受用施物功德摄益有差别故。于后施主心虽异缘而前缘施思所熏习。微细相续渐渐转变差别而生。由此当来能感多果。故密意说恒时相续福业渐增福业续起。若谓如何由余相续德益差别令余相续心虽异缘而有转变。释此疑难与无表同。彼复如何由余相续德益差别。令余相续别有真实无表法生。若于无依诸福业事如何相续福业增长。亦由数习缘彼思故。乃至梦中亦恒随转。无表论者。于无依福既无表业。宁有无表。有说。有依诸福业事。亦由数习缘彼境思故说恒时相续增长。若尔经说。诸有苾刍具净尸罗成调善法受他所施诸饮食已。入无量心定身证具足住。由此因缘应知施主无量福善滋润相续。无量安乐流注其身。施主尔时福恒增长。岂定常有缘彼胜思。是故所言思所熏习微细相续渐渐转变差别而生。定为应理。又非自作但遣他为业道如何得成满者。应如是说。由本加行。使者依教所作成时。法尔能令教者微细相续转变差别而生。由此当来能感多果。诸有自作事究竟时。当知亦由如是道理。应知即此微细相续转变差别名为业道。此即于果假立因名。是身语业所引果故。如执别有无表。论宗无表亦名身语业道。然大德说。于取蕴中由三时起思为杀罪所触。谓我当杀正杀杀已。非但由此业道究竟。勿自母等实未被害由谓已害成无间业。然于自造不误杀事。起如是思杀罪便触。若依此说非不应理。何于无表偏怀憎嫉定拨为无。而许所熏微细相续转变差别。然此与彼俱难了知。今于此中无所憎嫉。然许业道是心种类。由身加行事究竟时。离于心身于能教者身中别有无表法生。如是所宗不令生喜。若由此引彼加行生事究竟时。即此由彼相续转变差别而生。如是所宗可令生喜。但由心等相续转变差别。能生未来果故。又先已说。先说者何。谓表业既无宁有无表等。又说法处不言无色。由有如前所说定境无见无对法处摄色。又言道支应无八者。且彼应说。正在道时如何得有正语业命。为于此位有发正言起正作业求衣等不。不尔。云何。由彼获得如是种类无漏无表故。出观后由前势力能起三正不起三邪。以于因中立果名故。于无表立语业命名。若尔云何不受此义。虽无无表而在道时。获得如斯意乐依止。故出观后由前势力。能起三正不起三邪。以于因中立果名故。可具安立八圣道支。有余师言。唯说不作邪语等事以为道支。谓在定时由圣道力便能获得决定不作。此定不作依无漏道而得安立故名无漏。非一切处要依真实别有法体方立名数。如八世法。谓得不得及与毁誉称讥苦乐。非此不得衣食等事别有实体。此亦应然。别解脱律仪亦应准此。谓由思愿力先立要期。能定遮防身语恶业。由斯故建立别解脱律仪。若起异缘心应无律仪者。此难非理。由熏习力欲起过时忆便止故。戒为堤塘义亦应准此。谓先立誓限定不作恶。后数忆念惭愧现前。能自制持令不犯戒。故堤塘义由心受持。若由无表能遮犯戒。应无失念而破戒者。且止此等众多诤论。毗婆沙师说。有实物名无表色。是我所宗。前说无表大种所造性。为表大种造。为有异耶。颂曰

  此能造大种　　异于表所依

论曰。无表与表异大种生。所以者何。从一和合有细粗果不应理故。如表与大心同时生。无表亦然。为有差别。一切所造色多与大种俱时而生。然现在未来亦有少分依过去者。少分者何。颂曰

  欲后念无表　　依过大种生

论曰。唯欲界系初刹那后所有无表从过大生。此为所依无表得起。现身大种但能为依。为转随转因。随其次第如轮行于地手地为依。何地身语业何地大所造。颂曰

  有漏自地依　　无漏随生处

论曰。欲界所系身语二业。唯欲界系大种所造。如是乃至第四静虑身语二业。唯是彼地大种所造。若身语业是无漏者。随生此地应起现前。即是此地大种所造。以无漏法不堕界故。必无大种是无漏故。由所依力无漏生故。此表无表其类是何。复是何类大种所造。颂曰

  无表无执受　　亦等流情数
  散依等流性　　有受异大生
  定生依长养　　无受无异大
  表唯等流性　　属身有执受

论曰。今此颂中先辩无表是无执受。无变碍故。亦等流性。亦言显此有是刹那。谓初无漏。余皆等流性。谓同类因生。此唯有情。依内起故。于中欲界所有无表。等流有受别异大生。异大生言。显身语七一一是别大种所造。定生无表差别有二。谓诸静虑无漏律仪。此二俱依定所长养无受。无异大种所生。无异大言。显此无表七支同一具四大种所生。所以者何。所依大种如心唯一无差别故。应知有表唯是等流。此若属身是有执受。余义皆与散无表同。表业生时为要破坏本身形量。为不尔耶。若尔何失。若破坏者。异熟色断应可更续。是则违越毗婆沙宗。若不破坏如何得有一身处所二形量成。有别新生等流大种。造有表业不破本身。若尔随依何身分处起有表业应大于本。新生大种遍增益故。若不遍增益。如何遍生表。身有孔隙故得相容。已辩业门二三五别。此性界地差别云何。颂曰

  无表记余三　　不善唯在欲
  无表遍欲色　　表唯有伺二
  欲无有覆表　　以无等起故

论曰。无表唯通善不善性无有无记。所以者何。以无记心势力微劣。不能引发强业令生。可因灭时果仍续起。所言余者谓表及思。三谓皆通善恶无记。于中不善在欲非余。已断不善根无惭无愧故。善及无记诸地皆有。以于颂中不别遮故。欲色二界皆有无表。以无色中无大种故。随于何处有身语转。唯是处有身语律仪。若尔身生欲色二界入无色定应有律仪。如起无漏心有无漏无表。不尔以彼不堕界故。于无色界若有无表。应有无表非大种生。不可说言有漏无表以别界地大种为依。又背诸色入无色定故彼定中不能生色。由彼定有伏色想故。毗婆沙师作如是说。为治恶戒故起尸罗。唯欲界中有诸恶戒。无色于欲具四种远。一所依远。二行相远。三所缘远。四对治远。故无色中无无表色。表色唯在二有伺地。谓通欲界初静虑中。非上地中可言有表。有覆无记表。欲界定无。唯于梵世中可得说有。曾闻大梵有诳谄言。谓自众中为避马胜所征问故。矫自叹等。上地既无言何得有声处。有外大种为因发声。有余师言。上三静虑亦有无覆无记表业。无善无染。所以者何。非上地生能起下地善及染心发身语表。劣故断故。前说为善。复以何因二定以上都无表业。于欲界中无有有覆无记表业。以无发业等起心故。有寻伺心能发表业。二定以上都无此心。又发表心唯修所断。见所断惑内门转故。以欲界中决定无有有覆无记修所断惑。是故表业上三地都无。欲界中无有覆无记表。为但由等起令诸法成善不善性等。不尔。云何。由四种因成善性等。一由胜义。二由自性。三由相应。四由等起。何法何性由何因成。颂曰

  胜义善解脱　　自性惭愧根
  相应彼相应　　等起色业等
  翻此名不善　　胜无记二常

论曰。胜义善者。谓真解脱。以涅槃中最极安隐众苦永寂犹如无病。自性善者。谓惭愧根。以有为中唯惭与愧及无贪等三种善根。不待相应及余等起。体性是善犹如良药。相应善者。谓彼相应。以心心所要与惭愧善根相应方成善性。若不与彼惭等相应。善性不成。如杂药水。等起善者。谓身语业不相应行。以是自性及相应善所等起故。如良药汁所引生乳。若异类心所起得等云何成善。此义应思。如说善性四种差别。不善四种与此相违。云何相违。胜义不善。谓生死法。由生死中诸法皆以苦为自性极不安隐犹如痼疾。自性不善。谓无惭愧三不善根。由有漏中唯无惭愧及贪嗔等三不善根。不待相应及余等起。体是不善犹如毒药。相应不善。谓彼相应。由心心所法要与无惭愧不善根相应。方成不善性。异则不然。如杂毒水。等起不善。谓身语业不相应行。以是自性相应不善所等起故。如毒药汁所引生乳。若尔便无一有漏法是无记或善。皆生死摄故。若据胜义诚如所言。然于此中约异熟说。诸有漏法若不能记异熟果者立无记名。于中若能记爱异熟说名为善故无有过。胜义无记。谓二无为。以太虚空及非择灭。唯无记性更无异门。于此应思。若等起力令身语业成善不善。则诸大种例亦应然。以作者心本欲起业。非四大种故不成例。若尔定心随转无表。非正在定作意引生。亦非散心加行引发。不同类故。如何成善。或天眼耳应成善性。于如是义应设劬劳。如上所言。见所断惑内门转故不能发表。若尔何缘契经中说由邪见故起邪思惟邪语邪业及邪命等。此不相违。何以故。颂曰

  等起有二种　　因及彼刹那
  如次第应知　　名转名随转
  见断识唯转　　唯随转五识
  修断意通二　　无漏异熟非
  于转善等性　　随转各容三
  牟尼善必同　　无记随惑善

论曰。表无表业等起有二。谓因等起。刹那等起。在先为因故。彼刹那有故。如次初名转。第二名随转。谓因等起将作业时。能引发故说名为转。刹那等起正作业时。不相离故名为随转。随转于业有何功能。虽有先因为能引发。若无随转者如死业应无。若尔无心如何发戒。诸有心者业起分明故随转心于业有用。见所断识于发表中唯能为转。于能起表寻伺生中为资粮故不为随转。于外门心正起业时此无有故。又见所断若发表色此色则应是见所断。若许见断斯有何失。是则违越阿毗达磨。又明无明不相违故。有漏业色非见所断。如是道理应更成立。若尔大种亦应见断。俱见断心力所起故。无如是过失如非善不善。或复许尔理亦无违。不应许然。以诸大种定非见断及非所断。以一切种不染污法与明无明不相违故。彼经但据前因等起而作是说。故不相违。若五识身唯作随转。无分别故。外门起故。修断意识通为二种。有分别故。外门起故。一切无漏异熟生心非转随转。唯在定故。不由加行任运转故。如是即成四句差别。有转非随转。谓见所断心。有随转非转。谓眼等五识。有转亦随转。谓修所断三性意识。有非转随转。谓诸无漏异熟生心。转随转心定同性不。此不决定。其事云何。谓前转心若是善性。后随转识通善等三。不善无记随转亦尔。唯牟尼尊转随转识多分同性少有不同。谓转若善心随转亦善。转心若无记随转亦然。而或有时善随无记转。曾无无记为善随转时。以佛世尊于说法等心或增长无萎歇故。有余部说。诸佛世尊常在定故。心唯是善无无记心。故契经说

  那伽行在定　　那伽住在定
  那伽坐在定　　那伽卧在定

毗婆沙师作如是释。此显佛意。若不乐散心则于四威仪能常在定。然于余位非无威仪及异熟生通果心起。诸有表业成善等性。为如转心。为如随转。设尔何失。若如转者。则欲界中应有有覆无记表业。身见边见能为转故。或应简别非一切种见所断心皆能为转。若如随转恶无记心俱得别解脱表应非善性。于此征难应设劬劳。应言如转心表成善等性。然非如彼见断转心。修断转心为间隔故。若表不由随转心力成善等者。则不应言彼经但据前因等起非据刹那。故欲界中定无有覆无记表业。但应说言。彼经唯据余心所间因等起说故。见断心虽能为转。而于欲界定无有覆无记表业

阿毗达磨俱舍论卷第十三阿毗达磨俱舍论卷第十四

        尊者世亲造

        三藏法师玄奘奉　诏译

    分别业品第四之二

傍论已了。复应辩前表无表相。颂曰

  无表三律仪　　不律仪非二

论曰。此中无表略说有三。一者律仪。二不律仪。三者非二谓非律仪非不律仪。能遮能灭恶戒相续故名律仪。如是律仪差别有几。颂曰

  律仪别解脱　　静虑及道生

论曰。律仪差别略有三种。一别解脱律仪。谓欲缠戒。二静虑生律仪。谓色缠戒。三道生律仪。谓无漏戒。初律仪相差别云何。颂曰

  初律仪八种　　实体唯有四
  形转名异故　　各别不相违

论曰。别解脱律仪相差别有八。一苾刍律仪。二苾刍尼律仪。三正学律仪。四勤策律仪。五勤策女律仪。六近事律仪。七近事女律仪。八近住律仪。如是八种律仪相差别。总名第一别解脱律仪。虽有八名实体唯四。一苾刍律仪。二勤策律仪。三近事律仪。四近住律仪。唯此四种别解律仪皆有体实。相各别故。所以者何。离苾刍律仪。无别苾刍尼律仪。离勤策律仪无别正学勤策女律仪。离近事律仪无别近事女律仪。云何知然。由形改转。体虽无舍得而名有异故。形谓形相。即男女根。由此二根男女形别。但由形转令诸律仪名为苾刍苾刍尼等。谓转根位令本苾刍律仪名苾刍尼律仪。或苾刍尼律仪名苾刍律仪。令本勤策律仪名勤策女律仪。或勤策女律仪及正学律仪名勤策律仪。令本近事律仪名近事女律仪。或近事女律仪名近事律仪。非转根位有舍先得得先未得律仪因缘。故四律仪非异三体。若从近事律仪受勤策律仪。复从勤策律仪受苾刍律仪。此三律仪为由增足远离方便立别别名。如只双金钱及五十二十。为体各别具足顿生。三种律仪体不相杂。其相各别具足顿生。三律仪中具三离杀。乃至具足三离饮酒。余数多少随其所应。既尔相望同类何别。由因缘别相望有异。其事云何。如如求受多种学处。如是如是。能离多种憍逸处时。即离众多杀等缘起。以诸远离依因缘发故。因缘别远离有异。若无此事舍苾刍律仪。尔时则应三律仪皆舍。前二摄在后一中故。既不许然。故三各别。然此三种互不相违。于一身中俱时而转。非由受后舍前律仪。勿舍苾刍戒便非近事等。近事近住勤策苾刍四种律仪云何安立。颂曰

  受离五八十　　一切所应离
  立近事近住　　勤策及苾刍

论曰。应知此中如数次第。依四远离立四律仪。谓受离五所应远离。安立第一近事律仪。何等名为五所应离。一者杀生。二不与取。三欲邪行。四虚诳语。五饮诸酒。若受离八所应远离。安立第二近住律仪。何等名为八所应离。一者杀生。二不与取。三非梵行。四虚诳语。五饮诸酒。六涂饰香鬘舞歌观听。七眠坐高广严丽床座。八食非时食。若受离十所应远离。安立第三勤策律仪。何等名为十所应离。谓于前八涂饰香鬘舞歌观听开为二种。复加受畜金银等宝以为第十。若受离一切应离身语业。安立第四苾刍律仪。别解律仪名差别者。颂曰

  俱得名尸罗　　妙行业律仪
  唯初表无表　　名别解业道

论曰。能平险业故名尸罗。训释词者。谓清凉故。如伽他言。受持戒乐。身无热恼故名尸罗。智者称扬故名妙行。所作自体故名为业。岂不无表亦名不作。如何今说所作自体。有惭耻者受无表力不造众恶故名不作。表思所造得所作名。有余释言。是作因故。是作果故。名作无失。能防身语故名律仪。如是应知。别解脱戒通初后位无差别名。唯初刹那表及无表得别解脱及业道名。谓受戒时初表无表。别别弃舍种种恶故。依初别舍义立别解脱名。即于尔时所作究竟。依业畅义立业道名。故初刹那名别解脱。亦得名曰别解律仪。亦得名为根本业道。从第二念乃至未舍不名别解脱名别解律仪。不名业道名为后起。谁成就何律仪。颂曰

  八成别解脱　　得静虑圣者
  成静虑道生　　后二随心转

论曰。八众皆成就别解脱律仪。谓从苾刍乃至近住。外道无有所受戒耶。虽有不名别解脱戒。由彼所受无有功能永脱诸恶依著有故。静虑生者。谓此律仪从静虑生。或依静虑。若得静虑者定成此律仪。诸静虑边亦名静虑。如近村邑得村邑名故。有说言于此村邑有稻田等。此亦应然。道生律仪圣者成就。此复有二。谓学无学。于前分别俱有因中说二律仪是随心转。于此三内其二者何。谓静虑生及道生二。非别解脱。所以者何。异心无心亦恒转故。静虑无漏二种律仪。亦名断律仪。依何位建立。颂曰

  未至九无间　　俱生二名断

论曰。未至定中九无间道。俱生静虑无漏律仪。以能永断欲缠恶戒及能起惑名断律仪。由此或有静虑律仪非断律仪。应作四句。第一句者。除未至定九无间道有漏律仪。所余有漏静虑律仪。第二句者。依未至定九无间道无漏律仪。第三句者。依未至定九无间道有漏律仪。第四句者。除未至定九无间道无漏律仪所余一切无漏律仪。如是或有无漏律仪非断律仪。应作四句。准前四句如应当知。若尔世尊所说略戒

  身律仪善哉　　善哉语律仪
  意律仪善哉　　善哉遍律仪

又契经说。应善守护应善安住眼根律仪。此意根律仪以何为自性。此二自性非无表色。若尔是何。颂曰

  正知正念合　　名意根律仪

论曰。为显如是二种律仪俱以正知正念为体故。列名已复说合言。谓意律仪慧念为体。即合二种为根律仪。故离合言显勿如次。今应思择。表及无表谁成就何。齐何时分。且辩成无表律仪不律仪。颂曰

  住别解无表　　未舍恒成现
  刹那后成过　　不律仪亦然
  得静虑律仪　　恒成就过未
  圣初除过去　　住定道成中

论曰。住别解脱补特伽罗。未舍以来恒成现世。此别解脱律仪无表。初刹那后亦成过去。前未舍言遍流至后。无散无表有成未来。不随心色势微劣故。如说安住别解律仪。住不律仪应知亦尔。谓至未舍恶戒以来恒成现世。恶戒无表初刹那后亦成过去。诸有获得静虑律仪。乃至未舍恒成过未。余生所失过去定律仪。今初刹那必还得彼故。一切圣者无漏律仪。过去未来亦恒成就。有差别者。谓初刹那必成未来非成过去。此类圣道先未起故。若有现住静虑彼道。如次成现在静虑道律仪。非出观时有成现在。已辩安住善恶律仪。住中云何。颂曰

  住中有无表　　初成中后二

论曰。言住中者。谓非律仪非不律仪。彼所起业未必一切皆有无表。若有无表即是善戒或是恶戒种类所摄。彼初刹那但成现在。然现在世处过未中。故以成中说成现在。初刹那后未舍以来。恒成过现二世无表。若有安住律不律仪。亦有成恶善无表不。设有成就为经几时。颂曰

  住律不律仪　　起染净无表
  初成中后二　　至染净势终

论曰。若住律仪由胜烦恼作杀缚等诸不善业。由此便发不善无表。住不律仪。由淳净信。作礼佛等诸胜善业。由此亦发诸善无表。乃至此二心未断来。所发无表恒时相续。然其初念唯成现在。自兹以后通成过现。已辩无表。成表云何。颂曰

  表正作成中　　后成过非未
  有覆及无覆　　唯成就现在

论曰。诸有安住律不律仪及住中者。乃至正作诸表业来恒成现表。初刹那后至未舍来恒成过去。必无成就未来表者。如无表释。有覆无覆二无记表。定无有能成就过未。法力既劣得力亦微。是故无能逆追成者。此法力劣谁之所为。是心所为。若尔有覆无记心等勿成过未。此责非理。表昧钝故。依他起故。心等不然。无记表业从劣心起。其力倍劣彼能起心。故表与心成有差别。如前所说住不律仪。此不律仪名差别者。颂曰

  恶行恶戒业　　业道不律仪

论曰。此恶行等五种异名。是不律仪名之差别。是诸智者所诃厌故。果非爱故立恶行名。障净尸罗故名恶戒。身语所造故名为业。根本所摄故名业道。不禁身语名不律仪。然业道名唯目初念。通初后位立余四名。或成表业非无表等。应作四句。其事云何。颂曰

  成表非无表　　住中劣思作
  舍未生表圣　　成无表非表

论曰。唯成就表非无表者。谓住非律仪非不律仪。以微劣思造善造恶。唯发表业尚无无表。况无记思所发表业。除有依福及成业道。唯成无表非表业者。谓易生圣补特伽罗。表业未生或生已舍。俱成非句如应当知。说住律仪不律仪等成就表业无表业已。此诸律仪由何而得。颂曰

  定生得定地　　彼圣得道生
  别解脱律仪　　得由他教等

论曰。静虑律仪由得有漏根本近分静虑地心。尔时便得。与心俱故。无漏律仪由得无漏根本近分静虑地心。尔时便得。亦心俱故。彼声为显前静虑心。复说圣言简取无漏。六静虑地有无漏心。谓未至中间及四根本定。非三近分。如后当辩。别解脱律仪由他教等得。能教他者说名为他。从如是他教力发戒。故说此戒由他教得。此复二种。谓从僧伽补特伽罗有差别故。从僧伽得者。谓苾刍苾刍尼及正学戒。从补特伽罗得者。谓余五种戒。诸毗柰耶毗婆沙师说。有十种得具戒法。为摄彼故复说等言。何者为十。一由自然。谓佛独觉。二由得入正性离生。谓五苾刍。三由佛命善来苾刍。谓耶舍等。四由信受佛为大师。谓大迦叶。五由善巧酬答所问。谓苏陀夷。六由敬受八尊重法。谓大生主。七由遣使。谓法授尼。八由持律为第五人。谓于边国。九由十众。谓于中国。十由三说归佛法僧。谓六十贤部共集受具戒。如是所得别解律仪。非必定依表业而发。又此所说别解律仪。应齐几时要期而受。颂曰

  别解脱律仪　　尽寿或昼夜

论曰。七众所持别解脱戒。唯应尽寿要期而受。近住所持别解脱戒。唯一昼夜要期而受。此时定尔。所以者何。戒时边际但有二种。一寿命边际。二昼夜边际。重说昼夜为半月等。时名是何法。谓诸行增语。于四洲中光位闇位如其次第立昼夜名二边际中尽寿可尔。于命终后虽有要期而不能生别解脱戒。依身别故。别依身中无加行故无忆念故。一昼夜后或五戒十昼夜等中受近住戒。何法为障令彼众多近住律仪非亦得起。必应有法能为障碍。以薄伽梵于契经中说近住律仪唯一昼夜故于如是义应共寻思。为佛正观一昼夜后理无容起近住律仪。故于经中说一昼夜。为观所化根难调者。旦应授与一昼夜戒。依何理教作如是言。过此戒生不违理故。毗婆沙者作如是言。曾无契经说过昼夜有别受得近住律仪。是故我宗不许斯义。依何边际得不律仪。颂曰

  恶戒无昼夜　　谓非如善受

论曰。要期尽寿造诸恶业得不律仪。非一昼夜如近住戒。所以者何。谓此非如善戒受故。谓必无有立限对师受不律仪如近住戒我一昼夜定受不律仪。此是智人所诃厌业故。若尔亦无有立限对师我乃至命终定受恶戒。勿尽形寿得不律仪。虽无对师要期尽寿作诸恶业。由起毕竟坏善意乐得不律仪。非起暂时坏善意乐。无师令彼得不律仪。故不律仪无一昼夜。然近住戒由现对师要期受力。虽无毕竟坏恶意乐。而得律仪。设有对师要期暂受不律仪者。亦必应得。然未曾见故不立有。经部师说如善律仪无别实物名为无表。此不律仪亦应非实。即欲造恶不善意乐相续不舍名不律仪。由此后时善心虽起而名成就不律仪者。以不舍此阿世耶故。说一昼夜近住律仪。欲正受时当如何受。颂曰

  近住于晨旦　　下座从师受
  随教说具支　　离严饰昼夜

论曰。近住律仪于晨旦受。谓受此戒要日出时。此戒要经一昼夜故。诸有先作如是要期。谓我恒于月八日等必当受此近住律仪。若旦有碍缘斋竟亦得受。言下座者。谓在师前居卑劣座。或蹲或跪曲躬合掌。唯除有病。若不恭敬不发律仪。此必从师无容自受。以后若遇诸犯戒缘。由愧戒师能不违犯。受此戒者应随师教受者后说。勿前勿俱。如是方成从师教受。异此授受二俱不成。具受八支方成近住。随有所阙近住不成。受此律仪必离严饰。憍逸处故。常严身具不必须舍。缘彼不能生甚憍逸如新异故。受此律仪必须昼夜。谓至明旦日初出时。若不如斯依法受者。但生妙行不得律仪。又若如斯尽昼夜受。具制屠猎奸盗有情。近住律仪深成有用。言近住者。谓此律仪近阿罗汉住。以随学彼故。有说。此近尽寿戒住。如是律仪或名长养。长养薄少善根有情。令其善根渐增多故。如有颂言

  由此能长养　　自他善净心
  是故薄伽梵　　说此名长养

何缘受此必具八支。颂曰

  戒不逸禁支　　四一三如次
  为防诸性罪　　失念及憍逸

论曰。八中前四是尸罗支。谓离杀生至虚诳语。由此四种离性罪故。次有一种是不放逸支。谓离饮诸酒。生放逸处。虽受尸罗若饮诸酒则心放逸。犯尸罗故。后有三种是禁约支。谓离涂饰香鬘乃至食非时食。以能随顺厌离心故。何缘具受如是三支。若不具支便不能离性罪失念憍逸过失。谓初离杀至虚诳语。能防性罪。离贪嗔痴所起杀等诸恶业故。次离饮酒能防失念。以饮酒时能令忘失应不应作诸事业故。后离三种能防憍逸。以若受用种种香鬘高广床座习近歌舞心便憍举。寻即毁戒。由远彼故心便离憍。若有能持依时食者。以能遮止恒食时故。便忆自受近住律仪。能于世间深生厌离。若非时食二事俱无。数食能令心纵逸故。有余师说。离非时食名为斋体。余有八种说名斋支。涂饰香鬘舞歌观听分为二故。若作此执便违契经。经中说离非时食已。便作是说。此第八支我今随圣阿罗汉学。随行随作。若尔有何别斋体。而说此八名斋支。总摽斋号别说为支。以别成总得支名故。如车众分及四支军五支散等。斋戒八支应知亦尔。毗婆沙师作如是说。离非时食是斋亦斋支。所余七支是斋支非斋。如正见是道亦道支。余七支是道支非道。择法觉是觉亦觉支。余六支是觉支非觉。三摩地是静虑亦静虑支。所余支是静虑支非静虑。如是所说不应正理。不可正见等即正见等支。若谓前生正见等为后生正见等支。则初刹那圣道等应不具有八支等。为唯近事得受近住。为余亦有受近住耶。颂曰

  近住余亦有　　不受三归无

论曰。诸有未受近事律仪。一昼夜中归依三宝。说三归已受近住戒。彼亦受得近住律仪。异此则无。除不知者。如契经说。佛告大名。诸有在家白衣男子男根成就。归佛法僧起殷净心。发诚谛语自称我是邬波索迦。愿尊忆持慈悲护念。齐是名曰邬波索迦。为但受三归即成近事。外国诸师说。唯此即成。迦湿弥罗国诸论师言。离近事律仪则非近事。若尔应与此经相违。此不相违。已发戒故。何时发戒。颂曰

  称近事发戒　　说如苾刍等

论曰。起殷净心发诚谛语自称我是邬波索迦。愿尊忆持慈悲护念。尔时即发近事律仪。称近事等言便发律仪故。以经复说我从今时乃至命终舍生言故。此经意说舍杀生等。略去杀等但说舍生。故于前时已得五戒。彼虽已得近事律仪。为令了知所应学处故。复为说离杀生等五种戒相令识坚持。如得苾刍具足戒已。说重学处令识坚持。勤策亦然。此亦应尔。是故近事必具律仪。颂曰

  若皆具律仪　　何言一分等
  谓约能持说

论曰。若诸近事皆具律仪。何缘世尊言有四种。一能学一分。二能学少分。三能学多分。四能学满分。谓约能持故作是说。能持先所受故说能学言。不尔应言受一分等。理实约受等具律仪。以具律仪故名近事。如是所执违越契经。如何违经。谓无经说自称我是近事等言便发五戒。此经不说我从今者乃至命终舍生言故。经如何说。如大名经。唯此经中说近事相。余经不尔故违越经。然余经说。我从今时乃至命终舍生归净。是归三宝发诚信言。此中显示以见谛者。由得证净举命自要。表于正法深怀爱重乃至为救自生命缘。终不舍于如来正法。非彼为欲说近事相。故说如是舍生等言。设说亦非分明理教。谁能准此不明了文。便信前时已发五戒。又约持犯戒说学一分等尚不应问。况应为答。谁有已解近事律仪必具五支。而不能解于所学处持一非余。乃至具持名一分等。由彼未解近事律仪受量少多故应请问。凡有几种邬波索迦能学学处。答言。有四邬波索迦。谓能学一分等。犹未能了。复问何名能学一分。乃至广说。若阙律仪得名近事。苾刍勤策阙亦应成。彼既不成。此亦应尔。何缘近事乃至苾刍所受律仪支量定尔。由佛教力施设故然。若尔何缘不许由佛教力施设虽阙律仪。而名近事非苾刍等。迦湿弥罗国毗婆沙师。不许阙律仪得成近事。此近事等一切律仪。由何得成下中上品。颂曰

  下中上随心

论曰。八众所受别解脱律仪。皆随受心有下中上品。由如是理诸阿罗汉或有成就下品律仪。然诸异生或成上品。为有但受近事律仪不受三归成近事不。不成近事除有不知。诸有归依佛法僧者。为归何等。颂曰

  归依成佛僧　　无学二种法
  及涅槃择灭　　是说具三归

论曰。归依佛者。谓但归依能成佛无学法。由彼胜故身得佛名。或由得彼法佛能觉一切。何等名为佛无学法。谓尽智等及彼随行。非色等身。前后等故。为归一佛。一切佛耶。理实应言归一切佛。以诸佛道相无异故。归依僧者。谓通归依诸能成僧学无学法。由得彼故僧成八种补特伽罗。不可破故。为归一佛僧。一切佛僧耶。理实通归一切佛僧。以诸僧道相无异故。然契经说当来有僧汝应归者。彼经但为显示当来现见僧宝。归依法者。谓归涅槃。此涅槃言唯显择灭。自他相续烦恼及苦寂灭一相。故通归依。若唯无学法即是佛者。如何于佛所恶心出血。但损生身成无间罪。毗婆沙者作是释言。坏彼所依彼随坏故。然寻本论不见有言唯无学法即名为佛。但言无学法能成于佛。既不遮佛体亦摄依身。故于此中不容前难。若异此者。应佛与僧住世俗心非僧非佛。又应唯执成苾刍戒即是苾刍。然如有欲供养苾刍者。彼唯供养成苾刍尸罗。如是有欲归依佛者。亦应但归成佛无学法。有余师说。归依佛者。总归依如来十八不共法。此能归依何法为体。语表为体。如是归依以何为义。救济为义。由彼为依能永解脱一切苦故。如世尊言

  众人怖所逼　　多归依诸山
  园苑及丛林　　孤树制多等
  此归依非胜　　此归依非尊
  不因此归依　　能解脱众苦
  诸有归依佛　　及归依法僧
  于四圣谛中　　恒以慧观察
  知苦知苦集　　知永超众苦
  知八支圣道　　趣安隐涅槃
  此归依最胜　　此归依最尊
  必因此归依　　能解脱众苦

是故归依普于一切受律仪处为方便门。何缘世尊于余律仪处立离非梵行为其所学。唯于近事一律仪中但制令其离欲邪行。颂曰

  邪行最可诃　　易离得不作

论曰。唯欲邪行世极诃责。以能侵毁他妻等故。感恶趣故非非梵行。又欲邪行易远离故。诸在家者耽着欲故离非梵行难可受持。观彼不能长时修学故不制彼离非梵行。又诸圣者于欲邪行一切定得不作律仪。经生圣者亦不行故离非梵行则不如是。故于近事所受律仪但为制立离欲邪行。勿经生圣者犯近事律仪。不作律仪谓定不作。诸有先受近事律仪后娶妻妾。于彼妻妾先受戒时得律仪不。理实应得。勿但于一分得别解律仪。若尔云何后非犯戒。颂曰

  得律仪如誓　　非总于相续

论曰。如本受誓而得律仪。本受誓云何。谓离欲邪行。非于一切有情相续言我皆当离非梵行。由此普于有情相续唯得离欲邪行戒。非离非梵行律仪故后纳妻妾非毁犯前戒。何缘但制离虚诳语。非离间语等为近事律仪。亦由前说三种因故。谓虚诳语最可诃故。诸在家者易远离故。一切圣者得不作故。复有别因。颂曰

  以开虚诳语　　便越诸学处

论曰。越诸学处被检问时。若开虚诳语。便言我不作。因斯于戒多所违越。故佛为欲令彼坚持。于一切律仪制离虚诳语。云何令彼若犯戒时便自发露能防后犯。复以何缘不于远离遮罪建立近事律仪。谁言此中不离遮罪。离何遮罪。谓离饮酒。何缘于彼诸遮罪中不制离余。唯遮饮酒。颂曰

  遮中唯离酒　　为护余律仪

论曰。诸饮酒者心多纵逸。不能守护诸余律仪。故为护余令离饮酒。宁知饮酒遮罪摄耶。由此中无性罪相故。以诸性罪唯染心行。为疗病时虽饮诸酒不为醉乱能无染心。岂不先知酒能醉乱而故欲饮即是染心。此非染心由自知量。为疗病故分限而饮不令醉乱故非染心。诸持律者言。饮酒是性罪。如彼尊者邬波离言。我当如何供给病者。世尊告曰。唯除性罪余随所应皆可供给。然有染疾释种须酒。世尊不开彼饮酒故。又契经说。诸有苾刍称我为师不应饮酒。乃至极少如一茅端所沾酒量亦不应饮。故知饮酒是性罪摄。又诸圣者虽易多生亦不犯故。如杀生等。又经说是身恶行故。对法诸师言非性罪。然为病者总开遮戒。复于异时遮饮酒者。为防因此犯性罪故。又令醉乱量无定限。故遮乃至饮茅端所沾量。又一切圣皆不饮者。以诸圣者具惭羞故。饮酒能令失正念故。乃至少分亦不饮者。以如毒药量无定故。又经说是身恶行者。酒是一切放逸处故。由是独立放逸处名。余不立此名。皆是性罪故。然说数习堕恶趣者。显数饮酒能令身中诸不善法相续转故。又能引发恶趣业故。或能令彼转增盛故。如契经说。窣罗迷丽耶末陀放逸处。依何义说。酝食成酒名为窣罗。酝余物所成名迷丽耶酒。即前二酒未熟已坏不能令醉不名末陀。若令醉时名末陀酒。简无用位重立此名。然以槟榔及稗子等亦能令醉。为简彼故。须说窣罗迷丽耶酒。虽是遮罪而令放逸广造众恶。为令殷重遮断故说放逸处言。酒是放逸所依处故

说一切有部俱舍论卷第十四阿毗达磨俱舍论卷第十五

        尊者世亲造

        三藏法师玄奘奉　诏译

    分别业品第四之三

此别解脱静虑无漏三种律仪。从彼得一亦余二不。不尔。云何。颂曰

  从一切二现　　得欲界律仪
  从根本恒时　　得静虑无漏

论曰。欲界律仪。谓别解脱。此从一切根本业道及从加行后起而得。从二得者。谓从二类。即情非情性罪遮罪。从现得者。谓从现世蕴处界得。非从去来。由此律仪有情处转。去来非是有情处故。若得静虑无漏律仪。应知但从根本业道。尚不从彼加行后起得此律仪况从遮罪。从恒时者。谓从过去现在未来蕴处界得。由此差别应作四句。有蕴处界从彼唯得别解律仪非余二等。第一句者。谓从现世加行后起及诸遮罪。第二句者。谓从去来根本业道。第三句者。谓从现世根本业道。第四句者。谓从去来加行后起。非于正得善律仪时可有现世恶业道等。是故应言从现处得。理应但说防护未来。定不应言防护过现。诸有获得律不律仪。从一切有情支因有异不。此定有异相云何。颂曰

  律从诸有情　　支因说不定
  不律从一切　　有情支非因

论曰。律仪定从一切有情得。无少分理。支因说不定。支不定者。有从一切得谓苾刍律仪。有从四支得谓所余律仪。唯根本业道名律仪支故。因不定者。谓或有义从一切因。或约余义唯许从一。从一切者。谓从无贪嗔痴。必俱起故。唯从一者。谓从下中上心。不俱起故。此中且就后三因说。或有一类住律仪者。于一切有情得律仪。非一切支非一切因。谓以下心或中或上。受近事勤策戒。或有一类住律仪者。于一切有情得律仪。由一切支非一切因。谓以下心或中或上。受苾刍戒。或有一类住律仪者。于一切有情得律仪。由一切支及一切因。谓以三心受近事勤策苾刍戒。或有一类住律仪者。于一切有情得律仪。由一切因非一切支。谓以三心受近事近住勤策戒。无有不遍。于诸有情得律仪者。以于一切诸有情所住善意乐方得律仪。异则不然。以恶意乐不全息故。若人不作五种定限方可受得别解律仪。谓有情支处时缘定。有情定者。念我唯于某类有情当离杀等。言支定者。念我唯于某律仪支当持不犯。言处定者。念我唯住某类方域当离杀等。言时定者。念我唯于一月等时能离杀等。言缘定者。念我唯除斗战等缘能离杀等。如是受者不得律仪。但得律仪相似妙行。于非所能境如何得律仪。由普于有情发起增上不损命意乐故得律仪。毗婆沙师有作是说。若谓一向于所能境方可受得别解律仪。则此律仪应有增减。以所能境与非所能二类有情有转易故。如是便有别解律仪离得舍缘有得舍过。彼说不然。如生草等先无后起或起已枯于彼律仪无增无减。能不能境所得律仪。境转易时例亦应尔。彼言不尔。所以者何。以诸有情前后性等草等前后性不同故。若尔有情般涅槃已。如前性类今时既无。于彼律仪如何无减。故如是释于理不然。前所说因于理为善。若尔前佛及所度生已涅槃者。后佛于彼既不发得别解律仪。如何尸罗无减前过。以一切佛别解律仪皆从一切有情处得。设彼有情今犹在者。后佛从彼亦得律仪。故后尸罗无减前过。已说从彼得诸律仪。得不律仪定从一切有情业道。无少分境及不具支不律仪者。此定无有由一切因。下品等心无俱起故。若有一类由下品心得不律仪。后于异时由上品心断众生命。彼但成就下不律仪。亦成杀生上品表等。中品上品例此应知。此中何名不律仪者。谓诸屠羊屠鸡屠猪捕鸟捕鱼。猎兽劫盗魁脍典狱。缚龙煮狗及罝弶等。等言类显王典刑罚及余听察断罪等人。但恒有害心名不律仪者。由彼一类住不律仪。或有不律仪名不律仪者。言屠羊者。谓为活命要期尽寿恒欲害羊。余随所应当知亦尔。遍于有情界得诸律仪其理可尔。由普欲利乐胜阿世耶而受得故。非屠羊等不律仪人于己至亲有损害意。乃至为救自身命缘亦不欲杀。如何可说普于一切得不律仪。由彼至亲若为羊等于彼亦可有损害心。既知至亲现非羊等。如何于彼可有害心。又圣必无作羊等理。如何于彼得不律仪。若观未来羊等自体。于现相续得不律仪。是则羊等于未来世亦有至亲及圣自体。于彼决定无损害心。是则应观未来自体。不于现在得不律仪。于羊等现身既有害意。如何不于彼得不律仪。于母等现身既无害意。如何亦于彼得不律仪。于等事中应求异理。又屠羊等不律仪人。于一生中不与不取。于己妻妾住知足心。哑不能言无语四过。如何彼亦得具支不律仪。彼遍损善阿世耶故。虽哑不言而身表语所欲说义故得具支。若尔彼人或时先受二三学处。后但受杀。于余不损善阿世耶。如何具发七支恶戒。毗婆沙者作如是言。必无缺支及余一分可得名住不律仪人。经部诸师作如是说。随所期限支具不具及全分一分皆得不律仪。律仪亦然。唯除八戒。由随彼量善恶尸罗性相相违互相遮故。已说从彼得不律仪。得不律仪及余无表。如何方便未说当说。颂曰

  诸得不律仪　　由作及誓受
  得所余无表　　由田受重行

论曰。诸不律仪由二因得。一者生在不律仪家。由初现行杀等加行。二者虽复生在余家。由初要期受杀等事。谓我当作如是事业。以求财物养活自身。当于尔时便发恶戒。得余无表由三种因。一者由田。谓于如是诸福田所施园林等。彼善无表初施便生。如说有依诸福业事。二者由受。谓自誓言。若未礼佛不先食等。或作誓限。于斋日月半月及年常施食施。三由重行。谓起如是殷重作意行善行恶。由此三因起余无表。如是已说得律仪等。舍律仪等未说当说。具云何舍别解律仪。颂曰

  舍别解调伏　　由故舍命终
  及二形俱生　　断善根夜尽
  有说由犯重　　余说由法灭
  伽湿弥罗说　　犯二如负财

论曰。言调伏者意显律仪。由此能令根调伏故。唯除近住所余七种别解律仪。由四缘舍。一由意乐对有解人发有表业舍学处故。二由弃舍众同分故。三由二形俱时生故。四由所因善根断故。舍近住戒由前四缘及由夜尽。是故总说别解律仪由五缘舍。何缘舍戒由此五缘。与受相违表业生故。所依舍故。所依变故。所因断故。过期限故。有余部说。于四极重感堕罪中。若随犯一亦舍勤策苾刍律仪。有余部言。由正法灭亦能令舍别解律仪。以法灭时一切学处结界羯磨皆止息故。迦湿弥罗国毗婆沙师言。犯根本罪时不舍出家戒。所以然者。非犯一边一切律仪应遍舍故。非犯余罪有断尸罗。然有二名。谓持犯戒。如有财者负他债时名为富人及负债者。若于所犯发露悔除名具尸罗。不名犯戒。如还债已但名富人。若尔何缘薄伽梵说犯四重者不名苾刍。不名沙门非释迦子。破苾刍体害沙门性。坏灭堕落立他胜名。依胜义苾刍密意作是说。此言凶勃。凶勃者何。谓于世尊了义所说以别义释令成不了。与多烦恼者为犯重罪缘。宁知此言是了义说。由律自释有四苾刍。一名想苾刍。二自称苾刍。三乞丐苾刍。四破惑苾刍。此义中言非苾刍者。谓非白四羯磨受具足戒苾刍。非此苾刍先是胜义。后由犯重成非苾刍。故知此言是了义说。然彼所说。非犯一边一切律仪应遍舍者。彼言便是征诘大师。大师此中立如是喻。如多罗树若被断头必不复能生长广大。诸苾刍等犯重亦然。大师此中喻显何义。意显于戒随犯一边根本重罪。令余所受必不复能生长广大。谓彼毁犯诸重罪时。违越苾刍根本行故。与极猛利无惭无愧共相应故。行根既断。理应遍舍一切律仪。又犯重人世尊不许食僧祇食下至一抟。践毗诃罗一足跟地。摈出一切苾刍事业。大师依彼说如是言。应速拔除稻禾稗莠。应速简弃腐朽栋梁。应速簸扬种中糠秕。如是应速驱摈众中实非苾刍称苾刍者。彼苾刍体其相如何。随相是何体必应有。以世尊说准他当知有四沙门。更无第五。所言四者。一胜道沙门。二示道沙门。三命道沙门。四污道沙门。虽有此说而彼唯有余沙门相故名沙门。如被烧材假鹦鹉[此/束]涸池败种火轮死人。若犯重人非苾刍者。则应无有授学苾刍。不说犯重人皆成他胜罪。但成他胜罪。定说非苾刍。谓或有人相续殊胜。虽犯极重戒而非他胜罪。由彼无有一念覆心。法主世尊制立如是。若犯他胜便非苾刍。何不重令出家受戒。由彼相续已为极重无惭愧怀。无力能发出家律仪。如蕉种故。非观彼有苾刍律仪故。不重令出家受戒。所以然者。设彼后时谓是苾刍更舍所学亦不许彼重出家故。于此无义苦救何为。若如是人犹有苾刍性。应自归礼如是类苾刍。正法灭时虽无一切结界羯磨及毗奈耶。未得律仪无新得理。而先得者无有舍义。静虑无漏二律仪等。云何当舍。颂曰

  舍定生善法　　由易地退等
  舍圣由得果　　练根及退失

论曰。诸静虑地所系善法由二缘舍。一由易地。谓从下地生上地时。或上地没来生下地。二由得退。谓从已获胜定功德还退失时。等言为显舍众同分亦舍少分殊胜善根。如色界中所有善法由易地退舍。无色界亦然。唯无律仪与色界异。无漏善法由三缘舍。一由得果谓得果时舍前向道及果道故。二由练根。谓练根位由得利道舍钝道故。三由退失。谓得退时退失果道胜果道故。如是已说舍诸律仪。不律仪云何舍。颂曰

  舍恶戒由死　　得戒二形生

论曰。诸不律仪由三缘舍。一者由死舍所依故。二由得戒。谓若受得别解律仪。或由获得静虑律仪恶戒便舍。由因缘力得律仪时。诸不律仪一切皆断。以善恶戒其性相违。善戒于中势力强故。三由相续二形俱生。以于尔时所依变故。住恶戒者。虽或有时起不作思舍刀网等。若不受得诸善律仪。诸不律仪无容弃舍。譬如虽避发病因缘。不服良药病终难愈。不律仪者。受近住戒至夜尽位舍律仪时。为得不律仪。为名处中者。有余师说。得不律仪。恶阿世耶非永舍故。如停热铁赤灭青生。有余师言。若不更作无缘令彼得不律仪。以不律仪依表得故。处中无表舍复云何。颂曰

  舍中由受势　　作事寿根断

论曰。处中无表舍由六缘。一由受心断坏故舍。谓舍所受。作是念言。我从今时弃先所受。二由势力断坏故舍。谓由净信烦恼势力所引无表。彼二限势若断坏时无表便舍。如所放箭及陶家轮。弦等势力尽时便止。三由作业断坏故舍。谓如所受后更不作。四由事物断坏故舍。事物者何。谓所舍施寺舍敷具制多园林。及所施为罝网等事。五由寿命断坏故舍。谓所依止有转易故。六由善根断坏故舍。谓起加行断善根时。便舍善根所引无表。欲非色善及余一切非色染法舍。复云何。颂曰

  舍欲非色善　　由根断上生
  由对治道生　　舍诸非色染

论曰。欲界一切非色善法舍由二缘。一断善根。二生上界。三界一切非色染法舍由一缘。谓彼但由对治道起。若此品类能断道生。当舍此中所有烦恼及彼助伴。非余方便。善恶律仪何有情有。颂曰

  恶戒人除北　　二黄门二形
  律仪亦在天　　唯人具三种
  生欲天色界　　有静虑律仪
  无漏并无色　　除中定无想

论曰。唯于人趣有不律仪。然除北洲唯三方有。于三洲内。复除扇搋及半择迦具二形者。律仪亦尔。谓于人中除前所除。并天亦有。故于二趣容有律仪。复以何缘知扇搋等所有相续非律仪依。由经律中有诚证故。谓契经说。佛告大名。诸有在家白衣男子男根成就。归佛法僧起殷净心。发诚谛语自称我是邬波索迦。愿尊忆持慈悲护念。齐是名曰邬波索迦。毗奈耶中亦作是说。汝应除弃此色类人。故知律仪非彼类有。复由何理彼无律仪。由二所依所起烦恼于一相续俱增上故。于正思择无堪能故。无有极重惭愧心故。若尔何故无不律仪。彼于恶中心不定故。又若是处有善律仪。则恶律仪于彼亦有。由此二种相翻立故。北俱卢人无受及定。及无造恶胜阿世耶。是故彼无善戒恶戒。猛利惭愧恶趣中无。故律不律仪于彼亦非有。与胜惭愧相应相违。方有律仪不律仪故。又扇搋等如碱卤田故不能生善戒恶戒。世间现见诸碱卤田。不能滋生嘉苗秽草。若尔何故契经中言有卵生龙半月八日。每从宫出来至人间。求受八支近住斋戒。此得妙行。非得律仪。是故律仪唯人天有。然唯人具三种律仪。谓别解脱静虑无漏。若生欲天及生色界。皆容得有静虑律仪。生无色界彼必非有。无漏律仪亦在无色。谓若生在欲界天中及生色界中。除中定无想皆容得有无漏律仪。生无色中唯得成就以无色故必不现起。因辩诸业性相不同。当释经中所摽诸业。且经中说。业有三种。善恶无记。其相云何。颂曰

  安不安非业　　名善恶无记

论曰。如是名为善等业相。谓安隐业说名为善。能得可爱异熟涅槃。暂永二时济众苦故。不安隐业名为不善。由此能招非爱异熟。与前安隐性相违故。非前二业立无记名。不可记为善不善故。又经中说。业有三种。福非福等。其相云何。颂曰

  福非福不动　　欲善业名福
  不善名非福　　上界善不动
  约自地处所　　业果无动故

论曰。欲界善业说名为福。招可爱果益有情故。诸不善业说名非福。招非爱果损有情故。上二界善说名不动。岂不世尊说下三定皆名有动。圣说此中有寻伺等名为动故。由下三定有寻伺等灾患未息故立动名。不动经中据能感得不动异熟说名不动。如何有动定招无动异熟。虽此定中有灾患动。而业对果非如欲界有动转故立不动名。谓欲界中余趣处业。由别缘力异趣处受。以或有业能感外内财位形量色力乐等。于天等中此业应熟。由别缘力所引转故。于人等中此业便熟。色无色界余地处业。无容转令异地处受。业果处定立不动名。又经中说。业有三种。顺乐受等。其相云何。颂曰

  顺乐苦非二　　善至三顺乐
  诸不善顺苦　　上善顺非二
  余说下亦有　　由中招异熟
  又许此三业　　非前后熟故
  顺受总有五　　谓自性相应
  及所缘异熟　　现前差别故

论曰。诸善业中始从欲界至第三静虑名顺乐受业。以诸乐受唯至此故。诸不善业名顺苦受。过三静虑上地诸善业。说名为顺不苦不乐受。此上都无苦乐受故。非此诸业唯感受果。应知亦感彼受资粮。受及资粮此中名受。有余师说。下诸地中亦有第三顺非二业。由中定业招异熟故。若异此者。中间定业应无异熟。或应无业。以无苦乐异熟果故。有余师说。此业能感根本地中乐根异熟。有说。此业不感受果。二说俱与本论相违。故本论言。颇有业感心受异熟非身耶。曰有。谓善无寻业。又本论说。颇有三业非前非后受异熟耶。曰有。谓顺乐受业色。顺苦受业心心所法。顺不苦不乐受业心不相应行。乃至广说。由此证知下地亦有顺非二业。非离欲界有此三业俱时熟故。此业为善为不善耶。是善而劣。若尔便与所说相违。谓善至三名顺乐受。得可爱果名为善业。应知彼据多分为言。此业与受体性既殊。如何说为顺乐受等。业与乐受体性虽殊。而能为因利益乐受。或复此业是乐所受。彼乐如何能受于业。乐是此业异熟果故。或复彼乐是业所受。由此能受乐异熟故。如顺浴散。此亦应然。是故名为顺乐受业。顺余二业应知亦尔。总说顺受略有五种。一自性顺受。谓一切受。如契经说。受乐受时如实了知受于乐受。乃至广说。二相应顺受。谓一切触。如契经说。顺乐受触。乃至广说。三所缘顺受。谓一切境。如契经说。眼见色已。唯受于色不受色贪。乃至广说。由色等是受所缘故。四异熟顺受。谓感异熟业。如契经说。顺现受业。乃至广说。五现前顺受。谓正现行受。如契经言。受乐受时二受便灭。乃至广说。非此乐受现在前时有余受能受此乐受。但据乐受自体现前即说名为受于乐受。此中但说异熟顺受。由业能招受异熟故。虽业与受体性有殊。而得名为顺乐受等。如是三业有定不定。其相云何。颂曰

  此有定不定　　定三顺现等
  或说业有五　　余师说四句

论曰。此上所说顺乐受等。应知各有定不定异。非定受故立不定名。定复有三。一顺现法受。二顺次生受。三顺后次受。此三定业并前不定总成四种。或有欲令不定受业复有二种。谓于异熟有定不定。并定业三合成五种顺现法受者。谓此生造即此生熟。顺次生受者。谓此生造第二生熟。顺后次受者。谓此生造从第三生后次第熟。有余师说。顺现法受业。余生亦得熟。随初熟位建立业名为顺现等。勿强力业异熟果少。毗婆沙师不许此义。以或有业果近非胜。或有相违。譬如外种经三半月葵便结实。要经六月麦方结实。譬喻者说业有四句。一者有业于时分定异熟不定。谓顺现等三非定得异熟。二者有业于异熟定时分不定。谓不定业定得异熟。三者有业于二俱定。谓顺现等定得异熟。四者有业于二俱不定。谓不定业非定得异熟。彼说诸业总成八种。谓顺现受有定不定。乃至不定亦有二种。于此所说业差别中。颂曰

  四善容俱作　　引同分唯三
  诸处造四种　　地狱善除现
  坚于离染地　　异生不造生
  圣不造生后　　并欲有顶退

论曰。顺现法受等三业唯定并不定为四。是说为善。此中唯显时定不定。释经所说四业相故。颇有四业俱时作耶。容有。云何。遣三使已自行邪欲俱时究竟。几业能引众同分耶。能引唯三。除顺现受。现身同分先业引故。何界何趣能造几业。诸界诸趣或善或恶。随其所应皆容造四。总开如是若就别遮。于地狱中善除顺现。无爱果故余皆得造。不退姓名坚。彼于离染地。若异生类除顺生受可造余三。圣者双除顺生顺后可造余二。异生不退无次更生。后还生下。不退圣者必无还生下诸地故。随所生地容造顺现受。造不定业一切处无遮。然诸圣者若于欲界及有顶处已得离染。虽有退堕而亦不造顺生后业。从彼退者必退果故。诸退果已必不命终。如后当辩。住中有位亦造业耶。亦造。云何。颂曰

  欲中有能造　　二十二种业
  皆顺现受摄　　类同分一故

论曰。于欲界中住中有位。容有能造二十二业。谓中有位及处胎中。出胎以后各有五位。胎中五者。一羯剌蓝。二頞部昙。三闭尸。四键南。五钵罗奢佉。胎外五者。一婴孩。二童子。三少年。四中年。五老年。住中有位能造中有乃至老年定不定业。应知如是中有所造十一种定业。皆顺现受摄。由类同分无差别故。谓此中有位与自类十位。一众同分一业引故。由此不别说顺中有受业。即顺生等业所引故。诸定受业其相云何。颂曰

  由重惑净心　　及是恒所造
  于功德田起　　害父母业定

论曰。若所造业。由重烦恼或淳净心。或常所作。或于增上功德田起。功德田者。谓佛法僧。或胜补特伽罗。谓得胜果胜定。于此田所虽无重惑及淳净心亦非常行。若善不善所起诸业。或于父母随轻重心行损害事。如是一切皆定业摄。余非定受。现法果业其相云何。颂曰

  由田意殊胜　　及定招异熟
  得永离地业　　定招现法果

论曰。由田胜者。闻有苾刍于僧众中作女人语。彼于现世转作女人。此等传闻其类非一。由意胜者。闻有黄门救脱诸牛黄门事故。彼于现世转作丈夫。此等传闻事亦非一。或生此地永离此地染。于此地中诸善不善业。于异熟定位不定者。此业必能招现法果。若有余位顺定受业。彼必定无永离染义。必于余位受异熟果。若于异熟亦不定者。永离染故不受异熟。何田起业定即受耶。颂曰

  于佛上首僧　　及灭定无诤
  慈见修道出　　损益业即受

论曰。于如是类功德田中为善恶业定即受果。功德田者。谓佛上首僧。约补特伽罗差别有五。一从灭定出。谓此定中得心寂静。此定寂静似涅槃故。若从此定初起心时。如入涅槃还复出者。二从无诤出。谓此定中有缘无量有情为境。增上利益意乐随逐。出此定时。有为无量最胜功德所熏修身相续而转。三从慈定出。谓此定中有缘无量有情为境。增上安乐意乐随逐。出此定时。有为无量最胜功德所熏修身相续而转。四从见道出。谓此道中永断一切见所断惑得胜转依。从此出时净身续起。五从修道出。谓此道中永断一切修所断惑得胜转依。从此出时净身续起。故说此五名功德田。若有于中为损益业。此业必定能招即果。若从余定余果出时。由前所修定非殊胜修所断惑未毕竟尽故彼相续非胜福田。异熟果中受最为胜。今应思择。于诸业中颇有唯招心受异熟。或招身受非心受耶。亦有。云何。颂曰

  诸善无寻业　　许唯感心受
  恶唯感身受　　是感受业异

论曰。善无寻业。谓从中定乃至有顶所有善业。于中能招受异熟者。应知但感心受非身。身受必与寻伺俱故。诸不善业能感受者。应知但感身受非心。以不善因苦受为果心俱苦受。决定名忧忧非异熟。如前已辩。有情心狂何识因处。颂曰

  心狂唯意识　　由业异熟生
  及怖害违忧　　除北洲在欲

论曰。有情心狂唯在意识。若在五识必无心狂。以五识身无分别故。由五因故有情心狂。一由有情业异熟起。谓由彼用药物咒术令他心狂。或复令他饮非所欲若毒若酒。或现威严怖禽兽等。或放猛火焚烧山泽。或作坑阱陷坠众生。或余事业令他失念。由此业因于当来世感别异熟能令心狂。二由惊怖。谓非人等现可怖形来相逼迫。有情见已遂致心狂。三由伤害。谓因事业恼非人等由彼嗔故伤其支节遂致心狂。四由乖违。谓由身内风热痰界互相违反大种乖适故致心狂。五由愁忧。谓因丧失亲爱等事。愁毒缠怀心遂发狂。如婆私等。若在意识方有心狂。复许心狂业异熟起。如何心受非异熟耶。不说心狂是业异熟。但言是业异熟所生。谓恶业因感不平等异熟大种。依此大种心便失念。故说为狂。如是心狂对于心乱应作四句。谓有心狂而非心乱。乃至广说。狂非乱者。谓诸狂者不染污心。乱非狂者。谓不狂者诸染污心。狂亦乱者。谓诸狂者诸染污心。非狂乱者。谓不狂者不染污心。除北俱卢所余欲界。诸有情类容有心狂。谓欲天心尚有狂者。况人恶趣得离心狂。地狱恒狂。多苦逼故。谓诸地狱恒为种种异类苦具伤害末摩猛利难忍。苦受所逼尚不自识。况了是非。故地狱中怨心伤叹。猖狂驰叫世传有文。欲界圣中唯除诸佛。大种乖适容有心狂。无异熟生。若有定业必应先受后方得圣。若非定业。由得圣故。能令无果亦无惊怖。超五畏故。亦无伤害以诸圣者无非人等憎嫌事故。亦无愁忧证法性故。又经中说。业有三种。谓曲秽浊。其相云何。颂曰

  说曲秽浊业　　依谄嗔贪生

论曰。身语意三各有三种。谓曲秽浊。如其次第应知依谄嗔贪所生。谓依谄生身语意业名为曲业。谄曲类故。若依嗔生身语意业名为秽业。嗔秽类故。若依贪生身语意业名为浊业。贪浊类故

说一切有部俱舍论卷第十五阿毗达磨俱舍论卷第十六

        尊者世亲造

        三藏法师玄奘奉　诏译

    分别业品第四之四

又经中说。业有四种。谓或有业黑黑异熟。或复有业白白异熟。或复有业黑白黑白异熟。或复有业非黑非白无异熟能尽诸业。其相云何。颂曰

  依黑黑等殊　　所说四种业
  恶色欲界善　　能尽彼无漏
  应知如次第　　名黑白俱非

论曰。佛依业果性类不同所治能治殊说黑黑等四。诸不善业一向名黑。染污性故。异熟亦黑。不可意故。色界善业一向名白。不杂恶故。异熟亦白。是可意故。何故不言无色界善。传说若处有二异熟谓中生有。具三种业谓身语意。则说非余。然契经中有处亦说。欲界善业名为黑白。恶所杂故。异熟亦黑白。非爱果杂故。此黑白名依相续立。非据自性。所以者何。以无一业及一异熟是黑亦白。互相违故。岂不恶业果善业果杂故。是则亦应名为白黑。不善业果非必应为善业果杂。欲善业果必定应为恶业果杂。以欲界中恶胜善故。诸无漏业能永断尽前三业者名为非黑。不染污故。亦名非白。以不能招白异熟故。此非白言是密意说。以佛于彼大空经中告阿难陀。诸无学法纯善纯白一向无罪。本论亦言。云何白法。谓诸善法无覆无记。无异熟者不堕界故。与流转法性相违故。诸无漏业为皆能尽前三业不。不尔。云何。颂曰

  四法忍离欲　　前八无间俱
  十二无漏思　　唯尽纯黑业
  离欲四静虑　　第九无间思
  一尽杂纯黑　　四令纯白尽

论曰。于见道中四法智忍。及于修道离欲染位前八无间圣道俱行有十二思唯尽纯黑。离欲界染第九无间圣道俱行一无漏思。双令黑白及纯黑尽。此时总断欲界善故。亦断第九不善业故。离四静虑一一地染。第九无间道俱行无漏思。此四唯令纯白业尽。何缘诸地有漏善法。唯最后道能断非余。以诸善法非自性断。已断有容现在前故。然由缘彼烦恼尽时方说名为断彼善法。尔时善法得离系故。由此乃至缘彼烦恼余一品在。断义不成。善法尔时未离系故。颂曰

  有说地狱受　　余欲业黑杂
  有说欲见灭　　余欲业黑俱

论曰。有余师说。顺地狱受及欲界中顺余受业如次名为纯黑杂业。谓地狱异熟唯不善业感。故顺彼受名纯黑业。唯除地狱余欲界中异熟皆通善恶业感。故顺彼受名黑白业。有余师说。欲见所断及欲界中所有余业。如次名为纯黑俱业。谓见所断无善杂故名纯黑业。欲修所断有善不善故名俱业。又经中说有三牟尼。又经中言有三清净。俱身语意。相各云何。颂曰

  无学身语业　　即意三牟尼
  三清净应知　　即诸三妙行

论曰。无学身语业名身语牟尼。意牟尼即无学意。非意业。所以者何。胜义牟尼唯心为体。谓由身语二业比知。又身语业是远离体。意业不然。无无表故由远离义建立牟尼。是故即心由身语业能有所离故名牟尼。何故牟尼唯在无学。以阿罗汉是实牟尼诸烦恼言永寂静故。诸身语意三种妙行名身语意三种清净。暂永远离一切恶行烦恼垢故名为清净。说此二者为息有情计邪牟尼邪清净故。又经中说有三恶行又经中言有三妙行。俱身语意。相各云何。颂曰

  恶身语意业　　说名三恶行
  及贪嗔邪见　　三妙行翻此

论曰。一切不善身语意业。如次名身语意恶行。然意恶行复有三种。谓非意业贪嗔邪见。贪等离思别有体故。譬喻者言。贪嗔邪见即是意业。故思经中说此三种为意业故。若尔则应业与烦恼合成一体。许有烦恼即是意业斯有何失。毗婆沙师说。彼非理若许尔者。便与众多理教相违成大过失。然契经说是意业者。显思以彼为门转故。由此能感非爱果故。是聪慧者所诃厌故。此行即恶。故名恶行。三妙行者。翻此应知。谓身语意一切善业。非业无贪无嗔正见。正见邪见。既无故思欲益他损他。如何成善恶。能与损益为根本故。又经中言有十业道。或善或恶。其相云何。颂曰

  所说十业道　　摄恶妙行中
  粗品为其性　　如应成善恶

论曰。于前所说。恶妙行中若粗显易知摄为十业道。如应若善摄前妙行。不善业道摄前恶行。不摄何等恶妙行耶。且不善中身恶业道。于身恶行不摄一分。谓加行后起余不善身业。即饮诸酒执打缚等。以加行等非粗显故。若身恶行令他有情失命失财失妻妾等说为业道。令远离故。语恶业道于语恶行不摄加行后起及轻。意恶业道于意恶行不摄恶思及轻贪等。善业道中身善业道于身妙行不摄一分。谓加行后起及余善身业。即离饮酒施供养等。语善业道于语妙行不摄一分。谓爱语等。意善业道于意妙行不摄一分。谓诸善思。十业道中。前七业道为皆定有表无表耶。不尔。云何。颂曰

  恶六定无表　　彼自作淫二
  善七受生二　　定生唯无表

论曰。七恶业道中。六定有无表。谓杀生不与取虚诳语离间语粗恶语杂秽语。如是六种若遣他为。根本成时自表无故。若有自作彼六业道。则六皆有表无表二。谓起表时彼便死等。后方死等与遣使同。根本成时唯无表故。唯欲邪行必具二种。要是自身所究竟故。非遣他作。如自生喜。七善业道若从受生。必皆具二。谓表无表。受生尸罗必依表故。静虑无漏所摄律仪名为定生。此唯无表。但依心力而得生故。加行后起如根本耶。不尔。云何。颂曰

  加行定有表　　无表或有无
  后起此相违

论曰。业道加行必定有表。此位无表或有或无。若猛利缠淳净心起则有无表。异此则无。后起翻前。定有无表。此位表业或有或无。谓若后时起随前业。则有表业。异此便无。于此义中如何建立加行根本后起位耶。且不善中最初杀业。如屠羊者将行杀时。先发杀心从床而起。执持价直趣卖羊廛。[捐-口+左]触羊身酬价捉取。牵还养饭将入屠坊。手执杖刀若打若刺。或一或再至命未终。如是皆名杀生加行。随此表业彼正命终。此刹那顷表无表业。是谓杀生根本业道。由二缘故。令诸有情根本业道杀罪所触。一由加行。二由果满。此刹那后杀无表业随转不绝名杀后起。及于后时剥截治洗。若称若卖或煮或食赞述其美表业刹那。如是亦名杀生后起。余六业道随其所应三分不同。准例应说。贪嗔邪见才现在前。即说名为根本业道。故无加行后起差别。此中应说。为所杀生住死有时能杀生者彼刹那顷表无表业即成业道。为死后耶。若尔何失。二俱有过。若所杀生正住死有能杀生者业道即成。即能杀者与所杀生。俱时命终应成业道。然宗不许彼业道成。若所杀生命终以后。能杀生者业道方成。是即不应先作是说。随此表业彼正命终。此刹那顷表无表业。是谓杀生根本业道。又应违害毗婆沙师释本论中加行未息。谓本论说颇有已害生杀生未灭耶。曰有。如已断生命彼加行未息。毗婆沙者释此文言。此中于后起以加行声说。应言于根本说加行声。许命终后根本未息故。如无有过此中应说。此中说何名为无过。谓于根本说加行声。若尔于时所有表业如何可成根本业道。何为不成。以无用故。无表于此有何用耶。故业道成非由有用。但由加行果圆满时。此二俱成根本业道。又诸业道展转相望容有互为加行后起。今且应说杀生业道以十业道为起加行。谓如有人欲害怨敌。设诸谋计合构杀缘。或杀众生祈请助力。或盗他物以资杀事。或淫彼妇令杀其夫。或为乖离彼亲友故起语四过令生猜阻。设有势力无救护心。或于彼财心生贪着。或即于彼起嗔恚心。或起邪见长养杀业然后方杀。如是名为以十业道为杀加行。杀怨敌已复于后时诛其所亲收其财物淫彼所爱。乃至复起贪嗔邪见。次第现前。此十名为杀生后起。所余业道如应当知。贪等不应能为加行。非唯心起加行即成。唯起心时未作事故。又经中说。苾刍当知。杀有三种。一从贪生。二从嗔生。三从痴生。乃至邪见有三亦尔。此中应说。何相杀生名从贪生。问余亦尔。非诸业道一切皆由三根究竟。然其加行不与彼同。云何不同。颂曰

  加行三根起　　彼无间生故
  贪等三根生

论曰。不善业道加行生时。一一由三不善根起。依先等起故作是说。杀生加行由贪起者。如有为欲得彼身分或为得财或为戏乐或为拔济亲友自身。从贪引起杀生加行。从嗔起者。如为除怨发愤恚心起杀加行。从痴起者。如有祠中谓是法心起杀加行。又诸王等依世法律。诛戮怨敌除剪凶徒。谓成大福起杀加行。又波剌私作如是说。父母老病若令命终得免困苦便生胜福。又诸外道有作是言。蛇蝎蜂等为人毒害。若能杀者便生胜福。羊鹿水牛及余禽兽。本拟供食故杀无罪。又因邪见杀害众生。此等加行皆从痴起。偷盗加行从贪起者。谓随所须起盗加行。或为别利恭敬名誉。或为救拔自身亲友。从贪引起偷盗加行。从嗔起者。谓为除怨发愤恚心起盗加行。从痴起者。谓诸王等依世法律夺恶人财。谓法应尔无偷盗罪。又婆罗门作如是说。世间财物于劫初时。大梵天王施诸梵志。于后梵志势力微劣。为诸卑族侵夺受用。今诸梵志于世他财若夺若偷。充衣充食或充余用。或转施他皆用己财无偷盗罪。然彼取时有他物想。又因邪见盗他财物。皆名从痴起盗加行。邪淫加行从贪起者。谓于他妻等起染着心。或为求他财名位恭敬。或为救拔自身他身。从贪着心起淫加行。从嗔生者。谓为除怨发愤恚心起淫加行。从痴生者。如波剌私赞于母等行非梵行。又诸梵志赞牛祠中有诸女男受持牛禁吸水啮草或住或行。不简亲疏随遇随合。又诸外道作如是言。一切女人如臼花果熟食阶蹬道路桥船。世间众人应共受用。此等加行从痴所生。虚诳语等语四业道从贪嗔生。类前应说。然虚诳语所有加行从痴生者。如外论言

  若人因戏笑　　嫁娶对女王
  及救命救财　　虚诳语无罪

又因邪见起虚诳语离间语等所有加行。当知一切从痴所生。又诸吠陀及余邪论。皆杂秽语摄。加行从痴生。贪嗔等三既无加行。如何可说从贪等生。以从三根无间生故。可说贪等从三根生。谓或有时从贪无间生贪业道。从二亦然。嗔及邪见从三亦尔。已说不善从三根生。善复云何。颂曰

  善于三位中　　皆三善根起

论曰。诸善业道所有加行根本后起。皆从无贪无嗔无痴善根所起。以善三位皆是善心所等起故。善心必与三种善根共相应故。此善三位其相云何。谓远离前不善三位离恶加行即善加行。离恶根本即善根本。离恶后起即善后起。且如勤策受具戒时。来入戒坛礼苾刍众。至诚发语请亲教师。乃至一白二羯磨等。皆名为善业道加行。第三羯磨竟一刹那中表无表业名根本业道。从此以后至说四依及余依前相续随转表无表业皆名后起。如先所说。非诸业道一切皆由三根究竟。何根究竟何业道耶。颂曰

  杀粗语嗔恚　　究竟皆由嗔
  盗邪行及贪　　皆由贪究竟
  邪见痴究竟　　许所余由三

论曰。恶业道中杀生粗语嗔恚业道由嗔究竟。要无所顾极粗恶心现在前时。此三成故。诸不与取欲邪行贪。此三业道由贪究竟。要有所顾极染污心现在前时。此三成故。邪见究竟要由愚痴。由上品痴现前成故。虚诳离间杂秽语三许一一由三根究竟。以贪嗔等现在前时一一能令此三成故。诸恶业道何处起耶。颂曰

  有情具名色　　名身等处起

论曰。如前所说四节业道。三三一三随其次第于有情等四处而生。谓杀等三有情处起。偷盗等三众具处起。唯邪见一名色处起。虚诳语等三名身等处起。有起加行定欲杀他。而与所杀生俱死或前死亦得根本业道罪耶。颂曰

  俱死及前死　　无根依别故

论曰。若能杀者与所杀生俱时命终。或在前死。彼定不得根本业道故。有问言。颇有杀者起杀加行及令果满而彼不为杀罪触耶。曰有。云何。谓能杀者与所杀生俱死前死。何缘如是。以所杀生其命犹存不可令彼能杀生者成杀罪故。非能杀者其命已终可得杀罪。别依生故。谓杀加行所依止身今已断灭。虽有别类身同分生。非罪依止。此曾未起杀生加行。成杀业道理不应然。若有多人集为军众欲杀怨敌。或猎兽等。于中随有一杀生时。何人得成杀生业道。颂曰

  军等若同事　　皆成如作者

论曰。于军等中若随有一作杀生事。如自作者一切皆成杀生业道。由彼同许为一事故。如为一事展转相教。故一杀生余皆得罪。若有他力逼入此中。因即同心亦成杀罪。唯除若有立誓自要救自命缘。亦不行杀。虽由他力逼在此中。而无杀心故无杀罪。今次应辩成业道相。谓齐何量名曰杀生。乃至齐何名为邪见。且先分别杀生相者。颂曰

  杀生由故思　　他想不误杀

论曰。要由先发欲杀故思于他有情他有情想作杀加行不误而杀。谓唯杀彼不漫杀余。齐此名为杀生业道。有犹豫杀亦成杀生。谓彼先于所欲杀境心怀犹豫为生非生。设复是生为彼非彼。后起决志若是若非我定当杀。由心无顾。若杀有情亦成业道。于刹那灭蕴如何成杀生。息风名生。依身心转。若有令断不更续生。如灭灯光铃声名杀。或复生者即是命根。若有令断不续名杀。谓以恶心隔断他命。乃至一念应生不生。唯此非余杀罪所触。此所断命为属于谁。谓命若无彼便死者。既标第六非我而谁。破我论中当广思择。故薄伽梵所说颂言

  寿暖及与识　　三法舍身时
  所舍身僵仆　　如木无思觉

故有根身名有命者。无根名死。其理决然。离系者言。不思而杀亦得杀罪。犹如触火设不先思亦被烧害。若尔汝等遇见他妻。或误触身亦应有罪。又善心者拔离系发。或师慈心劝修苦行。或因施主宿食不消。此等皆应获苦他罪。又胎与母互为苦因。应母与胎有苦他罪。又所杀者既与杀合。亦应如火能烧自依。不应但令能杀得罪。又遣他杀杀罪应无。如火不烧教触火者。又诸木等应为罪触。如舍等崩亦害生故。又非但喻立义可成。已分别杀生。当辩不与取。颂曰

  不与取他物　　力窃取属己

论曰。前不误等如其所应。流至后门故不重说。谓要先发欲盗故思。于他物中起他物想。或力或窃起盗加行。不误而取令属己身。齐此名为不与取罪。若有盗取窣堵波物。彼于如来得偷盗罪。以佛临欲入涅槃时哀愍世间总受所施。有余师说。望守护者。若有掘取无主伏藏。于国主边得偷盗罪。若有盗取诸回转物。已作羯磨于界内僧。若羯磨未成。普于佛弟子得偷盗罪。余例应思。已辩不与取。当辩欲邪行。颂曰

  欲邪行四种　　行所不应行

论曰。总有四种行不应行。皆得名为欲邪行罪。一于非境行不应行。谓行于他所摄妻妾或母或父或父母亲乃至或王所守护境。二于非道行不应行。谓于自妻口及余道。三于非处行不应行。谓于寺中制多迥处。四于非时行不应行。非时者何。谓怀胎时饮儿乳时受斋戒时。设自妻妾亦犯邪行。有说。若夫许受斋戒而有所犯方谓非时。既不误言亦流至此。若于他妇谓是己妻。或于己妻谓为他妇。道非道等但有误心虽有所行而非业道。若于此他妇作余他妇想行非梵行成业道耶。有说亦成。以于他妇起淫加行及受用故。有说不成。如杀业道于此起加行于余究竟故。于苾刍尼行非梵行。为从何处得业道耶。此从国王不忍许故。于自妻妾受斋戒时尚不应行。况出家者。若于童女行非梵行。为从何处得业道耶。若已许他于所许处。未许他者于能护人。此及所余皆于王得。已辩欲邪行。当辩虚诳语。颂曰

  染异想发言　　解义虚诳语

论曰。于所说义异想发言。及所诳者解所说义。染心不误成虚诳语。若所诳者未解言义。此言是何。是杂秽语。既虚诳语是所发言有多字成言。何时成业道。与最后字俱生表声及无表业成此业道。或随何时所诳解义。表无表业成此业道。前字俱行皆此加行。所言解义定据何时。为据已闻正解名解。为据正闻能解名解。若尔何失。若据已闻正解名解。言所诠义意识所知。语表耳识俱时灭故。应此业道唯无表成。若据正闻能解名解。虽无有失然未了知。如何正闻可名能解。善言义者无迷乱缘。耳识已生名为能解。如无失者应取为宗。经说诸言略有十六。谓于不见不闻不觉不知事中言实见等或于所见所闻所觉所知事中言不见等。如是八种名非圣言。若于不见乃至不知言不见等或于所见乃至所知言实见等。如是八种名为圣言。何等名为所见等相。颂曰

  由眼耳意识　　并余三所证
  如次第名为　　所见闻知觉

论曰。毗婆沙师作如是说。若境由眼识所证名所见。若境由耳识所证名所闻。若境由意识所证名所知。若境由鼻识舌识及身识所证名所觉。所以然者。香味触三无记性故如死无觉。故能证者偏立觉名。何证知然。由经理证。言由经者。谓契经说。佛告大母。汝意云何。诸所有色非汝眼见。非汝曾见。非汝当见。非希求见。汝为因此起欲起贪起亲起爱起阿赖耶起尼延底起耽着不。不尔。大德。诸所有声非汝耳闻。广说乃至诸所有法非汝意知。广说乃至。不尔。大德。复告大母。汝于此中应知所见。虽有所见应知所闻所觉所知。唯有所闻所觉所知。此经既于色声法境。说为所见所闻所知。准此定于香等三境。总合建立一所觉名。若不许然何名所觉。又香味触在所见等外。于彼三境应不起言说。是名为理。此证不成。且经非证。经义别故。非此经中世尊为欲决判见等四所言相。然见此经所说义者。谓佛劝彼于六境中。及于见等四所言事。应知但有所见等言。不应增益爱非爱相。若尔何相名所见等。有余师说。若是五根现所证境名为所见。若他传说名为所闻。若运自心以种种理。比度所许名为所觉。若意现证名为所知。于五境中一一容起见闻觉知四种言说。于第六境除见有三。由此觉名非无所目。香等三境言说非无。故彼理言亦为无理。先轨范师作如是说。眼所现见名为所见。从他传闻名为所闻。自运己心诸所思构名为所觉。自内所受及自所证名为所知。且止傍言应申正论。颇有由身表异想义不由发语成虚诳语耶。曰有。故论言。颇有不动身杀生罪触耶。曰有。谓发语。颇有不发语诳语罪触耶。曰有。谓动身。颇有不动身不发语二罪所触耶。曰有。谓仙人意愤及布洒他时。若不动身亦不发语。欲无无表离表而生。此二如何得成业道。于如是难应设劬劳。已辩虚诳语。当辩余三语。颂曰

  染心坏他语　　说名离间语
  非爱粗恶语　　诸染杂秽语
  余说异三染　　佞歌邪论等

论曰。若染污心发坏他语。若他坏不坏俱成离间语。解义不误流至此中。若以染心发非爱语毁呰于他名粗恶语。前染心语流至此故。解义不误亦与前同。谓本期心所欲骂者。解所说义业道方成。一切染心所发诸语名杂秽语。所以者何。染所发言皆杂秽语故。唯前语字流至此中。有余师说。异虚诳等前三种语所有一切染心发言名杂秽语。此谓佞歌及邪论等。佞谓谄佞。如有苾刍邪命居怀发谄佞语。歌谓歌咏。如世有人以染污心讽吟相调。及倡妓者为悦他情以染污心作诸词曲。言邪论者。谓广辩说诸不正见所执言词。等谓染心所发悲叹。及诸世俗戏论言词。但异前三染心所发一切皆是杂秽语收。轮王现时亦有歌咏。如何不是杂秽语收。由彼语从出离心发能引出离非预染心。有余师言。尔时亦有成嫁娶等所发染言。由过轻故不成业道。已辩三语。当辩意三。颂曰

  恶欲他财贪　　憎有情嗔恚
  拨善恶等见　　名邪见业道

论曰。于他财物恶欲名贪。谓于他财非理起欲。如何令彼属我非他。起力窃心耽求他物。如是恶欲名贪业道。有余师言。诸欲界爱皆贪业道。所以者何。五盖经中依贪欲盖佛说应断此世间贪。故知贪名总说欲爱。有说。欲爱虽尽名贪。而不可说皆成业道。此恶行中摄粗品故。勿轮王世及北俱卢所起欲贪成贪业道。于有情类憎恚名嗔。谓于他有情欲为伤害事。如是憎恚名嗔业道。于善恶等恶见拨无。此见名为邪见业道。如经说。无施与无爱乐无祠祀无妙行无恶行。无妙恶行业果异熟。无此世间无彼世间。无母无父。无化生有情世间无沙门。或婆罗门是阿罗汉。彼经具显谤业谤果谤圣邪见。此颂举初等言摄后

说一切有部俱舍论卷第十六阿毗达磨俱舍论卷第十七

        尊者世亲造

        三藏法师玄奘奉　诏译

    分别业品第四之五

如是已辩十业道相。依何义名业道。颂曰

  此中三唯道　　七业亦道故

论曰。十业道中后三唯道。业之道故立业道名。彼相应思说名为业。彼转故转。彼行故行。如彼势力而造作故。前七是业。身语业故。亦业之道。思所游故。由能等起身语业思托身语业为境转故。业业之道立业道名。故于此中言业道者。具显业道业业道义。虽不同类而一为余。于世典中俱极成故。离杀等七无贪等三立业道名类此应释。此加行后起何缘非业道。为此依此彼方转故。又前说此摄粗品故。又若由此有减有增令内外物有增有减立为业道。异此不然。譬喻论师执贪嗔等即是意业。依何义释彼名业道。应问彼师。然亦可言。彼是意业恶趣道故立业道名。或互相乘皆名业道。如是所说十恶业道。皆与善法现起相违。诸断善根由何业道。断续善相差别云何。颂曰

  唯邪见断善　　所断欲生得
  拨因果一切　　渐断二俱舍
  人三洲男女　　见行断非得
  续善疑有见　　顿现除逆者

论曰。恶业道中唯有上品圆满邪见能断善根。若尔何缘本论中说云何上品诸不善根。谓诸不善根能断善根者。或离欲位最初所除。由不善根能引邪见。故邪见事推在彼根。如火烧村火由贼起故世间说彼贼烧村。何等善根为此所断。谓唯欲界生得善根。色无色善先不成故。施设足论当云何通。如彼论言。唯由此量是人已断三界善根。依上善根得更远说。令此相续非彼器故。何缘唯断生得善根。加行善根先已退故。缘何邪见能断善根。谓定拨无因果邪见。拨无因者。谓定拨无妙行恶行。拨无果者。谓定拨无彼果异熟。有余师说。此二邪见犹如无间解脱道别。有余师说。断善邪见唯缘有漏。非无漏缘。唯自界缘不缘他界。由彼唯作相应随眠。境不随增。势力劣故。如是说者通一切缘。随因亦增。有强力故。有余师说。九品善根由一刹那邪见顿断。如见道断见所断惑。如是说者渐断善根。谓九品善根由九品邪见逆顺相对渐次而断。如修道断修所断惑。即下下邪见。能断上上善根。乃至下下善根。上上邪见所断。若作是说符本论文。如本论言。云何名微俱行善根。谓断善根时最后所舍者。由舍彼故名断善根。若尔彼文何理复说云何上品诸不善根。谓诸不善根能断善根者。彼依究竟密说此言。由此善根断无余故。谓若犹有一品善根。余品善根因斯可起。未可说彼名断善根。断究竟时方名断善。故唯说上品名能断善根。有余师言。断九品善终无中出如见道中。如是说者通出不出。有余师说先舍律仪后断善根。未易舍故。如是说者若彼律仪是此品心所等起果。此品心断舍彼律仪。以果与因品类同故。为在何处能断善根。人趣三洲非在恶趣。亦非天趣。所以者何。以恶趣中染不染慧不坚牢故。以天趣中现见善恶诸业果故。言三洲者。除北俱卢。彼无极恶阿世耶故。有余师说。唯赡部洲。若尔便违本论所说。如本论说。赡部洲人极少成八根。东西洲亦尔。如是断善依何类身。唯男女身。志意定故。有余师说。亦非女身。欲勤慧等皆昧钝故。若尔便违本论所说。如本论说。若成女根定成八根。男根亦尔。为何行者能断善根。唯见行人非爱行者。诸爱行者恶阿世耶极躁动故。诸见行者恶阿世耶极坚深故。由斯理趣非扇搋等能断善根。爱行类故。又此类人如恶趣故。此善根断其体是何。善断应知非得为体。以断善位善得不生。非得续生替善根得非得生位名断善根。故断善根非得为体。善根断已由何复续。由疑有见。谓因果中有时生疑。此或应有。或生正见定有非无。尔时善根得还续起。善得起故名续善根。有余师言。九品渐续。如是说者顿续善根。然后后时渐渐现起。如顿除病气力渐增。于现身中能续善不。亦有能续除造逆人。经依彼人作如是说。彼定于现法不能续善根。彼人定从地狱将殁。或即于彼将受生时能续善根。非余位故。言将生位。谓中有中。将殁时言。谓彼将死。若由因力彼断善根将死时续。若由缘力彼断善根将生时续。由自他力应知亦尔。又意乐坏非加行坏断善根者。是人现世能续善根。若意乐坏加行亦坏断善根者。要身坏后方续善根。见坏戒不坏见坏戒亦坏断善根者应知亦尔。有断善根非堕邪定。应作四句。第一句者。谓布剌拏等。第二句者。谓未生怨等。第三句者。谓天授等。第四句者。谓除前相。已乘义便辩断善根。今应复明本业道义。所说善恶二业道中。有几并生与思俱转。颂曰

  业道思俱转　　不善一至八
  善总开至十　　别遮一八五

论曰。于诸业道思俱转中。且不善与思从一唯至八。一俱转者。谓离所余贪等三中随一现起。若先加行造恶色业不染心时随一究竟。二俱转者。谓嗔心时究竟杀业。若起贪位成不与取或欲邪行或杂秽语。三俱转者。谓以嗔心于属他生俱时杀盗。若尔所说偷盗业道由贪究竟理应不成。依不异心所作究竟故作如是决判应知。若先加行造恶色业贪等起时随二究竟。四俱转者。谓欲坏他说虚诳言或粗恶语意业道一语业道三。若先加行造恶色业贪等现前随三究竟。如是五六七皆如理应知。八俱转者。谓先加行造作所余六恶色业。自行邪欲俱时究竟。后三业道自力现前必不俱行故无九十。如是已说不善业道与思俱转数有不同。善业道与思总开容至十。别据显相遮一八五。二俱转者。谓善五识及依无色尽无生智现在前时无散善七。三俱转者。谓与正见相应意识现在前时无七色善。四俱转者。谓恶无记心现在前位。得近住近事勤策律仪。六俱转者。谓善五识现在前时得上三戒。七俱转者。谓善意识无随转色。正见相应现在前时得上三戒。或恶无记心现前时得苾刍戒。九俱转者。谓善五识现在前时得苾刍戒。或依无色尽无生智现在前时得苾刍戒。或静虑摄尽无生智相应意识现在前时。十俱转者。谓善意识无随转色正见相应现在前时得苾刍戒。或余一切有随转色正见相应心正起位。别据显相所遮如是。通据隐显则无所遮。谓离律仪有一八五。一俱转者。谓恶无记心现在前时得一支远离。五俱转者。谓善意识无随转色正见相应现在前时得二支等。八俱转者。谓此意识现在前时得五支等。善恶业道于何界趣处。几唯成就几亦通现行。颂曰

  不善地狱中　　粗杂嗔通二
  贪邪见成就　　北洲成后三
  杂语通现成　　余欲十通二
  善于一切处　　后三通现成
  无色无想天　　前七唯成就
  余处通成现　　除地狱北洲

论曰。且于不善十业道中。那落迦中三通二种。为粗恶语杂秽语嗔三种皆通现行成就。由相骂故有粗恶语。由悲叫故有杂秽语。身心粗强[怡-台+龍]悷不调。由互相憎故有嗔恚。贪及邪见成而不行。无可爱境故。现见业果故。业尽死故无杀业道。无摄财物及女人故。无不与取及欲邪行。以无用故无虚诳语。即由此故及常离故无离间语。北俱卢洲贪嗔邪见皆定成就而不现行。不摄我所故。身心柔软故。无恼害事故。无恶意乐故。唯杂秽语通现及成。由彼有时染心歌咏。无恶意乐故。彼无杀生等。寿量定故。无摄财物及女人故。身心软故。及无用故。随其所应。彼人云何行非梵行。谓彼男女互起染时。执手相牵往诣树下。树枝垂覆知是应行。树不垂枝并愧而别。除前地狱北俱卢洲余欲界中十皆通二。谓于欲界天鬼傍生及人三洲十恶业道皆通成现。然有差别。谓天鬼傍生。前七业道唯有处中摄无不律仪。人三洲中二种俱有。虽诸天众无有杀天。而或有时杀害余趣。有余师说。天亦杀天。斩首截腰其命方断。已说不善。善业道中无贪等三于三界五趣皆通二种。谓成就现行。身语七支无色无想但容成就必不现行。谓圣有情生无色界。成就过未无漏律仪。无想有情必成过未第四静虑静虑律仪。然圣随依何地依止曾起曾灭无漏律仪。生无色时成彼过去。若未来世依五地身。无漏律仪皆得成就余界趣处除地狱北洲。七善皆通现行及成就。然有差别。谓鬼傍生有离律仪处中业道。若于色界唯有律仪。三洲欲天皆具二种。不善善业道所得果云何。颂曰

  皆能招异熟　　等流增上果
  此令他受苦　　断命坏威故

论曰。且先分别十恶业道各招三果。其三者何。异熟等流增上别故。谓于十种若习若修若多所作。由此力故。生那落迦是异熟果。从彼出已来生此间。人同分中受等流果。谓杀生者寿量短促。不与取者资财乏匮。欲邪行者妻不贞良。虚诳语者多遭诽谤。离间语者亲友乖穆。粗恶语者恒闻恶声。杂秽语者言不威肃。贪者贪盛。嗔者嗔增。邪见者增痴。彼品痴增故。是名业道等流果别。人中短寿亦善业果。如何可说是杀等流。不言人寿即杀业果。但言由杀人寿量短。应知杀业与人命根作障碍因令不久住。此十所得增上果者。谓外所有诸资生具。由杀生故光泽鲜少。不与取故多遭霜雹。欲邪行故多诸尘埃。虚诳语故多诸臭秽。离间语故所居险曲。粗恶语故田多荆棘硗确碱卤稼穑匪宜。杂秽语故时候变改。贪故果少。嗔故果辣。由邪见故果少或无。是名业道增上果别。为一杀业感那落迦异熟果已复令人趣寿量短促。为更有余。有余师言。即一杀业先感彼异熟后感此等流。有余复言。二果因别。先谓加行后谓根本。虽复总说一杀生言。而实通收根本眷属。此中所说等流果言非越异熟及增上果。据少相似假说等流。此十何缘各招三果。且初杀业于杀他位令他受苦断命失威。谓杀生时令他受苦故堕于地狱受苦异熟果。断他命故来生人中受命短促为等流果。坏他威故感诸外物鲜少光泽为增上果。余恶业道如理应思。由此应准知善业道三果。谓离杀等若习若修若多所作。由此力故。生于天中受异熟果。从彼殁已来生此间。人同分中受等流果。谓离杀者得寿命长。余上相违如理应说。又契经说。八邪支中分色业为三。谓邪语业命。离邪语业邪命是何。虽离彼无。而别说者。颂曰

  贪生身语业　　邪命难除故
  执命资贪生　　违经故非理

论曰。嗔痴所生语身二业。如次名为邪语邪业。从贪所生身语二业。以难除故别立邪命。谓贪能夺诸有情心。彼所起业难可禁护。为于正命令殷重修故。佛离前别说为一。如有颂曰

  俗邪见难除　　由恒执异见
  道邪命难护　　由资具属他

有余师执。缘命资具贪欲所生身语二业方名邪命。非余贪生。所以者何。为自戏乐作歌舞等。非资命故。此违经故。理定不然。戒蕴经中观象斗等。世尊亦立在邪命中。邪受外境虚延命故。正语业命翻此应知。如前所言果有五种。此中何业有几果耶。颂曰

  断道有漏业　　具足有五果
  无漏业有四　　谓唯除异熟
  余有漏善恶　　亦四除离系
  余无漏无记　　三除前所除

论曰。道能证断。及能断惑。得断道名。即无间道。此道有二种。谓有漏无漏。有漏道业具有五果。异熟果者。谓自地中断道所招可爱异熟。等流果者。谓自地中后等若增诸相似法。离系果者。谓此道力断惑所证择灭无为。士用果者。谓道所牵俱有解脱所修及断。增上果者。谓离自性余有为法。唯除前生。即断道中无漏道业唯有四果。谓除异熟。余有漏善及不善业亦有四果。谓除离系。异前断道故说为余。次后余言例此应释。谓余无漏及无记业。唯有三果除前所除。谓除前所除异熟及离系。已总分别诸业有果。次辩异门业有果相。于中先辩善等三业。颂曰

  善等于善等　　初有四二三
  中有二三四　　后二三三果

论曰。最后所说皆如次言。显随所应遍前门义。且善不善无记三业一一为因。如其次第对善不善无记三法辩有果数。后例应知。谓初善业以善法为四果除异熟。以不善为二果。谓士用及增上。以无记为三果。除等流及离系。中不善业以善法为二果。谓士用及增上。以不善为三果。除异熟及离系。以无记为四果。除离系。等流云何。谓遍行不善及见苦所断余不善业。以有身见边执见品诸无记法为等流故。后无记业以善法为二果。谓士用及增上。以不善为三果。除异熟及离系。等流云何。谓有身见边执见品诸无记业。以诸不善为等流故。以无记为三果。除异熟及离系。已辩三性。当辩三世。颂曰

  过于三各四　　现于未亦尔
  现于现二果　　未于未果三

论曰。过去现在未来三业一一为因。如其所应以过去等为果别者。谓过去业以三世法各为四果。唯除离系。现在业以未来为四果如前说。以现在为二果。谓士用及增上。未来业以未来为三果。除等流及离系。不说后业有前果者。前法定非后业果故。已辩三世。当辩诸地。颂曰

  同地有四果　　异地二或三

论曰。于诸地中随何地业以同地法为四果。除离系。若是有漏以异地法为二果。谓士用及增上。若是无漏以异地法为三果。除异熟及离系。不堕界故不遮等流已辩诸地。当辩学等。颂曰

  学于三各三　　无学一三二
  非学非无学　　有二二五果

论曰。学无学非学非无学三业一一为因。如其次第各以三法为果别者。谓学业以学法为三果。除异熟及离系。以无学法为三亦尔。以非二为三果。除异熟及等流。无学业以学法为一果。谓增上。以无学为三果除异熟及离系。以非二为二果。谓士用及增上。非二业以学法为二果。谓士用及增上。以无学法为二亦尔。以非二为五果。已辩学等。当辩见所断等。颂曰

  见所断业等　　一一各于三
  初有三四一　　中二四三果
  后有一二四　　皆如次应知

论曰。见所断修所断非所断三业一一为因。如其次第各以三法为果别者。初见所断业以见所断法为三果。除异熟及离系。以修所断法为四果。除离系。以非所断法为一果。谓增上。果修所断业以见所断法为二果。谓士用及增上。以修所断法为四果。除离系。以非所断法为三果。除异熟及等流。后非所断业以见所断法为一果。谓增上。以修所断法为二果。谓士用及增上。以非所断法为四果。除异熟。皆如次者。随其所应遍上诸门。略法应尔。因辩诸业应复问言。如本论中所说三业。谓应作业不应作业。及非应作非不应作业。其相云何。颂曰

  染业不应作　　有说亦坏轨
  应作业翻此　　俱相违第三

论曰。有说。染业名不应作。以从非理作意所生。有余师言。诸坏轨则身语意业亦不应作。谓诸所有应如是行。应如是住。应如是说。应如是着衣。应如是食等。若不如是名不应作。由彼不合世俗礼仪。与此相翻名应作业。有说。善业名为应作。以从如理作意所生。有余师言。诸合轨则身语意业亦名应作。俱违前二名为第三。随其所应二说差别。为由一业但引一生。为引多生。又为一生但一业引。为多业引。颂曰

  一业引一生　　多业能圆满

论曰。依我所宗应作是说。但由一业唯引一生。此一生言显一同分。以得同分方说名生。若尔何缘尊者无灭自言。我忆昔于一时于殊胜福田一施食异熟便得七返生三十三天。七生人中为转轮圣帝。最后生在大释迦家丰足珍财多受快乐。彼由一业感一生中大贵多财及宿生智。乘斯更造感余生福。如是展转至最后身生富贵家得究竟果。显由初力故作是言。譬如有人持金钱一。展转贸易得千金钱。唱如是言。我本由有一金钱故获大富乐。复有说者。彼于昔时一施食。为依起多胜思愿有感天上。有感人中。刹那不同熟有先后。故非一业能引多生。亦无一生多业所引。勿众同分分分差别。虽但一业引一同分。而彼圆满许由多业。譬如画师先以一色图其形状后填众彩。是故虽有同禀人身。而于其中有具支体诸根形量色力庄严。或有于前多缺减者。非唯业力能引满生。一切不善善有漏法有异熟故皆容引满。以业胜故但标业名。然于其中业俱有者能引能满。随业胜故。若不与业为俱有者。能满非引。势力劣故。如是二类其体是何。颂曰

  二无心定得　　不能引余通

论曰。二无心定虽有异熟。而无势力引众同分。以与诸业非俱有故。得亦无力引众同分。以与诸业非一果故。所余一切皆通引满。薄伽梵说。重障有三。谓业障烦恼障异熟障。如是三障其体是何。颂曰

  三障无间业　　及数行烦恼
  并一切恶趣　　北洲无想天

论曰。言无间业者。谓五无间业。其五者何。一者害母。二者害父。三者害阿罗汉。四者破和合僧。五者恶心出佛身血。如是五种名为业障。烦恼有二。一者数行。谓恒起烦恼。二者猛利。谓上品烦恼。应知此中唯数行者名烦恼障。如扇搋等。烦恼数行难可伏除故说为障。上品烦恼虽复猛利非恒起故易可伏除。于下品中数行烦恼虽非猛利而难伏除。由彼恒行难得便故。谓从下品为缘生中。中品为缘复生上品。令伏除道无便得生。故烦恼中随品上下。但数行者名烦恼障。全三恶趣人趣北洲及无想天名异熟障。此障何法。谓障圣道及障圣道加行善根。又业障中理亦应说余决定业。谓余一切定感恶趣卵生湿生及女人身第八有等。然若有业由五因缘易见易知。此中偏说。谓处趣生果及补特伽罗。于诸业中唯五无间具此五种易见易知。余业不然故此不说。余障废立如应当知。此三障中烦恼与业二障皆重。以有此者第二生内亦不可治。毗婆沙师作如是释。由前能引后故后轻于前。此无间名为目何义。约异熟果决定更无余业余生能为间隔。故此唯目无间隔义。或造此业补特伽罗从此命终定堕地狱中无间隔故名无间。彼有无间得无间名。与无间法合故名无间。如与沙门合故名沙门。三障应知何趣中有。颂曰

  三洲有无间　　非余扇搋等
  少恩少羞耻　　余障通五趣

论曰。且无间业唯人三洲。非北俱卢余趣余界。于三洲内。唯女男及造无间业。非扇搋等。所以者何。即前所说彼无断善不律仪。因即是此中无逆所以。又彼父母及彼己身。如次少恩少羞耻故。谓彼父母于彼少恩。为彼缺身增上缘故。又由于彼少爱念故。彼于父母惭愧心微。以无现前增上惭愧可言坏故触无间罪。由此已释。鬼及傍生虽害母等而非无间。然大德说。若觉分明亦成无间。如聪慧马。若有人害非人父母不成逆罪。心境劣故。已辩业障唯人三洲。余障应知五趣皆有。然于人趣唯北俱卢。在天趣中唯无想处

说一切有部俱舍论卷第十七阿毗达磨俱舍论卷第十八

        尊者世亲造

        三藏法师玄奘奉　诏译

    分别业品第四之六

于前所辩三重障中。说五无间为业障体。五无间业其体是何。颂曰

  此五无间中　　四身一语业
  三杀一诳语　　一杀生加行

论曰。五无间中四是身业。一是语业。三是杀生。一虚诳语根本业道。一是杀生业道加行。以如来身不可害故。破僧无间是虚诳语。既是虚诳语何缘名破僧。因受果名。或能破故。若尔僧破其体是何。能所破人谁所成就。颂曰

  僧破不和合　　心不相应行
  无覆无记性　　所破僧所成

论曰。僧破体是不和合性。无覆无记心不相应行蕴所摄。岂成无间。如是僧破因诳语生。故说破僧是无间果。非能破者成此僧破。但是所破僧众所成。此能破人何所成就。破僧异熟何处几时。颂曰

  能破者唯成　　此虚诳语罪
  无间一劫熟　　随罪增苦增

论曰。能破僧人成破僧罪。此破僧罪诳语为性。即僧破俱生语表无表业。此必无间大地狱中经一中劫受极重苦。余逆不必生于无间。若作多逆罪皆于次生熟如何多逆同感一生。随彼罪增苦还增剧。谓由多逆感地狱中大柔软身多猛苦具。受二三四五倍重苦。谁于何处能破于谁。破在何时。经几时破。颂曰

  苾刍见净行　　破异处愚夫
  忍异师道时　　名破不经宿

论曰。能破僧者要大苾刍。必非在家苾刍尼等。唯见行者非爱行人。住净行人非犯戒者。以犯戒者言无威故。要异处破。非对大师。以诸如来不可轻逼。言词威肃对必无能。唯破异生非破圣者。以诸圣者证法性故。有说。得忍亦不可破。为含二义说愚夫言。要所破僧忍师异佛。忍异佛说有余圣道。应说僧破在如是时。此夜必和不经宿住。如是名曰破法轮僧。能障圣道轮坏僧和合故。何洲人几破法轮僧。破羯磨僧何洲人几。颂曰

  赡部洲九等　　方破法轮僧
  唯破羯磨僧　　通三洲八等

论曰。唯赡部洲人。少至九。或复过此能破法轮。非于余洲。以无佛故。有世尊处方有异师。要八苾刍分为二众。以为所破。能破第九。故众极少犹须九人。等言为明过此无限。唯破羯磨通在三洲。极少八人。多亦无限。通三洲者。有圣教故。要一界中僧分二部。别作羯磨故须八人。过此无遮故亦言等。于何时分无破法轮。颂曰

  初后疱双前　　佛灭未结界
  于如是六位　　无破法轮僧

论曰。初谓世尊转法轮未久。后谓善逝将般涅槃时。此二时中僧一味故。于正戒见疱未起时。要二疱生方可破故。未立止观第一双时。法尔由彼速还合故。佛灭后时无真大师为敌对故。未结界时无一界中分二部故。于此六位无破法轮。非破法轮诸佛皆有。必依宿业有此事故。且止傍论应辩逆缘。颂曰

  弃坏恩德田　　转形亦成逆
  母谓因彼血　　误等无或有
  打心出佛血　　害后无学无

论曰。何缘害母等成无间非余。由弃恩田坏德田故。谓害父母是弃恩田。如何有恩。身生本故。如何弃彼。谓舍彼恩。德田谓余阿罗汉等。具诸胜德及能生故。坏德所依故成逆罪。父母形转杀成逆耶。逆罪亦成。依止一故。由如是义故。有问。言颇有令男离命根。非父阿罗汉而为无间罪触不。曰有。谓母转形。颇有令女离命根非母阿罗汉而为无间罪触不。曰有。谓父转形。设有女人羯剌蓝堕。余女收取置产门中生子。杀何成害母逆。因彼血者身生本故。诸有所作应咨后母。能饮能养能长成故。若于父母起杀加行。误杀余人无无间罪。于非父母起杀加行。误杀父母亦不成逆。如子执杖击父母。蚊母隐在床谓余而杀。若一加行害母及余二无表生。表唯逆罪。以无间业势力强故。尊者妙音说有二表。表是积集极微成故。若害阿罗汉无阿罗汉想。于彼依止起定杀心。无简别故亦成逆罪。若有害父父是阿罗汉得一逆罪。以依止一故。若尔喻说当云何通。佛告始欠持。汝已造二逆。所谓害父杀阿罗汉。彼显一逆由二缘成。或以二门诃责彼罪。若于佛所恶心出血。一切皆得无间罪耶。要以杀心方成逆罪。打心出血无间则无。若杀加行时彼非阿罗汉将死方得阿罗汉果。能杀彼者有逆罪耶。无。于无学身无杀加行故。若造无间加行不可转。为有离染及得圣果耶。颂曰

  造逆定加行　　无离染得果

论曰。无间加行若必定成中间决无离染得果。余恶业道加行中间。若圣道生业道不起。依止与彼定相违故。于诸恶行无间业中何罪最重。于诸妙行世善业中何最大果。颂曰

  破僧虚诳语　　于罪中最大
  感第一有思　　世善中大果

论曰。虽了法非法。为欲破僧而起虚诳语颠倒显示。此无间中为最大罪。由此伤毁佛法身故。障世生天解脱道故。谓僧已破乃至未合。一切世间入圣得果离染尽漏皆悉被遮。习定温诵思等业息。大千世界法轮不转。天人龙等身心扰乱故招无间一劫异熟。由此破僧罪为最重。余无间罪如其次第第五三一后后渐轻。第二最轻。恩等少故。若尔何故三罚业中。佛说意罚为最大罪。又说罪中邪见最大。据五无间说破僧重。约三罚业说意罪大。就五僻见说邪见重。或依大果害多有情断诸善根。如次说重。感第一有异熟果思。于世善中为最大果。感八万大劫极静异熟故。约异熟果故说此言。据离系果则金刚喻定相应思能得大果。诸结永断为此果故。为简此故说世善言。为唯无间罪定生地狱。诸无间同类亦定生彼。有余师说。非无间生。同类者何。颂曰

  污母无学尼　　杀住定菩萨
  及有学圣者　　夺僧和合缘
  破坏窣堵波　　是无间同类

论曰。如是五种随其次第是五无间同类业体。谓有于母阿罗汉尼行极污染谓非梵行。或有杀害住定菩萨。或杀学圣者。或夺僧合缘。或破窣堵波。是五逆同类。有异熟业于三时中极能为障。言三时者。颂曰

  将得忍不还　　无学业为障

论曰。若从顶位将得忍时感恶趣业皆极为障。以忍超彼异熟地故。如人将离本所居国一切债主皆极为障。若有将得不还果时。欲界系业皆极为障。唯除随顺现法受业。若有将得无学果时。色无色业皆极为障。亦除顺现。二喻如前。如上所言住定菩萨为从何位得住定名。彼复于何说名为定。颂曰

  从修妙相业　　菩萨得定名
  生善趣贵家　　具男念坚故

论曰。从修能感妙三十二大丈夫相异熟果业。菩萨方得立住定名。以从此时乃至成佛常生善趣及贵家等。生善趣者。谓生人天。趣妙可称故名善趣。于善趣内常生贵家。谓婆罗门或刹帝利巨富长者大婆罗家。于贵家中根有具缺。然彼菩萨恒具胜根。恒受男身尚不为女。何况有受扇搋等身。生生常能忆念宿命。所作善事常无退屈。谓于利乐有情事中。众苦逼身皆能堪忍。虽他种种恶行违逆。而彼菩萨心无厌倦。如世传有无价驮娑。当知此言目彼菩萨。由彼大士虽已成就一切殊胜圆满功德。而由久习无缘大悲。任运恒时系属他故。普于一切有情类中。以无慢心皆摄同己。或常观己如彼仆使。故于一切难求事中皆能堪忍。及于一切劳迫事中皆能荷负。修妙相业其相云何。颂曰

  赡部男对佛　　佛思思所成
  余百劫方修　　各百福严饰

论曰。菩萨要在赡部洲中。方能造修引妙相业。此洲觉慧最明利故。唯是男子非女等身。尔时已超女等位故。唯现对佛。缘佛起思是思所成。非闻修类。唯余百劫造修非多。诸佛因中法应如是。唯薄伽梵释迦牟尼。精进炽然能超九劫。九十一劫妙相业成。是故如来告聚落主。我忆九十一劫以来。不见一家因施我食有少伤损。唯成大利。从此自性恒忆宿生。是故但言九十一劫。宿旧师说。菩萨出初无数劫来。离四过失得二功德。如前所辩。一一妙相百福庄严。何等名为一一福量。有说。唯除近佛菩萨所余一切有情所修富乐果业名一福量。有说。世界将欲成时。一切有情感大千土业增上力为一福量。有说。此量唯佛乃知。今我大师昔菩萨位于三无数劫供养几佛耶。颂曰

  于三无数劫　　各供养七万
  又如次供养　　五六七千佛

论曰。初无数劫中供养七万五千佛。次无数劫中供养七万六千佛。后无数劫中供养七万七千佛。三无数劫一一满时。及初发心各逢何佛。颂曰

  三无数劫满　　逆次逢胜观
  然灯宝髻佛　　初释迦牟尼

论曰。言逆次者。自后向前。谓于第三无数劫满所逢事佛名为胜观。第二劫满所逢事佛名曰然灯。第一劫满所逢事佛名为宝髻。最初发心位逢释迦牟尼。谓我世尊昔菩萨位最初逢一佛号释迦牟尼。遂对其前发弘誓愿。愿我当作佛一如今世尊。彼佛亦于末劫出世。灭后正法亦住千年。故今如来一一同彼。我释迦菩萨于何位中何波罗蜜多修习圆满。颂曰

  但由悲普施　　被折身无忿
  赞叹底沙佛　　次无上菩提
  六波罗蜜多　　于如是四位
  一二又一二　　如次修圆满

论曰。若时菩萨普于一切能施一切乃至眼髓。所行惠舍但由悲心。非自希求胜生差别。齐此布施波罗蜜多修习圆满。若时菩萨被析身支。虽未离欲贪而心无少忿。齐此戒忍波罗蜜多。修习圆满。若时菩萨勇猛精进因行。遇见底沙如来坐宝龛中入火界定威光赫奕特异于常。专诚瞻仰忘下一足。经七昼夜无怠。净心以妙伽他赞彼佛曰

  天地此界多闻室　　逝宫天处十方无
  丈夫牛王大沙门　　寻地山林遍无等

如是赞已便超九劫。齐此精进波罗蜜多修习圆满。若时菩萨处金刚座。将登无上正等菩提。次无上觉前住金刚喻定。齐此定慧波罗蜜多修习圆满。能到自所往圆德彼岸。故此六名曰波罗蜜多。契经说。有三福业事。一施类福业事。二戒类福业事。三修类福业事。此云何立福业事名。颂曰

  施戒修三类　　各随其所应
  受福业事名　　差别如业道

论曰。三类皆福。或业或事。随其所应如业道说。谓如分别十业道中有业亦道有道非业。此中有福亦业亦事。有福业非事。有福事非业。有唯是福非业非事。且施类中身语二业具福业事三种义名。彼等起思唯名福业。思俱有法唯受福名。戒类既唯身语业性故。皆具受福业事名。修类中慈唯名福事。业之事故。慈相应思以慈为门。而造作故。慈俱思戒唯名福业。余俱有法唯受福名。或福业名显作福义。谓福加行事显所依。谓施戒修是福业之事。为成彼三起福加行故。有说。唯思是真福业。福业之事谓施戒修。以三为门福业转故。何法名施。施招何果。颂曰

  由此舍名施　　谓为供为益
  身语及能发　　此招大富果

论曰。虽所舍物亦得施名。而于此中舍具名施。谓由此具舍事得成故。舍所由是真施体。或由怖畏希求贪等舍事亦成。非此意说。简彼故说为供益言。谓为于他供养饶益而有所舍。此具名施。具名何谓。谓身语业及此能发。能发谓何。谓无贪俱能起此聚。如有颂曰

  若人以净心　　辍己而行施
  此刹那善蕴　　总立以施名

应知如是施类福业事。能招当现大财富为果。言施类福者。显施为体义。如叶类器草类舍等。戒修类言准此应释。为何所益而行施耶。颂曰

  为益自他俱　　不为二行施

论曰。此中一切未离欲贪及离欲贪诸异生类。持己所有奉施制多。此施名为唯为自益非他。由此有获益故。若诸圣者已离欲贪。施诸有情除顺现受。此施名曰唯为益他。以他由此获饶益故。非为自益。超果地故。若彼一切未离欲贪。及离欲贪诸异生类。持己所有施诸有情。此施名为为二俱益。若彼圣者已离欲贪。奉施制多除顺现受。此施名曰不为益二。以此唯为恭敬报恩。前已总明施招大富。今次当辩施果别因。颂曰

  由主财田异　　故施果差别

论曰。施有差别由三种因。谓主财田有差别故。施差别故果有差别。且由施主差别云何。颂曰

  主异由信等　　行敬重等施
  得尊重广爱　　应时难夺果

论曰。由施主成信戒闻等差别功德。故名主异。由主异故施成差别。由施差别与果有异。诸有施主具如是德。能如法行敬重等四施。如次便得尊重等四果。谓若施主行敬重施。便感常为他所尊重。若自手施。便能感得于广大财爱乐受用。若应时施感应时财。所须应时不过时故。若无损施便感资财。不为他侵及火等坏。由所施财差别云何。颂曰

  财异由色等　　得妙色好名
  众爱柔软身　　有随时乐触

论曰。由所施财或阙或具色香味触。如次便得或阙或具妙色等果。谓所施财色具足故便感妙色。香具足故便感好名。如香芬馥遍诸方故。味具足故便感众爱。如味美妙众所爱故。触具足故感柔软身及有随时生乐受触。如女宝等。果有减者由因阙故。如是亦由具色香等故名财异。由财异故。施体及果皆有差别。由所施田差别云何。颂曰

  田异由趣苦　　恩德有差别

论曰。由所施田趣苦恩德各有差别。故名田异。由田异故施果有殊。由趣别者。如世尊说。若施傍生受百倍果。施犯戒人受千倍果。由苦别者。如七有依福业事中先说应施客行病侍园林常食及寒风热随时食等。复说。若有具足净信男子女人成此所说七种有依福业事者。所获福德不可取量。由恩别者。如父母师及余有恩。如熊鹿等本生经说诸有恩类。由德别者。如契经言。若施持戒人受亿倍果等。于诸施福最胜者何。颂曰

  脱于胜菩萨　　第八施最胜

论曰。薄伽梵说。若离染者于离染者施诸资财。于财施中此为最胜。若诸菩萨所行惠施。是普利乐诸有情因。虽不名为脱施于脱。而于施福亦为最胜。除此更有八种施中。第八施福亦为最胜。八施者何。一随至施。二怖畏施。三报恩施。四求报施。五习先施。六希天施。七要名施。八为庄严心为资助心为资瑜伽为得上义而行惠施。随至施者。宿旧师言。随近己至方能施与。怖畏施者。谓见此财坏相现前宁施不失。习先施者。谓习先人父祖家法而行惠施。余施易了故不别释。如契经说。施预流向。其果无量。施预流果果量更增。乃至广说颇有施非圣果亦无量耶。颂曰

  父母病法师　　最后生菩萨
  设非证圣者　　施果亦无量

论曰。如是五种设是异生。但施亦能招无量果。住最后有名最后生。法师四田中是何田所摄。是恩田摄。所以者何。为诸世间大善友故。无明所盲者能施慧眼故。开示世间安危事故。令有情生起无漏法身故。以要说者。善说法师乃至能为佛所作事故。于彼行施便招无量果。欲知诸业轻重相者。应知轻重略由六因。其六者何。颂曰

  后起田根本　　加行思意乐
  由此下上故　　业成下上品

论曰。后起者谓作已随作。田谓于彼作损作益。根本者谓根本业道。加行者谓引彼身语。思谓由彼业道究竟。意乐者谓所有意趣。我应造作如是如是。我当造作如是如是。或有诸业唯由后起所摄受故得成重品。定安立彼异熟果故。或有诸业由田成重。或有于田由根本力成重非余。如父母田行杀罪重非盗等业。由余成重。例此应思。若有六因皆是上品。此业最重。翻此最轻。除此中间非最轻重。如契经说。有二种业。一造作业。二增长业。何因说业名增长耶。由五种因。何等为五。颂曰

  由审思圆满　　无恶作对治
  有伴异熟故　　此业名增长

论曰。由审思故者。谓彼所作业非先全不思。非率尔思作。由圆满故者。谓诸有情中。或由一恶行便堕恶趣。或乃至三。或由一业道便堕恶趣。或乃至十。此中若有齐此量业应堕恶趣。未圆满时但名造作不名增长。若此已圆满亦得增长名。由无恶作对治故者。谓无追悔无对治业。由有伴故者。谓作不善业不善为助伴。由异熟故者。谓定与异熟善翻此应知。异此诸业唯名造作。如前所明。未离欲等持己所有奉施制多。此施名为唯为自益。既无受者福如何成。颂曰

  制多舍类福　　如慈等无受

论曰。福有二类。一舍二受。舍类福者。谓由善心但舍资财施福便起。受类福者。谓所施田受用施物施福方起。于制多所奉施供具虽无受类有舍类福。彼既不受福由何生。复以何因知福生者要由彼受不受不生。不受于他无摄益故。此非定证。若福要由摄益他成。则修慈等及正见等应不生福。是故应许供养制多有多福生。如修慈等。谓如有一修慈等定。虽无受者及摄益他。而从自心生无量福。如是有德者虽已灭过去而追伸敬养福由自心生。岂不唐捐此施敬业。不尔发业心方胜故。谓如有一欲害怨家。彼命虽终犹怀怨想发起种种恶身语业。生多非福非但起心。如是大师虽已过去追伸敬养起身语业。方生多福非但起心。若于善田殖施业种可招爱果。若于恶田虽施但应招非爱果。此不应尔。所以者何。颂曰

  恶田有爱果　　种果无倒故

论曰。现见田中种果无倒。从末度迦种末度迦果生。其味极美。从赁婆种赁婆果生。其味极苦。非由田力种果有倒。如是施主虽于恶田而益他心殖诸施种。但招爱果不招非爱。然由田过令所殖种或生果少或果全无。施类福业事傍论已了。今次应辩戒类福业事。颂曰

  离犯戒及遮　　名戒各有二
  非犯戒因坏　　依治灭净等

论曰。诸不善色名为犯戒。此中性罪立犯戒名。遮谓所遮非时食等。虽非性罪而佛为护法及有情别意遮止。受戒者犯亦名犯戒。简性罪故但立遮名。离性及遮俱说名戒。此各有二。谓表无表。以身语业为自性故。已略辩戒自性差别。若具四德得清净名。与此相违名不清净。言四德者。一者不为犯戒所坏。犯戒谓前诸不善色。二者不为彼因所坏。彼因谓贪等烦恼随烦恼。三者依治。谓依念住等。此能对治犯戒及因故。四者依灭。谓依涅槃回向涅槃非胜生故。等言为显复有异说。有说。戒净由五种因。一根本净。二眷属净。三非寻害。四念摄受。五回向寂。有余师说。戒有四种。一怖畏戒。谓怖不活恶名治罚恶趣畏故受护尸罗。二希望戒。谓贪诸有胜位多财恭敬称誉受持净戒。三顺觉支戒。谓为求解脱及正见等受持净戒。四清净戒。谓无漏戒。彼能永离业惑垢故。已辩戒类。修类当辩。颂曰

  等引善名修　　极能熏心故

论曰。言等引善其体是何。谓三摩地自性俱有。修名何义。谓熏习心以定地善于心相续极能熏习令成德类。如花熏苣蕂。是故独名修。前辩施福能招大富。戒修二类所感云何。颂曰

  戒修胜如次　　感生天解脱

论曰。戒感生天。修感解脱。胜言为显就胜为言。谓施亦能感生天果就胜说戒。持戒亦能感离系果就胜说修。经说四人能生梵福。一为供养如来[馬*犬]都建窣堵波于未曾处。二为供养四方僧伽造寺施园四事供给。三佛弟子破已能和。四于有情普修慈等。如是梵福其量云何。颂曰

  感劫生天等　　为一梵福量

论曰。先轨范师作如是说。随福能感一劫生天受诸快乐是一福量。由彼所感受快乐时同梵辅天一劫寿故。以于余部有伽他言

  有信正见人　　修十胜行者
  便为生梵福　　感劫天乐故

毗婆沙师作如是说。即于分别妙相业中。所辩福量此即同彼。等言为显如是异说。财施已说。法施云何。颂曰

  法施谓如实　　无染辩经等

论曰。若能如实为诸有情以无染心辩契经等令生正解名为法施。故有颠倒或染污心求利名誉恭敬辩者。是人便损自他大福。前已别释三福业事。今释经中顺三分善。颂曰

  顺福顺解脱　　顺决择分三
  感爱果涅槃　　圣道善如次

论曰。言顺福分者。谓感世间可爱果善。顺解脱分者。谓定能感涅槃果善。此善生已。令彼有情名为身中有涅槃法。若有闻说生死有过诸法无我涅槃有德。身毛为竖悲泣堕泪。当知彼已殖顺解脱分善。如见得雨场有芽生知其穴中先有种子。顺决择分者。谓近能感圣道果善。即暖等四。后当广说。如世间所说书印算文数。此五自体云何应知。颂曰

  诸如理所起　　三业并能发
  如次为书印　　算文数自体

论曰。如理起者。正加行生。三业应知即身语意。能发即是能起此三。如其所应受想等法。此中书印以前身业及彼能发五蕴为体。次算及文以前语业及彼能发五蕴为体。后数应知。以前意业及彼能发四蕴为体。但由意思能数法故今应略辩诸法异名。颂曰

  善无漏名妙　　染有罪覆劣
  善有为应习　　解脱名无上

论曰。善无漏法亦名为妙。诸染污法亦名有罪有覆及劣。准此妙劣余中已成。故颂不辩。诸有为善亦名应习。余非应习义准已成。何故无为不名应习。不可数习令增长故。又习为果。此无果故。解脱涅槃亦名无上。以无一法能胜涅槃是善是常超众法故。余法有上义准已成

说一切有部俱舍论卷第十八阿毗达磨俱舍论卷第十九

        尊者世亲造

        三藏法师玄奘奉　诏译

    分别随眠品第五之一

前言世别皆由业生。业由随眠方得生长。离随眠业无感有能。所以者何。随眠有几。颂曰

  随眠诸有本　　此差别有六
  谓贪嗔亦慢　　无明见及疑

论曰。由此随眠是诸有本故业离此无感有能。何故随眠能为有本。以诸烦恼现起能为十种事故。一坚根本。二立相续。三治自田。四引等流。五发业有。六摄自具。七迷所缘。八导识流。九越善品。十广缚义。令不能越自界地故。由此随眠能为有本。故业因此有感有能。此略应知差别有六。谓贪嗔慢无明见疑。颂说亦言。意显慢等亦由贪力于境随增。由贪随增义如后辩。及声显六体各不同。若诸随眠体唯有六。何缘经说有七随眠。颂曰

  六由贪异七　　有贪上二界
  于内门转故　　为遮解脱想

论曰。即前所说六随眠中分贪为二。故经说七。何等为七。一欲贪随眠。二嗔随眠。三有贪随眠。四慢随眠。五无明随眠。六见随眠。七疑随眠。欲贪随眠依何义释。为欲贪体即是随眠。为是欲贪之随眠义。于余六义征问亦尔。若尔何失。二俱有过。若欲贪体即是随眠。便违契经。如契经说。若有一类。非于多时为欲贪缠缠心而住。设心暂尔起欲贪缠寻如实知出离方便。彼由此故于欲贪缠能正遣除并随眠断。若是欲贪之随眠义。随眠应是心不相应。便违对法。如本论说。欲贪随眠三根相应。毗婆沙师作如是说。欲贪等体即是随眠。岂不违经。无违经失。并随眠者并随缚故。或经于得假说随眠。如火等中立苦等想。阿毗达磨依实相说。即诸烦恼说名随眠。由此随眠是相应法。何理为证知定相应。以诸随眠染恼心故。覆障心故。能违善故。谓随眠力能染恼心。未生善不生。已生善退失。故随眠体非不相应。若不相应能为此事。则诸善法应无起时。以不相应恒现前故。既诸善法容有起时。故知随眠是相应法。此皆非证。所以者何。若许随眠非相应者。不许上三事是随眠所为。然经部师所说最善。经部于此所说如何。彼说欲贪之随眠义。然随眠体非心相应。非不相应。无别物故。烦恼睡位说名随眠。于觉位中即名缠故。何名为睡。谓不现行种子随逐。何名为觉。谓诸烦恼现起缠心。何等名为烦恼种子。谓自体上差别功能。从烦恼生能生烦恼。如念种子是证智生能生当念功能差别。又如芽等有前果生能生后果功能差别。若执烦恼别有随眠心不相应名烦恼种。应许念种非但功能别有不相应能引生后念。此既不尔。彼云何然。差别因缘不可得故。若尔六六契经相违。经说于乐受有贪随眠故。经但说有。不言尔时即有随眠。何所违害。于何时有。于彼睡时。或假于因立随眠想。傍论且止。应辩正论。言贪分二。谓欲有贪。此中有贪以何为体。谓色无色二界中贪此。名何因唯于彼立。彼贪多托内门转故。谓彼二界多起定贪。一切定贪于内门转故。唯于彼立有贪名。又由有人于上二界起解脱想。为遮彼故。谓于上界立有贪名。显彼所缘非真解脱。此中自体立以有名。彼诸有情多于等至及所依止深生味着故。说彼唯味着自体。非味着境。离欲贪故。由此唯彼立有贪名。既说有贪在上二界。义准欲界贪名欲贪。故于颂中不别显示。即上所说六种随眠。于本论中复分为十。如何成十。颂曰

  六由见异十　　异谓有身见
  边执见邪见　　见取戒禁取

论曰。六随眠中见行异为五。余非见五积数总成十故于十中五是见性。一有身见。二边执见。三邪见。四见取。五戒禁取。五非见性。一贪二嗔三慢四无明五疑。又即所说六种随眠。于本论中说九十八。依何义说九十八耶。颂曰

  六行部界异　　故成九十八
  欲见苦等断　　十七七八四
  谓如次具离　　三二见见疑
  色无色除嗔　　余等如欲说

论曰。六种随眠由行部界有差别故成九十八。谓于六中由见行异分别为十。如前已辩。即此所辩十种随眠。部界不同成九十八。部谓见四谛修所断五部。界谓欲色无色三界。且于欲界五部不同乘十随眠成三十六。谓见苦谛至修所断。如次有十七七八四。即上五部。于十随眠一二一一如其次第。具离三见二见见疑。谓见苦谛所断具十。见集灭谛所断各七。离有身见边见戒取。见道谛所断八。离有身见及边执见。修所断四。离见及疑。如是合成三十六种。前三十二名见所断。才见谛时彼则断故。最后有四名修所断。见四谛已后后时中数数习道彼方断故。如是已显。十随眠中萨迦耶见唯在一部。谓见苦所断。边执见亦尔。戒禁取通在二部。谓见苦见道所断。邪见通四部。谓见苦集灭道所断。见取疑亦尔。余贪等四各通五部。谓见四谛及修所断。此中何相见苦所断。乃至何相是修所断。若缘见此所断为境名见此所断。余名修所断。如是六中见分十二。疑分为四。余四各五。故欲界中有三十六。色无色界五部各除嗔。余与欲同。故各三十一。由是本论以六随眠行部界殊说九十八。于此所辩九十八中八十八见所断。忍所害故。十随眠修所断。智所害故。如是所说见修所断为决定尔。不尔云何。颂曰

  忍所害随眠　　有顶唯见断
  余通见修断　　智所害唯修

论曰。忍声通说法类智忍。于忍所害诸随眠中有顶地摄唯见所断。唯类智忍方能断故。余八地摄通见修断。谓圣者断唯见非修。法类智忍如应断故。若异生断唯修非见。数习世俗智所断故。智所害诸随眠。一切地摄。唯修所断。以诸圣者及诸异生。如其所应。皆由数习无漏世俗智所断故。有余师说。外道诸仙不能伏断见所断惑。如大分别诸业契经说。离欲贪诸外道类有缘欲界邪见现行。及梵网经亦说。彼类有缘欲界诸见现行。谓于前际分别论者。有执全常。有执一分。有执诸法无因生等。非色界惑缘欲界生。于欲界境已离贪故。定是欲界诸见未断。毗婆沙师释彼经义。起见时暂退。如提婆达多。由行有殊分见为五。名先已列。自体如何。颂曰

  我我所断常　　拨无劣谓胜
  非因道妄谓　　是五见自体

论曰。执我及我所是萨迦耶见。坏故名萨。聚谓迦耶。即是无常和合蕴义。迦耶即萨名萨迦耶。此萨迦耶即五取蕴。为遮常一想故立此名。要此想为先方执我故。毗婆沙者作如是释。有故名萨。身义如前。勿无所缘计我我所。故说此见缘于有身。缘萨迦耶而起此见。故标此见名萨迦耶。诸见但缘有漏法者。皆应标以萨迦耶名。然佛但于我我所执摽此名者。令知此见缘萨迦耶。非我我所。以我我所毕竟无故。如契经说。苾刍当知。世间沙门婆罗门等。诸有执我等随观见一切。唯于五取蕴起。即于所执我我所事执断执常名边执见。以妄执取断常边故。于实有体苦等谛中。起见拨无名为邪见。一切妄见皆颠倒转并应名邪。而但拨无名邪见者。以过甚故。如说臭酥恶执恶等。此唯损减。余增益故。于劣谓胜名为见取。有漏名劣。圣所断故。执劣为胜总名见取。理实应立见等取名。略去等言。但名见取。于非因道谓因道见。一切总说名戒禁取。如大自在生主。或余非世间因妄起因执。投水火等种种邪行。非生天因妄起因执唯受持戒禁。数相应智等。非解脱道妄起道执。理实应立戒禁等取名。略去等言但名戒禁取。是谓五见自体。应知。若于非因起是因见。此见何故非见集断。颂曰

  于大自在等　　非因妄执因
  从常我倒生　　故唯见苦断

论曰。执大自在生主或余为世间因生世间者。必先计度彼体是常一我作者方起因执。才见苦时于自在等。常执我执永断无余故。彼所生因执亦断。若尔有执投水火等种种邪行是生天因。或执但由受持戒禁等便得清净。不应见苦断。然本论说有诸外道。起如是见立如是论。若有士夫补特伽罗受持牛戒鹿戒狗戒便得清净解脱出离。永超众苦乐至超苦乐处。如是等类非因执因。一切应知。是戒禁取见苦所断。如彼广说。此复何因是见苦断。迷苦谛故有太过失。缘有漏惑皆迷苦故。复有何相别戒禁取。可说彼为见道所断。诸缘见道所断法生。彼亦应名迷苦谛故。又缘道谛邪见及疑。若拨若疑无解脱道。如何即执此能得永清净。若彼拨无真解脱道。妄执别有余清净因。是则执余能得清净。非邪见等。此缘见道所断诸法。理亦不成。又若有缘见集灭谛所断邪见等执为清净因。此复何因非见彼断。故所执义应更思择。如前所说。常我倒生。为但有斯二种颠倒。应知颠倒总有四种。一于无常执常颠倒。二于诸苦执乐颠倒。三于不净执净颠倒。四于无我执我颠倒。如是四倒其体云何。颂曰

  四颠倒自体　　谓从于三见
  唯倒推增故　　想心随见力

论曰。从于三见立四倒体。谓边见中唯取常见以为常倒。诸见取中取计乐净为乐净倒。有身见中唯取我见以为我倒。有说。我倒摄身见全。我倒如何摄我所见。如何不摄。由倒缠故。诸有计我。于彼事中有自在力是我所见。此即我见由二门转。是我属我。若是别见由我为我见亦应别。何故余惑非颠倒体。要具三因胜者成倒。言三因者。一向倒故。推度性故。妄增益故。谓戒禁取非一向倒。缘少净故。断见邪见非妄增益。无门转故。所余烦恼不能推度。非见性故。由具三因胜者成倒。是故余惑非颠倒体。若尔何故契经中言于无常计常。有想心见倒。于苦不净无我亦然。理实应知。唯见是倒。想心随见亦立倒名。与见相应行相同故。若尔何故不说受等。彼于世间不极成故。谓心想倒世间极成。受等不然。故经不说。如是诸倒预流已断。见及相应见所断故。有余部说。倒有十二。谓于无常计常倒中有想心见三种颠倒。乃至于无我计我倒亦尔。于中八唯见断。四通见修断。谓乐净想心。若谓不然。未离欲圣离乐净想。宁起欲贪。毗婆沙师不许此义。若有乐净想心现行。便许圣者有乐净倒。圣者亦起有情想心。是则亦应许有我倒。非于女等及于自身离有情想心有起欲贪故。由契经说。若有多闻诸圣弟子。于苦圣谛如实见知。乃至尔时彼圣弟子。无常计常想心见倒皆已永断。乃至广说。故知想心唯取见倒相应力起。是倒非余。然圣有时暂迷乱故。率尔于境欲贪现前。如于旋火轮画药叉迷乱。若尔何故尊者庆喜告彼尊者辩自在言

  由有想乱倒　　故汝心燋热
  远离彼想已　　贪息心便净

故有余师复作是说。八想心倒学未全断。如是八种缠。由如实见知圣谛方得永断。离此无余永断方便。故此所说不违彼经。为唯见随眠有多差别。为余亦有。慢亦有。云何。颂曰

  慢七九从三　　皆通见修断
  圣如杀缠等　　有修断不行

论曰。且慢随眠差别有七。一慢二过慢三慢过慢四我慢五增上慢六卑慢七邪慢。令心高举总立慢名。行转不同故分七种。于劣于等如其次第谓己为胜谓己为等令心高举总说为慢。于等于胜如其次第谓胜谓等总名过慢。于胜谓胜名慢过慢。于五取蕴执我我所令心高举名为我慢。于未证得殊胜德中谓已证得名增上慢。于多分胜谓己少劣名为卑慢。于无德中谓己有德名为邪慢。然本论说慢类有九。一我胜慢类。二我等慢类。三我劣慢类。四有胜我慢类。五有等我慢类。六有劣我慢类。七无胜我慢类。八无等我慢类。九无劣我慢类。如是九种从前七慢三中离出。从三者何。谓从前慢过慢卑慢。如是三慢若依见生行。次有殊成三三类。初三如次即过慢慢卑慢。中三如次即卑慢慢过慢。后三如次即慢过慢卑慢。于多分胜谓己少劣卑慢可成。有高处故。无劣我慢高处是何。谓于如是自所爱乐胜有情聚虽于己身知极下劣而自尊重。如是且依发智论释。依品类足释慢类者。且我胜慢从三慢出。谓慢过慢慢过慢三。由观劣等胜境别故。如是七慢何所断耶。一切皆通见修所断。诸修所断圣未断时为可现行。此不决定。谓有修所断。而圣定不行。如杀生缠是修所断。而诸圣者必不现行。杀生缠者。显由此惑发起故思断众生命。等言为显盗淫诳缠无有爱全有爱一分。无有名何法。谓三界无常于此贪求名无有爱。有爱一分谓愿当为蔼罗筏拏大龙王等。此诸缠爱一切皆缘修所断故唯修所断。已说慢类等。有是修所断。何缘圣者未断不起。颂曰

  慢类等我慢　　恶作中不善
  圣者而不起　　见疑所增故

论曰。等言为显杀等诸缠无有爱全有爱一分。此慢类等我慢恶悔。是见及疑亲所增长。虽修所断而由见疑背已折故。圣不能起。谓慢类我慢有身见所增。杀生等缠邪见所增。诸无有爱断见所增。有爱一分常见所增。不善恶作是疑所增。故圣身中皆定不起。九十八随眠中几是遍行几非遍行。颂曰

  见苦集所断　　诸见疑相应
  及不共无明　　遍行自界地
  于中除二见　　余九能上缘
  除得余随行　　亦是遍行摄

论曰。唯见苦集所断见疑及彼相应不共无明力。能遍行自界地五部故。此十一皆得遍行名。谓七见二疑二无明十一。如是十一于自界地五部诸法遍缘。随眠为因遍生五部染法。依此三义立遍行名。此中所言遍缘五部。为约渐次。为约顿缘。若渐次缘余亦应遍。若顿缘者谁复普于欲界诸法顿计为胜能得清净或世间因。不说顿缘自界地一切。然说有力能顿缘五部。虽尔遍行亦非唯此。以于是处有我见行。是处必应起我爱慢。若于是处净胜见行。是处必应希求高举。是则爱慢应亦遍行。若尔顿缘见修断故。应言此二何所断耶。应言修所断。杂缘境故。或应见所断。见力引故。毗婆沙师作如是说。此二烦恼自相非共。无顿缘力故非遍行。是故遍行唯此十一。余非。准此不说自成。于十一中除身边见。所余九种亦能上缘。上言正明上界上地。兼显无有缘下随眠。此九虽能通缘自上。然理无有自上顿缘。于缘上中且约界说。或唯缘一或二合缘。故本论言。有诸随眠是欲界系缘色界系。有诸随眠是欲界系缘无色界系。有诸随眠是欲界系缘色无色界系。有诸随眠是色界系缘无色界系。约地分别准界应思。生在欲界若缘大梵起有情见。或起常见。如何身边见不缘上界地。不执彼为我我所故。边见必由身见起故。若尔计彼为有情常是何见摄。对法者言。此二非见是邪智摄。何缘所余缘彼是见。此亦缘彼而非见耶。以宗为量故作是说。为遍行体唯是随眠。不尔。云何并随行法。谓上所说十一随眠并彼随行皆遍行摄。然除彼得。非一果故。由此故有作是问言。诸遍行随眠皆遍行因不。答言。于此应作四句。第一句者。谓未来世遍行随眠。第二句者。谓过现世彼俱有法。第三第四如理应辩。九十八随眠中。几缘有漏。几缘无漏。颂曰

  见灭道所断　　邪见疑相应
  及不共无明　　六能缘无漏
  于中缘灭者　　唯缘自地灭
  缘道六九地　　由别治相因
  贪嗔慢二取　　并非无漏缘
  应离境非怨　　静净胜性故

论曰。唯见灭道所断邪见疑彼相应不共无明。各三成六。能缘无漏。余缘有漏准此自成。于此六中缘灭谛者。各以自地灭为所缘。灭互相望非因果故。谓欲界系三种随眠。唯缘欲界诸行择灭。乃至有顶三种随眠。唯缘有顶诸行择灭。缘道谛者缘六九地。谓欲界系三种随眠。唯缘六地法智品道。若治欲界若能治余皆彼所缘。以类同故。色无色界八地各有三种随眠。一一唯能通缘九地类智品道。若治自地若能治余皆彼所缘。以类同故。何故缘灭自地非余。缘道便通六九同类。以诸地道互相因故。虽法类品亦互相因。而类智品不治欲界。故类智品道非欲三所缘。法智品既能治色无色。应为彼八地各三所缘。非此皆能治色无色。苦集法智品非彼对治故。亦非全能治色无色。不能治彼见所断故。二初无故。非彼所缘。即由此因显遍行惑有缘苦集诸地无遮。境互为缘因。非能对治故。何缘贪嗔慢戒禁取见取见。无漏断非无漏缘。以贪随眠应舍离故。若缘无漏便非过失。如善法欲不应舍离。缘怨害事起嗔随眠。灭道非怨故非嗔境。缘粗动事起慢随眠。灭道寂静故非慢境。于非净法执为净因名戒禁取。灭道真净故不应为戒禁取境。于非胜法执为最胜名为见取。灭道真胜故亦不应为见取境。是故贪等不缘无漏。九十八随眠中。几由所缘故随增。几由相应故随增。颂曰

  未断遍随眠　　于自地一切
  非遍于自部　　所缘故随增
  非无漏上缘　　无摄有违故
  随于相应法　　相应故随增

论曰。遍行随眠。普于自地五部诸法所缘随增。以能遍缘自地法故。所余五部非遍随眠。所缘随增唯于自部。唯以自部为所缘故。此据总说。别分别者。六无漏缘九上缘惑于所缘境无随增义。所以者何。无漏上境非所摄受及相违故。谓若有法为此地中身见及爱摄为己有。可有为此身见爱地中所有随眠所缘随增理。如衣润湿埃尘随住。非诸无漏及上地法为诸下身见爱摄为己有故缘彼下惑非所缘随增。住下地心求上地等。是善法欲非谓随眠。圣道涅槃及上地法与能缘彼下惑相违故。彼二亦无所缘随增理。如于炎石足不随住。有说。随眠是随顺义。非无漏上境顺。诸下随眠故。虽是所缘而无随增理。如风病者服干涩药病者于药非所随增。已约所缘辩随增义。今次应辩相应随增。谓随何随眠于自相应法由相应故于彼随增。诸说随增。谓至未断故。初颂首标未断言。颇有随眠不缘无漏不缘上界而彼随增但于相应非所缘不。有。谓缘上地诸遍行随眠。九十八随眠中几不善几无记。颂曰

  上二界随眠　　及欲身边见
  彼俱痴无记　　此余皆不善

论曰。色无色界一切随眠唯无记性。以染污法若是不善有苦异熟。苦异熟果上二界无。他逼恼因彼定无故。身边二见及相应痴欲界系者亦无记性。所以者何。此与施等不相违故。为我当乐现在勤修施戒等故。执断边见能顺解脱。故世尊说。于诸外道诸见趣中此见最胜。谓我不有我所亦不有。我当不有我所当不有。又此二见迷自事故。非欲逼害他有情故。若尔贪求天上快乐及起我慢例亦应然。先轨范师作如是说。俱生身见是无记性。如禽兽等身见现行。若分别生是不善性。余欲界系一切随眠与上相违皆不善性。于上所说不善惑中。几是不善根。几非不善根。颂曰

  不善根欲界　　贪嗔不善痴

论曰。唯欲界系一切贪嗔及不善痴不善根摄。如其次第世尊说为贪嗔痴三不善根。性唯不善烦恼为不善法根立不善根。余则不尔。所余烦恼非不善根。义准已成。故颂不说。于上所说无记惑中。几是无记根。几非无记根。颂曰

  无记根有三　　无记爱痴慧
  非余二高故　　外方立四种
  中爱见慢痴　　三定皆痴故

论曰。迦湿弥罗国诸毗婆沙师说无记根亦有三种。谓诸无记爱痴慧三。下至异熟生亦无记根摄。何缘疑慢非无记根。疑二趣转。慢高转故。彼师谓疑二趣相转。性动摇故不应立根。慢于所缘高举相转。异根法故亦不立根。为根必应坚住下转。世间共了故彼非根。外方诸师立此有四。谓诸无记爱见慢痴。无记名中遮善恶故。何缘此四立无记根。以诸愚夫修上定者不过依托爱见慢三。此三皆依无明力转。故立此四为无记根。诸契经中说十四无记事。彼亦是此无记摄耶。不尔。云何。彼经但约应舍置问立无记名。谓问记门总有四种。何等为四。颂曰

  应一向分别　　反诘舍置记
  如死生殊胜　　我蕴一异等

论曰。且问四者。一应一向记。二应分别记。三应反诘记。四应舍置记。此四如次。如有问者。问死生胜我一异等。记有四者。谓答四问。若作是问。一切有情皆当死不。应一向记一切有情皆定当死。若作是问。一切死者皆当生不。应分别记有烦恼者当生非余。若作是问。人为胜劣。应反诘记。为何所方。若言方天应记人劣。若言方下应记人胜。若作是问。蕴与有情为一为异。应舍置记。有情无实故一异性不成。如石女儿白黑等性。如何舍置而立记名。以记彼问言此不应记故。有作是说。彼第二问亦应一向记非一切当生。然问者言一切死者皆当生不。理应分别记彼所问。总答不成。虽令总知仍未解故。又作是说。彼第三问亦应一向记。人亦胜亦劣。所待异故如识果因。然彼问者一向为问。非一向记故应成分别记。但此应诘问意所方故此名为应反诘记。又作是说。彼第四问既全不记蕴与有情若异若一。云何名记。然彼所问理应舍置。记言应舍置。如何不名记。对法诸师作如是说。一向记者。若有问言世尊是如来应正等觉耶。所说法要是善说耶。诸弟子众行妙行耶。色乃至识皆无常耶。苦乃至道善施设耶。应一向记契实义故。分别记者。若有直心请言。愿尊为我说法。应为分别。法有众多。谓去来今。欲说何者。若言为我说过去法。应复分别。过去法中亦有众多色乃至识。若请说色。应分别言。色中有三。善恶无记。若请说善应分别言。善中有七。谓离杀生广说乃至离杂秽语。若彼复请说离杀生。应分别言。此有三种。谓无贪嗔痴三善根所发。若彼请说无贪发者。应分别言。此复有二。谓表无表。欲说何者。反诘记者。若有谄心请言愿尊为我说法。应反诘彼。法有众多欲说何者。不应分别。乃至令彼默然而住。或令自记无便求非。岂不二中都无有问唯有请说亦无有记唯反诘言欲说何者。如何此二成问记耶。如有请言为我说道。岂非问道。即由反诘记彼所问。岂非记道。若尔应俱是反诘记。不尔。问意直谄有殊。记有分别无分别故。舍置记者。若有问言。世为有边为无边等。此应舍置不应为说。今依契经辩问记相。如大众部契经中言。苾刍当知。问记有四。何等为四。谓或有问应一向记。乃至有问但应舍置。云何有问应一向记。谓问诸行皆无常耶。此问名为应一向记。云何有问应分别记。谓若有问诸有故思造作业已为受何果。此问名为应分别记。云何有问应反诘记。谓若有问士夫想与我为一为异耶。应反诘言。汝依何我作如是问。若言依粗我。应记与想异。此问名为应反诘记。云何有问但应舍置。谓若有问。世为常无常亦常亦无常非常非无常。世为有边无边亦有边亦无边非有边非无边。如来死后为有非有亦有亦非有非有非非有。为命者即身。为命者异身。此问名为但应舍置

说一切有部俱舍论卷第十九阿毗达磨俱舍论卷第二十

        尊者世亲造

        三藏法师玄奘奉　诏译

    分别随眠品第五之二

诸有情类于此事中随眠随增名系此事。应说过去现在未来何等随眠能系何事。颂曰

  若于此事中　　未断贪嗔慢
  过现若已起　　未来意遍行
  五可生自世　　不生亦遍行
  余过未遍行　　现正缘能系

论曰。且诸随眠总有二种。一者自相。谓贪嗔慢。二者共相。谓见疑痴。事虽有多此说所系。如应未断流至后门。若此事中有贪嗔慢。于过去世已生未断。现在已生能系此事。以贪嗔慢是自相惑。非诸有情定遍起故。若未来世意识相应贪嗔慢三遍于三世乃至未断皆能系缚。未来五识相应贪嗔若未断可生唯系未来世。未来五识相应贪嗔若未断不生亦能系三世。所余一切见疑无明去来未断遍缚三世。由此三种是共相惑一切有情俱遍缚故。若现在世正缘境时。随其所应能系此事。应辩诸事过去未来。为实有无方可说系。若实是有则一切行恒时有故应说为常。若实是无如何可说有能所系及离系耶。毗婆沙师定立实有。然彼诸行不名为常。由与有为诸相合故。为此所立决定增明应略标宗显其理趣。颂曰

  三世有由说　　二有境果故
  说三世有故　　许说一切有

论曰。三世实有。所以者何。由契经中世尊说故。谓世尊说。苾刍当知。若过去色非有。不应多闻圣弟子众于过去色勤修厌舍。以过去色是有故。应多闻圣弟子众于过去色勤修厌舍。若未来色非有。不应多闻圣弟子众于未来色勤断欣求。以未来色是有故。应多闻圣弟子众于未来色勤断欣求。又具二缘识方生故。谓契经说。识二缘生。其二者何。谓眼及色。广说乃至意及诸法。若去来世非实有者。能缘彼识应阙二缘。已依圣教证去来有。当依正理证有去来。以识起时必有境故。谓必有境识乃得生。无则不生。其理决定。若去来世境体实无。是则应有无所缘识。所缘无故识亦应无。又已谢业有当果故。谓若实无过去体者。善恶二业当果应无。非果生时有现因在。由此教理。毗婆沙师。定立去来二世实有。若自谓是说一切有宗决定应许实有去来世。以说三世皆定实有故。许是说一切有宗。谓若有人说三世实有。方许彼是说一切有宗。若人唯说有现在世及过去世未与果业。说无未来及过去世已与果业。彼可许为分别说部。非此部摄。今此部中差别有几。谁所立世最善可依。颂曰

  此中有四种　　类相位待异
  第三约作用　　立世最为善

论曰。尊者法救作如是说。由类不同三世有异。彼谓诸法行于世时。由类有殊非体有异。如破金器作余物时。形虽有殊而体无异。又如乳变成于酪时。舍味势等。非舍显色。如是诸法行于世时。从未来至现在。从现在入过去。唯舍得类非舍得体。尊者妙音作如是说。由相不同三世有异。彼谓诸法行于世时。过去正与过去相合。而不名为离现未相。未来正与未来相合。而不名为离过现相。现在正与现在相合。而不名为离过未相。如人正染一妻室时。于余姬媵不名离染。尊者世友作如是说。由位不同三世有异。彼谓诸法行于世时。至位位中作异异说。由位有别非体有异。如运一筹置一名一置百名百置千名千。尊者觉天作如是说。由待有别三世有异。彼谓诸法行于世时。前后相待立名有异。如一女人名母名女。此四种说一切有中。第一执法有转变故。应置数论外道朋中。第二所立世相杂乱。三世皆有三世相故。人于妻室贪现行时。于余境贪唯有成就。现无贪起何义为同。第四所立前后相待。一世法中应有三世。谓过去世前后刹那。应名去来中为现在。未来现在类亦应然。故此四中第三最善。以约作用位有差别。由位不同立世有异。彼谓诸法作用未有名为未来。有作用时名为现在。作用已灭名为过去。非体有殊。此已具知。彼应复说。若去来世体亦实有应名现在。何谓去来。岂不前言约作用立。若尔现在有眼等根彼同分摄有何作用。彼岂不能取果与果。是则过去同类因等既能与果。应有作用。有半作用世相应杂。已略推征。次当广破。颂曰

  何碍用云何　　无异世便坏
  有谁未生灭　　此法性甚深

论曰。应说若法自体恒有。应一切时能起作用。以何碍力令此法体所起作用时有时无。若谓众缘不和合者。此救非理。许常有故。又此作用云何得说为去来今。岂作用中而得更立有余作用。若此作用非去来今而复说言作用是有。则无为故应常非无故不应言作用已灭及此未有法名去来。若许作用异法体者。可有此失。然无有异。故不应言有此过失。若尔所立世义便坏。谓若作用即是法体。体既恒有用亦应然。何得有时名为过未。故彼所立世义不成。何为不成。以有为法未已生名未来。若已生未已灭名现在。若已灭名过去。彼复应说若如现在法体实有去来亦然。谁未已生谁复已灭。谓有为法体实恒有。如何可得成未已生已灭。先何所阙。彼未有故名未已生。后复阙何。彼已无故名为已灭。故不许法本无今有有已还无则三世义。应一切种皆不成立。然彼所说恒与有为诸相合故。行非常者此但有虚言。生灭理无故。许体恒有说性非常。如是义言所未曾有。依如是义。故有颂言

  许法体恒有　　而说性非常
  性体复无别　　此真自在作

又彼所言世尊说故。去来二世体实有者。我等亦说有去来世。谓过去世曾有名有。未来当有。有果因故。依如是义说有去来。非谓去来如现实有。谁言彼有如现在世。非如现世彼有云何。彼有去来二世自性。此复应诘。若俱是有如何可言是去来性。故说彼有。但据曾当因果二性。非体实有。世尊为遮谤因果见据曾当义说有去来。有声通显有无法故。如世间说有灯先无有灯后无。又如有言有灯已灭非我今灭。说有去来其义亦应尔。若不尔者去来性不成。若尔何缘世尊依彼杖髻外道说业过去尽灭变坏而犹是有。岂彼不许业曾有性。而今世尊重为说有。依彼所引现相续中与果功能。密说为有。若不尔者。彼过去业现实有性过去岂成。理必应尔。以薄伽梵于胜义空契经中说。眼根生位无所从来。眼根灭时无所造集。本无今有有已还无。去来眼根若实有者。经不应说本无等言。若谓此言依现世说此救非理。以现世性与彼眼根体无别故。若许现世本无今有有已还无。是则眼根去来无体义已成立。又彼所说。要具二缘识方生故。去来二世体实有者。应共寻思。意法为缘生意识者。为法如意作能生缘。为法但能作所缘境。若法如意作能生缘。如何未来百千劫后当有彼法。或当亦无为能生缘生今时识。又涅槃性违一切生立为能生不应正理。若法但能为所缘境。我说过未亦是所缘。若无如何成所缘境。我说彼有如成所缘。如何成所缘。谓曾有当有。非忆过去色受等时。如现分明观彼为有。但追忆彼曾有之相。逆观未来当有亦尔。谓如曾现在所领色相。如是追忆过去为有。亦如当现在所领色相如是逆观未来为有。若如现有应成现世。若体现无。则应许有缘无境识。其理自成。若谓去来极微散乱有而非现。理亦不然。取彼相时非散乱故。又若彼色有同现在。唯有极微散乱为异。则极微色其体应常。又色唯应极微聚散竟无少分可名生灭。是则遵崇邪命者论弃背善逝所说契经。如契经说。眼根生位无所从来。乃至广说。又非受等极微集成。如何可言去来散乱。然于受等追忆逆观。亦如未灭已生时相。若如现有体应是常。若体现无。还应许有缘无境识。理亦自成。若体全无是所缘者第十三处应是所缘。诸有达无第十三处。此能缘识为何所缘。若谓即缘彼名为境。是则应拨彼名为无。又若缘声先非有者。此能缘识为何所缘。若谓即缘彼声为境求声无者应更发声。若谓声无住未来位。未来实有如何谓无。若谓去来无现世者。此亦非理。其体一故。若有少分体差别者。本无今有其理自成。故识通缘有非有境。然菩萨说世间所无我知我见无是处者。意说。他人怀增上慢亦于非有现相谓有。我唯于有方观为有。若异此者则一切觉皆有所缘。何缘于境得有犹豫。或有差别。理必应然。以薄伽梵于余处说善来苾刍。汝等若能为我弟子。无谄无诳有信有勤。我旦教汝令暮获胜。我暮教汝令旦获胜。便知有是有。非有是非有。有上是有上。无上是无上。由此彼说。识有境故有去来者。亦不成因。又彼所言。业有果故有去来者。理亦不然。非经部师作如是说。即过去业能生当果。然业为先所引相续。转变差别令当果生。彼我品中当广显示。若执实有过去未来则一切时果体常有业于彼果有何功能。若谓能生则所生果本无今有其理自成。若一切法一切时有。谁于谁有能生功能。又应显成雨众外道所党邪论。彼作是说。有必常有。无必常无。无必不生。有必不灭。若谓能令果成现在如何令果成现在耶。若谓引令至余方所则所引果其体应常。又无色法当如何引。又此所引应体本无。若谓但令体有差别。本无今有其理自成。是故此说一切有部。若说实有过去未来。于圣教中非为善说。若欲善说一切有者。应如契经所说而说。经如何说。如契经言。梵志当知。一切有者。唯十二处或唯三世。如其所有而说有言。若去来无如何可说有能所系及离系耶。彼所生因随眠有故。说有去来能系烦恼。缘彼烦恼随眠有故。说有去来所系缚事。若随眠断得离系名。毗婆沙师作如是说。如现实有过去未来。所有于中不能通释。诸自爱者应如是知。法性甚深非寻思境。岂不能释便拨为无。有异门故此生此灭。谓色等生即色等灭。有异门故异生异灭。谓未来生现在世灭。有异门故即世名生。以正生时世所摄故。有异门故说世有生。未来世有多刹那故。傍论已了。今应思择。诸事已断彼离系耶。设事离系彼已断耶。若事离系彼必已断。有事已断而非离系。断非离系其事云何。颂曰

  于见苦已断　　余遍行随眠
  及前品已断　　余缘此犹系

论曰。且见道位。苦智已生集智未生。见苦所断诸事已断。见集所断遍行随眠若未永断能缘此者于此犹系。及修道位随何道生。九品事中前品已断。余未断品所有随眠能缘此者于此犹系。断非离系。如是应知。何事有几随眠随增。若随事别答。便费多言论。是故应造略毗婆沙。由此虽劳少少功力。而能越渡大大问流。谓法虽多略为十六种即三界五部及无漏法。能缘彼识名数亦然但应了知何法何识境。易思何事何随眠随增。此中且应知何法何识境。颂曰

  见苦集修断　　若欲界所系
  自界三色一　　无漏识所行
  色自下各三　　上一净识境
  无色通三界　　各三净识缘
  见灭道所断　　皆增自识行
  无漏三界中　　后三净识境

论曰。若欲界系见苦见集修所断法。各五识缘。谓自界三即如前说。及色界一即修所断。无漏第五。皆容缘故。若色界系即前所说三部诸法各八识缘。谓自下三皆如前说。及上界一即修所断。无漏第八。皆容缘故。若无色系即前所说三部诸法各十识缘。谓三界三皆如前说。无漏第十皆容缘故。见灭见道所断诸法。应知一一增自识缘。此复云何。谓欲界系见灭所断为六识缘。五即如前。增见灭断。见道所断为六识缘。五亦如前。增见道断。色无色界见灭道断。随应为九十一识缘。若无漏法为十识缘。谓三界中各后三部。即见灭道修所断识。无漏第十。皆容缘故。为摄前义。复说颂言

  见苦集修断　　欲色无色系
  应知如次第　　五八十识缘
  见灭道所断　　各增自识缘
  无漏法应知　　能为十识境

如是了知十六种法为十六识所缘境已。今应思何事何随眠随增。若别疏条恐文烦广。故我于此略示方隅。且有问言。所系事内乐根有几随眠随增。应观乐根总有七种。谓欲界一即修所断。色界五部。无漏第七。一切无漏非诸随眠之所随增。如前已说。此中前六随其所应欲修所断及诸遍行色界一切随眠随增。若有问言。缘乐根识复有几种随眠随增。应观此识总有十二。谓欲界四除见灭断。色界五部。无色界二。即见道谛及修所断。无漏第十二。皆能缘乐根。此随所应欲界四部。色界有为缘。无色界二部。及诸遍行随眠随增。若复有问言。缘缘乐根识复有几种随眠随增。应观此识总有十四。于前十二更加二种。即无色界见苦集断。如是十四识能缘缘乐根。此随所应欲色如上。无色四部随眠随增。准此方隅余应思择。若心由彼名有随眠。彼于此心定随增不。此不决定。或有随眠。谓与心相应。及缘心未断相应已断则不随增。依此义门应作是说。颂曰

  有随眠心二　　谓有染无染
  有染心通二　　无染局随增

论曰。有随眠心总有二种。有染无染心差别故。于中有染或有随增。谓相应缘随眠未断。相应已断则不随增。仍说有随眠。以恒相应故。若无染者。唯局随增。缘此随眠必未永断。此唯据随增名有随眠故。如上所说十种随眠次第生时。谁前谁后。颂曰

  无明疑邪身　　边见戒见取
  贪慢嗔如次　　由前引后生

论曰。且诸烦恼次第生时。先由无明于谛不了。不欲观苦乃至道谛。由不了故。次引生疑。谓闻二途便怀犹豫。为苦非苦。乃至广说。从此犹豫引邪见生。谓邪闻思生邪决定拨无苦谛乃至广说。由拨无谛引身见生。谓取蕴中拨无苦理。便决定执此是我故。从此身见引边见生。谓依我执断常边故从此边见引生戒取。谓由于我随执一边便计此执为能净故。从戒禁取引见取生。谓计能净已必执为胜故。从此见取次引贪生。谓自见中情深爱故。从此贪后次引慢生。谓自见中深爱着己。恃生高举陵蔑他故。从此慢后次引生嗔。谓自见中深爱恃己。于他所起违己见中情不能忍必憎嫌故。有余师说。于自见解取舍位中起憎嫌故。见谛所断贪等生时。缘自相续见为境故。如是且依次第起。说越次起者前后无定。诸烦恼起由几因缘。颂曰

  由未断随眠　　及随应境现
  非理作意起　　说或具因缘

论曰。由三因缘诸烦恼起。且如将起欲贪缠时。未断未遍知欲贪随眠故。顺欲贪境现在前故。缘彼非理作意起故。由此力故便起欲贪。此三因缘如其次第即因境界加行三力。余烦恼起类此应知。谓此且据具因缘说。或有唯托境界力生。如退法根阿罗汉等。即上所说随眠并缠。经说为漏瀑流轭取。漏谓三漏。一欲漏。二有漏。三无明漏。言瀑流者。谓四瀑流。一欲瀑流。二有瀑流。三见瀑流。四无明瀑流。轭谓四轭。如瀑流说。取谓四取。一欲取。二见取。三戒禁取。四我语取。如是漏等其体云何。颂曰

  欲烦恼并缠　　除痴名欲漏
  有漏上二界　　唯烦恼除痴
  同无记内门　　定地故合一
  无明诸有本　　故别为一漏
  瀑流轭亦然　　别立见利故
  见不顺住故　　非于漏独立
  欲有轭并痴　　见分二名取
  无明不别立　　以非能取故

论曰。欲界烦恼并缠除痴四十一物总名欲漏。谓欲界系根本烦恼三十一并十缠。色无色界烦恼除痴五十二物总名有漏。谓上二界根本烦恼各二十六。岂不彼有惛沉掉举二种缠耶。品类足中亦作是说。云何有漏。谓除无明余色无色二界所系结缚随眠随烦恼缠。今于此中何故不说。迦湿弥罗国毗婆沙师言。彼界缠少不自在故。何缘合说二界随眠为一有漏。同无记性于内门转。依定地生。由三义同故合为一。如前所说名有贪因。即是此中名有漏义。准此三界十五无明义至已立为无明漏。何缘唯此别立漏名。无明能为诸有本故。瀑流及轭体与漏同。然于其中见亦别立。谓前欲漏即欲瀑流及欲轭。如是有漏即有瀑流及有轭。析出诸见为见瀑流及见轭者。谓猛利故令住名漏。如后当说。见不顺彼。性猛利故。由此于漏不独立名。但可与余合立为漏。如是已显二十九物名欲瀑流谓贪嗔慢各有五种疑四缠十。二十八物名有瀑流。谓贪与慢各十疑八。三十六物名见瀑流谓三界中各十二见。十五物名无明瀑流。谓三界无明各有五。应知四轭与瀑流同。四取应知体同四轭。然欲我语各并无明。见分为二与前轭别。即前欲轭并欲无明三十四物总名欲取。谓贪嗔慢无明各五疑有四并十缠。即前有轭并二界无明三十八物总名我语取。谓贪慢无明各十疑有八。于见轭中除戒禁取余三十物总名见取。所除六物名戒禁取。何缘别立戒禁取耶。由此独为圣道怨故。双诳在家出家众故。谓在家众由此诳惑计自饿等为天道故。诸出家众由此诳惑计舍可爱境为清净道故。何缘无明不别立取。能取诸有故立取名。然诸无明非能取故。谓不了相说名无明。彼非能取。非猛利故。但可与余合立为取。然契经说。欲轭云何。谓诸欲中欲贪欲欲欲亲欲爱欲乐欲闷欲耽欲嗜欲喜欲藏欲随欲着缠压于心。是名欲轭。有轭见轭应知亦尔。又余经说。欲贪名取。由此故知。于欲等四所起欲贪名欲等取。如是已辩随眠并缠。经说为漏瀑流轭取。此随眠等名有何义。颂曰

  微细二随增　　随逐与随缚
  住流漂合执　　是随眠等义

论曰。根本烦恼现在前时行相难知故名微细。二随增者。能于所缘及所相应增惛滞故。言随逐者。谓能起得恒随有情常为过患。不作加行为令彼生。或设劬劳为遮彼起而数现起故名随缚。由如是义故名随眠。稽留有情久住生死。或令流转于生死中。从有顶天至无间狱。由彼相续于六疮门泄过无穷故名为漏。极漂善品故名瀑流。和合有情故名为轭。能为依执故名为取。若善释者应作是言。诸境界中流注相续泄过不绝故名为漏。如契经说。具寿当知。譬如挽船逆流而上。设大功用行尚为难。若放此船顺流而去。虽舍功用行不为难。起善染心应知亦尔。准此经意。于境界中烦恼不绝说名为漏。若势增上说名瀑流。谓诸有情若坠于彼。唯可随顺无能违逆。涌泛漂激难违拒故。于现行时非极增上说名为轭。但令有情与种种类苦和合故。或数现行故名为轭。执欲等故说名为取

说一切有部俱舍论卷第二十阿毗达磨俱舍论卷第二十一

        尊者世亲造

        三藏法师玄奘奉　诏译

    分别随眠品第五之三

如是已辩随眠并缠。世尊说为漏瀑流等。为唯尔所。为复有余。颂曰

  由结等差别　　复说有五种

论曰。即诸烦恼结缚随眠随烦恼缠义差别故。复说五种。且结云何。颂曰

  结九物取等　　立见取二结
  由二唯不善　　及自在起故
  缠中唯嫉悭　　建立为二结
  或二数行故　　为贱贫因故
  遍显随惑故　　恼乱二部故

论曰。结有九种。一爱结。二恚结。三慢结。四无明结。五见结。六取结。七疑结。八嫉结。九悭结。此中爱结谓三界贪。余随所应当辩其相。见结谓三见。取结谓二取。依如是理故。有说言。颇有见相应法为爱结系非见结系。非不有见随眠随增。曰有。云何。集智已生灭智未生见灭道所断二取相应法。彼为爱结为所缘系非见结系。遍行见结已永断故。非遍见结所缘相应二俱无故。然彼有见随眠随增。二取见随眠于彼随增故。何缘三见别立见结二取别立为取结耶。三见二取物取等故。谓彼三见有十八物。二取亦然。故名物等。三等所取。二等能取。故名取等。所取能取有差别故立为二结。何故缠中嫉悭二种建立为结非余缠耶。二唯不善自在起故。谓唯此二两义具足。余皆不然。故唯立二。若缠唯八此释可然。许有十缠此释非理。以忿覆二种亦具两义故。由此若许具有十缠。应言嫉悭过失尤重。谓此二种数现行故。又二能为贱贪因故。遍显戚欢随烦恼故。恼乱出家在家部故。或恼乱天阿素洛故。或恼人天二胜趣故。或恼乱他及自部故。佛于余处依差别门。即以结声说有五种。颂曰

  又五顺下分　　由二不超欲
  由三复还下　　摄门根故三
  或不欲发趣　　迷道及疑道
  能障趣解脱　　故唯说断三

论曰。何等为五。谓有身见戒禁取疑欲贪嗔恚。何缘此五名顺下分。此五顺益下分界故。谓唯欲界得下分名。此五于彼能为顺益。由后二种不能超欲界。设有能超由前三还下。如守狱卒防逻人故。有余师说。言下分者。谓下有情即诸异生。及下界即欲界。前三能障超下有情。后二能令不超下界。故五皆得顺下分名。诸得预流六烦恼断。何缘但说断三结耶。理实应言断六烦恼。摄门根故但说断三。谓所断中类有三种。唯一通二通四部故。说断三种摄彼三门。又所断中三随三转。谓边执见随身见转。见取随戒取转。邪见随疑转。说断三种摄彼三根。故说断三已说断六。有作是释。凡趣异方有三种障。一不欲发。二迷正道。依邪道故。三疑正道。趣解脱者亦有如斯相似三障。谓由身见怖畏解脱不欲发趣。由戒禁取依执邪道迷失正路。由疑于道深怀犹预。佛显预流永断如是趣解脱障故说断三。佛于余经如顺下分。说顺上分亦有五种。颂曰

  顺上分亦五　　色无色二贪
  掉举慢无明　　令不超上故

论曰。如是五种若未断时。能令有情不超上界。顺益上界故名顺上分结。已辩结。缚云何。颂曰

  缚三由三受

论曰。缚有三种。一贪缚。谓一切贪。二嗔缚。谓一切嗔。三痴缚。谓一切痴。何缘唯说此三为缚。由随三受说缚有三。谓于乐受贪缚随增。所缘相应俱随增故。于苦受嗔。于舍受痴。应知亦尔。虽于舍受亦有贪嗔非如痴故。约自相续乐等三受为缚所缘作此定说。已分别缚。随眠云何。颂曰

  随眠前已说

论曰。随眠有六。或七或十或九十八。如前已说。随眠既已说。随烦恼云何。颂曰

  随烦恼此余　　染心所行蕴

论曰。此诸烦恼亦名随烦恼。以皆随心为恼乱事故。复有此余异诸烦恼染污心所行蕴所摄。随烦恼起故亦名随烦恼。不名烦恼非根本故。广列彼相如杂事中。后当略论缠烦恼垢摄者。且应先辩。缠相云何。颂曰

  缠八无惭愧　　嫉悭并悔眠
  及掉举惛沈　　或十加忿覆
  无惭悭掉举　　皆从贪所生
  无愧眠惛沈　　从无明所起
  嫉忿从嗔起　　悔从疑覆诤

论曰。根本烦恼亦名为缠。经说欲贪缠为缘故。然品类足说有八缠。毗婆沙宗说缠有十。谓于前八更加忿覆。无惭无愧如前已释。嫉谓于他诸兴盛事令心不喜。悭谓财法巧施相违令心吝着。悔即恶作。如前已辩。眠谓令心昧略为性。无有功力执持于身。悔眠二缠唯取染污。掉举惛沈亦如前释。除嗔及害于情非情令心愤发说名为忿。隐藏自罪说名为覆。于此所说十种缠中无惭悭掉举是贪等流。无愧眠惛沈是无明等流。嫉忿是嗔等流。悔是疑等流。有说。覆是贪等流。有说。是无明等流。有说。是俱等流。有知无知如其次第。余烦恼垢其相云何。颂曰

  烦恼垢六恼　　害恨谄诳憍
  诳憍从贪生　　害恨从嗔起
  恼从见取起　　谄从诸见生

论曰。恼谓坚执诸有罪事。由此不取如理谏悔。害谓于他能为逼迫。由此能行打骂等事。恨谓于忿所缘事中数数寻思结怨不舍。谄谓心曲。由此不能如实自显。或矫非拨。或设方便令解不明。诳谓惑他。憍前已释。如是六种从烦恼生。秽污相粗名烦恼垢。于此六种烦恼垢中。诳憍是贪等流。害恨是嗔等流。恼是见取等流。谄是诸见等流。如言何曲谓诸恶见。故谄定是诸见等流。此垢并缠从烦恼起。是故皆立随烦恼名。此垢及缠为何所断。颂曰

  缠无惭愧眠　　惛掉见修断
  余及烦恼垢　　自在故唯修

论曰。且十缠中无惭等五通见修断。由此通与二部烦恼相应起故。随与见此谛所断相应。即说名为见此谛所断。余嫉悭悔忿覆并垢自在起故唯修所断。唯与修断他力无明共相应故名自在起。此随烦恼谁通何性。颂曰

  欲三二余恶　　上界皆无记

论曰。欲界所系眠惛掉三皆通不善无记二性所余一切皆唯不善。上二界中随应所有一切唯是无记性摄。此随烦恼谁何界系。颂曰

  谄诳欲初定　　三三界余欲

论曰。谄诳唯在欲界初定。宁知梵世有谄诳耶。以大梵王匿己情事。现相诳惑马胜苾刍。此二于前虽已分别义相应故今复重辩。惛掉憍三通在三界。所余一切皆唯在欲。谓十六中五如前辩。所余十一唯欲界系。已辩随眠及随烦恼。于中有几唯在意地。有几通依六识地起。颂曰

  见所断慢眠　　自在随烦恼
  皆唯意地起　　余通依六识

论曰。略说应知。诸见所断及修所断。一切慢眠随烦恼中自在起者。如是一切皆依意识。依五识身无容起故。所余一切通依六识。谓修所断贪嗔无明及彼相应诸随烦恼即无惭愧惛掉及余大烦恼地法所摄随烦恼依六识身皆容起故。如先所辩乐等五受根。今此所明烦恼随烦恼。何烦恼等何根相应。于此先应辩诸烦恼。颂曰

  欲界诸烦恼　　贪喜乐相应
  嗔忧苦痴遍　　邪见忧及喜
  疑忧余五喜　　一切舍相应
  上地皆随应　　遍自识诸受

论曰。欲界所系诸烦恼中。贪喜乐相应。以欢行转遍六识故。嗔忧苦相应。以戚行转遍六识故。无明遍与前四相应。欢戚行转遍六识故。邪见通与忧喜相应。欢戚行转唯意地故。何缘邪见欢戚行转。如次先造罪福业故。疑忧相应。以戚行转唯意地故。怀犹预者求决定知心愁戚故。余四见慢与喜相应。以欢行转唯意地故。已约别相说受相应。就通相说受相应者。一切皆与舍受相应。以诸随眠相续断位势力衰歇必住舍受。欲界既尔。上地云何。皆随所应遍与自地自识俱起诸受相应。谓若地中具有四识彼一一识所起烦恼各遍自识诸受相应。若诸地中唯有意识即彼意识所起烦恼遍与意识识受相应。上诸地中识受多少如前已辩。故不别说。已辩烦恼诸受相应。今次复应辩随烦恼。颂曰

  诸随烦恼中　　嫉悔忿及恼
  害恨忧俱起　　悭喜受相应
  谄诳及眠覆　　通忧喜俱起
  憍喜乐皆舍　　余四遍相应

论曰。随烦恼中嫉等六种。一切皆与忧根相应。以戚行转唯意地故。悭喜相应。以欢行转唯意地故。欢行转者。悭相与贪极相似故。谄诳眠覆忧喜相应。欢戚行转唯意地故。欢戚行者。谓或有时以欢喜心而行谄等。或时有以忧戚心行。憍喜乐相应。欢行唯意故。在第三静虑与乐相应。若在下诸地与喜相应。此上所说诸随烦恼一切皆与舍受相应。相续断时皆住舍故。有通行在唯舍地故。舍于一切相应无遮。譬如无明遍相应故。余无惭愧惛沉掉举四皆遍与五受相应。前二是大不善地法摄故。后二是大烦恼地法摄故。所说烦恼随烦恼中。有依异门。佛说为盖。今次应辩。盖相云何。颂曰

  盖五唯在欲　　食治用同故
  虽二立一盖　　障蕴故唯五

论曰。佛于经中说盖有五。一欲贪盖。二嗔恚盖。三惛眠盖。四掉悔盖。五疑盖。此中所说惛掉及疑。为如欲贪嗔恚眠悔唯在欲界。通三界耶。应知此三亦唯在欲。以契经说如是五种纯是圆满不善聚故。色无色界无有不善。然此五种纯不善故。唯在欲界非色无色。何故惛眠掉悔二盖各有二体合立一耶。食治用同故合立一。食谓所食。亦名资粮。治谓能治。亦名非食。用谓事用。亦名功能。由此经中作如是说。惛眠虽二食非食同。何等名为惛眠盖食。谓五种法。一[夢-夕+登]瞢。二不乐。三频申。四食不平性。五心昧劣性。何等名为此盖非食。谓光明想。如是二种事用亦同。谓俱能令心性沈昧。掉悔虽二食非食同。何等名为掉悔盖食。谓四种法。一亲里寻。二国土寻。三不死寻。四随念昔种种所更戏笑欢娱承奉等事。何等名为此盖非食。谓奢摩他。如是二种事用亦同。谓俱能令心不寂静。由此说食治用同故惛眠掉悔二合为一。诸烦恼等皆有盖义。何故如来唯说此五。唯此于五蕴能为胜障故。谓贪恚盖能障戒蕴。惛沉睡眠能障慧蕴。掉举恶作能障定蕴。定慧无故于四谛疑。疑故能令乃至解脱解脱智见皆不得起。故唯此五建立为盖。若作如是解释经意。掉悔理应惛眠前说。以必依定方有慧生。定障亦应先慧障故。依如是理。有余师言。此五盖中。惛眠掉悔如次能障定蕴慧蕴。由此契经作如是说。修等持者怖畏惛眠。修择法者怖畏掉悔。有余别说。唯立五因。彼说云何。谓在行位。先于色等种种境中取可爱憎二种相故。后在住位由先为因。便起欲贪嗔恚二盖。此二能障将入定心。由此后时正入定位于止及观不能正习。由此便起惛眠掉悔如其次第障奢摩他毗钵舍那令不得起。由此于后出定位中思择法时疑复为障。故建立盖唯有此五。今应思择。他界遍行及见灭道断有漏缘诸惑于彼断位不知彼所缘。知彼所缘时而彼不断。如是诸惑断由何因。非要遍知所缘故断。若尔断惑总由几因。由四种因。何等为四。颂曰

  遍知所缘故　　断彼能缘故
  断彼所缘故　　对治起故断

论曰。且见所断惑断由前三因。一由遍知所缘故断。谓见苦集断自界缘。及见灭道断无漏缘。二由断彼能缘故断。谓见苦集断他界缘。以自界缘能缘于彼。能缘若断彼随断故。三由断彼所缘故断。谓见灭道断有漏缘。以无漏缘能为彼境所缘若断彼随断故。若修所断惑断由后一因。谓但由第四对治起故断。以若此品对治道生则此品中诸惑顿断。何品诸惑谁为对治。谓上上品所有诸惑。下下品道能为对治。至下下品所有诸惑。上上品道能为对治。如是义门后当广辩。所言对治总有几种。颂曰

  对治有四种　　谓断持远厌

论曰。诸对治门总有四种。一断对治。谓无间道。二持对治。谓此后道。由彼能持此断得故。三远分对治。谓解脱道后所有道。由彼道能令此所断惑得更远故。有余师说。亦解脱道。以解脱道如彼能令此所断惑得更远故四厌患对治。谓若有道见此界过失深生厌患。然此对治若欲善说。理实应为如是次第。一厌患对治。谓缘苦集起加行道。二断对治。谓缘一切起无间道。三持对治。谓缘一切起解脱道。四远分对治。谓缘一切起胜进道。诸惑永断为定从何。颂曰

  应知从所缘　　可令诸惑断

论曰。应知诸惑得永断时。不可令其离相应法。但可令彼远离所缘。令于所缘不复生故。断未来惑理且可然。容令于境不复生故。过去诸惑云何说断。若谓颂说从所缘言意显遍知所缘故断。此亦非理。不决定故。由此应说烦恼等断定何所从。自相续中烦恼等断由得断故。他相续中诸烦恼等及一切色不染法断。由能缘彼自相续中所有诸惑究竟断故。所言远分远性有几。颂曰

  远性有四种　　谓相治处时
  如大种尸罗　　异方二世等

论曰。传说。远性总有四种。一相远性。如四大种。虽复俱在一聚中生以相异故亦名为远二治远性。如持犯戒。虽复俱在一身中行以相治故亦名为远。三处远性。如东西海。虽复俱在一世界中方处隔故亦名为远。四时远性。如过未世。虽复俱依一法上立时分隔故亦名为远。望何说远。望现在世。无间已灭及正生时与现相邻。如何名远。由世性别故得远名。非久曾当方得名远。若尔现在亦应得远名。以望去来世性亦别故。若谓去来法无作用离作用故名为远者。诸无为法作用说无。云何名近。若谓由现遍得无为故名近者。去来二世例亦应然。虚空无为如何名近。若谓过未更互相望由隔现在故名为远。现望二世俱极相邻。无为无隔故皆近者。则应去来邻现在世。相望有隔故具二名。不应一向说名为远。若依正理应说去来离法自相故名为远。未来未得法自相故。过去已舍法自相故。等言为明举事未尽。前言惑断由治道生。道胜进时所断诸惑为再断不。所得离系有重得耶。颂曰

  诸惑无再断　　离系有重得
  谓治生得果　　练根六时中

论曰。诸惑若得彼能断道。即由彼道此惑顿断。必无后时再断惑义。所得离系虽无随道渐胜进理。而道进时。容有重起。彼胜得义。所言重得总有几时。总有六时。何等为六。谓治道起得果练根。治道起时。谓解脱道。得果时者。谓得预流一来不还阿罗汉果。练根时者。谓转根时。此六时中诸惑离系随道胜进重起胜得。然诸离系随应当知。有具六时起胜得者。乃至亦有唯具二时。谓欲界系见四谛断及色无色见三谛断所有离系具六时得。色无色界见道谛断所有离系唯五时得。由治生时即得果故。不应于此分为二时。欲界修断五品离系亦五时得。除预流果。第六离系唯四时得。谓于前五又除一时。得果治生时无异故。第七八品亦四时得。得果四中除前二故。第九离系唯三时得。谓于前四又除一时。亦治生时即得果故。色无色界修所断中。唯除有顶第九离系所余离系亦三时得。得果四中除前三故。有顶第九唯二时得。谓前三内又除一时。亦治生时即得果故。如是且说容有理说。以利根者前诸位中一一皆除练根得故。诸有超越入圣道者随应有除预流等故。即诸离系彼彼位中得遍知名。遍知有二。一智遍知。二断遍知。智遍知者。谓无漏智。断遍知者。谓即诸断。此于果上立因名故。为一切断立一遍知。不尔。云何。颂曰

  断遍知有九　　欲初二断一
  二各一合三　　上界三亦尔
  余五顺下分　　色一切断三

论曰。诸断总立九种遍知。谓三界系见谛所断烦恼等断立六遍知。所余三界修道所断烦恼等断立三遍知。且三界系见谛所断烦恼等断立六云何。谓欲界系初二部断立一遍知。初二部言即显见苦见集所断。次二部断各立一遍知。次二部言显见灭道断。如是欲界见谛所断烦恼等断立三遍知。如欲界三上界亦尔。谓色无色二界所系。亦初二断一二各一合三。是见苦集见灭见道所断法断合立三义。如是名为三界见谛所断法断六种遍知。余三界系修道所断烦恼等断立三云何。谓欲界系修道所断烦恼等断立一遍知。应知即是五顺下分结尽遍知。并前立故。色界所系修道所断烦恼等断立一遍知。应知此即是色爱尽遍知。无色界系修道所断烦恼等断立一遍知。即一切结永尽遍知。此亦并前合立一故。如是名为三界修道所断法断三种遍知。以何因缘色无色界修道所断烦恼等断别立遍知非见所断。以修所断治不同故。如是所立九种遍知。应辩于中几何道果。颂曰

  于中忍果六　　余三是智果
  未至果一切　　根本五或八
  无色边果一　　三根本亦尔
  俗果二圣九　　法智三类二
  法智品果六　　类智品果五

论曰。于此九中且应先辩与忍智道为果差别。忍果有六。谓三界系见断法断六种遍知。智果有三。谓顺下分色爱一切结尽遍知。由此三遍知是修道果故。如何忍果说为遍知。诸忍皆是智眷属故。如王眷属假立王名。或忍与智同一果故。今次应辩与静虑地眷属根本为果差别。未至静虑果具有九。谓此为依能断三界见修所断烦恼等故。根本静虑果五或八。所言五者。毗婆沙师说。根本地唯能永断色无色摄烦恼等故。欲界所系烦恼等断彼唯许是未至果故。所言八者。尊者妙音说。根本地亦与欲界诸烦恼等为断对治。诸有先离欲界染者。依根本地入见谛时。于欲界系见断法断许别道引无漏得故。由此亦是彼见道果。除顺下分结尽遍知。以彼唯是未至果故。无容修彼断对治故。中间静虑如根本说。今次应辩与无色地眷属根本为果差别。无色边地果唯有一。谓依空处近分地道得色爱尽遍知果故。前三根本果亦唯一。谓依无色前三根本得一切尽遍知果故。今次应辩与世俗道及诸圣道为果差别。俗道果二。谓俗道力唯能获得顺下分尽及色爱尽遍知果故。圣道果九。谓圣道力遍能永断三界法故。今次应辩与法类智为果差别。法智果三。谓法智力能断三界修所断故得后三果类智果二。谓类智力但能永断色无色界修所断故。得后二果。今次应辩与法类智同品诸道为果差别。法智品果六。谓即是前法智法忍所得六果。类智品果五。谓即是前类智类忍所得五果。品言通摄智及忍故。何故一一断不别立遍知。唯就如前九位建立。颂曰

  得无漏断得　　及缺第一有
  灭双因越界　　故立九遍知

论曰。有漏法断虽多体位。而四缘故立九遍知。且由三缘立六忍果。谓得无漏离系得故。缺有顶故。灭双因故。诸断要具如是三缘立遍知名。阙则不尔。如异生位有灭双因无无漏断得。未缺有顶故。虽亦得断不名遍知。若圣位中从入见谛至苦类忍现行以前。虽有已得无漏断得未缺有顶未灭双因。至苦类智集法忍位。虽亦缺有顶犹未灭双因。未灭见集断诸遍行因故。至后法智类智位中诸所得断。三缘具故。于一一位建立遍知。具由四缘立三智果。谓于前三加越界故。言越界者。谓此界中烦恼等法皆全离故。有立离俱系亦是一缘故。立遍知缘总有五种。离俱系者。谓此虽断未立遍知。要离所余缘此境。或方可建立。此离俱系与灭双因及越界缘。用无别故。虽义有异而不别说。虽诸越界位皆灭双因而灭双因时非皆越界故。灭双因外别立越界缘。灭三地双因未立遍知故。谁成就几遍知。颂曰

  住见谛位无　　或成一至五
  修成六一二　　无学唯成一

论曰。异生定无成遍知理。若诸圣者住见谛位。从初乃至集法忍时。于诸遍知亦未成就。至集法智集类忍时唯成就一。至集类智灭法忍时便成就二。至灭法智灭类忍时便成就三。至灭类智道法忍时便成就四。至道法智道类忍时便成就五。住修道位道类智为初。乃至未得全离欲界染及离欲退皆成就六。至全离欲色爱未尽。或先离欲从道类智未起色尽胜果道前。唯成一遍知。谓顺下分尽。从色爱尽及无学位起色缠退亦一如前。有色爱者从色爱永尽先离色者从起色尽道至未全离无色爱前成下分尽色爱尽二。从无学退起无色缠成二遍知。名如前说。住无学位唯成就一。谓一切结永尽遍知。何缘不还阿罗汉果总集诸断立一遍知。颂曰

  越界得果故　　二处集遍知

论曰。具二缘故。于一切断总集建立为一遍知。一者越界。二者得果。唯彼两位具足二缘。故彼遍知总集为一。谁舍谁得几种遍知。颂曰

  舍一二五六　　得亦然除五

论曰。言舍一者。谓从无学及色爱尽全离欲退。言舍二者。谓诸不还从色爱尽起欲缠退。及彼获得阿罗汉时。言舍五者。谓先离欲后入见谛道类智时得下分尽舍前五故。言舍六者。谓未离欲所有圣者得离欲时。得亦然者。谓有得一得二得六。唯除得五。言得一者。谓得未得。及从无学起色缠退。言得二者。谓从无学起无色界诸缠退时。言得六者。谓退不还。因辩随眠分别断竟

说一切有部俱舍论卷第二十一阿毗达磨俱舍论卷第二十二

        尊者世亲造

        三藏法师玄奘奉　诏译

    分别贤圣品第六之一

如是已说烦恼等断于九胜位得遍知名。然断必由道力故得。此所由道其相云何。颂曰

  已说烦恼断　　由见谛修故
  见道唯无漏　　修道通二种

论曰。前已广说诸烦恼断由见谛道及修道故。道唯无漏亦有漏耶。见道应知唯是无漏。修道通二。所以者何。见道速能治三界故。顿断九品见所断故。非世间道有此堪能。故见位中道唯无漏。修道有异故通二种。如向所言。由见谛故。此所见谛其相云何。颂曰

  谛四先已说　　谓苦集灭道
  彼自体亦然　　次第随现观

论曰。谛有四种。名先已说。于何处说。谓初品中分别有漏无漏法处。彼如何说。谓彼颂言。无漏谓圣道。此说道谛。择灭谓离系。此说灭谛。及苦集世间。此说苦集谛。四谛次第如彼说耶。不尔。云何。如今所列。一苦二集三灭四道。四谛自体亦有异耶。不尔。云何。如先所辩。为显体同彼故说亦然声。四谛何缘如是次第。随现观位先后而说。谓现观中先所观者便在先说。若异此者应先说因后方说果。然或有法说次随生。如念住等。或复有法说次随便。如正胜等。谓此中无决定理趣起。如是欲先断已生后遮未生。但随言便。今说四谛随瑜伽师现观位中先后次第。何缘现观次第必然。加行位中如是观故。何缘加行必如是观。谓若有法是爱着处能作逼恼。为求脱因。此法理应最初观察。故修行者加行位中最初观苦。苦即苦谛。次复观苦以谁为因。便观苦因。因即集谛。次复观苦以谁为灭。便观苦灭。灭即灭谛。后观苦灭以谁为道。便观灭道。道即道谛。如见病已次寻病因。续思病愈后求良药。契经亦说谛次第喻。何契经说。谓良医经。如彼经言。夫医王者。谓具四德能拔毒箭。一善知病状。二善知病因。三善知病愈。四善知良药。如来亦尔为大医王如实了知苦集灭道。故加行位如是次观。现观位中次第亦尔。由加行力所引发故。如已观地纵马奔驰。此现观名为目何义。应知此目现等觉义。何缘说此唯是无漏。对向涅槃正觉境故。此觉真净故得正名。应知此中果性取蕴名为苦谛。因性取蕴名为集谛。是能集故。由此苦集因果性分。名虽有殊非物有异。灭道二谛物亦有殊。何义经中说为圣谛。是圣者谛故得圣名。于非圣者此岂成妄。于一切是谛性无颠倒故。然唯圣者实见非余。是故经中但名圣谛。非非圣谛颠倒见故。如有颂言。圣者说是乐。非圣说为苦。圣者说为苦。非圣说是乐

有余师说。二唯圣谛。余二通是圣非圣谛。唯受一分是苦自体。所余并非。如何可言诸有漏行皆是苦谛。颂曰

  苦由三苦合　　如所应一切
  可意非可意　　余有漏行法

论曰。有三苦性。一苦苦性。二行苦性。三坏苦性。诸有漏行如其所应与此三种苦性合故。皆是苦谛。亦无有失。此中可意有漏行法与坏苦合故名为苦。诸非可意有漏行法与苦苦合故名为苦。除此所余有漏行法与行苦合故名为苦。何谓为可意非可意余。谓乐等三受如其次第由三受力令顺乐受等诸有漏行得可意等名。所以者何。若诸乐受由坏成苦性。如契经言。诸乐受生时乐住时乐坏时苦。若诸苦受由体成苦性。如契经言。诸苦受生时苦住时苦。不苦不乐受由行成苦性。众缘造故。如契经言。若非常即是苦。如受顺受诸行亦然。有余师释。苦即苦性名苦苦性。如是乃至行即苦性名行苦性。应知此中说可意非可意为坏苦苦苦者。由不共故。理实一切行苦故苦。此唯圣者所能观见。故有颂言

  如以一睫毛　　置掌人不觉
  若置眼睛上　　为损及不安
  愚夫如手掌　　不觉行苦睫
  智者如眼睛　　缘极生厌怖

以诸愚夫于无间狱受剧苦蕴生苦怖心。不如众圣于有顶蕴。道谛亦应是行苦摄。有为性故。道谛非苦。违逆圣心是行苦相。非圣道起违逆圣心。由此能引众苦尽故。若观诸有为涅槃寂静者。亦由先见彼法是苦后观彼灭以为寂静故。有为言唯显有漏。若诸法中亦许有乐。何缘但说苦为圣谛。有一类释。由乐少故。如置绿豆乌豆聚中。以少从多名乌豆聚。谁有智者沥水浇痈有少乐生计痈为乐。有余于此以颂释言

  能为苦因故　　能集众苦故
  有苦希彼故　　说乐亦名苦

理实应言。圣者观察诸有及乐体皆是苦。以就行苦同一味故。由此立苦为谛非乐。如何亦观乐受为苦。由性非常违圣心故。如以苦相观色等时非彼苦相一如苦受。有谓。乐受是苦因故。诸圣亦观彼为苦者。此释非理。能为苦因是集行相。岂关于苦。又诸圣者生色无色。缘彼如何有苦想转。非彼诸蕴为苦受因。又经复说行苦何用。若由非常观乐为苦。非常苦观行相何别。生灭法故观为非常。违圣心故观之为苦。但见非常知违圣心故非常行相能引苦行相。有余部师作如是执。定无实乐受唯是苦。云何知然。由教理故。云何由教。如世尊言。诸所有受无非是苦。又契经言。汝应以苦观于乐受。又契经言。于苦谓乐名为颠倒。云何由理。以诸乐因皆不定故。谓诸所有衣服饮食冷暖等事。诸有情类许为乐因。此若非时过量受用便能生苦。复成苦因不应乐因。于增盛位或虽平等但由非时便成苦因能生于苦。故知衣等本是苦因。苦增盛时其相方显。威仪易脱理亦应然。又治苦时方起乐觉。及苦易脱乐觉乃生。谓若未遭饥渴寒热疲欲等苦所逼迫时。不于乐因生于乐觉。故于对治重苦因中。愚夫妄计此能生乐。实无决定能生乐因。苦易脱中愚夫谓乐。如荷重担暂易肩等。故受唯苦。定无实乐。对法诸师言乐实有。此言应理。云何知然。且应反征拨无乐者何名为苦。若谓逼迫既有适悦有乐应成。若谓损害既有饶益有乐应成。若谓非爱既有可爱有乐应成。若谓可爱体非成实。以诸圣者于离染时可爱复成非可爱故。不尔。可爱圣离染时。由异门观为非爱故。谓若有受自相可爱。此受未常成非可爱。然诸圣者于离染时。以余行相厌患此受。谓观此受是放逸处。要由广大功力所成变坏无常故非可爱。非彼自相是非爱法。若彼自体是非可爱不应于中有起爱者。若不起爱于离染时圣者不应以余行相观察乐受深生厌患。故由自相有实乐受。然世尊言诸所有受无非苦者。佛自释通。如契经言。佛告庆喜。我依诸行皆是无常。及诸有为皆是变坏。密作是说。诸所有受无非是苦。故知此经不依苦苦作如是说。若由自相说受皆苦。何缘庆喜作是问言。佛于余经说有三受。谓乐及苦不苦不乐。依何密意此经复言诸所有受无非是苦。庆喜但应作如是问。依何密意说有三受。世尊亦应但作是答。我依此密意故说有三受。经中既无如是问答。故由自相实有三受。世尊既言我密意说诸所有受无非是苦。即已显示此所说经依别意说非真了义。又契经言。汝应以苦观乐受者。应知此经意显乐受有二种性。一有乐性。谓此乐受依自相门是可爱故。二有苦性。谓依异门亦是无常变坏法故。然观乐时能为系缚。诸有贪者啖此味故。若观苦时能令解脱。如是观者得离贪故。佛以观苦能令解脱故。劝有情观乐为苦。如何知此自相是乐。如有颂言

  诸佛正遍觉　　知诸行非常
  及有为变坏　　故说受皆苦

又契经言于苦谓乐名颠倒者。此别意说。以诸世间于诸乐受妙欲诸有一分乐中一向计乐故成颠倒。谓诸乐受若依异门亦有苦性。然诸世间唯观为乐故成颠倒。诸妙欲境乐少苦多。唯观为乐故成颠倒。诸有亦然。故不由此能证乐受无实理成。若受自相实皆苦者。佛说三受有何胜利。若谓世尊随俗说者。不应正理。以世尊言我密说受无非苦故。又于观五受说如实言故。谓契经说。所有乐根所有喜根应知此二皆是乐受。乃至广说。复作是说。若以正慧如实观见如是五根三结永断。乃至广说。又佛如何于一苦受。随顺世俗分别说三。若谓世间于下上中苦。如其次第起乐等三觉。佛随顺彼说乐等三。理亦不然。乐亦三故。应于下等三苦唯起上等乐觉。又受殊胜香味触等所生乐时。有何下苦而世于中起乐受觉。若许尔时有下苦者。如是下苦已灭未生。世应尔时有极乐觉。此位众苦都无有故。受欲乐时征问亦尔。又下品受现在前时。许受分明猛利可取。许中品受现在前时与此相违。如何应理。又下三定说有乐故。应有下苦。以上诸地说有舍故。应有中苦。定胜苦增。岂应正理。故不应依下等三苦如次建立乐等三受。又契经说。佛告大名。若色一向是苦非乐非乐所随。乃至广说。故知定有少分实乐。如是且辩彼所引教显无实乐为证不成。所立理言亦不成证。且以诸乐因皆不定故者。此非正理。迷因义故。谓观所依分位差别诸外境界方为乐因或为苦因。非唯外境。若此外境至此所依如是分位能为乐因。未尝至此不为乐因。是故乐因非不决定。如世间火观所煮炙分位差别为美熟因或为违因非唯彼火。若此火至此所煮炙如是分位。为美熟因。未尝至此非美熟因故美熟因非不决定。乐因亦尔。决定理成。又三静虑中乐因岂不定。彼因无时能生苦故。又彼所说要治苦时起乐觉者。准前已破。谓受殊胜香味触等所生乐时。对治何苦而世于中起于乐觉。设许尔时治粗苦者。此能治苦已灭未生。尔时转应生极乐觉。又静虑乐治何故生。如是等破准前应说。又彼所说苦易脱中乐觉乃生如易肩者。此身分位实能生乐。乃至身如是分位未灭前必有乐生。灭则不尔。若异此者此位后时乐应转增。苦渐微故。如是易脱身四威仪生乐解劳应知亦尔。若先无苦于最后时何为欻然生于苦觉。由身变易分位别故。如酒等后时有甘醋味起。是故乐受实有理成。由此定知。诸有漏行三苦合故如应名苦。即苦行体亦名集谛。此说必定违越契经。契经唯说爱为集故。经就胜故说爱为集。理实所余亦是集谛。如是理趣由何证知。余契经中亦说余故。如薄伽梵伽他中言

  业爱及无明　　为因招后行
  令诸有相续　　名补特伽罗

又契经说五种种子。此即别名说有取识。又彼经说置地界中。此即别名说四识住。故经所说是密意言。阿毗达磨依法相说。然经中说爱为集者。偏说起因。伽他中说业爱无明皆为因者。具说生起及彼因因。云何知尔。业为生因爱为起因。经所说故。又彼经中次第显示后行业有因有缘有绪故。为别建立种子及田说有取识及四识住。故非唯爱为集谛体。何法名生。何法名起。界趣生等品类差别自体出现。说名为生。若无差别后有相续。说名为起。业与有爱如其次第为彼二因。譬如种子与谷麦等别种类芽为能生因。水与一切无差别芽为能起因。业及有爱为生起因。应知亦尔。爱为起因何理为证。离爱后有必不起故。谓有爱离爱二俱命终。唯见有爱者后有更起。由此理证爱为起因。起有起无定随爱故。又由爱故相续趣后。现见若于是处有爱。则心相续数趣于彼。由此比知。以有爱故能令相续驰趣后有。又取后身。更无有法封执坚着如贪爱者。如荜豆屑于澡浴时和水涂身至干燥位着身难离余无以加。如是无有余为因法执取后身如我爱者。由此理证爱为起因。如是世尊说谛有四。余经复说。谛有二种。一世俗谛。二胜义谛。如是二谛。其相云何。颂曰

  彼觉破便无　　慧析余亦尔
  如瓶水世俗　　异此名胜义

论曰。若彼物觉彼破便无。彼物应知名世俗谛。如瓶被破为碎凡时瓶觉则无。衣等亦尔。又若有物以慧析除彼觉便无亦是世俗。如水被慧析色等时水觉则无。火等亦尔。即于彼物未破析时以世想名施设为彼。施设有故名为世俗。依世俗理说有瓶等。是实非虚名世俗谛。若物异此名胜义谛。谓彼物觉彼破不无及慧析余彼觉仍有。应知彼物名胜义谛。如色等物碎至极微。或以胜慧析除味等。彼觉恒有。受等亦然。此真实有故名胜义。依胜义理说有色等。是实非虚名胜义谛。先轨范师作如是说。如出世智及此后得世间正智所取诸法名胜义谛。如此余智所聚诸法名世俗谛。已辩诸谛。应说云何方便勤修趣见谛道。颂曰

  将趣见谛道　　应住戒勤修
  闻思修所成　　谓名俱义境

论曰。诸有发心将趣见谛。应先安住清净尸罗然后勤修闻所成等。谓先摄受顺见谛闻。闻已勤求所闻法义。闻法义已无倒思惟。思已方能依定修习。行者如是住戒勤修。依闻所成慧起思所成慧。依思所成慧起修所成慧。此三慧相差别云何。毗婆沙师谓。三慧相缘名俱义。如次有别。闻所成慧唯缘名境。未能舍文而观义故。思所成慧缘名义境。有时由文引义。有时由义引文。未全舍文而观义故。修所成慧唯缘义境。已能舍文唯观义故。譬若有人浮深驶水。曾未学者不舍所依。曾学未成或舍或执。曾善学者不待所依。自力浮渡。三慧亦尔。有言。若尔思慧不成。谓此既通缘名缘义。如次应是闻修所成。今详三相无过别者。谓修行者依闻至教所生胜慧名闻所成。依思正理所生胜慧名思所成。依修等持所生胜慧名修所成。说所成言显三胜慧是闻思等三因所成。犹如世间于命牛等如次说是食草所成。诸有欲于修精勤学者。如何净身器令修速成。颂曰

  具身心远离　　无不足大欲
  谓已得未得　　多求名所无
  治相违界三　　无漏无贪性
  四圣种亦尔　　前三唯喜足
  三生具后业　　为治四爱生
  我所我事欲　　暂息永除故

论曰。身器清净略由三因。何等谓三因。一身心远离。二喜足少欲。三住四圣种。身远离者。离相杂住。心远离者。离不善寻。此二易可成。由喜足少欲。言喜足者无不喜足。少欲者无大欲。所无二种差别云何。对法诸师咸作是说。于已得妙衣服等更多求名不喜足。于未得妙衣等多希求名大欲。岂不更求亦缘未得。此二差别便应不成。是故此中应作是说。于所已得不妙不多怅望不欢名不喜足。于所未得衣服等事求妙求多名为大欲。喜足少欲能治此故与此相违应知差别。喜足少欲通三界无漏。所治二种唯欲界所系。喜足少欲体是无贪。所治二种欲贪为性。能生众圣故名圣种。四圣种体亦是无贪。四中前三体唯喜足。谓于衣服饮食卧具。随所得中皆生喜足。第四圣种谓乐断修。如何亦用无贪为体。以能弃舍有欲贪故。为显何义立四圣种。以诸弟子舍俗生具及俗事业。为求解脱归佛出家。法主世尊愍彼安立助道二事。一者生具。二者事业。前三即是助道生具。最后即是助道事业。汝等若能依前生具作后事业解脱非久。何故安立如是二事。为欲对治四种爱生故。契经言。苾刍谛听。爱因衣服应生时生。应住时住。应执时执。如是爱因饮食卧具及有无有。皆如是说。为治此四说四圣种。即依此义更异门说。谓佛为欲暂息永除我所我事欲故说四圣种。我所事者谓衣服等。我事者谓自身。缘彼贪名为欲。为暂止息前三贪故说前三圣种。为永灭除四种贪故说第四圣种。如是已说修所依器。由何门故能正入修。颂曰

  入修要二门　　不净观息念
  贪寻增上者　　如次第应修

论曰。正入修门要者有二。一不净观。二持息念。谁于何门能正入修。如次应知。贪寻增者。谓贪猛盛数现在前。如是有情名贪行者。彼观不净能正入修。寻多乱心名寻行者。彼依息念能正入修。有余师言。此持息念非多缘故能止乱寻。不净多缘显形差别引多寻故治彼无能。有余复言。此时息念内门转故能止乱寻。不净多于外门转故。犹如眼识治彼无能。此中先应辩不净观。如是观相云何。颂曰

  为通治四贪　　且辩观骨锁
  广至海复略　　名初习业位
  除足至头半　　名为已熟修
  系心在眉间　　名超作意位

论曰。修不净观正为治贪。然贪差别略有四种。一显色贪。二形色贪。三妙触贪。四供奉贪。缘青瘀等修不净观治第一贪。缘彼食等修不净观治第二贪。缘虫蛆等修不净观治第三贪。缘尸不动修不净观治第四贪。若缘骨锁修不净观。通能对治如是四贪。以骨锁中无四贪境故。应且辩修骨锁观。此唯胜解作意摄故。少分缘故。不断烦恼。唯能制伏令不现行。然瑜伽师修骨锁观总有三位。一初习业。二已熟修。三超作意。谓观行者。欲修如是不净观时。应先系心于自身分。或于足指或额或余。随所乐处心得住已。依胜解力于自身分假想思惟。皮肉烂堕渐令骨净。乃至具观全身骨锁。见一具已复观第二。如是渐次广至一房一寺一园一村一国。乃至遍地以海为边。于其中间骨锁充满。为令胜解得增长故。于所广事渐略而观。乃至唯观一具骨锁。齐此渐略不净观成名瑜伽师初习业位。为令略观胜解力增于一具中先除足骨思惟余骨系心而住。渐次乃至除头半骨思惟半骨系心而住。齐此转略不净观成名瑜伽师已熟修位。为令略观胜解自在除半头骨系心眉间。专注一缘湛然而住。齐此极略不净观成名瑜伽师超作意位。有不净观由所缘小非自在小应作四句。此由作意已熟未熟未熟已熟。及由所缘自身至海有差别故。此不净观何性。几地缘何境。何处生。何行相。缘何世。为有漏。为无漏。为离染得。为加行得。颂曰

  无贪性十地　　缘欲色人生
  不净自世缘　　有漏通二得

论曰。如先所问今次第答。谓此观以无贪为性通依十地。谓四静虑及四近分中间欲界。唯缘欲界所见色境。所见者何。谓显形色。缘义为境。由此已成。唯人趣生。三洲除北。尚非余趣。况余界生。既立不净名。唯不净行相。随在何世缘自世境。若不生法通缘三世。既唯胜解作意相应。此观理应唯是有漏。通离染得及加行得。由有曾得未曾得故。说不净观相差别已。次应辩持息念。此差别相云何。颂曰

  息念慧五地　　缘风依欲身
  二得实外无　　有六谓数等

论曰。言息念者。即契经中所说阿那阿波那念。言阿那者。谓持息入。是引外风令入身义。阿波那者。谓持息出。是引内风令出身义。慧由念力观此为境故名阿那阿波那念。以慧为性。而说念者。念力持故于境分明所作事成。如念住故。通于五地。谓初二三静虑近分中间欲界。此念唯与舍相应故。谓苦乐受能顺引寻。此念治寻故不俱起。喜乐二受能违专注。此念于境专注故成。由此相违故不俱起。有说。根本下三静虑中亦有舍受。彼说依八地。上定现前息无有故。此定缘风。依欲身起。唯人天趣除北俱卢。通离染得及加行得。唯与真实作意相应。正法有情方能修习。外道无有。无说者故。自不能觉微细法故。此相圆满由具六因。一数二随三止四观五转六净。数谓系心缘入出息不作加行。放舍身心唯念忆持入出息数。从一至十不减不增。恐心于现。极聚散故。然于此中容有三失。一数减失。于二谓一。二数增失。于一谓二。三杂乱失。于入谓出于出谓入。若离如是三种过失名为正数。若十中间心散乱者。复应从一次第数之。终而复始乃至得定。随谓系心缘入出息不作加行随息而行。念息入出时各远至何所。谓念息入。为行遍身。为行一分。随彼息入行至喉心脐髋髀胫。乃至足指念恒随逐。若念息出离身为至一磔一寻。随所至方念恒随逐。有余师说。息出极远乃至风轮或吠岚婆。此不应理。此念真实作意俱故。止谓系念唯在鼻端。或在眉间乃至足指。随所乐处安止其心。观息住身如珠中缕。为冷为暖为损为益。观谓观察此息风已。兼观息俱大种造色及依色住心及心所。具观五蕴以为境界。转谓移转缘息风觉安置后后胜善根中乃至世间第一法位。净谓升进入见道等。有余师说。念住为初金刚喻定为后名转。尽智等方名净。为摄六相故。说颂言

  持息念应知　　有六种异相
  谓数随止观　　转净相差别

息相差别云何应知。颂曰

  入出息随身　　依二差别转
  情数非执受　　等流非下缘

论曰。随身生地息彼地摄。以息是身一分摄故。此入出息转依身心差别。以生无色界及羯剌蓝等并入无心定及第四定等。此息于彼皆不转故。谓要身中有诸孔隙。入出息地心正现前息于尔时方得转故。出第四定等及初生时息最先入。入第四定等及后死时息最后出。息有情数摄。有情身分故。非有执受。与根相离故。是等流性。同类因生故。非所长养。身增长时彼损减故。非异熟生。断已后时更相续故。余异熟色无如是故。唯自上地心之所缘。非下地威仪通果心境故

说一切有部俱舍论卷第二十二阿毗达磨俱舍论卷第二十三

        尊者世亲造

        三藏法师玄奘奉　诏译

    分别贤圣品第六之二

如是已说入修二门。由此二门心便得定。心得定已复何所修。颂曰

  依已修成止　　为观修念住
  以自相共相　　观身受心法
  自性闻等慧　　余相杂所缘
  说次第随生　　治倒故唯四

论曰。依已修成满胜奢摩他。为毗钵舍那修四念住。如何修习四念住耶。谓以自共相观身受心法。身受心法各别自性名为自相。一切有为皆非常性。一切有漏皆是苦性。及一切法空非我性名为共相。身自性者。大种造色。受心自性如自名显。法自性者。除三余法。传说。在定以极微刹那。各别观身名身念住满。余三满相如应当知。何等名为四念住体。此四念住体各有三。自性相杂所缘别故。自性念住以慧为体。此慧有三种。谓闻等所成。即此亦名三种念住。相杂念住以慧所余俱有为体。所缘念住以慧所缘诸法为体。宁知自性是慧非余。经说。于身住循身观名身念住。余三亦然。诸循观名唯目慧体。非慧无有循观用故。何缘于慧立念住名。毗婆沙师说。此品念增故。是念力持慧得转义。如斧破木由楔力持。理实应言慧令念住。是故于慧立念住名。随慧所观能明记故。由此无灭作如是言。若有能于身住循身观。缘身念得住乃至广说。世尊亦说。若有于身住循身观者念便住不谬。然有经言。此四念住由何故集。由何故灭。食触名色作意集故。如次令身受心法集。食触名色作意灭故。如次令身受心法灭。应知彼说所缘念住以念于彼得安住故。又念住别名随所缘缘自他俱相续异故。一一念住各有三种。此四念住说次随生。生复何缘次第如是。随境粗者应先观故。或诸欲贪于身处转。故四念住观身在初。然贪于身由欣乐受。欣乐于受由心不调。心之不调由惑未断。故观受等如是次第。此四念住如次治彼净乐常我四种颠倒。故唯有四不增不减。四中三种唯不杂缘。第四所缘通杂不杂。若唯观法名不杂缘。若于身等二三或四。总而观察名为杂缘。如是熟修杂缘身等法念住已。复何所修。颂曰

  彼居法念住　　总观四所缘
  修非常及苦　　空非我行相

论曰。彼观行者。居缘总杂法念住中。总观所缘身等四境修四行相。所谓非常苦空非我。修此观已生何善根。颂曰

  从此生暖法　　具观四圣谛
  修十六行相　　次生顶亦然
  如是二善根　　皆初法后四
  次忍唯法念　　下中品同顶
  上唯观欲苦　　一行一刹那
  世第一亦然　　皆慧五除得

论曰。修习总缘共相法念住。渐次成熟乃至上上品。从此念住后。有顺决择分初善根生。名为暖法。此法如暖立暖法名。是能烧惑薪圣道火前相。如火前相故名为暖。此暖善根分位长故。能具观察四圣谛境。及能具修十六行相。观苦圣谛修四行相。一非常二苦三空四非我。观集圣谛修四行相。一因二集三生四缘。观灭圣谛修四行相。一灭二静三妙四离。观道圣谛修四行相。一道二如三行四出。此相差别如后当辩。此暖善根下中上品渐次增长至成满时有善根生。名为顶法。此转胜故更立异名。动善根中此法最胜如人顶故名为顶法。或由此是进退两际如山顶故。说名为顶。此亦如暖具观四谛。及能具修十六行相。如是暖顶二种善根。初安足时唯法念住。以何义故名初安足。谓随何善根以十六行相最初游践四圣谛迹。后增进时具四念住。诸先所得后不现前。于彼不生钦重心故。此顶善根下中上品渐次增长至成满时有善根生名为忍法。于四谛理能忍可中此最胜故。又此位忍无退堕故名为忍法。此忍善根安足增进皆法念住。与前有别。然此忍法有下中上。下中二品与顶法同。谓具观察四圣谛境及能具修十六行相。上品有异。唯观欲苦与世第一相邻接故。由此义准。暖等善根皆能具缘三界苦等义已成立。无简别故。谓瑜伽师于色无色对治道等一一圣谛行相所缘渐减渐略。乃至但有二念作意思惟欲界苦圣谛境。齐此以前名中忍位。从此位无间起胜善根一行一刹那名上品忍。此善根起不相续故。上品忍无间生世第一法。如上品忍缘欲苦谛修一行相唯一刹那。此有漏故名为世间。是最胜故名为第一。此有漏法世间中胜。是故名为世第一法。有士用力离同类因引圣道生。故名最胜。如是暖等四种善根。念住性故。皆慧为体。若并助伴皆五蕴性。然除彼得勿诸圣者暖等善根重现前故。此中暖法初安足时。缘三谛法念住现在。修未来四。随一行相现在。修未来四。缘灭谛法念住现在。修未来一。随一行相现在。修未来四。由此种性先未曾得。要同分者方能修故。后增进时缘三谛。随一念住现在。修未来四。随一行相现在。修未来十六。缘灭谛法念住现在。修未来四。随一行相现在。修未来十六。由此种性先已曾得。不同分者亦能修故。顶初安足缘四谛法念住现在。修未来四。随一行相现在。修未来十六。后增进时缘三谛随一念住现在。修未来四。随一行相现在。修未来十六。缘灭谛法念住现在。修未来四。随一行相现在。修未来十六。忍初安足及后增进。缘四谛法念住现在。修未来四。随一行相现在。修未来十六。然于增进略所缘时。随略彼所缘不修彼行相。世第一法缘欲苦谛法念住现在。修未来四。随一行相现在。修未来四。无异分故。似见道故。已辩所生善根相体。今次应辩此差别义。颂曰

  此顺决择分　　四皆修所成
  六地二或七　　依欲界身九
  三女男得二　　第四女亦尔
  圣由失地舍　　异生由命终
  初二亦退舍　　依本必见谛
  舍已得非先　　二舍性非得

论曰。此暖顶忍世第一法。四殊胜善根名顺决择分。依何义建立顺决择分名。决谓决断。择谓简择。决断简择谓诸圣道。以诸圣道能断疑故。及能分别四谛相故。分谓分段。此言意显所顺唯是见道一分。决择之分故得决择分名。此四为缘引决择分。顺益彼故得顺彼名故。此名为顺决择分。如是四种皆修所成。非闻思所成。唯等引地故。四中前二是下品摄。以俱可动犹可退故。忍中品摄。胜前二故。有世第一为其上故。世第一法独是上品。此四善根皆依六地。谓四静虑未至中间。欲界中无。阙等引故。余上地亦无。见道眷属故。又无色界心不缘欲界故。欲界先应遍知断故。此四善根能感色界五蕴异熟为圆满因。不能牵引。憎背有故。或声为显二有异说。谓暖顶二。尊者妙音说。依前六及欲七地。此四善根依欲身起。人天九处除北俱卢。前三善根三洲初起。后生天处亦续现前。第四善根天处亦起。此无初后一刹那故。此四善根唯依男女。前三男女俱通得二。第四女身亦得二种。依男唯得男身善根。已得女身非择灭故。圣依此地得此善根。失此地时善根方舍。失地言显迁生上地。异生于地若失不失。但失众同分。必舍此善根。初二善根亦由退舍。由死退舍唯异生非圣。由失地舍唯圣非异生。忍及世第一异生亦无退。依根本地起暖等善根。彼于此生必定得见谛。厌生死心极猛利故。若先舍已后重得时。所得必非先之所舍。如舍已重得别解脱律仪。以未曾熟修大功用成故。若先已得暖等善根经生故舍。遇了分位善说法师便生顶等。若不遇者还从本修。失退二舍非得为性。退必起过。失不必然。得此善根有何胜利。颂曰

  暖必至涅槃　　顶终不断善
  忍不堕恶趣　　第一入离生

论曰。四善根中若得暖法。虽有退断善根造无间业堕恶趣等。而无久流转必至涅槃故。若尔何殊顺解脱分。若无障碍去见谛近。此与见道行相同故。若得顶法虽有退等而增毕竟不断善根。若得忍时虽命终舍住异生位而增无退不造无间。不堕恶趣。然颂但说不堕恶趣言。义准已知不造无间业。造无间业者必堕恶趣故。忍位无退如前已辩。此位不堕诸恶趣者。已远趣彼业烦恼故。若至忍位于少趣生处身有惑中得不生法故。趣谓诸恶趣。生谓卵湿生。处谓无想北俱卢大梵处。身谓扇搋半择迦二形身。有谓第八等有。惑谓见所断惑。此于下上位随所应而得。谓于下忍得恶趣不生。所余不生至上忍方得。得世第一法。虽住异生位而能趣入正性离生。颂虽不言离命终舍。既无间入正性离生。义准已成。无命终舍。何缘唯此能入离生。已得异生非择灭故。能如无间道舍异生性故。此四善根各有三品。由声闻等种性别故。随何种性善根已生。彼可移转向余乘不。颂曰

  转声闻种性　　二成佛三余
  麟角佛无转　　一坐成觉故

论曰。声闻种性暖顶已生。容可转成无上正觉。彼若得忍无成佛理。谓于恶趣已超越故。菩提萨埵利物为怀。为化有情必往恶趣。彼忍种性不可回转。是故定无得成佛义。声闻种性暖顶忍三。皆有可转成独觉义。在佛乘外故说为余。麟角佛言显麟角喻及无上觉暖等善根。并无移转向余乘义。皆以第四静虑为依。一坐便成自乘觉故。第四静虑是不倾动。最极明利三摩地故。堪为麟角喻无上觉所依。此中觉言显尽无生智。后当辩。此是菩提性故。言一坐者。从暖善根乃至菩提不起于座。有余师说。从不净观不起于座乃至菩提。有余独觉异麟角喻。起彼种性初二善根。转向余乘。理无遮碍。颇有此生创修此行即此生引起顺决择分耶。不尔。云何。颂曰

  前顺解脱分　　速三生解脱
  闻思成三业　　殖在人三洲

论曰。顺决择分今生起者。必前生起顺解脱分。诸有创殖顺解脱分。极速三生方得解脱。谓初生起顺解脱分。第二生起顺决择分。第三生入圣。乃至得解脱。譬如下种苗成结实三位不同。身入法性成熟解脱三位亦尔。传说。如是顺解脱分。唯闻思所成。通三业为体。虽就最胜唯是意业。而此思愿摄起身语亦得名为顺解脱分。有施一食持一戒等深乐解脱。愿力所持便名种殖顺解脱分。殖顺解脱分唯人三洲。余厌离般若如应无故。遇佛出世殖此善根。有余师言。亦遇独觉。已因便说顺解脱分。入观次第是正所论。于中已明诸加行道世第一法为其后边。应说从斯复生何道。颂曰

  世第一无间　　即缘欲界苦
  生无漏法忍　　忍次生法智
  次缘余界苦　　生类忍类智
  缘集灭道谛　　各生四亦然
  如是十六心　　名圣谛现观
  此总有三种　　谓见缘事别

论曰。从世第一善根无间。即缘欲界苦圣谛境有无漏摄法智忍生。此忍名为苦法智忍。为显此忍是无漏故。举后等流以为标别。此能生法智。是法智因得法智忍名。如花果树。即此名入正性离生。亦复名入正性决定。由此是初入正性离生亦是初入正性决定故。经说。正性所谓涅槃。或正性言因诸圣道。生谓烦恼。或根未熟。圣道能越故名离生。能决趣涅槃。或决了谛相故。诸圣道得决定名。至此位中说名为入。此忍生已得圣者名。此在未来舍异生性。谓许此忍未来生时有此用非余。如灯及生相。有余师说。世第一法舍异生性。此义不然。彼此同名世间法故。性相违故。亦无有失。如上怨肩能害怨命。有余师说。此二共舍。如无间道解脱道故。此忍无间即缘欲苦有法智生。名苦法智。应知此智亦无漏摄。前无漏言遍流后故。如缘欲界苦圣谛境有苦法忍苦法智生。如是复于法智无间总缘余界苦圣谛境。有类智忍生。名苦类智忍。此忍无间即缘此境有类智生。名苦类智。最初证知诸法真理故名法智。此后境智与前相似故得类名。以后随前而证境故。如缘苦谛欲界及余生法类忍法类智四。缘余三谛各四亦然。谓复于前苦类智后。次缘欲界集圣谛境有法智忍生。名集法智忍。此忍无间即缘欲集有法智生。名集法智。次缘余界集圣谛境有类智忍生。名集类智忍。此忍无间即缘此境有类智生。名集类智。次缘欲界灭圣谛境有法智忍生。名灭法智忍。此忍无间即缘欲灭有法智生。名灭法智。次缘余界灭圣谛境有类智忍生。名灭类智忍。此忍无间即缘此境有类智生。名灭类智。次缘欲界道圣谛境有法智忍生。名道法智忍。此忍无间即缘欲道有法智生。名道法智。次缘余界道圣谛境有类智忍生。名道类智忍。此忍无间即缘此境有类智生。名道类智。如是次第有十六心。总说名为圣谛现观。此中余部有作是言。于诸谛中唯顿现观。然彼意趣应更推寻。彼现观言无差别故。详诸现观总有三种。谓见缘事有差别故。唯无漏慧于诸谛境现见分明名见现观。此无漏慧并余相应同一所缘名缘现观。此诸能缘并余俱有戒生相等不相应法同一事业名事现观。见苦谛时于苦圣谛具三现观。于余三谛唯事现观。谓断证修。若诸谛中约见现观说顿现观理必不然。以诸谛中行相别故。若言以一无我行相总见诸谛则不应用苦等行相见苦谛等。如是便与契经相违。如契经言。诸圣弟子以苦行相思惟于苦。以集行相思惟于集。以灭行相思惟于灭。以道行相思惟于道。无漏作意相应择法。若言此经说修道位此亦不然。如见修故。若彼复谓见一谛时于余谛中得自在故说顿现观理亦无失。然于如是现观中间有起不起。别应思择。若彼复谓于见苦时。即能断集证灭修道说顿现观理亦无失。由先已说见苦谛时于余三谛中有事现观故。依见现观。于契经中见有诚文。说渐现观。如契经说。佛告长者。于四圣谛非顿现观必渐现观。乃至广说。如是等有三经。一一经有别喻。若谓有经作如是说。但于苦谛无惑无疑。于佛亦无故顿现观。此亦非证。依定不行。或必当断。密意说故。已辩现观具十六心。此十六心为依何地。颂曰

  皆与世第一　　同依于一地

论曰。随世第一所依诸地应知即此十六心依。彼依六地。如先已说。何缘必有如是忍智前后次第间杂而起。颂曰

  忍智如次第　　无间解脱道

论曰。十六心中忍是无间道。约断惑得无能隔碍故。智是解脱道。已解脱惑得与离系得俱时起故。具二次第理定应然。犹如世间驱贼闭户。若谓第二唯无间道与离系得俱时而生。则此位中于彼彼境应定不起已断疑智。若谓见位唯忍断惑则与本论说九结聚相违。此难不然。诸忍皆是智眷属故。如王眷属所作事业名王所作。此十六心皆见谛理。一切可说见道摄耶。不尔。云何。颂曰

  前十五见道　　见未曾见故

论曰。苦法智忍为初。道类智忍为后。其中总有十五刹那。皆见道所摄。见未见谛故。至第十六道类智时。无一谛理未见今见。如习曾见。故修道摄。岂不尔时观道类忍见道谛理未见今见。此中约谛不约刹那。非一刹那未见今见可名今见未见谛理。如刈畦稻唯余一科不可名为此畦未刈。又道类智是果摄故。顿修八智十六行故。舍前道故。相续起故。如余修道。非见道摄。然道类智必不退者。任持见道所断断故。即由此故应见道摄。此难不然。太过失故。何缘七智亦见道摄。见诸谛理未究竟故。谓未周遍见诸谛理中间起故。亦见道摄。已说见修二道生异。当依此道分位差别建立众圣补特伽罗。且依见道十五心位建立众圣有差别者。颂曰

  名随信法行　　由根钝利别
  具修惑断一　　至五向初果
  断次三向二　　离八地向三

论曰。见道位中圣者有二。一随信行。二随法行。由根钝利别立二名。诸钝根名随信行者。诸利根名随法行者。由信随行名随信行。彼有随信行名随信行者。或由串习此随信行以成其性故名随信行者。彼先信他随行义故。准此应释随法行者。彼于先时由自披阅契经等法随行义故。即二圣者。由于修惑具断有殊立为三向。谓彼二圣若于先时未以世道断修断惑名为具缚。或先已断欲界一品乃至五品至此位中名初果向。趣初果故。言初果者。谓预流果。此于一切沙门果中必初得故。若先已断欲界六品或七八品至此位中名第二果向。趣第二果故。第二果者。谓一来果。遍得果中此第二故。若先已离欲界九品。或先已断初定一品。乃至具离无所有处至此位中名第三果向。趣第三果故。第三果者。谓不还果。数准前释。次依修道道类智时建立众圣有差别者。颂曰

  至第十六心　　随三向住果
  名信解见至　　亦由钝利别

论曰。即前随信随法行者至第十六道类智心名为住果。不复名向。随前三向今住三果。谓前预流向今住预流果。前一来向今住一来果。前不还向今住不还果。阿罗汉果必无初得。见道无容断修惑故。世道无容离有顶故。至住果位舍得二名。谓不复名随信法行。转得信解见至二名。此亦由根钝利差别。诸钝根者先名随信行今名信解。诸利根者先名随法行今名见至。此二圣者信慧互增故。标信解见至名别。何缘先断欲界修惑一至五等至第十六道类智心。但说名为预流果等。非后果向。颂曰

  诸得果位中　　未得胜果道
  故未起胜道　　名住果非向

论曰。诸得果时于胜果道必定未得故。住果者乃至未起胜果道时。但名住果。不名后向。然诸先断欲界修惑一至五等至得果时此生必定起胜果道。由此先离三静虑染后依下地入见道者。彼得果已于现生中必能引生后胜果道。若异此者圣生上地应不可说定成乐根。如是已依先具倍离及全离欲入见谛者十六心位立众圣别。当约修惑辩渐次生能对治道分位差别。颂曰

  地地失德九　　下中上各三

论曰。失谓过失。即所治障。德谓功德。即能治道。如先已辩欲修断惑九品差别。如是上地乃至有顶例亦应尔。如所断障一一地中各有九品。诸能治道无间解脱九品亦然。失德如何各分九品。谓根本品有下中上。此三各分下中上别。由此失德各分九品。谓下下下中下上。中下中中中上。上下上中上上品。应知此中下下品道势力能断上上品障。如是乃至上上品道势力能断下下品障。上上品等诸能治德初未有故。此德有时上上品等失已无故。如浣衣位粗垢先除于后后时渐除细垢。又如粗闇小明能灭。要以大明方灭细闇。失德相对理亦应然。白法力强黑法力劣故刹那顷劣道现行。无始时来展转增益上品诸惑能令顿断。如经久时所集众病服少良药能令顿愈。又如长时所集大闇。一刹那顷小灯能灭。已辩失德差别九品。次当依彼立圣者别。且诸有学修道位中总亦名为信解见至。随位复有多种差别。先应建立都未断者。颂曰

  未断修断失　　住果极七返

论曰。诸住果者于一切地修所断失都未断时名为预流。生极七返。七返言显。七往返生。是人天中各七生义。极言为显受生最多。非诸预流皆受七返故。契经说极七返生。是彼最多七返生义。诸无漏道总名为流。由此为因趣涅槃故。预言为显最初至得。彼预流故说名预流。此预流名为目何义。若初得道名为预流则预流名应目第八。若初得果名为预流则倍离欲全离欲者至道类智应名预流。此预流名目初得果。然依遍得一切果者初所得果建立此名。一来不还非定初得。此定初得故名预流。何缘此名不目第八。以要至得道类智时具得向果无漏道故。具得见修无漏道故。于现观流遍至得故名预流者。第八不然。故预流名不目第八。彼从此后别于人中极多结七中有生有。天中亦然。总二十八。皆七等故说极七生。如七处善及七叶树。毗婆沙师所说如是。若尔何故契经中言无处无容见圆满者更可有受第八有义。此契经意约一趣说。若如言执中有应无。若尔上流极有顶者。亦应一趣无第八生。依欲界说故无此过。此何为证为教为理。以何证彼于人天中各受七生非合受七。以契经说天七及人。饮光部经分明别说于人天处各受七生。由是此中不应固执。若于人趣得预流果。彼还人趣得般涅槃。于天趣得还于天趣。何缘彼无受第八有。相续齐此必成熟故。圣道种类法应如是。如七步蛇第四日疟。又彼有余七结在故。谓二下分五上分结。中间虽有圣道现前余业力持不证圆寂。至第七有逢无佛法时。彼在居家得阿罗汉果。既得果已必不住家。法尔自得苾刍形相。有言。彼往余道出家。云何彼名无退堕法。以不生长退堕业故。违彼生长业与果故。强盛善根镇彼身故。加行意乐俱清净故。诸有决定堕恶趣业尚不起忍。况得预流。故有颂言

  愚作罪小亦堕恶　　智为罪大亦脱苦
  如团铁小亦沉水　　为钵铁大亦能浮

经说预流作苦边际。依何义立苦边际名。依齐此生后更无苦。是令后苦不相续义。或苦边际所谓涅槃。如何涅槃可是所作。除彼得障故说作言。如言作空。谓毁台观。余位亦有极七返生。然非决定。是故不说

说一切有部俱舍论卷第二十三阿毗达磨俱舍论卷第二十四

        尊者世亲造

        三藏法师玄奘奉　诏译

    分别贤圣品第六之三

已辩住果未断修惑名为预流生极七返。今次应辩断位众圣。且应建立一来向果。颂曰

  断欲三四品　　三二生家家
  断至五二向　　断六一来果

论曰。即预流者进断修惑。若三缘具转名家家。一由断惑。断欲修断三四品故。二由成根。得能治彼无漏根故。三由受生。更受欲有三二生故。颂中但说初后缘者。预流果后说进断惑。成能治彼诸无漏根。义准已成。故不具说。然复应说三二生者。以有增进于所受生。或少或无或过此故。何缘此无断五品者。以断第五必断第六。非一品惑能障得果。犹如一间未越界故。应知总有二种家家。一天家家。谓欲天趣生三二家而证圆寂。或一天处或二或三。二人家家。谓于人趣生三二家而证圆寂。或一洲处或二或三。即预流者。进断欲界一品修惑乃至五品。应知转名一来果向。若断第六成一来果。彼往天上一来人间而般涅槃名一来果。过此以后更无生故。此或名曰薄贪嗔痴。唯余下品贪嗔痴故。已辩一来向果差别。次应建立不还向果。颂曰

  断七或八品　　一生名一间
  此即第三向　　断九不还果

论曰。即一来者进断余惑。若三缘具转名一间。一由断惑。断欲修断七八品故。二由成根。得能治彼无漏根故。三由受生。更受欲有余一生故。颂中但说初后二缘不说成根。义如前释。如何一品惑障得不还果。由彼若断便越界故。前说三时业极为障。应知烦恼亦与业同。越彼等流异熟地故。间谓间隔。彼余一生为间隔故。不证圆寂。或余一品欲修所断惑为间隔故。不得不还果。有一间者说名一间。即断修惑七八品者。应知亦名不还果向。先断三四七八品惑入见谛者。后得果时乃至未修后胜果道。仍不名曰家家一间。未成治彼无漏根故。若断第九成不还果。必不还来生欲界故。此惑名曰五下结断。虽必先断或二或三。然于此时总集断故。依不还位。诸契经中以种种门建立差别。今次应辩彼差别相。颂曰

  此中生有行　　无行般涅槃
  上流若杂修　　能往色究竟
  超半超遍殁　　余能往有顶
  行无色有四　　住此般涅槃

论曰。此不还者总说有七。且行色界差别有五。一中般涅槃。二生般涅槃。三有行般涅槃。四无行般涅槃。五者上流。此于中间般涅槃故。说此名曰中般涅槃。如是应知。此于生已此由有行此由无行。般涅槃故名生般等。此上流故名为上流。言中般者。谓往色界住中有位便般涅槃。言生般者。谓往色界生已不久便般涅槃。以具勤修速进道故。此中所说般涅槃者。谓有余依。有余师说。亦无余依。此不应理。彼于舍寿无自在故。有行般者。谓往色界生已长时加行不息。由有功用方般涅槃。此唯有勤修无速进道故。无行般者。谓往色界生已经久加行懈息不多功用便般涅槃。以阙勤修速进道故。有说。此二有差别者由缘有为无为圣道。如其次第得涅槃故。此说非理。太过失故。然契经中先说无行。后说有行般涅槃者。如是次第与理相应。有速进道。无速进道。无行有行而成办故。不由功用得。由功用得故。生般涅槃得最速进最上品道。随眠最劣故生不久便般涅槃。言上流者是上行义。以流与行其义一故。谓欲界殁往色界生。未即于中能证圆寂。要转生上方般涅槃。即此上流差别有二。由因及果有差别故。因差别者。此于静虑由有杂修无杂修故。果差别者。色究竟天及有顶天为极处故。谓若于静虑有杂修者。能往色究竟方般涅槃。即此复有三种差别。全超半超遍殁异故。言全超者。谓在欲界于四静虑已具杂修。遇缘退失上三静虑。以初静虑爱味为缘。命终上生梵众天处。由于先世串习势力。复能杂修第四静虑。从彼处殁生色究竟。最初处殁生最后天。顿越中间是全超义。言半超者。从彼渐次生下净居乃至中间能越一处生色究竟。超非全故名为半超。圣必不生大梵天处。僻见处故。一导师故。言遍殁者。从彼渐次于一切处皆遍受生。最后方能生色究竟。一切处死故名遍殁。无不还者于已生处受第二生。由彼于生容求胜进。非等劣故。即由此故不还义满。必不还生曾生处故。尚不生本处。况有生于下。应知此谓二上流中由有杂修静虑因故往色究竟般涅槃者。余于静虑无杂修者。能往有顶方般涅槃。谓彼先无杂修静虑。由于诸定爱味为缘。此殁遍生色界诸处。唯不能往五净居天。色界命终于三无色次第生已。后生有顶方般涅槃。二上流中前是观行后是止行。乐慧乐定有差别故。二上流者于下地中得般涅槃见不违理。而言此往色究竟天及有顶天为极处者。由此过彼无行处故。如预流者极七返生。此五名为行色界者。行无色者差别有四。谓在欲界离色界贪从此命终生于无色。此中差别唯有四种。由生般涅槃有差别故。此并前五成六不还。复有不行色无色界即住于此能般涅槃名现般涅槃。并前六为七。于行色界五不还中复有异门。显其差别。颂曰

  行色界有九　　谓三各分三
  业惑根有殊　　故成三九别

论曰。即行色界五种不还总立为三。各分三种故成九种。何等为三。中生上流有差别故。云何三种各分为三。且中般涅槃分为三种。速非速经久得般涅槃。由三火星喻所显故。生般涅槃亦分三种。生有行等般涅槃故。此皆生已得般涅槃。是故并应名为生般。于上流中亦分三种。超半超等有差别故。然诸三种一切皆由速非速经久得般涅槃故。更互相望无杂乱失。如是三种九种不还。由业惑根有差别故。有速非速经久不同。且总成三。由造增长顺起生后业差别故。如其次第下中上品烦恼现行有差别故。及上中下根差别故。此三一一如其所应亦业惑根有差别故。各有三别故成九种。谓初二三由惑根别各成三种。非由业异。后三亦由顺后受业有差别故。分成三种。故说如是行色不还业惑根殊成三九别。若尔何故诸契经中。佛唯说有七善士趣。颂曰

  立七善士趣　　由上流无别
  善恶行不行　　有往无还故

论曰。中生各三。上流为一。经依此立七善士趣。有上流法故名上流。由此义同且立为一。何独依此立善士趣。不依所余有学圣者。趣是行义。所余有学皆行善业无差别故。唯此七种皆行善业不行恶业。余则不然。又唯七种行往上界不复还来。余则不尔。故独依此立善士趣。若尔何故契经中言。云何善士谓若成就有学正见。乃至广说。诸余有学若就异门亦可说为有善士性。以诸有学于五种恶皆获得毕竟不作律仪故。不善烦恼多已断故。立善士趣不就异门约唯行善不行恶故。唯托胜因往上界故。诸在圣位曾经生者。亦有此等差别相耶。不尔。云何。颂曰

  经欲界生圣　　不往余界生
  此及往上生　　无练根并退

论曰。若在圣位经欲界生必不往生色无色界。由彼证得不还果已。定于现身般涅槃故。若于色界经生圣者。容有上生无色界义。如行色界极有顶者。然天帝释作如是言。曾闻有天名色究竟。我后退落当生于彼。毗婆沙师作如是释。彼由不了对法相故。为令喜故。佛亦不遮。即此已经欲界生者及已从此往上界生诸圣必无练根并退。何缘不许经欲界生及上生圣者有练根并退。以必无故。何缘必无。经生习根极成熟故。及得殊胜所依止故。何缘有学未离欲贪无中有中般涅槃者。以彼圣道未淳熟故。未易能令现在前故。所有随眠非极劣故。毗婆沙者作如是释。诸欲界法极难越故。彼尚有余多所作故。谓应进断不善无记二烦恼故。及应进得若二若三沙门果故。并应总越三界法故。住中有位无如是能。前说上流杂修静虑为因能往色究竟天。先应杂修何等静虑。由何等位知杂修成。复为何缘杂修静虑。颂曰

  先杂修第四　　成由一念杂
  为受生现乐　　及遮烦恼退

论曰。诸欲杂修四静虑者。必先杂修第四静虑。以彼等持最堪能故。诸乐行中彼最胜故。如是杂修诸静虑者。是阿罗汉或是不还。彼必先入第四静虑多念无漏相续现前。从此引生多念有漏后复多念无漏现前。如是旋还后后渐减。乃至最后二念无漏次引二念有漏现前无间复生二念无漏。名杂修定加行成满。次后唯从一念无漏引起一念有漏现前无间复生一念无漏。如是有漏中间刹那前后刹那无漏杂故。名杂修定根本圆成。前二刹那似无间道。第三刹那似解脱道。如是杂修第四定已。乘此势力随其所应亦能杂修下三静虑。先于欲界人趣三洲如是杂修诸静虑已。后若退失生色界中。亦能如前杂修静虑。杂修静虑为三种缘。一为受生。二为现乐。三为遮止起烦恼退。谓不还中诸利根者。为现法乐及生净居。诸钝根者。亦为遮退。彼畏退故。如是杂修令味相应等持远故。诸阿罗汉若利根者。为现法乐。若钝根者。亦为遮防起烦恼退。杂修静虑为生净居。何缘净居处唯有五。颂曰

  由杂修五品　　生有五净居

论曰。由杂熏修第四静虑有五品故。净居唯五。何谓五品。谓下中上上胜上极品差别故。此中初品三心现前便得成满。谓初无漏次起有漏后起无漏。第二品六。第三品九。第四品十二。第五品十五。如是五品杂修静虑如其次第感五净居。应知此中无漏势力熏修有漏令感净居。有余师言。由信等五次第增上感五净居。经说不还有名身证。依何胜德立身证名。颂曰

  得灭定不还　　转名为身证

论曰。有灭定得名得灭定。即不还者若于身中有灭定得转名身证。谓不还者由身证得似涅槃法故名身证。如何说彼但名身证。以心无故。依身生故。理实应言。彼从灭定起得先未得有识身寂静。便作是思。此灭尽定最为寂静极似涅槃。如是证得身之寂静故名身证。由得及智现前证得身寂静故。契经说有十八有学。何缘于中不说身证。依因无故。何谓依因。谓诸无漏三学及果依彼差别立有学故。灭定非学亦非学果。故不约成彼说有学差别。不还差别粗相如是。若细分析数成多千。其义云何。且如中般约根建立便成三种。下中上根有差别故。约地建立则成四种。往初定等有差别故。约种性建立则成六种。退法种性等有差别故。约处建立成十六种。梵众天等处差别故。约地离染成三十六。色界具缚乃至已离第四静虑八品染故。约处种性离染根建立总成二千五百九十二。云何如是。且于一处种性有六。一一种性约离染门差别成九。谓随何地具缚为初乃至已离八品为后。如是六九成五十四。以十六处乘五十四成八百六十四。以根乘之复成三倍故总成二千五百九十二。诸离下地九品染者。即说名为上地具缚。为成一一地离染数等故。如是乃至上流亦尔。总计五种积数合成一万二千九百六十。已辩第三向果差别。次应建立第四向果。颂曰

  上界修惑中　　断初定一品
  至有顶八品　　皆阿罗汉向
  第九无间道　　名金刚喻定
  尽得俱尽智　　成无学应果

论曰。即不还者进断色界及无色界修所断惑。从断初定一品为初。至断有顶八品为后。应知转名阿罗汉向。即此所说阿罗汉向中断有顶惑第九无间道亦说名为金刚喻定。一切随眠皆能破故。先已破故。不破一切实有能破一切功能。诸能断惑无间道中。此定相应最为胜故。金刚喻定说有多种。谓断有顶第九品惑无间道生。通依九地故说此定智行缘别。未至地摄有五十二。谓苦集类智缘有顶苦集各有四行相应有八。灭道法智各有四行相应有八。灭类智缘八地灭一一各有四行相应合三十二。道类智缘八地道总有四行相应有四。以治八地类智品道同类相因必总缘故。如未至摄有五十二中四静虑应知亦尔。空处二十八。识处二十四。无所有处二十。以依无色无有法智及缘下灭灭类智故。然缘下地对治道者。以同品道互为因故。有说。此定智行缘别。未至地摄有八十种。谓道类智缘八地道亦各别有四行相。应由此于前增二十八。如未至摄有八十种中四静虑应知亦尔。空处四十。识处三十二。无所有处二十四。复有欲令金刚喻定智行缘别。未至地摄总有一百六十四种。谓灭类智缘八地灭有别有总各四行相。应由此于初增百一十二。如未至摄百六十四中四静虑应知亦然。空处五十二。识处三十六。无所有处二十四。若就种性根等分别。更成多种。如理应思。此定既能断有顶地第九品惑。能引此惑尽得俱行尽智令起。金刚喻定是断惑中最后无间道所生。尽智是断惑中最后解脱道。由此解脱道与诸漏尽得最初俱生故名尽智。如是尽智至已生时便成无学阿罗汉果。已得无学应果法故。为得别果所应修学此无有故得无学名。即此唯应作他事故。诸有染者所应供故。依此义立阿罗汉名。义准已成前来所辩四向三果皆名有学。何缘前七得有学名。为得漏尽常乐学故。学要有三。一增上戒。二增上心。三增上慧。以戒定慧为三自体。若尔异生应名有学。不尔。未如实见知谛理故。彼容后时失正学故。由此善逝再说学言。如契经中。佛告憺怕。学所应学学所应学。我唯说此名有学者。为令了知学正所学无有退失名有学者故。薄伽梵重说学言。圣者住本性。如何名有学。学意未满故。如行者暂息。或学法得常随逐故。学法云何。谓有学者无漏有为法。无学法云何。谓无学者无漏有为法。云何涅槃不名为学。无学异生亦成就故此复何缘不名无学。有学异生亦成就故。如是有学及无学者。总成八圣补特伽罗。行向住果各有四故。谓为证得预流果向乃至所证阿罗汉果名虽有八事唯有五。谓住四果及初果向。以后三果向不离前果故。此依渐次得果者说。若倍离欲全离欲者住见道中名为一来不还果向。非前果摄。如前所说。修道二种。有漏无漏有差别故。由何等道离何地染。颂曰

  有顶由无漏　　余由二离染

论曰。唯无漏道离有顶染。非有漏道。所以者何。此上更无世俗道故。自地不能治自地故。自地烦恼所随增故。若彼烦恼于此随增。此必不能治彼烦恼。若此力能对治于彼。则彼于此必不随增故。自地道不治自地。离余八地通由二道。世出世道俱能离故。既通由二离八地染。各有几种离系得耶。颂曰

  圣二离八修　　各二离系得

论曰。诸有学圣用有漏道离下八地修断染时。能具引生二离系得。用无漏道离彼亦然。由二种道同所作故。有余师释。以无漏道离彼染时。何缘证知亦生有漏离系得者。有舍无漏得烦恼不成故。谓有学圣以无漏道离彼染时。若不引生同治有漏离系得者。则以圣道具离八地。后依静虑得转根时。顿舍先来诸钝圣道唯得静虑利果圣道。上惑离系应皆不成。是则还应成彼烦恼。此证非理。所以者何。彼圣设无有漏断得亦不成就上地烦恼。如分离有顶得转根时及异生上生不成惑故。谓如分离有顶地染后依静虑得转根时。无漏断得既已顿舍。彼地离系无有漏得。而彼地惑亦不成就。又如异生生二定等。虽舍欲界等烦恼断得而不成就欲界等烦恼。此亦应然。故不成证。既说圣者二离八修各能引生二离系得。义准。异生用有漏道唯能引起有漏断得。并诸圣者用无漏道离见断惑及有顶修唯能引生无漏断得。由何地道离何地染。颂曰

  无漏未至道　　能离一切地
  余八离自上　　有漏离次下

论曰。诸无漏道若未至摄。能离欲界乃至有顶。静虑中间及四静虑三无色摄。随其所应各能离自及上地染。不离下离已故。诸有漏道一切唯能离次下地。非自地等。自地烦恼所随增故。势劣故。已离故。诸依近分离下地染。如无间道皆近分摄诸解脱道亦近分耶。不尔。云何。颂曰

  近分离下染　　初三后解脱
  根本或近分　　上地唯根本

论曰。诸道所依近分有八。谓四静虑无色下边。所离有九。谓欲八定。初三近分离下三染。第九解脱现在前时。或入根本或即近分。上五近分各离下染。第九解脱现在前时。必入根本非即近分。近分根本等舍根故。下三静虑近分根本受根异故。有不能入。转入异受少艰难故。离下染时必欣上故。若受无异必入根本。诸出世道无间解脱前既已说。缘四谛境十六行相义准自成。世道缘何作何行相。颂曰

  世无间解脱　　如次缘下上
  作粗苦障行　　及静妙离三

论曰。世俗无间及解脱道。如次能缘下地上地为粗苦障及静妙离。谓诸无间道缘自次下地诸有漏法作粗苦等三行相中随一行相。若诸解脱道缘彼次上地诸有漏法作静妙等三行相中随一行相。非寂静故说名为粗。由大劬劳方能越故。非美妙故。说名为苦。由多粗重能违害故。非出离故。说名为障。由此能碍越自地故。如狱厚壁能障出离。静妙离三翻此应释。傍论已了。应辩本义。尽智无间有何智生。颂曰

  不动尽智后　　必起无生智
  余尽或正见　　此应果皆有

论曰。不动种性诸阿罗汉。尽智无间起无生智。非更有尽智无学正见生。除不动法余阿罗汉。尽智无间有尽智生。或即引生无学正见。非无生智。后容退故。前不动种性无正见生耶。有正见生而不说者。一切应果皆有此故。谓不动法无生智后有无生智起。或无学正见。前说四果是谁果耶。此四应知是沙门果。何谓沙门性。此果体是何。果位差别总有几种。颂曰

  净道沙门性　　有为无为果
  此有八十九　　解脱道及灭

论曰。诸无漏道是沙门性。怀此道者名曰沙门。以能勤劳息烦恼故。如契经说。以能勤劳息除种种恶不善法。广说乃至。故名沙门。异生不能无异究竟趣涅槃故非真沙门。有为无为是沙门果。契经说此差别有四。理实就位有八十九。皆解脱道择灭为性。谓为永断见所断惑有八无间八解脱道。及为永断修所断惑有八十一无间八十一解脱道。诸无间道唯沙门性。诸解脱道亦是沙门有为果体。是彼等流士用果故。一一择灭唯是沙门无为果体。是彼离系士用果故。如是合成八十九种。若尔世尊何不具说。果虽有多而不说者。颂曰

  五因立四果　　舍曾得胜道
  集断得八智　　顿修十六行

论曰。若断道位具足五因。佛于经中建立为果。言五因者。一舍曾道。谓舍先得果向道故。二得胜道。谓得果摄殊胜道故。三总集断。谓总一得得诸断故。四得八智。谓得四法四类智故。五能顿修十六行相。谓能顿修无常等故。于四果位皆具五因。余位不然。故佛不说。若唯净道是沙门性。有漏道力所得二果。如何亦是沙门果摄。颂曰

  世道所得断　　圣所得杂故
  无漏得持故　　亦名沙门果

论曰。以世俗道得二果时。此果非唯以世俗道所得择灭为断果性。兼以见道所得择灭于中相杂总成一果。同一果道得所得故。由此契经言。云何一来果。谓断三结薄贪嗔痴。云何不还果。谓断五下结。又世俗道所得择灭。无漏断得所任持故。由此力所持退不命终故。亦得名为沙门果体。此沙门性有异名耶。亦有。云何。颂曰

  所说沙门性　　亦名婆罗门
  亦名为梵轮　　真梵所转故
  于中唯见道　　说名为法轮
  由速等似轮　　或具辐等故

论曰。即前所说真沙门性。经亦说名婆罗门性。以能遣除诸烦恼故。即此亦说名为梵轮。是真梵王力所转故。佛与无上梵德相应。是故世尊独应名梵。由契经说佛亦名梵亦名寂静亦名清凉。即于此中唯依见道。世尊有处说名法轮。如世间轮有速等相。见道似彼故名法轮。见道如何与彼相似。由速行等似彼轮故。谓见谛道速疾行故。有舍取故。降未伏故。镇已伏故。上下转故。具此五相似世间轮。尊者妙音作如是说。如世间轮有辐等相。八支圣道似彼名轮。谓正见正思惟正勤正念似世轮辐。正语正业正命似毂。正定似辋。故名法轮。宁知法轮唯是见道。憍陈那等见道生时。说名已转正法轮故。云何三转十二行相。此苦圣谛。此应遍知。此已遍知。是名三转。即于如是一一转时。别别发生眼智明觉。说此名曰十二行相。如是三转十二行相谛谛皆有。然数等故。但说三转十二行相。如说二法七处善等。由此三转如次显示见道修道无学道三。毗婆沙师所说如是。若尔三转十二行相非唯见道。如何可说唯于见道立法轮名。是故唯应即此三转十二行相所有法门名为法轮可应正理。如何三转。三周转故。如何具足十二行相。三周循历四圣谛故。谓此是苦此是集此是灭此是道。此应遍知。此应永断。此应作证。此应修习。此已遍知。此已永断。此已作证。此已修习。云何名转。由此法门往他相续令解义故。或诸圣道皆是法轮。于所化生身中转故。于他相续见道生时。已至转初故名已转。何沙门果依何界得。颂曰

  三依欲后三　　由上无见道
  无闻无缘下　　无厌及经故

论曰。前三但依欲界身得。得阿罗汉依三界身。前之二果未离欲故非依上得理且可然。第三云何非依上得。由理教故。且理云何。依上界身无见道故。非离见道已离欲者可有超证不还果义。何缘上界必无见道。且无色中无正闻故。又彼界中不缘下故。色界异生着胜定乐。又无苦受不生厌故。非无有厌能得见道。教复云何。由经说故。经言。有五补特伽罗。此处通达彼处究竟。所谓中般乃至上流。此通达言唯目见道。是证圆寂初加行故。由此见道上界定无

说一切有部俱舍论卷第二十四阿毗达磨俱舍论卷第二十五

        尊者世亲造

        三藏法师玄奘奉　诏译

    分别贤圣品第六之四

如前所说。不动应果。初尽智后起无生智。诸阿罗汉如预流等有差别不。亦有。云何。颂曰

  阿罗汉有六　　谓退至不动
  前五信解生　　总名时解脱
  后不时解脱　　从前见至生

论曰。于契经中说阿罗汉由种性异故有六种。一者退法二者思法。三者护法。四安住法。五堪达法。六不动法。于此六中前之五种从先学位信解性生。即此总名时爱心解脱。恒时爱护及心解脱故。亦说名为时解脱者以要待时及解脱故。略初言故。如言酥瓶。由此待时方能入定。谓待资具无病处等胜缘合时方入定故。不动法性说名为后。即此名为不动心解脱。以无退动及心解脱故。亦说名为不时解脱。以不待时及解脱故。谓三摩地随欲现前不待胜缘和合时故。或依暂时毕竟解脱。建立时解脱不时解脱名。容有退堕时无退堕时故。此从学位见至性生。如是所明六阿罗汉所有种性。为是先有。为后方得。不定。云何。颂曰

  有是先种性　　有后练根得

论曰。退法种性必是先有。思法等五亦有后得。谓有先来是思法性。有先退法性后练根成思。乃至不动随应当说。言退法者。谓遇少缘便退所得。非思法等。言思法者。谓惧退失恒思自害。言护法者。谓于所得喜自防护。安住法者。离胜退缘虽不自防亦能不退。离胜加行亦不增进。堪达法者。彼性堪能好修练根速达不动。不动法者。彼必无退。此六种性先学位中。初二阙恒时及尊重加行。由根有异故有差别。第三唯有恒时加行。第四唯有尊重加行。第五具二而是钝根。第六利根具二加行。退法种性非必定退。乃至堪达非必能达。但约容有建立此名。故六阿罗汉通三界皆有。若执退者必定应退。乃至堪达必能达者。彼执欲界具足有六。色无色界中唯安住不动。彼无退失自害自防及修练根故唯有二。如是六种阿罗汉中。谁从何退。为性为果。颂曰

  四从种性退　　五从果非先

论曰。不动种性必无退理。前之五种皆有退义。于中后四有从性退。退法一种无退性理。由此种性最居下故。五种皆有从果退义。虽俱有退然并非先。谓诸无学先学位中所住种性。彼从此性必无退理。学无学道所成坚故。若诸有学先凡位中所住种性。彼从此性亦无退理。世出世道所成坚故。若住此位后修练根所得思等四种种性。彼从此性容有退理。二先位中住思等性必亦无退此所得果。唯先退法有退果义。又亦无退先所得果。后所得果容有退义。是故定无退预流果。由此应果退法有三。一增进根。二退住学。三住自位而般涅槃。思法有四。三如前说。更加一种退住退性。余三如次有五六七。应知后后一一增故。思法等四退住学位时。还住退非余。若异此者得胜种性故。应是进非退。何缘定无退先果者。以见所断依无事故。谓有身见依我处转。见所断惑此见为根。我体既无名依无事。以无事故必无退理。若尔应说此惑缘无。非此缘无谛为境故。然于谛境不如实缘。诸烦恼中谁不如是。虽皆如是而有差别。以修断惑各有别事。即是可意不可意等于所缘境此相非无。见所断惑计有我等。非诸谛境有我等相。以无事故。与修断别。谓于色等所缘境中我见妄增。作者受者自在而转。非实我性。边执见等随此而生。故并说为依无事惑。若修所断贪嗔慢痴。色等境中唯起染着增背高举不了行转故。并说为依有事惑。又见断惑于谛理中执我我所断常见等。非谛中有少我等事。见断贪等缘此而生。是故皆名依无事惑。修所断惑于色等中谓好丑等。然色等境非无少分好丑等别。是故可名依有事惑。又见断惑迷谛理起名依无事。修所断惑迷粗事生名依有事。谛理真实。揩定可依。圣慧已证必无退理。事相浮伪无定可依。断迷彼惑。有失念退。或修断惑非审虑生。昧钝性故。见所断惑由审虑生。推度性故。圣不审虑于粗事中失念或生。审虑不尔。如于绳等率尔谓蛇。故修断惑圣有退起。非由率尔可起见惑。圣若审虑便见谛理。故圣见断定无退义。经部师说。从阿罗汉亦无退义。彼说应理。云何知然。由教理故。知何由教。经言。苾刍圣慧断惑名为实断。又契经言。我说有学应不放逸。非阿罗汉。虽有经言佛告庆喜。我说。利养等亦障阿罗汉而不说退阿罗汉果。但说退失现法乐住。经言不动心解脱身作证。我定说无因缘从此退故。若谓有退。由经说有时爱解脱。我亦许然。但应观察彼之所退。为应果性。为静虑等。然彼根本静虑等持。要待时现前故名时解脱。彼为获得现法乐住数希现前故名为爱。有说。此定是所爱味。诸阿罗汉果性解脱恒随逐故不应名时。更不欣求故不名爱若应果性容有退者。如何世尊但说所证现法乐住有可退理。由此证知。诸阿罗汉果性解脱必是不动。然由利等扰乱过失有于所得现法乐住退去自在。谓诸钝根。若诸利根则无退失。故于所得现法乐住有退无退故名退不退法。如是思等如理应思。不退安住不动何别。非练根得名为不退。练根所得名为不动。此二所起殊胜等至。设遇退缘亦无退理。安住法者。但于已住诸胜德中能无退失。不能更引余胜德生。设复引生从彼可退。是不退等三种差别。然乔底迦昔在学位。于时解脱极啖味故。又钝根故数数退失。深自厌责执刀自害。由于身命无所恋惜。临命终时得阿罗汉便般涅槃。故乔底迦亦非退失阿罗汉果。又增十经作如是说。一法应起。谓时爱心解脱。一法应证。谓不动心解脱。若应果性名为时爱心解脱者。何故于此增十经中再说应果。又曾无处说阿罗汉果名为应起。但说名应证。又说钝根所摄应果名为应起。为显何义。若为显彼能起现前则余利根最应能起。若为显彼应起现前亦余利根最所应起。故时解脱非应果性。若尔何故说时解脱应果。谓有应果根性钝故要待时故定方现前。若与彼相违名不时解脱。阿毗达磨亦作是言。欲贪随眠由三处起。一欲贪随眠未断遍知故。二顺彼经法正现在前故。三于彼正起非理作意故。若谓彼据具因生说。复有何法因不具生。是名由教。如何由理。若阿罗汉有令烦恼毕竟不起治道已生。是则不应退起烦恼。若阿罗汉此道未生。未能永拔烦恼种故应非漏尽。若非漏尽宁说为应。是名由理。若尔应释炭喻契经。如说。多闻诸圣弟子若行若住有处有时失念故生恶不善觉。此经唯说阿罗汉果。由此经言彼圣弟子心于长夜随顺远离广说乃至临入涅槃。余契经中。有即说此顺远离等名应果力。又此经说。彼于一切顺漏已能永吐已得清凉。由此定知。是阿罗汉。实后所说是阿罗汉。然彼乃至于行住时未善通达容有此事。谓有学者于行住时由失念故容起烦恼。后成无学则无起义。前依学位故说无失。毗婆沙师定作是说。阿罗汉果亦有退义。唯阿罗汉种性有六。为余亦有六种性耶。设有皆能修练根不。颂曰

  学异生亦六　　练根非见道

论曰。有学异生种性亦六。六种应果彼为先故。然见道位必无练根。此位无容起加行故。唯于信解异生位中。能修练根如无学位。如契经说。我说由斯所证四种增上心所现法乐住随一有退。所得不动心解脱身作证。我决定说无因缘从此退。如何不动法退现法乐住。颂曰

  应知退有三　　已未得受用
  佛唯有最后　　利中后钝三

论曰。应知诸退总有三种。一已得退。谓退已得殊胜功德。二未得退。谓未能得殊胜功德。三受用退。谓诸已得殊胜功德不现在前。于此三中世尊唯有一受用退。以具众德无容一时顿现前故。余不动法具有受用及未得退。亦于胜己殊胜功德犹未得故。余五种性容具有三。亦容退失已得德故。约受用退说不动法退现法乐无相违过。无退论者作如是说。诸无漏解脱皆名不动。然别立第六不动法者。如前释通。不应为难。诸阿罗汉既许退果。为更生不。诸住果时所不作事退时作不。不尔。何缘。颂曰

  一切从果退　　必得不命终
  住果所不为　　惭增故不作

论曰。无从果退中间命终。退已须臾必还得故。如契经说。苾刍当知。如是多闻诸圣弟子退失正念。速复还能令所退起尽没灭离。若谓不然。修梵行果应非安隐可委信处。又住果位所不应为违果事业由惭增故于暂退时亦必不造。譬如壮士虽蹶不仆。如上所言。有练根得无学有学。正练根时各几无间几解脱道。何性摄。何所依。颂曰

  练根无学位　　九无间解脱
  久习故学一　　无漏依人三
  无学依九地　　有学但依六
  舍果胜果道　　唯得果道故

论曰。求胜种性修练根者。无学位中转一一性各九无间九解脱道。如得应果。所以者何。彼钝根性由久串习非少功力可能令转。学无学道所成坚故。有学位中转一一性各一无间一解脱道。如得初果。上相违故。彼加行道诸位各一。如是无间及解脱道一切唯是无漏性摄。圣者必无用有漏道而转根理。非增上故。依谓身地。此所依身唯人三洲。余无退故。此所依地无学通九。谓未至中间四定三无色。有学唯六。谓除后三。所以者何。夫转根者。容有舍果及胜果道。所得唯果非向道故。无有学果无色地摄。故学练根但依六地。诸无学位补特伽罗。总有几种。由何差别。颂曰

  七声闻二佛　　差别由九根

论曰。居无学位圣者有九。谓七声闻及二觉者。退法等五不动分二。后先别故名七声闻。独觉大觉名二觉者。由下下等九品根异令无学圣成九差别。学无学位有七圣者。一切圣者皆此中摄。一随信行。二随法行。三信解。四见至。五身证。六慧解脱。七俱解脱。依何立七。事别有几。颂曰

  加行根灭定　　解脱故成七
  此事别唯六　　三道各二故

论曰。依加行异立初二种。谓依先时随他及法于所求义修加行故。立随信行随法行名。依根不同立次二种。谓依钝利信慧根增如次名为信解见至。依得灭定立身证名。由身证得灭尽定故。依解脱异立后二种。谓依唯慧离烦恼障者立慧解脱。依兼得定离解脱障者立俱解脱。此名虽七事别唯六。谓见道中有二圣者。一随信行。二随法行。此至修道别立二名。一信解。二见至。此至无学复立二名。谓时解脱不时解脱。应知此中一随信行根故成三。谓下中上。性故成五。谓退法等。道故成十五。谓八忍七智。离染故成七十三。谓具缚离八地染。依身故成九。谓三洲欲天。若根性道离染依身相乘合成一亿四万七千八百二十五种。随法行等如理应思。何等名俱及慧解脱。颂曰

  俱由得灭定　　余名慧解脱

论曰。诸阿罗汉得灭定者名俱解脱。由慧定力解脱烦恼解脱障故。所余未得灭尽定者名慧解脱。但由慧力于烦恼障得解脱故。如世尊说。五烦恼断不可牵引未名满学。学无学位各由几因于等位中独称为满。颂曰

  有学名为满　　由根果定三
  无学得满名　　但由根定二

论曰。学于学位独得满名。具由三因。谓根果定。有有学者但由根故亦得满名。谓诸见至未离欲染。有有学者但由果故亦得满名。谓信解不还未得灭尽定。有有学者由根果故亦得满名。谓见至不还未得灭尽定。有有学者由果定故亦得满名。谓诸信解得灭尽定。有有学者具由三故独得满名。谓诸见至得灭尽定。无有学者但由定故及根定故亦得满名。诸无学者于无学位由根定二独得满名。无学位中无非果满故无由果亦立满名。有但由根亦名为满。谓不时解脱未得灭尽定。有但由定亦名为满。谓时解脱得灭尽定。有具由二独名为满。谓不时解脱已得灭尽定。广说诸道差别无量。谓世出世见修道等。略说几道能遍摄耶。颂曰

  应知一切道　　略说唯有四
  谓加行无间　　解脱胜进道

论曰。加行道者。谓从此后无间道生。无间道者。谓此能断所应断障。解脱道者。谓已解脱所应断障最初所生。胜进道者。谓三余道。道义云何。谓涅槃路。乘此能往涅槃城故。或复道者。谓求所依。依此寻求涅槃果故。解脱胜进如何名道。与道类同。转上品故。或前前力至后后故。或能趣入无余依故。道于余处立通行名。以能通达趣涅槃故。此有几种。依何建立。颂曰

  通行有四种　　乐依本静虑
  苦依所余地　　迟速钝利根

论曰。经说通行总有四种。一苦迟通行。二苦速通行。三乐迟通行。四乐速通行。道依根本四静虑生名乐通行。以摄受支止观平等任运转故。道依无色未至中间名苦通行。以不摄支止观不等艰辛转故。谓无色定观减止增。未至中间观增止减。即此乐苦二通行中。钝根名迟。利根名速。二行于境通达稽迟故名迟通。翻此名速。或迟钝者所起通行名迟通行。速此相违。道亦名为菩提分法。此有几种。名义云何。颂曰

  觉分三十七　　谓四念住等
  觉谓尽无生　　顺此故名分

论曰。经说觉分有三十七。谓四念住．四正断．四神足．五根．五力．七等觉支．八圣道支。尽无生智说名为觉。随觉者别立三菩提。一声闻菩提。二独觉菩提。三无上菩提。无明睡眠皆永断故。及如实知已作已事不复作故。此二名觉。三十七法顺趣菩提。是故皆名菩提分法。此三十七体各别耶。不尔。云何。颂曰

  此实事唯十　　谓慧勤定信
  念喜舍轻安　　及戒寻为体

论曰。此觉分名虽三十七。实事唯十。即慧勤等。谓四念住慧根慧力择法觉支正见以慧为体。四正断精进根精进力精进觉支正精进以勤为体。四神足定根定力定觉支正定以定为体。信根信力以信为体。念根念力念觉支正念以念为体。喜觉支以喜为体。舍觉支以行舍为体。轻安觉支以轻安为体。正语正业正命以戒为体。正思惟以寻为体。如是觉分实事唯十。即是信等五根力上。更加喜舍轻安戒寻。毗婆沙师说。有十一。身业语业不相杂故。戒分为二。余九同前。念住等三名无别属。如何独说为慧勤定。颂曰

  四念住正断　　神足随增上
  说为慧勤定　　实诸加行善

论曰。四念住等三品善法体。实遍摄诸加行善。然随同品增上善根。如次说为慧勤及定。何缘于慧立念住名。毗婆沙师作如是说。慧由念力持令住故。理实由慧令念住境。如实见者能明记故。如念住中已广成立。何故说勤名为正断。于正修习断修位中此勤力能断懈怠故。或名正胜。于正持策身语意中此最胜故。何缘于定立神足名。诸灵妙德所依止故。有余师说。神即是定。足谓欲等。彼应觉分事有十三。增欲心故。又违经说。如契经言。吾今为汝说神足等。神谓受用种种神境分一为多。乃至广说。足谓欲等四三摩地。此中佛说定果名神。欲等所生等持名足。何缘信等先说为根。后名为力。由此五法依下上品分先后故。又依可屈伏不可屈伏故。信等何缘次第如是。谓于因果先起信心为果修因。次起精进由精进故念住所缘。由念力持心便得定。心得定故能如实知。是故信等如是次第。当言何位何觉分增。颂曰

  初业顺决择　　及修见道位
  念住等七品　　应知次第增

论曰。初业位中能审照了身等四境。慧用胜故说念住增。暖法位中能证异品殊胜功德。用勤胜故说正断增。顶法位中能持胜善趣无退德。定用胜故说神足增。忍法位中必不退堕善根坚固。得增上义故说根增。第一位中非惑世法所能屈伏。得无屈义故说力增。修道位中近菩提位。助觉胜故说觉支增。见道位中速疾而转。通行胜故说道支增。然契经中随数增说先七后八。非修次第。八中正见是道亦道支。余是道支而非道。七中择法是觉亦觉支。余是觉支而非觉。毗婆沙师所说如是。有余。于此不破契经所说次第立念住等。谓修行者将修行时。于多境中其心驰散。先修念住制伏其心故。契经言。此四念住能于境界系缚其心。及正遣除耽嗜依念。是故念住说在最初。由此势力勤遂增长。为成四事正策持心。是故正断说为第二。由精进故无忧悔心。便有堪能修治胜定。是故神足说在第三。胜定为依便令信等与出世法为增上缘。由此五根说为第四。根义既立。能正伏除所治现行牵生圣法。由此五力说为第五。于见道位建立觉支。如实觉知四圣谛故。通于二位建立道支。俱通直往涅槃城故。如契经说。于八道支修圆满者于四念住至七觉支亦修圆满。又契经说。苾刍当知。宣如实言者喻说四圣谛。令依本路速行出者喻令修习八圣道支。故知八道支通依二位说。随增位说次第既然。理实应言。此三十七几通有漏几无漏耶。颂曰

  七觉八道支　　一向是无漏
  三四五根力　　皆通于二种

论曰。此中七觉八圣道支唯是无漏。唯于修道见道位中方建立故。世间亦有正见等法。而彼不得圣道支名。所余皆通有漏无漏。此三十七何地有几。颂曰

  初静虑一切　　未至除喜根
  二静虑除寻　　三四中除二
  前三无色地　　除戒前二种
  于欲界有顶　　除觉及道支

论曰。初静虑中具三十七。于未至地除喜觉支。近分地中励力转故。于下地法犹疑虑故。第二静虑除正思惟。彼静虑中已无寻故。由此二地各三十六。第三第四静虑中间双除喜寻各三十五。前三无色除戒三支并除喜寻各三十二。欲界有顶除觉道支各二十二。无无漏故。觉分转时必得证净。此有几种。依何位得实体是何法有漏无漏耶。颂曰

  证净有四种　　谓佛法僧戒
  见三得法戒　　见道兼佛僧
  法谓三谛全　　菩萨独觉道
  信戒二为体　　四皆唯无漏

论曰。经说证净总有四种。一于佛证净。二于法证净。三于僧证净。四圣戒证净。且见道位见三谛时。一一唯得法戒证净。见道谛位兼得佛僧。谓于尔时兼于成佛诸无学法。成声闻僧学无学法亦得证净。兼言为显见道谛时亦得于法及戒证净。然所信法略有二种。一别。二总。总通四谛。别唯三谛全菩萨独觉道。故见四谛时皆得法证净。圣所爱戒与现观俱。故一切时无不亦得。由所信别故名有四。应知实事唯有二种。谓于佛等三种证净以信为体。圣戒证净以戒为体故唯有二。如是四种唯是无漏。以有漏法非证净故。为依何义立证净名。如实觉知四圣谛理故名为证。所信三宝及妙尸罗皆名为净。离不信垢破戒垢故。由证得净立证净名。如出观时现起次第故说观内次第如是。如何出时现起次第。谓出观位先信世尊是正等觉。次于正法毗奈耶中信是善说。后信圣位是妙行者。正信三宝犹如良医及如良药看病者故。由心净故发净尸罗。是故尸罗说为第四。要具净信此乃现前。如遇三缘病方除故。或此四种。犹如导师道路商侣及所乘乘。经言。学位成就八支。无学位中具成就十。何缘不说有学位中有正解脱及有正智。正脱正智其体是何。颂曰

  学有余缚故　　无正脱智支
  解脱为无为　　谓胜解惑灭
  有为无学支　　即二解脱蕴
  正智如觉说　　谓尽无生智

论曰。有学位中尚有余缚未解脱故无解脱支。非离少缚可名脱者。非无解脱体可立解脱智。无学已脱诸烦恼缚。复能起二了解脱智。由二显了可立二支。有学不然。故唯成八。解脱体有二。谓有为无为。有为解脱谓无学胜解。无为解脱谓一切惑灭。有为解脱名无学支。以立支名依有为故支摄。解脱复有二种。即余经言心慧解脱。应知此二即解脱蕴。若尔不应契经中说。云何解脱清净最胜。谓心从贪离染解脱。及从嗔痴离染解脱。于解脱蕴未满为满已满为摄修欲勤等。故解脱蕴非唯胜解。若尔是何。有余师说。由真智力遣贪嗔痴。即心离垢名解脱蕴。如是已说正解脱体。正智体者如前觉说。谓即前说尽无生智。心于何世正得解脱而言无学心解脱耶。颂曰

  无学心生时　　正从障解脱

论曰。如本论说。初无学心未来生时从障解脱。何谓为障。谓烦恼得。由彼能遮此心生故。金刚喻定正灭位中彼得正断。初无学心于正生位正得解脱。金刚喻定已灭位中彼得已断。初无学心于已生位名已解脱。未生无学及世俗心当于尔时亦名解脱。然今且说决定生者。以于尔时行身世故。诸世俗心从何解脱。亦即从彼遮心生障未解脱位此岂不生。虽有已生不似今者。彼何所似。与惑得俱。此后若生无俱惑得。道于何位令生障断。颂曰

  道唯正灭位　　能令彼障断

论曰。正灭位言显居现在。正生言显未来世故。道能断障唯正灭时。余位定无断障用故。非如解脱通未生者。以生未生离障同故。经说三界谓断离灭。以何为体。差别云何。颂曰

  无为说三界　　离界唯离贪
  断界断余结　　灭界灭彼事

论曰。断等三界。即分前说无为解脱以为自体。言离界者。谓但离贪。言断界者。谓断余结。言灭界者。谓灭所余贪等随眠所随增事故。经说三界即无为解脱。若事能厌必能离耶。不尔。云何。颂曰

  厌缘苦集慧　　离缘四能断
  相对互广陜　　故应成四句

论曰。唯缘苦集所起忍智说名为厌。余则不然。四谛境中所起忍智。能断惑者皆得离名。广狭有殊故成四句。有厌非离。谓缘苦集不令惑断所有忍智。缘厌境故。非离染故。有离非厌。谓缘灭道能令惑断所有忍智。缘欣境故。能离染故。有厌亦离。谓缘苦集能令惑断所有忍智。有非厌离。谓缘灭道不令惑断所有忍智。应知此中先离欲染后见谛者所有法忍及诸智中加行解脱胜进道摄不令惑断。惑已断故。非断治故

说一切有部俱舍论卷第二十五阿毗达磨俱舍论卷第二十六

        尊者世亲造

        三藏法师玄奘奉　诏译

    分别智品第七之一

前品初说诸忍诸智。于后复说正见正智。为有忍非智耶。为有智非见耶。颂曰

  圣慧忍非智　　尽无生非见
  余二有漏慧　　皆智六见性

论曰。慧有二种。有漏无漏。唯无漏慧立以圣名。此圣慧中八忍非智性。自所断疑未已断故。可见性摄。推度性故。尽与无生二智。非见性。已息求心不推度故。所余皆通智见二性。已断自疑推度性故。诸有漏慧皆智性摄。于中唯六亦是见性。谓五染污见世正见为六。如是所说圣有漏慧皆择法故并慧性摄。智有几种。相别云何。颂曰

  智十总有二　　有漏无漏别
  有漏称世俗　　无漏名法类
  世俗遍为境　　法智及类智
  如次欲上界　　苦等谛为境

论曰。智有十种摄一切智。一世俗智。二法智。三类智。四苦智。五集智。六灭智。七道智。八他心智。九尽智。十无生智。如是十智总唯二种。有漏无漏性差别故。如是二智相别有三。谓世俗智法智类智。前有漏智总名世俗。多取瓶等世俗境故。后无漏智分法类别。三中世俗遍以一切有为无为为所缘境。法类二种如其次第以欲上界四谛为境。即于如是二种智中。颂曰

  法类由境别　　立苦等四名
  皆通尽无生　　初唯苦集类

论曰。法智类智由境差别分为苦集灭道四智。如是六智若无学摄。非见性者名尽无生。此二初生唯苦集类。以缘苦集六种行相观有顶蕴为境界故。金刚喻定境同此耶。缘苦集因。缘灭道异。于前所说九种智中颂曰

  法类道世俗　　有成他心智
  于胜地根位　　去来世不知
  法类不相知　　声闻麟喻佛
  如次知见道　　二三念一切

论曰。有法类道及世俗智成他心智。余则不然。此智于境有决定相。谓不知胜及去来心。胜心有三。谓地根位。地谓下地智不知上地心。根谓信解时解脱根智不知见至不时解脱心。位谓不还声闻应果独觉大觉。前前位智不知后后胜位者心。此智不知去来心者。唯以现在他相续中能缘心等为境界故。又法类品不互相知。谓法智摄诸他心智不知类品。类智所摄诸他心智不知法品。由法类智以欲上界全分对治为所缘故。此他心智见道中无。总观谛理极速转故。然皆容作此智所缘。若诸有情将入见道。声闻独觉预修加行。为欲知彼见道位心。彼诸有情入见道位。声闻法分加行若满知彼见道初二念心。若为更知类分心故别修加行。至加行满彼已度至第十六心。虽知此心非知见道。麟喻法分加行若满知彼见道初二念心。若为更知类分心故。别修加行。至加行满知彼第八集类智心。以此但由下加行故。有说。知初二及第十五心。世尊欲知不由加行。于彼见道一切能知。尽无生智二相何别。颂曰

  智于四圣谛　　知我已知等
  不应更知等　　如次尽无生

论曰。如本论说。云何尽智。谓无学位若正自知我已知苦。我已断集。我已证灭。我已修道。由此所有智见明觉解慧光观是名尽智。云何无生智。谓正自知我已知苦不应更知。广说乃至。我已修道不应更修。由此所有广说乃至。是名无生智。如何无漏智。可作如是知。迦湿弥罗诸论师说。从二智出后得智中作如是知故无有失。由此后得二智别故。表前观中二智差别。有说。无漏智亦作如是知。然说见言乘言便故。或于谛理现照转故。由此本论亦作是言。且诸智亦是见。如是十智相摄云何。谓世俗智摄一全一少分。法类智各摄一全七少分。苦集灭智各摄一全四少分。道智摄一全五少分。他心智摄一全四少分。尽无生智各摄一全六少分。何缘二智建立为十。颂曰

  由自性对治　　行相行相境
  加行办因圆　　故建立十智

论曰。由七缘故立二为十。一自性故立世俗智。非胜义智为自性故。二对治故立法类智。全能对治欲上界故。三行相故立苦集智。此二智境体无别故。四行相境故立灭道智。此二行相境俱有别故。五加行故立他心智。非此不知他心所法。本修加行为知他心。虽成满时亦知心所。而约加行故立他心智名。六事办故建立尽智。事办身中最初生故。七因圆故立无生智。一切圣道为因生故。如上所言。法智类智。全能对治欲上界法。为有少分治上欲耶。颂曰

  缘灭道法智　　于修道位中
  兼治上修断　　类无能治欲

论曰。修道所摄灭道法智。兼能对治上界修断。欲之灭道胜上界故。已除自怨能兼他故。由此类智无能治欲。于此十智中谁有何行相。颂曰

  法智及类智　　行相俱十六
  世俗此及余　　四谛智各四
  他心智无漏　　唯四谓缘道
  有漏自相缘　　俱但缘一事
  尽无生十四　　谓离空非我

论曰。法智类智。一一具有非常苦等十六行相。十六行相后当广释。世智有此及更有余能缘一切法自共相等故。苦等四智。一一各有缘自谛境四种行相。他心智中。若无漏者唯有缘道四种行相。由此即是道智摄故。若有漏者取自所缘心心所法自相境故。如境自相行相亦尔。故此非前十六所摄。如是二种于一切时一念但缘一事为境。谓缘心时不缘心所。缘受等时不缘想等。若尔何故薄伽梵说如实了知有贪心等。非俱时取贪等及心。如不俱时取衣及垢。有贪心者。二义有贪。一贪相应。二贪所系。贪相应心具由二义。余有漏心唯贪所系。有说。经言有贪心者。唯说第一贪相应心。离贪心者。谓治贪心。若贪不相应名离贪心者。余惑相应者应得离贪名。若尔有心非贪对治不染污性。应许此心非有贪心离贪心等。是故应许余师所说。为贪所系名有贪心。乃至有痴离痴亦尔。毗婆沙师作如是说。聚心者谓善心。此于所缘不驰散故。散心者谓染心。此与散动相应起故。西方诸师作如是说。眠相应者名为聚心。余染污心说名为散。此不应理。诸染污心若与眠相应。应通聚散故。又应违害本论所言。如实知聚心。具足有四智。谓法智类智世俗智道智。沉心者谓染心。此与懈怠相应起故。策心者谓善心。此与正勤相应起故。小心者谓染心。少净品者所好习故。大心者谓善心。多净品者所好习故。或由根价眷属随转力用少多故名小大。染心根少。极二相应故。善心根多。恒三相应故。染心价少。非功用成故。善心价多。大资粮成故。染心眷属少。无未来修故。善心眷属多。有未来修故。染心随转少。唯三蕴故。善心随转多。通四蕴故。染心力用少。所断善根必还续故。善心力用多。忍必永断诸随眠故。由此染善得小大名。掉心者谓染心。掉举相应故。不掉心者谓善心。能治彼故。不静静心应知亦尔。不定心者谓染心。散动相应故。定心者谓善心。能治彼故。不修心者谓染心。得修习修俱不摄故。修心者谓善心。容有二修故。不解脱心者谓染心。自性相续不解脱故。解脱心者谓善心。自性相续容解脱故。如是所释不顺契经。亦不能辩诸句别义。如何此释不顺契经。经言。此心云何内聚。谓心若与惛眠俱行。或内相应有止无观。云何外散。谓心游涉五妙欲境随散随流。或内相应有观无止。岂不前说。染心眠俱便有一心通聚散过。虽说非理。不许眠俱诸染污心是散心故。岂不又说本论相违。宁违论文勿违经说。如何不辩诸句别义。谓依此释不能辩了散等聚等八异相故。依我所释非不能辩此契经中八句别义。谓虽散等同是染心。而为显其过失差别。及虽聚等同是善心。而为显其功德差别。故依八义别立八名。既不能通所违经说。所辩句义理亦不成。又若沉心即掉心者。经不应说若于尔时心沈。恐沈修安定舍三觉支者名非时修。若于尔时心掉。恐掉修择进喜名非时修。岂修觉支有散别理。此据作意欲修名修。非现前修故无有失。岂不我说亦不违经。虽诸染心皆名沉掉懈怠增者经说沉心。掉举增者经说掉心。据恒相应我说体一。随自意语谁复能遮。然实此经意不如是。前说。一切贪所系心。皆名有贪心。贪系是何义。若贪得随故。有学无漏心应名有贪。贪得随故。若贪所缘故。无学有漏心应名有贪。贪所缘故。若不许彼为贪所缘。云何彼心可成有漏。若谓由为共相惑缘应名有痴。痴所缘故。然他心智不缘贪得。亦不可说缘缘心贪。宁知他心是有贪等。故非贪系名有贪心。若尔云何。今详经意贪相应故名有贪心。贪不相应名离贪等。若尔何故余契经言。离贪嗔痴心不还堕三有。依离得说故无有过。岂不于前已破此说。余惑相应者。应得离贪名。彼亦与贪不相应故。若依此意。许亦无违。然不说为离贪心者。彼属有嗔有痴等故。且止傍论应述本宗。此所明他心智。为亦能取他心所缘。及亦取他心能缘行相不。俱不能取。知彼心时。不观彼所缘能缘行相故。谓但知彼有染等心。不知彼心所染色等。亦不知彼能缘行相。不尔他心智应亦缘色等。又亦应有能自缘失。诸他心智有决定相。谓唯能取欲色界系及非所系。他相续中现在同类心心所法。一实自相为所缘境。空无相不相应。尽无生所不摄。不在见道无间道中。余所不遮如应容有。尽无生智除空非我。各具有余十四行相。由此二智虽胜义摄而涉于世俗欲离空非我。谓由彼力于出观时作如是言。我生已尽梵行已立。所作已办不受后有。为有无漏越此十六更是所余行相摄不。颂曰

  净无越十六　　余说有论故

论曰。迦湿弥罗国诸论师言。无无漏行相越此十六。外国师说。更有所余无漏行相越于十六。云何知然。由本论故。如本论说。颇有不系心能了别欲界系法耶。曰能了别。谓非常故苦故空故非我故因故集故生故缘故。有是处有是事。如理所引了别。若谓彼文不为显示不系心了别欲界系法时。除前所明八行相外别有有是处有是事行相。但为显示作八行相。斯有是处斯有是事。此释不然。余不说故。谓若彼论依此意说。应于余处亦说此言。然彼余文但作是说。颇有见断心能了别欲界系法耶。曰能了别。谓我故我所故。断故常故。无因故无作故损减故。尊故胜故上故。第一故能清净故。能解脱故。能出离故。惑故疑故犹豫故。贪故嗔故慢故痴故。不如理所引了别。此等亦应说有是处等言。既无此言故释非理。十六行相实事有几。何谓行相。能行所行。颂曰

  行相实十六　　此体唯是慧
  能行有所缘　　所行诸有法

论曰。有余师说。十六行相名虽十六实事唯七。谓缘苦谛名实俱四。缘余三谛名四实一。如是说者实亦十六。谓苦圣谛有四相。一非常二苦三空四非我。待缘故非常。逼迫性故苦。违我所见故空。违我见故非我。集圣谛有四相。一因二集三生四缘。如种理故因。等现理故集。相续理故生。成办理故缘。譬如泥团轮绳水等众缘和合成办瓶等。灭圣谛有四相。一灭二静三妙四离。诸蕴尽故灭。三火息故静。无众患故妙。脱众灾故离。道圣谛有四相。一道二如三行四出。通行义故道。契正理故如。正趣向故行。能永超故出。又非究竟故非常。如荷重担故苦。内离士夫故空。不自在故非我。牵引义故因。出现义故集。滋产义故生。为依义故缘。不续相续断故灭。离三有为相故静。胜义善故妙。极安隐故离。治邪道故道。治不如故如。趣入涅槃宫故行。弃舍一切有故出。如是古释既非一门故随所乐更为别释。生灭故非常。违圣心故苦。于此无我故空。自非我故非我。因集生缘如经所释。谓五取蕴以欲为根。以欲为集。以欲为类。以欲为生。唯此生声应在后说。与论为异。此四体相差别云何。由随位别四欲有异。一执现总我起总自体欲。二执当总我起总后有欲。三执当别我起别后有欲。四执续生我起续生时欲。或执造业我起造业时欲。第一于苦是初因故说名为因。如种子于果第二于苦等招集故说名为集。如芽等于果。第三于苦为别缘故说名为缘。如田等于果。谓由田水粪等力故令果味势熟德别生。第四于苦能近生故说名为生。如华蕊于果。或如契经说。有二五二四爱行为四种欲。执现总我有五种异。一执我现决定有。二执我现如是有。三执我现变异有。四执我现有。五执我现无。执当总我亦有五异。一执我当决定有。二执我当如是有。三执我当变异有。四执我当有。五执我当无。执当别我有四种异。一执我当别有。二执我当决定别有。三执我当如是别有。四执我当变异别有。执续生我等亦有四种异。一执我亦当有。二执我亦当决定有。三执我亦当如是有。四执我亦当变异有。流转断故灭。众苦息故静。如说苾刍诸行皆苦。唯有涅槃最为寂静。更无上故妙。不退转故离。如正道故道。如实转故如。定能趣故行。如说此道能至清净余见必无至清净理。永离有故出。又为治常乐我所我见故修非常苦空非我行相。为治无因一因变因知先因见故修因集生缘行相。为治解脱是无见故修灭行相。为治解脱是苦见故修静行相。为治静虑及等至乐是妙见故修妙行相。为治解脱是数退堕非永见故修离行相。为治无道邪道余道退道见故修道如行出行相。如是行相以慧为体。若尔慧应非有行相。以慧与慧不相应故。由此应言诸心心所取境类别皆名行相。慧及诸余心心所法有所缘故皆是能行。一切有法皆是所行。由此三门体有宽陜慧通行相能行所行。余心心所唯能所行。诸余有法唯是所行。已辨十智行相差别。当辨性摄依他依身。颂曰

  性俗三九善　　依地俗一切
  他心智唯四　　法六余十九
  现起所依身　　他心依欲色
  法智但依欲　　余八通三界

论曰。如是十智三性摄者。谓世俗通三性。余九智唯是善。依地别者。谓世俗智通依欲界乃至有顶。他心智唯依四根本静虑。法智依此四及未至中间。余依此六地及下三无色。依身别者。谓他心智依欲色界俱可现前。法智但依欲界现起。余八智现起通依三界身。已辩性地身。当辩念住摄。颂曰

  诸智念住摄　　灭智唯最后
  他心智后三　　余八智通四

论曰。灭智摄在法念住中。他心智后三摄。所余八皆通四。如是十智展转相望。一一当言几智为境。颂曰

  诸智互相缘　　法类道各九
  苦集智各二　　四皆十灭非

论曰。法智能缘九智为境。除类智。类智能缘九智为境。除法智。道智能缘九智为境。除世俗智。非道摄故。苦集二智一一能缘二智为境。谓俗他心。世俗他心尽无生智皆缘十智为境。灭智不缘诸智为境。唯以择灭为所缘故。十智所缘总有几法。何智几法为所缘境。颂曰

  所缘总有十　　谓三界无漏
  无为各有二　　俗缘十法五
  类七苦集六　　灭缘一道二
  他心智缘三　　尽无生各九

论曰。十智所缘总有十法。谓有为法分为八种。三界所系无漏有为。各有相应不相应故。无为分二种。善无记别故。俗智总缘十法为境。法智缘五。谓欲界二无漏道二及善无为。类智缘七。谓色无色无漏道六及善无为。苦集智各缘三界所系六。灭智缘一。谓善无为道智缘二。谓无漏道。他心智缘欲色无漏三相应法。尽无生智缘有为八及善无为。颇有一念智缘一切法不。不尔。岂不非我观智知一切法皆非我耶。此亦不能缘一切法。不缘何法。此体是何。颂曰

  俗智除自品　　总缘一切法
  为非我行相　　唯闻思所成

论曰。以世俗智观一切法为非我时犹除自品。自品谓自体相应俱有法。境有境别故。同一所缘故。相邻近故。非此智所缘。此智唯是欲色界摄。闻思所成非修所成。修所成慧地别缘故。若异此者应顿离染。已辩所缘。复应思择。谁成就几智耶。颂曰

  异生圣见道　　初念定成一
  二定成三智　　后四一一增
  修道定成七　　离欲增他心
  无学钝利根　　定成九成十

论曰。诸异生位及圣见道第一刹那定成一智。谓世俗智。第二刹那定成三智。谓加法苦。第四六十十四刹那。如次后后增类集灭道智。诸未增位成数如前。故修位中亦定成七。如是诸位。若已离欲各各增一。谓他心智。唯除异生生无色者。时解脱者定成九智。谓加尽智。不时解脱定成就十。谓增无生。于何位中顿修几智。且于见道十五心中。颂曰

  见道忍智起　　即彼未来修
  三类智兼修　　现观边俗智
  不生自下地　　苦集四灭后
  自谛行相境　　唯加行所得

论曰。见道位中随起忍智。皆即彼类于未来修。然具修自谛诸行相念住。何缘见道唯同类修。先未曾得此种性故。对治所缘俱决定故。唯苦集灭三类智时。能兼修未来现观边俗智。于一一谛现观后边方能兼修故立斯号。由此余位未能兼修。道类智时何不修此。俗智曾于道无事现观故。又必无于道遍事现观故。谓于苦集灭可遍知断证。必无于道可能遍修。虽集灭边未遍断证。而于当位断证已周。道则不然。种性多故。有言。此是见道眷属。彼修道摄。故不能修。理非极成。不应为证。此世俗智是不生法。于一切时无容起故。若尔何故说名为修。先未曾得今方得故。既不能起得义何依。但由得故说名为得。由得故得曾所未闻。故所辩修理不成立。如古师说。修义可成。彼说云何。由圣道力修世俗智。于出观后有胜缘谛俗智现前。得此起依故名得此。如得金矿名为得金。毗婆沙师不乐此义。随依何地见道现前能修未来自地下地。谓依未至见道现前能修未来一地见道二地俗智。至依第四见道现前能修未来六地见道七地俗智。苦集边修四念住摄。灭边修者唯法念住。随于何谛现观边修。即以此行相缘此谛为境。见道力得故。唯加行所得。智增故立智名。若并眷属以欲四蕴色界五蕴为其自性。次于修道离染位中。颂曰

  修道初刹那　　修六或七智
  断八地无间　　及有欲余道
  有顶八解脱　　各修于七智
  上无间余道　　如次修六八

论曰。修道初念。谓第十六道类智时现修二智。未离欲者未来修六。谓法及类苦集灭道。离欲修七。谓加他心不修世俗。有顶治故。断欲修断九无间道八解脱道。俗四法智随应现修。断上七地诸无间道四类世俗灭道法智随应现修。断欲加行有欲胜进。俗四法类随应现修。此上未来皆修七智。谓俗法类苦集灭道。断有顶地前八解脱。四类二法随应现修。此于未来亦唯修七。然除世俗加他心智。断有顶地九无间道。四类二法随应现修。未来修法类苦集灭道六。断欲修断第九解脱。俗四法智随应现修。断上七地诸解脱道。四类世俗灭道法智随应现修。断欲修断第九胜进断上八地诸加行道。俗四法类随应现修。断上七地有顶八品诸胜进道。俗四法类及他心智随应现修。此上未来皆修八智。谓俗法类四谛他心。次辩离染得无学位。颂曰

  无学初刹那　　修九或修十
  钝利根别故　　胜进道亦然

论曰无学初念。谓断有顶第九解脱。苦集类尽随应现修。缘有顶故。胜进九十随应现修。未来随应修九修十。谓钝根者唯除无生。利根亦修无生智故。次辩余位修智多少。颂曰

  练根无间道　　学六无学七
  余学六七八　　应八九一切
  杂修通无间　　学七应八九
  余道学修八　　应九或一切
  圣起余功德　　及异生诸位
  所修智多少　　皆如理应思

论曰。学位练根诸无间道。四法类智随应现修。未来修六。四谛法类。似见道故不修世俗。能断障故不修他心。诸解脱道四法类智随应现修。未离欲者未来修六。四谛法类。已离欲者未来修七谓加他心。有余师言。解脱道位亦修世俗。诸加行道俗四法类随应现修。未离欲者未来修七。已离欲八。谓加他心。诸胜进道若未离欲俗四法类随应现修。未来亦七。若已离欲俗四法类及他心智随应现修。未来亦八。无学练根诸无间道。四类二法随应现修。未来修七。四谛法类尽。不修世俗如治有顶故。五前八解脱。四类二法随应现修。未来修八。四谛法类他心及尽。四第九解脱苦集类尽随应现修。未来修九。最后解脱苦集类尽随应现修。未来修十。诸加行道现修如学。未来修九。诸胜进道钝者九智随应现修。未来亦九。利者十智随应现修。未来亦十。学位杂修诸无间道。四法类俗随应现修。未来修七。诸解脱道唯四法类。加行增俗。诸胜进道又加他心随应现修。未来皆八。无学杂修诸无间道。现修如学。未来所修钝八利九。诸解脱道唯四法类。加行增俗随应现修。未来所修钝九利十。诸胜进道与练根同。学位修通五无间道现修俗智。未来修七。宿住神境。二解脱道。五加行道现修俗智。他心解脱法类道俗及他心智。一切胜进并苦集灭随应现修。此上未来皆修八智。无学修通五无间道。现修如学未来所修钝八利九。解脱加行现修如学。未来所修钝九利十。诸胜进道与练根同。天眼天耳二解脱道。无记性故不名为修。圣起所余四无量等修所成摄有漏德时。现在皆修一世俗智。有学未来未离欲七。已离欲八。无学未来钝九利十。除微微心。此于未来唯修俗故。若起所余无漏功德静虑摄者四法类智随应现修。无色摄者唯四类智随应现修。未来所修同前有漏。异生离染现修世俗断欲三定。第九解脱及依根本四静虑定起胜进道离染加行未来修二。谓加他心。所余未来唯修世俗。修五通时诸加行道二解脱道现修俗智。一解脱道现俗他心。诸胜进道二随应现。未来一切皆修二种。五无间道现未唯俗。依本静虑修余功德皆现修俗。未来修二。唯顺决择分必不修他心。以是见道近眷属故。依余地定修余功德。皆唯世俗现未来修。诸未来修为修几地。诸所起得皆是修耶。颂曰

  诸道依得此　　修此地有漏
  为离得起此　　修此下无漏
  唯初尽遍修　　九地有漏德
  生上不修下　　曾所得非修

论曰。诸道依此地及得此地时。能修未来此地有漏。圣为离此地及得此地时。并此地中诸道现起。皆能修此及下无漏为离此言通二四道。唯初尽智现在前时。力能遍修九地有漏不净观等无量功德。能缚众惑断无余故。如能缚断所缚气通。又彼自心今登王位。一切善法起得来朝。譬如大王登祚洒顶一切境土皆来朝贡。然此生上必不修下。初尽智言显离有顶及五练根位第九解脱道。诸所言修唯先未得令起今得是能所修。谓若先时未得今得用功得者方是所修。若法先时僧得弃舍。今虽还得而非所修。非设劬劳而证得故。若先未得用功现前能修未来。势力胜故。曾得而起不修未来。非多功起势力劣故。为唯约得说名为修。不尔。云何。修有四种一得修。二习修。三对治修。四除遣修。如是四修依何法立。颂曰

  立得修习修　　依善有为法
  依诸有漏法　　立治修遣修

论曰。得习二修依有为善未来唯得。现具二修。治遣二修依有漏法。故有漏善具足四修。无漏有为余有漏法。如次是具前后二修。外国诸师说修有六。于前四上加防观修。防护诸根观察身故。如契经说。云何修根谓于六根善防善护乃至广说。又契经说。云何修身。谓于自身观发毛爪。乃至广说。迦湿弥罗国诸论师言。防观二修即治遣修摄

说一切有部俱舍论卷第二十六阿毗达磨俱舍论卷第二十七

        尊者世亲造

        三藏法师玄奘奉　诏译

    分别智品第七之二

如是已辩诸智差别。智所成德今当显示。于中先辩佛不共德。且初成佛尽智位修不共佛法有十八种。何谓十八。颂曰

  十八不共法　　谓佛十力等

论曰。佛十力四无畏三念住及大悲。如是合名为十八不共法。唯于诸佛尽智时修。余圣所无故名不共。且佛十力相别云何。颂曰

  力处非处十　　业八除灭道
  定根解界九　　遍趣九或十
  宿住死生俗　　尽六或十智
  宿住死生智　　依静虑余通
  赡部男佛身　　于境无碍故

论曰。佛十力者。一处非处智力。具以如来十智为性。二业异熟智力。八智为性。谓除灭道。三静虑解脱等持等至智力。四根上下智力。五种种胜解智力。六种种界智力。如是四力皆九智性。谓除灭智。七遍趣行智力。或声显此义有二途。若谓但缘能趣为境九智除灭。若谓亦缘所趣为境十智为性。八宿住随念智力。九死生智力。如是二力皆俗智性。十漏尽智力。或声亦显义有二途。若谓但缘漏尽为境六智。除道苦集他心。若谓漏尽身中所得十智为性。已辩自性。依地别者。第八第九依四静虑。余八通依十一地起。欲四静虑未至中间。并四无色名十一地。已辩依地。依身别者。皆依赡部男子佛身。已辩依身。何故名力。以于一切所知境中智无碍转故名为力。由此十力唯依佛身。唯佛已除诸惑习气于一切境随欲能知。余此相违故不名力。如舍利子舍求度人不能观知鹰所逐鸽前后二际生多少等。如是诸佛遍于所知心力无边。云何身力。颂曰

  身那罗延力　　或节节皆然
  象等七十增　　此触处为性

论曰。佛生身力等那罗延。有余师言。佛身支节一一皆具那罗延力。大德法救说。诸如来身力无边。犹如心力。若异此者则诸佛身应不能持无边心力。大觉独觉及转轮王支节相连如其次第似龙蟠结连锁相钩。故三相望力有胜劣。那罗延力其量云何。十十倍增象等七力。谓凡象。香象。摩诃诺健那。钵罗塞建提。伐浪伽。遮怒罗。那罗延。后后力增前前十倍。有说。前六十十倍增敌那罗延半身之力。此力一倍成那罗延。于所说中唯多应理。如是身力触处为性。谓所触中大种差别。有说。是造触离七外别有佛四无畏相别云何。颂曰

  四无畏如次　　初十二七力

论曰。佛四无畏如经广说。一正等觉无畏。十智为性。犹如初力。二漏永尽无畏。六十智性。如第十力。三说障法无畏。八智为性。如第二力。四说出道无畏。九十智性。如第七力。如何于智立无畏名。此无畏名目无怯惧。由有智故不怯惧他。故无畏名目诸智体。理实无畏是智所成。不应说言体即是智。佛三念住相别云何。颂曰

  三念住念慧　　缘顺违俱境

论曰。佛三念住如经广说。诸弟子众一向恭敬能正受行。如来缘之不生欢喜。舍而安住正念正知。是谓如来第一念住。诸弟子众唯不恭敬不正受行。如来缘之不生忧戚。舍而安住正念正知。是谓如来第二念住。诸弟子众一类恭敬能正受行。一类不敬不正受行。如来缘之不生欢戚。舍而安住正念正知。是谓如来第三念住。此三皆用念慧为体。诸大声闻亦于弟子顺违俱境离欢戚俱。此何名为不共佛法。唯佛于此并习断故。或诸弟子随属如来有顺违俱。应甚欢戚。佛能不起可谓希奇。非属诸声闻不起非奇特故。唯在佛得不共名。诸佛大悲云何相别。颂曰

  大悲唯俗智　　资粮行相境
  平等上品故　　异悲由八因

论曰。如来大悲俗智为性。若异此者则不能缘一切有情。亦不能作三苦行相。如共有悲。此大悲名依何义立。依五义故此立大名。一由资粮故大。谓大福德智慧资粮所成办故。二由行相故大。谓此力能于三苦境作行相故。三由所缘故大。谓此总以三界有情为所缘故。四由平等故大。谓此等于一切有情作利乐故。五由上品故大。谓最上品更无余悲能齐此故。此与悲异由八种因。一由自性。无痴无嗔自性异故。二由行相。三苦一苦行相异故。三由所缘。三界一界所缘异故。四由依地。第四静虑通余异故。五由依身。唯佛通余身有异故。六由证得。离有顶欲证得异故。七由救济。事成希望救济异故。八由哀愍。平等不等哀愍异故。已辩佛德异余有情。诸佛相望法皆等不。颂曰

  由资粮法身　　利他佛相似
  寿种姓量等　　诸佛有差别

论曰。由三事故诸佛皆等。一由资粮等圆满故。二由法身等成办故。三由利他等究竟故。由寿种姓身量等殊。诸佛相望容有差别。寿异谓佛寿有短长。种异谓佛生刹帝利婆罗门种。姓异谓佛姓乔答摩迦叶波等。量异谓佛身有小大。等言显诸佛法住久近等。如是有异由出世时所化有情机宜别故。诸有智者思惟如来三种圆德深生爱敬。其三者何。一因圆德。二果圆德。三恩圆德。初因圆德复有四种。一无余修。福德智慧二种资粮修无遗故。二长时修。经三大劫阿僧企耶修无倦故。三无间修。精勤勇猛刹那刹那修无废故。四尊重修。恭敬所学无所顾惜修无慢故。次果圆德亦有四种。一智圆德。二断圆德。三威势圆德。四色身圆德。智圆德有四种。一无师智。二一切智。三一切种智。四无功用智断圆德有四种。一一切烦恼断。二一切定障断。三毕竟断。四并习断。威势圆德有四种。一于外境化变住持自在威势。二于寿量若促若延自在威势。三于空障极远速行小大相入自在威势。四令世间种种本性法尔转胜希奇威势。威势圆德复有四种。一难化必能化。二答难必决疑。三立教必出离。四恶党必能伏。色身圆德有四种。一具众相。二具随好。三具大力。四内身骨坚越金刚。外发神光踰百千日。后恩圆德亦有四种。谓令永解脱三恶趣生死。或能安置善趣三乘。总说如来圆德如是。若别分析则有无边。唯佛世尊能知能说。要留命行经多大劫阿僧企耶说乃可尽。如是则显佛世尊身具有无边殊胜奇特因果恩德如大宝山。有诸愚夫自乏众德。虽闻如是佛功德山及所说法不能信重。诸有智者闻说如斯生信重心彻于骨髓。彼由一念极信重心转灭无边不定恶业。摄受殊胜人天涅槃。故说如来出现于世为诸智者无上福田。依之引生不空可爱殊胜速疾究竟果故。如薄伽梵自说颂言

  若于佛福田　　能殖少分善
  初获胜善趣　　后必得涅槃

已说如来不共功德。共功德今当辩。颂曰

  复有余佛法　　共余圣异生
  谓无诤愿智　　无碍解等德

论曰。世尊复有无量功德。与余圣者及异生共。谓无诤愿智无碍解通静虑无色等至等持无量解脱胜处遍处等。随其所应。谓前三门唯共余圣。通静虑等亦共异生。前三门中且辩无诤。颂曰

  无诤世俗智　　后静虑不动
  三洲缘未生　　欲界有事惑

论曰。言无诤者。谓阿罗汉观有情苦由烦恼生。自知己身福田中胜。恐他烦恼复缘己生。故思引发如是相智。由此方便令他有情不缘己身生贪嗔等。此行能息诸有情类烦恼诤故得无诤名。此行但以俗智为性。第四静虑为其所依。乐通行中最为胜故。不动应果能起非余。余尚不能自防起惑。况能止息他身烦恼。此唯依止三洲人身。缘欲未来有事烦恼。勿他烦恼缘己生故。诸无事惑不可遮防。内起随应总缘境故。辩无诤已。次辩愿智。颂曰

  愿智能遍缘　　余如无诤说

论曰。以愿为先引妙智起如愿而了故名愿智。此智自性地种性身与无诤同。但所缘别。以一切法为所缘故。毗婆沙者作如是言。愿智不能证知无色。观彼因行及彼等流差别。故知如田夫类。诸有欲起此愿智时。先发诚愿求知彼境。便入边际第四静虑以为加行。从此无间随所入定势力胜劣。如先愿力引正智起。于所求境皆如实知。已辩愿智。无碍解者。颂曰

  无碍解有四　　谓法义词辩
  名义言说道　　无退智为性
  法词唯俗智　　五二地为依
  义十六辩九　　皆依一切地
  但得必具四　　余如无诤说

论曰。诸无碍解总说有四。一法无碍解。二义无碍解。三词无碍解。四辩无碍解。此四总说如其次第以缘名义言及说道不可退转智为自性。谓无退智缘能诠法名句文身立为第一。缘所诠义立为第二。缘方言词立为第三。缘应正理无滞碍说及缘自在定慧二道立为第四。此则总说无碍解体兼显所缘。于中法词二无碍解唯俗智摄。缘名身等及世言词事境界故。法无碍解通依五地。谓欲界四静虑。以于上地无名等故。词无碍解唯依二地。谓欲界初静虑。以于上地无寻伺故。义无碍解十六智摄。谓若诸法皆名为义。义无碍解则十智摄。若唯涅槃名为义者。义无碍解则六智摄。谓俗法类灭尽无生。辩无碍解九智所摄。谓唯除灭。缘说道故此二通依一切地起。谓依欲界乃至有顶。辩无碍解于说道中许随缘一皆得起故。施设足论释此四言。缘名句文此所诠义即此一二多男女等言别此无滞说及所依道无退转智。如次建立法义词辩无碍解名。由此显成四种次第。有余师说。词谓一切训释言词。如有说言有变碍故名为色等。辩谓展转言无滞碍。传说。此四无碍解生如次串习算计佛语声明因明为前加行。若于四处未得善巧必不能生无碍解故。理实一切无碍解生唯学佛语能为加行。如是四种无碍解中。随得一时必具得四。非不具四可名为得。此四所缘自性依地与前无诤差别如是。种性依身如无诤说。如是所说无诤行等。颂曰

  六依边际得　　边际六后定
  遍顺至究竟　　佛余加行得

论曰。无诤愿智四无碍解六种皆依边际定得。边际静虑体有六种。前六除词加余边际。词无碍解虽依彼得而体非彼静虑所收。边际名但依第四静虑故。此一切地遍所随顺故增至究竟故。得边际名。云何此名遍所随顺。谓正修学此静虑时。从欲界心入初静虑。次第顺入乃至有顶。复从有顶入无所有。次第逆入乃至欲界。复从欲界次第顺入。展转乃至第四静虑。名一切地遍所随顺。云何此名增至究竟。谓专修习第四静虑。从下至中从中至上。如是三品复各分三。上上品生名至究竟。如是静虑得边际名。此中边名显无越义。胜无越此故名为边。际言为显类义极义。如说四际及实际言。除佛所余一切圣者。所说六种唯加行得。非离染得。非皆得故。唯佛于此亦离染得。诸佛功德初尽智时由离染故一切顿得。后时随欲能引现前。不由加行。以佛世尊于一切法自在转故。已辩前三唯共余圣德。于亦共凡德。且应辩通。颂曰

  通六谓神境　　天眼耳他心
  宿住漏尽通　　解脱道慧摄
  四俗他心五　　漏尽通如力
  五依四静虑　　自下地为境
  声闻麟喻佛　　二三千无数
  未曾由加行　　曾修离染得
  念住初三身　　他心三余四
  天眼耳无记　　余四通唯善

论曰。通有六种。一神境智证通。二天眼智证通。三天耳智证通。四他心智证通。五宿住随念智证通。六漏尽智证通。虽六通中第六唯圣然其前五异生亦得。依总相说亦共异生。如是六通解脱道摄。慧为自性。如沙门果。解脱道言显出障义。神境等四唯俗智摄。他心通五智摄。谓法类道世俗他心。漏尽通如力说。谓或六或十智。由此已显漏尽智通依一切地缘一切境。前之五通依四静虑。何缘此五不依无色。初三别缘色为境故。修他心通色为门故。修宿住通渐次忆念分位差别方得成故。成时能缘处性等故。依无色地无如是能。诸有欲修他心通者。先审观己身心二相前后变异展转相随。后复审观他身心相。由此加行渐次得成。成已不观自心诸色。于他心等能如实知。诸有欲修宿住通者。先自审察次前灭心。渐复逆观此生分位前前差别至结生心。乃至能忆知中有前一念名自宿住加行已成。为忆念他加行亦尔。此通初起唯次第知。串习成时亦能超忆。诸所忆事要曾领受。忆净居者昔曾闻故。从无色殁来生此者。依他相续初起此通。所余亦依自相续起。修神境等前三通时。思轻光声以为加行。成已自在随所应为。故此五通不依无色。又诸无色观减止增。五通必依止观均地。未至等地由此已遮。如是五通境唯自下。且如神境随依何地。于自下地行化自在。于上不然。势力劣故。余四亦尔。随其所应。是故无能取无色界他心宿住为二通境。即此五通于世界境作用广陜诸圣不同。谓大声闻麟喻大觉不极作意如次能于一二三千诸世界境。起行化等自在作用。若极作意如次能于二千三千无数世界。如是五通若有殊胜势用猛利从无始来曾未得者由加行得。若曾串习无胜势用及彼种类由离染得。若起现前皆由加行。佛于一切皆离染得。随欲现前不由加行。六中前三唯身念住。但缘色故。谓神境通缘四外处色香味触。天眼缘色。天耳缘声。若尔何缘说死生智知有情类由现身中成身语意诸恶行等。非天眼通能知此事。有别胜智是通眷属。依圣身起能如是知。是天眼通力所引故。与通合立死生智名。他心智通三念住摄。谓受心法。缘心等故。宿住漏尽四念住摄。通缘五蕴一切境故。此六通中天眼天耳无记性摄。许此二体是眼耳识相应慧故。若尔宁说依四静虑。随根说故亦无有失。谓所依止眼耳二根由四静虑力所引起即彼地摄故。依四地通依根故说依四言。或此依通无间道说。通无间道依四地故。余之四通性皆是善。若尔何故品类足言通云何谓善慧。彼据多分。或就胜说。如契经说。无学三明。彼于六通以何为性。颂曰

  第五二六明　　治三际愚故
  后真二假说　　学有闇非明

论曰。言三明者。一宿住智证明。二死生智证明。三漏尽智证明。如其次第以无学位摄第五二六通为其自性。六中三种独名明者。如次对治三际愚故。谓宿住智通治前际愚。死生智通治后际愚。漏尽智通治中际愚。此三皆名无学明者。俱在无学身中起故。于中最后容有是真。通无漏故。余二假说。体唯非学非无学故。有学身中有愚闇故。虽有前二不立为明。虽有暂时伏灭愚闇。后还被蔽故不名明。契经说有三种示导。彼于六通以何为体。颂曰

  第一四六导　　教诫导为尊
  定由通所成　　引利乐果故

论曰。三示导者。一神变示导。二记心示导。三教诫示导。如其次第以六通中第一四六为其自性。唯此三种引所化生令初发心最为胜故。或此能引憎背正法及处中者令发心故。能示能导得示导名。又唯此三令于佛法如次归伏信受修行得示导名。余三不尔。于二示导教诫最尊。唯此定由通所成故。定能引他利乐果故。谓前二导咒术亦能。不但由通故非决定。如有咒术名健驮梨持此便能腾空自在。复有咒术名伊刹尼。持此便能知他心念。教诫示导除漏尽通余不能为。故是决定。又前二导有但令他暂时回心。非引胜果。教诫示导亦定令他引当利益及安乐果。以能如实方便说故。由是教诫最胜非余。神境二言为目何义。颂曰

  神体谓等持　　境二谓行化
  行三意势佛　　运身胜解通
  化二谓欲色　　四二外处性
  此各有二种　　谓似自他身

论曰。依毗婆沙所说理趣。神名所目唯胜等持。由此能为神变事故。诸神变事说名为境。此有二种。谓行及化。行复三种。一者运身。谓乘空行犹如飞鸟。二者胜解。谓极远方作近思惟便能速至。三者意势。谓极远方举心缘时身即能至。此势如意得意势名。于此三中意势唯佛。运身胜解亦通余乘。谓我世尊神通迅速随方远近举心即至。由此世尊作如是说。诸佛境界不可思议。故意势行唯世尊有。胜解兼余圣。运身并异生。化复二种。谓欲色界。若欲界化外四处。除声。若色界化唯二。谓色触。以色界中无香味故。此二界化各有二种。谓属自身他身别故。身在欲界化有四种。在色亦然。故总成八。若生在色作欲界化。如何不有成香味失。如衣严具作而不成。有说。在色唯化二处。化作化事为即是通不。不尔。云何。是通之果。此有几种。差别云何。颂曰

  能化心十四　　定果二至五
  如所依定得　　从净自生二
  化事由自地　　语通由自下
  化身与化主　　语必俱非佛
  先立愿留身　　后起余心语
  有死留坚体　　余说无留义
  初多一心化　　成满此相违
  修得无记摄　　余得通三性

论曰。神境通果能变化心力能化生一切化事。此有十四。谓依根本四静虑生有差别故。依初静虑有二化心。一欲界摄。二初静虑。第二静虑有三化心。二种如前。加二静虑。第三有四。第四有五。谓各自下。如理应思诸果化心依自上地必无依下。下地定心不生上果。势力劣故。第二定等果下地化心对初定等果上地化心由依及行亦得名胜。如得静虑化心亦然。果与所依俱时得故。诸从静虑起果化心。此心必无直出观义。谓从净定起初化心。此后后心从自类起。此前前念生自类心。最后化心还生净定。故此从二能生二心。非定果心无记性摄。不还入定有直出义。如从门入还从门出。诸所化事由自地心。无异地化心起余地化故。化所发言通由自下。谓欲初定化所发言。此言必由自地心起。上化起语由初定心。上地自无起表心故。若一化主起多化身。要化主语时诸化身方语。言音诠表一切皆同故。有伽他作如是说

  一化主语时　　诸所化皆语
  一化主若默　　诸所化亦然

此但说余佛则不尔。佛诸定力最自在故。与所化语容不俱时。言音所诠亦容有别。发语心起化心既无。应无化身。化如何语。由先愿力留所化身后起余心发语表业。故虽化语二心不俱。而依化身亦得发语。非唯化主命现在时能留化身令久时住。亦有令住至命终后。即如尊者大迦叶波留骨琐身至慈尊世。唯坚实体可得久留。故迦叶波不留肉等。有余师说。愿力留身必无有能令至死后。饮光尊者留骨琐身。由诸天神持令久住。初习业者由多化心方能化生一所化事。习成满者由一化心随欲化生多少化事。如是十四能变化心皆是修得。无记性摄。即是通果无记摄义。余生得等能变化心通善不善无记性摄。如天龙等能变化心。彼亦能为自他身化。于十色处化九除声。理实无能化为根者。然所化境不离根故。言化九处亦无有失。天眼耳言为目何义。颂曰

  天眼耳谓根　　即定地净色
  恒同分无缺　　取障细远等

论曰。此言唯目天眼耳根。即四静虑所生净色。谓缘光声修加行故。依四静虑于眼耳边引起彼地微妙大种所造净色眼耳二根。见色闻声名天眼耳。如是眼耳何故名天。体即是天。定地摄故。然天眼耳种类有三。一修得天。即如前说。二者生得。谓生天中。三者似天。谓生余趣由胜业等之所引生能远见闻似天眼耳。如藏臣宝菩萨轮王诸龙鬼神及中有等。修得眼耳过现当生恒是同分。以至现在必与识俱能见闻故。处所必具无翳无缺。如生色界一切有情。能随所应取被障隔极细远等诸方色声。故于此中有如是颂

  肉眼于诸方　　被障细远色
  无能见功用　　天眼见无遗

前说化心修余得异。神境等五各有异耶亦有。云何。颂曰

  神境五修生　　咒药业成故
  他心修生咒　　又加占相成
  三修生业成　　除修皆三性
  人唯无生得　　地狱初能知

论曰。神境智类总有五种。一修得。二生得。三咒成。四药成。五业成。曼驮多王及中有等诸神境智是业成摄。他心智类总有四种前三如上。加占相成。余三各三。谓修生业。除修所得皆通善等。非定果故不得通名。人中都无生所得者。余皆容有。随其所应本性生念业所成摄。于地狱趣初受生时。唯以生得他心宿住知他心等及过去生。苦受逼已更无知义。若生余趣如应当知

说一切有部俱舍论卷第二十七阿毗达磨俱舍论卷第二十八

        尊者世亲造

        三藏法师玄奘奉　诏译

    分别定品第八之一

已说诸智所成功德。余性功德今次当辩。于中先辩所依止定。且诸定内静虑云何。颂曰

  静虑四各二　　于中生已说
  定谓善一境　　并伴五蕴性
  初具伺喜乐　　后渐离前支

论曰。一切功德多依静虑。故应先辩静虑差别。此总有四种。谓初二三四。四各有二。谓定及生。生静虑体世品已说。谓第四八。前三各三。定静虑体总而言之是善性摄心一境性。以善等持为自性故。若并助伴五蕴为性。何名一境性。谓专一所缘。若尔即心专一境位。依之建立三摩地名不应别有余心所法。别法令心于一境转名三摩地非体即心。岂不诸心刹那灭故皆一境转。何用等持。若谓令心于第二念不散乱故须有等持。则于相应等持无用。又由此故三摩地成。宁不即由斯心于一境转。又三摩地是大地法。应一切心皆一境转。不尔。余品等持劣故。有余师说。即心一境相续转时名三摩地。契经说此为增上心学故。心清净最胜即四静虑故。依何义故立静虑名。由此寂静能审虑故。审虑即是实了知义。如说心在定能如实了知。审虑义中置地界故。此宗审虑以慧为体。若尔诸等持皆应名静虑。不尔。唯胜方立此名。如世间言发光名日非萤烛等亦得日名。静虑如何独名为胜。诸等持内唯此摄支。止观均行最能审虑。得现法乐住及乐通行名。故此等持独名静虑若尔染污宁得此名。由彼亦能邪审虑故。是则应有太过之失。无太过失。要相似中方立名故。如败种等。世尊亦说有恶静虑。若一境性是静虑体。依何相立初二三四。具伺喜乐建立为初。由此已明亦具寻义。必俱行故。如烟与火。非伺有喜乐而不与寻俱。渐离前支立二三四。离伺有二。离二有乐。具离三种。如其次第。故一境性分为四种。已辩静虑。无色云何。颂曰

  无色亦如是　　四蕴离下地
  并上三近分　　总名除色想
  无色谓无色　　后色起从心
  空无边等三　　名从加行立
  非想非非想　　昧劣故立名

论曰。此与静虑数自性同。谓四各二。生如前说。即世品说由生有四。定无色体总而言之。亦善性摄心一境性。依此故说亦如是言。然助伴中此除色蕴。无色无有随转色故。虽一境性体相无差。离下地生故分四种。谓若已离第四静虑生立空无边处。乃至已离无所有处生。立非想非非想处。离名何义。谓由此道解脱下地惑。是离下染义。即此四根本并上三近分。总说名为除去色想。空处近分未得此名。缘下地色起色想故。皆无色故立无色名。此因不成。许有色故。若尔何故立无色名。由彼色微故名无色。如微黄物亦名无黄。许彼界中色有何相若彼唯有身语律仪。身语既无。律仪宁有。又无大种何有造色。若谓如有无漏律仪不尔。无漏依有漏大种故。又彼定中亦遮有故。若许于彼有色根身如何可言彼色微少。若谓于彼身量小故水细虫极微亦应名无色。亦身量小不可见故。若谓彼身极清妙故中有色界应名无色。若谓彼身清妙中极应唯有顶得无色名。如定生身有胜劣故。又生静虑所有色身非下地根所能取故。与彼何异不名无色。若谓欲色随义立名无色不然。此有何理。若谓经说寿暖合故。又说名色与识相依如二芦束相依住故。又说名色识为缘故。又遮离色乃至离行识有来有去故。由此无色有色理成。此证不成。应审思故。谓所引教应共审思且契经言寿暖合者。为约一切界。为约欲界说。名色与识相依住者。为约一切界。为约欲色说。所说名色识为缘者。为说一切识皆为名色缘。为说名色生无不缘于识。遮离色至行识有来去者。为遮随离一。为遮离一切。若谓契经言无简别不应于此更致审思。此说不然。太过失故。谓应外暖亦与寿合。又应外名色依识识为缘。又说四食如四识住。色无色界应有段食。若谓经说有一类天超段食故。又说彼天喜为食故。无斯过者。则无色界不应有色。契经说彼出离色故。又契经言。无色解脱最为寂静。超诸色故。又契经说。无色有情一切色想皆超越故。若无色界实有色者。定应彼色自相可知。如何可言超色想等。若谓观下粗色故说。则于段食亦应许然。又诸静虑超下粗色。亦应可说出离色言。是则亦应名无色界。又亦应说出离受等。彼亦超下粗受等故。经既不说。知无色中遍超色类非超受等。由此定知。彼界无色。然契经中说有不出有者。于自地有不能出故。非遍出故。非永出故。又薄伽梵于静虑中说有色类乃至识类。于无色中说有受类乃至识类。不说有色。若无色中实有色者。何不如静虑说有色类言。故所立因无不成过。在彼多劫色相续断。后殁生下色从何生。此从心生非从色起。谓昔所起色异熟因熏习在心功能今熟。是故今色从彼心生。彼无色身心依何转。离身何不转。下曾不见故。色界无段食身复依何转。下亦不见身离段食转故。又先说彼心转所依。已释总名。空无边等从缘空等得别名耶。不尔。云何。下三无色如其次第修加行时思无边空及无边识无所有故建立三名。立第四名由想昧劣。谓无明胜想得非想名。有昧劣想故名非非想。虽加行时亦作是念诸想如病如箭如痈。若想全无便同痴闇。唯有非想非非想中与上相违寂静美妙。而不就此加行立名。以若诘言何缘加行作如是念。必应答言以于彼处想昧劣故。由此昧劣故。是立名正因。已辩无色。云何等至。颂曰

  此本等至八　　前七各有三
  谓味净无漏　　后味净二种
  味谓爱相应　　净谓世间善
  此即所味着　　无漏谓出世

论曰。此上所辨静虑无色。根本等至总有八种。于中前七各具有三。有顶等至唯有二种。此地昧劣无无漏故。初味等至。谓爱相应。爱能味着故名为味。彼相应故此得味名。净等至名目世善定。与无贪等诸白净法相应起故。此得净名。即味相应所味着境。此无间灭彼味定生。缘过去净深生味着。尔时虽名出所味定。于能味定得名为入。无漏定者。谓出世定。爱不缘故非所味着。如是所说八等至中静虑摄支。非诸无色。于四静虑各有几支。颂曰

  静虑初五支　　寻伺喜乐定
  第二有四支　　内净喜乐定
  第三具五支　　舍念慧乐定
  第四有四支　　舍念中受定

论曰。唯净无漏四静虑中初具五支。一寻二伺三喜四乐五等持。此中等持颂说为定。等持与定名异体同。故契经说心定等定名正等持。此亦名为心一境性。义如前释。传说。唯定是静虑亦静虑支。余四支是静虑支非静虑。如实义者如四支军。余静虑支应知亦尔。第二静虑唯有四支。一内等净二喜三乐四等持。第三静虑具有五支。一行舍二正念三正慧四受乐五等持。第四静虑唯有四支。一行舍清净二念清净三非苦乐受四等持。静虑支名既有十八。于中实事总有几种。颂曰

  此实事十一　　初二乐轻安
  内净即信根　　喜即是喜受

论曰。此支实事唯有十一。谓初五支即五实事。第二静虑三支如前。增内净支足前为六。第三静虑等持如前。增余四支足前为十。第四静虑三支如前。增非苦乐支足前为十一。由此故说。有是初支非第二支。应作四句。第一句谓寻伺。第二句谓内净。第三句谓喜乐等持。第四句。谓除前余法。余支相对如理应思。何故第三说增乐受。由初二乐轻安摄故。何理为证知是轻安。初二定中无乐根故。非初二定有身受乐。正在定中无五识故。亦无心受乐。以说有喜故。喜即喜受。无一心中二受俱行故。无乐受不可喜乐更互现前说具五支及四支故。有说。无有心受乐根。三静虑中说乐支者。皆是身受所摄乐根。若尔何故有契经说云何乐根谓顺乐触力所引生身心乐受。有余于此增益心言。诸部经中唯说身故。又第三定所立乐支。契经自说为身所受乐故。若谓于此说意为身此说身名为有何德。又第四定轻安倍增而不说彼有乐支故。若谓轻安要顺乐受方名为乐。第三静虑轻安顺乐应是乐支。若谓彼轻安为行舍所损。不尔。行舍增轻安故。又彼轻安胜前二故。又契经说。若于尔时诸圣弟子于离生喜身作证具足住。彼于尔时已断五法修习五法皆得圆满。广说乃至。何等名为所修五法。一欢二喜三轻安四乐五三摩地此经轻安与乐别说故初二乐非即轻安。若言定中宁有身识有亦无失。许在定中有轻安风胜定所起顺生乐受遍触身故。若谓外散故应失坏定者。无如是失。此轻安风从胜定生引内身乐还能顺起三摩地故。若谓起身识应名出定者。此难不然。由前因故。若谓依止欲界身根不应得生色界触识缘轻安识许生无过。若尔正在无漏定中触及身识应成无漏。勿所立支少分有漏少分无漏成违理失。无违理失。所以者何。许说身轻安是觉支摄故。若谓顺彼故说觉支无漏亦应许如是说。若谓许说便违契经。如契经言。诸所有眼乃至广说。此经中说十五界全皆有漏故。无违经过。此约余触及余身识密意说故。如何无漏静虑现前。少支有漏少支无漏。起不俱时斯有何失。若谓喜乐不俱起故应无五支及四支理。此亦无过。约容有说有喜乐支。如有寻伺。若谓寻伺亦许俱起于不俱起为喻不成。此非不成。心之粗细互相违故不应俱起。又于不俱起不能说过故。由此可说。依初五支减二三四立第二等。即由此理初说五支。拟渐离前建立后故。无渐减故不说想等。或应说何故初唯立五支。若谓此五资初定胜故立为支。此不应理。念慧能资胜寻伺故。虽有一类作如是说。然非古昔诸轨范师共施设故。应审思择。应说何法名内等净。此定远离寻伺鼓动相续清净转名为内等净。若有寻伺鼓动相续不清净转如河有浪。若尔此应无有别体。如何许有十一实事。是故应说。此即信根。谓若证得第二静虑则于定地亦可离中有深信生名内等净。信是净相故立净名。离外均流故名内等。净而内等故立内等净名。有余师言。此内等净等持寻伺皆无别体。若无别体心所应不成。心分位殊亦得名心所。虽有此理非我所宗。如上所言。喜即喜受。以何为证知决定然。汝等岂言喜非喜受。如余部许。我亦许然。余部云何许非喜受。谓别有喜是心所法。三定中乐皆是喜受。故喜喜受其体各异。非三定乐可名喜受。二阿笈摩分明证故。如辩颠倒契经中说。渐无余灭忧等五根。第三定中无余灭喜。于第四定无余灭乐。又余经说第四静虑断乐断苦先喜忧没。故第三定必无喜根由此喜受是喜非乐。如是所说诸静虑支。染静虑中为皆有不。不尔。云何。颂曰

  染如次从初　　无喜乐内净
  正念慧舍念　　余说无安舍

论曰。如上所说诸静虑支。染静虑中非皆具有。且有一类随相说言。初染中无离生喜乐。非离烦恼而得生故。第二染中无内等净。彼为烦恼所扰浊故。第三染中无正念慧。彼为染乐所迷乱故。第四染中无舍念净。彼为烦恼所染污故。有余师说。初二染中但无轻安。后二染中但无行舍。大善摄故。契经中说三定有动第四不动。依何义说。颂曰

  第四名不动　　离八灾患故
  八者谓寻伺　　四受入出息

论曰。下三静虑名有动者。有灾患故。第四静虑名不动者。无灾患故。灾患有八。其八者何。寻伺四受入息出息。此八灾患第四都无。故佛世尊说为不动。然契经说第四静虑不为寻伺喜乐所动。有余师说。第四静虑如密室灯照而无动。如定静虑所有诸受生亦尔不。不尔。云何。颂曰

  生静虑从初　　有喜乐舍受
  及喜舍乐舍　　唯舍受如次

论曰。生静虑中初有三受。一喜受。意识相应二乐受。三识相应。三舍受。四识相应。第二有二。谓喜与舍。意识相应。无有乐受。无余识故。心悦粗故。第三有二。谓乐与舍。意识相应。第四有一。谓唯舍受。意识相应。是谓定生受有差别。上三静虑无三识身及无寻伺。如何生彼能见闻触及起表业。非生彼地无眼识等。但非彼系。所以者何。颂曰

  生上三静虑　　起三识表心
  皆初静虑摄　　唯无覆无记

论曰。生上三地起三识身及发表心皆初定系。生上起下如起化心故能见闻触及发表。此四唯是无覆无记。不起下染已离染故。不起下善以下劣故。如是别释静虑事已。净等等至初得云何。颂曰

  全不成而得　　净由离染生
  无漏由离染　　染由生及退

论曰。八本等至随其所应若全不成而获得者。净由离染及由受生。谓在下地离下地染。及从上地生自地时。下七皆然。有顶不尔。唯由离染无由生故。遮何故说全不成言。为遮已成更得少分。如由加行得顺决择分等及由退得顺退分定。即依此义作是问言。颇有净定由离染得。由离染舍。由退由生。为问亦尔。曰有。谓顺退分。且初静虑顺退分摄。离欲染时得。离自染时舍。退离自染得。退离欲染舍。从上生自得。从自生下舍。余地所摄应如理思。无漏但由离染故得。谓圣离下染得上地无漏。此亦但据全不成者。若先已成余时亦得。谓尽智位得无学道。于练根时得学无学。余加行及退皆如理应思。岂不由入正性离生亦名初得无漏等至。此非决定。以次第者尔时未得根本定故。此中但论决定得者染由受生及退故得。谓上地没生下地时得下地染。及于此地离染退时得此地染。何等至后生几等至。颂曰

  无漏次生善　　上下至第三
  净次生亦然　　兼生自地染
  染生自净染　　并下一地净
  死净生一切　　染生自下染

论曰。无漏次生自上下善。善言具摄净及无漏。然于上下各至第三。远故无能超生第四。故于无漏七等至中从初静虑无间生六。谓自二三各净无漏。无所有处无间生七。谓自下六上地唯净。第二静虑无间生八。谓自上六并下地二。识无边处无间生九。谓自下六并上地三。第三四空无间生十。谓上下八并自地二。类智无间能生无色。法智不然。依缘下故。从净等至所生亦然。而各兼生自地染污故。有顶净无间生六。谓自净染下净无漏。从初静虑无间生七。无所有八。第二定九。识处生十。余生十一。从染等至生自净染并生次下一地净定。谓为自地烦恼所逼于下净定亦生尊重故有从染生次下净。若于染净能正了知可能从染转生下净。非诸染污能正了知。如何彼能从染生净。先愿力故。谓先愿言。宁得下净不须上染。先愿势力随相续转。故后从染生下净定。如先立愿方趣睡眠至所期时便能觉寤。无漏与染必不相生。净俱相生故三有别。如是所说净染生染但约在定净及染说。若生净染生染不然。谓命终时从生得净一一无间生一切染。若从生染一一无间能生自地一切下染。不生上者未离下故。所言从净生无漏者。为一切种皆能生耶。不尔。云何。颂曰

  净定有四种　　谓即顺退分
  顺住顺胜进　　顺决择分摄
  如次顺烦恼　　自上地无漏
  互相望如次　　生二三三一

论曰。诸净等至总有四种。一顺退分摄。二顺住分摄。三顺胜进分摄。四顺决择分摄。地各有四。有顶唯三。由彼更无上地可趣故。彼地无有顺胜进分摄。于此四中唯第四分能生无漏。所以者何。由此四种有如是相。顺退分能顺烦恼。顺住分能顺自地顺胜进分能顺上地。顺决择分能顺无漏。故诸无漏唯从此生。此四相望互相生者。初能生二。谓顺退住。第二生三。除顺决择。第三生三。除顺退分。第四生一。谓自非余。如上所言净及无漏皆能上下超至第三。行者如何修超等至。颂曰

  二类定顺逆　　均间次及超
  至间超为成　　三洲利无学

论曰。本善等至分为二类。一者有漏。二者无漏。往上名顺。还下名逆。同类名均异类名间。相邻名次。越一名超。谓观行者修超定时。先于有漏八地等至顺逆均次现前数习。次于无漏七地等至顺逆均次现前数习。次于有漏无漏等至顺逆间次现前数习。次于有漏顺逆均超现前数习。次于无漏顺逆均超现前数习。是名修习超加行满。后于有漏无漏等至顺逆间超名超定成。此中超者唯能超一。远故无能超入第四。修超等至唯人三洲。不时解脱诸阿罗汉。定自在故。无烦恼故。时解脱者虽无烦恼定不自在。诸见至者虽定自在有余烦恼。故皆不能修超等至。此诸等至依何身起。颂曰

  诸定依自下　　非上无用故
  唯生有顶圣　　起下尽余惑

论曰。诸等至起依自下身。依上地身无容起下。上地起下无所用故。自有胜定故。下势力劣故。已弃舍故。可厌毁故。总相虽然若委细说。圣生有顶必起无漏无所有处。为尽自地所余烦恼。自无圣道欣乐起故。唯无所有最邻近故。起彼现前尽余烦恼。此诸等至缘何境生。颂曰

  味定缘自系　　净无漏遍缘
  根本善无色　　不缘下有漏

论曰。味定但缘自地有漏。必无缘下。已离染故。亦不缘上。爱地别故。不缘无漏。应成善故。净及无漏俱能遍缘自上下地有为无为。皆为境故。有差别者。无记无为非无漏境。根本地摄善无色定不缘下地诸有漏法。自上地法无不能缘。虽亦能缘下地无漏缘类智品道不缘法智品。亦不能缘下地法灭。无色近分亦缘下地。彼无间道必缘下故。味净无漏三等至中。何等力能断诸烦恼。颂曰

  无漏能断惑　　及诸净近分

论曰。诸无漏定皆能断惑。本净尚无能。况诸染能断。不能断下。已离染故。不能断自自所缚故。不能断上。以胜己故。若净近分亦能断惑。以皆能断次下地故。中间摄净亦不能断。近分有几。何受相应。于味等三为皆具不。颂曰

  近分八舍净　　初亦圣惑三

论曰。诸近分定亦有八种。与八根本为入门故。一切唯一舍受相应。作功用转故。未离下怖故。此八近分皆净定摄。唯初近分亦通无漏。皆无有味。离染道故。虽近分心有结生染而遮定染故作是说。有说。未至定亦有味相应。未起根本。亦贪此故。由此未至具有三种。中间静虑与诸近分。为无别义为亦有殊。义亦有殊。谓诸近分为离下染是入初因。中定不然。复有别义颂曰

  中静虑无寻　　具三唯舍受

论曰。初本近分寻伺相应。上七定中皆无寻伺。唯中静虑有伺无寻。故彼胜初未及第二。依此义故立中间名。由此上无中间静虑。一地升降无如此故。此定具有味等三种。以有胜德可爱味故。同诸近分唯舍相应。非喜相应功用转故。由此说是苦通行摄。此定能招大梵处果。多修习者为大梵故。已说等至。云何等持。经说等持总有三种。一有寻有伺。二无寻唯伺。三无寻无伺。其相云何。颂曰

  初下有寻伺　　中唯伺上无

论曰。有寻有伺三摩地者。谓与寻伺相应等持。此初静虑及未至摄。无寻唯伺三摩地者。谓唯与伺相应等持。此即静虑中间地摄。无寻无伺三摩地者。谓非寻伺相应等持。此从第二静虑近分乃至非想非非想摄。契经复说三种等持。一空二无愿三无相。其相云何。颂曰

  空谓空非我　　无相谓灭四
  无愿谓余十　　谛行相相应
  此通净无漏　　无漏三脱门

论曰。空三摩地。谓空非我二种行相相应等持。无相三摩地。谓缘灭谛四种行相相应等持。涅槃离十相。故名无相。缘彼三摩地得无相名。十相者何。谓色等五男女二种三有为相。无愿三摩地。谓缘余谛十种行相相应等持。非常苦因可厌患故道如船筏。必应舍故。能缘彼定得无愿名。皆为超过现所对故。空非我相非所厌舍。以与涅槃相相似故。此三各二种。谓净及无漏。世出世间等持别故。世间摄者通十一地。出世摄者唯通九地。于中无漏者名三解脱门。能与涅槃为入门故。契经复说三重等持。一空空。二无愿无愿。三无相无相。其相云何。颂曰

  重二缘无学　　取空非常相
  后缘无相定　　非择灭为静
  有漏人不时　　离上七近分

论曰。此三等持缘前空等取空等相故立空空等名。空空等持缘前无学空三摩地取彼空相。空相顺厌胜非我故。无愿无愿缘前无学无愿等持取非常相。不取苦因等非无漏相故不取道等为厌舍故。无相无相即缘无学无相三摩地非择灭为境。以无漏法无择灭故。但取静相非灭妙离。滥非常灭故。是无记性故。非离系果故。此三等持唯是有漏。厌圣道故。无漏不然。唯三洲人不时解脱能起如是重三摩地。依十一地。除七近分。谓欲未至八本中间。契经复说四修等持。一为住现法乐。二为得胜知见。三为得分别慧。四为诸漏永尽修三摩地。其相云何。颂曰

  为得现法乐　　修诸善静虑
  为得胜知见　　修净天眼通
  为得分别慧　　修诸加行善
  为得诸漏尽　　修金刚喻定

论曰。如契经说。有修等持若习若修若多所作得现乐住。乃至广说。善言通摄净及无漏。修诸善静虑得住现法乐。而经但说初静虑者。举初显后。理实通余。不言为住后法乐者。以后法乐非定住故。谓或退堕或上受生或般涅槃便不住故。若依诸定修天眼通。便能获得殊胜知见。若修三界诸加行善及无漏善得分别慧。若修金刚喻定便得诸漏永尽。理实修此通依诸地而契经但说第四静虑者。传说。世尊依自说故

说一切有部俱舍论卷第二十八阿毗达磨俱舍论卷第二十九

        尊者世亲造

        三藏法师玄奘奉　诏译

    分别定品第八之二

如是已说所依止定。当辩依定所起功德。诸功德中先辩无量。颂曰

  无量有四种　　对治嗔等故
  慈悲无嗔性　　喜喜舍无贪
  此行相如次　　与乐及拔苦
  欣慰有情等　　缘欲界有情
  喜初二静虑　　余六或五十
  不能断诸惑　　人起定成三

论曰。无量有四。一慈二悲三喜四舍。言无量者。无量有情为所缘故。引无量福故。感无量果故。此何缘故唯有四种。对治四种多行障故。何谓四障。谓诸嗔害不欣慰欲贪嗔。治此如次建立慈等。不净与舍俱治欲贪。斯有何别。毗婆沙说。欲贪有二。一色二淫。不净与舍如次能治。理实不净能治淫贪。余亲友贪舍能对治。四中初二体是无嗔。理实应言悲是不害。喜则喜受。舍即无贪。若并眷属五蕴为体。若舍无贪性如何能治嗔。此所治嗔贪所引故。理实应用二法为体。此四无量行相别者。云何当令诸有情类得如是乐。如是思惟入慈等至。云何当令诸有情类离如是苦。如是思怆入悲等至。诸有情类得乐离苦岂不快哉。如是思惟入喜等至。诸有情类平等平等无有亲怨。如是思惟入舍等至。此四无量不能令他实得乐等。宁非颠倒。愿欲令彼得乐等故。或阿世耶无颠倒故。与胜解想相应起故。设是颠倒复有何失。若应非善理则不然。此与善根相应起故。若应引恶理亦不然。由此力能治嗔等故。此缘欲界一切有情。能治缘彼嗔等障故。然契经说修习慈等思惟一方一切世界。此经举器以显器中。第三但依初二静虑。喜受摄故。余定地无。所余三种通依六地。谓四静虑未至中间。或有欲令唯依五地。谓除未至。是容豫德。已离欲者方能起故。或有欲令此四无量随其所应通依十地。谓欲四本近分中间。此意欲令定不定地根本加行皆无量摄前虽说此能治四障而不能令诸惑得断。有漏根本静虑摄故。胜解作意相应起故。遍缘一切有情境故。此加行位制伏嗔等。或此能令已断更远故。前说此能治四障。谓欲未至亦有慈等。似所修成根本无量。由此制伏嗔等障已引断道生能断诸惑。诸惑断已离染位中。方得根本四种无量。于此后位虽遇强缘而非嗔等之所蔽伏。初习业位云何修慈。谓先思惟自所受乐。或闻说佛菩萨声闻及独觉等所受快乐。便作是念。愿诸有情一切等受如是快乐。若彼本来烦恼增盛不能如是平等运心应于有情分为三品。所谓亲友处中怨仇。亲复分三。谓上中下。中品唯一。怨亦分三谓下中上。总成七品。分品别已。先于上亲发起真诚与乐胜解。此愿成已。于中下亲亦渐次修如是胜解。于亲三品得平等已。次于中品下中上怨亦渐次修如是胜解。由数习力能于上怨起与乐愿与上亲等。修此胜解既得无退。次于所缘渐修令广。谓渐运想思惟一邑一国一方一切世界。与乐行相无不遍满。是为修习慈无量成。若于有情乐求德者能修慈定令速疾成。非于有情乐求失者。以断善者有德可录。麟喻独觉有失可取。先福罪果现可见故。修悲喜法准此应知。谓观有情没众苦海。便愿令彼皆得解脱。及想有情得乐离苦。便深欣慰实为乐哉。修舍最初从处中起渐次乃至能于上亲起平等心与处中等。此四无量人起非余。随得一时必成三种。生第三定等唯不成喜故。已辩无量。次辩解脱。颂曰

  解脱有八种　　前三无贪性
  二二一一定　　四无色定善
  灭受想解脱　　微微无间生
  由自地净心　　及下无漏出
  三境欲可见　　四境类品道
  自上苦集灭　　非择灭虚空

论曰。解脱有八。一内有色想观外色解脱。二内无色想观外色解脱。三净解脱身作证具足住。四无色定为次四解脱。灭受想定为第八解脱。八中前三无贪为性。近治贪故。然契经中说想观者。想观增故。三中初二不净相转。作青瘀等诸行相故。第三解脱清净相转。作净光鲜行相转故。三并助伴皆五蕴性。初二解脱一一通依初二静虑。能治欲界初静虑中显色贪故。第三解脱依后静虑。离八灾患心澄净故。余地亦有相似解脱而不建立。非增上故。次四解脱如其次第以四无色定善为性。非无记染。非解脱故。亦非散善。性微劣故。彼散善者。如命终心。有说。余时亦有散善。近分解脱道。亦得解脱名。无间不然。以缘下故。彼要背下地方名解脱故。然于余处多分唯说彼根本地名解脱者。以近分中非全分故。第八解脱即灭尽定。彼自性等如先已说。厌背受想而起此故。或总厌背有所缘故。此灭尽定得解脱名。有说。由此解脱定障。微微心后此定现前。前对想心已名微细。此更微细故曰微微。次如是心入灭尽定。从灭定出或起有顶净定心或即能起无所有处无漏心。如是入心唯是有漏。通从有漏无漏心出。八中前三唯以欲界色处为境。有差别者。二境可憎。一境可爱。次四解脱各以自上苦集灭谛及一切地类智品道。彼非择灭及与虚空为所缘境。第三静虑宁无解脱。第三定中无色贪故。自地妙乐所动乱故。行者何缘修净解脱。为欲令心暂欣悦故。前不净观令心沈戚。今修净观策发令欣。或为审知自堪能故。谓前所修不净解脱为成不成。若观净相烦恼不起。彼方成故。由二缘故。诸瑜伽师修解脱等。一为诸惑已断更远。二为于定得胜自在故能引起无诤等德及圣神通。由此便能转变诸事起留舍等种种作用。何故经中第三第八说身作证非余六邪。以于八中此二胜故。于二界中各在边故。已辩解脱。次辩胜处。颂曰

  胜处有八种　　二如初解脱
  次二如第二　　后四如第三

论曰。胜处有八。一内有色想观外色少。二内有色想观外色多。三内无色想观外色少。四内无色想观外色多。内无色想观外青黄赤白为四。足前成八。八中初二如初解脱。次二如第二解脱。后四如第三解脱。若尔八胜处何殊三解脱。前修解脱唯能弃背。后修胜处能制所缘。随所乐观惑终不起。已辩胜处。次辩遍处。颂曰

  遍处有十种　　八如净解脱
  后二净无色　　缘自地四蕴

论曰。遍处有十。谓周遍观地水火风青黄赤白及空与识二无边处。于一切处周遍观察无有间隙故名遍处。十中前八如净解脱。谓八自性皆是无贪。若并助伴五蕴为性。依第四静虑缘欲可见色。有余师说。唯风遍处缘所触中风界为境。后二遍处如次空识。二净无色为其自性。各缘自地四蕴为境。应知此中修观行者。从诸解脱入诸胜处。从诸胜处入诸遍处。以后后起胜前前故。此解脱等三门功德。为由何得。依何身起。颂曰

  灭定如先辩　　余皆通二得
  无色依三界　　余唯人趣起

论曰。第八解脱如先已辩。以即是前灭尽定故。余解脱等通由二得。谓由离染及加行得。以有曾习未曾习故。四无色解脱二无色遍处。一一通依三界身起。余唯人起。由教力故。异生及圣皆能现起。诸有生在色无色界起静虑无色。由何等别缘。颂曰

  二界由因业　　能起无色定
  色界起静虑　　亦由法尔力

论曰。生上二界总由三缘。能进引生色无色定。一由因力。谓于先时近及数修为起因故。二由业力。谓先曾造感上地生顺后受业。彼业异熟将起现前。势力能令进起彼定。以若未离下地烦恼必定无容生上地故。三法尔力。谓器世界将欲坏时。下地有情法尔能起上地静虑。以于此位所有善法由法尔力皆增盛故。诸有生在上二界中起无色定。由因业力非法尔力。无云等天不为三灾之所坏故。生在色界起静虑时。由上二缘及法尔力。若生欲界起上定时。一一应知。皆由教力。前来分别种种法门。皆为弘持世尊正法。何谓正法。当住几时。颂曰

  佛正法有二　　谓教证为体
  有持说行者　　此便住世间

论曰。世尊正法体有二种。一教二证。教谓契经调伏对法。证谓三乘菩提分法。有能受持及正说者。佛正教法便住世间。有能依教正修行者。佛正证法便住世间。故随三人住世时量。应知正法住尔所时。圣教总言唯住千载。有释证法唯住千年。教法住时复过于此。此论依摄阿毗达磨。为依何理释对法耶。颂曰

  迦湿弥罗议理成　　我多依彼释对法
  少有贬量为我失　　判法正理在牟尼

论曰。迦湿弥罗国毗婆沙师议阿毗达磨理善成立。我多依彼释对法宗。少有贬量为我过失。判法正理唯在世尊及诸如来大圣弟子

  大师世眼久已闭　　堪为证者多散灭
  不见真理无制人　　由鄙寻思乱圣教
  自觉已归胜寂静　　持彼教者多随灭
  世无依怙丧众德　　无钩制惑随意转
  既知如来正法寿　　渐次沦亡如至喉
  是诸烦恼力增时　　应求解脱勿放逸

    破执我品第九之一

越此依余岂无解脱。理必无有。所以者何。虚妄我执所迷乱故。谓此法外诸所执我。非即于蕴相续假立执有真实离蕴我故。由我执力诸烦恼生三有轮回无容解脱。以何为证。知诸我名唯召蕴相续非别目我体。于彼所计离蕴我中无有真实现比量故。谓若我体别有实物如余有法。若无障缘。应现量得如六境意。或比量得如五色根。言五色根比量得者。如世现见。虽有众缘由阙别缘果便非有不阙便有。如种生芽。如是亦见虽有现境作意等缘而诸盲聋不盲聋等识不起。起定知别缘有阙不阙。此别缘者即眼等根。如是名为色根比量。于离蕴我二量都无。由此证知无真我体。然犊子部执有补特伽罗其体与蕴不一不异。此应思择为实为假。实有假有相别云何。别有事物是实有相。如色声等。但有聚集是假有相。如乳酪等。许实许假各有何失。体若是实应与蕴异。有别性故。如别别蕴。又有实体必应有因。或应是无为。便同外道见。又应无用。徒执实有。体若是假便同我说。非我所立补特伽罗如仁所征实有假有。但可依内现在世摄有执受诸蕴立补特伽罗。如是谬言于义未显。我犹不了如何名依。若揽诸蕴是此依义。既揽诸蕴成补特伽罗则补特伽罗应成假有。如乳酪等揽色等成。若因诸蕴是此依义。既因诸蕴立补特伽罗则补特伽罗亦同此失。不如是立。所立云何。此如世间依薪立火。如何立火可说依薪。谓非离薪可立有火。而薪与火非异非一。若火异薪薪应不热。若火与薪一所烧即能烧。如是不离蕴立补特伽罗。然补特伽罗与蕴非异一。若与蕴异体应是常。若与蕴一体应成断。仁今于此且应定说。何者为火。何者为薪。令我了知火依薪义。何所应说。若说应言所烧是薪能烧是火。此复应说。何者所烧。何者能烧。名薪名火。且世共了。诸不炎炽所然之物名所烧薪。诸有光明极热炎炽能然之物名能烧火。此能烧然彼物相续令其后后异前前故。此彼虽俱八事为体而缘薪故火方得生。如缘乳酒生于酪酢。故世共说依薪有火。若依此理火则异薪。后火前薪时各别故。若汝所计补特伽罗如火依薪依诸蕴者则定应说缘蕴而生体异诸蕴成无常住。若谓即于炎炽木等暖触名火余事名薪。是则火薪俱时而起应成异体。相有异故。应说依义。此既俱生。如何可言依薪立火。谓非此火用薪为因。各从自因俱时生故。亦非此火名因薪立。以立火名因暖触故。若谓所说火依薪言为显俱生或依止义。是则应许补特伽罗与蕴俱生或依止蕴。已分明许体与蕴异。理则应许若许蕴无。补特伽罗体亦非有。如薪非有火体亦无。而不许然故释非理。然彼于此自设难言。若火异薪薪应不热。彼应定说热体谓何。若彼释言热谓暖触则薪非热。体相异故。若复释言热谓暖合则应异体亦得热名。以实火名唯目暖触。余与暖合皆得热名。是则分明许薪名热。虽薪火异而过不成。如何此中举以为难。若谓木等遍炎炽时说名为薪亦名为火是则应说。依义谓何。补特伽罗与色等蕴定应是一。无理能遮。故彼所言如依薪立火。如是依蕴立补特伽罗。进退推征理不成立。又彼若许补特伽罗与蕴一异俱不可说。则彼所许三世无为及不可说五种尔焰亦应不可说。以补特伽罗不可说第五及非第五故。又彼施设补特伽罗应更礭陈。为何所托。若言托蕴假义已成。以施设补特伽罗不托补特伽罗故。若言此施设托补特伽罗。如何上言依诸蕴立理则但应说依补特伽罗。既不许然。故唯托蕴。若谓有蕴此则可知故我上言此依蕴立。是则诸色有眼等缘方可了知。故应言依眼等。又且应说。补特伽罗是六识中何识所识。六识所识。所以者何。若于一时眼识识色。因兹知有补特伽罗。说此名为眼识所识。而不可说与色一异。乃至一时意识识法。因兹知有补特伽罗。说此名为意识所识。而不可说与法一异。若尔所计补特伽罗应同乳等唯假施设。谓如眼识识诸色时因此若能知有乳等便说乳等眼识所识。而不可说与色一异。乃至身识说诸触时。因此若能知有乳等便说乳等身识所识。而不可说与触一异。勿乳等成四或非四所成。由此应成总依诸蕴假施设有补特伽罗。犹如世间总依色等施设乳等是假非实。又彼所说。若于一时眼识识色。因兹知有补特伽罗。此言何义。为说诸色是了补特伽罗因。为了色时补特伽罗亦可了。若说诸色是了此因然不可言此异色者。是则诸色以眼及明作意等缘为了因故。应不可说色异眼等。若了色时此亦可了为色能了即了此耶。为于此中别有能了。若色能了即能了此则应许此体即是色或唯于色假立于此。或不应有如是分别如是类是色如是类是此。若无如是二种分别如何立有色有补特伽罗。有情必由分别立故。若于此中别有能了了时别故此应异色。如黄异青前异后等。乃至于法征难亦然。若彼救言如此与色不可定说是一是异。二种能了相望亦然。能了不应是有为摄。若许尔者。便坏自宗。又若实有补特伽罗而不可说色非色者。世尊何故作如是言。色乃至识皆无有我。又彼既许补特伽罗眼识所得。如是眼识于色此俱为缘何起。若缘色起则不应说眼识能了补特伽罗。此非眼识缘。如声处等故。谓若有识缘此境起。即用此境为所缘缘补特伽罗非眼识缘者。如何可说为眼识所缘。故此定非眼识所了。若眼识起缘此或俱便违经说。以契经中定判识起由二缘故。又契经说。苾刍当知。眼因色缘能生眼识。诸所有眼识皆缘眼色故。又若尔者。补特伽罗应是无常。契经说故。谓契经说。诸因诸缘能生识者皆无常性。若彼遂谓补特伽罗非识所缘。应非所识。若非所识应非所知。若非所知如何立有。若不立有便坏自宗。又若许为六识所识。眼识识故应异声等。犹如色。耳识识故。应异色等。譬如声。余识所识为难准此。又立此为六识所识。便违经说。如契经言。梵志当知。五根行处境界各别。各唯受用自所行处及自境界。非有异根亦能受用异根行处及异境界。五根谓眼耳鼻舌身。意兼受用五根行处及彼境界。彼依意故。或不应执补特伽罗是五根境。如是便非五识所识。有违宗过。若尔意根境亦应别。如六生喻契经中言。如是六根行处境界各有差别。各别乐求自所行处及自境界。非此中说眼等六根。眼等五根及所生识无有势力乐见等故。但说眼等增上势力所引意识名眼等根。独行意根增上势力所引意识不能乐求眼等五根所行境界。故此经义无违前失。又世尊说。苾刍当知。吾今为汝具足演说一切所达所知法门。其体是何。谓诸眼色眼识眼触。眼触为缘内所生受。或乐或苦不苦不乐。广说乃至。意触为缘内所生受。或乐或苦不苦不乐。是名一切所达所知。由此经文决判一切所达知法。唯有尔所。此中无有补特伽罗。故补特伽罗亦应非所识。以慧与识境必同故。诸谓眼见补特伽罗。应知眼根见此所有于见非我谓见我故。彼便蹎坠恶见深坑。故佛经中自决此义。谓唯于诸蕴说补特伽罗。如人契经作如是说。眼及色为缘生于眼识。三和合触俱起受想思。于中后四是无色蕴。初眼及色名为色蕴。唯由此量说名为人。即于此中随义差别假立名想。或谓有情不悦意生儒童养者命者生者补特伽罗。亦自称言我眼见色。复随世俗说。此具寿有如是名如是种族如是姓类如是饮食如是受乐如是受苦如是长寿如是久住如是寿际。苾刍当知。此唯名想。此唯自称。但随世俗假施设有。如是一切无常有为从众缘生由思所造。世尊恒敕依了义经。此经了义。不应异释。又薄伽梵告梵志言。我说一切有唯是十二处。若数取趣非是处摄无体理成。若是处摄则不应言是不可说。彼部所诵契经亦言。诸所有眼诸所有色。广说乃至。苾刍当知。如来齐此施设一切建立一切有自体法。此中无有补特伽罗。如何可说此有实体。频毗婆罗契经亦说。诸有愚昧无闻异生随逐假名计为我者。此中无有我我所性。唯有一切众苦法体将正已生。乃至广说。有阿罗汉苾刍尼名世罗。为魔王说

  汝堕恶见趣　　于空行聚中
  妄执有有情　　智者达非有
  如即揽众分　　假想立为车
  世俗立有情　　应知揽诸蕴

世尊于杂阿笈摩中为婆罗门婆拖梨说

  婆拖梨谛听　　能解诸结法
  谓依心故染　　亦依心故净
  我实无我性　　颠倒故执有
  无有情无我　　唯有有因法
  谓十二有支　　所摄蕴处界
  审思此一切　　无补特伽罗
  既观内是空　　观外空亦尔
  能修空观者　　亦都不可得

经说。执我有五种失。谓起我见及有情见堕恶见趣。同诸外道。越路而行。于空性中心不悟入不能净信不能安住不得解脱。圣法于彼不能清净。此皆非量。所以者何。于我部中曾不诵故。汝宗许是量为部为佛言。若部是量佛非汝师汝非释子。若佛言者此皆佛言。如何非量。彼谓。此说皆非真佛言。所以者何。我部不诵故。此极非理。非理者何。如是经文诸部皆诵。不违法性及余契经。而敢于中辄兴诽拨我不诵故非真佛言。唯纵凶狂故极非理。又于彼部岂无此经谓一切法皆非我性。若彼意谓补特伽罗与所依法不一不异故说一切法皆非我。既尔应非意识所识。二缘生识经决判故。又于余经如何会释。谓契经说。非我计我此中具有想心见倒。计我成倒说于非我。不言于我何烦会释。非我者何。谓蕴处界。便违前说补特伽罗与色等蕴不一不异。又余经说。苾刍当知。一切沙门婆罗门等诸有执我等随观见。一切唯于五取蕴起。故无依我起于我见。但于非我法妄分别为我。又余经言。诸有已忆正忆当忆种种宿住。一切唯于五取蕴起。故定无有补特伽罗。若尔何缘此经复说我于过去世有如是色等。此经为显能忆宿生一相续中有种种事。若见实有补特伽罗于过去生能有色等如何非堕起身见失。或应诽拨言无此经。是故此经依总假我言有色等如聚如流。若尔世尊应非一切智。无心心所能知一切法刹那刹那异生灭故。若许有我可能遍知。补特伽罗则应常住。许心灭时此不灭故。如是便越汝所许宗。我等不言佛于一切能顿遍知故名一切智者。但约相续有堪能故。谓得佛名诸蕴相续成就如是殊胜堪能才作意时于所欲知境无倒智起故名一切智。非于一念能顿遍知。故于此中有如是颂

  由相续有能　　如火食一切
  如是一切智　　非由顿遍知

如何得知约相续说知一切法非我遍知。说佛世尊有三世故。于何处说。如有颂言

  若过去诸佛　　若未来诸佛
  若现在诸佛　　皆灭众生忧

汝宗唯许蕴有三世。非数取趣。故定应尔

说一切有部俱舍论卷第二十九阿毗达磨俱舍论卷第三十

        尊者世亲造

        三藏法师玄奘奉　诏译

    破执我品第九之二

若唯五取蕴名补特伽罗。何故世尊作如是说。吾今为汝说诸重担取舍重担荷重担者。何缘于此佛不应说。不应重担即名能荷。所以者何。曾未见故。不可说事亦不应说。所以者何。亦未见故。又取重担应非蕴摄重担自取曾未见故。然经说爱名取担者。既即蕴。摄。荷者应然。即于诸蕴立数取趣。然恐谓此补特伽罗是不可说常住实有。故此经后佛自释言。但随世俗说此具寿有如是名。乃至广说。如上所引人经文句。为令了此补特伽罗可说无常非实有性。即五取蕴自相逼害得重担名。前前刹那引后后故名为荷者。故非实有补特伽罗。补特伽罗定应实有。以契经说诸有拨无化生有情邪见摄故。谁言无有化生有情如佛所言我说有故。谓蕴相续能往后世不由胎卵湿名化生有情。拨此为无故邪见摄。化生诸蕴理实有故。又许此邪见谤补特伽罗。汝等应言。是何所断。见修所断。理并不然。补特伽罗非谛摄故。邪见不应修所断故。若谓经说有一补特伽罗生在世间应非蕴者。亦不应理。此于总中假说一故。如世间说一麻一米一聚一言。或补特伽罗应许有为摄。以契经说生世间故。非此言生如蕴新起。依何义说生在世间。依此今时取别蕴义。如世间说能祠者生记论者生取明论故。又如世说有苾刍生有外道生。取仪式故。或如世说有老者生有病者生。取别位故。佛已遮故此救不成。如胜义空契经中说。有业有异熟。作者不可得。谓能舍此蕴及能续余蕴。唯除法假。故佛已遮。颇勒具那契经亦说。我终不说有能取者。故定无一补特伽罗能于世间取舍诸蕴。又汝所引祠者等生。其体是何而能喻此。若执是我彼不极成。若心心所彼念念灭新新生故取舍不成。若许是身亦如心等。又如明等与身有异。蕴亦应异补特伽罗。老病二身各与前别。数论转变如前已遣。故彼所引为喻不成。又许蕴生非数取趣则定许此异蕴及常。又此唯一。蕴体有五。宁不说此与蕴有异。大种有四造色唯一。宁言造色不异大种。是彼宗过。何谓彼宗。诸计造色即大种论。设如彼见应作是质。如诸造色即四大种亦应即五蕴立补特伽罗。若补特伽罗即诸蕴者。世尊何不记命者即身。观能问者阿世耶故。问者执一内用士夫体实非虚名为命者。依此问佛与身一异。此都无故一异不成。如何与身可记一异。如不可记龟毛[革*卬]软。古昔诸师已解斯结。昔有大德名曰龙军。三明六通具八解脱。于时有一毕邻陀王。至大德所作如是说。我今来意欲请所疑。然诸沙门性好多语。尊能直答。我当请问。大德受请。王即问言。命者与身为一为异。大德答言。此不应记。王言。岂不先有要耶。今何异言不答所问。大德质曰。我欲问疑。然诸国王性好多语。王能直答。我当发问。王便受教。大德问言。大王宫中诸庵罗树所生果味为酢为甘。王言。宫中本无此树。大德复责。先无要耶。今何异言不答所问。王言。宫内此树既无。宁可答言果味甘酢。大德诲曰。命者亦无。如何可言与身一异。佛何不说命者都无。亦观问者阿世耶故。问者或于诸蕴相续谓为命者。依之发问。世尊若答命者都无。彼堕邪见故佛不说。彼未能了缘起理故。非受正法器。不为说假有。理必应尔。世尊说故。如世尊告阿难陀言。有姓筏蹉出家外道。来至我所作是问言。我于世间为有非有。我不为记。所以者何。若记为有违法真理。以一切法皆无我故。若记为无增彼愚惑。彼便谓我先有今无。对执有愚此愚更甚。谓执有我则堕常边。若执无我便堕断边。此二轻重如经广说。依如是义故有颂曰

  观为见所伤　　及坏诸善业
  故佛说正法　　如牝虎衔子
  执真我为有　　则为见牙伤
  拨俗我为无　　便坏善业子

复说颂曰

  由实命者无　　佛不言一异
  恐拨无假我　　亦不说都无
  谓蕴相续中　　有业果命者
  若说无命者　　彼拨此为无
  不说诸蕴中　　有假名命者
  由观发问者　　无力解真空
  如是观筏蹉　　意乐差别故
  彼问有无我　　佛不答有无

何缘不记世间常等。亦观问者阿世耶故。问者若执我为世间。我体都无故。四记皆非理。若执生死皆名世间。佛四种记亦皆非理。谓若常者无得涅槃。若是非常便自断灭不由功力咸得涅槃。若说为常亦非常者定应一分无得涅槃。一分有情自证圆寂。若记非常非非常者则非得涅槃。非不得涅槃。决定相违便成戏论。然依圣道可般涅槃。故四定记皆不应理。如离系子问雀死生。佛知彼心不为定记。有边等四亦不记者。以同常等皆有失故。宁知此四义同常等。以有外道名嗢底迦。先问世间有边等四。复设方便矫问世尊。为诸世间皆由圣道能得出离为一分耶。尊者阿难因告彼曰。汝以此事已问世尊。今复何缘改名重问。故知后四义与前同。复以何缘世尊不记如来死后有等四耶。亦观问者阿世耶故。问者妄计已解脱我名为如来而发问故。今应诘问计有我者。佛何缘记有现补特伽罗不记如来死后亦有。彼言恐有堕常失故。若尔何缘佛记慈氏汝于来世当得作佛。及记弟子身坏命终某甲今时已生某处。此岂非有堕常过失。若佛先见补特伽罗彼涅槃已便不复见以不知故不记有者则拨大师具一切智。或应许不记由我体都无。若谓世尊见而不说则有离蕴及常住过。若见非见俱不可说则应渐言不可说佛是一切智。非一切智。若谓实有补特伽罗。以契经言谛故住故定执无我者堕恶见处故。此不成证。彼经亦说定执有我者堕恶见处故。阿毗达磨诸论师言。执我有无俱边见摄。如次堕在常断边故。彼师所说深为应理。以执有我则堕常边。若执无我便堕断边。前筏蹉经分明说故。若定无有补特伽罗为说阿谁流转生死。不应生死自流转故。然薄伽梵于契经中。说诸有情无明所覆贪爱所系驰流生死故应定有补特伽罗。此复如何流转生死。由舍前蕴取后蕴故。如是义宗前已征遣。如燎原火虽刹那灭而由相续说有流转。如是蕴聚假说有情。爱取为缘流转生死。若唯有蕴。何故世尊作如是说。今我于昔为世导师名为妙眼。此说何咎。蕴各异故。若尔是何物。谓补特伽罗。昔我即今体应常住。故说今我昔为师言。显昔与今是一相续。如言此火曾烧彼事。若谓决定有真实我则应唯佛能明了观。观已应生坚固我执。从斯我执我所执生。从此应生我我所爱。故薄伽梵作如是言。若执有我便执我所。执我所故。于诸蕴中便复发生我我所爱。萨迦耶见我爱所缚则为谤佛。去解脱远。若谓于我不起我爱。此言无义。所以者何。于非我中横计为我。容起我爱。非实我中。如是所言无理为证。故彼于佛真圣教中无有因缘起见疮疱。如是一类执有不可说补特伽罗。复有一类总拨一切法体皆非有。外道执有别真我性。此等一切见不如理。皆不能免无解脱过。若一切类我体都无。刹那灭心于曾所受久相似境何能忆知。如是忆知从相续内念境想类心差别生。且初忆念为从何等心差别无间生。从有缘彼作意相似相属想等不为依止差别愁忧散乱等缘损坏功德心差别起。虽有如是作意等缘。若无彼类心差别者则无堪能修此忆念。虽有彼类心差别因若无如是缘亦无能修理。要具二种方可能修。诸忆念生但由于此。不见离此有功能故。如何异心见后异心能忆。非天授心曾所见境后祠授心有忆念理。此难非理。不相属故。谓彼二心互不相属。非如一相续有因果性故。我等不言异心见境异心能忆。相续一故。然从过去缘彼境心引起今时能忆念识。谓如前说。相续转变差别力故。生念何失。由此忆念力有后记知生。我体既无孰为能忆。能忆是何义。由念能取境。此取境岂异念。虽不异念但由作者。作者即是前说念因。谓彼类心差别。然世间所言制怛罗能忆。此于蕴相续立制怛罗名。从先见心后忆念起。依如是理说彼能忆。我体若无是谁之念。为依何义说第六声。此第六声依属主义。如何物属何主。此如牛等属制怛罗。彼如何为牛主。谓依彼彼所乘所构所役等中彼得自在。欲于何所驱役于念。而勤方便寻求念主。于所念境。驱役于念。役念为何。谓令念起。奇哉自在起无理言。宁为此生而驱役此。又我于念如何驱役。为令念起。为令念行。念无行故但应念起。则因名主。果名能属。由因增上令果得生。故因名主。果于生时是因所有故名能属。即生念因足为念主。何劳立我为念主耶。即诸行聚一类相续。世共施设制怛罗牛。立制怛罗名为牛主。是牛相续于异方生变异生因故名为主。此中无一实制怛罗亦无实牛。但假施设。故言牛主。亦不离因。忆念既尔。记知亦然。如辩忆知熟为能了谁之识等亦应例释。且识因缘与前别者。谓根境等。如应当知。有作是言。决定有我。事用必待事用者故。谓诸事用待事用者。如天授行必待天授。行是事用。天授名者。如是识等所有事用。必待所依能了等者。今应诘彼。天授谓何。若是实我此如先破。若假士夫体非一物。于诸行相续假立此名故。如天授能行识能了亦尔。依何理说天授能行。谓于刹那生灭诸行不异相续立天授名。愚夫于中执为一体。为自相续异处生因。异处生名行。因即名行者。依此理说天授能行。如焰及声异处相续。世依此说焰声能行。如是天授身能为识因故。世间亦谓天授能了。然诸圣者为顺世间言说理故。亦作是说。经说诸识能了所缘。识于所缘为何所作。都无所作但以境生。如果酬因。虽无所作而似因起说名酬因。如是识生虽无所作而似境故说名了境。如何似境。谓带彼相。是故诸识虽亦托根生不名了根。但名为了境。或识于境相续生时。前识为因引后识起说识能了亦无有失。世间于因说作者故。如世间说钟鼓能鸣。或如灯能行识能了亦尔。为依何理说灯能行。焰相续中假立灯号。灯于异处相续生时。说为灯行。无别行者。如是心相续假立识名。于异境生时说名能了。或如色有色生色住。此中无别有生住者。说识能了理亦应然。若后识生从识非我。何缘从识不恒似前。及不定次生如芽茎叶等。有为皆有住异相故。谓诸有为自性法尔微细相续后必异前。若异此者纵意入定。身心相续相似而生。后念与初无差别故。不应最后念自然从定出。诸心相续亦有定次。若此心次彼心应生。于此心后彼必生故。亦有少分行相等心方能相生。种性别故。如女心无间起严污身心。或起彼夫彼子心等。后时从此诸心相续转变差别还生女心。如是女心于后所起严污心等有生功能。异此无功能。由种性别故。女心无间容起多心。然多心中若先数起。明了近起。先起非余。由如是心修力强故。唯除将起位身外缘差别。诸有修力最强盛者。宁不恒时生于自果。由此心有住异相故。此住异相于别修果相续生中最随顺故。诸心品类次第相生因缘方隅我已略说。委悉了达唯在世尊。一切法中智自在故。依如是义故。有颂言

  于一孔雀轮　　一切种因相
  非余智境界　　唯一切智知

色差别因尚为难了。况心心所诸无色法因缘差别可易了知。一类外道作如是执。诸心生时皆从于我。前之二难于彼最切。若诸心生皆从我者。何缘后识不恒似前。及不定次生如芽茎叶等。若谓由待意合差别有异识生理定不然。我与余合非极成故。又二物合有分限故。谓彼自类释合相言非至为先后至名合。我与意合应有分限。意移转故我应移转。或应与意俱有坏灭。若谓一分合理定不然。于一我体中无别分故。设许有合我体既常。意无别异。合宁有别。若待别学为难亦同。谓觉因何得有差别。若待行别我意合者则应但心待行差别能生异识。何用我为。我于识生都无有用。而言诸识皆从我生。如药事成能除痼疾诳医矫说普莎诃言。若谓此二由我故有此但有言无理为证。若谓此二我为所依如谁与谁为所依义。非心与行如画如果我为能持如壁如器。如是便有更相碍失。及有或时别住失故。非如壁器我为彼依。若尔如何。此但如地能为香等四物所依。彼如是言证成无我。故我于此深生喜慰。如世间地不离香等。我亦应尔。非离心行。谁能了地离于香等。但于香等聚集差别。世俗流布立以地名。我亦应然。但于心等诸蕴差别。假立我名。若离香等无别有地如何说言地有香等。为显地体有香等别。故即于地说有香等。令他了达是此非余。如世间言木像身等。又若有我待行差别。何不俱时生一切智。若时此行功用最强。此能遮余令不生果。宁从强者果不恒生。答此如前修力道理许行非常渐变异故。若尔计我则为唐捐。行力令心差别生故。彼行此修体无异故。必定应信我体实有以有念等德句义故。德必依止实句义故。念等依余理不成故。此证非理。不极成故。谓说念等德句义摄体皆非实义不极成。许有别体皆名实故。经说六实物名沙门果故。彼依实我理亦不成。依义如前已遮遣故。由此所立但有虚言。若我实无为何造业。为我当受苦乐果故。我体是何。谓我执境。何名我执境。谓诸蕴相续。云何知然。贪爱彼故。与白等觉同处起故。谓世有言。我白我黑。我老我少。我瘦我肥。现见世间缘白等觉与计我执同处而生。非所计我有此差别。故知我执但缘诸蕴。以身于我有防护恩。故亦于身假说为我。如言臣等即是我身。于有恩中实假说我。而诸我执所取不然。若许缘身亦起我执。宁无我执缘他身起。他与我执不相属故。谓若身若心与我执相属。此我执起缘彼非余。无始时来如是习故。相属谓何。谓因起性。若无我体谁之我执。此前已释。宁复重来。谓我于前已作是说。为依何义说第六声。乃至辨因为果所属。若尔我执以何为因。谓无始来我执熏习。缘自相续有垢染心。我体若无谁有苦乐。若依于此有苦乐生。即说名为此有苦乐。如林有果及树有花。苦乐依何。谓内六处。随其所起说为彼依。若我实无谁能作业谁能受果。作受何义。作谓能作。受谓受者。此但易名。未显其义。辩法相者释此相言。能自在为名为作者。能领业果得受者名。现见世间。于此事业若得自在名为能作。如见天授于浴食行得自在故名浴等者。此中汝等说何天授。若说实我喻不极成。说蕴便非自在作者。业有三种谓身语意。且起身业必依身心。身心各依自因缘转。因缘展转依自因缘。于中无一自在起者。一切有为属因缘故。汝所执我不待因缘亦无所作。故非自在。由此彼说能自在为名作者。相求不可得。然于诸法生因缘中。若有胜用假名作者。非所执我见有少用故定不应名为作者能生身业胜因者何。谓从忆念引生乐欲。乐欲生寻伺。寻伺生勤勇。勤勇生风。风起身业。汝所执我此中何用。故于身业我非作者。语意业起类此应思。我复云何能领业果。若谓于果我能了别。此定不然。我于了别都无有用。于前分别生识因中已遮遣故。若实无我。如何不依诸非情处罪福生长。彼非爱等所依止故。唯内六处是彼所依。我非彼依如前已说。若实无我业已灭坏。云何复能生未来果。设有实我业已灭坏。复云何能生未来果。从依止我法非法生。如谁依谁。此前已破。故法非法不应依我。然圣教中不作是说。从已坏业未来果生。若尔从何。从业相续转变差别。如种生果。如世间说果从种生。然果不随已坏种起。亦非从种无间即生。若尔从何。从种相续转变差别果方得生。谓种次生芽茎叶等。花为最后方引果生。若尔何言从种生果。由种展转引起花中生果功能故作是说。若此花内生果功能非种为先所引起者。所生果相应与种别。如是虽言从业生果。而非从彼已坏业生。亦非从业无间生果。但从业相续转变差别生。何名相续转变差别。谓业为先后色心起中无间断名为相续。即此相续后后刹那异前前生名为转变。即此转变于最后时有胜功能无间生果胜余转变故名差别。如有取识正命终时虽带众多感后有业所引熏习。而重近起数习所引明了非余。如有颂言

  业极重近起　　数习先所作
  前前前后熟　　轮转于生死

于此义中有差别者。异熟因所引与异熟果功能。与异熟果已即便谢灭。同类因所引与等流果功能。若染污者对治起时即便谢灭。不染污者般涅槃时方永谢灭。以色心相续尔时永灭故。何缘异熟果。不能招异熟如从种果有别果生。且非譬喻是法皆等。然从种果无别果生。若尔从何。生于后果从后熟变差别所生。谓于后时即前种果遇水土等诸熟变缘。便能引生熟变差别。正生芽位方得种名。未熟变时从当名说。或似种故世说为种。此亦如是。即前异熟遇闻正邪等诸起善恶缘便能引生诸善有漏及诸不善有异熟心。从此引生相续转变展转能引转变差别。从此差别后异熟生。非从余生。故喻同法。或由别法类此可知。如拘橼花涂紫矿汁。相续转变差别为因。后果生时瓤便色赤。从此赤色更不生余。如是应知。从业异熟更不能引余异熟生。前来且随自觉慧境于诸业果略显粗相。其间异类差别功能诸业所熏相续转变至彼彼位彼彼果生。唯佛证知非余境界。依如是义故。有颂言

  此业此熏习　　至此时与果
  一切种定理　　离佛无能知
  已善说此净因道　　谓佛至言真法性
  应舍闇盲诸外执　　恶见所为求慧眼
  此涅槃宫一广道　　千圣所游无我性
  诸佛日言光所照　　虽开殊眼不能睹
  于此方隅已略说　　为开智者慧毒门
  庶各随己力堪能　　遍悟所知成胜业

说一切有部俱舍论卷第三十


阿毗达磨俱舍论本颂(说一切有部

    No. 1560 [cf. Nos. 1558, 1559, 1561]

阿毗达磨俱舍论本颂(说一切有部)

        世亲菩萨造

        三藏法师玄奘奉　诏译

    分别界品第一(四十四颂)

  诸一切种诸冥灭　　拔众生出生死泥
  敬礼如是如理师　　对法藏论我当说
  净慧随行名对法　　及能得此诸慧论
  摄彼胜义依彼故　　此立对法俱舍名
  若离择法定无余　　能灭诸惑胜方便
  由惑世间漂有海　　因此传佛说对法
  有漏无漏法　　除道余有为
  于彼漏随增　　故说名有漏
  无漏谓道谛　　及三种无为
  谓虚空二灭　　此中空无碍
  择灭谓离系　　随系事各别
  毕竟碍当生　　别得非择灭
  又诸有为法　　谓色等五蕴
  亦世路言依　　有离有事等
  有漏名取蕴　　亦说为有诤
  及苦集世间　　见处三有等
  色者唯五根　　五境及无表
  彼识依净色　　名眼等五根
  色二或二十　　声唯有八种
  味六香四种　　触十一为性
  乱心无心等　　随流净不净
  大种所造性　　由此说无表
  大种谓四界　　即地水火风
  能成持等业　　坚湿暖动性
  地谓显形色　　随世想立名
  水火亦复然　　风即界亦尔
  此中根与境　　即说十处界
  受领纳随触　　想取像为体
  四余名行蕴　　如是受等三
  及无表无为　　名法处法界
  识谓各了别　　此即名意处
  及七界应知　　六识转为意
  由即六识身　　无间灭为意
  成第六依故　　十八界应知
  总摄一切法　　由一蕴处界
  摄自性非余　　以离他性故
  类境识同故　　虽二界体一
  然为令端严　　眼等各生二
  聚生门种族　　是蕴处界义
  愚根乐三故　　说蕴处界三
  诤根生死因　　及次第因故
  于诸心所法　　受想别为蕴
  蕴不摄无为　　义不相应故
  随粗染器等　　界别次第立
  前五境唯现　　四境唯所造
  余用远速明　　或随处次第
  为差别最胜　　摄多增上法
  故一处名色　　一名为法处
  牟尼说法蕴　　数有八十千
  彼体语或名　　此色行蕴摄
  有言诸法蕴　　量如彼论说
  或随蕴等言　　如实行对治
  如是余蕴等　　各随其所应
  摄在前说中　　应审观自相
  空界谓窍隙　　传说是明闇
  识界有漏识　　有情生所依
  一有见谓色　　十有色有对
  此余色声八　　无记余三种
  欲界系十八　　色界系十四
  除香味二识　　无色系后三
  意法意识通　　所余唯有漏
  五识唯寻伺　　后三二余无
  说五无分别　　由计度随念
  以意地散慧　　意诸念为体
  七心法界半　　有所缘余无
  前八界及声　　无执受余二
  触界中有二　　余九色所造
  法一分亦然　　十色可积集
  谓唯外四界　　能斫及所斫
  亦所烧能称　　能烧所称诤
  内五有熟养　　声无异熟生
  八无碍等流　　亦异熟生性
  余三实唯法　　刹那唯后三
  眼与眼识界　　独俱得非等
  内十二眼等　　色等六为外
  法同分余二　　作不作自业
  十五唯修断　　后三界通三
  不染非六生　　色定非见断
  眼法界一分　　八种说名见
  五识俱生慧　　非见不度故
  眼见色同分　　非彼能依识
  传说不能观　　被障诸色故
  或二眼俱时　　见色分明故
  眼耳意根境　　不至三相违
  应知鼻等三　　唯取等量境
  后依唯过去　　五识依或俱
  随根变识异　　故眼等名依
  彼及不共因　　故随根说识
  眼不下于身　　色识非上眼
  色于识一切　　二于身亦然
  如眼耳亦然　　次三皆自地
  身识自下地　　意不定应知
  五外二所识　　常法界无为
  法一分是根　　并内界十二

    分别根品第二(七十四颂)

  传说五于四　　四根于二种
  五八染净中　　各别为增上
  了自境增上　　总立于六根
  从身立二根　　女男性增上
  于同住杂染　　清净增上故
  应知命五受　　信等立为根
  未当知已知　　具知根亦尔
  于得后后道　　涅槃等增上
  心所依此别　　此住此杂染
  此资粮此净　　由此量立根
  或流转所依　　及生住受用
  建立前十四　　还灭后亦然
  身不悦名苦　　即此悦名乐
  及三定心悦　　余处此名喜
  心不悦名忧　　中舍二无别
  见修无学道　　依九立三根
  唯无漏后三　　有色命忧苦
  当知唯有漏　　通二余九根
  命唯是异熟　　忧及后八非
  色意余四受　　一一皆通二
  忧定有异熟　　前八后三无
  意余受信等　　一一皆通二
  唯善后八根　　忧通善不善
  意余受三种　　前八唯无记
  欲色无色系　　如次除后三
  兼女男忧苦　　并余色喜乐
  意三受通三　　忧见修所断
  九唯修所断　　五修非三非
  欲胎卵湿生　　初得二异熟
  化生六七八　　色六上唯命
  正死灭诸根　　无色三色八
  欲顿十九八　　渐四善增五
  九得边二果　　七八九中二
  十一阿罗汉　　依一容有说
  成就命意舍　　各定成就三
  若成就乐身　　各定成就四
  成眼等及喜　　各定成五根
  若成就苦根　　彼定成就七
  若成女男忧　　信等各成八
  二无漏十一　　初无漏十三
  极少八无善　　成受身命意
  愚生无色界　　成善命意舍
  极多成十九　　二形除三净
  圣者未离欲　　除二净一形
  欲微聚无声　　无根有八事
  有身根九事　　十事有余根
  心心所必俱　　诸行相或得
  心所且有五　　大地法等异
  受想思触欲　　慧念与作意
  胜解三摩地　　遍于一切心
  信及不放逸　　轻安舍惭愧
  二根及不害　　勤唯遍善心
  痴逸怠不信　　惛掉恒唯染
  唯遍不善心　　无惭及无愧
  忿覆悭嫉恼　　害恨谄诳憍
  如是类名为　　小烦恼地法
  欲有寻伺故　　于善心品中
  二十二心所　　有时增恶作
  于不善不共　　见俱唯二十
  四类恼忿等　　恶作二十一
  有覆有十八　　无覆许十二
  睡眠遍不违　　若有皆增一
  初定除不善　　及恶作睡眠
  中定又除寻　　上兼除伺等
  无惭愧不重　　于罪不见怖
  爱敬谓信惭　　唯于欲色有
  寻伺心粗细　　慢对他心举
  憍由染自法　　心高无所顾
  心意识体一　　心心所有依
  有缘有行相　　相应义有五
  心不相应行　　得非得同分
  无想二定命　　相名身等类
  得谓获成就　　非得此相违
  得非得唯于　　自相续二灭
  三世法各三　　善等唯善等
  有系自界得　　无系得通四
  非学无学三　　非所断二种
  无记得俱起　　除二通变化
  有覆色亦俱　　欲色无前起
  非得净无记　　去来世各三
  三界不系三　　许圣道非得
  说名异生性　　得法易地舍
  同分有情等　　无想无想中
  心心所法灭　　异熟居广果
  如是无想定　　从静虑求脱
  善唯顺生受　　非圣得一世
  灭尽定亦然　　为静住有顶
  善二受不定　　圣由加行得
  成佛得非前　　三十四念故
  二定依欲色　　灭定初人中
  命根体即寿　　能持暖及识
  相谓诸有为　　生住异灭性
  此有生生等　　于八一有能
  生能生所生　　非离因缘合
  名身等所谓　　想章字总说
  欲色有情摄　　等流无记性
  同分亦如是　　并无色异熟
  得相通三类　　非得定等流
  能作及俱有　　同类与相应
  遍行并异熟　　许因唯六种
  除自余能作　　俱有互为果
  如大相所相　　心于心随转
  心所二律仪　　彼及心诸相
  是心随转法　　由时果善等
  同类因相似　　自部地前生
  道展转九地　　唯等胜为果
  加行生亦然　　闻思所成等
  相应因决定　　心心所同依
  遍行谓前遍　　为同地染因
  异熟因不善　　及善唯有漏
  遍行与同类　　二世三世三
  果有为离系　　无为无因果
  后因果异熟　　前因增上果
  同类遍等流　　俱相应士用
  异熟无记法　　有情有记生
  等流似自因　　离系由慧尽
  若因彼力生　　是果名士用
  除前有为法　　有为增上果
  五取果唯现　　二与果亦然
  过现与二因　　一与唯过去
  染污异熟生　　余初圣如次
  除异熟遍二　　及同类余生
  此谓心心所　　余及除相应
  说有四种缘　　因缘五因性
  等无间非后　　心心所已生
  所缘一切法　　增上即能作
  二因于正灭　　三因于正生
  余二缘相违　　而兴于作用
  心心所由四　　二定但由三
  余由二缘生　　非无次第故
  大为大二因　　为所造五种
  造为造三种　　为大唯一因
  欲界有四心　　善恶覆无覆
  色无色除恶　　无漏有二心
  欲界善生九　　此复从八生
  染从十生四　　余从五生七
  色善生十一　　此复从九生
  有覆从八生　　此复生于六
  无覆从三生　　此复能生六
  无色善生九　　此复从六生
  有覆生从七　　无覆如色辩
  学从四生五　　余从五生四
  十二为二十　　谓三界善心
  分加行生得　　欲无覆分四
  异熟威仪路　　工巧处通果
  色界除工巧　　余数如前说
  三界染心中　　得六六二种
  色善三学四　　余皆自可得

    分别世界品第三(九十九颂)

  地狱傍生鬼　　人及六欲天
  名欲界二十　　由地狱洲异
  此上十七处　　名色界于中
  三静虑各三　　第四静虑八
  无色界无处　　由生有四种
  依同分及命　　令心等相续
  于中地狱等　　自名说五趣
  唯无覆无记　　有情非中有
  身异及想异　　身异同一想
  翻此身想一　　并无色下三
  故识住有七　　余非有损坏
  应知兼有顶　　及无想有情
  是九有情居　　余非不乐住
  四识住当知　　四蕴唯自地
  说独识非住　　有漏四句摄
  于中有四生　　有情谓卵等
  人傍生具四　　地狱及诸天
  中有唯化生　　鬼通胎化二
  死生二有中　　五蕴名中有
  未至应至处　　故中有非生
  如谷等相续　　处无间续生
  像实有不成　　不等故非譬
  一处无二并　　非相续二生
  说有健达缚　　及五七经故
  此一业引故　　如当本有形
  本有谓死前　　居生刹那后
  同净天眼见　　业通疾具根
  无对不可转　　食香非久住
  倒心趣欲境　　湿化染香处
  天首上三横　　地狱头归下
  一于入正知　　二三兼住出
  四于一切位　　及卵恒无知
  前三种入胎　　谓轮王二佛
  业智俱胜故　　如次四余生
  无我唯诸蕴　　烦恼业所为
  由中有相续　　入胎如灯焰
  如引次第增　　相续由惑业
  更趣于余世　　故有轮无初
  如是诸缘起　　十二支三际
  前后际各二　　中八据圆满
  宿惑位无明　　宿诸业名行
  识正结生蕴　　六处前名色
  从生眼等根　　三和前六处
  于三受因异　　未了知名触
  在淫爱前受　　贪资具淫爱
  为得诸境界　　遍驰求名取
  有谓正能造　　牵当有果业
  结当有名生　　至当受老死
  传许约位说　　从胜立支名
  于前后中际　　为遣他愚惑
  三烦恼二业　　七事亦名果
  略果及略因　　由中可比二
  从惑生惑业　　从业生于事
  从事事惑生　　有支理唯此
  此中意正说　　因起果已生
  明所治无明　　如非亲实等
  说为结等故　　非恶慧见故
  与见相应故　　说能染慧故
  名无色四蕴　　触六三和生
  五相应有对　　第六俱增语
  明无明非二　　无漏染污余
  爱恚二相应　　乐等顺三受
  从此生六受　　五属身余心
  此复成十八　　由意近行异
  欲缘欲十八　　色十二上三
  二缘欲十二　　八自二无色
  后二缘欲六　　四自一上缘
  初无色近分　　缘色四自一
  四本及三边　　唯一缘自境
  十八唯有漏　　余已说当说
  此中说烦恼　　如种复如龙
  如草根树茎　　及如糠裹米
  业如有糠米　　如草药如花
  诸异熟果事　　如成熟饮食
  于四种有中　　生有唯染污
  由自地烦恼　　余三无色三
  有情由食住　　段欲体唯三
  非色不能益　　自根解脱故
  触思识三食　　有漏通三界
  意成及求生　　食香中有起
  前二益此世　　所依及能依
  后二于当有　　引及起如次
  断善根与续　　离染退死生
  许唯意识中　　死生唯舍受
  非定无心二　　二无记涅槃
  渐死足齐心　　最后意识灭
  下人天不生　　断末摩水等
  止邪不定聚　　圣造无间余
  安立器世间　　风轮最居下
  其量广无数　　厚十六洛叉
  次上水轮深　　十一亿二万
  下八洛叉水　　余凝结成金
  此水金轮广　　径十二洛叉
  三千四百半　　周围此三倍
  苏迷卢处中　　次踰健达罗
  伊沙驮罗山　　朅地洛迦山
  苏达梨舍那　　頞湿缚羯拏
  毗那怛迦山　　尼民达罗山
  于大洲等外　　有铁轮围山
  前七金所成　　苏迷卢四宝
  入水皆八万　　妙高出亦然
  余八半半下　　广皆等高量
  山间有八海　　前七名为内
  最初广八万　　四边各三倍
  余六半半陜　　第八名为外
  三洛叉二万　　二千踰缮那
  于中大洲相　　南赡部如车
  三边各二千　　南边有三半
  东毗提诃洲　　其相如半月
  三边如赡部　　东边三百半
  西瞿陀尼洲　　其相圆无缺
  径二千五百　　周围此三倍
  北俱卢畟方　　面各二千等
  中洲复有八　　四洲边各二
  此北九黑山　　雪香醉山内
  无热池纵广　　五十踰缮那
  此下过二万　　无间深广同
  上七捺落迦　　八增皆十六
  谓煻煨尸粪　　锋刃烈河增
  各住彼四方　　余八寒地狱
  日月迷卢半　　五十一五十
  夜半日没中　　日出四洲等
  雨际第二月　　后九夜渐增
  寒第四亦然　　夜减昼翻此
  昼夜增腊缚　　行南北路时
  近日自影覆　　故见月轮缺
  妙高层有四　　相去各十千
  傍出十六千　　八四二千量
  坚手及持鬘　　恒憍大王众
  如次居四级　　亦住余七山
  妙高顶八万　　三十三天居
  四角有四峰　　金刚手所住
  中宫名善见　　周万踰缮那
  高一半金城　　杂饰地柔濡
  中有殊胜殿　　周千踰缮那
  外四苑庄严　　众车粗杂喜
  妙地居四方　　相去各二十
  东北圆生树　　西南善法堂
  此上有色天　　住依空宫殿
  六受欲交抱　　执手笑视淫
  初如五至十　　色圆满有衣
  欲生三人天　　乐生三九处
  如彼去下量　　去上数亦然
  离通力依他　　下无升见上
  四大洲日月　　苏迷卢欲天
  梵世各一千　　名一小千界
  此小千千倍　　说名一中千
  此千倍大千　　皆同一成坏
  赡部洲人量　　三肘半四肘
  东西北洲人　　倍倍增如次
  欲天俱卢舍　　四分一一增
  色天踰缮那　　初四增半半
  此上增倍倍　　唯无云减三
  北洲定千年　　西东半半减
  此洲寿不定　　后十初叵量
  人间五十年　　下天一昼夜
  乘斯寿五百　　上五倍倍增
  色无昼夜殊　　劫数等身量
  无色初二万　　后后二二增
  少光上下天　　大全半为劫
  等活等上六　　如次以欲天
  寿为一昼夜　　寿量亦同彼
  极热半中劫　　无间中劫全
  傍生极一中　　鬼月日五百
  頞部陀寿量　　如一婆诃麻
  百年除一昼　　后后倍二十
  诸处有中夭　　除北俱卢洲
  极微字刹那　　色名时极少
  极微微金水　　兔羊牛隙尘
  虮虱麦指节　　后后增七倍
  二十四指肘　　四肘为弓量
  五百俱卢舍　　此八踰缮那
  百二十刹那　　为怛刹那量
  腊缚此六十　　此三十须臾
  此三十昼夜　　三十昼夜月
  十二月为年　　于中半减夜
  寒热雨际中　　一月半已夜
  于所余半月　　智者知夜减
  应知有四劫　　谓坏成中大
  坏从狱不生　　至外器都尽
  成劫从风起　　至地狱劫生
  中劫从无量　　减至寿唯十
  次增减十八　　后增至八万
  如是成已住　　名中二十劫
  成坏坏已空　　时皆等住劫
  八十中大劫　　大劫三无数
  减八万至百　　诸佛现世间
  独觉增减时　　麟角喻百劫
  轮王八万上　　金银铜铁轮
  一二三四洲　　逆次独如佛
  他迎自往伏　　诤阵胜无害
  相不正圆明　　故与佛非等
  劫初如色天　　后渐增贪味
  由惰贮贼起　　为防雇守田
  业道增寿减　　至十三灾现
  刀疾饥如次　　七日月年止
  三灾火水风　　上三定为顶
  如次内灾等　　四无不动故
  然彼器非常　　情俱生灭故
  要七火一水　　七水火后风

    分别业品第四(一百三十一颂)

  世别由业生　　思及思所作
  思即是意业　　所作谓身语
  此身语二业　　俱表无表性
  身表许别形　　非行动为体
  以诸有为法　　有刹那尽故
  应无无因故　　生因应能灭
  形亦非实有　　应二根取故
  无别极微故　　语表许言声
  说三无漏色　　增非作等故
  此能造大种　　异于表所依
  欲后念无表　　依过大种生
  有漏自地衣　　无漏随生处
  无表无执受　　亦等流情数
  散依等流性　　有受异大生
  定生依长养　　无受无异大
  表唯等流性　　属身有执受
  无表记余三　　不善唯在欲
  无表遍欲色　　表唯有伺二
  欲无有覆表　　以无等起故
  胜义善解脱　　自性惭愧根
  相应彼相应　　等起色业等
  翻此名不善　　胜无记二常
  等起有二种　　因及彼刹那
  如次第应知　　名转名随转
  见断识唯转　　唯随转五识
  修断意通三　　无漏异熟非
  于转善等性　　随转各容三
  牟尼善必同　　无记随或善
  无表三律仪　　不律仪非二
  律仪别解脱　　静虑及道生
  初律仪八种　　实体唯有四
  形转名异故　　各别不相违
  受离五十八　　一切所应离
  立近事近住　　勤策及苾刍
  俱得名尸罗　　妙行业律仪
  唯初表无表　　名别解业道
  八成别解脱　　得静虑圣者
  成静虑道生　　后二随心转
  未至九无间　　俱生二名断
  正知正念合　　名意根律仪
  住别解无表　　未舍恒成现
  刹那后成过　　不律仪亦然
  得静虑律仪　　恒成就过未
  圣初除过去　　住定道成中
  住中有无表　　初成中后二
  住律不律仪　　起染净无表
  初成中后二　　至染净势终
  表正作成中　　后成过非未
  有覆及无覆　　唯成就现在
  恶行恶戒业　　业道不律仪
  成表非无表　　住中劣思作
  舍未生表圣　　成无表非表
  定生得定地　　彼圣得道生
  别解脱律仪　　得由他教等
  别解脱律仪　　尽寿或昼夜
  恶戒无昼夜　　谓非如善受
  近住于晨旦　　下座从师受
  随教说具支　　离严饰昼夜
  戒不逸禁支　　四一三如次
  为防诸性罪　　失念及憍逸
  近住余亦有　　不受三归无
  称近事发戒　　说如苾刍等
  若皆具律仪　　何言一分等
  谓约能持说　　下中上随心
  归依成佛僧　　无学二种法
  及涅槃择灭　　是说具三归
  邪行最可诃　　易离得不作
  得律仪如誓　　非总于相续
  以开虚诳语　　便越诸学处
  遮中唯离酒　　为护余律仪
  从一切二现　　得欲界律仪
  从根本恒时　　得静虑无漏
  律从诸有情　　支因说不定
  不律从一切　　有情支非因
  诸得不律仪　　由作及誓受
  得所余无表　　由田受重行
  舍别解调伏　　由故舍命终
  及二形俱生　　断善根夜昼
  有说由犯重　　余说由法灭
  迦湿弥罗说　　犯二如负财
  舍定生善法　　由易地退等
  舍圣由得果　　练根及退失
  舍恶戒由死　　得戒二形生
  舍中由受势　　作事寿根断
  舍欲非色善　　由根断上生
  由对治道生　　舍诸非色染
  恶戒人除北　　二黄门二形
  律仪亦在天　　唯人俱三种
  生欲天色界　　有静虑律仪
  无漏并无色　　除中定无想
  安不安非业　　名善恶无记
  福非福不动　　欲善业名福
  不善名非福　　上界善不勤
  约自地处所　　业果无动故
  顺乐苦非二　　善至三顺乐
  诸不善顺苦　　上善顺非二
  余说下亦有　　由中招异熟
  又许此三业　　非前后熟故
  顺受总有五　　谓自性相应
  及所缘异熟　　现前差别故
  此有定不定　　定三顺现等
  或说业有五　　余师说四句
  四善容俱作　　引同分唯三
  诸处造四种　　地狱善除现
  坚于离染地　　异生不造生
  圣不造生后　　并欲有顶退
  欲中有能造　　二十二种业
  皆顺现受摄　　类同分一故
  由重惑净心　　及是恒所造
  于功德田起　　害父母业定
  由田意殊胜　　及定招异熟
  得永离地业　　定招现法果
  于佛上首僧　　及灭定无诤
  慈见修道出　　损益业即受
  诸善无寻业　　许唯感心受
  恶唯感身受　　是感受业异
  心狂唯意识　　由业异熟生
  及怖害违忧　　除北洲在欲
  说曲秽浊业　　依谄嗔贪生
  依黑黑等殊　　所说四种业
  恶色欲界善　　能尽彼无漏
  应知如次第　　名黑白俱非
  四法忍离欲　　前八无间俱
  十二无漏思　　唯尽纯黑业
  离欲四静虑　　第九无间思
  一尽杂纯黑　　四令纯白尽
  有说地狱受　　余欲业黑杂
  有说欲见灭　　余欲业黑俱
  无学身语业　　即意三牟尼
  三清净应知　　即诸三妙行
  恶身语意业　　说名三恶行
  及贪嗔邪见　　三妙行翻此
  所说十业道　　摄恶妙行中
  粗品为其性　　如应成善恶
  恶六定无表　　彼自作淫二
  善七受生二　　定生唯无表
  加行定有表　　无表或有无
  后起此相违　　加行三根起
  彼无问生故　　贪等三根生
  善于三位中　　皆三善根起
  杀粗语嗔恚　　究竟皆由嗔
  盗邪行及贪　　皆由贪究竟
  邪见痴究竟　　许所余由三
  有情具名色　　名身等处起
  俱死及前死　　无根依别故
  军等若同事　　皆成如作者
  杀生由故思　　他想不误杀
  不与取他物　　力窃取属己
  欲邪行四种　　行所不应行
  染异想发言　　解义虚诳语
  由眼耳意识　　并余三所证
  如次第名为　　所见闻知觉
  染心坏他语　　说名离间语
  非爱粗恶语　　诸染杂秽语
  余说异三染　　佞歌邪论等
  恶欲他财贪　　增有情嗔恚
  拨善恶等见　　名邪见业道
  此中三唯道　　七业亦道故
  唯邪见断善　　所断欲生得
  拨因果一切　　渐断二俱舍
  人三洲男女　　见行断非得
  续善疑有见　　顿现除逆者
  业道思俱转　　不善一至八
  善总开至十　　别遮一八五
  不善地狱中　　粗杂嗔通二
  贪邪见成就　　北洲成后三
  杂语通现成　　余欲十通二
  善于一切处　　后三通现成
  无色无想天　　前七唯成就
  余处通成现　　除地狱北洲
  皆能招异熟　　等流增上果
  此令他受苦　　断命坏威故
  贪生身语业　　邪命难除故
  执命资贪生　　违经故非理
  断道有漏业　　具足有五果
  无漏业有四　　谓唯除异熟
  余有漏善恶　　亦四除离系
  余无漏无记　　三除前所除
  善等于善等　　初有四二三
  中有二三四　　后二三三果
  过于三各四　　现于未亦尔
  现于现二果　　未于未果三
  同地有四果　　异地二或三
  学于三各三　　无学一三二
  非学非无学　　有二二五果
  见所断业等　　一一各于三
  初有三四一　　中二四三果
  后有一二四　　皆如次应知
  染业不应作　　有说亦坏轨
  应作业翻此　　俱相违第三
  一业引一生　　多业能圆满
  二无心定得　　不能引余通
  三障无间业　　及数行烦恼
  并一切恶趣　　北洲无想天
  三洲有无间　　非余扇搋等
  少恩少羞耻　　余障通五趣
  此五无间中　　四身一语业
  三杀一诳语　　一杀生加行
  僧破不和合　　心不相应行
  无覆无记性　　所破僧所成
  能破者唯成　　此虚诳语罪
  无间一劫熟　　随罪增苦增
  苾刍见净行　　破异处愚夫
  忍异师道时　　名破不经宿
  赡部洲九等　　方破法轮僧
  唯破羯磨僧　　通三洲八等
  初后疱双前　　佛灭未结界
  于如是六位　　无破法轮僧
  弃坏恩德田　　转形亦成逆
  母谓因彼血　　误等无或有
  打心出佛血　　害后无学无
  造逆定加行　　无离染得果
  破僧虚诳语　　于罪中最大
  感第一有思　　世善中大果
  污母无学尼　　杀住定菩萨
  及有学圣者　　夺僧和合缘
  破坏窣堵波　　是无间同类
  将得忍不还　　无学业为障
  从修妙相业　　菩萨得定名
  生善趣贵家　　具男念坚固
  赡部男对佛　　佛思思所成
  余百劫方修　　各百福严饰
  于三无数劫　　各供养七万
  又如次供养　　五六七千佛
  三无数劫满　　逆次逢胜观
  然灯宝髻佛　　初释迦牟尼
  但由悲普施　　被析身无忿
  赞叹底沙佛　　次无上菩提
  六波罗蜜多　　于如是四位
  一二又一二　　如次修圆满
  施戒修三类　　各随其所应
  受福业事名　　差别如业道
  由此舍名施　　谓为供为益
  身语及能发　　此招大富果
  为益自他俱　　不为二行施
  由主财田异　　故施果差别
  主异由信等　　行敬重等施
  得尊重广爱　　应时难夺果
  财异由色等　　得妙色好名
  众爱柔软身　　有随时乐触
  田异由趣苦　　恩德有差别
  脱于脱菩萨　　第八施最胜
  父母病法师　　最后身菩萨
  设非证圣者　　施果亦无量
  后起田根本　　加行思意乐
  由此下上故　　业成下上品
  由审思圆满　　无恶作对治
  有伴异熟故　　此业名增长
  制多舍类福　　如慈等无受
  恶田有爱果　　种果无倒故
  离犯戒及遮　　名戒各有二
  非犯戒因坏　　依治灭净等
  等引善名修　　极能熏心故
  戒修胜如次　　感生天解脱
  感劫生天等　　为一梵福量
  法施谓如实　　无染辩经等
  顺福顺解脱　　顺决择分三
  感爱果涅槃　　圣道善如次
  诸如理所起　　三业并能发
  如次为书印　　算文数自体
  善无漏名妙　　染有罪覆劣
  善有为应习　　解脱名无上

    分别随眠品第五(六十九颂)

  随眠诸有本　　此差别有六
  谓贪嗔亦慢　　无明见及疑
  六由贪异七　　有贪上二界
  于内门转故　　为遮解脱想
  六由见异十　　异谓有身见
  边执见邪见　　见取戒禁取
  六行部界异　　故成九十八
  欲见苦等断　　十七七八四
  谓如次具离　　三二见见疑
  色无色除嗔　　余等如欲说
  忍所害随眠　　有顶唯见断
  余通见修断　　智所害唯修
  我我所断常　　拨无劣谓胜
  非因道妄谓　　是五见自体
  于大自在等　　非因妄执因
  从常我倒生　　故唯见苦断
  四颠倒自体　　谓从于三见
  唯倒推增故　　想心随见力
  慢七九从三　　皆通见修断
  圣如杀缠等　　有修断不行
  慢类等我慢　　恶作中不善
  圣有而不起　　见疑所增故
  见苦集所断　　诸见疑相应
  及不共无明　　遍行自界地
  于中除二见　　余九能上缘
  除得余随行　　亦是遍行摄
  见灭道所断　　邪见疑相应
  及不共无明　　六能缘无漏
  于中缘灭者　　唯缘自地灭
  缘道六九地　　由别治相因
  贪嗔慢二取　　并非无漏缘
  应离境非怨　　静净胜性故
  未断遍随眠　　于自地一切
  非遍于自部　　所缘故随增
  非无漏上缘　　无摄有违故
  随于相应法　　相应故随增
  上二界随眠　　及欲身边见
  彼俱痴无记　　此余皆不善
  不善根欲界　　贪嗔不善痴
  无记根有三　　无记爱痴慧
  非余二高故　　外方立四种
  中爱见慢痴　　三定皆痴故
  应一向分别　　反诘舍置记
  如死生殊胜　　我蕴一异等
  若于此事中　　未断贪嗔慢
  过现若已起　　未来意遍行
  五可生自世　　不生亦遍行
  余过未遍行　　现正缘能系
  三世有由说　　三有境果故
  说三世有故　　许说一切有
  此中有四种　　类相位待异
  第三约作用　　立世最为善
  何碍用云何　　无异世便坏
  有谁未生灭　　此法性甚深
  于见苦已断　　余遍行随眠
  及前品已断　　余缘此犹系
  见苦集修断　　若欲界所系
  自界三色一　　无漏识所行
  色自下各三　　上一净识境
  无色通三界　　各三净识缘
  见灭道所断　　皆增自识行
  无漏三界中　　后三净识境
  有随眠心二　　谓有染无染
  有染心通二　　无染局随增
  无明疑邪身　　边见戒见取
  贪慢嗔如次　　由前引后生
  由未断随眠　　及随应境现
  非理作意起　　说惑具因缘
  欲烦恼并缠　　除痴名欲漏
  有漏上二界　　唯烦恼除痴
  同无记内门　　定地故合一
  无明诸有本　　故别为一漏
  瀑流轭亦然　　别立见利故
  见不顺住故　　非于漏独立
  欲有轭并痴　　见分二名取
  无明不别立　　以非能取故
  微细二随增　　随逐与随缚
  住流漂合执　　是随眠等义
  由结等差别　　复说有五种
  结九物取等　　立见取二结
  由二唯不善　　及自在起故
  缠中唯嫉悭　　建立为二结
  惑二数行故　　为贱贫困故
  遍显随惑故　　恼乱二部故
  又五顺下分　　由二不超欲
  由三复还下　　摄门根故三
  或不欲发起　　迷道及疑道
  能障趣解脱　　故唯说断三
  顺上分亦五　　色无色二贪
  掉举慢无明　　令不超上故
  缚三由三受　　随眠前已说
  随烦恼此余　　染心所行蕴
  缠八无惭愧　　嫉悭并悔眠
  及掉举惛沈　　或十加忿覆
  无惭悭掉举　　皆从贪所生
  无愧眠惛沈　　从无明所起
  嫉忿从嗔起　　悔从疑覆诤
  烦恼垢六恼　　害恨谄诳憍
  诳憍从贪生　　害恨从嗔起
  恼从见取起　　谄从诸见生
  缠无惭愧眠　　惛掉见修断
  余及烦恼垢　　自在故唯修
  欲三二余恶　　上界皆无记
  谄诳欲初定　　三三界余欲
  见所断慢眠　　自在随烦恼
  皆唯意地起　　余通依六识
  欲界诸烦恼　　贪喜乐相应
  嗔忧苦痴遍　　邪见忧及喜
  疑忧余五喜　　一切舍相应
  上地皆随应　　遍自识诸受
  诸随烦恼中　　嫉悔忿及恼
  害恨忧俱起　　悭喜爱相应
  谄诳及眠覆　　通忧喜俱起
  憍喜乐皆舍　　余四遍相应
  盖五唯在欲　　食治用同故
  虽二立一盖　　障蕴故唯五
  遍知所缘故　　断彼能缘故
  断彼所缘故　　对治起故断
  对治有四种　　谓断持远厌
  应知从所缘　　可令诸惑断
  远性有四种　　谓相治处时
  如大种尸罗　　异方二世等
  诸惑无再断　　离系有重得
  谓治生得果　　练根六时中
  断遍知有九　　欲初二断一
  二各一合三　　上界三亦尔
  余五顺下分　　色一切断三
  于中忍果六　　余三是智果
  未至果一切　　根本五或八
  无色边果一　　三根本亦尔
  俗果二圣九　　法智三类二
  法智品果六　　类智品果五
  得无漏断得　　及缺第一有
  灭双因越界　　故立九遍知
  住见谛位无　　或成一至五
  修成六一二　　无学唯成一
  越界得果故　　二处集遍知
  舍一二五六　　得亦然除五

    分别贤圣品第六(八十三颂)

  已说烦恼断　　由见谛修故
  见道唯无漏　　修道通二种
  谛四名已说　　谓苦集灭道
  彼自体亦然　　次第随现观
  苦由三苦合　　如所应一切
  可意非可意　　余有漏行法
  彼觉破便无　　慧析余亦尔
  如瓶水世俗　　异此名胜义
  将趣见谛道　　应住戒勤修
  闻思修所成　　谓名俱义境
  具身心远离　　无不足大欲
  谓已得未得　　多求名所无
  治相违界三　　无漏无贪性
  四圣种亦尔　　前三唯喜足
  三生具后业　　为治四爱生
  我所我事欲　　暂息永除故
  入修要二门　　不净观息念
  贪寻增上者　　如次第应修
  为通治四贪　　且辩观骨琐
  广至海复略　　名初习业位
  除足至头半　　名为已熟修
  系心在眉间　　名超作意位
  无贪性十智　　缘欲色人生
  不净自世缘　　有漏通二得
  息念慧五地　　缘风依欲身
  二得实外无　　有六谓数等
  入出息随身　　依二差别转
  情数非执受　　等流非下缘
  依已修成止　　为观修念住
  以自相共相　　观身受心法
  自性闻等慧　　余相杂所缘
  说次第随生　　治倒故唯四
  彼居法念住　　总观四所缘
  修非常及苦　　空非我行相
  从此生暖法　　具观四圣谛
  修十六行相　　次生顶亦然
  如是二善根　　皆初法后四
  次忍唯法念　　下中品同顶
  上唯观欲苦　　一行一刹那
  世第一亦然　　皆慧五除得
  此顺决择分　　四皆修所成
  六地二或七　　依欲界身九
  三女男得二　　第四女亦尔
  圣由失地舍　　异生由命终
  初二亦退舍　　依本必见谛
  舍已得非先　　二舍性非得
  暖必至涅槃　　顶终不断善
  忍不堕恶趣　　第一入离生
  转声闻种性　　二成佛三余
  麟角佛无转　　一坐成觉故
  前顺解脱分　　速三生解脱
  闻思成三业　　殖在人三洲
  世第一无间　　即缘欲界苦
  生无漏法忍　　忍次生法智
  次缘余界苦　　生类忍类智
  缘集灭道谛　　各生四亦然
  如是十六心　　名圣谛现观
  此总有三种　　谓见缘事别
  皆与世第一　　同依于一地
  忍智如次第　　无间解脱道
  前十五见道　　见未曾见故
  名随信法行　　由根钝利别
  具修惑断一　　至五向初果
  断次三向二　　离八地向三
  至第十六心　　随三向住果
  名信解见至　　亦由钝利别
  诸得果位中　　未得胜果道
  故未起胜道　　名住果非向
  地地失德九　　下中上各三
  未断修断失　　住果极七返
  断欲三四品　　三二生家家
  断至五二向　　断六一来果
  断七或八品　　一生名一间
  此即第三向　　断九不还果
  此中生有行　　无行般涅槃
  上流若杂修　　能往色究竟
  超半超遍殁　　余能往有顶
  行无色有四　　住此般涅槃
  行色界有九　　谓三各分三
  业惑根有殊　　故成三九别
  立七善士趣　　由上流无别
  善恶行不行　　有往无还故
  经欲界生圣　　不往余界生
  此及往上生　　无练根并退
  先杂修第四　　成由一念杂
  为受生现乐　　及遮烦恼退
  由杂修五品　　生有五净居
  得灭定不还　　转名为身证
  上界修惑中　　断初定一品
  至有顶八品　　皆阿罗汉向
  第九无间道　　名金刚喻定
  尽得俱尽智　　成无学应果
  有顶由无漏　　余由二离染
  圣二离八修　　各二离系得
  无漏未至道　　能离一切地
  余八离自上　　有漏离次下
  近分离下染　　初三后解脱
  根本或近分　　上地唯根本
  世无间解脱　　如次缘下上
  作粗苦障行　　及静妙离三
  不动尽智后　　必起无生智
  余尽或正见　　此应果皆有
  净道沙门性　　有为无为果
  此有八十九　　解脱道及灭
  五因立四果　　舍曾得胜道
  集断得八智　　顿修十六行
  世道所得断　　圣所得杂故
  无漏得持故　　亦名沙门果
  所说沙门性　　亦名婆罗门
  亦名为梵轮　　真梵所转故
  于中唯见道　　说名为法轮
  由速等似轮　　或具辐等故
  三依欲后三　　由上无见道
  无间无缘下　　无厌及经故
  阿罗汉有六　　谓退至不动
  前五信解生　　总名时解脱
  后不时解脱　　从前见至生
  有是先种性　　有后练根得
  四从种性退　　五从果非先
  学异生亦六　　练根非见道
  应知退有三　　已未得受用
  佛唯有最后　　利中后钝三
  一切从果退　　必得不命终
  住果所不为　　惭增故不作
  练根无学位　　九无间解脱
  久习故学一　　无漏依人三
  无学依九地　　有学但依六
  舍果胜果道　　唯得果道故
  七声闻二佛　　差别由九根
  加行根灭定　　解脱故成七
  此事别唯六　　三道各二故
  俱由得灭定　　余名慧解脱
  有学名为满　　由根果定三
  无学得满名　　但由根定二
  应知一切道　　略说唯有四
  谓加行无间　　解脱胜进道
  通行有四种　　乐依本静虑
  苦依所余地　　迟速钝利根
  觉分三十七　　谓四念住等
  觉谓尽无生　　顺此故名分
  此实事唯十　　谓慧勤定信
  念喜舍轻安　　及戒寻为体
  四念住正断　　神足随增上
  说为慧勤定　　实诸加行善
  初业顺决择　　及修见道位
  念住等七品　　应知次第增
  七觉八道支　　一向是无漏
  三四五根力　　皆通于二种
  初静虑一切　　未至除喜根
  二静虑除寻　　三四中除二
  前三无色地　　除戒前二种
  于欲界有顶　　除觉及道支
  证净有四种　　谓佛法僧戒
  见三得法戒　　见道兼佛僧
  法谓三谛全　　菩萨独觉道
  信戒二为体　　四皆唯无漏
  学有余缚故　　无正脱智支
  解脱为无学　　谓胜解或灭
  有为无学支　　即二解脱蕴
  正智如觉说　　谓尽无生智
  无学心生时　　正从障解脱
  道唯正灭位　　能令彼障断
  无为说三界　　离界谓离贪
  断界断余结　　灭界灭彼事
  厌缘苦集慧　　离缘四能断
  相对互广狭　　故应成四句

    分别智品第七(六十一颂)

  圣慧忍非智　　尽无生非见
  余二有漏慧　　皆智六见性
  智十总有二　　有漏无漏别
  有漏称世俗　　无漏名法类
  世俗遍为境　　法智及类智
  如次欲上界　　苦等谛为境
  法类由境别　　立苦等四名
  皆通尽无生　　初唯苦集类
  法类道世俗　　有成他心智
  于胜地根位　　去来世不知
  法类不相知　　声闻麟喻佛
  如次知见道　　二三念一切
  智于四圣谛　　知我已知等
  不应更知等　　如次尽无生
  由自性对治　　行相行相境
  加行办因圆　　故建立十智
  缘灭道法智　　于修道位中
  兼治上修断　　类无能治欲
  法智及类智　　行相俱十六
  世俗此及余　　四谛智各四
  他心智无漏　　唯四谓缘道
  有漏自相缘　　俱但缘一事
  尽无生十四　　谓离空非我
  净无越十六　　余说有论故
  行相实十六　　此体唯是慧
  能行有所缘　　所行诸有法
  性俗三九善　　依地俗一切
  他心智唯四　　法六余七九
  现起所依身　　他心依欲色
  法智但依欲　　余八通三界
  诸智念住摄　　灭智唯最后
  他心智后三　　余八智通四
  诸智互相缘　　法类道各九
  苦集智各二　　四皆十灭非
  所缘总有十　　谓三界无漏
  无为各有二　　俗缘十法五
  类七苦集六　　灭缘一道二
  他心智缘三　　尽无生各九
  俗智除自品　　总缘一切法
  为非我行相　　唯闻思所成
  异生圣见道　　初念定成一
  二定成三智　　后四一一增
  修道定成七　　离欲增他心
  无学钝利根　　定成九成十
  见道忍智起　　即彼未来修
  三类智兼修　　现观边俗智
  不生自下地　　苦集四灭后
  自谛行相境　　唯加行所得
  修道初刹那　　修六或七智
  断八地无间　　及有欲余道
  有顶八解脱　　各修于七智
  上无间余道　　如次修六八
  无学初刹那　　修九或修十
  钝利根别故　　胜进道亦然
  练根无间道　　学六无学七
  余学六七八　　应八九一切
  杂修通无间　　学七应八九
  余道学修八　　应九或一切
  圣起余功德　　及异生诸位
  所修智多少　　皆如理应思
  诸道依得此　　修此地有漏
  为离得起此　　修此下无漏
  唯初尽遍修　　九地有漏德
  生上不修下　　曾所得非修
  立得修习修　　依善有为法
  依诸有漏法　　立治修遣修
  十八不共法　　谓佛十力等
  力处非处十　　业八除灭道
  定根解界九　　遍趣九或十
  宿住死生俗　　尽六或十智
  宿住死生智　　依静虑余通
  赡部男佛身　　于境无碍故
  身那罗延力　　或节节皆然
  象等七十增　　此触处为性
  四无畏如次　　初十二七力
  三念住念慧　　缘顺违俱境
  大悲唯俗智　　资粮行相境
  平等上品故　　异悲由八因
  由资粮法身　　利他佛相似
  寿种姓量等　　诸佛有差别
  复有余佛法　　共余圣异生
  谓无诤愿智　　无碍解等德
  无诤世俗智　　后静虑不动
  三洲缘未生　　欲界有事惑
  愿智能遍缘　　余如无诤说
  无碍解有四　　谓法义词辩
  名义言说道　　无退智为性
  法词唯俗智　　五二地为依
  义十六辩九　　皆依一切地
  但得必具四　　余如无诤说
  六依边际得　　边际六后定
  遍顺至究竟　　佛余加行得
  通六谓神境　　天眼耳他心
  宿住漏尽通　　解脱道慧摄
  四俗他心五　　漏尽通如力
  五依四静虑　　自下地为境
  声闻麟喻佛　　二三千无数
  未曾由加行　　曾修离染得
  念住初三身　　他心三余四
  天眼耳无记　　余四通唯善
  第五二六明　　治三际愚故
  后真二假说　　学有暗非明
  第一四六导　　教诫导为尊
  定由通所成　　引利乐果故
  神体谓等持　　境二谓行化
  行三意势佛　　运身胜解通
  化二谓欲色　　四二外处性
  此各有二种　　谓似自他身
  能化心十四　　定果二至五
  如所依定得　　从净自生二
  化事由自地　　语通由自下
  化身与化主　　语必俱非佛
  先立愿留身　　后起余心语
  有死留坚体　　余说无留义
  初多心一化　　成满此相违
  修得无记摄　　余得通三性
  天眼耳谓根　　即定地净色
  恒同分无缺　　取障细远等
  神境五修生　　咒药业成故
  他心修生咒　　又加占相成
  三修生业成　　除修皆三性
  人唯无生得　　地狱初能知

    分别定品第八(三十九颂)

  静虑四各二　　于中生已说
  定谓善一境　　并伴五蕴性
  初具伺喜乐　　后渐离前支
  无色亦如是　　四蕴离下地
  并上三近分　　总名除色想
  无色谓无色　　后色起从心
  空无边等三　　名从加行立
  非想非非想　　昧劣故立名
  此本等至八　　前七各有三
  谓味净无漏　　后味净二种
  味谓爱相应　　净谓世间善
  此即所味着　　无漏谓出世
  静虑初五支　　寻伺喜乐定
  第二有四支　　内净喜乐定
  第三具五支　　舍念慧乐定
  第四有四支　　舍念中受定
  此实事十一　　初二乐轻安
  内净即信根　　喜即是喜受
  染如次从初　　无喜乐内净
  正念慧舍念　　余说无安舍
  第四名不动　　离八灾患故
  八者谓寻伺　　四受入出息
  生静虑从初　　有喜乐舍受
  及喜舍乐舍　　唯舍受如次
  生上三静虑　　起三识表心
  皆初静虑摄　　唯无覆无记
  全不成而得　　净由离染生
  无漏由离染　　染由生及退
  无漏次生善　　上下至第三
  净次生亦然　　兼生自地染
  染生自净染　　并下一地净
  死净生一切　　染生自下染
  净定有四种　　谓即顺退分
  顺住顺胜进　　顺决择分摄
  如次顺烦恼　　自上地无漏
  互相望如次　　生二三三一
  二类定顺逆　　均间次及超
  至间超为成　　三洲利无学
  二类定顺逆　　非上无用故
  唯生有顶圣　　起下尽余惑
  味定缘自系　　净无漏遍缘
  根本善无色　　不缘下有漏
  无漏能断惑　　及诸净近分
  近分八舍净　　初亦圣或三
  中静虑无寻　　具三唯舍受
  初下有寻伺　　中唯伺上无
  空谓空非我　　无相谓灭四
  无愿谓余十　　谛行相相应
  此通净无漏　　无漏三脱门
  重二缘无学　　取空非常相
  后缘无相定　　非择灭为静
  有漏人不时　　离上七近分
  为得现法乐　　修诸善静虑
  为得胜知见　　修净天眼通
  为得分别慧　　修诸加行善
  为得诸漏尽　　修金刚喻定
  无量有四种　　对治嗔等故
  慈悲无嗔性　　喜喜舍无贪
  此行相如次　　与乐及拔苦
  欣慰有情等　　缘欲界有情
  喜初二静虑　　余六或五十
  不能断诸惑　　人起定成三
  解脱有八种　　前三无贪性
  二二一一定　　四无色定善
  灭受想解脱　　微微无间生
  由自地净心　　及下无漏出
  三境欲可见　　四境类品道
  自上苦集灭　　非择灭虚空
  胜处有八种　　二如初解脱
  次二如第二　　后四如第三
  遍处有十种　　八如净解脱
  后二净无色　　缘自地四蕴
  灭定如先辩　　余皆通二得
  无色依三界　　余唯人趣起
  二界由因业　　能起无色定
  色界起静虑　　亦由法尔力
  佛正法有二　　谓教证为体
  有持说行者　　此便住世间
  迦湿弥罗议理成　　我多依彼释对法
  少有贬量为我失　　判法正理在牟尼
  大师法眼久已闭　　堪为证者多散灭
  不见真理无制人　　由鄙寻思乱圣教
  自觉已归胜寂静　　持彼教者多随灭
  世无依怙丧众德　　无钩制惑随意转
  既知如来正法寿　　渐次沦亡如至喉
  是诸烦恼力增时　　应求解脱勿放逸

说一切有部俱舍论本颂一卷


阿毗达磨俱舍释论

    No. 1559 [No. 1558; cf. Nos. 1560, 1561]

    阿毗达磨俱舍释论序

正教本宗。文唯三藏。梵音所阐。谅无异说。法相深微。名实繁旷。若非圆明独朗。孰能通达。自日隐頞多之山。月翳罗睺之手。时移解昧。部执竞兴。或以文释义。或以义判文。虽复得失参差。皆以三藏为本。可谓殊涂同归一致百虑者也。寻十八部。师及弟子。并各造论。解其所执。于一部中多有诸论。此土先译萨婆多部。止有毗婆沙及杂心四卷。毗婆沙明义虽广。而文句来不具足。杂心说乃处中。止述自部宗致四卷。过存省略。旨趣难可寻求。此土先译经部正。有成实一论。成实乃以经部驳斥余师。其间所用。或同余部。又于破立之中。亦未皆尽其妙。且传译参差。难可具述。佛灭度后千一百余年。有出家菩萨。名婆薮盘豆。器度宏旷。神才壮逸。学穷文字。思彻渊源。德隆终古。名盖当世。造大小乘论。凡数十部。并盛宣行。靡不宗学。法师德业。具如别传。先于萨婆多部出家。仍学彼部所立三藏。后见彼法多有乖违。故造此论。具述彼执。随其谬处。以经部破之。故此论本宗是萨婆多部。其中取舍。以经部为正。博综群籍。妙拔众师。谈玄微穷于奥极。述事象略而周遍。显成圣旨。备摧异说。立不可窥。破无能拟。义兼数论。而深广愈之。词不繁而义显。义虽深而易入。故天竺咸称为聪明论。于大小乘学。悉依此为本。有三藏法师俱罗那他。聪敏强记。才辩无竭。硕学多闻。该通内外。为弘法故。远游此国。值梁室将倾。时事纷梗。法师避地东西。垂二十载。欲还天竺。来至番禺。慧恺因请翻讲摄大乘等论经。涉二年。文义方毕。法师尔后犹欲旋归。刺史欧阳纥尚仁贵道。久申敬事。重复请留。弥加殊礼。慧恺与僧忍等。更请翻讲此论。以陈天嘉四年岁次阏逢龙集涒滩正月二十五日。于制旨寺。始就开阐。惑品未毕。仍事徙居于南海郡内。续更敷说。法师游方既久。精解此土音义。凡所翻译。不须度语。但梵音所目。于义易彰。今既改变梵音。词理难卒符会。故于一句之中。循环辩释。翻覆郑重。乃得相应。慧恺谨即领受。随定随书。日夜相系。无懈晷刻。至其年闰十月十日。文义究竟。论文二十二卷。论偈一卷。义疏五十三卷。刺史仍请于城内讲说。既得温故。颇识大宗。非唯闇弱。多有疑滞。又恐所翻不免谬失。至天嘉五年岁次柔兆二月二日。与僧忍等。更请法师。重译论文。再解义意。至光大元年岁次强圉十二月二十五日。治定前本始末究竟。长史袁敬。识鉴沉深。信解明正。长史长子元友。爱文重法。博学多艺。并礼事法师。备尽经始经。南中翻译。悉赖此贵门。方希永传来世。以为后生模式。佛法大海。深广无际。若不局一涂。能信顺求学。岂不同餐甘露。共嗅詹匐者哉。如或专执。非所喻也

阿毗达磨俱舍释论卷第一

        婆薮盘豆造

        陈天竺三藏真谛译

    释论中分别界品第一

  一切种智灭诸冥　　拔出众生生死泥
  顶礼大师如理教　　对法俱舍我当说

释曰。若人欲正造论。当令他知大师不共功德。故说众德为先。后顶礼大师。此偈但依佛世尊说。偈曰。一切种智灭诸暝。释曰。灭一切暝。由一切种智。于一切法无明者。能障见真实义。故称为暝。此无明于佛世尊。由得究竟通对治故。一切种于一切法。永不生为法故。故称为灭。独觉及声闻。于一切法虽除无明。由有染污无明极不生故。不由一切种。何以故。诸余圣人。于如来不共法。及于余境。最久远时处无边差别。有无染污无明。显自利行究竟。赞叹佛已。次以利他行圆满。赞叹世尊。偈曰。拔出众生生死泥。释曰。生死是世间沉着处故。难可度故。故以譬泥。众生于中沉着无救接者。唯佛世尊欲怜愍度脱。授说正法手应理拔济。是人与自他利益行相应。偈曰。顶礼大师如理教。释曰。头面接足名顶礼。立教不虚称大师。无倒称如理。得善离恶言称教。说此如理教为利他方便。由如理教。从生死泥拔济众生。不由通慧施恩威德等。顶礼如理教师已。欲何所作。偈曰。对法俱舍我当说。释曰。此法通名灭济教。别名云何。阿毗达磨俱舍。何法名阿毗达磨。偈曰。净智助伴名对法。释曰。智谓。择法。净谓无垢。即无流智助伴。谓因缘资粮。若尔则说无流五阴。名阿毗达磨。此即真实阿毗达磨。若说假名阿毗达磨。偈曰。能得此法诸智论。释曰。即是有流思慧闻慧生得慧及助伴论。谓能传生无流智。是无流智资粮故。亦名阿毗达磨。因何义立此名。能持自体相故称达磨。或一切法中真实法涅槃为相。故称达磨。此智对诸法。于法现前故。称阿毗达磨。此论云何名阿毗达磨俱舍。偈曰。由义对法入此摄。释曰。彼文句名阿毗达磨。由随胜义入此论摄。是故此论于彼得称为藏。复次偈曰。论依对法名俱舍。释曰。阿毗达磨是此论依止。何以故。从彼法中引生此论故。彼于此论亦受藏名。以是义故此论名为阿毗达磨俱舍。复次此法其用云何。何人先说此法。而法师恭敬欲解说之。偈曰。离简择法更不有。为寂静惑别方便。世间由惑转有海。为此传佛说对法。释曰。若离择法觉分。无别方便能除灭诸惑。诸惑能轮转世间于生死海。由此正因。欲令弟子得简择法。故大师佛世尊先说阿毗达磨。若离此正诸说。弟子不能如理简择真法故。佛世尊处处散说此法。大德迦旃延子等诸弟子。撰集安置。犹如大德达磨多罗多撰集优陀那伽他部类。闻毗婆沙师传说如此。何者诸法是所简择。为令他简择彼法。佛世尊说阿毗达磨。偈曰。有流无流法。释曰。略说一切法。谓有流无流。此中何者有流。偈曰。有为除圣道。有流释曰。除道圣谛。所余有为法说。名有流。何以故。偈曰。于中流。由随增眠故。释曰。若有如此义。诸流缘灭道二谛为境起。于中不眠。无随增故。是故于中不可立有流为反质难。是不眠义。后分别惑品中当广说。说有流法已。何者无流法。偈曰。无流法圣道及三种无为。释曰。何者三无为。偈曰。虚空及二灭。释曰何者二灭。择灭非择灭。如此空等三无为及圣道。说为无流法。何以故。于中诸流不能眠故略说。三无为中何者为空。偈曰。此中空无碍。释曰。空以无障无碍为性故色于中行。偈曰。择灭谓永离。释曰。与有流法永相离说名择灭。各数简择苦等圣谛名择。即智胜因。此所得己利名为择灭。具足应言择所得灭。以略说故但称择灭。如车与牛相应名为牛车。一切有流为一择灭为不一。不一云何偈曰。各各对诸结。释曰。如结数量。择灭亦尔。若不尔。由证见苦所断惑择灭。则应一时俱证一切惑择灭。若尔修余对治道则空无果。佛经言择灭无同类。此言何义。择灭无同类因。亦非他同类。因此是经义。非无与其同类。说择灭已。偈曰。恒遮欲生生。别有非择灭释曰。能永遮未来诸法生。异于择灭有别灭。说名非择灭。不由简择得故。云何得。因缘不具故。譬如有人意识及眼根缘一色尘起。是时余色声香味触等。悉有即谢。五识聚不能缘彼为境界更生。何以故。五识无有功能缘过去尘为。境是故识等有非择灭。由因缘不具故。得依二灭立四句。有诸法唯有择灭。谓过去现在定生为法。皆是有流有诸法唯有非择灭。谓不生为法无流有为。有诸法具有二灭。谓有流定不生为法。有诸法无有二灭。谓过去现在定生为法。皆是无流。说三无为已。前说有为法除圣道名有流。何者是有为。偈曰。又诸有为法。谓色等。五阴。释曰。色阴受阴想阴行阴识阴。此五阴摄一切有为。已至聚集因缘所作。故名有为。何以故。无有法无缘及一缘。所生故。是彼种类故。于未来无妨。譬如独陀。偈曰。说世路言依。有离及有类。释曰。是诸有为法。有已正当行故名世路。复次无常所食故。言谓方言。是言所应义名言依。由执有义言故。佛经说有为法名言依。若不尔。则违分别道理二论。彼论云。言依入十八界摄。永出名离。所谓涅槃。一切有为。涅槃永出离故。有为法有离涅槃无离故。有为法名有离。有因故名有类。类以因义。毗婆沙师作此说。如是等是有为别名。复次是有为法。偈曰。有流名取阴。释曰。此何所显。是有取可说名阴有。但阴非取。谓无流有为。此中以惑为取。阴从取生故名取阴。譬如草木糠火。复次随逐取故。譬如王人。复次诸取从彼生故名取阴。譬如花树果树。是有流诸法。偈曰。或说有斗争。释曰。诸惑名斗争。能动诸善法。及损害自他。故斗争所随眠故。故说有斗争。譬如有流。复次偈曰。苦集谛世间。释曰。违圣人意故名苦。苦从诸见生故名集。破坏故名世间。有对治故。偈曰。见处及三有。释曰。诸见依中住。由随顺增长故。故是见处。但有令有故名有。如此说有流法。如义别名已前已说。色等五阴。此中偈曰。色阴谓五根。五尘及无教。释曰。五根谓眼耳鼻舌身。五尘是眼等五根境。谓色声香味触及无教。如此量名色阴。此中是前说色等五尘。偈曰。此识依净色。说名眼等根。释曰。色声香味触识所依止五种净色类。次第应知。是眼耳鼻舌身根。如佛世尊言。比丘眼是内入。合四大成。是净色性类。如此广说。复次前已说眼等五根。此识依净色说名眼等根。眼根等识依止。其义如此。若立此义。则顺分别道理论。彼论云。何者为眼根。谓眼识依止清净色。说五根已。次应说五尘。此中偈曰。色二。释曰。一显色。二形色。显色有四种。谓青黄赤白。余色是此四色未异。形色有八种。谓长等耶。对是重说色入。偈曰。或二十。释曰。谓青黄赤白长短方圆高下正邪云烟尘雾影光明闇。有余师说。空为一色故。有二十一色。此中形平等为正。不平等名邪。地气名雾。日焰名光。月星火药宝珠电焰名明。于中若色显现名影。翻此名闇。余色易解故今不释。有色入有显无形。谓青黄赤白影光明闇。有色入有形无显。谓有长等一分。即有教身业为相。有色入有显有形。谓所余诸色。有余师说。有色入无形无显。谓无教色。有余师说。唯光及明有显无形。何以故。恒见青等诸色有长等差别。云何一物二知所缘。此二色于一尘中现故。是义不然。于有教身业。则成反质难故。说色入已。偈曰。声尘有八种。释曰。有执依非执依四大为因。有众生名非众生名。是名四声。此声由可爱非可爱差别。故成八种。此中有执依为因者。谓言手等声。非执依为因者。谓风树浪等声。有众生名者。谓有义言声。异此为非众生名。有余师说。有别声有执依非执依四大为因。谓手鼓合生。譬如一显色邻虚不许依二四大生。此声亦应尔。说声已。偈曰。味六。释曰。谓甜酢碱辛苦淡差别故。偈曰。香有四。释曰。谓香臭平等不平等差别故。阿毗达磨中说香有三种。谓香臭平等。偈曰。触尘十一种。释曰。触有十一种应知。谓四大滑涩重轻冷饥渴。此中四大后当说。柔软名滑。粗燥为涩。可称名重。翻此为轻。热爱为冷。食爱为饥。饮爱为渴。于因立果名故说如此。如佛伽陀中说

  诸佛生现乐　　说正法亦乐
  大众和合乐　　聚集出家乐

于色界中无饥渴触。有所余诸触。于中彼衣若不可各称。四大聚集所造故。亦可得称。于彼无能损冷触。有能益冷触。他说如此。前已说色有多种。此中有时由一物眼识得生。若是时中分别一类。有时由多物眼识得生若是时中无。所分别。譬如军众。有无量显形色。及远见众宝应知。耳等识亦尔。身识若极多。由五触生。谓四大触。诸触中滑等随一。有师作如此执。复有余师说。具足十一触生身识。若尔则总缘尘。通境为尘。五识应成不但缘别境。五识对入别相为境故。许彼以别相为境。非对物别相。斯有何失。应思此义。身舌二根。一时尘至。何识先生。随强尘先发识。若平等尘至。舌识先生。食欲所引相续故。如此说五根五尘及如取尘已。今当说无教色。偈曰。乱心无心耶。随流净不净。依止于四大。何无教色说。释曰。异缘名乱心。入无想定及灭心定名无心。显非乱心及有心故言耶。是似相续或俱或后故名随流善名净。恶名不净。至得相续亦尔。为简此异彼故。说依止于四大。毗婆沙师说。依止以因为义四大为无教。生等五因故。欲显立名因故言何。此法虽以有色业为性。不如有教色可令他知。故名无教。显是余师说故言说。若略说。有教色。三摩提所生善恶性色名无教。前说依止四大。何者四大。偈曰。诸大谓地界。及水火风界。释曰。如此四大。能持自相及所造色故名界。云何四界名大。一切余色依止故。于彼成粗故。故名为大。复次极遍满起。地水火风聚中形量大故。复次能增广一切有色物生。及于世间能作大事故名大。复次此地等界。于何业中成。何为自性。偈曰。于持等业成。释曰。胜持和摄成熟引长。于四业中。次第成就。地水火风界。转移增益。故名引长是名四大业自性者次第。偈曰。坚湿热动性。释曰。地界以坚为性。水界以湿为性。火界以热为性。风界以动为性。引诸大相续令生异处。如吹灯光名动。分别道理论云。何者风界。所谓轻触。经说亦尔。或说轻触为所造色。此法以动为定性故。说动为风界。即以业显风自性。复次地等及地界等。异义云何。偈曰。说地显形色。由世立名想。水火亦复然。释曰。若世人示现他地大。但示显形色。如示现地大。示现水火大亦尔。但示显形色故依世假名想。说色入为地等三大。偈曰。唯风界。释曰。是风界世人说为风。偈曰。亦尔。释曰。如世人假说显形色为地。说风亦尔。或说黑风。或说团风。云何说无教为后此阴名色。显现变坏故。佛世尊说。比丘由此法变坏。变坏故说色取阴。何法能变坏。由手等触故变坏。广说如经。有对碍故可变坏。复次义部经中说

  求得欲尘人　　爱渴所染着
  若所求不遂　　喜彼如被刺

复次余师说。此色欲界变坏生。对碍故名色。若尔邻。虚色应不成色。不可变坏故。此言非难。邻虚色无独住。不和合故。若和合住则可变坏。若尔过去未来色不应成色。此亦已变坏应变坏。变坏性类故。如所烧薪。若尔无教不应成色。此亦由有教变坏故。其同变坏。如树动影动。是义不然。无教无变坏故。若尔有教谢灭。无教亦应谢灭。如树灭影灭。复有余师说。依止变坏故。无教亦变坏。是义不然。若尔眼识等。由依止变坏。亦应成色。是故汝执不平。虽然有异。何以故。无教依四大生。如影依树生。光依宝生。眼等识不尔。依眼等根生。诸根一向唯为眼等识作生因。此执非毗婆沙义。谓依树影生。依宝光生。彼师说。影等显色邻虚。各各依止自四大故。若实如此。影光依树宝生。无教不应同此依止。何以故。无教所依止。四大已谢。彼师不许无教随灭。是故此执不成救义。复有余师别立救义言。眼等诸识依止。各有差别。有依止变坏如眼等。有依止不变坏如意识等。无教依止既不尔。此难则不平。是故此义应然。由可变坏故名色阴。是法前已说。色阴为性。偈曰。此根尘复说。十入及十界。释曰。若安立入门属十八。谓眼入色入。乃至身入触入。若安立界门属十界。谓眼界色界。乃至身界触界。说色阴及安立入界已。次当说受等诸阴。此中偈曰。受阴领随触。释曰。有三种领随触。说名受阴。何者为三。谓能领随乐苦不乐不苦触。是名三受。复次若分别此受。则成六受聚。谓眼触所生受。乃至意触所生受。偈曰。想阴别执相。释曰。青黄长短男女亲怨乐苦等相差别执。是名想阴。复次若分别此想。有六如受。偈曰。异四名行阴。释曰。除色受想识四阴。余有为法名行阴。经中佛世尊说。六故意聚名行取阴。此说由胜故。此故意聚。是业性故。于造作中最胜故。佛世尊说。能作功用起有为法故。说此为有行取阴。若不尔。所余心法及不相应法非阴摄。则不可立为苦谛集谛。于彼亦不可立为应知应离。佛世尊说。我不说未见未通一法决定至苦后际。未除未灭亦尔。是故诸有为法入行阴摄。应信此义。偈曰。是受等三阴。释曰。谓受想行三阴。若安立为入及界。偈曰。或名法入界。并无教无为。释曰。此七种法。说名法入及法界。偈曰。识阴对对视。释曰。对对诸尘意识心是名识阴。复次若分别此识则成六识聚。谓眼识乃至意识。是所说识阴。若安立入。偈曰。或说为意入。释曰。若安立界。偈曰。或说为七界。释曰。何者为七。偈曰。谓六识意根。释曰。眼识界乃至意识界及意界。此中五阴。已说为十二入及十八界。除无教色。是色阴立为十入十界。受想行阴无教无为。立为法入法界。是识阴即是意入及六识界并意界。为不如此耶。前说唯六识为识阴。若尔异此六识。何法名意界。无别意界异六识。虽然是诸识中。偈曰。六中无间谢。说识名意根。释曰。六识中随一无间灭。此识说名意界。譬如一人先为子后为父。又如先为果后成种子。识亦如是。先为六识后成意界。若尔实物唯十七界或十二界。何以故。六识界及意界互相摄故。若尔云何安立为十八界。虽然偈曰。为成第六依。故界成十八。释曰。是五种识界。以眼等五界为依。第六意识界无有别依。为成立此依故说意界。由如此安立依能依境界三六故。界成十八。若尔阿罗汉最后心。应非意界。无识在后生。为此无间灭故成意界。是义不然。何以故。此已住意性中故。因缘不具故。后识不生。此中由阴摄一切有为。由取阴摄一切有流。由入由界摄一切法尽。应知一切诸法复有略摄。偈曰。略摄一切法。由一阴入界。释曰。阴中以色阴。入中以意入。界中以法界。应知摄一切法尽。如来处处说摄。其义应知如此。偈曰。同自性类故。释曰。此摄由同性类相应故。不由异性故。何以故。偈曰。离余法性类。释曰。诸法与他性相离。则此性与彼不相应。是故不由此性得摄他。譬如眼根。由色阴由眼入眼界。苦集二谛等摄。以同性故。不由余阴等。彼性不相应故。若尔有处说。由他摄他。譬如由四摄类摄一切众生。此摄不恒。应知是假名。何故不成二十一界。何以故。眼耳鼻各有二故。不应尔。何以故。偈曰。类境识同故。虽二成一界。释曰。此中同类者。此二同眼性类故。同境者。此二同缘色故。同识者。此二共为一眼识依止故。是故眼根虽二共成一界。于耳鼻应知亦尔。偈曰。若尔云何二。为庄严生二。释曰。若实如此。眼等一界云何生二。为庄严依止故。若不尔。一眼耳一依处生。一鼻一孔生。此身则大丑陋。是义不然。若本来如此。及猫狸鸲鹆等。生二眼耳鼻有何庄严。若尔生二何为。为助成识故。如人闭一眼开一眼。或开一眼半闭一眼。见色皆不明了。为庄严识令成就故。三根各须二处。说阴入界已。应说此义。阴入界其义云何。偈曰。聚来门性义。阴入界三名。释曰。随所有色。若过去未来现在。若内若外。若粗若细。若鄙若美。若远若近。此一切色摄聚一处。说名色阴。由此经言。阴以聚义。此义得成。此中过去色者。由无常已灭。未来未生。现在已生未灭。于自相续为内。异此名外。或由入判内外。有碍为粗。无碍为细。或由相待判粗细。若汝言。或由相待则粗细不成。是义不然。由待异故。若此待彼成粗。无方便待彼成细。譬如父子。有染污为鄙。无染污为美。过去未来为远。现在为近。乃至识阴亦尔。复有差别。五根依止为粗。心依止为细。毗婆沙师依地判粗细。有大德说。五根所缘为粗。异此名细。非可爱名鄙。可爱名美。不可见处为远。可见处为近。过去等自名所显。不须别释。应知受等亦尔。由随依止故有远近。粗细义如前。入者心及心法来门义。或说来增义。能增长心及心法来。界者别义。如一山处多有铁铜金银等差别。故说名界。如此于一依止中。或相续中。有十八种差别。说名十八界。此中别以本义。本谓同类因。此十八法。同类相续。为同类因。故说名别。若尔无为则非界。是义不然。此是心及心法。同类因故。复有余师说。界以种类义。诸法种类有十八。谓自性故说名界。若阴以聚义阴应是假名。有多物聚集故。譬如聚及人。是义不然。一物邻虚得阴名故。若尔不应说阴以聚义。何以故。一物无聚义故。复有余师说。能荷负事是阴义。复有师说。分分是阴义。何以故。如有诸说。我应转三阴物。此执与经不相应。何以故。经但说聚是阴义如经言。随所有色。若过去未来现在等。广说如经。若汝言随一过去等色阴义。于经中应知。是故一切过去等色。一一皆名色阴。不应作如此执。是一切色摄聚一处。说名为阴。由此说故。是故诸阴假名有如聚。若尔有色诸入。于汝应成假名有。何以故。多眼等邻虚成来门故。是义不然。聚集中一一成因故。复次与尘共作故。根亦非十二入。故毗婆沙中说阿毗达磨师。若观假名阴说。则说如此邻虚者一界一入一阴一分。有不观说。则说如此邻虚者一界一入一阴。此中于一分。假说具分。譬如衣一分被烧说衣被烧。复次云何。世尊由阴等门作三种。正说弟子众。偈曰。痴根乐三故。故说阴入界。释曰。阿毗达磨师说如此。众生痴有三种。有诸众生于心法不明执聚为我故。有诸众生于色不明。有诸众生于色心不明。根亦有三。谓利中钝。乐亦有三。谓乐略中。广文为此三人次第说三。谓阴入界。复有何因。一切所余心法。佛世尊安置一行阴中。分受想二法别立为阴。偈曰。争根生死因。立次第因故。心法中受想。分立为别阴。释曰。争根有二。一贪着欲尘。二贪着诸见。受想二法次第为此二争胜因。由众生着受味。是故执着欲尘。由随颠倒想起执着诸见。受想二法是生死胜因。何以故。众生贪着受起倒想。轮转生死。复有因为立次第。后文当说。此中由此次第因。分受想二法别立为阴应知如此。此因立次第中当说。复次云何。于界入中说无为。阴中不说。偈曰。阴中除无为。义不相应故。释曰。若于五阴中说三无为。不可安立令与阴相符。何以故。义不相应故云何不相应。此无为安色中。非色乃至非识。不可说为第六阴。何以故。不应阴义故。阴是聚义前已说。无为无过去未来现在等异如色等。由此异一切。摄聚一处可立名无为阴。为显染污依止故说取阴。为显染污清净依止故说阴。此二义于无为中无由义。不相应故。于阴中不立无为。如瓶破坏非瓶。如此阴灭坏不可立为阴。余师说如此。若作此执。于界入中成反质难。说诸阴别义已。偈曰。复次第如粗。染器等义界。释曰。色者有碍。一切中最粗。无色中受行相粗故。世间有说。我手痛我脚痛。想粗于二。男女等差别易分别故。于识行粗。欲嗔等相易分别故。于中识最细。由自性难分别故。是故最粗于前说。复次无始生死男女。于色互相爱乐。由贪着爱味。此贪由想颠倒。此颠倒由烦恼。此烦恼从染污心生。如此如染立次第。复次由器等义立次第。如器食肴厨人啖者。色等五阴亦尔。复次或由界立次第。欲界欲尘色所显。诸定受所显。三无色界想所显。有顶唯行所显。此四即是识住。于四中识能依住。此阴次第。为显田种子次第义。是故唯立五阴。不多不少。由此立次第因。于行中分受及想。别立为阴。由此受想最粗。染污次第因。受想似食肴。能显二界故。别立为阴。入界中眼等六应说次第。何以故。由随此尘及识次第易知故此眼等六。偈曰。前五现尘故。释曰。眼等五根缘现在尘。是故先说。意根境界不定。有意根缘现在尘有缘三世及非三世尘。偈曰。四所造尘故。释曰。前言流至此五中。四在前说。所造色为尘故。身尘不定。或身缘四大。或缘所造。或复俱缘。偈曰。余远急明事。释曰。余者谓前四根。此次第前说。由远急明事故眼耳缘远境。于后二前说。于前二中。眼事最远。远见江河。不闻声故。故眼在前。后有急缓事。如先见人击鼓后方闻声。鼻舌无远事。鼻事急故前说。如饮食未到舌。鼻已知香故。又鼻事明了。能缘味细香故。舌则不尔。偈曰。复随处次第。释曰。复次于身中。眼根依止在上。耳根次下。鼻又下耳。舌又下鼻。身多下舌。意根依止其中。无有的处。故如处所。立彼次第。复次何因十入皆色阴所摄。于中唯一入名色入。一切入皆法为自性。于中唯一入名法入。偈曰。为简别胜故。摄多胜法故。唯一入名色。及一入名法。释曰。云何为简别欲令知。如此十法。各得入名。由成立为根尘故。不须聚集更由眼等差别。是色不得眼等名。亦是色性。应知是色入故。不立此别名。复次色入于中胜故。何以故。有碍强故。若手等物触。即便变坏。复次体相显现于此彼处。易指示故。有似影故。复次世间同知说此入为色。非知余入。为简别故。说一入名法入。不说余入。复次于法入中。摄受等多法。为说多法故立通名。又涅槃是最胜法入此中摄。非于余入。故偏受法名。复有余师说。二十种品类。多余色故。肉天圣慧三眼境故。复有余法阴入界同名。于余经中已显。由此三门摄。彼皆尽为不尽。由此摄尽无余。此中偈曰。如来说法阴。其数八十千。此但言及名。色行阴所摄。释曰。有诸师执。佛正教言音为性。于彼师入色阴摄。复有诸师执。文句为性。于彼师入行阴摄。此法阴数量云何。偈曰。说如法阴量。释曰。有诸师说。有一分阿毗达磨名法阴。其量有六千偈。八十千中一一法阴。其量皆尔。复有诸师说。偈曰。阴等一一教。释曰。阴入界缘生谛食定无量无色解脱制入遍入觉助通解愿智无争等正教随一一皆名法阴。偈曰。实判行对治。随释法阴尔。释曰。诸师实判如此。众生有八万烦恼行类。谓欲嗔痴慢等差别故。为对治此行。世尊正说八万法阴。如八万法阴。于五阴中入色行二阴摄。偈曰。如此余应理。阴入及界等。于前说中摄。熟思彼性类。释曰。若有余阴入界等。于余经中说。是彼如前所说。阴入界中随彼性类。此论中所说。应善简择摄入其中。此中有别五阴。谓戒阴定慧解脱解脱知见阴。界阴入色阴摄。余四入行阴摄。复有十遍入。前八遍入。无贪为自性故。法入所摄。若共伴类。五阴为性故。意法二入所摄。制入亦尔。空遍入识遍入及空等四无边入。四阴为性故。意法二入所摄。复有五解脱入。智慧为性故。法入所摄。若共伴类。声意法三入所摄。复有二入。谓无想入非想非非想入。第一入即无想天。十入所摄。除香味入故。第二入意法二入所摄。如此于多界经中。佛说有六十二界。此等诸界。如理应知。入十八界中摄。彼中所说六界。谓地界水火风空识界。六中二界未说其相。此无为空。为应知即是空界耶。一切识为应知即是识界耶。彼说非。云何非。门风窍鼻口内等。偈曰。窍穴名空界。释曰。若说窍穴。应知是何法。偈曰。彼言谓光闇。释曰。何以故。无有窍穴离光闇可见故。是故彼言空界。唯光闇为性。昼夜为位。此空界说名邻碍色。彼说碍色者。谓聚集中色最易变坏故。光闇与碍色相邻故。名邻碍色。复有余师释。此亦是碍他。于此无碍故。与余色相邻。偈曰。识界即是识。有流。释曰。云何不说无流。由佛许六界。偈曰。生所依。释曰。此六界从初托生心。乃至死堕心生所依止。若无流法不得如此。如此六界中。前四触界摄。第五色界摄。第六七识界摄。说摄义已。是前所说十八界。于中几有显几无显。偈曰。于中一有显。谓色。释曰。此色易可显。如言此色彼色。由此言故。应知义至所余非显。几是有碍几是无碍。偈曰。十有碍有色。释曰。此十界色阴所摄是有碍。碍是何法。相障故名碍。此碍有三种。一障碍。二尘碍。三缘缘碍。此中障碍者。于自处对障他生。如手于手自相对障。石于石亦尔。尘碍者。眼等诸根。于色等尘。如假名论说。有眼于水有碍非于陆地。如鱼等眼。有眼于陆地有碍。非于水中。从多如人等眼。有眼二处有碍。谓于水陆。如龟鼍虾蟆鬼捕鱼人等眼。有眼二处无碍。除前三句。有眼于夜有碍。非于昼时。如蝙蝠鸲鹆等眼。有眼于昼有碍。非于夜时。从多如人等眼。有眼于昼夜有碍。如狗野干马豹猫狸等眼。有眼于二时无碍除前三句。尘碍相如此。缘缘碍者。心及心法。于自缘缘境有碍。尘碍与缘缘碍。异相云何。此法于碍处有功能。说是处为此法尘。名为尘碍。心及心法所取之尘。名缘缘碍。云何此根于自境相续生。及识于缘缘生。说名有碍。过此于彼不生故。复次此中碍者。以到义。谓于自境生。此中由障碍。应知十界有碍。互相障故。若法由尘碍有碍。亦由障碍有碍不。有四句。第一句谓七心界及法界一分相应心法。第二句谓五尘。第三句谓五根。第四句谓法界一分心不相应法。若法由尘碍有碍。亦由缘缘碍有碍不。除后二句若法由缘缘碍有碍。必由尘碍有碍。有法由尘碍有碍。不由缘缘碍有碍。如五根。大德鸠摩罗罗多说

  是处心欲生　　他碍令不起
  应知是有碍　　异此非有碍

说有碍已。十八界中几善几恶几无记。偈曰。八无记。释曰。何者为八。前所说十种有碍中。偈曰。是诸除色声。释曰。五根香味触界。是八由善恶差别不可记故。故说无记。有余师说。约果报不可记。故名无记。若尔于无流则成反质难。偈曰。余三性。释曰。余十种界具善恶无记性。此中七识界。与无贪等相应是善性。若与贪等相应是恶性。所余是无记性。法界与无贪等善相应。及发起择灭。皆是善性。与贪等恶相应。及发起是恶性。所余是无记性。色界声界善恶心发起。是善恶性。身口业所摄故。若异此是无记性。说诸界善等性已。十八界中几于欲界相应。几于色界无色界相应。偈曰。欲界。一切有。释曰。相应是有义。不相离义。于欲界中具足十八。偈曰。色界。十四。释曰。于色界中不具。但有十四。何者十四。偈曰。除香味。及鼻舌识故。释曰。于色界中无香味。此二是段食类故。由离欲段食。于彼受生故。由无此尘。鼻舌二识亦不得生。无缘缘故。若尔于彼不应立有触界。触亦是段食类故。实尔。若触非段食类。于彼可有。若尔香味亦应然。是义不然。何以故。离食无别用香味如触。触有别用。谓能成根。能为依持。及成衣服等故。彼处众生离欲段食。是故香味无用。触则不尔。有余师说。依止定及三摩跋提。或见色。闻声与轻安相应。有触胜类能益彼身。是故此三。于定生处得相随生。香味不尔。若尔于彼不应有鼻舌二根。是义不然。何以故。此二有用。若离此二身。则丑陋。无二根故。又言说不成。若用如此。但须鼻舌依止。为庄严身。及以言说。不须鼻舌二根。是义不然。无但依止非根。如男根依止于彼。此不生可然。以无用故。鼻舌依止。于彼有用。是故若离根于彼此生则应理。若有诸根无用亦生。如于胎中定死众生。无用可生。非无因可生。此诸根从何因生。于根有爱。所有胜业。若人离欲。于尘于根决定离欲。彼人若已离欲香味二尘。鼻舌二根于彼不应得生。若生鼻舌二根。男根云何不生。由生丑陋故。若根藏如象王阴。云何丑陋。不必由有用故生。云何生。必由因故生。虽复丑陋。若有因必应生。因既无此不生。彼云何生是义不然。与经相违故。经言彼人具足根无阙少。是义不然。随彼所有根说无阙少。有何相违。若不尔。于彼亦应有男根。彼说如此。于彼有鼻舌二根。但无香味。彼由内依门。于六根生贪爱。不由外尘门。于男根生爱。必由淫触门起。是故此义得成。故于色界有十四界。偈曰。无色界相应。意法意识界。释曰。已离欲色界。于彼受生十界色为性。及五识界用彼为依境。是故于无色界不得有。几界有流几界无流。意法识三界。前所说。偈曰。诸有流无流。是三。释曰。若是三界中。道谛无为所摄是无流。异此是有流。偈曰。余有流。释曰。所余十五界。一向定有流几界有觉有观。几界无觉有观。几界无觉无观。偈曰。有觉亦有观。定是五识界。释曰。是五识界恒与觉观相应故言定。为简异余界故。偈曰。后三有三义。释曰。意界法界意识界。是十八中最后故言后。此具三品。意界意识界与心相应法界。除觉观。于欲界及初定有觉有观。于中间定无觉唯有观。从第二定以上。乃至有顶无觉无观。一切心不相应法界。及中间定观。是觉恒无觉唯有观。无第二觉故。唯与观相应故。于欲界及初定观。不入三品中。说其名应云何。无观唯有觉。无第二观故。与觉相应故。故说如此。有觉观地。有四品法。一有觉有观。谓除觉观所余心相应法。二无觉有观。谓唯是觉。三无觉无观。谓心不相应法。四无观有觉。谓唯是观。偈曰。余界二所离。释曰。十有色界名余。此十界恒无觉观。与心不相应故。若五识聚有觉观。云何说无分别。偈曰。显示及忆念。由二无分别。释曰。彼说分别有三。一自性分别。二显示分别。三忆念分别。五识唯有自性分别。无余二分别。故说无分别。如马一足说言无足。此中自性分别。即是觉观。此后明心法中当说。后二分别。其相云何次第。偈曰。二是散心智。诸念唯心地。释曰。此智与意识相应。故名心智。非寂定故名散。此智即是显示分别。一切忆念与意识相应。若定若散。名忆念分别。几界有缘缘。几界无缘缘。偈曰。七识有缘缘。释曰。谓眼耳鼻舌身识意根意识。此七识界有缘缘。能取尘故。偈曰。法界中有半。释曰。此亦有缘缘。以心法为体故。余十有色界。及法界一分。与心不相应法。应知无缘缘。几有执几无执。偈曰。九界非所执。释曰。何者为九。七有缘缘界。并第八中半。偈曰。八声。释曰。此九是非所执。谓七识界法界声界。偈曰。余有二。释曰。余有二。谓或有执或无执。此中眼耳鼻舌身。若现在则有执。色香味触现在若与根不相离。亦有执。所余则无执。如除根发毛爪齿屎尿涕唾血等中。及于地水等中。有执无执。此言何义。心及心法摄彼为自依止。由彼损益互相随故。是世间说有觉此名有执故。执以觉义。所余名无执。几界四大为性。几界四大所造为性。偈曰。触界有二种。释曰。触有四大及四大所造。坚等四触是四大。软滑等七触是四大所造。依四大生故名所造。偈曰。九有色所造。释曰。五根界四尘界。此九但是所造。偈曰。及法界一分。释曰。法界中无教色。彼说亦是所造。所余七识界法界中除无教。非二种。佛陀提婆说。十入唯四大。此执不然。于经中由决了说四大及坚等四相故。此四大唯是触故。此坚等四相非眼等所见。色等四尘非身根所觉。是故此执不如经中。佛世尊说。比丘。眼根者是内入依四大。是四大所造净色。有色无显有碍。乃至身根亦尔。比丘。色者是外入依四大。是四大所造。有色有显有碍。比丘。声者是外入依四大。是四大所造。有色无显有碍。乃至味亦尔。比丘。触者是外入是四大。或依四大。是四大所造。有色无显有碍。如此经中。由触一分摄四大皆尽。所余非四大。此义明了可知。复次经中说。眼谓肉丸。于中是坚是坚类。如此等经。但说肉丸与眼根不相离。不说眼根。于入胎经中说。比丘。入者谓唯六界。此说为显成就众生根本。复于此经由佛说六种触入故。若不尔。于汝亦应无受等心法。若汝言心法即是心。是义不然。想受是心法依心生。由此经言及说心为本故。故此执不如由说心与欲相应。是故如前说。诸界有四大及四大所造。是义得成。几界微聚成。几界非微聚成。偈曰。十有色微聚。释曰。是五根界及五尘界。微聚所成。邻虚众所成故

阿毗达磨俱舍释论卷第一阿毗达磨俱舍释论卷第二

        婆薮盘豆造

        陈天竺三藏真谛译

    释论中分别界品之二

于十八界中何法能斫何法所斫。何法能烧何法所烧。何法能称何法所称。偈曰。能斫及所斫。谓是外四界。释曰。色香味触名斧名薪。即是能斫所斫。何法名斫。聚流相应生。断隔其生起名斫。身根等非所斫。若斫则无余。不可令二故。何以故。诸根若分为多。则不成根。所斫诸分非根故。亦非能斫。如宝光清净故。如能斫所斫。唯外四界。偈曰。所烧所称尔。释曰。唯外四界。是所烧是所称。非诸根。何以故。微细清净故。犹如光明。声亦尔。自性断故。偈曰。争能烧所称。释曰。有诸师说。外四界是能烧是所称。有诸师说。于中唯火大能烧。唯重触是所称。几界从果报生。几界从增长生。几界从等流生。几界有实物。几界唯一刹那生。偈曰。果报增长生。五内。释曰。五内界。谓眼等五根。从果报及增长生。不从等流生。离果报增长无别等流故。此中从果报因生。名果报生。除中间因名故。譬如牛车。复次是业至果报熟时。说名果报。正能熟故。从此生故。说果报生果者名熟。复次于因可立果名。如果中立因名。如经言。此六种触入。应知是宿业。饮食将养寝卧。三摩提等胜缘所资益。名增长生。有余师说。由梵行故增长。此言不然。何以故。梵行但不为损。无有益义。于果报相续增长相续。能为护持。犹如外城防守内城。声界或增长生。或等流生。偈曰。声非报。释曰。云何不从果报生。随欲生故。若尔于假名论中。云何说由永离恶口。善修不恶口戒故。得梵音大人相生。余师说。声属第三传。从业生霜佉四大。从霜佉四大生声。复有余师说。声属第五传。从业生果报四大。从果报四大。生增长四大。从增长四大。生等流四大。从等流四大生声。若尔身受从业所生四大生。不应成果报。若受如声。则违道理。偈曰。八种无碍界。流生果报生。释曰。何者为八。七识界及法界。是等流所生。从同类因及遍行因所生故。果报生者。谓从果报因生。此八界无增长生。无碍法无增长故。偈曰。余三。释曰。余四界谓色香味触。或果报生。或增长生。或等流生。偈曰。一有物。释曰。是无为法有贞实故成物。此于法界中有故。唯一法界有物。偈曰。后三一刹那。释曰。意界法界意识界。由文句次第故言后三。此三于初无流。苦法忍一刹那中。非等流生故。言一刹那。此中苦法忍相应心。谓意界意识界。与彼共生相应法。应简择此义。若人不与眼界相应。后至得相应。为与眼识界相应不。若人与眼识界相应。为与眼界相应不。偈曰。眼根与识界。独俱得复有。释曰。独得者。有与眼界相应。不与眼识相应。如人于欲界中次第至得眼根。或从无色界堕。于第二定等中生。有与眼识相应。不与眼界相应。如人已生第二定已。引眼识现前。从彼退于下界生。或俱得者。有与眼界眼识界一时相应。如人从无色界堕生欲界。或生初定。或俱不得者。除前三句。若人与眼界相应。为与眼识界相应不。有四句。第一句者。若人于第二定等中。已受生不引眼识令现前。第二句者。若人于欲界未得眼根。及已失眼根。第三句者。若人于欲界。已得眼根不失。或生初定二定等中正见色。第四句者。除前三句。眼界与色界。眼识界与色界。至得句义。应如此思量。为引如此思量故。言复有几界为我依。几界为我依外。偈曰。十二界我依。释曰。何者十二。偈曰。除色等。释曰。六识六根。此十二界名我依。色等六尘界名外。我既是无。云何说我依及我依外。我慢依止故。假说心为我。如偈言

  我是我善依　　异此何胜依
  若我好调伏　　智人得解脱

有余处佛世尊说。唯调伏心。如偈言

  调伏心最胜　　心调引乐故

是心世间说为我。眼等为此依止。及亲近故。是故说眼等名我。依色等为境界故称外。若尔六识界。应不成我依。何以故。六识未至意界位。不得为心依。是时若作意界。即六识作非余故。六识不离意界体。若不尔。意界唯过去。非未来现在。彼部许十八界有三世故。若未来现在识。无意界体相。于过去中。亦不可立为意界。何以故。相于三世。无不定义故。几界有等分。几界非等分。若一向有等分。偈曰。法界等分。释曰。是尘于识定为境。若识于中已生及定生为法。是尘说名等分。无一法界此中无边意识非已生非应生。何以故。一切圣人心缘法界。必如此生。谓一切法无我。此心离自性及共有法。余一切法悉为境界。此刹那心。于第二刹那心。皆成境界。于二刹那中。一切法皆成境界。是故法界恒是等分。偈曰。非等分余。释曰。除法界所余界。非等分亦有等分。何法名非等分。偈曰。不作自事。释曰。义至已说。若作自事名有等分。若眼界已见色正见色当见色。说名有等分。乃至意界亦尔。由于尘自功能立名等分。罽宾国师说非等分眼有四种。若眼根不见色。已灭正灭当灭。无生为法。西方诸师说。有五种无生为法。分为二分。一与识相应。一与识不相应。乃至身亦尔。意根但无生为法。名非等分。色者若已见正见当见。名有等分。非等分有四种。若色非所见。已灭正灭当灭。无生为法。名非等分。乃至触亦尔。由自根功能应知。色等有等分非等分义。是一人等分眼。于一切人非等分。乃至意亦尔。色则不尔。随能见者。于此人则成等分。若不能见。于此人则非等分。何以故。有如此义。此色是一人所见。亦可得为多人所见。如观看时中见月舞相攒等色。无如此义。由一眼根二人见色。是故诸根不共得故。就一相续分别等分非等分。色由共得故。不就一相续立等分非等分。如色声香味触界应知如此。声界可许如此。香等三界。随一一人所得。余人不得。何以故。此三皆至到根故不共得。别立似眼等。应是道理。虽不共得。有如此道理可立共得。何以故有如此义。是香等能生一人鼻等识。亦可得生余人鼻等识。眼等则不尔。是故香等如色可得例说。眼等诸识等分非等分义。由定生定不生故。犹如意界。等分者有何义。根尘及识。更互相应。又共作一切能。又同以一触为事故。非等分者。是等分同类。虽似彼非彼。故名非等分。几界见谛所灭。几界修道所灭。几界非所灭。偈曰。十界修道灭。五亦。释曰。色等十界。并五识界。一向修道所灭。偈曰。后三三。释曰。意界法界意识界。此三各有三种。八十八随眠。或与彼共有法。是彼至得。共彼伴类。皆见谛灭。所余有流皆修道灭。无流非所灭。更有别法。是见谛所灭为。不尔。何者别法。凡夫性能感恶道。身口二业与圣道相违故。此非见谛灭。此中略说见谛灭相。偈曰。非污非见灭。非色非六生。释曰。见谛所灭随一法。无非染污。色亦非见谛灭。凡夫性。是无记无染污。断善根凡夫。及离欲人。与此相应故。身口二业是色故。是故非见谛灭。何以故。不能违四。谛理故。若尔苦法忍生时。凡夫性应在。则成违许难。六谓意入。若离此于余处生。名非六生。谓从五根生。此法亦非见谛灭。十八界中几界是见几界非见。偈曰。眼法界一分名见。释曰。何者为一分。偈曰。有八种。释曰。身见等五见。世间正见。有学正见。无学正见。此八是法界一分名见。所余法界非见。此中身见等五见。分别惑品中。时至当广说。世间正见者。意识相应善有流慧。有学正见者。谓有学无流慧。无学亦尔。此四如有云无云夜昼见色。有染污无染污。世间有学无学见。观诸法亦尔。云何说世间正见。唯与意识相应。由此义。偈曰。五识共生智。非见不度故。释曰。见者度决为体。能起简择是非故五识相应智则不尔。无分别故。是故非见。若彼有染污无染污。悉非见。若尔眼根亦无决度。何故名见。由能观视色故。云何知。偈曰。眼见色。释曰。若眼见色。与余识相应。人应得见色。若非一切眼见色。何者能见。偈曰等分。释曰。是时此眼有识。是时能见。异此则不能见。若尔应许依眼根识能见。偈曰。非能依眼识。释曰。不可立眼识能见。何以故。偈曰。由色非可见。被障彼执尔。释曰。是色壁等所障则不可见。若识能见。识无碍故。于壁等障则不为妨。是故应见被障之色。于被障色识既不生。云何能见。云何不生。若人执唯眼见色。于此人由眼有碍。于所障色无有功能。识不得生与依共一境起故。此义应然。若尔云何眼不至境。犹如身根。由不见被障色。以有碍故。若尔云母琉琉水精净水所障。色云何得见。是故不由有碍被障诸色眼不能见。若尔何故不见。是处光明相通无隔。于被障色眼识得生。若是处光明被隔不通。于中眼识不生。由不生故。不能见被障色。若尔云何经中说。由眼见色。此中明由依止得见。是此经意。如说由意根识法。意不能识法。以过去故。何者能识唯是意识。经说由眼见亦尔。复次于所依中说能依事。譬如楼叫。复次如余经说。眼所识诸色。可爱可欲悦心。此色非眼所识。复次有余经说婆罗门眼者唯门。为见众色。由此等证故。知藉眼为门以识见色。此义是证所显。于能见眼则成门。何以故。若眼成见为见诸色。是义不然。若识能见。何法。能识。此二何异。何以故。是色识即是色见。譬如有解脱名见或名智。如此有识。或名见或名识。复有余师说。若眼能见。眼则成作者。何法为别见事。有如此过失。此言非难。如汝许识能识。于中不立作者及事差别。眼能见色亦尔。复有余师说。眼识名见。见依止故。说眼能见。譬如打依止故说钟作声。若尔识依止故。义至应言眼能识不应至。何以故。此眼识于世间成立名见。云何知。此识生时。说色是所见。不说是所识。毗婆沙中自说如此。若眼所至眼识所受。乃说所见。故说眼见不说眼识。但由识在。故名能识。譬如说日作昼。经部说。何故共聚破空。何以故。依眼缘色。眼识得生。此中何法能见。何法所见。一切无事。但唯有法。谓因及果。此中为互相解。随意假说。如说眼能见识能识。于中不应执着。佛世尊说。汝等莫执着方言。莫随逐世间所立名字。罽宾国毗婆沙师。悉檀判如此。眼能见。耳能闻。鼻能嗅。舌能尝。身能触。意能识。为用一眼见色。为用二眼见色。此中无定。偈曰。或由二眼见。分明见色故。释曰。亦由二眼根见色。阿毗达磨师说如此。何以故。若开二眼见最明了。若开一眼。半闭一眼。则见二月。由随一变异见则不明。不可由依止处别分识为二。识无住处故。不同于色若眼能见。耳能闻。乃至意能识。彼尘为至为不至耶。偈曰。眼耳及意根。不至尘。释曰。云何如此眼能见远色。若以药涂眼则不能见。耳能闻远声。若眼耳缘至尘。修观行人。天眼天耳。不得应成。犹如鼻等。若尔云何不能见一切不至尘。及最远尘。并所障尘。若尔云何磁石不吸一切不至之铁。若能缘至尘。此难则齐。云何不能见一切至尘。谓眼药及筹等。如鼻等缘至尘。不缘一切至。不能取香等共有故。如此眼尘不至。非一切不至。皆是眼尘。意无色故。无有至能。故不缘至尘。有余师说。耳缘至不至尘。由闻耳内声故。所余鼻舌身。偈曰。三异。释曰。以至到为尘。云何知鼻缘至尘。若断息则不闻香。至是何法。生无间为至。邻虚为互相触。为不相触。罽宾国师说。不相触。何以故。若由一切体相触。诸物则应相杂。若由体一分相触。邻虚则有方分。诸邻虚无方分故。若尔云何发声。由无间故。若言相触。二手相榼则应相着。石投石亦尔。若尔微聚相榼云何不散。风界所持故。何以故。有风界能破散。如劫末时。有风界能合持。如劫成时。云何今说三根尘由无间至缘于至尘。是彼无间义。说名为至。谓于中间无有别物。复次微聚物有方分故。若相触则无失。若作如此执。毗婆沙中此文句得成。是触为以触为因生。为非触为因生。作如此问。约因为答。有时以触为因。非触得生。若物分散。有时以非触为因。触得生。若物增长。有时以触为因。触得生。若聚与聚共合。有时以非触为因。非触得生。如隙中微尘。大德婆须蜜多罗说。若邻虚相触。应得住至后刹那。大德说。邻虚不相触。于无间中。世间假立触名。大德意可受。若不如此。邻虚则有间。中间既空。何法能断其行。说其有碍。是聚不异邻虚。若聚相触。即是邻虚相触。如可变坏。若汝言邻虚有方分。若触非触。皆成有分过失。若无方分。于汝不可许之。为色若有触。可立此难。眼等诸根取尘。为称其自量。由事速疾故。犹如旋火。乃至遍见大山等。色为能取等不等量尘。是前所说。缘至到尘。偈曰。三根谓鼻等。许取如量尘。释曰。如根量邻虚。尘邻虚亦尔。共合生鼻等识。眼耳则无定。有时取最小尘。若见毛端。有时取等量尘。若见蒲桃子。有时取最大尘。若见大山。即于闻时耳亦如此。或闻蚊声。或闻雷声。意既无体。不可说其形量。眼等诸根邻虚形相云何可知。眼根邻虚。于眼童子中住。如时罗花青色所覆。是故不散。有余部说。如聚重累住。互不相障。清彻如颇梨柯宝。耳根邻虚。于耳中住。如浮休阇皮。鼻根邻虚。于鼻頞中住。前三根横作行度。无有高下。舌根邻虚如半月。彼说于舌中央。如发端量。非舌根邻虚所覆。身根邻虚如身相。女根邻虚如鼓颡。男根邻虚如大指。此中眼根邻虚。或时一切等分。或时一切非等分。或时有等分有非等分。乃至舌根邻虚亦尔。身根邻虚。无一切等分。若然焰地狱中。所执驻众生。有无量身邻虚。亦非一切等分。何以故。若一切皆发身识。则身散坏。无唯一邻虚根一邻虚尘能生识。五识以微聚为根尘故。是故邻虚无显。不可见故。是六识界如前所说。谓眼识乃至意识。于中五识尘唯现世。最后识尘三世。彼依为如此不。说不尔。云何不尔。偈曰。后界依过去。释曰。意识界无间灭识为依。偈曰。五界依亦共。释曰。亦言显过去。此中眼识依。共有同一世故。乃至身识亦尔。彼过去依。谓意根。如此五识聚。依二根生。故说如此。若法能为眼识依。为能作彼次第缘不。此中有四句。第一句。谓眼根。第二句。谓次第已灭心法法界。第三句。谓次第已灭心。第四句。除前三句。乃至身识自根。亦应如此说。于意识但无初句。若法为依。必为次第缘故。若有法为次第缘非依。谓无间灭心法法界。识生随属二缘。复有何因。但说眼等为彼依。不说色等。偈曰。随根异识异。故眼等成依。释曰。由眼等根有差别故。诸识亦有差别。眼等根若有增损。诸识随之则有明昧。不由色等差别诸识变异。于识二缘中眼等胜故。立为识依。不说色等。色等是识所识。复有何因。说为眼识乃至意识。不说为色识乃至法识。由眼等是彼依故。约根说识。复次偈曰。由彼不共因。故约根说识。释曰。云何不共因。此眼根不得为余识依色可。得为意识缘缘。及为他眼识境。乃至身亦尔。由识依止。及由不共因。是故约根说识。不约色等。譬如鼓声麦芽。若人在此身中。由眼见色。是身眼色识。为是一地。为是别地。一切皆异。若人生欲界。由自地眼见自地色。此四种同在自地。若此人由初定眼见自地色。身及色俱在自地。眼及识属初定。若见初定色。则三种属初定。若由二定眼见自地色。身及色在自地。眼属二定。识属初定。若见初定色。色及识属初定。身在自地。眼属二定。若见二定色。眼及色属二定。身在自地。识属初定。如此由三定四定。眼若见自地及下地色。应如理推合。若人生在初定地。由自地眼见自地色。此四皆属自地。若见下地色。则三种在自地。若由二定眼见自地色。则三种在自地。若见欲界色。身及识在自地。色在下界。眼属二定。若见二定色。眼及色属二定。余二在自地。由三定等眼。亦应如理推合。若生二定等地。由自地眼若见自他地色。亦应如理推合。此中是决判。偈曰。眼无下身义。释曰。身眼色有五地。谓欲界地乃至第四定地。眼识有二地。谓欲界及初定。此中随身地。眼根或等地或上地。定无下地。随眼根地。色或等地或下地。是眼境界。偈曰。上色非下境。释曰。未曾有上地。色下地眼能见。偈曰。识。释曰。识。不得在眼上。譬如色。偈曰。于此色遍于身二一切。释曰于此。谓于前所说眼识。一切色是其境界。或上或下或等。二谓识及色。于身此二一切有。如广说眼根。应知如此。偈曰。耳亦尔。释曰耳无下身。义上声非下境。识于此声遍于身二一切。如理广说。应知如眼。偈曰。余三。一切属自地。释曰。鼻舌身界。身自尘及识。皆属自地。如此已通立无差别。后为简别。更立别言。偈曰。身识下自地。释曰。身在欲界。触亦尔。此三恒在自地。身识有处属自地。如人生欲界及初定。有处属下地。如人生二定。偈曰。意根地不定。释曰。有时意根与身意识法。同在一地。有时上下为地。于五地身意等属一切地。谓入观时。及受生时。如此道理。于分别三摩跋提品中当广说。为离繁重言故。不于此品中说。何以故。功多用少故。前来往复。与随所欲说相关竟。今应思量此义。于十八界及六识界。何界所知。何识能知。偈曰。五外二所知。释曰。色声香味触界。如其次第。眼耳鼻舌身识所识。复为意识所知。此外尘随一二识所知。余十三界非五识境故。唯一意识界所知。此是义至所显。十八界中几界常住几界无常。无一界具足常住。虽尔偈曰。常住法无为。释曰无为是法界一分。即是常住。余界皆是无常。几界是根几界非根。偈曰。法界半名根。及十二我依。释曰。于经中说。根有二十二。何者是耶。眼根耳根鼻根舌根身根意根。女根男根。命根乐根苦根喜根忧根舍根。信根精进根念根定根慧根。未知欲知根。知根。知已根。阿毗达磨师破。安立六内入次第。次命根后说意根。能缘境故。此中法界半者。命等十一根。是三根分法界一分故。十二我依者。眼等五根。如自名所说。七心界名意根。女根男根。是身界一分。后当说。所余五界。并法界一分。成立非根

    俱舍释论中分别根品第二之一

说二十二根已。根义云何。最胜自在为义。于自事用中。增上自在故。复以光饰为义。于身中最明显故。是故以最胜自在光饰为义。于中何根何处自在。偈曰。于四义五根。增上。释曰。眼耳二根随一。于四义中增上。一于光饰自身增上。若人盲聋。形相则丑陋故。二于引护自身增上。若见若闻。能离不安吉处故。三于生眼耳识。及共相应法中增上。由识及相应法随其增损有明昧故。四于见色闻声不共因增上。非意识他识因故。鼻舌身根。光饰自身。如前二根。二于引护自身增上。由此三能用段食故。三于生鼻等三识及共相应法中增上。四于嗅香尝味觉触。不共因增上。偈曰。于二二四根。释曰。女根男根命根意根。于二于二随一增上。女根男根。于众生差别及相貌不同增上。差别谓分别。男女相貌不同。谓乳等形状。音声威仪各异。复有余师说。于染污清净增上。何以故尔。自性黄门。故作黄门。及二根人。不护无间业断善根等不有。守护至果离欲亦不有。此二但于男女有。命根于聚同分相应及执持中增上。意根于托后有相应。及随从自在中增上。此中后有相应者。如经言。是时乾闼婆。于二意中随一现前。或与欲相应。或与嗔相应。随从者如偈言

  意引将世间　　意转令变异
  是意根一法　　一切法随行

乐受等五根。及信等八根。增上云何。偈曰。五及八。于染污清净。释曰。次第应知彼增上。乐受等五根。于染污增上。欲等诸惑。于彼随眼故。信等八根。于清净增上。何以故。一切清净。皆由彼成故。有余师说。乐受等于清净亦有增上。由安乐故。心则得定。佛说信以苦为资粮。复次有六喜等受。是出离所依。毗婆沙师作如此说。复有余师说。不由眼耳二根引护自身。由先已知得离不安吉处故。此二但于识是增上。无有见色闻声异于识。是故眼耳二根。于不共因中不应更立增上。是故眼等不应有如此增上。若尔彼增上云何。偈曰。得自尘增上。得一切六根。释曰。眼等五根于得自尘中增上。意根于得一切尘中增上。是故此六。一一皆立为根。若尔诸尘于此中有增上。云何不立为根。无增上。何以故。为最胜主故名增上。眼于得色中。为主最胜。是得一切色通因故。由其增损。识随明昧故。色则不尔。反此二义故。如此乃至意根及法。应知亦尔。偈曰。女男性增上。从身立二根。释曰。复从身根更立女男二根。此二与身根不异。是身根中有一分。于下门处次第得女男根名。于女男性为增上故。女男性谓女相声行欲乐。是名女性。男相声行欲乐。是名男性。由此身分。二性得成就。及可了别。于此二性是增上。故立为根。偈曰。住同分染污。于清净增上。寿命及五受。信等立为根。释曰。住聚同分中。寿命为增上。于染污五受为增上。云何如此。于乐受欲随眠。于苦受嗔。于不乐不苦受无明。经中说如此。于清净信等五为增上。云何如此诸惑是彼所伏。不能上起。圣道由彼引生。是故许立彼一一为根。偈曰。未知欲知知。知已立根尔。至得后后道。涅槃等增上。释曰。三中一一应立为根。为显此义故言尔。未知欲知。于至得知中增上。故立为根。知于至得知已中增上。知已于至得涅槃增上。故立为根。何以故。若人心未解脱。无得涅槃义。等言为显别类义。何者别义。于见谛应除惑灭中。未知欲知根为增上。于修道应除惑灭中。知根为增上。于现世安乐住中。知已为增上。能证受解脱喜乐故。若由增上义立根。无明等惑。亦应立为根。何以故。无明等诸分。于行等中亦有增上。是故应立无明等为根。能言等亦尔。谓舌手脚谷道男女阴。皆应立为根。于言说执捉离向弃舍戏乐中增上。是故应立为根。不可立为根。何以故。由根用如此。偈曰。心依此差别。其住及染污。资粮并清净。如此量立根。释曰。此中心依。谓眼等六根。众生类以六入为根本故。此六种依差别。由女男二根。此一期住由命根。此染污由五受根。清净资粮由信等五根。实清净由三无流根。是故不许立无明等为根。偈曰。复有生依生。生住生受用。立十四后八。约解脱立根。释曰。复言为显诸部别执。余部说。生死依者。所谓六根。此依生由何法。由女男二根。此住由命根随命根相续故。受用由五受。为显此义故。立十四根。依此四义。约解脱所余亦立为根。信等五是解脱依。未知欲知是生。知是住。知已是受用。是故根量如此不增不减是故次第亦尔。不可颠倒。舌不可于言说中立为根。何以故。观学胜能故。手脚不应于执捉及离向中立为根。无异故。此物由异相于余处生。说名执捉及离向离手离脚。蛇等亦能执捉能离向故。手脚于此二不可立为根。谷道不可于弃舍立为根。重物在空中一切处落。又由风引故出。女男阴不可於戏乐中立为根。女男戏乐不由自阴成。互相发起故。喉齿眼脸节解。于吞嚼开闭屈伸事中增上故。应立为根。一切因缘。于其自事增上。皆应立为根。若不许如此舌等根义。此亦不成。此中眼根为初。男根为后。前已广释。命根是不相应行。于不相应法中当广释。信等五根于心法中当广释。乐受等未知欲知等。今当释之。即如次第释。偈曰。苦根非所爱。身受。释曰。非所爱。谓能损恼由苦故。偈曰。乐根者。所爱。释曰。乐根谓所爱身受。能为利益故。偈曰。第三定。心受名乐根。释曰。于第三定是可爱受。依心地起名乐根。何以故。于第三定中无有身受。以无五识故。偈曰。此乐于余处。喜根。释曰。除第三定于余处。谓欲界及初定二定中。若在心地。立名喜根。于第三定由离欲喜故。但成乐根。不成喜根。何以故。喜粗浊故。但得喜根名。偈曰。心地苦。忧根。释曰。非所爱受。若在心地名忧根。偈曰。舍根者。中。释曰。非所爱非非所爱。谓非乐非苦受。故名中立为舍根。此为是身受为是心受。偈曰。二。释曰。或身受或心受。何因为合。此二受立为一根。偈曰。无别故。释曰。心地苦乐多从分别生。身受则不尔。但随尘生。于阿罗汉生亦如此。是故此二为根有差别。舍受者。若人不分别。由自性生。或在身或在心地。故合二为一根。身乐利益有异。心乐亦尔。苦亦如此。身苦损害有异。心苦亦尔。此分别于舍受中无对舍。无此分别故。是故不分为二根。偈曰见修无学道。九三。释曰。意乐喜舍信等五。是九根于三道中说名三根。于见道中名未知欲知根。于修道中名知根。于无学道中名知已根。云何如此。于见道中为知所未曾知实境。是故修行。于修道中无境先未曾知即方应知。是前所知今重知之。为除所余烦恼故。于无学道中。已知如此知。复次能护已知故。说已知护。何以故。由已得尽智无生智故。苦我已离不应更离。若人在此位所得根。或名已知知根。或名已知护根。释体性已。根类差别今当说。几根有流几根无流。如是等。此中是根无间已说。谓未知欲知等是根。偈曰。无垢三。释曰。无流是无垢义。垢者是流别名故。偈曰。有色命二苦。有流。释曰。有色七根命根苦根忧根。一向有流。何以故。眼等有色七根。色阴摄故。故是有流。偈曰。九二种。释曰。意乐喜舍根及信等五根。此九根或有流或无流。有余师说。信等一向无流。何以故。佛世尊说。若人一切种。无有信等五根。我说此人在正法外。住凡夫众类中。此经不足为证。依无流说。此经云何知。佛世尊安立圣人已。方说此经。若人一切种。无信等五根。广说如经。凡夫有二种。一在正法内不断善根。二在正法外断善根。佛依此人故说此言。谓我说此人在正法外住凡夫众类中。于经中佛说。有诸众生。生于世间。长于世间。若利根中根软根。未转无上法轮时。是故知有有流信等五根。佛复于经中说。乃至我未如实知。信等五根。集生及灭滋味过失及出离。我未能从此世间有天有梵。广说如经。若诸法无流。无如此简择品类。几根是果报。几根非果报。一向是果报者。偈曰命果报。释曰。若尔阿罗汉比丘引命行。令住此命行。亦是命根。是何法果报。于阿毗达磨藏中说。云何引命行。令住阿罗汉比丘。有圣如意成通慧。至得心自在位。或于大众。或于一人。舍施若钵若袈裟。或随一沙门命资粮。因此发愿。入第四定远际三摩提观。从此定起。作如是心。说如是言。凡是我业应熟感。富乐愿此业熟生我寿命。是时此阿罗汉业。应感富乐。转生寿命。复有余师执。残业果报转熟。彼说宿生所作业。有残果报。由修习力。引取受用。云何弃舍命行。如此舍施发愿。入第四定远际三摩提观。从此定起。作如是心。说如是言。凡是我业应熟感寿命。愿此业熟生我富乐。如彼欲乐。如此转熟。大德瞿沙说。于自依止中。由定力。引色界四大令现前。能随顺寿命。或相违四大。由如此方便。引命行令住。及以弃舍。应如此成。诸阿罗汉。有如此定自在力。由此力宿业所生。诸根四大。引住时量。皆悉回转。先未曾有三摩提引住时量。今则引接。是故如此寿命非果报。异此名果报。从问更起别问。阿罗汉人。何因发愿引命行令住。或为利益他。或为令正法久住。是诸阿罗汉。已见自身寿命将尽。于此二中不见他有此能复以何因弃舍寿命。于有命时。见利益他事少。自身疾苦所逼如偈言

  修梵行已竟　　圣道已善修
  由舍命欢喜　　如人病得差

若尔。此引寿行命住及弃舍。应知何处何人。能为此事。于人道中。于三洲。于男女。非时解脱阿罗汉。俱解脱人。得远际三摩提。何以故。此人于诸定有自在。其相续非惑所熏。经中说。世尊愿留诸命行。舍诸寿行。命寿二行差别云何。余师说。无有差别。云何知。经中说。何者为命根。谓三界寿。复有余师说。宿业果报名寿行。现世业果名命行。复有师说。若由此得住聚同分中名寿行。若由此得暂时住名命行。诸言者。由愿留多寿命行生起故。何以故。于一刹那生起无愿留能故。复有余师说。无有一物名寿命得暂时住。为显此义故有诸言。复有余师说。于多行中假立寿命名。无别一物名寿命。若不尔。佛不应说行问云何世尊舍弃寿行愿留命行。为显于死有自在故弃舍。为显于寿命有自在故愿留。云何但三月不过。受化弟子利益事毕竟故。复次世尊建立义言。若比丘修习数行四如意足。若欲住可得一劫。或过一劫。为显所建立义故。留舍命寿。毗婆沙师说。于五阴及死。为显自胜能故。先于菩提树下。已破烦恼魔及天魔得胜能。随应论且止。所依本义今应说。偈曰。十二二种。释曰。何者为十二。偈曰。除后八。及忧根。释曰。又除命根。所余十二有二种。有是果报。有非果报。此中眼等七根。若是增长果。非果报。所余皆是果报。意苦乐喜舍根。若善若染污。非果报。若威仪工巧变化相应。亦非果报。所余是果报。除命根及眼等十二根。所余非果报。此义至得成。若忧根非果报此经云何。将经言。有业于喜受好。有业于忧受好。有业于舍受好。依相应好。故说此言。若业与忧受相应。名于忧受好。譬如触与乐受相应。说触于乐受好。若尔业于喜受舍受好。亦应成如此。如汝所欲。我亦许之。于相应无失。于果报亦无失。若尔由无能故皆许如此。有何别道理。能立忧非果报。忧受由分别差别所生。及分别所息果报则不然。若尔于喜受亦应然。不应立喜为果报若忧是果报。作无间业人。因无间业生忧受故。此业应熟。喜亦应尔。若喜是果报。作福业人。因福业生喜受故。是福业应熟。是义不然。复有别证。诸离欲人无忧受故。果报则不尔。诸离欲人亦无无记喜根。若尔果报有何相。随其相若有宿业应位。虽复如此。喜根可有残果报。忧根则无。余一切种不行起故。故毗婆沙师说。忧非果报。以命根为第八。于善道中善业果报。于恶道中恶业果报。意根于二道二业果报。乐喜舍三根。是善业果报。苦根是恶业果报。于善道二根人。由恶业得。如此位此论已说。所余应说。几根有果报。几根无果报。此中忧根。于前无间已说。偈曰。一定有报。释曰。此一忧根有果报。定言为决。忧根异于余法。此根无无记。亦无无流。在散动地故。是故忧根无无果报。偈曰。十二种。释曰。二种。谓有报无报。何者为十。偈曰。意余受信等。释曰余受者。应知异忧根。信精进念定慧根。此中意乐喜舍。若是恶若善。有流则有果报。苦根若善若恶有果报。若无记无果报。信等五根。若有流有果报。无流无果报。所余无果报义至自成。几根是善。几根是恶。几根无记。此中若一向善。偈曰。八根善。释曰。信等五。未知欲知等三。偈曰。二种忧。释曰。或善或恶。偈曰。意及余受。三种。释曰。此五根有三种。善恶无记。偈曰。余一种。释曰。何者为余。眼根为第一。命根为第八。此八一向无记

何根何界相应。于二十二根中。偈曰。欲界有除净。释曰。于欲界相应相。应知除一向无流。未知欲知等三根。何以故。此三决定非三界相应故。偈曰。色有除女男。二苦。释曰。如前除无流。二苦谓苦忧二根。于色界人离欲淫欲法。故又令依止非可爱故。是故彼无女男二根若尔云何说彼为丈夫。何处说。如经言。无处无理。女人作梵。有处有理。丈夫作梵。于彼别有丈夫相。于欲界但是丈夫所得。于彼无苦根。依止净妙故。又无恶业故。亦无忧根。奢摩他软滑相续故。又无限类境界故。偈曰。无色有。除二乐及色。释曰。除女男二根。除二苦根。及无流根。所余几根。意命舍信等五根。如此多根。应知于无色界相应。无余根。几根见谛灭。几根修道灭。几根非所灭。偈曰。意三受三种。释曰。何者三受。乐喜舍根。偈曰。见修灭忧根。释曰。忧根二道灭。见道修道所灭故。偈曰。九修道灭。释曰。眼根为第一。命根为第八。及苦根由修道灭。偈曰。五或非灭。释曰。信等五根。或修道灭。或非所灭。有有流无流故。偈曰。三非。释曰。未知欲知等三根。非见道修道所灭。以无流故。无过失法。不可除故

说诸根品类差别已。诸根至得今当说。几根于何界果报先所得。偈曰。欲中初得二。果报。释曰。身根命根是果报故。正托胎时先得此二。偈曰。非化生。释曰。四生中由除化生。胎卵湿三生。应知已许。云何不说意舍二根。正受生时。此二根必是染污故。若化生初得果报有几根。偈曰。彼得六。释曰。若彼无女男根。如劫初生。何者为六。眼耳鼻舌身命根。偈曰。七。释曰。若彼生一根如于天等生。偈曰。八。释曰。若彼生二根。化生人可有二根耶。若于恶道可有。于欲界初得如此。于色界无色界云何。偈曰。色中六。释曰。由欲胜故名欲界。或但名欲。由色胜故名色界。或但名色。经中说。是寂静解脱过于色非色。于色界中初所得果报有六根。彼根同欲界。无二根化生所得。偈曰。余一。释曰。无色界异色界故名余。由三摩跋提异故。由生胜故。此中初得果报。但有一命根。余根则非。说至得已。弃舍今当说。于何界正死。弃舍几根。偈曰。正死人弃舍。于无色命意。舍根。释曰。若人在无色界正死。于最后心弃舍命意舍三根。偈曰。于色八。释曰。若人在色界正死。于最后心弃舍八根。三如前。又眼等五根。何以故。一切化生众生。具根受生。具根死堕故。偈曰。欲界十九八。释曰。若人在欲界正死。于最后心若具二根人弃舍十根。八如前。又女男根。若一根人则弃舍九根。若无根人但舍八根。若一时死道理则然。偈曰。次第死舍四。释曰。若人次第死。于最后心一时弃舍四根。谓身命意舍根。何以故。此四无相离尽故。若染污心。及无记心死。应知道理如此。若人于善心死。是时偈曰。于善诸处五。释曰。若人于善心死。一切处如前说。若弃舍根。复舍信等五根。何以故。此信等五根。于善心必具足生。如此于无色界弃舍八根。于色界弃舍十三根。如此依前次第。应更广数。于根伽兰他中。简择一切根法。应如此知。复次何沙门若果。由几根能得。偈曰。九得边二果。释曰。由九根至得前后际沙门。若果何者为边。须陀洹果。及阿罗汉果。前后际所得故。几果在中际。斯陀含果。阿那含果。此中须陀洹果信等。除知已根并意根舍根。由此九根得前际果。未知欲知根在次第道。知根在解脱道。由此二根得须陀洹果。次第能引择灭至得。及能作彼依止故。复有阿罗汉果信等。除未知欲知根意根。乐喜舍根中随一。由此九根得后际果。偈曰。七八九中二。释曰。斯陀含果。阿那含果。观前后故名中。此二果一一至得。由七八九根。云何如此。斯陀含果。若人。次第修方得。若依世间道。此果由七根得。信等五根并舍意二根。若依出世道。此果由八根得。七如前。知根为第八。若先多离欲人。方得此果。由九根得。如得须陀洹果。阿那含果。若人次第修方得。若依世间道。此果由七根得。如前所说。得斯陀含果。若依出世道。此果由八根得。亦如前所说。得斯陀含果。若先已离欲人。方得此果。由九根得。亦如前所说。得斯陀含果。此果与前果有异。谓乐喜舍随一根相应。由依止差别故。若次第修人。于第九解脱道。若入根本定。依世间道。是时由八根得阿那含果。何以故。于第九解脱道中。喜根为第八。于次第道则用舍根定。由此二根得阿那含果。若人依出世道。入第九解脱道。是人则由九根得阿那含果。此中知根为第九。若尔阿毗达磨藏中。云何说如此。彼藏中说。由几根能得阿罗汉果。彼中答由十一根。云何此中说由九根得。定由九根。偈曰。十一得罗汉。说依一人成。释曰。有如此道理。是一人已退。已退由乐喜舍根。更得阿罗汉果。是故说由十一根。无有是处。乐受等三根。于一时中俱得生。云何于阿那含人。不论如此义。此阿那含。不得如此。何以故。无先已退后时由乐根更证本果故。复次若先离欲人无退堕义。此人离欲二道所证故。此义应当思量。与何根共相应。有几根必定共相应。此中偈曰。舍命意相应。必与三相应。释曰。若人与舍等根随一相应。此人必与三根相应。三根者。谓舍命意。何以故。此三更互无离相应故。与余根相应则不定。或相应或不相应。此中生无色界人。与眼耳鼻舌根不相应。于欲界亦尔谓若人未得及已失。生无色界人。与身根不相应。生色无色界人。与女根不相应。于欲界亦尔。谓若未得及已失。与男根亦尔。若凡夫人生第四定第二定处及无色界。与乐根不相应。若凡夫生第三定第四定及无色界。与喜根不相应。若凡夫生色无色界。与苦根不相应。若离欲人。与忧根不相应。若断善根人。与信等根不相应。凡夫及至得果人。与未知欲知根不相应。凡夫及见道人无学道人。与知根不相应。凡夫及有学人。与知已根不相应。于非遮位中如前所说。应知与余根相应。偈曰。与四有乐身。释曰。若人与乐根相应。此人必与四根相应。谓舍等三根及乐根。若人与身根相应。此人必与四根相应。三如前并身根。偈曰。与五有眼等。释曰。若人与眼根相应。此人必与五根相应。谓舍命意身及眼根。与耳鼻舌相应。应知亦尔。偈曰。有喜亦。释曰。若人与喜根相应。此人必与五根相应。谓舍命意乐及喜根。若人生第二定。未得第三定。与何乐根相应。与第三定染污乐根相应。偈曰。有苦。与七。释曰若人与苦根相应。此人必与七根相应。谓身命意及余四受相应。偈曰。有女等。与八。释曰。若人与女根相应。此人必与八根相应。七如前。及女根。等言七者摄男根。忧根及信等根。若人得如此根。随一一皆与八根相应。七如前。男根为第八。若人与忧根相应。七如前。忧根为第八。若人与信等根相应。此人必与信等五根。及与舍命意根相应。偈曰。与十一。有知知已根。释曰。若人与知根相应。此人必与十一根相应。谓乐喜舍命意五根。又信等五根。知根为第十一。与知已根相应亦尔。十根如前。知已根为第十一。偈曰。未知欲知根。与十三相应。释曰。何者为十三。谓意命身根女男根随一。及三受根。信等五根。未知欲知根为第十三。复次若人与极少根相应。与几根相应。偈曰。极少无善八。受意身命应。释曰。若人断善根。说名无善。极少与八根相应。谓五受根。及身意命根。如断善根人。与极少根相应。偈曰。凡夫无色尔。释曰。若凡夫生无色界。与八根相应。偈曰。舍命意信等。释曰。舍命意三根及信等五根。信等一向善故。除断善根人。一切处皆通。若尔未知欲知等根。于彼亦应立。此难不然。由立八根故。依凡夫故。若人极多。与几根相应。偈曰。极多与十九。离三无流根。二根。释曰。除三无流根。若人具女男根。及具余根。则与十九根相应。复有何别人。与极多根相应。偈曰。有欲圣。释曰。若未离欲有学圣人若与极多根相应。亦与十九根相应。偈曰。一根除二净。释曰。除一根及除二无流根。谓除知已根。前二随除一根。诸根由分别界差别义。所引来依广分别义已说

阿毗达磨俱舍释论卷第二阿毗达磨俱舍释论卷第三

        婆薮盘豆造

        陈天竺三藏真谛译

    释论中分别根品之二

复次。此义应当思量。是诸有为法。如彼自相。更互不同。为如此彼生亦不同。为有诸法决定俱生。亦有。何以故。一切法有五品。一色二心三心法四不相应五无为。此中无为法无生。有色诸法今当决判。偈曰。于欲界八物。无声根邻虚。释曰。极细色聚说名邻虚。欲令知无余物细于彼者。此邻虚若在欲界。离声亦非根。则八物俱生。随一不减。八物谓地等四大及四大所造色香味触。若有根邻虚无声。则九物俱生。或十物俱生。此中偈曰。有身根九物。释曰。若身根邻虚。此中有九物。八如前。身根为第九。偈曰。十物有余根。释曰。此邻虚中若有余根则有十物。九如前。眼等五根中随一为第十。此邻虚若有声俱生。如次第九物十物十一物俱生。何以故。有声与根不相离。谓执依四大为因声。若四大不相离。云何有聚。或见唯坚实。或见唯流湿。或见唯暖热。或见唯轻动。此聚中随一偏多。或功力最胜故。见一明了。譬如针锋及绵触。又如糗盐末味。若尔云何。于彼应知所余亦有。由事故可知。事谓持摄熟引。复次余师说。若得别缘。坚等成软湿等故。于水中由极冷故。或得热触。虽不相离。有冷胜别德。如声及受有胜别德。复有余师说。于聚中由种子彼有。不由自体相。如经言。于木聚中有种种诸界。由此言故知。由种子故有。若尔云何。于风知有显色。此义但可信不可比。何以故。由相杂能持香故。于风四尘不定故。色界香味不有。此义于前已说。是故由此说。于色界有别邻虚。复有由此说邻虚。有六物七物八物。此义已显。不须更说。此中为约物说物。为约入说物。若尔何为。若约物说物。此说则少。谓八物九物十物。何以故。此中必有形色。是邻虚滋长故。轻重触随一。滑涩触随一。有处有冷触。有处有饥渴触。若约入说物。此说则多。谓八物等。何以故。应但说四物。四大亦是触入。是义不然。此中有处约物说物。谓所依止物。有处约入说物。谓能依止物。虽复如此。四大物转成多。能依止物随一依具四大故。此中复有执取物类为物。虽别类四大。不过自性故。何须作此功用为分别说。如此义语言如意生起。唯义应思量。说色决定俱起已。所余品生起今当说。此中偈曰。心心法必俱。释曰。何以故。此心及心法。更互相离则不得生。偈曰。一切共行相。释曰。必言流。不但心及心法必定俱起。一切有为中。若有应生。或色心及心法等。是名一切。若起必共有为相俱起。偈曰。与得。释曰。若众生名是法。必与至得俱起。余法不尔。是故别立是法所说名心法。何者是耶。偈曰。心法五。大地等别故。释曰。心法有五品。一大地。二善大地。三惑大地。四恶大地。五小分惑地。何法名地。是所行处。若法此法行处。是法说为此法地。此中诸法地大故名大地。若法于一切心有。何法于一切心有。偈曰。受作意想欲。触慧念思惟。相了定十法。遍于一切心。释曰。彼说此十法。于一切心刹那皆聚集生。此中受谓三种。随领乐苦非乐非苦。作意谓心故为事。想谓心执境差别相。欲谓求作。触谓根尘识和合所生异法。慧谓般若。即是择法。念谓不忘所缘境。思惟谓心回向。相了谓于所缘相有法能令心明了。定谓心一心。心法差别最细难可分别。于相续尚难知。何况刹那中。有色药草。有多种味。于中有药其味差别。可以根证。亦难分别。何况此法无色。智慧所了。是诸法善为大地。说名善大地。若诸法恒于善心中起。何者为诸法。偈曰。信不放逸安。舍羞及惭愧。二根非逼恼。精进恒于善。释曰。如是等法。恒于善心中起。此中信谓心澄净。有余师说。于谛实业果中心决了故名信。不放逸谓修习善法。有何修习。异于善法。恒在善法。名不放逸。于余部经中说。是心护名不放逸。安谓心于事有能。此义可不如此。于余经说。身于事有能名安。非不说如身受。应知此亦尔。若尔云何。于助觉立为分。何以故。于中是身于事有能。说名身安应知。若尔云何说此为觉分。由随顺觉分故。得觉分名。何以故。此身安能引心安觉分令生故。于余处曾见有。如此说不曾有。犹如经言。喜及助喜法。世尊说名喜觉分。复有别说。嗔及嗔因名害盖。复有正见正思惟正精进。此三说名般若分。此资粮由随顺。故得彼名。如此身安随顺心安觉分。故得彼名。舍谓心平等。无所偏对。今此言云何相应。何者前说。思惟于心回向为体。今说舍于心无回向为体。此言云何相应。为前不说耶。谓心法义理难知。有难知后方可知。此最难可知。谓于相违立不相违。有余处回向。有余处不回向。此中有何相违。若尔一切相应法。不应共缘一境。如此种类。所余诸法。此中应来。此法道理。汝等必应须知。羞及惭愧后当释。二根谓无贪无嗔二种善根。无痴亦是善根。此善根以智慧为体。前已立为大地故。于善大地中不复重说。非逼恼谓不欲违损他。精进谓勇猛。说十善大地已。是地大故名大地。惑是彼大地故。说彼为惑大地。是诸法恒于染污心起。何者为诸法。偈曰。痴放逸懈怠。无信无安掉。恒在染。释曰。此中痴谓无明。无智无显。放逸谓不修习善法。此是修习善法对治懈怠谓心无胜能。无信谓心无澄净。此是信对治法。无安谓身重心重。身心于事无能阿毗达磨藏中说。无安有二种。谓身无安心无安。云何心法。说名身法。如说受为身受。掉谓心不静。如此六法。是名染污大地。于阿毗达磨藏中。不说十法为惑大地耶。彼中亦不说无安。何者为十。无信。懈怠。忘念。心乱。无明。不了别。不正思惟。邪相了。掉。放逸。天爱汝知至不知术。此中何者为术忘念。心乱。不了别。不正思惟。邪相了。此法已属大地。不可重安立为惑大地。如无痴于善大地。彼亦如此。若念彼染污。说为忘念。定被染污。说为心乱。所余亦尔。是故作如此说。是大地法可即立为惑大地不。此中有四句。第一句谓受想作意欲触第二句。谓无信懈怠无明掉放逸。第三句。谓念等五法。第四句。谓除前三句。所余诸法。复有诸师。欲心乱异邪定。于彼所说。四句异此。有余师执无安与一切惑相应。于惑大地中不说。于谁有失。彼答应说。由随顺定故。是故不说。何以故。若人无安为行。修观速能得定。掉行人不尔。以无安为行。非掉为行。此人何相。以掉为行。非无安为行。此人何相。何以故。此二法随便不舍。共生事故。虽然此二法。于人随重成此人行。是故立六法为惑大地。何以故。此六法恒于染污心起。余处则不起。偈曰。若恶。及无羞无惭。释曰。于一切恶心。无羞及无惭。恒生起故。立此二法为恶大地。此二法相后当说。偈曰。嫌恨谄嫉妒。佷覆及悭吝。诳醉并逼恼。是十小惑地。释曰。以小惑为彼地故。说彼为小惑地。唯与修道所灭。依心地所起。无明相应故。此十惑于小分烦恼中当释。说五品心法已。有余心法不定。谓觉观恶作睡等。于中应说。何处心几心法。必定俱起。于欲界中有五种心。善心有一。恶心有二。谓独行及与余惑相应。无记心有二。谓有覆无覆此中欲界心。必有觉有观。是故于中。偈曰。有觉有观故。于欲界善心。二十二心法。释曰。必定俱起。何者二十二。十大地。十善大地。并觉观。偈曰。或处长恶作。释曰。非于一切善心皆有恶作。是处若有。于中为长。则心法成二十三。何法名恶作。于所作恶心生后燋。此心法缘恶作起。故名恶作。此法即是后燋。譬如缘空为境解脱门说名空解脱门。又如无贪观缘不净相起说名不净观。于世间亦曾见此事。由处说有处。如言一切县郡来。一切土地来。此恶作是后燋处。或于果假立因名。如说六种触入名宿业。若尔此后燋。若缘所未作事。云何名恶作。于未作假立作名。如经言。若我不作非我好作。何者后燋名善。由不作善及已作恶故后生燋。是善后燋。翻此名恶后燋。此二各缘二境起。偈曰。于独行恶心。见相应二十。释曰。于独行欲界恶心。有二十心法俱起。谓十大地。六惑大地。二恶大地。并觉观。独行心者。此中唯一独行无明。无有欲等余惑。不但独行恶心。若与见相应恶心中。亦有二十心法。如独行恶心中诸法。若尔由长见故。云何不立二十一。不然。是大地所摄智慧差别说名见故。此中与见相应恶心。于此心中若有邪见见取戒执取。偈曰。与四惑嫌等。恶作二十一。释曰。此恶心与四惑相应。谓欲嗔慢疑。此心中有二十一心法。此惑随一。并独行恶心中所说二十。若与嫌等小分惑相应心中。亦有二十一心法。小惑随一并前二十。若与恶作相应心中。亦有二十一心法。恶作为一。并前二十。若略说于独行恶心及与见相应恶心。但有二十。若与余惑及小分惑相应。有二十一。偈曰。有覆心十八。释曰。于欲界与身见边见相应。名有覆无记。此中有十八心法。大地十。惑大地六。并觉观。此二见如前所释故无长。偈曰。余无记十二。释曰。与有覆无记异。即是无覆无记。此中有十二心法。大地十。并觉观。罽宾国外诸师欲恶作无记。于此诸师。若心与恶作相应。有十三心法。偈曰。睡遍不违故。若有唯此长。释曰。睡与如前所说一切心法不相违。由是善恶无记性故。于五品心中随若有此应知为长。若二十二。并睡成二十三。若二十三。并睡成二十四。如此等于欲界中。是所说心法定量。偈曰。恶作睡诸恶。于初定皆无。释曰。于如前所说中。恶作及睡。初定一向无诸恶随一。譬如嗔离谄醉诳。谓嫌等及无惭无羞。悉无所余一切皆有此诸法。于初定不有。偈曰。于中定无觉。释曰。此法及觉。于中间定。亦如此无。所余亦如此有。偈曰。过此又无观。释曰。度中间定以上。于第二定等乃至无色界。如所遮皆无观。及谄诳亦无。所余皆有。何以故。此谄曲。佛说乃至极大梵处与梵众相应故。上去则无。此梵王于自大集中。阿输实比丘问。是四大何处灭无余。梵王不解。作诡言答。我是大梵自在。作者化者起者。一切所有我为本因。说随地如心法数量义已。如毗婆沙中所立。心法及异相今当说。无羞与无惭异相云何。偈曰。无羞不重德。释曰。于功德及有德人不尊重于他无自在心。无敬畏心。无随属他心。说名无羞。此心对治尊重。偈曰。非赞不见怖。无惭。释曰。非赞谓若事善人所诃。是名非赞。于中不见怖。是名无惭。此中怖谓非所爱果。能生怖畏故。云何得知。如此为不见怖名不见怖。为见不怖名不见怖。若尔何为。若不见怖应成无明若见不怖应成智慧。不见怖者。我不说不见。亦不说见。何者为是。有小惑为此二因。说名无惭。有余师说。观自身由过失不耻名无羞。观他名无惭。若尔二观一时云何得成。不说如此一时观自观他。何者有非耻类。若观自身生起。说名无羞。有非耻类。若观他生起。说名无惭。翻此名惭羞。由第一解。显有尊重有自在有敬畏有随属名有羞。于非赞见有怖名有惭。由第二解。显观自他生起耻心说名惭羞。爱乐及信此二异相云何。偈曰。乐名信。释曰。爱乐有二种。一有染污。一无染污。此中若有染污名爱乐。如于妻子等。若无染污名信。如于自师尊长及有德人处有信非爱乐。是信缘苦集起。有爱乐非信。谓有染污爱乐。有具二。谓缘灭道生信。有非二。谓除前三句。有余师说。信谓于德决期。以此为先后则生爱。故信非爱。复有余师说。偈曰。重羞。释曰。如前说。以重为羞此何相。不即重名羞。于他起自在心名重。以此为先后则生耻。说耻为羞。是故尊重异羞。偈曰。欲色有。释曰。于无色界无爱乐及尊重。此义云何。信及羞是善大地故。于彼既有前二。云何无羞。信有二种。一信法。二信人。尊重亦尔。信及羞。若缘人起。彼处则无。此二名爱及重。觉与观异相云何。偈曰。觉观谓粗细。释曰。粗细属何法。谓心粗细。心粗名觉。心细名观。此二于一心云何俱起。此中有余师说。譬如酥浮水上。于上为日光所触。非凝非释。如此由觉观相应故。心不过细。亦不过粗。是故此二于一心中俱有事用。若尔此觉观。但是粗细因。非自粗细。譬如水及日光。是酥凝释因。非自凝释。粗细由观他成。由地品类差别故。乃至有顶应有觉观。复次同类生以粗细为差别。此义不应成。是故不可由粗细分别觉观性异。有余师说。言语行名觉观。如经言。已觉已观方有言说非未觉未观。此中若粗名觉。若细名观。若于一心中。有别法名粗。有别法名细。此有何妨无妨。若有种类差别于一生类中。下上二品不得俱起。种类亦有异。若尔汝今应说。此不可说。是故由上下品种类异。则可显示若尔则不可显示。各各自种类有上下故。有余师说。觉观于一心不并起。若尔云何。初定说具五分。约地说五分。不由刹那。慢与醉异相云何。偈曰。心高说为慢。醉爱着自法。心起变异乱。释曰。由随类所分别胜德。心高于他说名慢。醉者此人于自法起爱着。其心乱味。如饮酒惛迷。心欢喜差别。从贪欲生说名醉。余师说如此。说心法与心共别异已。如是等法。佛世尊假立众名。于正法中。由此说教故。云何释异。偈曰。心意识一义。释曰。心以增长为义。能解故名意。能别故名识。善恶诸界所增长故名心。或能增长彼故名心。此心为他作依止说名意。若能依止说名识。如心意识三名一义如此。偈曰。心及余心法。有依境界相。相应。释曰。此四种名亦通一义。此心及心法。或说有依由依根起故。或说有境。皆能取境故。或说有相。是所缘境随类差别能分别故。或说相应。平等聚集故。云何平等聚集名相应。偈曰。义有五。释曰。有五种平等类为相应义。谓依止境界取相时物平等等。何法为物平等。如心一物。如此心法亦各各一物。说心及心法广义及差别义已。偈曰。不相应诸行。至非至同分。无想处二定。寿命及诸相。名聚等。释曰。如此等有为法。与心不相应。非是色性。说名不相应行。偈曰。于中。至得及同随。释曰。得有二种。谓未至得已失得。与正得同随。翻此名非至。义至自成。此至非至属何法。偈曰。至非至属带。自相续。释曰。若法堕他相续。无至非至。何以故。无众生与他法相应。及与非堕相续法相应。何以故。无有众生。与非众生数法相应故。于有为法如此决定。若于无为法至非至云何。偈曰。二灭。释曰。一切众生皆与非择灭得及同随相应是。故于阿毗达磨藏说如此言。何者与无流法相应。答一切众生。亦与择灭相应。除具缚及住初刹那人。所余一切圣人。及所余凡夫。皆与择灭相应。无众生与虚空相应。于虚空何故无非至。若法无至。非至亦无。所谓别法。有别法名至非至。此执从何生。从经生。何以故。于经中说。是十种无学法。由生由得由同随。是圣人与五分相离。若尔与非众生数法至得亦应成。何以故。由经言。比丘。转轮王与七宝相应。谓得同随。此经中说自在名得同随。何以故。是王于宝有自在。谓如意作。于转轮王经。汝执自在名得同随。于彼经汝执别物名得同随。此执何证得成。此中何执非道理。是非道理。此至非至自性不可知譬如色声等又如欲嗔等。其事亦不可知。譬如眼耳等。离实物法故。立此法为有。则非道理。若汝执此至是诸法生因。于无为此法应无。若法未至及已舍。由易地及离欲。此法云何更生。若汝说共有至得为生因今立生相。复何所作及生生。若此即是生因。具缚众生下中上惑生差别。不应有至。无差别故。若由此法余法。有差别生可从其起。是故至非生因。有何人说此言。谓至为生因。汝说云何成立差别因。何以故。此至若无。圣人及凡夫。若同起世心。此人是圣。此人是凡。此差别不可成立。已灭未灭惑有差别故。圣凡差别自成。是义不然。何以故。此差别云何成。此人惑已灭。此人惑未灭。若信有至。如此等事则成。由至非至永灭离故。此事由依止差别故成。诸圣人依止。由见道修道胜力故。如此回转。如不应更生二道所灭诸惑。譬如火所燋种子。依止亦尔。不更为惑种子故说惑已灭。惑由世间道。损坏惑种子相续中。说惑已灭。翻此名未灭。若法未灭。与此法至得相应。若此法已灭。则无至得相应。此言唯是假说善法有二种。有不由功力生起有由功力生起。是法说名生得及修得。此中不由功力所生起善。于依止中善种子不破坏故。说与至得相应。由种子破坏故。说无至得相应。如断善根人。此人相续中。由邪见应知善种子已破坏。于彼相续中。善法种子非永除灭。若善法由功力所生起。由彼正生故。于彼生中相续自在无碍故。说与彼相应。是故此种子。未拔除非破坏。增长自在时。此种子得至得名。无别物。何法名种子。是名色于生果有能。或现时或当时。由相续转异类胜故。何法名转异。是相续差别。谓前后不同。何法名相续。生成因果。三世有为法。何者为胜类与果无间有生果能。有处说如此。若人与贪欲同随。则无复能修习四念处。此经中安受贪爱说名同随。何以故。此人随安受贪爱时量。无有功能。修习四念处。如此至得同随一切种皆是假名法。非实有物翻此名非至得同随。毗婆沙师说此。至非至实是有物。何以故。我等悉檀说如此。彼说此至。偈曰。于三世三种。释曰。过去诸法。有过去至。有未来至。有现在至。如是未来现在诸法。各有三至。偈曰。于善等善等。释曰。若法善恶无记性。至亦次第随法同善恶无记性。偈曰。随法界同界。释曰。若法随与界相应。至得与法同界。若法在欲色无色界。彼至得亦同。在欲色无色界。偈曰。离三界四种。释曰。离三界法。谓一切无流法。此无流法至得。若略摄有四种。谓三界相应。及无流界相应此中非择灭至得有三界。择灭至得。或在色无色界及无流界。道谛至得。唯是无流故。此至得若略摄。成有四种。有学法至得是有学。无学法至得是无学。非学非无学法至得有差别。偈曰。非学无学三。释曰。非学非无学法。谓有流及无为。由有学等差别。此法至得成三种有流至得。谓非学非无学法。及非圣人所得非择灭择灭至得。是择灭学无学道所得。此至得亦是学无学。见修二道所应灭惑至得。次第应为见修二道所破。若非二道所灭法至得。则有差别。今当说。偈曰。非所灭二种。释曰。非所灭法。谓无流法。此中非择灭至得。唯修道所断。及非圣人所得择灭至得。圣人所得择灭至得。唯是无流故非所灭。道谛至得亦如此。前说于三世三种。此是总说。为简别此总说故说此偈。偈曰。无记至俱起。释曰。若无覆无记法至得。但有现在。无过去未来。此法力弱故。此法若过去。至得则过去。此法若现在。至得则现在。一切无覆无记至得。皆如此耶。偈曰。除二通变化。释曰。二通慧是无记。变化亦尔。除此三所余悉同。此三势力强故。由加行胜类成就故。故此至得通三世。工巧处无记。及别威仪无记。极所数习。有余师欲此至得同三世。唯无覆无记至得但现在耶。偈曰。又覆无记色。释曰。有覆无记有教色至得但现在。何以故。若最上品不能起长无教色故。是故力弱。如无记法至得有差别。善恶法至得。为有如此差别不。答有。偈曰。欲界色无前。释曰。于欲界色过去一向无至得。现在及未来皆有至得。如至得非至得。亦有如此差别不。答无。何者。偈曰。非至无污记。释曰。一切非至。唯无覆无记。约世差别。云何。偈曰。去来世三种。释曰。现世法非至得但现世。若过去未来法非至得。各有三世。偈曰。欲等无垢有。释曰。亦有三种非至。欲界法非至得。或在欲界。或在色无色界。如此色界无色界无流界。非至得亦尔。无有非至得是无流。何故如此。偈曰。许圣道非至。凡夫性。释曰。如发慧阿毗达磨藏说。何法名凡夫性。非至得圣法。非至得即是非至。若非至圣法。是凡夫性。凡夫性不应成无流。不得何圣法。一切圣法不别说故。非至得者。离实有得。若不尔。佛世尊与声闻独觉性不相应故。应不成圣。若尔应作决定说。定非至得圣法。不应说定言。何以故。是直文句能为决定。譬如说人食水食风。有余师说。不得苦法智忍及俱起法。名凡夫性。亦不可说由舍此还成凡夫。何以故。此苦法智忍。及俱起法。非至得永灭除故。若尔苦法智忍。及俱起法。亦有三性。非至得何法。一切。若尔如前难过失更至亦如前救。若尔立文句之功此复何用。若立如此则为最胜。如经部师所说。经部执云何。若未曾起圣法相续。名凡夫性。复次此非至云何。灭是法是非至得。偈曰。由至度余地则舍。释曰。如非至得圣道名凡夫性。由至得圣道。即舍凡夫性。或由度余地。所余诸法非至。应如此思。非至非至若生起。非至至若断。说舍非至。非至及至。为更有至非至不。此二各各有二。若尔于至非至。有无穷过失。无无穷过失。更互相应。故法若生以自体为第三生。第一本法。第二本法至得。第三至得至得。此中由至得生相续。与本法相应。及与至得至得相应。由至得至得生相续。但与至得相应。若作如此是本法以自体为第三。若善若染污。于第二刹那有三至得生。复有三同随至得俱生。合成六。于第三刹那第一第二刹那所生诸法。有九大至得。共同随至得。成十八物。如此后后增长生故。诸至得流。一切过去未来。大惑小惑刹那。一切生得善刹那。共相应及俱生法至得。无始无终轮转生死众生中。随一众生。刹那刹那起成无边物。随一一诸众生身。相续刹那亦如此。今诸至得。最大集会希有生起。唯有一德。谓不相碍。故得处所。若不尔。于一人虚空亦非其器。何况第二。何法名同分。偈曰。同分众生等。释曰。有物名同分。谓众生等类。于阿毗达磨藏说此。名谓聚同分。此有不异异。不异谓一切众生与众生同分。随一众生同分。于一切众生悉有故。异谓是一切众生同分。由界地道杂生男女优婆塞比丘有学无学等差别。各不相应故。亦有法同分。由阴入界等故。不异如前。若无聚同分。非别有实物。于众生由种种别类更互不同。此亦众生。彼亦众生。如此同智。及同言说。不应得成。阴等同智及同言说亦尔。有退亦生。不舍聚同分。不得同分。不立此成四句。第一句者。从此退于中更受生。第二句者。入正定聚。何以故。此人舍凡夫聚同分。得圣人聚同分。第三句者。由度余道。第四句者。除前三句。若有实物。名凡夫同分。何用别立凡夫性。何以故。若离人同分。无别人性可分别。复次世间亦不曾见有人同分法。以无色故。智慧亦不能分别众生生类不异。但许如此众生同分。若实有。于中何所能作。复次云何不许非众生有同分。如舍利谷麦豆波那婆庵罗铁金等。自性类等故。如此等同分更互有异。云何可说不异同分。若尔鞞世师外道。由此执得显成。何以故。此执即是鞞世师悉檀。彼立六句义中。此执是同异句义。由此法于不同物中生起同智。说名同异。毗婆沙师说。彼执有异。彼谓同异唯是一物遍在多物。众生同分则不尔。若显成若不显成。实有同分。由经所证。佛世尊说。若此人还成此类。谓于人聚同分实有如此说。非说别有物。若尔此经所显同分是何法。是有为法。如此生起。于中假说人天等。如说舍利谷等同分。如此义非毗婆沙师所赞许。何法名无想有。偈曰。无想于彼天。能灭心心法。释曰。于无想众生天中受生。有法能遮灭彼心及心法。此说名无想有。由此法心及心法。于未来中暂时不起。于生无有功能。如堰遏江水。此法一向。偈曰。果报。释曰。此是何业果报。无想定业于何处众生有此无想天。偈曰。诸广果。释曰。有诸天名广果。于彼一处有众生名无想天。如初定中间。彼众生为一向无想。为或暂一时有想故名无想。有时有想。谓受生时退堕时。于长时起想故。彼众生从此处方退堕。经言如此。于彼众生如久时熟眠觉起。即便退堕。必欲界受生。更无余处。由宿世定业功能尽故。不能生长未曾有业故。譬如放箭速疾势尽故即便堕地。若众生必应生彼天。此众生定有欲界后报业。譬如北鸠娄必有生天后报业。阿毗达磨藏说。何者为二三摩跋提无想定及灭想受定。何法名无想定。如前所说。无想有能灭心心法偈曰。如此无想定。释曰。无想观行人。定名无想定。又此定无想。名无想定。此定能遮灭心及心法。是如此言所引。此定在何处。偈曰。后定。释曰。最后定。谓第四定最上品。此定于中相应。非于余地何用修此定。偈曰。欲解脱。释曰。诸外观行人。执此定为决定出离。是故由求解脱故。修习此定。无想有是果报故。成无记法此定偈曰。善。释曰。此无想定一向是。善此定于无想天五阴为果报。若善于三报位中是何位。偈曰。必有生报。释曰。此定唯生报。非现报及后报。亦非不定报。若人已生起此定。后更退失。彼说此人必还更得受无想天生。是故若人得此定。必不得入正定聚。此定但凡夫所得。偈曰。非圣。释曰。圣人不得修习此定。彼见此定如见深坑。何以故。若人于此定起解脱心乃修此定。圣人于生死不起解脱心。圣人若已得第四定。为于过去未来得此定。不犹如诸定非圣亦不得。何以故。此定若已曾数数所习。大功用所成故。又无心故。偈曰。一世得。释曰。但一时得。谓现在得。如波罗提木叉戒。得此定于第二刹那有过去至得。乃至未舍此定。无心故于未来无修。今灭心定其相云何。偈曰。灭定亦如此。释曰。如无想定。无心定亦如此。如此言引何义。能灭心及心法。此二定异相云何。此定偈曰。为静住。释曰。寂静住想为思惟先故。圣人修此定。彼定解脱想为思惟先。彼与第四定同地。此定偈曰。有顶。释曰。此定以非想非非想为地。此定偈曰。善。释曰。此定必是善。无染污故。非无记。虽复是善。偈曰二报不定。释曰。此定由二因有二报。或生报或后报。有时于果报不定有时无果报。若得定人般涅槃。此定于有顶以四阴为果报。此定一向。偈曰。唯圣。释曰。但圣人能得此定非凡夫。何以故。凡夫不能得修此定。怖畏断绝故。又由圣道力所生起故。云何如此。于中生现世涅槃愿乐故。此定虽是圣人所得。非离欲所得云何得。偈曰。由修得。释曰。此定由修习力得。非过去得。未来不可修。由心力强故成。若尔于佛世尊。亦由修习得耶不。云何。偈曰。菩提得。释曰。诸佛世尊。与尽智同时得此定。何以故。诸佛无有一德由功用得。由一切圆德现前。皆随佛欲成故。是故一切功德。于佛悉是离欲所得。若尔先未生灭心定。于尽智时。佛世尊云何成俱解脱人。得成如于已生。此中得自在故。西国诸师说。菩萨在有学位。先已生此定。后方得菩提。云何不许如此。若尔与大德优波掘多所造道理足论。彼顺成证。彼论说。先已起灭想受定。后方得尽智。应说如来如此。偈曰。非前。释曰。罽宾国毗婆沙师说。先入无心定后得尽智。是义不然。何以故偈曰。三十四念得故。释曰。彼说三十四心刹那中菩萨得无上菩提。在四谛观有十六心刹那。于离欲有顶有十八心刹那。为除有顶九分惑。由修九品次第道九品解脱道故。合此心足三十四刹那。菩萨先已离欲无所有处。后方入正定聚。下地诸惑不复更除灭。是故于此中间不同类心不生起故。无道理得入灭心定。此何所为。若于中间不同类心生起现前。有更起心。诸菩萨无更起心。实如此无更起心。不由无流道不更起。若尔立不更起。云何佛说。我未坏金刚座。乃至未得诸流尽。如此意无改故。是故说无更起。于一坐时一切事究竟故。此义如前。是外国诸师所说。若此二定。多种别异相。偈曰。二依欲色。释曰。此二定。谓无想定无心定。依欲色二界修得。若人不许于色界修得无色定。是伽兰他。于此人相违。或时色有不成有。此中有五种判。一色界众生。二有想诸天。住于不同分心。三入无想定。四入无心定。五无想诸天。已得无想天生。各是彼有。由此文句。是故此二定。决定依止欲色二界。此中是二定差别。偈曰。灭定初人道。释曰。此灭心定。初于人道中修得已。昔经退人后方于色界修得。于灭心定为退不说有。若不尔。则与大德优陀夷经相违经言净命。有诸比丘。在正法内。具清净戒。具清净定。具清净慧。是人数数入观。修灭想受定。数数出观。则有是处。应如实知。此人于现法。先若不得知已根。及于临死时。由身破灭故。过段食诸天。随一意生诸天中。或于中受生。此人于中生已。数数入无心定观。不更出此定。无有是处。应如实知。此中意生天者。世尊说是色界。是定与有顶相应。若人得此定不退。云何得于色界受生。有余部执。此灭心定。以第四定为地。于此部若离退堕。是义亦成。是义不得成。谓无心定。以第四定为地。何以故。由经言故。经说有九种次第定。若有如此决定超越定云何得成此定次第决定。约初学人。若观行人。已至定自在位超越亦得。修如此二定。约地有差别。一以第四定为地。一以有顶为地。复由加行有异。谓解脱静住想。为思惟先所修习故。复由相续有异。谓生在凡夫圣人相续中故。复由果有异。谓无想有及有顶为果故。复由受报有异。谓定受报不定受报。及二受报故。复由初生有异。谓于二界。及于人道初生故。云何此二定。同灭离心及心法为自性。说第一为无想定。说第二为灭想受定。由违逆想违逆想受故。此二修观得成。譬如于他心通中亦知他受等。但说名知他心通。今云何从久久时灭心后更生心。毗婆沙师说。虽复过去。以是有故。是故前灭成后次第缘。有余师说。云何于无色界生众生。色久久时断尽。后时更生色。此色定从心生。不从色生。若尔心亦从此有根身更生。不从心生。何以故。此二更互为种子。谓心及有根身。宿旧诸师皆说如此。大德婆须蜜多罗。于问中说。若人执灭心定无心。此人则有如此失。我今执灭心定有心。大德瞿沙说。此执不然。若识有从三和合有触。佛世尊说。依触生受想作意等。是故于此定中想受等法不应灭。若汝言佛世尊说缘受生爱。今有受于阿罗汉爱不生。如此于无心定虽复有触。受想等不生。是义不然。有简别故。缘无明触所生受则贪爱生起。于生受中不简别触。是故此义不平。是故毗婆沙师说。灭想受三摩跋提。必定无心。若无心云何成三摩跋提。由成立四大平等义。复由三摩跋提心故至此定。此二定为由实物有。为由假名有。彼说实有物。由能遮碍心相续生故。是义不然。由三摩跋提心此心。相续断故。三摩跋提心与余心相违生起。由此心生起。于中间时唯余心不生起为相故。无有别物。此定能引与余识相违。相续为依止故。名三摩跋提。此定唯心心法不起为相若观行人出定。此定先无后无故。此定假说名有为。复次此定唯能令依止如此平等故。名三摩跋提。应知无想有亦如此。此定但心于此位中与心生起相违。此心唯不起。假说为无想。有毗婆沙师不说如此。彼执实有物

阿毗达磨俱舍释论卷第三阿毗达磨俱舍释论卷第四

        婆薮盘豆造

        陈天竺三藏真谛译

    释论中分别根品之三

说二定已。何法为命。偈曰。寿即命。释曰。云何如此。阿毗达磨藏中说。何者为命根。谓三界寿。此非可知。此寿是何法。偈曰。能持身暖及意识。释曰。此偈是佛世尊所说。寿暖及意识。此三舍身时。所舍身即眠。如枯木无意是故此法能持暖及识。为相续住因。说名为寿。若尔有何别法。能持此寿。此暖及识。还持此寿。若尔此三法。互相持起故。于中何法先谢。由此法谢余法后谢。若执如此。应立三法恒起无谢。是义不然。此寿以业为持。如业所引。相续随生住故。若尔是暖及识。何故不许以业为持。勿执诸识从始至终皆是果报。若尔此暖应以业为持。此识应以暖为持。如此于无色界识应无持。以暖触无故。此识于彼以业为持。君不可随意作。或说暖为识持。或说业为识持。汝前已许何所许。勿执诸识从始至终皆是果报。若尔是故唯有寿于二为持。我亦说此不无但非别实物。若尔汝立寿是何法是。三界业所引聚同分住时。何以故。此聚同分。速疾随宿业所作。谓应住如量时。是聚同分。得如此时住。说名为寿。譬如稻等所引熟时。又如放箭所引住时。若有人执。有别德名速疾。生在箭上。由随此德故。箭行乃至堕。时于此人是德由唯一故。及无碍故。于余处急缓至时。差别不应成。若汝说由风此德有碍。是义不然。放时即应堕。或无堕时。风不异故。毗婆沙师强说如此。此寿有实别物。今为但由寿尽死。为别由余法死。于假名论中说。有死由寿尽死由福尽。此义有四句。第一句者。感寿命报业尽故。第二句者。感富乐报业尽故。第三句者。二业俱尽故。第四句者。由不离不平等事故。若寿命已尽福业尽。于死有何能。于福业尽死中。寿命尽亦尔。是故于二尽死。是名俱尽死。又于发慧论中说。为应说寿随相续起。为一起便住。彼答欲界众生。不入无想定无心定观。应说寿随相续起。若入二定观。及色无色界众生。应说寿一起便住。此答显何义。若由依止伤害。寿亦被伤害。此寿随相续起。此是第一句义。若寿依止不可伤害。如起便住。此是第二句义。第一句显有障碍。第二句显无障碍。罽宾国师判义如此。是故有夭抂死。于经中说。众生所得身有四种。一有众生。身于中自害得行。他害不得行。此义有四句。唯自害得行者。于欲界中如戏忘诸天恨污诸天。此二天由重喜恨。从此处退堕。不由余缘。说诸佛亦尔。由自死故。唯他害得行者。如在胎卵中身。二俱害者。于欲界多。非二害者一切中阴众生。色界无色界欲界随一。如地狱比鸠娄。在见谛道慈悲灭心定无想定观。王仙佛便佛所记。达寐罗郁多罗强耆罗长者。儿耶舍俱摩罗时婆等人。一切。后生菩萨母。菩萨在胎时。转轮王。转轮王母。王在胎时。于此中俱非二害。复次于经中云何说此言。婆檀多于何众生。自害不行。他害亦不行。舍利弗非想非非想受生众生。诸师解。于余定及余无色处。自害谓依自地圣道。他害谓依上地近分定。于中无此二。若尔依余地圣道。于彼应成他害。若不尔其义云何。或由取后兼显前。或由取前兼显后。取前兼显后者。如经言。如梵众天是第一乐生天。取后兼显前者。如经言。如光曜天是第二乐生天。于彼经如言显譬喻义。是故于彼经此义可然。谓取前兼后。取后兼前。何以故。是譬喻法。由显一类。所余类例可知。此舍利弗问中。无有如言。是故不可引彼经为此经证。若汝执显譬喻。是如言义。则此经中。不应有如言。经言有诸众生。身有别异。想有别异。如人及随一诸天。是故应知。如言唯为显不为譬。勿过多言。说寿命已。偈曰。复有有为相。生老住无常。释曰。有为法唯此四相。若于法中有此四相。应知此法是有为。与前相翻则是无为。此中生者能生此法。住者能安立此法。老者能变异此法。无常者能灭此法。为不如此耶。如经言。有三种有为法有为相。若具言。于经中应说第四相。此经中不说。何相谓住。若尔此经中说何法为住异。此住异是老别名。譬如起是生别名。灭是无常别名。住异亦尔。是老别名。若诸法能起。唯为有为法行于世。此法于经中说是有为相。为起他厌怖心。何以故生者。从未来世。能引有为法令入现在世。老及无常能损其力。从现在世遣入过去世。譬如有人在棘稠林中。有三怨家。一能于稠林中牵令出外。二能损其力。三能断其命。三相于有为亦尔。住者摄持有为法。如欲不相离。是故不立此住为有为相。复有无为法。于自相住故。住相相滥。有余师执。此经中住与老合为一故说三相。何用如此。此住于有为是爱着依止故。佛显此住。如吉祥王位与灾横相应。为令他于中不生爱着。是故有为定有四相。复有生等四相有为故。更有别生等四相不。说有。偈曰。生生等彼相。释曰。彼言显四本相。由诸法有本相故成有为。本相亦尔。由随相故成有为。故立本相更有四随相。谓生生住住老老无常无常。若尔随一一相应更有四相。则有无穷过失。此随相更立别相故。无有无穷过失。何以故。偈曰。诸八一法事。释曰。如此诸相于八法有事。何法名事。功能人功。生生等诸相。唯于一法有事。云何如此。一切有为法。若生取自体为第九。共本相及随相八。此中生者。离自体能生八法。生生者唯生本生。譬如雌鸡有生多子。有生一子。二生亦尔。住者离自体能安立八法。住住者唯安立本住。如此老及无常。如前义应合之。是故无有无穷过失。经部师说。此执即是破虚空事。何以故。生等诸法非实有物故。如汝所分。云何得知。非实有物。无量证故。于四相实有物中无随一量。谓证量比量圣言量。譬如于色等诸法。若尔经中云何说。有为法者。若生可知。及灭住异可知。天爱汝今能诵伽兰他。不解伽兰他义。佛世尊说。义是量非文句。何者为义。无明所盲凡夫众生有为法相续。执为我及我所。于中生爱着。世尊为除彼爱着心。欲显行法相续是有为相及缘生相。故说此经。经言有三种有为法有为相。非为显一刹那有为四相是实有物。若法不可知。不堪立为相。是故此经中说。有为法若生可知等。经说重有为名。为令他知此相显有为性。勿如此为显有为法类。是有故立四相。譬如于水白鹭。及于好恶童女相。此中相续。初起名生。终谢名灭。此相续流名住。前后差别名住异。佛世尊显示此义故。约难陀说。难陀。善男子。善知受生。善知受住。预善知受谢灭尽。此中说偈

  生谓相续初　　断名灭续住
  住异此相续　　是前后差别

复次偈曰

  非曾有名生　　住相续无常
  相续断住异　　相续前后异

复次偈言

  若法刹那灭　　离住即便灭
  此常灭是故　　分别住非理

是故定以相续为住。若执如此义。是阿毗达磨藏释言。则与道理相应。阿毗达磨藏云何者为住。已生有为法不灭。此义云何。何以故。刹那灭法。已生无不灭发慧论中说。于一心中何法名生。谓初起。何法名灭。谓死。何法名住异。谓老。此论文中。但是聚同分一心。于此心中是如前。复有别释。于刹那刹那有为法中。此义亦成。离分别有别物。云何成。随一一刹那。未有有名生。有已不有名灭。前前后后刹那相应名住。此彼不相似名住异。若尔有法生不异此义云何。虽复如此。不无别异。云何得知。掷不掷强力掷弱力掷。金刚等物。久速落时有差别故。是彼四大变异差别则成。诸有为法。不由大差别异。虽复别异显现相似。若尔是最后声。及光明刹那。于涅槃时。是最后六入。后刹那无故。无有住异相。是故立此为相不遍有为。若不说住为有为相。何者谓住异。若法有住。此法必有住异。是故立无不遍。于此经中若略说。此经中世尊所显有为法相。必如此。经云。有为何相。若先未有今有。有已更不有。此法相续名住。此相续前后不同名住异。于中何用立生等物。云何此法是所相即立为能相。大人相与大人不异。云何立为相。壶尾领蹄角于牛成相。与牛不异。复云何立为相。譬如坚实等。是地等大相与地不异。又如上升为烟相。由此相故。远处知烟。此相与烟不异。于有为相道理亦尔。色等有为法。不由有故。有为相可相。若人已了别自性。乃至未解先无后有相续差别相。是故由此相。不可相有为性。复次诸相。于有为法非别有实物。若强执生等诸相别有实物。更何非理义而应剧此。何以故。是一法于一时正生正住正老正灭。云何为正。诸相共起故。是义不然。由功能差别故。生者正在未来世。得作功能。云何知。由法已生。不可生故。若法生所生已。住等正在现世。得起功能。是时法生。非是时中住老无常。此义应共思量。未来法为有为无。后能生不能生。此义应成。若此法有于中生作功能。此法云何成未来。应说此法未来相。功能已谢体已生。云何成现在。亦应说现在相。住等俱在功能中。于一刹那此法住老灭相俱成。何以故。是时住正安立此法。是时老变异此法。是时无常灭此法。于一时此法为是住为是老为是灭。有余人说。住等诸相功能次第不俱。于此人则失刹那灭义。若汝说我立刹那。如此四相功能成名一刹那。若尔住与余二俱起。先暂安立法老不变异无常不灭。此义云何成。由作力强故。云何住有强力。犹无常灭。住并本法住已起功能不能更起。犹如生生不更起功能。此义应理。何以故。应生法生已引至现在。无更引义。是义可然。此法住所安立。可永安立。若不能安立则非道理。何法为碍。老无常是碍。若此二有力。应在前成。若住功能已谢。此二亦不住。本法亦尔。云何作功能。何处作功能。此二更有何别事可作。何以故。由住所摄故。法唯生则不灭。若住所舍必定不住。即是此法灭。是故此二无事可作。此义假设可然。是一法已生未灭立名住。灭名无常老。于一法中一切种不可成。何以故。老谓前后不同及变异。从此法此法异类不应成。此中说偈

  若如前无老　　若异非前法
  是故于一法　　老相不得成

有余部说。至灭因缘无常能灭本法。于彼部此义应至。谓服下药天来令利。何用分别无常。从此灭因自足立灭。心及心法由信刹那灭。此心及心法无常相。不观灭因缘故。住及无常非于别时俱作功能故。一法于一时中。应立住灭俱成。是故约相续。世尊说有为法相若依此义。彼经善立。复次若生在未来能生应生法。云何一切未来法。不一时俱起由此义偈曰。生能生应生。不离因及缘。释曰。若离因缘和合。生不能生故。未来法不俱起。若尔我等见此是因缘功能。若有和合生有故。若无不有故。则生不能生应生法。是故应许唯因缘能生。若一切有云何可知。谓此法已生此智不应有若生实无。复次相应言。亦不应成。谓色家生。若如汝所执。应说色家色。乃至老死如理应次第说。若尔是故汝应许无我义亦尔。数量各合离此彼有性。如此等事外道所立言实有物。汝等亦应信受。何以故。为成一大小别聚散自他有物等智故。又成就相应言故。如说色聚。此相应言云何成是色自性。是故此生等唯假名立。为显未有有义故。假说名生。此生先未有。今有为相。有多种类。为简别种类异故。约色说生作相应言。谓色生为令知此生但色非余。如说旃檀香等。又如石子体。如前所论。生住等如理应知亦尔。若法离生相得生。云何空等无为法不生。汝解不生者。未有有是名生。无为恒有。云何得生。若由法尔。汝许一切法无生如此则一切不生。云何不执如此。如一切有为同有生。有余因缘为生。别法无有功能。如此一切因缘为生。无为无有功能。由于生不同。是故毗婆沙师说。生等四相。实有别物。何以故。不可由有难者故弃背诸阿含。如为有鹿故而不种麦。又如为多蝇附故而不啖果。是故于过失中应起对治。如本悉檀。随顺修行

说八相已。何者为名聚等。偈曰。名句及字聚。号言文总集。释曰。此中名谓所立号。如色声等。句谓所立言。随量能成就所欲说义。如有为皆无常。如是等。若由此言事得时相应差别显现。此言称句。如偈言善友一时遇。字谓无义文。如阿阿伊伊等。为不如此耶。字者书类分名。君不为显书类分故造立字。为显字故造立书类分。若不闻说字。此字由书方便云何应知。为令知故立书类分。是故字非非书类分名。是名等三各总集称聚。此中名聚者。如色声香味触等。句聚者如一切有为无常。一切法无我涅槃寂静。如是等。字聚者如迦佉伽伽饿等。为不如此耶。此名聚等。言说为体。即是音声性属色自性。云何说是心不相应法。此法不以言说为性。何以故。音声即是言说。不由唯音声诸义可解。云何可解。音声起于名。名能显示义。君不唯音声称言。若由此音声义可了知。此音声则称言。由何音声而义可解。若说者于义中已共立定法。譬如瞿音声。于九义已立定法。如尼六多论偈说

  言方地光牛　　金刚眼天水
  于此九种义　　智人说瞿名

若人作如此执。谓名能显义。此人亦应信受此义。若名于义已定显立。若以名显义。由唯音声于义定立此用得成。何用立名实有别法。此义不可知。云何音声起于。名为音声生名说。起为显名说。起若生者言语以音声为自性故。应生一切名。唯音声为体。复次是音声差别。如汝所许。能生起名。唯应此能显义。若显者言语以音声为自性故。应显一切名。唯音声为体。复次是音声差别。如汝所许。能显了名。唯应此能显义。何用执名有别法。复次诸声无有聚集。一法分分生。是义不然。若执言语能生名。云何能生名。云何观过去教色刹那。最后教色刹那能生无教色。若尔于最后声名生故。若人但闻最后一声。是人便应能了知此义。若汝执如此音声生字以字生名。此中同前立难。字无聚集故。若说音声显字。此中亦同前立难。是字异音声。聪慧人安静心约异相亦不能分别。是故不可执音声能生及能显字。复次若汝许。名与义必俱相应。犹如生等。此中过去未来义现世名不应有。云何父随意立子名。云何名与无为法。俱起是故此执不成正术。佛世尊所说

  依名伽他成　　工制造伽他

此中于义所立定法。音声称名别庄饰诸名称伽他。此庄饰即依名庄饰。是制置差别无有别物。譬如物行及心次第。复次唯于字中分别有别物。是字等总集。说为名聚句聚字聚。此但假说无有正用。毗婆沙师说实有不相应行为性。谓名句字聚。何以故。非一切法皆是觉观思惟所能通达。名聚等不相应行。于何界中相应。为是众生名。为非众生名。为果报生。为增长生。为等流生。为善为恶为无记。此问应答。偈曰。欲色众生数。等流无记尔。释曰。名等有欲界相应。有色界相应。亦有说于无色界相应。此不可言说。但思惟依止。此名等即众生名。若人能显此。此人与其相应。非所显义。此名但等流果。是无覆无记。尔言者。如名聚等众生名等流果无覆无记。如此同分亦尔。偈曰。同分亦果报。三界有。释曰。又此亦是果报果。不但等流果。此通三界有。或欲界或色界或无色界有。偈曰。至二。释曰。至得有二种。或等流果。或果报果。偈曰。诸相亦。释曰。生等诸相亦有。二种如。至得。偈曰。二定非至亦。等流。释曰谓无想定无心定及非。至得此三一向是等流果。于中有所余应说所余。谓无想有及寿命。于前已明故不重说。云何说至得为众生名。由说是众生相应故。云何说诸相。有是众生名。有非众生名。与一切有为法俱起故

说一切非相应法已。于前已说偈。谓生能生应生。不离因及缘。此中何法名因。何法名缘。偈曰。随造及俱有。同类并相应。遍行与果报。立因有六种。释曰。因有六种。一随造因。二俱有因。三同类因。四相应因。五遍行因。六果报因。此中随造因相云何。偈曰。除自余随造。释曰。所生有为法。离自体以一切法为随造因。对彼生住不为障碍故。为不如此耶。若人不解诸惑当来应生。由已知故。此惑不得生。此智于彼生中能作障碍。日光于见星能作障碍。云何一切法。离自体于有为法立为随造因。此中应知。正欲起法。不能碍生故。立为随造因。于他生中诸法有能为碍。而不碍故。立为随造因。此亦可然。譬如土主有强力。不为逼损土人。说言我等由此主故得安乐。若土主无力为碍。云何成随造因。又如涅槃及定无生法。于一切法生中及地狱等阴。于无色界阴生中。皆无力为碍。云何成随造因。何以故。若彼非有如有。不能为障碍事。若土主无力亦有如前说。此中是譬此是通说。若胜随造因。非但不遮。亦有能生力。如眼根及色于眼识生中。饮食于身。田等于芽。若有人作如此难。一切法由不能碍故。于他成因。云何一切法生不俱有。于杀生中如杀者。云何一切不共得同罪。此不成难。何以故。由立一切法不能遮余法生故。名随造因。不由能作故立随造因。有余师说。一切随造因。于一切法有功力。譬如涅槃于眼识。云何有功力。以涅槃为境界。意识得生。或善或恶。因此次第方生眼识。由因缘传传。涅槃于眼识亦有因缘分。故有功力。于余法亦应如此知。此是其方。说随造因已。俱有因相云何。偈曰。俱有互为果。释曰。若法此彼互为果。此法遆为俱有因。其譬类云何。偈曰。如大心心法。随心相所相。释曰。譬如地等四大。此彼更互为因。心于随心法。随心法于心。有为相于有为法。有为法于有为相。若立如此义。一切有为如理皆成俱有因。若离更互为果。谓法于随相为俱有因。随相于法则非应。摄如此义。何法名随心。偈曰。心法及二护。彼法心诸相。是名随心法。释曰。随心法者。一切与心相应法。定戒及无流戒。如是等法生等相。此法心家法故。说随心法。云何此法随心生。若略说偈曰。时果善等故。释曰。约时有四种。谓与心俱生俱住俱灭。及于三世中随同一世故。随果者。谓同功力果果报果等流果故。随善等者。若心是善恶无记。心法等随心亦是善恶无记。如此由十种因。说名随心法。此中若心极少。于五十八法为俱有因。五十八者。十大地四十本相。自本相随相八。于此心五十四法为俱有因。除四随相。余师说。但有十四。十大地法自本四相。毗婆沙师不立此义。若立如此。则违分别道理论。论云。有法以身见为因。不为身见因。除身见及身见相应法生老住灭。若有所余染污苦谛。以身见为因。亦作身见因。是所除法。有余师除此文句谓与身见相应法生等相。罽宾国师说。彼师必应读此文句。或由义应忆此文句。若法由俱有因故。因此法必俱有。若法俱有此法或非俱有因。谓于法中随相。此随相于同类。随心法随相于心。此随相于同类。所造有碍色于同类所造色于四大至得俱起于有至得。俱起于有至得。如是等法虽复俱起非俱有因。何以故。非一果一报一流故。此至得与有得法或不俱起。谓或在前生。或在后生故。如此一切今且许之。虽然种子等余法于因果中悉明了。未曾见如此道理。此义应说。云何俱起诸法共一时互为因果。不无此理。譬如灯与光互与影。此义应共详辩。为灯是光因。为先有聚集于灯共光生中成因。此义未可然。何以故。由此道理斯义自现。随有无故。了别因果人。说此因果相。若此法有无。彼法随有无。此法定是因。彼法定是果。俱有诸法中。随一无所余皆无。随一有所余皆有故。因果义成。俱起因果此义可然。互为因果。此义云何由此义。若尔所造有碍色定不相离。于同类更互义亦然。与四大义此又应同。心随相等于心等亦尔。如三杖互有相持力故住。俱起诸法因果义成亦尔。此执须更思量。此三杖为由俱起力故住。为由先聚集力故住。此中亦有别物。谓绳钉地能持。此等有余因。谓同类因等故。俱有因成。同类因相云何。偈曰。同类因相似。释曰。是同类法于同类法为同类因。如善五阴于善五阴为同类因。有染污于染污。有无记于无记亦尔。色是无记。于五阴中四阴非色同类因。余师说如此。柯罗逻于柯罗逻等十位。是同类因。頞浮陀于頞浮陀等。如此离前。一一于一聚同分中为同类因。于所余同类中。是十位于十位亦尔。于外物类亦尔。如麦于麦。舍利谷于舍利谷。如此等应广思量。若有人不许色为色同类因。此文句即违彼人所许意。谓前四大是后四大因。亦是增上缘。一切相似法。于相似中悉为同类因不。说非何为。偈曰。自部地。释曰。自部有五种。见苦所灭乃至修道所灭。地有九种。欲界一四定四无色。此中见苦所灭法。于见苦所灭法中。为同类因。非于余法。乃至修道所灭法亦尔。若彼欲界法。于欲界法为同类因。初定地于初定地。乃至第四定地于第四定地。于所余地亦尔。此同类因非一切法。何者。偈曰。前生。释曰。若同类法前已生。于后法已生及未生。是同类因。若未来定非同类因。此义从何来。从阿毗达磨藏来。彼藏云何者为同类因。前已生善根于后生善根及与彼相应。法于自部自界。由同类因成因。如此若过去于过去现在。若过去现在于未来。应说如此。此亦是阿毗达磨藏文句。彼藏云。若法于此法成因。或时是法于此法不成因不。彼答无时非因。约俱有因相应因果报因故有此言。与前文句不相违。若人执如此。未来诸法于正生位中定成同类因。是故约最后位说此言。谓无时非因。于此人前执不成救义。由此法于正生位前未作同类因后方成因。此问中说。是法若于此法成次第缘。有时是法于此法非次第缘。不由前分别可得说如此。无时非缘。云何说如此。若此法不生。为显二门故说此言。如于彼于此亦尔。如于此于彼亦尔。若尔得何功德。若尔此文显法主非聪慧人。是则此中于前救义。为胜。复次若尔云何说此文。除未来身见及身见相应苦谛。所余染污苦谛。此以身见为因。非身见因。是所除此以身见为因。亦是身见因。除未来身见及身见相应苦谛。应作如此文句。若不作由义应忆知如此文句。若尔此假名论文句云何。将彼论云。一切法于四义中定四义。谓因果依境。此中因谓相应因。果谓功力果。及增上果。依谓眼等相。境谓色等尘若尔同类因。先未成因。后方成因。此义自至约位许如此非是约物。何以故。聚集者是位果非物果。若同类因。于未来世成因。如果报因何所有。于发慧阿毗达磨中。此因应显现。此执未可然。何以故。是同类因有功能能取果与果。此因于阿毗达磨中显现非余。无如此义。何以故。此同类因。由等流果说有聚此果。若未来不相似无前后故。若已生于未生不应成等流。如过去于现世。勿以果前因后故。无未来同类因。若尔果报因。于未来亦不成因。何以故。是果报果。若在因前。或与因俱。非道理故。于未来中无前后故。是义不然。何以故。同类因若无前后。此法相似。于相似法成同类因。更互为因故。更互等流。此执应成更互等流义。此不应道理。果报因不尔。若离前后。亦不可立为更互因果。因果相异故。是故同类因位所成。果报因相所成。是故若于未来不可遮于前。已说同类。谓于自地依何法有此决。但约有流作此决。若无流云何。偈曰。更互有九地道。释曰。同类因义流于非至地。于中间定四色定三无色定。于此九地道谛。更互为同类因。何以故。此道于九地为客故。不属彼界。彼地贪爱不能取此为自境。是故若法同类。虽不同地。得作同类因。此同类因生何品果。偈曰。于等胜果。释曰。此为等品上品果因非下品果因。如苦法智忍为未来苦法智忍同类因。或为上品道乃至无生智同类因。若无生智但为无生智因。无余上品故。见修无学道。为三二一同类因。此中钝根道。亦为钝根道利根道因。利根道但为利根道因。如信行信解脱时解脱道。或为六四二因。法行见至非时解脱道。或为三二一因。云何下地道于上地道。或等或胜。一由根二由因增长。此中见道等下下品等。于后后由因增长胜。若于一相续中。信行法行道不得俱有。若已生于未生为因。为唯道于等胜果作同类因。为更有余法世间法亦尔。偈曰。学得于二尔。释曰。不但无流法为等胜果同类因。学得有流法于二果亦尔。或为等果同类因。或为胜果同类因。非下类因。此学得是何法。偈曰。闻思等诸法。释曰。此法加行所得。谓闻德思德修德。为等品胜品果因。非下品因。如欲界闻慧。为欲界闻思慧因。若思慧但为思慧因。无修慧故。色界闻慧。为闻慧修慧因。无思慧故。若修慧但为修慧因。如此等有九品差别故。最下下品。为一切下中等八品因。道理如此。生得善法。一切皆有九品。前为后同类因。染污法亦尔。若无覆无记有四种。谓果报生。威仪相应。工巧处。变化心。共有此四种。次第为四三二一同类因。于欲界变化心。是四定果。此中是上地定果。非下地定果同类因。何以故。功力所造同类因。无道理以下类为果。譬如舍利谷麦等。勿作功力无果。是故诸师说如此言。若无流已生。可得非未生无流因不有如已生苦法智于未生苦法智忍。一切胜于劣非同类因。先所得无流法。定在一相续中。于后生无流。可非因不有。谓未来苦法智忍于苦法智。何以故。果非前故。又未来无同类因故。前已生无流法。于后已生无流法。可非因不有。谓胜于下类。如已退上果现证下果。复次苦法智至得于后后刹那入观人所得苦法智忍至得下类故。说同类因已。偈曰。相应因何相心心法。释曰。一切心及心法共聚。名相应因。若尔有别相续生心心法。更互应成相应因。是义不然。若一相一境得成相应因。若尔则同前过失。若同一时成相应因。若尔于别相续生心心法。应成相应因。如众人共见新月等。是故偈曰。同依。释曰。若彼互同依止。得名相应因。同者谓不异。如眼根刹那能作眼识依。亦作眼识相应受等心法依。乃至意根刹那于意识及意识相应法依义亦尔。相应因即是俱有因。何义立为俱有因。何义立为相应因。譬如同宗互相于有力故得行路。俱有因亦尔。由五种平等。共同所作故。立相应因。譬如同宗共同食饮资用事是故得行。于中若离一则一切不相应。是故此二因其势有异

说相应因已。遍行因相云何。偈曰。遍行染污因。自地前遍行。释曰。于自地先有诸法。若遍处能行于后生染污法。立为遍行因。此遍行法。后分别惑品中当说。由为一切染污法通因故。离同类因。别立此因。能为余部染污因故。由彼威力。别部诸惑。亦得增长。圣人染污法。亦以遍行为因不。罽宾国师说。一切染污法。见谛所灭惑为因。何以故。于分别道理论说。何法以见谛所灭惑为因。诸染污法。及见谛所灭法果报。何法以无记为因。一切无记有为法。及诸恶。有法以苦为因。以身见为因。非身见因不。广说如彼论。乃至云除身见及诸余法生老住灭所有别染污苦谛。若尔云何会释假名论文。彼论云。有法不善。唯不善为因。不有若圣人退离欲欲界染污作意初起现前。约未灭因。说此言。何以故。见谛或是此因已灭。是故不说。说遍行因已。果报因相云何。偈曰。果报因非善。及以有流善。释曰。一切恶及有流善法。是果报因。果报为法故。是故无记不能造果报。由无功力故。譬如陈朽种子。若尔云何无流不生果报。非贪爱所润故。譬如贞实种子无湿润故。此无流法不系属三界。云何能生属三界果报。所余诸法有二种故。能生果报。譬如贞实种子有润湿。此名云何可知。为是果报家因。为以果报为因。若尔何有。若执果报家因故说果报因。果报生眼此文不应成。若执果报为因是业果报。此文亦不成。此二悉得成。已如前说。复次果报是何义。熟不似故名报。何以故。于欲界有时一阴果报因一果。谓至得生等。有二阴一果。谓身口业生等。有四阴一果。谓善恶心心法生等。于色界有一阴果报因一果。谓至得及无想定生等。有二阴一果。谓初定教色生等。有四阴一果。谓散善心生等。有五阴一果。谓在定心生等。于无色界有一阴果报因一果。谓至得灭心定生等。有四阴一果。谓善心心法生等。复次有业此业唯一法入为果报。谓寿命为果报。若业感意入果报。此业生二入为果报。谓意入法入。如此若业感触入果报亦尔。若业感身入果报。此业生三入为果报。谓身触及法入。如此色香味亦尔。若业感眼根果报。此业生四入为果报。谓眼身触法入。如此耳鼻舌亦尔。有业感五六七八九十十一入果报。何以故。业有二种。有多业一果报。有一业多果报故。譬如外种子有多种果有一种果。多种果者。譬如莲石榴匿瞿陀等。一种果者。譬如谷麦等。一世业三世果报熟有是处。三世业一世果报熟无是处。勿果减因。如此一刹那业。多刹那果报。此义不可倒。不得与业同时果报熟。亦无无间次第熟。何以故。次第刹那。次第缘所引故。果报因观次第刹那相续终方熟。复次此六因。定在何世。彼定世由义已显。未以文说。是故应更立言释。偈曰。遍行及同类。二世。释曰。此二因若在过去现世则成因。若未来不成因。能证此义道理。于前已说。偈曰。三世三。释曰。俱有因相应因果报因。此三因各有三世。随造因不说定世故。是故应知通三世及无世。说六因已。何法为彼果。约此彼成因。偈曰。有为择灭果。释曰。何者为果法。一切有为法及择灭。阿毗达磨藏文如此。若尔无为法由果故应有因。若法以此为果。此法成因故。则应感果。若法有为可立因果。偈曰。无为非因果。释曰。无为法不可立为因果。何以故。非六因故。非五果故。云何不许圣道为择灭随造因。由不能遮应起法生故。立此为随造因。无为无生。是故于无为不成因。若尔是何法果。云何为果。是道果。由道力至得故。若尔但至得是道果。于至得道有功能故。择灭则非有别义。圣道于至得有功能。有别义道于择灭有功能。于至得功能云何能令生。于择灭功能云何能令至。是故圣道于择灭非一向因。择灭于圣道非一向果。可是增上果。云何无为成随造因。不遮他生故。成随造因。此法无果。解脱法无取果与果时。由无功能故。何以故。佛世尊不曾说无为为因。由别义亦说为因。经部师说如此。云何说是因是缘。能令色生皆是无常。若色依无常因缘生。此色云何得常住。乃至识亦尔。若尔无为法不应成识所缘境。由决能生皆是无常。此义自至。是因是缘能令识生皆是无常。由此定说是识所缘亦是无常。不说如此。是故识所缘。有常无常。此义自至

阿毗达磨俱舍释论卷第四阿毗达磨俱舍释论卷第五

        婆薮盘豆造

        陈天竺三藏真谛译

    释论中分别根品之四

为不如此耶。是因于他生有分皆是无常。由此言此无为法唯不遮为能故立为因。此义已拨。于余经中说所缘境不说不能遮为因。于经中无为法因义不成。以不说故。虽复不说亦不正拨。无量余经能显此义。皆已磨灭。云何决执此义。非经所说。若尔何法名离灭。为于前不已说耶。择灭谓永离。各各对诸结。于前问何法为择灭。答是离灭。今问何法为离灭。答是择灭。此释更互相依。终不能显自性。是故应引别义显其体性。诸圣人能自证此法体性。若欲说如此等相。亦可得说。谓常住善有别物。若思量即是离灭择灭。经部师说。一切无为法皆是无物。何以故。此法不如色受等有别体物。云何无别物。唯无有触。说名虚空。何故如此。于闇中彼人不得碍。逆说为虚空。由简择力。现在随眠惑及生离灭。后余集苦不更生。说名择灭。离此简择。由缘不具故。诸法不更生。说名非择灭譬如聚同分残于中间死不更生。余部师说。于随眠惑不更生中。般若有功能。唯此名择灭。此中后苦不更生。由随眠惑灭坏生缘不具故。此法得成。于中般若无功能。说此灭名非择灭。此法若离简择则不得成。是故此灭即是择灭。有余师说。若法先已生后灭。是自味灭。说名非择灭。于此执中非择灭应成无常。若法未灭未有非择灭故。为不如此耶。是汝择灭同前难不异。以简择为先故。若我等不执择灭在简择后。何以故。非先简择后方未生诸法不得生。所执云何。先时已有诸法无生。若离简择是法应生。简择起时后永不生。于此中是简择功能。谓先未有生障。今为生障。若汝执唯不生为涅槃。云何会释此经文句。经言若信等五根。被事被修被数习。为离灭过去未来现世众苦故。生起离灭即是涅槃。不生但约未来。于过去现世无不生义。实有如此。虽然能缘三世惑灭故。世尊说名苦灭。云何判如此。如别经言。于色贪爱汝等应除灭。若贪爱已灭。此色于汝等则灭则离。广说如经。乃至识亦尔。若尔于三世苦离灭亦尔。若有如此执。为除过去未来现世惑故说此经。解释道理悉应如此。若有如此执。过去惑在过去生。现世惑在现世生。譬如贪爱行中说十八贪爱行。约过去世谓约过去生。乃至现世亦尔。由此二世惑。于今相续中。已安立种子。为生未来惑。由种子灭故说彼亦灭。譬如由果报尽故亦说业尽。是未来苦。及未来惑。无种子故。永不更生。说名离灭。若执异此过去及现世。有何可灭。于已灭及定向灭。是灭功用复有何果。若无为实无有物。是佛世尊所说经云。所有诸法。谓有为无为。于中说离欲法无等。云何于无中无法说无等。若我等不说无为无。我说如此有。如我所说。如说声有先不有有后不有。虽有有言非有物。终不成有。应知无为法亦尔。有无所有。最可称叹。谓一切。灾横永不复有。此不有于余。不有最胜无。等故可称叹。为令应受化弟子乐求此法。若无为唯无所有。灭离则非圣谛。何以故。此无所有故。若尔谛有何义。为不如此耶。无倒为义。此二亦无倒。如圣人所见苦如苦。苦无所有。如无所有。若尔于圣谛有何相违。君云何无所有。成第三圣谛。成圣谛义。已说第二次无间圣所见所说。故成第三。君若无为唯无所有。缘虚空涅槃为境识。应成无境界。此义于过去未来实有思量中当决判。君若许无为法实有别物。有何所有。复何所有。毗婆沙本义。则便被护。诸天应护。若彼知此。必应可护。此执非真实。云何非真实。此无为不如色受等自性可证。不如眼根等可以事证。此离灭是惑苦离灭。如此安立。云何可成。何以故。此离灭与惑等不相关。因果等义不有故。唯遮拨彼。是义可然。谓某甲某甲不有。若执实有别物。由惑至得断至得此离灭故。说此是惑离灭。复有何因。能决定此法至得。经中说。比丘已至得现法涅槃。若无所有。云何至得。由至得对治故。至得烦恼及后生永相违依止故。故说至得涅槃。诸阿含显此法。唯无所有为义。阿含云。是众苦无余灭。弃舍无际。尽离欲离灭。寂静断没。不续余苦不取不生。是法寂静美妙。谓舍一切余爱。尽离欲离灭名涅槃。云何不许如此于彼不生故名无生。我等见此义与理不相应。此文何所显。若与已有相应。本来应无生。涅槃常住故。若与已至得相应。从此至得可分别此法已有惑已得。汝应许若不生。是譬喻最与理相应。譬如光涅槃心解脱亦尔。如光涅槃非有物。世尊心解脱亦尔。阿毗达磨藏。亦说如此。彼藏云何者无类法。答无为法。无类谓无体。此言显无自性。毗婆沙师说。文句义不如此。若尔何义。类有五种。一自性类。如经言。若已得此类。是人必与其相应。二境类。如经言。一切法如类智慧所知。三结类。如经言。若于此类中与欲结相应。即与嗔结相应不。四因类。如经言。何者有类法。一切有为法。五摄类。如经言。田类宅类等。此文中是因以类名显之。是故一切无为实有别物。毗婆沙师说如此。无为法无因无果。说三无为已。果有五种。于中此果何因。此因何果。偈曰。后因果报果。释曰。果报因最后说故称后。此因以果报果为果。偈曰。前因增上果。释曰。随造因最初说故称前。此因以增上果为果。此因唯不能遮为性。有何增上。即此是增上。随造因复有助功能。譬如于五识十入有功德。又于器世界诸业有功能。耳等诸根。于眼识生中。传传有增上。由闻欲见生故。如此等应思。偈曰。同类及遍行。等流。释曰。此二因果皆似因故。悉以等流果为果。偈曰。二功力。释曰。二谓俱有因相应因。同以功力果为果。不过丈夫能故名功力。此功力即是其果。何法名功力。此法于余法所有功能。此功力如丈夫能故名功力。如世间言鸦足草药醉象将军。为余因亦有功力果。为唯此二余因亦有。余果报因由功力果或俱生。或无间生。果报果不尔。此果报因。亦有远功力果。譬如农夫所应得稻。何法名果报果。乃至何法名增上果。偈曰。果报无记法。释曰。是无覆无记法。此果报为非众生名耶。偈曰。众生。释曰。此法唯属内。非共得故。称众生名。此法为增长为等流。偈曰。有记生。释曰。善恶二法。于果报可记故说有记。从此后时生非无间生。是名果报。果报相如此。非众生名法。亦从业生。云何不名果报。共所得故。此法余人亦能如此共用。果报无共得。何以故。是彼所作业果报。此得共用。无有是处。增上果亦是业所生。云何共用。从共业生故。偈曰。等流似自因。释曰。若果与因相似。是名等流果。如同类遍行因果。若同类遍行因果皆同类。云何不许皆是同类因。由此果约地约染污同本因。不由一切类。若法由一切类与果相似故。许此法是同类因。为此义故立四句。若法于此法是同类因。于此法亦是遍行因不。有四句。第一句者。非遍行因。但是同类因。第二句者。别部遍行因。第三句者。一部遍行因。第四句者。除前三句。偈曰。离灭由智尽。释曰。尽谓永离灭。智谓三道中三根。因此智苦集次第尽故。名永离灭。即是择灭。说名离灭果。偈曰。若由法力生。是果名功力。释曰。若由此法功能彼法生。彼法是此法功力果。如下地加行心。上地三摩提有流无流定心变化心。如是等择灭者。由道功能。应但说至得。偈曰。先未有有为。有为增上果。释曰。从先已生有为法。别生有为法。名增上果。功力果与增上果其异云何。能作所得果名功力果。非能作所得果名增上果。如工巧师所得名功力果亦增上果。若余所得但是增上果。复次如此六因中。何因何时能取果及能与果。偈曰。五现世取果。释曰。离随造因。所余五因。在现世能取自果。非过去果已取故亦非未来无功力故。随造亦尔。此因不定有果。是故不说。偈曰。二是时与果。释曰。俱有相应二因。亦在现世能与果。何以故。此二因取果与果同在一时故。偈曰。二现世过去。释曰。与果同类遍行二因。此二因若过去与果。此义可然。云何此二因于现世与等流果。由次第生故。若果已生此二因即谢过去。若与果已后不更与。有同类因。但能取果不与果不。此中有四句。第一句者。若人断善根。最后所断至得。第二句者。若人还接善根。最初所得至得。应说如此是人还接前至得。第三句者。不断善人于所余位。第四句者。除前三句。若恶同类因。第一句者。是人正得离欲。欲界最后。所舍至得。第二句者。若人退欲界离欲。最初所得至得。应说如此是退人前至得。第三句者。不离欲欲界。于所余位。第四句者。除前三句。如此有覆无记同类。因至得阿罗汉果及退。于中如理应思。无覆无记无后句。若因能与果必能取果。有能取果不能与果。如阿罗汉最后阴。若约有境界同类因。随刹那判。有善同类因。但取果不与果不。此中有四句。第一句者。若从善心次第起染污无记心现前。第二句者。翻前。第三句者。善心次第起善心。第四句者。除前三句。如善不善等四句。亦应如理思。偈曰。一过去与果。释曰。果报因在过去能与果。何以故。果报无俱起。无无间起故。有余师说。有四种果。一依止果。譬如水轮为风轮果。乃至草等为地果。二加行果。譬如不净观无生智。三集果。譬如眼等眼识等。四修习果。譬如色界道变化为果。此四种果。属增上果功力果摄。说因及果已。何者为法。由何因生。由几因生。若略说法有四种。一染污法二果报生法。三初无流法。四前二残法。何者为残法。离果报所余无记。离初无流所余善法。此四种法。偈曰。染污果报余。初无流次第。除果报遍行。二同类余生。释曰。染污法除一果报因。从余五因生。果报生法。除一遍行因。从余五因生。所余法除果报遍行二因。从余四因生。初无流法。除果报遍行二因。又除同类因。从余三因生。此四法是何法。偈曰。心及心法。释曰。此四法从余因生。但是心心法。若尔非相应法及色。此云何。偈曰。如余相应所离。释曰。除一相应因。是染污等余法。如心心法如此生。此中染污法从四因生。果报生法从四因生。所余法皆从三因生。初无流法从二因生。无一法从一因生。广解因究竟。缘是何法有几种。偈曰。说缘有四种。释曰。何处说。于经中说。经云有四缘类。一因缘类。二次第缘类。三缘缘类。四增上缘类。此中类者。是缘自性。此中因缘者。偈曰。因缘是五因。释曰。除一随造因。所余五因说名因缘。偈曰。心心法非后。已生次第缘。释曰。除阿罗汉最后心心法。已生余心心法。名次第缘。云何名次第缘。此法等无间缘故。名次第缘。是故色非次第缘。生不等故。何以故。从欲界色。后时次第欲界色界无教色生。后时欲界色无流色生。后时三种色生。是色现前乱过因生。次第缘无过乱。是缘生义。大德婆须蜜多罗说。于不相违一相续增长。后二生故。大德说。后从因最少最多生故。后时从大色小色生。譬如稻穰生灰。或从小色大色生譬如贝多核中人。次第生乃至垂条繁茂。转成尼瞿卢陀树。为不如此耶。心心法有时生多有时生少。谓于善恶无记位。有觉观等位。于三定。有如此约别类。不约自类无时受多生。想等亦尔。为约自类立次第缘不。无如此义。何以故。具足一聚。于具足二。为次第缘。非从少受等法多受等生。此义已如前说。说相续同类部。作如此执。自类是次第缘非余类。譬如心为心次第缘。受等亦尔。如广应知。若从无染污。次第生染污法。以先灭染污。为今染污次第缘。如入无心定心于出定心。今不弘此执。非相应行法。亦由现前乱过因生故。不成次第缘。属三界法及无系属法。一时现前生故。云何不许未来法为次第缘。次第缘杂乱故。未来世无前后差别故。若尔云何世尊得如此智。此未来法应在前生。次此法应在后生。约一切众生。乃至穷生死际。次第皆知。由约过去现在比知故。彼言佛世尊。见过去世。从如此类业。如此类果报已生。从法法生亦尔。今世亦有如此类业。从此类业如此类果报。来世当生。从法法生亦尔。得知如此如此。是如来愿智非比智。由过去现世比。世尊于未来世众物散乱相杂证见已。生如此智。此人作如是业已。必应摄如是等未来果报。若尔世尊未见前际。应不能知后际。有余师说。于一切众生相续中。有与心相应有为差别法。为当来果相。世尊观此。知未来果。若未现前诸定及通慧。若尔如来则是观相故知。不能更证。是故世尊一切境界。随欲正遍知。经部说如此。何以故。世尊说。诸佛境界不可思议。若未来法。无次第成立。云何世第一法次后苦法智忍生。非余法生。乃至金刚譬心次后尽智生。非余法生。若法能碍余法生。从此法无间余法得生。譬如从种子等芽等无次第缘。云何阿罗汉最后心非次第缘。不与余心相应故。若尔无间灭心为意不。何以故。无间后识不生故。若不立为次第缘。亦应不立最后心为意。意依止性所显。非功能所显。故有依义。由余缘不具故。余识不生不。由彼非依止故识不生。次第缘是功能所显。若有法此缘所取为果。此法一切余法及诸众生。无能遮碍令彼不生。若法与心有次第。可说与心无间不。此中有四句。第一句者。从无心定出观心。及第二三摩跋提刹那等。第二句者。初三摩跋提刹那。于后心位及生等。第三句者。初三摩跋提刹那。及有心位。第四句者。第二三摩跋提刹那等。及生等于出定心。若法与心次第。与三摩跋提为次第不。此中有四句。前第三第四句。即是此中第一第二句。前第一第二句。即是此中第三第四句。出灭定心。于前心断隔极远时。今云何从前心。说为次第。无别心隔故。说次第缘已。缘缘相云何。偈曰。缘缘一切法。释曰。一切法即五聚。此中如理应知缘缘相。譬如眼识及相应法。以色为缘缘耳识声。鼻识香。舌识味。身识触。意识一切法亦尔。若法是此法缘缘。此法无时非此法缘缘。若非所缘。亦是缘缘。体相一故。譬如薪非所烧亦名薪。体相一故。心及心法。由定入物刹那。于如自所缘境定。为由依止定为不定。尔定若生必与依止相应。未生及已过去。与依止相离。余师说。若过去亦依止所立。说缘缘已。偈曰。随造增上缘。释曰。随造因即是增上缘。故增上缘即是缘缘。何以故。一切法是缘缘故。此二缘何者广。俱有法为缘缘。无有是处。有是处。得为增上缘。故增上缘广。由缘义广故名增上。此缘于一切有为法离自性。皆是增上缘。有法于余法。由四缘成缘。不有谓自性于自性。他性于他性。无为于有为。无为于无为。此四缘若起功能。于何位法中起功能。因缘者已说五种。偈曰。于正灭二因。作功能释曰。正灭者。谓现世法。何以故。现世法已得生。今向灭故。此位中俱有因。及相应因作功能。何以故。于俱生果中此因有功能。偈曰。三因。于正生。释曰。正生者。谓未来法。何以故。未来法未得生。今向生故。此位中同类因。遍行因果报因。作功能。因缘功能如此。偈曰。二缘。翻前有功能。释曰。由功能道理。分因缘为二。翻此功能。应知即是次第缘缘缘功能位。次第缘。于正生作功能。为与彼位故。缘缘。于正灭作功能。现世心心法所取故。增上缘于一切位。由不遮故成缘。即是其功能。说诸缘及功能已。复次何者为法。由几缘得生。偈曰。由四缘心法。释曰。此中心及心法。因缘者有五因。次第缘者。在前心心法。非余心心法所间。缘缘者。如应色等五尘及一切法。增上缘者。离自性一切余法。偈曰。二定由三缘。释曰。灭心定无想定无缘缘。此二定不缘境起故。此中因缘者。有二因。谓俱有因。即生等。同类因。即先已生同地善法。次第缘者。谓共相应法三摩跋提心。增上缘如前。此二定由心功用生故。故以心为次第缘。由能遮心生故。自外非次第缘。偈曰。余法由二生。释曰。余法。谓与心不相应法及有色法。由因缘增上缘生。从如前所立六因四缘。一切有生法得生。一切世间。不如自在我胜性等为一生因。此中以何因为证。若汝执一切成立事因。缘所作。为不如此耶。由此执则乖弃汝所说本义。谓一自在等。为一切世间因。复次偈曰。非自在次故。释曰。世间不从自在等生。次第生故。若汝执唯一自在是一切世间生因。或执余因。一切世间应一时俱起。一切次第生。皆明了可见。若汝执此次第随自在欲成。愿此法于今生。愿此法于今灭。愿此法在后生灭。由欲有异。此义得成。谓因不一。是欲有异。应一时俱起。有欲自在。非有异故。若观余因差别故成。则非自在为因。是欲次第生中。若观别因。则有无穷过失。若不观别因。则无次第义。是因传传无边差别。由信无始故。此人乐执自在为因。不过释迦弟子所显道理。若汝言。自在欲虽复俱起。世间不俱起。随欲生故。是义不然。是自在欲于后世无所以故。由如此大功用化生世间。自在得何利益。若汝言常喜乐为用。是义不然。此乐若离方便自在则不能得故。于乐自在非自在。于余亦尔。复次若自在。见地狱等世间多为抂苦之所逼恼。由此故生乐。咄哉何用此粗恶自在。依自在天。世间首卢柯。则成善哥

  由能烧崄利　　可畏恒苦他
  乐食肉血髓　　令啼称律他

若汝信受自在等为世间一因。有余法以所证见。人功为因。则被弃舍。若汝分别执。自在共余因成因。此执但为爱敬故说。何以故。离众因。自在功能不可见故。诸因必须与余因和合故。能作自在。若尔则非自在。复次若初化作。以自在为因。此不观余因故。应成立如自在无初。于我及胜性等。立及破亦尔。是故世间无一因义。是自所造业。于道于杂能生世间。不学慧人。良足可悲。自受自果报果。及自受功力果。而起邪分别。谓自在等为因。此义已去。前云余法由二生。此言云何。若大于大成因缘。偈曰。二种大大因。释曰。若立四大为四大因。则有二种因。谓同类因。俱有因。偈曰。于所造五种。释曰。若四大是所造色因。则成五种因。云何成。一能生故。二能为依止故。三能持故。四令住故。五令增长故。是随造因。由此义分为五种。一能生因。从此生故。二依止因。已生随逐此故。三持因。为此所持故。譬如画色与壁。四住因。此令彼相续不断故。五增长因。此令彼圆满故。如此四大。于所造色。为生变异持住长因。五义得显。偈曰。所造互三种。释曰。若所造色作所造色。由三种因。谓俱有因。同类因。果报因。随造因平等起故。不恒数之。此中俱有更互因者。随心变身口二业。非余所造色。同类因者。一切前生。于后同类。果报因者。若身口二业。感眼等根为果报。偈曰。所造大因一。释曰。若所造色造四大但一因。谓果报因。若身业口业。以四大为果报。前已总说。心及心法。为次第缘。未说决定。何心为次第缘。何心从次第缘生。今当说此义。此中若略说有十二心。云何十二。偈曰。欲界心善恶。有覆及无覆。释曰。欲界中心有四种。谓善恶。有覆无记。无覆无记。偈曰。于二界除恶。余有。释曰。于色界无恶有余三。无色界亦尔。如此十心皆是有流。偈曰。无流二。释曰。谓有学无流。无学无流。由如此心合成十二。此中偈曰。于欲从善九。释曰。次第言后应说。于欲界中所有善心。从此九心次第得生。于自地有四心。色无色界有二心。若正入观是善心。若托生是有覆无记心。无色界但有有覆无记心。谓托生时最远故无善。无色界由四远。于欲界最为远。谓依止取相境界对治远故。及有学无学心。偈曰。此善从八生。释曰。复次此欲界善心。从八心次第生。自地四心。色界二心善心。谓出定时。有覆无记心。谓为有染污定所逼。还依下地善心。有学无学心。谓出观时。偈曰。从十恶心生。释曰。除有学无学心。何以故。若人于欲界托生。从一切欲界色界无色界心次第得生。恶心偈曰。从此四。释曰。从欲界恶心。但自地四心次第生。如说于欲界恶心。偈曰。覆尔。释曰。欲界有覆无记心。亦从三界十心次第生。从欲界有覆无记心。亦但自地四心次第生。偈曰。从五无覆心。释曰。于欲界所有无覆无记心。从五心次第生。自地四心。色界善心。谓生欲界变化心。偈曰。复从此七心。释曰。从欲界无覆无记心。七心次第生。自地四心。色界二心善心。谓从变化心次第生染污心。谓托生时。无色界染污心。谓托生时。偈曰。从色善十一。释曰。从色界所有善心。十一心次第生。除无色界无覆无记心。偈曰。从九此复生。释曰。色界善心。从九心次第生。除欲界二染污心。及无色界无覆无记心。偈曰。从八有覆生。释曰。色界有覆无记心。从八心次第生。除欲界二染污心。及有学无学心。偈曰。此六。释曰。从色界有覆无记心。六心次第生。自地三心。欲界三心。除无覆无记。偈曰。三无覆。释曰。色界无覆无记心。但从自地三心次第生。偈曰。此六。释曰。从色界无覆无记心。六心次第生。自地三心。欲界二染污心。无色界染污心。如说于色界无覆无记心。于无色界道理亦尔。偈曰。无色如是理。释曰。无色界无覆无记心。于自地亦但从三心次第生。从此六心次第生自地三心。下地三染污心。偈曰。从善九。释曰。从无色界善心。九心次第生。除欲界善心及欲界色界无覆无记心。所余心得生。偈曰。此从六。释曰。无色界善心。从六心次第生。自地三心。色界善心有学无学心。偈曰。有覆七。释曰。从无色界有覆无记心。七心次第生。自地三心。色界善心。及染污心。欲界二染污心。偈曰。此尔。释曰。此无色界有覆无记心。从七心次第生。除欲界色界染污心及有学无学心。从所余心生。偈曰。从此四。有学。释曰。此有学心。从四心次第生。三界善心及有学心。偈曰。从此五。释曰。从此有学心。五心次第生。即前四及无学心。偈曰。无学亦从五。释曰。此无学心。从如前所说五心次第生。偈曰。从无学四心。释曰。从无学心。四心次第生。三界善心及无学心。说十二心已。今复作偈曰。十二作二十。释曰。云何作。偈曰。加行及生得。分三界善二。释曰。于三界中善心。各分为二心。一加行得。二生得。偈曰。果报及威仪。工巧并变化。欲界四无记。释曰。欲界无覆无记心分为四。一果报生心。二作威仪心。三工巧处心。四变化心。偈曰。色界除工巧。释曰。于色界无覆无记心分为三。除工巧处心。于彼无工巧故。如此十二心。更分成二十心。善有六心。无覆无记有八心。威仪等心。于无色界中。无威仪等事故。色香味触四尘。是三心境界。工巧心亦以声为境。此四心唯是意识。是五识于威仪工巧处亦加行心所引。余师说有意识威仪所引起。以十二入为境界。如此二十心中。何心为次第缘。何心从次第生。欲界八心中。从加行心。十心次第生。于自地有七心。除变化心。色界加行心。及有学无学心。此心从八心次第生。从自地善心染污心。色界加行心染污心。有学无学心。从生得心。九心次第生。自地七心。除通果心。色无色界染污心。此心从十一心次第生。从自地七心生如前。色界加行心。及染污心。有学无学心。从恶心及有覆无记心。七心次第生。谓自地心如前。此二心从十四心次第生。自地七心。色界四心。除加行心及通果心。无色界三心。除加行心。从威仪心果报心。八心次第生。自地六心。除加行心及通果心。色无色界二染污心。此二心从七心次第生。谓自地七心如前。从工巧心。六心次第生。谓自地六。心除加行心及通果心。此心从七心次第生。谓自地七心。除通果心。从变化心。二心次第生。谓自地通果心。及色界加行心。此心亦从二心次第生。即前二心。今当约色界说六心次第。从色界加行心。十二心次第生。欲界二善心通果心。自地六心。无色界加行心。有学无学心。此心从十心次第生。欲界加行心通果心。自地四心。除威仪心果报心。无色界加行心。染污心。有学无学心。从生得心。八心次第生。欲界二染污心自地五心。除通果心。无色界染污心。此心从五心次第生。谓自地五心。除通果心。从染污心。九心次第生。欲界四心。善心染污心。自地五心。除通果心。此心从十一心次第生。欲界生得心。威仪心果报心。自地五心。除通果心。无色界三心。除加行心。从威仪心。七心次第生。欲界二染污心。自地四心。除加行心通果心。无色界染污心。此心从五心次第生。自地五心。除通果心果报心亦尔。从通果心。二心次第生。谓自地加行心通果心。此心亦从二心次第生如前。今当约无色界说四心次第。从无色界加行心。七心次第生。色界加行心。自地四心。有学无学心。此心从六心次第生。色界加行心自地三心。除果报心有学无学心从生得心。七心次第生。自地四心。下地染污心。此心从四心次第生。谓自地四心。从染污心。八心次第生。自地四心。色界加行心染污心。欲界二染污心。此心从十心次第生。自地四心。欲界色界。生得威仪果报心。从果报心六心次第生。自地三心。除加行心。下地染污心。此心从四心次第生。谓自地四心。从有学心。六心次第生。三界加行心。欲界生得心。有学无学心。此心从四心次第生。三界加行心。有学心。从无学心五心次第生。如有学五心。除有学心。此心从五心次第生。三界加行心。有学无学心。复有何因。从加行心。次第生果报威仪工巧心。而此心不从彼生。由加行力能引威仪工巧故。羸弱心相续。不能引将加行故。是故不随从加行心。出观心不由功用起。从加行心后此生可然。若尔从染污心不应得生加行心。无德故。虽然若人厌极。或逼行加行心。能令相离故。从染污心后。得生加行心。欲界生得心。由明了故。从有学无学心。色界加行心次第得生。不由功用起故。从此彼心不得生。从色界染污心。欲界生得心得生。由明了故。从无色界染污心。色界生得心不得生。由不明了故。思惟有三种。一自相思惟。如色以变坏为相。乃至识以了别为相。如是等名自相思惟。二通相思惟。谓四谛十六取相相应思惟。三欲乐思惟。不净观。无量。解脱。制入。遍入等思惟。从三思惟。次第能生圣道令现前。从圣道生思惟亦尔。若尔此言相应不相违。谓观行人。修习念觉分。与不净观相应。余师说。通相思惟现前即是圣道。从此亦得次第生三思惟。若人由不净观调伏心已。从通相思惟。次第生圣道。约此传传故。说此言。修习念觉分与不净观相应。有余师说。从圣道次第但生通相思惟。此义亦可然。若依止非至等三地。入正定聚。从三地圣道。次第生欲界通相思惟。若依止第二定等入正定聚。此义云何。何以故。此欲界心无能应此道。以地最远故。欲界地通相思惟。非第二定地所得。除决择分能。复次圣人更生决择分。能令现前。无有是处。何以故。若人已至得果。更令加行果向现前。此义亦不相应。若尔此言云何相应。有别通相思惟。与彼同类八圣道后之所修习。谓一切有为无常。一切法无我。涅槃寂静。必应令此现前。毗婆沙师不说此义若人依止非至定。得阿罗汉果。后出观心。或以非至定为地。或以欲界为地。若依无所有处为地。得阿罗汉果。后出观心。或以无所有处为地。或以有顶为地。于所余地出观。唯依自地。于欲界有三种思惟。一闻慧思惟。二思慧思惟。三生得慧思惟。于色界亦有三种思惟。谓闻修生得。无思慧。何以故。若彼人作功用思惟。即入三摩提。于无色界有二种思惟。谓修得生得。此中从五思惟。得次第生圣道令现前。除三生得。由圣道属加行故。从圣道但得次第生一生得思惟。谓欲界生得。以明了故。前所说十二心。于中何心现前。应得几心。偈曰。三界染心中。得六六二心。释曰。欲界染污心。正起现前。应得六心先与六心不相应。后还得故欲界善心先已相离。由疑惑还接善根故。由退还下界。更得不善心有覆无记心。又得色界染污心。由退还故。复由退定故。又得无色界染污心及退定故。又得有学心。色界染污心正起现前。亦得六心。得色界三心。又得欲界无覆无记心。由退还下界故。又得无色界染污心。及有学心。由退定故。无色界染污心。正起现前得二心。由退定故。得染污心及有学心。偈曰。于色界善三。释曰。色界善心。正起现前得三心。得自地善心。又得欲界色界无覆无记心。偈曰。学四。释曰。有学心正起现前得四心。谓有学心。欲界色界无覆无记心。无色界善心。由圣道离欲欲界色界时。偈曰。余准此。释曰。若有处不说得心。于中应知准得此心。有余师说。不分别得心。如偈言

  染污心起时　　说得九种心
  于善得六心　　于无记准此

此中于善心应说得七心。一得欲界善心。由正见接善根时。得欲界色界无覆无记心。由得离欲故。得色界无色界善心。由得彼定故。得有学无学心。由入正定聚。及证阿罗汉果时。是所余由此解释。应自思惟。为摄前义故说此偈

  托生入观时　　离欲退定时
  接善时得心　　是非先所得

分别四缘义究竟

阿毗达磨俱舍释论卷第五阿毗达磨俱舍释论卷第六

        婆薮盘豆造

        陈天竺三藏真谛译

    释论中分别世间品第三

今当说此义。由决定欲界色界无色界故。已分别心等诸法。此中何法名欲界色界无色界。为答此问故。偈曰。地狱鬼畜生。人道及六天。名欲界。释曰。四道及六天聚。六天者。一四天王天。二三十三天。三唱乐天。四善知足天。五化乐天。六他化自在天。是名欲界及器世界。此欲界复有几处。偈曰。二十。由地狱洲异。释曰。云何十四成二十。大地狱有八。一更生。二黑绳。三众磕。四叫唤。五大叫唤。六烧然。七大烧然。八无间。是名地狱异。洲有四。一剡浮洲。二东胜身。三西牛货。四北胜生。是名洲异。前说有六天。合数欲界成二十处。若约众生世。从他化自在天乃至无间地狱。若兼取器世界乃至风轮。从此欲界。偈曰。向上十七处。名色界。释曰。云何偈曰。各各定三地。释曰。此中初定二定三定。各各有三地。偈曰。于中四定有八地。释曰。此中初定三地者。一梵众。二梵先行。三大梵。二定三地者。一小光。二无量光。三遍光。三定三地者。一小净。二无量净。三遍净。四定八地者。一无云。二福生。三广果。又一无大求。二无热。三善现。四善见。五无下。如此十七处名色界。及于中住众生。罽宾国师说。但有十六。何以故。于梵先行处有处。高广最胜。如别层起。唯有一主名大梵处。非有别地。偈曰。无色界无处。释曰。云何无处。无色法无有处。何以故。过去未来有教等无色法。不住于处。此义决定。偈曰。由生有四种。释曰。若无处云何有异。由生差别故。无色界成立四种。一空无边入。二识无边入。三无有无边入四非想非非想入。此四不由处立为高下差别。何以故。是处得无色定人死堕。即于此中生。复从此后死堕。于此处中阴即起。如有色众生依色色相续生。于无色界何所依相续得生。偈曰。聚同分及命。依此心相续。释曰。众生聚同分及命根。依此二彼心相续生。阿毗达磨师说如此。若尔有色众生。云何不依此二心相续生。此力弱故。彼力云何强。从定差别生故。何以故。此定能伏灭色想。若尔由定力最强。依定心相续起何用立别依。此义应说。如有色众生。依色聚同分及寿命得生。无色众生依何法此二法得相续生。此二互相依。若尔有色众生。此二何故不自相依生。由二力弱故。若尔于无色二法云何力强。从定差别生故。此二如前。与心相续应同。或同心及心法。是故无色众生心相续。无别依止。经部师说如此。复次先所生能引心相续。因于色未离爱欲。此心相续。必与色共起。是故此相续依色得生起。是先所生能引无色心相续。因于色无复爱欲故。心相续不观色生。以弃背色故。云何说此三。为欲界色界无色界。界以持为义能持自相故。或性为义如前。此界与欲相应故名欲界。与色相应故名色界。除相应言。譬如金刚耳珰及弥梨遮饮。于此界中色非有故。不可显现故。不可变坏故。是故名无色界。复次此界是欲界家。界能持欲故。余二界应知亦尔何。法名欲。若略说与段食相应欲。与淫相应欲。故于中名欲。如偈言

  世间希有不名欲　　于中分别爱名欲
  世间希有住不异　　智人于中唯除欲

尼干子对舍利弗。说偈言

  世间希有若非欲　　汝说分别爱名欲
  比丘恒应受尘欲　　若起染污尘觉观

大德舍利弗答

  世间希有若是欲　　分别爱着若非欲
  汝师恒应受尘欲　　若见可爱色等尘

若有诸法。于欲界色界无色界起行。是诸法为与欲界色界无色界相应。不。非何者欲界等。欲若于法随眠名欲界等相应。何法名欲界等欲。是法能随眠于欲色无色界中。是名欲界等欲。此答同缚马答。如问缚马者。谁是马主马主是谁是能缚。此二悉不可解。不同缚马答。何以故。此三处前已于欲界等中分别显了。于中未离欲人所有欲。是名欲界欲。若欲界欲随眠于此法中。此法名欲界相应。如此色无色界欲。若人已离欲下界。如理应知。复次若欲有色。以非寂静为地。名欲界欲于有色定及无色欲。名色界无色界欲。余言如前。于变化心中所起欲。云何名欲界欲。于中若有欲则名为信。由啖此味若退堕定。随变化于能变化人心上欲。亦是欲界欲。复次若变化为香味。即是欲界相应。由此二非色界心所变化故。为唯一三界耶。三界无边。譬如虚空。三界亦尔。是故无先未有今有。众生生对对。诸佛出世时。无量众生般涅槃。无众生有尽难。譬如虚空。世界云何住。傍住。经中说譬如车轴渧天雨时。水渧从上空落无间无缺。如此于东方世界正坏正成。无间无缺亦尔。如东方南方西方北方亦尔。不说有上下方。于别部经言有上有下。从阿迦尼吒上更有欲界。欲界下更有阿迦尼吒。若人离欲一欲界。是人即离欲一切欲界。色无色界亦尔。若人依初定起通慧。随所生处世界起通慧。由此通慧得往自世界梵王处。非余处。如前所说三界。偈曰。于中地狱等。名说有五道。释曰。于三界中说有五道。如前所立名。谓地狱畜生鬼神天人。由此自名说道有五。欲界中有四道及第五道一分。色界无色界中。唯天道一分。为有诸界出此道不。由说于界中有诸道。说有善染污器世界。中阴为性。是界非道。五道者偈曰是无覆无记。众生非中阴。释曰。道以无覆无记为性。若不尔。道应相杂但众生名是道。亦非中阴为性。假名论中说。四生摄五道尽。非五道摄四生尽。何者非摄。即是中阴。法阴阿毗达磨说。何者眼界。依四大及四大所造清净色。是眼根眼入眼界。谓地狱畜生鬼神天人。修得及中阴。于经中说。于道却中阴。此经何名七有。经云有七有。谓地狱有畜生有。鬼神有。天有。人有。业有。中阴有。此经中说五道共因共行。是故道定唯无覆无记。由却彼因业。有出彼外故。罽宾国师说。经大德舍利弗说。净命是地狱。或流现前故。即起即长地狱受报业。净命身口意谄曲憎忿粗涩业。于地狱色受想行识果报熟。果报已起得名地狱众生。净命此中除色等法。地狱众生皆不可得。是故五道定是无覆无记。若尔应救分别道理论。彼论云。于五道一切随眠惑缘起。托五道心有五种。由共前分执道故。是故不相违。譬如说郊外为国土。余部说。诸道不。但无记有善有。染污是汝所。说由于道。却业有出外故不由别。立业有于道成外譬如于。五浊惑浊见浊。亦有别说。诸见非非惑。如此业有亦入道摄。亦有别说。为显道因故。于中阴亦应如此论。是义不然。非道理故。众生往于彼。是故彼名道。中阴非所往。即于死堕处起故。若尔无色界不应成道。即于死堕处起故。若尔由中间有故。故立中阴。非道在二道中间故。若此成道。不应说为中有。复次大德舍利弗说。果报已起得名地狱众生。有说。果报已起。不说即是果报复说净命。此中除色等法地狱众生皆不可得。此言但拨能行五道人故说除色等阴地狱人不可得。不拨余阴。毗婆沙师说。五道定是无覆无记。果报为性。有余师说。增长为自性。于五道三界中。此义次第应知。偈曰。身异及想异。身异同一想。翻此身想一。复有三无色。故识住有七。释曰。经中说。有有色众生身异想异。如人道及诸余天。是第一识住。何者余天。欲界天。初定天。除劫初生天。云何彼身异。色相形不同故。云何彼想异。乐想苦想非乐非苦想不同故。有色众生身异想一。如梵众天劫初受生。是第二识住。何以故。是劫初生。一切梵众同起一想。谓我等是大梵所生。大梵亦作此想。谓彼是我所生。由同思想大梵为一因故。故言想一。大梵王身量高大。异于彼众相貌威德言语光明衣着等亦异彼众。故言身异。于经中说。是诸梵众有如此思想。我等见此众生长寿于久时住。乃至起如此心。愿余众生于我同类中生。是众生起如此心愿。我等即于此处受生。是彼云何见此众生。余师说。彼住遍光天处。见此众生。何以故。是梵众从彼处堕故。梵众已不得第二定三摩跋提。云何能忆第二定地宿住事。若得云何缘大梵为境。起戒执取。有余师说。诸梵众在中阴得见。是义不然。于中阴无道理为得久住。无障碍故。云何彼起如此心。我等见此众生长寿久住此中。是故诸梵众在此处忆昔时事。昔时已见此众生长寿久住。后时更见。是故起如此心。有有色众生身一想异。如遍光天。是第三识住。此中复由执上边处。应知具足取二定。若不尔。小光无量光。何处识住可得安立。于彼天色相形不异故身一。有乐想不乐不苦想故想异。彼说是诸梵。于根本定地厌极喜根。从方便地。引舍根令现前。于方便地厌极舍根。从根本地更引喜根令现前。譬如大富人厌极欲乐别受法乐。厌极法乐更受欲乐。若尔于遍净天为不同此义耶。遍净天由彼乐不生厌极。何以故。是乐最寂静。喜乐非寂静。为没重心故。经部师说。有经显彼想不一。经言。有诸众生于遍光天上新得受生。未明了世间坏聚。未明了世间成散。见下地火光焰。怖畏起厌离心。谓火光焰勿烧空梵王处。已从下至于我处。有诸众生。于遍光天上先旧受生。已明了世间坏聚。已明了世间成散。见彼众生起惊怖心。慰喻之言。勿畏净仙。勿畏净仙。昔时此光烧空梵处竟。自然灭静。是故于火光有来不来想故。怖不怖想故。故说想异。不由乐不乐不苦想。有有色众生身一想一。如遍净天。是第四识住。想一者。同一乐想。此中于初定由染污想彼一想。于第二定由善想彼不一想。于第三定由果报生想彼一想。无色界三识住。如经所显。是七名识住。此中何名识住。于七处相应五阴及四阴。如理应知。是识住所余何故非识住。偈曰。所余有变异。释曰。所余是何法。谓诸恶道第四定及有顶。何以故。于中识有诸变异。故非识住。云何变异。于恶道中苦受是变异。由损害识故。于第四定无想定是变异。于有顶灭心定是变异。能断识相续故。复说住于余处众生。是欲住处。若住于此处不欲更动。说名识住。于恶道无此二义。于第四定中众生恒有动求出心。若凡夫欲见无想天。若圣人欲见五净居。有顶心细昧故。彼非识住。如所说是七识住。偈曰。有顶无想天。众生居有九。释曰。于九处中众生如欲得住。偈曰。不欲住余非。释曰。何者为余。谓恶道。何以故。于中众生不欲住业。罗刹逼之令住。不由自欲住。是故非众生居。譬如牢狱。于余经说七种识住。复有余经说。偈曰。复有四识住。释曰。何者为四。爱色识住。爱受识住。爱想识住。爱行识住。此四体相云何。此次第。偈曰。谓有流四阴。释曰。是阴。偈曰。自地非余地。释曰。此四阴是自地阴。非余地阴。何以故。住者定着为义。于不同地阴中。识随贪爱故。不能得住。云何不说识为识住。由离能住立住故。不说识住。非能住为住。譬如非王为王所使。复次若识乘策此法。此法名识住。由船人道理故。说诸法为识住。非识自乘策识故。不说识为住。毗婆沙师说如此。若尔经中说。于识食有爱有欲。若于中有爱有欲。于中识即乘住。此经云何。七种识住五阴为性。此经复云何有如此。虽然不分别。生处所摄五阴中有受乐识生时。亦说识为识住。若如色等。各各能起识染污。若单识不能为如此。是故于四识住不说单识为识住。复次佛世尊说四识住为田。一切有取识为种子。不可安立种子为种子田。佛世尊意可了别如此。偈曰。住等众生名。释曰。是法为共生识好最胜田。是法说之为识住。为以七识住摄四识住不。为以四识住摄七识住不。偈曰。各异。释曰。七不摄四。四不摄七。偈曰。四句摄。释曰。若思量应知四句相摄。有法七所摄非四所摄等第一句者。七识住中识。第二句者。恶道第四定有顶识所离诸阴。第三句者。谓七识住四阴。第四句者。除前三句

前所说三界有五道等差别。于中应知。偈曰。于中有四杂。众生谓卵等。释曰。卵生胎生湿生化生。杂者何义。杂生为义。于中众生相杂生。由生等故。何者卵生。是众生从卵出。如鹅鹤孔雀鹦鹉舍利等。何者胎生。是众生从胎出。如象马牛驴驼等。何者湿生是众生从四大气所生。如虫蚊蜻蛉等。何者化生。是众生不减具根圆。得是及身分一时俱生。如天地狱中阴等。复次于一一道中有几种生。偈曰。人畜具四生释曰。人道有四生。卵生者。如世罗优波世罗二比丘从鹤鸟生。又弥伽罗母。三十二子。又如般遮罗王生五百子。胎生者。如今世人。湿生者。如顶生王。遮娄优波遮娄王。迦富多摩梨尼夫人。庵罗夫人等。化生者。如劫初生人。畜生亦有四种。可见有三种。若化生如龙伽娄罗鸟等。偈曰。地狱但化生。中阴及诸天。释曰。一切地狱众生。中阴众生诸天。皆是化生。偈曰。鬼神亦胎生。释曰。亦言即显有化生。胎生者。如女饿鬼白净命目干连云

  我夜生五子　　昼时亦生五
  生已皆食尽　　如此我无饱

何生于一切中最胜。化生。若尔云何。最后生菩萨。已至得。生自在唯受胎生。若作如此见大利益。利益者。由亲属相关故。令无量大家释迦种得入正法。此人是转轮王种姓。但由此名欲生他恭敬尊重。及背邪归正。在于人道。亦得如此希有胜利。我等今云何下心。为起受化众生正勤心。若不尔。家姓则不可识。世间应作此计。此众生是何幻惑。为天为鬼。外道亦说此言。一百劫尽如此幻惑人出于世。作幻化事啖食世间。为离此谤故受胎生。有余师说。为安立身界尸履故受胎生。于中人及余众生。作供养事竟。由此福德过于千遍。恒受天生后得解脱。何以故。化生众生无外种子故。若死身不得住。如灯光已灭静无复余。化生亦尔。若是人信世尊。有成愿通慧。此救不然。从别问更生别问。若化生众生。尸骸不可得。经中云何说。化生伽娄罗取化生龙为食。不解故无失。复有食乃至未死。若死无复饱。何生于一切中最多。唯化生。何以故。此具二道。三道中一分。一切中间悉化生何法名中阴。偈曰。死有及生有。在中间五阴。释曰。前死有后生有。于中间所得身。为至余处。说此身名中有。在二道中间故。若身已有。云何非生。偈曰。未至应至故。未生名中有。释曰。若至所应至处。方得名生。此众生已离本生。未至应至处。于中间虽有未得名生何处。是此众生应往是处。业所引果报。明了显现及究竟。是所住处。若至此处名生。余部说。生有与死有断绝。此执非可许。何以故。由道理及阿含故。此中依道理说。偈曰。似谷相续故。无间于后生。释曰。诸法次第相续生。由不断故。于余处生。此可证见。譬如谷相续。是故众生相续次第无断绝。于余处生。此义可然。若尔诸法断绝于余处生。此可证见。譬如于镜等中从本生影。亦可证见。如此从死有生有断绝生。此亦可然。偈曰。影非成实故。不等故非譬。释曰。影是何法。有别物生。是色中一类。是义不然。非成实故。若成实有物不相似故。故亦不堪为譬。云何非成实。偈曰。共一处二无。释曰。于余一处见镜色及影色。此一处中无道理二影俱有。依止四大异故。复次别方定故。于一水处互向自面。所有诸色互对生影。于一色中二人共看。不应有俱时各见此中余色得生。是义不然。复次影及光。不曾见于一处俱有。曾见镜在影中日光显然。若影是实有。光不应得于中生以相违故。复次共一处二无者。何者为二。谓镜面及月圆。于别处见镜面。于别处见镜中月圆。如井中水。此月影若于中生。不应见在余处。是故此影实无所有。诸法聚集有如此势力。谓非有显现似有。何以故。诸法功能差别。难可思议。如此不成实故。不堪为譬。云何由不相似故不堪为譬。偈曰。无相续。释曰。影非本物相续。与镜相续相应故。与本俱有故。如生有约死有成。相续无间无绝。生于余处故。影无如此相续。是故影譬不等。偈曰。二生。释曰。从二种因影得生。谓从本物及镜。依此最胜二因影得生。生有不尔。从二因生。谓从死有及从余胜法。复由此义影譬不等。不应说如此。有外色无意赤白为胜因。若化生众生。于空中受生。复分别何因如此。由道理不可许。从死阴断绝无相续生阴得起。由此道理。是故有。中阴。偈曰。由经。释曰。由经知有中阴。经中说七种有。地狱有。畜生有。鬼神有。天有。人有业有。中有。此经非彼受诵。复由别经说有中阴。偈曰。乾闼婆。释曰。三处现前故。于母胎中众生得受生。何者为三。一母四大调适有时。二父母互起爱心和合。三乾闼婆正至欲托生。若除中阴。此中何法名乾闼婆。若此经非彼所受诵。故执如此。云何阴坏得至其中。复次若汝执无中阴。云何会释阿输罗耶那经。经云汝等能知不。是乾闼婆正至于中。为刹帝利。为婆罗门。为鞞舍。为首陀罗。为从东方来南西北方来。广说如经。此中何法名乾闼婆。五阴破坏。云何得来。如此之经汝可不读耶。若汝言我不受此经。此义复云何。偈曰。说五。释曰。佛世尊说有五种阿那含。中灭生灭无行灭有行灭上流灭。若无中有。云何得名中灭。有诸天名中。至于彼般涅槃。故名中灭。若尔亦应有天名生等。至于彼般涅槃。汝等亦应作如此执。是故此非好执。复次偈曰。行经故。释曰。于经中说有七种贤圣行。于中说中灭人有三。由时节处所胜负差别故。譬如有铁小火星才出即灭。初人亦尔。譬如有铁火星出远方灭。第二人亦尔。譬如有铁火星出去最远堕未至地而灭。第三人亦尔。如汝所执。若有天名中则无如此三品。时节处所胜负差别。是故此执唯漫分别。有余师说。于寿量中间立三人。或执近诸天边。若人灭尽诸惑。说名中灭。此人或行入界般涅槃。或行入想般涅槃。或行入觉般涅槃。是故成三。复次初人于色界中。摄聚同分已般涅槃。第二人受富乐已般涅槃。第三人入诵法藏堂已般涅槃。若尔生灭何相。此人入多时相应诵法藏堂已方般涅槃。多故减寿命。然后般涅槃。非初受生即般涅槃。如此一切与火星譬皆不相应行处所无胜负差别故。若尔于无色界。亦应说有中灭人。亦于寿量中间般涅槃故。由不说故。是故此执惟自分别。若汝不读诵如此等经。我今何所作。大师已般涅槃。正教无主。已多种分破乃至今时。于文于义随欲分破。此犹不息。若人受如此等阿含。为证为量。中阴于此人得成。若尔云何说头师魔。由现身入大阿毗指狱。此魔正生未死。地狱火焰已来烧身。方舍寿命。由中有身乃入地狱。经意如此。何以故若业最剧。圆满此业。不得待舍身。是故此魔现报先熟。生报后熟。复次此义今云何可会释。有五无间业。若人已作已长。次第无间必生地狱。不往余道。此是经意。于中为显此业必受生报。若如文分别。但应称五业。不得说余句。应至如此。若作业无间命即应断。无暂活义。何人不许中有生义。虽然从死有无间。由中有生于地狱趣。向生有故。是故不说为生有。若尔云何。释此偈

  已度四位至衰耄　　二生汝今近阎魔
  于其中间必无住　　路中资粮咄不有

此偈显于人道中无中间住。生灭次第无碍故。复次于中有中无住。为至生处行无碍故。偈意如此。若如此是意。若如此非意。此分判依何道理得成。汝亦同此难。是故于此二义。如前所说经。无相违故。故不可偏以此偈证无中阴义。复次证名言者。是行无行何道是所应往。中有若起有何相。偈曰。由一业引此。当先有相貌。释曰。此业能引生诸道。此业能引显中有。为至此道。是故此道必所应往。于此道中是应来先有相。此即中阴相。若尔狗等众生。于一胎中应生五道中阴。若地狱中阴即烧母腹。于先有时。地狱众生火亦不恒然。若行于园中。何况在中阴。设许火烧然。如不可见亦不可触。由体性细故。是故非难。诸中阴于胎中亦互不相触故。为业遮故。故不能烧。身量云何。如六七岁小儿。而识解聪利于小儿。若菩萨在中阴。如圆满少壮人。具大小相。是故虽在中有。正欲入胎。而能遍照百俱胝剡浮洲。若尔云何菩萨母。于梦中见白象子欲入右胁。母所见但是梦相不关中有。菩萨久已离畜生故。譬如柯枳王见十种梦。谓象井糗旃檀林小象衣争璎珞莲华。于事前得此梦。中阴众生非破腹入胎。云何得入。从生门入。是故双生。若在后生为大。若在前生为小。若尔大德达磨须部吼底说偈。云何会释

  变身作白象　　六牙四足饰
  入母胎卧住　　念如仙入林

此言不必须会释。何以故。此言非经非律非阿毗达磨。但是集言。聪慧人欲集义为论。有余诸法摄为增益。若言必须会释。此是母于梦中见子入胎相。大德说偈意如此。色界中有身量圆满。有衣共生。惭羞最重故。诸菩萨中有衣着具足。复有叔柯罗比丘尼。由本愿力故。于中有着衣入胎出胎。乃至般涅槃后共衣俱烧。所余皆裸。欲界众生无惭羞多故。复次何法名先有。偈曰。复有先于死后于生刹那。释曰。有者若约通义。谓五取阴。此有离为四分。一中有。如前说。二生有。谓于道托生初刹那。三从此后除死刹那。是别先有。此中说名先有。四最后刹那名死有。从此后有中有。若生有色众生中。此中有。偈曰。同生净天眼。可见。释曰。若同生道中阴。定互相见。若人有天眼最清净。是一通慧类。此人亦得见。彼若生得天眼则不能见。以最细故。余师说。天道中阴能见一切中阴。谓人鬼畜生地狱中阴。除前除前得见。偈曰。业通疾。释曰。通慧者谓行虚空。此通从业得。此通速疾云何。不可及回故名疾。若人应生他方。修得通慧人所不能及。佛世尊亦不能遮回。由业力最强故。偈曰。具根无障碍。释曰。此有具足五根。金刚等所不能碍。此义应然。曾闻破烧赤铁块。见虫于中生。中有众生。若应生此道中从此道。一切方便。偈曰。不转。释曰。云何人道中阴。无时可转令成天道中阴及余道中阴。此众生若为此道成中阴。决定应生此道中。不生余道。复次欲界中阴为食段食不。答尔。不食粗段。何故。偈曰。此食香。释曰。故名乾闼婆。若福德小食臭气若福德大食妙香。众生于此有中得住几时。大德说无定。乃至未得生缘聚集。此中寿命无别业引之。一聚同分摄故。若不尔。此中由命根尽。应别立死有。若有肉聚等须弥山。此肉聚至夏时一切成虫。彼中阴为住待夏时不。复从何方来。此问未曾至经中。亦未曾至阿毗达磨中。若尔可然。微细众生贪着香味。寿命短促。无有边际。此众生闻气贪着香味。于舍命时觉悟先业能感虫生报。由此贪爱受于虫生。复次昔已有业能感彼道。是时彼缘最多。于生果报得具事能非余时。此义必然。何以故。已有宿业能感转轮王报。世间寿八万岁时。或过此寿。有多转轮王生非余时。是故世尊说众生业报不可思议。大德婆须蜜多罗说。七日得住。若不得生缘和合。此中死堕死堕更生。复有余师说。七七日住。毗婆沙师说。但促时住。以乐受生故。疾行结生。若因缘聚集未具。若其于此道中必应受生。是时宿业自和合众缘。若不定生此处。于余处此道中皆得受生。余师说。若于此众生类中不得生。则于余相似类众生中受生。譬如牛于夏时欲事偏多。狗于秋时。熊于冬时。马于春时。野牛野干豹等欲事无时。是时此众生应生牛中。若非夏时则生野牛中。若应生狗中非时则生野干中。若应生马中非时则生驴中。若应生熊中非时则生豹中。为不如此耶。若众生在别聚同分中阴中。于余聚同分则不得受生。一业所引故是故此执有失可诃。此中有为行至应生道处故起。偈曰。颠倒心行彼。生处由欲戏。释曰。此中有众生。由宿业势力所生眼根。虽住最远处。能见应生处。于中见父母变异事。若应成男。于母则起男人欲心。若应成女。于父则起女人欲心。到此心起嗔。于分别论中有如此文。乾闼婆于二心中随一心应起现前。或欲相应起。或嗔相应起。此中有众生。由二起颠倒心故。求欲戏往至生处。是事乐得属己。是时中不净已至胎处。即生欢喜仍托彼生。从此刹那。是众生五阴和合坚实。中有五阴即灭。如此方说受生。若胎是男。依母右胁面向背蹲坐。若胎是女。依母左胁面向母腹住。若胎非男非女。如欲类托生住。亦如此无中有异男女。皆具根故。是故或女或男托生如处而住。后时在胎中增长。或作黄门。此义应思。为即以赤白四大成胎中众生根及依止。为由业力故别有四大宿业所生成根等。但依止赤白四大。有余师说。即是赤白四大。何以故。此赤白先无根。共中阴俱灭。有根后生。由种子灭芽生道理故。是时说此名柯罗逻。若作如此思。则善顺此经。经云父母不净和合所生。复有经云。比丘汝等长夜增长贪爱摄取血滴。余师说。别有四大。譬如叶虫依止叶粪。虫依止粪。由说柯罗逻依止不净生。是故与柯罗逻经不相违。若托胎卵生道理如此。于余生如理应说。此中是道理应知。偈曰。余爱乐香处。释曰。若众生欲受湿生。由爱乐香故至生处。此香或净或不净。随宿业故。化生由爱乐处所故至生处。若尔地狱众生。云何爱乐处所。由心颠倒故。此众生见寒风及冷雨触恼。自身见地狱火猛盛可爱。欲得暖触故往入彼。复见自身为热风热光及火焰等所炙。苦痛难忍。见寒地狱清凉。爱乐冷触故往入彼。如位造作能感如此生业。见自身是如此位。见彼众生亦尔。是故往彼。先旧诸师作如此说。复次此中天中阴。一向上升如从坐起。人畜生鬼神中阴如人等。偈曰。地狱脚向上。释曰。如偈言

  众生堕地狱　　脚上头向下
  诽谤诸仙人　　护精进行者

前已说颠倒心行彼。为一切中阴众生皆有此事入母胎。为不皆尔亦不无。此经中说。有四种托胎。何者为四。偈曰。一正入有觉。释曰。有众生多善根聚集。护持正念。死时不失正念故有觉。乃至入母胎。亦不失正念。住时出时则失正念故无觉。偈曰。余住。释曰。有众生住母胎。亦不失正念故有觉。先入亦尔。偈曰。复余出。释曰。复有众生出母胎。亦不失正念故有觉。先入住亦尔。偈曰。余三位。释曰。有余众生在三位中。皆失正念故无觉。若入无觉。住出必无觉。是名四种托胎。此是逆说。由随顺首卢柯结故说。偈曰。一切卵生则无觉。释曰。若卵生众生。恒于三处无觉。云何卵生众生。说名托胎。此众生亦先托胎。或由当来名说。如经言能作有为。是故名行。如世人言煮饭磨糗。是故无失。云何不觉悟入母胎及住出。复云何觉悟入住出。若众生小名位。正欲入母胎时。即起颠倒想欲。或见猛雨洪注疾风飘鼓。或见大阴寒。或见多人沸挠。自谓我今入密草稠林草屋叶屋中。我今匐行住树根下壁根下。若住亦起颠倒。谓我今于此等中住。若出亦起颠倒。谓我今从此等中出。若大名位众生亦起颠倒想欲。我今当入园入游戏处。登上高楼及大殿堂。坐于床座。若住谓住其中。若出谓从此出。如此不觉悟入住出。若觉悟者了解分别。谓我今正入母胎。正住母胎。正出母胎。无颠倒想欲。此中更分别说。偈曰。说托胎有三。轮王及二佛。释曰。转轮王独觉大正觉。此三人次第应知托胎三义。第一托胎谓转轮王。何以故。此人正入胎时有觉悟。非住出时。第二托胎谓独觉。此人入住二时有觉悟非出时。第三托胎谓大正觉。此人入住出三时皆有觉悟。此中三人悉由当来名所显。云何三事不同。偈曰。业智慧及二。次第胜能故。释曰。业胜能者。能作大福德行人。由福德有业胜能。故立第一。修习多闻多思人。由智慧有胜能。故立第二。能作大福德行及修习多闻多思。人由福慧有胜能故。立第三。是转轮王等三人如此次第。所余为第四。此义应尔

外道本执说我义。于此中执我。言争事起。彼言若汝立义众生从别世度余世。我等本义则成。谓实有我。今破此义。偈曰。无我。释曰。此我何相。能舍此阴能受彼阴。如彼所分别。此我实无。谓于内作者人。何以故。非二量境界故。如色尘及眼等根。佛世尊亦说。有业有果报。作者不可得。由无故。故不可说。此我能舍此阴受彼阴。若离法假名。此中法假名者。谓若此有彼有。由此生彼生。广说十二缘生。此我何相。谓非所破。偈曰。唯诸阴。释曰。若假说唯诸阴名我。此我非所破若尔诸阴从此世到余世。此义应至诸阴不度余世。云何此诸阴。偈曰。烦恼业生起。由中阴相续。入母胎如灯。释曰。诸阴刹那刹那灭。彼于度无能。烦恼所摄业。所变异故。唯有诸阴。由中有相续往入母胎。譬如灯虽念念灭由相续得至余处。诸阴亦尔。是故无失。实无有我。但烦恼业所引诸阴相续得入母胎。此义得成

阿毗达磨俱舍释论卷第六阿毗达磨俱舍释论卷第七

        婆薮盘豆造

        陈天竺三藏真谛译

    释论中分别世间品之二

复次偈曰。如引次第长。相续由惑业。更入于余世。释曰。一切阴相续牵引不平等。能感寿命业有差别故。此相续随能引势。如此次第得增长。何者次第。如偈言

  初名柯罗逻　　次生頞浮陀
  从此生俾尸　　俾尸生伽那
  伽那生舍佉　　及发毛爪等
  并有色诸根　　次第生身分

此五位皆在胎内。谓柯罗逻。頞浮陀。俾尸。伽诃那。波罗舍佉。此胎中刺。由时节次第增长至成熟位。于母腹中业报所生。猛风吹之。风转胎刺安置令向母身门。此胎如强粪聚过量难忍。次从此处堕。是时二苦不可为譬。复次或时母饮食威仪执作过差。或由宿业过失。于胎内死。是时有诸女人善识方便。及诸医师解养婴儿。方温以酥油。及睒摩梨滑汁用以涂手。手着小利刃。于胎内譬如粪坑。最剧臭闇不净之器。是无量千虫类住处。秽汁常流。恒须对治。不净及血垢腻洟液。湿烂臭滑之所染污。鄙恶叵见。穿漏薄皮以覆其上。宿业所作。身大创孔手内其中。分分断割牵出于外。此胎中子。由宿后报业引入余道。趣向难知。复次若生无难。是时或母乳子。或余女人能瞻视之。此儿体似新疮。触如刀仗及烈灰汁。爱此儿身及以洗拭。次唅以清酥。饮以母乳。渐次饴以细粗饮食令稍习之。此子由次第增长。由诸根成熟诸惑更起。诸业更生及更增长。由此惑业舍命之后。由中有相续如前。更入余世。偈曰。故有轮无初。释曰。由此道理。生以惑业为因。惑业以生为因。生复以惑业为因。如是应知。生死轮无初。何以故。若分别执有初。此初应成无因。若初实无因。所余一切悉自然生。皆应无因。现见此事。于芽等中有种子等。功能。由处时定故。火等诸因。于熟等果亦尔。是故无生无因。说常住为因。于前已破。是故生死必定无初。是生死终。由因尽可然。由生属因故。譬如芽属种子。由种子坏故芽灭。是阴相续所说。三生为位。偈曰。如此缘生法。十二分三节。释曰。此中十二分者。一无明二行三识四名色五六入六触七受八爱九取十有十一生。十二老死。三节者。一前际二后际三中际。谓过去未来现世。云何于三节安立十二分。偈曰。前后际二二。于中八。释曰。无明行在前际。生老死在后际。所余八在中际。此八分一切众生于此生为具有不。答非。若尔何众生具八。偈曰。具生。释曰。若众生触一切位。说名具生。非于中阴死。非托色无色界生。何以故。于大因缘经中。但约欲界众生说经言。阿难。若识不托母胎赤白。为得变异成柯罗逻不。不得世尊。广说如经。有时说缘生有二种。有属前际摄缘生。有属后际摄缘生。于中七分说名前际。谓从无明乃至受。所余五分说名后际。合前后际因果为二分故。何法名无明等。偈曰。宿惑位无明。释曰。于宿世中一切惑位。于今名无明。与无明共行故。由无明力所余得起故。譬如于说王行中说导从行亦名王行。偈曰。及宿业名行。释曰。位言次第流。于宿世中福等业位。于今名行。若今有是彼果报。偈曰。托生阴名识。释曰。于母胎中初托生刹那。所有五阴名识。偈曰。此后称名色。先于六入生。释曰。从托生心。后乃至六入未生。此位称名色。应说先于四入生。云何言六。六者如此量立入故。是时四生。六圆满故。偈曰。此先三和合。释曰。若六入已生。此位说名六入。乃至根尘识三和合未起。偈曰。触先乐苦舍。能分别因智。释曰。由三和合名触。此人乃至未能了别三受因异。此位名触。若已能了别三受因。偈曰。受先淫欲爱。释曰。受位者。了别三受因为体乃至未起淫欲爱。偈曰。求淫乐具爱。释曰。于欲尘及情色爱欲生起位名爱。乃至未能寻求五尘。偈曰。四取谓生具。为得故遍寻释曰。若于此位中着心寻觅五尘。为得故于一切处驰求。此位名取。如此驰求。偈曰。当来有果报。能造业名有。释曰。此人因求得欲尘心驰求。能生长感未来有报业。此位名有。由此业从今生更退。于未来世正托生位。偈曰。更接有名生。释曰。此位名更接。何以故。于今生是识分。于未来名生。从此后偈曰。老死乃至受。释曰。除生从此后乃至受。此位名老死。是四分谓名色六入触受。于未来名老死。分判十二分如此。此缘生余处说有四种。一约刹那说。二约多时说。三约相应说。四约位说。云何约刹那说。于一刹那中具有十二分。譬如有人由随贪爱染污断众生寿命。此人一刹那具有十二分。是中痴惑名无明。作杀意名行。了别尘类名识。与识俱起四阴名色。约名色清净根名六入。六入相对和合名触。领触名受。是贪名爱。所余与爱相应上心惑名取。彼所生身口二业名有。如此等法起名生。变异名老。灭名死。复说约刹那约相应。如分别道理论说。约位说者。十二分皆有五阴。无间生相续名多时。于四中今说何缘生。偈曰。此今约位说。释曰。若分分具有五阴。云何唯说无明等为分不说余。偈曰。由胜说为分。释曰。若于位中无明为胜。说此位名无明。若于中行胜说名行。乃至老死胜说名老死。是故无失。复云何于经中说缘生有十二分。于分别道理论说异。彼论云。何者为缘生。谓一切有为法。于经有别意。故说十二。于阿毗达磨约法相说。复有别说。缘生有六种。谓约位说。约刹那说。约多时说。约相应说。约众生名说。约众生非众生名说。云何于经中但说众生名。偈曰。于前后中际。为除他无明。释曰。是故说三节。此中前际无明者。从此生疑。我于过去为已有为非有。何我已有云何我已有。后际无明者。从此生疑。我于未来为更有为不有。广说如前。中际无明者。从此生疑。此何法。此法云何。今何我当来何我。为除此三种无明。是故约众生名。三节说为十二缘生。于经中如次第说。谓无明行乃至生老死。云何得知如此。由经言。比丘若比丘。由如实正智能通达缘及缘生所生法。是比丘不约疑耶。思前际谓我于过去为已有为非有。广说如前。复有余师说。爱取有为前际后际无明。何以故。此三是未来果因故。此十二缘生。应知有三种自性。一惑二业三类。此中偈曰。三惑。释曰。三分以惑为性。谓无明爱取。偈曰。二分业。释曰。二分以业为性。谓行及有。偈曰。七分类为果。释曰。七分以类为性。谓识名色六入触受生老死。惑业依故。此类或说名果。此七分于余处说名果。所余诸分说名因。惑业为性故。何因缘于中际说果因广。类有五种差别故。离惑为二分故。于后际说果略。离为二分故。于前际说因略。说惑一门故。偈曰。略果及略因。由中可比二。释曰。由广说中际。前际后际。广因广果。例此可知。是故前后际不复广说。若复广说此言无用。若缘生唯十二分。由不说无明因。生死应至有始。不说老死果故。生死应至有边。若立无明因老死果。应更说别分。若说此二别分。则有无穷之过。若不说别分。又不免前难。不应别立。此中由佛世尊已显此义故。偈曰。从惑惑业生。从业更果类。从类类惑生。有分理如此。释曰。从惑惑生者。谓从爱取生。从惑业生者。谓从取有生。从无明行生。从业果类生者。谓从行识生。从有生生。从类类生者。谓从识名色生。乃至从触受生。从生老死生。从类惑生者。谓从受爱生。由世尊安立有分道理如此。由无明是烦恼性故。惑从类生。惑从惑生。此义自显。由老死类以受为边故。从此更生惑。是故于中不可增减如此纯大苦聚缘和合生由此言。若不尔。此文有何义相应。有余师说。于余经中说。无明以不正思惟为因。不正思惟以无明为因。于此经中不正思惟。亦是所说由入取摄故。云何不正思惟入四取摄。若说由相应故。亦应说入爱无明摄。与彼相应故。若在彼摄。此中云何能证。谓无明以不正思惟为因。若但由位摄能证因果义。爱及无明入取摄故。不应立为别分。如不正思惟。有余师说。于余经说不正思惟为无明因。此不正思惟说在触时。如经言。依眼根缘色尘。染浊思惟生。能起无明。于受时无明必生。如经言。缘无明触所生受。故爱得生。由此别经故知。不正思惟于触时起。能为受时所起无明作因缘。是故无明无无因义。故不须立别分。无无穷之过。此不正思惟。由说复从无明生。染浊思惟从痴生。此经言为证。于余经不无此义。若汝意欲立如此义。此中则应更说。彼文句不应说。若不说云何知有。由道理知有。何者为道理。若受无无明。不能为爱因缘。譬如于阿罗汉。若触不颠倒。不能作染污受因。云何知不正思惟从无明生。由于阿罗汉无无明故。触不颠倒。若由此道理故。不更说则成太甚过失。若此义由道理可见不须别说。自可得知。不但不正思惟。所余诸分不说亦应可知。则悉不须说故。此执不成救义。前所立难亦不成难。谓度无明老死。不说余故。故生死有初有边正说非不圆满。何以故。受化众生迷惑于有生。云何从宿世现世起。复从现世来世起。此三世次第相应。如来唯欲说如此多义。此义于前已说。如偈言。于前后中际。为除他无明。佛世尊说。比丘我今为汝等。说缘生及缘生此所生诸法。此二句其义何异。若依阿毗达磨义。此二无别义。何以故。此二是一切有为法故。云何未来法。未生说名所生。若尔。云何未来未是所作。说名有为。由能生故。意所引故。说名有为。若尔无流云何。是彼亦由善故意所引若尔于涅槃约至得。亦应有如此义。此有为是所生种类故。虽复未生。亦说名所生。譬如色未变坏亦说名色。由是变坏种类故。是故无失

今当说经正意。偈曰。此中缘生因。所生已名果。释曰。是分正是因。说名缘生。从此生余法生故。是分正是果。说名所生。如此一切分。皆二种成就。由是因果故。若尔安立不应成是义。不然。所观有差别故。若观此分。是分成缘生。不即观此分更成所生。譬如因果及父子。彼言大德富娄那舍说。有法是缘生。非缘生所生。此有四句。第一句。谓一切未来法。第二句。谓过去现世阿罗汉最后心。第三句。谓过去现世所余诸法。第四句。谓无为法。此中经部师曰。此执为是要术。为是经义。是经义。若说是经义则非经义。云何非是。前所说缘生。约位立十二分。一一位皆具五阴。此执与经不相应。何以故。于经中分别十二分。有别义故。经云。何者为无明。谓于前际无知。于后际无知。于前后际无知。广说如经。若经是了义。不可引令入不了义摄。是故此执非经义。君非一切经但由分别故成了义。有时诸经如胜分别作义。如象迹譬经中说。何者地界。谓发毛等。于发毛亦有色等余物。于此经中亦尔。随胜分别义。此经不可引为证。何以故。于中不由地界分别发毛等故。成不具说。于中由发毛等分别地界。非过发毛等别有地界。是故此言是具足说。于此经中具说无明等。无复所余。为不如此耶。过发毛等。于余物中如泪洟唾等亦有地界。泪等皆是所说。如经言。于身中若有所余亦尔名地界。我今亦得许如此无明所余法。若尔可得显现别类诸法引入无明。此摄有何义。若于此位中必有五阴。若此法有无。彼法必定有无。立此法为分。若有五阴诸行未必有。及识随福非福不动行乃至爱等。是故如经了别。乃是经义。前所说四句。于中若谓未来法非缘生。所生此执与此经相违。经云何者缘生所生法。谓无明乃至老死。复次生老死二分。勿许未来世摄。亦应破安立三节。有余部说。缘生是无为法。云何得知。若如来出世若不出世。此法如常住。由此经言。此言若如此意判可然。若不如此则非。云何如此不如此。若如此意判。若如来出世若不出世。恒缘无明等行等得生。无时不缘无缘余法。是故常住实尔。此执可受。若作如此执。谓有别法名缘生。此法常住。此执应拨。谓无如此。何以故。生是有为法相故。不曾见余常住法应成无常法相。生者是未有向有法相。此与无明等有何相应。而说彼为缘生。句义亦不相应。此法亦常住亦缘生。本言至行集生。此句有何义。若合此句所显义。谓诸行法至因及缘。由聚集未有成有。是义至行集生所显。此句义不相应。何以故。若一作者。于二事中。于前事一义成。于后事第二义成。譬如浴已方食。若法在至生前此法则无所有。何法前至后生。无事不依作者成故。此中彼说偈。能至先于生。无有故不然。言俱亦不然。由事约前后。无如此过失。于此义中应问学声论人。此法若生在何位。为在现世。为在未来。若尔何有。若汝言生在现世。云何在现世。若未有若已生。何用更生。若已生更生有。无穷过失。若汝说于未来位生。云何未有法成作者。若无作者事云何成。是故于此位若生。即于此位去至何位得生。未来正向生。在此位中至于缘。声论师安立作者及事。此立不成就。能有名作者。有名事我今不见。离能有法。有别事名有。是故于名言无复可难。前所立名。今更显其义。谓若此有彼有。由此生彼生。此二句义。即是至行集生名义。此中说偈

  如不有得生　　至于缘亦尔
  若已生得生　　无穷由已有

汝论中决判。一作者于二事中。于前事一义成。于后事第二义成。此判不定。或见于一作者。二事俱成。譬如灯至闇灭。又如开口眠。若汝说眼在后。云何非闭时。若别时作。有余师于此难中分别救义。波罗底以重为义。一底也是不住法。谓无常。三以聚集为义。郁波陀以生为义。此句说如此义。对种种因缘。无常法由聚集故生。故称波罗底底也三物波拖。如此分别。于此经中立。于余处云何成。如经言至于眼至于色眼识得生。云何世尊。约缘生说此二句。谓若此法有彼法必有。由此法生彼法必生。为决定故。令彼生此智故。若无明有行必有非余。是故行缘无明生。复次或为显诸分传传。故说二句。若此分有彼分必有。由此分生彼分必生。复次或为显生传传。故说二句。若前际有中际亦有。由中际生后际亦生。复次或为显证因传因故。说二句。何以故。有时从无明次第诸行生。有时从无明诸行传传生。有余师说。为除无因执常住因执。故说二句。若无因诸有不有。亦不从无生生。如彼所计常住。谓自性我等。若执如此。立前句则无用。但由此生彼生句。破二偏执。及说得成就故。复次有余道分别如此。若我有为依止。行等诸法必有。由无明等生故。行等得生。为破此执。是故世尊决判此义。若由此生彼必生。此法若有彼必有非余。谓诸行以无明为缘。乃至云如此纯大苦聚得生。复有余师说。为显不灭及生。故说二句。若无明不灭诸行不灭。由无明生故诸行生。复有余师说。为显住及生。故说二句。乃至因缘相续有。事相续必随有。由因缘生事必得生。世尊正欲显生说住有何相关。云何世尊。破次第令颠倒。先说住后托生。复有余师说。若此有彼有者。若事有缘灭必有。若尔此事应不由因生。是义不然无无因义。何以故。由此生彼生故。若经义如此。唯应说前句。若此有彼有。复次先应说事生后说。此有彼有。若作此说。文句不倒。若不尔。正问何者缘生。说灭则非次第。是故如此等执。并非经意。云何诸行以无明为缘。乃至老死以生为缘。此中我等应显唯相应义。于世间中诸婴儿凡夫。不知依因缘生唯是有为更无余法。由不知故。我见我慢染污其心。为自我得受乐及不苦不乐。由身等作三种业。为得未来乐故作福行。为得受乐及不苦不乐故。修不动行。为得现世乐故。作非福行。此三种业说名缘无明生行。由随业引诸识相续。与中阴相应受种种道。犹如灯光。行说名缘行生识。若执如此应知此识已生。于分别识分中云。何者为识。谓六种识聚。以识为先。次于此随名色生具足五阴。于分别中如此说故。余言如前。次名色成熟故。次第六入生。次于尘起乱心时。由识生故。从三和合生触。谓于乐受等胜。次从此生三受。次从此受生爱。若人由苦所逼。于乐受生欲爱。于乐不苦不乐生色爱。于不苦不乐生无色爱。次由爱所乐受故取欲等四法。此中欲者。谓五欲尘。见者谓六十二见。如梵网经说。戒者谓离恶戒。执者谓心决执犹如执狗。牛等行又如尼乾陀行。如经言。此人裸形不畜着衣。广说如经。又如婆罗门。波输波多。波立婆等外道。执取杖乌鹿皮编发灰囊三杖秃头等。我言者谓身。此中有言说谓此是我。故说身名我言。有余师说。于身中由有我见及我慢。说此二名我言。云何此二成我言。由此二说言有我故。有余师说。由我不有故。但有言说。无实义故称我言。如经言。比丘无闻婴儿凡夫。随逐世间假名言堕于我执。于中实无我及我所。复次欲者离后三。所余诸法。见取戒执取如前释。通三界我言但在色无色界。所有诸法离前二。于四中取是何法。于中贪欲名取。何以故。此义于一切处。世尊皆作此释。如经言。何者为取。于中贪欲。次以取为缘。能引未来有。此业生长说名有。如经言。阿难是业于未来。能引后有。此中说名有。次以有为缘。识更托生。是未来生说名生。具有五阴。次若生已。有老死等应知。如经中说。如此纯者。谓离我我所故。大者无初无边故。苦聚者由有流诸行聚集故。缘和合生者无果。单因缘所生故。此道理是毗婆沙师所显。是故先说。复次无明者何义。非明是名无明。若尔有过量失。眼等亦应成无明。若尔明无应是无明。若尔应以无所有为无明。此二执不相应故。应以别法为无明。别法者。偈曰。明翻别无明。如非亲实等。释曰。翻亲有别人。是亲对治说名非亲。非随余所有。及非亲无。非实者。如言说及不虚有言语能对治。此说名非实。非法非利非事等。能对治法等余法。是名非法等。非余非无。无明亦尔。有别法能对治明名无明。此义云何可知。由说为因缘故。复次偈曰。由说为结等。释曰。有余经说。无明为结缚随眠流相应。若唯无所有。不应说如此等义。亦不可立为眼等故。实有别法名无明。若尔如世言。恶妇说无妇。恶子说无子。无明亦应尔恶。明名无明偈曰。非恶明见故。释曰。若汝言非者。可诃义可诃。诸明说名无明是义。不然。何以故。若智可诃必有染污。此即以见为性故。不应成无明。若尔此智应即是无明。不可立此智为无明。何以故。偈曰。见共相应故。释曰。若无明成恶慧性。诸见不应与无明相应。二智不得一时相应起故。复次偈曰。说能染智故。释曰。经言由欲染污心不解脱。由无明染污慧不清净。若此是慧不应成慧染污。如心有别染污与心性异。谓欲无明于慧亦尔。云何不许如此。由善慧与染污慧相杂。是故不清净。故说此为彼染污。是心欲所染污。说不解脱。为决定欲所变异耶。由欲所害故不得解脱。若人治转欲熏修即得解脱。如此无明所染污慧不清净。我等分别。由无明害故慧不清净。若欲分别。何人相遮。诸师说无明与智别类。如欲与心。若有人执一切惑名无明。应以前道理破此执。何以故。若无明是一切惑性类。不应于结等义中立为别惑。若即是见。不应说与见相应。余惑与见等互不相摄故。亦应说无明染污心。故不解脱。若汝言为分别差别故作此说。于慧亦应分别无明差别。我许无明是别惑。此无明以何为性。不能了别谛实业果为性。此不可解。何法名不了别。为非了别。为了别无。若尔二皆有失。如无明若有别法。是了别对治名非了别。如此亦不可解。是故此何物分别法性。如此等类。不无如经。言何者为眼根。谓清净色。是眼识依止。复有法不可分别。而不可说无。譬如于慈观中无贪性。不净观中无嗔性等。大德达磨多罗说。我有如此计类名无明。离我慢有何别法名类。是经中所说。经云我今由知如此。由见如此。一切爱。一切见。一切类。一切我执我所执。我慢随眠灭尽故。不更生故无影般涅槃。有如此类。云何决判此是无明。由不可说此类有别惑。为不如此所余慢嗔等诸惑可非类耶。此中若更思量。有多言应说。是故须止此论。复次名色者何义。色于前已广说。偈曰。名者无色阴。释曰。云何说为名。随属名及根尘。于义中转变故。故称名。所随属何名。是世间所了别。能目种种诸义。谓牛马人色声等。此能目义。云何称名。于种种义由约用转变故称名。有余师说。于此道中弃舍身已。能转变更作别生说为名谓无色阴。六入于前已说。触今当说。偈曰。触六。释曰。谓眼触乃至意触。此六触是何法。偈曰。和合生。释曰。从三法和合生谓根尘识。此义可然。五根与尘及识。共和合同时起故。意根已谢。与未来现世法尘意识。云何得和合。即是此三和合。谓因果成和合义者。或成就一事为义。是一切三。于生起触中最有胜能。此中诸师智慧种种起不同。有诸师说。但和合名触。彼亦引经为证。经云是三法相会和合聚集说名触。有余师说。有别法与心相应名触。彼亦引经为证。经云六六法门。何者为法门。内入有六。外入有六。识聚有六。触聚有六。受聚有六。爱聚有六。何以故。此经中从根尘识。别说触聚故。此中若诸师说。唯和合名触。彼救义如此。君非为别说故诸法有别类。勿从法入受爱等法成有别类。无如此失。异受爱等。法入有故。从三成触。无如此别三。于中可执余为是。于中若有根尘无识为余。无有别识无有根尘为余。是故若已说三更说触。则无复义。有余师说。非一切眼及色是眼识因。非一切眼识是眼色事。是故于中若有成因成果安立。是诸为触。若诸师说触异和合。云何避此经。经云是三法相会和合聚集说名触。彼诵经异。复次由因说果名。譬如天上乐地狱苦。此言由多立破差别故。则成漫说。须止此论。阿毗达磨师说。触定是别法。于六触中。偈曰。五是有碍触。第六依言触。释曰。眼耳鼻舌身触。此五名有碍触。依止有碍根故。第六意触称依言触。何以故。依言者谓名。此名是意识长境界故。意识得依言称。是故意触称依言。如经言。由眼识但识青不能识此是青。若由意识识青亦能识此是青。第一触依止所显。第二触境界所显。有余师说。意识依言于境生起。非五识。是故唯此一称依言。与此相应触。称依言触。故第一依止所显。第二相应所显。复次此六触更立成三触。偈曰。明无明余触。释曰。有明触有无明触。有异于二触。谓非明非无明触。此触次第应知。偈曰。无流染污余。释曰。若无流说为明触。若染污说为无明触。与明无明相应故。余为非明非无明触。与二不相应故。何者为余。谓有流善及无覆无记。复次无明触由数数起故。取一边成二触。偈曰。嗔恚贪欲触。释曰。由与嗔恚贪欲相应故。复次由摄一切故。偈曰。乐苦舍领三。释曰。复有三触。谓乐受所领触。苦受所领触。不苦不乐受所领触。于乐受等好故。复次是领复易领。说此名受。此受于中有故。说为乐受触。如此苦受触不苦不乐受触。应知亦尔。若尔此触应成十六。说触已受今当说。此中触前已说六种。偈曰。从此生六受。释曰。六受者。眼触所生受。耳鼻舌身意触所生受。于中偈曰。五属身余心。释曰。此受从眼触。乃至身触生有五。说名身受。依止有色根故。心触生受。此一名心受。唯依止心故。复次若受生。为在触后。为与触俱。毗婆沙师说。一时俱起。互为俱有因故。云何俱生二法中。能生所生差别得成。云何不成。无能故。于已生法余法无复能。此证与立义不异。何以故。是时说。云何俱生二法中能生所生差别得成。于此时中。此义亦彼说。谓于已生法余法无复能若尔更互能生故有失。是所许故有何失。俱有因互为果。此实所许。于此经中非所许。谓触与受互为因果。曾闻如此缘眼触。眼触所生受生。不曾闻缘眼触所生受眼触生。复次是义不然。由过能生家法故。若法能生此法必别时不得俱。譬如先有种后生芽。先乳后酪。先击后声。先意后识。如此等非不成因果前后差别。同时因果亦成。譬如眼识等与眼色等四大及四大所造色。此中先有根尘后方有识。从先有四大及四大所造色。后时所造色生。若执如此。复有何难。若尔如芽影。触受亦然。有余师说。从触后受生。何以故。先有根尘次有识。是三和合为触。缘触后受生。于第三刹那。若尔于一切识不必有受。亦非一切识有触。无如此失。何以故。以前触为因。于后触中受生故。一切触有受。今非道理更起。此中云何非道理。于二触中各有境界。以先触为因。于后触受生。别类境界触所生受。应缘别境界起。此义云何可然。复次是心共受相应。此受与心不同境界。此义复云何成。若尔应立此义。是时识成触。此识无受。从此后识有受无触。因缘不相应故。此执何失。若尔大地定义即破。谓于一切心十大地。必俱。此大地定义于何处立。于阿毗达磨中立。君我等以经为依。不以阿毗达磨为依。佛世尊说。汝等应依经行。大地义不尔。于一切心必有。若尔大地义云何地有三。谓有觉有观地。无觉有观地。无觉无观地。复有三地。谓善地。恶地。无记地。复有三地。谓有学地。无学地。非有学非无学地。是故于前三初地若有是名大地。若法定于善地中有。是法说名善大地。若法定于染污地中有。是法说名恶大地。此法如应相代。有非一切时俱起。余师说。如此善大地等者。由应文句。是故被引。今说先不说。若从触后受生。汝应救此经。经云依眼缘色眼识生。三和合有触。俱生受想故。意等经中说俱生。不说与触俱生。此何所救。若俱必应触。此俱言亦曾见于次第中。如经云何修习与慈俱起念觉分。故俱言非证。是义不然。何以故。于经中说是受是想。是故意是识。此法并相杂不相离。是故无识与受不相杂。此义应思量。相杂是何义。于此经中亦说如此。是所受即是所思。是所思即是所想。是所想即是所识。此义未可解。为决四法境界。为决四法刹那。寿命及暖触俱起中。由说相杂言。决定刹那成。复有经说。三和合名触。云何有识非三和合。有三和合非触。是故此义必定应然。谓一切识中。有触受等与触俱起。前来多种争论。于事已足。本所依义今次当说。于前已略说心受。偈曰。此复成十八。由心分别行。释曰。此心受更分成十八。由分别十八意行故。何者十八心分别行。有六喜分别行。有六忧分别行。有六舍分别行。此云何成立。若由自性应成三。谓喜忧舍分别行。若由相应应成一。与意识相应故。若由境界应成六。缘色等六尘故。若成立十八。必依三。于中十五名色等分别行。非相杂境界。决定缘色等起故。三名法分别行。有二种心分别行。此句何义。彼说依意识喜等分别境界。余师说于六尘令意分别行。由随受故。于境界中。意数数分别行故。云何身受不说为意分别。此受不依意不能分别。由五识无分别故。是故不应为分别行。第三定乐云何不入分别行中摄从初于欲界中无心地乐根故。能对治此苦分别行无故。若彼但依心地起。此义云何。经言由眼见色已。堪为喜处即分别行。如是等依五识所引意故说如此。若实判十八。皆以意识为地。譬如不净观。眼识所引在于心地。复次见已乃至触已。由此言说故。不可为难。若不见乃至不触。起分别行。此亦意分别行。若不尔。于欲界中缘色界。于色等中不应有分别行。缘欲界香味触。于色界中分别行亦不应成。随明了道理故。如此说。若人见色。于声分别行。此亦是分别行。随不相滥故说。由定判根尘故。为有如此色定为喜处乃至定为舍处不。有约相续决定。非约境界。于分别行中几与欲界相应。于中几种。何法为境界。乃至于无色界。亦应如此问。偈曰。一切缘欲界。释曰。于欲界中具有十八。是五为一切境界。于中偈曰。有色十二境。释曰。色界十二意分别行境界。除六香味分别。于彼无此二故。偈曰。三后。释曰。境界从上流。若无色界。但三法分别行境界。于彼色等无故。说欲界相应已。与色界相应今当说。偈曰。于二定十二。释曰。除六忧分别行。所余十二与二定相应。云何如此。偈曰。行欲界。释曰。若彼缘欲界。偈曰。自八境。释曰。此色界若为自分别行境界。但八分别行境界。除香味四分别行故。偈曰。无色二。释曰。无色界为二法分别行境界。偈曰。于二定六。释曰。于第三第四定。但六舍分别行无余。此六境界。偈曰。欲界六。释曰。若缘欲界。此成六舍分别行境界。偈曰。自四。释曰。若缘自界。但四舍分别行境界。无香味故。偈曰。余界一境界。释曰。无色界异下二界故称余。此唯一法分别行境界。说色界相应已。与无色界相应今当说。偈曰。有四于色边。释曰。空无边入道。说此名色边。于中有四分别行。谓色声触法分别行。偈曰。行色。释曰。此四缘第四定为境。若人执如此。则离四为境界。若人执合第四定为境界。于中但一总境界。谓法尘分别行。偈曰。一行上。释曰。若道分别行。缘无色界起但一。谓法尘分别行。偈曰。一于本。释曰。若于根本无色界。但一法尘分别行无余。此行偈曰。自境。释曰。但缘无色界。何以故。无色根本定。不得取下界为境界故。此义后当显说。如此等意分别行。偈曰。诸十八有流。释曰。于中无一分别行。是无流故。言诸有流。何人复几意分别行共相应。若人生于欲界。未得色界善心。与一切欲界分别行相应。与初定二定地。八分别行相应。与三定四定。四分别行相应。悉有染污。除缘香味境故。于无色界与一染污分别行相应。若人得色界心未得离欲。与欲界一切分别行相应。与初定有十分别行相应。有四染污喜分别行。除能缘香味境故。有六种舍分别行。未来定为地。第二第三第四定及无色界。分别行相应。应知如前。由此道理。所余应自随判。若人已生定地。于欲界与一舍法分别行相应。谓欲界变化心。有余师说。有如此意分别行义。如毗婆沙师立。于经中见分别行义异于此。何以故。若人从此地离欲。此人不得缘此为境起分别行。是故虽复有流。非一切喜等是意分别行。若尔以何为分别行。若有染污。若意由彼能分别行于境界故。彼名分别行。云何分别行。或爱着于境。或憎恶于境。或不简择舍境。为对治此三故。如来说六恒住法门。如经言。由眼见色。不生喜心。不生忧心。住舍心有念有智。乃至由意知诸法亦如此。云何知如此。诸阿罗汉人。不无世间善缘法喜根。若有染污为分别行。应知此法门为对治。复次喜等或三十六寂静。足由依爱着出离差别故。此差别是阿毗达磨所说故。此中依爱着皆悉染污。依出离皆悉是善。如此有分名受。应知有无量差别。所余诸分不复更说。云何不说由此义故。偈曰。由已说当说。释曰。此中有有分。于前已说。有有分于后当说。此中识者前已说。如偈言

  识阴对对视　　或说为意入
  或说为七界　　谓六识意根

六入者前已说如偈言

  此识依净色　　说名眼等根

行有于业俱舍中当说。爱取于惑俱舍中当说

阿毗达磨俱舍释论卷第七阿毗达磨俱舍释论卷第八

        婆薮盘豆造

        陈天竺三藏真谛译

    中分别世间品之三

行有于业俱舍中当说。爱取于惑俱舍中当说。如此缘生。若略说唯三。谓惑业果类。此三义前已显。偈曰。于中说诸惑。如种子及龙。如根树及糠。释曰。此惑与种子等。云何相似。譬如从种子芽叶等生。如此从惑惑业类生。又如池是龙所镇住处恒不枯涸。如此惑龙镇住生池相续不断。又如树未被拔根。斫斫更生。如此未拔除惑根诸道灭灭更起。又如树时时生花生子。如此诸惑数数生惑业类。又如米为糠所裹。于生有功能非单米。如此业为惑至得糠所裹。于生别生有功能非单业。如此诸惑应知如种子等。偈曰。如有糠米业。及如稻并花。释曰。于前已说惑似糠。今说业如有糠米。又如稻蕉等以果熟位为边。如此诸业已熟不更生报。又如花于生子中是近因。如此业于生果报中最为近因。偈曰。如熟饮食类。释曰。如已熟食及饮。一向为受用。不可更转为生。如此果报类。不能于别生中更牵别果报。若更牵报无得解脱义。如此生相续依因依缘生。不过四有。谓中有生有先时有死有。此四于前已释。偈曰。于四种有中。生有必染污。释曰。此中几有定不定染污。若一向染污。唯是生有。由何惑。偈曰。由自地诸惑。释曰。若生有在此地。一切同地惑皆为染污。于三界无有一惑由此众生不结生。阿毗达磨师说。如此此染污由大惑。不由小分惑。由自在故。若此位最昧钝。随有惑先数数起惑最近。是时于此位中此惑即起为染污。由先疾利故。接中有为必应知如此染污不。偈曰。余三。释曰。所余三有。即中有等。各有三种。谓善染污无记。于诸有中几有于何界相应。偈曰。无色三。释曰。除中有所余有。何以故。无色界非隔别处。为至彼故起中阴。于欲色界不数故。则知皆具四有。如众生依因依缘生。此义已广说。若众生已生。云何得住。偈曰。世间以食住。释曰。有一法世尊自通自知。为他正说。谓一切众生以食为住。经言如此。此食有几种。有四种偈曰。段食。释曰。段食者有粗有细。细者是中有众生食。以香为食故。及诸天劫初众生食。以无变秽流故。此食悉入彼身。如油于沙。复次若细众生彼食亦细。譬如发污虫等。触食第二。作意食第三。识食第四。此中段食者。偈曰。于欲界。释曰。此食于色无色界无。由离欲此于彼生故。偈曰。以三入为体。释曰。于欲界香味触入。一切皆名段食。作段吞故。先以口鼻含之。后分分吞故。影光焰辉。此等云何成食。由从多故。作如此说。此等若非所食能令相续住。亦入细食数。譬如浴涂等。云何色入非食。若作段食必约于色。偈曰。非色入由此。不利自根脱。释曰。食是何法。若能利益自根四大。色入者于正食时。不能利益自根及四大。何况能利益余根及四大。非自境界故。有时见色即起乐及喜。此色亦非食。但缘此为境。能生乐受等触。以此为食非色。复次已得解脱人。谓阿那含阿罗汉。见可爱饮食无利益故。偈曰。触作意及识。三有流通二。释曰。触者从三和合生。作意者是心业。识者是意识。此三若有流必是食。此三通三界有。云何不立无流为食。由立食以能滋长诸有为义。无流生起能灭尽诸有。毗婆沙师执如此。复次于经中说食义。食有四种。为令已生众生得住。及为愈相续。又为利益寻求生众生。无流法不尔。是故非食。已生者于道中已生众生。此义易解。何者寻求生。偈曰。意生寻求生。乾闼婆中有。对有。释曰。世尊以此五名。说中阴众生。何以故。此众生从意生故。故说意生。不取不净及血所有诸外为生依故。寻求生者。欲得生未得故。处处寻求生。乾闼婆者。由食香故。以香益身行向于道故。对有者。对向生处起故。如经言。对起有碍害自体。生有碍害世间。由此经言故。对有名中阴。复有别经言。有众生对有结已尽。非生有结。此经中有四句。复次已生者。谓阿罗汉。寻求生者。谓有爱众生。复次几种食令已生众生。住几种食能滋益寻求众生生。毗婆沙师说。一切食皆能为二事。何以故。段食亦于有爱众生令得后有。佛世尊说。有四食为病根痈刺老死等缘。作意食亦曾见令现生住。先旧师说如此有一父遭饥饿难。以满囊灰挂置壁上。慰喻二子语云是糗。二子数思糗囊。得多时安住。后时有人。为开彼知是灰。失先作意即便命终。复次于海中有多人。船败见大涛聚。思谓是岸。随往趣彼。至已触之方知是涛。失先作意即便命终。于别诵中说。海中有大身众生。从水登岸。于沙上生卵。以沙覆之还入海中。若母于此卵忆念不忘。卵则不坏。母若于中忘失忆念。此卵即坏。经部解不尔。勿由他食他食得成。若释应如此。于中若卵缘母。忆念不忘。卵则不坏。若忘即坏。有余师说。此忆在触位中。云何说食唯四。为不如此耶。一切有流法。必能滋益有。虽然由胜故说。偈曰。为益此。能依所依二。能引生别。有次第说后。二释。曰所依者。谓有根身。为滋益此身段食为胜。能依者。谓心及心法。为滋益此法触食为胜。如此二食。于滋益现世已生有中胜余。复立作意食者。于引后有为胜。是所引有。从业所薰修识种子生。如此后二。于引生未生有为胜。是前二食如乳母。能将养已生故。后二食如生母。能生未生故。由胜余故唯立四。为一切所吞分段皆是。食不有分段是所吞而非段食。此有四句第一句者。若吞此分段。诸根坏损害四大。第二句者。谓余三食。第三句者。是所吞分段能滋益诸根增长四大。第四句者。除前三句。如此与触等如理应各立四句。为有缘触等得诸根滋益。及四大增长。是诸亦非食不。有谓别地及无流。余句应思。若人食此食。损食者根大。此物亦是食。由执初至故。何以故。段食于二时中作食用。若正食时对治本病。若消时增益身大。毗婆沙师说如此。于何道有几食。于一切道有一切食。于生亦尔。于地狱云何有段食。有燃赤铁段为食。锡赤铁汁为饮。若能损害物亦是食。则违前四句。亦违分别道理论。彼论云。何者为段食。若缘此分段滋益诸根。增长四大相续得愈。及识亦尔。广说如论。由约能增益食说。故无相违。损害食于地狱中亦有食相。何以故。此食有能为暂遮饥渴等病。复次有别处地狱。如人道有段食故。是故段食遍五道中。有此义应然。佛世尊说。若有人施一百离欲欲界外仙人食。若有人施一凡夫人食。此人在剡浮密林中行。于此前施后施。福德百千倍胜。是何凡夫在剡浮密林中行。余师说。住于剡浮。或云。是有福凡夫。此执不然。由说一故。此中何所以。施一凡夫食福德。多胜施多离欲凡夫。若施多凡夫食。此福德胜施一凡夫。是义可然。有余师说。是近佛地菩萨。余师不说此义。何以故。若施此菩萨福德最多。不可称数。若施此人所得福德。乃至施百俱胝阿罗汉。亦所不及。毗婆沙师说。有凡夫已得四谛观决择分能。此中说名在剡浮密林中行。此名与义不相称。又不曾于余处但假安立此名。谓经及阿毗达磨藏等中。说剡浮密林中行。必得四谛观决择分能。是故此是自所分别。若尔云何。必约菩萨正在剡浮密林中行。故说此言。何以故。此菩萨于是时与凡夫离欲。欲界二义相应故。于余仙人分别。令异此菩萨。于无边众生无量倍胜。而报百者。由随前所立。此义必应尔。何以故。由除此人于外仙人格量须陀洹故。若不尔。应以剡浮密林中行格量须陀洹说众生依因依缘生。及众生得住义已。众生死堕义亦已说。谓由福尽。不由命尽等。此义今当说。为于何识正起时众生得死堕及托生。偈曰。断接善离欲。退及死托生。此事于意识。释曰。断善根。更接善根。离欲下界。退失上界死生。如此六法。于意识中成。非于余识。由说生故。托中有义亦是所说。若约受死生云何。偈曰。于舍受死生。释曰。舍命及受生。此二心在不苦不乐受中。此受昧钝故。余受则明了。于明了识中死生不成。于此意识中。偈曰。非一无心二。释曰。死及生虽复在意识。非一心及无心中。何以故。若人正在定心无死生义。地非同分故。功用所成故。能为利益故。于无心中亦不得死。何以故。若无心人则无横害。是时依止若欲起变异。是时随属依止心。必定起现前。后方舍命非余。若于受生时无心亦不应然。心断因不有故。若离上心惑。不得受生故。是故于中无心不应道理。死有有三种。于前已说。偈曰。涅槃二无记。释曰。于威仪心及果报心。若于欲界中。有果报名舍。若无于威仪心般涅槃。云何但于无记非余心中。此无记。随顺心断绝。由力弱故。若人正死。于何身。分中意识断灭。若一时死。身根共意识一时俱灭。若人次第死。此中偈曰。次第死脚脐。于心意识断。下人天不生。释曰。若人必往恶道受生。及人道天道。如此等人。次第于脚于脐于心意识断灭。不更受生是名不生。谓阿罗汉。此人于心意识断绝。有余部说于头上。何以故。身根于此等处。与意识俱灭故。若人正死。此身根如热石上水渐渐缩减。于脚等处次第而灭。复次若众生如此次第舍命。于中多众生。为斫末摩苦受所逼方死。云何斫末摩。偈曰。末摩水等。释曰。末摩者。于身有别处。如偈言

  于身有是处　　由随触令死
  若优钵罗花　　须微尘所触

故知身中有别处若于中被损触能引令死。此身分名末摩。此末摩。水风火中随一大若起相乖。似利刃斫之。即便破坏。此不如薪等被斫即断如被斫即无复动觉。故说名斫。云何不由地大第四病无故。风热痰三病。如次第以风火水大为上首。与外器世界三灾相似故。是故于内身有三灾。此斫末摩苦受死者。多于此人起。谓能数数行。斫他末摩事。此人必由斫末摩苦受死。于诸天中无末摩苦受死。虽然若诸天子应有退堕事。先有五种小变异相现。一衣服及庄严具出不可爱声。二身光闇昧。三正浴时水滴住身。四本心于尘驰动今住一尘。五眼有瞬动。此五或时不定。复有五种大变异相现。必不免死。一衣服染着尘秽。二花鬘萎燥。三腋下汗出。四臭气入身。五于自坐处不得安坐。如此众生世界如此生住退。佛世尊安立。属三聚摄众生。聚有三种。一正定聚。二邪定聚。三不定聚。于此中偈曰。正定邪定聚。圣人无间作。释曰。何者为正。欲尽无余。嗔尽无余。痴尽无余。一切惑尽无余。故名为正。经说如此。圣者若此人相续中无流道已生故名圣。云何名圣。从恶堕法能远出离故名圣。由至得必定永离灭果故。如此等人由于惑尽定故。故名正定。若人已得解脱分能。善根必定涅槃为法。云何不立为正定。此人后当堕于邪定。此人不由时定定于正中。譬如七胜等。何者为邪。地狱畜生鬼神道。说此名邪。此中作无间业人。于地狱道中定故。说名邪定。若异二定所余非定。此义自成。是三聚观因缘属二不属二

说众生世界已。器世界今当说。偈曰。此中器世界。说于下依住。深十六洛沙。风轮广无数。释曰。三千大千世界。诸佛说深广。谓依于空住下底风轮。由众生增上业所生。此风轮厚十六洛沙由旬。纵广无复数。坚实如此。若大诺那力人。以金刚杵悬击掷之。金刚碎坏而风轮无损。于风轮上。偈曰。水轮深十一复有二十千。释曰。于风轮上。由众生业增上。诸云聚集雨雨滴如大柱。此水轮成。深十一洛沙二万由旬。云何于中水轮不傍流散。由众生业增上力故。譬如所食所饮。是诸食饮若未消时。不堕熟藏。余师说如此。或如食道理故。由风所持故不流散。余部说如此。复次此水由众生业胜德所生。有别风大吹转此水。于上成金。如熟乳上生膏。偈曰。水厚八洛沙所余皆是金。释曰。所余有几许。三洛沙二万由旬。是名金地轮。在水轮上。水轮并金地轮。厚量已说。偈曰。径量有三千。复有四百半。有十二洛沙。水金轮广尔。释曰。此二轮径量是同。偈曰。若周围三倍。释曰。若以边量数则成三倍。合三十六洛沙一万三百五十由旬。金地轮在水上。于此地中。偈曰。须弥娄山王。由乾陀罗山。伊沙陀罗山。佉特罗柯山。修腾婆那山。阿输割那山。毗那多柯山。尼旻陀罗山。释曰。如此等山依金地轮上住。八大山中央有须弥娄山。所余山绕须弥娄住。一由乾陀罗。二伊沙陀罗。三佉特罗柯山。四修腾婆那。五阿输割那。六毗那多柯。七尼旻陀罗。此须弥娄山七山城所围。最外山城名尼旻陀罗。偈曰。于四大洲外。复有轮围山。释曰。于第七山外有四大洲。于四大洲外复有铁轮围山。由此山故。世界相圆如轮。于中偈曰。七金此是铁。释曰。由乾陀罗等七山皆金所成。此最外围山唯铁所成。偈曰。四宝须弥娄。释曰。约四边次第。金银琉璃颇梨柯四宝所成。诸边随能成宝。类光明故。于诸方中空色显现似于本宝。对剡浮洲须弥娄边。琉璃宝所成由此宝光映故。见空青色似于琉璃。复次云何如此等宝得生。于金地上。复有诸云雨。水滴如车轴。此水为种种种子胎藏。有种种威德差别。风吹变此水。转成种种类宝。如此转变为生别种类事总别。由不先有及不并有。道理能作因缘。不同僧佉外道所立转变义。僧佉转变者。此物先已住。转成别法。若尔有何失。此有法不可解。此法已住。由有于中分别诸余法。何人说如此。从法有法异。此法类不异。唯成异相说名转变。若尔亦非道理。云何非道理。此物即是即此不是。先未曾有。此言说道理。如此方便。金等诸宝已聚集生。有别风由业威力所起。此风能引取诸宝。集在一处。即成山成洲。所取处成内外海须弥娄等山。铁轮围为后。偈曰。入水八十千。释曰。于金地上有水。深八万由旬。此中诸山次第入中。偈曰。此山出水上。亦八万由旬。释曰。如此须弥娄山。高一十六万由旬。偈曰。八山半半下。释曰。由乾陀罗山。从水上高四万由旬。半下须弥娄山。伊沙陀罗山。半下由乾陀罗山。如此于诸山应知次第半。下乃至铁轮围山半下。尼旻陀罗山。高三百一十二半由旬。偈曰。高广量平等。释曰如诸山从水上高量。广量亦尔。偈曰。其中间七海。释曰。尼旻陀罗最为后。于彼中间有七海。遍满八功德水。此水冷美轻软清香。饮时不咽逆。于喉饮已利益内界不损于腹。此七海中。偈曰。初海八十千。释曰。由乾陀罗内是第一海广。八万由旬偈曰。说此名内海。释曰。海有二种。一内。二外。此二山内海。偈曰。一一边三倍。释曰。已说此海广八万由旬。若约乾陀罗内边数。一一边三倍。此广合成二洛沙四万由旬。偈曰。余海半半狭。释曰。由乾陀罗。伊沙陀罗。此二山中间是第二海。半狭初海。广四万由旬。半第二广为第三由。此半半狭。应知余广量。乃至第七广一千二百五十由旬。长量不说。由多量差别出故。偈曰。所余名外海。释曰。何者为余。尼旻陀罗铁轮围。二山中间名外大海。此海碱遍满碱烈味水。此海约由旬数广。偈曰。三洛沙二万及二千。释曰。大海量如此。偈曰。于中。释曰。有四大洲。对须弥娄四边。偈曰。剡浮洲二千。三边相如车。释曰。于此海中剡浮洲一边二千由旬。三边等量。其相似车。于此洲中央。从金地上起金刚座。彻剡浮洲地。与上际平。一切菩萨皆于中坐。修习金刚三摩提。何以故。更无余依止及处能堪受此三摩提。偈曰。一三由旬半。释曰。此第四边广量三由旬半。是故此洲似车相。偈曰。东洲如半月。释曰。从此洲向东。对须弥娄边有洲名弗婆毗提诃出海上。其相如半月。若约边量。偈曰。三边如。释曰。此洲三边如剡浮洲三边。量各二千由旬。偈曰。一边。三百半由旬。释曰。是第四边。广三百五十由旬。偈曰。瞿陀尼相圆。七千半由旬。释曰。从此洲向西。对须弥娄边有洲。名阿婆罗瞿陀尼洲。边量七千五百由旬。此洲相圆如满月。偈曰。径量二千半。释曰。中央广二千五百由旬。偈曰。鸠娄八千等。释曰。从此洲向北。对须弥娄边有洲。名郁多罗鸠娄洲。边量八千由旬。四角畟方其相似比陀诃。四边量等。如一边二千由旬。余边亦尔。无微毫增减。随诸洲相。于中住众生面相亦尔。此四洲中间有诸别洲起。诸洲何名何处。偈曰。二提诃鸠娄。遮摩罗遮罗。中间有八洲。舍诃北[璊-王+月]陀。释曰。此中有洲。一提诃。二毗提诃。属东毗提诃。是彼类故。又有二洲。一鸠娄。二高罗婆。属北鸠娄。是彼类故。复有二洲。一舍陀诃。二郁多罗[璊-王+月]陀。属西瞿陀尼。是彼类故。复有二洲。一遮摩罗。二阿婆罗遮摩罗。属剡浮洲。是彼类故。此诸洲皆是人所住处。唯阿婆罗遮摩罗一洲。是罗刹住处。偈曰。此中向北地。九山边雪山。释曰。此剡浮洲中。向北地有三黑山。度三黑山复有三黑山。度三黑山复有三黑山。此山悉下故名蚁山。九山北边有雪山。从雪山向北地。偈曰。香雪二山间。五十由旬池。释曰。雪山北边。香山南边。此处最胜。其中有池名阿那婆怛多。从此池流出四大河。一恒伽。二辛头。三私多。四薄搜。此池纵广各五十由旬。遍满八功德水。非人所行处。若有通慧人乃可得行。此池南边山高二十五由旬。北边山高五十由旬。此二山杂物所成。从香山北边最胜处。有岩名难陀。七宝所成。纵广各五十由旬。唯是象王所住处。从此度六国土。及度七重林。七重河度第七河更有二林形如半月。此林北生剡浮树此树高百由旬。此树子若熟味美无等。由此树最高子味最美。故洲因此立剡浮名。地狱在何处。其数量复云何。偈曰。向下二十千。阿毗指广尔。释曰。于此剡浮洲。下二十千由旬有地狱。名阿毗指。深广各二十千由旬。若从底向上。四十千由旬。于中苦受无间故名阿毗指。何以故。于余地狱苦受有间。如更活地狱中众生。身已被斫破及撞捣。有冷风吹其还生故。名更活地狱阿毗指中无如此事。有余师说。于中无乐间苦。故名无间。何以故。于余地狱虽无乐果报。不遮等流果故。偈曰。上有七地狱。释曰。从此阿毗指地狱上。有七种地狱。次第重累。一大烧。二烧。三大叫唤。四叫唤。五聚磕。六黑绳。七更活。余部说。此七地狱在阿毗指地狱四边。此八地狱。偈曰。八十六园。释曰。此一切地狱。各各有十六园佛世尊说

  如此八地狱　　我说难可度
  满极恶业人　　各有十六园
  四面有四门　　害具及量等
  铁城所围绕　　六方皆铁板
  铁地悉焦热　　猛火恒洞燃
  无数百由旬　　遍满焰交彻

何者为十六园。偈曰。热灰及死尸。刃路等烈江。于彼四方异。释曰。此八地狱四面。各各对门有四种园。一热灰园。深皆没膝。众生于中若下脚血肉即皆烂尽。如腊滴赤铁上。举脚血肉还生。二死尸园。此园死尸遍满。地皆是粪。于中有虫名攘鸠多。身白头黑口利如针。破彼众生皮肉及骨。啖食其髓。三刀刃路园。有大路遍密有利刀刃。众生于中若下脚血肉皆断坏。举脚血肉还生。复有剑叶林园。于中有赤利剑等仗。风吹堕落斫刺彼众生身及身分。复有铁苫摩利林。利刺长十六寸。于中众生或上或下。若上刺头则向下。若下刺头则向上。刺彼众生身血肉皆尽。于中复有乌色及驳色狗。各取彼众生食之。复有铁觜乌。啄食彼众生心眼。此刀刃路等三众生。同为杖所害故。合为一园。四烈灰汁江园。江名鞞多梨尼。遍满极热烈灰汁水。众生若入其中。于两岸上有人捉剑槊叉等仗。遮断不令得上。众生在中或踊向上或沉入下。或傍回转被蒸煮熟。譬如大镬满其中水下燃猛火。于中有米豆麻麦等被蒸煮熟。彼众生亦尔。此江园似大地狱堑。此四园由方有异故成十六。是最极杀害困苦事处故名园。有余师说。从地狱内出入。彼更没于苦故名园。从问更生别问。此地狱卒为是众生。为非众生。说非众生。若尔彼云何行动。由众生业。譬如成世界风等。若尔云何大德达摩须部底说偈言

  恒嗔最粗业　　于恶起爱乐
  见他苦生乐　　必作阎摩卒

是彼狱卒。由王教掷众生于地狱中。故说彼为阎摩王罗刹。非前能作杀害事立为众生。余部说。彼悉是众生。若尔此业复于何处受报。当于此处受报。何以故。彼由宿恶业报故。于此处生。于中更作恶业。即于中受报。若尔作无间业众生。所受果报处。彼在其中何法遮令不受此报。云何彼在火中而不被烧。汝作如此思。不业为彼属火。故不被烧。生于此中。与余不异。云何为卒。如此八种说名热地狱。偈曰。八寒地狱頞浮等。释曰。复有余八寒地狱。一頞浮陀二。尼剌浮陀。三阿吒吒。四阿波波。五沤睺睺(香候反)。六郁波罗。七波头摩。八分陀利柯。于此八中众生极寒所逼。由身声疮变异相。故立此名。此八是剡浮洲下。大地狱傍。剡浮洲如此广量。云何于中得容阿毗指等地狱处。诸洲向下广。譬如谷聚。是故大海次第渐深。如此十六地狱。一切众生。增上业所起。有别处地狱。由众生自业所起。或多人共聚。或二人或一人。此别地狱差别多种处所不定。或在江边。或在山边。或在旷野。或在余处。地狱器本处在下。畜生行处有三。谓地水空。大海为本处。从海行于余处。鬼神以阎摩王处为本处。此王处于剡浮洲向下深五百由旬。有大国土。纵广亦五百由旬。是鬼神本所住处。从此本处散行余处。于鬼神道中。有大福德业神通。受用富乐如天上所。余诸鬼神如饿鬼。本业经说

复次月日在于何处。住于风中。何以故。是风于空中由众生共业增上所生。绕须弥娄山转。如水洄澓。能制持日月及星。从此洲向上。日月行高几由旬。偈曰。日月弥娄半。释曰。与由乾陀罗山顶齐。彼行如此。月日量云何。偈曰。五十一由旬。释曰。月轮径五十由旬。日轮径五十一由旬。诸星轮量。若最小径一俱卢舍。若最大径十六由旬。日轮下面。外边颇梨抲宝所成。皆是火珠。此宝能炙能照。月轮下面外边月爱宝所成。皆是水珠。此宝能冷能照。由众生业。于眼身果花谷苗草药等损益中。如应有能。于四洲中唯一月能作损益事。一日亦尔。此一日于四洲为俱能作。日所作事不。不尔。云何不尔。于中偈曰。夜半日没中。日出同一时。释曰。若于北鸠娄正半夜。是时于东毗提诃日正没。于剡浮洲日正中。于西瞿陀尼日正出。于余处例皆如此。于此洲中由日行有差别。夜刹那有时增有时减。日刹那亦尔。此中复偈曰。雨际二后九。夜则渐渐长。释曰。雨时第二月第二半第九日。从此去夜渐渐长。偈曰。寒际第四月夜短。释曰。于冬时第四月第二半第九日。从此去夜渐短。偈曰。日翻此。释曰。是时夜若增。是时日即减。是时夜若减。是时日即增。几量增几量减。偈曰。日夜长罗婆。释曰。夜若增增一罗婆。日增亦尔。此增次第应知。偈曰。日行南北时。释曰。若日行剡浮洲南边夜则长。若日行剡浮洲北边日即长。于白半初。云何见月轮不圆。此有何因。偈曰。由自影近日。故见月不圆。释曰。若月宫殿行近日宫殿。是时日光侵照月宫殿。由此日影覆月余边。是影显月轮不圆。分别世经说。如此先旧诸师说。日月行相应有如此。有时见不圆及半。复次日等宫殿何众生于中住。四大天王所部天。此诸天为唯住此中。更有别处。若住宫殿唯住此处。若依地住在须弥娄山诸层中住。此山有几层。一一层其量云何。偈曰。山王层有四。相去各十千。释曰。须弥娄山。从水际取初层。中间相去十千由旬。乃至第四层。相去亦尔。由此四层山王半量。层层所围绕。此四层次第出。复有几量。偈曰。十六八四二千由旬傍出。释曰。初层从须弥娄傍出十六千由旬。第二八千。第三四千。第四二千由旬出。何众生得住此中。偈曰。俱卢多波尼。持鬘恒醉神。诸四大王天。释曰。有夜叉神名俱卢多波尼住初层。复有诸天神名持鬘住第二层。复有天神名恒醉住第三层。如此等皆是四大王天军众。四天王自身及余眷属。住第四层。如于四层中四大王天眷属住。偈曰。于余山亦尔。释曰。于由乾陀罗等七山小大国土。四大天王所余眷属住皆遍满。是故四天王天众皆依地住。三十三天住须弥娄顶。偈曰。三十三住顶。纵广二十千。释曰。于须弥娄山上。帝释及三十三天住此最胜处。此处纵广云何。有余师说。一一边各八万由旬。如下际。此名最胜处。有余师说。于须弥娄顶中央。一一边各二万由旬。周围八万由旬为最胜处。三十三天于其中住。偈曰。方角有四峰。金刚神所住。释曰。须弥娄四维各有一峰。此峰径五百由旬。高量亦尔。有夜叉神名金刚手。于此中住守护诸天。此须弥娄顶。偈曰。中央二千半。高一由旬半。有城名善见。金软多爱相。释曰。须弥娄山王顶。中央有大城名善见。纵广各二千五百由旬。高一由旬半。皆金所成。百一种类宝之所庄饰。城地亦尔。地触柔软犹如绵聚。下足即没举足还满。此城是帝释所都之处。偈曰。一边二百半。皮阇延多殿。释曰。天帝释所住宫殿。在大城中央。名皮阇延多。由种种宝类所庄饰故。此处最胜。能映夺诸天宫殿可爱相貌。此殿纵广各二百五十由旬。于大城内有如是等最胜可爱相。偈曰。外众车恶口。杂喜园庄严。释曰。城外四面最胜可爱处。有四种园。是诸天所游戏处一众车园。二恶口园。三相杂园。四欢喜园。此园于外庄严大城。偈曰。中二十由旬。四善地四方。释曰。众车等园四方各有别处名善地。中间相去二十由旬。是诸天最胜希有游戏处。如互相妒生可爱想。余园所不及。大城外边。偈曰。东北波利园。西南善法堂。释曰。天中有树。名波利阇多。是三十三天欲尘游戏最胜处。树径五由旬。高百由旬。枝叶至杪四边各出五十由旬。周围覆三百由旬。住此树华开敷时。香顺风薰满百由旬。香逆风薰满五十由旬。若顺风薰。此乃可然。说逆风薰云何可信。有余师说。不过树界故。故说此言。何以故。无香得逆风薰故。有余师说。此一树花香威德有如此事。谓天上调和香风所遮隔。此香犹相续不断。余香若为风所吹。则渐歇薄乃至都尽。是故余香去不得远。相形比胜余树。故说此言。花香相续。为依止自四大能薰余处。为但薰风不出余处。此中无定。诸师许有二种。若尔云何。世尊说此偈

  花香非能逆风薰　　根实诸香亦皆尔
  善人戒香逆风薰　　正行芳流遍国界

依人中香气。故说此偈。何以故。此香是世间共知。无如此能。弥嬉沙塞部说。此香顺风薰百由旬。逆风薰五十由旬。有诸天集会堂名善法。对大城西南角。诸天于中坐。论量世间应作不应作事。四大天王及三十三天。安立器世其相如此。偈曰。从此上宫殿。天住。释曰。三十三天上各有宫殿。所余诸天依其中住。何者所余。谓夜摩兜率多化乐他化自在梵众等。如前所说。合有十六处。如此若略说。合二十二部诸天所。此等皆有别器世界。偈曰。六受欲。释曰。于二十二中有六欲界天。能受用尘欲非余。谓四大王天。乃至他化自在天。此六天。偈曰。身交抱捉手。笑相视为淫。释曰。依地住相应故。皆二身交为淫。谓四大王天及三十三天。与人道不异。是诸天由风出故心热即息。以无不净故。夜摩天以相抱为淫。心热即息。兜率陀天以捉手为淫化乐天以共笑为淫。他化自在天以相视为淫。一切欲天同以二身交为淫。后相抱等四。从譬时量得名。分别世经说如此。向上诸天。如欲尘次第转胜妙。欲乐亦尔。向上转重。于男天膝上及女天膝上。若有童男童女天生。此童男童女即是二天之子。初生身量云何。偈曰。譬五年乃至。譬十年初生。生中。释曰。次第于六欲天处。第一天新生天子。如人中五岁童子。乃至第六天新生天子。如人中十岁童子。此新生天子速得身量圆满成就。偈曰。皆具根。有衣色界尔。释曰。色界诸天具足身量。衣裳被服自然着体。以惭羞重故。一切天同中国语。说婆罗门言。于欲界中此义应知。偈曰。于欲生有三。欲界天及人。释曰。云何三有诸众生。自然至得欲尘。于自然得欲尘中。作增上自在。如诸人及诸余天。诸余天者。谓前四部天。有诸众生化作欲尘。于化作尘中作增上自在。谓化乐天。有诸众生他化作欲尘。于他化作欲尘中作增上自在。谓他化自在天。此生由能受用。如自然生尘故。由能受用如意自所化作尘故。由能受用如他化作尘故。约此欲尘故。欲界生有三。于色界中。偈曰。乐生亦有三。于三定九地。释曰。于三定中有九地。是名三种乐生。何以故。是诸天由离生乐。由定生乐。由离喜生乐。长时安乐住。无苦长时乐故。故名乐生。于初定中间生无喜乐故。是乐生应思。是诸天二十二处。如前所说。从下向上相去几许。是一切处不可皆以由旬数量其远近虽然。偈曰。如此至彼量。向上例皆尔。释曰。从剡浮洲等向上处。从此处向剡浮洲等。如相去量。从此处向上相去量亦尔。如第四层。四大天王所住处四万由旬。从此如向剡浮洲相去量。从此向三十三天亦尔。从三十三天向剡浮洲相去量。从此向夜摩天亦尔。从夜摩天向剡浮洲相去量。从此向兜率多天亦尔。如此一切广例皆尔。乃至从善见向剡浮洲相去量。从此向阿迦尼师吒亦尔。从阿迦尼师吒向上无复余处。由此义故。此处胜于余处无处胜于此处。故名阿迦尼师吒。有余师说。此处名阿伽尼师吒。色聚集住名阿伽。此处究竟名尼师吒。复有余师说。此处名阿迦尼师吒。谓所行究竟。生下处众生。为得往上地见上地宫殿不。偈曰。下天无能升。离通慧依他。释曰。三十三天或由通慧得往。夜摩天或由依他故得往。谓有通慧人所引接。或由上天所引接。所余诸天亦尔。若诸天生在上地来下界。下地得见上天。若往上地则无所见。以非其境界故。如不能觉上地触。于见色亦尔。是故彼不由自身来。虽然由作下地化身故来下地故。下地随意得见。上地随意得见下地。余部说如此

阿毗达磨俱舍释论卷第八阿毗达磨俱舍释论卷第九

        婆薮盘豆造

        陈天竺三藏真谛译

    中分别世间品之四

复次夜摩等天宫其量云何。上四天如须弥娄山量。余部说如此。复有余师说。向上倍倍广。复有余师说。初定地量。同一四洲世界。第二定地量。同小千世界。第三定地量。同二千世界。第四定地量。同三千世界。复有余师说。初定等三地量同一千等世界。第四定无复量。复次何义名小千世界二千世界三千世界。偈曰。四洲及月日。须弥娄欲界。梵处各一千。名小千世界。释曰。一千剡浮洲。乃至一千北鸠娄。一千月日。一千须弥娄山。一千四大王天。乃至一千他化自在天。一千梵处。说此名小千世界。偈曰。千倍此小千。名二千中世界。释曰。更千倍小千世界。名二千中世界。偈曰。千倍三大千。释曰。更千倍二千中世界。名三千大千世界。如此一切。偈曰。共同一坏成。释曰。如此等世界同有小大三灾。此大千世界同坏同成。此义后当广说。如器世界量不同。于中住众生身量亦有差别。不有。此中偈曰。剡浮洲人量。四肘三肘半。释曰。剡浮洲人从多身长三肘半。或有人长四肘。偈曰。后后倍倍增。东西北洲人。释曰。东毗提诃人身长八肘。西瞿陀尼人身长十六肘。北鸠娄人身长三十二肘。若天云何。偈曰。身量四分增。乃至俱舍半欲界。释曰。四大王天身长一俱卢舍四分之一。三十三天身长四分之二。夜摩天身长四分之三。兜帅多天身长四分。化乐天身长五分。他化自在天身长一俱卢舍半。偈曰色界。初半由旬次第。释曰。色界诸天于初处梵众天身长半由旬。从此次第。偈曰。半半增释曰。于三处半半增。梵先行天身长一由旬。大梵天身长一由旬半。少光天身长二由旬。偈曰。向上从少光。上身倍倍增。唯除无云三由旬。释曰。无量光天身长四由旬。遍光天身长八由旬。如此倍增由旬。乃至遍净天身长六十四由旬。无云天倍增减三由旬。身长一百二十五由旬。从此后福生等天更倍增。乃至阿迦尼师吒天身长十六千由旬。身量向后有如此差别。寿量亦有差别不有。偈曰。北鸠娄千年。于二离半半。释曰。北鸠娄人定寿千年。于西东二洲寿量半半减。西瞿陀尼寿五百年。东毗提诃寿二百五十年。偈曰。此不定。释曰。于剡浮洲寿量不定。有时极多有时极少。多少云何。偈曰。最后十岁。释曰。此寿渐减。最后唯有十岁。偈曰。初叵量。释曰。劫初生众生。寿命不可量。由千等数不能计量故。说人寿已。今当说天寿。若先安立日夜。方得计诸天寿。天日。夜云何偈曰。人中五十年。彼天一。日夜。欲下天。释曰。人中五十年。于欲界最下天。谓四大王天。是一日一夜。偈曰。以此彼寿五百年。释曰。以此三十日夜立为一月。以十二月立为一年。以此五百年为彼天寿量。偈曰。向上后倍增。释曰。上地诸天倍增为日夜。以此日夜计彼寿量。彼寿云何。人中一百年。是三十三天一日一夜。以此日夜一千年。为彼天寿量。应知夜摩天等次第如此。人中二百四百八百十六百。为彼一日一夜。以此日夜二千四千八千十六千。天年次第为上天寿量。从由乾陀罗。向上无日月诸天云何安立日夜。用明光事。云何得成。由花开花合。谓俱牟头花。波头摩花等。诸鸟有鸣不鸣。睡有来去。以此等事判日夜。用光明事者。身自然光不须外光。说欲天寿量已。偈曰。色界无日月。由劫判彼寿。劫数如身量。释曰。于色界中若有诸天。身量半由旬。寿量则半劫。若身量一由旬。寿量则一劫。如此彼身随由旬数。彼寿量劫数皆随身量。乃至阿迦尼师吒天。以十六千大劫为寿量。偈曰。无色二十千。劫后二二增。释曰。于空无边入。寿量二十千。劫识无边入。更增二十千劫。无所有入。更增二十千劫。有顶更增二十千劫。此寿量二十四十六十八十千劫。此中应知。云何为劫。为是别劫。为是坏劫。为是成劫。为是大劫。偈曰。从少光大劫。从此下半劫。释曰。从少光梵处。应知寿量约大劫。从此下半大劫说名劫。以分别大梵等寿量。云何如此。是时世间二十别劫成。二十别劫成已住。二十别劫散集。是六十别劫。于大梵处说名一劫半。分别如此。已是半劫。谓四十别劫。立为一劫。说彼寿量。说善道寿量已。恶道寿量今当说。偈曰。与欲界天寿。日夜次第等。于更活等六。寿量如欲天。释曰。如所说六欲天寿量。于六地狱日夜。应知次第皆等。六者谓更活黑绳聚磕叫唤大叫唤烧然。于彼由旬日夜等。六欲天寿量。应知于彼寿量。亦等六天寿量。云何如此所说。四天王寿量。于更活地狱是一日一夜。以此日夜立月立年。以此五百年为其寿量。三十三天寿量。于黑绳地狱是一日一夜。以此日夜于中寿量足一千年。如此于余处次第应知。乃至他化自在天寿量。于烧然地狱是一日一夜。以此日夜于中寿量足十六千年。偈曰。于大烧半劫。阿毗指别劫。释曰。于大烧燃地狱。寿量半别劫。于无间地狱。寿量足一别劫。于畜生寿量无定。偈曰。畜生极别劫。释曰。若畜生中最极长寿。但一别劫。谓诸龙难陀优波难陀阿输多利等。何以故。佛世尊说。比丘有八部龙名大龙。皆一劫住持于地轮。广说如经。偈曰。鬼日月五百。释曰。人中一月。于鬼神是一日夜。以此日夜寿量五百年。于寒地狱寿量云何。偈曰。从婆诃百年。除麻尽为寿。頞浮陀二十。倍倍后余寿。释曰。约譬喻佛世尊说。寒地狱寿量如经言。比丘。譬如此中二十佉梨。是摩伽陀量一。婆诃麻遍满高出从。此有人一。百年度除一粒麻。比丘。如此二十佉梨。一婆诃麻。由此方便。我说速得减尽。我未说于頞浮陀生众生寿量得尽。比丘。如頞浮陀寿量。更二十倍为尼剌浮陀寿量。乃至比丘。二十倍波头摩寿量。为分陀利柯寿量。如此等寿量。为有未具足于中间死不。一切处有。偈曰。除鸠娄中夭。释曰。于北鸠娄洲。一切人寿量皆定必具寿量尽方得舍命。于余处寿命不定。若约别人。于中间多不得死。谓住兜帅多天。一生补处菩萨。最后生菩萨。佛所记。佛所使。信行法行。菩萨母。转轮王母。正怀胎。如此等由由旬量说。处所及身量已由年量。说寿命量已。此二齐量未说。如此一切用名分别。此名穷量。亦应显说。为说此三。是故初立方便。偈曰。邻虚字刹那。色名时最极。释曰。若分分析色极于邻虚。故邻虚是色极量。时量亦尔。极于刹那。名量亦尔。极于轻字如伊短音。复次刹那者何量。若因缘已具足。随时法得一生。是时名刹那。复次是法若行度一邻虚。是时名刹那。复次若有强力丈夫一弹指顷。经六十五刹那。阿毗达磨师说如此。于此中偈曰。七邻虚阿羺尘铁尘水兔羊。牛隙尘虮虱。麦指节应知。后后七倍增。释曰。以邻虚为初。应知后后皆七倍增。七邻虚为一阿羺。七阿羺为一铁尘。七铁尘为一水尘。七水尘为一兔尘。七兔尘为一羊尘。七羊尘为一牛尘。七牛尘为一隙光中尘。七隙光中尘为一虮。七虮为一虱。七虱为一麦。七麦为指一节。三节为一指。是世间所解故。偈中不说。若横并指。偈曰。二十四指量一肘。四肘一弓。五百弓俱卢舍。此名阿练若。释曰。十二指为一[月*桀]手。二十四指为一肘。四肘名一寻。亦名一弓。五百弓为一俱卢舍。亦名村亦名阿练若。偈曰。此八一由旬。释曰。此八俱卢舍为一由旬。说由旬量已。年量今当说。偈曰。百二十刹那。怛刹那。释曰。一百二十刹那。为一怛刹那。偈曰。六十说名一罗婆。释曰。六十怛刹那。说名一罗婆。偈曰。后三三十增。是一牟休多。及一日夜月。释曰。三十罗婆。为一牟休多。三十牟休多。为一日夜夜。有时长有时短有时等。三十日夜为一月。偈曰。十二月一年。一年共减夜。释曰。寒际有四月。热际有四月。雨际有四月。如此十二月。立为一年共减夜。何以故。有六减夜入一年中。云何如此

  寒热雨三际　　中月半已度
  于余半月中　　智人知减夜

说年量已。劫量今当说。偈曰。说劫有多种。释曰。别劫坏劫成劫大劫。此中偈曰。坏劫地狱尽。乃至器世灭。释曰。于诸地狱中。从无复众生。乃至器世界灭。是名坏劫。何以故。坏有二种。一道坏。二界坏。复有二种坏。一众生坏。二器世界坏。有如此时。于此时中地狱众生。但死无复受生。此时是坏劫之初。是时世间二十别劫。成已住。此住劫应知已度。更二十别劫。世间应坏。是坏此时应知次第复至。若是时于地狱中无一众生为余。由此时量世间已坏。由地狱坏故。于此时中。若众生有定业。必应于地狱受报。未尽业引此众生。于余世界地狱受报。畜生坏劫。鬼神坏劫。亦应作如此说。住大海畜生先坏。共人行畜生后坏。复有如此时。于人道中随有一人。自然无师法尔。所得修入初定。此人从初定出。说如此言。善人从离生喜乐最美妙。善友从离生喜乐微细寂静。余人闻此言。复各修学此定。如此等人舍命后皆生梵处。若是时于剡浮洲。无一众生为余。由此时量世间已坏。由剡浮洲坏败。如此东毗提诃。西瞿陀尼。北鸠娄坏。亦应作如此说。若是时于人道。无一人为余。由此时量。世间已坏。由人道坏故。北鸠娄人舍命生欲界天。于自地中无离欲故。如此于四大王天。修习初定已生于梵处。若是时于四大王天。无一天为余。由此时量。世间已坏。由四大王天坏故。如此乃至他化自在天坏。亦应作如此说。若是时于欲界天。无一天为余。由此时量世间已坏。由欲界坏故。于梵处随一众生法尔所得修入第二定。从此定出说如此言。此乐最美妙。谓定生喜乐。此乐最寂静。谓定生喜乐。余人闻此言。复各修学此定。如此等天。舍命后皆生遍光天处。若是时于梵处无一众生为余。由此时量世。间已坏由众生坏故是时器世界皆空。从此时初定道所起。能感器世界业。悉已谢灭。七日次第出。乃至烧大地及诸须弥娄山无复余。从此猛火风吹光焰上烧梵处。如此光焰。应知是初定地同类。何以故。若灾非同类则不能坏。由相应发故。故说此火能烧。何以故。是欲界火能接色界火故。此义于余灾。如理应知亦尔。从地狱中。由众生死不更生。乃至器世界尽。经如此时说名坏劫。偈曰。成劫先于风。乃至地狱有。释曰。从初风起。乃至于地狱有众生。是名成劫。何以故。世间如此已坏。唯空为余。于长时住。乃至后众生业增上故诸世界器先相初起。谓于空中有微细风。渐渐而动。是时世间二十别劫坏已住。此坏劫应知已度。更二十别劫。世间应成。此成是时应知。次第复至。从是时诸风渐渐增大。乃至成就如前所说风轮。如前所说次第事。一切皆成。谓水轮及大地金轮地轮。乃至诸洲。须弥娄山等。初成大梵天宫殿。次第乃至成夜摩天宫殿。从此后风轮起。由此时量应知世间已成。由器世界成故。是时随有众生。应作大梵王。从遍光天堕于大梵宫殿受生。余诸众生从彼次第堕。有生梵先行处。有生梵众处。有生他化自在处。如此次第。乃至于北鸠娄。西瞿陀尼。东毗提诃。剡浮洲。鬼神道。畜生道。地狱道处受生。此是法尔。谓后世间坏。先世间成。是时若一众生。于地狱处受生。由此时量。世间二十别劫已成。此成劫应知已度。更二十别劫。世间应住。此住是时应知次第复至。偈曰。别劫从无量。乃至成十岁。释曰。从世间初成。十九别劫。于无量寿时中已度。此无量寿众生。寿命渐减乃至十岁。世间已成及住。是住初别劫。偈曰。初下一别劫。次上下十八。释曰。从此初住。后有十八上十八下。为十八别劫。云何如此。从此十岁众生寿命。若转增上乃至八万岁。复转减下乃至十岁。是第二别劫。如此乃至十八。偈曰。后上一别劫。释曰。最后一上别劫。即住劫第二十别劫。如此若下从八万乃至十岁。若尔增上至几量为究竟。偈曰。乃至寿八万。释曰。过此无复上。于十八劫中。如一上一下时量。初住下劫时量亦尔。最后上劫时量亦尔。是故一切时量平等。偈曰。世间如此成。住经二十劫。释曰。由此别劫道理。世间二十别劫成已住。如成住时量。于如此等时。偈曰。劫成及破坏。坏住皆平等。释曰。二十别劫世间成。二十别劫世间坏。二十别劫坏已空住。虽于此三时无上下量劫。然此劫量皆平等。若算数平等故。此中由一别劫。器世界成。由十九别劫。此处成所住。由一别劫。器世界被离。由十九别劫。器世界空无众生。如此别劫。有四种二十合成八十。偈曰。八十名大劫。释曰。若大劫其量如此。此劫以何法为自性。五阴为自性。于经中说。由劫三阿僧祇。诸佛得无上菩提果。此三阿僧祇。于四劫中为是何劫。此中所说是大劫。以此偈曰。大劫三僧祇。释曰。由三劫阿僧祇。所求佛果方成。阿僧祇既无数边。三数云何成。不应如此知。若尔云何。虽然有六十数处名一阿僧祇。于余经中说如此。何者为六十。有第一数无第二数。是处名第一。十此第一。名第二处。十第二处名百。十百名千。十千名万。十万名洛沙。十洛沙名阿底洛沙。十阿底洛沙名俱胝。十俱胝名末持诃。十末持诃名阿由多。十阿由多名摩诃由多。十摩诃由多名那由多。十那由多名摩诃那由多。十摩诃那由多名波由多。十波由多名摩诃波由多。十摩诃波由多名郁僧伽。十郁僧伽名摩剡僧伽。十摩剡僧伽名婆诃那。十婆诃那名摩诃婆诃那。十摩诃婆诃那名知知婆。十知知婆名摩诃知知婆。十摩诃知知婆名醯兜。十醯兜名摩诃醯兜。十摩诃醯兜名柯罗婆。十柯罗婆名摩诃柯罗婆。十摩诃柯罗婆名因陀。十因陀名摩头陀。十摩头陀名婆末多。十婆末多名摩诃婆末多。十摩诃婆末多名伽知。十伽知名摩诃伽知。十摩诃伽知名纴婆。十纴婆名摩诃纴婆。十摩诃纴婆名物陀。十物陀名摩诃物陀。十摩诃物陀名婆罗。十婆罗名摩诃婆罗。十摩诃婆罗名社那。十社那名摩诃社那。十摩诃社那名毗休多。十毗休多名摩诃毗休多。十摩诃毗休多名婆洛沙。十婆洛沙名摩诃婆洛沙。十摩诃婆洛沙名阿僧祇。间中有八处忘失

如此大劫。次第数至第六十处。说名一阿僧祇。度一更如此数名第二。第三亦尔。故说三阿僧祇。非一切方便所不能数。故名阿僧祇。众生先已发愿云何复须此最长时修行。方得无上菩提。如此事云何不应有。何以故。由大福德智慧资粮行。由六波罗蜜百万难行道。于大劫三阿僧祇中。无上正觉果诸菩萨方得。若由别方便。有解脱理何用久修此大难行道。为他故须如此大功用。云何我等从大苦流。有能为拔济他。由此意故久劫修行。由他利益。于己有何自利。是己自利。谓他利益。是己所乐故。君此事今何人能信。此事实难可信。若人荷负自身为重。于他无慈悲。若具智慧慈悲人。此事易信。譬如于世间有诸余人。恒习恶过失。于中虽无自利益。欣乐他损恼事。众所共见。如此复有余人。恒习大悲。于中无自利益。欣乐行利益他事。是故此事可比。复次譬如世间凡夫。由长时数习故。于诸行法实非自我。不能了别诸行体相。于诸行中生起我爱。因此我爱恒荷负众苦如此。复有余人。于长时由数习智慧。于自相续弃舍自爱。于他增长自爱。因此爱故。为他荷负众苦。是故应知。此义不异。复次有别性。如此种类起。由他苦故苦。由他乐故乐。不由自身故。彼不见他利益事异自利益。此中说偈

  下人求自乐　　作种种方便
  中人求灭苦　　非乐苦依故
  上人由自苦　　乐他得安乐
  及他苦永灭　　他苦自苦故

为于劫上时诸佛出世。为于劫下时诸佛出世。偈曰。成佛于劫下。减八万至百。释曰。世间人寿八万岁时。寿减正发。乃至人寿百岁。于此中间诸佛世尊出现于世。云何不于劫上时出。于此时中众生难教厌离故。云何不于百下时出。于此时中五浊炽盛。何者为五浊。一命浊。二劫浊。三惑浊。四见浊。五众生浊。下劫将末命等五最粗最下。已成滓故。说名为浊。由前二浊。次第损减寿命。及损减乐具。复由二浊损减助善。何以故。因此二浊。有诸众生。多修习欲尘乐行及自苦行。能损在家出家助善。由后一浊损减自身身量。色无病力智念正勤不动。此德坏故。独觉于何时出世。偈曰。上下时独觉。释曰。独觉于上劫及下劫时。皆得出世。何以故。独觉有二种。一部行二犀角喻此中部行者。先是声闻或名独胜。有余师说。有先是凡夫后成部行独觉。若此人于前世。已修决择分能善根。今生自然觉悟圣道。云何得知。于本行经中说。有一山处。有五百外仙。修难行苦行。乃至有一猕猴。与独觉共住。后至外仙所。现独觉威仪庄饰。五百外仙皆成独觉。若先是圣人。不得修难行苦行。犀角喻者。谓独自住。二种独觉中。偈曰。犀角喻百劫。释曰。足一百大劫。修行菩提资粮。方成犀角喻独觉。云何名独觉。离师正教。于一自身如理觉悟。故名独觉。何以故。诸独觉但调伏一身。不调伏他故。云何名犀角喻。于人天道最胜品中。贞实无等故。何因不觉悟他。诸独觉非无能为他说法。具得四无碍解故。彼亦有能。能忆持往昔诸佛所说正教。及为他说故。彼亦非无慈悲为利益他。恒现通慧故。不由众生不感圣果故不为说。何以故。是时亦有修世道离欲诸仙。虽然亦由宿世修习故。由喜乐少求故。是故不能说正教令他受甚深法。何以故。随爱流行世间。难可引济令其逆流故。为离杂行摄部众故。怖畏散乱杂谈说故

复次转轮王于二时中何时出世。偈曰。减八万岁时。无转轮王生。释曰。人寿无量时。乃至寿八万岁。转轮王生于世间。不减八万时。何以故。若人寿减八万。是人非此吉祥富乐器故。由轮成王位为法故。名转轮王。此王有四种。偈曰。金银铜铁轮。释曰。若人以金为轮。此人是上上品。以银为轮是上品。以铜为轮是中品。以铁为轮是下品。偈曰。四随下次第。一二三四洲。释曰。若人以铁为轮。此人为一洲王。以铜为轮为二洲王。以银为轮为三洲王。以金为轮为四洲王。分别世中说如此。于经中由偏显胜故。但说金轮。经言。若王生刹帝利种。已受灌顶位。于布萨时。白半十五日。王从头次第洗竟持八戒。布萨升上高楼。大臣等集皆悉围绕。于东方有轮宝出现。千辐具足有毂有辋。一切庄严无不圆备。如善巧工匠所作。一切皆金。来至王所。应知此王必是转轮王。若余转轮王生亦尔。偈曰。非二俱如佛。释曰。于经中说。无处无位。谓无前无后二如来阿罗呵三若三佛陀出现世间。有处有位。若一如来二如来。二转轮王亦尔。此中是义应思。是所许处。为约大三千世界。为约一切世界。余部说。诸佛世尊但一处出余处则无。何以故。勿许诸佛世尊功能有阙是一世尊。于一切处具有能故。若于一处一佛。不能荷负一切受化弟子。余佛于中亦无有能。于经中说云。舍利弗。若有一人。来至汝所问汝言。大德于今时为有沙门婆罗门与瞿昙沙门平等平等于无上菩提不。汝若被问。当云何答。世尊。若有一人来至我所。作如此问。我若被问。应如此答。于今时无有沙门婆罗门与我世尊平等平等于无上菩提。何以故。世尊。我从世尊吉祥口证闻此言。证持此言。无处无位。谓无前无后。二如来阿罗诃三若三佛陀出现世间。有处有位。若一若尔佛世尊。于梵王经说。此义云何。经言。梵王于三千大千世界中。我自在成此言。是不了说义。说何义不了。若如来约自性心。不作别故意。正说利益他等。于此境界皆自然成。若如来作别故意境界则随意无边。有别部说。于余世界各有诸佛如来。何以故。见多人共俱修菩提资粮。有多佛世尊。于一处一时出现无如此理。若出现余处则无有碍。是故必于余世界等成正觉。若尔此义中前所引经云。无处无时。谓无前无后。二如来出现于世。此义今云何。将此义今应思量。此经为约一世界说。为约一切世界说。若约一切世界说。转轮王不应出余世界。由遮俱生故。譬如如来。若汝忍如此。此义云何不忍。诸佛出现世。是大吉祥福。若多佛出多世界。无有过失。于世间无量众生。得与大福德己利相应。若尔于一佛田。云何二如来不俱出世。无用故。随本愿故。故诸菩萨发如此愿。于盲世间无将导无救无依。愿我于中成佛。为眼及依。为令敬恭及疾行故。何以故。若一佛则生他极重恭敬。又令他思惟如此。余佛最难可得。是故如所立教速疾修行。勿大师去已及般涅槃。我等无依止。复次是四种转轮王。由金轮等制伏天下。云何能制伏次第。偈曰。他迎自往彼。争伏胜。释曰。若王得金轮为具。剡浮洲诸国王。各自来迎候。各云我等国土。富乐平安丰壤。遍多人众。皆属天尊。愿天尊教敕。我等皆是天尊翼从。若王得银轮为具。王自往彼土。诸王皆下心归伏。若王得铜轮为具。王往近彼土。遣使去还与共讨争。然后诸王方下心归伏。若王得铁轮为具。王自往彼土。擐甲捉仗示攻伐相。然后诸王方下心归伏。一切转轮王。偈曰。无害。释曰。若捉仗制伏他土尚无杀害。何况余王。伏天下已。一切众生住王国土。王悉教令受持十善法。是故诸王死定生天。经中说。由转轮圣王出现于世。世间则有七宝现生。何者为七。一轮宝。二象宝。三马宝。四摩尼宝。五女宝。六长者宝。七大臣宝。象等诸宝。是众生类。云何由他业生。若无一众生由他业生。此人先共造诸业。能感互相应报。此人若受生。余众生由自宿业生。与此人相应。此转轮王与余王。为唯七宝有差别。为更有余差别。有余差别。谓此四转轮王有三十二大人相。余王则无。譬如诸佛。若尔王与佛何异。于中偈曰。处正明了圆。佛相余无等。释曰。佛三十二相有三德。与王相不同。三德者。一处极正不偏。二极明了不隐昧。三极圆满无减缺。劫初诸人。为有王。为无王。无王虽然偈曰。初生如色界。释曰。劫初生人。如色界众生。各自在住。经中说。劫初生人。有色意生。具身身分。具根无减。色形可爱。自然光明。能飞行空中。喜乐为食。依喜乐于久长时住。偈曰。众生渐贪味。为懒惰储畜。由财雇守田。释曰。众生已如此成。地味渐出。其味甘美胜细蜂蜜。于中有一人贪爱为性。闻地味香试取尝之。遂便啖食。余人次第随学此事。初发段食在于此时。是时诸人由数习此食。于身生坚重二触。失先光明。从此有黑暗起。是时日月出现。由贪味故。是彼地味次第灭尽地皮干起。以此为食。于中起贪又失此食。次生林虅以此为食。于中起贪又失此食。次生舍利。不由耕种自然而有。以此为食。此食最粗变异有残。为除此残生大小便道。此道与男女根俱生。相貌亦异。是时彼人互相瞻视。由随先惑习气起邪思惟。由邪思惟罗刹所吞。淫欲变异于心猛盛。即便犯罪。是淫欲鬼。初发入心在于此时。是时彼人晚时为瞑食。晓时为昼食。相要共取舍利。于中有一人懒惰为性。长取舍利储宿为食。余人学之亦各储宿。是时于中即生我所。因此我所后取舍利。将已即尽不复更生。是时彼人即共分田。于自分田生重贪惜。于他所得作侵损事。初发偷盗在于此时。为遣此失皆共集聚。其中有一胜人。诸人各以所得六分之一。共雇此人为守田主。彼说此人为差(厕知反)多罗莎未(亡履反)差多罗莎未故。得刹帝利名。大人众所许。能染世间心。是故初生名摩诃先摩多王。一切王相传。此王为初。于中若有人心出家外。是人得名婆罗门。后时有一王。由贪惜财物。于民不行分施恩事。诸人由贫乏故。多行盗事。王于此罪人好行刀杖。治罚事初发。杀害在于此时。是时罪人覆藏说言。我不作此事。初发妄语在于此时。偈曰。次由十恶增。寿减至十岁。释曰。次第由此方便业道增长。故寿命渐减。于最后时。一切人皆寿十岁。是故一切灾横。二法为根本。谓贪味及懒惰。是时人寿十岁。是别劫出尽。云何出尽。偈曰。是劫由杖疾。及饿灾故出。释曰。别劫有三因缘故出尽。一刀杖。二疾疫。三饥饿。别劫出尽时。是十岁人非法欲所染。不平等贪所逼。邪法所遍。是人嗔毒转增上。若互相见即起极重嗔杀心。譬如今时猎鹿人见野鹿。是时诸人随有所捉或木或草。于彼人悉成极利刀仗。彼人作是思惟。我今必应在前。是故更互相杀。由此皆死。复有别劫出尽时。是十岁人由罪过多故。鬼神起憎恶心。于彼作诸灾横。是故处处遭阿萨阇病。由此皆死。复有别劫出尽时。是十岁人由罪过多故。天神龙起憎恶心。不复降雨。是故处处饥饿穷困。由此皆死。是时有三粮。一栴遮粮。二白骨粮。三筹粮。名旃遮粮者。此有二因。今时聚集彼时名旃遮。又奁子名旃遮。是时诸人饥羸所逼。聚集聚集。皆饥饿死。又为护惜来岁粮。及怜愍眷属。于将来时藏举少粮及种子。置奁子中。故名旃遮粮。白骨粮者。亦有二因。是人身燥涩既久。死后少时骨即白色。又无食饥饿。取此白骨煮汁饮之。筹粮者。亦有二因。是时诸人由次第传筹。家家分张粮食。今日家主食。明日妇食。如此次第。复次昔时曾有谷处。开圻以筹挑取。随得谷粒。以多水煮之饮以为粮。于经中传说如此。若人能于一日护离杀生。或能施一诃梨勒。或于大众起恭敬心能施一食。是人于刀杖疾疫饥饿劫时。不于中生。刀杖疾疫饥饿三灾起各几时。偈曰。七日及七月。七年次第尽。释曰。由杖杀害众生灾。于七日内起。疾疫灾于七月七日内起。饥饿灾于七年七月七日内起。是时于二洲人。亦有似三灾事起。嗔恚于彼增长。至重黑瘦恶色。及身羸弱于彼亦起。饥渴亦起。是各各所说三灾。于诸灾中应知。次第皆有。偈曰。散集劫有三。由火水风起。释曰。于一一定处。众生下散上集。故名散集劫。由七日出故有火灾。由大雨水故有水灾。由大风相违故有风灾。由此三灾。器世界极细分皆尽无余。此中有余外道师执说。如此邻虚常住。于此时中以此为余。云何彼乐执此义。诸余大物。后更生时。勿彼生无种子。为不如此耶。是众生业势力所生风。由功能胜说为种子。复次灾头风。亦为种子因。弥嬉沙塞部经中说。风从余现成世界。引载彼种子来。虽然诸外道师。不许芽等从种子生。若尔彼执云何。从自分生。乃至自分从自邻虚生。若尔种子等。于芽等中有何功能。离安立邻虚无别功能。由芽邻虚从种子出故。何因彼许如此。从非同类因果生。此不应理。云何不应理。若尔一切物生则应不定。是义不然。由功能定故。无不定义。譬如谷熟等。若是义不然。何以故。求那法种种不同。踏腊脾(蔽也反)法不尔。若物欲生必从同类物生。譬如从竹笪生从缕衣生。今不相应义起。此中何义不相应。引不成就义证不成就义。此中何义不成就。笪异竹衣异缕。此义不成就。何以故。是竹是缕。如此聚集故得别名。譬如蚁行。云何得知。于一缕和合中不见衣故。何以故。于中若衣实有。何法能障令不显现。若不具有。但有衣分。此则非衣。何以故。唯聚集为衣故。复有何一分衣异于此缕。若由观多依和合故衣成。唯缕和合中已应见衣。时无见有此衣。初中后不对根故。故知离缕无有别衣。若衣分分次第对根。不应说由眼由身证得为有分。由次第决证有分故。是故衣智但缘分起。譬如火轮。若缕有别色类事。衣无色等故。则衣不可得。若衣有种种色等别类。不生别类。此义不成。于无种种色等别边。不应见衣。或应即于此边见种种色。衣缕有种种事。衣应无种种异。是故知衣无有别物。复次火光烧照等有差别。此光于初中后。不应有色触及事等邻虚。虽过根若聚集则可证。如彼能作事。眼等诸根若生肤曀等。则不见散发等。但见聚发等。何以故。一发等于彼过根故。譬如邻虚。是故知。汝但于色等假立邻虚名。由此义故。色等灭时邻虚即同灭。若邻虚是物实异色等。不应与色同灭。若同灭异义则不成。随愚智类不可分别。此物是地水火风。此物中色声香味触。是德汝执言。诸物是眼耳所证。毛古贝红花郁金。若被烧彼智即无故。知彼智但缘色等起。熟所生德起时。由形貌相似故。瓶智更生。譬如色行。何以知然。若人不见形貌。不能知故。于婴儿言何足可重。今且止破彼执。复次于三灾中。何灾何为头。偈曰。三定二定等。次第三灾头。释曰。诸灾有三。火灾以第二定为头。下地烧然。水灾以第三定为头。下地烂坏。风灾以第四定为头。下地散灭。随诸灾上地说名灾头。何因三定地。由火水风破坏。偈曰。由等彼内灾。释曰。于初定地觉观为内灾。此觉观能起心燋热。与外火同。于第二定喜为内灾。此喜与轻安触相应。能令依止软滑。与外水同。于此定中一切身强违触灭故。说是苦根灭处。于第三定出入二息为。内灾此即。是风于定于三摩跋提。若如实有此内灾。于此定等必有如此外灾。云何无地灾。地名器世。此地与火水风相违。不与地相违。若尔于第四定有何灾。偈曰。四无不动故。释曰。于第四定离内灾故。佛世尊说。彼名不动。是故于中诸灾不起。故彼无灾余部说。由净居天威力故无灾。何以故。彼无复能得入无色界及住余处受生。定于彼般涅槃故。于彼无灾。若尔第四定器。应是常住。偈曰。无常众生共。宫殿生灭故。释曰。第四定不共一地相应。云何各各地住。与他不共。譬如众星。于中若有众生。生及死堕。宫殿与彼俱生俱灭故。此地非常住。此三灾起次第云何。若无间。偈曰。七火一水灾。释曰。先七灾由火起。后一灾方由水起。如此次第。更七灾由火起。随七火灾后各一水灾起。偈曰。七水灾已度。后复七火灾。释曰。由此次第七水灾已度。后复七火灾更次第起。偈曰。然后风灾起。释曰。从此后一风灾起。何因如此。于彼众生由定胜德。如自身住差别。所居处亦尔。此住几时经五十六火灾一风灾。若作如此义。分别立世论。则被随顺。彼论云。六十四劫是遍净天寿量

阿毗达磨俱舍释论卷第九阿毗达磨俱舍释论卷第十

        婆薮盘豆造

        陈天竺三藏真谛译

    中分别业品第四

前已说众生世及器世。差别有多种不同。如此不同何因所作。非随一作者。以知为先所造。若尔云何诸众生。偈曰。业生世多异。释曰。若世间多种差别皆从业生。云何因众生业。郁金旃檀等生极胜可爱。而彼身不尔。是彼业种类。如此作杂业众生。彼身有九疮门。甚可厌恶。外具生极可爱。以对治此身。诸天等不造杂业。此二悉可爱。若尔此业是何法。偈曰。故意及所作。释曰。经中说。业有二种。一故意业。二故意所造业。此所造但故意所作。非身口所作。此二业或成三业。谓身口意。云何安立此三。为由依止。为由自性。为由缘起。若由依止但一身业。一切依止身故。若由自性但一口业。于一切中但口是业故。若由缘起但一意业。一切皆故意所起故。次第由此三因安立三业。毗婆沙师说如此。此中偈曰。故意即心业。释曰。心业者但故意故。意何相。谓心思已决。偈曰。故意生身口。释曰。如此故意依身口门起。即以身口还显故意。应知此名身口二业。偈曰。二有教无教。释曰。是身口业。应知一一各有二类。谓有教无教为性。此中偈曰。说身有教相。释曰。由随故意。是身如此如此相貌。说名有教。有余师说。行动名有教。若身行动。必由业行动故。行动是身业。对向彼说。偈曰。非动刹那故。释曰。一切有为法。与刹那相应。何法名刹那。得体无间灭。是名刹那。随法有如此名刹尼柯。譬如有杖人。何以故。一切有为法。从得体后即不有。是时生是时即坏故。执此法得度余处。则非道理。是故身业非行动。此义亦可然。若一切有为皆是刹尼柯。汝今应知。此义成实。谓有为刹那刹那灭。云何知。偈曰。最后灭尽故。释曰。诸有为法。灭不由因。何以故。因缘者为生有法。灭非有法。若非有此因何所作。此灭既无所有。故不须因。有法生时次若无灭。后时亦应无有法无异故。若汝言此法变异方有灭。此法即非此变异故。是义不然。何以故。此法自体由自体变异。无如此理。若证见薪等由火相应故。灭不显现。善友为与火相应。薪等灭尽故不可见。为自然灭。余不更生故不可见。譬如与风相应故灯灭。与手相应故铃声灭。是故此义由比量得成。此中何法为比量。已说由灭非因。所作故。复次偈曰。无不从因生。释曰。若灭必由因则无灭。无因所生故。刹那生灭法。如智声光等。见此灭无因。是故知一切灭皆不观因。若有人执由别智故余智灭。由别声故余声灭。是义不然。二智不俱起故。疑智及决智。无道理得俱起。苦乐嗔欲亦尔。若明了智及声生。次第不明了智及声生。云何不明了等类法。能灭明了等类法。若有人执。灯光于余位中无依处故灭。或由随法非法故灭。此执不然。何以故。此无不应成因。所执法非法。为生灭因无道理。于刹那中起如此功能。于一切有为中。可作如此分别余因。且置此诤。若言薪等灭以火相应为因。此执中熟所生德。少熟中熟最熟生中。偈曰。生因成能灭。释曰。此熟中生因即成灭因。何以故。由从火相应熟德生从此不异。后中熟生时。少熟即灭。是彼生因即是灭因。或此灭由因不异。是义不然。偈曰。于决无证故。释曰。从如此因彼先得生复从此因彼更成灭。偈曰。于地等宁有。释曰。于光差别且得分别彼因有异。于灰汁雪酢曰水地相应故。熟德差别生时于中何所分别。是义不然。何以故。水被煮则减尽。于中火相应何所作。由此势力。生长火界。由火界势力。水聚渐渐减少。乃至极减位。不更接后相续。于中此事是火相应所作。是故诸有法灭皆无有因。是坏性故自然而灭。若生即灭。是故彼刹那刹那灭义得成。由刹那灭故无行动。诸有法。于余处无间生中。世间起行动妄执。譬如草光等。行动既无相貌为身业。此义得成。经部师说。相貌非实有物。何以故。偈曰。向一方聚生。执色假说此。相貌由比量。约色相决判。释曰。若色多生于一方假说名长。观此色于余色少假说名短。若于四方色多生假说名方。若一切处色生等。假说名圆。所余亦尔。譬如火薪。疾向一方。于余处见无间则执为长。若于一切处见则执为圆。是故相貌与色无别类。何以故。若有别类。偈曰。二根取无入。决是意尘故。释曰。若眼见此分别为长。若身触亦尔。是故此相貌。应成二根所取。无有色入为二根所取。偈曰。由分别坚等。长等智生故。释曰。如于触中执长等相貌。汝于色中应知亦尔。于相貌中唯有忆念起。与触相应故。无有证取。譬如人见火色。于火热触生念。闻花香于花色生念。此中是义应理。由彼实有不相离故。是故互得相比。偈曰。于大聚集有。复决定相貌。不同相违故。释曰。无有触尘于相貌中。定因此定故。于二中更互相比知。决定得成。若无定相应取触。比相貌决定成。于色比亦定应成。或如于色于相貌不定故。比不应成。此二义悉不成。是故由触比相貌。是义不然。于有众多相貌物。如[毯-炎+瞿]毹等。由见众多相貌故。随一所见。是众多相貌所成一分。若是实物。此义不成。譬如显色。是故相貌无有实物。复次随有有碍色。此色必定有邻虚。相貌色无别邻虚。是故多色如此聚集。假说长等名。若汝言。是相貌邻虚聚集如此得长等名。此执一向堕偏助。相貌邻虚不成就故。若彼别相成就。彼聚集可然。相貌邻虚如色等邻虚。自性既不成就。云何得有聚集。若汝言色同不异。但见相貌有异。谓土器等。是义不然。前为不已说耶。若色起如此相。于中假立为长等。譬如蚁等。无有差别。而说有行轮等异。相貌亦尔。复次若汝言。于闇中远不见色。如杌等但见长等相。故相异色。是义不然。何以故。是所见即是色。于此中不明了故。分别为长等。譬如行军等。由如此理。此义必应然。有时不可分别差别。唯众物聚集。见不明了。若尔汝等经部师。除身行动及相貌。此中汝立何法为身业。但立相貌。为身有教业。不由实有故。若汝假说相貌。云何立为身业。以身为依止。此业为身业。若故意能引身。于种种处即立此故意为身业。如此口意二业。如理应知。若尔于前已说。业有二种。一故意业。二故意所造业。此二有何异。分别故意先起。谓我等应作如此如此。是名故意业。故意分别已。后引事故意起。能引身作种种事。是名故意所造业。若尔则无有教业。是有教业于欲界亦无。是故随此执有大过失起。若尔对此过失。复有别对治起。若无教业。从如向所说名身业。故意差别生。何所有此应随从故意起。譬如定无教。此过失不应有。由随本故意差别所引及依事。故意差别生故。若有教起。亦观本能引故意势力故。此方得生。由昧钝故。何况无教。毗婆沙师说。身相貌实有物。身有教业以此为体。偈曰。言教语音声。释曰。是声言语为性。是名有教。言业无教。于前已说。经部师说。此亦非实有物。何以故。先已信求。唯定不作为量故。彼师依过去四大。成立此义故。过去四大已无为性故。由执此色为相故。毗婆沙师说。此无教实有物。云何得知偈曰。三无流色长。不作说道等。释曰。于经中说。色有三种。有三处能摄诸色。有色有显有碍。有色无显有碍。有色无显无碍。佛说有无流色。如经言。何者无流法。若色过去现世未来。于中欲不起嗔不起。乃至于识亦尔。说此名无流法。若除无教色。则无无显无碍色及无流色。经中又说增长。如经言。若善男子善女人。有信根与七种有摄福德业处相应。若行若住若卧若觉。恒时平等。福德增长。福德相续。与无摄相应亦尔。若离无教。异缘心人。福德业处不应有增长。若人自不作但教他作。若无无教业道不应成。何以故。令他教业非是业道。非自所作业故。若已作此性无差别故。亦非佛世尊说。比丘诸法是外入。非十一入所摄。谓无显无碍。不说无色。此言则成无用。若不见无教色在法入摄。若离无教色。圣道不成八分。若人入观正语正业正命。不相应故。若尔此经所说云何经言。若人如此知如此见。正见至修习圆满。正觉正进正念正定。先时正语正业正命。已清净离染污。此言约先循世道离欲。故作此说。若无无教色。波罗提木叉戒亦不应成。何以故。从受戒后此戒即无。谓能成异缘心人。为比丘比丘尼等。于经中说。远离戒为塘。能遮邪戒故。若此无不应成塘。由此等证故知实有无教色。此中经部师说。此证甚多种种希有。理实不然。何以故。是汝所说。由三种色故。有无教色。此中先旧观行师说。诸观行人有定境界。色由定威力生起。此色非眼境故说无显。不遮处所故说无碍。若汝言。此云何名色。此难于无教亦同。是汝所说。由说无流色故。有无教色。此义同前。此色由定威力生。在无流定中。为境界故。观行人说。此为无流色。有余师说。阿罗汉色及外色名无流色。非流依止故。若尔经中云何说。何者有流法。谓一切眼一切色。广说如经。此色非流对治故。说名有流。由此别义。此色可说有流。可说无流。若尔何有相杂过失。由此相此色成有流。不由此相更成无流。于中有何相杂。若色入一向有流。此经中云何简别说。经言有流色者。若色有取心坚覆藏所依。广说如经。是汝所说。由福德增长者。此中先旧师说。此是法尔。如如施主。所施财物。受者受用。如此如此。由受者功德胜劣故。由财物利益胜劣故。若施主心异缘。由先缘施故意所熏修故。是时相续至得微细转异胜类。由此于未来时。为生多少果报相续功能。约此义故。说福德增长福德相续。若汝言。由别相续胜劣。于异缘心人别相续转异。今云何得成。此执与无教同。由别相续胜劣。于别相续中有别法名无教。此云何得成。于无摄福德业处。此云何有。由数数修习。能缘此为境故意故。于梦时此亦得随相续并起。若人说有教。于无摄福德业处。于中既无有教业。云何得有无教。有余师说。于有摄福德业处。由数数修能缘此为境故意故。无教得生。若尔云何。于经中说。若比丘。有戒有善法。食施主一食已。修无量心定。由身证触依。此中住因。此生能施施主无量福德无量善流。安乐之食。应信求如此。此中是时有何故意差别。是故相续转异胜类。此义如理。是汝所说。若人教他业道。云何成者。此中经部师说。由此人立教损害他差别成故。于能教人相续中微细转异胜类得生。由此转异。于未来中此相续为生多少果报。则有功能。若人自作事果究竟时。应知此义如前。此相续转异胜类。说名业道。于果立因名故。说此为身口业者。是身口二业果故。譬如说有无教人。于无教立身口业名。大德说。于所取阴中。由三时故意起故。此人为杀生罪所触。谓我今必应杀正杀已杀。若此故意生。由此量业道不得成就。何以故。勿自父母等未被害。由妄分别杀故无间业成。若自杀起如此等故意。业道则成。若作如此意则应道理。汝何憎嫉心偏拨无教。信受相续转异胜类。二俱非所解。无憎嫉心虽然由随故意身加行业道究竟故。若已成此别法。异于二依能行人生。此义不生爱乐。若由故意起加行事生究竟。因此事相续转异胜类。成此义则生爱乐。从心心法相续。未来果报生故。是汝所说。由无有教业故。无教则无。如此等义于前已答。是汝所说。由不说法入非色。此言已答。无显无碍是定境色即法入摄。是汝所说。八分圣道不应成者。善友请汝。为说此义。若人入观修道。正语正业正命。云何应有此人说言。作业求觅衣食不。不尔云何此人得如此相无流无教。由得此分。后时出观。则不更行邪语等事。必能恒行正语等分。是故由于因立果名。说无教为正语等分。若尔此中云何不执如此。若人入观修道。离无教得如此相。谓故意及依止。由得此二。后出观时。不更行邪语等事。恒行正语等分。是故由于因立果名故。得安立圣道八分。有余师说。此中唯不作为量。说名三分。由此圣道势力。此人必得定。不更作邪语等。此定不作。由得无流道为依止。说名无流。何以故。于一切处。不定应数实有体法。譬如八世法。一得二不得三好闻四恶闻五赞六毁七乐八苦。此中不得衣服等。非实有别物。亦被数于余处亦尔。波罗提木叉戒等亦尔。有信求心人。由故意先作受方便。于如所遮业。护持身口。若汝言。心异缘时。即无复戒。是义不然。由数习此。故意欲犯恶事时。是人忆本故意护持。即起塘义。亦有忆持。先不作恶誓。起惭羞心故。不破禁戒。此即塘义。是故依师受不作恶。若如汝所言。唯无教业。能遮断犯戒失则应无人忘念破戒。且止广诤。毗婆沙师说。有别物。色为性。名无教。此若有前已说。此依止四大生。为依有教四大生。为不尔。依别四大生。何以故。此一和合。有细粗二果。无如此义。无教所依四大。与有教四大同时起。不一切所造色。若现世若未来。多依过去四大生。此所依云何。偈曰。刹那后无教。欲过去大生。释曰。从初刹那后。欲界无教。依止过去四大生。是四大作此生依止。是身现世四大为相续依止。是二四大。次第为此生流因故。譬如轮行于地。以手转之。以地为依处。所依止四大是何地。能依止身口业是何地。偈曰。依止自四大。身口业有流。释曰。欲界身口业。但依欲界四大生。如此乃至第四定身口业。依止第四定四大生。偈曰。无流随生处。释曰。若无流身口业。随地受生人所得。应知即依此地四大生。由不堕于界故。无流四大无故。由彼力生故。此中有教无教二业应知。偈曰。无教非心取。流果众生名。流心取大生。释曰。无教者其相云何。非心心法。依止等流果。似因故。众生法故。等流果心心法所取四大。依此无教生非定地。无教品类如此。定地云何。偈曰。定生增长果。无取异大生。释曰。定无教无流无教。皆从定心生。依定所生增长。非心所取。不异四大生。不异者。若依止此四大。离杀生无教生。即依此四大。乃至离无义语无教生。云何如此。如心四大不异故。于波罗提木叉戒中。各各依四大。七无教戒。生有教色等流。若属身是心所取。此有教色若生。为破前相貌相续起为不。若尔何有。若破前后生果报色。已断由更相续故。则违毗婆沙执。若不破而生。云何于一四大聚中。有二相貌起。是时有别等流四大生。依此有教色生。若尔依随一身分。有教色生。此分则应大本。彼四大所遍满故。若不遍满。云何由具分起有教色。由身空故。故彼有处。此业由别义说。有二种三种五种。此中无教有二种一善二恶。偈曰。无无记无教。释曰。云何如此。无记心力弱。是故不能引生有力业。若因已灭。此等流果恒相续起。偈曰。余三释曰。余业有三种。谓善恶无记。何者是余。谓有教及故意。偈曰。复不善欲中。释曰。若恶业应知唯于欲界中非余界。三恶根及无渐无羞灭故。若善无记一切处有。以不遮故。偈曰。色无教。释曰。若色界有无教。何况欲界。于无色界无。无四大故。若是处有身口生。此中有身口护戒。若尔若人身在欲色界。入四无色定。应有无教。譬如无流无教。是义不然。此不堕三界故。通无色界无教。不应依止不等类四大生。背一切色故。故无色界定不能引生色。制伏色相故。持戒为对治破戒。破戒但是欲界法。于欲界由四种远。无色界最远。谓依止取相境界对治故。是故于中无无教。毗婆沙师说如此。偈曰。有教有观二。释曰。是有教色。于有观二地中有。谓欲界及初定。上去皆无。偈曰。欲无无记教。释曰。于欲界无有覆无记有教。于梵处则有。何以故。曾闻大梵王有语从谄曲生。此于自大集中。为避净命阿输实难赞叹自身。若尔从第二定以上。若无言说云何有声入。以外四大为因故有声入。余师说。于第二定等亦有言语。但是无覆无记。无善无染污何以故。若人生彼处。如此类下地心。不能引令现前。为生身口。有教业最粗下故。已弃舍故。前义是彼所说。复有何因。离梵处于上无有教业。于欲界无有覆无记有教业。偈曰。缘起无有故。释曰。若有觉观心。能起身口有教业。此心于第二定等则无。此若起必由修道所灭心起。见谛所灭心。依内门起故。是故于欲界中。无有覆无记身口二业。为由随发起。应知诸法善恶性为不尔非。云何。由四种因。一真实。二自性。三相应。四发起。此中偈曰。解脱真实善。释曰。涅槃者。一切苦寂静。最极平安故。是真实善。譬如无病。偈曰。自性根惭羞。释曰。根谓三善根惭及羞。此法由自性是善。不观别相应发起因故。譬如良药。偈曰。相应彼杂故。释曰。与三善根及惭羞。相应诸法。由相杂故是善。若彼不与此相应则无善性。譬如良药杂水。偈曰。发起有教等。释曰。身业口业。及心不相应诸行。与善根等相应法所发起。由发起故是善。譬如煮良药汁所成乳。诸至得等非同类心所发起。云何是善性。由此义故善。如所说四种善。偈曰。翻此四名恶。释曰。云何名四恶。生死名真实恶。生一切苦为体。最极不平安故。譬如有疾。三恶根及无惭无羞。名自性恶。不观余因成故。譬如恶毒。与彼相应诸法由相应故名恶。譬如恶毒杂水。彼法所发起。身口二业。生等及至得。由发起故名恶。譬如煮恶毒汁所成乳。若尔无一有流法应成无记或成善。皆入生死内故。如汝所言。实皆如此。若有流法。于果报不可记。说名无记。若有流法。于可爱果报有记说名善。若真实无记。必应寻求。偈曰。实无记二常。释曰。二种无为法。非有别方便成无覆无记。谓虚空及非择灭。此义应思。若身口业。由随发起成善恶性。四大云何。非善恶性。作者于业中有故意。非于四大。若尔入定观人。于无教无故意。非寂静心。不能发起无教非同类故。云何无教成善。天耳天眼。应立为善性。于中故意所发起故。此中汝应作功力。是汝所说。见谛所灭心。不能发起身口有教业。此义若尔。云何佛世尊说。从邪见邪觉观。生邪语邪业等亦尔。如此等此义不相违。何以故。偈曰。缘起有二种生因刹那起。释曰。有教无教缘起有二种。一生因缘起。二共刹那缘起。于一刹那共起故。偈曰。于二初能生第二随彼起。释曰。生因缘起者。唯能生能引。未有令有故。共刹那缘起者。唯能随共生。于事时不相离故。此心于此事中有何能。虽先被引。若离此心事则不起。譬如死人。若尔若人无心。于生无教戒。此心云何有。若人有心此身口业则明了起。是此心功能。此中偈曰。能生见谛灭意识。释曰。若见谛所应灭心。能为身口业生因。何以故。能发起彼觉观生资粮故。不能随起缘。外门起心事时。此心已无故。是色若以见谛心为缘起生。此色亦是见谛灭。斯有何失。则违阿毗达磨。彼藏云。与明无明不相违故。无色见谛所灭。此立未成。何以故。是四大应成见谛灭。同心所起故。此失不应有。如其非善非恶。若成如此复云何。此亦不可。何以故。此色无道理成见谛灭。亦不成非所灭。与明无明不相违故。是故依生因缘起。于经中说无相违。偈曰。修道灭生随起具能。释曰。若修道所灭意识有二种。谓能生及能随。偈曰。五识唯随起。释曰。五识无分别故。但与身口业共一刹那起。不能为引生因。此中有四句。见谛心但是生因缘起。五识但是共刹那缘起。修道所灭意识具二种。一切无流。无二种如能生缘起。共刹那缘起亦尔不。此义不定。偈曰。于能生善等。随起有三种。释曰。生因缘起若善。共刹那缘起。或善恶无记。生因缘起若恶无记亦尔。偈曰。于佛等或善。释曰。于佛世尊一人。生因缘起共刹那缘起。此二必同。若善同善。若无记同无记。或善者。有时生因缘起无记。共刹那缘起或善。无时生因缘起是善。共刹那缘起是无记。何以故。诸佛正说。无时萎歇。余部师说。诸佛世尊。无无记心。何以故。佛世尊相续。一向自性是善。恒寂静故。于经中说

  那伽行寂静　　那伽倚寂静
  那伽卧寂静　　那伽坐寂静

若不由诸佛意欲。余心不起故。故说如此。非有如来无记心。谓果报威仪变化心。毗婆沙师说如此。前已说。若修道所灭意识。能作生因缘起。及作共刹那缘起。应知此一切善恶无记。偈曰。果报生无二。释曰。若果报心。不能作生因缘起。亦不能作共刹那缘起。不由功用生及起相续故。今为如能生缘起身口业生。为如共刹那缘起。若尔何有。若如能生。于欲界中应有有覆无记有教业。身见边见所生起故。若尔一切见谛惑。亦无但能生此中应说差别道理。若如共刹那。若人起恶心或无记心有教。波罗提木叉不应成善。如能生有教亦尔。不如见谛所灭。修道所灭心为隔故。若不由随共刹那缘起。判有教善恶等。不应说如此。于经中佛世尊依生因缘起说。非依共刹那缘起说。是故于欲界无有覆无记有教业。若尔应说。如此依别法所摄生因缘起说。此诤已竟。如前所说。有二种无教。今说偈曰。无教应知三。护不护异二。释曰。此无教。一名护。二名不护。三异此二。谓非护非非护。能遮能灭破戒相续。故说名护。偈曰。护波罗提木叉。定生及无流。释曰。此护有三品。波罗提木叉护者。若生此界。谓欲界戒。定护者。谓色界戒。无流护者。谓无流戒。偈曰。木叉戒八种。释曰。何者为八。比丘戒。比丘尼戒。式叉摩那戒。沙弥戒。沙弥尼戒。优婆塞戒。优婆夷戒。优波婆娑戒。此八种护说名波罗提木叉戒。由名此护有八。若约实物其数云何。偈曰。由实物有四。释曰。四者谓比丘戒。沙弥戒。优婆塞戒。优波婆娑戒。此波罗提木叉护。若约实物唯有此四。体相定同故。比丘尼戒与比丘戒不异。式叉摩那戒沙弥尼戒与沙弥戒不异。优婆夷戒与优婆塞戒不异。何以知然。偈曰。由根名异故。释曰。根者是相。能别男女异故。由此根故。比丘比丘尼等立有别名。云何如此。若转根比丘成比丘尼。比丘尼成比丘。沙弥成沙弥尼。若沙弥尼式叉摩那成沙弥。优婆塞成优婆夷。优婆夷成优婆塞。于转根时无有因缘。为舍前戒。无有因缘。更得新戒。是故四种护体性不异于三。若人从优婆塞戒受沙弥戒。从沙弥戒受比丘戒。为此护由远离增长故。说各各不同。譬如五十二十。及如陀那罗婆底罗等。为诸护各各具生。偈曰。彼各。释曰。此三种戒不相杂。各有别相生起。于三戒中有三种离杀生护。乃至三种离饮酒护。所余亦尔。三种远离有何差别。由缘起异故。远离有差别。如如求欲受持多种学处。如此如此。远离醉乱放逸处。能远离最多杀生等因缘。于远离缘起恒能得住。是故由缘起异。远离有差别。若无如此义。若人舍比丘戒。应即舍三戒。前二入第三。摄故此义非所许。是故三护各有别体。偈曰。不相违。释曰。此三共生。不由受后护弃舍前护。何以故。勿由舍比丘所受护。即非优婆塞。云何成优婆塞。云何成优波婆娑。乃至云何成比丘。偈曰。五八十一切。恶处受离故。优婆塞布萨。沙弥及比丘。释曰。此说应知如次第。于五种所应远离法。受持远离故。是人即住优婆塞护。五所应远离者。谓杀生不与取邪淫行妄语饮酒类醉处。于八种所应远离法。受持远离故。是人即住优波婆娑护。八所应远离者。谓杀生不与取非梵行妄语令醉饮。着香花观听舞歌等眠坐高胜卧处非时食。于十种所应远离。法受持远离故。是人即住沙弥护。十所应远离者。是前所说八。又受畜金银等着香花观听舞歌等。分为二故成十。一切所应远离身口二业。由受持远离故。是人即住比丘护。此波罗提木叉戒。偈曰。尸罗善行业。或说守护等。释曰。能平不平等事故名尸罗。若依尼六多论。由冷故名尸罗。如佛说偈

  受持戒最乐　　名色无烧热

聪慧人所称赞故名善行。所造为性故名业。于前为不说耶。无教者称无作。云何名业。由善受此有惭羞人。约恶法说名无作。此故意教业所作故说名业。余师说。是业因业果。故说名业。如此由通义。立波罗提木叉护等别名。复次偈曰。初有教无教。波木叉业道。释曰。若人正善受戒。初刹那有教无教。说名波罗提木叉。能受者因此解脱众恶故。解脱者弃舍为义。此亦名波罗提木叉护。从初乃至后时。皆能遮防身口恶业故。从第二刹那以去。但名波罗提木叉护。不得名波罗提木叉。根本业名波罗提木叉。非后分业。业道亦尔。复次如此等护。何护何人互相应。偈曰。应波木叉八。释曰。与波罗提木叉护相应有八部。谓比丘比丘尼。乃至优波婆娑住为第八。外道为无所受戒耶。有戒非波罗提木叉护。何以故。彼戒非一向为解脱众恶起。爱着三有故偈曰。定生护得定。释曰。从定生于定生。是护名定生护。若人与定相应。是人必与定生护相应。此中近分定。立为定故说定生。譬如郭邑近处亦名郭邑。如世言。于此郭邑有舍利田。有余谷田。偈曰。无流护圣人。释曰。一切圣人与无流护相应。圣人谓有学无学。于前俱有因中。已说二护随心生灭。于彼说何。二护于三中。偈曰。后二随心起。释曰。定护无流护。随心生住灭。波罗提木叉护则不尔。何以故。若异缘心人。此亦得生。后二不尔。复次此二或名灭护。此名在何位。偈曰。于未来二灭。九次第道生。释曰。于未来定中定护无流护。若在九次第道中说名灭护。何以故。此二能灭破戒。及能灭发起破戒诸惑故。是故有定护非灭护。此有四句。第一句者。除未来定。及无间道有流定护。第二句者。非至定及无间道无流护。第三句者。非至定及无间道有流护。第四句者。除非至定及无间道无流护。如此有无流护非灭护。亦有四句。如理应知。若尔佛世尊所说偈

  由身护善哉　　口护亦善哉
  依意护善哉　　一切护善哉

复有别说。比丘眼根善护所守护住。此意护根护自性云何。此二非无教戒性。云何。偈曰。合善慧正念。各说意根护。释曰。为显二护各具二性故。合离说欲显次第。意护以善慧正念为性。根护亦尔。此义今应思。何人与何有教无教。几时得相应。此中偈曰。若住波木叉。与现应至舍。与无教相应。释曰。若人住波罗提木叉护。乃至未舍无教。于中间恒与现世无教相应。偈曰。前念后与过。释曰。从初刹那后。与过去无教亦得相应。乃至弃舍。此句应知一切处如说。住波罗提木叉护人。偈曰。住不护亦尔。释曰。若人住于不护。乃至未舍不护。于中恒与现世不护无教相应。从初刹那后。亦与过去相应。偈曰。有定护相应。与过去未来。释曰。若得定生护。恒与过去未来无教相应。乃至未弃舍。何以故。若过去生中。所弃舍过去定生护。于初刹那中即得。偈曰。圣初非与过。释曰。若圣人与无流护亦尔。此是圣人差别。谓若初得无流护。则不与过去相应。于前世未曾得无流道故。偈曰。住定及圣道。与现世相应。释曰。若人与定护无流护相应。若入定观及圣道观。是人次第与现世无教相应。若出观则不尔。若人住于护不护。此事已说。若约中住人云何。偈曰。中住若有二初中。释曰。若人不住于护不护。说此人名中住。此人不必定有无教。若有恶戒及戒分所摄无教。于初与中相应。此现世在过去未来中故名中。偈曰。后二时释曰。从初刹那后。则与过去相应。又与现世相应。乃至弃舍。若人住于不护。为有时与善无教相应不。若人住于护。为有时与恶无教相应不。若相应复几时。偈曰。住不护与善。住护复与恶。与无教相应。乃至净污疾。释曰。若人住于不护。由善信心强疾作礼塔等事。则生善无教。若人住于护。由烦恼心强疾作打缚他等事。则生恶无教。此二乃至相续未断。无教于此时恒相续生。此人于初刹那。与现世无教相应。于余刹那与过去亦相应

阿毗达磨俱舍释论卷第十阿毗达磨俱舍释论卷第十一

        婆薮盘豆造

        陈天竺三藏真谛译

    中分别业品之二

分别说无教已。偈曰。复一切与教。正作与中应。释曰。一切人于护不护及中住。乃至造有教业未竟。是时中与现世有教相应。偈曰。刹那后与过。至舍。释曰。从初刹那后乃至舍。与过去有教相应。偈曰。非来应。释曰。无人与未来有教相应。偈曰。与有覆无覆。过去不相应。释曰。若有教或有覆或无覆。与过去不相应。未来亦尔。若法势力弱。至得亦弱。不得相续。此势力弱。何法所作。心所作。若尔心所作有覆无记。勿势力弱。是义不然。身口业昧钝故。依他成故。心则不尔。此无覆有教。亦由弱力故意所起。是故其力最弱。于前已说。有人住于不护。何法名不护。偈曰。不护及恶行。恶戒或业道。释曰。如此等是不护众名。此中不能禁制恶中身口。故名不护。聪慧人所诃故。得非可爱果报故。故名恶行。善戒对治故。故名恶戒。身口所造故名业。根本所摄故。名业道。有人与有教相应。不与无教相应。此义有四句。此中偈曰。但与教相应。中住下心作。释曰。若故意弱。或作善或作恶。此人住于非护非不护。但与有教相应。不与无教相应。何况作无记。除有摄福德业处及业远。偈曰。舍未生有教。余无教圣人。释曰。但与无教相应。不与有教相应者。若圣人已易生。若未作身口业。或已舍身口业。与二相应者。若人住波罗提木叉护。起身口业。或住非护非非护。由最上品故意。或作善或作恶。与二不相应者。除前三句。说住护不护及中人。安立至得有教无教义已。云何能得此护。偈曰。定生由定地得。释曰。是时若得有流定地心。或根本定或近分定。是时即得定生护。以一时俱起故。偈曰。由圣依此无流。释曰。若得此定地无流所依。即得无流护。此中有六定地。或皆无流。谓四定非至中间。此义后当说。偈曰。波木叉。由互令他等。释曰。波罗提木叉护者。由令他方得。若他令彼彼亦令他。此或从大众得。或从一人得。从大众得者。谓比丘比丘尼式叉摩那护。从一人得者。谓所余诸护。有毗那耶。毗婆沙师说。受大戒有十种。为摄此故说等。何者为十。一由自然得大戒。如佛婆伽婆及独觉。二由入正定聚得大戒。如憍陈如等五比丘。得苦法智忍时。三由呼善来比丘得大戒。如耶舍等。四由信受大师得大戒。如摩诃迦叶。五由答问难得大戒。如须陀夷。六由信受八尊法得大戒。如大瞿耽弥。七由遣使得大戒。如达摩陈那比丘尼。八由能持毗那耶为第五。于边地国得大戒。九由十部于中国得大戒。十由三说三归得大戒。如六十贤部共集受戒。是诸人波罗提木叉护。非定随有教。此波罗提木叉护。若欲受几时应受。偈曰。随有命善受。正护或日夜。释曰。七部所持波罗提木叉护。随有命应受。优波婆娑护。一日一夜受时决定。如此护时边有二。种谓寿命边。日夜边。于日夜重说。故成半月护。何法名时。此名显有为法义。于四洲是光位说名曰。闇位说名夜。此义可然。谓从命终后。虽复有受护不得生。依止非同分故。由此依止于中不能起加行故。不能令忆本行故。若人一日一夜后。或五日或十日。受优波婆娑护。于多优波婆娑护生中。何法能遮。应有法能遮。由如来于经中说。优波婆娑护。但一日一夜。此义今应思。为如来见一日一夜后优波婆娑护不得生故。但说优波婆娑护一日一夜为。为安立难调伏根众生。正受优波婆娑护。止于一日一夜中。如此事云何可思度。此时若护得生。与何道理相违。此事后不曾见如来为一人说故。毗婆沙师。非如来所说则不敢说。不护决定时云何。偈曰。无日夜不护。释曰。由此人乐一期作恶业。是故不护生。不得止一日一夜。不如优波婆娑护。何以故。如彼执。偈曰。由不受如此。释曰。无人受不护。如受优波婆娑护。愿我一日一夜中。受持不护。由此业是聪慧人所诃。若尔亦无如此受持。愿我一期中受持不护。是故勿一期得不护。虽不受持如此。由一向违善。故意作此恶事。故得不护。不由暂时违善故意得。是故皆得一生不护。优波婆娑护。虽心不一向。由求受故意力。是故一日一夜。得随所求故。若有人求得不护。暂时受不护。必得不护。此义非所曾见故。不可立如此。经部师说。如护无教非有实物。不护亦尔。非有实物。此不护以求恶事故意为体。共随续事。因此若人虽起善心。犹说有不护。以不弃舍此故。复次此优波婆娑护。若人欲一日一夜受。受法云何。偈曰。晨朝从他受。下坐随后说。布萨护具分。离庄饰昼夜。释曰。晨朝者。谓日初出时。此护时最促。唯一日一夜故。若人先已作求受意。谓我恒于第八日等时。必应受优波婆娑护。若食已亦得受。亦应从他受。不得自受。由此观他故。若有犯因缘。为不犯故。下坐者。或蹲或跪下心合掌。除病时若人无恭敬心。诸善护则不生。随施戒人语。后说勿前勿俱。若尔可说从他受。若不尔受施皆不成。若受必须具分受。不可减。分离庄饰者。离非旧庄饰。何以故。若常所用庄饰。不生极醉乱心如新庄饰。若受必须尽一日夜。至明旦若不如此法受。但生善行。不得优波婆娑护。此善行能感可爱果报。若执如此行。猎行邪淫人。于夜于日受优波婆娑护。必有果报不违道理。优波婆娑者何义。由此护此人近阿罗汉边住。由随学阿罗汉法故。又近随有命护边住故。或说名布沙他。生长单薄善根众生。复净善根故。名布沙他。如偈言

  由此能长养　　自他净善心
  故佛如来说　　此名布沙他

云何受此护。必须具八分。由此义偈曰。戒分无放逸。分修分次第。前四一后三。释曰。前四名戒分。从离杀生乃至离妄语。此四离性罪故。次一名不放逸分。谓离饮酒。若人善受具戒。由饮酒醉乱。能扰动诸学处海。由放逸故。后三名修分。乃至离非时食。能随助厌离心为功德故。若不受无放逸分及修分。有何过失。偈曰。由此失念醉。释曰。若人饮酒。即忘失是事非事念。若人受用高胜卧处及舞歌音乐等。心醉乱即生。于此二中。随用一处。破戒不远。若人依时食。由离先所习非时食。忆持优波婆娑护。即起厌离心亦生。若无第八。此二则不有。有余人说。唯离非时食。于此八中。说名优波婆娑。所余八。为此分开。观听舞歌着香花等分为二。若执如此。则为经所违。经云由离非时食。是第八分。我今随学随行诸圣阿罗汉。若尔何别法。名优波婆娑。以此八为分。是聚处随一一法说名分。譬如车分及四分军五分散。应知八分优波婆娑亦尔。毗婆娑师说。离非时食。是优波婆娑。亦是优波婆娑分。譬如正见是圣道亦是圣道分。择法觉分是觉亦是觉分。三摩提是定亦是定分。宿旧诸师说。不可立正见等为彼分。若前生正见等。于后生成分。初刹那生圣道不应成八分。为唯优婆塞有优波婆娑护。为余人亦有。亦有。偈曰。余人有布萨。若无三归无。释曰。若人非优婆塞。于一日夜中。归依佛法僧已。后受优波婆娑护。此人则得此护。异此则不得。除不知。经中说。佛言摩诃那摩。若人在家白衣丈夫。与男根相应。归依佛归依法归依僧。亦说此言。愿大德忆持。我今是优婆塞摩诃那摩。唯由此量。此人成优婆塞。为由受三归即成优婆塞。为不尔。外国诸师说非。罽宾国师说。离五戒则不成优婆塞。若尔经中说云何。此中无相违。由此言五戒发故。是故偈曰。由称优婆塞护。释曰。由信受自称名。是优婆塞。此人则发优婆塞护。是时信受已自称言。大德忆持。我是优婆塞。从今时随有命我离命。离夺命等事。由除中间语故。但言离命。已得戒人。为令识可持非可持故。后为说戒。偈曰。说如比丘护。释曰。已得具戒更令受学处。沙弥亦尔。为令识戒相。从此从彼汝今应护。优婆塞亦尔。离五护无别优婆塞。偈曰。一切若有护。一处等云何。释曰。若一切优婆塞。皆住优婆塞护。云何佛婆伽婆。说四种优婆塞。一持一处。二持少处。三持多处。四持具处。偈曰。能持故说尔。释曰。若人能持。随所应持。于中说此人为能持故。说一切优婆塞本有护。今此执违经起。云何违经。由信受称言即得五护。谓彼说离命。此言云何违经。经言不尔。经言云何。如摩诃那摩经说。于中是明优婆塞相。于余处则无。是处说如此文。随有命至于命。我今专信愿尊忆持。于此文中。见四谛人。显示见知种类。由寿命信受正法。若为救寿命。我亦无义更舍正法。此文不为显优婆塞相。如汝所说文句。谓为离命。于余处非所曾见。何人能从此不明了文。持一处等文。若依破戒人。说此文句。于中问亦不相应。何况答。何以故。何人已解优婆塞护。不解如此若人不破此戒是人持此戒。若人不识优婆塞护量。依能持如此护量人故问。此问则应理。问言世尊几量为优婆塞持一处。乃至几量。为优婆塞持具处。毗婆沙师说。若离护亦成优婆塞。若不具受护。亦应成比丘及沙弥。犹如优婆塞。优婆塞等护分量。决定云何。随大师分别所立。分别决判立优婆塞等异。汝亦应许。由随大师分别所立。何以故。若未有护。如世尊安立优婆塞安立沙弥比丘。则不如此。罽宾国师。不许此义。一切护偈曰。下中上如意。释曰。八部所持护。有下中上品。云何得成。由求受故。意有差别。若作如此执。阿罗汉波罗提木叉护。应最下劣。凡夫应最上品。若唯受护。不受三归。得成优婆塞不。不得。除无知。若人归依佛法僧。此人归依何法。偈曰。能成佛僧法。无学及二种。归依及涅槃。归依佛法僧。释曰。若人归依佛。必归依能成佛无学诸法。何者能成法。由彼法胜故此身说为佛。或由得彼法。于一切觉中。有胜能故。说此人为佛。此法何相。尽智等共伴类。色身前后无差别故。若归依佛。为归依一佛。为归依一切佛。若依道理。归依一切佛。道相不异故。若人归依僧。此人即归依能成僧。有学无学诸法。由得彼法。八道果人成僧。不可破故。若归依僧。为归依一僧。为归依一切僧。若依道理。归依一切僧。道相不异故。经中说于未来世中当有名僧。此人亦归依此僧。此言为显现在僧宝最胜功德。若人归依法。此人即归依涅槃。所谓择灭自他相续中。惑及苦。寂静为一相故。若定以无学法为佛。云何于如来边。起恶心出佛身血。得无间业。由损害依止故。彼法亦被损害。毗婆沙师说如此。阿毗达磨藏不说如此。唯无学法是名佛说。云何成佛诸法名佛。不遮依止为佛故。是故此难不成难。若不尔。佛在世心。则不成佛。僧亦应尔。唯戒能成比丘。是故戒是比丘。如人供养比丘。则供养能成比丘戒。如此若人归依佛。则唯归依能成佛无学法。有余师说。若人归依佛。此人即归依十八不共法。归依体性云何。有教言语为性。归依者何义。救济为义。由依止此三。永解脱一切苦故。如佛世尊所说偈

  多人求归依　　诸山及密林
  园苑树支提　　怖畏所逼恼
  此归依非胜　　此归依非上
  若至此归依　　不解脱众苦
  若人归依佛　　归依法及僧
  四种圣谛义　　依慧恒观察
  苦及苦生集　　一向过离苦
  具八分圣道　　趣向苦寂静
  此归依最胜　　此归依为上
  若至此归依　　则解脱众苦

是故信受归依行。于一切受护为入门。复有何因。佛于余护中。立远离淫欲。为学处。于优婆塞护中。立远离邪淫。为学处。偈曰。邪淫最可诃。易作得不作。释曰。邪淫于世间最可诃。为侵坏他妇故。能引恶道业故。淫欲不尔。若在家人。远离邪淫。此事易作。远离淫欲。此事难作。由不能行难行事故不出家。诸圣人于邪淫性得不作护。于余生自性不犯故。于淫欲不尔。是故于优婆塞护中。立离邪淫为学处。勿别转生圣人犯优婆塞护分。何以故。决定不作。名不作护。若人已成优婆塞。方娶妻妾。此人于彼为得护不。说得。勿于一处得护。云何于彼不破坏护。偈曰。如受意得护。非于相续得。释曰。如彼受护故意得护亦尔。受护故意云何。谓我今永离邪淫。非于彼相续。谓我今不应作淫欲。是故受五戒人。以彼为依止。于离邪淫分得护。不从于彼离淫欲得。是故由成自妇行淫欲。不违破护。云何唯离妄语。于优婆塞护。立为学处。不立离两舌等。由前三证。谓妄语最可诃。易作得不作。偈曰。通起妄语故。过一切学处。释曰。于一切违犯学处中。若被检问妄语即起。谓我不作。如此由妄语。通起堕犯无更起义。故大师约此义。谓云何犯戒人。如实发露显示自失故。立离妄语为护。复有何因。于假制罪中护。不立为优婆塞学处。彼说立。偈曰。假制罪中唯。离酒释曰。何因唯离酒为戒不离余。偈曰。为护余。释曰。何以故。若人饮酒。则不能守余护分。云何知饮酒是假制罪。无自性罪相故。性罪相者。若起染污心。方犯此罪。是名性罪。有时唯作对治病。意饮酒如量不令醉。若尔此心已成染污。本知此能令醉而故饮。非染污。由知如量不令醉故饮。一切毗那耶藏师说。饮酒是性罪。如律文言。世尊云何应治病人。佛言。优波离。除性罪。何者性罪。是我为优婆塞所立学处。复次释迦病时。世尊不许饮酒。复次经言。比丘若人说我为师。由茅端酒亦不应饮故。知饮酒是性罪。复次圣人已转别性。本性不犯此故。如杀生等。复次由说此是身恶行。阿毗达磨师说。不尔。何以故。有时为病人许开假制罪。而重遮饮酒。此何所以为离非所许应至故。能令醉量不定故。是故由茅端饮亦不许。非圣人所犯者。由诸圣人惭羞失念事。因此失念。是故一滴亦不许饮。以量不定故。譬如恶毒。说身恶行者。放逸依处故。是故于中立放逸依处名于余处不立。彼处自性罪故。若过量数习。世尊说由此入恶道。是义云何。由爱习此数数恶行相续生故。能引感恶道业故。得生恶道。酒酒类令醉放逸依处。此句有何义。酒谓饮酒。酒类谓余物酒。此二有时未至及已度令醉位。不名令醉。为除此故。说令醉槟榔子。及俱陀婆谷。亦能令醉。为除此故。说酒及酒类。虽是假制罪。为显因缘。令殷重急除。故说放逸依处。一切恶行所依故。是三种戒。谓波罗提木叉。定生。无流。从此因若得一戒。为得余二戒不。说非。若尔云何。偈曰。欲从一切二。现得木叉护。释曰。欲界戒。谓波罗提木叉护。从一切者。谓前分根本后分。从二者。谓众生名非众生名。又性罪处假制罪处。从现者。谓现世五阴十二入十八界。从此得波罗提木叉戒。何以故。缘众生为境起故。是故不从过去未来。得去来二世非众生数故。偈曰。从根本恒时。得定无流护。释曰。从根本业道。得定生护及无流护。不从前分及后分生。何况从制罪生。从一切时阴入界所得。谓过去现世未来。因此故立四句。有阴入界从彼得波罗提木叉戒。不得定生及无流戒。应如此广说。第一句者。从现世前分后分从制罪处。第二句者。从过去未来根本业道。第三句者。从现世根本业道。第四句者。从过去未来前分后分。此护不护。为皆从一切境一切分一切因得为有异。若约决定得。偈曰。于众生得护。由分因不定。释曰。护从一切众生得。不从一分众生得。从分不定。有人从一切分得护。谓受比丘戒。有人从四分得护。谓受所余诸戒。业道是一切护分。由因有义从一切得。有义不从一切得。若立无贪无嗔无痴为护生因。即从一切得。彼不相离故。若立下中上故意。为护生因。则不从一切得。三品不俱起故。今定立后因为生因。应论此义。有住护人。于一切众生有护。不由一切分。不由一切因。若人由下品或中上品故意。受优婆塞及沙弥护。有人于一切众生有护。由一切分。不由一切因。若人由下品或中上品故意。受比丘戒。有人于一切众生一切分一切因得护。若人由三品故意。受三种护。有人于一切众生。由一切因得护。不由一切分。若人由三品故意。受五戒八戒十戒。若不从一切众生。如此护则无。何以故。由此人随遍一切众生。于善故意中住方得护。异此不得故。云何如此。恶意不绝故。若人不作五种定分别。乃得波罗提木叉护。五定分别者。谓众生分处时缘。于某众生我离杀等。是名众生定分别。于某分我持。是名分定分别。于某处我持。是名处定分别。我持此护乃至一月等。是名时定分别。除斗战事。是名缘定分别。若人作如此受。唯得善行不得护。于非所能境。云何得护。由不损害一切众生命。善故意受得故。若从是所能境得护。此护则有增减。所能非所能互相转故。若尔离得舍护因缘得护舍护。此义自成。毗婆沙师说如此。有余师说。此义不应尔。何以故譬如草等未有有时或时枯。灭护无增减义。于所能非所能众生。互相转时。无增减义亦尔。是义不然。众生前后有故。草等不有。若众生般涅槃永不有。云何护增减义不成。是故此救义不可然。前言义则为善。若尔于前佛所一切已般涅槃众生。后出世诸佛。从彼不得波罗提木叉护故。云何后佛戒减前佛戒。此义不成。从一切众生得故。若彼众生设在。从彼亦应得说。能令得护因义已。不护云何得。偈曰。不护从一切。一切分非因。释曰。不护者。从一切众生得。从一切业道得。何以故。无不护人由不具不护。成不护不由一切因。一时下品等不俱起故。若人由下品心得不护。此人由上品心。亦得断众生命。此人与下品不护相应。亦与上品杀生等无教相应。由中上。品心亦尔。此中是人名不护人。谓杀羊。杀鸡。杀猪。捕鸟。捕鱼。猎鹿。偷盗行。刑戮人。狱卒。缚象人。煮狗人。网捕人。主将军。断事人。如此等人。约义皆是不护。住于不护故。名不护人。彼有不护故。名不护人。此义可然。谓诸护从一切众生得。于一切众生。由善利故意受持故。杀羊等人。于母父妻子等中。无损害心。为救自寿命。亦不乐损。彼云何言从一切众生得。至亲等若转生成羊等。彼亦能杀。何以故。知彼未成彼等。是故不杀。若至亲等成圣人更为畜生。无有是处。从彼云何得不护。若由观未来世事从现世相续生不护。羊等于未来应成儿等。从一向不杀。云何于现世相续得不护。若人于众生恒起损害意。从彼无不护。此执有何义。此义于至亲等同。此人于彼无损害意。而从彼得不护。此义复云何。若有杀羊等人。于一生中不与不取。于自妻知足。于妄语喑哑。云何由一切分得不护。善故意坏故。若义应由言语得显。彼能以身显示。若尔有人受学处。或二或三。此义云何。一向无不具分不护及一处不护。毗婆沙师说。如此随求受故意。不具分及一处。皆得不护。受护亦尔除八分护。经部师说如此。由如此量。遮防善戒恶戒故。说从此得不护已。云何得不护。此义未说。今当说。偈曰。得不护由二。自作及求受。释曰。不护由二因得。若生彼家。由自行杀生等事。若生余家。由求受此业。谓我等应行此业。为立资生。由此二因故。不护得生。偈曰。得所余无教。由田受重行。释曰。有如此相田。于中由唯施阿蓝摩等生善无教。如有摄福德业处说。复次自誓受善行。若未礼佛。我誓不食不眠。若斋日及半月一月中。我当恒施他食。如此等。由此受善行无教恒流。有如此故重心行善恶诸业。从此更生无教。说由此能得护不护已。舍护不护今当说。此中偈曰。舍护木叉调。由舍学处死。由二根转生。由根断时尽。释曰。木叉调者谓波罗提木叉护。能调伏身口业故。有四因能舍波罗提木叉护。除优波婆娑护。一由故意。于有解人边舍所学处。二由舍聚同分故舍。三由一时二根俱起故舍。四由善根断故舍。优波婆娑护。由前四因故舍。复由夜尽故舍。合此为五。故说舍因有五。何因由此五故舍。由生有教与求受故意相违故。依止不住故。依止变异故。缘起断故。引如此量故。偈曰。余记感大烧。释曰。有余部说。有四种感大烧燃罪。由随犯一罪。即舍比丘及沙弥护。偈曰。或由正法尽。释曰。有余师说。由正法灭尽时。一切学处戒坛羯磨一切舍离。偈曰。罽宾师说犯。有二如负财。释曰。罽宾国毗婆沙师执说如此。若人犯根本罪。不舍比丘戒。何以故。由动坏一处舍一切护。此不应然。犯别学处。余学处断。无如此义。虽然此人有二种。有戒有破戒。譬如有人有财物而负他债。发露显示此罪已。还得具清净戒。无复破戒。譬如有人还他债已更具财。若尔云何。佛世尊说。此人非比丘。非沙门。非释子。从比丘护沙门义断。堕灭退故。说名波罗夷。约真实比丘故说此言。今不计命大过事起。何者不计命大过事。是佛世尊立为了义。汝翻此为不了义。于破戒与缘。于多烦恼人。为作犯缘。云何知此言是了义。此言于毗那耶中是决判说。毗那耶云。比丘有四种。一名比丘。二自称比丘。三乞者比丘。四破烦恼比丘。于此义中白四羯磨受戒。说为名比丘。此人先是真实比丘。后成非比丘。无如此义。是汝所言。由犯一处。所余不失。此中大师已与决判。譬如多罗树。于头被斫。更不生荑。不应成老。不应成长。不应成大。世尊作如此譬。欲显何义。如此由破一分根本故。所余护无更生起义。若人犯根本罪最重。能破一切比丘行。与最重无惭羞相应故。此人即断一切护根本。是故舍一切护。此义应然。何以故。于大众食及住处。佛不许此人啖一段食。践一脚跟地。此人大师所摈出一切大众事用外。约此人佛复说言。汝等应灭除甘蔗栽。拔弃空腹树。簸却无实谷。汝今应遮断。非比丘自称为比丘。于此人比丘法何相。如相是相。虽然不无比丘法。何以故。佛世尊说。准陀沙门但四。无有第五。四者。一道生。二说道。三道活。四污坏道。有如此说。此人唯相貌为余故。说为沙门。譬如烧木枯池鹦鹉嘴坏种子火轮死众生等。若由破戒成非比丘。不应成与学比丘。我等不说。一切犯戒人。由犯戒事。即成波罗夷。若波罗夷人。必定非比丘。有余人由相续胜异。虽犯而非波罗夷。由一心不敢覆藏故。法主安立律义如此。若波罗夷非比丘。云何不更许出家。由相续为最重无惭羞所坏。于护不能感生故如焦种子。不由观有比丘法故。何以故。此人若已舍戒。亦不许更出家故。于此毁损。功用何益若人已成如此。犹名比丘。勿然此为比丘义。由正法灭尽毗那耶羯磨无故。不更得新护。若已得不舍。复次定生护及无流护。弃舍云何。偈曰。由度地及退。弃舍定得善。释曰。一切定得善法。由二因缘舍离。或由受上地生度余地。或由退上定堕下地。或由舍聚同分。复次如色界定得善。由度余地退及弃舍。偈曰。无色亦尔。释曰。于无色界定得善。约度余地及退亦尔。唯无定戒。偈曰。圣得果练根退。释曰。无流善由三因缘故弃舍。由得果弃舍前道。由练根弃舍下劣根道。由退弃舍上品道。或果或于果胜道。弃舍诸护法如此。偈曰。舍不护得护。死二根生故。释曰。有三因缘。能断除不护。一由得护。谓受持护。或得定生护。由昔因缘力故得定。一切不护皆断绝。对治力大故。二由死弃舍不护。由依止破灭故。三由二根俱起弃舍不护。依止变异故。若人舍杖网等。由不欲作意故。虽舍离缘起。若不受对治护。不护无断义。譬如离病缘起。不服良药重病不差。前义亦尔。是不护人。若受优波婆娑护。为从护入不护。为从护入非护非不护。有余师说。还入不护。以舍意不定故。譬如赤铁更还青色。毗婆沙师说。是义不然。若人更行先事。还入不护。由此至得随属有教故。复次异护不护无教云何弃舍。偈曰。疾心受行物。命根断舍中。释曰。由善心强疾。或由烦恼必强疾。能引无教生。此心若断无教即断。譬如陶师转轮及放箭等行。由受心断无教亦尔。若人舍受心。谓勿如此受由行事断此亦断。如本所作事即若不更行。由具物断此亦断。何者具物。谓支提园眠坐具延多罗网等具类。由寿命断。或由善根断。此亦即断。若人作断善根方便。由此六种因即弃舍。此中无教偈曰。欲界无色善根断上生舍。释曰。若欲界中一切非色性善。由二种因弃舍。谓善根断。及生色无色界。偈曰。由对治生故。舍无色染污。释曰。一切非色性染污。由对治故弃舍。是惑种类应除。是对治种类能灭。由此对治生即弃舍。染污及伴类不由别方便。复次何众生中有不护有护。偈曰。人道不护除。二黄门二根。鸠娄。释曰。唯人道有不护。于余道无。于人道中除生成黄门横成黄门二根。及北鸠娄。偈曰。护亦尔。天亦。释曰。护于人道有除。如前所除。于天道亦有护。故二道有护。云何得知黄门等无护。由经及律。经言摩诃那摩。若人在家白衣丈夫。与男根相应。归依佛。归依法归依僧。亦说此言。愿大德忆持。我今是优婆塞。摩诃那摩。唯由此量。此人成优婆塞。于律亦有文。律言如此等相人。汝等必应除。复由何因故。于彼无护。二依止惑过量故。正思简择相续无能故。下品惭羞亦无故。是故无护。若尔何故无不护。于恶中依止不定实故。若是处有护。是处则有不护。二相对治故。北鸠娄人。求受及定心不有故。于恶无欲作故意故。是故无护亦无不护。于恶道云何无护无不护。无极重惭羞故。由与此二相应及坏故。方得护不护。复次彼依止。有如此失。转成瘠田。谓二黄门二根。恶道众生于此依止。护不生。不护亦不生。譬如于碱涩瘠田苗嘉不生秽草亦不生。于经中云何言。比丘有卵生龙。于半月八日。从龙宫出。受八分相应优波婆娑。此行但是善行。于彼无护故。是故唯于人天道有护。复于中偈曰。人具三。释曰。人道中一切三护皆具有。谓波罗提木叉等三护。偈曰。生欲色界天。定护。释曰。若诸天生欲色界。有定生护。于上界则无。偈曰。复无流。除中定无想。天及无色界。释曰。无流护生欲色界天有。除中间定无想天及无色界。若生无色界诸天。由至得有定护及无流护。不由现前有。从此向后。由依分别说业故。如经中略说业。今当广分别说业有三种。谓善恶无记。此中偈曰。平不平异业。善不善异二。释曰。此是善等相。若业平安立为善。若果报可爱。若能令至涅槃。是名平安。暂永二时能救济苦故。若不平安。说名不善。为对治平安故。若业果报。非可爱及能障解脱。异前二业。非平安非非平安故。是故应知。非善非非善。此言何义。以无记为义。复次偈曰。福非福不动。苦受等复三。释曰。复有三业。谓福德业。非福德业。不动业。复有三业。谓有乐受业。有苦受业。有不乐不苦受业。此中偈曰。欲善业福德。释曰。于欲界善业。由能清净故。由能数引可爱报故。说名福德。偈曰。上界善不动。释曰。色界无色界善业。说名不动为不尔耶。佛世尊说。三定有动。于中是觉是观。所余诸行。诸圣说名动。广说如经。约彼定有过失。故说如此。是三定等。于不动经中。约能成不动善缘道。或说名不动。复有何因。此定实有动。有时说为不动。偈曰。由业于自地。约报不可动。释曰。若欲界业。约果报有动义。云何动报。于处无定故。是业已感别道。于余道亦得熟。复有业已感别天聚同分。于余天聚同分亦得熟。何以故。是业能感量力色乐欲尘等。于天上应熟。此业有时。由随别缘。于人畜生鬼神道中熟。若色无色界业。于余地无因缘得熟。由果报于处定故。是故说名不动。非福业者。于世间明了。谓非善若义世间所成。于中何须作功用。分别说福德等业已。有乐受等业今当说。偈曰。乐善至三定。释曰。若业是善。说于乐受好。此业乃至三定。何以故。乐受地但极于此。是故欲界及三定是彼地。过此偈曰。向上善非二。释曰。过第三定向上。一切善业。于不苦不乐好。于中无苦乐果报故。偈曰。于欲界恶业。立名有苦受。释曰。欲界言。为显唯于欲界有。余处定无。此等业不但受为果报。受资粮亦是果报。偈曰。余说下有中。释曰。有师说。是中业能感不苦不乐受。从第四定以上有。于下地亦有。何因知有。偈曰。中间定报故。释曰。若不尔。中间定业应无果报。或于中间定有别类业。于中无苦无乐故。中间定业。于定乐根是其报。余师说如此。复有余师说。此业决无定为报。此执与阿毗达磨藏相违。何以故。于彼藏有如此文。文言。为有如此不。由此业以心法为体受。为此业熟果报不。有。谓无觉善业。偈曰。无前后报熟。由佛说三业。释曰。于经中由说此文。有三业果报熟无前无后不。有。有乐受业色熟为果报。有苦受业心及心法熟为果报。有不苦不乐受业非心相应法熟为果报。是故于下地有不苦不乐业。若离欲界。于余处此三业无一时俱熟。此业为善为非善。是善而体羸弱。若尔前说乐善至三定。复说若果报可爱。若能令至涅槃。是名善。则与此言相违。此说应知从多。此业不以受为性。云何说有乐受等。于乐受等好故。说有乐受等。复次是此业乐必应受。此受受何法。是乐报应受报。乐于此业中有故。复次由此业应受乐报故。说此业有乐受。譬如欲散有苦受业。有不苦不乐受业。应知亦尔。偈曰。自性及相应。境界与果报。或由令现前。受义有五种。释曰。受若约义有五种。一自性受。谓苦乐等。二相应受。谓触。如经言。应受乐触。三境界受。谓六尘。如经言。由眼见色。是人受色不受色欲。如此等。何以故。由受故缘此境界。故说受此境。四果报受。谓业受。如经言。现法受业。生受业。后受业。不定受业。五现前受。谓随与一相应。如经言。是时受乐受。是时中二受皆灭离。何以故。是时乐受生。余受不得生。由彼应受此受。若现前可说能受此受。是故由应受果报。说应受乐业。苦等亦尔。偈曰。此或定不定。释曰。此应受乐受等三业。应知各有定不定。由此不必应受故。偈曰。复定受有三。现等受报故。释曰。定业有三。谓现法应受。生应受。后应受。此三种定业。合不定受业。故成四种

阿毗达磨俱舍释论卷第十一阿毗达磨俱舍释论卷第十二

        婆薮盘豆造

        陈天竺三藏真谛译

    中分别业品之三

偈曰。复有五种业。释曰。复有余师说。业有五种。不定受业分为二。谓于报或定。于报或不定。此中现法应受业者。于此生造业。即于此生熟。生应受业者。于此生造业。于第二生熟。后应受业者。于此生造业。从第二生后熟。有余师说。现法应受业果报。于余生亦有。由随此功力立名故。勿最强力业果报劣薄。毗婆沙师不许此义。何以故。彼说有业果报亲近果报非胜。有业翻此。譬如外种子。葵三月半结实。麦等六月结实。偈曰。余师说四句。释曰譬喻部师。说有四句。有业于位定于报不定。若业现报于报不定。有业于报定于位不定。有业二处皆定。若现报等于报亦定。有业于二处皆不定。若业不必应受。于报亦不定。于彼人此业成八种。现报有二种。定不定乃至定不。定亦尔。彼说现报等为定。第四不定。于一刹那中。得引四业。俱起不得。云何得。于三教他自行邪淫。此四若一时究竟。是四业中。偈曰。引聚同分三。释曰。何以故。此现报业。不能引聚同分。现有同分故。于何界何道中。几种业可引。偈曰。一切处四引。释曰。于三界及一切道中。四种业皆有引义。此四或善或恶。此引如相应。此开今更立遮。偈曰。地狱引善三。释曰。于地狱中三种善业有引。现报无引。于中无可爱报故。偈曰。凡于离欲处。坚不引生报。释曰。凡夫人若于此地已得离欲。若坚住无退失于此下地中。不得造生报业。能造余三。偈曰。圣不造余报。释曰。坚言流至此句。若圣人于此地已得离欲。无复退堕。不能造二业。谓生报及后报。何以故。此人不能更感下地生故。但能造现报业及不定报业。于随现生处。偈曰。欲顶退不造。释曰。若圣人有退堕。已离欲界及有顶。于此二界不得造生报及后报业。何以故。此人已退果。无舍寿义。此义后当广说。于中阴有引业义不。有。偈曰。二十二种业。于欲中阴引。释曰。若欲界中阴。能引二十二种业。此云何。胎位有五。谓柯罗逻。頞浮陀。俾尸。伽诃那。波罗舍佉。已生位有五。谓婴儿童子少壮中老。于此位中中阴众生。有时引柯罗逻受业。或不定或定。乃至老位应受。及中阴中应受。偈曰。此业但现报。释曰。此中阴所引业。定有十一种。应知必是现报。何以故。偈曰。彼是一果报。释曰。此聚同分。唯有一一业所引故。是中阴聚同分。及中阴后类十位。是故不说别业感中阴。由此二同生报业所引故。复有何相应。知此业是定。偈曰。重惑及净心。或是恒所行。于功德田定。能损自父母。释曰。是业由重惑所造。或由重善心所造。或恒时所行。或于有功德田所起。应知此业必定此中有功德田。谓三宝或人差别。人差别者。若人至果胜类。或定胜类。此中若无重惑心。及重善心。此业或善或恶。必成定业。若恒所行亦尔。复次若依自父母。以率尔心造随类违损业。此业亦必定受报。余业则不定。复次现法应受业。其相云何。偈曰。此业成现报。由田意胜异。释曰。现报业者。或由田胜异成。如传说。有一比丘。于大众中行女人言。故现身即转根成女。此传有文。由故意胜异者。如传说。有一黄门。由解脱牛黄门事故。现身即转根成男。复次偈曰。永离欲地故。释曰。若业或善或恶。依此地生。由永离欲。此地此业。则成现报业。此业何相。偈曰。若业于报定。释曰。若业于果报定。于位不定。此业是所说现报业。若业于余位中定。此业定于余位中与报。有此业人无离欲故。若不定云何。此业无报。由永离欲故。此田何相。于中所造业。必定得现报。若总说。大比丘众以佛为现前上首。若约人差别有五。偈曰。灭定无诤慈。见罗汉果起。于彼损益业。果于现法受。释曰。若人出无。心定观。即得最极心寂静。由此定似涅槃故。此人因此定。如往还于涅槃。若人出无诤三摩提。观无量众生。无诤利益。善意所随逐最猛盛。无量福德熏修所变。相续正起。若人出无量慈观。无量众生安乐善意所随逐最猛盛。无量福德薰修所变相续正起。若人出四谛观。见谛所破惑灭尽无余。故新得转依。清净相续即起。若人出阿罗汉果观。修道所破惑灭尽无余。故新得转依。清净相续即起。是故于此五人或作善利益事。或作恶损恼事。此业果报。于现世必定应得。余人所修得道。未究竟故。若出未圆满自性果观。新得转依清净不尔。是故彼不及前人福田。若果报受为胜。是故此义应思。有业但以心受为果报非身受不。有业但以身受为果报非心受不。说有。偈曰。若善业无觉。许受为果报。此受是心法。释曰。无觉业者。从中间定乃至有顶。此无觉善业。唯以心受为果报。云何非身受。此身受必与觉观俱起故。偈曰。若恶唯身受。释曰。若恶业定以身受为果报。云何心受非彼报。此业以苦受为报。若苦受在心地则成忧根。此忧根非果报。于前已说。若尔众生有癫狂。此癫狂于何心有。复由何因生。偈曰。心癫于心心。释曰。心心谓意识。何以故。若人在于五识。则无癫乱事。五识无分别故。偈曰。此从业报生。释曰。此心癫乱。从众生业报生。若人以物咒及增加所作。散坏他心。或不求欲众生。令饮毒饮酒。或恐怖众生。于猎等时。或在矿野等处。纵火焚烧。又以坑阱陷坠众生。或由余业令众生失念。因此业报。此众生于未来世心则癫乱。复有别因。偈曰。怖打不平忧。释曰。怖者。诸鬼神作可畏形相来逼。此人见即惊怖。打者诸鬼神。因人恶行起憎恚心。于此人末摩作打拍事。不平者。风热淡互相违反。令身四大皆不调适。忧者。如婆师絺等。若意识癫乱。此心癫乱。从业报生。云何言心受非果报。我等不说此心是果报。何为四大违损是果报。从此心起故。说心从果报生。由业所生四大不平等。故心狂乱。不自在失念。说此心名癫狂。若作如此四句得成。有心狂故乱。非散故乱。广说应知。狂乱非散乱者。心不自在无染污。散乱非狂乱者。心自在有染污。狂乱亦散乱者。心不自在有染污。无狂乱亦无散乱者。心自在无染污。何众生有狂乱心。偈曰。欲界除鸠娄。释曰。于欲界中有。唯除北鸠娄。何以故。于天中亦有狂天。何况于人畜生鬼神道中。地狱众生皆恒狂乱。是彼众生万种损恼恚害。末摩量重难忍。苦受所逼。于自身亦不了别。何况能识是非等事。何心何啼天地狱传此中应说。于圣人亦有心狂乱。由四大不平等故。除佛世尊。若约先定业。受报已毕。若约不定业则无果报。不由怖畏。已度五怖畏故。不由损害。永无恶行能生鬼神憎恚心故。不由忧恼。证见法如实性故。复次于经中说有三曲。身曲口曲意曲。复有三粗。身粗口粗意粗。复有三涩。身涩口涩意涩。此中次第应知。偈曰。说曲粗涩业。谄曲嗔欲生。释曰。若身业从谄曲生。说名身曲业。邪曲性类故。口意曲业亦尔。若身业从嗔恚生。说名身粗业。忿怒性类故。口意粗业亦尔。若身业从贪欲生说名身涩业。染污性类故。口意涩业亦尔。偈曰。黑白等差别。复说业四种。释曰。有黑业黑果报。有白业白果报。有黑白业黑白果报。有不黑不白业不黑不白果报。生能灭尽余诸业故。偈曰。非善欲色有。善次第应知。黑白有二业。能灭彼无流。释曰。非善业者。一向名黑。本性黑故。果报亦黑。果报非可爱故。此业唯欲界。有色界善业一向白。非黑所杂故。果报亦白。果报可爱故。云何不说无色界业。若是处有二种果报。谓中阴生阴。有三种业。谓身口意。此中说黑白业。余处不说。有余师云。此亦于余经中说。欲界善业名黑白业。非善所杂故。果报亦黑白。果报相杂故。若分别此业。须约相续。不得约性。何以故。无一业如此种类及果报。此业是黑即是白。无如此义。互相违故。若尔恶业为善业所杂故。应成白黑业。恶为善所杂。此义不成。于欲界中恶力强故。唯善可杂。由力弱故。无流业者。若起能灭尽此三。何以故。此业非黑。无染污故。非白。无白果报故。此不白言。是不了义说。有别意故。佛世尊于大空经中。依无学法说。阿难如此法。一向白一向善一向无诃。于阿毗达磨藏中说。何者为白法善法及无覆无记法。无果报者。不堕于界故。与生死相违故。一切无流业为悉能灭白等三业不。不。此云何。偈曰。于法忍离欲。于八次第道。十二种故意。此能灭黑业。释曰。于见谛道中有四法忍。于离欲欲界中有八次第道。于此中是故意有十二种。此业一向能灭黑业。偈曰。于第九故意。能灭黑白业。释曰。于第九离欲。欲界次第道故意。能灭黑白业及黑业。偈曰。白业离欲定。后次第道生。释曰。若人定定作离欲。是第九次第道。此中有四种故意。一向能灭白业。云何但第九次第道。能灭白业。不由余。此善非自性灭。已灭可更现前故。虽然缘彼为境惑灭故。故说彼灭。是故乃至余一品惑。犹以彼为境未灭。未可说彼已灭。偈曰。余说地狱报。及欲受报二。释曰。有余师见。应受地狱报业。离地狱于欲界余道应受报业。次第应知。是黑业是黑白业。何以故。唯地狱定是恶业报故。说受地狱报业名黑业。离地狱于欲界余道中。有善恶业报。是故受彼报业。名黑白业。偈曰。余说见灭黑。释曰。有余师说。见谛所灭业名黑业。与善不相杂故。偈曰。余欲业黑白。释曰。欲界业异见谛所灭业。名黑白业。此异云何。谓修道所灭。何以故。此业有善有恶。于经中说。有三牟那。谓身牟那口牟那意牟那。此中偈曰。无学身口业。意应知次第。三牟那。释曰。无学身口二业。名身口牟那。无学心名意牟那。非意业。何以故。心是真实圣者。此由身口故定可比量。复次此身口二业。离恶为性。意业但思。非有教故。不能比量为离。故说牟那。是故唯心能离故。说名牟那。云何说无学不说余。阿罗汉是真实圣者故。一切或言分别灭故。偈曰。三净。释曰。于经中说。有三种清净。谓身清净。口清净。意清净。此三种清净。偈曰。一切三善行。释曰。一切身善行。名身清净。一切口意善行。名口意清净。能除遮恶行及惑污故。或暂或永。此正说何为。众生信乐邪牟那及邪清净。为令思量远离故。经中复说有三种恶行。偈曰。恶身口意业。说名三恶行。释曰。身口意业若不善。次第应知。名身口意恶行。偈曰。非业贪嗔等。说意恶行三。释曰。亦有恶行非业性。谓三意恶行别类。非故意故。譬喻部说。贪等名意业。于故心作。经中说。若执如此惑业成一性。若尔何有若惑成业。无如此义。于经中由故意因。此门起故。大师由彼显故意。毗婆沙师说如此。若不尔。惑业成一体。十二缘生分。则不成就故。不许如此。由此于果报非可爱。聪慧人所诃故。说身口意行名恶行。偈曰。翻此名善行。释曰。由翻恶行应许为善行。谓善身口意业。及无贪无嗔正见。无利益损恼他事故。云何正见邪见得成。善恶性为损益根本故。是所说恶行及善行。此中偈曰。由摄彼粗品。故说十业道。如理谓善恶。释曰。前所说恶行及善行中。由摄明了易知善恶二业。是故经中说十业道。如理应知。若善从善行出。若恶从恶行出。于中何恶行及善行非所摄。于恶业道中。是身恶行一分非所摄。谓前分后分。所余染污亦尔。此非粗显故。若身恶行。能令他失离寿命财物妻妾。说名业道。欲令他分别离此故。于恶行别立意恶行一分名故意。于善业道中。是身善行一分非所摄。谓前后分。及离饮酒等。布施供养等。口善行如爱语等。意善行如故。意如此业道中。偈曰。六恶有无教。释曰。唯六不善业道。定以无教为性。谓杀盗妾语两舌恶口无义语。若教他作。无根本有教故。偈曰。一二种。释曰。邪淫恒以有教无教为性。何以故。此自身所成就故。若令他作欢喜。不如自作故。偈曰。身作。释曰。是六种业道。若自作亦各二种。谓有教无教。若正起有教时彼即死。则具有教无教。若起有教后方死。但是无教。若善业道。偈曰。七二种唯善。释曰。善有色七业道。必定二种。谓有教无教。受所得戒依属有教故。偈曰。无教从定生。释曰。定所生定无流所摄诸护。说名定生。彼唯无教。但依属心故。偈曰。近方便有教。释曰。业道前方便。必有教为性。偈曰。无教或有无。释曰。若最重上心惑所污惑。蜜味心清净。作方便加行。则有无教。若异此则无。偈曰。后分则翻此。前分三根生。释曰。翻前分方便义。应如是业道后分。何以故。此后分必无教为性。有教或有或无。若人已作业道。后更起同类法。则有有教。异此悉无。复次此业道前分。根本后分。从何位可得安立。譬如有人欲杀禽兽。从床起捉直行往彼所。揣触其身即买牵还。将入屠所欲就杀之。即便捉仗与一下手或再下手。乃至未令命断。名杀前分。是事能令命断。此中是有教无教身业。共一刹那起。是名根本业道。何以故。由二种因缘。是人为杀生罪所触。由作加行及果究竟故。从此刹那后无教刹那。悉是业道后分。乃至治洗贩卖。或煮自食称赞其美。如此等有教刹那。悉成后分。如此于余六业道中。前分根本后分义。如理应知。不平贪等三无前后分。由现前起即成业道。汝今应说此为是众生正在死有有教无教成业道。为已死成业道。若尔何有。若所杀众生正在死有。能杀及令杀人。若共一时死。应有犯杀生罪。悉檀义不尔。若已死成业道。是悉檀所说。谓若由此害事。能令彼离寿命。是有教身业。及共一刹那起无教。是名业道。此言不应说。复次于阿毗达磨藏中说。为有如此义不。是众生已被杀。是人未离杀生事。有。譬如已令此众生离命根。能杀加行未舍未息。此中后分由前分名说。此文句与毗婆沙义相违。是根本此时中未灭故。是故如无失道理。应许如此。云何无失。此中用前分名说根本。此则无失。若尔如此相有教。云何成根本业道。云何不成。无能故。若尔无教云何成业道。是故加行果成就时。此二成业道。业道者。有时是余业道前分。或是余业道后分。是杀生事位。有时成业道。有时成前分。譬如有人欲杀怨家。作恶方术杀禽兽祠鬼神。或由偷他物。或于彼妇作邪淫。共彼人欲杀怨家。或说妄语两舌恶口软语。破彼亲友随多少能为救护者。或于彼起不平贪。或于彼生嗔。或为杀彼增长邪见。如此于余业道。如理应思。贪等不应成前分。何以故。若由唯发起心。是人正行前分。无如此义。若离行事经中说。比丘杀生有三种。一从贪欲生。二从嗔恚生。三从无明生。乃至邪见亦尔。此经中如此杀生相云何。杀从贪生者。若为得彼身分。为得物。为戏乐等事。令他失命。或为救济自身及自眷属。从嗔生者如为报怨。从痴生者。如大祠舍施人。由行善法意故。又如诸王。随法文句量故。行重罚怨家及恶人。诸王得生大福德。又波尸国人杀业亦从痴生。何以故。彼说如此言。若二亲老困。及有重疾。必应为舍命。有频那柯外道说。蛇蜈蚣啮毒等。恒能伤害人。此必应杀鹿羊鸟牛等。为供人庖厨故受生。若杀无失。若杀生从邪见生。亦是从痴生。盗从贪生者。随其所求不与而取。或为得别利养爱重好名。为救济自身及自眷属。从嗔生者。如为报怨。从痴生者。如诸王由随法文句量。为罚恶人故夺其物。又如婆罗门言。一切物梵王已舍与婆罗门。由婆罗门力弱。诸蛮谩取受用。是故若婆罗门夺取夺取自物。若食食自物。若衣衣自物。若施施自物。于彼无非他财想。若盗从邪见生。亦是从痴生。邪淫从贪生者。于他妻妾先起贪爱方行邪淫。及为得利养爱重。为救济自身及自眷属。从嗔生者。如为报怨。从痴生者。如波尸国人娶母等事。又如于瞿娑婆祠中。有余女吸水啮草。是人行着其亲。或着姑姨姊妹同姓等。又如频那柯外道说。女人如臼花果熟食水渚道路等。妄语等从贪嗔生如前。妄语从痴生者。如皮陀言

  戏笑及女人　　娶妇并救命
  救财故妄语　　梵王说无害

若妄语从邪见生。亦是从痴生。两舌等若从邪见生。亦是从痴生。一切从四皮陀所出邪论言。皆是无义语。不平贪等。云何从贪等生。偈曰。从彼次第生。贪等三根生。释曰。从贪次第生故。说彼从贪生。从嗔次第生故。说彼从嗔生。从痴次第生故。说彼从痴生。说恶业道已。善业道云何。偈曰。善业道前后。无贪嗔痴生。释曰。共前分后分。一切善业道。从无贪无嗔无痴生。善故意所生故。此善故意。必定与无贪等三善根相应故。前分等三其相云何。此中若远离恶业道前分。即是善业道前分。若远离根本即是根本。若远离后分即是后分。譬如沙弥欲受大戒。入不共住礼拜比丘。请优波陀诃。乃至说一羯磨。及第二羯磨。此名前分。第三羯磨竟时。是有教业共一刹那无教。是根本业道从此后。乃至说四依。依此根本所有有教业及无教业。乃至相续未断。是名后分。是所说言。非一切业道由贪等究竟。此中何业道。由何恶根得究竟。偈曰。杀生嗔恶口。成就皆由嗔。释曰。杀生嗔恚恶口。必由嗔得究竟。舍心涩心现前。此三得成故。偈曰。邪淫贪欲盗。由贪故究竟。释曰。由贪欲现前故。邪淫贪欲偷盗得成就。偈曰。邪见由无明。释曰。若人起最重品痴。能成就邪见。偈曰。许所余由三。释曰。何者为余。谓妄语两舌无义语。此三由三恶根。随一成就。或由贪或由嗔或由痴。是业道约四节所说。谓三三一三。如此次第应知。偈曰。众生受用依。名色及名聚。释曰。杀等依止众生起。邪淫等依止受用物起。邪见依止名色起。妄语等依止名聚起。若人起定心。为杀彼人。或与彼同时死。或在彼前死。为有根本业道不。偈曰。俱死及前死。无根。释曰。是故显此问。若人行杀生事。果亦究竟。不犯杀生罪。有如此义不有。若能杀人。或在前死。或同时死。若尔何因所杀人犹活未死。杀者与杀生罪不相应。若杀者同时死亦不相应。云何不相应。偈曰。别依生。释曰。由此依止。于彼行杀事。此依止已断灭。有别依止生。异先聚同分。此依止不行杀事故。是故无与业道相应义。复次若为杀他故。集众为军。或掘坑或猎或偷破。多人聚集同为此事。于中一人若行杀生事。何人得杀生罪。偈曰。军等同事故。悉得如作者。释曰。如作者犯罪。如此一切人同犯一罪。共一事故。若由义此彼更互相杀。若人由他势力所逼引令入中。是人亦与此罪相应。若人依此誓去。谓随有命为救自命。我亦不杀。唯除此人。若人自作杀生事。此行几量成业道。乃至邪见。成业道此相应说。偈曰。杀生有故意。他想不乱杀。释曰。若人有故意。我必应杀彼。于彼有彼想。唯杀彼不漫杀余。由此三义杀生成业道。若尔有人。心疑不决而杀生。谓此为是众生。为非众生。为是彼为非彼。此人于杀已决方杀。谓若是若非我必须杀。此人已作舍心。若杀生得杀生罪。于刹那刹那灭五阴中。云何断波罗那。此名有何义。以风为义。此风依身依心起。若人断此风。譬如风灭灯光手灭铃声。断此风亦尔。是名断波罗那。或以命根为义。是一刹那命根。正欲生。若遮碍此。即犯杀生罪。异此不犯。此命属何人。由命断彼死。说此命属彼人。何物为彼。此义于破说我中当共思量。佛世尊说

  命根暖及识　　若三弃舍身
  彼舍即永眠　　如枯木无觉

是故有命根身名活。无命根身名死。尼乾陀子说。若不以知为先杀生。杀者亦得罪。譬如不以知为先触火亦被烧。于彼若遇见他妇及触。此义亦应然。拔尼乾陀子发。教彼修苦行。彼腹胀死。施主应得罪。母及胎互为困苦因故。犯罪人由与杀事相应故。如火烧自依。若人教他杀。不应得罪。譬如教他触火。由教故自不被烧。无意土木等亦应得罪。如屋倒杀生故。又于犯死罪理。不应但由立譬得成。说杀生罪已。偈曰。偷盗于他物。力闇取属己。释曰。不乱言流。若人由强力。或由闇窃取他财物属己。于他物中若有取意。由力由暗除乱取。因此量成盗业道。若盗薮抖波物。从佛得罪。何以故。一切供养物。于般涅槃时。佛世尊悉已受。有余师说。若人能护此物。从此人得罪。若掘窖得无主物。从国主得罪。若人偷回转物。若已作羯磨。从至不共住人得罪。若未作羯磨。从一切佛弟子得罪。偈曰。行非行邪淫。说此有四种。释曰。四种行不应行名邪淫。一行不应行。谓他所摄。若母女父母亲。二行不应行。谓非分。若自妇于下道及口。三行不应行。谓非处。若露处。支提处。修梵行处。四行不应行。谓非时。若自妇有胎时。饮儿时。受护时。若由夫听许故得护。此为非时。余部说如此。不乱言流。若往他妇所。作自妇想。不成业道。若作他妇想。往余他妇所。余师说。由行于他妇及受用此类故成业道别。处欲作。于别处行故。无业道罪。譬如杀生。余师说如此。若于比丘尼行此事。从何处得罪。从国主得罪。何以故。此事非国主所忍许故。若自妇有戒。尚不可行。何况比丘尼。若于童女行此事。于父母所许人得罪。若未许人。于守护人得罪。乃至于王得罪。偈曰。别想说此言。于解义妄语。释曰。是其所说义。于此义中。起别异想说言。所依人若解此言义。此言成妄语。若所依人不解此言义。此言云何。此言则成无义语。所说言者。有时多文字成语。于此语中何字成业道。最后字共无教成业道。或随处。彼人已解义。前文字但是前分加行。说解义者。为得闻已解义为得闻能解义。若尔何有。若已解义。语义是意识境界故言语与耳识俱灭故。应但以无教为业道。若能解义则无此失。云何成能解。解语人在于耳识。此人为能解。如执无失可许。如此于经中说。言说有十六种。不见说见。乃至不知说知。见说不见。乃至知说不知。此八非圣言说。不见说不见。乃至不知说不知。已见说见。乃至已知说知。此八是圣言说。此中见闻觉知相云何。偈曰。眼耳及意识所证并余三。此名见闻知。次第或说觉。释曰。若眼识所证为见。耳识所证为闻。意识所证为知。鼻舌身识所证为觉。何以故。香味触本性无记故。譬如死尸。是故缘彼识说为觉。毗婆沙师说如此。此中以何为证。有二种证。谓阿含及道理。阿含云。摩罗枳母。汝意云何。是色非汝眼昔所曾见。非今正所见。非汝作心。我当应见。汝为因此色得起欲起爱起喜起着起结起贪不。不尔。婆檀多。是声非汝耳昔所曾闻。乃至是法非汝意昔所曾知。广说乃至。不尔。婆檀多。摩罗枳母。汝意云何。为于此中于见唯有见生。于闻唯有闻生。于觉唯有觉生。于知唯有知生。于经中说如此。既于三尘说见闻知。故知于余三尘同立觉名。若不许如此。此三在见等三外故。于香等应无言说。是名道理。此经非证。有别义故。何以故。于此经中非佛世尊欲判四言说相故。说此言说何为。佛言摩罗枳母。于六境界中。及于见等四种言说中。为但见等言说起。为更增足爱不爱等因。于此说中见经义如此。若尔何相为见。乃至何相为知。有余师说。五根所证为见。从他传得为闻。是时所筹量。自意所许为觉。自心所证为知。是五尘随一所见故。因此义立见言说。若事非自所证。但从他传得说此名闻。若事约五尘。由自思量所立。自所许故。说此名觉。第六尘异五故。但意识所证。说此名知。是故于香等无无言说。是故汝所立道理。不成道理。先旧诸师说如此。眼根所证说名见。从他传得说名闻。是自所思说名觉。对自身所受所得说名知。勿广论此。更释此论。若人由身显义异。为有妄语不。有。是故阿毗达磨藏说。为有不由身行杀生事犯杀生罪不。有。若由言行。为有不由言行妄语事犯妄语罪不。有。若由身行。为有不由身口行此事犯杀生妄语罪不。有。如由仙人心忿责。此中引布萨譬为证。若由身口不行。无欲界无教不以有教为先故。云何此无教成业道。汝今于中应作功用。说妄语已。偈曰。破语有染心。所说坏他爱。释曰。解义言无乱言流。若有染污心。为坏他和合及相喜爱。是名破语。偈曰。恶语非他爱。释曰。有染污心。解义不乱。此三言流。此三何义。若人有染污心。于解义人。是所欲说处。是所欲说语。即说是名恶语。偈曰。诸染非应语。释曰。一切染污言。与义不相应故。名非应语。亦名散语。于义不相摄故。偈曰。余说异三染。释曰。有余师说。从妄语等口业。若有染污口业。异彼是名非应语。偈曰。佞悲歌舞曲。邪论。释曰。譬如邪命比丘。为得利养作谄佞言。复有人为别离忧所逼作悲思言。复有人由欲染心故歌。复有舞儿。于舞时为染污他作诸词曲。复有人执邪论。起见弘说此论乃至俗话等言。异妄语等三。所有染污言。皆名非应语。转轮王时有歌。云何非非应语。是时彼人所歌。一切与出离义相应。不与邪味相应。是时有求妇迎妇等语。虽是非应语而非业道。余师说如此。偈曰。贪欲者。他财不平欲。释曰。于他财物非道理非平等求得。为属自己作是意愿。如此等物皆悉属我。或由力或由闇。此贪欲名业道。有余师说。一切欲界爱欲。皆是贪欲业道。何以故。于五盖经。依爱欲有如此言。此人舍于世间贪欲盖。若一切爱皆是贪欲。非一切悉是业道。由摄重品恶故。勿一切转轮王及北鸠娄人有贪欲业道。余师说如此。偈曰。嗔恚舍众生。释曰。缘众生过失。起害舍心。于损伤他事中。心强疾故成业道。偈曰。于善恶无见。邪见。释曰。于善恶二业拨云无业。是名邪见。如经言。无施无供养无嗅多无善行无恶行。于世间无沙门婆罗门是阿罗汉。此邪见具足。谓拨业拨果拨圣人。于经中有多种文句。此偈但显重。是十业道体相。如此业道是何义。偈曰。此后三。唯道七业道。释曰。贪欲等三是业家道。故说业道。发起故意依彼起故。前七亦业亦道。能显本意故。是彼种类故。是故名业。业道如前。无贪等及离杀生等。应知亦如此。前后二分云何非业道。由彼生为成此及依止。此为根本故。如粗摄为业道故。此如前说。复次由彼增减。于世间一切内外物。胜劣显现故。立彼为业道。若尔譬喻部师执但贪爱等是意业。此三于彼云何成业道。汝应问彼师。此亦可答。彼是业亦是恶趣道故。彼名业道。复次更互相乘故。皆名业道。是所说十恶业道。此一切与善法行相违故。故说名恶。偈曰。断根由邪见。释曰。于十恶中由何恶断善根。由最上上品圆满邪见。若尔于阿毗达磨藏中云何说言。何者最上上品恶根。是彼能断灭善根。若人正至离欲欲界位。最初所除。由邪见为恶根所引起故。于恶根中立邪见事。譬如火能烧国土。劫能引火令起故。说国土为劫所烧。何者是所灭善根。偈曰。欲界生得善。释曰。唯欲界中善根被断。与色无色界善根不相应故。若尔假名分别论云何。将彼论云。唯由此量。是人已断三界善根。上界善根至得。依最远相离义故说此言。由令相续非彼器故。唯生得善根被断灭。是一切加行得善已退失故。此邪见能断善根。缘何境界。偈曰。谓拨无因果。释曰。此邪见若能拨因。谓无善恶行。若拨果谓无善恶行业所有果报。此二邪见。似次第道及解脱道。余部师说。如此缘有流为境。不缘无流。缘同分界不缘非同分界。唯由相应随眠故。故彼力弱。偈曰。一切次。释曰。诸师分别说。如此一切邪见。九品善根一时能断。譬如见谛灭惑。复有余师说。次第断。由九品邪见。九品善根被断。譬如修道灭惑。乃至最上上品邪见。断最下下品善根。若执如此。毗婆沙伽兰他。则被守护。伽兰他言。何者善根最细恒随。是断善根人。最后所断。由彼断灭。此人得断善根名。若尔此伽兰他义云何。将伽兰他言。何者最上上品恶根。若是恶根能除灭善根。名最上上品。约圆满事故说此言。何以故。由此灭无余故。无一品类在不被断。为彼作生因。如见谛道中间不出观。断善根亦尔。复有余师说。此事有二种。复有余师说。先断除护类善根。后断自性善根。复有余师说。若护是心果。由舍此心。护亦被舍。于何处善根可断灭。偈曰。人道。释曰。于人道中。非恶道有。染无染智不坚牢故。于天道证见业果报故。于三洲非北鸠娄。彼本来无恶意故。余师说。唯剡浮洲人。若执如此。与伽兰他相违。伽兰他云。剡浮洲人。若与最少根相应。唯与八根相应。东毗提诃西瞿耶尼亦尔。此善根偈曰。能断唯男女。释曰。若断善根。唯男女能断。余师说。智根精进根昧钝故。女人不断。若尔此执与伽兰他则相违。伽兰他云。若人与女根相应。此人必定与八根相应。于男女中贪爱行。不能断善根。意地动弱故。若尔何行人能断。偈曰。见行。释曰。此人恶意甚深坚牢故。是故黄门等不能断。是贪爱行部类故。犹如恶道。此断善根体相云何。偈曰。此非得。释曰。是时善根至得断不更生。非至得生。于非至得生时。说善根已断。此善根已断。云何更相续。偈曰。接善疑有见。释曰。此人于因果中若生疑心。或生有见。此名正见。是时正见至得更起故。说接善根昔时九品已断。今一时相接。由次第现前。譬如得无病及力。是彼人接善根。偈曰。今非作无间。释曰。余断善根人。于今生有接善根义。若作无间业人。今生无接善根义。依此人故经中说。此人不应今生得接善根。此人或从地狱。正退正生。是时应接善根。正生谓住中阴。正退谓将死。此中若由因力断善根。是退时接善根。若由缘力断善根。是正生时接善根。由自力由他力亦尔。复次若人由自意坏断善根。此人于现世得接善根。若人由自意坏。及他教坏断善根。此人于舍身后得接善根。若人由见坏。由见戒坏亦尔。有断善根不堕邪定聚。此义有四句。第一句者。如富楼那等。第二句者。如未生怨王等。第三句者。如提婆达多等。第四句者。除前三句

阿毗达磨俱舍释论卷第十二阿毗达磨俱舍释论卷第十三

        婆薮盘豆造

        陈天竺三藏真谛译

    中分别业品之四

由分别安立业道。此中是义应说。几种业道故意。与彼相应俱起。偈曰。故意俱乃至。与八恶业道。释曰。有时故意。与一恶业道俱起。离余业道。若贪欲等起现前。若人无染污心。由先教他作有色业道。随一成就时。与二俱起者。若人起嗔恚心杀生时。或贪欲所染心行。盗及邪淫时。或说非应语。与三俱起者。若人起嗔恚心。于他众生俱时杀盗。若尔是时偷盗不由贪欲成就。若人心不异成就业道时。应知前决义。若人贪欲等所染。由教他有色二业道成就时。如此等与三与四俱起者。若人有欲破他和合意。说妄语恶语。此中意业道随一。口业道有三。有时贪欲等所染。由教他别三成就时。余五六七应知。合如此义。与八俱起者。于六教他。自行邪淫。若彼共一时俱成。由恶业道义极于此偈曰。若善乃至十。释曰。若论故意与善业道相应不相应。乃至得与十业道相应。已作如此通说。为简择此故。更作别说。偈曰。不共一八五。释曰。故意无与一八五业道相应义。此中与二相应者。于善五识起时。入无色定时。尽智无生智起时。与三相应者。与正见相应意识起时。与四相应者。恶心无记心起时。正受优婆塞护及沙弥护。与六相应者。善五识起时。受前二护。与七相应者。善意识起时。受前二护。或恶心或无记心起时。受比丘护。与九相应者。善五识起时。受比丘护。若意识与尽智无生智相应。是尽智无生智相应心。与定相应。与十相应者。异此于余处善意识起时。受比丘护。一切定护无流护相应故意。离尽智无生智。若与非护所摄。亦得与一相应。若人异心受一远离分。亦得与五八相应。若人善意识起时。一时受二远离分。或受五远离分。复于何道几业道。或恶或善。由现前及至得俱起。偈曰。非应语恶语。嗔于地狱二。释曰。是三种业道。于地狱由二种义有。一由现前有。二由至得有。由悲泣有非应语。由互相骂有恶语。由相续恼互相憎故有嗔恚。偈曰。由至得贪欲。邪见。释曰。若由至得有贪爱邪见。不由现前有。无可爱尘故。证知业果故。由业尽死故无杀生。不摄财及妇故无偷盗邪淫。无用故无妄语。恒自无和合故无破语。偈曰。北洲三。释曰。由至得言流。贪欲嗔恚邪见。不由现前有。无我所无摄故。相续软滑故。嗔恚类境无故。无恶意故。偈曰。第七彼自有。释曰。非应语于彼现前有。何以故。彼人有时起染污心歌。无恶意故。无杀生等。寿命定故。不摄财及妇故。无用故。彼人云何作非梵行。彼人若欲共此女人和合戏。即执彼手俱往树下。此女若堪行。树即密覆。便与交通。若不堪行树则不覆。即相背去。偈曰。于余欲十恶。释曰。自有言流。除地狱及北洲。于余处十种恶业道。由现前亦有。于畜生鬼神天道中。有非不护业道。于人道中。不护所摄业道亦有。若天不能杀余天。能杀余道众生。诸天若斩首斩腰。即便舍命。说恶业道已。偈曰。后三一切有。现前至得故。释曰。于五道及三界。一切处无贪无嗔正见。由现前及至得皆有。偈曰。无色无想天。由至得七。释曰。身口七善业道。于无色界及无想天中。但由至得有。圣人已生无色界。与过去未来无流护至得相应故。无想天与定护至得相应。随所依止地。圣人所生及所舍无流护。若生无色界。与此过去护相应。与依五地未来护亦相应。偈曰。余。由现前亦有。除地狱北洲。释曰。余者谓别界别道。于余界余道中。是七种善业道。由现前亦有。除地狱及北洲。是余者谓畜生鬼神。于中唯有非护。于色界但护所摄。于余处具有二种。复次是十种恶业道。及善业道。偈曰。一切皆能与。增上流报果。释曰。今且论恶。由一切十恶所事修习数起故。生于地狱。是名果报果。若受地狱报竟。得如此类。谓人道等聚同分。由断命故。寿命短促。由偷盗故。有财物障难。由邪淫故多怨憎。于妻妾有障碍。由妄语故。多被诽谤。由破语故。亲友不和穆。由恶语故。恒闻不可爱声。由非应语故。有理实言人不信受。由贪欲故多重贪欲。由嗔恚故多重嗔恚。由邪见故。闇钝多痴。此见多无明故。是名十恶等流果。于人道中寿命若短促。亦是善业果。此云何是杀生等流果。不说人寿命是等流果。何者由恶业令寿命减少。杀生是人道寿命障碍因。此义应知。增上果者。由杀生所事修习数起。一切外资生具无复势味。由偷盗故。多霹雳多尘。由邪淫故多尘垢。由妄语故多臭秽。由破语故。外器有高深。由恶语故其地恶味。高燥相违不宜一切。由非应语故。时节不调适。四大变异不平等。由贪欲故。一切所种果实少弱。由嗔恚故。一切所生皆悉莶苦。由邪见故。一切资生或少果或无果。是名十恶增上果。为由此业今生寿命短促。为由别业。有余师说即是此业。何以故。昔时此业果报果已。成今时是其等流果。有余师说。昔时由前分。今时由根本。由执共伴类故是所说。杀生等等流果者。非等流种类。由相似差别故说如此。复次云何十业道。有三种果生。若人作杀生事。生被杀者苦故。断彼命故。除彼势味故。是故彼偈曰。由困苦除命。灭势味果三。释曰。由困苦他故。有果报果故。于地狱受害困苦。由行杀故。故有等流果。今生可爱寿命短促。由减他势味故。有增上果。外草药等势味或无或弱。所余业道三果。应知亦尔。善业道三果。应知亦如此。佛世尊所说。有邪语邪业邪命。有何邪命。异于此二。无异此二。偈曰。贪生身口业。别立为邪命。释曰。若于众生从嗔痴生身口二业。名邪语邪业。异此二别立为邪命。偈曰。难治。释曰。贪欲法通引众生。是故从彼所生业。中心难可禁护。是故正命不易可治。于中为生他殷重心故。今此二立为第三。此中说偈

  在家见难治　　恒执种种见
  比丘命难治　　资生属他故

偈曰。资贪生。若执。释曰。若有人执命资粮。贪欲所生身口二业。名邪命非余。何以故。为自身游戏于舞歌等。不立为命资粮。偈曰。非经故。释曰。是义不然。何以故。由经言。于戒聚经中。看象斗等事。佛世尊安立于邪命中。何以故。由邪受用尘故。此义已竟。先于前所说五种果。于中何业由几果有果。偈曰。于灭道有垢。业有果由五。释曰。为得灭故修此道。复由此道故惑灭故。说名灭道。谓次第道。此道若有流。于中所有业。有五种果为果。何以故。此业于自地中所得可爱果。是名果报果。后时或等或胜相似法。是等流果。相离果者。谓择灭心离诸结。功力果者。是道所引生诸法。谓解脱道及俱起诸法。未来应得余法。及此择灭。增上果者。离自性所余有为法。除前生。偈曰。于无垢由四。释曰。于无流灭道中业。由四果有果。除果报果。偈曰。有流余善恶。释曰。若善有流业。异于灭道及恶业。此二由四果有果。除相离果。偈曰。所余无流业。由三无记尔。释曰。所有无流业。若异灭道及无记业。由三果有果。除果报果及相离果。偈曰。四二及余三。善业善等果。释曰。此义应知次第。后当说之。有时善业以善法为果则有四果。除果报果。若以恶法为果则有二果。谓功力果增上果。若以无记法为果则有三果。除等流果及相离果。偈曰。若恶善等二。三四如次第。释曰。此义应知次第。若恶业以善法为果则有二果。谓功力果增上果。若以恶法为果则有三果。除果报果及相离果。若以无记法为果则有四果。除相离果等流果。云何。谓无记身见边见。是见苦谛所灭。不善遍行惑等流果。偈曰。无记有二三。三复于善等。释曰若无记业以善法为果则有二果。谓功力果及增上果。若以恶法为果则有三果。除果报果及相离果。云何如此。见苦谛所灭不善惑。是无记二见等流果。若以无记法为果则有三果。偈曰。过去一切四。释曰。一切谓三世法。此法若为过去业果。各有四果除相离果。偈曰。中业来果尔。释曰。若现世业。以未来法为。果则有四果。如前。偈曰中。果二。释曰若现世法为现世业果。但有二果。谓功力果及增上果。偈曰。来业。未来果有三。释曰。若未来业以未来法为果则有三果。除等流果及相离果。偈曰。同地法有四。释曰。除相离果。所余皆有。偈曰。三二若异地。释曰。异地业若无流则有三果。除果报果及相离果。由不堕界故。若有流则有二果。谓功力果及增上果。偈曰。有学三学等。释曰。若有学业以有学法为果则有三果。除果报果及相离果。若以无学法为果亦尔。若以非学非非学法为果则有三果。除果报果及等流果。偈曰。无学业学等。诸法但一果。或三果及二。释曰。若无学业以有学法为果则有一果。谓增上果。若以无学法为果则有三果。除果报果及相离果。若以非学非非学法为果则有二果。谓功力果及增上果。偈曰。异此二学等。二二及五果。释曰。异学无学业。谓非学非无学业。若以有学法为果则有二果。谓功力果及增上果。以无学法为果亦尔。若以非学非无学法为果则有五果。偈曰。三四果及一。见灭业彼等。释曰。若见谛所灭业。以见谛所灭法为果则有三果。除果报果及相离果。若以修道所灭法为果则有四果。除相离果。若以非所减法为果则有一果。谓增上果。偈曰。二果四及三。修道所灭业。释曰。若修道所灭业。以见谛所灭法为果则有二果。谓功力果及增上果。若以修道所灭法为果则有四果。除相离果。若以非所灭法为果则有三果。除果报果及等流果。偈曰。非灭业彼一。二四果次第。释曰。非所灭业。若以见谛所灭法为果则有一果。谓增上果。若以修道所灭法为果则有二果。谓功力果及增上果。若以非所灭法为果则有四果。除果报果。更说次第言者。应知于前中后。为显因果重说诸义。由分别业相应义故。此业体相亦应问。于阿毗达磨藏中。说有三业。谓非理作。如理作。非理非非理作。此业其相云何。偈曰。非理作有染。余说非方次。释曰。若业有染污。说名非理作。从不正思生故。余师说如此。或有师说。失方便次第名非理作。若人应如此行。应如此住。应如此啖食。应如此着衣。如此等事若作不如。此名非理作。此业由非应理所造故。悉名非理作。一切善业名如理作。及不失方便次第。亦名如理作。异此二名非理非非理作业。为一业引一生。为一业引多生。复次为多业引一生。为一业引一生。若约此悉檀应说如此。偈曰。一业引一生。释曰。但一生唯一业能引。不能引多生。生者是聚同分名。若得彼说名生。若尔大德阿尼娄驮。云何说言。我今由昔时所施一食果报故。七反生三十三天。七反作转轮王已。乃至今犹于大富释迦家生。由此业果报得大富果。及得忆持宿住事。更生别业。欲显功能故说此言。譬如有人由一金钱作功力得千金钱。方说此言。我今由一金钱故得大富。复说此人。以此时施食为依止。诸故意相续最长大起。于中有诸故意。能引摄果报。不得多业感一生。勿分分所引聚同分。成此聚同分。由一业所引许余业。偈曰。多业能圆满。释曰。譬如画师由一色画人形貌。以多色圆满。何以故。于世间中有众生。同人聚同分。有具足根身及。身分色形貌量力端正等相圆满故。于人聚中最分明可爱。有余人于中不具分。不但唯业能引生。何为所余有果报法。若一切种。偈曰。二定非能引。无心及至得。释曰。二无心定亦有果报。不能引聚同分。与业不俱起故。至得亦尔。与业不同果故。佛世尊说。障有三种。谓业障烦恼障果报障此三障体性云何。偈曰。无间等重业。染住惑恶道。北洲无想天。说此名三障。释曰。有五无间业等。是名业障谓杀母杀父。杀阿罗汉。破僧和合。于如来身有害意出血。是名业障。染住惑名烦恼障。惑有二种。一染住。谓恒行。二强利。谓重品。此中染住惑名烦恼障。譬如黄门等。惑强利惑非障。何以故。若惑由重品故强利此惑有时起不恒故。有时可灭。非轻品惑恒起。何以故。若惑恒起为灭。此不得人功时。此惑依轻品成中品。依中品成上品故。此惑是正障。三种恶道名果报障。善道一分亦尔。谓北洲人及无想天。此三障障何法。能障圣道及障圣道加行善根。复有余业于恶道等报定。谓于卵生湿生。生女人身。生第八有中定。亦应说为业障。若业由五种因可了可说。立此业为障。何者为五。一由依。二由果。三由道。四由生。五由人。故但说五。于中惑障最粗。业障次粗。何以故。由此二于第二生。是人不可治。毗婆沙师说。后后能乘故。故次第说。无间者何义。于生果报中。无别业及别生果能遮碍。复次作此业人。若舍寿命无间生地狱果无法能碍。是人由与此法相应。于生地狱中无间故。说为无间。譬如沙门。复次此三种障。应知于何道中有。若决定者。偈曰。于三洲无间。释曰。于北洲及余道皆无。何况余界。于人道中男女二人能作此业。偈曰。黄门等不许。释曰。何因是彼无。护因即是此因。复有别因。偈曰。少恩少惭羞。释曰。次第父母于某。某于父母。父母于某恩少。由不具身分为增上故。爱念少故。某于父母不起重品惭羞。由破此惭羞。为无间罪所触。由此因故。畜生鬼神道中。不许有无间业。大德说。若智慧明了。有五无间。譬如聪慧马故。若人杀非人父母。无无间业。说业障已。偈曰。余障于五道。释曰。何者为余。谓惑障果报障。果报障者。于人道中北洲人。于天道中无想天。此无间业体性云何。四身业为体。一口业为体。三杀生为性。一妄语为性。一杀生前分为性。诸佛如来不可杀害为法。于因立果名故。说僧和合破为无间业。僧由此因破故因得破名。此破其义云何。偈曰。僧破非和合。性非相应法。无染无记法。释曰。和合者。谓与心不相应行无覆无记。僧破亦尔。此云何成无间业。能破人与此不相应何为偈曰。众与此相应。释曰。何以故。是破属所破不属能破。若尔能破。与何法相应。偈曰。依此妄语罪。能破与相应。释曰。能破人与破僧和合罪相应。此罪谓妄语。复次此妄语。与僧和合破俱起有教无教。能破与此罪相应。偈曰。毗指一劫熟。释曰。一别劫果报。于阿毗指大地狱熟。所余无间业不决定。于阿毗指大地狱熟。若人作多无间业。此多业悉无间熟。由此业是人何所得。偈曰。如增苦受增。释曰。此人由多无间业熟。于阿毗指地狱。得最大最厚柔软依止。是苦恼事最多种最难忍。起由此二因。所受苦受。二三四五分增。何人能破僧和合。偈曰。比丘见好行。破。释曰。在家不能破比丘。尼等亦不能破。是比丘多见行。非贪爱行。住于正行。由行不可诃。邪行不能破。何以故。此人教不可信受故。何处得破。偈曰。余处。释曰。若世尊在此处。异此处故得破。不得亲对世尊。诸佛如来不可轻逼故。言教最可信受故。若破何人。偈曰。凡夫。释曰。但破凡夫僧和合不能破圣人。自证见正理法故。是凡夫未得忍前。余师说如此。由几量僧得破。偈曰。别师道忍时。已破。释曰。是时彼僧忍受别师异如来。及信受别道。异如来所说正道。由此量应说僧已破。破已几时得住。此夜。偈曰。不宿住。释曰。大众已破。不度此夜。必定更和合。是所说破僧和合。偈曰。说此名破轮。释曰。何以故。是时佛世尊法轮已破。能障碍圣道生起故。故名轮破。或说僧破。此轮破何处得成。偈曰剡浮洲。释曰。但于剡浮洲破。余处则无。由几人得破。偈曰。九等。释曰。定取九为破。过此无定。八比丘是名僧第九为能破。何以故。僧必定应于二聚二助中住。若尔得破别有僧破。从羯磨破成。若于一别住不和合作羯磨。是名羯磨破。此破偈曰。三洲有破业。释曰。于三洲等若有如来正教。此由几比丘成。偈曰。此由八及余。释曰。此中但作羯磨。不立十四破类法故。以八为定。是破轮于六时不得成。偈曰。初后頞浮前。双前师灭时。未结别住时。破轮不得成。释曰。初者转法轮未久。后者世尊将般涅槃时。此二时中大众恭敬修。同一味故无破。于中间在頞浮陀前僧不破。于正法中。乃至戒頞浮陀见頞浮陀未起时。于双前亦不破。乃至二弟子奢摩他毗钵舍那双未起时。由已破不经宿故。由二更和合故。若大师已般涅槃时。无相对立故无破。乃至未结别住时亦无破。何以故。若共一别住安立二助。则名僧破。于此六时破轮不成。非一切佛皆有此破轮。此事依业成故。云何杀母等事中有无间业。于余处无。偈曰。有恩功德田。由舍离除故。释曰。于杀父母中。由舍有恩人。云何彼有恩。是自身生本故。云何舍彼。谓除彼命根。功德田者。谓阿罗汉。阿罗汉身是三界惑择灭。及戒等阴器故。故名功德田。由除此身故成无间业。若父母转根。于此一依止中。偈曰。别根障亦有。释曰。是故经中说云。为有如此不令男人离命根。非父非阿罗汉。而为无间罪所触不。有。若母转根。令女人离命根。非母非阿罗汉。而为无间罪所触不有。若父转根。有女人柯罗逻堕。有别女人。即取安置产门中。此人以何女为母。若杀于何女成无间业。偈曰。从血生是母。释曰。若从此女人血成此人身。此女是其生母。于第二女人。一切事中皆应问听。何以故。此女能饮此儿。及能长养教训是非。若人于母行杀害方便。误杀余人。无无间业。不于自母行杀害方便。误杀自母。亦无无间业。因子欲杀方便母隐床中。父走余处故死。此人成无间业。若人行一害事。杀母及杀余人。二无教业并起。有教唯无间业。由此无间业力强故。大德瞿沙说。邻虚所成故。有教亦有二种。若不想是阿罗汉。杀阿罗汉。有无间业。谓我今必杀。于此依止意决定故。若人杀父。父是阿罗汉。此人但得一无间业。由依止一故。若尔此阿婆陀那经云何。将经云。汝去语始看持。汝今造二无间业。由汝令父离命根。亦令阿罗汉离命根。显此无间业由二因缘所成。故说此言。复次由此二门诃责彼人。故说此言。为决定于如来边起恶心出血故。有无间业为不。若由杀意故有无间业。偈曰。于佛打意无。释曰。若人唯有打故意出佛血。则无无间业。若人于非阿罗汉行杀害事。害后成阿罗汉。得无间业不。偈曰。害后无学无。释曰。于此人无无间业。何以故。此杀方便不于阿罗汉起故。若人已作无间方便。未转方便时。为先得离欲及圣果不。偈曰。行无间前人。无离欲及果。释曰。若人作无间业。方便必定应成。是方便时中。无离欲及得圣果。若不定则不如。若人于余业道。作前方便道生时。得离欲及圣果。后业道不生。何以故。是今依止与彼业一向相违故。于五无间中何无间业罪最重。偈曰。破僧和妄语。许最大重罪。释曰。了别法非法人。妄语是僧和合破。因显翻倒理故。于一切邪行是最大重罪。何以故。能害诸如来法身故。能障碍世间天道及涅槃道故。何以故。大众正破时。世间入正定聚证果。离欲流尽等悉皆被遮。修定读诵一切正思事并不得起。一切世间及人天。皆纷扰生忧恼乱心。此事乃至僧未更和合。复次由此业报。于阿毗指地狱熟具满一劫。故言大重。所余无间业次第应知。第五第三第一为重。一切中第二最轻。若尔佛世尊说。于三种治罚中。意治罚最重。复说。一切罪中邪见最胜。于无间业中定判破僧为最重罪。此言云何。若约无间一劫果报。无胜破僧妄语。若决判三业。意治罚最重。余治罚随此故。若决判诸见邪见最重。非拨彼境界故。复次依大果报。依杀害多众生。依断除善根。故说此言。次第应知。于善行中何善行果报最大。偈曰。世有顶故意善中最大果。释曰。于善业中非想非非想故意果报最大。何以故。于八万大劫微妙寂静。是其果报故。此言约果报果说。若约相离果。金刚三摩提故意。于一切中为最大果。一切结灭尽为果故。是故说于世间为由无间业于地狱得无间生。为亦由无间同类。由二种。有余师说。唯由无间业必定得无间生。由同类不定。何者为无间同类。偈曰。污母阿罗汉。杀定地菩萨。及有学圣人。夺僧和合缘。是无间同类。五破佛支提。释曰。如此五业与五无间业。应知次第同类。若人污坏自母阿罗汉。由行非梵行故。若人杀至住定地菩萨。若杀有学圣人。若夺大众和合因缘。若起佛支提想。破佛薮斗波。此业说名无间同类。有余业若有果报。于三时中最急起障。何者三时。偈曰。忍那含罗汉。位中业起障。释曰。若人从顶思想忍。是时一切引恶道果报业。悉起为障。由应过彼果报地故。譬如有人应舍离自国土。一切债主皆起诸业亦尔。若人应至阿那含果。一切欲界杂业。悉起为障。唯除现报业。若人应至阿罗汉果。一切色界无色界业。悉起为障。于前已说。若人杀定地菩萨。偈曰。菩萨从何位。释曰。取何位应说此是菩萨。偈曰。从作相业时。释曰。从修行能感三十二相八十随相果报业时。何以故。此人于此时中。已入菩萨正定位。云何如此。此人从此时。向后恒尔。偈曰。善道贵家具。男忆宿不退。释曰。善道者。最胜可赞故名善道。由生于人天道中故。复于善道中。生刹帝利种姓。婆罗门种姓。大长者种姓。于中生摩诃婆罗家。此人已生贵家。有贵家人具根。有不具根。此根有二种。谓色根法根。若不具此。是从明向闇。若具此。是从明向明。恒得丈夫身。非女人身。何况作黄门等。此人忆一切生中一切宿住事。由闻思二慧圆满故。于安乐利益众生事中。由一切苦品类。由一切他违逆恶事不厌极故。是世间所说。非直买得陀婆。应知是菩萨。何以故。是诸大士。已至一切胜德最上上品位。无余因缘。唯由系属大悲故。于一切众生。安立自身。似彼仆使。由无憍慢故。于一切众生。能忍受一切最难求。欲恒荷负一切苦行事。由碍他故。不立自事。是故说非直买得是所说。能感相果报业者。偈曰。剡浮洲丈夫。对佛佛故意。思慧类百劫。于余得引此。释曰。唯于剡浮洲菩萨修引相报业。非余洲何以故。剡浮洲人。智根最利故。唯丈夫非女人。过女人位故。此修于何时。大师在现前时。由缘佛为境故意故。此业思慧为类。非闻修慧。于余时谓百大劫量。非于多余。一切佛皆尔。唯释迦牟尼世尊。正勤最炽盛故。能超九劫。于九十一劫引所余相业。是故如来说。土主我从此生前所经九十一劫。不忆不见。昔时于一家生中。因施一熟食。有间有损。何况大事。从此时自性念宿住故。已出初阿僧祇。菩萨除灭四种过失。恒得二种最胜德。宿旧师说如此。于菩萨诸相中。偈曰。一一百福生。释曰。此福量云何。除近行菩萨。一切十方众生。能感富乐业为量。余师说如此。如众生业增上缘。能感三千大千世界生。如此量。毗婆沙师说如此。有余师说。唯诸佛能知此业数量。复次今世尊。昔在菩萨位中。事几诸佛。于初阿僧祇事七十五千佛。于第二阿僧祇事七十六千佛。于第三阿僧祇事七十七千佛。一一阿僧祇最后时。何佛世尊出。由逆时应知次第。偈曰。三僧祇后出。毗婆尸燃灯。宝光。释曰。于剌那尸弃佛世尊。第一阿僧祇究竟。于燃灯佛世尊。第二阿僧祇究竟。于毗婆尸佛世尊。第三阿僧祇究竟。于一切佛。偈曰。先释迦。释曰。有佛世尊。号释迦牟尼。昔已出世。于此世尊所。今佛世尊求修菩萨行。初发菩提愿。愿我成佛。皆同如此相。昔时世尊。如今末世时生。乃至世尊正法住唯一千年内。菩萨在于何位。圆满何波罗蜜。偈曰。遍处施一切。由大悲施满。释曰。是时于一切众生。平等一切所应施类。若施财乃至眼及骨髓。若施法无师秘密。若施无畏现在未来二世救济。唯有大悲无所求。为由此量施波罗蜜得圆满。偈曰。分斫身无怪。有欲戒忍成。释曰。若是时菩萨未得离欲法。若被斩斫身分分断。于自他无爱憎故。最轻怪心亦不起。是时戒忍波罗蜜二俱圆满。偈曰。赞底沙精进。释曰。昔有如来号底沙。于宝山岩中入火界定。令佛世尊昔在菩萨位。以别意行遇见此如来。一脚着地一脚未下。于七日七夜。诵一偈赞叹已方坐。偈曰

  地天梵静处皆无　　三世十方未曾有
  遍行寻此地山林　　何人等尊由三德

是时精进波罗蜜已圆满。九大劫已超究竟。偈曰。定慧觉无间。释曰。先无上菩提。持诃那波罗蜜。般若波罗蜜已圆满。于金刚三摩提位。此六云何名波罗蜜多。由至自圆德际故。复次波罗摩者。谓菩萨最上品故。是彼正行。名波罗美(眠履反)是彼正行聚。名波罗美多。互不相离故。经中说有三福业类。一施性福业类。二戒性福业类。三修性福业类。此三云何名福业类偈曰。福业福业类。此三如业道。释曰。此施等三。亦福亦业亦类。如应次第。譬如业道。彼亦业亦道。但业家道非业。故说业道。此三亦尔。于施性福业类中。身口业有三种。能发起故。意有二。亦福亦业。余诸法共彼俱起。但福非业非类。于戒性中但身口业故唯有三种。于修性中慈无量修。但福亦是福业类。与此相应故意。由慈门所生起故。与此观俱起故。意及戒亦福亦业。所余信等相应法。但福非余。复次造作福名福业。谓福前分行。此三是前分依止类。为成就此三。是故作福真实福业唯是故意。此三是故意所缘福业类。余师说如此。施者是何法。或说所施名施。此三中偈曰。由此施是施。释曰。若由此因施事得成。说此因为施。由怖畏求得爱欲等。施事亦成。此中不许彼为施因。为简别彼故说此言。偈曰。欲供养利意。释曰。于他由欲作供养及利益事故施。是故此二是施因。若尔则施但因非业。虽然若正由此法起故施得成。此正是施。此法何相。偈曰。身口及缘起。释曰。缘起是何法。是法聚能生起身口业。此名缘起。此中说偈

  慧人由善心　　若舍财于他
  此刹那善阴　　说此名施业

偈曰。此大富为果。释曰。是施性福业类。能得大富乐果报。此施复何为。偈曰。为利自他二。不为二故施。释曰。此中若未离欲圣人。及未离欲凡夫。于支提施物。此施唯利益自身。不为利他。他由此无利益故若已离欲圣人。以物施他众生。除现报业。此施但为利他。他由此得利益故。不为自身。此业果报地。永已过故。若未离欲圣人。及未离欲凡夫。以物施他众生。此施为二利。谓自他。若已离欲圣人。于支提施物。除现报业。此业不为二利。谓自他。此施唯为恭敬知恩故施。若约通义说。此施以大富乐为果报。偈曰。胜别由能施。施类由胜故。释曰。此中能施胜者。偈曰。由信等人胜。释曰。由信戒闻等德相应故为胜。此人所行施。由施主有胜德。于与果最胜。若施主有如此德。偈曰。以敬重等施。释曰。若敬重心行施。自手行施。应时行施。不损恼行施。是故偈曰。得尊重大乐。应时及难夺。释曰。若施主能行四德施。次第得四种可爱胜果。谓得他恭敬尊重。于大胜可爱尘起受用意乐。应受用时即得财物。不过受用时。所得财物不可侵夺。谓怨亲水火等。说施主胜德义已。由施主有胜德故。施有胜类。复次所施物有胜德云何。偈曰。色等德物胜。释曰。若所施物色香味触等德随一相应。此物由此德胜若施如此有德物此施何。有次第应知。偈曰。妙色好名闻。可爱相软滑。随时乐触身。释曰。若施有色德物。得端正可爱色报。若施有香德物。得大好名闻。如香于四方名闻遍覆。若施有味德物。得报如美味。为一切世间所爱。若施有触德物。得柔软细滑身。复得随时安乐触身。譬如宝女身田。何德为胜。偈曰。由道苦恩德。施田有胜德。释曰。如世尊说。若施物于畜生。应受百倍果报。若施物于人道破戒众生。应受千倍果报。由苦差别。田有胜德者。如有摄福业类中说。一于病人行施。二于看治病人行施。三于寒时行施。说如此等施。复说。若与此有摄七种福业类相应。有信善男子善女人。所得福德不可校量。由恩差别田有胜德者。如父母及余有恩人。譬如熊鹿本生经说。由德差别田有胜德者。如经言。若施物于有戒人。应受百千倍果报。如此等。于一切施中。偈曰。脱人施脱胜。释曰。若离欲人。施物于离欲人。此施于一切财施中。佛世尊说最胜。偈曰。菩萨释曰菩萨所行施。此施是一切众生安乐利益事因故。此施若非离欲人所行。及不于离欲人施。此施于一切施最胜。除菩萨施。是佛世尊所说八种施。于中偈曰。及第八。释曰。最胜何者为八。一已至施。二怖畏施。三已施我施。四当施我施。五昔已施施。谓父及先亡等。六为得天道施。七为得好名闻施。八为庄严心施。为心资粮施。为应众理施。为得最上品己利施。已至施者。先旧师解。于已至及亲近人所行施。怖畏施者。此人见财物现前向灭坏。若施胜自灭坏。由此意故行施。所余易解故不分别。若施物于须陀洹向人。此施果报不可称量。若施物于须陀洹。百倍无量。如此广说。应知如经。复次偈曰。父母病说法。人后生菩萨。虽凡夫中施。果报无数量。释曰。此五人若皆是凡夫。于彼行施。约果报无数无量。于中最后生菩萨说法人。于四种胜田中。安立在何田。入恩田摄。何以故。此人是善知识。世间无明所闇。能施慧眼。能显示平等不平等。能生起无流法身。若略说此人能作佛所应作事。若人欲知诸业轻重相。略说应知。有六种因。偈曰。后分田及依。前分故意愿。此下上品故。故业有下上。释曰。后分者。若作此业已。复更数数随作。田者是处行损行益。依者谓业道。前分者。为得业道。身口故意。若由此业道究竟。故意者。如此如此我应作。如此如此我正作。愿者谓求当来用。有人由属后分故。成重品业。定安立果报故。复有人由属田故业成重品于田由属依止。此业成重品不由。余因依止谓业道。譬如父母及余众生。由杀生依止重。不由偷盗等重。所余应知亦尔。若人作业。此六因一切皆是上品。应知此业是最重品。若人作业。此六因一切皆是下品。应知此业是最轻品。经中说业有二种。一所作。二所长。云何业是所长。由五种因。偈曰。故意作圆满。无忧悔对治。由伴类果报说业所增长。释曰。云何由故意作。此业故意所作。非无意为先非匆促所作。熟研寻简择然后方作。云何由圆满。有人由一邪行堕恶道。有人乃至由三。有人由一业道堕恶道。乃至有人由十堕恶道。此中若人由此业量应堕恶道。此量未圆满。此业但是所作未是所长。若已圆满方是所长。云何由无忧悔对治。若人作业于中无忧悔心。不受善行为对治。云何由伴类。惑作恶以恶为伴类。云何由果报。此业已定能与果报。善业亦应如此思。若异此相所作业。但作非长。前已说。未离欲人。于支提施物。此施但为自利不为利他。此中若无能受用施物。云何此业成福。福业有二种。一弃舍为类。若由舍物此福业生。二受用为类。若由受用所施物此福业生。此中偈曰。支提舍类福。释曰。于中无受用类福。彼若不受云何有福。何因为证。若有能受必有福。若无能受则无福。随一无利益故。此因不成证。何以故。若福由利他故。成修慈等无量及正见应无福。是故应许此义。于支提福唯舍为类。偈曰。如慈虽不受。释曰。譬如于慈悲等观中。虽无能受及利益他事。有无量福生。从自心起。如此若有德人已灭。敬事心所作。从自心起福。若尔施恭敬等业。应成无果。是义不然。何以故。业生缘敬事心最胜故。譬如有人欲杀怨家。怨家先已死。此人犹想怨家起故意。造身口业生多非福。不但由欲杀意。如此大师已去世。若人由敬事心起恭敬施等事。最生多福。不但由敬事心。若于善田行施。及起恭敬等业种子。得可爱报。若于恶田应得不可爱报。偈曰。恶田有好果。果种不倒故。释曰。于恶田见果。从种子无倒。谓从蒲桃种子。唯蒲桃子生。其味甘美。从维婆种子。唯维婆子生。其味莶苦。如此于恶田由安乐利益他意。所生施业种子。唯可爱果报生。非不可爱。恶行亦尔。由田过失此种子或少果或无果。说施性福业类及有立破已。戒性今当说。偈曰。邪戒谓恶色。正戒离此二。释曰。恶性色。谓身口业说名恶戒。远离此业说名善戒。此远离戒有二种。有教身口业。能远离恶说名有教戒。但是远离性类说名无教戒。不但远离恶戒名善戒。何者偈曰。及是佛遮制。释曰。此业虽非自性恶戒。为守人及正法故。佛世尊立遮制戒。如非时食等远离所遮制名善戒。此戒有二种。谓有教无教。若人受此戒。由犯事故得破戒罪。若由略义戒性已说。偈曰。此清净四德。释曰。若具四德名清净戒。若翻四德名染污戒。云何具四德。偈曰。非邪戒因污。依对治寂灭。释曰。非邪戒所污者。如前所说。破戒相随一所不毁犯。贪等诸烦恼及利等染污。皆所不触。此戒依止。破戒对治。谓依念处等故。此戒依止寂灭起。不依止善道生胜类起。为得涅槃所回向故。有余师说。由五因故得清净。一由根本业道清净。二由前分清净。三非邪觉观所侵触。四四念处所摄持。五于涅槃所回向。有余师说。戒有四种。一怖畏戒。由无资粮忧恼重罚恶道怖畏所得。二望得戒。谓生死乐具及他恭敬利养好名贪欲所得。三顺觉分戒。谓能引解脱。有正见人。厌患生死。求出离所得。四无流戒。能对治诸惑。是无垢清净。说戒性已。修性福业类今当说。偈曰。寂静地善业修。释曰。寂静者何法。业与定地自性法俱起。云何说此法名修。偈曰。能薰心故。释曰。云何薰习。此寂静地善业最极能薰习心。能令心与德成一性故。及相续亦尔。譬如以花熏麻。前已说。此施以大富乐为果报。戒修云何。偈曰。由胜戒感天。修感相离果。释曰。施亦能感天道。戒由胜能能感天道。亦能感相离果等。修由胜能能感相离果。亦能感天道等。经中说。有四人能生梵福业。何法名梵福。毗婆沙师说。为校量能感相报业故。说梵福业。随一业菩萨所修。能令得诸相中一相。此业量说名梵福。先旧诸师说。偈曰。四业名梵福。劫生天乐故。释曰。随福业量。能感一劫天道生及乐报。此业名梵福。说此业有四种。何者为四。一若此地处。未经建立如来支提。于中造立如来薮斗波。二若此地处。未经建立僧伽蓝。于中造立僧伽蓝。三世尊弟子众已破。能更引摄令和合。四于十方众生。修四无量心观。此四种人。如梵先行寿量。于天道中生。受喜乐报。梵先行天寿量一劫故。佛说此人业同彼福业。于别部中彼师说此偈

  有信正见人　　若修十胜行
  即生梵福业　　劫生天乐故

说财施已。法施今当说。偈曰。法施如实理。无染说经等。释曰。修多罗等十二部正教如实道理。无染污心显释文义。是名法施。是故此人自作最广大。自福减失及损他福。若人颠倒说法。或有染污心。为求利养恭敬名闻故说法。此人亦尔。说福业类差别已。复有三种业类差别。偈曰。福解脱决择。能感善有三。释曰。复有别三种业类差别。一福德分能。若此业能感人天可爱报。二解脱分能。若业已起。此人后时必定以涅槃为法。若人听闻生死过失诸法无我涅槃功德。诸佛恩德相应正说。毛竖泪落悲赞等事起。此人昔已有解脱分能善根。应如此决。譬如于夏月由见芽生知地坎坼中先有种子。三决择分能。于暖等位有四种。后当说。是世间所说。谓字印算量文章数。此五体相云何。偈曰。如理所成业。共缘起有三。字印及算量。文章数次第。释曰。如理所成者。正方便所生。有三者。谓身口意业。此中字印。若胜方便所作属身业。此共缘起。算量文章若胜方便所作属口业。亦共缘起。此四五阴为性。数若胜方便所作属意业。亦共缘起。四阴为性。此数即是心思。诸法众名今当说。偈曰。有诃覆下性。染污。释曰。若法有染污。有时说名有诃。或说为有覆。或说为下劣性。偈曰。善无。流美妙。释曰。若善无流说名美妙。异下性及美妙法。应知此名中。偈曰。有为善。应事。释曰。若善有为说此名应事。所余不应事此义自成。云何无为不应事。不可数习增长故。又无果故。一切事皆为得果。一切余法皆有上。何法独无上。偈曰。脱无上。释曰。涅槃是出离一切生死法。故名解脱。此法于一切法无等。何以故。善真实常住故。尚无法等涅槃。何况有上

阿毗达磨俱舍释论卷第十三阿毗达磨俱舍释论卷第十四

        婆薮盘豆造

        陈天竺三藏真谛译

    中分别惑品第五

前已说。世间多种异从业生。诸业由随属惑故。至得生长。若离随眠惑。于生诸有诸业。无复功能。是故应知。彼偈曰。随眠惑有本。释曰。云何为有本。若惑现在正起。能作十种事。一坚固根本。二安立相续。三数治自田。四生起等流。五能引生业有。六圆满自资粮。七令迷境界。八引将识相续。九令离净品善法类。十成就缚义。由不得过自界故。彼随眠惑有几种。若略说有。偈曰。六。释曰。何者为六。偈曰。谓如欲嗔。憍慢无明见。心疑。释曰。如欲者。显余惑与欲同。由境界随眠故。此义后当说。偈曰。复说彼。六由欲别七。释曰。于前偈中所说。六随眠惑。于中分欲为二。更说彼为七。谓欲欲随眠。嗔随眠。有欲随眠。憍慢随眠。无明随眠。心见随眠。疑随眠。此义云何应知。为随眠即是欲欲。为随眠异欲欲。譬如石子体及提婆达多衣。若尔何有。若欲欲即是随眠。则违佛经。经云。世间有人。非欲欲上心惑所染心数数长时住。如实见知是欲欲上心惑出离义。于此人是欲欲上心惑。由根由力。正所断除。及与随眠永得灭离。若汝执别欲别随眠。由立随眠与欲不相应。则与阿毗达磨藏相违。彼藏云。欲欲随眠与三根相应。毗婆沙师说。欲欲即是随眠。乃至疑即是随眠。前不说与经相违耶。无相违。何以故。经云及与随眠永得灭离者。与随从法永得灭离。复次于经中随眠言。是方便语。或至得语。譬如地狱苦天上乐及说火苦。阿毗达磨藏言。皆依直相起。随眠即是惑故。一切随眠皆与受相应。云何得知。由随眠起心染污故。能为障故。与善相违故。由心为随眠惑所染污。未生善不得生。从已生善亦退故。故知随眠惑与心不相离。若由不相应。此义得成。无时善法可得。由彼恒在故。由善法有时可得故。知随眠与心相应。经部师说此义非证。若人执随眠惑不与心相应。此三义彼不执为随眠所作。但是上心所作。若作如此执。则无过失。如经部执。随眠者是欲欲随眠。此随眠不与心相应。亦不与心相离。由非别类故。若惑眠说名随眠。若惑觉说名上心。此惑眠何相。不在现前种子随逐惑觉。何相正现前起。何者惑种子。是身相续功能。从惑生能生惑。说名种子。譬如牙等。从舍利子生。能生舍利子。若人执诸惑种子是别法。谓随眠不相应。此人应立别法为念种子。若说随眠非相应非非相应。于六六经中。此义云何经言。此惑于此人乐受成欲随眠。由此等言。此惑是时未得随眠。若尔于何时。眠时是时。或于因说果名。故称随眠。且置此论。应更显本义。于经中所说欲差别。谓欲欲有欲。此有欲是何法。偈曰。有欲二界生。释曰。色界无色界中生欲。说名有欲。为何因作如此名。偈曰。内门起故说断彼解脱想。释曰。于彼二界人。多起三摩跋提欲。此欲依内门起故。说名有欲。复次于此二界中。有余人起涅槃想。为除彼涅槃想故。说此欲名有欲。有者谓身体。即是五阴。于彼众生啖三摩跋提及依止味。离欲欲界故。是故此欲名有欲。此六种随眠。于阿毗达磨藏中复分为十。云何为十。偈曰。见五。谓身见。边见及邪见。见取戒执取。由此复成十。释曰。本立六为随眠惑。于中分见为五故成十。于中五以见为自性。谓身见边见邪见见取戒执取。五以非见为性。谓欲嗔慢无明疑。复次此十随眠惑。于阿毗达磨藏中。更立为九十八。于欲界中有三十六。色界中有三十一。无色界中有三十一。若略说此随眠惑名三界惑。或说名见修所灭惑。于中欲界见谛所灭有三十二。何者三十二。偈曰。彼十七七八。三二见所离。次第俱断灭。见欲苦等故。释曰。是所说十惑。于欲界具十见苦所灭。于中七见集所灭。七见灭所灭。除身见边见戒执取故。八见道所灭。除身见边见故。如此欲界三十二惑说名见谛所灭。由唯见谛除灭故。偈曰。四惑名修灭。释曰。四惑者。谓欲嗔慢无明。彼云何是修所灭。若人先已见四谛。后由数修习道。方能灭除如此身见。于中但一品见苦所灭。边见亦尔。邪见有四品。见苦集灭道所灭。见取疑亦尔。戒执取有二品。见苦道所灭。欲嗔慢无明有五品。见四谛及修道所灭。于中彼何相见苦所灭。乃至何相修道所灭。由见谛相彼灭。及能缘彼故。说见谛灭。所余名修道所灭。若立如此见成十二。疑成四欲五嗔五慢五无明五。如此欲界惑。合成三十六种。偈曰。合彼唯除嗔。色惑。释曰。除五品嗔。如此名色界惑。合三十一。如色界惑。偈曰。无色尔。释曰。无色界惑亦三十一。偈曰。故立九十八。释曰。如此六随眠惑。所缘法相及对治并界差别故。阿毗达磨师。立为九十八随眠惑。是见谛所灭随眠惑为决定。唯由见四谛灭。为非。说非。云何偈曰。有顶忍所灭。定见灭。释曰。此随眠惑。于有顶生类忍所灭。是彼必定见谛所灭。非修道所灭。偈曰。余生。见修灭。释曰。忍所灭此言流。于所余地如理法忍类忍所灭随眠惑。于圣人是见谛所灭。于凡夫是修道所灭。偈曰。非忍灭。必修道灭。释曰。于一切地中惑。凡是智所灭。于二人恒修道所灭。有余师说。见谛所灭惑。非外凡夫所灭。何以故。于大分别业经中说。分别前际人说常住。或说随一常住。或说不由因生。此三离欲人。缘欲界起诸见。说有通行。若色界惑。不能以欲界法为境。由离欲界欲故。是故知欲界相应诸见不得灭。同诸见生时。彼已退定。犹如提婆达多毗婆沙师说如此。此五见由名已说。不由自性。彼自性云何。偈曰。我我所常断。无于下胜见。非因道此见。是名五见性。释曰。我及我所见名身见。由刹那刹那坏故说灭。由聚集故名身。以阴为义。此法亦坏亦聚故名灭身。谓五取阴。为除彼计常想。及于聚执一想。故说如此。何以故。彼我见于五阴以此想为先。于灭及身。不如执说名身见。一切见能缘有流法为境。悉缘灭身。而但立我我所见名灭身见者。欲令彼知此见唯于灭于身起。非于我我所。如经言。世间若有沙门婆罗门。起见谓有我。是彼一切唯于五阴起。我见是类彼所许为我。或执见为常。或执见为断。是名边见。由执常边断边故。于实有苦等谛执见为无。故名邪见。一切见皆翻违理起。悉是邪见。但说一见为邪见者。由此见最恶能断善根故。故说为邪见。譬如臭酥及恶旃陀罗。此一向非拨故。所余诸见但有增益。于下品法执为最胜。说名见取。何法名下品。谓一切有流法。圣人所弃舍故。执此法为最胜。是名见取。应说见等胜取见。此中除等见言。非因中因见。非道中道见。名戒执取见。譬如摩醯首罗非世间因。彼观为因。世主天等所余诸物亦尔。入火水等非生天因。彼观为因。唯执僧佉踰伽等智非解脱道。彼观为道。此中应知除等见言。如此五见性应知。若非因中起因见。云何此见非见集所灭。若有人见自在及世主为因。此人必执此为常为一我作者。是故此偈曰。于自在等处。从常我倒生。因等虚妄执。是故见苦灭。释曰。由见苦谛。于自在等处。常执我执俱灭。非因执是二倒所作。是故与此见共灭。若人由入火水等方便起生天执。由戒及执计得清净。此执亦见苦所灭。阿毗达磨藏文言如此。复言。若有人执说如此。是时善男子受持牛戒。行鹿戒狗戒。由此行清净解脱出离。过度苦乐得至过苦乐处。若信非因为因。戒执取见。见苦所灭。广说如彼藏。云何此执见苦所灭。于苦乖违故。此执太过为失。一切缘有流境。或于苦乖违。与非因执因。复有何相。别戒执取。见道所灭。缘见道所灭法为境。此于苦亦乖违。若人缘道起邪见及疑。或谓无解脱道。或思此道为是解脱道。为非依此二。云何分别观为清净。若彼执别有解脱道故。拨无此解脱道。是人由别解脱道。执计为清净。不由邪见。是故此执不成缘见道。所灭惑为境。若人由见集灭二谛所灭邪见。计为清净。云何此戒执取。非见集灭谛所灭。是故汝所执义更须简择。是前所说。有常倒我倒为唯此名倒。为更有余说。颠倒有四。谓于无常常颠倒。于苦乐颠倒。于不净净颠倒。于无我我颠倒。此四种颠倒体相云何。偈曰。从二见半生四倒。释曰。从边见中取常见为常颠倒。从见取立乐颠倒净颠倒。从身见立我见为我颠倒。余师说。见取云何以我所为倒。彼见我于是处自在故。于是处起我所见。是故此见皆是身见。由二门起。若汝计我是第一执。我所是第二执。若我与带物称我。此二文应成别执。云何不立余惑为颠倒。由以三因成立颠倒义故。何者为三。偈曰。颠倒故。决度增益故。释曰。此二见半。一向颠倒故。于境界决定度故。增益义故。断见邪见不能增益。非有门起故。戒执取非一向倒。随分量清净为境界故。所余诸惑不能决度。是故不立为颠倒。若尔于经中。说于无常执常。是名想倒心倒见倒。此中云何唯见为倒。偈曰。想心随见故。释曰。由随属见倒与见倒相应。想及心亦说为倒。云何不说受等为倒。由世间成故。于世间说。此人颠倒想颠倒心。此义明了。不说颠倒受。如此颠倒于须陀洹人一切皆灭。由诸见见谛所灭故。余相应法亦同灭。颠倒有十二种。于无常计常。是想心见颠倒。乃至于无我计我。是想心见颠倒。于中八倒见谛所灭。四倒修道所灭。谓于苦计乐。是想心倒。于不净计净。是想心倒。余部说如此。若不尔。离乐想倒及净想倒。未离欲圣人。云何淫欲欲得起。毗婆沙师不许此义。何以故。彼言。若由乐净想心生起故。于圣人立此二为颠倒。众生想心生起故。云何不立此二为我颠倒。何以故。于女人及自身。若离众生想。淫欲欲不应成。复于经中说。由多闻圣弟子是苦圣谛如实已见已知。乃至此圣弟子。于此时中于无常计常。想倒心倒见倒。皆悉永灭。广说如经。是故若从见生想心。则成颠倒非余。由暂时心乱故。譬如于火轮心乱。及夜叉心乱。若尔大德阿难依婆耆舍大德。说言

  由起想颠倒　　故汝心焦热

此言云何。将是故一切八想倒及心倒。于圣人未灭。余部说如此。若尔云何不违佛经。是八终由如实见知四谛。方皆灭尽。离四谛观无得灭义。由说灭方便故。故不相违。为唯见倒有差别。为余惑亦有。慢亦有。云何有差别。偈曰。七慢。释曰。何者为七。一慢。二过慢。三过过慢。四我慢。五增上慢。六下慢。七邪慢。若不分别。但以心高为慢。此心高由生起差别故成七种。于下计自胜。或与等计自同。若人如此分别起高心名慢。于等计自胜名过慢。于上品计自胜名过过慢。于五取阴分别计是我及我所名我慢。未至胜德计自己得名增上慢。于多量胜计自少量劣名下慢。实自无德计自有德名邪慢。若尔于阿毗达磨藏中说慢类有九种。一我胜慢类。二我等慢类。三我下慢类。四有胜我慢类。五有等我慢类。六有劣我慢类。七无胜我慢类。八无等我慢类。九无下我慢类。此义云何。此九从前七慢生。偈曰。九慢类。从三。释曰。何者为三。谓从过慢慢下慢。此中第一三慢。依止见起。即是三慢。谓过慢慢下慢。下慢慢过慢。即是第二三慢。慢过慢下慢。即是第三三慢。此义相应。于多量为胜。计自少量为劣立为慢。有高处故。计无他下劣于自。此中何为高处。有如此高处。于自所乐最下劣众生聚中。知自最下。于自起尊重心。复次于发慧论中分明说此事。如言我是王旃陀罗。若依分别道理论说。计我胜此慢。或慢或过慢或过过慢。由观下等胜品人故。复次此七种慢。何法所灭。故说偈曰。见修灭。释曰。由见及修故说彼灭。一切七见谛修道所灭。是修道所灭。于圣人未灭。为必定于圣人现前起。为不起。不定。譬如偈曰。杀等上心惑。修灭如彼尔。释曰。有上心惑。能起故意为作。杀生乃至说妄语。此皆修道所灭。缘修道所灭法为境界故。复次偈曰。非有爱圣人不起。释曰。非有贪爱亦修道所灭。此非有是何法。谓于三界不有。于中起爱乐名非有爱。如言显有爱一分。谓彼愿我生成伊罗槃那象王等。偈曰。慢类等。释曰。九慢类中。有慢类修道所破。我慢亦尔。如此等于圣人不现前起。九慢类非我慢。由等言乃至摄非有爱。何因如此等法未灭。非现前起。偈曰。无见所圆故。释曰。由见圆满故。故彼不起。此义云何。九慢类及我慢。身见所圆满。由背折故不能更起。杀生等上心惑。邪见所圆满故。非有爱断见所圆满故。有爱一分常见所圆满故。偈曰。恶性忧亦无。释曰。忧悔心若是恶性。亦是修道所灭。于圣人亦不得现前起。疑惑所圆满故。复次于九十八惑中。几惑遍行几惑非遍行。偈曰。遍行见苦集。灭惑谓诸见。疑共彼无明。及独行无明。释曰。见苦集所灭诸见及疑惑。与彼共相应起无明及独行无明。皆见苦集所灭。此十一惑。于非同类部界中说名遍行。七见二疑二无明故成十一。缘具自界生起故。有何人以具欲界计执为清净。以非因缘计执为因缘。不说具由缘具自界及一时起。虽不然能缘一切五品自界故。说能缘具自界。若尔不可唯立十一为遍行惑。是处有我见必有我爱。是处有胜见清净见。此中必有乐得。由此等起高心。是故爱及慢应成遍行惑。若尔此二惑。缘见灭修灭为境界。此二何道所灭。修道所灭。杂乱境界故。复次或执见谛所灭。由见力所生立故。此二是别相惑非通相惑。是故非遍行。毗婆沙师说如此。于非同类部界。是所说遍行惑有十一种。于中偈曰。九惑上地境。于彼除二见。释曰。于十一中除身见边见。所余九惑说名遍行。非同类界惑。有时能缘一不同类界为境。或缘二界。如阿毗达磨藏云。是惑于欲界相应。有时能缘色界相应法为境。是惑于欲界相应。有时能缘无色界相应法为境。是惑于欲界相应。有时能缘色界无色界相应法为境。由此文句应知此义。若人生在欲界。于梵王起众生见及常见。云何身见及边见。不立缘不同类上界为境。由不执为自我及自我所故。边见从此起故。此是何见。此二执非见。但是邪智。为一切遍行皆是惑邪。说非。偈曰。离至得与彼。俱起亦遍行。释曰。与遍行惑俱起所余诸法皆是遍行至得。不尔果不一故。是故说四句。有遍行惑不由遍行因成因。此中应立四句。初句者。谓未来世遍行惑。第二句者。过去现世俱起余法。第三第四。应自思立。于九十八惑中。几惑缘有流法为境。几惑缘无流法为境。偈曰。邪见疑与二。应无明独行。见灭道所灭。六无流为境。释曰。见灭所灭三惑。谓邪见疑与二相应无明。及独行无明。见道所灭。亦是此三如此六惑缘无流法为境。所余诸惑缘有流为境。此义自成。复次此中偈曰。自地灭及道。六地及九地。缘无流惑境。由道互为因。释曰。邪见等诸惑。能缘灭谛为境。自地灭是其境。若行欲界欲界灭。乃至行有顶有顶灭。缘道为境。行欲界惑。一切六地法智类道为境。若色无色界对治。缘道为境。行色界无色界八地惑。一切九地类智类道为境。何以故。由道互相因故。虽复法智类智更互相因。类智非欲界对治故。缘道为境。行欲界惑。不能缘类智类道为境。若尔法智是色无色界对治故。缘道为境。行色无色界惑。应成所缘境。此法智类道非具对治。苦集法智。非色无色界对治故。又非具色无色界惑对治故。前后无故。是故非境。复次云何欲嗔慢见取戒执取。不许彼缘无流为境。偈曰。非欲所离故。释曰。欲者必应舍离。若此缘无流为境。则不应可离。譬如欲乐善法。偈曰。非嗔非过故。释曰。嗔者若起缘他过失起。灭道谛既非过失故。嗔不缘此起。偈曰。非慢非二取静净胜性故。释曰。灭道二谛。寂静为性故。必不由此二起于高心。由此二是自己真实清净故。于二清净执不成戒执取。此二法于一切法中最胜。于下劣法中起胜执。说名见取。是故如此等惑。不应缘无流法为境。于九十八随眠惑中。几惑由缘境随眠。几惑由相应随眠。偈曰。遍行随眠惑。具自地随眠。唯由缘缘故。释曰。遍行诸惑。于自地缘自部及他部。得生起增长。偈曰。非遍行自部。释曰。所余非遍行惑。于自地中但缘自部随眠。譬如见苦所灭惑。缘见苦所灭惑部随眠。乃至修道所灭惑。缘修道所灭惑部随眠。不缘余部。作通说已今更简别。偈曰。非无流上境。释曰。此惑若缘无流为境。不由所缘境故。随眠缘上地为境亦尔。何因如此是彼所缘法偈曰。非自取对故。释曰。若是法类我见我爱执取为自依。于此中余惑亦能缘彼随眠。譬如于湿衣埃尘及于湿田种子。无流法不尔。上地亦不尔。是故缘彼为境。或于彼无随眠义。若人在下界求得上地。此是善法欲非惑。涅槃及道。是能缘诸惑对治上地。亦是下地惑对治。是故彼惑于此三境不得依住。譬如于热石蹠下不得住。随眠言者。随长为义。虽可缘于中无有随长。不如风病服粗涩药。若惑由缘境随眠已说。偈曰。若彼与相应。于此由相应。释曰。随眠言流。若惑与此法相应。彼惑于此法由相应故得随眠。乃至未灭。有诸惑不缘无流为境。非遍行不同分界。此惑但由相应得随眠。不由缘境不。有。谓遍行非同分地惑。九十八惑中。几惑恶性。几惑无记性。偈曰。上界惑无记。释曰。一切色界无色界惑。无记为性。何以故。一切恶性染污有苦受果报。此苦报于彼无。非他逼恼因故。偈曰。于欲界身见。边见共无明。释曰。于欲界中身见边见。及与二相应无明。此三无记为性。何因如此。与施等不相违故。谓我于未来世必应受乐故。今世行善持戒修定。边见既随顺解脱。是故世尊说。于外五见中此见最胜。谓我不有我所不有我。当不有我所亦尔。此二执无苦果报。迷于自体故。不逼恼他生起故。若尔贪爱天上。及我慢应同此义。生得身见是无记。若于禽兽等有。若有分别则成恶。先旧诸师说如此。偈曰。所余惑恶性。释曰。于欲界异此二诸惑皆不善。几惑非善根。几惑非非善根。偈曰。于欲界恶根。贪欲嗔无明。释曰。于欲界中一切欲一切嗔一切无明。除与身见边见相应。余惑次第说为三不善根。谓贪欲不善根。嗔恚不善根。无明不善根。若惑非善。又为非善法根。许此法为不善根。所余诸惑非非善根。此义自成。几法为无记根。几法非。偈曰。无记根有三。释曰。何者为三。偈曰。爱无明及慧。释曰。随有无记贪爱无明及果报生慧。如此等一切是无记根。罽宾国师说如此。偈曰。二缘高生故。余非。释曰。彼说疑者由二缘生。不应成根。以转动故。慢以高生为相。由高生故。非根异根法故。何以故。根者坚着下生。此义世间所了。疑慢无此义故。不立为根。偈曰。外师说。四。释曰。罽宾国外诸师说。无记根有四。偈曰。谓爱见慢痴。释曰。此四但无记。谓无记爱无记见无记慢无记无明。何因此四成无记根。偈曰。三观人由痴。释曰。由修定人有三。谓由爱见慢修上观行。此三人由依无明故得成三。于经中所说。有十四种无记。类为彼无记故说无记。为由别义。非。云何。若问应遮断说名无记。问有四种。一应一向记。二应分别记。三应反问记。四应置记。此中次第应知。偈曰。一向记分别。反问及置记。譬如死生胜。及我异等义。释曰。若问一切众生皆应死不。应一向记。定皆应死。若问已死一切更生不。应分别记。若有惑则更生。无惑则不生。若问人道为胜为劣。应反问记。汝今依何问此。若彼答依天。应记人劣。若彼答依恶道。应记人胜。若问众生与五阴为一为异。此应置记。众生非实有故。譬如石女儿黑白等色。云何此置成记。此不可记有此记故。复有余师说。此义亦一向应记。谓非一切应生。若有人问若众生当死彼为更生不。此应分别记。于人道中有二种。谓有劣有胜。此二各有所观。是故此二一向应记。譬如识亦因亦果。若人一向问由不一向记。应成分别记。众生与五阴为异不。说非所记。此非记不应成记。此应置记问。由置如此应记。此云何不成记。阿毗达磨师说。多他阿伽睹婆伽婆阿罗诃三若三佛陀。此法正说。弟子众正行。色无常乃至识。说苦乃至说道。如此等应一向记。由与利他相应故。分别记者。若有人言。请尊说法。此人应问。彼诸法多。或过去现世未来。何法我所应说。若彼言应说过去法。应问彼过去法多。谓色乃至识。若彼言应说色。应问彼色有多种。谓善恶无记。若彼言应说善色。应问彼善色有七种。谓离杀生乃至离无义语。若彼言应说离杀生。应问彼离杀生有三种。谓从无贪无嗔无痴生。若彼言应说无贪。应问彼从无贪生有二种。谓有教无教差别故。如此名分别记。若谄曲心人作如此问。应如此分别记。对彼应言。诸法多不应自分别。乃至彼默然住。及彼自记。此二人无所问。一向互请说。此二人无一有记。一向互相问。云何彼成问此成记。此中二义皆成。何以故。若人言请为说道。此人为不问道耶。由问彼故记彼问。若尔此云何非反问记耶。置记者。谓世间有边及无边等。复次依经应见有四问记相。大德摩诃僧祇说经言。比丘记问有四种。何者为四。比丘有问应一向记。乃至有问应置记。比丘。何者问应一向记。一切有为无常。比丘。何者问应分别记。若人问若故意造业受何果报。此问应分别记。比丘。何者问应反问记。若人问想为即是我为想异我。若彼此问应反问。彼长老汝依何我作如此问。若答问粗我。应记我异想异。比丘。是名反问记。比丘。何者问应置记。谓十四非记类。世间常非常亦常非常非常非非常。世间有边无边亦有边无边非有边非无边。如来异死不异死。亦异死不异死。非异死非非异死。命者即是身。命者异于身。若人随眠惑于境界中生起。此人由此惑于此境界相应。此义应说。由过去惑于何境相应。乃至由现世惑于何境相应。若略说诸惑有二种。一别相惑。谓欲嗔慢。二通相惑。谓见疑无明。于中偈曰。由欲嗔高慢。过去及现世。是处起未灭。于此类相应。释曰。过去现世欲嗔慢。是处已起乃至未灭。于此处中三是众生与彼相应。何以故。此三是别相惑。非必一切一切处起。偈曰。一切中由当心地。释曰。已起未灭此言流。由未来欲嗔慢。依心地起。一切类中相应。谓于三世。偈曰。余自世。释曰。欲嗔慢异心地惑。在未来世。但于未来境相应。云何为余。依五识起故。定生为法由彼惑。偈曰不生一切中。释曰。此三惑若不生为法依五识起。尚于一切类相应。谓三世。偈曰。一切余中应。释曰。何者为余。谓见疑无明。此三若三世。于一切境及一切世中与彼相应。彼是通相惑故。乃至未灭此言流过去未来为实有物。为假名有。若实有于一切时有故。一切有为法应成常住。若无于无中由无物。云何相应及解脱。毗婆沙师。成立一切有为法非常住。由与行相相应故。彼成立此义分明。谓偈曰。三世有。释曰。何因为证。偈曰。说故。释曰。佛世尊说。比丘过去色若不有。多闻圣弟子。于过去色。不应成无所观惜。由过去色有。是故多闻圣弟子。于过去色成不观惜。未来色若不有。多闻圣弟子。于未来色不应成无所求欲。由未来色有。是故多闻圣弟子。于未来色成无所求欲。复次偈曰。由二。释曰。依二识生。此义是经所说。何者为二。谓眼及色。乃至意及法。彼经云。过去未来若无。能缘彼识不由二生。如此由阿含证。得知过去未来是有。若以道理为证。偈曰。有境。释曰。若有尘识得生非无尘。过去未来尘若无。应有缘无为境识。是故因此义。识亦不应有。所缘境无故。复次偈曰。果。释曰。过去法若无。善恶二业于未来云何有果。何以故。于果报生时。果报因必不在。是故知过去未来是。有毗婆沙师立如此。若人自说我是萨婆多部同学。此义必应信受。何以故。偈曰。由执说一切。有许。释曰。若人说一切有。谓过去未来现世。虚空择灭。非择灭。许彼为说一切有部。复有余人说。现世法必有过去业。若未与果是有。若过去业已与果。及未来无果此皆是无。若如此分别故。说三世有。此人非说一切有部摄。是说分别部所摄。说一切有部中有几种人。偈曰。彼四种。彼师有相位。异异分别名。释曰。大德达磨多罗。分别有异故安立三世。彼说若法行于世。唯有有异。非物类异。譬如打破金器作别庄严具。有别形相故有异。不由物类异故异。色等同故。复次譬如乳变异成酪。舍味力熟等不舍。色法亦如此。从未来世正行现世。舍未来有相。不舍自物类。从现世正行过去世。舍现世有相。不舍自物类。大德瞿沙说。由相别异故立三世。彼说若法行于世。若过去与过去相相应。与未来现世相亦不相离。若未来与未来相相应。与过去现世相亦不相离。若现世与现世相相应。与过去未来相亦不相离。譬如有人爱着一妇。于余亦不离欲。诸法亦尔。大德婆须蜜多罗说。由位别异故立三世。彼说若法行于世。至位位说为异异。由位异故异。不由物异故异。譬如一画。安置一处说为一。若安置十印位说为十。若安置百印位说为百。若安置千印位说为千。法于三世亦尔。大德佛陀提婆说。由异异故立三世。彼说若法行于世。观前观后。说异异。譬如一女或说为子或说为母。法于三世亦尔。是萨婆多部师中。第一由说变异立世故。引置僧佉义中。于第二。三世义相杂。一切世与一切相相应故。彼立人为譬。谓此人于一妇起欲心。于余妇唯有至得。此中何义为同。于第四。一世中三世俱至。于过去世有前后刹那。名过去未来。中刹那名现世。余世亦尔。是故于四师中。偈曰。第三可。释曰。若师以位异立世。于此人。偈曰。诸世。由功能立故。释曰。若是时诸法未作功能说为未来。是时正作功能说为现在。是时作功能已谢说为过去。此师于功能执胜于法体与彼同。彼执不过此义。此义汝今应说。若法已过去。由物类实有。未来亦尔。云何说名过去未来。为前不已说耶。谓诸世由功能所安立。若尔正现世非等分眼根。有何功能感果与果。复次是未来同类等因。由正感果故。已立有功能。或立半功能。是故立世相相杂。复次此义应说。谓此法由自体恒有。应恒作功能。偈曰。何碍。释曰。何法为碍。由此碍故。是法有时作功能。有时不作。偈曰。缘不具。非常。释曰。若汝言因缘不具故。是义不然。由汝执彼体恒有故。复次偈曰。此云何。释曰。由功能为因故。说此法过去未来现世。此功能于汝云何。为更别有功能为无。偈曰。坏悉檀理故。释曰。若汝言。此功能非过去未来现世而有。若尔此功能。由非有为故义至恒有。是故不应说此言。谓是时诸法未作功能说为未来。是时正作功能说为现世。是时作功能已谢说为过去。偈曰。非能不异故。释曰。无如此失。若功能与法异可有此失。由功能与法不异故无此失。若尔终不免本失。谓偈曰。世义则不成。释曰。若汝言。法即是功能。此法由体恒有。云何有时说为过去。有时说为未来。是故安立三世不成。此中何世义不成。若法未生。是名未来世。若法已生未灭。是名现在世。若法已谢灭。是名过去世此中是义汝必应说。若如现世法是实有物。过去未来亦尔者。偈曰。未生灭云何。释曰。若法由自体实有。此言云何成。谓此法未生。此法已灭。于前世何法先不有。由此故说此法未生。复由何法后不有。由此故说此法已灭。是故三世义一切种皆不成就。若不信受此义。谓未有有已有方无。是汝所言。由行相相应故。是法不应成常住。此言一向但有言与生灭不相应故。此法恒有而非常住。此言及理所未曾有。此中说偈

  法体性恒有　　而不许法常
  有法不异性　　是真自在事

是汝等所说。由佛说故。故三世是有。我等亦说过去未来有。过去者。若法昔曾有。未来者若有因法当有。若如此立义可得说有。不由实有故说。何人说如此如现世有。过去未来亦尔若异此云何有。偈曰。由去来体故。释曰由过去未来体故有此言。今复来。云何说名过去未来。是故先曾有因。当应有果。为令他解。欲除彼拨因果邪见故。佛世尊说。有过去有未来。如说有灯先无有灯后无。于世间中有如此言。复有世言。如说有灯已灭非我所灭。说过去未来有言亦如此。若不尔。过去未来义则不得成。是汝所言。佛世尊为杖胜外道说。若业已谢灭尽过坏。此业亦有。为彼不许此业先时已有故。说是有为已许。若尔佛何故为彼更说有。此中佛世尊依自相续。有宿业功能。能与今后二世果报故说此言。若不尔此业由自体性有。则不成过去。此义汝必应然。由佛世尊于真实空经中说。眼根若生无所从来。若灭无所增集。比丘如此眼根先未有有。有已后无。若未来眼根是有则无此说。谓未有有等。若汝执此言。谓于现世中未有有。是义不然。何以故。世与法义不异故。若汝执于自体未有有此义自成。谓未来眼根无是汝所说。由缘二识生故。此言今应思。依意根缘法尘。是所生意识。为如意根于此识作生缘法尘亦尔。为但作所缘境。若诸法为识作生缘。是未来法当来千劫应有。或不有彼法。云何能生今识。复次涅槃能违一切生。云何可立为意识生缘。若执诸法但是所缘境。我等亦说。未来诸法唯是所缘境。若无云何作境界。此中我说。如成境界如此有云何成境界。已有当有。何以故。无有人忆念过去色受等观此为有。何为已有。如人正受现世色。若过去忆念亦如此。如彼于现世应有。诸佛如来见彼亦尔。若彼法如今有。应成现世。若不如今有。是故有缘无法为境识。此义应成。若汝执此法已散是义不然。何以故。已散不可知故。若汝执彼色由邻虚分散。若尔邻虚应成常住。唯有邻虚和合及分散。无有一物能生能灭。汝今便信受裸形外道执而弃舍佛经。经言。是眼根若生无所从来。广说如经。受等非邻虚聚成。云何分散。是彼如正生所受如此忆念。若彼如昔今有。义至应成常住。若不有缘无法为境。此义自成。若无所有亦是识境界。应立为第十三入以摄此境。若无第十三入。此识以何入为境。如此名即是境界。若尔此智应缘名于名作无解若人缘声先无为境。于此人以何法为境。声为境。若尔若人未得无声。此人必应作声。若汝言此境在未来位。是义不然。何以故。此是有于中云何作无解。若汝执未来无现世。是义不然。何以故。此境一故。复次是未来境差别。未有有则成。是故识境界成有二种。谓有及无。若尔菩萨所说经云何。言若法于世间无。我应知我应见无有是处。此证不然。非经意故。经说诸外道起增上慢。定相实未有。彼见已有我今不尔。若定相实有我则见有。此是经意。若不尔。一切智以实有法为境故。疑及简择云何成。复有何差别。复次此义由此证。必定应尔。于余经中佛世尊说。善来比丘。为我弟子。若我朝教汝暮至证胜得。若暮教汝朝至证胜得。若有汝应知有。若无汝应知无。若有上汝应知有上。若无上汝应知无上。是故此言非证。谓由识必有境故。是汝所言。由业有果报故。过去世不无者。此中今共论之。何以故。诸经部师不说。从过去业果报得生。此云何从昔相续转异胜类生。此义于破说我品中当显示。若人执过去未来实有物。于此人果报恒有。于此果报业有何能。若汝说于生有能。若尔生者以未有有义。是故本无今有。此义自成。若如汝所执一切皆有。今于何法何处。应有功能。若执如此婆沙干若义则被随顺。彼言若有必有。若无必无。若无不生。若有不灭。令成现世因有功能。令成现世是何法引至于余处。若尔此法应成常住。若无色于中云何是因引功能。未有有此义自成。若汝执自性差别是因功能。未有有此义亦自然成。是故于说一切有部法中。此义不如道理。谓一切过去未来有。若如经中说。一切有义。若执如此此执最胜。云何经中说一切有。如经言。婆罗门若说一切有唯十二入。或唯三世。若如道理应有必如此有。若过去未来无有实物。云何众生由此于此相应。从彼生以彼为因惑生故。缘彼为境惑随眠生故。故说于此二世类相应是故毗婆沙师说。实有过去未来世。若义证比圣言。可得了达。自爱人于中必应信受。若不尔。自爱人于中应作如此知是法如最甚深。非必定由自思量之所能解。是故不应非拨。有别义是生即是灭。谓色生色灭。有别义别生别灭。谓未来生现世灭。有别义世生。正生世所摄故。从世生。未来世不同刹那故。未来世应有未有。从应有至现有

阿毗达磨俱舍释论卷第十四阿毗达磨俱舍释论卷第十五

        婆薮盘豆造

        陈天竺三藏真谛译

    中分别惑品之二

说世义已。由相应故来。今应思此义。是类已灭众生于中得相离不。复次众生于此类处已得相离。此类为已灭不。于中若已相离。此类于此人必定已灭。若类已灭。于中众生或已相离或未相离。譬如偈曰。灭苦下惑中。由余遍行应。于前类已灭。余同境惑应。释曰。苦智已生集智未生。见苦所灭类聚皆已灭尽。由见集谛所灭缘彼为境。余遍行惑于彼相应。于修道所灭类聚中有九品惑。于先已灭品中。由余惑缘彼为境。于彼相应此义应知。于何类中几惑能缘彼类生。若句句答此问。应说无数法。是故先旧师造略集毗婆沙。彼云。云何。由少功力。我等应度最大问流。若略说有十六种法。谓欲色无色界相应各有五品。及无流心。亦有十六同此类。于中何法为何心境界。若人已了知如此。于中如此多惑缘彼得生。此义方可思量。此中偈曰。见苦集修灭。是欲相应法。自界三一色。无垢识境界。释曰。此法是自界法。有三部故说自界三。此法一部是色界法故说一色。于欲界相应行法。见苦集所灭。及修道所灭。皆是五识境。于自界有三识。谓是前三色界心一。谓修道所灭及无流心。偈曰。自界下界三。上一净识境。释曰。于色界相应行。如前三部法。是八心所缘境。谓自界心三如前。下界心三亦如前。上界心一。谓修道所灭心及无流心。偈曰。无色三界三。无流识境界。释曰。于无色界相应行三部法。是十心所缘境。谓三界心各三如前。无流心一。说三界见苦集所灭及修道所灭已。偈曰。见灭道所灭一切自长境。释曰。见灭道所灭法中是自心。谓见灭道所灭心。此心为长应知。彼法是此心境。云何如此。欲界相应见灭所灭法。唯六识境界谓前所说五识及自长识。见道所灭法亦尔。谓前所说五识及自长识。如此色无色界见灭道所灭法。是见灭道所灭。自长识境界故。是故为九识。及十一识境。说三界五部法已。偈曰。无流三界后。三无流心境。释曰。若无流法为十心境界。谓三界后三部心。即见灭道修所灭心。及无流心。复次为摄此义故。造一偈半

  见苦集修灭　　于三界无流
  五八及十识　　十识所缘境
  见灭道所灭　　一切自长境

已解安立如此十六心。于十六境随眠正事。于中云何思量。我等为安立此义故显唯方。于缘乐根为境识中。几随眠惑依彼得生。若有如此问来。应自思量。乐根有七种。于欲界中唯有修道所灭。于色界五部及无流。此乐根若略说。是十二心境界。欲界四心。除见灭所灭心。色界心有五。无色有二心。谓见道修道所灭心及无流心。如此十二识能缘乐根为境。于中如理。欲界部惑。色界部惑。缘有为境。无色界二部。并遍行诸惑。于中随眠生。应知如此。于缘能缘乐根为境。心中几随眠惑依彼得生。所说能缘乐根为境。十二识复为何识境界。即是前所说十二识类。复次无色界有二部谓见苦集所灭心。是十四心。应知缘能缘受识为境。此中更增无色界见苦集所灭心。欲界有四心。缘有为境。色界有五心。缘有为境。依此十四心随眠惑得生。此义应知。由此方所余亦应知。若由此惑心则有缚。此诸惑于此心中皆随眠不。得随眠。若惑与心相应不灭。及能缘彼为境亦不灭。有不能随眠。若惑与心相应已灭。若作如此义。偈曰。有缚心二种。染无染由眠。释曰。若心有染污。由惑能随眠是故心有缚。及由与心相应。缘彼为境惑由不能随眠。惑与彼相应未灭。互相应故。若无染污心。但由能随眠惑及能缘彼为境。惑不灭为缚。复次十种惑生起云何。从初者由痴相应故。迷闇于谛境。彼人不乐观苦苦相。于彼人不显现。乃至道亦尔。是故偈曰。从痴疑。释曰。若人已痴闻。二义起疑惑。谓此为是苦。此为非苦。乃至道亦尔。偈曰。邪见。释曰。从疑惑起邪见。若人有疑心。由邪闻邪思故。决定邪智起。乃至拨无苦等。偈曰。从身见释曰。彼说从邪见身见生由苦除五阴由我我所执故。偈曰。边见。释曰从身见边见生。由执我断常二边故。偈曰从此戒执取。释曰。从边见戒执取见生。何以故。若人随执一边。由此边计执清净故。偈曰。次见取。释曰。从戒执取见见取生。何以故。若由此法计执清净。必执此法为最胜。于下执胜为见取故。偈曰。自见。欲慢。释曰。于自见爱着心起故。由自见高心起故。是故从自见欲起慢起。偈曰。于他见嗔起。释曰。若人爱着自见。于他见能对治自见。则起嗔恚。有余师说。于自见已取已。舍中起嗔恚。偈曰。如次第。释曰。见谛所灭欲等诸惑。缘依自相续见起故。生起次第如此。若惑欲生起。必由三因缘得起。能起因缘者。偈曰。从未灭随眠。及对根现尘由不正思惟惑起。释曰。惑者譬如欲随眠。此未灭未永离。欲惑相应。尘对根显现。于中起不正思惟。由具三故欲惑得起。此三次第。谓因缘加行力。偈曰。具因缘。释曰。若余惑有具因生。应知亦如此。彼说有时由尘力惑亦生。起不由因。力譬如退法阿罗汉。是随眠惑于经中世尊说为三流。谓欲流有流无明流。或说为四暴河。谓欲暴河有暴河见暴河无明暴河。或说为四系。即是四河或说为四取。谓欲取见取戒执取我言取。于中偈曰。欲界共倒起。烦恼名欲流。离痴。释曰。除无明所余欲界行惑共诸倒起惑。应知名欲流。有四十一物。三十一随眠惑。除五种无明并十倒起惑。此但惑非随眠。偈曰。唯随眠。色无色有流。释曰。除无明言流。一切色无色界行随眠惑。除无明名有流。有五十二物。色界惑二十六。除五部无明。无色界亦尔。于上界为不有疲弱掉起二种倒起惑邪。如分别道理论说。何者为有流。除无明是所余诸惑。与色无色界相应。谓结缚随眠小惑倒起惑。此中云何不摄。罽宾国师云。由不自在故。复有何因缘。色无色界合说一有流。偈曰。无记内门起。依寂静地生。故合一。释曰。是二界惑同无记性。依内门起。依定地生。由此三法等。是故合立为一。由此因立有欲义。更由此因立有流义。今三界无明立为无明流。此义自成。有十五物。云何别立此无明为流。一切流偈曰。为根。立无明别流。释曰。一切流无明为根。是故别立无明为流。如说流应知余亦尔。偈曰。暴河系亦尔。别立见明故。释曰。是所说欲流。即是欲暴河。及欲系。是所说有流。即是有暴河。及有系。除诸见。彼言由了别故。于暴河及系。立见为别品。偈曰。非于流无伴。由非顺流故。释曰。能令流故名流。流等名后当释。彼说若见独无伴。不随顺流。由明了故。是故于流不立为别品。合立为流品。是欲暴河。有二十九物。谓欲嗔慢有十五。疑有四并十倒起惑。有暴河有二十八物。谓欲慢有二十。疑八见暴河有三十六物。无明暴河有十五物。如暴河应知系亦尔。偈曰。如所说共痴。有二分见故名取。释曰。是欲系共无明立为欲取。有三十四物。谓欲嗔慢无明有二十。疑有四。并十倒起惑。是有系共无明立为我言取。有三十八物。谓欲慢无明有三十。疑有八。是见系除戒执取。立为见取。有三十物。是戒执取有六物。云何从诸见中。离戒执取立为别取。由对治圣道故。由欺诳二部故。在家部由此惑遭诳计。执自饿为天道故。出家部由舍离可爱尘。修习苦涩为道。计应得解脱故。欲取及见取者。是在家出家二部斗诤因故。故立为二取。在家由取五尘故。与在家起斗诤。出家由取诸见各不同故。与出家起斗诤。此二部取定及定果。为解脱道及解脱果故。故立二界惑。为我言取。云何合无明说取不别为取。由能取生死故立为取。偈曰。由无明。非能取故合。释曰。无明以不了为相故。昧钝故故不能取。是故共惑合为取。于经中佛世尊说。何者为欲系。广说如经。乃至于欲尘。众生欲染污欲求欲爱欲喜欲欲欲乱欲着欲遍着欲乐欲定欲贪。此欲变异众生心住。说此名欲系。乃至有系等亦如此于余经中说。爱欲亦名取。是故知欲等取。于欲等中唯爱欲为取。此义已说。于经中唯随眠惑说名流暴河系取。复次随眠名有何义。乃至取名有何义。偈曰。微细随逐故。二种随眠故。非功用恒故。故说彼随眠。释曰。此中微细者。行相最细故。故非他可知。随逐者。由至得恒有故。二种随眠者。随流行众生相续中能作二种缚。谓境界缚相应缚。非功用恒故者。若不作功用为生。彼若作对治为遮。彼数数现前故。由此三义故。说彼惑名随眠。偈曰。令住及令流。能牵及能合。能取故说彼。名流暴河等。释曰。令住不护中从六门漏能流生死。从有顶至阿毗指故名流。能牵引众生。令入苦海故名瀑河。能合众生令不离苦故名系。因此众生取欲等及生生具故说名取。又若如此解是为最胜。由彼故相续于六尘中流。故说彼名流。如经言。长老。譬如船由大功用牵引逆流。若舍功用此船随流而去则无复难。诸惑亦尔。由随经文句。应知流义过量猛疾。故说此惑名暴河。何以故。由此惑众生漂逝。唯得随顺不可违逆故。若非过量行名系。能令与种种苦和合故。或数数相应故。能取欲等故。取所生故能。生取故故。名为取。由如此义故说彼名流。乃至名取。偈曰。由结等差别。复说彼五种。释曰。是随眠惑。由结缚随眠染污倒起差别更说五种。此中结有九种。谓随顺结违逆结慢结无明结见结取结疑结嫉姤结悭吝结。此中随顺结者。谓三界欲。所余诸结应如理思。见结者谓三见。取结者谓二见。是故说此言。为有此义不。与见相应法中。但由随顺结相应。不由见结。于中见结随眠非非随眠。说有。集智已生灭智未生。于见灭道所灭法中。与见取戒执取相应。何以故。彼法与随顺结相应。与见结不相应。遍行已灭故。非遍行以彼为境界故。相应见结无有故。见随眠于彼随眠。谓二取见。但由相应故。复有何因。于结中合三见立为别见结。复以二见别立为取结。偈曰。物取平等故。立见为别结。释曰。三见唯十八物。二取亦唯十八物。是故彼言。由物等故。离见立为二结。此二见以能取为性。所余不尔。但是所取。由能取所取差别故。立为二结。云何嫉姤悭吝。于诸结中立为二结。不立余倒起偈曰。由一向不善。由二自在故。于中惑姤吝。别立为二结。释曰。无余倒起惑。如此种性。若二在于此处。此处则一向不善。此二又自在起。不随属他。若人执唯八是倒起。于此人可有如此答。若人立十为倒起。于此人忿恨及覆藏。亦有此二种性。是故此救不成救难。偈曰。无贵重富财。因故遍相故。能损二部故。别立姤吝结。释曰。有余师说于倒起中妒吝。有三重失由嫉妒。得轻贱报由悭吝。得贫穷报如偈言

  无贵重乏财　　非自亲所敬

由忧喜相起故。能显示诸惑相。由嫉姤能损他部。由悭吝能损自部。他得利益事不能忍。故自不能为他作利益事故。是故立姤吝为二结。复有余处。佛世尊说结。偈曰。五种下分结。释曰。何者为五。谓身见戒执取疑贪欲嗔恚。云何说彼为下分结。于下分好故。下分者谓欲界。此五惑于欲界随顺事故好。云何为好。偈曰。由二不过欲。由三更还下。释曰。由贪欲嗔恚。众生不能出离欲界。由身见等三。若已出离。更还欲界。譬如守门及寻叛。复由三不得过下分众生。所谓凡夫众生。由二不得过下分界。所谓欲界。故说此五为下分结。若须陀洹人。由三结灭尽故。六烦恼已灭。何因除三见。但说灭三结。谓身见戒执取疑。若欲说应说一切。今何为偈曰。由执门根三。释曰。诸惑有三类。谓一种二种四种。一切惑门此三能执。复次边见由身见生。见取由戒执取生。邪见由疑惑生。是故彼为能执根。有余师说。偈曰。不欲去乱道疑道是三事是。障解脱行故。说灭。三结释曰若人欲。行于余处。有三种障。一不欲去。二迷乱路。由取异路故。三于路心有疑。若人欲行求解脱。即有如此三障。此中由身见于解脱生怖畏心故不欲去。由戒执取舍圣道取余道故于道心迷乱。由疑惑于世出世道起二道心故不得进。由灭三解脱行障故。得进至解脱道成须陀洹。佛世尊为显须陀洹德故说灭三结。如世尊已说五种下分结。复如此说。偈曰。上分结有五。释曰。复有五结于上分好。云何为五。偈曰。二色非色欲。掉起慢无明。释曰。应知此五是随顺上分结。谓色界欲无色界欲掉起慢无明。由未灭此五。不能得出离上界。故说此五。于上界好分别结义已。何者为缚。缚有三。一欲缚。谓一切欲。二嗔缚。三无明缚。谓一切无明。云何说此三名缚。偈曰。因受说三缚。释曰。由随属三受故说三缚。何以故。于乐受欲缚随眠。由缘缘及由相应故。于苦受嗔。于不苦不乐受无明随眠。欲嗔不尔。复次以自相续为境界故。定如此随眠。义于前已释。小分惑今当说。是大分惑。应说名烦恼。能染污心故。小分惑亦尔。何者为小分惑。偈曰。余染污心法。说名为行阴。于烦恼小分。说彼非烦恼。释曰。有染污余法异大烦恼。是行阴所摄。是心相应法。说名小分惑非是大惑。是彼于粗类中所说。此中倒起。烦恼垢所摄。我今当说。何法为倒起。烦恼亦名倒起。由经中说。欲欲倒起所变心。于分别道理论说。偈曰。无羞及无惭。姤吝及掉起。忧悔疲弱睡。倒起惑有八。及忿覆。释曰。若随毗婆沙道理说。有十种倒起。八如前。并忿恨及覆藏为十。此中无羞无惭。于前已释。于他圆德心不安喜名嫉姤。与法财施聪解相违心执名悭吝。心散不静名掉起。忧悔疲弱于前已释。于持身无能。心细昧名睡。安立彼必有染污。忧悔亦尔。除嗔恚及逼恼。于众生非众生心逆名忿恨。隐秘可诃名覆藏。是十种倒起惑。偈曰。欲生。无羞掉起吝。释曰。此三小分惑。是贪欲等流。偈曰。于覆诤释曰。有余师说。覆藏是爱欲等流。有余师说。是无明等流。有余师说。是欲痴等流。次第已知。未知偈曰。痴生疲弱睡无惭。释曰。此三小惑是无明等流。偈曰忧悔从疑生。释曰。若人于义不了故。疑必生忧悔心。偈曰。忿姤嗔恚流。释曰。此二小惑从嗔恚生。如此十种。由大惑流故说名小惑。偈曰。复余六惑垢释曰。复有六种小惑。说名惑垢。谓偈曰。诳谄醉如前。不舍及结过。逼恼。释曰。此中于他假伪名诳心。邪曲名谄曲。此惑不能如实显自意。作方便为避不分明信受。于前已释。醉亦如前释。坚执有何类说名不舍。由此惑如实所教不受正教。数思忿心所缘事名结过。损辱他意名逼恼。由此惑故。行打骂等事困苦于他。此六种惑垢中。偈曰。从欲生。诳醉。释曰。此二小惑。由自爱故欺诳。及不计他故。是欲等流垢。偈曰。嗔恚生。结过及逼恼。释曰。此二小惑。于他损心所生故。故是嗔恚等流垢。偈曰。从见取不舍。从见谄曲生。释曰。若人于戒执取起见取。此人有二僻执。如理教舍。由此二见不能舍此僻执故。是二见等流垢。如偈言

  何法名邪曲　　谓邪见等见

是故谄曲是诸见等流垢。于中何惑何道所灭。前所说十倒起惑。偈曰。此中无差惭。疲弱睡掉起。有二。释曰。是五法有二种。或见谛所灭。或修道所灭。与二部惑相应故。此惑随与见谛所灭相应。即由见此谛灭偈曰。余修灭释。曰余。倒起惑异此五。必定修道所灭。谓嫉姤悭吝忧悔忿恨覆藏。偈曰。及自在惑垢。释曰。此五小分惑。唯与无明相。应故如嫉姤等。五小分惑修道所灭。自在惑垢亦尔。是六种惑垢。由自在故。修道所灭。如前所说。一切小惑。偈曰。于欲恶。释曰。若在欲界皆悉是恶。偈曰。三二。释曰。疲弱掉起睡。或恶或无记。偈曰。上界彼无记释曰。从欲界上。随所有小分惑。皆是无记。于中几惑于何界有。应知偈曰。诳谄从欲界。初定。释曰。此二惑于欲界及初定有。云何知于梵处有欺诳。偈曰。梵诳故。释曰。于色界大梵王。由不如显示自体故。欺诳净命阿输实。于前已说。谄曲由义相应今更说。于中亦说有谄曲。由相应至故。偈曰。疲掉醉三界。释曰。此三小惑于三界皆有。偈曰。余惑唯欲界。释曰。于十六中除五惑。所余十一小惑但行于欲界。说惑及小惑已。于中几惑依意识地起。几惑依六识地起。若略说。偈曰。见灭及慢睡。依意识地生。释曰。一切见谛所灭惑皆依意地起。慢睡亦尔。若此二修道所灭。何以故。此具起于心地。偈曰。自在小分惑释曰。随有小分惑自在起若是修道所灭应知。亦依心地。起偈曰余依六识。起释曰。所余大惑及小。惑应。知依六识地。起何。者为余修道所灭欲嗔无明及余小分惑。与欲等相应。又无羞无惭疲弱掉起。及余于惑大地所说。是前所说。乐受等五根。于中与何根有何惑。及小惑相应。偈曰。欲与喜乐应。释曰。如理应知。欲与乐喜二根相应。偈曰。嗔与忧苦应。释曰。嗔与苦忧二根相应。何以故。此二惑由欢喜忧恼相起故。由六识为地故。偈曰。无明一切应。释曰。无明与一切惑相应故。是故与五根相应。偈曰。邪见忧喜应释曰。邪见依心地起故。是故与忧喜相应如次第于有福行无福行人。偈曰。疑忧应。释曰。若人有疑心求得决知。是故由疑生忧。偈曰。余惑与喜应。释曰。所余诸惑与喜相应。何者为余。谓四见慢。由欢喜相故。如此分判已。诸惑与何界相应。偈曰。欲生。释曰。于欲界生诸惑。应如此判。说决定相应惑已。通相应今当说。偈曰。一切与舍应。释曰。一切随眠惑与舍根相应。相续断时。彼说诸惑必定依舍受起。若尔上地惑云何判。偈曰。随自自如地上地惑相应。释曰。上地诸惑与自受根。相应若于彼地随根量多少。如于彼地。若惑依四识地起。如理应知。与四识地受相应。说随眠惑与根相应已。小惑相应今当说偈曰。忧根应忧悔。嫉姤忿逼恼。结过不舍耶。释曰。如此等惑与忧根相应。缘忧恼相起故。依意地起故。偈曰。悭吝翻此义。释曰。此惑与喜根相应。由是贪爱等类故。缘欢喜相生故。偈曰。欺诳及谄曲。覆藏睡三种。释曰。此四惑与喜忧二根相应。何以故。有时心欢喜欺诳他有时忧恼心。乃至睡亦尔。偈曰。醉喜乐。释曰。若醉在第三定。与乐根相应。若在下地与喜根相应。若在上地与舍根相应。何以故。偈曰。舍遍释曰。一切小分惑与舍受相应。何以故。舍根无遮处譬如无明。偈曰。余四五根应释曰。无羞无惭疲弱掉起。此四惑与五根相应。属恶大地故。属惑大地故。经中所说五盖谓贪欲嗔恚睡弱掉悔疑。于此中为并取三界所摄睡弱掉悔疑。为但取欲界所摄。是无杂圆满恶聚是五盖。由经中说。彼一向恶故。偈曰。欲界中五盖。释曰。于余界不立五盖故唯欲界中有五盖。复有何因。立睡弱二小惑为一盖。合掉悔亦尔。偈曰。一对治食事。合二一。释曰。此二双同一对治故。同食故。同一事故。故合为一。经中说。睡弱一食一非食。何法是睡弱盖食。有五种法。谓惓不安频申不节食心沉下。何法非睡弱盖。食谓光明想。彼事亦一。谓此二小惑。能令心沉下。掉悔二小惑。亦说同一食同一非食。何法是掉悔盖食。有四法。亲属觉。国土觉。不死觉。数忆昔所更事。谓游戏安乐给侍。何法非掉悔盖食。谓奢摩他。此二亦同一事。何以故。此二同能令心不寂静是故同一对治食事故。合二立一盖若一切惑皆是盖。云何唯说五为盖。偈曰。能破法聚起。疑故。释曰由贪欲嗔恚盖。戒法聚破坏。由睡弱盖。慧法聚破坏。由掉悔盖。定法聚破坏。若定慧无则。于四谛起疑惑心故。解脱解脱知见破坏。由此义故。说五为盖。于此执中与定法聚相违。掉悔盖应在慧障前。是故余师说。如其次第能破定聚及慧聚。何以故。经中说。若人修行定观。怖畏睡弱若人修行简择法。怖畏掉悔。有余师释。盖义有异。云何释。若人在六识行位。于可爱可憎相尘中。由执相故。若在住位。是贪欲嗔恚。以彼为先因故起障。初正欲入定相心。次若已入定。不如理修奢摩他毗钵舍那。故起睡弱掉悔疑。如次第障奢摩他毗钵舍那。故解脱解脱知见不得成。是故说五为盖。今应思此义。是遍行不同分界惑。见灭道所灭。缘有流法为境诸惑。是时若观察彼境。是时彼不灭。是彼灭时。彼境不可观察。由此义。彼云何可灭。非必定。唯由了别境界诸惑得灭。何为由四种因诸惑得灭。何者为四。若约见谛所灭惑。由三因。偈曰。由了别。彼境。能缘境灭故。境界惑灭故。释曰。此中由了别彼境者。谓见苦集所灭惑。能缘自地起。及缘无流法为境。能缘境灭。故者谓遍行不同分界惑。何以故。遍行同分界惑。是彼境。若所缘为境。惑灭能缘亦同灭。境界惑灭故。彼灭者谓见灭。道所灭惑。缘有流境起。何以故。缘无流境起惑。是彼境界。此惑若灭彼亦同灭。修道所灭惑。云何得灭。偈曰。对治起故尽。释曰。此惑品若是对治道起。此惑即灭。何惑是所对治。何道是能对治。最上上品惑是所对治。最下下品道是能对治。此义后当广说。此对治有几种。偈曰。灭持能远离。厌恶对治四。说次异。释曰。一灭对治。谓无间道。二持对治。谓次此后道。由此道能持前道所得灭。三远离对治。谓解脱道。后所有诸道。能令已断灭惑至得远相离故。有余师说。此即是解脱。此道能令惑至得最远相离。四厌恶对治。谓由此道观察诸界所有过患。于中起厌离心。复次四对治应如此次第。一厌恶对治。谓缘苦集所修方便道。二灭对治。即是前无间道。三持对治。即是解脱道。四远离对治。谓胜德道。若惑正灭。何处可灭。偈曰。应除。惑于自境界。释曰。何以故。诸惑若正灭。不可令与相续相离相应。处不可知故。可令与境界相离。由此惑不能更缘境生。若尔未来烦恼。可令与境相离。若已过去。云何可令与境相离。若汝言。由了别境界此惑可令相离。此义不必可定。是故应说此义。有几量应说此惑已灭。若惑依自相续生。由至得断绝。若惑依他相续生。一切色及一切无染污法。能缘彼等为境。自相续惑灭故。说彼永所远离。若尔远义有几种。偈曰。相异对治故。各处别时故。四大戒处所。世二如远义。释曰。相远者。譬如四大。由相不同故。虽共生说互相远。对治远者。譬如戒于破戒。破戒于戒亦尔。处远者。最相去远法。由处各别故说名远。譬如东西海。时远者。譬如说过去未来为远。此二于何世远。于现世若无间已灭。及向生。于现世云何远。由世别异故远。不由久已灭及久方生。若尔亦应立现世为远。不尔。由约功能故说远。若尔无为近义云何成。于一切世中有至得故。若尔于过去未来。亦应如此。虚空复云何。若尔过去未来更互远现世所隔故。现世于二近故成近。无为法无隔故近。若尔过去未来于现世近故。应具二义。若作此执。是义可然。于法自体相未来世远。未得至故。过去已谢灭故远。由急恒修故。进胜道诸惑灭。亦渐渐转胜为。不尔无如此。何以故。偈曰。诸惑同一灭。释曰。彼惑若应灭。此道若是彼灭道。由此道彼则同一灭。偈曰。重得彼永离。释曰。有几时中重得说于六时。何者为六。偈曰。对治生得果。练根六时中。释曰。对治生者。此义中谓解脱道。得果者。谓四沙门果。练根者。谓修增胜根道。于此六时中数得诸惑永离。此得应如理知。有余人于六时得有余人。乃至二时得此永离。于别别位中得永断智名。永断有二种。一智永断。二灭永断。智永断谓无流智。灭永断唯灭。合此名永断智。于果说因故。为一切灭悉是永断智不。说云何为。偈曰。永断九。释曰。云何九。此中偈曰。欲界。初二部惑灭一。释曰。于欲界中初二部惑灭离。谓见苦集谛所灭惑为一永断智。偈曰。后二灭离二。释曰。于欲界见灭所灭惑灭离为二。见道所灭惑灭离为三。如欲界相应见谛所灭惑。有三永断智。偈曰。上三亦尔。释曰。色无色界相应见谛所灭惑灭离。立三永断智亦如此。见苦集所灭惑灭离为一。见灭所灭惑灭离为二。见道所灭惑灭离为三。如此三界见谛所灭惑灭离。成六永断智。偈曰。所余下分色。一切惑灭尽。更三永断智。释曰。下分惑灭离为一。色流灭离为二。谓色欲永断一切流灭离为三。谓一切结灭尽永断。云何色无色界修道所灭惑灭离。立为别永断智。见谛所灭不尔。修道所灭惑对治不同故。如此九永断智。于前偈曰。六忍果。释曰。见谛所灭惑灭离为性。是八忍果。偈曰。余智果。释曰。下分惑灭离等。三永断智。是修道果故。说名智果。若尔云何说为忍果。由忍是智伴类故。是故约忍说智事。譬如于王伴类说王事。复次与智同果故。偈曰。非至果一切。本定。五或八。释曰。若约毗婆沙意判。一切九品永断智。是非至定果。何以故。依此地能灭三界见修所灭二部惑故。若论根本定果有五。谓色无色界相应惑灭离为性。一切欲界惑灭离。是非至定果故。大德瞿沙意云。八永断智是根本定果。何以故。此师意明。已离欲人若入四谛观。一切欲界见谛惑灭离。是见道果。依此定成因。此定得无流相离果故。此永断智属此地果。下分惑灭离。但是非至定果。中间定应知如定。若约无色定。偈曰。无色定果一。释曰。空遍入道果。是一永断智。谓离欲色界永断智。偈曰。本三无色一。释曰。根本三无色定。唯一永断智为果。谓一切结灭尽为果。偈曰。圣道果一切。释曰。九永断智皆是圣道果。偈曰。世道二。释曰。若约世道论。下分惑及色界惑灭离。此二永断智。但是世道果。偈曰。类尔。释曰。类智果亦有二。谓最后二。偈曰。法智三。释曰。法智由通能对治三界修道所灭惑故。以最后三永断智为果。偈曰。二类。六五永断智。释曰。法智类道以六永断智为果。谓法忍法智果类智类道。以五为果。谓类忍类智果。由说类故。通摄忍及智。云何不立一灭离为永断智。由安立忍果为灭故。是故偈曰。得无流离故。损有顶分故。拔除二因故。断智。释曰。若于灭中具有三因。可说为永断智。凡夫无有由无流得灭离。亦无损有顶分。是故凡夫所得灭。不名永断智。若圣人有忍果灭。于此灭中乃至在苦类忍。有无流永离至得。未有损有顶分。于苦类智具有此二义。无拔除二因义。见集所灭遍行因未灭故。于余法类智中。具有三义。是故于此位中所有灭离。得永断智名。此灭是智果。由前三因及第四因。说名永断智。偈曰。过界故。释曰。若人出离界。由离欲一切界故。得二结相离。彼说是第五因。若于中与能缘。彼为境别惑相离。此义可然。此出离界不异拔除二因故。是故不须立出离界义为第五因。何人得几永断智相应。偈曰。无与一至五。在见位相应。释曰。凡夫人与永断智无相应。若圣人在见谛道中。乃至在集法忍。亦不与此相应。于集法智与一相应。于集类智与二相应。于灭法智与三相应。于灭类智与四相应。于道法智与五相应。于道类忍亦与五相应。未离见位故。偈曰。住修复与六。乃至与一二。释曰。若圣人在修位中。谓道类智等与六相应。乃至未离欲欲界及已退。次从此位。若至离欲欲界位。或前或后。与一下分惑灭离永断智相应。若至阿罗汉果。更与一相应。谓一切结永断智相应。若退由色界上心惑。但与一下分惑永断智相应若至离欲色界位。与二相应。谓与下分惑及色界惑永断智相应。若退由无色界上心惑。亦但与此二相应。何因唯阿那含。及阿罗汉。安立与一一永断智相应。不立与多相应。由此义偈曰。算彼由离界。及至沙门果。释曰。由二种因计算。永断智安立为一。何者为二。由离欲诸界及得沙门果此二位中。具有二因。是故合一切灭离。立为一一永断智。复次何人舍几永断智及得亦尔。偈曰。有人舍一二。五六无得五。释曰。舍一者。若从阿罗汉果退。及从离欲欲界退。舍二者。阿那含人。离欲色界已后退离欲欲界。舍五者。若人先已离欲欲界。后在道类智位。何以故。此人得下分惑灭离时。舍前五永断智。舍六者。若人次第修。由离欲欲界。如舍得亦尔。有人得一。若人得未曾得。有得二。若人退无色界离欲有得六。若人退阿那含果无退六还得五。论永断智竟

阿毗达磨俱舍释论卷第十五阿毗达磨俱舍释论卷第十六

        婆薮盘豆造

        陈天竺三藏真谛译

    分别圣道果人品第六之一

此义已说。谓如灭得名永断智。复次此义。偈曰。烦恼灭已说。由见修四谛。释曰。诸烦恼有二种。一由见谛所灭。二由修道所灭。此义于前已广说。彼灭亦尔。见修二道今当说。此二道为是有流。为是无流。是故说此言。偈曰。修道有二种。见道唯无流。释曰。云何修道有二种。由依世修及依出世修故。见道一向是出世。能对治三界惑故。复能一时灭见谛所灭九品惑故。何以故。世道无如此能。由惑强道弱故。前已说由见四谛。何法名四谛。偈曰。已说谛有四。释曰。何处说。于分别有流无流法中。云何说。如偈言。无流法圣道。此约自名说。灭谛亦已说。如偈言。择灭谓永离。各各对诸结。苦谛集谛亦已说。如偈言。苦集谛世间。见处及三有。四谛次第为如前所说不。说非。虽然复有别义。偈曰。谓苦谛集谛。灭道谛亦尔。释曰。此中是彼次第。如前所说。四谛体性。今说亦尔。为显此义故有尔言。不复重释。偈曰。对正观次第。释曰。若观先缘此谛起。依观立此谛为先。后三亦尔。若不尔应先说因次后说果。何以故。有余法随生立次第。譬如念处及定等。有余法随显相说次第。如说正勤。何以故。无此定义。谓先起欲为灭已生。后起欲为令未生不生。有余法随正说立次第。譬如八分圣道等。今说四谛。随修对正观次第。复有何因。修观有如此次第。是爱着处于处能缚。能所缚解脱。因此求解脱。观察位中初发观次第如此故。先简择苦。此苦以何法为因。故次简择集。此苦以何法为灭。故次简择灭。此灭以何法为道。故次简择道。譬如先观病次寻思病因缘及灭病药。于经中。佛世尊所显。四谛譬如此于何经中。医譬经中。经言。若医与四分德相应。能拔治他刺。何者四分德。一识病。二识病因缘。三识病灭。四识治病药。广说如经。如观察位中次第。简择四谛。修观位中。见四谛次第亦尔。由先习利故。譬如于己所见地无碍纵马令走。对正观者。此句何义。趣向正觉为义。云何此唯无流非有流。由此趣向于涅槃缘真实境起故名正。未曾知知故名觉。如实能通清净境故。此中是果取阴名苦谛。因取阴名集谛。从此聚集苦生故。是故此二谛。由果因义异故名有异不由物异。灭道二谛不但由名异。亦由物异。于经中说有四圣谛。此说有何义。此法唯是圣人谛。是故经说名圣谛。若尔此四于余人是妄。不于一切人皆是谛。以无颠倒故。此中如圣人观。彼余人不能如此观故。说此唯于圣人是谛。于非圣人则非。由颠倒观故。如偈言

  圣人说是乐　　余人说为苦
  余人说是净　　圣人说为苦

有二谛唯圣谛。有三谛圣非圣谛。余师说如此。若受一分是苦自性。云何说一切有为有流皆名苦谛。偈曰。苦由三苦应。如理皆无余。可爱非可爱。及余有流行。释曰。苦类有三。一苦苦类。二行苦类。三坏苦类。无余与二苦如理相应故。是故一切有为有流皆是苦。此中可爱由坏苦故苦。非可爱由苦苦故苦。异此二所余由行苦故苦。何者为可爱非可爱非二。谓三受如次第。由三受相应故。一切有为有流。得可爱非可爱等名。何以故。此乐受变异即是苦。如经言。乐受生时乐。住时乐。坏时苦。苦受由性故苦。谓生时苦住时苦。不苦不乐受。由行故苦。因缘所生起故。如经言。若无常即是苦。如受与受相应有为法。亦应说如此。有余师说。苦受唯由苦类故苦。乐受唯由坏故苦。乃至行苦亦尔。由可爱非可爱不遍故。故此二名不具分苦。一切有为由行苦故皆是苦。前二受亦由行苦故苦。故此一名具分苦。此苦唯圣人能见。此中说偈

  譬如一睫毛　　在掌人不觉
  此若落眼中　　作损及不安
  凡夫如手掌　　不觉行苦睫
  圣人如眼睛　　由此生厌怖

何以故。凡夫众生于阿毗指五阴生苦怖意。亦不及圣人于有顶诸阴生苦怖意。若尔于道谛应立行苦义。由是有为故。是义不然。何以故。苦是违逆意为相。故道非苦。何以故。此道生起。不违圣人意故。能引得一切苦灭尽故。若圣人由寂静相观察涅槃。是法由苦相圣人观之为苦。唯此法灭圣人观为寂静。于诸法中若有乐受。云何说唯苦圣谛。由乐少故。譬如乌豆聚中亦有绿豆而说为乌豆聚。余师说如此。何以故。何智慧人。由以冷水稍稍浇痈所生轻乐。计痈为乐。此中余部师说偈

  由能为苦因　　与众苦杂故
  由苦所爱故　　故说乐为苦

一切有苦乐圣人观为苦。由行苦同一味故。是故立苦为圣谛。不立为乐。云何以苦相。观喜乐自性受为苦。由有流无常能违意故苦。譬如彼以苦相观色想等。色等亦非苦如苦受。是汝所言。由苦因故苦。是义不然。何以故。此执是集相非苦相。诸圣人于色无色界生中。云何起苦想。何以故。于彼众生五阴非复苦因故。复次于经中说。行苦何用。若圣人于乐由无常故观苦。无常相苦相有何差别。由生灭为法。是故无常。由有流能违意。是故为苦。若见无常此所见即能违意。是故无常想能引苦想。有余部说。决定无乐受一切受唯苦。云何知然。由阿含及道理。云何由阿含佛世尊说。随所有受皆是苦别名。复有别说。应以苦相观乐受。复有别说。于苦计执乐想说名颠倒。由阿含证如此。云何由道理。乐因不定故。何以故。随所有饮食冷热等。众生计为乐因。若过量用非时用。此因复成苦因。此义不应然。谓由乐因增长。或由平等于非时悉皆生苦。是故彼从初皆为苦因。非是乐因。后时此苦渐渐增长。方得显了。威仪差别亦应如此。于苦对治。及于苦差别。由起乐想故。何以故。随世间所有饮食等生具。乃至未为别苦所逼。若受则不许为乐。别苦者。谓饥渴寒热疲惓。爱欲所生苦。是故愚人于苦对治起乐想。非于乐于苦差别亦尔。一切凡夫于中起乐想。譬如担重易肩。是故由此道理。定知无乐。阿毗达磨师说决定有乐。此执应理。云何知然。此中应问拨无乐人。何法名苦。若汝言逼恼为体名苦。此乐云何逼恼。若汝言。损害为苦。乐能增益。云何损害。若汝言非所爱为苦。此即是所爱云何为苦。是所爱后于圣人更非所爱。谓于离欲时。是故此乐不成就。不成就故非所爱。不由余义。何以故。若受由自体性是所爱。此受由自体性。无时无因成非所爱。此义应然。何以故。由圣人以别过失相厌恶此受故。彼观此受。是放逸处。大功力所成易变异无常。由如此义故。非所爱不由自体相。若此受由自体本非所爱。于中无有人生起爱欲。不应为离欲。此受以别道理观察过失。是故知由自体相定有乐受。是汝所言。佛世尊说。随所有受皆是苦别名。此经世尊自显了其义。经云阿难陀。我依诸行无常及有为变异故说。随所有受皆是苦别名。是故知不依苦苦说此经。此义自然成。复次若由自性。一切受皆是苦。何用净命。阿难陀问佛如此。问云何世尊说。受有三种。谓乐苦不苦不乐。世尊复说。随所有受皆是苦别名。世尊依何义说此言。谓随所有受皆是苦别名。若如汝所执。是理净命。阿难陀应问佛如此。世尊依何义说此言。谓受有三佛世尊应答阿难陀言。阿难陀此说是由别意说。谓受有三。佛世尊既不说如此。是故由体性实有三受。故知此经言依别意说。谓随所有受皆是苦别名。是汝所言。应以苦相观乐受。是义不然。何以故。此受中有二性。一有乐性。由自性是所爱故。二有苦性。由别道理。是变异无常法故。若以乐相观此受。则生他系缚。由有欲众生乐啖此味故。若以苦相观此受。则能解脱。有缚众生由于此得离欲故。如理所见能令解脱。诸佛世尊随如此理。善教众生令修学此观。云何得知。此受由自性故乐。由此偈言

  已知行无常　　复观彼变异
  故说诸受苦　　正遍觉智者

是汝所言。于苦计执乐想。说名颠倒。故知无乐。是义不然。何以故。此言是不了义说。世间有乐想。于受欲尘及生处中。此中乐受。由别道理有苦。若见此一向乐。是见名颠倒。欲尘少乐多苦。一向观有乐名颠倒。生处亦尔。是故由此证拨无乐。此义不成。若由自性一切受皆苦。复说受有三。此言有何功德。若汝言由随顺世间故说。是义不然。何以故。一切受皆苦。此言由别意说故。复次由说真实言。如经云。是乐根是喜根。应见此名乐受。是苦根是忧根。应见此名苦受。如此广说已。若人如此。由如实正智观察五根。此人即灭离三结如此等。云何世间分别苦受有三品。若汝言于下上中品中。如次第世间起乐受等意。是义不然乐亦有三品故。于轻品得苦中。应起最上品乐意。若人正受香味触等胜类所生乐。是时受何苦。正受轻苦。于轻苦中起乐心。若尔此轻苦受未生时及灭时。应生最上品乐意。由苦灭无余故。欲尘乐现前时。应说如此。复次此执云何与理相应。谓于轻品苦受中明了最重领起。于中品苦受中而不分明。复次于三定乐受是轻苦。从第四定以上非苦非乐受。是中苦此执云何如理。谓于轻品等苦中分别乐受等。佛世尊说云。摩诃那摩。若色但苦非乐。非乐所随。广说如经。是故知有乐受。但不成就。不可由如汝所引经无乐受义得成。是汝所言。由乐因不定故无乐。是义不然。由不解因义故说此言。何以故。诸尘观依止位差别。成为乐因。或成苦因。不但唯尘。若至此依止位差别。诸尘必成乐因。无时至此不成乐因。是故可立乐因为定。譬如火势。观应熟饮食位差别成为美熟因。此火势即是美熟因。若至此应熟饮食位差别必成美熟因。无时至此不成美熟因。于定中乐因云何不定。是汝所言。于苦对治由起乐想者。是义不然此执于前已破。若人是时正用胜品香等。差别所生乐受。是人于对治中生乐想。若此苦未生及以灭。此乐想应最分明起。于定乐中若生乐想。是何对治。于担重易肩中别位所生必有乐受。乃至如此相身位未灭。若不尔最后乐想。应最重起。如此疲极人转威仪中。应知亦尔。是汝所言。后时云何起苦想。若不从初渐渐生苦。是义不然。由身变异差别。譬如酒等初味甜后味酢。是故乐受定有。此义应成。由三苦相应故。一切有流皆苦。是所说集谛即是苦谛。此言与经相违。何以故。于经中说唯贪爱为集。由贪爱胜故。经中说为集。不拨所余诸法为集。此义云何可知。由于余处亦说别法为集故。佛世尊说偈云

  业贪爱无明　　此三于未来
  能为诸有因

复有经说。五种种子类。是有取识别名。地界是四识住别名。是故经中此言。由别意说。故不了义。阿毗达磨教中。言依法相。复次佛世尊。欲说有为法相续恒有因故。说贪爱为集。佛欲说生因有因故。于偈中说余法。谓业贪爱无明。如经言。业于生是因。贪爱于有是因。复次由经中有因有缘有发起次第故。佛世尊安立种子及田。说识等亦为因。何法名生。何法名有。界道生等品类差别故。取此身名生。无差别接续后有说名有。此二次第以业及有爱为因。譬如舍利麦等种子。由品类有差别故。能为差别芽生因。水等无差别故。通能为一切芽生因。业及贪爱譬喻如此。贪爱为有因。此中有何道理为证。无贪爱人不受生故。何以故。有爱无爱二人俱死。唯见有爱更生。不见无爱更生。由离贪爱无生故。是故知贪爱为有因。复次由转变相续故。若是处中有贪爱见心相续于彼数数转变。是故于未来中由比量应知亦如此。复次更无余惑能执取此身。犹如贪爱。譬如浴散分中燥摩须罗屑。无有余因如此坚着。如我爱此即道理。有处佛世尊说谛有四。有处说谛有二。谓俗谛真谛。此二谛何相。偈曰。若破无彼智。由智除余尔。俗谛如瓶水。异此名真谛。释曰。若物分分被破。物智则不起。此物名俗有。譬如瓶等。此瓶若破成瓦。缘此瓦瓶智则不起。是故瓶等。诸物由形相假有。复次于此物中由智析除余法。此物智亦不起。此物名俗有。譬如水等。此水若由智析除色大等法。水智则不起。是故水等诸物。由聚集假故有。由名句字门显示真实义。缘名句字于真义起智。若入观时不能缘名等。若出观时不能缘真义。是故名等及此智。由显示假故有。于此三法以何法为俗。但名所作无体是俗。由随顺世间。说有瓶水名等。称为实语不说为妄。是故立此为俗谛。离此三所余名真谛。若物分分被破。物智起不异。若由智析除余法。物智亦不异。若离名等。于境界智亦不异。说此法名真实。譬如色等。若约邻虚析此色。及由智除味等余法缘色智起不异。如色受等。应知亦尔。此名世间真谛。如此等法由于世间实有故故立为真谛复有余师说。若法是出世智所缘。或是出世后智所缘。如此亦说名真谛。谓境界真果真道真。若余法异此三。说名俗谛。略说诸谛已。若广说应知。如六胜智论说。修何方便能入四谛观。应说此义。是故从初发行次第今当说。偈曰。住善行有闻。思后学修慧。释曰。若人求欲观四谛。从初先学持戒。次取学随顺四谛观文句。次听文句正义。听闻已如理正思义。无倒思已。后修习观行。令成修慧。此人依闻慧生思慧。依思慧生修慧。此三慧何相。偈曰。名二义境界。闻思修三慧。释曰。彼言闻慧。缘名为境。思慧缘名义为境。有时由文句引义。有时由义引文句。修慧但缘义为境。何以故。此慧已成故。不观文字。唯缘义起。譬如有人未曾学泅。不离浮物。若已学未成。或离或捉。若学已成。不依浮物。自能得渡。三慧譬如此。毗婆沙师说如此。于此分别中。思慧不成就。若思缘名起。则成闻慧。若缘义起。则成修慧。若立三慧相。如此则无过失。依圣言量。所生决定智名闻慧。依圣教简择道理。所生决定智名思慧。依三摩提。所生智名修慧。此三慧皆约因得名。因闻生名闻慧。思修慧亦尔。譬如说食为命。说草为牛。若人勇猛求得修观。此修观云何得成。是故应说此义次第。偈曰。有二离人。释曰。若人由身由心。能远离住。谓远离群杂及盖觉观等恶法。此二远离。于何人可易善成若人有知足有少欲。偈曰。无。不知足大欲。释曰。若人不知足有大欲。于此人此二远离。则难得成。若成亦不清净。此不知足及大欲。别相云何。偈曰。前已得求多。后未得求得。释曰。彼说已得可爱衣服等缘。更求多得。说名不知足。求得未得。说名大欲。阿毗达磨师说如此。为不尔耶。此求多得。于未得起。非于已得。若尔此二何异。汝等应说。若执如此。是义可然。由已得非可爱非多衣服等缘。心忧不安。说名不知足。未得可爱及多求得。说名大欲。偈曰。翻此二对治。释曰。翻此不知足及大欲。应知二种法为对治。谓知足及少欲。偈曰。或三界无流。释曰。此二种对治。或属三界。或属无流界。不知足及大欲。唯属欲界。此知足少欲。自性云何。偈曰。无贪类。释曰。无贪善根为性。偈曰。圣种。释曰。是知足少欲。无贪为性故。是故入圣种摄。由圣人从彼生故。说彼为圣种。是圣种已无贪为性故。偈曰。前三知足体。释曰。前三谓随得衣服饮食住处知足。此三知足。是前三圣种体。第四圣种。谓修灭乐戏。云何此第四。以无贪为性。由背有欲生故。复次由四圣种。佛世尊显示何义。偈曰。后显业三生。释曰。佛世尊既为法主。弟子弃舍生具及业基出家。依佛求解脱。法主立二正事。一生具二业基。由前三圣种。安立生具。由第四圣种。安立业基。依此生具。汝等作如此业基。不久应至得解脱。云何法主安立如此生具及业基。偈曰。爱生对治故。释曰。于经中说贪爱生有四。如经言。比丘因衣服贪爱欲生生。欲住住。欲取取。因饮食及住处。贪爱欲生生欲住住。欲取取。比丘因如此有非有。贪爱欲生生。广说如经。为对治此四种贪爱故。说四圣种。偈曰。我所我类爱。为暂永除灭。释曰。是前所说义复有别意。故须更说。我所类谓衣服等三。我类谓自身。于此二生爱。此中为暂灭我所类爱故。立前三圣种。为永灭四爱。谓我所类爱。我类爱。故立第四圣种。此义已说。由因此义。观行人得善调伏。后修观得成。若人已调伏。堪为道器。于修中缘何法门。得入修观偈曰。入修由二因。不净观息念。释曰。何人因不净观入修。何人因阿那波那念入修次第。偈曰。多欲多觉观。释曰。若人欲行恒起或重起。此人由不净观。得入于修。若人由多觉观行。起散乱心。此人由阿那波那念。得入于修何以故。此念由不缘多种境故。是故生起能作灭离觉观对治不净观。由缘多种差别色形为境能引生觉观。余师说如此。又余师说。由不缘外门起故。不生觉观。不净观如眼识缘外门起故。引生觉观。由观察彼境故。此中欲有四种。一色欲。二形貌欲。三触欲。四威仪欲诸师说。为对治第一欲。修观行人。应缘坏黑等色为境作不净观。为对治第二欲。应缘膖胀被食分散为境作不净观。为对治第三欲。应缘赤筋相连骨为境作不净观。为对治第四欲。应缘不动死尸为境作不净观。诸师说。若欲修通对治。偈曰。骨观通欲治。释曰。于相连骨聚中四种欲境品类皆悉不有。若缘此骨聚为境修习不净观。通能对治四种欲。由不净观皆假想。一处思量为体故。不能永灭诸惑。但能伏灭诸惑。观行人修习不净观有三种。一初发观行。二已数习成行。三已过思量行。此中偈曰。骨量遍至海。增减名初发。释曰。若观行人。欲修习不净观。从初于自身分中。安置于心。或在脚指。或在额上。随所乐处。心已随事。后于身分作假想。除皮肉血等。次第治骨令净。心见具足骨聚相。如见一骨聚假想见第二亦尔。如此次第渐渐增长。满于房寺伽蓝国内。乃至遍满大地。以海为边。假想见如此。骨聚遍满。为增长意乐故。后更缩减前观。乃至假想。唯见自身骨聚。为渐略粗广心故。心由如此量。自在不净观得成。于此位中。是人名初发观行。偈曰。除脚头骨半说名数习成。释曰。复为渐略。细心量差别故。于骨聚中。除脚骨思惟余骨。是名下略。如此次第乃至除半身。及除半头骨。思惟余半头骨。是名中上二略。由于略自在究竟故。于此位中。是人名已数习成行。偈曰。安心于眉间。说名过思量。释曰。此观行人。除所余半头骨。唯安心于自眉间。或缘骨及余境。一心得住。于此位中。是人名已过思量行。有不净观。由境界小故小。不由自在小故小。此中有四句。已熟未熟思惟。未熟已熟思惟。缘自身乃至海边骨聚为境故。复次此不净观。何法为性。几地何法为境。何处得生此义次第应知。偈曰。无贪性十地。欲见境人生。释曰。此观无贪为性。地有十。谓四定及四近边定中间定欲界。以欲界所见法为境。所见谓色及形。是故此定以义为境此义可然。此观唯于人道中生。余道则无。何况余界。于人道中。除北鸠娄。由如此义。是故此观名不净观。随观世境界亦尔。若无生为法。缘三世为境。由假想思惟故。但是有流。有离欲得。有加行得。由曾得不曾得故。说不净观相及差别已。阿那波那念今当说。偈曰。阿那波那念。慧五地风境。依欲身。释曰。若风向身入名阿那。若风背身出名波那。缘二为境忆持。名阿那波那念此念以智慧为性。而说为念者。譬如念处。此慧因念力得成故。故说为念。此念依五地生。谓三近边定初定中间及欲界。由说与舍相应故。由苦乐随顺觉观起。此定既是觉观对治故。与苦乐不相应。复次苦乐是定心怨对故。此观是定心所成故。与苦乐不相应。有余师执。观行人入四定观。皆有舍受。于彼师此观则有八地。过此于余地非入出息地故。此定缘风为境。从欲界依止生于人天有此观。或由离欲得或由加行得。此观是真实思惟。属正法内观行人。偈曰。外道无。释曰。于外道教无此观。无正说故。自不能觉微细正法。此观偈曰。六由数等。释曰。此观若具与六因相应。方得圆满。六因者。一数。二随。三安四相。五转。六净此中于入出二息中。不作功用。与心舍身心相唯由念数。一二乃至十。由畏心略及乱。是故不少不多。于此数中有三失。一减数。谓若二数一。二长数。谓若一数二。三杂乱数。谓若入数出。若出数入。若离三失。是名正数。中间若乱。更从初数。乃至得定。随者不作功用。随逐入出息行。此息入若远出若远。如息行心亦随行。此息为遍行身内。为行身一分。如息行心亦随行。若息入行。至喉心脐脐下髀胫。由如此处所。次第乃至脚心。亦随行息。若出行。或一搩手。或一寻乃至风轮。及鞞岚婆风。心亦随行。由此观思惟真实故。是义不然。安者或于眉间。或于鼻端。随所乐处。乃至脚指。坚念于中住。譬如摩尼依缕。相者观视此息。为益为损。为冷为热等。此观不但以风大为境。四大及所造色。心及心法。以彼为依具。以五阴为境界。转者转缘风境慧。安置此念于上上品善根处。乃至世第一法。净者此念已入见道修道中。有余师说。从念处为初。金刚心为后名转。尽智无生智名净。此中说偈

  一数二随行　　三安四占相
  五转六清净　　说名息念观

此中。应知入出息法。偈曰。入出息随身。释曰。随身所依地。入出息与身同地。由息是身一分故。此息依止身心差别生起生无色界众生。及在柯罗逻等位。于中不有故。入无心定。及在第四定。于此人亦不有故。何以故。若身中已有空。入出息地。心若正现前。此息必生起。若人出第四定观风。则先入若死。若入第四定观风。但出不入。偈曰。众生名。释曰。假立众生法聚中一分故。偈曰。非取。释曰。与根相离故。非心心法所取为依止。偈曰。等流。释曰。非增长非果报。若身增长。此不增长故非增长。已断更续故非果报。何以故。无果报色有如此相。故是等流。偈曰。非下心。所缘非余心。释曰。此二息同地心及上地心。能缘此为境。非下地心能缘。亦非威仪及变化等心能缘。说入修二法门已。由此二法门。若已得。三摩提。偈曰。修观已成就。方修四念处。释曰。为成就四谛观故。次说修四念处。何以故。四念处通摄一切法故。能对治四倒故。云何作四念处观。偈曰。身受及心法。由简择二相。释曰。先由别通相简择身。次简择受心法。别相者。是彼各各自性。通相者。譬如一切有为以无常为相。一切有流以苦为相。一切法以无我空为相。复次身有何别相。四大四大所造为相。异前三名法。复次彼说。若人正入修观。观身由邻虚分及刹那灭正见。如此身念处得成。余念处亦尔。复次念处复有何性。念处有三。谓自性念处。相应念处。境界念处。此中自性念处者。偈曰。性慧。释曰。是何慧。偈曰。闻思修。释曰。闻思修三慧。是自性念处故。约慧念处成三。偈曰。余相应境故。释曰。所余诸法。若与慧共生。说名相应念处。与自性念处相应故。能缘境界念处故。是二念处境界。说名境界念处。自性念处是慧。云何可知。于身观身别通身相。名身念处。由此经言故。何法名观智慧。何以故。若人有慧于内身中。能观通别二相故。云何说慧为念处。毗婆沙师说。由念多故。说名念处。义判云。由念力安立成故。譬如破木坚持于楔。若执如此。是义可然。由慧念得住故。慧名念处。如所见不忘故。如净命阿尼娄驮说。此观行人。若住观中。观身别通二相。念缘身为境。即生住长佛世尊。自说。观行人。若住观中。观身别通二相。念住不忘。由此经故。知慧是自性念处。是处说如此义。比丘是四种念处。云何生集。云何灭离。是食生集。即是身生集。是食灭离。即是身灭离。此经但说境界念处。于中念止住故。如境界彼名亦如此。由缘自他及二相续为境界故。四念处各有三种。偈曰。次第如生。释曰。彼次第随生。生云何如此。如粗先观察故。由身是粗爱欲依止。此由受爱欲。此由心不调伏。此由惑不灭。故立次第。偈曰。四。对治倒等故。释曰。能对治净乐常我。是故说念处次第有四。不增不减。此四念处中。前三境界无相杂。第四有二种。若但见法境界。则不相杂。譬如身等。若通观二三四。同一道理。同一境界。此则相杂。如此数数修习。身等为境四种念处已。偈曰。此人法念中。总摄境界住。观法无常苦空无我相故。释曰。此修观人。住相杂境界。于法念处中。一切身等四法。总摄为一境。由四相观察。谓无常相苦相空相无我相。偈曰。从此暖行生。释曰。从此法念处。如此次第数数修习。至最上上品。有善根名暖行即生起。是如暖行名暖行。是能烧惑薪。四圣道火前起相故。故说名暖。偈曰。具四谛为境。有十六种行。释曰。此暖善根由位长故。具缘四谛为境有十六行。以四相观苦。谓无常苦空无我。以四相观集。谓因集生缘。以四相观灭。谓灭静妙离。以四相观道。谓道如行出。十六行差别后当说。如于暖行前亦如此。偈曰。从暖顶亦尔。释曰。是暖由软中上品次第增长。从暖上上品。有善根名顶即生起。此善根应知如暖。具缘四谛为境。有十六行。由是最上上品胜彼故立别名。由是善法顶故。故说名顶何以故。从此有堕有过故。偈曰。于二由法念。安相。释曰。于暖顶二善根中。由法念处安相。何法名安相。于四谛初安立十六相。偈曰。长由余。释曰。此二善根已生。更修四念处故得增长。若人增长已。于前所得无复现前。由不恭敬故。偈曰。从彼忍。释曰。从软中上次第增长。顶善根忍善根得生。最极能忍四圣谛理故。无退堕故。此忍亦有三种。谓软中上。此中偈曰。二忍。同彼。释曰。如前说。顶软中二忍亦尔。由安相故。一切忍。偈曰。法念长。释曰。是三品忍。同用法念处为增长。不由余念处。偈曰。欲界苦为境增上品。释曰。是最上品忍。为引世第一法故。故缘欲界苦起。是故暖等善根。缘三界苦等为境。此义自成。由不说决定义故。是时能灭色界无色界。对治一一谛相境界。乃至由二刹那心。思惟欲界苦。如此一切说名中忍。若一刹那缘欲界苦为境。此名上品忍。偈曰。一念。释曰。此上品忍但一刹那无长时。偈曰。世第一亦尔。释曰。如上品忍缘欲界苦为境。一相一刹那。世第一法亦尔。缘欲界苦为境。一相一刹那。此法是世间法。由有流故。于世间法中最胜故。说世第一胜者。离同类因。由此功力。能引圣道故。是故暖等念处为性故。同是慧性。偈曰。诸五阴离至。释曰。是一切皆以五阴为性。由摄伴类故。但离至得。至得非暖等所摄。何以故。勿圣人由现前至得故。更现前暖等善根。此中缘三谛为境。暖位安相中。修法念处现在同类四。若缘灭谛为境。此有二种。一切中诸行同类。若于增长中。四念处现世修随一。未来具四。若缘灭为境。增长中但修最后念处同类四。复修四念处。及一切行。由已得性。若安相于顶中。虽缘四谛。修最后念处。缘灭谛增长中。但修最后念处。未来具四。及一切行。若缘三谛。增长中四念处。现世修随一。未来具四。及一切行。若安相于忍中。于一切位中。修最后念处。未来具四。及一切行。若安相于世第一中。但修最后念处未来具四行亦四。由无后分故。由似见道故。偈曰。如此决择分。能四。释曰。如此有四种决择分能善根。谓暖顶忍世第一。于四中前二是软品。动故。由有退堕故。忍是中品。世第一是上品。决择分能有何义。决以无疑为义。择以分别法相为义。此二即是圣道义。由圣道能灭一切疑故。能分别四圣谛相故。谓此法是苦。乃至此法是道。是故一切圣道。名决择分者。于见道中。随约一道故名分。若法能引此令生。说名决择分能善根。偈曰。修慧类。释曰。此四皆属修位。非闻思位故。偈曰。未来中间定。地。释曰。未来定中间定四根本定。是此善根所依地。六地所摄故。于下地无。以无定故。于上地无。由是见道伴类故。故于彼无。不缘欲界故。此欲界应先知先灭离故由此二地。互不具奢摩他毗钵舍那故。此二是见道伴类。于二地无故。二地非决择分能善根所依处此四善根。以色界中五阴为果报。但能圆满不能引生。由背憎生死起故。偈曰。说二下地。释曰。大德瞿沙说。前二决择分能善根。以七地为依处。或依欲界地起。是一切暖等四善根。偈曰。欲依三。释曰。前三于人道中。生于三洲。若先已生。于天道亦得现前。第四于天上亦得生。前三男女二人得。依男女身生。偈曰。第一。女得由二依。释曰。若女人得世第一。必由二依方得。若男人得但由男人依得。何以故。由先已得女人类非择灭故。云何舍决择分能善根。偈曰。由舍地圣舍。释曰。随所依地。圣人得此四善根。若圣人舍此地。即舍此善根。不由别因舍地。云何由得度胜地故。不由余因。偈曰。非圣舍由死。释曰。若凡夫人。必由舍聚同分故舍。若有若无得度胜地。偈曰。初二由退舍。释曰。前暖顶二善根。凡夫人由退堕舍。及由死舍。圣人于二无退舍。从忍及世第一。凡夫人亦不退。偈曰。由本中见谛。释曰。若人依根本定。生暖等善根。于今生若未见四谛必见四谛。厌恶心极重故。偈曰。退已得非先。释曰。若人退前二后还得。是得未曾得。非得先所舍。譬波罗提木叉护。非曾熟修。功用所成故若位各有余。从此余更修接之。若无从根本修

阿毗达磨俱舍释论卷第十六阿毗达磨俱舍释论卷第十七

        婆薮盘豆造

        陈天竺三藏真谛译

    分别圣道果人品之二

复次如此违舍二退。何法为性。偈曰。二退非至得。释曰。此二退以非至得为性。违退必由罪过成。舍退则不定。已得暖人后若退堕。必定以涅槃为法。若尔此暖与解脱分能善根何异。由于见四谛位最近故。若无障碍。复次偈曰。暖不受邪教。释曰。若已得暖人。后退于此位。能不受邪教。若不受邪教暖顶何异。偈曰。顶不断善根。释曰。若已得顶人。后退于此位中不能断善根。有入恶道义。亦得起无间业。偈曰。忍不堕恶道。释曰。若由舍退忍。无更入恶道义。由已远离行恶道惑业故。何以故。由得忍位。于道杂生依止。有惑所有别类。皆已得无生法谓恶趣。卵湿杂生。无想天。北鸠娄。大梵生。黄门。作黄门。二根身。第八有。见修所灭惑。此无生法于软位。何况于上。是彼无生如应得故。是故无入恶道义。偈曰。世第一离凡。释曰。若人得世第一善根。由退死二舍无有是处。此人于此位中。已得凡夫非择灭。无更堕凡夫位义。何以故。离功用于第二刹那中。必证苦谛故。是暖等四善根。各有软中上三品。即成三性。由声闻等性差别故。此中偈曰。转弟子性二。成佛。释曰。转此暖顶二善根。从声闻性生起。得成大正觉有如此义。若得忍已则无此义。何因故不得。彼说由已过度诸恶道生故。诸菩萨由化作他利益为自胜事。故意能往诸恶趣受生。此性不可回转。故无此义。偈曰。转三余。释曰。从声闻性。转三决择分能善根。成异大正觉。谓成独觉。独觉性不可回转。何以故。偈曰。不求利他故。余转性不遮。释曰。若观行人本发独觉愿。后入修观得暖顶二善根。此善根则不可转为菩萨善根。何以故。由彼不为利益他事故。发愿修观故。此二位虽复可转于彼无可转义。以心愿坚故。若转作声闻不遮此义。复次偈曰。至觉彼一坐。后定佛独觉。释曰。大师佛世尊及犀角喻佛此二人于一坐中。依止第四定。由明了不动三摩提故。从初发起四决择分能善根。乃至菩提。唯于一坐得究竟菩提。谓尽智无生智。此义后当说。有余师说。从修不净观。乃至菩提于一坐得究竟。若有人执。有别独觉异犀角喻独觉。于彼人转二善根成菩萨。此义无遮。于过去生未修解脱分能善根。但于今生作功力生决择分能善根。为有如此义。不必定。无如此义。何以故。偈曰。前彼解脱分。释曰。此义决定。应知于过去生先生解脱分能善根已。今生方得生决择分能善根。若人急疾修行。经几生修得成解脱分能。及决择分能善根。偈曰。速解脱三生。释曰。第一生先生解脱分能善根。第二生次修决择分能善根。第三生修得圣道。譬如次第下种苗成结实。何故如此次第。于此法真理及教中。应令自相续入住成熟解脱。诸师说解脱分能善根。偈曰。闻思性。释曰。此业但是闻思慧类。非修慧类。此有几业。偈曰。三业。释曰。若论最胜。但是意业。由愿所摄。身口二业亦成解脱分能何以故。有人施一食。或守一学处乐解脱力所引故。因此业引生解脱分能善根。引此业于何处。偈曰。引生于人道。释曰。人道中于三洲得引生此业。于余则无。般若厌离二法。如应无故。由义相应。说解脱分能已。入四谛观次第。是今所说。此中乃至世第一已说。所余今说故说此言。偈曰。世第一无间。无流法智忍。释曰。从世第一善根无间。无流法智忍得生。缘于何境。偈曰。欲界苦。释曰。欲界苦是彼境界。此忍说名苦法智忍。为显此无流故。以等流果简别。此忍能得法智故。名法智忍。譬如花果树。说此忍名入正定聚。何以故。因此忍观行人能入正定故。正是何法。经中说涅槃名正。于中定者。是一向不异义。至得此决定故名入。若此忍已生。说此人名道人。此法次一刹那未生时。凡夫性已转灭。是此忍未来功能。此义可然。无余譬如灯生。有余师说。以世第一灭凡夫性。是义不然。同世间法故。此义无失。此彼相违故。譬如上怨家肩杀怨家。有余师说。由二故灭。此二似无间解脱道故。偈曰。次中。法智。释曰。次苦智忍后无间于欲界苦中法智生。说此为苦法智。无流言应知流至一切处。如于欲界苦中法智忍及法智生。偈曰。复尔生。于余苦类忍。及智。释曰。苦法智后无间。合色无色界苦。为一所缘境。类智忍生。说此为苦类智忍。次无间类智生说此为苦类智。于初入观由知法真实理故。此理无坏。若佛出世及不出世。此理恒然。故说名法。由此后观是前观类。后所缘境。是前境类。以后随应前故。说后名类。如于苦有四忍智生。偈曰。三谛尔。释曰。苦类智后无间。于欲界集法智忍生。次无间集法智生。如此无间次第。于所余集类智忍。及集类智生。于欲界灭法智忍。及灭法智生。于所余灭类智忍。及灭类智生。于欲界苦对治。道法智忍及道法智生。于所余道类智忍及道类智生。偈曰。如此十六心。观四谛。释曰。由此次第。是四谛观成有十六心。有余部说。四谛观唯有一心。此观于彼应知是不了义说。何以故。于彼经中说四谛观。类不分别故。此四谛观。偈曰。有三。见境界及事。释曰。见观者。由无流智了别谛相故。境界观者。由与无流智相应同境界故。事观者。由不相应法故。谓戒生等。若已见苦。此三观即成。于集等余。谛有事观。由断证修故。若彼说约见观。立为一观。此说不然。由四谛相有差别故。若彼说。由无我相。见一切谛。是义不然。何以故。此观不从苦谛为初成故。若尔与经相违。经云。圣弟子由苦相简择苦。由集相集。由灭相灭。由道相简择道。与无流思惟相应智。说名择法觉分。若汝言。此经为显修道。故说此言。是义不然。如见修故。若汝言。由见一谛于余得自在故。故说一时观谛。此义无失。四谛观中。有说出观。有说不出观。此义应思。若说如此。是时正见苦。则灭除集。至得灭修习道故。说一时观谛若执如此。则无过失。于一谛一见观。于余谛说事观故。若约见观。于经中说。四谛定次第观此说可见。经云长者非一时观诸谛。云何观次第观。如此广说。有三经。皆有譬喻。若汝言。若人于苦谛。无疑无不决心。于佛亦无疑无不决心。由此经。是故知有一时观四谛。是义不然。依不更起必定应灭。故说此言。是所说有十六心观。偈曰。世第一同地。释曰。随世第一所依地。十六心观同依此地。世第一所依地有六。于前已说。云何必定应有此义先忍后智。由此义。偈曰。忍智无间道。解脱道次第。释曰。忍谓无间道。约烦恼至得断不可间隔故。故说无间道智。谓解脱道。是已解脱惑。至得人法故与灭离至得俱起故。故说解脱道是故此二必定应有。譬如牵却关户。若说第二解脱道。与灭离至得。一时俱起。灭离疑惑智于此境界不应得生。由忍能灭惑故。此难不然。若汝言。九结聚由忍灭。不由智故则与阿毗达磨藏相违。是义不然。忍是智伴类故。譬如臣事说为王事。忍于智亦尔。为一切十六心由见谛故。皆是见道。为不尔。虽然偈曰。由见未曾见见道十五心。释曰。以苦法智忍为初。乃至道类智忍。是十五刹那心名见道。何因得名见道。由见所未曾见谛故。于第十六心无未曾见今始见。由重习所曾见故成修道。为不如此耶。此心亦见非自所曾见道类智忍所缘谛。是义不然。何以故。今思约谛不约刹那。复次不由第八刹那谛非所见。譬如一区田。余一穗未被刈。说未刈田。无如此义。属果摄故。八智十六行修故。由道于先灭故。修道是彼相续故。是故立道类智属修道。此不退义。由执持见谛惑灭离故。若汝言。是故此属见道是义不然。由有太甚失故。七智云何属见道。由见未究竟故。此中见谛未圆满。由此七智在见中间。是故数彼为见道。已说此义。谓能决判见修道生及差别。复次已生圣道人所有差别。今当分别说。是前所说见道为性。十五刹那。此中应知有二人。偈曰。钝利根二人。于中信法行。释曰。若钝根人行于彼中说名由信随行。若利根人说名由法随行。由信人故随行于义故。名由信随行。又由信根随行。为此人法。故名由信随行。先由信他故寻思义。由法随行亦尔。先由经等正法。自寻思义。为此义故说四量。法为量非人。义为量非文句。了义为量非不了义。智为量非识。云何判此四。由四种人差别故。一由贡高人差别故。二由路柯耶胝柯人差别故。三由自见取住人差别故。四由闻胜人差别故。此中于贡高人。以法为量非人。由共论说思量为智所得故。不但由威仪差别。复次佛世尊。有说人有说法。此中法为量非人。此法有二种。文句及义。此中义为量非文句。由不爱着国土言说故。何以故。不应成取文句为胜决定。应思量简择义。佛世尊说。经有二种。有了义有不了义。若人简择义。应以了义经为量。非不了义。佛世尊说。随福行及不动行。识为生善道。说四谛智为至得涅槃。若人行于法似法。以智为量非识。复次于四时中有失无失故。约四人立四量。一读诵时。二忆持时。三简择时。四修行时。此二人偈曰。若已灭修惑。于初果道向。释曰。沙门果初者。谓须陀洹果。于一切果至得中。为第一故。由未得此果故。若由实有义。但名由信随行由法随行。如先由世间道已灭修惑。或是具缚。说此为向须陀洹果。偈曰。乃至灭五品。释曰。若此人先由世间道。灭欲界修惑。乃至五品尽如此说向初果。偈曰。向二灭九前。释曰。若此二人从第五品后。先灭六七八品已。方入见道中。说此二人向第二果。谓斯陀含。偈曰。离欲欲色界。则向第三果。释曰。此人若已灭第九品。离欲欲界惑已。灭上界惑。乃至无所有处。说此二人向第三果。谓阿那含。偈曰。十六二住果。随所向三人。释曰。若第十六心起不可更说。此人为由信法随行。亦不可说向果云何可说。住果人住何果。于前若向此果。今即住此果。或须陀洹果。或斯陀含果。或阿那含果。阿罗汉果异前三。不可由见道如彼从初得。何以故。由见道能灭修道所灭惑故。无道理先于见谛惑灭离欲有顶故。偈曰。是时信乐得。见至软利根。释曰。是时钝根人先由信随行。今说名信乐得。若利根人先由法随行。今说名见至。由得最上品信智故。是故信乐及见所显。复有何因。若人已断五品修惑。于第十六心但说为须陀洹人不。说为斯陀含向。由此义。偈曰。得果果胜道。由不能得故。未修行胜道。故住果非向。释曰。若人正得果。不得由果胜道。此义为定。是故若人住果。乃至未修行果胜道。为得别果。是时未可说为向别果。于余果亦尔若人离欲第三定。更依下地入正定。此人必定现前由果胜道。若不尔。从下生上界。则不应与乐根相应。安立多灭及离欲人。入正定位中。其义如此。次第安立人今当说。是故且安立此义。如于欲界中说修惑有九品。如此偈曰。诸失有九品。地地德亦尔。释曰。如欲界中所说有九品惑。于色无色界地地乃至有顶应知各有九品惑。如惑德亦尔。为对治此失。名无间道及解脱道。地地各有九九品。云何如此。偈曰。软中上三品。更软等差别。释曰。根本有软中上三品分别。一一品更有软中上三品差别故。安立成九品。此云何有。软软品软中品软上品。有中软品中中品中上品。有上软品上中品上上品。此中由软软品道。上上品惑灭。乃至由上上品道软软品惑灭何以故。从初上上品道品不得生故。于已生上上品道人。相续中上上品惑已无故。譬如浣衣。先除粗尘垢后方除细。又如粗闇由微细光灭。微细闇由大光灭。道惑亦尔。何以故。白法势力强故。黑法势力弱故。是故由一刹那生软软圣道。无始生死轮转所增益。成上上品诸惑皆得灭离。譬如久时增长三病。以一两三角根散即能牵灭。譬如一刹那小灯。能破坏久时大闇。如此于一切九品惑中。偈曰。未灭修惑品。住果七生竟。释曰。若人已住果。未灭一品修道所灭惑。说此人名须陀洹。唯能作七生故。说七生胜此一切后。何以故。非一切皆作七生故。故经中说七生为胜。七反受生是彼圆满生。何以故。胜言者极为义。道者谓向涅槃流。由此道行至涅槃故。是人已至此流故。说名须陀洹。云何至流。若由得初道故名至流。第八亦应成须陀洹。若由得初果故名至流。多灭修惑人。及已灭九品惑人。亦应成须陀洹。约得一切果人。由得第一果。立为须陀洹。何因得初果立名须陀洹。不立第八。由得向果道故。由得见修二道故。由对证具足流故。于道类智中。是故此人得须陀洹名。向人则非。此人于人道中作七生有及七中有于天道亦尔。此人受二十八生。云何说七生为胜。由七平等故。故说七生为胜。譬如七处胜智及七叶树。毗婆沙师说如此。若尔经中云何说。具见人应生第八有。无有是处。此经意但约一道。若如文分别。中阴亦不应有。如此上流人至有顶为胜亦尔。第八生不应有。由约欲界说。此则无失。此中何证。有经及道理。定以何证。于人天各有七返。非合二有七返。经说于人天道。唯有七返。云何得知此义。七返人道。七返天道。由经言。七返于人及于天。迦尸比部说。有各各语。谓七返于人。七返于天。应同此义。若人于人道得须陀洹果。后必还于人道得阿罗汉果。于天道亦尔。复有何因。须陀洹不生第八有。由如此量时。相续成熟故。道类亦尔。譬如七步毒蛇毒。又如第四日虐。复次由七结为余故。下结余二。上结具五。虽于中间修圣道现前。不得般涅槃。七生应受。业势力所持故下上二业所引故。若诸佛不出世。在家得阿罗汉果。得阿罗汉已。必不住家。法尔必得比丘威仪。有余师说。或作别道人威仪。云何此人不退善道为法行恶道业无增长故。已增长能生果报。业于生果报中。无复功能故。由相续为最强力善根所镇故。行意二清净故。若有定感恶道业。尚不能得忍善根。何况须陀洹。此中说偈

  愚作小罪生恶道　　智作大罪离恶道
  如小圆铁必沉水　　大铁成钵则得浮

经中说七生为胜。作苦后边。何者为苦边。度此七后无复有苦。令苦不更相续。复次涅槃名苦后边。云何作涅槃。由能除障涅槃至得故。譬如人说为我作空。有余人七生为胜。此亦不定。是故不说。如此未灭修惑住果人。说名七生为胜。偈曰。若灭三四品。二三生家家。释曰。是须陀洹人。由三因缘转成家家。一由灭惑故。成三四品惑灭故。二由得惑对治无流根故。三由生二三生为余故。于偈中但显二因须陀洹人后得灭时。得惑对治。无流根义。不由说成故。是生有时最少。过此不应生故。是故但说生。云何不立由灭第五品。五品灭时第六品必定灭故。何以故。非一品惑能障观行人所应得果。如于一间人不度界故。是家家人有二种。一天家家。若人生于天。往二三家般涅槃。或于此天。或于彼天。二人家家。于人道亦尔。或于此洲。或于彼洲。复次此得初果人偈曰。已灭至五品。是向第二果。释曰。若人得果已。已灭修惑一品。乃至五品心。正在第六品。应知此人向第二果。偈曰。已灭第六品。则成斯陀含。释曰。此得果人已灭第六品。心正在第七品。说名至第二果。由一往生天。更一来生人故。说名斯陀含。过此无生故。欲嗔痴三品。惑薄弱故。今唯软品为余故。是得果人。偈曰。已灭七八品。一生名一间。则向第三果。释曰。由三种因缘。斯陀含人转成一间人。一由七八品惑灭故。二由得惑对治无流根故。三由一生为余故。云何一品惑能障此人阿那含果。由此人应度下界故。如前所说。于三位中。三种业起为障。如业能障。应知惑亦尔。由应度业果报果及等流果地故。故惑业皆为障。间者障义。此障唯一。在唯一生障此人般涅槃故。唯一惑障此人得阿那含果故。故名一间。灭七八品。其义如此。若未入四谛观前。已灭第三四七八品惑。后方证果。不成家家。亦非一间。乃至由果胜道未现前起。偈曰。灭九阿那含。释曰。得果人由灭第九品惑。应知名阿那含。于欲界不更来故。由五下分结惑灭尽故。此五灭由合数故说。何以故。于前必已灭三。后灭二故。偈曰。此中生有行。无行般涅槃。上流。释曰。此人于中间般涅槃故。说名中灭。如此已生。即般涅槃。故名生灭。不由行般涅槃。由行般涅槃。此义应知。此阿那含人有五种。中间灭者。于中阴般涅槃生灭者唯已生不久般涅槃。由熟修运载道故。此灭由有余涅槃。有余师说。具二涅槃。是义不然。此人于舍命无自在故。彼说有行灭者。若人受生已。于修不息加行。由多功用般涅槃。恒修习运载道故。无行灭者。不由多功用。后般涅槃。尊重修运载道故。余师说。由有为无为道般涅槃故。是义不然。由太甚过失故于经中先说非行灭。后说行灭。如此次第与理相应。运载非运载道。由熟修不熟修所成故。是故灭不由功用得。由功用得。生灭者。最能运载道及最上品道。诸惑最软品。上流者。往上受生。是受生处。于中不般涅槃。流者行义。偈曰。此于定。杂修行无下。释曰。是上流人。由因果有二种。谓由因由果由因者。有杂修定不杂修定为因故。由果者。阿迦尼师吒为胜。有顶为胜故。此中若人杂修定为因。则往生阿迦尼师吒。于彼般涅槃。偈曰。超出半超出。遍退。释曰。阿迦尼师吒为胜。上流人有三种由超出等差别故。此中超出者。于欲界杂修定。已退上三定。由啖初定味。舍命生梵众天。由随宿世串修故。于中更杂修第四定。从彼舍命。生阿迦尼师吒。此人于中间没上出。是名超出。半超出者。从初定生净居已。乃至超一别处。方生阿迦尼师吒。圣人必不生大梵处。由是僻见处故。于一切一生故。遍退者。若人行于一切处。后入阿迦尼师吒。无时阿那含人是所生处。更受第二生。由行增胜故。若尔此人阿那含义。则得圆满。于已生处。一向不更来故。如此杂修定。应知行阿迦尼师吒。复次偈曰。余行顶。释曰。非杂修定上流人以有顶为胜。何以故。此人随定定品起啖味心。生一切处已。唯不入五净居天。由次第受三无色处生。后往生有顶皆般涅槃。此是奢摩他行人。前是毗钵舍那行人。上流人于中间般涅槃。我见此义不违理。而说阿迦尼师吒及有顶胜者。过此无行处故。譬如说须陀洹七生为胜。如此五人。皆是行色界阿那含。偈曰。行无色余四。释曰。有别阿那含。行于无色界。若已离欲色界。舍色界生。受无色界生。此人复有四种。由生灭等差别故。如此阿那含人。合成六人。偈曰。欲界灭复别。释曰。有余阿那含。于今生即般涅槃。此名现法般涅槃。是名第七。偈曰。三人更分三。应知九色行。释曰。复次三种阿那含。各有三差别故。是故行色界阿那含有九人。三种者。谓中灭生灭上流。云何各三差别。中灭者。速疾非速疾久时般涅槃故。由三铁星譬。所分别故。生灭者。生无行有行般涅槃故。何以故。此三同受生已。后般涅槃故。是故三人同称生灭。上流者。超出等差别故。故成三人。一切三速疾非速疾久时般涅槃故。是故更互有差别。偈曰。复彼人差别。业惑根异故。释曰。此三种九种阿那含人。由业惑根差别故。彼有差别。此三人有报生报后报差别业故。复次于彼相续。软中上惑数数行差别故。复次此三人。各有上中软根差别故。是故此三人。如理各有差别。是前二三。由惑由根差别故有异。后三由后报业差别故有异。此九人由九种业惑根故。是故阿那含人成九种。若尔云何经中。说有七种贤圣人行。偈曰。上流非差别。说七贤圣行。释曰。上流为法故名上流。由说此人无分别故。经中说七贤圣行。云何依如此上流行。说为七贤圣行。不说余有学人行。唯此人于余地有行。余人则不有。此人但行善业。不行不善业。若人行此行。唯往不来。如所说三义。于余圣人皆无。是故偈曰。善恶行不行。由往不更还。释曰。故于上流立七贤圣行。于余不立。若尔云何经中说。何者为贤圣人。有学人与正见相应。广说如经。于余人亦有贤圣义。此由别意说有。谓永至得不作五种恶护。又已多灭恶性惑故。若不由别意立贤圣人义。彼人是此论说。复次已转生阿那含。为有如此差别不。不有。由此义偈曰。欲界转生圣不往生余界。释曰。于欲界中已转别生圣人必不得往生余界。何以故。若至阿那含。于此生必定般涅槃故。于色界中若转生圣人。有时入无色界。若上流有顶为胜。若尔云何天帝释说。是所闻天名阿迦尼师吒。世尊弟子。于我边没往彼受生。毗婆沙师说。由不解阿毗达磨藏。故说此言。云何佛世尊。不遮此言。为随顺帝释喜心。是故不遮偈曰。此及上生人。无练根并退。释曰。此者是于欲界转生圣人。及有别圣人。往上界受生。此等人无练根修行。又无因缘得退。云何不许欲界转生人。及往生色无色界人练根及退事。由转别生宿住故。根渐成熟。得胜类依止。由此二义。无练根及退事。复次未得离欲有学人。云何不成中灭。由道未成熟故。由思不即现前故。随眠惑非劣品故。欲界难出离故。毗婆沙师说如此。此人所应作事甚多。一应灭恶无记性烦恼。二应至得第二第三沙门果。三应出离三界。若在中阴不能成就如此事。于前已说。若修杂定。此人必生阿迦尼师吒天。此中何定应先杂修。偈曰。先杂修后定。释曰。若人欲杂修诸定。必先杂修第四定。何以故。此定随一切事一切乐行中最胜故。若杂修必由如此方便。或阿罗汉人。或阿那含人。先修习与多相续相应无流第四定。出此观已。次修习与多相续相应有流第四定。出此观已。更入无流第四定。由此次第渐渐减无流有流相续。乃至二刹那入无流观。二刹那入有流观。更二刹那入无流观。此名杂修定加行。偈曰。成由一念杂。释曰。若人无流刹那后。无间现前修有流。有流刹那后。无间现前修无流。如此有流刹那。由二无流刹那杂故。此杂修得成。前二刹那似无间道。第三刹那似解脱道。如此方便。得杂修第四定。如此杂修第四定已。由此功能所余诸定皆可杂修。此杂修于何处成。于欲界三洲。先学杂修得已若退。后于色界更杂修。复次杂修四定。其用云何。偈曰。为生及游戏。并怖畏惑退。释曰。由三因缘圣人杂修诸定。若利根阿那含人。求得净居天生。为于现法安乐住。若钝根阿那含。由怖畏诸惑。欲极远出离。啖味相应诸定。为不更退故。若阿罗汉人利根。为于现法安乐住。若钝根由怖畏诸惑。求不更退故修此定。复次净居天生云何唯五。是所说杂修第四定。偈曰。由杂修五品。净居生有五。释曰。此杂修唯有五品。谓软中上上中上上差别故。第一番修三心令现前。谓无流有流无流。第二番六心。第三番九心。第四番十二心。第五番十五心。如此十五修。以五净居天为果。于中随一切有流故得生彼。随无流不得生下。有余师说。由信等诸根次第增上故。得生五天。偈曰。得灭定那含。说名为身证。释曰。灭至得于此人有。或成此人。故说得灭。若阿那含人得灭心定。说名身证。由身证似涅槃法故。云何由身得证。由心无故。由依身生故。于余经说有十八有学人。彼中云何不说身证。由因缘无故。无何因缘。有三种无流学及无流学果。由此二差别故。安立有学人差别。灭心定非有学非无学果亦尔。是故由得此定。不可立为有学人差别。若如粗分别。阿那含人差别。应如前分别。若依细分别。分分开之。数成多千。此义云何。中灭人有三。由软中上根差别。由地差别成四。退法等性差别成六。由别处差别成十六。由地离欲差别成三十六。于欲界具缚圣人。乃至于第四定。得八品离欲。约处性离欲根差别故。成二千五百九十二。云何如此。于一处有六性。性性各有九人。从具缚位乃至离欲。八品惑。从自所得定。六九成五十四。十六五十四。成八百六十四。次由根差别。复为三倍。若作如此计。于下定得九品离欲人。此人于上地说为具缚。若平等计。如中灭乃至上流亦尔。若合数一切人。四十减十三千阿那含偈曰。灭有顶八品。成阿罗汉向。释曰。阿那含义流至此。阿那含人从于初定离欲一品惑。乃至灭有顶八品惑。此人成阿罗汉向。偈曰。第九无间道。释曰。能灭有顶第九品惑。无间道中。此人亦是阿罗汉向。偈曰。此名金刚定。释曰。此者是能灭第九品惑无间道说名金刚譬三摩提。能破一切惑。无惑能破之。此道不破一切惑。由已破故。能破一切惑。一切无间道中。最上上品故。余师说。金刚譬定。有多种差别。非至定所摄。缘有顶苦集为境。苦集类智行相应有八。灭道法智行相应有八。灭类智行相应。缘初定灭为境有四。乃至缘有顶灭为境有四。道类智行相应有四。合缘一切类智品为境故。此金刚三摩提。由智行境界差别故。成五十二金刚三摩提。如非至定所摄。乃至第四定所摄亦尔。空识无所有无边入所摄。如理应知。有二十八二十四二十。于无色界所依止法智。及缘下地灭为境类智无故。下地对治道为境。互为因故。有余师执。道类智一一地对治。亦是此三摩提所缘境。于彼师非至定所摄金刚三摩提。更增二十八故。成八十金刚三摩提。乃至第四定所摄亦尔。于空处等依止。次第有四十三十二二十四三摩提。复次由性根差别。此三摩提更成多种。是所说有顶第九品惑。此由金刚三摩提所灭。偈曰。由得第九灭。尽智。释曰。与第九品惑灭离。至得俱起智名尽智。即是从金刚三摩提无间后所生解脱道。是故名尽智。由与一切流尽共起故。由此智于初。偈曰。无学应释曰。此人于前是阿罗汉向。尽智生时。即成无学名阿罗汉。由至得阿罗汉果故。为得别果。无有别学更应修学。故名无学。是故为作他利益事相应。故名阿罗汉。一切有欲人。所应恭敬故。名阿罗汉。是故此义自成。谓所说七人名有学。彼云何名有学。为得流尽恒学三学为法。谓依戒学依心学依慧学。此三学戒定慧为性。若尔凡夫亦应成有学。是义不然。未如实见知四谛理故。后时更作邪学故。是故佛世尊。于经中重说尸婆柯。彼学三学。学三学故。说名有学。此重说有何义。若人正学非邪学。若人如前学。后学亦尔。若尔自性住圣人。云何以学为法。由意欲故是有学。譬如行人蹔息。学至得不相离故。复次何者为有学法。一切有学人无流法。何者为无学法。一切无学人无流法。涅槃云何非有学。无学及凡夫与此相应故。云何非无学。有学及凡夫与此相应故。合一切有学无学成八人。向果道人有四。至得果人有四。一为证得须陀洹果行于道。二证得须陀洹果。乃至七为证得阿罗汉果行于道。八证得阿罗汉果。此人由名故成八。若由实物唯五。前一是向果道人。后四是住果人。所余向人不出三果成立故。属三果摄。此义依次第得说。复次若先多灭。及离欲欲界人有三种。于见道中。成斯陀含向及阿那含向。此非须陀洹斯陀含摄。何以故于前已说。修道有二种。一世道。二出世道。有学人由何道得离欲。从何界得离欲。偈曰。由出世离欲。有顶。释曰。从有顶若得离欲。必定是有学由出世道。不由世道。云何如此。从有顶上无复世故。依自地道非对治故。自地道云何不能对治。自地惑所随眠故。若惑于此道类中随眠。不可立此道类能灭此惑。若道是此惑对治。此惑则不得于此道中随眠故。依自地道不得为自地惑对治。偈曰。余二种。释曰除有顶于一切地离欲中有二种。由世出世道。凡夫及学人。皆得离欲。此中偈曰。由世道圣人离欲至得二。释曰。由世间道。若圣人至得离欲。则有二种灭离至得起。一世间至得。二出世至得。偈曰。余说由出世。释曰。由出世道。若圣人得离欲。灭离至得亦有二种。余师说如此。何以故。偈曰。舍惑不应故。释曰。若圣人由圣道至得离欲。若世间至得不生。此义中。若人由圣道。离欲无所有无边入。依上诸定。更修练根行。此人由具舍前道。果道一向无故。与上地惑灭离应不相应。若舍此已。应更与彼惑相应。偈曰。有顶半解脱。如上生不应。释曰。此人虽无世间灭离至得。亦不得与彼惑相应。譬如有学人于有顶惑以得半解脱。于中必无世间灭离至得。由修练根行故。已舍出世至得。与彼地惑亦不相应

阿毗达磨俱舍释论卷第十七阿毗达磨俱舍释论卷第十八

        婆薮盘豆造

        陈天竺三藏真谛译

    分别圣道果人品之三

复次如凡夫生初定地以上。由舍欲界惑灭离至得。与彼惑不更相应。于彼亦尔。是故此执非证。复由何地。从何地得离欲。偈曰。由无流非至。离欲一切地。释曰。若依非至定地。修无流道。能离欲一切地乃至有顶若人依近分定。得下地离欲。为如无间道一切解脱道亦从近分定起不非。何为。偈曰。从定近分后。脱道三地胜。释曰。一切众生生地有九种。谓欲界四色定四无色定。此中从欲界离欲。乃至第二定离欲。名三地胜。于此三地中。最后解脱道。或从近分定起。或从根本定起。偈曰。非上近分。释曰。从三地胜以上。一切最后解脱道。皆从根本定起。悉不从近分定起。舍根平等故。于三定中近分及根本。由受根异故。有余人不能得入根本定。通修行根难成故。是故于离欲三地。最后解脱道。亦得从近分定起。由无流非至定得离欲一切地。此义已说。由余地未说故今应说。偈曰。圣由八自上灭。释曰。若由八种无流定得离欲。谓色定中间定无色定。从自地及上地。皆得离欲。非从下地。先已离欲故此中出世无间道解脱道缘四谛为境故。如谛十六相起。此义自成。偈曰。解脱无间道。世间如次第。寂静粗重等。想上下地境。释曰。解脱道起。寂静等为相。无间道起。粗重等为相。此二道如其次第。第一缘上地为境起。第二缘下地为境起。若解脱道思量上地。则缘寂静美妙出离随一相故。若无间道思量下地。则缘粗重逼恼厚壁随一相故。由不寂静。故名粗重。由大功用所成非美妙。故名逼恼。由多过失能违逆故。不得出离此地。故名厚壁。譬如罪人不离牢狱重障故。翻此相应知寂静美妙出离相义。说随本应余义已。复次从尽智无间后。何智得生。偈曰。若不坏尽智。后无生不生。尽智或无学。正见。释曰。若人成不坏法阿罗汉。从尽智无间后。无生智必生。非尽智无学正见生。若非不坏法人。从尽智更生尽智。或生无学正见。非无生智有退堕故。复次此无学正见。于不坏阿罗汉。为必不生耶。偈曰。此通应。释曰。若不坏法阿罗汉。从无生智后。有时无生智更生。有时无学正见生。何以故。此正见于一切阿罗汉。皆通无差别。是前所说四果。此果属何法。是沙门若果。何法名沙门若。偈曰。沙门无垢道。释曰。若道是无流称为沙门若。由此道人成沙门那。由能寂静惑故。如经言。此人能寂静多种恶法。不应慧法。染污法随顺生死能感后有。乃至老死故。名沙门那。凡夫非必定能寂静众恶故。非真实沙门那。复次此沙门若。何法为果。偈曰。有为无为果。释曰。有为无为法。是沙门若果。此果于前已说有四种。谓须陀洹斯陀含阿那含阿罗汉。如经言。比丘沙门若果有四。广说如经。复次此果有几种。偈曰。彼一减九十。释曰。此沙门若。沙门若果。有为无为。各八十九。此是何法。偈曰。解脱道与灭。释曰。为灭见惑。有八无间道八解脱道。为灭修惑。于九地各有九品无间道。各灭九品惑。各有九品解脱道。此中一切无间道。名沙门若。一切解脱道。名有为沙门若果。是无间道等流果。及功力果故。诸惑灭离。名无为沙门若果。由如此义。有为无为果各有一减九十。若尔于佛世尊此义应合分别。不可分别。若果甚多。偈曰。成立四种果。由五因具有。释曰。于灭道位中。若具有五因。于此位中佛世尊安立沙门若果。何者五因。偈曰。舍前得别道。得通灭果果。及至得八智。修习十六行。释曰。一先舍离前道。二至得未曾得道。由舍离至得向道道果故。三合数至得灭。由一至得。至得一切灭故。四一时得八智故。五四法智及类智。修习十六谛相。谓无常等相。如此五因。果果皆有此五因。不可于佛果中立。若唯无流道名沙门若。云何世道所得二种果。名沙门若果。偈曰。世道得离故。得无流持果。释曰。于二果中不唯以世道灭为果。谓斯陀含果。阿那含果。云何见道果灭于中相离。同一至得。摄一切灭。为一一果故。是故经中说。何者为斯陀含果。谓三结灭离。及欲嗔痴薄弱。何者为阿那含果。调五下分结灭离。由无流道至得灭离故。故此道被持。由无流道力。至死不退失故。是故此灭如理应成沙门若果。是前所说名沙门若果。复次此偈曰。婆罗门梵轮。说此梵转故。释曰。由能遣荡诸惑故。说名婆罗门。或说名梵轮。由梵转故。与无上梵法相应故。说佛世尊名夫岚摩。如经中说。世尊是夫岚摩。如此寂静。如此清凉。广说如经。故佛世尊名夫岚摩。此轮是佛世尊轮。故名梵轮。唯佛世尊所转故。偈曰。法轮名见道。释曰。轮者何义。因此得行故说名轮。由见道似轮故。说此法名轮。云何相似。偈曰。疾行等辐等。释曰。由疾行故似轮。由舍此趣彼故。由未伏能伏已伏镇令不失故。由从下向上从上向下故。由此疾行等义故言似轮。由辐等义者。八分圣道。由辐等义似轮故。大德瞿沙说此名轮。正见正觉正进正念。此四法似辐。正语正业正命。此三法似毂。正定此一法似辋。是故见道说名法轮。立此见道为法轮。以何法为证。于圣憍陈如见道生时。由说言世尊已转法轮故。云何三转十二相。此法是苦圣谛。此谛必应知。此法已知。如此三转。于一一转中。法眼成智成明成慧成。如此三转及四相。谛谛皆有。由同三及十二故。说三转十二相。譬如说聪慧于二处七处。由此转见道修道无学道。如数已显现。毗婆沙师说如此。若执如此。不但见道有三转十二相。云何安立此为法轮。是法门本名法轮。此中亦具有三转十二相。若尔云何三转。于中三番转四谛故。云何十二相。三番思想四圣谛故。谓此法名苦圣谛及集灭道圣谛。此法必应知。必应灭。必应证。必应修。此法已知已灭已证已修。云何说名转。由行度他相续令彼解此义故。复次一切圣道皆是法轮。由能行度于弟子相续故。此法于他相续。由生见道故。正被转说已转。复次于何界中得几沙门若果。偈曰。欲三三界后。释曰。唯于欲界中得三果。于余无。最后沙门若果。谓阿罗汉。此果于三界通得。此前二果。未离欲人所得故。于上不得。此义应理。第三果云何于上不应得。偈曰。上界无见道。释曰。于欲界上无见道。若离此道。已得离欲人。至得阿那含果。无有是处。由此义。是故但于欲界有三果。由何因于上地无见道。于无色界正闻无故。不能缘下界境故。故无见道。于色界中。偈曰。无厌故此作。彼究竟经故。释曰。色界凡夫。由爱着三摩跋提乐。由无苦受故。不生厌恶心。若离厌恶。无别道理能引生圣道。如此等名道理。亦有阿含为证。经言有五人。于此造作于彼究竟。何者为五。中灭乃至上流。造作者。谓初发修见道。是涅槃正方便故。究竟者。谓至得阿罗汉果。由此经故。知于上界无见道。前已说此义。若不坏法阿罗汉。尽智后必生无生智。阿罗汉为有差别不。说有。偈曰。阿罗汉有六。释曰。于经中说。阿罗汉有六性。一退堕法。二自害法。三守护法。四住不动法。五应通达法。六不坏法。偈曰。前五信乐性。释曰。除不坏法一人。所余五人信乐得为先。偈曰。彼脱依时爱。释曰。此五人应知。彼解脱依时得成。及最所爱恒守护故。是故说彼有时解脱。彼观时得解脱故。由除观字故。说时解脱。譬如酥瓮。何以故。彼人现前修三摩提。必观时成时者。谓命缘无病住处时等。观此时彼俱解脱成故。偈曰。不坏法无坏。释曰。若不坏阿罗汉所得解脱。则恒成无破坏。由无退堕故。偈曰。故非时解脱。释曰。是故说此人不依时解脱。何以故。此人不观时。恒解脱如意。能现前修习三摩提故。复次由蹔时永时解脱故。立彼为有时解脱无时解脱。由有退失不退失义故。偈曰。此先见至类。释曰。此不坏法阿罗汉。于学位中应知见至为性。此六阿罗汉。为从初有六性。为后得六性。偈曰。有余本得性。有余练根得。释曰。有人从初本以退堕为性。有人从初本以自害为性。所余性亦尔。复次有人。先以退堕法为性。后由修练根行。更进得自害法为性。乃至进得不坏法为性。应知亦尔。此中退堕法者。若人必定从所得法退堕。不能得自害法为性。自害法者。若人必定应杀害自身。守护法者。若人随自所得必定应守护。住不动法者。若人离最强退堕因缘。虽不恒守。必定应住于所得不动。无退堕故。离加行故。不得增进。通达法者。若人后时必定通达不坏法为性。不坏法者。若人必定不如前人有退堕。前二人于有学位中。无恒修及尊重修。但根有异。第三人恒修加行根钝。第四人尊重修加行根利。第五人具二修但根钝。第六人具德二修慧根最利。第一退堕法人。非必定应有退堕。乃至通达法人。非必定应通达。不坏法但约有义。故说此名。若人执如此。于三界中皆具六阿罗汉。此义不相违。若人执彼必定有退等事乃至通达。于彼人欲界中有六阿罗汉。色无色界唯有二。谓住不动法及不坏法。此二人更退自害。修练根行。此事不有故。此六人中何人得退。从何法退为从果。为从性。偈曰。退性有四人。五退果。释曰。自害等四人从性退。何以故。退堕法人。无更从自性退堕。退堕法等五人。皆从果退。此五人虽退。偈曰。非先。释曰。若人先所得性。此人不从此性退。由有学无学道成就令坚实故。若有学性。世出世道所成就。亦无有退。由修练根行。后所得性。此性有退。若人得初果。此人从初果无退。从余果得退。是故从须陀洹果。无有退堕。若作如此执。退法有三人。一在退堕性中般涅槃。二修练根所得性退。三退堕有学。自害有四。三如前。第四更还退性。如此余三增一一品。如次第应知。成五六七人。是本所得性。若退成有学人。于中得住不住余性。若不尔。由得增长性。转增不成退。复有何因从初果不退。偈曰。见惑无类故。释曰。云何无类。一切见谛所灭惑。依我生起故。彼以身见为根本故。此所依我。必定永无。故说无类。若尔彼应成缘无为境。非缘无为境。由缘谛为境故。于谛中不如分别为境。若尔何惑不然。有差别。何以故。我见于色等类。由作者受者自在者分别故。增益非实有我性起。以身见为依止。所余边见等惑生起。是故说无类。修道所灭惑。欲嗔慢无明。于色等类中。爱增上起。不了为自性生起。是故说有类。何以故。彼有微净等境。由缘此故。彼得起我等皆无仿佛。复次随道所灭惑。有境类各各相对。谓可爱不可爱等。一切见谛所灭惑。通以我等相为境。是故无各相对境类。复次见道所缘境。谓无常苦无我空。真实是有故。非世道所缘故。于无始生死。先未曾所证见故。是故初果无退事。复次圣人。若不至心观察。由念忘失修惑则起。若至心观察则不得起。譬如于藤起蛇想。若人不至心观察。我见等惑则不得生起。诸见由明了决度故。是故圣人。从见谛惑。无有退义。经部师说。从阿罗汉果。无有退义。此义真实可然。云何可知。由阿含及道理。此中是何。阿含经云。比丘此是真灭。若由圣智所灭。复次偈曰。说无放逸事。释曰。经云有学人。于无放逸中。我说必有无放逸事。于阿罗汉我不说。若汝言。于阿罗汉亦有无放逸事。如经言。阿难。于阿罗汉人。利养赞叹等事。我说亦能为障碍。是义不然。此经所说。退但说从现法安乐住退。是不坏心解脱。本来身所证。我说从此无别因缘能令阿罗汉退堕。若汝言。从依时解脱有退。是义可然。我等亦说。如此此依时解脱义。应须思量。为是阿罗汉果。为是九定是根本定及根本三摩提。云何知依时现前故。说名依时解脱。为于现世安乐住数数所寻修故。说名所爱。有余师说。是应所啖味故。说名所爱。阿罗汉解脱恒相随逐故。不可立为依时。非复所爱故。不可立为所爱。若从阿罗汉果有退堕。理云何。佛世尊说。唯从依心学现世安乐住有退。是故应知此义。谓一切阿罗汉解脱。必是不坏法。从现世安乐住。阿罗汉有退。由利养赞叹等心散乱故。由自在退失故。由根钝故。有人亦不退。若利根人。此中若有退说名退法阿罗汉。若不退说名不退法阿罗汉。自害法等义应如此思。不退法住。不动法。不坏法。此三人有何异。不退法者。非练根至。不坏法者。由练根至。此二人随所修得三摩跋提差别。从此无退堕。住不动者。彼于随所得功德中住。从此功德必定不退。亦不增进生余功德。若生余功德从此得动。如此应知三人差别。偈曰时解脱瞿提。释曰。净命瞿提柯在学位中。由数数啖定味故。由根钝故。从依时解脱退堕。生忧悔心。欲舍身命。执仗自害。于将死时得阿罗汉。即般涅槃。是故瞿提柯非退阿罗汉果。于十增经中说此言。有一法必定应生。谓依时所爱心解脱。复有一法必定应证。谓不坏法心解脱。若依时所爱心解脱。是阿罗汉果。云何于十中作两番说。于余处不曾闻说阿罗汉后更应生。云何文必定可证。若汝言。钝根所摄阿罗汉果必应更生。此经文欲证何义。若汝言。欲显于生果有能故。以此文为证。若尔于余果亦可以此为证。若汝言。此果应生故。故说应生。余果最应生。是故依时解脱。非阿罗汉果。若尔云何说阿罗汉依时解脱。若阿罗汉人由钝根故。现前修三摩提观时得成。说此为依时解脱。翻此为非时解脱。阿毗达磨藏说。有由三处欲界随眠欲生起上心。何者为三。一欲界随眠欲未得灭离。二随欲界上心欲法对根现前三。于中起不如思惟若。汝言此。文依具因生惑故说。何惑由不具因得生。依阿含证不退义如此。云何由道理。若阿罗汉人。已得如此对治。由此一切惑至得永不生为法。云何更退。若此对治未生。云何诸流得尽。由未永拔除惑种子。更生为法。若流未尽。云何称阿罗汉。依道理证不退义如此。偈曰。由火聚譬退。释曰。若尔火聚譬经汝宜应救。此经言。多闻圣弟子。如此行如此住。有时有处。由念忘失故。更生恶不应慧觉观。是义不然。何以故。此文中不定显现阿罗汉。云何知。由此经言。阿罗汉心长时归向空寂。乃至垂堕涅槃。由此言故。知前非证。复有余经中说。阿罗汉有如此力。由一切流处诸法。阿罗汉恒时清凉。恒时寂静。由此言故前非证。有如此言。乃至未弃舍行。若尔有学人在行中。亦有此义。于或生中火聚譬经。由依有学位说故。于阿罗汉无如此失。毗婆沙师说。诸阿罗汉人。从果得退。为唯阿罗汉有六性。余人亦有。偈曰。凡学人六性。释曰。不但阿罗汉有六性。凡夫及有学人。皆有六性。何以故。是阿罗汉六性。以彼次第为前。复次偈曰。见道无练根。释曰。于异见道处。有修练根行。于见道中则无。修加行不及故。有人于凡夫位中。修度余根。有人于信乐得位中。修练根行。经中说言。是人所得四种依心现法安乐住。从此随一我说有得退堕。是不坏心解脱。唯一阿罗汉人。本来身所证。我说无别因缘能令阿罗汉从此退堕云何不坏法阿罗汉。从现世安乐住得退。偈曰。退堕有三种。已得未得用。释曰。已得退者。若人从已得功德退堕。未得退者。若人不能得应得功德。受用退者。若人所得功德。不令现前。此三种退堕中。偈曰。最后佛不坏。中间余有三。释曰。佛世尊但有受用退无余。由如来一向行利益他事。不坏法阿罗汉。有受用退及未得退。谓从胜人法差别。未至得故。余诸阿罗汉。亦有已得退未得退受用退。此二可知。由经依受用退。说退。立不坏法阿罗汉不退。此不违经。是故一切无流解脱。皆不可坏。如所说安立不坏法阿罗汉义。此义如非不如。是故此义不可难。谓阿罗汉。皆以不坏为法。此名显不坏义。复次如毗婆沙言。若有阿罗汉。退阿罗汉果。此阿罗汉。为更受生不。不更受生。云何得知。偈曰。退位不死故。释曰。无有一人从圣果退在退位中舍命。何以故。如经言。比丘圣弟子。若忘失忆念皆悉迟缓。虽然若灭此忘失。速得灭尽。由此经言。是故无有死义。若不尔此正梵行。非可安息。若人从此果退。是昔所住果非所作事。为更作不。偈曰。不作非所作。释曰。若人已退。不更作与本果相违事。譬如健人虽趺不躄。若人修练根行。有几无间道及解脱道。偈曰。无间解脱九。不坏。释曰。若人求通达不坏法性。是通达法人所修。有九无间道九解脱道。譬如人求得阿罗汉果无间解脱道。云何如此。是软根性。偈曰。由久事。释曰。此人于长时已数习软根性。此根由少分功用不可回转。由有学无学道所成坚实故。偈曰。于见至一一。释曰。若人欲通达见至性。修无间道唯一。解脱道亦一。于中方便道亦一。是一切无间道解脱道。偈曰。无流。释曰。何以故。由有流道修练根行。无有是处。根无流故。道所缘境皆真如故。何处根可练令增进。偈曰。人道增。释曰。于人道中得修练根行。于余处则无。无退堕故。复次何人依何地得修练根行。偈曰。无学依九地。有学但依六。释曰。若无学人依止九地修练根行。谓未至地中间定四色定及三无色定。若有学人。依六地修练根行。离三无色。何以故。由此义偈曰。舍有差别果。得胜果道增。释曰。若人修练根行。舍果及果胜软根道。即得利根性果及道。无阿那含果是无色界摄。由此因故。有学于无色界无练根行。是故一切阿罗汉。唯有九人。由根差别故。云何如此。偈曰。二佛声闻七。有九由九根。释曰。何者七声闻。退堕法等人有五。不坏法人有二。一由练根至。二从本。是不坏法性。于本不坏性中有差别。谓二佛。一独觉二大正觉。此九人由软软中软上软等根差别故。是故成九阿罗汉。一切圣人唯有七人。谓由信随行。由法随行。信乐。得见至。身证。慧解脱。二分解脱。如此七人。偈曰。加行根灭定。解脱二故成。七人。释曰。若由加行成二人。谓由信随行。由法随行。于前由信受他教。及由法修行。于义修加行故。若由根成二人。谓信乐得见至。由软钝坚利根故。一由信乐胜。二由般若胜。若由三摩跋提成一人。谓身证。由身证得灭心定故。若由解脱成二人。谓慧解脱二分解脱。由慧及定解脱惑障及定障故。此人由名成七。偈曰。或六人。三道人双故。释曰。若由实义唯有六人。何以故。于见道中有二人。谓由信随行。由法随行。此二人若于修道中成别二人。谓信乐得见至。此二人若于无学道中。成别二人。谓时解脱非时解脱。此中若由根差别。由信随行人成三人。若由性更成五人。若由道成十五人。住于八忍及七智故。若由离欲成七十三人。一具缚人。于离欲欲界有九人。乃至离欲无所有无色处。各有九人。由依处有九。谓三洲及六欲天生。由根性道离欲依处。合数成百千四十七千八百二十五人。所余诸圣人。如义及理。应如此数。是所说名。二分解脱。此是何人。慧解脱复是何人。偈曰。得灭定俱脱。余人慧解脱。释曰。若人先得灭心定。后于无学位。名二分解脱。由般若及三摩提。解脱惑障及八解脱障故。所余但由般若力。一向解脱惑障故。佛世尊所说偈

  若舍此五结　　不坏法具学

有几量此人成具分有学。偈曰。由定根果故。说圆满具学。释曰。有学人由三义故称具学。一由果。二由根。三由三摩跋提。但由果者。谓信乐得阿那含人非身证。但由根者。谓见至未离欲。由果由根者。谓见至阿那含未得身证。由果由三摩跋提者。谓信乐得阿那含已得身证。由果根三摩跋提具学者。谓见至身证阿那含。但由三摩跋提。及但由根三摩跋提不由果为具有学人。无有是处。偈曰。无学圆满德。由二。释曰。圆满无学者。唯由二。一由根。二由三摩跋提。若果未圆满成无学。无有是处。是故于果不论圆满不圆满。但由根圆满。不由三摩跋提者。谓非时解脱。慧解脱人。若但由三摩跋提圆满。不由根者。谓依时解脱。二分解脱人。由根及三摩跋提圆满者。谓非时解脱。二分解脱人。所说道差别有多种。谓世出世道。见道修道无学道。或说加行道无间道解脱道增进道等。若略说此道有几种。偈曰。略说道四加行无间。解脱增进道。释曰。加行道者。若从此道无间道生。无间道者。若由此道能除惑障。解脱道者。从已解脱无间道所灭惑障。后次最初所生道。增进道者。从解脱道后所生余道。谓三摩提通练根等道。此四种云何说名道。由此法是般涅槃路故。说名为道。若人发行此路。必定得至涅槃故。复次由此法观行人寻求涅槃。故说名道。解脱增进云何名道。由是前道种类故。由最上品故。由能令至后有故。说前为后道。由是入无余涅槃方便故。故此四皆是道。复次此道有时说名行。由此行至涅槃故。此行有四种。如经言。有行苦迟智。有行苦速智。有行乐迟智。有行乐速智。此中偈曰。依定道乐行。释曰。于四定中此四种道。说名乐行。由摄分故。奢摩他毗钵舍那。平等起故。此道不由功用成故。说名乐行。偈曰。于余地苦行。释曰。于余地。谓非至定中间定无色定中。此道说名苦行。由不摄分故。奢摩他毗钵舍那不具故。大功用所成故。说名苦行。何以故。非至定及中间定。此定由奢摩他不具。未至初定及二定故。无色定由毗钵舍那不具。思想心细故。此乐苦行。复有二种。偈曰。迟智软根人。速智约利根。释曰。若人根钝。或乐或苦行。此行名迟智。若人根利此行名速智。复次于此行中智迟故。说名迟智。速智亦尔。复次此行是迟人行故。说名迟智。速智亦尔。复次此道或名觉助觉助法有三十七品。谓四种念处。四正勤。四如意足。五根。五力。七觉分。八圣道分。此中偈曰。尽无生二智。菩提。释曰。是尽智无生智。由人差别故。成三种菩提。一声闻菩提。二独觉菩提。三无上正遍菩提。由无余无明灭故。是已利如实能觉。已作不应更作故。偈曰。由顺此。三十七觉助。释曰。由彼法为菩提生方便生住受用故。故三十七得觉助名。偈曰。由名实义十。释曰。此觉助法。若由名说三十七。若由实物。一切菩提助法。则唯有十。何者为十。偈曰。信精进忆念。三摩提智慧。喜舍及轻安。戒觉。释曰。信者于七处心澄净。精进者于境界心勇猛。念者于所缘境心明不忘。定者于境界一心寂静。慧者如理解。喜者心安乐。舍者心无功用。轻安者身心随事。戒者能平身口。觉者能思量。如此十物。云何安立于七处。偈曰。慧念处。精进名正勤。如意足名定。释曰。于中四念处正勤如意足。智慧精进定为自性。次说五根。如根力亦尔。由执名有异何以故。信精进念定慧五物。是根即是力。于中念处择法觉分正见。即是慧。正勤精进觉分正精进。即是精进。如意足定觉分正定。即是定。觉分正念。即是念。何法为余。喜轻安舍觉分正觉及戒分。此五为余。如此助觉法。唯有十物。苦依毗婆沙师执。有十一物。身口二业不相通故。是故戒分成二物。是前所说四念处等。智慧精进定为自性。此中应知。偈曰。由随胜立名。一切加行得。释曰。于中由随胜故。说如此名。一切加行所得法。皆是念处正勤如意足。云何说精进名正勤。由彼能安立身口意业令胜。云何说三摩提。名如意足。一切胜德。以彼为依止故。若有人说。唯三摩提名如意足谓欲等。于彼人道品成十三物。长欲心故。若执如此。即与经相违。经云比丘。我今为汝说如意及如意足。乃至言何者为如意。于正法中有比丘。证用多种如意境界。谓本是一即成多种广说如经。云何前说名根。后说名力。由软上差别故。由可胜伏不可胜伏故。根者虽于修观中增上。在下劣位中。所对治惑。能胜伏故。故是根非力。力者于修观中在胜上位。所对治惑不能胜伏故。故是力非根。云何立次第。若人信此行有胜果。为求得此果故修正勤。若人恒修正勤。忆念得住。若人专念境界。心不散乱故。即便得定。若心得定。则见知如实。因如此义。故立次第。复次于何位中。何菩提助法所应显现。偈曰。初发行决择。分中所分别。于修位见位。七部次第知。释曰。初发行位中。为了持身等境界。是故先修四念处。由为得增胜生长精进故。故于暖位修四正勤。由能入不应退善根故。故于顶位修四如意足。由不更退故至增上位。是故于忍位修五根。非惑可胜伏故。是故。于世第一位。修五力。又世间余法。亦不能胜伏。由近菩提位故。是故于修道中修觉分。由发行。所显故。是故于见道中修圣道。是彼所随逐故。为随数次第故。先说七后说八。若随修次第。先修八后修七。此中择法觉分者。此是觉亦是觉分。正见是道亦是道分。毗婆沙师说如此。有余师不破此次第。说助觉法次第。初发行者。为制伏于多种境界散乱偏倒诸智故。修四念处。四念处是观行人系录心处。为灭除一切依贪忆念分别。由此经言故。知四念处为发行初。由念处力故。能生长精进。为成四事故。能正安立心令胜故。次四念处。修四正勤。由此正勤心安无忧悔故。治心成三摩提故。次四正勤修四如意足。由依止定信等诸根成出世法增上缘故。次四如意足修五根。此根最能制伏所对治法。起行由自功能。离同类因。能生出世法故。次五根修五力。于见道中修觉分。于见修道中修圣道分。何以故。经中说此言。于八分圣道中。一切应修至修圆满。谓四念处至修圆满。乃至七觉分至修圆满。复有经言。比丘宣示如实言者。谓为四圣谛观。譬如自所行路。更如此行。为修八分圣道譬。是故应知。于二位中修八分圣道。此等次第皆成。说次第已。此义今当说。于觉助法中几法是有流。几法是无流。偈曰。无流觉道分。释曰。由安立彼于修道见道中。是故觉分道分。皆是无流。于世间亦有正见等法。此法不得圣道名。偈曰。余法有二种。释曰。所余觉助法。有有流有无流。复次于何地。有几觉助法。偈曰。于初定具足。释曰。于初定地中具有一切三十七菩提助法。偈曰。非至定除喜。释曰。云何无喜。诸近分定势力所将故。复于下地疑怖未息故。偈曰。第二定离觉。释曰。于第二定中正觉所离。唯有三十六。于彼无觉观故。偈曰。于二二所离。释曰。第三第四定中觉助法。喜觉二法所离。唯有三十五。偈曰。及中定。释曰。于中间定亦二所离同三十五偈曰。离戒前二三无色。释曰。于三无色界。正语正业正命喜正觉所离。唯有三十二。偈曰。于欲界有顶。离觉圣道分。释曰。于此二处。唯有二十二菩提助法。何以故。于此二处。非无流道器故若人正在三十七觉助法观位中。于何位应知得正解净信。偈曰。见三谛得戒。及法正解信。于见道信佛。及信弟子众。释曰。若人正见苦集灭圣谛。于法得正解净信。及得圣所爱戒。由见道圣谛。于佛世尊及圣弟子众。得正解净信。何以故。是于二正解净信。即于能成佛无学。独得法中生正解净信。于能成僧有学无学法中。生正解净信复得戒。及于法正解净信。偈曰。法谓三谛。及菩萨独觉道。释曰。是故若人正观四谛。于法得正解净信。此法由信依处。及名差别故。说四正解净信。偈曰。若约物唯二。信戒。释曰。佛法僧正解净信。信为自性。是一法圣所爱。戒是戒一法。故约实物彼唯二物。此二为有流为无流。一切正解净信一向。偈曰。皆无流。释曰。正解净信有何义。如实觉了四谛已。于四处得无流信。说名正解净信。此信由无流智所成。通于二人。此人正出观时。如现前生起。四信如此次第。云何出观现前生起。知世尊是正觉遍知。是世尊正法正教于正说中第一。是世尊圣弟子众。于正行中无等。似医师方药安养病人三类故。是心净信所作名戒净信。或说第四云。若人得净信已。如此正行名戒净信。此似无病类故。或说此四似道路师似路似宗侣似乘。经中说。有学人与八分相应。无学人与十分相应。云何不说有学人有正解脱正解脱知见。偈曰。解脱非学分有系故二种。释曰。有学位中人正有系。由未能免离烦恼缚故。若正有系。云何立彼为解脱。若解脱一分缚。不可说为已解脱。若无解脱。云何得立解脱知见。无学人已永解脱一切烦恼缚故。可说有解脱。由依自二证智所显故。此言如理。何法名解脱。此解脱有二种。一有为。二无为。此中偈曰。惑灭是无为。心净了有为。释曰。无为解脱。谓诸惑灭尽。有为解脱谓无学心净了。偈曰。此分。释曰。此有为解脱。说名无学分。诸分有为故。偈曰。即二脱。释曰。此有为解脱。经中说为二种解脱。谓心解脱及慧解脱。应知此二于无学人是解脱分。若尔于余经中云何说此言。毗耶伽何者为解脱。谓心永圆净。此中有比丘。于欲心离欲及解脱。于嗔痴心离欲及解脱。如此若未圆满解脱聚为圆满。若已圆满。为摄持是欲及精进等。广说如经。是故不应但以心了为解脱。此云何真慧。已遣欲等诸惑。是心一向无垢。余师说名解脱。说正解脱已。正解脱知见。异于正见。此是何类。偈曰。慧如说菩提。释曰。是前所说名菩提。此法于今应知说名正解脱知见。谓尽智无生智。复次何心得解脱。为是过去现在未来。偈曰。解脱正生心。无学从惑障。释曰。未来心说名正生。此心属无学人。从此惑障得解脱。阿毗达磨云知此。此心何法为障。烦恼至得为障。能碍彼生故。何以故。于金刚譬定时。此至得即灭。灭时此无学心正生。此生时即是解脱。此至得已灭。此无学心已生。说名已解脱。若尔未生心。及世间心。此心亦解脱。云何说正生及无学。若生必定解脱。此心是今所说。世间心从何惑解脱。从障生解脱。若人未解脱。解脱心为不生耶。生不如今所论解脱心。此心何如。与惑至得相应故。此道在何位。能除自生障。偈曰。正灭道能灭能障道诸惑。释曰。若道正在现世。能损前惑。为未来惑作次第缘。力于未来惑引择灭为永遮令不更生。是故道正在现世。损现在遮未来将起时。是前所说无为解脱。经中所说界有三种。谓灭界离欲界永除界。此法有何异。偈曰。无为解脱界。释曰。此无为解脱即是三界。此中偈曰。离欲谓欲灭。释曰。欲烦恼灭说名离欲界。偈曰。灭界余惑灭。释曰。异欲余烦恼灭。说名灭界。偈曰。永除别类灭。释曰。离惑类所余诸法灭。说名永除界。此三界即是无为解脱。若由此类心起厌恶。为由此类心得离欲不。此中有四句。云何作四句。偈曰。厌离由苦集。忍智故。释曰。由苦集忍及智心。但生厌恶。不由余法。何以故。此二是忧恼境界类故。偈曰。离欲。释曰。由灭道忍及智心。但得离欲。不由余法。何以故。此二是喜乐境界类故。偈曰。二由一切灭。释曰。是一切苦集灭道忍及智。能灭诸惑。由彼心得厌恶。亦得离欲。非二由余法若彼不能灭惑。此中若已离欲人。重观四谛。由法智忍。不能灭惑。若智加行解脱增进道所摄。此智亦不能灭惑。偈曰。此中立四句。释曰。是故应知四句义如此

阿毗达磨俱舍释论卷第十八阿毗达磨俱舍释论卷第十九

        婆薮盘豆造

        陈天竺三藏真谛译

    分别慧品第七之一

已说诸忍及诸智已。说正见及正智。诸忍为非智。正智为非正见耶。偈曰。无垢忍非智。释曰。是前所说八种无流忍非智。是所应灭随眠疑惑未灭故。可说彼名见。决度寻觅为体性故。如忍但是见性非智如此。偈曰。尽无生非见。释曰。尽智无生智非见。非决度寻觅为性故。偈曰。异彼圣智二。释曰。异于忍及尽智无生智。所余无流般若。亦见亦智。偈曰。余智。释曰。世间般若一切皆是智。偈曰。见有六。释曰。五见及世间正见。此六种世间般若。名见亦智。所余非见但智。由几量能摄一切智。由十智。若略摄十智。唯有二智。偈曰。有流无流智。释曰。一切智不出二性。谓世智出世智。此二中偈曰。第一名俗智。释曰。有流智说名世俗智。何以故。此智由多缘瓶衣男女等俗类为境故。偈曰。无流智有二。法智及类智。释曰。无流分为二智。谓法智类智。以此二智合前成三智。谓世俗智法智类智。此中偈曰。俗智一切境。释曰。一切有为无为法。皆是俗智境。偈曰。欲苦等为境。法智。释曰。法智者。于欲界中以苦苦集苦灭苦灭对治为境。偈曰。若类智。上苦等为境。释曰。类智者。于色无色界中以苦苦集苦灭苦灭对治为境。偈曰。此二由谛异。成四。释曰。法智类智。由谛有差别故成四智。谓苦智集灭道智。由缘四谛起故。偈曰。四更二。名尽无生智。释曰。法智类智。由境已成四种。于中若非无学正见为性。名尽智无生智。偈曰。此智复初生。苦集类智性。释曰。此二智若初生。名尽智无生智。以苦集类智为性。由苦集各四行相。缘有顶阴为境界故。金刚譬三摩提。与此二所缘境同不。若金刚譬三摩提缘苦集为境则与二智同境。若缘灭道为境则与二智不同。偈曰。从四他心智。释曰。他心智从四智成。谓法类道世俗智。此他心智。更须决判。偈曰。过地根人上。释曰。若过地心。下地不能知上。谓下地定心不能知上地定心。若过根软根不能知上。谓信乐得人。及时解脱人道。不能知见至得人及非时解脱人道。若过人下人不能知上人心。谓阿那含阿罗汉声闻独觉佛道。下不能知上。偈曰。灭未生不知。释曰。若过去未来他心。他心智则不能知。以现在他心为境界故。复有何非所知。偈曰。法类互不知。释曰。法智种性他心智。不能知类智种性他心。类智种性他心智。不能知法智种性他心。何以故。此二心以欲界上界对治为境界故。于见位中无他心智通。以时促故。见位得为他心智境。此中若人由他心智。欲知见道心。先作加行已。偈曰。见位初二念。声闻犀喻二。佛自然具知。释曰。若声闻修他心智。欲知见道中他心。得知前二刹那心。谓法智忍法智。知类智种性境。别加行所成故。是时于中修彼他心智方便。此修观人。已度至第十六心。于中间不能得知。若犀角喻独觉。欲知见道中他心。得知三刹那心。谓前二心及第八集类智心。由加行软故。余师说。知第一二第十五心。佛世尊一切见道刹那心。不由加行心知。但以自性心知。复次尽智无生智。此二有何差别。偈曰。尽智于四谛。已知等决知。不更应知等。说名无生智。释曰。阿毗达磨藏云。何者尽智。苦谛我已知厌。集谛我已断除。灭谛我已证得。道谛我已修习。以此义。是知见明觉慧解先正对观。是名尽智。何者无生智。苦谛我已知厌。不更知厌。乃至道谛我已修习。不更修习。以此义。是知乃至正对观。是名无生智。云何由无流智得知如此。由无流智后智出。观已得知如此。由后智有差别故。立尽无生智有差别。罽宾国阿毗达磨师说如此。有余师说。由无流智得知此义。说尽无生智为见者。为以一切名释此义故。复次由证智为性故名见。是故阿毗达磨藏中说。若法是智即此法是见。复次为显今所说见异前所说见。如此名十智。谓法智类智世俗智他心智苦智集智灭智道智尽智无生智。此中世俗智。是一智一智分。法智是一智七智分。类智亦尔。苦智是一智四智分。集智灭智亦尔。道智是一智是五智分。他心智是一智四智分。尽智是一智六智分。无生智亦尔。云何智唯三。安立为十。偈曰。由自性对治。行相行相境。加行作事办。因圆故说十。释曰。彼说由七种因缘。安立智成十。一由自性故安立世俗智。非能知真实义故。二由对治故安立法类二智。由能对治欲界上界故。三由所缘相异故安立苦集二智。不由境界体异故。四由所缘相及境界体异故安立灭道二智。五由加行异故安立他心智。何以故。由此智他心法非所知故。唯欲知他心故。修加行人。得他心智。六由作事已办故安立尽智。由事已办人相续初生故。七由因缘圆满故安立无生智。以一切无流法为因故。是一切三界具对治故。于前已说。法智唯能对治欲界。复次偈曰。法智于灭谛。及道谛修道。是三界对治。释曰。灭道二法智。若修道所摄。能对治三界。偈曰。类智非欲治。释曰。类智一向不能对治欲界。此智异二故。说具对治。此十种智中。几智有行相。复有几行相。偈曰。法智及类智。有十六行相。释曰。此二智一一皆具十六行相。此行相后当说。偈曰。俗智如不如。释曰。世俗智有十六行相。有别相能缘一切法通相别相等故。偈曰。由自谛相四。释曰。苦集灭道智。由缘自谛行相起故。一一有四行相。偈曰。他心智亦尔。无垢。释曰。无流他心智。亦如此由缘自谛行相故。亦成四行相。唯道智故。偈曰。复有垢。如应知自相。释曰。若有流他心智。是自所应知心及心法如。如彼相思想亦尔。能取别相为境故。此二种偈曰。缘一物为境。释曰。是时若缘心为境。不能缘心法为境。若缘受不能缘想。如此等。若尔云何佛世尊说。若心有欲如实能知。此心有欲。如此等心及心法。不得一时取。譬如衣及衣垢非俱时取故。有欲心者。有欲有二种。一相杂有欲。二相应有欲。此中若心与欲相杂。由二义有欲。若异此有流心由相应义。是故有欲。此经中所说有欲。是相应有欲。若欲对治说名无欲。余师说如此。何以故。若与欲相应说名无欲。何有与别惑相杂亦应成无欲。是义不然。何以故。此心非欲对治故。若无染污心。非有欲非无欲。不应成无欲如此等。是故与欲相应心。此中说名有欲。乃至有痴无痴等。应知亦尔。略心者是善心。由境界少故。散心者是染污心。与散乱相应故。复次略心者与睡眠相应。散心者所余有染污心。西国诸师说如此。毗婆沙师不许作此说。彼说。此一心亦略亦散。染污睡眠相应故。若尔则与阿毗达磨藏相违。彼藏云。若如实知略心。此智成四智。谓法智类智世俗智道智。下劣心者。是染污心。与懒惰相应故。上胜心者。是善心。与精进相应故。小行心者。是染污心。或善小净品所治故。大行心者。翻于前心。由根价伴类随从力少多故。何以故。若有染污心则与二根相应。若善心则与三善根相应。若染污心则少价。不由功用所成故。若善心则大价。由多功用所成故。若染污心。无未来同类修故。无多伴类若善心有过去未来同类修故。有多伴类。若染污心则少随从。三阴所随从故。若善心则多随从。四阴所随从故。染污心力少。彼所断善根更相续故。善心力多。由一刹那苦法智忍生。能杀害十惑永不生故。是故有染污心说名小。善心说名大。动心者是染污心。与掉起相应故。不动心者是善心。能对治彼故。非寂静心寂静心亦尔。非定心者。是染污心。与散乱相应故。定心者是善心。能对治彼故。非修心者是染污心。非生修及事修所修故。修心者是善心。生事二修所修故。非解脱心者是染污心。由非自性解脱相续解脱所解脱故。解脱心者是善心。由二解脱所解脱故。毗婆沙师说如此。若作此解则不随顺经。亦不能释如此文句差别义。云何不随顺经。如经言。云何心于内成略。若心与羸弱睡眠相应。或于内摄持相应。不与毗钵舍那相应。云何心于外成散。若心于五欲尘倒乱驰动故。于前不已说耶。此心亦略亦散。已说不应理。说睡眠相应染污心不立为散故。于前不已说耶。与阿毗达磨藏相违。阿毗达磨藏相违。此亦可然。但勿与经相违。云何不能释文句差别义。不说散下劣动不寂静不定非修非解脱心差别义故。略上胜等亦尔。若非不已说诸文句差别义。同是染污心。由显彼过失差别故。同是善心。由显彼功德差别故。是故彼义差别已说。不救经相违故。此所说义。非文句义。若于经中许此心是下劣。心即是动心。汝释可然。经中不说此义。经言是时若心下劣。或疑欲下劣。于此时中轻安三摩提舍觉分。非是修时。是时若心驰动。或疑欲驰动。于此时中择法精进喜觉分非是修时。诸觉分为有散心修不思量。彼此中说名修。由能令现前故。是故无失。此中若心由懒惰胜。说名下劣。若心由掉起胜。说名驰动。是故无失。如此等或共生故。是故我等说。若心下劣即有驰动此语与密意相应。我亦不遮。于经中意不尔故。我说如此。是汝所说。一切欲相应心。说名有欲。何心与欲相应。若汝言欲至得相应故。说与欲相应。无流心应成有欲。谓有学心。若言缘欲为境界说名有欲。阿罗汉心亦应有欲。何以故。此心有时缘有流心分别有欲。由缘欲为境界故。是心云何得成有流。若汝言缘通惑为境故。是故说有欲。若尔是心但有痴非是有欲。由缘痴为境界故。缘他心为境界心。不缘至得为境界。非此心境界。缘欲为境界。是故不由欲相应故心有欲。此中应知。若尔有欲心云何。与欲相杂是名有欲。不与欲相杂。是名无欲。见经意如此。余经中所说是人心无欲无嗔无痴。不回转为法。于欲界色界无色界依欲等至得灭。故说此文。若尔于前为不已说耶。若心与别惑相杂。由但不与欲相杂故。应成无欲。由此经意则无过失。不得取此心为无欲。云何不取。由经已说。此心有嗔有痴等。故勿复广论。应说本悉檀。为取他心行相。为取他心所缘境。不取此二为境。不观行相境界起故。但知此心有欲。不能知色等境。是心生欲处。若不尔。此心则缘色等为境界。若取他心缘色等为境。他心智应成取自性。一切他心智知物别相。谓心及心法。现世他相续。欲色相应不相应为境界。于见位被遮。于修位中得。非空无相不相应法尽智无生智所摄。无间道所遮。此义应知。说他心智已。偈曰。后二十四相。空无我所杂。释曰。后二者。谓尽智无生智。此二智行相有十四。离空无我二行相故。此二虽缘真如。多缘虚假知。我生已尽。我不见从此后更受别有。由观中智力故。出观说如此言。为有无流别行相心。为无。若依罽宾国师说。偈曰。无净出十六。行相。释曰。彼说无无流行相出四谛十六行相心。偈曰余师有。释曰。西国师说。阿毗达磨藏中说。异十六心别有无流心。云何得知。彼藏云。若不相应心。为得知与欲界相应法不得知。由无常苦空无我。或由因集有缘得知。或有是处有是义。由道理相应故得知。无是处无是义。由道理不相应故得知。此执非彼藏义。谓有是处有是义由道理相应故得知等。此何为有是处有是义。由无常等相故得知。是彼藏义。是义不然。何以故。于余文中不说此义故。如此执若是彼藏义。此文句于余处亦必定应说。彼藏云。由见谛所灭心。为知与欲界相应法不。得知。由我由我所由断由常由无因由无事由非拨由胜由上由无等由极由净。由解脱由出离由不决由二心由疑由爱着由嗔恚由高慢由不了。由如此非理相应得知。若为结前此文句中应说前文句。谓有是处有是义等。由不说故。是故知非是此义四谛十六行相。为由名有十六。为由实物有十六。余师说。由实物唯有七。由名有十六。集灭道行相。各共显一物故。毗婆沙师说不尔。彼说云何。偈曰。实物有十六。释曰。此中随属缘故无常。逼恼为性故苦。对治我所执故空。对治我见故非我。同种子法道理故因。和合显现行故集。生所显故有相应能成故缘譬如土聚弋轮绳水等聚集故。能成瓶等果。此法亦尔。诸阴断绝故灭。能杀三火故静。无灾横故妙。出一切过失外故离。由行义故道。与理相应故如。正所成就故行。一向过度故出。复次一向不定故无常。负重故苦。由人所离故空。不如意作故非我来义故因。生起故集。行相应故有。为胜依故缘。无相应相应断故灭。三有为相所离故静真实善故妙。极至止息故离。能对治邪道故道。能对治不如故如。顺趣涅槃土故行。一切有对治故出。如我等所信受今当说。生灭为法故无常。违意故苦我所离故空。自非我故非我。因集有缘。如经中说。是五取阴。依欲为根依欲为集。依欲为生。依欲为有。有名应在后说。此四于欲有何差别。爱欲有四种。于自体称我起爱欲。名自体无差别。爱欲。谓我应生名无差别后有爱欲。谓我应生如此如此。名有差别后有爱欲结生爱欲名受生爱欲。此中第一是苦初因似根。譬如于果种子故名因。第二由前所。引譬如果初出芽等故名集。第三是如此种类苦缘。譬如于果田水土等为缘。何以故。由随田等缘于果中香味力熟威德差别得成故名缘等。四即是生。从此生成故。譬如于果华终故名有于爱欲行经中有二五二四有四欲。生起事尽故灭。无苦故静。如经言。比丘如此诸行皆苦唯涅槃寂静。无上故妙。不更回转故离。由成路故道。如实生起故如。定净故行。如经偈言唯此道无余。能清净见故。永破有故出。复次为对治常乐我所我见行故。修无常苦空无我行相。为对治无因一因转变因知先因见行故。修因集有缘行相。为对治无解脱见行故。修灭行相为对治计解脱为苦见行故。修静行相。为对治于定起美妙见行故。修妙行相。为对治数数退故解脱非极定见行故。修离行相。为对治无道邪道有余道此道更回转见行故。修道如行出行相。行相是何法。偈曰。行相谓智慧。释曰。若尔行相不成智慧。智慧与别智慧不相应故。若执如此则应道理。谓一切心及心法。于境界中取差别名行相。为但智慧能取境差别耶。非。云何。偈曰。共此缘境法。释曰。般若及一切有境界法。皆能取境差别。偈曰。所取别有法。释曰。若法是有一切必定取差别所取。若如此执。此义则成。智慧是行相。复由取差别能观有法。复为余法所观。所余有境界法。由取差别能观有法。复为余法所观。若无境界法。但是取差别所观。从此后是十种智。今当说善等差别。偈曰。初智三余善。释曰。是一初智谓世俗智最先所说故言初。此智有三性谓善恶无记。所余九智唯是善性。偈曰。此智通诸地。释曰。一切地者。谓欲界乃至有顶。偈曰。法智六地。释曰。法智于四定及未至中间定所得。偈曰。类。九地。释曰。类智于前六地及三无色所得。偈曰。复六智。释曰。苦集灭道尽无生此六智。若通论亦于九地所得。若别论法智所摄。则于六地得。若类智所摄。则于九地得。偈曰。四定他心智。释曰。他心智但于四定得。非余处。偈曰。欲色身依止。释曰。此他心智。于欲色界得修令现前。偈曰。法智依欲身。释曰。法智但依欲界身现前。非于色无色界身可令现前。偈曰。余智依三界。释曰。何者为余智。除他心智及法智。所余八智。分别诸智地及依止已。以四念处摄诸智今当说。偈曰。念处一灭智。释曰。是一灭智名法念处。偈曰。他心智三念。释曰。他心智若缘他心起。必定缘受想行等。偈曰。所余四念处。释曰。除灭智他心智。所余八智。通四念处摄。何智几智为所缘境。偈曰。法智境九智。释曰。法智缘九智为境。除类智。偈曰。类道智境九。释曰。类智亦缘九智为境。除法智。道智亦缘九智为境。除世俗智。偈曰。苦集智境二。释曰。世俗智若他心智是有流。此二智是苦集智境。偈曰。四智十。释曰。世俗智他心智尽智无生智此四智。缘十智为境。偈曰。非一。释曰。唯一灭智不缘智为境。缘无为法为境故。偈曰。应合法有十。释曰。为分别智境。于十种法中应合十智。何者十法。偈曰。三界无流法。无为二二种。释曰。有为法分为八。欲界色界无色界无流界。与心相应。与心不相应差别故。无为分为二。善无记差别故。是名十法。此云何合。何智缘几。法为境。此中世俗智。缘一切十法为境。法智缘五法为境。欲界及无流四法善无为法。类智缘七法为境。色界无色界及无流六法善无为法。苦智集智缘欲界色界无色界六法为境。灭智但缘善无为一法为境。道智缘无流二法为境。他心智缘三法为境。欲界色界及无流相应法。尽智无生智缘九法为境。除无记无为。由一智能知一切法不。不得。虽不得。偈曰。世智除类初。一智由无我。释曰。世俗智除自类初刹那。一切余法由无我相能解。谓一切法无我。是自体及自体共生诸法名自类。不能缘此法。有境界及境界有差别故。共一境界故。最近同时故。此智若是欲界智。是闻思二慧。若是色界智。但是闻慧非修慧。修慧缘别地为境故。此义已度。是义今当说。何人与几智相应。若凡夫人。但与一世俗智相应。若离欲凡夫人。与他心智相应。复次若圣人。偈曰。一智应有欲。于无流初念。释曰。若未离欲圣人。若法智忍初生刹那。与一世俗智相应。忍非智故。偈曰。第二三应。释曰。于苦法智刹那。与三智相应。世俗智法智苦智。偈曰。上。于四一一增。释曰。从第二刹那上第四刹那。应知一一智增。苦类智刹那苦类智增。集灭道法智刹那集灭道智增。是故于道法智与七智相应。若先离欲人。应知一切位中。他心智增相应。复次于何位中修习得智有几。偈曰。如生彼所修。忍智于见位。未来。释曰。于见道中若忍若智正生。此二同类。于未来被修。是彼行相有四亦被修。于见道中云何唯修同类智及行相。未通达余性故。偈曰。于中尔。世智于三类。释曰。于见道中世俗智是所修于苦集灭三类智时。非法智时不能对观一切谛故。故偈曰。名对观后智。释曰。是故此世俗智。说名对观后智。于一一谛对观最后时所修故。云何于道类智不修此智。此道先由世道。未曾对观故。对观不遍故。何以故。一切苦可得遍知。一切集可得遍除。一切灭可得圆证。道则不尔。不可圆修故。是故无对观后。于中不得修对观后智。若尔是时一切集未皆灭除。集类智亦无对观后。不应得修对观后智。是义不然。何以故。见集谛所应灭集。皆已灭尽故。道者是见谛所灭惑对治。不可一切皆修令尽。由性多故。是故道有别异。有余师说由见道伴类故。此执不可取。为证不成就故。对观后世俗智。有时可令现前不一向。无时可令现前。此云何。偈曰。此无生为法。释曰。此智于在观及出观位。一向不生为法。若入观不得生此智。以相违故。若出观亦不得生此智。以心粗故。若尔此云何可修。先未曾得今始得故。今时云何得。若不可令现前生。由至得故得。由得故得。此释所未曾闻。是故如此修必定不成。若执如此。修义得成。如宿旧师说。彼说云何。由出世法功力故。此对观后智则是所修。云何已修观后出观人。缘四谛为境。最胜世间智。今得现前。即彼是修如此修即是至得。若得能现前彼依止相续。何以故。若得性已性果必可得。毗婆沙师不乐受此义。复次此世俗智。为依几地修。随见道地。偈曰。自下地。释曰。随见道所依止地。或即依此地。或依此地之下地。修世俗智。若是道依止未至定地生。所修世俗智有二地。或依未至定地。或依欲界地。乃至若见道依止第四定地生。所修世俗智。或同或下。有此世俗智。几念处摄。偈曰。灭后。释曰。若观灭谛已后。所得世俗智。是最后念处摄。谓法念处由决判一世俗智。所余应知。皆是四念处摄。此观后世俗智。偈曰。共谛相。释曰。随正对观谛所得。此智行相则同此谛行相。由说与对观同行相。则已说此智与彼所缘同谛。由见道所得故。偈曰。用得。释曰。世俗。智有二种。一性法得。二修习得。由执此智共同类起。于欲界色界四阴五阴为自性。偈曰。十六六有欲。释曰。所修此言流。若未离欲人。于第十六道类智刹那中。有二智现在修。有六智未来修。谓法智类智苦集灭道智。偈曰。离欲人有七。释曰。若人先已离欲。于道类智中。他心智是第七所修。偈曰。有欲修道中。从此上七修。释曰。从第十六刹那上。于修道中乃至未得离欲。于一切加行无间解脱增进道中修七智。谓法智类智苦集灭道智世俗智。若修世间道世俗世智。是现在修。若修出世道。四种法智中。随一是现在修。余六智是未来修。偈曰。七地胜通解。得不坏杂修。于无间道。释曰。七智所修此言流。七地者。四定三无色。放彼离欲故名为胜。于五通慧通达不坏性时。若有学人于杂修定位并论。在一切无间道中。则修七智。如前所说。若修世俗道。现在修世俗智。若修出世道。四种类智及二种法智中。随一现在修。通达不坏性时。不修世俗智。非有顶对治故。此中应知。尽智为第七。偈曰。上。诸八解脱道。释曰。从离欲七地上离欲有顶。于诸八解脱道中修七智。谓法智类智苦集灭道智及他心智。不修世俗智。非有顶对治故。若现在修四种类智。及二种法智中。随修一智。偈曰。学练根解脱。六七智修余。释曰。若有学人。修练根时。于解脱道中。若有欲人。但修六智。谓法智类智苦集灭道智。若离欲人修七智。以他心智为第七。有余师说。世俗智于二位中所修。此二道于前加行中。得修世俗智。偈曰。无间道六修。释曰。若已离欲未离欲有学人。修练根无间道中。但修六智。如前。不得修世俗智。似见道故。不得修他心智。一切无间道中所遮故。云何遮非惑对治故。偈曰。有顶胜亦尔。释曰。若离欲有顶时。于诸无间道中如此修六智。偈曰。于尽智修九。释曰。离欲有顶时第九解脱道。即名尽智。此中修九智。除无生智。偈曰。得不坏修十。释曰。若人本以不坏法为性。此人于尽智位中。得修十智。得无生智故。偈曰。练不坏解脱。释曰。若人练根至不坏性。此人于最后解脱道中。亦得修十智。偈曰。所说余修八。释曰。何者为余。离欲欲界时。第九解脱道中。离欲七地五通慧。有学杂修定中。一切解脱道。为通达不坏性。诸八解脱道中。一切离欲人加行及增进道。于此一切道中得修未来八智。除尽智无生智。若有学判如此。若无学人五通慧杂修定。加行解脱道增进道中。或修九智。或修十智。五通慧杂修定无间道中。或修八智。或修九智。二通慧解脱道中。由无记故。无未来修。若凡夫人欲界及三定离欲。最后解脱道中。依定地修加行。三通慧解脱道无量等功德摄。于时世俗智未来修。他心智亦尔。除决择分能善根见道伴类故。于余处得未曾得道时。但世俗智未来修。复次于何道中所修智有几地。世俗智者。随道所依地。此地或由道初得。以此地为依止。未来修世俗智。无流道者。非一向随道所依地未来修。此云何。偈曰。为离此地欲。是得此下修。释曰。若为离欲此地修二种道。谓加行道等。随地由离欲初所得。或以此地为依止。或以下地为依止。一切无流智必定是所修。偈曰。有流于尽智。释曰。于尽智生时。一切地诸有流功德。凡是尽智所应得。皆是所修。谓不净观。阿那波那。念处。无量八解脱等。譬如同时绳断诸被绞人一时气通。复次此人已至心自在王位。一切善根由至得故。并皆起迎。譬如有人得大王位。由贡献财物说国土迎。随有所得皆是所修不。于前若未得则是所修。何以故。偈曰。先曾得非修。释曰。若法退已还得。此非所修。已修所弃舍故。为但得为修为复有余。非唯得。何以故。修有四种。一得修。二习修。三对治修。四治净修。此中偈曰。得修及习修。是善有为修。对治治净修。有流诸法修。释曰。得修习修者。谓修一切有为善法。于未来有一修。于现在有二修。此二修依前二正勤成。未生令生。已生令长。对治修治净修者。谓修诸有流法。此二修依后二正勤成。未生令不生。已生令灭。若尔有流善法。则具四修。若无流法。但有前二修。若染污及无记法。但有后二修。西国阿毗达磨师说。有六种修。四修同前。五守修。六择修。守修是六根修。择修是身修。如经言。是六根已善调伏已善修。复次经言。于身中有如此物。谓发齿爪毛等。广说如经。如此于身简择故。自爱不起。罽宾国师说。此二修入对治修及治净修摄

阿毗达磨俱舍释论卷第十九阿毗达磨俱舍释论卷第二十

        婆薮盘豆造

        陈天竺三藏真谛译

    分别慧品之二

说一切凡夫及圣人。由通义于一切智修诸德已。十八不共得佛法。谓力等。此法唯佛世尊一人。于尽智生时已至得得修。非于余人。今当说。何者。十八。偈曰。十八不共得。佛法。谓力等。释曰。十力四无畏三念处大悲。是名十八。此中解十力有七义。何者为七。一自性。二分别。三独得。四平等。五作事。六次第。七差别。此义应知。此中偈曰。处非处十智。释曰。处非处中智力具十智。偈曰。业力有八智。释曰。于业及果报中智力具八智。除灭智道智。偈曰。定根欲性力。九智遍行道。或十智。释曰。定解脱三摩提三摩跋提智力。转转根智力。种种欲智力。种种性智力。各九智力除灭智。遍行道智力。或十智。或九智。何以故。若执此道共果说名遍行道智力。则具十智。若执不共果。但有九智除灭智。偈曰。世智。于二。释曰。宿住念智力。及死生智力。但是世俗智。偈曰。六十灭。释曰。流尽智力。或六智为性。谓法智类智灭智尽智无生智世俗智。若执唯灭智名流尽智力。其义如此。若执流尽相续中智说名流尽智。力。则具十智。说十智力性已。彼地今当说。偈曰。宿住退生力。于定。释曰。宿住智力。及死生智力。依四定为地。偈曰。所余力。于诸地。释曰。所余八智力。一切地所摄。一切地有十。一谓欲界未至定中间定四色定四无色定。一切十智力。依止剡浮洲界人身起。离佛世尊不出世时。此十种智力。于余人不说名力。但于佛相续说名力。于他有对怨及碍故。不说名力。偈曰。云何。力由此无碍。释曰。唯佛灭一切流及无明习气等皆尽。于一切境界智生无碍是故于佛威力。于余人有碍。何以故。彼欲知此境。于境中智不生故。是故不应受力名。曾闻大德舍利弗弃舍求欲出家人。复次曾闻鹞所怖鸟。大德舍利弗。不能知其受生初及受生终。如此由智无对怨及碍故。佛世尊心力。如境界无有边际。若心力如此。身力云何。偈曰。身那罗延力。释曰。复次有余师说佛世尊身那罗延力。偈曰。或节节。释曰。有余师说。于一一节中具那罗延力。大德说。如佛心力无边际。佛身力亦尔。何以故。若不尔。此身则不堪受无边际智力。何以故。一切佛世尊独觉转轮王。节节中有龙结锁钩骨故。那罗延力其量云何。偈曰。百增。象等七种力。释曰。人道中百香象力敌一白象王力。百白象王力敌一摩诃诺那力。百摩诃诺那力敌一钵娑建提力。百钵娑建提力敌一婆郎伽力。百婆郎伽力敌一遮[少/(兔-、)]罗力。百遮[少/兔]罗力敌一那罗延力。如此百百增。香象白象。摩诃诺那。钵娑建提。婆郎伽。遮[少/兔]罗力。成那罗延力。有余师说。二倍此力名那罗延力。随转增为胜。何以故。佛力无量故。偈曰。此触入为性释曰。此身力应知。触入为自性。是四大胜类所造色。异七种触。余师说如此。偈曰。无畏有四种。释曰。依经文说。无畏有四种。偈曰。前二初十力。后二第二七。释曰。处非处智力。如第一无畏。如经言。我今已成三若三佛陀。广说如经。应知是第一无畏。流尽智力。如第二无畏。如经言。我今诸流已尽。广说如经。应知是第二无畏。属业智力。如第三无畏。如经言。是我所说。于弟子众。与障碍相应法。广说如经。应知是第三无畏。遍行道智力。如第四无畏。如经言。是我所说。于弟子众。为出离生死诸净品道。广说如经。应知是第四无畏。如此四法。应知是四无畏。无畏以无怖为性。云何说。智慧为无畏。由此四法故。诸佛于大集中。无复疑心故。说彼名无畏。此无疑是智慧所成故。于智说无畏非智。此四显何义。显自利利他义。前二是自利。后二是利他。复次此四唯是利益他事。能除说者垢及所说垢故。说四无畏已。念处者。由弟子众差别故有三。如经说此念处。偈曰。三念念慧性。释曰。此三念处念慧为性。是时若弟子众。恭敬心听及修行。不恭敬心听及修行。复有具二。于中佛世尊无爱欲心。无嗔恚心。无杂污心。云何说此三。为佛不共得法。此三显如来习气灭尽。复次若自弟子众。于师教恭敬受行。不恭敬受行。及具二事中。喜忧等事。如于佛一向不生。于他不尔。此三不生。于佛是希有法。余人则无。故立此法为不共得。大悲今当说。偈曰。大悲世俗智。释曰。大悲以世俗智为性。若不尔则不应成缘一切众生为境界。亦不得以三苦为行相。譬如声闻悲。云何名大悲。偈曰。由资粮行相。境平等最上。释曰。一由资粮大。能生长大福德智慧资粮故。二由行相大。以三苦为行相。缘众生起故。三由境界大。通缘三界众生为境故。四由平等大。于一切众生平等起利益事故。五由最上大。无余悲上此故大悲与悲有何差别。偈曰。差别有八种。释曰。一性差别。由无嗔无痴为性故。二行相差别。由一苦三苦为行相故。三境界差别。由缘一界三界为境起故。四地差别。由依四定。第四定为地故。五相续差别由依声闻等相续。佛相续生故。六至得差别。由离欲欲界有顶所得故。七救济差别。由欲救济欲成救济故。八悲差别。由不同同悲故。已说诸佛由十八法不与他共。为与诸佛一向共不。与诸佛有共不共。此云何。偈曰。由资粮法身。及行他利益。一切佛平等。非寿姓量等。释曰。由三因缘。一切诸佛一切平等。一因圆满平等。由昔行福德智慧资粮同圆满故。二果圆满平等。由所得法身同具足成就故。三利益他平等。由对背证转利益他事同究竟故。由此三义诸佛平等。不共者谓差别。由寿命种姓身量等。所成寿命有长短。前世后世生有异故。婆罗门刹帝利种不同故。迦叶波瞿多摩等姓不同故。身量光明有大小故。等言者。法住身坏不坏等故。如此由随时生。故有差别。若聪明人。思惟诸佛三种圆满胜德。于佛世尊所。必能得生最极爱念尊重之心。谓圆满因胜德。圆满果胜德。圆满恩胜德。此中圆满因胜德有四种。一一切福德智慧皆数习行。二长时行。三无间行。四尊重行。圆满果胜德有四种。一智胜德。二断胜德。三威力胜德。四色身胜德。圆满恩胜德有四种。谓永解脱三恶道生死恩德。或安立善道及三乘恩德。智胜德复有四种。一无师智。二一切智。三一切种智。四无功用智。断胜德亦有四种。一一切解脱障灭。二一切定障灭。三一切智障灭。四永时灭。威力胜德亦有四种。一于外尘化生转变愿成合散自在威力。二于寿命舍取安自在威力。三于障及虚空最远最速行。于少令多入自在威力。四种种自性希有法圆德威力。威力胜德复有四种。一难化能化。二答难必能断疑。三立教决定出离。四能制伏恶魔外道等。色身胜德有四种。一大相胜德。二小相胜德。三力胜德。四金刚真实骨身胜德。诸佛胜德若。总说有如此等。若分别此胜德差别。则无有边。此胜德唯有诸佛如来。能具知具说。若诸佛如来。摄持寿命无数阿僧祇劫。说乃可尽。如此诸佛如来。是无边希有功德。智德断德恩德。大宝之池。凡夫众生。由自德贫乏。损害信乐。虽证闻如此等圆满胜德。于佛不起尊重心。于如来正法亦尔。若聪明人闻此功德。起归依心彻于骨髓。于佛正法亦尔。此人由一向净信心。则已制伏不定报恶业聚已。受人天道吉祥乐报。最后趣般涅槃为胜。是故诸佛如来出世。为一切众生无上福田。由能生不空可爱胜疾善后果故。云何得知。佛世尊自说偈以显此义偈曰

  若人当来世　　于佛行少善
  受诸天生已　　必得不死足

说诸佛如此等不共德已。偈曰。有余佛法共。弟子及凡夫。释曰。诸佛如来有功德。与弟子共得。或与凡夫共得。是何功德。如次第。偈曰。无诤及愿智。无碍解等德。释曰。诸德谓无诤三摩提愿智。四无碍解。通慧定无色三摩提。无量解脱。制入遍入等。此中无诤三摩提者。有诸阿罗汉比丘。已知众生众苦是惑所生起。欲令自身于他成无上福田。欲制伏他缘自身烦恼生起。生如此相智。由此智他人不得生起一切种诤。由此智无有他人缘观行人。或起欲心。或起嗔心。或起高慢心等由此正行。必不发动随余一人所应起烦恼。故名无诤。此三摩提体相云何。偈曰。世俗智无诤。释曰。此是三摩提自性。谓世俗智。偈曰后定。释曰。后定谓第四定最后分。此定虽通以第四定为地。但是乐速智。偈曰。不坏法。释曰。但于不坏法阿罗汉相续中生。非余阿罗汉。何以故。余阿罗汉于自相续。有时不能令离余诤生起。偈曰。人道生。释曰。此定在人道中修得。唯于三洲。此定缘何境生。偈曰。未生。欲有类或境。释曰。未来欲界有类。或为此定境。愿他诸惑勿生依此门生故。无类惑者。不可遮离诸遍行惑。缘具界地生起故。如说无诤。偈曰。愿智亦如此释曰。此亦世俗智为性。依后定为地。依不坏法相续生。于人道修得。若尔差别云何。偈曰。但缘一切境。释曰。愿智缘一切法为境起故。此异于彼无色界法。由愿智不可证知。虽然由等流行差别。则可比知。毗婆沙师说。此中行田人为譬。愿智所修法门云何。是自己所求欲知众事。为此故入远际第四三摩提。愿我必知此事。即于此事如实而知。随此定近远行力知近远亦尔。偈曰。于法义方言。巧辩无碍解。释曰。无碍解有四种。一法无碍解。二义无碍解。三方言无碍解。四巧辩无碍解。此无碍解。应知如无诤三摩提。云何如依不坏法相续生。于人道修得。此二同彼境界地。自性差别说此异彼。偈曰。前三名义言。次第无碍解。释曰。于名句字聚中。于义中。于言语中。不可回转智。是名法义方言无碍解。次第应知。偈曰。第四中理脱。于言道自在。释曰。不可回转智此言流。中理离障失言。中定道自在显现中。不可回转智。说名巧辩无碍解。偈曰。此缘言道境。释曰。正说及道。是此智境界。偈曰。九智。释曰。此解以九智为性。谓巧辩道自在无碍解。除灭智。偈曰。一切地。释曰。此解依一切地起。谓欲界乃至有顶。由缘言道随一为境故。偈曰。十或六义解。释曰。义中无碍解。若以一切法为义。此解以十智为性若唯涅槃为义。但以六智为性。谓法智类智灭智尽智无生智世俗智。偈曰。遍处。释曰。此义无碍解。依一切地起。偈曰。余世智。释曰。所余法方言二无碍解。以世俗智为性。缘名句等言语为境故。偈曰。欲界定法解。释曰。法无碍解有五地欲界及四定所摄故。于上无名等聚故。偈曰。于言欲初定。释曰。方言无碍解。依欲界初定为地。于上无觉观故。于分别假名论中。分别四无碍解云。于名句字中。于彼所目义中。此义一二多三时男女等差别说中。此说无障失中。不可回转智。名法等无碍解。是故彼次第得成。方言者。因理释言。譬如由有碍故名色等。言于立破胜言说名巧辩。余师说。此四无碍解。算数佛世尊言声论因缘论。次第是此四解。先加行法门。何以故。若人于四处未修明了加行。不能得生此解。有余师说。于佛世尊正法中。彼一切加行。皆圆满成。若人得一。是人必定具得四。何以故。偈曰。若不具未得。释曰。若得彼不具足不可说。此人得四无碍解。是所说无诤等功德。偈曰。六远际定得。释曰。此六由远际定力所得故。说彼为远际定。偈曰。此六。释曰。是第四定名远际。六法为体。谓无诤三摩提愿智三无碍解。及远际三摩提。方言无碍解。虽由远际定力得。不依第四定为地起。是故不取。何法名远际三摩提。偈曰。最后定。随顺一切地。此至增究竟。释曰。此定唯以第四定为地。云何随顺一切地。先从欲界善思心入初定。从初定入二定。如此次第。乃至入非想非非想定。复次从非想非非想定。次第逆修。乃至至欲界心。复次从欲界心。更次第顺修。乃至第四定。如此修随顺一切地。云何名至增究竟。如此修第四定。从软修中从中修上。此三更各分为三。故成九品。最后品名至增究竟。如此定名远际定。际者或差别为义。或增极为义。譬如四际及实际。如此。六功德。偈曰。唯佛。非行得。释曰。异佛所余诸人。必由修行方得。不由离欲得。唯佛世尊。无功德是修行得。一切功德皆是离欲得。何以故。唯一世尊法王。于一切法得自在故。是故一切功德。随如来意欲皆悉现前。如此诸德皆与弟子共得。若通慧等亦与凡夫共得。何法名通慧。偈曰。如意成耳心。宿住死生尽。智证名通解。六种。释曰。如意成境。智证通慧天耳。他心差别宿。住念死生流尽。智证通慧此六名通慧。于中前五与凡夫共得。一切六通慧。偈曰。解脱智。释曰。以解脱道智为性。譬如沙门果。偈曰。此四世俗智。释曰。除他心差别通慧及流尽通慧。余四皆以世俗智为体。偈曰。他心慧五智。释曰。他心通慧。以五智为体。谓法智类智道智世俗智他心智。偈曰。尽通慧如力。释曰。如前所说。流尽智力。此通慧应知亦尔。或六智或十智为体。彼以一切地为依止。应知此亦尔。偈曰。余五于四定。释曰。所余五以四定地为依止。此云何不以无色定地为依止。于中三通慧缘色为境故。不得依无色定地起。他心差别通慧。色门所生故。亦不以无色定地为依止。宿住念通慧。忆持位差别次第所生故。亦不以无色定地为依止。此以处所姓名住等为境界故。若人欲知他心。于自相续先观身心二相。谓我身相如此。心相如此。如观自身心相。于他相续亦起如此相思惟。由此即知他心。是故通慧得生。若此通慧已成不观色。自知他心。若人欲忆持宿住。从前次第观察灭自识相已。如此逆次第思惟诸位差别。乃至托胎心。次由忆持中阴一刹那故。此通已成。如忆持自宿住。忆持他宿住亦尔。若此通已成。亦得起忆宿住。若此事昔已经受。此事是所忆余则非。若尔于他事云何亦如此。若尔云何忆持五净居天宿住。由听闻所曾受故得忆持。若人从无色界退生于此界。由以他相续为依止故。得修无色宿住通慧。所余依止自相续得知。如意成通慧等。观察轻相音声光明。是彼加行。复次此五通慧。偈曰。自下地境通解。释曰。随所依止地。如意成通慧性。由此得行此地及化生等诸物。或于下地非于上地。如此由天耳通慧。得闻自地声及下地声。不得闻上地声。由他心差别通慧。不得知上地他心。由宿住念通慧。不得忆上地宿住。由死生通慧。不得见上地死生。是故依止无色地心。由他心通慧宿住念通慧。皆不得取。由地上故。此诸通慧云何得。若未曾悉由修行所得。偈曰。曾悉离得。释曰。此五通慧。若余生所数习。则由离欲得。若别胜由修行得。一切皆由修行得生。偈曰。第三三念处。释曰。他心差别通慧。三念处摄。谓受心法念处。心及心法为境界故。偈曰。意成耳眼初。释曰。如意成天耳天眼通慧。初念处摄。谓身念处。缘色为境界故。如意成通慧。以四外入为境界除声。天耳天眼通慧。以声色为境界。若尔死生通慧。云何能知如此。如经言。是彼众生与身邪行相应。口意邪行相应。诽谤圣人起邪见。受邪见法及业故。由此舍身命。必受无行恶道堕负黑闇处生。所余广说如经。由天眼不得知。如此有别智。是天眼通慧伴类。于圣人相续中生。能知如此由不决定故。所余通慧以四念处为性此义自成。偈曰。天耳眼无记。余通慧皆善。释曰。天耳天眼通慧。是无记性。此通慧以耳识眼识相应智为体。若尔此二以四定地为依止。云何得成。由随依止地说为彼地。故不相违。眼耳根是此识依止。以四定为地。复次由随无间道立彼地。所余四皆是善性。若尔于分别道理论中云何说。何者为通慧谓善慧。此文或约胜义说。或约多义说。于六通慧中。偈曰。三明得。释曰。宿住念死生流尽通慧。说此三为无学明得。云何唯此三名明得。所余非。偈曰。前际。等无明对治。释曰。此三能次第断除前际后际中际无明故。是故唯三名明得。三中若真实无学。偈曰。最后无学。释曰。流尽证智定是无学。偈曰。二。同名彼续生。释曰。所余二通慧。由生于无学相续中故。说名无学。此二自性非有学非无学。若尔云何不许此二通慧名有学。偈曰。于学不说明。续有无明故。释曰。由佛不说此二通慧是有学法。云何不说。若相续有无明。于中安立明得。则不应理。更为无明所制伏故。于六通慧中。偈曰。一三六是导。释曰。如意成他心差别流尽通慧。此三如次第。即是三导。谓如意成导记心导正教导。此三各从初最能引受化人意故。有增碍心未信心不欲修心。此受化人。由此三起归向心信受心修行心故。说此三为导。偈曰。三中正教胜。释曰。于三导中。正教导为最胜。何以故。偈曰。非不决定故。生善爱果故。释曰。如意成导记心导。由明可作。有明处名乾陀梨。诵此明咒。即能飞行空中。复有明处。名伊叉尼柯。通此明处能知他心。如实正教。不可由别方便作。由此非不决定。故胜前二。由前二导。但能回转事成。由正教导。一能生善果。二能生可爱果。由此能显正方便故胜前二。前已说如意成。此是何法。若顺毗婆沙道理。偈曰。如意成定。释曰。由彼如意事成就故。定名如意成。何事由彼成。应说此事。偈曰。中。行空及化生。释曰。此中行空有三种。一引将身行。二愿成行。三心疾行。此中偈曰。心疾行唯佛。释曰。此行最迅速如心。唯佛世尊有如此行。余人则无。于最远处。由发一行心时即至彼故。故佛世尊说。诸佛境界难可思议。所余二不由说于佛自成。偈曰。余将身愿成。释曰。声闻独觉。有引将身行。如鸟次第引将身行。愿成行者。是极远处。愿令最近故。由此疾彼行。化生如意成有二种。一欲界相应。二色界相应。此中偈曰。欲界化外入四入类二种。释曰。欲界中化生。以色香味触入为体。此有二种。或与自身相应。或与他身相应。偈曰。色二。释曰。色界相应化生。唯以二入为体。谓色入触入。于彼无香味故。此亦有二种如前。如于欲界化生有四种。于色界亦尔。是故略说化生有八。若生色界人。化生欲界物。云何不至得香味。譬如衣及庄严具。无有至得。化生物亦尔。有余师说。彼所生物。唯有二入。为由化生通慧化生诸物。为不尔。非。此云何由通慧果。此是何法。偈曰。由化心。此心有十四。释曰。有通慧果是生化心。能生一切所化物。此心有十四。偈曰。如次第定果。二至五。释曰。初定地通慧果心有二。一欲界地。二初定地。第二定地通慧果心有三。谓欲界初定二定地如此。第三第四定地通慧果心有四有五应知。此义变化心应知。是诸定果属自地及下地。偈曰。非上。释曰。无有上地变化心为下地定果。第二定果欲界变化心。从初定地。彼果由道为胜。偈曰。得如定。释曰。此变化心至得如定至得。为唯从变化心即出观为不。无如此义。是故说此义。偈曰。净定。自生二从彼。释曰。从清净定次第生变化通慧。从变化通慧次第生变化果心。从变化果心生无量变化果心。不从余心生。次从变化果心生变化通慧。从变化通慧生净定。或生变化果心。何以故。若人住定果。不更入本定。无有从定果即出观义。一切所化物。偈曰。由自地化生。释曰。随化生物地。化生心地。则与此同地。何以故。由别地变化心。不能化生别地诸物。偈曰。言说由余地。释曰。由同地心亦得言说。若所化人在欲界。或初定地。由同地心。可得令言说。若所化人在上地。但由初定心令言说。于上地无发起有教业心故。若令多所化人言说。为同为不同。偈曰。与能化非佛。释曰。离佛世尊所化人。余一切人所化人。与能化人俱同言说。若能化人有言说。与多所化人俱同言说。如偈言

  一人正说言　　诸所化俱说
  一人若默然　　诸所化亦尔

唯佛世尊。如所意欲。或前或后。所化众人。或彼问佛答。或佛问彼答。是时若起言说心。是时即无变化心。应无所化。云何能化人。令所化言说。偈曰。立愿已别作。释曰。由欲令所化久住故。先发化生愿。然后入观。更由别心。发起有教业故。令彼同有言说。为人生在所愿事皆随意成。为死后亦成。偈曰。已死愿事成。释曰。由圣大德迦叶愿力故。骨身住不坏故。知死后愿事亦得成此愿。偈曰。非虚余说无。释曰。若物非坚实。相续不久。于中愿事不成。圣大迦叶。不愿留皮肉等身分故。有余师说。若人已死。无复愿事。若尔圣大迦叶骨身云何得住。由大德弟子诸天威力护持故得住。为由一心化生一物。为由多心化生一物。偈曰。初一由多心。已成翻此能。释曰。初修学时。随一所化物。起多变化心。化生事方成。若化生通慧已成。由一变化心。化生非一物。随量欲化生。为一切变化心皆是无记不。偈曰。修得是无记。释曰。若变化心。是修得果。必定是无记。偈曰。若生得有三。释曰。若变化心。由生得则有善恶无记。谓天龙鬼神等生得变化心所作。或于自身化生。或于他身化生。此九入为性。有色入除声故。不各离根生故。譬如纪美虫及伊师迦草。如意成有二种一修得。二生得。此复有二种。偈曰。意成由咒药。业生故五种。释曰。若略说如意成有五种。一修果。二生得。三咒成。四药成。五业成。业成者。譬如顶生王等及中阴众生。是所说天耳及天眼。此二为是天种类故说天。为如天故说天。此义应思如天耳天眼者。谓菩萨转轮王宝长者。若是天种类耳眼。偈曰。天耳及天眼。清净色定地。释曰。若人入四定。缘音声光明。修加行为方便故。依四定地。四大有二种。清净色起遍耳眼边。为闻声见色依止。由依定地生故。此耳眼是天种类。复次此二。偈曰。等分具恒故。远细等境界。释曰。天耳天眼无非等分。恒与识相应故。无不具根。无盲乱等失故。譬如色界众生。上细障远等色及声。皆是彼境。若肉眼如偈说。远住被障细。遍处色不见。肉眼见对色。天眼则翻此。若由天眼见色。所见色近远云何。随人随眼所见色近远亦尔。声闻独觉佛世尊。若不作功用心。欲见能见一千二千三千世界。若作功用心欲见。偈曰。二三千无数。应供独觉佛。释曰。若大声闻由天眼欲见。作大功用心。能见中二千世界。若犀角喻独觉。由天眼欲见作大功用心。能见大三千世界。若佛世尊。由天眼欲见。能见阿僧祇世界。随佛所欲见。何以故。如智能于法天眼。能于色亦尔。为但如意成有生得。为余亦生得。偈曰。有余生得。释曰。天眼等四亦有生得。一切生所得。不得通慧名。偈曰。眼。中阴非彼境。释曰。是生得天眼不能见中阴众生色。何以故。此色但是通慧眼所见。非生得天眼所见。除彼同类。偈曰。他心智有三。释曰。生得言流。若生得应知三种。谓善恶无记。偈曰。观明咒所作。释曰。不但生得有三种。学伊叉尼柯论。能观相人所得他心智。由思惟分别所成。或由明咒所作。此应知亦有三种。谓善恶无记不如修得一向是善。由生所得他心智及宿住念智。偈曰。地狱初能知。释曰。地狱众生。初受生乃至未为苦受所逼。于中能了达他心。及能忆持宿住。若生住余道。由此二恒知。偈曰。于人无生得。释曰。唯于人道如前所说。如意成等五。无生所得。若尔云何得有自性忆持宿住人。此从业差别所作。何以故。于彼亦有三种。宿住念智。有修得果。有生得。有业所作

阿毗达磨俱舍释论卷第二十阿毗达磨俱舍释论卷第二十一

        婆薮盘豆造

        陈天竺三藏真谛译

    分别三摩跋提品第八

由依止智慧一切功德。谓智慧种类分别说已。别性类功德今当分别说。是故最初依定应作分别说。由一切功德依止彼故。偈曰。四定有二种。释曰。若略说定有二种。由生得定修得定差别故。复次此定唯有四种。谓初定二定三定四定。此中受生中定。不应更说。于分别世间品中。偈曰。生得定已说。释曰。云何说。各各定三地。四定有八地。修得定必定应说。故说此言。偈曰。修定善一类。释曰。若不分别。唯心善一类名定。是三摩提性故。偈曰。共伴类五阴。释曰。若分别诸定。共随行相应法。应知五阴为性。何法名一类。谓一境等。若尔唯心一境成定。非别类心法成定。不说诸心是定。由彼法诸心成一类故。说彼法为定。彼法名一类。为不如此耶。一切心刹那刹那灭故。皆是一类。若汝言第二心从此境不散故。是一类。是义不然。于相应法中。定大地应无用。由此是三摩提。是故诸心共缘一境。汝何故不许此义。若言由定大地故诸心成一类。应立一切心皆成一类。此亦成失。是义不然。由此定势力弱故。经部师说。是心同一类故说名定。何以故。三摩提者。谓依心学。心清净为胜。经中说名四定。余师说。如此定者。名持诃那。持诃那是何义。由此得知得见故。名持诃那。何以故。若心得定。则能如实知见。此名以思量为义。思者即是般若。此悉檀作如此说。若尔一切三摩提。皆应名持诃那。由一类能令如实知见故。是义不然。于胜类中立彼名故。譬如作光名曰。于中与何胜法类相应。若定与分相应此定则与胜类相应。何以故。此共奢摩他毗钵舍那。双生起故。故说为现法安乐住。及迟速乐行。由彼最明了思量故。故彼是胜类。若善一类。名持诃那。有染污云何名持诃那。由邪思惟故。若尔则有大过之失。是义不然。于相似中。由但立名故。譬如坏种子。故佛世尊。亦说恶法。为持诃那。复次是善一类。有何相名初定。乃至是善一类。有何相名第四定。偈曰。有观及喜乐。释曰。觉观喜乐相应善一类。说名初定。由说观觉。即被说觉观。如火及烟。相应行故。有不相离相离故。无有观有喜乐与觉相离。所余三定偈曰。前前分所离。释曰。善一类言流。觉观所离。但有喜乐。是第二定觉观喜所离但有乐。是第三定。觉观喜乐所离但有舍。是第四定。如说四定。偈曰。无色尔。释曰。无色有几种。义与定同。彼亦有二种。由修得生得故。亦有四种。由减损想故。是彼生得。于前已说。谓无色界无处。由生有四种聚同分及命。依此心相续。修得无色定。若不分别。但以善一类为性。由此义无色定与四定同。偈曰。四阴。释曰。若分别诸定。共随行相应法。应知四阴为性。无随行色故。偈曰。寂离下地生。释曰。空遍入从寂离第四定生。识遍入从寂离空遍入生。无所有遍入。从寂离识遍入生。非想非非想遍入。从寂离无所有遍入生。无色定由此故成四。何法名寂离。由此道彼解脱他地故。说此道名寂离。彼定至得离欲故。是四无色定。偈曰。制伏色想名。共三种近分。释曰。空遍入近分定。缘第四定为境界故。未得制伏色想名。何以故。于中制伏色想未竟故。未得灭离。是前所说。无色界但有四阴。此言不成就。谓于无色界无色。若无色界有色。云何说为无色界。由色细故。譬如阿宾伽罗。执彼所有色。其相云何。若唯有身口护色。身口既无。云何得有身口护色若无四大。说有四大所造色。无如此义。若汝言如无流护。是义不然。由有流四大有故。于说彼三摩跋提。中乃至有拨言。谓无色等想。若彼有身必定有色根。云何许彼有细色。若汝执由身量极细故说无色。于不可见色水虫。应成无色。若汝执彼色极净故说无色。于中阴及色界。亦应立为无色。若汝执由无胜。彼净色故说无色。则但有顶成无色。所余应非。何以故。如修三摩跋提。三摩跋提生差别亦尔。彼定生色。由非下地根所取故。于彼有何差别。若汝言二界名随义立。第三界名非随义立。此中以何道理为证。由说寿命暖触相应故。如二芦束互相依持。名色及识。由说互相依故。于十二缘生中。说依识名色生。依名色识生。复有别证。离色乃至离行。由拨识去来故。是故于无色界。有色义成。是义不然。应更思量故。此义必定应共思量。谓说寿命暖触相应义。此言为依欲界寿命说。为依一切寿命说。名色及识互相依言。为依欲界色界识说。为依一切识说。说名色依识生言。说识依名色生言。此中为一切识以名色为依。一切名色以识为依。为不皆尔。此中说离色等。拨识去来言。为离一切色等。拨识去来义。为随离一。若汝言。由佛不分别故。不可自分别思量。是义不然。有大过之失故。是外暖触不应成与寿命相离。复次外色应依止名。由不分别说故。由佛说四识住及四食。于色无色界应有段食及色识住。若汝言。说过用段食诸天。及说喜食诸天。由此言故。无大过之失。于无色亦应尔。不应立有色。由佛说无色是一切色出离故。如经言。是寂静解脱。过一切色是无色。复有说有众生无色。复有说由过一切色想及有碍想故。知无色界中无色。何以故。若彼实有色。彼必定应生想分别自色。若汝执。观下地粗色故说无色。是义不然。何以故。于段食中。此义应同。四定出离下地故。于中应立无色。云何不说彼是受等出离。由是下地受等出离故。彼已过一切种色类。不过一切种受等类。是故说彼但是色出离非受等。由有不说出离有者。由有不得出离有故。不能出离一切有。及永出离有故。复次佛世尊。于色定中。说言于色定中。若有色类乃至识类。于无色定中。说言于无色定中。若有受类乃至识类。于无色界。若有色类。云何不说若有色类言耶。是故偈曰。无色定无色。释曰。由此二证应知。于无色界必定无色。说有色者。此是邪言。与理相违故。若尔于彼中无量劫色相续已断绝。后从彼退时。色云何更生。偈曰。更生色从心。释曰。色从心更生。昔时色报因所熏习故。此心有功能生于今色。若不依止色。心云何得生起。云何不得生起。此中非所曾见故。若尔离段食。于色界中不应得生起。何以故。此中非所曾见故。于前已说。此依止能令彼心相续生起。说此义已。复次此义今当说。为空无边入等必定以空等为境界故。说彼以此名。为不尔非。此云何前三者。偈曰。空无边及识。无边无所有。由加行立名。释曰。空无边识无边无所有。彼作如此思惟。得修观行。因此加行。是故彼如次第得此三名。偈曰。昧故非想非。释曰。由想软昧故。说名非想非非想。何以故。彼想不明了。非全无想。若彼于中修如此观行。想即是病。想即是痈。想即是刺。无想即是痴闇。是寂静。是美妙。谓非想非非想入。虽然不由此加行立名。云何彼执如此观行。决定应。释曰。相微细故。此义于前已说。偈曰。如此根本定。八物释曰。根本定若约实法。唯有八物。谓四色定四无色定。此中偈曰。有三种。七。释曰。除有顶所余七定。各有三种。何者为三。偈曰。有啖清净。无流。释曰。此七定有与啖味相应。有清净有无流。偈曰。第八二。释曰。第八是有顶。此定有二种。有与啖味相应。有清净无无流。复次此中偈曰。啖味相应定。有爱。释曰。啖味谓贪爱味。是定所有功德。缘此起爱欲心。爱欲即是能啖故。说贪爱所染污定。名与啖味相应。偈曰。世间净。清净。释曰。世间定法若善为性。说名清净。与无贪等白净法相应故。复次此中何定是啖味相应所啖。偈曰。是堪啖。释曰。是所堪啖即是清净三摩跋提法。此法是彼所啖。必从一刹那等已灭。若是所啖则已出。彼能啖即是所修观偈曰。出世定无流。释曰。出世三摩跋提法。是名无流。此三摩跋提法中。唯四持诃那有分。四无色定无分。此中偈曰。于初有五分。释曰。初持诃那中有五分。五者偈曰。觉观喜乐住。释曰。觉观喜乐善一类。此五于定能引治安。依体故说为五分。此五分中第五彼说亦定亦分。所余但分非定。若实说如四分军。五分持诃那亦尔。偈曰。熹等及内净。于第二四分。释曰。于第二持诃那有四分。一内澄净。二熹。三乐。四善一类。此四应知如前。偈曰。第三有五分。舍念慧乐住。释曰。于第三持诃那有五分。一舍二念三慧四乐五住住即是善一类。何以故。住是三摩提别名故。如经言。何者为三摩提。是心住于正境于正位由此经故。知住是三摩提别名。偈曰。最后有四分。中受舍念住。释曰。第四持诃那是最后。于中有四分。谓非苦非乐受。舍清净念清净善一类。若依如此文。定分有十八。初定三定各有五分。二定四定各有四分故。如此数由名立。若由实物。偈曰。实物有十一。释曰。初定分有五。于第二内澄净增。于第三舍念慧乐增。于第四非苦非乐受增。由此义故有十一。是故说。若分在于初定。于第二为是分不。有四句。第一句是觉观。第二句是内澄净。第三句是喜乐善一类。第四句除前所说是余法。如此一切定分。皆应以四句更互相摄。云何于第三定中。说乐为别物。由此乐于第三定成受乐。于前二定中。偈曰。轻安乐前二。释曰。于第一第二定。是轻安说名乐。于前二轻安乐。于第三是受乐。此义云何成。前二持诃那。与乐根不相应故。何以故。于前二定中所说乐。不应成身乐。入观人五识不有故。不可立为心乐。已说为喜故。喜者谓心踊跃。喜乐二种。一时俱生。无如此义。喜乐或于定中递互生起。此不可执。由说定有五分故。有余师说。于前三定中。心地乐根。皆悉不有。但安立身乐根。以为彼分。若尔经中云何说。如此经云。何者为乐根。缘能起乐触。身心受乐。所爱胜受类。说此名乐根。此文不知何人所增加。何以故。于一切部中。唯有身乐文故。文言修观人由身正受乐。此义由自名所说故。若汝执由心身受者。若作此说。得何功德。于第四定轻安最极。不说为乐故。若汝言。是轻安随顺乐受故。亦得说名乐。是义不然。第三定中何故不说轻安名乐。若汝言。由为舍所损害故。是义不然。由舍彼增进故。品类胜前二故。复次由经轻安与乐有差别如经言。是时圣弟子。从轻安生喜。由身证已生起。此已于其中住。于此经中由别说轻安及乐。是故知轻安非乐。若汝言。正入观人身识云何生。此不相违。何以故。有风从三摩提生。名轻安与乐受相符。依内起遍满身故。若汝言。由外散乱即便退定。是义不然。从定生依内身起。由此身乐与定相随故。无有退义。若汝言。身识起时。观行人即出定。是义不然。由前言所成故若汝言。由欲界所生身根。色界相应触识不应得生。是义不然。自轻安识生故。若尔身根所领触及身识。应成无流。勿有一分有流一分无流。由说身轻安为觉分。是义可然。若汝言。由随顺觉分故。说为觉分。无流义亦应尔。若汝言。此执与经相违。经云。何者名有流法。一切眼根乃至触尘。是故相违。是义不然。由依别触身识别意说故。若汝言。于无流法。无一分有流一分无流。是义不然。不俱时起故。于中复有何失。若汝言。乐及喜不并起故。初定应无五分。是义不然。依应有义说故。譬如说觉观。若汝言。此义未成。由譬不成就故。是义不然。由粗细二心一时相违故。由汝不说此义中过失故。是故于初定五分中。由减二三四分故。安立第二定等。由此义故。于初定说有五分。为欲减前安立后定故。是故不减想等。若不尔。云何唯五为分。若汝言。由有益故立别分。是义不然。觉观二法。于念慧中最有益故。有诸部师。作如此诤论。宿旧诸师。不说如此不随。可知所有法立为定分。是故彼执应须思量。何法名内澄净。觉观散动灭离故。相续清净流。说名内澄净。何以故。如江有浪。由觉观散动故。此相续生起。不得清净。若尔此非别物。云何由此实物定分有十一。是故偈曰。信根内净。释曰。有别物谓信根。此人由得第二定地故。于出离寂静地中。生起决信故。此中说信根。为内澄净。有余师说。觉观三摩提内澄净。悉非别物。若彼非实别物。云何成心法。心位差别。有时说为心法。由心成故。阿毗达磨悉檀。不说如此。是汝所说。喜者是适心。此义云何可知。若不尔。欲以何法为别。如别部所许。别部云何许。彼执有别心法名喜适心。是三定中乐。若非于三定中乐应成适心。偈曰。喜。适心由二证。释曰。佛世尊于毗波利多经中说。第三定已于中先生适心。根灭尽无余。于第四定中。乐根灭尽无余。佛复于余经中说。由乐根苦根灭故。于前忧根适心根灭故。广说如经。由此二证。于第三定中。必定无有适心根。是故喜根即是适心根非乐。如清净定中所说分。于染污定为有不。不有何分于彼不有。偈曰。染污无喜乐。内澄净念慧。及舍念清净。释曰。若定有染污。初定无寂离生喜乐。不能寂离惑故。第二定无内澄净。由惑所染浊故。第三定无念慧。由染污乐所乱故。第四定无舍清净念。清净由与惑相应故。有余师说。唯如此。偈曰。余说无轻舍释曰。有余师说。初定二定。若有染污则无轻安。第三第四定。若有染污则无舍。由此二法是善大地故。佛世尊说。三定有动变。由有过失故。偈曰。离八过失故。说第四不动。释曰何者为八过失。偈曰。觉观及二息。余乐等四种。释曰。觉观乐苦喜忧出息入息。此八是诸定过失。此八过失中随一过失。于第四定中无。是故唯说第四定为不动。觉观喜乐等所不能动变故。故经中说。第四定为不动。譬如内密室无风灯光。余师说如此。于前二定。说有适心受。由与喜相应故。第三乐第四舍。如修观定中受。于生得定中受为如此不。非此云何。偈曰。喜受乐舍受。舍受及喜受。乐舍及舍受。生得定诸受。释曰。于初生得定中有三受。一乐受与三识俱起。二喜受以意识为地。三舍受与四识相应起。于第二生得定中有二受。谓喜及舍。此二以意识为地。无乐余识不有故。于第三生得定中有二受。谓乐舍。此二以意识为地。于第四生得定中。唯有舍受。由如此义。生得定受。与修得定受不同。于第二定等。若无三识及觉。彼众生云何得见闻触。彼复云何得起有教身口业。不说于彼受生众生眼识等不有。虽有。不属二定等地。此云何偈曰。眼耳身三识。身口业缘起。二等初定得。释曰。眼等三识。及能起有教业识。于第二定等虽不有。彼能令现前。譬如变化心。彼由此识能见闻触。及能起有教业。偈曰。此无染无记。释曰。此四识无染污亦无记。第二定等众生所引四识令现前。此四识应知以初定为地。非有染污。由彼离欲下地故。非善下劣品故。说定事已。复次清净等四色定。及四无色定至得云何。偈曰。不得得清净。由离欲及生。释曰。若人不至得彼。此人能得清净四色定及四无色定。或由离欲下地。或由受生下地。除有顶。何以故。清净有顶。不由受生得故。不得者此言云何。若人未曾得。及舍至得。由加行能得清净。或得决择分清净。由退故得退分定。是故毗婆沙中说此言。为有如此不。或由离欲至得清净定。或由离欲弃舍清净定。由退堕及受生亦尔。说有约退堕分初定。论此六义。何以故。由离欲得此故。由离欲大梵处弃舍此故。由退堕大梵处离欲得此故。由退堕离欲欲界弃舍此故。由舍上大梵处受生得此故。由从此退堕受生欲界弃舍此故。偈曰。无流由离欲。释曰。不得得此言流。若人已曾得。由尽智更得无学无流。若由修练根道。或得有学。或得无学。为不如此耶。由入正定聚。初得无流。次第修观人。不必定由未曾得得此无流定。如必定应得。是今所说。偈曰。染污退生得。释曰。不得得此言流。由退得者。若人退此离欲。更还得此。由受生得者。从上地更生下地。复次从何定法。后几种定次第得生。从无流初定。后有六定。无间得生。于自地清净定无流定为二。于第二第三定。亦各有二。从无所有入后次第生有七。于自地清净无流为二。识无边入。空无边入。亦各有二。于有顶但有清净无无流。从第二定。后次第生有八。于自地清净无流为二。于第三第四及初定。亦各有二。从识无边入后次第生有九。自地有二。空无边入及第四定有四。无所有入及有顶有三。由如此方。所余色无色定次第十十定法。应如此知。此中是略摄。偈曰。从第三上下无流后善生。释曰。由说善性清净及无流皆彼摄。同是善性故。无流定法后次第。或依自地二种定法生。谓清净无流。或上地下地。乃至第三亦尔。何以故。超修观人过第三处求超不得成。云何如此。由过远故。从类智次第能修无色定观。从法智次第不得如此。以下地依止为境界故。如说从无流次第生诸定。所余应知亦尔。偈曰。从净生亦尔。长染污自地。释曰。此中生自地染污定长于前。此从清净定后次第得生。所余诸义如无流。何以故。无流定后。染污不得生故。偈曰。从污自地净。染。释曰。从染污定后次第。于自地清净及染污定得生。偈曰。一下地净。释曰。若人为惑所逼下地若清净。于中亦生尊重。若人已了别此定。谓此定染污行于下地定。则从善行于善。不从染污。若不分别。云何得行于下地清净定。由前引心力。何以故。此人于前。有如此欲乐。谓宁得下地清净。不用上地染污。是先意欲众生相续亦能随逐。譬如人先发愿方眠如所要期时即觉。若无流从染污后。一切种次第不得生。此言约修观时说。谓从清净定及染污定。后次第自地染污定生。非于余地。偈曰。退时从净染。一切。释曰。死堕时从生得清净定。后次第一切地染污定生。偈曰。染非上释曰。从染污四色定四无色定。后死堕时。次第自地下地染污定生。非上地。复次非从一切清净定后无流定生。若尔此义云何。偈曰。清净定有四。退分等。释曰。退堕分。安住分。增进分。决择分。清净定有此四种。有顶有三种。除决择分故。此四其相云何。偈曰。次第。或生自上地。无流随得故。释曰。若此定功德随顺烦恼生。名退堕分。若此定功德随顺自地名安住分。若此定功德随顺上地名增进分。若此定功德随顺无流名决择分。是故说此定名无流。此四种定中几定从几定后次第生。偈曰。二三三及一。从退等次第。释曰。退堕分定后。次第二定得生。谓退堕分。及安住分。安住分定后。次第三定得生。除决择分。增进分定。后次第三定得生。除退堕分。所余次第得生。决择分定后。次第一定得生。谓决择分定。修超定观。云何得成。偈曰。去来于二类。八地密超一。修超诸定观。行非等分三。释曰。去者谓次第修观。来者谓逆修观。于二类者。谓有流无流。八地者。谓四色定四无色定。密者谓上下次第。超一者谓过一一地。先于有流八地。或顺或逆修观。修观成熟已。次于七无流地修观亦尔。修观成熟已。后时为成就。于修自在故。从有流初定。超入有流第三定。从有流第三定。超入空无边入。从空无边入。超入无所有入。次更如此逆超。若此修已成熟。后于无流定修顺逆超一亦尔。应如此次第修顺逆观为超定加行。是时若从有流初定。能入无流第三定。从无流第三定。能入有流空无边入。从有流空无边入。能入无流无所有入。次修逆超亦如此。是时非等分第三定中去来成故。超修定得成。由最远故。第四不可超修。此修于三洲中。是非时解脱阿罗汉。所修得惑灭尽故。于定有自在故。见至圣人。彼根虽利。于定若有自在。彼惑未尽故不得修。时解脱阿罗汉。惑虽已尽。于定不得自在。亦不得修。由何依止。有几色定无色定可令现前。偈曰。自下地依止色无色。释曰有顶定于有顶处可修令现前。于下地乃至欲界皆能修令现前。如判有顶。所余诸定。于自地及下地。皆得修令现前。云何如此。若人生于上地。不能令下地诸定现前。何以故。于此人偈曰。非下。释曰。生上地人。下地定于彼无毫厘用。由下劣被轻故。说通义已。此中更说别义。偈曰。圣现无所有。入于有顶流尽。释曰。若圣人已生有顶。由现前修无流无所有入。至得流尽。云何已生有顶。能现前修无流无所有入。于自地无故。此熟所悉故。得现前修。复次色定。无色定所缘何境。偈曰。有爱自有境。释曰。若定与啖味相应。说名有爱。缘自地有起。有言者显取有流境。不能缘下地。已离欲故。不能缘上地。由诸地贪爱各所隔碍故。不能缘无流为境。应成清净故。偈曰。善定遍有境。释曰。若定以善为性。谓清净及无流。此定以一切法为境。彼境实有物。谓有为无为。偈曰。本善色无色。非有流下境。释曰。根本清净色定。及无色定。下地有流法。非彼境界。缘自地及上地为境界故。若无流为境界。一切类智种类。是彼境界。非法智种类。非下地灭。若近分定及无间道。以下地为境界。此三种色定无色定中。何定能灭惑。偈曰。由无流惑灭。释曰。惑灭不由清净定。何况由染污定。由此下界惑不得灭。于下未离欲故。自不能对治自故。是故不能灭自地惑。由最胜故。不能灭上地惑。但由无流定得灭。复次偈曰。及诸定近分。释曰。由色无色近分清净定。诸惑亦得灭是下地对治故。此近分有几种。偈曰。彼定近分八。释曰。随一一定。近分亦尔。依近分得入根本故。近分为如根本有三种不。近分受为如根本受不。非。偈曰。清净非苦乐。释曰。彼近分定。但是清净一类。与舍受相应。由功用所引故。未离下地厌怖故。离欲为果故。是故唯舍受无啖味。偈曰。初圣。释曰。最初近分定。名非至定。此有二种。有清净有无流。若由近分心结生。即有染污。若入观必无染污。由前已遮故。偈曰。余说三。释曰。有余师说。非至近分定。亦与啖味相应。此中有说。名近分定。有说。名中间定。此二名为一义。为有别义。有别义。何以故。近分者是离欲道。偈曰。无觉中间定。释曰。此定与觉不相应。说名中间定。与二定异故。由胜初定故。于初定中不立。于第二定等中。亦非所立。由无胜类故。复次此中间定。有几种有几受。偈曰。三种无苦乐。释曰。此定或与啖味相应。或清净或无流。是无苦无乐受。与舍根相应故。不与喜根相应。大功用所引故。故说为苦迟速行。此中间定果差别云何。偈曰。大梵王为果。释曰。若人修习上品中间定。受大梵王报。复次摄一切诸定。于经中说有三定。一有觉有观三摩提。二无觉有观三摩提。三无觉无观三摩提。此中中间定。即是无觉有观三摩提。由此经第二言所证。但遮觉故从此定。偈曰。有觉观此下。释曰。从此向下所有诸定。悉名有觉有观。谓初定及依初定余定。偈曰。此上定无二。释曰。于彼中无二。谓过中间定。向上余定。无觉观二。从第二定近分。乃至有顶皆无二。复次经中说。三摩提有三种。谓空定。无愿定。无相定。此中偈曰。无相应静相。释曰。与灭谛行相相应定。说名无相定。此定有四行相。何以故。涅槃者由离十相。说名无相。此定以涅槃为境。故名无相。十相者。谓五尘男女三有为相。是名十相。偈曰。空定无我空。释曰。与无我空二行相相应定。说名空定。此定有二行相。偈曰。无愿定所余。谛相相应故。释曰。与所余诸谛行相相应定。说名无愿定。此定有十行相。何以故。于无常苦及彼因生厌背故。于道由筏喻义。必定应弃舍。观行人于彼生过背意故。彼皆不可愿。以彼为境。故名无愿。于无我空中无厌背义。由与涅槃相似故。此三定有二。偈曰。彼清净无垢。释曰。此三定以清净及无流为种类。属世出世故。若世间定。依十一地成。若出世定。随无流道地。偈曰。净三解脱门。释曰。此三定若无流。说名三解脱门。谓空解脱门。无愿解脱门。无相解脱门。由彼是解脱门故。由别义于彼更说别名。偈曰。空空等名定。复有三别定。释曰。有空空定。有无愿无愿定。有无相无相定。以空定等为境界故。彼名空空定等。于中偈曰。二定缘无学。由空无常相。释曰。有二别定。缘无学诸定为境。空空定缘无学空定为境。由空行相故。无愿无愿定。缘无学无愿定为境。由无常行相故。不由苦及因等行相。无流法不以彼为相故。不由道谛行相彼所应厌背故。偈曰。无相无相定。静相非择灭。释曰。无相无相定。缘无学无相定非择灭为境。由寂静行相故。不由灭。妙离行相。何以故。与无常灭同故。无记性故。非永出离故。此三别定一向。偈曰。有流。释曰。由背舍圣道故。彼是有流。若无流则不尔。此定是何道所得。偈曰。人。释曰。于人道中非于天道。于何人相续中生。偈曰。不坏。释曰。唯不坏相阿罗汉。能得此定。由事究竟故。非余阿罗汉。此定依几地生。偈曰。七近分所离。释曰。除七近分定。于十一地。谓欲界。非至定。中间定。四色定。四无色定。复有经说有四三摩提修。经云。有三摩提修。若修若事若习成。为得现世安乐住。广说如经。此中偈曰有别修四定。净初为现乐。释曰。若初定是善性类。或清净或无流。此三摩提。必定能得现世安乐住。初定既尔。余定应知亦然。不必定得未来安乐住。或退堕。或生上地。或入涅槃。于中未来安乐住。或不成就故。偈曰。为知见眼通。释曰。第二三摩提修。为得知见三摩提修。谓天眼通慧修。偈曰。为别慧行生。释曰。第三三摩提修。为得差别慧三摩提修。一切胜德。皆从加行生。谓三界无流诸德。若定能得此德。说此定修。为差别慧三摩提修。偈曰。金刚譬后定。能灭有流修。释曰。于第四定有三摩提。名金刚譬修。此定能得一切流尽。彼言佛世尊说。四三摩提修。依佛自修行说。此义云何可知。由依第四定。约时分别故。说诸三摩提已。一切德依止三摩提成。说时已至。是故今说。偈曰。无量定有四。释曰。四无量定。谓慈悲喜舍无量。以无量众生为境界故。感无量果报故。云何立四。偈曰。由嗔等对治。释曰。多行杀害嗔逼恼嗔嫉妒嗔爱起憎嗔。众生为灭此行。是故次第应修此四无量定。不净观及舍无量定。若同对治欲界爱欲。有何差别。毗婆沙师说。色欲对治是不净观。淫欲对治是舍无量观。若执如此则与理相应。淫欲对治是不净观。能除色形貌触威仪欲故。母父及儿亲等欲对治是舍。此四定性类云何。偈曰。慈无嗔及悲。释曰。慈以无嗔善根为性。悲亦如此。偈曰。喜定谓适心。释曰。于他欢适事。心随彼欢适。说名为喜。偈曰。舍无贪。释曰。舍以无贪善根为性。若尔云何对治嗔。由嗔是贪爱所引故。若尔此定应以二善根为性。此义应理。此慈等无量定。行相云何。偈曰。行相。有乐及有苦。得喜及众生。释曰。若众生安乐。是慈定境界。于彼起行相思惟。谓众生安乐。由此得修慈无量观。若众生有苦。是悲定境界。于彼起行相思惟。谓众生有苦。由此得修悲无量观。若众生得喜。是喜定境界。于彼起行相思惟。谓众生得喜。由此得修喜无量观。若不分别。但众生众生。是舍定境界。于彼起行相思惟。谓众生众生。由此得修舍无量观。由是中心故。观若彼无乐于彼乐观乐。云何此观。不成颠倒。由愿得意故。非是颠倒。复由意无颠倒故。复由是愿乐想定故。复次若如此颠倒。有何过失。若汝言。非善性为过失。是义不然。彼以善根为性故。又能对治嗔等恶法故。说彼行相已。若彼缘众生为境。缘何众生为境。偈曰。彼欲众生境。释曰。欲界众生。是彼所缘境。能对治缘彼为境嗔恚等故。若尔经中所说。约一方起慈等心。此义云何。此言由显器。在器中亦是所显。此四无量依几地生。偈曰。于二定喜。释曰。于前二定。修喜无量观。适心为性故。偈曰。余六地。释曰。所余三无量观。于六地中修。谓非至定中间定及四定。偈曰。余说五。释曰。有余师说。除非至定。但于五地修。复有余师说于十地。谓欲界及四近分。由摄不定加行根本故。是前所说。彼能对治嗔恚等。为由彼惑得灭不。偈曰。由彼惑不灭。释曰。根本定为地故。假愿思惟为体故。缘众生为境故。由修彼加行。能制伏嗔恚等故。说彼是嗔恚等对治。已灭能令远故。有慈等观。以欲界及非至定为地。有以根本定为地。由前制伏诸惑已。后由灭道灭除诸惑。次于离欲位中。由得根本无量定故。若得定强力缘时。非复彼所能逼故。初学人云何修慈无量观。如计自身所得胜乐。或见闻他得胜乐。谓佛菩萨独觉声闻。于众生起如此至得胜乐愿乐想。谓愿诸众生。得如此乐。若不能等发此心。由惑最强盛故。先于亲属。分为三品。于最上品亲。起得胜乐愿想。于彼若已成。次于中及下亲。观行亦尔。于三品若得平等慈观已。次于中人。观行应知。皆如前说。次于怨人。复分为三品。于最下怨。愿彼得胜乐次于中怨及上怨亦尔。于最上怨。愿得胜乐想。若起不更退失。如于最上品亲不异。次第于家聚落方土中。起得胜乐愿想。乃至缘一方及遍一切世界。起愿得胜乐想。由慈无量心。周普无余。若人于一切众生。恒乐取德。此人必定速得成就慈观。何以故。于断善根人。若取彼德亦可得。于犀角喻独觉。若取彼过亦可得。由能显昔福非福果故。于悲及喜。修观行亦尔。观彼众生没多灾横流内。愿彼解脱众苦。愿彼众生恒得欢喜。若人作如此愿想。得入悲喜定观。舍观从中境成。但以众生众生为行相故。四无量定。是何道能修。偈曰。人道生。释曰。若修彼必定在于人道。非于余道。若人与一无量定相应。必定与一切相应不。不定。与一切相应此何为。偈曰。三应定。释曰。若人生第三第四定。与喜不相应。若人得无量定。恒与三相应。偈曰。解脱八。释曰。于内有色想于外观色。是第一解脱。于内无色想于外观色。是第二解脱。净解脱由身证已于修中住。是第三解脱。无色定为四解脱。灭受想定为第八解脱。于彼偈曰。前二。不净观。释曰。前二解脱。不净观为体性。以黑烂等想为行相故。是故于此二。应知如不净观中观行义。此前二偈曰。二定。释曰。于前二定中。此二解脱是所修。非于余地。次第是欲界及初定。地色欲对治故。偈曰。三后定无贪。释曰。第三净解脱。但于第四定修。此亦以无贪善根为体性。非不净观为体性。由净想为行相故。若摄彼共伴类。五阴为体性。无色解脱者。偈曰。净无色定地释曰。若善若定地四无色观。是四无色解脱。非不定地。譬如于死有中。余部师说。无色定有时非定。如目干连所修。复次无色近分定解脱道。彼亦得解脱名。若是善及定地。非无间道缘下地为境故。何以故。背舍义即是解脱。偈曰。灭心定解脱。释曰。灭受想定。即是第八解脱。此定于前已说。由背受想故名解脱。复由背舍一切有为法故。复有余师说。由此八能解脱一切定障故。若人修灭心定。偈曰。最后细后成。释曰。有顶者由想最细故。此定更修令最细。方得入灭心定。若人已入灭心定。云何得出。偈曰。自地净下圣。心从彼出观释曰。或由于有顶清净心从彼得出。或由无所有入为地。清净心及无流心。从彼得出。如此依有流心。入无心定。出心通有流无流。于此八解脱中。偈曰。欲界可见境。前三。释曰。于前三解脱。通以欲界色入为境。或可憎或可爱如次第。偈曰。四无色。是类智种类。自上地谛境。释曰。无色解脱缘上地及自地苦。苦集苦灭为境。一切类智种类道。及非择灭虚空为境。云何于第三定不立解脱。于第二定地。色欲不有故。复于清凉乐有动故。云何彼修净解脱观为安乐。先不净观。损羸自相续故。复次为欲观察自能不能故。谓于前二解脱。为成不成。若尔则知彼二成。若更由净相观净境。先惑不起。何以故。修观人由二种因故。修解脱等观。一为令诸惑极远相离。二为于定中得自在。为能引取无诤等诸德。及能引取圣通慧。此通慧能变异物类。成就所愿。延促寿等事。云何于第三第八说身证。于余不说。由二胜故。复由在界地穷际故。偈曰。制入有八种。释曰。于内有色相于外观色小量。或好或恶。制修此色。我见我知。作如此想是第一制入。无量亦尔。于内无色想于外观色。此二如前二合此成四通。无内色想观青黄赤白色。我见我知。作如此想合此成八。偈曰。二如初解脱。释曰。如初解脱。应知二制入亦尔。偈曰。后二如第二。释曰。如第二解脱。应知第三第四制入亦尔。偈曰。余如净解脱。释曰。如净解脱。应知后四制入亦尔。若尔此彼有何异。由前八但背舍。由后八制修。境界令随自意乐显现。及令惑不起。偈曰。十遍入。释曰。能普覆起一类。无间隙故名无边。何法为无边。谓地水火风。青黄赤白。此色相普覆。空无边入。识无边入。此二亦普覆。于中偈曰。无贪。八。释曰。前八以无贪为性。偈曰。后定。释曰。第四定是彼所依地。偈曰。彼境。欲。释曰。欲界色入是彼境。有余师说。风无边入触为境界。复有余师说。前四触为境界。后四色为境界。偈曰。二净无色。释曰。最后二无边入。以清净无色定为性。偈曰。自地四阴境。释曰。自地四阴。是后二无边入境界。八制入是入解脱法门。十无边入是入制入法门。前前于后后胜故。此解脱等。以一切凡夫圣人相续为依止。唯除灭心解脱。偈曰。灭心定已说。释曰。灭心定解脱。于前已说。由一切义差别。偈曰。余离欲行得。释曰。异灭心定。所余解脱等。或离欲所得。或加行所得。由前悉前未悉故。偈曰三界依无色。余人道修得。释曰。无色解脱。无色无边入。此法以三界身为依止。三界人所修得故。所余诸解脱。及诸制入无边入。依止人道相续得成。由正教力缘所生故。云何于色无色界。修得色定无色定差别。由三种因缘。四持诃那无色三摩跋提得生。由因业法尔力故。此中偈曰。因业力二界。生色无色定。释曰。于二界。谓色无色界。生无色界定。或由因力。谓近修及数修。或由业力。谓上界分后报。业果报欲至故。何以故。若人于下界不生欲。于上界不能得生。偈曰。于色界。色定由二法尔得。释曰。于色界中生差别定必由二力。谓因力业力。或由法尔力。世界欲坏时。一切众生。是时来下地。生四色定。是时善法。最成就丰饶起故。是佛世尊正法。应更几时住。于中如此等诸法品类。明了可知可见。偈曰。世尊正法二。教修得为体。释曰。此中正教者。即是诸阿含。谓修多罗。毗那耶。阿毗达磨。正修得者。谓阿地伽摩。此是三乘人所修。菩提助法。及三乘果。如此名二种正法。此中有几人。偈曰。于中有能持。能说及能行。释曰。于阿含有二人。一能正持。二能正说。于阿地伽摩但有一人。谓能正修得。随此三人相传住时。正法亦随此时得住。何以故。有二因缘。能令正法久住。谓正说正受。有余师说。佛般涅槃后一千年。正法得住。此说约正修得。不约阿含。若约阿含则有多时。何以故。于末世中若能持此正法。诸人有二种。一随闻得信。二随正解得信。诸天皆拥护。彼人令阿含及正修得。于世不速隐没。是故于中。如文如义。应急修正行。此论中。佛世尊阿毗达磨。是我所说。为如经部中所显。为如毗婆沙中所显。偈曰。罽宾毗婆沙理成。我多随彼说此论。正法偏执是我失。判法正理佛为量。释曰。罽宾国毗婆沙师二证所成就。此阿毗达磨。我今多随彼义说。于中若有偏执。是我过失。离证能正判正法。唯佛世尊为最胜量。何以故。由证见一切法故。若佛圣弟子。离阿含及道理。判正法亦非中量

阿毗达磨俱舍释论卷第二十一阿毗达磨俱舍释论卷第二十二

        婆薮盘豆造

        陈天竺三藏真谛译

    破说我品第九

  大师世间眼已闭　　又证教人稍灭散
  不见实义无制人　　由不如思动乱法
  自觉已入最妙静　　荷负教人随入灭
  世间无主能坏德　　无钩制惑随意行
  若知佛法寿　　将尽已至喉
  是惑力盛时　　求脱勿放逸

离此法于余法为无得解脱耶。无。云何如此。非如我见诳于心故。何以故。彼人不于五阴相续中假立我言故。何为由彼分别有别实物名我一切。或以我执为生本故。于余法无解脱义。云何得知。如此但于五阴相续中。假起我言。非于余义。由我非证比二量所知故。余法若实有若无障碍。必定由证量得知。譬如六尘及心。或由比量得知。譬如五根。此中如此比知。若有因缘。余因缘不有故。不见事生。若有则见事生。色尘等缘若具有。能障碍法若悉不有。盲聋等人及非盲聋等人。于色等尘眼等识不生生故。可得比量别因不有有义。别因即是眼等根。如此证量及比量。于我不有故。是故说决定无我。是跋私弗多罗部所说。必定有我。与五阴不一不异。此言宜应简择。为彼执由实物故有。由假名故有。实有相云何。假有相云何。若如色等别有。名实有物。若如乳等但聚集有。名假名有。若由实物有与阴别性故。应说与阴有异。譬如别别阴。必定须说此我因。若无因即是无为。则同外论师说。亦无别用。若汝执由假名有故有。此说最胜。我等亦说如此。我等立我有。不由实有说有。亦不由假名有说有。此何为。约内所取现世诸阴执说为我。今此别言。于义复不开显。非我等所解。此约言显何义。若义如此。谓缘诸阴。于诸阴中假名说我。此义应成。譬如缘色。等物假名说乳。复次若义如此。谓因诸阴故。我言成诸阴。是说我言因故。此执亦同前失。我等说我不如此。若不尔云何。如约薪执说火。约阴执说人亦尔。云何约薪执说火。若离薪火不可执说。不可立火与薪有异与薪无异。若火异薪。薪应不热。若火不异薪。所烧应即是能烧。如此离诸阴。不可执说人。亦不可说人异诸阴。由有常过失故。亦不可说人与诸阴不异。由有断过失故。善友愿汝为我说。何物为薪。何物为火。后我当得知约薪执说火义。此中何所应说。所烧是薪。能烧是火。若有应说必如此说。此中汝须更决说。何物是所烧。何物是能烧。于世间中可然物说名薪。亦名所烧。若然能烧光最热说名火。何以故。此物能然彼能烧彼。由能变异彼相续后不如本故。此二各有八物所成。缘薪火得生。譬如缘乳酪生。缘摩偷酢生。是故言约薪热说火。若尔则知火与薪异。由不同时故。若人如火必定缘阴生异于阴则成无常。复次若于然薪中。是热触说名火。所余三大与此共生。许此名薪。此二互有差别。明了易知。由相有异故。约薪有火义。汝今应说。云何约薪热说火。何以故。此薪非是火因。亦非热说火因。何以故。但火是热说火因。若汝说约言。是依止义。或共有义若尔诸阴于人应成依止。应成共生。彼互差别亦明了易知。复次若阴灭人应即灭。譬如薪灭火即灭。是汝所说。若火异薪。薪应不热。此中何物名热。若汝说热性名热。薪应不热。别火性故。复次若汝说。若有热性名热。此物虽与热性火异。此复成热。与热性相应故。是故于别异无过失。复次若汝言。正然物说名薪。亦说名火。是故约义。汝今应说若是阴即是人。此不异义。即至不可遮。是故此譬不成。如前云约薪执说火。约阴执说人亦尔复次若不可说人与阴异所知。有五种。谓过去未来现在无为不可言。此应不可说。何以故。此所知于过去等。不可说为第五及非第五故是时汝等执说人为观诸阴执说人。为观人执说人。若观诸阴执说人名。但约阴中执说人名。由人不可得故。若观人执说人。云何言约阴执说人。何以故。此执说但人是所缘境故。若汝言诸阴若有人则可知是故言约阴执说有人。若尔眼根思惟光明等。若有是时此色方可知。亦应约眼根等执说色。是有此义。汝应说。人于六识中。是何识所知。彼说由六识所知。此义云何。若缘眼所知色分别观人。应说此人是眼所知。不可说即色非即色。乃至若缘意所知法分别观人。应说此人是意所知。不可说即法非即法。若尔此人应成与乳等同。若缘眼所知色分别观乳。或观水等。应说乳水是眼所知。不可说即色非即色。如此应说。鼻舌身所知亦尔。乃至不可说即触非即触。勿乳水等非四物所成。此非所许义。是故如色等具物假说名乳及水等。如此亦应具诸阴假说名人。此义应成。是汝所说。缘眼所知色分别观人。此言有何义。为色是观察人智因。为正证知色即证知人。若色是人智因。亦不可说人异于彼。若尔色与光明眼根觉观等。亦应不可说异。彼是色智因故。若正证知色。即证知人。为即由色证智证知人。为由别智。若即由色证智证知人。人与色不应成异性。或于色但假说人。若不尔。若由一智所证知。此人非色此色非人。此二云何可分别若不能如此分别。云何强立此言。谓色是有。人亦是有。何以故。由随证知可说彼有如色乃至于法亦应说如此。若由别智分别此二。别时所得故。人应成异色。譬如黄色异青等。又如前后刹那。乃至于法亦应说如此。若汝言。如色及人一异不可说能证知。此二智一异亦不可说。是故此智亦不可说是有为。则破自悉檀。若说人是有。但不可说即色非即色云何佛世尊说。色无我乃至识亦无我。是汝所说。眼识能证见人。此识为缘色生。为缘人生。为缘二生。若尔何有。若缘色生。则不能缘人生。譬如声等。何以故。若缘此尘此识得生。唯此尘是此识缘缘。若缘人及二。此执与经不相应故。则为佛经所违何以故。经中已决判此义。唯依缘二法诸识得生。复有别经。亦违此执。经云比丘眼是因色是缘。能生眼识。何以故。一切所有眼识。唯因眼缘色生。若如汝所执。此人应成无常。何以故。是因是缘能生眼识。彼皆无常。由此经言故。若汝执。人非眼识境人则非眼识所知。复次若汝立义。人是六识所知。此人由耳识所知故。应成异色。譬如声由眼识所知故。应成异声。譬如色。于余尘应知亦如此复次此经文句。违汝所执。经云婆罗门。是五根各别行处。各别境界。是因自行处境界。彼各各受用。非别根能受用别根行处境界。谓眼根耳根鼻根舌根身根。心能受用五根行处境界。是故心是彼所依止。人非境界。若非境界。不应是六识所知。若尔意根应成别不通经云有六种根。各别行处各别境界。乐欲自自行处境界。此言于六众生我譬中说。是义不然。于此经中不定说六根为根。是五根乐欲见等事不有故。彼识亦尔。彼增上处所引意识。立此为根。故说名根。是独类心增上缘所引意识。此识非能乐欲受用余根行处境界。是故无失。复次佛世尊说。比丘我今为汝等说一切所应知一切所应识法门。眼根是所应知。是所应识。色眼识眼触。由眼触因缘。于内生受。谓苦乐不苦不乐等。乃至由意触因缘。于内生受。谓苦乐不苦不乐等。是名一切所应知一切所应识法门。由此经。若有所应知及所应识决。唯此量不出于此。于中不说人。是故人决定非所应知。智及识境界同故。执我诸人说云。我等由眼见人。于非我所。见有我故。彼则堕我见处深坑。于经中佛世尊自了义说云。但于五阴说假名人。于人经中说。依眼缘色生眼识。由三和合生触。共生受想作意等。是四种无色阴。及眼根并色。唯如此量说名人。于此中立诸名。谓萨埵那罗摩[少/(兔-、)]阇摩那婆弗伽罗时婆布洒善斗。于中立言。我由眼见色。于中有世传云。此命者如此名。如此姓。如此种类。如此食。如此受苦乐。如此长寿。如此久住。如此寿际。比丘如此事。唯名为量。唯言为量。唯传为量如此等一切法无常有为。故意所造。由因缘生。如此了义经。于此执中。佛世尊说为依为量。此经不可更别思量。复次有别经说。婆罗门若说一切有。唯是十二入。若人非人所摄。此人必定不有。此义则成。若入入摄。非不可言。于彼部中有如此经。经言比丘。若所有眼。若所有色。广说如经。由唯此量。比丘诸佛如来。说一切有穷显一切说。又频琵娑罗经中说。比丘婴儿无闻凡夫随逐假名我言。此中无我无我所。唯苦欲生得生。广说如经。有阿罗汉比丘尼。名世罗。对魔王说此偈言

  如从和合分　　于中说车名
  如此依诸阴　　假名说众生

于少分阿含中。为波遮利婆罗门。说此偈言

  波遮利汝听　　能解诸结法
  由此心有染　　复由此心净
  我者无我体　　颠倒故分别
  无我无众生　　唯法谓因果
  有分唯十二　　唯有阴入界
  熟思寻此法　　人实不可得
  如观内是空　　观外亦如是
  此二不可得　　能修及空义

复有经说。我执中有五种过失。谓起我见众生见。堕于见处。与外道不异。僻行邪道心。不入空义。不生净信心。于中不住。于此人圣法不得清净。彼不以此文为依量。何以故。此文于我部中。非所诵说。为以部为依量。为以佛言为依量。若取部为依量。佛世尊于彼则非正教师。彼便非释迦种子。若取佛言为依量。如此等文句。云何不取为依量。彼云如此等文句。非是佛言。云何非佛言。于我部中非昔所诵故。于今非理事起。此中有何非理。此文句是一切余部所读诵。此文句不违佛经及法尔。由我等不读诵故。此非佛言。此言一向非正思量。但由强作。于彼为无此经耶。谓一切法无我。若汝言。不说人是法。不说人异法。若尔此人应成非意识所知。缘二识得生。由经文决故。于此文中汝云何分别救难。经言于无我我执。是想倒心倒见倒。于无我我执是颠倒非于我。何者非我。诸阴入界。汝于前云。不可说我是色非色。此言最不可忍。何以故。于余经说。比丘若有沙门婆罗门。观执有我。彼一切但依五取阴。起此观执。是故一切不于我起我执。复有经说。若有诸人。能忆种种宿住。已忆正忆当忆。彼一切唯依五阴。若尔此经云何说此言。我如此色等。于宿世已生。此言为显能忆宿住人能忆多种宿住。若见人有色。应堕身见过失。若不说我。一切色等则无属处故说。此言不为显我。是故人是假名有。譬如聚流等。若尔佛世尊。不应成一切智人。何以故。无有心及心法能知一切法刹那刹那生灭故。是故人能知。若尔心灭时。由执人不灭故。汝则已信许人是常住。我等不说于一切境由智一时现前佛世尊是一切智。若不尔此云何。是相续称为佛。有如此胜能。于随所欲知境中。唯由回心生智无倒故。称一切智。此中说偈

  由相续有能　　称火食一切
  说遍知亦然　　不由俱悉解

此义云何可知。由说过去等世故。如偈曰

  是过去诸佛　　是未来诸佛
  是现在世佛　　能除众生忧

汝等但许五阴有三世非许人。若唯五阴名人。云何说此经。经云我今为汝。说重担取重担舍重担荷负重担。云何此言不可说。重担不能自荷负重担故。云何不能此事。非所曾见故不可言。亦不可言此事非所曾见故。复次应立取重担非阴所摄。为成此义故。佛世尊分别荷负重担人。是命者如此名。如此姓。乃至如此久住。及寿际。应知是名荷负重担。勿作别物意知。或执为常住。或执为不可言。诸阴自能灭诸阴。谓前阴于后阴。为显荷负重担义。故说此文。必定有人。何以故。由此经言。无自然生众生。此执是邪见。何人说无自然生众生。如佛世尊分别众生。我说亦尔。是故若人拨无于余生中自然生。五阴相续世一间立名自然生众生。说此人起邪见。谓无自然生众生。由有诸阴自然生故。是汝所说拨人邪见。见何谛所灭。此邪见不应由见谛灭。亦不应由修道灭。何以故。人不属四谛摄故。若汝言有别经为证。显人非阴。经言一人于世间向生。生为利益安乐多人。广说如经。由此经言故人非阴。是义不然。由于聚中假说一故。譬如说一麻一米。或于一聚说一言。如说一山一屋。应说人即是有为。由汝许有生故。如阴先未有后有。人生不尔不尔云何。生由取别阴故。譬如延若师生毗伽罗论师生。由取明处故说名生。又如比丘生道人生。由取相故说名。生又如老者已生病者已生。由取别位故说名生。是义不然。由被拨故。于经中佛世尊已拨此义。何经于真实空经。经云。比丘如此有业有果报。作者不可得。实无有故。是能弃舍此阴。往取彼阴。唯除于法世流布语所立人。又于颇求那经中说。我亦不说众生能取阴。唯诸法相续起。由此经。是故知。无有一人能取诸阴能舍诸阴。汝今信执何延若师生。乃至病者生。立为人譬。若执我此不成就。非有故。若执心及心法。彼刹那刹那。未曾有有故。不可为譬。若执身亦如心。如身明相。阴及人应成差别。老病此二是别身。是僧佉所立变异义。于前已破。是故延若师等不成譬。若汝执。诸阴有未有有义。人则不尔。若尔人应异阴。亦是常住。此义分明所显。汝说阴五人一。云何不说人与阴异。汝云何说四大色一。色不异四大。如此是立义过失。何者立义。立唯有大义。虽然如唯四大是色如此唯五阴是人。此义已许。若唯阴名人。云何佛世尊。不记命者即是身。命者异于身。由观问人意。是故不记。此问人执。有一别实物名命者。于内是作者。彼人依此为问。此物必定实无。云何可记是一是异。譬如龟毛强涩软滑。此结宿旧诸师先已解释。有大德那伽斯那阿罗汉。旻邻陀王。至大德所说云。我今欲问大德。沙门多漫言。如我所问。若大德直答。我当问大德。大德言。王但问。王即问。命者为即是身。为命者异身异。大德言。此义非所记。王言。大德。我先为不令大德立誓耶。谓不应说别语。我有别语。此义非可语。大德言。我今欲问大王。诸王多漫言。如我所问。王若直答。我当问王。王言。大德但问。大德即问。于王内中庵罗树。此子为酸为甜。王言。我内中无庵罗树。大德言。大王。我先为不令王立誓耶。谓不应说别语。王言。我说何别语。我内中无庵罗树。树既无云何得记子味酸甜。大王。如此命者既无。我云何能记异身不异身。云何佛世尊。不直记无我。由佛观问人意。故不直记。何以故。是诸阴相续。立名命者。勿问人由执此不有堕于邪见。是故不说。由彼未通达十二缘生理故。是故彼非受此正说器。复次由此道理应决此义。为是由世尊说。此言阿难。跋娑同姓外道问我。我为有为不有。我不答。若说此言。为非相应耶。谓一切法无我。阿难。若我答跋娑同姓外道问。说一切法无我。此外道于先已在痴闇。为不更过前量入痴闇耶。昔时我有我。今时永无我。若执有我则堕常见。若执无我则堕断见。广说如经。此中说偈

  观见牙伤身　　及弃舍善业
  诸佛说正法　　如雌虎衔子
  若信说有我　　见牙伤彻身
  若弃假名我　　善子即堕落

复说偈言

  由人实无故　　佛不记一异
  亦不得说无　　勿执无假我
  是阴相续中　　有善恶果理
  说命者拨无　　由说无命者
  彼人未堪受　　正说真空理
  问有我无我　　故不答我无
  若由观问意　　于有何不记
  同前无涅槃　　堕难故不记

世间常住等问。佛亦不记。由观问人意故。若彼执我为世间。此无故四答不应理。若彼执一切生死名世间答此亦不应理。何以故。若世间常住。无一人得般涅槃若非常住。则一切皆断灭。自然般涅槃。若具二必定。一分不得涅槃。一分自得。若非二。应成非得涅槃非非得涅槃。由涅槃至得随属道故。是故不可定为四答。譬如不记尼干弟子握中之雀。由此义世间有边等四问。佛亦不记。此四问同前四义故。何以知然。有外道名郁胝柯。以此四问佛。复问。为一切世间由此道得出离。为世间一分。大德阿难言。郁胝柯。是义汝于初已问世尊。今何故。复以方便更问此义。如来有异死等四问。由观问人意故。佛亦不记。何以故。彼人执已解脱我名如来。故为此问。于执有我人。应作如此问云何世尊记生存人有。不记于异死人有。为离堕常过失故。此事云何记。佛言。弥底(知履反)履也。今汝于未来当成如来阿罗诃三藐三佛陀。复云何声闻过世已死于后生。记彼言。某甲某处受生。如此亦应堕常过失。若世尊先时见众生存在。般涅槃已则不复见。故不记者。此应由无明故不记。则拨大师一切智德。汝或应信受此义。谓由我不有故佛不记。若佛见人不记。虽不记此人是有。亦是常住。此义自成。若汝说此义亦不可言。谓佛见及不见。若尔汝应渐渐成此义。令皆不可言佛世尊是一切智。不可言非一切智。亦不可言我必定有。由此言依实依住。拨我无我说名见处。说有亦是见处。是故此言不可以为证。阿毗达磨师说。此二皆是边见。断常二边见所摄故。此言是理。如跋婆经中言。阿难若说有我。此人则堕常见。若说无我。此人则堕断见。若汝言。人无何物往还生死。何以故。生死自往还。此义不可言。佛世尊说。诸众生以无明为盖。贪爱为缚。往还此彼。或于地狱。或于畜生饿鬼人天道中。如此长夜受于众苦。增益贪爱。常聚血滴。若尔此人云何往还生死。由舍此阴。受彼别阴。汝今所立义。于前已破。若尔离人生死云何自往还。譬如火刹那刹那灭。由相续故说行。如此阴聚。说名众生。以贪爱为取。约相续说名往还。若世间唯是阴聚。云何佛世尊说。今我于昔时曾作世师。名曰善目。云何不应说如此。由诸阴异故。若尔何者有人。若昔人即是今人。人则常住是故今我是昔世师。此言显一相续。譬如有言。是于彼火烧然至此。若我实有。唯诸佛如来能明了见。见已世尊即立我执。令成坚实。我既是有我所亦成。由佛说经为显此义。众生于五阴中。生我所执。则成坚实。是彼于五阴则成。身见我所见有已。彼我所爱复成坚实。彼以我所爱。为坚实系缚。则于解脱转成极远。若汝言。于我不生我爱。此言应何道理。谓于无我由信有我起我爱。于实我不起我爱。是故于如来正法中。无因缘起见疮疱。谓有诸人拨无我。起有我执。复有诸人。拨有执一切无。是诸外道计。执我实有别物。正法内人起有我执。及执一切无。如此等人同不得解脱。由无差别故。若由一切种我实不有。心既刹那刹那生灭。久远时所曾更事。今云何忆。云何更知。从忆念境界相类差别。心念及更知生。从此想类差别心。无间念得生。其相云何。由与于彼回向觉观同有相应及想等。无依止差别。忧悲散乱等损其势力。何以故。此想类差别心。若同境非同类。不能生此念。若同类非同境。亦不能生此念。若二同但一刹那。亦不能生此念。若异此三。则能生此念。若念生必由此生。不见余物。于念有功能故。今云何别心所见余心得忆。何以故。天与心所见。祠与心不应得忆是义不然。不相应故。天与心祠与心。此二不相应。非因果故。如一相续心有相应。彼则不尔。我等不说。别心所见。别心能忆。此云何。从见心有别忆念心生。由相续变异故。如前所说。若尔有何失。从忆念心。更知心生若无我孰能忆能忆是何义。由念能取境。此取境为异念。不异此念。能作取故。是我前所说。因缘能生此念。谓想类差别心。复次是汝所说。及多忆念从此相续称名及多见忆念生。说名忆念。若无我此念是谁念。又第六别言是何义主为义。譬如人问。此以何为主。譬如婆罗门牛。云何婆罗门为此牛主。由乘将使等事属婆罗门故。若尔此念。于何处可使。由此以我为彼主。于应忆境中。于中何用。使彼为忆境故。希有乐自在人。作此言说谓使此为生此。云何此可使为生彼名使为遣彼名使。由念无行故。因生说使。若尔主应成财因。财应成主果。何以故。由因于果果有增上。由果因有所得。是因能生念。此念属此因。是故主以因为义。诸行聚相续摄在一处。立名天与。立名牛主。此假名人。于余处牛变异生中。思量为因缘故。说名牛主。于中无一人名天与。无一物名牛。是故于中若离因义。不可立为主。何物能识。此识是谁识。应如念释。此识因缘。谓根尘觉观思惟。如理应知。是此差别。若有人说我有。由有观有者故。一切有等事必定观有者等。譬如天与行。此中有事名行。必定观行者天与识事亦尔。是物能识。此识必应依彼生。应问此人。汝所说天与是何物。若说我为天与。此我于前已破。不可成立。若汝说。世流布所显。此人不成一物。诸行聚得如此名。此中如说天与行。说天与识亦尔云何说天与行。诸行刹那刹那生灭相应无别异说名天与。诸凡夫执彼。许为一众生彼于别处作自相续因。世间于彼说天与行。于余处生说名行。譬如光声相续于别处生说名行。是彼正作识因。说名天与识。圣人由世流布所立。亦说彼事。为与言说相应故。于经中说识识境。此中识何所作。悉无所作。如识果随似因。悉无所作。但由得相似体故说如此。说识识境亦尔。悉无所作。但由得相似体。识相似有何义。体生似彼。是故此识。虽从根生。但说识尘。不说识根。复次此中识相续。由于后识是因故。说识识境。此言无失由于因中立作者名故。譬如说铃正鸣。复次譬如灯行。识识境亦尔。云何灯行。于光相续。假名说灯。此相续正生于余处说灯行余处。如此于心相续。假名说识。此心相续于余尘中生识。此识彼尘复次譬如世间说。色有色生色住。此中能有等不异有等。亦有二言。于识二言亦尔。若从识识生。不从我生。云何生不恒似本。又不由决定次第生。譬如芽节叶等。由住异诸行相故。一切有为法性。皆如此必定。相续不同。若不尔。入如意得定。观人身心。相似生故。一切相续。与初刹那不异故。后时不应自然出定。亦有决定次第心生。若心应从此心生。从此彼必定生故。亦有别心。同相有功能生同相心。由性差别故。譬如从女人心次第若秽污身心生。或此夫及子等心生。复于后时。由相续变异故。更生女人心。此心于秽污身心生中。或于此夫及子等心生中有功能。由同性故。若异此则无功能。复次从此女人心。由别因缘。生无量别心。于此众心中。若心多生。明了生最近生。从此心次第先生。是彼修习力最强故。除现时身外因缘差别。此心修习力强。云何不恒受果。由此心有住异相故。此住异相。于别修习果生中。随顺功德故。此法相于一切心种类中。是方无间因智中。诸佛世尊有自在。此中说偈

  于孔雀一尾　　具一切相因
  余人不能知　　此智是佛力

何况无色诸心差别。我等能知。有余外道执。从我心生。此二难。于彼外道最明了成。云何心不恒生同一相。云何不决定次第生。譬如芽节叶等。若汝执。由观心和合差别故异。是义不然。由别和合不成就故。由二和合物有定量故。彼说和合相者。非至为先后至说名和合。由彼所执和合相。则应立我有定量。遍义则不成。是故由心有行。亦应说我有行及灭。若汝执。由于一分和合。是义不然。此一物无分故。我亦许汝有和合。虽然若心恒不异。云何和合有差别。若汝说。由观智有差别。是故心有差别。是义不然。智与心同难故。我既无差别。智云何有差别。若汝执。观功用差别。从我和合智差别生。是义不然。云何不执。但从功用差别。相应心智差别生。何以故。此中无有我功能。随一可知得故。譬如药事成时有诳惑医说部莎诃言。若汝说由我有此二得成。此执但有语言。若汝言。此我是彼依止。若尔于中何者是所依。何者是能依。何以故。此二非所持。譬如画色及婆陀罗子。亦非能持。譬如壁及瓶由有相碍。俱有二过失故。若我为彼依止不如此。若不尔。云何如地大。是香等依止。我今大喜此譬。乃证我义。谓我无如离香等别地大不可得。于香等假名说地大。如此于功用及心。无有别我。但于此二假名说我。何人能决了有地异于香等。汝今应知。譬如无自在人有第二头。异色等五尘。若离香等无别地。云何说于地有四德。为各分别彼令他得知香等得地等名无别地等。譬如说木像身形虽然若由观功用差别故。智有差别。云何不一时生一切智。若功用最强。是功用遮余功用。若尔是最强功用。云何不恒生果。是彼道理。是彼道理即是彼修分别。我则无复用。必定应信受。有我念等。由求那性故。此求那必定依止物故。是故念依我。是我德若执彼依止余物。则不相应。离我余物无觉故。是义不然。彼求那性不成就故。是汝所立。念等是求那性。于我不成就。我等执一切所有皆名陀蜡脾(毗邪反)。由经言。沙门果者唯有六物。是故彼依止陀蜡脾为性不成。何以故。是依止义。前已简择。不成就故。是故此言。但是漫说。若我实无。造业何用。我当受乐。我当受苦。为此故造业。我是何物。我计执境界。我计执何法为境界。诸聚为境界。汝云何知。由于彼生爱故。与白黑等智。同依止故。如说我白我黑我肥我瘦我老我少等。见此计执我与白黑等智悉同依止。汝不许于我有如此等差别。是故此我计执。但约阴起于我有恩故。于身假名说我。譬如世言。彼臣即是我。此于我有恩。假立我言。我计执则不尔。若但缘身为境界。云何不缘他身为境界。是义不然。不相应故。此我计执。随所有法共相应。或身或心。于中起我计执。非于余处。于无始生死所数习故。何者为相应。谓因果道理。若无我此我计执。是谁计执。又第六别言是何义。此问已去。今复更来。答亦如此。乃至若法是此计执。因此计执属此法。若尔何法为计执。因昔我计执所熏习。缘自相续为境界。有垢秽心。若无我谁受苦谁受乐。是依止中或苦生或乐生。譬如树有花林有果。此苦乐以何法为依止。内六入随一。如前所说。应知如此。若执我无。谁造作业。谁受用果。造作及受用。此言有何义。先未有能令有名作。正得先业果名受用。此言说别名。非显别义。解判法相师说。于事有自在名作者。见世间有人。于余事中有自在能。譬如天与。于住食行等事中。汝今说何法为天与。若汝说我为名天与。我前已破。此不成有。若说五阴是作者。则无自在。业有三种。谓身口意。此中于身业者。是身为作事。必系属心。是心事于身亦系属。自因缘心于自事亦尔。是故随一无自在。一切有法。皆系属因缘故。生起悉无自在。汝法中是所执我。若不观余因缘。不许为作者故。是故此自在不成。由无此相。是故随立一为作者。皆不得成。于事中若因由功能胜。假名说为作者。于余事不见我有一功能故。不可立我为作者。何以故。意欲从忆念。生觉观从意欲生。功用从觉观生。风从功用生。从风起业。于中我作何功能。受用果何相。若我正用此事。说我为受者。是受用果相。此言何义。若汝说觉知为受。是义不然。我于觉知无功能。由已破于识我功能故。若我无。云何不以非众生为依止所有善恶业生长。非受等依止故。以何为依止。六入为依止。非我此义前已说。我既无。从已谢灭业。于未来果云何生。若我有。从已谢灭业。于未来果云何生。从能依法非法生。如汝所言。有何能依及所依。此语前已破。是故法非法。无所依止。复次我等不说。从已谢灭业。于未来中果报得生。若尔云何从业相续转异。胜类果生。譬如种子果。如世间说从种子果生。此果不从已谢灭种子生。非无间生。云何生。从种子相续转异胜类生。谓芽节叶等次第所生花。及花后此果既从花生。云何说为种子果。由转转于花中生果功能。是种子所作故。是最后花功能。若不以种子功能为先。此花无功能。得生如此等流果。如此从此业说果报生。不异此义。果报不从已谢灭业生。亦非无间生。若尔云何从业相续转异。胜类果生。此中相续是何法。转异是何法。胜类是何法。以业为先后后心生。说名相续。此相续后后异前。说名转异。于此转异中。若有转异无间最能生果。说名胜类。此于余转异最胜故。譬如有取死心于后有生有功能。虽以种种业为先。若业重最近数习。是三所生功能。此中明了显现非余业。如偈言

  若重近数习　　及昔作诸业
  先先先后熟　　于轮转有续

此中果报因所立。于果报果中功能。生果报已。即便谢灭。同类因所立。于等流果中功能。若有染污法。对治生时。即便谢灭若无染污法。由心相续永谢灭故。此功能即灭。谓般涅槃时。复次云何从果报。别果报不更生。譬如从种子果更生。种子果。此中一切所立义。与譬义不必悉同。此中不从果更生别果。若尔云何生。从湿胀转异胜类所生。此中四大种类。能生芽等。是果种子非余。复次是前相续。由当有名说为种子。以相似故。此中亦尔。从此果报。听闻正邪二法等。因缘差别所生。或有流善。或不善心。转异若生。从此更生别果报。不由别理故。此譬与立义同。复次由此譬。更应知此义。譬如从勒荷汁所点摩东笼伽花。相续转异所生。于果内赤色瓤得生。从余不生如此从业所生果报。别果报不得生。若由如前所说道理。此则得生。随粗如我智慧所知。此理已显。由种种胜能有差别。诸业所熏习。相续至如此位。能生如此。如此果报。此义唯诸佛世尊境界。此中说偈

  业熏习胜类　　果报位及净
  由一切种理　　离佛余不知
  佛经理互应　　解真义胜量
  依二说无伤　　何用难堕身

  如此善立理清净　　已见诸佛教法尔
  盲闇种种邪见行　　愿舍外执得明行
  此涅槃土一广道　　诸佛日言光所照
  众圣行熟无我理　　虽开昧眼人不见
  佛世尊告富娄那　　汝等正勤持此法
  若人依此修观行　　必定皆得五五德
  如此已显正义方　　为开智人智毒门
  愿彼舍离外邪执　　为自及他得实义

阿毗达磨俱舍释论卷第二十二


阿毗达磨品类足论

    No. 1542 [No. 1541]

阿毗达磨品类足论卷第一

        尊者世友造

        三藏法师玄奘奉　诏译

    辩五事品第一

有五法。一色。二心。三心所法。四心不相应行。五无为。色云何。谓诸所有色。一切四大种。及四大种所造色。四大种者。谓地界水界火界风界。所造色者。谓眼根耳根鼻根舌根身根色声香味。所触一分。及无表色。心云何。谓心意识。此复云何。谓六识身。即眼识耳识鼻识舌识身识意识。心所法云何。谓若法心相应。此复云何。谓受想思触作意欲胜解念定慧信勤寻伺放逸不放逸善根不善根无记根。一切结缚随眠。随烦恼缠。诸所有智。诸所有见。诸所有现观。复有所余如是类法与心相应。总名心所法。心不相应行云何。谓若法心不相应。此复云何。谓得无想定灭定。无想事命根众同分。依得事得处得生老住无常性。名身句身文身。复有所余如是类法。与心不相应。总名心不相应行。无为云何。谓三无为。一虚空。二非择灭。三择灭

地界云何。谓坚性。水界云何。谓湿性。火界云何。谓暖性。风界云何。谓轻等动性。眼根云何。谓眼识所依净色。耳根云何。谓耳识所依净色。鼻根云何。谓鼻识所。依净色。舌根云何。谓舌识所依净色。身根云何。谓身识所依净色。色云何。谓诸所有色。若好显色。若恶显色。若二中间。似显处色。如是诸色二识所识。谓眼识及意识。此中一类眼识先识。眼识受已意识随识。声云何。此有二。谓有执受大种为因声。及无执受大种为因声。如是诸声二识所识。谓耳识及意识。此中一类耳识先识。耳识受已意识随识。香云何。谓诸所有香。若好香若恶香若平等香鼻所嗅。如是诸香二识所识。谓鼻识及意识。此中一类鼻识先识。鼻识受已意识随识。味云何。谓诸所有味。若可意若不可意。若顺舍处舌所尝。如是诸味二识所识。谓舌识及意识。此中一类舌识先识。舌识受已意识随识。所触一分云何。谓滑性涩性轻性重性冷饥渴性。身所触。如是诸触及四大种。二识所识。谓身识及意识。此中一类身识先识。身识受已意识随识。无表色云何。谓法处所摄色。此及五色根。于一切时一识所识。谓意识

眼识云何。谓依眼根各了别色。耳识云何。谓依耳根各了别声。鼻识云何。谓依鼻根各了别香。舌识云何。谓依舌根各了别味。身识云何。谓依身根各了别所触。意识云何。谓依意根了别诸法

受云何。谓领纳性。此有三种。谓乐受苦受不苦不乐受。想云何。谓取像性。此有三种。谓小想大想无量想。思云何。谓心造作性。即是意业。此有三种。谓善思不善思无记思。触云何。谓三和合性。此有三种。谓顺乐受触。顺苦受触。顺不苦不乐受触。作意云何。谓心警觉性。此有三种。谓学作意。无学作意。非学非无学作意。欲云何。谓乐作性。胜解云何。谓心正胜解已胜解当胜解性。念云何。谓心明记性。定云何。谓心一境性。慧云何。谓心择法性。信云何。谓心澄净性。勤云何。谓心勇悍性。寻云何。谓心粗动性。伺云何。谓心细动性。放逸云何。谓不修善法性。不放逸云何。谓修善法性。善根云何。谓三善根。即无贪善根。无嗔善根。无痴善根。不善根云何。谓三不善根。即贪不善根。嗔不善根。痴不善根。无记根云何。谓四无记根。即无记爱无记见无记慢无记无明

结有九种。谓爱结恚结慢结无明结见结取结疑结嫉结悭结。爱结云何。谓三界贪。恚结云何。谓于有情能为损害。慢结云何。谓七慢类。即慢过慢慢过慢我慢增上慢卑慢邪慢。慢者。于劣谓己胜。或于等谓己等。由此正慢已慢当慢。心高举心恃篾。过慢者。于等谓己胜。或于胜谓己等。由此正慢已慢当慢。心高举心恃篾。慢过慢者。于胜谓己胜。由此正慢已慢当慢。心高举心恃篾。我慢者。于五取蕴等。随观执我或我所。由此正慢已慢当慢。心高举心恃篾。增上慢者。于所未得上胜证法。谓我已得。于所未至上胜证法。谓我已至。于所未触上胜证法。谓我已触。于所未证上胜证法。谓我已证。由此正慢已慢当慢。心高举心恃篾。卑慢者。于他多胜谓自少劣。由此正慢已慢当慢。心高举心恃篾。邪慢者。于实无德谓我有德。由此正慢已慢当慢。心高举心恃篾。无明结云何。谓三界无智。见结云何。谓三见。即有身见边执见耶见。有身见者。于五取蕴等。随观执我或我所。由此起忍乐慧观见。边执见者。于五取蕴等。随观执或断或常。由此起忍乐慧观见。邪见者。谤因谤果。或谤作用。或坏实事。由此起忍乐慧观见。取结云何。谓二取。即见取戒禁取。见取者。于五取蕴等。随观执为最为胜为上为极。由此起忍乐慧观见。戒禁取者。于五取蕴等。随观执为能清净为能解脱为能出离。由此起忍乐慧观见。疑结云何。谓于谛犹豫。嫉结云何。谓心妒忌。悭结云何。谓心鄙吝。缚云何。谓诸结亦名缚。复有三缚。谓贪缚嗔缚痴缚。随眠有七种。谓欲贪随眠。嗔随眠。有贪随眠。慢随眠。无明随眠。见随眠。疑随眠。欲贪随眠有五种。谓欲界系见苦集灭道修所断贪。嗔随眠有五种。谓见苦集灭道修所断嗔。有贪随眠有十种。谓色界系五。无色界系五。色界系五者。谓色界系见苦集灭道修所断贪。无色界系五亦尔。慢随眠有十五种。谓欲界系五。色界系五。无色界系五。欲界系五者。谓欲界系见苦集。灭道修所断慢。色无色界系各五亦尔。无明随眠有十五种。谓欲界系五。色界系五。无色界系五。欲界系五者。谓欲界系见苦集灭道修所断无明。色无色界系各五亦尔。见随眠有三十六种。谓欲界系十二。色界系十二。无色界系十二。欲界系十二者。谓欲界系有身见边执见。见苦道所断邪见见取戒禁取。见集灭所断邪见见取。色无色界系各十二亦尔。疑随眠有十二种。谓欲界系四。色界系四。无色界系四。欲界系四者。谓欲界系见苦集灭道所断疑。色无色界系各四亦尔。随烦恼云何。谓诸随眠。亦名随烦恼。有随烦恼不名随眠。谓除随眠诸余染污。行蕴心所缠有八种。谓惛沉掉举睡眠恶作嫉悭无惭无愧

诸所有智者。有十智。谓法智类智他心智世俗智苦智集智灭智道智尽智无生智。法智云何。谓缘欲界系诸行诸行因诸行灭诸行能断道诸无漏智。复有缘法智及法智地诸无漏智。亦名法智。类智云何。谓缘色无色界系诸行诸行因诸行灭诸行能断道诸无漏智。复有缘类智及类智地诸无漏智。亦名类智。他心智云何。谓若智修所成。是修果依止。修已得不失智。欲色界系。和合现前。他心心所。及一分无漏。他心心所。皆名他心智。世俗智云何。谓诸有漏慧。苦智云何。谓于五取蕴。思惟非常苦空非我。所起无漏智。集智云何。谓于有漏因思惟因集生缘。所起无漏智。灭智云何。谓于择灭思惟灭静妙离。所起无漏智。道智云何。谓于圣道思惟道如行出。所起无漏智。尽智云何。谓自遍知。我已知苦。我已断集。我已证灭。我已修道。由此而起。智见明觉。解慧光观。皆名尽智。无生智云何。谓自遍知。我已知苦不复当知。我已断集不复当断。我已证灭不复当证。我已修道不复当修。由此而起。智见明觉解慧光观。皆名无生智。诸所有见者。且诸智亦名见。有见非智。诸八现观边忍。一苦法智忍。二苦类智忍。三集法智忍。四集类智忍。五灭法智忍。六灭类智忍。七道法智忍。八道类智忍。诸所有现观者。若智若见俱名现观

得云何。谓得诸法。无想定云何。谓已离遍净染未离上染出离想作意。为先心心所灭。灭定云何。谓已离无所有处染止息想作意。为先心心所灭。无想事云何。谓生无想有情天中心心所灭。命根云何。谓三界寿。众同分云何。谓有情同类性。依得云何。谓得所依。处事得云何。谓得诸蕴。处得云何。谓得内外处。生云何。谓令诸蕴起。老云何。谓令诸蕴熟。住云何。谓令已生诸行不坏。无常云何。谓令已生诸行灭坏。名身云何。谓增语。句身云何。谓字满。文身云何。谓字众。虚空云何。谓体空虚。宽旷无碍。不障色行。非择灭云何。谓灭非离系。择灭云何。谓灭是离系

    品类足论辩诸智品第二之一

有十智。如前说。法智何所缘。谓缘欲界系诸行及一分无漏法。类智何所缘。谓缘色无色界系诸行及一分无漏法。他心智何所缘。谓缘欲色界系和合现前他心心所及一分无漏他心心所。世俗智何所缘。谓缘一切法。苦智何所缘。谓缘五取蕴。集智何所缘。谓缘有漏因。灭智何所缘。谓缘择灭。道智无所缘。谓缘学无学法。尽智何所缘。谓缘一切有为法及择灭。无生智何所缘。谓缘一切有为法及择灭。何故法智缘欲界系诸行及一分无漏法。答法智知欲界系诸行诸行因诸行灭诸行能断道故。何故类智缘色无色界系诸行及一分无漏法。答类智知色无色界系诸行诸行因诸行灭诸行能断道故。何故他心智缘欲色界系和合现前他心心所及一分无漏他心心所。答他心智知欲色界系和合现前他心心所及一分无漏他心心所故。何故世俗智缘一切法。答世俗智知一切法。或如理所引。或不如理所引。或非如理非不如理所引故。何故苦智缘五取蕴。答苦智知五取蕴非常苦空非我故。何故集智缘有漏因。答集智知有漏因因集生缘故。何故灭智缘择灭。答灭智知择灭灭静妙离故。何故道智缘学无学法。答道智知学无学法道如行出故。何故尽智缘一切有为法及择灭。答尽智自遍知我已知苦我已断集我已证灭我已修道故。何故无生智缘一切有为法及择灭。答无生智自遍知。我已知苦不复当知。我已断集不复当断。我已证灭不复当证。我已修道不复当修故

法智是几智全。几智少分。答法智是法智全。七智少分。谓他心智苦智集智灭智道智尽智无生智。类智是几智全。几智少分。答类智是类智全。七智少分。谓他心智苦智集智灭智道智尽智无生智。他心智是几智全。几智少分。答他心智是他心智全。四智少分。谓法智类智世俗智道智。世俗智是几智全。几智少分。答世俗智是世俗智全。一智少分。谓他心智。苦智是几智全。几智少分。答苦智是苦智全。四智少分。谓法智类智尽智无生智。集智灭智应知亦尔。道智是几智全。几智少分。答道智是道智全。五智少分。谓法智类智他心智尽智无生智。尽智是几智全。几智少分。答尽智是尽智全。六智少分。谓法智类智苦智集智灭智道智无生智亦尔

何故法智是法智全。答法智知欲界系诸行诸行因诸行灭诸行能断道故。何故法智是他心智少分。答法智知欲界系诸行能断道中他无漏心心所故。何故法智是苦智少分。答法智知欲界系五取蕴非常苦空非我故。何故法智是集智少分。答法智知欲界系诸行因因集生缘故。何故法智是灭智少分。答法智知欲界系。诸行灭灭静妙离故。何故法智是道智少分。答法智知欲界系诸行能断道道如行出故。何故法智是尽智少分。答法智自遍知。我已知欲界系诸行苦。我已断欲界系诸行集。我已证欲界系诸行灭。我已修欲界系诸行能断道故。何故法智是无生智少分。答法智自遍知。我已知欲界系诸行苦不复当知。我已断欲界系诸行集不复当断。我已证欲界系诸行灭不复当证。我已修欲界系诸行能断道不复当修故。何故类智是类智全。答类智知色无色界系诸行诸行因诸行灭诸行能断道故何故类智是他心智少分。答类智知色无色界系诸行能断道中他无漏心心所故。何故类智是苦智少分。答类智知色无色界系五取蕴非常苦空非我故。何故类智是集智少分。答类智知色无色界系诸行因因集生缘故。何故类智是灭智少分。答类智知色无色界系诸行灭灭静妙离故。何故类智是道智少分。答类智知色无色界系诸行能断道道如行出故。何故类智是尽智少分。答类智自遍知。我已知色无色界系诸行苦。我已断色无色界系诸行集。我已证色无色界系诸行灭。我已修色无色界系诸行能断道故。何故类智是无生智少分。答类智自遍知。我已知色无色界系诸行苦不复当知。我已断色无色界系诸行集不复当断。我已证色无色界系诸行灭不复当证。我已修色无色界系诸行能断道不复当修故

何故他心智是他心智全。答他心智知欲色界系和合现前他心心所。及一分无漏他心心所故。何故他心智是法智少分。答他心智知欲界系诸行能断道中他无漏心心所故。何故他心智是类智少分。答他心智知色无色界系诸行能断道中他无漏心心所故。何故他心智是世俗智少分。答他心智知他有漏心心所故。何故他心智是道智少分。答他心智知圣道中他无漏心心所故

何故世俗智是世俗智全。答世俗智知一切法。或如理所引。或不如理所引。或非如理非不如理所引故。何故世俗智是他心智少分。答世俗智知他有漏心心所故

何故苦智是苦智全。答苦智知五取蕴非常苦空非我故。何故苦智是法智少分。答苦智知欲界系五取蕴非常苦空非我故。何故苦智是类智少分。答苦智知色无色界系五取蕴非常苦空非我故。何故苦智是尽智少分。答苦智自遍知。我已知苦故。何故苦智是无生智少分。答苦智自遍知。我已知苦不复当知故

何故集智是集智全。答集智知有漏因因集生缘故。何故集智是法智少分。答集智知欲界系诸行因因集生缘故。何故集智是类智少分。答集智知色无色界系诸行因因集生缘故。何故集智是尽智少分。答集智自遍知我已断集故。何故集智是无生智少分。答集智自遍知我已断集不复当断故

何故灭智是灭智全。答灭智知择灭灭静妙离故。何故灭智是法智少分。答灭智知欲界系诸行灭灭静妙离故。何故灭智是类智少分。答灭智知色无色界诸行灭灭静妙离故。何故灭智是尽智少分。答灭智自遍知我已证灭故。何故灭智是无生智少分。答灭智自遍知我已证灭不复当证故

说一切有部品类足论卷第一阿毗达磨品类足论卷第二

        尊者世友造

        三藏法师玄奘奉　诏译

    辩诸智品第二之余

何故道智是道智全。答道智知圣道道如行出故。何故道智是法智少分。答道智知欲界系诸行能断道道如行出故。何故道智是类智少分。答道智知色无色界系诸行能断道道如行出故。何故道智是他心智少分。答道智知圣道中他无漏心心所故。何故道智是尽智少分。答道智自遍知我已修道故。何故道智是无生智少分。答道智自遍知我已修道不复当修故

何故尽智是尽智全。答尽智自遍知我已知苦我已断集我已证灭我已修道故。何故尽智是法智少分。答尽智自遍知。我已知欲界系诸行苦。我已断欲界系诸行集。我已证欲界系诸行灭。我已修欲界系诸行能断道故。何故尽智是类智少分。答尽智自遍知。我已知色无色界系诸行苦。我已断色无色界系诸行集。我已证色无色界系诸行灭。我已修色无色界系诸行能断道故。何故尽智是苦智少分。答尽智自遍知。我已知苦故。何故尽智是集智少分。答尽智自遍知。我已断集故。何故尽智是灭智少分。答尽智自遍知。我已证灭故。何故尽智是道智少分。答尽智自遍知。我已修道故

何故无生智是无生智全。答无生智自遍知我已知苦不复当知。我已断集不复当断。我已证灭不复当证。我已修道不复当修故。何故无生智是法智少分。答无生智自遍知。我已知欲界系诸行苦不复当知。我已断欲界系诸行集不复当断。我已证欲界系诸行灭不复当证。我已修欲界系诸行能断道不复当修故。何故无生智是类智少分。答无生智自遍知。我已知色无色界系诸行苦。不复当知。我已断色无色界系诸行集。不复当断。我已证色无色界系诸行灭。不复当证。我已修色无色界系诸行能断道。不复当修故。何故无生智是苦智少分。答无生智自遍知。我已知苦不复当知故。何故无生智是集智少分。答无生智自遍知。我已断集不复当断故。何故无生智是灭智少分。答无生智自遍知。我已证灭不复当证故。何故无生智是道智少分。答无生智自遍知。我已修道不复当修故。如是十智。几有漏几无漏。答一有漏八无漏。一应分别。谓他心智或有漏或无漏。云何有漏。谓知他有漏心心所法。云何无漏。谓知他无漏心心所法。如是十智。几有漏缘。几无漏缘。答二有漏缘。二无漏缘。六应分别。谓法智。或有漏缘或无漏缘。云何有漏缘。谓缘苦集。云何无漏缘。谓缘灭道。类智尽智无生智亦尔。他心智或有漏缘。或无漏缘。云何有漏缘。谓知他有漏心心所法。云何无漏缘。谓知他无漏心心所法。世俗智或有漏缘或无漏缘。云何有漏缘。谓缘苦集。云何无漏缘。谓缘灭道及虚空非择灭。如是十智。几有为几无为。答一切是有为非无为。如是十智。几有为缘几无为缘。答四有为缘。一无为缘。五应分别。谓法智或有为缘或无为缘。云何有为缘。谓缘苦集道。云何无为缘。谓缘灭类智。尽智无生智亦尔。世俗智或有为缘或无为缘。云何有为缘。谓缘苦集道。云何无为缘。谓缘择灭及虚空非择灭

    品类足论辩诸处品第三

有十二处。谓眼处色处耳处声处鼻处香处舌处味处身处触处意处法处。此十二处。几有色几无色。答十有色一无色。一应分别。谓法处或有色或无色。云何有色。谓法处所摄身语业。云何无色。谓余法处。此十二处。几有见几无见。答一有见。十一无见。此十二处。几有对几无对。答十有对。二无对。此十二处。几有漏几无漏。答十有漏。二应分别。谓意处或有漏或无漏。云何有漏。谓有漏作意相应意处。云何无漏。谓无漏作意相应意处。法处或有漏或无漏。云何有漏。谓法处所摄有漏身语业。及有漏受想行蕴。云何无漏。谓法处所摄无漏身语业。及无漏受想行蕴。虚空二灭。此十二处。几有为几无为。答十一有为。一应分别。谓法处或有为或无为。云何有为。谓法处所摄身语业。及受想行蕴。云何无为。谓虚空二灭。此十二处。几有诤几无诤。答十有诤。二应分别。谓意处法处。若有漏是有诤。若无漏是无诤。如有诤无诤。世间出世间。堕界不堕界。有味着无味着。耽嗜依出离依。顺结不顺结。顺取不顺取。顺缠不顺缠。应知亦尔。此十二处。几有记几无记。答八无记。四应分别。谓色处或有记。或无记。云何有记谓善不善色处。云何无记。谓除善不善色处。诸余色处。声意法处亦尔。此十二处。几有覆几无覆。答八无覆。四应分别。谓色处或有覆或无覆。云何有覆。谓不善有覆无记色处。云何无覆。谓善无覆无记色处。声意法处亦尔。如有覆无覆。染污不染污有罪无罪。应知亦尔。此十二处。几应修几不应修。答八不应修。四应分别。谓色处或应修或不应修。云何应修。谓善色处。云何不应修。谓不善无记色处声意处亦尔。法处或应修或不应修。云何应修。谓善有为法处。云何不应修。谓不善无记法处及择灭。此十二处。几有异熟几无异熟。答八无异熟。四应分别。谓色处或有异熟或无异熟。云何有异熟。谓善不善色处。云何无异熟。谓无记色处。声处亦尔。意处或有异熟或无异熟。云何有异熟。谓不善善有漏意处。云何无异熟。谓无记无漏意处。法处亦尔。此十二处。几是见几非见。答一是见。十非见。一应分别。谓法处或是见或非见。云何是见。谓五染污见。世俗正见。学无学见。云何非见。谓余法处。此十二处几内几外。答六内六外。此十二处。几有执受几无执受。答三无执受。九应分别。谓眼处或有执受或无执受。云何有执受。谓自体所摄眼处。云何无执受。谓非自体所摄眼处。色耳声鼻香舌味身触处亦尔。此十二处。几是心。几非心。答一是心。十一非心。此十二处。几是心所几非心所。答十一非心所。一应分别。谓法处或是心所或非心所。云何是心所。谓有所缘法处。云何非心所。谓无所缘法处。此十二处。几有所缘几无所缘。答一有所缘。十无所缘。一应分别。谓法处或有所缘或无所缘。云何有所缘。谓诸心所。云何无所缘。谓非心所法处。此十二处。几是业几非业。答九非业。三应分别。谓色处或是业或非业。云何是业。谓身表业。云何非业。谓余色处。声处或是业或非业。云何是业。谓语表业。云何非业。谓余声处。法处或是业或非业。云何是业。谓法处所摄身语业及思。云何非业。谓余法处

此十二处。几善几不善几无记。答八无记。四应分别。谓色处或善或不善或无记。云何善。谓善身表业。云何不善。谓不善身表业。云何无记。谓除善不善身表业。诸余色处声处。或善或不善或无记。云何善。谓善语表业。云何不善。谓不善语表业。云何无记。谓除善不善语表业。诸余声处意处。或善或不善或无记。云何善。谓善作意相应意处。云何不善。谓不善作意相应意处。云何无记。谓无记作意相应意处。法处或善或不善或无记。云何善。谓法处所摄善身语业及善受想行蕴并择灭。云何不善。谓法处所摄不善身语业。及不善受想行蕴。云何无记。谓无记受想行蕴。及虚空非择灭。此十二处。几见所断。几修所断。几非所断。答十修所断。二应分别。谓意处或见所断。或修所断。或非所断。云何见所断。谓若意处。随信随法行现观边忍所断。此复云何。谓见所断八十八随眠。相应意处。云何修所断。谓若意处学见迹修所断。此复云何。谓修所断十随眠相应意处。及不染污有漏意处。云何非所断。谓无漏意处法处。或见所断。或修所断。或非所断。云何见所断。谓若法处随信随法行现观边忍所断。此复云何。谓见所断八十八随眠。及彼相应法处。彼所等起心不相应行。云何修所断。谓若法处学见迹修所断。此复云何。谓修所断十随眠。及彼相应法处。彼所等起身语业。彼所等起心不相应行。并不染污有漏法处。云何非所断。谓无漏法处。此十二处。几学几无学几非学非无学。答十非学非无学。二应分别。谓意处或学或无学或非学非无学。云何学。谓学作意相应意处。云何无学。谓无学作意相应意处。云何非学非无学。谓非学非无学作意相应意处。法处或学或无学或非学非无学。云何学。谓学身语业及学受想行蕴。云何无学。谓无学身语业。及无学受想行蕴。云何非学非无学。谓法处所摄有漏身语业。及有漏受想行蕴。并无为法。此十二处。几欲界系。几色界系。几无色界系。几不系。答二欲界系。十应分别。谓眼处或欲界系或色界系。云何欲界系。谓若眼处欲界系大种所造。云何色界系。谓若眼处色界系大种所造色。耳声鼻舌身处亦尔。触处或欲界系或色界系。云何欲界系。谓欲界系四大种。及欲界系大种所造触处。云何色界系。谓色界系四大种。及色界系大种所造触处。意处或欲界系。或色界系或无色界系。或不系。云何欲界系。谓欲界系作意相应意处。云何色界系。谓色界系作意相应意处。云何无色界系。谓无色界系作意相应意处云。何不系。谓无漏作意相应意处。法处或欲界系。或色界系。或无色界系。或不系。云何欲界系。谓欲界系法处所摄身语业。受想行蕴。云何色界系。谓色界系法处所摄身语业。受想行蕴。云何无色界系。谓无色界系受想行蕴。云何不系。谓无漏身语业受想行蕴。及无为法。此十二处。几过去几未来几现在。答十一或过去或未来或现在。一应分别。谓法处若有为。或过去或未来或现在。若无为非过去非未来非现在

此十二处几苦谛摄。几集谛摄。几灭谛摄。几道谛摄。几非谛摄。答十苦集谛摄。二应分别。谓意处若有漏苦集谛摄。若无漏道谛摄。法处若有漏。苦集谛摄。若无漏有为道谛摄。若择灭灭谛摄。若虚空非择灭非谛摄。此十二处。几见苦所断。几见集所断。几见灭所断。几见道所断。几修所断。几非所断。答十修所断。二应分别。谓意处或见苦集灭道修所断。或非所断。云何见苦所断。谓若意处。随信随法行苦现观边忍所断。此复云何。谓见苦所断。二十八随眠相应意处。云何见集所断。谓若意处随信随法行集现观边忍所断。此复云何。谓见集所断十九随眠相应意处。云何见灭所断。谓若意处随信随法行灭现观边忍所断。此复云何。谓见灭所断十九随眠相应意处。云何见道所断。谓若意处随信随法行道现观边忍所断。此复云何。谓见道所断二十二随眠相应意处。云何修所断。谓若意处。学见迹修所断。此复云何。谓修所断十随眠相应意处。及不染污有漏意处。云何非所断。谓无漏意处法处。或见苦集灭道修所断。或非所断。云何见苦所断。谓若法处随信随法行苦现观边忍所断。此复云何。谓见苦所断二十八随眠。及彼相应法处。彼所等起心不相应行。云何见集所断。谓若法处随信随法行集现观边忍所断。此复云何。谓见集所断十九随眠。及彼相应法处。彼所等起心不相应行。云何见灭所断。谓若法处随信随法行灭现观边忍所断。此复云何。谓见灭所断十九随眠。及彼相应法处。彼所等起心不相应行。云何见道所断。谓若法处随信随法行道现观边忍所断。此复云何。谓见道所断二十二随眠。及彼相应法处。彼所等起心不相应行。云何修所断。谓若法处学见迹修所断。此复云何。谓修所断十随眠。及彼相应法处。彼所等起身语业。心不相应行。并不染污有漏法处。云何非所断。谓无漏法处

五蕴十二处。为五摄十二。十二摄五耶。答十二摄五。非五摄十二。何所不摄。谓诸无为五蕴十八界。为五摄十八。十八摄五耶。答十八摄五。非五摄十八。何所不摄。谓诸无为。五蕴二十二根。为五摄二十二。二十二摄五耶。答二蕴全二蕴少分。摄二十二根。二十二根。摄二蕴全二蕴少分。何所不摄。谓一蕴全。二蕴少分。五蕴九十八随眠。为五摄九十八。九十八摄五耶。答一蕴少分。摄九十八随眠。九十八随眠。摄一蕴少分。何所不摄。谓四蕴全。一蕴少分。十二处十八界。为十二摄十八。十八摄十二耶。答互相摄随其事。十二处二十二根。为十二摄二十二。二十二摄十二耶。答六处全一处少分。摄二十二根。二十二根。摄六处全一处少分。何所不摄。谓五处全一处少分。十二处九十八随眠。为十二摄九十八。九十八摄十二耶。答一处少分。摄九十八随眠。九十八随眠。摄一处少分。何所不摄。谓十一处全一处少分。十八界二十二根。为十八摄二十二。二十二摄十八耶。答十二界全一界少分。摄二十二根。二十二根。摄十二界全一界少分。何所不摄。谓五界全一界少分。十八界九十八随眠。为十八摄九十八。九十八摄十八耶。答一界少分。摄九十八随眠。九十八随眠。摄一界少分。何所不摄。谓十七界全一界少分。二十二根九十八随眠。为二十二摄九十八。九十八摄二十二耶。答互不相摄

    品类足论辩七事品第四之一

十八界十二处五蕴五取蕴六界。十大地法。十大善地法。十大烦恼地法。十小烦恼地法。五烦恼五触五见五根五法。六识身。六触身。六受身。六想身。六思身。六爱身。十八界云何。谓眼界色界眼识界。耳界声界耳识界。鼻界香界鼻识界。舌界味界舌识界。身界触界身识界。意界法界意识界。十二处云何。谓眼处色处耳处声处鼻处香处舌处味处身处触处意处法处。五蕴云何。谓色蕴受蕴想蕴行蕴识蕴。五取蕴云何。谓色取蕴受取蕴想取蕴行取蕴识取蕴。六界云何。谓地界水界火界风界空界识界。十大地法云何。谓受想思触作意欲胜解念定慧。十大善地法云何。谓信勤惭愧无贪无嗔轻安舍不放逸不害。十大烦恼地法云何。谓不信懈怠失念心乱无明不正知非理作意邪胜解掉举放逸。十小烦恼地法云何。谓忿恨覆恼嫉悭诳谄憍害。五烦恼云何。谓欲贪色贪无色贪嗔痴。五触云何。谓有对触。增语触。明触。无明触。非明非无明触。五见云何。谓有身见。边执见。邪见。见取。戒禁取。五根云何。谓乐根苦根喜根忧根舍根。五法云何。谓寻伺识无惭无愧。六识身云何。谓眼识耳识鼻识舌识身识意识。六触身云何。谓眼触耳触鼻触舌触身触意触。六受身云何。谓眼触所生受。耳触所生受。鼻触所生受。舌触所生受。身触所生受。意触所生受。六想身云何。谓眼触所生想。耳触所生想。鼻触所生想。舌触所生想。身触所生想。意触所生想。六思身云何。谓眼触所生思。耳触所生思。鼻触所生思。舌触所生思。身触所生思。意触所生思。六爱身云何。谓眼触所生爱。耳触所生爱。鼻触所生爱。舌触所生爱。身触所生爱。意触所生爱

眼界云何。谓眼于色已正当见。及彼同分。色界云何。谓色为眼已正当见。及彼同分。眼识界云何。谓眼及色为缘生眼识。如是眼为增上。色为所缘。于眼所识色。诸已正当了别。及彼同分。耳界云何。谓耳于声已正当闻。及彼同分。声界云何。谓声为耳已正当闻。及彼同分。耳识界云何。谓耳及声为缘生耳识。如是耳为增上。声为所缘。于耳所识声。诸已正当了别。及彼同分。鼻界云何。谓鼻于香已正当嗅。及彼同分。香界云何。谓香为鼻已正当嗅。及彼同分。鼻识界云何。谓鼻及香为缘生鼻识。如是鼻为增上。香为所缘。于鼻所识香。诸已正当了别。及彼同分。舌界云何。谓舌于味已正当尝。及彼同分。味界云何。谓味为舌已正当尝。及彼同分。舌识界云何。谓舌及味为缘生舌识。如是舌为增上。味为所缘。于舌所识味。诸已正当了别。及彼同分。身界云何。谓身于触已正当触。及彼同分。触界云何。谓触为身已正当触。及彼同分。身识界云何。谓身及触为缘生身识。如是身为增上。触为所缘。于身所识触。诸已正当了别。及彼同分。意界云何。谓意于法已正当了。及彼同分。法界云何。谓法为意已正当了。意识界云何。谓意及法为缘生意识。如是意为增上。法为所缘。于意所识法。诸已正当了别。及彼同分

眼处云何。谓眼是色已正当能见。及彼同分。色处云何。谓色是眼已正当所见。及彼同分。耳处云何。谓耳是声已正当能闻。及彼同分。声处云何。谓声是耳已正当所闻。及彼同分。鼻处云何。谓鼻是香已正当能嗅。及彼同分。香处云何。谓香是鼻已正当所嗅。及彼同分。舌处云何。谓舌是味已正当能尝。及彼同分。味处云何。谓味是舌已正当所尝。及彼同分。身处云何。谓身是触已正当能触。及彼同分。触处云何。谓触是身已正当所触。及彼同分。意处云何。谓意是法已正当能了。及彼同分。法处云何。谓法是意已正当所了

色蕴云何。谓十色处。及法处所摄色。受蕴云何。谓六受身。即眼触所生受。乃至意触所生受。想蕴云何。谓六想身。即眼触所生想。乃至意触所生想。行蕴云何。此有二种。谓心相应行蕴。心不相应行蕴。心相应行蕴云何。谓心相应法。此复云何。谓思触作意欲胜解念定慧信勤寻伺。放逸不放逸。善根不善根无记根。一切结缚随眠随烦恼缠。诸所有智诸所有见诸所有现观。复有此余如是类法与心相应。总名心相应行蕴。心不相应行蕴云何。谓心不相应法。此复云何。谓得无想定灭定无想事命根众同分。依得事得处得。生老住无常。名身句身文身。复有此余如是类法与心不相应。总名心不相应行蕴。如是二种合名行蕴。识蕴云何。谓六识身。即眼识乃至意识。色取蕴云何。谓若诸色有漏有取。于此诸色。若过去若未来若现在。或欲或贪或嗔或痴。或随一一心所随烦恼。应生时生。是名色取蕴。受想行识取蕴云何。谓若诸受想行识。有漏有取。于此诸受想行识。若过去若未来若现在。或欲或贪或嗔或痴。或随一一心所随烦恼。应生时生。是名受想行识取蕴

地界云何。谓坚性。水界云何。谓湿性。火界云何。谓暖性。风界云何。谓轻等动性。空界云何。谓邻阿伽色。识界云何。谓五识身。及有漏意识

受云何。谓受等受各别等受已受受类。是名为受。想云何。谓想等想增上等想已想想类。是名为想。思云何。谓思等思增上等思已思思类。心作意业。是名为思。触云何。谓触等触触性等触性。已触触类。是名为触。作意云何。谓牵引心。随顺牵引。思惟牵引。作意造意。转变心警觉心。是名作意。欲云何。谓欲欲性增上。欲性现前。欣喜希望乐作。是名为欲。胜解云何。谓心正胜解已胜解当胜解性。是名胜解。念云何。谓念随念别念忆念。不忘不失不遗不漏不忘法性。心明记性。是名为念。定云何。谓令心住等住安住近住坚住。不乱不散。摄止等持。心一境性。是名为定慧云何。谓于法简择极简择。最极简择。解了等了遍了近了。机黠通达。审察聪睿。觉明慧行毗钵舍那。是名为慧

说一切有部品类足论卷第二阿毗达磨品类足论卷第三

        尊者世友造

        三藏法师玄奘奉　诏译

    辩七事品第四之余

信云何。谓信性增上信性。忍可欲作。欲为欲造。心澄净性。是名为信。勤云何。谓勤精进。勇健势猛。炽盛难制。励意不息。心勇悍性是名勤。惭云何。谓惭等惭各别惭。羞等羞各别羞。厌等厌各别厌。毁等毁各别毁。有尊有敬。有所自在。有自在转。有所畏忌。不自在行。是名为惭。愧云何。谓愧等愧各别愧。耻等耻各别耻。厌等厌各别厌。毁等毁各别毁。怖罪惧罪。于罪见怖。是名为愧。无贪云何。谓有心所与心相应。能对治贪。是名无贪。无嗔云何。谓有心所与心相应。能对治嗔。是名无嗔。轻安云何。谓身轻安心轻安。已轻安轻安类。是名轻安。舍云何。谓身平等心平等。身正直心正直。无警觉寂静住。是名为舍。不放逸云何。谓于断恶法具足善法中。坚作常作。修习不舍。名不放逸。不害云何。谓于有情不毁不损。不伤不害。不恼不触。不令堕苦。是名不害

不信云何。谓不信不信性。增上不信性。不忍不可。不欲作。不欲为。不欲造。心不澄净性。是名不信。懈怠云何。谓下劣精进。微弱精进。羸惙精进。退怯精进。憩息精进。心不勇悍性。是名懈怠。失念云何。谓虚念空念。忘念失念。心外念性。是名失念。心乱云何。谓心乱心散心流转心飘荡。心不一趣不住一缘。是名心乱。无明云何。谓三界无知性。不正知云何。谓非理所引慧非理。作意云何。谓染污作意。邪胜解云何。谓染污作意相应心。正胜解已胜解当胜解。是名邪胜解。掉举云何。谓心不寂静。心不憺怕。心不宁谧。掉动飘举。心躁扰性。是名掉举。放逸云何。谓于断恶法具足善法中。不修不习不别修习。不坚作不常作。不勤修习性。是名放逸

忿云何。谓忿等忿。遍忿极忿。已正当忿。是名为忿。恨云何。谓心结怨。已正当恨。是名为恨。覆云何。谓隐藏自罪。恼云何。谓心佷悷。已正当恼。是名为恼。嫉云何谓心妒忌。悭云何。谓心鄙吝。诳云何。谓幻惑他。谄云何。谓心矫曲。憍云何。谓憍醉极憍醉。迷闷极迷闷。慢缓极慢缓。心傲诞性。是名为憍。害云何。谓于有情能为毁损伤害恼触。逼令堕苦。是名为害。欲贪云何。谓于诸欲起贪等贪。执藏防护。耽着爱乐。是名欲贪。色贪云何。谓于诸色起贪等贪。执藏防护。耽着爱乐。是名色贪。无色贪云何。谓于无色起贪等贪。执藏防护。耽着爱乐。是名无色贪。嗔云何。谓于有情心怀愤恚。根裁对碍。憎怒凶悖。猛烈暴恶。已正当嗔。是名为嗔。疑云何。谓于谛犹豫

有对触云何。谓五识身相应触。增语触云何。谓意识身相应触。明触云何。谓无漏触。无明触云何。谓染污触。非明非无明触云何。谓不染污有漏触

有身见云何。谓于五取蕴等。随观执我或我所。由此起忍乐慧观见。是名有身见。边执见云何。谓于五取蕴等。随观执或断或常。由此起忍乐慧观见。是名边执见。邪见云何。谓谤因谤果。或谤作用。或坏实事。由此起忍乐慧观见。是名邪见。见取云何。谓于五取蕴等。随观执为最为胜。为上为极。由此起忍乐慧观见。是名见取。戒禁取云何。谓于五取蕴等。随观执为能清净。为能解脱。为能出离。由此起忍乐慧观见。是名戒禁取

乐根云何。谓顺乐受。触所触时。所起身乐心乐平等受。受所摄。是名乐根。苦根云何。谓顺苦受。触所触时。所起身苦不平等受。受所摄。是名苦根。喜根云何。谓顺喜受。触所触时。所起心喜平等受。受所摄。是名喜根。忧根云何。谓顺忧受。触所触时。所起心忧不平等受。受所摄。是名忧根。舍根云何。谓顺舍受。触所触时。所起身舍心舍。非平等非不平等受。受所摄。是名舍根

寻云何。谓心寻求遍寻求。构度极构度现前构度。推究追寻极思惟。思惟性令心粗动。是名为寻。伺云何。谓心伺察遍伺察随遍伺察。随转随流随属。于寻令心细动。是名为伺。识云何。谓六识身。即眼识乃至意识。无惭云何。谓不惭不等惭不各别惭。不羞不等羞不各别羞。不厌不等厌不各别厌。不毁不等毁不各别毁。无尊无敬。无所自在。无自在转。无所畏忌自在而行。是名无惭。无愧云何。谓不愧不等愧不各别愧。不耻不等耻不各别耻。不厌不等厌不各别厌。不毁不等毁不各别毁。不怖罪不惧罪于罪不见怖。是名无愧

眼识云何。谓眼及色为缘生眼识。如是眼为增上。色为所缘。于眼所识色。诸已正当了别。是名眼识。耳鼻舌身意识亦尔。眼触云何。谓眼及色为缘生眼识。三和合故触。如是眼为增上。色为所缘。于眼所识色。诸触等触触性等触性已触触类。是名眼触。耳鼻舌身意触亦尔。眼触所生受云何。谓眼及色为缘生眼识。三和合故触。触为缘故受。如是眼为增上。色为所缘。眼触为因为集为类为生。眼触所生作意相应。于眼所识色。诸受等受各别等受。已受受类。是名眼触所生受。耳鼻舌身意触所生受亦尔。眼触所生想云何。谓眼及色为缘生眼识。三和合故触。触为缘故想。如是眼为增上色为所缘。眼触为因为集为类为生。眼触所生作意相应。于眼所识色诸想等想增上等想已想想类。是名眼触所生想。耳鼻舌身意触所生想亦尔。眼触所生思云何。谓眼及色为缘生眼识。三和合故触。触为缘故思。如是眼为增上。色为所缘。眼触为因为集为类为生。眼触所生作意相应。于眼所识色诸思等思增上等思。已思思类心作意业。是名眼触所生思。耳鼻舌身意触所生思亦尔。眼触所生爱云何。谓眼及色为缘生眼识。三和合故触。触为缘故爱。如是眼为增上。色为所缘。于眼所识色诸贪等贪。执藏防护耽着爱乐。是名眼触所生爱。耳鼻舌身意触所生爱亦尔

眼界。几界几处几蕴摄。眼界所摄法几界几处几蕴摄。眼界所不摄法。几界几处几蕴摄。眼界所摄不摄法。几界几处几蕴摄。除眼界所摄法余法。几界几处几蕴摄。除眼界所不摄法余法。几界几处几蕴摄。除眼界所摄不摄法余法。几界几处几蕴摄。乃至意触所生爱。为问亦尔

答眼界一界一处一蕴摄。不摄十七界十一处五蕴。眼界所摄法一界一处一蕴摄。不摄十七界十一处五蕴。眼界所不摄法。十七界十一处五蕴摄。不摄一界一处一蕴。眼界所摄不摄法。十八界十二处五蕴摄。无界无处无蕴不摄。除眼界所摄法余法。十七界十一处五蕴摄。不摄一界一处一蕴。除眼界所不摄法余法。一界一处一蕴摄。不摄十七界十一处五蕴。除眼界所摄不摄法。所问余法。无事空论。以一切法皆被除故。如眼界。九有色界十有色处。应知亦尔。眼识界。二界一处一蕴摄。不摄十七界十二处五蕴。如眼识界。耳鼻舌身意识界六识身。应知亦尔。意界七界一处一蕴摄。不摄十一界十一处四蕴。如意界。意处识蕴识法。应知亦尔。法界一界一处四蕴摄。不摄十七界十一处二蕴。法处亦尔。色蕴十一界十一处一蕴摄。不摄八界二处四蕴。受蕴一界一处一蕴摄。不摄十八界十二处四蕴。如受蕴。想蕴行蕴大地法中受想。应知亦尔。色取蕴十一界十一处一蕴摄。不摄八界二处五蕴。受取蕴一界一处一蕴摄。不摄十八界十二处五蕴。如受取蕴。想取蕴行取蕴。五有色界。八大地法。十大善地法。十大烦恼地法。十小烦恼地法。五烦恼五触五见五根四法。后五六身。应知亦尔。识取蕴七界一处一蕴摄。不摄十三界十二处五蕴。识界亦尔

眼识界一界一处三蕴相应。十八界十二处五蕴不相应。如眼识界。耳鼻舌身意识界识取蕴识界六识身。应知亦尔。意界一界一处三蕴相应。十八界十二处三蕴不相应。如意界。意处识蕴识法。应知亦尔。法界八界二处四蕴相应。十一界十一处二蕴不相应。如法界。法处行蕴八大地法。应知亦尔。受蕴八界二处三蕴相应。十一界十一处三蕴不相应。如受蕴想蕴大地法中受想。应知亦尔。受取蕴八界二处三蕴相应。十三界十二处五蕴不相应。想取蕴亦尔。行取蕴八界二处四蕴相应。十三界十二处五蕴不相应。寻伺法亦尔。信八界二处四蕴相应。十八界十二处五蕴不相应。如信余九大善地法。十大烦恼地法。欲贪嗔无明触非明非无明触无惭无愧。应知亦尔。忿三界二处四蕴相应。十八界十二处五蕴不相应。如忿。余九小烦恼地法。无色贪疑明触。五见六爱身。应知亦尔。色贪六界二处四蕴相应。十八界十二处五蕴不相应。有对触七界二处四蕴相应。十三界十二处五蕴不相应。增语触三界三处四蕴相应。十七界十二处五蕴不相应。六触身六思身亦尔。乐根八界二处三蕴相应。十八界十二处五蕴不相应。舍根亦尔。苦根七界二处三蕴相应。十八界十二处五蕴不相应。喜根三界二处三蕴相应。十八界十二处五蕴不相应。忧根亦尔。眼触所生受。三界二处三蕴相应。十七界十二处五蕴不相应。如眼触所生受。耳鼻舌身意触所生受六想身。应知亦尔

    品类足论辩随眠品第五之一

九十八随眠。几欲界系。几色界系。几无色界系。答三十六欲界系。三十一色界系。三十一无色界系。此九十八随眠。几见所断。几修所断。答八十八见所断。十修所断。欲界系三十六随眠。几见所断。几修所断。答三十二见所断。四修所断。色界系三十一随眠。几见所断。几修所断。答二十八见所断。三修所断。无色界系三十一随眠亦尔。此九十八随眠。几见苦所断。几见集灭道修所断。答二十八见苦所断。十九见集所断。十九见灭所断。二十二见道所断。十修所断。欲界系三十六随眠。几见苦所断。几见集灭道修所断。答十见苦所断。七见集所断。七见灭所断。八见道所断。四修所断。色界系三十一随眠。几见苦所断。几见集灭道修所断。答九见苦所断。六见集所断。六见灭所断。七见道所断。三修所断。无色界系三十一随眠亦尔。随眠是何义。答微细义是随眠义。随增义是随眠义。随逐义是随眠义。随缚义是随眠义。如是随眠。若未断未遍知。由二事故随增。谓所缘故相应故。如是随增。于自界非他界。有十二随眠。谓欲贪随眠。嗔恚随眠。色贪随眠。无色贪随眠。慢随眠。无明随眠。有身见随眠。边执见随眠。邪见随眠。见取随眠。戒禁取随眠。疑随眠。云何欲贪随眠随增。谓可爱故可乐故可恋故可意故。云何嗔恚随眠随增。谓不可爱故不可乐故不可恋故不可意故。云何色贪随眠随增。谓可爱故。可乐故可喜故可意故。云何无色贪随眠随增。谓可爱故可乐故可意故。云何慢随眠随增。谓高举故轻篾故。云何无明随眠随增。谓无知故闇昧故愚痴故。云何有身见随眠随增。谓我故我所故。云何边执见随眠随增。谓断故常故。云何邪见随眠随增。谓无因故无用故诽谤故。云何见取随眠随增。谓最故胜故上故极故。云何戒禁取随眠随增。谓能清净故。能解脱故能出离故。云何疑随眠随增。谓惑故疑故犹豫故。云何起欲贪随眠。乃至云何起疑随眠。答欲贪随眠。由三处起。一者欲贪随眠未断未遍知故。二者顺欲贪缠法现在前故。三者于彼处有非理作意故。乃至疑随眠亦由三处起。一者疑随眠未断未遍知故。二者顺疑缠法现在前故。三者于彼处有非理作意故。有七随眠十二随眠。为七摄十二。十二摄七耶。答互相摄随其事。谓欲贪随眠摄欲贪随眠。嗔随眠摄嗔恚随眠。有贪随眠。摄色无色贪随眠。慢随眠摄慢随眠。无明随眠摄无明随眠。见随眠摄五见随眠。疑随眠摄疑随眠。七随眠九十八随眠。为七摄九十八。九十八摄七耶。答互相摄随其事。谓欲贪嗔随眠各摄五。有贪随眠摄十。慢无明随眠各摄十五。见随眠摄三十六。疑随眠摄十二。十二随眠九十八随眠。为十二摄九十八。九十八摄十二耶。答互相摄随其事。谓欲贪嗔色无色贪随眠各摄五。慢无明随眠各摄十五。有身见边执见随眠各摄三。邪见见取疑随眠各摄十二。戒禁取随眠摄六

九十八随眠。几是遍行。几非遍行。答二十七是遍行。六十五非遍行。六应分别。谓见苦集所断无明随眠。或是遍行或非遍行。云何是遍行。谓见苦集所断非遍行随眠不相应无明。云何非遍行。谓见苦集所断非遍行随眠相应无明。欲界系三十六随眠。几是遍行。几非遍行。答九是遍行。二十五非遍行。二应分别。谓欲界系见苦集所断无明随眠。或是遍行或非遍行。云何是遍行。谓欲界系见苦集所断非遍行随眠不相应无明。云何非遍行。谓欲界系见苦集所断非遍行随眠相应无明。色界系三十一随眠。几是遍行。几非遍行。答九是遍行二十非遍行。二应分别。谓色界系见苦集所断无明随眠。或是遍行或非遍行。云何是遍行。谓色界系见苦集所断非遍行。随眠不相应无明。云何非遍行。谓色界系见苦集所断非遍行随眠相应无明。无色界系三十一随眠亦尔。九十八随眠。几是遍行修所断。几非遍行非修所断。答三十七是遍行修所断。五十五非遍行非修所断。六应分别。谓见苦集所断无明随眠。或是遍行或非遍行。云何是遍行。谓见苦集所断非遍行随眠不相应无明。云何非遍行。谓见苦集所断非遍行随眠相应无明。欲界三十六随眠。几是遍行修所断。几非遍行非修所断。答十三是遍行修所断。二十一非遍行非修所断。二应分别。谓欲界系见苦集所断无明随眠。或是遍行或非遍行。云何是遍行。谓欲界系见苦集所断非遍行随眠不相应无明。云何非遍行。谓欲界系见苦集所断非遍行随眠相应无明。色界三十一随眠。几是遍行修所断。几非遍行非修所断。答十二是遍行修所断。十七非遍行非修所断。二应分别。谓色界系见苦集所断无明随眠。或是遍行或非遍行。云何是遍行。谓色界系见苦集所断非遍行随眠不相应无明。云何非遍行。谓色界系见苦集所断非遍行随眠相应无明。无色界系三十一随眠亦尔

九十八随眠。几有漏缘。几无漏缘。答八十有漏缘。十二无漏缘。六应分别。谓见灭道所断无明随眠。或有漏缘或无漏缘。云何有漏缘。谓见灭道所断有漏缘随眠相应无明。云何无漏缘。谓见灭道所断有漏缘随眠不相应无明。欲界系三十六随眠。几有漏缘。几无漏缘。答三十有漏缘。四无漏缘。二应分别。谓欲界系见灭道所断无明随眠。或有漏缘或无漏缘。云何有漏缘。谓欲界系见灭道所断有漏缘随眠相应无明。云何无漏缘。谓欲界系见灭道所断有漏缘随眠不相应无明。色界系三十一随眠。几有漏缘。几无漏缘。答二十五有漏缘。四无漏缘。二应分别。谓色界系见灭道所断无明随眠。或有漏缘或无漏缘。云何有漏缘。谓色界系见灭道所断有漏缘随眠相应无明。云何无漏缘。谓色界系见灭道所断有漏缘随眠不相应无明。无色界系三十一随眠亦尔

九十八随眠。几有为缘。几无为缘。答八十九有为缘。六无为缘。三应分别。谓见灭所断无明随眠。或有为缘或无为缘。云何有为缘。谓见灭所断有为缘随眠相应无明。云何无为缘。谓见灭所断有为缘随眠不相应无明。欲界系三十六随眠。几有为缘。几无为缘。答三十三有为缘。二无为缘。一应分别。谓欲界系见灭所断无明随眠。或有为缘或无为缘。云何有为缘。谓欲界系见灭所断有为缘随眠相应无明。云何无为缘。谓欲界系见灭所断有为缘随眠不相应无明。色界系三十一随眠。几有为缘。几无为缘。答二十八有为缘。二无为缘。一应分别。谓色界系见灭所断无明随眠。或有为缘或无为缘。云何有为缘。谓色界系见灭所断有为缘随眠相应无明。云何无为缘。谓色界系见灭所断有为缘随眠不相应无明。无色界系三十一随眠亦尔

九十八随眠。几所缘故随增非相应故。几相应故随增非所缘故。几所缘故随增亦相应故。几非所缘故随增非相应故。答所缘故随增非相应故者。无相应故。随增非所缘故者。谓无漏缘随眠。所缘故随增亦相应故者。谓有漏缘随眠。非所缘故随增非相应故者无。如不定系欲界系色界系无色界系亦尔

有二十法。谓见苦所断法。见集所断法。见灭所断法。见道所断法。修所断法。如不定系欲界系色界系无色界系亦尔。于见苦所断法。几随眠随增。答见苦所断一切。及见集所断遍行随眠。于见集所断法。几随眠随增。答见集所断一切。及见苦所断遍行随眠。于见灭所断法。几随眠随增。答见灭所断一切。及遍行随眠。于见道所断法。几随眠随增。答见道所断一切。及遍行随眠。于修所断法。几随眠随增。答修所断一切。及遍行随眠。如不定系欲界系色界系无色界系亦尔

于见苦所断法。几随眠所缘故随增非相应故。几随眠相应故随增非所缘故。几随眠所缘故随增亦相应故。几随眠非所缘故随增非相应故。答所缘故随增非相应故者。谓见集所断遍行随眠。相应故随增非所缘故者无。所缘故随增亦相应故者。谓见苦所断一切随眠。非所缘故随增非相应故者。谓见集所断非遍行。及见灭道修所断一切随眠。于见集所断法。几随眠所缘故随增非相应故。几随眠相应故随增非所缘故。几随眠所缘故随增亦相应故。几随眠非所缘故随增非相应故。答所缘故随增非相应故者。谓见苦所断遍行随眠。相应故随增非所缘故者无。所缘故随增亦相应故者。谓见集所断一切随眠。非所缘故随增非相应故者。谓见苦所断非遍行。及见灭道修所断一切随眠。于见灭所断法。几随眠所缘故随增非相应故。几随眠相应故随增非所缘故。几随眠所缘故随增亦相应故。几随眠非所缘故随增非相应故。答所缘故随增非相应故者。谓遍行随眠。相应故随增非所缘故者。谓见灭所断无漏缘随眠。所缘故随增亦相应故者。谓见灭所断有漏缘随眠。非所缘故随增非相应故者。谓见苦集所断非遍行。及见道修所断一切随眠。于见道所断法。几随眠所缘故随增非相应故。几随眠相应故随眠非所缘故。几随眠所缘故随增亦相应故。几随眠非所缘故随增非相应故。答所缘故随增非相应故者。谓遍行随眠。相应故随增非所缘故者。谓见道所断无漏缘随眠。所缘故随增亦相应故者。谓见道所断有漏缘随眠。非所缘故随增非相应故者。谓见苦集所断非遍行。及见灭修所断一切随眠。于修所断法。几随眠所缘故随增非相应故。几随眠相应故随增非所缘故。几随眠所缘故随增亦相应故。几随眠非所缘故随增非相应故。答所缘故随增非相应故者。谓遍行随眠。相应故随增非所缘故者无。所缘故随增亦相应故者。谓修所断一切随眠。非所缘故随增非相应故者。谓见苦集所断非遍行。及见灭道所断一切随眠。如不定系欲界系色界系无色界系亦尔

说一切有部品类足论卷第三阿毗达磨品类足论卷第四

        尊者世友造

        三藏法师玄奘奉　诏译

    辩随眠品第五之二

有唯二十法。谓唯见苦所断法。唯见集所断法。唯见灭所断法。惟见道所断法。唯修所断法。如不定系欲界系色界系无色界系亦尔。于惟见苦所断法。几随眠随增。答惟见苦所断。非遍行随眠。于惟见集所断法。几随眠随增。答惟见集所断。非遍行随眠。于惟见灭所断法。几随眠随增。答惟见灭所断一切随眠。于惟见道所断法。几随眠随增。答惟见道所断一切随眠。于惟修所断法。几随眠随增。答惟修所断一切随眠。如不定系欲界系色界系无色界系亦尔

于惟见苦所断法。几随眠所缘故随增非相应故。几随眠相应故随增非所缘故。几随眠所缘故随增亦相应故。几随眠非所缘故随增非相应故。答所缘故随增非相应故者无。相应故随增非所缘故者无。所缘故随增亦相应故者。谓惟见苦所断非遍行随眠。非所缘故随增非相应故者无。于惟见集所断法。几随眠所缘故随增非相应故。几随眠相应故随增非所缘故。几随眠所缘故随增亦相应故。几随眠非所缘故随增非相应故。答所缘故随增非相应故者无。相应故随增非所缘故者无。所缘故随增亦相应故者。谓惟见集所断非遍行随眠。非所缘故随增非相应故者无。于惟见灭所断法。几随眠所缘故随增非相应故。几随眠相应故随增非所缘故。几随眠所缘故随增亦相应故。几随眠非所缘故随增非相应故。答所缘故随增非相应故者无。相应故随增非所缘故者。谓见灭所断无漏缘随眠。所缘故随增亦相应故者。谓见灭所断有漏缘随眠。非所缘故随增非相应故者无。于惟见道所断法。几随眠所缘故随增非相应故。几随眠相应故随增非所缘故。几随眠所缘故随增亦相应故。几随眠非所缘故随增非相应故。答所缘故随增非相应故者无。相应故随增非所缘故者。谓见道所断无漏缘随眠。所缘故随增亦相应故者。谓见道所断有漏缘随眠。非所缘故随增非相应故者无。于惟修所断法。几随眠所缘故随增非相应故。几随眠相应故随增非所缘故。几随眠所缘故随增亦相应故。几随眠非所缘故随增非相应故。答所缘故随增非相应故者无。相应故随增非所缘故者无。所缘故随增亦相应故者。谓惟修所断一切随眠。非所缘故随增非相应故者无

有二十心。谓见苦所断心。见集所断心。见灭所断心。见道所断心。修所断心。如不定系欲界系色界系无色界系亦尔。于见苦所断心。几随眠随增。答见苦所断一切。及见集所断遍行随眠。于彼相应法。及彼等起心不相应行亦尔。于见集所断心。几随眠随增。答见集所断一切。及见苦所断遍行随眠。于彼相应法。及彼等起心不相应行亦尔。于见灭所断心。几随眠随增。答见灭所断一切。及遍行随眠。于彼相应法亦尔。于彼等起心不相应行。见灭所断有漏缘。及遍行随眠。于见道所断心。几随眠随增。答见道所断一切。及遍行随眠。于彼相应法亦尔。于彼等起心不相应行。见道所断有漏缘。及遍行随眠。于修所断心。几随眠随增。答修所断一切。及遍行随眠。于彼相应法。及彼等起心不相应行亦尔。如不定系欲界系色界系无色界系亦尔

于见苦所断心。几随眠所缘故随增非相应故。几随眠相应故随增非所缘故。几随眠所缘故随增亦相应故。几随眠非所缘故随增非相应故。答所缘故随增非相应故者。谓见集所断遍行随眠。相应故随增非所缘故者无所缘故随增亦相应故者。谓见苦所断一切随眠。非所缘故随增非相应故者。谓见集所断非遍行。及见灭道修所断一切随眠。于彼相应法亦尔。于彼等起心不相应行。见苦所断一切。及见集所断遍行随眠。所缘故随增非相应故。诸余随眠。于彼非所缘故随增非相应故。于见集所断心。几随眠所缘故。随增非相应故几随眠相应故随增非所缘故。几随眠所缘故随增亦相应故。几随眠非所缘故随增非相应故。答所缘故随增非相应故者。谓见苦所断遍行随眠。相应故随增非所缘故者无。所缘故随增亦相应故者。谓见集所断一切随眠。非所缘故随增非相应故者。谓见苦所断非遍行。及见灭道修所断一切随眠。于彼相应法亦尔。于彼等起心不相应行。见集所断一切。及见苦所断遍行随眠。所缘故随增非相应故。诸余随眠。于彼非所缘故随增非相应故。于见灭所断心。几随眠所缘故随增非相应故。几随眠相应故随增非所缘故。几随眠所缘故随增亦相应故。几随眠非所缘故随增非相应故。答所缘故随增非相应故者。谓遍行随眠。相应故随增非所缘故者。谓见灭所断无漏缘随眠。所缘故随增亦相应故者。谓见灭所断有漏缘随眠。非所缘故随增非相应故者。谓见苦集所断非遍行。及见道修所断一切随眠。于彼相应法亦尔。于彼等起心不相应行。见灭所断有漏缘。及遍行随眠。所缘故随增非相应故。诸余随眠。于彼非所缘故随增非相应故。于见道所断心。几随眠所缘故随增非相应故。几随眠相应故随增非所缘故。几随眠所缘故随增亦相应故。几随眠非所缘故随增非相应故。答所缘故随增非相应故者。谓遍行随眠。相应故随增非所缘故者。谓见道所断无漏缘随眠。所缘故随增亦相应故者。谓见道所断有漏缘随眠。非所缘故随增非相应故者。谓见苦集所断非遍行。及见灭修所断一切随眠。于彼相应法亦尔。于彼等起心不相应行。见道所断有漏缘。及遍行随眠所缘故随增非相应故。诸余随眠。于彼非所缘故随增非相应故。于修所断心。几随眠所缘故随增非相应故。几随眠相应故随增非所缘故。几随眠所缘故随增亦相应故。几随眠非所缘故随增亦非相应故。答所缘故随增非相应故者。谓遍行随眠。相应故。随增非所缘故者无。所缘故随增亦相应故者。谓修所断一切随眠。非所缘故随增非相应故者。谓见苦集所断非遍行。及见灭道所断一切随眠。于彼相应法亦尔。于彼等起心不相应行。修所断一切。及遍行随眠。所缘故随增非相应故。诸余随眠。于彼非所缘故随增非相应故。如不定系欲界系色界系无色界系亦尔

有四十八心。谓见灭所断邪见相应心。见灭所断疑相应心。见灭所断邪见疑相应心。见灭所断邪见不相应心。见灭所断疑不相应心。见灭所断邪见疑不相应心。见道所断心亦尔。如不定系欲界系色界系无色界系亦尔。于见灭所断邪见相应心。几随眠随增。答见灭所断邪见。及彼相应无明。若见灭所断有漏缘。若遍行随眠。于彼相应法亦尔。于彼等起心不相应行。见灭所断有漏缘。及遍行随眠。于见灭所断疑相应心。几随眠随增。答见灭所断疑。及彼相应无明。若见灭所断有漏缘。若遍行随眠。于彼相应法亦尔。于彼等起心不相应行。见灭所断有漏缘。及遍行随眠。于见灭所断邪见疑相应心。几随眠随增。答见灭所断邪见疑。及彼相应无明。若见灭所断有漏缘。若遍行随眠。于彼相应法亦尔。于彼等起心不相应行。见灭所断有漏缘。及遍行随眠。于见灭所断邪见不相应心。几随眠随增。答除见灭所断邪见。及彼相应无明。诸余见灭所断一切及遍行随眠。于彼相应法亦尔。于彼等起心不相应行。见灭所断有漏缘及遍行随眠。于见灭所断疑不相应心。几随眠随增。答除见灭所断疑及彼相应无明。诸余见灭所断一切。及遍行随眠。于彼相应法亦尔。于彼等起心不相应行。见灭所断有漏缘。及遍行随眠。于见灭所断邪见疑不相应心。几随眠随增。答除见灭所断邪见疑及彼相应无明。诸余见灭所断一切。及遍行随眠。于彼相应法亦尔。于彼等起心不相应行。见灭所断有漏缘。及遍行随眠。见道所断心亦尔。如不定系。欲界系色界系无色界系亦尔

于见灭所断邪见相应心。几随眠所缘故随增非相应故。几随眠相应故随增非所缘故。几随眠所缘故随增亦相应故。几随眠非所缘故随增非相应故。答所缘故随增非相应故者。谓见灭所断有漏缘。及遍行随眠。相应故随增非所缘故者。谓见灭所断邪见。及彼相应无明。所缘故随增亦相应故者无。非所缘故随增亦非相应故者。谓除见灭所断邪见及彼相应无明。诸余见灭所断无漏缘。及见苦集所断非遍行。并见道修所断一切随眠。于彼相应法亦尔。于彼等起心不相应行。见灭所断有漏缘。及遍行随眠所缘故随增非相应故。诸余随眠。于彼非所缘故随增非相应故。于见灭所断疑相应心。几随眠所缘故随增非相应故。几随眠相应故随增非所缘故。几随眠所缘故随增亦相应故。几随眠非所缘故随增非相应故。答所缘故随增非相应故者。谓见灭所断有漏缘。及遍行随眠。相应故随增非所缘故者。谓见灭所断疑。及彼相应无明。所缘故随增亦相应故者无。非所缘故随增非相应故者。谓除见灭所断疑及彼相应无明。诸余见灭所断无漏缘。及见苦集所断非遍行。并见道修所断一切随眠于彼相应法亦尔。于彼等起心不相应行。见灭所断有漏缘。及遍行随眠。所缘故随增非相应故。诸余随眠。于彼非所缘故随增非相应故。于见灭所断邪见疑相应心。几随眠所缘故随增非相应故。几随眠相应故随增非所缘故。几随眠所缘故随增亦相应故。几随眠非所缘故随增非相应故。答所缘故随增非相应故者。谓见灭所断有漏缘。及遍行随眠。相应故随增非所缘故者。谓见灭所断邪见疑。及彼相应无明。所缘故随增亦相应故者无。非所缘故随增非相应故者。谓除见灭所断邪见疑及彼相应无明。诸余见灭所断无漏缘。及见苦集所断非遍行。并见道修所断一切随眠。于彼相应法亦尔。于彼等起心不相应行。见灭所断有漏缘。及遍行随眠。所缘故随增非相应故。诸余随眠。于彼非所缘故随增非相应故。于见灭所断邪见不相应心。几随眠所缘故随增非相应故。几随眠相应故随增非所缘故。几随眠所缘故随增亦相应故。几随眠非所缘故随增非相应故。答所缘故随增非相应故者。谓遍行随眠。相应故随增非所缘故者。谓除见灭所断邪见及彼相应无明。诸余见灭所断无漏缘随眠。所缘故随增亦相应故者。谓见灭所断有漏缘随眠。非所缘故随增非相应故者。谓见灭所断邪见。及彼相应无明。若见苦集所断非遍行。若见道修所断一切随眠。于彼相应法亦尔。于彼等起心不相应行见灭所断有漏缘。及遍行随眠。所缘故随增非相应故。诸余随眠。于彼非所缘故随增非相应故。于见灭所断疑不相应心。几随眠所缘故随增非相应故。几随眠相应故随增非所缘故。几随眠所缘故随增亦相应故。几随眠非所缘故随增非相应故。答所缘故随增非相应故者。谓遍行随眠。相应故随增非所缘故者。谓除见灭所断疑及彼相应无明。诸余见灭所断无漏缘随眠。所缘故随增亦相应故者。谓见灭所断有漏缘随眠。非所缘故随增非相应故者。谓见灭所断疑。及彼相应无明。若见苦集所断非遍行。若见道修所断一切随眠。于彼相应法亦尔。于彼等起心不相应行。见灭所断有漏缘。及遍行随眠。所缘故随增非相应故。诸余随眠。于彼非所缘故随增非相应故。于见灭所断邪见疑不相应心。几随眠所缘故随增非相应故。几随眠相应故随增非所缘故。几随眠所缘故随增亦相应故。几随眠非所缘故随增非相应故。答所缘故随增非相应故者。谓遍行随眠。相应故随增非所缘故者。谓除见灭所断邪见疑及彼相应无明。诸余见灭所断无漏缘随眠。所缘故随增亦相应故者。谓见灭所断有漏缘随眠。非所缘故随增非相应故者。谓见灭所断邪见疑及彼相应无明。若见苦集所断非遍行。若见道修所断一切随眠。于彼相应法亦尔。于彼等起心不相应行见灭所断有漏缘及遍行随眠。所缘故随增非相应故。诸余随眠。于彼非所缘故随增非相应故。见道所断心亦尔。如不定系欲界系色界系无色界系亦尔

有三十六随眠。谓见苦所断十。见集所断七。见灭所断七。见道所断八。修所断四。见苦所断十随眠云何。谓有身见。边执见。见苦所断邪见见取戒禁取疑贪嗔慢无明。见集所断七随眠云何。谓见集所断邪见见取疑贪嗔慢无明。见灭所断七随眠云何。谓见灭所断邪见见取疑贪嗔慢无明。见道所断八随眠云何。谓见道所断邪见见取戒禁取疑贪嗔慢无明。修所断四随眠云何。谓修所断贪嗔慢无明。于有身见。几随眠随增。答见苦所断一切。及见集所断遍行随眠。于彼相应法及彼等起心不相应行亦尔。如有身见。边执见见苦所断邪见见取戒禁取疑贪嗔慢无明亦尔。于见集所断邪见。几随眠随增。答见集所断一切。及见苦所断遍行随眠。于彼相应法及彼等起心不相应行亦尔。如见集所断邪见。见取疑贪嗔慢无明亦尔。于见灭所断邪见。几随眠随增。答见灭所断邪见相应无明。及见灭所断有漏缘。并遍行随眠。于彼相应法见灭所断邪见。及彼相应无明。若见灭所断有漏缘。若遍行随眠。于彼等起心不相应行。见灭所断有漏缘。及遍行随眠。见灭所断疑亦尔。于见灭所断见取。几随眠随增。答见灭所断有漏缘。及遍行随眠。于彼相应法。及彼等起心不相应行亦尔。见灭所断贪嗔慢亦尔。于见灭所断无明。几随眠随增。答除见灭所断无漏缘无明。诸余见灭所断一切及遍行随眠。于彼相应法。见灭所断一切及遍行随眠。于彼等起心不相应行。见灭所断有漏缘及遍行随眠。见道所断亦尔。于修所断贪。几随眠随增。答修所断一切及遍行随眠。于彼相应法及彼等起心不相应行亦尔。修所断嗔慢无明亦尔

于有身见。几随眠所缘故随增非相应故。几随眠相应故随增非所缘故。几随眠所缘故随增亦相应故。几随眠非所缘故随增非相应故。答所缘故随增非相应故者。谓除有身见相应无明。诸余见苦所断一切。及见集所断遍行随眠。相应故随增非所缘故者无。所缘故随增亦相应故者。谓有身见相应无明。非所缘故随增非相应故者。谓见集所断非遍行。及见灭道修所断一切随眠。于彼相应法。所缘故随增非相应故者。谓除有身见及彼相应无明。诸余见苦所断一切。及见集所断遍行随眠。相应故随增非所缘故者无。所缘故随增亦相应故者。谓有身见及彼相应无明。非所缘故随增非相应故者。谓见集所断非遍行。及见灭道修所断一切随眠。于彼等起心不相应行。见苦所断一切。及见集所断遍行随眠。所缘故随增非相应故。诸余随眠。于彼非所缘故随增非相应故。如有身见。边执见见苦所断邪见见取戒禁取疑贪嗔慢亦尔。于见苦所断无明。几随眠所缘。故随增非相应故。几随眠相应故随增非所缘故。几随眠所缘故随增亦相应故。几随眠非所缘故随增非相应故。答所缘故随增非相应故者。谓见苦所断无明。及见集所断遍行随眠。相应故随增非所缘故者无。所缘故随增亦相应故者。谓除见苦所断无明。诸余见苦所断一切随眠。非所缘故随增非相应故者。谓见集所断非遍行。及见灭道修所断一切随眠。于彼相应法。所缘故随增非相应故者。谓见集所断遍行随眠。相应故随增非所缘故者无。所缘故随增亦相应故者。谓见苦所断一切随眠。非所缘故随增非相应故者。谓见集所断非遍行。及见灭道修所断一切随眠。于彼等起心不相应行见苦所断一切。及见集所断遍行随眠。所缘故随增非相应故。诸余随眠。于彼非所缘故随增非相应故。于见集所断邪见。几随眠所缘故随增非相应故。几随眠相应故随增非所缘故。几随眠所缘故随增亦相应故。几随眠非所缘故随增非相应故。答所缘故随增非相应故者。谓除见集所断邪见相应无明。诸余见集所断一切及见苦所断遍行随眠。相应故随增非所缘故者无。所缘故随增亦相应故者。谓见集所断邪见相应无明。非所缘故随增非相应故者。谓见苦所断非遍行。及见灭道修所断一切随眠。于彼相应法。所缘故随增非相应故者。谓除见集所断邪见及彼相应无明。诸余见集所断一切。及见苦所断遍行随眠。相应故随增非所缘故者无。所缘故随增亦相应故者。谓见集所断邪见及彼相应无明。非所缘故随增非相应故者。谓见苦所断非遍行。及见灭道修所断一切随眠。于彼等起心不相应行。见集所断一切及见苦所断遍行随眠。所缘故随增非相应故。诸余随眠。于彼非所缘故随增非相应故。如见集所断邪见。见取疑贪嗔慢亦尔。于见集所断无明。几随眠所缘故随增非相应故。几随眠相应故随增非所缘故。几随眠所缘故随增亦相应故。几随眠非所缘故随增非相应故。答所缘故随增非相应故者。谓见集所断无明。及见苦所断遍行随眠。相应故随增非所缘故者无。所缘故随增亦相应故者。谓除见集所断无明。诸余见集所断一切随眠。非所缘故随增非相应故者。谓见苦所断非遍行。及见灭道修所断一切随眠。于彼相应法。所缘故随增非相应故者。谓见苦所断遍行随眠。相应故随增非所缘故者无。所缘故随增亦相应故者。谓见集所断一切随眠。非所缘故随增非相应故者。谓见苦所断非遍行。及见灭道修所断一切随眠。于彼等起心不相应行见集所断一切。及见苦所断遍行随眠。所缘故随增非相应故。诸余随眠。于彼非所缘故随增非相应故。于见灭所断邪见。几随眠所缘故随增非相应故。几随眠相应故随增非所缘故。几随眠所缘故随增亦相应故。几随眠非所缘故随增非相应故。答所缘故随增非相应故者。谓见灭所断有漏缘。及遍行随眠。相应故随增非所缘故者。谓见灭所断邪见相应无明。所缘故随增亦相应故者无。非所缘故随增非相应故者。谓除见灭所断邪见相应无明。诸余见灭所断无漏缘。及见苦集所断非遍行。并见道修所断一切随眠。于彼相应法。所缘故随增非相应故者。谓见灭所断有漏缘。及遍行随眠。相应故随增非所缘故者。谓见灭所断邪见。及彼相应无明。所缘故随增亦相应故者无。非所缘故随增非相应故者。谓除见灭所断邪见。及彼相应无明。诸余见灭所断无漏缘。及见苦集所断非遍行。并见道修所断一切随眠。于彼等起心不相应行见灭所断有漏缘。及遍行随眠。所缘故随增非相应故。诸余随眠。于彼非所缘故随增非相应故。见灭所断疑亦尔。于见灭所断见取。几随眠所缘故随增非相应故。几随眠相应故随增非所缘故。几随眠所缘故随增亦相应故。几随眠非所缘故随增非相应故。答所缘故随增非相应故者。谓除见灭所断见取相应无明。诸余见灭所断有漏缘。及遍行随眠。相应故随增非所缘故者无。所缘故随增亦相应故者。谓见灭所断见取相应无明。非所缘故随增非相应故者。谓见灭所断无漏缘。及见苦集所断非遍行。并见道修所断一切随眠。于彼相应法。所缘故随增非相应故者。谓除见灭所断见取及彼相应无明。诸余见灭所断有漏缘。及遍行随眠。相应故随增非所缘故者无。所缘故随增亦相应故者。谓见灭所断见取。及彼相应无明。非所缘故随增非相应故者。谓见灭所断无漏缘。及见苦集所断非遍行。并见道修所断一切随眠。于彼等起心不相应行。见灭所断有漏缘。及遍行随眠。所缘故随增非相应故。诸余随眠。于彼非所缘故随增非相应故。见灭所断贪嗔慢亦尔

说一切有部品类足论卷第四阿毗达磨品类足论卷第五

        尊者世友造

        三藏法师玄奘奉　诏译

    辩随眠品第五之余

于见灭所断无明。几随眠所缘故随增非相应故。几随眠相应故随增非所缘故。几随眠所缘故随增亦相应故。几随眠非所缘故随增非相应故。答所缘故随增非相应故者。谓见灭所断有漏缘无明。及遍行随眠。相应故随增非所缘故者。谓除见灭所断无漏缘无明。诸余见灭所断无漏缘随眠。所缘故随增亦相应故者。谓除见灭所断有漏缘无明。诸余见灭所断有漏缘随眠。非所缘故随增亦非相应故者。谓见灭所断无漏缘无明。及见苦集所断非遍行。并见道修所断一切随眠。于彼相应法。所缘故随增非相应故者。谓遍行随眠。相应故随增非所缘故者。谓见灭所断无漏缘随眠。所缘故随增亦相应故者。谓见灭所断有漏缘随眠。非所缘故随增非相应故者。谓见苦集所断非遍行。及见道修所断一切随眠。于彼等起心不相应行。见灭所断有漏缘。及遍行随眠所缘故随增非相应故。诸余随眠。于彼非所缘故随增非相应故。见道所断亦尔。于修所断贪。几随眠所缘故随增非相应故。几随眠相应故随增非所缘故。几随眠所缘故随增亦相应故。几随眠非所缘故随增非相应故。答所缘故随增非相应故者。谓除修所断贪相应无明。诸余修所断一切及遍行随眠。相应故随增非所缘故者无。所缘故随增亦相应故者。谓修所断贪相应无明。非所缘故随增非相应故者。谓见苦集所断非遍行。及见灭道所断一切随眠。于彼相应法。所缘故随增非相应故者。谓除修所断贪。及彼相应无明。诸余修所断一切。及遍行随眠。相应故随增非所缘故者无。所缘故随增亦相应故者。谓修所断贪。及彼相应无明。非所缘故随增非相应故者。谓见苦集所断非遍行。及见灭道所断一切随眠。于彼等起心不相应行修所断一切。及遍行随眠。所缘故随增非相应故。诸余随眠。于彼非所缘故随增非相应故。修所断嗔慢亦尔。于修所断无明。几随眠所缘故随增非相应故。几随眠相应故随增非所缘故。几随眠所缘故随增亦相应故。几随眠非所缘故随增非相应故。答所缘故随增非相应故者。谓修所断无明及遍行随眠。相应故随增非所缘故者无。所缘故随增亦相应故者。谓除修所断无明。诸余修所断一切随眠。非所缘故随增亦非相应故者。谓见苦集所断非遍行。及见灭道所断一切随眠于彼相应法。所缘故随增非相应故者。谓遍行随眠。相应故随增非所缘故者无。所缘故随增亦相应故者。谓修所断一切随眠。非所缘故随增非相应故者。谓见苦集所断非遍行。及见灭道所断一切随眠。于彼等起心不相应行修所断一切及遍行随眠。所缘故随增非相应故。诸余随眠于彼非所缘故随增非相应故

有四十八无明。谓见灭所断邪见相应无明。见灭所断疑相应无明。见灭所断邪见疑相应无明见灭所断邪见不相应无明。见灭所断疑不相应无明。见灭所断邪见疑不相应无明。见道所断亦尔。如不定系欲界系色界系无色界系亦尔。于见灭所断邪见相应无明。几随眠随增。答见灭所断邪见。及见灭所断有漏缘。并遍行随眠。于彼相应法见灭所断邪见及彼相应无明。若见灭所断有漏缘。若遍行随眠。于彼等起心不相应行。见灭所断有漏缘。及遍行随眠。于见灭所断疑相应无明。几随眠随增。答见灭所断疑。及见灭所断有漏缘。并遍行随眠。于彼相应法见灭所断疑。及彼相应无明。若见灭所断有漏缘。若遍行随眠。于彼等起心不相应行见灭所断有漏缘及遍行随眠。于见灭所断邪见疑相应无明。几随眠随增。答见灭所断邪见疑。及见灭所断有漏缘。并遍行随眠。于彼相应法见灭所断邪见疑及彼相应无明。若见灭所断有漏缘若遍行随眠。于彼等起心不相应行。见灭所断有漏缘及遍行随眠。于见灭所断邪见不相应无明。几随眠随增。答见灭所断疑。及见灭所断有漏缘。并遍行随眠。于彼相应法。除见灭所断邪见及彼相应无明。诸余见灭所断一切及遍行随眠。于彼等起心不相应行。见灭所断有漏缘及遍行随眠。于见灭所断疑不相应无明。几随眠随增。答见灭所断邪见及见灭所断有漏缘。并遍行随眠。于彼相应法。除见灭所断疑及彼相应无明。诸余见灭所断一切及遍行随眠。于彼等起心不相应行。见灭所断有漏缘及遍行随眠。于见灭所断邪见疑不相应无明。几随眠随增。答见灭所断有漏缘及遍行随眠。于彼相应法。除见灭所断邪见疑及彼相应无明。诸余见灭所断一切及遍行随眠。于彼等起心不相应行。见灭所断有漏缘及遍行随眠。见道所断亦尔。如不定系欲界系色界系无色界系亦尔

于见灭所断邪见相应无明。几随眠所缘故随增非相应故。几随眠相应故随增非所缘故。几随眠所缘故随增亦相应故。几随眠非所缘故随增非相应故。答所缘故随增非相应故者。谓见灭所断有漏缘。及遍行随眠。相应故随增非所缘故者。谓见灭所断邪见。所缘故随增亦相应故者无。非所缘故随增非相应故者。谓除见灭所断邪见诸余见灭所断无漏缘。及见苦集所断非遍行。并见道修所断一切随眠。于彼相应法。所缘故随增非相应故者。谓见灭所断有漏缘。及遍行随眠。相应故随增非所缘故者。谓见灭所断邪见及彼相应无明。所缘故随增亦相应故者无。非所缘故随增非相应故者。谓除见灭所断邪见及彼相应无明。诸余见灭所断无漏缘。及见苦集所断非遍行。并见道修所断一切随眠。于彼等起心不相应行见灭所断有漏缘及遍行随眠。所缘故随增非相应故。诸余随眠。于彼非所缘故随增非相应故。于见灭所断疑相应无明。几随眠所缘故随增非相应故。几随眠相应故随增非所缘故。几随眠所缘故随增亦相应故。几随眠非所缘故随增非相应故。答所缘故随增非相应故者。谓见灭所断有漏缘。及遍行随眠相应故随增非所缘故者。谓见灭所断疑。所缘故随增亦相应故者无。非所缘故随增非相应故者。谓除见灭所断疑。诸余见灭所断无漏缘。及见苦集所断非遍行。并见道修所断一切随眠。于彼相应法。所缘故随增非相应故者。谓见灭所断有漏缘。及遍行随眠。相应故随增非所缘故者。谓见灭所断疑。及彼相应无明。所缘故随增亦相应故者无。非所缘故随增非相应故者。谓除见灭所断疑及彼相应无明。诸余见灭所断无漏缘。及见苦集所断非遍行。并见道修所断一切随眠。于彼等起心不相应行。见灭所断有漏缘。及遍行随眠。所缘故随增非相应故。诸余随眠。于彼非所缘故随增非相应故。于见灭所断邪见疑相应无明。几随眠所缘故随增非相应故。几随眠相应故随增非所缘故。几随眠所缘故随增亦相应故。几随眠非所缘故随增非相应故。答所缘故随增非相应故者。谓见灭所断有漏缘。及遍行随眠。相应故随增非所缘故者。谓见灭所断邪见疑。所缘故随增亦相应故者无。非所缘故随增非相应故者。谓除见灭所断邪见疑。诸余见灭所断无漏缘。及见苦集所断非遍行。并见道修所断一切随眠。于彼相应法。所缘故随增非相应故者。谓见灭所断有漏缘。及遍行随眠。相应故随增非所缘故者。谓见灭所断邪见疑。及彼相应无明。所缘故随增亦相应故者无。非所缘故随增非相应故者。谓除见灭所断邪见疑及彼相应无明。诸余见灭所断无漏缘。及见苦集所断非遍行。并见道修所断一切随眠。于彼等起心不相应行见灭所断有漏缘及遍行随眠。所缘故随增非相应故。诸余随眠。于彼非所缘故随增非相应故。于见灭所断邪见不相应无明。几随眠所缘故随增非相应故。几随眠相应故随增非所缘故。几随眠所缘故随增亦相应故。几随眠非所缘故随增非相应故。答所缘故随增非相应故者。谓见灭所断有漏缘无明。及遍行随眠。相应故随增非所缘故者。谓见灭所断疑。所缘故随增亦相应故者。谓除见灭所断有漏缘无明。诸余见灭所断有漏缘随眠。非所缘故随增非相应故者。谓除见灭所断疑。诸余见灭所断无漏缘。及见苦集所断非遍行。并见道修所断一切随眠。于彼相应法。所缘故随增非相应故者。谓遍行随眠。相应故随增非所缘故者。谓除见灭所断邪见及彼相应无明。诸余见灭所断无漏缘随眠。所缘故随增亦相应故者。谓见灭所断有漏缘随眠。非所缘故随增非相应故者。谓见灭所断邪见。及彼相应无明。若见苦集所断非遍行。若见道修所断一切随眠。于彼等起心不相应行见灭所断有漏缘。及遍行随眠。所缘故随增非相应故。诸余随眠。于彼非所缘故随增非相应故。于见灭所断疑不相应无明。几随眠所缘故随增非相应故。几随眠相应故随增非所缘故。几随眠所缘故随增亦相应故。几随眠非所缘故随增非相应故。答所缘故。随增非相应故者。谓见灭所断有漏缘无明。及遍行随眠。相应故随增非所缘故者。谓见灭所断邪见。所缘故随增亦相应故者。谓除见灭所断有漏缘无明。诸余见灭所断有漏缘随眠。非所缘故随增非相应故者。谓除见灭所断邪见。诸余见灭所断无漏缘。及见苦集所断非遍行。并见道修所断一切随眠。于彼相应法。所缘故随增非相应故者。谓遍行随眠。相应故随增非所缘故者。谓除见灭所断疑及彼相应无明。诸余见灭所断无漏缘随眠。所缘故随增亦相应故者。谓见灭所断有漏缘随眠。非所缘故随增非相应故者。谓见灭所断疑。及彼相应无明。若见苦集所断非遍行。若见道修所断一切随眠。于彼等起心不相应行见灭所断有漏缘。及遍行随眠。所缘故随增非相应故。诸余随眠。于彼非所缘故随增非相应故。于见灭所断邪见疑不相应无明。几随眠所缘故随增非相应故。几随眠相应故随增非所缘故。几随眠所缘故随增亦相应故。几随眠非所缘故随增非相应故。答所缘故随增非相应故者。谓见灭所断有漏缘无明。及遍行随眠。相应故随增非所缘故者无。所缘故随增亦相应故者。谓除见灭所断有漏缘无明。诸余见灭所断有漏缘随眠。非所缘故随增非相应故者。谓见灭所断无漏缘。及见苦集所断非遍行。并见道修所断一切随眠。于彼相应法。所缘故随增非相应故者。谓遍行随眠。相应故随增非所缘故者。谓除见灭所断邪见疑及彼相应无明。诸余见灭所断无漏缘随眠。所缘故随增亦相应故者。谓见灭所断有漏缘随眠。非所缘故随增非相应故者。谓见灭所断邪见疑。及彼相应无明。若见苦集所断非遍行。若见道修所断一切随眠。于彼等起心不相应行。见灭所断有漏缘。及遍行随眠。所缘故随增非相应故。诸余随眠。于彼非所缘故随增非相应故。见道所断亦尔。如不定系欲界系色界系无色界系亦尔。诸随眠有漏缘。彼随眠所缘相应故随增耶。答若随眠所缘相应故随增。彼随眠有漏缘。有随眠有漏缘彼随眠非所缘相应故随增。谓缘异界地遍行随眠。此复云何。谓诸随眠欲界系。缘色界系。若诸随眠欲界系。缘无色界系。若诸随眠色界系。缘无色界系。若诸随眠欲界系。缘色无色界系。异地缘亦尔。诸随眠无漏缘。彼随眠相应故随增耶。答若随眠无漏缘。彼随眠相应故随增。有随眠相应故随增彼随眠非无漏缘。谓缘异界地遍行随眠。此复云何。谓诸随眠欲界系。缘色界系。若诸随眠欲界系。缘无色界系。若诸随眠色界系。缘无色界系。若诸随眠欲界系。缘色无色界系。异地缘亦尔

    品类足论辩摄等品第六之一

有所知法。所识法。所通达法。所缘法。增上法。有色法无色法。有见法。无见法。有对法。无对法。有漏法。无漏法。有为法。无为法。有诤法。无诤法。世间法。出世间法。堕界法。不堕界法。有味着法。无味着法。耽嗜依法。出离依法。心法。非心法。心所法。非心所法。心相应法。心不相应法。心俱有法。非心俱有法。随心转法。非随心转法。心为因法。非心为因法。心为等无间法。非心为等无间法。心为所缘法。非心为所缘法。心为增上法。非心为增上法。心果法。非心果法。心异熟法。非心异熟法。业法。非业法。业相应法。业不相应法。业俱有法。非业俱有法。随业转法。非随业转法。业为因法。非业为因法。业为等无间法。非业为等无间法。业为所缘法。非业为所缘法。业为增上法。非业为增上法。业果法。非业果法。业异熟法。非业异熟法。有法。非有法。有相应法。有不相应法。有俱有法。非有俱有法。随有转法。非随有转法。有为因法。非有为因法。有为等无间法。非有为等无间法。有为所缘法。非有为所缘法。有为增上法。非有为增上法。有果法。非有果法。有异熟法。非有异熟法。所遍知法。非所遍知法。所应断法。非所应断法。所应修法。非所应修法。所应证法。非所应证法。所应习法。非所应习法。有罪法。无罪法。黑法。白法。有覆法。无覆法。顺退法。非顺退法。有记法。无记法。已生法。非已生法。正生法。非正生法。已灭法。非已灭法。正灭法。非正灭法。缘起法。非缘起法。缘已生法。非缘已生法。因法。非因法。有因法。非有因法。因已生法。非因已生法。因相应法。因不相应法。结法。非结法。顺结法。非顺结法。取法。非取法。有执受法。无执受法。顺取法。非顺取法。烦恼法。非烦恼法。染污法。不染污法。杂染法。非杂染法。缠法。非缠法。所缠法。非所缠法。顺缠法。非顺缠法。有所缘法。无所缘法。有寻法。无寻法。有伺法。无伺法。有喜法。无喜法。有警觉法。无警觉法。有事法。无事法。有缘法。无缘法。有上法。无上法。远法。近法。有量法。无量法。见法。非见法。见处法。非见处法。见相应法。见不相应法。异生法法。非异生法法。共异生法。不共异生法。定法。非定法。顺热恼法。非顺热恼法。根法。非根法。圣谛所摄法。非圣谛所摄法。俱有法。非俱有法。相应法。不相应法。果法。非果法。有果法。无果法。异熟法。非异熟法。有异熟法。无异熟法。因缘法。非因缘法。有因缘法。无因缘法。离法。非离法。有离法。无离法。相续法。非相续法。有相续法。无相续法。有三法。谓善法。不善法。无记法。学法。无学法。非学非无学法。见所断法。修所断法。非所断法。见所断为因法。修所断为因法。非所断为因法。有见有对法。无见有对法。无见无对法。异熟法。异熟法法。非异熟非异熟法法。劣法中法妙法。小法大法无量法。可意法。不可意法。非可意非不可意法。乐俱行法。苦俱行法。不苦不乐俱行法。俱生法。俱住法。俱灭法。非俱生法。非俱住法。非俱灭法。心俱生法。心俱住法。心俱灭法。非心俱生法。非心俱住法。非心俱灭法。有三界。谓欲界恚界害界。复有三界。谓出离界无恚界无害界。复有三界。谓欲界色界无色界。复有三界。谓色界无色界灭界。有三有。谓欲有色有无色有。有三漏。谓欲漏有漏无明漏。有三世。谓过去世未来世现在世。有三言依事。谓过去言依事。未来言依事。现在言依事。有三苦性。谓苦苦性坏苦性行苦性。有三法。谓有寻有伺法。无寻唯伺法。无寻无伺法。有三地。谓有寻有伺地。无寻唯伺地。无寻无伺地。有三业。谓身业语业意业。复有三业。谓善业不善业。无记业。复有三业。谓学业无学业非学非无学业。复有三业。谓见所断业。修所断业。非所断业。复有三业。谓顺现法受业。顺次生受业。顺后次受业。复有三业。谓顺乐受业。顺苦受业。顺不苦不乐受业

有四念住。谓身念住。受念住。心念住。法念住。有四正断。谓为令已生恶不善法得永断故。勤修正断。为令未生恶不善法永不生故。勤修正断。为令未生善法生故。勤修正断。为令已生善法坚住不忘修满倍复增广智作证故。勤修正断。有四神足。谓欲三摩地断行成就神足。勤三摩地断行成就神足。心三摩地断行成就神足。观三摩地断行成就神足。有四静虑。谓初静虑。第二静虑。第三静虑。第四静虑。有四圣谛。谓苦圣谛。集圣谛。灭圣谛。道圣谛。有四无量。谓慈无量。悲无量。喜无量。舍无量。有四无色。谓空无边处。识无边处。无所有处。非想非非想处。有四圣种。谓随所得衣喜足圣种。随所得食喜足圣种。随所得卧具喜足圣种。乐断乐修圣种。有四沙门果。谓预流果一来果不还果阿罗汉果。有四智。谓法智类智他心智世俗智。复有四智。谓苦智集智灭智道智。有四无碍解。谓法无碍解。义无碍解。词无碍解。辩无碍解。有四缘。谓因缘。等无间缘。所缘缘。增上缘。有四食。谓段食若粗若细。触食意思食识食。有四瀑流。谓欲瀑流。有瀑流。见瀑流。无明瀑流。有四轭。谓欲轭有轭见轭无明轭。有四取。谓欲取见取戒禁取我语取。有四法。谓过去法未来法现在法。非过去非未来非现在法。复有四法。谓欲界系法。色界系法。无色界系法。不系法。复有四法。谓善为因法。不善为因法。无记为因法。非善为因非不善为因非无记为因法。复有四法。谓缘有所缘法。缘无所缘法。缘有所缘缘无所缘法。非缘有所缘非缘无所缘法

有五蕴。谓色蕴受蕴想蕴行蕴识蕴。有五取蕴。谓色取蕴受取蕴想取蕴行取蕴识取蕴。有五趣。谓捺落迦趣傍生趣鬼趣人趣天趣。有五烦恼部。谓见苦所断烦恼部。见集所断烦恼部。见灭所断烦恼部。见道所断烦恼部。修所断烦恼部。有五法。谓色法心法心所法。心不相应行法。无为法。有六界。谓地界水界火界风界空界识界。有六法。谓见苦所断法。见集所断法。见灭所断法。见道所断法。修所断法。非所断法。有七随眠。谓欲贪随眠。嗔随眠。有贪随眠。慢随眠。无明随眠。见随眠。疑随眠。有七识住。谓有色有情身异想异。如人一分天。是初识住。有色有情身异想一。如梵众天劫初时。是第二识住。有色有情身一想异。如极光净天。是第三识住。有色有情身一想一。如遍净天。是第四识住。无色有情超一切色想。灭有对想不思惟种种想入无边空。空无边处具足住。如空无边处天。是第五识住。无色有情超一切空无边处入无边识。识无边处具足住。如识无边处天。是第六识住。无色有情超一切识无边处入无所有。无所有处具足住。如无所有处天。是第七识住。有七觉支。谓念等觉支。择法等觉支。精进等觉支。喜等觉支。轻安等觉支。定等觉支。舍等觉支。有八解脱。谓有色观诸色。是初解脱。内无色想观外色。是第二解脱。净解脱身作证具足住。是第三解脱。超一切色想灭有对想不思惟种种想。入无边空。空无边处具足住。是第四解脱。超一切空无边处入无边识。识无边处具足住。是第五解脱。超一切识无边处入无所有。无所有处具足住。是第六解脱。超一切无所有处入非想非非想处具足住。是第七解脱。超一切非想非非想处。入想受灭身作证具足住。是第八解脱。有八胜处。谓内有色想观外色少。若好显色。若恶显色。于彼诸色胜知胜见。具如是想是初胜处。内有色想观外色多。若好显色。若恶显色。于彼诸色胜知胜见。具如是想是第二胜处。内无色想观外色少。若好显色若恶显色。于彼诸色胜知胜见。具如是想是第三胜处。内无色想观外色多。若好显色。若恶显色。于彼诸色胜知胜见。具如是想是第四胜处。内无色想观外诸色。若青青显青现青光。犹如乌莫迦华。或如婆罗痆斯深染青衣。若青青显青现青光。内无色想观外诸色。若青青显青现青光。亦复如是。于彼诸色胜知胜见。具如是想是第五胜处。内无色想观外诸色。若黄黄显黄现黄光。犹如羯尼迦花。或如婆罗痆斯深染黄衣。若黄黄显黄现黄光。内无色想观外诸色。若黄黄显黄现黄光。亦复如是。于彼诸色胜知胜见。具如是想是第六胜处。内无色想观外诸色。若赤赤显赤现赤光。犹如槃豆时缚迦花。或如婆罗痆斯深染赤衣。若赤赤显赤现赤光。内无色想观外诸色。若赤赤显赤现赤光。亦复如是。于彼诸色胜知胜见。具如是想是第七胜处。内无色想观外诸色。若白白显白现白光。犹如乌杀斯星。或如婆罗痆斯极鲜白衣。若白白显白现白光。内无色想观外诸色。若白白显白现白光。亦复如是。于彼诸色胜知胜见。具如是想是第八胜处。有八圣道支。谓正见正思惟正语正业正命正精进正念正定

说一切有部品类足论卷第五阿毗达磨品类足论卷第六

        尊者世友造

        三藏法师玄奘奉　诏译

    辩摄等品第六之二

有九结。谓爱结恚结慢结无明结见结取结疑结嫉结悭结。有九有情居。谓有色有情身异想异。如人及一分天。是初有情居。有色有情身异想一。如梵众天劫初时。是第二有情居。有色有情身一想异。如极光净天。是第三有情居。有色有情身一想一。如遍净天。是第四有情居。有色有情无想无异想。如无想有情天。是第五有情居。无色有情超一切色想。灭有对想。不思惟种种想入无边空。空无边处具足住。如空无边处天。是第六有情居。无色有情超一切空无边处。入无边识。识无边处具足住。如识无边处天。是第七有情居。无色有情超一切识无边处入无所有。无所有处具足住。如无所有处天。是第八有情居。无色有情超一切无所有处入非想非非想处具足住。如非想非非想处天。是第九有情居。有十遍处。谓地遍满一类想。上下傍布无二无量。是初遍处。水遍满一类想。上下傍布无二无量。是第二遍处。火遍满一类想。上下傍布无二无量。是第三遍处。风遍满一类想。上下傍布无二无量。是第四遍处。青遍满一类想。上下傍布无二无量。是第五遍处。黄遍满一类想。上下傍布无二无量。是第六遍处。赤遍满一类想。上下傍布无二无量。是第七遍处。白遍满一类想。上下傍布无二无量。是第八遍处。空遍满一类想。上下傍布无二无量。是第九遍处。识遍满一类想。上下傍布无二无量。是第十遍处。有十无学法。谓无学正见正思惟正语正业正命正精进正念正定正胜解正智

有十一法。谓有漏色。无漏色。有漏受。无漏受。有漏想。无漏想。有漏行。无漏行。有漏识。无漏识。及无为法。有十二处。谓眼处色处耳处声处鼻处香处舌处味处身处触处意处法处。有十八界。谓眼界色界眼识界。耳界声界耳识界。鼻界香界鼻识界。舌界味界舌识界。身界触界身识界。意界法界意识界。有二十二根。谓眼根耳根鼻根舌根身根。女根男根命根意根。乐根苦根喜根忧根舍根。信根精进根念根定根慧根。未知当知根已知根具知根。有九十八随眠。谓欲界系三十六。色界系三十一。无色界系三十一如前说

所知法云何。谓一切法是智所知随其事。此复云何。谓苦智知苦。集智知集。灭智知灭。道智知道。复有善世俗智。知苦集灭道及虚空非择灭。故说一切法是智所知随其事。是名所知法。所识法云何。谓一切法是识所识随其事。此复云何。谓眼识识色。耳识识声。鼻识识香。舌识识味。身识识触。意识识法。眼色眼识。耳声耳识。鼻香鼻识。舌味舌识。身触身识。意法意识。故说一切法是识所识。随其事是名所识法。所通达法云何。通达者。谓善慧。此以一切法。为所通达。随其事。此复云何。谓苦忍苦智通达苦。集忍集智通达集。灭忍灭智通达灭。道忍道智通达道。复有善有漏慧。通达苦集灭道及虚空非择灭。故说通达者谓善慧。此以一切法为所通达。随其事是名所通达法。所缘法云何。谓一切法是心心所法所缘。随其事。此复云何。谓眼识及相应法缘色。耳识及相应法缘声。鼻识及相应法缘香。舌识及相应法缘味。身识及相应法缘触。意识及相应法缘法。眼色眼识。耳声耳识。鼻香鼻识。舌味舌识。身触身识。意法意识。故说一切法是心心所法所缘。随其事是名所缘法。增上法云何。谓一切有为法互为增上。复有无为法与有为法为增上。是名增上法

有色法云何。谓十处一处少分。无色法云何。谓一处一处少分。有见法云何。谓一处无见法云何。谓十一处。有对法云何。谓十处。无对法云何。谓二处。有漏法云何。谓十处二处少分。无漏法云何。谓二处少分。有为法云何。谓十一处一处少分。无为法云何。谓一处少分。有诤法云何。谓十处二处少分。无诤法云何。谓二处少分。世间出世间法。堕界不堕界法。有味着无味着法。耽嗜依出离依法亦尔。心法云何。谓一处。非心法云何。谓十一处。心所法云何。谓若法与心相应。此复云何。谓受蕴想蕴相应行蕴。非心所法云何。谓若法心不相应。此复云何。谓色心心不相应行。无为心相应法云何。谓心所法。此复云何。谓受蕴想蕴相应行蕴。心不相应法云何。谓非心所法。此复云何。谓色心心不相应行无为。心俱有法云何。谓心俱有十一处少分。除意处。非心俱有法云何。谓意处。及非心俱有十一处少分。随心转法云何。谓若法与心。一生一住一灭。此复云何。谓一切心所法。及道俱有定俱有戒。若心若彼法。生老住无常。是名随心转法。非随心转法云何。谓若法不与心一生一住一灭。此复云何。谓除随心转身语业。诸余色法。除随心转心不相应行。诸余心不相应行。及心无为。是名非随心转法。心为因法云何。谓除已入正性离生补特伽罗初无漏心。诸余心。及除诸余异生定当入正性离生者未来初无漏心。诸余心。及心为因十一处少分。是名心为因法。非心为因法云何。谓已入正性离生补特伽罗初无漏心。及诸余异生定当入正性离生者未来初无漏心。并心为因十一处少分。是名非心为因法。心为等无间法云何。谓心为等无间。心心所法。若已生若正生。及无想定灭定。若已生若正生。是名心为等无间法。非心为等无间法云何。谓除心为等无间心心所法。诸余心心所法。及除心为等无间心不相应行。诸余心不相应行。并色无为。是名非心为等无间法。心为所缘法云何。谓若意识及相应法。以心为所缘。是名心为所缘法。非心为所缘法云何。谓除心为所缘意识及相应法。诸余意识及相应法。若五识身及相应法。若色无为心不相应行。是名非心为所缘法。心为增上法云何。谓有为法。以心为增上。是名心为增上法。非心为增上法云何。谓无为法。心果法云何。谓一切有为法及择灭。非心果法云何。谓虚空非择灭。心异熟法云何。心异熟十一处少分。除声处。非心异熟法云何。谓声处及非心异熟十一处少分

业法云何。谓身语业及思。非业法云何。谓除身语业。诸余色。除思诸余行蕴。及三蕴全并无为法。业相应法云何。谓若法与思相应。此复云何。谓一切心心所法。除思。业不相应法云何。谓若法思不相应。此复云何。谓色及思。心不相应行无为。业俱有法云何。谓意处及业俱有十一处少分。除思。非业俱有法云何。谓思及非业俱有十一处少分。除意处。随业转法云何。谓若法与思。一生一住一灭。此复云何。谓一切心心所法。除思及道俱有定俱有戒。若思若彼法。生老住无常。是名随业转法。非随业转法云何。谓若法不与思一生一住一灭。此复云何。谓除随业转身语业。诸余色。及除随业转心不相应行。诸余心不相应行。思及无为。是名非随业转法。业为因法云何。谓除已入正性离生补特伽罗初无漏思。诸余思。及除诸余异生定当入正性离生者未来初无漏思。诸余思。及意处。并业为因十一处少分。是名业为因法。非业为因法云何谓已入正性离生补特伽罗初无漏思。及诸余异生定当入正性离生者未来初无漏思。及非业为因十一处少分。除意处。是名非业为因法。业为等无间法云何。谓若法心为等无间。非业为等无间法云何。谓若法非心为等无间。业为所缘法云何。谓三识身及相应法。以业为所缘。是名业为所缘法。非业为所缘法云何。谓除业为所缘三识身及相应法。诸余即此三识身及相应法。并余三识身及相应法。若色无为心不相应行。是名非业为所缘法。业为增上法云何。谓有为法。以业为增上。非业为增上法云何。谓无为法。业果法云何。谓一切有为法及择灭。非业果法云何。谓虚空非择灭。业异熟法云何。谓业异熟十一处少分。除声处。非业异熟法云何。谓声处。及非业异熟十一处少分

有法云何。谓有漏法。非有法云何。谓无漏法。有相应法云何。谓有漏心心所法。有不相应法云何。谓无漏心心所法。及色无为心不相应行。有俱有法云何。谓有漏法。及与有漏法俱生诸无漏法。非有俱有法云何。谓除有漏俱生诸无漏法。诸余无漏法。随有转法。及有为因法云何。谓有漏法。非随有转法。及非有为因法云何。谓无漏法。有为等无间法云何。谓有漏心心所法等无间。诸余有漏无漏心心所法。若已生若正生。及无想定灭定。若已生若正生。是名有为等无间法。非有为等无间法云何。谓除有为等无间心心所法。诸余心心所法。及余有为等无间心不相应行。诸余心不相应行。并色无为。是名非有为等无间法。有为所缘法云何。谓五识身及相应法。若意识及相应法。以有为所缘。是名有为所缘法。非有为所缘法云何。谓除以有为所缘意识及相应法。诸余意识。及相应法。并色无为心不相应行。是名非有为所缘法。有为增上法云何。谓有为法。非有为增上法云何。谓无为法。有果法云何。谓有漏法。及世俗道所证结断。非有果法云何。谓除有果无漏法。诸余无漏法。有异熟法云何。谓有异熟十一处少分。除声处。非有异熟法云何。谓声处。及非有异熟十一处少分

所遍知法云何。有二遍知。一智遍知。一断遍知。智遍知所遍知法云何。谓一切法皆是智遍知所应知故。非智遍知所遍知法云何。谓如是法求不可得无法非智所应知故。断遍知所遍知法。即是所应断法。此复云何。谓有漏法。非断遍知所遍知法。即是非所应断法。此复云何。谓无漏法。所应修法云何。谓善有为法。非所应修法云何。谓不善无记法及择灭。所应证法云何。有二作证。一智作证。二得作证。智作证所应证法云何。谓一切法。皆是智作证所应证故。非智作证所应证法云何。谓如是法。求不可得无法非智所应证故。得作证所应证法云何。谓一切善法。及依定所证无覆无记天眼天耳。非得作证所应证法云何。谓除依定所证无覆无记天眼天耳。诸余无记法及一切不善法。所应习法云何。谓善有为法。非所应习法云何。谓不善无记法及择灭。有罪法云何。谓不善及有覆无记法。无罪法云何。谓善及无覆无记法。黑白法有覆无覆法。顺退非顺退法亦尔。有记法云何。谓善不善法。无记法云何。谓除善不善。诸余法。已生法云何。谓过去现在法。非已生法云何。谓未来法及无为。正生法云何。谓若法未来现前正起。非正生法云何。谓除未来现前正起法。诸余未来及过去现在。并无为法。已灭法云何。谓过去法。非已灭法云何。谓未来现在。及无为法。正灭法云何。谓若法现在现前正灭。非正灭法云何。谓除现在现前正灭法。诸余现在及过去未来。并无为法。缘起法云何。谓有为法。非缘起法云何。谓无为法。缘已生非缘已生法。因法非因法。有因法非有因法因已生法非因已生法亦尔。因相应法云何。谓一切心心所法。因不相应法云何。谓色无为心不相应行

结法云何。谓九结。非结法云何。谓除九结诸余法。顺结法云何。谓一切有漏法。非顺结法云何。谓一切无漏法。取法云何。谓四取。非取法云何。谓除四取诸余法。有执受法云何。谓有执受九处少分。除声意法处。无执受法云何。谓声意法处及无执受九处少分。顺取法云何。谓一切有漏法。非顺取法云何。谓一切无漏法。烦恼法云何。谓若法是缠。非烦恼法云何。谓若法非缠。染污法云何。谓不善及有覆无记法。不染污法云何。谓善及无覆无记法。杂染法云何。谓有漏法。非杂染法云何。谓无漏法。缠法云何。谓若法是烦恼。非缠法云何。谓若法非烦恼。所缠法云何。谓染污心心所法。非所缠法云何。谓不染污心心所法。及色无为心不相应行。顺缠法云何。谓有漏法。非顺缠法云何。谓无漏法

有所缘法云何。谓一切心心所法。无所缘法云何。谓色无为心不相应行。有寻法云何。谓寻相应法。无寻法云何。谓寻不相应法。有伺法云何。谓伺相应法。无伺法云何。谓伺不相应法。有喜法云何。谓喜根相应法。无喜法云何。谓喜根不相应法。有警觉法云何。谓作意相应法。无警觉法云何。谓作意不相应法。有事有缘法云何。谓有为法。无事无缘法云何。谓无为法。有上法云何。谓一切有为法及虚空非择灭。无上法云何。谓择灭。远法云何。谓过去未来法。近法云何。谓现在及无为法。有量法云何。谓若法果及异熟俱有量。无量法云何。谓若法果及异熟俱无量。见法云何。谓眼根五染污见。世俗正见。学见无学见。非见法云何。谓除眼根。诸余色蕴。除余八见。诸余行蕴。及三蕴全并无为法。见处法云何。谓有漏法。非见处法云何。谓无漏法。见相应法云何。谓八见相应法。见不相应法云何。谓八见不相应法

异生法法云何。谓地狱傍生鬼界有情。北俱卢洲人。无想有情天诸蕴界处。及生彼业。是名异生法法。非异生法法云何。谓四通行。四无碍解。四沙门果。无诤愿智。边际定。大悲灭定。空空无愿无愿无相无相。杂修静虑。现观边世俗智。净居天蕴界处及生彼业。是名非异生法法。共异生法云何。谓共有定及共有生。此复云何。谓如是定。及如是生。异生圣者俱容得有。是名共异生法。不共异生法云何。谓四通行。四无碍解。四沙门果。无诤愿智。边际定。大悲灭定。空空无愿无愿无相无相。杂修静虑。现观边世俗智。净居天蕴界处。及生彼业。是名不共异生法。定法云何。谓五无间业。及学无学法。非定法云何。谓除五无间业。诸余有漏及无为法。顺热恼法云何。谓不善及有覆无记法。非顺热恼法云何。谓善及无覆无记法。根法云何。谓内六处。及法处所摄根法。非根法云何。谓外五处。及法处所摄非根法。圣谛所摄法云何。谓一切有为法及择灭。非圣谛所摄法云何。谓虚空非择灭

俱有法云何。谓一切有为法。非俱有法云何。谓无为法。相应法云何。谓一切心心所法。不相应法云何。谓色无为心不相应行。果法云何。谓一切有为法。及择灭。非果法云何。谓虚空非择灭。有果法云何。谓一切有为法。无果法云何。谓无为法。异熟法云何。谓异熟十一处少分。除声处。非异熟法云何。谓声处。及非异熟十一处少分。有异熟法云何。谓不善善有漏法。无异熟法云何。谓无记无漏法。因缘法云何。谓一切法。非因缘法云何。谓如是法。求不可得。以一切法是因缘故。有因缘法云何。谓一切有为法。无因缘法云何。谓无为法。离法云何。谓欲界系善戒。色无色界系。出离远离所生善定及学无学法并择灭。非离法云何。谓除欲界系善戒。诸余欲界系法。除色无色界系出离远离所生善定。诸余色无色界系法。及虚空非择灭。有离法云何。谓一切有为。无离法云何。谓无为法。相续法云何。谓若法以灭法为先。或已生或正生。此复云何。谓过去现在。及未来现前正起法。如是后法与前法相续。是名相续法。非相续法云何。谓除未来现前正起法。诸余未来及无为法。是名非相续法。有相续法云何。谓若法以灭法为先而已生。此复云何。谓除过去现在阿罗汉命终时五蕴。诸余过去现在法。如是前法有后相续法。是名有相续法。无相续法云何。谓过去现在阿罗汉命终时五蕴。及未来并无为法

善法云何。谓善五蕴及择灭。不善法云何。谓不善五蕴。无记法云何。谓无记五蕴。及虚空非择灭。学法云何。谓学五蕴。无学法云何。谓无学五蕴。非学非无学法云何。谓有漏五蕴及无为法。见所断法云何。谓若法随信随法行。现观边忍所断。此复云何。谓见所断八十八随眠。及彼相应法。并彼等起心不相应行。修所断法云何。谓若法学见迹修所断。此复云何。谓修所断十随眠。及彼相应法。若彼等起身语业。若彼等起心不相应行。若不染污有漏法。非所断法云何。谓无漏法。见所断为因法云何。谓一切染污法及见所断法异熟。修所断为因法云何。谓唯一切修所断法。非所断为因法云何。谓无漏有为法。有见有对法云何。谓一处。无见有对法云何。谓九处。无见无对法云何。谓二处。异熟法云何。谓异熟十一处少分。除声处。异熟法法云何。谓不善善有漏法。非异熟非异熟法法云何。谓除异熟无记法。诸余无记法及善无漏法。劣法云何。谓不善及有覆无记法。中法云何。谓善有漏及无覆无记法。妙法云何。谓无漏有为法及择灭。小法云何。谓小信小欲小胜解及彼相应法。彼俱有法。若诸色法。少小微细不多不广。是名小法。大法云何。谓大信大欲大胜解。及彼相应法。彼俱有法。若诸色法。虽复多广。而非无边无际无量。若虚空非择灭。是名大法。无量法云何。谓无量信无量欲无量胜解及彼相应法。彼俱有法。若诸色法。多广无边无际无量。若择灭。是名无量法。可意法云何。谓若法意所乐。不可意法云何。谓若法意所不乐。非可意非不可意法云何。谓若法顺舍。乐俱行法云何。谓若法乐受相应。苦俱行法云何。谓若法苦受相应。不苦不乐俱行法云何。谓若法不苦不乐受相应。俱生法云何。谓有为法有生相故。俱住法云何。谓有为法有住相故。俱灭法云何。谓有为法有灭相故。非俱生法云何。谓无为法无生相故。非俱住法云何。谓无为法无住相故。非俱灭法云何。谓无为法无灭相故。心俱生法云何。谓心俱生十一处少分。除意处。心俱住法云何。谓心随转法。心俱灭法云何。谓心俱灭十处少分。除声意处。非心俱生法云何。谓意处及非心俱生十一处少分。非心俱住法云何。谓非心随转法。非心俱灭法云何。谓声意处。及非心俱灭十处少分

欲界云何。谓欲贪及欲贪相应受想行识。若彼等起身语业。若彼等起心不相应行。是名欲界。恚界云何。谓嗔及嗔相应受想行识。若彼等起身语业。若彼等起心不相应行。是名恚界。害界云何。谓害及害相应受想行识。若彼等起身语业。若彼等起心不相应行。是名害界。出离界云何。谓出离及出离相应受想行识。若彼等起身语业。若彼等起心不相应行并择灭。是名出离界。无恚界云何。谓无嗔及无嗔相应受想行识。若彼等起身语业。若彼等起心不相应行。是名无恚界。无害界云何。谓不害及不害相应受想行识。若彼等起身语业。若彼等起心不相应行。是名无害界。欲界云何。谓欲贪随增法。色界云何。谓色贪随增法。无色界云何。谓无色贪随增法。色界云何。谓欲界色界总名色界。无色界云何。谓四无色。灭界云何。谓择灭非择灭。复次一切色法总名色界。除择灭非择灭。诸余非色法。总名无色界。择灭非择灭。总名灭界

欲有云何。谓若业欲界系。取为缘能感当来彼业异熟。是名欲有。色有云何。谓若业色界系。取为缘能感当来彼业异熟。是名色有。无色有云何。谓若业无色界系。取为缘能感当来彼业异熟。是名无色有。欲漏云何。谓除欲界系无明。诸余欲界系。结缚随眠。随烦恼缠。是名欲漏。有漏云何。谓除色无色界系无明。诸余色无色界系。结缚随眠。随烦恼缠。是名有漏。无明漏云何。谓三界无智。过去世云何。谓若诸行已起已等起。已生已等生。已转已现转。已集已现。已谢已尽。已灭已离。已变坏。是过去堕。过去分堕。过去类。过去世摄。是名过去世。未来世云何。谓若诸行未已起未已等起。未已生未已等生。未已转未已现转。未已集未已现。未已和合。未已现前。是未来堕。未来分堕。未来类。未来世摄。是名未来世。现在世云何。谓若诸行已起已等起。已生已等生。已转已现转。已集已现。正安住未变坏。和合现前。是名现在。堕现在分堕现在类。现在世摄。是名现在世。过去言依事云何。谓过去所摄行。未来言依事云何。谓未来所摄行。现在言依事云何。谓现在所摄行。苦苦性云何。谓欲界由苦苦故苦。坏苦性云何。谓色界由坏苦故苦。行苦性云何。谓无色界由行苦故苦。复次不可意诸行。由苦苦故苦。可意诸行。由坏苦故苦。非可意非不可意诸行。由行苦故苦。复次苦受由苦苦故苦。乐受由坏苦故苦。不苦不乐受由行苦故苦。有寻有伺法云何。谓寻伺相应法。无寻唯伺法云何。谓寻不相应伺相应法。无寻无伺法云何。谓寻伺不相应法。有寻有伺地云何。谓欲界梵世。及一分无漏法。无寻唯伺地云何。谓修静虑中间。得梵大梵及一分无漏法。无寻无伺地云何。谓一切极光净。一切遍净。一切广果。一切无色。及一分无漏法

说一切有部品类足论卷第六阿毗达磨品类足论卷第七

        尊者世友造

        三藏法师玄奘奉　诏译

    辩摄等品第六之三

身业云何。谓身表及无表。语业云何。谓语表及无表。意业云何。谓思。善业云何。谓善身语业。及善思。不善业云何。谓不善身语业。及不善思。无记业云何。谓无记身语业。及无记思。学业云何。谓学身语业。及学思。无学业云何。谓无学身语业。及无学思。非学非无学业云何。谓有漏身语业。及有漏思。见所断业云何。谓若业随信随法行。现观边忍所断。此复云何。谓见所断八十八随眠相应思。修所断业云何。谓若业学见迹修所断。此复云何。谓修所断十随眠相应思。及彼等起身语业。并不染污有漏业。非所断业云何。谓无漏身语业。及无漏思。顺现法受业云何。谓若业此生造作增长。彼业即于此生受异熟非余生。是名顺现法受业。顺次生受业云何。谓若业此生造作增长。彼业随第二生受异熟非余生。是名顺次生受业。顺后次受业云何。谓若业此生造作增长。彼业或随第三生。或随第四生。或复过此受异熟非余生。是名顺后次受业。顺乐受业云何。谓欲界系善业及色界系。乃至第三静虑地善业。顺苦受业云何。谓不善业。顺不苦不乐受业云何。谓第四静虑地系善业。及无色界系善业

身念住云何。谓十有色处。及法处所摄色。受念住云何。谓六受身。即眼触所生受。乃至意触所生受。心念住云何。谓六识身。即眼识乃至意识。法念住云何。谓受所不摄非色法处。复次身增上所起善有漏无漏道。是名身念住。受增上所起善有漏无漏道。是名受念住。心增上所起善有漏无漏道。是名心念住。法增上所起善有漏无漏道。是名法念住。复次缘身所起善有漏无漏慧。是名身念住。缘受所起善有漏无漏慧。是名受念住。缘心所起善有漏无漏慧。是名心念住。缘法所起善有漏无漏慧。是名法念住。为令已生恶不善法得永断故勤修正断云何。谓为令已生恶不善法永断。增上所起善有漏无漏道。为令未生恶不善法永不生故勤修正断云何。谓为令未生恶不善法不生。增上所起善有漏无漏道。为令未生善法生故勤修正断云何。谓为令未生善法得生。增上所起善有漏无漏道。为令已生善法坚住不忘修满倍复增广智作证故勤修正断云何。谓为令已生善法坚住不忘修满倍复增广智证。增上所起善有漏无漏道。欲三摩地断行成就神足云何。谓欲增上所起善有漏无漏道。勤三摩地断行成就神足云何。谓勤增上所起善有漏无漏道。心三摩地断行成就神足云何。谓心增上所起善有漏无漏道。观三摩地断行成就神足云何。谓观增上所起善有漏无漏道

初静虑云何。谓初静虑所摄善五蕴。第二静虑云何。谓第二静虑所摄善五蕴。第三静虑云何。谓第三静虑所摄善五蕴。第四静虑云何。谓第四静虑所摄善五蕴。苦圣谛云何。谓五取蕴。集圣谛云何。谓有漏因。灭圣谛云何。谓择灭。道圣谛云何。谓学无学法。慈无量云何。谓慈及慈相应受想行识。若彼等起身语业。若彼等起心不相应行。是名慈无量。悲无量云何。谓悲及悲相应受想行识。若彼等起身语业。若彼等起心不相应行。是名悲无量。喜无量云何。谓喜及喜相应受想行识。若彼等起身语业。若彼等起心不相应行。是名喜无量。舍无量云何。谓舍及舍相应受想行识。若彼等起身语业。若彼等起心不相应行。是名舍无量。空无边处云何。此有二种。一定二生。此中所有受想行识。是名空无边处。识无边处云何。此有二种。一定二生。此中所有受想行识。是名识无边处。无所有处云何。此有二种。一定二生。此中所有受想行识。是名无所有处。非想非非想处云何。此有二种。一定二生。此中所系受想行识。是名非想非非想处

随所得衣喜足圣种云何。谓随所得衣喜足增上所起善有漏无漏道。是名随所得衣喜足圣种。随所得食喜足圣种云何。谓随所得食喜足增上所起善有漏无漏道。是名随所得食喜足圣种。随所得卧具喜足圣种云何。谓随所得卧具喜足增上所起善有漏无漏道。是名随所得卧具喜足圣种。乐断乐修圣种云何。谓乐断乐修增上所起善有漏无漏道是名乐断乐修圣种。预流果云何。此有二种。一有为二无为。有为预流果云何。谓证预流果所有学法。已正当得。无为预流果云何。谓证预流果所有结断。已正当得。是名预流果。一来果云何。此有二种。一有为二无为。有为一来果云何。谓证一来果所有学法。已正当得。无为一来果云何。谓证一来果所有结断。已正当得。是名一来果。不还果云何。此有二种。一有为二无为。有为不还果云何。谓证不还果所有学法。已正当得。无为不还果云何。谓证不还果所有结断。已正当得。是名不还果。阿罗汉果云何。此有二种。一有为二无为。有为阿罗汉果云何。谓证阿罗汉果所有无学法。已正当得。无为阿罗汉果云何。谓证阿罗汉果所有结断。已正当得。是名阿罗汉果。法智苦智等。二种四智。如前应知。法无碍解云何。谓于名句文身所有不退智。义无碍解云何。谓于胜义所有不退智。词无碍解云何。谓于言词所有不退智。辩无碍解云何。谓于无滞应理言词。及于等持自在显示。所有不退智

因缘云何。谓一切有为法。等无间缘云何。谓除过去现在阿罗汉命终时心心所法。诸余过去现在心心所法。所缘缘及增上缘云何。谓一切法。段食云何。谓缘段食。诸根长养。大种增益。资助随资助。充悦随充悦。护随护。转随转。益随益。是名段食。触食云何。谓缘有漏触。诸根长养。大种增益。资助随资助。充悦随充悦。护随护。转随转。益随益。是名触食。意思食云何。谓缘有漏思。诸根长养。大种增益。资助随资助。充悦随充悦。护随护。转随转。益随益。是名意思食。识食云何。谓缘有漏识。诸根长养。大种增益。资助随资助。充悦随充悦。护随护。转随转。益随益。是名识食

欲瀑流云何。谓除欲界系见及无明。诸余欲界系结缚随眠随烦恼缠。是名欲瀑流。有瀑流云何。谓除色无色界系见及无明。诸余色无色界系结缚随眠随烦恼缠。是名有瀑流。见瀑流云何。谓三界五见。即有身见边执见邪见见取戒禁取。是名见瀑流。无明瀑流云何。谓三界无智。四扼亦尔。欲取云何。谓除欲界系五见。诸余欲界系结缚随眠随烦恼缠。是名欲取。见取云何。谓四见。即有身见边执见邪见见取。是名见取。戒禁取云何。谓如有一取戒言戒能清净能解脱能出离能超苦乐至超苦乐处。取禁言禁能清净能解脱能出离能超苦乐至超苦乐处。取戒禁言戒禁能清净能解脱能出离能超苦乐至超苦乐处。是名戒禁取。我语取云何。谓除色无色界系五见。诸余色无色界系结缚随眠随烦恼缠。是名我语取。过去法云何。谓过去五蕴。未来法云何。谓未来五蕴。现在法云何。谓现在五蕴。非过去非未来非现在法云何。谓无为法。欲界系法云何。谓欲界系五蕴。色界系法云何。谓色界系五蕴。无色界系法云何。谓无色界四蕴。不系法云何。谓一切无漏法。善为因法云何。谓善有为法。及善法异熟。不善为因法云何。谓欲界系染污。及不善法异熟。无记为因法云何。谓无记有为。及不善法。非善为因非不善为因非无记为因法云何。谓无为法。缘有所缘法云何。谓缘心心所法意识。及相应法。缘无所缘法云何。谓五识身及相应法。并缘色无为心不相应行意识。及相应法。缘有所缘缘无所缘法云何。谓缘心心所法色无为。心不相应行意识。及相应法。非缘有所缘非缘无所缘法云何。谓色无为色不相应行

五蕴五取蕴如前说。捺落迦趣云何。谓那落迦诸有情类。同性同类同众同分。依得事得处得。生彼有情。无覆无记色受想行识。是名捺落迦趣。傍生趣云何。谓傍生诸有情类。同性同类同众同分。依得事得处得。生彼有情。无覆无记色受想行识。是名傍生趣。鬼趣云何。谓鬼诸有情类。同性同类同众同分。依得事得处得。生彼有情。无覆无记色受想行识。是名鬼趣。人趣云何。谓人诸有情类。同性同类同众同分。依得事得处得。生彼有情。无覆无记色受想行识。是名人趣。天趣云何。谓天诸有情类。同性同类同众同分。依得事得处得。生彼有情。无覆无记色受想行识。是名天趣。见苦所断烦恼部云何。谓有烦恼部随信随法行苦现观边忍所断。此复云何。谓见苦所断二十八随眠。及彼相应诸烦恼众。见集所断烦恼部云何。谓有烦恼部随信随法行集现观边忍所断。此复云何。谓见集所断十九随眠。及彼相应诸烦恼众。见灭所断烦恼部云何。谓有烦恼部随信随法行灭现观边忍所断。此复云何。谓见灭所断十九随眠。及彼相应诸烦恼众。见道所断烦恼部云何。谓有烦恼部随信随法行道现观边忍所断。此复云何。谓见道所断二十二随眠。及彼相应诸烦恼众。修所断烦恼部云何。谓有烦恼部学见迹修所断。此复云何。谓修所断十随眠。及彼相应烦恼众。色等五法如前说

地等六界如前说。见苦所断法云何。谓若法随信随法行苦现观边忍所断。此复云何。谓见苦所断二十八随眠及彼相应法。并彼等起心不相应行。是名见苦所断法。见集所断法云何。谓若法随信随法行集现观边忍所断。此复云何谓见集所断十九随眠。及彼相应法。并彼等起心不相应行。是名见集所断法。见灭所断法云何。谓若法随信随法行灭现观边忍所断。此复云何。谓见灭所断十九随眠。及彼相应法。并彼等起心不相应行。是名见灭所断法。见道所断法云何。谓若法随信随法行道现观边忍所断。此复云何。谓见道所断二十二随眠。及彼相应法。并彼等起心不相应行。是名见道所断法。修所断法云何。谓若法学见迹修所断。此复云何。谓修所断十随眠。及彼相应法。若彼等起身语业。若彼等起心不相应行。若不染污诸有漏法。是名修所断法。非所断法云何。谓诸无漏法。欲贪随眠云何。谓于诸欲诸贪等贪。执藏防护耽着爱乐。嗔随眠云何。谓于有情心怀愤恚。欲为损害。根裁对碍。憎怒凶悖。猛烈暴恶。已正当嗔。令诸有情互相违害。有贪随眠云何。谓于色无色诸贪等贪。执藏防护耽着爱乐。慢随眠云何。谓慢已慢当慢。心高举心恃篾。无明随眠云何。谓三界无智。见随眠云何。谓五染污见。疑随眠云何。谓于谛犹豫。初识住云何。谓有色有情身异想异。如人一分天。是初识住。此中初者。谓随算数。渐次顺次。相续次第。此最在初。彼系诸色受想行识。总名识住。第二识住云何。谓有色有情身异想一。如梵众天劫初时。是第二识住。此中第二者。谓随算数。渐次顺次相续次第。此居第二。彼系诸色受想行识。总名识住。第三识住云何。谓有色有情身一想异。如极光净天。是第三识住。此中第三者。谓随算数。渐次顺次相续次第。此居第三。彼系诸色受想行识。总名识住。第四识住云何。谓有色有情身一想一。如遍净天。是第四识住。此中第四者。谓随算数。渐次顺次相续次第。此居第四。彼系诸色受想行识。总名识住。第五识住云何。谓无色有情超一切色想。灭有对想。不思惟种种想。入无边空。空无边处具足住。如空无边处天。是第五识住。此中第五者。谓随算数。渐次顺次相续次第。此居第五。彼系诸受想行识。总名识住。第六识住云何。谓无色有情超一切空无边处。入无边识。识无边处具足住。如识无边处天。是第六识住。此中第六者。谓随算数。渐次顺次相续次第。此居第六。彼系诸受想行识。总名识住。第七识住云何。谓无色有情。超一切识无边处。入无所有。无所有处具足住。如无所有处天。是第七识住。此中第七者。谓随算数。渐次顺次相续次第。此居第七。彼系诸受想行识。总名识住

念等觉支云何。谓圣弟子等。于苦思惟苦。于集思惟集。于灭思惟灭。于道思惟道。无漏作意相应。诸念随念。别念忆念。不忘不失。不遗不漏。不忘法性。心明记性。是名念等觉支。择法等觉支云何。谓圣弟子等。于苦思惟苦。于集思惟集。于灭思惟灭。于道思惟道。无漏作意相应。于法简择极简择最极简择。解了等了遍了近了。机黠通达。审察聪睿。觉明慧行。毗般舍那决择法性。是名择法等觉支。精进等觉支云何。谓圣弟子等。于苦思惟苦。于集思惟集。于灭思惟灭。于道思惟道。无漏作意相应。诸勤精进。勇健势猛。炽盛难制。励意不息。心勇悍性。是名精进等觉支。喜等觉支云何。谓圣弟子等。于苦思惟苦。于集思惟集。于灭思惟灭。于道思惟道。无漏作意相应。心欣极欣现前极欣。欣性欣类。适意悦意。喜性喜类。乐和合不别离。欢欣悦豫。有堪任性。踊跃踊跃性。欢喜欢喜性。是名喜等觉支。轻安等觉支云何。谓圣弟子等。于苦思惟苦。于集思惟集。于灭思惟灭。于道思惟道。无漏作意相应。身轻安心轻安。已轻安轻安类。是名轻安等觉支。定等觉支云何。谓圣弟子等。于苦思惟苦。于集思惟集。于灭思惟灭。于道思惟道。无漏作意相应。诸令心住等住安住近住坚住。不乱不散摄止等持。心一境性。是名定等觉支。舍等觉支云何。谓圣弟子等。于苦思惟苦。于集思惟集。于灭思惟灭。于道思惟道。无漏作意相应。心平等性。心正直性。心无警觉寂静住性。是名舍等觉支

初解脱云何。谓有色观诸色。是初解脱。此中初者。谓随算数。渐次顺次相续次第。此最在初。又随入定。渐次顺次相续次第。此最在初。如是定中所有善色受想行识。是名解脱。第二解脱云何。谓内无色想。观外色。是第二解脱。此中第二者。谓随算数。渐次顺次相续次第。此居第二。又随入定。渐次顺次相续次第。此居第二。如是定中所有善色受想行识。是名解脱。第三解脱云何。谓净解脱身作证具足住。是第三解脱。此中第三者。谓随算数。渐次顺次相续次第。此居第三。又随入定。渐次顺次相续次第。此居第三。如是定中所有善色受想行识。是名解脱。第四解脱云何。谓超一切色想。灭有对想。不思惟种种想。入无边空。空无边处具足住。是第四解脱。此中第四者。谓随算数。渐次顺次相续次第。此居第四。又随入定。渐次顺次相续次第。此居第四。如是定中所有善受想行识。是名解脱。第五解脱云何。谓超一切空无边处。入无边识。识无边处具足住。是第五解脱。此中第五者。谓随算数。渐次顺次相续次第。此居第五。又随入定。渐次顺次相续次第。此居第五。如是定中所有善受想行识。是名解脱。第六解脱云何。谓超一切识无边处。入无所有无所有处具足住。是第六解脱。此中第六者。谓随算数。渐次顺次相续次第。此居第六。又随入定。渐次顺次相续次第。此居第六。如是定中所有善受想行识。是名解脱。第七解脱云何。谓超一切无所有处。入非想非非想处具足住。是第七解脱。此中第七者。谓随算数渐次顺次相续次第。此居第七。又随入定。渐次顺次相续次第。此居第七。如是定中所有善受想行识。是名解脱。第八解脱云何。谓超一切非想非非想处。入想受灭身作证具足住。是第八解脱。此中第八者。谓随算数。渐次顺次相续次第。此居第八。又随入定。渐次顺次相续次第。此居第八。如是定中诸解脱胜解脱异极解脱。复次若法想微细为因。想微细为等无间。是与想不俱义。非不成就义。是名解脱

初胜处云何。谓内有色想观外色少。若好显色若恶显色。于彼诸色胜知胜见。具如是想。是初胜处。此中初者。谓随算数。渐次顺次相续次第。此最在初。又随入定。渐次顺次相续次第。此最在初。如是定中所有善色受想行识。是名胜处。第二胜处云何。谓内有色想观外色多。若好显色若恶显色。于彼诸色胜知胜见。具如是想。是第二胜处。此中第二者。谓随算数。渐次顺次相续次第。此居第二。又随入定。渐次顺次相续次第。此居第二。如是定中所有善色受想行识。是名胜处。第三胜处云何。谓内无色想观外色少。若好显色若恶显色。于彼诸色胜知胜见。具如是想。是第三胜处。此中第三者。谓随算数。渐次顺次相续次第。此居第三。又随入定。渐次顺次相续次第。此居第三。如是定中所有善色受想行识。是名胜处。第四胜处云何。谓内无色想观外色多。若好显色若恶显色。于彼诸色胜知胜见。具如是想。是第四胜处。此中第四者。谓随算数。渐次顺次相续次第。此居第四。又随入定。渐次顺次相续次第。此居第四。如是定中所有善色受想行识。是名胜处。第五胜处云何。谓内无色想观外诸色。若青青显青现青光。犹如乌莫迦花。或如婆罗痆斯深染青衣。若青青显青现青光。内无色想观外诸色。若青青显青现青光。亦复如是。于彼诸色胜知胜见。具如是想。是第五胜处。此中第五者。谓随算数。渐次顺次相续次第。此居第五。又随入定。渐次顺次相续次第。此居第五。如是定中所有善色受想行识。是名胜处。第六胜处云何。谓内无色想观外诸色。若黄黄显黄现黄光。犹如羯尼迦花。或如婆罗痆斯深染黄衣。若黄黄显黄现黄光。内无色想观外诸色。若黄黄显黄现黄光。亦复如是。于彼诸色胜知胜见。具如是想。是第六胜处。此中第六者。谓随算数。渐次顺次相续次第。此居第六。又随入定。渐次顺次相续次第。此居第六。如是定中所有善色受想行识。是名胜处。第七胜处云何。谓内无色想观外诸色。若赤赤显赤现赤光。犹如槃豆时缚迦花。或如婆罗痆斯深染赤衣。若赤赤显赤现赤光。内无色想观外诸色。若赤赤显赤现赤光。亦复如是。于彼诸色胜知胜见。具如是想。是第七胜处。此中第七者。谓随算数。渐次顺次相续次第。此居第七。又随入定。渐次顺次相续次第。此居第七。如是定中所有善色受想行识是名胜处。第八胜处云何。谓内无色想观外诸色。若白白显白现白光。犹如乌杀斯星。或如婆罗痆斯极鲜白衣。若白白显白现白光。内无色想观外诸色。若白白显白现白光。亦复如是。于彼诸色胜知胜见。具如是想。是第八胜处。此中第八者。谓随算数。渐次顺次相续次第。此居第八。又随入定。渐次顺次相续次第。此居第八。如是定中所有善色受想行识。是名胜处

说一切有部品类足论卷第七阿毗达磨品类足论卷第八

        尊者世友造

        三藏法师玄奘奉　诏译

    辩摄等品第六之四

正见云何。谓圣弟子等。于苦思惟苦。于集思惟集。于灭思惟灭。于道思惟道。无漏作意相应。于法简择极简择最极简择。解了等了遍了近了。机黠通达。审察聪睿。觉明慧行。毗般舍那。是名正见。正思惟云何。谓圣弟子等。于苦思惟苦。于集思惟集。于灭思惟灭。于道思惟道。无漏作意相应诸心。寻求遍寻求。构度极构度现前构度。推究追寻。极思惟。思惟性。是名正思惟。正语云何。谓圣弟子等。于苦思惟苦。于集思惟集。于灭思惟灭。于道思惟道。除趣邪命语四恶行。于余语恶行。由决择力所引无漏。远离止息。各别远离。寂静律仪。不作不造。不行不犯。不毁分限。堤塘桥梁船筏。弃舍轨则。不违不越。不违越住。是名正语。正业云何。谓圣弟子等。于苦思惟苦。于集思惟集。于灭思惟灭。于道思惟道。除趣邪命身三恶行。于余身恶行。由决择力所引无漏。远离止息各别远离。寂静律仪。不作不造。不行不犯。不毁分限。堤塘桥梁船筏。弃舍轨则。不违不越。不违越住。是名正业。正命云何。谓圣弟子等。于苦思惟苦。于集思惟集。于灭思惟灭。于道思惟道。于趣邪命身语恶行。由决择力所引无漏。远离止息。各别远离。寂静律仪。不作不造。不行不犯。不毁分限。堤塘桥梁船筏。弃舍轨则。不违不越。不违越住。是名正命。正精进云何。谓圣弟子。于苦思惟苦。于集思惟集。于灭思惟灭。于道思惟道。无漏作意相应。诸勤精进。勇健势猛。炽盛难制。励意不息。心勇悍性。是名正精进。正念云何。谓圣弟子等。于苦思惟苦。于集思惟集。于灭思惟灭。于道思惟道。无漏作意相应。诸念随念。别念忆念。不忘不失。不遗不漏。不忘法性。心明记性。是名正念。正定云何。谓圣弟子等。于苦思惟苦。于集思惟集。于灭思惟灭。于道思惟道。无漏作意相应。诸令心住等住安住近住坚住。不乱不散摄止等持。心一境性。是名正定

爱结云何。谓三界贪。恚结云何。谓于有情能为损害。慢结云何。谓七慢类。无明结云何。谓三界无智。见结云何。谓三见。取结云何。谓二取。疑结云何。谓于诸谛疑惑犹豫。嫉结云何。谓妒忌。悭结云何。谓心鄙吝

初有情居云何。谓有色有情身异想异。如人一分天。是初有情居。此中初者。谓随算数。渐次顺次相续次第。此最在初。有情居者。谓诸有情。于此居止各别居止。由此显彼受生处故。名有情居。第二有情居云何。谓有色有情身异想一。如梵众天劫初时。是第二有情居。此中第二者。谓随算数。渐次顺次相续次第。此居第二。有情居者。义如前说。第三有情居云何。谓有色有情身一想异。如极光净天。是第三有情居。此中第三者。谓随算数。渐次顺次相续次第。此居第三。有情居者。义如前说。第四有情居云何。谓有色有情身一想一。如遍净天。是第四有情居。此中第四者。谓随算数。渐次顺次相续次第。此居第四。有情居者。义如前说。第五有情居云何。谓有色有情无想无异想。如无想有情天是第五有情居。此中第五者。谓随算数。渐次顺次相续次第。此居第五。有情居者。义如前说。第六有情居云何。谓无色有情超一切色想。灭有对想不思惟种种想。入无边空。空无边处具足住。如空无边处天。是第六有情居。此中第六者。谓随算数。渐次顺次相续次第。此居第六。有情居者。义如前说。第七有情居云何。谓无色有情超一切空无边处入无边识。识无边处具足住。如识无边处天。是第七有情居。此中第七者。谓随算数。渐次顺次相续次第。此居第七。有情居者。义如前说。第八有情居云何。谓无色有情超一切识无边处入无所有。无所有处具足住。如无所有处天。是第八有情居。此中第八者。谓随算数。渐次顺次相续次第。此居第八。有情居者。义如前说。第九有情居云何。谓无色有情超一切无所有处入非想非非想处具足住。如非想非非想处天。是第九有情居。此中第九者。谓随算数。渐次顺次相续次第。此居第九。有情居者。义如前说

初遍处云何。谓地遍满一类想。上下傍布无二无量。是初遍处。此中初者。谓随算数。渐次顺次相续次第。此最在初。又随入定。渐次顺次相续次第。此最在初。如是定中所有善色受想行识。是名遍处。水火风青黄赤白遍处亦尔。第九遍处云何。谓空遍满一类想。上下傍布无二无量。是第九遍处。此中第九者。谓随算数。渐次顺次相续次第。此居第九。又随入定渐次顺次相续次第。此居第九。如是定中所有善受想行识。是名遍处。识无边处遍处亦尔。无学正见正思惟正语正业正命正精进正念正定。如八支圣道说。无学正胜解云何。谓圣弟子等。于苦思惟苦。于集思惟集。于灭思惟灭。于道思惟道。无学作意相应。已正当胜解。是名无学正胜解。无学正智云何。谓尽智无生智。是名无学正智

有漏色云何。谓若诸色有漏有取。于此诸色。若过去若未来若现在。或欲或贪或嗔或痴。或随一一心所随烦恼应生时生。是名有漏色。无漏色云何。谓若诸色无漏无取。于此诸色若过去若未来若现在。或欲或贪或嗔或痴。或随一一心所随烦恼应生时不生。是名无漏色。有漏无漏受想行识亦尔。无为法云何。谓三无为。即虚空非择灭择灭。十二处十八界。如辩七事品已说

眼根云何。谓眼于色已正当见。及彼同分。耳根云何。谓耳于声已正当闻。及彼同分。鼻根云何。谓鼻于香已正当嗅。及彼同分。舌根云何。谓舌于味已正当尝。及彼同分。身根云何。谓身于触已正当触。及彼同分。女根云何。谓身根少分。男根云何。谓身根少分。命根云何。谓三界寿。意根云何。谓六识身。乐根云何。谓顺乐受触所触时所起。身乐心乐。平等受。受所摄。是名乐根。苦根云何。谓顺苦受触所触时所起。身苦不平等受。受所摄。是名苦根。喜根云何。谓顺喜受触所触时所起。心喜平等受。受所摄。是名喜根。忧根云何。谓顺忧受触所触时所起。心忧不平等受。受所摄。是名忧根。舍根云何。谓顺舍受触所触时所起。身舍心舍非平等非不平等受。受所摄。是名舍根。信根云何。谓依出离远离所生善法。诸信信性。增上信性。忍可欲作。欲为欲造。心澄净性。是名信根。精进根云何。谓依出离远离所生善法。诸勤精进。勇健势猛。炽盛难制。励意不息。心勇悍性。是名精进根。念根云何。谓依出离远离所生善法。诸念随念。别念忆念。不忘不失。不遗不漏。不忘法性。心明记性。是名念根。定根云何。谓依出离远离所生善法。诸念心住。等住安住。近住坚住。不乱不散。摄止等持。心一境性。是名定根。慧根云何。谓依出离远离所生善法。于法简择极简择最极简择。解了等了遍了近了。机黠通达。审察聪睿。觉明慧行。毗钵舍那。是名慧根。未知当知根云何。谓已入正性离生补特伽罗。诸学慧慧等根。由此诸根随信随法行。于未现观四圣谛能现观。是名未知当知根。已知根云何。谓具见已现观补特伽罗。诸学慧慧等根。由此诸根。信胜解见至身证。于已现观四圣谛。能趣上胜所证功德。是名已知根。具知根云何。谓漏尽阿罗汉。诸无学慧慧等根。由此诸根。慧解脱俱分解脱。能得现法乐住。是名具知根。九十八随眠如前说

所知法所识法。所通达法。所缘法增上法。十八界十二处五蕴摄。十智知。六识识。一切随眠随增有色法。十一界十一处一蕴摄。八智知。除他心灭智。六识识。欲色界遍行。及修所断随眠随增。无色法。八界二处四蕴摄。十智知。一识识。一切随眠随增。有见法。一界一处一蕴摄。七智知。除他心灭道智。二识识。欲色界遍行。及修所断随眠随增。无见法。十七界十一处五蕴摄。十智知。五识识。一切随眠随增。有对法。十界十处一蕴摄。七智知。除他心灭道知。六识识。欲色界遍行。及修所断随眠随增。无对法。八界二处五蕴摄。十智知。一识识。一切随眠随增。有漏法。十八界十二处五蕴摄。八智知。除灭道智。六识识。一切随眠随增。无漏法。三界二处五蕴摄。八智知。除苦集智。一识识。非随眠随增。有为法。十八界十二处五蕴摄。九智知。除灭智。六识识。一切随眠随增。无为法。一界一处非蕴摄。六智知。除他心苦集道智。一识识。非随眠随增。有诤法。十八界十二处五蕴摄。八智知。除灭道智。六识识。一切随眠随增。无诤法。三界二处五蕴摄。八智知。除苦集智。一识识。非随眠随增。世间出世间法。堕界不堕界法。有味着无味着法。耽嗜依出离依法亦尔

心法。七界一处一蕴摄。九智知。除灭智。一识识。一切随眠随增。非心法。十一界十一处四蕴摄。十智知。六识识。一切随眠随增。心所法。一界一处三蕴摄。九智知。除灭智。一识识。一切随眠随增。非心所法。十八界十二处三蕴摄。十智知。六识识。一切随眠随增。心相应心不相应法亦尔。心俱有法。十一界十一处四蕴摄。九智知。除灭智。六识识。一切随眠随增。非心俱有法。十八界十二处三蕴摄。十智知。六识识。一切随眠随增。随心转法。一界一处四蕴摄。九智知。除灭智。一识识。一切随眠随增。非随心转法。十八界十二处三蕴摄。十智知。六识识。一切随眠随增。心为因法。十八界十二处五蕴摄。九智知。除灭智。六识识。一切随眠随增。非心为因法。十三界十二处三蕴摄。十智知。六识识。三界遍行。及修所断随眠随增。心为等无间法。八界二处四蕴摄。九智知。除灭智。一识识。一切随眠随增。非心为等无间法。十八界十二处五蕴摄。十智知。六识识。一切随眠随增。心为所缘法。三界二处四蕴摄。九智知。除灭智。一识识。三界有为缘随眠随增。非心为所缘法。十八界十二处五蕴摄。十智知。六识识。一切随眠随增。心为增上法。十八界十二处五蕴摄。九智知。除灭智。六识识。一切随眠随增。非心为增上法。一界一处非蕴摄。六智知。除他心苦集道智。一识识。非随眠随增。心果法。十八界十二处五蕴摄。十智知。六识识。一切随眠随增。非心果法。一界一处非蕴摄。一智知。谓世俗智。一识识。非随眠随增。心异熟法。十七界十一处五蕴摄。八智知。除灭道智。五识识。除耳识三界遍行。及修所断随眠随增。非心异熟法。十八界十二处五蕴摄。十智知。六识识。一切随眠随增。业法。三界三处二蕴摄。九智知。除灭智。三识识。谓眼耳意识。一切随眠随增。非业法。十八界十二处五蕴摄。十智知。六摄识。一切随眠随增。业相应法。八界二处四蕴摄。九智知。除灭智。一识识。一切随眠随增。业不相应法。十一界十一处二蕴摄。十智知。六识识。一切随眠随增。业俱有法。十八界十二处五蕴摄。九智知。除灭智。六识识。一切随眠随增。非业俱有法。十一界十一处二蕴摄。十智知。六识识。一切随眠随增。随业转法。八界二处五蕴摄。九智知。除灭智。一识识。一切随眠随增非随业转法。十一界十一处二蕴摄。十智知。六识识。一切随眠随增业为因法。十八界十二处五蕴摄。九智知。除灭智。六识识。一切随眠随增。非业为因法。十一界十一处二蕴摄。十智知。六识识。三界遍行。及修所断随眠随增。业为等无间法。八界二处四蕴摄。九智知。除灭智。一识识。一切随眠随增。非业为等无间法。十八界十二处五蕴摄。十智知。六识识。一切随眠随增。业为所缘法。五界二处四蕴摄。九智知。除灭智。一识识。三界有为缘随眠随增。非业为所缘法。十八界十二处五蕴摄。十智知。六识识。一切随眠随增。业为增上法。十八界十二处五蕴摄。九智知。除灭智。六识识。一切随眠随增。非业为增上法。一界一处非蕴摄。六智知。除他心苦集道智。一识识。非随眠随增业果法。十八界十二处五蕴摄。十智知。六识识。一切随眠随增。非业果法。一界一处非蕴摄。一智知。谓世俗智。一识识。非随眠随增。业异熟法。十七界十一处五蕴摄。八智知。除灭道智。五识识。除耳识。三界遍行。及修所断随眠随增。非业异熟法。十八界十二处五蕴摄。十智知。六识识。一切随眠随增

有法。十八界十二处五蕴摄。八智知。除灭道智。六识识。一切随眠随增。非有法。三界二处五蕴摄。八智知。除苦集智。一识识。非随眠随增。有相应法。八界二处四蕴摄。八智知。除灭道智。一识识。一切随眠随增。有不相应法。十三界十二处五蕴摄。十智知。六识识。三界有漏缘随眠随增。有俱有法。十八界十二处五蕴摄。九智知。除灭智。六识识。一切随眠随增。非有俱有法。三界二处五蕴摄。八智知。除苦集智。一识识。非随眠随增。随有转法有为因法。十八界十二处五蕴摄。八智知。除灭道智。六识识。一切随眠随增。非有随转法。非有为因法。三界三处五蕴摄。八智知。除苦集智。一识识。非随眠随增。有为等无间法。八界二处四蕴摄。九智知。除灭智。一识识。一切随眠随增。非有为等无间法。十八界十二处五蕴摄。十智知。六识识。一切随眠随增。有为所缘法。八界二处四蕴摄。九智知。除灭智。一识识。三界有漏缘随眠随增。非有为所缘法。十三界十二处五蕴摄。十智知。六识识。一切随眠随增。有为增上法。十八界十二处五蕴摄。九智知。除灭智。六识识。一切随眠随增。非有为增上法。一界一处非蕴摄。六智知。除他心苦集道智。一识识。非随眠随增。有果法。十八界十二处五蕴摄。九智知。除道智。六识识。一切随眠随增。非有果法。三界二处五蕴摄。八智知。除苦集智。一识识。非随眠随增。有异熟法。十七界十一处五蕴摄。八智知。除灭道智。五识识。除耳识。三界遍行。及修所断随眠随增。非有异熟法。十八界十二处五蕴摄。十智知。六识识。一切随眠随增

智遍知所遍知法。十八界十二处五蕴摄。十智知。六识识。一切随眠随增。非智遍知所遍知法。非界非处非蕴摄。非智知非识识非随眠随增。以如是法不可得故。断遍知所遍知法。即是所应断法。此法十八界十二处五蕴摄。八智知。除灭道智。六识识。一切随眠随增。非断遍知所遍知法。即是非所应断法。此法三界二处五蕴摄。八智知。除苦集智。一识识。非随眠随增。所应修法。十界四处五蕴摄。九智知。除灭智。三识识。三界遍行。及修所断随眠随增。非所应修法。十八界十二处五蕴摄。九智知。除道智。六识识。一切随眠随增。智作证所应证法。十八界十二处五蕴摄。十智知。六识识。一切随眠随增。非智作证所应证法。非界非处非蕴摄。非智知非识识非随眠随增。以如是法不可得故。得作证所应证法。十二界六处五蕴摄。十智知。三识识。三界遍行。及修所断随眠随增。非得作证所应证法。十八界十二处五蕴摄。八智知。除灭道智。六识识。一切随眠随增。所应习法。十界四处五蕴摄。九智知。除灭智。三识识。三界遍行。及修所断随眠随增。非所应习法。十八界十二处五蕴摄。九智知。除道智。六识识。一切随眠随增。有罪法。十界四处五蕴摄。八智知。除灭道智。三识识。一切随眠随增。无罪法。十八界十二处五蕴摄。十智知。六识识。三界遍行。及修所断随眠随增。黑白法。有覆无覆法。顺退非顺退法亦尔。有记法。十界四处五蕴摄。十智知。三识识。欲界一切色无色界遍行。及修所断随眠随增。无记法。十八界十二处五蕴摄。八智知。除灭道智。六识识。色无色界一切欲界二部。及见集所断遍行随眠随增

已生法。十八界十二处五蕴摄。九智知。除灭智。六识识。一切随眠随增。非已生法。十八界十二处五蕴摄。十智知。六识识。一切随眠随增。正生非正生法已灭非已灭法正灭非正灭法亦尔。缘起法。十八界十二处五蕴摄。九智知。除灭智。六识识。一切随眠随增。非缘起法。一界一处非蕴摄。六智知。除他心苦集道智。一识识。非随眠随增。缘已生非缘已生法因法非因法有因非有因法因已生非因已生法亦尔。因相应法。八界二处四蕴摄。九智知。除灭智。一识识。一切随眠随增。因不相应法。十一界十一处二蕴摄。九智知。除他心智。六识识。三界有漏缘随眠随增

结法。一界一处一蕴摄。八智知。除灭道智。一识识。除无漏缘不共无明。诸余一切随眠随增。非结法。十八界十二处五蕴摄。十智知。六识识。一切随眠随增。顺结法。十八界十二处五蕴摄。八智知。除灭道智。六识识。一切随眠随增。非顺结法。三界二处五蕴摄。八智知。除苦集智。一识识。非随眠随增。取法。一界一处一蕴摄。八智知。除灭道智。一识识。一切随眠随增。非取法。十八界十二处五蕴摄。十智知。六识识。一切随眠随增。有执受法。九界九处一蕴摄。七智知。除他心灭道智。五识识。欲色界遍行。及修所断随眠随增。无执受法。十八界十二处五蕴摄。十智知。六识识。一切随眠随增。顺取法。十八界十二处五蕴摄。八智知。除灭道智。六识识。一切随眠随增。非顺取法。三界二处五蕴摄。八智知。除苦集智。一识识。非随眠随增。烦恼法。一界一处一蕴摄。八智知。除灭道智。一识识。一切随眠随增。非烦恼法。十八界十二处五蕴摄。十智知。六识识。一切随眠随增。染污法。十界四处五蕴摄。八智知。除灭道智。三识识。一切随眠随增。不染污法。十八界十二处五蕴摄。十智知。六识识。三界遍行。及修所断随眠随增。染污法。十八界十二处五蕴摄。八智知。除灭道智。六识识。一切随眠随增。非杂染法。三界二处五蕴摄。八智知。除苦集智。一识识。非随眠随增。缠法。一界一处一蕴摄。八智知。除灭道智。一识识。一切随眠随增。非缠法。十八界十二处五蕴摄。十智知。六识识。一切随眠随增。所缠法。八界二处四蕴摄。八智知。除灭道智。一识识。一切随眠随增。非所缠法。十八界十二处五蕴摄。十智知。六识识。三界有漏缘随眠随增。顺缠法。十八界十二处五蕴摄。八智知。除灭道智。六识识。一切随眠随增。非顺缠法。三界二处五蕴摄。八智知。除苦集智。一识识。非随非随增

有所缘法。二界二处四蕴摄。九智知。除灭智。一识识。一切随眠随增。无所缘法。十一界十一处二蕴摄。九智知。除他心智。六识识。三界有漏缘随眠随增。有寻法。八界二处四蕴摄。九智知。除灭智。一识识。欲色界一切随眠随增。无寻法。十三界十二处五蕴摄。十智知。六识识。一切随眠随增。有伺无伺法亦尔。有喜法。三界二处三蕴摄。九智知。除灭智。一识识。色界一切。除欲界无漏缘疑及彼相应无明。诸余欲界一切随眠随增。无喜法。十八界十二处五蕴摄。十智知。六识识。一切随眠随增。有警觉法。八界二处四蕴摄。九智知。除灭智。一识识。一切随眠随增。无警觉法。十一界十一处二蕴摄。十智知。六识识。一切随眠随增。有事法。有缘法。有上法。十八界十二处五蕴摄。九智知。除灭智。六识识。一切随眠随增。无事法。无缘法。无上法。一界一处非蕴摄。六智知。除他心苦集道智。一识识。非随眠随增。远法。十八界十二处五蕴摄。九智知。除灭智。六识识。一切随眠随增。近法。十八界十二处五蕴摄。十智知。六识识。一切随眠随增。有量无量法亦尔。见法。二界二处二蕴摄。九智知。除灭智。一识识。三界有漏缘。及无漏缘见相应无明随眠随增。非见法。十七界十一处五蕴摄。十智知。六识识。一切随眠随增。见处法。十八界十二处五蕴摄。八智知。除灭道智。六识识。一切随眠随增。非见处法。三界二处五蕴摄。八智知。除苦集智。一识识。非随眠随增。见相应法。三界二处四蕴摄。九智知。除灭智。一识识。三界有漏缘。并无漏缘。见及彼相应无明随眠随增。见不相应法。十八界十一处五蕴摄。十智知。六识识。除无漏缘见。诸余一切随眠随增

说一切有部品类足论卷第八阿毗达磨品类足论卷第九

        尊者世友造

        三藏法师玄奘奉　诏译

    辩摄等品第六之五

异生法法。十八界十二处五蕴摄。八智知。除灭道智。六识识。欲色界一切随眠随增。非异生法法。十一界十处五蕴摄。十智知。四识识。三界遍行。及修所断随眠随增。共异生法。十八界十二处五蕴摄。八智知。除灭道智。六识识。一切随眠随增。不共异生法。十一界十处五蕴摄。十智知。四识识。三界遍行。及修所断随眠随增。定法。五界四处五蕴摄。九智知。除灭智。三识识。欲界遍行。及修所断随眠随增。非定法。十八界十二处五蕴摄。九智知。除道智。六识识。一切随眠随增。顺热恼法。十界四处五蕴摄。八智知。除灭道智。三识识。一切随眠随增。非顺热恼法。十八界十二处五蕴摄。十智知。六识识。三界遍行。及修所断随眠随增。根法。十三界七处四蕴摄。九智知。除灭智。一识识。一切随眠随增。非根法。六界六处三蕴摄。十智知。六识识。一切随眠随增。圣谛所摄法。十八界十二处五蕴摄。十智知。六识识。一切随眠随增。非圣谛所摄法。一界一处非蕴摄。一智知。谓世俗智。一识识。非随眠随增。俱有法。十八界十二处五蕴摄。九智知。除灭智。六识识。一切随眠随增。非俱有法。一界一处非蕴摄。六智知。除他心苦集道智。一识识。非随眠随增。相应法。八界二处四蕴摄。九智知。除灭智。一识识。一切随眠随增。不相应法。十一界十一处二蕴摄。九智知。除他心智。六识识。三界有漏缘随眠随增。果法。十八界十二处五蕴摄。十智知。六识识。一切随眠随增。非果法。一界一处非蕴摄。一智知。谓世俗智。一识识。非随眠随增。有果法。十八界十二处五蕴摄。九智知。除灭智。六识识。一切随眠随增。无果法。一界一处非蕴摄。六智知。除他心苦集道智。一识识。非随眠随增。异熟法。十七界十一处五蕴摄。八智知。除灭道智。五识识。三界遍行。及修所断随眠随增。非异熟法。十八界十二处五蕴摄。十智知。六识识。一切随眠随增。有异熟法。十界四处五蕴摄。八智知。除灭道智。三识识。欲界一切色无色界遍行。及修所断随眠随增。无异熟法。十八界十二处五蕴摄。十智知。六识识。色无色界一切欲界二部。及见集所断遍行随眠随增。因缘法。十八界十二处五蕴摄。十智知。六识识。一切随眠随增。非因缘法。非界非处非蕴摄。非智知。非识识。非随眠随增。以如是法不可得故。有因缘法。十八界十二处五蕴摄。九智知。除灭智。六识识。一切随眠随增。无因缘法。一界一处非蕴摄。六智知。除他心苦集道智。一识识。非随眠随增。离法。五界四处五蕴摄。十智知。三识识。三界遍行。及修所断随眠随增。非离法。十八界十二处五蕴摄。八智知。除灭道智。六识识。一切随眠随增。有离法。十八界十二处五蕴摄。九智知。除灭智。六识识。一切随眠随增。无离法。一界一处非蕴摄。六智知。除他心苦集道智。一识识。非随眠随增。相续法。十八界十二处五蕴摄。九智知。除灭智。六识识。一切随眠随增。非相续法。十八界十二处五蕴摄。十智知。六识识。一切随眠随增。有相续无相续法亦尔

善法。十界四处五蕴摄。十智知。三识识。三界遍行。及修所断随眠随增。不善法。十界四处五蕴摄。七智知。除类灭道智。三识识。欲界一切随眠随增。无记法。十八界十二处五蕴摄。八智知。除灭道智。六识识。色无色界一切欲界二部。及见集所断遍行随眠随增。学无学法。三界二处五蕴摄。七智知。除苦集灭智。一识识。非随眠随增。非学非无学法。十八界十二处五蕴摄。九智知。除道智。六识识。一切随眠随增。见所断法。三界二处四蕴摄。八智知。除灭道智。一识识。三界见所断一切随眠随增。修所断法。十八界十二处五蕴摄。八智知。除灭道智。六识识。三界修所断一切。及遍行随眠随增。非所断法。三界二处五蕴摄。八智知。除苦集智。一识识。非随眠随增。见所断为因法。十八界十二处五蕴摄。八智知。除灭道智。六识识。一切随眠随增。修所断为因法。十八界十二处五蕴摄。八智知。除灭道智。六识识。三界修所断一切。及遍行随眠随增。非所断为因法。三界二处五蕴摄。七智知。除苦集灭智。一识识。非随眠随增

有见有对法。一界一处一蕴摄。七智知。除他心灭道智。二识识。欲色界遍行。及修所断随眠随增。无见有对法。九界九处一蕴摄。七智知。除他心灭道智。五识识。欲色界遍行。及修所断随眠随增。无见无对法。八界二处五蕴摄。十智知。一识识。一切随眠随增。异熟法。十七界十一处五蕴摄。八智知。除灭道智。五识识。三界遍行。及修所断随眠随增。异熟法法。十界四处五蕴摄。八智知。除灭道智。三识识。欲界一切。色无色界遍行。及修所断随眠随增。非异熟非异熟法法。十八界十二处五蕴摄。十智知。六识识。色无色界一切。欲界二部。及见集所断遍行随眠随增劣法。十界四处五蕴摄。八智知。除灭道智。三识识。一切随眠随增。中法。十八界十二处五蕴摄。八智知。除灭道智。六识识。三界遍行。及修所断随眠随增。妙法。三界二处五蕴摄。八智知。除苦集智。一识识。非随眠随增。小法大法。十八界十二处五蕴摄。九智知。除灭智。六识识。一切随眠随增。无量法。可意法。不可意法。非可意非不可意法。十八界十二处五蕴摄。十智知。六识识。一切随眠随增。乐俱行法。八界二处三蕴摄。九智知。除灭智。一识识。色界一切。除欲界无漏缘疑及彼相应无明识余欲界一切随眠随增。苦俱行法。八界二处三蕴摄。七智知。除类灭道智。一识识。欲界一切随眠随增。不苦不乐俱行法。八界二处三蕴摄。九智知。除灭智。一识识。一切随眠随增。俱生法。俱住法。俱灭法。十八界十二处五蕴摄。九智知。除灭智。六识识。一切随眠随增。非俱生法。非俱住法。非俱灭法。一界一处非蕴摄。六智知。除他心苦集道智。一识识。非随眠随增。心俱生法。十一界十一处四蕴摄。九智知。除灭智。六识识。一切随眠随增。心俱住法。一界一处四蕴摄。九智知。除灭智。一识识。一切随眠随增。心俱灭法。十界十处四蕴摄。九智知。除灭智。五识识。一切随眠随增。非心俱生法。非心俱住法。非心俱灭法。十八界十二处三蕴摄。十智知。六识识。一切随眠随增

欲界十界四处五蕴摄。七智知。除类灭道智。三识识。欲界有漏缘随眠随增。恚界亦尔。害界五界四处五蕴摄。七智知。除类灭道智。三识识。欲界遍行。及修所断随眠随增。出离界十界四处五蕴摄。十智知。三识识。三界遍行。及修所断随眠随增。无恚界无害界。十界四处五蕴摄。九智知。除灭智。三识识。三界遍行。及修所断随眠随增。欲界。十八界十二处五蕴摄。七智知。除类灭道智。六识识。欲界一切随眠随增。色界。十四界十处五蕴摄。七智知。除法灭道智。四识识。色界一切随眠随增。无色界。三界二处四蕴摄。六智知。除法他心灭道智。一识识。无色界一切随眠随增。欲界色界名色界者。十八界十二处五蕴摄。八智知。除灭道智。六识识。欲色界一切随眠随增。四无色名无色界者。三界二处四蕴摄。六智知。除法他心灭道智。一识识。无色界一切随眠随增。择灭非择灭名灭界者。一界一处非蕴摄。六智知。除他心苦集道智。一识识。非随眠随增。复次一切色法。总名色界者。十一界十一处一蕴摄。八智知。除他心灭智。六识识。欲色界遍行。及修所断随眠随增。除择灭非择灭。诸余非色法。总名无色界者。八界二处四蕴摄。九智知。除灭智。一识识。一切随眠随增。择灭非择灭。总名灭界。如前说。欲有。十八界十二处五蕴摄。七智知。除类灭道智。六识识。欲界一切随眠随增。色有。十四界十处五蕴摄。七智知。除法灭道智。四识识。色界一切随眠随增。无色有。三界二处四蕴摄。六智知。除法他心灭道智。一识识。无色界一切随眠随增。欲漏。一界一处一蕴摄。七智知。除类灭道智。一识识。欲界一切随眠随增。有漏。一界一处一蕴摄。七智知。除法灭道智。一识识。色无色界一切随眠随增。无明漏。一界一处一蕴摄。八智知。除灭道智。一识识。除无漏缘无明。诸余一切随眠随增

三世三言依事。十八界十二处五蕴摄。九智知。除灭智。六识识。一切随眠随增。欲界由苦苦故苦者。十八界十二处五蕴摄。七智知。除类灭道智。六识识。欲界一切随眠随增。色界由坏苦故苦者。十四界十处五蕴摄。七智知。除法灭道智。四识识。色界一切随眠随增。无色界由行苦故。苦者。三界二处四蕴摄。六智知。除法他心灭道智。一识识。无色界一切随眠随增。复次不可意诸行。由苦苦故苦。可意诸行。由坏苦故苦。非可意非不可意诸行。由行苦故苦苦者。皆十八界十二处五蕴摄。八智知。除灭道智。六识识。一切随眠随增。复次苦受由苦苦故苦者。一界一处一蕴摄。七智知。除类灭道智。一识识。欲界一切随眠随增。乐受由坏苦故苦者。一界一处一蕴摄。八智知。除灭道智。一识识。色界一切。除欲界无漏缘疑及彼相应无明。诸余欲界一切随眠随增。不苦不乐受由行苦故苦者。一界一处一蕴摄。八智知。除灭道智。一识识。一切随眠随增。有寻有伺法。八界二处四蕴摄。九智知。除灭智。一识识。欲色界一切随眠随增。无寻唯伺法。三界二处四蕴摄。九智知。除灭智。一识识。欲色界一切随眠随增。无寻无伺法。十三界十二处五蕴摄。十智知。六识识。色无色界一切欲界有漏缘随眠随增。有寻有伺地。十八界十二处五蕴摄。九智知。除灭智。六识识。欲色界一切随眠随增。无寻唯伺地。三界二处五蕴摄。九智知。除灭智。一识识。色界遍行。及修所断随眠随增。无寻无伺地。十一界十处五蕴摄。九智知。除灭智。四识识。色无色界一切随眠随增

身业。二界二处一蕴摄。八智知。除他心灭智。二识识。欲色界遍行。及修所断随眠随增。语业亦尔。意业一界一处一蕴摄。九智知。除灭智。一识识。一切随眠随增。善业。三界三处二蕴摄。九智知。除灭智。三识识。三界遍行。及修所断随眠随增。不善业。三界三处二蕴摄。七智知。除类灭道智。三识识。欲界一切随眠随增。无记业。三界三处二蕴摄。八智知。除灭道智。三识识。色无色界一切。欲界三部。及见集所断遍行随眠随增。学业无学业。一界一处二蕴摄。七智知。除苦集灭智。一识识。非随眠随增。非学非无学业。三界三处二蕴摄。八智知。除灭道智。三识识。一切随眠随增。见所断业。一界一处一蕴摄。八智知。除灭道智。一识识。三界见所断一切随眠随增。修所断业。三界三处二蕴摄。八智知。除灭道智。三识识。三界修所断一切及遍行随眠随增。非所断业。一界一处二蕴摄。七智知。除苦集灭智。一识识非随眠随增。顺现法受业。顺次生受业。顺后次受业。三界三处二蕴摄。八智知。除灭道智。三识识。欲界一切。色无色界遍行。及修所断随眠随增。顺乐受业。三界三处二蕴摄。八智知。除灭道智。三识识。欲色界遍行。及修所断随眠随增。顺苦受业。三界三处二蕴摄。七智知。除类灭道智。三识识。欲界一切随眠随增。顺不苦不乐业。一界一处二蕴摄。七智知。除法灭道智。一识识。色无色界遍行。及修所断随眠随增。身念住。十一界十一处一蕴摄。八智知。除他心灭智。六识识。欲色界遍行。及修所断随眠随增。受念住。一界一处一蕴摄。九智知。除灭智。一识识。一切随眠随增。心念住。七界一处一蕴摄。九智知。除灭智。一识识。一切随眠随增。法念住。一界一处二蕴摄。十智知。一识识。一切随眠随增。复次身受心法增上所起善有漏无漏道。三界二处五蕴摄。九智知。除灭智。一识识。三界遍行。及修所断随眠随增。复次缘身受心法所起善有漏无漏慧。一界一处一蕴摄。九智知。除灭智。一识识。三界遍行。及修所断随眠随增。四正断。四神足。三界二处五蕴摄。九智知。除灭智。一识识。三界遍行。及修所断随眠随增。四静虑。三界二处五蕴摄。九智知。除灭智。一识识。色界遍行。及修所断随眠随增。苦集圣谛。十八界十二处五蕴摄。八智知。除灭道智。六识识。一切随眠随增。灭圣谛。一界一处非蕴摄。六智知。除他心苦集道智。一识识。非随眠随增。道圣谛。三界二处五蕴摄。七智知。除苦集灭智。一识识。非随眠随增。四无量。三界二处五蕴摄。七智知。除法灭道智。一识识。色界遍行。及修所断随眠随增。空无边处。识无边处。无所有处。三界二处四蕴摄。七智知。除法他心灭智。一识识。无色界一切随眠随增。非想非非想处。三界二处四蕴摄。六智知。除法他心灭道智。一识识。无色界一切随眠随增。四圣种。三界二处五蕴摄。九智知。除灭智。一识识。三界遍行。及修所断随眠随增。有为四沙门果。三界二处五蕴摄。七智知。除苦集灭智。一识识。非随眠随增。无为四沙门果。一界一处非蕴摄。六智知。除他心苦集道智。一识识。非随眠随增。法智。一界一处一蕴摄。六智知。除类苦集灭智。一识识。非随眠随增。类智。一界一处一蕴摄。六智知。除法苦集灭智。一识识。非随眠随增。他心智。一界一处一蕴摄。九智知。除灭智。一识识。色界遍行。及修所断随眠随增。世俗智。一界一处一蕴摄。八智知。除灭道智。一识识。除无漏缘见。诸余一切随眠随增。苦集灭道智。一界一处一蕴摄。七智知。除苦集灭智。一识识。非随眠随增。法无碍解。一界一处一蕴摄。八智知。除灭道智。一识识。欲色界遍行。及修所断随眠随增。词无碍解亦尔。义无碍解。一界一处一蕴摄。九智知。除灭智。一识识。三界遍行。及修所断随眠随增。辩无碍解亦尔

因缘。十八界十二处五蕴摄。九智知。除灭智。六识识。一切随眠随增。等无间缘。八界二处四蕴摄。九智知。除灭智。一识识。一切随眠随增。所缘缘增上缘。十八界十二处五蕴摄。十智知。六识识。一切随眠随增。段食。三界三处一蕴摄。六智知。除类他心灭道智。四识识。欲界遍行。及修所断随眠随增。触食。意思食。一界一处一蕴摄。八智知。除灭道智。一识识。一切随眠随增。识食。七界一处一蕴摄。八智知。除灭道智。一识识。一切随眠随增

欲瀑流。一界一处一蕴摄。七智知。除类灭道智。一识识。欲界一切随眠随增。有瀑流。一界一处一蕴摄。七智知。除法灭道智。一识识。色无色界一切随眠随增。见瀑流。一界一处一蕴摄。八智知。除灭道智。一识识。三界见所断有漏缘。及见相应无漏缘无明随眠随增。无明瀑流。一界一处一蕴摄。八智知。除灭道智。一识识。除无漏缘无明。诸余一切随眠随增。如四瀑流。四轭亦尔。欲取。一界一处一蕴摄。七智知。除类灭道智。一识识。欲界一切随眠随增。见取。一界一处一蕴摄。八智知。除灭道智。一识识。三界见所断有漏缘。及无漏缘见相应无明随眠随增。戒禁取。一界一处一蕴摄。八智知。除灭道智。一识识。三界见苦所断一切。见集所断遍行。见道所断有漏缘随眠随增。我语取。一界一处一蕴摄。七智知。除法灭道智。一识识。色无色界一切随眠随增。过去法。未来法。现在法。十八界十二处五蕴摄。九智知。除灭智。六识识。一切随眠随增。非过去非未来非现在法。一界一处非蕴摄。六智知。除他心苦集道智。一识识。非随眠随增。欲界系法。十八界十二处五蕴摄。七智知。除类灭道智。六识识。欲界一切随眠随增。色界系法。十四界十处五蕴摄。七智知。除法灭道智。四识识。色界一切随眠随增。无色界系法。三界二处四蕴摄。六智知。除法他心灭道智。一识识。无色界一切随眠随增。不系法。三界二处五蕴摄。八智知。除苦集智。一识识。非随眠随增。善为因法。十八界十二处五蕴摄。九智知。除灭智。六识识。三界遍行。及修所断随眠随增。不善为因法。十八界十二处五蕴摄。七智知。除类灭道智。六识识。欲界一切随眠随增。无记为因法。十八界十二处五蕴摄。八智知。除灭道智。六识识。一切随眠随增。非善为因非不善为因非无记为因法。一界一处非蕴摄。六智知。除他心苦集道智。一识识。非随眠随增。缘有所缘法。三界二处四蕴摄。九智知。除灭智。一识识。三界有为缘随眠随增。缘无所缘法。八界二处四蕴摄。九智知。除灭智。一识识。一切随眠随增。缘有所缘缘无所缘法。三界二处四蕴摄。九智知。除灭智。一识识。三界有为缘随眠随增。非缘有所缘非缘无所缘法。十一界十一处二蕴摄。九智知除他心智。六识识。三界有漏缘随眠随增。色蕴。十一界十一处一蕴摄。八智知。除他心灭智。六识识。欲色界遍行。及修所断随眠随增。受蕴。一界一处一蕴摄。九智知。除灭智。一识识。一切随眠随增。想蕴行蕴亦尔。识蕴。七界一处一蕴摄。九智知。除灭智。一识识。一切随眠随增。色取蕴。十一界十一处一蕴摄。七智知。除他心灭道智。六识识。欲色界遍行。及修所断随眠随增。受取蕴。一界一处一蕴摄。八智知。除灭道智。一识识。一切随眠随增。想取蕴。行取蕴亦尔。识取蕴。七界一处一蕴摄。八智知。除灭道智。一识识。一切随眠随增。地狱趣。十八界十二处五蕴摄。七智知。除类灭道智。六识识。欲界一切随眠随增。傍生趣鬼趣人趣亦尔。天趣。十八界十二处五蕴摄。八智知。除灭道智。六识识。三界一切随眠随增。见苦所断烦恼部。一界一处一蕴摄。八智知。除灭道智。一识识。三界见苦所断一切。及见集所断遍行随眠随增。见集所断烦恼部。一界一处一蕴摄。八智知。除灭道智。一识识。三界见集所断一切。及见苦所断遍行随眠随增。见灭所断烦恼部。一界一处一蕴摄。八智知。除灭道智。一识识。三界见灭所断一切。及遍行随眠随增。见道所断烦恼部。一界一处一蕴摄。八智知。除灭道智。一识识。三界见道所断一切。及遍行随眠随增。修所断烦恼部。一界一处一蕴摄。八智知。除灭道智。一识识。三界修所断一切。及遍行随眠随增。色法。十一界十一处一蕴摄。八智知。除他心灭智。六识识。欲色界遍行。及修所断随眠随增。心法。七界一处一蕴摄。九智知。除灭智。一识识。一切随眠随增。心所法。一界一处三蕴摄。九智知。除灭智。一识识。一切随眠随增。心不相应行法。一界一处一蕴摄。八智知。除他心灭智。一识识。三界有漏缘随眠随增。无为法。一界一处非蕴摄。六智知。除他心苦集道智。一识识。非随眠随增

地界。一界一处一蕴摄。七智知。除他心灭道智。二识识。欲色界遍行。及修所断随眠随增。水火风空界亦尔。识界。七界一处一蕴摄。八智知。除灭道智。一识识。一切随眠随增。见苦所断法。三界二处四蕴摄。八智知。除灭道智。一识识。三界见苦所断一切。及见集所断遍行随眠随增。见集所断法。三界二处四蕴摄。八智知。除灭道智。一识识。三界见集所断一切。及见苦所断遍行随眠随增。见灭所断法。三界二处四蕴摄。八智知。除灭道智。一识识。三界见灭所断一切。及遍行随眠随增。见道所断法。三界二处四蕴摄。八智知。除灭道智。一识识。三界见道所断一切。及遍行随眠随增。修所断法。十八界十二处五蕴摄。八智知。除灭道智。六识识。三界修所断一切。及遍行随眠随增。非所断法。三界二处五蕴摄八智知。除苦集智。一识识。非随眠随增

欲贪随眠。及嗔随眠。一界一处一蕴摄。七智知。除类灭道智。一识识。欲界有漏缘随眠随增。有贪随眠。一界一处一蕴摄。七智知。除法灭道智。一识识。色无色界有漏缘随眠随增。慢随眠。一界一处一蕴摄。八智知。除灭道智。一识识。三界有漏缘随眠随增。无明随眠。一界一处一蕴摄。八智知。除灭道智。一识识。除无漏缘无明。诸余一切随眠随增。见随眠。一界一处一蕴摄。八智知。除灭道智。一识识。三界见所断有漏缘。及无漏缘见相应无明随眠随增。疑随眠。一界一处一蕴摄。八智知。除灭道智。一识识。三界见所断有漏缘。及无漏缘疑相应无明随眠随增

初识住。十八界十二处五蕴摄。七智知。除类灭道智。六识识。欲界一切随眠随增。第二识住。十四界十处五蕴摄。七智知。除法灭道智。四识识。色界一切随眠随增。第三第四识住。十一界十处五蕴摄。七智知。除法灭道智。四识识。色界一切随眠随增。第五第六第七识住。三界二处四蕴摄。六智知。除法他心灭道智。一识识。无色界一切随眠随增

说一切有部品类足论卷第九阿毗达磨品类足论卷第十

        尊者世友造

        三藏法师玄奘奉　诏译

    辩摄等品第六之余

七等觉支。若别一界一处一蕴摄。若总一界一处二蕴摄。七智知。除苦集灭智。一识识。非随眠随增。初第二第三解脱。三界二处五蕴摄。七智知。除法灭道智。一识识。色界遍行。及修所断随眠随增。第四第五第六解脱。三界二处四蕴摄。七智知。除法他心灭智。一识识。无色界遍行。及修所断随眠随增。第七解脱。三界二处四蕴摄。六智知。除法他心灭道智。一识识。无色界遍行。及修所断随眠随增。想受灭解脱。一界一处一蕴摄。六智知。除法他心灭道智。一识识。无色界遍行。及修所断随眠随增。八胜处。三界三处五蕴摄。七智知。除法灭道智。一识识。色界遍行。及修所断随眠随增。八圣道支中。正语。正业。一命。一界一处一蕴摄。六智知。除他心苦集灭智。一识识。非随眠随增。余五圣道支。一界一处一蕴摄。七智知。除苦集灭智。一识识。非随眠随增

爱结慢结。一界一处一蕴摄。八智知。除灭道智。一识识。三界有漏缘随眠随增。恚结。一界一处一蕴摄。七智知。除类灭道智。一识识。欲界有漏缘随眠随增。无明结。一界一处一蕴摄。八智知。除灭道智。一识识。除无漏缘无明。诸余一切随眠随增。见结。一界一处一蕴摄。八智知。除灭道智。一识识。三界见所断有漏缘。及无漏缘见相应无明随眠随增。取结。一界一处一蕴摄。八智知。除灭道智。一识识。三界见所断有漏缘随眠随增。疑结。一界一处一蕴摄。八智知。除灭道智。一识识。三界见所断有漏缘。及无漏缘疑相应无明随眠随增。嫉结悭结。一界一处一蕴摄。七智知。除类灭道智。一识识。欲界遍行。及修所断随眠随增。初有情居。十八界十二处五蕴摄。七智知。除类灭道智。六识识。欲界一切随眠随增。第二有情居。十四界十处五蕴摄。七智知。除法灭道智。四识识。色界一切随眠随增。第三第四第五有情居。十一界十处五蕴摄。七智知。除法灭道智。四识识。色界一切随眠随增。余四有情居。三界二处四蕴摄。六智知。除法他心灭道智。一识识。无色界一切随眠随增

前八遍处。三界二处五蕴摄。七智知。除法灭道智。一识识色界遍行。及修所断随眠随增。后二遍处。三界二处四蕴摄。六智知。除法他心灭道智。一识识。无色界遍行。及修所断随眠随增。十无学法中。正语。正业。正命。一界一处一蕴摄。六智知。除他心苦集灭智。一识识。非随眠随增。余七无学法。一界一处一蕴摄。七智知。除苦集灭智。一识识。非随眠随增。有漏色。十一界十一处一蕴摄。七智知。除他心灭道智。六识识。欲色界遍行。及修所断随眠随增。有漏受想行。一界一处一蕴摄。八智知。除灭道智。一识识。一切随眠随增。有漏识。七界一处一蕴摄。八智知。除灭道智。一识识。一切随眠随增。无漏色。一界一处一蕴摄。六智知。除他心苦集灭智。一识识。非随眠随增。无漏受想行。一界一处一蕴摄。七智知。除苦集灭智。一识识。非随眠随增。无漏识。二界一处一蕴摄。七智知。除苦集灭智。一识识。非随眠随增。无为法。一界一处非蕴摄。六智知。除他心苦集道智。一识识。非随眠随增。眼处。一界一处一蕴摄。七智知。除他心灭道智。一识识。欲色界遍行及修所断随眠随增。如眼处。耳鼻舌身处亦尔。色处。一界一处一蕴摄。七智知。除他心灭道智。二识识。欲色界遍行。及修所断随眠随增。如色处。声触处亦尔。香处味处。一界一处一蕴摄。六智知。除类他心灭道智。二识识。欲界遍行。及修所断随眠随增。意处。七界一处一蕴摄。九智知。除灭智。一识识。一切随眠随增。法处。一界一处四蕴摄。七智知。一识识。一切随眠随增

眼界。一界一处一蕴摄。七智知。除他心灭道智。一识识。欲色界遍行。及修所断随眠随增。耳鼻舌身界亦尔。色界。一界一处一蕴摄。九智知。除他心灭道智。二识识。欲色界遍行。及修所断随眠随增声触界亦尔。香界味界。一界一处一蕴摄。六智知。除类他心灭道智。二识识。欲界遍行。及修所断随眠随增。意界。七界一处一蕴摄。九智知。除灭智。一识识。一切随眠随增。法界。一界一处四蕴摄。十智知。一识识。一切随眠随增。眼识界。二界一处一蕴摄。八智知。除灭道智。一识识。欲色界遍行。及修所断随眠随增。耳身识界亦尔。鼻舌识界。二界一处一蕴摄。七智知。除类灭道智。一识识。欲界遍行。及修所断随眠随增。意识界。二界一处二蕴摄。九智知。除灭智。一识识。一切随眠随增

眼根。一界一处一蕴摄。七智知。除他心灭道智。一识识。欲色界遍行。及修所断随眠随增。耳鼻舌身根亦尔。女根男根。一界一处一蕴摄。六智知。除类他心灭道智。一识识。欲界遍行。及修所断随眠随增。命根。一界一处一蕴摄。七智知。除他心灭道智。一识识。三界遍行。及修所断随眠随增。意根。七界一处一蕴摄。九智知。除灭智。一识识。一切随眠随增。乐根。一界一处一蕴摄。九智知。除灭智。一识识。色界一切。欲界遍行。及修所断随眠随增。苦根一界一处一蕴摄。七智知。除类灭道智。一识识。欲界遍行。及修所断随眠随增。喜根。一界一处一蕴摄。九智知。除灭智。一识识。色界一切。除欲界无漏缘疑及彼相应无明。诸余欲界一切随眠随增。忧根。一界一处一蕴摄。七智知。除类灭道智。一识识。欲界一切随眠随增。舍根。一界一处一蕴摄。九智知。除灭智。一识识。一切随眠随增。信根。一界一处一蕴摄。九智知。除灭智。一识识。三界遍行。及修所断随眠随增。精进念定慧根亦尔。未知当知根。三界二处二蕴摄。七智知。除苦集灭智。一识识。非随眠随增。已知根具知根亦尔

欲界系有身见随眠。一界一处一蕴摄。七智知。除类灭道智。一识识。欲界见苦所断一切。及见集所断遍行。随眠随增。欲界系边执见。及见苦所断。余八随眠亦尔。欲界系见集所断邪见随眠。一界一处一蕴摄。七智知。除类灭道智。一识识。欲界见集所断一切。及见苦所断遍行。随眠随增。欲界系见集所断。余六随眠亦尔。欲界系见灭所断邪见随眠。一界一处一蕴摄。七智知。除类灭道智。一识识。欲界见灭所断有漏缘。及邪见相应无明。并遍行。随眠随增。欲界系见灭所断见取随眠。一界一处一蕴摄。七智知。除类灭道智。一识识。欲界见灭所断有漏缘。及遍行随眠随增。欲界系见灭所断贪嗔慢随眠亦尔。欲界系见灭所断疑随眠。一界一处一蕴摄。七智知。除类灭道智。一识识。欲界见灭所断有漏缘。及疑相应无明。并遍行随眠随增。欲界系见灭所断无明随眠。一界一处一蕴摄。七智知。除类灭道智。一识识。除欲界见灭所断无漏缘无明。诸余欲界见灭所断一切。及遍行随眠随增。欲界系见道所断邪见随眠。一界一处一蕴摄。七智知。除类灭道智。一识识。欲界见道所断有漏缘。及邪见相应无明。并遍行随眠随增。欲界系见道所断见取随眠。一界一处一蕴摄。七智知。除类灭道智。一识识。欲界见道所断有漏缘。及遍行随眠随增。欲界系见道所断戒禁取贪嗔慢随眠亦尔。欲界系见道所断疑随眠。一界一处一蕴摄。七智知。除类灭道智。一识识。欲界见道所断有漏缘。及疑相应无明。并遍行随眠随增。欲界系见道所断无明随眠。一界一处一蕴摄。七智知。除类灭道智。一识识。除欲界见道所断无漏缘无明。诸余欲界见道所断一切。及遍行随眠随增。欲界系修所断贪随眠。一界一处一蕴摄。七智知。除类灭道智。一识识。欲界修所断一切。及遍行随眠随增。欲界系修所断嗔慢无明随眠亦尔。色界系有身见随眠。一界一处一蕴摄。七智知。除法灭道智。一识识。色界见苦所断一切。及见集所断遍行随眠随增。色界系边执见。及见苦所断。余七随眠亦尔。色界系见集所断邪见随眠。一界一处一蕴摄。七智知。除法灭道智。一识识。色界见集所断一切。及见苦所断遍行随眠随增。色界系见集所断余五随眠亦尔。色界系见灭所断邪见随眠。一界一处一蕴摄。七智知。除法灭道智。一识识。色界见灭所断有漏缘。及邪见相应无明。并遍行随眠随增。色界系见灭所断见取随眠。一界一处一蕴摄。七智知。除法灭道智。一识识。色界见灭所断有漏缘。及遍行随眠随增。色界系见灭所断贪慢随眠亦尔。色界系见灭所断疑随眠。一界一处一蕴摄。七智知。除法灭道智。一识识。色界见灭所断有漏缘。及疑相应无明。并遍行随眠随增。色界系见灭所断无明随眠。一界一处一蕴摄。七智知。除法灭道智。一识识。除色界见灭所断无漏缘无明。诸余色界见灭所断一切。及遍行随眠随增。色界系见道所断邪见随眠。一界一处一蕴摄。七智知。除法灭道智。一识识。色界见道所断有漏缘。及邪见相应无明。并遍行随眠随增。色界系见道所断见取随眠。一界一处一蕴摄。七智知。除法灭道智。一识识。色界见道所断有漏缘。及遍行随眠随增。色界系见道所断戒禁取贪慢随眠亦尔。色界系见道所断疑随眠。一界一处一蕴摄。七智知。除法灭道智。一识识。色界见道所断有漏缘。及疑相应无明。并遍行随眠随增。色界系见道所断无明随眠。一界一处一蕴摄。七智知。除法灭道智。一识识。除色界见道所断无漏缘无明。诸余色界见道所断一切。及遍行随眠随增。色界系修所断贪随眠。一界一处一蕴摄。七智知。除法灭道智。一识识。色界修所断一切。及遍行随眠随增。色界系修所断慢无明随眠亦尔。如色界系三十一随眠。应知无色界系三十一随眠亦尔。差别者。六智知。除法他心灭道智

    品类足论辩千问品第七之一

  学处净果行圣种　　正断神足念住谛
  静虑无量无色定　　觉分根处蕴界经

学处。谓近事五学处。净谓四证净。果谓四沙门果。行谓四通行。圣种谓四圣种。正断谓四正断。神足谓四神足。念住谓四念住。谛谓四圣谛。静虑谓四静虑。无量谓四无量。无色谓四无色。定谓四修定。觉分谓七等觉支。根谓二十二根。处谓十二处。蕴谓五蕴。界谓十八界。经谓颂中。前九后九及。各总为一合。有二十经。依一一经为前五十问

且依近事五学处经。为五十问。谓五学处。几有色几无色。几有见几无见。几有对几无对。几有漏几无漏。几有为几无为。几有异熟几无异熟。几是缘生是因生是世摄。几非缘生非因生非世摄。几色摄。几名摄。几内处摄。几外处摄。几智遍知所遍知。几非智遍知所遍知

几断遍知所遍知。几非断遍知所遍知。几应断几不应断。几应修几不应修。几染污几不染污。几果非有果。几有果非果。几果亦有果。几非果非有果。几有执受。几无执受。几大种所造。几非大种所造。几有上几无上。几是有几非有。几因相应。几因不相应

有六摄善处。谓善五蕴及择灭。为六善处摄五学处。为五学处摄六善处。有五摄不善处。谓不善五蕴。为五不善处摄五学处。为五学处摄五不善处。有七摄无记处。谓无记五蕴。及虚空非择灭。为七无记处摄五学处。为五学处摄七无记处。有三摄漏处。谓欲漏有漏无明漏。为三漏处摄五学处。为五学处摄三漏处。有五摄有漏处。谓有漏五蕴。为五有漏处摄五学处。为五学处摄五有漏处。有八摄无漏处。谓无漏五蕴。及三无为。为八无漏处摄五学处。为五学处摄八无漏处。此五学处。几过去几未来几现在。几非过去非未来非现在。几善几不善几无记。几欲界系。几色界系。几无色界系。几不系。几学几无学。几非学非无学

几见所断。几修所断。几非所断。几非心非心所非心相应。几是心所与心相应。几唯是心。几随心转非受相应。几受相应非随心转。几随心转亦受相应。几非随心转非受相应。几随心转非想行相应。几想行相应非随心转。几随心转亦想行相应。几非随心转非想行相应。几随寻转非伺相应。几伺相应非随寻转。几随寻转亦伺相应。几非随寻转非伺相应。几见非见处。几见处非见。几见亦见处。几非见非见处。几有身见为因非有身见因。几有身见因非有身见为因。几有身见为因亦有身见因。几非有身见为因非有身见因。几业非业异熟。几业异熟非业。几业亦业异熟。几非业非业异熟。几业非随业转。几随业转非业。几业亦随业转。几非业非随业转。几所造色非有见色。几有见色非所造色。几所造色亦有见色。几非所造色非有见色

几所造色非有对色。几有对色非所造色。几所造色亦有对色。几非所造色非有对色。几难见故甚深。几甚深故难见。几善非善为因。几善为因非善。几善亦善为因。几非善非善为因。几不善非不善为因。几不善为因非不善。几不善亦不善为因。几非不善非不善为因。几无记非无记为因。几无记为因非无记。几无记亦无记为因。几非无记非无记为因。几因缘非有因。几有因非因缘。几因缘亦有因。几非因缘非有因。几等无间非等无间缘。几等无间缘非等无间。几等无间亦等无间缘。几非等无间非等无间缘。几所缘缘非有所缘。几有所缘非所缘缘。几所缘缘亦有所缘。几非所缘缘非有所缘。几增上缘非有增上。几有增上非增上缘。几增上缘亦有增上。几非增上缘非有增上。几瀑流非顺瀑流。几顺瀑流非瀑流。几瀑流亦顺瀑流。几非瀑流非顺瀑流。如依学处为五十问。依余十九为问亦尔

五学处者。一尽形寿离断生命。二尽形寿离不与取。三尽形寿离欲邪行。四尽形寿离虚诳语。五尽形寿离饮诸酒。此五名为近事学处。此五学处。几有色等者。一切是有色。几有见等者。一无见。四应分别。谓若表是有见。若无表是无见。几有对等者。一切应分别。谓若表是有对。若无表是无对。几有漏等者。一切是有漏。几有为等者。一切是有为。几有异熟等者。一切有异熟。几是缘生等者。一切是缘生是因生是世摄。几色摄等者。一切是色摄。几内处摄等者。一切外处摄。几智遍知所遍知等者。一切是智遍知所遍知

此五学处。几断遍知所遍知等者。一切是断遍知所遍知。几应断等者。一切是应断。几应修等者。一切是应修。几染污等者。一切不染污。几果非有果等者。一切是果亦有果。几有执受等者。一切无执受。几大种所造等者。一切是大种所造。几有上等者。一切是有上。几是有等者。一切是有。几因相应等者。一切因不相应

此五学处。与六善处相摄者。一善处少分摄五学处。五学处亦摄一善处少分。与五不善处相摄者。互不相摄。与七无记处相摄者。互不相摄。与三漏处相摄者。互不相摄。与五有漏处相摄者。一有漏处少分摄五学处。五学处亦摄一有漏处少分。与八无漏处相摄者。互不相摄。几过去等者。一切或过去或未来或现在。几善等者。一切是善。几欲界系等者。一切欲界系。几学等者。一切非学非无学

此五学处。几见所断等者。一切修所断。几非心等者。一切非心非心所非心相应。几随心转非受相应等者。一切非随心转非受相应。几随心转非想行相应等者。一切非随心转非想行相应。几随寻转非伺相应等者。一切非随寻转非伺相应。几见非见处等者。一切是见处非见。几有身见为因非有身见因等者。一切非有身见为因非有身见因。几业非业异熟等者。一切是业非业异熟。几业非随业转等者。一切是业非随业转。几所造色非有见色等者。一是所造色非有见色。四应分别。谓若表是所造色。亦有见色。若无表是所造色。非有见色

此五学处。几所造色非有对色等者。一切应分别。谓若表。是所造色。亦有对色。若无表。是所造色。非有对色。几难见故甚深等者。一切难见故甚深。甚深故难见。几善非善为因等者。一切是善亦善为因。几不善非不善为因等者。一切非不善非不善为因。几无记非无记为因等者。一切非无记非无记为因。几因缘非有因等者。一切是因缘亦有因。几等无间非等无间缘等者。一切非等无间非等无间缘。几所缘缘非有所缘等者。一切是所缘缘非有所缘。几增上缘非有增上等者。一切是增上缘亦有增上。几瀑流非顺瀑流等者。一切顺瀑流非瀑流

四证净者。谓佛证净。法证净。僧证净。圣所爱戒证净。此四证净。几有色等者。一有色。三无色。几有见等者。一切是无见。几有对等者。一切是无对。几有漏等者。一切是无漏。几有为等者。一切是有为。几有异熟等者。一切无异熟。几是缘生等者。一切是缘生是因生是世摄。几色摄等者。一是色摄。三是名摄。几内处摄等者。一切外处摄。几智遍知所遍知等者。一切是智遍知所遍知

此四证净。几断遍知所遍知等者。一切非断遍知所遍知。几应断等者。一切不应断。几应修等者。一切是应修。几染污等者。一切不染污。几果非有果等者。一切是果亦有果。几有执受等者。一切无执受。几大种所造等者。一是大种所造。三非大种所造。几有上等者。一切是有上。几是有等者。一切非有。几因相应等者。一因不相应。三因相应

此四证净。与六善处相摄者。二善处少分摄四证净。四证净亦摄二善处少分。与五不善处相摄者。互不相摄。与七无记处相摄者。互不相摄。与三漏处相摄者。互不相摄。与五有漏处相摄者。互不相摄。与八无漏处相摄者。一无漏处全。一无漏处少分。摄四证净。四证净亦摄一无漏处全一无漏处少分。几过去等者。一切或过去或未来或现在。几善等者。一切是善。几欲界系等者。一切是不系。几学等者。一切应分别。谓佛证净。或学或无学。云何学。谓学作意相应佛证净。云何无学。谓无学作意相应证佛净。法僧证净亦尔。圣所爱戒证净。或学或无学。云何学。谓学身语业。云何无学。谓无学身语业

此四证净。几见所断等者。一切非所断。几非心等者。一非心非心法非心相应。三是心所与心相应。几随心转非受相应等者。一随心转。非受相应。三随心转。亦受相应。几随心转非想行相应等者。一随心转。非想相应。三随心转。亦想相应。一随心转。非行相应。三随心转。亦行相应。除其自性。几随寻转非伺相应等者。一切应分别。谓佛证净。或有寻有伺。或无寻唯伺。或无寻无伺。云何有寻有伺。谓有寻有伺作意相应佛证净。云何无寻唯伺。谓无寻唯伺作意相应佛证净。云何无寻无伺。谓无寻无伺作意相应佛证净。法僧证净亦尔。圣所爱戒证净。或随寻转非伺相应。或非随寻转非伺相应。云何随寻转非伺相应。谓随寻转无漏身语业。云何非随寻转非伺相应。谓不随寻转无漏身语业。几见非见处等者。一切非见非见处。几有身见为因。非有身见因等者。一切非有身见为因非有身见因。几业非业异熟等者。一是业非业异熟。三非业非业异熟。几业非随业转等者。一是业亦随业转。三随业转非业。几所造色非有见色等者。一是所造色非有见色。三非所造色非有见色

说一切有部品类足论卷第十阿毗达磨品类足论卷第十一

        尊者世友造

        三藏法师玄奘奉　诏译

    辩千问品第七之二

此四证净。几所造色非有对色等者。一是所造色非有对色。三非所造色非有对色。几难见故甚深等者。一切难见故甚深。甚深故难见。几善非善为因等者。一切是善亦善为因。几不善非不善为因等者。一切非不善非不善为因。几无记非无记为因等者。一切非无记非无记为因。几因几非有因等者。一切是因缘亦有因。几等无间非等无间缘等者。一非等无间非等无间缘。三应分别。谓佛证净。或是等无间非等无间缘。或是等无间亦等无间缘。或非等无间非等无间缘。云何是等无间非等无间缘。谓未来现前正起佛证净。云何是等无间亦等无间缘。谓过去现在佛证净。云何非等无间非等无间缘。谓除未来现前正起佛证净。诸余未来佛证净法僧证净亦尔。几所缘缘非有所缘等者。一是所缘缘非有所缘。三是所缘缘亦有所缘。几增上缘非有增上等者。一切是增上缘。亦有增上。几暴流非顺暴流等者。一切非暴流非顺暴流。四沙门果者。谓预流果。一来果。不还果。阿罗汉果。此四沙门果。几有色等者。一切应分别。谓沙门果所摄身语业。是有色。余皆无色。几有见等者。一切是无见。几有对等者。一切是无对。几有漏等者。一切是无漏。几有为等者。一切应分别。谓预流果。或有为或无为。云何有为。谓预流果所摄五蕴。云何无为。谓预流果所摄择灭。一来不还阿罗汉果亦尔。几有异熟等者。一切无异熟。几是缘生等者。一切应分别。谓有为沙门果。是缘生是因生是世摄。若无为沙门果。非缘生非因生非世摄。几色摄等者。一切应分别。谓沙门果所摄身语业。是色摄。余皆是名摄。几内处摄等者。一切应分别。谓沙门果所摄心意识。是内处摄。余皆是外处摄。几智遍知所遍知等者。一切是智遍知所遍知

此四沙门果。几断遍知所遍知等者。一切非断遍知所遍知。几应断等者。一切不应断。几应修等者。一切应分别。谓有为沙门果。是应修。若无为沙门果。不应修。几染污等者。一切不染污。几果非有果等者。一切应分别。谓有为沙门果。是果亦有果。若无为沙门果。是果非有果。几有执受等者。一切无执受。几大种所造等者。一切应分别。谓沙门果所摄身语业。是大种所造。余皆非大种所造。几有上等者。一切应分别。谓有为沙门果是有上。若无为沙门果是无上。几是有等者。一切非有。几因相应等者。一切应分别。谓沙门果所摄身语业。心不相应行。及择灭因不相应。余皆因相应

此四沙门果。与六善处相摄者。六善处少分摄四沙门果。四沙门果亦摄六善处少分。与五不善处相摄者。互不相摄。与七无记处相摄者。互不相摄。与三漏处相摄者。互不相摄。与五有漏处相摄者。互不相摄。与八无漏处相摄者。八六无漏处少分摄四沙门果。四沙门果亦摄八六无漏处少分。几过去等者。一切应分别。谓有为沙门果。或过去或未来或现在。若无为沙门果。非过去非未来非现在。几善等者。一切是善。几欲界系等者。一切是不系。几学等者。一切应分别。谓预流果。或学或非学非无学。云何学。谓有为预流果。云何非学非无学。谓无为预流果。一来不还果亦尔。阿罗汉果。或无学或非学非无学。云何无学。谓有为阿罗汉果。云何非学非无学。谓无为阿罗汉果

此四沙门果几见所断等者。一切非所断。几非心等者。一切应分别。谓沙门果所摄身语业。心不相应行及择灭。非心非心所非心相应。若受蕴想蕴。及相应行蕴。是心所与心相应。若心意识。唯是心。几随心转非受相应等者。一切应分别。谓预流果有四句。或随心转非受相应。谓预流果所摄身语业。及随心转。心不相应行。并受或受相应非随心转。谓预流果所摄心意识。或随心转亦受相应。谓预流果摄想蕴。及相应行蕴。或非随心转非受相应。谓除预流果摄随心转心不相应行。诸余预流果摄心不相应行及择灭。一来不还阿罗汉果亦尔。几随心转非想行相应等者。一切应分别。谓除自性。如受应知。几随寻转非伺相应等者。一切应分别。谓预流果有四句。或随寻转非伺相应。谓预流果所摄身语业。及随寻转心不相应行。并伺或伺相应非随寻转。谓预流果所摄寻。或随寻转亦伺相应。谓预流果所摄寻伺相应心心所法。或非随寻转非伺相应。谓除预流果所摄随寻转心不相应行。诸余预流果所摄心不相应行及择灭。一来果亦尔。不还果有四句。或随寻转非伺相应。谓不还果所摄随寻转身语业。及随寻转心不相应行。并寻相应伺。或伺相应非随寻转。谓不还果所摄寻。及寻不相应伺相应心心所法。或随寻转亦伺相应。谓不还果所摄寻伺相应心心所法。或非随寻转非伺相应。谓除不还果所摄随寻转身语业。心不相应行。诸余不还果所摄身语业。心不相应行。及不还果所摄寻不相应伺。若无寻无伺心心所法。并择灭。阿罗汉果亦尔。几见非见处等者。一切应分别。谓预流果所摄慧是见非见处。余皆非见非见处。一来不还果亦尔。阿罗汉果所摄尽无生智。所不摄慧。是见非见处。余皆非见非见处。几有身见为因非有身见因等者。一切非有身见为因非有身见因。几业非业异熟等者。一切应分别。谓沙门果所摄身语业及思。是业非业异熟。余皆非业非业异熟。几业非随业转等者。一切应分别。谓预流果有四句。或业非随业转。谓预流果所摄思。或随业转非业。谓预流果所摄受想识蕴。及思所不摄随业转行蕴。或业亦随业转。谓预流果所摄身语业。或非业非随业转。谓除预流果所摄随业转心不相应行。诸余预流果所摄心不相应行。及择灭。一来不还阿罗汉果亦尔。几所造色非有见色等者。一切应分别。谓沙门果所摄身语业。是所造色非有见色。余皆非所造色。非有见色

此四沙门果。几所造色非有对色等者。一切应分别。谓沙门果所摄身语业。是所造色非有对色。余皆非所造色非有对色。几难见故甚深等者。一切难见故甚深。甚深故难见。几善非善为因等者。一切应分别。谓有为沙门果。是善亦善为因。若无为沙门果。是善非善为因。几不善非不善为因等者。一切非不善非不善为因。几无记非无记为因等者。一切非无记非无记为因。几因缘非有因等者。一切应分别。若有为沙门果。是因缘亦有因。若无为沙门果。非因缘非有因。几等无间非等无间缘等者。一切应分别。谓沙门果。或是等无间非等无间缘。或是等无间亦等无间缘。或非等无间非等无间缘。是等无间非等无间缘者。谓未来现前正起沙门果所摄心心所法。是等无间亦等无间缘者。谓过去现在沙门果所摄心心所法。非等无间非等无间缘者。谓除未来现前正起沙门果所摄心心所法。诸余未来沙门果所摄心心所法。及身语业心不相应行。并择灭。几所缘缘非有所缘等者。一切应分别。谓沙门所摄身语业心不相应行。及择灭。是所缘缘非有所缘。余皆是所缘缘亦有所缘。几增上缘非有增上等者。一切应分别。谓有为沙门果。是增上缘亦有增上。若无为沙门果。是增上缘非有增上。几暴流非顺暴流等者。一切非暴流非顺暴流

四通行者。谓有苦迟通行。有苦速通行。有乐迟通行。有乐速通行。此四通行。几有色等者。一切应分别。谓通行所摄身语业是有色。余皆是无色。几有见等者。一切是无见。几有对等者。一切是无对。几有漏等者。一切是无漏。几有为等者。一切是有为。几有异熟等者。一切无异熟。几是缘生等者。一切是缘生是因生是世摄。几色摄等者。一切应分别。谓通行所摄身语业是色摄。余皆是名摄。几内处摄等者。一切应分别。谓通行所摄心意识内处摄。余皆外处摄。几智遍知所遍知等者。一切是智遍知所遍知

此四通行。几断遍知所遍知等者。一切非断遍知所遍知。几应断等者。一切不应断。几应修等者。一切是应修。几染污等者。一切不染污。几果非有果等者。一切是果亦有果。几有执受等者。一切无执受。几大种所造等者。一切应分别。谓通行所摄身语业。是大种所造。余皆非大种所造。几有上等者。一切是有上。几是有等者。一切非有。几因相应等者。一切应分别。谓通行所摄身语业。心不相应行。因不相应。余皆因相应

此四通行与六善处相摄者。五善处少分摄四通行。四通行亦摄五善处少分。与五不善处相摄者。互不相摄。与七无记处相摄者。互不相摄。与三漏处相摄者。互不相摄。与五有漏处相摄者。互不相摄。与八无漏处相摄者。五无漏处摄四通行。四通行亦摄五无漏处。几过去等者。一切或过去或未来或现在。几善等者。一切是善。几欲界系等者。一切是不系。几学等者。一切应分别。谓四通行。或学或无学。云何学。谓学五蕴。云何无学。谓无学五蕴

此四通行几见所断等者。一切非所断。几非心等者。一切应分别。谓通行所摄身语业。心不相应行。非心非心所非心相应。若受蕴想蕴相应行蕴。是心所与心相应。若心意识。唯是心几随心转非受相应等者。一切应分别。谓诸通行。各有四句。或随心转非受相应。谓通行所摄身语业。及随心转心不相应行并受。或受相应非随心转。谓通行所摄心意识。或随心转亦受相应。谓通行所摄想蕴及相应行蕴。或非随心转非受相应。谓除通行所摄随心转心不相应行。诸除通行所摄心不相应行。几随心转非想行相应等者。一切应分别。谓除其自性。如受应知。几随寻转非伺相应等者。一切应分别。谓苦迟通行有四句。或随寻转非伺相应。谓苦迟通行所摄随寻转身语业心不相应行。及寻相应伺。或伺相应非随寻转。谓苦迟通行所摄寻。及寻不相应伺相应心心所法。或随寻转亦伺相应。谓苦迟通行所摄寻伺相应心心所法。或非随寻转非伺相应。谓除苦迟通行所摄随寻转身语业心不相应行。诸余苦迟通行所摄身语业心不相应行。及寻不相应伺。并无寻无伺心心所法。苦速通行亦尔。乐迟通行亦有四句。或随寻转非伺相应。谓乐迟通行所摄随寻转身语业心不相应行及伺。或伺相应非随寻转。谓乐迟通行所摄寻。或随寻转亦伺相应。谓乐迟通行所摄寻伺相应心心所法。或非随寻转非伺相应。谓除乐迟通行所摄随寻转身语业心不相应行。诸余乐迟通行所摄身语业心不相应行。及无寻无伺心心所法。乐速通行亦尔。几见非见处等者。一切应分别。谓通行所摄尽无生智所不摄慧。是见非见处。余皆非见非见处。几有身见为因非有身见因等者。一切非有身见为因非有身见因。几业非业异熟等者。一切应分别。谓通行所摄身语业及思。是业非业异熟。余皆非业非业异熟。几业非随业转等者。一切应分别。谓诸通行。各有四句。或业非随业转。谓通行所摄思。或随业转非业。谓通行所摄受想识蕴。及思所不摄随业转行蕴。或业亦随业转。谓通行所摄身语业。或非业非随业转。谓除通行所摄随业转心不相应行。诸余通行所摄心不相应行。几所造色非有见色等者。一切应分别。谓通行所摄身语业。是所造色非有见色。余皆非所造色非有见色

此四通行。几所造色非有对色等者。一切应分别。谓通行所摄身语业。是所造色非有对色。余皆非所造色非有对色。几难见甚深等者。一切难见故甚深。甚深故难见。几善非善为因等者。一切是善亦善为因。几不善非不善为因等者。一切非不善非不善为因。几无记非无记为因等者。一切非无记非无记为因。几因缘非有因等者。一切是因缘亦有因。几等无间非等无间缘等者。一切应分别。谓诸通行。或是等无间非等无间缘。或是等无间亦等无间缘。或非等无间非等无间缘。是等无间非等无间缘者。谓未来现前正起通行所摄心心所法。是等无间亦等无间缘者。谓过去现在通行所摄心心所法。非等无间非等无间缘者。谓除未来现前正起通行所摄心心所法。诸余未来通行所摄心心所法。及通行所摄身语业心不相应行。几所缘缘非有所缘等者。一切应分别。谓通行所摄身语业心不相应行。是所缘缘非有所缘。余皆是所缘缘亦有所缘。几增上缘非有增上等者。一切是增上缘亦有增上。几暴流非顺暴流等者。一切非暴流非顺暴流

四圣种者。谓随所得衣喜足圣种。随所得食喜足圣种。随所得卧具喜足圣种。乐断乐修圣种。此四圣种。几有色等者。一切应分别。谓圣种所摄身语业是有色。余皆是无色。几有见等者。一切是无见。几有对等者。一切是无对。几有漏等者。一切应分别。谓诸圣种。或有漏。或无漏。云何有漏。谓圣种所摄有漏五蕴。云何无漏。谓无漏五蕴。几有为等者。一切是有为。几有异熟等者。一切应分别。谓诸圣种。若有漏有异熟。若无漏无异熟。几是缘生等者。一切是缘生是因生是世摄。几色摄等者。一切应分别。谓圣种所摄身语业是色摄。余皆是名摄。几内处摄等者。一切应分别。谓圣种所摄心意识内处摄。余皆外处摄。几智遍知所遍知等者。一切是智遍知所遍知。此四圣种。几断遍知所遍知等者。一切应分别。谓诸圣种。若有漏是断遍知所遍知。若无漏非断遍知所遍知。几应断等者。一切应分别。谓诸圣种。若有漏是应断。若无漏不应断。几应修等者。一切是应修。几染污等者。一切不染污。几果非有果等者。一切是果亦有果。几有执受等者。一切无执受。几大种所造等者。一切应分别。谓圣种所摄身语业。是大种所造。余皆非大种所造。几有上等者。一切是有上。几是有等者。一切应分别。谓诸圣种。若有漏是有。若无漏非有。几因相应等者。一切应分别。谓圣种所摄身语业心不相应行因不相应。余皆因相应

此四圣种。与六善处相摄者。五善处少分摄四圣种。四圣种亦摄五善处少分。与五不善处相摄者。互不相摄。与七无记处相摄者。互不相摄。与三漏处相摄者。互不相摄。与五有漏处相摄者。应作四句。或有漏处非圣种。谓圣种所不摄有漏五蕴。或圣种非有漏处。谓无漏四圣种。或有漏处亦圣种。谓有漏四圣种。或非有漏处非圣种。谓虚空及二灭。与八无漏处相摄者。应作四句。或无漏处非圣种。谓虚空及二灭。或圣种非无漏处。谓有漏四圣种。或无漏处亦圣种。谓无漏四圣种。或非无漏处非圣种。谓圣种所不摄有漏五蕴。几过去等者。一切或过去或未来或现在。几善等者。一切是善。几欲界系等者。一切应分别。谓诸圣种。或欲界系。或色界系。或无色界系。或不系。云何欲界系。谓圣种所摄欲界五蕴。云何色界系。谓圣种所摄色界五蕴。云何无色界系。谓圣种所摄无色界四蕴。云何不系。谓无漏五蕴。几学等者。一切应分别。谓诸圣种。或学或无学。或非学非无学。云何学。谓学五蕴。云何无学。谓无学五蕴。云何非学非无学。谓圣种所摄有漏五蕴

此四圣种几见所断等者。一切应分别。谓诸圣种。若有漏修所断。若无漏非所断。几非心等者。一切应分别。谓圣种所摄身语业心不相应行。非心非心所非心相应。圣种所摄受蕴想蕴相应行蕴。是心所与心相应。圣种所摄心意识唯是心。几随心转非受相应等者。一切应分别。谓诸圣种。各有四句。或随心转非受相应。谓圣种所摄随心转身语业心不相应行及受。或受相应非随心转。谓圣种所摄心意识。或随心转亦受相应。谓圣种所摄想蕴。及相应行蕴。或非随心转非受相应。谓除圣种所摄身语业心不相应行。诸余圣种所摄身语业心不相应行。几随心转非想行相应等者。一切应分别。谓除其自性。如受应知。几随寻转非伺相应等者。一切应分别。谓诸圣种。各有四句。或随寻转非伺相应。谓圣种所摄随寻转身语业心不相应行。及寻相应伺。或伺相应非随寻转。谓圣种所摄寻。及寻不相应伺相应心心所法。或随寻转亦伺相应。谓圣种所摄寻伺相应心心所法。或非随寻转非伺相应。谓除圣种所摄随寻转身语业心不相应行。诸余圣种所摄身语业心不相应行。及寻不相应伺。并无寻无伺心心所法。几见非见处等者。一切应分别。谓诸圣种。各有四句。或见非见处。谓尽无生智所不摄无漏慧。或见处非见。谓见所不摄有漏四圣种。或见亦见处。谓圣种所摄世间正见。或非见非见处。谓见所不摄无漏四圣种。几有身见为因非有身见因等者。一切非有身见为因非有身见因。几业非业异熟等者。一切应分别。谓圣种所摄身语业及思。是业非业异熟。余皆非业非业异熟。几业非随业转等者。一切应分别。谓诸圣种。各有四句。或业非随业转。谓除圣种所摄随业转身语业。诸余圣种所摄身语业及思。或随业转非业。谓圣种所摄受想识蕴。及思所不摄随业转行蕴。或业亦随业转。谓圣种所摄随业转身语业。或非业非随业转。谓除圣种所摄随业转心不相应行。诸余圣种所摄心不相应行。几所造色非有见色等者。一切应分别谓圣种所摄身语业。是所造色非有见色。余皆非所造色非有见色

此四圣种几所造色非有对色等者。一切应分别。谓圣种所摄身语业。是所造色非有对色。余皆非所造色非有对色。几难见故甚深等者。一切难见故甚深。甚深故难见。几善非善为因等者。一切是善亦善为因。几不善非不善为因等者。一切非不善非不善为因。几无记非无记为因等者。一切非无记非无记为因。几因缘非有因等者。一切是因缘亦有因。几等无间非等无间缘等者。一切应分别。谓诸圣种。或是等无间非等无间缘。或是等无间亦等无间缘。或非等无间非等无间缘。是等无间非等无间缘者。谓未来现前正起圣种所摄心心所法。是等无间亦等无间缘者。谓过去现在圣种所摄心心所法。非等无间非等无间缘者。谓除未来现前正起圣种所摄心心所法。诸余未来圣种所摄心心所法。及圣种所摄身语业心不相应行。几所缘缘非有所缘等者。一切应分别。谓圣种所摄身语业心不相应行。是所缘缘非有所缘。余皆是所缘缘亦有所缘。几增上缘非有增上等者。一切是增上缘亦有增上。几暴流非顺暴流等者。一切应分别。谓诸圣种。若有漏是顺暴流非暴流。若无漏非暴流非顺暴流。如四圣种。四正断四神足亦尔

四念住者。谓身念住受念住心念住法念住。身念住云何。谓缘身善有漏无漏慧。受念住云何。谓缘受善有漏无漏慧。心念住云何。谓缘心善有漏无漏慧。法念住云何。谓缘法善有漏无漏慧。此四念住。几有色等者。一切无色。几有见等者。一切无见。几有对等者。一切无对。几有漏等者。一切应分别。诸缘身慧。或有漏。或无漏。云何有漏。谓有漏作意相应缘身慧。云何无漏。谓无漏作意相应缘身慧。缘受心法慧亦尔。几有为等者。一切有为。几有异熟等者。一切应分别。谓诸念住。若有漏有异熟。若无漏无异熟。几是缘生等者。一切是缘生是因生是世摄。几色摄等者。一切是名摄。几内处摄等者。一切外处摄。几智遍知所遍知等者。一切是智遍知所遍知

说一切有部品类足论卷第十一阿毗达磨品类足论卷第十二

        尊者世友造

        三藏法师玄奘奉　诏译

    辩千问品第七之三

此四念住几断遍知所遍知等者。一切应分别。谓诸念住。若有漏是断遍知所遍知。若无漏非断遍知所遍知。几应断等者。一切应分别。谓诸念住。若有漏是应断。若无漏不应断。几应修等者。一切是应修。几染污等者。一切不染污。几果非有果等者。一切是果亦有果。几有执受等者。一切无执受。几大种所造等者。一切非大种所造。几有上等者。一切是有上。几是有等者。一切应分别。谓诸念住。若有漏是有。若无漏非有。几因相应等者。一切因相应

此四念住。与六善处相摄者。一善处少分摄四念住。四念住亦摄一善处少分。与五不善处相摄者。互不相摄。与七无记处相摄者。互不相摄。与三漏处相摄者。互不相摄。与五有漏处相摄者。应作四句。或有漏处非念住。谓有漏色受想识蕴。及念住所不摄有漏行蕴。或念住非有漏处。谓无漏四念住。或有漏处亦念住。谓有漏四念住。或非有漏处非念住。谓无漏色受想识蕴。及念住所不摄无漏行蕴。并无为。与八无漏处相摄者。应作四句。或无漏处非念住。谓无漏色受想识蕴。及念住所不摄无漏行蕴。并无为。或念住非无漏处。谓有漏四念住。或无漏处亦念住。谓无漏四念住。或非无漏处非念住。谓有漏色受想识蕴。及念住所不摄有漏行蕴。几过去等者。一切或过去或未来或现在。几善等者。一切是善。几欲界系等者。一切应分别。谓缘身慧。或欲界系。或色界系。或无色界系。或不系。云何欲界系。谓欲界作意相应缘身慧。云何色界系。谓色界作意相应缘身慧。云何无色界系。谓无色界作意相应缘身慧。云何不系。谓无漏作意相应缘身慧。缘受心法慧亦尔。几学等者。一切应分别。谓缘身慧。或学或无学。或非学非无学。云何学。谓学作意相应缘身慧。云何无学。谓无学作意相应缘身慧。云何非学非无学。谓有漏作意相应缘身慧。缘受心法慧亦尔

此四念住。几见所断等者。一切应分别。谓诸念住。若有漏修所断。若无漏非所断。几非心等者。一切是心所与心相应。几随心转非受相应等者。一切随心转亦受相应。几随心转非想行相应等者。一切随心转亦想相应。一切随心转亦行相应。除其自性。几随寻转非伺相应等者。一切应分别。谓缘身慧。或有寻有伺。或无寻唯伺。或无寻无伺。云何有寻有伺。谓有寻有伺作意相应缘身慧。云何无寻唯伺。谓无寻唯伺作意相应缘身慧。云何无寻无伺。谓无寻无伺作意相应缘身慧。缘受心法慧亦尔。几见非见处等者。一切应分别。谓缘身慧。有四句。或见非见处。谓尽无生智所不摄无漏缘身慧。或见处非见。谓五识身相应善慧。或见亦见处。谓世间正见。或非见非见处。谓见所不摄无漏缘身慧缘受慧。或见非见处。或见亦见处。或非见非见处见非见处者。谓尽无生智所不摄无漏缘受慧。见亦见处者。谓世间正见。非见非见处者。谓见所不摄无漏缘受慧。缘心法慧亦尔。几有身见为因非有身见因等者。一切非有身见为因非有身见因。几业非业异熟等者。一切非业非业异熟。几业非随业转等者。一切随业转非业。几所造色非有见色等者。一切非所造色非有见色

此四念住几所造色非有对色等者。一切非所造色非有对色。几难见故甚深等者。一切难见故甚深。甚深故难见。几善非善为因等者。一切是善亦善为因。几不善非不善为因等者。一切非不善非不善为因。几无记非无记为因等者。一切非无记非无记为因。几因缘非有因等者。一切是因缘亦有因。几等无间非等无间缘等者。一切应分别。谓缘身慧。或是等无间非等无间缘。或是等无间亦等无间缘。或非等无间非等无间缘。是等无间非等无间缘者。谓未来现前正起缘身慧。是等无间亦等无间缘者。谓过去现在缘身慧。非等无间非等无间缘者。谓除未来现前正起缘身慧。诸余未来缘身慧。缘受心法慧亦尔。几所缘缘非有所缘等者。一切是所缘缘亦有所缘。几增上缘非有增上等者。一切是增上缘亦有增上。几暴流非顺暴流等者。一切应分别。谓诸念住。若有漏是顺暴流非暴流。若无漏非暴流非顺暴流

复次身念住云何。谓十色处。及法处所摄色。受念住云何。谓六受身。心念住云何。谓六识身。法念住云何。谓受所不摄非色法处。此四念住几有色等者。一有色三无色。几有见等者。三无见。一应分别。谓身念住。或有见或无见。云何有见。谓一处。云何无见。谓九处。及一处少分。几有对等者。三无对。一应分别。谓身念住。或有对或无对。云何有对。谓十处。云何无对。谓一处少分。几有漏等者。一切应分别。谓身念住。或有漏或无漏。云何有漏。谓十处及一处少分。云何无漏。谓一处少分。受念住或有漏或无漏。云何有漏。谓有漏作意相应受蕴。云何无漏。谓无漏作意相应受蕴。心念住亦尔。法念住或有漏或无漏。云何有漏。谓有漏想行蕴。云何无漏。谓无漏想行蕴。及三无为。几有为等者。三有为。一应分别。谓法念住。或有为或无为。云何有为。谓想行蕴。云何无为。谓三无为。几有异熟等者。一切应分别。谓身念住。或有异熟或无异熟。云何有异熟。谓不善善有漏色蕴。云何无异熟。谓无记无漏色蕴。受心法念住亦尔。几是缘生等者。三是缘生是因生是世摄。一应分别。谓法念住。若有为是缘生是因生是世摄。若无为非缘生非因生非世摄。几色摄等者。一色摄。三名摄。几内处摄等者。一内处摄。二外处摄。一应分别。谓身念住。或内处摄或外处摄。云何内处摄。谓五内处。云何外处摄。谓五外处。及一外处少分。几智遍知所遍知等者。一切是智遍知所遍知

此四念住几断遍知所遍知等者。一切应分别。谓诸念住。若有漏是断遍知所遍知。若无漏非断遍知所遍知。几应断等者。一切应分别。谓诸念住若有漏是应断。若无漏不应断。几应修等者。一切应分别。谓身念住。或应修或不应修。云何应修。谓善色蕴。云何不应修。谓不善无记色蕴。受心念住亦尔。法念住或应修或不应修。云何应修。谓善想行蕴。云何不应修。谓不善无记想行蕴。及三无为。几染污等者。一切应分别。谓身念住。或染污或不染污。云何染污。谓有覆色蕴。云何不染污。谓无覆色蕴。受心法念住亦尔。几果非有果等者。三是果亦有果。一应分别。谓法念住。或是果非有果。或是果亦有果。或非果非有果。是果非有果者。谓择灭。是果亦有果者。谓想行蕴。非果非有果者。谓虚空非择灭。几有执受等者。三无执受。一应分别。谓身念住。或有执受或无执受。云何有执受。谓自体所摄色蕴。云何无执受。谓非自体所摄色蕴。几大种所造等者。三非大种所造。一应分别。谓身念住。或大种所造。或非大种所造。云何大种所造。谓九处。及二处少分。云何非大种所造。谓一处少分。几有上等者。三有上。一应分别。谓法念住。或有上或无上。云何有上。谓想行蕴及虚空非择灭。云何无上。谓择灭。几是有等者。一切应分别。谓诸念住。若有漏是有。若无漏非有。几因相应等者。一因不相应。二因相应。一应分别。谓法念住。若是心所因相应。若非心所因不相应

此四念住与六善处相摄者。六善处摄四念住少分。四念住少分亦摄六善处。与五不善处相摄者。五不善处摄四念住少分。四念住少分亦摄五不善处与。七无记处相摄者。七无记处摄四念住少分。四念住少分亦摄七无记处。与三漏处相摄者。三漏处摄一念住少分。一念住少分亦摄三漏处。与五有漏处相摄者。五有漏处摄四念住少分。四念住少分亦摄五有漏处。与八无漏处相摄者。八无漏处摄四念住少分。四念住少分亦摄八无漏处。几过去等者。三或过去。或未来。或现在。一应分别。谓法念住。若有为或过去或未来或现在。若无为非过去非未来非现在。几善等者。一切应分别。谓身念住。或善或不善或无记。云何善不善。谓三处少分。云何无记。谓八处及二处少分。受念住。或善或不善或无记。云何善。谓善作意相应受蕴。云何不善。谓不善作意相应受蕴。云何无记。谓无记作意相应受蕴。心念住亦尔。法念住。或善或不善或无记。云何善。谓善想行蕴及择灭。云何不善。谓不善想行蕴。云何无记。谓无记想行蕴及虚空非择灭。几欲界系等者。一切应分别。谓身念住。或欲界系或色界系或不系。云何欲界系。谓二处及九处少分。云何色界系谓九处少分。云何不系。谓一处少分。受念住。或欲界系或色界系或无色界系或不系。云何欲界系。谓欲界作意相应受蕴。云何色界系。谓色界作意相应受蕴。云何无色界系。谓无色界作意相应受蕴。云何不系。谓无漏作意相应受蕴。心念住亦尔。法念住。或欲界系或色界系或无色界系或不系。云何欲界系谓欲界想行蕴。云何色界系。谓色界想行蕴。云何无色界系。谓无色界想行蕴。云何不系。谓无漏想行蕴。及无为法。几学等者。一切应分别。谓身念住。或学或无学或非学非无学。云何学无学。谓一处少分。云何非学非无学。谓十处及一处少分。受念住。或学或无学或非学非无学。云何学。谓学作意相应受蕴。云何无学。谓无学作意相应受蕴。云何非学非无学。谓有漏作意相应受蕴。心念住亦尔。法念住。或学或无学或非学非无学。云何学。谓学想行蕴。云何无学。谓无学想行蕴。云何非学非无学。谓有漏想行蕴及无为法

此四念住几见所断等者。一切应分别。谓身念住。或修所断或非所断。云何修所断。谓十处及一处少分。云何非所断。谓一处少分。受念住。或见所断或修所断或非所断。云何见所断。谓受念住随信随法行。现观边忍所断。此复云何。谓见所断八十八随眠相应受蕴。云何修所断。谓受念住学见迹修所断。此复云何。谓修所断十随眠相应受蕴。及不染污有漏受蕴。云何非所断。谓无漏受蕴。心念住亦尔。法念住。或见所断或修所断或非所断。云何见所断。谓法念住。随信随法行。现观边忍所断。此复云何。谓见所断八十八随眠。及彼相应想行蕴。并彼等起心不相应行。云何修所断。谓法念住学见迹修所断。此复云何。谓修所断十随眠。及彼相应想行蕴。若彼等起心不相应行。若不染污有漏想行蕴。云何非所断。谓无漏想行蕴。及无为法。几非心等者。一非心非心所非心相应。一是心所与心相应。一唯是心。一应分别。谓法念住。若有所缘是心所与心相应。若无所缘非心非心所非心相应。几随心转非受相应等者。一随心转非受相应。一受相应非随心转。二应分别。谓身念住。或随心转非受相应。或非随心转非受相应。随心转非受相应者。谓随心转身语业。诸余色蕴非随心转非受相应。法念住。或随心转非受相应。或随心转亦受相应。或非随心转非受相应。随心转非受相应者。谓随心转心不相应行。随心转亦受相应者。谓想蕴及相应行蕴。非随心转非受相应者。谓除随心转心不相应行。诸余心不相应行。及无为法。几随心转非想行相应等者。除其自性。如受应知。几随寻转非伺相应。等者。一切应分别。谓身念住。或随寻转非伺相应。或非随寻转非伺相应。随寻转非伺相应者。谓随寻转身语业。诸余色蕴。非随寻转非伺相应。受念住。或有寻有伺。或无寻唯伺。或无寻无伺。云何有寻有伺。谓有寻有伺作意相应受蕴。云何无寻唯伺。谓无寻唯伺作意相应受蕴。云何无寻无伺。谓无寻无伺作意相应受蕴。心念住亦尔。法念住有四句。或随寻转非伺相应。谓随寻转心不相应行。及寻相应伺。或伺相应非随寻转。谓寻及寻不相应伺相应想行蕴。或随寻转亦伺相应。谓寻伺相应想行蕴。或非随寻转非伺相应。谓除随寻转心不相应行。诸余心不相应行。及寻不相应伺。若无寻无伺非受心所。若无为法。几见非见处等者。一切应分别。谓身念住。或见处非见。或见亦见处。或非见非见处。见处非见者。谓九处及一处少分。见亦见处者。谓一处。非见非见处者。谓一处少分。受念住。若有漏是见处非见。若无漏非见非见处。心念住亦尔。法念住有四句。或是见非见处。谓尽无生智所不摄无漏慧。或是见处非见。谓有漏想蕴。及见所不摄有漏行蕴。或是见亦见处。谓五染污见。及世间正见。或非见非见处。谓无漏想蕴。及见所不摄无漏行蕴。并无为法。几有身见为因非有身见因等者。一切应分别。谓身念住。若染污有身见为因非有身见因。若不染污非有身见为因非有身见因。受念住。或有身见为因非有身见因。或有身见为因亦有身见因。或非有身见为因非有身见因。有身见为因非有身见因者。谓除过去现在见苦所断随眠相应受蕴。亦除过去现在见集所断遍行随眠相应受蕴。亦除未来有身见相应受蕴。诸余染污受蕴。有身见为因亦有身见因者。谓前所除受蕴。非有身见为因非有身见因者。谓不染污受蕴。心念住亦尔。法念住。或有身见为因非有身见因。或有身见为因亦有身见因。或非有身见为因非有身见因。有身见为因非有身见因者。谓除过去现在见苦所断随眠及彼相应俱有等想行蕴。亦除过去现在见集所断遍行随眠及彼相应俱有想行蕴。亦除未来有身见相应想行蕴。亦除未来有身见及彼相应法生老住无常。诸余染污想行蕴。有身见为因亦有身见因者。谓前所除想行蕴。非有身见为因非有身见因者。谓不染污想行蕴。及无为法。几业非业异熟等者。一切应分别。谓身念住。或业非业异熟。或业异熟非业。或非业非业异熟。业非业异熟者。谓身语业。业异熟非业者。谓业异熟生色蕴。非业非业异熟者。谓除业及业异熟色蕴。诸余色蕴。受念住。或业异熟非业。或非业非业异熟。业异熟非业者。谓业异熟生受蕴。诸余受蕴。非业非业异熟。心念住亦尔。法念住有四句。或业非业异熟。谓业异熟所不摄思。或业异熟非业。谓思所不摄业异熟生想行蕴。或业亦业异熟。谓业异熟生思。或非业非业异熟。谓除业及业异熟想行蕴。诸余想行蕴。及无为法。几业非随业转等者。二随业转非业。二应分别。谓身念住有三句。或业非随业转。谓除随业转身语业。诸余身语业。或业亦随业转。谓随业转身语业。或非业非随业转。谓除业及随业转色蕴。诸余色蕴。法念住有三句。或业非随业转。谓思或随业转非业。谓想蕴及思所不摄随业转行蕴。或非业非随业转。谓除业及随业转行蕴。诸余行蕴。及无为法。几所造色非有见色等者。三非所造色非有见色。一应分别。谓身念住有三句。或所造色非有见色。谓八处及二处少分。或所造色亦有见色。谓一处。或非所造色非有见色。谓一处少分

此四念住几所造色非有对色等者。三非所造色非有对色。一应分别。谓身念住有三句。或所造色非有对色。谓一处少分。或有对色非所造色。谓一处少分。或所造色亦有对色。谓九处及一处少分。几难见故甚深等者。一切难见故甚深。甚深故难见。几善非善为因等者。一切应分别。谓身念住有三句。或善为因非善。谓善异熟生色蕴。或善亦善为因谓善色蕴。或非善非善为因。谓除善异熟生色蕴诸余无记。及不善色蕴。受心念住亦尔。法念住有四句。或善非善为因。谓择灭。或善为因非善。谓善异熟生想行蕴。或善亦善为因。谓善想行蕴。或非善非善为因。谓除善异熟生想行蕴。诸余无记。及不善想行蕴。并虚空非择灭。几不善非不善为因等者。一切应分别。谓身念住有三句。或不善为因非不善。谓不善异熟生色蕴。或不善亦不善为因。谓不善色蕴。或非不善非不善为因。谓除不善异熟生色蕴。诸余无记及善色蕴。受念住有三句。或不善为因非不善。谓不善异熟生受蕴。及欲界有身见边执见相应受蕴。或不善亦不善为因。谓不善受蕴。或非不善非不善为因。谓除不善异熟生受蕴。及除欲界有身见边执见相应受蕴。诸余无记及善受蕴。心念住亦尔。法念住有三句。或不善为因非不善。谓不善异熟生想行蕴。及欲界有身见边执见。并彼相应俱有等想行蕴。或不善亦不善为因。谓不善想行蕴。或非不善非不善为因。谓除不善异熟生想行蕴。及除欲界有身见边执见并彼相应俱有等想行蕴。诸余无记及善想行蕴。并三无为。几无记非无记为因等者。一切应分别。谓身念住有三句。或无记为因非无记。谓不善色蕴。或无记亦无记为因。谓无记色蕴。或非无记非无记为因。谓善色蕴。受心念住亦尔。法念住有四句。或无记非无记为因。谓虚空非择灭。或无记为因非无记。谓不善想行蕴。或无记亦无记为因。谓无记想行蕴。或非无记非无记为因。谓善想行蕴。及择灭。几因缘非有因等者。三是因缘亦有因。一应分别。谓法念住。若有为是因缘亦有因。若无为非因缘非有因。几等无间非等无间缘等者。一非等无间非等无间缘。三应分别。谓受念住有三句。或等无间非等无间缘。谓未来现前正起受蕴。及过去现在阿罗汉命终时受蕴。或等无间亦等无间缘。谓除过去现在阿罗汉命终时受蕴。诸余过去现在受蕴。或非等无间非等无间缘。谓除未来现前正起受蕴。诸余未来受蕴心念住亦尔。法念住。有三句。或等无间非等无间缘。谓未来现前正起非受心所。及过去现在阿罗汉命终时。非受心所。并已生正起无想灭定。或等无间亦等无间缘。谓除过去现在阿罗汉命终时非受心所。诸余过去现在非受心所。或非等无间非等无间缘。谓除未来现前正起非受心所。诸余未来非受心所。及除等无间心不相应行。诸余心不相应行。并无为法。几所缘缘非有所缘等者。一所缘缘非有所缘。二所缘缘亦有所缘。一应分别。谓法念住。若是心所是所缘缘亦有所缘。若非心所是所缘缘非有所缘。几增上缘非有增上等者。三增上缘亦有增上。一应分别。谓法念住。若有为是增上缘亦有增上。若无为是增上缘非有增上。几暴流非顺暴流等者。一切应分别。谓身念住。若有漏顺暴流非暴流。若无漏非暴流非顺暴流。受心念住亦尔。法念住有三句。或顺暴流非暴流。谓有漏想蕴及暴流所不摄有漏行蕴。或暴流亦顺暴流。谓四暴流。或非暴流非顺暴流。谓无漏想行蕴。及无为法

四圣谛者。谓苦圣谛集圣谛灭圣谛道圣谛。此四圣谛。几有色等者。一无色。三应分别。谓苦圣谛。或有色或无色。云何有色。谓十处及一处少分。云何无色。谓一处。及一处少分。集圣谛亦尔。道圣谛所摄身语业。是有色。余皆是无色。几有见等者。二无见。二应分别。谓苦圣谛。或有见或无见。云何有见。谓一处。云何无见。谓十一处。集圣谛亦尔。几有对等者。二无对。二应分别。谓苦圣谛。或有对或无对。云何有对。谓十处。云何无对。谓二处。集圣谛亦尔。几有漏等者。二有漏二无漏。有为等者。三有为。一无为。几有异熟等者。二无异熟。二应分别。谓苦圣谛。或有异熟或无异熟。云何有异熟。谓善不善苦谛。云何无异熟。谓无记苦谛。集圣谛亦尔。几是缘生等者。三是缘生是因生是世摄。一非缘生非因生非世摄。几色摄等者。一名摄。三应分别。谓苦圣谛。或色摄或名摄。云何色摄。谓十处及一处少分。云何名摄。谓一处及一处少分。集圣谛亦尔。道圣谛所摄身语业是色摄。余皆是名摄。几内处摄等者。一外处摄。三应分别。谓苦圣谛。或内处摄或外处摄。云何内处摄。谓六内处。云何外处摄。谓六外处。集圣谛亦尔。道圣谛所摄心意识内处摄。余皆外处摄。几智遍知所遍知等者。一切是智遍知所遍知

说一切有部品类足论卷第十二阿毗达磨品类足论卷第十三

        尊者世友造

        三藏法师玄奘奉　诏译

    辩千问品第七之四

此四圣谛几断遍知所遍知等者。二是断遍知所遍知。二非断遍知所遍知。几应断等者。二应断二不应断。几应修等者。一应修一不应修。二应分别。谓苦圣谛。或应修或不应修。云何应修。谓善苦谛。云何不应修。谓不善无记苦谛。集圣谛亦尔。几染污等者。二不染污。二应分别。谓苦圣谛。或染污或不染污。云何染污。谓有覆苦谛。云何不染污。谓无覆苦谛。集圣谛亦尔。几果非有果等者。三是果亦有果。一是果非有果。几有执受等者。二无执受。二应分别。谓苦圣谛。或有执受或无执受。云何有执受。谓自体所摄苦谛。云何无执受。谓非自体所摄苦谛。集圣谛亦尔。几大种所造等者。一非大种所造。三应分别。谓苦圣谛。或大种所造。或非大种所造。云何大种所造。谓九处及二处少分。云何非大种所造。谓一处及二处少分。集圣谛亦尔。道圣谛所摄身语业。是大种所造。余皆非大种所造。几有上等者。三有上一无上。几是有等者。二是有二非有。几因相应等者。一因不相应。三应分别。谓苦圣谛所摄色心不相应行。是因不相应。余皆因相应。集圣谛亦尔。道圣谛所摄身语业心不相应行。是因不相应。余皆因相应

此四圣谛与六善处相摄者。六善处摄二谛及二谛少分。二谛及二谛少分亦摄六善处。与五不善处相摄者。五不善处摄二谛少分。二谛少分亦摄五不善处。与七无记处相摄者。应作四句。或是无记处非谛。谓虚空非择灭。或是谛非无记处。谓二谛及二谛少分。或是无记处亦谛。谓二谛少分。或非无记处非谛。是事不可得。与三漏处相摄者。三漏处摄二谛少分。二谛少分亦摄三漏处。与五有漏处相摄者。五有漏处摄二谛。二谛亦摄五有漏处。与八无漏处相摄者。应作四句。或是无漏处非谛。谓虚空非择灭。或是谛非无漏处。谓二谛。或无漏处亦谛。谓二谛。或非无漏处非谛。是事不可得。几过去等者。三或过去或未来或现在。一非过去非未来非现在。几善等者。二是善。二应分别。谓苦圣谛。或善或不善或无记。云何善。谓苦谛所摄善五蕴。云何不善。谓苦谛所摄不善五蕴。云何无记。谓苦谛所摄无记五蕴。集圣谛亦尔。几欲界系等者。二不系。二应分别。谓苦圣谛。或欲界系。或色界系。或无色界系。云何欲界系。谓苦谛所摄欲界五蕴。云何色界系。谓苦谛所摄色界五蕴。云何无色界系。谓苦谛所摄无色界四蕴。集圣谛亦尔。几学等者。三非学非无学。一应分别。谓道圣谛或学或无学。云何学。谓学五蕴。云何无学。谓无学五蕴

此四圣谛几见所断等者。二非所断。二应分别。谓苦圣谛。或见所断或修所断。云何见所断。谓苦谛随信随法行现观边忍所断。此复云何。谓见所断八十八随眠。及彼相应苦谛。并彼等起心不相应行。云何修所断。谓苦谛学见迹修所断。此复云何。谓修所断十随眠。及彼相应苦谛。并彼等起身语业。心不相应行。若不染污苦谛。集圣谛亦尔。几非心等者。一非心非心所非心相应。三应分别。谓苦圣谛所摄色心不相应行。非心非心所非心相应。受蕴想蕴相应行蕴。是心所与心相应。心意识唯是心。集圣谛亦尔。道圣谛所摄身语业。心不相应行。非心非心所非心相应。受蕴想蕴相应行蕴。是心所与心相应。心意识唯是心。几随心转非受相应等者。一非随心转非受相应。三应分别。谓苦圣谛有四句。或随心转非受相应。谓随心转身语业心不相应行。及受或受相应非随心转。谓心意识。或随心转亦受相应。谓想蕴及相应行蕴。或非随心转非受相应。谓除随心转身语业心不相应行。诸余色心不相应行。集圣谛亦尔。道圣谛有四句。或随心转非受相应。谓身语业。及随心转心不相应行并受。或受相应非随心转。谓心意识。或随心转亦受相应。谓想蕴及相应行蕴。或非随心转非受相应。谓除随心转心不相应行。诸余心不相应行。几随心转非想行相应等者。除其自性。如受应知。几随寻转非伺相应等者。一非随寻转非伺相应。三应分别。谓苦圣谛有四句。或随寻转非伺相应。谓随寻转身语业心不相应行。及寻相应伺。或伺相应非随寻转。谓寻及寻不相应伺相应心心所苦谛。或随寻转亦伺相应。谓寻伺相应心心所苦谛。或非随寻转非伺相应。谓除随寻转身语业心不相应行。诸余色心不相应行。及寻不相应伺。并无寻无伺心心所苦谛。集圣谛亦尔。道圣谛有四句。或随寻转非伺相应。谓随寻转身语业心不相应行。及寻相应伺。或伺相应非随寻转。谓寻及寻不相应伺相应心心所法。或随寻转亦伺相应。谓寻伺相应心心所法。或非随寻转非伺相应。谓除随寻转身语业心不相应行。诸余身语业心不相应行。及寻不相应伺。并无寻无伺心心所法。几见非见处等者。一非见非见处。三应分别。谓苦圣谛。或见亦见处。或见处非见。或见亦见处者。谓眼根五染污见世间正见。余皆见处非见。集圣谛亦尔。道圣谛所摄尽无生智所不摄慧。是见非见处。余皆非见非见处。几有身见为因非有身见因等者。二非有身见为因非有身见因。二应分别。谓苦圣谛。或有身见为因非有身见因。或有身见为因亦有身见因。或非有身见为因非有身见因。有身见为因非有身见因者。谓除过去现在见苦所断随眠及彼相应俱有等苦谛。亦除过去现在见集所断遍行随眠及彼相应俱有苦谛。亦除未来有身见因相应苦谛。亦除未来有身见及彼相应法生老住无常。诸余染污苦谛。有身见为因亦有身见因者。谓前所除苦谛。非有身见为因非有身见因者。谓不染污苦谛。集圣谛亦尔。几业非业异熟等者。一非业非业异熟三应分别。谓苦圣谛有四句。或业非业异熟。谓身语业及业异熟所不摄思。或业异熟非业。谓思所不摄业异熟生苦谛。或业亦业异熟。谓业异熟生思。或非业非业异熟。谓除业及业异熟生苦谛。诸余苦谛。集圣谛亦尔。道圣谛所摄身语业及思。是业非业异熟余皆非业非业异熟。几业非随业转等者。一非业非随业转。三应分别。谓苦圣谛有四句。或业非随业转。谓除随业转身语业。诸余身语业及思。或随业转非业。谓受想识蕴。及思所不摄随业转行蕴。或业亦随业转。谓随业转身语业。或非业非随业转。谓除业及随业转苦谛。诸余苦谛。集圣谛亦尔。道圣谛有四句。或业非随业转。谓思或随业转非业。谓受想识蕴及思所不摄随业转行蕴。或业亦随业转。谓身语业。或非业非随业转。谓除随业转心不相应行。诸余心不相应行。几所造色非有见色等者。一非所造色非有见色。三应分别。谓苦圣谛有三句。或所造色非有见色。谓八处及二处少分。或所造色亦有见色。谓一处。或非所造色非有见色。谓一处及二处少分。集圣谛亦尔。道圣谛所摄身语业。是所造色非有见色。余皆非所造色非有见色

此四圣谛几所造色非有对色等者。一非所造色非有对色。三应分别。谓苦圣谛有四句。或所造色非有对色。谓一处少分。或有对色非所造色。谓一处少分。或所造色亦有对色。谓九处及一处少分。或非所造色非有对色。谓一处及一处少分。集圣谛亦尔。道圣谛所摄身语业。是所造色非有对色。余皆非所造色非有对色。几难见故甚深等者。一切难见故甚深甚深故难见。几善非善为因等者。一是善非善为因。一是善亦善为因。二应分别。谓苦圣谛。有三句。或善为因非善。谓善异熟生苦谛。或是善亦善为因。谓善苦谛。或非善非善为因。谓除善异熟生苦谛。诸余无记。及不善苦谛。集圣谛亦尔。几不善非不善为因等者。二非不善非不善为因。二应分别。谓苦圣谛有三句。或不善为因非不善。谓不善异熟生苦谛。及欲界系有身见边执见。并彼相应俱有等苦谛。或不善亦不善为因。谓不善苦谛。或非不善非不善为因。谓除不善异熟生苦谛。及除欲界系有身见边执见并彼相应俱有等苦谛。诸余无记。及善苦谛。集圣谛亦尔。几无记非无记为因等者。二非无记非无记为因。二应分别。谓苦圣谛。有三句。或无记为因非无记。谓不善苦谛。或无记亦无记为因。谓无记苦谛。或非无记非无记为因。谓善苦谛。集圣谛亦尔。几因缘非有因等者。三是因缘亦有因。一非因缘非有因。几等无间非等无间缘等者。一非等无间非等无间缘。三应分别。谓苦圣谛有三句。或是等无间非等无间缘。谓未来现前正起心心所苦谛。及过去现在阿罗汉命终时心心所苦谛。并已生正起无想灭定。或是等无间亦等无间缘。谓除过去现在阿罗汉命终时心心所苦谛。诸余过去现在心心所苦谛。或非等无间非等无间缘谓除未来现前正起心心所苦谛。诸余未来心心所苦谛。除等无间心不相应行。诸余心不相应行。及色苦谛。集圣谛亦尔。道圣谛有三句。或是等无间非等无间缘。谓未来现前正起心心所道谛。或是等无间亦等无间缘。谓过去现在心心所道谛。或非等无间非等无间缘。谓除未来现前正起心心所道谛。诸余未来心心所道谛。及身语业心不相应行道谛。几所缘缘非有所缘等者。一是所缘缘非有所缘。三应分别。谓苦圣谛所摄色心不相应行。是所缘缘非有所缘。诸余苦谛。皆是所缘缘亦有所缘。集圣谛亦尔道圣谛所摄身语业心不相应行。是所缘缘非有所缘。诸余道谛。皆所缘缘亦有所缘。几增上缘非有增上等者。一是增上缘非有增上。三是增上缘亦有增上。几暴流非顺暴流等者。一非暴流非顺暴流。二应分别。谓苦圣谛。或是暴流亦顺暴流。或顺暴流非暴流。是暴流亦顺暴流者。谓四暴流。诸余苦谛。是顺暴流非暴流。集圣谛亦尔。四静虑者。谓初静虑。第二静虑。第三静虑。第四静虑。此四静虑几有色等者。一切应分别。谓诸静虑所摄身语业是有色。余皆是无色。几有见等者。一切无见。几有对等者。一切无对。几有漏等者。一切应分别。谓诸静虑。或有漏或无漏。云何有漏。谓静虑所摄有漏五蕴。云何无漏。谓静虑所摄无漏五蕴。几有为等者。一切有为。几有异熟等者。一切应分别。谓诸静虑。若有漏有异熟。若无漏无异熟。几是缘生等者。一切是缘生是因生是世摄。几色摄等者。一切应分别。谓诸静虑所摄身语业是色摄。余皆是名摄。几内处摄等者。一切应分别。谓诸静虑所摄心意识。内处摄。余皆外处摄。几智遍知所遍知等者。一切智遍知所遍知

此四静虑几断遍知所遍知等者。一切应分别。谓诸静虑。若有漏断遍知所遍知。若无漏非断遍知所遍知。几应断等者。一切应分别。谓诸静虑。若有漏应断。若无漏不应断。几应修等者。一切是应修。几染污等者。一切不染污。几果非有果等者。一切是果亦有果。几有执受等者。一切无执受。几大种所造等者。一切应分别。谓诸静虑所摄身语业。是大种所造。余皆非大种所造。几有上等者。一切是有上。几是有等者。一切应分别。谓诸静虑。若有漏是有。若无漏非有。几因相应等者。一切应分别。谓诸静虑所摄身语业心不相应行因不相应。余皆因相应

此四静虑与六善处相摄者。五善处少分摄四静虑。四静虑亦摄五善处少分。与五不善处相摄者。互不相摄。与七无记处相摄者。互不相摄。与三漏处相摄者。互不相摄。与五有漏处相摄者。应作四句。或有漏处非静虑。谓静虑所不摄有漏五蕴。或静虑非有漏处。谓无漏四静虑。或有漏处亦静虑。谓有漏四静虑。或非有漏处非静虑。谓静虑所不摄无漏五蕴。及无为法。与八无漏处相摄者。应作四句。或无漏处非静虑。谓静虑所不摄无漏五蕴。及无为法。或静虑非无漏处。谓有漏四静虑。或无漏处亦静虑。谓无漏四静虑。或非无漏处非静虑。谓静虑所不摄有漏五蕴。几过去等者。一切或过去或未来或现在。几善等者。一切是善。几欲界系等者。一切应分别。谓诸静虑。若有漏色界系。若无漏是不系。几学等者。一切应分别。谓诸静虑。或学或无学或非学非无学。云何学。谓静虑所摄学五蕴。云何无学。谓静虑所摄无学五蕴。云何非学非无学。谓静虑所摄有漏五蕴

此四静虑几见所断等者。一切应分别。谓诸静虑。若有漏修所断。若无漏非所断。几非心等者。一切应分别。谓静虑所摄身语业心不相应行。非心非心所非心相应。受蕴想蕴相应行蕴。是心所与心相应。心意识唯是心。几随心转非受相应等者。一切应分别。谓各有四句。或随心转非受相应。谓静虑所摄身语业。及随心转心不相应行并受。或受相应非随心转。谓静虑所摄心意识。或随心转亦受相应。谓静虑所摄想蕴。及相应行蕴。或非随心转非受相应。谓除静虑所摄随心转心不相应行。诸余静虑所摄心不相应行。几随心转非想行相应等者。除其自性。如受应知。几随寻转非伺相应等者。三非随寻转非伺相应。一应分别。谓初静虑。应作四句。或随寻转非伺相应。谓初静虑所摄身语业。及随寻转心不相应行并伺。或伺相应非随寻转。谓初静虑所摄寻。或随寻转亦伺相应。谓初静虑所摄寻伺相应心心所法。或非随寻转非伺相应。谓除初静虑所摄随寻转心不相应行。诸余初静虑所摄心不相应行。几见非见处等者。一切应分别。谓各有四句。或见非见处。谓静虑所摄尽无生智所不摄无漏慧。或见处非见。谓见所不摄有漏四静虑。或见亦见处。谓静虑所摄有漏慧。或非见非见处。谓见所不摄无漏四静虑。几有身见为因非有身见因等者。一切非有身见为因非有身见因。几业非业异熟等者。一切应分别。谓诸静虑所摄身语业及思。是业非业异熟。余皆非业非业异熟。几业非随业转等者。一切应分别。谓各有四句。或业非随业转。谓静虑所摄思。或随业转非业。谓静虑所摄受想识蕴。及思所不摄随业转行蕴。或业亦随业转。谓静虑所摄身语业。或非业非随业转。谓除静虑所摄随业转心不相应行。诸余静虑所摄心不相应行。几所造色非有见色等者。一切应分别。谓诸静虑所摄身语业。是所造色非有见色。余皆非所造色非有见色

此四静虑。几所造色非有对色等者。一切应分别。谓诸静虑所摄身语业。是所造色非有对色。余皆非所造色非有对色。几难见故甚深等者。一切难见故甚深甚深故难见。几善非善为因等者。一切是善亦善为因。几不善非不善为因等者。一切非不善非不善为因。几无记非无记为因等者。一切非无记非无记为因。几因缘非有因等者。一切是因缘亦有因。几等无间非等无间缘等者。一切应分别。谓初静虑。有三句。或是等无间非等无间缘。谓未来现前正起心心所法。或是等无间亦等无间缘。谓过去现在心心所法。或非等无间非等无间缘。谓除未来现前正起心心所法。诸余未来心心所法。及身语业心不相应行。第二第三静虑亦尔。第四静虑。有三句。或是等无间非等无间缘。谓未来现前正起心心所法。及已生正起无想定。或是等无间亦等无间缘。谓过去现在心心所法。或非等无间非等无间缘。谓除未来现前正起心心所法。诸余未来心心所法。及除等无间心不相应行。诸余心不相应行。并身语业。几所缘缘非有所缘等者。一切应分别。谓诸静虑所摄身语业心不相应行。是所缘缘非有所缘。余皆是所缘缘亦有所缘。几增上缘非有增上等者。一切是增上缘亦有增上。几暴流非顺暴流等者。一切应分别。谓诸静虑。若有漏顺暴流非暴流。若无漏非暴流非顺暴流。四无量者。谓慈无量悲无量喜无量舍无量

此四无量几有色等者。一切应分别。谓诸无量所摄身语业。是有色。余皆无色。几有见等者。一切无见。几有对等者。一切无对。几有漏等者。一切有漏。几有为等者。一切有为。几有异熟等者。一切有异熟。几是缘生等者。一切是缘生是因生是世摄。几色摄等者。一切应分别。谓诸无量所摄身语业。是色摄。余皆是名摄。几内处摄等者。一切应分别。谓诸无量所摄心意识。内处摄。余皆外处摄。几智遍知所遍知等者。一切是智遍知所遍知

此四无量几断遍知所遍知等者。一切是断遍知所遍知。几应断等者。一切是应断。几应修等者。一切是应修。几染污等者。一切不染污。几果非有果等者。一切是果亦有果。几有执受等者。一切无执受。几大种所造等者。一切应分别。谓诸无量所摄身语业。是大种所造。余皆非大种所造。几有上等者。一切是有上。几是有等者。一切是有几因相应等者。一切应分别。谓诸无量所摄身语业心不相应行。因不相应。余皆因相应

此四无量与六善处相摄者。五善处少分摄四无量。四无量亦摄五善处少分。与五不善处相摄者。互不相摄。与七无记处相摄者。互不相摄。与三漏处相摄者。互不相摄。与五有漏处相摄者。五有漏处少分摄四无量。四无量亦摄五有漏处少分。与八无漏处相摄者。互不相摄。几过去等者。一切或过去或未来或现在。几善等者。一切是善。几欲界系等者。一切色界系。几学等者。一切非学非无学

此四无量。几见所断等者。一切修所断。几非心等者。一切应分别。谓诸无量所摄身语业心不相应行。非心非心所非心相应。受蕴想蕴相应行蕴。是心所与心相应。心意识唯是心。几随心转非受相应等者。一切应分别。谓各有四句。或随心转非受相应。谓无量所摄身语业。及随心转心不相应行并受。或受相应非随心转。谓无量所摄心意识。或随心转亦受相应。谓无量所摄想蕴。及相应行蕴。或非随心转非受相应。谓除无量所摄随心转心不相应行。诸余无量所摄心不相应行。几随心转非想行相应等者。除其自性。如受应知。几随寻转非伺相应等者。一切应分别。谓慈无量。有四句。或随寻转非伺相应。谓慈无量所摄随寻转身语业心不相应行。及寻相应伺。或伺相应非随寻转。谓慈无量所摄寻。及寻不相应伺相应心心所法。或随寻转亦伺相应。谓慈无量所摄寻伺相应心心所法。或非随寻转非伺相应。谓除慈无量所摄随寻转身语业心不相应行。诸余慈无量所摄身语业心不相应行。及慈无量所摄寻不相应伺。并慈无量所摄无寻无伺心心所法。悲舍无量亦尔。喜无量。有四句。或随寻转非伺相应。谓喜无量所摄随寻转身语业心不相应行及同。或伺相应非随寻转。谓喜无量所摄寻。或随寻转亦伺相应。谓喜无量所摄寻伺相应心心所法。或非随寻转非伺相应。谓除喜无量所摄随寻转身语业心不相应行。诸余喜无量所摄身语业心不相应行。及喜无量所摄无寻无伺心心所法。几见非见处等者。一切应分别。谓诸无量。或是见亦见处。或是见处非见。是见亦见处者。谓无量所摄慧。余皆是见处非见。几有身见为因非有身见因等者。一切非有身见为因非有身见因。几业非业异熟等者。一切应分别。谓无量所摄身语业及思。是业非业异熟。余皆非业非业异熟。几业非随业转等者。一切应分别。谓各有四句。或是业非随业转。谓无量所摄思。或随业转非业。谓无量所摄受想识蕴。及思所不摄随业转行蕴。或业亦随业转。谓无量所摄身语业。或非业非随业转。谓除无量所摄随业转心不。相应行。诸余无量所摄心不相应行。几所造色非有见色等者。一切应分别。谓无量所摄身语业。是所造色非有见色。余皆非所造色非有见色

说一切有部品类足论卷第十三阿毗达磨品类足论卷第十四

        尊者世友造

        三藏法师玄奘奉　诏译

    辩千问品第七之五

此四无量几所造色非有对色等者。一切应分别。谓诸无量所摄身语业。是所造色非有对色。余皆非所造色非有对色。几难见故甚深等者。一切难见故甚深甚深故难见。几善非善为因等者。一切是善亦善为因。几不善非不善为因等者。一切非不善非不善为因。几无记非无记为因等者。一切非无记非无记为因。几因缘非有因等者。一切是因缘亦有因。几等无间非等无间缘等者。一切应分别。谓各有三句。或是等无间非等无间缘。谓无量所摄未来现前正起心心所法。或是等无间亦等无间缘。谓无量所摄过去现在心心所法。或非等无间非等无间缘。谓除无量所摄未来现前正起心心所法。诸余无量所摄未来心心所法。及无量所摄身语业心不相应行。几所缘缘非有所缘等者。一切应分别。谓无量所摄身语业心不相应行。是所缘缘非有所缘。余无量所摄。皆是所缘缘亦有所缘。几增上缘非有增上等者。一切是增上缘亦有增上几暴流非顺暴流等者。一切顺暴流亦非暴流

四无色者。谓空无边处。识无边处。无所有处。非想非非想处。此四无色几有色等者。一切无色。几有见等者。一切无见。几有对等者。一切无对。几有漏等者。一有漏。三应分别。谓空无边处。或有漏或无漏。云何有漏。谓空无边处所摄有漏四蕴。云何无漏。谓空无边处所摄无漏四蕴。识无边处无所有处亦尔。几有为等者。一切有为。几有异熟等者。一切应分别。谓空无边处。或有异熟或无异熟。云何有异熟。谓善有漏。空无边处。云何无异熟。谓无记无漏。空无边处识无边处无所有处亦尔。非想非非想处。或有异熟或无异熟。云何有异熟。谓善非想非非想处。云何无异熟。谓无记非想非非想处。几是缘生等者。一切是缘生是因生是世摄。几色摄等者。一切名摄。几内处摄等者。一切应分别。谓诸无色所摄心意识。内处摄。余皆外处摄。几智遍知所遍知等者。一切智遍知所遍知

此四无色。几断遍知所遍知等者。一断遍知所遍知。三应分别。谓三无色。若有漏断遍知所遍知。若无漏非断遍知所遍知。几应断等者。一应断。三应分别。谓三无色。若有漏是应断。若无漏不应断。几应修等者。一切应分别。谓空无边处。或应修或不应修。云何应修。谓善空无边处。云何不应修。谓无记空无边处。识无边处无所有处非想非非想处亦尔。几染污等者。一切应分别。谓空无边处。或染污或不染污。云何染污。谓有覆空无边处。云何不染污。谓无覆空无边处。识无边处无所有处非想非非想处亦尔。几果非有果等者。一切是果亦有果。几有执受等者。一切无执受。几大种所造等者。一切非大种所造。几有上等者。一切是有上。几是有等者。一是有。三应分别。谓三无色。若有漏是有。若无漏非有。几因相应等者。一切应分别。谓诸无色所摄心不相应行因不相应。余皆因相应

此四无色与六善处相摄者。应作四句。或善处非无色。谓善色蕴。及无色所不摄善四蕴。并择灭。或无色非善处。谓无记四无色。或善处亦无色。谓善四无色。或非善处非无色。谓不善五蕴。无记色蕴。及无色所不摄无记四蕴。并虚空非择灭。与五不善处相摄者。互不相摄。与七无记处相摄者。应作四句。或无记处非无色。谓无记色蕴。及无色所不摄无记四蕴。并虚空非择灭。或无色非无记处。谓善四无色。或无记处亦无色。谓无记四无色。或非无记处非无色。谓不善五蕴。善色蕴。及无色所不摄善四蕴。并择灭。与三漏处相摄者。应作四句。或漏处。非无色。谓一漏处。及二漏处少分。或无色非漏处。谓漏处所不摄四无色。或漏处亦无色。谓二漏处少分。或非漏处非无色。谓色蕴。及漏处无色所不摄四蕴。并无为法。与五有漏处相摄者。应作四句。或有漏处非无色。谓有漏色蕴。及无色所不摄有漏四蕴。或无色非有漏处。谓三无色少分。或有漏处亦无色。谓一无色。及三无色少分。或非有漏处非无色。谓无漏色蕴。及无色所不摄无漏四蕴。并无为法。与八无漏处相摄者。应作四句。或无漏处非无色。谓无漏色蕴。及无色所不摄无漏四蕴。并无为法。或无色非无漏处。谓一无色。及三无色少分。或无漏处亦无色。谓三无色少分。或非无漏处非无色。谓有漏色蕴。及无色所不摄有漏四蕴。几过去等者。一切或过去或未来或现在。几善等者。一切应分别。谓空无边处。或善或无记。云何善。谓空无边处所摄善四蕴。云何无记。谓空无边处所摄无记四蕴。识无边处无所有处非想非非想处亦尔。几欲界系等者。一无色界系。三应分别。谓三无色。若有漏无色界系。若无漏是不系。几学等者。一非学非无学。三应分别。谓空无边处。或学或无学或非学非无学。云何学。谓空无边处所摄学四蕴。云何无学。谓空无边处所摄无学四蕴。云何非学非无学。谓空无边处所摄有漏四蕴。识无边处无所有处亦尔

此四无色几见所断等者。一切应分别。谓空无边处。或见所断。或修所断。或非所断。云何见所断。谓空无边处随信随法行现观边忍所断。此复云何。谓见所断二十八随眠。及彼相应彼等起心不相应行。空无边处。云何修所断。谓空无边处学见迹修所断。此复云何。谓修所断三随眠。及彼相应彼等起心不相应行。并不染污有漏空无边处。云何非所断。谓无漏。空无边处识无边处无所有处亦尔。非想非非想处。或见所断。或修所断。云何见所断。谓非想非非想处随信随法行现观边忍所断。此复云何。谓见所断二十八随眠。及彼相应彼等起心不相应行非想非非想处。云何修所断。谓非想非非想处学见迹修所断。此复云何。谓修所断三随眠。及彼相应彼等起心不相应行。并不染污非想非非想处。几非心等者。一切应分别。谓诸无色所摄心不相应行。非心非心所非心相应。受蕴想蕴相应行蕴。是心所与心相应。心意识唯是心。几随心转非受相应等者。一切应分别。谓各有四句。或随心转非受相应。谓无色所摄随心转心不相应行及受。或受相应非随心转。谓无色所摄心意识。或随心转亦受相应。谓无色所摄想蕴相应行蕴。或非随心转非受相应。谓除无色所摄随心转心不相应行。诸余无色所摄心不相应行。几随心转非想行相应等者。除其自性。如受应知。几随寻转非伺相应等者。一切非随寻转非伺相应。几见非见处等者。一切应分别。谓空无边处。应作四句或见非见处。谓空无边处所摄尽无生智所不摄无漏慧。或见处非见。谓见所不摄有漏空无边处。或见亦见处。谓空无边处所摄五染污见。及世俗正见。或非见非见处。谓见所不摄无漏空无边处。识无边处无所有处亦尔。非想非非想处。或见亦见处。或见处非见见亦见处者。谓非想非非想处所摄五染污见世间正见余非想非非想处。皆见处非见。几有身见为因非有身见因等者。一切应分别。谓空无边处。或有身见为因非有身见因。或有身见为因亦有身见因。或非有身见为因非有身见因。有身见为因非有身见因者。谓除过去现在见苦所断随眠及彼相应俱有等空无边处。亦除过去现在见集所断遍行随眠及彼相应俱有空无边处。亦除未来有身见相应空无边处。亦除未来有身见及彼相应法生老住无常空无边处。诸余染污空无边处。有身见为因亦有身见因者。谓前所除空无边处。非有身见为因非有身见因者。谓不染污空无边处。识无边处无所有处非想非非想处亦尔。几业非业异熟等者。一切应分别谓空无边处。应作四句。或业非业异熟。谓空无边处异熟所不摄思。或业异熟非业。谓思所不摄业异熟生空无边处。或业亦业异熟。谓空无边处业异熟生思。或非业非业异熟。谓除业及业异熟生空无边处。诸余空无边处识无边处无所有处非想非非想处亦尔。几业非随业转等者。一切应分别。谓空无边处。有三句。或业非随业转。谓空无边处所摄思。或随业转非业。谓空无边处所摄受想识蕴。及思所不摄随业转行蕴。或非业非随业转。谓除空无边处所摄随业转心不相应行。诸余空无边处所摄心不相应行。识无边处无所有处非想非非想处亦尔。几所造色非有见色等者。一切非所造色非有见色。此四无色。几所造色非有对色等者。一切非所造色非有对色。几难见故甚深等者。一切难见故甚深甚深故难见。几善非善为因等者。一切应分别。谓空无边处。有三句。或善为因非善。谓善异熟生空无边处。或善亦善为因。谓善空无边处。或非善非善为因。谓除善异熟生空无边处。诸余无记空无边处。后三无色亦尔。几不善非不善为因等者。一切非不善非不善为因。几无记非无记为因等者。一切应分别。谓空无边处。或无记亦无记为因。或非无记非无记为因。无记亦无记为因者。谓无记空无边处。非无记非无记为因者。谓善空无边处。后三无色亦尔。几因缘非有因等者。一切是因缘亦有因。几等无间非等无间缘等者。一切应分别。谓空无边处。有三句。或是等无间非等无间缘。谓未来现前正起心心所空无边处。及过去现在阿罗汉命终时心心所空无边处。或是等无间亦等无间缘。谓除过去现在阿罗汉命终时心心所空无边处。诸余过去现在心心所空无边处。或非等无间非等无间缘。谓除未来现前正起心心所空无边处。诸余未来心心所空无边处。及空无边处心心不相应行。识无边处无所有处亦尔。非想非非想处。有三句。或是等无间非等无间缘。谓未来现前正起心心所非想非非想处。及过去现在阿罗汉命终时心心所非想非非想处。并已生正起灭定。或是等无间亦等无间缘。谓除过去现在阿罗汉命终时心心所非想非非想处。诸余过去现在心心所非想非非想处。或非等无间非等无间缘。谓除未来现前正起心心所非想非非想处。诸余未来心心所非想非非想处。及除等无间心不相应行非想非非想处。诸余心不相应行非想非非想处。几所缘缘非有所缘等者。一切应分别。谓诸无色所摄心不相应行。是所缘缘非有所缘。诸余无色。是所缘缘亦有所缘。几增上缘非有增上等者。一切增上缘亦有增上。几暴流非顺暴流等者。一切应分别。谓空无边处有三句。或顺暴流非暴流。谓暴流所不摄有漏空无边处。或暴流亦顺暴流。谓三暴流少分。或非暴流非顺暴流。谓无漏空无边处。识无边处无所有处亦尔。非想非非想处。或暴流亦顺暴流。或顺暴流非暴流。暴流亦顺暴流者。谓三暴流少分。余皆顺暴流非暴流。四修定者。一有修定。若习若修。若多所作得现法乐住。二有修定。若习若修。若多所作得胜知见。三有修定。若习若修。若多所作得分别慧。四有修定。若习若修。若多所作得诸漏尽。此四修定几有色等者。一切应分别。谓诸修定所摄身语业是有色。余皆是无色。几有见等者。一切无见。几有对等者。一切无对。几有漏等者。一有漏一无漏。二应分别。谓为现法乐住。或有漏或无漏。云何有漏。谓为现法乐住所摄有漏五蕴。云何无漏。谓为现法乐住所摄无漏五蕴。为分别慧。或有漏或无漏。云何有漏。谓为分别慧所摄有漏五蕴。云何无漏。谓无漏五蕴。几有为等者。一切有为。几有异熟等者。一有异熟一无异熟。二应分别。谓为现法乐住。及为分别慧。若有漏有异熟。若无漏无异熟。几是缘生等者。一切是缘生是因生是世摄。几色摄等者。一切应分别。谓诸修定所摄身语业是色摄。余皆是名摄。几内处摄等者。一切应分别。谓诸修定所摄心意识。内处摄。余皆外处摄。几智遍知所遍知等者。一切是智遍知所遍知

此四修定几断遍知所遍知等者。一是断遍知所遍知。一非断遍知所遍知。二应分别。谓为现法乐住。及为分别慧。若有漏是断遍知所遍知。若无漏非断遍知所遍知。几应断等者。一应断一不应断。二应分别。谓为现法乐住。及为分别慧。若有漏是应断。若无漏不应断。几应修等者。一切是应修。几染污等者。一切不染污。几果非有果等者。一切是果亦有果。几有执受等者。一切无执受。几大种所造等者。一切应分别。谓诸修定所摄身语业。是大种所造。余皆非大种所造。几有上等者。一切是有上。几是有等者。一是有。一非有。二应分别。谓为现法乐住。及为分别慧。若有漏是有。若无漏非有。几因相应等者。一切应分别。谓诸修定所摄身语业心不相应行。因不相应。余皆因相应

此四修定。与六善处相摄者。五善处少分摄四修定。四修定亦摄五善处少分。与五不善处相摄者。互不相摄。与七无记处相摄者。互不相摄。与三漏处相摄者。互不相摄。与五有漏处相摄者。应作四句。或有漏处非修定。谓修定所不摄有漏五蕴。或修定非有漏处。谓一修定。及二少分。或有漏处亦修定。谓一修定。及二少分。或非有漏处非修定。谓虚空及二灭与八无漏处相摄者。应作四句。或无漏处非修定。谓虚空及二灭。或修定非无漏处。谓一修定。及二少分。或无漏处亦修定。谓一修定及二少分。或非无漏处非修定。谓修定所不摄有漏五蕴。几过去等者。一切或过去或未来或现在。几善等者。一切是善。几欲界系等者。一色界系一不系。二应分别。谓为现法乐住。若有漏色界系。若无漏不系。为分别慧。或欲界系。或色界系。或无色界系。或不系。云何欲界系。谓为分别慧所摄欲界五蕴。云何色界系。谓为分别慧所摄色界五蕴。云何无色界系。谓为分别慧所摄无色界四蕴。云何不系。谓无漏五蕴。几学等者。一学一非学非无学。二应分别。谓为现法乐住。或学或无学或非学非无学。云何学。谓为现法乐住所摄学五蕴。云何无学。谓为现法乐住所摄无学五蕴。云何非学非无学。谓为现法乐住所摄有漏五蕴。为分别慧。或学或无学或非学非无学。云何学。谓学五蕴。云何无学。谓无学五蕴。云何非学非无学。谓为分别慧所摄有漏五蕴。此四修定几见所断等者。一修所断。一非所断。二应分别。谓为现法乐住。及为分别慧。若有漏修所断。若无漏非所断。几非心等者。一切应分别。谓诸修定所摄身语业心不相应行。非心非心所非心相应。受蕴想蕴相应行蕴。是心所与心相应。心意识唯是心。几随心转非受相应等者。一切应分别。谓为现法乐住。应作四句。或随心转非受相应。谓为现法乐住所摄身语业。及随心转心不相应行并受。或受相应非随心转。谓为现法乐住所摄心意识。或随心转亦受相应。谓为现法乐住所摄想蕴。及相应行蕴。或非随心转非受相应。谓除为现法乐住所摄随心转心不相应行。诸余为现法乐住所摄心不相应行。为胜知见为尽诸漏亦尔。为分别慧。应作四句。或随心转非受相应。谓随心转身语业。及为分别慧所摄心不相应行并受。或受相应非随心转。谓为分别慧所摄心意识。或随心转亦受相应。谓为分别慧所摄想蕴。及相应行蕴。或非随心转非受相应。谓除随心转身语业。诸余为分别慧所摄身语业。除为分别慧所摄心不相应行。诸余为分别慧所摄心不相应行。几随心转非想行相应等者。除其自性。如受应知。几随寻转非伺相应等者。一无寻无伺。三应分别。谓为现法乐住。有四句。或随寻转非伺相应。谓为现法乐住所摄随寻转身语业心不相应行及伺。或伺相应非随寻转。谓为现法乐住所摄寻。或随寻转亦伺相应。谓为现法乐住所摄寻伺相应心心所法。或非随寻转非伺相应。谓除为现法乐住所摄随寻转心不相应行。诸余为现法乐住所摄心不相应行。为胜知见。有四句。或随寻转非伺相应。谓为胜知见所摄随寻转身语业心不相应行及伺。或伺相应非随寻转。谓为胜知见所摄寻。或随寻转亦伺相应。谓为胜知见所摄寻伺相应心心所法。或非随寻转非伺相应。谓除为胜知见所摄随寻转身语业心不相应行。诸余为胜知见所摄身语业心不相应行。及为胜知见所摄无寻无伺心心所法。为分别慧。有四句。或随寻转非伺相应。谓随寻转身语业。及为分别慧所摄随寻转心不相应行。并寻相应伺。或伺相应非随寻转。谓为分别慧所摄寻。及寻不相应伺相应心心所法。或随寻转亦伺相应。谓为分别慧所摄寻伺相应心心所法。或非随寻转非伺相应。谓除随寻转身语业。诸余为分别慧所摄身语业。及除为分别慧所摄随寻转心不相应行。诸余为分别慧所摄心不相应行。并寻不相应伺。若无寻无伺心心所法。几见非见处等者。一切应分别。谓为现法乐住。有四句。或见非见处。谓为现法乐住所摄尽无生智所不摄无漏慧。或见处非见。谓见所不摄有漏为现法乐住。或见亦见处。谓为现法乐住所摄世间正见。或非见非见处。谓见所不摄无漏为现法乐住为胜知见。或见亦见处。或见处非见。见亦见处者。谓为胜知见所摄世间正见。诸余为胜知见。是见处非见。为分别慧。有四句。或见非见处。谓尽无生智所不摄无漏慧。或见处非见。谓见所不摄有漏为分别慧。或见亦见处。谓为分别慧所摄世间正见。或非见非见处。谓见所不摄无漏为分别慧为尽诸漏所摄慧。是见非见处。余皆非见非见处。几有身见为因非有身见因等者。一切非有身见为因非有身见因。几业非业异熟等者。一切应分别。谓诸修定所摄身语业及思。是业非业异熟。余皆非业非业异熟。几业非随业转等者。一切应分别。谓为现法乐住。有四句。或业非随业转。谓为现法乐住所摄思。或随业转非业。谓为现法乐住所摄受想识蕴。及思所不摄随业转行蕴。或业亦随业转。谓为现法乐住所摄身语业。或非业非随业转。谓除为现法乐住所摄随业转心不相应行。诸余现法乐住所摄心不相应行。为胜知见及为尽诸漏亦尔。为分别慧。有四句。或业非随业转。谓除为分别慧所摄随业转身语业。诸余为分别慧所摄身语业及思。或随业转非业。谓为分别慧所摄受想识蕴。及思所不摄随业转行蕴。或业亦随业转。谓为分别慧所摄随业转身语业。或非业非随业转。谓除为分别慧所摄随业。转心不相应行。诸余为分别慧所摄心不相应。几所造色非有见色等者。一切应分别。谓诸修定所摄身语业。是所造色非有见色。余皆非所造色非有见色。此四修定几所造色非有对色等者。一切应分别。谓诸修定所摄身语业。是所造色非有对色。余皆非所造色非有对色。几难见故甚深等者。一切难见故甚深甚深故难见。几善非善因等者。一切是善亦善为因。几不善非不善为因等者。一切非不善非不善为因。几无记非无记为因等者。一切非无记非无记为因。几因缘非有因等者。一切是因缘亦有因。几等无间非等无间缘等者。一切应分别。谓各有三句。或是等无间非等无间缘。谓未来现前正起修定所摄心心所法。或是等无间亦等无间缘。谓过去现在修定所摄心心所法。或非等无间非等无间缘。谓除未来现前正起修定所摄心心所法。诸余未来修定所摄心心所法。及修定所摄身语业心不相应行。几所缘缘非有所缘等者。一切应分别。谓诸修定所摄身语业心不相应行。是所缘缘非有所缘。余皆是所缘缘亦有所缘。几增上缘非有增上等者。一切是增上缘亦有增上。几暴流非顺暴流等者。一顺暴流非暴流。一非暴流非顺暴流。二应分别。谓为现法乐住及为分别慧。若有漏是顺暴流非暴流。若无漏非暴流非顺暴流

七觉支者。谓念等觉支。乃至舍等觉支。此七觉支几有色等者。一切无色。几有见等者。一切无见。几有对等者。一切无对。几有漏等者。一切无漏。几有为等者。一切有为。几有异熟等者。一切无异熟。几是缘生等者。一切是缘生是因生是世摄。几色摄等者。一切名摄。几内处摄等者。一切外处摄。几智遍知所遍知等者。一切是智遍知所遍知

说一切有部品类足论卷第十四阿毗达磨品类足论卷第十五

        尊者世友造

        三藏法师玄奘奉　诏译

    辩千问品第七之六

此七觉支几断遍知所遍知等者。一切非断遍知所遍知。几应断等者。一切不应断。几应修等者。一切是应修。几染污等者。一切不染污。几果非有果等者。一切是果亦有果。几有执受等者。一切无执受。几大种所造等者。一切非大种所造。几有上等者。一切有上。几是有等者。一切非有。几因相应等者。一切因相应

此七觉支。与六善处相摄者。二善处少分摄七觉支。七觉支亦摄二善处少分。与五不善处相摄者。互不相摄。与七无记处相摄者。互不相摄。与三漏处相摄者。互不相摄。与五有漏处相摄者。互不相摄。与八无漏处相摄者。二无漏处少分摄七觉支。七觉支亦摄二无漏处少分。几过去等者。一切或过去或未来或现在。几善等者。一切是善。几欲界系等者。一切不系。几学等者。一切应分别。谓念等觉支。或学或无学。云何学。谓学作意相应念等觉支。云何无学。谓无学作意相应念等觉支。余六等觉支亦尔

此七觉支几见所断等者。一切非所断。几非心等者。一切是心所与心相应。几随心转非受相应等者。一随心转非受相应。六随心转亦受相应。几随心转非想行相应等者。一切随心转想行相应。除其自性。几随寻转非伺相应等者。一切应分别。谓念等觉支。或有寻有伺。或无寻唯伺。或无寻无伺。云何有寻有伺。谓有寻有伺作意相应念等觉支。云何无寻唯伺。谓无寻唯伺作意相应念等觉支。云何无寻无伺。谓无寻无伺作意相应念等觉支。择法精进轻安定舍等觉支亦尔。喜等觉支。或有寻有伺。或无寻无伺。云何有寻有伺。谓有寻有伺作意相应喜等觉支。云何无寻无伺。谓无寻无伺作意相应喜等觉支。几见非见处等者。六非见。非见处。一应分别。谓择法等觉支所摄尽无生智所不摄慧。是见非见处。余皆非见非见处。几有身见为因非有身见因等者。一切非有身见为因非有身见因。几业非业异熟等者。一切非业非业异熟。几业非随业转等者。一切随业转非业。几所造色非有见色等者。一切非所造色非有见色

此七觉支几所造色非有对色等者。一切非所造色非有对色。几难见故甚深等者。一切难见故甚深甚深故难见。几善非善为因等者。一切是善亦善为因。几不善非不善为因等者。一切非不善非不善为因。几无记非无记为因等者。一切非无记非无记为因。几因缘非有因等者。一切是因缘亦有因。几等无间非等无间缘等者。一切应分别。谓念等觉支。或是等无间非等无间缘。或是等无间亦等无间缘。或非等无间非等无间缘。是等无间非等无间缘者。谓未来现前正起念等觉支。是等无间亦等无间缘者。谓过去现在念等觉支。非等无间非等无间缘者。谓除未来现前正起念等觉支。诸余未来念等觉支。余六等觉支亦尔。几所缘缘非有所缘等者。一切是所缘缘亦有所缘。几增上缘非有增上等者。一切是增上缘亦有增上。几暴流非顺暴流等者。一切非暴流非顺暴流

二十二根者。谓眼根乃至具知根。此二十二根几有色等者。七有色十五无色。几有见等者。一切无见。几有对等者。七有对十五无对。几有漏等者。十有漏。三无漏。九应分别。谓意根。或有漏。或无漏。云何有漏。谓有漏作意相应意根。云何无漏。谓无漏作意相应意根。乐喜舍信精进念定慧根亦尔。几有为等者。一切有为。几有异熟等者。一有异熟。十一无异熟。十应分别。谓意根或有异熟或无异熟。云何有异熟。谓不善善有漏意根。云何无异熟。谓无记无漏意根。乐喜舍根亦尔。苦根或有异熟或无异熟。云何有异熟。谓善不善苦根。云何无异熟。谓无记苦根。信精进念定慧根。若有漏有异熟。若无漏无异熟。几是缘生等者。一切是缘生是因生是世摄。几色摄等者。七是色摄。十五是名摄。几内处摄等者。八内处摄。十一外处摄。三应分别。谓未知当知根已知根具知根。所摄心意识。内处摄。余皆外处摄。几智遍知所遍知等者。一切是智遍知所遍知

此二十二根几断遍知所遍知等者。十是断遍知所遍知。三非断遍知所遍知。九应分别。谓意等九根。若有漏是断遍知所遍知。若无漏非断遍知所遍知。几应断等者。十应断。三不应断。九应分别。谓意等九根。若有漏是应断。若无漏不应断几应修等者。八应修八不应修。六应分别。谓意根。或应修。或不应修。云何应修。谓善意根。云何不应修。谓不善无记意根。乐苦喜舍根亦尔。忧根或应修或不应修。云何应修。谓善忧根。云何不应修。谓不善忧根。几染污等者。十六不染污。六应分别。谓意根或染污或不染污。云何染污。谓有覆意根。云何不染污。谓无覆意根。乐苦喜忧舍根亦尔。几果非有果等者。一切是果亦有果。几有执受等者。十五无执受。七应分别。谓眼根或有执受或无执受。云何有执受。谓自体所摄眼根。云何无执受。谓非自体所摄眼根。余六色根亦尔。几大种所造等者。七大种所造。十五非大种所造。几有上等者。一切是有上。几是有等者。十是有三非有。九应分别。谓意等九根。若有漏是有。若无漏非有。几因相应等者。八因不相应。十四因相应

此二十二根与六善处相摄者。应作四句。或善处非根。谓善色蕴想蕴。及根所不摄善行蕴并择灭。或根非善处。谓八根及六根少分。或善处亦根。谓八根及六根少分。或非善处非根。谓不善色蕴行蕴。不善无记想蕴。及根所不摄色蕴行蕴。并虚空非择灭。与五不善处相摄者。应作四句。或不善处非根。谓不善色想行蕴。或根非不善处。谓十六根及六根少分。或不善处亦根。谓六根少分。或非不善处非根。谓善色蕴。善无记想蕴。根所不摄善无记行蕴。及根所不摄无记色蕴。并无为法。与七无记处相摄者。应作四句。或无记处非根。谓无记想蕴。及根所不摄无记色蕴行蕴。并虚空非择灭。或根非无记处。谓九根及五根少分。或无记处亦根。谓八根及五根少分。或非无记处非根。谓善不善色蕴想蕴不善行蕴。及根所不摄善行蕴并择灭。与三漏处相摄者。互不相摄。与五有漏处相摄者。应作四句。或有漏处非根。谓有漏想蕴。及根所不摄有漏色蕴行蕴。或根非有漏处。谓三根及九根少分。或有漏处亦根。谓十根及九根少分。或非有漏处非根。谓无漏色蕴想蕴。及根所不摄无漏行蕴。并三无为。与八无漏处相摄者。应作四句。或无漏处非根。谓无漏色蕴想蕴。及根所不摄无漏行蕴。并三无为。或根非无漏处。谓十根及九根少分。或无漏处亦根。谓三根及九根少分。或非无漏处非根。谓有漏想蕴。及根所不摄有漏色蕴行蕴。几过去等者。一切或过去或未来或现前。几善等者八善八无记。六应分别。谓意根或善或不善或无记。云何善。谓善作意相应意根。云何不善。谓不善作意相应意根。云何无记。谓无记作意相应意根。乐苦喜舍根亦尔。忧根或善或不善。云何善谓善作意相应忧根。云何不善。谓不善作意相应忧根。几欲界系等者。四欲界系三不系。十五应分别。谓眼根或欲界系。或色界系。云何欲界系。谓欲界大种所造眼根。云何色界系。谓色界大种所造眼根。耳鼻舌身根亦尔。命根或欲界系。或色界系。或无色界系。云何欲界系。谓欲界寿。云何色界系。谓色界寿。云何无色界系。谓无色界寿。意根或欲界系。或色界系。或无色界系。或不系。云何欲界系。谓欲界作意相应意根。云何色界系。谓色界作意相应意根。云何无色界系。谓无色界作意相应意根。云何不系。谓无漏作意相应意根。舍及信等五根亦尔。乐根或欲界系。或色界系。或不系。云何欲界系。谓欲界作意相应乐根。云何色界系。谓色界作意相应乐根。云何不系。谓无漏作意相应乐根。喜根亦尔。几学等者。二学。一无学。十非学非无学。九应分别。谓意根。或学或无学或非学非无学云何学。谓学作意相应意根。云何无学。谓无学作意相应意根。云何非学非无学。谓有漏作意相应意根。乐喜舍信等五根亦尔

此二十二根几见所断等者。九修所断。三非所断。十应分别。谓意根。或见所断。或修所断。或非所断。云何见所断。谓意根随信随法行现观边忍所断。此复云何。谓见所断八十八随眠相应意根。云何修所断。谓意根学见迹修所断。此复云何。谓修所断十随眠相应意根。及不染污有漏意根。云何非所断谓无漏意根。舍根亦尔。乐根或见所断。或修所断。或非所断。云何见所断。谓乐根随信随法行现观边忍所断。此复云何。谓见所断二十八随眠相应乐根。云何修所断。谓乐根学见迹修所断。此复云何。谓修所断五随眠相应乐根。及不染污有漏乐根。云何非所断。谓无漏乐根喜根或见所断。或修所断。或非所断。云何见所断。谓喜根随信随法行现观边忍所断。此复云何。谓见所断五十二随眠相应喜根。云何修所断。谓善根学见迹修所断。此复云何。谓修所断六随眠相应喜根。及不染污有漏喜根。云何非所断。谓无漏喜根。忧根或见所断或修所断云何见所断。谓忧根随信随法行现观边忍所断。此复云何。谓见所断十六随眠相应忧根。云何修所断。谓忧根学见迹修所断此复云何。谓修所断二随眠相应忧根。及不染污忧根。信等五根。若有漏修所断。若无漏非所断。几非心等者。八非心非心所非心相应。十是心所与心相应。一唯是心。三应分别。谓三无漏根所摄八根。是心所与心相应。一根唯是心。几随心转非受相应等者。五随心转非受相应。一受相应非随心转。五随心转亦受相应。八非随心转非受相应。三应分别。谓三无漏根所摄三根。随心转非受相应。一根受相应。非随心转。五根随心转亦受相应。几随心转非想行相应等者。一想相应非随心转。十随心转亦想相应。八非随心转非想相应。三应分别。谓三无漏根所摄八根。随心转亦想相应。一根想相应非随心转。一行相应非随心转。十随心转亦行相应。除其自性。八非随心转非行相应。三应分别。谓三无漏根所摄。一行相应非随心转。八随心转亦行相应。除其自性。几随寻转非伺相应等者。二有寻有伺。八无寻无伺。十二应分别。谓意根。或有寻有伺。或无寻唯伺。或无寻无伺。云何有寻有伺。谓有寻有伺作意相应意根。云何无寻惟伺。谓无寻唯伺作意相应意根。云何无寻无伺。谓无寻无伺作意相应意根。舍根信等五根三无漏根亦尔。乐根。或有寻有伺。或无寻无伺。云何有寻有伺。谓有寻有伺作意相应乐根。云何无寻无伺。谓无寻无伺作意相应乐根。喜根亦尔。几见非见处等者。一见亦见处。九见处非见。十二应分别。谓意根。若有漏是见处非见。若无漏非见非见处。乐喜舍根信等四根亦尔。慧根有四句。或见非见处。谓尽无生智所不摄无漏慧根。或见处非见。谓见所不摄。有漏慧根。或见亦见处。谓世间正见。或非见。非见处。谓见所不摄无漏慧根。未知当知根已知根所摄慧。是见非见处。余皆非见非见处。具知根所摄尽无生智所不摄慧根。是见非见处。余非见非见处。几有身见为因非有身见因等者。十六非有身见为因非有身见因。六应分别。谓意根。或有身见为因非有身见因。或有身见为因亦有身见因。或非有身见为因非有身见因。有身见为因非有身见因者。谓除过去现在见苦所断随眠相应意根。亦除过去现在见集所断遍行随眠相应意根。亦除未来有身见相应意根。诸余染污意根。有身见为因亦有身见因者。谓前所除意根。非有身见为因非有身见因者。谓不染污意根。乐喜舍根亦尔。苦根若染污有身见为因非有身见因。若不染污非有身见为因非有身见因。忧根或有身见为因非有身见因。或有身见为因亦有身见因。或非有身见为因非有身见因。有身见为因非有身见因者。谓除过去现在见苦所断随眠相应忧根。及除过去现在见集所断遍行随眠相应忧根。诸余染污忧根。有身见为因亦有身见因者。谓前所除忧根。非有身见为因非有身见因者。谓不染污忧根。几业非业异熟等者。一是业异熟非业九非业非业异熟。十二应分别。谓眼根。或是业异熟非业。或非业非业异熟。是业异熟非业者。谓异熟生眼根。余眼根非业非业异熟。耳鼻舌身女男根意乐苦喜舍根亦尔。几业非随业转等者。八非业非随业转。十四随业转非业。几所造色非有见色等者。七是所造色非有见色。十五非所造色非有见色

此二十二根。几所造色非有对色等者。七是所造色亦有对色。十五非所造色非有对色。几难见故甚深等者。一切难见故甚深甚深故难见。几善非善为因等者。八是善亦善为因。十四应分别。谓眼根。或善为因非善。或非善非善为因。善为因非善者。谓善异熟生眼根。诸余眼根非善非善为因。耳鼻舌身女男命根亦尔。意根或善为因非善。或是善亦善为因。或非善非善为因。善为因非善者。谓善异熟生意根。是善亦善为因者。谓善意根。非善非善为因者。谓除善异熟生意根。诸余无记不善意根。乐喜舍根亦尔。苦根或是善亦善为因。或非善非善为因。是善亦善为因者。谓善苦根。非善非善为因者。谓不善无记苦根。忧根或是善亦善为因。或非善非善为因。是善亦善为因者。谓善忧根。非善非善为因者。谓不善忧根。几不善非不善为因等者。八非不善非不善为因。十四应分别。谓眼根。或不善为因非不善。或非不善非不善为因。不善为因非不善者。不善异熟生眼根。诸余眼根非不善非不善为因。耳鼻舌身女男命根亦尔。意根。或不善为因非不善。或不善亦不善为因。或非不善非不善为因。不善为因非不善者。谓不善异熟生意根。及欲界系有身见边执见相应意根。不善亦不善为因者。谓不善意根。非不善非不善为因者。谓除不善异熟生意根。及除欲界系有身见边执见相应意根。诸余无记及善意根。乐根或不善亦不善为因。或非不善非不善为因。不善亦不善为因者。谓不善乐根。非不善非不善为因者。谓善无记乐根。苦根或不善为因非不善。或不善亦不善为因。或非不善非不善为因。不善为因非不善者。谓异熟生苦根。不善亦不善为因者。谓不善苦根。非不善非不善为因者。谓除异熟生苦根。诸余无记及善苦根。喜根或不善为因非不善。或不善亦不善为因。或非不善非不善为因。不善为因非不善者。谓欲界系有身见边执见相应喜根。不善亦不善为因者。谓不善喜根。非不善非不善为因者。谓除欲界系有身见边执见相应喜根。诸余无记及善喜根。舍根亦尔。忧根或不善亦不善为因。或非不善非不善为因。不善亦不善为因者。谓不善忧根。非不善非不善为因者。谓善忧根。几无记非无记为因等者。八无记亦无记为因。八非无记非无记为因。六应分别。谓意根。或无记为因非无记。亦无记亦无记为因。或非无记非无记为因。无记为因非无记者。谓不善意根。无记亦无记为因者。谓无记意根。非无记非无记为因者。谓善意根。乐苦喜舍根亦尔。忧根或无记为因非无记。或非无记非无记为因。无记为因非无记者。谓不善忧根。非无记非无记为因者。谓善忧根。几因缘非有因等者。一切是因缘亦有因。几等无间非等无间缘等者。八非等无间非等无间缘。十四应分别。谓意根。或是等无间非等无间缘。或是等无间亦等无间缘。或非等无间非等无间缘。是等无间非等无间缘者。谓未来现前正起意根。及过去现在阿罗汉命终时意根。是等无间亦等无间缘者。谓除过去现在阿罗汉命终时意根。诸余过去现在意根。非等无间非等无间缘者。谓除未来现前正起意根。诸余未来意根。舍根亦尔。乐根或是等无间非等无间缘。或是等无间亦等无间缘。或非等无间非等无间缘。是等无间非等无间缘者。谓未来现前正起乐根。是等无间亦等无间缘者。谓过去现在乐根。非等无间非等无间缘者。谓除未来现前正起乐根。诸余未来乐根。苦喜忧根信等五根三无漏根亦尔。几所缘缘非有所缘等者。八是所缘缘非有所缘。十四是所缘缘亦有所缘。几增上缘亦有增上等者。一切是增上缘亦有增上。几暴流非顺暴流等者。十顺暴流非暴流。三非暴流非顺暴流。九应分别。谓意等九根。若有漏顺暴流非暴流。若无漏非暴流非顺暴流

十二处者。谓眼处色处乃至意处法处。此十二处几有色等者。十有色一无色。一应分别。谓法处。或有色或无色。云何有色。谓法处所摄身语业。云何无色。谓余法处。几有见等者。一有见十一无见。几有对等者。十有对二无对。几有漏等者。十有漏。二应分别。谓意处。或有漏或无漏。云何有漏。谓有漏作意相应意处。云何无漏。谓无漏作意相应意处。法处或有漏或无漏。云何有漏。谓法处所摄有漏身语业。及有漏受想行蕴。云何无漏。谓无漏身语业。及无漏受想行蕴。并无为法。几有为等者。十一有为。一应分别。谓法处或有为或无为。云何有为。谓法处所摄身语业。及受想行蕴。云何无为。谓虚空及二灭。几有异熟等者。八无异熟。四应分别。谓色处。或有异熟或无异熟。云何有异熟。谓善不善色处。云何无异熟。谓无记色处。声处亦尔。意处或有异熟。或无异熟。云何有异熟。谓不善善有漏意处。云何无异熟。谓无记无漏意处。法处亦尔。几是缘生等者。十一是缘生是因生是世摄。一应分别。谓法处若有为是缘生是因生是世摄。若无为非缘生非因生非世摄。几色摄等者。十色摄一名摄。一应分别。谓法处所摄身语业是色摄。余皆是名摄。几内处摄等者。六是内处摄。六是外处摄。几智遍知所遍知等者。一切是智遍知所遍知

此十二处几断遍知所遍知等者。十是断遍知所遍知。二应分别。谓意法处。若有漏是断遍知所遍知。若无漏非断遍知所遍知。几应断等者。十应断。二应分别。谓意法处。若有漏是应断。若无漏不应断。几应修等者。八不应修。四应分别。谓色处或应修或不应修。云何应修。谓善色处。云何不应修。谓不善无记色处。声处意处亦尔。法处或应修或不应修。云何应修。谓善有为法处。云何不应修。谓不善无记法处及择灭。几染污等者。八不染污。四应分别。谓色处或染污或不染污。云何染污。谓有覆色处。云何不染污。谓无覆色处。声意法处亦尔。几果非有果等者。十一是果亦有果。一应分别。谓法处。或是果非有果。或是果亦有果。或非果非有果。是果非有果者。谓择灭是果亦有果者。谓有为法处。非果非有果者。谓虚空非择灭。几有执受等者。三无执受。九应分别。谓眼处。或有执受。或无执受。云何有执受。谓自体所摄眼处。云何无执受。谓非自体所摄眼处。色耳鼻香舌味身触处亦尔。几大种所造等者。九是大种所造。一非大种所造。二应分别。谓触处坚湿暖动非大种所造。余是大种所造。法处所摄身语业。是大种所造。余非大种所造。几有上等者。十一有上。一应分别。谓法处择灭是无上。余皆是有上。几是有等者。十是有。二应分别。谓意法处。若有漏是有。若无漏非有。几因相应等者。十因不相应。一因相应。一应分别。谓法处诸心所法。是因相应。余因不相应

说一切有部品类足论卷第十五阿毗达磨品类足论卷第十六

        尊者世友造

        三藏法师玄奘奉　诏译

    辩千问品第七之七

此十二处与六善处相摄者。六善处摄四处少分。四处少分亦摄六善处。与五不善处相摄者。五不善处摄四处少分。四处少分亦摄五不善处。与七无记处相摄者。七无记处摄八处四处少分。八处四处少分亦摄七无记处。与三漏处相摄者。三漏处摄一处少分。一处少分亦摄三漏处。与五有漏处相摄者。五有漏处摄十处二处少分。十处二处少分亦摄五有漏处。与八无漏处相摄者。八无漏处摄二处少分。二处少分亦摄八无漏处。几过去等者。十一或过去或未来或现在。一应分别。谓法处若有为。或过去或未来或现在。若无为。非过去非未来非现在。几善等者。八无记。四应分别。谓色处。或善或不善或无记。云何善。谓善身表。云何不善。谓不善身表。云何无记。谓除善不善身表。诸余色处。声处或善或不善或无记。云何善。谓善语表。云何不善。谓不善语表。云何无记。谓除善不善语表。诸余声处。意处或善或不善或无记。云何善。谓善作意相应意处。云何不善。谓不善作意相应意处。云何无记。谓无记作意相应意处。法处或善或不善或无记。云何善。谓法处所摄善身语业。及善受想行蕴并择灭。云何不善。谓法处所摄不善身语业。及不善受想行蕴。云何无记。谓无记受想行蕴。及虚空非择灭。几欲界系等者。二欲界系。十应分别。谓眼处。或欲界系或色界系。云何欲界系。谓欲界大种所造眼处。云何色界系。谓色界大种所造眼处。色耳声鼻舌身处亦尔。触处或欲界系或色界系。云何欲界系。谓欲界四大种。及欲界大种所造触处。云何色界系。谓色界四大种。及色界大种所造触处。意处或欲界系。或色界系。或无色界系。或不系。云何欲界系。谓欲界作意相应意处。云何色界系。谓色界作意相应意处。云何无色界系。谓无色界作意相应意处。云何不系。谓无漏作意相应意处。法处或欲界系。或色界系。或无色界系。或不系。云何欲界系。谓法处所摄欲界身语业。及欲界受想行蕴。云何色界系。谓法处所摄色界身语业。及色界受想行蕴。云何无色界系。谓无色界受想行蕴。云何不系。谓无漏身语业。及无漏受想行蕴。并三无为。几学等者。十非学非无学。二应分别。谓意处或学或无学或非学非无学。云何学。谓学作意相应意处。云何无学。谓无学作意相应意处。云何非学非无学。谓有漏作意相应意处。法处或学或无学或非学非无学。云何学。谓学身语业。及学受想行蕴。云何无学。谓无学身语业。及无学受想行蕴。云何非学非无学。谓法处所摄有漏身语业。及有漏受想行蕴。并虚空二灭。此十二处几见所断等者。十修所断。二应分别。谓意处或见所断或修所断。或非所断。云何见所断。谓意处随信随法行现观边忍所断。此复云何。谓见所断八十八随眠相应意处。云何修所断。谓意处学见迹修所断。此复云何。谓修所断十随眠相应意处。及不染污有漏意处。云何非所断。谓无漏意处。法处或见所断。或修所断。或非所断。云何见所断。谓法处随信随法行现观边忍所断。此复云何。谓见所断八十八随眠。及彼相应法处。并彼等起心不相应行。云何修所断。谓法处学见迹修所断。此复云何。谓修所断十随眠。及彼相应法处。并彼等起无表身语业心不相应行。若不染污有漏法处。云何非所断。谓无漏法处。几非心等者。十非心非心所非心相应。一唯是心。一应分别。谓法处若有所缘。是心所与心相应。若无所缘。非心非心所非心相应。几随心转非受相应等者。十非随心转非受相应。一受相应非随心转。一应分别。谓法处。或随心转非受相应。或随心转亦受相应。或非随心转非受相应。随心转非受相应者。谓随心转身语业心不相应行及受。随心转亦受相应者。谓想蕴及相应行蕴。非随心转非受相应者。谓除随心转身语业心不相应行。诸余身语业心不相应行。及无为法。几随心转非想行相应等者。除其自性。如受应知。几随寻转非伺相应等者。十非随寻转非伺相应。二应分别。谓意处。或有寻有伺。或无寻唯伺。或无寻无伺。云何有寻有伺。谓有寻有伺作意相应意处。云何无寻唯伺。谓无寻唯伺作意相应意处。云何无寻无伺。谓无寻无伺作意相应意处。法处。有四句。或随寻转非伺相应。谓随寻转身语业。心不相应行。及寻相应伺。或伺相应非随寻转。谓寻及寻不相应伺。相应心所法。或随寻转亦伺相应。谓寻伺相应心所法。或非随寻转非伺相应。谓除随寻转身语业心不相应行。诸余身语业心不相应行。及寻不相应伺。并无寻无伺心所法。若无为法。几见非见处等者。一见亦见处。九见处非见。二应分别。谓意处。若有漏是见处非见。若无漏非见处非见。法处。有四句。或见非见处。谓尽无生智所不摄无漏慧。或见处非见。谓见所不摄有漏法处。或见亦见处。谓五染污见世俗正见。或非见非见处。谓见所不摄无漏法处。几有身见为因非有身见因等者。八非有身见为因非有身见因。四应分别。谓色处。若染污有身见为因非有身见因。若不染污非有身见为因非有身见因。声处亦尔。意处。或有身见为因非有身见因。或有身见为因亦有身见因。或非有身见为因非有身见因。有身见为因非有身见者。谓除过去现在见苦所断随眠相应意处。亦除过去现在见集所断遍行随眠相应意处。亦除未来有身见相应意处。诸余染污意处。有身见为因亦有身见因者。谓前所除意处。非有身见为因非有身见因者。谓不染污意处。法处。或有身见为因非有身见因。或有身见为因亦有身见因。或非有身见为因非有身见因。有身见为因非有身见因者。谓除过去现在见苦所断随眠及彼相应俱有等法处。亦除过去现在见集所断遍行随眠及彼相应俱有法处。亦除未来有身见相应法处。亦除未来有身见及彼相应法生老住无常。诸余染污法处。有身见为因亦有身见因者。谓前所除法处。非有身见为因非有身见因者。谓不染污法处。几业非业异熟等者。一切应分别。谓眼处。或业异熟非业。或非业非业异熟。业异熟非业者。谓异熟生眼处。诸余眼处。非业非业异熟。耳鼻香舌味身触意处亦尔。色处。或是业非业异熟。或业异熟非业。或非业非业异熟。是业非业异熟者。谓身表。业异熟非业者。谓业异熟生色处。非业非业异熟者。谓除业及业异熟色处。诸余色处声处。或是业非业异熟。或非业非业异熟。是业非业异熟者。谓语表。诸余声处。非业非业异熟。法处。有四句。或业非业异熟。谓法处所摄身语业。及异熟所不摄思。或业异熟非业。谓思所不摄业异熟生法处。或业亦业异熟。谓异熟生思。或非业非业异熟。谓除业及业异熟法处。诸余法处。几业非随业转等者。八非业非随业转。一随业转非业。三应分别。谓色处。或是业非随业转。或非业非随业转。是业非随业转者。谓身表。诸余色处。非业非随业转。声处。或是业非随业转。或非业非随业转。是业非随业转者。谓语表。诸余声处。非业非随业转。法处有四句。或业非随业转。谓除随业转身语业。诸余法处所摄身语业及思。或随业转非业。谓受蕴想蕴。及思所不摄随业转行蕴。或业亦随业转。谓随业转身语业。或非业非随业转。谓除业及随业转法处。诸余法处。几所造色非有见色等者。有三句。或所造色非有见色。谓八处及二处少分。或所造色亦有见色。谓一处。或非所造色非有见色。谓一处及二处少分

此十二处几所造色非有对色等者。有四句。或所造色非有对色。谓一处少分。或有对色非所造色。谓一处少分。或所造色亦有对色。谓九处一处少分。或非所造色非有对色。谓一处一处少分。几难见故甚深等者。一切难见故甚深。甚深故难见。几善非善为因等者。一切应分别。谓眼处。或善为因非善。或非善非善为因。善为因非善者。谓善异熟生眼处。诸余眼处。非善非善为因。耳鼻香舌味身触处亦尔。色处。或善为因非善。或善亦善为因。或非善非善为因。善为因非善者。谓善异熟生色处。善亦善为因者。谓善色处。非善非善为因者。谓除善异熟生色处。诸余无记。及不善色处。意处亦尔。声处。或善亦善为因。或非善非善为因。善亦善为因者。谓善声处。诸余声处。非善非善为因。法处。有四句。或善非善为因。谓择灭。或善为因非善。谓善异熟生。法处。或善亦善为因。谓善有为法处。或非善非善为因。谓除善异熟生法处。诸余无记。及不善法处。几不善非不善为因等者。一切应分别。谓眼处。或不善为因非不善。或非不善非不善为因。不善为因非不善者。谓不善异熟生眼处。诸余眼处。非不善非不善为因。耳鼻香舌味身触处亦尔。色处。或不善为因非不善。或不善亦不善为因。或非不善非不善为因。不善为因非不善者。谓不善异熟生色处。不善亦不善为因者。谓不善色处。非不善非不善为因者。谓除不善异熟生色处。诸余无记。及善色处。声处。或不善亦不善为因。或非不善非不善为因。不善亦不善为因者。谓不善声处。诸余声处。非不善非不善为因。意处。或不善为因非不善。或不善亦不善为因。或非不善非不善为因。不善为因非不善者。谓不善异熟生意处。及欲界有身见边执见相应意处。或不善亦不善为因者。谓不善意处。非不善非不善为因者。谓除不善异熟生意处。及除欲界有身见边执见相应意处。诸余无记。及善意处。法处。或不善为因非不善。或不善亦不善为因。或非不善非不善为因。不善为因非不善者。谓不善异熟生法处。及欲界有身见边执见。并彼相应法处。若彼等起心不相应行。不善亦不善为因者。谓不善等起法处。非不善非不善为因者。谓除不善异熟生法处。及除欲界有身见边执见并彼相应法处若彼等起心不相应行。诸余无记。及善法处。几无记非无记为因等者。八无记亦无记为因。四应分别。谓色处。或无记为因非无记。或无记亦无记为因。或非无记非无记为因。无记为因非无记者。谓不善色处。无记亦无记为因者。谓无记色处。非无记非无记为因者。谓善色处。声意处亦尔。法处有四句。或无记非无记为因。谓虚空非择灭。或无记为因非无记。谓不善法处。或无记亦无记为因。谓无记有为法处。或非无记非无记为因。谓善法处。几因缘非有因等者。十一是因缘亦有因。一应分别。谓法处若有为是因缘亦有因。若无为非因缘非有因。几等无间非等无间缘等者。十非等无间非等无间缘。二应分别。谓意处。或是等无间非等无间缘。或是等无间亦等无间缘。或非等无间非等无间缘。是等无间非等无间缘者。谓未来现前正起意处。及过去现在阿罗汉命终时意处。是等无间亦等无间缘者。谓除过去现在阿罗汉命终时意处。诸余过去现在意处。非等无间非等无间缘者。谓除未来现前正起意处。诸余未来意处法处。或是等无间非等无间缘。或是等无间亦等无间缘。或非等无间非等无间缘。是等无间非等无间缘者。谓未来现前正起诸心所法。及过去现在阿罗汉命终时诸心所法。并已生正起无想灭定。是等无间亦等无间缘者。谓除过去现在阿罗汉命终时诸心所法。诸余过去现在诸心所法。非等无间非等无间缘者。谓除未来现前正起诸心所法。诸余未来心所法。及除等无间心不相应行。诸余心不相应行。并身语业虚空二灭。几所缘缘非有所缘等者。十所缘缘非有所缘。一所缘缘亦有所缘。一应分别。谓法处若诸心所。是所缘缘亦有所缘。若非心所。是所缘缘非有所缘。几增上缘非有增上等者。十一是增上缘亦有增上。一应分别。谓法处若有为是增上缘亦有增上。若无为是增上缘非有增上。几暴流非顺暴流等者。十顺暴流非暴流。二应分别。谓意处若有漏顺暴流非暴流。若无漏非暴流非顺暴流。法处或顺暴流非暴流。或暴流亦顺暴流。或非暴流非顺暴流。顺暴流非暴流者。谓暴流所不摄有漏法处。暴流亦顺暴流者。谓四暴流。非暴流非顺暴流者。谓无漏法处

五蕴者。谓色蕴乃至识蕴。此五蕴几有色等者。一有色四无色。几有见等者。四无见。一应分别。谓色蕴或有见或无见。云何有见。谓一处。云何无见。谓九处一处少分。几有对等者。四无对。一应分别。谓色蕴或有对或无对。云何有对。谓十处。云何无对。谓一处少分。几有漏等者。一切应分别。谓色蕴或有漏或无漏。云何有漏。谓十处一处少分。云何无漏。谓一处少分。受蕴或有漏或无漏。云何有漏。谓有漏作意相应受蕴。云何无漏。谓无漏作意相应受蕴。想识蕴亦尔。行蕴或有漏或无漏。云何有漏。谓有漏心相应。及心不相应行蕴。云何无漏。谓无漏心相应。及心不相应行蕴。几有为等者。一切是有为。几有异熟等者。一切应分别。谓色蕴或有异熟或无异熟。云何有异熟。谓不善善有漏色蕴。云何无异熟。谓无记无漏色蕴。余四蕴亦尔。几是缘生等者。一切是缘生是因生是世摄。几色摄等者。一是色摄四是名摄。几内处摄等者。一内处摄。三外处摄。一应分别。谓色蕴或内处摄或外处摄。云何内处摄。谓五内处。云何外处摄。谓五外处。及一外处少分。几智遍知所遍知等者。一切是智遍知所遍知

此五蕴几断遍知所遍知等者。一切应分别。谓诸蕴若有漏是断遍知所遍知。若无漏非断遍知所遍知。几应断等者。一切应分别。谓诸蕴若有漏是应断。若无漏不应断。几应修等者。一切应分别。谓诸蕴若是善是应修。若非善不应修。几染污等者。一切应分别。谓诸蕴若有覆是染污。若无覆不染污。几果非有果等者。一切是果亦有果。几有执受等者。四无执受。一应分别。谓色蕴或有执受或无执受。云何有执受。谓自体所摄色蕴。云何无执受。谓非自体所摄色蕴。几大种所造等者。四非大种所造。一应分别。谓色蕴或是大种所造。或非大种所造。云何大种所造。谓九处二处少分。云何非大种所造。谓一处少分。几有上等者。一切是有上。几是有等者。一切应分别。谓诸蕴若有漏是有。若无漏非有。几因相应等者。一因不相应。三因相应。一应分别。谓行蕴若诸心所是因相应。若非心所因不相应

此五蕴与六善处相摄者。有四句。或善处非蕴。谓择灭。或蕴非善处。谓不善无记五蕴。或善处亦蕴。谓善五蕴。或非善处非蕴。谓虚空非择灭。与五不善处相摄者。五不善处摄五蕴少分。五蕴少分亦摄五不善处。与七无记处相摄者。有四句。或无记处非蕴。谓虚空非择灭。或蕴非无记处。谓善不善五蕴。或无记处亦蕴。谓无记五蕴。或非无记处非蕴。谓择灭与三漏处相摄者。三漏处摄一蕴少分。一蕴少分亦摄三漏处。与五有漏处相摄者。五有漏处摄五蕴少分。五蕴少分亦摄五有漏处与八无漏处相摄者。应作四句。或无漏处非蕴。谓虚空二灭。或蕴非无漏处。谓有漏五蕴。或无漏处亦蕴。谓无漏五蕴。或非无漏处非蕴。如是事。不可得。几过去等者。一切或过去或未来或现在。几善等者。一切应分别。谓诸蕴或善或不善或无记。云何善。谓善五蕴。云何不善。谓不善五蕴。云何无记。谓无记五蕴。几欲界系等者。一切应分别。谓诸蕴。或欲界系。或色界系。或无色界系。或不系。云何欲界系谓欲界五蕴。云何色界系。谓色界五蕴。云何无色界系。谓无色界四蕴。云何不系。谓无漏五蕴。几学等者。一切应分别。谓诸蕴。或学。或无学。或非学非无学。云何学。谓学五蕴。云何无学。谓无学五蕴。云何非学非无学。谓有漏五蕴

此五蕴几见所断等者。一切应分别。谓色蕴。若有漏修所断。若无漏非所断。受蕴。或见所断。或修所断。或非所断。云何见所断。谓受蕴随信随法行现观边忍所断。此复云何。谓见所断八十八随眠相应受蕴。云何修所断。谓受蕴学见迹修所断。此复云何。谓修所断十随眠相应受蕴。及不染污有漏受蕴。云何非所断。谓无漏受蕴。想识蕴亦尔。行蕴。或见所断。或修所断。或非所断。云何见所断。谓行蕴随信随法行现观边忍所断。此复云何。谓见所断八十八随眠。及彼相应行蕴。并彼等起心不相应行。云何修所断。谓行蕴学见迹修所断。此复云何。谓修所断十随眠。及彼相应行蕴。并彼等起心不相应行。若不染污有漏行蕴。云何非所断。谓无漏行蕴。几非心等者。一非心非心所非心相应。二是心所与心相应。一唯是心。一应分别。谓行蕴。若有所缘。是心所与心相应。若无所缘。非心非心所非心相应。几随心转非受相应等者。一随心转非受相应。一受相应非随心转。一随心转亦受相应。二应分别。谓色蕴。或随心转非受相应。或非随心转非受相应。随心转非受相应者。谓随心转身语业。诸余色蕴。非随心转非受相应。行蕴。有三句。或随心转非受相应。谓随心转心不相应行。或随心转亦受相应。谓心所行蕴。或非随心转非受相应。谓除随心转心不相应行。诸余心不相应行。几随心转非想行相应等者。除想自性。如受应知。二随心转亦行相应。一行相应非随心转。二应分别。谓色蕴。或随心转非行相应。或非随心转非行相应。随心转非行相应者。谓随心转身语业。诸余色蕴。非随心转非行相应。行蕴。有三句。或随心转非行相应。谓随心转心不相应行。或随心转亦行相应。谓心所行蕴。除其自性。或非随心转非行相应。谓除随心转心不相应行。诸余心不相应行。几随寻转非伺相应等者。一切应分别。谓色蕴。或随寻转非伺相应。或非随寻转非伺相应。随寻转非伺相应者。谓随寻转身语业。诸余色蕴。非随寻转非伺相应。受蕴。或有寻有伺。或无寻唯伺。或无寻无伺。云何有寻有伺。谓有寻有伺作意相应受蕴。云何无寻唯伺。谓无寻唯伺作意相应受蕴。云何无寻无伺。谓无寻无伺作意相应受蕴。想识蕴亦尔。行蕴。有四句。或随寻转非伺相应。谓随寻转心不相应行。及寻相应伺。或伺相应非随寻转。谓寻及寻不相应伺相应心所行蕴。或随寻转亦伺相应。谓寻伺相应心所行蕴。或非随寻转非伺相应。谓除随寻转心不相应行。诸余心不相应行。及寻不相应伺。并无寻无伺心所行蕴。几见非见处等者。一切应分别。谓色蕴。有三句。或见处非见。谓九处及一处少分。或见亦见处。谓一处。或非见非见处。谓一处少分。受想识蕴。若有漏是见处非见。若无漏非见非见处。行蕴。有四句。或见非见处。谓尽无生智所不摄无漏慧。或见处非见。谓见所不摄有漏行蕴。或见亦见处。谓五染污见。及世间正见。或非见非见处。谓见所不摄无漏行蕴

说一切有部品类足论卷第十六阿毗达磨品类足论卷第十七

        尊者世友造

        三藏法师玄奘奉　诏译

    辩千问品第七之八

几有身见为因非有身见因等者。一切应分别。谓色蕴。若染污有身见为因非有身见因。若不染污非有身见为因非有身见因。受蕴有三句。或有身见为因非有身见因。谓除过去现在见苦所断随眠相应受蕴。及除过去现在见集所断遍行随眠相应受蕴。并除未来有身见相应受蕴。诸余染污受蕴。或有身见为因亦有身见因。谓前所除受蕴。或非有身见为因非有身见因。谓不染污受蕴。想识蕴亦尔。行蕴有三句。或有身见为因非有身见因。谓除过去现在见苦所断随眠及彼相应俱有等行蕴。亦除过去现在见集所断遍行随眠及彼相应俱有行蕴。亦除未来有身见相应行蕴。亦除未来有身见及彼相应法生老住无常。诸余染污行蕴。或有身见为因亦有身见因。谓前所除行蕴。或非有身见为因非有身见因。谓不染污行蕴。几业非业异熟等者。一切应分别。谓色蕴。有三句。或业非业异熟。谓身语业。或业异熟非业。谓业异熟生色蕴。或非业非业异熟。谓除业及业异熟色蕴。诸余色蕴受蕴。或业异熟非业。或非业非业异熟。业异熟非业者。谓业异熟生受蕴。诸余受蕴。非业非业异熟。想识蕴亦尔。行蕴有四句。或业非业异熟。谓业异熟所不摄思。或业异熟非业。谓思所不摄业异熟生行蕴。或业亦业异熟。谓业异熟生思。或非业非业异熟。谓除业及业异熟行蕴。诸余行蕴。几业非随业转等者。三随业转非业。二应分别。谓色蕴有三句。或业非随业转。谓除随业转身语业。诸余身语业。或业亦随业转。谓随业转身语业。或非业非随业转。谓除业及随业转色蕴。诸余色蕴行蕴。有三句。或业非随业转。谓思。或随业转非业。谓思所不摄随业转行蕴。或非业非随业转。谓除随业转心不相应行。诸余心不相应行。几所造色非有见色等者。四非所造色非有见色。一应分别。谓色蕴。有三句。或所造色非有见色。谓八处。及二处少分。或所造色亦有见色。谓一处。或非所造色非有见色。谓一处少分

此五蕴几所造色非有对色等者。四非所造色非有对色。一应分别。谓色蕴应作四句。或所造色非有对色。谓一处少分。或有对色非所造色。谓一处少分。或所造色亦有对色。谓九处及一处少分。或非所造色非有对色。如是色不可得。几难见故甚深等者。一切难见故甚深甚深故难见。几善非善为因等者。一切应分别。谓各有三句。或善为因非善。谓善异熟生五蕴。或善亦善为因。谓善五蕴。或非善非善为因。谓除善异熟生五蕴。诸余无记不善五蕴。几不善非不善为因等者。一切应分别。谓色蕴。有三句。或不善为因非不善。谓不善异熟生色蕴。或不善亦不善为因。谓不善色蕴。或非不善非不善为因。谓除不善异熟色蕴。诸余无记。及善色蕴。受蕴有三句。或不善为因非不善。谓不善异熟生受蕴。及欲界系有身见边执见相应受蕴。或不善亦不善为因。谓不善受蕴。或非不善非不善为因。谓除不善异熟生受蕴。及除欲界系有身见边执见相应受蕴。诸余无记。及善受蕴。想识蕴亦尔。行蕴有三句。或不善为因非不善。谓不善异熟生行蕴。及欲界系有身见边执见。及彼相应彼等起行蕴。或不善亦不善为因。谓不善行蕴。或非不善非不善为因。谓除不善异熟行蕴。及除欲界系有身见边执见并彼相应彼等起行蕴。诸余无记。及善行蕴。几无记非无记为因等者。一切应分别。谓各有三句。或无记为因非无记。谓不善五蕴。或无记亦无记为因。谓无记五蕴。或非无记非无记为因。谓善五蕴。几因缘非有因等者。一切是因缘亦有因。几等无间非等无间缘等者。一非等无间非等无间缘。四应分别。谓受蕴。有三句。或是等无间非等无间缘。谓未来现前正起受蕴。及过去现在阿罗汉命终时受蕴。或是等无间亦等无间缘。谓除过去现在阿罗汉命终时受蕴。诸余过去现在受蕴。或非等无间非等无间缘。谓除未来现前正起受蕴。诸余未来受蕴。想识蕴亦尔。行蕴有三句。或是等无间非等无间缘。谓未来现前正起心所行蕴。及过去现在阿罗汉命终时心所行蕴。并已生正起无想灭定。或是等无间亦等无间缘。谓除过去现在阿罗汉命终时心心所行蕴。诸余过去现在心所行蕴。或非等无间非等无间缘。谓除未来现前正起心所行蕴。诸余未来心所行蕴。及除等无间心不相应行。诸余心不相应行。几所缘缘非有所缘等者。一是所缘缘非有所缘。三是所缘缘亦有所缘。一应分别。谓行蕴。若诸心所是所缘缘亦有所缘。若非心所是所缘缘非有所缘。几增上缘非有增上等者。一切是增上缘亦有增上。几暴流非顺暴流等者。一切应分别。谓色蕴。若有漏顺暴流非暴流。若无漏非暴流。非顺暴流。受想识蕴亦尔。行蕴有三句。或顺暴流非暴流。谓暴流所不摄有漏行蕴。或暴流亦顺暴流。谓四暴流。或非暴流非顺暴流。谓无漏行蕴

十八界者。谓眼界色界眼识界。乃至意界法界意识界。此十八界。几有色等者。十有色七无色。一应分别。谓法界。或有色或无色。云何有色。谓法界所摄身语业。诸余法界。是无色。几有见等者。一有见。十七无见。几有对等者。十有对八无对。几有漏等者。十五有漏。三应分别。谓意界。或有漏或无漏。云何有漏。谓有漏作意相应意界。云何无漏。谓无漏作意相应意界。意识界亦尔。法界或有漏或无漏。云何有漏。谓法界所摄有漏身语业。及有漏受想行蕴。云何无漏。谓无漏身语业。及无漏受想行蕴。并无为法。几有为等者。十七是有为。一应分别。谓法界或有为或无为。云何有为。谓法界所摄身语业。及受想行蕴。云何无为。谓虚空二灭。几有异熟等者。八无异熟。十应分别。谓色界或有异熟或无异熟。云何有异熟。谓善不善色界。云何无异熟。谓无记色界声。及五识界亦尔。意界或有异熟或无异熟。云何有异熟。谓不善善有漏意界。云何无异熟。谓无记无漏意界。法界意识界亦尔。几是缘生等者。十七是缘生是因生是世摄。一应分别。谓法界。若有为是缘生是因生是世摄。若无为非缘生非因生非世摄。几色摄等者。十是色摄。七是名摄。一应分别。谓法界所摄身语业。是色摄。余皆是名摄。几内处摄等者。十二是内处摄。六是外处摄。几智遍知所遍知等者。一切是智遍知所遍知

此十八界。几断遍知所遍知等者。十五是断遍知所遍知。三应分别。谓意法意识界。若有漏是断遍知所遍知。若无漏非断遍知所遍知。几应断等者。十五是应断。三应分别。谓意法意识界。若有漏是应断。若无漏不应断。几应修等者。八不应修。十应分别。谓色界或应修或不应修。云何应修。谓善色界。云何不应修。谓不善无记色界。声界六识界意界亦尔。法界或应修或不应修。云何应修。谓善有为法界。云何不应修。谓不善无记法界及择灭。几染污等者。八不染污。十应分别。谓色界或染污或不染污。云何染污。谓有覆色界。云何不染污。谓无覆色界。声界六识界意法界亦尔。几果非有果等者。十七是果亦有果。一应分别。谓法界。有三句。或是果非有果。谓择灭。或是果亦有果。谓有为法界。或非果非有果。谓虚空非择灭。几有执受等者。九无执受。九应分别。谓眼界或有执受或无执受。云何有执受。谓自体所摄眼界。云何无执受。谓非自体所摄眼界。色耳鼻香舌味身触界亦尔。几大种所造等者。九及二少分。是大种所造。七及二少分。非大种所造。几有上等者。十七有上。一应分别。谓法界。或有上或无上。云何有上。谓有为法界。及虚空非择灭。云何无上。谓择灭。几是有等者。十五是有。三应分别。谓意法意识界。若有漏是有。若无漏非有。几因相应等者。七因相应。十因不相应。一应分别。谓法界。若诸心所因相应。若非心所因不相应。此十八界与六善处相摄者。六善处摄十界少分。十界少分亦摄六善处。与五不善处相摄者。五不善处摄十界少分。十界少分亦摄五不善处。与七无记处相摄者。七无记处摄八界十界少分。八界十界少分亦摄七无记处。与三漏处相摄者。三漏处摄一界少分。一界少分亦摄三漏处。与五有漏处相摄者。五有漏处摄十五界三界少分。十五界三界少分亦摄五有漏处。与八无漏处相摄者。八无漏处摄三界少分。三界少分亦摄八无漏处。几过去等者。十七或过去或未来或现在。一应分别。谓法界。若有为或过去或未来或现在。若无为非过去非未来非现在。几善等者。八无记。十应分别。谓色界。或善或不善或无记。云何善。谓善身表。云何不善。谓不善身表。云何无记。谓除善不善身表。诸余色界。声界或善或不善或无记。云何善。谓善语表。云何不善。谓不善语表。云何无记。谓除善不善语表。诸余声界。眼识界或善或不善或无记。云何善。谓善作意相应眼识。云何不善。谓不善作意相应眼识。云何无记。谓无记作意相应眼识。余五识界。意界亦尔。法界或善或不善或无记。云何善。谓法界所摄善身语业。及善受想行蕴并择灭。云何不善。谓法界所摄不善身语业。及不善受想行蕴。云何无记。谓无记受想行蕴。及虚空非择灭。几欲界系等者。四欲界系。十四应分别。谓眼界。或欲界系或色界系。云何欲界系。谓欲界大种所造眼界。云何色界系。谓色界大种所造眼界。色耳声鼻舌身界亦尔。触界或欲界系。或色界系。云何欲界系。谓欲界四大种。及所造触界。云何色界系。谓色界四大种。及所造触界眼识界。或欲界系。或色界系。云何欲界系。谓欲界作意相应眼识。云何色界系。谓色界作意相应眼识。耳身识界亦尔。意界或欲界系。或色界系。或无色界系。或不系。云何欲界系。谓欲界作意相应意界。云何色界系。谓色界作意相应意界。云何无色界系。谓无色界作意相应意界。云何不系。谓无漏作意相应意界。意识界亦尔。法界或欲界系。或色界系。或无色界系。或不系。云何欲界系。谓法界所摄欲界身语业。及欲界受想行蕴。云何色界系。谓法界所摄色界身语业。及色界受想行蕴。云何无色界系。谓无色界受想行蕴。云何不系。谓无漏身语业。及无漏受想行蕴。并无为法。几学等者。十五非学非无学。三应分别。谓意界或学或无学或非学非无学。云何学。谓学作意相应意界。云何无学。谓无学作意相应意界。云何非学非无学。谓有漏作意相应意界。意识界亦尔。法界或学或无学或非学非无学。云何学。谓学身语业。及学受想行蕴。云何无学。谓无学身语业。及无学受想行蕴。云何非学非无学。谓法界所摄有漏身语业。及有漏受想行蕴。并无为法

此十八界几见所断等者。十五修所断。三应分别。谓意界。或见所断。或修所断。或非所断。云何见所断。谓意界随信随法行现观边忍所断。此复云何。谓见所断八十八随眠相应意界。云何修所断。谓意界学见迹修所断。此复云何。谓修所断十随眠相应意界。及不染污有漏意界。云何非所断。谓无漏意界。意识界亦尔。法界或见所断。或修所断。或非所断。云何见所断。谓法界随信随法行现观边忍所断。此复云何。谓见所断八十八随眠。及彼相应法界。并彼等起心不相应行。云何修所断。谓法界学见迹修所断。此复云何。谓修所断十随眠。及彼相应法界。并彼等起身语业心不相应行。若不染污有漏法界。云何非所断。谓无漏法界。几非心等者。十非心非心所非心相应。七唯是心。一应分别。谓法界。若有所缘是心所与心相应。若无所缘非心非心所非心相应。几随心转非受相应等者。十非随心转非受相应。七受相应非随心转。一应分别。谓法界有三句。或随心转非受相应。谓随心转身语业心不相应行及受。或随心转亦受相应。谓想蕴及相应行蕴。或非随心转非受相应。谓除随心转身语业心不相应行。诸余身语业心不相应行。及无为法。几随心转非想行相应等者。除其自性。如受应知。几随寻转非伺相应等者。十非随寻转非伺相应。五有寻有伺。三应分别。谓意界。或有寻有伺。或无寻唯伺。或无寻无伺。云何有寻有伺。谓有寻有伺作意相应意界。云何无寻唯伺。谓无寻唯伺作意相应意界。云何无寻无伺。谓无寻无伺作意相应意界。意识界亦尔。法界有四句。或随寻转非伺相应。谓随寻转身语业心不相应行。及寻相应伺。或伺相应非随寻转。谓寻及寻不相应伺相应心所法。或随寻转亦伺相应。谓寻伺相应心所法。或非随寻转非伺相应。谓除随伺转身语业心不相应行。诸余身语业心不相应行。及寻不相应伺。并无寻无伺心所法。若无为法。几见非见处等者。一见亦见处。十四见处非见。三应分别。谓意界。若有漏见处非见。若无漏非见非见处。意识界亦尔。法界有四句。或见非见处。谓尽无生智所不摄无漏慧。或见处非见。谓见所不摄有漏法界。或见亦见处。谓五染污见。及世间正见。或非见非见处。谓见所不摄无漏法界。几有身见为因非有身见因等者。八非有身见为因非有身见因。十应分别。谓色界。若染污有身见为因非有身见因。若不染污非有身见为因非有身见因。声界五识界亦尔。意识界。或有身见为因非有身见因。或有身见为因亦有身见因。或非有身见为因非有身见因。有身见为因非有身见因者。谓除过去现在见苦所断随眠相应意界。亦除过去现在见集所断遍行随眠相应意界。亦除未来有身见相应意界。诸余染污意界。有身见为因亦有身见因者。谓前所除意界。非有身见为因非有身见因者。谓不染污意界。意识界亦尔。法界。有三句。或有身见为因非有身见因。谓除过去现在见苦所断随眠及彼相应俱有等法界。亦除过去现在见集所断遍行随眠及彼相应俱有法界。亦除未来有身见相应法界。亦除未来有身见及彼相应法生老住无常。诸余染污法界。或有身见为因亦有身见因。谓前所除法界。或非有身见为因非有身见因。谓不染污法界。几业非业异熟等者。一切应分别。谓眼界。或业异熟非业。或非业非业异熟。业异熟非业者。谓异熟生眼界。非业非业异熟者。谓余眼界。耳鼻舌身香味触界及七心界亦尔。色界有三句。或业非业异熟。谓身表。或业异熟非业。谓业异熟生色界。或非业非业异熟。谓除业及业异熟色界。诸余色界。声界有二句。或业非业异熟。谓语表。或非业非业异熟。谓余声界。法界。有四句。或业非业异熟。谓法界所摄身语业。及业异熟所不摄思。或业异熟非业。谓思所不摄业异熟法界。或业亦业异熟。谓业异熟生思。或非业非业异熟。谓除业。及业异熟法界。诸余法界几业非随业转等者。七随业转非业。八非业非随业转。三应分别。谓色界。或业非随业转。或非业非随业转。业非随业转者。谓身表。非业非随业转者。谓余色界。声界。或业非随业转。或非业非随业转。业非随业转者。谓语表。非业非随业转者。谓余声界。法界有四句。或业非随业转。谓除随业转身语业。诸余法界所摄身语业及思。或随业转非业。谓受蕴想蕴。及思所不摄随业转行蕴。或业亦随业转。谓随业转身语业。或非业非随业转。谓除业及随业转法界。诸余法界。几所造色非有见色等者。应作三句。或所造色非有见色。谓八界及二界少分。或所造色亦有见色。谓一界。或非所造色非有见色。谓七界。及二界少分。此十八界。几所造色非有对色等者。应作四句。或所造色非有对色。谓一界少分。或有对色非所造色。谓一界少分。或所造色亦有对色。谓九界及一界少分。或非所造色非有对色。谓七界及一界少分。几难见故甚深等者。一切难见故甚深。甚深故难见。几善非善为因等者。一切应分别。谓眼界。或善为因非善。或非善非善为因。善为因非善者。谓善异熟生眼界。非善非善为因者。谓余眼界。耳鼻香舌味身触界亦尔。色界有三句。或善为因非善。谓善异熟生色界。或善亦善为因。谓善色界。或非善非善为因。谓除善异熟生色界。诸余无记。及不善色界。六识意界亦尔。声界。有二句。或善亦善为因。谓善声界。或非善非善为因。谓不善无记声界。法界有四句。或善非善为因。谓择灭。或善为因非善。谓善异熟生法界。或善亦善为因。谓善有为法界。或非善非善为因。谓除善异熟生法界。诸余无记及不善法界。几不善非不善为因等者。一切应分别。谓眼界。或不善为因非不善。或非不善非不善为因。不善为因非不善者。谓不善异熟生眼界。非不善非不善为因者。谓余眼界。耳鼻香舌味身触界亦尔。色界。有三句。或不善为因非不善。谓不善异熟生色界。或不善亦不善为因。谓不善色界。或非不善非不善为因。谓除不善异熟生色界。诸余无记及善色界。眼耳鼻舌身识界亦尔。声界有二句。或不善亦不善为因。谓不善声界。或非不善非不善为因。谓善无记声界。意界有三句。或不善为因非不善。谓不善异熟生意界。及欲界系有身见边执见相应意界。或不善亦不善为因。谓不善意界。或非不善非不善为因。谓除不善异熟生意界。及除欲界系有身见边执见相应意界。诸余无记及善意界。意识界亦尔。法界有三句。或不善为因非不善。谓不善异熟生法界。及欲界系有身见边执见。及彼相应等起法界。或不善亦不善为因。谓不善法界。或非不善非不善为因。谓除不善异熟生法界。及除欲界有身见边执见并彼相应等起法界。诸余无记及善法界。几无记非无记为因等者。八无记亦无记为因。十应分别。谓色界有三句。或无记为因非无记。谓不善色界。或无记亦无记为因。谓无记色界。或非无记非无记为因。谓善色界。声界六识界意界亦尔。法界。有四句。或无记非无记为因。谓虚空非择灭。或无记为因非无记。谓不善法界。或无记亦无记为因。谓无记有为法界。或非无记非无记为因。谓善法界。几因缘非有因等者。十七是因缘亦有因。一应分别。谓法界。若有为是因缘亦有因。若无为非因缘非有因。几等无间非等无间缘等者。十非等无间非等无间缘。八应分别。谓眼识界有三句。或是等无间非等无间缘。谓未来现前正起眼识。或是等无间亦等无间缘。谓过去现在眼识。或非等无间非等无间缘。谓除未来现前正起眼识。诸余未来眼识。耳鼻舌身识界亦尔。意界有三句。或是等无间非等无间缘。谓未来现前正起意界。及过去现在阿罗汉命终时意界。或是等无间亦等无间缘。谓除过去现在阿罗汉命终时意界。诸余过去现在意界。或非等无间非等无间缘。谓除未来现前正起意界。诸余未来意界。意识界亦尔。法界有三句。或是等无间非等无间缘。谓未来现前正起诸心所法。及过去现在阿罗汉命终时诸心所法。并已生正起无想灭定。或是等无间亦等无间缘。谓除过去现在阿罗汉命终时诸心所法。诸余过去现在心所法。或非等无间非等无间缘。谓除未来现前正起诸心所法。诸余未来心所法。及除等无间心不相应行。诸余心不相应行。及身语业。并无为法。几所缘缘非有所缘等者。十是所缘缘非有所缘。七是所缘缘亦有所缘。一应分别。谓法界。若诸心所是所缘缘亦有所缘。若非心所是所缘缘非有所缘。几增上缘非有增上等者。十七是增上缘亦有增上。一应分别。谓法界。若有为是增上缘亦有增上。若无为是增上缘非有增上。几暴流非顺暴流等者。十五顺暴流非暴流。三应分别。谓意界。若有漏顺暴流非暴流。若无漏非暴流非顺暴流。意识界亦尔。法界有三句。或顺暴流非暴流。谓暴流所不摄有漏法界。或暴流亦顺暴流。谓四暴流。或非暴流非顺暴流。谓无漏法界

说一切有部品类足论卷第十七阿毗达磨品类足论卷第十八

        尊者世友造

        三藏法师玄奘奉　诏译

    辨决择品第八

有色法。十一界十一处一蕴摄。八智知。除他心灭智。六识识。欲色界遍行。及修所断随眠随增。唯有色法。十界十处一蕴摄。非智知。五识识。非随眠随增。无色法。八界二处四蕴摄。十智知。一识识。一切随眠随增。唯无色法。七界一处四蕴摄。二智知。谓他心灭智。非识识。无色界一切。欲色界二部。及见苦集所断非遍行随眠随增。有见法一界一处一蕴摄七智知。除他心灭道智。二识识。欲色界遍行。及修所断随眠随增。唯有见法。一界一处非蕴摄。非智知。一识识。非随眠随增。无见法十七界十一处五蕴摄。十智知。五识识。一切随眠随增。唯无见法。十七界十一处四蕴摄。三智知。谓他心灭道智。四识识。无色界一切欲界二部。及见苦集所断非遍行随眠随增。有对法。十界十处一蕴摄。七智知。除他心灭道智。六识识。欲色界遍行。及修所断随眠随增。唯有对法。十界十处非蕴摄。非智知。五识识。非随眠随增。无对法。八界二处五蕴摄。十智知。一识识。一切随眠随增。唯无对法。八界二处四蕴摄。三智知。谓他心灭道智。非识识。无色界一切欲界色界二部。及见苦集所断非遍行随眠随增。有漏法。十八界十二处五蕴摄。八智知。除灭道智。六识识。一切随眠随增。唯有漏法。十五界十处非蕴摄。二智知。谓苦集智。五识识。一切随眠随增。无漏法。三界二处五蕴摄。八智知。除苦集智。一识识。非随眠随增。唯无漏法。非界非处非蕴摄。二智知。谓灭道智。非识识。非随眠随增。有为法。十八界十二处五蕴摄。九智知。除灭智。六识识。一切随眠随增。唯有为法。十七界十一处五蕴摄。四智知。谓他心苦集道智。五识识。一切随眠随增。无为法。一界一处非蕴摄。六智知。除他心苦集道智。一识识。非随眠随增唯无为法。非界非处非蕴摄。一智知。谓灭智。非识识。非随眠随增。有诤无诤法。世间出世间法。堕界非堕界法。有味着无味着法。耽嗜依出离依法。顺结非顺结法。顺取非顺取法。顺缠非顺缠法。如有漏无漏法应知

有记法。十界四处五蕴摄。十智知。三识识。欲界一切。色无色界遍行。及修所断随眠随增。唯有记法。非界非处非蕴摄。二智知。谓灭道智。非识识。欲界二部。及见集所断非遍行随眠随增。无记法。十八界十二处五蕴摄。八智知。除灭道智。六识识。色无色界一切。欲界二部。及见集所断遍行随眠随增。唯无记法。八界八处非蕴摄。非智知。三识识。色无色界二部。及见苦集所断非遍行随眠随增。有覆法。十界四处五蕴摄。八智知。除灭道智。三识识。一切随眠随增唯有覆法。非界非处非蕴摄。非智知。非识识。三界二部。及见苦集所断非遍行随眠随增。无覆法。十八界十二处五蕴摄。十智知。六识识。三界遍行。及修所断随眠随增。唯无覆法。八界八处非蕴摄。二智知。谓灭道智。三识识。非随眠随增。应修法。十界四处五蕴摄。九智知。除灭智。三识识。三界遍行。及修所断随眠随增。唯应修法。非界非处非蕴摄。一智知。谓道智。非识识。非随眠随增。不应修法。十八界十二处五蕴摄。九智知。除道智。六识识。一切随眠随增。唯不应修法。八界八处非蕴摄。一智知。谓灭智。三识识。三界二部。及见苦集所断非遍行随眠随增。染污法。十界四处五蕴摄。八智知。除灭道智。三识识。一切随眠随增。唯染污法。非界非处非蕴摄。非智知。非识识。三界二部。及见苦集所断非遍行随眠随增。不染污法。十八界十二处五蕴摄。十智知。六识识。三界遍行。及修所断随眠随增。唯不染污法。八界八处非蕴摄。二智知。谓灭道智。三识识。非随眠随增。有罪无罪法亦尔。有异熟法。十界四处五蕴摄。八智知。除灭道智。三识识。欲界一切。色无色界遍行。及修所断随眠随增。唯有异熟法。非界非处非蕴摄非智知。非识识。欲界二部。及见集所断非遍行随眠随增。无异熟法。十八界十二处五蕴摄。十智知。六识识。色无色界一切。欲界二部。及见集所断遍行随眠随增。唯无异熟法。八界八处非蕴摄。二智知。谓灭道智。三识识。色无色界二部。及见苦集所断非遍行随眠随增。见法。二界二处二蕴摄九智知。除灭智。一识识。三界有漏缘。及见相应无漏缘无明随眠随增。唯见法。一界一处非蕴摄。非智知。非识识。非随眠随增。非见法。十七界十一处五蕴摄。十智知。六识识。一切随眠随增。唯非见法。十六界十处三蕴摄。一智知。谓灭智。五识识。除见相应无漏缘无明。诸余无漏缘随眠随增。内法。十二界六处二蕴摄。九智知。除灭智。一识识。一切随眠随增唯内法。十二界六处一蕴摄。非智知。非识识。非随眠随增。外法。六界六处四蕴摄。十智知。六识识。一切随眠随增。唯外法六界六处三蕴摄。一智知。谓灭智。五识识。非随眠随增。有执受法。九界九处一蕴摄。七智知。除他心灭道智。五识识。欲色界遍行。及修所断随眠随增。唯有执受法。非界非处非蕴摄。非智知。非识识。非随眠随增。无执受法。十八界十二处五蕴摄。十智知。六识识。一切随眠随增。唯无执受法。九界三处四蕴摄。三智知。谓他心灭道智。一识识。无色界一切。欲色界二部。及见苦集所断非遍行随眠随增。心法。七界一处一蕴摄。九智知。除灭智。一识识。一切随眠随增。唯心法。七界一处一蕴摄。非智知。非识识。非随眠随增。非心法。十一界十一处四蕴摄。十智知。六识识。一切随眠随增。唯非心法。十一界十一处四蕴摄。一智知。谓灭智。五识识。非随眠随增。有所缘法。八界二处四蕴摄。九智知。除灭智。一识识。一切随眠随增。唯有所缘法。七界一处三蕴摄。一智知。谓他心智。非识识。三界无漏缘随眠随增。无所缘法。十一界十一处二蕴摄。九智知。除他心智。六识识。三界有漏缘随眠随增。唯无所缘法。十界十处一蕴摄。一智知。谓灭智。五识识。非随眠随增。心所法。一界一处三蕴摄。九智知。除灭智。一识识。一切随眠随增。唯心所法。非界非处二蕴摄。非智知。非识识。非随眠随增。非心所法。十八界十二处三蕴摄。十智知。六识识。一切随眠随增。唯非心所法。十七界十一处二蕴摄。一智知。谓灭智。五识识。非随眠随增。业法。三界三处二蕴摄。九智知。除灭智。三识识。一切随眠随增。唯业法。非界非处非蕴摄。非智知。非识识。非随眠随增。非业法。十八界十二处五蕴摄。十智知。六识识。一切随眠随增。唯非业法。十五界九处三蕴摄。一智知。谓灭智。三识识非随眠随增。善法。十界四处五蕴摄。十智知。三识识。三界遍行。及修所断随眠随增。唯善法。非界非处非蕴摄。二智知。谓灭道智。非识识。非随眠随增。不善法。十界四处五蕴摄。七智知。除类灭道智。三识识。欲界一切随眠随增。唯不善法。非界非处非蕴摄。非智知。非识识。欲界二部。及见集所断非遍行随眠随增无记法。十八界十二处五蕴摄。八智知。除灭道智。六识识。色无色界一切。欲界二部。及见集所断遍行随眠随增。唯无记法。八界八处非蕴摄。非智知。三识识。色无色界二部。及见苦集所断非遍行。随眠随增见所断法。三界二处四蕴摄。八智知。除灭道智。一识识。见所断一切随眠随增。唯见所断法。非界非处非蕴摄。非智知。非识识。三界二部。及见苦集所断非遍行随眠随增。修所断法。十八界十二处五蕴摄。八智知。除灭道智。六识识。三界遍行。及修所断随眠随增。唯修所断法。十五界十处非蕴摄。非智知。五识识。修所断一切随眠随增。非所断法。三界二处五蕴摄。八智知。除苦集智。一识识。非随眠随增。唯非所断法。非界非处非蕴摄。二智知。谓灭道智。非识识。非随眠随增学法。三界二处五蕴摄。七智知。除苦集灭智。一识识。非随眠随增。唯学法。非界非处非蕴摄。非智知。非识识。非随眠随增。无学法亦尔。非学非无学法。十八界十二处五蕴摄。九智知。除道智。六识识。一切随眠随增。唯非学非无学法。十五界十处非蕴摄。三智知。谓苦集灭智。五识识。一切随眠随增。欲界系法。十八界十二处五蕴摄。七智知。除类灭道智。六识识。欲界一切随眠随增。唯欲界系法。四界二处非蕴摄。非智知。二识识。欲界一切随眠随增。色界系法。十四界十处五蕴摄。七智知。除法灭道智。四识识。色界一切随眠随增。唯色界系法。非界非处非蕴摄。非智知。非识识。色界一切随眠随增。无色界系法。三界二处四蕴摄。六智知。除法他心灭道智。一识识。无色界一切。随眠随增。唯无色界系法。非界非处非蕴摄。非智知。非识识。无色界一切随眠随增。不系法。三界二处五蕴摄。八智知。除苦集智。一识识。非随眠随增。唯不系法。非界非处非蕴摄。二智知。谓灭道智。非识识。非随眠随增。过去法。十八界十二处五蕴摄。九智知。除灭智。六识识。一切随眠随增。唯过去法。非界非处非蕴摄。非智知。非识识。非随眠随增。未来现在法亦尔。非过去非未来非现在法。一界一处非蕴摄。六智知。除他心苦集道智。一识识。非随眠随增。唯非过去非未来非现在法。非界非处非蕴摄。一智知。谓灭智。非识识。非随眠随增

苦圣谛所摄法。十八界十二处五蕴摄。七智知。除集灭道智。六识识。一切随眠随增。唯苦圣谛所摄法。非界非处非蕴摄。一智知。谓苦智。非识识。非随眠随增。集圣谛所摄法。十八界十二处五蕴摄。七智知。除苦灭道智。六识识。一切随眠随增。唯集圣谛所摄法。非界非处非蕴摄。一智知。谓集智。非识识。非随眠随增。灭圣谛所摄法。一界一处非蕴摄。六智知。除他心苦集道智。一识识。非随眠随增。唯灭圣谛所摄法。非界非处非蕴摄。一智知。谓灭智。非识识。非随眠随增。道圣谛所摄法。三界二处五蕴摄。七智知。除苦集灭智。一识识。非随眠随增。唯道圣谛所摄法。非界非处非蕴摄。一智知。谓道智。非识识。非随眠随增。谛所不摄法。一界一处非蕴摄。一智知。谓世俗智。一识识。非随眠随增。唯谛所不摄法。非界非处非蕴摄。非智知。非识识。非随眠随增。见苦所断法。三界二处四蕴摄。八智知。除灭道智。一识识。见苦所断一切。及见集所断遍行随眠随增。唯见苦所断法。非界非处非蕴摄。非智知。非识识。见苦所断非遍行随眠随增。见集所断法。三界二处四蕴摄。八智知。除灭道智。一识识。见集所断一切。及见苦所断遍行随眠随增。唯见集所断法。非界非处非蕴摄。非智知。非识识。见集所断非遍行随眠随增。见灭所断法。三界二处四蕴摄。八智知。除灭道智。一识识。见灭所断一切。及遍行随眠随增。唯见灭所断法。非界非处非蕴摄。非智知。非识识。见灭所断一切随眠随增。见道所断法。三界二处四蕴摄。八智知。除灭道智。一识识。见道所断一切。及遍行随眠随增。唯见道所断法。非界非处非蕴摄。非智知非识识。见道所断一切随眠随增。修所断法。十八界十二处五蕴摄。八智知。除灭道智。六识识。修所断一切。及遍行随眠随增。唯修所断法。十五界十处。非蕴摄。非智知。五识识。修所断一切随眠随增。非所断法。三界二处五蕴摄。八智知。除苦集智。一识识。非随眠随增。唯非所断法。非界非处非蕴摄。二智知。谓灭道智。非识识。非随眠随增。色蕴。十一界。十一处一蕴摄。八智知。除他心灭智。六识识。欲色界遍行。及修所断随眠随增。唯色蕴。十界十处一蕴摄。非智知。五识识。非随眠随增。受蕴。一界一处一蕴摄。九智知。除灭智。一识识。一切随眠随增。唯受蕴。非界非处一蕴摄。非智知。非识识。非随眠随增。想行蕴亦尔。识蕴。七界一处一蕴摄。九智知。除灭智。一识识。一切随眠随增。唯识蕴。七界一处一蕴摄。非智知。非识识。非随眠随增

眼处。一界一处一蕴摄。七智知。除他心灭道智。一识识。欲色界遍行。及修所断随眠随增。唯眼处。一界一处非蕴摄。非智知。非识识。非随眠随增。耳鼻舌身处亦尔。色处。一界一处一蕴摄。七智知。除他心灭道智。二识识。欲色界遍行。及修所断随眠随增。唯色处。一界一处非蕴摄。非智知。一识识。非随眠随增。声触处亦尔。香处。一界一处一蕴摄。六智知。除类他心灭道智。二识识。欲界遍行。及修所断随眠随增。唯香处。一界一处非蕴摄。非智知。一识识。非随眠随增。味处亦尔。意处。七界一处一蕴摄。九智知。除灭智。一识识。一切随眠随增。唯意处。七界一处一蕴摄。非智知。非识识。非随眠随增。法处。一界一处四蕴摄十智知。一识识。一切随眠随增。唯法处。一界一处三蕴摄。一智知。谓灭智。非识识。非随眠随增。眼界一界一处一蕴摄。七智知。除他心灭道智。一识识。欲色界遍行。及修所断随眠随增。唯眼界一界一处非蕴摄。非智知。非识识。非随眠随增。耳鼻舌身界亦尔。色界一界一处一蕴摄。七智知。除他心灭道智。二识识。欲色界遍行。及修所断随眠随增。唯色界一界一处非蕴摄。非智知。一识识。非随眠随增。声触界亦尔。香界一界一处一蕴摄。六智知。除类他心灭道智。二识识。欲界遍行。及修所断随眠随增。唯香界。一界一处非蕴摄。非智知。一识识。非随眠随增。味界亦尔。意界如意处。法界如法处。眼识界二界一处一蕴摄。八智知。除灭道智。一识识。欲色界遍行。及修所断随眠随增。唯眼识界。一界非处非蕴摄。非智知。非识识。非随眠随增。耳身识界亦尔。鼻识界二界一处一蕴摄。七智知。除类灭道智。一识识。欲界遍行。及修所断随眠随增。唯鼻识界。一界非处非蕴摄。非智知。非识识。非随眠随增。舌识界亦尔意识界二界一处一蕴摄。九智知。除灭智。一识识。一切随眠随增。唯意识界一界非处非蕴摄。非智知。非识识。非随眠随增。眼根一界一处一蕴摄。七智知除他心灭道智。一识识。欲色界遍行。及修所断随眠随增。眼根一界一处非蕴摄。非智知。非识识。非随眠随增耳鼻舌身根亦尔。女根一界一处一蕴摄。六智知。除类他心灭道智。一识识。欲界遍行及修所断随眠随增。唯女根非界非处非蕴摄。非智知。非识识。非随眠随增。男根亦尔。命根一界一处一蕴摄。七智知。除他心灭道智。一识识。三界遍行。及修所断随眠随增。唯命根。非界非处非蕴摄。非智知。非识识。非随眠随增。意根如意处。乐根。一界一处一蕴摄。九智知。除灭智。一识识。色界一切。欲界遍行。及修所断随眠随增。唯乐根非界非处非蕴摄。非智知非识识。非随眠随增

苦根一界一处一蕴摄。七智知。除类灭道智。一识识。欲界遍行。及修所断随眠随增。唯苦根非界非处非蕴摄。非智知。非识识。非随眠随增。喜根一界一处一蕴摄。九智知。除灭智。一识识。色界一切。除欲界无漏缘疑及彼相应无明。诸余欲界一切随眠随增。唯喜根非界非处非蕴摄。非智知。非识识。非随眠随增。忧根一界一处一蕴摄。七智知。除类灭道智。一识识。欲界一切随眠随增。唯忧根非界非处非蕴摄。非智知。非识识。非随眠随增。舍根一界一处一蕴摄。九智知。除灭智。一识识。一切随眠随增。唯舍根非界非处非蕴摄。非智知。非识识。非随眠随增。信根一界一处一蕴摄。九智知。除灭智。一识识。三界遍行。及修所断随眠随增。唯信根非界非处非蕴摄。非智知。非识识。非随眠随增。精进念定慧根亦尔。未知当知根。三界二处三蕴摄。七智知。除苦集灭智。一识识。非随眠随增。唯未知当知根。非界非处非蕴摄。非智知。非识识。非随眠随增。已知具知根亦尔

欲界见苦所断随眠。一界一处一蕴摄。七智知。除类灭道智。一识识。欲界见苦所断一切。及见集所断遍行随眠随增。唯欲界见苦所断随眠。非界非处非蕴摄。非智知。非识识。非随眠随增。欲界见集所断随眠。一界一处一蕴摄。七智知。除类灭道智。一识识。欲界见集所断一切。及见苦所断遍行随眠随增。唯欲界见集所断随眠。非界非处非蕴摄。非智知。非识识。非随眠随增。欲界见灭所断随眠。一界一处一蕴摄。七智知。除类灭道智。一识识。除欲界见灭所断不共无明。诸余欲界见灭所断一切及遍行随眠随增。唯欲界见灭所断随眠。非界非处非蕴摄。非智知。非识识。非随眠随增。欲界见道所断随眠。一界一处一蕴摄七智知。除类灭道智。一识识。除欲界见道所断不共无明。诸余欲界见道所断一切及遍行随眠随增。唯欲界见道所断随眠。非界非处非蕴摄。非智知。非识识。非随眠随增。欲界修所断随眠。一界一处一蕴摄。七智知。除类灭道智。一识识。欲界修所断一切及遍行随眠随增。唯欲界修所断随眠。非界非处非蕴摄。非智知。非识识。非随眠随增。色界见苦所断随眠。一界一处一蕴摄。七智知。除法灭道智。一识识。色界见苦所断一切及见集所断遍行随眠随增。唯色界见苦所断随眠。非界非处非蕴摄。非智知。非识识。非随眠随增。色界见集所断随眠。一界一处一蕴摄。七智知。除法灭道智。一识识。色界见集所断。一切及见苦所断遍行随眠随增。唯色界见集所断随眠。非界非处非蕴摄。非智知。非识识。非随眠随增。色界见灭所断随眠。一界一处一摄摄。七智知。除法灭道智。一识识。除色界见灭所断不共无明。诸余色界见灭所断一切及遍行随眠随增。唯色界见灭所断随眠。非界非处非蕴摄。非智知。非识识。非随眠随增。色界见道所断随眠。一界一处一蕴摄。七智知。除法灭道智。一识识。除色界见道所断不共无明。诸余无色界见道所断一切及遍行随眠随增。唯色界见道所断随眠。非界非处非蕴摄。非智知。非识识。非随眠随增。色界修所断随眠。一界一处一蕴摄。七智知。除法灭道智。一识识。色界修所断一切及遍行随眠随增。唯色界修所断随眠。非界非处非蕴摄。非智知。非识识。非随眠随增。无色界见苦所断随眠。一界一处一蕴摄。六智知。除法他心灭道智。一识识。无色界见苦所断一切。及见集所断遍行随眠随增。唯无色界见苦所断随眠。非界非处非蕴摄。非智知。非识识。非随眠随增。无色界见集所断随眠。一界一处一蕴摄。六智知。除法他心灭道智。一识识。无色界见集所断一切。及见苦所断遍行随眠随增。唯无色界见集所断随眠。非界非处非蕴摄。非智知。非识识。非随眠随增。无色界见灭所断随眠。一界一处一蕴摄。六智知。除法他心灭道智。一识识。除无色界见灭所断不共无明。诸余无色界见灭所断一切。及遍行随眠随增。唯无色界见灭所断随眠。非界非处非蕴摄。非智知。非识识。非随眠随增。无色界见道所断随眠。一界一处一蕴摄。六智知。除法他心灭道智。一识识。除无色界见道所断不共无明。诸余无色界见道所断一切及遍行随眠随增。唯无色界见道所断随眠。非界非处非蕴摄。非智知。非识识。非随眠随增。无色界修所断随眠。一界一处一蕴摄。六智知。除法他心灭道智。一识识。无色界修所断一切。及遍行随眠随增。唯无色界修所断随眠。非界非处非蕴摄。非智知。非识识。非随眠随增

说一切有部品类足论卷第十八


阿毗达磨识身足论

    No. 1539

阿毗达磨识身足论卷第一

        提婆设摩阿罗汉造

        三藏法师玄奘奉　诏译

    初归礼赞颂

  稽首大觉觉中王　　觉王所供三界日
  解脱妙法智所归　　智者所依诸圣众
  阿毗达磨海难渡　　佛口池流千圣饮
  于境巨溟能善决　　故我至诚今顶礼
  朗日不举照人间　　稠林昏翳孰能遣
  若无阿毗达磨论　　智所知冥谁殄灭
  阿毗达磨正法灯　　心中净眼智根本
  所知林日邪论剑　　开士威力如来藏
  三界照明慧眼道　　一切法灯佛语海
  能发胜慧破诸疑　　是诸圣贤法衢路
  智者慧水大陂池　　求智勇锐胜基本
  了此胜法至聪明　　悟斯圣教真佛子

    总嗢拖南颂

  初目干连蕴　　次补特伽罗
  因所缘杂类　　四句最为后

    识身足论目干连蕴第一之一第一嗢拖南颂

  根恶行想　　寻思界漏　　火爱所有
  垢缚皆三

沙门目连作如是说。过去未来无。现在无为有。应问彼言。汝然此不。谓契经中世尊善语善词善说。三不善根。贪不善根嗔不善根。痴不善根。彼答言尔。复问彼言。汝然此不。谓有能于贪。不善根已观今观当观是不善。彼答言尔为何所观。过去耶未来耶现在耶。若言观过去。应说有过去。不应无过去。言过去无。不应道理。若言观未来。应说有未来。不应无未来。言未来无。不应道理。若言观现在。应说有一补特伽罗非前非后二心和合。一是所观。一是能观。此不应理。若不说一补特伽罗非前非后二心和合。一是所观。一是能观。则不应说观于现在。言观现在。不应道理。若言不观过去未来现在。则无能于贪不善根已观今观当观。是不善。若无能观。则无能已厌。今厌当厌。若无能厌。则无能已离染今离染当离染。若无能离染。则无能已解脱今解脱当解脱。若无能解脱。则无能已般涅槃今般涅槃当般涅槃。如不善如是结缚随眠随烦恼缠。所弃所舍所断遍知亦尔。复问彼言。汝然此不。谓有能于贪不善根已观今观当观。后世感苦异熟。彼答言尔。为何所观。过去耶未来耶现在耶。若言观过去。应说有过去。不应无过去。言过去无不应道理。若言观未来。应说有未来。不应无未来。言未来无不应道理。若言观现在。应说有一补特伽罗非前非后。亦能造业。亦即领受此业异熟。此不应理。若不说一补特伽罗非前非后。亦能造业。亦即领受此业异熟。则不应说观于现在。言观现在不应道理。若言不观过去未来现在。则无能于贪不善根已观今观当观。后世感苦异熟。若无能观。则无能已厌今厌当厌。若无能厌。则无能已离染今离染当离染。若无能离染。则无能已解脱今解脱当解脱。若无能解脱。则无能已般涅槃今般涅槃当般涅槃。如贪不善根如是嗔不善根痴不善根亦尔。身恶行语恶行是不善。非结非缚非随眠。非随烦恼非缠。是所弃所舍所断遍知。能于后世感苦异熟。意恶行是不善。结缚随眠随烦恼缠。所弃所舍所断遍知。能于后世感苦异熟。欲想恚想害想是不善。非结非缚非随眠非随烦恼非缠。是所弃所舍所断遍知。能于后世感苦异熟。欲寻恚寻害寻是不善。非结非缚非随眠。是随烦恼非缠。是所弃所舍所断遍知。能于后世感苦异熟。欲界恚界是不善。结缚随眠随烦恼缠。所弃所舍所断遍知。能于后世感苦异熟。害界是不善。非结非缚非随眠。是随烦恼非缠。是所弃所舍所断遍知。能于后世感苦异熟。欲漏无明漏是不善。结缚随眠随烦恼缠。所弃所舍所断遍知。能于后世感苦异熟。有漏非不善。是结缚随眠随烦恼缠所弃所舍所断遍知。非于后世感苦异熟。贪火嗔火痴火。及欲爱是不善。结缚随眠随烦恼缠所弃所舍所断遍知。能于后世感苦异熟。色爱无色爱非不善。是结缚随眠随烦恼缠所弃所舍所断遍知。非于后世感苦异熟。贪所有嗔所有痴所有。贪垢嗔垢痴垢。贪缚嗔缚痴缚是不善。结缚随眠随烦恼缠所弃所舍所断遍知。能于后世感苦异熟

    识身足论目干连蕴第一中第二嗢拖南颂

  瀑扼取系盖　　下上栽拘碍
  见爱与随眠　　邪支结业道

沙门目连作如是说。过去未来无现在无为有。应问彼言。汝然此不。谓契经中世尊善语善词善说。四种瀑流。欲瀑流有瀑流见瀑流无明瀑流。彼答言尔。复问彼言。汝然此不。谓有能于欲瀑流已观今观当观是不善。彼答言尔。为何所观。过去耶未来耶现在耶。若言观过去。应说有过去。不应无过去。言过去无不应道理。若言观未来。应说有未来。不应无未来。言未来无不应道理。若言观现在。应说有一补特伽罗非前非后二心和合。一是所观。一是能观。此不应理。若不说一补特伽罗非前非后二心和合。一是所观。一是能观。则不应说观于现在。言观现在不应道理。若言不观过去未来现在。则无能于欲瀑流已观今观当观是不善。若无能观。则无能已厌今厌当厌。若无能厌。则无能已离染今离染当离染。若无能离染。则无能已解脱今解脱当解脱。若无能解脱。则无能已般涅槃今般涅槃当般涅槃。如不善如是结缚随眠随烦恼缠所弃所舍所断遍知亦尔。复问彼言。汝然此不。谓有能于欲瀑流已观今观当观。后世感苦异熟。彼答言尔。为何所观。过去耶未来耶现在耶。若言观过去。应说有过去。不应无过去。言过去无不应道理。若言观未来。应说有未来。不应无未来。言未来无不应道理。若言观现在。应说有一补特伽罗非前非后。亦能造业亦即领受此业异熟。此不应理。若不说一补特伽罗非前非后。亦能造业亦即领受此业异熟。则不应说观于现在。言观现在不应道理。若言不观过去未来现在。则无能于欲瀑流已观今观当观后世感苦异熟。若无能观则无能已厌今厌当厌。若无能厌。则无能已离染今离染当离染。若无能离染。则无能已解脱今解脱当解脱。若无能解脱。则无能已般涅槃今般涅槃当般涅槃。如欲瀑流。如是见瀑流无明瀑流亦尔。有瀑流非不善。是结缚随眠随烦恼缠所弃所舍所断遍知。非于后世感苦异熟。如瀑流扼亦尔。于诸取中欲取见取戒禁取是不善。结缚随眠随烦恼缠所弃所舍所断遍知。能于后世感苦异熟。我语取非不善。是结缚随眠随烦恼缠所弃所舍所断遍知。非于后世感苦异熟。诸系是不善。结缚随眠随烦恼缠所弃所舍所断遍知。能于后世感苦异熟。于诸盖中贪欲盖嗔恚盖疑盖是不善。结缚随眠随烦恼缠所弃所舍所断遍知。能于后世感苦异熟。惛沉睡眠盖掉举恶作盖是不善。非结非缚非随眠。是随烦恼缠所弃所舍所断遍知。能于后世感苦异熟。下分结中萨迦耶见非不善。是结缚随眠随烦恼缠所弃所舍所断遍知。非于后世感苦异熟。余下分结是不善。结缚随眠随烦恼缠所弃所舍所断遍知。能于后世感苦异熟。上分结中掉举结非不善。非结非缚非随眠。是随烦恼缠所弃所舍所断遍知。非于后世感苦异熟。余上分结非不善。是结缚随眠随烦恼缠所弃所舍所断遍知。非于后世感苦异熟。五心根栽五心拘碍是不善。结缚随眠随烦恼缠所弃所舍所断遍知。能于后世感苦异熟。于诸见中萨迦耶见边执见非不善。是结缚随眠随烦恼缠所弃所舍所断遍知。非于后世感苦异熟。邪见见取戒禁取是不善。结缚随眠随烦恼缠所弃所舍所断遍知。能于后世感苦异熟。诸身爱是不善。结缚随眠随烦恼缠所弃所舍所断遍知。能于后世感苦异熟。诸随眠中有贪随眠非不善。是结缚随眠随烦恼缠所弃所舍所断遍知。非于后世感苦异熟。所余随眠是不善。结缚随眠随烦恼缠所弃所舍所断遍知。能于后世感苦异熟。诸邪支中邪见是不善。结缚随眠随烦恼缠所弃所舍所断遍知。能于后世感苦异熟。邪语邪业邪命是不善。非结非缚非随眠非随烦恼非缠。是所弃所舍所断遍知。能于后世感苦异熟。所余邪支是不善。非结非缚非随眠。是随烦恼非缠。是所弃所舍所断遍知。能于后世感苦异熟。于诸结中嫉结悭结是不善。结缚非随眠。是随烦恼缠所弃所舍所断遍知。能于后世感苦异熟。所余诸结是不善。结缚随眠随烦恼缠所弃所舍所断遍知。能于后世感苦异熟。诸业道中前七业道是不善。非结非缚非随眠非随烦恼非缠。是所弃所舍所断遍知。能于后世感苦异熟。后三业道是不善。结缚随眠随烦恼缠所弃所舍所断遍知。能于后世感苦异熟

    识身足论目干连蕴第一中第三嗢拖南颂

  结盖觉支心受意　　调练陀坚最为后

沙门目连作如是说。过去未来无。现在无为有。应问彼言。汝然此不谓契经中世尊善语善词善说。若有内眼结。如实了知我有内眼结。若无内眼结。如实了知我无内眼结。如此眼结未生而生。生已令断。断已当来不复更生。亦如实知。彼答言尔。为何所知。过去耶未来耶现在耶。若言知过去。应说有过去。不应无过去。言过去无不应道理。若言知未来应说有未来。不应无未来。言未来无不应道理。若言知现在。应说有一补特伽罗非前非后二心和合。一是所知。一是能知。此不应理。若言无一补特伽罗非前非后二心和合。一是所知一是能知。不应说言知于现在。言知现在不应道理。若言不知过去未来现在。是则经中世尊善语善词善说。若有内眼结。如实了知我有内眼结。若无内眼结。如实了知我无内眼结。如此眼结。未生而生。生已令断。断已当来不复更生。亦如实知。如是契经世尊所说。汝便诽谤违越拒逆。若汝诽谤违越拒逆如是世尊所说契经

不应道理。如眼结如是。耳鼻舌身意结亦尔

沙门目连作如是说。过去未来无。现在无为有。应问彼言。汝然此不。于契经中世尊善语善词善说。若有内贪欲盖。如实了知我有内贪欲盖。若无内贪欲盖。如实了知我无内贪欲盖。如此贪欲盖。未生而生。生已令断。断已当来不复更生。亦如实知。彼答言尔。为何所知。过去耶未来耶现在耶。若言知过去。应说有过去。不应无过去。言过去无不应道理。若言知未来。应说有未来。不应无未来。言未来无不应道理。若言知现在。应说有一补特伽罗非前非后二心和合。一是所知一是能知。此不应理。若言无一补特伽罗非前非后二心和合。一是所知一是能知。则不应言知于现在。言知现在不应道理。若言不知过去未来现在。是则经中世尊善语善词善说。若有内贪欲盖。如实了知我有内贪欲盖。若无内贪欲盖。如实了知我无内贪欲盖。如此贪欲盖。未生而生生已令断。断已当来不复更生。亦如实知。如是契经世尊所说。汝便诽谤违越拒逆。若汝诽谤违越拒逆如是世尊所说契经不应道理。如贪欲盖如是。嗔恚惛沉睡眠掉举恶作疑盖亦尔

沙门目连作如是说。过去未来无。现在无为有。应问彼言。汝然此不。于契经中世尊善语善词善说。若有内念等觉支。如实了知我有内念等觉支。若无内念等觉支。如实了知我无内念等觉支。如此念等觉支。未生令生。生已令住。不忘修习圆满。倍复增广智作证。亦如实知。彼答言尔。为何所知。过去耶未来耶现在耶。若言知过去。应说有过去。不应无过去。言过去无不应道理。若言知未来。应说有未来。不应无未来。言未来无不应道理。若言知现在。应说有一补特伽罗非前非后二心和合。一是所知。一是能知。此不应理。若言无一补特伽罗非前非后二心和合。一是所知一是能知。则不应言知于现在。言知现在不应道理。若言不知过去未来现在。是则经中世尊善语善词善说。若有内念等觉支。如实了知我有内念等觉支。若无内念等觉支。如实了知我无内念等觉支。如此念等觉支。未生令生。生已令住。不忘修习圆满。倍复增广智作证。亦如实知。如是契经世尊所说。汝便诽谤违越拒逆。若汝诽谤违越拒逆如是世尊所说契经。不应道理。如念等觉支如是。择法等觉支。精进等觉支。喜等觉支。轻安等觉支定等觉支。舍等觉支亦尔

沙门目连作如是说。过去未来无。现在无为有。应问彼言。汝然此不。谓契经中世尊善语善词善说。若有贪心。如实了知是有贪心。若离贪心。如实了知是离贪心。彼答言尔。为何所知。过去耶未来耶现在耶。若言知过去。应说有过去。不应无过去。言过去无不应道理。若言知未来。应说有未来。不应无未来。言未来无不应道理。若言知现在。应说有一补特伽罗非前非后二心和合。一是所知。一是能知。此不应理。若言无一补特伽罗非前非后二心和合。一是所知一是能知。则不应言知于现在。言知现在不应道理。若言不知过去未来现在。是则经中世尊善语善词善说。若有贪心。如实了知是有贪心。若离贪心。如实了知是离贪心。如是契经世尊所说。汝便诽谤违越拒逆。若汝诽谤违越拒逆如是世尊所说契经。不应道理。如有贪心离贪心如是。有嗔心离嗔心。有痴心离痴心。略心散心。沉心举心。掉动心不掉动心。不寂静心寂静心。不定心定心。不修心修心。不解脱心解脱心。如实了知亦尔

沙门目连作如是说。过去未来无。现在无为有。应问彼言。汝然此不。谓契经中世尊善语善词善说。受有二种。一者身受。二者心受。彼答言尔。具寿。若时领纳身受心受。尔时当言在何世。过去耶未来耶现在耶。若言在过去应说有过去。不应无过去。言过去无不应道理。若言在未来。应说有未来。不应无未来。言未来无不应道理。若言在现在。应说有一补特伽罗非前非后领纳二受。一者身受。二者心受。此不应理。若言无一补特伽罗非前非后领纳二受。一者身受二者心受。则不应言在于现在。言在现在不应道理。若言不在过去未来现在。是则经中世尊善语善词善说。受有二种。一者身受。二者心受。如是契经世尊所说。汝便诽谤违越拒逆。若汝诽谤违越拒逆如是世尊所说契经。不应道理

沙门目连作如是说。过去未来无。现在无为有。应问彼言。汝然此不。谓契经中世尊善语善词善说。受有三种。一者乐受。二者苦受。三者不苦不乐受。彼答言尔。具寿。若时领纳乐等三受。尔时当言在何世。过去耶未来耶现在耶。若言在过去。应说有过去。不应无过去。言过去无不应道理。若言在未来。应说有未来。不应无未来。言未来无不应道理。若言在现在。应说有一补特伽罗非前非后领纳三受。一者乐受。二者苦受。三者不苦不乐受。此不应理。若言无一补特伽罗非前非后领纳三受。一者乐受二者苦受三者不苦不乐受。则不应言在于现在。言在现在不应道理。若言不在过去未来现在。是则经中世尊善语善词善说。受有三种。一者乐受。二者苦受。三者不苦不乐受。如是契经世尊所说。汝便诽谤违越拒逆。若汝诽谤违越拒逆如是世尊所说契经。不应道理

沙门目连作如是说。过去未来无。现在无为有。应问彼言。汝然此不。谓契经中世尊善语善词善说。意法为缘发生意识。彼答言尔。具寿。若时意识现起意。于尔时当言在何世。过去耶未来耶现在耶。若言在过去。应说有过去。不应无过去。言过去无不应道理。若言在未来。应说有未来。不应无未来。言未来无不应道理。若言在现在。应说有一补特伽罗非前非后二心和合。意及意识。此不应理。若言无一补特伽罗非前非后二心和合。意及意识。则不应言在于现在。言在现在不应道理。若言不在过去未来现在。是则经中世尊善语善词善说。意法为缘发生意识。如是契经世尊所说。汝便诽谤违越拒逆。若汝诽谤违越拒逆如是世尊所说契经。不应道理

沙门目连作如是说。过去未来无。现在无为有。应问彼言。汝然此不。谓契经中世尊善语善词善说。以齿持齿舌端着齶。复以其心降伏执持调练其心。何所调练。过去耶未来耶现在耶。若言调练过去。应说有过去。不应无过去。言过去无不应道理。若言调练未来。应说有未来。不应无未来。言未来无不应道理。若言调练现在。应说有一补特伽罗非前非后二心和合。一所调练一能调练。此不应理。若言无一补特伽罗非前非后二心和合。一所调练一能调练。则不应言调练现在。言调练现在不应道理。若言不调练过去未来现在。是则经中世尊善语善词善说。以齿持齿舌端着齶。复以其心降伏执持调练其心。如是契经。汝便诽谤违越拒逆。若汝诽谤违越拒逆如是世尊所说契经。不应道理

沙门目连作如是说。过去未来无。现在无为有。应问彼言。汝然此不。谓契经中世尊善语善词善说。为彼具寿补穑揭罗娑利苾刍说。有十八意近行。名为士夫。彼答言尔。复问彼言。具寿若时眼见色已。随顺喜处诸色近行。尔时十七余意近行。当言在何世。过去耶未来耶现在耶。若言在过去。应说有过去。不应无过去。言过去无不应道理。若言在未来应说有未来。不应无未来。言未来无不应道理。若言在现在。应说有一补特伽罗非前非后有十八意近行同时现行此不应理。若言无一补特伽罗非前非后有十八意近行同时现行。则不应言在于现在。言在现在不应道理。若言不在过去未来现在。是则经中世尊善语善词善说。为彼具寿补穑揭罗娑利苾刍。说有十八意近行名为士夫。如是契经世尊所说。汝便诽谤违越拒逆。若汝诽谤违越拒逆如是世尊所说契经。不应道理

    识身足论目干连蕴第一中第四嗢拖南颂初

  无所缘静虑　　异生大士羞
  宣说有情居　　食圣谛断漏

沙门目连作如是说。有无所缘心。应问彼言。汝然此不。谓契经中世尊善语善词善说。苾刍了别。了别故名为识。何所了别。谓了别色。了别声香味触法。彼答言尔。汝听堕负。若汝说有无所缘心。则不应言谓契经中世尊善语善词善说。苾刍了别了别故名为识。何所了别。谓了别色了别声香味触法。作如是言不应道理。汝今若言谓契经中世尊善语善词善说。苾刍了别了别故名为识。何所了别。谓了别色了别声香味触法。则不应说有无所缘心。言有无所缘心。不应道理。彼作是言。无所缘心决定是有。何者是耶。谓缘过去或缘未来。应问彼言。汝然此不。谓契经中世尊善语善词善说。为本鱼师莎底苾刍说言。苾刍由彼彼因。由彼彼缘。发生于识。识既生已堕彼彼数。由眼及色发生于识。识既生已堕眼识数。由耳鼻舌身意及法发生于识。识既生已堕意识数。彼答言尔。汝听堕负。若汝说言无所缘心决定是有。则不应言谓契经中世尊善语善词善说。为本鱼师莎底苾刍说言。苾刍由彼彼因由彼彼缘发生于识。识既生已堕彼彼数。由眼及色发生于识。识既生已堕眼识数。由耳鼻舌身意及法发生于识。识既生已堕意识数。作如是言不应道理。汝今若言谓契经中世尊善语善词善说。为本鱼师莎底苾刍说言。苾刍由彼彼因由彼彼缘发生于识。识既生已堕彼彼数。由眼及色发生于识。识既生已堕眼识数。由耳鼻舌身意及法发生于识。识既生已堕意识数。则不应说无所缘心决定是有。言决定有无所缘心。不应道理

沙门目连作如是说。过去未来无。现在无为有。应问彼言。汝然此不。若有惭羞恶作防护爱乐所学久居善处证得世间四种静虑。彼答言尔即彼具寿临终时分。有诸识达同梵行者。来诣问言。具寿当记自所证得。彼作是言。具寿我今已得世间四种静虑。应问彼言。即彼具寿记何所证。过去耶未来耶现在耶。若言记过去。应说有过去。不应无过去。言过去无不应道理。若言记未来。应说有未来。不应无未来。言未来无不应道理。若言记现在。应说有一补特伽罗非前非后二心和合。一是所记一是能记。又在定中应说异语。此不应理。若不说一补特伽罗非前非后二心和合。一是所记一是能记。又在定中不说异语。则不应言记于现在。言记现在不应道理。若言不记过去未来现在。是则空无胜过人法。自称言有。彼应毁坏

沙门目连作如是说。过去未来无。现在无为有。应问彼言。汝然此不。谓契经中世尊善语善词善说。有五种根。所谓信根精进根念根定根慧根。苾刍若有于此五根。由上品故。由猛利故。由调善故。由圆满故。成阿罗汉俱分解脱。自斯已降。转微转钝成慧解脱。自斯已降。转微转钝成于身证。自斯已降。转微转钝成于见得。自斯已降。转微转钝成信解脱。自斯已降。转微转钝成随法行。自斯已降。转微转钝成随信行。苾刍如是。根波罗蜜多为缘。果波罗蜜多施设可知。果波罗蜜多为缘。补特伽罗波罗蜜多施设可知。如是五根无有唐捐。苾刍若有于此五根。一切皆无我。说彼住外异生品。彼答言尔。具寿有学现起缠心。尔时此五根当言在何世。过去耶未来耶现在耶。若言在过去。应说有过去。不应无过去。言过去无不应道理。若言在未来。应说有未来。不应无未来。言未来无不应道理。若言在现在。应说有一补特伽罗非前非后二心和合。一者学心二者缠心。此不应理。若言无一补特伽罗非前非后二心和合。一者学心二者缠心。则不应言在于现在。言在现在不应道理。若言不在过去未来现在。是则有学现起缠心。应言是外。应言异生。应言住在外异生品

沙门目连作如是说。过去未来无。现在无为有。应问彼言。汝然此不。谓契经中世尊善语善词善说。为具寿无灭。于大士寻思中说。少欲是法大欲非法。彼答言尔。具寿少欲是何法。是心所有法与心相应。具寿若阿罗汉。身在欲界现入灭定。如是少欲。当言在何世。过去耶未来耶现在耶。若言在过去。应说有过去。不应无过去。言过去无不应道理。若言在未来。应说有未来。不应无未来。言未来无不应道理。若言在现在。即不应说现入灭定。言现入灭定不应道理。若言不在过去未来现在。是则阿罗汉身在欲界。现入灭定应无少欲

沙门目连作如是说。过去未来无。现在无为有。应问彼言。汝然此不。谓契经中世尊善语善词善说。为具寿罗怙罗说。罗怙罗。若有正知而说妄语。无羞无惭无有恶作。我说彼无恶业不造。彼答言尔。具寿羞惭是何法。是心所有法与心相应。具寿若阿罗汉身在欲界。现入灭定羞惭。当在何世。过去耶未来耶现在耶。若言在过去。应说有过去。不应无过去。言过去无不应道理。若言在未来。应说有未来。不应无未来。言未来无不应道理。若言在现在。则不应说现入灭定。言现入灭定不应道理。若言不在过去未来现在。是则阿罗汉身在欲界。现入灭定应无羞惭

说一切有部识身足论卷第一阿毗达磨识身足论卷第二

        提婆设摩阿罗汉造

        三藏法师玄奘奉　诏译

    目干连蕴第一之二第四嗢拖南颂后

沙门目连作如是说。过去未来无。现在无为有。应问彼言。汝然此不。谓契经中世尊善语善词善说。九有情居有诸有情。有色有种种身。有种种想。谓人及天一分。是名初有情居。有诸有情。有色有种种身。有一种想。谓梵众天在彼初生。是名第二有情居。有诸有情。有色有一种身。有种种想。谓光音天。是名第三有情居。有诸有情。有色有一种身。有一种想。谓遍净天。是名第四有情居。有诸有情。有色无想无各异想。谓无想天。是名第五有情居。有诸有情。无色一切种色想超过故。有对想灭没故。种种想不作意故。无边虚空空无边处具足住。谓近趣空无边处天。是名第六有情居。有诸有情。无色一切种无边虚空处超过已。无边识识无边处具足住。谓近趣识无边处天。是名第七有情居。有诸有情。无色一切种识无边处超过已。无少所有无所有处具足住。谓近趣无所有处天。是名第八有情居。有诸有情。无色一切种无所有处超过已。非想非非想处具足住。谓近趣非想非非想处天是名第九有情居。彼答言。尔具寿若阿罗汉身在欲界。现入灭定。当言住在何有情居。彼答言有种种身有种种想。具寿由何世想说名有想。过去耶未来耶现在耶。若言由过去。应说有过去。不应无过去。言过去无不应道理。若言由未来。应说有未来。不应无未来。言未来无不应道理。若言由现在。则不应说现入灭定。言现入灭定不应道理。若言不由过去未来现在。是则阿罗汉身在欲界。现入灭定。应言无想。应言无想有情。应言住在无想有情

沙门目连作如是说。过去未来无。现在无为有。应问彼言。汝然此不。谓契经中世尊善语善词善说。一切有情皆依食住。彼答言尔。具寿。无想有情诸天。当言有何食。彼答有触意思识食。具寿。彼食尔时当言在何世。过去耶未来耶现在耶。若言在过去。应说有过去。不应无过去。言过去无不应道理。若言在未来。应说有未来。不应无未来。言未来无不应道理。若言在现在。则不应说无想有情。言无想有情不应道理。若言不在过去未来现在。是则经中世尊善语善词善说。一切有情皆依食住。如是契经世尊所说。汝便诽谤违越拒逆。若汝诽谤违越拒逆如是世尊所说契经。不应道理

沙门目连作如是说。过去未来无现在无为有。应问彼言。汝然此不。谓契经中世尊善语善词善说。有六识身眼识耳识鼻识舌识身识意识。彼答言尔。应问彼言。汝然此不。谓有能于眼识已观今观当观。是无常是苦是空是无我。已观今观当观。彼因是因是集是生是缘。彼灭是灭是静是妙是离。能断彼道是道是如是行是出。彼答言尔。为何所观。过去耶未来耶现在耶。若言观过去。应说有过去。不应无过去。言过去无不应道理。若言观未来。应说有未来。不应无未来。言未来无不应道理。若言观现在。应说有一补特伽罗非前非后二心和合。一是所观一是能观。此不应理若言无一补特伽罗非前非后二心和合。一是所观一是能观。则不应说观于现在。言观现在。不应道理。若言不观过去未来现在。是则应无能于眼识已观今观当观。是无常是苦是空是无我。已观今观当观。彼因是因是集是生是缘。彼灭是灭是静是妙是离。能断彼道是道是如是行是出。若无能观。则应无能已厌今厌当厌。若无能厌。则应无能已离染今离染当离染。若无能离染则应无能已解脱今解脱当解脱。若无能解脱。则应无能已般涅槃今般涅槃当般涅槃。如眼识如是耳识鼻识舌识身识意识亦尔

沙门目连作如是说。过去未来无。现在无为有。应问彼言。汝然此不。谓契经中世尊善语善词善说。是诸苾刍。应断诸漏。彼答言尔。为何所断。过去耶未来耶现在耶。若言断过去。应说有过去。不应无过去。言过去无不应道理。若断未来应说有未来。不应无未来。言未来无不应道理。若言断现在。应说有一补特伽罗非前非后二心和合。一是所断一是能断。此不应理。若言无一补特伽罗非前非后二心和合。一是所断一是能断。则不应说断于现在。言断现在不应道理。若言不断过去未来现在。是则经中世尊善语善词善说。是诸苾刍。应断诸漏。如是契经世尊所说。汝便诽谤违越拒逆。若汝诽谤违越拒逆如是世尊所说契经。不应道理

    识身足论补特伽罗蕴第二之一第一嗢拖南颂初

  趣补特伽罗　　八种与三聚
  三种自造作　　见闻觉知后

补特伽罗论者作如是言。谛义胜义。补特伽罗。可得可证。现有等有。是故定有补特伽罗。性空论者作是问言。汝然此不谓契经中世尊善语善词善说。如是五趣决定安立不相杂乱。谓捺落迦趣傍生趣鬼趣天趣人趣。决定别有奈落迦趣。乃至决定别有人趣。彼答言尔。复问彼言。汝然此不。有从奈落迦没生傍生趣。彼答言尔汝听堕负若有五趣决定安立不相杂乱。谓奈落迦趣乃至人趣。决定别有奈落迦趣。乃至决定别有人趣。则不应说有从奈落迦没生傍生趣。汝作是言不应道理。汝今若说有从奈落迦没生傍生。趣则不应说如是五趣决定安立不相杂乱。谓奈落迦趣乃至人趣。决定别有奈落迦趣。乃至决定别有人趣。言此五趣决定安立不相杂乱。谓奈落迦趣乃至人趣。决定别有奈落迦趣。乃至决定别有人趣。不应道理。彼作是言。定有从奈落迦没生傍生趣。应问彼言汝然此不。彼即是彼答言不尔。汝听堕负。若定有从奈落迦没生傍生趣。是则应说彼即是彼。汝作是言不应道理。若汝不说彼即是彼。则不应言定有从奈落迦没生傍生趣。言定有从奈落迦没生傍生趣。不应道理。若作是言。彼即是彼。应问彼言。汝然此不。彼奈落迦即傍生趣。答言不尔。汝听堕负。若彼即是彼。是则应说彼奈落迦即傍生趣。汝作是言不应道理。若汝不说彼奈落迦即傍生趣。则不应说彼即是彼。言彼即是彼不应道理。若作是言。彼异于彼。应问彼言。汝然此不。奈落迦断别生傍生。答言不尔。汝听堕负。若彼异彼。是则应说奈落迦断别生傍生。汝作是言不应道理。若汝不说奈落迦断别生傍生则不应说彼异于彼。言彼异于彼不应道理。若作是言。不可说彼或彼或异应问彼言。汝然此不。有从奈落迦没生傍生趣。如是之言。亦不可说或彼或异。答言不尔。汝听堕负。若不可说彼或彼或异。是则应言有从奈落迦没生傍生趣。如是之言。亦不可说或彼或异。汝作是言不应道理。若汝不说有从捺落迦没生傍生趣。如是之言。亦不可说或彼或异。则不应言不可说彼或彼或异。言不可说彼或彼或异。不应道理。如有从奈落迦没生傍生趣。如是有从奈落迦没生于鬼趣亦尔

补特伽罗论者作如是言。谛义胜义。补特伽罗。可得可证。现有等有。是故定有补特伽罗。性空论者作。是问言。汝然此不。谓契经中世尊善语善词善说。如是五趣决定安立不相杂乱。谓奈落迦趣傍生趣鬼趣天趣人趣。决定别有奈落迦趣。乃至决定别有人趣。彼答言尔。复问彼言。汝然此不。有从奈落迦没生于人趣。彼答言尔。汝听堕负。若有五趣决定安立不相杂乱。谓奈落迦趣乃至人趣。决定别有奈落迦趣。乃至决定别有人趣。则不应说有从奈落迦没生于人趣。汝作是言不应道理。汝今若说有从奈落迦没生于人趣。则不应说如是五趣决定安立不相杂乱。谓奈落迦趣乃至人趣。决定别有奈落迦趣。乃至决定别有人趣。言此五趣决定安立不相杂乱。谓奈落迦趣乃至人趣。决定别有奈落迦趣。乃至决定别有人趣。不应道理。彼作是言。定有从奈落迦没生于人趣。应问彼言。汝然此不彼即是彼。答言不尔。汝听堕负。若定有从奈落迦没生于人趣。是则应说彼即是彼。汝作是言不应道理。若汝不说彼即是彼。则不应言定有从奈落迦没生于人趣。言定有从奈落迦没生于人趣。不应道理。若作是言。彼即是彼。应问彼言。汝然此不彼奈落迦即是人趣。答言不尔。汝听堕负。若彼即是彼。是则应说彼奈落迦即是人趣。汝作是言不应道理。若汝不说彼奈落迦即是人趣。则不应说彼即是彼。言彼即是彼不应道理。又若作是言。彼即是彼。应问彼言。汝然此不。奈落迦趣于生无漏根力觉支无所堪能。入趣有所堪能。彼答言尔。复问彼言。汝然此不。彼无堪能即有堪能。答言不尔汝听堕负。若彼即是彼是则应说彼无堪能。即有堪能。汝作是言。不应道理。若汝不说彼无堪能。即有堪能。则不应说彼即是彼。言彼即是彼不应道理。若作是言。彼异于彼。应问彼言。汝然此不。奈落迦断别生人趣。答言不尔。汝听堕负。若彼异于彼。是则应说奈落迦断别生人趣。汝作是言不应道理。若汝不说奈落迦断别生人趣。则不应说彼异于彼。言彼异于彼不应道理。若作是言。不可说彼或彼或异。应问彼言。汝然此不。有从奈落迦没生于人趣。如是之言。亦不可说或彼或异。答言不尔。汝听堕负。若不可说彼或彼或异。是则应言有从奈落迦没生于人趣。如是之言。亦不可说或彼或异。汝作是言不应道理。若汝不说有从奈落迦没生于人趣。如是之言。亦不可说或彼或异。则不应言不可说彼或彼或异。言不可说彼或彼或异。不应道理。如有从奈落迦没生于人趣。如是有从奈落迦没生于天趣亦尔。如奈落迦趣。如是傍生鬼天人趣亦尔。此中差别者。于奈落迦傍生鬼趣中。不应说有所堪能。于天人趣中应说有所堪能。于天人趣中不应说无所堪能。于奈落迦傍生鬼趣中。应说无所堪能

补特伽罗论者。作如是言。谛义胜义。补特伽罗。可得可证。现有等有。是故定有补特伽罗。性空论者。作是问言。汝然此不。谓契经中世尊善语善词善说。如是八种补特伽罗。决定安立不相杂乱。谓预流果能作证向。若预流果。乃至阿罗汉果。能作证向。若阿罗汉果。决定别有预流果能作证向。决定别有预流果。乃至决定别有阿罗汉果能作证向。决定别有阿罗汉果。彼答言尔。复问彼言。汝然此不。诸预流果能作证向。补特伽罗得预流果。彼答言尔。汝听堕负。若有八种补特伽罗决定安立不相杂乱。谓预流果能作证向。若预流果乃至阿罗汉果。能作证向。若阿罗汉果。决定别有预流果。能作证向。决定别有预流果。乃至决定别有阿罗汉果。能作证向。决定别有阿罗汉果。则不应言诸预流果能作证向补特伽罗得预流果。汝作是言。不应道理。今汝若说诸预流果能作证向补特伽罗得预流果。则不应说如是八种补特伽罗决定安立不相杂乱。谓预流果能作证向。若预流果乃至阿罗汉果能作证向。若阿罗汉果决定别有预流果能作证向。决定别有预流果。乃至决定别有阿罗汉果。能作证向。决定别有阿罗汉果。言此八种补特伽罗。决定安立不相杂乱。谓预流果能作证向。若预流果乃至阿罗汉果。能作证向。若阿罗汉果。决定别有预流果。能作证向。决定别有预流果。乃至决定别有阿罗汉果。能作证向。决定别有阿罗汉果。不应道理。彼作是言。诸预流果能作证向补特伽罗定得预流果。应问彼言。汝然此不。彼即是彼答言不尔。汝听堕负。若预流果能作证向补特伽罗。定得预流果。是则应说。彼即是彼。汝作是言不应道理。若汝不说彼即是彼。则不应言诸预流果能作证向补特伽罗定得预流果。言预流果能作证向补特伽罗定得预流果。不应道理。若作是言。彼即是彼。应问彼言。汝然此不彼作证向。即是住果。答言不尔。汝听堕负。若彼即是彼。汝则应言。彼作证向即是住果。汝作是言不应道理。若汝不说彼作证向即是住果。则不应言彼即是彼。言彼即是彼不应道理。又若作是言。彼即是彼。应问彼言。汝然此不。诸预流果能作证向补特伽罗不成就果。若预流果成就于果。彼答言尔。复问彼言。汝然此不。彼不成就即是成就。答言不尔。汝听堕负。若预流果能作证向补特伽罗不成就果彼。预流果成就于果。是则应言。彼不成就即是成就。汝作是言不应道理。若汝不说彼不成就。即是成就。则不应言彼即是彼。言彼即是彼不应道理。若作是言。彼异于彼。应问彼言。汝然此不。诸预流果能作证向断别生预流果。答言不尔。汝听堕负。若彼异于彼。是则应言。诸预流果能作证向断别生预流果。汝作是言。不应道理。若汝不说诸预流果能作证向断别生预流果。则不应言彼异于彼。言彼异于彼不应道理。若作是言。不可说彼或彼或异。应问彼言。汝然此不。诸预流果能作证向得预流果。如是之言亦不可说或彼或异。答言不尔。汝听堕负。若不可说彼或彼或异。是则应言。诸预流果能作证向得预流果。如是之言亦不可说或彼或异。汝作是言不应道理。若汝不说诸预流果能作证向得预流果。如是之言亦不可说或彼或异。则不应言不可说彼或彼或异。汝作是言不应道理。如预流果能作证向望预流果。如是之言亦不可说或彼或异。则不应言不可说彼或彼或异。汝作是言不应道理。如预流果能作证向望预流果。如是诸一来果能作证向望一来果亦尔。此中差别者。诸一来果能作证向。不应定说不成就果

补特伽罗论者。作如是言。谛义胜义。补特伽罗可得可证。现有等有。是故定有补特伽罗。性空论者作是问言。汝然此不。谓契经中世尊善语善词善说。如是八种补特伽罗决定安立不相杂乱。谓预流果能作证向。若预流果乃至阿罗汉果能作证向。若阿罗汉果。决定别有预流果能作证向。决定别有预流果。乃至决定别有阿罗汉果能作证向。决定别有阿罗汉果。彼答言尔。复问彼言。汝然此不。诸不还果能作证向得不还果。彼答言尔。汝听堕负。若有八种补特伽罗。决定安立。不相杂乱。谓预流果能作证向。若预流果乃至阿罗汉果能作证向。若阿罗汉果决定别有预流果能作证向。决定别有预流果。乃至决定别有阿罗汉果能作证向。决定别有阿罗汉果。则不应说诸不还果能作证向得不还果。汝作是言不应道理。汝今若说诸不还果能作证向得不还果。则不应言如是八种补特伽罗决定安立不相杂乱。谓预流果能作证向若预流果。乃至阿罗汉果能作证向。若阿罗汉果。决定别有预流果能作证向。决定别有预流果。乃至决定别有阿罗汉果能作证向。决定别有阿罗汉果。言有八种补特伽罗决定安立不相杂乱。谓预流果能作证向。若预流果。乃至阿罗汉果能作证向。若阿罗汉果。决定别有预流果能作证向。决定别有预流果。乃至决定别有阿罗汉果能作证向。决定别有阿罗汉果。不应道理。彼作是言。诸不还果能作证向。定得不还果。应问彼言。汝然此不彼即是彼。答言不尔。汝听堕负。若不还果能作证向定得不还果。是则应说彼即是彼。汝作是言不应道理。若汝不说彼即是彼。则不应言诸不还果能作证向定得不还果。言不还果能作证向定得不还果。不应道理。若作是言。彼即是彼。应问彼言。汝然此不。彼作证向即是住果。答言不尔。汝听堕负。若彼即是彼。是则应说。彼作证向即是住果。汝作是言不应道理。若汝不说彼作证向即是住果。则不应言彼即是彼。言彼即是彼。不应道理。又若作是言。彼即是彼。应问彼言。汝然此不。诸不还果能作证向有其嗔恚。彼不还果远离嗔恚。彼答言尔。复问彼言。汝然此不。彼有嗔恚即离嗔恚。答言不尔。汝听堕负。若彼即是彼。是则应说。彼有嗔恚即离嗔恚。汝作是言不应道理。若汝不说彼有嗔恚即离嗔恚。则不应言彼即是彼。言彼即是彼不应道理。若作是言彼异于彼。应问彼言。汝然此不。诸不还果。能作证向断别生不还果。答言不尔。汝听堕负。若彼异于彼。是则应说。诸不还果能作证向断别生不还果。汝作是言不应道理。若汝不说诸不还果能作证向断别生不还果。则不应言彼异于彼。言彼异于彼不应道理。若作是言。不可说彼或彼或异。应问彼言。汝然此不。诸不还果能作证向得不还果。如是之言。亦不可说或彼或异。答言不尔汝听堕负。若不可说彼或彼或异。是则应说。诸不还果能作证向得不还果。如是之言。亦不可说或彼或异。汝作是言不应道理。若汝不说诸不还果能作证向得不还果。如是之言。亦不可说或彼或异。则不应言不可说彼或彼或异。言不可说彼或彼或异。不应道理

补特伽罗论者作如是言。谛义胜义。补特伽罗可得可证现有等有。是故定有补特伽罗。性空论者作是问言。汝然此不。谓契经中世尊善语善词善说。如是八种补特伽罗决定安立不相杂乱。谓预流果能作证向若预流果。乃至阿罗汉果能作证向若阿罗汉果。决定别有预流果能作证向。决定别有预流果。乃至决定别有阿罗汉果能作证向。决定别有阿罗汉果。彼答言尔。复问彼言。汝然此不。阿罗汉果能作证向得阿罗汉果。彼答言尔。汝听堕负。若有八种补特伽罗。决定安立不相杂乱。谓预流果能作证向若预流果。乃至阿罗汉果能作证向若阿罗汉果。决定别有预流果能作证向。决定别有预流果。乃至决定别有阿罗汉果能作证向。决定别有阿罗汉果。则不应说阿罗汉果能作证向得阿罗汉果。汝作是言不应道理。汝今若说阿罗汉果能作证向得阿罗汉果。则不应说如是八种补特伽罗决定安立不相杂乱。谓预流果能作证向若预流果。乃至阿罗汉果能作证向若阿罗汉果。决定别有预流果能作证向。决定别有预流果。乃至决定别有阿罗汉果能作证向。决定别有阿罗汉果。言有八种补特伽罗。决定安立不相杂乱。谓预流果能作证向若预流果。乃至阿罗汉果能作证向若阿罗汉果。决定别有预流果能作证向。决定别有预流果。乃至决定别有阿罗汉果能作证向。决定别有阿罗汉果。不应道理。彼作是言。阿罗汉果能作证向定得阿罗汉果。应问彼言。汝然此不彼即是彼。答言不尔。汝听堕负。若有阿罗汉果能作证向定得阿罗汉果。是则应说。彼即是彼。汝作是言不应道理。若汝不说彼即是彼。则不应言阿罗汉果能作证向定得阿罗汉果。言阿罗汉果能作证向定得阿罗汉果不应道理。若作是言。彼即是彼。应问彼言。汝然此不。彼作证向即是住果。答言不尔。汝听堕负。若彼即是彼。是则应说。彼作证向即是住果。汝作是言不应道理。若汝不说彼作证向即是住果。则不应言彼即是彼。言彼即是彼不应道理。又若作是言。彼即是彼。应问彼言。汝然此不诸阿罗汉果。能作证向。未全离贪。未全离慢。未全离无明。学有所作。阿罗汉果已全离贪。已全离慢。已全离无明。是其无学所作已办。彼答言尔。复问彼言。汝然此不。彼有所作即所作已办。答言不尔。汝听堕负。若彼即是彼。是则应说。彼有所作即所作已办。汝作是言不应道理。若汝不说彼有所作即所作已办。则不应言彼即是彼。言彼即是彼不应道理。若作是言。彼异于彼。应问彼言。汝然此不。诸阿罗汉果能作证向断别生阿罗汉果。答言不尔。汝听堕负。若彼异于彼。是则应说。诸阿罗汉果能作证向断别生阿罗汉果。汝作是言不应道理。若汝不说诸阿罗汉果。能作证向断别生阿罗汉果。则不应言彼异于彼。言彼异于彼不应道理。若作是言。不可说彼或彼或异。应问彼言。汝然此不。诸阿罗汉果能作证向得阿罗汉果。如是之言。亦不可说或彼或异。答言不尔。汝听堕负。若不可说彼或彼或异。是则应说。诸阿罗汉果能作证向得阿罗汉果。如是之言。亦不可说或彼或异。汝作是言不应道理。若汝不说。诸阿罗汉果能作证向得阿罗汉果。如是之言。亦不可说或彼或异。则不应言不可说彼或彼或异。言不可说彼或彼或异。不应道理

补特伽罗论者。作如是言。谛义胜义补特伽罗。可得可证现有等有。是故定有补特伽罗。性空论者作是问言。汝然此不。谓契经中世尊善语善词善说。如是三聚决定安立不相杂乱。谓不定聚。邪性定聚。正性定聚。决定别有不定聚。决定别有邪性定聚。决定别有正性定聚。彼答言尔。复问彼言。汝然此不。有从不定聚入邪性定聚。彼答言尔。汝听堕负。若有三聚决定安立不相杂乱。谓不定聚。邪性定聚。正性定聚。决定别有不定聚。决定别有邪性定聚。决定别有正性定聚。则不应说有从不定聚入邪性定聚。汝作是言不应道理。汝今若说有从不定聚入邪性定聚。则不应说如是三聚决定安立不相杂乱。谓不定聚邪性定聚正性定聚。决定别有不定聚。决定别有邪性定聚。决定别有正性定聚。言有三聚决定安立不相杂乱。谓不定聚邪性定聚正性定聚。决定别有不定聚。决定别有邪性定聚。决定别有正性定聚。不应道理。彼作是言。定有从不定聚入邪性定聚。应问彼言。汝然此不彼即是彼。答言不尔。汝听堕负。若定有从。不定聚入邪性定聚。是则应说彼即是彼。汝作是言不应道理。若汝不说彼即是彼。则不应言。定有从不定聚入邪性定聚。言定有从不定聚入邪性定聚。不应道理。若作是言。彼即是彼。应问彼言。汝然此不。诸住不定聚即是住邪性定聚。答言不尔。汝听堕负。若彼即是彼。是则应说诸住不定聚即是住邪性定聚。汝作是言不应道理。若汝不说诸住不定聚即是住邪性定聚。则不应言彼即是彼。言彼即是彼不应道理。又若作是言。彼即是彼。应问彼言。汝然此不。住不定聚于生无漏根力觉支有所堪能。住邪性定聚无所堪能。彼答言尔

复问彼言汝然此不。彼有堪能即无堪能。答言不尔。汝听堕负。若彼即是彼。是则应说彼有堪能即无堪能。汝作是言不应道理。若汝不说彼有堪能即无堪能。则不应言彼即是彼。言彼即是彼不应道理。若作是言。彼异于彼。应问彼言。汝然此不。诸住不定聚断别生住邪性定聚。答言不尔。汝听堕负。若彼异于彼。是则应。说诸住不定聚断别生住邪性定聚。汝作是言不应道理。若汝不说诸住不定聚断别生住邪性定聚。则不应言彼异于彼。言彼异于彼不应道理。若作是言。不可说彼或彼或异。应问彼言。汝然此不。诸从不定聚入邪性定聚。如是之言。亦不可说或彼或异答言不尔。汝听堕负。若不可说。彼或彼或异是则应说。诸从不定聚入邪性定聚。如是之言。亦不可说或彼或异。汝作是言不应道理。若汝不说诸从不定聚入邪性定聚。如是之言。亦不可说或彼或异。则不应言不可说彼或彼或异。言不可说彼或彼或异。不应道理

补特伽罗论者。作如是言。谛义胜义补特伽罗。可得可证现有等有。是故定有补特伽罗。性空论者作是问言。汝然此不。谓契经中世尊善语善词善说。如是三聚决定安立不相杂乱。谓不定聚。邪性定聚。正性定聚。决定别有不定聚。决定别有邪性定聚。决定别有正性定聚。彼答言尔。复问彼言。汝然此不。有从不定聚入正性定聚。彼答言尔。汝听堕负。若有三聚决定安立不相杂乱。谓不定聚邪性定聚正性定聚。决定别有不定聚。决定别有邪性定聚。决定别有正性定聚。则不应说有从不定聚入正性定聚。汝作是言不应道理。汝今若说有从不定聚。入正性定聚。则不应言如是三聚决定安立不相杂乱。谓不定聚邪性定聚正性定聚。决定别有不定聚。决定别有邪性定聚。决定别有正性定聚。言有三聚决定安立不相杂乱。谓不定聚邪性定聚正性定聚。决定别有不定聚。决定别有邪性定聚。决定别有正性定聚。不应道理。彼作是言定有从。不定聚入。正性定聚。应问彼言。汝然此不。彼即是彼。答言不尔。汝听堕负。若定有从不定聚入正性定聚。是则应说彼即是彼。汝作是言不应道理。若汝不说彼即是彼。则不应言定有从不定聚入正性定聚。言定有从不定聚入正性定聚。不应道理。若作是言。彼即是彼。应问彼言。汝然此不。诸住不定聚即是住正性定聚。答言不尔。汝听堕负。若彼即是彼。是则应说诸住不定聚即是住正性定聚。汝作是言。不应道理。若汝不说诸住不定聚。即是住正性定聚。则不应言彼即是彼。言彼即是彼不应道理。又若作是言。彼即是彼。应问彼言。汝然此不。诸住不定聚是有量福田。住正性定聚是无量福田。彼答言尔。复问彼言。汝然此不。诸有量福田即是无量福田。答言不尔。汝听堕负。若彼即是彼。是则应说。诸有量福田即是无量福田。汝作是言不应道理。若汝不说诸有量福田即是无量福田。则不应言彼即是彼。言彼即是彼不应道理。若作是言。彼异于彼。应问彼言。汝然此不。诸住不定聚断别生住正性定聚。答言不尔。汝听堕负。若彼异于彼。是则应说诸住不定聚断别生住正性定聚。汝作是言不应道理。若汝不说诸住不定聚断别生住正性定聚。则不应言彼异于彼。言彼异于彼。不应道理。若作是言。不可说彼或彼或异。应问彼言。汝然此不。诸有从不定聚入正性定聚。如是之言。亦不可说或彼或异。答言不尔。汝听堕负。若不可说彼或彼或异。是则应说。诸有从不定聚入正性定聚。如是之言亦不可说或彼或异。汝作是言。不应道理。若汝不说诸有从不定聚入正性定聚。如是之言。亦不可说或彼或异。则不应言不可说彼或彼或异。言不可说彼或彼或异。不应道理

说一切有部识身足论卷第二阿毗达磨识身足论卷第三

        提婆设摩阿罗汉造

        三藏法师玄奘奉　诏译

    补特伽罗蕴第二之二第一嗢拖南颂后

补特伽罗论者。作如是言。谛义胜义。补特伽罗。可得可证。现有等有。是故定有补特伽罗。性空论者作是问言。汝然此不。谓契经中世尊善语善词善说。如是三种补特伽罗。决定安立不相杂乱。谓学补特伽罗。无学补特伽罗。非学非无学补特伽罗。彼答言尔。法亦三种。谓学法无学法非学非无学法。彼答言尔。复问彼言。汝然此不。先是非学非无学补特伽罗次成学。既成学已后成无学。成无学已复成学补特伽罗。彼答言尔。复问彼言。汝然此不。先是非学非无学法次成学。既成学已后成无学。成无学已复成学法。答言不尔。汝听堕负。若先是非学非无学补特伽罗次成学。既成学已后成无学。成无学已复成学补持伽罗。是则应说先是非学非无学法次成学。既成学已后成无学。成无学已复成学法。汝作是言不应道理。若汝不说先是非学非无学法次成学。既成学已后成无学。成无学已复成学法。则不应说先是非学非无学补特伽罗次成学。既成学已后成无学。成无学已复成学补特伽罗。言先是非学非无学补特伽罗次成学。既成学已后成无学。成无学已复成学补特伽罗。不应道理

补特伽罗论者。作如是言。有我有情命者生者养育士夫补特伽罗。由有补特伽罗故。能造诸业。或顺乐受。或顺苦受。或顺不苦不乐受。彼造顺乐受业已。领受乐受。造顺苦受业已。领受苦受。造顺不苦不乐受业。已领受不苦不乐受。性空论者作是问言。汝然此不自作苦乐。答言不尔。汝听堕负。若有我有情命者生者养育士夫补特伽罗。由有补特伽罗故。能造诸业。或顺乐受。或顺苦受。或顺不苦不乐受。彼造顺乐受业已。领受乐受。造顺苦受业已。领受苦受。造顺不苦不乐受业已。受不苦不乐受。是则应说自作苦乐。汝作是言不应道理。若汝不说自作苦乐。则不应说有我有情命者生者养育士夫补特伽罗。由有补特伽罗故。能造诸业。或顺乐受或顺苦受。或顺不苦不乐受。彼造顺乐受业已。领受乐受。造顺苦受业已。领受苦受。造顺不苦不乐受业已。受不苦不乐受。言有我有情命者生者养育士夫补特伽罗。由有补特伽罗故。能造诸业。或顺乐受。或顺苦受。或顺不苦不乐受。彼造顺乐受业已。领受乐受。造顺苦受业已。领受苦受。造顺不苦不乐受业已。受不苦不乐受。不应道理。若作是言。自作苦乐。应问彼言。汝然此不。谓契经中世尊善语善词善说。为鉆部卢出家外道说鉆部卢即受即领诸有欲令自作苦乐。此鉆部卢我终不说。彼答言尔。汝听堕负。若自作苦乐。则不应言谓契经中世尊善语善词善说为鉆部卢出家外道说鉆部卢即受即领诸有欲令自作苦乐。此鉆部卢我终不说。汝作是言不应道理。汝今若说谓契经中世尊善语善词善说为鉆部卢出家外道说鉆部卢即受即领诸有欲令自作苦乐。此鉆部卢。我终不说。则不应言自作苦乐。言自作苦乐不应道理。若作是言。他作苦乐。应问彼言。汝然此不。谓契经中世尊善语善词善说为鉆部卢出家外道说鉆部卢异受异领。若有欲令他作苦乐。此鉆部卢我终不说。彼答言尔。汝听堕负。若他作苦乐。则不应言谓契经中世尊善语善词善说为鉆部卢出家外道说鉆部卢异受异领。诸有欲令他作苦乐。此鉆部卢我终不说。汝作是言不应道理。汝今若说谓契经中世尊善语善词善说为鉆部卢出家外道说鉆部卢异受异领。诸有欲令他作苦乐。此鉆部卢我终不说。则不应言他作苦乐。言他作苦。乐不应道理

补特伽罗论者。作如是言。有我有情命者生者养育士夫补特伽罗。由有补特伽罗故。能造诸业。或顺乐受。或顺苦受。或顺不苦不乐受。彼造顺乐受业已。领受乐受。造顺苦受业已。领受苦受。造顺不苦不乐受业已。领受不苦不乐受。性空论者作是问言。汝然此不。此作此受。答言不尔。汝听堕负。若有我有情命者生者养育士夫补特伽罗。由有补特伽罗故。能造诸业。或顺乐受。或顺苦受。或顺不苦不乐受。彼造顺乐受业已。领受乐受。造顺苦受业已。领受苦受。造顺不苦不乐受业已。领受不苦不乐受。是则应言此作此受。汝作是言不应道理。若汝不说此作此受。则不应言有我有情命者生者养育士夫补特伽罗。由有补特伽罗故。能造诸业。或顺乐受。或顺苦受。或顺不苦不乐受。彼造顺乐受业已。领受乐受。造顺苦受业已。领受苦受。造顺不苦不乐受业已。领受不苦不乐受。言有我有情命者生者养育士夫补特伽罗。由有补特伽罗故。能造诸业。或顺乐受。或顺苦受。或顺不苦不乐受。彼造顺乐受业已。领受乐受。造顺苦受业已。领受苦受。造顺不苦不乐受业已。领受不苦不乐受。不应道理。若作是言。此作此受。应问彼言。汝然此不。谓契经中世尊善语善词善说。为一梵志说言。梵志此作此受是堕常边。彼答言尔。汝听堕负。若此作此受。则不应言谓契经中世尊善语善词善说。为一梵志说言。梵志。此作此受是堕常边。汝作是言不应道理。汝今若说谓契经中世尊善语善词善说。为一梵志说言。梵志。此作此受是堕常边。则不应言此作此受。言此作此受不应道理。若作是言。异作异受。应问彼言。汝然此不。谓契经中世尊善语善词善说。为一梵志说言。梵志异作异受是堕断边。彼答言尔。汝听堕负。若异作异受。则不应言于契经中世尊善语善词善说。为一梵志说言。梵志异作异受是堕断边。汝作是言不应道理。汝今若说谓契经中世尊善语善词善说。为一梵志说言。梵志。异作异受是堕断边。则不应言异作异受。言异作异受不应道理

补特伽罗论者作如是言。有我有情命者生者养育士夫补特伽罗。由有补特伽罗故。于所见闻觉知法中。已得已求。意随寻伺。性空论者。作是问言。汝然此不。谓契经中世尊善语善词善说。为本牧驴頞李瑟吒苾刍说言。苾刍诸所见闻觉知法中。已得已求。意随寻伺。如是一切非我我所。亦非我我。如是如实正慧观见。彼答言尔。汝听堕负。若有我有情命者生者养育士夫补特伽罗。由有补特伽罗故。于所见闻觉知法中。已得已求。意随寻伺。则不应言。谓契经中世尊善语善词善说。为本牧驴頞李瑟吒苾刍说言。苾刍。诸所见闻觉知法中。已得已求。意随寻伺。如是一切。非我我所。亦非我我。如是如实正慧观见。汝作是言不应道理。汝今若言。谓契经中世尊善语善词善说。为本牧驴頞李瑟吒苾刍说言。苾刍。诸所见闻觉知法中。已得已求。意随寻伺。如是一切。非我我所。亦非我我。如是如实正慧观见。则不应言有我有情命者生者养育士夫补特伽罗。由有补特伽罗故。于所见闻觉知法中。已得已求。意随寻伺。言有我有情命者生者养育士夫补特伽罗。由有补特伽罗故。于所见闻觉知法中。已得已求。意随寻伺。不应道理

    识身足论补特伽罗蕴第二中第二嗢拖南颂

  言慈何所缘　　识身与念住
  诸觉支可得　　有为及无为

性空论者。作如是言。谛义胜义补特伽罗。非可得非可证。非现有非等有。是故无有补特伽罗。补特伽罗论者问言。具寿。慈何所缘。答言。诸法性有等有。由想等想假说有情。于此义中慈缘执受诸蕴相续。彼问。汝说慈缘执受蕴相续耶。此答言尔。彼复问言。汝然此不。谓契经中世尊善语善词善说。当使有情具诸快乐。如是思惟入慈等至。此答言尔彼作是言。汝听堕负。若慈缘执受诸蕴相续。则不应言。谓契经中世尊善语善词善说。当使有情具诸快乐。如是思惟入慈等至。汝作是言不应道理。汝今若说谓契经中世尊善语善词善说。当使有情具诸快乐。如是思惟入慈等至。则不应言慈缘执受诸蕴相续。言慈缘执受诸蕴相续。不应道理。应问彼言。汝然此不。谓契经中世尊善语善词善说。有六识身。眼识耳鼻舌身意识。彼答言尔。问言。具寿。慈与何等识身相应。为眼识耶。为耳鼻舌身意识耶。若言眼识相应。则不缘有情。以诸眼识。唯缘色故。若言耳识相应。则不缘有情。以诸耳识唯缘声故。若言鼻识相应。则不缘有情。以诸鼻识唯缘香故。若言舌识相应。则不缘有情。以诸舌识唯缘味故。若言身识相应。则不缘有情。以诸身识唯缘触故。若言意识相应。则不缘有情。以诸意识唯缘法故。若言不与眼识耳鼻舌身意识相应。即应别有第七有情之识慈与彼相应。此识世尊不现等觉。具寿。世尊于无畏中作如是说。我于诸法现正等觉。若有沙门或婆罗门天魔梵等。如法诘难或令忆念。于是法中不现等觉。我于如是正见。无缘我正见。彼无有缘故。得安隐住无怖无畏。自称我处大仙尊位转大梵轮。于大众中正师子吼。具寿若尔。岂不难佛为无智耶。彼言。具寿。我不难佛以为无智。世尊于此虽现等觉而不宣说。具寿世尊曾为具寿阿难陀说。汝阿难陀。我于诸法无间宣传。谓四念住四正断四如意足五根五力七等觉支八圣道支。汝阿难陀。如来于法无有师拳。谓自覆藏恐他知我无所识解。具寿若尔。为不难佛有师拳耶。彼言。具寿。我不难佛以为无智。亦不难佛为有师拳。世尊于彼虽现等觉而不宣说。具寿。世尊升摄波林。契经中说。汝等苾刍。乃至大地升摄波林叶之齐量。我于彼法自然了知。虽现等觉不为他说。是故世尊。于如是识虽现等觉而不宣说。应问彼言。具寿即彼契经。为不更有余广句耶。谓世尊言。汝等苾刍。然彼诸法。不能引义。不能引善。不能引法。不引梵行。不证神通。不证等觉。不证涅槃。设有如是补特伽罗。不能引义。不能引善。不能引法。不引梵行。不证神通。不证等觉。不证涅槃。即无所用。是故无有补特伽罗。性空论者。作如是言。谛义胜义补特伽罗。非可得非可证。非现有非等有。是故无有补特伽罗。补特伽罗论者问言。具寿慈何所缘。答言。诸法性有等有由想等想。假说有情。于此义中慈缘执受诸蕴相续。彼问汝说慈缘执受蕴相续耶。此答言尔。彼复问言。汝然此不。谓契经中世尊善语善词善说。当使有情具诸快乐。如是思惟入慈等至此答言尔。彼作是言。汝听堕负。若慈缘执受诸蕴相续。则不应言谓契经中世尊善语善词善说。当使有情具诸快乐。如是思惟入慈等至。汝作是言不应道理。汝今若说。谓契经中世尊善语善词善说。当使有情具诸快乐。如是思惟入慈等至。则不应言慈缘执受诸蕴相续言慈缘执受诸蕴相续。不应道理。应问彼言。汝然此不。谓契经中世尊善语善词善说。有四念住。身念住受心法念住。彼答言尔。问言。具寿。慈与何等念住相应。为身念住耶。为受心法念住耶。若言身念住相应。则不缘有情。以身念住唯缘身故。若言受念住相应。则不缘有情。以受念住唯缘受故。若言心念住相应。则不缘有情。以心念住唯缘心故。若言法念住相应。则不缘有情。以法念住唯缘法故。若言不与身念住受心法念住相应。即应别有第五有情念住慈与彼相应。此念住世尊不现等觉。具寿。世尊于无畏中作如是说。我于诸法现正等觉。若有沙门或婆罗门天魔梵等如法诘难。或令忆念。于是法中不现等觉。我于如是正见。无缘我正见。彼无有缘故。得安隐住无怖无畏。自称我处大仙尊位转大梵轮。于大众中正师子吼。具寿若尔。岂不难佛为无智耶。彼言。具寿。我不难佛以为无智。世尊于此虽现等觉而不宣说。具寿。世尊曾为具寿阿难陀说。汝阿难陀。我于诸法无间宣传。谓四念住四正断四如意足五根五力七等觉支八圣道支汝阿难陀。如来于法无有师拳。谓自覆藏恐他知我无所识解。具寿若尔。为不难佛有师拳耶。彼言具寿。我不难佛以为无智。亦不难佛为有师拳。世尊于彼虽现等觉而不宣说。具寿。世尊升摄波林。契经中说。汝等苾刍。乃至大地升摄波林叶之齐量。我于彼法自然了知。虽现等觉不为他说。是故世尊于彼念住。虽现等觉而不宣说。应问彼言。具寿。即彼契经。为不更有余广句耶。谓世尊言。汝等苾刍。然彼诸法。不能引义。不能引善。不能引法。不引梵行。不证神通。不证等觉。不证涅槃。设有如是。补特伽罗。不能引义。不能引善。不能引法。不引梵行。不证神通。不证等觉。不证涅槃。即无所用。是故无有补特伽罗

性空论者。作如是言。谛义胜义。补特伽罗。非可得非可证。非现有非等有。是故无有补特伽罗。补特伽罗论者问言。具寿。慈何所缘。答言。诸法性有等有由想等想。假说有情。于此义中慈缘执受诸蕴相续。彼问。汝说慈缘执受蕴相续耶。此答言尔。彼复问言。汝然此不。谓契经中世尊善语善词善说。当使有情具诸快乐。如是思惟入慈等至。此答言尔。彼作是言。汝听堕负。若慈缘执受诸蕴相续。则不应言。谓契经中世尊善语善词善说。当使有情具诸快乐。如是思惟入慈等至。汝作是言不应道理。汝今若说。谓契经中世尊善语善词善说。当使有情具诸快乐。如是思惟入慈等至。则不应言慈缘执受诸蕴相续。言慈缘执受诸蕴相续。不应道理。应问彼言汝然此不。谓契经中世尊善语善词善说。有七等觉支念等觉支择法精进喜安定舍等觉支。彼答言尔。问言。具寿。慈与何等觉支相应。为念等觉支耶。为择法精进喜安定舍等觉支耶。若言念等觉支相应。则不缘有情。以念等觉支唯缘法故。若言择法精进喜安定舍等觉支相应。则不缘有情。以舍等觉支唯缘法故。若言不与念等觉支择法精进喜安定舍等觉支相应。即应别有第八有情等觉支慈与彼相应。此等觉支世尊不现等觉。具寿。世尊于无畏中作如是说。我于诸法现正等觉。若有沙门或婆罗门天魔梵等。如法诘难。或令忆念。于是法中不现等觉。我于如是正见。无缘我正见。彼无有缘故。得安隐住无怖无畏。自称我处大仙尊位转大梵轮。于大众中正师子吼。具寿若尔。岂不难佛为无智耶。彼言。具寿。我不难佛以为无智。世尊于此虽现等觉而不宣说具寿。世尊曾为具寿阿难陀说。汝阿难陀。我于诸法无间宣传。谓四念住四正断四如意足五根五力七等觉支八圣道支。汝阿难陀。如来于法无有师拳。谓自覆藏恐他知我无所识解。具寿若尔。为不难佛有师拳耶。彼言。具寿。我不难佛以为无智。亦不难佛为有师拳。世尊于此虽现等觉而不宣说。具寿。世尊升摄波林。契经中说。汝等苾刍。乃至大地升摄波林叶之齐量。我于彼法自然了知。虽现等觉不为他说。是故世尊。于彼等觉支。虽现等觉而不宣说。应问彼言。具寿。即彼契经为不更有余广句耶。谓世尊言。汝等苾刍。然彼诸法。不能引义。不能引善。不能引法。不引梵行。不证神通。不证等觉。不证涅槃。设有如是补特伽罗。不能引义。不能引善。不能引法。不引梵行。不证神通。不证等觉。不证涅槃。即无所用。是故无有补特伽罗

补特伽罗论者。作如是言。有为可得。无为可得。补特伽罗亦有可得。性空论者问言。具寿。补特伽罗。当言有为。当言无为。若言有为。应同有为可施设。有生灭住异。若言无为应同无为可施设。无生灭住异。具寿。世尊为诸苾刍说有二物。一者有为。二者无为。为无为外无别有物。是故无有补特伽罗

    识身足论补特伽罗蕴第二中第三嗢拖南颂

  补特伽罗无有空　　诸法和合各所作
  了知由几俱生二　　心性无常明爱缘

有六识身。谓眼识耳鼻舌身意识。眼色为缘生眼识如是眼识唯能识诸色。非补特伽罗。此补特伽罗非眼识所识。唯有诸色为眼识所识。是故此眼识非补特伽罗识又眼色为缘生眼识。三和合故有触。如是眼触唯能触诸色。非补特伽罗。此补特伽罗非眼触所触。唯有诸色为眼触所触。是故此眼触非补特伽罗触。又眼色为缘生眼识。三和合故有触。触为缘故生受。如是眼触所生受。唯能受诸色。非补特伽罗。此补特伽罗。非眼触所生受所受。唯有诸色。为眼触所生受所受。是故此眼触所生受。非补特伽罗触所生受。又眼色为缘生眼识。三和合故有触。触为缘故生想。如是眼触所生想。唯能想诸色。非补特伽罗。此补特伽罗。非眼触所生想所想。唯有诸色。为眼触所生想所想。是故此眼触所生想。非补特伽罗触所生想。又眼色为缘生眼识。三和合故有触。触为缘故生思。如是眼触所生思。唯能思诸色。非补特伽罗。此补特伽罗。非眼触所生思所思。唯有诸色。为眼触所生思所思。是故此眼触所生思。非补特伽罗触所生思。由此诸法触为第五补特伽罗。非可得非可证。非现有非等有。是故无有补特伽罗。如眼识耳鼻舌身意识亦尔

有六识身。为眼识耳鼻舌身意识。眼色为缘生眼识。此中若眼若色若眼识。皆非补特伽罗。唯有眼色为缘生眼识。又眼色为缘生眼识。三和合故有触。此中若眼若色若眼识若眼触。皆非补特伽罗。唯有眼色为缘生眼识。三和合故有触。又眼色为缘生眼识。三和合故有触。触为缘故生受。此中若眼若色若眼识若眼触若眼触所生受。皆非补特伽罗。唯有眼色为缘生眼识。三和合故有触。触为缘故生受。又眼色为缘生眼识。三和合故有触。触为缘故生想。此中若眼若色若眼识若眼触若眼触所生想。皆非补特伽罗。唯有眼色为缘生眼识。三和合故有触。触为缘故生想。又眼色为缘生眼识。三和合故有触。触为缘故生思。此中若眼若色若眼识若眼触若眼触所生思。皆非补特伽罗唯有眼色为缘生眼识。三和合故有触。触为缘故生思。由此诸法触。为第五补特伽罗。非可得非可证。非现有非等有。是故无有补特伽罗。如眼识耳鼻舌身意识亦尔

有六识身。谓眼识耳鼻舌身意识。眼色为缘生眼识。此中眼生色生眼识不生。如是不可得。眼生色生眼识亦生。如是可得。此中眼灭色灭眼识不灭。如是不可得。眼灭色灭眼识亦灭。如是可得。又眼色为缘生眼识。三和合故有触此中眼生色生眼识生。眼触不生。如是不可得。眼生色生眼识生。眼触亦生。如是可得。此中眼灭色灭眼识灭。眼触不灭。如是不可得。眼灭色灭眼识灭。眼触亦灭。如是可得。又眼色为缘生眼识。三和合故有触。触为缘故生受。此中眼生色生眼识生。眼触生眼触所生受不生。如是不可得。眼生色生眼识生。眼触生眼触所生受亦生。如是可得。此中眼灭色灭眼识灭。眼触灭眼触所生受不灭。如是不可得。眼灭色灭眼识灭。眼触灭眼触所生受亦灭。如是可得。又眼色为缘生眼识。三和合故有触。触为缘故生想。此中眼生色生眼识生。眼触生眼触所生想不生。如是不可得。眼生色生眼识生。眼触生眼触所生想亦生。如是可得。此中眼灭色灭眼识灭。眼触灭眼触所生想不灭。如是不可得。眼灭色灭眼识灭。眼触灭眼触所生想亦灭。如是可得。又眼色为缘生眼识。三和合故有触。触为缘故生思。此中眼生色生眼识生。眼触生眼触所生思不生。如是不可得。眼生色生眼识生。眼触生眼触所生思亦生。如是可得。此中眼灭色灭眼识灭。眼触灭眼触所生思不灭。如是不可得。眼灭色灭眼识灭。眼触灭眼触所生思亦灭。如是可得。如是诸法触为第五同生同住同灭。一生时一切生。一灭时一切灭。由此诸法触。为第五补特伽罗。非可得非可证。非现有非等有。是故无有补特伽罗。如眼识耳鼻舌身意识亦尔

有六识身。谓眼识耳鼻舌身意识。眼色为缘生眼识。如是眼识能识诸色。非触非受非想非思。由能识相是眼识故。又眼色为缘生眼识。三和合故有触。如是眼触能触诸色。非受非想非思非识。由能触相是眼触故。又眼色为缘生眼识。三和合故有触。触为缘故生受。如是眼触所生受能受诸色。非想非思非识非触。由能受相是眼触所生受故。又眼色为缘生眼识。三和合故有触。触为缘故生想。如是眼触所生想能想诸色。非思非识非触非受。由能想相是眼触所生想故。又眼色为缘生眼识。三和合故有触。触为缘故生思。如是眼触所生思能思诸色。非识非触非受非想。由能思相是眼触所生思故。如是诸法触。为第五同生同住同灭。一生时一切生。一灭时一切灭。既生起已。各各别作自所作事。不作其余他所作事。由此诸法触为第五补特伽罗。非可得非可证。非现有非等有。是故无有补特伽罗。如眼识耳鼻舌身意识亦尔

有六识身。谓眼识耳鼻舌身意识。问眼识何所了别。答眼识了别诸色。何所不了别。谓十一处。问耳识何所了别。答耳识了别诸声。何所不了别。谓十一处。问鼻识何所了别。答鼻识了别诸香。何所不了别。谓十一处。问舌识何所了别。答舌识了别诸味。何所不了别。谓十一处。问身识何所了别。答身识了别诸触。何所不了别。谓十一处。问意识何所了别。答意识了别。眼色及眼识。耳声及耳识。鼻香及鼻识。舌味及舌识。身触及身识。意法及意识。如是六识身。是能了别。有了别性。非无了别性。补特伽罗无如是性。是故无有补特伽罗。有十二处。谓眼处色处耳处声处鼻处香处舌处味处身处触处意处法处。问眼处几识所识。乃至法处几识所识。答色处二识所识。谓眼识及意识。声处二识所识。谓耳识及意识。香处二识所识。谓鼻识及意识。味处二识所识。谓舌识及意识。触处二识所识谓身识及意识。余七处唯意识所识。如是十二处。是所识有所识性。非无所识性。补特伽罗无如是性。是故无有补特伽罗

有六识身。谓眼识耳鼻舌身意识。眼色为缘生眼识。三和合故有触。与触俱生有受想思。由此识法触为第五。补特伽罗。非可得非可证。非现有非等有。是故无有补特伽罗。如眼识耳鼻舌身意识亦尔

于可爱事由无智故。便生等贪。此中无智即是无明。等贪即行。了别事相即是其识。识俱四蕴即是名色。名色依根即是六处。六处和合即是其触。此中领纳即是其受。受生欣喜即是其爱。此爱增广即名为取。能生后有业即名有。诸蕴现起则名为生。诸蕴成熟即名为老。诸蕴弃舍即名为死。于内热恼即名为愁。发言怨嗟即名为叹。五识相应不平安受。说名为苦。意识相应不平安受。说名为忧。其心热恼扰恼燋恼。说名扰恼。等起谓生。言如是者。示现显了开发增语。能生起故。说名积集。纯谓至极。究竟圆满。大苦蕴者。大灾大横大殃大恼。顺大世分。众苦法聚

又诸无明未断未知。为因为缘诸行生起。谓随福行。随非福行。随不动行。如是诸行未断未知。为因为缘诸识生起。或往善趣或往恶趣。如是诸识未断未知。为因为缘名色生起。或在此世或在后世。如是名色未断未知。为因为缘六处生起。或有圆满或不圆满。六处和合故有其触。随触领纳故有其受。受生欣喜故有其爱。即爱增广说名为取。能感后有业名为有。诸蕴现起说名为生。诸蕴成熟说名为老诸蕴弃舍说名为死。于内热恼说名为愁。发言怨嗟说名为叹。五识相应不平安受。说名为苦。意识相应不平安受。说名为忧。其心热恼扰恼燋恼。说名扰恼。等起谓生。言如是者。示现显了开发增语。能生起故。说名积集。纯谓至极。究竟圆满。大苦蕴者。大灾大横大殃大恼。顺大世分。众苦法聚

由十四因。应知心性决定无常。谓加行故。相应故。威仪路故。工巧处故。身业故。语业故。意业故。因故。等无间故。所缘故。增上故。染不染故。受差别故。所作事业展转异故

若心已生分明可了。或于今时。或于余时。诸所忆念即所了知。如是心性不离前心。又此心性不离前心。由此道理诸心展转。无前际来诸心次第。如是名为苦集圣谛。如是应观苦集圣谛如是观者名为正观。若异观者名为邪智

若有诸爱未断未知。为因为缘后苦生起。若有诸爱已断已知。无因无缘可令后苦更得生起。设使诸爱已断已知。为因为缘后苦生起。由此具寿。应见应闻。如是具寿。已离诸爱生于世间然今诸爱已断已知。无因无缘可令后苦更得生起是故具寿。不见不闻。如是具寿。已离诸爱生于世间。如是名为苦灭圣谛。如是应观苦灭圣谛。如是观者名为正观若异观者名为邪智

有六识身。谓眼识耳鼻舌身意识。眼识有四缘。一因缘。二等无间缘。三所缘缘。四增上缘。何等因缘。谓此俱有相应法等。何等等无间缘。谓若从彼诸心心法平等无间。如是眼识已生正生。何等所缘缘。谓一切色。何等增上缘。谓除自性余一切法。是名眼识所有四缘。谓因缘等无间缘。所缘缘增上缘。如是眼识是谁因缘。谓此俱有相应法等。是谁等无间缘。谓从眼识平等无间。已生正生。诸心心法。是谁所缘缘。谓能缘此诸心心法。是谁增上缘。谓除自性余一切法。如眼识耳鼻舌身意识亦尔

说一切有部识身足论卷第三阿毗达磨识身足论卷第四

        提婆设摩阿罗汉造

        三藏法师玄奘奉　诏译

    因缘蕴第三之一嗢拖南颂

  过去等因与善等　　随增几缘几因等
  十十五心非因等　　结缚随眠等相应

有六识身。谓眼识耳鼻舌身意识。如是六识身。或过去或未来或现在。过去眼识颇有过去为因。非未来为因非现在为因耶。颇有未来为因。非过去为因非现在为因耶。颇有现在为因。非过去为因非未来为因耶。颇有过去现在为因。非未来为因耶。颇有未来现在为因。非过去为因耶。颇有过去未来为因非现在为因耶。颇有过去未来现在为因耶。如过去眼识。未来现在眼识亦尔。如眼识耳鼻舌身意识亦尔

过去眼识。一切皆用过去为因。所余诸句皆不可得。未来眼识。或用过去未来为因。非现在为因。何等未来因。谓此俱有相应等法。何等过去因。谓过去法。与此眼识。或为同类或异熟等。非现在法与此眼识或为同类或异熟等。或有过去未来现在为因。何等未来因。谓此俱有相应等法。何等过去现在因。谓过去现在法。与此眼识或为同类或异熟等现在眼识。一切皆用过去现在为因。所余诸句皆不可得。何等现在因。谓此俱有相应诸法。何等过去因。谓过去法。与此眼识。或为同类或异熟等。如眼识。耳鼻舌身识亦尔。过去意识。一切皆用过去为因。所余诸句皆不可得。未来意识或有未来为因。非过去现在为因。谓未证入正性离生补特伽罗。未来最初无漏意识。何等未来因。谓此俱有相应诸法。或有未来现在为因。非过去为因。谓苦法智忍现在前时。所有未来无漏意识何等未来因。谓此俱有相应诸法。何等现在因。谓苦法智忍。及彼俱有相应等法。或有过去未来为因非现在为因。何等未来因。谓此俱有相应等法。何等过去因。谓过去法。与此意识。或为同类或异熟等。非现在法与此意识或为同类或异熟等。或有过去未来现在为因。何等未来因。谓此俱有相应等法。何等过去现在因谓。过去现在法与。此意识或为同类或异熟等。现在意识。或有现在为因。非过去为因。非未来为因。谓苦法智。忍现在前。时与彼俱有相应意识。何等现在因谓此俱有相应诸法。或有过去现在为因。非未来为因。何等现在因。谓此俱有相应诸法。何等过去因。谓过去法与此意识。或为同类或异熟等

有六识身。谓眼识耳鼻舌身意识。如是六识身。或善或不善或无记。善眼识。颇有善为因。非不善为因非无记为因耶。颇有不善为因。非善为因非无记为因耶。颇有无记为因。非善为因非不善为因耶。颇有善无记为因。非不善为因耶。颇有不善无记为因。非善为因耶。颇有善不善为因。非无记为因耶。颇有善不善无记为因耶。如善眼识。不善无记眼识亦尔。如眼识耳鼻舌身意识亦尔

善眼识一切皆用善为因。所余诸句皆不可得。不善眼识。一切皆用不善无记为因。所余诸句皆不可得。无记眼识。或有无记为因。非善为因。非不善为因。谓威仪路工巧处眼识。及梵世所系染污眼识。或有善无记为因。非不善为因。谓善异熟生眼识。何等无记因。谓此俱有相应等法。何等善因。谓彼善法。能感于此眼识异熟。或有不善无记为因。非善为因。谓不善异熟生眼识何等无记因。谓此俱有相应等法。何等不善因。谓彼不善法。能感于此眼识异熟。如眼识耳鼻舌身识亦尔。此中差别者。鼻识舌识不应说有梵世所系。善意识一切皆用善为因。所余诸句皆不可得。不善意识。一切皆用不善无记为因。所余诸句皆不可得。无记意识。或有无记为因。非善为因。非不善为因。谓威仪路工巧处意识。及色无色所系染污意识。或有善无记为因。非不善为因。谓善异熟生意识。何等无记因。谓此俱有相应等法。何等善因。谓彼善法能感于此意识异熟。或有不善无记为因。非善为因。谓欲所系有身见边执见相应意识。何等无记因。谓此俱有相应等法。何等不善因。谓欲所系见苦所断八随眠等。及见集所断遍行随眠等

有六识身。谓眼识耳鼻舌身意识。如是六识身。或善或不善。或有覆无记。或无覆无记。于善眼识。有几随眠之所随增。于不善有覆无记无覆无记眼识。有几随眠之所随增。如眼识耳鼻舌身意识亦尔

于善眼识。有欲缠色缠遍行随眠及修所断随眠之所随增。于不善眼识。有欲缠遍行随眠及修所断随眠之所随增。于有覆无记眼识。有色缠遍行随眠及修所断随眠之所随增。于无覆无记眼识。有欲缠色缠遍行随眠及修所断随眠之所随增如眼识耳鼻舌身识亦尔。此中差别者。鼻识舌识不应说有有覆无记。于善意识。有三界遍行随眠及修所断随眠之所随增。于不善意识。有欲缠一切随眠之所随增。于有覆无记意识。有色无色缠一切随眠及欲缠见苦所断一切随眠见集所断遍行随眠之所随增。于无覆无记意识。有三界遍行随眠及修所断随眠之所随增

有六识身。谓眼识耳鼻舌身意识。如是六识身。或善或不善。或有覆无记。或无覆无记。于善眼识。有几随眠。当言为因。当言为缘。有几随眠。当言为缘而不为因。于不善有覆无记无覆无记眼识。有几随眠。当言为因当言为缘。有几随眠。当言为缘而不为因如眼识。耳鼻舌身意识亦尔

于善眼识一切随眠。当言为缘而不为因。于不善眼识有十五随眠。当言为因。当言为缘。所余随眠。当言为缘而不为因。于有覆无记眼识。有十四随眠。当言为因。当言为缘。所余随眠。当言为缘而不为因。于无覆无记眼识中。除随眠异熟眼识。于余无覆无记眼识。一切随眠。当言为缘而不为因。于随眠异熟眼识。有三十四随眠。当言为因。当言为缘。所余随眠。当言为缘而不为因。问一心耶。答不尔。于见苦所断邪见随眠异熟眼识。有二随眠。当言为因。当言为缘。所余随眠。当言为缘而不为因。如见苦所断邪见。见取戒禁取疑贪恚慢亦尔。于见苦所断不共无明随眠异熟眼识。有一随眠。当言为因。当言为缘。所余随眠。当言为缘而不为因。于见集所断邪见随眠异熟眼识。有二随眠。当言为因。当言为缘。所余随眠。当言为缘而不为因。如见集所断邪见。见取疑贪恚慢亦尔。于见集所断不共无明随眠异熟眼识。有一随眠。当言为因。当言为缘。所余随眠。当言为缘而不为因。于见灭所断邪见随眠异熟眼识。有二随眠。当言为因。当言为缘。所余随眠。当言为缘而不为因。如见灭所断邪见。见取疑贪恚慢亦尔。于见灭所断不共无明随眠异熟眼识。有一随眠。当言为因。当言为缘。所余随眠。当言为缘而不为因。于见道所断邪见随眠异熟眼识。有二随眠。当言为因。当言为缘。所余随眠。当言为缘而不为因。如见道所断邪见。见取戒禁取疑贪恚慢亦尔。于见道所断不共无明随眠异熟眼识。有一随眠。当言为因。当言为缘。所余随眠。当言为缘而不为因。于修所断贪随眠异熟眼识。有二随眠。当言为因。当言为缘。所余随眠。当言为缘而不为因。如修所断贪。恚慢亦尔。于修所断不共无明随眠异熟眼识。有一随眠。当言为因。当言为缘。所余随眠。当言为缘而不为因。如眼识。耳鼻舌身识亦尔。此中差别者。鼻识舌识不应说有有覆无记。于善意识一切随眠。当言为缘而不为因。于不善意识。有三十六随眠。当言为因。当言为缘。所余随眠。当言为缘而不为因。问一心耶。答不尔。于见苦。所断不善意识。有十四随眠。当言为因。当言为缘。所余随眠。当言为缘而不为因。于见集所断不善意识。有十四随眠。当言为因。当言为缘。所余随眠。当言为缘而不为因。于见灭所断不善意识。有十八随眠。当言为因。当言为缘。所余随眠。当言为缘而不为因。于见道所断不善意识。有十九随眠。当言为因。当言为缘。所余随眠。当言为缘。而不为因。于修所断不善意识。有十五随眠。当言为因。当言为缘。所余随眠。当言为缘而不为因。于有覆无记意识。有七十六随眠。当言为因。当言为缘。所余随眠。当言为缘而不为因。问一心耶。答不尔。于欲所系有覆无记意识。有十四随眠。当言为因。当言为缘。所余随眠。当言为缘而不为因。于色所系见苦所断有覆无记意识。有十三随眠。当言为因。当言为缘。所余随眠。当言为缘而不为因。于色所系见集所断有覆无记意识。有十三随眠。当言为因。当言为缘。所余随眠。当言为缘而不为因。于色所系见灭所断有覆无记意识。有十七随眠。当言为因。当言为缘。所余随眠。当言为缘而不为因。于色所系见道所断有覆无记意识。有十八随眠。当言为因。当言为缘。所余随眠。当言为缘而不为因。于色所系修所断有覆无记意识。有十四随眠。当言为因。当言为缘。所余随眠。当言为缘而不为因。如色所系。无色所系亦尔。于无覆无记意识。一切随眠。当言为缘而不为因

有六识身。谓眼识耳鼻舌身意识。如是六识身。或过去或未来或现在。或善或不善。或有覆无记。或无覆无记。于过去善眼识所有随眠。彼于此心若所随增。亦能为因耶。设于此心能为因者。为所随增耶。如过去善眼识。未来现在善眼识亦尔。如善眼识。不善有覆无记无覆无记眼识亦尔。如眼识耳鼻舌身意识亦尔

于过去善眼识所有随眠。彼于此心若所随增。即不为因。若于此心能为因者。即非随眠亦不随增。如过去善眼识。未来现在善眼识亦尔。于过去不善眼识。所有随眠。彼于此心或能为因。非所随增。或所随增不能为因。或能为因。亦所随增。或不能为因。亦非所随增。且能为因非所随增者。谓诸随眠在此心前。同类遍行。即彼随眠。若不缘此。设缘已断。及此相应随眠已断。为所随增不能为因者。谓诸随眠在此心后。同类遍行。即彼随眠。缘此未断。能为其因亦所随增者。谓诸随眠。在此心前。同类遍行。即彼随眠。缘此未断。及此相应随眠未断。不能为因亦非所随增者。谓诸随眠在此心后。同类遍行。即彼随眠。若不缘此。设缘已断。若所余缘。若他随眠。若不同界遍行随眠。如过去不善眼识。未来不善眼识亦尔。于现在不善眼识。所有随眠。彼于此心或能为因非所随增。或所随增不能为因。或能为因亦所随增。或不能为因。亦非所随增。且能为因非所随增者。谓诸随眠在此心前。同类遍行。即彼随眠。若不缘此。设缘已断。是所随增不能为因者。谓诸随眠在此心后。同类遍行。即彼随眠。缘此未断。是能为因亦所随增者。谓诸随眠在此心前。同类遍行。即彼随眠。缘此未断。及此相应所有随眠。不能为因非所随增者。谓诸随眠在此心后。同类遍行。即彼随眠。若不缘此。设缘已断。若所余缘。若他随眠。若不同界遍行随眠。如不善眼识。有覆无记眼识亦尔。于过去无覆无记眼识。所有随眠。彼于此心为所随增。亦为因耶。除诸随眠异熟眼识。于余过去无覆无记眼识。所有随眠。彼于此心。若所随增不能为因。若于此心能为因者。即非随眠亦不随增。若诸随眠异熟眼识。所有随眠。彼于此心或能为因非所随增。或所随增不能为因。或能为因亦所随增。或不能为因亦非所随增。且能为因非所随增者。谓诸随眠为因。能感此心异熟。即彼随眠。若不缘此。设缘已断。为所随增不能为因者。谓诸随眠不为因感此心异熟。即彼随眠。缘此未断。是能为因亦所随增者。谓诸随眠为因。能感此心异熟。即彼随眠。缘此未断。不能为因非所随增者。谓诸随眠不为因感此心异熟。即彼随眠。不能缘此。设缘已断。若所余缘。若他随眠。若不同界遍行随眠。如过去无覆无记眼识。未来现在无覆无记眼识亦尔。如眼识。耳鼻舌身意识亦尔。此中差别者。鼻识舌识。不应说有有覆无记。不应说有随眠所感异熟意识

有六识身。谓眼识耳鼻舌身意识。如是六识身。或过去或未来或现在。或善或不善。或有覆无记。或无覆无记。于过去善眼识所有随眠。彼于此心若不随增。亦不为因耶。设于此心不为因者。亦不随增耶。如过去善眼识。未来现在善眼识亦尔。如善眼识。不善有覆无记无覆无记眼识亦尔。如眼识。耳鼻舌身意识亦尔

于过去善眼识所有随眠。彼于此心若不随增。亦不为因。或不为因非不随增。谓诸随眠缘此未断。如过去善眼识。未来现在善眼识亦尔。于过去不善眼识。所有随眠。彼于此心或不为因非不随增。或不随增非不为因。或不为因亦不随增。或非不为因。非不随增。且不为因非不随增者。谓诸随眠在此心后。同类遍行。即彼随眠。缘此未断。非所随增非不为因者。谓彼随眠在此心前。同类遍行。即彼随眠。若不缘此。设缘已断。及此相应随眠已断。不能为因亦不随增者。谓诸随眠在此心后。同类遍行。即彼随眠。若不缘此。设缘已断。若所余缘。若他随眠。若不同界遍行随眠。非不为因非不随增者。谓诸随眠在此心前。同类遍行。即彼随眠。缘此未断。及此相应随眠未断。如过去不善眼识。未来不善眼识亦尔。于现在不善眼识。所有随眠。彼于此心。或不为因非不随增。或不随增非不为因。或不为因亦不随增。或非不为因。非不随增。且不为因非不随增者。谓诸随眠在此心后。同类遍行。即彼随眠。缘此未断非所随增非不为因者。谓诸随眠在此心前。同类遍行。即彼随眠。若不缘此。设缘已断。不能为因非所随增者。谓诸随眠在此心后。同类遍行。即彼随眠。若不缘此。设缘已断。若所余缘。若他随眠。若不同界遍行随眠。非不为因非不随增者。谓诸随眠在此心前。同类遍行。即彼随眠。缘此未断。及此相应所有随眠。如善眼识。有覆无记眼识亦尔。于过去无覆无记眼识。所有随眠。彼于此心若不随增亦不为因耶。谓除随眠异熟眼识。于余无覆无记眼识。所有随眠。彼于此心若不随增亦不为因。或不为因非不随增。谓诸随眠。缘此未断。若诸随眠异熟眼识。所有随眠。彼于此心或不为因非不随增。或不随增非不为因。或不为因亦不随增。或非不为因。非不随增。且不为因非不随增者。谓诸随眠不为因感此心异熟。即彼随眠。缘此未断。非所随增非不为因者。谓诸随眠为因能感此心异熟。即彼随眠。若不缘此。设缘已断。不能为因非所随眠者。谓诸随眠不为因感此心异熟。即彼随眠。若不缘此。设缘已断。若所余缘。若他随眠。若不同界遍行随眠。非不为因非不随增者。谓诸随眠为因能感此心异熟。即彼随眠。缘此未断。如过去无覆无记眼识。未来现在无覆无记眼识亦尔。如眼识。耳鼻舌身意识亦尔。此中差别者。鼻识舌识。不应说有有覆无记。不应说有随眠所感异熟意识

有十种心。谓欲界系善心。不善心。有覆无记心。无覆无记心。色界系善心。有覆无记心。无覆无记心。无色界系善心。有覆无记心。无覆无记心。欲界系善心。若体未断未断为因耶。设未断为因体未断耶。乃至无色界系无覆无记心。若体未断未断为因耶。设未断为因体未断耶

欲界系善心。若体未断未断为因耶。曰如是。设未断为因体未断耶。曰如是。诸不善心。若体未断未断为因耶。或体未断未断为因。或体未断已断为因。及未断为因。且体未断未断为因者。谓诸具缚补特伽罗。诸不善心自体未断。未断为因。或体未断。已断为因。及未断为因者。谓未离欲界贪。苦智已生集智未生。见集灭道。及修所断诸不善心。何等未断因。谓此俱有相应等法。何等已断因。谓欲界系见苦所断遍行随眠。及彼相应等法。集智已生灭智未生。见灭道修所断诸不善心。何等未断因。谓此俱有相应等法。何等已断因。谓欲界系遍行随眠。及彼相应等法。灭智已生道智未生。见道修所断诸不善心。何等未断因。谓此俱有相应等法。何等已断因谓欲界系遍行随眠。及彼相应等法。若见圆满。世尊弟子。未离欲界贪。修所断诸不善心。何等未断因。谓此俱有相应等法。何等已断因。谓欲界系遍行随眠。及彼相应等法。是名体未断已断为因。及未断为因。设未断为因体未断耶。或未断为因。体亦未断或未断为因。及已断为因。而体未断或未断为因。及已断为因。其体已断。未断为因。体未断者。谓诸具缚补特伽罗。诸不善心。是名未断为因。体亦未断未断为因。及已断为因。体未断者。谓未离欲界贪。苦智已生集智未生见集灭道。及修所断诸不善心。何等未断因。谓此俱有相应等法。何等已断因。谓欲界系见苦所断遍行随眠。及彼相应等法。集智已生灭智未生。见灭道修所断诸不善心。何等未断因。谓此俱有相应等法。何等已断因。谓欲界系遍行随眠及彼相应等法。灭智已生道智未生。见道修所断诸不善心。何等未断因。谓此俱有相应等法。何等已断因。谓欲界系遍行随眠。及彼相应等法。若见圆满。世尊弟子。未离欲界贪。修所断诸不善心。何等未断因。谓此俱有相应等法。何等已断因。谓欲界系遍行随眠。及彼相应等法。是名未断为因。及已断为因。而体未断。未断为因。及已断为因。体已断者。谓未离欲界贪。苦智已生集智未生。见苦所断诸不善心。何等已断因。谓此俱有相应等法。何等未断因。谓欲界系见集所断遍行随眠。及彼相应等法。是名未断为因。及已断为因。其体已断。诸欲界系有覆无记心。若体未断未断为因耶。曰如是。设未断为因体未断耶。或未断为因其体未断。或未断为因。及已断为因其体已断。未断为因体未断者。谓诸具缚补特伽罗。诸欲界系有覆无记心。是名未断为因其体未断。未断为因。及已断为因体已断者。谓未离欲界贪。苦智已生集智未生。诸欲界系见苦所断有覆无记心。何等已断因。谓此俱有相应等法。何等未断因。谓欲界系见集所断遍行随眠。及彼相应等法是名未断为因。及已断为因。其体已断。诸欲界系无覆无记心。若体未断未断为因耶。除诸随眠所感异熟。余欲界系无覆无记心。若体未断未断为因耶。曰如是。设未断为因体未断耶。曰如是。若诸随眠所感异熟。或体未断未断为因。或体未断已断为因。及未断为因。其体未断未断为因者。谓诸具缚补特伽罗。随眠所感诸异熟心。若未离欲界贪。苦智已生集智未生。见集灭道及修所断随眠所感诸异熟心。集智已生灭智未生。见灭道修所断随眠所感诸异熟心。灭智已生道智未生。见道修所断随眠所感诸异熟心。若见圆满世尊弟子。未离欲界贪。修所断随眠所感诸异熟心。是名体未断未断为因。其体未断已断为因及未断为因者。谓未离欲界贪。苦智已生集智未生。见苦所断随眠所感诸异熟心。何等未断因。谓此俱有相应等法。何等已断因。谓见苦所断诸随眠等。能感如是诸异熟心。集智已生。灭智未生。见苦集所断随眠所感诸异熟心。何等未断因。谓此俱有相应等法。何等已断因。谓见苦集所断诸随眠等。能感如是诸异熟心。灭智已生道智未生。见苦集灭所断随眠所感诸异熟心。何等未断因。谓此俱有相应等法。何等已断因。谓见苦集灭所断诸随眠等。能感如是诸异熟心。若见圆满世尊弟子。未离欲界贪。见所断随眠所感诸异熟心。何等未断因。谓此俱有相应等法。何等已断因。谓见所断诸随眠等。能感如是诸异熟心。是名体未断已断为因及未断为因。设未断为因体未断耶。曰如是。诸色界系善心。若体未断未断为因耶。曰如是。设未断为因体未断耶。曰如是。诸色界系有覆无记心。若体未断未断为因耶。或体未断未断为因。或体未断已断为因。及未断为因。其体未断未断为因者。谓诸具缚补特伽罗。诸色界系有覆无记心。已离欲界贪。未离色界贪。苦类智未生。诸色界系有覆无记心。是名体未断未断为因。其体未断已断为因。及未断为因者。谓未离色界贪。苦类智已生。集类智未生。诸色界系见集灭道。及修所断有覆无记心。何等未断因。谓此俱有相应等法。何等已断因。谓色界系见苦所断遍行随眠。及彼相应等法。集类智已生。灭类智未生。诸色界系见灭道修所断有覆无记心。何等未断因。谓此俱有相应等法。何等已断因。谓色界系遍行随眠。及彼相应等法。灭类智已生。道类智未生。诸色界系见道修所断有覆无记心。何等未断因。谓此俱有相应等法。何等已断因。谓色界系遍行随眠。及彼相应等法。若见圆满世尊弟子。未离色界贪。诸色界系有覆无记心。何等未断因。谓此俱有相应等法。何等已断因。谓色界系遍行随眠。及彼相应等法。是名体未断已断为因及未断为因。设未断为因其体未断耶。或未断为因其体未断。或未断为因及已断为因其体未断。或未断为因及已断为因其体已断。未断为因。其体未断者。谓诸具缚补特伽罗。诸色界系有覆无记心。已离欲界贪。未离色界贪。苦类智未生。诸色界系有覆无记心。是名未断为因其体未断。未断为因及已断为因其体未断者。谓未离色界贪。苦类智已生。集类智未生。诸色界系见集灭道。及修所断有覆无记心。何等未断因。谓此俱有相应等法。何等已断因。谓色界系见苦所断遍行随眠。及彼相应等法。集类智已生。灭类智未生。诸色界系见灭道。修所断有覆无记心。何等未断因。谓此俱有相应等法。何等已断因。谓色界系遍行随眠。及彼相应等法。灭类智已生。道类智未生。诸色界系见道修所断有覆无记心。何等未断因。谓此俱有相应等法。何等已断因。谓色界系遍行随眠及彼相应等法。若见圆满世尊弟子。未离色界贪。诸色界系修所断有覆无记心。何等未断因。谓此俱有相应等法。何等已断因。谓色界系遍行随眠。及彼相应等法。是名未断为因及已断为因其体未断。未断为因及已断为因其体已断者。谓未离色界贪。苦类智已生。集类智未生。诸色界系见苦未断有覆无记心。何等已断因。谓此俱有相应等法。何等未断因。谓色界系见集所断遍行随眠。及彼相应等法。是名未断为因及已断为因其体已断。诸色界系无覆无记心。若体未断未断为因耶。曰如是。设未断为因其体未断耶。曰如是。诸无色界系善心。若体未断未断为因耶。曰如是。设未断为因其体未断耶。曰如是。诸无色界系。有覆无记心。若体未断未断为因耶。或体未断未断为因。或体未断已断为因及未断为因。其体未断未断为因者。谓诸具缚补特伽罗。诸无色界系有覆无记心。已离欲界贪。未离色界贪。苦类智未生。诸无色界系有覆无记心。已离色界贪。苦类智未生。诸无色界系有覆无记心。是名体未断未断为因。其体未断已断为因及未断为因者。谓苦类智已生。集类智未生。诸无色界系见集灭道。及修所断有覆无记心。何等未断因。谓此俱有相应等法。何等已断因。谓无色界系见苦所断遍行随眠。及彼相应等法集类智已生。灭类智未生。诸无色界系见灭道修所断有覆无记心。何等未断因。谓此俱有相应等法。何等已断因。谓无色界系遍行随眠。及彼相应等法。灭类智已生。道类智未生。诸无色界系见道修所断有覆无记心。何等未断因。谓此俱有相应等法。何等已断因。谓无色界系遍行随眠。及彼相应等法。若见圆满世尊弟子。未离无色界贪。诸无色界系有覆无记心。何等未断因。谓此俱有相应等法。何等已断因。谓无色界系遍行随眠。及彼相应等法。是名体未断已断为因及未断为因。设未断为因。其体未断耶。或未断为因其体未断。或未断为因及已断为因其体未断。或未断为因及已断为因其体已断。未断为因其体未断者。谓诸具缚补特伽罗。诸无色界系有覆无记心。已离欲界贪未离色界贪。苦类智未生。诸无色界系有覆无记心。已离色界贪。苦类智未生。诸无色界系有覆无记心。是名未断为因其体未断。未断为因及已断为因其体未断者。谓苦类智已生。集类智未生。诸无色界系见集灭道及修所断有覆无记心。何等未断因。谓此俱有相应等法。何等已断因。谓无色界系见苦所断遍行随眠。及彼相应等法。集类智已生。灭类智未生。诸无色界系见灭道修所断有覆无记心。何等未断因。谓此俱有相应等法。何等已断因。谓无色界系遍行随眠。及彼相应等法。灭类智已生。道类智未生。诸无色界系见道修所断有覆无记心。何等未断因。谓此俱有相应等法。何等已断因。谓无色界系遍行随眠。及彼相应等法。若见圆满世尊弟子。未离无色界贪。诸无色界系修所断有覆无记心。何等未断因。谓此俱有相应等法。何等已断因。谓无色界系遍行随眠。及彼相应等法。是名未断为因及已断为因其体未断。未断为因及已断为因其体已断者。谓苦类智已生。集类智未生。诸无色界系见苦所断有覆无记心。何等已断因。谓此俱有相应等法。何等未断因。谓无色界系见集所断遍行随眠。及彼相应等法。诸无色界系无覆无记心。若体未断未断为因耶。曰如是。设未断为因其体未断耶。曰如是

说一切有部识身足论卷第四阿毗达磨识身足论卷第五

        提婆设摩阿罗汉造

        三藏法师玄奘奉　诏译

    因缘蕴第三之二

有十种心。谓欲界系善心。不善心。有覆无记心。无覆无记心。色界系善心。有覆无记心。无覆无记心。无色界系善心。有覆无记心。无覆无记心。诸欲界系善心若体已断已断为因耶。设已断为因其体已断耶。乃至无色界系无覆无记心。若体已断已断为因耶。设已断为因其体已断耶。诸欲界系善心。若体已断已断为因耶。曰如是。设已断为因其体已断耶。曰如是。诸不善心。若体已断已断为因耶。或体已断已断为因。或体已断已断为因。及未断为因。其体已断已断为因者。谓未离欲界贪。集智已生。灭智未生。见苦集所断不善心。灭智已生道智未生。见苦集灭所断不善心。若见圆满世尊弟子。未离欲界贪见所断不善心。已离欲界贪。未离色界贪诸不善心。已离色界贪。未离无色界贪诸不善心。已离无色界贪诸不善心。是名体已断已断为因。其体已断已断为因及未断为因者。谓未离欲界贪。苦智已生集智未生。见苦所断诸不善心。何等已断因。谓此俱有相应等法。何等未断因。谓欲界系见集所断遍行随眠。及彼相应等法。是名体已断已断为因及未断为因。设已断为因其体已断耶。或已断为因其体已断。或已断为因及未断为因其体已断。或已断为因及未断为因其体未断。已断为因其体已断者。谓未离欲界贪。集智已生灭智未生。见苦集所断诸不善心。灭智已生道智未生。见苦集灭所断诸不善心。若见圆满世尊弟子。未离欲界贪见所断诸不善心。已离欲界贪。未离色界贪诸不善心。已离色界贪。未离无色界贪诸不善心。已离无色界贪诸不善心。是名已断为因其体已断。已断为因及未断为因其体已断者。谓未离欲界贪。苦智已生集智未生。见苦所断诸不善心。何等已断因。谓此俱有相应等法。何等未断因。谓欲界系见集所断遍行随眠。及彼相应等法。是名已断为因及未断为因其体已断。已断为因及未断为因其体未断者。谓未离欲界贪。苦智已生集智未生。见集灭道及修所断诸不善心。何等未断因。谓此俱有相应等法。何等已断因。谓欲界系见苦所断遍行随眠。及彼相应等法。集智已生灭智未生。见灭道修所断诸不善心。何等未断因。谓此俱有相应等法。何等已断因。谓欲界系遍行随眠。及彼相应等法。灭智已生道智未生。见道修所断诸不善心。何等未断因。谓此俱有相应等法。何等已断因。谓欲界系遍行随眠。及彼相应等法。若见圆满世尊弟子。未离欲界贪。修所断诸不善心。何等未断因。谓此俱有相应等法。何等已断因。谓欲界系遍行随眠。及彼相应等法。是名已断为因及未断为因其体未断。诸欲界系有覆无记心。若体已断已断为因耶。或体已断已断为因。或体已断已断为因。及未断为因。其体已断已断为因者。谓未离欲界贪。集智已生灭智未生。诸欲界系有覆无记心。灭智已生道智未生。诸欲界系有覆无记心。若见圆满世尊弟子。未离欲界贪。诸欲界系有覆无记心。已离欲界贪。未离色界贪。诸欲界系有覆无记心。已离色界贪。未离无色界贪。诸欲界系有覆无记心。已离无色界贪。诸欲界系有覆无记心。是名其体已断已断为因。其体已断已断为因及未断为因者。谓未离欲界贪。苦智已生集智未生。诸欲界系见苦所断有覆无记心。何等已断因。谓此俱有相应等法。何等未断因。谓欲界系见集所断遍行随眠。及彼相应等法。是名体已断已断为因及未断为因。设已断为因其体已断耶。曰如是。诸欲界系无覆无记心。若体已断已断为因耶。曰如是。设已断为因其体已断耶。谓除随眠所感异熟。余欲界系无覆无记心。已断为因其体已断耶。曰如是。随眠所感诸异熟心。或已断为因其体已断。或已断为因及未断为因其体未断。已断为因其体已断者。谓已离欲界贪。未离色界贪。随眠所感诸异熟心。已离色界贪。未离无色界贪。随眠所感诸异熟心。已离无色界贪随眠所感诸异熟心。是名已断为因其体已断。已断为因及未断为因其体未断者。谓未离欲界贪。苦智已生集智未生。见苦所断随眠所感诸异熟心。何等未断因。谓此俱有相应等法。何等已断因。谓见苦所断诸随眠等。能感如是诸异熟心。集智已生灭智未生。见苦集所断随眠所感诸异熟心。何等未断因。谓此俱有相应等法。何等已断因。谓见苦集所断诸随眠等。能感如是诸异熟心。灭智已生道智未生。见苦集灭所断随眠所感诸异熟心。何等未断因。谓此俱有相应等法。何等已断因。谓见苦集灭所断诸随眠等。能感如是诸异熟心。若见圆满世尊弟子。未离欲界贪。诸见所断随眠所感诸异熟心。何等未断因。谓此俱有相应等法。何等已断因。谓见所断诸随眠等。能感如是诸异熟心。是名已断为因及未断为因其体未断。诸色界系善心。若体已断已断为因耶。曰如是。设已断为因其体已断耶。曰如是。诸色界系有覆无记心。若体已断已断为因耶。或体已断已断为因。或体已断已断为因及未断为因。其体已断已断为因者。谓未离色界贪。集类智已生灭类智未生。诸色界系见苦集所断有覆无记心灭类智已生。道类智未生。诸色界系见苦集灭所断有覆无记心。若见圆满世尊弟子。未离色界贪。诸色界系见所断有覆无记心。已离色界贪。未离无色界贪。诸色界系有覆无记心。已离无色界贪。诸色界系有覆无记心。是名体已断已断为因。其体已断已断为因及未断为因者。谓未离色界贪。苦类智已生。集类智未生。诸色界系见苦所断有覆无记心。何等已断因。谓此俱有相应等法。何等未断因。谓色界系见集所断遍行随眠。及彼相应等法。是名体已断已断为因及未断为因。设已断为因其体已断耶。或已断为因其体已断。或已断为因及未断为因其体已断。或已断为因及未断为因其体未断。已断为因其体已断者。谓未离色界贪。集类智已生。灭类智未生。诸色界系见苦集所断有覆无记心。灭类智已生。道类智未生。诸色界系见苦集灭所断有覆无记心。若见圆满世尊弟子。未离色界贪。诸色界系见所断有覆无记心。已离色界贪。未离无色界贪。诸色界系有覆无记心。已离无色界贪。诸色界系有覆无记心。是名已断为因其体已断。已断为因及未断为因其体已断者。谓未离色界贪。苦类智已生。集类智未生。诸色界系见苦所断有覆无记心。何等已断因。谓此俱有相应等法。何等未断因。谓色界系见集所断遍行随眠。及彼相应等法。是名已断为因及未断为因其体已断。已断为因及未断为因其体未断者。谓未离色界贪。苦类智已生。集类智未生。诸色界系见集灭道。及修所断有覆无记心。何等未断因。谓此俱有相应等法。何等已断因谓色界系见苦所断遍行随眠。及彼相应等法。集类智已生。灭类智未生。诸色界系见灭道修所断有覆无记心。何等未断因。谓此俱有相应等法。何等已断因。谓色界系遍行随眠。及彼相应等法。灭类智已生。道类智未生。诸色界系见道修所断有覆无记心。何等已断因。谓此俱有相应等法。何等已断因。谓色界系遍行随眠。及彼相应等法。若见圆满世尊弟子。未离色界贪。诸色界系修所断有覆无记心。何等未断因。谓此俱有相应等法。何等已断因。谓色界系遍行随眠。及彼相应等法。是名已断为因及未断为因其体未断。诸色界系无覆无记心。若体已断已断为因耶。曰如是。设已断为因其体已断耶。曰如是。诸无色界系善心。若体已断已断为因耶。曰如是。设已断为因其体已断耶。曰如是。诸无色界系有覆无记心。若体已断已断为因耶。或体已断已断为因。或体已断已断为因及未断为因。其体已断已断为因者。谓集类智已生。灭类智未生。诸无色界系见苦集所断有覆无记心。灭类智已生。道类智未生。诸无色界系见苦集灭所断无覆无记心。若见圆满世尊弟子。未离无色界贪。诸无色界系见所断有覆无记心。已离无色界贪。诸无色界系有覆无记心。是名体已断已断为因。其体已断已断为因及未断为因者。谓苦类智已生。集类智未生。诸无色界系见苦所断有覆无记心。何等已断因。谓此俱有相应等法。何等未断因。谓无色界系见集所断遍行随眠。及彼相应等法。是名体已断已断为因及未断为因。设已断为因其体已断耶。或已断为因其体已断。或已断为因及未断为因其体已断。或已断为因。及未断为因其体未断。已断为因其体已断者。谓集类智已生。灭类智未生。诸无色界系见苦集所断有覆无记心。灭类智已生。道类智未生。诸无色界系见苦集灭所断有覆无记心。若见圆满世尊弟子。未离无色界贪。诸无色界系见所断有覆无记心。已离无色界贪。诸无色界系有覆无记心。是名已断为因其体已断。已断为因及未断为因。其体已断者。谓苦类智已生。集类智未生。诸无色界系见苦所断有覆无记心。何等已断因。谓此俱有相应等法。何等未断因。谓无色界系见集所断遍行随眠。及彼相应等法。是名已断为因及未断为因其体已断。已断为因及未断为因其体未断者。谓苦类智已生。集类智未生。诸无色界系见集灭道。及修所断有覆无记心。何等未断因。谓无俱有相应等法。何等已断因。谓无色界系见苦所断遍行随眠。及彼相应等法。集类智已生。灭类智未生。诸无色界系见灭道修所断有覆无记心。何等未断因。谓此俱有相应等法。何等已断因。谓无色界系遍行随眠。及彼相应等法。灭类智已生。道类智未生。诸无色界系见道修所断有覆无记心。何等未断因。谓此俱有相应等法。何等已断因。谓无色界系遍行随眠。及彼相应等法。若见圆满世尊弟子。未离无色界贪。诸无色界系修所断有覆无记心。何等未断因。谓此俱有相应等法。何等已断因。谓无色界系遍行随眠。及彼相应等法。是名已断为因及未断为因其体未断。诸无色界系无覆无记心。若体已断已断为因耶。曰如是。设已断为因其体已断耶。曰如是

有十五心。谓欲界系有五心。色界系有五心。无色界系有五心。如是十五心。或过去或未来或现在。云何欲界系有五心。谓欲界系见苦所断心。见集灭道修所断心。如欲界系。色界系无色界系亦尔。于过去欲界系见苦所断心。所有随眠。彼于此心若所随增亦为因耶。设为因者亦随增耶。乃至于过去无色界系修所断心。所有随眠。彼于此心。若所随增亦为因耶。设为因者亦随增耶

于过去欲界系见苦所断心。所有随眠。彼于此心。若所随增亦为因耶。或能为因非所随增。或所随增不能为因。或能为因亦所随增。或不能为因亦非所随增。且能为因非所随增者。谓诸随眠在此心前。同类遍行即彼随眠。若不缘此。设缘已断。及此相应随眠已断。是所随增不能为因者。谓诸随眠在此心后。同类遍行。即彼随眠缘此未断。亦能为因亦所随增者。谓诸随眠在此心前。同类遍行即彼随眠。缘此未断。及此相应随眠未断。不能为因非所随增者。谓诸随眠在此心后。同类遍行。即彼随眠。若不缘此。设缘已断。若所余缘。若他随眠。若不同界遍行随眠。如过去欲界。系见苦所断心。未来欲界系见苦所断心亦尔。于现在欲界系见苦所断心。所有随眠。彼于此心。若所随增亦为因耶。或能为因非所随增。或所随增不能为因。或能为因亦所随增。或不能为因亦非所随增。且能为因非所随增者。谓诸随眠在此心前。同类遍行。即彼随眠。若不缘此设缘已断。是所随增不能为因者。谓诸随眠在此心后。同类遍行。即彼随眠。缘此未断。亦能为因亦所随增者。谓诸随眠在此心前。同类遍行。即彼随眠。缘此未断及此相应所有随眠。不能为因非所随增者。谓诸随眠在此心后。同类遍行。即彼随眠。若不缘此。设缘已断。若所余缘。若他随眠。若不同界遍行随眠。如见苦所断心。见集灭道及修所断染污心亦尔。于过去欲界系修所断不染污心。所有随眠。彼于此心。若所随增亦为因耶。谓除随眠所感异熟。余过去欲界系修所断不染污心。所有随眠。彼于此心若所随增即不为因。若于此心能为因者。即非随眠亦不随增。于随眠所感异熟心。或能为因非所随增。或所随增不能为因。或能为因亦所随增。或不能为因。亦非所随增。且能为因非所随增者。谓诸随眠为因。能感此心异熟。即彼随眠若不缘此。设缘已断。是所随增不能为因者。谓诸随眠不为因感此心异熟。即彼随眠缘此未断。亦能为因亦所随增者。谓诸随眠为因能感此心异熟。即彼随眠缘此未断。不能为因非所随增者。谓诸随眠不为因感此心异熟。即彼随眠若不缘此。设缘已断。若所余缘若他随眠。若不同界遍行随眠。如过去。未来现在亦尔。如欲界系。色界系无色界系亦尔。此中差别有色界系心。无色界系心。不应说有随眠异熟

有十五心。谓欲界系有五心。色界系有五心。无色界系有五心。如是十五心。或过去或未来或现在。云何欲界系有五心。谓欲界系见苦所断心。见集灭道修所断心。如欲界系。色界系无色界系亦尔。于过去欲界系见苦所断心。所有随眠。彼于此心。若不随增亦不为因耶。设不为因亦不随增耶。乃至于现在无色界系修所断心。所有随眠。彼于此心。若不随增亦不为因耶。设不为因亦不随增耶

于过去欲界系见苦所断心。所有随眠。彼于此心。若不随增亦不为因耶。或不为因非不随增。或不随增非不为因。或不为因亦不随增。或非不为因非不随增。且不为因非不随增者。谓诸随眠在此心后。同类遍行。即彼随眠缘此未断非所随增非不为因者。谓诸随眠在此心前。同类遍行。即彼随眠。若不缘此。设缘已断。及此相应随眠已断。不能为因非所随增者。谓诸随眠在此心后。同类遍行。即彼随眠。若不缘此。设缘已断。若所余缘若他随眠。若不同界遍行随眠。非不为因非不随增者。谓诸随眠在此心前。同类遍行。即彼随眠。缘此未断。及此相应随眠未断。如过去欲界系见苦所断心。未来亦尔。于现在欲界系见苦所断心。所有随眠。彼于此心若不随增。亦不为因耶。或不为因非不随增。或不随增非不为因。或不为因亦不随增。或非不为因非不随增。且不为因非不随增者。谓诸随眠在此心后。同类遍行。即彼随眠。缘此未断。非所随增非不为因者。为诸随眠在此心前。同类遍行。即彼随眠。若不缘此设缘已断。不能为因非所随眠者。谓诸随眠在此心后。同类遍行。即彼随眠。若不缘此设缘已断。若所余缘。若他随眠。若不同界遍行随眠。非不为因非不随增者。谓诸随眠在此心前。同类遍行。即彼随眠缘此未断。及此相应所有随眠。如见苦所断心。见集灭道及修所断染污心亦尔。于过去欲界系修所断不染污心。所有随眠。彼于此心。若不随增亦不为因耶。谓除随眠所感异熟。于余欲界系修所断不染污心。所有随眠。彼于此心。若不随增亦不为因。或不为因非不随增。谓诸随眠缘此未断。若诸随眠所感异熟。或不为因非不随增。或不随增非不为因。或不为因亦不随增。或非不为因非不随增。不能为因非不随增者。谓诸随眠不为因感此心异熟。即彼随眠缘此未断。非所随增非不为因者。谓诸随眠为因能感此心异熟。即彼随眠若不缘此设缘已断。不能为因不随增者。谓诸随眠不为因感此心异熟。即彼随眠。若不缘此设缘已断。若所余缘。若他随眠。若不同界遍行随眠。非不为因。非不随增者。谓诸随眠为因能感此心异熟。即彼随眠缘此未断。如过去欲界系修所断不染污心。未来现在亦尔。如欲界系心色界系心无色界系心亦尔。此中差别者。色界系心。无色界系心。不应说有随眠异熟

有六识身。谓眼识耳鼻舌身意识。如是六识身。或善或不善或有覆无记。或无覆无记。于善眼识所有结缚随眠随烦恼缠。几当言为因当言为缘。几当言为缘而不为因。于不善有覆无记无覆无记眼识。所有结缚随眠随烦恼缠。几当言为因当言为缘。几当言为缘而不为因。如眼识。耳鼻舌身意识亦尔

于善眼识。一切结缚随眠随烦恼缠。皆当言为缘而不为因。于不善眼识。有七结七缚十五随眠二十随烦恼缠。当言为因。当言为缘。所余一切当言为缘而不为因。于有覆无记眼识。有六结六缚十四随眠十六随烦恼缠。当言为因当言为缘。所余一切当言为缘而不为因。无覆无记眼识中。除随眠异熟。于余无覆无记眼识。一切结缚随眠随烦恼缠。皆当言为缘而不为因。于随眠异熟眼识。有七结七缚三十四随眠三十九随烦恼缠。当言为因。当言为缘。所余一切当言为缘而不为因。一心耶。曰不尔。于见苦所断邪见随眠异熟眼识。有二结二缚二随眠七随烦恼缠。当言为因。当言为缘。所余一切当言为缘而不为因。如见苦所断。邪见随眠异熟眼识。见取戒禁取疑贪恚慢。随眠异熟眼识亦尔。于见苦所断不共无明随眠异熟眼识。有一结一缚一随眠六随烦恼缠。当言为因。当言为缘。所余一切当言为缘而不为因。于见集所断邪见随眠异熟眼识。有二结二缚二随眠七随烦恼缠。当言为因。当言为缘。所余一切。当言为缘而不为因。如见集所断邪见随眠异熟眼识。见取疑贪恚慢随眠异熟眼识亦尔。于见集所断不共无明随眠异熟眼识。有一结一缚一随眠六随烦恼缠。当言为因。当言为缘。所余一切当言为缘而不为因。于见灭所断邪见随眠异熟眼识。有二结二缚二随眠七随烦恼缠。当言为因。当言为缘。所余一切当言为缘而不为因。如见灭所断邪见随眠异熟眼识。见取疑贪恚慢随眠异熟眼识亦尔。于见灭所断不共无明随眠异熟眼识。有一结一缚一随眠六随烦恼缠。当言为因。当言为缘。所余一切当言为缘而不为因。于见道所断邪见随眠异熟眼识。有二结二缚二随眠七随烦恼缠。当言为因。当言为缘。所余一切当言为缘而不为因。如见道所断邪见随眠异熟眼识。见取戒禁取疑贪恚慢随眠异熟眼识亦尔。于见道所断不共无明随眠异熟眼识。有一结一缚一随眠六随烦恼缠。当言为因。当言为缘。所余一切当言为缘而不为因。于修所断贪随眠异熟眼识。有二结二缚二随眠七随烦恼缠。当言为因。当言为缘。所余一切当言为缘而不为因如修所断贪随眠异熟眼识。恚慢随眠异熟眼识亦尔。于修所断不共无明随眠异熟眼识。有一结一缚一随眠六随烦恼缠。当言为因。当言为缘。所余一切当言为缘而不为因。如眼识。耳鼻舌身识亦尔。此中差别者。鼻识舌识。不应说有有覆无记。于善意识。一切结缚随眠随烦恼缠。皆当言为缘而不为因。于不善意识。有七结七缚三十六随眠四十一随烦恼缠。当言为因。当言为缘。所余一切当言为缘而不为因。一心耶。曰不尔。于见苦所断不善意识。有七结七缚十四随眠十九随烦恼缠。当言为因。当言为缘。所余一切当言为缘而不为因。于见集所断不善意识。有七结七缚十四随眠十九随烦恼缠。当言为因。当言为缘。所余一切当言为缘而不为因。于见灭所断不善意识。有七结七缚十八随眠二十三随烦恼缠。当言为因。当言为缘。所余一切当言为缘而不为因。于见道所断不善意识。有七结七缚十九随眠二十四随烦恼缠。当言为因。当言为缘。所余一切。当言为缘而不为因。于修所断不善意识。有七结七缚十五随眠二十随烦恼缠。当言为因。当言为缘。所余一切当言为缘而不为因。于有覆无记意识。有七结七缚七十六随眠八十一随烦恼缠。当言为因。当言为缘。所余一切当言为缘而不为因。一心耶。曰不尔。于欲界系有覆无记意识。有七结七缚十四随眠十九随烦恼缠。当言为因。当言为缘。所余一切当言为缘而不为因。于色界系见苦所断有覆无记意识。有六结六缚十三随眠十五随烦恼缠。当言为因。当言为缘。所余一切当言为缘而不为因。于色界系见集所断有覆无记意识。有六结六缚十三随眠十五随烦恼缠。当言为因。当言为缘。所余一切当言为缘而不为因。于色界系见灭所断有覆无记意识。有六结六缚十七随眠十九随烦恼缠。当言为因。当言为缘。所余一切当言为缘而不为因。于色界系见道所断有覆无记意识。有六结六缚十八随眠二十随烦恼缠。当言为因。当言为缘。所余一切当言为缘而不为因。于色界系修所断有覆无记意识。有六结六缚十四随眠十六随烦恼缠。当言为因。当言为缘。所余一切当言为缘而不为因。于无覆无记意识。一切结缚随眠随烦恼缠。当言为缘而不为因。有六识身。谓眼识耳鼻舌身意识。如是六识身。或善或不善。或有覆无记。或无覆无记。于善眼识所有结缚随眠随烦恼缠。当言与几相应几不相应。于不善有覆无记无覆无记眼识。所有结缚随眠随烦恼缠。当言与几相应几不相应。如眼识。耳鼻舌身意识亦尔

于善眼识一切结缚随眠随烦恼缠。当言皆不相应。于不善眼识。有三结三缚三随眠七随烦恼缠。当言相应一心耶。曰不尔。于贪相应不善眼识。有二结二缚二随眠六随烦恼缠。当言相应。如贪相应不善眼识。嗔相应不善眼识亦尔。于有覆无记眼识。有二结二缚二随眠四随烦恼缠。当言相应。于无覆无记眼识。一切结缚随眠随烦恼缠。当言皆不相应。如眼识耳鼻舌身识亦尔。此中差别者。鼻识舌识。不应说有有覆无记。于善意识。一切结缚随眠随烦恼缠。当言皆不相应。于不善意识。有七结七缚三十四随眠三十九随烦恼缠。当言相应一心耶。曰不尔。于见苦所断邪见随眠相应不善意识。有二结二缚二随眠。若觉悟位六随烦恼缠。当言相应。若睡眠位增第七眠。如见苦所断邪见随眠相应不善意识。见取戒禁取疑贪恚慢随眠相应不善意识亦尔。于见苦所断不共无明随眠相应不善意识。有一结一缚一随眠。若觉悟位五随烦恼缠。当言相应。若睡眠位增第六眠。于见集所断邪见随眠相应不善意识。有二结二缚二随眠。若觉悟位六随烦恼缠。当言相应。若睡眠位增第七眠。如见集所断邪见随眠相应不善意识。见取疑贪恚慢随眠相应不善意识亦尔。于见集所断不共无明随眠相应不善意识。有一结一缚一随眠。若觉悟位五随烦恼缠。当言相应。若睡眠位增第六眠。于见灭所断邪见随眠相应不善意识。有二结二缚二随眠。若觉悟位六随烦恼缠。当言相应。若睡眠位增第七眠。如见灭所断邪见随眠相应不善意识。见取疑贪恚慢随眠相应不善意识亦尔。于见灭所断不共无明随眠相应不善意识。有一结一缚一随眠。若觉悟位五随烦恼缠。当言相应。若睡眠位增第六眠。于见道所断邪见随眠相应不善意识。有二结二缚二随眠。若觉悟位六随烦恼缠。当言相应。若睡眠位增第七眠。如见道所断邪见随眠相应不善意识。见取戒禁取疑贪恚慢随眠相应不善意识亦尔。于见道所断不共无明随眠相应不善意识。有一结一缚一随眠。若觉悟位五随烦恼缠。当言相应。若睡眠位增第六眠。于修所断贪随眠相应不善意识。有二结二缚二随眠。若觉悟位六随烦恼缠当言相应。若睡眠位增第七眠。如修所断贪随眠相应不善意识。恚慢随眠相应。不善意识亦尔。于修所断不共无明随眠相应不善意识。有一结一缚一随眠。若觉悟位五随烦恼缠。当言相应。若睡眠位增第六眠。于有覆无记意识。有六结六缚六十五随眠六十八随烦恼缠。当言相应一心耶。曰不尔。于欲界系萨迦耶见相应有覆无记意识。有二结二缚二随眠。若觉悟位四随烦恼缠。当言相应若睡眠位增第五眠。如欲界系萨迦耶见相应有覆无记意识。边执见相应有覆无记意识亦尔。于色界系萨迦耶见随眠相应有覆无记意识。有二结二缚二随眠四随烦恼缠。当言相应。如色界系萨迦耶见随眠相应有覆无记意识。边执见见苦所断邪见见取戒禁取疑贪慢随眠相应有覆无记意识亦尔。于色界系见苦所断不共无明随眠相应有覆无记意识。有一结一缚一随眠三随烦恼缠。当言相应。于色界系见集所断邪见随眠相应有覆无记意识。有二结二缚二随眠四随烦恼缠。当言相应。如色界系见集所断邪见随眠相应有覆无记意识。见取疑贪慢随眠相应有覆无记意识亦尔。于色界系见集所断不共无明随眠相应有覆无记意识。有一结一缚一随眠三随烦恼缠。当言相应。于色界系见灭所断邪见随眠相应有覆无记意识。有二结二缚二随眠四随烦恼缠。当言相应。如色界系见灭所断邪见随眠相应有覆无记意识。见取疑贪慢随眠相应有覆无记意识亦尔。于色界系见灭所断不共无明随眠相应有覆无记意识。有一结一缚一随眠三随烦恼缠。当言相应。于色界系见道所断邪见随眠相应有覆无记意识。有二结二缚二随眠四随烦恼缠。当言相应。如色界系见道所断邪见随眠相应有覆无记意识。见取戒禁取疑贪慢随眠相应有覆无记意识亦尔。于色界系见道所断不共无明随眠相应有覆无记意识。有一结一缚一随眠三随烦恼缠。当言相应。于色界系修所断贪随眠相应有覆无记意识。有二结二缚二随眠四随烦恼缠。当言相应。如色界系修所断贪随眠相应有覆无记意识。慢随眠相应有覆无记意识亦尔。于色界系修所断不共无明随眠相应有覆无记意识。有一结一缚一随眠三随烦恼缠。当言相应。如色界系有覆无记意识。无色界系有覆无记意识亦尔于无覆无记意识。一切结缚随眠随烦恼缠。当言皆不相应

说一切有部识身足论卷第五阿毗达磨识身足论卷第六

        提婆设摩阿罗汉造

        三藏法师玄奘奉　诏译

    所缘缘蕴第四之一嗢拖南颂

  问过去等问善等　　问了青等二四心
  问十二心有二种　　问十五心有五种

有六识身。谓眼识耳鼻舌身意识。如是六识身。或过去或未来或现在。过去眼识。有缘过去非未来现在耶。有缘未来非过去现在耶。有缘现在非过去未来耶。有缘过去现在非未来耶。有缘未来现在非过去耶。有缘过去未来非现在耶。有缘过去未来现在耶。如过去眼识。未来现在眼识亦尔。如眼识耳鼻舌身意识亦尔

一切过去眼识。皆缘过去。余句不可得。未来眼识。或缘过去。或缘未来。或缘现在。一切现在眼识。皆缘现在。余句不可得。如眼识耳鼻舌身识亦尔。过去未来现在意识。皆应说言缘一切法。有六识身。谓眼识耳鼻舌身意识。如是六识身。或善或不善或无记。善眼识。有缘善非不善无记耶。有缘不善非善无记耶。有缘无记非善不善耶。有缘善不善非无记耶。有缘善无记非不善耶。有缘不善无记非善耶。有缘善不善无记耶。如善眼识。不善无记眼识亦尔。如眼识耳鼻舌身意识亦尔

善眼识或缘善。或缘不善。或缘无记。不善眼识或缘善。或缘不善。或缘无记。无记眼识或缘善。或缘不善。或缘无记。如眼识耳识意识亦尔。余三识身。若善若不善若无记。一切应言唯缘无记

有六识身。谓眼识耳鼻舌身意识。眼识唯能了别青色。不能了别此是青色。意识亦能了别青色。乃至未能了别其名。不能了别此是青色。若能了别其名。尔时亦能了别青色。亦能了别此是青色。如青色黄赤白等色亦尔。耳识唯能了别声。不能了别此是声。意识亦能了别声。乃至未能了别其名。不能了别此是声。若能了别其名。尔时亦能了别声。亦能了别此是声。鼻识唯能了别香。不能了别此是香。意识亦能了别香。乃至未能了别其名。不能了别此是香。若能了别其名。尔时亦能了别香。亦能了别此是香。舌识唯能了别味。不能了别此是味。意识亦能了别味。乃至未能了别其名。不能了别此是味。若能了别其名。尔时亦能了别味。亦能了别此是味。身识唯能了别触。不能了别此是触。意识亦能了别触。乃至未能了别其名。不能了别此是触。若能了别其名。尔时亦能了别触。亦能了别此是触。意识亦能了别诸法。谓或执为我。或执我所。或执为断或执为常。或拨无因。或拨无作。或复损减。或执为尊。或执为胜。或执为上。或执第一。或执清净。或执解脱。或执出离。若惑若疑。若犹豫。若贪若嗔。若慢若痴。若粗若苦。若障若静。若妙若离。若如病若如痈。若如箭若恼害。若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若于灭谓灭谓静谓妙谓离。若于道谓道谓如谓行谓出。若有因若有起若有是处。若有是事。若如理所引了别。若不如理所引了别。若非如理所引。非不如理所引了别

有四种心。谓欲界系心。色界系心。无色界系心。不系心。欲界系心有能了别欲界系法耶。有能了别色界系法耶。有能了别无色界系法耶。有能了别不系法耶。有能了别欲界系色界系法耶。有能了别欲界系无色界系法耶。有能了别欲界系不系法耶。有能了别色界系无色界系法耶。有能了别色界系不系法耶。有能了别无色界系不系法耶。有能了别欲界系色界系无色界系法耶。有能了别欲界系色界系不系法耶。有能了别欲界系无色界系不系法耶。有能了别色界系无色界系不系法耶。有能了别欲界系色界系无色界系不系法耶。如欲界系心乃至不系心亦尔。欲界系心有能了别欲界系法耶。曰能了别。谓或执为我。或执我所。或执为断。或执为常。或拨无因。或拨无作。或复损减。或执为尊。或执为胜。或执为上。或执第一。或执清净。或执解脱。或执出离。若惑若疑。若犹豫。若贪若嗔。若慢若痴。若粗若苦若障。若如病若如痈。若如箭若恼害。若无常若苦若空若无我。若于因谓因。谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。若不如理所引了别。若非如理所引非不如理所引了别。有能了别色界系法耶。曰能了别。谓或拨无因。或拨无作。或复损减。或执为尊。或执为胜。或执为上。或执第一。或执清净。或执解脱。或执出离。若惑若疑。若犹豫。若无智。若冥暗。若愚痴。若粗若苦若障。若静若妙若离。若如病若如痈。若如箭若恼害若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。若不如理所引了别。有能了别无色界系法耶。曰能了别。谓或拨无因。或拨无作。或复损减。或执为尊。或执为胜或执为上。或执第一。或执清净。或执解脱。或执出离。若惑若疑。若犹豫。若无智。若冥暗。若愚痴。若粗若苦若障。若静若妙若离。若如病若如痈。若如箭若恼害。若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。若不如理所引了别。有能了别不系法耶。曰能了别。谓若于灭谓灭谓静谓妙谓离。若于道谓道谓如谓行谓出。若无常若苦若空若无我。若损减灭。若损减道。若犹豫了别。若愚痴。若如理所引了别。若不如理所引了别。有能了别欲界系色界系法耶。曰能了别。谓若粗若苦若障。若如病若如痈。若如箭若恼害。若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别欲界系无色界系法耶。曰能了别。谓若粗若苦若障。若如病若如痈。若如箭若恼害。若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别欲界系不系法耶。曰能了别。谓若无常若苦若无我。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别色界系无色界系法耶。曰能了别。谓或拨无因。或拨无作。或复损减。或执为尊。或执为胜。或执为上。或执第一。或执清净。或执解脱。或执出离。若惑若疑。若犹豫。若无智。若冥暗。若愚痴。若粗若苦若障。若静若妙若离。若如病若如痈。若如箭若恼害。若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。若不如理所引了别。有能了别色界系不系法耶。曰能了别。谓若无常若空若无我。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别无色界系不系法耶。曰能了别。谓若无常若空若无我。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别欲界系色界系无色界系法耶。曰能了别。谓若粗若苦若障。若如病若如痈。若如箭若恼害。若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别欲界系色界系不系法耶。曰能了别。谓若无常若空若无我。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别欲界系无色界系不系法耶。曰能了别。谓若无常若空若无我。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别色界系无色界系不系法耶。曰能了别。谓若无常若空若无我。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别欲界系色界系无色界系不系法耶。曰能了别。谓若无常若空若无我。若有因若有起。若有是处。若有是事。若如理所引了别。色界系心。有能了别色界系法耶。曰能了别。谓或执为我。或执我所。或执为断。或执为常。或拨无因。或拨无作。或复损减。或执为尊。或执为胜。或执为上。或执第一。或执清净。或执解脱。或执出离。若惑若疑。若犹豫。若贪若慢若痴。若粗若苦若障。若静若妙若离。若如病若如痈。若如箭若恼害。若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。若不如理所引了别。若非如理所引非不如理所引了别。有能了别欲界系法耶。曰能了别。谓若粗若苦若障。若如病若如痈。若如箭若恼害。若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。若非如理所引非不如理所引了别。有能了别无色界系法耶。曰能了别。谓或拨无因。或拨无作。或复损减。或执为尊。或执为胜。或执为上。或执第一。或执清净。或执解脱。或执出离。若惑若疑。若犹豫。若无智。若冥暗。若愚痴。若粗若苦若障。若静若妙若离。若如病若如痈。若如箭若恼害。若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。若不如理所引了别。有能了别不系法耶。曰能了别。谓若于灭谓灭谓静谓妙谓离。若于道谓道谓如谓行谓出。若无常若苦若空若无我。若损减灭。若损减道。若犹豫了别。若愚痴。若有因若有起。若有是处。若有是事。若如理所引了别。若不如理所引了别。有能了别欲界系色界系法耶。曰能了别。谓若粗若苦若障。若如病若如痈。若如箭若恼害。若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别欲界系无色界系法耶。曰能了别。谓若粗若苦若障。若如病若如痈。若如箭若恼害。若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别欲界系不系法耶。曰能了别。谓若无常若空若无我。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别色界系无色界系法耶。曰能了别。谓或拨无因。或拨无作。或复损减。或执为尊。或执为胜。或执为上。或执第一。或执清净。或执解脱。或执出离。若惑若疑。若犹豫若无智。若冥暗若愚痴。若粗若苦若障。若静若妙若离。若如病若如痈。若如箭若恼害。若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。若不如理所引了别。有能了别色界系不系法耶。曰能了别。谓若无常若空若无我。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别无色界系不系法耶。曰能了别。谓若无常若空若无我。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别欲界系色界系无色界系法耶。曰能了别。谓若粗若苦若障。若如病若如痈。若如箭若恼害。若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别欲界系色界系不系法耶。曰能了别。谓若无常若空若无我。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别欲界系无色界系不系法耶。曰能了别。谓若无常若空若无我。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别色界系无色界系不系法耶。曰能了别。谓若无常若空若无我。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别欲界系色界系无色界系不系法耶。曰能了别。谓若无常若空若无我。若有因若有起。若有是处。若有是事。若如理所引了别。无色界系心。有能了别无色界系法耶。曰能了别。谓或执为我。或执我所。或执为断。或执为常。或拨无因。或拨无作。或复损减。或执为尊。或执为胜。或执为上。或执第一。或执清净。或执解脱。或执出离。若惑若疑。若犹豫。若贪若慢若痴。若粗若苦若障。若静若妙若离。若如病若如痈。若如箭若恼害。若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。若不如理所引了别。若非如理所引非不如理所引了别。有能了别不系法耶。曰能了别。谓若于灭谓灭谓静谓妙谓离。若于道谓道谓如谓行谓出。若无常若空若无我。若损减灭。若损减道。若犹豫了别。若愚痴。若有因。若有起。若有是处。若有是事。若如理所引了别。若不如理所引了别。有能了别色界系法耶。曰能了别。谓若粗若苦若障。若如理所引了别。有能了别无色界系不系法耶。曰能了别。若无常若空若无我。若有因若有起。若有是处。若有是事。若如理所引了别。如是了别。余不了别不系心。有能了别不系法耶。曰能了别。谓若于灭谓灭谓静谓妙谓离。若于道谓道谓如谓行谓出。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别欲界系法耶。曰能了别。谓若无常若苦若空若无我。若有因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别色界系法耶。曰能了别。谓若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别无色界系法耶。曰能了别。谓若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别色界系无色界系法耶。曰能了别。谓若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。如是了别。余不了别

有四种心。谓欲界系心。色界系心。无色界系心。不系心。诸欲界系心。若能了别欲界系法。此中有几随眠。是所随增。若能了别所余诸法。此中有几随眠。是所随增。乃至诸不系心。若能了别不系法。此中有几随眠。是所随增。若能了别所余诸法此中有几随眠。是所随增。诸欲界系心。若能了别欲界系法。此中有欲缠有漏缘随眠。是所随增。诸欲界系心。若能了别色界系法。此中有欲缠三部随眠。是所随增。诸欲界系心。若能了别无色界系法。此中有欲缠三部随眠。是所随增。诸欲界系心。若能了别不系法。此中有欲缠三部随眠及遍行随眠。是所随增。诸欲界系心。若能了别色界系无色界系法。此中有欲缠三部随眠。是所随增。若能了别所余诸法。此中有欲缠遍行随眠及修所断随眠。是所随增。诸色界系心。若能了别色界系法。此中有色缠有漏缘随眠。是所随增。诸色界系心。若能了别无色界系法。此中有色缠三部随眠。是所随增。诸色界系心。若能了别不系法。此中有色缠三部随眠及遍行随眠。是所随增。诸色界系心。若能了别色界系无色界系法。此中有色缠三部随眠。是所随增。若能了别所余诸法。此中有色缠遍行随眠及修所断随眠。是所随增。诸无色界系心。若能了别无色界系法。此中有无色缠有漏缘随眠。是所随增。诸无色界系心。若能了别不系法。此中有无色缠三部随眠及遍行随眠。是所随增。若能了别所余诸法。此中有无色缠遍行随眠及修所断随眠。是所随增。诸不系心。若能了别不系法。此中无有随眠。是所随增。若能了别所余诸法。此中亦无有随眠。是所随增

有十二心。谓欲界系善心。不善心。有覆无记心。无覆无记心。色界系善心。有覆无记心。无覆无记心。无色界系善心。有覆无记心。无覆无记心。学心无学心。欲界系善心。有能了别欲界系法耶。有能了别色界系法耶。有能了别无色界系法耶。有能了别不系法耶。有能了别欲界系色界系法耶。有能了别欲界系无色界系法耶。有能了别欲界系不系法耶。有能了别色界系无色界系法耶。有能了别色界系不系法耶。有能了别无色界系不系法耶。有能了别欲界系色界系无色界系法耶。有能了别欲界系色界系不系法耶。有能了别欲界系无色界系不系法耶。有能了别色界系无色界系不系法耶。有能了别欲界系色界系无色界系不系法耶。如欲界系善心。乃至无学心亦尔

欲界系善心。有能了别欲界系法耶。曰能了别。谓若粗若苦若障。若如病若如痈。若如箭若恼害。若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别色界系法耶。曰能了别。谓若粗若苦若障。若静若妙若离。若如病若如痈。若如箭若恼害。若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别无色界系法耶。曰能了别。谓若粗若苦若障。若静若妙若离。若如病若如痈。若如箭若恼害。若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别不系法耶。曰能了别。谓若于灭谓灭谓静谓妙谓离。若于道谓道谓如谓行谓出。若无常若空若无我。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别欲界系色界系法耶。曰能了别。谓若粗若苦若障。若如病若如痈。若如箭若恼害。若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别欲界系无色界系法耶。曰能了别。谓若粗若苦若障。若如病若如痈。若如箭若恼害。若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起若有是处。若有是事。若如理所引了别。有能了别欲界系不系法耶。曰能了别。若无常若空若无我。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别色界系无色界系法耶。曰能了别。谓若粗若苦若障。若静若妙若离。若如病若如痈。若如箭若恼害。若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别色界系不系法耶。曰能了别。谓若无常若空若无我。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别无色界系不系法耶。曰能了别。谓若无常若空若无我。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别。欲界系色界系无色界系法耶。曰能了别。谓若粗若苦若障。若如病若如痈。若如箭若恼害。若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别欲界系色界系不系法耶。曰能了别。谓若无常若空若无我。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别欲界系无色界系不系法耶。曰能了别。谓若无常若空若无我。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别色界系无色界系不系法耶。曰能了别。谓若无常若空若无我。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别欲界系色界系无色界系不系法耶。曰能了别。谓若无常若空若无我。若有因若有起。若有是处。若有是事。若如理所引了别。诸不善心。有能了别欲界系法耶。曰能了别。谓或拨无因。或拨无作。或复损减。或执为尊。或执为胜。或执为上。或执第一。或执清净。或执解脱。或执出离。若惑若疑。若犹豫。若贪若嗔若慢若痴若不如理所引了别。有能了别色界系法耶。曰能了别。谓或拨无因。或拨无作。或复损减。或执为尊。或执为胜。或执为上。或执第一。或执清净。或执解脱。或执出离。若惑若疑。若犹豫若无智。若冥暗若愚痴。若不如理所引了别。有能了别无色界系法耶。曰能了别。谓或拨无因。或拨无作。或复损减。或执为尊。或执为胜。或执为上。或执第一。或执清净。或执解脱。或执出离。若惑若疑。若犹豫若无智。若冥暗若愚痴。若不如理所引了别。有能了别不系法耶。曰能了别。谓若损减灭。若损减道。若犹预了别。若愚痴。若不如理所引了别。有能了别色界系无色界系法耶。曰能了别。谓或拨无因。或拨无作。或复损减。或执为尊。或执为胜。或执为上。或执第一。或执清净。或执解脱。或执出离。若惑若疑。若犹豫若无智。若冥暗若愚痴。若不如理所引了别。如是了别。余不了别。诸欲界系有覆无记心。有能了别欲界系法耶。曰能了别。谓或执为我。或执我所。或执为断。或执为常。若不如理所引了别。如是了别。余不了别。诸欲界系无覆无记心。有能了别欲界系法耶。曰能了别谓非如理所引非不如理所引了别如是了别余不了别

说一切有部识身足论卷第六阿毗达磨识身足论卷第七

        提婆设摩阿罗汉造

        三藏法师玄奘奉　诏译

    所缘缘蕴第四之二

诸色界系善心。有能了别色界系法耶。曰能了别。谓若粗若苦若障。若静若妙若离。若如病若如痈。若如箭若恼害。若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别欲界系法耶。曰能了别。谓若粗若苦若障。若如病若如痈。若如箭若恼害。若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别无色界系法耶。曰能了别。谓若粗若苦若障。若静若妙若离。若如病若如痈。若如箭若恼害。若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别不系法耶。曰能了别。谓若于灭谓灭谓静谓妙谓离。若于道谓道谓如谓行谓出。若无常若苦若空若无我。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别。欲界系色界系法耶。曰能了别。谓若粗若苦若障。若如病若如痈。若如箭若恼害。若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别欲界系无色界系法耶。曰能了别。谓若粗若苦若障。若如病若如痈。若如箭若恼害。若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别欲界系不系法耶。曰能了别。谓若无常若苦若空若无我。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别色界系无色界系法耶。曰能了别。谓若粗若苦若障。若静若妙若离。若如病若如痈。若如箭若恼害。若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别色界系不系法耶。曰能了别。谓若无常若苦若空若无我。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别无色界系不系法耶。曰能了别。谓若无常若苦若空若无我。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别欲界系色界系无色界系法耶。曰能了别。谓若粗若苦若障。若如病若如痈。若如箭若恼害。若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别欲界系色界系不系法耶。曰能了别。谓若无常若苦若空若无我。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别欲界系无色界系不系法耶。曰能了别。谓若无常若苦若空若无我。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别色界系无色界系不系法耶。曰能了别。谓若无常若苦若空若无我。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别欲界系色界系无色界系不系法耶。曰能了别。谓若无常若苦若空若无我。若有因若有起。若有是处。若有是事。若如理所引了别

诸色界系有覆无记心。有能了别色界系法耶。曰能了别。谓或执为我。或执我所。或执为断。或执为常。或拨无因。或拨无作。或复损减。或执为尊。或执为胜。或执为上。或执第一。或执清净。或执解脱。或执出离。若惑若疑。若犹豫。若贪若慢若痴。若不如理所引了别。有能了别无色界系法耶。曰能了别。谓或拨无因。或拨无作。或复损减。或执为尊。或执为胜。或执为上。或执第一。或执清净。或执解脱。或执出离。若惑若疑。若犹豫若无智。若冥闇若愚痴。若不如理所引了别。有能了别不系法耶。曰能了别。谓若损减灭。若损减道。若犹豫了别。若愚痴。若不如理所引了别。有能了别色界系无色界系法耶。曰能了别。谓或拨无因。或拨无作。或复损减。或执为尊。或执为胜。或执为上。或执第一。或执清净。或执解脱。或执出离。若惑若疑。若犹豫若无智。若冥闇若愚痴。若不如理所引了别。如是了别。余不了别。诸色界系无覆无记心。有能了别色界系法耶。曰能了别。谓非如理所引非不如理所引了别。有能了别欲界系法耶。曰能了别。谓非如理所引非不如理所引了别。如是了别。余不了别

诸无色界系善心。有能了别无色界系法耶。曰能了别。谓若粗若苦若障。若静若妙若离。若如病若如痈。若如箭若恼害。若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别色界系法耶。曰能了别。谓若粗若苦若障。若如理所引了别。有能了别不系法耶。曰能了别。谓若于灭谓灭谓静谓妙谓离。若于道谓道谓如谓行谓出。若无常若苦若空若无我。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别无色界系不系法耶。曰能了别。谓若无常若苦若空若无我。若有因若有起。若有是处。若有是事。若如理所引了别。如是了别。余不了别

诸无色界系有覆无记心。有能了别无色界系法耶。曰能了别。谓或执为我。或执我所。或执为断。或执为常。或拨无因。或拨无作。或复损减。或执为尊。或执为胜。或执为上。或执第一。或执清净。或执解脱。或执出离。若惑若疑。若犹豫。若贪若慢若痴。若不如理所引了别。有能了别不系法耶。曰能了别。谓若损减灭。若损减道。若犹豫了别。若愚痴。若不如理所引了别。如是了别。余不了别

诸无色界系无覆无记心。有能了别无色界系法耶。曰能了别。谓非如理所引非不如理所引了别。如是了别。余不了别

诸学心有能了别不系法耶。曰能了别。谓若于灭谓灭谓静谓妙谓离。若于道谓道谓如谓行谓出。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别欲界系法耶。曰能了别。谓若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处若有是事。若如理所引了别。有能了别色界系法耶。曰能了别。谓若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别无色界系法耶。曰能了别。谓若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。有能了别色界系无色界系法耶。曰能了别。谓若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。如是了别。余不了别。如学心无学心亦尔

有十二心。谓欲界系善心。不善心。有覆无记心。无覆无记心。色界系善心。有覆无记心。无覆无记心。无色界系善心。有覆无记心。无覆无记心。学心。无学心。诸欲界系善心。若能了别欲界系法。此中有几随眠。是所随增。若能了别所余诸法。此中有几随眠。是所随增。乃至诸无学心。若能了别不系法。此中有几随眠。是所随增。若能了别所余诸法。此中有几随眠。是所随增

诸欲界系善心。若能了别欲界系法。此中有欲缠遍行随眠及修所断随眠。是所随增。若能了别所余诸法。此中亦有欲缠遍行随眠及修所断随眠。是所随增。诸不善心。若能了别欲界系法。此中有欲缠有漏缘随眠是所随增。若能了别色界系法。此中有欲缠二部随眠。是所随增。若能了别无色界系法。此中有欲缠二部随眠。是所随增。若能了别不系法。此中有欲缠二部随眠及遍行随眠。是所随增。若能了别色界系无色界系法。此中有欲缠二部随眠。是所随增。诸欲界系有覆无记心。唯能了别欲界系法。此中有欲缠见苦所断一切随眠及见集所断遍行随眠。是所随增。诸欲界系无覆无记心。唯能了别欲界系法。此中有欲缠遍行随眠及修所断随眠。是所随增。诸色界系善心。若能了别色界系法。此中有色缠遍行随眠及修所断随眠。是所随增。若能了别所余诸法。此中有色缠遍行随眠及修所断随眠。是所随增。诸色界系有覆无记心。若能了别色界系法。此中有色缠有漏缘随眠。是所随增。若能了别无色界系法。此中有色缠二部随眠。是所随增。若能了别不系法。此中有色缠二部随眠及遍行随眠。是所随增。若能了别色界系无色界系法。此中有色缠二部随眠。是所随增。诸色界系无覆无记心。若能了别色界系法。此中有色缠遍行随眠及修所断。随眠是所随增。若能了别所余诸法。此中有色缠遍行随眠及修所断随眠。是所随增。诸无色界系善心。若能了别无色界系法。此中有无色缠遍行随眠及修所断随眠。是所随增。若能了别所余诸法。此中有无色缠遍行随眠及修所断随眠。是所随增。诸无色界系有覆无记心。若能了别无色界系法。此中有无色缠有漏缘随眠。是所随增。若能了别不系法。此中有无色缠二部随眠及遍行随眠。是所随增。诸无色界系无覆无记心。唯能了别无色界系法。此中有无色缠遍行随眠及修所断随眠。是所随增。诸学心若能了别不系法。此中无有随眠。是所随增。若能了别所余诸法。此中亦无有随眠。是所随增。如学心无学心亦尔

有十种心。谓欲界系善心。不善心。有覆无记心。无覆无记心。色界系善心。有覆无记心。无覆无记心。无色界系善心。有覆无记心。无覆无记心。诸欲界系善心。若体未断所缘未断耶。设所缘未断体未断耶。乃至诸无色界系无覆无记心。若体未断所缘未断耶。设所缘未断体未断耶

诸欲界善心。若体未断所缘未断耶。或体未断所缘未断。或体未断所缘已断。或体未断所缘已断及所缘未断。或体未断不可分别此心所缘已断未断。其体未断所缘未断者。谓诸具缚补特伽罗。诸欲界系善心。缘欲界系。缘色界系。缘无色界系。缘欲界系色界系。缘欲界系无色界系。缘色界系无色界系。缘欲界系色界系。无色界系。若未离欲界贪。苦智已生集智未生。诸欲界系善心。缘见集灭道及修所断。集智已生灭智未生诸欲界系善心。缘见灭道及修所断。灭智已生道智未生。诸欲界系善心。缘见道及修所断。若见圆满世尊弟子。未离欲界贪。诸欲界系善心。缘修所断。是名体未断所缘未断。其体未断所缘已断者。谓未离欲界贪。苦智已生集智未生。诸欲界系善心。缘见苦所断。集智已生灭智未生。诸欲界系善心。缘见苦集所断。灭智已生道智未生。诸欲界系善心。缘见苦集灭所断。苦见圆满世尊弟子。未离欲界贪。诸欲界系善心缘见所缘。是名体未断所缘已断。其体未断所缘已断及所缘未断者。谓未离欲界贪。苦智已生集智未生。诸欲界系善心。缘见苦集灭道及修所断。集智已生灭智未生。诸欲界系善心。缘见苦集灭道及修所断。灭智已生道智未生。诸欲界系善心。缘见苦集灭道及修所断。若见圆满世尊弟子。未离欲界贪。诸欲界系善心。缘见修所断。是名体未断所缘已断及所缘未断。其体未断不可分别此心所缘已断未断者。谓诸具缚补特伽罗。诸欲界系善心。缘非所断。若未离欲界贪。苦智已生集智未生。诸欲界系善心。缘非所断。集智已生灭智未生。诸欲界系善心。缘非所断。灭智已生道智未生。诸欲界系善心。缘非所断。若见圆满世尊弟子。未离欲界贪。诸欲界系善心。缘非所断。是名体未断不可分别此心所缘已断未断。设所缘未断其体未断耶。或所缘未断其体未断。或所缘未断其体已断。或所缘未断及所缘已断其体未断。或所缘未断及所缘已断。其体已断。所缘未断其体未断者。谓诸具缚补特伽罗。诸欲界系善心。缘欲界系。缘色界系。缘无色界系。缘欲界系色界系。缘欲界系无色界系。缘色界系无色界系。缘欲界系色界系无色界系。未离欲界贪。苦智已生集智未生。诸欲界系善心。缘见集灭道及修所断。集智已生灭智未生。诸欲界系善心。缘见灭道及修所断。灭智已生道智未生。诸欲界系善心。缘见道及修所断。若见圆满世尊弟子。未离欲界贪。诸欲界系善心。缘修所断。是名所缘未断其体未断。所缘未断其体已断者。谓已离欲界贪。未离色界贪苦类智未生。诸欲界系善心。缘色界系。缘无色界系。缘色界系无色界系。已离色界贪。苦类智未生。诸欲界系善心。缘无色界系。是名所缘未断其体已断。所缘未断及所缘已断其体未断者。谓未离欲界贪。苦智已生集智未生。诸欲界系善心。缘见苦集灭道及修所断。集智已生灭智未生。诸欲界系善心。缘见苦集灭道及修所断。灭智已生道智未生。诸欲界系善心。缘见苦集灭道及修所断。若见圆满世尊弟子。未离欲界贪。诸欲界系善心。缘见修所断。是名所缘未断及所缘。已断其体未断。所缘未断及所缘已断其体已断者。谓已离欲界贪。未离色界贪。诸欲界系善心。缘欲界系色界系。缘欲界系无色界系。缘欲界系色界系无色界系。已离色界贪。未离无色界贪。诸欲界系善心。缘欲界系无色界系。缘色界系无色界系。缘欲界系色界系无色界系。是名所缘未断及所缘已断其体已断。诸不善心。若体未断所缘未断耶。或体未断所缘未断。或体未断所缘已断。或体未断所缘已断。及所缘未断。或体未断不可分别此心所缘已断未断。其体未断所缘未断者。谓诸具缚补特伽罗。诸不善心。缘欲界系。缘色界系。缘无色界系。缘色界系无色界系。未离欲界贪。苦智已生集智未生。诸见集所断不善心。缘见集灭道及修所断。诸见集所断不善心。缘见集所断。诸见灭所断不善心。缘见灭所断。诸见道所断不善心。缘见道所断。诸修所断不善心。缘修所断。集智已生灭智未生。诸见灭所断不善心。缘见灭所断。诸见道所断不善心。缘见道所断。诸修所断不善心。缘修所断。灭智已生道智未生。诸见道所断不善心。缘见道所断。诸修所断不善心。缘修所断。若见圆满世尊弟子。未离欲界贪。诸修所断不善心。缘修所断。是名体未断所缘未断。其体未断所缘已断者。谓未离欲界贪。苦智已生集智未生。诸见集所断不善心。缘见苦所断。是名体未断所缘已断。其体未断所缘已断及所缘未断者。谓未离欲界贪。苦智已生集智未生。诸见集所断不善心。缘见苦集灭道及修所断。是名体未断所缘已断及所缘未断。其体未断不可分别此心所缘已断未断者。谓诸具缚补特伽罗。诸不善心。缘非所断。未离欲界贪。苦智已生集智未生。诸不善心。缘非所断。集智已生灭智未生。诸见灭道所断不善心。缘非所断。灭智已生道智未生。诸见道所断不善心。缘非所断。是名体未断不可分别此心所缘已断未断。设所缘未断其体未断耶。或所缘未断其体未断。或所缘未断其体已断。或所缘未断及所缘已断其体未断。或所缘未断及所缘已断其体已断。所缘未断其体未断者。谓诸具缚补特伽罗。诸不善心。缘欲界系。缘色界系。缘无色界系。缘色界系无色界系。未离欲界贪。苦智已生集智未生。诸见集所断不善心。缘见集灭道及修所断。见集所断不善心。缘见集所断。见灭所断不善心。缘见灭所断。见道所断不善心。缘见道所断。修所断不善心。缘修所断。集智已生灭智未生。诸见灭所断不善心。缘见灭所断。见道所断不善心。缘见道所断。修所断不善心。缘修所断。灭智已生道智未生。诸见道所断不善心。缘见道所断。诸修所断不善心。缘修所断。若见圆满世尊弟子。未离欲界贪。诸修所断不善心。缘修所断。是名所缘未断其体未断。所缘未断其体已断者。谓未离欲界贪。苦智已生集智未生诸见苦所断不善心。缘见集灭道及修所断。集智已生灭智未生。诸见苦集所断不善心。缘见灭道及修所断。灭智已生道智未生。诸见苦集所断不善心。缘见道及修所断。若见圆满世尊弟子。未离欲界贪。诸见所断不善心。缘修所断。已离欲界贪。未离色界贪。苦类智未生。诸不善心。缘色界系。缘无色界系。缘色界系无色界系。已离色界贪。苦类智未生。诸不善心。缘无色界系。是名所缘未断其体已断。所缘未断及所缘已断其体未断者。谓未离欲界贪。苦智已生集智未生。诸见集所断不善心。缘见苦集灭道及修所断。是名所缘未断及所缘已断其体未断。所缘未断及所缘已断其体已断者。谓未离欲界贪。苦智已生集智未生。诸见苦所断不善心。缘见苦集灭道及修所断。集智已生灭智未生。诸见苦集所断不善心。缘见苦集灭道及修所断。灭智已生道智未生。诸见苦集所断不善心。缘见苦集灭道及修所断。若见圆满世尊弟子。未离欲界贪。诸见所断不善心。缘见修所断。已离色界贪。未离无色界贪。诸不善心。缘色界系无色界系。是名所缘未断及所缘已断其体已断。诸欲界系有覆无记心。若体未断所缘未断耶。曰如是。设所缘未断其体未断耶。或所缘未断其体未断。或所缘未断其体已断。或所缘未断及所缘已断其体已断。所缘未断其体未断者。谓诸具缚补特伽罗。诸欲界系有覆无记心。缘欲界系。是名所缘未断其体未断。所缘未断其体已断者。谓未离欲界贪。苦智已生集智未生。诸欲界系见苦所断有覆无记心。缘见集灭道及修所断。集智已生灭智未生。诸欲界系见苦所断有覆无记心。缘见灭道及修所断。灭智已生道智未生。诸欲界系见苦所断有覆无记心。缘见道及修所断。若见圆满世尊弟子。未离欲界贪。诸欲界系有覆无记心。缘修所断。是名所缘未断其体已断。所缘未断及所缘已断其体已断者。谓未离欲界贪。苦智已生集智未生。诸欲界系有覆无记心。缘见苦集灭道及修所断。集智已生灭智未生。诸欲界系有覆无记心。缘见苦集灭道及修所断。灭智已生道智未生。诸欲界系有覆无记心。缘见苦集灭道及修所断。若见圆满世尊弟子。未离欲界贪。诸欲界系有覆无记心。缘见修所断。是名所缘未断及所缘已断其体已断。诸欲界系无覆无记心。若体未断所缘未断耶。或体未断所缘未断。或体未断所缘已断。或体未断所缘已断及所缘未断。其体未断所缘未断者。谓诸具缚补特伽罗。诸欲界系无覆无记心。缘欲界系。未离欲界贪。苦智已生集智未生。诸欲界系无覆无记心。缘见集灭道及修所断。集智已生灭智未生。诸欲界系无覆无记心。缘见灭道及修所断。灭智已生道智未生。诸欲界系无覆无记心。缘见道及修所断。若见圆满世尊弟子。未离欲界贪。诸欲界系无覆无记心。缘修所断。是名体未断所缘未断。其体未断所缘已断者。谓未离欲界贪。苦智已生集智未生。诸欲界系无覆无记心。缘见苦所断。集智已生灭智未生。诸欲界系无覆无记心。缘见苦集所断。灭智已生道智未生。诸欲界系无覆无记心。缘见苦集灭智所断。若见圆满世尊弟子。未离欲界贪。诸欲界系无覆无记心。缘见所断。是名体未断所缘已断。其体未断所缘已断及所缘未断者。谓未离欲界贪。苦智已生集智未生。诸欲界系无覆无记心。缘见苦集灭道及修所断。集智已生灭智未生。诸欲界系无覆无记心。缘见苦集灭道及修所断。灭智已生道智未生。诸欲界系无覆无记心。缘见苦集灭道及修所断。若见圆满世尊弟子。未离欲界贪。诸欲界系无覆无记心。缘见修所断。是名体未断所缘已断及所缘未断。设所缘未断其体未断耶。曰如是

说一切有部识身足论卷第七阿毗达磨识身足论卷第八

        提婆设摩阿罗汉造

        三藏法师玄奘奉　诏译

    所缘缘蕴第四之三

诸色界系善心。若体未断所缘未断耶。或体未断所缘未断。或体未断所缘已断。或体未断所缘已断及所缘未断。或体未断不可分别此心所缘已断未断。其体未断所缘未断者。谓诸具缚补特伽罗。诸色界系善心。缘欲界系。缘色界系。缘无色界系。缘欲界系色界系。缘欲界系无色界系。缘色界系无色界系。缘欲界系色界系无色界系。已离欲界贪。未离色界贪。苦类智未生。诸色界系善心。缘色界系。缘无色界系。缘色界系无色界系。未离色界贪。苦类智已生。集类智未生。诸色界系善心。缘见集灭道及修所断。集类智已生。灭类智未生。诸色界系善心。缘见灭道及修所断。灭类智已生。道类智未生。诸色界系善心。缘见道及修所断。若见圆满世尊弟子。未离色界贪。诸色界系善心。缘修所断。是名体未断所缘未断。其体未断所缘已断者。谓已离欲界贪。未离色界贪。苦类智未生。诸色界系善心。缘欲界系。未离色界贪。苦类智已生。集类智未生。诸色界系善心。缘见苦所断。集类智已生。灭类智未生。诸色界系善心。缘见苦集所断。灭类智已生。道类智未生。诸色界系善心。缘见苦集灭所断。若见圆满世尊弟子。未离色界贪。诸色界系善心。缘见所断。是名体未断所缘已断。其体未断所缘已断及所缘未断者。谓已离欲界贪。未离色界贪。诸色界系善心。缘欲界系色界系。缘欲界系无色界系。缘欲界系色界系无色界系。未离色界贪。苦类智已生。集类智未生。诸色界系善心。缘见苦集灭道及修所断。集类智已生。灭类智未生。诸色界系善心。缘见苦集灭道及修所断。灭类智已生。道类智未生。诸色界系善心。缘见苦集灭道及修所断。若见圆满世尊弟子。未离色界贪。诸色界系善心。缘见修所断。是名体未断所缘已断及所缘未断。其体未断不可分别此心所缘已断未断者。谓诸具缚补特伽罗。诸色界系善心。缘非所断。已离欲界贪。未离色界贪。苦类智未生。诸色界系善心。缘非所断。未离色界贪。苦类智已生。集类智未生。诸色界系善心。缘非所断。集类智已生。灭类智未生。诸色界系善心。缘非所断。灭类智已生。道类智未生。诸色界系善心。缘非所断。若见圆满世尊弟子。未离色界贪。诸色界系善心。缘非所断。是名体未断不可分别此心所缘已断未断。设所缘未断其体未断耶。或所缘未断其体未断。或所缘未断其体已断。或所缘未断及所缘已断其体未断。或所缘未断及所缘已断其体已断。所缘未断其体未断者。谓诸具缚补特伽罗。诸色界系善心。缘欲界系。缘色界系。缘无色界系。缘欲界系色界系。缘欲界系无色界系。缘色界系无色界系。缘欲界系色界系无色界系。已离欲界贪。未离色界贪。苦类智未生。诸色界系善心。缘色界系。缘无色界系。缘色界系无色界系。未离色界贪。苦类智已生。集类智未生。诸色界系善心。缘见集灭道及修所断。集类智已生。灭类智未生。诸色界系善心。缘见灭道及修所断。灭类智已生。道类智未生。诸色界系善心。缘见道及修所断。若见圆满世尊弟子。未离色界贪。诸色界系善心。缘修所断。是名所缘未断其体未断。所缘未断其体已断者。谓已离色界贪。苦类智未生。诸色界系善心。缘无色界系。是名所缘未断其体已断。所缘未断。及所缘已断其体未断者。谓已离欲界贪。未离色界贪。诸色界系善心。缘欲界系色界系。缘欲界系无色界系。缘欲界系色界系无色界系。未离色界贪。苦类智已生。集类智未生。诸色界系善心。缘见苦集灭道及修所断。集类智已生。灭类智未生。诸色界系善心。缘见苦集灭道及修所断。灭类智已生。道类智未生。诸色界系善心。缘见苦集灭道及修所断。若见圆满世尊弟子。未离色界贪。诸色界系善心。缘见修所断。是名所缘未断及所缘已断其体未断。所缘未断及所缘已断其体已断者。谓已离色界贪。未离无色界贪。诸色界系善心。缘欲界系无色界系。缘色界系无色界系。缘欲界系色界系无色界系。是名所缘未断及所缘已断其体已断。诸色界系有覆无记心。若体未断所缘未断耶。或体未断所缘未断。或体未断所缘已断。或体未断所缘已断及所缘未断。或体未断不可分别此心所缘已断未断。其体未断所缘未断者。谓诸具缚补特伽罗。诸色界系有覆无记心。缘色界系。缘无色界系。缘色界系无色界系。已离欲界贪。未离色界贪。苦类智未生。诸色界系有覆无记心。缘色界系。缘无色界系。缘色界系无色界系。未离色界贪。苦类智已生。集类智未生。诸色界系见集所断有覆无记心。缘见集灭道及修所断。见集所断有覆无记心。缘见集所断。见灭所断有覆无记心。缘见灭所断见道所断。有覆无记心。缘见道所断。修所断有覆无记心。缘修所断。集类智已生。灭类智未生。诸色界系见灭所断有覆无记心。缘见灭所断。见道所断有覆无记心。缘见道所断。修所断有覆无记心。缘修所断。灭类智已生。道类智未生。诸色界系见道所断有覆无记心。缘见道所断。修所断有覆无记心。缘修所断。若见圆满世尊弟子。未离色界贪。诸色界系修所断有覆无记心。缘修所断。是名体未断所缘未断。其体未断所缘已断者。谓未离色界贪。苦类智已生。集类智未生。诸色界系见集所断有覆无记心。缘见苦所断。是名体未断所缘已断。其体未断。所缘已断及所缘未断者。谓未离色界贪。苦类智已生。集类智未生。诸色界系见集所断有覆无记心。缘见苦集灭道及修所断。是名体未断所缘已断。及所缘未断。其体未断不可分别此心所缘已断未断者。谓诸具缚补特伽罗。诸色界系有覆无记心。缘非所断。已离欲界贪。未离色界贪。苦类智未生。诸色界系有覆无记心。缘非所断。未离色界贪。苦类智已生。集类智未生。诸色界系有覆无记心。缘非所断。集类智已生。灭类智未生。诸色界系见灭道所断有覆无记心。缘非所断。灭类智已生。道类智未生。诸色界系见道所断有覆无记心。缘非所断。是名体未断不可分别此心所缘已断未断。设所缘未断其体未断耶。或所缘未断其体未断。或所缘未断其体已断。或所缘未断及所缘已断其体未断。或所缘未断及所缘已断其体已断。所缘未断其体未断者。谓诸具缚补特伽罗。诸色界系有覆无记心。缘色界系。缘无色界系。缘色界系无色界系。已离欲界贪。未离色界贪。苦类智未生。诸色界系有覆无记心。缘色界系。缘无色界系。缘色界系无色界系。未离色界贪。苦类智已生。集类智未生。诸色界系见集所断有覆无记心。缘见集灭道及修所断。见集所断有覆无记心。缘见集所断。见灭所断有覆无记心。缘见灭所断。见道所断有覆无记心。缘见道所断。修所断有覆无记心。缘修所断。集类智已生。灭类智未生。诸色界系见灭所断有覆无记心。缘见灭所断。见道所断有覆无记心。缘见道所断。修所断有覆无记心。缘修所断。灭类智已生。道类智未生。诸色界系见道所断有覆无记心。缘见道所断。修所断有覆无记心。缘修所断。若见圆满世尊弟子。未离色界贪。诸色界系修所断有覆无记心。缘修所断。是名所缘未断其体未断。所缘未断其体已断者。谓未离色界贪。苦类智已生。集类智未生。诸色界系见苦所断有覆无记心。缘见集灭道及修所断。集类智已生。灭类智未生。诸色界系见苦集所断有覆无记心。缘见灭道及修所断。灭类智已生。道类智未生。诸色界系见苦集所断有覆无记心。缘见道及修所断。若见圆满世尊弟子。未离色界贪。诸色界系见所断有覆无记心。缘修所断。已离色界贪。未离无色界贪。苦类智未生。诸色界系有覆无记心。缘无色界系。是名所缘未断其体已断。所缘未断及所缘已断其体未断者。谓未离色界贪。苦类智已生。集类智未生。诸色界系见集所断有覆无记心。缘见苦集灭道及修所断。是名所缘未断及所缘已断其体未断。所缘未断及所缘已断其体已断者。谓未离色界贪。苦类智已生。集类智未生。诸色界系见苦所断有覆无记心。缘见苦集灭道及修所断。集类智已生。灭类智未生。诸色界系见苦集所断有覆无记心。缘见苦集灭道及修所断。灭类智已生。道类智未生。诸色界系见苦集所断有覆无记心。缘见苦集灭道及修所断。若见圆满世尊弟子。未离色界贪。诸色界系见所断有覆无记心。缘见修所断。已离色界贪。未离无色界贪。诸色界系有覆无记心。缘色界系无色界系。是名所缘未断及所缘已断其体已断。诸色界系无覆无记心。若体未断所缘未断耶。或体未断所缘未断。或体未断所缘已断。或体未断所缘已断及所缘未断。其体未断所缘未断者。谓诸具缚补特伽罗。诸色界系无覆无记心。缘欲界系缘色界系。已离欲界贪。未离色界贪。苦类智未生。诸色界系无覆无记心。缘色界系。未离色界贪。苦类智已生。集类智未生。诸色界系无覆无记心。缘见集灭道及修所断。集类智已生。灭类智未生。诸色界系无覆无记心。缘见灭道及修所断。灭类智已生。道类智未生。诸色界系无覆无记心。缘见道及修所断。若见圆满世尊弟子。未离色界贪。诸色界系无覆无记心。缘修所断。是名体未断所缘未断。其体未断所缘已断者。谓已离欲界贪。未离色界贪。苦类智未生。诸色界系无覆无记心。缘欲界系。未离色界贪。苦类智已生。集类智未生。诸色界系无覆无记心。缘见苦所断。集类智已生。灭类智未生。诸色界系无覆无记心。缘见苦集所断。灭类智已生。道类智未生。诸色界系无覆无记心。缘见苦集灭所断。若见圆满世尊弟子。未离色界贪。诸色界系无覆无记心。缘见所断。是名体未断所缘已断。其体未断所缘已断及所缘未断者。谓未离色界贪。苦类智已生。集类智未生。诸色界系无覆无记心。缘见苦集灭道及修所断。集类智已生。灭类智未生。诸色界系无覆无记心。缘见苦集灭道及修所断。灭类智已生。道类智未生。诸色界系无覆无记心。缘见苦集灭道及修所断。若见圆满世尊弟子。未离色界贪。诸色界系无覆无记心。缘见修所断。是名体未断所缘已断及所缘未断。设所缘未断其体未断耶。曰如是

诸无色界系善心。若体未断所缘未断耶。或体未断所缘未断。或体未断所缘已断。或体未断所缘已断及所缘未断。或体未断不可分别此心所缘已断未断。其体未断所缘未断者。谓诸具缚补特伽罗。诸无色界系善心。缘色界系。缘无色界系。已离欲界贪。未离色界贪。苦类智未生。诸无色界系善心。缘色界系。缘无色界系。已离色界贪。苦类智未生诸无色界系善心。缘无色界系。苦类智已生。集类智未生。诸无色系善心缘见集灭道及修所断。集类智已生。灭类智未生。诸无色界系善心。缘见灭道及修所断。灭类智已生。道类智未生。诸无色界系善心。缘见道及修所断。若见圆满世尊弟子。未离无色界贪。诸无色界系善心。缘修所断。是名体未断所缘未断。其体未断所缘已断者。谓已离色界贪。苦类智未生。诸无色界系善心。缘色界系。苦类智已生。集类智未生。诸无色界系善心。缘见苦所断。集类智已生。灭类智未生。诸无色界系善心。缘见苦集所断。灭类智已生。道类智未生。诸无色界系善心。缘见苦集灭所断。若见圆满世尊弟子。未离无色界贪。诸无色界系善心。缘见所断。是名体未断所缘未断。其体未断所缘已断及所缘未断者。谓苦类智已生。集类智未生。诸无色界系善心。缘见苦集灭道及修所断。集类智已生。灭类智未生。诸无色界系善心。缘见苦集灭道及修所断。灭类智已生。道类智未生。诸无色界系善心。缘见苦集灭道及修所断。若见圆满世尊弟子。未离无色界贪。诸无色界系善心。缘见修所断。是名体未断所缘已断及所缘未断。其体未断不可分别此心所缘已断未断者。谓诸具缚补特伽罗。诸无色界系善心。缘非所断。已离欲界贪。未离色界贪。苦类智未生。诸无色界系善心。缘非所断。已离色界贪。苦类智未生。诸无色界系善心。缘非所断。苦类智已生。集类智未生。诸无色系善心。缘非所断。集类智已生。灭类智未生。诸无色界系善心。缘非所断。灭类智已生。道类智未生。诸无色界系善心。缘非所断。若见圆满世尊弟子。未离无色界贪。诸无色界系善心。缘非所断。是名体未断不可分别此心所缘已断未断。设所缘未断其体未断耶。曰如是。诸无色界系有覆无记心。若体未断所缘未断耶。或体未断所缘未断。或体未断所缘已断。或体未断所缘已断及所缘未断。或体未断不可分别。此心所缘已断未断。其体未断所缘未断者。谓诸具缚补特伽罗。诸无色界系有覆无记心。缘无色界系。已离欲界贪。未离色界贪。苦类智未生。诸无色界系有覆无记心。缘无色界系。已离色界贪。苦类智未生。诸无色界系有覆无记心。缘无色界系。苦类智已生。集愿智未生。诸无色界系见集所断有覆无记心。缘见集灭道及修所断。见集所断有覆无记心。缘见集所断。见灭所断有覆无记心。缘见灭所断。见道所断有覆无记心。缘见道所断。修所断有覆无记心。缘修所断。集类智已生。灭类智未生。诸无色界系见灭所断有覆无记心。缘见灭所断。见道所断有覆无记心。缘见道所断。修所断有覆无记心。缘修所断。灭类智已生。道类智未生。诸无色界系见道所断有覆无记心。缘见道所断。修所断有覆无记心。缘修所断。若见圆满世尊弟子。未离无色界贪。诸无色界系修所断有覆无记心。缘修所断。是名体未断所缘未断。其体未断所缘已断者。谓苦类智已生。集类智未生。诸无色界系见集所断有覆无记心。缘见苦所断。是名体未断所缘已断。其体未断所缘已断及所缘未断者。谓苦类智已生。集类智未生。诸无色界系见集所断有覆无记心。缘见苦集灭道及修所断。是名体未断所缘已断及所缘未断。其体未断不可分别此心所缘已断未断者。谓诸具缚补特伽罗。诸无色界系有覆无记心。缘非所断。已离欲界贪。未离色界贪。苦类智未生。诸无色界系有覆无记心。缘非所断已离色界贪。苦类智未生。诸无色界系有覆无记心。缘非所断。苦类智已生。集类智未生。诸无色界系有覆无记心。缘非所断。集类智已生。灭类智未生。诸无色界系见灭道所断有覆无记心。缘非所断。灭类智已生。道类智未生。诸无色界系见道所断有覆无记心。缘非所断。是名体未断不可分别此心所缘已断未断。设所缘未断其体未断耶。或所缘未断其体未断。或所缘未断其体已断。或所缘未断及所缘已断。其体未断。或所缘未断及所缘已断其体已断。所缘未断其体未断者。谓诸具缚补特伽罗。诸无色界系有覆无记心。缘无色界系。已离欲界贪。未离色界贪。苦类智未生。诸无色界系有覆无记心。缘无色界系。已离色界贪。苦类智未生。诸无色界系有覆无记心。缘无色界系。苦类智已生。集类智未生。诸无色界系见集所断有覆无记心。缘见集灭道及修所断。见集所断有覆无记心。缘见集所断。见灭所断有覆无记心。缘见灭所断。见道所断有覆无记心。缘见道所断。修所断有覆无记心。缘修所断。集类智已生。灭类智未生。诸无色界系见灭所断有覆无记心。缘见灭所断。见道所断有覆无记心。缘见道所断。修所断有覆无记心。缘修所断。灭类智已生。道类智未生。诸无色界系见道所断有覆无记心。缘见道所断。修所断有覆无记心。缘修所断。若见圆满世尊弟子。未离无色界贪。诸无色界系修所断有覆无记心。缘修所断。是名所缘未断其体未断。所缘未断其体已断者。谓苦类智已生。集类智未生。诸无色界系见苦所断有覆无记心缘见集灭道及修所断。集类智已生。灭类智未生。诸无色界系见苦集所断有覆无记心。缘见灭道及修所断。灭类智已生。道类智未生。诸无色界系见苦集所断有覆无记心。缘见道及修所断。若见圆满世尊弟子。未离无色界贪。诸无色界系见所断有覆无记心。缘修所断。是名所缘未断其体已断。所缘未断及所缘已断其体未断者谓苦类智已生。集类智未生。诸无色界系见集所断有覆无记心。缘见苦集灭道及修所断。是名所缘未断及所缘已断其体未断。所缘未断及所缘已断其体已断者。谓苦类智已生。集类智未生。诸无色界系见苦所断有覆无记心。缘见苦集灭道及修所断。集类智已生。灭类智未生。诸无色界系见苦集所断有覆无记心。缘见苦集灭道及修所断。灭类智已生。道类智未生。诸无色界系见苦集所断有覆无记心。缘见苦集灭道及修所断。若见圆满世尊弟子。未离无色界贪。诸无色界系见所断有覆无记心。缘见修所断。是名所缘未断及所缘已断其体已断。诸无色界系无覆无记心。若体未断所缘未断耶。或体未断所缘未断。或体未断所缘已断。或体未断所缘已断及所缘未断。其体未断所缘未断者。谓诸具缚补特伽罗。诸无色界系无覆无记心。缘无色界系。已离欲界贪。未离色界贪。苦类智未生。诸无色界系无覆无记心。缘无色界系。已离色界贪。苦类智未生。诸无色界系无覆无记心。缘无色界系。苦类智已生。集类智未生。诸无色界系无覆无记心。缘见集灭道及修所断。集类智已生。灭类智未生。诸无色界系无覆无记心。缘见灭道及修所断。灭类智已生。道类智未生。诸无色界系无覆无记心。缘见道及修所断。若见圆满世尊弟子。未离无色界贪。诸无色界系无覆无记心。缘修所断。是名体未断所缘未断。其体未断所缘已断者。谓苦类智已生。集类智未生。诸无色界系无覆无记心。缘见苦所断。集类智已生。灭类智未生。诸无色界系无覆无记心。缘见苦集所断。灭类智已生。道类智未生。诸无色界系无覆无记心。缘见苦集灭所断。若见圆满世尊弟子。未离无色界贪。诸无色界系无覆无记心。缘见所断。是名体未断所缘已断。其体未断所缘已断及所缘未断者。谓苦类智已生。集类智未生。诸无色界系无覆无记心。缘见苦集灭道及修所断。集类智已生。灭类智未生。诸无色界系无覆无记心。缘见苦集灭道及修所断。灭类智已生。道类智未生。诸无色界系无覆无记心。缘见苦集灭道及修所断。若见圆满世尊弟子。未离无色界贪。诸无色界系无覆无记心。缘见修所断。是名体未断所缘已断及所缘未断。设所缘未断其体未断耶。曰如是

说一切有部识身足论卷第八阿毗达磨识身足论卷第九

        提婆设摩阿罗汉造

        三藏法师玄奘奉　诏译

    所缘缘蕴第四之四

有十种心。谓欲界系善心。不善心。有覆无记心。无覆无记心。色界系善心。有覆无记心。无覆无记心。无色界系善心。有覆无记心。无覆无记心。诸欲界系善心。若体已断所缘已断耶。设所缘已断其体已断耶。乃至诸无色界系无覆无记心。若体已断所缘已断耶。设所缘已断其体已断耶

诸欲界系善心。若体已断所缘已断耶。或体已断所缘已断。或体已断所缘未断。或体已断所缘已断及所缘未断。或体已断不可分别此心所缘已断未断。其体已断所缘已断者。谓已离欲界贪。未离色界贪。诸欲界系善心。缘欲界系。已离色界贪。未离无色界贪。诸欲界系善心。缘欲界系缘色界系。缘欲界系色界系。已离无色界贪。诸欲界系善心。缘欲界系。缘色界系。缘无色界系。缘欲界系色界系。缘欲界系无色界系。缘色界系无色界系。缘欲界系色界系无色界系。是名体已断所缘已断。其体已断所缘未断者。谓已离欲界贪。未离色界贪。苦类智未生。诸欲界系善心。缘色界系。缘无色界系。缘色界系无色界系。已离色界贪。苦类智未生。诸欲界系善心。缘无色界系。是名体已断所缘未断。其体已断所缘已断及所缘未断者。谓已离欲界贪。未离色界贪。诸欲界系善心。缘欲界系色界系。缘欲界系无色界系。缘欲界系色界系无色界系已离色界贪。未离无色界贪。诸欲界系善心。缘欲界系无色界系。缘色界系无色界系。缘欲界系色界系无色界系。是名体已断所缘已断及所缘未断。其体已断不可分别此心所缘已断未断者。谓已离欲界贪。未离色界贪。诸欲界系善心。缘非所断。已离色界贪。未离无色界贪。诸欲界系善心。缘非所断。已离无色界贪。诸欲界系善心。缘非所断。是名体已断不可分别此心所缘已断未断。设所缘已断其体已断耶。或所缘已断其体已断。或所缘已断其体未断。或所缘已断及所缘未断其体已断。或所缘已断及所缘未断其体未断。所缘已断其体已断者谓已离欲界贪。未离色界贪。诸欲界系善心。缘欲界系。已离色界贪。未离无色界贪。诸欲界系善心。缘欲界系。缘色界系。缘欲界系色界系。已离无色界贪。诸欲界系善心。缘欲界系。缘色界系。缘无色界系。缘欲界系色界系。缘欲界系无色界系。缘色界系无色界系。缘欲界系色界系无色界系。是名所缘已断其体已断。所缘已断其体未断者。谓未离欲界贪。苦智已生集智未生。诸欲界系善心。缘见苦所断。集智已生灭智未生。诸欲界系善心。缘见苦集所断。灭智已生道智未生。诸欲界系善心缘见苦集灭所断。若见圆满世尊弟子。未离欲界贪。诸欲界系善心。缘见所断。是名所缘已断其体未断。所缘已断及所缘未断其体已断者。谓已离欲界贪。未离色界贪。诸欲界系善心。缘欲界系色界系。缘欲界系无色界系。缘欲界系色界系无色界系。已离色界贪。未离无色界贪。诸欲界系善心。缘欲界系无色界系。缘色界系无色界系。缘欲界系色界系无色界系。是名所缘已断及所缘未断其体已断。所缘已断及所缘未断其体未断者谓未离欲界贪。苦智已生集智未生。诸欲界系善心。缘见苦集灭道及修所断。集智已生灭智未生诸欲界系善心。缘见苦集灭道及修所断。灭智已生道智未生。诸欲界系善心。缘见苦集灭道及修所断。若见圆满世尊弟子。未离欲界贪。诸欲界系善心。缘见修所断。是名所缘已断及所缘未断。其体未断。诸不善心。若体已断所缘已断耶。或体已断所缘已断。或体已断所缘未断。或体已断所缘已断及所缘未断。或体已断不可分别此心所缘已断未断。其体已断所缘已断者。谓未离欲界贪。苦智已生集智未生。诸见苦所断不善心。缘见苦所断。集智已生灭智未生。诸见苦集所断不善心。缘见苦集所断。见苦所断不善心。缘见苦所断。见集所断不善心。缘见集所断。灭智已生道智未生。诸见苦集所断不善心。缘见苦集灭所断。见苦所断不善心。缘见苦所断。见集所断不善心。缘见集所断。见灭所断不善心。缘见灭所断。若见圆满世尊弟子。未离欲界贪。诸见所断不善心。缘见所断。已离欲界贪。未离色界贪诸不善心。缘欲界系。已离色界贪。未离无色界贪。诸不善心。缘欲界系。缘色界系。已离无色界贪。诸不善心。缘欲界系。缘色界系。缘无色界系。缘色界系无色界系。是名体已断所缘已断。其体已断所缘未断者。谓未离欲界贪。苦智已生集智未生。诸见苦所断不善心。缘见集灭道及修所断。集智已生灭智未生。诸见苦集所断不善心。缘见灭道及修所断。灭智已生道智未生。诸见苦集所断不善心。缘见道及修所断。若见圆满世尊弟子。未离欲界贪。诸见所断不善心。缘修所断。已离欲界贪。未离色界贪。苦类智未生。诸不善心。缘色界系。缘无色界系。缘色界系无色界系。已离色界贪。苦类智未生。诸不善心。缘无色界系。是名体已断所缘未断。其体已断所缘已断及所缘未断者。谓未离欲界贪。苦智已生集智未生。诸见苦所断不善心。缘见苦集灭道及修所断。集智已生灭智未生。诸见苦集所断不善心。缘见苦集灭道及修所断。灭智已生道智未生。诸见苦集所断不善心。缘见苦集灭道及修所断。若见圆满世尊弟子。未离欲界贪。诸见所断不善心。缘见修所断。已离色界贪。未离无色界贪诸不善心。缘色界系无色界系。是名体已断所缘已断及所缘未断。其体已断不可分别此心所缘已断未断者。谓未离欲界贪。灭智已生道智未生。诸见灭所断不善心。缘非所断。若见圆满世尊弟子。未离欲界贪。诸见所断不善心。缘非所断。已离欲界贪。未离色界贪。诸不善心。缘非所断。已离色界贪。未离无色界贪诸不善心。缘非所断。已离无色界贪诸不善心。缘非所断是名体已断不可分别。此心所缘已断未断。设所缘已断其体已断耶或所缘已断其体已断。或所缘已断其体未断。或所缘已断及所缘未断其体已断。或所缘已断及所缘未断其体未断。所缘已断其体已断者。谓未离欲界贪。苦智已生集智未生。诸见苦所断不善心。缘见苦所断。集智已生。灭智未生。诸见苦集所断不善心。缘见苦集所断。见苦所断不善心。缘见苦所断。见集所断不善心。缘见集所断。灭智已生道智未生。诸见苦集所断不善心。缘见苦集灭所断。见苦所断不善心。缘见苦所断。见集所断不善心。缘见集所断。见灭所断不善心。缘见灭所断。若见圆满世尊弟子。未离欲界贪。诸见所断不善心。缘见所断。已离欲界贪。未离色界贪。诸不善心。缘欲界系。已离色界贪。未离无色界贪诸不善心。缘欲界系。缘色界系。已离无色界贪。诸不善心。缘欲界系。缘色界系。缘无色界系。缘色界系无色界系。是名所缘已断其体已断。所缘已断其体未断者。谓未离欲界贪。苦智已生集智未生。诸见集所断不善心。缘见苦所断。是名所缘已断其体未断所缘已断及所缘未断其体已断者。谓未离欲界贪。苦智已生集智未生。诸见苦所断不善心。缘见苦集灭道及修所断。集智已生灭智未生。诸见苦集所断不善心。缘见苦集灭道及修所断。灭智已生道智未生。诸见苦集所断不善心。缘见苦集灭道及修所断。若见圆满世尊弟子。未离欲界贪。诸见所断不善心。缘见修所断。已离色界贪。未离无色界贪。诸不善心。缘色界系无色界系。是名所缘已断及所缘未断其体已断。所缘已断及所缘未断其体未断者。谓未离欲界贪。苦智已生集智未生。诸见集所断不善心。缘见苦集灭道及修所断。是名所缘已断及所缘未断其体未断。诸欲界系有覆无记心。若体已断所缘已断耶。或体已断所缘已断。或体已断所缘未断。或体已断所缘已断及所缘未断。其体已断所缘已断者。谓未离欲界贪。苦智已生集智未生。诸欲界系有覆无记心。缘见苦所断。集智已生灭智未生。诸欲界系有覆无记心。缘见苦集所断。灭智已生道智未生。诸欲界系有覆无记心。缘见苦集灭所断。若见圆满世尊弟子。未离欲界贪。诸欲界系有覆无记心。缘见所断。已离欲界贪。未离色界贪。诸欲界系有覆无记心。缘欲界系。已离色界贪。未离无色界贪。诸欲界系有覆无记心。缘欲界系。已离无色界贪。诸欲界系有覆无记心。缘欲界系。是名体已断所缘已断。其体已断所缘未断者。谓未离欲界贪。苦智已生集智未生。诸欲界系有覆无记心。缘见集灭道及修所断。集智已生灭智未生。诸欲界系有覆无记心。缘见灭道及修所断。灭智已生道智未生。诸欲界系有覆无记心。缘见道及修所断。若见圆满世尊弟子。未离欲界贪。诸欲界系有覆无记心。缘修所断。是名体已断所缘未断。其体已断所缘已断及所缘未断者。谓未离欲界贪。苦智已生集智未生。诸欲界系有覆无记心。缘见苦集灭道及修所断。集智已生灭智未生。诸欲界系有覆无记心。缘见苦集灭道及修所断。灭智已生道智未生。诸欲界系有覆无记心。缘见苦集灭道及修所断。若见圆满世尊弟子。未离欲界贪。诸欲界系有覆无记心。缘修所断。是名体已断所缘已断及所缘未断。设所缘已断其体已断耶。曰如是。诸欲界系无覆无记心。若体已断所缘已断耶。曰如是。设所缘已断其体已断耶。或所缘已断其体已断。或所缘已断其体未断。或所缘已断及所缘未断其体未断。所缘已断其体已断者。谓已离欲界贪。未离色界贪。诸欲界系无覆无记心。缘欲界系。已离色界贪。未离无色界贪。诸欲界系无覆无记心。缘欲界系。已离无色界贪。诸欲界系无覆无记心。缘欲界系。是名所缘已断其体已断。所缘已断其体未断者。谓未离欲界贪。苦智已生集智未生。诸欲界系无覆无记心。缘见苦所断。集智已生灭智未生。诸欲界系无覆无记心。缘见苦集所断。灭智已生道智未生。诸欲界系无覆无记心。缘见苦集灭所断。若见圆满世尊弟子。未离欲界贪。诸欲界系无覆无记心。缘见所断。是名所缘已断其体未断。所缘已断及所缘未断其体未断者。谓未离欲界贪。苦智已生集智未生。诸欲界系无覆无记心。缘见苦集灭道及修所断。集智已生灭智未生。诸欲界系无覆无记心。缘见苦集灭道及修所断。灭智已生道智未生。诸欲界系无覆无记心。缘见苦集灭道及修所断。若见圆满世尊弟子。未离欲界贪。诸欲界系无覆无记心。缘见修所断。是名所缘已断及所缘未断其体未断。诸色界系善心。若体已断所缘已断耶。或体已断所缘已断。或体已断所缘未断。或体已断所缘已断及所缘未断。或体已断不可分别此心所缘已断未断。其体已断所缘已断者。谓已离色界贪。未离无色界贪。诸色界系善心。缘欲界系。缘色界系。缘无色界系。已离无色界贪。诸色界系善心。缘欲界系。缘色界系。缘无色界系。缘欲界系色界系。缘欲界系无色界系缘色界系无色界系。缘欲界系色界系无色界系。是名体已断所缘已断。其体已断所缘未断者。谓已离色界贪。苦类智未生。诸色界系善心。缘无色界系。是名体已断所缘未断。其体已断所缘已断及所缘未断者。谓已离色界贪。未离无色界贪。诸色界系善心。缘欲界系无色界系。缘色界系无色界系。缘欲界系色界系无色界系。是名体已断所缘已断及所缘未断。其体已断不可分别此心所缘已断未断者。谓已离色界贪。未离无色界贪。诸色界系善心。缘非所断已离无色界贪。诸色界系善心。缘非所断。是名体已断不可分别此心所缘已断未断。设所缘已断其体已断耶。或所缘已断其体已断。或所缘已断其体未断。或所缘已断及所缘未断其体已断。或所缘已断及所缘未断其体未断。所缘已断其体已断者。谓已离色界贪。未离无色界贪。诸色界系善心。缘欲界系。缘色界系。缘欲界系色界系。已离无色界贪。诸色界系善心。缘欲界系。缘色界系。缘无色界系。缘欲界系色界系。缘欲界系无色界系。缘色界系无色界系。缘欲界系色界系无色界系。是名所缘已断其体已断。所缘已断其体未断者。谓已离欲界贪。未离色界贪。苦类智未生。诸色界系善心。缘欲界系。未离色界贪。苦类智已生。集类智未生。诸色界系善心。缘见苦所断。集类智已生。灭类智未生。诸色界系善心。缘见苦集所断。灭类智已生。道类智未生。诸色界系善心。缘见苦集灭所断。若见圆满世尊弟子。未离色界贪。诸色界系善心。缘见所断。是名所缘已断其体未断。所缘已断及所缘未断其体已断者。谓已离色界贪。未离无色界贪。诸色界系善心。缘欲界系无色界系。缘色界系无色界系。缘欲界系色界系无色界系。是名所缘已断及所缘未断其体已断。所缘已断及所缘未断其体未断者。谓已离欲界贪。未离色界贪。诸色界系善心。缘欲界系色界系。缘欲界系无色界系。缘欲界系色界系无色界系。未离色界贪。苦类智已生集类智未生。诸色界系善心。缘见苦集灭道及修所断。集类智已生。灭类智未生。诸色界系善心。缘见苦集灭道及修所断。灭类智已生。道类智未生。诸色界系善心。缘见苦集灭道及修所断。若见圆满世尊弟子。未离色界贪。诸色界系善心。缘见修所断。是名所缘已断及所缘未断其体未断。诸色界系有覆无记心。若体已断所缘已断耶。或体已断所缘已断。或体已断所缘未断。或体已断所缘已断及所缘未断或体已断不可分别此心所缘已断未断。其体已断所缘已断者。谓未离色界贪。苦类智已生。集类智未生。诸色界系见苦所断有覆无记心。缘见苦所断。集类智已生。灭类智未生。诸色界系见苦集所断有覆无记心。缘见苦集所断。见苦所断有覆无记心。缘见苦所断。见集所断有覆无记心。缘见集所断。灭类智已生。道类智未生。诸色界系。见苦集所断。有覆无记心。缘见苦集灭所断。见苦所断有覆无记心。缘见苦所断。见集所断有覆无记心。缘见集所断。见灭所断有覆无记心。缘见灭所断。若见圆满世尊弟子。未离色界贪。诸色界系见所断有覆无记心。缘见所断。已离色界贪。未离无色界贪。诸色界系有覆无记心。缘色界系。已离无色界贪。诸色界系有覆无记心。缘色界系。缘无色界系。缘色界系无色界系。是名体已断所缘已断。其体已断所缘未断者。谓未离色界贪。苦类智已生。集类智未生。诸色界系见苦所断有覆无记心。缘见集灭道及修所断。集类智已生。灭类智未生。诸色界系见苦集所断有覆无记心。缘见灭道及修所断。灭类智已生。道类智未生。诸色界系见苦集所断。有覆无记心。缘见道及修所断。若见圆满世尊弟子。未离色界贪。诸色界系见所断有覆无记心。缘修所断。已离色界贪。苦类智未生。诸色界系有覆无记心。缘无色界系。是名体已断所缘未断。其体已断所缘已断及所缘未断者。谓未离色界贪。苦类智已生。集类智未生。诸色界系见苦所断有覆无记心。缘见苦集灭道及修所断。集类智已生。灭类智未生。诸色界系见苦集所断有覆无记心。缘见苦集灭道及修所断。灭类智已生。道类智未生。诸色界系见苦集所断有覆无记心。缘见苦集灭道及修所断。若见圆满世尊弟子。未离色界贪。诸色界系见所断有覆无记心。缘见修所断。已离色界贪。未离无色界贪。诸色界系有覆无记心。缘色界系无色界系。是名体已断所缘已断及所缘未断。其体已断不可分别此心所缘已断未断者。谓未离色界贪。灭类智已生。道类智未生。诸色界系见灭所断有覆无记心缘非所断。若见圆满世尊弟子。未离色界贪。诸色界系见灭道所断有覆无记心。缘非所断。已离色界贪。未离无色界贪。诸色界系有覆无记心。缘非所断。已离无色界贪。诸色界系有覆无记心。缘非所断。是名体已断不可分别此心所缘已断未断。设所缘已断其体已断耶。或所缘已断其体已断。或所缘已断其体未断。或所缘已断及所缘未断其体已断。或所缘已断及所缘未断其体未断。所缘已断其体已断者。谓未离色界贪。苦类智已生。集类智未生。诸色界系见苦所断有覆无记心。缘见苦所断。集类智已生。灭类智未生。诸色界系见苦集所断有覆无记心。缘见苦集所断。见苦所断有覆无记心。缘见苦所断。见集所断有覆无记心。缘见集所断。灭类智已生。道类智未生。诸色界系见苦集所断有覆无记心。缘见苦集灭所断。见苦所断有覆无记心。缘见苦所断。见集所断有覆无记心。缘见集所断。见灭所断有覆无记心。缘见灭所断。若见圆满世尊弟子。未离色界贪。诸色界系见所断有覆无记心。缘见所断。已离色界贪。未离无色界贪。诸色界系有覆无记心。缘色界系。已离无色界贪。诸色界系有覆无记心。缘色界系。缘无色界系。缘色界系无色界系。是名所缘已断其体已断。所缘已断其体未断者。谓未离色界贪。苦类智已生。集类智未生。诸色界系见集所断有覆无记心。缘见苦所断是名所缘已断其体未断。所缘已断及所缘未断其体已断者。谓未离色界贪。苦类智已生。集类智未生。诸色界系见苦所断有覆无记心。缘见苦集灭道及修所断。集类智已生。灭类智未生。诸色界系见苦集所断有覆无记心。缘见苦集灭道及修所断。灭类智已生。道类智未生。诸色界系见苦集所断有覆无记心。缘见苦集灭道及修所断。若见圆满世尊弟子。未离色界贪。诸色界系见所断有覆无记心。缘见修所断已离色界贪。未离无色界贪。诸色界系有覆无记心。缘色界系无色界系。是名所缘已断及所缘未断其体已断。所缘已断及所缘未断其体未断者。谓未离色界贪。苦类智已生。集类智未生。诸色界系见集所断有覆无记心。缘见苦集灭道及修所断。是名所缘已断及所缘未断其体未断。诸色界系无覆无记心。若体已断所缘已断耶。曰如是。设所缘已断其体已断耶。或所缘已断其体已断。或所缘已断其体未断。或所缘已断及所缘未断其体未断。所缘已断其体已断者。谓已离色界贪。未离无色界贪。诸色界系无覆无记心。缘欲界系。缘色界系。已离无色界贪。诸色界系无覆无记心。缘欲界系。缘色界系。是名所缘已断其体已断。所缘已断其体未断者。谓已离欲界贪。未离色界贪。诸色界系无覆无记心。缘欲界系未离色界贪。苦类智已生集类智未生。诸色界系无覆无记心。缘见苦所断集类智已生。灭类智未生。诸色界系无覆无记心。缘见苦集所断。灭类智已生。道类智未生。诸色界系无覆无记心。缘见苦集灭所断。若见圆满世尊弟子。未离色界贪。诸色界系无覆无记心。缘见所断。是名所缘已断其体未断。所缘已断及所缘未断其体未断者。谓未离色界贪。苦类智已生。集类智未生。诸色界系无覆无记心。缘见苦集灭道及修所断。集类智已生。灭类智未生。诸色界系无覆无记心。缘见苦集灭道及修所断。灭类智已生。道类智未生。诸色界系无覆无记心。缘见苦集灭道及修所断。若见圆满世尊弟子。未离色界贪。诸色界系无覆无记心。缘见修所断。是名所缘已断及所缘未断其体未断

说一切有部识身足论卷第九阿毗达磨识身足论卷第十

        提婆设摩阿罗汉造

        三藏法师玄奘奉　诏译

    所缘缘蕴第四之五

诸无色界系善心。若体已断所缘已断耶。曰如是。设所缘已断其体已断耶。或所缘已断其体已断。或所缘已断其体未断。或所缘已断及所缘未断其体未断。所缘已断其体已断者。谓已离无色界贪。诸无色界系善心。缘色界系。缘无色界系。是名所缘已断其体已断。所缘已断其体未断者。谓已离色界贪。未离无色界贪。诸无色界系善心。缘色界系。苦类智已生。集类智未生。诸无色界系善心。缘见苦所断。集类智已生。灭类智未生。诸无色界系善心。缘见苦集所断。灭类智已生。道类智未生。诸无色界系善心。缘见苦集灭所断。若见圆满世尊弟子。未离无色界贪。诸无色界系善心。缘见所断。是名所缘已断其体未断。所缘已断及所缘未断其体未断者。谓苦类智已生。集类智未生。诸无色界系善心。缘见苦集灭道及修所断。集类智已生。灭类智未生。诸无色界系善心。缘见苦集灭道及修所断。灭类智已生。道类智未生。诸无色界系善心。缘见苦集灭道及修所断。若见圆满世尊弟子。未离无色界贪。诸无色界系善心。缘见修所断。是名所缘已断及所缘未断其体未断。诸无色界系有覆无记心。若体已断所缘已断耶。或体已断所缘已断。或体已断所缘未断。或体已断所缘已断及所缘未断。或体已断不可分别此心所缘已断未断。其体已断所缘已断者。谓苦类智已生。集类智未生。诸无色界系见苦所断有覆无记心。缘见苦所断。集类智已生。灭类智未生。诸无色界系见苦集所断有覆无记心。缘见苦集所断。见苦所断有覆无记心。缘见苦所断。见集所断有覆无记心。缘见集所断。灭类智已生。道类智未生。诸无色界系见苦集所断有覆无记心。缘见苦集灭所断。见苦所断。有覆无记心。缘见苦所断。见集所断有覆无记心。缘见集所断。见灭所断有覆无记心。缘见灭所断。若见圆满世尊弟子。未离无色界贪。诸无色界系见所断有覆无记心。缘见所断。已离无色界贪。诸无色界系有覆无记心。缘无色界系。是名体已断所缘已断。其体已断所缘未断者。谓苦类智已生。集类智未生。诸无色界系见苦所断有覆无记心。缘见集灭道及修所断。集类智已生。灭类智未生。诸无色界系见苦集所断有覆无记心。缘见灭道及修所断。灭类智已生。道类智未生。诸无色界系见苦集所断有覆无记心。缘见道及修所断。若见圆满世尊弟子。未离无色界贪。诸无色界系见所断有覆无记心。缘修所断。是名体已断所缘未断。其体已断所缘已断及所缘未断者。谓苦类智已生。集类智未生。诸无色界系见苦所断有覆无记心。缘见苦集灭道及修所断。集类智已生。灭类智未生。诸无色界系见苦集所断有覆无记心。缘见苦集灭道及修所断。灭类智已生。道类智未生。诸无色界系见苦集所断有覆无记心。缘见苦集灭道及修所断。若见圆满世尊弟子。未离无色界贪。诸无色界系见所断。有覆无记心。缘见修所断。是名体已断所缘已断及所缘未断。其体已断不可分别此心所缘已断未断者。谓未离无色界贪。灭类智已生。道类智未生。诸无色界系见灭所断有覆无记心。缘非所断。若见圆满世尊弟子。未离无色界贪。诸无色界系见灭道所断有覆无记心。缘非所断。已离无色界贪。诸无色界系有覆无记心。缘非所断。是名体已断不可。分别此心所缘已断未断。设所缘已断其体已断耶。或所缘已断其体已断。或所缘已断其体未断。或所缘已断及所缘未断其体已断。或所缘已断及所缘未断其体未断。所缘已断其体已断者。谓苦类智已生。集类智未生。诸无色界系见苦所断有覆无记心。缘见苦所断。集类智已生。灭类智未生。诸无色界系见苦集所断有覆无记心。缘见苦集所断。见苦所断有覆无记心。缘见苦所断。见集所断有覆无记心。缘见集所断。灭类智已生。道类智未生。诸无色界系见苦集所断有覆无记心。缘见苦集灭所断。见苦所断有覆无记心。缘见苦所断。见集所断。有覆无记心。缘见集所断。见灭所断有覆无记心。缘见灭所断。若见圆满世尊弟子。未离无色界贪。诸无色界系见所断有覆无记心。缘见所断。已离无色界贪。诸无色界系有覆无记心缘无色界系。是名所缘已断其体已断。所缘已断其体未断者。谓苦类智已生。集类智未生。诸无色界系见集所断有覆无记心。缘见苦所断。是名所缘已断其体未断。所缘已断及所缘未断其体已断者。谓苦类智已生。集类智未生。诸无色界系见苦所断有覆无记心。缘见苦集灭道及修所断。集类智已生。灭类智未生。诸无色界系见苦集所断有覆无记心。缘见苦集灭道及修所断。灭类智已生。道类智未生。诸无色界系见苦集所断有覆无记心。缘见苦集灭道及修所断。若见圆满世尊弟子。未离无色界贪。诸无色界系见所断。有覆无记心。缘见修所断。是名所缘已断及所缘未断其体已断。所缘已断及所缘未断其体未断者。谓苦类智已生。集类智未生。诸无色界系见集所断有覆无记心。缘见苦集灭道及修所断。是名所缘已断及所缘未断其体未断。诸无色界系无覆无记心。若体已断所缘已断耶。曰如是。设所缘已断其体已断耶。或所缘已断其体已断。或所缘已断其体未断。或所缘已断及所缘未断其体未断。所缘已断其体已断者。谓已离无色界贪。诸无色界系无覆无记心。缘无色界系。是名所缘已断其体已断。所缘已断其体未断者。谓苦类智已生。集类智未生。诸无色界系无覆无记心。缘见苦所断。集类智已生。灭类智未生。诸无色界系无覆无记心。缘见苦集所断。灭类智已生。道类智未生。诸无色界系无覆无记心。缘见苦集灭所断。若见圆满世尊弟子。未离无色界贪。诸无色界系无覆无记心。缘见所断。是名所缘已断其体未断。所缘已断及所缘未断其体未断者。谓苦类智已生。集类智未生。诸无色界系无覆无记心。缘见苦集灭道及修所断。集类智已生。灭类智未生。诸无色界系无覆无记心。缘见苦集灭道及修所断。灭类智已生。道类智未生。诸无色界系无覆无记心。缘见苦集灭道及修所断。若见圆满世尊弟子。未离无色界贪。诸无色界系无覆无记心。缘见修所断。是名所缘已断及所缘未断其体未断

有十五心。谓欲界系有五心。色界系有五心。无色界系有五心。云何欲界系有五心。谓欲界系见苦所断心。见集所断心。见灭所断心。见道所断心。修所断心。如欲界系五心。色界系无色界系五心亦尔。如是十五心。或过去或未来或现在。诸过去欲界系见苦所断心所有随眠。彼于此心若所随增是能缘耶。设是能缘所随增耶。如过去未来现在亦尔。如见苦所断心。见集灭道修所断心亦尔。如欲界系。色界系无色界系亦尔

诸过去欲界系见苦所断心所有随眠。彼于此心若所随增是能缘耶。或所随增非是能缘。或是能缘非所随增。或所随增亦是能缘。或非所随增非是能缘。是所随增非是能缘者。谓彼随眠此心相应未断。是其能缘非所随增者。谓彼随眠能缘此心已断。是所随增亦是能缘者。谓彼随眠能缘此心未断。非所随增亦非能缘者。谓彼随眠此心相应已断。若所余缘。若他随眠。若不同界遍行随眠。如过去未来亦尔。诸现在欲界系见苦所断心所有随眠。彼于此心若所随增是能缘耶。或所随增非是能缘。或是能缘非所随增。或所随增亦是能缘。或非所随增非是能缘。是所随增非是能缘者。谓彼随眠此心相应。是其能缘非所随增者。谓彼随眠能缘此心已断。是所随增亦是能缘者。谓彼随眠能缘此心未断。非所随增亦非能缘者。谓彼随眠。若所余缘。若他随眠。若不同界遍行随眠。如欲界系见苦所断心。见集灭道及修所断染污心亦尔。诸过去欲界系修所断不染污心所有随眠。彼于此心若所随增是能缘耶。若诸随眠。是所随增亦是能缘。或是能缘非所随增。谓诸随眠缘此心已断。如过去未来现在亦尔。如欲界系。色界系无色界系亦尔

有十五心。谓欲界系有五心。色界系有五心。无色界系有五心。云何欲界系有五心。谓欲界系见苦所断心见集灭道修所断心。如欲界系有五心。色界系无色界系亦尔。如是十五心。或过去或未来或现在。诸过去欲界系见苦所断心所有随眠。彼于此心若非所随增非是能缘耶。设非是能缘非所随增耶。如过去未来现在亦尔。如见苦所断心。见集灭道及修所断心亦尔。如欲界系。色界系无色界系亦尔

诸过去欲界系见苦所断心所有随眠。彼于此心若非所随增非是能缘耶。或非所随增非不能缘。或非能缘非不随增。或非所随增亦不能缘。或非不随增非不能缘。非所随增非不能缘者。谓诸随眠缘此心已断。非是能缘非不随增者。谓诸随眠此心相应未断。非所随增非是能缘者。谓诸随眠此心相应已断。若所余缘。若他随眠。若不同界遍行随眠。非不随增非不能缘者。谓诸随眠缘此心未断。如过去未来亦尔。诸现在欲界系见苦所断心所有随眠。彼于此心若非所随增非是能缘耶。或非所随增非不能缘。或非能缘非不随增。或非所随增亦非能缘。或非不随增非不能缘非所随增非不能缘者。谓诸随眠缘此心已断。非是能缘非不随增者。谓诸随眠此心相应。非所随增非是能缘者。谓诸随眠。若所余缘。若他随眠。若不同界遍行随眠。非不随增非不能缘者。谓诸随眠缘此心未断。如欲界系见苦所断心。见集灭道及修所断染污心亦尔。诸过去欲界系修所断不染污心所有随眠。彼于此心若非所随增或非能缘耶。若诸随眠非是能缘亦非随增。或非随增非不能缘。谓诸随眠缘此心已断。如过去未来现在亦尔。如欲界系。色界系无色界系亦尔

有十五心。谓欲界系有五心。色界系有五心。无色界系有五心。云何欲界系五心。谓欲界系见苦所断心。见集灭道修所断心。如欲界系五心。色界系无色界系五心亦尔。诸欲界系见苦所断心。能了别欲界系。见苦所断法耶。能了别自地四种所断法耶。能了别色界系无色界系五种所断法耶。如欲界系见苦所断心。见集灭道修所断心亦尔。如欲界系五心。色界系无色界系五心亦尔

诸欲界系见苦所断心。能了别欲界系见苦所断法耶。曰能了别。谓或执为我。或执我所。或执为断。或执为常。或拨无苦。或执为尊。或执为胜。或执为上。或执第一。或执清净。或执解脱。或执出离。若惑若疑。若犹豫。若贪若嗔。若慢若痴。若不如理所引了别。亦能了别自地四种所断法耶。曰能了别。谓或执为我。或执我所。或执为断。或执为常。或拨无苦。或执为尊。或执为胜。或执为上。或执第一。或执清净。或执解脱。或执出离。若惑若疑。若犹豫若无智。若冥暗若愚痴。若不如理所引了别。亦能了别色界系无色界系五种所断法耶。曰能了别。谓或拨无苦。或执为尊。或执为胜。或执为上。或执第一。或执清净。或执解脱。或执出离。若惑若疑。若犹豫若无智。若冥暗若愚痴。若不如理所引了别。诸欲界系见集所断心。能了别欲界系见集所断法耶。曰能了别。谓或拨无因。或执为尊。或执为胜。或执为上。或执第一。若惑若疑。若犹豫。若贪若嗔。若慢若痴。若不如理所引了别。亦能了别自地四种色界系无色界系五种所断法耶。曰能了别。谓或拨无因。或执为尊。或执为胜。或执为上。或执第一。若惑若疑。若犹豫若无智。若冥暗若愚痴。若不如理所引了别。诸欲界系见灭所断心。能了别欲界系见灭所断法耶。曰能了别。谓或执为尊。或执为胜。或执为上。或执第一。若贪若嗔。若慢若痴。若不如理所引了别。亦能了别不系法耶。曰能了别。谓或拨无灭。若犹豫了别。若愚痴。若不如理所引了别。如是了别余不了别诸欲界系见道所断心能了别欲界系见道所断法耶。曰能了别。谓或执为尊。或执为胜。或执为上。或执第一。或执清净。或执解脱。或执出离。若贪若嗔。若慢若痴。若不如理所引了别。亦能了别不系法耶。曰能了别。谓或拨无道。若犹豫了别。若愚痴。若不如理所引了别。如是了别余不了别。诸欲界系修所断心。能了别欲界系修所断法耶。曰能了别。谓若贪若嗔。若慢若痴。若粗若苦若障。若如病若如痈。若如箭若恼害。若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。若不如理所引了别。若非如理所引。非不如理所引了别。亦能了别自地四种所断法耶。曰能了别。若粗若苦若障。若如病。若如痈。若如箭。若恼害。若无常。若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。若非如理所引。非不如理所引了别。亦能了别色界系无色界系四种所断法耶。曰能了别。谓若粗若苦若障。若如病若如痈。若如箭若恼害。若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。亦能了别色界系无色界系修所断法耶。曰能了别。谓若粗若苦若障。若静若妙若离。若如病若如痈。若如箭若如恼害。若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。亦能了别不系法耶。曰能了别。谓若于灭谓灭谓静谓妙谓离。若于道谓道谓如谓行谓出。若无常若空若无我。若有因若有起。若有是处。若有是事。若如理所引了别。诸色界系见苦所断心。能了别色界系见苦所断法耶。曰能了别。谓或执为我。或执我所。或执为断。或执为常。或拨无苦。或执为尊。或执为胜。或执为上。或执第一。或执清净。或执解脱。或执出离。若惑若疑。若犹豫。若贪若慢若痴。若不如理所引了别。亦能了别自地四种所断法耶。曰能了别。谓或执为我。或执我所。或执为断。或执为常。或拨无苦。或执为尊。或执为胜。或执为上。或执第一。或执清净。或执解脱。或执出离。若惑若疑。若犹豫若无智。若冥暗若愚痴。若不如理所引了别。亦能了别无色界系五种所断法耶。曰能了别。谓或拨无苦。或执为尊。或执为胜。或执为上。或执第一。或执清净。或执解脱。或执出离。若惑若疑。若犹豫若无智。若冥暗若愚痴。若不如理所引了别。如是了别余不了别。诸色界系见集所断心。能了别色界系见集所断法耶。曰能了别。谓或拨无因。或执为尊。或执为胜。或执为上。或执第一。若惑若疑。若犹豫。若贪若慢若痴。若不如理所引了别。亦能了别自地四种无色界系五种所断法耶。曰能了别。谓或拨无因。或执为尊。或执为胜。或执为上。或执第一。若惑若疑。若犹豫若无智。若冥暗若愚痴。若不如理所引了别。如是了别余不了别。诸色界系见灭所断心。能了别色界。系见灭所断法耶。曰能了别。谓或执为尊。或执为胜。或执为上。或执第一。若贪若慢若痴。若不如理所引了别。亦能了别不系法耶。曰能了别。谓或拨无灭。若犹豫了别。若愚痴。若不如理所引了别。如是了别余不了别。诸色界系见道所断心。能了别色界系见道所断法耶。曰能了别。谓或执为尊。或执为胜。或执为上。或执第一。或执清净。或执解脱。或执出离。若贪若慢若痴。若不如理所引了别。亦能了别不系法耶。曰能了别。谓或拨无道。若犹豫了别。若愚痴。若不如理所引了别。如是了别余不了别。诸色界系修所断心。能了别色界系修所断法耶。曰能了别。谓若贪若慢若痴。若粗若苦若障。若静若妙若离。若如病若如痈。若如箭若恼害。若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因。若有起。若有是处。若有是事。若如理所引了别。若不如理所引了别。若非如理所引非不如理所引了别。亦能了别欲界系五种自地四种所断法耶。曰能了别。谓若粗若苦若障。若如病若如痈。若如箭若恼害。若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。亦能了别无色界系四种所断法耶。曰能了别。谓若粗若苦若障。若如病若如痈。若如箭若恼害。若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。亦能了别无色界系。修所断法耶。曰能了别。谓若粗若苦若障。若静若妙若离。若如病若如痈。若如箭若恼害。若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。亦能了别不系法耶。曰能了别。谓若于灭谓灭谓静谓妙谓离。若于道谓道谓如谓行谓出。若无常若空若无我。若有因若有起。若有是处。若有是事。若如理所引了别。诸无色界系见苦所断心。能了别无色界系见苦所断法耶。曰能了别。谓或执为我。或执我所。或执为断。或执为常。或拨无苦。或执为尊。或执为胜。或执为上。或执第一。或执清净。或执解脱。或执出离。若惑若疑。若犹豫。若贪若慢若痴。若不如理所引了别。亦能了别自地四种所断法耶。曰能了别。谓或执为我。或执我所。或执为断。或执为常。或拨无苦。或执为尊。或执为胜。或执为上。或执第一。或执清净。或执解脱。或执出离。若惑若疑。若犹豫。若不如理所引了别。如是了别余不了别。诸无色界系见集所断心。能了别无色界系见集所断法耶。曰能了别。谓或拨无因。或执为尊。或执为胜。或执为上。或执第一。若惑若疑。若犹豫。若贪若慢若痴。若不如理所引了别。亦能了别。自地四种所断法耶。曰能了别。谓或拨无因。或执为尊。或执为胜。或执为上。或执第一。若惑若疑。若犹豫若无智。若冥暗若愚痴。若不如理所引了别。如是了别余不了别。诸无色界系见灭所断心。能了别无色界系见灭所断法耶。曰能了别。谓或执为尊。或执为胜。或执为上。或执第一。若贪若慢若痴。若不如理所引了别。亦能了别不系法耶。曰能了别。谓或拨无灭。若犹豫了别。若愚痴。若不如理所引了别。如是了别余不了别。诸无色界系见道所断心。能了别无色界系见道所断法耶。曰能了别。谓或执为尊。或执为胜。或执为上。或执第一。或执清净。或执解脱。或执出离。若贪若慢若痴。若不如理所引了别。亦能了别不系法耶。曰能了别。谓或拨无道。若犹豫了别。若愚痴。若不如理所引了别。如是了别余不了别。诸无色界系修所断心。能了别无色界系修所断法耶。曰能了别。谓若贪若慢若痴。若粗若苦若障。若静若妙若离。若如病若如痈。若如箭若恼害。若无常若苦。若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。若不如理所引了别。若非如理所引非不如理所引了别。亦能了别自地四种所断法耶。曰能了别。谓若粗若苦若障。若如病若如痈。若如箭若恼害。若无常若苦若空若无我。若于因谓因谓集谓生谓缘。若有因若有起。若有是处。若有是事。若如理所引了别。若非如理所引非不如理所引了别。亦能了别色界系五种所断法耶。曰能了别。谓若粗若苦若障若如理所引了别。亦能了别不系法耶。曰能了别。谓若于灭谓灭谓静谓妙谓离。若于道谓道谓如谓行谓出。若无常若空若无我。若有因若有起。若有是处。若有是事。若如理所引了别。如是了别余不了别

有十五心。谓欲界系有五心。色界系有五心。无色界系有五心。云何欲界系五心。谓欲界系见苦所断心。见集灭道修所断心。如欲界系五心。色界系无色界系五心亦尔。诸欲界系见苦所断心。若能了别欲界系见苦所断法。此中有几随眠。是所随增。若能了别所余诸法。此中有几随眠。是所随增。乃至诸无色界系修所断心。若能了别无色界系修所断法。此中有几随眠。是所随增。若能了别所余诸法。此中有几随眠是所随增。诸欲界系见苦所断心。若能了别欲界系见苦所断法。此中有欲界系见苦所断。一切随眠见集所断遍行随眠。是所随增。若能了别所余诸法。此中亦有欲界系见苦所断一切随眠见集所断遍行随眠。是所随增。诸欲界系见集所断心。若能了别欲界系见集所断法。此中有欲界系。见集所断一切随眠见苦所断遍行随眠。是所随增。若能了别所余诸法。此中亦有见集所断一切随眠见苦所断遍行随眠。是所随增。诸欲界系见灭所断心。若能了别欲界系见灭所断法。此中有欲界系见灭所断有漏缘随眠遍行随眠。是所随增。若能了别不系诸法。此中有欲界系见灭所断一切随眠遍行随眠。是所随增。诸欲界系见道所断心。若能了别欲界系见道所断法。此中有欲界系见道所断有漏缘随眠遍行随眠。是所随增。若能了别不系诸法。此中有欲界系见道所断一切随眠遍行随眠。是所随增。诸欲界系修所断心。若能了别欲界系修所断法。此中有欲界系修所断一切随眠遍行随眠。是所随增。若能了别所余诸法。此中有欲界系修所断一切随眠遍行随眠。是所随增。如欲界系心。色界系无色界系心亦尔

有十五心。谓欲界系有五心。色界系有五心。无色界系有五心。云何欲界系五心。谓欲界系见苦所断心。见集灭道修所断心。如欲界系五心。色界系无色界系五心亦尔。如是十五心。或善或不善。或有覆无记。或无覆无记。诸欲界系见苦所断善心。此能缘识。有几随眠。是所随增。诸欲界系见苦所断不善心。有覆无记心。无覆无记心。此能缘识。有几随眠。是所随增。如见苦所断心。见集灭道修所断心亦尔。如欲界系。色界系无色界系亦尔。诸欲界系见苦所断心。无有是善无覆无记。亦无此心能缘之识。唯有不善有覆无记。此能缘识。有欲界系三部随眠及色界系遍行随眠修所断随眠。是所随增。诸欲界系见集所断心。无有是善有覆无记无覆无记。亦无此心能缘之识。唯有不善。此能缘识。有欲界系三部随眠。及色界系遍行随眠修所断随眠。是所随增。诸欲界系见灭所断心。无有是善有覆无记无覆无记。亦无此心能缘之识。唯有不善。此能缘识。有欲界系三部随眠及欲界系见灭所断有漏缘随眠色界系遍行随眠修所断随眠。是所随增。诸欲界系见道所断心。无有是善有覆无记无覆无记。亦无此心能缘之识。唯有不善。此能缘识。有欲界系三部随眠及欲界系见道所断有漏缘随眠色界系遍行随眠修所断随眠。是所随增。诸欲界系修所断心。无有覆无记。亦无此心能缘之识。有善不善无覆无记。此能缘识。有欲界系三部随眠及色界系遍行随眠修所断随眠。是所随增诸色界系见苦所断心。无善不善无覆无记。亦无此心能缘之识。唯有有覆无记。此能缘识。有欲界系及色界系三部随眠无色界系遍行随眠修所断随眠。是所随增。诸色界系见集所断心。无善不善无覆无记。亦无此心能缘之识。唯有有覆无记。此能缘识。有欲界系及色界系三部随眠无色界系遍行随眠修所断随眠。是所随增。诸色界系见灭所断心。无善不善无覆无记。亦无此心能缘之识。唯有有覆无记。此能缘识。有欲界系及色界系三部随眠色界系见灭所断有漏缘随眠无色界系遍行随眠修所断随眠。是所随增。诸色界系见道所断心。无善不善无覆无记。亦无此心能缘之识。唯有有覆无记。此能缘识。有欲界系及色界系三部随眠色界系见道所断有漏缘随眠无色界系遍行随眠修所断随眠。是所断增。诸色界系修所断心。无有不善。亦无此心能缘之识。有善有覆无记无覆无记。此能缘识。有欲界系及色界系三部随眠无色界系遍行随眠修所断随眠。是所随增。诸无色界系见苦所断心。无善不善无覆无记。亦无此心能缘之识。唯有有覆无记。此能缘识。有三界系三部随眠。是所随增。诸无色界系见集所断心。无善不善无覆无记。亦无此心能缘之识。唯有有覆无记。此能缘识。有三界系三部随眠。是所随增。诸无色界系见灭所断心。无善不善无覆无记。亦无此心能缘之识。唯有有覆无记。此能缘识。有三界系三部随眠及无色界系见灭所断有漏缘随眠。是所随增。诸无色界系见道所断心。无善不善无覆无记。亦无此心能缘之识。唯有有覆无记。此能缘识。有三界系三部随眠及无色界系见道所断有漏缘随眠。是所随增。诸无色界系修所断心。无有不善。亦无此心能缘之识。有善有覆无记无覆无记。此能缘识。有三界系三部随眠。是所随增

说一切有部识身足论卷第十阿毗达磨识身足论卷第十一

        提婆设摩阿罗汉造

        三藏法师玄奘奉　诏译

    杂蕴第五之一嗢柁南颂

  杂蕴初染次所识　　色颇有受心世间
  无间缘增断善染　　分见缘界后了别

有六识身。谓眼识耳鼻舌身意识。五识身唯能起染。不能离染。意识身亦能起染。亦能离染。那落迦趣。傍生趣。祖域趣。断善根者。邪定性者。北拘卢洲。无想有情心。唯能起染不能离染。不定性者。正定性者。南赡部洲。东毗提诃。西瞿陀尼。诸有情心。亦能起染亦能离染。四大王众天三十三天。夜摩天。睹史多天。乐变化天。他化自在天。梵世间天。光音天。遍净天。无想有情。不摄广果天。及诸中有。诸无色处诸有情心。亦能起染亦能离染。诸随信行随法行心。唯能离染不能起染。诸信胜解见得身证心。亦能起染亦能离染。诸慧解脱俱分解脱心。不能起染不能离染。有说。此二亦能离染。就远分说

有六识身。谓眼识耳鼻舌身意识。诸有色法六识所识。唯有色法五识所识。诸无色法一识所识。唯无色法非识所识。诸有见法二识所识。唯有见法一识所识。诸无见法五识所识。唯无见法四识所识。诸有对法六识所识。唯有对法。五识所识。诸无对法一识所识。唯无对法非识所识。诸有漏法六识所识。唯有漏法五识所识。诸无漏法一识所识。唯无漏法。非识所识。诸有为法六识所识。唯有为法五识所识。诸无为法一识所识。唯无为法非识所识

有六识身。谓眼识耳鼻舌身意识。眼色为缘生于眼识。若诸青色可意乐俱。了别此青可意乐俱触受思想。此青色转可意乐俱。由此便能长养诸根。增益大种。眼色为缘生于眼识。若诸青色违意苦俱。了别此青违意苦俱触受思想。此青色转违意苦俱。由此便能损减诸根。破坏大种。眼色为缘生于眼识。若诸青色。非是可意。亦非违意。非苦乐俱。了别此青非是可意亦非违意非苦乐俱。触受思想此青色转。非是可意。亦非违意。非苦乐俱。由此诸根非养非损。大种亦尔非增非坏。如青色黄赤白色亦尔。如眼识耳鼻舌身识亦尔。意法为缘生于意识。若有诸法可意乐俱。了别此法可意乐俱。触受思想此诸法转可意乐俱。由此便能长养诸根。增益大种。意法为缘生于意识。若有诸法违意苦俱。了别此法违意苦俱。触受思想此诸法转违意苦俱。由此便能损减诸根。破坏大种。意法为缘生于意识。若有诸法。非是可意。亦非违意。非苦乐俱。了别此法非是可意亦非违意非苦乐俱。触受思想此诸法转非是可意。亦非违意。非苦乐俱。由此诸根非养非损。大种亦尔非增非坏

或有诸色有显无形。或有诸色有形无显。或有诸色有显有形。或有诸色无显无形。有显无形者。谓青黄赤白影光明闇空一显色。此即如彼青黄赤白。有形无显者。谓身表业。有显有形者。谓若诸色有显有形。无显无形者。谓若诸色无显无形

颇有此系心此系业。此心此业即此系果耶。曰有。如欲界系心欲界系业。此心此业欲界系果。色无色界系心。色无色界系业。色无色界系果。颇有此系心此系业。此心此业非此系果耶。曰有。如色界道欲界化化。作欲界事说欲界语。如色无色界道断结作证

诸受过去。此受一切已灭耶。曰诸受过去。此受一切已灭。或受已灭此受非过去。谓此生中受生已灭。诸受未来。此受一切未生耶。曰诸受未来。此受一切未生。或受未生此受非未来。谓此生中受定当生。诸受现在。此受一切现前耶。曰诸受现前。此受一切现在。或受现在此受非现前。谓此生中受生已灭。及此生中受定当生

有六种心。谓欲界系见所断心。修所断心。色界系见所断心。修所断心。无色界系见所断心。修所断心。颇有欲界系见所断心决定唯缘善法耶。唯缘不善法耶。唯缘有覆无记法耶。唯缘无覆无记法耶。如见所断心。修所断心亦尔。如欲界系。色界系无色界系亦尔

颇有欲界系见所断心决定唯缘善法耶。曰有。谓欲界系见灭道所断无漏缘随眠相应诸心。颇有欲界系见所断心决定唯缘。不善法耶。曰有。谓欲界系。见集所断不遍行随眠相应诸心。及欲界系见灭道所断有漏缘随眠相应诸心。颇有欲界系见所断心决定唯缘有覆无记法耶。无覆无记法耶。曰无。颇有欲界系修所断心决定唯缘善法耶。曰有。谓欲界系空空无愿无愿相应诸心。颇有欲界系修所断心决定唯缘不善法耶。有覆无记法耶。曰无。颇有欲界系修所断心决定唯缘无覆无记法耶。曰有。谓欲界系三识身。及欲界系无相无相相应诸心。颇有色界系见所断心决定唯缘善法耶。曰有。谓色界系见灭道所断无漏缘随眠相应诸心。颇有色界系见所断心决定唯缘不善法耶。曰无。颇有色界系见所断心决定唯缘有覆无记法耶。曰有。谓色界系见苦集所断不遍行随眠相应诸心。及色界系见灭道所断有漏缘随眠相应诸心。颇有色界系见所断心决定唯缘无覆无记法耶。曰无。颇有色界系修所断心决定唯缘善法耶。曰有。谓色界系空空无愿无愿相应诸心。颇有色界系修所断心决定唯缘不善法耶。有覆无记法耶。曰无。颇有色界系修所断心决定唯缘无覆无记法耶。曰有。谓色界系一识身。及色界系无相无相相应诸心。颇有无色界系见所断心决定唯缘善法耶。曰有。谓无色界系见灭道所断无漏缘随眠相应诸心。颇有无色界系见所断心决定唯缘不善法耶。曰无。颇有无色界系见所断心决定唯缘有覆无记法耶。曰有。谓无色界系见苦集所断不遍行随眠相应诸心。及无色界系见灭道所断有漏缘随眠相应诸心。颇有无色界系见所断心决定唯缘无覆无记法耶。曰无。颇有无色界系。修所断心决定唯缘善法耶。曰有。谓无色界系空空无愿无愿相应诸心。颇有无色界系修所断心决定唯缘不善法耶。有覆无记法耶。曰无。颇有无色界系修所断心决定唯缘无覆无记法耶。曰有。谓无色界系无相无相相应诸心

颇有诸法世间有漏随顺有取取蕴所摄。自内等起思择等生是妙善性欲界所系。唯圣者有不共一切愚夫异生。曰有。谓欲界系现观后边诸世俗智。颇有诸法世间有漏随顺有取取蕴所摄。自内等起思择等生是妙善性色界所系。唯圣者有不共一切愚夫异生。曰有。谓色界系现观后边诸世俗智。颇有诸法世间有漏随顺有取取蕴所摄自内等起思择等生无色界系。唯圣者有不共一切愚夫异生。曰有。谓灭尽定

颇有诸法世间有漏随顺有取取蕴所摄自内等起思择等生是妙善性欲界所系定无漏法等无间生缘无漏法。唯圣者有不共一切愚夫异生。曰有。谓欲界系空空无愿无愿无相无相。颇有诸法世间有漏随顺有取取蕴所摄自内等起思择等生是妙善性色界所系定无漏法等无间生缘无漏法。唯圣者有不共一切愚夫异生。曰有。谓色界系空空无愿无愿无相无相。颇有诸法世间有漏随顺有取取蕴所摄自内等起思择等生是妙善性无色界系定无漏法等无间生缘无漏法。唯圣者有不共一切愚夫异生。曰有。谓无色界系空空无愿无愿无相无相

有十二心。谓欲界系善心。不善心。有覆无记心。无覆无记心。色界系善心。有覆无记心。无覆无记心。无色界系善心。有覆无记心。无覆无记心。及学心。无学心。欲界系善心等无间生几心。乃至无学心等无间生几心

欲界系善心等无间生九心。不善心欲界系有覆无记心等无间生四心。无覆无记心等无间生七心。色界系善心等无间生十一心。有覆无记心无覆无记心等无间生六心。无色界系善心等无间生九心。有覆无记心等无间生七心。无覆无记心等无间生六心。学心等无间生五心。无学心等。无间生四心

有十二心。谓欲界系善心。不善心。有覆无记心。无覆无记心。色界系善心。有覆无记心。无覆无记心。无色界系善心。有覆无记心。无覆无记心。及学心。无学心。欲界系善心。于欲界系善心。由几缘故。说能为缘。欲界系善心。乃至于无学心。由几缘故。说能为缘乃至无学心。于无学心。由几缘故。说能为缘。无学心。于欲界系善心乃至学心。由几缘故。说能为缘。欲界系善心。于欲界系善心。由因缘等无间缘所缘缘增上缘故。说能为缘。于不善心。欲界系有覆无记心。由等无间缘所缘缘增上缘故。说能为缘。于欲界系无覆无记心。由因缘等无间缘所缘缘增上缘故。说能为缘。于色界系善心。由等无间缘所缘缘增上缘故。说能为缘。于色界系有覆无记心。由等无间缘增上缘故。说能为缘。于色界系无覆无记心。由所缘缘增上缘故。说能为缘。于无色界系善心无覆无记心。由一增上缘故。说能为缘。于无色界系有覆无记心。由等无间缘增上缘故。说能为缘。于学心无学心。由等无间缘所缘缘增上缘故。说能为缘。不善心。于不善心。由因缘等无间缘所缘缘增上缘故。说能为缘。于欲界系有覆无记心无覆无记心。由因缘等无间缘所缘缘增上缘故。说能为缘。于色界系善心无覆无记心。由所缘缘增上缘故。说能为缘。于色界系有覆无记心及无色界系一切心。由一增上缘故。说能为缘。于学心无学心。由所缘缘增上缘故。说能为缘。于欲界系善心。由等无间缘所缘缘增上缘故。说能为缘。欲界系有覆无记心。于欲界系有覆无记心。由因缘等无间缘所缘缘增上缘故。说能为缘。于欲界系无覆无记心。由等无间缘所缘缘增上缘故。说能为缘。于色界系善心无覆无记心。由所缘缘增上缘故。说能为缘。于色界系有覆无记心及无色界系一切心。由一增上缘故。说能为缘。于学心无学心。由所缘缘增上缘故。说能为缘。于欲界系善心。由等无间缘所缘缘增上缘故。说能为缘。于不善心。由因缘等无间缘所缘缘增上缘故。说能为缘。欲界系无覆无记心。于欲界系无覆无记心。由因缘等无间缘所缘缘增上缘故。说能为缘。于色界系善心。由等无间缘所缘缘增上缘故。说能为缘。于色界系有覆无记心。由等无间缘增上缘故。说能为缘。于色界系无覆无记心。由所缘缘增上缘故。说能为缘。于无色界系善心无覆无记心。由一增上缘故。说能为缘。于无色界系有覆无记心。由等无间缘增上缘故。说能为缘。于学心无学心。由所缘缘增上缘故。说能为缘。于欲界系善心不善心有覆无记心。由等无间缘所缘缘增上缘故。说能为缘。色界系善心。于色界系善心。由因缘等无间缘所缘缘增上缘故。说能为缘。于色界系有覆无记心。由等无间缘所缘缘增上缘故。说能为缘。于色界系无覆无记心。由因缘等无间缘所缘缘增上缘故。说能为缘。于无色界系善心由等无间缘所缘缘增上缘故。说能为缘。于无色界系有覆无记心。由等无间缘增上缘故。说能为缘。于无色界系无覆无记心。由一增上缘故。说能为缘。于学心无学心。由等无间缘所缘缘增上缘故。说能为缘。于欲界系善心不善心。由等无间缘所缘缘增上缘故。说能为缘。于欲界系有覆无记心无覆无记心。由等无间缘增上缘故。说能为缘。色界系有覆无记心。于色界系有覆无记心。由因缘等无间缘所缘缘增上缘故。说能为缘。于色界系无覆无记心。由等无间缘所缘缘增上缘故。说能为缘。于无色界系善心。由所缘缘增上缘故。说能为缘。于无色界系有覆无记心无覆无记心。由一增上缘故。说能为缘。于学心无学心。由所缘缘增上缘故。说能为缘。于欲界系善心不善心。由等无间缘所缘缘增上缘故。说能为缘。于欲界系有覆无记心。由等无间缘增上缘故。说能为缘。于欲界系无覆无记心。由一增上缘故。说能为缘。于色界系善心。由等无间缘所缘缘增上缘故。说能为缘。色界系无覆无记心。于色界系无覆无记心。由因缘等无间缘所缘缘增上缘故。说能为缘。于无色界系善心。由所缘缘增上缘故。说能为缘。于无色界系有覆无记心。由等无间缘增上缘故。说能为缘。于无色界系无覆无记心。由一增上缘故。说能为缘。于学心无学心。由所缘缘增上缘故。说能为缘。于欲界系善心。由所缘缘增上缘故。说能为缘。于不善心。由等无间缘所缘缘增上缘故。说能为缘。于欲界系有覆无记心。由等无间缘增上缘故。说能为缘。于欲界系无覆无记心。由一增上缘故。说能为缘。于色界系善心有覆无记心。由等无间缘所缘缘增上缘故。说能为缘。无色界系善心。于无色界系善心。由因缘等无间缘所缘缘增上缘故。说能为缘。于无色界系有覆无记心。由等无间缘所缘缘增上缘故说能为缘。于无色界系无覆无记心。由因缘等无间缘所缘缘增上缘故。说能为缘。于学心无学心。由等无间缘所缘缘增上缘故。说能为缘。于欲界系善心。由所缘缘增上缘故。说能为缘。于不善心。由等无间缘所缘缘增上缘故。说能为缘。于欲界系有覆无记心。由等无间缘增上缘故。说能为缘。于欲界系无覆无记心。由一增上缘故。说能为缘。于色界系善心有覆无记心。由等无间缘所缘缘增上缘故。说能为缘。于色界系无覆无记心。由一增上缘故。说能为缘。无色界系有覆无记心。于无色界系有覆无记心。由因缘等无间缘所缘缘增上缘故。说能为缘。于无色界系无覆无记心。由等无间缘所缘缘增上缘故。说能为缘。于学心无学心。由所缘缘增上缘故。说能为缘。于欲界系善心。由所缘缘增上缘故。说能为缘。于不善心。由等无间缘所缘缘增上缘故。说能为缘。于欲界系有覆无记心。由等无间缘增上缘故。说能为缘。于欲界系无覆无记心。由一增上缘故。说能为缘。于色界系善心有覆无记心。由等无间缘所缘缘增上缘故。说能为缘。于色界系无覆无记心。由一增上缘故。说能为缘。于无色界系善心。由等无间缘所缘缘增上缘故。说能为缘。无色界系无覆无记心。于无色界系无覆无记心。由因缘等无间缘所缘缘增上缘故。说能为缘。于学心无学心。由所缘缘增上缘故。说能为缘。于欲界系善心。由所缘缘增上缘故。说能为缘。于不善心。由等无间缘所缘缘增上缘故。说能为缘。于欲界系有覆无记心。由等无间缘增上缘故。说能为缘。于欲界系无覆无记心。由一增上缘。故说能为。缘于色界系善心。由所缘缘增上缘故。说能为缘。于色界系有覆无记心。由等无间缘所缘缘增上缘故。说能为缘。于色界系无覆无记心。由一增上缘故。说能为缘。于无色界系善心有覆无记心。由等无间缘所缘缘增上缘故。说能为缘。学心于学心。由因缘等无间缘所缘缘增上缘故。说能为缘。于无学心。亦由因缘等无间缘所缘缘增上缘故。说能为缘。于欲界系善心。由等无间缘所缘缘增上缘故。说能为缘。于不善心。由所缘缘增上缘故。说能为缘。于欲界系有覆无记心无覆无记心。由一增上缘故。说能为缘。于色界系善心。由等无间缘所缘缘增上缘故。说能为缘。于色界系有覆无记心。由所缘缘增上缘故。说能为缘。于色界系无覆无记心。由一增上缘故说能为缘。于无色界系善心。由等无间缘所缘缘增上缘故。说能为缘。于无色界系有覆无记心。由所缘缘增上缘故。说能为缘。于无色界系无覆无记心。由一增上缘故。说能为缘。无学心于无学心。由因缘等无间缘所缘缘增上缘故。说能为缘。于欲界系善心。由等无间缘所缘缘增上缘故。说能为缘。于不善心。由所缘缘增上缘故。说能为缘。于欲界系有覆无记心无覆无记心。由一增上缘故。说能为缘。于色界系善心。由等无间缘所缘缘增上缘故。说能为缘。于色界系有覆无记心。由所缘缘增上缘故。说能为缘。于色界系无覆无记心。由一增上缘故。说能为缘。于无色界系善心。由等无间缘所缘缘增上缘故。说能为缘。于无色界系有覆无记心。由所缘缘增上缘故。说能为缘。于无色界系无覆无记心。由一增上缘故。说能为缘。于学心。由所缘缘增上缘故。说能为缘

云何增上缘。谓眼色为缘生眼识。此眼识以眼为增上缘。亦以色耳声及耳识。鼻香及鼻识。舌味及舌识。身触及身识。意法及意识。若此相应法。若此俱有法。若有色无色。若有见无见。若有对无对。若有漏无漏。若有为无为。如是一切法皆为增上缘。唯除自性。如是耳鼻舌身意法为缘生意识。此意识以意为增上缘。亦以法眼色及眼识。耳声及耳识。鼻香及鼻识。舌味及舌识。身触及身识。若此相应法。若此俱有法。若有色无色。若有见无见。若有对无对。若有漏无漏。若有为无为。如是一切法皆为增上缘。唯除自性。是名增上缘

诸断善根。彼云何断。何行相断。谓如有一。害母害父。害阿罗汉。破和合僧。以勃恶心出如来血能断善根。诸以故思害母命者。彼云何害。何行相害。谓如有一。具贪嗔痴其性猛利。彼由猛利贪嗔痴故。乐着博戏。嗜酒耽淫。好恶朋友好恶伴侣。染习种种诸放逸处。其母专志摄录遮制。告言子子。汝今勿复乐着博戏嗜酒耽淫好恶朋友好恶伴侣染习种种诸放逸处。汝今勿应往趣地狱傍生饿鬼。汝今勿应堕诸恶处生诸恶趣。由母专志摄录遮制。便于母所起猛利嗔。不忍不信作是怨言。苦哉荼毒。云何我母制我所爱博戏酒淫朋友伴侣。若复于我作如此类不饶益事。我当决定害其命根。如是能断。彼于异时所发起嗔。不忍不信转复猛利坚固炽盛。由所起嗔不忍不信展转猛利坚固炽盛。复于后时发起如是修断嗔缠。由此嗔缠之所缠故。便起故思害其母命。彼由如是身业语业。意思悕求愿行种类。说名邪性。由此弃舍先所成就诸想等想。假立言说。住不定聚不定种性。由此获得先未成就。诸想等想。假立言说。住邪定聚邪定种性。获得五种补特伽罗。和杂种类助伴种类。恶众同分处得事得生长处得。谓害母害父。害阿罗汉。破和合僧。以勃恶心出如来血。诸以故思害母命者。彼如是害。此行相害。如说害母害父亦尔。诸害声闻阿罗汉命。彼云何害。何行相害。谓如有一。于其声闻阿罗汉人所有衣钵。或随一一沙门命缘如法众具。极生贪染系心不舍。作是思惟。我今要当随分窃夺。若彼因此。于我损害。缚录退黜呵责毁骂。令堕下贱不尊贵处。我当决定害其命根。如是能断。又如声闻阿罗汉人处大众中。于自言论显照施设成立开示。于他言论破坏遮止。其中所有或诸沙门。或婆罗门。怀怨害见朋怨害论。作是怨言。苦哉荼毒。云何如是名类沙门。处大众中。于自言论显照施设成立开示。于他言论破坏遮止。若复于我作如此类不饶益事。我当决定害其命根。如是能断。彼于异时所发起嗔不忍不信。转复猛利坚固炽盛。由所起嗔不忍不信展转猛利坚固炽盛。复于后时发起如是修断嗔缠。由此嗔缠之所缠故。便起故思害彼声闻阿罗汉命。彼由如是身业语业意思悕求愿行种类。说名邪性。由此弃舍先所成就诸想等想。假立言说。住不定聚不定种性。由此获得先未成就诸想等想。假立言说。住邪定聚邪定种性。获得五种补特伽罗。和杂种类助伴种类。恶众同分处得事得生长处得。谓害母害父。害阿罗汉。破和合僧。以勃恶心出如来血。诸害声闻阿罗汉命。彼如是害。此行相害。诸破如来声闻弟子和合僧众。彼云何破。何行相破。谓如有一。于非法法想。于非毗柰耶毗柰耶想。彼不覆此想。不覆此忍。不覆如是乐慧观见。于其如来声闻弟子和合僧众。教示劝诲。令其欢悦修学受持。言是正法是毗柰耶是大师教。具寿。汝今于是正法是毗柰耶是大师教。应当许可忍受开显。应起受筹。若以彼身为其第五。起受筹者。下极此数。补特伽罗。虽言能破如来弟子和合僧众。然不能生一劫住罪。复如有一。于法非法想。于毗柰耶非毗柰耶想。彼不覆此想。不覆此忍。不覆如是乐慧观见。于其如来声闻弟子和合僧众。教示劝诲。令其欢悦修学受持。言非正法非毗柰耶非大师教。具寿。汝今于是非法非毗柰耶非大师教。应当许可忍受开显。应起受筹。若以彼身为其第五。起受筹者。下极此数。补特伽罗。虽言能破如来弟子和合僧众。然不能生一劫住罪。复如有一。于非法非法想。于非毗柰耶非毗柰耶想。彼隐覆此想。隐覆此忍。隐覆如是乐慧观见。于其如来声闻弟子和合僧众。教示劝诲。令其欢悦修学受持。言是正法是毗柰耶是大师教。具寿。汝今于是正法是毗柰耶是大师教。应当许可忍受开显。应起受筹。若以彼身。为其第五。起受筹者。下极此数。补特伽罗。应言能破如来弟子和合僧众。亦能生于一劫住罪。复如有一。于法法想。于毗柰耶毗柰耶想。彼隐覆此想。隐覆此忍。隐覆如是乐慧观见。于其如来声闻弟子和合僧众。教示劝诲。令其欢悦修学受持。言非正法非毗柰耶非大师教。具寿。汝今于是非法非毗柰耶非大师教。应当许可忍受开显。应起受筹。若以彼身。为其第五。起受筹者。下极此数。补特伽罗。应言能破如来弟子和合僧众。亦能生于一劫住罪。彼由如是身业语业意思悕求愿行种类。说名邪性。由此弃舍先所成就诸想等想。假立言说。住不定聚不定种性。由此获得先未成就诸想等想。假立言说。住邪定聚邪定种性。获得五种补特伽罗和杂种类助伴种类。恶众同分处得事得生长处得。谓害母害父。害阿罗汉。破和合僧。以勃恶心出如来血。诸破如来声闻弟子和合僧众。彼如是破。此行相破。诸勃恶心出如来血。彼云何出。何行相出。谓如如来处大众中。于自言论显照施设成立开示。于他言论破坏遮止。其中所有。或诸沙门。或婆罗门。怀怨害见明怨害论。作是怨言。苦哉荼毒。云何如是名类沙门。处大众中。于自言论显照施设成立开示。于他言论破坏遮止。若复于我作如此类不饶益事。我当决定害其命根。如是能断。彼于异时所发起嗔不忍不信。转复猛利坚固炽盛。由所起嗔不忍不信展转猛利坚固炽盛。复于后时发起如是修断嗔缠。由此嗔缠。之所缠故。便起故思。我今决定害如来命。然诸如来。法尔无有能害命者。唯可有能以勃恶心出如来血。彼由如是身业语业意思悕求愿行种类。说名邪性。由此弃舍先所成就诸想等想。假立言说。住不定聚不定种性。由此获得先未成就诸想等想。假立言说。住邪定聚邪定种性。获得五种补特伽罗和杂种类助伴种类。恶众同分处得事得生长处得。谓害母害父。害阿罗汉。破和合僧以勃恶心出如来血。诸勃恶心出如来血。彼如是出。此行相出

说一切有部识身足论卷第十一阿毗达磨识身足论卷第十二

        提婆设摩阿罗汉造

        三藏法师玄奘奉　诏译

    杂蕴第五之二

诸断善根。彼云何断。何行相断。谓如有一。故思害母害父命已。无随愧悔。复如有一。故思害母害父命已。有随愧悔。如是二人师诸沙门。或婆罗门嗢羯洛迦。或彼徒类。执无有见。立无有论。言无有因。言无有作。施设彼彼善业恶业。皆断坏者。数往请问。云何为善。云何不善。云何有罪。云何无罪。作何事已成好非恶。彼由亲近承事供养如是师故。于所作罪未生愧悔令其不生。已生愧悔令速除遣。作如是言。杀生愚妄虚无有果。无义无起。无味无利。无有杀生。无有杀生所感异熟。如是不与取欲邪行。妄语离间语粗恶语绮语。贪嗔邪见。皆是愚妄虚无有果。无义无起。无味无利。无邪见等。无邪见等所感异熟。彼于此事深生爱乐忍受开显。以于此事深生爱乐忍受开显。便说是人履于左道。谓邪见邪思惟邪语邪业邪命邪勤邪念邪定。彼由如是履左道故。三种善根渐渐损减微薄间缺。三不善根渐渐增长猛利炽盛。三种妙行渐渐损减微薄间缺。三种恶行渐渐增长猛利炽盛。十善业道渐渐损减微薄间缺。十恶业道渐渐增长猛利炽盛。八正右道渐渐损减微薄间缺。八邪左道渐渐增长猛利炽盛。彼由杀生不与取欲邪行妄语离间语粗恶语绮语贪嗔邪见转增长故。多住不寂静。多住不律仪。虽于少时生起微劣善心心法正见俱行。然复种种恶不善法。多分现行多居左品。如度夏热入秋凉时。夜分垂云叆叇冥暗。震雷掣电暂发光明。才睹众色速还隐没。如是彼人多住不寂静。多住不律仪。虽于少时生起微劣善心心法正见俱行。然复种种恶不善法。多分现行多居左品。又如有人春末夏初。热渴所闷。热风所恼。入清凉池濯清冷水。沐浴饮已速疾还出。其身所有粗渧皆落。唯有微渧住毛孔中。如是彼人多住不寂静。多住不律仪。虽于少时生起微劣善心心法正见俱行。然复种种恶不善法。多分现行多居左品。彼于后时亦能伤害尊胜生命。无随愧悔。究竟拨无一切善恶业果异熟。由彼伤害尊胜生命无随愧悔。究竟拨无一切善恶业果异熟。便说是人已断三界所有善根。谓欲界系。及色界系。无色界系。当知如是补特伽罗。于现法中。不能更续所有善根。决定当于地狱死时。或于生时续诸善根。问若杀如是补特伽罗。若杀蚁卵折脚蚁子。何者罪大。答若以等缠异熟亦等。复有说者。若杀蚁卵折脚蚁子。所得罪大。非杀如是补特伽罗。何以故。以诸蚁卵折脚蚁子不断善根。如是色类补特伽罗断善根故。彼由如是身业语业意思希求愿行种类。说名邪性。由此弃舍先所成就诸想等想假立言说。住不定聚不定种性。由此获得先未成就诸想等想。假立言说。住邪定聚邪定种性。获得五种补特伽罗和杂种类助伴种类。恶众同分处得事得生长处得。谓害母害父。害阿罗汉。破和合僧。以勃恶心出如来血。诸断善根。彼如是断。此行相断。谓有一类补特伽罗。由欲界系诸染污心现在前故。所有善根或舍而不得。或得而不舍。或亦舍亦得。或不舍不得。舍而不得者。谓善根断时。及已离欲界贪异生。由欲界缠退。色无色界系所有善根舍而不得。已离欲界贪异生。欲界缠退。色界系善根舍而不得。已离色界贪有学。欲界缠退。无色界系善根舍而不得。如是名为舍而不得。得而不舍者。谓迷惑心续善根时。亦舍亦得者。谓无色界没生欲界时。舍无色界系善根。得欲界系善根。从色界没生欲界时。舍色界系善根。得欲界系善根。诸阿罗汉欲界缠退。舍无色界系及无学善根。得学善根。退无学心住有学心。如是名为亦舍亦得。不舍不得者。谓不断善根。从欲界没还生欲界。如是名为不舍不得。复有一类补特伽罗。由色界系诸染污心现在前故。所有善根或舍而不得。或亦舍亦得。或不舍不得。舍而不得者。谓已离色界贪。有学异生色界缠退。无色界系善根舍而不得。从欲界没生色界时。欲界系善根舍而不得。如是名为舍而不得。亦舍亦得者。谓无色界没生色界时。舍无色界系善根。得色界系善根。诸阿罗汉色界缠退。舍无色界系及无学善根。得学善根。退无学心住有学心。如是名为亦舍亦得。不舍不得者。谓色界没还生色界。如是名为不舍不得。复有一类补特伽罗。由无色界系诸染污心现在前故。所有善根或舍而不得。或亦舍亦得。或不舍不得。舍而不得者。谓从欲界没生无色界。诸欲界系及色界系善根舍而不得。从色界没生无色界。诸色界系善根舍而不得。如是名为舍而不得。亦舍亦得者。谓阿罗汉无色缠退。舍无学善根。得有学善根。退无学心住有学心。如是名为亦舍亦得。不舍不得者。谓无色界没还生无色界。如是名为不舍不得

又十二处。谓眼处色处。耳处声处。鼻处香处。舌处味处。身处触处。意处法处。云何眼处。谓诸眼处。已见色今见色当见色。或复所余彼同分眼处。云何彼同分眼处。谓彼同分眼处。或过去或未来或现在。云何过去彼同分眼处。谓诸眼处不见色已灭。云何未来彼同分眼处。谓诸眼处或在未来。定不当生。或有当生不见色当灭。云何现在彼同分眼处。谓诸眼处。不见色今灭。云何色处。谓诸色处。眼已见眼今见眼当见。或复所余彼同分色处。云何彼同分色处。谓彼同分色处。或过去或未来或现在。云何过去彼同分色处。谓诸色处眼不见已灭。云何未来彼同分色处。谓诸色处。或在未来定不当生。或有当生眼不见当灭。云何现在彼同分色处。谓诸色处眼不见今灭。如眼处色处。耳处声处鼻处香处舌处味处身处触处亦尔。云何意处。谓诸意处已了别法今了别法当了别法。或复所余彼同分意处。云何彼同分意处。谓诸意处在未来世定不当生。无有过去现在彼同分意处。无有彼同分法处。过去眼于色有二句。谓过去眼。于色或已见非今见非当见。或非已见非今见非当见。未来眼。于色有三句。谓未来眼。于色或非已见非今见非当见。或非已见非今见是当见。或非已见非今见。或当见或不当见。现在眼。于色有十二句。谓现在眼。于色或已见非今见非当见。或今见非已见非当见。或当见非已见非今见。或已见今见非当见。或已见当见非今见。或今见当见非已见。或已见非今见。或当见或不当见。或今见非已见。或当见或不当见。或非已见非今见。或当见或不当见。或已见今见。或当见或不当见。或已见今见当见。或非已见非今见非当见

颇眼为缘中为缘上。此缘何缘。即缘下眼。曰有。谓中与上颇眼为缘初非此缘。何非此缘。即业大种。曰有。谓下中上。如眼耳鼻舌身亦尔。颇意为缘中为缘上。此缘何缘。即缘下意。曰有。谓中与上。颇意为缘初非此缘。何非此缘。谓业烦恼。曰有。谓下中上

有十八界。谓眼界色界眼识界。耳界声界耳识界。鼻界香界鼻识界。舌界味界舌识界。身界触界身识界。意界法界意识界。颇眼界已断已遍知。色界亦尔耶。设色界已断已遍知。眼界亦尔耶。颇眼界已断已遍知。乃至意识界亦尔耶。设意识界已断已遍知。眼界亦尔耶。颇乃至法界已断已遍知。意识界亦尔耶。设意识界已断已遍知。法界亦尔耶

颇眼界已断已遍知。色界亦尔耶。曰如是。设色界已断已遍知。眼界亦尔耶。曰如是。如眼界望色界。望耳界声界鼻界舌界身界触界亦尔。颇眼界已断已遍知。眼识界亦尔耶。曰若眼界已断已遍知。眼识界亦尔。或眼识界已断已遍知非眼界。谓已离梵世贪。未离上贪。如眼界望眼识界。望耳识界身识界亦尔。颇眼界已断已遍知。香界亦尔耶。曰若眼界已断已遍知。香界亦尔。或香界已断已遍知非眼界。谓已离欲界贪。未离上贪。如眼界望香界。望味界鼻识界舌识界亦尔。颇眼界已断已遍知。意界亦尔耶。曰若意界已断已遍知。眼界亦尔。或眼界已断已遍知。非意界。谓已离色界贪。未离上贪。如眼界望意界。望法界意识界亦尔。如眼界如是广说。色界耳界声界鼻界舌界身界触界。广说亦尔。颇眼识界已断已遍知。耳识界亦尔耶。曰如是。设耳识界已断已遍知。眼识界亦尔耶。曰如是。如眼识界望耳识界。望身识界亦尔。颇眼识界已断已遍知。香界亦尔耶。曰若眼识界已断已遍知。香界亦尔。或香界已断已遍知。非眼识界。谓已离欲界贪。未离梵世贪。如眼识界望香界。望味界鼻识界舌识界亦尔。颇眼识界已断已遍知。意界亦尔耶。曰若意界已断已遍知。眼识界亦尔。或眼识界已断已遍知。非意界。谓已离梵世贪。未离上贪。如眼识界望意界。望法界意识界亦尔。如眼识界如是广说。耳识界身识界广说亦尔。颇香界已断已遍知。味界亦尔耶。曰如是。设味界已断已遍知。香界亦尔耶。曰如是。如香界望味界。望鼻识界舌识界亦尔。颇香界已断已遍知。意界亦尔耶。曰若意界已断已遍知。香界亦尔。或香界已断已遍知。非意界。谓已离欲界贪。未离上贪。如香界望意界。望法界意识界亦尔。如香界如是广说。味界鼻识界舌识界广说亦尔。颇意界已断已遍知。法界亦尔耶。曰如是。设法界已断已遍知。意界亦尔耶。曰如是。如意界望法界。望意识界亦尔。颇法界已断已遍知。意识界亦尔耶。曰如是。设意识界已断已遍知。法界亦尔耶。曰如是

有十二心谓欲界系善心。不善心。有覆无记心。无覆无记心。色界系善心。有覆无记心。无覆无记心。无色界系善心。有覆无记心。无覆无记心。及学心。无学心。如是十二心。或过去或未来或现在。过去欲界系善心有四句。谓或已了别非今了别非当了别。或已了别当了别非今了别。或已了别今了别非当了别。或已了别今了别当了别。已了别非今了别非当了别者。谓色无色界生长诸圣补特伽罗。已了别当了别非今了别者。谓已断善根补特伽罗。及色无色界生长异生。已了别今了别非当了别者。谓欲界生长。趣色无色界。诸不还者。住最后善心。已了别今了别当了别者。谓欲界生长。不断善根。住自性位。如过去未来亦尔。欲界系未曾得善心有四句。或非已了别非今了别非当了别。或非已了别非今了别当了别。或非已了别非今了别或当了别或不当了别。或今了别当了别非已了别。非已了别非今了别非当了别者。谓先未曾得定不当得。非已了别非今了别当了别者。谓先未曾得决定当得。非已了别非今了别或当了别。或不当了别者。谓先未曾得或当得或不当得。今了别当了别非已了别者。谓先未曾得最初现前。现在欲界系善心有三句。或已了别今了别非当了别。或非已了别今了别当了别。或已了别今了别当了别。已了别今了别非当了别者。谓欲界生长。趣色无色界。诸不还者住最后善心。非已了别今了别当了别者。谓先未曾得最初现前。已了别今了别当了别者。谓先曾得今现在前。过去不善心有七句。或已了别非今了别非当了别。或已了别非今了别当了别。或已了别非今了别。或当了别或不当了别。或已了别今了别非当了别。或已了别。今了别当了别。或已了别今了别或当了别或不当了别。或已了别今了别当了别。已了别非今了别非当了别者。谓已离欲界贪。从离欲贪定不当退。已了别非今了别当了别者。谓已离欲界贪。从离欲贪。决定当退。已了别非今了别。或当了别或不当了别者。谓已离欲界贪从离欲贪。或当退或不当退。已了别今了别非当了别者。谓住离欲贪。无间道中得离欲贪。从离欲贪定不当退。已了别今了别当了别者。谓住离欲贪无间道中得离欲贪。从离欲贪决定当退。已了别今了别或当了别或不当了别者。谓住离欲贪。无间道中得离欲贪。从离欲贪。或当退或不当退。已了别今了别当了别者。谓未离欲界贪。住自性位。如过去未来亦尔。现在不善心有一句。即已了别今了别当了别。谓不善心正现在前。过去欲界系有覆无记心有七句。或已了别非今了别非当了别。或已了别非今了别当了别。或已了别非今了别。或当了别或不当了别。或已了别今了别非当了别。或已了别今了别当了别。或已了别今了别或当了别或不当了别。或已了别今了别当了别。已了别非今了别非当了别者。谓已离欲界贪异生。从离欲贪定不当退。及未离欲界贪圣者。现观边苦法智已生。已了别非今了别当了别者。谓已离欲界贪异生。从离欲贪决定当退。已了别非今了别或当了别或不当了别者。谓已离欲界贪异生。从离欲贪或当退或不当退。已了别今了别非当了别者。谓诸异生住离欲贪。无间道中得离欲贪。从离欲贪定不当退。及未离欲界贪圣者。现观边苦法智未生。已了别今了别当了别者。谓诸异生住离欲贪。无间道中。得离欲贪。从离欲贪决定当退。已了别今了别或当了别或不当了别者。谓诸异生住离欲贪。无间道中得离欲贪。从离欲贪或当退或不当退。已了别今了别当了别者。谓未离欲界贪异生。住自性位。如过去未来亦尔。现在欲界系有覆无记心有一句。即已了别今了别当了别。谓诸异生。欲界系有覆无记心。正现在前。过去欲界系无覆无记心有四句。或已了别非今了别非当了别。或已了别非今了别当了别。或已了别今了别非当了别。或已了别今了别当了别。已了别非今了别非当了别者。谓无色界生长诸圣补特伽罗。已了别非今了别当了别者。谓无色界生长异生。已了别今了别非当了别者。谓欲界色界生长。趣无色界。诸不还者住最后心。已了别今了别当了别者。谓欲界色界生长。住自性位。如过去未来亦尔。欲界系未曾得无覆无记心有四句。或非已了别非今了别非当了别。或非已了别非今了别当了别。或非已了别非今了别或当了别或不当了别。或非已了别今了别当了别。非已了别非今了别非当了别者。谓先未曾得定不当得。非已了别非今了别当了别者。谓先未曾得决定当得。非已了别非今了别或当了别或不当了别者。谓先未曾得或当得或不当得。非已了别今了别当了别者。谓先未曾得最初现前。现在欲界系无覆无记心有三句。或已了别今了别非当了别。或非已了别今了别当了别。或已了别今了别当了别。已了别今了别非当了别者。谓欲界色界生长。趣无色界诸不还者。住最后无覆无记心。非已了别今了别当了别者。谓先未曾得最初现前。已了别今了别当了别者。谓先曾得今现在前。过去色界系善心有四句。或已了别非今了别非当了别。或已了别非今了别当了别。或已了别今了别非当了别。或已了别今了别当了别。已了别非今了别非当了别者。谓无色界生长。诸圣补特伽罗。已了别非今了别当了别者。谓欲界生长。未得色界善心。及无色界生长异生。已了别今了别非当了别者。谓欲界色界生长。趣无色界。诸不还者。住最后心。已了别今了别当了别者。谓欲界生长。得色界善心。住自性位。及色界生长。住自性位。如过去未来亦尔。色界系未曾得善心有四句。或非已了别非今了别非当了别。或非已了别非今了别当了别。或非已了别非今了别。或当了别或不当了别。或非已了别今了别当了别。非已了别非今了别非当了别者。谓先未曾得。定不当得。非已了别非今了别当了别者。谓先未曾得。决定当得。非已了别非今了别。或当了别或不当了别者。谓先未曾得。或当得或不当得。非已了别今了别当了别者。谓先未曾得最初现前。现在色界系善心有三句。或已了别今了别非当了别。或非已了别今了别当了别。或已了别今了别当了别。已了别今了别非当了别者。谓色界生长。趣无色界诸不还者住最后善心。非已了别今了别当了别者。谓先未曾得最初现前。已了别今了别当了别者。谓先曾得。今现在前。过去色界系有覆无记心有七句。或已了别非今了别非当了别。或已了别非今了别当了别。或已了别非今了别。或当了别。或不当了别。或已了别今了别非当了别。或已了别今了别当了别。或已了别今了别或当了别或不当了别。或已了别今了别当了别。已了别非今了别非当了别者。谓已离色界贪。从离色贪。定不当退。已了别非今了别当了别者。谓已离色界贪。从离色贪决定当退。已了别非今了别或当了别或不当了别者。谓已离色界贪。从离色贪。或当退或不当退。已了别今了别非当了别者。谓住离色贪无间道中。得离色贪。从离色贪定不当退。已了别今了别当了别者。谓住离色贪。无间道中。得离色贪。从离色贪决定当退。已了别今了别或当了别或不当了别者。谓住离色贪。无间道中。得离色贪。从离色贪。或当退或不当退。已了别今了别当了别者。谓未离色界贪住自性位。如过去未来亦尔。现在色界系有覆无记心有一句。即已了别今了别当了别。谓色界系有覆无记心正现在前。过去色界系无覆无记心有四句。或已了别非今了别非当了别。或已了别非今了别当了别。或已了别今了别非当了别。或已了别今了别当了别。已了别非今了别非当了别者。谓无色界生长。诸圣补特伽罗。已了别非今了别当了别者。谓欲界生长未离欲界贪。及无色界生长异生。已了别今了别非当了别者。谓欲界色界生长趣无色界诸不还者。住最后心。已了别今了别当了别者。谓欲界生长已离欲界贪。及色界生长住自性位。如过去未来亦尔。色界系未曾得无覆无记心有四句。或非已了别非今了别非当了别。或非已了别非今了别当了别。或非已了别非今了别或当了别或不当了别。或非已了别今了别当了别。非已了别非今了别非当了别者。谓先未曾得定不当得。非已了别非今了别当了别者。谓先未曾得决定当得。非已了别非今了别或当了别或不当了别者。谓先未曾得。或当得或不当得。非已了别今了别当了别者。谓先未曾得最初现前。现在色界系无覆无记心有三句。或已了别今了别非当了别。或非已了别今了别当了别。或已了别今了别当了别。已了别今了别非当了别者。谓色界生长。趣无色界诸不还者。住最后无覆无记心。非已了别今了别当了别者。谓先未曾得最初现前。已了别今了别当了别者。谓先曾得今现在前。过去无色界系善心有二句。或已了别非今了别当了别。或已了别今了别当了别。已了别非今了别当了别者。谓未得无色界善心。已了别今了别当了别者。谓已得无色界善心。如过去未来亦尔。无色界系未曾得善心有四句。或非已了别非今了别非当了别。或非已了别非今了别当了别。或非已了别非今了别或当了别或不当了别。或非已了别今了别当了别。非已了别非今了别非当了别者。谓先未曾得定不当得。非已了别非今了别当了别者。谓先未曾得决定当得。非已了别非今了别或当了别或不当了别者。谓先未曾得。或当得或不当得。非已了别今了别当了别者。谓先未曾得最初现前。现在无色界系善心有二句。或非已了别今了别当了已别。或了别今了别当了别。非已了别今了别当了别者。谓先未曾得最初现前。已了别今了别当了别者。谓先曾得今现在前。过去无色界系。有覆无记心有七句。或已了别非今了别非当了别。或已了别非今了别当了别。或已了别非今了别。或当了别或不当了别。或已了别今了别非当了别。或已了别今了别当了别。或已了别今了别或当了别或不当了别。或已了别今了别当了别。已了别非今了别非当了别者。谓已离无色界贪。从离无色贪定不当退。已了别非今了别当了别者。谓已离无色界贪。从离无色贪决定当退。已了别非今了别或当了别或不当了别者。谓已离无色界贪。从离无色贪。或当退或不当退。已了别今了别非当了别者。谓住离无色贪。无间道中。得离无色贪。从离无色贪。定不当退。已了别今了别或当了别或不当了别者。谓住离无色贪。无间道中。得离无色贪。从离无色贪。或当退或不当退。已了别今了别当了别者。谓未离无色贪住自性位。如过去未来亦尔。现在无色界系。有覆无记心有一句。即已了别今了别当了别。谓无色界系有覆无记心。正现在前。过去无色界系。无覆无记心有一句。即已了别非今了别非当了别。谓异熟心已灭。如过去未来亦尔。无色界系。未曾得无覆无记心有三句。或非已了别非今了别非当了别。或非已了别非今了别当了别。或非已了别非今了别或当了别或不当了别。非已了别非今了别非当了别者。谓先未曾得。定不当得。非已了别非今了别当了别者。谓先未曾得决定当得。非已了别非今了别或当了别或不当了别者。谓先未曾得。或当得或不当得。现在无色界系。无覆无记心有一句。即非已了别今了别非当了别。谓异熟心正现在前。过去学心有七句。或已了别非今了别非当了别。或已了别非今了别当了别。或已了别非今了别或当了别或不当了别。或已了别今了别非当了别。或已了别今了别当了别。或已了别今了别或当了别或不当了别。或已了别今了别当了别。已了别非今了别非当了别者。谓阿罗汉。从阿罗汉果定不当退。已了别非今了别当了别者。谓阿罗汉。从阿罗汉果决定当退。已了别非今了别或当了别或不当了别者。谓阿罗汉。从阿罗汉果。或当退或不当退。已了别今了别非当了别者。谓住阿罗汉果。无间道中。得阿罗汉果。从阿罗汉果定不当退。已了别今了别当了别者。谓住阿罗汉果。无间道中。得阿罗汉果。从阿罗汉果。决定当退。已了别今了别或当了别或不当了别者。谓住阿罗汉果。无间道中。得阿罗汉果。从阿罗汉果。或当退或不当退。已了别今了别当了别者。谓诸有学住自性位。如过去未来亦尔。未曾得学心有四句。或非已了别非今了别非当了别。或非已了别非今了别当了别。或非已了别非今了别或当了别或不当了别。或非已了别今了别当了别。非已了别非今了别非当了别者。谓先未曾得定不当得。非已了别非今了别当了别者。谓先未曾得。决定当得。非已了别非今了别或当了别或不当了别者。谓先未曾得。或当得或不当得。非已了别今了别当了别者。谓先未曾得最初现前。现在学心有八句。或非已了别今了别非当了别。或非已了别今了别当了别。或非已了别今了别或当了别或不当了别。或已了别今了别非当了别。或已了别今了别当了别。或已了别今了别或当了别或不当了别。或非已了别今了别当了别。或已了别今了别当了别。非已了别今了别非当了别者。谓先不退阿罗汉果。住阿罗汉果。无间道中。得阿罗汉果。从阿罗汉果。定不当退。非已了别今了别当了别者。谓先不退阿罗汉果。住阿罗汉果。无间道中。得阿罗汉果。从阿罗汉果。决定当退。非已了别今了别或当了别或不当了别者。谓先不退阿罗汉果。住阿罗汉果。无间道中。得阿罗汉果。从阿罗汉果。或当退或不当退。已了别今了别非当了别者。谓先已退阿罗汉果。住阿罗汉果。无间道中。得阿罗汉果。从阿罗汉果。定不当退。已了别今了别当了别者。谓先已退阿罗汉果。住阿罗汉果。无间道中。得阿罗汉果。从阿罗汉果。决定当退。已了别今了别或当了别或不当了别者。谓先已退阿罗汉果。住阿罗汉果。无间道中。得阿罗汉果。从阿罗汉果。或当退或不当退。非已了别今了别当了别者。谓先未曾得最初现前。已了别今了别当了别者。谓先已曾得今现在前。过去无学心有四句。或已了别非今了别非当了别。或已了别非今了别当了别。或已了别今了别非当了别。或已了别今了别当了别。已了别非今了别非当了别者。谓时解脱阿罗汉果。已入不动。已了别非今了别当了别者。谓阿罗汉已退阿罗汉果。已了别今了别非当了别者。谓时解脱阿罗汉。住得不动无间道中。已了别今了别当了别者。谓诸无学住自性位。如过去未来亦尔。未曾得无学心有四句。或非已了别非今了别非当了别。或非已了别非今了别当了别。或非已了别非今了别或当了别或不当了别。或非已了别今了别当了别。非已了别非今了别非当了别者。谓先未曾得定不当得。非已了别非今了别当了别者。谓先未曾得。决定当得。非已了别非今了别或当了别或不当了别者谓先未曾得。或当得或不当得。非已了别今了别当了别者。谓先未曾得最初现前。现在无学心有三句。或已了别今了别非当了别。或非已了别今了别当了别。或已了别今了别当了别。已了别今了别非当了别者。谓时解脱阿罗汉。住得不动无间道中。非已了别今了别当了别者。谓先未曾得。最初现前。已了别今了别当了别者谓先曾得。今现在前

说一切有部识身足论卷第十二阿毗达磨识身足论卷第十三

        提婆设摩阿罗汉造

        三藏法师玄奘奉　诏译

    成就蕴第六之一嗢拖南颂

  初成不成与舍得　　未断已断二种心
  补特伽罗二梵世　　学无学心二最后

有十二心。谓欲界系善心。不善心。有覆无记心。无覆无记心。色界系善心。有覆无记心。无覆无记心。无色界系善心。有覆无记心。无覆无记心。及学心。无学心。若成就欲界系善心。亦成就不善心耶。设成就不善心。亦成就此善心耶。若成就欲界系善心。乃至亦成就无学心耶。设成就无学心。亦成就此善心耶。乃至若成就学心。亦成就无学心耶。设成就无学心。亦成就学心耶

若成就欲界系善心。亦成就不善心耶。或成就欲界系善心。非不善心。或成就不善心。非此善心。或成就此善心。亦不善心。或非成就此善心。亦非不善心。成就欲界系善心非不善心者。谓欲界生长。已离欲界贪补特伽罗。成就不善心非此善心者。谓已断善根补特伽罗。成就此善心亦不善心者。谓欲界生长。不断善根。未离欲界贪补特伽罗。非成就此善心亦非不善心者。谓色无色界生长补特伽罗。若成就欲界系善心。亦成就欲界系有覆无记心耶。或成就欲界系善心。非欲界系有覆无记心。或成就欲界系有覆无记心。非欲界系善心。或成就此善心。亦此有覆无记心。或非成就此善心。亦非此有覆无记心。成就欲界系善心非欲界系有覆无记心者。谓欲界生长。已离欲界贪圣者异生。及未离欲界贪圣者。现观边苦。法智已生。成就欲界系有覆无记心非欲界系善心者。谓已断善根补特伽罗。成就欲界系善心。亦欲界系有覆无记心者。谓欲界生长异生。不断善根。未离欲界贪。及未离欲界贪圣者。现观边苦法智未生。非成就欲界系善心。亦非欲界系有覆无记心者。谓色无色界生长补特伽罗。若成就欲界系善心。亦成就欲界系无覆无记心耶。若成就欲界系善心。定成就欲界系无覆无记心。或成就欲界系无覆无记心。非欲界系善心。谓已断善根及色界生长补特伽罗。若成就欲界系善心。亦成就色界系善心耶。或成就欲界系善心。非色界系善心。或成就色界系善心。非欲界系善心。或成就欲界系善心。亦色界系善心。或非成就欲界系善心。亦非色界系善心。成就欲界系善心非色界系善心者。谓欲界生长。不断善根。未得色界善心补特伽罗。成就色界系善心。非欲界系善心者。谓色界生长补特伽罗。成就欲界系善心。亦色界系善心者。谓欲界生长。已得色界善心补特伽罗。非成就欲界系善心。亦非色界系善心者。谓已断善根。及无色界生长补特伽罗。若成就欲界系善心。亦成就色界系有覆无记心耶。或成就欲界系善心。非色界系有覆无记心。或成就色界系有覆无记心。非欲界系善心。或成就欲界系善心。亦色界系有覆无记心。或非成就欲界系善心。亦非色界系有覆无记心。成就欲界系善心。非色界系有覆无记心者。谓欲界生长。已离色界贪补特伽罗。成就色界系有覆无记心。非欲界系善心者。谓已断善根。及色界生长。未离色界贪补特伽罗。成就欲界系善心。亦色界系有覆无记心者。谓欲界生长。不断善根。未离色界贪补特伽罗。非成就欲界系善心。亦非色界系有覆无记心者。谓色界生长。已离色界贪。及无色界生长补特伽罗。若成就欲界系善心。亦成就色界系无覆无记心耶。或成就欲界系善心。非色界系无覆无记心。或成就色界系无覆无记心。非欲界系善心。或成就欲界系善心。亦色界系无覆无记心。或非成就欲界系善心。亦非色界系无覆无记心。成就欲界系善心非色界系无覆无记心者。谓欲界生长。不断善根。未离欲界贪补特伽罗。成就色界系无覆无记心。非欲界系善心者。谓色界生长补特伽罗。成就欲界系善心。亦色界系无覆无记心者。谓欲界生长。已离欲界贪补特伽罗。非成就欲界系善心。亦非色界系无覆无记心者。谓已断善根。及无色界生长补特伽罗。若成就欲界系善心。亦成就无色界系善心耶。或成就欲界系善心。非无色界系善心。或成就无色界系善心。非欲界系善心或成就欲界系善心。亦无色界系善心。或非成就欲界系善心。亦非无色界系善心。成就欲界系善心。非无色界系善心者。谓欲界生长。不断善根。未得无色界善心补特伽罗。成就无色界系善心。非欲界系善心者。谓色界生长。已得无色界善心。及无色界生长补特伽罗。成就欲界系善心。亦无色界系善心者。谓欲界生长。已得无色界善心补特伽罗。非成就欲界系善心。亦非无色界系善心者。谓已断善根。及色界生长。未得无色界善心补特伽罗。若成就欲界系善心。亦成就无色界系有覆无记心耶。或成就欲界系善心。非无色界系有覆无记心。或成就无色界系有覆无记心。非欲界系善心。或成就欲界系善心。亦无色界系有覆无记心。或非成就欲界系善心。亦非无色界系有覆无记心。成就欲界系善心。非无色界系有覆无记心者。谓欲界生长阿罗汉。成就无色界系有覆无记心。非欲界系善心者。谓已断善根。及色无色界生长。有学异生补特伽罗。成就欲界系善心。亦无色界系有覆无记心者。谓欲界生长。有学及异生。不断善根补特伽罗。非成就欲界系善心。亦非无色界系有覆无记心者。谓色无色界生长阿罗汉。若成就欲界系善心。亦成就无色界系无覆无记心耶。若成就欲界系善心。定不成就无色界系无覆无记心。若成就无色界系无覆无记心。定不成就欲界系善心。若成就欲界系善心。亦成就学心耶。或成就欲界系善心。非学心。或成就学心。非欲界系善心。或成就欲界系善心亦学心。或非成就欲界系善心。亦非学心。成就欲界系善心非学心者。谓欲界生长。阿罗汉。及异生。不断善根补特伽罗。成就学心。非欲界系善心者。谓色无色界生长。有学补特伽罗。成就欲界系善心亦学心者。谓欲界生长。有学补特伽罗。非成就欲界系善心。亦非学心者。谓已断善根。及色无色界生长。阿罗汉。若异生补特伽罗。若成就欲界系善心。亦成就无学心耶。或成就欲界系善心。非无学心。或成就无学心。非欲界系善心。或成就欲界系善心。亦无学心。或非成就欲界系善心。亦非无学心。成就欲界系善心。非无学心者。谓欲界生长。有学及异生不断善根补特伽罗。成就无学心。非欲界系善心者。谓色无色界生长阿罗汉。成就欲界系善心亦无学心者。谓欲界生长阿罗汉。非成就欲界系善心亦非无学心者。谓已断善根。及色无色界生长。有学若异生补特伽罗。若成就不善心。亦成就欲界系有覆无记心耶。若成就欲界系有覆无记心。定成就不善心。或成就不善心。非欲界系有覆无记心。谓未离欲界贪圣者。现观边苦法智已生。若成就不善心。亦成就欲界系无覆无记心耶。若成就不善心。定成就欲界系无覆无记心。或成就欲界系无覆无记心。非不善心。谓欲界生长。已离欲界贪。或色界生长补特伽罗。若成就不善心。亦成就色界系善心耶。或成就不善心。非色界系善心。或成就色界系善心。非不善心。或成就不善心。亦色界系善心。或非成就不善心。亦非色界系善心。成就不善心非色界系善心者。谓欲界生长。未得色界善心补特伽罗。成就色界系善心非不善心者。谓欲界生长。已离欲界贪。及色界生长补特伽罗。成就不善心。亦色界系善心者。谓欲界生长。未离欲界贪。已得色界善心补特伽罗。非成就不善心。亦非色界系善心者。谓无色界生长补特伽罗。若成就不善心。亦成就色界系有覆无记心耶。若成就不善心。定成就色界系有覆无记心。或成就色界系有覆无记心。非不善心。谓欲界生长。已离欲界贪。未离色界贪。及色界生长。未离色界贪补特伽罗。若成就不善心。亦成就色界系无覆无记心耶。若成就不善心。定不成就色界系无覆无记心。若成就色界系无覆无记心。定不成就不善心。若成就不善心。亦成就无色界系善心耶。若成就不善心。定不成就无色界系善心。若成就无色界系善心。定不成就不善心。若成就不善心。亦成就无色界系有覆无记心耶。若成就不善心。定成就无色界系有覆无记心。或成就无色界系有覆无记心非不善心。谓有学异生。已离欲界贪。若成就不善心。定不成就无色界系无覆无记心。若无学心。若成就无色界系无覆无记心。若无学心。定不成就不善心。若成就不善心。亦成就学心耶。或成就不善心非学心。或成就学心非不善心。或成就不善心亦学心。或非成就不善心亦非学心。成就不善心非学心者。谓欲界生长异生。未离欲界贪。成就学心非不善心者。谓诸有学已离欲界贪。成就不善心亦学心者。谓诸有学未离欲界贪。非成就不善心亦非学心者。谓阿罗汉及诸异生。已离欲界贪。若成就欲界系有覆无记心。亦成就欲界系无覆无记心耶。若成就欲界系有覆无记心。定成就欲界系无覆无记心。或成就欲界系无覆无记心。非欲界系有覆无记心。谓欲界生长。已离欲界贪。及未离欲界贪圣者。现观边苦法智已生。若色界生长补特伽罗。若成就欲界系有覆无记心。亦成就色界系善心耶。或成就欲界系有覆无记心。非色界系善心。或成就色界系善心。非欲界系有覆无记心。或成就欲界系有覆无记心。亦色界系善心。或非成就欲界系有覆无记心。亦非色界系善心。成就欲界系有覆无记心。非色界系善心者。谓欲界生长。未得色界善心补特伽罗。成就色界系善心。非欲界系有覆无记心者。谓欲界生长。异生已离欲界贪。及未离欲界贪圣者。现观边苦法智已生。若色界生长补特伽罗。成就欲界系有覆无记心。亦色界系善心者。谓欲界生长异生。未离欲界贪。已得色界善心。及未离欲界贪圣者。现观边苦法智未生。非成就欲界系有覆无记心。亦非色界系善心者。谓无色界生长补特伽罗。若成就欲界系有覆无记心。亦成就色界系有覆无记心耶。若成就欲界系有覆无记心。定成就色界系有覆无记心。或成就色界系有覆无记心。非欲界系有覆无记心。谓欲界生长有学异生。已离欲界贪。未离色界贪。及未离欲界贪圣者。现观边苦法智已生。若生色界生长。未离彼贪补特伽罗。若成就欲界系有覆无记心。定不成就色界系无覆无记心。若无色界系善心。若成就色界系无覆无记心。若无色界系善心。定不成就。欲界系有覆无记心。若成就欲界系有覆无记心。亦成就无色界系有覆无记心耶。若成就欲界系有覆无记心。定成就无色界系有覆无记心。或成就无色界系有覆无记心。非欲界系有覆无记心。谓已离欲界贪。有学异生。及未离欲界贪圣者。现观边苦法智已生。若成就欲界系有覆无记心。定不成就无色界系无覆无记心。若无学心。若成就无色界系无覆无记心。若无学心。定不成就欲界系有覆无记心。若成就欲界系有覆无记心。亦成就学心耶。或成就欲界系有覆无记心非学心。或成就学心。非欲界系有覆无记心。或成就欲界系有覆无记心。亦学心。或非成就欲界系有覆无记心亦非学心。成就欲界系有覆无记心非学心者。谓欲界生长异生。未离欲界贪。成就学心非欲界系有覆无记心者。谓诸有学现观边苦法智已生。成就欲界系有覆无记心亦学心者。谓未离欲界贪圣者。现观边苦法智未生。非成就欲界系有覆无记心亦非学心者。谓阿罗汉及诸异生。已离欲界贪。若成就欲界系无覆无记心。亦成就色界系善心耶。若成就色界系善心。定成就欲界系无覆无记心。或成就欲界系无覆无记心。非色界系善心。谓欲界生长。未得色界善心补特伽罗。若成就欲界系无覆无记心。亦成就色界系有覆无记心耶。若成就色界系有覆无记心。定成就欲界系无覆无记心。或成就欲界系无覆无记心。非色界系有覆无记心。谓欲界色界生长。已离色界贪补特伽罗。若成就欲界系无覆无记心。亦成就色界系无覆无记心耶。若成就色界系无覆无记心。定成就欲界系无覆无记心。或成就欲界系无覆无记心。非色界系无覆无记心。谓欲界生长。未离欲界贪补特伽罗。若成就欲界系无覆无记心。亦成就无色界系善心耶。或成就欲界系无覆无记心。非无色界系善心。或成就无色界系善心。非欲界系无覆无记心。或成就欲界系无覆无记心。亦无色界系善心。或非成就欲界系无覆无记心。亦非无色界系善心。成就欲界系无覆无记心。非无色界系善心者。谓欲界色界生长。未得无色界善心补特伽罗。成就无色界系善心。非欲界系无覆无记心者。谓无色界生长补特伽罗。成就欲界系无覆无记心。亦无色界系善心者。谓欲界色界生长。已得无色界善心补特伽罗。非成就欲界系无覆无记心。亦非无色界系善心者。无有此句。若成就欲界系无覆无记心。亦成就无色界系有覆无记心耶。或成就欲界系无覆无记心。非无色界系有覆无记心。或成就无色界系有覆无记心。非欲界系无覆无记心。或成就欲界系无覆无记心。亦无色界系有覆无记心。或非成就欲界系无覆无记心。亦非无色界系有覆无记心。成就欲界系无覆无记心。非无色界系有覆无记心者。谓欲界色界生长诸阿罗汉。成就无色界系有覆无记心。非欲界系无覆无记心者。谓无色界生长。有学异生。成就欲界系无覆无记心。亦无色界系有覆无记心者。谓欲界色界生长有学位生。非成就欲界系无覆无记心。亦非无色界系有覆无记心者。谓无色界生长诸阿罗汉。若成就欲界系无覆无记心。定不成就无色界系无覆无记心。若成就无色界系无覆无记心。定不成就欲界系无覆无记心。若成就欲界系无覆无记心。亦成就学心耶。或成就欲界系无覆无记心。非学心。或成就学心。非欲界系无覆无记心。或成就欲界系无覆无记心。亦学心。或非成就欲界系无覆无记心。亦非学心。成就欲界系无覆无记心。亦非学心者。谓欲界色界生长阿罗汉。及诸异生。成就学心。非欲界系无覆无记心者。谓无色界生长。有学补特伽罗。成就欲界系无覆无记心。亦学心者。谓欲界色界生长。有学补特伽罗。非成就欲界系无覆无记心。亦非学心者。谓无色界生长阿罗汉。及诸异生。若成就欲界系无覆无记心。亦成就无学心耶。或成就欲界系无覆无记心。非无学心。广说四句。成就欲界系无覆无记心。非无学心者。谓欲界色界生长有学。及诸异生。成就无学心。非欲界系无覆无记心者。谓无色界生长诸阿罗汉。成就欲界系无覆无记心。亦无学心者。谓欲界色界生长诸阿罗汉。非成就欲界系无覆无记心。亦非无学心者。谓无色界生长有学。及诸异生。若成就色界系善心。亦成就色界系有覆无记心耶。或成就色界系善心。非色界系有覆无记心。广说四句。成就色界系善心。非色界系有覆无记心者。谓欲界色界生长。已离色界贪补特伽罗。成就色界系有覆无记心。非色界系善心者。谓欲界生长。未得色界善心补特伽罗。成就色界系善心。亦色界系有覆无记心者。谓欲界生长。已得色界善心。未离色界贪。及色界生长。未离彼贪补特伽罗。非成就色界系善心。亦非色界系有覆无记心者。谓无色界生长补特伽罗。若成就色界系善心。亦成就色界系无覆无记心耶。若成就色界系无覆无记心。定成就色界系善心。或成就色界系善心。非色界系无覆无记心。谓欲界生长。未离欲界贪。已得色界系善心补特伽罗。若成就色界系善心。亦成就无色界善心耶。或成就色界系善心。非无色界系善心。广说四句。成就色界系善心。非无色界系善心者。谓欲界生长。已得色界善心。未得无色界善心及色界生长。未得无色界善心补特伽罗。成就无色界系善心。非色界系善心者。谓无色界生长补特伽罗。成就色界系善心。亦无色系善心者。谓欲界色界生长。已得无色界善心补特伽罗。非成就色界系善心。亦非无色界系善心者。谓欲界生长。未得色界善心补特伽罗。若成就色界系善心。亦成就无色界系有覆无记心耶。或成就色界系善心。非无色界系有覆无记心。广说四句。成就色界系善心。非无色界系有覆无记心者。谓欲界色界生长诸阿罗汉。成就无色界系有覆无记心。非色界系善心者。谓欲界生长。未得色界善心。及无色界生长有学异生。成就色界系善心。亦无色界系有覆无记心者。谓欲界生长有学异生。已得色界善心。及色界生长有学异生。非成就色界系善心。亦非无色界系有覆无记心者。谓无色界生长诸阿罗汉。若成就色界系善心。定不成就无色界系无覆无记心。若成就无色界系无覆无记心。定不成就色界系善心。若成就色界系善心。亦成就学心耶。或成就色界系善心。非学心。广说四句。成就色界系善心。非学心者。谓欲界生长阿罗汉。及诸异生。已得色界善心。若色界生长阿罗汉。及诸异生。成就学心。非色界系善心者。谓无色界生长。有学补特伽罗。成就色界系善心。亦学心者。谓欲界色界生长。有学补特伽罗。非成就色界系善心。亦非学心者。谓欲界生长未得色界善心。及无色界生长阿罗汉。及诸异生。若成就色界系善心。亦成就无学心耶。或成就色界系善心。非无学心。广说四句。成就色界系善心。非无学心者。谓欲界生长有学异生。已得色界善心。及色界生长。有学异生。成就无学心。非色界系善心者。谓无色界生长诸阿罗汉。成就色界系善心。亦无学心者。谓欲界色界生长诸阿罗汉。非成就色界系善心。亦非无学心者。谓欲界生长。未得色界善心。及无色界生长。有学异生。若成就色界系有覆无记心。亦成就色界系无覆无记心耶。或成就色界系有覆无记心。非色界系无覆无记心。广说四句。成就色界系有覆无记心。非色界系无覆无记心者。谓欲界生长。未离欲界贪补特伽罗。成就色界系无覆无记心。非色界系有覆无记心者。谓欲界色界生长。已离色界贪补特伽罗。成就色界系有覆无记心。亦色界系无覆无记心者。谓欲界生长已离欲界贪。未离色界贪。及色界生长。未离彼贪补特伽罗。非成就色界系有覆无记心。亦非色界系无覆无记心者。谓无色界生长补特伽罗。若成就色界系有覆无记心。亦成就无色界系善心耶。或成就色界系有覆无记心。非无色系善心。广说四句。成就色界系有覆无记心。非无色界系善心者。谓欲界色界生长未得无色界善心补特伽罗。成就无色界系善心。非色界系有覆无记心者。谓欲界色界生长。已离色界贪。及无色界生长补特伽罗。成就色界系有覆无记心。亦无色界系善心者。谓欲界色界生长。未离色界贪。已得无色界善心补特伽罗。非成就色界系有覆无记心。亦非无色界系善心者。无有此句。若成就色界系有覆无记心。亦成就无色界系有覆无记心耶。若成就色界系有覆无记心。定成就无色界系有覆无记心。或成就无色界系有覆无记心。非色界系有覆无记心。谓有学异生。已离色界贪。若成就色界系有覆无记心。定不成就无色界系无覆无记心。若无学心。若成就无色界系无覆无记心。若无学心。定不成就色界系有覆无记心。若成就色界系有覆无记心。亦成就学心耶。或成就色界系有覆无记心。非学心。广说四句。成就色界系有覆无记心。非学心者。谓诸异生。未离色界贪。成就学心。非色界系有覆无记心者。谓诸有学。已离色界贪。成就色界系有覆无记心。亦学心者。谓诸有学未离色界贪。非成就色界系有覆无记心。亦非学心者谓阿罗汉。及诸异生。已离色界贪。若成就色界系无覆无记心。亦成就无色界系善心耶。或成就色界系无覆无记心。非无色界系善心。广说四句。成就色界系无覆无记心。非无色界系善心者。谓欲界生长。已离欲界贪。未得无色界善心。及色界生长。未得无色界。善心补特伽罗。成就无色界系善心。非色界系无覆无记心者。谓无色界生长补特伽罗。成就色界系无覆无记心。亦无色界系善心者。谓欲界色界生长。已得无色界善心补特伽罗。非成就色界系无覆无记心。亦非无色界系善心者。谓欲界生长。未离欲界贪补特伽罗。若成就色界系无覆无记心。亦成就无色界系有覆无记心耶。或成就色界系无覆无记心。非无色界系有覆无记心。广说四句。成就色界系无覆无记心。非无色界系有覆无记心者。谓欲界色界生长诸阿罗汉。成就无色界系有覆无记心。非色界系无覆无记心者。谓欲界生长。未离欲界贪。及无色界生长有学异生。成就色界系无覆无记心。亦无色界系有覆无记心者。谓欲界生长有学异生已离欲界贪。及色界生长有学异生。非成就色界系无覆无记心。亦非无色界系有覆无记心者。谓无色界生长诸阿罗汉。若成就色界系无覆无记心。定不成就无色界系无覆无记心。若成就无色界系无覆无记心。定不成就色界系无覆无记心。若成就色界系无覆无记心。亦成就学心耶。或成就色界系无覆无记心。非学心。广说四句。成就色界系无覆无记心。非学心者。谓欲界生长诸阿罗汉及诸异生。已离欲界贪。若色界生长诸阿罗汉。及诸异生。成就学心。非色界系无覆无记心者。谓欲界生长有学。未离欲界贪。及无色界生长有学补特伽罗。成就色界系无覆无记心。亦学心者。谓欲界生长有学。已离欲界贪。及色界生长。有学补特伽罗。非成就欲界系无覆无记心。亦非学心者。谓欲界生长异生。未离欲界贪。及无色界生长诸阿罗汉。及诸异生。若成就色界系无覆无记心。亦成就无学心耶。或成就色界系无覆无记心。非无学心。广说四句。成就色界系无覆无记心。非无学心者。谓欲界生长有学异生。已离欲界贪。及色界生长有学异生。成就无学心。非色界系无覆无记心者。谓无色界生长诸阿罗汉。成就色界系无覆无记心。亦无学心者。谓欲界色界生长诸阿罗汉。非成就色界系无覆无记心。亦非无学心者。谓欲界生长。未离欲界贪。及无色界生长有学异生

说一切有部识身足论卷第十三阿毗达磨识身足论卷第十四

        提婆设摩阿罗汉造

        三藏法师玄奘奉　诏译

    成就蕴第六之二

若成就无色界系善心。亦成就无色界系有覆无记心耶。或成就无色界系善心。非无色界系有覆无记心。广说四句。成就无色界系善心。非无色界系有覆无记心者谓阿罗汉。成就无色界系有覆无记心。非无色界系善心者。谓诸有学异生。未得无色界善心。成就无色界系善心。亦无色界系有覆无记心者。谓诸有学异生。已得无色界善心。非成就无色界系善心。亦非无色系有覆无记心者。无有此句。若成就无色界系善心。亦成就无色界系无覆无记心耶。若成就无色界系无覆无记心。定成就无色界系善心。或成就无色界系善心。非无色界系无覆无记心。谓欲界色界生长。已得无色界善心。及无色界生长异熟果心。不现在前。若成就无色界系善心。亦成就学心耶。或成就无色界系善心。非学心。广说四句。成就无色界系善心。非学心者。谓阿罗汉。及诸异生。已得无色界善心。成就学心。非无色界系善心者。谓诸有学。未得无色界善心成就无色界系善心。亦学心者。谓诸有学。已得无色界善心。非成就无色界善心。亦非学心者。谓诸异生。未得无色界善心。若成就无色界善心。亦成就无学心耶。若成就无学心。定成就无色界系善心。或成就无色界系善心。非无学心。谓诸有学异生。已得无色界善心。若成就无色界系有覆无记心。亦成就无色界系无覆无记心耶。或成就无色界系有覆无记心。非无色界系无覆无记心。广说四句。成就无色界系有覆无记心。非无色界系无覆无记心者。谓欲界色界生长有学异生。及无色界生长有学异生。异熟果心不现在前。成就无色界系无覆无记心。非无色界系有覆无记心者。谓无色界生长诸阿罗汉。异熟果心正现在前。成就无色界系有覆无记心。亦无色界系无覆无记心者。谓无色界生长有学异生。异熟果心正现在前。非成就无色界系有覆无记心。亦非无色界系无覆无记心者。谓欲界色界生长诸阿罗汉。及无色界生长诸阿罗汉。异熟果心不现在前。若成就无色界系有覆无记心。亦成就学心耶。若成就学心。定成就无色界系有覆无记心。或成就无色界系有覆无记心。非学心。谓诸异生。若成就无色界系有覆无记心。定不成就无学心。若成就无学心。定不成就无色界系有覆无记心。若成就无色界系无覆无记心。亦成就学心耶。或成就无色界系无覆无记心。非学心。广说四句。成就无色界系无覆无记心非学心者。谓无色界生长阿罗汉异生。异熟果心正现在前。成就学心非无色界系无覆无记心者。谓欲界色界生长有学。及无色界生长有学。异熟果心不现在前。成就无色界系无覆无记心亦学心者。谓无色界生长有学。异熟果心正现在前。非成就无色界系无覆无记心亦非学心者。谓欲界色界生长阿罗汉异生。及无色界生长阿罗汉异生。异熟果心不现在前。若成就无色界系无覆无记心。亦成就无学心耶。或成就无色界系无覆无记心。非无学心。或成就无学心。非无色界系无覆无记心。或成就无色界系无覆无记心。亦无学心。或非成就无色界系无覆无记心。亦非无学心。成就无色界系无覆无记心非无学心者。谓无色界生长有学异生。异熟果心正现在前。成就无学心非无色界系无覆无记心者。谓欲界色界生长诸阿罗汉。及无色界生长诸阿罗汉。异熟果心不现在前。成就无色界系无覆无记心亦无学心者。谓无色界生长诸阿罗汉。异熟果心正现在前。非成就无色界系无覆无记心亦非无学心者。谓欲界色界生长有学异生。及无色界生长有学异生。异熟果心不现在前。若成就学心。定不成就无学心。若成就无学心。定不成就学心

有十二心。谓欲界系善心。不善心。有覆无记心。无覆无记心。色界系善心。有覆无记心。无覆无记心。无色界系善心。有覆无记心。无覆无记心。及学心。无学心。若不成就欲界系善心。亦不成就不善心耶。设不成就不善心。亦不成就欲界系善心耶。若不成就欲界系善心。乃至亦不成就无学心耶。设不成就无学心。亦不成就欲界系善心耶。乃至若不成就学心。亦不成就无学心耶。设不成就无学心。亦不成就学心耶

若不成就欲界系善心。亦不成就不善心耶。或不成就欲界系善心非不善心。或不成就不善心。非欲界系善心。或不成就欲界系善心。亦不善心。或非不成就欲界系善心。亦非不善心。不成就欲界系善心非不善心者。谓已断善根补特伽罗。不成就不善心非欲界系善心者。谓欲界生长。已离欲界贪补特伽罗。不成就欲界系善心亦不善心者。谓色无色界生长补特伽罗。非不成就欲界系善心亦非不善心者。谓不断善根。未离欲界贪补特伽罗。若不成就欲界系善心。亦不成就欲界系有覆无记心耶。或不成就欲界系善心。非欲界系有覆无记心。广说四句。不成就欲界系善心非欲界系有覆无记心者。谓已断善根补特伽罗。不成就欲界系有覆无记心非欲界系善心者。谓欲界生长异生。已离欲界贪。及未离欲界贪圣者。现观边苦法智已生。不成就欲界系善心亦欲界系有覆无记心者。谓色无色界生长补特伽罗。非不成就欲界系善心亦非欲界系有覆无记心者。谓欲界生长异生。不断善根。未离欲界贪。及未离欲界贪圣者。现观边苦法智未生。若不成就欲界系善心。亦不成就欲界系无覆无记心耶。若不成就欲界系无覆无记心定不成就欲界系善心。或不成就欲界系善心。非欲界系无覆无记心。谓已断善根。及色界生长补特伽罗。若不成就欲界系善心。亦不成就色界系善心耶。或不成就欲界系善心。非色界系善心。广说四句。不成就欲界系善心非色界系善心者。谓色界生长补特伽罗。不成就色界系善心非欲界系善心者。谓欲界生长不断善根。未得色界善心补特伽罗。不成就欲界系善心亦色界系善心者。谓已断善根。及无色界生长补特伽罗。非不成就欲界系善心亦非色界系善心者。谓欲界生长。已得色界系善心补特伽罗。若不成就欲界系善心。亦不成就色界系有覆无记心耶。或不成就欲界系善心。非色界系有覆无记心。广说四句。不成就欲界系善心非色界系有覆无记心者。谓已断善根。及色界生长。未离色界贪补特伽罗。不成就色界系有覆无记心非欲界系善心者。谓欲界生长。已离色界贪补特伽罗。不成就欲界系善心亦色界系有覆无记心者。谓色界生长。已离色界贪。及无色界生长补特伽罗。非不成就欲界系善心亦非色界系有覆无记心者。谓欲界生长。不断善根。未离色界贪补特伽罗。若不成就欲界系善心。亦不成就色界系无覆无记心耶。或不成就欲界系善心。非色界系无覆无记心。广说四句。不成就欲界系善心非色界系无覆无记心者。谓色界生长补特伽罗。不成就色界系无覆无记心非欲界系善心者。谓欲界生长。不断善根。未离欲界贪补特伽罗。不成就欲界系善心亦色界系无覆无记心者。谓已断善根及无色界生长补特伽罗。非不成就欲界系善心亦非色界系无覆无记心者。谓欲界生。长已离欲界贪补特伽罗。若不成就欲界系善心。亦不成就无色界系善心耶。或不成就欲界系善心。非无色界系善心。广说四句。不成就欲界系善心非无色界系善心者。谓色界生长。已得无色界善心。及无色界生长补特伽罗。不成就无色界系善心非欲界系善心者。谓欲界生长。不断善根。未得无色界善心补特伽罗。不成就欲界系善心亦无色界系善心者。谓已断善根。及色界生长。未得无色界善心补特伽罗。非不成就欲界善心亦非无色界善心者。谓欲界生长。已得无色界善心补特伽罗。若不成就欲界系善心。亦不成就无色界系有覆无记心耶。或不成就欲界系善心。非无色界系有覆无记心。广说四句。不成就欲界系善心非无色界系有覆无记心者。谓已断善根。及色无色界生长。有学异生。不成就无色界系有覆无记心非欲界善心者。谓欲界生长诸阿罗汉。不成就欲界系善心亦无色界系有覆无记心者。谓色无色界生长诸阿罗汉。非不成就欲界系善心亦非无色界系有覆无记心者。谓欲界生长有学。及不断善根异生。若不成就欲界系善心。亦不成就无色界系无覆无记心耶。或不成就欲界系善心。非无色界系无覆无记心。广说四句。不成就欲界系善心非无色界系无覆无记心者。谓无色界生长。异熟果心正现在前。不成就无色界系无覆无记心非欲界系善心者。谓欲界生长。不断善根。不成就欲界系善心亦无色界系无覆无记心者。谓已断善根。及色界生长。若无色界生长。异熟果心不现在前。非不成就欲界系善心亦非无色界系无覆无记心者。无有此句。若不成就欲界系善心。亦不成就学心耶。或不成就欲界系善心。非学心。广说四句。不成就欲界系善心非学心者。谓色无色界生长有学。不成就学心非欲界系善心者谓欲界生长诸阿罗汉。及诸异生。不断善根不成就欲界系善心亦非学心者。谓已断善根。及色无色界生长诸阿罗汉。及诸异生。非不成就欲界系善心亦非学心者。谓欲界生长有学。若不成就欲界系善心。亦不成就无学心耶。或不成就欲界系善心。非无学心。广说四句。不成就欲界系善心非无学心者。谓色无色界生长诸阿罗汉。不成就无学心非欲界系善心者。谓欲界生长有学异生。不断善根。不成就欲界系善心亦无学心者。谓已断善根。及色无色生长有学异生。非不成就欲界系善心亦非无学心者。谓欲界生长诸阿罗汉。若不成就不善心。亦不成就欲界系有覆无记心耶。若不成就不善心。定不成就欲界系有覆无记心。或不成就欲界系有覆无记心。非不善心。谓未离欲界贪圣者。现观边苦法智已生。若不成就不善心。亦不成就欲界系无覆无记心耶。若不成就欲界系无覆无记心。定不成就不善心。或不成就不善心。非不成就欲界系无覆无记心。谓欲界生长。已离欲界贪。及色界生长补特伽罗。若不成就不善心。亦不成就色界系善心耶。或不成就不善心。非色界系善心。广说四句。不成就不善心非色界系善心者。谓欲界生长。已离欲界贪。及色界生长补特伽罗。不成就色界系善心非不善心者。谓欲界生长。未得色界善心补特伽罗。不成就不善心亦色界系善心者。谓无色界生长补特伽罗。非不成就不善心亦非色界系善心者。谓欲界生长。未离欲界贪。已得色界善心补特伽罗。若不成就不善心。亦不成就色界系有覆无记心耶。若不成就色界系有覆无记心。定不成就不善心。或不成就不善心。非色界系有覆无记心。谓欲界生长。已离欲界贪。未离色界贪。及色界生长。未离彼贪补特伽罗。若不成就不善心亦不成就色界系无覆无记心耶。或不成就不善心。非色界系无覆无记心。广说四句。不成就不善心非色界系无覆无记心者。谓欲界生长。已离欲界贪。及色界生长补特伽罗。不成就色界系无覆无记心非不善心者。谓欲界生长未离欲界贪补特伽罗。不成就不善心亦色界系无覆无记心者。谓无色界生长补特伽罗。非不成就不善心亦非色界系无覆无记心者。无有此句。若不成就不善心。亦不成就无色界系善心耶。或不成就不善心。非无色界系善心。广说四句。不成就不善心非无色界系善心者。谓欲界色界生长。已得无色界善心。及无色界生长补特伽罗。不成就无色界系善心非不善心者。谓欲界生长。未离欲界贪补特伽罗。不成就不善心亦无色界系善心者。谓欲界生长已离欲界贪。未得无色界善心。及色界生长。未得无色界善心补特伽罗。非不成就不善心非无色界系善心者。无有此句。若不成就不善心。亦不成就无色界系有覆无记心耶。若不成就无色界系有覆无记心。定不成就不善心。或不成就不善心。非无色界系有覆无记心。谓有学异生。已离欲界贪。若不成就不善心。亦不成就无色界系无覆无记心耶。或不成就不善心。非无色界系无覆无记心。广说四句。不成就不善心非无色界系无覆无记心者。谓无色界生长。异熟果心正现在前。不成就无色界系无覆无记心非不善心者。谓欲界生长。未离欲界贪补特伽罗。不成就不善心亦无色界系无覆无记心者。谓欲界生长。已离欲界贪。及色界生长。若无色界生长。异熟果心不现在前。非不成就不善心亦非无色界系无覆无记心者。无有此句。若不成就不善心。亦不成就学心耶。或不成就不善心。非学心。广说四句。不成就不善心非学心者。谓诸有学。已离欲界贪。不成就学心非不善心者。谓欲界生长异生。未离欲界贪。不成就不善心亦学心者。谓阿罗汉。及诸异生。已离欲界贪。非不成就不善心亦非学心者。谓诸有学未离欲界贪。若不成就不善心亦不成就无学心耶。或不成就不善心。非无学心广说四句。不成就不善心非无学心者。谓阿罗汉。不成就无学心非不善心者。谓有学异生未离欲界贪。不成就不善心亦无学心者。谓有学异生。已离欲界贪。非不成就不善心亦非无学心者。无有此句。若不成就欲界系有覆无记心。亦不成就欲界系无覆无记心耶。若不成就欲界系无覆无记心。定不成就欲界系有覆无记心。或不成就欲界系有覆无记心。非欲界系无覆无记心。谓欲界生长异生。已离欲界贪。及未离欲界贪圣者。现观边苦法智已生。若色界生长补特伽罗。若不成就欲界系有覆无记心。亦不成就色界系善心耶。或不成就欲界系有覆无记心。非色界系善心。广说四句。不成就欲界系有覆无记心。非色界系善心者。谓欲界生长异生。已离欲界贪。及未离欲界贪圣者。现观边苦法智已生。若色界生长补特伽罗。不成就色界系善心非欲界系有覆无记心者。谓欲界生长。未得色界善心补特伽罗。不成就欲界系有覆无记心亦色界系善心者。谓无色界生长补特伽罗。非不成就欲界系有覆无记心。亦非色界系善心者。谓欲界生长异生。未离欲界贪。已得色界善心。及未离欲界贪圣者。现观边苦法智未生。若不成就欲界系有覆无记心。亦不成就色界系有覆无记心耶。若不成就色界系有覆无记心。定不成就欲界系有覆无记心。或不成就欲界系有覆无记心。非不成就色界系有覆无记心。谓欲界生长异生。已离欲界贪。未离色界贪。及未离色界贪圣者。现观边苦法智已生。若色界生长。未离彼贪补特伽罗。若不成就欲界系有覆无记心。亦不成就色界系无覆无记心耶。或不成就欲界系有覆无记心。非色界系无覆无记心。广说四句。不成就欲界系有覆无记心。非色界系无覆无记心者。谓欲界生长。已离欲界贪。及色界生长补特伽罗。不成就色界系无覆无记心。非欲界系有覆无记心者。谓欲界生长异生。未离欲界贪。及未离欲界贪圣者。现观边苦法智未生。不成就欲界系有覆无记心亦色界系无覆无记心者。谓无色界生长补特伽罗。非不成就欲界系有覆无记心亦非色界系无覆无记心者。无有此句。若不成就欲界系有覆无记心。亦不成就无色界系善心耶。或不成就欲界系有覆无记心。非无色界系善心。广说四句。不成就欲界系无覆无记心非无色界系善心者。谓欲界色界生长。已得无色界善心。及无色界生长补特伽罗。不成就无色界系善心非欲界系有覆无记心者。谓欲界生长异生。未离欲界贪及未离欲界贪圣者。现观边苦法智未生。不成就欲界系有覆无记心亦无色界系善心者。谓欲界生长异生。已离欲界贪。未得无色界善心。及未离欲界贪圣者。现观边苦法智已生。若色界生长。未得无色界善心补特伽罗。非不成就欲界系有覆无记心亦非无色界系善心者。无有此句。若不成就欲界系有覆无记心。亦不成就无色界系有覆无记心耶。若不成就无色界系有覆无记心。定不成就欲界系有覆无记心。或不成就欲界系有覆无记心。非无色界系有覆无记心。谓已离欲界贪异生。及未离欲界贪圣者。现观边苦法智已生。若不成就欲界系有覆无记心。亦不成就无色界系无覆无记心耶。或不成就欲界系有覆无记心。非无色界系无覆无记心。广说四句。不成就欲界系有覆无记心非无色界系无覆无记心者。谓无色界生长。异熟果心正现在前。不成就无色界系无覆无记心非欲界系有覆无记心者。谓欲界生长异生。未离欲界贪。及未离欲界圣者。现观边苦法智未生。不成就欲界系有覆无记心亦无色界系无覆无记心者。谓欲界生长异生。已离欲界贪。及未离欲界贪圣者。现观边苦法智已生。若色界生长。若无色界生长。异熟果心不现在前。非不成就欲界系有覆无记心。亦非无色界系无覆无记心者。无有此句。若不成就欲界系有覆无记心。亦不成就学心耶。或不成就欲界系有覆无记心。非学心。广说四句。不成就欲界系有覆无记心非学心者。谓诸有学现观边苦法智已生。不成就学心非欲界系有覆无记心者。谓欲界生长异生。未离欲界贪。不成就欲界系有覆无记心。亦学心者。谓阿罗汉及诸异生。已离欲界贪。非不成就欲界系有覆无记心亦非学心者。谓未离欲界贪圣者。现观边苦法智未生。若不成就欲界系有覆无记心。亦不成就无学心耶。或不成就欲界系有覆无记心。非无学心。广说四句。不成就欲界系有覆无记心非无学心者。谓阿罗汉。不成就无学心。非欲界系有覆无记心者。谓欲界生长异生。未离欲界贪。及未离欲界贪圣者。现观边苦法智未生。不成就欲界系有覆无记心亦无学心者。谓欲界生长异生。已离欲界贪。及未离欲界贪圣者。现观边苦法智已生。若色无色界生长有学异生。非不成就欲界系有覆无记心亦非无学心者。无有此句。若不成就欲界系无覆无记心。亦不成就色界系善心耶。若不成就欲界系无覆无记心。定不成就色界系善心。或不成就色界系善心非欲界系无覆无记心。谓欲界生长。未得色界善心补特伽罗。若不成就欲界系无覆无记心。亦不成就色界系有覆无记心耶。若不成就欲界系无覆无记心。定不成就色界系有覆无记心。或不成就色界系有覆无记心。非不成就欲界系无覆无记心。谓欲界色界生长。已离色界贪补特伽罗。若不成就欲界系无覆无记心。亦不成就色界系无覆无记心耶。若不成就欲界系无覆无记心。定不成就色界系无覆无记心。或不成就色界系无覆无记心。非欲界系无覆无记心。谓欲界生长。未离欲界贪补特伽罗。若不成就欲界系无覆无记心。定非不成就无色界系善心。若不成就无色界系善心。定非不成就欲界系无覆无记心。若不成就欲界系无覆无记心。亦不成就无色界系有覆无记心耶。或不成就欲界系无覆无记心。非无色界系有覆无记心。广说四句。不成就欲界系无覆无记心非无色界系有覆无记心者。谓无色界生长。有学异生。不成就无色界系有覆无记心非欲界系无覆无记心者。谓欲界色界生长诸阿罗汉。不成就欲界系无覆无记心亦无色界系有覆无记心者。谓无色界生长诸阿罗汉。非不成就欲界系无覆无记心亦非无色界系有覆无记心者。谓欲界色界生长。有学异生。若不成就欲界系无覆无记心。亦不成就无色界系无覆无记心耶。或不成就欲界系无覆无记心。非无色界系无覆无记心。广说四句。不成就欲界系无覆无记心非无色界系无覆无记心者。谓无色界生长。异熟果心正现在前。不成就无色界系无覆无记心。非欲界系无覆无记心者。谓欲界色界生长补特伽罗。不成就欲界系无覆无记心亦无色界系无覆无记心者。谓无色界生长。异熟果心不现在前。非不成就欲界系无覆无记心亦非无色界系无覆无记心者。无有此句。若不成就欲界系无覆无记心。亦不成就学心耶。或不成就欲界系无覆无记心。非学心。广说四句。不成就欲界系无覆无记心非学心者。谓无色界生长。有学补特伽罗。不成就学心非欲界系无覆无记心者。谓欲界色界生长。阿罗汉异生。不成就欲界系无覆无记心亦学心者。谓无色界生长。阿罗汉异生。非不成就欲界系无覆无记心亦非学心者。谓欲界色界生长。有学补特伽罗。若不成就欲界系无覆无记心。亦不成就无学心耶。或不成就欲界系无覆无记心。非无学心。广说四句。不成就欲界系无覆无记心非无学心者。谓无色界生长。诸阿罗汉。不成就无学心非欲界系无覆无记心者。谓欲界色界生长。有学异生。不成就欲界系无覆无记心亦无学心者。谓无色界生长。有学异生。非不成就欲界系无覆无记心亦非无学心者。谓欲界色界生长。诸阿罗汉

说一切有部识身足论卷第十四阿毗达磨识身足论卷第十五

        提婆设摩阿罗汉造

        三藏法师玄奘奉　诏译

    成就蕴第六之三

若不成就色界系善心。亦不成就色界系有覆无记心耶。或不成就色界系善心。非色界系有覆无记心。广说四句。不成就色界系善心非色界系有覆无记心者。谓欲界生长。未得色界善心补特伽罗。不成就色界系有覆无记心。非色界系善心者。谓欲界色界生长。已离色界贪补特伽罗。不成就色界系善心亦色界系有覆无记心者。谓无色界生长补特伽罗。非不成就色界系善心亦非色界系有覆无记心者。谓欲界生长。已得色界善心。未离色界贪。及色界生长。未离彼贪补特伽罗。若不成就色界系善心。亦不成就色界系无覆无记心耶。若不成就色界系善心。定不成就色界系无覆无记心。或不成就色界系无覆无记心。非色界系善心。谓欲界生长。未离欲界贪。已得色界善心补特伽罗。若不成就色界系善心。亦不成就无色界系善心耶。或不成就色界系善心。非无色界系善心。广说四句。不成就色界系善心非无色界系善心者。谓无色界生长补特伽罗。不成就无色界系善心非色界系善心者。谓欲界生长。已得色界善心。未得无色界善心。及色界生长。未得无色界善心补特伽罗。不成就色界系善心亦无色界系善心者。谓欲界生长。未得色界善心补特伽罗。非不成就色界系善心亦非无色界系善心者。谓欲界色界生长。已得无色界善心补特伽罗。若不成就色界系善心。亦不成就无色界系有覆无记心耶。或不成就色界系善心。非无色界系有覆无记心。广说四句。不成就色界系善心非无色界系有覆无记心者。谓欲界生长。未得色界善心。及无色界生长。有学异生。不成就无色界系有覆无记心非色界系善心者。谓欲界色界生长诸阿罗汉。不成就色界系善心亦无色界系有覆无记心者。谓无色界生长诸阿罗汉。非不成就色界系善心亦非无色界系有覆无记心者。谓欲界生长有学异生。已得色界善心。及色界生长有学异生。若不成就色界系善心。亦不成就无色界系无覆无记心耶。或不成就色界系善心。非无色界系无覆无记心。广说四句。不成就色界系善心非无色界系无覆无记心者。谓无色界生长。异熟果心正现在前。不成就无色界系无覆无记心非色界系善心者。谓欲界生长。已得色界善心。及色界生长补特伽罗。不成就色界系善心亦无色界系无覆无记心者。谓欲界生长未得色界善心。及无色界生长。异熟果心不现在前。非不成就色界系善心亦非无色界系无覆无记心者。无有此句。若不成就色界系善心。亦不成就学心耶。或不成就色界系善心。非学心。广说四句。不成就色界系善心非学心者。谓无色界生长。有学补特伽罗。不成就学心非色界系善心者。谓欲界生长。阿罗汉异生。已得色界善心。及色界生长。阿罗汉异生。不成就色界系善心亦学心者。谓欲界生长。未得色界善心。及无色界生长。阿罗汉异生。非不成就色界系善心亦非学心者。谓欲界色界生长。有学补特伽罗。若不成就色界系善心。亦不成就无学心耶。或不成就色界系善心。非无学心。广说四句。不成就色界系善心非无学心者。谓无色界生长诸阿罗汉。不成就无学心非色界系善心者。谓欲界生长有学异生。已得色界善心。及色界生长有学异生。不成就色界系善心亦无学心者。谓欲界生长。未得色界善心。及无色界生长。有学异生。非不成就色界系善心亦非无学心者。谓欲界色界生长诸阿罗汉

若不成就色界系有覆无记心。亦不成就色界系无覆无记心耶。或不成就色界系有覆无记心。非色界系无覆无记心。广说四句。不成就色界系有覆无记心非色界系无覆无记心者。谓欲界色界生长。已离色界贪补特伽罗。不成就色界系无覆无记心非色界系有覆无记心者。谓欲界生长。未离欲界贪补特伽罗。不成就色界系有覆无记心亦色界系无覆无记心者。谓无色界生长补特伽罗。非不成就色界系有覆无记心亦非色界系无覆无记心者。谓欲界生长。已离欲界贪。未离色界贪。及色界生长。未离彼贪补特伽罗。若不成就色界系有覆无记心。定非不成就无色界系善心。若不成就无色界系善心。定非不成就色界系有覆无记心。若不成就色界系有覆无记心。亦不成就无色界系有覆无记心耶。若不成就无色界系有覆无记心。定不成就色界系有覆无记心。或不成就色界系有覆无记心。非无色界系有覆无记心。谓有学异生。已离色界贪。若不成就色界系有覆无记心。亦不成就无色界系无覆无记心耶。或不成就色界系有覆无记心。非无色界系无覆无记心。广说四句。不成就色界系有覆无记心非无色界系无覆无记心者。谓无色界生长。异熟果心正现在前。不成就无色界系无覆无记心非色界系有覆无记心者。谓欲界色界生长。未离色界贪补特伽罗。不成就色界系有覆无记心亦无色界系无覆无记心者。谓欲界色界生长。已离色界贪。及无色界生长。异熟果心不现在前。非不成就色界系有覆无记心亦非无色界系无覆无记心者。无有此句。若不成就色界系有覆无记心。亦不成就学心耶。或不成就色界系有覆无记心。非学心。广说四句。不成就色界系有覆无记心非学心者。谓诸有学已离色界贪。不成就学心非色界系有覆无记心者。谓诸异生。未离色界贪。不成就色界系有覆无记心亦学心者。谓阿罗汉及诸异生。已离色界贪。非不成就色界系有覆无记心亦非学心者。谓诸有学未离色界贪。若不成就色界系有覆无记心。亦不成就无学心耶。或不成就色界系有覆无记心。非无学心。广说四句。不成就色界系有覆无记心非无学心者。谓阿罗汉。不成就无学心非色界系有覆无记心者。谓诸有学异生。未离色界贪。不成就色界系有覆无记心亦无学心者。谓有学异生。已离色界贪。非不成就色界系有覆无记心。亦非无学心者。无有此句。若不成就色界系无覆无记心。亦不成就无色界系善心耶。或不成就色界系无覆无记心。非无色界系善心。广说四句。不成就色界系无覆无记心非无色界系善心者。谓无色界生长补特伽罗。不成就无色界系善心非色界系无覆无记心者。谓欲界生长。已离欲界贪。未得无色界善心。及色界生长。未得无色善心补特伽罗。不成就色界系无覆无记心亦无色界系善心者。谓欲界生长。未离欲界贪补特伽罗。非不成就色界系无覆无记心。亦非无色界系善心者。谓欲界色界生长。已得无色界善心补特伽罗。若成就色界系无覆无记心。亦成就无色界系有覆无记心耶。或不成就色界系无覆无记心。非无色界系有覆无记心。广说四句。不成就色界系无覆无记心非无色界系有覆无记心者。谓欲界生长。未离欲界贪。及无色界生长。有学异生。不成就无色界系有覆无记心非色界系无覆无记心者。谓欲界色界生长诸阿罗汉。不成就色界系无覆无记心亦无色界系有覆无记心者。谓无色界生长诸阿罗汉。非不成就色界系无覆无记心。亦非无色界系有覆无记心者。谓欲界生长有学异生。已离欲界贪及色界生长有学异生。若不成就色界系无覆无记心。亦不成就无色界系无覆无记心耶。或不成就色界系无覆无记心。非无色界系无覆无记心。广说四句。不成就色界系无覆无记心非无色界系无覆无记心者。谓无色界生长。异熟果心正现在前。不成就无色界系无覆无记心非色界系无覆无记心者。谓欲界生长。已离欲界贪。及色界生长补特伽罗。不成就色界系无覆无记心。亦无色界系无覆无记心者。谓欲界生长。未离欲界贪。及无色界生长。异熟果心不现在前。非不成就色界系无覆无记心。亦非无色界系无覆无记心者。无有此句。若不成就色界系无覆无记心。亦不成就学心耶。或不成就色界系无覆无记心。非学心。广说四句。不成就色界系无覆无记心非学心者。谓欲界生长有学。未离欲界贪。及无色界生长。有学补特伽罗。不成就学心非色界系无覆无记心者。谓欲界生长诸阿罗汉。及诸异生。已离欲界贪。及色界生长诸阿罗汉。及诸异生。不成就色界系无覆无记心亦学心者。谓欲界生长异生。未离欲界贪。及无色界生长。阿罗汉异生。非不成就色界系无覆无记心亦非学心者。谓欲界生长有学。已离欲界贪。及色界生长。有学补特伽罗。若不成就色界系无覆无记心。亦不成就无学心耶。或不成就色界系无覆无记心。非无学心。广说四句。不成就色界系无覆无记心非无学心者。谓无色界生长阿罗汉。不成就无学心非色界系无覆无记心者。谓欲界生长。有学异生。已离欲界贪。及色界生长有学异生。不成就色界系无覆无记心亦无学心者。谓欲界生长。未离欲界贪。及无色界生长有学异生。非不成就色界系无覆无记心亦非无学心者。谓欲界色界生长。诸阿罗汉。若不成就无色界系善心。定非不成就无色界系有覆无记心。若不成就无色界系有覆无记心。定非不成就无色界系善心。若不成就无色界系善心。亦不成就无色界系无覆无记心耶。若不成就无色界系善心。定不成就无色界系无覆无记心。或不成就无色界系无覆无记心。非无色界系善心。谓欲界色界生长。已得无色界善心。及无色界生长。异熟果心不现在前补特伽罗。若不成就无色界系善心。亦不成就学心耶。或不成就无色界系善心。非学心。广说四句。不成就无色界系善心非学心者。谓诸有学未得无色界善心。不成就学心非无色界系善心者。谓阿罗汉异生。已得无色界善心。不成就无色界系善心亦学心者。谓诸异生未得无色界善心。非不成就无色界系善心亦非学心者。谓欲界色界生长有学。已得无色界善心。若不成就无色界系善心。亦不成就无学心耶。若不成就无色界系善心。定不成就无学心。或不成就无学心。非无色界系善心。谓有学异生。已得无色界善心。若不成就无色界系有覆无记心。亦不成就无色界系无覆无记心耶。或不成就无色界系有覆无记心。非无色界系无覆无记心。广说四句。不成就无色界系有覆无记心。非无色界系无覆无记心者。谓无色界生长阿罗汉。异熟果心。正现在前。不成就无色界系无覆无记心。非无色界系有覆无记心者。谓欲界色界生长有学异生。及无色界生长有学异生。异熟果心。不现在前。不成就无色界系有覆无记心。非无色界系无覆无记心者。谓无色界生长阿罗汉。异熟果心。正现在前。非不成就无色界系有覆无记心。亦非无色界系无覆无记心者。谓无色界生长。有学异生。异熟果心。正现在前。若不成就无色界系有覆无记心。亦不成就学心耶。若不成就无色界系有覆无记心。定不成就学心。或不成就学心。非无色界系有覆无记心。谓诸异生。若不成就无色界系有覆无记心。定非不成就无学心。若不成就无学心。定非不成就无色界系有覆无记心。若不成就无色界系无覆无记心。亦不成就学心耶。或不成就无色界系无覆无记心。非学心。广说四句。不成就无色界系无覆无记心。非学心者。谓欲界色界生长有学。及无色界生长有学。异熟果心。不现在前。不成就学心。非无色界系无覆无记心者。谓无色界生长。阿罗汉异生。异熟果心。正现在前。不成就无色界系无覆无记心。亦学心者。谓欲界色界生长。阿罗汉异生。及无色界生长。阿罗汉异生。异熟果心。不现在前。非不成就无色界系无覆无记心。亦非学心者。谓无色界生长有学。异熟果心。正现在前。若不成就无色界系无覆无记心。亦不成就无学心耶。或不成就无色界系无覆无记心。非无学心。广说四句。不成就无色界系无覆无记心。非无学心者。谓欲界色界生长诸阿罗汉。及无色界生长诸阿罗汉。异熟果心。不现在前。不成就无学心。非无色界系无覆无记心者。谓无色界生长有学异生。异熟果心。正现在前。不成就无色界系无覆无记心。亦无学心者。谓欲界色界生长有学异生。及无色界生长有学异生。异熟果心。不现在前。非不成就无色界系无覆无记心。亦非无学心者。谓无色界生长阿罗汉。异熟果心。正现在前。若不成就学心。亦不成就无学心耶。或不成就学心。非无学心。或不成就无学心。非学心。或不成就学心。亦无学心。或非不成就学心。亦非无学心。不成就学心。非无学心者。谓阿罗汉。不成就无学心。非学心者。谓诸有学不成就学心。亦无学心者。谓诸异生。非不成就学心。亦非无学心者。无有此句

有十二心。谓欲界系善心。不善心。有覆无记心。无覆无记心。色界系善心。有覆无记心。无覆无记心。无色界系善心。有覆无记心。无覆无记心。及学心。无学心。若欲界系善心。舍成就得不成就。不善心亦尔耶。设不善心舍成就得不成就。欲界系善心亦尔耶。若欲界系善心。舍成就得不成就。乃至无学心亦尔耶。设无学心。舍成就得不成就。欲界系善心亦尔耶。乃至若学心。舍成就得不成就。无学心亦尔耶。设无学心。舍成就得不成就。学心亦尔耶

若欲界系善心。舍成就得不成就。定非不善心。及欲界系有覆无记心。若不善心。及欲界系有覆无记心。舍成就得不成就。定非欲界系善心。若欲界系善心。舍成就得不成就。欲界系无覆无记心亦尔耶。或欲界系善心。舍成就得不成就。非欲界系无覆无记心。或欲界系无覆无记心。舍成就得不成就。非欲界系善心。或欲界系善心。舍成就得不成就。亦欲界系无覆无记心。或非欲界系善心。舍成就得不成就。亦非欲界系无覆无记心。欲界系善心。舍成就得不成就。非欲界系无覆无记心者。谓善根断时。及欲界没。色界生时。欲界系无覆无记心舍成就得不成就。非欲界系善心者。谓从色界没无色界生时。欲界系善心舍成就得不成就。亦欲界系无覆无记心者。谓从欲界没。无色界生时。非欲界系善心舍成就得不成就。亦非欲界系无覆无记心者。除上尔所相。若欲界系善心。舍成就得不成就。色界系善心亦尔耶。或欲界系善心。舍成就得不成就。非色界系善心。广说四句。欲界系善心舍成就得不成就。非色界系善心者。谓善根断时。及欲界没。色界生时。色界系善心舍成就得不成就。非欲界系善心者。谓欲界生长。已得色界善心。从色界善心。复还退时。及色界没。或欲界或无色界生时。欲界系善心舍成就得不成就。亦色界系善心者。谓从欲界没。无色界生时。非欲界系善心舍成就得不成就。亦非色界系善心者。除上尔所相。若欲界善心。舍成就得不成就。定非色界系有覆无记心。若色界系有覆无记心。舍成就得不成就。定非欲界系善心。若欲界善心。舍成就得不成就。色界系无覆无记心亦尔耶。或欲界系善心。舍成就得不成就。非色界系无覆无记心。广说四句。欲界系善心舍成就得不成就。非色界系无覆无记心者。谓善根断时。及欲界没色界生时。色界系无覆无记心。舍成就得不成就。非欲界系善心者。谓已离欲界贪。从离欲贪复还退时。及色界没欲界生时。若从色界没无色界生时。欲界善心舍成就得不成就。亦色界系无覆无记心者。谓从欲界没。无色界生时。非欲界系善心舍成就得不成就。亦非色界系无覆无记心者。除上尔所相。若欲界系善心。舍成就得不成就。定非无色界系善心。若无色界系善心。舍成就得不成就。定非欲界系善心。从此以后。亦都无有。若不善心。舍成就得不成就。欲界系有覆无记心亦尔耶。或不善心。舍成就得不成就。非欲界系有覆无记心。广说四句。不善心舍成就得不成就。非欲界系有覆无记心者。谓诸圣者离欲贪时。欲界有覆无记心舍成就得不成就。非不善心者。谓未离欲界贪圣者。现观边苦法智现在前时。不善心舍成就得不成就。亦欲界系有覆无记心者。谓诸异生离欲贪时。非不善心舍成就得不成就。亦非欲界系有覆无记心者。除上尔所相。若不善心。舍成就得不成就。定非欲界系无覆无记心。若欲界系无覆无记心。舍成就得不成就。定非不善心。从此已后亦都无有。若欲界系有覆无记心。舍成就得不成就。定非欲界系无覆无记心。若欲界系无覆无记心。舍成就得不成就。定非欲界系有覆无记心。从此已后亦都无有。若欲界系无覆无记心。舍成就得不成就。色界系善心亦尔耶。若欲界系无覆无记心。舍成就得不成就。色界系善心定尔。或色界系善心。舍成就得不成就。非欲界系无覆无记心。谓欲界生长。已得色界善心。从色界善心。复还退时。及色界没欲界生时。若欲界系无覆无记心。舍成就得不成就。定非色界系有覆无记心。若色界系有覆无记心。舍成就得不成就。定非欲界系无覆无记心。若欲界系无覆无记心。舍成就得不成就。色界系无覆无记心亦尔耶。若欲界系无覆无记心。舍成就得不成就。色界系无覆无记心定尔。或色界系无覆无记心。舍成就得不成就。非欲界系无覆无记心。谓已离欲界贪。从离欲贪。复还退时。及色界没欲界生时。若欲界系无覆无记心。舍成就得不成就。定非无色界系善心。若无色界系善心。舍成就得不成就。定非欲界系无覆无记心。从此以后都无所有。若色界系善心。舍成就得不成就。定非色界系有覆无记心。若色界系有覆无记心。舍成就得不成就。定非色界系善心。若色界系善心。舍成就得不成就。色界系无覆无记心亦尔耶。或色界系善心。舍成就得不成就。非色界系无覆无记心。广说四句。色界系善心舍成就得不成就。非色界系无覆无记心者。谓欲界生长异生。未离欲界贪。已得色界善心。从色界善心。复还退时。色界系无覆无记心。舍成就得不成就。非色界系善心者。谓已离欲界贪圣者。从离欲贪复还退时。色界系善心舍成就得不成就。亦色界系无覆无记心者。谓已离欲界贪异生。从离欲贪。复还退时。及欲界色界没。无色界生时。若色界没欲界生时。非色界系善心舍成就得不成就。亦非色界系无覆无记心者。除上尔所相。若色界系善心。舍成就得不成就。无色界系善心亦尔耶。或色界系善心。舍成就得不成就。非无色界系善心。广说四句。色界系善心舍成就得不成就。非无色界系善心者。谓欲界生长。已得色界善心。未得无色界善心。从色界善心。复还退时。及色界没。或欲界或无色界生时。若欲界没无色界生时。无色界系善心舍成就得不成就。非色界系善心者谓欲界生长。已得无色界善心。起色界缠复还退时。及无色界没。或欲界或色界生时。色界系善心舍成就得不成就亦无色界系善心者。谓欲界生长异生。已得无色界善心。起欲界缠复还退时。非色界系善心舍成就得不成就。亦非无色界系善心者。除上尔所相。若色界系善心。舍成就得不成就。定非无色界系有覆无记心。若无色界系有覆无记心舍成就得不成就。定非色界系善心。从此以后都无所有。若色界系有覆无记心。舍成就得不成就。定非色界系无覆无记心。若色界系无覆无记心。舍成就得不成就。定非色界系有覆无记心。从此以后都无所有。若色界系无覆无记心舍成就得不成就。无色界系善心亦尔耶。或色界系无覆无记心。舍成就得不成就。非无色界系善心。广说四句。色界系无覆无记心舍成就得不成就。非无色界系善心者。谓欲界生长。已离欲界贪。未得色界善心。从离欲贪。复还退时。及色界没。或欲界或无色界生时。无色界系善心舍成就得不成就。非色界系无覆无记心者。谓欲界生长。已得无色界善心。起色界缠。复还退时。及无色界没。或欲界或色界生时。色界系无覆无记心舍成就得不成就。亦无色界系善心者。谓欲界生长。已得无色界善心。起欲界缠。复还退时。非色界系无覆无记心舍成就得不成就。亦非无色界系善心者。除上尔所相。若色界系无覆无记心。舍成就得不成就。定非无色界系有覆无记心无覆无记心学心。若无色界系有覆无记心。无覆无记心学心。舍成就得不成就。定非色界系无覆无记心。若色界系无覆无记心。舍成就得不成就。无学心亦尔耶。或色界系无覆无记心。舍成就得不成就。非无学心。广说四句。色界系无覆无记心舍成就得不成就。非无学心者。谓已离欲界贪。有学异生。从离欲贪。复还退时。及色界没。或欲界或无色界生时。若欲界没无色界生时。无学心舍成就得不成就。非色界系无覆无记心者。谓阿罗汉。起色无色缠。复还退时。色界系无覆无记心舍成就得不成就。亦无学心者。谓阿罗汉。起欲界缠。复还退时。非色界系无覆无记心舍成就得不成就。亦非无学心者。除上尔所相。若无色界系善心。舍成就得不成就。定非无色界系有覆无记心。若无色界系有覆无记心。舍成就得不成就。定非无色界系善心。若无色界系善心。舍成就得不成就。无色界系无覆无记心亦尔耶。或无色界系善心。舍成就得不成就非无色界系无覆无记心。广说四句。无色界系善心舍成就得不成就。非无色界系无覆无记心者。谓欲界色界生长。已得无色界善心。从无色界善心。复还退时。及无色界善心。染污心没。或欲界或色界生时。无色界无覆无记心舍成就得不成就。非无色界系善心者。谓无色界异熟果心生已灭时。无色界系善心舍成就得不成就。亦无色界系无覆无记心者。谓无色界住。异熟果心没。或欲界或色界生时。非无色界系善心舍成就得不成就。亦非无色界系无覆无记心者。除上尔所相。若无色界系善心。舍成就得不成就。定非学心。若学心。舍成就得不成就。定非无色界系善心。若无色界系善心。舍成就得不成就。无学心亦尔耶。或无色界系善心。舍成就得不成就。非无学心。广说四句。无色界系善心舍成就得不成就。非无学心者。谓有学异生。已得无色界善心。从无色界善心。复还退时。及无色界没。或欲界或色界生时。无学心舍成就得不成就。非无色界系善心者。谓阿罗汉。起无色缠。复还退时。无色界系善心舍成就得不成就。亦无学心者。谓阿罗汉。起欲色界缠。复还退时。非无色界系善心舍成就得不成就。亦非无学心者。除上尔所相。若无色界系有覆无记心。舍成就得不成就。定非无色界系无覆无记心。若无色界系无覆无记心舍成就得不成就。定非无色界系有覆无记心。从此以后都无所有。若无色界系无覆无记心。舍成就得不成就。定非学心及无学心。若学心及无学心。舍成就得不成就。定非无色界系无覆无记心。若学心。舍成就得不成就。定非无学心。若无学心。舍成就得不成就。定非学心

说一切有部识身足论卷第十五阿毗达磨识身足论卷第十六

        提婆设摩阿罗汉造

        三藏法师玄奘奉　诏译

    成就蕴第六之四

有十二心。谓欲界系善心。不善心。有覆无记心。无覆无记心。色界系善心。有覆无记心。无覆无记心。无色界系善心。有覆无记心。无覆无记心。及学心。无学心。若欲界系善心。舍不成就得成就。不善心亦尔耶。设不善心。舍不成就得成就。欲界系善心亦尔耶。若欲界系善心。舍不成就得成就。乃至无学心亦尔耶。设无学心。舍不成就得成就。欲界系善心亦尔耶。乃至若学心。舍不成就得成就。无学心亦尔耶。设无学心。舍不成就得成就。学心亦尔耶

若欲界系善心。舍不成就得成就。不善心亦尔耶。或欲界系善心。舍不成就得成就。非不善心。广说四句。欲界系善心舍不成就得成就非不善心者。谓善根续时。不善心舍不成就得成就。非欲界系善心者。谓已离欲界贪。从离欲贪。复还退时。欲界系善心舍不成就得成就。亦不善心者。谓色无色界没。欲界生时。非欲界善心舍不成就得成就。亦非不善心者。除上尔所相。若欲界系善心。舍不成就得成就。欲界系有覆无记心亦尔耶。或欲界系善心。舍不成就得成就。非欲界系有覆无记心。广说四句。欲界善心舍不成就得成就。非欲界系有覆无记心者。谓善根续时。欲界系有覆无记心舍不成就得成就。非欲界系善心者。谓已离欲界贪异生。从离欲贪。复还退时。欲界系善心舍不成就得成就。亦欲界系有覆无记心者。谓色无色界没。欲界生时非欲界系善心舍不成就得成就。亦非欲界系有覆无记心者。除上尔所相。若欲界系善心。舍不成就得成就。欲界系无覆无记心亦尔耶。或欲界系善心。舍不成就得成就。非欲界系无覆无记心。广说四句。欲界系善。心舍不成就得成就。非欲界系无覆无记心者。谓善根续时。及色界没。欲界生时。欲界系无覆无记心舍不成就得成就。非欲界系善心者。谓无色界没。色界生时。欲界系善心舍不成就得成就。亦欲界系无覆无记心者。谓无色界没。欲界生时。非欲界系善心舍不成就得成就。亦非欲界系无覆无记心者。除上尔所相。若欲界系善心。舍不成就得成就。定非色界系善心。若色界系善心。舍不成就得成就。定非欲界系善心。若欲界系善心。舍不成就得成就。色界系有覆无记心亦尔耶。或欲界系善心。舍不成就得成就。非色界系有覆无记心。广说四句。欲界系善心舍不成就得成就。非色界系有覆无记心者。谓善根续时。及色界没。欲界生时。色界系有覆无记心舍不成就得成就。非欲界系善心者。谓已离色界贪。从离色贪。复还退时。及无色界没。色界生时。欲界系善心舍不成就得成就。亦色界系有覆无记心者。谓无色界没。欲界生时。非欲界系善心舍不成就得成就。亦非色界系有覆无记心者。除上尔所相。若欲界系善心。舍不成就得成就。定非色界系无覆无记心。若色界系无覆无记心。舍不成就得成就。定非欲界系善心。从此以后。都无所有。若不善心。舍不成就得成就。欲界系有覆无记心亦尔耶。若欲界系有覆无记心舍不成就得成就。不善心定尔。或不善心。舍不成就得成就。非欲界系有覆无记心。谓已离欲界贪圣者。从离欲贪。复还退时。若不善心。舍不成就得成就。欲界系无覆无记心亦尔耶。或不善心。舍不成就得成就。非欲界系无覆无记心。广说四句。不善心舍不成就得成就。非欲界系无覆无记心者。谓已离欲界贪。从离欲贪。复还退时。及色界没。欲界生时欲界无覆无记心舍不成就得成就。非不善心者。谓无色界没。色界生时。不善心舍不成就得成就。亦欲界系无覆无记心者。谓无色界没。欲界生时。非不善心舍不成就得成就。亦非欲界系无覆无记心者。除上尔所相。若不善心。舍不成就得成就。定非色界系善心。若色界系善心。舍不成就得成就。定非不善心。若不善心。舍不成就得成就。色界系有覆无记心亦尔耶。或不善心。舍不成就得成就。非色界系有覆无记心。广说四句。不善心舍不成就得成就。非色界系有覆无记心者。谓已离欲界贪。未离色界贪。从离欲贪。复还退时。及色界没。欲界生时。色界系有覆无记心舍不成就得成就。非不善心者。谓已离色界贪。起色界缠。复还退时。及无色界没。色界生时。不善心舍不成就得成就。亦色界系有覆无记心者。谓已离色界贪。起欲界缠。复还退时。及无色界没。欲界生时。非不善心舍不成就得成就。亦非色界系有覆无记心者。除上尔所相。若不善心。舍不成就得成就。定非色界系无覆无记心。及无色界系善心。若色界系无覆无记心。及无色界系善心。舍不成就得成就。定非不善心。若不善心。舍不成就得成就。无色界系有覆无记心亦尔耶。或不善心。舍不成就得成就。非无色界系有覆无记心。广说四句。不善心舍不成就得成就。非无色界系有覆无记心者。谓已离欲界贪有学异生。从离欲贪。复还退时。及色无色界没。欲界生时。无色界系有覆无记心舍不成就得成就。非不善心者。谓阿罗汉。起色无色界缠。复还退时。不善心舍不成就得成就。亦无色界系有覆无记心者。谓阿罗汉起欲界缠。复还退时。非不善心舍不成就得成就。亦非无色界系有覆无记心者。除上尔所相。若不善心。舍不成就得成就。定非无色界系无覆无记心及无学心。若无色界系无覆无记心。及无学心。舍不成就得成就。定非不善心。若不善心。舍不成就得成就。学心亦尔耶。或不善心。舍不成就得成就。非学心。广说四句。不善心舍不成就得成就。非学心者。谓已离欲界贪。有学异生。从离欲贪。复还退时。及色无色界没。欲界生时。学心舍不成就得成就。非不善心者。谓阿罗汉。起色无色界缠。复还退时。及修加行。入见道时。不善心舍不成就得成就。亦学心者。谓阿罗汉。起欲界缠。复还退时。非不善心舍不成就得成就。亦非学心者。除上尔所相。若欲界系有覆无记心。舍不成就得成就。欲界系无覆无记心亦尔耶。或欲界系有覆无记心。舍不成就得成就。非欲界系无覆无记心。广说四句。欲界系有覆无记心舍不成就得成就。非欲界系无覆无记心者。谓已离欲界贪异生。从离欲贪。复还退时。及色界没。欲界生时。欲界系无覆无记心舍不成就得成就。非欲界系有覆无记心者。谓无色界没。色界生时。欲界系有覆无记心舍不成就得成就。亦欲界系无覆无记心者。谓无色界没。欲界生时。非欲界系有覆无记心舍不成就得成就。亦非欲界系无覆无记心者。除上尔所相。若欲界系有覆无记心。舍不成就得成就。定非色界系善心。若色界系善心。舍不成就得成就。定非欲界系有覆无记心。若欲界系有覆无记心。舍不成就得成就。色界系有覆无记心亦尔耶。或欲界系有覆无记心。舍不成就得成就。非色界系有覆无记心。广说四句。欲界系有覆无记心舍不成就得成就。非色界系有覆无记心者。谓已离欲界贪异生。未离色界贪。从离欲贪。复还退时。及色界没。欲界生时。色界系有覆无记心舍不成就得成就。非欲界系有覆无记心者。谓已离色界贪。起色界缠。复还退时。及无色界没。色界生时。欲界系有覆无记心舍不成就得成就。亦色界系有覆无记心者。谓已离色界贪异生。起欲界缠。复还退时。及无色界没。欲界生时。非欲界系有覆无记心舍不成就得成就。亦非色界系有覆无记心者。除上尔所相。若欲界系有覆无记心。舍不成就得成就。定非色界系无覆无记心。若色界系无覆无记心。舍不成就得成就。定非欲界系有覆无记心。从此以后。都无所有。若欲界系无覆无记心。舍不成就得成就。色界系善心亦尔耶。或欲界系无覆无记心。舍不成就得成就。非色界系善心。广说四句。欲界系无覆无记心舍不成就得成就。非色界系善心者。谓无色界没。欲界生时。色界系善心舍不成就得成就。非欲界系无覆无记心者。谓修加行。色界善心。初现前时。欲界系无覆无记心舍不成就得成就。亦欲界系善心者。谓无色界没。色界生时。非欲界系无覆无记心舍不成就得成就。亦非色界系善心者。除上尔所相。若欲界系无覆无记心。舍不成就得成就。色界系有覆无记心定尔。或色界系有覆无记心。舍不成就得成就。非欲界系无覆无记心。谓已离色界贪。从离色贪。复还退时。若欲界系无覆无记心。舍不成就得成就。色界系无覆无记心亦尔耶。或欲界系无覆无记心。舍不成就得成就。非色界系无覆无记心。广说四句。欲界系无覆无记心舍不成就得成就。非色界系无覆无记心者。谓无色界没。欲界生时。色界系无覆无记心舍不成就得成就。非欲界系无覆无记心者。谓于欲界。得离欲时。欲界系无覆无记心舍不成就得成就。亦色界系无覆无记心者。谓无色界没。色界生时。非欲界系无覆无记心舍不成就得成就。亦非色界系无覆无记心者。除上尔所相。若欲界系无覆无记心。舍不成就得成就。定非无色界系善心。若无色界系善心。舍不成就得成就。定非欲界系无覆无记心。从此以后。都无所有。若色界系善心。舍不成就得成就。色界系有覆无记心亦尔耶。或色界系善心。舍不成就得成就。非色界系有覆无记心。广说四句。色界系善心舍不成就得成就。非色界系有覆无记心者。谓修加行。色界善心。初现前时。色界系有覆无记心舍不成就得成就。非色界系善心者。谓已离色界贪。从离色贪。复还退时。及无色界没。欲界生时。色界系善心舍不成就得成就。亦色界系有覆无记心者。谓无色界没。色界生时。非色界系善心舍不成就得成就。亦非色界系有覆无记心者。除上尔所相。若色界系善心。舍不成就得成就。色界系无覆无记心亦尔耶。或色界系善心。舍不成就得成就。非色界系无覆无记心。广说四句。色界系善心舍不成就得成就。非色界系无覆无记心者。谓修加行。色界善心。初现前时。色界系无覆无记心舍不成就得成就。非色界系善心者。谓于欲界得离欲时。色界系善心舍不成就得成就。亦色界系无覆无记心者。谓无色界没。色界生时。非色界系善心舍不成就得成就。亦非色界系无覆无记心者。除上尔所相。若色界系善心。舍不成就得成就。定非无色界系善心。若无色界系善心。舍不成就得成就。定非色界系善心。从此以后。都无所有。若色界系有覆无记心。舍不成就得成就。色界系无覆无记心亦尔耶。或色界系有覆无记心。舍不成就得成就。非色界系无覆无记心。广说四句。色界系有覆无记心。舍不成就得成就。非色界系无覆无记心者。谓已离色界贪。从离色界贪。复还退时。及无色界没欲界生时。色界系无覆无记心舍不成就得成就。非色界系有覆无记心者。谓于欲界得离欲时。色界系有覆无记心舍不成就得成就。亦色界系无覆无记心者。谓无色界没。色界生时。非色界系有覆无记心舍不成就得成就。亦非色界系无覆无记心者。除上尔所相。若色界系有覆无记心。舍不成就得成就。定非无色界系善心。若无色界系善心。舍不成就得成就。定非色界系有覆无记心。若色界系有覆无记心。舍不成就得成就。无色界系有覆无记心亦尔耶。或色界系有覆无记心。舍不成就得成就。非无色界系有覆无记心。广说四句。色界系有覆无记心舍不成就得成就。非无色界系有覆无记心者。谓已离色界贪。有学异生。从离色贪。复还退时。及无色界没。欲界生时。无色界系有覆无记心舍不成就得成就。非色界系有覆无记心者。谓阿罗汉。起无色界缠。复还退时。色界系有覆无记心舍不成就得成就。亦无色界系有覆无记心者。谓阿罗汉。起欲界色界缠。复还退时。非色界系有覆无记心舍不成就得成就。亦非无色界系有覆无记心者。除上尔所相。若色界系有覆无记心。舍不成就得成就。定非无色界系无覆无记心。及无学心。若无色界系无覆无记心。及无学心。舍不成就得成就。定非色界系有覆无记心。若色界系有覆无记心。舍不成就得成就。学心亦尔耶。或色界系有覆无记心。舍不成就得成就非学心。广说四句。色界系有覆无记心舍不成就得成就。非学心者。谓已离色界贪。有学异生。从离色贪。复还退时。及无色界没。欲界色界生时。学心舍不成就得成就。非色界系有覆无记心者。谓阿罗汉。起无色界缠。复还退时。及修加行入见道时。无色界系有覆无记心舍不成就得成就。亦非学心者。谓阿罗汉。起欲界色界缠。复还退时。非色界系有覆无记心舍不成就得成就。亦非学心者。除上尔所相。若色界系无覆无记心。舍不成就得成就。定非无色界系善心。若无色界系善心。舍不成就得成就。定非色界系无覆无记心。从此以后。都无所有。若无色界系善心。舍不成就得成就。定非无色界系有覆无记心。若无色界系有覆无记心。舍不成就得成就。定非无色界系善心。从此以后。都无所有。若无色界系有覆无记心。舍不成就得成就。定非无色界系无覆无记心及无学心。若无色界系无覆无记心。及无学心。舍不成就得成就。定非无色界系有覆无记心。若无色界系有覆无记心。舍不成就得成就。学心定尔。或学心。舍不成就得成就。非无色界系有覆无记心。谓修加行。入见道时。若无色界系无覆无记心。舍不成就得成就。定非学心及无学心。若学心及无学心。舍不成就得成就。定非无色界系无覆无记心。若学心。舍不成就得成就。定非无学心。若无学心。舍不成就得成就。定非学心。有十种心。谓欲界系善心。不善心有覆无记心。无覆无记心。色界系善心。有覆无记心。无覆无记心。无色界系善心。有覆无记心。无覆无记心。若欲界系善心未断。成就此心耶。设成就此心。此心未断耶。乃至若无色界系无覆无记心未断。成就此心耶。设成就此心。此心未断耶

若欲界系善心未断。成就此心耶。或欲界系善心未断。非成就此心。或成就此心。非此心未断。或此心未断。亦成就此心。或非此心未断。亦非成就此心。此心未断。非成就此心者。谓已断善根成就此心。非此心未断者。谓欲界生长。已离欲界贪。此心未断。亦成就此心者。谓欲界生长。不断善根。未离欲界贪。非此心未断亦非成就此心者。谓色无色界生长。若不善心未断。成就此心耶。曰如是。设成就此心。此心未断耶。曰如是。若欲界系有覆无记心未断。成就此心耶。曰如是。设成就此心。此心未断耶。曰如是。若欲界系无覆无记心未断。成就此心耶。若此心未断。定成就此心。或成就此心。非此心未断。谓欲界生长。已离欲界贪。及色界生长。若色界系善心未断。成就此心耶。或色界系善心未断。非成就此心。或成就此心。非此心未断。或此心未断。亦成就此心。或非此心未断。亦非成就此心。色界系善心未断非成就此心者。谓欲界生长未得色界善心。成就此心非此心未断者。谓欲界色界生长。已离色界贪。此心未断亦成就此心者。谓欲界生长。已得色界善心。未离色界贪。及色界生长。未离彼贪。非此心未断亦非成就此心者。谓无色界生长。若色界系有覆无记心未断。成就此心耶。曰如是。设成就此心。此心未断耶。曰如是。若色界系无覆无记心未断。成就此心耶。或色界系无覆无记心未断。非成就此心。或成就此心。非此心未断。或此心未断。亦成就此心。或非此心未断。亦非成就此心。色界系无覆无记心未断非成就此心者。谓欲界生长。未离欲界贪。成就此心非此心未断者。谓欲界色界生长。已离色界贪。此心未断亦成就此心者。谓欲界生长。已离欲界贪。未离色界贪。及色界生长。未离彼贪。非此心未断亦非成就此心者。谓无色界生长。若无色界系善心未断。成就此心耶。或无色界善心未断。非成就此心。或成就此心。非此心未断。或此心未断。亦成就此心。或非此心未断。亦非成就此心。无色界系善心未断非成就此心者。谓未得无色界善心。成就此心非此心未断者。谓阿罗汉。此心未断亦成就此心者。谓有学异生。已得无色界善心非此心未断亦非成就此心者。无有此句。若无色界系有覆无记心未断成就此心耶。曰如是。设成就此心。此心未断耶。曰如是。若无色界系无覆无记心未断成就此心耶。或无色界系无覆无记心未断。非成就此心。或成就此心。非此心未断。或此心未断。亦成就此心。或非此心未断。亦非成就此心。无色界系无覆无记心未断亦非成就此心者。谓有学异生。无色界系异熟果心。不现在前。成就此心非此心未断者。谓阿罗汉。无色界系异熟果心。正现在前。此心未断亦成就此心者。谓有学异生。无色界系异熟果心。正现在前。非此心未断亦非成就此心者。谓阿罗汉。无色界系异熟果心。不现在前

有十种心。谓欲界系善心。不善心。有覆无记心。无覆无记心。色界系善心。有覆无记心。无覆无记心。无色界系善心。有覆无记心。无覆无记心。若欲界系善心已断。不成就此心耶。设不成就此心。此心已断耶。乃至若无色界系无覆无记心已断。不成就此心耶。设不成就此心。此心已断耶

若欲界系善心已断。不成就此心耶。或欲界系善心已断。非不成就此心。或不成就此心。非此心已断。或此心已断。亦不成就此心。或非此心已断。亦非不成就此心。欲界系善心已断非不成就此心者。谓欲界生长。已离欲界贪。不成就此心非此心已断者。谓已断善根。此心已断亦不成就此心者。谓色无色界生长。非此心已断亦非不成就此心者。谓欲界生长。不断善根。未离欲界贪。若不善心已断。不成就此心耶。曰如是。设不成就此心。此心已断耶。曰如是。若欲界系有覆无记心已断。不成就此心耶。曰如是。设不成就此心。此心已断耶。曰如是。若欲界系无覆无记心已断。不成就此心耶。若欲界系无覆无记心。不成就此心定已断。或此心已断。非不成就此心。谓欲界生长。已离欲界贪。及色界生长。若色界系善心已断。不成就此心耶。或色界系善心已断。非不成就此心。或不成就此心。非此心已断。或此心已断。亦不成就此心。或非此心已断。亦非不成就此心。色界系善心已断非不成就此心者。谓欲界色界生长已离色界贪。不成就此心非此心已断者。谓欲界生长。未得色界善心。此心已断。亦不成就此心者。谓无色界生长。非此心已断亦非不成就此心者。谓欲界生长。已得色界善心未离色界贪。及色界生长。未离彼贪若色界系有覆无记心已断。不成就此心耶。曰如是。设不成就此心此心已断耶。曰如是。若色界系无覆无记心已断。不成就此心耶。或色界系无覆无记心已断。非不成就此心。或不成就此心。非此心已断。或此心已断。亦不成就此心。或非此心已断。亦非不成就此心。色界系无覆无记心已断非不成就此心者。谓欲界色界生长。已离色界贪。不成就此心非此心已断者。谓欲界生长。未离欲界贪。此心已断亦不成就此心者。谓无色界生长。非此心已断亦非不成就此心者。谓欲界生长。已离欲界贪。未离色界贪。及色界生长。未离彼贪。若无色界系善心已断。不成就此心耶。若无色界系善心已断。定非不成就此心。或不成就此心。非此心已断。谓未得无色界善心。若无色界系有覆无记心已断。不成就此心耶。曰如是。设不成就此心。此心已断耶。曰如是。若无色界系无覆无记心已断。不成就此心耶。或无色界系无覆无记心已断。非不成就此心。或不成就此心。非此心已断。或此心已断。亦不成就此心。或非此心已断。亦非不成就此心。无色界系无覆无记心已断非不成就此心者。谓阿罗汉。无色界系异熟果心。正现在前。不成就此心非此心已断者。谓有学异生。无色界系异熟果心。不现在前。此心已断亦不成就此心者。谓阿罗汉。无色界系异熟果心。不现在前。非此心已断亦非不成就此心者。谓有学异生。无色界系异熟果心。正现在前

有十二心。谓欲界系善心。不善心。有覆无记心。无覆无记心。色界系善心。有覆无记心。无覆无记心。无色界系善心。有覆无记心。无覆无记心。及学心。无学心。若成就欲界系善心。如是十二心几成就。几不成就。乃至若成就无学心。如是十二心。几成就。几不成就

若成就欲界系善心。二心定成就。一心定不成就。余或成就。或不成就。若成就不善心。四心定成就。四心定不成就。余或成就或不成就。若成就欲界系有覆无记心。五心定成就。四心定不成就。余或成就。或不成就。若成就欲界系无覆无记心。此一心定成就。一心定不成就。余或成就。或不成就。若成就色界系善心。二心定成就。一心定不成就。余或成就。或不成就。若成就色界系有覆无记心。三心定成就。二心定不成就。余或成就。或不成就。若成就色界系无覆无记心。三心定成就。三心定不成就。余或成就。或不成就。若成就无色界系善心。此一心定成就。二心定不成就。余或成就。或不成就。若成就无色界系有覆无记心。此一心定成就。一心定不成就。余或成就。或不成就。若成就无色界系无覆无记心。二心定成就。七心定不成就。余或成就。或不成就。若成就学心。二心定成就。一心定不成就。余或成就。或不成就。若成就无学心。二心定成就。五心定不成就。余或成就。或不成就

有十二心。谓欲界系善心。不善心。有覆无记心。无覆无记心。色界系善心。有覆无记心。无覆无记心。无色界系善心。有覆无记心。无覆无记心。及学心。无学心。若不成就欲界系善心。如是十二心。几不成就。几成就。乃至若不成就无学心。如是十二心。几不成就几成就。若不成就欲界系善心。此一心定不成就余或成就。或不成就若不成就不善心。二心定不成就。余或成就。或不成就。若不成就欲界系有覆无记心此一心定不成就。余或成就。或不成就若不成就欲界系无覆无记心。七心定不成就。一心定成就。余或成就。或不成就。若不成就色界系善心。二心定不成就。余或成就。或不成就。若不成就色界系有覆无记心。三心定不成就。一心定成就。余或成就。或不成就。若不成就色界系无覆无记心。此一心定不成就。余或成就。或不成就。若不成就无色界系善心。三心定不成就。三心定成就。余或成就。或不成就。若不成就无色界系有覆无记心。五心定不成就。二心定成就。余或成就。或不成就。若不成就无色界系无覆无记心。此一心定不成就。余或成就。或不成就。若不成就学心。此一心定不成就。余或成就。或不成就。若不成就无学心。此一心定不成就。一心定成就。余或成就或不成就

有十二心。谓欲界系善心。不善心。有覆无记心。无覆无记心。色界系善心。有覆无记心。无覆无记心。无色界系善心。有覆无记心。无覆无记心。及学心。无学心。复有三种补特伽罗。一未离欲界贪补特伽罗。二未离色界贪补特伽罗。三未离无色界贪补特伽罗。未离欲界贪补特伽罗。如是十二心。几成就。几不成就。未离色界贪补特伽罗。如是十二心。几成就。几不成就。未离无色界贪补特伽罗。如是十二心。几成就。几不成就

未离欲界贪补特伽罗。四心定成就。四心定不成就。余或成就。或不成就。未离色界贪补特伽罗。三心定成就。二心定不成就。余或成就。或不成就。未离无色界贪补特伽罗。一心定成就。一心定不成就。余或成就。或不成就。十二心。谓欲界系善心。不善心。有覆无记心。无覆无记心。色界系善心。有覆无记心。无覆无记心。无色界系善心。有覆无记心。无覆无记心。及学心。无学心。复有三种补特伽罗。一已离欲界贪补特伽罗。二已离色界贪补特伽罗。三已离无色界贪补特伽罗。已离欲界贪补特伽罗。如是十二心。几不成就。几成就。已离色界贪补特伽罗。如是十二心。几不成就。几成就。已离无色界贪补特伽罗。如是十二心。几不成就。几成就

已离欲界贪补特伽罗。二心定不成就。余或成就。或不成就。已离色界贪补特伽罗。三心定不成就。一心定成就。余或成就。或不成就。已离无色界贪补特伽罗。五心定不成就。二心定成就。余或成就。或不成就

若最初梵世系善心现在前。一切欲界系善心等无间耶。若最初修加行梵世系善心现在前。一切欲界系善心等无间。或最初梵世系善心现在前。非欲界系善心等无间。谓从梵世上没。生梵世中。彼最初梵世系善心现在前。乃至若最初无所有处系善心现在前。一切识无边处系善心等无间耶。若最初修加行无所有处系善心现在前。一切识无边处系善心等无间。或最初无所有处系善心现在前。非识无边处系善心等无间。谓从非想非非想处没。生无所有处。彼最初无所有处系善心现在前

有十二心。欲界系善心。不善心。有覆无记心。无覆无记心。色界系善心。有覆无记心。无覆无记心。无色界系善心。有覆无记心。无覆无记心。及学心无学心。若学心。舍成就得不成就。如是十二心。几舍成就得不成就。几舍不成就得成就。若无学心。舍成就得不成就。如是十二心。几舍成就得不成就。几舍不成就得成就

若学心。舍成就得不成就。二心定舍成就得不成就。一心定舍不成就得成就。余非舍成就得不成就。亦非舍不成就得成就若无学心。舍成就得不成就。一心定舍成就得不成就。二心定舍不成就得成就。二心或舍成就得不成就。二心或舍不成就得成就。五心非舍成就得不成就。亦非舍不成就得成就

有十二心。谓欲界系善心。不善心。有覆无记心。无覆无记心。色界系善心。有覆无记心。无覆无记心。无色界系善心。有覆无记心。无覆无记心。及学心。无学心。若学心。舍不成就得成就。如是十二心。几舍不成就得成就。几舍成就得不成就。若无学心。舍不成就得成就。如是十二心。几舍不成就得成就。几舍成就得不成就

若学心。舍不成就得成就或有二心定。舍不成就得成就。一心定舍成就得不成就。二心或舍不成就得成就。二心或舍成就得不成就。或有得一。都无所舍。五心非舍不成就得成就。亦非舍成就得不成就。若无学心。舍不成就得成就。一心定舍不成就得成就。二心定舍成就得不成就

说一切有部识身足论卷第十六


阿毗达磨顺正理论

    No. 1562

阿毗达磨顺正理论卷第一

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩本事品第一之一

  诸一切种诸冥灭　　拔众生出生死埿
  敬礼如是如理师　　对法藏论我当说

论曰。诸欲造论。必有宗承。于所奉尊。理先归敬。所以经主观诸世间。皆为邪师异论所惑。自师永离一切诸冥。立教不虚。处大师位。成就尊胜不共功德。为缘引发殷净信心。欲正流通彼所立教。故先赞礼佛薄伽梵自利利他圆满功德。用标嘉瑞。许发论端。此中世尊智断二德皆具足故。自利圆满。恩德备故。利他圆满。所以者何。一切种冥皆永灭故。智德圆满。诸境界冥亦永灭故。断德圆满。授正教手拔众生出生死泥故。恩德圆满。声闻独觉。虽破诸冥。而犹未能灭一切种。故不成就一切种智。未得所有无知差别。不行智故。意乐随眠智等阙故。不能如理济拔有情。自利利他德未满故。虽有圣德而不名师。唯佛世尊二德圆满。无倒济拔一切有情。成就希奇广大名称。位居尊极。独号大师。故先赞礼大师功德。以开所说对法藏论。对法者何。颂曰

  净慧随行名对法　　及能得此诸慧论

论曰。慧者择法义。净者无漏义。诸漏名垢。择法离垢故名净慧。何缘得知此无漏慧名为对法。以佛世尊恣天帝等所请问故。如契经言。我有甚深阿毗达磨及毗奈耶。恣汝请问。此以圣道及圣道果。恣天帝释随意请问。恣筏蹉类请问亦尔。复以何缘唯无漏慧名为对法。由此现观诸法相已。不重迷故。岂不现观非唯慧能。是则对法应非唯慧。实非唯慧。谓及随行。何谓随行。谓慧随转色受想等诸心所法。生等及心。此则总说净慧随行。无漏五蕴名为对法。何故不说受等随行名为对法。慧于见等三现观中。皆有能故。生等及色有事非余。受等唯通缘事现观。受等各有领纳等用。如慧能见应名对法。受等如盲。岂名对法。不能简别四圣谛故。以于现觉苦等相中其见现观最为殊胜。于诸谛中。简择转故。受等虽与净慧俱行。而慧力持趣彼彼境。故现观中非为最胜。是故成就无漏慧根。说为胜义阿毗达磨。为有世俗阿毗达磨观彼说此为胜义耶。有谓能得此诸慧论。此谓所得无漏慧根能得诸慧。谓彼世间殊胜修慧思慧闻慧及彼随行。非离如是慧及随行无漏慧根可能证得。彼是能得此方便故。同无漏慧受对法名。如慈方便亦名慈等。能得诸论。谓彼根本阿毗达磨。是无漏慧胜资粮故。亦名对法。如业异熟。漏等资粮亦名业等。前诸慧言。亦说生得。离生得慧无能诵持对法教者。唯生得慧能正诵持契经等法。故彼亦名阿毗达磨。岂不此论是无漏慧胜资粮故亦名对法。何故乃名对法。俱舍颂曰

  摄彼胜义依彼故　　此立对法俱舍名

论曰。此就依主及多财释。藏谓坚实。犹如树藏。对法论中诸坚实义皆入此摄。是彼藏故名对法藏。即是对法之坚实义。藏或所依。犹如刀藏。谓彼对法是此所依。引彼义言造此论故。此论以彼对法为藏。名对法藏。即是对法为所依义。此论所依阿毗达磨。何因故说。谁复先说。虽不应问说对法人。佛教依法不依人故。而欲必以人为量者。此及前问。今当总答。颂曰

  若离择法定无余　　能灭诸惑胜方便
  由惑世间漂有海　　因此传佛说对法

论曰。由离择法无胜方便。能灭世间引苦诸惑。故世尊言。若于一法未达未知。我终不说能正尽苦。世间未灭诸烦恼故。于三有海生死轮回。为令世间修习择法灭诸烦恼。故言因此佛说对法。佛若不说。舍利子等诸大声闻。亦无有能于诸法相如理简择。是故此论所依根本。阿毗达磨定是佛说。经主称传显已不信。阿毗达磨是佛所说。何缘不信。传闻尊者迦多衍尼子等造故。不说对法为所依故。如世尊告阿难陀言。汝等从今当依经量。诸部对法义宗异故。此皆不然。诸大声闻。随佛圣教而结集故。阿毗达磨是佛所许。亦名佛说。能顺遍知杂染清净因果智故。如诸契经。若佛所许不名佛说。便应弃舍。无量契经若不说依非佛语者。毗柰耶藏应非佛说。临涅槃时不劝依故。若言亦劝苾刍当依别解脱经无斯过者。是则应许广毗柰耶非佛所说。便非定量。若毗柰耶即是广释戒经本故是佛说者。阿毗达磨广释契经。何故偏疑非佛所说。又即慧蕴。及与随行。并胜资粮。名为对法四依中说智是所依。不说依言。有不成过又彼唯说经非定依。而竟不言阿毗达磨及毗柰耶依有差别。又定应许阿毗达磨是经差别。故成所依。或应颂等亦非所依。世尊唯劝依经量故。又今言依。欲显何义。若显量义。理未必然。如何世尊先说四量。而今但说经为量耶。或应先时依唯说一。以法等三经所摄故。或即于彼已遮依人。亦即劝依经之差别。而今复说有唐捐过。故今言依。应显别义谓汝昔来心属于我。是则依仗补特伽罗。自今以往无别所依。应唯仗经勿令忘失。又今言经。总说一切如来圣教。若不尔者。应颂等教应非所依。而复劝依别解脱者。为令于戒起尊重心。以彼戒经不应求义。唯当恭敬如说而行。毁重戒者不可修治。故重劝依令坚持戒。是故言依非唯量义。又劝阿难依经量者。正为劝依阿毗达磨。是经之量故名经量。即是众经所有定义。阿毗达磨能决众经。判经了义不了义故。阿毗达磨名能总摄。不违一切圣教理言。故顺此理名了义经。与此理违名不了义。不了义者恐违法性。依正理教应求意旨。若异此者如先但说。依了义经。今亦应尔。唯劝依经。不应言量。所言诸部阿毗达磨义宗异故。非佛说者。经亦应尔。诸部经中。现见文义有差别故。由经有别。宗义不同。谓有诸部。诵七有经。彼对法中建立中有。如是建立渐现观等。赞学根本异门等经。说一切有部中不诵。抚掌喻等众多契经。于余部中曾所未诵。虽有众经诸部同诵。然其名句互有差别。谓有经说汝阿氏多。于当来世成等正觉。非黑非白。非黑非白异熟业等。无量名句诸部不同。是故不应由义宗异。阿毗达磨便非佛说。阿毗达磨定是佛说。由佛摄受三藏教故。如世尊说。老耄出家持吾三藏甚为难得。若谓此言依杂藏说。理必不然。以彼即是经差别故。曾无处说。别持彼故。唯有处说。持素怛缆及毗柰耶摩怛理迦。而无别处言持杂藏。亦不可说杂藏即是摩怛理迦。由别释故。如大尊者迦叶波言。摩怛理迦。名目何等。谓四念住。广说乃至八支圣道。四正行四法迹四无碍解。空空无愿无愿无相无相。诸现观边。诸世俗智。杂修静虑。无诤愿智。边际定智。止观等法。及集异门法蕴施设。如是等类。一切总谓摩怛理迦。非杂藏中此等诸法具足可得。故说杂藏。即是第三非为善说。又契经说。于阿毗达磨阿毗毗柰耶应勤修学。故知佛说阿毗达磨。若尔阿毗毗柰耶藏。应为第四。不尔由许毗柰耶藏即是阿毗毗柰耶故。所有最胜增上尸罗相应论道。以能现对毗柰耶故。名阿毗毗柰耶。所有甚深诸法性相相应论道。以能现对法性相故。名阿毗达磨。或诸契经名为达磨。论能现前决择其义。名阿毗达磨别解脱。本名毗柰耶律。唯现前广辩缘起。名阿毗毗柰耶。是故所言。不成疑难。又佛圣教三蕴所收。犹如契经。毗柰耶藏阿毗达磨定应量摄。正法灭经。亦作是说

  阿毗达磨毗柰耶　　阿笈摩中要文义
  当有不传诸弟子　　恐闻齐己有轻陵

又说此法此毗柰耶。此大师教法即对法。现见经中。有前句事。或时彼事。离前句说。如正等觉或但言觉。增上尸罗唯说尸罗。诸欲贪等但说贪等。故知此法即是对法。世尊有处。亦以法声方便说有。阿毗达磨。谓若有说随顺契经。显毗柰耶不违法性。应随此等理教信知。阿毗达磨真是佛说。谤正法罪深为可怖。勿自爱人习语恶行讪谤对法言非佛说。谤论已了。如上所言。为令世间修习择法。因此佛说阿毗达磨。何等名为彼所择法。颂曰

  有漏无漏法　　除道余有为
  于彼漏随增　　故说名有漏
  无漏谓道谛　　及三种无为
  谓虚空二灭　　此中空无碍
  择灭谓离系　　随系事各别
  毕竟碍当生　　别得非择灭

论曰。说一切法略有二种。一者有漏。二者无漏。是则总说。次当别解。除道圣谛。余有为法。是名有漏。此复云何。谓五取蕴。色乃至识。如说云何名色取蕴。谓有漏色随顺诸取。广说乃至。识亦如是。何缘取蕴名为有漏。以于彼中漏随增故。有身见等诸烦恼中立漏名想。令染污心常漏泄故。与漏相应。及漏境界。随增漏故。名漏随增。随增眠义后当广辩。由此已遮不同界地及无漏缘。烦恼境界随眠有漏。彼此展转不随增故。非相对立如是二名。有漏无漏复有何相。如世尊言。有漏法者。谓所有色随顺诸取。是能增益诸有取义。广说乃至。识亦如是。与此相违。是无漏法。有漏无漏略相如是。为广分别。复作是言。谓于过去未来现在。诸所有色生长现贪或嗔或痴。或随一一余随烦恼诸心所法。乃至广说。复为何义作如是说。为别分别顺诸取义。若尔唯应说能生长贪等烦恼。或随一一余随烦恼。非总相说。能别了知。为令一切别知义故。以非一切一切烦恼皆可现行。故唯总说。或随一一余随烦恼。又诸随眠行相微细。彼现行位有不能知。忿等行相粗显易知。故唯总说。余随烦恼或堕世间。名为有漏世间所摄。名堕世间。谓处世间不出为义。依苦谛体立世间名。故契经言。吾当为汝宣说世间及世间集。又作是言。观世间集于世间无。是为非有乃至广说。复云何知。诸堕世间皆名有漏。如契经言。吾当为汝说有漏法及无漏法。有漏法者。谓诸所有眼。诸所有色。诸所有眼识。诸所有眼触。诸所有眼触为缘内所生。或乐受或苦受或不苦不乐受。如是乃至。堕世间意。堕世间法。堕世间意识。堕世间意触。广说乃至。名有漏法。无漏法者。谓出世间意。出世间法。出世间意识。广说乃至。名无漏法。依此圣言。及由正理。有漏无漏法相成立。无法自制。譬喻论师违理背经。妄作是说。非有情数离过身中所有色等。名无漏法。此必不然。违契经故。如契经言。谓于过去未来现在诸所有色。生长现贪或嗔或痴。乃至广说。非有情数。离过身中所有色等。既能生长有情贪等。云何无漏。所以者何。无比指鬘乌卢频螺迦叶波等。缘世尊身生长贪嗔痴等漏故。彼计于言。非境第七。是依第七。如油于麻为漏所依。故名有漏。此不应理。以于去来说起现故。未曾依去来起现在贪等。是故彼计决定非善。又上经言。或随一一余随烦恼诸心所法非随烦恼。有非心所。为简彼故复言心所。故知复言心所法者。为显于言是境第七。又应灭道是无智依。如言无明以于苦等无智为性。此中于言第七声故。若此于言非许依者。因何固执。彼定是依。故于色等生长痴等。非定漏依方名有漏。又一切声皆应无漏。以声定非漏所依故。不应执声定是无漏。经言声体是杂染故。非说无漏名为杂染。是应理言。又诸异生身中善识应成无漏。非漏依故。若言漏分随逐故者。学位诸识皆应有漏。又显色等粪秽酒等非漏依故。应皆无漏。又阿罗汉身是无漏。不应正理。故契经说。诸所有苦皆取为缘。然阿罗汉身定是苦。故契经言

  阿罗汉寿终　　深生大欢喜
  其犹舍毒器　　亦如众病除

譬喻者说。先业所引六处名寿。此若无漏。圣不应观如毒器等。如契经言。诸阿罗汉常自羞厌诃毁己身。圣者不应羞厌诃毁诸无漏法。故阿罗汉身定有漏。由契经言。无明所蔽。贪爱所缚。愚夫智者同感有身。若谓无明所感身灭。余明所引身复续生。智者应无无明贪爱所感有身。便违经说。又诸觉分应成有果。若阿罗汉身非有者。如病如毒可厌毁身。而言非彼三有所摄。除譬喻师。谁为此计。又眼等法有过离过。体相同故。不应别执。又譬喻部。异生身中眼等亦非诸漏依止。彼执五识无染污故。若阿罗汉无诸取蕴岂不违经。如说彼观自五取蕴如痈病等。又彼传执。非有情数外法是苦而非苦谛。应执有贪非贪随眠。眼非眼界。受非受蕴。如契经言触俱生受名为受蕴。故应诸苦皆是苦谛。由契经言。若于诸苦。或于苦集。迷惑犹预。是于苦谛集谛生疑。如是已辩。譬喻论宗阙于至理。为有至教证彼执耶。彼谓亦有。故契经言。离贪嗔痴则离诸漏。又说有六心栽覆事。所谓有漏有取诸色心栽覆事。声等亦尔。彼谓此中心栽覆事。既说有漏有取诸色。故知别有无漏诸色。广说乃至。触亦如是。彼依义准妄为是计。然圣教中。不应依此义准理门起诸戏论。如契经说。我诸所有触所生受。一切皆灭。亦应义准。别有诸受。非触所生。而不应许。又契经说。大迦叶波。于施主家心无系着。亦应义准余阿罗汉。于施主家心有系着。又彼经中非容义准。无若声故。由彼不言。谓若有漏有取诸色心栽覆事。但言有漏有取诸色心栽覆事。此显色过。非为简色。是故彼宗亦无至教。虽彼上座误引经言。若诸苾刍。有漏有取。彼于现法不般涅槃。又引经言

  真梵离诸漏　　不染于世间
  谓独觉世尊　　自在离诸漏

此于彼义都不相应。我亦不许阿罗汉等有漏取故。眼等虽名有漏顺取。而非取漏。经亦不言阿罗汉等无顺取法离诸有漏。言亦不染者。谓于世间一切境界烦恼断。故由契经。说贪等名。染谓于世间所摄受事及一切趣。永离贪等。故名不染。由此即释余契经言。佛告苾刍。阿罗汉等于诸世间已得离系。虽行世间而能摧伏。不为世间之所染污。谓于世间诸有漏事。不为一切烦恼所缚。是故说言。阿罗汉等于诸世间已得离系。虽行世间而能摧伏。不为世间所染污者。此经意说。阿罗汉等虽处世间。亦复成就而于世间得对治故。摧伏世间烦恼染污。是故彼宗都无至教。又彼起执依训词门。谓与漏俱名为有漏。此释非理。立相异故。如契经言。谓于过去未来现在诸有色等。生长现爱或恚或慢。乃至广说。如何去来与现俱起。又譬喻者。唐搅虚空。十八界中前十五界一向有漏。经所说故。谓契经言。有漏法者。诸所有眼诸所有色。诸所有眼识。如是乃至。身触身识诸所有言。显无余义。彼言我等不诵此经。非不诵经能成所乐。欲成所乐当勤诵经。又彼不以一切契经皆为定量。岂名经部。谓见契经。与自所执宗义相违。即便诽拨。或随自执改作异文。言本经文传诵者失。或复一切皆不信受。如顺别处等经皆言非圣教摄。是对法者实爱自宗。制造安置阿笈摩内。彼由此故背无量经。违越圣言多兴异执。我此论中渐当显示。已辩有漏及有漏因。云何无漏。谓道圣谛及三无为。有异释言。与漏等类故名有漏。如有种族。复有释言。为漏所污故名有漏。如有毒食。或有释言。与漏俱断故名有漏。如天帝释有怛策迦与彼俱堕。如是等类训释众多。与彼相违名无漏法。道圣谛者。谓非有漏色等五蕴。三无为者。虚空二灭所谓择灭及非择灭。此虚空等三种无为。及道圣谛。由是因缘名为无漏。次前已说其道圣谛。后当广辩。于略所说三无为中。虚空但以无碍为性。于中诸法最极显现。故名虚空。是则无障以为其相。所有大种及造色聚。一切不能遍覆障故。或非所障。亦非能障是故说言无障为相。已说虚空。择灭即以离系为性。于四圣谛各别简择。故名为择。即是善慧差别为性离系涅槃是此果故。名为择灭。有作是言。诸所断法同一择灭。对法者言。随系事别。若诸所断同一择灭。证得苦法智忍所断烦恼灭时。余烦恼灭为证得不若证得者。修余对治则为无用。若不证得。是则一物证少非余。与理相违。有分过故。由是定应计离系事。随系事量。不违正理。已说择灭。永碍当生得非择灭。择谓如理勤所成慧。不由此慧。有法永碍未来法生。名非择灭。如眼与意专一色时。于所余色及一切声香味触等。念念灭中对彼少分。意处法处得非择灭。以五识身及与一分意识身等。于已灭境终不能生。缘俱境故。由彼生用系属同时。所依缘故。若法能碍。彼法生用。此法离慧定碍彼法。令住未来。永不生故。得非择灭。此法实有后当成立。随顺本文次第理故。前说除道余有为法。是名有漏。何谓有为。应当辩说颂曰

  又诸有为法　　谓色等五蕴
  亦世路言依　　有离有事等

论曰。老病死等灾横差别。隐积损伏。故名为蕴。为别戒等故言色等。戒等五蕴。不能具摄一切有为。色等五蕴具摄有为故此偏说。言有为者。众缘聚集共所生故。未来未起。何谓有为。是彼类故。亦名有为。如所烧薪。于未烧位是彼类故亦名为薪。或据曾当立名无失。如琴瑟等名为有声。亦如乳房莲花池等。诸不生法不越彼类。故名有为。此有为法。彼彼经中。世尊随义名世路等。彼复云何。谓诸有为亦名世路。色等五蕴生灭法故。未来现在过去路中而流转故。诸不生法众缘阙故。虽复不生是彼类故立名无失。有说。无常之所吞食故名世路。或名言依。言谓言音。或谓能说。此则语声相续差别。依谓名俱义。即具摄五蕴。如契经说。言依有三。无四无五。由此善通品类足论。彼说言依五蕴所摄。岂不亦依无为起说。何故彼义不立言依。彼义与名无俱理故。如说言依。谓名俱义。若义与名可俱说者。立为言依。以无为义与有为名不可俱说。无俱义故不立言依。堕世离世无俱理故。或此灭故建立无为。故契经言。蕴灭名灭。灭非言依。言依是蕴。复有释言。若于是处三分可得。立为言依。谓依义语。无为唯义。故非言依。有说。亦依而阙于语。或名有离。诸趣轮回沉溺生死。涅槃永舍故名为离。是息诸趣恒流转义。若已至得定不还来。此有离故说名有离。如有财者名为有财。即是有为有出离义。一切有为皆同船筏。是故圣道亦应舍离。如契经言。法尚应断。何况非法。或名有事。事谓所依。或是所住。即是因义。果依于因。从因生故。如子依母。或果住因。能覆因故。如人住床。是因为果所映蔽义。因果前后故。及细粗性故此有事故。说名有事。喻如前说。此唯有为。如是等类。说有为法诸名差别。于此所说有为法中。颂曰

  有漏名取蕴　　亦说为有诤
  及苦集世间　　见处三有等

论曰。岂不前说。除道圣谛。余有为法。名为有漏。何故此中复重说耶。虽前已说。而欲显彼差别名想。或为显彼名想定义。故复重说。前说一切有为名蕴。今说有漏名为取蕴。义准无漏但名为蕴。即诸漏中立取名想。以能执取三有生故。或能执持引后有业。故名为取。蕴从取生。或能生取。故名取蕴。如草糠火。如花果树。即有漏法亦名有诤。谓烦恼中立诤名想。触动善品故。损害自他故。蕴与诤俱。或诤蕴俱而得生起。故名有诤。此中意显蕴之与诤非随阙一。余可得生。及者显余有漏名想。谓或名苦。即五取蕴。是诸逼迫所依处故。自性粗重不安隐故。或名为集。即彼种类能为因故。能集成故。或名世间。可毁坏故。如世尊说。性可毁坏故名世间。若尔道谛应是世间。不尔第二毁坏无故。道谛毁坏性不定故。世间毁坏性决定故。或名见处。萨迦耶等五见住中。随增眠故。岂不有漏一切烦恼皆随增耶。岂不诸见漏取诤摄前已说耶。虽有此理。而彼诸见。于有漏法一切种时相无差别。坚执无动随增眠故。体用增盛。为显有漏是能生长。此诸见处。故应重说。贪等痴疑则不如是。以彼贪等有一切种无一切时。痴一切时非无差别。疑无差别而不坚执。是故有漏不说彼处。或名三有。有因有依。三有摄故。等言为摄名有染等。如是等类是有漏法。随义别名。如上所言。色等五蕴名有为法。色蕴者何。颂曰

  色者唯五根　　五境及无表

论曰。色谓色蕴。言五根者所谓眼耳鼻舌身根。言五境者。所谓色声香味所触境。谓眼等所摄所行。及无表者。谓法处色。唯者唯此所显。十处一处少分。名为色蕴。如是诸色其相云何。颂曰

  彼识依净色　　名眼等五根

论曰。彼谓前说眼等五根。识即眼耳鼻舌身识。依者眼等五识所依。如是所依净色为体。即此净色名眼等根。故薄伽梵于契经中说眼等根净色为相。本论亦说。云何眼根。眼识所依净色为性。如是广说。诸圣教中以根别识。不以境界。故知彼言显根非境。有说。彼者是境非根而无意识缘色等故。名色等识。彼识所依名眼等过由净色言所简别故。若尔色言应成无用。彼识依净名眼等根。义已成故。无识所依净而非色。为简彼故。应用色言。若谓色言是契经说。契经可尔。不说识依差别言故。若谓此言是本论说。彼亦同疑应俱思择。如是释者为遣疑难。须置色言。若识依言就有财释。则应净信名眼等根。故置色言。为简此释。无有一法以识为依色而是净。可为此释。是故色言甚为有用。由此即释本论所言。又于此中前言为简耳等四根。彼虽皆用净色为性。而彼非为眼识所依。故彼四根非眼根摄。后言为简无间灭依。彼虽亦为眼识所依。而彼非用净色为性。故彼意根非眼根摄。或复前言。显同分眼。后言为显彼同分眼。余根亦尔。若尔净色相无别故。应不成五。不尔。功能有差别故。如何得知功能别者。不共境识所依定故。又因别故。现见别因果有差别。犹如琴瑟箫笛等声。然眼耳等所因四大各有差别。因差别故。眼等净色体有差别。体虽有别因无异故。其果净色应无别者。此难不然。虽同一相。现见异故。犹如内外大种差别。若言如声。因虽有别而相一故。同一处摄眼等五根亦应尔者。无如是过。声虽因别而与一识为境界故。一处所摄。眼等五根。别类境识所依性故。又是别依用所显故。不应诸根同一处摄。又如识受。虽同了别领纳一相。由因别故。而有六识三受差别。此亦如是。如彼识受。虽六三异而相同故一处所摄。眼等亦应一处摄者。受与无为。何因同处。故非一处摄。显自相同有。自相虽异。同处摄故。已辩眼等相。色等今当说。颂曰

  色二或二十　　声唯有八种
  味六香四种　　触十一为性

论曰。言色二者。是二种义。谓显与形。此中显色有十二种形色有八。故或二十。显十二者。谓青黄赤白云烟尘雾影光明闇。于十二中青等四种是正显色。云等八种是此差别。其义隐者今当略释。地水气腾说之为雾。障光明起。于中余色可见名影。翻此为闇。日焰名光。月星火药宝珠电等诸焰名明。形色八者。谓长短方圆高下正不正。此中正者。谓平等形。不平等形名为不正。余色易了故今不释。有说。色有二十一种。空一显色第二十一。此即空界色之差别。于显色中青黄赤白影光明闇。唯显可知。于形色中身表业性。唯形可了。余色形显俱可了知。如何一事有二体者。非宗所许。故无此过。辩业品中当更思择。已说色处。当说声处。能有呼召故名为声。或唯音响说之为声。善逝圣教咸作是言。声是耳根所取境界。是四大种所造色性。此声八种。谓有执受或无执受大种为因及有情数非有情数差别为四。此复可意及不可意差别成八。执受大种。谓现在世有情数摄。长养等流异熟地等。与此相违名无执受。此中执受大种为因。声有二种。谓有情类加行所生。及余不待加行所起。其有情类加行所生。复有二种。一者手等加行所生。二者语表业为自性。此语表业复有二种。谓依名起。及不待名。依名起者复有二种。一者有记。二者无记。不待名者二种亦然。是有执受大种为因声相差别。其无执受大种为因声亦二种。一者有情加行所起。二者诸界扰动所生。初谓螺贝钟鼓等声。后谓风林河等所发有情数者语手等声。余声即是非有情数。如是诸声闻生悦者。名可意声与此相违。名不可意。八中唯有初二应理。以有情数非有情数。即有执受及无执受大种为因。声所摄故。于色等中亦应可说可意等异。何独在声。色等亦应说有执受及无执受大种为因。理实应说。然由声处自性难知。故但就因说有二种。色等不尔。是故不说。本论所摄声相无异。故不应立此八种声。岂不有声用有执受及无执受大种为因而得生起。如手鼓等合所生声无如是声。二具四大各别果故。非二四大同得一果为俱有因。成过失故。虽有执受与无执受二四大种共相扣击而俱为因。各别发声彼声各据自所依故。不成三体。虽有执受与无执受手鼓大种相击为因发生二声。而相映夺随取一种。其差别相不易可知。是故声处唯有二种。已说声处。当说味处。越次说者。显彼境识生无定故。味谓所啖。是可尝义。此有六种。甘酢碱辛苦淡别故。已说味处。当说香处。香谓所嗅。此有四种。好香恶香等不等香有差别故。等不等者。增益损减。依身别故。有说。微弱增盛异故。本论中说。香有三种。好香恶香及平等香。若能长养诸根大种。名为好香。与此相违。名为恶香。无前二用。名平等香。或诸福业增上所生。名为好香。若诸罪业增上所生。名为恶香。唯四大种势力所生。名平等香。此虽增上果而亦有差别。故唯大种势力所生。亦是有情增上果摄。已说香处。当说触处。触谓所触。十一为性。即十一实以为体义。谓四大种及七造触。滑性涩性重性轻性及冷饥渴。若尔身根应成所触。此既能触彼彼定触。此故有说。身根唯能触非所触。譬如眼根唯能见非所见。复有说者。无有少法能触少法。所依所缘无间生时。立触名想。若依此识能得彼境。此于彼境假说能触。境非识依故非能触。即由此因唯说地等名为所触。依彼色等定非所触。此中意显依身根识。不缘彼境而生起故。若彼色等非所触者。如何华等由身触时色等变坏。由彼所依被损坏故。现见所依有损益故能依损益。非此相违。如地方所甘泽润沃稼穑丛林鲜荣滋茂。烈日所迫。与此相违。故知所依大种被损。能依色等变坏非余。如是义言后当广辩。此中大种至次当说。今应略释滑涩等相。滑即是性故言滑性。如别即性故言别性。训释词者。可相逼触。故名为滑。即是软暖堪执持义此有涩用。故名有涩。如有毛者说为有毛。涩即是性故言涩性。是力粗燥坚硬异名。能为镇压。故名为重。是能成办摧伏他义。重即是性故言重性。毗婆沙说。令称权升故名为重。易可移转故名为轻。现见世间。物形虽大。而有轻故。易令迁动。轻即是性故言轻性。毗婆沙说。不令称首坠故名轻。由彼所逼希暖欲生。故名为冷。又令凝结及易了知。故名为冷。是彼损益疾可知义。食欲名饥。饮欲名渴。岂不欲是心所法故违触相耶。以于因中立果名故。无相违失。如言河乐阶蹬亦乐。食为人命。草为畜命。余所未说。闷力劣等摄在此中。故不别说。闷不离滑。力即涩重劣在软暖。轻性中摄。如是其余所触种类。随其所应十一中摄。何缘滑等展转差别。所依大种增微别故。水火界增故生滑性。地风界增故生涩性。地水界增故生重性。火风界增故生轻性。故死身内重性偏增。水风界增故生于冷。由是亦说此所生闷。若尔云何言不离滑。随一一增。此有无过。或复闷者。是滑差别。非唯滑性。应知此因亦有差别。是故滑性。或因水风界增故起。或因水火界增故生。所以二言无相违失。风界增故生饥。火界增故生渴余随所应皆当配释。如是所造。离大种外。别有体性。后当广辩

说一切有部顺正理论卷第一阿毗达磨顺正理论卷第二

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩本事品第一之二

于色蕴中已说根境唯余无表此今当说。颂曰

  乱心无心等　　随流净不净
  大种所造性　　由此说无表

论曰。乱心无心等者。等言谓通两处。即不乱心及有心位。不善无记名乱心。余心名不乱。无想灭定名无心。此能灭心故。虽更有余无心果位。而无表色非所随流。故无心言不摄于彼。于三性心及无心位相似相续。故名随流。净不净者。谓善不善。善心等起名净无表。相似相续说为律仪。或非律仪。不善心等起名不净无表。相似相续。说为不律仪。或非不律仪。若无记心亦为二种。刹那等起。由此即说二等起心。然净不净二无表色。其随转心或不相似。若净无表或全无心。因等起心二各相似。已说乱心无心等随流净不净。复说大种所造者。有余随流净不净得。为简彼故。说造色言。此中造者。即表因义。云何知然。如契经说。色造我见。即是因色起我见义。复言由此说无表者。由善不善心所等起。诸位随流净不净色。虽如表业。而非表示令他了知。故名无表。为显如是立名因缘。故言由此说者显此。是余师意。经主不许如是种类无表色故。以要言之。依止身语表业差别。及善不善心等差别。所生无碍善不善色。是名无表。今谓经主。于此颂中。不能具说无表色相。以说随流名无表故。彼自释言。相似相续说名随流。非初刹那可名相续。勿有太过之失。是故决定初念无表。不入所说相中。又相续者。是假非实。无表非实。失对法宗。又定所发乱无心位不随流故。应非无表。若言不乱有心位中此随流故无斯过者。净不净表业应有无表相。又谓等言通无心者。此言无用。前已摄故。乱心等言。已摄一切余有心位。第二等言。复何所摄。经主应思。或谓后等摄不乱心。前无用者。此不应然。无容摄故。何容后等摄不乱心。遮言理于相似处起。乘无起等。理不及余。故非全摄。或可乱心言成无用。又应简言。唯净无表。于无心位随流非余。于自释中亦不简别。故于此理经主应思。云何离失说无表相

  作等余心等　　及无心有记
  无对所造性　　是名无表色

已说无表。此中所言大种所造。大种云何。颂曰

  大种谓四界　　即地水火风
  能成持等业　　坚湿暖动性

论曰。此诸大种何缘名界。一切色法出生处故。亦从大种大种出生。诸出生处世间说名界。如金等矿立金等界名。或种种苦出生处故。说名为界。喻如前说有说。能持大种自相及所造色。故名为界。如是诸界亦名大种。何故言种。云何名大。种种造色差别生时。彼彼品类差别能起。是故言种。有说。有情业增上故。无始生死未尝非有。是故言种。或法出现即名为有。生长有性。是故言种。即是生长法有性义。或是生长有情身义。或能显了十种造色。是故言种。由此势力彼显了故。若尔便有大过之失。一切因缘于果生位。皆有用故。无大过失。有大用故。言大用者。谓诸有情根本事中。如是四种。有胜作用。依此建立识之与空。乃得说为有情根本。为别所余故复名大。又于诳惑愚夫事中。此四最胜。故名为大。如矫贼中事业胜者。别余故名大矫大贼。如是此四因缘中胜。名大别余。无太过失。有说。此四普为一切余色所依。广故名大。有说。一切色等聚中具有坚等。故名为大。风增聚中阙于色等。火增聚中阙于味等。色界诸聚皆无香味。青等聚中阙于黄等。滑等聚中阙于涩等。声等不定。是故唯此四种名大。何故虚空不名大种。彼大种相不成立故。能损益故。立大种名。虚空不然。故非大种。岂不虚空有容受故能损益耶。虚空实无容受之用。非可聚色随所住方虚空开避。云何容受。然无对故。不障彼住。由是虚空无损益用。若尔何意作如是说。能容受故名曰虚空。此说意言。有虚空故。令有对色展转相容以虚空界与虚空相少分相似。故有此处假号虚空。空界即是咽喉等穴。能令众生吞咽饮食。及有转变便利等事。以无容受损益功能。是故虚空定非大种。又诸大种非一非常。自相众多果别无量。虚空自性是一是常。相无差别。全无有果。非无别因生有别果。是故虚空不名大种。若谓余因有差别故能助虚空生别果者。即此别因能生别果。何用执此虚空为因。有说。虚空其性常故。法生灭位相无差别。地等不尔。故法不同。现见大种。种等位中。其相转变芽等位起。虚空无为则不如是。性相常故。作用都无。既不能生故非大种。又于此中。由大及种二言具故。唯四义成。虚空有大而无种义。种与能生名差别故。有说。虚空亦无大义。体非色故。造色及余有为非色性能生故。是种非大。如前所说。大种二义互不成故。随阙一种不能。生成所造色故。大种唯四不增不减。毗婆沙者作如是言。减即无能。增便无用。故唯有四。如床座足有说。大种法尔唯四。有说。大种于所造色唯须持摄熟长四业。若减若增无能无用。云何得知。此四大种恒不相离。如入胎经及大造经。应了知故。又理应然。何等为理。谓石等中现有能摄。生火增坠三业可得。故知于此有水火风恒不相离。于诸水中现有持摄。暖性流动三业可得。故知于此有地火风恒不相离。于火焰中现有任持。摄聚击动三业可得。故知于此有地水风恒不相离。于风聚中现有能持。起冷暖触三业可得。故知于此有地水火恒不相离。复云何知。如是四界。由此因缘恒相随逐。由此能成持等业故。谓地等界如次能成持摄熟长四种事业。由此因缘。于诸色聚。若有持等四业可得。即知此中有地等界。互不相离恒相随逐。为能持等四业即是界自相耶。不尔云何。如是四界随其次第。坚湿暖动以为自相。应知此中说性显体。为明体性不相离故。云何应知。地等四种。异坚等相。有持等业。复云何知。地等四种。相业无异征审异耶。不见相业有差别故。我等不见坚等持等相业有异故。反征审汝。谓我言离坚等相条然别有持等业耶。然持等业与坚等相。非离非即。坚等即是地等自相。无所观故。持等业用。别有所观而施设故。非持自相。说此持业。勿一切法有持业故。皆名为地。成太过失是故应知。地界坚相无别所观别观所持说能持业。水界湿相无别所观。别观所摄说能摄业。火界暖相无别所观。别观所熟说能熟业。风界动相无别所观。别观所长羯剌蓝等。或复芽等说能长业。长谓增盛。或复流引。动谓能引大种造色。令其相续生至余方。是故持等业非即坚等相。有说。三时一时异故。知相与业其义不同。有说。地等有持等业。若地界等有坚等相。此说不然。风与风界无差别故。长动应一。风界若以动为性者。何故契经及品类足论。皆言风界谓轻等动性。复说轻性为所造色。说动为风。轻为造色。是显自相。轻为风者。举果显因。是风果故。岂不火界亦是轻因。说火风增生于轻故。虽有是说而火不定。若有轻性。火增为因。是处必有增盛风界。或有轻性。风增为因。而其中无增盛火界。如苇等花飘举轻性。此中火界若增盛者。其中应有热触可得。由此风界遍为轻因。故别举轻偏显风界。然地等相易可了知。故不须说重等果。显对坚等三动难了故。为地等界即地等耶。不尔。云何颂曰

  地谓显形色　　随世想立名
  水火亦复然　　风即界亦尔

论曰。地言唯表显形色处。岂不总地四处合成。何故但言显形为地。此中虽有香味触处。而随世想故作是言。由诸世间相示地者。以显形色而相示故。若尔世间相示衣等。亦以显形而相表示。如言衣等。白等长等而许四处为衣等性。地亦应然。何故唯色又诸世间亦于香等施设地名。谓作是言。我今嗅地尝地触地。虽有是事而显形色。于地水火能通表示。所以者何。世不多说我嗅于水。亦不多说嗅尝于火。虽言触地等而即地等界。是故地中虽有香等。而显形色胜故偏说。又显形色表示二界。地等无异是故偏说。若尔显形表示衣等。胜香等故亦应偏说。世起想名无有决定。故对。法者随世想名。示现地等衣等差别。又实有物非世共成。世所共成皆是假有。故于假法应随世间所起想名差别而说。由是香等假说为地。亦无有失。且就显形表示地者。作如是说。由诸世间想名无定。不可以一例余皆同。已说衣等四处为性。诸余总法如应当知。衣等物中亦有生等。彼物应以五处为性。虽非非有。而诸世间不于彼起衣等想名。若尔声处应名衣等。以世间说闻衣等声。虽亦有声而非相续。色等恒有故唯说四。如地但用显形为体。水火亦然。随世想故。世间现见水青长等。故说显形为水自性。世间见触水流相已。便作是说。此中水流。然此流体理非实水。眼等五根境各别故。亦非显色。身可触故。又非形色。八不摄故。非离显形有别色处。云何见触水流相耶。众水聚集风力所推。生彼彼方展转相续。世间于此起流想名。如是众水异方生时。于中显形为眼所见。其间湿性为身所触。是故显形及与湿性。风力所击展转相推异方生时说为流性。非离此外别有流体。故水流等是假非真。世间现见火赤长等。故说显形为火自性。又即色触转变生时。名火焰炭。是假非实。无一实物身眼得故。已说地等与界差别。世间于动立风名故。风与风界无有差别。由此道理言风即界。岂不世间于显形色亦生风想。世间现以黑风团风更相示故。有通此难故说言亦。是如地等与界别义。古昔诸师咸作是说。地于中杂故见如此。为显其风即是风界。故复言尔尔者定义。此二说中前说为胜。遍处不净无差别故。不净唯缘色处境故。颂曰

  此中根与境　　即说十处界

论曰。已说实物根境无表为色蕴性。此中根境亦即说为十处十界。于处门中立为十处。谓眼处等。于界门中立为十界。谓眼界等。已立色蕴并立处界。此中色蕴何缘名色。善逝圣教。且说变坏故名为色。此说意言。苦受因故。有触对故。可转易故。名为变坏。由变坏故说名为色。苦受因者。色有变坏。能生苦受。如义品言

  趣求诸欲人　　常起于希望
  诸欲若不遂　　恼坏如箭中

有触对者。手等所触色便变坏。是有对碍可变坏义。可转易者。如牛羊等身可转易。是可转变及贸易义。由可转易故名变坏。云何色法可转易耶。谓异相生故名转易。或能表示宿所习业。故名为色。如契经说。此摩纳婆。宿习能招恶形色业。谓多忿恨。或能表示内心所有。故名为色。如契经说。具寿。汝今诸根凝悦定证甘露。岂不此说唯就有见有情数色训释色词。唯此能表宿所习业及内心故。若尔无见非情数色。应皆非色。无斯过失。唯色聚中有此义故。不说诸色皆能表示。且于一切非色。聚中无能表示。故此释词理得成立。如契经说。业为生因。此说诸生皆因于业。不言诸业皆是生因。今不应难。业非生因便为非业。若不尔者。善逝训词亦可为难。非一切色皆变坏故。世尊且据有对碍色。说如是言。有变坏故说名为色。又作是言。谁能变坏。谓手触故即便变坏。乃至广说。复作是言。诸习欲者。无有恶业而非所为。非诸圣者全不习欲。而竟不为招恶趣业。故知彼说唯据异生。此亦应然。不可为难。或一切色皆能表示宿所习业。非有情色。亦共许为宿业果故。无见诸色云何表示。与有见色不相离故。非离无见而有有见。有见无见一业果故。由此无见能表义成。而无受等亦成色过。虽从业生非恒有故。设恒有者。细难知故。异熟生色非思虑生无间随转。故唯诸色有能表示宿所习业。若尔声非异熟生故。应不成色。虽非业生而能表示宿所习业。如盐贤等是。所引证。又声生因处无心定亦常现有。故于所释色义无违。有说。变碍故名为色。若尔极微云何变碍。无一极微现在独住。积集住故变碍义成有说。亦有独住极微。然有变碍而不发识。五识依缘要积集故。如立极微。虽无方分亦无触对。而许极微有碍有对有障用故。应知变碍义亦如是。已灭未生是彼类故。如所烧薪。彼同分眼。又如世说。急食急行故名为马。而非一切。虽无彼德而似彼故。种类义成。但随少分建立名想。此亦如是。由此即释。定不生法住色相故。亦得色名。又如世间于未有用逆说当有。如言当火今若欻起焚烧村逻无一得存。亦如世间于用已灭追说曾有。如言昔火今若欻起焚烧村逻无一得存。非未有用及用已灭能实焚烧。而相类同说亦应理。定不生法理亦应然。彼设当生亦应变碍。是故变碍释色义成。去来虽尔。无表云何。有释。表色有变碍故。无表随彼亦受色名。此不应理。随心转色不从表生。应非色故。经主于此误立前宗。言如树动影亦随动。即说过言。如树灭时影必随灭。表色灭时无表应灭。然非彼喻。所立异故。谓立所依有变碍故此亦名色。说是喻言。无表所依即四大种。非彼大种不成就时无表随转。故于此中无如是失。又此相违有不定过。谓不决定此从彼生。彼若灭时此亦随灭。如父工匠种等灭时。非子殿堂芽等随灭。又如所依金刚喻定。灭不成就。所生尽智至蕴相续不灭随转。又如无漏俱生所依。生上界时所依虽灭无表随转。若以所依大种变碍。能依无表亦名色者。眼等五识所依五根。有变碍故。应亦名色。有释此言。无斯过失。无表依止大种转时。如影依树光依珠宝。眼等五识依眼等时。则不如是。唯能为作助生缘故。经主谓此如影依树光依宝言。非为符顺毗婆沙义。由许影等显色极微各自依止四大种故。此非本论毗婆沙说。亦非不顺毗婆沙义。此言意说。影等大种。树等大种。为所依故。所以者何。影等大种生住变时。皆随彼故。此影光言意表总聚。非唯显色。如树宝言。是故影等影色极微。依止影等大种而转。影等大种复依树等大种而生。故于此中无不顺过。经主复说。设许影光依止树宝。而无表色不同彼依。由许所依大种虽灭而无表色不随灭故。此难不关毗婆沙义。能依所依许俱灭故。无表所依大种若灭。能依无表未常不灭。初念无表可与所依大种俱灭。第二念等无表云何。第二念等大种若无。其无表色岂得现有。虽此位中非无大种。而彼大种非此所依。非生因故。奇哉如是善解对法。岂不非唯生因大种望所造色。能为所依。然更有余四因大种。望所造色许为依故。若彼所依大种灭已。能依无表犹不灭者。圣生无色无漏无表。既许成就应得现前。生依二因大种灭已。无漏无表。虽成不行。故知欲界无表行者。定由所依大种不灭。此若不尔。彼云何然。由此诸师咸作是说。诸所造色有二种依。一生起依。二力转依。圣生无色。由力转依大种无故。无漏无表虽复成就而不现行。由未承奉无倒解释对法诸师。致斯迷乱。然眼等识所依五根。虽有变碍而不成色。由彼种类有别异故。有识种类不依于色。唯五识身依色而起六识皆用意为所依。无色界中意亦可得又于下地眠梦定等。意用可得无五根用。又理不应。六识自性一法种类亦色非色。无有无表不依色生。故应所依有变碍故。能依无表亦得名色。又言色者。如牛孔雀。依少分类。以立想名。非无差别。不应为难。已说色蕴。当说受等。颂曰

  受领纳随触　　想取像为体
  四余名行蕴　　如是受等三
  及无表无为　　名法处法界

论曰。随触而生领纳可爱及不可爱俱相违触。名为受蕴。领纳即是能受用义。此复三种。谓乐及苦不苦不乐。能益身心。故名为乐。能损身心。故名为苦。有所领纳而非苦乐。名不苦不乐。如非黑非白。复云何知此别有体。有说。以能增益损减诸根大种及俱相违。三用别故。知有三体。或有说者。增贪嗔痴随眠别故。知有三体。虽于诸受一切随增。而由所缘及相应故。就别相说。又痴虽与三受相应。贪嗔各二而就多分相应现行故作是说复有说者。与贪嗔痴行相相似。故作是说。有余师说。对法中言。于乐受中贪随增者。不说乐受唯能起贪。但说其贪随乐受起。二受嗔痴应知亦尔。今正说者。由教及理。知第三受决定非无。教者如言。由乐断故。及苦断故。此中唯有不苦不乐。理者离受心必不生。离苦乐心现可得故。焉知离受心必不生。由诸契经同所说故。如契经说。眼及色为缘生于眼识三和合触俱起受想思。如是乃至。意及法为缘生于意识。三和合触俱起受想思。无第七心离受而起。故知决定有第三受。又说诸受略有二种。一执取受。二自性受。执取受者。谓能领纳自所缘境。自性受者。谓能领纳自所随触。故世尊言。顺乐受触。顺苦受触。及顺不苦不乐受触。是乐受等所领触义领所缘受与一境法。差别之相难可了知。如契经言。具足领受。此领受言似依慧说。故彼契经。次后复说。不受后有。如实了知。虽受亦能领纳境界。而此领纳自性难知。故领纳触为自性受。此不共余易了差别。如是诸受。与心等法同所缘故。异领纳故。所缘事别。所领事别由此触于受。若时为所领。是时非所缘。若时为所缘。是时非所领。故缘领事别。由此善通如是文句受乐受时。如实了知受于乐受。乃至广说。此中意说。能以觉慧。无倒审知三受差别。非乐谓苦。非苦谓乐。非于苦乐谓俱相违。余亦如是。此中非受领受自性。即受性故。但领所缘受及余法。一切皆是心及心所所领受故。有阿笈摩。能显此理。如契经言。缘种种界。有种种触。缘种种触。有种种受。缘种种受。有种种爱种种界者。谓根境识种种性相有差别故。何故不言缘种种界有种种受。复何不言缘种种界有种种爱。此亦同疑。故应俱释。次第法尔安立无过现见世间。从先种子生后果时。由花乳等有差别故。果有差别。如次第生立因果定。俱生因果亦应定立。是故诸受虽亦因界。而要用触以为近因。又如两木相磨生火。风为近缘。如是三法和合生受。触为近缘。故就领触。为受自性。非领所缘。理定成立。此受约世总说为三。就触所依别分为六。已说受蕴。第三想蕴取像为体。谓于一切随本安立。青长等色。琴贝等声。生莲等香。苦辛等味。滑涩等触。生灭等法。所缘境中如相而取。故名为想。是故此想随德立名。以能取像故名为想。总别三六如受应知。已说想蕴。第四行蕴。四余诸行。谓除前说色受想三。及除当说识为第四。余有为法名为行蕴。此有相应及不相应。思等得等如其次第。契经唯说六思身者。由最胜故。所以者何。思是业性。为因感果。其力最强。故世尊言。若能造作有漏有为。名行取蕴。若谓唯此名行蕴者。理必不然。余行色等所不摄故。应非蕴摄。若言如此有何过者。则非苦集知断应无。设尔何失。违圣教故。如世尊言。若于一法未达未知。我说不能作苦边际。未断未灭。说亦如是。若谓余行犹如虚空及非择灭。无斯过者。理亦不然。彼是增长我执事故。我执能障苦尽法故。彼上座说。行蕴唯思。余作意等是思差别。复作是言。作意等行。不可离思知别有体。或离余行。别有少分思体可得。由此行蕴。虽非一物而一思摄。是故契经。虽举一思。而不违理。复云何知。作意等行。一切皆用思为自体。以薄伽梵于契经中说六思身为行蕴故。说贪嗔等名意业故。非黑非白。无异熟业。能尽诸业。此以思名说圣道故。说诸静虑无量无色。以为白白异熟业故。不应异名说异法故。非一说一。是谬言故。诸薄伽梵终无谬言。彼上座宗所说如此。理谓不然。前后所立且相违故谓彼前说行蕴唯思。后言行蕴非唯一物。何容一思即非一物。唯说六思为行蕴故。知作意等思为体者。其理不然。说法异故。现见经中。世尊说法有种种异。或举初摄后。或举后摄初或举初后以摄中间。或举中间以摄初后。何等经中举初摄后。谓静虑食。瞿波洛迦。不退堕法。集谛等经。静虑即是四修等持。契经中说。若修初静虑。得现法乐住。非余不得现法乐住。举初摄后故作是说。由是如来。所说无减。食谓四食契经中说。第一段食。有粗有细。非余三食无有粗细。举初摄后故作是说。瞿波洛迦。谓彼经说不了知色。非余四蕴。已得了知。举初摄后故作是说。不退堕法。谓彼经言。预流果人不堕恶趣。非余圣者堕诸恶趣。举初摄后故作是说。集谛谓彼契经中说爱为集谛。非余染法集谛不收。举初摄后故作是说。思择谛中当别显示。诸如是等无量契经。皆举最初以摄于后。由是如来所说无减。何等经中举后摄初。谓得自体识住。赞颂福田等经。得自体者。四得自体契经中说。生在非想非非想天。非可自害。非可他害。非不一切色无色天。非可自害。非可他害。举后摄初故作是说。识住谓彼七识住经作如是说。有色有情身一想异。如极光净天。是第三识住。非不少光无量光天亦名有色身一想异。举后摄初故作是说。赞颂福田。谓彼经说

  若于阿罗汉　　恒修妙施福
  常为诸天神　　劝赞呈嘉瑞

非于前三修妙施福不蒙天等劝赞呈祥。举后摄初故作是说。若谓前三堪应供养故亦得名阿罗汉者。便成此经非了义说。阿罗汉名主无学故。何等经中但举初后以摄中间。谓赞出家证净等经。赞出家者。谓彼经说

  诸有出家人　　能证预流果
  及阿罗汉果　　是名多所作

非出家人。证一来果及不还果。非多所作。但举初后以摄中间。故作是说。赞证净者。谓彼经说

  诸有于如来　　住妙信无动
  及尸罗善净　　常得会嘉祥

非于法僧住信无动不会嘉祥。但举初后以摄中间。故作是说。何等经中。但举中间以摄初后。谓契经说。若有修习第四静虑。名得漏尽。非不七依皆能尽漏。但举中间以摄初后。故作是说。诸如是等无量契经。皆举中间以摄初后。由是如来所说无减。诸经既尔。此亦应然。虽复行蕴多法集成。而但举初说思无过。何不最初举作意等。造作有为。思最胜故。如心能导三处现前修二法等。心能导者。如契经说。心导世间。此中非无受想等法。以心胜故。作如是说三处现前。谓契经说。信于三处现在前故。能生多福。此中非无无贪无嗔正见等。法以信胜故。作如是说。修二法者。如契经说。应修二法。谓奢摩他毗钵舍那。善有为法一切应修。止观胜故。作如是说。如是等经。皆举胜法以为初首。此亦应然。又佛世尊。有余之说处处可得。如窣堵波诸善士趣及心解脱断结等经。窣堵波者。如契经说。三人应为造窣堵波。此理不应。为异生者造窣堵波。非见谛者。当知此经是有余说。善士趣者。如契经说。七善士趣。谓趣涅槃阿罗汉果。非余圣生非善士趣。当知此经是有余说。心解脱者。如契经言。得阿罗汉。其心解脱欲漏有漏及无明漏。然实解脱一切烦恼及随烦恼。当知此经是有余说。断结者。谓契经中言。永断三结证预流果。非不永断见谛所断一切烦恼。当知此经是有余说。如是等经。皆就胜说此亦如是。造作有为。功能胜故。云何说此能造有为。谓有胜能。引生果故。果虽本有。而少分生此能随引。故立为造。彼上座言。造有为者谓思能造本无有为。如织者言。我持此缕织作裳服。此亦应尔。如是所说。理必不然。有依无依不同法故。彼意谓思。如能织者。本无有为。谓如裳服。裳服所依缕无所喻。若许未来有为体有无少分用。造义得成。上座缕喻。显有未来。或所立喻有言无义对法诸师。说假有法本无今有可为此喻。若执实体亦是本无。彼定不应立如是喻。又彼应说假实异相。若有异者。则无譬喻。若无异者。便似空花。说贪嗔等为意业故。知作意等思为体者。理亦不然。贪嗔邪见。体虽非业。业资粮故。亦说为业。如余资粮亦名彼彼。如戒经言。见众圣乐河阶蹬乐。彼乐资粮。故亦名乐。又如经说。若有眼根。不调不护。此法能感非爱异熟。眼根虽是无异熟法。非爱异熟法资粮故。亦说能感非爱异熟。又如经说。乐谈论等五种退具。实退具者。谓诸烦恼。引退果故。乐谈论等。是彼资粮。亦名退具。又如经言

  愚夫着欲而兴诤　　诸仙无诤由离欲
  是故应除一切欲　　犹如麟角独游行

耽着境界兴诸斗诤。境实非欲。是欲资粮故亦名欲。是故经言

  世诸妙境非真欲　　真欲谓人分别贪

又如经说。增色随眠。色非随眠。是彼资粮故同彼说。又如经说

  女为梵行垢　　女恼害众生

女实非垢。垢谓贪等。是垢资粮故亦名垢。又契经中宣说七漏。实漏唯二。余皆非漏。是漏资粮故亦名漏。由此等经。证贪嗔等意业资粮故名意业。而非业体。道理成就。非黑非白。无异熟业。能尽诸业。此以思名说圣道故。知作意等思为体者。理亦不然。如想等名此无失故。如契经言。修无常想能除欲爱色无色爱。彼以想名说诸圣道。既许圣道非想差别。此亦应然。故无有失。又说受意能断烦恼。故契经说。修喜觉支依离贪意能破巢窟。圣道既非受意差别。此亦应然。故无有失。有闻经说。业缚众生。谓一切业皆能系缚。为遣如是邪僻执故。说此思业能尽诸业。又显业胜故作是说。说诸静虑无量无色。以为白白异熟业故。知作意等思为体者。此非审察。诸静虑等。五蕴四蕴为自性故。如契经言。此中所有若色若受。广说乃至。名静虑等。非譬喻师业有色性。为显诸业于感异熟力最强故。此中一切善五蕴法。皆说为业。又如此中受想及识。虽说为业。而体非思。如是此中作意等法。亦应说业。而体非思。若言受等别蕴摄故无斯过者。是则成立得以异名说于异法。此既成立如上所言。说贪嗔等名意业故。谓即是思理不成立。现见极成异性受等。以业名说。余亦应然。由此即破后所说因。不应异名说异法故。又见异名亦说异法。如言能行具香等施。施体是思。非即香等。然由香等觉发于思。故有异名说于异法。非一说一。是谬言故。诸薄伽梵终无谬言。知作意等思为体者。理亦不然。就胜说故。名义相属不决定故。所化有情意乐别故。不了义经。现可得故。非薄伽梵谬说此言。若立行蕴体但是思。彼显世尊言有谬失。由许世尊说一法体即为非一。复说非一。体即一故。若说行蕴非一物成。此显世尊言无谬失。是故彼因有言无理。又彼所立违于比量。谓行蕴体非唯是思。立总想故。如法处界。若异此者。应但名思。一法成故。如受想蕴。此中意显如外第六法处界声立总想故。总摄十一十七处界。不摄多法。如是行声。立总想故。总摄四蕴。不摄多行。故知行蕴体不唯思。若尔如彼应最后说。思次第中自当显示。此非文便故应且止。又以芭蕉喻行蕴故。知行蕴体非唯是思。如说行蕴喻如芭蕉。此显多物成行蕴体。又以经说相应言故。知行蕴体非唯是思。如契经言。见为根信证智相应。若信与智俱是思者。是则思体与思相应。自体相应理不应许。又作意等不应即是思之差别以契经中离作意等别说思故。如契经说。彼如是见即如是思。若彼邪见即是思者。此义应言。彼如是思即如是思。或如是见即如是见。若作是言。其义何别又如经说。彼有如是信欲勤安念智思舍。名为胜行。若信等行即是思者说信等已。何复说思。又此诸法似同时用。如何一思多体俱起。上座此中作如是释。为摄此时所起余行。故复举思。前说信等。为显此时所起胜行。如五浊法及四修行。谓五浊中见虽烦恼。由最胜故。复更别说。四修行者。如契经言。修身语意妙行正见。断身语意恶行邪见。非正邪见意妙恶行之所不摄。胜故别说。此亦应尔。理不应然。信等亦应思所摄故。不应别说。岂不已说。为显此时所起胜行。故说信等。虽知已说。然不应理。一法一时多体俱起。如受想等不应理故非受想等一法体类乐小等别有俱时起。是故彼说非佛法宗。又彼彼处若不举思。彼彼契经所说应阙。如世尊言。学无学戒定慧解脱。此契经内。既不举思。应阙所余作意等法。若谓闻者于彼已知。则举慧等。亦应无用。是故彼释。因定不然。喻亦非理。诸见所持难解脱故。为显诸见缚义坚强。故与烦恼总别显过。意恶行中邪见最重。为显邪见胜彼贪嗔。理须总别说断对治。思于信等未见胜用。何缘此思总别而说。是故彼喻与法不齐。如前难彼。若执信等思为自性。思与信等总别而说。其理不成。彼立见喻。极不相似。非诸烦恼诸意恶行一切皆用见为自体。何得以见总别说故。例思同彼应总别说。又设许彼作意等法皆思为性。然所立思。不同邪见。色界色处。若增上缘。若能作因。若分别慧。修三摩地。法界法处。行蕴安立。除作意等。无多思故。又此经中别说何用。谓契经言。若有所受即有所思。若有所思即有所想。若有所想即有所寻。彼宗既许寻即是思。举寻为乘。彼上座言。此经非乘。若不举寻。疑思即是作意欲等。此不应疑。相有异故。彼体即思相如何异。若尔举寻则应无用。彼执寻思其相一故。又作意等既许即思。疑思即彼。复有何过。是故彼言。都无有义。又彼所言。作意等行。不可离思。知别有者。于别有智。应正勤求。岂以无知。令作意等皆离思体无别有性。又如汝等频言想识时依行缘相似转故。虽不能示二相差别。而汝等宗。许其体异思作意等。应亦如是。纵汝不知体何妨异。若作意等体与思异。何故无经说为行蕴。亦说行故义已说蕴。谓说寻伺名为说行。说信欲等名为胜行。说诸命根名寿命行。非此等法体非蕴收。是有为故。如色受等。无经说彼余蕴所摄。而有经中说彼为行。岂有利根言非行蕴。又如离爱余后有因。虽说为集。不名集谛。而汝不应许非谛摄。诸因果法皆谛摄故。作意等行。亦应如是。虽说为行。不名行蕴。而汝不应许非蕴摄。一切有为蕴所摄故。世尊就胜且但说思。非作意等行蕴不摄。又彼不应作如是说。世尊无缘说于密语。离思余法行蕴所收。如前已论。理极成立。岂非是佛说密语缘。又行蕴收思外余法。理实是有。而但说思。此何密意。若无密意。便谤世尊。言不随智。若有密意。即自成立佛密语缘故说四余行名行蕴。理教相应义善成立。如是行蕴。非尽有依。故唯约世总说三种。如前分别色蕴体已。便约处界二门建立。如是此中辩受想行三蕴体已。亦应建立为处及界。谓此三蕴。及无表色。三种无为。如是七法。于处门中立为法处。于界门中立为法界

说一切有部顺正理论卷第二阿毗达磨顺正理论卷第三

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩本事品第一之三

已说四蕴自性处界。第五识蕴自性处界。今当显示。颂曰

  识谓各了别　　此即名意处
  及七界应知　　六识转为意

论曰。识谓了别者。是唯总取境界相义。各各总取彼彼境相。名各了别。谓彼眼识虽有色等多境现前。然唯取色不取声等。唯取青等。非谓青等。亦非可意不可意等。非男女等。非人杌等。非得失等。如彼眼识。于其自境。唯总取相。如是余识。随应当知。有余师说。谁于法性假说作者。为遮离识有了者计。何处复见唯于法性假说作者。现见说影为动者故。此于异处无间生时。虽无动作而说动者。识亦如是。于异境界相续生时。虽无动作而说了者。谓能了境故亦无失。云何知然。现见余处。遮作者故。如世尊告颇勒具那。我终不说有能了者。复有说言。刹那名法性。相续名作者。自意所立。思缘起中。当更显示。此识约世总说为三。就所依根别分为六。应知即此所说识蕴。于处门中立为意处。于界门中立为七界。及声显一析为二门。辩一一识体分处界。七界者何。六识及意。谓眼识界至意识界。即此六识转为意界。此别建立蕴处界门。应知遍摄诸法皆尽。此中应思。若即识蕴名七心界。前说识蕴。就所依根别分为六。今离六识。说何等法。复名意界。更无异法即于此中。颂曰

  由即六识身　　无间灭为意

论曰。即六识身无间灭已。能生后识。故名意界。时分异故别立无失。犹如子果立为父种。若尔界体。应唯十七或唯十二。更相摄故。何缘建立十八界耶。颂曰

  成第六依故　　十八界应知

论曰。如五识界。别有眼等五界为依。第六意识无别所依。如离所缘识无起义。离依亦尔。识不得生。为成此依故说意界。如是所依能依境界。应知各六。界成十八。如何已灭名现识依。是现识生邻近缘故。如虽有色而要依眼眼识得生。如是虽有所缘境界。而后识生。要依前念无间灭意。是故前言无间灭者。为遮前念有间灭心。虽先闻避而未生故。由此无间。已灭六识。为现识依。说为意界。或现在识正成依用。过去已成等无间缘。亦于现在能取果故。虽依彼生。而非随彼。故心依心。不名心所。心所品类。必随心故。已释诸蕴取蕴处界。当于此中思择摄义。诸蕴总摄一切有为。取蕴唯摄一切有漏。处界总摄一切法尽。五蕴无为名一切法。别摄如是。应辩总摄。颂曰

  总摄一切法　　由一蕴处界
  摄自性非余　　以离他性故

论曰。一蕴谓色。一处谓意。一界谓法。此三总摄五蕴无为。总是集义。置总言者。令知总三。勿谓各一。有余部执。摄谓摄他。处处说言。余摄余故。且如说三蕴摄八支圣道。若摄自性。慧蕴唯应摄于正见。非正思惟及正精进。定蕴唯应摄于正定。不摄正念。既契经中不如是说。故知诸法唯摄他性。此执不然。无定因故。若摄他性。何因决。定慧蕴唯能摄正思惟及正精进。不摄正念及与正定。或所余法。若言此摄。亦有定因。谓正思惟及正精进。其性猛锐相涉般若念定等法。慧相相违。念涉定相。非思惟等。若尔便成唯摄自性。由不许摄异相法故。诸法相望。无非异相。若片相似许相摄者。应许一切摄一切法。岂不如与他性相应。而非一切一切相应。如是应许他性相摄。而非一切一切相摄。此不应例。夫相应者。唯有缘法。异体相望。共一缘转时依行相品类等同。此说相应。故非一切。其相摄者。通一切法。有何定因。此唯摄彼不摄余法。故应一切摄一切法。以诸色法及不相应。展转相望。无一缘等互相似义。可不相应。相摄不尔若摄他性。何故眼等不摄耳等。得等展转相望亦然。若尔何缘经说如是。此中相顺假说为摄。谓正思惟及正精进。俱是慧品。顺正见故。念是定品。顺正定故。假说名摄若尔彼彼契经中言。信等五根慧根所摄。我以四摄摄诸徒众。台观中心摄众材等。世间亦说。双栝摄扉。轮辋摄辐。缕摄衣等。其义云何。如是一切。假意趣说。谓依方便招引不散任持意趣。假说为摄。诸所引证摄他性言。是暂时说。待他成故。摄待因成义同不摄。又若许法定摄他性。一法生位应一切生。一法灭时应一切灭。是则非爱过失便增。一部断时五部应断。修胜对治。便为无用。见如是等众过失故。我部诸师。说自性摄。如是所立摄自性言。是究竟说。不待他故摄不待因。是真实摄。诸法恒时。摄自性故。复云何知。不摄他性。以一切法离他性故。谓眼根性离耳等性。彼离于此而言此摄。理必不然。故知诸法唯摄自性。如是眼根唯摄色蕴。眼处眼界苦集谛等。是彼性故。不摄余蕴。余处界等离彼性故。如是余法随应当思。因自性摄。此义应思。男女二根。何界所摄。何缘于此。率尔生疑。异部中言。非身根故。身界不摄。故可生疑。应舍此疑。定身界摄与身用别。界云何同类境识同。故一界摄。言类同者。男女二根同身类故。由境同故。知彼类同。男女与身。同触为境。眼鼻喉中触咽便觉。余处不尔。岂异身根。此三境同。由识同显。一切皆是身识依故。增上义异。故立别根。谓男女与身类境识同故。虽同处界。而增上义。有差别故。别立二根。如十一根。虽同处界。增上义异。各别立根。眼耳鼻根各依二处。何缘界体数不成多。合二为一故唯十八。何缘合二为一界耶。颂曰

  类境识同故　　虽二界体一

论曰。眼耳鼻根。虽各二处。类等同故。合为一界。言类同者。同眼性故。言境同者。同色境故。言识同者。眼识依故。耳鼻亦然。故立一界。界体既一。处何缘二。颂曰

  然为令端严　　眼等各生二

论曰。为所依身相端严故。界体虽一而两处生。若眼耳根处唯生一。鼻无二穴。身不端严。此释不然。驼猫鸱等。如是丑陋。何有端严。是故诸根各别种类。如是安布差别而生。此待因缘。如是差别因缘有障。或不二生。犹如身根头项腹背手足等处。安布差别种类如是。不应疑难。亦待因缘。如是差别因缘有障。或别异生。故是蛇等。身支有阙。又见彼类。舌非一生。是故诸根安布差别。待因缘起。非为严身。若尔何故。说眼等根为令端严各生二处。此有别义。非为严身。现见世间。于诸作用增上圆满。亦说端严。若眼等根各阙一处。见闻嗅用皆不明了。各具二者明了用生。是故此言为端严者。正是为令用增上义。已释诸蕴及处界摄。当释其义。于所知境。蕴摄有为。处界亦摄诸无为法。何故如是。所知境中或说名蕴。或名处界。由蕴处界三义别故。别义者何。颂曰

  聚生门种族　　是蕴处界义

论曰。积聚义是蕴义。生门义是处义。种族义是界义。何等故知聚义是蕴。由经说故。如契经言。诸所有色。若过去若未来若现在。若内若外。若粗若细。若劣若胜。若远若近。如是一切略为一聚。说名色蕴。此经中显聚义是蕴。何缘故知门义是处。由训词故。处谓生门。心心所法于中生长。故名为处。是能生长彼作用义。如契经说。梵志当知。以眼为门。唯为见色。此经唯证门义有六。然心心所有十二门。故契经说。眼及色为缘生于眼识。三和合触俱起受想思。如是乃至。意及法为缘生于意识。三和合触俱起受想思。有余师说。由此依此心等生长。故名为处。何缘故知族义是界。与世种族义相似故。如一山中有诸雄黄雌黄赤土安膳那等众多种族。说名多界。如是一身。或一相续。有十八类诸法种族。名十八界。如彼山中有雄黄等生本诸矿。名为种族。如是此中有心心所生本诸法。说为种族。若尔处界义应相滥。俱心心所生本义故。由此别应释种族义。如雄黄等展转相望体类不同。故名种族。如是眼等。展转相望。体类不同。故名种族。若尔意界望于六识。无别体类应非别界。此难不然。所依能依体类别故。有说。安立时分异故。复有说者。六是意先。意非六先。故甚有异。虽诸界体并通三世。然就位别安立异名。由此故言六先意后。未来意六。时位未分。如何可言六先意后。若以聚义释蕴义者。蕴则非实。聚是假故。此难不然。于聚所依。立义言故非聚即义。义是实物名之差别。聚非实故。此释显经有大义趣。谓如言聚。离聚所依。无别实有聚体可得。如是言我色等蕴外。不应别求实有我体。蕴相续中假说我故。如世间聚。我非实有。蕴若实有。经显何义。勿所化生知色等法。三时品类无量差别。各是蕴故。蕴则无边便生怯退。谓我何能遍知永断此无边蕴。为策励彼。蕴虽无边。而相同故。总说为一。又诸愚夫。于多蕴上生一合想。现起我执。为令彼除一合想故。说一蕴中有众多分。不为显示色等五蕴多法合成是假非实。又一极微三世等摄。以慧分析略为一聚。蕴虽即聚。而实义成。余法亦然。故蕴非假。又于一一别起法中。亦说蕴故。蕴定非假。如说。俱生受名受蕴。想名想蕴。余说如经。于一切时和合生故。蕴虽各别。而聚义成。有余师说。可分段义是蕴义。诸有为法。皆有过去未来现在三分段故。经主决判此释越经。今谓不然。不违理故。处界二义。岂不越经。而于其中摄取为正。复有何理。唯蕴义中固求经证。于处界义唯依理释。绝不求经。观此义言。似专朋党。故应如彼据理无违。何故世尊于所知境。由蕴等门作三种说。颂曰

  愚根乐三故　　说蕴处界三

论曰。善逝意趣。虽极难知。据理推寻。似应如此。谓诸弟子。愚根及乐。各有三故。善逝随彼。说蕴处界三种法门。乐谓胜解。三谓各三。所化众生愚有三种。有愚心所。总执为我。有唯愚色。有愚色心。根亦有三。谓利中钝。乐亦三种。谓乐略中及广文故。随所化生如是品别。如其次第。善逝为说蕴处界三。经主此中所说犹少。谓诸弟子。已过作意。已熟习行。初修事业。三位别故。怀我慢行。执我所随。迷识依缘。三过别故。恃命财族而生憍逸。三病异故。由此等缘。如其次第。世尊为说蕴处界三。彼上座言。说蕴为明所执一合差别相故。说处为明境及有境差别相故。说界为明境及有境并所生识差别相故。且说处门。如何遍立境有境相。此中不说眼等五根及与意根为境性故。然一切法。皆意根境。此于意境。非为遍说以立处门。但说七法。为意境故。如契经说。苾刍当知。法谓外处。是十一处所不摄法。又处处说法为意境。故说处中。似非遍立境有境相。诸有于此复作是言。如契经说。意及法为缘生于意识者。说一切法皆为意境。彼但有言。理教无故。若必尔者。何名决定立处相别。且不遍立境及有境。过则同前。又上座说。诸法无非意所行故。皆法处摄。若尔唯应立一法处。以一切法皆意境故。此但有言。无定量证。又彼所言。虽实一处。而于一中据差别相。立余十一。谓初眼处亦名法处。乃至意处亦名法处。最后法处唯名法处。若尔便越顺别处经。如彼经说。苾刍当知。法谓外处。是十一处所不摄法。又处处说。法为意境。都无处言。眼等十一名为法处。故不可谓虽皆法处。而彼经中据别法处。说十一处所不摄法名为法处。是故彼言唯自计度。又彼虽立境及有境。而极杂乱。五取自境。意缘一切。有何杂乱。有境为境。境为有境。岂非杂乱。不了此中何者有境何者为境。故甚迷乱。我于此经见如是趣。说处欲显不杂所依境有境异。此何所为。为舍我执。执我论者。妄作是言。我是见者乃至知者。此我即是乐等所依。此经示有多法作用。显无一法名能见者。乃至所依。由此理故。虽一切法皆是意境。而不共境。唯是境者。立为意境。唯对此立意为有境。勿彼谓此异想说我。有诸法处。体唯是境。亦有有境。然非所依。或此与意。立一有境。是能依故。亦无有失。眼等及意。虽有意根不共境义。而非唯境。色等五处虽但是境。而无意根不共境义。眼等五根更无余境。即色等境名为不共。即对此境说有境名。此中处声。说眼等六为所依处。说色等六为所缘处。显此为缘生长异法。故说为处。即依此理。以释处名。谓能生长心心所法。故名为处。是故说处。为立不杂境及有境无乱有用。我于此经。见是意趣。审择法者应更寻思。何故一切心所法中。别立二法为受想蕴。胁尊者言。世尊于法了达而立。不应诘问。或说有因。颂曰

  诤根生死因　　及次第因故
  于诸心所法　　受想别为蕴

论曰。世斗诤根。略有二种。谓贪着欲耽嗜拘碍。及贪着见耽嗜拘碍。初因受起。后由想生。味受力故。贪着诸欲。倒想力故。贪着诸见。又生死法。以受及想为最胜因。耽乐受故。执倒想故。爱见行者。生死轮回。由此二因。及后当说次第因故。应知别立受想为蕴。其次第因。邻次当辩。又此受想。能为爱见二杂染法。生根本故。各别显一识住名故。依灭此二立灭定故。如是等因有多品类。何故无为。说在处界。非蕴摄耶。颂曰

  蕴不说无为　　义不相应故

论曰。诸无为法若说为蕴。立在五中。或为第六。皆不应理。义相违故。所以者何。彼且非色。乃至非识。故非在五。聚义是蕴。非无为法。如彼色等有过去等品类差别。可略一聚名无为蕴。故非第六。又无为法。与颠倒依及断方便。义相违故。说有漏蕴显颠倒依。说无漏蕴显断方便。无为于此两义都无。义不相应。故不立蕴。有说。无为是蕴息故。不可名蕴。如世瓶破非复称瓶。经主难言。彼于处界例应成失。谓处界息应非处界。便违所宗。全于蕴门众生计我。入无余位诸蕴顿息。处界不然。非全生故。唯取蕴起假说为生。若诸蕴息亦立为蕴。般涅槃已。余蕴应存。众生畏蕴有多过患。应于涅槃无安隐想。非处界中全有多过。故无余位处界犹随。故蕴不应例彼成法。又此息言意非显断。空非择灭。体非断故。此言意显若于是处蕴相都无名为蕴息。三无为上聚义都无可名蕴息。非门族义于彼亦无故不应例。此释与颂义善相符。世尊起教。觉惠为先。依何说蕴如是次第。颂曰

  随粗染器等　　界别次第立

论曰。五蕴随粗随染器等及界别故。次第而立。随粗立者。五中最粗。所谓色蕴。有对碍故。五识依故。六识境故。五中初说。四中最粗。所谓受蕴。虽无形质。而行相用易了知故。四中初说。三中最粗。所谓想蕴。取男女等。行相作用。易了知故三中初说二中粗者。所谓行蕴。贪等现起。行相分明。易了知故。二中初说。识蕴最细。故最后说。随染立者。谓从无始生死已来。男女于身更相染爱。由显形等。故初说色。如是色贪。由耽受味。故次说受。此耽受味。由想颠倒。故次说想。此想颠倒。由烦恼力。故次说行。此烦恼力。依能引发后有识生。故后说识。随器等者。谓色如器受所依故。受类饮食。增益损减有情身故。想同助味。由取怨亲中平等相。助生受故。行似厨人。由思贪等业烦恼力。爱非爱等异熟生故。识喻食者。有情本中为主胜故。识为上首受等生故。即由此理。于受想等。随福行中。但说识为随福行者。又由此理。说行缘识。复由此告阿难陀曰。识若无者。不入母胎。心杂染故有情杂染。心清净故有情清净。于受想等俱起法中。如是等经。但标主识。随界别者。谓欲界中色最为胜。诸根境色。皆具有故。色界受胜。于生死中诸胜妙受。具可得故。三无色中。想最为胜。彼地取相。最分明故。第一有中。行最为胜。彼思能感最大果故。此即识住。识住其中。显似世间田种次第。是故诸蕴次第如是。由此五蕴无增减过。即由如是诸次第因。于心所中别立受想。谓受与想。于心所中。相粗生染。类食同助。二界中强故别立蕴。已随本颂。且就转门。说次第因。四种如是。当就还门。复说一种。谓入佛法有二要门。一不净观。二持息念。不净观门。观于造色。持息念门。念于大种。要门所缘。故先说色。由此观力。分析色相。刹那极微。展转差别。如是观时。身轻安故。心便觉乐。故次说受。受与身合。定为损益。损益于我理必不成。由斯观解。我想即灭。法想便生。故次说想。由此想故。达唯有法。烦恼不行。故次说行。烦恼既息。心住调柔。有所堪能。故次说识。已说顺次。逆次应说。恐厌繁文故应且止。如是已说诸蕴次第。于界处中应先辩说六根次第。由斯境识次第可知。眼等何缘如是次第。颂曰

  前五境唯现　　四境唯所造
  余用远速明　　或随处次第

论曰。于六根中。眼等前五。唯取现境。是故先说。意境不定。三世无为。或唯取一或二三四。是故后说。境决定者。用无杂乱。其相分明。所以先说。境不定者。用有杂乱。相不分明。所以后说。所言四境。唯所造者。前流至此。五中前四境唯所造。是故先说。身境不定。大种造色俱为境故。所以后说。或时身根唯取大种。或时身根唯取造色。或时身根俱取二种。是故身识。有说。极多缘五触起。谓四大种滑等随一。有说。极多缘十一起。余谓前四。如其所应。用远速明。是故先说。谓眼耳根取远境故。在二先说。二中眼用远故先说。如远丛林风等所击。现观摇动不闻声故。又眼用速。先远见人撞击钟鼓。后闻声故。鼻舌两根用俱非远。先说鼻者。由速明故。如对香美诸饮食时。鼻先嗅香。舌后尝味。如是且约境定不定用远速明。辩根次第。或于身中随所依处。安布上下说根次第。传说。身中眼处最上。又显在面。是故先说。耳鼻舌根依处渐下。身处多下。意无方处。有即依止五根生者。故最后说。岂不理实。鼻根极微。住鼻頞中。非居眼下。如说三根横作行列。处无高下。如冠花鬘。理实应尔。然经主意。就根依处。假说如此。经主或言。似通异释。故今于此别作颂文

  前五用先起　　五用初二远
  三用初二明　　或随处次第

于六根中眼等前五。于色等境先起功用。意后方生。是故先说。如本论言。色等五境。五识先受。意识后知。为自识依及取自境。应知俱是眼等功用。于五根中初二用远。境不合故。所以先说。二中眼用复远于耳。引事如前是故先说。鼻等三用。初二分明。故鼻居先。舌次身后。如鼻于香能取微细。舌于甘苦则不如是。如舌于味能取微细。身于冷暖则不如是。随处次第。释不异前。若色等境。五识先受。意识后知。云何梦中能取色等。有余师说。梦中忆念先所受境。若不尔者。诸生盲人。于其梦中亦应取色。有说。梦中非必忆念先所受境。境相现前分明取故。非于觉位忆念了别先所受境。如在梦中色等现前分明可取。非于梦位忆昔境时有殊胜德过于觉位。由此忆念先所受境。明了现前胜于觉位。是故梦中能取。非昔所受色等。然于梦位有时亦能忆昔境者。此非实梦。不能分明取境相故。若尔生盲何缘梦位不能取色。谁言生盲于其梦位不能取色。若谓梦中必定忆念先所受境。非先未受。应信生盲梦中取色。昔余生中曾见色故。又于梦中非唯梦见曾所更事。如余处说。是故生盲梦亦应尔。而本论言。色等五境五识先受意后知者。据容有说。非必定然。如是所言。于色等境。眼等先用。意后生者。亦非必定。眼等五识。展转互为等无间缘本论说故。此中且约非梦散位受了色等次第而说。由此已释定所取色。住空闲者。咸作是言。定中青等。是有见色。不可说言。此色定是眼识曾受异类色相。于此定中分明现故。此定境色。是定所生大种所造。清洁分明。无所障碍。如空界色。如是已说处界次第。即于此中应更思择。何缘十处体皆是色。唯于一种立色处名。又十二处体皆是法。唯于一种立法处名。颂曰

  为差别最胜　　摄多增上法
  故一处名色　　一名为法处

论曰。虽十二处十色皆法。而为差别。一立总名。言差别者。谓各别处。若色法性等故名同。是则处名应二或一。诸弟子等。由此总名。唯应总知不了别相。为令了知境及有境种种差别。故立异名。由是如来于其声等眼等色上。立异义名。色处更无异义名故。总名即别。如能作因。诸立别名。为显别义。此显别义。故即别名。法处亦尔。言最胜者。由二因缘。唯色处中色相最胜。一有见故。可示在此在彼差别。二有对故。手等触时即便变坏。又多种故。三眼境故。世共于此立色名故。诸大论师。非于声等立色名故。唯一名色。于法处中。摄受想等众多法故。应立通名。若离通名。云何能摄多别相法同为一处。又于此中摄名品类法名诸法。故立法名。谓择法觉支法智法随念法证净法。念住法无碍解法宝法归。此等法名有无量种。一切摄在此法处中。故独名法。又增上法。所谓涅槃。此中摄故。独名为法。诸契经中。有余种种蕴。及处界名想可得。皆在此摄。如应当知。且辩摄余诸蕴名想。颂曰

  牟尼说法蕴　　数有八十千
  彼体语或名　　此色行蕴摄

论曰。有说。佛教语为自体。彼说法蕴皆色蕴摄。语用音声为自性故。有说。佛教名为自体。彼说法蕴皆行蕴摄。名不相应行为性故。语教异名。教容是语。名教别体。教何是名。彼作是释。要由有名乃说为教。是故佛教体即是名。所以者何。诠义如实。故名佛教。名能诠义。故教是名。由是佛教定名为体。举名为首。以摄句文。齐何应知诸法蕴量。颂曰

  有言诸法蕴　　量如彼论说
  或随蕴等言　　如实行对治

论曰。有诸师言。八万法蕴。一一量等法蕴足论。谓彼一一有六千颂。如对法中法蕴足说。或说法蕴。随蕴等言一一差别。数有八万。谓蕴处界缘起谛食静虑无色无量解脱胜处遍处觉分神通无诤愿智无碍解等。一一教门。名一法蕴。如实说者。所化有情。有贪嗔痴我慢身见及寻思等八万行别为对治彼八万行故。世尊宣说八万法蕴。谓说不净慈悲缘起无常想空持息念等诸对治门。此即顺显随蕴等言。无蕴等言。不为对治有情病行唐捐而说。如彼所说八万法蕴。皆此五中二蕴所摄。如是余处诸蕴处界。类亦应然。颂曰

  如是余蕴等　　各随其所应
  摄在前说中　　应审观自相

论曰。余契经中。诸蕴处界。随应摄在前所说中。如此论中所说蕴等。应审观彼一一自相。且诸经中说余五蕴。谓戒定慧解脱解脱知见五蕴彼中戒蕴此色蕴摄。是身语业。非意思故。彼余四蕴。此行蕴摄。是心所法。非受想故。又诸经说。十遍处等。前八遍处。及八胜处。无贪性故。此法处摄。若兼助伴。五蕴性故。即此意处法处所摄。后二遍处。空无边等。四无色处。四蕴性故。亦此意处法处所摄。五解脱处。慧为性故。此法处摄。若兼助伴。即此声意法处所摄。复有二处。谓无想有情天处及非想非非想处。初处即此十处所摄。无香味故。后处即此意法处摄。无色性故。又多界经说界差别。有六十二。应随其相当知摄在十八界中。且彼经中所说六界。地水火风四界已辩。空识二界未辩其相。如是二界其相云何。颂曰

  空界谓窍隙　　传说是明闇
  识界有漏识　　有情生所依

论曰。内外窍隙。名为空界。如是窍隙。云何应知。传说。窍隙即是明闇。谓窗指等明闇窍隙显色差别。名为空界。本论中辩此空界相。亦说名为邻阿伽色。言阿伽者。谓极碍色。大造积集。堪引往来。能有任持。极为碍故。邻是近义。此空界色与彼相邻。虽是彼类而非即彼。色谓色界色处色蕴。为其自性。此邻极碍。复是色性。是故说名邻阿伽色。有说。阿伽即空界色。此中无碍故名阿伽。即无碍色。余碍相邻。是故说名邻阿伽色。所言传说。表不信承。彼说意言。何有此理。故彼上座。及余一切譬喻部师。咸作是说。虚空界者。不离虚空。然彼虚空体非实有。故虚空界体亦非实。此有虚言而无实义。虚空实有。后当广明。今因空界。且略成立。离虚空界实有虚空。故世尊言。虚空无色无见无对。当何所依。然藉光明虚空显了。此经意说。虚空无为。虽无所依。而有所作。谓能容受一切光明。以果显因。有实体相。虚空无者。应无光明。既有光明。眼识所取。是色差别。故有虚空。以能容受光明等故。实有虚空理极成立。由此所说。契经文句。显二分明。各别实有。又于色界得离染时。亦说断此虚空界故。如世尊说。离色染时心于五界解脱离染。唯余识界不应说断。虚空无为。诸漏于中曾未转故。又契经说。此虚空界有内有外。非即虚空。如契经言。内虚空界。所谓眼窍。乃至广说。外虚空界。所谓空中及门窗等诸有窍隙。非无为法可言内外。岂不空界与空无为无障相同。体应无异。此言无理。所以者何。虚空无为无障相者。谓非能障。亦非所障。虚空界者。虽非能障。而是所障。被余障故。由此不应定说空界无障为相同彼虚空。若尔诸说。造色不离大种处者。彼说大种不障造色。大种亦非造色所障。是则大种无障为相。应同虚空。彼说非理。俱有对故。大种造色。互相障碍。应各别处。岂相容受。既不相容。如何大种无障为相同于虚空。又彼许色少分无障。故与虚空其相有别。彼说大造虽不相障而障余色。故异虚空。虽诸大种不障自果。亦复不为自果所障。而与余色互相障碍。是故虚空无障为相。异虚空界。理得成立。由此空界非即虚空。又体实有。经说有故。犹如地等。如契经说。实有六界成假士夫。又是有为假士依故。犹如地等。又是明闇显色性故。又是有漏。说此为缘入母胎故。离色染时说。断彼故。即由此因证体是色。又如颂言

  譬如盛满月　　行无垢空轮

空即空界。显空是色。有垢无垢。在色体故。有别诵言

  如净满月轮　　游历虚空界

此亦空界无障垢故。月轮无垢义不异前。或复如何说有色法行于无色。与理相应。又说汝等当观我手举在虚空。乃至广说。彼诸长老。不善谛观如是理教。随情所说。于古圣贤展转传授。顺理言教而不敬从。已说空界。识界云何。谓有漏识。何缘不说无漏诸识为识界耶。与识界义不相应故。由无漏法。于有情生断害坏等差别转故。非生所依。如是六界。于有情生生养长因差别转故。是生所依。生因。谓识界续生种故。养因。谓大种生依止故。长因谓空界容受生故。尊者世友作如是言。界是施设有情因故。非无漏法。如契经说。六界为缘入母胎故。由此界名随义而立。谓能持生。故名为界。入母胎缘。贯通六界。唯一识界。独能续生。彼经六界此九界摄。余随所应。当观摄义。故诸余界。十八界摄

说一切有部顺正理论卷第三阿毗达磨顺正理论卷第四

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩本事品第一之四

如是已说余蕴处界皆在此中。蕴处界摄今当显示。蕴处界三。有见等门义类差别。界中具显根境识故。诸门义类易可了知。故今且约十八界辩。由斯蕴处义类已成。于前所说十八界中。几有见几无见。几有对几无对几善几不善几无记。颂曰

  一有见谓色　　十有色有对
  此除色声八　　无记余三种

论曰。十八界中。一是有见。所谓色界。云何说此名有见耶。由二义故。一者此色定与见俱。故名有见。由色与眼俱时起故。如有伴侣二者此色可有示现。故名有见。可示在此在彼别故。如有所缘。有说。此色于镜等中有像可现。故名有见。可示如彼此亦尔故。不可说声有谷响等应成有见。不俱生故。由说此相。余界无见义准已成。如是已说有见无见唯色蕴摄。十界有对。对是碍义。此有彼碍。故名有对。此复三种。境界所缘障碍别故。境界有对。谓眼等根。心及心所。诸有境法与色等境。和会被碍。得有对名。故施设论。作如是言。有眼于水有碍非陆。乃至广说。彼论意言。有眼水中与境和会。而被拘碍。非于陆境。所缘有对。谓心心所。于自所缘。和会被碍。得有对名。境界所缘。复有何别。若于彼法。此有功能。即说彼为此法境界。如人于彼有胜功能。便说彼为我之境界。心心所法执彼而起。彼于心等名为所缘。若法所缘有对定是境界有对。心心所法。境界若无。取境功能定不转故。有虽境界有对而非所缘有对。谓五色根非相应法。无所缘故。云何眼等。于自境界所缘转时。说名有碍。越彼于余此不转故。或复碍者是和会义。谓眼等法。于自境界及自所缘。和会转故。有说。若法唯于彼转。不能越彼。故名有碍。障碍有对谓可集色。自于他处被碍不生。如手石等。更相障碍。今于如是三有对中。唯辩障碍。故但言十。更相障碍。对义胜故。若法境界有对亦障碍有对耶。应作四句。谓七心界相应法界。是第一句。色等五境。是第二句。眼等五根。是第三句。法界一分非相应法。是第四句。说十有色名为有对。义准说余名为无对。言有色者。谓除无表。余色蕴摄。变碍名色。有变碍义。故名有色。有说。色者。谓能示现在此彼言。此有彼言。故名有色。有说。诸色有自体故。名为有色。称说易故。唯于色体说有色言。如是已说有对无对。于此所说十有对中。除色及声。余八无记。言无记者。谓不可记说为善不善故。应赞毁法。可记说在黑白品中。名为有记若于二品皆所不容。体不分明。名无记法。其余十界。通善等三。即是七心色声法界。善谓舍恶。是违恶义。或复善者。名慧摄受谓若诸法慧所摄受。或摄受慧。皆名为善。或复善者。是吉祥义。能招嘉瑞。如吉祥草。翻此即释不善义名。色声二界。善心等起。即名为善。恶心等起。名为不善。余是无记。其七心界。若无贪等相应名善。贪等相应名为不善。余名无记。法界所摄品类众多。无贪等性相应等起。择灭名善。若贪等性相应等起。名为不善。余名无记。其五识身皆无分别。又唯一念堕在境中。云何立为善不善性。若谓五识无分别故。非善不善。有太过失。或等引中所有意识。皆无分别。应非善性。又五识身非无分别。许与寻伺恒相应故。又虽一念堕在境中。谁遮相应。有信贪等。由有意识。虽复一念堕在境中。而成善恶。故不应用此所说因遮五识身善不善性。化地部说。前四识身。但异熟生。唯无记性。身识亦有时转变生。故与意识俱通。有记。此说非理。与契经中立六爱身。义相违故。彼作是释。眼触无间所生贪爱。名眼触生。此释非理。受等同故。六六经中说眼触生受想思等。非不许彼与眼触等俱时而生。是故不应作如是释。岂不如经说十八意近行。虽复说有三六不同。而唯在意。此亦应尔。如是立喻与法不同。立六六门。据所依异。立意近行。就所缘别。是故不应以彼喻此。又彼所说。但述己情。防护六根。契经说故。如契经说。应于眼根乃至意根防护而住。若如所说契经但应言应于意根防护而住。若谓释此同意近行。经是则应言应防护色等。又说能招苦异熟故。如契经说。若有六根不护不防不密而住。招苦异熟。然五色根无记性故。不招异熟。应知经意。就依根识作如是说。如契经言。眼所识色。眼所希求。此亦如是。若不尔者。经唯应说。若有意根不护不防不密而住。招苦异熟。又契经说。若有眼根不护不防不密而住。乃至广说。岂异熟生。有不护等。又虽一念堕在境中。而能取相故通有记。如契经言。眼见色已。能不取相。不取随好。由诸色境二识取故。先起眼识取诸色相。后起意识取彼随好。如是契经。意显眼识能取相故。亦能起染。若尔云何唯说意识是有分别。应知但依分别力故。起诸过失。应共思求契经意趣。我说。若识于一刹那能取非一品类境界。于一所缘多心流注。如是相识。名有分别。然五识身唯取现境。无二念识同一所缘无一所缘前取灭已。第二念识复取生故。意识能缘三世境界。法虽已灭。犹是所行。于一所缘多心流注。故唯说此是有分别。然五识身。自性分别恒相应故。亦有分别。而契经言无分别者。谓无随念计度分别。自性分别。其体是寻。五识相应。如前已说。然伽他说。第六增上王等。此中显示多分起染次第。如契经言。父母于子能作难作。非不亦有子于父母能作难作。此中亦尔。然诸众生有种种性。或软烦恼。或利烦恼。软烦恼者。要先发起虚妄分别。然后烦恼方现在前。利烦恼者。不待分别。境才相顺。烦恼便起。由此道理。或有先起染污意识。或有先起染污余识。如燃火时。或先烟起。渐次生焰。后方洞然。或遇卒风。猛焰顿发。俄成灰烬。如人身中。病本若少。饮食乖适然后病生。病本若多。少遭风热外缘所触。众疾竞起。烦恼病起。理亦应然。故五识身亦通三性。理得成立。已说善等。十八界中。几欲界系。几色界。系几无色界系。颂曰

  欲界系十八　　色界系十四
  除香味二识　　无色系后三

论曰。系谓系属。即被缚义。欲界所系具足十八。色界所系唯十四种。除香味境及鼻舌识。除香味者。段食性故。离段食贪方得生彼。除鼻舌识。无境界故。非无境界少有识生。若尔于彼亦应无触。非食性触于彼得有。触界于彼无成食用。有成余用。所谓成身。若不尔者。大种应无。则诸所造亦应非有。便同无色何名色界。又于彼触有成外用。谓成宫殿及衣服等。虽离食染。触有别用。香味不然。故彼非有。有余师说。住此依彼静虑等至。见色闻声。轻安俱起。有殊胜触。摄益于身。是故此三。生彼静虑。由相随逐。香味不尔。故在彼无。经主此中谓前有过。言彼鼻舌亦应非有。如香味境。彼无用故。岂不二根于彼有用。谓起言说。及庄严身。起说严身。但须依处根非有见。何所庄严。如无男根亦无依处。二根无者依处亦无。于彼可无男根依处。彼无用故鼻舌依处。彼有用故。离根应有。谓庄严身。及起言说。有虽无用而有根生。如处胞胎定当死者。于中眼耳何用故生。于根有爱及殊胜业。因此故生。无用何失。岂不色界鼻舌二根有爱业因故亦应起。若离境爱。根爱亦无。或应男根于彼亦有。彼无男根。离根爱故。由离根爱。依处亦无。此中何因作如是执。若离境爱。根爱亦无。非根爱无处爱亦离。根与依处邻逼而生。境界不然。如何倒执男根依处于彼不生。即显男根于彼离爱。既许鼻舌依处彼生。故知二根彼爱未离。故不应执彼离根爱未离处爱。理如前说。又离境爱非证根无。如或有时眼耳身识未得离爱。彼所依根。亦同其识。未得离爱。或复有时。已离识爱。根爱未离。由有所须。如是或时根爱已尽。其境界爱亦复随灭。或复有时。已离境爱。由须用故。根爱未除。又引男根。亦不成证。由彼起爱所依不同。依于内身起六根爱。非依境起。如何可说若离境爱根爱亦无。起男根爱。依淫触境。境爱彼无。理无根爱。又眼等根。互相系属。见诸哑者多分耳聋。涂足不涂眼便明昧。脐轮涂沃津润于唇。拔鼻中毛眼便落泪。诸如是等。其类寔繁。故知诸根更相损益。勿令眼等诸根用微故。鼻舌根色界定有。由兹色界十四义成。无色界系。唯有后三。所谓意法及意识界。要离色染。于彼得生。故无色中无十色界。依缘无故。五识亦无。故唯后三无色界系。已说界系。十八界中几有漏几无漏。颂曰

  意法意识通　　所余唯有漏

论曰。即此意法及意识三。一切皆通有漏无漏。谓除道谛及三无为。余意等三皆是有漏。道谛所摄。及三无为。如其所应。三皆无漏。唯通有漏。谓余十五。道谛无为所不摄故。如是已说有漏无漏。十八界中。几有寻有伺。几无寻唯伺。几无寻无伺。颂曰

  五识有寻伺　　后三三余无

论曰。眼等五识有寻有伺。由与寻伺恒共相应。此五识身恒与寻伺共相应者。经主释言。以行相粗外门转故。此因非理。现见意识。内门转时。亦常与彼共相应故。应作是释。五识唯于寻伺所随地中有故。非于欲界初静虑中心心所法除寻与伺而有不与寻伺相应。何用外门为因简别。意法意识名为后三。根境识中各居后故。此后三界皆通三品。意界意识界及相应法界。除寻与伺。若在欲界初静虑中。有寻有伺。静虑中间无寻唯伺。从此以上无寻无伺。法界一切非相应法。静虑中间伺亦如是。于彼上地无寻伺故。非相应故。彼无寻故。自体自体不相应故。寻一切时无寻唯伺。自体自体不相应故。此常与伺共相应故。岂不经主言。无第二寻故。设有第二许相应耶。有第二受而不相应。无第二言。非为定证。一时无二故。行相不同故。虽有第二而不相应。如是此因便为无用。或应自体自体相应。许无差别亦相应故。此何缘故成异体耶。岂不还成自体自体不相应故。自体行相无差别法。一时无有二体相应。是故此因能为定证。非彼言无第二寻故。伺在欲界初静虑中。三品不收。应名何等。此应名曰无伺唯寻。自体自体不相应故。此常与寻共相应故。由此安立有寻伺地。法有四品。余十色界。寻伺俱无。常与寻伺不相应故。此中乘便应更思量。若五识身有寻有伺。寻即分别。如何许彼无分别耶。颂曰

  说五无分别　　由计度随念
  以意地散慧　　意诸念为体

论曰。分别有三。一自性分别。二计度分别。三随念分别。由五识身虽有自性而无余二。说无分别。如一足马名为无足。故虽有一而得名无。岂不意识有唯一种分别相应。由依意识总类具三。说有分别。自性分别体唯是寻。后心所中自当辩释。余二分别。如其次第。意地散慧诸念为体。散言简定。意识相应散慧。名为计度分别。定中不能计度境故。非定中。慧。能于所缘。如此如是计度而转。故于此中简定取散。若定若散。意识相应诸念。名为随念分别。明记所缘用均等故。五识虽与慧念相应。择记用微。故唯取意。夫分别者。推求行相。故说寻为自性分别。简择明记。行似顺寻。故分别名亦通慧念。由此三行差别摄持。皆令于境明了转异。于已了境遮简行生。故分别名不通于想于未了境不能印持。故分别名不通胜解。若在欲界及初静虑。不定意识。具三分别。若初静虑。在定意识。及上散心。各二分别。上地意识。若在定中。及五识身。各一分别

如是已说有寻伺等。十八界中。几有所缘。几无所缘。几有执受。几无执受。颂曰

  七心法界半　　有所缘余无
  前八界及声　　无执受余二

论曰。六识意界。及法界摄诸心所法。名有所缘。有所缘故。如人有子。所缘所行及与境界。名义差别。余十色界。及法界摄不相应法。名无所缘。义准成故。此中上座作如是言。五识依缘俱非实有。极微一一不成所依所缘事故。众微和合。方成所依所缘事故。为成此义。谬引圣言。佛告多闻诸圣弟子。汝等今者应如是学。诸有过去未来现在。眼所识色。此中都无常性恒性。广说乃至。无颠倒性。出世圣谛。皆是虚伪妄失之法。乃至广说。彼谓五识若缘实境。不应圣智观彼所缘。皆是虚伪妄失之法。由此所依亦非实有。准所缘境不说而成。又彼师徒串习世典。引众盲喻。证已义宗。传说。如盲一一各住。无见色用。众盲和集。见用亦无。如是极微一一各住。无依缘用。众多和集。此用亦无。故处是假。唯界是实。彼部义宗略述如是。今谓彼论涉坏法宗。故有智人不应欣慕。五识不缘非实有境。和集极微为所缘故。又五识身无分别故。不缘众微和合为境。非和合名别目少法。可离分别所见乃至所触事成。以彼和合无别法故。唯是计度分别所取。五识无有计度功能。是故不缘和合为境。即诸极微。和集安布。恒为五识生起依缘。无有极微不和集故。设有极微不和集者。是彼类故。亦属依缘。然五识身。唯用和集为所缘故。不缘彼起。犹如虽有过去未来色等境界以五识身唯现境故不缘彼起。虽不缘彼而五境摄。又眼识不缘和合为境。以青等显色应非实故。若眼识缘和合为境。青黄等觉应决定无。青等不应是和合故。若是和合应非实有。是则显色。亦假非真。无容眼识不取青等。有意识能分别青等。若言青等如和合者。其理不然。以就胜义。非许和合是色性故。有诸师说。和合亦非意识境故。或五识身。唯缘胜义。世俗唯是意识所缘。故无青等同和合过。如取未来不见灭色。于何分位缘和合耶。于彼所依已灭分位。岂不此位无和合耶。余位亦无。何独责此。如青等有和合本无。唯分别心计度而取。如于现世和集色等。起总计度名和合觉。如是亦应由觉慧力。于已灭位不集色等。起总计度名和合觉。又如觉慧。虽集去来现在等色总为一聚名色蕴觉。而去来等诸色不同。不可集为一和合聚。虽彼一一各起蕴觉。而去来等诸色不同。应不总生一色蕴觉。然有如是总色蕴觉。故知亦于已灭色等。彼虽离散不可和集。而觉慧力。摄为一聚。成和合觉。理不相违。缘一合境名和合觉。如于已灭青色境界。谓是青性觉相分明。复为他说。我见如是如是青性。如是于彼已灭色等。起和合觉明了现前。亦为他说我见如是如是和合。若执意识亦不能缘和合为境。是则应许诸和合觉无有所缘。若谓即缘所依为境。是则应名缘色等觉。色等一一非和合故。何得说名缘和合觉。若谓施设理亦不然。不可无境有施设故。非毕竟无可施设有。是故意识。亦有能缘和合为境非五识身。以彼唯缘实有境故。若执极微不可见故。眼识不缘实有为境。此执不然。是可见故。而不了者。由彼眼根取境粗故。又彼眼识无分别故。诸有殊胜智慧力者。乃能了别细极微相。如远近观锦绣文像又如先说。先何所说。谓无极微不和集故。既常和集。非不可见。有说。极微性相安立。彼于眼识为所缘定。眼识于彼非定现行。不能一一别相见者。不和会故。非非相故。以有诸法虽是可见有少因缘而不能见。如不能见水中盐色。及不能见壁等障色。又不达义。妄引圣言。若执彼经有此义者。意识所缘亦应非实。同说虚伪妄失法故。若尔缘实觉慧应无。是则分明崩坏法论。若言意识通无漏故无斯过者。理亦不然。无漏意识。亦以总法为所缘故。汝宗又许。眼等五识通无漏故。不应妄执五识所缘唯假非实。有世间智缘界为境。彼所缘界亦应非实。然彼经说。六识所缘皆虚伪等。无有差别。故说有漏所缘唯假。但由贪着自所乐宗。若尔彼经复有何义。愚夫长夜。于色等境。妄执常等真实性相。是故如来教圣弟子。如实观彼离诸妄执。谓去来今六识所识。如彼妄执常等都无。皆是虚伪妄失之法。此显妄执所取境虚。不显所缘皆非是实。故彼经后复作是言。有能如是如实观者。于去来今眼所识色。诸邪胜解想心见倒贪身系等。广说乃至。彼皆永断。是故于中愚夫妄见所执常等。佛圣弟子。观为虚伪妄失之法。非观境体为虚伪等。是谓契经不违理义。又如是释其理必然。由彼经说。于去来今眼所识色。非有眼识能识去来。又非去来可有和合。又非汝等许有去来。是故不应引彼圣教证成五识缘和合境。此契经义。违汝所宗。以说常等是虚等故。又彼经中。不依眼等五识境说。由观彼境远离所执常等性故。又说彼境三世别故。又说观彼想心见倒贪身系等皆永断故。又若如言。便起定执于深义趣不思求者。受等亦应非胜义有。以于六境说虚等故。又于诸处唯总说言。眼色为缘。生于眼识。如何得知。以界和合为所依缘。生于眼识。非界和集为所依缘。复如何知唯界和集。理如前说。复有圣言。显眼等识非缘妄境。故契经言。于不见言见。于见言不见。此非圣语。于见言见。于不见言不见。此是圣语。若眼等识缘妄境者。于见言见。应非圣语。于见言不见。应是圣语。若谓随俗说如是言无斯过者。则应意识说。缘实者亦随俗言。是即一切唯有假说。便为安住坏法论宗。或应辩析差别道理。又此圣语。依何境说。若依和合。眼识不缘和合为境。已广成立。若依和集即是胜义。何谓见言随世俗说又所见色唯是胜义。于见见言可随俗说。言于诸方不决定故。非所见色是随俗言。而契经说。大母当知。于所见中唯有见语。此就增益常等性相。说此唯言。非于见境。又于色处。说名有见及有对故。于声等处别异说故。处非假有。非于假有补特伽罗瓶等法上有差别说。唯于实有色等法上。有自共相差别说故。又于此中。触法处界有何差别。而言触法处唯是假。界是实耶。若言此二亦有差别。多物和合方得处名。一一别物。即得名界。触处可尔。法处云何。汝宗法处虽有三法。而无积集。法界何异。又彼建立处界不同。都无正理及所余量。但彼上座。随意而立。傍观鉴人不应信受又若处假界是胜义。上座此论便违经说。如契经说。乔答摩尊余处说言。我觉一切。依何一切言我觉耶。唯愿为开胜义有法。世尊告曰。梵志当知。言一切者。谓十二处。此胜义有。余皆虚伪。世尊不应依不实法说胜义有。又亦不应唯证假有成等正觉。空花论者可说此言。称佛为师。不应党此。故十二处皆是实有。非于假法可说胜义。如是上座诸有所言。前后谛观。多成违害。信而无智。同所敬承。具智信人。必无随顺。又众盲喻。违彼自宗。一一极微非依缘体。众微和合成依缘论。彼对盲喻。极不相符。和集极微为依缘论。此对盲喻理不相违。许一一微是依缘故。执一一微非可见者。众微和合亦应不见。同盲喻故。如非色合。故五识身。决定不用和合为境。然必有境。故以实法为境义成。若五识身。了胜义境。何缘五识不断结耶。了自相故。外门转故。无等引故。无分别故。一堕境故。所缘少故。虽了胜义而不断结。故说七半有所缘中。五界唯缘胜义为境。余缘胜义。亦缘世俗。如是已说有所缘等。十八界中九无执受。何等为九。谓前所说七有所缘。并全法界。此八及声皆无执受。颂中及言。具含二义。一显总集。谓八及声总无执受。二显异门。谓余师说。不离根声亦有执受。余九通二。谓五色根。色香味触。云何通二。眼等五根住现在世。名有执受。过去未来。名无执受。色香味触住现在世不离五根。名有执受。过去未来及住现在。非不离根。名无执受。是故九界各通二门。何等名为有执受相。标之心首而说是言。本论中说。己身所摄名有执受。此复云何。谓心心所执为己有。即心心所共所执持。摄为依处。名有执受。损益展转更相随故。若尔色等即应一向名无执受。心心所法不依彼故。非根性故不尔。色等若不离根。虽非所依。而是心等之所亲附。故无此失。毗婆沙说。若诸色法逼迫断坏。便能生苦。与此相违即能生乐。是己身摄。名有执受。有余师说。若诸有情执为自体。一切处时。方便防护茅灰火刺霜雹等缘。是己身摄。名有执受。若尔应违契经所说。故契经言。若于是处识所执藏。识所随摄。名有执受。虽有是说而不相违。有执受法略有二种。一者有爱及有身见。执为己有。名有执受。二者为因能生苦乐。名有执受。宿业所引异熟果等。分位相续。是名第二。此中有爱及有身见。若正智生。即便断灭。异熟相续。诸漏尽者。亦未断灭。是故若法。既执受已。至般涅槃。随转不舍。此法一向名有执受。是为经论二义差别。如是已说有执受等。十八界中。几大种性。几所造性。几可积集。几非积集。颂曰

  触界中有二　　余九色所造
  法一分亦然　　十色可积集

论曰。触界通二。一者大种。二者所造。此二如前十一触释。寡学上座。于此说言。非触处中有所造色。所以者何。即诸大种形差别故。谓即大种次第安布。于诸金银颇胝迦宝云母金刚芭蕉练等和合聚中。说为滑触。与此相反和合聚中。说为涩触。余随所应。皆即大种安布差别。又眼亦能觉了彼故。彼谓依眼随取大种形量色相。亦能觉了滑涩等物。故知滑等不异大种。此说不然。违圣教故。如契经说。苾刍当知。触谓外处。是四大种。及四大种所造有色无见有对。彼不许有。如是契经。不应不许。入结集故。又不违害诸余契经。亦不违理。故应成量。彼谓此经非入结集。越总颂故。如说。制造顺别处经立为异品。若尔便应弃舍一切。违自部执圣教契经如说。制造二种空经立为异品。亦越总颂。如是等类。互相非拨。若谓此经非圣所说违余经故。法处不说无色言故。如舍利子增十经中。唯作是言。有十色处。故知此经非入结集。但是对法诸师。爱无表色。制造安置阿笈摩中。若尔对法诸师。岂不亦能作如是说。譬喻部师。憎无表色。制造安置增十经中。如是展转。更相非拨。便为坏乱一切契经。然增十经。为显十种应遍知法。故但说言有十色处。此十一向苦谛摄故。苦谛唯是应遍知故。无有相违。无表有漏无漏性故。犹如意处。亦应修习。是故于彼增十经中。唯说一向应遍知法。岂不亦是应永断耶。此难不然。立谛异故。又舍利子。于彼经中定有此意。言非尽法。即彼经中复说十种应永断法谓五内外顺诸盖法非无余法亦是永断。是故成此不违余经。如是上座。说触处中无所造色。决定违害此别处经。智者应了。言即诸大种形差别故者。不说正因。云何定知。即诸大种形量差别名滑等性。非异大种别有滑等又诸大种。安布差别。即诸大种。非诸大种是眼所取。眼所取者。谓显与形。如何乃言即诸大种形差别故。岂不闇中身亦能取形量差别。若尔大种应二根取。以言形量即大种故。由此即破彼第二因。谓眼亦能觉了彼故。又谓依眼随取大种形量色相亦能觉了滑涩等者。此言何义。若谓眼取大种形量。既执形量不异大种。应许眼根能取大种。若谓眼根能取色相。大种形量随此比知。如是云何。遮滑等异大种。由见色相。比知滑等言即大种。此有何因。而言滑等不异大种。但有虚言都无实义。又应谓坚即余三大安布差别如滑涩等。谓他亦能如是计度。余三大种。安布差别。即名为坚。无别有坚异三可得。由无异因。不应别执。故彼言义。无所堪能。又因嗅香觉了苦酢。应言苦酢体不异香。又滑等相异诸大种。故异大种应别有性。谓非滑性即是坚性。非诸坚处皆有滑故。如地即坚未尝相离滑性。若尔应不离坚亦非滑性即是湿性。非诸湿处皆有滑故。亦非滑性即是暖性。非诸暖处皆有滑故。亦非滑性即是动性。非息等处滑可得故。由此故知滑非大种。亦非不有。如实有法现可得故。又能为缘生影像故。若谓唯有安布差别无实体者。理亦不然安布差别必有所依。此所依体即滑性故。或应唯得安布差别。不应亦了此中滑性。又契经中。方便说有如是滑性。如契经言

  如来皮肤极细滑　　一切尘垢不着身

又纵滑性。有经无经。然曾无经遮彼有故。又与正理不相违故。如是滑性实有义成。又若滑性。异四大种。无别有体。应假非实。是则身识应不了知。身识唯缘胜义境故。又离分别滑觉应无。如离分别。于诸大种。一一体上皆有别觉。即说身识缘诸大种。实物为境。非缘假法。滑性亦然。既身所取。故不可说是假非实。又非一一大种中有。故异大种别有滑性。由此道理。亦总成立异四大种有涩等性。其中差别当更显示。彼上座言。无别所造名轻重性。即诸大种。或少或多。说轻重故。又轻重性相待成故。非实有体。谓即一物待此名轻。待彼名重。非坚性等相待而成。又于风界说轻性故。轻即是风。如本论言。云何名风界。谓轻等动性。世尊亦说。诸轻等动性。名内外风界。此说不然。前说大种。与此相异。非此性故。若不了知经论义故。即谓轻性是风界者。应说重性是何大种。若说此宗谓有大种增生重性。重性即是此大种者。理必不然。重与地水相各异故。又于一切和合聚中。皆具有故。应无差别。若谓少多故无过者。应非重性即是坚湿。又许和合为轻重故。身识不应缘彼为境。又即大种众多极微和合聚中。许为重故。即应一切和合聚中皆有重性。无定因故。若言大种和集差别。能为因缘别生重性则无斯过。此于世间现所见故。又言轻重相待成故。非实有者。此非善说。譬如因果。轻重亦然。谓如一物待此名因。非即待此复名为果。待彼名果。非即待彼复名为因。如是一物待此名轻。非即待此复名为重。待彼名重。非即待彼复名为轻。因果既实。此如何假。故唯能诠相待不定。非所诠体而有改易。又如彼此岸。轻重性亦尔。谓于彼物立彼岸名。非说此岸令体改易。或于此物立此岸名。非说彼岸令体改易。以即一物相续转时。待此彼边名彼此岸。轻重亦然。体非不定又如黑白。轻重亦然。谓即一物待此名黑。待彼名白。而非显色无别有体。是故相待。非不实因。若言待多总说一性。如瓶林等。是假非实。此亦应然。故非实者。云何知尔。应说其因。此且非因有过失故。若言坚等非相待成此相待成故非实者。坚等言说亦相待成。待不坚物立坚名故。坚非不实。此亦应然。若谓不然。未尝相待说坚为湿。不相似故。此非不然。其所待因。一向决定。义相似故。然非待余坚名湿者。以更无别所待因故。待不坚物说此为坚。未尝待彼名不坚物。轻重亦然。故义相似。虽于轻聚有时说重。而非由说舍彼轻性。但余缘故。起异能诠。体非改易。如前已辩。是故相待非不实因。或诸坚物亦有待对成异品类。谓或名坚。成名坚胜。或名坚极。于中亦说坚名不坚。其理既同。汝应生喜。不能令喜。轻重二物。同坚不坚。应成一故。且轻重性异诸大种。实有义成。然不应言相待不定应成一物。如黑与白。虽相待对。品类不同。而非一故。若言黑白。虽品类异。而未曾有说白为黑黑为白者。此亦不然。现见世间。有此说故。名虽不定而体不易。如前已说。故体不同。又如汝说。微火为冷。有微暖聚。待此名冷。待彼名暖。名虽不定而体是实。此亦应然。有诸色聚。轻极微多。重极微少。此聚名轻。与此相违彼聚名重。轻重二性聚同体别。其理显然。何缘不受。言于风界说轻性故轻即风者。此亦不然。辩大种中已释此义。对坚等三。动最难了。故举轻果以显风因。虽四大种皆是轻因。而就增强。故作是说。火虽增强而不决定。又轻与动相顺相似。故论经言。轻等动性。若唯如言定取义者。即彼经说。发毛爪等名内地界。岂发毛等唯地界耶。是故彼言。有别意趣。不应执彼遮轻造色。又阿笈摩有如是颂

  坚重坠身中　　如重舟沈海

故重如坚。应实有体。有余师说。轻性唯用重无为体。此亦不然。于虚空等重性既无。应有轻故。又于薪等重性非无。亦有轻故。若不尔者。掷置水内则不应浮。有非有性。不应俱有。亦不应说广大故浮。广大是形非触性故。广大石等亦应浮故。又此轻性是轻安果。故体非无。谓修定者。由轻安故。身觉轻触。不应用无作轻安果。若唯令身离重触故名为果者。理亦不然。轻性是身长养因故。不应谓无。亦能长养。以离轻安。应长养故。若谓轻安能除重触。唯大种生名长养者。应谓轻安灭余大种生。余大种。即名长养。何灭重为。重性如轻应非别有。则与上座所执应同。然不应理。轻重二相。诸大种中。皆无有故。若执轻性即诸大种少分为体。应执轻安现在前故少大种生。何故轻安与诸大种相违而起。若相违者。少亦应不生。若不相违。谁障多不起。故轻不应是轻安果。又轻非用重无为性。品类异故。犹如重性。又阿笈摩说有轻重。如彼所说。如诸铁团或诸铁鍱。若时有火。有极暖热。尔时便有极软极轻极调柔用与此相违。极坚极重极不调柔。我身亦尔。若有轻安。则便有轻有调柔用。堪任修断。与此相违。即便有重。无调柔用。不任修断

说一切有部顺正理论卷第四阿毗达磨顺正理论卷第五

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩本事品第一之五

又上座言。火界或少。或不增强。即名为冷。所以者何。于彼无日。或去日远。便有冷故。又如极大炎热起时。无别少分所造触起。同许唯有火大增多。热减少时亦应如是。无别少分所造触生。应许唯是火大减少。若别有冷亦应许有别所造触非暖非冷。是故定无冷所造触。非火界少。或不增强即名为冷。现见冷触所损害者。火界增时能摄益故。损害因增转应损害。谁有智者作如是执。被少火害归投大火。若谓彼由匮乏火故有损害者。理必不然。定有余因能损害故。谓火少故。有余冷增能为损害。非即由火。由此准说冷摄益者。谓为少因。所摄益者。此因若增。转应摄益。是故彼论非为应理。又彼所说。热增减时。无所造生唯即火者。亦不应理。现见二法更互相违。一法增时余法减故。如能断道与所断惑。非道增时无别惑起。例道退位无别惑生。又冷生时和合异故。谓水风界增盛聚中。有冷生因。非由火界。不应就火增盛为难。又执火界少为冷者。彼雪聚中火微极少。不应于此冷微极多。智不应言如如火界渐渐微少。如是如是火界转多。为应理论。彼执冷火无别体故。不可金少即为非金。故有别物异诸大种。由火界减。彼物体增。是所造触。说名为冷。有执此宗。谓有大种增生冷触。冷触即是此大种者。理亦不然。冷与水风相各异故。又二物成。体应是假便应不为身识所缘。以非冷暖无别性故。例无别冷。理亦不然。彼即冷等下等品类。分位别故有余师说。冷等唯用暖无为体此亦不然。品类异故。犹如暖等。不容无法有异品类。或应地等用无为性。谓亦可说唯水等无。名地等界。故彼所说。非破冷触是造色因。又冷能为觉生缘故。如火界等非即暖无。应有色聚全无有火。有非有俱不应理故。诸色聚中既必有火。是则冷触应毕竟无。故知离火别有冷触。又诸冷触其体实有。相状分明。现可觉故。犹如暖等。又契经中。如暖说故。体必应有。故契经言。我于冷暖皆能堪忍。若于尔时冷暖调适。即能成熟。取证成就。非于尔时极冷极暖。若极冷暖不能修业。故冷造色实有义成。又上座言。饥渴二种。非所造色。希求性故。理亦不然。此二于因说果名故。由触差别逼切其身。生食饮欲。是饥渴因。故名饥渴。如说轻安。谓身轻性。轻安果故。说名轻安。若尔此因应暖为性。由火界暖。能熟能消。便能发生食饮欲故。此言非理。食饮二欲应是造色。火为因故。又非火界。是二欲因应一切时生一欲故。现见二欲非恒时有。岂不自宗欲因造触所依大种。虽恒非无。而此造触体非常有。此例不然。欲因造触待风火界。增强生故。若谓二欲亦应尔者。理亦不然。如前已说。二欲应是造色性故。若谓如因所触大种发生身识。而非身识是造色性。欲亦应然。此不相似。识不要因大种增盛方得生起。欲即不然。因增生故由彼身识不因大种。或等或增差别生起。但随所依不由差别。身触为缘而得生起。二欲不然。如所造色。要因大种增盛而生。既随大种差别而生。何缘所遮令非造色。风火若盛二欲便增。风火若微二欲便减。既随大种增微不同。二欲何缘非造色性。若言二欲虽因大种。而不依彼故非造色。谓欲依心不依大种。故不应难令成造色。若尔此欲应不要因大种增盛方得生起。不见不依大种身识。随诸大种差别而生唯见身识大种为缘。若等若增。但触便起。二欲若尔。应一切时不待增盛。有因便起。则前所说。应一切时生二欲难坚住难遣。又风火界有时虽增。而不现起食饮二欲。故知二欲因现不生。彼因尔时何缘不起。由所依身有过患故。或为余缘所障碍故。岂不即由此故二欲不生。何须复别计有欲因造触。此不应然。欲与身识俱时起故。虽有障碍而识得生。欲不得生。此有何理。心所法生。必定系属依缘识合。彼三具有。又彼希求大法地摄。故与一切心品俱生。生欲胜因。尔时具有而不生者。必为所余生缘阙故。所余缘者。谓所造触。故离大种实有饥渴。造色为性。又不应言造触生障即障心心所。勿心等生障即障造触。无异因故。且止广诤。必应信有饥渴二体造触为性。今应思择。若诸大种色聚中增。为体为用。何缘复劝如是思择。为欲蠲除不实过故。经主自论有处说言。此是彼宗所有过失。彼宗谓彼毗婆沙师。言诸聚中一切大种。体虽等有而或有聚。作用偏增。如心心所。又如所觉团中盐味。未审此中经主意趣。定谓谁是毗婆沙师。若谓善释阿毗达磨诸大论师。彼无此说。彼说大种由体故增。石水焰风。诸色聚内。坚湿暖动体相偏增。一一聚中各了一故。若诸聚内大种体均。不应此中各唯了一。又随世想立地等名。应全无因。空有言说。以诸色聚形显皆同。若执坚等体均无异。因何得生地等别想。若谓因用。理必不然。用与自体无差别故。用若是实即体增成。实即体故。用若非实亦体增成。不异体故。无非实用异体有增。由此即释彼心心所团中盐喻。谓盐受等。用即体故。即体用增。总说如是。然有差别。谓诸大种有对碍故。可积集故。方处差别。分明可了。受等无对。不可积集。但由用别。了增微异。是故大种。体可积集。就体说增。心心所法。就用差别。说增微异。岂不色法亦见用增。如酢和水。良药和毒。盐和水等。虽两数同。而用有异。如何言色就体说增。此不相违。以酢与水触微虽等而味不同。酢味微多。水味微少。故酢味胜。还由体增。于诸聚中有味等物。体增强故。谓是用增。良药毒等。缘起理门有差别故。体类如是。由此虽少而能伏多。非异体类有别用生。故执用增。是为邪计。或如类别。品别亦尔。故唯心等。就用说增。就体说增。谓诸色法。譬如依多依一成故。又诸大种就体说增。现可得故。教故。理故。谓大种增即体可得。非用非业。有集碍故。教者谓如种喻经说。若有地界。无水界者。应不聚集。无能摄故。如是一一广说如经。此经意言。非有色聚全无水界。若全无者。应不和合。然有不能摄余色聚令和合者。以其少故。自余诸界。准释应知。理谓大种若但用增。非体聚积。而说增者。应有大种。或所造色一极微上亦有用增。如于受等一法体上。有时用增独能为境。何缘极微一一别住。不能为境生五识身。又诸极微用增强者。其相粗着。应非极微。故诸色法。由可积聚体有对碍。就体说增。诸无色法不可积聚。体无对碍。就用说增。此义既成。不可倾动。而经主说。毗婆沙师。言诸聚中一切大种体虽等有。而或有聚用偏增者。此未识宗。故作是说。又今应说。坚等何因是色所依。非余色等。以此遍满一切处故。谓诸聚中地等四相。皆遍具有。色等不然。由此地等三义成立。一所依义。二能生义。三广大义。又是色等所随逐故。现见世间。瓶盆等物。由火成熟。便有色等转变可得。扣击弹抚有差别故。声转变生。余色等中无如是事。是故坚等。色等所随。是色所依。非余色等。又能损坏余色物故。色等依地无能坏用。若尔久观雪等盛色。根不应坏。不尔彼色所依能坏根所依故。以于闇中觉彼生苦。故知唯坏大种非根。若坏于根不应觉彼发生身识。又色不能损坏大种。非所触故。是故大种。独能损坏余色物故。是色所依。非余色等。有说。坚等所触性故。能为所依。此说非理。冷等应成大种性故。然冷等触。非遍满故。不成大种。岂不暖中无有冷触。于冷触中亦无有暖。暖应如冷。亦非大种。此难不然。冷有暖故。由被冷覆而不可知。若尔冷触应同暖遍。不尔冷用暖中无故。以于冷中暖用可得。非于暖中冷用可得。冷同暖遍。此难应止。暖用者何。谓能成熟。岂不见冷亦能成熟。如有暖故物不烂坏。不烂坏因名能成熟。冷亦如是。应与暖同。此亦不然。水风界盛。暂时凝结。此中成熟。即暖用故。是故不应说言坚等所触性故能为所依。冷等应成大种性故。然彼冷触。水风界增。四大果故。是所造色。又彼冷触。持摄熟长。四决定用不可得故。体非大种。岂不由冷雪等凝结有胜用耶。此言非理。水风界盛。如造冷触。生彼果故。亦由暖故。甘蔗汁等。凝结可得。若言冷是大种果者冷暖相违。不应和合。如何从暖生于冷耶。如坚与湿同一事故。互不相违。水火亦然。既同一事。理无相反。如以冷水浇灌石灰。从冷生热。此亦应尔。以诸大种同一事故。虽性相违而恒和合。冷是水风近所生果。地界与彼都不相违。火性虽违而不为损。同一果故。何妨和合。又若见彼诸界增故。于诸聚中立异大种。即彼诸界。是能生长诸造色因。名为大种。非冷增故。于诸聚中立异大种。故非大种。然暖增故。于诸聚中异大想灭异大想生。冷即不尔。是故冷暖。能依所依。二性差别。岂不现见由冷增故水界凝结。世间于此亦立种种冰雪雹名。此难如前水风界盛如造冷触生彼果释。或冰雪雹即水异名。非草木等异名称火。故彼所难理定不齐。是故冷触唯所造性。由斯触界有二义成。余九色界。唯是所造。谓五色根色声香味。法界一分。亦唯所造。此复云何。谓无表业。依大种生。故名所造。然声为显定无一界唯大种性。余七心界。法界一分。除无表色。俱非二种。义准已成。譬喻论师。作如是说。诸所造色非异大种。所以者何。契经说故。如说。云何名内地界。谓于眼肉团中若内各别坚性坚类邻近执受。乃至广说。若异大种别有诸根。不应于根说大种性。又余经说。苾刍当知。诸有士夫皆即六界。既定说六。为假有情所依实事。故知眼等色等造色。非异大种。若所造色异诸大种。有何意趣。此经不说。彼言非理。不了契经深意趣故。前所引经。顺世名想。故作是说。谓诸世间。眼肉团中。起眼名想。此眼名想。依眼所依大种等起。眼肉团者。总说一切。不离眼根大种所造。若不尔者。此经唯应说谓于眼内各别等。坚性等言。已遮慧眼。应不须说肉团中言。又于眼言是因第七。肉团中言是依第七。由此表知。总摄一切因眼所起。不离眼根大种所造。是因于眼所起肉团。其中所有内各别等。名内地界。此则显示眼等生因依因等地。由此重说二第七言。总摄一切眼及肉团所依大种。后所引经。唯说六界。不言余者。有别意趣。谓续生时眼等无故。虽于此位亦有身根。而犹未能觉冷等触。若法有体。未起作用。不应立在有用品中。又唯六界。是诸有情有用本事。从续生心至命终心。常有用故。住灭定者。识有何用。彼过去识。能作未来等无间缘。由此当果决定现起。是彼识用。若尔身根亦应有用。同类因用未尝无故。此难不然。非定成就与定成就。有差别故。谓有身根。虽不成就。而有与果。同类因用。定无彼识。体不成就。能作当果等无间缘。故识与身。义非均等。又身根用。非同类因。为识生依。是身根用入灭定者。决定当出后识生依。是前识用。故唯六界。是诸有情有用本事。理极成立。或举空界。表诸造色。故引此经非遮所造。空界实有是所造色。前已成故。又执造色不异大种。则应色等皆同一相。谓坚等相。若尔眼等五根所行。应无差别。是则违经所说。眼等所行各异。如何所执色等境界皆同一相。谓坚等相。然非一切境一切根所行。此不能令智者心喜若言如说色等五境虽同一相谓造色相。而无此失。如是大种与所造色。虽同一相谓坚等相。而无失者。此亦不然。非许造色性有别法体故。又眼等根。于色等境。取定别相。非定总故。所以者何此宗不许所造色性如坚等相有别法体。故不可谓如说色等。虽同所造一法自性。而眼根等境别义成。如是色等虽同坚等一法自相。而眼等根境别义立又眼等根于色等境。取定别相。非定总相。勿眼等根与色等境总相同故。亦是眼等五根所取。成大过失。又受等法与色等境。亦同一相所谓行相。受等亦应眼等所取。是故决定。应许色等有不共相种类差别。由此眼等。虽一一根能取多相。而无五根境杂乱失。种类别故若谓如彼眼等五根。虽同一相谓澄净相。而能各各别取境界。如是色等。虽同一相谓坚等相而是眼等各别所行。此亦不然。余法亦有澄净相故。若澄净相。是眼等根差别相者。是则不应许。所余法亦有此相。然澄净相。亦许信有。是故澄净。于眼等根。非差别相。然坚湿等。是差别相。若执色等此相皆同。而言眼根唯取色处。非触处者。无别因证。或复眼等。虽净相同。而功能异。故别取境。功能异者。由因别故。眼等虽同四大种果。而诸大种增减不同。因既不同果功能异。由斯取境差别义成。又不应言色等差别亦由大种增减不同。若尔极微有不成过。故汝此救。理定不然。又彼具寿云何安立境有境异。谓若有人。自触身分。既执身触。皆同一相。一刹那中。互无差别。立谁为境。谁为有境。若有差别性别义成。谓坚等相。所触名境。与此相违身名有境。许身触性有差别故。若无差别。则无安立境有境异。便违理教。若言如意虽同一相而一刹那立境有境不相违者。理亦不然。意虽为境。而一切时立为有境。故无斯过。然身根境坚等大种。未尝有时立为有境。故彼例救。理极不齐。许身根境坚等大种亦是有境。复有何失。如意唯应立为一处。是则应无决定安立。此为身处。此为触处。应说此中有何定理。判此唯境此唯有境。故彼所宗。杂乱难辩又若色等即诸大种。彼说一一青色极微。即四大种。或唯是一。二俱有过。然色处等。虽色名同。而有青雄香甘冷等性相差别。由此五境展转不同。眼等五根无共境过。若诸大种。性相各别。与青极微体无异者。岂不一故。四性不成。若青极微。唯一大种。即四大种。应互相离。一聚唯有一大种故。是则违害种喻等经。不应别异性相大种成无差别。一青色聚。若言随一增故尔者。应说何界增故为青。若谓地界。陂池河海应无青色。若谓水界。玉青石等应不极青。若谓火界。世间盛火不应极赤。若谓风界。风中不应色不可得。若说青色异诸大种。实有一体。随一界增。多四大种。各生青色合成一聚。于理无违。故异大种。有所造色。复有至教。分明证成。如契经言。诸所有色。皆四大种。及四大种所造摄故。复有何理。知所造言异诸大种。别有所目。然契经说。有诸愚夫。由六触处。诸所触对。觉乐觉苦。或有随一。由彼所造。不可由斯所造言故。别有第七触处可得。此非定证。有于异体亦说如是所造言故。如告具寿阿难陀言。所造我见。谁之所造。谓色所造。乃至广说。若见余处。有所造言。无别所目。谓此亦尔。应有身见以色为体。便有乖违自所宗过。又不应以余所造言所目法体。或异不异。便疑此经说大种所造言。有余契经定证异故。如契经说。苾刍当知。眼谓内处四大种所造净色。有色无见有对。乃至身处。广说亦尔。苾刍当知。色谓外处四大种所造。有色有见有对。声谓外处四大种所造。有色无见有对。香味二处。广说亦尔。触谓外处是四大种及四大种所造。有色无见有对。此中分明显诸大种唯是触处一分所摄。余有色处。皆非大种。故定知此及所造言。如我见经所造我见别有所目。定非如彼六触处经。随一所造无别所目。是故九色。法界一分。异四大种所造义成。如是已说大种性等。十八界中。五根五境十有色界。是可积集。以是极微体可聚故。义准余八。非可积集。体非极微。不可聚故。如是已说可积集等。十八界中。几能斫几。所斫几能烧几。所烧几能称几。所称如是六门今应。总答颂曰

  谓唯外四界　　能斫及所斫
  亦所烧能称　　能烧所称诤

论曰。色香味触成斧薪等。此即名为能斫所斫。唯者定义。意显斫等决定是外四界非余。及言为显能斫所斫俱通四界。岂不有为刹那性故都无能斫所斫义耶。理虽如是。而诸色聚相逼续生。异缘分隔。令各续起。是故非无能斫所斫。此所斫义。身根等无。非诸色根异缘分隔可令成二各相续起。支分离身。则无根故。又身根等。亦非能斫。净妙相故。如珠宝光。此等义言。唯言所显。如能斫所斫体唯外四界。所烧能称。其体亦尔。谓唯外四界名所烧能称。身等色根。净妙相故。亦非二事。如珠宝光。声非色等相续俱转。有间断故。六义皆无。能烧所称。有异诤论。谓或有说。能烧所称。体亦如前。唯外四界。或复有说。唯有火界可名能烧。所称唯重。如是已说能所斫等。十八界中。几异熟生几所长养。几等流性。几有实事。几一刹那。如是五问今应总答。颂曰

  内五有熟养　　声无异熟生
  八无碍等流　　亦异熟生性
  余三实唯法　　刹那唯后三

论曰。内五谓眼耳鼻舌身。有异熟生及所长养。遮等流性。是故不说。岂不前生眼等五界应言与后生及未生眼等诸根为因决定。如是眼等。应有等流。同类因生。等流果故。何缘乃说遮等流性。不说眼等全无等流。但即长养异熟生性。无别等流。故应遮止如异长养有异熟生。异异熟生有所长养。非异此二有别等流。为辩异门废总论别离因而熟。故名异熟。异熟体生。名异熟生。或是异熟因所生故。名异熟生。略去中言。故作是说。譬如牛车。或所造业。至得果时。变而能熟。故名异熟。果从彼生。名异熟生。或于因上。假立果名。如于果上假立因名。如契经说。今六触处。应知即是昔所造业。饮食资助眠睡等持胜缘所益。名所长养。饮食等缘于异熟体。唯能摄护。不能增益。别有增益。名所长养。应知此中长养相续。常能护持。异熟相续。犹如外廓。防援内城。无异熟生离所长养有所长养离异熟生。如修所得天眼天耳。既说声界无异熟生。义准非无等流长养。何缘声界非异熟生。数数间断。复还生故。异熟生色。无如是事。非随欲乐异熟果生。声随欲生。故非异熟。岂不如彼施设论言。善修远离粗恶语故。感得大士梵音声相。虽由业感。而非异熟。以声起在第三传故。谓从彼业生诸大种。从诸大种缘击发声。若尔身受因业所生大种发故。应非异熟。此难不然。非诸身受皆因大种及因业生。大种所发。亦非一切皆是异熟。然诸身受。亦因非业所生大种及非大种而得生故。谓身受起。要假身触。身识等缘。由此亦缘外大种起。非要待业所感大生。于理无违。故通异熟。若执声界是异熟生。如是声界。唯因大种。唯因异熟大种而生。不离如前所说过失。若说声界非异熟生。如是声界。唯因大种。通因异熟及非异熟大种而起。于理无违。亦无如前所说过失。故应如是分别声界。非诸身受唯因大种。是异熟者。非唯异熟大种为因。又不同彼有违理失。是故所例。理极不齐。有余师说。声非异熟。如何异熟大种所生。故应许声属第四传。或第五传。故非异熟。谓从业生异熟大种。从此传生长养大种。此复传生等流大种。长养大种发长养声。等流大种发等流声。此说非理。岂不如从无记大种发善恶声。从有执受发无执受。从身境界发耳境界。如是若从异熟大种发非异熟。有何相违。是故彼说定为非理。八无碍者。七心法界。此有等流异熟生性。若非异熟。同类遍行因所生者。名等流性。若异熟因所生起者。名异熟生。岂不此中亦有长养。谓先因力引后果生。亦令功能转明盛故。契经亦言。诸无色法。增长广大。应有长养。虽有此言。而非长养。即说等流增长广大。若先因力引后果生。令其功能转明盛者。此亦即依等流性说。同类遍行因所生故。诸有碍法。极微所成。同时积集。可名长养。诸无碍法。非极微故。无积集义。不名长养。轨范诸师咸作是说。余谓余四色香味触。皆通三种。谓异熟生。亦所长养。及等流性。实唯法者。实谓无为。以坚实故。此法界摄。故唯法界触名有实。意法意识。名为后三。于六三中。最后说故。唯此三界。有一刹那。谓初无漏苦法忍品。非等流故。名一刹那。此说正现行亦非等流者。余有为法。无非等流。唯初无漏。五蕴刹那。无同类因而得生起。余有为法。无如是事。等无间缘。势力强故。前因虽阙。而此得生。等无间缘势力强者。与初圣道品类同故。无量善法所长养故。与初圣道性相等故。为此广修诸加行故。苦法忍相应心名意界意识界。余俱起法。名为法界。复有余师。此中异说。谓一切法。皆有实事。有实相故。除无为法。皆一刹那。速谢灭故。除初无漏心及助伴。余有为法。皆是等流。十色少分。是所长养。十七少分。是异熟生。由此眼等五内色根。各有二种。谓所长养。及异熟生。虽有余三。而无别性。义杂乱故。所以不说。余皆准此。声界有二。五识亦然。意意识三色等亦尔。法界有四。除所长养。上座此中依十二处。立一切种皆异熟生。非异熟生为所长养。如所缠裹周匝护持。又一身中。眼等应有二种类故。不见别有二所作故。无别长养。又彼声处。应异熟生。以许彼因是异熟故。又异熟者。因顿引发任运随转。不须数数重起加行方得生起。又于眼等此事应同。若言声处若是异熟。处无心位应恒行者。意等云何。若言意等有相续者。此亦不然。非异熟生所间绝故。彼上座宗。略述如是。而彼所说理皆不然。且十二处。非一切种。皆异熟生善染污等。异熟生性。不成立故。若善染污。是异熟生。已断善根。及阿罗汉。如异熟意。应得现行。差别因缘。不可得故。又无漏法。是异熟生不应理故。又十二处。摄一切法。若立一切皆异熟生。则应非情亦是异熟。若是异熟。与理相违。上座所宗。不可依据。如凭巨石难以浮深。若立异熟生通一切种非一切种唯是异熟生。除异熟生。应说别相。便与对法义有相符。对法诸师。亦无定立一处一界唯异熟生。随其所应。非异熟者。立长养等诸门差别。又彼所说。非异熟生为所长养。如所缠裹周匝护持者。此非宗所许。但许身中有所长养异熟生色。长养相续常能护持。异熟相续。令不间断。岂不一切皆唯异熟势力所引。随力胜劣。故有相续。或有间断。此非佛教说一切果皆宿因造。同外道故。无同彼失。亦许现在众缘功能助引生故。若尔不应说彼一切皆唯异熟势力所引。又异熟力。一业所引。不应或时有胜有劣。不应计度一业力势。或时增胜。或时微劣。异熟势力。随业所引。不应或时有胜有劣。又于忧喜勇怯等位。种种色相差别而生。此不可为异熟生性。以非相似相续转故。此色与心。俱起俱灭。依心转故。名所长养。又现见身。增减可得。异熟不应随缘增减。若遇现缘而增益者。此所增益。非业所生。现缘生故。定非异熟。若虽有业势力所随。由阙资缘。而损减者。此所损减。非业所生。亦非异熟。由此道理。应决定知。若有增减。则非异熟。若是异熟。则无增减。由有此二。知所长养。离异熟体。别有义成。亦不应言异熟生色离极微增而有增益。离极微减而有损减。彼极微聚。系属现缘暂时体生。还即灭故。用增非体。理相违故。极微用增。过如前说。若执一切唯异熟生。即一切果皆宿因造。便同宿作外道论失。又言一身眼等应有二种类者。此无所妨。事聚种类。二差别故。谓异熟生。与所长养。事种类别。因有异故。由此眼等。无别等流。离前二因。无别因故。依聚种类。说一无失。二事成一。聚种类故。又言不见。二所作者。应见为依。发生眼识及相应法。是二所作。不应唯说异熟生眼为识生依非所长养。勿彼天眼不能为依发生眼识。成过失故。异熟生眼。离所长养。不能为依发生眼识。故生一识。是二功能。又彼应说。许一身中有二眼等总别生识。此于法性。有何伤损。但应勿如彼许二共一根。彼违圣言。谬显法性。尚无愧怯。况此顺理。正显圣言。而怀惭怖。故定应许一总身中眼等五根各二种类总别生识。于理无违。又言声处应异熟生以许彼因是异熟者。理极粗浅。则声处所因异熟大种应非异熟生。成过失故。由是不应定执此义。从异熟生者。皆名异熟生。若如是说。复有何过。声处唯应非染触摄。由彼所因性类尔故。又声不应是所造色。彼因大种非所造故。又因染等所依所缘。发生意识如是意识。应唯染等。成过失故。又一意识。一时应成善染等过。彼所依缘。一时容有善染等故。由此等过。不应执声异熟生故成异熟生。是故应知。初释为善。又言异熟因顿引发任运随转。不须数数重起加行方得生者。此不能立声是异熟生性。由此反能立声非异熟生。若执声为异熟生性。一起断已。应不更生。由异熟生一起断已无加行因能重起故。我等皆许业感异熟。不由重起加行方生。汝等何缘重述斯旨。计彼所说。无所证声异熟生用。只应为满已论文数致此浮词。又彼所执别有随界。便为无用。于业所引异熟转中。彼无用故。既许业因顿引异熟。不须数数加行重发。何须别执此随界为。或应许此引业无用。又我意说。声数间断。随欲重生。异熟生色。无如是事。汝今何故言于眼等此事应同。岂异熟色断已重起。又我难意声既是色与异熟色起法不同。应非异熟。何预意等。而汝欻责意等云何。汝自许声所因大种。是异熟故。声异熟生。若许意等亦如是者。从非异熟所生意等。则应一向非异熟生。若从异熟所生意等。亦应一向是异熟生。既不许然。如何例责。又色非色法有异故。异熟相续。亦应不同。非不生盲异熟生眼。起已断坏。终不重生。即令意等异熟生法相续间绝。亦不重起。又异熟心。为非异熟间。复异熟生时。即非异熟能为彼生因。复能断彼类。非声生因即令声断。是故异熟色与意等相续各异。不应为例。以要言之。彼于此论异熟长养等流义言。都不解了。致斯纷竞。故应且止。鉴者当知。如是已说异熟生等。今应思择。若有眼界。先不成就。今得成就。亦眼识耶。若眼识界先不成就。今得成就。亦眼界耶。如是等问。今应略答。颂曰

  眼与眼识界　　独俱得非等

论曰。独得者。谓或有眼界。先不成就今得成就。非眼识。谓生欲界。渐得眼根。及无色殁。生二三四静虑地时。或有眼识。先不成就。今得成就。非眼界。谓生二三四静虑地。眼识现起。及从彼殁生下地时。俱得者。谓或有二界。先不成就。今得成就。谓无色殁。生于欲界及梵世时。非者俱非。谓除前相。等者摄余所未说义。此复云何。谓若成就眼界亦眼识界耶。应作四句。第一句者。谓生二三四静虑地。眼识不起。第二句者。谓生欲界。未得眼根。或得已失。第三句者。谓生欲界。得眼不失。及生梵世。若生二三四静虑地。眼识现起。第四句者。谓除前相。如是眼界与色界。眼识与色界。得及成就。如理应思。由斯理路。例应思择。后五种三得与成就。并互相望及舍不成。如毗婆沙广文示现。恐词繁杂故今不述

说一切有部顺正理论卷第五阿毗达磨顺正理论卷第六

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩本事品第一之六

如是已说得成就等。十八界中。几内几外。颂曰

  内十二眼等　　色等六为外

论曰。六根六识十二名内。外谓所余色等六境。我依名内。外谓此余。我体既无。内外何有。非无净戒有净戒依。经主此中作如是释。我执依止故假说心为我。故契经说

  由善调伏我　　智者得生天

世尊余处说调伏心。如契经言

  应善调伏心　　心调能引乐

故但于心假说为我。眼等为此所依亲近。故说名内。色等为此所缘疏远。故名为外。若尔六识应不名内。未至意位。非心依故。至意位时不失六识界。未至意位亦非越意相。若异此者。意界唯应在过去世六识唯在现在未来。便违自宗许十八界皆通三世。又若未来现在六识。无意界相。设至过去意界位中。亦应不立。相于三世无改易故。此释不然。今且应说。何缘一生一住一灭及一果等心心所中。说心名内。心所为外。岂不心所依假我心。是能依性。对彼所依。极亲近故。转应名内。又非眼等与眼识等常为所依。未曾有心。不与心所为所依性。故唯心所。应名为内。或复此中有何殊理。与假我心为所依者。立之为内。不立能依。故彼所言。无深理趣。又心少分。是我执依。一切心依。皆名为内。由此不应作如是释。我执依止。故假说心为我。又少分心。贪等依故。应一切心皆成染污。或少分心。寻伺依故。一切应成有寻有伺。此既不尔。彼云何然。差别因缘不可得故。又彼何能遮心所等我执依性。以有身见缘五取蕴为境界故。是故彼释理定不然。若尔何缘说心为我。恒于自境自在行故。我谓于自境常自在行。心曾无有时不行自境。故一切心。皆名为我。非诸心所亦得我名。意为上首故。经说独行故。彼要依心能行境故。如诸心所。虽亦调伏。而但就胜说调伏心。说我亦然。唯心非所。若法与此似我之心。为不共益。彼名为内。与此相违余法名外。故诸心所无成内失。又诸心所。虽复与心一生住等。而心望心。独名为内。非心所者。同异类心。展转相望。为所依性。皆不舍故。诸心所法。异类望心。必定舍离能依性故。谓若善心。望善染污及无记心。为所依性。皆不舍离。染污无记心亦如是。若善心所望彼染污及无记心。舍能依性。染污无记望余亦尔。故心望心为所依性。无相简隔。得名为内。心所望心。为能依性。有相简隔。不得内名。又诸心所。望同类心。为能依性。或多或少。心为所依。则不如是由此内名在心非所。若尔大法应受内名。不尔心所朋类坏故。如异生中不堕法者。复有余师。依训词理以释内名。谓我于彼有增上用。故名为内。我谓自体。于所余法。有增上用。如彼大德鸠摩逻多说如是颂

  若爪指舌端　　无别增上用
  动触尝肴膳　　作用应无差

色香味触。诸色聚中。或唯身根。有增上用。如是广说。乃至眼根。心亦于余有增上用。是故十二。皆得内名。若尔受等自体差别。亦见于余有增上用。是则诸法皆应名内。上座所宗。既一切法皆法处摄。彼宗云何建立内外。彼说如余。云何如余。谓为六识作所依者。建立为内。不为六识作所依者。建立为外。夫所依者。唯有情数亲近不共色等不定。如彼色等。虽复亦有是有情数亲近不共与眼等同。非所依故。而立为外。不立为内。如是眼等虽法处摄。与受等同是所依故。而立为内。不立为外。所余法处。唯名为外。又虽眼等皆通二分。而内外性。互不相违。是故不应执此为难。谓作眼等识所依时。立为内性。若作意识所缘境时。立为外性。彼谓如意根是内处摄。为意识所缘。复外处摄。如是所说品类言词。皆率己情。不能遮过。有似比度。无真教理。所以者何。违契经故。如契经说。苾刍当知。法谓外处。是十一处所不摄法。无见无对。且于此经。非一切法皆法处摄。由此经中遮十一处摄法处故。亦非唯彼所执别法名为法处。由此经中非如意处说无色故。彼宗唯执受想思蕴。名别法处。于中无色。若此经中。依彼别法。说法处者。则应如说无见无对。亦言无色。由是理故。于此经中。再广遮遣异眼等处。谓是十一处所不摄法。及无见无对。若色唯有有见有对。更无余色。直欲宣说别法处者。应但说言。法谓外处意处不摄亦是无色。由是已成此别法处十一不摄无见无对。或复应言无见无对意处不摄亦是无色。此中不说无色言故。又遮眼等摄法处故。由此别有法处色成。此色是何。谓无表色。业俱舍中当共思择。云何令他知眼等处。虽为意境。而唯是内。故此经中。遮总数摄及差别性。以显法处。谓佛世尊观未来世。于我生处有称释子。执一切法皆是法处。为遮彼故。显了说言。法处唯此非一切法。是故唯于辨法处相。说十一处所不摄言。以眼等无展转摄义。于眼等处无如是说。意识能缘一切法故。勿一切法皆法处收。故于此中如是遮遣。又彼上座。复立眼等通内外性。定应不成。以曾无处说。彼眼等若作眼等识所依时。立为内性。若作意识所缘境时。立为外性。由此即破所引意根。以如眼等曾无说故。如何自号善释难师。而绝未知立同喻法。既能如此何远举意。为成眼根通内外性。只应近举耳为同法。为成耳根通内外性。亦应近举眼为同法。彼上座言。所立眼等通内外性。决定应成。如世尊说。苾刍当知。诸所有眼或过去或未来或现在。或内或外。乃至广说。意亦如是。若尔便有太过之失。如契经说。于内身中住循身观。乃至广说。又如经言。诸所有色。若过去若未来若现在。若内若外。乃至广说。于色等中。既无内性。经不应说。诸所有言。受想行中。如何有内。又先自说。若为六识作所依者。建立为内。既许如是。色等受等。非识所依。应唯名外。经何说内。如色受等。虽说内言。而非内处。唯外处摄。如是眼等。虽说外言。而非法处。唯内处摄。若尔经言有何意趣。此经意趣。当共思求。汝上所言。且不应理。我今当释。此经意趣。谓彼眼等为识所依。说名为内。色等所缘说名为外。彼此无诤。又如眼根识所依止。已正当生说名为内。与此相违。说名为外。乃至意根。内外亦尔。若色等境。与识所依。同一身转。说名为内。与此相违。说名为外。如是就处就所依身。建立内外。不违圣教。随顺法相。是故上座所立眼等。通内外性。定为不成非但不成。相又杂乱。以执眼等作识依缘为内外性。相杂乱故。谓若意识缘所依意为境起时。此意当言置在何聚。不应在内意识所缘故。不应在外意识所依故。不应在内外。非经所说故。曾无经说。如是意根。或内或外。或通内外。岂不说有内外心耶。此就依身说为内外。若异此释。应于受等内性不成。又应于心不具三观。于唯外心住循心观。无容有故。彼如是执。心为意识作所缘时。说名为外。此即名内。心常为识作所依故。若许眼等意识缘时。亦唯名内。斯有何失。非彼眼等有时不为自所发识作所依性。如是上座。立内外门。违害契经。不成相乱。唯我阿毗达磨诸大论师所立。顺经成就。无杂乱失。已说内外。十八界中。几同分几彼同分。颂曰

  法同分余二　　作不作自业

论曰。法同分者。谓一法界唯是同分。今应先辨境同分相。若境与识定为所缘。且如法界。与彼意识为定所缘。是不共故。识于其中已生生法。此所缘境。说名同分。意能遍缘一切境故。于三世境及非世中。无一法界不于其中已正当生无边意识。二念意识。即能普缘一切法故。由是法界。恒名同分。余二者。谓余十七界。皆有同分及彼同分。何名同分彼同分耶。谓作自业不作自业。若作自业名为同分。不作自业名彼同分。如何眼等说为同分彼同分耶。且同分眼。说有三种。谓于色界。已正当见。彼同分眼。说有四种。谓此相违及不生法。西方诸师说有五种彼同分眼。谓不生法。复开为二。有识无识相差别故。如眼耳鼻舌身亦然。各于自境。应说自用。意界同分。说有三种。谓于所缘。已正当了。彼同分意。唯有一种。谓不生法。色界同分。说有三种。谓眼所见。已正当灭。彼同分色。说有四种。谓此相违及不生法。广说乃至触界亦尔。各对自根。应说自用。眼等六识依生不生。立二分故。如意界说。眼若于一是同分。于余一切亦同分。此若于一是彼同分。于余一切亦彼同分。广说乃至意界亦尔。色即不然。于见者是同分。于不见者是彼同分。或有诸色。在妙高等山中而住。于一切有情。皆是彼同分。有天眼者。以无用故亦不观彼。或有诸色。唯于一有情名为同分。如独于私隐已正当观。或有诸色。于百千有情名为同分。如共观月舞相扑等色。复有何缘说眼同分及彼同分异于色耶。容多有情同见一色。无用一眼二有情观。声如色说。是共境故。香味触三。如内界说。非共境故。然诸世间。依假名想。有言我等同嗅此香同尝此味同觉此触。云何同分彼同分义。分谓交涉。同有此分故名同分。云何交涉。谓根境识更相交涉。即是展转相随顺义。或复分者。是已作用更相交涉。故先说言。若作自业名为同分。或复分者。是所生触。依根境识交涉生故。同有此分故名同分。即同有用同有触义。与此相违名彼同分。由非同分与彼同分种类分同。名彼同分。云何与彼种类分同。谓此与彼同见等相。同处同界。互为因故。互相属故。互相引故。种类分同。已说同分及彼同分。十八界中。几见所断。几修所断。几非所断。颂曰

  十五唯修断　　后三界通三
  不染非六生　　色定非见断

论曰。十五界者。谓十色界及五识界。唯修断者。此十五界唯修所断。后三界者。意界法界及意识界。于六三中最后说故。通三者。谓此后三界各通三种。此中八十八随眠。及彼相应心心所法。并彼诸得若彼生等。诸俱有法。皆见所断所余有漏。皆修所断。一切无漏。皆非所断。此中有说。最初圣道。刹那生时。诸异生性。一切皆得永不成就。是故此性。亦见所断经说。预流得不堕法。非不永断。能招恶趣身语意业。得尽恶趣。名不堕法。又说。我已尽那落迦。乃至广说。尽是断义。如阿罗汉。自记别言。我生已尽。是故染污能招恶趣身语业等。亦见所断。皆与见道极相违故。为遮此说。复言不染。非六生色。定非见断。其异生性。是不染污。无记性摄。此若染污。欲界异生。离欲贪已。应非异生。此成就得。依属生身。是故不应生余界地成余界地诸异生性。此若是善断善根者。应非异生。故不染污无记性摄。既不染污非见所断。若见所断应忍所断。若忍所断。忍正起时。犹应成就则应圣者亦是异生。又不染法。定非见断。缘彼烦恼。究竟断时。方名断故。又非六生。亦非见断。六谓意处。异此而生。名非六生。是从眼等五根生义。即五识等。缘色等境。外门转故。非见所断。又诸色法。若染不染。亦非见断。如不染法。缘彼烦恼。究竟断时。方名断故。断义云何。略有二种。一离缚断二离境断。离缚断者。如契经言。于无内眼结如实了知我无内眼结。离境断者。如契经言。汝等苾刍。若能于眼断欲贪者。是则名为眼得永断。阿毗达磨诸大论师。依彼次第。立二种断。一自性断。二所缘断。若法是结及一果等。对治生时。于彼得断。名自性断。由彼断故于所缘事。便得离系。不必于中得不成就。名所缘断。此中一切。若有漏色。若不染污。有漏无色。及彼诸得生等法上。有见所断及修所断。诸结所系。如是诸结。渐次断时。于一一品各别体上。起离系得时彼诸结及一果等。皆名已断。彼有漏色。及不染污。有漏无色。并彼诸得生等法上。诸离系得。尔时未起。未名为断。由彼诸法唯随彼地最后无间道所断故。非诸见道。能随地别次第离染。云何能断彼色等法。见圣谛者。诸恶趣法。众缘阙故。已得不生。缘彼烦恼未断尽故。犹未名断。若法未断已得不生。或不成就。此与已断有何差别。断据治道。令得离系。非谓不生。或不成就。且非不生。故名为断。以不定故所以者何。或有已断。而犹得生。如彼身中异熟果等。随其所应。或有已断。亦得不生如身见等。或有未断。已得不生。如未离染圣者身中。无有爱等一切过去及未来世诸不生法。若诸无为。已得忍者。邪见等法。如是一切。或有未断而亦得生。如所余法。随其所应。亦非不成。故名为断。亦不定故。所以者何。或有已断。而犹成就。如彼身中不染污法。随其所应。诸染污法。彼若断已。定不成就。或染污法。彼虽未断。而不成就。如未离欲者得暖随转戒诸犯戒恶舍而未断。最后无间道所断故。非身语业九品渐断。诸染污者。过亦少故。如是等类。或有未断而亦成就。如所余法。随其所应。有余师说。招恶趣等身语二业。非见所断。亲等起故。非见所断。有余于此说过难言。现见余品亲所起业。余品道生。方能永断。是故彼说。定不应理。此难不然。应审思故。亦见此品亲等起业。此品道生。即能永断。何不引此而证彼义。若见所断。应彼亲起。然不应以彼为定品。夫定品者。由非遍惑力所隔别。是故品别。虽有十三。而说五门。以为定品。由是证知。身语二业。若此品亲起即此品俱断此业。既非见所断惑亲等起故。非见所断。是故彼说非不应理。而契经言。诸邪见者。所起身业语业意业。皆是邪者。此不相违。经但说言。诸邪见者所起三业。不言邪见所起三业。或由邪见。起修所断。贪等烦恼。为因等起。发起此业。故作是说。然修所断。贪等烦恼。能为近因刹那等起。发起此业。故说有漏身语二业。唯修所断。又契经中说预流者言。我已尽那落迦等。此说于彼得非择灭。永不更生。故名为尽。此中有难。若未来法。永不更生。说名尽者。此不生法。其相如何。应如过去名不灭法。然于彼时。全未有体。如何可说彼是生法或不生法。彼应思择。法于未来。为有为无。可作是难。又彼应诘世尊所言。如说未生恶不善法遮令不生。又言。此灭余更不续。复说遮止名断诸漏。于此等言。亦应难诘。然于彼时。全未有体。如何可说不生不续及与遮止。或此相违。是故所说永不更生。故名为尽。非不应理。又如断言。义有差别。尽言亦尔。不可例同。如契经说。能断财蕴。或少或多。又言。能断杀生等事。此亦应然。不可为例。又经虽说见谛圆满补特伽罗。终不故思断众生命。乃至广说。此亦不能证成色业是见所断。由此经中说阿罗汉同此言故。然此经中。以初学者定无重恶意乐随逐。故作是说。诸阿罗汉。断彼近因。种类斯尽。故作是说。是故诸经。非证彼义。由此不染非六生色定非见断。其理极成。如是已说见所断等。十八界中。几是见。几非见。颂曰

  眼法界一分　　八种说名见
  五识俱生慧　　非见不度故
  眼见色同分　　非彼能依识
  传说不能观　　被障诸色故

论曰。眼全是见。法界一分八种是见。余皆非见。何等为八。谓身见等。五染污见。世间正见。有学正见。无学正见。于法界中。此八是见。所余非见。一切法中。唯有二法。是见自体。有色法中。唯眼是见。无色法中。行相明利。推度境界。内门转慧。是见非余。此中眼相。如前已说。世间共了。观照色故。闇相违故。用明利故。说眼名见。五染污见。随眠品中当辩其相。世间正见。谓意识相应善有漏胜慧。有学正见。谓有学身中一切无漏慧。无学正见。谓无学身中决定无漏慧。一正见言具摄三种。别开三者。为显异生学无学地三见别故。又显渐次修习生故。譬如夜分无月等明云雾晦冥而游险阻。所见色像无非颠倒。五染污见。观法亦尔。譬如夜分有月等明除诸晦冥而游险阻。所见色像少分明净。世间正见。观法亦尔。譬如昼分云翳上升掩蔽日轮而游平坦。所见色像渐增明净。有学正见。观法亦尔。譬如昼分烈日舒光雰雾廓清而游平坦。所见色像最极明净。无学正见。观法亦尔。如如行者渐习慧生。除自心中愚闇差别。如是如是。于诸所缘。正见渐增明净有异。非所缘境。有净不净。由自觉慧垢障有无。故谓所缘有净不净。如是诸见。总类有五。一无记类。二染污类。三善有漏类。四有学类。五无学类。无记类中。眼根是见。耳等诸根。一切无覆无记慧等。悉皆非见。染污类中。五见是见。余染污慧。悉皆非见。谓贪嗔慢不共无明疑俱生慧。余染污法。亦皆非见。有学类中。无慧非见。但余非见。无学类中。尽无生智及余非见。余无学慧一切是见。善有漏类中。唯意识相应善慧是见。余皆非见有余师说。意识相应善有漏慧。亦有非见。谓五识身所引发慧。发有表慧。命终时慧。又于此善有漏类中。五识俱生慧亦非见。何缘如是所遮诸慧。皆非见耶。不决度故。唯有如前所说慧相。是见自体。谓无色中。行相明利。推度境界。内门转慧。是见非余。唯此相慧。有决度能。于所缘境。审虑转故。非所遮慧能于所缘审虑决度。是故非见。言决度者。谓于境界。审虑为先。决择究竟。若尔眼根既无此相应不名见。岂不先说。世间共了观照色故。闇相违故。用明利故眼亦名见。契经亦言。眼见诸色。若眼见者。何不同时得一切境。无斯过失。许少分眼能见色故。少分者何。谓同分眼。同分眼相。如前已说。识所住持。乃成同分。非一切根同时自识各所住持。故无斯咎。若尔即应彼能依识是见非眼。要眼识生方能见故。不尔眼识力所住持。胜用生故。如依薪力胜用火生。若见色用是识生法。此见色用离眼应生。由识长益俱生大种。令起胜根。能见众色。故不应说能依识见。谁有智者。当作是言。诸有因缘能生了别。如是了别。即彼因缘。识是见因。故非见体。何缘定知眼识非见。理教无故。言理无者。与耳等识无差别故。眼识与彼耳等诸识。有何差别。而独名见。故不应言识为见体。若谓所依根差别故异余识者。理不应然。识由所依有差别故。但可想转得眼识名。不应所依有差别故。法性改易。转成见体。如依草木牛粪糠火。名虽改易。而暖性同。诸识相望。性类无别。言唯依眼识见非余。此说随情不依正理。若此缘色故成见者。缘色意识亦应成见。唯缘现色故成见者。理亦不然。无异因故。缘三世境慧是见极成。缘去来色识。亦应成见。有去来识缘现色境。应许众盲成现色见。若言意识非见体者。眼识亦应许体非见。非于一类少是见体少非见体。理不相违。如何一类。少分是善少分非善。此亦应然。不应为例。体义别故。眼等诸识。体类虽同。而有善等义类差别。如火体义。了别境相识体类中。有净非净义类差别。名善非善。不可义类有差别故。即令体类亦有差别。如火虽有猛盛微劣。有烟无烟。待缘不同。义类差别。而其体类同无分别。暖为自性。如是诸识了别境相。体类虽同。而有善等义类差别。故所引例。不成救义。若谓诸识体类虽同而有见等义类别者。其理不然现是诸法体类别相。不应执为义类别故。非如善等遍通一切识等法故。如是且说无有因缘。眼识成见以辩理无。言教无者。谓无至教说眼识见令闻生解。处处经中。说眼及慧。名见可得。又说。眼识是见非眼。世间相违。世间但说无眼名盲。非无眼识。谓盲但由不成就眼。不由眼识成与不成。非生第二静虑以上。于彼眼识不现前时有眼无识可名盲者。又诸盲者。虽阙眼根。而成眼识。应不名盲。亦复不应名无见者。若言见识不现前故。虽复成就。而说为盲。是则世间。诸有目者。识不起位应亦名盲。又若眼识有能别相。令别余识得名见者。此能别相。即应是见。若此眼识。无能别相令别余识。而言眼识是见非余。应如恶王所颁教令。岂不如慧此亦尔耶。譬如诸慧择法为相有时是见。亦是简择。有时非见。唯是简择。如是诸识了境为相。有时是见。亦是了别。有时非见。唯是了别。由此即释彼有难言。若识能见。谁复了别。许见与识无差别故。如是引例。理极不齐。由能别相令慧名见。此能别相。即是能见。非能别相令识名见。此能别相。即能见故。若能别相。即是见者。即所依眼。能见义成。识但由所依唯名有别故。或应说此定能别相。除所依根更有何法。唯眼识有耳等识无。又彼所言。如见与慧。见识亦尔。许无别者。亦应许识体即是慧。共许相应中见其体唯是慧故。又若见识无差别者。诸识应即见。见应即诸识。盲睡眠等。何缘不见。若谓尔时无眼识者。此亦不然。体类同故。此与余识体类何殊。余无见能。此独能见。如斯等救。前已广遮。或复一法应有二体。一体能识。一体能见。若非见体许能见者。即汝所宗。有太过失。若谓如慧能见能择理不相违此亦然者。不尔见慧无差别故。岂不见识亦无差别。若尔有目应不异盲。何缘无目。成就眼识。得说为盲。而彼有目余识现前不名盲者。如此等过。前已广论。是故定知眼识非见。复有余师。以别道理。成立眼识定非是见。谓不能观被障色故。然经主意。不忍彼因。故于颂中。摽传说语。谓彼传说。现见壁等所障诸色。则不能观。若识见者。识无对故。壁等不碍应见障色。便诘答言。于彼障色。眼识不生。识既不生。如何当见。此诘非理。眼识于彼。设许得生。亦不能见。前说余识无差别故。是故所言。于被障色。眼识不生。识既不生。如何见者。此不成答。又不应说于被障色眼识不生。理不成故。以难意言。若执眼识有见色用。识无对故。于被障色。应亦得生。若谓如识了别色用于被障色不得生者。理亦不然。此许眼识与有对眼一境转故。若言我说亦同此者。汝不应然。不许眼见色为眼境理不成故。又何故说。识既不生。如何当见。生即是见。见即是生。若说识既不生如何当见。即说识既不生如何当生。或说识既不见如何当见。岂不于此应总难言。何故不生。何故不见。又若有执。一切因缘。皆唯前生。无俱起者。识生不生。皆不能见。依彼所宗。此亦非答。又于琉璃云母等障。眼识亦起。何故说言。于被障色。眼识不生。若谓于中光明无隔故得生者。且许眼识于被障色生义得成。即汝前言。违自所许。又世现见。虽离光明而眼识起。如人能见诸黑闇色。夜行禽兽。亦见黑闇所障诸色。非欲观闇待光明故。若言境界法应尔者。夜行禽兽。应如人等。于闇所障识亦不生。不可说言一黑闇色对人对畜其性变异。若言诸趣法应尔者。不尔诸趣是异熟故。猫狸犬等。于黑闇中。起染污心。取诸色故。唯异熟眼趣体所摄。故可于中作如是计。异熟法尔。于诸趣中。或有能取闇所障色。若谓夜行禽兽等眼常带光明故能见者。理亦不然。不可得故。若言少故不可得者。于远境色。照用应无。眼识于中不应得起。是故所说。于被障色。眼识不生。识既不生。如何见者。非如理答。唯未鉴人之所爱乐。若尔眼根能见论者。何缘不取被障诸色。眼有对故。于被障色。无见功能。识与所依一境转故。亦不得起。经主于此。复征难言。眼岂如身根境合方取。而言有对故不见彼耶。此难不然。不了所说有对义故。所以者何。此不唯说眼是障碍有对法故。唯取合境非不合境。故不能取被障诸色。此中亦依境界有对。义意说言。若于此境有被拘碍。彼于余境设无障者。亦不起用。况于有障。一切有境法应如是。不能俱时取诸境界。若尔眼识亦是有对。不应但言眼有对故于被障色无见功能。亦不应言识与所依一境转故。可言于彼眼识不生。由自说言一切有境法应尔故。此例不然。不闲意故。我义意说。眼亦境界有对性故。色是障碍有对性故。于被障色。眼用不生。意与意识。虽有所依。能依决定。而无一境。作用决定。非此二种能于一时取一境界。所依眼根所取境界。即是能依眼识所取。又必同时。是故于彼被障境界。如遮眼用识用亦尔。由是故说。识与所依一境转故。可言于彼眼识不生。许识见者。何缘不起。岂不眼是境界有对。被琉璃等境拘碍时。于彼所障亦能起用。何故说言。若于此境。有被拘碍。彼于余境。设无障者。亦不起用。况于有障。岂不前说。不俱时取。取琉璃时。不取所障。取所障时。不取琉璃。以非俱取。无相违过。若尔何缘。眼不能取壁等障色。我不同汝言于是中。光明无故。所以者何。世间现见。虽离光明。而能取故。既谓不同。何缘不取。诸积聚色。障碍性故。譬如明闇为障不同。如闇与明虽同色处而闇所障人不能取。明所障色人则能取。夜行禽兽。虽亦能取闇所障色。而不能取壁等所障。如是虽能取琉璃等所障诸色。而不能取壁等所障。由此眼根唯见壁等。不见壁等所障诸色。有积聚色障碍性故。法应如是。不可推征。有根虽能取不合境。由少碍故。而不能取余不合境。有根虽能取于合境。而有合境不能取故。经主所言。眼岂如身根境合方取。而由有对故不见彼者。此应责言。若根能取不合境者。则应能取一切不合。若取合境。则一切合。皆应能取。若不尔者。言成无用。是故所言。眼有对故。于被障色。无见功能。识与所依。一境转故。可言于彼眼识不生。许识见者。何缘不起。如是立破。理极成就

说一切有部顺正理论卷第六阿毗达磨顺正理论卷第七

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩本事品第一之七

眼若是见。何故世尊。说以为门。不言能见。如契经说。梵志当知。以眼为门。唯为见色。理不应说见即是门。但可说言。依门得见。非此契经定能证彼眼识是见。不说眼识以眼为门。唯见色故。有余师执。以眼为门。慧见色故。应除固执共审思求此经意趣。我宗所释。以诸愚夫无明所盲无真导者。或执自性极微等因。或执无因而生诸行。或谓诸行若刹那灭。一切世间。应俱坏断。由此妄想计度诸行。或暂时住。或毕竟常。是故世尊。为显诸行因果展转。无始时来。虽刹那灭。而不坏断。非一切果从一因生。亦非无因而生诸行。密意为说。如是契经。以眼为门。唯为见色。广说乃至。以意为门。唯为了法。门是缘义。缘有二种。谓种类同。及种类异。此中且说种类同缘。以眼为门。为见色者。谓后眼起。前眼为缘。为见色言。显起有用。如是乃至意处应知。又此契经。为显眼等各有二用。一能为门。二能取境。能为门者。且如眼根。能为所依。令心心所各别行相于境而转。能取境者。且如眼根。唯为见色。若异此者。唯义相违。诸心心所。唯应见故。然心心所。皆眼为门。汝执见体。唯心非所。又受想等诸心所法。领纳取像造作等用。各各不同。不应唯见。既言唯见。明知是眼。由此眼根唯能见故。如是眼用。略有二种。一能为门。二能见色。乃至意处。如理当知。故我所宗无违经失。又此契经。更有别义。谓见方便。假说为门。世于方便。说门言故。如世间说。我依此门。必当获得如意财宝。即是我依此方便义。世尊亦告手居士言。当依此门如法摄众。谓四摄事。为摄方便。此说眼识为见方便。眼由识持。能见色故。识是眼根。见方便故。见依止故。假说名眼。此意说言。识为方便。眼能见色。如余经中。了别色位。以眼是识所依性故。邻近缘故。于眼根体。假说识名。故契经言。眼所识色。此中亦尔。观照色位。以识是眼邻近缘故所依止故。于眼识体。假说眼名。无违经失。为舍外道我任持根令能取境颠倒执故。如是假说。令彼梵志了识持根能取自境非我持故。若尔应说眼识为门唯为见色。不应说识勿彼外道执我能见。谓所执我以识名说。世闻多执识为我故。若说为眼。即知眼识眼为所依。定非是我。我体常住。定无所依。闻说有依。我想便息。又避余过不应说识。谓经当说。以意为门。唯为了法。若说识者。即定应说意识为门。若作是说。便不应理。以即意识能了诸法。非余意了识为方便。岂不说意。亦有斯过。谓如说眼为门。即知是眼识为见方便。如是说意为门。亦知是意识为了方便。虽复说意。而无斯过。由闻意名。唯作意解。非谓意识。所以者何。眼根有用识俱生故。眼识与眼作见方便。故于此识可说眼名。意根无用。以过去故。意识与意不作方便故于意识。不说名意。意为意识了法方便。要依意根能了法故。由是若说以眼为门。智者应知。为舍我执说识为眼。若至第六说意为门。智者应知。意即是意无了用故。意为方便意识能了。又此经说。有二种眼。谓彼同分。及同分眼。虽彼同分不能见色。而能为门引同分眼。令生见色。于一生中。必先获得彼同分眼。然后引生同分眼故。如眼乃至身亦如是。意有二种。一者无用。二者有用。虽无用意不能了法。而能为门引有用意。令生了法。意识即意故。意即意识故。说意能了。无有过失。如是等义。辩释此经。是故不应引为定证。遮见是眼成见是识。又经主言。然经说眼能见色者。是见所依故说能见。何缘经主起此执耶。由彼经言。意能识法。非意能识。以过去故。意是识依。故说能识。眼亦尔者。此不成证。意与意识。种类一故。以意识相即是意故。说意能识。于相无违。如契经言。由意暴恶所作所说无非不善。不应说言由过去意。能起如是身语二业。此由现在意暴恶故。发起不善身语二业。又契经言

  欲生漏不起　　由意无染浊

非无浊意定能发生无浊意识。故不应谓由所依说。又契经说。心导世间。此岂于心说心所事。是故不可引彼契说证眼见言说能依识。又此经说眼见色言。不可执为眼识能见。无处定说识能见故。处处有说。眼能见故。前说余师执慧见故。然此经说。意识法言。可就所依说识无过。有处定说识能识故。无处定说意能识故。于此义中。无异执故。又经主说。或就所依说能依业。如世间说床座言声。经主何因。起斯定执。余言余解。不可无因。若谓有因所依眼力识见色故。此不成因。识见色因。非极成故。我等宗说。识能住持所依眼根令能见色。故言识见因不极成。又无余经定说识见。岂不如说床座言声。此说可然。以极成故。言声床座。异处极成。故闻此言知能依业就所依说。如有实论世间共许。于余假说。非有识见。彼此极成。是故不应起如是执。若尔眼见亦不极成。何故但言识持眼见。不说依眼识见色耶。眼见极成。前已说故。眼耳等识。无差别故。眼耳等根。有差别故。非有用眼离识而生。故说眼根识持能见。识见有过。前已具论。故不应言依眼识见。然契经说眼所识色。可就所依说能依业。眼与识异俱极成故。今闻识用在于眼根。知就所依说能依业。由此即释余契经言眼所欣慕。有余师说。眼识眼根。欣慕不成。无分别故。要有分别。欣慕可成。应知此中眼识所引分别意识。假说名眼。由眼传生。如意近行。彼有分别。可成欣慕。是故不可引就所依说能依业证眼非见。眼能见色。具理教故。如是且辩执识见论不应正理。由此亦遮。执慧见论。其过等故。又若眼识相应慧见。余识相应慧亦应见。则一切境。应成所见。又一切根。见所依故。皆应成眼。复有何因。唯执眼识相应慧见。非余慧耶。又如前说盲不盲等。诸余过难。随其所应。于慧见论。皆应广设。识慧见论。既并不成。由此准成。眼根能见。又契经说见闻觉知。四相各别。无杂乱故。若执识等为能见者。如前已说。无差别故。见闻觉知。应成杂乱。然此宗说。眼识持根。令有见用。非眼识见。闻等亦尔。随其所应。又眼是见。非眼识等。经论世理证分明故。经谓契经。处处皆说眼见色故。又伽他言。两眼两耳。多见闻故。又契经说。我诸弟子。同世间眼。引导世间。住正法故。眼若非见。世尊弟子。不应能导与世眼同。又契经说。眼等五根。各别所行。各别境界。如是等说。极分明故。论谓根本阿毗达磨。及毗婆沙。发智论言。二眼见色。品类足论。亦作是言。谓眼已见正见当见。诸如是等所说众多。毗婆沙中。亦作是说。若眼所得说名所见。为显同分眼有见能。故复说言。眼识所受。即是眼识任持眼根令有所得。说名见义世谓世间。同许眼见阙眼根者。说为盲故。理谓见闻嗅尝等用。各各异故。非同识等。经论世理。如是分明。证唯眼根决定能见。然随自执。譬喻部师。有于此中妄兴弹斥。言何共聚摣掣虚空。眼色等缘生于眼识。此等于见孰为能所。唯法因果。实无作用。为顺世情。假兴言说。眼名能见识名能了。智者于中。不应执着。彼谓佛说方域言词。不应坚执。世俗名想。不应固求。此言非顺圣教正理。于眼见性。亦不能遮。虽复有为皆从缘起。而说诸法别相用故。谓有为法虽等缘生。而不失于自定相用。故世尊说。法从缘生。亦说地等有别相用。如地界等。虽从缘生。而有如前坚等自相。亦有持等决定作业。如是眼色。及眼识等。虽从缘生。而必应有种种差别决定相用。由此差别决定相用。眼唯名眼。非色非识色唯名色。非识非眼。识唯名识。非眼非色。此中虽无总实相用。可名能见所见能了。而于如是无有总实相用理中。如可说有眼色等缘生于眼识。如是亦说色识等缘生于眼见。于如是等无有总实相用法中。随逐世情。似有总实相用显现。世尊于此总实相用。劝有智者。令除执着。故作是言。方域言词不应坚执。世俗名想不应固求。谓于世间。执有总实能见体相所起言词。不应坚执。此相无故。及于世间执有总实能见作用所起名想。不应固求。此用无故。如见相用余类应知。不可以无总实相用便越世俗假立名言。一向依随胜义而住。亦不可执别实用无。是故定应不违胜义。随顺世俗假立名言。由此但遮世间所起总实相用坚执固求。非谓亦遮诸法胜义各别相用坚执固求。以一切法缘起相用各实有故。非缘一切一切果生。是故我宗。双依二谛说眼能见。两俱无失世尊亦许作者作用。故契经说。苾刍当知。能了能了。故名为识。颇勒具那契经。虽说我终不说有能了者。亦不全遮作者作用。少有所遣。故作是言。思缘起中我当更辩。如是安住圣教正理。思求决择眼见非余。而彼于中妄兴弹斥。拨世俗理。篾胜义宗。摣掣虚空。定唯在彼。又所引教。何所证成。岂此中言。眼非见体。非说眼见。便同外道。许诸法有总实相用。又彼所说因果应无。不许法有别相用故。要有诸法各别相用。方可说有因果差别。若许诸法有别相用。如是诽毁则为唐捐。若谓全无总别作用。便违世俗胜义谛理。既许因果二谛非无。应许诸法有假实用。是故眼等取境义成。谓能见闻嗅尝觉了。如是见用。总相已成。今更应思见用别相。于所见色。为一眼见。为二眼见何缘于此复更应思。岂不极成。若闭一眼余眼能见。是则二眼俱能见色。其义已成此义虽成。而犹未了二眼见色。前后俱时为审了知。应更思择。若尔应说。非二眼中随闭一眼或一眼坏即令余眼无见功能。故知一眼亦能见色。若彼二眼不坏俱开。则二眼根同时见色。一眼见色义显易成。俱见难成故应辩释。颂曰

  或二眼俱时　　见色分明故

论曰。或时二眼俱能见色。何缘定知。见分明故。以闭一眼于色相续见不分明。开二眼时。即于此色见分明故。若二眼根前后见者。虽开二眼而但一见。如一眼闭见色不明。开二眼时亦应如是。如开二眼见色分明。一眼闭时亦应如是。既不如是。定知有时二眼俱见。依性一故。眼设百千尚生一识。况唯有二。有余部说。处隔越故。眼见色时唯一非二。又以一眼观箭等时。能审定知曲直相故。速疾转故。增上慢心。谓我一时二眼能见。此说非理。所以者何。岂不现见。全身没在冷暖水中。支体身根。俱时觉触。如是二眼。处虽隔越。俱时见色。理亦无违。虽二眼根方处各异。种类同故。而一根摄。唯一眼识。依二眼生。故许同时俱见无失。然别因故。但由一眼能审定知箭等曲直。言别因者。由眼极微如香荾花傍布而住。正现前事。见即分明。非正现前。见便不了。于观箭等曲直相时。二眼中间置箭等者。俱望二眼非正现前。更相眩曜见不详审。设当一眼置箭等时。余眼傍观亦不审了。故闭一眼以箭等事当一眼时。一眼正观无相眩曜。易审曲直。又言二眼处隔越故不俱见者。此亦不然。如人二手俱触冷暖。处虽隔越。同时发识。眼亦应然。何不俱见。又一眼中有翳隔断。应不俱时同发一识。又彼所言。速疾转故。起增上慢。谓我一时二眼见者。此实能见。非增上慢。虽复二眼见用速疾。若于一时。一眼发识。余眼不能助发识者。便开二眼。或一眼闭。见色明昧差别应无。随一眼中识定空故。由此亦遮上座所说。彼作是言。二眼于境前后起用。见则分明。或复一眼。有闭坏时。一眼虽开无相替代。彼所生识。唯依一门速疾转故。见不明了。此说亦非所执二眼刹那展转相替代时。一眼常空不能见色。恒唯一眼能见色故。与一眼者见色明昧差别应无。故彼所言不能令喜。又若一眼有闭坏时。眼识常依一门转故。于所见色不明了者。是则二眼不坏俱开时。一眼识依二门转。由此所见明了义成。若谓二眼不坏俱开。眼识尔时一门转者。即前所说。或复一眼有闭坏时。一眼虽开。无相替代。彼所生识。唯依一门速疾转故。见不明了。言成无用。无替代言。亦不应理。刹那前后有替代故。又初刹那识应明了。又应意识恒常闇昧。是故彼说。决定无有见色明昧差别因缘。又彼应说。眼识生时。左右二眼众缘皆具。何不同时俱能生识。二眼前后生识论者。众缘具时。无有因缘。令生识用。初左非右。或复相违。又彼上座论宗所许。全身没在冷暖水中。身根极微。遍能生识。以中或表身根损时。虽生身识。而不明了。故知身识明了生时。定由所依宽广遍发几许多百踰缮那身境遍现前。上下俱时。同生一识。何缘二眼。相去不遥。俱境现前。不许同时共生一识。今观彼意。无别因缘。但欲故违阿毗达磨诸大论者所说义宗。顽嚣众中逞己聪睿。对法者说。身根极微。理应定无一切同分。十三火聚缠逼身时。身根极微。犹有无量是彼同分。不生身识。设遍生识。身应散坏。彼上座言。此应征难。彼所受身不散坏者。为由身识不遍发故。为由宿业力所持故。又彼身形所有损害。为由身识为由火烧。又彼身中。猛火遍逼。何缘身识不遍发耶。又发识处。身应散坏。如是征难。皆不应理。业要待缘能持身故。谓由业力。令彼身中身根极微不遍发识。勿遍发识身便散坏。彼何不受如是义耶。又由此故。业力胜劣差别义成。生彼有情。受苦轻重。业不等故。谓彼同分身根极微少者。便生猛利苦受。若彼同分身根极微多者。便生微劣苦受。若谓业力招异熟苦胜劣法尔何用彼者。此责不然。一身前后。受苦胜劣。应无有故。非一业力于一身中感苦受果前后胜劣满业多故。无斯过者。理亦不然多业异熟。前后生起。无定因故。若谓待缘合时生者。是则业力待缘义成。业虽能招异熟苦果。要缘身触身识方生。身识俱时乃生苦受。是故业力必待缘成。有非情法亦能为缘发生苦受。然非异熟。若谓彼缘亦是业力增上果者。然增上果。既非异熟。不必相续胜劣无定。是则无业不待缘成。其理难越。故我所言。谓由业力。令彼身中身根极微不遍发识。勿遍发识身便散坏。其理极成。言彼身形所有损害。为由身识为火烧者。我说定由身识损害。若无识了外火何能不见悦意境界现前乐受不生身有摄益。诸聪睿者。咸作是言。由遇外缘觉发内境。起心心所。方于自身为损为益。若无苦受与识俱生。谁于彼身能为损害。故彼所执。理定不然。言彼身中猛火遍逼。何缘身识不遍发者。上座亦应同此当说。何缘二眼境俱现前。唯一眼根生识非二。又如先说。先何所说。谓由业力令彼身中身根极微不遍发识。勿遍发识身便散坏。言发识处身应坏者。何缘定知彼身不坏。如等活等[打-丁+柰]落迦中。随发识处身分便坏。而不全坏。若全坏者。彼应数数命终受生。是故应知。一切身分有多同时发一识者。如是眼根虽有二处。亦可俱时同发一识。云何一眼识依二眼根转。识无形色无住处故。依二转相难可定说。如何得知。识无住处。一识遍依多根转故。谓若眼识有住处者。眼根有二眼识唯一。识应但依一眼而转。则应一眼见色非二。或应俱时在一相续有二眼识依二根转。如是二事既皆不许。故心心所定无住处。若谓一识于一时中住二眼处。此亦非理。有分相杂非一过故。谓若一识于一时中住二眼者应成有分住左眼分非住右眼住右眼分非住左故。又应相杂。二眼中间眼识。亦依身根住故。是则身识亦成眼识。又应非一。二眼中间若无眼识有隔断故。如何成一。如是则应非一眼识于一时间各住一眼。是故不应许一眼识于一时中住二眼处。又执眼识住眼中者。当云何住。为体相涉如油住麻。为别相依如果住器。然此二执。俱不应理。若如初者。眼与眼识。其性各别。应成一故。若如后者。无方分法。别体相合。理不成故。若心心所无住处者。如何可言依止眼根了别诸色故名眼识。又若眼识不住眼中。如何眼根成所依性。此责非理。眼作眼识不共邻近生起缘故说为依止及所依性。不可言依彼即说住其中。亦说臣依王人依财食故。若谓眼识随所依根有损益故住眼中者。理亦不然。现见影光镜像等物。随依损益而不住故。谓影等物非住树等。而见树等有损益时影等随依亦有损益。又见大海。随月亏盈。水有增减。然大海水不住月中。故所立因。有不定失。若尔眼识何不能取眼依肉团眼药眼筹眼睑翳等。设许眼识住眼根中。极相逼故。可不能取。既许眼识如非住境亦不住根。岂不如色亦应能取眼肉团等。此亦不然。由能依识与所依根一境转故。又极远色。与识所住虽不相邻。而不能取。若肉团等。与所住根极邻逼故。识不取者。诸所有色与所住根。不相邻逼。皆应能取。是故眼识取境法尔。若所取境与所依根。极近极远皆不能取。若尔眼识应有住处。非无住处。可说此识与所取色极近极远。此亦不然。就所依根。说近远故。或就邻近生因说故。眼是眼识邻近生因识执眼根以为我故。即就此因。说有近远。或由眼识身内转故。就身说有近远无过。身由此理名有识身。以识执身为自内有。故知眼识在身内转。有作是言。心心所法。定有住处。现见诸果住因处故。谓见世间所生诸果。无不住在能生因处。如羯剌蓝住精血处。芽等亦住种等因处。眼根既是生眼识因。眼识定应住眼根处。若谓如声亦离本者。此救不然。声必不离所依本故。此言非理。如粪土等相续有异。非如种等相续一故。眼与眼识。由体类别相续有异。如粪土等虽芽等因。体类别故住处各别。眼识亦然。不住眼处。非如芽等与种等因相续不异。可言住彼。又识不住色等处故。如色明空及作意等。虽能为因发生眼识。而识生时不住彼处。眼亦应尔。虽是识因。而识生时不住彼处。岂不如眼虽与色等同为识因而眼识生唯依止眼不依色等。如是眼根。虽与色等同为识因。而眼识生。应唯住眼不住色等。汝今何缘不取是义。谓如眼根。虽与色等望所生识依非依异。而与眼识同为异类相续因性。如是眼根。虽与色等望所生识依非依异。而同作识非所住因。由此故知。心心所法。定无住处。其义极成。故先所言。识无形色。无住处故。依二转相难可定说。理必应然。如是所说。眼等诸根。正取境时。为至不至。何缘于此犹复生疑。现见经中有二说故。如世尊说。有情眼根。爱非爱色之所拘碍。非不相至。拘碍义成。又世尊说。彼以天眼观诸有情。广说乃至。或远或近。非于至境可立远近。由此二说。故复生疑。根境相至其义不定。若就功能到境名至。则一切根唯取至境。若就体相无间名至。颂曰

  眼耳意根境　　不至三相违

论曰。眼根唯取非至境界。远近二境俱时取故眼若至境应有行动。非天授等有行动法。远近二方一时俱至。是故眼根取非至境。若说如灯。于远近境一时俱至。是彼性故。此说不然。因不成故。谓若有说。譬如明灯远近二方俱至而照。眼根亦尔。远近二境俱至而取。同彼明灯火明性故。此因不成。眼火明性非极成故。又眼不应是火明性。闇中欲见求光明故。非灯欲照瓶衣等时别求光明助方能照。若谓眼中火明小故求大光明助方见者。此亦非理。现见小明大所伏故。眼应毕竟不能见色。又明灯喻。与眼不同。邻逼无间照不见故。谓如明灯。于油炷等极邻逼物。能烧能照。眼则不然。于眼药等极邻逼境。不能见故。又如明灯。于诸远近所照之物。无间遍照眼则不尔。或越中间树林等色见山等故。由兹灯喻。与眼不同。前所立因。远近二境俱时取故。证眼唯取非至境者。理无倾动。又眼不应至境方取。以不能取邻逼境故。又亦能取颇胝迦等所障色故。又于所见有犹豫故。若取至境。因何犹豫。非于至处犹豫应理。又不审知人杌异故。既言至彼审知竖相不审差别。此有何因。又眼无容至远境故。无容住此眼越多千踰缮那量。至月轮境眼有明故。无斯过者。理亦不然。眼有火明。非极成故。眼性非火。宁有火明。耳根亦唯取非至境。方维远近可了知故。谓可了知此南北等方维远近差别音声。声至耳根方得闻者。应如味等。此事皆无。岂不鼻根亦见能了方维远近香差别耶。虽见但由顺方回转。取香明了比知差别。眼耳见闻方维远近。不假回转而能了知。故与鼻根取境非类。又近远声。取有明了不明了故。若至乃闻并应明了。又近远声。取有决了犹豫别故。若至乃闻至无别故。如近决了。于诸远声。应无犹豫。如远犹豫。于诸近声。应无决了。由此等证。不至能闻。意根亦唯取非至境。不取俱有相应法故。若言如鼻虽不能取自俱生香而取至境意亦尔者。理必不然。由外觉发。内俱生香鼻方能取。义极成故。如说唯内食能作食事故。非不取时能为食事。又无色故非能有至。是故意根取非至境。设有难言。三根能取非至境者。理必不成。应皆能取一切处时所有一切不至物故。谓若三根取非至境。非至同故。天上地下。极远障隔。已灭未生。诸不至物。何不能取。又彼三根。未起已灭。何不能取。又面余方。何不能见余方境界。此难不然。譬如磁石能吸铁故。谓如磁石。虽能吸于诸不至铁。而不能吸无量百千踰缮那等有隔障铁。又不能吸已灭未生及不对面诸不至铁。未起已灭亦不能吸。又如镜等生于像故。谓如镜等。虽复能生不至物像。而不能生极远障隔已灭未生及不对面一切物像。未起已灭亦不能生。眼等亦然。不应为难。是故彼难。不令三根退失能取非至境用。有说耳能取于至境。声相续转来入耳故。又自能闻耳中声故。此说非理。手才执铃声顿息故。若声相续来入耳中。手执铃时依铃声可息。从彼传生。中间离质相续不息。此声应可闻。然执铃时。现见一切铃声顿息。都不可闻。不可息余。余亦随息。不闻余故。余亦不闻。若谓如灯灭时近远明皆灭者。此亦不然。俱不俱时转差别故。非一与一相续异故。谓灯与明现见俱转。灯焰才灭则不见明。声即不然。彼许离质展转相续来入耳故。彼定应许闻至声时初附质声久已谢灭。若不尔者。初所起声。闻位犹存。失刹那性。故声与彼灯明不同。又灯与明。相续各异。如心心所同共缘生。缘被损时彼此俱息。声即不尔。相续无异。如识相续不共缘生。声相续中。前声虽灭。后声犹起。何故不闻。是故依质所发音声。即能为缘生于耳识。若异此者。声至方闻。了近远声。应无差别。然自能闻耳中声者。非如香等邻鼻等根。虽在耳中。仍非至境。由语逼耳字句难知。欲审听者遮其苦逼。故耳唯能取非至境。今应思择。何缘闇中。眼不能取瓶衣等色。为体无故。为非境故。为助取因无故。为障取因有故。而不取耶。且闇中色。非体无故而不可取。有天眼者。能现取故。又闇中色。非非境故而不可取。彼因大种。现可取故。设持明照应不取故。非处明中极微等色及余非境。眼根能见。虽有说言此闇中色如中有色异明色类故不可取。而非应理。所以者何。应不取彼俱行触故。又持明照时。不见异色故。或应闇与明成灭生因故。形亦应成异类性故。现见曾受彼种类者。闇中触时。知即彼故。又于闇中。赤染衣等。色至明中不见异故。由此证知非异色类。若尔闇色。何缘不取。譬喻论师。作如是说。由助取因光明无故。此中光明有何作用。谓有摄益能取根用。如食干糗不得味故。又言色在可见处故。若尔光明唯应于境能为摄益非摄益根。谓身住闇中。见明处色故。又由所立干糗喻故。复由所引阿笈摩故。又言色在可见处者。意不说色在光明中。但言境在根力及处。彼经广说。乃至法在可知处故。又若闇中瓶衣等色。其体先有。阙助取因。故不能取。后遇光等助取因时。显了彼色。故能取者。应许空中先有风体。阙助取因。故不能取。后遇扇等助取因时。显了彼风。然后能取。又亦应许二木相磨是火取因非别生火。然不应许。有过失故。执我论者应亦可言。我体先有。阙能取根。故不能取。是故闇色。非助取因。光明无故眼不能取。若尔何缘不取。由障取因有故。何者是耶。谓即黑闇云烟尘等所障诸色。眼不能取。例极成故。光明违此障取因故。待彼光明。方能取色。故亦说彼为识生因。又如琉璃与彼壁等。望能取者。为障不同。如是闇明种类尔故。是障非障体性有别。如前已辩。岂不亦由助因无故而不能取。见根功能作意无故。虽有实境。而智不生。虽有是事。然可生疑。谓于闇中如不取色。光明亦尔。由此未知。为由所见无故不取。为由光明无故不取。云等障色不见极成。又黑闇障是所现见。故闇中色。由闇障故。眼不能取。此事无疑。如有说言。极远诸色。由有远故。而不能取。复有说言。极远诸色。由无近故。而不能取。此二说中。前说为胜。以有体故。不生疑故。如是应知。有闇障故。无光明故。是故闇中所有诸色。定由闇障而不能取。光明违此障取因故。待彼光明。眼能取色。如是所说。其理必然

说一切有部顺正理论卷第七阿毗达磨顺正理论卷第八

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩本事品第一之八

已说三根取非至境。余三鼻等。与上相违。谓鼻舌身。唯取至境。如何知鼻唯取至香。有说。断息时则不嗅香故。此因于义未足证成。设有息时能嗅香气。何能证鼻唯取至香。以诸极微不相触故。何不相触。若诸极微遍体相触。即有实物体相杂过。若触一分成有分失。是故此因。于鼻唯取至根香义。未足证成。实有息时能取香气。然不相触。至义岂成。彼难既然。此因何解。今观至义。谓境与根。邻近而生。方能取故。由此道理。说鼻舌身唯取至境。如言眼睑筹等。至色眼不能见。非眼睑等要触眼根方得名至。但眼睑等邻近根生。即名为至。由不能见如是至色。故说眼根取非至境。如眼等根取非至境。然不能取极远境界。鼻等亦然。虽取至境。而不能取极近境界。但由香等邻近根生。故说三根取至无过。非鼻香等根境极微展转相触。非所触故。又是障碍有对性故。触即有失。为显此义。复应研究。设有难言。若诸极微互不相触。如何拊击。得发音声。今此岂同鸺鹠子等。要由合德方乃生声。而为此难。然物合时理不成故不应许有合德生声。若尔云何得有声发。于此真实圣教理中。离合击名。唯依大种。谓有殊胜二四大种。离合生时。得彼名故。此位大种。是声生因。此俱生声。是耳根境。此有何失。彼不忍受。我不忍受。亦有因缘。谓诸极微。既不相触。彼此大种合义岂成。邻近生时。即名为合。岂待相触方得合名。又汝不应踌躇此义。此彼大种。定不相触。所以者何。是所触故非能触故。诸色蕴中。唯有触界。名为所触。但有身根。名为能触。此外触义。更不应思。若谓所触亦能触者。应许身根亦是所触。则境有境。便应杂乱。然无杂乱。立境有境。若谓此二无杂乱失。身识所缘所依别故。岂不由此转成杂乱。谓若身根。亦所触者。何缘不作身识所缘。若许触界亦能触者。何缘不作身识所依若诸极微。定不相触。毗婆沙论。则不应言非触为因生于是触。谓离散物正和合时。是触为因生于非触。谓和合物正离散时。是触为因生于是触。谓和合物复和合时。非触为因生于非触。谓向游尘同类相续。毗婆沙宗。决定不许极微展转更相触义。应知彼言有别意趣。且向游尘多极微集。而彼论说。非触为因生于非触。故知彼言。定有别意。有何别意。谓于和合说是触言。毗婆沙师咸作是说。但由风界力所摄持。令诸极微和合不散。众缘合故。聚色生时。说非触因生于是触。即离散因生聚集义。岂不无有不集极微待缘方集。则应一切是触为因生于是触。有作是说。亦有极微不聚集者。故无此失。有说。待粗和合色故。于细和合立非触名。故非触因生是触者。是细聚因生粗聚义。故彼所言。于义无失。众缘合故摄持聚色。风界灭时。与此相违。离散色起即于此位。说是触因生于非触。是粗聚因。生细聚义。众缘合故。摄持聚色。风界不灭。诸粗色聚。或生自类。或转生粗。说是触因。生于是触。是粗聚因。生粗聚义。由此道理。诸向游尘。能摄持粗。风界不起。细聚相续。不转成粗。名非触因生于非触。是细聚因。生细聚义。此谓彼言所有别意。又于非色亦说触言。如契经说。出灭定时。当触几触。当触三触。谓不动触。无所有触。及无相触。然非此中可计实有互相触义。是故所言此彼大种。定不相触。其理极成。若许相触。复有何过。岂不前说。若诸极微遍体相触。即有实物体相杂过。若触一分。成有分失。然彼上座。于此复言。诸极微体。即是方分。如何有体。言无方分。此言非理。若许极微更无细分。有自体故。是方分者。诸无色法。既有自体。无差别故。应是方分。若谓无色无和合义。是故不应名方分者。此亦非理。诸无色法。有处亦说有和合故。又彼所宗。色有和合。亦不应理。应成一故。不应一体可名和合。又上座说。二类极微。俱无分故。住处无别。此亦非理。彼论自言。有说极微处不相障。是宗有失。违圣教中有对言故。何缘复说二类极微。俱无分故。住处无别。又彼所言。即由此故。许依同处说不相离。又言极少许五极微。同在一处。不相妨碍。此皆非理。若容五微同一处者。何物为障百千俱胝。不许同处。如是便应一极微处。包容一切所有极微。是则世间总一微量。或应不许极少五微同在一处。不相妨碍。多微聚集。处宽广故。是故应许极微有分。或许诸微互不相触不相离义。异此可成无一极微。现在独住而不聚集。如前已辩。是故一切和合聚中。随其所应。皆有一切。由此故说不相离言。非约处同名不相离。然无分故。不触义成。若尔身根及与触界。如何能触所触得成。已成极微互不相触。能所触义。今应共思。若谓我宗由能所触已许相触。更何所思。唯汝自应思量是义。此不应理。许触论宗。于是义中。应同思故。谓若鼻舌。与自境微。亦相触者。何缘不许此根境微是能所触。若不许二触自境微。而同身根名取至境如彼理趣。此亦同然。或非色中应有相触。如前所引触三触故。是故此中。应共思择。契经所说触义意趣。然我先说。谓境与根。邻近而生。方能取故。名取至境。今能所触。准彼应成极邻近故。岂不一切鼻舌身根皆取至境。无差别故。则应能触通鼻舌根。所触亦应兼于香味。此亦非理。邻近虽同。而于其中。有品别故。如眼睑等。虽至名同。而于其中。非无品别。非眼睑等同得至名。即令一切至无差别。睑筹药翳。于彼眼根。渐邻近中。品类别故。又如眼等。取非至同。非至境中。非无品别。鼻等亦尔。取至境同于至境中。应有品别。又滑涩等。世间共起所触想名。对彼身根。说名能触。故无有过。有说。实无能触所触。然似有故假立触名。或任于中更求余理。且不应许境与身根实更相触。如前已说。境与有境。应杂乱故。是故应随此顺正理。说能所触名起因缘。有余师说。虽诸极微互不相触。而和合色相触无过。由此拊击。得发音声。如诸极微。虽无变碍。而和合色变碍非无。此不应理。非离极微有和合色。若触和合应触极微。彼即应许极微相触。是故前说。于理为胜。又上座言。此若触彼。彼定触此。既成所触。余触所触。理不相违若异此者。极微展转无相摄持。应不和合。若谓摄持是风界力。风界岂似手所捧持。摄持诸微。令不散坠。此难非理。且如水轮风轮摄持。令不散坠。风轮岂似手所捧持。如彼摄持。此亦应尔。若言我许极微相触。由相触故。相摄持者。似手捧难。则为唐捐。如汝所言。极微相触。次第安布。能相摄持。我亦说言。由风界力。邻近安布。能相摄持。故不应言。若异此者。极微展转无相摄持。应不和合。异汝所言。极微展转。有相摄持。和合成故。又不相触。亦能摄持。譬如身根不触身识能摄持识。令起现前。又彼所言。此若触彼。彼定触此。既成所触。余触所触。理无违者。彼不审思。而作是说。如前已说。境与身根。实不相触。应境有境相杂过故。遍体一分触违理故。诸有对法。体是障碍有对摄故。处所展转。互不相容。不应相触。无细分故。非触一分。各别性故。非触全体。同处多微。过如前说。如何可言。此若触彼。彼定触此。乃至广说。又准此说。应亦可言。此若见彼。彼定见此。既成所见。余见所见。理不相违。此若闻彼。彼定闻此。既成所闻。余闻所闻。理无违等。彼既不然。此云何尔。若所触界。亦不相触如何大种展转相望。互为摄益。或相损害。岂要相触方能损益。异此云何。若必尔者。观雪日等眼云何损。观月轮等眼云何益。眼不应至日等大种。汝又不许有彼光明俱行大种。汝许光明依日月轮大种生故。由彼上座自说是言。大种造色。多不相离。亦有少分得相离者。谓诸日月灯宝光明。及离诸花。孤游香等因论生论。身根既唯取至境故。日光中热。身现得故汝云何知。日光但依日轮大种。不依邻近身根大种。若于是处。身觉日热。即近是处。眼见日光。应知此光非离大种。故唯邻近大种为缘。能损能益。邻近大种。非彼极远。亦非相触。此义已成。且如所触。不触身根。然能为因。令身损益。若谓所触触着身根。所依大种为损益者。雪日光等。于眼云何。设许所触触着身根所依大种能为损益。然不许身所依大种能触身根仍为损益。岂不大种展转相望虽不相触由相邻近能为因故损益义成。故不应言若所触界亦不相触。如何大种展转相望。互为摄益。或相损害。然大德说。一切极微。实不相触。但由无间。假立触名。经主此中。显彼胜德。作如是言。此大德意。应可爱乐。若异此者。是诸极微。应有间隙。中间既空。谁障其行。许为有对。今说大德如是意趣。非即可乐亦非可恶。但应寻究。如何无间。仍不相触。理未显故。意趣难知。若说诸微全无间隙。然不相杂。应成有分。不许处同。复无间隙。既许无间。何不相触。故彼但间言定显邻近义。此中但言。或显定义。定有间隙。故名定间。如定有热故名定热。是定有隙。理得成义。或显无义。谓此中无如极微量触色所间。故名无间。如是无间大种极微邻近生时。假说为触。若作此释。大德所言。一切极微。实不相触。但由无间。假立触名。深有义趣。即由障碍有对势力。能相障行。许为有对。非许住处展转相容而可说为障碍有对。岂怖处同。遮无间住。许有间隙而无趣行。非有所怖。法性应尔。诸有对者。处必不同。勿彼处同。或成有分。故无间住。理必不然。虽于中间少有空隙。而有对力。拒遏其行。间隙者何。有余师说。是无触色。复有说言。都无所有。经主复说。又许极微。若有方分。触与不触。皆应有分。若无方分。设许相触。亦无过者。此说非理。有分方分。名异义同。立无分言。已遮方分。如何于此复更生疑。谓许极微若有方分。既无方分。如何可触又遍体触。或触一分。二皆有过。前已具论。如何复言。若无方分。设许相触。亦无斯过。是故所言无极微量。触色所间。故名无间。如是无间。大种极微。邻近生时。假说为触。其义成就。非住处同。或无间住。可许有对无分义成。今应观察。眼等诸根。为于自境唯取等量。速疾转故如旋火轮。见大山等。为于自境通取等量不等量耶颂曰

  应知鼻等三　　唯取等量境

论曰。前说至境鼻等三根。应知唯能取等量境。如鼻舌身根极微量。香味触境极微亦然。相称合生鼻等识故。岂不鼻等三根极微有时不能遍取香等。何故乃言唯取等量。以非鼻等三根极微于香等微能取过量。故说唯能取等量境。非无少分三根极微亦能取于少分三境。随境微量至根少多。尔所根微。能起功用。眼耳不定。谓眼于色有时取小。如见毛端。有时取大。如暂开目见大山等。有时取等。如见蒲桃野枣果等。耳根亦取蚊雷琴声小大等量。意无质碍。不可辩其形量差别。颂中应知言兼劝知此义。今乘义便复应观察。云何眼等诸根极微安布差别。不可见故。虽难建立。而有对故。住方处故。和集生故。定应说其安布差别。眼根极微。居眼星上。对向自境。傍布而住。如香荾花。清彻膜覆。令无分散。有说重累如丸而住。体清彻故。如秋泉池。不相障碍。耳根极微。居耳穴内。旋环而住。如卷桦皮。鼻根极微。居鼻頞内。背上面下。如双爪甲。此初三根。横作行度。无有高下。如冠花鬘。舌根极微。布在舌上。形如半月。当舌形中。如毛端量。非为舌根极微所遍。身根极微。遍住身分。如身形量。女根极微。形如鼓[壴*桑]。男根极微。形如指[韋*沓]。眼根极微有时一切皆是同分。有时一切皆彼同分。有时一分是彼同分。余是同分。乃至舌根极微亦尔。身根极微。定无一切皆是同分。乃至极热奈落迦中。猛焰缠身。犹有无量身根极微。是彼同分。故如是说。设遍发识。身应散坏。以无根境各一极微为所依缘能发身识。五识决定积集多微。方成所依所缘性故。云何建立六识所依。为如五识唯缘现在。意识通缘三世非世。如是诸识依亦尔耶。不尔。云何。颂曰

  后依唯过去　　五识依或俱

论曰。由六识身无间灭已。皆名为意此与意识。作所依根。是故意识。唯依过去。眼等五识。所依或俱。或言表此亦依过去。谓眼等五是俱所依。过去所依即是意界。如是五识所依各二。第六意识。所依唯一。为显颂中依义差别。故复应问。若是眼识所依性者。即是眼识等无间缘耶。设是眼识等无间缘者。复是眼识所依性耶。应作四句。第一句。谓俱生眼根。第二句。谓无间灭心所法界。第三句。谓过去意根。第四句。谓除所说法。乃至身识亦尔。各各应说自根。意识应作顺前句答。谓是意识所依性者。定是意识等无间缘。有是意识等无间缘。非与意识为所依性。谓无间灭心所法界。又五识界。如所依根。定有过现。彼所缘境。为亦如是。为有别耶。定有差别已灭未生。非五识境。所以者何。由与所依一境转故。于非现境依不转故。有执五识境唯过去。应告彼言。若如是者。岂不但以前生为缘与识俱生皆非缘性。又已灭色。彼执体无。但分别心。取为境起。又定应许。彼所依根。亦在过去。能生现识。如是彼言。皆不应理。且置所依及余识境。如何眼识境唯过去。不缘一切过去色耶无间百年灭无异故。若谓无失取自因故。无间灭色是现识因。百年灭色无因义者。此亦不然。无异因故。唯无间灭是现识因。非百年灭。有何因证。如彼百年已灭诸色。与现眼识。都不相关。无间灭色。应亦如是。既无差别。何独为因此望百年。亦有差别。眼识将生时。此色为缘故。若尔眼识境应非过去。识在未来缘现在境故。亦不可说异时为缘异时为境。此与眼识除为境用。复作何缘眼识生时。久已灭色近灭无异。何不为缘。汝执久灭与近灭者俱非实体无差别故。又久近灭。能为缘用。理俱不成。非现境界相续各异非一果性。无差别故。又汝应说。鼻舌身三。云何名为。取近至境过去未来。说为远故。又若五识唯缘过去。如何于彼有现量觉。如于自身受有现量觉。谓我曾领纳如是苦乐。此救不然。于自身受领纳觉了时分异故。谓于自身。曾所生受。余时领纳余时觉了。领纳时者谓为损益时。尔时此受未为觉了境。谓了余境识俱生受。正现前时。能为损益。此损益位。名领纳时。即自性受。领所随触。自体生故。识等领彼损益行相。自体起故。此灭过去。方能为境。生现忆念。此忆念位。名觉了时。由斯理趣。唯于现量。曾所受事。有现量觉。故现量觉。于自身受有义得成。现量有三。依根领纳觉了。现量性差别故。过去色等。既许未曾现量所受。云何可言如自身受有现量觉。如于他身受非自领纳。现量所受则无现量觉。言我曾受如是苦乐。缘彼受智。既非现量觉。如是现色等。非自依根现量所受。应无现量觉。谓我曾受如是色等。缘彼境智。应非现量觉。又若现在色等五境。非现量得。如缘未来受所起智。缘非曾领纳现量所得故。必无自谓我曾领受如是苦乐。例缘过去色等起智。缘非曾依根现量所得故。应无自谓我曾领受如是色等。如苦受等。必为领纳现量受已。方有缘彼现量觉生。如是色等。必为依根现量受已。方有缘彼现量觉生。现所逼故。定应信受。若领纳受时非缘受为境。缘受为境时非领纳受者。世尊何故作如是言。受乐受时如实了知受于乐受。乃至广说。此无违失。如是所说。是观察时。非领纳时。显观行者。于曾领纳现量所得乐等受中无迷谬故。作如是说。是故不应于诸现量曾未受境有现量觉。由此五识唯缘现境。必以俱生为所缘故。契经既说。眼色为缘。生于眼识。乃至广说。何因识起俱托二缘。得所依名。在根非境。颂曰

  随根变识异　　故眼等名依

论曰。眼等即是眼等六界。由眼等根有转变故。诸识转异。随根增损有明昧故。非色等变令识有异。以识随根不随境故。依名唯在眼等非余。若尔意识亦随身转。谓风病等损恼身时。意识即乱。身清泰时。意识安静。何缘彼意识不以身为依。随自所依故无此失。谓风病等损恼身时。发生苦受相应身识。如是身识。名乱意界。此与苦受俱落谢时。能为意根生乱意识。与此相违意识安静。是故意识随自所依。岂不有漏意界无间无漏识生。如是等异。如何意识随自所依。非据有漏无漏等类名随自依。但据增损明昧差别。如从无覆无记眼根生善不善有覆眼识。而名眼识随自所依。此亦应尔。是故能依非随一切所依法性。若不尔者。应非能依随所依故。何缘所识是境非根。而立识名。随根非境。颂曰

  彼及不共因　　故随根说识

论曰。彼谓前说眼等名依。故立识名。随根非境。依是胜故。及不共者。谓眼唯自眼识所依。色亦通为他身眼识。及通自他意识所取。乃至身触应知亦然。岂不意识境不共故应名法识。此难非理。通别法名。共非遍故。境不具前二种因故。谓通名法。非唯不共别名法界。非遍摄识。又别法界。虽不共余。而非意识所依根性。是故若法。是识所依。及不共者。随彼说识。色等不然。故不随彼说色等识。如鸣鼓声及麦芽等。又此颂文。复有余义。彼谓眼等识所随故。及不共者。及由眼等是不共故。谓有一生色发四生眼识。无一生眼根发二生眼识。况有能发四生识者。如是界趣族类身眼。各别发识。故名不共。广说乃至。身亦如是。岂不余生意根亦发余生意识。非全不发。但不俱时。无一生意一时并发二生意识。可如色等。故作是言。无二况四。如是眼等。识所随故。生界趣等。别生识故。由此二因。随根非境。有言。根识俱是内性。境唯是外。故随根说。有言。根识俱有情数。色等不定。故随根说。众缘和合。眼识方生。何故契经。唯举眼色。眼识所依所缘性故。余法虽是眼识生缘。而非所依及所缘性。又是眼识邻近缘故。岂不空明能生作意亦是眼识邻近缘耶。眼色二缘。于生眼识。极邻近故。异空明等。又眼识生。必藉所依所缘力故。及不共故。眼识生时。必藉眼色为所依缘。余法不定。谓夜行类。识不藉明生。水行类。识不待空发人。于琉璃颇胝迦等障色亦尔。天眼发识。不假空明。若谓眼识生必藉明。近明近色。主明客明。定一为缘。方见色故。又眼识发。必藉于空。以空遍满一切处故。此皆非理。眼藉明者。要藉大明照色方见。非猫狸等眼有大明。如何能见。复有人等眼虽无明而夜见色。甚违汝义。如说有人于闇中色亦能睹见。不待光明。若空遍满一切处者。无障碍故。亦应能取壁等障色。能生作意。通与六识。作共生缘。眼色非共。是故契经。唯举眼色。或随所化宜闻便说。象迹喻等诸契经中。作意等缘皆具说故。随身所住。眼见色时。身眼色识地为同不。应言此四或异或同。所言同者。谓生欲界。以自地眼。见自地色。四皆同地。生初静虑。以自地眼。见自地色。亦皆同地。非生余地有四事同。所言异者。谓生欲界。若以初静虑眼见欲界色。身色欲界。眼识初定。见初定色。身属欲界。三属初定。若以二静虑眼。见欲界色。身色欲界。眼属二定。识属初定。见初定色身属欲界。眼属二定。色识初定。见二定色身属欲界。眼色二定。识属初定。如是若以三四静虑地眼。见下地色。或自地色如理应知。如是若生四静虑地。四事有异。如理应思。余界亦应如是分别。今当略辩此决定相。颂曰

  眼不下于身　　色识非上眼
  色于识一切　　二于身亦然
  如眼耳亦然　　次三皆自地
  身识自下地　　意不定应知

论曰。身眼色三皆通五地。谓在欲界四静虑中。眼识唯在欲界初定。此中眼根望身生地。或等或上。终不居下。色识望眼等下非上。下地眼根。串见粗色。于上细色无见功能。又下眼根。无有胜用。上地自有殊胜眼根于下地中。自有眼识。故下地眼。非上识依。色望于识。通等上下。色识于身。如色于识。谓通自地或上或下。识望于身。通自地者。唯生欲界初静虑中。或上地者。唯生欲界。或下地者。唯生二三四静虑地。色望于身。自下地者。自上眼见。若上地者。唯上眼见。又以自地眼。唯见自下色若以上地眼。见自上下色。广说耳界。应知如眼。谓耳不下于身。声识非上耳。声于识一切二于身亦然。随其所应。广如眼释。鼻舌身三。总皆自地。多分同故香味二识。唯欲界故。鼻舌唯取至境界故。于中别者。谓身与触。其地必同。取至境故。识望触身。或自或下。自谓若生欲界初定。生上三定。谓之为下。应知意界。四事不定。谓意有时与身识法。同在一地。有时上下。身唯五地。三通一切。唯生五地。自意自识。缘自地法。名意与三同在一地。意界有时在上地者。谓游定时。若生欲界。从初静虑。无间起欲界识。了欲界法。意属上地。三属下地。或二三四静虑等无间。起初二三静虑等地识。了初二三静虑等地法。意属上地。三属下地。如是若生初静虑等。从上起下。如理应知。于受生时。无上地意依下地身。必无下地身根不灭受上生故。又定无有住异地心而命终故。如是应知。无下地意依上地身。依上地意受下地身。则不违理。谓从上地意界无间。于欲色界。初结生时。意属上地。身识下地。彼所了法。或自地。或上地。或不系。如是应知。依下地意。受上地身。亦不违理。于游定时。有下地意依上地身。亦不违理。谓生上地。先起下地识身化心。如是识法。亦应广说。复应思择。若欲界眼。见欲界色。或色界眼见二界色。尔时彼色。可为几种眼识所识。于此复起几种分别。为令于宗不迷乱故。先总料简。后当别释。应知此中且辩计度及与不定随念分别。遍诸地故。约此二种。一切眼识。皆无分别。又善分别。能缘一切自上下地。染污分别。缘自上地。无记分别。缘自下地。随所生地。未离彼贪具有此地三种分别。若离彼贪。唯有此地二种分别。谓除染污。非生余地有初静虑善眼。识现在前由此必定系属生故。生初静虑。亦不得依余地眼根起善眼识。非生余地能起余地无覆无记分别现前。此亦必定系属生故。非此中意唯说一生所起分别。若说一生。则生上地。应定无有下地分别。即此生中。彼三分别。无容得有现在前故。又上地分别应唯善非无记。前已说因故。通说余生皆得具有。已总料简。次当别释。断善根者。眼见色时。此色染污无覆无记。眼识所识。于此复起三种分别。谓善染污无覆无记。不断善根。未离贪者。眼见色时。此色三种。眼识所识。于此复起三种分别。若诸异生。生在欲界。已离欲界贪。未离初定贪。以欲界眼。见诸色时。此色是善无覆无记。眼识所识。于此复起欲界分别若退法者。具有三种。不退法者。唯有二种。谓除染污。以初静虑眼。见欲界色时。此色唯是无覆无记。眼识所识。于此复起欲界分别。如前应知。于此复起初静虑地二种分别。谓除染污。以初静虑眼见彼地色时。此色唯是无覆无记。眼识所识。于此复起欲界分别。若退法者。则有二种。谓除无记。不退法者。则唯有善。于此复起初静虑地三种分别。已离初定贪。未离二定贪。以二静虑眼。见欲界色时。此色唯是无覆无记。眼识所识。于此复起欲界分别。若退法者。具有三种。不退法者。唯有二种。谓除染污。于此复起初定分别。若退法者。则有二种。谓除染污。不退法者。则唯有善。于此复起二静虑地二种分别。谓除染污。以二静虑眼。见初定色时。此色唯是无覆无记。眼识所识。于此复起欲界分别。若退法者则有二种。谓除无记。不退法者。则唯是善。于此复起初定分别。若退法者。具有三种。不退法者。则唯是善。于此复起二静虑地二种分别。谓除染污。以二静虑眼。见二定色时。此色唯是无覆无记。眼识所识于此复起欲界分别。若退法者。则有二种。谓除无记。不退法者。则唯有善。初静虑地所起分别。亦如是知。于此复起二静虑地三种分别随此所说。别释理趣。已离二定贪。未离三定贪。已离三定贪。未离四定贪。已离四定贪。如理应思择。如说异生生在欲界。如是生在四静虑地。及诸圣者生五地中。随其所应。亦当广说。然有差别。谓诸圣者。若退不退皆无缘上染污分别。异地遍行。皆已断故。见道功德。必无退故。由此方隅。例应推究耳闻声等识及分别。傍论已了。应辩正论。今当思择。十八界中。谁六识中几识所识。几常几无常。几根几非根。颂曰

  五外二所识　　常法界无为
  法一分是根　　并内界十二

论曰。十八界中。色等五界。如其次第。眼等五识各一所识。又总皆是意识所识。如是五界。各六识中二识所识。由此准知余十三界。一切唯是意识所识。非五识身所缘境故。十八界中。无有一界全是常者。唯法一分无为是常。义准无常法余余界。十八界中。法界一分。并内十二。是根非余。谓五受根。信等五根及命根全。三无漏根。各有少分。是法界摄。眼等五根。如自名摄。女根男根。即是身界一分所摄。如后当辩。意根通是七心界摄。后三一分意意识摄。义准所余色等五界。法界一分。皆体非根。二十二根。如契经说。所谓眼根耳根鼻根舌根身根意根女根男根命根乐根苦根喜根忧根舍根信根精进根念根定根慧根未知当知根已知根具知根。经中建立六处次第。故身根后即说意根。阿毗达磨诸大论师。回此意根。置命根后。无所有缘次第说故。诸门分别易显了故

说一切有部顺正理论卷第八阿毗达磨顺正理论卷第九

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩差别品第二之一

如是因界已列诸根今于此中应更思择。世尊何故别说根名。在内界全及法一分。依增上义。别说为根。彼彼事中得增上故。此增上义。界义显成。界谓伊地。或谓忍地。最胜自在。是伊地义。照灼明了。是忍地义。唯此炽盛光显名根。此意总示二十二根。于诸聚中。作用增上。诸法相望。各各别有增上用故。应并名根。此极增上。别说义成。如师子王及村邑长转轮王等。于兽村邑四大洲等。极增上故。此极增上。谁望于谁。颂曰

  传说五于四　　四根于二种
  五八染净中　　各别为增上

论曰。非一切根总于一事为极增上。眼等五根各于四事有增上用。一庄严身。二导养身。三生识等。四不共事。庄严身者。谓五根中。随阙一根。身丑陋故。导养身者。谓因见闻。避险难故。及于段食。能受用故。香味触三。皆成段食。如有颂言

  譬如明眼人　　能避现险难
  世有聪明者　　能离当苦恶
  多闻能知法　　多闻能离罪
  多闻舍无义　　多闻得涅槃

  身由食住　　命托食存　　食已令心
  适悦安泰

生识等者。谓发五识及相应法。随所依根。有明昧故。不共事者。谓取自境。见闻嗅尝觉别境故。有说。眼耳于能守护生身法身。如其次第有增上用。前二伽他。即为此证。有说眼耳俱能守护生法二身。亲近善士。听闻正法。眼耳各为一增上故。女男命意。各于二事有增上用。且女男根二增上者。一有情异。二分别异。有情异者。劫初有情。形类皆等。二根生已。便有女男形类差别。分别异者。进止言音乳房髻等。安布差别。有说勇怯有差别故。名有情异。衣服庄严有差别故。名分别异。有说。此于染净二品。有增上力。故言于二受不律仪。起无间业。断善根故。名于染品。有增上力。能受律仪。入道得果。及离欲故。名于净品有增上力。扇搋等身。无如是事。命根于二有增上者。谓由此故。施设诸根及根差别。由此有彼有此无彼无故。或于众同分能续及能持。于无色界。要有命根。方有所生处决定故。彼起自地善染污心。或起余心。非命终故。意根于二有增上者。谓能续后有。及自在随行。能续后有者。如世尊告阿难陀言。识若不入母胎中者。精血得成羯剌蓝不。不也世尊。乃至广说。自在随行者。如契经言

  心能导世间　　心能遍摄受
  如是心一法　　皆自在随行

有说。意根于染净品有增上力。故言于二。如契经言。心杂染故。有情杂染。心清净故。有情清净。乐等五受。信等八根。于染净中有增上力。谓乐等五。于染增上。贪等随眠所依事故。有说。此于染净二品。俱有增上。说为耽嗜出离依故。乐故心定苦为信依等。契经中说故。信等八根。于净增上。如契经说我圣弟子。具信墙堑。具勤势力。具念防卫。心定解脱。慧为刀剑。乃至广说。此中即摄后三根故。彼于净品。定有增上。初传说言。显乐后说。谓或有说。能导养身。非眼等用。是识增上。要由诸识了违顺境。方能避险难。及受段食故。即彼复谓能见色等。不共功能。亦非异识。故不共事。于眼等根。不可立为别增上用。故非由此眼等成根。若尔云何。颂曰

  了自境增上　　总立于六根
  从身立二根　　女男性增上
  于同住杂染　　清净增上故
  应知命五受　　信等立为根
  未当知已知　　具知根亦尔
  于得后后道　　涅槃等增上

论曰。了自境者。谓六识身。眼等五根。于能了别各别境识。有增上用。第六意根。于能了别一切境识。有增上用。故眼等六。各立为根。然无境界亦成根失。以眼等根与能了别一切境识为通因故。识但随根有明昧故。此说非理。彼同分根。应非根故。岂不斯过汝亦有耶。我无此失。说于严身有增上故。又非一切与能了别一切色识为通因性。以诸眼根刹那灭故了诸色识。不俱生故。若言眼类无差别者。色亦应同。类无异故。若谓青黄种类别者。眼亦应尔。有异熟生及所长养类不同故。识但随根有明昧者。此亦非因。识体生已。方可得有随根明昧。未生令生增上力等。随阙一种则不生故。或识随根有明昧故。导养身义。应许在根。眼用若增。随发胜识。能避险难。导养于身。眼用若微。随发劣识。不了险难。令身颠坠。故导养身。在根非识。又于此中有何少异。前门已显。眼等诸根。发眼等识及相应法。今此门中略彼一分。非已所见。何足生欣。既无别义不应重说。又汝所言。见色等用。非异识者。此亦不然。识能见等。前已遮故。谓依眼识。非能见体。与耳等识。类无别故。如是等难。广说如前。又说从身立二根者。女男性中。有增上故。谓女性中。女根增上。于男性中。男根增上。女男性者。谓女及男。二身形类音声作业志乐各异。女男根体。不离身根。身一分中。立此名故。此处少异余处身根。谓是欲界身根一分。唯能为依。发贪俱起不善身识。故从身根。别立为二。劫初等位。虽有身根。而无女男身形等异。故应从彼别立二根。此亦未越前门中义。前说二根于有情异及分别异。有增上故。又说命根五受信等。于同分住及染净中。如其次第。有增上用。立为根者。此与前门。亦无别故。不应重述。又说无漏三根亦尔。于得后后道涅槃等。有增上用。谓第一根。于得第二有增上用。此第二根。于得第三有增上用。此第三根。于得涅槃有增上用。非离此根能证彼故。亦不异前。无劳重说。即是于净。有增上故。又经主释。亦尔言者。类显一一各能为根。亦不应理。不应疑故。由得后后道涅槃等。增上言故。别义已成。不应于中复生疑故。若言性类无差别故。应生疑者。理亦不然。见修无学。三地各异。互无相摄。不可生疑。设有生疑。得后后等。已简别故。何烦类显。虽同九根性无差别。而增上力有差别故。何容疑彼。应是一根非女男根。见此疑故。今释彼言。更有别义。谓显离九无别三根。如从身根别立男女。离身根体。无别二根。三根亦尔。虽从九根别义建立。而非离九别有三根。此释应理。经主又释。等言为显复有异门。云何异门。谓见所断。及修所断烦恼灭中。如其次第。未知当知。及已知根。有增上用。此亦不然。唯无间道名增上者。见修道中。加行解脱胜进道摄。应不名根。若通四道皆增上者。顺决择分。道类智等。于见所断烦恼灭中。有增上故。应初根摄。已知根性。应摄第三。过失众多。非为善释。今以别义。释彼等言。谓无漏慧。于诸谛理。先未现观。今得现观。有增上力。立第一根。若无漏慧。已得现观。于余烦恼渐永断中。加行希望犹未满足。有增上力。立第二根。若无漏慧。已离烦恼。于诸无漏现法乐住。有增上力。立第三根。慧为上首。具三现观。故且说慧。余八助成。理实所立根。亦通具二者。岂不此中忍于谛理已得现观。七智于中重现观故。非初根摄。又隔忍故。非第二摄。此解脱道。应不名根。已知根中。亦有谛理。先未现观。今现观故。则所立根。应成杂乱。此皆无失。见智现观。有差别故。如世间慧。于诸圣谛。已得现观。仍说无漏。先未现观。今得现观。又如苦集体虽一物。而行相别。现观有别。若于谛理。未审决者。唯见现观。若已审决。方得名为智见现观。故彼七智。亦得名为先未现观今得现观。然道类智。无同此失。虽一刹那同于七智。而后相续皆有异故。如后多念。名已知根。非见道位。七智刹那。有于谛理重现观者。故此与彼。不应同例。然尽智等。如初刹那。相续亦尔。皆能任持。金刚喻定所害烦恼。诸离系得。令相续故。经主不应同此无失。又道类智。于所观境。虽一刹那。未得现观。而于无量刹那道境。已得现观。故少从多。于一切境。皆名现观。成已知根。非度大海或妙高山余芥子量未能度故。可名于彼未得度者。此亦应然。西方诸师。说道类智。亦是未知当知根摄。若对彼释。此过全无。故我所言。无前二失。若增上故。立为根者。于爱见品诸烦恼中。受想二法。有增上用。想应如受亦立为根。又诸烦恼。于能损坏善品等中。有增上用。应成根体。又最胜故。建立诸根。一切法中。涅槃最胜。何缘不立涅槃为根。又迦比罗。语具手足。及大便处。亦立为根。于语执行及能弃舍。有增上故。如是等事。不应立根。由所许根有如是相。颂曰

  心所依此别　　此住此杂染
  此资粮此净　　由此量立根

论曰。心所依者。眼等六根。此内六处。是有情本。此相差别。由女男根。复由命根此一期住。此成杂染。由五受根。此净资粮。由信等五。此成清净。由后三根。由此立根。事皆究竟。不应更立想等为根。诸烦恼中。爱过最重。故唯立受与彼为根。爱过重者。以契经说。爱与六处为生因故。如契经说。由爱为因。六处生起。又想非见烦恼生因。余因发生颠倒见已。妄分别想。持令相续。离正对治。不可断坏。故说此想与彼为因。受为爱因。俱通二种。受为过重。烦恼因故通二因故。独立为根。有余师言。想为余法所映夺故。不立为根。谓诸善想。正慧映夺。诸染污想。颠倒映夺。非增上故。不立为根。又诸烦恼。亦非增上。受于其中成增上故。唯受于彼可立为根。或损善品。坏乐果事。下劣鄙秽。如何立根。根是世间增上法故。又于诸法。涅槃虽胜。灭诸根故。不立为根。如破诸瓶破非瓶体。又语具等。亦不名根。不定杂乱。大过失故。不定失者。何等语具。立为语根。能发言音。名为语具。此即是舌。若尔则应寻伺等法及能引起语业诸风亦立为根。能发语故。谓寻伺等。依唇齿齶咽喉等缘发起言音。非但依舌。无异因故。又寻伺等。于发言音。是胜因故。又诸手腋。管弦息等。皆能为因。发言音故。不应唯立舌为语根。若谓了色亦由言故。不应独立眼为根者。理必不然。诸生盲人。虽闻说色。不了青等差别相故。手于执取不应名根。口等亦能执取物故。足于行动不应名根。蛇鱼等类。不由于足有行动故。出大便处。于能弃舍不应名根。口等亦能有弃舍故。杂乱失者。彼所立根应成杂乱。口能执取及弃舍故。手足俱有执行用故。有如是等杂乱过失。太过失者。彼所立根。应无限量。若舌根异语根异者。应许鼻根与息根异。如舌能语鼻通息故。若此于彼少有作用。即立为根。是则咽喉齿唇肚等。于诸吞嚼摄持等事。有增上故。应立为根。或一切因。于生自果。皆增上故。应并立根。故迦比罗。如童子戏。不应许彼语具等根。非定无杂极增上故。复有余师。别说根相。颂曰

  或流转所依　　及生住受用
  建立前十四　　还灭后亦然

论曰。或言显此是余师执。彼约生死流转还灭。最胜所依。生住受用。有增上故。建立诸根。生死相续。是流转义。流转所依。谓六内处。眼等定是彼自性故。生由男女。二根为缘。彼得生故。住由命根。是彼相续不断因故。受用由受。五受为缘。损益转故。于流转中。约此四种胜作用故。立十四根。还灭位中。亦约此四胜作用故。立余八根。生死止息。是还灭义。即是六处。毕竟断灭。此得所依。谓信等五。以是一切善根生长最胜因故。初无漏根。能生此得正定聚中。此初生故。次无漏根令此得住。由彼长时相续起故。后无漏根。令得受用现法乐住。彼所显故。非业烦恼与内六处为生因故亦立为根。一一各别。无功能故。若尔眼等应亦非根。意喜乐舍。应非无漏。信等五根。应非有漏。就偏增说。可有此义。不应于中起决定执。诸业烦恼。无定不共增上用故。不立为根。已说根义及建立因。当说诸根一一自体。此中眼等乃至男根。前此品中已辩其相。谓彼识依五种净色。名眼等根。女男二根。从身一分。差别而立。命根体是不相应故。不相应中当广分别。信等体是心所法故。心所法中当广分别。乐等五受。三无漏根。更无辩处。故今应释。颂曰

  身不悦名苦　　即此悦名乐
  及三定心悦　　余处此名喜
  心不悦名忧　　中舍二无别
  见修无学道　　依九立三根

论曰。身谓身受。依身起故。即五识相应受言不悦者。是损恼义。于五识俱领触受内。能损恼者。名为苦根。所言悦者。是摄益义。即五识俱领触受内。能摄益者。名为乐根。初静虑中。三识俱乐。亦此所摄。种类同故。第三静虑。意识俱受。能摄益者。亦名乐根。彼地更无余识身故。即意俱悦。立为乐根。意识俱生悦受有二在第三定。说名为乐。由此地中离喜贪故。除第三定。下三地中。说名喜根。有喜贪故。此二心悦。摄益义同。行相何殊。分为喜乐。由行相转有差别故。若有心悦。安静行转。名为乐根。若有心悦粗动行转。名为喜根。或复乐根摄益殊胜。喜根摄益则不如是。由此第三静虑地乐。诸圣说为所耽着处。与意识俱能损恼受。是心不悦。名曰忧根。已约身心悦不悦受。行相差别。立四受根。所言中舍二无别者。中是非悦非不悦义。即不苦乐。说名舍根。身心受中。此定何受。应言此受通在身心。苦乐何缘各分为二。不苦不乐唯立一根。此在身心无差别故。谓心苦乐多分躁动。苦乐在身。则为安住。不苦不乐。在身在心。行相无差。唯安住故又心苦乐。多分别生。在身不然。随境力故。阿罗汉等。亦如是生。舍在身心。俱无分别。处中行相。任运而起。又苦乐受。在身在心。于怨于亲。行相转异。不苦不乐。在身在心。于中庸境。行相无异。是故苦乐。各分为二。不苦不乐。唯立一根。已释乐等诸受根体。三无漏根。今次应释。不可一一别说其体。应就三道依九总立。意乐喜舍信等五根。此九三道中。即是三无漏。谓在见道。意等九法。即是未知当知根体。未知当知行相转故。若在修道。意等九法。即是第二。已知根体。为欲断除余随眠故。于已知境。数复了知。在无学道。意等九法。即是第三。具知根体。知已已知。故名为知。习知成性故。或能护知故。名为具知。九根相应。合成此事。故意等八。亦得此名。如是根名。虽二十二。而诸根体。但有十七。女男二根。身根摄故。三无漏根。九根摄故。如是已释根体不同。当辩诸门义类差别。此二十二根中。几有漏几无漏。颂曰

  唯无漏后三　　有色命忧苦
  当知唯有漏　　通二余九根

论曰。次前所说。最后三根。体唯无漏。是无垢义。垢之与漏。名异体同。七有色根。命及忧苦。一向有漏。七有色者。眼耳鼻舌身女男根。色蕴摄故。九通二者。即前所说三无漏摄。意等九根。名为无漏。余意等九。是名有漏。有余师说。信等五根。亦唯无漏。契经唯说圣所有故。又世尊说。若全无此信等五根。我说彼住外异生品。此非诚证。依无漏根说此言故。云何知然。先依无漏信等五根。建立诸圣位差别已。说此言故。全无此者。此即此前所说。无漏信等根义。若不尔者。唯应说言无信等根。不应言此。或诸异生。略有二种。一内二外。内谓不断善根。外谓善根已断。依外异生。作如是说。若全无此信等五根。我说彼住外异生品。为有契经证信等五通有漏不。亦有。云何。谓世尊说。我若于此信等五根。未如实知。是集没味过患出离。未能超此天人世间及魔梵等。乃至未能证得阿耨多罗三藐三菩提。乃至广说。非无漏法应作如是次第观察。又说佛未转法轮时。先以佛眼。遍观世界。有诸有情。处在世间。或生或长。有上中下诸根差别。未转法轮。世间已有无漏根者。如来出世。则为唐捐。若汝于此所引二经。异分别者。我当复以殊胜分别如理遮遣。故信等根。定通有漏。如是已说有漏无漏。二十二根中。几是异熟几非异熟。颂曰

  命唯是异熟　　忧及后八非
  色意余四受　　一一皆通二

论曰。且无分别此诸根中。唯一命根。定是异熟。如何此命。可无分别。定果命根。非异熟故。如是命根。亦是异熟。得边际定应果苾刍。于僧众中或别人所。施思果故。诸我能感富异熟业。愿皆转招寿异熟果。本论说故。有余说。彼由边际定力。引取前生顺不定受业。所感寿命。令现受用。复有欲令边际定力引前生业残异熟果。而经主言。由胜定力。引取未曾诸根大种住时势分。如此命根。非是异熟。余是异熟。此言非理。所以者何。且彼唯说。诸根大种。住时势分。名为命根。如后当破。设许如是随执彼为长养等性。皆不应理。且不应执是长养性。彼能防守异熟果故。所防异熟。已转尽故。不应异熟相续断已。独有长养。太过失故。亦不应执是等流性。眼等无别等流性故。无记非善等流果故。又界应成杂乱过故。亦不应执是异熟性。定非欲界异熟因故。又彼自许如是事故。然其所说迷谬难详。任更指陈。彼名何法。而言此命非异熟耶。尊者法胜说。此命根亦非异熟。故彼论说。有十三根。皆通二种。此违本论。一根非业是业异熟九根非业。非业异熟。十二不定。忧根及后信等八根。皆非异熟。是有记故。经说有业顺忧受者。依受相应。言顺无过。如言有触顺乐受等何缘定谓忧非异熟此是异熟。不应理故。云何不应。离欲贪者。不随转故。异熟不然。设许随转。应如苦根。阿罗汉等。亦可知有。而实非有。经所遮故。如契经说。设见大师般涅槃位亦无愁等。又无用故。善亦不行。非能摄益。如喜根故。何相知彼有无记喜。彼时虽无。外相而有。内分别生。或彼善喜。容有现行。非善忧根。彼可现起。应随善相准知无记。非无记喜。违离欲道。又阿笈摩。证彼有喜。如契经说。彼犹受喜异熟。不言彼有黑品忧根。故知忧根越异熟法。余根通二义准已成。谓七色意根。除忧余四受。十二一一皆通二类。七有色根。若所长养则非异熟。余皆异熟。意及四受。若善染污。若威仪路。及工巧处。并能变化。随其所应。亦非异熟。余皆异熟。如是已说是异熟等。二十二根中。几有异熟几无异熟。颂曰

  忧定有异熟　　前八后三无
  意余受信等　　一一皆通二

论曰。如前所诤。忧根当知定有异熟。定言意显唯有非无遮非异熟因无记无漏故。非为显示唯此忧根是有异熟。勿有余根一切皆是无异熟过。故但显忧唯有异熟。越次说者。显无记无漏若总若别皆无异熟因。非如此中有记有漏要总方是有异熟因。故越次说。深为有用。眼等前八。及最后三。此十一根。定无异熟。八无记故。三无漏故。余皆通二。义准已成。谓意根余四受。信等言等取精进等四根。此十一一皆通二类。意乐喜舍。若不善善有漏有异熟。若无记无漏无异熟。苦根若善不善有异熟。若无记无异熟。信等五根。若有漏有异熟。若无漏无异熟。如是已说有异熟等。二十二根中。几善几不善几无记。颂曰

  唯善后八根　　忧通善不善
  意余受三种　　前八唯无记

论曰。信等五根。及三无漏。一向是善。次虽居后。乘前便故。而说在初。忧根唯通善不善性。意及四受。皆通三性。眼等八根。唯是无记。如是已说善不善等。二十二根中。几欲界系几色界系几无色界系。颂曰

  欲色无色界　　如次除后三
  兼女男忧苦　　并余色喜乐

论曰。欲界除后三无漏根。由彼三根唯不系故。准知欲界系。有余十九根。色界如前除三无漏。兼除男女忧苦四根。准知十五根。亦通色界系。除女男者。色界已离淫欲法故。除此无因须受用故。有说由此身丑陋故。此说不然。阴藏隐密非丑陋故。前说为善。然佛置彼在男品中。如契经说。无处无容女身为梵。有处有容男为梵者离欲威猛似男用故。如有称赞大梵王言

  大梵如丈夫　　所得皆已得
  离欲道威猛　　故说为丈夫

除苦根者。色界中无损害事故。苦是损害业异熟故。有说彼身极净妙故。除忧根者。彼处无有违逆相故。又奢摩他润相续故。有说色界具离欲智。忧是无智等流果故。无色如前除三无漏女男忧苦。并除五色及喜乐根准知余八根。通无色界系。如是已说欲界系等。二十二根中。几见所断几修所断几非所断。颂曰

  意三受通三　　忧见修所断
  九唯修所断　　五修非三非

论曰。意喜乐舍。一一通三。忧根唯通见修所断。非无漏故。七色命苦。唯修所断。有色无染非六生故。非无漏故。信等五根。或修所断。或非所断。通善有漏及无漏故。最后三根。唯非所断。皆是无漏无过法故。岂不圣道亦所断耶。如契经言。应知圣道犹如船筏。法尚应断何况非法。此非见修二道所断。入无余依涅槃界位舍故名断。已说诸门义类差别。当说初得异熟诸根。几异熟根何界初得。须问初得异熟根者。遮无染心能续生故。颂曰

  欲胎卵湿生　　初得二异熟
  化生六七八　　色六上唯命

论曰。欲胎卵湿生。初受生位。唯得身与命二异熟根。观行者言。此初生位。亦有具得眼等种子。然但身根。能生自识。眼等不尔。故唯说二。或生盲等。于续生时。无眼等根。但有此二。此言非理。所以者何。初续生时。无五识故。举胎卵湿。显除化生。化生色根。无渐起故。此辩异熟。不说意舍时彼定染非异熟故。尔时亦得信等诸根。非异熟故。此中不说羯赖蓝位。虽得色等异熟生法。而体非根。故此不说。化生初位。得六七八。无形得六。如劫初时。六谓眼耳鼻舌身命。一形得七。如诸天等。二形得八。恶趣容有二形化生。色初得六。如欲化生无形者说。上唯命者。谓无色界。定生俱胜。故名为上。彼初唯得异熟命根。由此证知命根实有。此若非有。为得何根名生无色。非善染污名业果生。未受彼生容现起故。又异熟心无续生理。唯许染心能续生故。过去未来非有论者。尔时三世异熟皆无。异熟既无。生依何说。虽驰妄计以立己宗。必应许有生依实法。说异熟根最初得已。当说最后所灭诸根。何界死时几根后灭。颂曰

  正死灭诸根　　无色三色八
  欲顿十九八　　渐四善增五

论曰。且说染污及无记心正命终时根灭多少。谓无色界将命终时。命意舍三。于最后灭。无色唯有舍受非余。又无色言。遮彼有色。有余师说。彼有色故。若不说有实物命根。何异。熟断名无色死。若言异熟四蕴断故彼名死者。善染污心现在前位。应亦名死。若言彼地所受异熟犹未尽者。如何不受而有尽期。善染污心现在前位。当言彼受何业异熟。非不现前可名为受。若谓于彼异熟习气恒随转故名为受者。理亦不然。所执习气。非极成故。太过失故。异熟虽尽。习气随故。如业习气。应无死期。若异熟尽。无习气者。业亦不应有余习气。若言习气望现异熟如我得者。应如我得异熟不起习气则无。又非异熟习气随转名受异熟。非彼性故。又汝所执习气理无。后当广辩。故定应许。从续生心至命终心别有实法。名为异熟恒相续转。彼若断时。名无色死。色界死时。八根后灭。谓眼等五。及前三根。化生生死根无缺故。欲顿死时。十九八灭。二形十灭。谓女男根及前说八。一形九灭。无形八灭。若渐死时。身命意舍四根后灭。此四必无前后灭义。若在三界。善心死时。一切位中。数各增五。善心必具信等根故。谓于无色。增至八根乃至欲界渐终至九。复应思择。二十二根。几能证得何沙门果。虽沙门果非根亦得。此辩根故。但问诸根。颂曰

  九得边二果　　七八九中二
  十一阿罗汉　　依一容有说

论曰。边谓预流阿罗汉果。中谓一来及不还果。且预流果。由九根得。谓意舍信等初二无漏根。此果与向。未至地摄。故唯有舍。云何此由已知根得。由离系得与解脱道俱时起故。若尔何缘唯说无间道能得离系果。唯此能断离系得生能障得故。由此故说。彼离系得。唯是无间道等流士用果。若尔解脱道。于果及得。有何功能。离系及能得。由无间道。非此果故。有说无间道是解脱道眷属故。无间道所作。即名解脱道所作。如臣所作得王作名。西方诸师说。解脱道于离系得能作证故。此说不然。离系应是彼道果故。后当广辩。今且略释。虽解脱道于沙门果非同类因。而是相应俱有因故。名得彼果。亦无有失。以沙门体更互相依而得生故。展转相望。为士用果谁复能遮。若言加行无间胜进应亦尔者。许亦无失。或已知根。亦为同类因。能得预流果。谓转根时。如阿罗汉。就容有说。亦无有过。阿罗汉果。亦九根得。谓意信等后二无漏。乐喜舍中随取一种。此果及向。通九地摄。故于三受随取其一。中间二果。一一皆通七八九得。世出世道次第超越。证差别故。且一来果次第证者。依世间道。由七根得。谓意及舍信等五根。依出世道。由八根得。谓即前七根已知根第八。倍离欲贪超越证者。如预流果。由九根得。证不还果。应知亦尔。总例虽然。而有差别。全离欲贪超越证者依地别故。三受随一。次第证者。若于第九解脱道中。入根本地。依世间道。由八根得。喜为第八。依出世道。由九根得。已知第九。若阿罗汉。亦九根得。违发智论。彼问几根得阿罗汉。答十一故。三受定无俱时起故。但由九得。言十一根。依容有说。谓容有一补特伽罗。从无学位数数退已。由乐喜舍数复还得。非不还果有同此失。次第无容乐根得故。超越无容有退失故。复应思择。成就何根。彼诸根中。几定成就。颂曰

  成就命意舍　　各定成就三
  若成就乐身　　各定成就四
  成眼等及喜　　各定成五根
  若成就苦根　　彼定成就七
  若成女男忧　　信等各成八
  二无漏十一　　初无漏十三

论曰。命意舍中。随成就一。彼定成就如是三根。非此三中有阙成就。皆遍一切地及依故。信等五根。遍一切地。非一切依。余十四根二俱非遍。故成命等。唯定成三。余或成就或不成就。云何成就眼等四根。生色界全欲界少分身根生。在欲色界全女男生。在欲界少分乐根生。在欲下三定及圣生上喜根生。在欲下二定及圣生上苦生。欲界全忧欲贪未离。信等五根若不断善。三无漏根已得未舍。如是诸位。各定成就。除此余位定不成就。若成乐根定成就四。谓命意舍乐。若成身根。亦定成四。谓命意舍身。余或成就。或不成就。如前应思。若成眼根。定成就五。谓命意舍。身根眼根。耳鼻舌根。应知亦五。前四如眼。第五自根。若成喜根。亦定成五。谓命意舍乐根喜根。生第二定。未离彼贪。但成第三染污乐受。若成苦根。定成就七。谓身命意四受除忧。若成女根定成就八。七如苦说。第八女根。男忧亦八。七如苦说。第八自根。信等亦八。谓命意舍信等五根。若女男俱成。彼定成十五若成具知根。定成就十一。谓命与意乐喜舍根信第五根及具知根已知根亦尔。自根等十一。若成未知根。定成就十三。谓身命意苦乐喜舍信等五根及未知根。渐命终位。传说深心厌生死故。能入见道。如是已说位定成就补特伽罗定成。当说诸极少者成就几根。颂曰

  极少八无善　　成受身命意
  愚生无色界　　成善命意舍

论曰。已断善根。名为无善。彼若极少成就八根。谓五受根。及身命意。据渐舍命。唯余身根。愚谓异生。未见谛故。彼生无色。亦成八根。谓信等五。及命意舍。由定数故。及说愚故。善言不滥三无漏根。诸极多者成就几根。颂曰

  极多成十九　　二形除三净
  圣者未离欲　　除二净一形

论曰。诸二形者。具眼等根。除三无漏。成余十九。无漏名净。离二缚故。若圣有学。未离欲贪。成就极多。亦具十九。除二无漏。及除一形。二无漏者。谓具知根。前二随一言一形者。无有二形及与无形。得圣法故

说一切有部顺正理论卷第九阿毗达磨顺正理论卷第十

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩差别品第二之二

因分别界。已广辩根诸行俱生。今应思择。何缘思择诸行俱生。为遣邪宗显正理故。谓或有执。诸行无因自然而起。或复有执。由一因故诸行得生。或复有执。由自性等。不平等因。而生诸行。或复有执。诸行生时。唯用前生。为因故起。为遣此等种种邪宗显生正理。故应思择。此中诸行。略有二种。一有色。二无色。无色有三。一心。二心所。三心不相应行。有色有二。一是极微聚。二非极微聚。初极微聚复有二种。一欲界系。二色界系。初欲界系。复有二种。一无根聚。二有根聚。此中且辩极微聚色。颂曰

  欲微聚无声　　无根有八事
  有身根九事　　十事有余根

论曰。有对色中。最后细分。更不可析。名曰极微。谓此极微。更不可以余色觉慧分析为多。此即说为色之极少。更无分故。立极少名。如一刹那名时极少。更不可析为半刹那。如是众微。展转和合。定不离者。说为微聚。此在欲界。无声无根八事俱生。随一不减。云何八事。谓四大种。及四所造。色香味触。此若有声。即成九事。而不说者。显因大种相击故生。非如色等恒时有故。无声有根。诸极微聚。此俱生事。或九或十。有身根聚。九事俱生。八事如前。身为第九。有余根聚。十事俱生。九事如身。加眼等一。眼耳鼻舌。必不离身。依身转故。四根展转相离而生。处各别故。此有根聚。若有声生。加所生声。成十十一。此有执受大种为因。故与诸根不相离起。不说所以。如前应知。色界唯除香味二事。余同欲界。故不别说。若谓事言依体依处。太少太多。成过失者。所依能依。依体依处。差别说故。无有过失。谓所依事。依体而说。若能依事。依处而说。或唯依体。亦无有失。由此中说定俱生故。形色等体。非决定有。光明等中。则无有故。或唯依处。然为遮遣多诽谤故。别说大种。多诽谤者谓或谤言。大种造色。无别有性。或复谤言。无别触处所造色体。或复谤言。非一切聚皆具一切。或复谤言。数不决定。别说大种。此谤皆除。若言大种各各别生造色果故。应成多者。其理不然约类说故。已说有色决定俱生。无色俱生今次当说。颂曰

  心心所必俱　　诸行相或得

论曰。心与心所必定俱生。随阙一时余曾不起。诸行即是一切有为。所谓有色无色诸行。前必俱言应流至此。谓有色等诸行生时。必与生等四相俱起。言或得者。谓诸行内。唯有情法。与得俱生。或言显此不遍诸行。于前所说四有为中。广辩色心如前品说。心所等法犹未广辩。今先广辩诸心所法。颂曰

  心所且有五　　大地法等异

论曰。诸心所法。且有五品。大地法等。有别异故。此复云何。一大地法。二大善地法。三大烦恼地法。四大不善地法。五小烦恼地法。地谓容止处。或谓所行处。若此是彼容止所行。即说此为彼法之地。地即是心。大法地故。名为大地。此中若法。大地所有名大地法。谓法遍与一切品类一切心俱。生由此故。心非大地法。非心俱生故。彼法是何。颂曰

  受想思触欲　　慧念与作意
  胜解三摩地　　遍于一切心

论曰。于所依身。能益能损。或俱相违。领爱非爱俱相违触。说名为受。安立执取男女等境差别相因。说名为想。令心造作善不善无记成妙劣中性说名为思。由有思故。令心于境有动作用。犹如磁石势力能令铁有动用。由根境识和合而生。能为受因。有所触对。说名为触。希求取境。说名为欲。简择所缘邪正等相。说名为慧。于境明记不忘失因。说名为念。引心心所。令于所缘有所警觉。说名作意。此即世间说为留意。于境印可。说名胜解。有余师言。胜谓增胜。解谓解脱。此能令心。于境无碍自在而转。如胜戒等。令心无乱。取所缘境。不流散因。名三摩地。彼上座言。无如所计十大地法。此但三种。经说俱起受想思故。岂不彼经亦说有触。如彼经言。三和合触。经虽言有触。不说有别体。故彼经言。如是三法聚集和合。说名为触。故无如所计十大地法性。此言非理。由彼经言。义准有触。理得成故。佛于彼经。非说触相。但说生触和合众缘谓彼经中说名触者。触缘名触。非实触相。和合所生。乃名实触云何知彼不说触相。但说触缘。余契经中。别说眼等为触缘故。谓有经言。六处缘触。伽他中说。二为触缘。故知三和。触缘非触。不应谓彼更互为缘。三皆触缘亦即触相。以眼与色是眼识缘。眼识不为眼色缘故。设许三法更互为缘。触是有缘。非即缘故。应离眼等三和合缘别有所生真实触相。于能生触三种近缘。假说触名。非实触相。眼色与触。能为缘者。谓作所依所缘性故。眼识与触。能为缘者。谓作一果不离依故。是故于彼假说触名。然彼所言。眼等相望互为因果。和合名触。此亦非理。义不成故。非彼宗中不许俱起。互为因果义可得成。有非有故。相续异故。非一果故。设许三法互为因果。彼不应说与触为缘。以彼宗中触无实故。现见说有与有为缘。如受与爱眼色与识。然说眼等与触为缘。缘既实有。果亦应尔。由是证知。别有实触。既许三法互为因果名为和合。彼亦应许从三和合别有触生。由此故言。六处缘触。伽他亦说。二为触缘。若异此者。既无实法。可名和合。即此三中。假施设故。又彼三法。非互为缘。无和合义。如何可立彼为触缘。若谓如说瓶衣等物色等为缘。然离色等。无瓶等物。此亦应尔。若尔受等。应无别物。如说受等。眼色为缘受等亦应。非离眼等若言触相。非显了故。谓如受等别相显了。触无如是别相可取。但由思构知有此法。故离三和。无别触体。此亦不然。触体实有。以有用故。如眼等根。谓眼等根。虽非现见。能取境故。知有自体。又如思等。虽非现见。但由思构。知有此法。谓有能成意业等用。由此用故。知有自体。若心所法现可见者。应无有执彼即是心触亦应然。虽非现见。以有用故。知有自体。又曾未见诸圣教中于无体法说有别用。唯于有体。说有用言。既于触中。说为有用。故知彼触。别有自体。若言眼等六处差别即能生受。无别触用。谓即内处与外境俱。能发生识互为因果。和合名触。此即生受。故于此中。无别触用。此言非理。先已说故。又经重言应无用故。又爱等应有即受等过故。谓先已说。非彼宗中不许俱起互为因果。义可成等。又经重言。三和合触。应成无用。谓经先说眼色为缘生于眼识。由此眼等体及因果。其义已成。复说俱起受想思故。即分明证。眼等因果和合生彼。是则重言三和合触。定应无用。由先所言眼等因果义已成故。岂不若说眼等因果和合而生别体触者。三和合言。亦成无用。经但应说眼色为缘生于眼识。次说俱起受想思言。由此眼等。因果相仍义已成故。不尔此言更有余义。我等不说三和合言。为成眼等为因果义。若尔此言为成何义。此专为成别有触义。谓眼色识三俱起时。眼不待二。色亦如是。识生必托所依所缘。故眼识生。要待余二。诸心所法生时。亦待所依所缘。然彼所依。复有二种。一是和合所依谓识。二是相离所依谓眼。或识是彼亲密所依眼根是彼系属所依。所缘即是彼所取境。故彼生时。必待三法。眼及色为缘生于眼识者。谓眼与色和合为缘生于眼识。即是俱时。不增不减。共为缘义。次后经复言三和合触者。谓眼色识和合为缘。生于眼触。亦是俱时。不增不减。共为缘义。若谓和合言是共为缘义。则应触体三法合成。岂更有余实体触者。此亦非理。眼色识三。无有展转为缘义故。然说一切共为缘故。由斯触体别有义成。若尔应言三和合故触。不尔为遮疑。后时生故。说第五声。便疑后起。应如经说。曼驮多王。恶心起故。俱时堕落。若尔何缘契经但说六处缘触。受等亦用彼为缘故。不尔何缘契经但说触为缘受。受亦为缘生于触故。此既如是。彼亦应然辩缘起中。当为汝释。如是且随对法正理。释经中句。是有用言。非如上座随情解释三和合言于义无用。又若缘触和合生于受。遂谓触即六处之差别。如是缘爱和合生于取。应谓爱即是受之差别。此既不然。彼云何尔。或应说彼与此别因。先已成立。触有自体。故不应谓触即三和。又触实有。契经说为心所法故。如受想等。谓薄伽梵。于契经中。说触以为心所法性。非无实法。可名心所。故如受等。触应有实。如伽他言

  眼色二为缘　　生诸心所法
  识触俱受想　　诸行摄有因

上座释此伽他义言。说心所者。次第义故。说识言故。不离识故。无别有触。次第义者。据生次第。谓从眼色生于识触。从此复生诸心所法。俱生受等。名心所法。触非心所。说识言者。谓于此中。现见说识。故触是心。非心所法。不离识者。谓不离识而可有触。识前定无和合义故。假名心所。而无别体。今谓三证。理并不然。初次第义。且不应理。眼色无间不说识故。复作是言。谓从眼色生于识触。从此复生受等心所。若尔有何余心所法二缘所生。世尊经中。分明显说。诸心所法。从二缘起。非在第三。我等于中。说诸心所亦二缘起。非在第三。上座于中起异分别。说诸心所唯在第三。是则陵蔑如来。或是不达经义。次说识言。亦不应理。岂见说识便无心所。此伽他中。非唯辩识。然不可以心所法言不属识故。亦非受等。应可说言。受等诸法。亦非心所。所以者何。现见此中说识言故。虽说识言。而许受等是心所者。触亦应然。彼后所言。谓不离识而可有触。识前定无和合义故。假名心所。无别体者。亦不应理。依心所门。说触言故。前说心所从二缘生。今乘彼门。列触等相。非仍前识。宁无别体。应如受等。定别有性。虽触生时。实不离识而不应说即识为体。以识生时亦不离触。及受想等心。亦应用心所为性但假名心。心既不然。触云何尔。又不离言义不成故。谓即依识假立触名。言不离者。此不成就。若不离言。是相因义。识亦不离受等心所。应如前说。但假名心。若言此难亦同不成。谓识不离受等心所。应即受等。但假名心。此亦非理。以极成故。谓契经说。心与受等心所俱生。不相离故。又伽他义证此极成。谓眼色二缘共生诸心所。为但心所二缘所生。不尔云何亦生于识。识即是心。由此成立眼色二缘能生一切心心所法。非但生心。虽已总标诸心所法二缘所生。而未别显。何者是耶。故复言触。触是受因。是故先说为彼二缘先生心所。后方生识。不尔云何故复言俱。是俱起义。诸心所者。诸是多言。已举一触。余是何等。故言受想及诸行摄。此显受等与前识触决定俱生。诸行摄者。总摄一切行蕴所收诸心所法。若不尔者。应但说思。不应言诸思是一故。为摄何义。复说有因。为摄与前俱有诸法。不相离故。与彼俱生。即彼为因。不由眼色此无所依及所缘故。有作是释。此有因言。显心心所皆从缘起。此释不然。前说眼色二缘所生。应无用故。复有别释言。有因者。显心心所有同类因。何者同类因。谓前生同类眼色。与彼非同类故。但说为缘。前生同类。如种子故。说之为因。又世尊言。眼是生识。邻近缘故。亦说为因。诸心所法。亦以眼根为缘生故。说名有因。前缘后因。无重说过。如是正释伽他义已。前言此难亦同不成。谓识不离受等心所。应即受等但假名心。彼言非理。由此中说心心所法俱时起故。显识生时。不离触等。是故前说。虽触生时。实不离识。而不应说即识为体。以识生时亦不离触及受想等。心亦应用心所为性。但假名心。理极成立。由此彼言。谓不离识而可有触识前定无和合义故。假名心所。无别体者。此但有言都不应理。由彼三证理并不然。是故前言触体实有。契经说为心所法故。如受想等。其理极成。故应信知。离根境识三和合外别有实触。又触实有。契经说为食所摄故。犹如识等。此中上座复作是言。四食中触。未必唯用三和为体。所以者何。触食应用所触为体。以六境中无如所触。更无所待。能生受者。谓胜冷热锯割等触。故于一切身受因中。触最增强。别立为食。由触门故。便于三受。皆能离染。其理得成。彼言但从自分别起。且彼三和。决定非触。如何是食。或复是余此何所疑。而称未必。但应舒意确判言非。若如段食。复有何过。谓如段食。非一法成。虽多法成。而得名一。触食亦尔。三和合成。斯有何过。此喻非理。一一亦成段食性故。非彼眼等一一各别可名三和成触食体。又根境识。摄法无遗。段食等三。皆应触摄。食应唯一。世尊不应于契经中说食有四。识食摄在根及识中。段及意思体非离境。说触食已。复说余三。便显世尊言成无用。故有智者。于说三和为触食言。不应信受。又说所触为触食体理亦不然。于段食中。已说所触为彼体故。又彼断时说断三受。理不成故。谓段食中。已摄所触。三处合成段食性故。触食若所触食应唯有三。又说触食断遍知时。三受永断然于有顶。得离染时。断诸受尽。非于所触。得离染时。可于诸受有永断义。又于缘起次第义中。所说受缘。应是触食。彼触断时。诸受应断。非由所触断故彼断。诸圣教中。都未曾见说彼所触与受为缘。故受断时。非由所触。又说所触更无所待能生受言。深可嗤笑。既许所触。灭入过去。第三刹那。受方得起。是则所触于受起时。体灭时隔。有何生用。由彼义宗。根境无间。识方得起。从识无间。受乃得生。身受生时。身及所触。其体已灭。时复隔远。何得为因。且识生时。身触已灭。望无间识。缘用尚无。况于后时所起身受。时分隔越。得有缘用。若言先有根境识三因果性故。受方得起。是故根境。于受起时。亦有展转能生功用。如是便应有太过失。谓要先有名色六处。因果性故。触乃得生。是则应言名色缘触。或复应说六处缘受。以受起时。彼有用故。诸说分位缘起论者。虽受起时。亦缘六处。而曾不说六处缘受。设许所触能生于受。如何可言更无所待。若彼生受不待根识。木石等中。何不生受。若彼要待根识等缘。方生受者。余境亦尔。云何不说。以六境中无如所触更无所待能生受者。此与余境有何差别。而偏赞美。为生受因。决定无有根境识三共和合时。而不生受。故彼所说。无理可依。但从自心分别所起。又彼具寿。如何可言厌于劣界离妙界染。不可厌余得离余染。勿离余染余得解脱。彼此别因。不可得故。即由此理。苦集法智。不能兼离色无色贪。诸胜冷热锯割等触。上界所无。故知意取欲界所触。为触食性。故彼所言。由触门故。便于三受皆能离染。理不得成。又契经说。触食断时。三受永断。故知佛说触与三受俱时永断。契经不说触食断已当断三受。故不应言由断触故当于三受皆能离贪。说触断时受亦断故非。于欲界得离染时可于有顶亦得离染。故知别有一法名触。是受近因。断有顶时。此触方断由此断故。三受永断。此后更无诸所应作。故心所中。定有实触。名为触食。其理得成。古昔诸师。为证此触其体实有。亦立多因上座于中。怀增上慢。自谓能释。如是诸因。我当于中褒贬德失。古师所立诸因者何。谓彼咸言。触定实有。说有因果。杂染离染各别断除差别言故。如受想等。此中说有因果言者。谓说此触有六处因有受果故。非世俗法而可说有胜义因果。说有杂染离染言者。谓佛于彼大六处经。说如是言若有于眼不如实见不如实知。便于眼中起诸杂染。如是若有于色于眼识于眼触。广说乃至。便于意触起诸杂染。与此相违。便得离染。非于假法而可说有杂染离染。说有各别言者。谓佛于彼六六经中。说如是言。有六内处六外处六识身六触身六受身六爱身各各差别。此契经中。根境识外。别说有触。不可于彼假及所依各别而说。说有断除言者。谓契经说。触食断时。三受永断。非由见于世俗法故名如实见。及说圣道安住所缘。说有差别言者。谓于假法所依事中。亦有一一差别言说。如言我见瓶衣色等。此亦应尔。是则应说十八触身。然不如是。故知触体。非即三和。彼上座言。三和名触。于如是义。亦不相违。所以者何。如名色等。亦有如是所说义故。眼等因果和合触中。于上义门。都无违害。如彼说有因果言者。谓彼眼等因果合触。六处为因。受为其果。离内六处。无三和故。从三和生乐苦等故。说有杂染杂染言者。谓三和触。为受因故。希求方便。生诸杂染。彼于尔时。愿生自识。为辩此门领纳差别。举所依根及所取境。即于此事。如实见知。便得离染。说有各别言者。谓辩眼等因果合性。为受起因从此生爱。非诸眼色皆眼识因。非诸眼识皆眼色果。又如重担与荷担者。离取蕴担。虽无荷者。而契经中。各别显说。此亦应尔。说有断除言者。谓断杂染故。前说希求方便生诸杂染。今说断彼杂染即名断触。见称事故。名如实见。及说圣道安住所缘。说有差别言者。谓三和触。非一合故。不可如瓶等说一有众分。如名色等。亦有如是所说义者。谓如名色六处等支。非一法成。虽非实有。而有如上所说诸义。此亦应然。故无有失。如是一切理皆不成。且彼眼等因果和合。说名为触。如先已破。谓先已说。非彼宗中不许俱起互为因果义可成等。如是所执。后更当破。又眼色等因果和合。于受何为非唯因果合即能有所生。如先已辩。又契经说。眼色为因。生受等果。如是因果。应合生识及为触缘。或于此中。应说差别。若言无处如是说故。谓世尊言。眼色为缘。生于眼识。三和合触。无处说言。眼色为因。生受等果。可言如是因果和合生识及触。是故不应如是说者。此亦非理。有处说故。即此经说。受等俱生。此俱生言。显与识等同时起义。后当成立。然彼经说。眼色为缘。生眼识者。由识是彼受等所依。相用强故。世尊虑有执眼色缘唯生眼识。故此经说。眼色为因。生受等果。又伽他说。眼色二缘。生诸心所。足为明证。故眼色缘。非唯生识。唯执眼等因果合故。名触生受。理定不然。假法无能及不定故。所言眼等因果合触。六处为因。离内六处无三和者。理亦不然。岂不离境及识随一。亦无三和。非诸假法三事合成。于所依中。随阙一种。而得有假。犹如伊字。说触为实心所法者。虽依根境及识而生。然内六处。生用最胜。为胜生因及所依故。所以偏说。即由如是殊胜所依。标六触名。谓眼等触假法用既无。如何生受果。言三和触为受因故。希求方便生杂染者。重言无用。已别说故。谓前已说。于眼于色于眼识中。起诸杂染。离三法外。复有何触。而后重说于眼触言。若谓此言重说眼等三法因果和合性者。是则不应但言眼触如眼识及色非独依彼故。眼色识三同作假触所依止性。等无差别。唯言眼触。不言色触及眼识触。此有何因。又彼所宗。由眼及色。生于眼识。后方生受。眼识为受等无间缘。邻近所依。非眼非色。是则唯应说名识触。如何反说为眼触耶。若谓有无定相随故。谓若有彼眼等六处。有眼等触。彼无触无如生盲等。无眼等触由此经言六处缘触。以有根者色识合时。便说有触。非无根故。此亦不然。见有虽得眼等六处。而或有时诸识不起。则无有触。如在无想灭尽定等。彼位无心。后当成立。故约有无定相随者。唯应依识以摽触名。又心所言。彼应忆念。触若定随根有无者。应名根所非心所法。又生盲等。若住意地。有心位中。既有身根。更何所阙。身触不起。非有身识。身触不生。见有身根。而无身触。应知彼触随识有无。不随根境识是生触。强胜因故。应随识说。然诸契经。说眼等触。知别有触体。是心所依眼等故。如眼等识名随依说。其理极成。故不应言眼等六触眼等因果和合为性。如别有触虽依识生而说眼触。我亦然者。其理不然。就胜因依说触名故。或复略去中间言故。或说所依。所依眼故。又契经言。于眼于色于眼识中。起诸杂染。由此已说眼色识三因果合性。以根境识随相系属次第说故。若异此者。应次第说眼等六根六境六识又契经说。于眼触中起杂染者。此言何义。若谓此言显于眼等因果合性起杂染义。此义非理。由次第说根境识三。已显彼故。或契经说。于眼识中。起诸杂染。即已成立。眼色识三因果合性。非无根境而有识故。于识起染。即于三和。岂不前言。非诸眼识皆眼色果。虽前有言。而无实义。故不成救。彼无眼识非眼色果。以执唯有现在法故。或复应说。彼识是何。若识有时眼色无故。非彼果者。则因果性。毕竟应无。执非并故。既诸眼识。皆眼色果。则于眼识起杂染言。便已成立。眼色识三因果合性。何须重说。此由汝等于法性相不善度量。辄率己情。释佛经义。致斯迷惑。是故汝等。应更精勤于法性相求无倒解。言彼尔时愿生自识为辩此门领纳差别。举所依根所取境者。识且可尔。根境应思。彼二云何令受差别。如前已辩。彼受起时。根境体灭。无生用故。杂染既有过离染亦不成。如破彼说杂染道理。准此应破彼各别言。谓辩眼等因果合性为受起因。及生爱等。所立重担荷担者喻。于证彼义。无所堪能。以有未来五取蕴性。名为重担。非荷担者。现在取蕴名荷者故。如契经言

  已舍于重担　　后不复更取
  取重担为苦　　舍重担为乐

此有荷者异于重担。彼无触性离根境识。故所立喻。于义无能。有余别释此各别言。非别说故。则别有体。如外处中第六法处已摄六受及六爱身。虽别建立。而无别体。如是虽无根境识外六触身体。而亦别说六种触身。斯有何过。此亦非理所以者何。离受爱外有余法处。可得别说。离根境识。无别三和可别说故。言断杂染故名断者。如杂染中义准应破。谓杂染中。已广成立。离眼等外有触杂染。由彼断故三受永断。非由眼等因果合性杂染断故三受永断。言见称事名如实见。及说圣道住所缘者。理亦不然。虚假事见非证实故。岂名如实。既非如实。何名圣道安住所缘。若非圣道安住所缘。何能永断触食三受。言三和触非一合故。不可如瓶说众分者。理亦不然。见非一合亦别说故。犹如有说补特伽罗之受想等众分差别。言如名色六处等支。虽非实有而有如前所说诸义。故无失者。理亦不然。非审宗故。于非一事立一想名。各别事中失此名想。名假有相。如瓶如行。或如汝执三和触等。名色名想不可杂坏。如触法界总别皆有。故此非与汝执触同。由斯类释六处支等。为显内处唯有六故。立六处名。非于多法立一名想。谓为六处于此实法名色等支。可有胜义因果等说。非于汝执假有触等说有胜义因果等言。故彼古昔诸大论师。所立诸因。理善成就。由此有触。是别心所。一切心俱。理极成立。此既成立。上座所言。大地唯三。极为迷谬

云何成立。前四法余实有别体。是大地法。彼彼说故。实有别体。诸心起时。皆见有用。由斯理证。两义皆成。又世尊言。谓一切法。欲为根本。作意引生。触为能集。受为随流。念为增上。定为上首。慧为最胜。解脱坚固涅槃究竟。想思二法。不说自成。故此经中略而不说。由定无有心相续中空无取相以取境相。诸心位中无非胜故。思是意业。有心皆有。由此契经。现证欲等实有别体。是大地法。然上座言。此经所说。是不了义。故不可依。彼云何知是不了义。彼谓色等理不应用。欲为根本。作意引生。触为能集。然此经说一切法言。故应但依心心所说。由斯证是不了义经。此说不然。非所许故。依一切法。说此契经。不但偏依心心所说。为令弟子酬答外道矫诘问词。说此经故。非诸外道于心心所名想极成。何容虑彼。于此义中。善巧诘问。谓诸外道。闻佛世尊于一切法能如实觉。广大名称遍诸世间。情不忍许。彼恒聚集。共设谋议。言大沙门乔答摩氏。辩才无滞。敌论为难。且应诘问。彼诸弟子。仁者大师。于一切法。具辩析智。所说云何。且一切法。谁为根本。广说乃至。谁为究竟。世尊虑有新学苾刍欻遭究问。或便惶乱。为防斯耻。预说此经。应知此中言一切法欲为本者。一切流转。皆以希求为种子故。谓于诸法。生觉了心。并以希求为根本故。如生顺起缘一切心。故说诸法欲为根本。一切法中所有了别。皆由作意方便引起。故说诸法作意引生。言一切法触能集者。诸法皆与触为能集。根境识三和合生故。言一切法受随流者。诸受随顺一切法流。谓乐苦等。随爱非爱及俱相违。别境转故。或一切法随受而流。意显诸法随受行相差别而转。为境性故。言一切法念增上者。谓由念力。于诸所缘不忘失故。由此故说念为遍行。守门防逻。言一切法定上首者。谓三摩地。能系缚心。令于所缘安住不散。令心于境专一审虑。故名为定。此于制心威力最胜。故言上首。心性虽躁。由定所持。不速背此往余流散。由此契经。说心如电说定坚固犹若金刚。言一切法慧最胜者。诸法性相。虽极甚深。般若坚明。皆能洞照。故言最胜。或复般若出过诸法。故名最胜。胜是过义。世俗于过。说为胜故。此中意说。唯有般若。遍照所知。尚有余力。于一切法。能了别中。邪正胜解。力最坚固。由是印定诸境胜因。故言诸法解脱坚固。解脱即是胜解异名。无始时来。生死流转。心境展转。相续无边。唯有涅槃。为其究竟。故言诸法涅槃究竟。由如是释。一切法言。摄法周尽。更无异趣。由斯证此。是了义经。决定可依。证前两义。此中欲者。思行蕴中。已引圣言。成立别有。谓如经说。彼有如是信欲勤安。乃至广说。又前已说。诸心起时。皆见有用。证知欲是大地法性。所以者何。一切流转。皆以希求为种子故。谓心用欲。作俱起缘。一切境中。恒流转故。然上座言。此欲决定非大地法。阿阐地迦经所说故。此言非理。依巧便欲言非有欲。故无斯过。若言斯理他亦应同。谓他亦言。依全无欲。说非有故。此理不同。彼于余境。有所乐欲。现可得故。谓彼现于可爱乐事。定有希求。而得说为非有欲者。故知此依巧便欲说。如言非信世间亦于不仁孝子说为非子。故非有言。未为定证。于境无欲心必不生。故此定应是大地法。慧别有体。诸经说故。心了境时。必有简择。用微劣者。便不觉知。故慧定应是大地法。然上座说。慧于无明疑俱心品。相用无故。非大地法。所以者何。智与无智。犹豫决定。理不应俱。此说不然。邪见心品。与无明俱。理极成故。非无痴心可有邪见。故邪见品。定有无明。不共无明。相应心品。云何有慧。且许无智与智相应。其理成立。此既成立。不共无明。相应心品。亦应有慧。但微劣故。相不明了。由此类释。亦与疑俱。若疑相应全无慧者。云何得有二品推寻。于二品中。差别简择。推寻理趣。乃成疑故。念体别有。亦如经说。心了境时。必有明记。亦由微劣。有不觉知。故念定应是大地法。然上座言。此念决定。非大地法。契经说有失念心故。失谓亡失。又见多于过去境上。施设念故。然于彼境。即智行相明记而转。故无别念。此说不然。如前说故。非巧便念名为失念。如狂乱心名为失心。或念微劣。名为失念。如迷闷等。名失想思。既见多于过去境上。施设有念。便于现在所缘境上。有念极成。非于现境曾无明记。后于过去有忆念生。言于彼境。即智行相明记而转。无别念者。理亦不然。觉察明记。行相别故。于境觉察重审名智。不忘失因。明记名念。故有说言。于所受境。令心不忘。明记为念。若执如是明记行相。即智行相。无别念者。受等亦应无别有体。谓亦可言。即智行相。领纳而转。无别有受。余亦应然。即为非理。又彼唯许心所有三。智体亦无。何独无念。说念即智。但有虚言。又阿笈摩。证念非智。如契经说。住正念者。便住正知。又契经言。具正知者。便具正念。如是等类。所说寔多。若念即智。契经应言。住正念者。便住正念。具正知者。便具正知。如是所言。有何别义。若念唯缘过去境者。如何失念知现他心。或复如何缘涅槃智。灭等行转。而名失念。又缘未来。死生智等。如何失念。成力明通。如斯等类。为过兹甚。故诸心品。皆与念俱

说一切有部顺正理论卷第十阿毗达磨顺正理论卷第十一

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩差别品第二之三

作意别有。亦如经说。心由作意引发故生。故此定应是大地法。然上座言。无别一法名为作意。由此别相理不成故。谓于所缘。能作动意。名作意相。若于所缘。唯作动意。诸余心所。应不能缘。若亦由斯方能缘者。理不应尔。名作意故。余缘生故。此难非理。诸心所法。依心转故。但动于意余动亦成。故无心所不能缘过。又众缘力诸法乃生。故虽余缘生心心所。而此作意。非无力用。谓此作意。力能令识于余境转。若尔一境识流转时。应无作意。是则作意非大地法。不尔一境识流转时。亦有作意。然于余境。此用明了。谓于一境。刹那刹那。亦由作意力方引心令起。然于余境。引发心时。作意功能。明显易了。岂不众缘发生心等即名能引。何劳别计作意力为。此责非理。虽具生识余和合缘。而说作意能生识故如契经说。尔时若无能生作意。正现在前识终不起。理亦应尔。虽多境界俱时现前。而识何因唯缘一起。岂不于此生缘合故。诚如所言。此即作意生缘合者。即世尊言。作意尔时正现前义。所言作意。于境引心。为是前生。为是俱起。是俱时起。非谓前生。经言作意正现前故。正现前者。谓正起近现前自境。即正生时。将入现在。取自境义。此中意显。由作意力。引识令缘自所乐境。胜解别有。亦如经说。心由胜解。印可所缘。诸心起时。皆能印境。故此定应是大地法。然上座言。胜解别有理不成立。见此与智相无别故。谓于所缘令心决定。名胜解相此与智相都无差别。是故定应无别胜解。此言非理。要有印可。方决定故。有言胜解是决定者。于决定因说为决定。若尔此二。应不同时。不尔此二相随顺故。谓由简择。随生印可。复由印可。随生决定。不相违故。同时无失。若一切心。皆有此二。则诸心品。应皆印决。此难非理。以或有时余法所伏功能被损。虽有印决。劣难知故。诸无色法。就用说增。如前已辩。世尊建立。贪嗔痴等。行相异故。又别说有十无学支。故知非无别胜解体。彼谓此中心离贪轭。相续转故。即随缚断。名正解脱。所以者何。以薄伽梵于余经中自决此义。故余经说。云何名为心善解脱。谓心从贪从嗔从痴。离染解脱。云何名为慧善解脱。谓如实知。心从贪等离染解脱。此言非善。以无体法。为无学支。理不成故。彼无少法名随缚断。如何可立为无学支。又彼释言。即随缚断。名正解脱。此不成释。所以者何。由随缚断解脱生故。离染无为。名随缚断无学胜解。名正解脱。若不尔者。前离染言。已显缚断。后解脱言。应成无用。言如实知心解脱者。见离染心相应解脱。又如实知解脱心者。谓见解脱相应之心。故余契经。世尊自说。心离染故。便得解脱。若不尔者。解脱既是离染异名。应依初说。不依第五。如余处言。尽离灭等。虽依初说离染解脱。而体各异。若不尔者。说解脱言。应成无用。如无染离染义无差别故。又说解脱为对治故。非随缚断即是解脱。故契经说。折伏法中。言由正解脱折伏邪解脱。非随缚断能为对治。若能印可。是胜解相。此与信欲应无差别。相虽少同。而体甚异。谓审印可。是胜解相。心净希求。是信欲相。岂不信顺及与欲乐即印可耶。信顺欲乐。随顺印可。非即印可。信欲助成胜解用故。心所相用。极难辩析。唯审睿觉。能分别知。故譬喻师。不能堪忍。分析劳倦。遂总非拨。三摩地别有。亦如契经说。平等持心。令住自境。名三摩地。诸心起时。无不各住自所取境。故此定应是大地法。然上座言。离心无别三摩地体。由即心体缘境生时不流散故。若三摩地。持心令住一境转者。岂由三摩地无故。心便于多境转耶。若谓多心由此持故令于一境无间转者。则不应说刹那刹那有三摩地。心唯一念堕在境中。此应非有。如是此应非大地法。若由有此心住所缘。是则此体应非现见。然诸心所。体可现见。又法功能。不待余法。故心住境。自力非余。此言非理。令心造作。亦应无别大地法思。差别因缘。不可得故。又识非住所缘为性。慧等亦同。心有定非定故。又诸心所体现见言。如前已破。前如何破。谓若心所现可见者。应无有执彼即是心。又法功能。必待余法。或应缘起言成无义。又心所用。不应在心。心心所法性各别故。三摩地用。谓能住心了别所缘。是识功用。如自体起。必托所缘。亦非自能住境不散。设住境用。依心体成。如令心造作别有体义立。又阿笈摩。证三摩地实有别体。如契经说。应修二法。谓奢摩他毗钵舍那。若拨无实三摩地者。便违此等无量契经。若谓无违。于心心所分位差别。立此用故。即心心所差别转时。立三摩地。名用无失。此亦不然。于余法体。立余法用。理不成故。又不应言三摩地用。于彼一切差别位立。唯依于心。而说此故。又彼宗义。心心所法。不同时起。有何定准说心定时受等亦定。若谓如无别相应体而说相应。此亦应尔。谓如无别相应法体。而彼心等。总名相应。如是虽无别三摩地而心心所。总说为定。理亦不然。是彼性故。谓心心所。是相应性。非等持性。所以者何。一切位中。彼相应性。无胜劣故。三摩地性。于诸位中。有胜劣故。此既一相诸位何缘胜劣有别。余法所持。令此功力有损益故。现见青等余色所糅。相续随流。胜劣有别。又若无定心自住者。应无贪等心自染等。岂不如无别法助故。慧自简择。如是亦无别法助故。心自住境。此例不齐。以契经说心如电光亦如猿猴。非住相故。又三摩地体即心者。想等亦应无别有性。即心能取名相施设。应说为想。即心领纳违等所缘。应说为受。即心造作善恶等业。应说为思。是则唯心。应无三所。又见谛者。于并生疑。故三摩地。非心位别。如契经说。大德世尊。我若在定。心则解脱。非不在定。为先有定后方解脱。广说如经。彼执解脱亦心位别。或说无学心为解脱支故。必无二心一身并起。故彼于并不应生疑。是故定应别有心所。是心住因。名三摩地。故受等十。别有实体。一切心俱名大地法。如是已说十大地法。大善之地。名大善地。此中若法大善地所有。名大善地法。谓法恒于诸善心有。彼法是何。颂曰

  信及不放逸　　轻安舍惭愧
  二根及不害　　勤唯遍善心

论曰。心浊相违。现前忍许。无倒因果。各别相属。为欲所依。能资胜解。说名为信。专于己利防身语意放逸相违。名不放逸。正作意转。身心轻利安适之因。心堪任性。说名轻安。心平等性。说名为舍。掉举相违。如理所引。令心不越。是为舍义。趣向如理。自法二种增上所生。违爱等流。心自在性。说名为惭。爱乐修习功德为先。违痴等流。厌恶劣法。说名为愧。有说怖畏谪罚恶趣自他谤因。说名为愧二根者谓无贪无嗔。已得未得境界耽着希求相违。无爱染性。名为无贪。于情非情。无恚害意。哀愍种子。说名无嗔。与乐损恼有情相违。心贤善性。说名不害。于诸已生功德过失。守护弃舍。于诸未生功德过失。令生不生。心无堕性。说名为勤。由有此故。心于如理所作事业。坚进不息。有作是言。此中既说身轻安故。非唯心所说名轻安。此言非理。受等亦应同此说故。然五识身相应诸受。说名身受。有作是说。设有轻安体非心所。然此中说心所法故。不应说彼以能随顺觉支体故。亦名觉支。谓身轻安。能引觉支心轻安故。亦见余处。嗔及嗔因。名嗔恚盖。见思惟勤。名为慧蕴。虽彼嗔因思惟及勤非嗔非慧。然顺彼故。亦得彼名。此亦应尔。舍后当辩。说二及言。兼摄欣厌。厌谓善心。审观无量过患法性。此增上力。所起顺无贪心厌背性。与此相应。名厌作意。欣谓善心。希求过患出离对治。此增上力。所起顺证修心欣尚性。此于离喜未至等地。亦有现行。故非喜受。与此相应。名欣作意。此二行相。更互相违。故一心中。无容并起。是故此中。不正显说。大善地法性不成故。亦有喜根。厌行俱转。定无有欣厌行俱转。为表此二定不俱行。说二及言。行相违故。如是已说大善地法。大烦恼之地。名大烦恼地。此中若法。大烦恼地所有。名大烦恼地法。谓法恒于染污心有。彼法是何。颂曰

  痴逸怠不信　　惛掉恒唯染

论曰。云何如是六种。名大烦恼地法。以恒唯与诸染心俱。颂言染者。是染心义。又放逸等及与无明。如其次第。应知即是前不放逸勤信轻安舍等所治。痴谓愚痴。于所知境。障如理解。无辩了相。说名愚痴。即是无明无智无显。逸谓放逸。于专己利弃舍纵情。名为放逸。怠谓懈怠。于善事业。阙减胜能。于恶事业。顺成勇悍。无明等流。名为懈怠。由此说为鄙劣勤性勤习鄙秽。故名懈怠。不信者。谓心不澄净。邪见等流。于诸谛实静虑等至。现前轻毁。于施等因。及于彼果。心不现许。名为不信。惛谓惛沈。[夢-夕+登]瞢不乐等所生心。重性说名昏沉。由斯覆蔽心。便惛昧无所堪任。瞢愦性故。由是说为轻安所治。心为大种能生因故。由此为先。起身重性。假说惛沈。实非惛沈。彼是身识。所缘境故然此惛沈。无明覆故。本论不说为大烦恼地法。有言。彼论说无明名。唯目惛沈。相相似故。无明性是大遍行故。是此地法不说而成。有说此名。总目二义。掉谓掉举。亲里寻等所生。令心不寂静性。说名掉举。心与此合。越路而行。非理作意。失念心乱。不正知邪胜解。前已说在大地法中。故此地法中。虽有而不说。如于大善地法不说无痴善根。唯诸染心。恒有此六。如是已说大烦恼地法。大不善之地。名大不善地。此中若法大不善地所有。名大不善地法。谓法恒于不善心有。彼法是何。颂曰

  唯遍不善心　　无惭及无愧

论曰。唯二心所。但与一切不善心俱。谓无惭愧。故唯二种。名此地法。此二法相。如后颂中自当显示。故此不说。如是已说大不善地法。小烦恼之地。名小烦恼地。此中若法小烦恼地所有。名小烦恼地法。谓法少分染污心俱。彼法是何。颂曰

  忿覆悭嫉恼　　害恨谄诳憍
  如是类名为　　小烦恼地法

论曰。类言为摄不忍不乐愤发等义。小是少义。显非一切染污心有。非虽少分染污心俱。仍各别起。无相应义。唯修所断。意识俱起。无明相应。此诸法相。随烦恼中。当广分别。如前所说。一切心所。应知其性。皆是实有。所以者何。非一品类。所缘义中。种种行相。俱时起故。一体同时。如所缘义。差别行相。无容有故。然由余法所制伏故。见其相续变异而起。现见清油垢水风等势力制持。灯相续中。便有明昧声动等故。如是已说大地法等品类决定心所差别。复有此余不定心所。恶作睡眠寻伺等类。总说名为不定地法。今应决判一切心所诸心品中俱生数量。何心品中。有几心所。颂曰

  欲有寻伺故　　于善心品中
  二十二心所　　有时增恶作
  于不善不共　　见俱唯二十
  四烦恼忿等　　恶作二十一
  有覆有十八　　无覆许十二
  睡眠遍不违　　若有皆增一

论曰。且欲界中心品有五。谓善唯一。不善有二。谓不共无明俱生。及余烦恼等俱生。无记有二。谓有覆无记。及无覆无记。如是欲界一切心品。决定恒与寻伺相应。故善心品。有二十二心所俱生。谓十大地法。十大善地法。及不定二。谓寻与伺。此中勤舍应不俱生。行相违故。如进与止。造修委弃。理不同时。契经亦遮此二俱起。说修二法时非时故。如契经说。心若惛沈。尔时应修择法勤喜。修轻安定舍则为非时。心若掉举。尔时应修轻安定舍。修择法勤喜。则为非时。俱生无失。不相违故。住正理者。起如理行。不息名勤。即于尔时。弃非理行。平等名舍。又于如理非理行中。舍如持称。进止平等。故舍与勤。更相随顺。起善止恶。行不相违。若于所缘。一取一舍。更相违背。可有此失。由斯类释。经主所难。谓有警觉无警觉性。作意与舍。应互相违。如是善成。于善心品。有二十二。心所俱生。不定地法。所余二种。恶作睡眠。非通三界。及六识身。有漏无漏。非唯不染。亦非唯染。故善心品。非一切时。皆有恶作。但可容有。有时增数。至二十三。言恶作者。悔以恶作为所缘故。立恶作名。如无想定。有说。无相及身念住。有处名身。若尔有缘所未作事心生追悔。应非恶作。不尔。未作亦名作故。如追悔言。我先不作如是事业。是我恶作。然此恶作。通善不善。不通无记。随忧行故。离欲贪者。不成就故。非无记法有如是事。然有追变。我顷何为不消而食。我顷何为不画此壁。如是等类。彼心乃至未触忧根。但是省察未起恶作。若触忧根。便起恶作。尔时恶作。理同忧根。故说恶作。有如是相。谓令心戚。恶作心品。若离忧根。谁令心戚。恶作有四。谓善不善。一一皆依二处起故。若于不善不共心品。有二十种。心所俱生。谓十大地法。六大烦恼地法。二大不善地法。并二不定。谓寻与伺何等名为。不共心品。谓此心品。谁有无明。无有所余。贪随眠等。如不共品邪见见取及戒禁取。俱生亦尔。大地法中。即慧差别。说名为见。故数不增。颂言唯者。是简别义。谓唯见俱。定有二十。表不共品中容有恶作等。谓若恶作是不善者。唯无明俱。非余烦恼。贪慢二种。欣行转故。嗔外门转。行相粗故。非恶作俱。疑不决定。恶作决定。故不俱起。有身见等。欣行转故。极猛利故。恶作不尔。然此恶作。依善恶行事处转故。诸见不尔。故不相应。邪见一分。虽戚行转。而二因故。非恶作俱。是故恶作是不善者。唯无明俱。容在不共。忿等亦尔。于四不善贪嗔慢疑。烦恼心品。有二十一心所俱生。二十如不共。如贪等随一。于前所说。忿等相应随烦恼品。亦二十一心所俱生。二十如不共。加忿等随一。不善恶作相应心品。亦二十一心所俱生。谓即恶作等二十一。若于无记有覆心品。唯有十八心所俱生。谓如不共二十法中。除大不善地法二种。欲界无记有覆心者。谓与萨迦耶见及边执见相应。不增见义。如前应释。于余无记无覆心品。许唯十二心所俱生。谓十大地法。并不定寻伺。有执恶作亦通无记。忧如喜根。非唯有记。此相应品。便有十三心所俱起。睡眠一切不相违故。于诸心品。皆可现行。于善不善无记心品。随何品有。即说此增。随其所应。各增一数。工巧处等诸无记心。似有勇悍。然非称理而起加行。故无有勤。又非染污故无懈怠。无信不信类此应知。已说欲界心所俱生诸品定量。当说上界。颂曰

  初定除不善　　及恶作睡眠
  中定又除寻　　上兼除伺等

论曰。初静虑中。于前所说诸心所法。除唯不善恶作睡眠。余皆具有。唯不善者。谓嗔烦恼。及无惭愧。除谄诳憍。所余忿等。余皆有者。如欲界说。中间静虑。除前所除。又更除寻。余皆具有。第二静虑以上乃至无色界中。除前所除。又除伺等。等者显除谄诳。余皆如前具有。以从欲界乃至梵天。皆有王臣众生等别。故有谄诳。上地皆无。如是已说三界所系诸心所法俱生定量。有诸心所。性相似同。难知差别。今随宗义。辩彼难知心所别相。无惭无愧。爱之与敬。别相云何。颂曰

  无惭愧不重　　于罪不见怖
  爱敬谓信惭　　唯于欲色有

论曰。无惭无愧差别相者。于诸功德及有德者。无敬无崇。无所忌难。无所随属。说名无惭。诸功德者。谓尸罗等。有德者谓亲教等。于此二境。无敬无崇。是无惭相。即是敬崇能障碍法。或缘诸德。说为无敬。缘有德者。说为无崇。无所忌难。无所随属。总显前二。或随次第。于所造罪。不见怖畏。说名无愧。诸观行者。所诃厌法。说名为罪。于所诃厌诸罪业中。不见能招此世他世讥毁谪罚非爱难忍异熟果等诸怖畏事。是无愧相。即不忌惮罪业果义。不见怖言。欲显何义。为不见彼怖。为见而不怖。前应显无明。后应显邪见。此言不显见与不见。为无愧体。但显有法是随烦恼能与现行无智邪智为邻近因。说名无愧。此略义者。谓能令心。于德有德无所崇敬。名曰无惭。于罪现行。无所忌惮。名为无愧。有余师说。于诸烦恼。不能厌毁。名曰无惭。于诸恶行。不能厌毁。说为无愧。有说。独处造罪无耻。名曰无惭。若处众中造罪无耻。说为无愧。有说。现起不善心时。于异熟因。无所顾眄。名曰无惭。于异熟果。无所顾眄。说为无愧。诸不善心现在前位。皆于因果。无所顾眄。故一心中二法俱起。由此翻释惭愧异相。若净意乐。为习善人所乐胜业。名有惭者。为得善人所乐胜果。名有愧者。诸有爱乐胜业胜果。必亦怖于恶因苦果。一切善心。现在前位。定于因果。皆无迷惑。由此惭愧。一心并生。故有余师。以如是义。标于心首。说如是言于所造罪。自观无耻。名曰无惭。观他无耻。说为无愧。谓异熟因。当时现起。故名为自。其异熟果。后时方有。故说为他。彼义意言。诸造罪者。意乐不净。于现罪业及当苦果。皆无顾眄。由此已释。经主此中。误取彼情。横申过难。谓设难言。若尔此二。所观不同。云何俱起。已说无惭无愧别相。爱敬别者。爱谓爱乐。体即是信。然爱有二。一有染污。二无染污。有染谓贪。无染谓信。信复有二。一忍许相。二愿乐相。若缘是处。现前忍许。或即于中。亦生愿乐。此中爱者。是第二信。或于因中。亦立果称。前信是爱邻近因故。名爱无失。敬谓敬重。体即是惭。谓如前释大善地法中言。心自在性说为惭者。应知即是此中敬体。然复有言。有所崇重。故名为敬。由此为先。方生惭耻。故敬非惭。彼师应许无惭耻者能起恭敬。以执先起敬时未有惭耻故。应无惭耻者能起恭敬。若谓敬时已有惭耻。则不应说由敬为先方生惭耻。若谓敬时非无惭耻。然敬非惭。此亦非理。言敬非惭。无证因故。非敬为先方生惭耻。勿无惭者能起恭敬。又勿有敬而无惭耻。然复确执敬体非惭。但有虚言。都无实义。故应敬体是惭差别。谓或有惭。名有崇重。此惭差别说名为敬。补特伽罗为境界故。即惭差别。得崇重名。夫崇重者。是心自在。心自在性。已说为惭。谓于心中。有自在力。能自制伏。有所崇重。故说敬体是惭差别。于诸所尊。有所崇重。故名为敬。是境第七。或因第七。由于所尊发随属意。即名为惭。此惭即是有所崇重。故此敬体。是惭差别。义善成就。即由此证。补特伽罗为境信惭。说名爱敬。非谓以法为境起者。故爱与敬。虽大善摄。而不立在无色界中。有余师言。信顺亲密。而无耽染。说名为爱。瞻望所尊。崇重随属。说名为敬有余师说。亲近善士因名为爱。不越彼言因名为敬。复有说者。于和合众。见等皆同。故名为爱。于可尊重。深心恭事。故名为敬。此爱与敬。欲色界有。无色界无。无依处故。如是已说爱敬别相。寻伺憍慢别相云何。颂曰

  寻伺心粗细　　慢对他心举
  憍由染自法　　心高无所顾

论曰。寻伺别者。谓心粗细。心之粗性。说名为寻。心之细性。说名为伺。若尔寻伺体不异心。经即就心说二性故。此言非理。由不了达经义意故。经言所有心粗细性名寻伺者。由有此法。心起便粗。此法为寻。由有此法。心起便细。此法名伺。或作异释。故体异心。谓我不言。心之粗性名心粗性。心之细性名心细性。若尔云何。依心粗性。名心粗性。依心细性。名心细性。若尔粗细性相违故。不应寻伺一心俱生。虽一心中二体可得。用增时别。故不相违。如水与酢等分和合。体虽平等。而用有增。粗心品中。寻用增故。伺用被损。有而难觉。细心品中。伺用增故。寻用被损。有而难觉。若谓酢用一切时增故非喻者。此言非理。我不定说。以酢喻寻。伺喻于水。但有用增者即说如酢故。若心品中。寻伺二法随用增者。即说如酢。微便喻水。由是寻伺。虽一心中体俱可得。用时别故。而无一心。即粗即细。如贪痴性。虽并现行。而得说心为有贪行。随何心品。有法用增。由此为门。总摽心品。有说。现见别法所持。令其别法相续变故。心体相续既有粗细。故知别为寻伺所持。有余复言。为立寻伺。为定障故。说寻伺为心粗细性。云何知然。诸圣教内。处处于定立心名故。谓契经中。说四静虑为定根已。复说四静虑。为增上心学。又契经说。依住净戒。修习二法。谓止观已。复说。智者依住净戒。修习心慧。又契经言。离贪欲故。心得解脱。离无明故。慧得解脱。止观是彼亲近对治。故知于定建立心名。谓大仙尊。见有观行者。方欲趣入中间静虑时。有法为障。推求此障。知寻为体。复有观行者。方欲趣入第二静虑时。有法为障。推求此障。知伺为体。既能为障。故知别有。若言烦恼足为定障。何须别立寻伺障者。此言非理。烦恼唯障离染法故。非为定障。云何知然。下地烦恼有虽已断。而上地定不现前故。有虽未断。上地边定。亦现前故。又唯烦恼为定障者。应唯未断能与趣入上地为障。然寻伺等。要现在前。方与趣入上地为障。又契经说。静虑中言。寂静寻伺。离喜断乐。已离贪者。修诸定时。方说寻等寂静离断。故知烦恼外别有寻等障。于染善心。为障别故。不应责言烦恼障定。何须别立寻伺为障。是故所言为立寻伺为定障故。说寻伺为心粗细性。理善成立。定之粗障说名为寻。定之细障说名为伺。由此故说心之粗性。说名为寻。心之细性说名为伺。亦无有失。非于上地定过患中更有如斯粗细名想。故上地定。得一味名。由是彼无中间静虑非上诸地。如初静虑。于一地中。有渐除障。渐得胜定。可立中间。何故不说寻伺自相。如说。受等各别相耶。辩诸法相。有多门故。谓圣教中有约自性辩诸法相。或约相应果因功用及所缘等。且如说言。云何地界。谓坚强性。云何不善。谓与无惭无愧相应。云何三摩地。谓心一境性。云何为触。谓三和合。云何为眼根。谓眼识所依。云何法智。谓于欲界所系诸行。或彼行因。或彼行灭。或彼断道。诸无漏智。如是等门。辩诸法相。皆于正理。无所乖违。是故不应责同受等。诸法性相。最极难知。辩静虑中当更分别。如是已说寻伺别相。慢憍别者。慢谓对他心自举性。称量自他德类胜劣若实不实。心自举恃。陵蔑于他。故名为慢。憍谓染着自法为先。令心傲逸。无所顾性。于自勇健财位戒慧族等法中。先起染着。心生傲逸。于诸善本无所顾眄。故名为憍。于诸善本无所顾者。谓由心傲。于诸善业不欣修习。是谓慢憍差别之相。如是已说诸心心所品类不同俱生决定差别之相。然心心所于契经中。随义建立种种名相。今当辩此名义差别。颂曰

  心意识体一　　心心所有依
  有缘有行相　　相应义有五

论曰。心意识三。体虽是一。而训词等义类有异。谓集起故名心。思量故名意。了别故名识。或种种义故名为心。即此为他作所依止故名为意。作能依止故名为识。或界处蕴施设差别。或复增长相续业生种子差别。如是等类。义门有异。故心意识。三名所诠。义异体一。如心意识。三名所诠。义异体一。诸心心所名有所依。所缘行相相应亦尔。名义虽殊而体是一。谓心心所。以六内处。为所依故。名有所依。以色等境。为所缘故。名有所缘。即于所缘境品类相中。有能取义。故名有行相。平等俱时与他合故。说名相应。云何平等。五义等故。谓心心所。五义平等。故说相应。所依所缘行相时事。皆平等故。事平等者。一相应中。如心体一。诸心所法各各亦尔。有譬喻者。说唯有心无别心所。心想俱时。行相差别。不可得故。何者行相唯在想有。在识中无。深远推求。唯闻此二名言差别。曾无体义差别可知。又由至教证无心所。如世尊告阿难陀言。若无有识入母胎者。乃至广说。又说。或心或意或识长夜流转。生于地狱。乃至生天。又说。士夫即是六界。所谓地界乃至识界。又说。我今不见一法速疾回转犹如心者。又说。我今不见一法若不修习则不调柔无所堪能犹如心者。又如契经伽他中说

  心远行独行　　无身寐于窟
  能调伏难伏　　我说婆罗门

此等诸经皆遮心所。又于心所。多兴诤论。故知离心无别有体。谓执别有心所论者。于心所中。兴多诤论。或说。唯有三大地法。或说有四。或说有十。或说十四。故唯有识随位而流。说有多种心心所别。如甘蔗汁。如倡伎人。故无受等别体可得。心心所法。共一境转。生住灭等。分位是同。善不善等性类无异。体相差别。实难了知。非诸劣智能生胜解。故契经言。心心所法。展转相应。若受若想若思若识。如是等法和杂不离。不可施设差别之相。故应于此发起正勤求生胜解了差别相。诸契经中。处处说有受想思等。识俱生故。不可由不得一类别相便总拨一切圣教真理。纵仁于此识想差别。若得不得。然其想相离于识体。决定别有。我于此二差别相中。分明证得。谓若于彼诸境界中。总了其体。说名为识。别取名相。施设名想。复云何知。此二俱起。非于境界总了体识。无间灭已。别取名相。施设识生即名为想。由阿笈摩及正理故。阿笈摩者。谓契经中。先说识已。后说俱生受想思故。言正理者。谓于眼识所了色中。取相名想。若于后时。想方起者。前色已灭。云何今时有相可取。辩本事品。已遮眼识缘过去境。若言意识能取彼相。理亦不然。经说。眼触所生想故。若谓此如意近行说。此亦非理。意识不从触所生故。犹如眼识。非有诸识三和所生。如何可言识从触起。若彼复执。从意识后方生意地能取相想。此非眼识无间所生。便违所言如意近行。又从身触所生身受。若同彼想不现领纳身所取境。如何现前分明随领顺苦等触。不应许此领纳过去所触境生相分明故。又生次第。理不成故。谓经所说。眼触所生受想及思。三心所法。眼识无间。谁定先生。彼许此三是识差别。故识不可多体俱生。定次第生。无因证故。应说三法谁最初起。虽引至教证唯有心。而于义中无证功力。识于诸处有胜功能。非诸心所。是故偏说。又诸心所无不依心。但说所依能依已显。又心心所。随处随时。用有增微。就增者说。或有心品。识用增强。或受或想或复思等。随一一法用增强位。以此为门。总摽心品。故唯说识。不妨有余。心独行言。为遮心并起。不遮心所。如言人独行。故所引经。无证功力。言于心所有多诤论。故知离心无别体者。此亦不然。皆信有故。谓依理教。诸大论师。皆信离心别有心所。但于多少数增减中。经无定说。故兴诤论。若执受等是心差别。如何即心可名心所。据何定理。说识为心。复以何缘。即名心所。若谓诸识体即是心。受等诸法。是心体类。心相续中。有此法故。名心所者。何故不言所造诸色即是大种体类差别。即于地等相续位中。有此法故。名为所造。此既不尔。彼云何然。离大种外。别有所造。辩本事中已广成立。若责何故知心所法决定离心别有体者。由阿笈摩及正理故。阿笈摩者。如契经言。眼色为缘。生于眼识。三和合触。俱生受想思等心所。如是诸法。是心种类。依止于心。系属于心。故名心所。此俱生言不说无间。但显心所同时而生。俱有因中。当更成立。又不容有心体俱生。故知但说心所俱起。若谓如前所引经说。心心所法。展转相应。若受若想若思若识。如是等法和杂不离。不可施设差别相者。此经意显。心所与心其体无别。此亦非理。寿识暖三。亦同此说。应无别体。不可说言识之与暖其体无别。又和杂言。显有别体。非无别体可说和杂。若唯有识。前识灭已。后识方生。云何可言如是等法和杂不离。若言由此受想思识无间生故名和杂者。此亦不然。理不成故。余契经说俱生言故。或识无间有此法生。容可说言和杂不离。非识无间有受等三俱时而起。如何可说受想思等与识和杂。故彼所执理教相违。又契经言。修观行者。得他心智。能知他心及心所法。而记别言。汝意如是。汝意如此。汝有此寻。汝有此伺。乃至广说。不应即心名为心所。如前已辩。由是等类诸阿笈摩。证知离心别有心所。由正理者。如前所说。谓于眼识所了色中。取相名想。若于后时。想方起者。前色已灭。云何今时有相可取。乃至广说。有余复言。如契经说

  名映于一切　　无有过名者
  由此名一法　　皆随自在行

名者即是受相行识。既言一法。故知唯心无别心所。此言非理。以名如色多体成故。如契经言。法有二种。谓名及色。非大种等差别相法一法为性。此亦应尔。有余复言。若心心所。其体各异。于一心品。应有众多。能觉了用。故心所法应不异心。此亦不然。能觉了用。体唯一故。觉了谓慧。非心心所皆慧为体。如何令余非觉了性成觉了体。故无斯过。有余复言。我等现见唯有一识。渐次而转。故知离心。无别心所。此亦非理。受等如心体相分明。现可取故。又心心所。虽体俱生。而其功用。非无先后用增强位。体方可知。如诸大种。此亦应尔。有何定因。唯心心所俱时而起。说名相应。非诸大种。或所造色。由大种等体有增不增故。若尔心所体亦应然。不尔一相体无增故。又契经说。见为根信证智相应。故诸大种。或所造色。无相应义。若言不尔不遮余故。非彼经中说诸色法无相应义。又亦说色有相应故。谓于诤处。说二相应。此言非理。太过失故。如于一分佛说色言。应一切法皆色为体。若言世尊唯说大种所造为色。此亦非理。不遮余故。若谓变坏故名为色。知此色言。已遮余法。此亦非理。唯变坏义。非定知故。若谓经言手等触对故名变坏。唯变碍义。是色非余。此亦非理。不决定故。非彼经中说唯变坏是色非余。又余经中。亦说无色有变碍故。谓契经言。意为可意不可意法之所变碍。故无色法亦应是色。如是经言。了别境界。故名为识。应诸色法亦识为体。若谓不然。曾无说色识为体故。此不应理。如想受等。应成识故。又不遮故。若谓如何无所缘法而得说为了境识者。此亦非理。自计度故。何处经言。无所缘法不能了境。又何处说。色无所缘。是故应唯心心所法。有相应义。同一所依所缘行相时事等故。诸契经中。见心心所有如是义。非大种等。以大种等方处势用各各差别。虽暂和合不相离故假说相应。而非毕竟有相应义。唯心心所。毕竟相应。故相应言。义善成立。有余师说。如一器中煎水涌沸击烂烧动四用差别。俱时有故。知四大种。异体和杂。实有义成。如是众多心心所法。展转相助。虽同一时所依所缘行相相似。而其势用各各差别。无杂乱故。知有别体。如斯论旨诸部极成。皆已共摧唯有心论。故心心所别有义成

说一切有部顺正理论卷第十一阿毗达磨顺正理论卷第十二

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩差别品第二之四

无色法中。已辩心心所。今次当辩心不相应行。颂曰

  心不相应行　　得非得同分
  无想二定命　　相名身等类

论曰。等者等取句身文身及和合性。类者显余所计度法。即前种类。谓有计度离得等有蕴得等性。如是诸法。不与心相应故。说名为心不相应行。非如心所与心共一所依所缘相应而起。说心言者。为显此中所说得等是心种类。诸心所法。所依所缘。皆与心同。亦心种类。为简彼故。言不相应。诸无为法。亦心种类。无所依缘。故亦是不相应。为欲简彼故复言行。此已总标。复应别释。于中且辩得非得相。颂曰

  得谓获成就　　非得此相违
  得非得唯于　　自相续二灭

论曰。得获成就。义虽是一。而依门异。说差别名。得有二种。谓先未得。及先已得。先未得得。说名为获。先已得得。说名成就。应知非得。与此相违。谓先未得及得已失。未得非得。说名不获。已失非得名不成就。故说异生性。名不获圣法。于何法中有得非得。且有为中。于自相续。有得非得。非他相续及非相续。若蕴堕在自相续中。可有成就不成就故。他相续蕴及非情蕴。必无成就不成就故。无为法中。唯于二灭。有得非得。一切有情。无不成就非择灭者。故对法中。有如是说。谁成无漏法。谓一切有情。除初刹那具缚圣者及余一切具缚异生。诸余有情。皆成择灭。决定无有成就虚空。以于虚空无有得故。亦无不成就。以无非得故。若法有得亦有非得。若法无得亦无非得。其理决定。依此得故。说如是言。色蕴行蕴。一得所得。余蕴行蕴。说亦如是。有漏无漏。一得所得。有为无为。一得所得。如是等类。如理应思。经主此中作如是问。何缘知有别物名得。应答彼言。契经说故。如契经中薄伽梵说。应知如是补特伽罗。成就善法及不善法。若谓经说有转轮王成就七宝。有太过失。此难不然。王于七宝自在无碍。名成就故。若谓余经所说成就亦应尔者。此亦不然。以现在者。唯于现在有自在力。非过未故。谓转轮王。于现七宝有自在力。增上果故。恒现前故。随乐而转。可名成就。善不善法。则不决定。且如善法。现在前时。补特伽罗。于现善法。可说成就。彼于过未不善法中。应更指陈。若无现得由何别法。说为自在。不善现前征善亦尔。况执过未全无体者。于何自在说名成就。若于未来。有能生力名成就者。理亦不然。是则应有非爱过故。谓诸异生。住最后有。定生无漏应是圣者。诸阿罗汉。住最后心。决定不能复生无漏。应非阿罗汉。便退成异生住世俗。忍见所断烦恼。必不复生。应是预流果。又若许有别物名得。有何非理。如是非理。谓所执得。无体可知。如色声等。或贪嗔等。无用可知。如眼耳等。故无容有别物名得。执有别物。是为非理。此定不然。非非理故。由所许得是已得法不失因故。又是知此系属于彼。智幖帜故。除此更有何别大用能过于此。说此为无。若尔何用执此得为。唯所依中。有诸种子。未拔未损。增长自在。于如是位。立成就名。由斯不失已得诸法。亦此属彼智之幖帜。此复云何。且诸善法。略有二种。一者不由功力修得。二者要由功力修得。即名生得及加行得。不由功力而修得者。若所依中。种未被损。名为成就。若所依中种已被损。名不成就。谓断善者。由邪见力。损所依中善根种子。应知名断。非所依中善根种子毕竟被害说名为断。要由功力而修得者。若所依中。彼法已起。生彼功力自在无损。说名成就。与此相违。名不成就。不善无记。由对治道。断伏种子。或无功力可生现行。名不成就。与此相违名为成就。故所执得便为无用。如是种种颠倒所执。但有虚言。而无实义。且执何法名为种子。谓名与色。于生自果。所有展转邻近功能。此由相续转变差别。名色者何。谓即五蕴。如何执此为种子性。能为善等诸法生因。为总为别。为自种类。且汝所执。唯应尔所。若言是总种体应假。假为实因。不应正理。若言是别。如何可执无记色种为善不善诸法生因。若自种类善法无间。不善法生。或复相违。以何为种。天爱非汝解种子性。前心俱生思差别故。后心功能差别而起。即后心上功能差别。说为种子。由此相续转变差别。当来果生此中意说。不善心中。有善所引展转邻近功能差别。以为种子。从此无间善法得生。或善心中不善所引展转邻近功能差别。以为种子。从此无间不善法生。今汝所执功能差别种子。与彼善不善心。为有别体。为无别体。此无别体。岂不许善为不善种及许不善为善种耶。谁有心者。执暖与火无有别体。而复执言。唯暖能烧。火不能烧。云何能感那落迦等诸异熟果。不善心中。安置能感。可爱异熟善思差别所引功能差别种子。复云何感末奴沙等诸异熟果。净善心中。安置能感非爱异熟恶思差别所引功能差别种子。诸不善心。于感可爱诸异熟果。无堪能故。诸净善心。于感非爱诸异熟果。无堪能故。云何言二能招二果。如是便谤诸佛世尊所得十力中处非处智力。又应许思差别所引功能差别种子与心同一果故。无漏心中。亦有有漏功能差别。则无漏心。亦应能感三有之果。无漏心中。亦许安置烦恼种故。则无漏心。亦应能作烦恼生因。或圣身中。修所断惑。应无种子自然而生。烦恼心中亦许安置无漏种故。则烦恼心。亦应能作无漏生因。或圣身中。烦恼心后所起无漏。应无种生。或应尔时名初无漏。又退法性阿罗汉果。或有退起诸烦恼故。即阿罗汉无学心中。应有三界烦恼种子。有烦恼退。后当广辩。又曾未见异种类法性有差别而无别体。故彼所执极为迷谬。又前所起思差别。与后功能差别心云何作因果更互相应义。此何所疑。因果法尔。要有前思差别故。方有后心功能差别生。若无前思差别者后心功能差别则不起。是故此二得有因果更互相应。若有思时少有所起。可有此义。然有思时都无所起。未来无故。前思后心有无不并。云何可说因果相应。如是等义。辩过未中。当更思择。然彼所说。非所依中善根种子毕竟被害说名断者。何故但言非毕竟害。此但应言毕竟不害。本无种故。又彼所说。违害契经。以契经言毕竟断故。如世尊说。应知如是补特伽罗。善法隐没。恶法出现。有随俱行。善根未断。以未断故。从此善根。犹有可起余善根义。彼于后时。一切皆断。如何所有微劣善根一切皆断。非毕竟害。故彼但应由自分别魍魉所魅。而作此言。又善种子。若邪见力。损其功用。令不生芽。设非毕竟断。此复何所用。无用能生善根芽故。若邪见力。不能损彼生善芽用。是则不应名断善根。能生善故。又彼所言。要由功力而修得者。若所依中彼法已起。生彼功力。自在无损。说名成就。此亦非理。彼宗此善生义尚无。况有身中彼法已起。生彼功力。自在无损。前说彼宗。未来无故当于何处有自在力。即彼生因。理非有故。不应征觅余不生因。既无生因。依何而说生彼功力自在无损。由此已遮说烦恼断品类计度。然彼所言。犹如种子火所焚烧转变异前无能生用。如是圣者所依身中。无生惑能。名烦恼断。惑世间道。损所依中烦恼种子。亦名为断。与上相违名未断者。此今应说。以无漏道。断诸烦恼。与世间道断诸烦恼。有何差别。俱如种子火所焚烧无生用故。若谓如种非极被损令永不能生于芽等。以世间道。损烦恼种。亦复如是。犹能如前生诸行果及当能起诸烦恼者。如何说言如种被损。种被损者谓不生芽。若能生芽不名被损。由世俗道。断惑亦尔。若损惑种。应不能生后既能生。不应名损。若不名损。如何名断。又一心中。能断所断。理不俱有。断义不成。故彼所言。谓名与色。于生自果。所有展转邻近功能。名为种子。理不成立。又彼所言。此由相续转变差别。何名转变。谓相续中前后异性。何名相续。谓因果性。三世诸行。何名差别。谓有无间生果功能。如是具寿。一切所说。异意异言其首亦异。以譬喻者无有相续前后异性。亦无因果三世诸行。亦无无间生果功能。如后当辩。彼由憎背对法义宗。于圣教中。起诸过患。如诽谤得于圣教中所起众多违理过患。如是于得若许实有。于圣教义有何相违。经主于中虽随自执多有所说。而无所成。所执种子理不成故。种子既无。知所许得。是已得法。不失因故。又是知此系属于彼。智幖帜故。决定有用。用有既成。知别有体。故所许得。体用极成。对法诸师议论宗处。诸譬喻者。多分于中申自所执诸法种子。惑乱正义。令不分明。复有诸师。于此种子。处处随义。建立别名。或名随界。或名熏习。或名功能。或名不失。或名增长。故我此中广兴决择。摧彼所执建立正宗。如是已成得非得性。此差别义今应广思。且得云何。颂曰

  三世法各三　　善等唯善等
  有系自界得　　无系得通四
  非学无学三　　非所断二种

论曰。三世法得各有三种。谓过去法。有过去得。有未来得。有现在得。如是未来及现在法。各有三得。约容有义。且作是说。其中差别。后当更辩。又善等法。得唯善等。谓善不善及无记法。如其次第。有善不善无记三得。又有系法。得唯自界。谓欲色界无色界法。如其次第。唯有欲色无色三得。若无系法得通四种。谓不系法。就总种类。具四种得。即三界系及与不系。别分别者。非择灭得。通三界系。若择灭得。色无色系及与不系。其道谛得。唯有不系。又有学法。得唯有学。若无学法得唯无学。故学无学法得各有一种。非学无学法得总类有三。别分别者。全五取蕴。及三无为。总名非学非无学法。且五取蕴。及非择灭。并非圣道所证择灭。唯有非学非无学得。若有学道所证择灭。得唯有学。若无学道所证择灭。得唯无学。又见修所断法。如其次第。有见修所断得。非所断法得总有二。别分别者。诸无漏法名非所断。若非择灭及非圣道所证择灭得唯一种。谓修所断。若以圣道所证择灭。及道圣谛得唯一种。谓非所断前言三世各有三得。诸有为法。皆定尔耶。不尔。云何。颂曰

  无记得俱起　　除二通变化
  有覆色亦俱　　欲色无前起

论曰。无覆无记得唯俱起。无前后生。势力劣故。一切无覆无记法得。皆定尔耶。不尔。云何。除眼耳通及能变化。谓眼耳通慧。及能变化心。势力强故。加行差别所成办故。虽是无覆无记性收。而有前后及俱起得。又威仪路四蕴之得。多分世断及刹那断。唯除诸佛马胜苾刍及余善习威仪路者。若工巧处四蕴之得。亦多世断及刹那断。除毗湿缚羯磨天神及余善习工巧处者。唯有无覆无记法得。但俱起耶。不尔。云何。有覆无记色得亦尔。谓唯色界初静虑染身语表业得亦如前。但有俱起。虽上品染。而亦不能发无表故。势力微劣。由此定无法前后得。欲界诸色。亦定唯有俱起得耶。不尔。云何。谓欲界系善不善色得无前起。唯有俱生。及后起得。如是已辩得差别相。非得差别其相云何。颂曰

  非得净无记　　去来世各三
  三界不系三　　许圣道非得
  说名异生性　　得法易地舍

论曰。性差别者。一切非得。皆唯无覆无记性摄。世差别者。过去未来。各有三种谓过去法及未来法。一一各有三世非得。若现在法。唯有过去未来非得。决定无有现在非得。以现在法与不成就不俱行故。有说。现法无现非得。性相违故。界差别者。三界系法。及不系法。各三非得。谓欲界系法。有二界非得。色无色界系。及不系亦尔定无非得是无漏者。所以者何。由许圣道非得说名异生性故。如本论言。云何异生性。谓不获圣法。不获即是非得异名。如何无漏法可名异生性不获。何圣法名异生性耶。为总不获一切圣法。为唯不获苦法智忍。有说。不获一切圣法。若尔岂不无非异生。无一总成诸圣法故。若有不获不杂于获。是异生性。若杂获者。非异生性。故无有失。若尔本论应说纯言。不尔杂言见义有故。如说此类食水食风。虽无纯言。而亦知彼纯食水风。不杂余故。有说。不获苦法智忍。然非后舍复成异生。前已永害。彼非得故。经主于此复作是言。若曾未生圣法相续。分位差别。名异生性。何缘经主。复作是言。谓异生性。都无实物。若尔是谁相续分位。谓眼耳等相续分位。岂一刹那眼等分位。非异生性。而言眼等相续方是异生性耶。非一刹那可名相续。刹那便有非实过故。此非唯有言违义失。亦复有余违契经过。故世尊说。如是名为随信行者。入正性离生。超越异生地。此异生地。即异生性。何缘故知。说得舍故。非于尔时舍曾所得眼等诸法少分可知。如得未曾所得圣法。圣者正在见道位时。成就眼等一切品类。皆如前位。无所缺减。若异生性。无别有体。便违此经。尔时无别异生地体可超越故。若谓恶趣是异生地。得忍位已应非异生。若谓眼等未得圣时离圣法故。依之假立异生名想是异生性。入见道时。超越彼故。说名超越异生地者。理亦不然。如何尔时眼等诸法如本随逐。而可说为超越眼等。若言如证阿罗汉果超越眼等。理亦不然。彼时具证眼等结断。虽成就眼等而名超越故。今此位中。眼等如本具缚成就。故喻不齐。若谓如言未离欲圣超越恶趣。理亦不然。于彼已得非择灭故。未离欲圣。于彼不作不趣不行。可名超越。今见道位。超何眼等。若言应有异瓶等物瓶等性者。理亦不然。离破瓶等。舍瓶等性理不成故。无漏心起时。眼等如本。而舍异生性。故例不齐。由此已遮生性等例若言婆罗门等性何不尔者。如圣异生定差别。彼不见故。谓圣异生。各有少分不作不趣。作趣定别。无有少分智慧工巧制止堪能定差别事。婆罗门等。诸种姓中。唯一能为。非余能作。可因此执有婆罗门等性。虽亦见有中边国等少分差别。而无别性。由许别有众同分法为差别依。故无有过。岂不如圣法即说是圣性。成就此性。故名圣者。如是异生法应即异生性。成就此性。故名异生。此例不然。以诸圣法唯圣者有。可即圣法说为圣性。诸异生法圣者亦有。如何可立为异生性。若异生法。唯异生有遍异生成可是异生性。恶趣无想北俱卢等。不遍异生故非异生性。余命根等。虽遍异生。非唯异生有。亦非异生性。又唯异生有遍异生相续。违圣道得是异生性。又若有法与诸异生作身生因是异生性。岂不业烦恼与诸异生作身生因。何用异生性。此责非理。现见有法待余因方能作余法因故。非业烦恼所生眼等。离四大种。而可得生。故有别法。名异生性。即超越此。故名超异生地。要作此释。方显世尊所说契经有大义趣。傍论已了。今更应思。如是非得。何时当舍。此法非得。得此法时。或转易地。舍此非得。如圣法非得说名异生性。随得圣法时舍三界非得。如是住初无漏心者。于苦法智展转乃至。住金刚喻三摩地者。于阿罗汉所有非得。如其所应。随得此法。舍此非得。如是乃至。阿罗汉果。时解脱者。于阿罗汉不时解脱。所有非得。得此法时。舍此非得。余法非得。类此应思。又此非得。云何名舍。若非得得断。非得非得生。如是名为舍于非得。得与非得。虽各有余得及非得。然非无穷。由得势力。成就本法及与得得。得得势力。成就法得。岂成无穷。非得亦应如理思择。非得非得。必不俱生。又从下地生上地时。下地非得一切皆舍。从上生下。类此应知。由所依力。非得转故。如是已辩得非得相。同分者何。颂曰

  同分有情等

论曰。有别实物。名为同分。谓诸有情。展转类等。本论说此。名众同分。一趣等生。诸有情类。所有身形。诸根业用。及饮食等。互相似因。并其展转相乐欲因。名众同分。如鲜净色业心大种。皆是其因。故身形等。非唯因业。现见身形。是更相似。业所引果。诸根业用。及饮食等。有差别故。若谓满业有差别故。此差别者。理不应然。或有身形。唯由相似引业所起。以众同分有差别故。业用等别。若身形等。唯业果者。随其所乐业用等事。若舍若行应不得有。此中身形业用乐欲。展转相似。故名为同。分是因义。有别实物是此同因。故名同分。如是同分。世尊唯依诸有情说。非草木等。故契经言。此天同分。此人同分。乃至广说。就界趣生处身等别。有无量种有情同分。复有法同分。谓随蕴处界。异生同分入离生时舍。有情同分入涅槃时舍。岂不异生性即异生同分。此不应然。所作异故。谓彼身形业用乐欲。互相似因。名为同分。若与圣道成就相违。是异生因。名异生性。入离生时。于众同分。亦舍亦得。于异生性。舍而不得。同分非色。如何得知。有用能生无别事类。由见彼果。知有彼故。如见现在业所得果。知有前生曾所作业。又观行者。现证知故。何不许有无情同分。不应如是责。有大过失故。汝亦许有人天等趣胎卵等生。何不亦许庵罗等趣菉豆等生。又佛世尊。曾不说故但应思择。何故世尊。唯于有情。说有同分。非于草等。复云何知。如是同分。别有实物。且我于中作如是解。由彼草等无有展转业用乐欲互相似故。于彼不说别有同分。又必因有情。草等方生故。唯于有情。说有同分。又因先业及现勤勇。此法得生。于彼草等。二事皆无。故无同分。即由此事。证有实物。又木素漆雕画等像。及彼真形。虽有色形展转相似。而言一实。由此非唯见彼相似。即言是实。要于相似差别物类。方起实言。故知实有此差别法。此实言说。由此法生。又前说故。前说云何。谓见身形。是更相似。业所引果。诸根业用。及饮食等。有差别故。是诸同分。展转差别。如何于彼。更无同分。而起无别觉施设耶。由诸同分是同类事等因性故。即为同类展转相似觉施设因。如眼耳等由大种造。方成色性。大种虽无余大种造。而色性成。此应显成胜论所执总同句义同异句义。若胜论执。此二句义。其体非一。刹那无常。无所依止。展转差别。设令同彼。亦无多过。非胜论者执眼等根能行色等。即令释子舍如是见。别作余解。故彼所难。是朋党言。求正理人。不应收采。已辩同分。无想者何。颂曰

  无想无想中　　心心所法灭
  异熟居广果

论曰。若生无想有情天中。有法能令心心所灭。名为无想。是实有物。能遮未来心心所法。令暂不起。如堰江河。此法一向是无想定所感异熟。由彼无想有情天中。无想及色。唯是无想定所感异熟故。此定无力引众同分及与命根。以众同分及与命根唯是有心。第四静虑所感果故。彼处余蕴。是共异熟。以生无想有情天中。入无想前。出无想后。多时有心故。然无心位。极长远故。总名无想天。无想有情。居在何处。居在广果。谓广果天中。有高胜处如中间静虑。名无想天。彼以宿业。等无间缘。为任持食。谓由宿业。引众同分及命根等。由续生心及无间入无想果心。牵引资助。故彼亦有过去触等。为任持食。无心位中。唯有过去触等为食。现在都无。有心位中。二种俱有。彼诸有情。由想起故。从彼处没。没已决定生于欲界。非余处所。先修定行。所感寿量。势力尽故。于彼不能更修定故。如箭射空力尽便堕。若诸有情。应生彼处。必有欲界顺后受业。如应生彼北俱卢洲。必定应有生天之业。已辩无想。二定者何。谓无想定。及灭尽定。初无想定。其相云何。颂曰

  如是无想定　　后静虑求脱
  善唯顺生受　　非圣得一世

论曰。如前所说。有法能令心心所灭。名为无想。如是复有别法。能令心心所灭。名无想定。说如是声。唯显此定灭心心所与无想同。由正成办。或极成办。故名为定。有余师说。如理等行故名为定。令心大种平等行故。无想者定。或定无想。名无想定。由厌坏想。生此定故。非诸异生能厌坏受。由耽着受而入定故。此定在何地。谓在后静虑即在第四静虑非余。此不应说。所以者何。此定能感无想异熟。已说无想居广果天。当说广果。在后静虑。岂于余地而修彼因。此责不然曾无说故。未曾有处说无想定为无想因。岂不前颂说无想为异熟。于彼释中。说为无想定果。此亦不然。曾未有颂作如是说。今说乃成。何故此定。名异生定。为求解脱修此定故。彼执无想是真解脱。执无想定为出离道。为证无想而修此定。一切圣者。不执有漏为真解脱及真出离。故说此定名异生定。前说无想。是异熟故。无记性摄。不说自成。今无想定。一向是善。岂不此是异熟因故。善性所摄不说自成。此于无想有情天中。为因能招五蕴异熟。不尔颂中犹未说故。又染无记。谁复能遮。若尔此中应言纯善。不尔离言见义有故。此应准前异生性释。或唯言善。已显非余。此定既是异熟因性。为顺何受。唯顺生受非顺现后及不定受。一类诸师。作此定执。理顺生受及不定受。所以者何。成此定者。亦容得入正性离生。入已必无现起此定。由约现行。说无想定名异生定。非约成就。又许此定通是此法外法异生所得非圣。以诸圣者于无想定如见深坑不乐入故。颂中已说求脱言故。即显此定唯属异生。复言非圣。便为无用。此初得时。为得几世。此于诸位中。如别解脱戒。念念别得。未曾得故。第一念时。非得过去。以无心故。不修未来。故初得时。唯得一世。谓得现在。第二念等。乃至未出。亦成过去。出已乃至未舍已来。唯成过去。如天眼耳。无未来修。唯加行得。非离染得。次灭尽定。其相云何。颂曰

  灭尽定亦然　　为静住有顶
  善二受不定　　圣由加行得
  成佛得非前　　三十四念故

论曰。如前无想定。灭尽定亦然。谓如已离第三静虑贪者。有法能令心心所灭。名无想定。如是已离无所有处贪者。有法能令心心所灭。名灭尽定。如是二定差别相者。前无想定。为求解脱厌坏于想。以出离想作意为先。而得证入。今灭尽定。为求静住厌坏散动。以止息想作意为先。而得证入。前无想定。在色界边地。今灭尽定。在无色边地。以在非想非非想处所受生身。是最上业。所牵引故。说名有顶。或有边际。故名有顶。如树边际说名树顶。唯此地中。有灭尽定。何缘下地无此定耶。厌背一切心及边际心断。方能得此胜解脱故。谓由二缘。立此解脱。一者厌背一切心故。二者边际心暂断故。若于下地有此定者。便非厌背一切种心。以未能厌上地心故。亦不名为边际心断。以上地心犹未断故。应名厌背少分诸心。亦复应名中际心断。于三性中。此灭尽定。同前唯善。非染无记。非诸圣者厌怖散动取染无记为寂静住。前无想定能顺生受及不定受。今灭尽定。通顺生后及不定受。谓约异熟。有顺生受。或顺后受。及不定受。或全不受谓若下地起此定已。不生上地便般涅槃。此灭尽定。能招有顶四蕴异熟。前无想定。唯异生得。此灭尽定。唯圣者得。非诸异生能起灭定。彼有自地。起灭定障。犹未断故。未超有顶见所断惑于起灭定毕竟无能。非诸异生能超有顶见所断惑。故唯圣者。得灭尽定。有余师说。由诸异生怖断灭故。圣者于此现法涅槃胜解入故。唯圣者得。非诸异生彼说非理。于无想定。与此同故。彼此心断。涅槃胜解。无差别故。此中有说。第四静虑心心所粗。犹有所依。故不怖断。彼亦非理。修无想定。为灭心故。为求解脱起出离想。修无想定。怖畏灭心。不应正理。既出离想。修无想定。亦应涅槃胜解而入是故彼说。非为正因。一切圣者。得有顶时。皆得如斯灭尽定不。应言不得。由此定非离染得故。由何而得。由加行得。要由加行。方证得故。如无想定。初证得时。唯得现在。不得过去。不修未来。要由心力。方能修故。第二念等。乃至未舍。亦成过去。世尊亦以加行得耶。不尔。云何。成佛时得。彼谓世尊尽智时得。岂不尽智于成佛时亦不名得。况灭尽定。以诸菩萨住金刚喻三摩地时。名得尽智。得体生时。名为得故。于成佛时。应说尽智。不由加行而现在前。暂起欲乐现在前时。一切圆德。随乐起故。非佛身中所有功德成佛时得。如何可说佛尽智时得灭尽定。由菩萨时永离一切烦恼染故。令佛身中功德得起。故说如来所有功德。皆离染得。故彼所言。亦有过失。随宜为彼而通释者。谓于近事。而说远声。或金刚喻三摩地时。必成佛故。亦名成佛。无间刹那。定成佛故。且置斯事。世尊曾未起灭尽定。得尽智时如何得成。最上圆满俱分解脱。永离定障故。舍不成就故。于起灭定得自在故。如已起者成俱解脱。西方师说。菩萨学位。先起此定。后得菩提。迦湿弥罗国毗婆沙师说。非前起灭定后方生尽智。何因此国知前未起。何为不责西方起因。且我迦湿弥罗国。说三十四念得菩提故。谓诸菩萨。决定先于无所有处。已得离贪。方入见谛。不复须断下地烦恼。三十四念。得大菩提。谛现观中。有十六念。离有顶贪。有十八念。谓断有顶九品烦恼。有九无间九解脱道。如是十八。足前十六。成三十四。于此中间。无容得起不同类心。故于前位。决定无容起灭尽定。若于前位。起灭尽定。便越期心。然诸菩萨。决定不越要期心故。理实菩萨。不越期心。然非不越无漏圣道。若尔期心。如何不越。谓我未得诸漏永尽。终不解斯结加趺坐。决定不越如是期心。唯于一坐时诸事究竟故。岂不由斯已成违越。欲起无漏圣道期心。如何菩萨。为尽诸漏。修未曾得见修二道。欲拔有顶见断惑根。及除有顶修惑怨敌。立誓要期结加趺坐。事未究竟。而于其中。舍所要期无漏治道贵重无始。能为诳惑世间定类。为获共有易得灭定。而致稽留。如是善成三十四念得菩提故。为非前因。如契经说。出灭定时。当触三触。谓不动触。无所有触。及无相触。何者云何触此三触。有说。灭定起心相应。有空无愿无相三触。如其次第。出灭定时。触于三触。有余师说。识处空处心相应触。名不动触此二纯作识空想故。无所有处心相应触。名无所有触。无先所有故。非想非非想处心相应触。名无相触。想无想相。不分明故即由此故。说四无色名有想定。从灭定起心通有漏无漏。灭定起时。或逆次第入诸等至。或逆超越入诸等至。容有如是起灭定心现在前故。复有余师。作如是说。唯约无漏。无所有处缘涅槃心。起灭定时。言触三触。以无漏故。名为不动。无所有处地所摄故。名无所有缘涅槃故。名为无相。虽已说二定有多同异相。而于其中复有同异。颂曰

  二定依欲色　　灭定初人中

论曰。言二定者。谓无想定。及灭尽定。此二俱依欲色二界。而得现起。然于此中。有说。唯在下三静虑。入无想定。非在第四。勿因与果极相邻逼。有说。亦在第四静虑。入无想定。除无想天。以生彼天受彼果故。有余师说。唯在欲界。入无想定。非在色界。彼违论文。谓本论言。或有是色有。此有非五行。谓色廛有情。或生有想天。住不同类心。若入无想定。若入灭尽定。或生无想天。已得入无想。是谓是色有。此有非五行。由此证知。如是二定。俱依欲色而得现起。是名同相。言异相者。谓无想定。欲色二界。皆得初起。灭定初起。唯在人中。谓灭尽定。唯在人中。得初修起。唯人中有说者释者。及有强盛。加行力故。有在人中。初修得已。由退为先。方生色界。依色界身。后复修起。非在无色能入灭定。无所依故。命根必依色心而转。若在无色入灭定者。色心俱无命根应断。诸蕴展转相依而住。故无有情唯具一蕴。又心心所。不相离故。亦无有情唯具三蕴。何因故知。灭定有退。准邬陀夷契经义故。经言具寿。有诸苾刍。先于此处。具净尸罗。具三摩地。具般罗若。能数入出灭受想定。斯有是处。应如实知。彼于现法。或临终位。不能勤修令解满足。从此身坏超段食天。随受一受意成天身。于彼生已。复数入出灭受想定。亦有是处。应如实知。此意成天身。佛说是色界灭受想定。唯在有顶。若得此定。必无退者。不应得往色界受生。如是广释二定异相。总有六门。谓地加行相续异熟顺受初起。有差别故

说一切有部顺正理论卷第十二阿毗达磨顺正理论卷第十三

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩差别品第二之五

今应思择。灭尽定中。总灭一切心心所法。何缘唯说灭受想定。厌逆彼二生此定故。谓想与受。能为见爱杂染所依。故偏厌逆如是二法。多诸过患。如五蕴中已广分别。故偏厌逆入灭尽定。有余师言。诸相应法。若生若灭。若得若断。如是等事。无不同时。然说法者。随宜方便。以种种门差别而说。阿毗达磨。唯依正理。分别诸法性相义类。判决诸经意趣权实。不令如说定执非余。由此应知。诸经意趣。如说此定识不离身。当知心所亦应不离。如说此定诸意行灭。当知此中心亦应灭。如斯影论。余经亦有。如言诸佛正等菩提。皆不放逸以为根本。余经复告阿难陀言。无上菩提。由精进得。如说智慧能害烦恼。余经复言。修无常想。能断欲贪。乃至广说。譬喻论者。作如是言。灭尽定中。唯灭受想。以定无有无心有情。灭定命终。有差别故。经说入灭定识不离身故。又言寿暖识互不相离故。此说非理。以一切心皆与受想俱生灭故。有何至教。证此义成。如契经说。眼及色为缘生于眼识。三和合触。俱起受想思。如是乃至。意及法为缘生于意识等。曾无处言有第七识。可执彼识离受想生。又此定中。所依灭故。能依亦灭。非无所依。诸心所法。可能独生。是故此中。诸心心所。一切皆灭。若谓此俱言显无间起义。如曼驮多恶心起故俱时堕落。如不净俱修念觉支。此亦应尔理必不然。有差别故。曼驮多等。契经俱言。理实应显无间起义。以非爱业与非爱果。决定不应同时生故。又彼经说第五转故。如彼经说。曼驮多王恶心起故。俱时堕落。此显后时方堕落义。不净觉支。有漏无漏性差别故。起不同时。此经俱言。显同时起。圣教正理皆不相违。故此言俱非无间起。又执俱言显无间起。有不定过。如契经说。乐俱喜俱四谛现观。不可复执。此同曼驮多等经。谓乐喜无间方生四谛现观。又如经说。有贪心等。与贪俱故。名有贪心。此不应执从贪无间所起之心名有贪心。如是便有太过之失。故此俱言。显同时义。又受想等。依止心故。名为心所。离所依止。此受想等。应不得生。若谓心作等无间缘名所依者。心亦依心无间生故。应名心所。又从心所无间生心。心所亦应成所依性。如是等义。至六因中。当更广辩。又契经说。入灭定时。诸意行灭。故知灭定。非但灭此受想二法。又识相续。于此定中。非暂灭者。决定应有所依所缘。与识和合离所依缘。识不生故。既有三和。必应有触。与触俱起。有受想思。则灭定中。受想二法。亦应不灭。若谓如经说受缘爱。然阿罗汉。虽有诸受。而非爱缘。触亦应尔。非一切触皆生受等。此例不然。有差别故。经自简言。若无明触所生诸受。为缘生爱。诸阿罗汉。无无明触。故虽有受。而不生爱。曾无有处简触生受。故但有触。必生受等。有余师说。于灭定中。虽有识体。而无触者。未知彼意执何为触。然一切识。必托所依所缘而起。所依缘识。三法和合。佛说为触。由触为缘。生受想等。许灭定中有三和合。然说无触但有虚言。又灭定中。唯有心者。应无思虑。以灭定中说诸意行悉皆灭故。心若无思。即无思虑。无思虑心。同所不许。心有作业。皆由思故。思既非有。心亦定无。无心有情。理必应有。有命等故。异于命终。有情色心。非决定有。心若定有。色亦应然。色有时无。心亦应尔。故有命者。即名有情。然命必依色心随一。引契经说。识不离身。于定无心。亦无违害。以即于此所依身中识必还生。故言不离。谓一相续。众同分中。识相续流。非毕竟断。譬如鬼病暂不发时。由未永除。仍名不离。引寿暖识不相离言。于定无心。亦无违害。唯于少分说此言故。以无色中都无有暖。非无寿识。故此定中。都无有识。非无寿暖。无色界中。无一切色。后当广辩。是故灭定。必无有心。然定后心。复得生者。定前心作等无间缘。所引摄故。又加行中。要期势力。所引发故。灭尽定体为假为实。应言此定体实非假。能遮碍心。令不生故。经主于此。引异释言。由前定心能为遮碍。谓前定心。与所余心。相违而起。由此起故。唯令余心暂时不转。此能引发违心所依。令相续故。唯不转位。假立为定。无别实体。此唯不转分位假定。入前出后。两位皆无。故假说此。是有为摄。或即所依。由定心引。令如是起。假立为定。若尔后心从何而起。彼说此依有根身起。以有根身与心展转为种子故。何有此理。应一切时一切境识俱时起故。说依前心后心起者。以无第二等无间缘。虽有同时所依境界。而无一切境识俱起。若执不待自类因缘待有根身识便起者。彼一切位。一切境识。何法为碍。起不俱时。闻有余师。起如是见。执有多识一身俱起。今观仁者。似己禀承故说此言。欲符彼执。若言所说不待前心待有根身后识起者。据无心位。作如是说。有根身中。有心种故。但从彼起。非待前心。有心位中不从彼起。此亦非理无异因果。又有心位。诸识起时。转更应待有根身种。所以者何。在无心位。有根身中。有违余心定心种子。由此损伏有根身中余心种子。应无胜力引起余心。若言此位有根身中。有不违心无量心种。由此胜力余心生者。有心位中。亦应同此。如何不待有根身生。又如有执。不待自类种子为因。谷麦等芽。但由地等而得生起。何有智人。闻不嗤笑。又执灭定体唯是假。未知何法为假所依。非离假依可有假法。又唯不转其体是无。如何可言是有为摄。此前后位及现皆无。有性恒时不可得故。而言是有是有为摄。但有虚言。都无有义。若言假定亦有所依。谓所依身。由定心引。令如是起。假立为定。是则此定应无记摄。非无记法可说为善。是故唯应依心心起。非前定心力能遮碍余心。由此故知。离前心外定有别法。能遮碍心。由此法故。于无心位。虽有心因。而心不起。即此别法。名灭尽定。体是有为。实而非假。修观行者。由定前心要期愿力所引发故。令灭尽定势力渐微。至都尽位。无遮碍用意法为缘。还生意识。由此准释。前无想定。及与无想。随其所应。已辩二定。命根者何。颂曰

  命根体即寿　　能持暖及识

论曰。命体即寿。故本论言。云何命根。谓三界寿。异名虽尔。自体未详。应更指陈。何法名寿。谓有别法。能持暖识。说名为寿。故世尊言

  寿暖及与识　　三法舍身时
  所舍身僵仆　　如木无思觉

故有别法。能持暖识。相续住因。说名为寿若尔此寿。何法能持。此寿能持我说是业。一向是业异熟果故。一期生中。常随转故。暖非一向业异熟果。识二俱非虽有一期常随转处。而非一向是业异熟。故不可说识由业持。是故说寿能持暖识。非非业感识流转中业有少分能持功用。一同分中。异熟生识。断而更续。寿力所持。复如何知。寿能持暖。要有寿者。方有暖故。诸无暖者。亦见有寿。故知寿体非暖所持。岂不无寿亦见有暖。虽亦见有非此所论。此论寿识俱行暖故。由此故知。有别实法。彼力能持有情数暖。及能持识。说之为寿。经主于此。复作是言。今亦不言。全无寿体。但说寿体非别实物。若尔何法说名寿体。谓三界业。随应所引六处并依住时势分。由业所引六处并依住时势分。相续决定。随应住时。尔所时住。故此势分。说为寿体。如谷种等所引乃至熟时势分。又如放箭所引乃至住时势分。寿体实有。根处已成。于此但应征经主意。若处无业所引异熟内五色处。于彼或时无业所引第六意处。谓于长时起染污识或善有漏。及无漏识。相续位中。无业所引异熟势分。说何为寿。若于是处有业异熟。从生刹那至命终位。恒无间转可说是处有业所引住时势分。相续决定。说为命根。此既无业所引异熟住时势分恒无间转。云何可说此有命根。其理既然。为说何法名业所引住时势分。既无所引住时势分。相续决定。复属于谁。既无如是相续决定。由何义说随应住时尔所时住说为寿体。是故经主。于此义中。专构多言。都无所表。又所引喻。于证无能。如种所引相续无断。乃至熟时。恒随转故。放箭所引相续无断。乃至住时。恒随转故。此二可有乃至熟时住时势分。非业异熟。于一切时。相续无断可言业谢犹有所引住时势分相续决定。随应住时。尔所时住。故所引喻。于证无能。是故寿体。实有别物。能持暖识。说为命根。如是命根。非唯依身转。于无色界。有命根故。非唯依心转。处无心位。亦有命故。若尔命根依何而转。此依先世能引业转及依现世众同分转。其众同分。亦准命根。今复应思。诸有死者。为寿尽故。为有余因。施设论言。有寿尽故死。非福尽故死。广作四句。第一句者。感寿异熟业力尽故。第二句者。感富乐果业力尽故。第三句者。能感二种业俱尽故。第四句者。不能避脱枉横缘故。不应复言舍寿行故。义已摄在初句中故。寿尽位中福尽。于死无复功能。故俱尽时有死。说为俱尽故死。发智论说。此寿当言随相续转。为复当言一起便住。欲缠有情。不入无想定。不入灭尽定。当言此寿随相续转。若入无想定。若入灭尽定。及色无色廛一切有情。当言此寿一起便住。彼言何义。若所依身。可损害故。寿随损害。是名第一随相续转。若所依身不可损害。如起而住。是名第二一起便住。初显有障。后显无障。由此决定有非时死。故契经说。有四得自体。谓有得自体。唯可自害。非可他害。广作四句。唯可自害非他害者。谓生欲界戏忘念天意愤恚天。彼由专习增上嬉戏。身体疲劳。意念忘失。又由发起增上愤恚。以怨恨心。更相顾视。是故于彼殒没非余。此复应说舍寿行者。以不由他自舍命故。唯可他害非自害者。谓处卵中。及处胎中。羯刺蓝頞部昙闭尸键南钵罗奢佉位。由彼无能自损害故。俱可害者。谓余多分欲界有情。俱非害者。谓在中有色无色界。一切有情。及在欲界。一分有情。如那落迦北俱卢洲正住见道慈定灭定及无想定王仙佛使佛所记别达弭罗嗢怛罗殑耆罗长者子耶舍鸠磨罗时彼最后身菩萨及此菩萨母怀菩萨胎时一切转轮王及此轮王母怀轮王胎时。若尔何故契经中言。大德何等有情所得自体。非可自害非可他害。舍利子谓在非想非非想处受生有情。彼轻举后以摄初故。如余契经。举初摄后。谓如经说。初静虑中。有离生乐。此举最初摄后诸地。亦有此乐。此经亦尔。举后摄初。或除有顶其余无色。诸静虑中受生有情。亦如欲界戏忘念天意愤恚天。唯可自害。彼亦由起如是种类烦恼力故。从彼处没。或余无色诸静虑中。所得自体。可为自地圣道所害。亦上他地近分所害。有顶自上二害俱无是故说为俱非所害。岂不有顶亦为他地圣道所害。应名他害。若依此说。理亦应通。然今言他意说上地。以于殊胜事亦他声转故。或此于彼无自在力。方说为他上地于下皆得自在。不名他故。然于此中。应作是责。若佛意说。自他地道。断诸烦恼。名自他害。则不应言因自他害便有致死。非因断惑不断惑故有死不死。又与前释理不相应。谓那落迦等。非自他所害。然彼尊者。于前所说。自他害义心已领解。为显余义。复作是言。大德彼诸有情。为从彼处有殒没不。舍利子。若彼有情。未断烦恼。便有殒没。已断烦恼。即于彼处。而般涅槃。何缘尊者但依最后所得自体。复问世尊。由彼俱无自他害故。有于彼起常增上慢。为令弃舍。故复问言。彼诸有情。乃至广说。命行寿行。有何差别。若生法寿。名为命行。不生法寿。说为寿行。有作是言。非所弃舍。名为命行。是所弃舍。名为寿行。复有说言。若神足果。名为命行。若先业果。名为寿行。复有说者。若明增上生。名为命行。无明增上生。名为寿行。或有说者。唯离贪者相续所得。名为命行。亦有贪者相续所得。名为寿行。是为命行寿行差别。已辩命根。何谓诸相。颂曰

  相谓诸有为　　先住异灭性

论曰。如是四种。是有为相。显彼性故。得彼相名。此中生者。谓有别法。是行生位。无障胜因。由能引摄。令其生故。能引摄者。谓彼生时。此法能为彼胜缘性。虽诸行起。皆得名生。然此生名。但依诸行生位无障胜因而立。住谓别法。是已生未坏诸行。引自果无障胜因异谓别法。是行相续后异前因。灭谓别法。是俱生行灭坏胜因。性是体义。岂不经说有三有为之有为相。住为善友。能安有为。何故不说。契经不说。必有所因。应为开示。若有诸相。唯表有为。此经便说。非此住相唯表有为。诸无为法。亦自住故。或复于此具显有为功德过失。故说四种。于契经中。唯为显示有为过失。故但说三。或如余经。但言行是有生灭法。非无有异。此经亦然。非无住体。观少因故。唯说有三。故四与三。无相违失观何因故。唯说有三。住通有为无为品故。勿所化者生如是疑。有为无为。展转相似。故虽有住。而但说三。或此经中。已密说住。以直言三。无唯声故。若异此者。应说唯有三种有为之有为相。或此经中。住异合说。不尔住言应成无用。合说意者。为显有为住必兼异。诸无为法。有住无异。故别有为。非此经中言住异者。显住即异。但显有为有起有尽有住有异。若谓无为住不成者。此不应理。必应成故。以当成立有三无为。由此即成无为有住。故定唯有四有为相此生等相。既是有为。应更别有生等四相。若更有相。便致无穷。彼更有余生等相故。实许更有。然非无穷。所以者何。颂曰

  此有生生等　　于八一有能

论曰。此中有言。兼显定义。意显此有唯四非余。此谓前说四种本相。生生等者。谓四随相。即是生之生生。乃至灭之灭灭。诸行有为。由四本相。本相有为。由四随相。世尊何处说随相耶。岂不此经亦说随相。谓生等相。亦是有为。故生生等相。亦起等性故。契经既说。有三有为之有为相。有为之起。亦可了知。尽及住异。亦可了知。如何此中不摄随相。又于诸相。皆有亦言。故此经中。亦说随相。言有为之起亦可了知者。起即本相生。亦表生生义。尽及住异亦可知言类起。亦言应如理释。若不尔者。何用亦言。故契经中。于无为法说尚无有起等可知。此说意言。诸无为法。尚无生等本相可知况生生等随相可得。若不尔者。应但说无起等可知。不应言尚。又薄伽梵。于契经中。说诸有为相复有相。故契经说色有起尽。此复应知。亦有起尽。乃至广说。又契经说。老死生等。由此故知。相复有相。若尔本相。如所相法。一一应有四种随相。此复各四展转无穷。无斯过失。四本四随。于八于一功能别故为亲缘用。名曰功能。谓四本相。一一皆于八法有用。四种随相。一一皆于一法有用。其义云何。谓法生时。并其自体。九法俱起。自体为一。相随相八。本相中生。除其自性。能为亲缘。生余八法。诸法于自体。无生等用。故随相生生为亲缘用。于九法内。唯生本生。此生一生多由功能别。故生性既无异功能。何有别如受领纳性。虽无异而有差别损益功能。又本相随相。境有多少。如五识意识境有少多。本相中住。亦除自性。能为亲缘。住余八法。随相住住。能为亲缘。于九法中。唯住本住。谓为亲缘令法暂住。能引自果。是住功能。本相中异。除其自性。能为亲缘。异余八法。随相异异。能为亲缘。于九法中。唯异本异。本相中灭。除其自性。能为亲缘。灭余八法。随相灭灭。能为亲缘。于九法中。唯灭本灭。是故生等相复有相。随相唯四。无无穷失。何缘如是分别相耶。异此分别。不应理故。所以者何。非舍如斯阿毗达磨立相正理。朋顺余宗。少有能立有为相故。诸有违背对法正理于诸相等真实义中。所生觉慧。皆为迷谬。凡有所说。莫不乖真。我今于中次第广辩。且彼经主。缘他故说。何缘如是分析虚空。非生等相有实法体。如所分别。所以者何。无定量故。谓此诸相。非如色等有定现比。或至教量。证实有者。岂生等相。有实法体。如余分别不尔若尔如是所言。非生等相有实法体。如所分别。便为无用。又此诸相。岂如瓶等有定现比。或至教量。证体假有。既遮实有。故彼定应许生等相体是假有。第三计有理必无故。由遮差别。准知定应非许生等。毕竟无故。且无现量证彼生等体是假有。诤论事故。亦无至教证彼生等体是假有。无处说故。若假有比量实有亦应同。是则汝曹由执假有。岂非倒是钻搅虚空。证相体实理后当辩。今应先引至教为证。谓契经言。诸邪见者。所有身业语业意业。诸有愿求。皆如所见。所有诸行皆是彼类。此经意说。生等诸行。随彼转故。彼一果故。彼为因故。名为彼类。由此经中。说三业义。故受等行。非此所须。又一境转故。但应随说一。是故但应身语意业。俱行生等说为诸行。此行从彼邪见所生。是邪见果。故名彼类。若谓如是所释不然。汝于此经。更说何义。然我所释。于义无违。又三相经足为至教。谓彼经说。有三有为之有为相。有为之起。亦可了知。尽及住异。亦可了知。若异此者。经但应言三有为相。谓诸有为起尽住异。是则再说有为之言。及亦可知。皆应无用。汝执生等三有为相。离所相法。无别有体。应求此文有何义趣。若谓不说有为之言。则不了知谁之相者。说有为相。足可了知。相属有为。无劳此说。既离此说。义亦得成。然标释中。皆置第六。故知能相。离所相有。现见以余表示余故。若谓亦见置第六声然非异体。故因不定。岂不能相离所相无。是则经文应如向说。离第六转。义亦成故。又彼所引。无异第六。释此经文。因亦不定。如何由此定判经文。所说三相。是假非实。又彼所言。天爱汝等执文迷义。薄伽梵说。义是所依。何谓此经所说实义。谓愚夫类。无明所盲。于行相续。执我我所。长夜于中。而生耽着。世尊为断彼执着故。显行相续体是有为及缘生性。故作是说。有三有为之有为相。非显诸行一刹那中具有三相。由一刹那起等三相不可知故。非不可知。应立为相。故此契经。复作是说。有为之起。亦可了知。尽及住异。亦可知者。今谓彼释不应经义。且不应许行相续中但有一起一尽一异。设复许有。亦不应说。以执我者。虽不曾闻行相续中有起尽等。而亦自然能了知故。彼虽了知。而犹执我。故复为说则为唐捐。先已了知。我执犹盛。今欲除遣。而复为说。应审思议。世尊设教。于所化者。何所益耶。然诸异生。于行相续。迷细生灭。执我我所。世尊欲令遣所执故。显示诸行一相续中有多刹那生灭差别。故作是说。有三有为之有为相。乃至广说。如是说经。深成有用。若谓诸行刹那生等非彼现见说无益者。汝等于此。亦不现见。岂不求理。非不了知。若不了知刹那生等。必无能舍我我所执。唯佛能设方便善巧。令彼求理而得了知。先不了知。故生我见。今了知故。我见便舍故知此说三有为相。唯约刹那。非据相续然刹那生等。虽非现见而说有用。汝所释经义由无用故。必不应理。故我解经。非同汝释。又汝应说。无明所盲。行相续中。起我见者。于行相续生等诸相。未闻说前为现见不。若言现见。便越所宗。或复为说。应成无用。若不现见。佛为说后应亦不知。无异因故。若言教力令其知者。刹那诸相。理亦应同。若相续相粗易知者。离佛教力。彼亦应知。若诸行中。相续诸相。虽非现见。而许教力令其了知。能治我执。刹那诸相。亦应如是。如何乃言刹那生等。非彼现见。说无所益。然诸行中相续生等。谁不能了。而更须说。故彼所释。违经义理。又一刹那生等诸相。微细觉慧所能了知。谓于刹那无间。展转善观察者。能了知故。微细觉慧。由教力生。了行无常。能除我执。既是微细觉慧所知。言一刹那起等三相不可知者。非如理说。又彼所说。非不可知应立相者。不应定说。不可知故。为非相因受等诸相。粗觉慧者。不能了知。非非相故。言不可知。便非相者。如是所说。非应理论。又此经言。有为之起。亦可了知。尽及住异。亦可知者。依刹那说。此经意说。刹那起等。审观察时。可了知故。世尊为劝诸受化者。令审观察。故说此言。又经主言。然经重说有为言者。令知此相表是有为。勿谓此相表有为有。如居白鹭表水非无。如是所言。违自宗义。许未生位有为有者。可说非生表有为有。以未生时彼先有故。既未生位。执有为无。岂得非生表有为有。白鹭表水。正是彼宗。生表有为有性同喻。若生不表本无今有。有为有者便似亦拨。唯许有为是有宗义。彼执有为唯得自体。即说名生。生体即是有为有性。生与有为。既无别体。有为与有。复无差别。如何此相。能表有为不表于有。又若为此重说有为。前所说言。便为无用。有为之起。亦可知等。足能成立如斯义故。是故此言。应表别义。彼上座言。若不重说有为言者。则不了知有为之相。为表何义此为能表。有色等性。为复能表有味等性为或能表善恶等性。为遣斯惑。重说有为。彼亦非理。已说有三有为之相。何容此相表有色等。非于别法无差别相应与彼法为差别相。又经当说。有为之起亦可知等。于无为中。当复遮此起等三相。由斯足了此相分明表有为性。何须重说。又彼何容疑此诸相能表示余有色等性。由有色等是自相故。起等表此应成自相。不应一体自相有三。如何契经说有三相。故彼于此无容致疑。又当亦言兼表集义。令知三相表一有为。无容疑此别有所表。是故彼执。亦定非善。又彼依何如何施设诸有为相。且彼经主。朋上座宗。作如是说。诸行相续。初起名生。终尽位中。说名为灭。中间相续随转名住。此前后别。名为住异。复谓世尊依如是义。说难陀言。是善男子。善知受生。善知受住。及善知受衰异坏灭。诸行相续名何所诠。谓诸有为无间流转。此复何法为其自性。是假有法。宁求自性。然诸刹那。展转相似。因果相继。诸行感赴。连环无断。说名相续。若尔相续说有一生。不应正理。非俱起故。若谓无量诸行刹那无间缺生名为相续。如何可说相续有生。彼依已生未灭诸行。方可建立有为法生。非于未生及已灭故。又此相续。既是假有。为唯现在。是此所依为复通依过去现在。若唯现在。是此所依。此则不应说为假有。一刹那法。独为相续假法所依。不应理故。然依多法总立为一。是假有相。如瓶如行。若此通依过去现在。以相续假前生刹那及现在法为所依故。是则相续生义应无。不可言生在过去故。又法现在。则非相续若是相续。非现在故。既唯现在可立有生。应唯刹那不名相续。若无此义。应违契经。故契经言。或有一类。其身安住。乃至百年。非一刹那可百年住。谁言一念。身住百年。但说此身相似相续中不间起异类刹那。谓身前前刹那无间。后后相似刹那续生。假说一身百年安住。此于经说有何相违。又不应言相续有住。以于多念立相续名。多念必无俱时住故。岂不共许刹那分位及众同分三现在成。如何乃言无相续住。若无相续。后二应无。此同前经。应如理释。谓后二种。假立现名。于此亦应假立生等。许三世有。此义可然。若说过去未来无体。唯有现在一刹那中。如何执有相续生等。非前刹那诸行未灭。尔时即有后刹那生。如何执此二共有一生相。又一刹那如何非有生灭二相俱时建立。又诸刹那展转相似。时无间缺。诸行生时。容可执有相续生等。若时善识刹那无间。不善识生。复于此识刹那无间。无记识起。尔时前后识性不同。如何执有相续生等。若言前后是一识类。亦得说名相似相续。则此相续。应无有生。从无始时来。一识相续故。乃至未入无余涅槃。此相续住应无有灭。又善识刹那已生已灭不善起。不善识刹那已生已灭无记起。岂不尔时一刹那顷生灭二相俱时建立。如遮诸行相续有生。如是亦应类遮住灭。谁有身心无狂乱者。能执已灭未生有住。或一刹那执有相续。又若不许色等诸行一一刹那皆有生灭。则譬喻者亦执有为经多时住。便与外道胜论等师执有何别。而言最后刹那灭故。一一刹那皆有灭者。彼岂不名心蕴余事口说余事。以破他宗。又唯法无名灭性故。彼宗灭性法无为体。是则诸法应非无常。非诸法无可名法故。若即诸法说为无常。不应灭性以无为体。以法皆用有为性故。灭相之体。名为灭性。非无有体可立性名。如何彼宗可言灭性。又言。诸行是有灭法。理不应成。灭无体故。无体不应成法性故。又无常性。若无体者。不应说第六谓色之无常。无无系属自及他故。又相续异理亦不成。非一切时于一切处许有前后差别性故。由此故说。若执身等非一一念皆有异者。外缘无别。如何后时身等现有差别可得。彼于外缘。无差别时。谁令相续前后差别。不应言别自然而有。相同相续应无别故。亦应执生自然有故。亦不应说自类为因故有差别。类无别故。若谓即用自类前生为后因缘相续有别。是则地等离火等合。应但由前熟变相起而实不起。故理不然。又彼拨无俱生异相。复无外缘前后差别。而定执有相续异相遍一切时一切处者。此无所因。而兴固执。又不应执与外缘俱。前因刹那为缘性故。能生后念果性刹那。由兹相续前后有异。或有诸行不待外缘。而有有为异相体故。有执所相长时相续。微细损减。即说名异。此亦不然。一切相续。应非遍有异相体故。谓增益时。应无异故。如有说言。是四大种。及所造色。所合成身。有时见增。有时见减。又此相续。复由何缘。而有损减。过同前说。如是已破相续生等。所引契经。于义非证。彼善男子。善知未来过去受故。谓现在智。知未来受。正生名生。非已生位。知过去受。已灭名灭。非正灭位。非知已生未灭位受。不应理故。善知受住及衰异言。非本所诵。设有此诵。义亦无违。过去未来。据曾当说。有生等故。又生等相一切时有。故彼所引于证无能。是故应随圣教正理。信解诸行一一刹那实有生等非于相续。又经主说。一一刹那诸有为法。离执实有四相亦成。云何得成。谓一一念。本无今有名生。有已还无名灭。后后刹那。嗣前前起名为住。即彼前后有差别故名住异。于前后念相似生时。前后相望非无差别。故离执有生等实物。一刹那顷四相亦成。岂不汝宗先有所怖故不。许有生等别物。今还失念自成立耶。如何有为一刹那顷。生住异灭四法为性。而无一法一时即生即住即衰即坏过失。若谓系属众缘故者。众缘同此应顿为缘。谓彼众缘。一一皆以生住异灭为自性故。此中何理。缘体有四。初为生缘。非即令灭。复有何理。诸有为法。但生体缘为缘。初令诸法生。非灭体缘为缘令法本不起。又生与灭依一法成。若异不异皆有过失。所以者何。此若异者。此即异此。不应理故。若不异者。生时应灭。灭时应生。又应无二。生灭二种。更相障故。又生法体。即灭法体。而言生灭。无杂乱失。此必应是毗瑟笯天所为幻惑。又应审决过去未来为有为无。然后可说本无今有有已还无相续。或刹那皆成假四相。又依何义说住相言。后后刹那。嗣前前起。嗣前起者。应即是生。既再说生。应无四相。又何缘力前后刹那相续有异。过同前说。又唯法无名为灭性。所有过失。如前已辩。故知生等。别有实物。又经主说。若离有为色等自性。有生等物。一法一时。应即生住衰异坏灭。许俱有故。执离有为无别生等。如斯过疾。不可救疗。一法一时。功能差别。理不成故。许离有为有别生等。无斯过失。如体不同。用有别故。现见内外。诸羯剌蓝。诸种子等。余缘摄助。于生自果。有胜功能。谓羯赖蓝等。识所摄助为胜因性。生頞部昙等。虽頞部昙等非不待识。而非因识生頞部昙等。此二相续。有差别故。然非此识与頞部昙等不作胜缘。由此有彼有。此无彼无故。又非此识与羯赖蓝等为俱助缘生頞部昙等。即令此识亦与种等为俱助缘。生于芽等。如是种等。地等摄助。为胜因性。生于芽等。虽彼芽等非不待地等。而非因地等生于芽等。种等无间。生芽等故。然非地等与彼芽等不作胜缘。芽等有无随地等故。又非地等与种子等为俱助缘生于芽等。即令地等亦得与彼羯赖蓝等为俱助缘。而得生于頞部昙等。如是余法缘助。于因令生自果。如应当说。又自称为释迦弟子。必应亦许有俱生因。由契经言。识与名色。更互为缘。而得住故。然羯赖蓝种等。与頞部昙芽等。为前生因。识及地等。为俱生缘。此俱生缘。比前生因。其力增胜。以虽有彼羯赖蓝等及与种等诸前生因。若无有识地等俱缘。即頞部昙芽等诸果。必不生故。由此准知。诸有为法。虽有种种外助因缘。而必有内生住异灭。为近助因。方得行世。然有为法。分位不同。略有三种。谓引果用。未得正得已灭别故。此诸有为。复有二种。谓有作用。及唯有体。前是现在。后是去来。此复一一各有二种。谓彼功能。有胜有劣。谓有为法。若能为因。引摄自果。名为作用。若能为缘。摄助异类。是谓功能。如是二种。辩三世中。当广思择。应以差别缘起正理蕴在心中。于其生等。功能差别。当生信解。谓或有法。于未获得引果用时。由过未得正得已灭引果用时。外缘摄助。于办自事。发起内缘。摄助功能。是名生相。或复有法。于正获得引果用时。即由彼时外缘摄助。于办自事。发起内缘。摄助功能。是余三相。于正生位。生为内缘。起所生法。至已生位。此所生法。名为已起。于正灭位。住为内缘。安所住法。令引自果。至已灭位。此所住法。名于自果已能引发。即正灭位。灭为内缘。坏所灭法。至已灭位。此所灭法。名为已坏。异相亦尔。如应当知。有余师说。因要待处世时位伴。方与果故。生已生时。起用差别。谓或有因。待处与果。如雨要待云处方生。要赡部洲处金刚座。方证无上正等菩提。或复有因。待世与果。如异熟因。顺解脱分。要在过去。方能与果。或复有因。待时与果。如轮王业。要劫增时。方能获得转轮王位。或复有因。待位与果。如诸种子。至变果位。方能生芽。初无漏心。及光明等。虽体先有。而要未来正生位中。能有所作。或复有因。待伴与果。如诸大种心心所等。要与伴俱。能有所作。由斯差别。缘起正理。四相起用。分位不同。谓正生时。生相起用。至已生位。住异灭三。同于一时。各起别用。如是四相。用时既别。如何难言一法一时应即生住衰异坏灭。又正灭时。此所相法。由余住相为胜因故。暂时安住。能引自果。即于尔时由余异相为胜因故。令其衰异。即于尔时由余灭相为胜因故。令其坏灭。故三一时无相违过

说一切有部顺正理论卷第十三阿毗达磨顺正理论卷第十四

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩差别品第二之六

又彼经主。于此生疑。尔时此法。为名安住。为名衰异。为名坏灭。今当为决。已生位中。住异灭三。起用各别。令所相法。于一时中。所望不同。具有三义。如斯通释。何理相违。故彼所疑。未为应理。又次前说。设许未来生有作用。如何成未来。应说未来相。法现在时。生用已谢。如何成现在。应说现在相。此无所违。无非现在。有作用故。岂不生相未来生时能生诸法。即是作用。何故乃言。此唯现在。天爱作用。非汝所知。此是功能。非关作用。谓有为法。若能为因。引摄自果。名为作用。若能为缘。摄助异类。是谓功能。如前已辩。一切现在。皆能为因。引摄自果。非诸现在皆能为缘摄助异类。谓闇中眼。或有功能被损害者。便于眼识。不能为缘摄助令起。然其作用。非闇所损。定能为因。引当眼故。由斯作用。功能有别。然于同类相续果生。有定不定。摄引势力。名为作用。亦名功能。若于异类相续果生。但能为缘。摄助令起。此非作用。但是功能。岂不论言。苦法智忍。光明生相。如是三法。皆于未来。能起作用。天爱汝今执文迷义。我宗释言。此文但约近缘功能。假说作用。以于多种法生缘中生是近缘。理极成立。故以余位因作用名。于此位中。假立名想。如是住等。随应当知。苦忍光明。亦于此位。有胜功力。假立此名。实唯引果。方名作用。或有难言。于正生位。若无生等如何此时生有作用。非住异灭。于此位中。若有生等。如何住等无用唯生。此难不然。且正生位。生等非无。住等尔时非现在故。功能未有。设此位中。未有生等。如汝因果。理亦无违由汝宗中果将生位能生因性。或有或无。许有邻近展转因故。又彼经主。于四相中。许三拨异。作如是说。又应一法生已未坏名住。住已坏时名灭。理且可然。异于一法进退推征。理不应有。所以者何。异谓前后性相转变。非即此法可言异此。故说颂言

  即前异不成　　异前非一法
  是故于一法　　立异终不成

且已略成异有别体。刹那相续异并不成。今复各应思择此义。谓许法外有异相体。由此能令所相一法异而不异。此我应思。不许法外有异相体。而许刹那相续有异。如何外缘虽无差别。然得有异。经主应思。我所应思。于后思择。三世义处。当兼显了。今于此中。正当义便。故略成立。用遣所疑。谓从本来诸法唯有自体安住。差别用无。由遇前生俱生缘力。令差别用本无而起。即此名为现在作用。亦名能引自果功能。依此世尊。作如是说。本无今有。有已还无。此用与体。不可言异。如能益损差别功能与能领受自体不异。又如所执。于后心中。前心差别。所引习气。此不可说异于后心。或复如善有见有对。造色业性。虽不异色。而彼品类。差别义成。故于此中。诸对法者。于法自体。差别用中。立有异名。非唯自体。谓有为法。于自体中。能引自果。作用名住。即此作用。衰损名异。此住及衰。无容自有应有别法令住令衰。此二之因。即住异相。于斯正理。何不忍欤。我于此中。不能忍者。此差别用。于现在时。与其自体。非异性故。此用既异。体亦应然。如何乃言用异非体。若执过去未来体无。于彼所宗。可有此失。非许三世恒有体者。所以者何。若作用息。唯舍现在。法体犹存。云何乃令体亦有异。故说颂言

  自体名有异　　由胜用衰损
  如何于一法　　立异终不成

非正生位立有异名。作用尔时未衰损故。即由此理。立住异名。此能衰损引果用故。由法作用。被衰损时。方引自果。由因被损。后果生位。渐劣前因。故果渐劣。由因有异。此果刹那。复由俱起异相为缘令衰损故。复能为后果渐劣缘。如是一切。有为相续。刹那刹那。令后后异。故前前念。有异义成。此义既成。应为比量。谓见最后有差别故。前诸刹那。定有差别。非如幻惑。譬喻论师。所立刹那相续异理。若尔相续渐增长时。异相应无。不见果故。无斯过失。住相尔时由外缘助。势力增强摧伏异故。有余师说。诸法作用。无有能住过一刹那。是故有为说名有异。非舍自相方得异名亦非有为有常性过。由此法性自体恒然。非作非转不可改易。故火常用暖为自体。离暖更无火体可得。然火作用要藉众缘。故宗立火为无常性。若自体异。即成别法。应非无常。体无变故。谓若唯执现在世有去来体无。则诸行法其性应常。无变异故。云何无异。谓有与无性各安立无变异故。彼唯执有现在世法刹那性故不可变异。未来过去其体并无。无法如何当言变异。故不可说诸行无常。不可说言无变为有有变为无名为变异。有无二性体不相成。以有与无体相违故。亦非果异因无异故。非无异因。可有异果。果必随因方有异故。若谓有性是无常者。理亦不然。有性不可成余性故。以法有性未尝非有。有与非有各别立故。由此诸行变异定无。是则有为皆应常住。若许过未亦有亦无。从未生无可生为有。从已生有可灭为无。此去来无与现在有。俱非决定。可有改易。去来之有与现在同。于一切时。恒无改易。由于体有用或有无。可说有为分位有异。是故唯说三时有宗。于一法中。可言有异。法有异故。异相可成。异相既成。无常义立。非如唯说现在有宗。相续刹那。异皆非有。如前已说。故应且止。若生在未来。生所生法。未来一切法。何不顿生。彼能生因。各常合故。此先已辩。先何所辩。谓或有法。于未获得引果用时。由遇未得正得已灭引果用时外缘摄助。于办自事。发起内缘摄助功能。是名生相。即依此义。说如是言。颂曰

  生能生所生　　非离因缘合

论曰。非离所余因缘和合。唯生相力。能生所生。故诸未来。非皆顿起。生相虽作俱起近因能生所生。诸有为法。而必应待前自类因及余外缘和合摄助。如种地等差别因缘助芽等生令生芽等。若尔我等唯见因缘有生功能。无别生相。有因缘合。诸法即生。无即不生。何劳生相。故应唯有因缘力生。此责不然。唯许众缘诸法生者。此责同故。谓若唯许未来诸法因缘和合而得生者。此责亦同未来诸法因缘无别何不顿生。又因缘中。随阙一种具所余故。果亦应生。且如眼根先业所引。虽离大种。而亦应生。或应但由大种功力不由先业眼根得生。或诸眼根。随业所引。能生大种。无不合时。于一生时。余亦应起。或应大种于眼无能。不见离前眼大种独生故。但应因前眼后眼得生。执大种能生。应成无用。又如种子水土等缘随阙一时芽必不起。故知种等功力极成。于眼等生。地等大种。能生功力。非所现见。既不现见。大种功力。应不为因生于眼等。又汝所执。有业种子。相续转变。谁为障碍。不能顿生。一切业果。若由缘助。业种方能生。应但缘能生。何劳业种。以众缘助业果乃生。众缘若无果不生故。既赖缘助而业种非无。虽藉众缘。宁拨无生相。又见初念无漏生时。生能为因。起无漏得。得自相有。前已极成。应说除生有何别法。能作此得。前俱起因。若全无因。得不应起。则初无漏。应不说成。生相生时。为亦别有俱生因不。应言亦有。谓除生体余一果法。云何异灭为生助因。古昔诸师。咸作是释。同一果法。展转为因。如诸大种。更相顺故。复有释言。诸有为法。一切皆是生等性故。生等四相。一一用时。以此为门。余皆助力。证斯义者。谓念住中。观身等为无常性故。然上座说。诸行无住。若行可住。经极少时。何故不经。须臾日月时年劫住。无异因故又阿笈摩亦说诸行无有住故。如世尊言。苾刍诸行皆临灭时。既无有住。亦无有灭。且彼所说。若行可住。经极少时理不应忍。极少时者谓一刹那。若一刹那。亦无有住。是则诸行。应毕竟无。若谓有为全无有住。得体无间即灭故者。岂不有此得体时。故即名诸行极少住时。虽有此时。而无有住。依何位说此无住言。为得体时。为得体后。执无住位。唯应二时。若得体时。亦无住者。则不能越前所说过。若得体后。方言无住。非所许故。设难唐捐。汝等所言。得体时者。即我说住。能引果时。非我所宗引果时后。诸行有住。何缘汝等对我遮破。诸行住时。如汝行中有时有者。必待余法生用方成。如是亦应有引果者。必待余法方成引用。此所待者。立以住名。是则我宗。如汝所说。礭陈何等理教相违。岂不经言诸行无住。若说有住。此教相违。汝执有违。种种计度。非实义故。对法诸师。所说称理。有何违害。然契经说。无有住者。为遮常住。故说此言。次后复言。亦无灭故。此言遮遣诸行断灭。若离为遮诸行断者。此无灭言。更何所遣。然诸行灭。但有二种。一生无间灭。二毕竟断灭。故为遮遣常断二边。经言诸行无住无灭。非为遮遣对法诸师所立为因。令引果住。诸有智者。请为谛观。谁之所言。违正理教。为说诸行有暂住者。为说诸行全无灭者。我本不言诸行生已全无有灭。何缘经说。皆临灭时。亦无有灭。言无灭者。是无息义。此无意说。诸行生已。无间必灭。无暂息时。说无住言此义已显。复言无灭。应成无用。我亦不言诸行生已毕竟常住。若尔何缘。说有为法生已有住。言有住者。是暂停义。谓正灭时。诸行暂住。非于已灭及正生时可说住言。无作用故。如前已说。于正灭时。诸行方有引果作用。虽作是说。而住必无。曾无契经说有住故。曾无遮故。何定言无。又理所逼。故应信有。设无至教。住于正理。无所乖违。言有何失。然有至教证住为有。如抚掌喻。契经中言。苾刍诸行如幻如焰。暂时而住。速还谢灭。岂不由斯已证对法所说诸行有暂住时由此亦成毗婆沙释。言无住者依刹那后密意而说。非谓全无。然彼所言。此随自意。分别计度。通善逝经。经曾不言有住故者。今谓彼类未读此经。或率己情。拨为非量。或朋党执。浊乱其心。虽数披文而不记了。诸求理者。请为寻思。谁于佛经随自意执。为言诸行有暂住者。为拨此经为非量者。然薄伽梵先于经中。说临灭时诸行无住。虑当来世。譬喻部师。执彼经文。拨刹那住。故复说此抚掌喻经。显诸行中有暂时住。彼不忍受此大师言。复作是责。何缘但许依刹那后密意而说。而不言依众同分后。刹那与此有何差别。此责非理。有差别故。刹那顷住。有俱起因。众同分住此因非有。是故此责。非应正理。彼复责言。若由住力能令诸行暂时住者。何不由此令诸有为经千俱胝。刹那量住。何缘诸行一念住因非即令住千俱胝念。此亦非理。离能生因。彼亦不许诸行生故。何缘诸行。一念生因。非即令生千俱胝念。如是道理。进退应同。又契经言。应知乐受生住皆乐。复有经言。应知色等有生有住。若谓此经依相续说。不应正理。义不成故。谓若不许刹那有住。如何相续住义得成。相续必依刹那成故。如是住相。理教极成。然譬喻师。固言非有。不知于住曾结何冤。其理显然。而不忍受。有余难言。若无常相。离无常性。别有体者。何不离苦。别有苦相。如斯例难。其理不成。若说无常性由无常相有。可依此说而设难言。苦性亦应由苦相有。然有为法。性是无常。但由灭相。为缘故灭。如有为法性是无常。要待生缘为缘故起。如是苦性。设复更有苦相为缘。此复何用。故所例难。其理不成。由此已遮空无我难。又即无常相。亦是苦相。体无常故。苦经所说故。又彼亦应遭如是难。若所生法。别有生缘。方得生者。应许苦法别待苦缘方得成苦。或所生法。应离生缘自然而生。犹如苦等。又前已说前说者何。如汝行中有时有者。必待余法生用方成。如是我宗。一切时有。故法有性。不待因缘。苦无我等。应如有性灭应如生。要待余法。故知别有能灭内因。离所灭法。名无常相。若谓诸行无别灭因。生亦应然。不待因有。此二与体俱异法故。或应说二差别所因。若言此二亦有差别。谓诸行生必待因故。现见生时迟速差别。若诸行灭。亦待因者。亦应灭时迟速有异。灭若如生。时有迟速。便违诸行刹那灭宗。故知无因自然而灭。无斯过失。灭因与行必俱有故。时无差别。生因与行。或俱不俱。虽时隔越。亦为因故。诸行生时。可有迟速。若诸行灭。不由因者。于正生时。应即灭坏。或应后位灭坏亦无。汝许前后同无因故。若谓此位诸行未生。何得难令即有灭者。是则应许生为灭因。要见有生方有灭故。既许诸行灭必待生。如何可言无因而灭。又由至教。证灭有因。如契经言。此法灭故。彼法亦灭。又说如是一切有因。故知诸行由因故灭。又诸有为相皆展转为因。必由有生。方可灭故。必有灭法。方可生故。必由有住。方有异故。必由有异。住可迁故。复有责言。住因无故。法自然灭。何用灭因。此责非理。唯说前生为因论者。因正有时。未有所起。彼执未来体是无故。后果生位。前因已无。虽无住因。何妨有住。故彼所说。非无灭因。又先已辩住相为因。诸行生已刹那顷住。如何复说住无有因。若谓诸行一刹那后必无有故自然灭者。若无灭相。谁遣其无令生已灭。都由灭相。故离有为。有灭相体。又不应执灭相体无。如前所引。契经中说。有为之起。亦可了知。尽及住异。亦可知故。非于无法应劝了知。诸可了知者是有异名故。又如必有能生差别令所生法至已生位。如是必有能灭差别。令所灭法至已灭位。故灭如生别有义立又彼上座。作如是言。如虽无别有性一性长性短性合离性等为其所待而亦得成。有一长短合离等法。住等亦然。无别所待。此说便成违自宗过。彼宗自许有一长短合离等法待余成故。彼执诸法托有因缘本无今有故。诸法有待。余有性非无所待。汝宗诸行本无今有。有性如生待有方立。对法者说。诸法有性一切时有。不待因缘。故彼所言。自违宗义。遮余同类此一方成。故亦待余一义成立。长短展转相待而成。或待极微安布而立。故非自有。必待他成。合之与离。亦待别物。是故一切皆有所待。非无所待可立名言。又法生因亦应由此例被遮遣。如有等性无所待成。生亦应尔。然无是事。故诸有为。分位差别。一切皆待异因缘成。非自然有。故有为相。一一刹那。皆别实有义极成立。譬喻部师所立。假有相续生等。诸有为相。不合正理。违背契经。唯我所宗。符经顺理。故有智者。应勤修学。已广分别诸有为相。名身等类。其义云何。颂曰

  名身等所谓　　想章字总说

论曰。等者等取句身文身名句文身。本论说故。诸想总说。即是名身。诸章总说。即是句身。诸字总说。即是文身。言总说者。是合集义。于合集义中。说嗢遮界故。想谓于法分别取着。共所安立。字所发想。即是眼耳瓶衣车等。如是想身。即是名身。谓眼耳等。章谓章辩。世论者释。是辩无尽。带差别章。能究竟辩所欲说义。即是福招乐异熟等。如是章身。即是句身。谓如有说

  福招乐异熟　　所欲皆如意
  并速证第一　　永寂静涅槃

如是句等。字谓[褒-保+可]阿壹伊等字。如是字身。即是文身。谓迦佉伽等。有余师说。本论中言。云何多名身。谓名名事等。非彼论师欲辩名等是实有相。而依假合以发问端。是故彼问多名身等者。决定应问名等体实相。思择名等体实相中。何用推征名等假合。又名等三相差别者。谓声所显。能显于义。已共立为能诠定量。显示所解意乐所生。能表所知。境界自体。犹如响像。此相是名。若能辩析所知境中。广略义门。此相是句。于能说者。声已灭位。犹令系念。持令不惑。传寄余者。此相是文。此中名者。谓随归赴。如如语声之所归赴。如是如是。于自性中。名皆随逐。呼召于彼。句者即能辩所说义谓能辩析差别义门。文者谓能有所彰显。依此由此彼彰显故。此即是字。谓令系念无有忘失。或复由此之所任持。令无疑惑。或能持彼。转寄于余。故有说言。如静虑者方便境相。与静虑中所觉了境。而为梯蹬。文于名句及义亦尔。有余师说。[褒-保+可]壹等字。能彰名句。故说为文。即此诸字。或别或总。能诠自性。故说为名。即此和合。能究竟辩差别义门。说名为句。如是三种。体应成一。又应非实。故不可依。复有余师。一处显三相。谓如说言。欲我知汝本。此中诸字各说为文。欲者是名。总说为句。是则总说名句文身。此亦不免前所说过。是故最初所说名等三相为善。可研寻故。岂不经中受想行识四无色蕴总说为名。本论亦言。法处所摄。身业语业。是色所收。其余法处。皆名所摄。此中何故说名。但以心不相应行蕴为性。契经本论。皆为总摄一切法门。略为二种。色为体者。总说为色。自余非色。总说为名。非色聚中摄于名故。总从别目。故说为名。今此中名。唯约能显所诠义说。是故但以心不相应行蕴为性。义为可说不可说耶。如实应言。义不可说。若尔何故。因为等言。解为等义。非颠倒解。又应违经吾当为汝略说法要。有义有文。无斯过失。假安立故。谓劫初人。于种种义。共立种种差别想名。由此相传。于诸名想。解无颠倒。又如有说。语能发名。名能显义。然契经言。文义巧妙。曾无有说有义有文。设许如斯亦无有失。世尊所说。具文义故。谓世尊教。能正显了无量义门。文词圆满。无所缺漏。故作是说。又三世诸法各有三世名谓过去法。过去诸佛。以过去名。曾已显示。未来诸佛。以未来名。当复显示。现在诸佛。以现在名。今正显示。未来现在。如应当知。又诸法中。无无名者。若有应成非所知过。故薄伽梵说如是言

  名能映一切　　无有过名者
  是故名一法　　皆随自在行

有余师说。义少名多。于一义中。有多名故。有余复说。名少义多。名唯一界少分所摄。义则具收十八界故。复有说者。互有少多。谓约界摄。义多名少。若依立教。义少名多。谓佛世尊。于一一法。随义施设无边名故。如贪名爱名火名蛇名蔓名渴名网名毒名泉名河名修名广名针缕等。如是一切。此中经主。作如是言。岂不此三语为性故用声为体。色自性摄如何乃说为心不相应行。此责非理。所以者何。由教及理。知别有故。教谓经言。语力文力。若文即语。别说何为。又说应持正法文句。又言依义不依于文。又说伽他因谓阐陀文字。阐陀谓造颂分量语为体。又契经言。知法知义法谓名等。义谓所诠。又契经言。文义巧妙。又言应以善说文句读诵正法恶说文句读诵正法义即难解。又说如来获得希有名句文身。又说彼彼胜解文句甚为希有。由此等教。证知别有能诠诸义名句文身。犹如语声。实而非假。理谓现见。有时得声而不得字。有时得字而不得声。故知体别。有时得声不得字者。谓虽闻声而不了义。现见有人粗闻他语。而复审问。汝何所言。此闻语声。不了义者。都由未达所发文故。如何乃执文不异声。有时得字不得声者。谓不闻声。而得了义。现见有人不闻他语。睹唇等动。知其所说。此不闻声。得了义者。都由己达所发文故。由斯理证。文必异声。又见世间。隐声诵咒。故知咒字。异于咒声。又见世间。有二论者。言音相似。一负一胜。此胜负因。必异声有。又法与词二无碍解。境界别故。知字离声。是故声者。但是言音。相无差别。其中屈曲。必依迦遮吒多波等。要由语声。发起诸字。诸字前后和合生名此名既生。即能显义。由此展转而作是言。语能发名名能显义。故名声异。其理极成应知此中声是能说。文是所说。义俱非二。如是则为无乱建立。此中经主。又作是言。非但音声皆称为语。要由此故。义可了知。如是音声。方称语故。谓能说者。于诸义中。已共立为能诠定量。若此句义。由名能显但由音声显用已辩。何须横计别有实名。何等名为能诠定量。岂不于义共立想名。此即说为能诠定量。谓能说者。于诸义中。先共安立如是诸字。定能展转。诠如是义。由共安立如是字故。因如是字发如是名。此名即是能诠定量。诸能说者。将发语时。要先思惟。如是定量。由此自语。或他语时。于所显义。皆能解了。故非唯声即能显义。要语发字。字复发名。名乃能诠。所欲说义。如语发字。字复发名。如是应思。发句道理。此中经主。复作是言。又未了此名如何由语发。为由语显。为由语生。若由语生。语声性故。声应一切皆能生名。若谓生名声有差别。此足显义。何待别名。若由语显。语声性故。声应一切皆能显名。若谓显名声有差别。此足显义。何待别名。执声能诠。斯难亦等。谓若声体。即能显义。应一切声无非能显。若谓能显声有差别如是差别。应即是名。故所推征。未为过难。然能说者。以所乐名。先蕴在心。方复思度。我当发起如是如是言。为他宣说如是如是义。由此后时。随思发语。因语发字。字复发名。名方显义。由依如是展转理门说。语发名名能显义。如斯安立。其理必然。若不以名先蕴心内。设令发语无定表诠。亦不令他于义生解。又经主言。或唯应执别有文体。即总集此为名等身更执有余。便为无用。此亦非理。无有诸文俱时转故。由斯总集理不成故。非一一文中皆不显义故。或如树等。大造合成。非不缘斯别生于影。影由假发。而体非假。如是诸文。亦应总集别生名句而彼名句虽由假发。而体非假。此为善说理极成故。若尔则应一切假法皆可安立为实有性。无如是过所以者何。于一字中。亦有名故。无假有法搅一实成。故假与名义不相似。既于一字。亦得有名。宁知此名。离字而有。如是一字。如无义字。无有所诠。依此为缘。别有名起。方能表义。然极相近。别相难知。如壁上光二色难辩。若许即声能显于义。无别名等。斯有何失。违害法相。岂非失耶。无有音声。唯意能得。字等不尔。故体不同。然有音声。虽由共立契约而发。有作意听。而但了声。于义不了。彼后因此还得了知。非前了声于义不了。后唯因此便能了义。故知离声别有名等。前意未得不了所诠。后意得时。方能了义。若谓不尔后意还因得声差别能了义故。此声差别非异于声。此亦不然能诠契约。即声差别理不成故。若所共立。能诠契约。即声差别者。应如色差别。非共立契亦可了知。非青与黄二色差别要共立契然后了知。虽二色中先不共立差别契约。而彼青黄差别之相。非异色故。眼识得已。意识即能随分别知此彼差别。又理不应于契约上复作契约。故不应言能诠契约。虽不异声而先不共立契约者。虽复得声而更待余立契约故未能了别。此望余声有差别相。又若所立契即声差别者。于有义声及无义声所有差别。虽先未共立差别契。应亦了知。谓于一声有此差别。于余声上。此差别无。先未共立差别契者。得二声时。虽不了义。然应如彼二色差别。即能了达有契约声无契约声差别之相。故知别有名句文身。缘声而生。能显了义。然彼上座。于此复言。意业为先。所生声位。安布诸字。决定差别。以成名等。此离于声。别有自性。理不可得。如是亦应由前理教显彼上座有言无实。非但由彼虚构言词能立即声是名等体。若但由彼虚构言词。能立即声是名等者。亦应能立一切极成别有体法为无别体。谓即湿性。积集凝结。名为坚性。即彼坚性。离散消融。名为湿性。即坚湿性。与冷乖离名为暖性。即上三性。于轻转时名为动性。眼识所识色界即是香处所摄。即诸大种能有所缘。名心心所。如是一切皆应得成。又因现摇香触等相。亦能了义。故不应立名句文身即声为体。是故于我所说离声有名等三。能显义理。若能如实少分显非我应收采。非但由彼所构虚言。能倾实义。又彼虽说如世尊言。因寻伺言说语。非不因寻伺言说语者。由声发声。故名等三无别有体。此亦无失。如施等故。谓如经言。舍施受乐。此亦应然语因名语。又如触等因亦名为触等。又彼虽说非世共知名句文身。是心不相应行。我当于彼而发语言。既不共知。语凭何发。此亦非理。世间虽无分别功力。而能缘故。如世间说。被菜所烧为泥所烂。彼虽不达而是能缘。此亦应尔。又如以眼现见光明。而言我今见不了色。又作两手相击声因。而言作声。不言作击。又无智者。但作是言。因弃舍欲弃舍便秽。然实义者。因弃舍欲生便秽路。能发风心。心复发风。风方弃舍。如是非无了名等觉能觉了义。但由名等觉相微细。故不能知。虽不定心不能分别。此是声觉。此名等觉。此是义觉。而实非无。故于审谛观察诸法差别相时。世间粗心所起言说。未足为证。且诸世间。于自觉慧所行境界。亦不能知。故佛世尊。如实开演。诸有执我等随观见。一切唯于五取蕴起。如是世间。于粗浅事。若不闻说。尚未能了。况于深细心不相应行蕴所摄名句文身。不因开示。而能解了。故彼所言。定为非理又经主说。诸刹那声。不可聚集亦无一法分分渐生。如何名生。可由语发。又自释言。云何待过去诸表刹那。最后表刹那。能生无表。复自难言。若尔最后位声乃生名。但闻最后声。应能了义。若作是执。语能生文。文复生名。名方显义此中过难。应同前说。以诸念文不可集故。语显名过。应例如生。又文由语。若显若生。准语于名。皆不应理。此难违害自所禀宗。彼说去来。皆无自体。声前后念。不可顿生。如何成文成名成句。若前前念。转转相资。最后刹那。成文名句。但闻最后。应了义成。又无相资。去来无故。既恒一念。如何相资。既无相资。前后相似。后如初念。应不能诠。闻后如初。应不了义。故彼所执。前后相资。声即能诠。理不成立。我宗三世皆有非无。故后待前。能生名等。虽最后念名等方生。而但闻彼。不能了义。由不具闻。如先共立名等契约。能发声故。然闻一声。亦有了者。由串习故。依此比余。故经主言。破彼非此。毗婆沙说名句文三。各有三种。名三种者。谓名名身多名身。句文亦尔。名有多位。谓一字生。或二字生。或多字生。一字生者。说一字时。但可有名。说二字时。即谓名身。或作是说。说三字时。即谓多名身。或作是说。说四字时。方谓多名身。二字生者。说二字时。但可有名。说四字时。即谓名身。或作是说。说六字时。即谓多名身。或作是说说八字时。方谓多名身。多字生中。三字生者。说三字时。但可有名。说六字时。即谓名身。或作是说。说九字时。即谓多名身。或作是说。说十二字时。方谓多名身。此为门故。余多字生。名身多身。如理应说。句亦多位。谓处中句。初句后句。短句长句。若八字生。名处中句。不长不短故。谓处中三十二字生于四句。如是四句。成室路迦。经论文章。多依此数。若六字已上生名初句。二十六字已下生名后句。若减六字生名短句。过二十六字生名长句。且依处中句辩三种。说八字时。但可有句。说十六字时。即谓句身。或作是说。说二十四字时。即谓多句身。或作是说。说三十二字时。方谓多句身。文即字故。唯有一位。说一字时。但可有文。说二字时。即谓文身。或作是说。说三字时。即谓多文身。或作是说。说四字时。方谓多文身。由此理故。应作是说。说一字时。有名无名身无多名身。无句无句身无多句身。有文无文身无多文身。说二字时。有名有名身。无多名身。无句等三。有文有文身。无多文身。说四字时。有名等三。无句等三。有文等三。说八字时。有名等三。有句无句身无多句身。有文等三。说十六字时。有名等三。有句有句身。无多句身。有文等三。说三十二字时。名句文三。各具三种。由此为门。余如理说。已略辩三。复应思择。如是名等。何界所系。为是有情数。为非有情数。为是异熟生。为是所长养。为是等流性。为善为不善为无记。此皆应辩。颂曰

  欲色有情摄　　等流无记性

论曰。此名等三。唯是欲色二界所系。就色界中。有说唯在初静虑地。有说亦通上三静虑。随语随身。所系别故。若说此三随语系者。说生欲界作欲界语时。语名等身皆是欲界系。彼所说义。或三界系。或通不系。即彼复作初定语时。语及名等初定地系。身欲界系。义如前说。如是若生初静虑地。作二地语。如理应思。若生二三四静虑地。作二地语。亦如理思。若说此三随身系者。说生欲界或四静虑。名等及身。各自地系。语或自地。或他地系。义如前说又名等三。有情数摄。非情有为不成就故。能说者成。非所显义。唯成现在不成去来。又名等三。唯等流性。非所长养。非异熟生。而言名等从业生者。是业所生。增上果故。又名等三。唯是无覆无记性摄。故断善者。说善法时。虽成善名等。而不成善法。离欲贪者。不成不善。诸无学者。不成染污。成能诠名等。非所诠法故。如上所说。余不相应。所未说义。今当略辩。颂曰

  同分亦如是　　并无色异熟
  得相通三类　　非得定等流

论曰。亦如是言。为显同分如名身等。通于欲色有情等流无覆无记。并无色言。显非唯欲色。言并异熟。显非唯等流。是界通三类通二义。云何异熟。谓地狱等。及卵生等。趣生同分。云何等流。谓界地处。种姓族类。沙门梵志。学无学等。所有同分。有余师说。诸同分中。先业所引生是异熟。同分现在加行起是等流。同分得及诸相类并通三。谓具刹那等流异熟。非得二定。唯是等流。唯言为明非异熟等所余应说。而不说者命根无想。如前说故。余义准前已可知故。谓说得等唯成等故。有情数摄。义可准知。说诸有为有生等故。准知诸相。通情非情。余随所应。义皆已显。是故于此无劳重说

说一切有部顺正理论卷第十四阿毗达磨顺正理论卷第十五

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩差别品第二之七

如是已辩不相应行前言生相生所生时。非离所余因缘和合。此中何法。说为因缘。且因六种何等为六。颂曰

  能作及俱有　　同类与相应
  遍行并异熟　　许因唯六种

论曰。本论许因唯有六种。不增不减。一能作因。二俱有因。三同类因。四相应因。五遍行因。六异熟因。能作因体。通一切法。是故先说。俱有因体。遍诸有为。故居第二。余同类等。于有为中。如其所应。各摄少分。随言稳便。次第而说。法生所赖。故说为因。如是六因。非佛所说。如何本论自立此名。定无大师所不说义。阿毗达磨。辄有所说。经中现无。由隐没故。自相可得。决定应有。又诸经中。所化力故。世尊方便作异门说。对法诸师。由见少相。知其定有。分明结集。故有说言。此六因义。说在增一增六经中。时经久远。其文隐没。尊者迦多衍尼子等。于诸法相。无间思求。冥感天仙现来授与。如天授与筏第遮经其理必然。如四缘义。虽具列在此部经中而余部中。有不诵者。由时淹久。多隐没故。既见余经。有少隐没。故知此处。亦非具在。又见经中处处散说。故六因义。定应实有。谓如经说。眼及色为缘生于眼识。又如经说。二因二缘。能生正见诸如是等。即能作因。诸法于他。有能作义由生无障。故立此因。如契经说。有三道支。正见随转。又如经说。三和合触。俱起受想思。诸如是等。即俱有因。诸行俱时。同作一事。由互随转。故立此因。如说如是补特伽罗。成就善法及不善法。应知如是补特伽罗。善法隐没恶法出现。有随俱行。善根未断以未断故。从此善根。犹有可起余善根义。又说苾刍。若于彼彼多随寻伺。即于彼彼心多趣入。无明为因起诸染着。明为因故离诸染着。诸如是等。即同类因。过去现在。同类诸法由牵自果故立此因。如契经说。见为根信证智相应。又如经言。若有了别。即有了知。在定了知。乃为如实非不在定。诸如是等。即相应因。心心所相应。同作一事。由共取一境故立此因。如契经言诸邪见者。所有身业语业意业。诸有愿求。皆如所见所有诸行皆是彼类。如是诸法。皆悉能招非欣爱乐不可意果。又经说。一切见趣生时。皆以有身见为其根本。若此见生不忍一切。此见能生贪欲嗔恚。诸如是等。即遍行因。过去现在。见苦集所断疑见无明。及相应俱有。于同异类诸染污法由能引起故立此因。一部为因生五部果。故同类外立遍行因如契经言。若所作业。是善有漏。是修所成。于彼处生。受诸异熟。又如经言。诸故思业作及增长。定招异熟诸如是等。即异熟因。一切不善善有漏法由招异类故立此因。如是六因。佛处处说。诸憎背者。迷故不见。又薄伽梵处处经中。说有俱生前生因义。依此有彼有。此生故彼生。如次应知。前二因义。又薄伽梵于契经中。分明显说二种因义。谓契经言。诸有不敏处无明者。由无明故。亦造福行。此经即显有前生因。又契经说眼色为缘。广说乃至。意法为缘生痴所生染浊作意。此中愚者痴即无明。希求即爱爱表即业。此经即显有俱生因。一心中说有展转为因故。至义次第当复决择。已略举因。今当广辩。且初能作因相云何。颂曰

  除自余能作

论曰。此能作因。略有二种。一有生力。二唯无障。诸法生时。唯除自体。以一切法。为能作因。由彼生时皆不为障。于中少分有能生力。且如有一眼识生时。以所依眼为依止因。以所缘色。为建立因。以眼识等。如种子法。为不断因。以相应法。为摄受因。以俱有法为助伴因。以耳根等为依住因。此等总说为能作因。于中一分。名有力因。以有能生胜功能故。所余诸分。名无力因。以但不为障碍住故。虽余因性亦能作因。然能作因。更无别称。如色处等。总即别名。何故自体。非自能作因。以能作因于自体无故。谓无障义。是能作因。自于自体。恒为障碍。又一切法。不待自体。应有恒成。损减等故。有余师说。若有自体因自体者。即应无明还缘无明。乃至老死还缘老死。一刹那顷。此即此因。是则乖违缘起法性。有余师说。自于自体。不见有用。故非因缘。犹如指端刀刃眼等。若除自体。余一切法。与此一法为能作因。则无间业。亦与圣道为能作因。如何应理。又唯生时。由无障住。可能为因。应非余位。非彼与此有时为因。有时非因。可应正理。圣道生位。彼定为因。故于余时。非无因义。若于此生彼能为障。而不为障。可立为因。然于此生。无障用者。设不为障。何得为因。由一切法展转相望。皆有障力。故得为因。谓于是处。有此一法。是处无容更有第二。设复此法于余处有。彼亦无容更有余法。如是诸法。岂不相望皆能为障。而不为障。故皆可立为能作因。无色亦有时依等定。故彼相望。亦有障力。又诸法内。一法生时。如与欲法余皆无障。谓二缘故。法不得生。一顺因无。二违缘有。诸法生位。必待胜力。各别因缘。及待所余无障而住。增上缘法。由能生因。有能障因无诸法乃生。故唯由无障碍。说一切法。名为能作因。非有障力。而不为障。与无障力不为障者。于无障时。少有差别。俱有无障力同无胜用故。由斯已遣诸有难言。若一切法。无障住故。皆能作因。何缘诸法。非皆顿起。一杀生时。何缘一切非如杀者皆成杀业。但由无障。说彼为因。无胜用故。灰刺等触。为乐受因。如何应理。非灰等触为乐受因。是因因故。谓同类故。苦受得与乐受为因。因灰等触生于苦受。故为因因。如是见等。展转相望。有少功能。皆应显说。由前略指触受方隅。余例可悉。无烦广辩。故能作因。望所生果。非唯无障。亦有生力。然阙亲因及因等起。故一切法。不可顿生。非如杀者皆成杀业。过去诸法。与余二世为能作因。彼二世法。还与过去为增上果。未来诸法。与余二世。由无障故为能作因。彼二世法。非俱后故。不与未来为增上果。果必由因取故。唯有二因。唯据无障。故许通三。现在诸法。与余二世。为能作因。彼二世中。唯未来法。为现在果。有为有为是因是果。有为无为。非因非果。无为无为非因非果。无为有为。是因非果。由此义故。说如是言。能作因多非增上果。以一切法皆能作因。唯诸有为。是增上果。如是已辩能作因相。第二俱有因相云何。颂曰

  俱有互为果　　如大相所相
  心于心随转

论曰。若法更互为士用果。彼法更互为俱有因。展转助力。而得生故。其相云何。如四大种。更互相望。为俱有因。虽有体增体不增者。而皆三一。更互为因。自体不应待自体故。亦不应待同类体故。一一大种。唯待余三。要四大种。异类和集。方有功能。生造色故。如是有为相与所相。心与心随转。亦更互为因。是则俱有因。由互为果。遍摄有为法。如其所应。此中所说。因相太少。谓诸心随转。及诸能相。各应说互为俱有因。故又不应说唯互为果为俱有因。法与随相。非互为果。然为因故。此为因相。彼应更辩。由此义故。应辩相言。有为法一果可为俱有因。本论说故。此无过失。然本论中。曾不见说心随转色与心为因。应辩此中造论者意。或有师言。是有余说。彼显论过。非谓辩成。言义阙减。名论过故。复有师言。此中论者。非为具辩俱有因相。但为遮遣余宗所执。谓为遮遣执唯有心。故说离心有诸心所。又为遮遣执业唯思无无表业。是故复说有心随转身业语业。复为遮遣执生等相非实有物。是故复说。有心随转不相应行。岂不具辩俱有因相。转更显成。别有心所身语无表及生等相。又于余处。曾未具辩俱有因相。今不具说。便成阙减。故彼应思。我于此中。见如是意。若法与心。决定俱起。遍一切心。依心而转。即说彼法。与所依心。展转相望。为俱有因。诸心所法。非定俱起。或少或多。现可得故。身业语业。非遍诸心。不定心俱全无有故。生等诸相。皆依心转。非互相依。生等皆以法为上首。互相资故。由斯不说彼互为因。又于此中。为欲显示但说异类为俱有因。同类互为因。不说而成义。又为显示有身语业唯依于心不依于表。故不说彼与心为因。又彼大德意趣难了。诸有智者。尚未善知。故于此中。有作是计。唯心能与心随转色。为俱有因。非色与心。从心生故。依心起故。如王与臣。胜不因劣。此计非理。如臣与王防卫任持互有力故。心随转法。其体云何。颂曰

  心所二律义　　彼及心诸相
  是心随转法

论曰。一切所有心相应法。静虑无漏。二种律仪。彼法及心之生等相。如是皆谓心随转法。何因不说彼之随相。不说所因。后自当辩。何缘此法名心随转。颂曰

  由时果善等

论曰。略说由时果等善等。十种缘故名心随转。且由时者。谓此与心一生住灭。及堕一世。由果等者。谓此与心。一果等流。及一异熟。由善等者。谓此与心。同善不善无记性故。岂不但言一生住灭。即知亦是堕一世中。虽亦即知堕于一世。而犹未了。此法与心。过去未来。亦不相离。或为显示诸不生法。故复说言及堕一世。若尔但应言堕一世。不尔应不令知定堕一世。岂不等流异熟亦是一果摄。如何一果外。说等流异熟耶。实尔此中言一果者。但摄士用及离系果。岂不此言通故亦摄等流异熟。虽言亦摄。非此所明。然士用果。总有四种。俱生无间。隔越不生。此显与因非俱有果。为遮唯执与因俱生。和合聚中有士用果。此和合聚。互为果故。自非自体士用果故。即显非彼俱起和合。士用果中。有一果义。是故别举等流异熟。应知此中时一果一。显俱显共。其义有殊。此中心王极少。犹与五十八法为俱有因。谓十大地法。彼四十本相。心八本随相。名五十八法。五十八中。除心四随相。余五十四。为心俱有因。何缘心随相。非心俱有因。不由彼力心得生故。心非与彼互为果故。彼于一法。有功能故。又与心王非一果故。聚中多分非彼果故。即由如是所说多因。随相不名心随转法。若尔云何心能与彼为俱有因。由随心王生等诸位。彼得转故。岂不应知大种生等。心亦用彼为俱有因。谓如造色非生等果。生等非不与诸大种为俱有因。此亦应尔。如是所例。其理不齐。展转果一果多。非彼果故。非诸造色是诸大种展转果中一果所摄。何容造色非诸大种生等果故。例此为失。又如前说。前说者何。不由彼力。心得生故。然诸大种。与生等相。展转力生。故无此失。有余师说。五十八中。能为心因。唯十四法。谓十大地法。并心四本相。非诸心所生等相力能为心因。如心随相。若尔便违品类足论。如彼论言。或有苦谛。以有身见为因。非与有身见为因。除未来有身见及彼相应法生老住无常。诸余染污苦谛。或有苦谛。以有身见为因。亦与有身见为因。即所除法。彼作是言。我等不诵及彼相应法。应随义理简择论文方可诵持故。异此便坏俱有因相。或应许随相亦心俱有因。复有说言。一切同聚。皆互相望。为俱有因。于同聚中。随阙一种。所余诸法。皆不生故。此诸说中初说为善。又此俱起和合聚中。有是能转而非随转。谓即心王。有唯随转。谓色及心不相应行。有是能转亦是随转。谓心所法。随心转故。能转心不相应行故。有二俱非。谓除前相。云何俱起诸法聚中。有因果义。何故知无俱起诸法。于将生位。既非已生。并应未有。如何可说能生所生。又说。有因则有果故。若未来世诸法能生。应有诸法恒时生过。又俱生法。此果此因。无定因证。如牛两角。又诸世间。种等芽等。极成因果相生事中。未见如斯同时因果。故今应说。云何俱起诸法聚中。有因果义。今当且为辩因果相。即令知有俱生因果。谓前略举诸因相中。引薄伽梵处处经说。依此有彼有。此生故彼生。与此相反非有非生。如是名为因果总相。此中初显俱生因义。后文复显前生因义。若尔决定无俱生因。以薄伽梵说依此有彼有未来无故。何得为因。此责不然。无有多种故。未来非无故。后当广辩。又此契经。证未来有。或复彼应说不违理经义。此中上座。释经义言。依此有彼有者。此说有因相续为先。然后有果相续而住。谁生为先。谁生已住。为答此复说此生故彼生。此显因生为先故后果生而相续住。如是上座。但率己情。妄解佛经。以扶己义。如是解释佛所说经。无有定因堪为证故。谓何定因为证依此有彼有言。但据因果相续而说。不据一一因果刹那。依有一念因即有一念果。此顺正理。非因相续后方有果相续。违正理故。又彼所说。无别胜理。非觉为先而作是释。不能开显经之妙义。若谓刹那因果难觉故据相续因果说者。此亦不然。无容有故。谓无容有不隔果刹那因相续而起。亦无容有不隔因刹那果相续起故。若如彼释。应显世尊说非如理。或应不据相续因果而说此经。彼如是释。令缘起义难可了知。是故彼应于此经义更作余释。又彼何理定判。前经依相续说。后经不尔。后经亦应得作是释。此生故彼生者。此说有因相续为先然后有果相续而住。非彼宗有与生义别。如非将生时与将起时异。又所疑问。谁生为先谁住已住。亦不应理。前后二门。不相待故。二门所待。义各异故。非前所说依此有彼。有复待后说此生故彼生。谓前已说。依此有彼有。不待疑问谁生故彼生。并待后释因生故果生。前义方了。如后所说。此生故彼生。要待疑问。谁生故彼生。复待别释因生故果生义即明了。如是前说依此有彼有。亦待疑问。依谁有彼有。复待别释。依因有果有义即明了。是故前后所待各别。故我所说。初经为显俱生因义。后经复显前生因义。其理极成。彼复异门。释此经义。前经为显诸行有因。后经为遮计常因执。此亦非理。但说后经。如是二门。皆成就故。谓经但说此生故彼生。二事俱辩。由说因果相继而生。显行有因遮无因论。由生言故。显无常因。亦即能遮说常因论。诸常住法。必无生故。既由后说。二事俱成。则说前经。便为无用。非薄伽梵说无用经。故知二经。非如彼释。设许如是解释前经。亦不乖违俱生因义。谓即依此俱生因有。而能令彼俱生果有。岂不由此显行有因。亦即能遮执无因论。如后所说。此生故彼生。由此能显因是无常。亦即能遮说常因论。而不违害说前生因。如是前说依此有彼有。由此能显诸行有因。亦即能遮说无因论。而不违害说俱生因。又前生因正居有位。未来无故。都无所生。彼宗自说未来无故。既无所生。如何善逝。分明显说。此有彼有。如此有言。是差别说。所说有义。现有极成。故彼有言。亦差别说。所说有义。亦应现有。此彼异因。不可得故。如是同喻。彼此极成。如言彼色居正灭位。又曾无处于极成无作差别说。言彼是有。如何可于未来无法作差别说言彼是有。于差别说。而说为无。如是所言。违害正理。又未来法。许有因故。虽无作用。而体应有。若彼不许未来有因。应许毕竟无同兔角。既许有因。亦必应许未来体有异毕竟无。诸所言无。义有多种。未生已灭毕竟互无。初二言无。但无作用。故未来世。非体全无。得有能生及所生义。于正生位。作用虽无。而有功能生所生法。又我不许诸未生因及已生因是真作者。诸法无有真作用故。真作用者。谓诸因缘。于所生果。常能造作。此真作用。非佛所许。然诸法生。互相系属。随有所阙。余则不生。非此不生。彼有生义。依如是量。说此为因。此因功能。非恒时有。故无诸法恒时生过。又我不许唯俱生因不假余因能生诸法。故无诸法恒时生过。又唯说有前生因者。于如是过。岂独言无。彼前生因。恒时有故。应一切法一切时生。随有许因能生诸法。皆可施设如是过难。然妄执有随界论者。彼执恒现有无量法生因。岂不汝宗独为诸法于一切时顿生过害。若汝虽执唯前生因而待余缘方能生果。何故不许此俱生因亦待余缘方能生法。如汝所执。唯前生因能生诸法。然不恒生未来亦尔。不应为难言俱生法此果此因无定。因证如两角等。皆非应理。现见两角。随一坏时。余不坏故。若随一坏。余亦坏者。可比相生如心心所。又我不许一切俱生皆有展转为因果义。许有者何。谓共一果或展转果。方有此义。或由此力。彼法得生。如是俱生。有因果义。非牛两角有上所说。故不可引为同法喻。又对法者。非许俱生互为果法。有决定量。谓此唯因。此唯是果。但许如是和合聚中一切相望皆因皆果。故不应责因果定因。又如唯说前生因者。许有少分前生非因。非诸前生皆无因义。如是说有俱生因者。亦许少分俱生非因。非诸俱生皆无因义。又有别喻证俱生因。故彼立因。有不定过。谓世现见。灯之与明。俱时而生。有因果故。复何因证。灯是明因。谓明随灯。或增或减。或住或行。有差别故。又欣明者。便取灯故。又厌明者。便害灯故。我亦许明因灯而起。然不许彼因俱起灯。所以者何。灯明俱起。不可待灯明方生故。非俱生法相待应理。如非自体待自体生。但由前生灯为缘故。无间后念明乃得生是故不应引之为喻。此亦非理。灯初起时。有灯无明不可得故。谓曾未见有时有灯而无有明。故为非理。若谓时促不可得者。此亦不然。非极成故。若有少分无明之灯。世极成立。或有责彼不得之因。容可答言。由时促故。此不可得。然无少分无明之灯。世极成立。故不应说由时促故。为不得因。若许灯明恒俱起者。彼不应说灯是明因。由灯与明一因生故。谓油炷等。与灯为因。即此亦应为明因故。如是二种。既一因生。如灯不因明故得起。明亦应尔。非因灯生。复有喻故。不相因起。如苣蕂中皮人与腻三事和合。一因生故。非展转因。世极成立。灯明亦尔。一因生故。明必不应用俱起灯为因。灯明不应同一因起。如皮人腻在苣蕂中。不见苣蕂皮人腻合同一因生得为因果。灯明二种。现见在前相随等因。证有因果。故不可说同一因生。又一为先俱生诸法因有差别。是极成故。谓共现见。一种为先所起牙中。俱生诸法。色香味触。因各别故。既一芽中。色香味触。俱时而起。因各有殊。故知灯明。俱时而起。亦应如彼非一因生。若灯与明一因生者。或有以物揜蔽灯时。明应如灯非不相续。灯如明故。应亦不生。非苣蕂中皮人腻合一因起位。见有随一缘碍不生余尚得起。灯明不尔。故因不同。若谓灯明体无别者。亦不违害我俱生因。又焰与明。非同法故。其体各异。由前所说。相随等因。得为因果。故灯明喻。其义极成。又见厌背受想二法入灭定者。思等心所。亦如受想。皆不得生说此定中意行灭故。由此准度验思等生系属受想。故知诸法前生因外。有俱生因。然上座言。思等心所。于灭定中。不得生者。由与受想生因同故。非由展转为因生故。何谓为彼所同之因。若谓是触此位应有。彼许灭定中有心现行故。若是所依此位亦有一切心所法。皆依识生故。同因既有。彼何不生。又应退失前后生论。许触与识为彼因故。由此不应说与受想生因同故思等不生。又见因虽同而不俱生故。知必俱生者。定展转为因。谓由眼色前生识故。无量眼识。皆可得生。此生因虽同。而不俱起者。由不展转为因生故。唯因前识后识得生。非因后识前识生故。由此验知。生因虽共。不相因者。未必俱生。若必俱生。定相因起。俱生因义。由此极成。又前已说。芽中色等。俱时而起。因各有殊故知生因虽不同者。亦有展转俱时起义。是故俱起及不俱起。非定由因同与不同。又说心心所同一因生。亦说俱生时有因果故。谓说心所及与眼识。同用眼色为因而生。故契经说。眼色二为缘。生诸心所。又契经说眼及色为缘。生于眼识。如是二经。说心心所同一因生。复说同时诸心所法。依心而生。故契经说。若想若思。诸心所法。是心种类。依止于心。系属于心。依心而转。非诸心所。心不俱生。有依属心依心转义。非无与有可成能依所依性故。如是之义。后当更辩。是故决定有俱生因。又俱生因。若定无者。应立大种造色不成。谓若大种及眼等造色。唯依前生大种而生者。大种眼等同用一具大种为因。何缘造色唯是眼等。非诸大种。又应违经谓薄伽梵。对无衣者。作如是言。我终不说受众苦者。无因无缘。有苦生起。若执诸法唯有前生因无俱生因者。彼即应说。有因缘时无苦生起。苦生起位因缘已无是则违前契经所说。又应违害缘起正理。如契经说。眼色为缘生于眼识。前生眼色。与后眼识。应非所依及非所缘。有无有故。非毕竟无。可说此是所依所缘。此亦应尔彼眼识生时。眼色已灭故。应无缘力。眼识自生。无法无容为所依故。眼识唯缘现在境故。若眼色识。不俱生者。则应眼色非眼识缘或耳声等。亦眼识缘。同与眼识。非相属故。若薄伽梵。唯说前生眼色为缘生眼识者。则应说眼识唯用识为缘。自类缘强如种子故。前识为后识等无间缘故。既不说识为眼识缘。故知此中唯说俱起眼根色境。为眼识缘。非一身中二识俱起。故不说识为眼识缘。若谓此中唯说眼识不共缘者。前生眼色与耳声等。不属眼识。义无别故。何唯眼色。为不共缘。非耳声等。又必应尔。由第六识无别俱生所依缘故。但说前起意为依缘。意识得生。非如余识又诸识缘非唯前起。以契经说。意法为缘。生于意识意识通以三世无为。为境界故。由此决定有俱生缘。理极成立。又此经言。三和合触。分明证故。若眼识生。眼色已灭。眼识尔时。与谁和合。若言五触如意触者。此亦不然。意识力强。通与诸法有和合故。意识依境。虽不俱生。而体非无。有和合义。我宗三世及三无为皆实有故。汝宗唯有现在世法。合义不成。又诸憎背俱生因者。初无漏法。从何因生。彼前生因。曾未有故。若谓净界本来有者。因既恒有。何缘障故。无漏果法。曾未得生。若言更赖余缘助者。即此所赖。何不为因。又应唐捐作如是责。谓何不执自在天等若言要待相续转变。理亦不然。此与净界。若异若一。皆有过故。谓若异者。应同前难。即此转变。何不为因。如何复执净界为种。或应唐捐作如是诘。如服泻药天来令利。若言一者。前后既同。应毕竟无生无漏用。然彼前后无差别因。不可无因自有差别。若言如种待缘转变。同类种子有地等缘。和合摄助可有相续待时方成转变差别。所执净界无漏法种。若是有漏。执此唐捐。有漏法不应为无漏种故。无漏法亦不应为有漏种故。若是无漏如何本来成就圣道。而堕恶趣。岂成圣道而是异生。非圣位中不起圣道。尔时可得名异生故。若言少故无斯过者。勿彼能为无始积集。坚固烦恼对治生因。又更无劳难譬喻者。契经已遮彼所执故。如世尊说。我实不见。提婆达多白法犹成如毛端量。乃至广说。世尊自说。天授身中。白法根种。无余已拔。故此经内。复作是言。有随俱行善根未断。以未断故。从此善根。犹有可起余善根义。彼于后时。一切皆断。今应说彼除此善根。更复有何非无余拔。而于佛教所说义中。无顾忌心。不能信受。不可闻说。大木聚中。有净界故。即说有情身中亦有太过失故。如大木聚随他所欲。成净成染。有情亦应许随他欲。或从净界无漏法种。生圣法已。复随他欲。还成异生。又亦应执诸阿罗汉退法种性有烦恼种。无学有退。后当成立。又上座说。诸行决定无俱生因。诸行将生。应无因故。又应余类生余类故。谓俱生法。于将起位。非此与彼能作生因。犹未生故。又应求彼二种异因。由彼二因。二俱得起。此说非理。无证因故。是所许故。谓俱生法。将生位中。此非彼因。未说因证。岂不已说。犹未生故。此亦同疑。谓何因证。犹未生法。不能为因。又彼如何。于无体法。倒许为因。非有体法。若谓未生体非有者。体若非有。勿谓有因。非兔角等毕竟无法。可说有因。此亦应尔。汝亦不许兔角非无。又我所宗有有多种。体用假实有差别故。未来虽有。而引果用。犹未有故。说为未生。体既非无。何无因义。不说因证。而执未生非法生缘。不应正理。若未生故不得成因生故成因。是则应许过去诸法定成因性。若尔执有随界唐捐。或应随界无因而有。若谓过去是展转因。此有虚言。都无实义如何过去。全无有体。而可成立为展转因。智者应观此盲朋党。于无体法。倒执为因。有体法中。拨无因义。若谓因过去非过去是因。是则未来亦应同此。如过去法体非有故。非展转因。未来亦应体非有故。非展转果。又展转者是相续言。不应此法。即续于此。既无去来。唯有现在。故应决定无展转因。然彼所说。又应求彼二种异因。由彼二因。二俱起者。此我已许。谓我许心心所等法。皆由前生自类因起。及由俱起异类因生。汝复于中何劳征难。是故上座。都无有因能证定无俱生因义。又彼所说。唯一刹那。有所依性。及诸行法。有俱生因。皆难可了。此非理说。虽难可了。而义非无。如所依性。谓所依性。一刹那中。虽难可了。而心心所。非无所依刹那眼等。又诸业果。一刹那顷。虽难可了。感起非无。此俱生因。亦应如是。然后具寿。诸所发言。皆非善说。违教理故。由此决定有俱生因。故俱有因理极成立

说一切有部顺正理论卷第十五阿毗达磨顺正理论卷第十六

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩差别品第二之八

如是已辩俱有因相。第三同类因相云何。颂曰

  同类因相似　　自部地前生
  道展转九地　　唯等胜为果
  加行生亦然　　闻思所成等

论曰。能养能生或远或近诸等流果。名同类因。应知此因。唯相似法。于相似法。非于异类。如善五蕴与善五蕴展转相望。为同类因。染污无记。应知亦尔。有余师说。净无记蕴。五是色果。四非色因。性下劣故。有余师说。五是四果。色非四因。势力劣故。有余师说。色与四蕴。相望展转。皆不为因。劣异类故。若就位说。有余师言。羯赖蓝位。能与十位为同类因。頞部昙等九位。一一皆除前位。与余为因。后位望前。但有缘义。若尔最初羯赖蓝色。应无有因。最后老色。应无有果。故理不然。复有师言。前生十位。一一皆与后生十位。各自类色为同类因。由此方隅。一切外分。各于自类。如应当说。譬喻者说。诸色决定无同类因。但由众缘和合资助。而得生长。现从井下掘出泥中。有芽生故。非于地下曾有种生。芽从何起。故知色法无同类因。彼执违害本论所说。故本论言。过去大种。未来大种。因增上等。彼言我说于此无违。由增上缘有近有远。如次说为因增上故。无方逃难矫设此言。虽似顺文。而实违理。又非许色有同类因。于理于文。有所违害。然从井下掘出泥中。有芽生者。彼先有种。阙和合缘。未生芽等。今缘和合。牙等乃生。若彼泥中。无同类因。而得生者。应生一切。或全不生。无定因故。为诸相似于相似法。皆可得说为同类因。不尔云何自部自地。唯与自部自地为因。是故说言自部自地。部谓五部。谓见苦所断。乃至修所断。地谓九地。谓欲界为一。静虑无色八。此中欲界见苦所断。还与欲界见苦所断。为同类因。如是乃至。欲界修所断。还与欲界修所断为因。如说欲界五部所断。静虑无色。各四地中。随其所应。皆如是说。此为一切。不尔前生。谓唯前生。与后相似。生未生法。为同类因。是谓圆满同类因相。唯说前生与后生果为同类因。于义便阙。不说与未生为同类因故。唯说过去与未来现在为同类因等。于义亦阙。不说过去有因果故。若如前说。通摄本论所说前生与后生法。及说过去为现未因。现在但为未来因义。未来何故无同类因。彼无前后次第义故。岂不诸法于正生时已能蠲除一切障碍。望未生者得说为前。又异熟因。于未来世。亦应非有由异熟果。望异熟因无前后故。要依前后立同类因。非正生时已越后位。未有作用。如余未来。过去唯前。未来唯后。现通前后。约世定故。过去诸法。虽皆是前。而取果时。已定前后。非未来法于正生时作用别余可立前后。要至现在已生位中。方简未来。令成后位。以已作用。取彼为果。若尔异熟因亦勿未来有。此彼非类。所以者何。此同类因与等流果。善等无别。若无先后应互为因。既互为因应互为果。互为因果。与理相违。既无理能遮互为果。则应许有果在因先。亦有二心互为因义。是则违害发智论文。彼异熟因。与果相别。虽离前后。而无上过。故同类因。就位建立。未来非有。若异熟因。就相建立。未来非无。若同类因。未来非有。岂不因义今有本无。许故无失。约位非体。由和合作用位。果非体果。和合作用。是法差别因缘和合。法行异位。法行异位。非离体成。然异位行。亦非即体。如是异位。从异位生。同类果因。名为异位。故和合作用位。果非体果。理虽无过。文而有违。如本论说。若法与彼法为因。无时此法非彼因。岂不过现与彼为因未来非因。便违此说。无违此过。此依俱有相应异熟。通三世因。密意说故。有余师释。虽此通依六因作论。而无有失。未来既无同类遍行。如何可说无时非因。未来虽无。而此意说能为因后无时非因。又此未来亦定应有。谓有为法于正生时。定能为因。殄诸障故。依此密说无时非因。然经主言。彼非善释。以未来法正生位前非同类因后方成故。如是过难。前已释通。谓非未来有前后故。就三世说无时非因。意显更无第四时故。若尔等无间应同此说。然本论不许。故本论言。若时此法。未至已生。非等无间。无斯过失。所以者何。等无间缘。据开避力。非正生位。有开避能。要已生时。有开避力。若至已灭。名已开避。同类因者。如种子法。于正生位。住种法中。至已生时。正能取果。故因非类等无间缘。有余师释。次正生后。此同类因。定取自果。等无间缘。则非决定。有已灭位。方取自果。故不可依正生时说。毗婆沙释。为现二门。如彼处说。此亦应尔如此处说。彼亦应尔。然经主说。如是作文。获何功德。唯显论主非善于文。无斯过失。转彰论主于文巧故。谓能显示诸所作文有有余意有无余意。何须显示有余意文。有余意文。处处有故。于何处有。次后当辩。如是善通发智论说。品类足论当云何通。如彼论言。或有苦谛。以有身见为因。非与有身见为因。除未来有身见及彼相应苦谛。诸余染污苦谛。或有苦谛。以有身见为因。亦与有身见为因。即所除法。是诵者失。文无此言。彼论但言除未来有身见相应苦谛。无及彼言。设有如是言。准义应知谬。施设足论当云何通。彼说诸法四事决定。所谓因果所依所缘。应知彼文因者。谓能作俱有相应异熟因。果者谓增上士用异熟果。所依者谓眼等六根。所缘者谓色等六境。又品类足论当云何通。如说云何非心为因法。谓彼已入正性离生补特伽罗初无漏心。及余异生决定当入正性离生初无漏心。然彼异生未来所有诸无漏心。皆非心为因。何故唯说彼初无漏心。有作是释。彼文不辩同类因义。何者唯辩二种异生。谓有般涅槃法。及无般涅槃法。文虽不举无涅槃法。义准理门显示知有。谓彼既说。有余异生决定当入正性离生。由此义准亦有异生决定不入正性离生。有余师释。彼文亦辩同类因义。然彼唯说。若心毕竟非心为因。虽彼未入正性离生者。诸无漏心。皆非心为因。然彼若入正性离生。唯有初无漏心。是非心为因法。余心无不以心为因。识身足论。当云何通。如彼论言。于过去染污眼识所有随眠。彼于此心。或能为因。非所随增。或所随增。不能为因。或能为因。亦所随增。或不能为因。亦非所随增。且能为因非所随增者。谓诸随眠在此心前同类遍行。即彼随眠。若不缘此。设缘已断及此相应随眠已断。为所随增不能为因者。谓诸随眠。在此心后同类遍行。即彼随眠。缘此未断。能为其因。亦所随增者。谓诸随眠。在此心前同类遍行。即彼随眠。缘此未断及此相应随眠未断。不能为因亦非所随增者。谓诸随眠。在此心后同类遍行。即彼随眠。若不缘此。设缘已断。若所余缘。若他随眠。若不同界遍行随眠。如彼过去染污眼识。未来染污眼识亦尔。过去四句其理可然。未来如何可立四句。有作是释。彼于未来应立三句。除所随增不能为因。彼无后故。然说未来如过去者。显正生时。必入现在。望余未起。可立为前。对此可说余名后故。有余师释。此说未来亦有四句。不言未来有在心后同于过去。谓有同类遍行随眠在未来世。于彼未来染污眼识。缘而未断。是所随增不为因故。言同类因唯自地者。定依何说。定依有漏。若无漏道。展转相望。一一皆与九地为因。谓四静虑及三无色未至中间。是名九地。余无等引。非猛利故。皆不能发。无漏圣道。九地道谛。展转为因。所以者何。此非系地故。非诸地爱执为已有故。由是道谛。虽地不同。展转为因。同种类故。然非一切为一切因。与谁为因。谓等胜果。加行生故。非为劣因。初定圣道。有依初定。乃至有依无所有处二定等道应知亦尔。于依自上有。于依下地无。谓依初定初定圣道。与依九定九地圣道为同类因。即此唯用依初定道为同类因。不用依上圣道为因。以性劣故。依第二定初定圣道。除依初定。与依余定九地圣道。为同类因。即此唯用依初二定九地圣道。为同类因。非依上地依第三定。初定圣道。除依初二。与依余定九地圣道。为同类因。即此唯用依初二三九地圣道。为同类因。非依上地。乃至若依无所有处初定圣道。唯与依此无所有处九地圣道。为同类因。即此通用依九地定九地圣道。为同类因。如依九定。初定圣道。余定圣道。依于九地。随其所应。当广思择。又一地摄诸无漏道。亦非一切为一切因。为等胜因。非劣因故。且如已生苦法智忍。还与未来苦法智忍。为同类因。是名为等。又即此忍。复能与后从苦法智至无生智。为同类因。是名为胜。如是广说。乃至已生诸无生智。唯与等类为同类因。更无胜故。又诸已生见道修道。及无学道。随其次第。与三二一为同类因。展转为因。亦不违理。如何后生胜无漏道。能与前生劣无漏道。为同类因而不违理。谁言后生胜为前生劣因。前生钝根。种性修道。与自相续未来决定不生利根种性见道。为同类因。何理为碍。一切有情。各别相续。法尔安立六种种性。无学望前应知亦尔。然有差别。谓有前生无学圣道。于自相续后生修道为同类因无学退已。于修道中。可有转生利根义故。若尔应与本论相违。如说已知根与未知当知根为所缘增上。非因非等无间。如是具知根。于二根亦尔。此无相违。有余意故。如次前说。有余意文。处处皆有。即是此等。故应显示有余意文。今此文中。有何余意。谓依后生如是根性所摄已知根。即望前生如是根性所摄未知根。密作如是言。为所缘增上非因等无间。劣故后生故。此文但说已起作用依相续转诸无漏根。如说有用世第一法。若尔有情各别相续。法尔安立三乘菩提。如是亦应声闻乘道得作独觉佛乘道因。独觉乘道作佛道因。无斯过失。性极远故。若已升陟声闻道者。无容更生余乘道故。若尔已升随信行道。随法行道。无容更生。是则前生随信行道。与未来世毕竟不生随法行道。应不为因。亦无此失。诸钝根道。可有转成利根道故。谓即由彼随信行根诸蕴相续。可有转得属随法行蕴相续根。非由已升声闻乘道诸蕴相续。可有转得独觉佛乘蕴相续道。依如是理。故有说言。虽无是处而假分别。若见道中。有出观者。随信行道。亦有转得随法行根。然无出义。故根差别。与乘不同。由此故言。诸钝根道。与钝及利。为同类因。若利根道。唯利道因。如随信行及信胜解时解脱道随其次第。与六四二。为同类因。若随法行及见至非时解脱道。随其次第。与三二一。为同类因。此亦准前应知不定。诸上地道。为下地因。云何名为或等或胜。由因增长。及由根故。为但圣道唯与等胜为同类因。不尔云何。余世间法加行生者。亦与等胜为因非劣。加行生法其体云何。谓闻所成思所成等。等者等取修所成等因闻思修所生功德。名彼所成。加行生故。唯与等胜为因非劣。如欲界系闻所成法。能与自界闻思所成。为同类因。非修所成因。欲界无故思所成法。与思所成。为同类因。非闻所成因。以彼劣故。若色界系闻所成法。能与自界闻修所成。为同类因。非思所成。因色界无故。修所成法。唯与自界修所成法。为同类因。非闻所成因。以彼劣故。无色界系修所成法。唯与自界修所成法。为同类因。非闻思所成因。以无故劣故。有余师说。思所成法。与修所成。为同类因。岂不欲界有思所成无修所成。若于色界有修所成无思所成。然世间法。唯与自界。为同类因。前说自部自地为因。依有漏故。如何彼说思为修因。有作是释。即于欲界。有胜方便所摄善根。虽思所成。而极寂静。似修慧故。名修所成。思为彼因。说亦无过有余师释。得尽智时所修欲界思所成法。是阿罗汉修慧果故。似修慧故。名修所成。思为彼因。说亦无过。此闻思修所成诸法。各有九品。谓下下等。若下下品。为九品因。下中八因。乃至上上。唯上上因。除前劣故。生得善法。与加行善。为同类因。非加行善为生得因。以彼劣故。又生得善。亦有九品。一切相望展转为因。容一一后皆现前故。有余师说。定一心中得一切故。然由现行异熟九品。可施设有九品差别。染污九品。准此应知。复由对治有九品故。可施设有九品差别。无覆无记。总有四种。谓异熟生。威仪路。工巧处。化心俱品。随其次第。能与四三二一为因。有余师说。一切相望展转为因。同一缚故。此说非理。勿初静虑暖等四法展转为因。又欲界化心。有四静虑果。非上静虑果下静虑果因。非加行因得下劣果。勿设功用而无所获。因如是义。故有问言。颇有已生诸无漏法非未生位无漏法因。有谓已生苦法智品。于自种性未来不生苦法智忍俱品诸法。如是乃至。诸有已生金刚喻品。与自种性。下位未生诸无漏法。又一切胜。于一切劣。以加行法为同类因。所得之果。或等或胜。颇有一身诸无漏法前所定得非后生因。有。谓未来苦法忍品。于后已生苦法智品。以果必无在因前故。或同类因。未来无故。颇有前生诸无漏法非后已起无漏法因。有。谓前生胜无漏法。于后已起劣无漏法。如前已生苦法智得于后已生苦法忍得。彼虽后生。而是劣故。如是一切圣道诸得。前胜后劣。准此应知。经主此中以上果退下果现前。用答所问。此非决定。退上果已。容有练根起胜无漏现在前故。彼应简此。然此同类因。与果功用。无有穷尽。非如异熟因与果功用定有穷尽。诸阿罗汉。受同类因。果犹未尽。而涅槃故。非同类因定能生果。谓有同类因。由有障故。果或余时起。或永不生。故于此中。有作是问。同类因与果亦能取果耶。总相答言。诸与果者。必能取果。所以者何。不取而与。理不成故。有能取果而不能与。谓阿罗汉最后诸蕴。以前诸蕴虽能与果而未穷尽便般涅槃。又于听诵思择等业。虽同加行遇等助缘。而见善根积集有异。故知因用。非唯此生。然说随俱善根力故。善根生者。据成就说。此说意言。因虽成就及不成就。皆能生果而成就者。生果力强。强弱虽殊。为因义等。又近远因虽俱成就。而于生果。亦有胜劣。若但因彼随俱善根。善根生者。善根断已。应当毕竟不续善根。故同类因。约与果用。受用无尽。非异熟因。如是义门。曾何处说。岂不辩此因相中言。未来现在过去为因。过去现在为未来因。复有何缘。于阿罗汉正命终位。心心所法。遮等无间缘。许同类因性。此二与果等非俱故。等无间缘。由开避力。诸阿罗汉正命终时。无无间生心心所法。由阙和合生因缘故。无所开避等无间果。是故亦无能开避力。故遮最后法等无间缘相。然同类因果通近远又所引果。无有限量。非所取果必定当起。故不可类等无间缘。遮后位立同类因性。有异说言。定应唯许于无间果立同类因。又不应言善恶无记心次起位。非由前念为同类因后念心起。由见世间种芽茎叶蓓蕾花果。不相似物。次第生时。无间为因。相次而起。无隔越故。又如毛角能生蒲苇。彼言非理。现见善恶。随一增时。余一减故。又修能治所治应增。则永应无解脱苦义。又习所治能治应增。便无不成能治道者。如是等失。彼不可离。又见世间。习学书论工巧智等。已得坚住。虽遇异缘于中间起。而后生位。还以前时同类相续为因而起。故同类因。亦有隔越。种芽等喻。于证无能。外物相生次第安住。内法不尔。故喻无能。如种无间定有芽生非茎叶等。善心无间。不见定有如是心生。又芽无间可有茎生。非茎无间可有芽生。善恶心生。次第无定。又诸外物。时分决定。内法不尔。故喻无能。谓由功能勤勇教等力殊胜故。修观行者。善心多时相续而转。诸习欲者。恶心多时相续而转。非芽茎等。时分不定。故内外别。又稻等类。次第生中。无记性同。可有因义。心等一类。次第生中。善等性殊。不应为喻。言从毛角生蒲苇者。是世俗论。与理相违。若许相生无简同异。何不从二各二果生。然彼毛角如粪暖等。于生蒲苇但作顺缘。故同类因。唯于自类有间无间。皆得成因。如是已辩同类因相。第四相应因相云何。颂曰

  相应因决定　　心心所同依

论曰。唯心心所。是相应因。岂不此中无简别故时境行相别亦相应。设简别言。此三同者。异身同嘱。应说相应。故说同依。总遮斯难。谓要同依心心所法。方得更互为相应因。此中同言。显所依一。谓若眼识。用此刹那眼根为依。相应受等。亦即用此眼根为依。乃至意识。及相应法。同依意根。应知亦尔。今应思择。眼耳等根。所依性同。何缘说彼能依之识。所依各异。何劳致问。诸识所依。依性虽同。而类别故。若尔何故知同依言。唯就俱生刹那依义。说眼识等同一所依。非就长时种类依义。说诸眼识同一所依。又无间依种类同故。应眼等识为相应因。世尊亦依种类同义。说眼等识所依诸根。故契经言。眼见色已。生忧喜舍。又契经说。以眼为门。唯为见色。此等皆说种类同依。是故颂中。应如是简谓心心所。同时同依。故彼释中。自摄二义。谓若眼识用此刹那眼根为依。乃至广说。颂中既阙同时之言。如何得知此同依者。非一种类是一刹那。若谓释中摄故无过。应所造颂不说同依。但说相应因决定心心所。又相应言。足遮诸难。非时依异可有相应。但说相应。即知一切时依行相境事皆同。若异时依。异行相境。不相应故。非种类一多事俱起。共相应故俱有相应二因何别。且相应因法亦俱有因。有俱有因法非相应因。谓随转色。生等大种。若相应因即俱有因。此中二因义有何别。非相应因即俱有因。由此二因义各异故。然即一法。是相应因。亦俱有因义差别者。不相离义。是相应因。同一果义是俱有因。又展转力同生住等。是俱有因。若展转力同缘一境。是相应因。有余师说。由互为果义立俱有因。如商侣相依共游险道。由五平等义立相应因。即如商侣同受同作食等事业。其中阙一。皆不相应。是故极成互为因义。如是已辩相应因相。第五遍行因相云何。颂曰

  遍行谓前遍　　为同地染因

论曰。遍行因者。谓前已生遍行随眠。及俱品法。与后同地自部他部诸染污法。为遍行因何等名为遍行品法。随眠品中。当广分别。此因势力。越同类因势力而转。故别建立。亦为余部染法因故。由此势力。余部烦恼。及彼眷属。亦生长故。于自部摄诸烦恼中。同类遍行二因何别。由有身见。诸爱得生。诸爱亦能生有身见。二差别相如何可知。自部二因。亦有差别。谓执我故。能令诸爱生起坚固增广炽盛。我见遍缘诸爱境故。爱令我见生起坚固。而不能令增广炽盛。不能遍缘我见境故。由诸遍惑展转相望。皆能遍缘所缘境故。一一遍惑。皆互能令生起坚固增广炽盛。故此二因。非无差别。一时一品。能为同类遍行二因。有何差别。虽同时取二等流果。而自部果增盛非余。故彼二因亦有差别。何故云何自部增盛。由二因门所长养故。由此为彼近生因故。令彼增广及炽盛故。唯生自部二因何别。无遍行因。唯生自部。谓遍行法。正现前时。俱时有力。取五部果。又已如前说彼差别。有余师说。俱有因一分是相应因。同类因一分是遍行因。彼师意说。遍行因义。即同类因。然不应理。余部亦应是同类故。则非遍行。应望余部成同类因。是则诸因应成杂乱。虽复诸因无各别体。而诸因义互不相杂。若遍行法能为五部。染污法因则见所断。应为一切染污法因。是宗所许不应为难。故品类足。说如是言。云何见所断为因法。谓诸染污法。及见所断法所感异熟。云何无记为因法。谓诸无记有为法。及不善法。或有苦谛。以有身见为因。非与有身见为因。广说乃至。除未来有身见及彼相应法生老住无常。诸余染污苦谛。若尔应违施设足论。如彼论说。颇有法是不善唯不善为因耶。曰有。谓圣人离欲退最初已起染污思。依未断因。密作是说。此染污思因虽具有不善无记。而无记因。先已永断。圣人退位。见所断惑。皆已断故。一切见道。必无退故。欲界染无记。皆见所断故。唯不善因。退故成就。说为未断。是故无失。若已断法。亦能为因。何缘诸圣补特伽罗。于无有爱重嗔恚缠诸慢类中。曾不现起。断见邪见萨伽耶见。皆已断故。无有爱等。随其次第。彼近起故。彼于今位。云何为因。非彼于今方成因义。于异生位。修所断染法。已用见所断。为遍行因。若法与彼法为因。无时此法非彼因。故虽已断。而因可说。应知此中过去现在。遍行随眠。为五部因。能缘五部。亦是五部之所随增。彼相应法。除所随增生等。复除能缘五部。彼诸法得。非遍行因。或前后故。性疏远故。非一果故。有遍行随眠非遍行因。谓未来世遍行随眠。有遍行因非遍行随眠。谓过去现在遍行随眠。一果法有俱是。谓过去现在遍行随眠。有俱非谓所余诸法。有于此中作如是难。若说诸见疑及无明。为遍行因。生异类果与余别故。名遍行者。非遍行中亦有此用。谓贪随眠于境耽着。能为一切邪行根本。如有邪见令贪随眠于诸境中耽着炽盛。如是有贪亦令邪见于自所缘炽盛增广。乃至引彼令断善根。如有邪见谤灭道已引贪随眠令乐生死。如是有贪乐生死已。能引邪见令谤灭道。是故唯执见疑无明。为遍行因。生五部果。非余贪等。理定不成。此难不然。因用别故。不遍随眠。总以五部诸染污法。但为士用及增上果。展转可作等无间缘令现起故。及彼生时。不障碍故。遍行随眠。亦以五部诸染污法。为等流果。此彼何别。得如是耶。遍行随眠。通缘一切有漏法故。势力坚固。炽盛增广。才已生时。便能引发同异类果。不遍随眠。则不如是。缘境狭少。功能劣故。虽贪随眠耽着境界。亦与邪见为展转因。乃至引令断诸善本。而非暂起。顿引自他五部染法。为等流果。有贪随眠乐生死已。能引邪见。谤灭道者。此一部中。展转相引。非于异部。故亦无违。或复因义甚深难了。无边差别。非易可知。谓诸法中。都无真实作者作用。然复说有无量种因能招诸果。谓于诸果。此为近因。此为远因。此因令生。此因令灭。此因令彼。有此因不。为害此因能牵引。此因为所依。此因如助伴。此因如种子。此因如饮食。此因如医药。此等因义。差别无边。唯佛世尊。所行境界。如是已辩遍行因相。第六异熟因相云何。颂曰

  异熟因不善　　及善唯有漏

论曰。唯诸不善。及善有漏。是异熟因。异熟法故。随其所应。此因能感异熟果故。名异熟因。今于此中。因是何义。谓随业法。能别有情。故契经言诸有情类胜劣高下。由业所别。又契经说。业为生因。颂中及声。显此因与果性相虽异而品类无杂。唯言为遮异熟因体摄诸因义。谓有余师说。一切果皆名异熟。彼亦应许异熟因体摄一切因。唯言为令勿同如是余师横计。彼复何缘。执一切果。皆名异熟。由契经说。此大光明。有何异熟。又契经言。二种施食所感异熟。平等平等。又说爱为受之异熟。又言如来若不说此语。即诸时众。无如是异熟。又说此梦。有何异熟。又诸世间。亦说食等为乐异熟。此类寔繁。此诸异熟言。皆就喻假说。如眼福田爱说海火母声。如何知前亦就喻说。若不尔者。诸无漏法。应有异熟然诸契经。遮无漏法有异熟义。说无漏思。为非黑非白。无异熟业。能尽诸业。故说无漏法。所引等流名异熟者。虽彼情计立异名言。而义无别。又诸经中。亦有如是就喻假说。如人寿短。说为杀生等流果故。此于增上。说等流言。以不善业无覆无记。为等流果。不应理故。何缘定知。唯不善法。及善有漏。是异熟因。契经说故。谓契经说。有黑黑异熟业。有白白异熟业。有黑白黑白异熟业。有非黑非白异熟业。能尽诸业。又契经言。现见领受悦意异熟。或复领受悲号异熟。由善不善。又说我遭身业等损。谓苦受生受苦异熟。复言我遇身业等益。谓乐受生受乐异熟。如斯等证。其类众多。又如同类异熟二因。义不相杂。等流异熟二果。亦应不相杂乱。虽诸异熟不越等流。而彼异熟。非彼等流。故知异熟等流果异佛观所化宜闻差别。说法有殊。阿毗达磨。依真实理。决判诸法。故非异熟总摄诸果经言诸业有三果故。若一切果皆异熟者。经不应言果及异熟。若执诸果皆异熟果。应许诸因皆异熟因。经说诸业为生因故。如眼耳等。宿业为因。应从因生。皆由宿业。是则经说。无明为因。起贪嗔痴。及有经说。有因缘故。众生耽染。此等皆应因于宿业。许亦何失。如种种身是宿业果。现行烦恼。差别亦然。是则应同离系邪论。非佛弟子。且置如斯破愚傍论。根本法相。今应正辩。何缘无漏不招异熟。毗婆沙说。无爱润故。如贞实种无水润沃。又无漏法。既非系地。如何能招系地异熟。何缘无记不招异熟。由力劣故。如朽败种。余善不善。能招异熟。如有水润诸贞实种。然异熟因。或持业释。故契经说。异熟生眼。或依主释。故契经言。业之异熟。义如前辩。言异熟者。或离因熟。或异因熟。此二属果。或所造业。至得果时。变而能熟。此一属因。然经主言。毗婆沙师。作如是释。异类而熟。是异熟义。谓异熟因。唯异类熟。俱有等因。唯同类熟。能作一因。兼同异熟。故唯此一。名异熟因。乃至广说。皆不应理。毗婆沙师。非决定说。六因所得。皆名熟故。设许尔者。是果异名。亦无有失。此异熟因。总说有二。一能牵引。二能圆满。且众同分。及与命根。非不相应行独所能牵引。云何知然。契经说故。如契经说。业为生因。又说业令生死轮转。又言业力。能别有情。又言劣界。思业所引。应知劣界。即是欲有。又品类足说。诸命根是业异熟。非是业故。不相应行无是业者。诸有释此品类足言。一切命根。皆是异熟。于招异熟业力最胜。由此意趣故作是说。岂不此释转复能遮不相应行有牵引力业于异熟。是胜因故。命众同分。是胜异熟。许唯业招命众同分。方可得说。于招异熟业力最胜。异不应尔。要业牵引。命众同分时非业缘斯亦能招异熟若执非业亦能牵引胜异熟者。则不应说于招异熟业力最胜。是故彼释。定非应理。非心随转身语二业定不能引命众同分。不尔便违契经正理。经言劣界思所引故。此说欲有命众同分。唯意业感。非身语业。身语表业。众多极微。一心所起于中唯一。引众同分及与命根。余无此能。不应理故。若许同时共感一果。则应更互为俱有因。有对造色。为俱有因。非宗所许。此非展转力所生故。又非次第一一极微牵引命根及众同分。一心起故。非一心起。无异功能别引生后。而无过失。非为满业。亦有斯过。于一生中。各别能取色香味等。圆满果故。依此无表。亦同此释。多远离体一心起故。不许互为俱有因故。若无对造色有非俱有因。说有对言。便为无用。显有对造色皆非俱有因。故作是说。有无对造色得为俱有因。不可同彼。若欲界系身语二业。不能牵引。便违契经。如说杀生若修若习若多修习生那落迦。乃至广说。又违本论。如说于此三恶行中。何罪最大。谓能随顺僧破妄语。此业能取无间狱中劫寿异熟。寿定说为所牵引果。此说所起。显能起思。粗易了故。无相违失。于欲界中。有时一蕴为异熟因。共感一果。谓有记得及彼生等。有时二蕴为异熟因。共感一果。谓善不善色及生等。有时四蕴。为异熟因。共感一果。谓善不善心心所法。及彼生等。欲界无有随转色故。无有五蕴为异熟因共感一果。有余师说。欲界亦有五蕴为因共感一果。谓同刹那表无表色。及能起此心心所法。彼说不然。所起身语。与诸能起。异熟别故。能起所起。非定一时。故所感果。非定俱起。谓能所起。容于一时能取果故。应一果者。理亦不然。虽能所起容有一时而果异故。表与无表。虽同刹那。而所取果。尚有差别。又诸表业有多极微。无表亦有多远离事。必同时起。果尚有殊。何况能起心心所法。与非随转色。而同取一果。故彼所说。理定不然。于色界中。有时一蕴为异熟因。共感一果。谓有记得。无想等至。及彼生等。有时二蕴为异熟因。共感一果。谓初静虑。善有表业。及彼生等。非于第二静虑已上有诸表业。无能起故。有时四蕴为异熟因。共感一果。谓无随转色。善心心所法。及彼生等。此有六心。如后当说。有时五蕴为异熟因。共感一果。谓有随转色。诸心心所法。及彼生等。无色界中。有时一蕴为异熟因。共感一果。谓有记得灭尽等至。及彼生等。有时四蕴为异熟因。共感一果。谓一切善心心所法。如是总有九异熟因。谓三界中。如数次第。三四二种品类差别。有业唯感一处异熟。谓感法处。即命根等。若感意处。定感二处。谓意与法。若感触处。应知亦二。谓触与法。若感色处。定感三处。谓色触法。若感香味。应知亦三。谓各为一。并触与法若感身处。定感四处。谓身色处触处法处。若感眼处。定感五处。谓眼身色及触法处。感耳鼻舌。应知亦五。谓各为一。身色触法。有业能感六七八九十十一处。声非异熟。故此不论。业或少果。或多果故。如外种果或少或多。如莲种等。有根芽茎花台须叶种种果异。蒲桃等种。则不如是。波沓波种。有多根茎枝条花叶种种果异。有诸水陆草木种类。但有一茎。如针茅等。或但有叶无茎等生。种子法然。不应疑问。有一念业多念异熟。无多念业一念异熟。勿设劬劳果减因故。有一世业三世异熟。无三世业一世异熟。招感异熟势力法尔。然异熟果无与业俱。非造业时即受果故。又业现在。非即果熟。法受业门。理决定故。亦非无间。由次刹那等无间缘力所引故。刹那正起。力难制故。又异熟因感异类果。必待相续方能办故。已说六因。当说世定。颂曰

  遍行与同类　　三世三世三

论曰。遍行同类。唯居过现。未来世无。理如前说。相应俱有异熟三因。于三世中。皆悉遍有。颂既不说能作因所居义。准应知通三世非世。不可说彼定时分故

说一切有部顺正理论卷第十六阿毗达磨顺正理论卷第十七

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩差别品第二之九

已辩六因相别世定。必应对果建立因名。何等名为因所对果。颂曰

  果有为离系　　无为无因果

论曰。果有五种。后当广说。今且略标有为离系。如本论说。果法云何。谓诸有为。及与择灭。岂不择灭许是果故必应有因。非无有因可说为果。曾未见故。我亦许道为证得因。经说此为沙门果故。此六因内。从何因得。我说此果非从六因。前说六因生所赖故。若尔应许。此证得因。离前六因。别为第七。我宗所许。如汝所言。岂不汝宗有如是诵。涅槃是果。而无有因。虽有此诵。于义无失。谓诸世间。于设功用所欣事办。共立果名。死于士夫。极为衰恼。故于不死。士最所欣。如是所欣由道功用。所证得故。说名为果。言无因者。道于所得择灭无为。非六因故。择灭于道。非所生果。是所证果。道于择灭非能生因。是能证因。故道与灭。更互相对。因果是非不可定说。若道于灭。为证得因。是则但应得为道果。谁言道果定非灭得。道于灭得为同类因。或亦说为俱有因故。然此非圣正所求果。由诸圣者以所得灭蕴在心中。修行圣道。故道胜果。唯所得灭。非灭之得。以诸圣者非求有为而修圣道。故薄伽梵。于契经中。说沙门果唯断非道非唯为证。道修道。非无用得。初念道时。应所作已办。若许择灭。是能作因。应许涅槃。有增上果。非许择灭。眼等生时。有能生用。可如声等。谓有为法。正生位中。有为无为。皆不为障。故一切法。皆能作因。然有为中。唯过现法。有取与用。说为有果。未来诸法。及诸无为。无如是用。故非有果。故契经说。诸因诸缘。能生识者。皆是无常。虽无为法。是因是缘。而不能生。故佛不说。如前思择能作因中。说能作因。略有二种。一有生力。二唯无障。故无为法。无障成因。由不能生故非有果。岂不经说。意法为缘。生于意识。何故无为是法所摄。而不能生。依多能生。密作是说。何妨少分有不能生。或复无为亦能生识。然识非果。如前说故。非能生故。便是无常。彼说能生后有识故。由如是理。如有为法建立因果。无为不然。是故择灭。是因无果。是果无因。理极成立。此中多类诽谤涅槃。彼诽谤因。纷竞非一。我今正破经主谤因。兼破余师。成立择灭因兹亦辩余二无为。此中经主。引经部说一切无为。皆非实有。如色受等别有实物。此所无故。然经说者。唯无所触。说名虚空。谓于闇中。无所触对。便作是说。此是虚空。已起随眠。生种灭位。由拣择力。余不更生。说名择灭。离拣择力。由阙缘故。余不更生。名非择灭。如残众同分中夭者余蕴。此皆非理。无因证故。且彼所言。唯无所触。说名虚空。无触名空我亦信受。空无触故。言唯无触。说名虚空。非别有体。此何因证。已证闇中无所触对。便作是说。此是虚空。岂不此因能证非有。非唯用此所说为因。能证虚空决定非有。谓彼但说。此是虚空。非所触对。如何知彼唯于无触。说名虚空。如世说言。此乐非苦。岂唯无苦。说名为乐。若谓不然。苦乐二受。有损有益。所作别故。非此虚空少有所作。可得如乐。故喻不同。是则前因。应成无用。由今但以虚空都无。所作可得证非有故。且定不可以无触对。谓是虚空为决定因。证虚空体唯无所触。是则经主此中无因能证虚空决定非有。又契经说。虚空无为。有所作故。非不如乐。如世尊说。风依虚空无作有依非有心执。又光明色是虚空相。故知虚空其体实有。如契经说。然藉光明虚空显了由此定显虚空之相。所谓光明。所以契经复说此语。谓佛先说。风依虚空。后说虚空无所依止。勿彼梵志生如是疑。如何证知虚空是有。而世尊说。风依虚空。为遣彼疑。复说此语。若空非有。何藉光明。光明有色有见有对。若无虚空。谁能容受。故世尊说然藉光明虚空显者。显光明色能与虚空为实有相。然彼上座。不了此经所说义趣。妄作是诘。若藉光明虚空显了。虚空应是色法所收。如是诘言。何从而至。又虚空体。应实非无。以契经中如心说故。如契经言。虚空无色无见无对。当何所依。非于我中或兔角等。可有如是差别言说。此中彼释。为对所问。故说此言。如契经说。善调伏我。我是所依。若为对问说此言者。不应作是说。但应言梵志虚空无体当何所依。又不应说然藉光明虚空显了。非于前际说言可了。及于作者说言可得。而应说为如实对问。若于非有如有而说。此说便成无义利语。又所引喻于证无能。调我我依于心说故。此于内义已广思择。无色等言。若无实义。此所引喻。何所辩成。又彼所言。若虚空体少有实物。虚空常故。则有碍色应永不生。或应许此是有为摄。如筏蹉子。彼不审思。故作是说由彼所执。实不能容余碍色故。非虚空体被余碍色所障碍故。余色生时。虚空开避。成无常失。然此虚空。容受性故。非色性故。无劳开避。虚空界体是障色故。余色生时。理应开避。谓虚空界。是轻妙色。虽不障余。而被余障。可是无常有为所摄。虚空相者。既不障余。亦非余障。色法生位。宁是无常有为所摄。虚空与色。同住无违。故于诸位。无起无尽。然壁等中有障碍者。由有碍色居彼障余。非空无为彼中无故。虚空界色。微薄轻妙。不能碍余。被余粗重色排障时。即便开避。诸有对色。法应如是。若一所居。必无第二。虚空无对与空界殊。何容类彼有无常失。又彼所言。若虚空体。是实有物。应成有为。此与空界。无差别故。彼有虚言。而无实理。世尊自说有差别故。如契经言。虚空无色无见无对。又言空界离色染时。与四俱断。若虚空界。不异虚空。虚空无色无见无对。空界应然。应如识界说于无色离染时断。又经说空界成假士夫。及说藉光明虚空显了。若虚空界即是虚空。又即光明是虚空界。岂契经说然藉光明光明显了。故知有异。又契经说。所有诸法。若诸有为。若诸无为。于中离染。最为第一。然此经中。说法有二。无为是法。不可言无。无体不应成法性故。诸无为者。显彼体多。故有虚空及非择灭。足以离染方可成多。除此更无余无为故。由此空界非即虚空。上坐不思。言二无别。有余师说。无别虚空。于碍色无生空觉故。彼说非理。即由此因能证虚空。别有体故。异碍色处。别有虚空能为所缘。生空觉故。若无所缘。觉不生故。由斯彼说。但有虚言。又亦可言。无别碍色。于空无处。色觉生故。然非由此可证色无。故彼不能证空非有。若谓诸色有体可知。空亦应然。可比知故。谓如眼等。虽不现知。而由有用。比知有体。如是虚空。亦有用故。比知有体。用如前说。是故虚空。别有实体。又彼所说。已起随眠生种灭位。由拣择力。余不更生。名择灭者。如是择灭。理亦不成。缘阙不生。无差别故。择力缘阙二种不生。委细推征。竟有何别。又离圣道。亦有不生。岂不修道便成无用。此非无用。以修道力。能灭未生未来随眠及生种子。由种灭故。令未来世惑苦不生。若谓不尔。彼由何力而得不生。譬喻论师所执种子。前于思择得有无中。已拔其根片无遗漏。此种今者从何复生。设种非无。此随眠等。若由缘阙。后不更生。或由择力。灭彼种故。令不更生。此二何别。又不生法。犹如过去。必不更生。复何须断。种虽未断。而所生法。必不更生。犹如已断。勤修断道。应成无用。岂不汝宗亦于已得非择灭法更勤方便修能断道断彼得耶。我宗可然。由说通断三世惑苦别证涅槃诸不生法。犹如过去。得障涅槃。故复须断。汝宗不尔唯说随眠及苦不生。为涅槃故。种虽未灭。有如已灭。毕竟不生。如是不生。即涅槃体。与后何异委细推究。未见有殊。是故我宗。说择灭体。通断三世惑苦故得。说非择灭。唯于未来。诸行阙缘不生故得。由斯二灭相无杂乱。又彼所说。违背契经。经言五根若修若习若多修习。能令过去未来现在众苦永断。此永断体。即是涅槃。唯于未来。有不生义。非于过现。岂不相违。虽有此文。而不违义。此经意说。缘过现苦烦恼断故。名众苦断。如世尊言。汝等于色应断贪欲。贪欲断时。便名色断及色遍智。及至广说。过现苦断。义亦应然。或此经中。别有意趣。过去烦恼。谓过去生所起烦恼现在烦恼。谓现在生所起烦恼。如是二世所起烦恼。为生未来诸烦恼故。于现相续。引起种子。此种断故。彼亦名断。如异熟尽时亦说名业尽。未来众苦。及诸烦恼。由无种故。毕竟不生。说名为断。若异此者。过去现在。何缘须断。非于已灭及正灭时。须设劬劳为令其灭。如是一切。但有虚言。且破彼初所释经义。谓无漏道断烦恼时。无有能缘过现烦恼。可断彼故。而经说言。修习五根。断过现苦。然彼烦恼。当于尔时。为在未来。为在现在。定不可执在于过去。已灭无故。岂复须断。若在未来。彼执无故。与空花等。何有所缘。若在现在。便有二心。俱行过故。亦不应理。若谓有种。种已不成。设复许成。亦不应理。非心心所体无所缘。如何可言缘过现苦。不应计彼是无漏心。以无漏心非烦恼故。又非所断。如何可执由断彼故。亦说能缘过现二世诸烦恼断。今恣汝说此位断何能缘过去现在烦恼。故汝所言。都无实义。又缘离世所起烦恼。修习五根。应不能断。所以者何。经不说故。汝执经说断过现言。说断能缘过现烦恼。断未来言。亦应尔故。岂不经说。修习五根。断未来苦。苦言总故。亦摄能缘。离世烦恼。此岂如彼空花者。经无所依凭。随欲而释。世尊总说。修习五根能断去来现在众苦。何缘执此断过现言。说断能缘过现烦恼。即执此说断未来言是断未来众苦体义。汝必应释断未来言。唯断能缘未来烦恼。则缘离世所起烦恼。修习五根。应不能断。若汝定释断未来言。是断未来众苦体故。亦摄能缘离世烦恼。则应未来苦言总故。亦摄能缘过现烦恼。若尔契经不应别说。能断过去现在众苦。由如是理证立此经。断过现言。唯断苦体。故知择灭。通断三世众苦而证。非唯未来随眠及苦不生为体。又所引证。亦不相应。缘过现苦烦恼断故名众苦断。理不成故。言断贪欲名色等断。理亦不成。过同前故。如何名断。汝自应思。又色等蕴。非唯贪欲断故名断。由色等蕴亦恚慢等所缘境故。受想行识。亦与贪欲俱时断故。由此不应定说色等唯据能缘断故名断。如是亦应释断过现言非但据能缘烦恼断说。故彼引证。符顺此宗。于彼所宗。理非符顺。由斯亦破彼后释经以种子言。都无实义。依之说断。义岂得成。所引喻言。亦非同法。业望异熟。有别体故。非离烦恼有种义成。如何可言断彼种故名断过去现在众苦。故彼无义。但构虚言。又说不生为涅槃体。极为非理。无常过故。阿毗达磨说。诸圣者断烦恼已。有可退生。其理坚牢。后当广辩。故彼所说。非智所欣。又未来无。彼宗所许。如何可执无而复无先有后无世极成故。又彼论者。所执涅槃唯是不生。如何名得。由得对治。证得当起烦恼后有毕竟相违所依身故。名得涅槃。若尔才得初念圣道应得所治烦恼涅槃。当于尔时。已得此道所治当起烦恼。后有毕竟相违所依身故。如是安住。后学道时。应成无学。已得此道所治相违所依身故。安住此等无间道时。何所未证。求解脱道。已得涅槃。进修何用。无斯过失。初念圣道与烦恼种。俱时灭故。如汝所宗。诸烦恼得。非未永灭烦恼种时。名得当起烦恼后有毕竟相违所依身故。又非无间道未生时已能永灭诸烦恼种。故于安住。后学道时。无有已成无学道失若尔无学。应有烦恼。所以者何。初念圣道。既与烦恼种不相违。后亦应然。无差别故。然得非喻。许体别故。后时圣道差别生故。谓我许得别有实体。不违于忍与智相违。所以者何。智与烦恼得相违得俱时生故。汝宗唯说。烦恼所依相续转变。名烦恼种。及说烦恼毕竟不生。名为涅槃。有何法体。不违何法。与何相违。又初圣道。将欲生时。是异生身。将欲灭位。初圣道起。舍异生身。离彼有何别烦恼种。与初圣道。说不相违。次后便违无差别道。故汝宗义非为善立。又若涅槃都无体者。如何经说。一切有为无为法中。此最第一。如何无体。可立法名。如何说无于无中胜。现见诸法有自相者。展转相望。说有胜劣。未见有说兔角空花展转相望安立胜劣。是故决定别有涅槃。能持自相。故名为法。此于余法。其体殊胜。故涅槃体。实有义成。又佛世尊。定说为有。如契经说。苾刍当知。定有无生。此若无者。生死众苦。应无尽期。由有无生。乃至广说。我亦不说全无涅槃。但应如我所说而有。如说此声有先非有有后非有。不可非有说为有故。有义得成。说有无为。应知亦尔。有虽非有。而可称叹。故诸灾横毕竟非有。名为涅槃。此于一切有非有中。最为殊胜。为令所化深生欣乐。故应称叹此为第一。非如是说涅槃为有有义得成。所以者何。假实二有。不相应故。余种类有曾无说故。虽说此声有先非有有后非有。而应审决。为于毕竟非有物上说此有言。为此有言即于有上遮余而立。若别有物。居声先后可遮声故。说非有言。谓彼物中。此声非有。诸互非有。定依有说。若于毕竟非有物中而说有言。何不违理。非汝有物名为涅槃。可于其中遮苦有故。即说彼物。名为非有。故所立喻。于证无能。又不应引世俗言说。非拨胜义。朋援己宗。经主此中。亦不随喜。如是有义以作是说不可非有有义得成。世俗有言尚不随喜。如何可说无为有言。是故有言定应不可。依于毕竟非有而说。然彼毕竟非有涅槃。非假非实。更无余有。而许为有。彼譬喻师。立有法性。何极深隐。又曾无处见非有中有胜有劣。亦无智者。于非有中。有赞有毁。然作是说。有虽非有。而可称叹。此但有言如何复言。故诸灾横毕竟非有。名为涅槃。有非有中。此最为胜。谓唯灾横有体法中。见有胜劣。非于无体故彼所言。唯依妄执。岂不有法有差别故非有随之亦有差别。如色声等。非有各异。此亦不然。非有与有。相同相别。俱不成故。谓此非有有差别者。为由与有其相同故。为由与有其相别故。若由相同。应即是有。若由相别。应为指陈色之非有。何相非色。岂不非有即为此相。若尔色声非有相何别。而言色等非有各异耶。如色与声。虽同是有。而有种种相状差别。非有不然。无异体故。由此所说。有虽非有。而可称叹。乃至广说。但有虚言而无实义。故唯于有胜劣可成。于非有中。定无胜劣。世尊既说。离染涅槃。于诸法中。最为殊胜。应如色等实有义成。又若涅槃体非有者。岂令所化生厌生欣。非有中无胜劣相故。又应大圣惑所化生。于非有中如有说故。又若起见拨无涅槃。应成正见无倒解故。若谓此见不了涅槃。唯是行无故是邪者是则断见。应成正见。由彼唯缘诸行无故。若谓此见于唯行无非方便解故非正者。非于行无非方便见名为断见是余见故。然诸断见。唯缘行无。故不能遮成正见失。又于灭境。起静等见。应非正见。非实解故。非非有中有静不静如石女儿非勇非怯。现见病无别有调适。诸苦恼无别有安乐。如是亦应有为差别。非有之位别有无为。又若涅槃无实体者。如何可是圣谛所收。无体岂应名谛名妄。且言圣谛。其义云何。岂不此言属无倒义。圣见有无皆无颠倒。谓圣于苦见唯是苦。于苦非有见唯非有。此于圣谛义有何违。此有违者谓无境界。慧必不生。而言圣慧见非有境。何倒过此。思去来中当辩此义。如何毕竟绝名言无。而可说言。此是苦灭。而不违理。现见此彼指当名言。唯于有起。如何非有起此名言。又无如何成第三谛。此中经主。轻掉答言。第二无间圣见及说。故成第三。此答非理。今难者意。以若无境慧必不生。如何见无为第三谛。又若无体。但有虚言。何义说为第三圣谛。又若苦灭。唯是苦无。是则但应说苦治道。说道便显所治苦无。若不令无何名能治本依治道为令苦无故彼苦无说治便显。何离苦道别说苦灭。故若涅槃离于苦道。无别有体。但有虚言。何用说为第三圣谛。又汝应说。于立涅槃为实有宗。见何过失。而不信受。然许涅槃实有别物。于佛圣教所有义利。片无违失。虽彼所言若许实有朋虚妄计是名为失。然不应理。计毕竟无。亦名为有是虚妄故。又彼更有余虚妄计。谓未来法。无而复无。计为涅槃。过如前说。又彼计有烦恼种子于色等法非即非离。虽如斤斧补特伽罗而有能生障道等用。如是等类。非有执有。虚妄计度。汝常串习。为己所宗。何反弹斥。虽寄他言作如是说。许便拥护毗婆沙宗。今详经主似总厌背毗婆沙宗。欲依空花拨一切法皆无自性。而今于此且拨涅槃。拟为同喻证余非有。若实为护毗婆沙宗所说。不应朋坏法论。勿以彼论恶见之垢尘秽己心。宜将此宗正法之水而自沐浴。又言涅槃非体可得。如色受等非用可得如眼耳等。此实应然。涅槃实非如色受等及眼耳等体用可得。然有异彼体用可知。色等有为依自相续。体用粗显。易可了知。然彼涅槃。不依相续。体用微隐难可了知。要具精勤胜观行者。修所成慧正现前时。方证涅槃真实体用。从观出已。唱如是言。奇哉涅槃。灭静妙离非诸盲者不了青黄谓明眼人亦不见色或复纵汝知与不知。但许涅槃可名为有。则应定许体实非无。离有实物有不成故。又相即体。涅槃既有灭静等相。有体义成。又彼所言。灭若别有如何可立彼事之灭。第六转声。由灭与事非互相属。此彼相望非因果故。唯遮彼事。第六可成。彼事之无。名为灭故。彼言非理。相属非唯在因果故。又亦非唯无别体故。如何安立彼事之灭。应知二灭属于二心。二心能遮彼事得故且得择灭。要由二道。初无间道。与烦恼得俱时而灭。后解脱道。与择灭得俱时而生非烦恼得未已灭时。其离系得至已生位。如是彼彼烦恼得灭。便有此此择灭得生。故说此此灭属于彼彼事。于契经中。此义已显。经言具寿。言灭灭者。由谁灭故。而得言灭。由五取蕴灭故言灭。若无别灭。经但应言是谁之灭谓五取蕴。何义说言由五取蕴灭故言灭。应知烦恼得若灭时。名烦恼灭。我终不许即众苦灭名为涅槃许苦灭故。离于苦道。别得择灭。方名涅槃。灭若别无。有前说过。谓阿罗汉。应有烦恼。或住学道。烦恼已无。以于后时无差别故。此中经主。复作是言。何因此灭定属此得。岂非难尽矫设浮词。一相同品。离系与得。设无定因。斯亦何咎。由一道力。总灭诸结。总得离系。何用定因。或能所得。相属法尔。或能断道。为此定因。由道引生离系得故。非余断道所断惑灭由余道得。故汝应喜。同一断道所得择灭。其体非一有何定因。言此属贪此属嗔等。设无定属。复有何过。谓一品中一切所灭。一道所断所得离系。既同一得。何用定因。或如先说。先何所说。谓由法尔相属无乱。以从本来贪等与灭法尔相属。决定无乱。断道起位能总证得。故无定因。亦无有过。若谓不然。违圣教故谓有圣教。能显涅槃。唯以非有为其自性。故契经言。所有众苦。皆无余断。各别舍弃尽离染灭静息永没。余苦不续。不取不生。此极寂静。此极美妙。谓舍诸依及一切爱。尽离染灭。名为涅槃。又许涅槃体唯非有便为善释。经说喻言。如灯焰涅槃心解脱亦尔。彼谓此说如灯涅槃。唯灯焰谢无别有物。如是世尊。心得解脱。唯诸蕴灭。更无所有。对法诸师。已通此说。谓言苦灭。义有二途。一离苦外无别实体。二离苦外有别实体。佛观所化意乐不同。故说如斯二种灭义。谓或有处说无别体。如向所引二种契经或复有处说有别体。如契经说。定有无生。又契经言。有处有离。复有经说我观实有无为句义。所谓涅槃。复有经言。由五取蕴灭故言灭。此类寔繁。故我所宗。不违圣教。又经所说灯焰涅槃。离灯别有无常相故。此之所喻。于义何违或灯涅槃。虽无别体。而非非有。诸行皆是无常性故。其体非无。依此为言。亦无有过。又非由此所引契经能证涅槃体唯非有。此经唯就入无余依般涅槃时。而宣说故。谓于此位。一切余依。皆无余断。各别舍弃。乃至广说。故不相违。有余师说言不生者。依此无生。故言不生。此中经主。作如是说。我等见此第七转声。于证灭有都无功力。何意故说依此无生。若依此言。属已有义。应本不生涅槃常故。若依此言。属已得义。是则应计依道之得。故唯依道。或依道得。令苦不生。汝应信受。我等见此第七转声。于证灭有。甚有功力。道之与得。俱依灭故。以有涅槃。方求道得。此若非有。求彼何为。又苦不生。非唯由道。或复由得增上忍时。已得殊胜苦不生故。又缘阙故。苦亦不生。应是涅槃。如前已说。若谓种子未灭故者。已如前破。前如何破。种虽未灭。有如已灭。毕竟不生。与后何异。又若由道。或复由得。苦不生者。初念道时。已无惑苦。过如前说。则住学道。烦恼应无。若烦恼种未灭故者。治道生时。种何不灭正相违故。如闇与明。又于涅槃。得正生位。所治惑苦。方名永灭故彼师说。依此无生。故言不生。第七转声。于证灭有。甚有功力。若谓若然。修无间道。应无用者。理亦不然。涅槃正是此道果故若初刹那所治惑苦。已名永灭。是何道果故解脱道。无离系果。由与灭得俱时生故。如是已破经主谤因。成立涅槃其体实有。有余师说。无实涅槃。非因果故。如兔角等。诸实有者。因果为证。涅槃既非因果性摄。故定无有能证有因。是故涅槃定非实有。彼言非理。前已成立。虚空无为。其体实有。非因果性。此亦应然。又但有言。彼宗许有是因果性。非实有故。谓执涅槃非有论者。许未来是果过去是因而非许去来是实有性。故因果性非证有因。若许去来是实有者。许涅槃体是果是因。由许涅槃是沙门果。故与正生法为无障因故。修正行者。为办涅槃果名所办。所办是果。或应说办非果者何。何有体常而是因果。此不应责。且应自责。何有果因。而体实有。如一念起离同类因。彼一切处。无同喻理。有余师言。涅槃虽有。而假非实。此亦不然。假所依体。不可得故。若谓诸行即是涅槃假所依者。亦不应理。应成所断染污有漏无常性故。非离所依有假择灭可执。虽以所断染污有漏无常为其所依。而非所断。不染无漏常住为性。又相违故。应非用彼为此所依。如明与闇。曾无假法违自所依。又许涅槃是诸行灭。如何可说诸行为依未见有明闇为依故。又行有时灭未有故。未离欲者。有贪等时。不应许彼有贪等灭。贪等无位。方证涅槃。故彼所说。非顺正理。有余复言。智必有境。涅槃无实。彼作是言。缘涅槃慧。以名为境。理必不然。邪正二见。应相成故。谓若正见觉了涅槃。寂静常住。应成见取。以一切名皆无常故。若诸邪见。诽谤涅槃为无常性。应成正见。以称实义。而生解故。诸说涅槃无体论者。终不许说名即是无。诸说涅槃有体论者。终不许说名即涅槃。故彼所言亦违正理。又上座说。如世尊言。如是句义。甚为难见。谓一切依。皆永弃舍。寂静美妙。乃至涅槃。如是涅槃。如何难见。以其自性极难见故。如何非有可说自性。自执涅槃非实有故。若谓择灭。虽非实有。而萨迦耶是实有故。离彼得灭名为自性。故契经言。如是灭界。缘萨迦耶。而得显了。此违正理。所执灭界。与萨迦耶。非即非离。如何可言灭有自性。若有自性。如何复言灭非实有。既许涅槃非实有故。即无自性。何用诳惑信无智人。书此前后相违言论。又经唯说。如是灭界。缘萨迦耶。而得显了。如何定知灭非实有。唯萨迦耶。是实有物。然说缘他而显了者。皆实有物。世所极成。如缘闇等明等显了。缘实有物非实显了曾无有处。是所极成。故萨迦耶是实有物。谓灭非实。但是虚言。缘萨迦耶。灭显了者说因彼灭建立此故。由五取蕴灭故言灭。余契经中。分明说故。又彼所说虽诸经中有说。三界三涅槃界。有为界无为界。有灭界有生有无生。有苦灭圣谛我现了知。是安隐处。诸如是等。亦不相违。缘萨迦耶而建立故。此亦率尔。作如是说。纵三界等。缘萨迦耶。而得建立既无因证。如何定知体非实有。又言缘彼此显了故。是实有物。便为极成无体无容由他显了。如明等显缘闇等故。又彼所言。契经中说。有灭界者。亦不相违。缘离有身。而显示故。有无生者。亦不相违。于实有生。不转立故。即是有生相续断义。此亦非理如上所言。缘他显者。是实有故。生与无生。体各异故。非有不应说为有故。假实有外更无别有。若执无生非假实有不应名有。如前已说。生相续断。义有二种。谓离有身无别有别。准前苦灭二义应知。如何定言唯生不转名相续断。非别有物。许有别物。有无生言。可成有义。若无别物。不应名有。说过如前。又薄伽梵。于契经中。但应说言。有生不转。不应说此有无生言。世尊不应于胜义谛作迷谬说。有实无实。俱说有故。是迷谬言。为生如无生说为有故。其体非实。为无生如生说为有故。其体是实。令生如是迷谬心故。又相续断道未生无。道生已有道退复无。以诸圣人退生惑故。则相续断。应非无为。又说。涅槃非实有故。即无生者。理亦不然。唯有立宗。无证因故。谓何因证非实有故。涅槃无生非此无生。由常住故。而体实有。又许非实证无生故。则诸假法。应无有生。又应假法亦即无生。若尔汝宗刹那实法。不许生故。相续是假。亦无生故。是则汝曹。生之与灭。都非实有。何期汝等尝厌空花。而今乃成空花差别。又彼所说。如契经言。一切法者。谓十二处又契经言。此十二处。皆有戏论。皆是无常。契经复言。眼色眼识。广说乃至。意法意识皆是无常。若谓涅槃实而常住。世尊于此应有简别。如是所说。非审思求。如言皆是有热恼故。谓彼经言。此十二处。皆有戏论皆是无常。皆有热恼。非诸圣道体非处摄。又彼定无贪等热恼。何不简别。然彼契经。唯依有漏十二处体。密意说言此十二处。皆有热恼。即就此说。皆有戏论。皆是无常。不应由斯谤涅槃体言非实有。是故定应离苦集道有涅槃体。常实义成。今应思择非择灭体。此中经主所辩相言。离简择力。由阙缘故。余不更生。名非择灭。如残众同分中夭者余蕴。且应诘彼。何名阙缘。谓法生缘。若不和合。非不和合。少有法体。何能为障。令法不生。岂不阙缘名缘不具。此有何法。过亦同前。若谓阙缘即缘非有。亦不应理。非有不能障有生故。由此决定。非唯阙缘名非择灭。然别有法。得由阙缘。此有胜能障可生法。令永不起。名非择灭。若无别法能为障碍。但由阙缘法不生者。后遇彼类缘和合时。前不生法。今应还起。岂不如许有非择灭得由阙缘。非遇彼类缘和合时舍非择灭。如是唯许由阙缘故诸法不生。非遇彼类缘和合时彼法还起。所例非等。有无异故。谓由阙缘得非择灭。障可生法。令永不生。乃至涅槃得定相续。设遇彼类缘和合时。亦无有能舍先所得。夫缘阙者。但是缘无。无法无能与有为障。后遇彼类缘和合时。何法能遮令不还起。然法若住不生法中。此法必无还生之理。是故定有能永障缘。非唯阙缘令永不起岂不缘起道理法然。依此无彼无。此灭故彼灭。计非择灭。则为唐捐。此所说言。有何意趣。表唯缘阙故法不生。此中不见决定言说。如何得知。唯缘阙故。既不说有余不生因。故知不生。唯由缘阙。此中不说余不生因。以彼但由缘阙得故。非择灭得。为即用此缘阙为因。不尔非有无有功能为有因故。于缘阙位。随所住心。得非择灭。如是灭得即因彼心。非因缘阙。又准所说缘起道理。即定证知。有非择灭。受灭故爱灭。缘起经说故。此云何证非择灭有。如是灭言非余灭故。且彼不可是无常灭。见受灭时有爱生故。非爱未至已生位时。可为无常灭相所灭。又彼不可说为择灭。言由爱断受得断故。如世尊言。汝等于受应断贪欲。贪欲断故。此受便断。此经中辩受爱择灭。意显受爱断必俱时。缘起经中。说次第灭非次第灭。诸缘起支。可名择灭同对治故。由此准知。离无常灭及择灭外。有非择灭。由爱生缘阙故而得。依此密说言受灭故爱灭。又经说有二阿罗汉。由此准知有非择灭。如契经说。诸阿罗汉。略有二种。所谓退法及不退法。诸阿罗汉。一切烦恼皆断无余。而无生智有得不得。由此准知。必有别法。若有得者。烦恼便住不生法中。得无生智。此法即是非择灭体。若不得者。烦恼可生。便有退失无无生智。根殊胜故。烦恼不生。何用计斯非择灭体。依何义说根殊胜名。若此但依无生智说。彼意即说得无生智殊胜根故。烦恼不生。此复应思。诸阿罗汉。皆烦恼断。何缘于此殊胜智根有得不得。若过退法。名殊胜根。亦不应理。得此根者。亦有退生烦恼义故。谓退法性。转得胜根。乃至堪达。犹有遇缘退住学位。起诸烦恼若得胜根烦恼不起。转退法性。得思法根。应不复生一切烦恼。然不如是。由此故知。有阿罗汉。以诸烦恼生缘阙故。得非择灭。由此势力。能遮烦恼。令永不生。得无生智。若有退义。一切可然。而退不成。故皆不尔。退义必有。后当思择。又于施设。第一法中。诸言显有多无为故。证无为中有非择灭。足前二种。方可成多。除此更无余无为故。又灭与尽。名别体同。经说预流尽三恶趣。故知有别非择灭体。此尽定非余灭摄故。谓契经中。说预流者已尽地狱已尽傍生已尽饿鬼。乃至广说。非彼已能断诸恶趣。由彼未离欲界贪故。而诸恶趣。要于究竟离欲贪时。方得名断。有说。预流缘诸恶趣烦恼可生。故未名断。此因非诸有断所缘能缘烦恼犹可生故。亦非尽言显无常灭。以所尽者皆未生故。由此证知。定有别法。名非择灭。得此法故。令诸恶趣毕竟不生。若执但由阙生缘故彼不生者。过如前说。然上座说。非择灭名。诸圣教中。曾无说处。但邪分别。横计为有非圣说故。不可信依。此亦不然。圣所说故。且彼所执旧随界等。如喑哑人于梦所说。都无所用。但为诱引信无智人令生欣乐。谁有贤圣说如是言。何圣教中。有片可得。是故上座。勿以己宗准度他宗亦非圣说。岂不彼彼诸圣教中。离择无常二种灭外。处处说有灭尽等声。上座于中。何容不忍。对法者说。有用五字以于未来亦得择灭。为欲简彼令易了知。故本论中。加非择字。论者意说。世尊所言。非择为先。于未来世。由阙缘故。得永不生。应知此即非择灭体。何容谓此非圣所言。复有余师。谓非择灭由余故得。不以阙缘。根境为缘。诸识得起。一根与意。专一境时。余识生缘。根境虽具。而于彼彼识不得生。此岂生缘根境有阙。然具根境。识不俱生。故知但由得非择灭。若谓由阙第二等无间缘故。此第二等无间缘。由何故阙。岂不诸识不并生故。阙于第二等无间缘。复以何缘。识不并起。以有过故。必不可说诸识并生。若说并生便有染净俱生等过。要先并生斯过方可有。岂先有过。为不并生因。然识不并生。故无斯过。得非择灭故。识不并生。如是所言。皆不应理。若得非择灭。不由阙缘。得非择灭已应还可退。虽复诸识不可并生。而容后时次第生故。若依五识。说如是言。由所缘境已灭谢故。能灭诸识永不生者。是则同前。由阙缘故。得非择灭。令永不生。由此应知。前说为善。故非择灭实有义成。然本论中。说无为法名无事者。是无因义。所以者何。事有五种。一自性事。如有处言。若已得此事。彼成就此事。二所缘事。如有处言。一切法智所知随其事。三所系事。如有处言。若于此事爱结所系。彼于此事恚结系耶。四所因事。如有处言。有事法云何。谓诸有为法。五所摄事。如有处言。田事宅事妻子等事。故本论中。依第四说无为无事。不依最初自性事说无为无事

说一切有部顺正理论卷第十七阿毗达磨顺正理论卷第十八

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩差别品第二之十

因离系果。傍论已周。本所明今当说。于当所辩异熟等流离系士用及增上果。如是五果。对前六因。当言何果何因所得。颂曰

  后因果异熟　　前因增上果
  同类遍等流　　俱相应士用

论曰。于五果中。第三离系。非生因得。故此不论且辩六因。得余四果。言后因者。谓异熟因。于因颂中。最后说故。初异熟果。此因所得。有言异熟从异熟生。故此不应名无异熟。彼言非理。同类异熟二因所生。义各别故。谓前异熟。为同类因生后异熟。为等流果。即后异熟。由先业成。能成诸业。名异熟因。所成异熟。即异熟果。二因体异。二果义分。因果类殊。无相杂过。然异熟体。如熟饮食。于生异熟。无胜功能。故唯不善。及善有漏。是异熟因。名有异熟。言前因者。谓能作因。于因颂中。最初说故。后增上果。此因所得。增上之果。名增上果。唯无障住。有何增上。岂不即由无障住故说为增上。何劳征诘。又先已辩。能作因中。说能作因亦有胜力。谓眼识等。于正生时。耳等展转。有增上力。闻已便生欣见欲故。于器世界诸物生时。诸有情业。有增上力。诸可爱果。于不善业。不可爱果。于诸善业。亦有展转增上生用此等增上。如应当思。同类遍行。得等流果。果似因故。名为等流。如是二因。果相相似。故因虽二。其果唯一。俱有相应。得士用果。非越士体有别士用。即此所得。名士用果。此士用名。为目何法。即目诸法所有功能。如是冥符后颂文说。若因彼力生。是果名士用。然经主谓此士用名即目诸法所有作用。是则彼应作如是说。同牵一果。故名士用。若尔唯应无间隔越有士用果。俱生中无。非俱生中可有一切皆共同得一士用果。自体不因自力生故。亦不可说各别牵果。勿俱有因非一果故。此中士用士力士能士之势分。义皆无别。诸法功能。如士用故。名为士用如勇健人。似师子故。名为师子。岂不同类遍行二因无间所生亦士用果。然等流果。二因无间所生诸法。或是或非。一切决定。名士用果。何故但说俱有相应得士用果。非同类遍行。唯此二因。具足能得俱生无间二士用果。非前二因。是故不说。成等流果唯似自因。同类遍行果唯相似。故彼二果。唯名等流。余非等流。非二因得。又士用果。俱者义强。俱有相应。独能获得俱士用果。是故偏说。又同类因。虽亦能得所生无间诸士用果。而非一切皆能定得。以阿罗汉最后诸蕴无无间生士用果故。俱有相应二因。决定得士用果。是故偏说。有余师言。能作因等。亦有能得士用果义非异熟因。俱生无间二士用果。此所无故。有余师说此异熟因。亦有隔越远士用果。譬如农夫所收果实。已辩因果相对决定。今当正辩果相差别。异熟等果。其相云何。颂曰

  异熟无记法　　有情有记生
  等流似自因　　离系由慧尽
  若因彼力生　　是果名士用
  除前有为法　　有为增上果

论曰。唯于无覆无记法中。有异熟果。若尔则应非有情数亦是异熟。为欲简彼说有情言。唯于有情。有异熟故。若尔于彼有情数中。长养等流。应是异熟。又为简彼。说有记生。一切不善。及善有漏。能记异熟。故名有记。从彼后时。异熟方起。非俱无间名有记生。如是名为异熟果相。岂不异熟亦以前位异熟果体为同类因。是前异熟等流果故。则应亦说从无记生。是等流性。如何乃说从有记生。非等流性。无如是失。异熟果体。由同类因。相有杂乱。由异熟因。相无杂乱。是故但说从有记生由此准知。非等流性以等流果与因相似有杂乱故若异熟果。与因相殊。无杂乱故。非有情数亦从业生。何故不说为异熟果。此不应难。唯不共业所得之果。名异熟故。何故非情。非唯不共业所得果。以非情法余可于中共受用故。岂不大梵所住非情是别业果。亦应说彼名业异熟。何乃言非。有作是言。大梵住处。一切大梵业增上生。有余复言。大梵住处。相续未坏。余可于中有受用理。故非不共。如何一物。无量有情业所共感。岂不已说。余可于中共受用故。若非情果不共业招。应随异熟俱时起尽。又世现见国主崩时。所王国土。犹相续住。若所王国唯主业招。非余有情业共感者。余应不可于中受用。又若非情别业所感。则应一一诸有情身所居室宅园林池沼城郭山川悉皆各异而实不尔。故知一物无量有情业所共感。岂不业体有种种故应不能招无种种果云何可说无量有情多业同招非情一物。无如是失。譬如芽等。观自类因。而成一故。谓如芽等。虽因地水时分人功粪等力起。而观自类因故成一。非观地等因故成多。如是非情。观自因故。体成一物。非由观彼无量业故其体成多。又见世间。非种种业生种种果。如何不许种种业生非种种果。业于所感非情果中。有何因用。业于彼果。为能作因。如前已辩。如是已辩异熟果相等流果相今次当辩。似自因法。名等流果。谓似同类遍行二因。如同类因。善染无记。彼等流果。其相亦然。如遍行因。唯是染污彼等流果。其相亦尔。岂不俱起士用果性亦似自因。如何可言似自因法名等流果。无等流果不似自因。有士用果与自因异。故似自因名等流果。定无滥彼士用果失。岂不亦有等流果因。如遍行因。在于异部。用异部法。为等流果。他部等流。自部因性。染污同故。非不相似。其士用果性亦有殊。是故与因非定相似。有余师释。似自因言。谓果与因。具二相似。一者体类。二者性类。言体类者。谓受想等。言性类者。谓善染等。若于俱起士用果中。性类虽同。体必有异。受非受等士用果故。若于后起士用果中。体类性类。皆容有异。故不可说果定似因。若等流果。性必似因。于中亦有体似因者。唯等流果。定似自因。故似因言。无相滥失。若遍行因。亦得等流果。何不许此即名同类因于自部果。实即同类因。若望余部。唯遍非同类。然非遍法。随其性类。各望自部。唯同类因。若诸遍法。望于他部。同染污类。唯遍行因。此望自部。具二因义。故遍行因。虽得等流果。而不可许即名同类因。如是已辩等流果相。离系果相。今次当辩。由慧尽法。名离系果。灭故名尽。择故名慧。即说择灭。名离系果。由择为因。离诸系缚。证此灭故。说名为果。如是已辩离系果相。士用果相。今次当辩。若法因彼势力所生。即说此法。名士用果。此有四种。俱生无间隔越不生。如前已说。言俱生者。谓同一时。更互为因力所生起。言无间者。谓次后时。由前念因力所生起。如世第一法生苦法智忍。言隔越者。谓隔远时。展转为因力所生起。如农夫等于谷麦等。言不生者。所谓涅槃。由无间道力所得故。此既不生。如何可说彼力生故名士用果。现见于得亦说生名。如说我财生是我得财义。若无间道。断诸随眠。所证择灭。如是择灭。名离系果及士用果。若无间道。不断随眠重证本时所证择灭。如是择灭。非离系果。唯士用果。谓全未离欲界贪者。入见道时。苦法智忍。断十随眠。所证择灭。如是择灭。名离系果及士用果。若全已离欲界贪者。入见道时。苦法智忍。不断随眠证本择灭。如是择灭。非离系果。先离系故。是士用果。由此忍力。更起余得。而重证故。若分已离欲界贪者。入见道时。苦法智忍。于十随眠。有断不断。所证择灭。有新有本。如其次第。二果一果。如是乃至道法智忍。若全未离已离分离欲界贪者。于八随眠。全断不断。分断不断。所证择灭。有新有本。及有新本。如其次第。二果一果。二果一果。义如前释。若全未离色无色贪。入见道时。苦类智忍。断色无色十八随眠。所证择灭。如是择灭。名离系果及士用果。若分已离色无色贪。入见道时。苦类智忍。于色无色十八随眠。有断不断。所证择灭。有新有本。如其次第。二果一果。如是乃至道类智忍。若全未离。及分已离色无色贪。于色无色十四随眠。亦有全断分断不断。所证择灭。有新有本。如其次第。亦有二果二果一果。义如前释。于修道中。诸无间道。各随其义。如例应思。如是已辩离系果相。增上果相。今次当辩。诸有为法。除在前生。是余有为之增上果。必无少果在因前生。果在因前。斯有何咎。若未来法。其果已生。是则未来。所作已办。以无用故。应不更生。非本不生。而可有灭。无生灭故。诸行应常。若谓此应如不生法。虽无生灭。而体非常。此救不然。见彼种类。有生灭故。例不生法。可是无常。若行本来都无生灭。例何可说其体非常。故不成救。士用增上二果差别。云何应知。对作受者。有差别故。应知差别士用果名。唯对作者。增上果名。兼对受者。如谷麦等对诸农夫名士用果。彼力生故。亦增上果。彼受用故。对唯受者。唯增上果。非彼力生。彼受用故。工匠所成。对诸工匠。及对非匠。二果一果。准上应知。余例皆尔。于上所说六种因中。何位何因取果与果。颂曰

  五取果唯现　　二与果亦然
  过现与二因　　一与唯过去

论曰。五因取果。唯于现在。定非过去。彼已取故。亦非未来。彼无用故。言取果者。是能引义。谓引未来令其生等。于同体类。能为种子。于异体类。由同一果。于非一果。由同性类。于异性类。而由有是自聚相续。是故一切皆名能引。如是能引名为取果。此取果用。唯现在有。非于去来。唯此可名有为作用。于六因内简去何因。而言五因。唯现取果。谓六因内。除能作因。此能作因何缘被简。有余师说。此能作因。取果与果时无决定。故取与中。俱不分别。彼说非理。所以者何。此因取果。无非现在。又非不取而有与义。如何乃言时无决定。然能作因。能取果者。定唯现在。与通过现。应如同类。遍行二因。但非一切有增上果。可取或与。故此不说。岂不此因能取果用亦通过去。如何乃言能取果者。定唯现在。故本论中作如是说。过去诸法。为等无间。能生二心。若出无想灭尽定心。由入定心。现在取者。则应二定永不现前。又非不取而有与义。故应取果亦通过去。无如是事。入二定心。唯现在时。能取二定及出心果。然由二定是正所求。必应先起。由此为障。令出定心非于入心无间即起。此义于后当更分别。故上所言。此因取果。无非现在。又非不取而有与义。其理极成。然毗婆沙。有如是说。其能作因。取果与果。俱通过现。理不应然。法居现在。亦如同类遍行二因。总取未来为自果故。俱有相应与果亦尔。唯于现在。由此二因取果与果必俱时故。同类遍行二因与果。通于过现能作因中诸有果者。应同此说。然非一切皆容有果。故此不论同类遍行二因与果。过去可然。现在如何与等流果。有等流果无间生故。谓此二因。有等流果无间生者。即现在时。于无间果。亦取亦与。此果已生。因谢过去。名已取与。若此二因。灭至过去。其等流果。方至生时。则此二因。于正生果。先取今与。言与果者。谓此诸因。正与彼力。令其生等。其能作因。正居现在。彼增上果。有现已生。如眼根等。为能作因。生眼识等。诸增上果。有无间生。如世第一法等为能作因生苦法智忍等。诸增上果。有隔越生。如顺解脱分善根等为能作因生三乘菩提尽智等诸增上果。善同类因。有时取果而非与果。应作四句。第一句者。谓断善根时。最后所舍得。第二句者。谓续善根时。最初所得得。经主于此谬作是言。应说尔时续者前得。今详彼说。理不应然。所以者何。非唯断位最后所舍得与今续时初得等流果。以于断位先已灭得亦与续时得等流故。如何前位多刹那得。为同类因。皆取今得。而于今时。但说最后一刹那得与今得果。是故应如本文为善。第三句者。谓不断善根。于所余诸位。第四句者。谓除前相。又于不善同类因中。亦有四句。第一句者。谓离欲贪时最后所舍得。第二句者。谓退离欲时。最初所得得。经主于此亦作是言。应说尔时退者前得。今详彼说。理亦不然。以有如前所说过故。第三句者。谓未离欲贪。于所余诸位。第四句者。谓除前相。有覆无记同类因中。亦有四句。于阿罗汉得时退时。未得及余。如理应说。无覆无记同类因中。有顺后句。谓与果时。必亦取果。无覆无记。为同类因。乃至涅槃。恒相续故。或时取果。而非与果。谓阿罗汉最后诸蕴。约有所缘刹那差别。善同类因。应作四句。第一句者。谓善心无间。起染无记心。第二句者。谓与上相违。第三句者。谓善心无间。还起善心。第四句者。谓除前相。不善心等。如其所应。亦有四句。例准应说。异熟与果。唯于过去。由异熟果无与因俱。或无间故。西方诸师。说果有九。前五果外。别立四果。一加行果。谓如无生智等。远为不净等果。二安立果。谓如水轮为风轮果。乃至草等为大地果。如是一切所安立法。当知皆为能安立果。三和合果。谓如芽等为时地水种子等果。及眼识等。为眼色明作意等果。四修习果。谓如化心等。为诸静虑果。如是四果。皆是士用增上果摄。由是故说。果唯有五。说因果已。复应思择。此中何法几因所生。应知此中法略有四。谓染污法。异熟生法。初无漏法。三所余法。余法者何。谓除异熟。余无记法。除初无漏。诸余善法。如是四法。颂曰

  染污异熟生　　余初圣如次
  除异熟遍二　　及同类余生
  此谓心心所　　余及除相应

论曰。诸染污法。除异熟因。余五因生。由异熟因所生诸法。非染污故。异熟生法。除遍行因。余五因生。由遍行因所生诸法唯染污故。三所余法。双除异熟遍行二因。余四因生。由所余法非异熟性故。及非染污故初无漏法。及除同类。及言为显亦除异熟遍行二因余三因生。由初无漏无有前生同类法故。及是善故。有余师言。此中应说诸染污法唯四因生所以者何。遍行因体。离同类因。无别性故。彼言非理。所以者何。若彼不说遍行因者。便为不说余部染因。若彼不说同类因者。便为不说非遍行法及遍行得诸染法因。然实贪等贪等为因。得由得因而得生起。故染污法。除异熟因。余五因生。此说应理。如是四法。为说何等。应知唯是心心所法。若尔所余不相应行。及色四法。复几因生。如心心所。所除因外及除相应。应知余法从四三二余因所生。谓染污色。不相应行。如心心所。除异熟因。及除相应。余四因生。异熟生色不相应行。如心心所。除遍行因。及除相应。余四因生。三所余色。不相应行。如心心所。双除异熟遍行二因。及除相应。余三因生。初无漏色。不相应行。如心心所。除前三因。及除相应。余二因生。一因生法。决定无有。今应思择。一切法中。何法能为几因自性。谓或有法。具足能为六因自性。次第乃至有法能为一因自性。此中有法。具足能为六因性者。谓诸过现不善遍行心心所法。有法能为五因性者。谓诸过现不善非遍心心所法。或无记遍心心所法。或善有漏心心所法。或不善遍不相应行。有法能为四因性者。谓诸过现不善色法。或善有漏色。心不相应行。或不善非遍心不相应行。或无记遍心不相应行。或无记非遍心心所法。或诸无漏心心所法。或诸未来不善善有漏心心所法。有法能为三因性者。谓诸过现无记色法。或无记非遍心不相应行。或无漏色心不相应行。或未来不善及善有漏色心不相应行。或无记无漏心心所法。有法能为二因性者。谓诸未来无记无漏色心不相应行。有法能为一因性者。谓无为法。无法非因。有法非果。所谓虚空及非择灭。复应思择。如是六因。自性相望。有纯有杂。且能作因。对俱有因。为顺后句。谓俱有因必杂能作。有纯能作非俱有因。谓无为法。又能作因对同类因。亦顺后句。谓同类因必杂能作。有纯能作非同类因。谓未来法。及无为法。又能作因对相应因。亦顺后句。谓相应因必杂能作。有纯能作非相应因。谓诸色法。不相应行。及无为法。又能作因对遍行因。亦顺后句。谓遍行因必杂能作。有纯能作非遍行因。谓未来法。过去现在非遍行法。及无为法。又能作因对异熟因。亦顺后句。谓异熟因必杂能作。有纯能作非异熟因。谓无记法。及无漏法。若俱有因对同类因。为顺后句。谓同类因。必杂俱有。有纯俱有非同类因。谓未来法。又俱有因对相应因。亦顺后句。谓相应因必杂俱有。有纯俱有非相应因。谓诸色法。不相应行。又俱有因对遍行因。亦顺后句。谓遍行因必杂俱有。有纯俱有非遍行因。谓未来法。过去现在非遍行法。又俱有因对异熟因。亦顺后句。谓异熟因必杂俱有。有纯俱有非异熟因。谓诸有为中无记无漏法。若同类因对相应因。应作四句。第一句者。谓过去现在色不相应行。第二句者。谓未来世心心所法。第三句者。谓过现世心心所法。第四句者。谓未来色不相应行。及无为法。又同类因对遍行因。为顺后句。谓遍行因必杂同类。有纯同类非遍行因。谓过现世非遍行法。又同类因对异熟因。应作四句。第一句者。谓过去现在无记无漏法。第二句者。谓未来不善及善有漏法。第三句者。谓过现不善及善有漏法。第四句者。谓未来世无记无漏。及无为法。若相应因对遍行因。应作四句。第一句者。谓未来世心心所法。过现非遍心心所法。第二句者。谓过去现在遍不相应行。第三句者。谓过去现在遍心心所法。第四句者。谓诸色法。未来一切不相应行。过现非遍不相应行。及无为法。又相应因对异熟因。亦作四句。第一句者。谓无记无漏心心所法。第二句者。谓不善善有漏色。不相应行。第三句者。谓不善善有漏心心所法。第四句者。谓无记无漏色。不相应行。及无为法。若遍行因对异熟因。应作四句。第一句者。谓过去现在无记遍行法。第二句者。谓未来不善及善有漏法。过现善有漏不善非遍行法。第三句者。谓过去现在不善遍行法。第四句者。谓未来世无记无漏法。过现无漏无记非遍行法。及无为法。又应思择。如是六因。色非色等。诸门差别。谓六因中相应遍行二因非色。余之四因。通色非色。有见无见。有对无对。应知亦尔。又六因中。唯相应因。但相应法。余通相应不相应法。有所依无所依。有发悟无发悟。有行相无行相。有所缘无所缘。应知亦尔。又六因中。遍行异熟二因唯有漏。余之四因。通有漏无漏。又六因中。能作一因。通有为无为。余之五因。一向是有为。又六因中。遍行一因唯是染。余之五因。通染及不染有罪无罪。黑白。有覆无覆。顺退不顺退。应知亦尔。又六因中。异熟一因。唯有异熟。余之五因。通有异熟及无异熟。又六因中。能作一因。通三世及非世。俱有相应异熟三因。皆通三世。同类遍行二因。唯通过去现在。又六因中。遍行一因。不善无记。异熟一因。通善不善。余之四因。皆通三性。又六因中。遍行异熟。通三界系。余之四因。通三界系。及通不系。又六因中。遍行异熟二因。唯是非学非无学。余之四因。皆通三种。又六因中。遍行一因。唯见所断。异熟一因。通见修所断。余之四因。通见修所断及非所断。又六因中。能作一因。通四谛摄及非谛摄。遍行异熟二因。唯通苦集谛摄。余之三因。通苦集道三谛所摄。又六因中。相应遍行。唯四蕴摄。俱有同类异熟三因。通五蕴摄。能作一因。通五蕴摄及非蕴摄。又六因中。相应遍行。意法处摄。异熟一因。色声意法四处所摄。余之三因。十二处摄。又六因中。遍行一因。意法意识三界所摄。相应一因。通七心界法界所摄。异熟一因。通色声界及七心界法界所摄。余之三因。十八界摄。此等因果诸差别相。非一切智。无能遍知。已随我等觉慧所行。因果义中。广辩其相。为重明了。思择诸缘。何谓诸缘。颂曰

  说有四种缘　　因缘五因性
  等无间非后　　心心所已生
  所缘一切法　　增上即能作

论曰。于何处说。谓契经中。如契经中。说四缘性。谓因缘性。等无间缘性。所缘缘性。增上缘性。此中缘性。即是四缘。如四所居即所居性。为显种类。故说性言。意辩诸缘。随事差别。有无量体。然括其义。无非摄入四种类中。谓一切缘。无过此性。于六因内。除能作因。所余五因。是因缘性。如本论说。何谓因缘。谓一切有为法。论既不说亦摄无为。故立五因。为因缘性。无为何故不立因缘。此如前释。唯无障住立能作因。非余因摄。能作因体。摄法普周。随事不同。差别多种。譬如行蕴法界法处法宝法归法念住等。摄法多故。别立通名。为摄五因及三缘性所不摄义。立能作因及增上缘。体俱广故。又诸因相差别云何。因差别相。略有二种。一者生因。二者了因。复有二种。一者定因。二不定因。复有二种。一者共因。二不共因。复有二种。一者近因。二者远因。复有二种。一前生因。二俱起因。复有二种。一自他相续因。二非有情数因。虽诸法性本有非无而功用成。必待因力。如诸造色体本非无。而功用成必因大种。因中胜者其唯五因。如造色因胜者无五。无有为法成不由因。如羸病人不能自起。由如此义。故说颂言

  无少成立不由因　　一切由因佛所说
  诸法因多细难了　　世迷便谓总无因

然上座言。因缘性者。谓旧随界。即诸有情。相续展转。能为因性。彼谓世尊契经中说。应知如是补特伽罗。善法隐没。恶法出现。有随俱行善根未断。以未断故。从此善根。犹有可起余善根义。随俱善根。即旧随界。相续展转。能为因性。如斯等。类说名因缘。此亦同前经主所执种子义破。此旧随界。即彼种子名差别故。今乘义便。随彼所执名义有殊。更广遮遣。观彼随界。但有虚言。推征其体。都不可得。故亦不可即说此为相续展转能为因性。诸有相续展转为因。有体可得如色受等。若旧随界。是有相续展转为因。应如色等有体可得。此为何相。是种种法。所薰成界。以为其相。此亦难知。体为是色。为乃至识。随界名旧应是有为。一切有为。皆五蕴摄。故若是有。应于色等五蕴性中随是一种。或彼应说。何有有为。非是色等五蕴所摄。然体是有。可为极成。故但有言。都无实体。又旧随界。无体可知。犹如合行和合有等。此旧随界。体不可说。但可说言。是业烦恼所薰六处。感余生果。此界非唯体不可说。但执为有。与理相违。非体不可说可为极成有。以诸假有补特伽罗瓶等可说。为无别体。若诸实有色受等法。一一可说。为有别体。非旧随界可说犹如补特伽罗瓶等假有。亦非实有如色等法。是故不应执此为有。既尔何得执为因缘。又随界言。非圣教说。但上座等。擅立此名。又彼许何诸业烦恼所薰六处感余生果。为业烦恼俱生灭者。为此后时相续生者。为是无间生异熟者。若业烦恼俱生六处能感果者。则后六处无感果能。俱亦应然。岂能感果。应唯业烦恼有感果能。何须执六处感余生果。又彼不应定执。眼等为业烦恼俱起助因。盲等唯托业烦恼缘。亦感余生眼耳等故。又因与果许隔越成。何用执斯为旧随界。若此后时相续六处。能感果者。与业烦恼。都不相应。如何薰彼可成随界。非有与无有相应义。岂不因果得有相应与彼相同令成缘故彼相同语理不相应。以彼相言目彼之相。应言此相与彼相同。然于此中。略此相语。此业烦恼。与彼后时相续六处。性类各别。如何此相与彼相同。岂得相应令成缘性。或彼意谓业烦恼俱六处将灭。与后六处。其相是同。令成缘者。亦不应理。前六处相。于将灭时。后体未有。体未有故。彼相亦无。何有相同。令成缘性。故彼所说。但有虚言。若彼相言。依当有说。如世间说煮饭磨糗。以彼当来极成有故。此喻非理。与所立宗。等不成故。又喻与法。世俗容有不容有故。且应先审。胜义煮磨为有自性或差别类。为毕竟无犹若空花。故喻与宗。不成义等。若据世俗。容有煮磨。依此可言煮饭磨糗。不容有法与无相同。故此喻无证宗之力。然此饭糗。非当有名。现有极成饭及糗故。观此可说提婆达多与此相同。煮饭磨糗所喻不尔。故不相应。又所煮磨饭糗成已。所方饭糗相续犹在。彼此相同俱现可得。后念六处。至已生时。尔时已无前念六处。故不可说彼此相同。由后未生及已生位。俱不可说此彼相同。故所立喻。与法非等。设许饭糗是当有名。所喻相同。亦不应理。以非前念六处所生与业烦恼俱行六处。由业烦恼为俱助缘。有异相起。非因果故。如何有力令后成缘。故不可言。与业烦恼俱行六处。胜前六处。与后相同令成缘性。是故若言前六处灭还能生后自类六处。业烦恼灭还生自类后业烦恼。如是可说依当有名。有相同义。若业烦恼俱行六处。与前无异。而能令后有异相生。成缘性者。则不应说。与后六处其相是同。令成缘性。又此何故令后成缘。故彼所言。都无实义。若是无间能生异熟六处为因。能感果者。是则应无顺后受业。唯无间因生异熟故。无斯过失。邻近展转。能牵果故。如花种等。邻近展转。能引果生。若尔更招尤重过失。顺生后受业应杂乱。汝宗自许。一业所熏。六处相续。牵一果故。又种芽等。一相续摄种芽等虽灭。而后果可生。业烦恼六处相续各别业烦恼灭已。何容后时六处自类展转相续。至最后时。能生彼果。故彼法喻。义不相应。又业烦恼俱生六处。彼不应许业烦恼熏。勿许同时有因果故。如何从彼非业烦恼所熏六处。更无别缘。而于后时欻复生起诸业烦恼所熏六处。故汝所宗。理非善立。若谓如神粪土资熏能生芽等。此亦非理。我所许故。又不成故。谓我宗许有同时因。可立此喻。汝宗不尔。云何如种粪土资熏。又于此中。正立法喻。种应正喻业烦恼心。六处应言犹如粪土。则业烦恼类应名随界。如何说六处为随界耶。非由粪土资熏种故。还令生起粪土类芽。故种唯应喻于六处。由此六处业烦恼熏。生当六处异熟果故。此救非理。非后六处果即说用前六处为因故。谓经说眼等业烦恼为因。如种为因生于芽等。非芽等用粪等为因。故彼所救。非为应理。又经说生业为因故。非当六处。六处为种。非业烦恼为因感生。可执六处为其种子。故眼等五。于感当生。全无胜用。意处或有与业烦恼同一果义。故所立喻。与法相违。或种相续。与彼粪土。相续俱时。能生异果。诸业烦恼。相续久灭。而计六处相续为因。生业烦恼所牵异果。如斯法喻。岂得言同。又种粪土。俱有分故。芽中可有二果续生。如何可与无分有分同招一果为同法喻。若执芽中粪土与种果体无别。是则能喻。与所立同。俱不成故。又彼为证旧随界有。所引圣言。有随俱行善根未断。此经还证彼所妄执旧随界无。以诸善根无贪等性。彼于此位。不现在前。得未舍故。名为未断。依将断善。故说此言。此中善根。唯生得善。诸加行善。先已断故。生得善根。于续善位。随染心得。故谓随行九品顿得。故谓俱行。或此善根。先得后起。故谓随行。现起与得。不相违害。故谓俱行。是谓此经此句实义。善根断者。亦现无此随俱善根。故此经言。彼于后时。一切皆断。随俱善根。既旧随界此善根无。故彼随界亦无。随界既无。后因何法善根续起。又初续位善根现无。应无随界。既无随界。何缘名续后善根起。复从何因。然契经说。从此善根。后余善根。定当还起。故此还证旧随界无。又彼自言。此旧随界。体不可说。如何于此。说为善根。善根因性。又于一念一心体中。无有细分。如何能牵爱及非爱俱相违果。定差别因。不可得故。又善不善及无记心。于一切时。应俱现起。然不应许。互相违故。谓于善心正现行位。不善无记心界恒随。彼与善心非有别体。依何理说。彼不现行。余二性心。正现行位。各征二性。亦应同此。又彼应说。若一心中。有多品类心界随逐。何缘从此多心随界。后时但起一品类心。然于一时。有一切识所依境界等无间缘因缘。又具何不并起。彼所依等。一一刹那。皆有能生一切识义。何法为碍。于一时间。非从一根并生多识然彼上座。于此说言。有一念一根俱生二识。如共一身根命命鸟等。不可一处二身根生。如是便违有对法性。此言但顺上座自心。无二有情同一根义。相续异故。而命命等。二根杂住。如身舌根。故从二根生于二识。非一根上二识并生。亦无一根二有情共。理应如是。谓有一根是多业果。理不成故。然一切根。皆非共有。如是上座。何理能遮于一相续同时依止一根多根发多识过。故旧随界。非为善说。又上座等。唯执诸法从无间生。岂不大师说因缘性便为无用。以所有法生所藉因。等无间力足能成办。何劳此外更说因缘。虽彼释言等无间力与生因力其义有殊。于生法中。俱有功用。而无实理。但有虚言。即随界力无间住故。非离心等等无间力。可言别有因缘功用。又彼上座。执有法体虽经劫灭。而自相续。展转相仍。犹为因性。今观彼法但能为缘。生庆自心。妄计喜悦。非于生法实能为因。所以者何。若有法体虽经劫灭。犹能为因。即彼为因。足能生法。何劳虚构。随界为因。又若彼法虽无有体。而能为因生所生法。是则应许诸石女儿亦能为因生余子息。若谓因体本有今无。诸石女儿本亦无者。则应彼法不成因缘。本有因时果法未起。今果起位。因体已无。故说因缘定应无用。若上座许唯自相续生起决定得为因缘。云何复许善不善法为因缘生无记异熟。非善不善随界为因可生无记。相续异故。若善不善。无间能生无记异熟。此中应说。何故云何善不善为因生无记异熟。若言无记熏善不善故善不善为无记因。此亦非理。前已数辩彼熏习言。无实义故。又彼云何善不善法。无记熏故。成异熟因。若谓先时异熟熏故。则应异熟为异熟因。若异熟果。善不善法为因故生。而言此中无因缘用。唯增上摄。甚为非理。所以者何。善不善为因能牵起彼果。此于彼果。何故非因。又彼所言。违越圣教。如契经说。此因此缘。令彼有情生地狱等。又说眼等以业为因。又说诸生业为因等。此中上座。作是释言。诸增上缘。不越因性。故我所说。其理善成。此亦非理。离因缘外。经别说有增上缘故。又曾无处同彼说故。谓曾无经作如是说。增上缘性。即是因缘。正理论师。容作是释。非譬喻者。可作是言。以能作因。非彼许故。又彼上座。如何可执言。一心具有种种界。熏习一心多界。理不成故。非圣教中许胜义法有唯一体多体集成。若言有心。其体虽一。而于其内。界有众多。多界与心。体无异故。界应成一。心与多界。体无异故。心应成多。诸界相望。体无异故。一与一切体应相杂。此执终非理应上广思择。然随界名。应言随过。无量过失。所随逐故。观彼但欲破圣教故。坏正理故。矫立此名。或彼但由法性深细。不能久忍。闻思疲劳。是故于中未能了达。然于诸佛弟子众中。无方便求了达称誉。矫立如是随界虚名。由此应随阿毗达磨所说正理以释因缘。是故因缘五因为性。诚为善说。不可倾动

说一切有部顺正理论卷第十八阿毗达磨顺正理论卷第十九

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩差别品第二之十一

辩因缘已。等无间缘。何法为性。非后已生心心所法。谓除阿罗汉最后心心所。诸余已生心心所法。一切皆是等无间缘。为简未来无为法故。说已生言。为简诸色不相应故。说心心所。何故等无间缘唯心心所。此与等无间缘义相应故。此缘生法等而无间。依此义立等无间名。谓一相续。必无同类二法俱生。故说名等。此缘对果。无同类法中间为隔。故名无间。若说此果无间续生名无间者。出无想等心等。望前应非无间。或无等法于中间起。名等无间。是二中间。无容得有等法生义。或前俱生心心所品等。与无间后品为缘。非唯类同名等无间。唯执同类相续者。言唯心心所。一一自类。前能为后。等无间缘如是便违本论所说。如说云何心等无间法。谓心无间。余心心所法。乃至广说。理亦有违。谓有寻伺三摩地无间或无寻伺三摩地现前。彼寻伺应非等无间缘性。及无寻伺三摩地无间。或有寻伺三摩地现前。彼寻伺应无等无间缘起。彼言心心所虽等无间生。然非刹那无间必起。如从无想有情天没时。五百劫前。久灭心心所。与今心心所。为等无间缘。及出二定心心所法。以入心心所。为等无间缘。是等无间生。非刹那无间。此亦应尔。彼有久灭有寻有伺无寻无伺三摩地法。为今自类等无间缘。故无如前所说过失。彼言非理。过去为现等无间缘。理不成故。若正灭位。已取后时心心所法。为等无间。岂不便成等无间法。亦有时分间隔方生。谁作定因无间不起。要余分位间隔方生。然无想天二无心定。有隔时分。当起定因。是则汝宗。余有心位心心所法。应非一切皆能为后。等无间缘。若汝谓此如阿罗汉后心心所。设不为后等无间缘。有何过者。亦不应理。彼后无间心心所法。永不生故。此后无间心心所法。当有可生。于中亦无等类为间。何非缘体。又此心品无间所生。复以何缘。非等无间。然有能容后余心心所。令必可起名等无间缘。彼阿罗汉后心心所无容起后。故非此例。于有漏定。理且如前。无漏定中。当更征斥谓若依止有寻伺定。而得证入正性离生。不起期心复得上果。后入无漏无寻伺定。前所依定。不复现前。彼前定应非等无间缘性。或若依止第二静虑。乃至依止第四静虑。而得证入正性离生。不起期心。得阿罗汉。后入无漏初静虑等。彼后定应无等无间缘起。非执同类相续者宗。必有当生有寻伺定故。及有已灭无寻伺定故。又此何劳更深征斥。且初无漏心等应不生。无等无间缘为能取故。既尔解脱毕竟应无。岂不如无同类因取而有无漏初心等生。如是虽无等无间缘取。何妨无漏初心等亦生。此例非等。缘必具故。谓此虽无同类因取。有余因故。定有因缘。初无漏心及心所法。有所缘故。如余一切心心所法。定四缘生。执同类宗。二事皆阙。此心心所。如何得生。非有极成心心所法。从三缘起可为同喻。是故解脱毕竟应无。若尔唯应此心心所生由异类等无间缘。如无同类因唯异类牵起。此亦非理。种子理故。立同类因。有漏不应为无漏种。故非许此有同类因等无间缘。由开避理。同类异类。皆有此能。与处牵生。力无别故。诸心心所。随其所应。同类异类。皆能引起。许皆能作等无间缘。于教及理。并无违失。无想等喻。与法不同。谓不相应。非心心所。故不能作等无间缘。没及出时。心心所法。可还用彼生及入时心心所法为此缘起。余有心位。刹那刹那。等无间缘。曾无暂阙。何劳以隔越为等无间缘。夫等无间缘。谓与处牵起。异类心等。与处牵起义同。而非等无间缘。斯有何理。又应贪等等无间缘无间唯生贪等烦恼。则善心等。无容得生。如是信等等无间缘无间。唯应生于信等。则染心等。无容得生。由是等难。便为善伏。唯执同类相续者论。何故一身心心所法。无有同类二体俱生。等无间缘。无第二故。复何缘故。无有第二等无间缘。一一有情。各唯一心。相续转故。复何缘故。知诸有情。各唯一心相续而转。心于余境。正驰散时。于余境中。不审知故。又心在定。专一境时。余境散心。必不生故。又现有能调伏心故。谓若许有二心俱生。谁复障多。令不俱起。是则应有多心并生。一有一心。尚难调伏。况一有二。或一有多。既现有能调伏心者。故知一身内一心相续生。又若一身多心并起。为境各别。为共相应。若共相应。一境一相。无差别故。俱起唐捐。若境各别。则应染净善恶俱生。便无解脱。既无此失。故一有情。唯有一心相续而转。复有至教。证一有情唯有一心相续而转。谓契经说。受乐受时。彼于尔时。二受俱灭。又契经说。心为独行。复云何知。无有识等生而不藉等无间缘。由阿笈摩及正理故。阿笈摩者。如契经言。及彼能生作意正起。由正理者。现见觉慧。定由觉慧为先生故。若异此者。何理能遮。本无有情。今时欻起。诸阿罗汉。最后心心所。何缘故说非等无间缘。是不能生。有法性故。即是不能牵后果义。此复何故。无牵果能。以于尔时余缘阙故。若尔但由余缘阙故。后识不生。许此有能牵后果用。斯有何咎。此不应许。若许能牵。则应具能取果与果。余有心位等无间缘无非具此二功能故。岂不即以余缘阙故不具二能。是则应言。余缘阙故。不能牵果。由此故说。是不能生有法性故。因义极成。或复能牵能与等无间心心所处。名等无间缘。谓正灭时心心所法。能牵能与。在正生位。等无间法处。名等无间缘。诸阿罗汉。最后心等。于正灭时。无有正生等无间法。故不可说等无间缘。若尔无想及二定前心心所法。于正灭位正生位中。无等无间心心所法。望没出位。诸心心所。应不可说等无间缘。无斯过失。没出心等。定当生故生入心等于。正灭位。即能为彼等无间缘。由不相应中间为隔。没出心等。不得即生。彼若生时。名等无间。故此可说等无间缘。或此灭时。彼虽未起中间隔越。而由为此等无间缘力所取故。义已可说等无间生。有余释言。无余心等续此起故。诸阿罗汉。最后心心所。非等无间缘。然非此心更无后念识续生故。有非意失。以立意根依所显故。然最后心。有所依义。阙余缘故。后识不生等无间缘。作用所显。若法此缘取为果已。彼法无间。必定当生。彼所说因。都不应理。若阙余缘故。后识不生。则唯具余缘。后识应起。既不如是。应说此心由阙余缘。无此缘用。此缘无故。后识不生。何乃说言无余心等续此生故。非此缘体。若谓最后心。亦能取果。唯余缘阙故。后识不生如是所依。得名意界。亦应说是等无间缘。等无间缘。作用所显。此既有作用。余何不续生。由此彼应更说余理。故前二释。为无过因。何故未来心心所法。全不许立等无间缘。等无间缘。前后所显。未来无故。不立此缘。谓前已生心心所法。能为次后在正生位心心所等等无间缘。非于未来已有决定前后安立。设许有者。修正加行则为唐捐。若法先于此无间立。此法无间。彼定生故。若作是执。善心无间。具有善染无记三心。生必待于正加行等。如从种有灰芽等生。待和合缘。而得生故。修正加行。功不唐捐。此救随情。未能遣难。生决定故。建立此缘。若三心中。随有一种。善心无间。决定生者。修正加行。则为唐捐。若三种心。善心无间非定生者。则无此缘。非不定生名等无间。是故未来世。无等无间缘。若执未来有定前后。如世第一于苦忍等。彼据何缘。说定前后。非未来法前后可成。谓非未来世第一法于苦法忍可说前后。以彼本唯一世摄故。夫前后义。历世方成。世第一法至已生位。苦法智忍。方名为后。故前后义。于未来无等无间缘。由此非有。又设未来有定前后。亦不可立等无间缘。如芽等生属种等故。虽有前后。而无此缘。若此法生。系属彼法。要彼起已。此乃得生。故等无间缘。唯生已方立。若尔未来世。应无异熟因。由此因果定有前后。然非未来有前后故。无斯过失。虽定前后。而不约之立此因故。谓虽异熟因定有前后。而不约前后立异熟因。若尔如何立此因果。谓如是业因感如是异熟。此相可说亦在未来。故于未来。亦可安立。然约法性。预说未来。此因前生。此果后起。因已生位。果后义成。尔时方名真实前后。非未生位有实前后。诸因可说未来有者。彼因不待历世而立。如俱有因相应因等。岂不俱有因待中世而立。此责非理。不了义故。以俱时有故名俱有因。是更互相望为因果义。若未来世无等无间缘。如何世尊知未来因果。如契经说。若能供养吾身。驮都八分中一。当十三劫。不堕恶趣。人天往还。受诸妙乐。如是等说。其数寔多。非如是俦一切智境。非一切智可能测量知其真实。如世尊说。诸佛德用。诸佛境界。不可思议。故不应责。有余师说。如过去世。佛于未来。现知见转。谓佛欲知有情因果。然现在世。时分短促。故多观察过去未来。非佛世尊欲知后际先观前际然后能知。如佛世尊更无所待。由过去境智现前故。于过去世有情身中业果相应。能善通达此法无间。此法已生。如是不待先观前际。由未来境智现前故。于未来世有情身中业果相应。能定现见。此法无间。此法当生。复有余师。作如是说。有情身内现有未来。因果先相。犹如影像。或色或心。不相应行。佛唯观此。便知未来。非要现游静虑通慧。然非于彼占相故知。以于未来现证见故。非占相知。能于所占。现前证见。分明记别。佛于如是尔焰稠林。理有所因。方能现起。无碍观察。胜方便智。非佛自称一切智者。便于色等现境界中。非眼等识于先领受。唯用意识常现了知。又眼等识于声等境。理无方便。令互作业。何缘一切。色非等无间缘。等无间义不相应故。非无等法俱生为隔。故此无有等无间缘。谓一身中一长养色。相续不断。复有第二长养色生。不相违害。如一食等所长养色。相续不断。复有食等所长养色。相续而生。又有一类异熟生色。相续不断。复有一类异熟生色。相续而生。又一四大种所生造色同类多极微俱时而起。故不可立等无间缘。或法现前等而无间彼法可立等无间缘。谓现行心。若此所系。或非所系。俱行受等。与此皆同。故名为等。无心受等同一类法二体俱生。故名无间。色法不尔谓一心时有欲界系及色界系。二色并生。或欲界系及不系色。俱时而起。故色无有等无间缘。上座此中妄作是诘。若一类色。相续不断。复有一类。相续而生。由此故非等无间者。何缘于彼不共无明相应品中。有贪等起。此应反诘。彼上座言。不共无明相应心品。何缘得有贪等俱生。不共无明。相续未断。定无贪等俱时起义。然说贪等不共无明俱时起者。但为诱诳寡学门人。显己善通对法宗义。而于本论及诸圣言。曾无此理。又彼所诘。意何所显。为如二种长养眼根相无差别。例彼贪等不共无明。相亦无异。为如贪等不共无明其相有异。例彼二种长养眼根。相亦差别。纵有此意。应陈所诘。于此义中。得何胜利。岂由此故。便令受等贪等信等无此缘义。故彼所诘。有言无理。有余复言色法生灭。少多无定。故非此缘。谓或有时从多生少。如烧稻秆大聚为灰。从充大身转生瘦小。或时复有从少生多。如细种生诺瞿陀树根茎枝叶。渐次增荣。耸干抽条。垂阴远覆。羯剌蓝等。转生大身。故色定无等无间义。岂不心所无间生时亦有少多品类非等。谓善不善无记心中。有寻有伺三摩地等。此于异类。实有少多。然自类中。无非等义。谓无少受无间生多。或复从多无间生少。想等亦尔。无非等失。故心心所生灭体均。依之可立等无间义。然彼上座。对自门人。于此义中。妄有所诘。谓色亦与心心所同。自类一一各差别故。虽于诸界和合聚中有无量色。而彼种类展转相望。各有差别。如是所诘。但有虚言。既许现前有同类色。则同类色并起义成。非各有殊名现同类。然许诸聚展转相望种类有别。则别聚内。有多色体。同类义成。又若多微。同因一具大种所起。上座此中如何可执种类各异。又见胡麻诸豆麦等。从一种体。有多果生。多果相望。其类是一。如何可执此类有殊。又彼自言。有同类色多体和合。何反为征。谓彼上座。自遮诸色等无间缘。言有同类。同聚多色。俱时而起。非心受等同类俱生。故诸色定无等无间缘义。又彼所言。如色非色。虽有差别。而等不遮同类因等。如是彼法。亦应等作等无间缘。上座此征。极为杂乱。既尔亦应计诸色有所缘。又如所许。俱等无间缘。而于其中。有色有非色。如是应许俱同类因。等而其中有此缘非此缘。今于此中。假许彼执。显义有别酬彼所征。然实不可许诸色法为等无间缘相不相应故。若诸色法等无间缘相相应者。法尔应立。何须引例。同类因等。此缘彼因。义各异故。若诸色法等无间缘相不相应。设复引彼同类因等。于义何益。于义无益。而引彼因。例此缘者。但是上座。其年衰朽。出虚之言。有余复言。以诸色法一类相续。此处生时。若余色来夺其处者。可有移往余处生义。故非前色与处方生。又本色聚相续不断。其边复有同类色生。不尔色聚应无增长。等无间缘。终无此理。故色不立等无间缘。譬喻论师。说诸色法如心心所法有等无间缘。见乳醅种花生酪酢芽果。如心心所前灭后生。故知诸色。有此缘义。又无经说唯心心所能为此缘。故立此缘定非色者。是虚妄执。无如是义。诸缘功能。无边差别。略说四故。谓诸法生。待多缘合。诸缘功用。差别无边。然佛世尊。略说为四。诸从乳等羯喇蓝等形依等缘。生于酪等頞部昙等影识等果。当知摄在因增上缘。何缘故知乳等无间生于酪等。前法非后等无间缘。此先已说。先何所说。谓前说言。等无间义不相应故。现见极成心心所法。生必系属等无间缘。所有俱生。皆别种类。诸同种类。必不俱生。故同类俱。互相违法。要前念灭。后念方起。由与处方便立等无间缘。一四大种所生同类乳等造色。有多极微。俱时而起。不相妨碍。此相乖越等无间缘。故酪等生。虽系属彼。而不可立等无间缘。大种相生。亦同此释。谓同异类。皆可俱生。更互同时不相妨碍。虽相继起。而非此缘。又言无经说唯心等为此缘者。于色亦同。谓无经言。诸色亦有前能为后等无间缘。故譬喻师。非理横执。诸色亦有等无间缘。又譬喻师。为许色有所缘缘不。彼说言无。岂有契经明证此义。虽无经说。理必应然。等无间缘。何不许尔。故彼具寿。诸所发言。但率己情。无真理教。不相应行。何缘不立等无间缘。以乱起故。谓一身中。善恶无记。及三界系不系俱生。毗婆沙说。心及心所。所依所缘行相有碍。由斯故立等无间缘。色不相应。无如是事。故彼不立为此缘体。上座此中显己于学不勤方便。谬作是言。此说都无证成理趣。唯显心等与色等别观彼所言。未闲说意证成理趣蕴在此中。谓一所依所缘行相。定无有二识等并生。故必由前与处方起。若前为碍。后不得生。由此证知。唯心心所。前能为后等无间缘。若尔命根无二俱起。何不许托等无间缘。谓此命根。如识等相。故亦应立等无间缘。此例不然。命与生体俱先行力所引起故。谓此命根非无间灭。命力所引。要是先位所作行业力所引生。既尔命根应一念顷一切顿起一切同依。一念行业力所引故。先业所引心心所法起应不藉等无间缘。且诸命根。无顿起失。即由业力生决定故。因果法尔。一刹那业。引多刹那异熟令起。又无用故。命不顿生。谓为任持众同分故。引命根起。一命相续。足能任持。多便无用。心心所法。虽先业引。而非不待等无间缘。托诸根境。而得生故。既托根境。和合故生。设多并生。亦非无用。然无第二等无间缘。故同类中。无二俱起。又心心所。非唯先业力所引生。异熟及余杂乱起故。若不更托等无间缘。应一刹那有多俱起。谓命根体。唯是异熟。唯由先业力所引生。可言同类定次而起。心心所法。无如是事。异熟灭已。有等流生。等流无间。有刹那起。或起异熟。非定同类。故心心所。虽有异熟生。而亦不可言与命根等。是故唯等常无间生。名等无间。以此与此为缘故说等无间缘。岂不极微一类相续前前灭已后后续生。自类相望。等而无间。由前开避。后方得起。相不乖越。等无间缘。此不俱生。由无用故。非等无间缘力故然。准前命根。如理应释。然此亦有同类俱生。故不应言此缘所摄。又若唯开避建立此缘。可说极微等亦此缘摄。然约开避。及据牵生。立此缘体。故极微等。虽前避后。而非此缘。心等相生。有定不定。故知亦据有力牵生。现见一心前后相续。虽前避后。其理皆同。而生不生。有定不定。且生定者。谓世第一法心之无间。有苦法智忍心决定生。如是乃至。金刚喻定心之无间。有尽智品心决定生。有烦恼者。定心无间。烦恼心生。如是一切不生定者。谓染污品心之无间。诸无漏品心定不生。诸无漏品心之无间。诸染污品心定不生。一切无学心之无间。一切有学心定不生。下地烦恼心之无间。上地烦恼心定不生。一切异熟心之无间。诸刹那品心定不生。一切刹那心之无间。诸异熟品心定不生。如是一切生不定者。谓欲界染心之无间。自地四种心皆可生。上地烦恼心之无间。下地善品心亦可生。如是一切于后思择相生义中更当显示。由此所说。生与不生。有定不定。故知非但约开避立等无间缘。亦据牵生果法功用。非此功用。极微等有故彼不立等无间缘。岂不于心一类相续亦无如是牵生功用。非此功用或有或无。若此时无。后应非有。诸心心所。自因力生。前无间灭。有何所作。而计心等独为此缘。色不相应非此缘体。前无间灭有所作者。谓诸根境虽现和合。若前不灭。后必不生。谓一身中。虽多缘合而无识等同类并生。故知前心无间灭位。有力引后心等令生。色不相应。无如是事。故彼不立等无间缘。如说。云何心等无间法。谓心无间余心心所法。已生正生。及无想定。乃至广说。此已生言。摄过现世。正生言摄未来生时。若尔便应第二念等定及出定心非心等无间入心无间。彼未生故。岂不彼诸法后正生时名心等无间。故无此失。如何无失。彼正生时。前入定心。久灭过去。今时亦不可名心等无间。无斯过失。中间无余等无间缘为间隔故。有余师说。彼法虽远。义已可说为正生时等无间缘。果被取已。必当生故。若尔违害见蕴中文。如彼问言。若法与彼法为等无间。或时此法与彼非等无间耶。彼即答言。若时此法未至已生。有何违害。等无间定要至已生。此不相违。两释差别。俱摄受故。若时此法未已生者。此法是何为前为后。如世第一法生苦法智忍。为世第一法未至已生时。非与苦法智忍为等无间。若至已生位为等无间耶。为苦法智忍未至已生时。非与世第一法为等无间。若至已生位为等无间耶。若执前者。有心位可尔。无心位如何。谓无心定入心已生不可即与第二念等定及出心为等无间。若入定心至已生位。即与彼诸法。为等无间者。等无间缘果法被取。必无有物能碍其生。则彼一切皆应顿起。若入心后。出心即生。是则二定。永应不起。若执后者。苦法智忍。未已生时。应不与彼世第一法为等无间。然必应许。苦法智忍。在正生时。即名与彼世第一法为等无间。此中一类许可前执。然见蕴文。约有心位说等无间。故无前失。或言设约无心位辩。此失亦无。谓入定心。居现在位。顿取诸定及出心果。亦与最初刹那定果灭入过去。随后诸定及出定心。一一生时。与果非取。先已取故。岂不一切等无间缘无有异时取果与果。此责非理。取果必顿。与果有渐。故无有失。但应责言。同一心果。何缘诸定及出定心。前后而生不俱时起。正所求者。理必前生。谓入定心。顺求于定故心无间。定心前生。若尔何缘诸刹那定。前后而起。诸刹那定。俱生无用。故不俱生。由前加行势力所引。故多念定长时续生。非多刹那。定俱起用。一刹那定。所不能为。故不顿生。犹如识等。然诸念定。是等无间。不可说是等无间缘。若法由前心等引起。同一种类。必不俱生。生已复能引后令起。可名等无间及等无间缘。诸定虽由前心等引。同一种类。必不俱生。然其生已不能引后。可名等无间非等无间缘。是故设约无心位辩亦无有失。诸作是说。入二定心灭入过去。方能渐取第二念等定及出心。彼入定心。应非过去。未取果者。是牵果名。诸牵果能是行作用。依行作用立三世别。若有作用非现在者。岂不便坏世别所依。诸有释言。过去眼等。于色等境。无有见闻嗅尝觉等各别作用。故非现在。彼释不然。应共审决。眼等作用。为是于境见等功能为牵果用。若是于境见等功能。便于闇中。现在眼等。未生已灭。眼等何殊而不说为未来过去。闇中眼等。虽无见闻嗅尝等用。而皆现有牵果功能。可名作用。约有此用皆名现在。所余取境与果等用。皆非作用。但是功能。如是功能。三时容有。辩三世处。当更思择。又过去世诸心心所。于所依等。不能为碍。故不能作此缘取果。复有一类。许可后执。岂不苦法智忍在正生时。即与世第一法为等无间。理实应尔。然此中说等无间缘要至已生此缘方立。故无有过。如是两释。未已生言。于我义宗。并无违害。已广决择。阿毗达磨。等无间缘。所有正理。然彼上座。复作是言。等无间缘。谓前生法。令无间法获得自体。如世尊说。意法为缘。生于意识。谓意为因。法为缘故。意识得生。然无一时二识并起。此相非理。不明了故。色心无间。有色心生。俱是前生。令无间法获得自体。岂可即说色心互作等无间缘。然不应许互为缘义。谓色与心。相续各别。如何互作等无间缘。又一心因。起多色果。多色无间。无二识生。何得相望为等无间。故不应立等无间缘。心等独生。可名等无间。色等并起。如何得此名。故彼说色为等无间缘者。是不思审。谬作是言。又彼宗承。随界论者。因等无间。二缘应同。随界所依。体无别故。恶心无间。有善心生。应说谁因谁等无间。体无别故。责余亦然。故上座宗。但于圣教。矫施常网。幻惑愚夫。等无间缘。其性已辩。所缘缘性应说是何。谓所缘缘。即一切法。离心心所所缘境外。决定更无余法可得。谓一切法。是心心所生所攀附。故曰所缘。即此所缘。是心心所。发生缘故。名所缘缘。一切法者。即十二处。谓眼耳鼻舌身意识。及相应法。随其次第以诸色声香味触法。为所缘境。六根唯是意识所缘。何缘故知。经言多法生意识故。又眼等根。皆五识境。所不摄故。譬喻者宗。理必应尔。如意观法。五识亦然。谓所缘缘。非所缘境。若所缘境。非所缘缘。所以者何。彼说色等。若能为缘。生眼等识。如是色等。必前生故。若色有时眼识未有。识既未有。谁复能缘。眼识有时色已非有。色既非有。谁作所缘。眼识不应缘非有境。以说五识缘现在故。彼宗现在。非非有故。现所缘色。非所缘缘。与现眼识。俱时生故。乃至身识。征难亦然。五识应无所缘缘义。彼宗意识。缘现在者。应同五识。进退推征。若缘去来及无为者。决定无有所缘缘义。彼执去来及无为法。皆非有故。非非有体可立为缘。太过失故。此中上座。复作是言。缘过去等所有意识。非无所缘。非唯缘有。何缘故尔。以五识身为等无间。所生意识。说能领受。前意所取诸境界故。如是意识以意为因。此所缘缘。即五识境。要彼为先。此得生故。随彼有无。此有无故。然此意识。非唯缘有。尔时彼境。已灭坏故。非无所缘。由此意识随彼有无此有无故。又随忆念久灭境时。以于彼境前识为缘。生于今时。随忆念识堕一相续。传相生故。虽有余缘。起随念识。而要缘彼先境方生。如是所言。都无实义。同诸哑类梦有所说。唯愚亲友。或妄信依。诸有智人。谁能听受。彼既非许五识所缘与五识身俱时而起。是则五识尚所缘境灭已方生。况五无间所生意识。能受彼境。第三刹那意识生故。若五无间所生意识。能受过去五识所缘。复许所缘非是无者。则分明许意识所缘。虽名已灭而少分有。若执全无。则分明说。所生意识。都无所缘。而复说言。然此意识。非唯缘有。尔时彼境。已灭坏故。非无所缘。由此意识随彼有无此有无者。但是虚言。具惭愧人。不应持此隐蔽此识。无所缘过。又何故言。然此意识非唯缘有。尔时彼境。已灭坏故。已灭坏法。岂许亦有亦非有耶。若尔便归正理论者意所游路。以正理论有义多途。作用功能。体性别故。然过去法。非如现在作用亦有。非如空花体性亦无。若不许尔。言此意识非唯缘有。此言何用。应言此识决定缘无。或复应言决定缘有。又何故说。非无所缘。随彼有无此有无故。若随境有识有义成。是则过去便成有体。若过境无而有现识。则不应说随彼有无非无所缘言。又无义以境有故名有所缘。境体既无。所缘何有。又随忆念久灭境时。云何前生缘彼境识。能为缘故生今识耶。前识有时。今识未有。今识有位。前识已无。如何可言。于久灭境。前为缘故今识得生。非无与无可有缘义。非一相续故得为缘。兔角何缘前不生后。无与无法许为缘故。若有随界不同彼者。理亦不然。于前境中。今随界识。曾未生故。如何可言。缘彼境识。前为缘故。令今得生。不可说言随界与识别时缘境。勿于一时有二时故。又应一识各别所缘。以随界体即今识故。识非定缘前灭境故。若谓随界体非今识。应一相续二识并生。又不应言。随界生识。非前生故。如何可说。于久灭境。前为缘故。今念识生。随前有无今有无故。得为缘者。理亦不然。前后有无。不相随故。然彼复言。由过去世展转为因。复由未来展转为果。智等得生。是故智等。不可定说所缘是有或复是无。奇哉东方善言穷匮。如斯等论亦有书持。若执去来因果展转。不观现在智等得生。又执去来一向非有。是则智等应定缘无。若执去来因果展转。亦观现在智等得生。是则一心应有二虑。以无与有相差别故。又因果展转名何所诠。非越现刹那有前后际。如何过未立展转名。非无与无可名展转。故彼所说。过去未来。因果展转。智得生等。但足论文。都无有义。如是已辩所缘缘性。增上缘性。即能作因。以能作因因义细故。无边际故。摄一切法。若此于彼。不碍令生。是能作因。增上缘义。对三缘义。此类最多。所作寔繁。故名增上。岂不增上摄法普周。宁复对三。言此增上。非对三体立增上名。何者对三义用而立。诸缘义用。互不相通。诸缘体性。更互相杂。如增上缘义类无量。所作繁广。余三不然。故此独摽。增上缘称。有余师说。此增上缘。体类最多。故名增上。岂不诸法皆所缘缘。如何此缘独名增上。俱有诸法。非所缘缘。是增上缘。故不应难。此不应理。所以者何。立所缘缘非不定故。谓若此法。为彼所缘。设不缘时。亦所缘体。以所缘境性安住故。既一切法。皆所缘缘。不应此缘独名增上。此定应理。所以者何。如增上缘。彼不尔故。谓若此法为彼增上。无时望彼非增上缘。但彼生时。遍为增上。其所缘缘。则不如是。俱有诸法。非所缘缘。所以者何。总论体虽等别望有少多。故此一缘。独名增上。此中意说。唯增上缘。体类俱多。非唯据体。以所缘类皆增上缘。非增上类皆所缘缘。类谓于果功能差别。有余师说。所生广故。名增上缘。谓一切法。唯除自体。遍能生起一切有为。如一刹那眼识生位。除其自性。用一切。法为增上缘。余生亦尔。且如现在一念眼识。自相续中。过去诸识。为其种子。未来诸识。不为障碍。令已得生。同时眼根。为所依止。未来过去所有眼识。不障为因。令其已起。他相续法。亦为此因。谓见他身。起自眼识。或欣他色。生自眼根。为展转缘。生自眼识。故他余法。亦转为缘。望自识生。有增上力。诸余色法。为眼识因。谓为所缘及于所依。为损为益。由此展转眼识已生声亦为因。谓闻彼故。所依损益。因兹长养损减眼根。令已发生明昧眼识。香味所触耳鼻舌身。亦于所依。为损为益。由斯展转。为眼识因。于法界中。诸有为法。有为助伴。有摄受因。或为能牵。或为依等。如是展转。皆眼识因。择灭无为。亦为因者。谓有情类。信谤涅槃发业。能招爱非爱果。由斯展转眼识得生。一切有为。有非择灭。由不得彼。诸法得生。展转为因。亦生眼识。虚空容受色等有为。展转为因。亦发眼识。故一切法。为增上缘。眼识得生。余例应尔。由此诸法。一一望余。一切有为。为此缘性。如是一切。善与不善。皆应展转为增上缘。谓善为因。生王家等受富乐果。由此为依。多行放逸。造诸不善。不善为因。多遭苦逼。缘兹生厌。广树众善。又内外法。亦互为缘。谓因农夫。生稼穑等。因饮食等。滋长有情。有情无情。有根无根。有心无心。及有执受无执受等。应知皆互为增上缘。随其所应。例可安立。如是一趣。为五趣缘。一一为先生一切故。或依一趣。起一切因。由此当来受彼果故又怖恶趣。修诸善业生人天中。于人天中。嗜欲造罪。生诸恶趣。诸如是等。品类无边。故增上缘。所生最广。如是用体所生广故。应知略述此增上缘。然契经中。说世白法三增上者。止恶行善所观因。故立增上名。谓境现前。烦恼将起。随观彼一恶止善行。于止行中。得增上故。契经且说增上有三非余。于余无增上义。虽诸增上义通近远。而就胜说。如立母名。如圣教中说爱为母。以能生长诸有情故。非余烦恼无生长能。胜故多故。系缚心故。说爱为母。非余烦恼。又说二法能护世间。非不有余悲等能护。如斯等类。无量无边。就胜为言。此亦应尔。然上座说。此增上缘。但据诸根生心心所。此宗可尔。彼义不成。所以者何。如前屡辩。谓彼不许有俱生因。许前生因。义不成立。故彼所说。但有虚言。又说此缘相不具足。且如眼识生增上缘。非但眼根为依故起。亦有大种。为转生因转长养因。谓诸饮食。业烦恼等。为招引因。此明昧因。谓眼增损。首足身分。为任持因。作意明空。引助令起。如斯等类。非彼所论。故辩此缘相不具足。余耳识等。随其所应。有无量缘。非彼所说。故彼所说。增上缘相。但得少分。义不周圆。然彼所宗。亦许多法。于生识等。为展转因。如何此缘。唯说眼等。彼复说言。若法于彼。或生或养。可说为因。非不相由可有因义。故非一切法皆能作因及增上缘。不相由借故。彼言非理。诸法生时。所藉诸因。无分限故。谓不可说此法生时但藉若干法为因起。如外内法要藉时方众具种子。法与非法。若合若离。余生住坏。及大种等差别为因。芽等及身。方得生长。是故诸法于生长时。所藉众缘。无有限数。故一切法。皆能作因及增上缘。此说为善。又彼不了能作因义。故于此中不能信受。因即能作。名能作因。义不相违。即能生义。或有所以。可名为因。复有所以。可名非因。能作二义。名能作因。不相违故。可名为因。不相由故。可名非因。故能作因。能含二义。然不相违。复有二种。谓于所生法能碍不能碍。不能碍者与能为碍。而不碍法。不碍义同。故此亦有少分因相。由相不明不共施设。除俱有等五种胜因。所余因义。若近若远。一切说为能作因故。或此是彼能作之因。名能作因。是此与彼转为因义。如是因义。一切法中。皆容得有。故一切法。皆能作因。能作因中。已广思择。今因解释增上缘门。故复略辩此因名义。然上座言。为遮来世说一切法为一法因及缘者意。故契经说定有四缘。彼言但彰已无明鉴。岂违对法所说因缘

说一切有部顺正理论卷第十九阿毗达磨顺正理论卷第二十

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩差别品第二之十二

如是因缘。有何差别。此就实体。差别都无。应说因缘如何相摄。我前已说。因缘五因性。增上即能作。何复生疑所余二缘。未辩因摄。故今于此犹可生疑。有作是言。同类遍行二因。各少分名等无间缘。皆约已生。位无别故。无如是理。果有异故。岂不一切因皆有士用果。若法有力能生于彼。或得于彼。彼是此法士用果故。不尔二因俱等流果。义所显故。又善不善。有漏无漏界地等别。同异皆是等无间缘之士用果。二因之果。唯据类同。故与此缘。非无差别。岂不二因之等流果亦兼有异。如欲缠系见。苦所断二因所牵。自部等流有记无记。此亦染污。其类是同。有漏无漏。界地等异二因必无。故非无别。若尔已生心心所法。相应俱有二因摄故。应皆不立等无间缘。此与二因之士用果。其相各别。此无间生。与彼俱生。果有异故。岂不二因亦有无间生士用果。无如是义。以心心所能生无间士用果力。应知即是等无间缘。非是俱有相应因用。二因唯有能得俱生士用果力。以心心所能引俱生士用果义。即名俱有相应二因。引无间生士用果义。应知即是等无间缘。如引俱生果虽无别而依异义别立二因。体虽相杂。而义有异。二因对彼等无间缘。义别体同。应知亦尔。故等无间非即诸因。其所缘缘。为即因不。有作是说。即能作因。以体与果俱相似故。岂不所缘缘士用果为果。有作是说。此所缘缘果唯增上。或复能作因。亦有士用果。故无有失。若尔俱有相应二因。应如所缘能作因摄。然非所缘缘展转增上果。亦非士用果从所缘缘生。故无体果俱相似义。是故有释。因缘差别。不遍是因。遍者是缘。摄不摄故。如指指节。是故不见等无间缘及所缘缘有因摄义。此与因别。理不待言。唯初后二缘。应辩与因别。此既有别。余之二缘。缘义等故。亦应有别。故有总辩缘因异言。谓因能生。缘能长养。犹如生养二母差别。又缘摄助。因方能生。生已相续。缘力长养。故或有说。因唯有一。缘乃有多。犹如种子粪土等异。又因不共。共者是缘。如眼如色。又作自事说名为因。若作他事说名为缘。即如种子粪土等异。又能引起说名为因。能任持者说名为缘。如花如蔕。又因名近。远者名缘。如珠如日。又因能生。缘者能办。犹如从酪出于生酥。钻器人功力所能办。非钻器等令水出酥。以于水中阙酥因故。如斯等类。差别众多。是故因缘。别立名想。由其功力有差别故。又正有义故说为因。能助显发故说为缘。如字界缘于义有别。然契经说。二因二缘。生正见者。言音作意近远等生无漏正见。约此义显因缘二名。又契经说。有因有缘。有由序者。此显俱起无间远因义有差别。又契经说。眼因色缘生眼识者。意显眼识随不共根及共境起。又契经说。此因此缘此由序者。此中意显作者作具及余助缘。如是等经。随义应释。已随理教。广辩诸缘。如是诸缘显法生灭以为作用。应说何缘于何位法。而兴作用。颂曰

  二因于正灭　　三因于正生
  余二缘相违　　而兴于作用

论曰。前说五因。为因缘性。二因作用。于正灭时。正灭时言。显法现在灭现前故。名正灭时。俱有相应二因。于法灭现前位。而作功能。此位二因作功能者。谓俱生品。随阙一时。作用皆无。不能取境。于现在位。如是二因。虽俱一时取果与果。而今但约与果功能。所言三因。于正生者。谓未来法。于正生位。生现前故。名正生时。同类遍行异熟三种。法正生位。而作功能。故有说言。等流异熟二果。因力牵引。令生同类遍行。容有无间等流果起。可言彼果。于正生时。因兴作用。异熟因果。必隔远时。其因久灭。果方正起。如何作用。在果生时。非过去时可有作用。此言作用。意显功能。二相别中。已曾思择。以因虽灭经无量时而有功能。令自果起。由不共故。自果生时。作用虽无。而于自果。兴功能上。立作用名。彼上座言。一刹那顷。难说此是生时灭时。非法由因先生后灭。如杖持罥内蛇穴中系颈挽出方断其命。然体本无。由因故有。彼说但是掉举戏言。引非所宗。鄙俚言故。非对法者许法由因先生后灭同系蛇喻。但由缘起理趣法然。为晓学徒。说取与用。显于果起因有功能。故彼所言。唯增掉戏。又彼所言。一刹那顷。难说此是生时灭时。彼恒寻思粗浅异论。尚年已过。居衰耄时。岂能测量。幼恒思择。一切智者。诠至理言。修成妙慧所游宗极。虽一刹那而本末起。今时正起。名曰生时。生已无间。正临谢往。名曰灭时。此何难说。或虽难说非不可说。勤加方便。而可说故。岂由汝等堕于劬劳己不能说。令他亦舍无上菩提亦难可得。岂由难得便舍至求。是故不应以己堕学不了其相便拨言无。又体本无由因有者。何烦说此违自宗言。谓若本无。如何言体。既得言体。何谓本无。依对法宗。应作是说。以未来法亦有亦无。谓作用无体本有故。由诸先起及俱生因。体本所无。今时方有。说未来世无体论宗。未生既无。如何言体。若彼无间必当有故。得言体者。有太过失。现在无间必当无故。应言无体。便一切无。又未来无。以当有故。言有体者。现在有体。以曾无故。何不言无。过去亦应得说体有。以曾有故。世便相杂。是故彼说不耐推征。唯对法宗。理无倾动。已说因缘二时作用。二缘作用。与此相违。等无间缘。于法生位。而兴作用。以彼生时前心心所引开避故。若所缘缘。能缘灭位。而兴作用。以心心所要现在时方取境故。其增上缘。法生灭位。皆无障住。故彼作用随无障位。一切无遮。今应思择。俱有相应。及所缘缘。若法生已。方兴作用。何须立此二因一缘。若执因缘要有作用。方许立为因缘性者。则未来世。应无因缘。然宗所许。不应为难。若尔云何说有作用。若离如是二因一缘。正灭位中。所引诸法。应无作用。取境功能。若作用无亦名缘者。诸阿罗汉最后心等。亦应可立等无间缘。此责非理。前已辩故。说所缘缘非要由有作用方立。何相关涉。而将例彼等无间缘。彼缘要由开避牵引。故唯现在正可安立。于未来世。定无彼缘。于现在时。曾有作用。故虽过去。亦可安立。其所缘缘。非唯现在。但有体性。皆可成缘。不必要由作用而立。唯于少分。少分成缘。得作用名。非于一切。云何知有体方得成缘。所缘体若无。觉不生故。有余师说。立因立缘。亦有别义。非要能起。虽无生用。而亦成因。如自相续。见定因果。于他相续。理亦非无。如契经说。二因二缘。生于正见。此亦应尔。能生不生俱成因性。俱有诸法。和合能牵异聚一果。名为作用。以于如是和合聚中。随阙一法。余皆无用。故俱有法。更互为因。如俱有因。相应亦尔。展转有力。能取所缘。故非能生方成因性。若尔何缘先作是说。法生所赖故说名因。非可离因法有生义。故作是说。非谓一切能生果者方得名因。因义尚然。缘亦应尔。故法生已。作用非无。辩诸缘已。应言何法由几缘生。颂曰

  心心所由四　　二定但由三
  余由二缘生　　非天次第故

论曰。此中由言为显故义。谓心心所。四缘故生。其所缘缘。除生心等。无别有用。谓六识身。及相应法。随其所应。以色等五及一切法。为所缘缘。心等因缘。具五因性。前生自类。开避引发。是谓心等等无间缘。此增上缘。即一切法。各除自性。随其所应。岂不一缘二因作用。非于彼法生时。即有如是心等四缘故生。如何因缘。具五因性。虽法灭位作用方成。而法生时非无功力。离此彼法必不生故。以心心所必仗所缘。及托二因。方得生故。若法与彼法为所缘。或因无暂时。非本论说故。二无心定三缘故生。除所缘缘。非能缘故。此因缘者。但有二因。一俱有因。谓二定上生等诸相。二同类因。谓前已生自地善法。等无间缘。谓入定心及相应法。增上缘者。谓如前说。岂不无想亦三缘生。是心心所等无间故。亦应说为心等无间。但非心等加行引生。故于此中。废而不说。或此无想。但声所显。非如二定相对立故。二定何缘是心等无间。而不说是心等无间缘。由心等力。所引生故。如心心所生必系属前心灭故。非如色法可与余心俱时转故。非如得等可有杂乱。俱现前故。非如生等。是余伴故。然心方便加行引生。故可说为心等无间。与心等起定相违害。故非心等等无间缘。又为此缘理相违故。谓修行者。厌恶现行心心所法。入无心定。若无心定。复为此缘。引心心所。则修行者。应于此定无乐起心。为离现行心心所法。入无心定。此复引生心心所法。不应道理亦有至教。证无心定由心心所加行引生。如说超过一切非想非非想处想受灭身作证具足住。故知二定是心心所。加行引生。由心差别现前证故。无有至教。证无心定能为此缘。引心心所。故非心等等无间缘。二定刹那。前望于后。何缘不立等无间缘。诸念皆由前心等引。不能引后。如前已说。又最后念。应无果故。出心为果。斯有何失。岂不已说。此非心等等无间缘。如何可言最后念定出心为果。又出定心。依前心等加行起故。不可说作最后刹那定所引果。入定心等。望出定心。非无间灭。出心望彼。如何可说等无间耶。无等无间缘于中为隔故。无间等无间。义各有差别。前心等力引后法生。后法名为前等无间。刹那无隔。立无间名。是故二言。其义各别故作是说。若法与心为等无间。彼法亦是心无间耶。应作四句。第一句者。谓无心定出心心所。及第二等诸定刹那第二句者。谓初所起诸定刹那。及有心位诸心心所生住异灭。第三句者。谓初所起诸定刹那。及有心位心心所法。第四句者。谓第二等诸定刹那。及无心定出心心所生住异灭。若法与心为等无间。与无心定为无间耶。应作四句。谓前第三第四句。为今第一第二句。即前第一第二句。为今第三第四句。余不相应及诸色法。皆因增上二缘所生。复云何知。世间诸法。唯如上说因缘所生。非自在天我胜性等一因。所起。由次第故。谓诸世间。若自在等一因生者。则应一切俱时而生。非次第起。因现有故。何法为障。令不俱生。现见诸法。次第而起。故知非但一因所生。若执世间随自在欲。前后差别。故非顿起。是则应许非一因生。亦许欲为法生因故。此欲前后生灭差别。理亦不成。因无异故。非因无异果有差别。要待异因。果方别故。或差别欲。应许顿生。所因前后无差别故。是则诸法亦应顿生。谁能为障。令不顿起。若自在欲。更待余因。前后次第差别生者。应所因法更待余因。则所待因。应无边际。因无边故。无始义成。不越释门因缘正理。徒异名说自在为因。又无用故。不应妄执世间诸法自在为因。非自在天作大功力生世间法。少有所用。故不应谓自在为因。若为发生自欢喜者。但应发喜。何用生余。若喜离余方便不发。是则彼喜余方便生。自在于斯。应非自在。于喜既尔。余亦应然。差别因缘不可得故。或余方便。应余方便生。何用计从自在天所起。若余方便。离余方便生喜。亦应非余方便所起。或生苦具。逼害有情。为发自喜。咄哉何用事斯暴恶自在天为。又信世间唯从自在一因所起。则拨世间现见善恶诸士用果。若言自在待余因缘助发功能方成因者。但是朋敬自在天言。离所余因缘。不见别用故。时地水等种种因缘。于芽等生现有功力。芽等随彼成有无故。于芽等生除彼功力。不见别用。故不应计世间法起自在为因。自在既然。我胜性等。亦应准此如应思择。故无有法唯一因生。但从如前所说种种因缘所起。其理极成。既言色法因及增上。二缘所生。大种所造。总名为色于中云何。大种所造自他相望。互为因缘。颂曰

  大为大二因　　为所造五种
  造为造三种　　为大唯一因

论曰。初言大为大二因者。是诸大种。更互相望。但为俱有同类因义。俱起前生为因别故。谓随阙一。余不生故。更互相望。有俱有因。性类虽别。而同一事。更相顺故。有同类因。大于所造。能为五因。何等为五。谓生依立持养别故。虽同时生。而随转故。如芽起影灯焰发明。大于所造。得成因义。如是五因。但是能作。因之差别。大望所造。为余五因。理不成故。且诸大种。望所造色。非俱有因。非一果故。岂不大种与生等相非同得一所造色果。非不相望为俱有因。虽非同得一所造果。而更有余同一果义。大与所造必无一果。故例生等。理定不齐。又诸大种。与生等相。设互相望。不同一果。而互为果。故得成俱有因。大与所造。无如是义。岂不心与心之随相非互为果。而心与相。为俱有因。大与所造。亦应如是。何故非因。此例非等。心与随相。虽复相望非互为果。而彼随相互为果法。定有与心互为果义。又心随相与心一果。故心与彼为俱有因。大与所造。无如是事。故大于彼。非俱有因。又所造色。有善不善。大种一向无记性摄。非如是相成俱有因。若尔大种。望无记造色。应成俱有因。不尔所造善不善无记。同一种类故。同一类色。少分以大种为因少分非大种为因。无如是理。如一类法少分与心相应。少分非心相应。无如是义。又许大种在过去世。所造之色通去来。今非俱有因有如是理。又成就别。故无此因。谓有成就。诸所造色。非四大种。或有成就。能造大种。非所造色。非俱有因有如是相。故大与造。非俱有因。非相应因。不相应故。亦非遍行及异熟因。大种无覆无记性故。非同类因。俱时起故。设后起者。非同类故。虽有无记同。而种类异故。如心受等。种类虽别。而互相望。为同类因。大与所造。亦应尔者。理亦不然。受等与心。种类虽别。而同一果。故得为因。由此应知。说缘道理。又本论中。亦有文证。大望造色。无五种因。如说有色处非无记为因亦非无记。谓善色处。若诸大种。望所造色。于五因内。随作一因。则此句义。应不成立。若尔应与经论相违。如契经言。因四大种。施设色蕴。本论亦言。大种所造。因增上等。俱不相违。据生因等。说此言故。大与所造。为生因者。从彼起故。如母生子。为依因者。随彼转故。如臣依王。为立因者。能任持故。如地持物。为持因者。由彼力持。令不断故。如食持命。为养因者。能增长故。犹如树根水所沃润。如是则显大与所造。为起变持住长因性。或生因者。一切大种生所造色。非离诸大种有造色生故。造色生已。同类相续。不断位中。火为依因。能令干燥。不烂坏故。水为立因。能为浸润。令不散故。地为持因。能任持彼。令不坠故。风为养因。能引发彼。令增长故。如是大种。虽与所造无俱有等五种因义。而有生等五种别因。故与经论无相违失。此中上座。妄作是言。生等五因。非圣教说。彼谓圣教。曾无此名。未审彼宗。何名圣教。为鸠摩罗设摩文颂。为扇帙略所造论门。且佛教中有此名想。如契经说。爱生士夫爱生自体。又契经说依戒住戒。名色依识。识依名色。颂依文士。又契经说。四食建立摄益求生已生有情。又契经说。水持地等。又契经言。听闻正法。能令如理作意圆满。乃至广说。汝等由信。弃舍家法。趣于非家。信所长养。制睡眠力。乃至广说。唯汝所执。旧随界因。诸圣教中。都无说处。诸所造色。自互相望。但有三因。所谓俱有同类异熟。据所造类。容有三因。非一切有俱有因者。谓随心转身语二业七支相望。展转为因。同类因者。一切前生。于后同类。异熟因者。谓诸不善及善有漏。身语二业。能招异熟眼根等果。所造于大但为一因。谓异熟因。身语二业。能招异熟大种果故。已辩诸法尔所缘生。当随宗委辩等无间缘义。前虽总说诸心心所已生。除最后为等无间缘。未决定说。何心无间有几心生。复从几心有何心起。今当定说心有多种。如何依彼可定说耶。且略说心有十二种。云何十二。颂曰

  欲界有四心　　善恶覆无覆
  色无色除恶　　无漏有二心

论曰。且于欲界。有四种心。谓善不善有覆无记无覆无记。色无色界。各有三心。谓除不善。余如上说。如是十种说有漏心。若无漏心。唯有二种。谓学无学。合成十二。此十二心。互相生者。颂曰

  欲界善生九　　此复从八生
  染从十生四　　余从五生七
  色善生十一　　此复从九生
  有覆从八生　　此复生于六
  无覆从三生　　此复能生六
  无色善生九　　此复从六生
  有覆生从七　　无覆如色辩
  学从四生五　　余从五生四

论曰。欲界善心无间生九。谓自界四。色界二心。于入定时及续生位。如其次第。生善染心。生何善心。复何地摄。此于初位。生加行心。若于后时。生离欲得。随顺住故。无容起彼生得善心。生在此间。不能令彼起现前故。有说彼心未至地摄。有言亦摄在初静虑。有说亦在静虑中间。尊者妙音。作如是说。乃至亦在第二静虑。如超定时。隔地而起。有作是说。非等引心无力能牵隔地心起。是故彼说。理定不然。及无色一。于续生位。欲善无间。生彼染心。并学无学。随顺住故。欲善无间。必定不生色无色缠无覆无记。彼皆系属自界心故。亦定不生无色界善。以彼于此四远远故。一所依远。二行相远。三所缘远。四对治远。即此复从八无间起。谓自界四。色界二心。于出定时。从彼善起。被初静虑。染定恼时。从彼染心。生于欲善。求依下善为防退故。及学无学。谓出观时。染谓不善有覆无记。二各从十无间而生。谓自界四。色无色六。于续生位。上界六心。皆可命终生欲二染。必无无漏生染污心。故此非从学无学起。即此无间。能生四心。谓自界四。余无生理。必无下地染心无间能生上地。及无漏心。余谓欲缠无覆无记。此心从五无间而生。谓自界四。及色界善。欲界化心。从彼生故。即此无间能生七心。谓自界四。及色界二。善与染污。于入定时。欲界化心。还生彼善。于续生位。欲界无覆。生彼染心。并无色一。于续生位。此无覆心。能生彼染。如是已辩。欲界四心无间。从生能生决定。色界善心无间生十一。谓除无色。无覆无记心。异熟生心。属自界故。即此复从九无间起。谓除欲界二染污心。及除无色无覆无记。有覆从八无间而生。除欲二染。及学无学。即此无间能生六心。谓自界三。欲善不善有覆无记。无覆从三无间而起。谓唯自界。余无生理。即此无间能生六心。谓自界三。欲无色染。已辩色界三心相生。无色界善无间生九。谓除欲善欲色无覆。即此从六无间而生。谓自界三。及色界善。并学无学。有覆无间能生七心。谓自界三。及色界善。欲色界染。即此亦从七无间起。谓除欲色染。及学无学心。无覆如色说。从三无间生。谓自界三。余皆非理。即此无间能生六心。谓自界三。及欲色染。已辩无色三心相生。学心从四无间而起。谓即学心。及三界善。即此无间能生五心。谓前四心。及无学一。非三界染。互相违故。非诸无覆。不明利故。余谓无学从五无间生。谓三界善。及学无学二。即此无间能生四心。谓三界善。及无学一。不生学心。彼非果故。非染无覆。如前说故。说十二心互相生已。云何分此为二十心。颂曰

  十二为二十　　谓三界善心
  分加行生得　　欲无覆分四
  异熟威仪路　　工巧处通果
  色界除工巧　　余数如前说

论曰。三界善心。各分二种。谓加行得。生得别故。欲界无覆。分为四心。一异熟生。二威仪路。三工巧处。四通果心。色无覆心。分为三种。除工巧处。上界都无造作种种工巧事故。无色界无行等事故。无威仪路。无摄受支三摩地故。亦无通果。有谓无色。不缘色等为境界故。彼界无有威仪路等二无记心。彼即应许空无边处近分定有威仪路等。若谓彼定此无容有。故无过者。前即非因虽缘色等为境界者。彼亦许此无容有故。依如是理。欲界有八。色界有六。无色有四。学无学心。合为二十。如是二十。互相生者。且说欲界八种心中加行善心无间生十。谓自界七。除通果心。自类净定无间生故。及色界一。加行善心。并学无学。即此复从八无间起。谓自界四。二善二染。及色界二。加行有覆并学无学。生得善心无间生九。谓自界七。除通果心。及色无色有覆无记。即此复从十一心起。谓自界七。除通果心。及色界二。加行有覆。并学无学。二染污心无间生七。谓自界七。除通果心。即此复从十四心起。谓自界七。除通果心。及色界四。除加行善与通果心。并无色三。除加行善。异熟威仪无间生八。谓自界六除加行善与通果心。及色无色有覆无记。即此复从七无间起。谓自界七。除通果心。工巧处心无间生六。谓自界六。除加行善与通果心。即此复从七无间起。除通果心。从通果心。无间生二。谓自界一。即通果心。及色界一。即加行善。即此亦从二无间起。谓即前说自色二心。说欲界心互相生已。次说色界。六种心中。从加行善心无间生十二。谓自界六。及欲界三。加行生得与通果心。并无色一。加行善心。学无学心。即此复从十无间起。谓自界四。除威仪路与异熟生。及欲界二。加行通果。并无色二。加行有覆。学无学心。生得善心无间生八。谓自界五。除通果心。及欲界二。不善有覆。并色界一。有覆无记。即此无记无间生九。谓自界五。除通果心。及欲界四。二善二染。即此复从十一心起。谓自界五。除通果心。及欲界三。即生得善。威仪异熟。并无色三。除加行善。异熟威仪无间生七。谓自界四。除加行善与通果心。及欲界二。不善有覆。并无色一。有覆无记。即此复从五无间起。谓自界五。除通果心。从通果心无间生二。谓自界二。加行通果。即此亦从二无间起。谓即前说自界二心。说色界心互相生已。次说无色。四种心中。加行善心无间生七。谓自界四。及色界一。加行善心。并学无学。即此复从六无间起。谓自界三。唯除异熟。及色界一。加行善心。并学无学。生得善心无间生七。谓自界四。及色界一。有覆无记。并欲界二。不善有覆。即此复从四无间起。谓自界四。有覆无记无间生八。谓自界四。及色界二。加行有覆。并欲界二。不善有覆。即此复从十无间起。谓自界四。及色界三。生得异熟与威仪路。并欲界三。名如色说。异熟生心无间生六。谓自界三。除加行善。及色界一。有覆无记。并欲界二。不善有覆。即此复从四无间起。谓自界四。说无色心互相生已。次说无漏。二种心中。从有学心无间生六。谓通三界加行善心。及欲生得。并学无学。即此复从四无间起。谓三加行。及有学心。从无学心无间生五。谓前有学所生六中。除有学一。即此复从五无间起。谓三加行。及学无学。复有何缘。加行无间。能生异熟工巧威仪。非彼无间生加行善。且异熟生。由先业力所引发故。势力羸劣。非作功用所引发故。不能引起加行善心。故彼不能生加行善。出心不由功用转故。加行无间。生彼无违。工巧威仪。势力羸劣。乐作功用。引发工巧及威仪故。不能引起加行善心。出心不由功用转故。加行无间。生彼无违。若尔染心。不应无间生加行善。染着境界。违背善故。势力劣故。无甚过失。厌倦烦恼。数数现前。作是思惟。设何方便。令无义聚止息不行。便如实知起过失境。能生功德。脱我当起烦恼现前。寻复觉知。起善防护由斯愿力。能起加行。无始时来。数习染故。势力不劣。故染无间。生加行善。欲界生得。行相明利。非胜功用之所引发。以明利故。可有从彼学无学心色界加行无间而起。非胜功用所引发故。不能从此引生彼心。色无色界。生得善心。不明利故。非胜功用所引发故。非学无学。他界加行无间而起。亦非从此引生彼心。又欲生得。以明利故。可从色染无间而生。能为防护。色界生得。不明利故。非无色染无间而起。作意有三。谓自共相胜解作意。有差别故。云何名为自相作意。谓观诸色变碍为相。乃至观识了别为相。如是等观相应作意。云何名为共相作意。谓十六行相应作意。云何名为胜解作意。谓不净观。及四无量。有色解脱。胜处。遍处如是等观相应作意。如是三种作意无间。圣道现前。圣道无间。亦能具起三种作意。若作是说。便顺此言。不净观俱行修念等觉分。有余师说。唯从共相作意无间。圣道现前。圣道无间。方能具起三种作意。若尔何故。契经中言。不净观俱行修念等觉分。由不净观。调伏心已。方能引生共相作意。从此无间。圣道现前。依此展转密意而说。故无有过。有余复言。唯从共相作意无间。圣道现前。圣道无间。亦唯能起共相作意。此言有失。所以者何。依未至等三地。证入正性离生。圣道无间。可生欲界共相作意。以欲界中共相作意去彼圣道非极远故。若依第二第三第四静虑。证入正性离生。圣道无间。起何作意。非起欲界。共相作意以极远故。又于彼地。无容有故。以非彼地已有曾得共相作意。异于曾得顺决择分。非诸圣者顺决择分可复现前。非得果已可重发生加行道故。彼今应说。此圣道后。起何共相作意现前。岂不系属顺决择分。亦修彼类共相作意。如观诸行皆是无常。观一切法皆是无我。涅槃寂静。圣道无间。引彼现前。此救非理。系属加行所修作意。非得果后可引现前。是彼类故。前说圣道无间。通三作意现前。于理为善。若依未至定。得阿罗汉果。后出观心。或即彼地。或是欲界。依无所有处。得阿罗汉果。后出观心。或即彼地。或是有顶。若依余地。得阿罗汉果。后出观心。唯自非余。地于欲界中有三作意。一闻所成。二思所成。三生所得。色界亦有三种作意。一闻所成。二修所成。三生所得。无思所成。举心思时。即入定故。无色唯有二种作意。一修所成。二生所得。欲界闻思作意无间。圣道现前。圣道无间。具起三种作意现前。以诸圣道起必系属。加行道故。非生得善作意无间圣道现前。色界闻修作意无间。圣道现前。圣道无间。亦唯起彼二种作意。无色唯修作意无间。圣道现起。圣道无间。亦唯起修。不起生得。若生第二静虑以上。起初静虑三识身时。诸有未离自地染者。彼从自地善染无记作意无间。二识现前三识无间。还生自地三种作意。诸有已离自地染者。除染作意。唯善无记作意无间。三识现前。三识无间。亦唯起此二种作意。于前所说十二心中。何心现前几心可得。颂曰

  三界染心中　　得六六二种
  色善三学四　　余皆自可得

论曰。欲色染心正现前位。十二心内。各得六心。无色染心正现前位。十二心内。唯得二心。为一刹那。应言不尔。且起欲界染污心时。或界退还。或续善本。或退胜德。于此三位。随容有数。总得六心。界退还时。除自无覆。定得自界。善等三心。色界染心。亦容可得。续善本位。得自善心。以疑心中续善根故。退胜德位。三界染心。及有学心。皆容可得。若起色界染污心时。或界退还。或退胜德。随容有数。亦得六心。界退还时。得自三种。及得欲界无覆无记。谓通果心。退胜德位。色无色界二染污心。及有学心。皆容可得。若起无色染污心时。顿得二心。谓学自染。此中唯有退胜德位。色界善心。正现前位。十二心内。容得三心。谓自善心。及欲色界无覆无记。由升进故。有说根本静虑起时。顿得三心。即如前说。若泛说得。此义非无。然于尔时。唯得后二。以前一种先已得故。若不尔者。此位学心。亦容可得。应言得四。若有学心。正现前位。十二心内。容得四心。谓有学心。及欲色界无覆无记。并无色善若初证入正性离生。尔时学心。即名为得。若以圣道。离欲界染。最后所起解脱道时。得欲色界无覆无记。若以圣道。离色界染。得无色善。此中离言。非究竟离。以于色染未全离时。无色善心。已可得故。有说全离色界染时。得无色界根本地善。若尔应说亦得学心。离欲染时。亦得色善。是则应说。学心得五。余谓前说染等心余。谓三界三无覆无记。欲无色善。及无学心。不说彼心正现前位得心差别。应知彼心。正现前位。唯自可得。色无覆心。正现前位。都无所得。前已得故。不应说言皆自可得。岂不无学心正起时亦容得四。谓三界善。初尽智时。未来修故。非先已得。有未来修。如何可言此唯自得。又无色善正现起时。亦得学心。宁唯自得。今言得者。非先所成。如后颂说。故无此难。若不尔者。色善得三。学心得四。亦不应说容得余故。此义应思。有余但言。心有十一。以学无学同无漏故。即约此义。总说颂曰

  慧者说染法　　现起时得九
  善心中得六　　无记唯无记

欲界染心。界退还位。除自无覆。得自界三。色界染心。界退还位。得自善染。欲色无覆无记染心。退无学位。得自界染及有学心。此约界论。得心多少。非约地辩。故得九心。无色善心。无容得故。有余师说。染得十心。以无色中退生下地。染心起位得自善心。虽言得心约界而立。如亦可说得无漏心。得地善心何缘不说。言善心中得六心者。谓以正见。续善根时得欲界善。离欲染时。应知顿得欲色无覆。初入定时。如应别得色无色善。初入离生位。证阿罗汉时。得学无学。若尔何故。言得六心。如经主难应言得七。然学无学。同无漏故。总说一心。言六无失。有余师释。得尽智时。顿得六心。谓三界善。欲色无覆。及无漏心。虽约别时。亦容得六。而据顿得。故说此时。泛说无违。非今颂意。为摄前义。复说颂曰

  由托生入定　　及离染退时
  续善位得心　　非先所成故

说一切有部顺正理论卷第二十阿毗达磨顺正理论卷第二十一

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩缘起品第三之一

已依三界。辩得心等。今应思择。三界是何。各于其中。处别有几。颂曰

  地狱傍生鬼　　人及六欲天
  名欲界二十　　由地狱洲异
  此上十七处　　名色界于中
  三静虑各三　　第四静虑八
  无色界无处　　由生有四种
  依同分及命　　令心等相续

论曰。那落迦等下四趣全。及天一分。眷属中有。并器世间。总名欲界。天一分者。谓六欲天。一四大王众天。二三十三天。三夜摩天。四睹史多天。五乐变化天。六他化自在天。如是欲界地狱趣等。并器世间。总有十处。地狱洲异。分为二十。八大地狱。名地狱异。一等活地狱。二黑绳地狱。三众合地狱。四号叫地狱。五大叫地狱。六炎热地狱。七大热地狱。八无间地狱。言洲异者。谓四大洲。一南赡部洲。二东胜身洲。三西牛货洲。四北俱卢洲。如是十二。并六欲天。傍生饿鬼。处成二十。若有情界。从自在天。至无间狱。若器世界。乃至风轮。皆欲界摄。已说欲界并处不同。此欲界上。处有十七。谓三静虑处各有三。第四静虑处独有八。器及有情。总名色界。第一静虑处有三者。一梵众天。二梵辅天。三大梵天。第二静虑处有三者。一少光天。二无量光天。三极光净天。第三静虑处有三者。一少净天。二无量净天。三遍净天。第四静虑处有八者。一无云天。二福生天。三广果天。并五净居处合成八。五净居者。一无繁天。二无热天。三善现天四善见天。五色究竟天。广善所生故名为梵。此梵即大。故名大梵。由彼获得中间定故。最初生故。最后殁故。威德等胜故。名为大。大梵所有所化所领。故名梵众。于大梵前。行列侍卫。故名梵辅。自地天内光明最小。故名少光。光明转胜量难测故。名无量光。净光遍照自地处故。名极光净。意地受乐。说名为净。于自地中此净最劣。故名少净。此净转增量难测故。名无量净。此净周普。故名遍净。意显更无乐能过此。以下空中天所居地。如云密合。故说名云。此上诸天。更无云地。在无云首。故说无云。更有异生胜福方所可往生故。说名福生。居在方所。异生果中此最殊胜。故名广果。离欲诸圣。以圣道水。濯烦恼垢。故名为净。净身所止。故名净居。或住于此。穷生死边。如还债尽。故名为净。净者所住。故名净居。或此天中。无异生杂。纯圣所止。故名净居。繁谓繁杂。或谓繁广。无繁杂中此最初故。繁广天中此最劣故。说名无繁。或名无求。不求趣入无色界故。已善伏除杂修静虑上中品障。意乐调柔。离诸热恼。故名无热。或令下生烦恼名热。此初离远。得无热名。或复热者。炽盛为义。谓上品修静虑及果。此犹未证。故名无热。已得上品杂修静虑。果德易彰。故名善见。杂修定障。余品至微。见极清澈。故名善见。更无有处于有色中能过于此。名色究竟。或此已到众苦所依身最后边。名色究竟。有言色者。是积集色。至彼后边。名色究竟。此十七处。诸器世间。并诸有情。总名色界。有余别说十七处名。初静虑中。总立二处。第四静虑。别说无想。彼师应言。处有十八。以彼大梵。望梵辅天。寿量身量。无寻受等。皆有别故。岂不无想望广果天。唯异生等有差别故。前亦应言处有十八。此难非理。无想天生。即广果天系业果故。若尔大梵所受生身。亦梵辅天系业果故。不应别说为一天处。即梵辅天上品系业。招大梵果。此业望彼。少有差别。故招寿等。亦少不同。若大梵天。望彼梵辅。寿量等别。合为一处。则少光等。寿等虽殊。应合一处成大过失。此例不然。大梵一故。要依同分。立天处名。非一梵王可名同分。虽寿量等与余不同。然由一身不成同分。故与梵辅合立一天。高下虽殊。然地无别。少光天等。与此相违。故彼不应引之为例。上座色界立十八天。故作是言。修诸静虑。各有三品。谓上中下。随三品因。生三天处。第一静虑。大梵天王。自类相望。得有同分。与梵辅处。胜劣有殊。如聚落边阿练若处。虽相邻近。而处不同。无想有情。于第四定。为第四处。与广果天。有差别故。处成十八。此亦不然。初静虑地。处应四故。无想有情。应离广果不别立故。若谓随修三品静虑。诸静虑地。处各三者。则大梵王。寿等胜故。应异初定上中下因别用中间胜定业感。故应大梵异初定三。别业所招。成第四处。或应大梵无别有因。无想有情。与彼广果。寿身量等。无差别故。应无异因。处非第四。故立十八。理必不成。又若必然。应色究竟寿量身量三十二十。或六十四。然俱不许。是故不可约修静虑三品不同立处有别。因虽有四。处但立三。因但有三。处立四故。又初静虑。处若有三。应大梵王望梵辅处。高广迥隔。如上下天。亦应倍增寿量身量。是则一切建立不成。然梵众天。寿量半劫。身量亦有半踰缮那。至大梵天。量皆一半。若立大梵处为第三。应寿与身量增至二。是则以上。皆应倍增。诸所建立。皆不成就。是故迦湿弥罗国。诸大论师。咸说大梵王所居。即梵辅处。由兹色界。处唯十六。如是所说。善顺契经。七识住中。唯举边故。如极光净及遍净天。若谓不然。契经应说。如大梵处非梵众天。无想有情望广果处。寿等无异。如何别立。彼复说言。第一静虑。非无寿等建立差别。以彼三天半半增故。若尔大梵。应亦倍增。是则上天建立皆坏。无斯过失。许少光天望大梵天亦半增故。此唯妄执。未见色天。别处极成。有半增故。又坏正理。所以者何。既许依修三品静虑。得三品果。建立三天。何理中天倍增于下。然其上处半胜于中。故彼所言。唯凭妄执。是故建立色界诸天。唯我国师。所说无乱。已说色界并处不同。无色界中。都无有处。以无色法无有方所。过去未来。无表无色。不住方所。理决然故。但异熟生。胜劣差别。说有四种。一空无边处。二识无边处。三无所有处。四非想非非想处。如是四种。名无色界。此四非由处有上下。但由生故。胜劣有殊。复云何知。彼无方处。谓于是处。得彼定者。命终即于是处生故。复从彼殁。生欲色时。即于是处。中有起故。虽由生故四种不同。而无上下方处差别。四种何缘次第如是。由渐离欲渐得定故。或即由生次第如是。随生因力。果少多故。如有色界。一切有情。要依色身。心等相续。于无色界。受生有情。以何为依。心等相续。何缘于此欻复生疑。以诸法中都无有我。心心所法。在欲色中。依托色身。可相续转。于无色界。既无色身。心等应无相续转义。故今于此可复生疑。当知彼依同分及命。心等相续。非我为依。及声摄余不相应行。谓得非得。及与生等。非于此中显同分等实有自体。前已成故。但显彼用。谓能为缘。缘谓为依令心等续。眼等四识。一一皆用无间灭意及自色根。为其所依。及为依性。以自色根所依大种。身根及大。同分命根。得等生等。但为依性。身识即用意及身根。为其所依。及为依性。但以身根所依大种。同分命根。得等生等。为其依性。非为所依。意识但以无间灭意。为其所依。及为依性。身根及大。同分命根。得等生等。但为依性。如是欲色有情心等。依色同分命等相续。无色有情。以无色故。但依同分及命根等。心等相续。非无有依。依与所依。二相何别。今详宗趣。二相别者。要由彼有此方得生。无则不生。是为依相。定有彼相及随变者。是谓为依及所依相。岂不虽有色同分等。而或有时心等不续。如何说彼为心等依。此责不然。以有别法。能违心等。令不续故。心等续位必有彼依。故彼得为心等依相。现见心等。于死身内。毕竟不生。于生身中。心心所法。决定当起。故彼色等。依相极成。由此故知。色声香等。于心心所。不能为依。以外事中有色声等。然心心所。曾不转故。前所依相。应非遍有。非诸心等皆随所依而转变故。心等不随无间灭意定有转变。如何可说彼为所依。心等定随意根转变。夫随变者。谓令改易。无间灭意。于正灭时。令后心等入正生位。意根已灭。心等已生。如是即成后随前变。非同分等为心等依。如眼等根无间灭意。故所依相与依相别。遍诸所依无相滥过。如是欲色诸有情心。四蕴俱生。咸为依性。唯一色蕴。得为所依。意识所依。亦应兼色。随色变故。现见大种。酒等恼时。心便改易。无容意识色为所依。夫成所依。定能生变意识非定随大变生。设大种无。此亦有故。由是大种。望于意识。唯可成依。非所依性。是故六识欲色界中。用四蕴为俱生依性。无色意识。无复色依。彼俱生依。但通三蕴。若尔何故。但言无色心等依于同分及命。此说定同无乱依故。谓心心所。虽互为依。而非定同。不自依故。亦非无乱。在此地生。乱起自他心心所故。同分及命。心等同依。又此地生。唯此地故。依此设起不同地心。由此还令自地心起。唯依此二。名此地生。牵引业生。无间断故。由斯说是同不乱依。心等不然。故略不说。若无此二。余地四蕴。现在前时。尔时有情。应名余地。非此地摄。自地先业。所牵引果。不相续故。然不应许。是故当知。如欲色界。身同分命。为心等依。虽或有时异地心起。而依身等。于此生中。后定当牵自地心起。如是无色。虽无有身。心等定依同分及命。故颂偏说。同分命根。此是牵引业异熟故。是余异熟相续住因。譬如树根茎等依住。现见诸树叶枝茎等。虽同种生。而依根住。是故不应谓眼根等唯依业住无别有依。由斯已释。生无色界业生心等。须别依因。故本论中。不作是说。心转即用相应为依。即由此因得非得等。及声总显不说别名。谓彼非唯业所生故。设业生者。非恒续故。如何彼法。为心等依。谓彼若无。自地心等。必不生故。犹如身等。或由彼是无乱因故。非生上地成就下善。又无成异地异生性等故。彼为依性。其理极成。有余师言。如坑堑等。虽无风等。灯焰不生。彼法若无。心等不起。故知心等用彼为依。或有门人。作是征诘。不相应行。应如色身。亦能为依。生意识等。故但为说不相应行为心等依。非无色界俱生四蕴无相依义。然于此中。心与受等。为所依性。非彼受等为心所依。非所随故。要心总了境界相时。受等方能取差别相。故彼随心。非心随彼。然心心所。名互相依。互随转者。同一果故。何缘不说。欲色界中。此二为依。心等相续。而但说彼依于色身。欲色界中。身同分等。虽恒相续。皆能为依。而身粗显。是故偏说。或为成立同分命根离身别有。故作是说。非于无色。或余地中。业生心等。恒现前故。或显同分及命根等亦依身转。故作是说。虽彼与身互相依止。而身胜故。偏说为依。岂不命根为身依性。亦是殊胜。命根若无。身根等法。皆不转故。虽无命根彼皆不转。而身多遇灾横等缘。命等随身亦有损益。故身与彼为依义胜。即由此义。对法诸师说。无色中以无身故。同分命等。更互相依。经主此中。假为宾主。谬增正义。作是难言。若尔有色有情心等。何不但依此二相续。谓对法者。作是释言。有色界生。此二劣故。无色此二。因何故强。彼界二从胜定生故。由彼等至。能伏色想。若尔于彼。心等相续。但依胜定。何用别依。又今应说。如有色界受生有情。同分命根。依色而转。无色此二。以何为依。此二更互相依而转。有色此二。何不相依。有色界生。此二劣故。无色此二。因何故强。彼界二从胜定生故。前说彼定能伏色想。是则还同心相续难。或心心所。唯互相依。经主定于阿毗达磨。无所承禀。谬述此言。或由自心憎厌对法。矫作是说。惑乱正宗。谁有妙通诸法相者。当作如是酬前所问。彼立自宗言。无色界心等相续。无别有依。谓若有因。未离色爱。引起心等。所引心等。与色俱生。依色而转。若因于色。已得离爱。厌背色故。所引心等。非色俱生。不依色转。此亦非理。若引因力。令彼心等相续转者。善与染心。现在前位。心等相续。应无所依。又如有情在欲色界。引因力故。心等相续。与色俱生。依色而转。如是有情。在无色界。引因力故。心等相续。与众同分命根俱生。不依于色。唯依同分命根而转。既许欲色有情心等。不依色身定无转义。何因无色有情心等。都无所依。而有转义。又彼现许欲色界中心等相续。虽一业果。而必依余心等方转。于无色界何不许然。又不应说唯有于色未离爱因所引心等依色而转。现有于色已离爱因。所引心等。与色俱生。依色而转。生欲色界。色爱已除。无色界心。现在前故。彼虽无色心现在前。而彼有情。不名无色。未离色爱。因果为依。此无色心。相续转故。下界现起无色界心。既别有依。上亦应尔。又生无色。起余地心。或起无漏。若无自地少法为依心相续者。当言此是何地有情。如是推征。前已数辩。是故经主。所见非妙。上座此中。言无色界心与心所更互相依。如二芦束相依而住。或如下界名色相依。应诘彼言。如欲色界。虽名四蕴。更互相依。而许彼名别依色转。如是无色心所与心虽相依止。然复应许别有所依。得相续住。是故违背对法正理。必无有能证义真实。如本论说。云何欲界。谓有诸法。欲贪随增。色无色界。亦复如是。为显诸法三界现行。非皆彼系。故作是说。岂不诸法非异界地烦恼随增。应举一切自界烦恼随增显别。理实应然。但说多分随眠显别。以诸有情多分现起贪随眠故。言欲贪者。谓欲界贪。色无色贪。亦复如是。略说段食。淫所引贪。可立欲名。如经颂说

  世诸妙境非真欲　　真欲谓人分别贪
  妙境如本住世间　　智者于中已除欲

为显贪欲名异体同。故说此颂。欲所属界。说名欲界。色所属界。说名色界。略去中言。故作是说。如胡椒饮。如金刚环。于彼界中。色非有故。名为无色。所言色者。是变碍义。或示现义。彼体非色。立无色名。非彼但用色无为体。无色所属界。说名无色界。略去中言。喻如前说。又欲之界。名为欲界。由此界能任持欲故。色无色界。应知亦然。若界有色而无定者。是名欲界。若界有色亦有定者。是名色界。若界无色而有定者。是无色界。或界有色有欲境者。是名欲界。若界有色无欲境者。是名色界。若界俱无。是无色界。或界虽有五蕴异熟。而无五蕴为异熟因同得一果。是名欲界。若界俱有。是名色界。若界俱无。是无色界。或界多分具一切色。是名欲界。若界一切于色阙减。是名色界。若界一切色法皆无。是无色界。或界有色。亦有多趣。是名欲界。若界有色。而无多趣。是名色界。若界无色。亦无多趣。是无色界。如是等别。有无量种。三界为一。为复有多。三界无边。如虚空量。故虽无有始起有情。无量无边佛出于世。一一化度无数有情。令证无余般涅槃界。而不穷尽。犹若虚空。世界当言云何安住。当言傍生。故契经言。譬如天雨滴如车轴。无间无断。从空下澍。如是东方。无间无断。无量世界。或坏或成。如于东方。南西北方亦复如是。不说上下。有说。亦有上下二方。余部经中。说十方故。色究竟上。复有欲界。于欲界下。有色究竟。如是展转。世界无边。若有离一三界贪时。诸三界贪。无不灭离。依初静虑。起通慧时。所发神通。但能往至自所生界梵世非余。所余通慧。应知亦尔。勿有于境太过失故。已说三界。趣复云何。何处几种。颂曰

  于中地狱等　　自名说五趣
  唯无覆无记　　有情非中有

论曰。于三界中。随其所应。说有五趣。如自名显。谓前所说。地狱傍生鬼及人天。是名五趣。唯于欲界。有四趣全。三界各有天趣一分。为显有界非趣所摄。故三界中说有五趣。善染无记。有情无情。及中有等。皆是界性。趣体唯摄无覆无记及与有情。而非中有。言趣体唯摄无覆无记者。唯异熟生。为趣体故。由此已释。趣唯有情。无情中无异熟生故。中有非趣。后当广辩。趣体唯摄无覆无记。有何圣教。能定证知。谓七有经。且可为证。经说七有。谓地狱有。傍生有。饿鬼有。天有。人有。业有。中有。此中业有。是五趣因。简趣异因。是故别说。此经为显趣体唯摄无覆无记。故简异因。然经主言非别说故。定非彼摄。如五浊中。烦恼与见别说为浊。非别说故。彼见定非烦恼所摄。如是业有。虽亦是趣。为显趣因所以别说。故有说趣体兼善染。彼言非理。无处说故。有处说见亦是烦恼。虽有所因。别说为浊。而准余说。知即烦恼。曾无有处说诸趣因业即趣体可为诚证。虽有所因。别说为有。而准彼说。知业是趣。如何定知业是趣体。有所因故。有中别说。而非业有。体非是趣。为显趣因说为业有。故所引喻。于证无能。又彼所言。有太过失。应执中有亦趣摄故。然彼释言。由与趣义不相应故。二趣中间。故名中有。此若趣摄。应非中有。如是所释。后更研寻。且五浊经。于证无力曾无处说业是趣故。既许中有。由与趣义不相应故。非是趣体。业亦应然。亦与趣义不相应故。定非趣体。业若趣体。趣应相杂。于一趣身中。有多趣业故。若趣因业即是趣者。人有地狱业或现前。彼应是人亦是地狱。亦不应说地狱趣体。虽现在前。而非地狱。如是则有太过失故。谓异熟果正现在前。应非地狱。无差别故。然契经说。异熟起已。名那落迦。故业非趣。又业是趣。与理相违。犹如中有。是趣因故。趣谓所往。中有不应是所往处。由此能往正所生处。故非趣摄。如是业有。既许趣因。非所趣处。亦非趣摄。是故应知。趣体唯摄无覆无记。其理极成。唯异熟生。是诸趣体。何缘证知。契经说故。经说舍利子作是言。具寿。若有地狱诸漏现前故。造作增长顺地狱受业。彼身语意曲秽浊故。于那落迦中。受五蕴异熟。异熟起已。名那落迦。除五蕴法。彼那落迦。都不可得。此中既说。除异熟生色等五蕴。无别地狱。异熟起已。名那落迦。故知趣体唯是异熟。虽彼释言为遮实有能往诸趣补特伽罗。故作是说。除五蕴法。彼那落迦。都不可得。非遮余蕴。故作是言。然是自心虚妄计度。经说异熟五蕴起已方得名为那落迦故。又言除此异熟蕴法。彼那落迦不可得故。非蕴法言是总相说。乘前异熟五蕴起故。此言亦能兼遮实有。能往诸趣补特伽罗。许异熟蕴。总遮余故。又彼所言。异熟起已名地狱者。说异熟起方名地狱。非说地狱唯是异熟。此亦随情妄作斯解。其次即有简别说故。谓除次前异熟蕴法。彼那落迦。都不可得。若诸趣体非唯异熟。何故要言。异熟起已方名地狱。非于前位异熟诸蕴。先未起时已有地狱。能招业有。非于尔时已名地狱。故知地狱唯异熟生。非彼地狱能招业有。于异熟起未起位中。现行成就。少有差别。是故趣体唯异熟生。非善染等。理极成立。有余师说。亦通长养。彼违契经。不可依信。言地狱诸漏现在前故者。应言地狱烦恼是何。而今说为地狱诸漏。非地狱等诸趣烦恼。如初定等系地各别。然诸趣业定有别故。能起烦恼。如业而说。非趣体唯无覆无记。便与品类足论相违。彼说五趣一切随眠。所随增者。彼依五部能结生心。故作是说。趣及人心。总说为趣。无相违过。譬如村落及村落边总名村落。中有非趣。何缘故知。由经论理为定量故。且由经者。谓七有经。别说五趣。因方便故。言由论者。施设论说。四生摄五趣。非五摄四生。不摄者何所谓中有。法蕴论说。眼界云何。谓四大种所造净色。是眼眼根眼处眼界。地狱傍生鬼人天趣。修成中有。言由理者。趣谓所往。中有不然。如前已说。又彼即于死处生故。非所往处。故非趣体。然有难言。若尔无色亦应非趣。即于死处受生故者。彼难非理。以诸无色死处即生。不往余处。故是趣体。中有虽是死处即生。然往余处。故非趣体。经主复言。既尔中有名中有故。不应名趣。二趣中故名中有者。此不应理。因不成故。若许中有非趣极成。可作是言。二趣中故名为中有。中有非趣。既不极成。如何可言。二趣中故名为中有。名中有故。因义不成。设许中有是趣体者。顺彼受业。若未离贪。定在死生二有中起。故名中有。非说彼在二趣中故名为中有。然无本有名中有过。在中有地生死中间。容有不起本有者故。谓或容有生有无间死有现前。非起本有。必无容有在中有地死有无间生有现前。故中有名。不滥余有。虽亦有说欲色界中非定一切有中有者。此后思择中有义中。当立定有破彼所说。或容彼在异类二生中间起故。名为中有。非在二趣中间有故其本有等。无如是事。又经主言。此若趣摄。非中间故。是则不应名中有者。亦不应理。所以者何。设是趣摄。如前所释。成中有故。中有非趣。前说理成。经主后言不堪为证。此中上座作如是言。若许中有非趣所摄。彼即应说。离五趣外。别有能感中有起业。此无有失。是所许故。谓我宗中。许五趣体唯是无记。中有起业。唯是不善善有漏故。由是当知。离五趣外。别有能感中有起业。然此中有。即趣业果。谓业能招诸趣果者。此即能感往趣方便。往趣方便。即名中有。如同所许。化非化生。是一业果。如是应许趣非趣摄。一业所招。中般涅槃。由此成立。顺定受业。已与果故。若别业果。生有等业。未与果故。应不能起永断余结圣道现前。岂不生结彼已断故。能起如是圣道现前。如契经说。应知如是补特伽罗。已断生结。未断起结。故不成证。如何二结同一地系。而前后断。与理无违。故应思求彼经意趣。我今于此。审谛思求见彼契经。有如是意。谓依二断说如是言。二断者何。一得永对治断。二得永不行断。此中初断。谓起结全生结少分。于色界贪。得永离故。于无色贪。未永离故。若第二断。唯是生结。于欲色界。未离贪者。二时容有起结现行。谓住本有。发满业时。及住中有。续中有时。异生位中。造牵引业。已能感此应所受生。彼对治力伏相续故。觉了生有深过患故。住本有中。不能现起能发生有圆满业结。由此毕竟彼业不生。住中有中。彼无现起圣道障故。未至生处。便断余结而般涅槃。由彼无容结生有故。第二生结永不现行。先已得彼非择灭故。由此诸趣。与彼中有。是一业果。其理极成。又必应然。除在中有般涅槃者。无住中有不至生有而命终故。若别业果。应同所余别异业果。以何因故。诸受中有。必复至生。若余有情。在中有位。生有等业。亦已与果。何不同彼中般有情未至生处中有便死。此例不齐。以不还果是中般者。一切生结皆已断故。与生相违。胜对治道已现行故。顺彼受业。已与果故。不至生有便般涅槃。诸余有情。住在中有。生结未断。又无违生胜治道故。顺彼受业。虽已与果。而必当受生有异熟。诸业异熟。势猛速故。然彼上座。觉慧衰微。于无过中。妄兴过难。言若中有非趣所摄。彼即应说离五趣外。别有能感中有起业。胜智于中不应收采。如是总释诸趣体已。次应别解一一趣名。那落名人。迦名为恶。人多造恶。颠坠其中。由是故名那落迦趣。或近人故。名那落迦。造重罪人。速堕彼故。或复迦者是乐异名。那者言无。落是与义。无乐相与。名那落迦。或复落迦是救济义。那名不可。不可救济。名那落迦。或复落迦是爱乐义。不可爱乐。名那落迦。言傍生者。彼趣多分身横住故。或彼趣中。容有少分傍行者故。又类多故。多愚痴故。名曰傍生。言饿鬼者。谓余生中喜盗他物。习悭贪等。又复多是所祀祖宗。又多希求以自存济。又多怯劣。其形瘦悴。身心轻躁。故名饿鬼。人谓令天缘之起慢。我于此类善趣中尊或彼自心多增上慢。或多思虑。故名为人。天谓光明。威德炽盛。游戏谈论。勇悍相陵。或复尊高。神用自在。众所祈告。故名为天。有作是言。阿素洛者。与诸天众。违诤交通。言本是天。威德殊胜。由斯等故。天趣所收。谛现观中。无堪能故。似非人故。多谄曲故。定非天趣。是鬼趣摄。与诸天众。相违诤等。皆非证因。以不定故。且相违诤。非证天因。曾闻有人。共罗刹斗。又闻罗刹与猕猴斗。曼驮多王。破阿素洛。如斯等事。其类寔多。然诸天中。苏陀味胜。阿素洛女。容貌端严。由是相侵。数兴违诤。不由同趣。故彼非天。言互交通。亦不成证。现见贵贱亦互交通。诸耽欲人。重色非族。曾闻大树紧那罗王。有女端严。名为夺意。善财菩萨。纳以为妻。言本是天。亦不成证。是天帝释。赞妻父言。诸赞美言。或实非实。重设支故。矫赞其父。谄爱发言。岂足为证。又彼本住妙高山顶。为天所逼。退就下居。言本是天。亦无有失。又彼傲慢。自谓是天。数与诸天兴师相伐。释天为止。巧慰令欣。应时处言。设虚无过。威德殊胜。亦非证因。曾闻曼驮多王。威德胜于天故。难陀跋难陀等。虽是傍生。然其威德自在。胜诸天众。故阿素洛。唯鬼趣收。亦非第六。曾不说故。然不说为恶趣摄者。恐彼于佛。起毒恶心。因兹长夜受诸剧苦。又由训词。遮彼天摄。素洛名天。是自在义。阿是非义。显彼非天。自在减天。名阿素洛又素洛者。谓极可爱。天极可爱。得素洛名。虽彼亦多受诸快乐。由多谄曲。非极可爱。有说。诸趣或体相杂。异趣相因。而生子故。如鱼身者。鹿子仙人。自昔传闻。其类无量。一身两趣。故有相杂。彼说不然。自业趣定。而彼生缘有种种故。见非情内有有情生。岂彼一身。情非情摄。如庵罗女。因树而生。乔答摩宗。因日光起。故相因有。非证杂因。传说化生有因胎藏。既因胎藏。何谓化生。俗论多虚。不应依信。或异相托。理亦无违。鹿子仙人鱼身者等。由满业异形相不同。其实是人。故趣无杂。自余感赴。因果不同。思择业中。当广分别

说一切有部顺正理论卷第二十一阿毗达磨顺正理论卷第二十二

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩缘起品第三之二

于前所说诸界趣中。如其次第。识住有七。其七者何。颂曰

  身异及想异　　身异同一想
  翻此身想一　　并无色下三
  故识住有七　　余非有损坏

论曰。谓若略说。欲界人天并及下三静虑无色。此七生处。是识住体。若广分别。应随契经。有色有情。身异相异。如人一分天。是第一识住。一分天者。谓欲界天。及初静虑。除劫初起。言有色有情者。是成就色身义。言身异者。谓彼色身。种种显形。状貌异故。彼由身异。或有异身。故彼有情说名身异。言想异者。谓彼苦乐不苦不乐。想差别故。彼由想异。或有异想。或习异想。以成其性。故彼有情说名想异。今应思择。岂不后有身异言故有色已成。前有色言。应无义用。此责非理。于无色中。现见亦有说身言故。若谓身后有想异言。已证身言。唯诠色者。亦不应理。除想已外。余无色中。有疑滥故。或复谓后有如人言故前身言无有滥者。此亦非理。由后说有一分天言。容有滥故。若谓不以一分天言令彼身言滥于无色。依次第故。又于次后。说梵众等诸天言故。理亦不然。非遍说故。非后遍说一切天众皆建立在。余识住中。勿有生疑。一分天者。兼摄有顶第四静虑。故说有色及身异言。非有顶天可言有色。第四静虑。可言身异。一分天言。已简恶处。余人天众。各自名显。故此所说。一分天言。所摄如前。其义成立。由斯有顶。第四静虑。及诸恶处。非识住摄。故有色言具大义用。或言有色为显异因。谓身异因即是有色。要由有色。身方有异。由身有异。想异得成。故有色言。显异因性。由能损益。胜境现前。损益身时。身便变异。即于如是身变异时。令饮食等亦有变异。彼变异故。身异得成。由是便生乐等异想。故言有色是显异因。若必有色言。显身异因者。极光净等。身应有异。又极光净。应无异想。由彼天中身无异故。又诸梵众。想应不一。由彼天中身有异故。由斯所释。理未必然。其理必然。异因定故。谓身有异。定色为因。非色为因令身定异。故极光净等。无身成异失。如眼色为缘生于眼识等。如契经说。眼色为缘。生于眼识。现有眼色。眼识不生。余亦应尔。又如经说。身有轻安。便生受乐。此经意显无染受乐。定轻安为因非身轻安。定能生受乐。此亦应尔。故理必然。若谓眼色定为眼识缘。阙余缘故。有眼识不起。如契经说。能生作意。若不正起。识不生故。既许有色为身异因复阙何缘。令身不异。又受乐体。异于轻安。虽复轻安遍于诸地。无受乐地。可不生乐。有色身异。既无别体。诸有色者。皆应身异。此亦不然。与彼同故。虽诸有色皆身异因。有阙余因。而身不异。谓于欲界初静虑中。有表无表寻伺多识。为因生果。有种种异。故彼有色。为身异因。极光净天等。无彼因故。虽有色因。而身但一。不可以说彼为身异因。则不许言有色故身异。勿说作意能生眼识。便不许说眼色为缘。又彼不应以业生眼故。便不许说眼等为眼因。又彼不应以种生芽故。便不许说水粪等为因。是故不应作如是难。以有色故。令身异者。极光净等。身应有异。言极光净应无异想。由彼天中身无异者。亦不应理。由心于定有厌欣故。如说乐因。又想异言。为遣疑故。谓说身一。想应非异。心随身故。为遣此中想随身疑。故说想异。此言意显极光净天。心不随身。与余天别。言诸梵众。想应不一。由彼天中身有异者。理实应尔。但为显示彼劫初时同于一因。起一执想。故言想一。是故前释。一分天言。亦摄梵众天。唯除劫初起。此言意显彼想实异。但就少分缘义。说为想一。由斯有色定是异因。故有色言。深有义用。有色有情。身异想一。如梵众天。谓劫初起。是第二识住。所以者何。以劫初起彼梵众天同生此想。我等皆是大梵化生。大梵尔时亦生此想。是诸梵众皆我化生。何缘梵众同生此想。由见梵王处所形色及神通等皆殊胜故。又观大梵。先时已有已。及余天后方生故。彼不能见从上地殁。依初静虑发宿住通。不能了知上地境故。何缘大梵亦生此想。彼才发心。众便生故。谓己所化。非速殁故。或愚业果感赴理故。或见己身。形状势力寿威德等。过余众故。由是缘故。梵众梵王。身虽有殊。而生一想。岂不梵众言。我从彼生。而大梵王言。我能生彼。想即有异。如何言一。此责非理。梵众梵王。同执一因而生想故。或缘所化想是一故。有说此中唯依梵众。言同一想。非大梵王。以彼经但言如梵众天故。非王一身可名众故。虽彼后时得聪睿觉亦生异想。而从初位。以立其名。故言想一。王从众说。得想一名。故可彼天总名想一。言身异者。前说彼天。有表等因。感别果故。安立众生。有差别故。经说。梵众作是念言。我等曾见如是有情长寿久住。乃至起愿。云何当令诸余有情生我同分。于彼正起此心愿时。我等便生彼同分内。梵众何处。曾见梵王。有余师言。住极光净。从彼天殁来生此故。既从彼殁来生此间。云何未得第二静虑。而能忆彼诸宿住事。谁言未得第二静虑。若得应离初静虑贪。如何彼尚生初定戒禁取。退已方生。斯有何失。岂不色界无有退耶。有说。初生无妨有退。有余师说。住中有中。曾见梵王。此不应理。经言见彼久住世故。彼天中有。于正所受生。既不阙缘。无容久住故。应说梵众即住自天。曾见梵王。极光净殁。初受生时。曾见彼故。谓诸梵众初下生时。见大梵王。威光赫烈。虽怀敬慕欲往亲承。威神所逼。未果前诣。于兹荏苒遂致多时。后励专诚。预近瞻仰。到已皆共作是念言。我等曾见。乃至广说。谓彼近见大梵王时。便能忆知先所见事。复能了达众下生前。独有梵王及心所愿。或彼先在极光净天。曾见梵王。今见能忆。谓彼昔在极光净天。曾见梵王独居下地。亦知心愿与众同居。俯愍便兴初静虑化。令所化众偶侍梵王起化。须臾自便福尽命终。生下初静虑中。大梵身心及所化事。皆初静虑通慧所缘。今见便发宿住随念。故彼梵众作是念言。我等曾见。乃至广说。有余师说。二静虑中所起。能缘梵世眼识。是初静虑地法所收。故今亦能随念彼识。有作是说。彼梵众天。不受处胎断末摩苦。由斯得有念无忘失。故忆前生所见等事。有色有情。身一想异。如极光净天。是第三识住。此中举后。兼以摄初。应知具摄第二静虑。若不尔者。彼少光天。无量光天。何识住摄。彼二既有第三识住相。无缘可说非识住所收。故知此中依举显理。说诸识住。非但如言。彼天中无有表业等为因所感差别身形。故言身一。即形显等。同处诸天。相无别义。然彼尊者阿奴律陀契经中言。光净天等。身有高下胜劣可得。此依别处。故作是言。非一天中身有差别。又契经说。极光天中。有时诸天。同共集会。其身有异。光明并同。此说诸天其身各别。不言形显状貌不同。故与此经无相违失。有说。梵众名极光天。有妙光明。胜下天故。第二静虑。喜舍二想。杂乱现前。故言想异。传说。彼天厌根本地喜根已起。近分地舍根现前。厌近分地舍根已起。根本地喜根现前。譬如有人于诸饮食若素若腻欣厌互增。经主引经释想异义。谓极光净。新旧生天。缘于劫火。有怖不怖。二想交杂。故名想异。非喜与舍二想交杂。若尔不应第三静虑由乐想故说名想一。有何别理。第三静虑。由一乐想。名为想一。第二静虑。非由喜舍二想交杂名为想异。故彼所言。乍如可录及加详察。未足信依。上座此中作如是说。第三静虑。于一切时。由不怖想。故言想一。彼所引教。与经主同。今详彼言。非符识住。此及前释。理并不然。谓识于中喜乐安住。立为识住。如何乃说依于怖想立识住名。即以此缘。说诸恶处。第四静虑。及有顶天。非识住摄。次后当辩。理必应然。上座亦说。诸恶处等。非识住因。谓识住名。显识乐住。如说。有处令士夫心乐住其中。是名识住。非恶处等。令士夫心乐住其中。故非识住。既言若识不乐住中非识住者。怖想令识不乐住中。岂名识住。若彼怖想。虽能令识不乐住中。而立识住。是则彼说。诸恶处等非识住因。有不定失。又不怖想无容生故。应遍净天非名想一。如何知彼此想不生。彼有此想。曾无说故。谓曾无处说遍净天见下水灾而不生怖。或容彼谓水不上升。无虑漂疑故无怖者。既本无疑虑不怖想何从。若谓于中少有疑虑。则应遍净非名想一。是故但依对法正理。释想一异。名义善成。非譬喻宗理可存立。故有智者。择善而从。有色有情。身一想一。如遍净天。是第四识住。言身一者。释义如前。唯有乐想。故名想一。遍净天乐。寂静微妙。常生欣乐。无起厌时。是故无由近分交杂。故唯依此立想一名。岂不遍净亦有想异。如契经说。此遍净天。受寂静受乐。非如余遍净。此非想异。显乐受中自有差别。无别受故。一切有为展转差别。一类亦有下等品殊。不可依斯立想有异。是故但依唯一乐想。立想有一义无倾动初静虑中。由染污想。故言想一。以于非因起戒禁取执为因故。第二静虑。由二善想。故言想异。由等至力。二受交参而现前故。第三静虑。由无记想。故言想一。纯一寂静。异熟乐受而现前故。下三无色。名别如经。即三识住。是名为七。何等三无色。谓无色有情。一切色想。皆超越故。诸有对想。皆隐没故。于别异想。不作意故。入无边空。空无边处具足住。如随空无边处天。是第五识住。无色有情。一切空无边处。皆超越故。入无边识。识无边处具足住。如随识无边处天。是第六识住。无色有情。一切识无边处。皆超越故。入无所有。无所有处具足住。如随无所有处天。是第七识住。今应思择。初无色言。岂非无义。说诸色想皆超越言。义已足故。此责不然。有别义故。色界有情。虽无欲染。而有欲想。成就现行。俱现可得。勿有因此生如是疑。无色有情。虽无色染。应有色想成就现行。是故须说无色有情。一切色想。皆已超越。欲界系想。名欲想故。岂不一切色想皆超越言无色及越色想二皆成就此亦非理。有作是言。无色界中。亦有色故。初言无色。意为显成无色界中都无色故。次说色想皆超越言。显彼都无色界想故。由此二言。皆有义用。生无色界。亦成色想。越色想言。岂非无义。此难非理。已简别故。谓前简别。欲界系想。名欲想故。色想亦然。非生无色可有亦成色界想者。故此非难。或彼色想。都不现行。设就缘色释。亦无乖越义。一切色想皆超越者。贪染现行俱超越故。言色想者。谓色界想。或唯第四静虑地想。缘自他地色为境界。故名色想。诸有对想皆隐没者。五识相应想皆没故。依有对根诸所生想。唯缘有对为境界故。名有对想。若于欲界。得离贪时。二识相应。诸有对想皆当隐没。生上无容重现行故。于初静虑。得离贪时。三识相应。诸有对想。虽当隐没。而非一切。生上有时。重现行故。第四静虑。得离贪时。所可现行。皆当隐没。无色无容重现行故。于别异想不作意者。不复作意起异想故。取差别相。名别异想。此复云何。谓若有想。于所缘色。自相行转。此于离色贪。能为拘碍故。今不作意。令此现行。共相行想。顺离贪故。有余师说。若想遍能缘色非色。名别异想。今于此想。不作意行。唯作意行。缘无色想。是故无色。及诸色想。皆超越等。俱成有义。此中何法。名为识住。谓彼所系五蕴四蕴识于其中。乐住着故。有余师说。唯有情数。得识住名。契经说故。为显诸识所住着事。故契经说七识住名。由此余处。非识住摄。以彼处识有损坏故。识于其中不乐住着。余处者何。谓诸恶处。第四静虑。及与有顶。云何于中识有损坏。损坏识法。于彼有故。何等名为损坏识法。谓诸恶处有重苦受。能损于识。第四静虑。有无想定及无想事。有顶天中。有灭尽定。能坏于识令相续断。复说若处余处有情。心乐来止。若至于此。不更求出。说名识住。于诸恶处。二义俱无。第四静虑。心恒求出。谓诸异生。求入无想。若诸圣者。乐净居等。若净居天。乐证寂灭。有顶昧劣。故非识住。有说。若识爱力执受。安住其中。说名识住。一切恶处。净居天等。业力执受。安住其中。无想有情。及与有顶。见力执受。安住其中。由是皆非识住所摄。有余师说。众生有三。所谓乐着诸境乐想。乐着境者。人及欲天。乐着乐者。下三静虑。乐着想者。下三无色。唯于此处。立识住名。余无此三。故非识住。上代师资相承说者。若处具有见修所断及无断识。立识住名。异此便非识住所摄。岂不欲界人及六天无无漏识。应非识住。若言能作无漏所依。则有顶天。应名识住。此难非理。欲界无定可就所依说有无漏。然有顶天是定地摄。应依自性说彼有无。由自性无。故非识住。或非有顶补特伽罗一所依中具三种识。欲界善处补特伽罗。一所依中。容具三识。故不应以有顶为例。第四静虑。虽具三识。而五处全。一处少分。不具三识。故少从多。不立识住。是故识住。数唯有七。如是解释七识住已。因兹复辩九有情居。其九者何。颂曰

  应知兼有顶　　及无想有情
  是九有情居　　余非不乐住

论曰。前七识住。及第一有。无想有情。是名为九。诸有情类。唯于此九。欣乐住故。立有情居。谓诸有情。自乐安住。所依色等实物非余。以诸有情是假有故。然诸实物。是假所居。故有情居。唯有情法。以有情类于自依身爱住增强。非于处所。又于处所。立有情居。则有情居应成杂乱。居无杂乱。唯有内身。故有情居。唯有情法。既言生已名有情居。知有情居不摄中有又诸中有。非久所居。故诸有情不乐安住。又必应尔。由本论说。为显生处。立有情居。于生死中。为显诸识由爱住着。建立识住。显诸有情于自依止爱乐安住。立有情居。故此二门。建立差别。然契经说。有色有情无想无别想。如无想天者。想谓总取境。别想谓分别。今此天中。并遮前二。故说无想无别想言。或无想言。唯遮于想。无别想者。遮想俱行。或无想言。是总遮故。勿谓此处诸想皆无。故复说言无别想者。显有成就。但无现行。以别想名。诠现想故。或言无想。恐谓此中唯无染想。由斯复说无别想言。即显此中无有一切品类别想。有顶无想。既非识住。如何可说为有情居。此责不然。义各异故。由此二处有坏识法。识不乐居。故非识住。然彼二处。成有情身。有情乐居。故九所摄。谓若有处。余乐来居。不乐迁动。有情居摄。余处皆非。不乐住故。言余处者。谓诸恶处。第四静虑。除无想天。恶处皆非有情居者。谓非余处有乐来居。亦无住中不乐迁动。第四静虑。除无想天。所余皆非有情居者。虽从余处有乐来居。然非住中不乐迁动。谓广果等。若诸异生。乐入无想或无色处。若诸圣者。乐入净居或无色处。净居天处。乐入涅槃。故彼皆非有情居摄。然佛余处。曾以处声。宣说涅槃有顶无想。有诸外道。执有顶天及无想天。为真解脱。勿有闻此同说处声。便谓二天。同真解脱。起涅槃觉。转助邪宗。由此世尊。与诸识住。一处合说。为有情居。显真涅槃非为如是。但假施设有情所居。何故世尊。有情居内。有顶无想。偏说处声。精勤果中。至究竟故。唯异生处。精勤果中。无想有情。最为究竟。一切生处。精勤果中。唯有顶天。最为究竟。故唯此二。偏说处声。或复处声。显来门义。谓此二处。异熟尽时。多分命终。来生下故。因七识住。已辩有情居。余契经中。复说四识住。其四者何。颂曰

  四识住当知　　四蕴唯自地
  说独识非住　　有漏四句摄

论曰。如世尊言。识随色住。识随受住。识随想住。识随行住。是名四种。如是四种其体云何。谓唯除识。有漏四蕴。又此唯在自地非余。非识乐随余地蕴住。虽依余地蕴识亦现前。而余地蕴中识不乐住。喜爱润识。令于蕴中增长广大。契经说故。非于余地色等蕴中喜爱能润识令增长广大。故余地蕴。非识住摄。又自地中。唯有情数。唯自相续。立为识住。非非情数他相续中识随乐住如自相续。有余师说。彼亦识住。以于其中喜爱润识亦令增长及广大故。已依自宗建立识住。当说建立识住因缘。此中云何识非识住。又此识住其义云何。谓识于中由喜爱力。摄为所住。及为所著。是识住义。识随色住。住色着色。契经说故若尔识蕴应成识住。世尊亦说。于识食中。有喜有染。有喜染故。识住其中。识所乘御。此中经主。作如是释。亦不遮识。识所依着。总于诸蕴生喜染故。然如色等一一蕴中。生诸喜染。令识依着。独识不然。故言非住。又佛意说。此四识住。犹如良田。总说一切有取诸识。犹如种子。不可种子立为良田。仰测世尊教意如是。又法与识可俱时生为识良田。可立识住。识蕴不尔。故非识住。如是所释。但述己情。审谛思求。无深理趣。识与识住。如种如田。理可如是。不违教故。然彼所说。若法与识。可俱时生。为识良田。立识住者。不应正理。所以者何。彼先自说。识所依着。故名识住。非于俱起受等蕴中有识所依。彼依识故。住若所依。识不依彼。如何可说彼为识住。又非所缘同一境故。俱生受等。非所取故。又不可以相应依着释识住义。勿诸色法及不相应非识住故。又相应理无差别故。则应无漏亦识住体。如何可说俱生色等为识良田立为识住。又言。佛意说四识住。犹如良田。总说一切有取诸识。犹如种子。不可种子立为田者。理亦不然。异识相望。有所依着。岂非田义。又于识中。应无有取。然契经说。有取诸识。故知亦有识住识中。又彼所言。亦不遮识。识所依着。总于诸蕴生喜染故。然如色等一一蕴中。生诸喜染。令识依着。独识不然。故言非者。亦不应理。彼契经说。于识食中。有喜有染。有喜染故。识住其中。识所乘御。如何乃说。但于诸蕴总生喜染。独识不然。若言食中不立田种二分差别故无过者。应说因缘。何故不立。既于识食。别生喜染。识住其中。不应总说有取诸识皆如种子。识既于识。可为良田。何理独遮识为识住。故彼所说。但述己情。无深理趣。非为善释。又彼上座作是释言。即此不应还住于此。故不可说识随识住。若言过未及他相续识中住者。其理不然。唯于识中。无有势力令识增长及广大故。谓如色等。匡助于识。令其炽盛。识即不然。唯了别中无此用故。彼如是释。非悟理言。且此不应还住此故。不可说识随识住者。于彼宗义。其理不然。非彼唯于现在诸法立为识住。如何得以一刹那识。非自住故。证识非住。其义可成。纵加远避。终应唯许过未受等名为识住。彼识刹那无受等故。如是所说。即此不应还住此因。于义何益。若谓如色于现在时可成识住。识不如是故所说因于义有益。此亦非理。受等亦应非识住故。竟不曾说识与受等差别因缘。故所说因。于义无益。又未了彼。即此不应还住此言。意显何义。若言意显自体不能于自体中守自性义。则应同彼空花论宗。许一切法不守性故。如是识住。亦不应成。若言意显自体不能为自所依或所缘义。是则所立。唐捐其功。曾无有疑。依缘自故。谓如色等。他性诸法。可有为识所依所缘。识自体中。曾无此感。而今立理。复何所成。凡所立因。为遮有滥。此中无滥。因何所遮。是故彼因深成无用。又识自类展转相望。何劣受等而非识住。岂不前说。此证因言。唯于识中。无有势力令识增长及广大故。前虽已说。而非应理。识缘受等。增长广大。非识缘识。此有何因。岂不此因亦如前辨。谓如受等。匡助于识。令其炽盛。识即不然。唯了别中。无此用故。何用说此非极成因。不能证成。非所许故。识缘唯领等增长广大。非缘唯了别。此有何因。又彼上座。自于解释识住中言。识随色住。谓我我所。攀缘色生。是色识住。乃至广说。识亦于识。谓我我所。攀缘识生。何非识住。谓我我所攀缘既同。识何独不令识增长广大。又彼所说。识于所缘唯了别故。非如受等匡助于识令炽盛者。岂不于识所了事中。彼谓后时受等方起。是则于境要先了别。然后领等随次而生。能引识流展转炽盛。故唯了别。最是胜因。能匡助识。应成识住。如生本苦生为胜因。识炽盛因识最为胜。识及识住。皆识为因。能令展转增长广大。故识不能匡助于识令炽盛者。非为善因。若恐违经言识非住。上座立理岂不违经。经说识能增长识故。应除自执更访余因。然我师宗。作如是释。为令于识除我见心。故于识中。不说识住。如说。莎底契经中言。我达世尊所说法教。驰流生死。唯识非余。识谓世尊异名说我。为欲除灭彼我见心。显识依他体。非是我我所依性。非谓能依。故识住门。唯说有四。非实识住但四非识。今谓世尊所说识住。唯色等四。不言识者。由但色等于三时中与续有识为助伴故。谓唯色等。与识俱生。过未亦能为识助伴。令续有识生死驰流。识则不尔。故非识住。且眼等根。及俱色等。与俱生识。为所依依。已灭未生。但为识境。是故色蕴。于三时中。望续有识。能为助伴。现在受等。与识俱生。为俱有因。一分与识同缘一境。有助伴用。已灭未生。但为识境。是故受等。亦于三时。望续有识。能为助伴。识虽过未。望续有识。少有助能。而俱生中。全无助力。不俱起故。色等望识。具二助能。识唯去来。故非识住。故非情数。及他身中。色等四蕴。亦非识住。由彼望识但为所缘。不具二门助伴用故。住谓所住。是续有识。引自果时。能为依义。住或所著。是续有识。引自果时。能为境义。自身色等。可有与识同一境义。设不同境。然能为依。具二助能。故立识住。非有情数。他身色等。则不如是。故非识住。如何定知识住道理如是安立。契经说故。如世尊言。有四依取所缘识住。识随色住。住色着色。是识与色。或俱时生。依于色住。或于色境缘而生着。何缘生着。前说于中喜爱润故。如是乃至。识随行住。皆应广说。曾无有说。识随识住。随谓亲附。或谓邻近。去来定说为疏远故。现在色等。附近于识。与识俱生。名识随住。定无有识与识俱生。故不应言识随识住。由此经故。唯余四蕴。与续有识。为伴义成。有四依取。世尊说故。言依取者。谓色等四。为生死依。烦恼所取。或即为依。摄取众苦。由是无漏非住理成。唯说依取。为识住故。无漏色等。灭依取故。即彼经说。苾刍当知。若于色界。已得离贪。于所随色。意生系断。此系断故。即能缘识。无复住着增长广大。广说受等三界亦然。即由此经。义准三世色等四蕴。皆识住摄。为显色等与识异故。我所禀宗。作如是说。若法与识。可俱时生。识所乘御。如人船理。此法可说识住非余。如是所言。意简识住与识类别。非为欲遮去来色等言非识住。虽许去来亦识住摄。而非情数。非识住收。彼现在时。与续有识。尚为疏远。况在去来。由彼恒时与续有识但为疏远。所缘境界。定非彼识附近助伴。故识与彼俱非识住。自身色等。虽在去来与识疏远。而于现在。与续有识。极相亲近。由种类同。亦名识住。如现在世异心无心两位自身色行二蕴。谓如现起不同分心及无心位色行二蕴。虽非现在同分识依。而不失于二识住相。住彼相故。设于尔时。起同分识。定能为住。余缘碍故。识暂不生非彼尔时无识住相。去来色等。理亦应然。具二助能。相不失故。由此色等。自相续中。三世所摄。皆名识住。七四识住。皆有漏摄。为七摄四四摄七耶。非遍相摄。可为四句。有七非四。乃至广说。第一句者。谓七中识。第二句者。谓诸恶处。第四静虑。及有顶中。除识余蕴。第三句者。七中四蕴。第四句者。谓除前相。七中有识四中无者。由此二门。建立异故。若法与识。互为因果。识乐随转。立七识住。若法与识。可俱时生。能为助伴。立四识住。故所承师。咸作是说由所化者。禀性不同。故说七四识住差别。云何所化禀性不同。谓彼或乐各别缘境。或有于境不乐别缘。或乐遍知诸法自相。或于自相不乐遍知。或耽着爱或耽着见。或有自相烦恼力强。或有共相烦恼力强。或乐境界。或乐生死。有如是等性别无量。已说识住。于前所说诸界趣中。应知其生。略有四种。何等为四。何处有何。颂曰

  于中有四生　　有情谓卵等
  人傍生具四　　地狱及诸天
  中有唯化生　　鬼通胎化二

论曰。前所说界。通情非情。趣唯有情。然非遍摄。生唯遍摄。故说有情。无非有情名众生故。然有情类。卵生胎生湿生化生。是名为四。生谓生类诸有情中。虽余类杂。而生类等。言生类者。是众生义。若尔界趣。应亦名生。不尔界通情非情故。趣虽有情。而非遍故。此唯情遍独立生名。上座谓生是生因义。则非情法。应亦名生。以卵胎湿皆生因故。化生应非生。无别生因故。彼言亦有俱起生因。此不应然。彼自不许俱生因故。设有是何而竟不显。但有虚说。非离先业有别生因。亦非化生与业俱起。故彼所说。理必不然。所承诸师。作如是释。缘业合起。故说为生。谓诸有情。有卵胎湿。三缘和合。别别而生。有无别缘。唯业力合五蕴四蕴如应顿生。彼业力强不待缘故。今释一切皆业合生。佛说有情业所生故。有业生果待卵等缘。方有差别。有业生果。不待外缘。自有差别。若说一切皆业合生。如何说为卵胎生等。不可卵等从业合生名卵等生。彼非情故。不说一切唯业合生。不说卵等体生由业。但说一切皆业合生。业合生时。有缘卵等。从缘标别。名卵等生若说业生。名应无别。言卵生者。谓诸有情。生从卵[穀-禾+卵]。如鹅雁等。言胎生者。谓诸有情。生从胎藏。如象马等。言湿生者。谓诸有情。从皮肉骨。牛粪油滓水等和合暖润气生如虫飞蛾。蚊蚰蜒等言化生者。谓诸有情。不待三缘。无而欻有。具根无缺。支分顿生。如那落迦天中有等。化生体兼五蕴四蕴。余三但用五蕴为体。有说。皆通异熟长养。有说。一切体唯异熟。人及傍生。各具四种。人卵生者。谓如世罗邬波世罗。生从鹤卵。鹿母所生三十二子。给孤独女二十五子。般遮罗王五百子等。人胎生者。如今世人。人湿生者。如曼驮多遮卢邬波遮卢鸽鬘庵罗卫等。人化生者。唯劫初人。此四生人。皆可得圣。得圣无受卵湿二生。以圣皆欣殊胜智见卵湿生类。性多愚痴。或诸卵生。生皆再度。故飞禽等。世号再生。圣怖多生。故无受义。湿生多分众聚同生。圣怖杂居。故亦不受。傍生三种。现所共知。化生如龙妙翅鸟等。一切地狱诸天中有。皆唯化生。有说。饿鬼唯化生摄。有说。饿鬼亦有胎生。如饿鬼女白目连曰

  我夜生五子　　随生皆自食
  昼生五亦然　　虽尽而无饱

于四生内。何者最多。有说湿生。现见多故。设有肉等聚广无边。下越三轮。上过五净。容遍其量顿变为虫。是故湿生多余三种。有余师说。化生最多。谓二趣全。三趣少分。及诸中有。皆化生故。一切生中。何生最胜。应言最胜唯是化生。支分诸根。圆具猛利。身形微妙。故胜余生。若尔何缘后身菩萨得生自在。不受化生。见受胎生。有大利故。谓为引道诸大释种。亲属相因。入正法故。又令所化生增上心。彼既是人。能成大义。我曹亦尔。何为不能。因发正勤。修正法故。若化生者。恐疑是天。佛转法轮。便成无用。谓天所转。还被天机。唯天能知。非人所了。由斯自蔑。于正法轮。不起正勤勇猛思择。又令余类生敬慕心。舍俗出家。勤修正行。谓知菩萨生贵族中。能舍尊位。出家修道。成等正觉。转大法轮。我等何为不生欣仰。因兹舍俗修正行故。又为摧伏憍慢众生。令知世尊是轮王种。属斯隆贵。憍慢山崩。闻说敬承无疑谤故。若化生者。种族难知。恐疑幻化。为天为鬼。如外道论矫设谤言。过百劫后。当有大幻出现于世。啖食世间。又与化生时不同故。谓佛出世。人无化生。人化生时。佛不出世。有作是说。为饶益他。故受胎生。拟留身界。令无量众一供养因。千返生天。及证解脱。化生才殒。无复遗形。如灭灯光。即无所属。此中经主。作如是难。若人信佛。有持愿通。能久留身。此不成释。今谓此释其理必成。通所留身。非佛功德力无畏等所依熏故。不能广大饶益世间所以然者。是可留法。通愿能留。一切化生如刹那法。必无留义。谓诸有为。刹那定灭。诸佛神力。亦不能留。设欲久留。即须别化。此所别化。非佛功德力无畏等之所依熏。故于世间。无大饶益。若不尔者。佛应化为如本身形。受诸供养。令无量众生天解脱。故我所禀。毗婆沙师咸作是言。后身菩萨为利他故。不受化生。此义极成。不可倾动。化生何故死无遗形。由彼顿生。故应顿灭。如戏水者出没亦然。毗婆沙师说。化生者造色多故。死无遗形。大种多者。死非顿灭。即由此义。可以证知。一四大种。生多造色。若尔便与契经相违。经说。化生诸妙翅鸟。为充所食。取化生龙。由彼不了。取拟充食。不说除饥。斯有何咎。是故但说为食取龙不言此龙有成食用。或龙未死。暂得充饥。死已还饥。暂食何咎

说一切有部顺正理论卷第二十二阿毗达磨顺正理论卷第二十三

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩缘起品第三之三

已辩四生。前说地狱诸天中有。唯是化生。此中何法说名中有。何缘中有非即名生。颂曰

  死生二有中　　五蕴名中有
  未至应至处　　故中有非生

论曰。于死有后。在生有前。即彼中间。有自体起。为至生处。故起此身。二有中间。故名中有。如何此有。体有起殁。而不名生。又此有身。为从业得。为自体有。从业得者。此应名生。业为生因。契经说故。自体有者。此应无因。则同无因。外道论失。是故中有。应即名生。生谓当来所应至处。依所至义。建立生名。此中有身体虽起殁。而未至彼。故不名生。体谓此中异熟五蕴。此但名起。不说为生。死生有中暂时起故。或复生者。是所起义。中有能起。所以非生。所起者何。谓业所引。异熟五蕴。究竟分明。以业为生因。契经说故。此应名生者。其理不然。不说业为因皆名为生。故契经说。有补特伽罗。已断起结。未断生结。广说四句。由是准知。有顺中有非生有业。此业所得。不说为生。故与彼经无相违过。此既与生同一业引。如何中有名起非生。岂不前说。所至所趣。乃说为生。中有不尔。又一业果多故无失。如一念业有多念果。一无色业。色无色果。如是一业所引之果。有生有起。理何相违。有余部师。执无中有。有与理教并相违故。理相违者。前蕴灭处。后异即生。俱有过故。谓若异处前蕴灭已。异处后生则无中有。如何不许死有无间即于异处生有蕴生。若于此处。前蕴灭已。此处后生。亦无中有。是则应许。死有无间。即于此处。生有蕴生。如是中有。异前灭处。若生不生。皆无用故。死有无间。生有即生。其理极成。故无中有。又曾不说中有业故。谓有经说。顺现受等三业不同。曾无契经说有第四顺中有业。不可说中有无业而生。勿一切无因自然生故。又应诸有情皆具神通故。谓离功用。一切有情。皆应性得神通自在。然多用功。少有成办。是故中有。理定应无。又许有死生有应成。谓要有生方有死故。若许有死不由生成。有太过失。谓于诸趣。虽无顿生。应有顿死。无生有死。理极相违。又取有无俱成失故。谓死无间取中有不若取应生。经所说故。如契经说。若舍此身。更取余身。我记生故。如其不取应般涅槃。既般涅槃。何有中有。又彼应有无穷过故。谓死生间。既有中有。生中中死两隙宁无。设有便成无穷过失。如是略辩与理相违。与教相违。今次当说。谓世尊说。预流有情。极于七有。若有中有。世尊应言极十四有。又无间业。应成有间。谓契经言。五无间业。作已无间生地狱中。若隔中有。违无间义。又有中住。契经所遮。谓契经说

  再生汝今过盛位　　至衰将近琰魔王
  欲往前路无资粮　　求住中间无所止

若有中有。如何世尊言。彼中间无有所止。又彼非为宿住智缘。谓契经言。知宿住者。言我彼殁来生此间。不言彼殁曾生中有。由与如是理教相违。故知定无中有可得。前宗所执。略述如是。今谓一切皆非证因。且彼初说。前蕴灭处。后异即生。俱有过者。此难非理。许邻死处中有生故。谓许中有于前死处。非隔非即邻次而起。如是后后。乃至结生。恒邻次起。故无前失。至辩自宗。当更显示。又言不说中有业者。理亦不然。有处说故。谓契经说。我由如是杂滓秽身所造恶业。愿令一切皆成现受。勿随勿生勿后当受。岂不随言即显中有。谓现身后。方便异熟。顺生顺后。总说名随。中有名为方便异熟。以有恶业顺中有受。故发遮愿。说勿随言。或业能招当所往趣。此即能感中有异熟。中生二有。一业所牵。如前已辩。故中有业。不可言无。然佛世尊。略说三种分位定业。感中有业。摄在其中。故不别说。又言诸有情应具神通者。亦不违理。此位有故。若中有位。一切有情。具业成通。斯亦何咎。非此位有。例余皆然。勿一时间作野干等。或异生类。则例恒然。或应汝曹谤中有者。许有情类皆具神通。谓诸有情。于此处殁。能超无量亿踰缮那极远处生。都无障碍。此外何有余大神通。又言许有死生有应成者。此难亦不然。许生差别故。应理论者。于生差别。立中有名非即生有。如往人趣。于未到间。有生差别。是生方便。未名人趣。已得名人。未到所应生。一业所引故。由此故无诸趣顿死。许中有是生方便故。由此亦答取有无因。于取差别。名中有故。非此中身言意唯说色。亦见于非色说身言故。谓三有中。生及差别。总名生故。言舍此身更取余身。记生何咎。若谓唯说色法名身。有舍此身取无色者。岂薄伽梵不记为生。设许色身。亦无有失。舍此身已。更取余身。佛但记为生。不言生有故。非唯生有可记为生。以立生名但遮死故。如言师雨岂即同天。又此不应有无穷失。许邻次起。无此失故。若死中有处隔而生。可如所言有无穷失。然死中有邻次而生。既无中间。更立何用。故无穷过。非预我宗。又以我宗立有中有。则令中有更有中有。如是汝宗。唯立生有。亦应生有更有生有。彼此过同。不应为难。如是且破遮中有理。次当辩释遮中有教。经言预流极七有者。此于中有。亦无所违。说一期生为一有故。谓中有等。总名一期生。由形等同一业所引故。如是四有。总立一有名故。无预流极十四有过。一期生有。由少所因。依分位别。分为四有。或七有言。且依人趣生有而说。故亦无违。如汝宗中。亦许预流者受天七有。应成极十四。或彼意谓。极七有言。非欲别显人天各七。但显人天总唯七有。若尔应说预流有情生死驰流人天七有。经不应说预流有情生死驰流人天各七。故知经说极七有言。意显人天各别有七。不应执此违余经故。经言具见补特伽罗。无处无容受第八有。无违经失。乘前经故。谓经前说。预流人天各受七有。定无第八。次言具见补特伽罗。无处无容受第八有。故彼所引极七有经。于中有宗。亦无违害。又言无间业应成有间者。亦不应理。遮异趣故。谓若有作无间业已。定无异趣隔。必生地狱中。我见此经。义意如是。或复中有亦地狱收。故无无间成有间失。必生地狱中有中故。或执中间少有所隔非无间者。则无间业。毕竟应无。定无有造无间业已不隔刹那邻次即生地狱中故。若谓经说身坏无间生地狱故无斯过者。此亦不然。刹那坏故。若言此坏据一期终。我亦言生但生中有。经言身坏生地狱中。不说即生地狱生有。故遮异趣。说无间言。若不许然。应无无间。是故所引无间业经。无有功能遮遣中有。经言身坏生地狱中。不说即生地狱生有。如何中有。由此证无。有如童竖戏设难言。若无间言。遮异趣者。则无中有。其理极成。自执中有异于趣故。许无间言遮异趣故。彼言非善。许义别故。说者意言遮异趣者。两趣各别。故言异趣。如两村异名为异村。非非趣摄名为异趣。岂如是类童竖戏言。能正推征令证实义。故证中有决定为无。如是契经。非易可得。又此中有。定有义成。以但说此为无间故。若无中有。有惑有情。身坏无间皆受生有。经唯说此。则为唐捐。我释此经。言无间者。为遮异趣中间为隔。及遮中有缘阙稽留。故此经言。深有义趣。除此余业无此定遮。故不说彼为无间业。汝释此经。为遮中有。则一切业。皆成无间。故汝应信中有义成。或拨此经。言成无义。又于此业。见无间言。即谓此言为遮中有。余许有间。中有应成。又余经中。说有中般。故此经意。应审思求。若但执文。有太过失。谓契经说。一类有情。于五无间业。作及增长已。无间必定生那落迦。若但执文。应要具五方生地狱。非随阙一或余业因。便成太过。又言无间生那落迦。应作即生不待身坏。由此已释遮中住经。谓佛诲言。汝从此殁。定速颠坠。无异趣生。于中有中。亦无暂止。若不尔者。一切有情。皆死即生。何独遮此。故由此证。中有转成。又言彼非为宿住智缘者。此亦非理。略标趣故。非宿住通不缘中有。然略标趣。故说此言。我从彼殁。来生于此。若异此者。彼亦应言。我受此生羯剌蓝等。彼既不说。此亦应无。此既非无。中有应尔。或从彼殁。来生此言。已摄中有。此生摄故。如是余部遮中有因。皆无胜力能遮中有。应理论师。作如是说。定有中有。由理教故。理教者何。颂曰

  如谷等相续　　处无间续生
  像实有不成　　不等故非譬
  一处无二并　　非相续二生
  说有健达缚　　及五七经故

论曰。且由正理。中有非无。中有若无。则定非有从余处殁余处续生。未见世间相续转法。处虽有间而可续生。既许有情从余处殁生于余处。则定应许中间连续中有非无。譬如世间谷等相续。现见谷等余处续生。必于中间处无间断。故有情类相续亦然。刹那续生。处必无间。是故中有实有义成。岂不世间亦见有色处虽间断而得续生。如镜等中从质生像。死生二有。理亦应然。经主此中。作如是释。诸像实有理不成故。又非等故。为喻不成。谓别色生。说名为像。其体实有。理所不成。设成非等。故不成喻。何因像体实有不成。以一处所无二并故。彼谓一处镜色及像。并见现前。二色不应同处并有。依异大故。又陜水上。两岸色形。同处一时。俱现二像。居两岸者。互见分明。曾无一处并见二色。不应谓此二色俱生。又影与光。未尝同处。然曾见镜悬置影中。光像显然现于镜面。不应于此谓二并生。或言一处无二并者。镜面月像。谓之为二。近远别见。如观井水。若有并生。如何别见。故知诸像于理实无。然诸因缘和合势力。令如是见。以诸法性功能差别难可思议。今谓彼因。不能遣像。故不能解破中有难。且彼所说以一处所无二故者。其理不然。同处壁光。俱可取故。虽壁光色异大为依。而于一时同处可取。不可亦拨在壁光无。由此例知镜像俱有。故彼所说非遣像因。若谓光依日轮大种。故无过者。理亦不然。暖触如光近可取故。又日光色应无依因。许离所依能依转故。如是镜像二色所依。大种虽殊。而可同处。故彼所说。依异大故。因证二处不同。言成无用。又诸大种其处应同。彼无所依大种异故。若有对故无斯过者。则不应以依异大故证镜像色二处不同。能造所造。有对同故。理但应言。镜像二色俱有对故。同处不成。同处既无。何言一处镜色及像并见现前。若言处异不可取者。理亦不然。前已说故。谓壁光色。亦同处可取。然有对故。理实处不同。虽处不同。而可同取。如光壁理。镜像亦然。今且为仁。解同取理。谓彼像色。极清妙故。不能揜蔽所余诸色。以镜与像最极相邻。起增上慢。谓同处取。如云母等。极清妙色所隔诸余色。若极相邻。便起增上慢。谓同处取。或如前说。光壁虽殊。而于一时同处可取。如彼理趣。此亦应然。又于一水。两岸形色。现像同时。各别见者。缘和差别。故如是见。谓一水上。非一像生。清妙性同。不相揜蔽。见缘合者则能见之。若阙见缘则不能见。或有一处二见缘合。同观色像。非不共见。谓一镜中。一所见像。余即于此亦得同见若镜等中。无别像起同余处者。有何定因。唯镜等中。俱见色像。或于一色。有二有情。别住同观。有见不见。如于净板涂以骨灰筹画为文。时经久远。设复新画地壁为文。向光背光。有见不见。非于一色二可同观即以例余。皆令共见。勿以一色不可同观。便以例余。皆无共见。故彼所说。理非为善。又言光影同处相违。月像镜面见处别者。次后遮遣大德逻摩所立理中。兼酬此责。彼作是说。镜等诸像。皆非实有。造色为性。一分与遍。俱非理故。谓藉月轮为因。引发依水一分。或复遍依生像造色。二皆非理。依水一分。理且不然。无定因故。遍随转故。遍亦不然。分限见故。以俱非理。故非造色。又影与光互相违故。谓悬二镜置影光中。光影二像。交现镜面。现见光影。更互相违。如其二像。是实造色。不应同处二俱可取。既俱现可取故。非实造色。又分位别有取多故。谓天授像。现水等中。分位别故。取种种色。谓青黄赤白。取一则非余。不应一处异色同止。设许同止。何不俱取。故知此中无别造色。又量无差见动作故。谓一天授。背趣镜时。像现量无差见往来用别。于一造色。无容有此。然见有此。故非造色。又见像依处各别故。谓依水等。现月像时。见像与依。方处各别。若于水上。有像色生。是则不应见处远近。然见远近。故非造色。若尔于彼所见是何。本质为缘生眼识故。如缘眼色眼识得生。如是缘于眼及镜等。对镜等质。眼识得生。实见本质。谓见别像。今谓彼诸因。亦不能遣像。且彼所说。一分与遍。俱非理故。非造色者。理不应然。余亦同故。谓许缘于眼及镜等。对镜等质眼识生者。如是二种。征责亦同。一分与遍。俱非理故。谓还见本质。藉镜等为缘。一分或遍。二皆非理。且非镜等一分为缘。无定因故。历余方所。皆能现前为见缘故。亦非镜等遍能为缘。所见分明有分限故。以俱非理。故成谬执。然我不许月等为因水等一分为依生像。但质与依。无隔相对。依中法尔有质像生。何容像生但依一分。如何知像遍所依生。现见多人列长渠侧各见月像。对自面故。若尔何故一不见多。如是见缘不和合故。虽一切处有月像生。而但现前见缘和合。故于一分可见非余。傍阙明缘。闇所隔故。有余师释。像色轻微。正近可观。横远难见。或复渐次一亦见多。故于此中不应为难。若彼多者。则无有一而能见多。不可为难。若青黄等可俱见者。此亦应同多像极微。俱可见故。然见月像有分限者。以彼本质有分限故。现像必随所依本质。或无分限。本质为缘。于水上生无分限像。犹如于水现空想青。是故本质有分限故。虽一切处有月像生。而见分限。亦无有过。或复如说镜等为缘还见现前本质相者。虽复一分或遍为缘。皆不应理。然见本质。决定应许镜等为缘。生像亦然。何劳征难。又彼所说。以影与光互相违故。不应同处。由此故知像非有者。亦不应理。非所许故。谓悬二镜置影光中所现二像。非实光影。如色彼触不可得故。若尔明了所见是何。谓随壁等光影二质。于二镜面。有不相违。光影像起。非光影色。如有情像体非有情。故光影像。体非光影。虽同处现。而不相违。又彼所宗。影非实物。既无实体。何所相违。非无体中。可言违害。故约彼执违义亦无。则所说因。俱非所许。所言光影。更互相违。若有不应同处取者。此言何义。谓光影像。若是实有。应互相违。不应同处。同处既无。应不可取。既俱可取。故像实无。我先所言。其义如是。为唯实无者定不可取耶。或有实无而亦可取。或有实有而不可取。若尔所说同处既无。应不可取。此言何用同处虽无亦应可取。汝执无者亦可取故。亦不可说非一切无皆悉可取。无异因故。谓一切无相无差别。故不可说可不可取。又彼所言。由分位别有取多故。像非实者。此言于像亦不相违。唯于有中。由分位别。可取多色。非于无故。要于实有所见境中。由根明远近方所等差别。得有邪正了色不同。如观日光所照实有蟏蛸网色孔雀尾轮。方所等殊。所见有异。亦如观见旋火轮等。是故定知实有像色。由分位别有取众多。故彼遮因。翻证像有。或如灯焰众色杂居。由所住方有碍别故。非住一切见皆周尽。又如观箭曲直不同。虽有取多。亦无有过。虽无一处异色同止。而有取时。谓为同处。如斯理趣。前已具论。故彼推征。于像无害。又彼所说。其量无差。见动作故。像非实者。理亦不然。前已说故。谓虽别有实像色生。而像必随所依本质。故量虽等。而随所应。于所依上。如其本质。有显形动三种像生。像随所依及本质故。虽无动作。而似往来及余运动三用可得。如是动相。或由本质。余方运转。无间生故。或由所依随持者等有动摇故。或由观者自有动摇。谓像转故。如是诸像。不越所依分量处所。随本质等。见有往来及余动相。此于造色。有何相违。言见有此故非造色。不可异余造色相故。便非造色。如青黄等。虽互相异。而是造色。或应坚相异暖等故。便非大种。余例亦然。如诸大种与所造色。虽互相异而色性同。故此无能遮造色性。又彼所说。见像及依处各别故。非造色者。理亦不然。空界月像。同依水等。而发生故。谓空界色。与彼月轮。次第安布。近远差别。是见依像处差别因。空界是有。色处所摄。前已成立。故与月轮于水等上。各能生像。由所生像与质相同。故见与依处似差别。或由如是见缘和合非远近中。令见远近。如观采画锦绣等文。无高下中。见有高下。由月远故。见像亦然。如满月轮。见像无缺。由如是理。破彼诸因。故彼诸因。不能遣像。然彼随自执。悦愚夫情言。本质为缘。生眼识等。如斯意趣。还为如前自所说因之所遮遣。谓藉镜等一分为缘。或遍为缘。俱非理故。又彼所说。唯率妄情。于镜等中。无本质故。对镜等质镜等中无。岂余处有法于余处可取。喻亦非理。非同法故。谓曾无色住在余方。不对眼根缘生眼识。可喻本质镜等中无。而于其中缘生眼识。若彼缘阙故眼识不生。则此中不应引彼为喻。为如何等。彼有此无。而于此中。分明可取。又彼所说。唯述妄情。以所立因非极成故。唯缘本质眼及镜等。眼识得生。非极成故。唯对眼色。眼等为缘。眼识得生。理极成立。既取像色。分明现前。故知取像。非取本质。又理必然。以所取像形量显色异本质故。谓于镜等。山石池墙树林等像量减本质。又竖刀等。见面像长。横便见阔。异本质量。又于油等。观面像时。面像显色。与本质异。若所见像。即是本质。不应形显与质不同。诸有显形。异于彼者。皆非即彼。世所极成。未知具寿。离形与显。有何本质。而执见像形显虽殊而即本质。若谓本质与显及形非即非离而实可得。是则便同阿素洛女。巧为幻化诳惑愚夫。若谓藉缘力所改转。虽即是彼。而现有异。此亦不然。互相违故。理不成故非为善释。谓若即彼。不应现异。既现有异。不应即彼。即彼现异更互相违。又现有异而言即彼。理不成立。太过失故。谓老等位亦应可执即是先时羯剌蓝等。由缘力转故现有异等尔劬劳。何不即信藉众缘力有别像生。而计藉缘还见本质。是故所说。本质为缘。生眼识等。比度道理。极为微劣。于证无能。经主此中。所作是说故知诸像。于理实无。然诸因缘和合势力。令如是见。以诸法性功能差别难思议者。彼何不谓质镜等缘和合势力别能生像故如是见。以说法性功能差别难思议故。又和合名。非名实法。如何可执有势力耶。又执多缘合成一力。如何说诸法有差别功能。是故应如功能差别。眼及色等为缘。别引功能差别。眼识令生。如是亦由功能差别。质及镜等为缘。别引功能差别。像色令生。由此证成诸像实有。或应总拨诸法皆无。尝闻有人总拨无诸法。今观具寿。似与彼情通。审尔无劳共为谈论。又若尔者。拨中有人。岂不亦能作如是说。因缘和合势力难思。死生中间。处虽隔远。而令续起。以诸业性功能差别难可思议。故应谛思。于镜等上。若无像起。如何现前。如余实色。分明可见。故对法者。咸作是言。于镜等中。别有像色。大造和合差别为体。对别现生如是像故。犹如此像本质所依。谓镜等中。镜等现质。为依缘故。有随所依本质像起。分明可见。像所缘质。实有极成。此像为缘。于别镜等。亦有随质所依像起。分明可见。故知前像缘起像故。实有义成。由是应知。诸像实有。此若无者。余像何缘。若言前像所缘本质为此缘者。理亦不然。前质不对后所依故。后像不随前质起故。谓后所依。唯对前像。不对前质。如何可说前质为缘。现于后像。曾未见有背镜等质。于镜等中。为缘现像。由斯后像不随前质。但随前像。其理极成。是故所言。于别镜等。所现后像。但缘前质。不随前像。唯述妄情。复如何知像体实有。由像不越实有相故。谓若不越眼等识境皆是实有。后当成立。像既可见。故知实有。又像有时而可得故。此若无者。应一切时定不可得。或常可得。若谓有时可不可得。由所待缘合不合者。是则应知。余有为法。于缘合位。实有义成。又无分别识所缘故。谓五识身所缘境界。实有极成。然像既通眼识所得。故知实有。又像能遮余色生故。谓像能碍余像色生。于自所居。障余生故。若法随具如前相者。当知彼法。实有极成。此像既然。故知实有。岂不前说。一陜水上。同处一时。有二像起。如何说此碍余像生。岂不前言。如壁光等。处虽各别。而谓处同。由增上慢。不应为责。又于镜中。别处取故。谓于一镜。一处所中。无有二像俱时可得。如缘差别。取像亦异。若谓色性理不成者。此亦不然。理极成故。又如何知。像体定有。与余有法。生相似故。如识芽等。诸缘生法。有体极成。此亦如是。世共现见。从众缘生。是故应知。像体定有。如余有法。定有极成。从别缘生。相有差别。诸像亦尔。从别缘生。相有差别。故应定有。由此所言与余有法生相似故。其理极成。生无自因。曾未见故。像非有者。理亦不然。我许像生有自因故。谓我许像有同类因。如从异缘生识芽等。非我许像因镜等生。以许像生依自因故。镜水明等。但作取缘。如取向游尘。要藉光穿影。非光及影为彼尘因。亦非彼尘无因而有。或不可说异缘生即无。同异色生俱现见有故。且如何见从日月珠有火水生。此亦应尔。若言火水从自种生。以二珠中有二界故。则应火水俱二珠生。或应二珠能生风地。有二界故。如生火水。若谓二珠二界增故。偏为火水自类生缘。理亦不然。二珠应有热湿二种。现可得故。若谓二珠要由日月光明摄受。二界便增。方能为缘生火水者。则应二种并为光明所摄受故俱生火水。若彼二珠。界无增减何因热焰缘助日珠。能令生火。非为冷焰缘助日珠即令生水。亦应如是征责月珠。诸缘起理。实为难觉。石灰水合。唯生火故。谓世现见烧石为灰。遇水便能生火非水。此唯可说缘起难思。除此有何无过之答。又虹霓等。诸色聚生。从因起理。极难知故。又金刚等一色聚中。现有种种威神力故。又疗人兽树等事中。现有众多希奇用故。又诸物类。遇热日月咒术等缘。便有生变。虽不共合。而现为因。故缘起理。实为难觉。若了如斯缘起正理。则不应说生无自因。曾未见故。像定非有。诸有说像乍可非无然非造色。此言粗浅。无劳酬对。若非造色。应非眼境。但应言像非唯造色。是故诸像实有理成。非像理成。便能顺立拨无中有者色间断生喻。许质与依中间有物连续无断而生像故。谓月面等大种。恒时法尔。能生清妙大种。无间遍至。现对所依。在所皆生似本像色。依若清澈。像显易知。依若粗秽像隐难了。虽二中间亦有像色。由清妙故。在依方显如日光等。虽复遍生。在壁等依。方现可见。如何知像连质而生。中间有隔。像不生故。谓若月等。中无连续。于水等中。能生像者。中间有隔。像亦应生如彼所宗。执无中有。余处蕴灭。余处蕴生。又像形容。屈伸俯仰。及往来等。随本质故。由斯证像连质而生。不可引为遮中有喻。非像无故。为喻不成。但由非等坏随质故。谓见诸像。坏随本质。生有亦随死有灭者。有情相续。便有断过。又诸像生。似本质故。谓月等像。定似本质。从牛等死有。应唯牛等生。既不许然。故喻非等。又从一质。生多像故。谓随质依。生诸像位。可从一质随对镜等。众多所依遍生多像。非从一蕴相续死有。多蕴相续生有俱生。故像于斯。非为等喻。又质与像。非相续故。谓质与像。非一相续。像与本质。俱时有故。诸相续者。必不俱生像质俱生。故非相续。有情相续。前后无间。于此处死。余处续生。但应引谷。为同法喻。像非等故。为喻不成。又所现像。由二生故。谓二缘故。诸像得生。一者本质。二者镜等。世间现见。生有不尔。所以者何。生有如像。死有如质。更有何法。如像所依。故所引喻。与法非等。若精血等。如像所依。理亦不然。非有情故。又于空等。欻尔化生。于中执何如像依处。若谓唯识相续流转。连续死生其义已立。执色相续。复何所成。此不应理。诸有于色。未得离贪离色。唯心相续流转。理不成故。若心离色。可相续流。则应受生。定不取色。故心相续。必与色俱。方能流转。往受生处。又契经说。唯缚而生。唯缚而死。唯由被缚。从此世间。往于他世。圣说一切未离色贪。无不皆被色缚所缚。故无唯识相续流转。亦不可计前本有色。即能相续往后生处现见死处。身丧灭故。由此应知。别有色往。是故中有。定有理成。若谓现见离色心转。谓住于此。速取月轮。住缚喝国都城。念波吒厘子邑。世尊亦说。我不见有一法回转速疾如心。又契经说。心远行独行无身寐于窟。如是等类。非于中间别物可得。如是死生际中有虽无。而从此世间至于他世。此亦非理。前已说故。取非至境故。依等速转故。谓前已说。未离色贪离色唯心流转非理。又眼意识。取非至境。心住于此。远取月轮。遥念他邑。亦无有过。非心往至所取念境。曾不见识离所依生。或亦曾无离依无过。由此已释心远行等。又于所依境界行相。心疾回转。非离所依唯往境界速疾回转。是故知心非离于色。相续流转往受生处。由斯中有实有理成。如是已明像连质起。死生处隔。同喻不成。由此亦遮响声为喻。以声与彼谷等中间有物相续传生响故。谓本发声。所依大种。传生妙大种。遍至谷等中所在击生。似本声响。中间虽有声响相续。或散微故。而不可闻。若于中间。触山谷等。即便聚积。亦可得闻。云何知然。异时闻故。谓诸听者。先闻本声。于后方闻声所发响。若谓无间刹那闻者。二刹那前后难了知故。应起增上慢。谓一时闻。而不谓然知声相续中间淹滞。觉异时闻。由如是声相续展转。至于谷等方击响生。弥更证成。定有中有。岂不汝宗亦定不许诸声相续转入耳闻。如何言声相续展转。遇缘发响。异时方闻。汝责不然。我不遮故。谓声相续转。非我所遮。唯转入耳闻。非我所许。诸有大种。发声缘处。展转相击。皆有声生。在可闻缘声方可取。于中先取本质处声。于后乃闻异处生响。无同外道至根闻过。非声相续转入耳闻。以有先闻质处声已。后时异质。及离耳根更于别处。闻所发响。若唯能取逼耳生声。应不遥闻异方声响。故非相续转入耳闻。亦非诸声无相续转。遥闻声响。方所别故。声响异时异处闻故。由此中有定有义成。有余师言。风等缘合有差别故。声展转至。及不离质二。皆可闻是。则耳根。应能通取至不至境成。违宗过

说一切有部顺正理论卷第二十三阿毗达磨顺正理论卷第二十四

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩缘起品第三之四

有余复言。如无色界殁。中无连续欲色界色生。如是亦应此死有灭中。无连续彼生有起。所引谷喻。于证无能。又此喻中有非爱过。谓同法喻。例法应同。然谷等种中。唯生谷芽等。如是人殁。应但生人。牛等殁时。唯生牛等。故喻于此有非爱过。又种灭处。即有芽生。应眼根中识等灭已即于是处识等还生。则唯一根。恒生识等。如是耳等便为无用。又一身中。识等灭已。即复于此识等还生。是则恒存应无死义。如是死有于此处灭。即于此处中有复生。后后念生即前前处。乃至中有灭。即此生有生。是则应无往余生义。中有胜用。于此顿亡。巧立如斯害自宗喻。此皆非理。所以者何。从无色殁。生有色者。色法生时。有连续故。谓无色殁。生欲色时。即由是处大种和合。从顺后受业。有异熟色生。故彼色生。非无连续。或总相续无间断故。谓无色界。异熟终时。四无色蕴。无间无断。为缘引发。欲色界中。与色俱生。诸蕴令起。故彼色起。非无连续。欲色界殁。欲色界生。死生中间。处所悬隔。若无少物于中连持。无色死生下。岂得为同喻。又于此中。无非爱过。如一稻种。为芽糗饭灰散五因。如是有情一趣相续。为五因故。谓一稻种。能为五因。若遇顺缘。便生自果。如是一趣有情相续。具为五因。若遇如是顺缘和合。便生自果。故无人等灭唯生自类过。又无如种芽同处生灭失。以种相续生芽等时。虽无间断。非无处异。准斯理趣。内法亦然。故无果因唯同处失。谓诸种聚。于灭坏时。由水等缘和合摄助。能为粗大芽聚生因。于种灭时。芽异处起。芽虽增长转至远方。而于中间。邻次无断。由此外法从种生芽处非隔即邻次道理。如是内法。随所依身。心相续转。亦无有失。谓于死时。大种等聚。由业风等缘所摄持。能与当生邻死处起大种等聚。为能生因。独业不能令彼色聚中无连续远处欻生。邻死所生。即是中有。从兹展转。趣余方生。于其中间。非即非越。能至生有。如从种等芽等渐生能至于果。故举谷喻。非害自宗。或复何劳强拨中有。世曾未见。有诸色聚。中无连续。于异处生。唯见影光火焰等事中间连续至余方生。故非顿亡中有胜用。然眼识等。缘和合力。不越依身。别别处起。无方所故。非住一根于一身中识常生灭。恒无死难由斯已解。或复死者同分蕴灭。异分蕴生。故无斯过。且化生者。先世所作业果色根。并所依处。此处顿灭。即于此处。容有其余业果顿起。可疑死位与前无别。余三生者。先世所作业果。色根相续虽灭。而见依处相似随转。非后色根无所依处。别业果故。非即依前。由此证知。余业所感。根及依处。邻次前身根灭所依。异处而起。有对碍法。自所住方。必能障余。令不起故。于此无有恒不死疑。有余复言。犹如尺蠖前安前足后足后移。如是死生方所虽隔。先取后舍。得至余方。是故于斯中有无用。毗婆沙者。贬此释言。此释极同下俚言义。如是便有非二有情二趣二心俱行过故。又尺蠖喻。其理不成。以彼虫身中无间绝。安前移后。处隔可然。死生有身。中间隔绝。如何可得取生有身。既未取生。如何舍死。非心心所处无断可成。离所依身处续义无故。若谓有色为无断依。则为中有义已成立。若谓死生虽隔而到。则尺蠖喻。义不相应。有余复言。死生二有。虽隔而至。如意势通。此亦不然。非所许故。异此余类。此殁彼生。中间隔绝。应成通慧。若尔此应是行差别。实尔细故难可了知。谓一刹那。不应为难。故前谷喻。无过理成。以要相连处无间断。生有起故。定有中有。又有别理。中有非无。现见刹那无间生者。决定方所无间生故。谓世现见。从执受色。无间还生执受色者。刹那处所。俱无间生若生有色。许从死有刹那无间邻近而生。处所亦应无间邻近。然无如是理故。中有义成。若谓如从无色界殁生有色界。色初起时。昔色与今。方所无间刹那有间。而得续生。亦应下界死生有色刹那无间处有间生。此亦不然。不了宗故。谓于昔者。从欲色殁。生无色时。色身灭处今从彼殁。生欲色时。即前色身灭处。无间引今色起。非我所宗。是故此中。刹那处所。俱非邻近。不应为喻。又若刹那邻近生者。处所定尔。非由种故。谓诸刹那无间生者。处所必定。亦无间生非此相违。有斯决定。故彼所例。理不相应。又余缘合。方成因性现所见故。中有义成。谓诸种子。余助缘合。能作芽因。世所现见。如是识种。生生有色。必藉生处。外色为缘。故识定与生处色合。不应一识与死有身及生处所处间断色有俱合义。故有中有。若谓非色无所住处故无过者。理亦不然。无所住言。依遮诸识住根及境。如人座故。非识与色合义全无。以契经言有识身故。又经说识不离身故。若谓死有色亲能为因。如中有色生生有色者。亦不应理。死有与生处所隔绝。不成因故。或外助缘精血等色。与彼隔绝。应无助用。故应别有生有色因与精血合。此即中有。又如何知。定有中有。现可得故。谓中有身。净天眼者。现前可得。故如是说。诸中有身。极净天眼之所能见。又彼尊者阿泥律陀亦言。具寿我观佛化其量最多。非诸中有。是故中有。决定非无。又圣教说有中有故谓契经言。有有七种。即五趣有业有中有。又经说有健达缚故。如契经言。入母胎者。要由三事俱现在前。一者母身是时调适。二者父母交爱和合。三健达缚正现在前。除中有身。有何别物。名健达缚正现在前。若谓二经非我所许。非汝不许故此便无。谓无定因可为诚证。汝不许者。其体皆无。有谓后经应如是说。塞建陀灭正现在前。传者谬诵。为健达缚。于此位中。乐器无故。此非经义。于此位中。前蕴已灭。无来义故。然余经中。说健达缚东南西北诸方来故。如掌马族契经中言。汝今知不。此健达缚正现前者。为婆罗门。为刹帝利。为是吠舍。为戌达罗。为东方来。为南西北。复如是说。随是何族。随从何方。来现在前。非前蕴灭可有来义。故彼所言。依自计度。又世论说。由二因缘。女男交会。事极成立。一健达缚。二逻刹娑。初令自生和合贪故。后由强力现所逼故。然中有身。符顺初义。彼虽无乐器。而健达缚成。或随世间。假立名想。何劳于此起固执为。设于此经。彼亦不诵。岂复不信如是契经。如说汝非此他俱世当于中有能作苦边。又说将殁将生时故。如契经言。我以天眼观有情类。将殁将生。此将生言。即目中有。从此殁已。未生彼故。有谓此说究竟为远。于已生位。说将生言。如说大王今何来此。应于已殁说将殁言。差别因缘不可得故。又设尔者中有亦成。于此已殁未生彼故。或于已生再说无用。又非唯究竟方说远言。现见有远言亦说远故。如世尊告舍利子言。汝观此童。今来诣此。由此定证。将生时言。非说已生。但目中有。又可住经说意成故。谓世尊告彼可住言。若于尔时。彼有情类。此身已舍。住意成中。后一类身。未已生位。我施设彼。当于尔时。所住意成。有爱及取。言意成者。即中有身。由此证知。定有中有。有随自执。妄释此经。言意成声。诠无色界。彼谓可住朋友命终。超有色天。生于无色。可住天眼观不能见。来问世尊。若于尔时。彼有情类。乃至广说。一类身者。欲色界身。住意成言。显在无色。此执非理。无定因故。且应征问。拨中有者。此意成声。乃目多义。如何定执诠无色耶。谓于劫初。色无色界。变化中有。皆见此声。如其次第。略当显示。如说彼位有色意成。一切支体。无不具足。又说超越食段食天。随生一类意成天处。又世尊告邬陀夷言。意成天身。汝谓何等。岂不汝谓是无色名。又说从此身起意别。化作余身种类有色意成。又说此身无间坏已。起如是蕴。有色意成。故意成声。乃目多义。如何定谓诠于无色。若谓余说此责亦同。理不应尔。前身已舍。后未已生。经所说故。又彼所执。理不应然。若为可住。说无色界为意成者。彼则不应以天眼通观欲色界。非离色贪可生欲色。若为求彼所生处故。以天眼通观二界者。不应说无色为所住意成。以不定知彼生处故。由此经说。住意成言。专为显成有中有义。又何经证中有非无。由经说有五不还故。谓世尊说。有五不还。一者中般。二者生般。三无行般。四有行般。五者上流。中有若无。何名中般。若谓欲色二界中间得般涅槃名中般者。不生二界中有复无。何有有情于中趣般。若谓于彼有天名中。理必不然。无圣言故。谓于诸部。都无有经说有中天。唯凭自计。又彼应有太过之失。谓亦应有生等诸天住彼得般名生般等。若谓如言有中生般。亦许成立中生二有。虽复说有有行等般。而不许立有行等有。如是虽许别有中天。何废天名。不通生等。此亦非理。有行等三。别立有名。无别用故。非为住彼趣般涅槃。是立中生二有别用。又必无有住生有中得般涅槃。一刹那故。非更别立。有行等有。于立有门。少有别用中生等位。别立有名。于立有门。各有别用。唯立四有。有用便足。无劳别说余别有名。若立中天唯有趣般用。生等何故不别立天名。若立中天不约此用。然许别立有中天名。生等亦应然无定别因故。有何定用立中天名。而生等无故不应理。又所立名。皆随义故。无容于此妄立异名。谓有加行道精勤运转。得般涅槃。名有行般。若无加行道非勤运转。得般涅槃。名无行般。无容于此更立异名。所立中天。但随汝自欲。谁遮自欲。不立生等天。是故非斯妄分别论能遮中有。故此非无。又如何知。定有中有。由契经说。有七善士趣故。谓于前五。中般分三。由处及时远近中故。譬如札火小星迸时才起近即灭。初善士亦尔。譬如铁火小星迸时起至中乃灭。二善士亦尔。譬如铁火大星迸时远未堕而灭。三善士亦尔。若无中有。此依何立。非彼所执别有中天。有此处时。三品差别。故彼所执。定为非理。有说诸有寿量中间。断余烦恼。皆名中般。由至界位。或想或寻。而般涅槃。故说三品。彼谓烦恼随眠位中。修断加行。名至界位。此中意显有种未行。说名界位。即利根者。创起烦恼。便能精勤。修断加行。名至想位。此中意显染想初行。说名想位。即中根者。起烦恼久。方能精勤。修断加行。名至寻位。此中意显。由烦恼力。令心于境种种寻求。说名寻位。即钝根者。世尊依此。善士趣中。分析中般。说为三种。此虽巧计。义实不然。若尔现般。应非有故。又无寻地。亦说中般。如嗢柁南伽他中说

  总集众圣贤　　四静虑各十
  三无色各七　　唯六谓非想

此伽陀中。第二静虑以上三地。亦说中般。诸中般皆断五下分结故。非无寻地可说至寻。非上三地中阙一善士趣。又无色界应有中般。有寿量中间得般涅槃故。又薄伽梵舍利子等。一切皆应是中般摄。唯除生在睹史多天后身菩萨。及除生在北俱卢洲诸有情等。其余有情。容中天故。又彼或余诸有所执。皆札火等喻不相应。远近及中处时差别。若离中有皆不成故。汝等但由贪着己见。憎背中有。起斯妄执。非为依随圣教正理。是故中有实有极成。拨中有无。是何见摄。是迷因果连续为先所起邪见。诸经说谤化生有情是邪见故。已广成立中有非无。今复应思。当往何趣。所起中有形状如何。此何所疑。此与生有一异业果。俱有过故。所以者何。若中生有同一业果。便违经说。有数取趣。已断生结。未断起结。乃至广说。诸业必由烦恼起故。业如烦恼。应有差别。则中有形应异当趣。若中生有。各异业果。何缘二果定先后生。此中有业。顺现受等所不摄故应唯不定。又见人等。宿业虽别。而有身形相似无异。有业虽一。而果有殊。故可生疑。诸趣中有。与当所趣形为同别。为遣此疑。颂曰

  此一业引故　　如当本有形
  本有谓死前　　居生刹那后

论曰。业有二种。一牵引业。二圆满业。中生二有。牵引业同。圆满业异。引业同故。此中有形。与当本有。其状相似。如印所印文像不殊。若尔于一猪等腹内。容有五趣中有顿起。可有五子俱时命终。各当往生一趣中故。既有地狱中有现前。如何不能焚烧母腹。无斯过失。以地狱火唯烧有罪诸有情故。非不积集感彼业者。或未得果可为地狱火所焚烧。其理决定。又彼中有。非恒被烧。如何即令焚烧母腹。地狱本有。尚不恒烧。如暂游增。况彼中有。有言设许中有恒烧。如不可见。亦不可触。身极细故。所难非理。诸趣中有。虽居一腹。非互触烧。业所遮故。欲中有量。虽如小儿年五六岁。而根明利。有余师说。欲界中有。皆如本有盛年时量。有言菩萨中有可然。非余有情中有亦尔。菩萨中有。如盛年时。形量周圆。具诸相好。故住中有。将入胎时。照百俱胝四大洲等。为顺方域吉瑞相故。令菩萨母于其梦中见白象子来入右胁。九十一劫。已舍傍生。况最后身。仍为白象。有说中有。皆生门入。非破母腹而得入胎。故双生者。前小后大。理实中有。随欲入胎。非要生门。无障碍故。然由业力。胎藏所拘。色界中有量。圆满如本有。非色究竟中有身形。长十六千踰缮那量。赡部洲趣。无处能容。以太虚空极宽广故。中有身色。如末尼珠。灯等光明。无障碍故。色界中有。与衣俱生。惭愧增故。欲界中有。多分无衣。无惭愧故。唯除菩萨。及鲜白尼。本愿力故。有余师说。唯除此尼。施僧袈裟。发胜愿故。从兹世世。有自然衣。恒不离身。随时改变。乃至最后般涅槃时。即以此衣。缠尸焚葬。收其遗骨。起窣堵波。亦有衣形。周匝缠绕。菩萨所起一切善法。皆唯回向无上菩提。我等所宗许二俱有说。所似本有。其体是何。谓在死有前生有后蕴。总说有体。虽通一切有漏法性。而就有情前后位别。分析为四。一者中有。义如前说。二者生有。谓于诸趣。结生刹那。三者本有。除生刹那。死前余位。四者死有。谓最后念。若有于色未得离贪。此有无间中有定起。即于一生。位别分四。岂不诸有中有最初。则本有名。应目中有。非目中有。以当无间。生等三有。非彼果故若位容有。生当无间。中等诸位。可名本有。望余生诸位。安立此名。非立此名望一生三位。又此无间。定生彼有。此有望彼立本有名。又本有名目正所趣。余三不尔。不得此名。已说形量。余义当辩。颂曰

  同净天眼见　　业通疾具根
  无对不可转　　食香非久住
  倒心趣欲境　　湿化染香处
  天首上三横　　地狱头归下

论曰。此中有身。是何眼境。为同类眼净天眼见。谓中有身。唯同类眼。及余修得净天眼见非不同类不净天眼之所能观极微细故生得天眼尚不能观况余能见以说若有极净天眼方能见故。有说地狱傍生饿鬼人天中有。如其次第。各除后后。见自及前。为有能遮中有行不。上至诸佛。亦不能遮。以诸通中业通疾故。中有成就最疾业通。故契经言中。有业力。最为强盛。一切有情。一切加行。无能遮抑陵虚自在。是谓通义。通由业得。名为业通。此通势用速故名疾。中有具此最疾业通。诸通速行。无能胜者。依此故说。业力最强。随地诸根。中有皆具。虽言中有。如本有形。而初异熟。最胜妙故。又求有故。无不具根。曾闻析破焰赤铁团。见于其中有虫居止。故知中有无对义成。对谓对碍。此金刚等。所不能遮。故名无对。此界趣处。皆不可转。谓定无有色中有殁欲中有生。亦无翻此。此与生有。一业引。故应知趣处不转亦然。此中有身。资段食不。且如欲界中有食香。随福多福少。香有好有恶。由斯故得健达缚名。诸字界中。义非一故。此頞缚界。虽正目行。而于其中。亦有食义。以食香故。名健达缚。而音短者。如设建途及羯建途。略故无过。有说中有。藉香持身。以寻香行。名健达缚。如是中有。为住几时。此中有身。定非久住。生缘未合非久。如何大德释言。常途非久。缘未合者。容住多时。由彼命根非别业引。有余师说。此但少时。以中有中恒求生故。若于父母。俱定不移。虽住远方。业令速合。若于父母。随一可移。虽极清贞诃厌欲者。而于异境。起染现行。诸起染定时令非时亦起。或寄相似余类中生。谓驴等身。似于马等。非由所寄同分有殊。便失中生一业所引。生缘虽别。所引一故。设许转受相似类生。由少类同。亦无有过。又界趣处。若不全移。虽少类殊。亦无有失。以界趣处业定不移。余外生缘见有差别。如豆足等。斯有何过。或业种类。差别无边。唯佛世尊。方能究达。正结中有。为以何心。以染污心。譬如生有。将结生有。方便如何。住中有中。为至生处。由心颠倒。驰趣欲境。彼宿业力。所起眼根。虽住远方。能见生处父母交会。而起倒心。若当为男。于母起爱。于父起恚。女则相违。由是因缘。男女生已。于母于父。如次偏朋。故施设论。有如是说。时健达缚。于二心中。随一现行。谓爱或恚。彼由起此二种倒心。便谓己身与所爱合。所憎不净。泄至胎时。谓是己有。便生喜慰。当生喜位。名入母胎。取最后时所遗精血二三滴许。成羯剌蓝。精血相依。无间而住。中有蕴灭。生有蕴生。若男处胎。依母右胁。向背蹲坐。若女处胎。依母左胁。向腹而住。女男串习左右事故。宿自分别力使然故。无欲中有非女非男。以中有身不阙根故。入母胎后。或作不男。如何无根羯剌蓝大种体。即能作诸色根生依。谁谓色根依彼大种。中有大种。以羯剌蓝大种为依。能生生有。谓彼中有。与羯剌蓝大种相依。最后灭位。中有大种。藉彼为缘为因。引生异前大种。彼异大种。能作根依。如种生芽。必依地等。若尔何缘契经中说。父母不净。生羯剌蓝。依不净生。无违经失。有余师说。精血大种。于转变位。即作根依。谓前无根中有俱灭。后有根者。无间续生。如种与芽灭生道理。彼执生有色法生时。非中有色相续而起。与芽从种道理相违。无情与情。为种引起。不应道理。相续异故。有情无情二色俱灭。后情色起。无情为因。情不为因。言非应理。是故前说。于理为胜。此说欲界胎卵二生。湿化二生。染于香处。若湿生者。染香故生。谓远嗅知生处香气。便生爱染。往彼受生。随业所应。香有净秽。若化生者。染处故生。谓远观知当所生处。便生爱染。往彼受生。随业所应。处有净秽。生地狱者。亦由业力。或见身遇冷雨寒风。或见身遭热风猛焰。冷侵热逼。酷毒难忍。希遇温凉。冀除所厄。见热地狱热焰炽然。寒地狱中寒风飘鼓。便生爱染。驰躬投赴。有余师说。由见先造感彼业时。己身伴类。心生爱慕。驰往赴彼。往何趣中有。何相赴生处。且天中有。首正上升。如人直身从坐而起。人等三趣中有横行。如鸟飞空往余洲处。地狱中有。头下足上。颠坠其中。故伽他说

  颠坠于地狱　　足上头归下
  由毁谤诸仙　　乐寂修苦行

因辩中有复应伺察。何缘无色无中有耶。彼业不能引中有故。何缘彼业于此无能。起结断已。方生彼故。烦恼助业。方能引果。非离烦恼业有引能。以阿罗汉虽有诸业而不能引当来有故。有说若地具粗细业。于彼地中。得有中有。然无色界。有细无粗。粗细业者。谓色非色。或身等业。或十业道。此复应诘。何缘若地。具粗细业。方有中有。今于此中。见如是意。中有是细。所趣是粗。以所趣中满业多故。又趣寿限。容有定故。有位中受细满业果。有位中受粗满业果。欲色界中。具二业果。故有中有。无色不然。有余师说。为往生处。表所趣形。故立中有。非无色界有处有形。若尔即于自死尸内。身根灭处。命终受生。不往余方。中有何用。此立中有。表所趣形。前说二缘随有一故。此救非理。表所趣形。于所趣生。无胜用故。若中有已起。可表所趣形无用。故不起何能表所趣。故表所趣。非中有因。然上座言。若命终处。即受生者。中有便无。彼言非善。非死有位方引中有。如何可说。若死处生。不引中有。定于先时已作增长。感中有业。今谁为碍。令中有果不起现前。或复中生同一业果。中有复是一期生初。中有若无。生应不续。如必无有越羯剌蓝生頞部昙。是彼初故。若谓生有是一期初。中有非初。不必须引。此都无义。但有虚言。彼生起结。俱未断故。汝亦应许。未断生结生有或无。无异因故。非须别用方有蕴起。蕴起必由因未离爱。彼即中有须起之因。如有胎中定当死者。除由因力。何用根生。若谓此应如中般者。无生满业。如是即于死处生者。无中满业。此例不齐。如生有位必依中有。非中有位亦依生有。故例不齐。由斯一切未离第四静虑贪者。彼若已造生有满业。必亦能造中有满业。不说自成。或有不还。由对治力。伏相续故。生结不行。此唯能造中有满业。若阙对治是俱堕法。彼无能碍二结现行。由是未离色界贪者。生有必依中有起故。设于死处即受生者。亦定应许。死有无间中有即生。中有无间生有方起。又此中有。有决定相。谓无未离欲色界贪。生有不从中有后起。亦无中有与所趣生。非同一业所牵引果。亦无中有能入无心可为身证。俱分解脱。及起世俗不同分心。住中有中。无转根义。亦无能断见所断惑。及无断欲界修所断随眠。如是等门。皆应思择。一切中有。皆起倒心入母胎不。不尔云何契经中说。入胎有四。其四者何。颂曰

  一于入正知　　二三兼住出
  四于一切位　　及卵恒无知
  前三种入胎　　谓轮王二佛
  业智俱胜故　　如次四余生

论曰。有诸有情。多修福慧。故死生位。念力所持。心想分明。正知无乱。于中或有正知入胎。或有正知住胎。兼入。或正知出兼知入住。兼言为显后必带前。有诸有情。福慧俱少。入住出位。皆不正知。前不正知。后位必尔。如是所说四种入胎。具摄一切。入胎皆尽。顺结颂法。如是次第。然契经中。次第不尔。如是四种。且说胎生有愚不愚分位差别。诸卵生者。入胎等位。皆恒无知。如何卵生。从卵而出。言入胎藏。此据当来立名无失。如世间说造钏织衣。或说卵生曾入胎等。依今说昔。故无有过。应知此中。依想胜解有倒无倒。故说正不正知。谓诸有情。有倒想解。于中或有业智有失。彼入胎位。起倒想解。见大风雨毒热严寒。或大军众声威乱逼。遂见自入密草稠林叶窟茅庐。投树墙下。于中或有业虽无失。由智有失。起倒想解。入母胎位。自见己身。入妙园林升花台殿。坐卧殊胜诸床座等。住时见己住在此中。出位见身从此处出。是于三位。皆不正知。若诸有情。无倒想解。彼入胎位。知自入胎。住出胎时。自知住出。是于三位。皆能正知。四种入胎经应随此义释。何缘入胎不正知者。于住出位。必不正知。劣悟胜迷。理无容故。谓将入位。支体诸根。具足无损。强胜明利。尚不正知况住出时。支根损缺。羸劣暗昧。而能正知。理无容故。住正知者。由入胎时。胜正知因。一力引故。出正知者。由入住时胜正知因二力引故。又前三种入胎不同。谓转轮王。独觉大觉。如其次第。初入胎者。谓转轮王。入位正知。非住非出。二入胎者。谓独胜觉。入住正知。非于出位。三入胎者。谓无上觉。入住出位。皆能正知。此初三人。以当名显复有差别。如次应知业智及俱三种胜故。第一业胜。宿世曾修广大福故。第二智胜。久习多闻胜思择故。第三俱胜。旷劫修行胜福慧故。除前三种。余胎卵生。福智俱劣。合成第四。有说此四皆辩菩萨。谓最后有。即是第三睹史多天。前生第二。遇迦叶波佛。次前生为初。自此以前。皆是第四。或复初二三无数劫。如其次第。前三入胎。自此以前。皆是第四。岂不续有定是染心。何容正知入母胎藏。正知正念。说根律仪。夫根律仪。决应是善。无斯过失。一切正知。皆善性摄。非所许故。异此应无正知诳语。或入胎位。据相续说。非唯正结。生有刹那。于此位中。善心多起。染污心少。故说正知。如世间说白豆聚等。或令于彼发起恭敬。于不迷乱。立正知名。谓如实知。此是我父。此是我母。故名正知。云何第三。后有菩萨。于戒果等。皆明了知。而入胎时。有如是事。非入住位。有不正知。可于出时有正知理。出正知者。先因引故。无斯过失。由无始来串习如是世俗爱故。世间现见。由串习力。于才生时。便有爱染。如何可说四种入胎。唯正不正知二种入胎故。非住及出可说入胎。故不应言入胎有四。以入胜故。说四无失。谓入胎时。有差别故。于住出位。有能正知。以无不正知。入母胎藏。于住或出位。能有正知。故于住出。无倒想解。能自知者。由入差别。是故入胎声。兼说住出位。故住出位。虽有正知及不正知。而不成六。由入胜故。虽有三种。同异类殊。而总说入。所以然者。由尔所门。说处母胎。事究竟故。如是异类。有二入胎。于同类中。复二成四。此中应说。谁往入胎。何故问谁。以无我故。谓若无我。为复说谁。从此世间。乘中有蕴。往趣他世。入住出胎。是故应有内用士夫。从此世间往入胎等。为遮彼故。颂曰

  无我唯诸蕴　　烦恼业所为
  由中有相续　　入胎如灯焰
  如引次第增　　相续由惑业
  更趣于余世　　故有轮无初

论曰。无有实我能往入胎所以者何。如色眼等自性作业。不可得故。托所依缘。识等起位。所执别用实我不成。别用既无。又无自性明了可得。如兔角等。如何执有内用士夫。世尊亦遮所执实我。是作受者。能往后世。故世尊言。有业有异熟。作者不可得。谓能舍此蕴。及能续余蕴。乃至广说。复如何知。所执实我。是作者等。实不可得。为体无故。为体实有。有不得因。无得因故。我宗定许。由我体无。故不可得。非余因故。诸起我执无过四种。一执有我即蕴为性。二执异蕴住在蕴中。三执异蕴住异蕴法。四执异蕴都无所住。如是四种执我。有实而不可得。皆不应理。且非有我即蕴为性。即别即总。皆不成故。所以者何。各别自相。所不摄故。应成假故。亦非异蕴住在蕴中。体常无常。俱有过故。若无常者。念念各异。便非一我。有死有生。即作者应失。不作者应得。又非离蕴有生灭法少分可得。故非无常。若谓是常。应无转变。生老病死。皆不应成。又应无容别往余趣。又爱非爱境界合时。我不应随苦乐转变。亦不应为苦乐相应烦恼所恼。既非所恼。不应由斯起法非法。则未来世爱非爱身。既无有因。应无生理。则不可说我体虽常由身改转。说我变异如是我体不随自身。生老病死。诸趣苦乐。烦恼业果。而转变故。则应本来毕竟解脱。既不许尔。故我非常。离常无常。不可别执。有第三聚。计之为我。如虚空等。诸无为法。体异蕴故。不住蕴中。此亦应然。应不住蕴亦非异蕴。住异蕴法。染净蕴法。既不相依。则所计我。便成不用。既不依蕴非蕴何依。我与非蕴。不相关故。亦非异蕴。都无所住。如无为法。过同前故。又应本来。常解脱故。谓所执我。既无所住。则与色身。苦乐等受。小大等想。善恶等行。色声等识。都不相关。则应本来远离五蕴。不由功用。自然解脱。是故所执实我作者。能舍此续余无。故不可得。非体实有。有不得因。得因无故。而不可得。若尔外道。于何所缘。而起我执。虽离诸蕴无别我性。为执所缘。然唯诸蕴。为境起执。如契经说。诸有执我等随观见。一切唯于五取蕴起。虽无如彼外道所说真实我性。而有圣教。随顺世间所说假我。既无实我。依何假说。虽无实我。而于蕴中。随顺世间。假说为我。何缘知说我唯托蕴非余。以染及净法唯依蕴成故。谓我实无以诸杂染。但依诸蕴刹那相续。由烦恼业势力所引。中有相续。得入母胎。譬如灯焰刹那相续转至余方。诸蕴亦尔。且于欲界。若未离贪。内外处为缘起。非理作意贪等烦恼。从此而生。劣中胜思及识俱起。起已能牵当非爱果。亦为无间识等生缘。无间识等。观同异类。前俱生缘。而得起时。或善或染。或无记性。起已复能引自当果。及为无间识等生缘。如是为缘。后后次第。能牵二果。随应当知。此蕴相续。领纳先世惑业所引寿量等法。彼异熟势。至穷尽时。死识与依。俱至灭位。能为中有识等生缘。中有诸蕴。由先惑业。如幻相续。往所生处。至母腹内。中有灭时。复能为缘。生生有蕴。譬如灯焰。虽刹那灭。而能前后因果无间展转相续。得至余方。故虽无我。蕴刹那灭。而能往趣后世义成。即此诸蕴。如先惑业势力所引。次第渐增。于一期中。展转相续。复由惑业。往趣余世。现见因异其果有殊。故诸引业。果量非等。寿果长短。由业不同。随业增微。所引寿命。与身根等。展转相依。于羯剌蓝頞部昙等。后后诸位。渐渐转增。何等名为羯剌蓝等。谓蕴相续。转变不同。如是渐增。至根熟位。观内外处。作意等缘和合发生。贪等烦恼造作增长。种种诸业。由此惑业。复有如前。中有相续。转趣余世。应知如是。有轮无初。谓惑为因。能造诸业。业为因故。力能引生。生复为因。起于惑业。从此惑业。更复有生。故知有轮旋环无始。若执有始。始应无因。始既无因。余应自起。无异因故。现见相违。由此定无无因起法。无一常法。少能为因。破自在中。已广遮遣。是故生死决定无初。犹如谷等展转相续。然有后边。由因尽故。如种等尽芽等不生。生死既无。究竟清净。故染及净。唯依蕴成。执有实我。便为无用

说一切有部顺正理论卷第二十四阿毗达磨顺正理论卷第二十五

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩缘起品第三之五

已说内外羯剌蓝等种等道理。因果相续。应知此即说名缘起。如是缘起。非唯十二。云何知然。如本论说。云何为缘起。谓一切有为。然契经中。辩缘起处。或时具说十二有支。如胜义空契经等说。或说十一。如智事等经。或唯说十。如城喻等经。或复说九。如大缘起经。或说有八。如契经言。诸有沙门。或婆罗门。不如实知。诸法性等。诸如是等所说差别。何缘论说与经有异。论随法性。经顺化宜。故契经中。分别缘起。随所化者机宜异说。或论了义。经义不了。或论通说情及非情。契经但依有情数说。依有情故。染净得成。佛为有情。开显此二。但为此事。佛现世间。故契经中。依有情说。为欲成立大义利故。分别缘起。诸有支中。具无量门义类差别。今且略辩三生分位。无间相续。有十二支。颂曰

  如是诸缘起　　十二支三际
  前后际各二　　中八据圆满

论曰。十二支者。一无明。二行。三识。四名色。五六处。六触。七受。八爱。九取。十有。十一生。十二老死。言三际者。一前际。二后际。三中际。即是过未及现三生。云何十二支。于三际建立。谓前后际。各立二支。中际八支。故成十二。无明行在前际。谓过去生。生老死在后际。谓未来生。所余八在中际。谓现在生。前际二因。所招五果。后际二果。所待三因。非诸一生皆具此八。据圆满者。说有八支。圆满者何。谓支无缺。或由圆满。惑业所招。谓先增上惑业所引。此中意说。补特伽罗。历一切位。名圆满者。非诸天中及色无色。羯剌蓝等诸位阙故世尊但约欲界少分补特伽罗。说具十二。如大缘起契经中说。佛告阿难。识若不入胎。得增广大不。不也世尊。乃至广说。是故若有补特伽罗。于次前生。造无明行。具招现在。识等五支。复于现生。造爱取有。招次后世。生等二支。应知此经依彼而说。若依一切补特伽罗。立诸有支。便成杂乱。谓彼或有现在五支。非次前生。无明行果。及次后世。生老死支。非现在生爱取有果。彼皆非此。经意所明。勿见果因相去隔绝。便疑因果。感起无能。应知缘起支。略唯二分。前后际如次七支五支。以果与因属因果故。或因与果。五支七支。以因摄因。以果摄果故。谓现爱取。即过无明。现在有支即过去行。现在世识。即未来生。余现四支。即当老死。是名因果二分差别。此缘起言为目何义。今见此中差别义者。谓钵剌底。是现前义。壹女界是有义。一字界中。有多义故。由先钵剌底。壹女界成缘。讫埵缘是已义。此合所依变成猎比参。是和合义。嗢是上升义。钵地界是有义。由以嗢为先。钵地界成起。此总义者。缘现已合。有法升起。是缘起义。缘现前言。即目和合。复言和合。有何别用。为成无法唯一缘生。或显俱生前生缘故。缘现前者。显俱生缘。缘和合者。显前生缘。此则显成依。此有彼有。此生故彼生。是缘起义。又钵剌底。显应行义。壹女驮都。显不坏法。参显正集。此意总显世出现因。说名缘起。谓壹女界。由钵剌底为先助故。转变成缘。正集及升。为先助故。令钵地界转变成起。依如是义。立缘起名。经主此中。释差别义。钵剌底是至义。医底界是行义。由先助力。界义转变。故行由至。转变成缘。参是和合义。嗢是上升义。钵地界是有义。有藉合升。转变成起。由此有法。至于缘已。和合升起。是缘起义。如是所释。越彼所宗。且彼有界。由先助力。转变成起。非异有故。再显有义。竟何所成。以彼所宗无有非起无起。非有一应无义。经主自立此句义已。复自假兴如是征难。如是句义。理不应然。所以者何。依一作者。有二作用。于前作用。应有已言。如有一人浴已方食。无少行法有在起前。先至于缘。后时方起。非无作者可有作用。故说颂言

  至缘若起先　　非有不应理
  若俱便坏已　　彼应先说故

又自释言。无如是过。且应反诘声论诸师。法何时起。为在现在。为在未来。设尔何失。起若现在。起非已生。如何成现。现是已生。复如何起。已生复起。便致无穷。起若未来。尔时未有。何成作者。作者既无。何有作用。故于起位。即亦至缘起位者何。谓未来世。诸行正起。即于起位。亦说至缘。非如是言能释前难。以正起位许属未来。彼宗未来。犹未有体。至缘及起。依何得成。故前所难。无少行法有在起前。先至于缘。后时方起。非无作者。可有用言。仍未通释。又言声论。妄所安立。作者作用。理实不成。有是作者。起是作用。非于此中见有作者。异起作用。真实可得。故此义言。于俗无谬。此亦非理。所以者何。作者作用。义非无别。若非依有得有起用。则毕竟无。应成作者。又纵彼说。作者作用。若异若同。且彼未来。以无体故。不成作者。故彼所说。不免前过。大德逻摩。作如是说。为诠表义。故发音声。生灭等声。皆于诸行相续分位差别安立。于多义中。方得究竟。非一刹那细难知故。于相续位。立相既成。于一刹那。亦可准立。如是所说。但有虚言。既说音声为诠表义。彼宗生等。其体实无。故生等声。无义可表。无法不可说为义故。又生等相。非行相续分位安立。前于思择有为相中。已遮遣故要刹那位。立相得成。行相续中。方可准立。由相续假揽实成故。又彼起言。依何而说。非无有用可说用言。非毕竟无。可言有用。故彼于难。亦非善释。唯对法宗说已无过。起及起前。皆可有故。谓对法者言法起时。如已生位。其体实有。可随俗说作者无谬。诸说起位。同毕竟无。而说作者。如何无谬。若谓俱生因果论者。于已言过。无由解脱。已言于我进退无违。作者及时。俱非定故。虽依一作者说有已言。而见有已言依别作者。如依我已汝得不行。虽有已言依前时说。而亦见依后。如开口已眠。虽有已言。依别时说。而亦见有依不别时。如世有说言闇至已灯灭。是故俱生因果论者。于缘起理。进退无失。缘起句义。唯此极成。何故世尊。为释缘起。先作是说。依此有彼有。此生故彼生。而不唯说无明缘等。释缘起义。且上座言。缘起有二。一有情数。二非有情。前两句文。通摄二种。言无别故。无明缘等。唯摄有情。有情有故。然彼上座。亲教门人。有自斥言。此释非理。与摽释理。不相应故。前摽后释。理必相符。如何双摽。后唯释一。又外缘起。于此经中。不应先摽。以无用故。此斥非理。上所释言。不违摽释。非无用故。谓无明等。后所释言。不越摽中有情缘起。故摽释理非不相应。夫置先摽。拟生后释。后既无释。先何用摽。是故但应摽有情数。摽非有情数与释不相符。且非别摽。不释何咎。既无别释。何用总摽。此中总摽。有大义用。谓以现见非情缘起。显不现见内缘起故。种子生芽等世所现知。无明缘行等非世现见。世尊显示。如依种等有芽等得有。及种等生故芽等得生。如是应知。依无明等有。行等得有。无明等生故。行等得生。是故总摽。有大义用。此总显示一切有为无一不从众缘起者。若尔何故。不释非情如于有情。先摽后释。非情易了。但藉总摽。情数难知。故须别释。诸缘起教。多为利根。是故不应所摽皆释。又有情胜。故应广辩。外法亦以内为因故。若尔何故。余契经中。亦有广辩外缘起处。如种喻经等故。所释不然如是师徒。未为贤善。自师劳思。所造论宗。为逞己能。轻为弹斥。善说法者。理不应然。我于此中。详彼所释。一切皆与自论相违。谓彼论说经皆了义。而今释此违彼论宗。释不具申摽中义故。彼便许此非了义经。故此定非彼宗经义。大德逻摩。于自师释。心不忍许。复自释言。若十二支。许依三际即为略摄。三际缘起说。依此有彼有。及此生故彼生。若不许然。即此二句。如次显示亲传二因。此亦不然。且应详辩。为摄三际。说此二门。如是二门。义为同异。义若同者。但说一门。于义已周。余便无用。又违后释。别显二因。非此二言。前后再说。可令义旨。或同或异。若如后释。两义异者。为摄三际。说此二言。即此二言。各应重说。若异此者。非遍一切。则摽与释。义不相符。谓于摽中。所不摄义。释中广辩。义岂相应。故彼还成违摽释理。由此亲传。皆无重言。于诸有支。但随摽一与后广释。不相应故。若谓此二遍属诸支。谓初无明为缘生行。或亲或传。行等亦然。此但悕望。而无实理。后无如是分别说故。是则摽释还不相符。又譬喻宗。过未无体。如何可立亲传二因。且非业无间能生异熟故。业望异熟。亲因不成。亦非传因。传义无故。非业灭已后有余因。由先业力。招异熟果。要先因灭已。余因感果时。远由先因力。方名传因故。诸有横计旧随界等。思择因中。已广遮破。设许有彼传。亦不成远近二因。灭无异故。依何而说。彼远此近。据曾有说。理亦不成。随一有时。随一无故。无法无容说为传故。由此亦破据当有说。现在虽有。未来无故。非无所待。可说有传。是故定知。譬喻论者。但为诳惑。迷真理教。无觉慧人。辄有所释。上座徒党。有释为破无因常因。有释为显因果住生。说斯二句。经主已破。故不重遣。上座复言。依此有彼有者。依果有因有灭。此生故彼生者。恐疑果无因生。是故复言。由因生故。果方得起。非谓无因。经主难言经义若尔。应作是说。依此有彼成无。又应先言。因生故果生已。后乃可说。依果有因成无。如是次第。方名善说。若异此者。欲辩缘起。依何次第。先说因灭。故彼所释。非此经义。如是上座。凡有所言。亲教门人。及同见者。尚不承信。况随圣教。顺正理人。可能忍受。东方贵此。实谓奇哉。经主何缘。但言彼释非此经义。我今说彼上座所言。全无义理。诸有唯说前生为因。及唯现世。有体论者。曾无果有因方有灭。以果有时因已无故。于果起位因可有灭。故因灭时果犹未有。若果有位。因方有灭。许因犹有便坏刹那。又果有时因方许灭。则成因果俱时有过。以果有时因未无故。果于尔时亦有灭故。又若尔者。应不致疑果无因生。俱现有故。谓果有位因方有灭。果现从彼未无因生。如何有疑果无因起。则不应复说。因生故果生。若彼救言。我意不说果有位因方灭。我意但言。要果有位因方有灭。是于果有时因方有无义。设许如是。亦不应疑。谓果有时。因方非有。是则已显因先非无。何容复疑。果无因起。又余处说。依种等有。芽等得有。此有何义。若即有彼义便失自宗。若别有余义。何缘定执。未来名有许非即彼义。过去名有许即彼义耶。又无体法。不应说有。思涅槃中。已具遮遣。又果未有。应立有名。由因已无。仍名有故。由此义故。依此有彼有言。义便不定。然不许尔。是故应知。上座所言。全无义理。然彼经主。差别遮言。非此经义。无异有说此石女儿。非极勇健。又经主述自轨范师释二句义。显己仁孝。彼虽有失。而不彰显。师资之道。理固应然。我于彼师。无所承禀。设为弹斥。无亏大望。故我于此如实显非。谓彼诸师释此二句。为显因果不断及生。谓依无明不断诸行不断。即由无明生故。诸行得生。如是展转。皆应广说。此释不然。经义若尔。即亦应说。行缘无明。亦依行不断无明不断。以行与无明同对治故。非取断位。而可说言。爱犹不断。同对治故。若谓此就现行断说。则后生言应成无用。曾无有一无明现行而不名生。何须重说。故知经主所禀诸师。于诸法相。未为明达。对法诸师。释此二句。诸有支起。必由二因。俱生前生。有差别故。或有但以有体为因。或有为因有之差别。先为标此二种因故。说依此有彼有及此生故彼生。后为释此二种因故。说谓无明缘行。乃至生缘老死。或此二句。义虽无别。而缘起支。略有二种。谓前后际。因果不同。略标前际。故说依此有彼有。略标后际。故说此生故彼生。由此前际定说已有现有。谓依此有彼有。因果如次。在过现故。若于后际。定说现生当生。谓此生故彼生。因果如次。在现未故。前际中果有义已圆。故说为有。后际中果有义未满。故说为生。果正所求故随果说。或依二谛。释此二言。二谛即是。世俗胜义。依多立一。名世俗谛。安立界体。名胜义谛。前谛随顺世间言说。后谛随顺贤圣言说。世俗谛法。得有名生。失有名灭。胜义谛法。用起名生。用息名灭。言得有者。谓假所依。众缘和集。合立一有。言用起者。谓诸实物。众缘合时。引果用起。唯现有论。亦定应许。如是所说。二种有义。若不许此。应舍契经。依此有彼有者。是假所依有假便得有义。此意说假是有非生。即所依缘和合立故。何缘证知。如契经说

  如即揽众分　　假相说为车
  世俗说有情　　应知揽诸蕴

贪等烦恼。多缘假生。方能为因。生后有识。依正理说。必应如是。此生故彼生者。是因实界生实界得生义。此意说实。众缘力故。令起作用。是生非有。何缘证知。如契经说。二因二缘。能生正见。此生故者。过去现在诸缘生故。言彼生者。未来果生。虽于未来亦有缘义。约分位故。但说已生。或依此有彼有者。是依前生因。有现生果。有义言。此生故彼生者。是现生果生故。后生因生义。此中意显现生生故。遮余对治。生后有因。复依现生因有。后生果得有。由后生果生故。后后因得生。如是有轮。旋环无始。有余师释。如是二言。为于缘起知决定故。如余处说。依无明有。诸行得有。非离无明可有诸行。由如是理。唯有四句。若异此者。应成多句。谓依此有彼有彼非有。及此生故彼生彼不生。如是便成六句差别。如依灯有灯光有闇非有。及灯生故灯光生闇不生。此不应然。灯有闇灭。无有因果相应理故。法有我无。定无因果相应理故。本无迷执。为显因果相应理故。说此契经诸句差别。非有与无有因果义。如是所标。应成无用。如后别释。前应总标。后释既无。前标何用。是故应如前释为善。此中唯辩因果相故。执过四句。理不应然。谓依灯有闇非有依灯非有。闇便有。如是所说。非因果相。若必尔者。句应成八。齐尔所方能圆显生灭故。由前四句。圆显于生。由后四句。圆显于灭。若尔句别。但应成四。谓依此有彼有。及依此无彼无。尔所便能圆显义故。不尔唯此未说生故。已说有言。意唯诠有。故说依此有彼有。未说此生故彼生。非诸有法必有生故。本无今有。前已数遮。故如所言。定为无义。若谓说在胜义空经。因余义门。我当会释。前说三际立十二支。谓无明行。乃至广说。此中何法名为无明。乃至何法名为老死。颂曰

  宿惑位无明　　宿诸业名行
  识正结生蕴　　六处前名色
  从生眼等根　　三和前六处
  于三受因异　　未了知名触
  在淫爱前受　　贪资具淫爱
  为得诸境界　　遍驰求名取
  有谓正能造　　牵当有果业
  结当有名生　　至当受老死

论曰。于宿生中。诸烦恼位。至今果熟。总谓无明。何故无明声。总说烦恼。与牵后有行。为定因故。业由惑发。能牵后有。无惑有业。后有无故。非牵后有。诸行生时。贪等于中皆有作用。彼行起位。定赖无明。故无明声。总说烦恼。若尔何故唯前生惑。总谓无明。此生不尔。唯前生惑。似无明故。贪等烦恼。未得果时。势力无亏。说为明利。若得果已。取与用亏。不名明利。无明势力。设未亏损。亦非明利。彼现行时。亦难知故。前生诸惑。至于今生。已得果故。势力亏损。其相不明。似无明品。故唯前世惑。可说无明声。非于行中。亦应同此说。假立名想。唯于同类故。然经主说。彼与无明。俱时行故。由无明力。彼现行故。如说王行。非无导从。王俱胜故。总谓王行。未了此中俱时行义。为诸烦恼随从无明。为说无明随从烦恼。若取前义。理必不然。余惑相应。无明劣故。胜随从劣。理必不成。若取后义。应无明体从彼为名。随从彼故。非不随从此。可从此为名。若谓此彼互相随从。无差别故。非决定因。而偏立名。岂令生喜。又由无明力。彼现行故者。为约能转无明而说。为约随转无明而说。如是二途。并皆非理。无明亦随贪等转故。与余相应。非自在故。非不自在。可说力强。但应说无明由贪等力起。于彼相应品。贪等力强故。如不可说导从胜王。如何说贪等由无明力起。是故二因。皆无证力。唯前所说。其理为胜。于宿生中。福等业位。至今果熟。总立行名。初句位言。流至老死。福等诸业。随经主意。辩业品中。当广思择。此中应辩。何缘宿生如是类业。独名为行。名随义故。其义云何。谓依众缘和合已起。或展转力和合已生。又能为缘已令果和合。或此和合已能为果缘。是谓行名所随实义。宿生中业果今熟者。行相圆满。独立行名。由此已遮当生果业。以彼业果仍未熟故。相未圆满。不立行名。岂不一切已与自果。异熟因体。皆具此相。则应一切皆立行名。此体是何。谓诸非业及业前生。已得果者。虽有此理。而就胜说。业为异熟因。牵果最胜故。生现在果。业粗显易知故。因此能信知生过去果业。是故唯此独立行名。虽一切因已与果者。总应名行。然此唯说能招后有诸异熟因。故无行名不遍相失。是故成就。唯宿生中。感此生业。独名为行。于母胎等。正结生时。一刹那位五蕴名识。此刹那中。识最胜故。此唯意识。于此位中。五识生缘。犹未具故。识是何义。谓能了者前于思择。识蕴性中。已述余师假说了者。今为遮遣上座所执。显自所立。应复寻思。彼上座言。契经中说。识是了者。此非胜义。是世俗说。若是了者是识。亦应说为非识。谓若能了说名为识。不能了时应成非识。不应非识可立识名。上座此中说何位识。为不能了。若说未生已灭位识。便似空花。非彼所宗。此位有识。如何可说若是了者是识。亦应说为非识。亦不可说。于现在时。具有能了不能了识。以现在识必了境故。更无第四识位可得。如何可说不能了时。应成非识。又彼所宗。非识说识。识说非识。无法非识说为识故。现在是了说不了故。而上座言。不应非识立识名者。翻成自咎。诸说去来实有识者。非不了位便成非识。定是能了。识性类故。今此义中。不言了位方名为识。但作是说。众缘合时。唯识能了。如是应说。非要取像方名为想。非要观察方名为慧。余例应知。如世工师。不作瓶等。亦名彼匠。若遇彼缘。唯此能造瓶等物故。若谓作者体实都无。则亦应无能了等用。若谓亦无能了等用。应无识等功能差别。此若亦无。何有识等。识等无者。便滥空花。无圣教说。识非了者。然为遮我是了者计。故世尊告颇勒具那。我终不说有能了者。此不说言。表不显义。意为遮有自在无缘不依他成我为了者。故彼经说。设有来问。识是何缘。乃至广说。此问了者与何为缘。若此经中。问如是义。何不正说。与彼为缘。但言若得此问。我当作如是答。乃至即当来后有生所起。为遮有我是了者计。故不正说。识是彼缘。若作是说。识是彼缘。便谓世尊说我名识。故先显示识体是生。后方说生必缘于有。故次后问。有是何缘。复答言乃至即当来生有。此经不说前为现因。但说现因能生当有。由但显后准知前故。如不广显后果差别。但显前果。后可准知。何故世尊。举生显识。显识与生同一相故。由同一相说有缘生。即已显成行缘识义。故不别说识所从缘。若尔如问识食何缘。答此问中。如何无过。问何缘者。问所从缘。及问为缘。双答无失。亦如有问触复何缘。答此问言。六处缘触。触复缘受。若此偏问不应双答。若偏问双答。应问异答异。是故所问识食何缘与问触同。双答无过。故先说识与余为缘。后说以余为缘生识。此中亦说生缘老死。有为缘生。显识与生行支与有俱无异体。故无有过。或复此中。亦正说识能为缘体。言乃至故。以乃至声。表分限义。此中意说。乃至即当来后有生所起。此识为缘。若尔还成生他疑失。不尔当说从缘生故。如后当说。此缘于有。谓次后问。有是何缘。复答言乃至即当来生有。有声即表识所缘行。何故此中唯行与识。但以乃至分齐声显。此意显示能引后有能结后有。俱一刹那故。此经不遮识为能了者。但为遮我为了者计。如何知然。余经中说。云何名识。谓能了者。又佛世尊。遮别作者。故知作者非一切无。如何世尊遮别作者。如世尊说。有业有异熟。作者不可得。谓能舍此蕴。及能续余蕴。唯除法假。此既唯遮差别作者。故余作者。应许非无。为显因果相续诸行即是作者。故复说言。依此有彼有。此生故彼生。虽有难言如一天授。能造环钏。未造造已。及正造时。体唯是一。识亦应尔。俱作者故。此亦不然。天授前后。体实非一。妄谓一故。无一天授其体是常。虽实前后念念各异。然由诸行前后相似。微细差别。其相难知。故诸愚夫。妄谓为一。如祠授行相同天授不知别者。谓天授行故彼难中。无同法喻。故经说识。是了者言。但依胜义。非约世俗。而上座言。此非胜义。是世俗说。定为非理。行名色二缘识何别。此三缘识。何处说耶。行缘识者。如契经中。说行缘识。名色缘识者。如大缘起经。佛告阿难陀。识不依名色为得住不。不也世尊。二缘识者。如契经说。缘二生识。其二者何。谓眼与色。乃至意法。无行名色缘识非二有二缘识。非行名色。谓唯结生识。说行为缘。此由行势力。牵引生故。此结生识。唯一刹那。即此亦名名色缘识。由依名色得增长故。又亦说此名二缘识。意法为缘而得生故。六处等位。唯二缘识。岂不名色及二缘识。亦行为缘。一切前生业异熟识。或所余识。皆行为缘而得生故。虽有是理。然识生中。但说胜因。以为缘故。如生眼识。亦缘空等。而但说言缘二生识。谓续生位。意识生时。行为胜因。方得生起。由先业力。引至此位。故但说此以行为缘。若至余位。则名色等。亦得与识为胜生缘。岂不续生最初位识。亦以中有为胜生缘。此难不然。见离中有此续生识亦得生故。非余位识离名色等亦有得生。是故唯于初结生位说行缘识。有余师说。行缘识者。谓初取时。名色缘识者。谓取已守护时。二缘识者。谓护已增长时。或有说言。行缘识者。显示宿业。名色缘识者。显示次第。二缘识者。显示所依境。复有说者。言行缘识。显一门转。名色缘识。显二门转。彼位识亦依身根门转故。言二缘识。显六门转。如是等类。有多差别。又薄伽梵。说二种识为名色缘。谓结生时识。及本有时识。故世尊告阿难陀言。识若不入母胎中者。此名色成羯剌蓝不。不也世尊。乃至广说。世尊复告阿难陀言。识入母胎。复还舍离名色得生后名色不。不也世尊。乃至广说。此中义者。若识不入母胎中生。此识俱生所有名色。应不能与羯剌蓝位名色为因。设已入在母胎中生。若遇碍缘而断绝者。羯剌蓝位。所有名色。则不顺生羯剌蓝后所有名色。是名色支不成就义。世尊复告阿难陀言。识在婴孩或童子位。便断坏者。名色必无增长广大。不应生有刹那无间名色位生可名婴孩及童子位。故此言识。在本有时。此等识言。既无差别。取何位识。为名色缘。为释此疑。故颂中说。识正结生蕴。以行为缘故。虽初位识。能与俱起及无间生名色为缘。而此不取能为俱起名色缘义。由于此中但约分位辩缘起故。结生刹那。识及助伴。总名为识

说一切有部顺正理论卷第二十五阿毗达磨顺正理论卷第二十六

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩缘起品第三之六

结生识后。六处生前。中间诸位。总称名色。岂不已生身意二处。应言此在四处生前。大德逻摩。率自意释。度名色已。方立处名。意体虽恒。有非意处。要是触处。方得处名。灭尽定中。意处不坏。由斯亦许有意识生。然阙余缘。故无有触。是故非识。名色位中。身意二根。可得名处。故说名色在六处前。名色为缘。生于六处。此唯率意。妄设虚言。都无正理及正教故。谓无理教。可以证成。意法为缘。生于意识。于中亦有不名三和。或有三和。而无有触。若谓此位有劣三和。触亦应然。宁全非有。彼宗许触即三和故。又彼亦许有处无触。由彼自说灭尽定中意处不坏而无有触。既尔于识名色位中。何法坏心。令非意处。又彼执离根境识三。有何别缘。亲能生触。而言阙故。识有触无。非佛世尊曾有此说。但如童竖自室戏言。又说名色为触缘故。如告庆喜。若有问言。触有缘耶。应答言有。彼若复问。此触何缘。应正答言。所谓名色。既尔岂不六处生前有名色故。必应有触。是则无时意非意处。若谓如是。生触名色。非六处前名色支位。如世尊告阿难陀言。识在婴孩及童子位。便断坏者。名色必无增长广大。如是名色。岂六处前。故今触缘即彼名色。此救亦非理。说识为缘故。谓能为缘生触名色。世尊即说。彼结生识为缘。如契经言。识若不入母胎中者。此名色成羯剌蓝不。不也世尊。乃至广说。次说名色与触为缘。非此位中可得即说为婴孩等。故不成救今此位中。已有何色。为缘生触。而言此位。名色为缘。生于触耶。有说此位唯名生触。约位总说名色为缘。有言此约名色满位。身触为缘。能生身识。故说名色与触为缘。今谓此中名色缘触。就位总说。言具二缘。若别说缘。或名或二。或即六处为缘生触。故说名色与触为缘。然名色位。非无有触。以许此中有意识故。曾无处说。离根境等别有触缘。而说此中有识无触。有言无理。又彼所说。意体虽恒。有非意处。此何所表。若是处体。而不施设。此何所以。竟不说因。又言触处。方立处名。许是处体。此言便坏。若非处体。便违契经。一切法者。谓十二处。然佛世尊。处处显示。离十二处。无别有法。亦不可说。于诸法中。有非处体而处所摄。虽一极微。不能生触。而无现在唯一极微。非五识身所依缘者。亦是处体。得彼相故。是故所说。意体虽恒有非意处。非应理说。若尔何故。不作是言。四处生前。说为名色。识名色位。用减劣故。谓二位中。诸内处体。用犹减劣。不立处名。若此位中。处用圆胜。即于此位。可立处名。或位不同。体有异故。谓六处位。所得意身。用胜体圆。非前所得。如是六处。名色为缘。故说名色缘生六处。或此位方得全分现行故。谓要支开位。方得男女根。尔时诸识身。乃容皆现起。故身意处。六处位中。体用现行。方得全分。由斯故说六处生前是名色位。此说为善。余广分别。此名色支。于此后文。当更显示。即此名色为缘所生。具眼等根。未三和合。中间诸蕴。说名六处。谓名色后。六处已生。乃至根境识未具和合位。下中上品。次第渐增。于此位中。总名六处。岂于此位。诸识不生。而得说三未具和合。且无一位意识不生。名色位中。身识亦起。况六处位。言无三和。所余识身。亦容得起。然非恒胜。故未立三和名。于此位中。唯六处胜。故约六处。以标位别。既许六处缘名色生。一念名色。后即应立六处。如一念识后即立名色支。此责不然。六处要待名色成熟。方得生故。何法说为名色成熟。无别有法。然名色位。下中品时。未能为缘引生六处。要增上位。方能为缘引生六处。即名成熟。要待名色熟。六处方生。如因种转变芽方得起。或非离名色六处可得生。如要依云方得降雨。若尔六处。非名色生。如何可说言名色缘六处。诸为缘者。谓有助能。未必亲生。方成缘义。如果虽为引业所牵。满业若无。果终不起。如是六处。虽业所招。无名色缘。必无起义。即先行业所招六处。要由名色缘助乃生。同一相续势力引故。虽名色为缘亦生色等。而即初念识。滋润所生。故不说彼缘名色起。又彼色等。通情非情。今此唯明有情缘起。故唯说名色为缘生六处。或先已辩。识缘名色。即已总说缘生色等。今名色后色等与前。更有何殊义用可得。而须说彼。从名色生。故如本文。所说无失。此中上座。欲令眼等唯有世俗和合用故。作如是说。眼等五根。唯世俗有。乃至广说。如是所欲。于理匪宜。救疗彼方。如初品说。有少差别。今应更辩。谓上座言。五根所发识。唯缘世俗。有无分别故。犹如明镜照众色像。即由此理。识不任依。如佛世尊言。依智不依识。意识通缘世俗胜义。故体兼有依及非依。此亦不然。智应同故。若眼等识。缘世俗故。无分别故。不任依者。智亦应然。岂唯依性。谓彼说智是思差别。依五根门。亦有智起。彼缘世俗。无分别故。亦应同识。不任为依。若谓智生有缘胜义。及有分别。识亦应然。谓有意识。能缘胜义。有分别故。亦任为依。若智唯由意所引起。亦不应说唯智是依。以许意识通缘二故。及许体兼依非依故。由此如意识。智亦通非依。意识应如智亦有任依者。又无漏智。亦应非依。以于多法一行转故。无分别故。上座意许。如是法智。不缘胜义。故即于此。说如是言。多分有情。所起诸智。于多法上。一相智生。谓于多法。取一合相。此智难成。缘胜义起。若谓此智虽缘多法生。而不于诸法取一合相。眼等诸识。应亦许然。谓彼虽缘多法为境起。无分别故。不取一合相。如是应许五识唯依意识。贯通依非依性。有取一合相。有缘胜义故。曾无处说意识是依。上座或时说为依性。是则上座。于经义中。进退踌躇。不能定显。设复定显。便违理教。故上座意。不任为依。余处别当辩此经义。恐文烦重。故应且止。但应思择。此正所明。上座此中。广为方便。立无境识。此于第五随眠品中。当广遮遣。应知如是辩六处中。亦可遍摧彼诸妄计。薄伽梵说。根境识三具和合时。说名为触谓未能了三受因异。但具三和。彼位名触。触差别义。后当广辩。已了三受因差别相。未起淫贪。此位名受。谓已能了苦乐等缘。淫爱未行。说名受位。受差别义。后当广辩。贪妙资具。淫爱现行。未广追求。此位名爱。妙资具者。谓妙资财。贪此及淫。总名为爱。广辩爱义。如随眠品。上座于此。复作是说。受望于爱。非作生因。若尔如何说受缘爱。受为境故。说为爱缘。谓诸爱生。缘受为境。故契经说。若有于受。不如实知。是集没味过患出离。彼于受喜。即名为取。云何知此。契经中说。爱缘受生。岂不所言彼于受喜。即是缘受生喜爱义。此非诚证。于因义中。亦可得说第七声故。谓因于受。喜爱得生。是依受因。生喜爱义。由此故说受为爱缘。若不尔者。要爱生已。方有所缘。非爱未生可能缘受未有体故。既余缘力。爱体已生。如何复言受缘生爱。若余缘力。爱体已生。受为所缘。亦名缘者。如是便有太过之失。谓受有时。缘爱为境。亦应说受以爱为缘。又爱有时。缘触为境。亦应说触为缘生爱。又无漏智。亦缘爱为境。亦应说此爱为缘故生。设许此经约缘受境说于受喜。何缘知说受缘爱者。非谓生因。上座所宗。亦许一切所说缘起。皆据生因。如何此中。拨生因义。故彼论说。缘起为绳。系缚有情。令住生死。若能遍知受。名为断绳。若缘受生即名为缚。说所缘受。为令遍知。为爱即能遍知于受。而言说受。为令遍知。不尔云何。谓遍知智知受集等智所知受。即爱所缘。无有定因。证能治境即是所治。爱等所缘。故不应言。爱缘受起。说所缘受为令遍知。设为令遍知说爱所缘受。许所缘受为爱生因。于理何违。因为诽拨。诽许意识以意为所缘。便拨意根为因生识义。又彼上座。于自论中。数处有言。因受生爱。谓有无明受能为爱缘。无明触生。受为缘生爱。又说爱是果。必以受为因。由说果名。知有因故。又说无明助受。能为爱生因故。如是所说。存前违后。存后违前。前后二言。互相违害。不观理趣。率尔发言。故彼所言。不可依信。尊者世亲。作如是释。彼于爱喜。即名取者。爱摄在取。中故经不别说。上座于此。妄拨言非因果二门。理应别故。谓爱与取。因果性殊。以爱为因生取果故。如彼尊者说。爱为因还能生爱。有何别失。理必不然。说异相故。谓于缘起中。说异相因果。为辩生死相续次第。不可言爱摄在取中。若也爱生。还因于爱。如是展转。便致无穷。何所遍知。令爱止息。即应生死无断绝期。如是所言。皆不应理。自宗许触即是触因。和合性故。非彼许触与触所因。有别异相。或应许触离因而有。若彼意许触与触因。虽无异相。而有因果。爱取亦然。何容非斥。若言假实相有异者。理亦不然。非如受等类有别故。谓彼宗触离触所因。非如受等。体类有别。如何可言其相有异。非诸假法。离假所依。别有相体。依何辩异。或如六处。与触为缘。非许为缘唯望自类。望自他类。皆许为缘。然于此中。非无因果。如是说爱与取为缘。亦应许非唯望自类。望自他类。皆得为缘。而于此中。非无因果。又如六处。名色为缘。虽无相别。而有因果。亦如名色。用识为缘。识体即在名中所摄。前识后识。虽无相异。而识名色。非无因果。从爱生取。类亦应然。故缘起中。相虽无别。亦有因果。由此说取即摄于爱。亦无有失。所言因果。其相定异。如是言义。无理证成。为辩生死相续次第。必说因果。其相有殊。非相无别。有何因证。若谓因果相若无别。则所化生难知故者。亦不成证。所以者何。爱取义名有差别故。如识等名义与名色等别。既不说爱即为爱因。如何可言。二爱因果别难知故。生死相续次第难知。分明说爱能生取果。如是因果别岂难知。如彼所宗说。名色因识。六处因名色。触因六处。非难了知又佛世尊。亲演说故。谓契经说。若于受喜即名为取。取为有缘。乃至广说。故取摄爱。其理极成。上座复言。此经非了义。或诵者失。别说对治故。彼谓此经非了义摄。世尊为令速断灭故。于取因上。假说取声。或应诵言。若于受喜。便能生取。所以者何。余处别说彼对治故以契经言。若能灭此。于诸受喜。以喜灭故。取亦随灭。悲哉东土。圣教无依。如是不知了不了义。仍随自乐。决判众经。为立己宗。缘受生爱。及破他立取摄爱言。真了义经。判为不了。实可依者。执作非依非了义经。可名不了。勿不了义名了义经。若尔总无可依圣教。唯有无义。不可依言。是则便成坏圣法者。若取因爱。摄在取中。如取蕴因。摄在取蕴。如是取体。及与取因。二种皆以取声而说。于令速断。弥是胜缘。何所乖违。判非了义。又彼不可改本诵言。于教义中。无胜用故非本所诵。于圣教中。义有所阙。何烦辄改。又彼所引证此契经。非了义言。亦非诚证。谓因爱灭。果爱及余。亦随灭故。薄伽梵说。若能灭此。于诸爱喜。以喜灭故。取亦随灭。为显一因有多果故。又何不信如是契经。由此经说。喜即名取。故余经言。以喜灭故。取亦随灭。世尊为显取所摄喜。即是取因。故作是说若作是说。弥令速断。以于取中。摄多过故。又若余处分明显说。爱之与取。条然异类。可判此经。喜即名取。为不了义然无是说。仍有余经。判爱即取谓世尊说。我当为汝说顺取法及诸取体。广说乃至。云何为取体。谓此中欲贪。上座自言。若薄伽梵。自标自释。是了义经。不可判斯为不了义。又薄伽梵。告诸苾刍。取非即五蕴。亦非离五蕴。然取即是此中欲贪。是故此经言喜即取。无容判是不了义经。又取摄爱。理定应尔。以诸烦恼皆业因故。如前际惑。皆谓无明。故契经言。取缘有者。是因烦恼。发诸业义。爱于发业。是最胜因。摄在取中。为缘发有。于理何失。而不信依。如前际缘起。说无明缘行。一切烦恼。皆能发业。是业因故。皆谓无明。故后际中。能发业惑。皆取所摄。其理极成。又彼所言。爱还因爱。如是展转。便致无穷。理实无穷。于宗何失。谓许后爱因前爱生。前爱复因前前爱起。因无始故。理实无穷。此于我宗。是德非失。又彼所说。何所遍知。令爱息者。遍知自性故。及遍知因故。能令爱息。如是爱因。略有二种。一异类谓受。二同类谓爱。有何因证令爱止息。唯由遍知异类因受。非由遍知同类因爱。纵许爱息。唯由遍知。异类因受。岂能违爱。摄在取中。故说爱因亦取中摄。理无倾动。为得种种可意境界。周遍驰求。此位名取。取有四种。谓欲及见戒禁我语取差别故。以能取故。说名为取。即诸烦恼。作相想业。谓欲界系烦恼随烦恼。除见名欲取。如马等车。三界四见。名为见取。彼戒禁取。名戒禁取。色无色界系。烦恼随烦恼。唯除五见。名我语取。如是语取。随眠品中。当广分别。唯与上座。决择相应。此中略辩不立无明。为别取者。自力无明。不猛利故。非解性故。相应无明。他烦恼力。令能取故。由斯义故。不别立取。离余见立戒禁取者。于能集业力最胜故。由斯故说一戒禁取。于集业门力齐四见。由此一见。令业炽然。乖违圣道。远离解脱。故戒禁取。别立取名。以诸取名表依执义。虽烦恼类皆为依执。而此二取。依执义胜。故唯此二。俱得取名。以二于他最坚执故。然于此二。戒禁取强。如所蔽执炽然行故。由是离余。别立为取。四见皆以慧为性故。对余烦恼。依执义强。摄四简余。立为见取。诸余烦恼。定不定地。有差别故。不善无记。因差别故。立余二取。我语之取。名我语取。是于我语。能执取义。此有我语。说为我语。是于此中。有我语义。此体是何。谓有情数。诸法聚集。于此我语。有能执着。名我语取。若尔一切烦恼。皆应名我语取。我宗许尔。为难唐捐。何故少分说我语取。为欲成立一切烦恼皆我语取。故说别名。谓以别名说余三取。显我语取。是立总名。如色处界。及如行蕴法念住等。于圣教中。多见此例。为总摄余所应说义。故于少分。安立总名。如初力无畏及法处界等。复有异门。释我语取。谓依此故。能引我言。此即我见。名为我语。色无色缠。贪慢疑等。能令我见增长坚多。朋我语故。名我语取。是令我语能坚执义。或取能令我语盛义。非欲贪等亦得此名。唯定地惑。能于我语。极增盛中为近因故。非散地惑朋助我见令其增盛如定地惑。欲界有情。多游外境。令心散动。故此地惑。非令内缘我执增盛。是故不说为我语取。于此对法所立理中。寡学上座。谬兴弹斥。如是所说。理不相应。圣教曾无如是说故。谓曾无有少圣教中以我语声说上二界惑。彼所系我见烦恼。及以取声说彼余惑。又前后说。自相违故。谓对法中。自作是说。出家外道。于长夜中。执我有情。命者生者。及养育者。补特伽罗。彼尚不能记别无我。况能施设断我语取。上座于此。毕竟无能显对法宗。违于法性。但如歌末无义余声。言圣教曾无如是说故者。且问上座圣教是何。于三藏中。曾未闻有佛以法印决定印言。齐尔所来名为圣教。若谓圣教。是佛所言。宁知此言非佛所说。未见有一于佛所言。能决定知量边际故。谓曾未见。有于佛语能达其边。如何定言对法宗义。非圣教说。上座于此。乍可斥言。此所释理。违于法性。不应总拨。圣教中无。世尊每言。诸有所说。顺法性理。堪为定量。如契经说。随顺契经。显毗柰耶。不违法性。如是所说。方可为依。阿毗达磨。既名总摄。不违一切圣教理言。故所释理。无违法性。然佛世尊。亦尝称赞。非契佛意符正理言。如契经言。汝等所说。虽非我本意而所说。皆善符正理故。皆可受持。若圣教中。现无说处。言非量者。有太过失。谓圣教中。何处显了定说。树等皆无有命。定说诸行皆刹那灭。定说瓶等非别实有。定说过去非未来为因。定说有情非本无今有。又佛世尊。曾于何处。定释密说杀父等言。谓有漏业。名为父等。又自所执。旧随界等。佛于何处。曾说此言。设为证成。引相似教。非正显故。可作余释。由是所言。无经说故。便非有者。非决定因。又阿难陀。尚不应说如是释理。全无说处。况彼上座。于圣教中。少分受持。便应定判。故嗢怛罗契经中说。天帝释白嗢怛罗言。我今遍观赡部洲内。诸佛弟子。无能受持如是法门。唯除大德。是故大德。应自正勤持此法门。无令忘失。世尊自说此法门故。由是比知。今亦无有于佛圣教能具受持。佛初涅槃。及正住世。阿难陀等闻持海人。尚不遍知佛语边际。况今得有能遍知人。故上座说。谓曾无有少圣教中以我语声说上界等。此欲显已知圣教边。于自所知。增益之甚。然契经说。取为有缘一切烦恼。皆能发业。故取应摄一切烦恼。应具摄理。已如前说。此与理教。无片相违。故知经中定有说处。是故憎背他宗善说。苟欲成立自所宗承。如是未为顺圣教理。毁他成已。岂曰仁师。有智学徒。皆依对法。采正理食。以增慧命。饮濯如是善说清流。诸所愿求。无不成办。自无净信。又阙多闻越路而行。诽毁正法。显已有滥外道异生。岂谓自障禀贤圣法。岂不此释违于圣教。如世尊告诸苾刍言。汝等昔时。执我语取。为常恒住不变易法。谓正住耶。实尔世尊。乃至广说。此中意说。于内法中。执取为我。名我语取。故对法释。违此契经。此亦不然。迷经义故。且应审察。为依我见。问诸苾刍。汝等昔时。执我语取。为常恒等。为依所取我语事耶。我见且无。常恒等相。亦无有执。谓常恒等。如何世尊问苾刍众。汝等昔时。执我语取。为常恒等。谓正住耶。苾刍云何。答言实尔。故应但约所执取事为常等问。此意假说所取我语。名我语取。或应诵言。汝等昔时。由我语取。执常恒等。谓正住耶。或复应言。汝等昔时。执我语体。为常恒住。乃至广说。虽为此释。非意所存。理实但应所取名取。若谓此释理不应然。于能作用中。多置屡吒故。如是所引。理不定然。于业差别中。亦有屡吒故。如是经义。证对法宗。释我语取。义更明了。谓我语者。是说我言。世共于中说此为我。此有我语。得我语名。我语能为取依着处。故亦得说为我语取。此体是何。谓五取蕴。世于取蕴。起我有情命者等想。故契经说。诸有沙门。或婆罗门。乃至广说。此意则说。汝等昔时。执五取蕴。为常恒住。乃至广说。故所引经。所说取义。不能决定。证彼所执。亦不能遮。诸对法者。如前所辩。我语取相。然彼具寿。引此契经。但能显已诵文迷义。言前后说自相违者。此宗前后。都不相违。于对法文。不了义意。随已谬解。谓有相违。由彼出家诸外道类。不了取义。唯闻取名。但随取名。自称我等。说断三取。唯除第四。所以者何。彼诸外道。谓我语取。即所取我。然彼计我。是常恒住不变易法。体不可断。又于我断彼生大怖。故不施设断我语取。此意说言。彼若真实善解取义。于我语取。亦应施设能断少分。以于取义不善了知。唯闻取名。妄推实义。故除第四。言唯断三。亦如今时一譬喻者。不应立义而强立之。应立义中而倒不立。又彼依自所执取门。施设断三。非我语取。然彼所执。取体不同。且欲取中。有言体是诸妙欲境。有谓淫贪。他宗戒禁。名戒禁取。他宗诸见。名为见取。于我见中。执为正智。故不建立我语取名。故说断三。非我语取。故诸外道。有作是言。如彼大师。可敬可爱。我师亦尔。如彼大师。于法究竟。我师亦尔。如彼法侣。互相敬爱。我等亦尔。如彼于戒圆满护持。我等亦尔。如彼施设。能断诸取。我等亦尔。彼与我等。有何差别。故我宗义。前后无违。上座如何安立诸取彼言欲取。于契经中。世尊分明亲自开示。如有请问。欲者谓何。世尊答言。谓五妙欲。然非妙欲即是欲体。此中欲贪。说名为欲。又世尊劝依了义经。此了义经。不应异释。我今于此。见如是意。谓由爱力。五妙欲中。欲贪生故。而有所取。是名欲取。经与彼义。都不相应。谓此经中。都不依彼所执欲取而兴问答又经所说。亦不乖违。我对法宗所说欲义。我等亦说。五妙欲中。所有欲贪。是真欲故。又彼引此。竟何所成。世尊于此中。非辩欲取故。又此所引。非了义经。复应观察别意趣故。谓经后句。世尊自遮。言非妙欲即是欲体。有何密意。于前句中。正答问言。谓五妙欲。若更有别意。而名了义经。更无别意者。应名不了义。则了不了义应无定建立。又何意说。五妙欲中。欲贪生故。而有所取。是名欲取。为执欲贪。为执妙欲。名为欲取。除此二种。更作余执。则无所依。且彼所宗。取不摄爱。不应欲取体是欲贪。或彼前后自相违害。若执妙欲名欲取者。岂非烦恼能为业因。又取不应缘爱而起。唯应许爱缘取而生。彼上座言。取非二种。但于妙欲。欲贪生故。执而不舍。说名欲取。巧为如是响像言词。惑乱东方愚信族类。何名为执。何名不舍。岂不于彼五妙欲中有欲贪生。即名为执。耽着不弃。即名不舍。故先说彼不应立义。而强立之。应立义中而倒不立言成无谬。或彼应辩执不舍相。非即前二而名欲取。彼言见取。即是五见。谓爱力故。执而不舍。故契经说。由有彼故。应知是诸沙门梵志成不聪睿。堕无明趣。爱广滋长。彼谓诸见。由爱势力。种种炽盛。名广滋长。如是所说。前后相违。不了经义。引之无益。如何彼说前后相违。谓能执故。说名为执。如是执体。即是五见。彼即不弃。故名不舍。是谓后言违于前说。谓彼前说。于内法中。执取为我。名我语取。或我语取。见取所收。无别性故。应唯三取。理不应许。取体相杂。如何说彼不了经义。谓经但言爱广滋长。如何知说。是由爱力。种种炽盛。名广滋长。非由见力爱滋长耶。我于此中。见如是义。谓由见力。爱广滋长。由彼经言。沙门梵志。依前际执。说常住论。言我世间皆悉是常。于四事中。而兴诤论。由有彼故。应知是诸沙门梵志。成不聪睿。堕无明趣。爱广滋长。此中意说。爱由见力。而广滋长。非见由爱。此分明说爱广滋长。如何翻谓见滋长耶。如何此经。引之无益。谓纵如彼释引之何所成。非由此能成彼见取。岂由此故。便能证成。离彼诸见。外有执而不舍。然执不舍。即是诸见。故所引经。于彼无益。彼言此中戒禁取者。非五见中戒禁取摄。然即戒禁其体是何。谓有外道。由爱力故。受持牛鹿猪狗戒禁。愿我由斯持戒禁力。当受快乐。或当永断。观察为先。所起执见。是五见中。戒禁取摄。希欲为先。所受戒禁。是四取中。戒禁取摄。故此与彼。取体不同。如是立中。有二种失。取体支体。俱杂乱故。且无有一。但希求果。受持戒禁。非见为先。要见为先。方希求故。设许彼说。希欲为先。所受戒禁。非五见中戒禁取摄。则定应许。观察为先。所受戒禁。是五见中戒禁取摄。此戒禁取。于四取中。为是见取。为戒禁取。随许是一。取应杂乱。或违先许。彼先许言。希欲为先。所受戒禁。是四取中戒禁取摄。非五见中戒禁取摄。无如是失。以能执见是四取中见取所摄。所执戒禁。是四取中戒禁取摄。此救非理。四见亦应如戒禁取而建立故。谓余四见。亦应能执。是四取中。见取所摄。所执境界。别立余取。又应欲贪立为欲取。所贪境界。别立余取。此彼差别。无定因故。是则诸取。数应不定。如对法宗。于五见内。独立一见。名戒禁取。我宗亦然。强者别立。若尔应唯四见立一。如戒禁取。欲贪与境。应立别取。何理能遮。故彼所宗。非善立取。又诸有支。体应杂乱。谓取支中。有有支故以契经说。告阿难陀。能感当来后有诸业。应知即是此中有支。又业为生因。余契经说故。所受戒禁是有是业。后有即生。应如前际。则当生有。应取为缘。上座救言。此后所起。方名为有。用取为缘。此救不然。有业非有。即此种类。有业是有。此必应遭外道所魅。又应说爱。与有为缘。彼许有戒禁。从希望生故。由此定知。越对法理。必无于取无过安立。今应思择。应诸烦恼皆是取缘。展转相因。诸惑生故。何故但说爱为取缘。不可取缘说余烦恼。夫取缘者。谓能为缘。令取体生。不舍所取。爱望于取。具有二能。余惑但能令取体起。故唯说爱。能为取缘。上座释言。所以不说余烦恼者。理无有故。谓若离爱。现在前行我语等取。终不行故。未了彼言。何意故说。若遮诸惑展转力生。是则应违圣教正理。故契经说。佛告苾刍。爱由爱生。爱复生恚。恚由恚起。恚复生爱。如是亦说。取为爱缘。又契经说。爱用无明。为集为因为生为类。前已成立。无明是取。故亦应说。爱用取为缘。但由前说因。是故不说。理亦应尔。慢起无间遇恚生缘。然恚不生。反生于爱。斯有何理。爱恚生缘。定有差别。由是证知。爱亦缘余惑生。故非取生但缘于爱。而偏说者。由具二能。上座此中。妄释经义。谓非离爱恚得现行。未审此言。欲诠何义。岂不爱恚不俱起故。必应离爱恚得现行。若谓恚行必由前爱。是经义者。此但虚言。以契经言。恚由恚起。恚复生爱。故但虚言。由是所言。理无有故。爱必非赖余烦恼生。取但因爱。理不成立。是故对法所说取支。总摄诸惑。其理为善

说一切有部顺正理论卷第二十六阿毗达磨顺正理论卷第二十七

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩缘起品第三之七

如是所成。取为缘故。驰求种种可意境时。必定牵生。招当有业。谓由爱力。取增盛时。种种驰求善不善境。为得彼故。积集众多能招后有净不净业。此业生位。总名有支。应知此中由此依此。能有当果。故立有名。上座释言。有谓有性。故世尊说。有谓当来后有生起。有性即是当来世中果生起义。如是所释。理教相违。有应与生无差别故。当果生起。体即生支。则缘起支。便应数减。若谓现业是有因故假立有名。亦不应理。业体即是现有性故。业是现有性。能为当有因。故不可但言有因故名有。自性是有。宁假立名。如业有为因感异熟。有此果有。岂假因有为名。设许假立名。非失有自体能有所有。俱有性故。为证彼义。不应引此经。由此经文有异诵者故。云何异诵。如有诵言。有谓能令后有生起。设如彼诵。理亦无违。此于因中。说果名故。由有体是当有起因。假说当来后有生起。为显此义。故世尊说。取缘有已。次为显有是生缘故说此契经。又有于生为因最近。故契经说。业为生因。为显业有是生近因。故于业有因上。假说果名。此事必然。故后总结。言取缘有有缘生故。又余经说。佛告庆喜。招后有业。此中名有。是故上座。所引契经。于自释有不堪为证。唯对法者。所释有名。符理顺经。最为殊胜。有有二种。谓业异熟。今于此中。唯取业有。辩当生果近因性故。如前异诵契经中言。有谓能令后有生起。即如前际业说行支。今后际中。业名为有。此显生死前后际同。惑业为因。招异熟果。上座妄执。此有支名。总摄一切有。经不别说故。谓佛总说。有略有三。故知有支。摄一切有。若不尔者。世尊但应说此为行。或说为业。复有经证。如契经言。有谓当来后有生起。又世尊告阿难陀言。有略有三。欲色无色。又世尊告阿难陀言。业感当来后有名有。又契经说。诸有若无。颇有有不。乃至广说。故取能作业有生因。业为有助令生有起。是为略述。上座所宗。如是所言。皆非善说。虽不别说。然应别解。如说。识等缘名色等。虽于此中总说三界所有缘起。而许依容有说。识缘名色。名色缘六处。如是此中。虽不别说。而应别解。谓三界系业。说三界有名。如是有何过。若异此者。应摄非情。谓彼自言。若于此法。欲色无色贪等随增。此法如应。名三界有。非情诸法。亦欲色界贪等随增。以于此中不别说故。亦应摄彼。而彼不许。故非总摄。若谓此中依无明等有情说故。虽总说有。而不可谓亦摄非情。岂不此中但依流转还灭次第。及依惑业为因感生。次第说故。虽总说有。而随所应。但依不善善有漏业。说为欲色无色三有。若此有体如彼行支。何不如彼以行名说。前于思择行名义中。已辩余无所随义故。何不名业。为欲显此感后有因。是业差别。非一切业皆后有因。故立有名。不说为业。又业名有。圣教极成。如七有经说为业有。故彼所说。不别说故。知有支名。摄诸有者。违理教故。非为善说。彼所引经。应正详辩。且初所引颇勒具那契经中说。有谓当来后有生起。此前已释。谓此经文。有异诵故。及于因中。说果名故。又彼所引。三有契经。亦不相违。总问答故。非我等说一切取蕴不皆名有但有支内。业有胜故。唯业得名。然彼阿难陀。总问诸有。不问有支故。佛还总答。故彼所引。非证有支通以三界诸有为体。又彼所引二有契经。亦不相违。以总说故。谓于业有异熟有中。总说有声。俱有性故。前三界有。总以有声。说三界系一切业果。今此为显因果差别业与异熟。说为别有。或三界有。以一有声。说无量门。诸有漏法。今此但说感当来业。及后有果。总名为有。或此经说。业感当来。后有名有。此经正辩感后有业名为有支。如何引之。证通名有。故此文后。复作是言。若欲界系业有无者。颇得施设欲界有耶。不也世尊。乃至广说。此显要有业有方有异熟有义。即正说有缘生谓当生位。已有身根命根异熟说名后有。如是即以有声说生。非业俱行异熟名有。此于后有。无感用故。如是圣教。顺对法宗。如何引之证成彼义。又彼所引大缘起经。诸有若无。颇有有等亦不达义。故复引来。此中世尊。为辩行有取果与果功能时别。言诸有若无颇有有不者。寄问欲显业取果时。谓若此时无现业有。必无能引当生有义。于此文后。复作是言。诸有若无颇有生不。此寄问显业与果时。谓若过去业有无者。必无生有令正起义。或此后文意显业有。虽取果已要未断灭。方有与生令正起义。若无过去业虽未断。已灭无体。何能与生。而今契经。作如是说。若谓犹有旧随界故。此但有言无作因理。故此一分经义有别。非证要有现在业有方令现在果有亦有。现业俱有非现业果。如何无业。彼有便无故。此经非证有支通摄有。此中业有是能有。若异熟有是所有。如是所有。即是当来业果生中之差别义。此中正说。能有为有已具成立。如前行支。然彼复说。故取能作业有生因。业为有助令生有起。此非谛说。唯取诸业。为此有支。已于上文。数成立故。契经唯说取缘有故。唯许业有取为缘故。岂不上座于此义中已立有支。唯是业有。不说取缘异熟有故。由此所说。业为有助。令生有起。但如童竖自室戏言。非佛说故。业俱行有。于后果生。无感功能。前已说故。若谓业有由异熟有助其力故为生有因。是则彼宗。生无色界。业有起位。都无异熟。既无助力。应不招生。若谓尔时。有异熟界。前已破故。理亦不成。设许业有由异熟有助其力故。为生有因。是则有支。唯是业有。唯此业有。用取为缘。能作生缘其义成立。诸对法者。亦许一切无明等位皆具五蕴。然就胜者。以立支名。余劣俱生。但为助伴。故异熟有。于有支中。非立名依。以非胜故。又彼上座。忿嫉缠心。毁骂先贤。辩取缘有。唯显业有以为有支。故自问言。契经所说。取缘有者。何因故知。即自答言。以现见故。谓今现见。欲取为因。无量有情。造种种业因戒禁取。内外道人。种种受持苦难行业。因见等取。毗婆沙师。外道等人。起诤论业。此中彼自不说有支。谓取为缘。业异熟有。佛亦不说。离业有支。故彼所言。总摄一切。有为取缘有者。前后相违。不顺圣言。非佛弟子。如斯显说违理教言。着违教理。颠倒妄见。执为真正。异外道宗。毗婆沙师言顺教理。所有见解。符会理教。拨为邪妄。同诸外道。如是朋党。赞己毁他。有智者闻深可喘笑。是故先说。今于此中。唯取业有。辩当生果。近因性故。理善成立。唯由业有。从此命终。复结当生。非异熟故。正结生有位。即立为生支。如此生中。行为缘故。初结生位。名为识支。如是来生。有为缘故。初结生位。名为生支。此位此名。正所须故。谓于现世。识用分明。未来世中。生用最显。随自用显。立以支名。或余经中。说生苦故。为造天趣。后有业者。令生厌舍。故说为生。或显后有业皆能招苦果。为令不造故说为生。由是余经。说生等苦毕竟寂灭名般涅槃。我不说生名依不相应行。是故上座所设难词。如在空闲独为哀泣。又先思择有为相中。已遣彼言。故不重述。此生支后至当受支。中间诸位。总名老死。即如现在名色六处触受四支。于未来生如是四位。名为老死。为令厌舍欣当有心。以老死名。显当过患。若今世识。即未来生。今识为缘。但生名色。生应非遍为老死缘。或老死名。非通四位。故至当受。名老死言。应更思择。此无有失。老死支名。定通四位。随容有故。说以生为缘以一一支皆名老死故。于老死位。说有四支显未来生。亦如现在。得有前后为因果义。如何知佛以老死声。总说当来名色等四。佛于缘起后际果中。已说一支。唯余四故。如是正显。于三生中具十二支有轮无始。过此更说。则为唐捐。说十二支义圆满故。若谓当果唯应说生于义已周说余无用。此亦非理。若但说生。后际果中。未遍说故。如过去世二支为因。招现在果已圆满说。如是现世三支为因。招未来果。亦应具说。为显后际如前际故。若异此者。教成减失。以不遍说后际果故。或愚者闻毗瑟笯等诸天世界。若得往生。彼唯有生无老无死。闻已造集种种邪因。如来说生皆有老死。为遮遏彼求生方便。故于当果。不但说生。彼上座言。世尊非以老死声说当来四支。以老死名无差别故。又契经说乃至死故。彼言非理。前已说故。谓前已说后际果中。已说一支唯余四故。四支虽别。老死义通。故以一名说四无失。如是而说。显前后际因果相应。不增不减。若过四位。立老死支。所说便增。无所诠故。亦名为减。不遍说故。由是老死定摄四支。乃至死言。亦无有失。前际业果。死为后边。非越四支别有老死。后际业果。理亦应然。除初位生。余名老死。望终尽位。说乃至言。非谓先时不名老死。又望定有。说乃至言。于生支后。死定有故。由是彼说。不堪收采。何故但以有为相名。说后际果。不说前际。现不现见。有差别故谓前际果。体及生等俱可现见。举体便知。后际二种。俱非现见。唯显彼过。令厌息求。如说。苾刍色生住起。应知即是苦生病住老死起义。乃至广说。生与老死。各说一支。显彼功能时分异故。或佛于此缘起义中。说世俗生等非就胜义说。彼初起位。总说名生。终尽位中。总说名死老。非定有然顺死故。不别立支。总名老死。或蕴增位。总说名生。蕴减位中。总名老死。或诸愚夫所欣乐事。总名为生。即彼愚夫所厌离事。总名老死。故生与老死。各别立一支。岂不亦有死缘生。何故唯说生缘死。由决定故。作如是说。谓有死者。非定有生。诸有生者。定有死故。若尔有生非定有老。由此中老据世俗故。如何可说生缘老耶。以若无生定无老故。如无云处则定无雨。非此中生定从死有无间而起。以有生支中有无间而得生故。由此佛说有情缘起。具十二支。义善成立。又诸缘起。差别说四。一者刹那。二者远续。三者连缚。四者分位。有余复说。显法功能。此中刹那。谓因与果。俱时行世。如契经说。眼及色为缘生于眼识等。有余师说。一刹那中。具十二支。实有俱起。如贪俱起发业心中。痴谓无明。思即是行。于诸境事。了别名识。识俱三蕴。总称名色。有色诸根。说为六处。识相应触名为触。识相应受名为受。贪即是爱。与此相应。诸缠名取。所发身语二业名有。如是诸法。起即名生。熟变名老。灭坏名死。上座谓此非应理言。一刹那中。无因果故。违圣教故。了义说故。谓俱生品。因果定无。俱生法中。谁因谁果。又此所说。违于圣教。如世尊告阿难陀言。识若不入母胎中者。名色得成羯剌蓝不。行有三种。于诸受喜。说名为取。吾当为汝说法增减。趣苦集行。趣苦灭行。非此品类可有集没。但由掉举无量过失。魍魉所魅。轻发此言。又此契经。是了义说。世尊决定说此为依。由佛此中自解释故。此一类许非正所宗。设是所宗。难亦非理。一念亦有缘起义故。非专为此而造论故。已成立故。种种说故契经说故。非所许故。谓先已说。非唯十二说名缘起。眼色为缘生眼识等。是缘起故。上座于斯。岂不忍许。又非为立俱时因果说一刹那。有缘起论。但为显示法相应有。谓前已说。一刹那中。具十二支。实有俱起。如是十二。为展转力生。为前因力起。别应思择。又已成立有俱有因。后义相应当更分别。又佛种种说缘起义。不可信一。而总拨余。以契经中或说十二或十一等。如前已说。一一支缘。所说亦异。谓或有说。无明缘行。或复有处。说触缘行。如了达经。或复有处。说爱缘行。如羯磨经。或复有处。说行缘识。或有处说名色缘识。或复有处说有缘识或有处说六处缘触。或有处说名色缘触。如大缘起契经中说。或复有处说二缘触如伽他说。眼色二等。或复有说。三和缘触。或复有处。说触缘受。或复有处。说二缘受。即上所引伽他中说。或复有处。说受缘爱。或复有处说触缘爱。如了达经。或有处说无明缘爱。如羯磨经。即彼契经说业缘眼。余经复说名色缘眼。有余经说。大种缘眼。诸如是等无量契经。佛说缘起。种种差别。是故上座。所引契经。亦不违斯刹那缘起。彼此所说。理无违故。又佛自说。刹那缘起。谓刹那顷。多物相藉。如契经说。眼色为缘。生痴所生染浊作意。此中所有痴即无明。痴者希求。即名为爱。爱者所发表即名业。若于此中。复说识等为余支体。违何理教。既无所违。何不忍许。又非我等许彼所引。说缘起经。是了义说。非了义相。次后当辩。设许彼经是了义说。亦不违害刹那缘起。上座于此。非理生嫌。而作是说。无量过失。魍魉所魅。轻发此言。今于此中。依对法理。略辩彼意。彼前所说。如贪俱起发业心中。具十二支。依何而说。为依发业因等起心。为依刹那等起心说。若依发业因等起心。嗔痴相应。为因等起。亦应具足有十二支。有嗔痴为转爱为随转故。不应但说贪俱起心。若依刹那等起心说。有爱为转。何故不论。有作是言。依因等起。以此于业是决定故。非爱为转所发业中。决定还用爱为随转。嗔痴等心。亦容有故。今谓此据刹那等起。即由此理。作如是言。无身语业见所断起非因等起。心所发身语业。离刹那等起。而有未生故。若异此者。举心起逆。尔时则应得无间罪。又因等起。时有远故非爱为转。业决定生。故此于业亦非决定。由此定据刹那等起。刹那缘起。如是应知远续缘起谓前后际。有顺后受及不定受业烦恼故。无始轮转。如说。有爱等本际不可知。又应颂言

  我昔与汝等　　涉生死长途
  由不能如实　　见四圣谛故

连缚缘起。谓同异类。因果无间。相属而起。如契经说。无明为因。生于贪染。明为因故。无贪染生。又契经说。从善无间。染无记生。或复翻此。分位缘起。谓三生中。十二五蕴。无间相续。显法功能。谓如经说。业为生因。爱为起因。如是等类。功能差别。于此五种缘起类中。世尊说何。颂曰

  传许约位说　　从胜立支名

论曰。对法诸师。咸作是说。佛依分位。说诸缘起。经主不信。说传许言。若支支中。皆具五蕴。何缘但立无明等名。以诸位中无明等胜故。就胜立无明等名。谓若位中。无明最胜。此位五蕴。总名无明。乃至位中。老死最胜。此位五蕴。总名老死。故体虽总名别无失。如是前位。五蕴为缘。总能引生后位五蕴。随所应说一切一切。上座于此妄弹斥言。虽有无间生。然无缘起理。初结生有。不应理故。谓结生时。所有五蕴。于有情相续。非并能为缘。契经但言识入胎故。又失生惑业次第生理故。谓从六处触受。次第起诸烦恼。烦恼发业。业复引生。皆不成故。又因差别应不成故。谓说有情。前后诸蕴。皆总相望前为后因。则失立因差别道理。虽有前后无间而生。然非一切因能生一切果。如色法起。虽藉外缘。然自种力。无间引起。诸心心所。各别因生。若许分位。因应无别。又于无学成过失故。谓阿罗汉。若于爱位。或于取位。得阿罗汉。应无爱缘取及取缘有位。又应爱等不数生故。谓受为缘数生于爱。惑爱为缘。数生于取。若许分位。此不应成。其位已过。无重起故。又缘起经是了义故。谓此经义。佛自决了。前际无智等名为无明。福非福不动说名为行。六识身等名为识等。世尊恒劝。依了义经。是故于中不应异释。今谓上座所立诸因。无一能遮分位缘起。且初结生。不应理者。此非正因。就胜说故。谓初结生位。识用最强故。入母胎时。偏说其识。然非离受想等识可独生。相应俱有因中。已广成立。故就胜说。识入母胎。此显所依无能依必非有。上座自说。佛以识声。总说一切心心所法。故识支通摄一切心心所。如何废忘。今乃引经。证结生时唯许有识。又失生惑业次第生理者。分位缘起。于此宁失。谓如识位。就胜为名。六处等位中。六处等胜故。于六处等位。说六处等名。如是六处触受。次第起诸烦恼。烦恼发业。业复引生。此何所失。若如经说而执义者。定失如是次第生义。谓非六处独能生触。以说三和而有触故。触既非有。受从何生。受因既无。惑业宁起。惑业无者。生何所因。复有余经。说触生爱。应不唯说触为受缘。则失有支次第生理。是故憎背分位有支。言失生惑业次第生理者。彼所说过。自害彼宗。又因差别应不成者。理亦不然。依分位说因差别理。乃善成故。谓非我等许从一切还生一切。是差别因。以诸位中许有少色。于所余色。为胜生因。或有少色。于心心所。心心所法。为因亦然。非我所宗。说一切位色心心所。皆为胜因。彼彼位生种种别故。有位色胜。有位心胜。有位心所随一为胜。由遇彼彼差别因缘。如是如是差别生故。唯许分位缘起理中。得有如斯因果差别分明可见。何乃拨无。又于无学成过失者。此无有失。是所许故。谓于爱位。或于取位。得阿罗汉。我宗许彼无爱缘取及取缘有。上座若谓得阿罗汉。犹有爱缘取。及取缘有者。是则因有应复招生。既复招生。定有老死。如是应供当自归依。然非此中所说缘起。总依一切补特伽罗。是故无容于此设难。岂阿罗汉有爱有取。而可说言。谓阿罗汉。若爱取位。得阿罗汉。非离转根。有阿罗汉。得阿罗汉。是故上座所出言词。非慧所发。岂能如实宣释。甚深微细。难知缘起道理。又应爱等不数生者。此亦无违。非所遮故。谓非说分位缘起论者。言触受爱取余位不行。虽诸位中皆多法起。然随胜者。以立支名。上座于斯。非不忍许。谓识支位。唯一刹那。亦许于中摄诸心所。我宗亦尔。何所相违。又缘起经是了义者。理最不可。上座于中种种差别。而辩释故。谓有难言。经说三种业因缘集即贪所蔽行身恶行。乃至广说。不应但说无明缘行。上座于此。自解释言。此中无明声。总摄诸烦恼。然经但见以无智声分别无明。不言余惑。又上座许。触受二支言。亦即兼摄非理作意故。谓契经说。非理作意。为无明因。上座释言。非理作意。触或受摄。然经分别触受支中。曾不说有非理作意。又彼经言。如是种类心心所法。皆即无明。然实无明心余心所。其相各别。非总无明乍可无明。是思差别。彼许思差别为无明等故。又彼自说。无明助受。能为爱因。非唯受力。然经分别受缘爱中。唯说受因能生于爱。又彼自说。次后二支。必有无明。所以者何。非离无明烦恼转故。然经分别爱取二支。唯说爱等次第分别生死支中。皆不尽理。又彼自难。何故无明声。摄余烦恼。非余烦恼声。即自释言。非离彼故。谓非离无明余烦恼转。有离余烦恼无明独行。又彼更为究根源释。为令速起断对治故。以无明声。说余烦恼。明慧正起。亲治无明。无明断时。诸惑皆断。为令厌彼明慧速生。故以彼声。说诸烦恼。自如是等。以无量门。解释彼经深隐理趣。而数决判是了义经。详彼但应欺东方者。或心傲逸。轻发此言。且置前后。自相违害。了不了义。其相云何。而蕴在心数数决判。此缘起教。是了义经。彼上座言。诸有圣教。佛自标释。名了义经。所余契经。名不了义。彼言非理。诸圣教中。未见诚文。说如是相。唯是上座。妄为图度。诸无圣教。虽理相应。上座每言。此非定量。况无圣教。复理相违。而执此为了不了相。如何知此所说相非。见阙标释。而是了义。有具标释非了义故。谓契经说。佛告苾刍。若有说言。我不依空。能起无相及无所有。若智若见。离增上慢。无有是处。此中岂有标释二文。而许此经是了义说。或应更释。有何别意。又有彼亦许定是了义经。谓契经言。若有一类。于诸行法。非理思惟。能起世间第一法者。无有是处。然此经中。无别标释。如斯等说。其类寔烦。有具标释非了义者。谓契经言。云何内地界。谓发毛爪等。乃至广说。地界但以坚为自性。发等具以色等合成。此中如何说假为实。此经虽具标释二文。而复于中。应求意趣。又契经说。佛告苾刍。此彼中间言何所表。如是标已。佛自释言。此言表触。彼谓触集中间。谓受非受。应在六处触中间。又无余经曾决判此义。此经亦具标释二文。然亦于中。应求别意。又即于此缘起契经。虽佛于中自标自释。而彼上座。自以多门。解释彼经。深隐理趣。且佛意趣。结生有识。名为识支。而自释言。识者即是眼等六识。然唯意识。能结生有。此岂不应更详意趣。谁有智者。执着如斯。有别意经。名为了义。又经处处。以种种门。广说缘起。多非了义。皆随所应。当求意旨。如是不达了不了义经差别相。而称我用经为定量。甚为非理。故招我等毗婆沙师。于彼所宗。数为嗤诮。经主于此。假作是言。经部诸师。作如是白。此中所说。为述己情。为是经义。若是经义。经义不然。所以者何。经异说故。如契经说。云何为无明。谓前际无智。乃至广说。此了义说。不可抑令成不了义。故前所说。分位缘起。经义相违。此如上座宗应广遮遣。又但如标举。而解释故。谓虽有贪等亦为行缘。而但标无明。观别因故。又虽十二处皆为触缘。而由观别因。但标六处。诸如是等。其类寔多。如观别因。但标少分。亦即由此。唯释所标。如何执斯。为了义说。如标三种业因缘集。但随标释。谓贪嗔痴。非此相应。慢等诸惑。全无为业因缘集义。然观别因。但标三种。即由此故。唯释此三。又如经说。应修二法。谓奢摩他毗钵舍那。岂以此中唯标释二。正思惟等。便非所修。如是此中。随于何位。此法最胜。用标支名。随所标名。还如是释。此于经义。有何相违。又非诸经皆了义说。亦有随胜说。如象迹喻经。云何内地界。谓发毛爪等。虽于彼非无水等诸界。而唯说地界。此亦应尔。彼谓所引不可为证。非彼经中欲以地界辩发毛等。若彼经问言。云何发毛等。答谓地界者。可判彼为非具足说。非发毛等。唯地界故。然彼经中。以发毛等。分别地界。非有地界越发毛等。故彼契经。是具足说。此经所说。无明等支。亦应如彼。是具足说。除所说外。无复有余。此救非理。迷证意故。此中证意。谓发毛等。虽多法成。然于其中。地界胜故。总名地界。如彼聚中。地界胜故。废余劣者。就胜为名。如是此中。虽一一位皆具五蕴。而得于此就胜者说。无明等支。如何乃言所引非证。经主于此。复作是言。虽于诸位皆有五蕴。然随此有无彼定有无者。可立此法为彼法支。诸阿罗汉。虽有五蕴。而无有行。随福非福不动行识乃至爱等。是故经义。即如所说。如是所识。无深理趣。俱有因义。前已成立。经主于中。非不忍许。既一果故。成俱有因。则与无明。同一果法。如无明于果随有无定成。若阿罗汉。虽有五蕴。无无明故。而行则无。唯执无明。为行缘者。诸阿罗汉。既虽有受而无有爱应非唯受能为爱缘。然此经中。说受缘爱。更无差别。故非如说即是经义。然更于中。应求别理若无明触所生诸受。能为爱缘。非一切受。诸阿罗汉。无无明故。虽有诸受。而无爱者。岂不经义非即如说。经无如是分别说故。由此应信顺阿笈摩。不违正理。是此经义。又先已说。先说者何。谓非六处独能生触。故随胜说。是此经义。则说分位缘起理成。是故颂应言。佛依分位说。无劳于此说传许声。详彼但求足言成句。分位缘起。是此所明。其理既成。复应思择。何缘于三际。建立缘起支。颂曰

  于前后中际　　为遣他愚惑

论曰。依有情数。立十二支。为三际中。遣他愚惑。彼于三际愚惑者何。如契经言。我于过去世。为曾有非有。何等我曾有。云何我曾有。我于未来世。为当有非有。何等我当有。云何我当有。于现在世。何等是我。此我云何。我谁所有。我当有谁。为除如是三际愚惑。故经唯说有情缘起。三际缘起。如前已说。谓无明行。及生老死。并识至受。故契经说。若有苾刍。于诸缘起。缘已生法。能以如实正慧观见。彼必不于三际愚惑。谓我于过去世。为曾有非有等。有余师说。爱取有三。亦为除他后际愚惑。此三皆是后际因故。彼亦应说。识乃至受。亦为除他前际愚惑。此五皆是前际果故。则无中际。便违契经。或彼应申差别所以。然不能说。故前为胜

说一切有部顺正理论卷第二十七阿毗达磨顺正理论卷第二十八

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩缘起品第三之八

应知如是所说三际。唯有情数缘起义中。虽有十二支。而三二为性。三谓惑业事。二谓果与因。其义云何。颂曰

  三烦恼二业　　七事亦名果
  略果及略因　　由中可比二

论曰。前际因无明。后际因爱取。如是三种。烦恼为性。前际因行。后际因有。如是二种。以业为性。前际识等五。后际生老死。如是七名事。惑业所依故。如是七事。即亦名果。义准余五即亦名因。以烦恼业为自性故。何缘中际。广说因果。后际略果。前际略因。中际易知。应广说二。前后难了。各略说一。由中比二。具广已成。故不别说。说便无用。如何别立爱取二支。毗婆沙师。许初念爱以爱声说。即此相续。增广炽盛。立以取名。相续取境。转坚猛故。若尔应说三支刹那。何故唯言二刹那性。无斯过失。一一境中。各一刹那。合成多故正结生位。唯一刹那。于一身中。无容再结。故生与识。独说刹那。何缘现在诸烦恼位。偏说于爱非余烦恼。于爱易了爱味过患。余烦恼中此相难了。爱是能感后有胜因。世尊偏说。令知过患。云何当令勤求治道。故唯说爱。刹那相续二位差别。非余烦恼。有余师说。一切烦恼。初缘境时。说名为爱。后增广位。说名为取。故佛虽说业因于爱。爱因无明。而实业因通一切烦恼。一切烦恼。皆无明为因。故知爱声。通说诸惑。欲令因此总知过患。故以爱声说诸烦恼。非余烦恼。招生劣故。有说爱声。唯说爱体。多现行故。由此于爱分别刹那相续差别。虽非无此理。然前说为胜若缘起支唯有十二。老死无果。离修对治道。生死应有终。无明无因。无明是初故。生死应有始。或应更立余缘起支。余复有余。成无穷过。又佛圣教。应成缺减然不应许。此难不然。未了所说缘起理故。此缘起理。云何应知。颂曰

  从惑生惑业　　从业生于事
  从事事惑生　　有支理唯此

论曰。唯声正显有支数定。兼显业与惑或俱或后生是惑。生惑时业俱或后义。由如是理。总摄有支。即已善通前所设难。从惑生惑。谓爱生取。从惑生业。谓取生有。无明生行。从业生事。谓行生识。及有生生。从事生事。谓从识支生于名色。乃至从触生于受支。及从生支生于老死。从事生惑。谓受生爱。由立有支其理唯此。已成老死为事惑因。老死即如现四支故。及成无明为事惑果。无明即如现爱取故。岂假更立余缘起支。故经言如是纯大苦蕴集。是前后二际。更相显发义。是故无有老死无明无果无因有终始过。于此定摄因果义周。无更立支成无穷过。由佛遍说因果无遗。故无圣教成缺减失。此中上座。作是释言。余经中说。非理作意。为无明因。无明复生非理作意。非理作意。说在触时。故余经说。眼色为缘。生痴所生染浊作意。此于受位。必引无明。故余经言。由无明触。所生诸受为缘生爱是故触时。非理作意。与受俱转。无明为缘。由此无明。无无因过。亦不须立。余缘起支。又缘起支。无无穷失。非理作意。从痴生故。如契经说。眼色为缘。生痴所生染浊作意。余经虽有如是诚言。然此经中。应更须说。若由理故。不说自成。则一切支。皆不应说。设许理有。文但略标。便违自执此经了义。许此经文非尽理故。凡诸所有不尽理文。智者判为非了义故。既许理有。非载此文便证支名。从胜而立。且此经虽言六处缘触。而上座亦许缘识作意。以契经说。眼及色为缘生于眼识。及染浊作意。虽缘六处亦生识等。而此但言六处缘触。如是触缘非唯六处。但六处位。六处最强。于触位中。触最为胜。就胜而说。余例应思。然经主言。经不别说。老死有果。无明有因。生死便成有终始者。此难非理。经意别故。亦非所说理不圆满。所以者何。此经但欲除所化者三际愚故。由所化者唯生是疑。云何有情三世连续。谓从前世今世得生。今世复能生于后世。如来但为除彼疑情。说十二支。如前已辩。谓前后中际。为遣他愚惑。今详经主。苟欲违背毗婆沙宗。舍自劬劳。所作如理释疑难颂。所谓从惑生惑业等。自谓所言能免他难。今详彼释。于难未免。谓虽欲遣他三际愚。说缘起教。而不具说。老死有果。无明有因。非不了知前因后果相连续义。名诸所化已能除遣前后际愚。所化有情。谓中间诸位。如无明老死。因果俱无。便有断常二见交起。岂知从前世今世生。及了从今世后世起。经既不显。老死无明有果有因。连续不断。所化定谓中间余支。亦因果俱无。如无明老死。则缘起教便足他疑。岂谓除他三际愚惑。故于所难。殊未能通。枉舍劬劳。自所造颂。释难已了。如世尊言。吾当为汝说缘起法。缘已生法。此二何异。且本论言。云何为缘起。谓一切有为。复作是言。云何已生法。谓过去现在。此已生法。必应有缘。故知唯过现名缘已生法。准此缘起。亦在未来。以住未来是起法故。岂不本论亦作是言。谓一切有为。名缘已生法。此无有失。缘已生蕴。摄过去现在一切有为故。非已生法说名已生。不应正理。以相违故。然未来法。亦得名起。与有为相。不相离故。即由此理。前已说言。是起法故。得名缘起。故未来法。不名已生。如现未来。不名已灭。是灭法故。亦得灭名。此中有言。据当有义。未已生法。亦名已生。故世间言。纽绳造钏。外论亦说。祠火求男。此违教理。如说云何非已灭法。谓现未法。及诸无为。若未来据当名已生者。则未来现在应名已灭。如现未法。是灭法故。但得灭名。不名已灭。则未来法。是起法故。但得名起。不名已生。如是方名不违理论。又不生法。于彼成违。以彼必无当生理故。如何据当说亦得名已生。又彼理穷引俗事证。有圣教理证此义成。岂世俗言。证贤圣法。尊者望满。说诸法内。有是缘起非缘已生。应作四句。第一句者。谓未来法。第二句者。谓阿罗汉。最后心位。过现诸法。第三句者。余过现法。第四句者。谓无为法。若未来法。非缘已生。岂不违害契经所说。如说云何缘已生法。谓无明行至生老死。生与老死。既在未来而经说为缘已生法。此无违害。且应审知。一切有支。皆有为故。一一定为三世所摄。无明行支。及生老死。如何可为现在所摄。由约生身展转理故。约未来世二生身说。现在爱取有。得无明行名。约过去世二生身说。现在识至受。得生老死名。故过未四支。皆可现在摄。然彼尊者。复作是言。若无明行二在现在。彼余十支在未来世。八无间当生二第三当生若生老死二在现在。彼余十支。在过去世。八无间已灭二第三已灭。由如是理。十二有支。一切可为现在世摄。故生老死。亦名已生。由此与经无违害失。非未已生位。可说为已生。今详尊者所说义意。若从因已起名缘已生。若与余为因说名缘起。非无为法得缘起名。以为因相不圆满故。因相者何。谓前已说。依此有彼有。此生故彼生。依此无彼无。此灭故彼灭。虽有无为诸法得起。而不可说此生故彼生。亦不可言此灭故彼灭。及不可说依此无彼无。无生灭故。体常有故。诸无为法。能作所缘。无障碍住。于有为法。成能作因。然于有为。无取与力。阙于因相。由此佛说。诸因诸缘。能生识者。皆无常故。有余师说。无明名缘起。行名缘已生。如是展转。乃至生名缘起。老死名缘已生。如是所说。不顺经义。以契经中说无明等皆名缘起缘已生故。有说。无明唯说名缘起。最后老死唯名缘已生。中间十支。俱通二义。非老死位定生诸惑。是故老死唯名缘已生。无明定能发起诸行。故无明位唯说名缘起。诸对法者。有作是言。前际二支。说名缘起。此二意说。为因性故。后际两位。名缘已生。中际八支。皆通二义。如是二说。俱不顺经。经说诸支皆通二故。如是二句。决定义者颂曰

  此中意正说　　因起果已生

论曰。诸支因分说名缘起。所以者何。由此为缘。能起果故。以于因果相系属中说缘起故。此缘起义。但以缘声而成立故。如契经说。云何缘起。谓依此有彼有。及此生故彼生。即无明缘行。至生缘老死。如是说已。复作是言。此中法性。乃至最后无颠倒性。是名缘起。何等名为此中法性。谓于因果相系属中。有因功能。皆名法性。要有因故因果方有。更相系属。非无有因。如是性言。显能生义。唯有为法性。得此法性名。虽此经中非正显示。于因果相属因性名缘起。而以缘声。显缘起义。故知因性得缘起名。以缘声但于能显义转故因能显果。故说名缘。由是阿罗汉最后心心所。非等无间缘。无所显果故。即由此义。证缘起名定于因果相属中立。故佛于彼胜义空经说。此中法假谓无明缘行。广说乃至。生缘老死。以非胜义。故立假声。即目因果更相属义。诸支果分。说缘已生。所以者何。由此皆从缘已生故。果是诸法成办名故。要已生法。此义成故。涅槃成办。由得已生故。彼亦由已生名果。或复于此说缘起门。涅槃于中无容为难。若有为法。果义决定。是此所明。如沙门果。诸过现法。果义决定。名缘已生。法在未来。果义非定。废而不说。此略义者。是起法性。说名缘起。过现诸法。名缘已生。果义定故。谓于因果相系属中。据为因分说名缘起。定为果者。名缘已生。又此中因名缘起者。以能为缘起诸果故。于此中果法名缘已生者。以过去现在离缘不生故。如是一切。二义俱成。诸支皆有因果性故。虽因果性实体无别。而义建立非不极成。以所观待有差别故。谓若观此名缘已生。非即观斯复名缘起。譬如因果父子等名。然此契经说有密意。阿毗达磨无密意说。何等名为此经密意。谓薄伽梵。密显生死无始有终。说斯二句。言缘起者。显生死流无始时来旋还无断。故说顺逆诸支相生。缘已生言。为显生死若得对治有终尽期。谓若有缘。后更续起。如其缘阙。后不续生。由是经言作苦边际。又经中说缘起。是假因果相属。无自性故。说缘已生。其体是实。是彼依故。如瓶所依。阿毗达磨。说二皆实。因果二体。俱实有故。如是已显毗婆沙宗。不违契经缘起理趣。详经主说此违经者。由未承禀毗婆沙师。或师未达毗婆沙义。或虽披览毗婆沙文。邪执覆心。不鉴正理。有余部师。说缘起是无为。以契经言。佛告乞士。如是缘起。非我所作。非他所作。如来出世若不出世。如是缘起。法性常住乃至广说。由此意说。理亦可然。谓此意言。如是缘起。无别作者。故说无为。如来出世若不出世。行等常缘无明等起。非缘余法或复无缘。如是法性。非佛所作。非余所作。说为常住。此亦无疑。如是名常。理必然故若说别法。名为缘起。如择灭等。是凝然常。此必不然。说为缘起。而言体常。理不成故。又彼所执。无为缘起。为异无明等。为即无明等。为揽彼所成。如是三执。皆不应理。自性难知故。有无常过故。体应非实故。或复如言取经义者。则四大种应亦许常。以世尊言。是四大种乍可令异。乃至广说。此经遮彼有为相故。若不观理趣。应执是无为。或佛出世若不出世。此地水等。恒坚湿等。何缘不执此等皆常。然彼于中。有许不许。故知但是粗心所为。且置斯事。复应广释。无明名色触受四支。所以者何。行有爱取。业随眠品。当广释故。识与六处。辨本事品。已广释故。且无明义。其相云何。为是明无。为非明摄。若取前义。无明应是无。若取后义。应眼等为体。如是二种。理皆不然。且上座言。由有此故。令明非有。是谓无明。不可无因而有是事。彼说非理。若由有此为障碍故。明不现行。惑不得明名无明者。则一切烦恼。皆应是无明。随一有时。二俱成故。又不应执无明能与明无为因。以有与无契经不说。能为因故。又无不应是果性故。如何乃说。不可无因而有是事。非于无物可说有言。彼宗许有唯现在故。又彼宗义。虽无无明。而许有时明亦非有。不应定说。无明障明。若谓彼有无明随界。理亦不然。非自体故。设许随界体亦无明。此体有时明亦得起。故不应说能障于明。若谓此明至正生位。无明随界至正灭时。故说无明。能为明障。则住学道。应离无明。或复应明毕竟不起。无明随界。未曾无故。若谓如得随界应然。谓如汝宗。诸无明得非无明体。然或有时无明虽灭。由无明得势力所障。明不得生。或复有时虽有此得。由加行力。明亦得生。如是我宗。无明随界。非无明体。然或有时无明虽灭。由随界障明不得生。或时得生。斯有何过。此救非理。违自说故。太过失故。非我许故。谓彼自说。由有此故今明非有。是谓无明。而今复言。无明随界。非无明体。然能障明。岂不后言违前自说。又无明体。灭隔多时复得生者。离无明者。亦应后时无明更起。许随界体非无明故。俱离无明无有差别。又我不许。由无明得势力所障。明不得生。非对法宗说障余法令不得起。是此得用。若尔此得。其用云何。谓此为因。无明不失。何名不失。亦无别体。但由得用。令所得法数容更起。立不失名。过去无明。岂容更起。不尔。若尔此得何用。虽不能令所得更起。然于未起对治道前。由此恒随相续无断。岂不此与无明俱灭。此虽俱灭。后复续生。谓彼灭时。有为因力。引余自类。令无间生。余复引余。乃至道起。或令所得无明与果。是此得用。谓得断已。此无明果。不复得生。若无明得无无明能与果。应明生已无明复生。过去无明非无体故。既得未断无明果生。得已断时。彼果不起。故此差别。由得而成。如是所言。不越前相。谓令所得数容更起。成不失因说名为得。岂不有法有得。而不生如何可言法生因。谓得以所得法离得不生。故法生因。说名为得。如依眼识离眼不生。亦如汝宗。无明随界。如汝随界。虽恒时有。而无明果。不许恒生。我得亦然。不应为责。此例非理。以对法宗虽无明得无而无明容起。我宗离随界无明必不生。故此随界。非同彼得。无如是失且引彼宗。证得为因。理极成故。谓要有得。所得法可生故。得为生因。理极成立。又随界论。亦同得故。以离随界法亦可生。谓诸异生。无圣法随界。正修加行。圣法容得生。又前已说差别言故。谓由得用。令所得法数容更起。成不失因。说名为得。何关已失及本未得而可为难。又旧随界。已显理无。彼宗无明不现前位。便为已得永离无明。如何无明。后时得起。此设不起圣道加行。何法为障。令明不生。即由此因。诸阿罗汉。明不起位。便失于明。明于后时。如何得起。设非纵逸明体终无。何法为治无明不起。是故彼说。由有此故。令明非有。是谓无明。但有虚言。都无实义。唯对法者。容作是言。朋坏法宗无容说此。上座复说。或如是类。心及心所总谓无明。若尔无明。应非实有。许依心等假建立故。如此所说。理亦不成。一切心心所。皆应无明故。谓此无明。为自性住。心等为体。为有差别。若自性住。一切善等品类心等。应皆无明。非诸无明亦有不用。非理作意为因而起。此彼为因。契经说故。非不染污心心所法。可用非理作意为因。若有差别。能差别者。可是无明。非所差别。又彼应说。此差别相。心心所法。体相各殊。如何总成一无明相。言心心所。总谓无明。详彼心游如来教外。上座又言。或颠倒明即谓无明。以薄伽梵亦于邪见说无明故。如契经说。于邪见中。若习若修。若多修习。痴便猛利。由是应有二种无明。一者邪智。二者黑闇。彼言非理见行痴行。差别建立。应不成故。邪见黑闇。定有差别。若异此者二种应无。非无差别。可成二种既于邪见。若习若修。若多修习。痴便猛利。则于黑闇。若习若修。若多修习。痴亦猛利。契经说痴因无明故。岂不二果无差别故。应许二因亦无差别。是则建立见行痴行差别之相。应不得成。然见行者。与痴行者。入甘露门。各有差别。故彼上座。于经义迷若尔云何。是此经义。非不愚者有倒见行。故邪见俱无明必有。故于邪见。若习若修。若多修习。痴便猛利。然非邪见即是无明。何故无明邪见俱起。言痴猛利非邪见耶。非此所明有而不说。此中意说。数数现行。利贪嗔痴。为烦恼障。谓先有问。云何贪等成猛利耶。后即答言。于贪欲中。若习若修若多修习。贪便猛利。乃至广说。若尔所立见痴二行。应成杂乱。不尔见有三种差别。无杂乱失。谓或有见唯颠倒转。或复有见。全增益转。或复有见。少增益转。于此三中。唯倒转者痴力胜故。立痴行名。余二见强。立为现行。故立二行。无杂乱失。贪嗔俱转。虽有无明。劣故不言。痴便猛利。由此二惑缘有事转。故此品中。痴非增上。惑为显示生死无初。说烦恼生因同异类。如彼经说。诸贪嗔痴。莫不皆因无明而起。或为诃毁不正见故。言习邪见痴便增长。如彼经言。夫名智者。能灭无智。此增痴故。不名智者。乃至广说。故应勤求契经实义。不应执见。即是无明。后释颂中。当更遮遣。大德逻摩。作如是说。非邪见体即是无明。然诸贪欲嗔恚邪见。由异种类。贪嗔痴三。为各别根。而得增长。此亦非理。如何贪嗔。可名贪欲嗔恚异类。又痴何故但为邪见根不为根增长贪欲嗔恚。贪嗔何故非邪见根。然彼不能辩其意旨。故彼所说。非称经义。有说无智唯是智无。是故无明非有为性。若尔除佛余无学果。应有无明。无遍智故。若谓别说前际等无智为无明故无如是过者。不尔智无无差别故。夫言无者。性相俱无。如何可言属此属彼。或复彼应说二智无别相。谓以何为相名前际智等无念无间智等无复以何为相。二俱遮智。一是无明。一非无明。此有何理。故彼所说。亦非经义。有说。于是处明无谓无明如世间言。无盐食等。亦非离色等应成无明故。若谓一切烦恼明无。说名无明。亦不应理。以于结缚随眠等门离欲贪等别说有故。又前所说过随逐故。又若一切烦恼为体。此无明体。亦应是见。是则与见应不相应。由此亦非贪等俱转。执无明体即贪等故。不应即贪等与贪等相应。烦恼应无互相应理。又亦应说无明染心。以贪欲体即无明故。若谓此经据差别说。亦应据别说能染慧。是则应许别有无明。能染污慧。不应谓总以总无明。非别性故。由是应许别有无明。其义云何。颂曰

  明所治无明　　如非亲实等

论曰。如诸亲友所对怨敌。亲友相违。名非亲友。非异亲友。所余一切中平等类。非亲友无。谛语名实此所对治。虚诳言论。名为非实。非异于实。所余一切。色香等类。亦非实无。等言为显非天非白非法非爱非义事等。阿素洛等。天等相违。得非天等名。非异无天等。如是无明别有体实。是明所治。非异非无。云何知然。犹如识等。说从缘有为他缘故。复有诚证。颂曰

  说为结等故　　非恶慧见故
  与见相应故　　说能染慧故

论曰。经说无明。以为结缚随眠及漏枙瀑流等。非余眼等及体全无。可得说为结缚等事。故有别法。说名无明。如恶妻子名无妻子。如是恶慧应名无明。彼非无明。有是见故。诸染污慧。名为恶慧。于中有见。故非无明。见是推寻。猛睿决断。不可说彼名为愚痴。若尔无明。应是非见。诸染污慧。此亦非理。以许无明见相应故。无明若是慧。应见不相应。无二慧体共相应故。不可说见非无明俱非不愚痴见成倒故。又说无明能染慧故。如契经说。贪欲染心。令不解脱。无明染慧。令不清净。非慧还能染于慧体。如贪异类能染于心。无明亦应异慧能染。亦不可说无明与慧虽不相应而能为染。如贪为染必与心俱。心心所法。无等起染。但有自性相应染故。不可自体自体相应。是故无明。定非恶慧经主于此。假作救言。如何不许诸染污慧间杂善慧。令不清净。说为能染。如贪染心。令不解脱。岂必现起。与心相应。方说能染。然由贪力。损缚于心。令不解脱。后转灭彼贪熏习时。心便解脱。如是无明。染污于慧。令不清净。非慧相应。但由无明。损浊于慧。如是分别。何理相违。今详彼言。非善分别。离相应品。不能染故。若相应贪心相应故。能染于心。不相应贪。以未断故。亦能染者。则非阿罗汉应无不染心。若谓彼贪。有染不染。曾所未见。又成非爱失贪缠正现前应有不染故。又若相间杂名能染者。则诸无漏慧。亦应被染。又无染慧杂有染慧。应令有染转成无染。能治力强。非所治故。又诸善慧。正现行时。染定非有。诸染污慧。正现行时。善定非有。说谁能染复染于谁。若现有非有能互相染则应毕竟无得解脱义。若灭熏习便解脱者。熏习本无。更何所灭。设有熏习。亦非能染。非无明体。前已说故。灭不灭位。竟有何别。故说无明能染慧故。非慧为性。理无倾动。若有别法。说名无明。应说以何为别法性。且有别法。谓不了知。此即无明。何劳推究。应定何法名不了知。方可说为无明自性。唯薄伽梵。于一切法。正知正说。若性若相。余唯总了。何苦推征。然我于斯见如是相。谓有别法。能损慧能。是倒见因。障观德失。于所知法。不欲行转。蔽心心所。是谓无明。如何定知。此有别法。以如贪欲。说永离故。谓契经言。离贪欲故。心便解脱。离无明故。慧得解脱。又此如明。说为因故。谓契经说。无明为因。起诸杂染。明为因故。离诸杂染。又说如邪见有近对治故。谓契经说。诸邪见断由正见生。诸无明离由明慧起。又契经说。是一法故。谓契经说。若有苾刍。能断一法。我正记彼。所作已办。即是无明。又说如闇。有对治故。如伽他说

  诸有能断愚　　于所愚不惑
  彼转灭愚惑　　如日出除闇

若谓闇体非别实物。但以明无。为其体者。此不应理。明应尔故。若谓明生有缘可得。闇则不尔。理亦不然。生缘各别。如水等故。谓或有水生。无外聚缘。或有水生。待外聚缘力。地等不尔。余随所应。故法生缘。各有差别。如是明起。必待余缘。闇则但由违缘。非有同类因力及俱生缘。其体得生。有违何理。又见闇体。有品别故。非但明无可有品别。若谓是处明分有无。故闇得成。微中粗者。亦不应理。无法体无。无容得成品类别故。又有非有不同处故。又闇与影眼识境故。如青等色。其体实有。非五识身能缘假法。如前已辩。又闇与影。界所摄故。实有义成。又如烟云。障余色故。闇亦应尔。其体非无。若谓闇中眼识不起。由明非有非闇障故。理亦不然。缘明所隔远处暗色眼识生故。不见闇中余色物故。若谓闇处余有色物无明摄益。非闇障故。理亦不然。彼可疑故。此中理趣。如前已辨。又此如香体非非有。可久习近故。相不分明故。摄益眼因故。若谓由光损眼势用。此光无处眼增益者。亦不应理。久住其中。观此还能为损因故。若谓闇体非实有法。明不俱故。无色相故。此亦不然。杂明隔明。现可得故。岂不明处闇体必无。有对皆然。何独明闇。又契经说。黑闇为缘。明界可了。非无有法能作他缘。故闇有体。又闇如日可出现故。如言日没闇便出现。无法不应有出现义。又说缘杌。而现影故。杌既是假。影应非实。此难不然。如腹虽是假。而生实饥渴。前已成故。又可领触。犹如受故。又世尊告婆涩波言。于意云何。岂不缘杌而现于影。根本若断。此法不生。乃至广说。非于无法可说此言。又契经言。如入密室见闇充满。非于无体可有如斯见充满义。又契经说。以众光明破诸黑闇。闇若非有。其体本无。岂更须破。又契经说。若不断本。如影必随。乃至广说。由如是等众多理教。故知影闇其体实有。由此所言。无明如闇。有对治故。其理极成。是故无明。定有别法。无知为体。非但明无。然此无知。略有二种。谓染不染。此二何别。有作是说。若能障智。是染无知。不染无知。唯智非有。今详二种无知相别。谓由此故。立愚智殊。如是名是染无知相。若由此故。或有境中。智不及愚。是第二相。又若断已。佛与二乘。皆无差别。是第一相。若有断已。佛与二乘。有行不行。是第二相。又若于事自共相愚。是名第一染无知相。若于诸法味势熟德数量处时同异等相。不能如实觉。是不染无知。此不染无知。即说名习气。有古师说。习气相言有不。染污心所差别。染不染法数习所引。非一切智相续现行。令心心所不自在转。是名习气。非唯智无。无法无容能为因故。亦不应说有如是类心及心所总名习气。不染无知。前已说故。谓此无知为自性住。心等为体。为有差别。若自性住。心等为体。佛亦应有不染无知。若有差别。能差别者。可是无知。非所差别。现见善等品类差别心心所中。必有别法。为能差别。非即一切。如善品中。必有信等。不善品中。有无惭等。染污品中。有放逸等。如是等类。心心所中。必有别法。为能差别。故知此中亦有别法。能为差别者。是不染无知。今详彼言。有太过失。诸异生等。心心所法。皆不如实觉味势熟等相。然不见生余心所故。又一一念。彼心心所。差别而生。应念念中各有别别无知法起。若谓有异相令无知差别。即此足能差别心品。何须别计不染无知。是故即于味势熟等不勤求。解惠与异相法俱为因。引生后同类慧。此慧于解。又不勤求。复为因引生。不勤求解慧。如是展转无始时来。因果相仍。习以成性。故即于彼味等境中。数习于解。无堪能智。此所引劣智。名不染无知。即此俱生心心所法。总名习气。理定应然。或诸有情。有烦恼位。所有无染心及相续。由诸烦恼间杂所熏。有能顺生烦恼气分。故诸无染心及眷属。似彼行相差别而生。由数习力相继而起。故离过身中。仍名有习气。一切智者。永断不行。然于已断见所断位。通染不染心相续中。有余顺生烦恼习性。是见所断烦恼气分。于中染者。说名类性。金刚道断。皆不现行。若不染者。名见所断烦恼习气。亦彼道断由根差别。有行不行。若于已断修所断位。唯于不染心相续中。有余顺生烦恼习性。是修所断烦恼气分。名修所断烦恼习气。是有漏故。无学已断。随根胜劣。有行不行。世尊已得法自在故。彼如烦恼毕竟不行。故佛独称善净相续。即由此故。行无误失。得不共法。三念住等。又由此故。密意说言唯佛独名得无学果。大德逻摩作如是说。有不染法名为习气。如不善因所招异熟。世尊昔在菩萨位中。三无数劫修诸加行。虽有烦恼而能渐除。烦恼所引不染习气。白法习气渐令增长。后于永断诸漏得时。前诸习气有灭不灭。以于长时修加行故。证得无上诸漏永尽。然佛犹有白法习气。言习气有灭不灭故。如是所说理亦可然。而彼不能显其体性。不染习气。其体是何。非但虚言。令生实解。经言类性其体是何。有作是言。我慢为体。彼违经说。以契经中。于我慢外说类性故。经言我今如是知已。如是见已。诸所有爱。诸所有见。诸所有类性。诸我我所执。我慢执随眠。断遍知故。无影寂灭。故知类性异于我慢。有说余慢是类性摄。彼说不然。诸言流至我慢中故。我慢执言。摄诸慢尽。应如爱等各摄无遗。然于此中。胜者别说我我所执。是诸见根。故于见中。别显二种。为摄疑恚。说随眠言。胜烦恼中。无明未说为别显。彼说类性言。遍与惑俱。遍往诸趣。故名类性。类是行义。是类之体。得类性名

说一切有部顺正理论卷第二十八阿毗达磨顺正理论卷第二十九

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩缘起品第三之九

已辩无明。当辩名色。色已辩名云何。颂曰名无色四蕴

论曰。佛说无色四蕴名名。何故名名。能表召故。谓能表召种种所缘。若尔不应全摄无色不相应法。无所缘故。不尔表召唯在无色。如释色名所说无过。佛说变碍故名为色。去来无表。及诸极微。虽无变碍。而得名色。以无色中无变碍故。变碍名色。非不极成。如是无色中容有表召。非色中有故。理亦无违。故不相应名摄无失。又微细故。彼彼义中。随理立名。摽以名称。非无表等亦可称名。以彼所依现量得故。又于一切界地趣生。能遍趣求故立名称。非无漏无色不得名名。虽非此所明而似此故。又于无色随说者情。总说为名不劳征诘。上座意谓顺成彼彼有情相续。故说为名。是能为因。顺成彼义。若尔色法应亦是名。亦能为因顺成彼故。佛说地等成有情身。经说士夫即六界故。又无经说。唯无色蕴。成有情身。然有经言。因色等起。有情相续。故彼释名。无所凭据。岂不佛说此伽他言

  名能映一切　　无有过名者
  是故名一法　　皆随自在行

此中引彼。何所证成。为彼颂中显有情相续。唯用无色法为能成因。为显无色。强能引有色。于有情相续为能成因。若谓一切有情相续。无不皆以无色为因。理亦不然。诸无心者。但以有色成相续故。无心有情。前已成立。彼无得等。为能成因。又一一有情。三界诸蕴。成一相续。故诸色法。亦是一切有情相续因。不尔则应不作而得。或作已失。便成太过。若一有情相续诸位。色不遍者。无色亦同。又应审思。此伽他意。为说受等四蕴名名。为说能诠诸别相义。如牛色等言依名名。然于此中唯应说彼能诠一切色非色名。唯此力能映一切法。以无一法非名所诠。异此何名能映一切。又十二处名一切法。受等何能映十二处。若谓皆是受等所缘。则此中名。唯目意识及相应法。若谓所余是名类故。无斯过者。则不应引此颂证名。为因顺成有情相续。谓若唯意识及相应品。正是此伽他所说名者。则不应引证为因义。以五识身及相应品。亦为因顺成有情相续故。又如何说无过名者。若谓名中施设多蕴。色不过者。色中施设多界多处。名岂能过。若谓名通无色有者。诸不通者。应不名名。若谓不通是通种类。无斯过者。理亦不然。前说不应引为证故。谓不通者。亦为因成有情相续。与通等故除所执名。有何余法。可说彼诸法皆随自在行。若谓此名色随行者。亦不应理。非极成故。谓许名色展转相依。如何但言色随名转。若谓名遍色。色不能遍名。理亦不然。非情无故。又前已说。有无心有情故。亦非名色外有法随名转。经说所知法总有二。谓名与色。更无第三。又理不应四蕴名一。设许对色说一法言。然不见有定随行法。不可自体随自体行。故知此名。唯能诠想。若作此解。无假劬劳。释此伽他。义皆明了。引之将证四蕴名名。成有情身。定不应理。上座于此假设难言。若名色言。总摄五蕴。世尊说识依名色故。识则应有二。谓能依所依。即自释言。此难非理。已于名中。间出识故。谓已举识。说为能依。准知识所依但取余名色。今详彼难。理自不成。等无间缘。依识定依识故。然彼上座。不许同时识与名色有相依理。彼宗不许有同时因果故。如何以识无二俱生。遂令识无还依识义。又设许有俱生相依。但可识为受等所依。性不可受等与识为所依。如何识所依可取余名色。故彼问答。皆不应理。今于此中。应更思择。佛于城喻大缘起经说。识与名色。更互为缘义。为据前后。为约俱生。识缘名色。亦据前后。名色缘识。唯约俱生所以者何。识入母胎故。与羯剌蓝合。成有情身。故识缘名色。亦得有前后。非名色合已更结余识。非识未已起名色为缘故。唯约俱生。有名色缘识。识支唯一故。又一刹那故谓次第说缘起支中。但一识支。此唯一念。如何可执识与名色定约前后说互为缘。又契经说。如芦束故。谓契经言。如二芦束立在空地。展转为依。若一倒时。余亦随倒。如是具寿。二法相依。谓识缘名色。及名色缘识。若离俱起展转为缘。与芦束喻。云何相似。谓于识位。名色位未生。名色位生时。识位已灭。定无似芦束更互相依义。况拨过去未来无者。可言如彼更互相依。随一有时。随一无故。非无与有或有与无。可有展转互相依义。唯有与有。可互相依。故执相依。定前后者。是圣教外。非佛法宗。又契经说。无明作意俱时而起。展转为缘。谓说无明因非理作意。及非理作意从痴所生。及说此二俱时而起。故契经说。眼色为缘。生痴所生染浊作意。此中痴者。即是无明。乃至广说。言此中者。意显即此作意生时。或即所摽。缘和合位。非同属缘法可前后生。以二俱时起无障碍故。又如灯明同时而起有因果义。前于思择俱有因中。已曾具辩。如是因果俱起极成。而有救言。灯明非异。此不应理。灯之与明。触量色处用各别故。世间唯说焰为灯故。如说灯光灯能烧物。阿笈摩说。明依于灯。如日月光。明依日月轮起。又如大地依于水轮。水与地俱生方有为依义。灯明性别。由是极成。因果俱生。于斯义显。明虽依自大种而生。然于生时。非离灯焰。若谓明焰同一因生。以即焰因是明因者。亦不应理。有差别故。非从一和合有非一果。亦非一果非一和合生。岂不一击火声俱起。宁无一和合有非一果生。理亦不然。依各别故。又自类因。各别生故。由此彼救。但有虚言。故灯与明。因体各别。若识与名色。展转为缘。何故经多言识缘名色互为缘性。其理虽通。显识用强。是故偏说。识用强者谓识为所依受等用心为所依转故。识持精血。成羯剌蓝。成有情身。其用胜故。如王臣等。虽互相依。而王得名。以最胜故。识与名色。应知亦尔。又识缘名色。据前生缘说。展转为缘。唯约俱起。以识缘名色。通前后及俱。名色缘识。唯有俱起。以结生识无别位故。又识缘名色。据分位名色。说展转为缘。据刹那名色。大德逻摩率自意说。若从中有。结生有时。中有名色。为缘引起无间刹那结生类识。中有名色灭。独有识生。此方能引起生有名色。如是推寻非应正理。所言中有名色为缘。引无间刹那结生类识者。为中有识。亦能为缘。为但余名除中有识。若中有识亦为缘者。何理中有最后刹那心心所色为缘。但引后识令生非心所色。若谓除识余名为缘。何理俱生识非缘性。若谓彼位无识俱生。应结生识无所依起。不应心所为心所依。复以何缘。彼位心所。但与异类识作生因。不能引生同类心所。非于诸色未得离贪。可有暂时识不依色。故中有色。定能为缘。牵续生时心俱起色。如何此位。独有识生。若谓此时虽有色起而但说识。则应此位亦有心所。而但说心。是故不应复作是说。中有名色灭独有识生。此方能引起生有名色。又应此独识非中有生有。中有已灭故。生有未生故。非中有灭有位非生。故彼所言。出自邪执。又心心所前后生论。如何计度前后而起。眼识无间。眼触所生受等生时。为与余识俱时而起。为独受等。若有余识受等俱生。为是意识生即缘彼境。为别是余识缘余境生。且非意识生即缘彼境。眼触生受等。既依眼根。与此意识境时别故。非依眼根所生受等。可以过去为其所缘。亦非眼触所生受等。可以意法为缘而生。说意法为缘生意识等故。若以意法为缘生者。不可说是眼触所生。亦非余识缘余境起。若依境异。可俱时生。则应一时得一切境。若无诸识受等独生。则后识生。无所依。意识流断已。复更续生。下界曾无。彼全不许。入灭定等。识相续生。曾无间断。彼宗许故。由此彼说。中有后心。名色无间。独有识起。后方引起生有名色。但有虚言。违理教故。上座于此。假设难言。经不应言识缘名色。由展转力。方得生故。即自释言。此难非理。约生住缘有差别故。谓识能作名色生缘。由识托胎。令彼生故。彼生以后。为识住依。展转为缘。而得安住。故亦说识名色为缘。此亦不然。违理教故。谓佛未得大菩提时。求识生缘知即名色。如契经说。菩萨寻求老死生缘。乃至名色知生至识。次第为缘求识生缘知即名色。若彼名色非识生缘。菩萨所知便为颠倒。又彼所说。彼生以后。为识住依。展转为缘。而得安住。故亦说识名色为缘。有言无理。此所说识。名色为缘。即是为缘生名色识。如何以后方为识依。又彼经但言识依名色住。故契经说。告阿难陀。识不依名色为得住不。不也世尊。此经不言名色依识住。如何展转。又汝不许识名色俱生。如何可言展转为缘住。又如先说。拨过未宗。随一有时随一无故。非无与有。或有与无。可有展转互相依义。唯有与有可有相依。如何俱生有相依义。若随阙一。一不立故。又佛于彼大缘起经。不说有支次第因果。亦不唯说十二有支。彼说名色为触缘故。及说寻求等为得等缘故。然佛于彼。为阿难陀。显示甚深缘起理趣。故彼经义。约所依缘。但说识依名色而住。意识唯托意为所依。法为所缘。而得安住。眼等五识。眼等为所依。色等为所缘。而得安住。如是意识。所依唯一。所缘通二。五识翻此。唯除意识。所依必异时。余所依所缘。有俱生理。有支诸位。此义皆通。详上座宗。说识名色互为缘义。理必不成。然契经说。我观缘起至识便还过此。于余心不复转。此言何义。菩萨尔时。逆观缘起。诸支展转所从生缘。先观九支生缘各别。最后观识无别生缘。故至识还于余不转。然结生识。有二生缘。一者前生。二者俱起。识生行有。义无别故。先观生支。生缘谓有。即已观识。前生缘行。今观名色。为俱生缘。故至识还心不复转。已具观识二生缘故。以见今世结生位识。从前俱起二缘力生。准知余支。如应皆尔。一一念起。各具二缘。故唯于识支具显二缘观。如何名色为识俱缘。以于此中识住着故。如经说识住除识余名色。前以住着释识住义。故契经说。喜爱润识。令于蕴中增长广大。又大缘起经亦作是说。识不依名色。为得住不。不也世尊。乃至广说。此说识住着俱生名色中显识俱生缘故。说四识住。是故菩萨至识便还。虽老死支即名色等。前观老死。以生为缘。已显识支缘生名色。而非老死。皆识为缘。为定识为缘。唯生名色故。复观名色。以识为缘。毗婆沙师说。彼菩萨厌怖生故。再度观生。由菩萨心厌怖流转。不遍观察诸流转支。诸流转支。皆生为本。再观生故。为已遍知。无明行支。即爱取有。已观爱等。故不重观。于还灭门。菩萨欣慕。故遍观察十二有支。已辩名当辩触。颂曰

  触六三和生

论曰。触有六种。所谓眼触。乃至意触。此复是何三和所生。谓根境识三和合故。有别触生。虽第六三有各别世。而因果相属。故和合义成。或同一果。是和合义。虽根境识未必俱生。而触果同。故名和合。触体别有。大地中已成。虽三和生。而定识俱起。以如识说二缘生故。谓契经说。内有识身。及外名色。二二为缘。诸触生起。乃至广说岂不此即说触从三和生。谓内有识。身即六根六识。及外名色即六境故。二缘生故。因不极成。经义不然。佛说二故。谓此经说。二二为缘。诸触生起。不言三故。观此经义。有识身言。显六内处。外名色言。显六外处。余经亦说二缘所生。故伽他言。眼色二等。如前已说。又经说识触俱名色为缘。生缘既同。时岂前后。缘具必起。无能障故。由此即证。眼等触所生受等诸法。眼等识俱起。与眼识等生因同故。由此经言。是受是想是思是识。如是诸法。相杂不离。执触是假。宗亦应许受等与触俱起。由此经说。识杂受等故。识是触分故。既无有识。不杂受等证成受等。是大地法。彼作是言。大地法义。非要遍与一切心俱。若尔何名大地法义。有三三地。有寻伺等善等学等。地差别故。若法于斯一切地有。名大地法。余随所应。此但有言。违前经故。彼作是说。应审前经。彼经复言。诸所受即所思。诸所思即所想。诸所想即所识。未了于彼为约所缘。为约刹那。作如是说。有何未了。前约刹那。后约所缘。其理决定。宁知决定以余经中。约俱生法说相杂故。如契经言。寿暖与识。如是三法。相杂不离。非于此中约不俱起。及约所缘。作如是说。三必俱起故。二无所缘故。由此所说受等相杂言。定约刹那。异此不成故。谓若计彼无间而生。名为相杂。一无一有。相杂不成。如前已辩。亦不可谓同一所缘说名相杂。勿有意识与眼识等。有相杂义。故缘一境。有识生时。必有俱生。触受等法。定无有识离触等生。由所引经。已善成立。如何触受二法俱生。说触缘受。非受缘触。故契经言。非缘种种受有种种触。但缘种种触。有种种受。又经但说眼触为缘。生眼触所生受。曾无经说。眼受为缘生眼受所生触。岂不现见。灯明芽影。二虽俱生。但因灯芽生于明影。触受亦尔。此例不平。随行住变。有无有故。无有定因。证触与受二虽俱起。而触缘受非受缘触。虽无现相而理必然。受必随触。有差别故。若犹不了。更以别门。方便开示。令义易解。谓触有二。一假二实。所言假者。谓三和触。如契经言。如是三法。聚集和合。说名为触。所言实者。谓心所触。如契经言。眼色二缘。生于眼触。乃至广说。又契经说。内有识身。及外名色。二二为缘。诸触生起。又契经说。名色缘触。六处缘触。诸如是等。无量契经。此中假触为缘生受。非受为缘。非根境识三法和合从受生故。非唯眼识为眼触体。心所皆由所依显故。虽受生位识为胜因。而说受等生亦因于眼色。是故但说眼触为缘生眼触所生受。曾无有说眼受为缘生眼受所生触。此中实触。是心所故。可说与受展转为缘。是故二经不相违背。又约别义说亦无违。谓由此门。因触生受。非即由此因受生触。如契经言。我不见一法如是断贪欲如修身念。此约异门。遮诸余法。非谓通约诸对治门。以次后复言如修身念息念佛念死想等亦尔。言如是者。显异门义。如何知受。亦为触缘。余契经说。受缘触故。如契经言。由身受触。此意显有触身受为缘起。何故眼等亦为受等缘。但依说触不依说受等。以和合中触义显故。此彼和合。得相触名。非于自体得名为触。世于和合。立相触名。如二木合时。说为木相触。是故眼等三和合中。但可说触。非说受等。又非眼等是生触因。故依之说触名。何得难言亦受等因故应依说受等。若必尔者。应许一切触因所生皆名为触。然实一切触果法中。多分立名。随差别想。一随总想。以立别名。如色处界。及行蕴等。由此善释余处说言一切心所皆触引发。若尔想等皆触为缘。何故但言触为缘受。亦说想等用触为缘。如了达经不应为难。于触后位。受用最强。故以受声。总说诸行。然于缘起所说受因。但取实触。非三和假所以者何。说所依故。谓唯实触。就所依显。非诸假有。于假依中。可得品量。此胜此劣。若随阙一。无容有故。由是知此中说实触缘受。此中所说。缘起定义。谓随何位随何法强即说为缘。生次后位胜法为果。故无有失。或复当来。大杂染聚。所有根本。受为近因。故缘起中。次第说触为缘生受。令避缘故。受不现行。绝彼根本。诸心心所法。皆六处为缘。何故但言六处缘触。此位触胜。故说触名。理实应知。诸心心所。无不皆以六处为缘。复以何缘。实触胜位。唯说与彼胜受为缘。不说为缘生胜想等。虽触与彼亦俱时生。而顺受强。是故偏说。譬如胜解。偏顺决定轻安勤等。顺止观强其理法然。不应为难。名色二六处缘触。何差别。名色缘触。说在何经。大缘起经。有如是说。诸有行相。诸有摽举。施设名身。无彼行相。无彼摽举。可得了知。增语触不。不尔大德。诸有行相。诸有摽举。施设色身。无彼行相。无彼摽举。可得了知。有对触不。不尔大德。若一切种名身色身。皆无所有。可得了知。触或施设触不。不尔大德。是故庆喜。触之由绪。触因触缘。所谓名色。此所引经。欲辩何义。辩名与色。为触生因。名谓意法处。色谓眼色处。乃至身触处。此中名身名增语触。名为身故。得名身名。如是色身名有对触。色为身故。得色身名。是名为体。色为体义。此中意说。增语触因。名增语触。有对触因。名有对触。非二触体。由此说言。诸有行相。诸有摽举。施设名身。施设色身。言行相者。谓诸外处。行所行相。得行相名。言摽举者。谓诸内处。由此摽举。诸触名故。谓名眼触。乃至意触。此意说言。于诸有名体。施设增语触。于诸有色体。施设有对触。随有所阙所施设触。皆不得成。此上经文。且辩假触为辩缘。此所生实触。复作是说。若一切种名身色身。皆无所有。乃至广说。此义意言。若一切种。假触非有。则心所触。于三时中。自名难了。体不生故。不可了知。既不可了知。亦不可施设。若作如是分别经义。名色缘触。即二缘触。然名色缘触。分位决定。若二为缘触。分位不定。虽六处缘触。分位亦定。而偏就有情所依显示。名色缘触。通就所依所缘显示。故有差别。复有别义。此中名身名增语触。即是以名为所依义。此以意识为所依故。此中色身。名有对触。即是以色为所依义。此以五根为所依故。由是诸触所依力故。摽别其名。如眼识等。所谓眼触。乃至意触。意识与意。是一义故。若一切种名色所依六触非有。则定无有余无依触。而可了知。既无可了知。亦不可施设。此义意言。离六所依等。假触无故。离六触体外实触亦无。若作如是分别经义。即六处缘触。说名色缘触。此中显名色即六处差别。为辩缘起种种义门。令阿难陀知甚深义。有余师说说名色缘触。显三和生。显根境功能。说二缘触。说六处缘触。显不共因用。有说三种依界处缘起门。如其次第。即前六触。复合为二。其二者何。颂曰

  五根应有对　　第六俱增语

论曰。眼等五触。说名有对。以有对根为所依故。唯有对法为境界故。第六意触说名增语。增语谓名。名是意触所缘长境。故偏就此名增语触。意识通用名义为境。五不缘名。故说为长。如说眼识但能了青不了是青。意识了青亦了是青。乃至广说。故有对触名从所依境。就所长境立增语触名。有说意识名为增语。于发语中。为增上故。有言意识语为增上。方于境转。五识不然。是故意识。独名增语。与此相应。名增语触故。有对触名。从所依境。就相应主。立增语触名。即前六触。随别相应。复成八种。颂曰

  明无明非二　　无漏染污余
  爱恚二相应　　乐等顺三受

论曰。明无明等相应成三。一明触。二无明触。三非明非无明触。此三如次。应知即是无漏染污余相应触。余谓无漏及染污余。即有漏善。无覆无记。无明触中。一分数起。依彼复立爱恚二触。爱恚随眠。共相应故。总摄一切。复成三触。一顺乐受触。二顺苦受触。三顺不苦不乐受触。云何顺受触。是乐等受所领故。或能为受行相依故。名为顺受。如何触为受所领行相。依行相极似触。依触而生故。又与乐等受相应故。或能引生乐等受故。名为顺受。如是合成十六种触。已辩触当辩受。颂曰

  从此生六受　　五属身余心

论曰。从前六触生于六受。谓眼触所生受。至意触所生受。此合成二。一者身受。二者心受。六中前五说为身受。依色根故。意触所生说为心受。但依心故。颂曰

  此复成十八　　由意近行异

论曰。于前所说一心受中。由意近行异。复分成十八。云何十八意近行耶。谓喜忧舍各六近行。此复何缘立为十八。由三领纳。唯意相应。六境有异。故成十八。非一受体意识相应境异成六。领纳异故。意近行名。为目何义。喜等有力。能为近缘。令意于境数游行故。若说喜等。意为近缘。于境数行。名意近行。则应想等亦得此名。与意相应。由意行故。若唯意地。有意近行。岂不违经。如契经言。眼见色已。于顺喜色。起喜近行。乃至广说。此不相违。如依眼识引不净观。此不净观。唯意地摄。然契经言。眼见色已。随观不净。具足安住。此亦如是。依五识身所引意地。喜等近行。故作是说。由彼经言。眼见色已。乃至广说。故意近行。五识所引意识相应。不应为难。何缘身受。非意近行。与意近行。非同法故。以意近行唯依意识。故名为近。分别三世等自相共相境。故名为行。一切身受。与此相违。故非意近。亦不名行。岂不身受亦有此相。身受领纳色等境已。意识随行。由身受力。意识于境。数游行故。此亦不然。已说相故。谓诸身受。不依意识。无分别故。由彼不能分别境界功德过失。故非彼力。令意于境数数游行。又不定故。谓身受后非决定有。意识续生意受俱时。必有意识。故唯意受。名意近行。又生盲等类。虽无见已。乃至触已。而有近行故。第三静虑。有意地乐。亦应摄在意近行中。此责不然。初界无故。又凝滞故。谓欲界中。无意地乐。第三静虑。虽有不立。又彼地乐。凝滞于境。近行于境。数有推移。不滞一缘。方名行故。又无所对。苦根所摄。意近行故。若尔应无舍意近行。无所对故。不尔忧喜。即舍对故。第三静虑意地乐根。无自根本地舍根为对故。然无近分等无舍等近行失。以于初界中有同地所对故。或复容有。不容有故。谓意舍等。容有同地。所敌对法。意乐定无同地敌对。故无有失。然十八中。前之十五。色等近行。名不杂缘。以各别缘色等境故。三法近行。皆通二种。若唯缘法及六内处。名不杂缘。若缘此七及五外处。或别或总。名为杂缘。若虽非见。乃至触已。而起喜忧舍。亦是意近行。若异此者。未离欲贪。应无缘色界色等意近行。又在色界。应无缘欲香味触境。诸意近行。若尔何故。契经中言。眼见色已。于顺喜色。起喜近行。乃至广说。随明了说。故不相违。或眼等所引易可分别故。又诸近行。亦异建立。谓眼见色已。起声等近行。至意知法已。起色等近行。随无杂乱。经如是说。于中建立。根境定故。于顺喜色。起喜近行等。此举现在令类解所余。续生命终。唯舍近行。非忧与喜。舍任运得故。及顺彼位故。唯有杂缘。诸舍近行。能正离染。以意近行。但有漏故。唯舍非余。诸加行道中。亦有喜近行。非无间解脱。根本定摄故。最后解脱道。容有喜近行。诸意近行中。几欲界系。欲界意近行。几何所缘。色无色界。为问亦尔。颂曰

  欲缘欲十八　　色十二上三
  二缘欲十二　　八自二无色
  后二缘欲六　　四自一上缘
  初无色近分　　缘色四上一
  四本及三边　　唯一缘自境

论曰。欲界所系。具有十八。缘欲界境。其数亦然。缘色界境。唯有十二。除香味六。彼无境故。缘无色境。唯得有三。彼无色等。五所缘故。缘不系境。亦唯有三。说欲界系已。当说色界系。初二静虑。唯有十二。谓除六忧。若说所缘。定无染污。能缘下境。善缘欲境。亦具十二。除香味四。余八自缘。二缘无色。谓法近行。缘不系法。亦唯二种。三四静虑。唯六谓舍。缘欲界境。善亦具六。除香味二。余四自缘。一缘无色。谓法近行。缘不系法。亦唯一种。说色界系已。当说无色系。空处近分。唯有四种。谓舍但缘色声触法。缘第四静虑。亦具有四种。此就许有别缘者说。若执彼地。唯总缘下。但有杂缘。法意近行。缘无色界。唯一谓法缘。不系法亦唯一种。四根本地。及上三边。唯一谓法。但缘自境。无色根本。不缘下故。彼上三边。不缘色故。不缘下义。如后当辩。此缘不系。亦唯有一。诸意近行。通无漏耶。颂曰

  十八唯有漏

论曰。无有近行通无漏者所以者何。增长有故。无漏诸法。与此相违。有说近行。有情皆有。无漏不然。故非近行。有说圣道任运而转。故顺无相界故非近行体。近行与此体相违故谁成就几意近行耶。谓生欲界。若未获得色界善心。成欲一切。初二定八。三四定四。无色界一。所成上界皆不下缘。唯染污故。若已获得色界善心。未离欲贪。成欲一切。初静虑十舍具六种。未至地中。善心得缘香味境故。喜唯有四。以但有染不缘下故。岂不意近行眼等识所引。彼既无鼻舌二识。应无缘香味近行。此责不然。生盲聋等。自性生念。及在定中。皆应无有色等近行。故非一切。五识所引成二定八。三四静虑。无色如前。已离欲贪。若未获得二定善心。彼成欲界初定十二。谓除六忧。二静虑等。皆如前说。若已获得二定善心。于初定贪未得离者。成二定十。谓喜但四。唯染污故。舍具六种。已获得彼近分善故。余如前说。由此道理。余准应知。若生色界。唯成欲界一舍法近行。谓通果心俱。经主此中。假为异说。谓说如是。诸意近行。毗婆沙师。随义而立。然我所见。经义有殊。所以者何。非于此地已得离染可缘此境起意近行。故非有漏。喜忧舍三。皆近行摄。唯杂染者。与意相牵。数行所缘。是意近行。云何与意。相牵数行。或爱或憎。或不择舍。为对治彼。说六恒住。谓见色已。不喜不忧。心恒住舍。具念正智。广说乃至。知法亦尔。非阿罗汉。无有世间缘善法喜。但为遮止杂染近行。故作是说。未审经主以何相义。为意近行。蕴在心中。执阿罗汉。缘诸善法。有漏善喜。非意近行。非阿罗汉。有意近行。少与正理契经相违。如何定知。于诸境界。或爱或憎。或不择舍方是近行。非如先说。诸离欲者。或阿罗汉。于有漏事。虽全分断。而有有漏喜等现行。不名近行此有何理又以何缘。唯六恒住。远分所治。贪等相应杂染喜等。方名近行。非余有漏善喜等受。又彼自说差别言故。非染近行。定有极成。谓彼自言。但为遮止杂染近行。故作是说。既已许有非染近行。非六恒住。正所遮遣。故毗婆沙所说近行。非与正理契经相违。又诸有漏。皆名杂染。既许杂染皆名近行。与此宗义。有何相违。又彼所说。然我所见经义有殊。诚如所说。经义与彼所见别故。谓彼契经。为显无学眼见色已。非如昔时起贪嗔痴。言不喜等。不言见色已不起意近行。故毗婆沙所说为善。此诸近行。获得云何。谓离欲贪。前八无间。八解脱道。获得初定近分地中。六舍近行。第九无间解脱道中。获得欲界通果心俱。法舍近行。获得初定十二近行。此初定言。兼摄眷属。由此理趣。离上地染。如应当思。然有差别。谓离第四静虑贪时。第九无间。及解脱道。必不获得自地下地通果心俱法舍近行。离空处等诸地贪时。一切无间及解脱道。唯获得一法舍近行。得无学时。获得欲界初二静虑十二近行。三四静虑。六舍近行。空无边处。四舍近行。上地各一。舍法近行。于受生位。从上地没。生下地时。获得当地所有近行。生诸静虑。亦兼下地舍法近行。又即喜等十八意行。由为耽嗜出离依别。故世尊说。为三十六师句。此差别句。能表大师是师摽[愔*戈]。故名师句。如是诸句。唯佛大师。能知能说。余无能故。有说此受应名师迹。由是诸邪师行所依地故。有说此受应名刀路。或名怨路。由此能为爱刀爱怨所著处故。有说此受应名刀迹。以契经说。意为刀故。耽嗜依者。谓诸染受。出离依者。谓诸善受。无覆无记。顺善染故。随应二摄。更不别说。此三十六界地定者。谓欲界中。具三十六。初二静虑。唯有二十。谓耽嗜依八。出离依十二。三四静虑。唯有十种。谓耽嗜依四。及出离依六。空处近分。若许有别缘。便有五种。谓耽嗜依一。出离依四。若执唯总缘。但有二种。谓耽嗜依一。出离依一。无色根本。及上三边。各唯有二。如前应知。此约界地。所缘定者。欲缘欲境。具三十六。缘色界境。唯二十四。除缘香味二依各六。缘无色境。唯有六种。谓法近行。二依各三。缘不系境。亦唯此六。由此道理。色无色界。缘境差别。如应当思。如契经说。以六出离依喜近行。为仗为依。为建立故。于六耽嗜。依喜近行。能舍能弃。及能变吐。如是便断。乃至广说。此中所说。断十八种。耽嗜依言。显暂时断。喜为依故。断出离依。忧近行言。显离欲染。舍为依故。断出离依。喜近行言。显离第二静虑地染。一种性依舍为依故。断种种性。所依舍言。显离色染。非彼性类为依故断一种性依舍言。显究竟离无色界染。如是所说。受有支中。应知义门无量差别。何缘不说所余有支。颂曰

  余已说当说

论曰。所余有支。或有已说。或有当说。如前已辩。若尔何缘更兴此颂。为于后颂遮广释疑。由后颂中说烦恼等。勿有于此生如是疑。前已广明四支义讫。次应广释其余有支。为显后文依惑业事。寄喻总显十二有支。故轨范师。更兴此颂。如前已说。十二有支。略摄唯三。谓惑业事。此三用别。其喻云何。颂曰

  此中说烦恼　　如种复如龙
  如草根树茎　　及如糠裹米
  业如有糠米　　如草药如花
  诸异熟果事　　如成熟饮食

论曰。如何此三种等相似。如从种子芽叶等生。如是从烦恼生烦恼业事。如龙镇池水恒不竭。如是烦恼得相续镇生池。令惑业事流注无尽。如草根未拔。苗剪剪还生。如是烦恼根。未以圣道拔。令生苗稼断断还起。如从树茎频生枝花果。如是从惑数起惑业事。如糠裹米能生芽等。非独能生烦恼。裹业能感后有。非独能感。如米有糠能生芽等。业有烦恼。能招异熟如诸草药果熟为后边。业果熟已。更不招异熟。如花于果为生近因。业为近因。能生异熟。如熟饮食。但应受用。不可转生成余饮食。异熟果事。既成熟已。不能更招余生异熟。若诸异熟。复感余生。余复感余。应无解脱

说一切有部顺正理论卷第二十九阿毗达磨顺正理论卷第三十

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩缘起品第三之十

已辩缘起。即于此中。就位差别。分成四有。中生本死。如前已释。善等差别。三界有无。今当略辩。颂曰

  于四种有中　　生有唯染污
  由自地烦恼　　余三无色三

论曰。于四有中。生有唯染。决定非善。无覆无记。由何等惑。一切烦恼。诸烦恼染诸生有耶。不尔云何。但由自地。谓生此地。唯由此地中。一切烦恼。生有成染污。诸烦恼中。无一烦恼于结生位。无润功能。然诸结生。唯烦恼力。非由缠垢。所以者何。以自力行悔覆缠等。要由思择。方现起故。然此位中。身心昧劣。要任运惑。方可现行。唯有随眠。数习力胜。故诸烦恼。能数现行。于结生时。任运现起。诸缠及垢。数习力劣。非不思择。而得现前。是故结生。非诸缠垢。有余师说。我慢我爱。诸有情类。数数现行。结生位中。随一现起行相微细不舍相续。故染生有。唯此二能。此二非无。然非唯此。圣结生有。此不行故。亦有现起。无有爱故。此慢及爱。我见所资。或有希求。我断灭者。故非此二。皆数现行。由此极成。但由自地诸烦恼力。染污生有。余中有等。一一通三。谓彼皆通善染无记。应知中有。初续刹那。亦必染污。犹如生有。如是四有。何界所系。欲色具四。无色唯三。非无色业感中有果。辩中有中。已具思择有情于此。四种有中。由何而住。颂曰

  有情由食住　　段欲体唯三
  非色不能益　　自根解脱故
  触思识三食　　有漏通三界
  意成及求生　　食香中有起
  前二益此世　　所依及能依
  后二于当有　　引及起如次

论曰。经说世尊自悟一法。正觉正说。谓诸有情。一切无非由食而住。何等为食。食有四种一段。二触。三思。四识。段有二种。谓细及粗。细谓中有食。香为食故。及天劫初食。无变秽故。如油沃砂。散入支故。或细污虫婴儿等食。说名为细。翻此为粗。如是段食。唯在欲界。离段食贪。生上界故。非上界身。依外缘住。色界虽有能益大种。而非段食。如非妙欲。如色界中。虽有微妙色声触境。而不引生增上贪故。不名妙欲。如是虽有最胜微妙能摄益触。而毕竟无分段吞啖。故非段食。虽非段食摄。而非无食义。如喜虽非四食中摄。而经说为食。以有食义故。如契经言。我食喜食。由喜食久住。如极光净天。若尔欲界。亦应唯口分段吞啖。方名段食。不尔欲界吞啖为门。余可相从立此名故。非于色界少有吞啖。可令余触从彼为名。是故二界。无相类失。若人生在北俱卢洲。离段吞啖。寿岂断坏。虽不断坏。而所依身。形色瘦损。若为存活。若尔如何彼由食住。香等为食。非要吞啖。彼定常嗅如意妙香。或触可爱风等妙触。又彼身中。有能益暖。或非欲界皆资段食。亦非段食。定唯欲界从多就胜。故作是言。下有上无。不应为难。然段食体。事别十三。以处总收。唯有三种。谓唯欲界香味触三。一切皆为段食自体。可成段别而吞啖故。谓以口鼻分分受之。以少从多。故作是说。虽非吞啖。但能益身。令得久住。亦细食摄。犹如影光炎凉涂洗。又劫初位。地味等食。亦名段食。分段受故。又诸饮等。亦名段食。皆可段别而受用故。有余师说。一切食中。此最为胜。以于摄益根大种中。强而速故。岂不求食为除饥渴。如何饥渴亦名为食。由此二种。亦于根大能增益故。如按摩等。又于饮食。无希欲心。身便瘦损。故二名食。又有饥渴。方名无病。故为食事。此二胜余色处。应言是段食。不应言是段段别啖故。若尔何故言三处为体。以约食说故。但言三色处何缘不名为食。是不至取根所行故。以契经说。段食非在手中器中。可成食事。要入鼻口。牙齿咀嚼。津液浸润。进度喉咙。堕生藏中。渐渐消化。味势熟德。流诸脉中。摄益诸虫乃名为食。尔时方得成食事故。若在手器以当为名。如天授名那落迦等。虽彼分段总得食名。而成食时。唯香味触。尔时唯此为根境故。若总分段。皆名食者。声不相应。亦应是食。非声等物在彼段中。可如香等亦名为食。以不相续。无形段故。非无形段。不相续物。能住持身。可成食事。又如何知色处非食。身内摄益根大功能。如香味触。不别见故。尔时不生彼境识故。且香与味。为食极成。不待成立。见涂洗等。于身摄益。触有功能。夫食必依味势熟德。于身损益。思择是非。形显俱非味势熟德。于身损益。无有功能。生自识时。尚不损益自根大种。况入身已。不生自识。能为食事。见日月轮等。能损益眼根。是触功能。非形显力。岂不苦乐与识俱生。此二能为损益事故。色处于眼亦为损益。理不应然。眼与明等。应成食故。然彼为境。顺苦乐触。能为食事。色处不然。见安缮那筹等诸色。眼不增损。要至眼中。眼方增损。是故段食定非色处。又与极成香等段食。有共不共差别相故。又诸段食。要进口中。咀嚼令碎。坏其形显。香味触增。方成食事。非未咀嚼香味触增。分明可了。如已咀嚼。故唯香味触。是真实食体。唯为此三设功劳故。若尔何故。于契经中。称赞段食。具色香味。为令欣乐。兼赞助缘。如亦赞言。恭敬施与。岂即恭敬。亦名段食。然成段食。具正助缘。如有赞华林具华果影水。岂影与水亦即是林。或此经中。赞所舍受。不言食体。是色香味。又先已说。先说者何。谓以当为名。尔时实非食。赞假名食具色香味。非辩真食。有何相违。又叹食德。非辩食体医论所言。有可爱饮食。具色香味触。亦得非体。又举色相。表香味触。亦妙可欣。故作是说。经何不赞食具触邪。赞具色等已说触故。非有恶触具妙色等。故有妙触。不说自成。又唯触处。是真食体。赞此食体有色香味。故经说食体无缺减。然上座言。所饮啖聚。皆是食体。无别说故诸所饮啖。聚消变时。一切皆能增血肉等。任持相续。令不断坏。是故一切。皆名为食。彼言非理。所以者何。虽无别说。应别取故。如契经说。业为生因岂此生因。通无漏业。岂余非业。并非生因。又如经言。非黑非白。无异熟业。能尽诸业。岂如是相业。皆能尽诸业。岂一切业皆是所尽。又如经言。识生住起。应知即是苦生病住老死起义。非无漏识可说此言。如是等经。其例非一。虽无别说。而应别取聚中。若有食相食用。唯应取彼为食非余故。此因不能证色亦是食。又彼所说。诸所饮啖聚消变时。一切皆能增血肉等。任持相续。令不断坏。定知如是。应设诚言。既不说因。宁知形显。于消变位。如香味触。增血肉等。能任持身。是故食体。唯香味触。非色不能益自根解脱故。夫名食者。必先资益自根大种。后乃及余。饮啖色时。于自根大。尚不为益。况能及余。由彼诸根境各别故。有时见色。生喜乐者。缘色触生。是食非色。如斯理趣。前已具辩。又不还者。及阿罗汉。解脱食贪。虽见妙食。而不生喜。无所益故。已说段食界系及体。触思识三。次当显示。触谓根境识三和所生心所。缘起中。已广思择。思谓意业。识谓了境。此三唯有漏。通三界皆有。如是四食。体总有十六事。唯后三食。说有漏言。显香等三。不滥无漏。何缘无漏触等非食。食谓能牵能资诸有。可厌可断。爱生长处。无漏虽资他所牵有。而自无有牵有功能。非可厌断爱生长处。故不建立。在四食中。即由此因。望他界地。虽有漏法。亦非食体。他界地法。虽亦为因。能资现有。而不能作牵后有因。故不名食。诸无漏法。现在前时。虽能为因。资根大种。而不能作牵后有因。虽暂为因资根大种。而但为欲成已胜依。速趣涅槃。永灭诸有。自地有漏。现在前时。资现令增能招后有。由此已释。段食为因。招后有义。谓触等食。牵后有时。亦牵当来。内法香等。现内香等。资触等因。令牵当有。亦能自取当来香等。为等流果。是故段食。与后有因。同一果故。亦能牵有。故名为食。然香味触。体类有三。谓异熟生。等流长养。由外香等。觉发身中内香味触。令成食事。故所说食。其理定成。云何应知。触思识食。俱时而起。事用有殊。若谓此三事用无别。三食差别应不得成。如一抟中具香味触。用别难知。故立一段食名。触等用别。不应同彼。共不共知。有差别故。如香味触。世共同知。是一食性。触等不尔。又触思识。体用微细。故别分三。香等不尔。又虽俱起。随一增故。果现行时。非无差别。是故三体差别极成。如契经说。食有四种。能令部多有情安住。及能资益诸求生者。言部多者。显已生义。诸趣生已。皆谓已生。复说求生。为何所目。此目中有。由佛世尊以五种名说中有故。何等为五。一者意成。从意生故。是牵引业。所引果义。若尔此应有太过失。不尔。中有不揽外缘精血等物以成身故。二者求生。多喜寻察当生处故。生谓生有。中有多求趣生有处。三者食香身资香食。往生处故。四者中有。死生二有中间有故。五者名起。死有无间。支体无缺。身顿起故。或复对向当生决定。暂时起故。如契经说。有坏自体。起有坏世间生起谓中有。又经说有补特伽罗。已断起结。未断生结。何缘说食唯有四种。一切有为。皆有食用。经说涅槃。亦有食故。如契经说。涅槃有食。所谓觉支。虽诸有为。皆有食用。而就胜说。谓大仙尊。为所化者。就资有胜。唯说四食。如契经说。二因二缘。能生正见。非净戒等。于正见生。无因缘用。四食胜用。其相云何。谓初二食。能益此身。所依能依。后之二食。能引当有。能起当有。如次资益引起色名二种有身。故立四食所依。谓色即有根身。能依谓名。即心心所。此中段食。资益所依。以有根身由此住故。此中触食资益能依。以心心所由此活故。如是二食。于已生有。资益功能。最为殊胜。思为引业。识为种子。引起当有。谓由业故。能引当来。名色二有。业既引已。爱润识种。能令当有名色身起。故契经说。业为生因。爱为起因。如是二食。于未生有。引起功能。最为殊胜。故唯说此四种为食。此四食中。后二如生母。生未生故。前二如养母。养已生故。次第异者。举现见生因果差别。为显名色二有无始。故说前际不可了知。谓如此生已起名色。为依引起。感余生业。爱所润识。能为种故。令当来世名色果起。如是此生所有名色。以次前世名色为依。所引诸业。爱润识种。为因故起。即彼前生所依名色。复以前世名色为依。所引诸业。爱润识种。为因故起。如是展转。前前为依。是故名色二有无始。或诸众生。有三种别。一偏爱乐。现可爱境。二多希求。当可爱境。三于诸境。起处中舍。段食总益此三众生。触食别益爱现境者。思食别益希当境者。识食别益处中舍者。故唯说此四种为食。有说。受为生死根本。段食是受所受境界。触食是受所领近因。思是远因。识是所依。故唯说此四种为食。或复段食。能长境贪。长养诸根及大种故。如是境贪。能广于触和合三事。令生触故。触能引受。是所领故。受复能作希望思因。为受希望境及生故。希望思力。令爱增广。由思欣乐虚妄乐故。爱能润识。令续生有。要染污心。能结生故。识能生起名色有芽。名色由识而生长故。由斯故说。若于段食。断遍知时。亦断遍知五妙欲染。若于触食断遍知时。亦断遍知乐等三受。若于思食断遍知时。亦断遍知欲等三爱。若于识食断遍知时。亦断遍知名色二有。有说。观此能治四倒。故说四食。由不观察段等四种。如次能起净乐常我四种颠倒。经说四食。能令部多有情安住及能资益。诸求生者。此示四食能资居止三有众生。谓居生有本有中有。如其次第。除居死有。居死有中。食无能故。言部多者。谓居生有。食持生有。故说令安。意显生有。唯一念故。要由食持。方能牵后。言有情者。谓居本有。居本有中。可共言说。异非情故。名为有情。食持本有故说令住。住谓当位相续不断。言求生者。谓居中有。居中有中。求生有故。食持中有。令趣当生。不可回转。故名资益。或复众生略有三种。一具烦恼。二离烦恼。三余烦恼。具烦恼者。名为部多。于五趣中。数数生故。食能持彼。故说令安。正观既阙。无求出心。于生死中。情安止故。如阙眼者。无行动心。随其所居。而安止故。离烦恼者。名为有情。唯世俗说有情数故。食能持彼。故说令住。如众缘力持故坏车。暂往余方。故名为住。余烦恼者。名为求生。容有希求。当来合故。和合生有。其义无别。余烦恼者。容有希求。乃至行尽生有身故。食能持彼。故言资益。谓资益彼。至行尽位。或有情类。略有二种。所谓已生将生差别。诸已生者。名部多有情。诸将生者。唯说为求生。诸已生者。复有二种。一者受用先行业果。名为部多。二者受用现士用果。名为有情。由先世食。令现身中色力乐辩。寿得安立。由现世食。唯令现身。相续无断。故说名住。或令安者。唯令不坏。言令住者。令成士用。持将生者。令趣正生。故言资益。诸求生者。有说。部多求生各别。为简别故。说有情言。以说非情亦有食故。如契经说。我说大海。及大河等。悉皆有食。为简彼故。显此所明是有情食。非大海等。若尔此言。应成无用。说段食等。简义已成。非段等食资海等故。唯有情类。有段等食。故有情言。无简别用。乍可为简别。说部多言。以部多言中兼显实义。为欲遮遣。非实有情。执为有情。故作是说。谓诸外道。无明所盲。执诸丛林皆有思虑。有见等故。亦名有情。此亦必应资段食等。为简彼故。须说实言。如是实言。显极成义。共许有思虑。谓极成有情。此极成有情。方资段等食。非不共许。思虑有情。何故世尊。不唯略说食有四种。令有情安。部多求生二言何用。岂不已说。为显已生中有等异。故作是说。但说由食令有情安。于义已周。何劳复说。已生中有差别等义。余契经中。已作是说。有情无不由食而存。此中为遮谤中有论。及为显示生有近因。故说部多求生差别。或复勿有谓阿罗汉有学异生。食无差别。故说三句。显食有殊。谓诸异生。受诸饮食。多由烦恼。诸阿罗汉。受诸饮食。但为支身。诸有学者。受诸饮食。虽多生厌。而有烦恼。为显诸食。虽并支身有唯应受用。有亦须断者。故须具显如是三句。言于段食断遍知者。前虽说断未了。是何后说遍知。显是此断。或伏缘彼。烦恼名断。永拔其根。故名遍知。若尔不应作如是说。若于段食。断遍知时。亦断遍知五妙欲染。五妙欲染得永断时。段食由斯可名为断。虽有此理。而佛为彰俱时断故。作如是说。以于段食缘缚断时。五妙欲贪。其体名断。虽有此理。而不应说段食断时五欲贪断。色声二种。非段食故。此责不然。色声二种。与段食体同对治故。诸修观者。厌段食故。遍舍欲界。故作是说。或此中说。五妙欲染。非唯色等五境界贪。若尔是何非贤圣事。说名为欲。不离此界。诸所起贪。说名欲染。色等五境。能顺增贪。名五妙欲。此五妙欲所属之界。亦得此名。此界中贪。依此缘此五妙欲界。故名五妙欲染。此意说言。若段食断。欲界诸贪皆悉得断。以此与彼同对治故。非贪断时段食必断。段食断时诸贪必断。是故契经。作如是说。有释为显段食断言。唯据断除修所断染。故说断五妙欲染言。如是释言。无深理趣。此中唯说圣道离染。已显唯断修所断故。必无圣道于一时中。双断见修二所断义。谓圣道断见所断时缘段食贪。决定未断。于后正断段食贪时。见所断贪。必先已断。故虽不说断五妙欲染言。而亦知唯据断修所断染。又此简别。复何所成。纵谓所言段食断者。亦显已断见所断贪。若如是知。有何过失。如说。触等断遍知时。亦断遍知乐等余法。是故前释。于理无违。岂不随断触等一时受爱名色悉皆得断。何缘如次各别说耶。以有众生受爱后有。随于一种深觉过患。为欲令彼速得断除。如次为说触等因异。又为成触等虽同时生。而由果不同故三体别。又为显食名称于义。谓所能引故名为食。食谁所引。谓爱所引。经说四食。爱为缘故。食能引谁受爱名色。为显此义。故作是言。即显因无果定非有。触复如何。说名为食。以触能有摄益用故。受是摄益。体非能摄益。触能摄益。亦是摄益体。摄益因故。受所领故。非一切思皆是思食。要属希望。顺爱现行。意识相应。乃名为食。故饥馑世。愚痴小儿。望悬砂囊。而得存济。又世现见。由有希望。力便增长。希望若绝。力便衰微。所为退败。然契经说。意思食者。显此唯与意识相应。或为遮思是我德用。经说识食。为第四者。此唯约有段食处说。识能为食。其相云何。了可爱境。能住持身故。若尔云何先作是说。识食能益处中舍者。由彼亦有可爱涅槃。圣道等境。有漏了别。能任持身。故无有过。契经说有四种食食。第二食言。复有何用。为遮食外有能食者。显离诸食无食者故。由此佛告颇勒具那。我终不说有能食者。佛说四食名爱因缘。云何名为爱因缘义。所希爱事。为食体故。何缘于食。生于希爱。因此发生诸乐受故。缘乐受故。诸爱得生。诸爱已生。执为资具。由食是爱。邻近生因。若爱已生。复为资具。是故说食。名爱因缘。岂不食缘亦生于苦。不应但说名爱因缘。如契经言。诸所有苦。一切无不因食而生。理实应然。而愚夫类。颠倒所覆。于苦生因。执为乐因。缘生希爱。或苦所逼。希离爱生。此爱为因。追求饮食。故佛说食。名爱因缘。或复果生能成食事。有漏果苦。说爱为集。是故说食。名爱因缘。若尔无学。应无有食。以无学者爱无有故。或有食者。皆应有爱。此责不然。已简别故。谓已简别部多求生。是有爱者。四食于彼。如其次第。安及资益。据彼说食。名爱因缘。故无无学者无食有爱失。或无学食。先爱力引。名爱因缘。亦无有失。谓先爱力。所引发故。今虽离爱。仍求饮食。故有伽他言。非无食有命。又如经说。无明所覆。爱所系缚。愚夫智者。同得此身。然无阿罗汉有无明爱。失此亦应尔。虽知据此名爱因缘。然说此言。复有何用。为显诸食能牵后有。诸有爱者。段食亦能为爱因缘。牵后有故。以世尊说四食皆为病痈箭根。老死缘故。此食复为先爱引生。先爱复从先食引起。如是展转。无始时来。令生死轮旋环不绝。为生厌舍。故说此言。又诸苦生。皆因于食。但由诸食为爱因缘。为舍食缘令苦不起。如欲止病应避病缘。故说此言。深成有用。广辩食已。今应思择。于前所说中等四有。生死二有。唯一刹那。于此时中。何识现起。此识复与何受相应。定心无心。得死生不。住何性识。得入涅槃。于命终时。识何处灭。断末摩者。其体是何。颂曰

  断善根与续　　离染退死生
  许唯意识中　　死生唯舍受
  非定无心二　　二无记涅槃
  渐死足脐心　　最后意识灭
  下人天不生　　断末摩水等

论曰。断善续善。离界地染。从离染退。命终受生。此六位中。唯许意识。皆是意识不共法故。五识于此。无有功能。岂不最初结中有位亦唯意识。所说生言。已兼摄彼。非离所说。非此生言能摄结中有。以结中有即中有摄故。已遮中有。生所摄故。契经说有补特伽罗。已断生结。未断起结。广说四句。本论亦显中有非生。欲界命终。还生欲界。欲有续者。谓欲界没。还受欲界中有生有。如是等文。极相违害。无相违失。诸经论文。唯据生有。说生言故。中有初念。虽亦名生。而非生有。何相违害。本论亦有以生声说结中有位。有欲界系见修所断。二部诸结。一时获者。谓上界没。欲界生时。此等生言。说中有始。以色无色死有无间。顿获欲界。二部诸结。岂不住彼死有刹那。即获此结且证中有始亦名生。义得成立。然彼死有。当获非正。故颂生言。兼摄中有。意识虽具三受相应。而死生时。唯有舍受。正死名死。正生名生。如正笑时说名为笑。不苦乐受。性不明利。顺死生时。苦乐二受。性极明利。不顺死生。非明利识有死生义。以死生时必昧劣故。由此故说。下三静虑。唯近分心。有死生理。以根本地无舍受故。虽说在意识得有死生。而非在定心有死生理。非界地别有死生故。设界地同极明利故。由胜加行所引发故。又在定心能摄益故。必由损害方有命终。诸在定心。非染污故。必由染污。方得受生。异地染心。亦摄益故。加行起故。无命终理。异地染心。必胜地摄。何容乐往劣地受生。故彼亦无能受生理。一切异地。净无记心。加行起故。无命终理。非染污故。无受生理。又非无心有命终义。理相违故。死有二种。或他所害。或任运终。无心位中。他不能害。有殊胜法。任持身故。处无心位。不任运终。入心定能引出心故。谓入心作等无间缘。取依此身心等果法。必无有别法能碍令不生。若所依身。将欲变坏。必定还起属此身心。方得命终。更无余理。又有契经。证无心不命终。故契经说。无想有情。由想起已。从彼处没。非无心位可得受生。必由胜心现所引故。住昧劣位。而受生故。离起烦恼。无受生故。亦有契经。证无心不受生。故契经言。识若不入母胎中者。名色得成羯剌蓝不。乃至广说。虽死有心实通三性。而阿罗汉。必无染心。虽有善心及二无记。而强盛故。不入涅槃。入涅槃心。唯二无记。谓威仪路。或异熟生。若说欲界。有舍异熟。入涅槃心。通二无记。若说欲界。无舍异熟。入涅槃心。但威仪路。必无离受。而独有心。辩业品中。当广思择。劣善何故不入涅槃。以彼善心有异熟故。诸阿罗汉。厌背未来诸异熟果。入涅槃故。若尔住异熟。应不入涅槃。不尔。已简言厌背未来故。何不厌背现在异熟。知依现异熟永断诸有故。依现异熟。证无学果。知彼有恩。不说厌患。诸阿罗汉。深厌当生。故命终时。避彼因善。唯二无记。势力劣故。顺于昧劣相续断心。故入涅槃。唯二无记。眼等诸识。依止色根。尚无方所。况复意识。然约身根灭处说者。若顿死者。意识身根。欻然总灭。非有别处。若渐死者。往下人天。于足齐心。如次识灭。谓堕恶趣。说名往下。彼识最后两足处灭。若往人趣。识灭于齐。若往天中。识灭心处。诸阿罗汉。说名不生。彼最后心。亦心处灭。有余师说。彼灭在顶正命终时。于足等处。身根灭故。意识随灭。临命终时。身根渐灭。至足等处。欻尔都灭。如以少水置炎石上。渐减渐消。一处都尽。必无同分相续为因。能无间生所趣后有。唯渐命终者。临命终时。有为断末摩。苦受所逼。无有别物。名为末摩。然于身中。有异支节。触便致死。是谓末摩。谓于身中。有别处所。风热痰盛。所逼切时。极苦受生。即便致死。得末摩称。如有颂曰

  身中有别处　　触便令命终
  如青莲花须　　微尘等所触

若水火风。不平缘合。互相乖反。或总或别。势用增盛。伤害末摩。如以利刀分解支节。因斯引发极苦受生。从此须臾。定当舍命。由兹理故。名断末摩。非如斩薪说名为断。如断无觉。故得断名。好发语言。讥刺于彼。随实不实。伤切人心。由此当招断末摩苦。何缘不说地断末摩。以无第四内灾患故。内三灾患。谓风热痰。水火风增。随所应起。有说。此似外器三灾。此断末摩。天中非有。然诸天子。将命终时。先有五种小衰相现。一者衣服严具。绝可意声。二者自身光明。欻然昧劣三者于沐浴位。水滴着身。四者本性嚣驰。今滞一境。五者眼本凝。寂今数瞬动。此五相现。非定命终。遇胜善缘。犹可转故。复有五种大衰相现。一者衣染埃尘。二者花鬘萎悴。三者两腋汗出。四者臭气入身。五者不乐本座。此五相现。决定命终。设遇强缘。亦不转故。非此五相诸天皆有。亦非此五一一皆具。总集而说。故言有五。如何得知非一切有。由教理故。教谓经言。三十三天。有时集坐善法堂上。共受法乐。中有天子。福寿俱终。即天众中。不起于坐。俄然殒没。都不觉知。经说诸天五衰相现。经五昼夜。然后命终。宁不觉知。不起于坐。理谓衰相。皆是不善圆满业果。非一切天皆同集此不善业故。世尊于此有情世间生住没中。建立三聚。何谓三聚。颂曰

  正邪不定聚　　圣造无间余

论曰。一正性定聚。二邪性定聚。三不定性聚。何名正性。谓世尊言。贪无余断。嗔无余断。痴无余断。一切烦恼。皆无余断。是名正性。何故唯断。说名正性。谓此永尽邪伪法故。又体是善常智者定爱故。世尊亦说圣道名正性。经说趣入正性离生故。何名邪性。谓有三种。一趣邪性。二业邪性。三见邪性。即是恶趣。五无间业。五不正见。如次为体于二定者。学无学法。五无间业。如其次第。定趣离系地狱果故。成就此者。得此聚名。即名为圣。造无间者。正脱已脱烦恼缚故。说名为圣。圣是自在离系缚义。或远众恶。故名为圣。获得毕竟离系得故。或善所趣。故名为圣。中无间隔。故名无间。好为此因。故名为造。正邪定余。名不定性。彼待二缘。可成二故。非定属一。得不定名

说一切有部顺正理论卷第三十阿毗达磨顺正理论卷第三十一

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩缘起品第三之十一

如是已辩有情世间。器世间今当辩。颂曰

  安立器世间　　风轮最居下
  其量广无数　　厚十六洛叉
  次上水轮深　　十一亿二万
  下八洛叉水　　余凝结成金
  此水金轮广　　径十二洛叉
  三千四百半　　周围此三倍

论曰。此百俱胝四大洲界。如是安立。同坏同成。谓诸有情。法尔修得诸静虑故。下命终已。生第二等静虑地中。下器世间。三灾所坏。经久远已。依下空中。由诸有情业增上力。有微风起。后后转增。蟠结成轮。其体坚密。假设有一大诺健那。以金刚轮。奋威悬击。金刚有碎。风轮无损。如是风轮。广无数厚十六亿踰缮那。又诸有情业增上力。起大云雨。澍风轮上。滴如车轴。积水成轮。如是水轮。于未凝结位。深十一亿二万踰缮那。广称风轮。有言狭小。有情业力。持令不散。如所食饮未熟变时终不移流堕于熟藏。有余师说。由风所持。令不傍流。如篅持谷。有情业力。引别风起。抟击此水。上结成金。如熟乳停上凝成膜。故水轮减。唯厚八洛叉。余转成金。厚三亿二万。二轮界别。有百俱胝。一一二轮广量皆等。谓径十二亿三千四百半。周围其边。数成三倍。谓周围量。成三十六亿一万三百五十踰缮那。已辩三轮。山今当辩。颂曰

  苏迷卢处中　　次踰健达罗
  伊沙驮罗山　　朅地洛迦山
  苏达梨舍那　　頞湿缚羯拏
  毗那恒迦山　　尼民达罗山
  于大洲等外　　有铁轮围山
  前七金所成　　苏迷卢四宝
  入水皆八万　　妙高出亦然
  余八半半下　　广皆等高量

论曰。于金轮上。有九大山。妙高山王。处中而住。余八周匝。绕妙高山。于八山中。前七名内。第七山外有大洲等。此外复有铁轮围山。周匝如轮。围四洲界。持双等七。唯金所成。妙高山王。四宝为体。谓四面如次。北东南西。金银吠琉璃颇胝迦宝。随宝威德。色显于空。故赡部洲空。似吠琉璃色。如是宝等。从何而生。从诸有情业增上力。复大云起。雨金轮上。渧如车轴。经于久时。积水奔涛。深踰八万。猛风钻击。宝等变生。如是变生金宝等已。复由业力。引起别风。简别宝等。摄令聚集。成山成洲。分水甘碱。令别成立内海外海。云何一类水。别类宝等生。雨水能为异类宝等种所依藏。复为种种威德猛风之所钻击。生众宝等。故无有过。如是九山。住金轮上。没水量皆等。八万踰缮那。苏迷卢山。出水亦尔。如是则说妙高山王。从下金轮。上至其顶。总有十六万踰缮那。其余八山。出水高量。从内至外。半半渐卑。谓初持双。出水四万。乃至最后。铁轮围山。出水三百一十二半。如是九山。一一广量。各各与自出水量同。已辩九山。海今当辩。颂曰

  山间有八海　　前七名为内
  最初广八万　　四边各三倍
  余六半半狭　　第八名为外
  三洛叉二万　　二千踰缮那

论曰。妙高为初。轮围为后。中间八海。前七名内。七中皆具八功德水。一甘。二冷。三软。四轻。五清净。六不臭。七饮时不损喉。八饮已不伤腹。如是七海。初广八万。约持双山内边周量。于其四面。数各三倍。谓各成二亿四万踰缮那其余六海。量半半狭。谓第二海。量广四万。乃至第七。量广一千二百五十。此等不说周围量者。以烦多故。准前知故。第八名外。碱水盈满。量广三亿二万二千。理实应言。其量复有一千二百八十七半。已辩八海。当辩诸洲形量有异。颂曰

  于中大洲相　　南赡部如车
  三边各二千　　南边有三半
  东毗提诃洲　　其相如半月
  三边如赡部　　东边三百半
  西瞿陀尼洲　　其相圆无缺
  径二千五百　　周围此三倍
  北俱卢畟方　　面各二千等
  中洲复有八　　四洲边各二

论曰。于外海中。大洲有四。谓于四面。对妙高山。南赡部洲。北广南狭。三边量等。其相如车。南边唯广三踰缮那半。三边各有二千踰缮那。唯此洲中。有金刚座。上穷地际。下据金轮。诸最后身菩提萨埵。将登无上正等菩提。皆坐此座上。起金刚喻定。以无余依及余处所有坚固力。能持此故。东胜身洲。东狭西广。三边量等。形如半月。东三百五十三。边各二千。此东洲东边广南洲南际故。东如半月。南赡部如车。西牛货洲。圆如满月。径二千五百。周围七千半。北俱卢洲。形如方座。四边量等。面各二千。既说畟方面各二千以其义已显。故等言无用。或应但说圆及等。言无缺畟方。便为无用。又应说如满月方座。不应但说圆无缺等。随自洲相。人面亦然。复有八中洲。是大洲眷属。谓四大洲侧。各有二中洲。赡部洲边二中洲者。一遮末罗洲。二筏罗遮末罗洲。胜身洲边二中洲者。一提诃洲。二毗提诃洲。牛货洲边二中洲者。一舍搋洲。二嗢怛罗漫怛里拏洲。俱卢洲边二中洲者。一矩拉婆洲。二憍拉婆洲。此一切洲皆人所住。由下劣业增上所生。故住彼人。身形卑陋。有余师说。遮末罗洲。逻刹婆居。余皆人住。辩诸洲已。无热恼池。何方几量。颂曰

  此北九黑山　　雪香醉山内
  无热池纵广　　五十踰缮那

论曰。依至教说。此赡部洲。从中印度渐次向北。三处各有三重黑山。有大雪山。在黑山北。大雪山北。有香醉山。雪北香南。有大池水。名无热恼。出四大河。从四面流。趣四大海。一殑伽河。二信度河。三私多河。四缚刍河无热恼池。纵广正等。面各五十踰缮那量。八功德水。盈满其中。非得通人。难至其所。于此池侧。有赡部林。树形高大。其果甘美。依此林故。名赡部洲。或依此果。以立洲号。复于何处。置奈落伽。何量有几。颂曰

  此下过二万　　无间深广同
  上七奈落迦　　八增皆十六
  谓煻煨尸粪　　锋刃烈河增
  各住彼四方　　余八寒地狱

论曰。此赡部洲下过二万。有阿鼻旨大奈落迦。深广同前。谓各二万。故彼底去此。四万踰缮那。何缘唯此洲下。有无间狱。唯于此洲。起极重恶业故。刀兵等灾。唯此有故。唯此洲人。极利根故。以无乐间。立无间名。所余地狱中。虽无异熟乐。而无太过失。有等流乐故。有说。无隙。立无间名。虽有情少。而身大故。有情其中受苦无间。谓彼各为百钉钉身。于六触门。恒受剧苦。居热铁地。铁墙所围。猛焰交通。曾无暂歇。身遭热逼。苦痛难任。虽有四门远观开辟。而走求出。便见关闭。所求不遂。荼毒怨伤。以己身薪投赴猛火。焚烧支体。骨肉焦然。恶业所持。而不至死。余七地狱。在无间上。重累而住。其七者何。一者极热。二者焰热。三者大叫。四者号叫。五者众合。六者黑绳。七者等活。有说。此七在无间傍。八地狱因差别无量。世尊虽有委说。胜能宜闻者无。彼不委说。少有所说。具如经等。如伽他言

  多百踰缮那　　周遍焰交彻
  闻举身毛竖　　生极大怖畏

如是等颂。其类寔多。皆为显成地狱因果。若外若内。自身他身。皆出猛火。互相烧害。热中极故。名为极热。火随身转。炎炽周围。热苦难任。故名炎热。剧苦所逼。发大酷声。悲叫称怨。故名大叫。众苦所逼。异类悲号。怨发叫声。故名号叫。众多苦具。俱来逼身。合党相残。故名众合。先以黑索。拼量支体。后方斩锯。故名黑绳。众苦逼身。数闷如死。寻稣如本。故名等活。谓彼有情。虽遭种种斫刺磨捣。而彼暂遇凉风所吹。寻稣如本。等前活故。立等活名。八奈落迦增各十六。谓四门外各有四增。以非皆异名。但标其定数。故薄伽梵。说此颂言

  此八奈落迦　　我说甚难越
  以热铁为地　　周匝有铁墙
  四面有四门　　关闭以铁扇
  巧安布分量　　各有十六增
  多百踰缮那　　满中造恶者
  周遍焰交彻　　猛火恒洞然

此十六中。受苦增剧。过本地狱。故说为增。或于此中受种种苦。苦具多类。故说为增。或地狱中。适受苦已。重遭此苦。故说为增。有说。有情出地狱已。数复遭苦。故说为增。门各四增名差别者。煻煨。尸粪。锋刃。列河。门门四增。名皆相似。彼有情类。从大门中排极艰辛。冲门走出。求离求救。求安所居。忽复坠初煻煨增内。谓此增内。煻煨没膝。其量宽广。多踰缮那。有情游中。才下其足。皮肉与血俱焦烂坠。举足还生。平复如本。经极艰阻。从煻煨出。复堕第二尸粪增中。谓此增中。尸粪泥满。查濑臭涩。深没于人。又广于前煻煨增量。于中多有娘矩吒虫。嘴利如针。身白头黑。有情游彼。皆为此虫。赞皮破骨。唼食其髓。遭苦既久。从尸粪出。复涉第三锋刃增内。谓此增内。复有三种。初刀刃路。谓于此中。仰布刀刃。以为大道。有情游践。才下足时。皮肉与血俱断碎坠。举足还生。平复如本。次剑叶林。谓此林上纯以铦利剑刃为叶。有情游下。风吹叶坠。斩刺支体。骨肉零落。有乌驳狗。[打-丁+僕]令僵仆。啮首咬足。[齒*可]颈擘胛。攫腹掏心。摣掣食啖。后铁刺林。谓此林内。铁树高耸。量过百人。有利铁刺。长十六指。有情被逼。上下树时。其刺铦锋下上镵刺。有铁嘴鸟。探啄有情眼睛心肝。争竞而食。刀刃路等三种虽殊。而铁仗同。故一增摄。久经苦毒。越此增已。复溺第四烈河增中。谓此增河。其量深广。热碱烈水。盈满其中。有情溺中。或浮或没。或逆或顺。或横或转。彼蒸被煮。骨肉糜烂。如大镬中满盛灰汁置麻米等猛火下然麻等于中上下回转举体糜烂。有情亦然。设欲逃亡。于两岸上。有诸狱卒。手执刀枪。御捍令回。无由得出。复有狱卒。张大铁网。漉诸有情。置于岸上洋铜灌其口令。吞热铁丸。众苦备经。还掷河内。此河如堑。前三似园。围绕庄严诸大地狱。已说有八热奈落迦。寒奈落迦。亦有八种。何等为八。一頞部陀。二尼剌部陀。三頞哳吒。四臛臛婆。五虎虎婆。六嗢钵罗。七钵特摩。八摩诃钵特摩。此中有情。严寒所逼。随身声疮变。立差别想名。谓二三三。如其次第。此寒地狱。在绕四洲轮围山外极冥闇所。于中恒有凄劲冷风。上下冲击。纵横旋拥。有情由此。屯聚相依。寒酷切身。肤皮疱裂。体战僵硬。各出异声。疮开剖坼。如三华相。多由谤贤圣。招如。是苦果有说。此在热地狱傍。以赡部洲上尖下阔。形如谷聚。故得苞容。是故大海渐深渐狭。十六大狱。皆诸有情。增上业感。余孤地狱。或多二一。各别业招。或近江河。山间旷野。或在地下空中余处。无间大热及炎热三。于中皆无狱卒防守。大叫号叫及众合三。少有狱卒。琰魔王使。时时往来。巡检彼故。其余皆为狱卒防守。有情无情。异类狱卒。防守治罚。罪有情故。火不焚烧。有情卒者。彼身别禀异大种故。或由业力所遮隔故。一切地狱身形皆竖。初同圣语。曾闻有以圣语告言。汝在人中。不观欲过。又不承敬梵志沙门。是故于今。受斯剧苦。彼闻领解。生惭悔心。后不分明。苦所逼故。诸地狱器。安布如是。傍生所止。谓水陆空。生类显形。无边差别。其身行相。少竖多傍。如水逻刹娑及紧奈落等。虽傍生摄。而形竖行。本住海中。后流五趣。初同圣语。后渐乖讹。诸鬼本住。琰魔王国。从此展转。散趣余方。此赡部洲。南边直下。深过五百踰缮那量。有琰魔王都。纵广量亦尔。鬼有三种。谓无少多财。无财复三。谓炬针臭口。炬口鬼者。此鬼口中。常吐猛焰。炽然无绝。身如被燎多罗树形。此受极悭所招苦果。针口鬼者。此鬼腹大量如山谷。口如针孔。虽见种种上妙饮食。不能受用。饥渴难忍。臭口鬼者。此鬼口中。恒出极恶腐烂臭气。过于粪秽沸溢厕门。恶气自熏。恒空欧逆。设遇饮食。亦不能受。饥渴所恼。狂叫乱奔。少财亦有三。谓针臭毛瘿。针毛鬼者。此鬼身毛。坚刚铦利。不可附近。内钻自体。外射他身。如鹿箭中毒。晞狂走。时逢不净。少济饥渴。臭毛鬼者。此鬼身毛。臭甚常秽。熏烂肌骨。蒸坌肠胃。冲喉变欧。荼毒难忍。攫体拔毛。伤裂皮肤。转加剧苦。时逢不净。少济饥渴。言瘿鬼者。谓此鬼咽。恶业力故。生于大瘿。如大痈肿。热晞酸疼。更相[利-禾+皮][(ㄇ@人)/齊]。臭脓涌出。争共取食。少得充饥。多财亦有三。谓希词希弃大势。希祠鬼者。此鬼恒时。往祠祀中。飨受他祭。生处法尔。能历异方。如鸟陵虚。往还无碍。由先胜解。作是希望。我若命终。诸子孙等。必当祠我。资具饮食。由胜解力。生此鬼中。乘宿善因。感此祠祭。或有先世性爱亲知。为欲皆令丰足资具。如不如法。积集珍财。悭吝居心。不能布施。乘斯恶业。生此鬼中。住本舍边便秽等处。亲知追念。为请沙门梵志孤穷。供施崇福。彼鬼见已于自亲知及财物中。生己有想。又自明见悭果现前。于所施田。心生净信。相续生长。舍相应思。由此便成顺现法受。乘斯故得资具丰饶。希弃鬼者。此鬼恒欲收他所弃吐残粪等。用充所食。亦得丰饶。谓彼宿生。悭过失故。有饮食处见秽。或空乐秽见。空乐净见秽。亦由现福。如其所应。各得丰饶。饮食资具。生处法尔。所受不同。不可推征。祠到所以。如地狱趣。异熟生色。断已还续。余趣则无。于人趣中。有胜念智。修梵行等。余趣中无。天中随欲。众具皆现。如斯等事。生处法然。不可于中求其定量。大势鬼者。谓诸药叉。及逻刹娑。恭畔荼等。所受富乐。与诸天同。或依树林。或住灵庙。或居山谷。或处空宫。然诸鬼中。无威德者。唯三洲有。除北俱卢。若有威德。天上亦有。赡部洲西。有五百渚。于中有二。唯鬼所居。渚各有城二百五十。有威德鬼。住一渚城。一渚城居无威德鬼。曾闻昔有大转轮王。名曰尼弥。将欲巡境。先告御者摩怛黎言。宜引我车。从是道去。使吾现见罪福果殊。时摩怛黎。如王所敕。引车至彼二渚中间。处上空中。令王俯见有威德鬼。处妙宫台。富乐庄严。陵下天众。无威德鬼。处秽城村。老瘦饥穷。露形被发。手执瓦器。乞丐支身。王睹如斯弥鉴因果。诸鬼多分形竖而行。于劫初时。皆同圣语。后随处别。种种乖讹。日月所居量等义者。颂曰

  日月迷卢半　　五十一五十
  夜半日没中　　日出四洲等
  雨际第二月　　后九夜渐增
  寒第四亦然　　夜减昼翻此
  昼夜增腊缚　　行南北路时
  近日自影覆　　故见月轮缺

论曰。日月众星。依何而住。依风而住。谓诸有情业增上力。共引风起。绕妙高山。空中旋环。运持日等。令不停坠。彼所住去此几踰缮那。持双山顶。齐妙高山半。日等径量几踰缮那。日五十一。月唯五十。星最小者。半俱卢舍。最大者十六踰缮那。日轮下面。颇胝迦宝。火珠所成。能热能照。月轮下面。颇胝迦宝。水珠所成。能冷能照。随有情业增上所生。能于眼身果花稼穑药草等物。如其所应。为益为损。四洲日月。各有别耶。不尔。四洲同一日月。俱时四处作所作耶。不尔。云何。夜半日没。日中日出。四洲时等。俱卢赡部牛货胜身。隔妙高山。相对住故。若俱卢夜半。则赡部日中。胜身日没。牛货日出。若牛货日中。则胜身夜半。赡部日没。俱卢日出。此略义者。随何洲相对。日中月中。余二洲随应西没东出。第三洲处。夜中昼中。由是若时胜身牛货。如其次第。日中月中。尔时光明四洲皆有。然光作事在东南洲。于西北洲唯明作事。俱见两事。在北南洲。谓赡部洲。见日出月没。见月出日没。谓俱卢洲。东胜身洲。唯得见日。唯得见月。谓牛货洲。如是所余例应思择。何缘昼夜有减有增。日行此洲。路有别故。从雨际第二月后半第九日。夜渐增。从寒际第四月后半第九日。夜渐减。昼增减位。与此相违。夜渐增时。昼便渐减。夜渐减位。昼则渐增。昼夜增时。一昼夜增几。增一腊缚。昼夜减亦然。日行此洲。向南向北。如其次第。夜增昼增。何故月轮于黑半末白半初位。见有缺耶。世施设中作如是释。以月宫殿行近日轮。月被日轮光所侵照。余边发影。自覆月轮。令于尔时见不圆满。理必应尔。以于尔时亦见不明全月轮故。由是日没月便出时。相去极遥。见月圆满。有余师说。由日月轮行度不同。现有圆缺。此不应理。应无定故。或应思求余决定理。日等宫殿。何有情居。四大天王所部天众。是诸天众。唯住此耶。若空居天。唯住如是。日等宫殿。若地居天。住妙高山诸层级等。有几层级。其量云何。何等诸天。住何层级。颂曰

  妙高层有四　　相去各十千
  傍出十六千　　八四二千量
  坚手及持鬘　　恒憍大王众
  如次居四级　　亦住余七山

论曰。苏迷卢山。有四层级。始从水际。尽第一层。相去十千踰缮那量。如是乃至。从第三层。尽第四层。亦十千量。此四层级。从妙高山。傍出围绕。尽其下半。最初层级。出十六千。第二第三第四层级。如其次第。八四二千。住初层天。名为坚手。持鬘居第二。恒憍处第三。四大天王及诸眷属。各一方面住第四层。坚手等三天。皆四王众摄。持双山等七金山上。亦有四王所部村邑。是名依地住。四大王众天。于欲天中。此天最广。三十三天。住在何处。颂曰

  妙高顶八万　　三十三天居
  四角有四峰　　金刚手所住
  中宫名善见　　周万踰缮那
  高一半金城　　杂饰地柔软
  中有殊胜殿　　周千踰缮那
  外四苑庄严　　众车粗杂喜
  妙地居四方　　相去各二十
  东北圆生树　　西南善法堂

论曰。三十三天。住迷卢顶。其顶四面。各二十千。若据周围。数成八万。有余师说。面各八十千。与下际四边。其量无别。山顶四角。各有一峰。其高广量。各有五百。有药叉神。名金刚手。于中止住。守护诸天。于山顶中。有宫名善见。面二千半。周万踰缮那。金城量高。一踰缮那半。其地平坦。亦真金所成。俱用百一杂宝严饰。地触柔软。如妒罗绵。于践蹑时。随足高下。是天帝释。所都大城。城有千门。严饰壮丽。门有五百青衣药叉。勇健端严。踰缮那量。各严铠仗。防守城门。于其城中。有殊胜殿。种种妙宝。具足庄严。蔽余天宫。故名殊胜。面二百五十。周千踰缮那。是谓城中诸可爱事。城外四面四苑庄严。是彼诸天。共游戏处。一众车苑。谓此苑中。随天福力。种种车现。二粗恶苑。天欲战时。随其所须。甲仗等现。三杂林苑诸天入中。所玩皆同。俱生胜喜。四喜林苑。极妙欲尘。杂类俱臻。历观无厌。如是四苑。形皆畟方。一一周千踰缮那量。居中各有一如意池。面各五十踰缮那量。八功德水弥满其中。随欲妙华宝舟好鸟。一一奇丽。种种庄严。四苑四边。有四妙地。中间各去苑二十踰缮那。地一一边量皆二百。是诸天众。胜游戏所。诸天于彼。捔胜欢娱。城外东北。有圆生树。是三十三天。受欲乐胜所。盘根深广。五踰缮那。耸[榦-木+禾]上升。枝条傍布。高广量等。百踰缮那。挺叶开花。妙香芬馥。顺风熏满百踰缮那。若逆风时。犹遍五十。若谓经遮故无逆风熏经。就人间香校量无失。谓现见故。引校德香。且对人间香。赞德香为胜。诸天福胜。感此树香。虽天和风力所拥遏。然能相续。流趣余方。非人间香能有是事。业果差别。难可思议。不应以人贬量天福。城外西南角。有大善法堂。三十三天。时集详辨。制伏阿素洛等。如法不如法事。如是已辨三十三天所居外器。余有色天众所住器云何。颂曰

  此上有色天　　住依空宫殿

论曰。从夜摩天。至色究竟。所住宫殿。皆但依空有说。空中密云弥布。如地为彼宫殿所依外器世间。至色究竟。上无色故。不可施设。如是所说诸天众中。颂曰

  六受欲交抱　　执手笑视淫

论曰。梵众天等。由对治力。于诸欲法。皆已远离。唯六欲天。受妙欲境。六欲天者。一四大王众天。谓彼有四大王及所领众。或彼天众事四大王。是四大王之所领故。二三十三天。谓彼天处。是三十三部诸天所居。三夜摩天。谓彼天处。时时多分称快乐哉。四睹史多天。谓彼天处。多于自所受。生喜足心。五乐变化天。谓彼天处。乐数化欲境。于中受乐。六他化自在天。谓彼天处。于他所化欲境。自在受乐。六中初二依地居天。形交成淫。与人无别。然风气泄。热恼便除。非如人间有余不净。夜摩天众。才抱成淫。俱起染心。暂时相抱。热恼便息。唯一起染。虽受抱乐。而不成淫。若俱无染心。虽相执抱。如亲相敬爱。而无过失。睹史多天。但由执手热恼便息。乐变化天。唯相向笑。便除热恼。他化自在。相视成淫。如是后三俱一无染成淫乐爱。差别如前。后二天中。唯化资具。若异此者。俱染不成。实并形交。方成淫事。施设所说。显时不同。由上诸天欲境转妙。贪心转重。身触有殊。故经少时。数成淫事。不尔天欲乐。应少于人中。随彼诸天男女膝上。有童男童女。欻尔化生。即说为彼天所生男女。初生天众。身量云何。颂曰

  初如五至十　　色圆满有衣

论曰。且六欲诸天初生。如次如五六七八九十岁人。生己身形。速得圆满。色界天众。于初生时。身量周圆。具妙衣服。一切天众。皆作圣言。谓彼言词。同中印度。然不由学。自解典言。欲生乐生云何差别。颂曰

  欲生三人天　　乐生三九处

论曰。欲生三者。有诸有情。乐受现前诸妙欲境。彼于如是现欲境中。自在而转。谓今人趣。及下四天。有诸有情。乐受自化诸妙欲境。彼于自化妙欲境中。自在而转。谓唯第五乐变化天。有诸有情。乐受他化诸妙欲境。彼于他化妙欲境中。自在而转。谓第六他化自在天。此欲生三。依何建立。依受如生现前欲境故。依受如乐自化欲境故。依受如乐他化欲境故。又依所受下中上境故。又依受用有罪有劳现前欲境故。依乐受用无罪有劳。自化欲境故。依乐受用无罪无劳他化欲境故依如是等。故有差别。乐生三者。三静虑中。于九处生。受三种乐。以彼所受。有乐异熟。无苦异熟。故名乐生。此乐生三。依何建立。依多安住。离生喜乐。定生喜乐。离喜乐故。或依三种灾所及故。或依寻喜乐增上故。或依身想异无异故。依如是等。故有差别。大梵既有喜乐现行。名乐生天。亦无有失。所说诸天二十二处。上下相去。其量云何。颂曰

  如彼去下量　　去上数亦然

论曰。一一中间踰缮那量。非易可数。但可总举。彼去下量。去上例然。随从何天。去下海量。彼上所至。与去下同。谓妙高山。从第四层级。去下大海。四万踰缮那。上去三十三天。亦如去下海量。如三十三天去下大海。上去夜摩天。其量亦尔。如是乃至。如善见天去下大海。从彼上去色究竟天。其量亦尔。如是悬远。多踰缮那。如明眼人暂见色顷。世尊能以意势神通。运身往来。自在无碍。故佛神力。不可思议。于下处生。升见上不。颂曰

  离通力依他　　下无升见上

论曰。如四大王天众升见三十三天。非三十三天升见夜摩天等。然彼若得定所发通。一切皆能升见于上。或依他力。升见上天。谓得神通及上天众引接。往彼随其所应。或上天来下亦能见。若上界地来向下时。非下化身。下眼不见。非其境界故。如不觉彼触故。上界地来向下时。必化下身。为令下见。有余部说。如欲界中。若往若来。下眼见上。如是色界诸地往来。设离下化身。下眼亦见上。彼说非理。以色界中诸地相望因果断故。要离下地染。方得上生故。下地眼根。不见上色。是卑下业。所感果故。虽欲见上而无见能。依地居天。已说处量。夜摩天等处量云何。有说。四天如迷卢顶。有说。此四上倍倍增。有余师言。初静虑地宫殿依处。等一四洲。第二静虑。等小千界。第三静虑。等中千界。第四静虑。等大千界。有余师言。下三静虑。如次量等小中大千。第四静虑量无边际。齐何量说小中大千。颂曰

  四大洲日月　　苏迷卢欲天
  梵世各一千　　名一小千界
  此小千千倍　　说名一中千
  此千倍大千　　皆同一成坏

论曰。千四大洲。乃至梵世。如是总说为一小千。千倍小千。名一中千界。千中千界。总名一大千。此中小千。唯举至梵世故。少光等非小千界摄。积小千等为中大千。故中大千亦不摄彼。又言小者。是卑下义。以除上故。如截角牛。积小成余。亦非摄彼。此三千界。同坏同成。其中有情。坏成亦等。如外器量别。身量亦别耶。亦别。云何。颂曰

  赡部洲人量　　三肘半四肘
  东西北洲人　　倍倍增如次
  欲天俱卢舍　　四分一一增
  色天踰缮那　　初四增半半
  此上增倍倍　　唯无云减三

论曰。赡部洲人身。多长三肘半。于中少分。有长四肘。东胜身人。身长八肘。西牛货人。长十六肘。北俱卢人。三十二肘。欲界六天。最下身量。一俱卢舍。四分之一。如是后后一一分增。至第六天。身一俱卢舍半。色天身量。初梵众天。半踰缮那。梵辅全一。大梵一半。少光二全。此上余天。皆增倍倍。唯无云减三踰缮那。谓无量光天。倍增二至四。乃至色究竟。增满万六千。身量既殊。寿量别不。亦别。云何。颂曰

  北洲定千年　　西东半半减
  此洲寿不定　　后十初叵量
  人间五十年　　下天一昼夜
  乘斯寿五百　　上五倍倍增
  色无昼夜殊　　劫数等身量
  无色初二万　　后后二二增
  少光上下天　　大全半为劫

论曰。北俱卢人。定寿千岁。彼于人趣。福力最强。钝根薄尘。多诸快乐。无摄受过。死必上生。少受士用果。离诸违诤浊。以彼有情所受种种衣服严具皆从树生。诸妙花香。处处皆有。宫殿台阁。池路桥船。婇女园林。自然华丽。其地平坦。无有丘坑荆棘瓦砾毒刺碱卤。亦无毒虫诸恶禽兽。一切资具非工所成。昼夜虽恒受用无罪。诸善业果而不耽着。西牛货人寿五百岁。东胜身人寿二百五十岁。南赡部人寿无定限。劫后增减或少或多。少极十年多极八万。于劫初位。人寿叵量。非百千等所能计故。已说人间寿量长短。要先建立天上昼夜。方可算计天寿短长。天上云何建立昼夜。人五十岁。为六天中最在下天一昼一夜。乘斯昼夜。三十为月。十二月为岁。彼寿五百年。上五欲天。渐俱增倍。谓人百岁。为第二天一昼一夜。乘斯昼夜。成月及年。彼寿千岁。夜摩等四。随次如人二四八百千六百岁。为一昼夜。乘斯昼夜。成月及年。如次彼寿二四八千万六千岁。持双以上。日月并无昼夜。光明依何而有。依华开合鸟鸣不鸣。寤寐不同。立有昼夜。外光明事。依内身成。已说欲天寿量长短。色天无有昼夜差别。但以劫数。知寿短长。彼劫寿短长。与身量数等。谓若身量半踰缮那。寿量半劫。若彼身量一踰缮那。寿量一劫。乃至身量长万六千。寿量亦同。万六千劫。已说色界天寿短长。无色四天。从下如次。寿量二四六八万劫。上所说劫。为定依何。为坏为成。为中为大。少光以上。大全为劫。自下诸天。大半为劫。即由此故。说大梵王过梵辅天寿一劫半。空成住坏。各二十中。总八十中。为一大劫。取成住坏总六十中。为大梵王一劫半寿。故以大半四十中劫。为下三天所寿劫量。已说善趣寿量短长。恶趣云何。颂曰

  等活等上六　　如次以欲天
  寿为一昼夜　　寿量亦同彼
  极热半中劫　　无间中劫全
  傍生极一中　　鬼月日五百
  頞部陀寿量　　如一婆诃麻
  百年除一尽　　后后倍二十

论曰。恶趣亦无如人昼夜。然其寿量。比况可知。四大王等。六欲天寿。如其次第。为等活等六奈落迦一昼一夜寿量。如次亦同彼天。谓四大王寿量五百。于等活地狱。为一昼一夜。乘此昼夜。成月及年。以如是年。彼寿五百。乃至他化。寿万六千。于炎热地狱。为一昼一夜。乘此昼夜。成月及年。彼寿如斯。万六千岁。极热地狱。寿半中劫。无间地狱。寿一中劫。傍生寿量。多无定限。若寿极长。亦一中劫。谓难陀等。诸大龙王。故世尊言。大龙有八。皆住一劫能持大地。鬼以人间一月为一日。乘此成月岁。寿五百年。寒那落迦。云何寿量。世尊寄喻。显彼寿言。如此人间佉黎二十。成摩揭陀国一麻婆诃量。有置巨胜平满其中。设复有能百年除一。如是巨胜。易有尽期。生頞部陀。寿量难尽。此二十倍。为第二寿。如是后后二十倍增。是谓八寒地狱寿量。此诸寿量。有中夭耶。颂曰

  诸处有中夭　　除北俱卢洲

论曰。诸处寿量。皆有中夭。唯北俱卢。定寿千岁。此约处说。非别有情。有别有情。不中夭故。谓住睹史多天。一生所系菩萨。决定尽彼天中寿量。若最后有。佛记佛使。随信法行。菩萨轮王母。怀彼二胎时。此等有情。事未究竟。终不中夭。非谓必尽随所生处寿量短长

说一切有部顺正理论卷第三十一阿毗达磨顺正理论卷第三十二

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩缘起品第三之十二

如是已就踰缮那等。辩器世间身量差别。就年等辩寿量有殊。二量不同。未说应说。建立此等。无不依名。前二及名。未详极少。今应先辩三极少量。颂曰

  极微字刹那　　色名时极少

论曰。以胜觉慧。分析诸色。至一极微。故一极微。为色极少。不可析故。如是分析诸名及时。至一字刹那。为名时极少。一字名者。如说掉名。何等名为一刹那量。经主率意。作是释言。谓众缘合时。法得自体顷。如是所释。理不极成。应审法生前。体为有非有。对法者说。众缘合时。诸法得生。非得自体。未生诸法。已有体故。法体已有。何用复生。众缘合时。体虽已有。而能令彼至牵果位起胜作用。故说为生。至现已生。正能牵果。牵果用息。说为过去。未来何故。无牵果能。此责不然。即如有责未来何不名现在故。诸牵果用。我说现在。是故不应作如是责。何缘固执如是义宗。若异此宗。凡有所立。现与无量理教相违辩。三世中当。广思择去。来实有体。其理既成。彼说刹那量。定不应理。又待别举余量显故。谓众缘合。法得自体。仍未决了。此经几时。又法刹那非世现见。故问何量名一刹那。应答刹那其量如是。法得体顷。彼谓刹那。宁举刹那。显刹那量。故彼所释。其理不成。毗婆沙师。依胜义说。法刹那量。可以喻彰。然佛世尊。曾不说者。以不见有能解者故。然有为欲开晓学徒。依比量门。方便显示。谓如壮士一弹指时。经细刹那六十五等。如是已辩三极少量。前二量殊。今次应辩踰缮那等。其量云何。颂曰

  极微微金水　　兔羊牛隙尘
  虮虱麦指节　　后后增七倍
  二十四指肘　　四肘为弓量
  五百俱卢舍　　此八踰缮那

论曰。一极微量。亦可喻显。唯佛乃知。故亦不说。然为安立阿练若处。故毗奈耶。但作是说。七极微集。名一微等。极微为初。指节为后。应知后后皆七倍增。谓七极微。为一微量。积微至七。为一金尘。积七金尘。为水尘量。水尘积至七。为一兔毛尘。积七兔毛尘。为羊毛尘量。积羊毛尘七。为一牛毛尘。积七牛毛尘。为隙游尘量。隙尘七为虮。七虮为一虱。七虱为穬麦。七麦为指节。三节为一指。世所极成。是故于颂中不别分别。二十四指横布为肘。竖积四肘为弓。谓寻竖积五百弓。为一俱卢舍。毗奈耶说。此是从村至阿练若。中间道量。说八俱卢舍。为一踰缮那。已说极微渐次积集成微乃至一踰缮那。然许极微略有二种。一实二假。其相云何。实谓极成色等自相。于和集位。现量所得。假由分析。比量所知。谓聚色中。以慧渐析。至最极位。然后于中辩色声等极微差别。此析所至。名假极微。令慧寻思极生喜故。此微即极。故名极微。极谓色中析至究竟。微谓唯是慧眼所行。故极微言。显微极义。以何为证知有极微。以阿笈摩及理为证。阿笈摩者。谓契经说。诸所有色。或细或粗。细者谓极微。更不可析故。余有对色。说名为粗。复有余师。作如是释。不善无记。说名为粗。所余善色。说名为细。如是欲色系。有漏无漏别。此不应理。以劣胜言。已摄如是性等别故。复有别释。眼境为粗耳等余根所取名细。此亦非善。俱通二故。又不定故。谓有细色。如析毛端。极明眼者。犹难得见。或有大声。如雷音等。震动天地。有耳皆闻。是故细言。表极微色。理善成就。若谓经中亦说段食有粗细故。此释非者。亦不相违。此经说色。彼经说食。意各别故。以一极微。可名为色。不可名食。故意有异。理必应尔。以伽他言

  黑白等诸色　　皆有细有粗
  细者谓最微　　粗即余有对

由此诚证。极微定有。又先已说。先说者何。谓毗奈耶作如是说。七极微集。名一微等。如是名教。其理者何。谓如积聚有情身色。至色究竟有量最粗。准此亦应分析诸色。有究竟处。名一极微。云何知尔。以可析法分析至穷犹有余故。谓世现见。以余聚色。析余聚色。有细聚生。析析至穷。犹有余分。可为眼见。更不可析。如是聚色。不能析处。亦如粗聚。有可析理。谓彼可以觉慧分析。如以聚色析聚。至穷慧析至穷。应有余在。可为慧见。更不可析。此余在者。即是极微。是故极微。其体定有。此若无者。聚色应无。聚色必由此所成故。如是已说踰缮那等。应辩年等。其量云何。颂曰

  百二十刹那　　为怛刹那量
  腊缚此六十　　此三十须臾
  此三十昼夜　　三十昼夜月
  十二月为年　　于中半减夜

论曰。刹那百二十。为一怛刹那。六十怛刹那。为一腊缚。三十腊缚。为一牟呼栗多。三十牟呼栗多。为一昼夜。此昼夜有时增有时减有时等。三十昼夜为一月。总十二月为一年。于一年中分为三际。谓寒热雨。各有四月。十二月中。六月减夜。以一年内夜总减六。云何如是。故有颂言

  寒热雨际中　　一月半已度
  于所余半月　　智者知夜减

如是已辩刹那至年。劫量不同。今次当辩。颂曰

  应知有四劫　　谓坏成中大
  坏从狱不生　　至外器都尽
  成劫从风起　　至地狱初生
  中劫从无量　　减至寿唯十
  次增减十八　　后增至八万
  如是成已住　　名中二十劫
  成坏坏已空　　时皆等住劫
  八十中大劫　　大劫三无数

论曰。言坏劫者。谓从地狱有情不复生。至外器都尽。坏有二种。一趣坏。二界坏。复有二种。一有情坏。二外器坏。然坏与成总分四品。一者正坏。二坏已空。三者正成。四成已住。言正坏者。谓此世间。过于二十中劫住已。从此复有等住二十。坏劫便至。坏劫将起。住此洲人。寿量八万。若时地狱有情命终。无复新生。为坏劫始。乃至地狱。无一有情。尔时名为地狱已坏。诸有地狱。定受业者。业力引置他方狱中。由此准知。傍生鬼趣。时人身内。无有诸虫。与佛身同。傍生坏故。有说二趣于人益者。坏与人俱。余者先坏。如是二说。前说为善。若时人趣。此洲一人。无师法然。得初静虑。从静虑起。唱如是言。离生喜乐。甚乐甚静。余人闻已。皆入静虑。命终并得生梵世中。乃至此洲有情都尽。是名已坏赡部洲人。东西二洲。例此应说。北洲命尽。生欲界天。由彼钝根无离欲故。生欲天已。静虑现前。转得胜依。方能离欲。乃至人趣。无一有情。尔时名为人趣已坏。若时天趣。欲界六天。随一法然。得初静虑。乃至并得生梵世中。尔时名为欲天已坏。如是欲界无一有情。名欲界中有情已坏。若时梵世。随一有情。无师法然。得二静虑。从彼定起。唱如是言。定生喜乐。甚乐甚静。余天闻已。皆入彼静虑命终。并得生极光净天。乃至梵世中。有情都尽。如是名已坏有情世间。唯器世间。空旷而住。余方世界一切有情。感此三千世界业尽。于此渐有七日轮现。诸海干竭。众山洞然。洲渚三轮。并从焚燎。风吹猛焰。烧上天宫。乃至梵宫。无遗灰烬。自地火焰。烧自地宫。非他地灾能坏他地。由相引起。故作是言。下火风飘焚烧上地。谓欲界火。猛焰上升。为缘引生色界火焰。余灾亦尔。如应当知。如是始从地狱渐减。乃至器尽。总名坏劫。所言成劫。谓从风起。乃至地狱始有情生。谓此世间灾所坏已。二十中劫。唯有虚空。过此长时。次应复有等住二十。成劫便至。一切有情业增上力。空中渐有微细风生。是器世间将成前相。风渐增盛。成立如前所说风轮水金轮等。然初成立大梵天宫。乃至夜摩宫。后起风轮等。是谓成立外器世间。器有坏成。由有情力。若有情类。久集上天。此器世间。必应渐起。令福减者。散下居故。谓极光净。久集有情。天众既多。居处迫迮。诸福减者。应散下居。此器世间。理应先起。故劫坏位。有情上集。于劫成时。有情下散。由罪福减及福罪增。集散旋环。理应如是。既已成立此器世间。初一有情。极光净殁。生大梵处空宫殿中。后诸有情。亦从彼殁。有生梵辅。有生梵众。有生他化自在天宫。渐渐下生。乃至人趣。俱卢牛货胜身赡部。后生饿鬼傍生地狱。法尔后坏。必最初成。若初一有情生无间狱。二十中成劫应知已满。此后复有二十中劫。名成已住。次第而起。谓从风起。造器世间。乃至后后有情渐住。初一有情。极光净殁。生大梵宫者。即为大梵王。诸大梵王。必异生摄。以无圣者还生下故。上二界无入见道故。即由此故。无一有情无间二生为大梵义。既说大梵最后命终。极光净天。寿八大劫。二十中劫。世界还成。如何梵王。生极光净。受少寿量。还从彼殁。虽彼非无有中夭义。而广大福。方生彼天。八大劫寿中。始经少分。二十中劫顷。宁即命终。以此观知。余来生此。此洲人寿。经无量时。至住劫初。寿方渐减。从无量减。至极十年。即名为初一住中劫。此次十八。皆有增减。谓从十年增至八万。复从八万减至十年。尔乃名为第二中劫。次余十七。例皆如是于十八后。从十岁增至极八万岁。名第二十劫。一切劫增。无过八万。一切劫减。唯极十年。十八劫中。一增一减。时量方等。初减后增。故二十劫。时量皆等。此总名为成已住劫。所余成坏。及坏已空。虽无减增二十差别。然由时量与住劫同。准住各成二十中劫。成中初劫。起器世间。后十九中。有情渐住。坏中后劫。减器世间。前十九中。有情渐舍。如是所说。成住坏空。各二十中。积成八十。总此八十。成大劫量。若尔且对苦苦为言。应生死中乐多非苦。坏空成劫。一向乐故。于住劫中。虽苦乐杂。而纯苦少。纯乐时多。时分虽然。而苦起位。增上猛利。乐则不尔。谓于热际。烈日逼身。虽用旃檀乌施罗末及冰雪等。而为对治。便有增上身安乐生。尔时欻遭小刺所刺。顿忘众乐。唯觉有苦。如是若遇恩爱别离。心中所生。增上苦受。重于恩爱。和合生乐。由如是等。知生死中。乐少苦多。其理决定。诸劫唯用五蕴为体。除此时体不可得故。经说三劫阿僧企耶精进修行得成佛者。于前所说四种劫中。积大劫成三劫无数。谓从初种大菩提种。经三大劫阿僧企耶。方乃得成大菩提果。既称无数。何复言三。有释此言。诸善算者。依算计论算至数穷。初不能知。名一无数。如是无数。积至第三。余复释言。六十数内。别有一数。立无数名。谓有经中。说六十数。此言无数。当彼一名。积此至三。名三无数。非诸算计不能数知。菩萨经斯三劫无数。方乃证得无上菩提。如是已辩劫量差别。诸佛独觉。出现世间。为劫增时。为劫减位。颂曰

  减八万至百　　诸佛现世间
  独觉增减时　　麟角喻百劫

论曰。从此洲人寿八万岁。渐减乃至寿极百年。于此中间。诸佛出现。何缘增位无佛出耶。有情乐增。难教厌故。多行妙行故。少有堕三涂。减百年时。何故无佛。现于如是寿短促时。不能具成佛所作故。谓一切佛。出现世间。决定舍于第五分寿。从定所起命行依身。非于尔时所化乐见。以设出世为佛事少。故于尔时。佛不出世。经主于此。作是释言。五浊极增。难可化故。岂不今世人减百年五浊虽增。而有能办入正决定离染得果。佛唯为此。应出世间。故彼所言。非为善释。非百年位佛出世时。一切皆能遵崇圣教。入正决定。离染得果。可言减百一分。不能办斯佛事。故无佛出。然于减百。设佛出世。亦有一分能遵教等。如百年时。佛何不出。若谓减百堪化有情极鲜少故佛不出者。是则应说前所立因。不能具成佛所作故。虽于减百五浊极增。不能具成佛所作事。由斯故佛不出世间而此亲因。非彼所说。言五浊者。一寿浊。二劫浊。三烦恼浊。四见浊。五有情浊。云何浊义。极鄙下故。应弃舍故。如滓秽故。岂不寿劫有情浊三互不相离。见浊即用烦恼为体。五应不成。理实应然。但为次第显五衰损极增盛时。何等名为五种衰损。一寿命衰损。时极短故。二资具衰损。少光泽故。三善品衰损。欣恶行故。四寂静衰损。展转相违成諠诤故。五自体衰损。非出世间功德器故。为欲次第显此五种衰损不同。故分五浊。独觉出现。通劫增减。然诸独觉。有二种殊。一者部行。二麟角喻。部行独觉。先是声闻。得胜果时。转名独胜。有余说彼先是异生。曾修声闻顺决择分。今自证道。得独胜名。由本事中说。一山处总有五百苦行外仙。有一猕猴。曾与独觉相近而住。见彼威仪。展转游行。至外仙所。现先所见独觉威仪。诸仙睹之。咸生敬慕。须臾皆证独觉菩提。若先是圣人。不应修苦行。麟角喻者。谓必独居。二独觉中。麟角喻者。要百大劫。修菩提资粮。然后方成麟角喻独觉。言独觉者。谓现身中。离禀至教。唯自悟道。以能自调不调他故。何缘独觉。言不调他。非彼无能演说正法。以彼亦得无碍解故。又能忆念过去所闻。诸佛言词。堪为他说。得极远境宿住智故。又不可说彼无慈悲。为摄有情现神通故。又不可说无受教机。尔时有情。亦有能起世间离染。对治道故。虽有此理。而今测量。彼知尔时有情根欲。入见谛等。不藉他教。故不说法以调伏他。除此所余。摄有情事。无劳设教现通即成。又诸独觉阙力无畏对。于我论坚执众中欲说无我心便怯劣。故不说教以调伏他。有余释言。由彼独觉长时数习少欲胜解。又避摄众諠杂过失。故不说法以调伏他。若自有能。他有根欲。弃而不济度。岂名有慈悲。是故应如前释为善。轮王出世。为在何时。几种几俱何威何相。颂曰

  轮王八万上　　金银铜铁轮
  一二三四洲　　逆次独如佛
  他迎自往伏　　诤阵胜无害
  相不正明圆　　故与佛非等

论曰。从此洲人寿无量岁。乃至八万岁。有转轮王生。减八万时。有情富乐。寿量损减。非其器故。或顺彼受业。定于彼时。方与果故。如感佛身业。要劫减时方能与果。王由轮宝旋转应导。威伏一切。名转轮王。施设足中。说有四种。金银铜铁轮应别故。如其次第。胜上中下。逆次能王领一。二三四洲。谓铁轮王。王一洲界。铜轮王二。银轮王三。若金轮王。王四洲界。契经就胜。但说金轮。故契经言。若王生在刹帝利种。绍灌顶位。于十五日。受斋戒时。沐浴首身。受胜斋戒。升高台殿。臣僚辅翼。东方欻有金轮宝现。其轮千辐。具足毂辋。众相圆净。非匠所成。舒妙光明来应王所。此王定是。转金轮王。转余轮王。应知亦尔轮王如佛。无二俱生。故契经言。无处无位。非前非后。有二如来应正等觉。出现于世。有处有位。唯一如来。如说如来。轮王亦尔。应审思择。此唯一言。为据一大千。为约一切界。应说一切界。无差别言故。谓无经说。唯此世间。又无经言唯一世界。如何不说。而能定知唯据一大千。非约一切界。若尔何故。梵王经说我今于此三千大千诸世界中。得自在转。彼有密意。密意者何。谓若世尊。不起加行。唯能观此三千大千。若时世尊。发起加行。无边世界。皆佛眼境。天耳通等。例此应知。若不许然。佛于余界。何缘无有自在化能。为阙大悲。为智有碍。阙大悲者。经不应言如来悲心普覆一切。智有碍者。经不应言无一尔焰佛智不转。若佛智悲。遍于一切。无碍无阙。则应说法。普能济度一切有情。无边界中。如来皆有。不思议力。能普化故。又佛先于三无数劫。发愿度脱一切有情。令诸有情。若自所化。若他所化。皆已下种。资粮成熟。住在十方。无出世尊愿所及境。何缘此佛。不度余方。设一如来。唯化一界。亦非一界尽得涅槃。然许如来能化一界。故许一佛普化十方。虽度不尽。亦无有失。余为当来佛所度故。由斯理故。梵王经说。我今于此三千大千诸世界中。自在转者。定有密意。为证不成。又理必然。如舍利子。总约现在。白世尊言。我得彼问。当如是答。今时无有梵志沙门得无上菩提与我世尊等。所以然者。我从世尊。亲闻亲持。无处无位。非前非后。有二如来应正等觉。出现于世。有处有位。唯一如来。如其他方别有佛者。非舍利子怀嫉妒心。何故不言他方虽有而一世界无二如来。岂不此经亦有密意。引证己义。亦不得成。密意者何。谓彼所引。无处位等。有二如来。如说如来。轮王亦尔。若无密意。约现总遮。则应轮王余界非有。以彼如佛遮俱生故。若余界轮王。虽遮而有。则余界诸佛。不可言无。是故此经。约一界说。不可以佛定例轮王。即此经中遮女成佛。岂亦有佛以女身成。如遮轮王俱生非定。又不可以佛例轮王。以转轮王如业主别。所生处所。有隔别故。谓转轮王。业有分限。故所王领。亦有隔别。非一四洲俱时二主同所王领。况得有多。是故应知。为主有隔。其所生处理有分限。由有分限。故一界中。无二轮王。余界别有佛因无有分限异故为主王化亦无分限。由此无有佛土隔别。故不可言属此属彼。如何此佛唯化此方。余世界中有余佛化。云何知佛为化主无限。于一切界境皆有智故。诸界差别由二种依。谓依身殊。及法差别。佛于诸界差别相中。有能遍知殊胜智故。于一切法一切有情差别境中。无碍智转。如契经说。佛告苾刍。我观有情。非易可得。从久流转生死以来。非汝父母。乃至广说。又契经说。佛告苾刍。我观方土。非易可得。从久流转生死以来。非汝所居。乃至广说。又舍利子。赞述世尊成就无上宿住念智。作如是言。大德世尊于彼彼处。曾不曾住。若有色若无色。若有想若无想。若非想非非想。即彼彼处。所有行相。所有摽举。有无量种无上微妙宿住念智。岂不由此即成如来。于不生处。亦有智转。能为化主。化彼有情。非转轮王有如是德。故不可引比例世尊。又转轮王。于大千界。为多俱出各王四洲。为一轮王总王如佛。若尔何失。二俱不然。若多俱生各别王者。如王与佛遮二言同。而许轮王于大千界同时多出。非佛世尊。如是亦应许余世界有轮王出。无佛世尊。若一轮王。生一四洲界。而能总王百俱胝界者。轮王少福。都无妙智。而许总王三千大千。况我世尊。具大福德。于一切界。一切有情。有大堪能。无碍妙智而执所王不越大千与轮王同。斯有何理。又彼所执。都无至教。唯依少理。作如是言。现见世间。有多菩萨。俱时修习菩提资粮。一界一时。可无多佛。多界多佛。何理能遮。故无边界中有无边佛现。此所立理。应共寻思。俱时造修转轮王业。及俱修习菩提资粮。二类有情。谁多谁少。又轮王果。无上菩提。无障圆成。谁迟谁速。又有何定理。无二无多造。一界同时转轮王业。彼如是业成熟既同时。何理为遮不俱生一界。此中定理。于佛亦然。不可被征便许一界无二多造业。或非一俱生。又贤劫中。契经定说。有五百佛。出现世间。或有说言。千佛出世。若千菩萨。菩提资粮。同一劫中。可得圆满。何缘成佛定不同时。谓彼皆于三无数劫。精勤修习。菩提资粮。有一劫中。同处成佛。何缘无有同处同时。于一大千。无俱时理。多界唯一。理亦应同。唯佛世尊。能于此义。究竟通达。我等随力。且于此作如是寻思。诸有智人。应详其理。如是所说。四种轮王。威定诸方。亦有差别。谓金轮者。诸小国王。各自来迎。作如是请。我等国土。宽广丰饶。安隐富乐。多诸人众。唯愿天尊。亲垂教敕。我等皆是天尊翼从。若银轮王。自往彼土。威严近至。彼方臣伏。若铜轮王。至彼国已。宣威竞德。彼方推胜。若铁轮王。亦至彼国。现威列阵。克胜便止。一切轮王。皆无伤害。令伏得胜已。各安其所居。劝化令修十善业道。故轮王死。多得生天。经说轮王出现于世。便有七宝。出现世间。象等五宝。有情数摄。如何他业生他有情。非他有情从他业起。然由先造互相属业。于中若一。禀自业生。余亦俱时乘自业起。如是所说。诸转轮王。非唯有七宝与余王别。亦有三十二大士相殊。若尔轮王。与佛何异。佛大士相。处正明圆。王相不然。故有差别。言处正者。谓于佛身。众相无偏。得其所故。言明了者。谓于佛身。相极分明。能夺意故。言圆满者。谓于佛身。众相周圆。无缺减故。劫初人众。为有王无。颂曰

  劫初如色天　　后渐增贪味
  由惰贮贼起　　为防雇守田

论曰。劫初时人。皆如色界。极光净殁。来生人间。经于久时。渐有王出。故契经说。劫初时人。有色意成。支体圆满。诸根无缺。形色端严。身带光明。腾空自在。饮食喜乐。长时久住。有如是类。地味渐生。其味甘美。其香郁馥。时有一人。禀性耽味。嗅香起爱。取尝便食。余人随学。竞取食之。尔时方名。初受段食。资段食故。身渐坚重。光明隐没。黑闇便生。日月众星。从兹出现。由渐耽味。地味便隐。从斯复有地皮饼生。竞耽食之。地饼复隐。尔时复有林藤出现。竞耽食故。林藤复隐。有非耕种香稻自生。众共取之。以充所食。此食粗故。残秽在身。为欲蠲除。便生二道。因斯遂有男女根生。由二根殊。形相亦异。宿习力故。便相瞻视。因此遂生非理作意。欲贪鬼魅。惑乱身心。失意猖狂。行非梵行。人中欲鬼。初发此时。尔时诸人。随食早晚。随取香稻。无所贮积。后时有人。禀性懒堕。长取香稻。贮拟后食。余人随学。渐多停贮。由此于稻生我所心。各纵贪情。多收无厌。故随收处。无复再生。遂共分田。虑防远尽。于己田分。生吝护心。于他分田。有怀侵夺。劫盗过起。始于此时。为欲遮防。共聚详议。铨量众内一有德人。各以所收六分之一。雇令防护。封为田主。因斯故立刹帝利名。大众钦承。恩流率土。故复名大三末多王。自后诸王。此王为首。时人或有情厌居家。乐在空闲。精修戒行。因斯故得婆罗门名。后时有王。贪吝财物。不能均给国土人民。故贫匮者。多行贼事。王为禁止。行轻重罚。为杀害业。始于此时。时有罪人。心怖刑罚。覆藏其过。异想发言。虚诳语生。此时为首。于劫减位。有小三灾。其相云何。颂曰

  业道增寿减　　至十三灾现
  刀疾饥如次　　七日月年止

论曰。从诸有情。起虚诳语。诸恶业道。后后转增。故此洲人。寿量渐减。乃至极十。小三灾现。故诸灾患。二法为本。一贪美食。二性懒堕。此小三灾。中劫末起。三灾者。一刀兵。二疾疫。三饥馑。谓中劫末。十岁时人。为非法贪。染污相续。不平等爱。映蔽其心。邪法萦缠。嗔毒增上。相见便起猛利害心。如今猎师见野禽兽。随手所执。皆成利刀。各逞凶狂。互相残害。又中劫末。十岁时人。由具如前诸过失故。非人吐毒。疾疫流行。遇辄命终。难可救疗。又中劫末。十岁时人。亦具如前诸过失故。天龙忿责。不降甘雨。由是世间。久遭饥馑。既无支济。多分命终。是故说言。由饥馑故。便有聚集。白骨运筹。由二种因。名有聚集。一人聚集。谓彼时人。由极饥羸。聚集而死。二种聚集。谓彼时人。为益后人。辍其所食。置于小箧。拟为种子。故饥馑时。名有聚集。言有白骨。亦由二因。一彼时人。身形枯燥。命终未久。白骨便现。二彼时人。饥馑所逼。聚集白骨。煎汁饮之。有运筹言亦二因故。一由粮少。传筹食之。谓一家中。从长至幼。随筹至日。得少粗餐。二谓以筹。挑故场蕴。得少谷粒。多用水煎。分共饮之。以济余命。然有至教。说治彼方。谓若有能一昼一夜持不杀戒。于未来生决定不逢刀兵灾起。若能以一诃梨怛鸡起殷净心奉施僧众。于当来世决定不逢疾疫灾起。若有能以一抟之食起殷净心奉施僧众。于当来世决定不逢饥馑灾起。此三灾起。各经几时。刀兵灾起。极唯七日。疾疫灾起。七月七日。饥馑七年七月七日。度此便止。人寿渐增。东西二洲。有似灾起。谓嗔增盛。身力羸劣。数加饥渴。北洲总无。前说火灾焚烧世界。余灾亦尔。如应当知。何者为余。今当具辩。颂曰

  三灾火水风　　上三定为顶
  如次内灾等　　四无不动故
  然彼器非常　　情俱生灭故
  要七火一水　　七水火后风

论曰。此大三灾。逼有情类。令舍下地。集上天中。初火灾兴。由七日现。有说如是七日轮行。犹如雁行。分路旋运。有说如是七日轮行。上下为行。分路旋运。中间各相去。五千踰缮那。次水灾兴。由降瀑雨。有作是说。从三定边空中。欻然雨热灰水。有余复说。从下水轮起涌沸水。上腾漂浸。决定义者。即此边生后风灾兴。由风相击。有作是说。从四定边空中。欻然飘击风起。有余复说。从下风轮。起冲击风。上腾飘鼓。此决定义。准前应知。若此三灾。坏器世界。乃至无有细分为余。后粗物生。谁为种子。岂不即以前灾顶风为缘引生。风为种子。或先所说。由诸有情业所生风。能为种子。风中具有种种细物。为同类因。引粗物起。或诸世界。坏非一时。有他方风。具种种德。来此为种。亦无有过。故化地部契经中言。风从他方。飘种来此。如先所说。前灾顶风。此中何灾。以何为顶。火水风如次。上三定为顶。故世尊说。灾顶有三。若时火灾焚烧世界。以极光净。为此灾顶若时水灾。浸烂世界。以遍净天。为此灾顶若时风灾飘散世界。以广果天。为此灾顶。随何灾力。所不及处。即说名为此灾之顶。何缘下三定。遭火水风灾。初二三定中。内灾等彼故。谓初静虑。寻伺为内灾。能烧恼心。等外火灾故。第二静虑。喜受为内灾。与轻安俱。润泽如水。故遍身粗重。由此皆除故。经说苦根第二静虑灭。以说内心喜。得身轻安故。非唯火灾寻伺止息。亦由灭苦所依识身。故说苦根二静虑灭。虽生上地识身容现前。随欲不行自在故无过。然经言灭苦。据正入定时。初静虑中。犹有寻伺。无增上喜。不言苦灭。第三静虑。动息为内灾。息亦是风。等外风灾故。若入此静虑。有如是内灾。生此静虑中。遭是外灾坏。故初静虑。内具三灾。外亦具遭三灾所坏。第二静虑。内有二灾。故外亦遭二灾所坏。第三静虑。内唯一灾。故外但遭一灾所坏。何缘不立地亦为灾。以器世间即是地故。但可火等与地相违。不可说言地还违地。如先所说三断末摩。所断末摩。即是地故。不可立地以为能断。夫种类同。不相违故。又下三定。以火水风。如次为灾。损坏外器。若复立地。为第四灾。则应能损第四静虑。然彼静虑。必无外灾。以彼定无内灾患故。由此佛说。彼名不动。内外三灾。所不及故。由是故说。灾唯有三。毗婆沙师。说第四定摄净居故。灾不能损。由彼不可生无色天。亦复不应更往余处。由此证余界无净居天。若余世界中。有净居者。应如地狱移往他方。宁说不应更往余处。下三天处。由净居天威力摄持。故无灾坏。无容一地处少不同便有为灾坏不坏别。若尔彼地器应是常。不尔与有情俱生俱灭故。谓彼天处。无总地形但如众星居处。各别有情。于彼生时死时。所住天宫。随起随灭。是故彼器。体亦非常。所说三灾。云何次第。要先无间。起七火灾。其次定应。一水灾起。此后无间。复七火灾。度七火灾。还有一水。如是乃至。满七水灾。复七火灾。后风灾起。如是总有八七火灾。一七水灾。一风灾起。水风灾起。皆次火灾。自水风灾。必火灾起。故灾次第。理必应然。何缘七火方一水灾。极光净天。寿势力故。谓彼寿量。极八大劫。故至第八。方一水灾。由此应知。要度七水。八七火后。乃一风灾。由遍净天寿势力故。谓彼寿量。六十四劫。故第八八方一风灾。如诸有情。修定渐胜所感异熟身寿渐长。由是所居亦渐久住

说一切有部顺正理论卷第三十二阿毗达磨顺正理论卷第三十三

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩业品第四之一

此中一类。随顺造恶怯难论者。作如是言。如上所陈。诸内外事。多种差别。非业为因。现见世间。果石等物。众多差别。无异因故。谓从一种。有多果生。无种为先。有石等异。棘锋铦利豆皮黑等。众相差别。是谁所为。若必情欣有因论者。应言精血为内法因。种等为因。生外芽等。见由彼差别此有差别故。如果等异。无现异因。不现见因。亦应非有。为对彼执故立宗言。颂曰

  世别由业生　　思及思所作
  思即是意业　　所作谓身语

论曰。定由有情净不净业。诸内外事种种不同。云何知然。见业用故。谓世现见。爱非爱果。差别生时。定由业用。如农夫类。由勤正业。有稼穑等。可爱果生。有诸愚夫。行盗等业。便招非爱杀缚等果。复见亦有从初处胎。不由现因。有乐有苦。既见现在要业为先。方能引得爱非爱果。知前乐苦必业为先。故非无因。诸内外事。自然而有。种种差别。又世现见。造善者少。造恶者多。然于世间。有情乐少苦多。可得以现见为门非现见成故。谓世现见造作种种净不净业。为因缘故。便有种种乐苦果生。又见勤修如法行者。诸根怡悦。心寂安泰。若为贪等猛焰缠逼。行非法行。与上相违。又见世间如法行者。便得供养恭敬。附托非法行者。与此相违。由所现见法非法因。果足可比度不现见果因。亦见世间。与上相违者。此不违理。以有余因故。谓见世间。有造众恶而似感得心欢悦者。是先善业果。或现加行生。或有由斯招他敬养等。应知亦是现不现因生。如有智人为汤所瀹。便能了痛因火非水。如是智者。应当审思。诸乐果生。由善非恶。又世现见。久习贪等。贪等便增。慧等亦尔。然复见有不由久习而贪慧等自性猛利。智者应知。是先业果。若他敬等因恶行生应诸行恶行皆招他敬等故有许可善巧亲密诸现因缘得敬养者。应知以此。助余善业。令其有力。能与自果。行猎兽等诸恶行时。由不正思。便生欢悦。妄自庆慰。谓为乐者。是造业时。非受果位。有业皆受。现在虽乐。而感当来苦异熟果。是故智者。应善观察。勿耽小乐而招大苦。又见战等。杀害为因。便蒙赏赖。胜财位者此亦为缘。助先善业。若异此者。应俱蒙赖。或害己朋。亦应获赏。又同事业。所获有殊。由此应知。现士用等。但能缘助不现见因。令彼能招敬财位等。又见有造净不净业。而现获得毁赞衰利。与所造因相违果者。应知此为余业所伏。未得自果。但为他缘非例无因世间生起。又彼既许世所现见。种等为因。能生芽等。故无因论。理自不成。又不可言有情身等。但由现在加行力生。如芽等生。唯从种等。以外种等生芽等时非离有情业增上故。又若诸法无因生者。则应一切由一切物于一切时一切生起。何须计度种等别因。诸芽等生。可由业力。毒刺等物。应非业生。以非有情所须用故。此难非理。现不现见。粗细有情所须用故。又所须用。种种不同。谓令有情众同分等。生位增长。皆名须用。设非所食。须用义成。若诸世间。内外差别。皆有情业增上所生。何缘钵特摩。嗢钵罗花等。色香美妙。非有情身。由诸有情共不共业所生诸果有差别故。谓诸有情。造共净业。生莲花等美妙色香。共不净业。生毒刺等。由不共业。感有情身。杂思业生。故有净秽。与莲花等。不可例同。理必应然。以诸天等纯净业感。故彼内身。及外资缘。皆同美妙。然不肖者。以见世间。乐施者贫苦。悭吝者富乐。便增邪见。谓果无因。此由于田及思数习所得异熟增上等流果差别中不了达故。谓有先世。于良福田。暂植施因。故招富乐。然不数习能舍物思。故于今生。仍怀悭吝。若有先世。数施非田。则于今生。贫穷乐施。于如是义。何致愚迷。故由有情先世业力及现士用。二种世间。差别果生。理善成立。恶因论者。作是诘言。如何定知。害得非爱果不害得爱果。非此相违。应从二因各生二果。此如前释。前释者何。谓世现见。造善者少。造恶者多。然于世间有情乐少苦多可得。如是世间。诸有情类。多行杀害。少持不杀。如其爱果。杀害所招则应世间乐多苦少。既见不尔。是故定知。非杀害因。能招爱果。又见甘苦种子为因。如次能生甘苦二果。非相违故。如是若造苦乐他业。如次应招自苦乐果。非此相违。岂不世间毛蒲角[竺-二+韋]。虽别体类而见相生。如是亦应苦乐他业如次能得自乐苦果。此喻不成。非所许故。见谷麦等。果似因故。谓许蒲[竺-二+韋]。从自种生。毛角但能为其缘助。如谷麦等。虽自种生。而现见从水土等起。故彼所引。同喻不成。又见世间。求富乐者。必勤利乐有德者故。若如蒲[竺-二+韋]。从异类生。应彼为求当来乐者。于有德者。令苦非乐。既为求乐。勤利乐他。故杀害因。不招乐果。又彼所说。应从二因各生二果。理不成立。因无差别。而能别招爱非爱果。曾不见故。谓曾不见无差别因而能别招爱非爱果。但见无别从无别生。是故不应作如是计。净不净业。各招二果。若必尔者。不见有余异熟因故。净不净业所感之果。无差别故。则应一切有情业果。皆无差别。然无是事。若许尔者。持戒破戒。无差别故。精勤修学。即为唐捐。然不应许。又若尔者。应杀生故。于善趣中。同时俱受长寿短寿二种异熟。离杀生者。为难亦然。如是行盗。及离盗等。并应俱时受富贫等。亦不应执虽不俱时有二果生。而更代受。非因无别生别果故。又曾未见有异熟因生异熟已。犹有功力。能招别类异熟果故。又见有处。爱非爱果寿长短等。有决定故。若摄二因各生二果。而更代受。是则应无爱及非爱寿定长短受苦乐等决定差别。然现可得。或定长寿。或定短寿。或定多乐。或定多苦。是故无容二因更代各生二果。岂不有情皆爱自命。应在地狱亦爱命长。如是便成因果翻对。无如是失。以造业时能办多事。故受果位。亦有种种差别果生。谓造业时。诸杀生者。令他受苦。隔断他命。令他怖畏。失坏威光。故受果时。有三相似。谓苦他故。于地狱中。受极重苦。为异熟果。断他命故。于善趣中。受命极促。为等流果。坏他威故。感外药物皆少精光。为增上果。故无因果成翻对失。若尔便应许杀生业感善趣果。不尔不许感善趣中异熟果故。谓善趣寿。净业所招。然彼杀生。为其灾害。令其不遂全与自果。故说杀生能招短寿。设有恶业。感善趣中异熟果者。非爱果摄。是故亦非因果翻对。有执祠祀明咒为先。害诸有情。能招爱果。非泛尔害。故无前失。若尔咒术。或以[病-丙+猒]祷。令遭热病。乃至命终。应许此杀能招爱果。此咒术等。非欲利乐所害有情。祠祀明咒。意欲利乐所害羊等。故能害者。虽害有情。犹如良医。不招苦果。脱生死者。亦以利乐虫蚁等心。害虫蚁等。应招爱果。非以明咒。或以刀杖。同为利乐。杀害有情。果容有异。如能杀者。要依自心善恶有殊。得福非福。如是所杀羊等蚁等。应由自心得福非福。非由强杀令彼福生。以之为因。当招爱果。如脱生死者。害他有情。不为善果因。但招恶果。如是祠祀明咒为先。亦应唯招非所爱果。良医于彼。非同法喻。以诸良医为欲利乐诸有病者。勤加救疗。令他安乐。现非后生医及傍人知功验果。虽令病者暂苦触身。而彼良医。不生非福。然彼自许。羊等愚痴。不能了知。福与非福。既被杀害。现苦难任。虽说未来当招爱果。而能杀者及彼傍人。俱不现知。亦无理证。故所引喻。非与法同。杀者傍人。虽不现证。而由明论定量故知。祠祀害生不生非福。宁知明论是定量耶。以明咒声体是常故。谓诸明论。无制作者。于中咒词。自然有故。能为定量。唯此非余。为明论声。独是常性。为许一切声皆是常。若明论声独是常者。无定量证。理必不成。现见余声。耳根所取。是无常性。诸吠陀论。亦耳根得。应是无常。若一切声。皆是常者。应非定量。唯明论声。以许常声。为定量故。许皆定量。便失本宗。唯明论声。是定量摄。又非觉慧所发音声。唯可耳闻无定诠表。既许明论非觉为先。是则亦应非定量摄。又若明论。声体是常。谁障彼声。令不恒得。胸胭等处。互相击动。显明论声。此声虽常。显缘阙故。而不恒得。此声不应为缘所显能覆障法。不可得故。现见瓶等。被闇或余所覆障时。要假明等。除其覆障。瓶等方显。未得声前。能障声法都不可得。宁容可说声不恒得。由障未除。故彼所言。唯凭妄计。又世现见。显因虽别。而所显物。相无改转。然明论声。随缘闻异。谓随幼壮老胸胭等。击动发声。闻各有异。故不可说声由彼显。又声离能显异处可取故。谓离能显处。别处声可得。非所显物。离能显因。别处可取。故胸胭等。于吠陀论。非能显因。又此中无同法喻故。谓如何物先隐谁显。此如瓶等明等显发。理不应然。非极成故。谓且应审。为即闇瓶先被闇障今为明显为在闇瓶无间灭位有别瓶体。与明合生。故此中无极成同喻。设许明论被显如瓶。则应如瓶是无常性。以彼自说瓶是所显。及无常性。此亦应然。又应乐等同此执故。谓此声发现从自因。然执此声非生唯显乐等发起亦从自因。何故不执非生唯显。故一切声。从自因发。应如乐等非显唯生。是故彼言明论中咒。无制作者。故体是常。能为定量。有言无实。若尔应说诸明论声。至教所收。故为定量。谓明论说可爱果等。是诸大仙至圣所见。彼传说故。至教所摄。若顺便获诸可爱果。违便现遭不可爱报。不尔汝等所敬诸仙。所证至圣。非现量得。亦不可以比量准知。故彼传说非至教摄。谓汝所敬大仙所见。明论所说。可爱果等。汝等曾无能少现见。可以准验所说非虚。由此比知。彼证至圣验所传教。是至教摄。故汝所说。是愚敬言。讵能了知真至教相。且如仁等所敬大师。所证至圣。亦非仁等。现量所得。而许至圣。彼所说教。是至教摄。余亦应然。何独不许。此例非理。我等大师。有至圣相。现可证得。准相比度知证至圣。验所说教。是至教摄。何等名为至圣之相。与此相合。至圣性成证彼所言。是至教摄。夫虚诳语。因贪嗔痴。我等大师。圆满证得。贪嗔等过。皆毕竟尽。由得此尽。故成至圣。所以发言。皆至教摄。师过永尽。何理证知。能圆满说永尽道故。谓我大师。能圆满说。永尽过道。由是比知。贪等诸过。皆毕竟尽。如何知此道能毕竟尽过能障解脱得因由此暂永离故。若法能障众苦尽。得由所说道。能暂永离离此法故。便能证得。贪嗔痴等诸过永尽。此能障法。其体是何。谓能执我。即是我见。诸外道辈皆许有我。故彼不能解脱我执。以诸我执离无我见毕竟无能令止息者。然正法外。所有诸仙皆无有能正说无我。无此教故不离我执以于我执不能离故。便不能证贪等永尽。不证永尽。容有虚言。成就彼因贪嗔痴故。由是汝等所敬诸仙。实非大仙。亦非至圣。非至圣故。彼所传说。明论等声。非至教量。以彼非量。故我先辩。于祠祀中。明咒杀害非得爱果。其理极成。由是彼言祠祀明咒。为利羊等。虽害有情。犹如良医。不招苦果。如是所说。理定不成。彼既不成。唯此所说。世间差别。由业理成。然此颂中。言世别者。依第六转。谓世之别。或第七转。谓世中别。此所由业。其体是何。谓心所思。及思所作。故契经说。有二种业。一者思业。二思已业。思已业者。谓思所作。即是由思所等起义。应知思者。即是意业。思所作者。即身语业。如是二业。于契经中。世尊说为三。谓身语意业。如是三业。随其次第。由所依自性等起故建立。谓业依身故名身业。业性即语故名语业。此业依意复与意俱。等起身语故名意业。此中已说意业自性。谓即是思。思如前辩。身语二业。自性云何。颂曰

  此身语二业　　俱表无表性

论曰。应知如是所说诸业中。身语二业。俱表无表性。故本论言。云何身业。谓身所有表及无表。云何语业。谓语所有表及无表。复有何缘。唯身语业。表无表性。意业不然。以意业中无彼相故。谓能表示故名为表。表示自心令他知故。思无是事。故不名表。由此但言身语二业。能表非意。何故经言。诸爱者表。即是意业。此有余义。为显意业。虽体非色。由爱成粗。谓爱俱思。虽体非色。相粗显故。如身语表。能表自心。令他知故。实非表性。假说为表。故经但言。诸爱者表。即是意业。即是由爱所逼迫者。明了动心法。即是意业义。若此经言。爱者意业。体即是表。可举此经以显意业。用表为性。如是且辩意业非表。亦非无表。以无表业初起必依生因大种。此后无表生因虽灭。定有同类大种为依。故后后时。无表续起。诸意业起。必依于心。非后后时定有同类心相续起。可意无表依止彼心。多念相续。以心善等念念有殊。设无表思。同类续起。如何依止前心意业。可随后念异类心转。非有意业心不相应。故意业中。亦无无表。是故唯有身语二业。表无表性。其理善成。上座此中。作如是说。如何可说刹那灭身有动运转名为身业。以若有法此时此处生。无动运转即此时处灭。若不许如是无刹那灭义。如是语业。为难亦然。非对法宗许动运转名身语表。所以者何。颂曰

  身表许别形　　非行动为体
  以诸有为法　　有刹那尽故
  应无无因故　　生因应能灭
  形亦非实有　　应二根取故
  无别极微故　　语表许言声

论曰。发毛等聚。总名为身。于此身中。有心所起。四大种果。形色差别。能表示心。名为身表。如思自体。虽刹那灭。而立意业。于理无违。如是身形。立为身业。故彼所难。非预此宗。复以何缘。不立显色及大种等为身表耶。此等皆唯无记性故。岂不此等如能生心亦应得成善等性别。此责非理。此等不随作者乐欲而得生故。又设离心。亦得生故。表必待心。方得生故。若大种等。一心所生。如体有差别。法亦应尔故。然不可谓一心所生有差别体成差别性。复云何知。身语二业。有善不善。契经说故。如契经言。诸有染污眼耳所识法。彼具寿为非诸有清净。眼耳所识法。说亦如是。复云何知。四大种等。唯无记性。亦由经说。如契经言。或有一类。身住十年。乃至广说。说心意识。异灭异生。有设难言。诸有表业。善等性别。理不应成。自类有殊。理不成故。谓等是身业。待能起心。便成无记性。或成不善。如子或余执触母乳。是故身业。自类相望。差别不成。唯无记性。但由心故。此有差别。即能差别。可成善等。此难非理。彼此极相似故。别相难知。如庵没罗种等。如庵没罗种。所有显形。与竭树罗种。相极相似。虽极相似。而非无别。以见彼果有差别故。身语表业。理亦应然。若待能起心说表差别。然不可说表有善等异。则应思业亦无善等。以思亦与信贪等俱。方得名为善不善故。若一果故。善等成者。理亦不然。待他同故。如思虽与信等相应。同一果性。而待信等。势力方成。善等性别。如是表业。是善等心。所等起故。心等流故。成善等别。与思义同。若身语业。体是善等。应同外道离系者论。彼说善恶其性如火。思与不思。俱能烧故。无同彼失以善恶表离心不生。如眼等识。如眼等识。虽有差别。若离眼等。终不得生。如是表业。虽有善恶。若离于心。无容得起。故无同彼离系论失。又古诸师。已破离系所立火喻。说如是言。缚喝国人。意怀忿恚。有诸离系。起善净心。俱以其手。拔离系发。此二罪福。岂容平等。如是身语业相虽同。而于其中。有善恶异。故非如火业无差别。由此彼说。不应正理。是故我宗。无同彼失。彼上座所立身语业。云何彼作是言。余缘力故。令大造聚异方生时。后果前因。无间而转。能为摄益或为损害。即如是聚。名身表业。即以世俗补特伽罗。如是语言从缘而起。生如是果。名语表业。以约胜义。法无主宰。故多实界。合立表名。一物不能独表示故。又无余物名为表故。今谓彼宗所立表业。于圣教外。妄述己情。以契经中唯说眼耳二识所识。色之与声。有染净杂。非香等故。彼宗亦许。诸大造聚。皆唯无记。离身语业。不见别有染净色声。又诸大种。非眼所得。五识缘假。前已具遮。故彼所言。述己情计。若谓如是所立总聚亦无一向成无记失。随别等起。成差别故。又见彼果。有差别故。理亦不然。但有言故。彼宗自许。等起虽殊。而大造聚。无有差别。故等起心。虽有善等。而所等起。唯无记性。设许大造聚有善等差别。是不思择。凶乱发言。以诸聚体。不可得故。无体不应善等别故。亦不应立聚所依中一一皆有善等差别。以诸大种非眼境故。经唯说色声有染有净故。已遮显色等有善等差别。故不应执随别等起。令大造聚有善等别。设许显色是身表性。则许身表实有义成。于实有中须兴诤论。诸对法者。身表谓形。彼许显色名为身表。是则彼此非甚相违。然显不随等起心转。故非身表。如前已说。又果差别。虽有益损。而亦但应是无记性。以果差别。虽有益损。而不可言诸大种聚有善不善无记差别。有香等物。同此过故。而经但言。二有善等。虽无主宰。如有能生。故亦可言有能表性。是故上座所立身业。于圣教外。妄述己情。由此己遮所立语业。谓即世俗。如是语言。有善有染不应理故。又世俗不应说从缘而起。以世俗法非实有故。法若实有。可从缘生。异此缘生。应无自体。若尔便顺坏法者宗。故不应说即以世俗。如是语言。从缘而起。若依文次第。作如是释。世俗言但属补特伽罗。是则不应能通二难。谓先他论有作难言。如何世俗法。能生胜义果。如何有实表。便为坏胜义。先举世俗。从缘而起。故能生果。以通初难。次举胜义。法无主宰。合方能表。以通后难。若谓世俗不属语言。如何先文。能通初难。又唯许世俗属补特伽罗。则为许有胜义语业。此即语表。何理能遮。既许业成。亦应许表。又彼上座。自立诚言。非我拨无语实有性。然但不许别有一物。独能表示名为语表。我亦不许。离实语声。别有一物。名为语表。上座于此。何不生欣。岂不先说。一物不能独表示故。又无余物。名为表故。此无深理。如语体实。表亦应然。如无一语可独宣唱。亦无独能生耳识理。然语实有。不坏胜义。集从缘生。名为语业。如是虽无一实有界。独能表示。而有实表。不坏胜义。集从缘生。名为语表。我如是立。岂同汝宗。于圣教外。擅立业理。非由和集显色可见。不和集时。其体虽有。细故不见。便非显色。表亦应然。故是实有。又彼自许。触法界中。各有多物。如一一物别得界名。总亦是界。色界亦尔。总聚如别。俱得色名。表亦应尔。故对法者。立业理成。有余部言。动是身表。动名何法。谓诸行行。行如何行。谓余方起。或时诸行。即于本方。能为生因。生所生果。或时缘合。令于余方邻续前因。有果法起。故即诸行。余方生时。得身业名。亦名身表。虽有此理。但唯世俗。而身表业。必是胜义然非诸行实有行动。以有为法有刹那故。理虽如是。然不应言身有表业非实物有。以说诸行生灭为业诸行生灭。即诸行故。有何别理。要余方生。乃名为业。非即因处若即因处若于余方。随有法生。即于是处无间必灭。不往余方行动既无。何有实表。又已遮遣显等是业。故先所立。于理为胜。大德逻摩。作如是说。以诸行法即所得体。于是处生。即于是处。此体还灭。故无行动。虽有此理。然有体行。可是处灭。既执未来。法体未有。如何可说即所得体。于是处生又若得体。不应复生。既复须生。非已得体。故彼所说。自宗相违。若谓据当作如是说。此亦非理。以于世间不见无法。据当说故。但见于有后可改变。容据当说。如世间言。磨糗煮饭织绫绢等。非于无体可作是言。故彼所说。定非应理刹那何谓。谓极少时。此更无容前后分析。时复何谓。谓有过去未来现在。分位不同。由此数知诸行差别。于中极少诸行分位。名为刹那。故如是说。时之极促。故名刹那。此中刹那。但取诸法有作用位。谓唯现在。即现在法。有住分量。名有刹那。如有月子。或能灭坏。故名刹那。是能为因。灭诸法义。谓无常相。能灭诸法。此俱行法。名有刹那。或世间言。有刹那者。是有空义。谓现在位。无有能持。令不灭者。必不住故。名有刹那。或世间言。无刹那者。是无暇义。谓着余事。无暇专己。名无刹那。唯现在时。必有少暇。取自果故。名有刹那。然诸有为相续分位。有腊缚等。诸差别时。于诸时中。刹那最促。法定有此。名有刹那。而经主言。刹那何谓。得体无间灭。有此刹那法。名有刹那。如有杖人名为有杖。彼释非理。如杖异人。不可说故。喻不同法。非别有法异于得体。无间灭性。如何可说。此有刹那。如人有杖。亦不可谓约相续说。无体不应有得体故。或应无法名有刹那。非于有体便成大过。亦不应谓于似异说。引有杖人。为同喻故。或应假说言有刹那。于似说门。理应尔故。然不应许。假说有刹那。以无极成实有刹那故。谓若许有实有刹那。可许有余依似假说既无所似实。能似假不成。故对法宗。说有为法有刹那理独无有过。不应定言。得体无间灭。有此刹那法。名有刹那。复如何知。诸有为法。皆刹那灭。必不久住。以诸有为后必尽故。经主于此。作如是释。谓有为法。灭不待因。所以者何。待因谓果灭无非果故。不待因灭。既不待因。才生已即灭。若初不灭。后亦应然。以后与初有性等故。彼释非理。尽即是灭。佛说尽灭。是有为相。说有为相。是所有法。故契经说。诸行无常。有生灭法。又契经说。有为之起。亦可了知。尽及住异。亦可了知。若谓无法犹如色等。亦能为因。生识等者。则亦应许无法是果。此差别因。不可得故。何理无法是因非果。又见有法。以有为先。世所极成。有因是果。汝宗灭尽。亦有为先。必有为先。后方无故。如何不许是果有因。又法无因。许必是常。故灭若常者。法应永不生。若谓灭无。既非有体。如何成果。若非有体。如何为因。发生识等。又不应许是有为相。如许彼成。此亦应许。又譬喻者。能起异端。曾所未闻。解释道理。执有为相。是起及无。如是则应不成三数。谓有为法。得体名起。尽及异相。皆是体无。非后刹那。与前有异。少有所因。如前已辩。亦不可说有为法然起。亦应同成大过故。谓诸行起。亦应无因。以执有为法皆然故。是故彼异无体理成。则应以无为有为相。然不应许。故非灭不待因。故我此中。作如是释。现有法灭。不待客因。既不待客因。才生已即灭。若初不灭。后亦应然。以后与初主因等故。既见后有尽。知前念念灭。若谓不然。世现见故。谓世现见。薪等先有。由后与火客因合时。便致灭无。不复见故。定无余量。过现量者。故非诸法灭皆不待客因。岂不应如铃声灯焰。如彼声焰。虽离手风刹那刹那由主因灭而手风合余不更生后声焰无不复可取。如是薪等。由主灭因。令念念灭。后与火合。便于灭位。不为余因。以后不生。不复可取。是故此义。由比量成。非现量得。何谓比量。谓应如生无无因故。以有为法不见不待客主二因。而得生者。谓羯剌蓝。牙墙识等。必待精血水土根等外缘资助。然后得生。若待客因薪等灭者。则有为法。应并如生要待客因然后得灭。而世现见。觉焰音声。不待客因。由主因灭。故一切行灭。皆不待客因。是故诸有为。才生已即灭。灭因常合。故刹那灭义成。有执觉声前因后灭。有执灯焰灭亦住无为因。有执焰灭时。由法非法力。彼皆非理。所以者何。法未已生。无功能故。然不应说二不俱故。以如是难。招他责言。虽二不并。而许前法为后生因。虽二不俱如何不许前因后灭。唯现有论理应答言。前为后生因。以现有体故。未来体未有。宁为前灭因。故彼立因。应如此说。又最后灭。复由何因。住无为因。亦不应理。以无体法不成因故。法与非法。亦非灭因。见空窟中。有焰转故。又于一切有为法中。皆可计度。有此因故。应不更待火等灭因。是故不应执此因义。又若薪等灭。火合为因。于熟变生中。有下中上。应生因体即成灭因。所以者何。谓由火合。能令薪等有熟变生。中上熟生。下中熟灭。即生因体。应成灭因。然理不应因彼此有。即复因彼此法成无。若谓焰生不停住故无斯过者。理亦不然。体类不殊。无决定理。能为生灭二种因故。且于火焰差别生中。容计能生能灭因异。于灰雪酢日地水合。能令薪等熟变生中。如何计度生灭因异。若尔现见煎水减尽。火合于中为何所作。由客火合。主火界增。如如火界渐渐增长。如是如是。能令水聚渐为后位微劣水因。以火与水性相违故。乃至最后位更不能生后。是名火合于中所作。故诸法灭。不待客因。但由主因。令诸法灭。由如是理。证刹那灭义成。是故知身定无行动

说一切有部顺正理论卷第三十三阿毗达磨顺正理论卷第三十四

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩业品第四之二

于正法内。有作是言。身及山等。久住不灭。故契经说。或有一类。身住十年。乃至广说。又说七日羯剌蓝住。又说持地住经一劫。由此知身可得久住。故有行动。为表理成。此义不然。且彼亦许诸心心所有刹那灭。由此可证彼所不许。身及山等刹那灭义。应作是言。身刹那灭。见随心等。有转变故。谓见身相。于起苦乐贪嗔等时。随心等转。既随心等。念念灭法。身有转变。故刹那灭义成。又身与心等安危故。谓身既是刹那灭心所执受故。必安危等。以身有识续住多时。识若离身。即便烂坏。既与刹那灭心等安危故。身应如心必刹那灭。又身如识而宣说故。谓契经言。是心意识。刹那腊缚牟呼栗多。别异而生。别异而灭。又契经说。身于彼彼刹那等位。衰老枯竭。又契经言。苾刍诸行。无有住止。速归坏灭。又言苾刍诸行如幻。或增或减。暂住即灭。又契经说。摩纳缚迦。从入胎夜。乃至衰老。恒速逝往。无住无回。由此等经证知。诸行皆刹那灭。无久住理。而言住者。但约诸行相似相续。假说无违。亦有契经说心有住。如言心住不可移转。又经说。心从初静虑。移入第二静虑等中。又说心调便能住上。又于苦等生已相续多时住中。假说故受。又彼虽许月轮劫住而假说新非假说中即可决定执为实有。又相有别体异义成。非一体中相可有别。现见异体相方别故。如牛有垂[古*頁]。马有旋毛等。于一相续。相既有殊。由此证知。体必有异。乳酪显色。虽复相同。俱行别故。必有异体。谓二显色。甘酢味俱。故体必应前后各别。身亦应尔。既前后位。相有不同。由此比知。举体界聚。前后各别。故刹那灭。其理极成。既一切行。皆刹那灭。如何业果。感赴理成。如何不成。不相及故。谓曾未见种体已灭。犹能生芽。亦非所许。然非诸业如种生芽。于正灭时。与异熟果。又非无法可能为因。是故应无业果感赴。是彼宗过。何谓彼宗。谓譬喻宗。故彼宗说。如外种果感赴理成。如是应知业果感赴。谓如外种。由遇别缘。为亲传因。感果已灭。由此后位遂起根芽茎枝叶等。诸异相法。体虽不住。而相续转。于最后位。复遇别缘。方能为因。生于自果。如是诸业。于相续中。为亲传因。感果已灭。由此于后自相续中。有分位别异相法起。体虽不住而相续转。于最后位。复遇别缘。方能为因。生于自果。虽彼外种非亲为因令自果生。然由展转如是诸业。亦非亲为因令自果生。然由展转力内外因果相续理同。外谓种根芽等。不断名为相续。内法相续。谓前后心。恒无间断。故无外道所难过失。今详彼释一切可然。谓若唯言现在有者。可有相续展转理成。然理不成。故唯有语。彼不成理。余处已说。设许相续展转理成。彼不应如种果道理。现见种等。展转相续。必无间绝。方能生果。心能生果。相续有间。故种果喻。于彼所宗业果感赴。无能证力以入无想二无心定。心等不行。如前已辩。又说意行此中灭故。非至果生一业相续恒无间断。彼宗唯许思是实业。此即意行增长功能。随界习气种子论等。余处已遮。故外难言。无譬喻者所说业果。犹如种果感赴道理。是为正难。阿毗达磨。无心位中。说异熟因相续无断。得体实有。先已成立。即说此得。为相续体。若谓得体与业果别。不应说为业相续者。此难非理。一身果故。身与相续。是一义故。又如业种。业得亦然。故业相续。无有间断。是故我宗业果感赴。同于种果。无理能遮。虽诸业得有间断者。如已灭种。作用虽灭。而有少分与果功能。由此后时。能与自果。业亦应尔。故对法宗。无同彼宗过所随失。后当成立已灭犹有。若谓虽尔仍有异作异受果失。不许有一能作受者。体常住故。此难不然。异有二故。观理者说。异有二种。一者各别相续名异。二一相续体别名异。若别相续所造业因。果必不应余相续受。若一相续所造业因。其果何妨此相续受。岂如异相续无造受能则一相续中亦无造受。若谓各别相续名异。与一相续体别名异。异无别故。如彼此无造受义者。亦不应理。因果相属。不相属故。犹如稻种望稻麦芽。岂由稻种望稻麦芽。二种体异无差别故。即令稻种望稻麦芽。同是相属。或不相属。虽彼稻种望稻麦芽。体异无别。而望稻芽。因果相属。非望麦芽。如是自他相续前后。有属不属。差别理成。故一相续中。无异作受失。又种果异。种灭经久。而见与果。于理无遮。业果亦然。虽异何咎。又一相续。异时为因。异时与果。许无过失。若异相续。异时为因。异时与果。便许有失。如是岂不一异相续。因果有无。分明有异。又如烧村火焰相续。谓如有一欲燎他村。持火烧他草室少分火焰相续。乃至总烧举村屋宇。并成灰烬。村人擒获捶挞令陪。彼自雪言。我持少火。烧少舍已。我火即灭。故我但应陪一握草。彼如是自雪。岂成无过人。智者应知。遍烧村火。皆从初火相续而生。是故彼人。有遍烧过。如是诸蕴相续转变。所生诸果。应知皆是初蕴为因。展转而起。是故诸业。与所依蕴。虽久谢灭。而于后蕴。彼果得生。亦无有失。现见因已灭。果法得生故。如何不见种芽等然。且见世间枸橼酢味。相续转变至果熟时。酢因虽无有酢果起。应知业果理亦应然。刹那灭义成。有业果感赴。是故善说一切有为有刹那故。必无行动。若尔何故现见世间。有时身形行动可得。欲等缘力。能使身形无间异方展转生起。不审察者。起增上慢。谓有实行。现前可取。现见不取。月轮駃行。有时由云。余方疾起便起增上慢。谓见月駃行。如是世间身急回转。谓诸住物。皆急返旋。是故有为皆无行动。无行动故。所说身表。是形差别。其理极成。谓从加行心所生。不住等流大种果。别类形色。不待余显色为眼识生因。能蔽异熟生所长养形色。如是形色。名为身表。非由如是善等性故。令异熟生所长养断。如天眼耳现在前时。余眼耳根相续无断。诸别计有加行心生。于身聚中势力差别。为身无间异方生因。即此生因。名为身表。若尔身表。应非眼见。势力差别即是风故。然经主言。形非实有。谓显色聚。一方多生。即于其中。假立长色。待此长色。于余色聚一面少中。假立短色。于四方面并多生中。假立方色。于一切处遍满生中。假立圆色。所余形色。随应当知。如见火[火*曹]于一方面无间速运。便谓为长。见彼周旋。谓为圆色。故形无实别类色体。若谓实有别类形色。则应一色二根所取。谓于色聚长等差别。眼见身触。俱能了知。由此应成二根取过。理无色处二根所取。然如依触取长等相。如是依显。能取于形。此理不然。了相别故。若一方面。唯显多生。了相于中应无差别。既有长白二了相异。故于显外。别有形色。现见有触同根所取。了相异故。体有差别。如坚与冷。或暖与坚。如是白长。虽同根取。而了相异。故体应别。故知聚色。分析渐微。乃至于中。可生形觉。必有少分形觉生因。形色极微。于中犹起。理必应尔。以色聚中有唯显生形色不起。于中唯有显觉非形。如见空中光明等色。若即显色说名为形。无分量显中亦应起形觉。不相离故。如火界暖。彼火[火*曹]喻。于证无能。余处极成可假说故。谓于余处。有长圆等。所依实因。同时无间。于多方所安布差别所成色聚。长等极成。由是故于火[火*曹]等色。异时别处。无间转中。计度立为假长圆等。未曾见有。世俗胜义俱不极成。而可假立应二根取难亦不成。长等但为意识境故。以诸假有唯是意识所缘境界。如前已辨。能成长等。如种极微如是安布。说为形色。是无分别眼识所取。非身能取。如是形色。如依身根了坚湿等。了长短等。不如是故。以非闇中了坚湿等。即于彼位。或次后时。即能了知长短等相。要于一面多触生中。依身根门。分别触已。方能比度。知触俱行。眼识所牵意识所受。如是相状差别形色。如见火色及臭花香。能忆俱行火触花色。现见眼识随其所应。有于一时形显俱了。意识分别。前后无定。以显与形是一眼识所缘境故。意识分别。时差别故。了相异故。其体不同。形亦非触。宁有身根能取形义。故不应难应二根取。经主于此。复作是言。诸有二法。定不相离。故因取一可得念余。无触与形定不相离。如何取触能定忆形。此亦非理。现见世间。诸触聚中。有形定故。谓形于触。虽无定者。而于一面多触生中。定有长色。于一切处。触遍生中。定有圆色。如是等类。随应当知。故触于形。有决定者。非触于显有定如形。可了触时。能忆形色。以无有触如是安布。于如是显决定如形。又眼喉中。亦得烟触。或时以鼻嗅彼烟香。因此了知烟中显色。亦应显色二根所取。非实物有。又此与彼。义应同故。谓暖触于色及白色于香亦无有定。如形于触不应因彼火色花香。便能念知火触花色故。非由此能遮遣形异于显色别有体义。复有因证形非实有。以诸所有有对实色必应有实别类极微。然无极微名为长等。故即多物如是安布。差别相中。假立长等。岂不已说。即形极微。如是安布。眼识所得。积集差别。假立长等。虽说有此是朋党言。形色极微。非极成故。谓若形色。有别极微。自相极成。可得积集。如是安布以为长等。然非形色有别极微。自相极成。如诸显色。云何得有积集安布。如何具寿。许有极成显色极微。非形细分。如诸显色。一一极微。无独起理。设有独起。以极细故。非眼所得。于积集时。眼可得故。证知定有显色极微。形色极微。亦应如是。宁独不许自相极成。诸有对色。所积集处。皆决定有。极微可得。既于聚色差别生中。有形觉生。不待于显。如不待余。显有余显觉生。是故定应别有如种。能成长等。形色极微。诸显极微。有质碍故。即应积集假立长等。此亦非理。香等极微。亦应积集为长等故。以彼香等。所有极微。亦有质碍。唯据处所。不相容纳。名质碍故。若谓香等所有极微非有见故。无同彼失。则诸显色。所有极微。亦非形故。岂成长等。如何知显微体非形。如前已说。了相异故。不待显色。形觉生故。或有显聚。不见形故。非体是形有多积集。无障有眼。可不见形。是故应知。异于显色。有色处摄。形色极微。由此集成长等假色。故形细分。非不极成。云何是形而无细分。极微无分。应体非形。若尔亦应疑于显色。如何显色。体是有对。而可许有。无分极微。于诸无分受等诸法。未曾见有。名显等故。如显极微显相非有。如是亦有形色极微。而无形相。违何至理。夫显相者。谓能显示青白等性。非显极微。能有所显。故无显相。若异显色。实有形者。应如青黄了然知异。虽各实有。而法性然。故不可知了然有异。如杂余色见影光等。谓影光等。与地等合。杂生识故。别相难知。然其实体。非无有异。夜于粉壁。有净月明。明白相资。二俱显著。体既有异。何不智愚并能了然知其相别。如彼理趣。形显亦然。若显与形。相杂难了。应以正理勤求别相。虽与显色相杂而生。然于其边。能为疆界。摄持显色。是谓为形故破青丸显存形坏。谓圆形色但居其边。故破青丸。圆形即灭。然青显色。遍在丸中。故坏圆形。青显犹在。或形色体。非显体故。不如青黄别相易了。又诸显色。是显体故。与余显色。别相易知。如是形色。是形体故。与余形色。别相易了。故形异显。自相极成。又显与形。虽同一聚。然其体相。决定有殊。有一坏时。一不坏故。以相违因有差别故。非体无异。可由相违。因有差别。有坏不坏。又于色处。有善等别。不应显色有善等性。如前已辩。故有别形。若谓显中自有差别。谓待心起或不待心则已极成。身业实有。但于名想。少有迷谬。然有色处。加行心生。于色聚边。周遍而起。能为疆界。隔别显色。此与显色。非同法故。诸对法者。立以形名。即此说为身有表业。纵说为显。或说名余。且是极成。实有身表。若谓业相不成就故。非实有者。理亦不然。由此如思业相成故。又形与显。如水地风。冷等相殊了相异故。其体各别。何理能遮。又形必应异于显色。以如显色生异类贪别。说不净门为彼对治故。复有至教。证有别形。如颂中说。有粗有细。有短有长。净不净等。又契经说。颜貌端严。非短非长。非粗非细。非白非黑。光洁细软。非无别体。而可别说。又若遮遣行动及形。汝等经部宗。立何为身表。此中经主。辩彼宗言。身表即形。然假非实。如是语义。意趣难知。为长等形是假非实。为成长等如种极微说名为形。是假非实。若长等形。是假非实。与对法者所说无违。若成长等。如种极微。说名为形。是假非实。则不应理。由彼所宗以显成形。显非假故。显若非实。是则经部。同坏法论。不可与言。若意说形体不异显。故言非实。则异火界。无别有暖。亦应非实。设许说言。形非异显。如执异实显无别有形言形非实。如是亦应执异于假显无别有形以执即显色立为长等故。是则经部。应立长等非实非假。如何言假。又经部宗。若执形色有所依揽体实极微。对法诸师。亦作是说。所起诤论。为何所依。为显极微即是长等假所揽实为不尔耶。不尔。如前已成立故。或于显聚有不见有长短等形差别相故由是彼说。成无用言。又彼立假形以为身表。复立何法为身业耶。彼说业依身立为身业。谓能种种运动身思。依身门行。故名身业。语业意业。随其所应。立差别名。当知亦尔。若尔何故契经中。说有二种业。一者思业。二思已业。彼作是释。谓前加行起思惟思我当应为如是如是所应作事。名为思业既思惟已。起作事思。随前所思。作所作事。动身发语。名思已业。此中为摄一切业尽。为摄少分差别业耶。有言。此中摄一切业。有作是说。不摄无漏。此释非与经义相符。此中不应摄意业故。谓为动发身语二种。起思惟思及正动发身语二种起作事思。此二俱依身语门转。并应摄在身语业中。既尔此中。何名意业若依身语二门转思。亦许一分名意业者。是则立业。有杂乱过。纵许为欲动发身语。起思惟思。是意业性。亦非此中总摄诸业。以有不依身语门转有漏意业。其量无边。皆此经中所不摄故。且必不摄依眼触等所起诸思。以彼诸思非前所说。思惟作事。二思摄故。若谓此经所说思业。总摄一切意业皆尽。说思已业。总摄一切依身及语二门转思。且非此经所应说义。设许皆是此经所说。为欲动发身语二种。起思惟思。何业所摄。若思业摄。理必不然。如思惟思。依身语转。许思业摄。余亦应尔。则应但说一思业言。如是亦成业杂乱失。意业亦依身语转故。若谓为欲动发身语。起思惟思。此思不依身语转者。则为余境。起思惟思。彼思亦应不依余境。无异因故。是则意业。应不依境。然非所许。故理不然。若谓此如依身语门。转名依身语非身语业者。此于意业。则应成过。于中亦容此分别故。思已业摄。亦不应理。以后但说思已言故。非所思事可名思惟。以义与名不相应故。又汝经部说。诸仙人意愤杀生。是何业摄。为是身业。为意业耶。然此中无前后所起。思惟作事二思差别。以思惟思即作事故。便不能离业杂乱失。又世尊言。修苦行者。身语意业。各有别异。是故定应许此中有。依身门转。作事思业。由此俱时杀多生故。又杀生业。身业摄故。是则世尊。应言身业于诸业中。最为大罪。是故经部。思立诸业。复有理证。业不唯思谓才起思。欲为杀父等则应已得无间罪等故。若谓得罪要须动身。此未动身。故无失者。是则于思外有身业理成。谓有动身。方有身业。成杀等罪。若不动身。恶思虽起。罪未成故。岂不如执有别身业宗。若离恶思不成无间等。如是虽许唯思是业。若离动身不成此罪。此例非等。所以者何。以对法宗身语二业成无间等。要由恶思。若无恶思。此业不起故身罪业。待恶思成。唯思业宗。说思业起。不待身语。即思生位。已成身业。何假动身。又对法宗。由因等起。思有善等差别性故。所起身语善等性成可言必。待思差别故。身业方成无间罪等。非经部说。思业起时。要待身语。方成善恶。彼许身语唯无记故。如何可说要待动身思业方成。无间罪等。故引此例。不遮彼失。若谓如执眼根见宗。虽眼根生非待眼识。而见色用。待识方成。如是唯言思是业者。不善思起。虽不待身。而要待动身方便无间等。此亦非例。所以者何。以识与根有俱时起。许根由识有胜用生。故眼根生。虽不待识。而见色用。待识方成。然彼恶思。要先生已。后时方有运动身义。非思生位。由后动身。少令前思起差别用。又此所救。理必不成。无法无能。令诸有法起胜用故。复有至教。遮经部宗。安立业理。如契经说。夜所寻思。至于昼时。由身语表。非此中说能表谓思。余契经中。说表即业。故余经说。诸爱者表体即是业。又佛教诫罗怙罗言。汝若由身由语造业。于此所造身语业中。应当正勤。数审观察。非思即用身语为体。如何可言思所造业名由身语所造业耶。是故应知。契经即说身语二表。为身语业。不应如是取此经义。此经所言。由身由语。此造业者。是由依身及依语思所造业义。无如是义。所以者何。曾不说故。又不遮故。谓若有经。曾作是说。依身语思。所造诸业。名身语业。非即身语。又若有经遮身语表。即是身语二业自性。容可于此无差别言。准彼契经。作差别释。然曾无处有如是言。又我引经不违正理。故彼非理。频率己情。释破诸经。令乖实义。理应名曰坏经部师。非了义经为定量故。又伽他说

  由内心粗恶　　外动身发语
  因此能感苦　　翻此便招乐

此中说思及身语表。能感爱果。非爱果义。余经又言。诸邪见者。所有身业语业意业。一切皆能感非爱果。感爱果者。与此相违。由此证知。伽他中说。因身语二表。感爱非爱果。即是经中。说身语业能感爱果非爱果。义亦不应。谓依身语思名身语表。由彼自说形为身表。假非实故。然思不应是形非实。又契经说。起迎合掌恭敬礼拜。是身表业。余经又言。表即是业。由此证知欲作意等。展转所起。手等别形。名为身表。即是身业。故对法宗。立身语业。符教顺理。无杂乱过。由此所说四句理成。然于此中。诵者差别。谓有诵者。作是诵言。或有色聚。唯显可了。谓青等影等大种造色聚。以于其中显色多故。余非定取故。唯显色可了。空一显者。谓见空中。苏迷卢山。所现纯色。岂影等色。有种种显。而但说此是一显耶不尔。云何。以影等色与地等显和杂难辩。不可别见。依不纯义。说非一显。此空界色。无别所依。以纯可见。故名一显。或有色聚。唯形可了。谓身表俱大造动聚。以动摄受相续法性。假施设故。体非真实。但身聚中心所等起等流大造。实物聚中诸形差别。是谓身表。或有色聚。二俱可了。谓所说余诸形显聚。以非于此聚离一可取余故。此义中经主前难如何。一事有二体者。此难不成。非所许故。复有形显。互相依属。如说鹭非幡及幡非乌等。此中形显俱可了知。或有色聚。俱非可了。如香味等。及无表聚。有余诵者。作是诵言。或有色聚。唯有显等第一句者。谓明闇聚。即此差别。说为影光。第二句者。谓如前说。第三句者。谓前所说二句不摄。俱色处聚。青等色聚。亦有长等。形量差别。现可见故。第四句者。亦如前说。岂不影等亦有形量分明可见。应名俱有。彼言影等聚中无形。以虚散故。余极碍物。来入其中。彼不坏故。现见世间。和集极碍。有形色聚。余极碍物。来入其中。彼便损坏。影等聚不尔。故于中无形。又诸和集极碍色聚。有形极微。周匝安布。由如是聚形所摄持。便有分限。孔隙可得。非于影等诸色聚边。有形摄持。如和集等。以不见有自动摇故。然有长等形量分明现可得者。随本质故。若尔应无镜等中像。所以然者。如影无形。随本质故。而形可得。如是诸像。应无显色。随本质故。显色可知。又像应非形色为体。虽见有高下。而如画无故。如随本质及随所依。形色虽无。而现似有。显亦应尔似有实无。是则像非形亦非显为体非像显色如影形无诸像所随。不决定故。以像随质及所依故。谓像形显。或时随所依。或时随本质。而显现故。影显曾无随本质理。形亦无有随所依义。此所住处。名曰所依。故像与影。无有同义。若谓像与影随义同故。像应无体者。理亦不然。随义虽同。而见别故。谓像影形。虽同随质。而像随质。亦有高下。影唯随质。有粗分量。于粗分量。随义虽同。而像随质分量决定。影非决定与质量同。或大或小。或时等故。由此像与影随义虽同而但影无形非像无显。若显亦无则无随故。谓于影色有显自成。此影既用显色为体。说形随质可无有过。像体既非形。若亦非显者。则无像体。如何可说像随本质。或随所依故。像定应唯显为体形色分齐。必依极碍。显色分齐。唯依显相。是故影像画等无形。由此已遮像形同难。以彼形相随义虽同然如高下形可取而非有。前已说形色亦比量取故。形色于中非如所取。取不定故。可谓为无显色于中取无不定。同余显取故。像唯显为体。若尔应如影像形色随义虽别而无义等。如是像显及与影形。随义虽别应无义等。此例不然。前已说故。谓像若无显随义亦应无。又汝何缘不作是取。如影与像形随虽同。而于随中非无差别。如是像显及与影形。随义虽同。而有无别。岂不于此应设难言。如影等中。虽无形色。而于显色。现有分量。如是亦应于诸和集极碍色聚唯显无形。此难不然。若诸和集极碍色聚。亦无有形影像应无分量可取。于彩画等。诸工巧人。以余显色。间杂余显。摸仿本质。高下等形。实于其中。无高下等。若诸和集。极碍色聚。亦无实形。唯有显者。应如画等藉余显色间余显色。状似有形。而实于中无高下等。然诸和集极碍色聚。不待余显间余显色。自有高下等实形量可取。由此证知。诸极碍聚。异诸显色。别有实形。由此能令影像画等虽无形色而似有形。是故彼言非为正难。岂不如从非形为体像为其质所生别像。虽现可取。而无实形。如是应从非形为体。诸极碍聚。有影像生。有显无形。然形可取。此亦非理。随本质形。所起像显。似有形故。从此所生像亦似有。形量可得。理必应然。从无形质所起像显所生别像。唯显无形。故像无形。唯显为体。即由如是问答分别。已遣执像影为体论。以像与影非同法故。像如本质。有种种相。影即不然。故非同法。又诸影起。由障光明。光明有处。必无有影。像则不尔。故非同法。又见诸像入水镜中。见影不然。故非同法。又非因影别有影生。像能为因生于别像。故像与影。定非同法。又影不随质有高下。像则不尔。故非同法。是故不应执像即影。然初诵者。作如是言。影等聚中。非无形色。以显增故。唯显可了然诸形色。略有二种。一者谓在和集显色极碍聚边。周匝安布。二者谓在和集显色无碍聚边。周匝安布。唯在和集极碍聚边。形之差别。是名身表。故于此中。无所说过。已辩身表业语表业。云何谓即言声名语表业。何故语表体即语言。身表意业非即身意。以离语言无别声能。表离身及意有色表思业故立。身业名从所依。语业约自性。意业随等起。由此于中无相违过

阿毗达磨顺正理论卷第三十四阿毗达磨顺正理论卷第三十五

        尊者众贤造

        三藏法师玄奘奉　诏译

    辨业品第四之三

如是已辨二表业相。无表业相。初品已辨。然经部言。此亦非实。由先誓限。唯不作故。彼亦依过去大种施设。然过去大种体非有故。又诸无表无色相故。如是诸因。皆不应理。且非唯不作即名无表业。以无表业待胜缘故。谓唯不作。于立誓先与立誓后。无差别故。未立誓位。不作已成。复立誓限。便为无用。若谓不作要待胜缘方可得成。律仪性者。是则应许有别法生。现见世间。待胜缘合。必有有体别法生故。若谓立誓故得阿世耶。应责阿世耶名何所目。谓心心所法。如是差别转。若尔此息位。便失律仪。则应须数数重立誓受。若谓如是不作阿世耶。于一切时恒无息故者。彼言实尔。此体都无。无法无容有起息故。又独静处立誓要期。如此阿世耶。何非律仪性。既许此性必待胜缘。故知定应有胜法起。谓必应有殊胜法性。待如是缘。和合方起。非都无有殊胜法性。因广大教。加行方得。若异此者。是则应同诸婆罗门及离系者。矫设大方便。而空无所得。若谓如是立誓要期要对众前自显心愿。如证悔法方得成者。不服法衣。不落须发。不持应器。但对众前。立誓要期。从今已去。我定不作如是诸恶。应名出家受具戒者。又世现见。彼彼有情。种种施为殊胜加行。便有种种异类法生。既见出家受具戒者。施为种种殊胜加行。比知必定有胜法生。此于我宗。名无表业。纵汝立此名阿世耶。异心无心。恒随相续。此名于理亦无有过。若全无物而立此名。则成第四业道重罪。又彼所言。彼亦依过去大种施设。然过去大种体非有者。理亦不然。应共思择。过去法体。为有为无。方可难故。又过去世地等大种。能为生缘。非所许故。彼曾现在与无表色。能为生缘。今虽过去所生无表。续转无失。又言无表无色相者。理亦不然。前已说故。谓初品内。已辨斯理。无色法中。无此相故。彼约变坏及表示等诸相差别。释总色名。无色法中。无此相故。虽非此义遍一切色。而成无过。训释色词。或应识中亦有此失。以非诸识皆了别故。彼既无过。此宁有失。又释诸色。略有三义。一示现方处义。二触对变坏义。三约色施设义。谓有见色。可示在此在彼方所。故名为色诸有对色。可为手等触对变坏故名为色。诸无见无对色。约色施设。故名为色。非离身语此可施设。以无色界中此施设无故。或如过去未来诸色。虽无变坏等。而亦受色名。此亦应然。故彼非难。又定应许诸无表色是实有性。所以者何。颂曰

  说三无漏色　　增非作等故

论曰。以契经说。色有三种。此三为处。摄一切色。一者有色有见有对。二者有色无见有对。三者有色无见无对。除无表色。更复说何。为此中第三无见无对色。此中上座。率自妄情。改换正文。作如是诵。一者有色无见有对。谓一触处。非所见故。是所触故。二者有色有见无对。谓一色处。是所见故非所触故。三者有色无见无对。谓余八处。非所见故。非所触故。定无有色有见有对。如是诵释。若有信受。或有正理。可许引来遮破我宗所立无表。然彼诵释。不离前来所说过故。曾无余经作此诵故。谁能信受。彼作是说。经部诸师。所诵经中。曾见有此。诸对法者。应专信学。对法诸师。由爱无表。令心倒乱。谬诵此经。故非无经。作如是诵。阿毗达磨诸大论师。实谓奇哉怀贤泛爱。如斯[怡-台+龍]戾越路而行。一类自称经为量者。犹能眷摄为内法人时与评论。甚深理教。然彼所诵。于诸部中。所有圣言。曾不见有。所释义理。违背余经。宁劝智人。令专信学爱无表色。正合其仪。佛于经中。自摄受故。谓象迹喻契经中说。有法处色。故彼经言。具寿此中有诸色法。唯意识境。体是色蕴。法处所摄。无见无对。若离无表。更有何色。说是色蕴法处摄耶。何不许斯是去来色。应十处色不通三世。许眼等去来皆法处摄故。又应违背各别处经。法谓外处。是十一处所不摄法。无见无对。此经遮眼等是法处摄故。又彼过去未来眼等。随应体是有见有对。由此不应是法处摄。又彼勿许过去未来眼等是色。以于尔时无变坏等诸色相故。是则前难。及释此经。自互相违。非为善说。又法处色。决定应有。各别处经。说外法处非如意处。说无色故。以法处中决定有色。不说无色。深为应理。辨本事品。已广分别。如是彼诵。违教理言。但合无知经部所诵。又彼所释。遮隔世尊教所摄受殊胜诸色。对法诸师。若信学此。便为不欲饶益自他。故彼不应劝人信学。由彼一类不乐极成圣教正理。专率己见妄为颂释。惑乱愚人。故我从今渐当舍弃。又彼所诵。非但违经。巨细推征。亦无正理。谓有何理。唯一触处。名为有对。非余碍色。诸有碍色。于自所居。障余用起。故名为对。有此对者。得有对名。现见色处。于自所居。展转相望。能为障碍。声等眼等。相碍亦然。现于所居。互相障碍。而言无对。意趣难知。故上座言。全无正理。又依训释。色取蕴名。证有对名。非唯目触。谓为手等所触对时。即便变坏。名色取蕴。由此足能证色处等皆是有对。所以者何。非唯大种名色取蕴及名手等。可说彼此互相触时。便有变坏。手等总聚。互相触对。则便变坏。是此中义。现见世间。以余聚物。触余聚物。则便变坏。故彼所诵。违正教理。经主于此作是释言。诸瑜伽师。作如是说。修静虑者。定力所生。定境界色。为此第三。非眼根境。故名无见。不障处所。故名无对。此释非理。以一切法皆是意识所缘境故。住空闲者。意识即缘诸有见色。为定境界。此色种类。异余色等。是从定起。大种所生。无障澄清。如空界色。如是理趣。辨本事品。因释梦境。已具分别。应如是责。如何定境。青等长等。显形为性。如余色处非有见摄。然从定起大种所生。极清妙故。又在定中。眼识无故。非眼根境。如中有色。虽具显形。而非生有眼所能见。或如上地色。非下地眼境。既有现在少分色处。不与少分眼根为境。如何不许有少色处。不与一切眼根为境。又于梦中所缘色处。应无见无对。唯意识境故。是故由经说有三色。证无表色。实有理成。又契经中说有无漏色。如契经说。无漏法云何。谓于过去未来现在诸所有色。不起爱恚。乃至识亦然。是名无漏法。除无表色。何法名为此契经中诸无漏色。此中经主。亦作释言。诸瑜伽师。作如是说。即由定力所生色中。依无漏定者。即说为无漏。未审经主。曾于何处逢事何等。诸瑜伽师数引彼言会通圣教。旦曾闻有五百阿罗汉。乃至正法住。不般涅槃。然未曾闻彼有此说。设有此说。于理无违。无漏定俱生所有诸色。以形显为体。不应理故。若许彼非形显为体。是无漏色。依定而生。此即应知是无表色。譬喻者说。无学身中。及外器中。所有诸色。非漏依故。得无漏名。然契经言。有漏法者。诸所有眼。乃至广说。此非漏对治故。得有漏名。为挫彼宗广兴诤论。具如思择有漏相中。故于此中不重弹斥。又非眼等非漏对治得有漏名。勿有世间诸杂染道成无漏过。后于义便。当广成立。世间道中。有能离染。又彼眼等。非如意法。意识说故。谓佛有漏无漏相中。作如是言。堕世间意。堕世间法。堕世间意识。是名有漏。出世间意。出世间法。出世间意识。是名无漏。非眼等中作如是说。故知彼说。但述邪计。然契经中。说无漏色。故无表色。实有理成。又契经说。有福增长。如契经言。诸有净信。若善男子。或善女人。成就有依七福业事。若行若住。若寐若觉。恒时相续。福业渐增。福业续起。无依亦尔。除无表业。若起余心。或无心时。依何法说福业增长。此中上座作如是言。由所施物。福业增长。故如是言。乃至所施房舍久住。能令施主福业增长。恒相续生。又伽他中。亦作是说

  施园林池井　　桥船梯蹬舍
  是人由此故　　昼夜福常增

上座引此。殊未通经。但足自宗拨无表失。谓他先责。若无无表。染心等位。何福犹存。而契经言。福常增长。言福增长由所施物。此于他责。岂曰能通。理实福增。由所施物。然应分别。染心等位。何福不断。而说为增。上座于中未申其理。虽有所说而成无用。又彼自设所疑难言。若于其中。施物不住。如后三种。福云何增。即自释言。由所施食。所生饶益。犹安住故。能令施主施福常增。此亦同前。有所说过。又彼重说。或阿世耶。不忘失故。福常增长。若尔施主染心等位。颇有缘施。忆念犹存。由此故言。不忘失故。彼言不尔。不忘者何。谓阿世耶。离心心所及无表业。此名何义。岂不如是进退推征。彼显佛言都无有义。又彼自问。云何无依福业事中。可作是说。由所施物。福业增长。即自答言。此乘前诵诸有依福言便故来。理实此中无福增义。上座多分。率己妄情。擅立义宗。违诸圣教。不能通释。遂拨极成所违契经。言无实义。如是谤法。岂曰善人。若于契经。不了深义。不言为胜。何辄非拨。又言或由发起浓厚阿世耶故。福亦随增。此亦非理。前已征责。此阿世耶。理不成故。又应舍前所立论故。若无施物。福亦增长。前不应言由所施物相续久住福常增长。经主于此作如是言。先轨范师作如是释。由法尔力福业增长。如如施主所施财物。如是如是。受者受用。由诸受者受用施物功德摄益有差别故。于后施主心虽异缘。而前缘施思所熏习。微细相续。渐渐转变差别而生。由此当来。能感多果。故密意说。恒时相续。福业渐增。福业续起。应问此中何名相续。何名转变。何名差别。彼作是答。思业为先。后后心生。说名相续。即此相续。于后后时。别别而生。说名转变。即此无间。能生果时功力胜前。说名差别。如有取识为命终心。于此心前。虽有种种感后有业。而于此时。唯有极重。或唯串习。或近作业。感果功力。显著非余。诸异熟因。所引相续转变差别。与果功能。与异熟果。已此功能便息。诸同类因所引。相续转变差别。与果功能。若染污者。至得毕竟对治道时。与等流果。功能便息。不染污者。随心相续。至无余依般涅槃位。与等流果。所有功能。方毕竟息。如是所说。即是前来。我所数破。旧随界等。而今但以别异言词。如倡伎人矫易服饰。方便通释所引契经。然彼所言。微细相续转变差别。无少理趣。可令智者录在胸襟。唯有凭虚文词假合。如胜论者所执合德同异和合。无别体故。所以者何。如说心相续有染有净义。即心前后。染净差别。如是相续转变差别。亦应即心前后别义。此心差别。为因得果。此果可有前后差别。然所得果。体种种殊。彼所从因。定应有异。非一心体可有种种。若谓此如钵特摩种。亦不应理。彼多极微合成种故。可有差别。又种芽等。诸相续中。前后相望。势用无别。一心相续。前后相望。有善恶等。势用各别。非无细分。一念识体。可有善等势用不同。又圣教中。许一身有顺现法受等分位差别业。由此为因。如其次第。感现法受等分位差别果。非一心体可能为因。感得如斯分位别果。若谓如种缘合力殊。或能生芽。或生灰等。此亦非理。善不善二因。应俱能招爱非爱果故。然契经说。无是处言。又如种等。虽一相续。而缘合位。不从芽等有芽等生。心亦应然。虽一相续。而缘合位。不从善心生非爱果。亦非爱果从恶心生。故汝应许。于一心相续同时。便有无量心俱生。或应许心如和香饮。有无量体和合而生。或应许因过去有体。或应许果无因而生。如是便成迷失路者。又彼所说。一心相续。于后后位别别而生。名为转变。定不应理。且如有造福行无间即复造作非福行者。此二为是一类转变。为是异类而转变耶。若言此是一类转变。是则应无罪福差别。若言异类而转变者。应说更有何第三心。依之何相名福行转变。复说何相名罪行转变。由如是等种种推征。所计相续转变差别。一切不顺圣教正理。又彼所宗。唯现在有。于一念法。相续不成。相续既无。说何转变。转变无故。差别亦无。由此彼言都无实义。故有别法。若起余心。或无心时。恒现相续。渐渐增长。说名无表。故无表色实有理成。经主此中极为恍惚。不审了达自他宗趣。欲以己过攀他令等。逆述他责。作是释言。若谓如何由余相续德益差别。令余相续心虽异缘而有转变。释此疑难。与无表同。彼复如何由余相续德益差别。令余相续别有真实无表法生。不尔身心互相随故。由施主有福思差别。有如是相。表及无表。前行造色。与四大种。俱时而生。生已无间。此四大种。及所造色。俱时而灭。以俱生故。从此所生。后无表色。嗣前种类。乃至未遇。舍无表缘。恒相续转。如是施主。心虽异缘。而由受者德益差别。福常增长。理不相违。然增长言。显下中等品类差别。诸有为法。外缘所资。法皆然故。或此意显相续转多。故次复言。福业续起。汝宗不尔。所以者何。施主福思差别灭已。无间便有染心续生。受者尔时德益差别。施主由彼染污心增。何用如斯福业增长。若谓别有非染法增。离染污心有何别法。名为福业。说彼渐增宜善思寻求其自体。摽之心首徐当显示。今详汝等无显示能是故汝曹由未承禀妙闲圣教通正理师。大欲居心自立法想妄自举恃。朋经部宗。捧自执尘坌秽圣教。又彼所说无表论者。无依福中。既无表业。宁有无表。此亦不然。善无表业。彼定有故。谓闻某处某方邑中。现有如来或弟子住。生欢喜故。福常增者。彼必应有增上信心。遥向彼方。敬申礼赞。起福表业。及福无表。而自庄严。希亲奉觐。故依无表。说福常增。世尊经中。但说能起。此于福起。为胜因故。除无表色。若起余心。或无心时。必无福业。相续增长。如前已辨。若唯许彼有欢喜心。彼则唯应有意妙行。暂起便息。无常增理。故我决定许彼尔时。必亦应有身语妙行。又非自作。但遣他为。若无无表业。不应成业道。以遣他表非彼业道摄。此业未能正作所作故。使作所作已此性无异故。经主于此作是释言。应如是说。由本加行。使者依教。所作成时。法尔能令教者微细相续转变差别而生。由此当来能感多果。诸有自作事究竟时。当知亦由如是道理。应知即此微细相续转变差别。名为业道。此即于果。假立因名。是身语业。所引果故。彼释非理。微细相续转变差别。前已破故。无容更有释难功能。故于此中重引无用。又彼应说。由能教者。使往余处害余有情。教者后时。若于因果相属道理。得善了知。由此便能生深悔愧。或能发起余胜善心。使者尔时。杀事究竟。能令教者心相续中杀业道生。此心相续。为得爱果。为得非爱果。为俱得二果。理皆不然。杀业尔时。正究竟故。善心无容招苦果故。顺现受等。业成杂乱过故。若谓唯教者发表业思能牵引当来非爱果者。理实应尔。然彼所执。相续转变差别是何。能教者心。既善相续。复执何法。能感当来多非爱果。以能教者。后相续中。无别法生。能多感故。如是所立。不令生喜。然由先表及能起心为加行故。后时教者。虽起善心多时相续。仍有不善。得相续生。使所作成时有力能。引如是类大种及造色生。此所造色生。是根本业道。即彼先表及能起心。在现在时。为因能取今所造色。为等流果。于今正起无表色时。彼在过去能与今果。唯彼先时所起思业。于非爱果。为牵引因。后业道生。能为助满令所引果决定当生。如是所宗。可令生喜。非牵引力即令当来爱非爱果决定当起。除能教者能起表思。若于后时善心相续。乃至使者事究竟时。无表若无。更无别法。于非爱果。能为圆满。助因可得。果应不生。若加行心。即能令果决定当起。不须满因。使者或时不为杀事。教者非爱果亦应决定生。既不许然。故汝经部。于业果理。极为恶立。然上座言于所教者。加行无间。令能教者。为加行生无间罪触。以所遣使事究竟时。教者加行果方成故。此中彼执无间是何为母等亡为所生罪。若谓无间即母等亡。应离杀思亦成无间。若谓无间是所生罪。彼所教者事究竟时。能教者思。若是染污。可为无间重罪所触。若能教者。正起善思。使者尔时杀事究竟。彼能教者。有何罪生。如何发言。都无忌惮。说彼无间重罪所触。是故定应许实无表。若自不作。但遣他为。由无表生。成业道罪。又若无无表。应无八道。支以在定时语等无故。经主于此作如是责。且彼应说正在道时。如何得有正语业命。为于此位有发正言起正作业求衣等不。此责非理。佛语同故。经部诸师。亦应被责。正在道位。为有发言。及起作业。求衣等不。如何佛言正语业命。道支所摄。故责应同。然彼释言。虽无无表。而在道位。获得如斯意乐依止。故出观后。由前势力。能起三正。不起三邪。以于因中立果名故。可具安立八圣道支。彼释不然。应正见等同此释故。谓正见等。亦应可为如是计度。虽在道位无正见等。而得如斯意乐依止。故出观后。由前势力。起正见等。邪见等无。以于因中立果名故。可具安立八圣道支。然非观中无正见等。若无正见等。道亦应无故。由如是理。对法诸师。应作是例。如正见等正在道时。实有自体亦应实有。正语业命。诸无漏戒。如在观时。得正见等。于出观后。不同异生起邪见等。如是观中。得正语等。于出观后。不同异生起邪语等。如何所起不同异生。谓预流等。虽起染心习欲等事。而不可说起邪思惟及邪语等。同于观中。得彼对治。唯许别有正见等体。非正语等。斯有何理。又有何理。许依正见等假立正语等。非此相违。或应不许别有彼体。故彼所宗。非为善立。又如见定戒亦应然。说此皆通学无学故。谓契经说。有学尸罗。无学尸罗。有学三摩地无学三摩地。有学般若无学般若。若谓尸罗于正见等假安立者。别说尸罗。通学无学。便为无用。上座意谓堪能不作身语恶行。名正语等。由圣道力。转相续故。于二恶行。堪能不作。故正语等。非别有体。若尔正见。亦应唯是堪能不作意恶行性。所以者何。由圣道力。转相续故。于意恶行。堪能不作。即名正见。非别有体。经说。邪见名意恶行。今于此中。有何别理。一许有体。一则不然。故彼所言。都无实义。又应问彼。堪能不作。体是何法。彼言。即是胜阿世耶。所随善净心心所法。此如前破。前破者何。谓彼止息起染等心。应失律仪。如未得位。非于息位。有少如前胜阿世耶。所随逐法。可立不作殊胜想名非染等心。亦可得说名堪不作语恶行等。先所说过。皆应集此。又彼所说。言尸罗者。是串习义。是故尸罗无别实体。彼说不然。虽串习义而别说故。定别有体。如契经说。若已善修戒定慧三。修即串习。若唯串习名尸罗者。契经不应别说修戒。理不应说修串习故。若修定慧。即名尸罗。是则不应言修三种。又契经说。依住尸罗。修习二法。岂应说言依住修习。修习二法。今详具寿觉慧所行。唯凭世典作关圣教。故无表色。实有理成。虽彼有多余无端说。而皆不越前来所破。恐文烦重不别遮遣。且由前说。无表足成。此无表名。为目何体。目远离体。远离非作。非造无表。一体异名。非唯遮作即名无表。如世间说。非婆罗门。世共了知。别目一类。业为因故。如彩画业。此无表色。亦立业名。因表因思。而得生故。为诸无表皆二力生。不尔。云何。唯欲界系所有无表。可由强力二因所生。以欲界思非等引故。离身语表。无有功能。发无表业。静虑俱思定力持故。不待于表有胜功能。发无表业。由此无表。虽非是业。业为因故。亦得业名。不可受等亦名为业。以止息表业。立无表业故。非止息业而立受等。是故受等。虽业为因。无同无表亦名业过。又诸无表。以业为因。非为业因。受等与业。互为因果。是故无有同无表失。无表亦用非业为因。何缘不许亦名非业。亦许非业以非作故。但业为因。故亦名业。世尊亦说。非作名业。如说。云何名白白异熟业。谓五尸罗七种尸罗。乃至广说。解声明者。亦于非作眠及住位。以业声说。亦见世间。于非作位。同有所作。立作业名。如问天授汝作何业。答言。我今作眠或住。故同世俗言说无失。若尔欲界初念无表。不应建立无表业名。与表业俱。止息表业。理不成故。此难非理。以初无表是止息表。无表种类。后随初念相续转故。谓初刹那表俱无表。是后息表无表业类。许彼相望种类同故。虽与表业俱时而生。而得立为无表业体。皆由表业而得生故。或善无表止息恶业。不善无表止息善业故虽初念与表俱生。而亦得说名无表业。远离非作非造业名。准斯例释。皆无有过。无表与表。俱所造色。所依大种。为异为同。颂曰

  此能造大种　　异于表所依

论曰。无表与表。虽有俱生。然能生因大种各异。粗细两果。因必异故。生因和合有差别故。一切所造色多与生因大种俱生。然现在未来。亦有少分因过去者。少分者何。颂曰

  欲后念无表　　依过大种生

论曰。唯欲界系初刹那后。所有无表从过大生。谓欲界所系初念无表。与能生大种俱时而生。此大种生已。能为一切未来自相续无表生因。此与初刹那无表俱灭已。第二念等无表生时。一切皆是前过去大所造。此过大种。为后后念无表所依。能引发故。与后后念无表俱起。身中大种。但能为依。此大种若无。无表不转故。如是前俱二四大种。望后诸无表。为转随转因。譬如轮行因手依地。手能引发。地但为依。前俱大种。应知亦尔。大种通五地。身语业亦然。何地身语业。何地大种造。颂曰

  有漏自地依　　无漏随生处

论曰。身语二业。略有二种。一者有漏。二者无漏。若有漏者。五地所系。欲界所系。身语二业。唯欲界系。大种所造。如是乃至。第四静虑。身语二业。唯是彼地。大种所造。若无漏者。依五地身。随生此地。应起现前。即是此地大种所造。以无漏法不堕界故。必无大种。是无漏故。由所依力。无漏生故。表无表业。其类是何。复是何类。大种所造。颂曰

  无表无执受　　亦等流情数
  散依等流性　　有受异大生
  定生依长养　　无受无异大
  表唯等流性　　属身有执受

论曰。今此颂中。先辨无表。诸无表业。略有二种。定不定地。有差别故。然其总相。皆无执受。与有执受。相相违故。唯善不善故。非异熟生。无极微集故。非所长养。有同类因故。有是等流。亦言为显有刹那性。谓初无漏俱生无表。待识生故。有情数摄。若就差别。分别所依。不定地中。所有无表。等流有受异大种生异大生言显身语七。一一是别大种所造。定生无表差别有二。谓诸静虑无漏律仪。此二俱依定所长养。无受无异。大种所生。无异大言。显此无表。七支同一。具四大种。所造应知。有表唯是等流。此若属身。是有执受。余义皆与散无表同。谓有情数。及依等流。有受别异。四大种起。何缘散地。所有无表。能造大种。唯等流性。定地无表。所长养生。以殊胜心现在前位。必能长养大种诸根。故定心俱必有殊胜长养大种。能作生因。造定心俱所有无表散地无表因等起心。不俱时故。在无心位。亦有起故。所依大种。唯是等流。因等起心。不能长养能生无表诸大种故。若尔散地无表所依。谁等流果。有作是说。是次前灭大种等流。能造无对所有大种。非造有对大种等流。果有细粗。种类别故。如是说者。从无始来。定有能造无对造色。已灭大种。为同类因。能生今时等流大种。造有表业大种亦应是无始来。同类大种之等流果。非从异类定生无表。所依大种无执受者。定心果故。必无爱心执此大种以为现在内自体故。又此大种。无有其余执受相故。名无执受。散地无表。所依大种。有执受者。散心果故。以有爱心。执为现在内自体故。如显色等所依大种。系属依身。而得生故。亦可毁坏。外物触时。可生苦乐。何缘定心所生无表。是无别异大种所生。散无表生依别异大。定生无表。七支相望。展转力生同一果故。唯从一具四大种生。散此相违故依异大。有说。若彼同一生因。随越一时。应舍一切定生无表。七支相望。生因既同。必顿舍故。岂不如对一切有情相续所生。远离杀戒。虽同一具大种所生。非越一时顿舍一切。七支相对。理亦应然。此例不然。彼虽一具大种所造。然其所对。一一有情相续异故。若七支戒。无异大生。所对有情。相续既一。何缘越一非舍一切。是故此彼为例不齐。若尔此应同命根理。如命根体。为具身依。身不具时。亦为依止。故身虽缺。随有余根命犹能持。令不断坏。如是一具大种为因。能生律仪具不具果。故支虽缺。随有余支。大犹能持。令不断坏。此亦非例。以彼命根先与缺身俱时而起。中间有与具身俱生。后缺减时。复有俱起。故于具缺各别任持。大种不然。一具大种。为一相续。无表生因。若与七支。为生因者。未尝暂与缺支俱生。如何缺一时。持余令不舍。即由此理。从无贪等为因所生。离杀等戒。虽有对一有情相续。而越一时非舍一切。以是各别大种果故。大种别者。果类别故。虽对别异有情相续。发多无贪所生无表。而但一具大种为因。以所生果类无别故。由是若对一有情身。一具七支生因同者。则随越一应舍一切。如是立证。理亦可成。故散七支。依别大种。然依不许别舍律仪。此证不成。前说为善。如天眼起非坏本形。表色生时。理亦应尔。故虽身表在身中生。而无异熟色断已更续过。亦无一具大种聚中有二形色俱时起过。以诸身表别有等流大种新生。为所依故。随依身分。表色生时。此一分身。应大于本大及形色极微增故。然不现见。其理如何。有释此言。以表及大相微薄故。如染支体。然不见有大相可得。有说。身中有孔窍故。虽得相容纳而。不大于本

说一切有部顺正理论卷第三十五阿毗达磨顺正理论卷第三十六

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩业品第四之四

已辩业门略有二种。谓思思已业差别故。复有三种。谓身语意业差别故。复有五种。谓身语二各表无表。及思惟一业差别故。如是五业性及界地建立云何。颂曰

  无表记余三　　不善唯在欲
  无表遍欲色　　表唯有伺二
  欲无有覆表　　以无等起故

论曰。无表唯通善不善性无有无记。所以者何。是强力心所等起故。无记心劣无有功能为因等起引强力业。令于后后余心位中。及无心时亦恒续起。所言余者。谓二表及思三谓皆通善不善无记。于中不善在欲非余。有不善根无惭愧故。善及无记随其所应三界皆有。不别遮故。欲色二界皆有无表。决定不在无色界中。以无色界中有伏色想故。厌背诸色入无色定。故彼定中不能生色。或随何处有身语转唯是处有身语律仪。有作是言。以无色界无大种故无无表色。彼但能遮有漏无表。无漏无表无理能遮。谓无色中无大种故。堕界系地有漏律仪必定无容是别界地大种所造故。无色无无漏律仪。既许得为别界别地大种所造。无色界有何理能遮。是故前说于理无过。毗婆沙师作如是说。为治恶戒故起尸罗。唯欲界中有诸恶戒。无色于欲具四种远。一所依远。二行相远。三所缘远。四对治远。所依远者。谓于等至入出位中。等无间缘为所依体。无容有故。行相远者。谓无色心毕竟无能于欲界法作苦粗等诸行相故。所缘远义类此应知。由无色心但能以下第四静虑有漏诸法。为苦粗等行相所缘。对治远者。谓若未离欲界贪时。必定无容起无色定。能为欲界恶戒等法厌坏及断二对治故。非不能缘可能厌坏。故无色界无无表色。表色唯在二有伺地。谓通欲界初静虑中。非上地中可言有表。说有伺者。为显一切初静虑中遍有表业。若于上地表业全无。语表既无何有声处。有外大种为因发声不遮外声故无有失。有余师说。上三静虑亦有无覆无记表业理必应尔。上三地中起三识身既无有失。如何不起发表业心。然善染心上不起下下善下染劣故断故。由是生上无善染表。前说为善。所以者何。虽彼现前非彼系故。有覆无记表欲界定无。唯初静虑中可得说有。曾闻大梵有诳谄言。谓自众中为避马胜所征问故矫自叹等。复以何缘二定以上都无表业。于欲界中无有有覆无记表业。以无发业等起心故。有寻伺心能发表业。二定以上都无此心。岂不前言生上三地如亦得起下三识身。发表业心如何不起。岂不已说依上地身虽得现前而非彼系。有作是说。依余地身非起余地心能发身语表。若尔经说世尊一时升净居天。彼诸天众礼拜赞叹供养世尊。此经应成有语无义。又闻经说净居天等来诣佛所赞礼问难。故生余地起余地心发身语表于理无失。然如识身等非彼地所系。又发表心唯修所断。见所断惑内门转故。以欲界中决定无有有覆无记修所断惑。是故表业上三地都无。欲界中无有覆无记表。为但由等起令诸法成善不善性等。不尔。云何。由四种因成善性等。一由胜义。二由自性。三由相应。四由等起。何法何性由何因成。颂曰

  胜义善解脱　　自性惭愧根
  相应彼相应　　等起色业等
  翻此名不善　　胜无记二常

论曰。胜义善者。谓真解脱以安隐义说名为善。谓涅槃中众苦永寂最极安隐犹如无病。此由胜义安立善名。是故涅槃名胜义善。或真解脱是胜是义得胜义名。胜谓最尊无与等者。义谓别有真实体性。此显涅槃无等实有故名胜义。如是胜义安隐名善。如是涅槃是善常故。于一切法其体最尊。是故独摽为胜义善。自性善者。谓惭愧根。以有为中唯惭与愧及无贪等三种善根。不待相应及余等起体性是善。犹如良药。相应善者。谓彼相应以心心所要与惭愧善根相应方成善性。若不与彼惭等相应善性不成。如杂药水。等起善者。谓身语业生等及得二无心定。以是自性及相应善所等起故立等起名。如良药汁所引生乳。因异类心亦起诸得。如因静虑得通果心。胜无记心现在前故。得诸染法。胜染污心现在前故。得诸善法。此等如何成善等性。以就彼法俱生得故密作是言。非异类心不作缘起故无有失。虽异类心亦为缘起。而成善等非待彼心。或复因彼诸得等起。即待彼故成善等性故。得由等起成善等性异。如说善性四种差别。不善四种与此相违。云何相违。胜义不善。谓生死法由生死中。诸法皆以苦为自性。极不安隐犹如痼疾。自性不善。谓无惭愧三不善根。由有漏中唯无惭愧及贪嗔等三不善根不待相应及余等起。体是不善犹如毒药。相应不善。谓彼相应由心心所法。要与无惭愧不善根相应。方成不善性。异则不然如杂毒水。等起不善。谓身语业生等及得。以是自性相应不善所等起故。如毒药汁所引生乳。若尔应无一有漏法是无记或善。皆生死摄故一切皆应是不善摄。虽据胜义理实应然。而于此中约异熟说。诸有漏法若不能记异熟果者立无记名。于中若能记爱异熟说名为善。有为无记有漏善法以起少苦犹如轻病。亦得名为胜义不善。如善不善既有胜义。亦有胜义无记法耶。亦有。云何。谓二常法以非择灭及太虚空更无异门。唯无记性。是故独立胜义无记。无别自性相应等起。无一心所唯无记性。与无记心遍相应故。设方便立自性等三亦摄不尽无记多故。由是无记唯有二种。一者胜义。二者自性。有为无记是自性摄。不待别因成无记故。无为无记是胜义摄。以性是常无异门故。若等起力令身语业成善不善。此身语业所依大种例亦应然。俱从一心所等起故。此难非理。以作者心本欲起业非大种故。谓无作者于大种中发起乐欲。我当引发如是种类大种现前。由此为门善恶心起。又世现见身语二业待心而生。未曾见有身语二业离心而起。然四大种离心亦生。故知彼法非待心起。又如眼等不待心生。其性便无善等差别。如是大种不待心生。故理亦无善等差别。若尔诸得及生等相。应无等起善等差别。以非本心所欲起故。无心位中亦现起故。此难非理。由法势力安立善等差别成故。谓得四相依法而立。非如大种无待自成。有为法中无有一法不待心力成善不善。是故诸得及生等相如所属法。要由心力成善等性其理善成。生已离心虽相续转亦无有过。即是前心势力所引令其转故。随定无表定等力生理亦应成。等起善性天眼天耳应善性摄。以是善心所等起故。此难非理。以彼二通解脱道心是无记故。彼二与道俱时生故。通斯似难何费劬劳。如上所言身语二业由等起力成善不善。等起有几。何等起力令身语业成善不善。等起相望差别云何。颂曰

  等起有二种　　因及彼刹那
  如次第应知　　名转名随转
  见断识唯转　　唯随转五识
  修断意通二　　无漏异熟非
  于转善等性　　随转各容三
  牟尼善必同　　无记随或善

论曰。身语二业等起有二。谓因等起。刹那等起。在先为因故。彼刹那有故。如次初名转。第二名随转。谓因等起将作业时作是思惟。我今当作如是如是所应作业。能引发故说名为转。刹那等起正作业时。与先转心所引发业。俱时行故说名随转。若无随转虽有先因为能引发。如无心位或如死尸。表应不转随转。于表有转功能无表不依随转而转。无心亦有无表转故。如上所言见所断惑内门转故不能发表。若尔何缘薄伽梵说由邪见故起邪思惟邪语邪业及邪命等。此不相违见所断识于发表业但能为转。于能起表寻伺生中为资粮故不为随转。于外门心正起业时此无有故。由此故说见所断心为因等起发身语业。定不能为刹那等起见所断识。虽能思量而无功能动身发语。然于动发一表业中。容有多心思量动发。唯后一念与表俱行。异此表应非刹那性见所断识。虽能为转发有表业然非表业。于此识后无间即生内门转心。不能引起与身语表俱行识故。若异此者见所断心亦应于表业为刹那等起。以修所断加行意识能无间引表俱行心。亦与表俱行为刹那等起故。见所断虽能为因引诸表业。离修所断因等起心表俱行心无容得起。是故欲界无有有覆无记表业。然契经中但据展转为因等起。密作是言。由邪见故起邪语等。阿毗达磨据彼不能无间引生表俱行识。故密意说见所断心内门转故不能发表。是故经论理不相违。又见所断若发表色。此色则应是见所断。色非见断已广成立。若五识身唯作随转无分别故外门起故。修断意识有通二种。有分别故外门起故。由此应成四句分别。有转非随转。谓见所断心。有随转非转。谓眼等五识。有转亦随转。谓修所断一分意识。有非转非随转。谓余一切修所成识。以修所成无分别故。然说无漏异熟非者。此有太减及太过失。有漏定心亦俱非故。诸异熟识但可非转能为随转何理能遮。然经主言。不由加行任运转故。诸异熟识非转随转。有余复言。此唯先业势力所引余心息位方可现前故非二种。设此能起身语表业是何性类。为异熟生为威仪路为工巧处。且非异熟生现加行起故。亦非余二种异熟心起故。如是理趣但可能遮。异熟生心为因等起余心为转。所发表业异熟生心外门转故能为随转。何理相违。且若无心表业不转许表业转。用异熟识为随转因斯有何过。又但应说异熟生心势微劣故非因等起。不应说言不由加行任运转故。勿生得善亦不为因发有表业。亦非加行任运转故。由此经主有减增失。因复非因智者应了。转随转识性必同耶。不尔。云何。谓前转识若是善性。后随转识通善等三。不善无记为转亦尔。唯牟尼尊转随转识多分同性少有不同。谓转若善心随转亦善。转心若无记随转亦然。于续刹那定无迷故。而或有位善随无记转。曾无有时无记随善转。以佛世尊于说法等心或增长无萎歇故。有余部说。诸佛世尊常在定故心唯是善无无记心。故契经说

  那伽行在定　　那伽住在定
  那伽坐在定　　那伽卧在定

毗婆沙师作如是释。此显佛意必正知生。亦无有心不随欲起。于境无乱故立定名。非佛世尊无威仪路异熟生识及通果心。起此等心于理无失。既说善等转随转各三。准此标释中足为明证。所发诸业成善恶等。随因等起非随刹那。异此善心所引发业。既与不善无记心俱。何理能遮成恶无记。是则应有从别思惟为因引生别性类业。如是勤励欲为善者。翻有不善无记业生。或此相违便乖正理故。业成善等定由转力。非由随转力。其理善成。然随定心诸无表业与俱时起心一果故。由随转力善性得成。定属此心而得生故。经主于此标释理中不审了知。复作是责。诸有表业成善等性。为如转心为如随转。设尔何失。若如转者则欲界中应有有覆无记表业。身见边见能为转故。或应简别非一切种见所断心皆能为转。若如随转恶无记心俱得别解脱表应非善性。于此征难应设劬劳。未审此言何密意说。为劝对法诸大论师令设劬劳为当自劝。若劝对法诸大论师。彼于此中已勤方便善思善说何复劝为。如其自劝即知经主于斯义理未设劬劳。今正见生方能自省。未能解了对法所宗。幸自精勤求标释理。又作是说。若表不由随转心力成善等者。则不应言彼经但据前因等起非据刹那。故欲界中定无有覆无记表业。彼谓此说表成善等性决定。但由刹那等起力故。见所断惑虽为因等起。而欲界定无有覆无记业。此由经主不达我宗所有言义故作是说。此说意言若见所断惑为刹那等起与业俱行。是则不应隔修所断能起表业因等起心。则欲界中何缘无有有覆无记身语表业。然见所断惑。尚不能为因无间引生业俱行识。何能自作刹那等起。说不能作刹那等起。显不能为近因等起。但有能作近因等起者。此必能为刹那等起。故身见边见虽为远因引身语表。而由修断近因势力成不善性。是故说言彼经但据前因等起非据刹那。故欲界中定无有覆无记表业。若不尔者。则不应言彼经但据前因等起。前言为显隔近因故。简近因故说前因言。故彼此中不达言义辨业界地。傍论已周。复应辨前表无表相。颂曰

  无表三律仪　　不律仪非二

论曰。应知无表略说有三。一者律仪。二不律仪。三者非二。谓非律仪非不律仪。能遮能灭恶戒相续故名律仪。如是律仪差别有几。颂曰

  律仪别解脱　　静虑及道生

论曰。律仪差别略有三种一别解脱律仪。谓欲廛戒。二静虑生律仪。谓色廛戒。三道生律仪。谓无漏戒。初律仪相差别云何。颂曰

  初律仪八种　　实体唯有四
  形转名异故　　各别不相违

论曰。别解脱律仪相差别有八。一苾刍律仪。二苾刍尼律仪。三正学律仪。四勤策律仪。五勤策女律仪。六邬波索迦律仪。七邬波斯迦律仪。八邬波婆娑律仪。如是八种律仪相差别。总名第一别解脱律仪。此中依能修离恶行及离欲行补特伽罗。安立前五律仪差别。以如是类补特伽罗。乃至命终能离杀等诸恶行故。及能远离非梵行故。次复依能修离恶行非离欲行补特伽罗。安立尽形在家二众律仪差别。以如是类补特伽罗乃至命终能离杀等诸恶行故。不能远离非梵行故。由是经中但作是说。离欲邪行非非梵行。后复依能修非全离恶行欲行补特伽罗。安立在家一昼一夜律仪差别。以如是类补特伽罗不能全离恶行诸欲。为令渐习全离恶行及诸欲行方便住。故虽名有八实体唯四。一苾刍律仪。二勤策律仪。三近事律仪。四近住律仪。唯此四种别解律仪皆有体实相各别故。所以者何。离苾刍律仪无别苾刍尼律仪。离勤策律仪无别正学勤策女律仪。离近事律仪无别近事女律仪。云何知然。由形改转。体虽无舍得而名有异故。形谓形相即男女根。由此二根男女形别。但由形转令诸律仪名为苾刍苾刍尼等。谓转根位令本苾刍律仪名苾刍尼律仪。或苾刍尼律仪名苾刍律仪。令本勤策律仪名勤策女律仪。或勤策女律仪及正学律仪名勤策律仪。令本近事律仪名近事女律仪。或近事女律仪名近事律仪。非转根位有舍先得得先未得律仪因缘。故四律仪非异三体。若从近事律仪受勤策律仪。复从勤策律仪受苾刍律仪。此三律仪为由增足远离方便立别别名。如只双金钱及五十二十为体各别。具足顿生三种律仪。体不相杂其相各别。具足顿生三律仪中具三离杀。一一离杀其体各异。余随所应当知亦尔。由因缘别故体不同。如如求受多种学处。如是如是能离多种高广床座饮诸酒等憍逸处时。即离众多杀等缘起。以诸远离依因缘发。故因缘别远离有异。若无此事舍苾刍律仪。尔时则应三律仪皆舍。前二摄在后一中故。既不许然故三各别。然此三种互不相违。于一身中俱时而转。非由受后舍前律仪勿舍苾刍戒便非近事等。先已舍彼二律仪故。若有勤策受近事律仪。或有苾刍受前二种戒为受得不。有作是言。此不应责。若前已有无更得理。先已得故。若前未有则非勤策亦非苾刍。以先不受近事律仪必无受得勤策戒理。若先不受勤策律仪亦无受得苾刍戒理。是则不可立彼二名。以此推寻受应不得。有余师说。不受前律仪亦有即能受得后戒理。故持律者作是诵言。虽于先时不受勤策戒。而今但受具足律仪者亦名善受具足律仪。由此勤策容有受得近事律仪。苾刍容有受得勤策近事戒理。岂不勤策。不应自称唯愿证知我是近事。苾刍亦尔不应自称唯愿证知我是前二。非离如是自称号言有得近事勤策戒理。此难非理俱可称故。谓可称言我是勤策亦是近事唯愿证知。苾刍亦应如应而说。然就胜戒显彼二名亦无有失。若尔勤策及苾刍等。亦应受得近住律仪。如得近事许亦何过。然由下劣无欣受者。近事近住勤策苾刍四种律仪云何安立。颂曰

  受离五八十　　一切所应离
  立近事近住　　勤策及苾刍

论曰。应知此中如数次第依四远离立四律仪。谓受离五所应离法。建立第一近事律仪。何等为五所应离法。一者杀生。二不与取。三欲邪行。四虚诳语。五饮诸酒。若受离八所应离法。建立第二近住律仪。何等为八所应离法。一者杀生。二不与取。三非梵行。四虚诳语。五饮诸酒。六涂饰香鬘舞歌观听。七眠坐高广严丽床座。八食非时食。若受离十所应离法。建立第三勤策律仪。何等为十所应离法。谓于前八涂饰香鬘舞歌观听开为二种。复加受畜金银等宝以为第十。为引怖怯众多学处在家有情显易受持。故于八戒合二为一。如佛为栗氏子略说学处有三。若受离一切应离身语业。建立第四苾刍律仪。别解脱律仪众名差别者。颂曰

  俱得名尸罗　　妙行业律仪
  唯初表无表　　名别解业道

论曰。以清凉故名曰尸罗。此中尸罗是平治义。故字相处作是释言。平治义中置尸罗界。戒能平险业故得名尸罗。智者称扬故名妙行。或修行此得爱果故。所作自体故名为业。虽契经中说诸无表名为非造。亦名非作。以有惭耻受无表力不造恶故。而有作义如前已辨。亦名律仪如前已释。如是应知别解脱戒通初后位无差别名。唯初刹那表及无表。得别解脱及业道名。谓受戒时初表无表别别弃舍种种恶故。依初别舍义立别解脱名。或初所应修故名别解脱。或彼初起最能超过如狱险恶趣故名别解脱。即初刹那表与无表。亦得名为根本业道。初防身语畅思业故从第二念乃至未舍不名别解脱。名别解脱律仪。不名业道名为后起。已辨安立差别律仪。当辩律仪成就差别。谁成就何律仪。颂曰

  八成别解脱　　得静虑圣者
  成静虑道生　　后二随心转

论曰。八众皆成就别解脱律仪。谓从苾刍乃至近住。外道无有所受戒耶。虽有不名别解脱戒。由彼所受无有功能永脱诸恶。依著有故。静虑生者。谓此律仪由从或依静虑生故。若得静虑者定成此律仪。静虑眷属亦名静虑。道生律仪圣者皆成就。此复二种。谓学及无学。于前所说三律仪中。何等律仪随心而转。唯后二种。谓静虑生及道生。二非别解脱。所以者何。异心无心亦恒转故。静虑无漏二种律仪亦名断律仪。依何位建立。颂曰

  未至九无间　　俱生二名断

论曰。未至定中九无间道俱生静虑无漏律仪。以能永断欲廛恶戒及能起惑名断律仪。唯未至定中有断对治故。由此但摄九无间道。此中尸罗灭恶戒故。由此或有静虑律仪非断律仪。应作四句。第一句者。除未至定九无间道有漏律仪。所余有漏静虑律仪。第二句者。依未至定九无间道无漏律仪。第三句者。依未至定九无间道有漏律仪。第四句者。除未至定九无间道无漏律仪。所余一切无漏律仪。如是或有无漏律仪非断律仪。应作四句。谓前四句逆次应知。若尔世尊所说略戒

  身律仪善哉　　善哉语律仪
  意律仪善哉　　善哉遍律仪

又契经说。应善守护应善安住眼根律仪。此意根律仪以何为自性。此二自性非无表色。若尔是何。颂曰

  正知正念合　　名意根律仪

论曰。意根律仪一一各用正知正念合为自体。故契经说。眼见色已不喜不忧。恒安住舍正知正念。如是乃至意了法已。列别名已重说合言遮谓二律仪如次二为体。今应思择表及无表谁成就何齐何时分。且辨成无表律仪不律仪。颂曰

  住别解无表　　未舍恒成现
  刹那后成过　　不律仪亦然
  得静虑律仪　　恒成就过未
  圣初除过去　　住定道成中

论曰。住别解脱补特伽罗从初刹那乃至未遇舍学处等诸舍戒缘恒成现世。此别解脱律仪无表初刹那后亦成过去。前未舍言遍流至后。前生所得别解脱戒。于今受戒最初刹那。如静虑律仪何不成过去。此责非理。此戒与心非同果故。离染心等皆同一果故。彼戒如心得过去生者。又别解脱未曾得故。应如胜品静虑律仪。非初刹那中得过去生者。如说安住别解律仪。住不律仪应知亦尔。谓从初念乃至未过。受律仪等舍恶戒缘。恒成现世恶戒无表。初刹那后亦成过去。诸有获得静虑律仪。乃至未舍恒成过未。前生所失过去定律仪。今初刹那必还得彼故。此中应作简别而说。以顺决择分所摄定律仪。初刹那中不成过去。余生所得命终时舍。今生无容重得彼故。又非一切有情曾起有涅槃法者方可有彼故。一切圣者无漏律仪过去未来亦恒成就。有差别者谓初刹那必成未来非成过去。此类圣道先未起故。昔曾未得创得名初。先得已失今创得时亦得过去。已曾生者初刹那后乃至未舍亦成过去。乃至未般无余依位恒成未来。若有现住静虑彼道如次成现在静虑道律仪。非出观时有成现在。理应但说在定道时。成现在世定道无表。不应言住如住果言。唯说果成非果现起。今但言住云何得知定道现前非但成就。是故彼说犹令生疑。不能定显成现无表故应但说在定道言。虽说住言劳而无用。今详彼意前文已说成就去来。此句正明。成就中世。故知说住显起非成。以非唯成证成现故。定道无表随心转故。散心现前必无彼故。已辨安住善恶律仪。住中云何。颂曰

  住中有无表　　初成中后二

论曰。言住中者谓非律仪非不律仪。彼所起业不必一切皆有无表。若有无表即是善戒。或是恶戒种类所摄。或非二类彼初刹那但成中世。谓成现在此是过去未来中故。初刹那后未舍以来。恒成过现二世无表。若有安住律不律仪。亦有成恶善无表不。设有成者为经几时。颂曰

  住律不律仪　　起染净无表
  初成中后二　　至染净势终

论曰。若住律仪由胜烦恼。作杀缚等诸不善业。由此便发不善无表。住不律仪由淳净信。作礼佛等诸胜善业。由此亦发诸善无表。乃至此二心未断来所发无表恒时相续。然其初念唯成现在。第二念等通成过现。已辨成无表。成表业云何。颂曰

  表正作成中　　后成过非未
  有覆及无覆　　唯成就现在

论曰。一切安住律不律仪。及住中者乃至正作。诸表业来恒成现表。初刹那后至未舍来。恒成过去必无成就。未来表者不随心色。势微劣故。诸散无表亦同此释。有覆无覆二无记表。定无有能成就过未。法力劣故。唯能引起法俱行得。得力劣故。不能引生自类相续。可法灭已追得言成。亦无功能逆得当法。岂不此表如能起心。亦应有成去来世者。此表力劣由彼劣故。此责非理所起劣于能起心故。所以然者。如无记心能发表业。所发表业不生无表。故知所起劣能起心。如律仪名既有差别。不律仪号亦有别耶。亦有云何。颂曰

  恶行恶戒业　　业道不律仪

论曰。此恶行等五种异名。是不律仪名之差别。是诸智者所诃厌故。果非爱故立恶行名。障净尸罗故名恶戒。身语所造故名为业。根本所摄能畅业思。业所游路故名业道。不静身语名不律仪。然业道名唯目初念。通初后位立余四名。今应思择若成就表亦无表耶。应作四句。颂曰

  成表非无表　　住中劣思作
  舍未生表圣　　成无表非表

论曰。唯成就表非无表者。谓住非律非不律仪。劣善恶思造善造恶。身语二业唯能发表。此尚不能发无表业。况诸无记思所发表除有依福及成业道。彼虽劣思起亦发无表故唯成无表。非表业者谓异生圣补特伽罗。今表未生先生已舍。岂不已得静虑异生。今表未生先生已失。亦成无表非表业耶。何故颂中但摽于圣。非异生者理亦可然。何故释中摽异生者俱成非句。如理应思

说一切有部顺正理论卷第三十六阿毗达磨顺正理论卷第三十七

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩业品第四之五

如是建立表与无表及成就已。于中律仪三种差别云何而得。颂曰

  定生得定地　　彼圣得道生
  别解脱律仪　　得由他教等

论曰。静虑律仪与心俱得。若得有漏近分根本。静虑地心静虑律仪。尔时便得彼心俱故。从无色界殁生色界时。随得彼地中生得静虑。即亦得彼俱行律仪。无漏律仪亦心俱故。若得无漏近分根本静虑地心。尔时便得此复二种。谓由加行及离染故。由加行者如得胜进加行道摄。由离染者如得无间解脱道摄。彼声为显前静虑心。复说圣言简取无漏。六静虑地有无漏心。谓未至中间及四根本定非三近分如后当辨。颂言定生得定地者。此言有失以定地言总摄此地所有诸法律仪。亦是此地所收是则得律仪。由得律仪故若作是说便无所成。经主此中应自思择。故但应说得静虑言。别解脱律仪由他教等得。能教他者说名为他。从如是他教力发戒故。说此戒由他教得。此复二种。谓从僧伽补特伽罗有差别故。从僧伽得者谓苾刍苾刍尼及正学戒。从补特伽罗得者谓余五种戒。诸毗奈耶毗婆沙师说。有十种得具戒法。为摄彼故复说等言。何者为十。一由自然谓佛独觉自然。谓智以不从师证此智时得具足戒。二由佛命善来苾刍。谓耶舍等由本愿力佛威加故。三由得入正性离生。谓五苾刍由证见道得具足戒。四由信受佛为大师谓大迦叶。五由善巧酬答所问谓苏陀夷。六由敬受八尊重法谓大生主。七由遣使谓法授尼。八由持律为第五人谓于边国。九由十众谓于中国。十由三说归佛法僧。谓六十贤部共集受具戒。此中或由本愿力故。或阿世耶极圆满故。或薄伽梵威所加故。随其所应得具足戒。如是所说别解律仪。应齐几时要期而受。颂曰

  别解脱律仪　　尽寿或昼夜

论曰。七众所依别解脱戒。唯应尽寿要期而受。近住所依别解脱戒。唯一昼夜要期而受。此时定尔何因故然非毗奈耶相应义理。非一切智者能测量其实。谓有何因别解脱戒。有于众内执三衣等。礼众求师审问遮难。白四羯磨为先故得。或有但籍补特伽罗教命等缘为先故得。或有得戒不籍外缘。此等必应有决定理。佛知而说非余所量。又以何因造无间者。后虽悔愧修诸善业。于因果理能定信知。而于身中戒无容发故。佛遮彼出家受具。定知别有顺受戒身。以受尸罗能救恶趣。非所受戒于无间生。必定能招所应受果。亦非于后无招果能。又非彼人非佛悲境。理应定有律仪种性。唯依此处余处不生。是故不应征其所以。有余师说。世尊觉知戒时边际但有二种。一寿命边际。二昼夜边际。重说昼夜为半月等。故佛但说二受戒时。何法名时非离诸行。但光闇位四洲不同。如次应知立为昼夜。此中经部作如是言。二边际中尽寿可尔。于命终后虽有要期。而不能生别解脱戒。依身别故别依身中。无加行故无忆念故。一昼夜后或五或十。昼夜等中受近住戒。何法为障令彼众多。近住律仪非亦得起。彼如是说岂不违经。遍览诸经曾不见说过昼夜受近住律仪。汝等何缘以己劣慧贬量诸佛一切智境。数言五夜等受近住律仪。以佛经中唯说昼夜故。对法者亦作是言。近住律仪唯昼夜受。必应有法能为障碍。令过昼夜彼戒不生。故佛经中唯说昼夜。然彼复说应共寻思。为佛正观一昼夜后理无容起近住律仪。故于经中说一昼夜。为观所化根难调者。且应授与一昼夜戒。依何理教作如是言。过此戒生不违理故。复减于此何理相违。谓所化根有难调者。已许为说昼夜律仪。何不为调渐难调者。说唯一夜一昼须臾。以难调根有多品故。由此知有近住定时。若减若增便不发戒。世尊观见故唯说此。是故经部与正理师无诤理中横兴诤论。依何边际得不律仪。颂曰

  恶戒无昼夜　　以非如善受

论曰。要期尽寿造诸恶业得不律仪非一昼夜如近住戒。所以者何。以此非如善戒受故。谓必无有立限对师受不律仪。如近住戒我一昼夜定受不律仪。此是智人所诃厌业故。虽亦无有立限对师我当尽形造诸恶业。而由发起坏善意乐。欲永造恶得不律仪。非起暂时造恶意乐。无师而有得不律仪。故不律仪无一昼夜。然近住戒功德可欣。由现对师要期受力。虽无毕竟坏恶意乐。而于一昼夜得近住律仪。故得不律仪与得律仪异。此俱实有已广成立说一昼夜近住律仪。欲正受时当如何受。颂曰

  近住于晨旦　　下座从师受
  随教说具支　　离严饰昼夜

论曰。近住律仪于晨旦受。谓受此戒要日出时。此戒要经一昼夜故。诸有先作如是要期。我当恒于月八日等决定受此近住律仪。若旦有碍缘斋竟亦得受。言下座者谓在师前居卑劣座身心谦敬。身谦敬者或蹲或跪曲躬合掌唯除有病。心谦敬者于施戒师心不轻慢于三宝所生极尊重殷净信心。以诸律仪从敬信发。若不谦敬不发律仪。此必从师无容自受。以后若遇诸犯戒缘由愧戒师能不违犯。谓彼虽阙自法增上由世增上亦能无犯。受此律仪应随师教。受者后说勿前勿俱。如是方成从师教受。异此授受二俱不成。具受八支方成近住。随有所阙近住不成。诸远离支互相属故。由是四种离杀等支。于一身中可俱时起。以诸远离相系属中或少或多相差别故。受此戒者必离严饰憍逸处故。常严身具不必须舍。缘彼不能生其憍逸如新异故。受此律仪必须昼夜。谓至明旦日初出时。经如是时戒恒相续。异此受者唯生妙行不得律仪。然为令招可爱果故亦应为受。又若如斯尽昼夜受。具制屠猎奸盗有情。近住律仪深成有用。言近住者谓此律仪近阿罗汉住以随学彼故。有说。此近尽寿戒住。有说。此戒近时而住。如是律仪或名长养。长养薄少善根有情令其善根渐增多故。何缘受此近住律仪。必具八支非增非减。颂曰

  戒不逸禁支　　四一三如次
  为防诸性罪　　失念及憍逸

论曰。八中前四是尸罗支。谓离杀生至虚诳语。由此四种离性罪故。次有一种是不放逸支。谓离饮诸酒生放逸处。虽受尸罗若饮诸酒。心则放逸毁犯尸罗。醉必无能护余支故。后有三种是禁约支。谓离涂饰香鬘乃至食非时食。以能随顺厌离心故。厌离能证律仪果故。何缘具受如是三支。若不具支便不能离性罪失念憍逸过失。谓初离杀至虚诳语能防性罪。离贪嗔痴所起杀等诸恶业故。次离饮酒能防失念。以饮酒时能令忘失应不应作诸事业故。则不能护余远离支。后离余三能防憍逸。以若受用种种香鬘高广床座习近歌舞。心便憍举寻即毁戒。由远彼故心便离憍。谓香鬘等若恒受用。尚顺憍慢为犯戒缘。况受新奇曾未受者。故一切种皆应舍离。若有能持依时食者。以能遮止恒时食故。便忆自受近住律仪。能于世间深生厌离。若非时食二事俱无。数食能令心纵逸故。由此大义故具受三。有余师言。离非时食名为斋体。余有八种说名斋支。涂饰香鬘舞歌观听分为二故。若作此执便违契经。契经说离非时食已。便作是说。此第八支我今随圣阿罗汉学随行随作。若尔有何别斋体而说此八名斋支。毗婆沙师作如是说。离非时食是斋亦斋支。所余七支是斋支非斋。如正见是道亦道支。余七支是道支非道。择法觉是觉亦觉支。余六支是觉支非觉。三摩地是静虑亦静虑支。所余支是静虑支非静虑。经主于此谬作是责。不可正见等即正见等支。若谓前生正见等为后生正见等支。则初刹那圣道等应不具有八支等。非毗婆沙说正见等其体即是正见等支。亦非前生正见等为后生正见等支。然于俱生正见等八。唯一正见有能寻求诸法相力说名为道。以能寻求是道义故即此正见。复能随顺正思惟等故名为支。所余七支望俱生法能随顺故说名为支。非能寻求不名为道。实义如是。若就假名。余七皆能长养正见。故思惟等亦得道名。见名道支亦不违理。是则一切亦道亦支。余随所应皆如是说。由此类释斋戒八支。经主于中何凭说过。为唯近事得受近住。为余亦有受近住耶。颂曰

  近住余亦有　　不受三归无

论曰。诸有未受近事律仪。一昼夜中归依三宝。说三归已受近住戒。彼亦受得近住律仪。异此则无除不知者。由意乐力亦发律仪。岂不三归即成近事。如契经说佛告大名。诸有在家白衣男子。男根成就归佛法僧。起殷净心发诚谛语。自称我是邬波索迦。愿尊忆持慈悲护念。斋是名曰邬波索迦。此不相违受三归位未成近事。所以者何。要发律仪成近事故。于何时发近事律仪。颂曰

  称近事发戒　　说如苾刍等

论曰。起殷净心发诚谛语。自称我是邬波索迦。愿尊忆持慈悲护念。尔时乃发近事律仪。称近事等言方发律仪故。以经复说我从今者乃至命终护生言故。若离称号但受三归成近事者。自称我是近事等言便为无用。依何义故说护生言。别解律仪护生得故。然有别诵言舍生者。此言意说舍杀生等。略去杀等但说舍生。彼虽已得近事律仪。为令了知所应学处故。复为说离杀生等五种戒相。令识坚持如得苾刍具足戒已。说重学处令识坚持勤策亦然。此亦应尔。是故近事必具律仪。非受三归即成近事。颂曰

  若皆具律仪　　何言一分等
  约能持故说

论曰。经部于前所说义理心不生喜。复设是难若诸近事皆具律仪。何缘世尊言有四种。一能学一分。二能学少分。三能学多分。四能学满分。岂不由此且已证成。非唯三归即成近事。谓若别有但受三归即成近事。如是近事非前所说四种所收。应更说有第五近事。此于学处全无所学。亦应说为一近事故。佛观近事非离律仪。故契经中唯说四种。虽诸近事皆具律仪。然约能持故说四种。谓虽具受五支律仪。而后遇缘或便毁缺。其中或有于诸学处能持一分。乃至或有具持五支故作是说。能持先所受故说能学言。不尔应言受一分等。故此四种但据能持。经主此中作如是说。如是所执违越契经。如何违经。谓无经说自称我是近事等言便发五戒。此经不说我从今者乃至命终舍生言故。经如何说如大名经。唯此经中说近事相。余经不尔故违越经。然余经说。我从今时乃至命终舍生归净。是归三宝发诚信言。此中显示已见谛者由得证净。举命自要表于正法深怀爱重。乃至为救自生命缘。终不舍于如来正法。非彼为欲说近事相。故说如是舍生等言。未审此中经主说意。为欲劝励我国诸师。受持外方经部所诵。为受持佛所说契经。然有众经不违正理。外方经部曾不受持。有阿笈摩越于总颂。彼率意造还自受持。经主岂容令我国内善鉴圣教诸大论师。同彼背真受持伪教。且经所说我从今时。乃至命终舍生等者。何理唯说得证净人。非诸异生亦立此誓。诸异生类将受律仪。亦有如斯坚固意乐。乃至为救自生命缘。终不亏违所受学处。如斯誓受世现可得。然此文句大名经中。现有受持不违正理。故不应舍所诵正文。设大名经无此文句。于我宗义亦无所违。非我宗言说此文句。究竟方发近事律仪。由说自称我是近事。请持护念便发律仪。以自发言表为弟子。如大迦叶得具足戒世尊既说邬波索迦。应具受持五种学处。彼说我是邬波索迦。必具律仪何劳致惑。如称我是国大军师。彼必具闲兵将事业。依如是喻智者应思。如是分明无过理教。若不忍受知奈之何。又经主言。约持犯戒说一分等。尚不应问况应为答。谁有已解近事律仪必具五支。而不能解于所学处持一非余。乃至具持名一分等。由彼未解近事律仪受量少多故应请问。凡有几种邬波索迦能学学处。答言有四邬波索迦。谓能学一分等犹未能了。复问何名能学一分。乃至广说此全无理。唯对法宗所说理中应问答故。虽知近事必具律仪而未了知。随犯一种为越一切为一非余。由有此疑故应请问。诸部若有未见此文。于此义中迄今犹诤。若异此者佛经数言。邬波索迦具五学处。谁有于此已善了知。而复怀疑问受多少。设许尔者疑问相违。谓彼本疑受量多少。而问有几能学学处。答学一分等岂除本所疑。故彼义中不应问答。经主于此不正寻思。于诤理中怀朋党执。翻言对法所说义中。问尚不应况应为答。有余师说。由别契经证离律仪亦成近事。如契经说齐何名为邬波索迦尸罗圆满。谓有近事能断杀生能离杀生乃至饮酒。故知近事有阙律仪。彼于此经甚迷义意。此经意说无漏尸罗。以此中无尽寿声故。又如经说齐何名为邬波索迦信根圆满。谓有近事于如来所住有根信乃至广说。不可说有邬波索迦此信不成即全无信。如此经说信圆满言但约无漏。故知所说戒。圆满言非据有漏。但据无漏说如是言。是故不应引此经说。证有近事不具律仪。无漏戒中无离饮酒。故此所释。理必不然。此难不然。此经显说无漏戒体有胜能故。谓佛显示无漏戒力。能令所受近事律仪。乃至遮戒亦定无犯。故此经约无漏尸罗说离饮酒亦无有失。故契经说见圆满者。终不故思犯诸学处。或此经说尸罗圆满。欲显尸罗遍清净义。谓于五戒全无毁缺。方名尸罗遍清净者。依遍清净立圆满名。若决定无离戒近事。便违经说。或有一类具信非戒邬波索迦。此不相违此说近事不能具足。持五戒者名为具信非具尸罗。或此具言显可赞义。如言此剑磨已具色。非此未磨色全非有。戒亦应尔可赞名具。戒具众德立可赞名。与此相违名不具戒。若阙律仪亦名近事。苾刍勤策阙亦应成。然经主言何缘不许。由佛教力施设不同。虽阙律仪而成近事。苾刍勤策要具律仪。此率己情无经说故。彼前已说唯大名经说近事相余经不尔。今应定说世尊于何说离律仪而成近事。曾闻经部有作是执。亦有无戒勤策苾刍。彼执便同布剌拏等诸外道见非佛法宗。一切律仪品类等不。品类非等有三品故。下中上别随何故成。颂曰

  下中上随心

论曰。八众所受别解脱戒。随受心力成上中下。由如是理诸阿罗汉。或有成就下品律仪。然诸异生或成上品。此中上座作是拨言。如是所宗违正理教。若必尔者是则应无勇猛正勤修持禁戒。世尊亦说轨则所行皆得圆满。于微细罪见大怖畏。此但为持如先所得令不毁坏。故应发起勇猛正勤。非由修持令下中品转成中上。亦非由起勇猛正勤。便舍下中得中上戒。由此即释所引契经。亦但就持如先所得。能于毁犯微细罪中见大怖畏故作是说。不言由此令戒渐增。又彼所言诸有为法刹那不住。故所受戒由众缘力及阿世耶。从下生中从中生上此亦非理。所受律仪依殊胜缘方得生故。谓所受戒必托受缘。得已无容数数重受。若先受已后离受缘。泛遇余缘可更得者。先未受戒泛遇余缘。亦应可得无差别故。虽诸有为皆托缘起。而戒必托。殊胜缘生。故彼所言定不应理。依何义说邬波索迦彼先归依佛法僧宝。亲近承事所尊重师。便获尸罗故名近事。或能习近如理所为。坏恶事业故名近事。或能亲近事佛为师故名近事。分同诸佛得净尸罗善意乐故。如有颂言

  居远而近佛　　由勤勇归礼
  有悲离恶想　　故名为近事

今应思择。无智世间所事种种诸天神众。为诸近事应礼彼天。如礼世尊为不应礼。何缘于此欻尔生疑。以于世间现有一类。事邪天爱染习其心。乐率己情作诸事业。不依理教妄作是言。邬波索迦应礼天众。佛听许故。谓佛听许供养天神。故契经言供养天者名奉佛教。又随念故谓世尊说应随念天故应礼天。如说随念佛法僧宝。又不遮故。谓无经遮邬波索迦礼诸天众。又有恩故。谓彼诸天承奉合仪能与恩福。又能损故。谓彼天神承奉失仪能为大损。故诸近事应礼天神。略叙彼宗所说如是此皆非理。且彼所言佛听许故。应礼天者佛意不然简别说故。谓彼经说诸净施主。于诸应受祠祀天神。于时时间应以三事无倒供养以礼承奉。彼于施主必起善心。哀愍护念令无损恼。一于时时应施严净。二于时时应施供具。三于时时应施颂愿。以标三事为决定因。证知世尊除三事外。凡所施作皆非所许。非标数名便显定义。如说地动不犯等言。谓如经言四因缘故大地震动。非不更有四因缘外地动因缘。又如经言诸阿罗汉。能于五处毕竟不犯。非不更有余不犯处。又如经说在家出家于五处中应数观察。非不更有余处应观。如是等言其类非一。此亦应尔非决定因。此救不然如动地等。余经说有不可得故。此标定数非于余经。有不定言如动地等。以此为证知此经中标列数名显决定理。除此余理无容有故。或应所说蕴处界等如此数名皆成不定。或如所说蕴处界等。动地因等数亦应定。何缘一类标列数名。所显义中或定不定。以于余处除此所明或不见余或见余故。若一切处以言说同执事皆等便成大过。若谓经说供养等言。即已显成应礼拜者。则佛应遣诸天神众。亦应礼拜能祠施主。如彼经言诸天神众。既被供养及承奉已。应反供养等以报施主恩。是故此中但据随彼所乐欲事。皆正供承名供养等非申礼敬。诸天神众于近事边无敢希求礼敬事故。如国君主于诸苾刍。定无希求礼敬事者。惧损功德及寿命故。如契经说毗沙门天。请大目连舍利子等五百圣众。至自宫中。设供养已请施颂愿。复请从今诸出家者及近事等。至我寺中一切皆应施我颂愿。我等眷属亦从今时每以专诚护持正法。令佛弟子出家在家。于一切时恒无恼害。时二大圣许其所请。遍告一切出家在家诸有受持佛禁戒者。从今以去至天寺中皆应如法施天颂愿。然未曾令合掌敬礼。由此等证定知世尊于此经中非许礼敬。言随念故应礼天者。亦不应理迷经义故。谓经意说应作念言。彼诸有情成就信等。从此舍命已得上生四大王天及余天众。我亦成就信等善法亦应同彼当得生天。令随念天与己同德。非令礼敬名随念天。故引此经于彼非证言不遮故。应礼天者亦不应理义已遮故。经唯许三事供养天神。岂不此定言已遮礼敬。又准略说毗柰耶中亦已义遮礼天神故。谓佛曾说略毗柰耶告诸苾刍。我随文句所遮制者皆不应行。所开许者汝等应行。若非所遮非所开许顺秽违净皆不应行。顺净违秽汝等应行。既执如来不遮近事礼诸天众。亦不曾见开许近事礼诸天神。岂不此应第三聚摄。然诸近事若礼天神。如是所为顺秽违净。理应是佛所不许行。是则还成佛已遮制言不遮故。因不极成何缘礼天顺秽违净。以若近事乐礼天神。便与外道等无差别。爱乐邪徒所作业故。又若近事礼敬天神。则应爱重赞天邪论。便与爱乐敬天邪徒同禀尸罗作诸劳侣。由此方便习近邪师。堕恶趣因渐坚增盛。从此展转乃至多生亦乐多行如是邪行。又若礼敬诸邪天神。因此便憎如来圣教。以无不敬邪天神者。闻佛功德生愤恚心。乍可处中心无憎爱。又于过失礼敬持心必定怨嫌敬功德者。何缘信奉大力天神而说名为敬过失者。以彼礼敬恒乐于他。摧伏背恩害谄诳等。有过失境为增上故。由此唯有无闻愚夫。于彼天神深生敬爱。若诸贤圣唯于断灭远离寂静。大智悲等众德集成。诸佛世尊深生敬爱。依如是义故有。颂言

  贫贱有希怖　　愚类敬天神
  富贵无悕求　　智人唯敬佛

又若近事礼敬天神。引多有情作大衰损。谓事天者咸作是言。邬波索迦深闲佛教。现来礼敬我所事天。必于天神有怀敬信。善哉我等无倒归依。又诸世间乐观察者。推寻佛教未究其真。睹此便生如是僻执。佛教应似世间书传。不能决定辩真义理。乃令如是解佛教人。还来归依诸天神众。引如是等无量有情。令增邪执名大衰损。近事如是礼敬天神。违净顺秽佛所遮止。故不应言不遮止故。又不遮止非应作因。如佛不遮苾刍舍戒。以曾无处佛作是言。苾刍不应舍所学戒。非于舍戒佛曾不遮。则诸苾刍法应舍戒。故不应说邬波索迦应礼天神。佛不遮故言有恩故应礼天者亦不应理闻有怨故。传闻热病老死等苦。亦有是彼天神所作。不应定说于世有恩。又婆罗门长者居士。于苾刍众佛说有恩。供给命缘令无乏故。岂苾刍众应礼施主。既不应礼一切有恩。故所立因有不定失。又诸含识皆悉受用。自业所招诸异熟果。是故所说所事天神于世有恩有不成失。由此亦破能损故因。一切有情皆依自业。说谁有力能损于谁。又彼于他既能为损。谁有智者爱敬己怨。世有善人能益他者诸蒙益者应敬彼人。是诸天神性多愤恚。恒乐损恼他诸有情。如嫉己怨不应敬礼。故彼所说成相违因。又见世间归敬天者。天神于彼有时作衰。亦有有情不敬天者。天神于彼不能为害。故彼所说非敬天因。若谓如王亦不应理。世间依属法应尔故。非诸近事系属天神。自是邪徒相率归附。世间君主众所依投。非出家人皆应致敬。是故近事不应敬礼一切天神。理极成立

阿毗达磨顺正理论卷第三十七阿毗达磨顺正理论卷第三十八

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩业品第四之六

诸有归依佛法僧者。为归何等。颂曰

  归依成佛僧　　无学二种法
  及涅槃择灭　　是说具三归

论曰。如本论言归依佛者为归何法。谓若诸法妙有现有。由想等想施设言说名为佛陀归此能成佛。无学法言谓若者即是总标当所说义。言诸法者即是显示无我增言。妙有言显妙有性合。现有即明现可得义。或妙德合。故名妙有。现有即显是所知性。想者谓名言等。想者即是能显共立能诠标举。能诠故名施设。何故标举次则答言。由此能成无倒言说。觉一切法一切种相不藉他教故名佛陀。或此圆成智等众德自然开觉故名佛陀。或佛陀名显彼有觉。如质碍物名有质碍。或佛陀名显彼能说己所证觉以开觉他。如婆罗门来诣佛所。以妙赞颂问世尊言

  稽首世导师　　名最上觉者
  何缘父母等　　号尊名佛陀

世尊哀愍彼婆罗门。亦以伽他而告之曰

  婆罗门当知　　我如去来佛
  成就觉者相　　故我名佛陀
  婆罗门当知　　我观三世行
  皆有生灭法　　故我名佛陀
  婆罗门当知　　我于应知断
  修证事已辨　　故我名佛陀
  婆罗门当知　　我于一切境
  具一切智见　　故我名佛陀
  婆罗门当知　　我于无量劫
  修诸纯净行　　经无量死生
  今于最后身　　离尘垢毒箭
  证得无上觉　　故我名佛陀

能成佛言。显彼诸法与佛施设为建立因。如何此中于无量法而总建立标一佛名。如依众多和合人上立一僧宝一胜所归。又于众多无漏道上立一道蕴无有过失。或先已说先说者。何谓想等想施设言说。即佛相续无学法中立一佛名。无别一佛能成佛法。为是何等谓尽智等及彼眷属。由得彼法能觉一切。以彼胜故身得佛名。非色等身前后等故。为归一佛一切佛耶。理实应言归一切佛。以诸佛道相无异故。经主此中作如是说。然寻本论不见有言唯无学法。即名为佛。但言无学法能成于佛不遮所依身亦是佛体。是故于此不可难言。若唯无学法即是佛者。如何于佛所恶心出血但损生身成无间罪。今详经主于本论义未甚研寻能成佛言已遮佛体摄依身故。谓佛名言依佛义立。唯此所目是真佛体。若佛名言就依身立。于未证得无学法时。已有依身应亦名佛。故知佛号不目依身。由此依身非能成佛。故本论说能成佛言已遮依身亦是佛体。已显佛体唯无学法。或设许然亦非无难。谓佛体性略有二种。一者世俗。二者胜义。归依佛者现对世俗。于胜义佛系念归依。以托依身而归依彼。由得彼故得佛名法。故唯无学法是胜义佛体成无间罪由损胜义。然胜义佛必不可损。依如是义理可难言。如何于佛所恶心出血但损害生身成无间罪。毗婆沙者作是释言。坏彼所依彼随坏故。如是释难深为应理。又彼经主作如是难。若异此者应佛与僧住世俗心。非僧非佛云何如是。以于尔时学无学法不现前故。此难不然非所许故。谓我不许学无学法。唯现在位方成佛僧。唯言佛僧得彼法故。得于诸位曾无间断。宁住世俗心便非僧非佛。设许现在方成佛僧亦无有过。以许彼得其体亦是学无学故。得一切时常现前故。经主复言又应唯执成苾刍戒即是苾刍。是我所宗岂成过失。以得戒故假说依身亦名苾刍与前义等。是故经主于对法宗不善了知所说文义。婆雌子部作如是言。补特伽罗是所归佛。此非应理。所以者何。彼无差别不成归故。谓归离系补特伽罗与归世尊有何差别。善等差别同不记故。若谓如火随依差别。谓如依糠名为糠火。如是依佛法彼亦得佛名。此救不然应无常故。徒设救执无所成故。谓彼所执补特伽罗既随所依应无常性。又依糠火非即名糠补特伽罗。若依佛法但应名佛补特伽罗。补特伽罗非即名佛。如是救执竟何所成。既执补特伽罗随法成差别。应许能差别法即是佛。非余以归依名显依。由此能灭所有生死灾患。有如是用唯此相法。故说此法是所归依。余皆不然是说为善。又应许佛补特伽罗成世间法。故契经说今见世尊诸根变异。汝等既执补特伽罗。由随所依故成差别。何缘依佛法彼得佛名。非佛法为依不名非佛。此中无有差别理故。若谓如人虽有发等黑。而不随彼可得名白人。是则应成舍前救执。谓彼前救执补特伽罗。由随所依故成差别。今复不许补特伽罗随其所依成差别故。岂亦有火得差别名。随一分依不随一分。又依有漏无漏所成补特伽罗应成二体。不尔应舍前所救执。又世尊说我于世间生非补特伽罗亦有生理。若异此者世尊应言我现世间。然说不尔是故决定法为所归。如世尊言但应依法。不应依彼补特伽罗。又世尊言若见法者即是见我。又契经说佛虽转变而心无异。非汝所执补特伽罗可有转变。以汝不说补特伽罗是无常故。今乘义便且以余理破汝所归补特伽罗。其体非实余处广辩。尊者矩摩逻多作如是说。佛有漏无漏法皆是佛体。故契经说今者佛身衰老朽迈。又世尊说我今重病生邻死受。告阿难陀汝应为佛于此敷设嗢怛罗僧。又契经言。汝应以饮食如法供养佛为上首僧。又契经言诸苾刍众受持佛语。又契经言于如来所恶心出血。又经说佛以足蹑衣。又契经言我今观佛威光炽盛如妙金台。又世尊言我今欲往娑多山处报药叉恩。又契经言汝等商主若得见佛获无上利。又饶益他方得名佛。饶益他者多是俗智。又诸佛用大悲为体。此是有漏法有情相转故。如是等类教理众多。非无漏中可有斯事。故非唯无漏佛法为佛体。此亦非理由无学法力于身等法假立佛名故。云何知然。佛眼根等与前眼等无差别故。又如有漏名无学明。经说三明是无学故。非死生智可是无学此缘形显故。有情相转故无学身有得无学名。余法亦然与诸佛法堕一相续亦得佛名。又佛身等不应是佛以应断故。夫言佛者都无过失非应断故。又经说身无明集成故岂可说佛亦无明集成。又诸佛身是不净境。以一切欲界色是不净观境故。非佛应为不净观境。经说缘佛增长善根生欣作意。诸不净观一向与厌作意相应。故知佛身非真是佛。又说业食为身因故。佛身诸处业异熟摄。是段等食之所资长。岂应于此立真佛名。若人说佛因于业有。谁有智者而不诃责。岂有智人误发此语。后自觉察而无悔愧。若据佛资粮依止摄益等。假说为佛于理无遮。余处亦曾见此例故。如言食是命酪是热病等。又佛身中大悲俗智先菩萨位其体已有。此若是佛佛应先成。若有别因令此二种后转名佛。即应许此能差别法是佛非余。破此亦应同前一类违正理教自分别执。然大众部复作是言。如来身中所有诸法皆是无漏尽是所归。以经说身是已修故。谓契经说已修身心。如说已修心许心是真净身亦应尔。既说已修如何可言非真无漏。如是等证其类寔多。此一类宗辩本事品。已广遮遣无劳重破。然契经说已修身者。约对治修故作是说。是已修习能离色染无间道义。又契经言彼已修习四种念住。复言四念住总摄一切法。则一切法应皆无漏。若谓此据自性相离二念住说余亦应同。谓契经言已修身者。何故不许修身念住。又有漏善亦是所修故引修言证无漏者。此证与理岂得相应。又彼所言若佛眼等。是烦恼境故是有漏。岂不亦是离染所缘何理能遮。是无漏性此例非等如前已辩。有漏无漏相差别故。然契经说烦恼所缘圣道所厌名有漏者应共寻求。此经意趣善逝意趣极为难识。今见此经所说意者。若所缘境烦恼味着执为己有。亦为圣道之所厌恶。是名有漏理应眼等。漏所味着执为己有可成有漏。不应例言眼等诸法无漏。所厌恶应亦成无漏。欣厌既异为例不齐。非佛眼等为无漏。诸法作道等行相欣乐而缘。不可说言佛眼等法。无漏厌恶而成无漏。又如贪嗔于诸漏转。于眼等转其相亦然。故可说言眼等诸法同诸漏法亦成有漏。非如圣道于圣道转。于眼等转其相亦然。故不可言眼等诸法。同圣道法亦成无漏。故彼劬劳无所成者。虽复种种妄率己情。无损我宗经所说相。唯有大圣迦多衍尼子说所归佛体无有过失。僧伽差别略有五种。一无耻僧。二哑羊僧。三朋党僧。四世俗僧。五胜义僧。无耻僧者谓毁禁戒。而被法服补特伽罗。哑羊僧者谓于三藏无所了达补特伽罗。譬如哑羊无辩说用。或言哑者显无说法。能复说羊言显无听法用。即显此类补特伽罗。于三藏中无听说用。朋党僧者谓于游散营务斗诤。方便善巧结构朋党补特伽罗。此三多分造非法业。世俗僧者谓善异生。此能通作法非法业。胜义僧者谓学无学法。及彼所依器补特伽罗。此定无容造非法业。五中最胜是所归依。如赞归依伽他中说

  此归依最胜　　此归依最尊
  必因此归依　　能解脱众苦

于如是法补特伽罗二胜义僧中。迦多衍尼子意但以法为所归僧。故本论中作如是说。归能成僧学无学法。岂不此说与经相违。谓契经中世尊说有四双八只补特伽罗。是福田僧皆应供养。经有别义谓彼经中。说福田僧应供养故。彼经意显能受施僧。二胜义僧中能受他施者。非学无学法唯补特伽罗。此本论中说归依义。真能救护方是所归。真救护能唯在圣法。故契经言但应依法。不应依彼补特伽罗。由此论经不相违背。又此应是不了义经。待不违理别意趣故。待别意趣方可了者。此类名曰不了义经。谓此经中所立四八果向差别补特伽罗法补特伽罗定依何建立。据直言义理俱不成。若谓依法应唯立五。谓阿罗汉果及四种向。无漏法和合所成僧伽。若依补特伽罗亦非定八。以成八数定因不可得故。谓无量品别施设僧伽。依一补特伽罗乃至无量故。谓或依一施设僧伽。如说若能如其次第。以诸饮食供养一僧。便获供养一切僧福。或有依四施设僧伽。如供养众僧说戒羯磨等。或有依五施设僧伽如恣举等。或有依八施设僧伽。如此经说或有依十施设僧伽。如依中国受具戒等。或依二十施说僧伽。如出众余为羯磨等。此中后后能摄前前。非于前前能摄后后。从此以后数无决定。乃至依无量亦施设僧伽。如余处说苾刍僧伽苾刍尼僧伽。或二部僧伽。或贤圣僧伽。声闻僧伽等。于此多种依多品别补特伽罗施设。僧内唯此依八补特伽罗名福田僧非依余品。如是差别有何定因。由此二门皆不应理。故知此是不了义经。若谓唯齐此补特伽罗总摄诸声闻。所有无漏功德种类所成种种。若二若三相续差别故唯约此显示福田。此亦非理。且许施设补特伽罗僧要待法僧故。则应唯法是胜义僧补特伽罗如前已说。若前若后无差别故。又依此八补特伽罗亦不具能总得一切声闻无漏法功德种类尽。以非唯一预流果向能得一切。此向功德如是乃至阿罗汉果。若谓向果无差别故。唯此总说一切尽者。何不说五。而说八耶。以于此中次第可得。余三摄在此三中故。又依法立补特伽罗。唯依四双道说八补特伽罗故。以约殊胜功德所依显示有情八种差别故。此意说补特伽罗岂不即为唯依于法。自相共相差别理成。以于法中若总若别理皆得成立非补特伽罗。是故于此唯依于法施设僧伽分明可见。若尔何故不唯说五。为总摄法品类尽故。以非一切一来果向总摄一切预流果尽。如是乃至阿罗汉向不摄一切不还果尽。是故为显圣道差别。应说此八补特伽罗。故此契经成不了义。由唯约法建立僧伽故。我轨范师迦多衍尼子为善成立所归僧伽。诸胜施设中说有情故非定唯法者理亦不然。彼由法力成差别故。无余方便令所化生能正了知佛等胜德。故佛方便依有情门立胜施设令知无过。于此义中复应思择佛为僧摄。非僧摄耶。若僧摄者则胜施设证净宝归数皆应减。又与至教所说相违。如契经言

佛告长者何谓僧宝。谓于当来此世界中有善男子。生刹帝利婆罗门家。或生吠舍戍达罗家。归投如来应正等觉。出家修证是名僧宝。又契经说佛在僧前。又契经言佛于某处与若干数苾刍僧俱。若非僧摄契经何故作如是言。汝等若能以少施物。如次供养佛上首僧。则于僧田获得周遍清净施福。又契经说汝乔答弥。若奉施僧亦供养我。又经说有四双八只补特伽罗名福田僧。不应说佛离八而有。僧有多种谓有情人声闻福田及圣僧等。佛于此内非声闻僧。可是余僧自然觉故。又不成就声闻法故。又为声闻制立学处。言不应受畜等佛衣量衣。若佛世尊声闻僧摄。亦应受学如是学处。又云声闻所有衣物世尊听许苾刍众分。若佛世尊声闻僧摄世尊衣物亦应许分。既不许分。是故知佛可余僧摄。非声闻僧。由是极成佛僧无杂然契经说。汝等若能以少施物。如次供养佛上首僧。获遍福者约福田说故无有过。由此已解乔答弥经。或彼经言。亦供养我亦言意显简佛非僧。若佛即僧亦言何用。佛所说八补特伽罗为显声闻僧位差别。言僧中有八位不同。不作是言八皆僧摄。或所说八皆福田僧佛亦福田故无有过。施僧施佛何得大果。有作是言。施僧果大一切无漏圣法种类。皆于僧中具可得故。又言僧是上福田故。又有施主将物施佛世尊劝令回施僧故。然我所宗施佛果大。以契经说诸佛世尊。证得一切增上自在。殊胜功德名最尊故。又佛世尊一向无失。诸烦恼习皆无余故。又僧所修梵行功德一切皆由佛所生故。又佛世尊自他利德皆已圆满至究竟故。经说此德为最胜故。以能速疾引他心故。广大愿思缘此生故。然彼所言一切无漏圣法种类。皆于僧中具可得者。此不成证。世尊身内无量无边不共功德具可得故。如说假使诸世界中一切有情。皆阿罗汉或独胜觉所有功德。欲比世尊不及少分。所言僧是上福田者。亦非证因有别意故。谓约僧众其数甚多。能受用多所施财物。能令施主受用福增。是故言僧福田中上。或显僧众住经久时。及遍诸方故作是说。或僧虽复是上福田。然佛福田是上中极。由前所说诸因缘故。所言施主将物施佛世尊劝令回施僧者。此证非理。观别因故。谓佛为欲令僧住持无上正法得久住故。劝以施物回施于众。毗婆沙师作如是说。为令施主缘圣慈尊金色相身植胜因故。归依于法谓归爱尽离灭涅槃。如是一切是烦恼断名之差别。或有谓爱味着门转不应弃舍故。寄爱名通显一切烦恼永尽。爱与余烦恼同一对治故。言爱尽者。谓见所断诸爱永断故。预流者。此爱尽时便自记别诸恶趣尽。谓我已尽那落迦等。所言离者。谓欲界中诸所有贪多分已断。即是已薄欲界贪义。灭谓欲界诸爱全断。此地烦恼当于尔时决定无能系缚义故。言涅槃者。谓色无色诸爱永断。由此尽时诸所有苦皆永寂故。此则显示四沙门果。或此四种如其次第。显三界爱断及永般涅槃。或爱尽者。三界爱断所言离者。除爱所余诸烦恼断。所言灭者。显有余依般涅槃界。言涅槃者。显无余依般涅槃界。有余师说。归依法者。谓通归依诸佛世尊。所说杂染及清净法。彼说非理。所以者何。佛说涅槃名最上法。又有经说灭为最上。是故唯应归依此法。此中何法是所归依。能归是何。归依何义。所归依者。谓灭谛全道谛一分。除独觉乘菩萨学位无漏功德。何缘彼法非所归依。彼不能救生死怖故。谓诸独觉不能说法教诫。诸有情令离生死怖。菩萨学位不起期心故。亦无能教诫他义故。彼身中学无学法不能救护非所归依。有余师言。不和合故不显了故。如其次第。独觉菩萨非所归依。缘彼亦生无漏意净。故彼亦是证净境摄。此中能归语表为体。自立誓限为自性故。若并眷属五蕴为体。以能归依所有言说。由心等起非离于心。如是归依救济为义。他身圣法及善无为。如何能为自身救济。以归依彼。能息无边生死苦轮大怖畏故。非如牧竖防护诸牛。提婆达多守余人等。但令不散非所归依。不能令息生死畏故。虽复亦有归佛法僧。然彼不蒙现救济者。以彼违越佛教理故。如有依王而违王敕。王不救济此亦应然。有余师说。彼亦能与后边善根为种子故。归依但作正行种子。非即由此能息苦轮。故有归依未蒙救者。有余师说。彼虽归依未能奉行归所为故。归依所为其体是何。谓见四谛故。伽他说

  诸有归依佛　　及归依法僧
  于四圣谛中　　恒以慧观察
  知苦知苦集　　知永超众苦
  知八支圣道　　趣安隐涅槃
  此归依最胜　　此归依最尊
  必因此归依　　能解脱众苦

三所归依有差别者。佛唯无学。法二俱非。僧体贯通学与无学。又佛体是十根少分。僧通十二。法体非根。择灭涅槃非根摄故。又归依佛谓但归依一有为沙门果。归依法者谓通归依四无为沙门果。归依僧者谓通归依四有为沙门果及四果能趣向。又佛譬如能示道者。法如安隐所趣方域。僧如同涉正道伴侣。应求此等三差别因。应思何缘于余律仪处。立离非梵行为其所学。唯于近事一律仪中。但制令其离欲邪行。颂曰

  邪行最可诃　　易离得不作

论曰。唯欲邪行极为能观此他世者共所诃责。以能侵毁他妻等故。感恶趣故非非梵行。又欲邪行易远离故。诸在家者耽着欲故。离非梵行难可受持。观彼不能长时修学。故不制彼离非梵行。谓无始来数习力故。淫欲烦恼数起现行。诸在家人随顺欲境。数易和合抑制为难。故不制彼令全远离。又诸圣者于欲邪行一切定得不作律仪。经生圣者亦不行故。离非梵行则不如是故。于近事所受律仪但为制立离欲邪行。若异此者。经生有学应不能持近事性戒。若诸近事后复从师要期。更受离非梵行得未曾得此律仪不。有余师说。得此律仪然不由斯方成近事。亦不由此失近事名。亦非先时戒不圆满。有说不得未得律仪。然获最胜杜多功德。名获最胜远离法者。谓能远离淫欲法故。由此若能远离妻室净修梵行功不唐捐。若有先时未取妻妾。普于有情类受近事律仪。于后取时宁非犯戒。今非他摄故如用属己财。谓于今时以咒术力。或财理等种种方便摄彼属己。不系于他如何难令于彼犯戒。又有别理今取彼时。于前律仪无所违犯。颂曰

  得律仪如誓　　非总于相续

论曰。诸受欲者受近事戒。如本受誓而得律仪。本受誓云何。谓离欲邪行。于他所摄诸女人所。起他摄想而行非法。如是乃名犯欲邪行。非于一切有情相续。先立誓言我当于彼。离非梵行而得律仪。云何今时可名犯戒。既如本誓而得律仪。今正随行如何名犯。先取妻妾后受律仪。于自妻等亦发此戒。以近事等别解律仪一切有情处所得故。若异此者于自妻妾。非处非时非支非礼。亦应不犯欲邪行戒。于旧所受既有犯者。于新所受应有不犯。故不应为如先所难。何缘于四语业道中。立离虚诳语为近事学处。非立离余离间语等。亦由前说三种因故。谓虚诳语最可诃故。诸在家者易远离故。一切圣者得不作故。复有别因。颂曰

  以开虚诳语　　便越诸学处

论曰。越诸学处被检问时。若开虚诳语便言我不作。因斯于戒多所违越。故佛为欲令彼坚持。于一切律仪皆遮虚诳语。云何令彼缘力犯戒。时寻即生惭如实自发露。何缘一切离性罪中。立四种为近事学处。然于一切离遮罪中。于近事律仪唯制离饮酒。颂曰

  遮中唯离酒　　为护余律仪

论曰。诸饮酒者心多纵逸。不能守护诸余律仪。故为护余令离饮酒。谓饮酒已于恶作说别悔堕落。众余他胜五部罪中不能防守。或有是处由此普于诸学处海扰乱违越。由此世尊知饮诸酒是起一切性罪因故。能损正念及正智故。能引破戒破见愚故。于一切种离遮罪中。唯说此为近事学处。故离饮酒虽遮戒摄。而于一切立学处中。与离性罪相随而制。有言饮酒是性罪摄。相阿笈摩及正理故。阿笈摩者谓契经言。身有四恶行。杀生至饮酒不应遮罪是恶行摄。又如上座邬波离言。我当如何供给病者。世尊告曰。唯除性罪余随所应皆可供给。然有染疾释种须酒。世尊不开以酒供给。非佛于彼染疾。苾刍自说是师而不怜愍。由正理者。圣者易生亦不犯故如杀生等。又离饮酒。世尊说为。近事律仪如杀等故。正理论者作如是言。虽于此中若如理辩必遭一类愚者所讥。然彼心游正法相外。无容枉理惮彼邪言。故我必应辩正法相。非饮诸酒是性罪摄。由此中无性罪相故。性罪遮罪其相云何。未制戒时诸离欲者决定不起是性罪相。若彼犹行。是名遮罪。又若唯托染污心行。是性罪相。若有亦托不染心行是名遮罪。为防余失佛遮止故。今于此中应共思择。为有于酒虽极憎嫌而为良医令饮除疾。正知强服不起染心。为无如斯无染心者。若许有者既无染心。如何可成性罪恶行。若谓无者如何为疾正知强服而有染心。岂不先知饮酒是罪无惭故饮。或于饮罪愚谓非罪即是染心。此救不然。谓饮诸酒体性是罪。理不成故应审。何缘此皆性罪诸有为疾。以无染心知量而饮能不醉乱。如为除病知量服毒。能令无损岂是罪耶。故非饮酒皆恶行摄。若为憍逸。或为欢娱。或知醉乱。而贪故饮此等皆托染污心生。约此经中说身恶行。应知此是性罪所摄。设佛不遮亦是罪故。或饮诸酒由放逸处故名恶行。非由性罪。故此独立放逸处名。非杀生等是性罪故。然为病者总开遮戒。复于异时遮饮酒者。为防因此犯性罪故。谓勿由知饮是遮罪无多过失。便纵贪情渐次多饮遂致醉乱。因斯放逸造多性罪。为欲深防造性罪故。至茅端量亦不许饮。又令醉乱量无定限故遮。乃至饮茅端所沾量非定遮故。即谓饮酒是性罪摄。如博戏故。如说苾刍汝等决定不应博戏。非诸博戏决定遮故便是性罪。然博戏者。多过患故世极诃故。佛决定遮此。亦应然故非性罪。然彼所说。圣者易生亦不犯故。如杀生等是性罪者。何故不言有阿罗汉亦现行故。应是遮罪摄。如非时食等。若经生圣者得不作律仪。则定不应饮诸酒者。诸阿罗汉亦应定得不饮律仪如杀生等。若谓大师未制戒故容有饮者。不受律仪在家诸圣何缘不饮。非离饮酒可是无漏律仪。自性如先已说。又若圣者定不行故是性罪摄。则应一切圣者所行皆非性罪。是则非梵行应非性罪摄。然非所许故。此非因由此亦遮。有作是说。以契经说。数习能令堕恶趣故如杀生等。故饮诸酒是性罪摄。以非梵行虽是性罪而说数行不堕恶趣故。彼所说非决定因。然说数习堕恶趣者显数饮酒。能令身中诸不善法相续转故。又能发引恶趣业故。或能令彼转增盛故。亦见有说断生草等令堕恶趣。故此无能证饮诸酒是性罪摄。有余师释。如说修慈以密意门说堕恶趣。谓契经说能修慈心得八胜利非修慈故。即能令其得不还果。但据得果修慈为先密作是说。饮酒亦尔。谓酒能损大种诸根便失正念寻生放逸。遂造恶业因堕恶趣依如是义故作是言。又彼所言离饮诸酒。世尊说是近事律仪。故此定应是性罪者。亦不应理以非定故。应如近住所受律仪。如八戒中非时食等。离杀等四立近住支。然彼定非性罪所摄。此亦应尔故非证因。虽彼谤言为贪饮酒矫立饮酒是遮罪摄。今应征问。非时食等汝等许是性罪摄耶。彼答言非。岂亦汝等贪非时食。耽着博戏歌舞掘地断生草等。矫立此等是遮罪耶。若谓不然法相尔故。是则汝等所设谤言无益自增非爱业道。如契经说。窣罗迷丽耶末陀放逸处。依何义说。言窣罗者。谓米麦等如法蒸煮。和麴孽汁投诸药物。酝酿具成酒色香味饮已惛醉。迷丽耶者。谓诸根茎叶花果汁为前方便。不和麴孽酝酿具成酒色香味饮已惛醉。于中一类甘蔗成者得施途名。蒱桃果汁所酝成酒名为末途。即此末途令人耽醉胜于余酒故名末陀。或即窣罗迷丽耶酒。饮已令醉总名末陀。若蒱桃汁酝成酒味饮已令闷不得自在。如饮毒药鬼魅所持失志猖狂。故不令饮非已成酢及酒。未成亦不应饮。如甘蔗汁。不应观饮量若少若多。但真得酒名皆不应饮。多少皆是放逸处故。为遮一类愚闇增强耽味缠心。作如是说饮酒非失但遮过量。能不惛醉饮亦无罪。故说诸酒名放逸处。谓虽不醉有令醉。能佛为深防皆不听饮。故戒经说。若有苾刍饮诸酒者皆犯堕落。契经亦说。若饮诸酒感非爱果其类寔多。或于此中为欲显示离饮酒意。说诸酒已复重说此放逸处言。意显酒非不净性罪是放逸处故不应饮。言放逸者。不顾应作趣不应作故名放逸。是放逸因名放逸处。有作是说。酝食成酒名为窣罗。酝余物所成名迷丽耶酒。即前二酒未熟已坏不能令醉不名末陀。若令醉时名末陀酒。简无用位重立此名。然以槟榔及稗子等亦能令醉。为简彼故须说窣罗迷丽耶酒。虽是遮罪而令放逸广造众恶堕诸恶趣。为显彼是圣所远离恶行应断言放逸处。若饮酒已不吐未消彼必不能受律仪等。酒是放逸所依处故

说一切有部顺正理论卷第三十八阿毗达磨顺正理论卷第三十九

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩业品第四之七

别解脱律仪从何而得。复从何而得余二律仪。颂曰

  从一切二现　　得欲界律仪
  从根本恒时　　得静虑无漏

论曰。欲界律仪谓别解脱。此从一切根本业道。及从前后近分而得。从二得者。谓从二类即情非情性罪遮罪。于情性罪谓杀等业。遮谓女人同室宿等。非情性罪谓盗外财。遮谓掘地断生草等。从现得者谓从现世蕴处界得非从去来。由此律仪有情处转。去来非是有情处故。有情处者谓诸有情及诸有情所依止处。现蕴处界内者即是有情所依。外者名为有情所止。非过未故。若得静虑无漏律仪。应知但从根本业道。以定中唯有根本业道故。非从前后近分而得。以在定位唯有根本。在不定位中无此律仪故。从有情数所发遮罪尚不得此二种律仪。况从非情所发遮罪。从恒时者谓从过去现在未来蕴处界得。如与此戒为俱有心。由此不同应作四句。有蕴处界从彼唯得别解律仪非余二等。第一句者谓从现世前后近分及诸遮罪。第二句者谓从去来根本业道。第三句者谓从现世根本业道。第四句者谓从去来前后近分。有言非得善律仪时。可有现世恶业道等。故应别立此四句文。谓应说言有一类法。于彼唯得别解律仪非二律仪。乃至广说。第一句者谓于现在得前后近分及遮罪远离。余随所应皆如是说。于业道等处置业道等声。故前四句义亦无失。由如是理亦通防护。过现业道等非唯防未来。以业道等声说彼依处故。若异此者则应但说防护未来律仪。但能防未来罪令不起故。非防过现已灭已生律仪于彼无防用故。诸有获得律不律仪。从一切有情支因皆等不。非一切等。其相云何。颂曰

  律从诸有情　　支因说不定
  不律从一切　　有情支非因

论曰。律仪定由调善意乐。普缘一切有情方得。非少分缘恶心随故。支因不定支谓业道。且于别解诸律仪中有从一切支。谓苾刍戒有从四支得。谓余律仪许因不同略有二种。一无贪等三种善根。二下中上等起心。别就初因说一切律仪。由一切因一心有故。就后因说一切律仪。各由一因以下品等不俱时起如先说故。此中且就后三因说。或有一类住律仪者。于一切有情得律仪。非一切支非一切因。谓以下心或中或上受近事勤策戒。或有一类住律仪者。于一切有情得律仪。由一切支非一切因。谓以下心或中或上受苾刍戒。或有一类住律仪者。于一切有情得律仪。由一切支及一切因。谓以三心受近事勤策苾刍戒。或有一类住律仪者。于一切有情得律仪。由一切因非一切支。谓以三心受近事近住勤策戒。无有不遍于诸有情得律仪者。已说因故非于一分。诸有情所誓受律仪恶心全息。今应思择于佛乃至蚁子身上。所得律仪为有别不。若有别者趣不定故。于诸有情所得律仪应有增减。若无别者何缘杀人犯他胜罪。杀非人者唯犯粗恶。若杀傍生犯堕落罪。非有情境身差别故。令所受戒亦有差别。然罚罪业有差别者。应知但由别加行故。杀人加行与杀非人。乃至杀蚁皆有差别。且杀同趣同部罪中。由加行殊业尚有异。如杀香象所获罪多。若杀蚊虻所获罪少。何况异趣加行有别。异部罪中而无轻重。由总意乐建立律仪。谓普于有情无有差别。起调善意乐求得律仪。非于一有情不舍恶意乐。而可求得别解律仪。故得律仪无有差别。以得律仪者必不别观补特伽罗支处时缘故。谓定不作如是别观于某有情我离杀等。于某支戒我定能持。于某方域我离杀等。我唯于彼一月等时除战等缘能离杀等。如是受者不得律仪。但得律仪相似妙行。是故无有由诸有情身差别故。戒有差别。又于自身不得根本业道所摄别解律仪。勿思法等由自杀害成无间等所摄罪业。得眷属摄于理无遮。谓离最初众余罪等。又此所受别解脱律仪。通于一切能不能境得。非唯于能境得此律仪。要普于有情起无损恼意乐。无别方可得故。若谓不然于睡闷等皆不可杀。故应不得律仪。若谓彼觉得本心已还可杀者此亦应然。以非所能有可改易为能境已还可杀故。有作是说。若唯于能则此律仪应有增减。以所能境与非所能二类有情有转易故。此不成难境转易时无此律仪得舍因故。谓所能境及非所能后转易为不能能境。无理令彼舍得律仪。总于所能得律仪故。若必欲令能不能境有转易故。戒有舍得则成律仪增减过者。岂不有草本无而生有诸有情永入圆寂。由此应有舍得律仪亦不离前戒增减失。是故前说于理无过。又非过去一一如来。及所化生入圆寂故。后佛于彼不得律仪。有后律仪减于前失律仪。非对一一有情各异相续别发得故。又前后佛戒支等故。谓诸律仪随无贪等。为因差别生别类支。一一类支各一无表。总于一切有情处得。如是无表既无细分。不可分析为少为多。如何言有后减前失。又一切佛遍于有情。具一切支律仪无表。以支数等无差别故。无后佛戒减于前失。已说从彼得诸律仪得不律仪。定从一切有情业道无少分境及不具支。不律仪者此定无有由一切因下品等心无俱起故。若有一类由下品心得不律仪。后于异时由上品心断众生命。彼但成就下不律仪。亦成杀生上品表等。中品上品例此应知。此中应思于屠羊等事。有唯受一得不律仪。不应言亦有受一事得。若尔何故无从一切因得不律仪。如得律仪者。虽于杀等差别表中先已受一后更别受。而不律仪非更新得。谓先总望一切有情。起无所遮损害意乐。为活命故受不律仪。彼于今时复何所得。故此无有从一切因。然律仪中有从近事受勤策戒。勤策复受苾刍律仪。别别受时所受业道。眷属异故随要期异得先未得。由此可得从一切因。此中何名不律仪者。谓诸屠羊屠鸡屠猪捕鸟捕鱼猎兽劫盗魁脍典狱缚龙煮狗。及罝弶等。等言类显谗构讥刺。伺求人过喜说他非。非法追求以活命者。及王典刑罚断罪弹官等。但恒有害心名不律仪者。由如是种类住不律仪故。有不律仪故行不律仪故。巧作不律仪故数习不律仪故名不律仪者。言屠羊者。谓为活命要期尽寿恒欲害羊。余随所应当知亦尔。诸屠羊者唯于诸羊有损害心非于余类。宁于一切得不律仪。遍于有情界得诸律仪。其理可尔。由普欲利乐胜阿世耶而受得故。非屠羊等不律仪人。于己至亲有损害意。乃至为救自身命缘亦不欲杀。如何可说普于一切得不律仪。此亦可然。不律仪者遍于有情境善意乐坏故。虽无是处而假说言。设诸有情及父母等。一切皆作羊像现前。屠者遍缘皆有害意。谓彼久习不律仪心。乃至己亲亦无所顾。为活命故。设己至亲。现变为羊尚有害意。况命终后实受羊身。于彼能无杀害意。乐不律仪者受恶戒时必起如斯凶勃意乐。设我母等身即是羊我亦当杀况余生类。由此意乐得不律仪。异此但应得处中罪。由此虽了亲现非羊而亦有害心。故遍得恶戒虽无圣者当作羊身。而同至亲亦有害意。经主于此作是例言。若观未来羊等自体于现亲等得不律仪。羊等未来有亲等体。既于彼体无损害心。应观未来至亲等体。于现羊等不得恶戒。如是等例于理不齐。无善意乐故有恶意乐故。谓彼正受不律仪时。无正思惟调善意乐。我当不害一切有情。有邪思惟凶勃意乐。我当普害一切有情。事虽主羊而心宽遍。是故容有观未来羊。于现圣亲亦发恶戒。非观来世圣及至亲。于现羊身不发恶戒。或无劳诤理应同许。且如有一受屠羊人。虽一生中不与不取。于己妻妾住知足心。哑不能言无语四过。而因羊坏善阿世耶。具得七支不律仪罪。如是于亲等虽无害心。而善阿世耶因羊坏故。遍有情界得不律仪。若先要期受善学处。后不全损善阿世耶。由遇别缘唯受杀者得处中罪非不律仪。但得不律仪必应全损善阿世耶故具得七支。经部诸师于此僻执。随所期限支具不具。及全分一分皆得不律仪。律仪亦然唯除八戒。由随彼量善恶尸罗性相相违互相遮故。若尔应受不律仪人亦名近事。应诸近事亦得名为不律仪者。云何应尔理逼应然。谓屠羊人立如是誓。我为活命虽受杀羊。然受离余不与取等。或诸近事作是誓言。我定受持离杀生戒。为活命故唯受盗等。无如是理一相续中二阿世耶互相违故理应如是。所以者何。不律仪人若于是处阿世耶坏。唯于是处勿有律仪近事亦然。若于是处阿世耶不坏。唯于是处勿有不律仪。许随彼量善恶尸罗性相相违互相遮故。若一一处得不律仪。即能总遮一切善戒及一一处。得善律仪即能总遮一切恶戒。是故无有不律仪人亦名近事。及无近事亦得名为不律仪者。此亦非理违前说故。虽屠羊人为欲活命但受杀业。然于有情意乐坏故。亦应成就不与取等诸不律仪。由是理应离盗等者。亦应遮止杀不律仪。若汝意谓诸屠羊者。于他物等意乐不坏不应获得彼不律仪。岂不亦应离盗等者。有于羊所意乐既坏。不应遮遏杀不律仪。如是还应不免前过。若于是处有善意乐。即于是处唯得善尸罗。及于是处有恶意乐。即于是处唯得恶尸罗。则不应许由随彼量善恶尸罗互相遮止。此显所受善恶尸罗。非一一支遍能遮故。若汝意谓如善律仪有不具支此亦应尔。谓如有受近事近住勤策律仪。虽不具支而亦得彼缺支摄戒。受不律仪亦应如是。此例非等律仪不律仪用功不用功得有异故。谓诸善戒要藉用功善阿世耶方能受得。以难得故理数必应非受一时总得一切。若诸恶戒不藉用功恶阿世耶便能受得。非难得故理数必应随受一时总得一切。以于欲界不善力强。恶阿世耶任运而起。造诸重恶不待用功。善阿世耶易毁坏故。随受一种便总得余。善则不然故例非等。现见秽草不用功生。要设劬劳嘉苗方起。又如有受不律仪人作是要期我于尽寿。每昼或夜半月月等。一度屠羊等亦得不律仪。由不律仪易受得故。以于欲界不善力强。虽不恒为而得恶戒。诸有欲受出家律仪。若作要期我于尽寿每昼或夜半月月等。一度离杀等不得善律仪。由善律仪难受得故。以于欲界善法力劣。若不恒持不得善戒此亦应尔为例不齐故。经部师避无根过。而反堕在难拔过中。智者应详无倒取舍。已说从彼得不律仪。得不律仪及余无表。如何方便未说当说。颂曰

  诸得不律仪　　由作及誓受
  得所余无表　　由田受重行

论曰。不律仪人总有二种。一者生在不律仪家。二生余家后受此业诸有生在不律仪家。若初现行杀等加行。是人由作得不律仪。若生余家后方立誓。谓我当作如是事业。以求财物养活自身。初立誓时便发恶戒。是人由受得不律仪。由三种因得余无表。余无表者。谓非律仪非不律仪处中摄故。由三因者。一者由田。谓于如斯有德田所。初施园林等善无表便生。如说。有依诸福业事。二者由受。谓自要期言。我从今若不供养佛及僧众不先食等。或作誓限于斋日月半月及年常施食等。由此有善无表续生。三由重行。谓起如是殷重作意行善行恶。谓淳净信或猛利缠。造善恶时能发无表。长时相续乃至信缠势力终尽。如前已说。如是已说得律仪等。舍律仪等今次当说。且云何舍别解律仪。颂曰

  舍别解调伏　　由故舍命终
  及二形俱生　　断善根夜尽
  有说由犯重　　余说由法灭
  迦湿弥罗说　　犯二如负财

论曰。调伏声显律仪异名。由此能令根调伏故。由五缘舍别解律仪。一由故舍谓于律仪由阿世耶不怀欣慕。为舍学处对有解人发起相违表业差别。非但由起舍学处心。如得律仪心无能故。又在梦中舍不成故。非但由起表业差别忿癫狂等舍不成故。非但由二对傍生等起心发表舍不成故。二由命终。谓众同分增上势力得律仪故。三由依止二形俱生。谓身变时心随变故。又二形者非增上故。四由断灭所因善根。谓表无表业等起心断故。是此律仪因缘断义。舍尽寿戒由上四缘。近住律仪亦由夜尽。谓近住戒由上四缘。及夜尽舍过期限故。夜尽者。谓明相出时。诸轨范师多分共许如是五种舍律仪缘。有余部师执。随犯一感堕重罪舍出家戒有余部执。正法灭时别解律仪无不皆舍。以诸学处结界羯磨所有圣教皆息灭故。尔时虽无得未得律仪。而先得律仪无有舍义。迦湿弥罗国毗婆沙师。蕴理教于心作如是说。非犯随一根本罪时一切律仪有皆舍义。然犯重者有二种名。一名具尸罗。二名犯戒者。若于所犯应可悔除发露。悔除唯名具戒。如有财者负他债时。名为富人及负债者。若还债已但名富人。此亦应然故非舍戒。以何理教蕴在心中。且辨心中所蕴正理。谓如受一一非遍得律仪。应犯一一时非遍舍一切。本于一切有情处所受得律仪。不应今时于一犯罪便舍一切。若汝意谓出家律仪必无别受还别得义。如何可说如非别受遍得律仪。应无犯一遍舍一切故例非等此诘不然。自所许故。谓汝亦许在家律仪非犯根本便舍一切。或汝自许别解律仪。随别受时还得尔所。如是应许犯律仪时。随所犯舍非舍一切。且所受戒有是极成。非犯一时顿舍一切。苾刍勤策理亦应然。设犯重时无容皆舍。或先已说。先说者何。谓阙律仪若名近事。苾刍勤策阙亦应成。故无近事阙律仪者。如彼别犯非舍一切。苾刍勤策例亦应然。或于此中有何理趣。于四重罪随犯一时。出家律仪一切顿舍。非于三种有善意乐。乃至为救自身命缘亦不欲犯非舍一切。如汝宗说得不律仪。若尔何缘薄伽梵说。犯四重者不名苾刍。不名沙门非释迦子。破苾刍体害沙门性。坏灭堕落立他胜名。依胜义苾刍密意作是说。且汝应说何缘犯重便舍一切非犯所余。以犯所余可悔除故。若犯余罪未悔除时不失苾刍性。悔除何所益。更求何益此令苾刍性不缺漏。不朽不杂能令如是成何功德。若令如是便得生天。若尔诸天对持戒者应极可供养。执于尸罗无违犯者专求生彼故。然非圣教专为生天。令苾刍等清净持戒故。非悔者专为生天。既尔应言非犯戒者。可能现证出世功德。故悔除者异不悔除。岂不对于出世功德。可悔除罪未悔除时。彼亦非全破苾刍体。何缘不许犯重苾刍。犯不可除他胜罪故。虽亦成就所余律仪。于出世德毕竟非器。故世尊言非苾刍等。又可除罪未悔除时。如何有余苾刍性在。以彼于入正性离生。及余一切无漏功德皆能为障。乃至为修不净观等。尚不能令心住一境。况能成就。若如是类有苾刍体当自归礼。如是苾刍与犯重人有何差别。是故应许犯重苾刍如无子能子说非子。于无人用人说非人。于无形男说非男等。于苾刍事既不能成。虽有余律仪说非苾刍等。佛如是说于义何违。非唯能持别解脱戒。于佛圣教少有所成。由此律仪招有果故。然诸佛意憎背有果。持戒无缺尚未称情。况犯重人能适佛意。以违佛意如子违父。所作事业不称本期。由此故言非苾刍等。此言非证舍律仪因。毗婆沙师以如是理。蕴在心首决判此言。依胜义苾刍密意作是说。此中经主作如是说。此言凶勃凶勃者何谓。于世尊了义所说以别义释令成不了。与多烦恼者为犯重罪缘。宁知此言是了义说。由律自释有四苾刍。一名相苾刍。二自称苾刍。三乞丐苾刍。四破戒苾刍。此义中言非苾刍者。谓非白四羯磨受具足戒苾刍。非此苾刍先是胜义。后由犯重成非苾刍。故知此言是了义说。岂唯白四羯磨受具足戒苾刍。有犯重罪非由三归三说。受具足戒苾刍亦犯重罪。何理遮此三归得戒。令不犯重成非苾刍。设许此言是了义说。唯白四羯磨受具戒者。若有犯重罪成非苾刍。由此苾刍于生圣法无苾刍用名非苾刍。非舍律仪失苾刍号。故广论者作是判言。依胜义苾刍密意作是说此为善说。以犯重人无生圣道苾刍用故。非由执此是了义言。能遮我宗决判意趣。若异此者复有何缘同犯尸罗。于中则有失戒不失戒苾刍非苾刍故。离对法宗无令生喜。理虽作是谤与多烦恼者为犯重罪缘。然应详审谁最能作犯重罪缘为作是言。虽犯一戒而有余戒应勤护者为作是言。既犯一戒余戒皆失。任造恶者非对法者。此决判言少障生天解脱爱果。然唯示导令彼修因。如何谤言劝他犯重。谓我但作如是诫言。犯一戒时余戒不舍应于余戒专精护持。如是真名遮他犯重。汝说犯一顿舍一切岂不专作犯重罪缘。故造罪缘在汝非我。虽作是说非此苾刍先是胜义后由犯重成非苾刍。此言粗浅虽先未证望当证能。若后无能亦名失故。如契经说观此世间及天放逸退失圣慧。又先已说。先说者何。谓彼永非出世德器故。于胜义言非苾刍。宁知大师有斯密意。由此中说彼非沙门余处复言沙门有四更无第五。故知于此唯就胜义言非苾刍。由彼补特伽罗名污道沙门故。非彼先证道后污如何成。经主释言虽有此说而彼唯有余沙门相故名沙门。如被烧材假鹦鹉嘴涸池败种火轮死人。此但有言所引众喻皆无能故。以诸材木少被火烧。世间说名被烧材木。非全成炭名被烧材。若谓随烧全分一分二种皆许名被烧材。则喻及法二俱犹豫。喻于所喻无证功德。名涸池中容有少水但无池用故立涸名。设水全无亦名涸者同前犹豫。于证无能由此已遮死人败种。谓虽犹有少种功能而诸世间亦说败种。或虽不败被损功能不复生芽亦名败种。有同死法亦名死人。故契经中言放逸者。常死假鹦鹉嘴及旋火轮二喻皆违契经所说。沙门有四更无第五。若唯形相得名沙门。如世有人须沙门相矫设方便作沙门形。应名沙门说为第五。非彼假嘴及旋火轮可得说名嘴轮。余相非实嘴轮为其先故。如是应有先非沙门作沙门形立为第五。然佛说四无第五言。为止如斯相沙门执故引众喻皆无证能。又经主宁知佛如是意说。以余处说不名苾刍不名沙门非释子等。岂不数劝应审寻思。宁随一文便为固执。又先已说。先说者何。谓此沙门名污道故。知此唯约胜义苾刍密意说言非苾刍等。故非顿舍一切律仪。名非苾刍理极成立。非此唯有余沙门相故名沙门。如被烧材鹦鹉嘴等理可成立。以世尊说彼人应名犯戒苾刍恶苾刍故。若彼顿舍一切律仪。应但名为无尸罗等。宁标犯戒恶苾刍名。上座此中作如是诘。若言无者无何尸罗。以尸罗名亦目串习善恶戒。外亦见有言此善尸罗恶尸罗者作如是说何理相违。彼最应言无尸罗者。以一切有串习尸罗。然说彼为无尸罗者。则知彼阙净戒尸罗。故彼诘言无深理趣。经主于此自问答言。若犯重人非苾刍者则应无有授学苾刍不说犯重人皆成他胜罪。但成他胜罪定说非苾刍。对法诸师岂不应说。经部定是极凶勃人。凶勃者何。谓作是说有犯重者非成他胜。以世尊说犯四重者不名苾刍乃至广说。若谓彼据住覆藏心故佛说为非苾刍等。何缘不许犯重苾刍无苾刍胜能。言非苾刍等非由顿舍一切律仪。我国诸师不作是说。诸犯重者非非苾刍。但作是言有余戒在。本于一切受得律仪。非犯一时余便顿舍。如汝宗说得不律仪。经主此中欲排正理。言彼所说非犯一边一切律仪应遍舍者。彼言便是征诘大师。大师此中立如是喻。如多罗树若被断头必不复能生长广大。此喻意显犯一重时余戒不能生长广大。戒根既断理遍舍故。彼于喻意非能善释。此喻但遮余生长故。若异此者喻应不成。然我分明见此喻意。谓余学处如彼枝叶虽越而可得余律仪。四重如头若随犯一必不复得所余律仪。由此定无入见道等。故契经说依住尸罗方能进修殊胜止观。若异此释喻便不成。且汝所宗四重学处。为总如一多罗树头。为一树头喻一学处。若四学处总喻一头。应犯一时非舍一切。见断少分多罗树头余分无妨犹生长故。若一学处如一树头。亦犯一时非舍一切。以见断一多罗树头余头无妨犹生长故。如前已说。前说者何。谓于此中有何理趣。随犯一重顿舍律仪。非护余三不舍一切。如多罗顶断一余存。既见世间多罗树顶虽断一分余分犹生。四重总如多罗树顶。应知犯一无损余三。又诸多罗一头被断一不生长余树不然。汝执尸罗一相续断则余亦断故喻不成。由此亦遮上座立喻。彼说如大树具根茎枝叶。若根被断便总干枯。如是戒根若随犯一则便顿坏一切律仪。谁于此中言余不坏。已说犯一余无胜能。谓必不能入见道等。然就彼喻非失律仪。以见世间或有一树四根齐等深入坚牢。非断一时一切枯死。唯损一分戒亦应然。就别树论准前应说故彼立喻于证无能。经主此中复作是说。于此无义苦救何为。若如是人犹有苾刍性应自归礼。如是类苾刍此言便为轻调于佛。以佛说彼亦是沙门。虽得污道名而有尸罗故。经主此中应作是说。于此无义何苦救为。若如是人犹有沙门性应自归礼。如是类沙门余相沙门。如前已破非苾刍等。亦已释通由此理成。显彼所引诸余圣教为证无能。又彼不能少说正理。证唯犯一便舍一切。又于无义徒致推征。实有律仪强言已舍。劝已犯者纵情造恶。岂名持法利乐有情。若犯重人有余戒在。何缘摈出苾刍众外。何用如是无势用人。于清众中速摈弥善。若由犯重便舍律仪。应如二形生时能舍。性相违故如闇与明。不犯律仪应容更受。非无惭愧永障尸罗。勿舍彼人不得受戒。故知重罪得与戒俱。由污尸罗不容更受。既无胜用故应摈出。上座于此更有多言。由前理教已总遮遣。恐文烦广不别弹斥。然彼坚固烦恼缠心。于自论中造文作颂。说粗恶语谤讟圣贤。无故自伤深为可愍。我国众圣惑业已除。所制法言凭真理教。而彼凶勃谤法毁人。既造深愆当招剧苦。我岂于彼更致酬言。唯愿当来彼恶无报。静虑无漏二律仪等云何当舍。颂曰

  舍定生善法　　由易地退等
  舍圣由得果　　练根及退失

论曰。诸静虑地所系善法由二缘舍一由易地。谓上下生。二由退失。谓退胜定舍众同分。及离染时亦舍。暖等及退分定为摄此故复说等言。经主释中应加离染。如舍色善由易地退及离染。三无色亦尔。舍无漏善由三种缘。一由得果总舍前道。二由练根舍钝根道。三由退失舍诸胜道。此或是果或胜果摄。经主于此应说二缘。以得果言摄练根言。谓练根位必还得果弃舍钝果胜果道故。我于此中应少分别。若舍见道及道类智。当知但由得果非退。若不动法无学俱无所余无漏容具二种。如是已说舍诸律仪。不律仪云何舍。颂曰

  舍恶戒由死　　得戒二形生

论曰。诸不律仪由三缘舍。一者由死舍所依故。二由得戒。谓若受得别解律仪。或由获得静虑律仪恶戒便舍。对治力胜舍不律仪。三由相续二形俱起。以于尔时所依变故。住恶戒者虽或有时由善意乐舍刀网等。若不得律仪终不舍恶戒。现见虽避诸发病缘。不服良药病终难愈。不律仪者。受近住戒至夜尽位舍律仪时。为得不律仪为名处中者。有余师说。得不律仪恶阿世耶非永舍故。如停热铁赤灭青生。有余师言。若不更作无缘令彼得不律仪。以不律仪依表得故。前说应理。先受戒时恶阿世耶非永舍故。依前表业恶戒还起。处中无表舍复云何。颂曰

  舍中由受势　　作事寿根断

论曰。处中无表舍由六缘。一由受心断坏故舍。谓先誓受恒于某时敬礼制多。及赞颂等今作是念。后更不为彼阿世耶。从兹便息由彼弃舍本意乐故。或复别作势用增强与先现行相违。事业本意乐息无表便断。二由势力断坏故舍。谓由净信烦恼势力所引无表。彼二限势若断坏时无表便舍。如所放箭及陶家轮。故轨范师作如是说。由等起力所引发故。虽舍加行及阿世耶无表。或容尽寿随转。乃至发起极猛利缠捶击禽兽应知亦尔。或先立限齐尔所时今限势过无表便断。三由作业断坏故舍。谓虽不舍根本受心。然更不为所受作业。唯除忘念而不作者以此无表期加行生。绝加行时无表便舍。四由事物断坏故舍。谓所舍施制多园林。及所施为罝网等事。本由彼事引无表生。彼事坏时无表便舍。五由寿命断坏故舍。谓所依止有转易故。六由依根断坏故舍。谓起加行断善恶时。各舍彼根所引无表。非至断善得静虑时方舍。处中善恶无表以羸劣故起加行时便舍。处中善恶无表如何。经主于此义中说第六缘名为断善。若作是说断善加行亦名断善为第六缘。是则应言静虑加行亦名静虑。便成七缘静虑加行中舍恶无表故。应言根者通善恶根。所说断言是断加行由依根断为第六缘。此释颂文于理无失。欲非色善及余一切非色染法舍复云何。颂曰

  舍欲非色善　　由根断上生
  由对治道生　　舍诸非色染

论曰。欲界一切非色善法舍由二缘。一断善根。二生上界。应言少分亦离染舍。如忧根等非色善法。三界一切非色染法舍由一缘。谓起治道若此品类能断道生。舍此品中惑及助伴。何有情有善恶律仪。颂曰

  恶戒人除北　　二黄门二形
  律仪亦在天　　唯人具三种
  生欲天色界　　有静虑律仪
  无漏并无色　　除中定无想

论曰。唯于人趣有不律仪。然除北洲唯三方有。于三方内复除扇搋及半择迦具二形者。律仪亦尔。谓于人中除前所除并天亦有故。于二趣容有律仪。复以何缘知扇搋等所有相续非律仪。依由经律中有诚证故。谓契经说佛告大名。诸有在家白衣男子男根成就乃至广说。毗奈耶中亦作是说。汝应除弃此色类人。故知律仪非彼类有。复由何理彼无律仪。由二所依所起烦恼于一相续俱增上故。于正思择无堪能故。彼起贪欲相续行时不能伏除故非戒器。又有猛利惭愧现前。此类方能为戒依止。彼类无故非律仪依。若尔何缘彼无恶戒。于彼相续恶阿世耶性羸劣故不坚住故。谓扇搋等淫爱多行。无暂伏除对治道故。非诸数起猛利爱人能于有情。起极猛利勃恶意乐令现在前。设暂能生亦不坚住。身无能故心亦无能故彼类身亦无恶戒。即由此理善阿世耶。于彼身中劣不坚住。要有强盛坚住恶心方有恶戒。及有强盛坚住善心方有善戒。彼俱阙故二戒俱无。然二形生舍善恶戒二依。贪欲极增上故。非成扇搋等舍善恶律仪。起二依贪非极重故。由如是理已释北洲。二阿世耶非猛利故。又不顺起三摩地故。彼身无有善恶律仪。恶趣无能觉耶正理。又非猛利惭愧所依。要此相应及损坏者。方可得有善恶律仪。故恶趣中无善恶戒。又扇搋等如碱卤田。故不能生善戒恶戒。世间现见诸碱卤田。不能滋生嘉苗秽草。若尔何故契经中言。有卵生龙半月八日每从宫出来至人间。求受八支近住斋戒此得妙行非得律仪。是故律仪唯人天有。然唯人具三种律仪。谓别解脱静虑无漏。若生欲天及生色界皆容得有静虑律仪。然无想天但容成就。生无色界彼俱非有无漏律仪亦在无色。谓若生在欲界天中及生色界中。除中定无想皆容得有无漏律仪。生无色中唯得成就。以无色故必不现起。无漏上生得成下故

说一切有部顺正理论卷第三十九阿毗达磨顺正理论卷第四十

        尊者众贤造

        三藏法师玄奘奉　诏译

    辨业品第四之八

因辨诸业性相不同。当释经中所摽诸业。且经中说业有三种。善恶无记其相云何。颂曰

  安不安非业　　名善恶无记

论曰。诸安隐业说名为善。能得可爱异熟涅槃。暂永二时济众苦故。不安隐业名为不善。由此能招非爱异熟。极能遮止趣涅槃故。非前二业立无记名。不可记为善不善故。是非安隐不安隐义。又经中说业有三种。福非福等其相云何。颂曰

  福非福不动　　欲善业名福
  不善名非福　　上界善不动
  约自地处所　　业果无动故

论曰。欲界善业说名为福。非福相违招爱果故。诸不善业说名非福招非爱果违福业故。上二界善说名不动。岂不世尊说下三定皆名有动。圣说此中有寻伺喜乐受动故。由下三定有寻伺等灾患未息故立动名不动。经中据能感得不动异熟说名不动。如何有动定招无动异熟。虽此定中有灾患动而业对果非如欲界有动转故立不动名。谓欲界中余趣处满业。由别缘力可异趣处受。以或有业能感外内财位形量色力乐等。于天等中此业应熟。由别缘力所引转故。于人等中此业便熟。色无色界余地处业。无容转令异地处受业果处所。无改动故等引地摄无散动故。依如是义立不动名。应知此中由于因果相属愚故造非福业。以非福业纯染污故。要依粗重相续无明。由此无明现在前位。不能解信因果相属。是故发起诸非福行。由真实义愚故造福及不动业。真实义者。谓四圣谛。若于彼愚诸异生类。于善心位亦得间起。由此势力令于三界。不如实知其性皆苦。起福不动行为后有因。若已见谛者则无是事。乘先行力渐离染时。如次得生欲色无色。又经中说业有三种。顺乐受等其相云何。颂曰

  顺乐苦非二　　善至三顺乐
  诸不善顺苦　　上善顺非二
  余说下亦有　　由中招异熟
  又许此三业　　非前后熟故
  顺受总有五　　谓自性相应
  及所缘异熟　　现前差别故

论曰。诸善业中始从欲界。至第三静虑名顺乐受业。以诸乐受唯至此故。诸不善业名顺苦受。第四静虑及无色善业说名为顺不苦不乐受。此上都无苦乐受故。非此诸业唯感受果。应知亦感彼受资粮。受及资粮此中名受。随所化欲总立受名。下诸地中为亦许有顺非二业为决定无。有余师言。下地亦有顺非二业。以定中间既无苦乐应无业故。岂不中定与初静虑同一缚故。此中定业感初定中乐根异熟。理不应尔违本论故。谓本论言。颇有业感心受异熟非身耶。曰有。谓善无寻业中间定业既是无寻。若感根本乐根异熟应无寻业。通感身心二受异熟便违本论。然应此业唯感心受。如不善业唯感身受。设许通感无违本论。本论应言善无伺故。或非诸业皆感受果故。彼应感色心不相应行。然于一切无寻业中。有业唯能感心受果。偏就彼说故无有过。是故中定业感异熟非证。下地有顺非二业因。若尔此中更有余证。谓本论说。颇有三业非前非后受异熟耶。曰有。谓顺乐受业。色顺苦受业。心心所法顺不苦不乐受业。心不相应行乃至广说。由此证知下地亦有顺非二业。非离欲界有此三业俱时熟故。此亦非证。以本论中说三界业如三受故。然非三界所系诸业可俱时受。此亦应然。而本论言有三界业俱时熟者。为欲试验于对法宗解不解故。或于增上果说受异熟声。色无色思资下异熟。令其久住故作是言。顺三受业文亦容作此释。故彼所引非定证因。何苦推征彼所计执。见彼所计执违品类足故。如说。云何顺乐受业。谓从欲界系至三定善业。无违彼失无定言故。谓彼不言唯顺乐受。然下虽有顺非二业而由少故彼文不显。不可准此便作是言。上地亦应有顺苦乐。离苦乐染方生彼故。由此唯说从广果天乃至非想有顺非苦非乐受业。不说下地以上地无相违受故。于下地有相违受故。以于下地容有非苦非乐异熟。不可如彼三界系业定判。此文无容有容实俱受故。此业为善为不善耶。有作是言。是善而劣。又不可别示而可总言。于诸善业中或有一类能感乐受及受资粮或有一类能感非二。应知此业能益乐受名顺乐受如顺马处。或复此业能受于乐名顺乐受如顺浴散。顺余受业应知亦然。顺乐受业唯感乐受异熟果耶。唯感乐受异熟果者一切皆是顺乐受业。或有诸业名顺乐受而不能感乐受异熟。谓此若感色不相应。顺余受业应知亦尔。此业非唯感受异熟。如何总得顺受业名。诸业为因所感异熟皆似于受得受名故。所以者何。彼皆如受为身益损及平等故。如水火等于树枝等为益为损为等义成。又顺受多略说有五。一自性顺受。谓诸受体。如契经说。受乐受时。如实了知受于乐受乃至广说。二相应顺受。谓一切触。如契经言。顺乐受触乃至广说。三所缘顺受。谓一切境。如契经言。眼见色已。唯受于色不受色贪乃至广说。由色等是受所缘故。四异熟顺受。谓感异熟业。如契经说。顺乐受业乃至广说。五现前顺受。谓现行受。如契经说。受乐受时二受便灭乃至广说。非此乐受现在前时。有余受能受此乐受。但据乐受自体现前即说名为受。于乐受由所顺受有多种故。虽业异熟非皆是受而可总立顺受业名。谓诸善业为因所感。色不相应能为所缘生乐受故。是诸乐受所领纳故。可爱异熟顺乐受故亦名乐受。由此善业所招诸果。虽非乐受顺乐受故。招彼业名顺乐受业。顺苦非二理亦应然。如是三业有定不定其相云何。颂曰

  此有定不定　　定三顺现等
  或说业有五　　余师说四句

论曰。此上所说顺乐受等应知各有定不定异。非定受故立不定名。谓顺乐业非必定熟。若熟必应受乐异熟。顺余二业说亦如是。定复有三。一顺现法受。二顺次生受。三顺后次受。此三定业定感异熟。并前不定总成四种。或有欲令不定受业复有二种。谓于异熟有定不定。并定业三合成五种。顺现法受业体云何。谓于此生造作增长。唯此生受异熟非余。于此生言显众同分。为显加行根本业道。说造作言为显后起故说增长。或造作者显牵引业。言增长者显圆满业。或造作者。谓率尔为。言增长者。谓思已作。或造作者追悔所损。言增长者欢喜摄受。或以同类为助伴业。名为造作亦名增长。如善还以善为助伴。与此相违唯名造作。或有坚执而造作者名为造作亦名增长。与此相违唯名造作。或依具足名为造作。若由具足名为增长。如是等释义有多门。言唯此生受异熟者显时分定。然或有谓于人生中造作增长。还唯于此人生余身受异熟者。亦得名为顺现法受。为遮此执复说非余。此则显示有死生者。可言唯此不名非余。由此显业时分不坏。令极分明绝诸疑网。如何由此说非余言。便令定知非余身受。以或可释此非余言。是遮非人生非遮余身故。此释非理前唯此言遮非人生义已成故。谓前既说唯此生言。已定显成非非人类。然复于后说非余言。为遮余身义极明了。若异此者重说何为。故此业名顺现法受。以现法者是现身义。顺次生受业体云何。谓此生造业于无间生受。所言生者是生处义。造业生后无间而生故名次生。是次后生义顺彼生业名顺次生受。顺后次受业体云何。谓此生造业无间生后受。所言后者是无间生后众同分。所言次者显于多生次第别受。此言意显顺后受业决定次第各招一生。为避言词繁广过失。故于多业总立一名。云何名为顺不定受。谓薄伽梵见一类业。或由尸罗或由正愿或由梵行或由等持或由智力。令全无果或令轻微。或令移位。说此一切名不定业。为转此业应修净行。诸有情类此业最多。然契经言或有诸业应现法受。而或转于地狱受者。非此中辨顺现受业。意说有业顺不定受。若能精修身戒心慧。此所造业应人间受。由不精修身戒心慧。便乘此业堕奈落迦。契经又言或有诸业应地狱受。而或转于人中受者。此亦非辨时分定业但说不定释义准前。或释前经意说有业。虽是造作而非增长。若任其力应现法受。若后复造感地狱业。资助令增往地狱受。故契经说有业应于人中现受。由后复造感地狱业令增长故。转彼令于地狱中受。是故知彼说不定业。譬喻者说。顺现受业等于余生中亦得受异熟。然随初熟位立顺现等名。非但如名招尔所果。谓彼意说诸所造业。若从此生即能为因。与异熟果者名顺现法受。若从次生方能为因。与异熟果者名顺次生受。若越次生从第三生方与异熟者名顺后次受。何缘彼作如是执耶。勿强力业异熟少故。彼执非善。所以者何。彼业先时已生异熟。中间间断异熟复生理必不然如种芽故。若谓无间而生后身。应无死生业无异故。或身无异应数死生。又一业招二三生等。是诸果相为异为同相。若异者应如别业所感相续非一业果。或一业果其相应同。应说何缘前后相别。若谓满业助力使然。应唯一生前后有别。现见引业所引一生。虽有众多满业果异。而引业一但名一生。此亦应然无别因故。相若同者应是一生。非一生中前后相等。而可见有前后生殊。此亦应然一业果故。然不可谓唯一生身。便是众多引业所感。以能引业有差别故。或于本有应有死生。或应毕竟无死生理。又彼一业所感多生。为一趣中为在多趣。若在一趣过如前说。谓前与后应是一生。或一生中应数生死。以一业果无差别故。若在多趣诸趣相望有上中下品类别故。同一业果理必不成。以一刹那所造一业。有上中下理不成故。又若尔者趣应相杂。然趣无杂如前已辨。若谓余业所引生中。有于前生已得果业。感果势力犹未尽故。寄此生中更受异熟故。虽一业能感多生。而有死生果相差别此亦非理。所以者何。寄他生中更受果业。牵引圆满俱不成故。谓寄他生所受异熟。为是引果为满果耶。且不应言寄受引果。此生引果余业引故。一果不应引已复引。应随一业唐捐其功。后业于中极为无用。亦不应说于一生中有二引果勿有所受。一相续中便有多生多趣异熟俱时受过。亦不应言寄受满果。勿有引业于前生中已得引果。有余引力至于今生转成满过。谓有一类顺生受业。感次生中所引果。已今于余业所引生中变成顺后受感满果异熟。是则一业亦引亦满。便有引满杂乱过失。又一切业展转相资是则皆成造作增长。则应毕竟无有一业不受异熟而至涅槃。然彼此宗俱非所许。于譬喻者其过偏多。以彼宗中顺现受等所有诸业皆非决定。然许诸业展转相资理应皆成造作增长。诸有造作亦增长业。世尊经中说为决定。而言诸业皆不定者。当知彼是佛教外人。又于此中彼据何理许于余业所引生中。已于前生引果余业。能为助满资令久住。非于前世自所引生能为满因资令相续。又若有业顺天生受。从天死已生地狱中。如何令天顺生受业。今于地狱受后乐果。从地狱死生于天中。顺彼生业责亦如是。非于天中顺生受业。可于无间地狱受果亦非无间顺生受业。可于天中有受果义。若谓越他趣于自类趣中。此业方能重受果者前已说过。前说者何。谓业先时已生异熟中间间断异熟复生。理必不然如种芽故。虽彼立理证自义言勿强力业异熟果少此亦非证。所以者何。非要果多业名强力。顺现受业名强力者。能速得果故立此名。若一事中起多思愿。于中前后胜劣有殊。能感现生后异熟果言招多果亦无有失。又若执业要感多果方得名强。则感轮王异熟果业。望感佛业应说名强感多果故。若感佛业妙故名强是则名强。业有多种以业强理有多品故。谓或有业果近名强。或由果多或由果妙。然顺现受果近名强。宁以强名证感多果故。对法者说。诸业中顺现等三各别生果。业果无杂。于理为胜。譬喻者说。业有四句。一者有业于时分定异熟不定。谓顺现等三非定得异熟。二者有业于异熟定时分不定。谓不定业定得异熟。三者有业于二俱定。谓顺现等定得异熟。四者有业于二俱不定。谓不定业非定得异熟。彼说诸业总成八种。谓顺现受有定不定。乃至不定亦有二种。于此所说业差别中。颂曰

  四善容俱作　　引同分唯三
  诸处造四种　　地狱善除现
  坚于离染地　　异生不造生
  圣不造生后　　并欲有顶退

论曰。此中唯显顺乐等业。于现等时有定不定。释经所说顺现受等四业相殊故。定业中分为三种并不定业合而为四。是说为善。理必无有异熟不定时分定业。时定唯是异熟定中位差别故。非离异熟别有时体。如何时定非异熟耶。此中但依异熟定业得果位差别立顺现等故。若谓有业于时定者。谓熟必在此时非余。若越此时毕竟不受。故于时定非于异熟。此于异熟亦应决定义相似故。相似者何。谓如于时有或非理而名时分定。如是于熟有或非理应名异熟定。或复应许二俱不定。是故若业于时分定彼于异熟亦应决定。若于异熟名不定者。彼于时分亦应不定。由此理故定无八业。以于诸业中有不定义者。应总立一顺不定受。所以者何。义相似故。谓如熟定时不定业。时不定故既共许为顺不定受。如是时定熟不定业。熟不定故何不许为顺不定受。故譬喻者于此义中安立八业极为杂乱。又譬喻者说一切业。乃至无间皆悉可转。若无间业不可转者。应无有能越第一有。今观彼说有如是意。若谓诸业中少有不可转。则有顶业定为其先。以诸业中第一有业是极微细。诸生死本力能摄受广大异熟。无始生死流转有情。曾无有能越于彼者。若有能转如是类业。则无间业宁不可转。此亦但是虚妄僻执。以无间业异熟分位二俱决定。有顶不然故所引例无能证力。若有顶业皆不可转。起彼定者应定招生。是则无容起彼定已。证无学果及般涅槃。若一切业皆可转者。世尊不应说有定业。颇有四业俱时作耶。容有。云何遣三使已自行邪欲俱时究竟。顺现受等四种业中几业有能引众同分。唯三能引除顺现业。以顺现业必依先业所引同分而得起故。即于现生必与果故。何界何趣能造几业。诸界诸趣或善或恶。随其所应皆容造四。总开如是。若就别遮捺落迦中。善除顺现无爱果故余皆得造。有余师说。色无色界决定无有顺现受业。以顺现业必依殊胜境界加行方可成立谓于父母佛阿罗汉及余胜德。所熏修身为损益事能招现果。或于余境发起猛利坚执加行亦招现果。如是类业上界俱无。故二界中无顺现业。彼执非理余容起故。谓上二界亦有胜业。势力速疾能招现果。故上二界虽无如前缘胜境等顺现受业。而有胜定能招现果。顺现受业类非一故。由是摄中作如是说。顺现等四业皆欲界。一切色无色遍行修所断随眠之所随增故。一切处皆具能造如是四业。不退性名坚彼于离染地。若异生类除顺生受可造余三。圣者双除顺生后受可造余二。异生不退若离彼染。无容于彼无间受生。故彼应除顺生受业。于上地殁必还生下。故容造彼顺后受业。圣者不退若离彼染。必无容有于彼更生。故彼双除顺生顺后。随所生地容造顺现受。造不定业一切处无遮。然诸圣者若于欲界及有顶处。已得离染虽有退堕。而亦不造顺生后业。从彼退者必退果故。诸退果已必不命终还得本果。住中有位亦造业耶亦造云何。颂曰

  欲中有能造　　二十二种业
  皆顺现受摄　　类同分一故

论曰。于欲界中住中有位。容有能造二十二业。谓中有位及处胎中。出胎以后各有五位。胎中五者。一羯剌蓝。二頞部昙。三闭尸。四键南。五钵罗奢佉。胎外五者。一婴孩。二童子。三少年。四中年。五老年。此十一位一生所摄。住中有位能造中有。定不定业乃至能造。老年二业应知亦尔。当知如是中有所造十一种。定业皆顺现受摄。由类同分无差别故。谓此中有位与自类十位一众同分一业引故。由此不别说顺中有受业。即顺生等业所引故。类同分者。谓人等类非趣非生。以约趣生中有生有同分异故。诸定受业其相云何。颂曰

  由重惑净心　　及是恒所造
  于功德田起　　害父母业定

论曰。若所造业由重烦恼。或淳净心或常所作。或于增上功德田起。功德田者。谓佛法僧。或增上补特伽罗。谓证世出世胜德。于此田所虽无重惑及淳净心亦非常行。若善不善所起诸业。或于父母设起下缠行损害事。如是一切皆定业摄。有余师说。若以猛利意乐所造。或有造已起欢喜心。或一切时数数串习。或胜愿力事力所起业皆决定。现法果业其相云何。颂曰

  由田意乐胜　　及定招异熟
  得永离地业　　定招现法果

论曰。由田胜者闻有苾刍。于僧众中作女人语。彼须臾顷转作女人。此等传闻其类非一。意乐胜者闻有黄门救脱诸牛黄门事故。彼须臾顷转作丈夫。此等传闻事亦非一。或有余业亦得现果。谓生此地永离此地染。于此地中诸善不善业必应现受不重生故。如阿罗汉及不还者。未离染时已造彼业。今离染故成现法受。彼是何业。谓异熟定。应知此中所说业者。是异熟定非时定业。若有余位顺定受业。彼必定无永离染义。必于余位受异熟果。若于异熟亦不定者。永离染故不受异熟。诸不还者及阿罗汉。于欲三界设退起染。必不生下定涅槃故。异熟定业皆成现受。余随所应类此当说。何田起业定即受耶。颂曰

  于佛上首僧　　及灭定无诤
  慈见修道出　　损益业即受

论曰。于如是类功德田中。为善恶业定即受果。功德田者谓佛上首僧。约补特伽罗差别有五。一从灭定出。谓此定中得心寂静。此定寂静以涅槃故。若从此定初起心时如入涅槃。还复出者胜静功德庄严其身。为殷净心生长依处。二从无诤出。谓此定中已能永拔一切烦恼灾患相续。有缘一切有情为境。所起无边增上意乐。无诤功德积集熏身。从此出时彼心相续。不为一切世间定心。及不定心之所胜伏。是福非福近果胜田。三从慈定出。谓此定中有缘无量有情为境。利益安乐增上意乐积集熏身。出此定时有为无量最胜功德。所熏修身相续而转能生胜业。四从见道出。谓此道中能超一分。无始流转所不能超。三界轮回生死根本。从此道出有胜净身。相续而生能生胜业。五从修道出。谓此道中能超一分生死根本。余如前说。从如是五初出位中。乘前所修胜功德势。心犹反顾专念不舍。诸根寂静特异于常。世出世间定不定福。无能胜伏映夺彼者。故说此五名功德田。若有于中为损益业。此业必定能招即果。若从余定余果出时。由前所修定非殊胜。修所断惑未毕竟尽。故彼相续非胜福田。异熟果中受最为胜。今应思择于诸业中。颇有唯招心受异熟。或招身受非心受耶。亦有云何。颂曰

  诸善无寻业　　许唯感心受
  恶唯感身受　　是感受业异

论曰。善无寻业谓从中定乃至有顶所有善业。于中能招受异熟者。应知但感心受非身。于彼地中无身受故。身受必定与寻相应。非无寻业感有寻果。诸不善业能感受者。应知但感身受非心。以不善因苦受为果。意地苦受决定名忧。忧受必非异熟果摄。故不善业唯感身受。若执忧根定非异熟。诸有情类所发心狂。在何识中何因所感。依何处起非异熟耶。颂曰

  心狂唯意识　　由业异熟生
  及怖害违忧　　除北洲在欲

论曰。有情心狂唯在意识。若在五识必无心狂。以五识身无分别故。由何因故有情心狂。由诸有情业异熟起。由何等业异熟起耶。谓由彼用药物咒术令他心狂。或复令他饮非所欲若毒若酒。或现威严怖禽兽等。或放猛火焚烧山泽。或作坑阱陷坠众生。或余事业令他失念。由此业因于当来世。感得异类大种异熟。由彼势力令心发狂。由此心狂体非异熟。善恶心等皆容狂故。由斯但说业异熟生。谓恶业因感不平等异熟大种。依此大种心便失念故说为狂。如是心狂对于心乱应作四句。谓有心狂而非心乱。乃至广说。狂非乱者。谓诸狂者不染污心。乱非狂者。谓不狂者诸染污心。狂亦乱者。谓诸狂者诸染污心。非狂乱者。谓不狂者不染污心。有情心狂为但由此。更由四种。其四者何。一由惊怖。谓非人等现可怖形来相逼迫。有情见已遂致心狂。二由伤害。谓因事业恼非人等。由彼嗔故伤其支节遂致心狂。有情身中有别支节。若被打触心即发狂。三由乖违。谓由身内风热痰界互相违反。大种乖适故致心狂。四由愁忧。谓因丧失亲爱等事。愁毒缠怀心遂发狂如婆私等。何有情类有此心狂。除北俱卢所余欲界诸有情类容有心狂。谓欲天心尚有狂者。况人恶趣得离心狂。地狱恒狂众苦逼故。谓诸地狱恒为种种异类苦具伤害。末摩猛利难忍苦受所逼尚不自识况了是非。故地狱中怨心伤叹猖狂驰叫。世传有文。欲界圣中唯除诸佛。大种乖适容有心狂无异熟生。若有定业必应先受后方得圣。若非定业得圣道故。能令无果亦无惊怖。以诸圣者超五畏故。亦无伤害以诸圣者。无非人等憎嫌事故。亦无愁忧以诸圣者证法性故。一切如来心无狂乱。无渐舍命无破音声。亦无发白面皱等事。以极淳净妙业所生。又经中说业有三种。谓曲秽浊。其相云何。颂曰

  说曲秽浊业　　依谄嗔贪生

论曰。身语意三各有三种。谓曲秽浊如其次第。应知依谄嗔贪所生。谓依谄生身语意业。名为曲业。谄曲类故。实曲谓见故契经言。实曲者何。谓诸恶见谄是彼类故得曲名。从谄所生身语意业曲为因故果受因名。是故世尊说彼为曲。若依嗔生身语意业名为秽业。嗔秽类故嗔名秽者。谓嗔现前如热铁丸。随所投处便能烧害自他身心。诸烦恼中为过最重故。薄伽梵重立秽名。是诸秽中之极秽故。从嗔所生身语意业秽为因故果受因名。是故世尊说彼为秽。若依贪生身语意业名为浊业。贪浊类故贪名浊者。谓贪现前染着所缘是染性故。从彼生等准前应释。又真直道。谓八圣支。能障彼生三业名曲。真实无病。谓永涅槃障证彼因三业名秽。依外道见于佛教中障净信心不信名浊。以能扰浊净信心故。信从彼所起三业名浊。又堕断常违处中行。从彼所起身语意业违直道义故立曲名。由损减见所起诸业能秽净法故立秽名。秽名必依极秽义故。萨迦耶见所起诸业能障无我真实净见。依障净义故立浊名

说一切有部顺正理论卷第四十阿毗达磨顺正理论卷第四十一

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩业品第四之九

又经中说业有四种。谓或有业黑黑异熟。或复有业白白异熟。或复有业黑白黑白异熟。或复有业非黑非白无异熟。业能尽诸业。经虽略示而不广释。今应释彼。其相云何。颂曰

  依黑黑等殊　　所说四种业
  恶色欲界善　　能尽彼无漏
  应知如次第　　名黑白俱非

论曰。佛依业果性类不同。所治能治殊说黑黑等四。诸不善业一向名黑。以具染污黑不可意黑故。异熟亦黑。不可意故色界善业一向名白。不为一切不善烦恼。及不善业所陵杂故。异熟亦白。是可意故。依何意趣除无色善有说此中举初显后或色界中有可意白。及明了白可施设故。独立白名。无色界中有可意白。无明了白可施设故。不立白名。或色界中具中生有二白性故。独立白名。如契经言。或男或女成身妙行。广说乃至。死后感得有色意成如白衣光。或明白夜。或于色界具足三业。及十业道。无色不然。而契经中有说静虑无量无色。皆名白白异熟业者。彼据纯净可意异熟通立白名。然彼契经非了义说。以于上界四蕴五蕴一切善法说业声故。诸异熟因由业所显。故非业者亦立业名。证知彼经非了义。说欲界善业名为黑白。恶所杂故。异熟亦黑白。非爱果杂故。此黑白名依相续立非据自性。所以者何。以无一业及一异熟是黑亦白互相违故。若尔恶业果善业果杂故。是则亦应名为白黑。此难非理。以欲界中不善数行力能伏善故。彼苦果杂乐异熟。欲界善劣无有功能。陵伏不善。故彼乐果亦无功能杂苦异熟。故恶业果得纯黑名。有余师言。欲界善业意乐加行黑白杂起。由此故立黑白二名。非一业体有善有恶。云何如一为诳害他。意欲令他信附于己。先矫行施乃至出家如是名为虽意乐黑而加行白或复有一于子门人。为欲遮防非利乐事。及令安住利乐事中。以怜愍心起粗身语。楚挞诃骂逼迫有情。如是名为虽加行黑而意乐白。若尔不善应名白黑。以如善业亦有如前意乐加行白黑杂起。然非所许前说无失。诸无漏业能永断尽前三业者名第四业。此无漏业非染污故得非黑名于理无失。不堕界故。断异熟故。名无异熟亦无有失。既是胜义白。何故名非白。佛亦于彼大空经中告阿难陀。诸无学法纯善纯白一向无罪。本论亦言云何白法谓诸善法无覆无记。此有密意说非白声密意者何。谓此中说治前三业立为第四。勿所化者生如是疑。如何此中白能治白。为显能治胜所治故。约招异熟立非白名。以不能招白异熟故。或无学法于超一切染身中可得故。立纯白名。非如学法非超一切染身中可得故。不名纯白。故彼经中依如是义。于无学法说纯白声。今此经中以无漏业非顺爱故。又不能感白异熟故说名非白诸无漏业为皆能尽前三业不。不尔。云何。颂曰

  四法忍离欲　　前八无间俱
  十二无漏思　　唯尽纯黑业
  离欲四静虑　　第九无间思
  一尽杂纯黑　　四令纯白尽

论曰。于见道中四法智忍。及于修道离欲染位。前八无间圣道俱行有十二思唯尽纯黑。离欲界染第九无间圣道俱行。一无漏思双令黑白及纯黑尽。此时总断欲界善故。亦断第九不善业故。离四静虑一一地染。第九无间道俱行无漏思。此四唯令纯白业尽。所余诸业无异熟故。非所明故于此不论。故于此中唯说十七。与无间道俱行圣思。能永尽前三有漏业。虽尽诸业是圣慧能。然于此中说近对治。虽身语业亦近治三。非慧相应故此不说。何缘诸地有漏善业。唯最后道能断非余。以诸善法非自性断。已断有容现在前故。然由缘彼烦恼尽时方说名为断彼善法。尔时善法得离系故。由此乃至缘彼烦恼余一品在断义不成。善法尔时犹被缚故。颂曰

  有说地狱受　　余欲业黑杂
  有说欲见灭　　余欲业黑俱

论曰。第一第三皆有异说。有余师说。顺地狱受及欲界中顺余受业。如次名为纯黑杂业。谓地狱异熟唯不善业感。故顺彼受名纯黑业。唯除地狱余欲界中异熟皆通善恶业感。故顺彼受名黑白业。如是所说前已遮遣。谓善无能杂不善故。有余师说。欲见所断及欲界中所有余业。如次名为纯黑俱业。谓见所断无善杂故名纯黑业。欲修所断有善不善故名俱业。此亦非理。二所断中俱有业不能感异熟果故。若谓此中所说三业。据有异熟说非无异熟者。不应简言欲见所灭。又强力业理必不应为力劣者之所陵杂。是故不应说修所断诸不善业亦得杂名。亦不应言欲界有善。力胜不善。陵伏恶业非所许故。所以者何。以欲界善非数行故。无有能感一劫果故。又经中说有三牟尼。又经中言有三清净。俱身语意相各云何。颂曰

  无学身语业　　即意三牟尼
  三清净应知　　即诸三妙行

论曰。无学身业名身牟尼。无学语业名语牟尼。即无学意名意牟尼。非意牟尼意业为体。何缘唯说色识蕴中有是牟尼非于余蕴。有余师说。举后及初类显中间亦有此义。如实义者。胜义牟尼唯心为体。故契经说。心寂静故有情寂静此心牟尼。由身语业离众恶故。可以比知。意业于中无能比用。唯能所比合立牟尼。何故牟尼唯在无学。以阿罗汉是实牟尼。诸烦恼言永寂静故。诸身语意三种妙行。可名身语意三种清净无漏妙行。永离恶行烦恼垢故可名清净。有漏妙行犹为恶行。烦恼垢污如何清净。此亦暂时能离恶行烦恼垢故得清净名。或此力能引起无漏胜义清净故立净名。若谓此亦能引烦恼垢故。谓作烦恼等无间缘。是则不应名清净者。此亦非理。善心起时非为染心起加行故。染心无间无漏不生。有漏善心能引无漏。故有漏善得清净名。顺无漏心能除秽故。说此二者为息有情。计邪牟尼邪清净故。又经中说有三恶行。又经中言有三妙行。俱身语意相各云何。颂曰

  恶身语意业　　说名三恶行
  及贪嗔邪见　　三妙行翻此

论曰。一切不善身语二业。前后近分及与根本。并不善思如次名身语意恶行。然意恶行复有三种。谓非意业贪嗔邪见。岂不契经亦说贪等名为意业。如何今说贪嗔邪见非意业耶。是业资粮故亦名业。如漏资粮亦名漏等。宁知贪等非意业耶。由阿笈摩及正理故。阿笈摩者。谓契经言。贪嗔邪见是业缘集故知贪等非即业性。又契经言。诸爱者表即是意业。故知非爱即意业体。余例应然。勿有计言业即业集。故契经说。爱业有殊。然经主言许有烦恼即是意业。斯有何过。如是所许违。前契经及后正理岂非大过。若谓如说贪能令意造诸恶行。此经虽说贪即是意恶行因缘。非不许贪意恶行摄。如是虽说爱为业因。此爱亦应非不是业。彼例非等此经不言爱能令心起表业故。谓如彼说贪能令意造诸恶行。非此经言爱能令心起诸表业。如何引彼以例此经。证表业因爱亦是业。如经中说诸痴即无明。此经但示痴是无明体。显非痴者即非无明。如是此经说诸希求即爱。诸爱者表即是意业。辩相差别义已显成。若非希求便非是爱。若非表者亦非意业。唯除假说则无有过。意业名表如前已释。正理者何。谓若烦恼即是业者。十二缘起及三障等差别应无。由此证知贪等非业是聪慧者所诃厌故。又能感得非爱果故。此行即恶故名恶行。三妙行者翻此应知。谓一切善。身语二业前后近分及与根本并诸善思。如次名身语意妙行。然意妙行复有三种。非业无贪无嗔正见智所赞故。感爱果故。此行即妙故名妙行。正见邪见虽非益损他。而为彼本故亦成善恶。又经中言有十业道。或善或恶其相云何。颂曰

  所说十业道　　摄恶妙行中
  粗品为其性　　如应成善恶

论曰。于前所说恶妙行中。若粗显易知摄为十业道。如应若善摄前妙行。不善业道摄前恶行。不摄何等恶妙行耶。加行后起等彼非粗显故。且于不善十业道中。若身恶行令他有情。失命失财失妻妾等。说为业道。令远离故。若语恶行过失尤重。说为业道。令远离故。若意恶行重贪嗔等。说为业道。令远离故。加行后起及余过轻。并不善思皆非业道。善业道中身善业道。于身妙行不摄一分。谓加行后起及余善身业。即离饮酒断莫施等。语善业道于语妙行不摄一分。谓爱语等。意善业道于意妙行不摄一分。谓诸善思。十业道中前七业道。为皆定有表无表耶。不尔。云何颂曰

  恶六定无表　　彼自作淫二
  善七受生二　　定生唯无表

论曰。七恶业道中六定有无表谓杀生等。除欲邪行非如是六。若遣他为至根本时有表生故。若有自作彼六业道则六皆有表无表二。谓起表时彼便死等后方死等。与遣使同。根本成时唯无表故。唯欲邪行必具二种。要是自身所究竟故。非遣他作如自生喜。七善业道若从受生必皆具二。谓表无表。受生尸罗必依表故。静虑无漏所摄律仪名为定生。此唯无表但依心力而得生故。加行后起如根本耶。不尔。云何。颂曰

  加行定有表　　无表或有无
  后起此相违

论曰。业道加行必定有表。此位无表或有或无。若猛利缠淳净心起。则有无表异此则无。后起翻前定有无表。此位表业或有或无。第二刹那无表为始名为后起。故此定有。若于尔时起随前业则亦有表。异此便无。于此义中如何建立加行根本后起位耶。且不善中最初杀业。如屠羊者将行杀时。先发杀心经求价直。为买羊故食己赍粮游涉远途访牧羊所。至已揣触酬直牵还系养令肥。将入屠处执刀求穴。斫刺其身至命未终。皆名加行。随此表业彼正命终。此刹那顷表无表业。是谓杀生根本业道。此刹那后杀无表业随转不绝名杀后起。及于后时剥截治洗称卖收利以活己亲。此等表业亦名后起。如屠羊者三分既然。余不律仪如应当说。不与取业有三分者。且如窃者将行盗时。先发盗心遣人或自往来伺听他物所在。为往窃取食饮装束。赍持盗具密至他家。穿壁登梯方便而入。徐行申手探摸他财。未离处前皆名加行。物正离处。此刹那中表无表业。名本业道。此刹那后随无表业。及持财出藏受用等。所有表业皆名后起。欲邪行业有三分者。且如男子于他女人先起爱心将行非礼。命使瞻察媒媾往来严身赴彼。言笑执触事未果前皆名加行。事正究竟。此刹那中表无表业名本业道。有说。究竟谓入疮门。有余师言。谓泄不净。此刹那后随无表业。及余叙愧执触言辞所有表业皆名后起。虚诳语业有三分者。且如一类善行诳术。因求财物而活命者。先受情求许为伪证。发行诳意往诣众中。为述己身堪为诚证。言我于彼非怨非亲。知诸恶中无过虚诳。知众善内无过实语。我既于彼无所希求。岂自无辜为担毒刺。但恐贤直滥被刑科。未成证前皆名加行。若正对众背想发言。不见等中诈言见等所诳领解。此刹那中表无表业名本业道。有说。所诳印可方成。若尔应无诳贤圣理。然诳贤圣为过既深。由此应知前说为善。此刹那后随无表业。及获财利以养己亲。所有表业皆名后起。离间语业有三分者。且如一类发坏他心。遣使通传。或身自往诈为亲附。冀信己言未坏他前皆名加行。发离间语他领刹那表无表业名本业道。有余师说。他坏方成。若尔圣交深固难坏。应无坏圣离间语罪。然坏圣者获罪既深。由此应知前说为善。此刹那后随无表业。及今所坏无再合心。所有表业皆名后起。粗恶语业有三分者。且如一类将发粗言。起愤恚心扼腕顿足。扬眉努目啮齿动唇。未发语前皆名加行。正发粗语他领刹那表无表业名本业道。有余师说。他恼方成。若尔圣人具忍力者。既不可恼骂应无过。然骂贤圣获罪既深。由此应知前说为善。此刹那后随无表业及背所骂重述恶言。所有表业皆名后起。杂秽语业有三分者。且如一类发戏调心。先取他财集诸绮论。赍持戏具来诣众中。发戏言前皆名加行。正发戏语乐众刹那表无表业名本业道。此刹那后随无表业及获财利收用举藏。所有表业皆名后起。有余师说。贪嗔邪见才现在前即名业道。故无加行后起差别。如是说者。亦具三分有不善思。于贪嗔等能为前后助伴事故。又诸业道展转相望容有互为加行后起。如有一类欲害怨敌。设诸谋策合构杀缘。或杀众生祈请助力。或盗他物以资杀事。或淫彼妇令杀其夫。或知彼怨亲友强盛。自力微劣杀计难成。是故先于怨亲友所起语四过破坏其心。令于彼怨无心救护方便诱引令入己朋。或于彼财心生贪着。或即于彼起嗔恚心。或起邪见长养杀业。然后方杀既杀彼已。复于后时诛其所亲。夺其财物淫其所爱。乃至后起邪见现前。如是名为杀生业道。以十恶业道为加行后起。所余业道如应当知。有余师说。贪等不应能为加行。非唯心起加行即成未作事故。如是说者。贪等虽非所作业性。然彼贪等缘境生时非无力用。由有力用得加行名。方便引生诸业道故。今应详议如前所说。随此表业彼正命终。此刹那顷表无表业是谓杀生根本业道。此应非理。所以者何。为所杀生住死有位。能杀生者彼刹那中表无表业即成业道。为彼死后成业道耶。若所杀生住死有位。能杀生者业道即成。虽前所言且似无失。而于宗义决定相违。以所杀生与能杀者俱时舍命。亦应可说能杀生者杀业道成。许所杀犹存杀业道成故。此能杀者住死有时。所杀尔时既名正死。则能杀者应许获得此一刹那杀生业道。然宗不许与所杀生俱时命终成业道罪。若彼死后业道方成。则前所言为不应理。非所杀者正命终时可得名为彼命已断。如何先说彼正命终此刹那顷表无表业。是谓杀生根本业道。而今言死后杀业道方成。如是二途应善详定。决定死后业道方成。而前所言正命终者。于已往事却说现声。如有大王自远已至。而问今者从何所来。或此于因假说为果。谓所杀者正命终时。能杀有情加行表业。于杀有用非业道表。此业道表续加行生。彼所引故名加行果。然因于杀有胜功能。是故于因假说为果。实非业道说业道声。岂不此时表业有用。即应立此为业道耶。非要有能方成业道。勿无表业失业道名。此于杀中有何功用。如无表业表亦应然。又理不应立加行表即为业道。所杀有情于命终位命犹有故。要加行表与所杀生命俱时灭。彼死有后无同类命。一刹那中表无表业可成业道。此后念表于杀无能尚非杀生。何况是罪。但应无表得业道名。虽无杀能是杀果故。岂不后表理亦应然。杀表为因所引起故。谓由加行果圆满时。此二俱成根本业道。虽于他命断此二无能。而有取当来非爱果用。畅杀思故名杀业道。如本论说颇有已害生杀生未灭耶。曰有。如已断生命彼加行未息。此言何义。此中义者。以杀生时起杀加行总有三种。一唯由内。谓拳击等。二唯由外。谓掷石等。三俱由二。谓挥刀等。于此三种杀加行中。有所杀生命虽已断而能杀者生想未除。故于杀生不舍加行。由此本论作如是言。如已断生命彼加行未息。于杀加行说杀生声。故得说为杀生未灭。此亦业道后。如何名加行。毗婆沙师作如是释。此于后起说加行声。所以者何。以能杀者杀加行想犹未息故。于所杀生已命终想犹未生故立加行名。如何但言此于后起应作是说及于根本。所以者何。以所杀者次死有。后一刹那时及此后时多刹那顷。能杀加行皆容未息。是故应言此于后起。及于根本说加行声。无劳复说。及于根本。以于后起声亦摄根本故。要于所杀死有后时能杀方成杀生根本。岂不根本及其后起皆于所杀死有后生。俱可名为杀生后起。是故应信毗婆沙师于本论言极为善释。又经中说。苾刍当知。杀有三种。一从贪生。二从嗔生。三从痴生。乃至邪见有三亦尔。岂诸业道于究竟时皆由三根。佛作是说。非诸业道于究竟时皆由三根。加行有异。云何有异。颂曰

  加行三根起　　彼无间生故
  贪等三根生

论曰。不善业道加行生时。一一由三不善根起。依先等起故作是说。杀生加行由贪起者。如有贪彼齿发身分。或为得财。或为戏乐。或为拔济亲友自身。从贪引起杀生加行。从嗔起者。如为除怨发愤恚心起杀加行。从痴起者。如波剌斯。作如是说。父母老病若令命终便生胜福。以令解脱现在众苦。新得胜身明利根故。又谓是法祠中杀生。又诸王等依世法律诛戮怨敌除剪凶徒。谓成大福起杀加行。又外道言蛇蝎蜂等为人毒害。杀便获福。羊鹿水牛及余禽兽。本拟供食故杀无罪。又因邪见杀害众生。此等加行皆从痴起。偷盗加行从贪起者。如为财利恭敬名誉。或为救拔自身亲友。从贪引起偷盗加行。从嗔起者。如为降怨。发愤恚心起盗加行。从痴起者。如诸王等依世法律夺恶人财。谓法应尔无偷盗罪。又婆罗门作如是说。世间财物于劫初时大梵天王施诸梵志。于后梵志势力微。劣为诸卑族侵夺受用。今诸梵志于世他财。若夺若偷充衣充食。或充余用或转施他。皆用己财无偷盗罪。然彼取时有他物想。又因邪见盗他财物。此等皆名从痴所起。邪淫加行从贪起者。如于他室起染习心。或为求财或求恭敬。此等加行从贪所生。从嗔生者。如为除怨发愤恚心起淫加行。从痴起者。如波剌斯赞于母等行非梵行。又诸外道作如是言。一切女人如臼花果熟食阶蹬道路桥船。世间众人应共受用。又如梵志赞牛祠中。有诸女男受持牛禁吸水啮草。或住或行不简疏亲随遇随合。此等加行从痴所生。虚诳语等从贪生者。如为财利恭敬名誉济己及亲起四加行。从嗔生者。如为除怨发愤恚心起四加行。从痴起者。如因邪见起诳语等四种加行。又虚诳语从痴起者。如外论言

  若人因戏笑　　嫁娶对女王
  及救命救财　　虚诳语无罪

又杂秽语从痴起者。如依吠陀及余邪论习学讽咏。传授于他谓无罪愆。皆从痴起。贪等加行如何从三。以从三根无间生故。谓从贪等三不善根无间各容生三业道。由此已显从贪嗔痴无间相应生三加行。依无间义亦生业道。已说不善从三根生。善复云何。颂曰

  善于三位中　　皆三善根起

论曰。诸善业道所有加行根本后起。皆从无贪无嗔无痴善根所起。以善三位皆是善心所等起故。善心必与三种善根共相应故。此善三位其相云何。谓远离前不善三位。所有三位应知是善。且如勤策受具戒时。来入戒坛礼苾刍众。至诚发语请亲教师。乃至一白二羯磨等。皆名为善业道加行。第三羯磨竟一刹那中表无表业名。根本业道。从此以后至说四依。及余依前相续随转。表无表业皆名后起。如先所说非诸业道于究竟位皆由三根。应说由何根究竟何业道。颂曰

  杀粗语嗔恚　　究竟皆由嗔
  盗邪行及贪　　皆由贪究竟
  邪见痴究竟　　许所余由三

论曰。恶业道中杀生粗语嗔恚业道。由嗔究竟要无所顾。极粗恶心现在前时此三成故。诸不与取欲邪行贪。此三业道由贪究竟要有所顾。极染污心现在前时此三成故。邪见究竟要由愚痴。由上品痴现前成故。虚诳离间杂秽语三。一一许容由三究竟。以贪嗔等现在前时一一能令此三成故。贪嗔业道即贪嗔根。如何说由贪嗔究竟。如欲邪行业道生时。定有贪根能为究竟。非贪嗔二业道生时。别有贪嗔能为究竟。是故应说贪嗔等三一一皆由痴根究竟。非无痴者此三起故。有余于此作是释言。即说此法由此究竟。自体生时即业道故。彼理穷故作如是释。然实贪等正现前时。幸有痴根能为究竟。何缘不许执自体耶。余业道中他究竟故。虽有此义而不许者。勿诸业道皆痴究竟。诸业道成时定有痴俱故无如是失。以杀盗等时虽皆有痴而嗔贪强故。若尔邪见应不由痴。以邪见俱痴不强故。不尔邪见俱起痴强。尔时无余不善根故。非邪见体是不善根。故此俱痴根义为胜。若尔贪等应不由痴。以贪及嗔是根是胜。俱行痴劣应不可言贪嗔业道由痴究竟。约能究竟尔时痴强。更无余根究竟贪等。自体于自无助力能。宁可说言自究竟自。故痴究竟于理无失。有余于此复作释言。与贪嗔俱一果诸法。皆可随胜立贪嗔名。彼与贪嗔俱时生故。亦可说彼究竟贪嗔。于此释中亦容征难。恐文烦杂。故应且止。诸恶业道何处起耶。颂曰

  有情具名色　　名身等处起

论曰。如前所说四品业道。三三一三随其次第。于有情等四处而生。谓杀等三有情处起。偷盗等三众具处起。唯邪见一名色处起。虚诳语等三名身等处起。由何建立杀业道成。谓由加行及由果满。于此二分随阙一时。不为杀生根本罪触。颇有杀者起杀加行及令果满。而彼不为杀罪触耶。曰有。云何。颂曰

  俱死及前死　　无根依别故

论曰。若能杀者起杀加行。定欲杀他与所杀生俱时舍命或在前死。彼能杀者业道不成。所以者何。以所杀者其命犹在。不可即令能杀有情杀罪所触。以所杀者命未断故。非能杀者其命已终可得杀罪。别依生故。谓杀加行所依止身今已断灭。虽有别类身同分生非罪依止。此曾未起杀生加行成杀业道理不应然。若尔此中为问非理。既杀加行所依止身。非即能令杀生果满。于前二分便为阙一。如何以此蕴在心中。而可问言颇有杀者起杀加行及令果满。若谓此中约一相续。言此起加行即此果满者。是则亦应杀罪所触。许前后生相续一故。又所说因无能证力。以能杀者死活不殊。谓就依身设彼活位。亦有念念异灭异生。非起加行身即能令果满。何言依别故非杀罪所触。若谓死后同分异故。与活有殊是。则还成阙于一分。为问非理。此问应理因有证能。所以者何。义有别故。谓先问者作是问言。颇一相续起杀加行亦令果满。而彼不为杀罪触耶。既前后生相续是一非阙一分。于后答者作是答言。以前后生身及同分是别业果。别依生故。不为前生所作罪触。若不许尔害非父母应成无间。又非人趣应成逆罪。而不许然。故依别因有能证力。若有多人集为军众欲杀怨敌。或猎兽等。于中随有一杀生时。何人得成杀生业道。颂曰

  军等若同事　　皆成如作者

论曰。于军等中若随有一作杀生事如自作者。一切皆成杀生业道。由彼同许为一事故。如为一事展转相教故。一杀生余皆得罪。若有他力逼入此中。因即同心亦成杀罪。唯除若有立誓要期。救自命终亦不行杀。无杀心故不得杀罪

说一切有部顺正理论卷第四十一阿毗达磨顺正理论卷第四十二

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩业品第四之十

今应思择成业道相。谓齐何量名自杀生。乃至齐何名为邪见。且先分别杀生相者。颂曰

  杀生由故思　　他想不误杀

论曰。要由先发欲杀故思。于他有情他有情想作杀加行不误而杀。谓唯杀彼不漫杀余。齐此名为杀生业道。有怀犹豫为杌为人。设复是人为彼非彼因起决志。若是若非我定当杀。由心无顾。若杀有情亦成业道。如是业道若定若疑。但具杀缘皆有成理。于刹那灭行杀罪。如何成如何不成。无杀义故。谓众生命过去已灭现在自灭未来未至。是故必无杀生命理。如何说灭。灯焰铃声准彼亦应通杀生义。谓障当命应生不生。以起恶心行杀加行。令所杀者现命灭时。不能为因引同类命。障应生命令永不生。故名杀生。由斯获罪。此所断命为属于谁。谓命若无彼名死者。即是此命所依附身。标第六声显相属义。如伽他说寿暖等言。故有命身名有命者。非实有我其理决然。已分别杀生。当辩不与取。颂曰

  不与取他物　　力窃取属己

论曰。前不误等言如应流至后。谓要先发欲盗故思。于他物中起他物想。或力或窃起盗加行。不误而取令属己身。齐此名为不与取罪。若有盗取窣堵波物于佛得罪。佛将涅槃总受世间所施物故。有说。此罪于能护人。则彼自恣应无有罪。是故前说于理为胜。盗亡僧物已作羯磨。于界内僧得偷盗罪。羯磨未了。于一切僧。若盗他人及象马等。出所住处业道方成。已辩不与取。当辩欲邪行。颂曰

  欲邪行四种　　行所不应行

论曰。总有四种行不应行。皆得名为欲邪行罪。一于非境。谓他所护。或母或父或父母亲。乃至或夫所守护境。二于非道。谓设己妻口及余道。三于非处。谓于制多寺中迥处。四于非时。谓怀胎时。饮儿乳时。受斋戒时。有说。若夫许受斋戒而有所犯。方谓非时。既不误言亦流至此。若于他妇谓是己妻。或于己妻谓为他妇。道非道等但有误心。虽有所行而非业道。若于此他妇作余他妇想行非梵行。有说。亦成加行受用时并于他境故。有说。如杀业道不成加行。究竟时前境各别故。苾刍尼等如有戒妻。若有侵陵亦成业道。有说。此罪于所住王。以能护持及不许故。若王自犯业道亦成。故前所说于理为胜。已辩欲邪行。当辩虚诳语。颂曰

  染异想发言　　解义虚诳语

论曰。说听力故成虚诳语谓于所说异想发言。及所诳者解所说义。染心不误方成业道。所诳未解杂秽语收。语多字成要最后念表无表业方成业道。或随所诳解义即成。前字俱行皆此加行。此中解义据所诳者能解名解非正解义。齐何名为能解正解。前谓解者住耳识时。后谓正能分别其义。若正解义义意识知。语表耳识俱时灭故。应此业道唯无表成。是故理应善义言者住耳识位业道即成。能诳具足表无表故。有言。所诳随解不解。但异想说业道即成。不尔此同离间语故。随忍不忍要解方成。经说诸言略有十六。谓于不见不闻不觉不知事中言实见等。所见等中言不见等。如是八种名非圣言。不见等中言不见等。所见等中言实见等。如是八种名为圣言。何等名为所见等相。颂曰

  由眼耳意识　　并余三所证
  如次第名为　　所见闻知觉

论曰。若境由眼耳意余识所证。如次名所见等。鼻舌身根取至境故总名为觉余。经定说三根所取为所觉故。经言。大母。汝意云何。诸所有色非汝眼见。非汝曾见非汝当见非希求见汝。为因此起欲起贪起亲起爱起阿赖耶起尼延底起耽着不。不尔大德。诸所有声非汝耳闻。广说乃至。诸所有法非汝意知。广说乃至。不尔大德。复告大母汝于此中应知所见唯有所见。应知所闻所觉所知。唯有所闻所觉所知。此经既于色声法境说为所见所闻所知。准此于余定立所觉。若不许尔。所觉是何又香等三。在所见等外。于彼三境应不起言说。经主拨言。此不成证。经义别故。非此经中佛欲决判四所言相然见此经所说义者。谓佛劝彼于六境中。及于见等四所言事。应知但有所见等言。不应增益爱非爱相。若尔何相名所见等。有余师说。若是五根现所证境名为所见。若他传说名为所闻。若运自心以种种理比度所许名为所觉。若意现证名为所知。于五境中皆容起四。于第六境除见有三。由此觉名非无所目。香等三境言说非无。复引古师别释此四。今谓经主唯申自执非我许此。经判所言相故但言经证。三根所取名为所觉。起所觉言故。我师宗随此经立所见等相。于理无违。虽说为遮于彼增益爱非爱相。非不应理言六四别于理不然。前经后经义相似故。我见此经所说义者谓教大母如于三时色等境中。若不见等不希求故。欲等不生如是。若知所见等境唯有所见等。欲等亦不生欲等。但由自分别故。我随经义解此经文。非如经主随自分别。故后大母领佛教言。我解世尊所说义者

  见色已失念　　妄增爱相者
  心便受爱染　　及住于耽着
  彼由起此受　　众多相现前
  故彼心恒时　　为诸贪害恼
  如是集众苦　　便远于涅槃
  爱尽故涅槃　　日亲之所说
  见色已正念　　不增爱相者
  心不受爱染　　及不住耽着
  彼由不起受　　众多相现前
  故彼心恒时　　离诸贪害恼
  如是灭众苦　　便近于涅槃
  爱尽故涅槃　　日亲之所说

如是于声香味触法一一广说。世尊亦赞能如是解。善哉善哉。故经主言经义别者。诚如所说以经义别。经主于中异分别故。又何意趣朋彼二师违理教释。而偏憎背毗婆沙者顺理教言。且彼二师所释违教。所见等相佛于经中于色等境分明别说。而彼弃舍异建立故。亦与随教正理相违。说五境中各具有四。第六境上唯有三等。然法最可立所见名。非声等中可名所见。如言佛见去来世等。此皆意识不共境故。曾无圣教言耳见声鼻见香等。如何五境皆名所见唯非第六。又彼自说若意现证名为所知。法既所知应名所见。现所证故犹如色等。此有何理唯五所证。立所见名。又后师释。自内所受及自所证。名为所知。若尔见何缘非自内所受。是则所见应即所知。又所觉知应无差别。俱是意识自所证故。又诸比量现量为先达正理人皆所共许。若比量境方名所觉。不应所觉在所知先。故彼二师义无端绪。今谓经主僻执居心。背此正宗党彼邪说。颇有由身表异想义成妄语不。有。故论言颇有不动身杀生罪触耶。曰有。谓发语。颇有不发语妄语罪触耶。曰有。谓动身。颇有不动身不发语二罪所触耶。曰有。谓仙人意愤。及长养业时。经主于此作如是难。若不动身亦不发语。欲无无表离表而生。此二如何得成业道。于如是难应设劬劳。彼谓实无表无表业。岂容不立此二业道。彼亦应辩触二罪因。非但起恶思有太过失故。若要依身语二门转思。起欲杀诳心即应成逆。彼不成者仙等应同。既不动身亦不发语。如何成业道。及依身语门应设劬劳。释如是难。然我且释布洒他时。如由动身能表语义生语业道。若身不动能表语义业道亦生。然说戒时彼有所犯。默然表净令众咸知。如何不生妄语业道。仙人意愤义等教他。彼于有情心无所顾。非人敬彼知有恶心。动身为杀彼生业道。仙以何表令鬼知心。彼由意愤身语必变。或由咒诅必动身语。有余师说。非于欲界一切无表悉依表生。如得果时五苾刍等得别解脱戒。不善亦应然然彼先时决定有表。余亦应尔。仙如前说。布洒他时得妄语者。谓不清净诈入僧中坐现威仪。或有所说。此谓先表。余例应思。已辩虚诳语。当辩余三语。颂曰

  染心坏他语　　说名离间语
  非爱粗恶语　　诸染杂秽语
  余说异三染　　佞歌邪论等

论曰。若染污心发坏他语。若他坏不坏俱成离间语。解义不误流至此中。若以染心发非爱语。毁訾于他名粗恶语。前染心语流至此故。解义不误亦与前同。一切染心所发诸语。名杂秽语。皆杂秽故。唯前语字流至此中。有说。异前三余染心所发佞歌邪论等方杂秽语收。佞谓苾刍邪求名利发谄爱语。歌谓倡伎染心悦他作诸词曲。及染心者讽吟相调。邪论者。谓胜数明等述恶见言等。谓染心所发悲叹及戏论语。轮王现时歌咏等语。随顺出离与染相违。故彼皆非杂秽语摄。有说。彼有嫁娶等言。杂秽语收非业道摄。薄尘类故。不引无表非无无表可业道摄。已辩三语。当辩意三。颂曰

  恶欲他财贪　　憎有情嗔恚
  拨善恶等见　　名邪见业道

论曰。于他财物非理耽求欲令属己。或力或窃。如是恶欲名贪业道。岂不欲爱皆名为贪。如五盖经。依贪欲盖佛说应断。此世间贪虽皆名贪非皆业道。由前已说诸恶行中摄粗品为十业道故。唯于他物起恶欲贪名贪业道。若异此者贪着己物业道应成。轮王北洲为难亦尔。于有情类起憎恚心。欲为逼迫。名嗔业道。于善恶等恶见拨无。此见名为邪见业道。举初摄后故说等言。具足应如契经所说谤因谤果。二世尊等总十一类邪见不同。谓无施与。乃至广说。如是已辩十业道相。依何义释诸业道名。颂曰

  此中三唯道　　七业亦道故

论曰。十业道中后三唯道。业之道故立业道名。彼相应思说名为业。彼转故转。彼行故行。如彼势力而造作故。前七是业身。语业故。亦业之道。思所游故。由能等起身语业思。托身语业为境转故。业业之道立业道名。故于此中言业道者。具显业道业业道业。虽不同类而一为余。世记论中俱极成故。或业之道故名业道。亦业亦道故名业道。具足应言业道业道。以一为余但言业道。善业道义类此应知。加行后起应名业道。思亦缘彼为境转故。理亦应说而不说者。为本依本彼方转故。先说粗品为业道故。又由根本有减增故。令内外物有减有增。二分不然。故非业道。一切恶业道皆现善相违。断诸善根由何业道。断续善相差别云何。颂曰

  唯邪见断善　　所断欲生得
  拨因果一切　　渐断二俱舍
  人三洲男女　　见行断非得
  续善疑有见　　顿现除逆者

论曰。恶业道中唯有上品圆满邪见能断善根。若尔何缘本论中说。云何上品诸不善根。谓诸不善根能断善根者。或离欲位最初所除。由不善根能引邪见。故邪见事推在彼根。如火烧村。火由贼起。故世间说被贼烧村。何等善根为此所断。谓唯欲界生得善根。色无色善先不成故。施设足论当云何通。如彼论言唯由此量是人已断三界善根。依上善根得更远说。令此相续非彼器故。何缘唯断生得善根。加行善根先已退故。如说。如是补特伽罗成就善法。乃至广说。此中所言成善法者。总说成就加行生得。复言善法隐没者。此言唯说加行善。将断善时最初舍故。言有随俱行善根未断者。此显犹有生得善根。彼于后时一切悉断。由此断故名断善根。此断善根何因何位。谓有一类先成暴恶意乐随眠。后逢恶友缘力所资转复增盛。故善根减不善根增。后起拨因拨果邪见。令一切善皆悉隐没。由此相续离善而住。此因此位断诸善根。何名拨因拨果邪见。谤妙恶行名为拨因。谤果异熟名为拨果。邪见有二。谓自界缘及他界缘。或有漏缘及无漏缘。谁能断善。应言一切能断善根。九品善根为可顿断。如见道断见所断耶。不尔云何。谓渐次断九品邪见。九品善根顺逆相望渐次断故。如修道断修所断惑。谓下下品断上上品。至上上品断下下品。故本论说。云何名微俱行善根。谓断善根时最后所舍者。由舍彼故名断善根。若尔彼文何理。复说云何上品诸不善根。谓诸不善根能断善根者。不应于此微其理趣。乘前为问其理已成。谓此乘前所断微善。即问能断上不善根。前微善根既下品摄。后能断者理上品收。故于此中不劳征难。既如修道断所断惑。理于中间通起不起。诸律仪果有从加行。有从生得善心所生。若从加行善心生者。律仪先舍后断善根。然断善根加行根本皆名断善。依此故说断善根位舍诸律仪。若从生得善心生者。随断何品能生善根。所生律仪尔时便舍。舍能等起彼随舍故。为在何处能断善根。人趣三洲非在恶趣亦非天趣。所以者何。以恶趣中染不染慧不坚牢故。以天趣中现见善恶诸业果故。言三洲者。除北俱卢。彼无极恶阿世耶故。有余师说。唯赡部洲。若尔便违本论所说。如本论说。赡部洲人极少成八根。东西洲亦尔。如是断善依何类身。唯男女身志意定故。有余师说。亦非女身欲勤慧等皆昧钝故。若尔便违本论所说。如本论说若成女根定成八根。男根亦尔。为何行者能断善根。唯见行人非爱行者。诸见行者恶阿世耶极坚深故。彼恶意乐推求相续。故名极坚。见远随入故名极深。以极坚深故能断善。诸爱行者恶阿世耶极躁动故。由斯理趣非扇搋等能断善根。又此类人如恶趣故。此善根断其体是何。善断应知非得为体。以重邪见现在前时。能令善根成就得灭。不成就得相续而生。此位名为善根已断。故善断体即是非得。前已成立非得实有。善根断已由何复续。由疑有见谓续善位或由因力或依善友。有于因果欻复生疑。所招后世为无为有。有于因果欻生正见。定有后世先执是邪。尔时善根成就得还起。不成就得灭名续善根。九品善根顿续渐起。如顿除病气力渐增。于现身中能续善不。亦有能续除造逆人。有余师言。断见增者亦非现世。能续善根依彼二人。经作是说。彼定于现法不能续善根。彼人定从地狱将没。或即于彼将受生时能续善根非余位。故言将生位谓中有中。将殁时言谓彼将死。若由因力彼断善根。将死时续。若由缘力彼断善根将生时续。由自他力应知亦尔。又意乐坏非加行坏。断善根者是人现世能续善根。若意乐坏加行亦坏。断善根者要身坏后方续善根。谓世有人拨无后世名意乐坏。而不随彼意乐所作非加行坏。见坏戒不坏。见坏戒亦坏。断善根者应知亦尔。非劫将坏及劫初成有断善根。坏器世间增上力故。相续润故。行妙行者不断善根。以心坚牢有所乐故。断善邪定四句差别。谓补剌拏未生怨王提婆达多所余人等。如其次第应知差别。断善邪见破僧妄语。当知定招无间异熟。余无间业或招无间。或招所余地狱异熟。已乘义便辩断善根。今应复明本业道义。所说善恶二业道中。有几并生与思俱转。颂曰

  业道思俱转　　不善一至八
  善总开至十　　别遮一八五

论曰。于诸业道思俱转中。且不善与思从一唯至八。一俱转者。谓离所余贪等三中随一现起。若先加行所造恶业。贪等余染及不染心现在前时随一究竟。经主唯说不染污心此言太减。以慢疑等染心起时亦有由先加行所起业道成故。又说加行造恶色业色言太增。无色无容先加行造不染心起业道方成。须简别故。后如是类例应弹斥。有余师说。身三业道一一思俱转。谓杀盗邪淫。理不应然。邪淫必二无遣他为故。必贪究竟故。杀盗自为。亦必二故。设据遣他作应差别言。谓于究竟时贪等不起。又说。杂秽语及贪嗔等三。随一现前名一俱转。此亦非理。阙唯言故。如我先说于理为善。二俱转者。谓行邪行若自行杀盗杂秽语。或遣他为随一成位。贪嗔邪见随一现前。若先加行所造恶业贪等余染。及不染心现在前时随二究竟。经主于此作如是言。谓嗔心时究竟杀业。若起贪位成不与取。或欲邪行或杂秽语。此亦非理。若自究竟则应于杀无劳说嗔。此更无容余究竟故。于盗邪行说贪亦然。说起贪时成杂秽语。此言阙减。容三成故。若先加行于究竟时一一应言贪等随一。有余师说。于他命财起欲杀盗心令死时即取。或他婢等住船等中。犯邪行时。盗离本处。此非唯二。以贪嗔中随其所应必有一故。又说虚诳离间粗恶随起一时亦二俱转。此亦非理贪嗔等。三随其所应容有一故。由此先说于理为善。三俱转者。谓先加行所造恶业贪等起时随二究竟。若遣一使作杀等一。自行淫等。俱时究竟。若自作二如理应思。若先加行所造恶业。贪等余染及不染心现在前时随三究竟。若起贪等余染心时。自成摄离间虚诳语业等使作一等如理应思。有余师言。遣二使已自行邪行俱究竟时。及语前三随俱起二此亦非理。淫究竟时定有贪故。发语业道贪等三中容有一故。设起余心应差别故。四俱转者。谓欲坏他说虚诳言。或粗恶语。意业道一。语业道三若遣二使自行淫等。若先加行所造恶业。贪等起时随三究竟。如是等类准例应思。有余师言。俱说四语。此说非理。应分别故。如是五六七皆如理应思。八俱转者。谓先加行作六恶业。自行邪欲俱时究竟。余例应思。后三不俱故无九十。何缘邪欲要自究竟非如杀等。遣他亦成杀等遣他染心定故。谓若遣使行杀生等定有染心。遣他行淫容心无染。如嫁女等。又此类惑必现前故。谓由此类烦恼现起。自行杀等令他亦然。非遣他淫惑必如自又自远离行不应行。非遣他行名自犯故。谓有远离行不应行。授女与夫自非犯者。若于此境自离杀生。遣他杀时自名杀者。曾闻菩萨将女施他便获爱果。然非梵行不善业摄。若遣他犯与自作同。岂容安住恶业加行能招福果。或诸菩萨应犯邪行。又离杀等依遮境成。离行邪淫遮己身故。由此非杀一切有情。皆成他胜随于一切。但有行淫皆名犯重。又理必尔以诸苾刍但遣杀人必成他胜。虽行媒嫁而不犯重。何缘遣离杀不得离杀戒。但遣他杀生便得杀生罪。此例非等非无杀思有遣他杀有无离杀思。而遣他离杀义不同故。又受持戒于此处强舍犯尸罗于他处胜故于犯戒有遣他犯名自犯。若于持戒无遣他持名自持。又先已说。先说者何。谓欲界中恶胜善劣。又缘起法有种种殊不可为难。且如眼识不住色中。亦非住眼随眼增损而不随色。又如从心生大显等不随心力成善等性。而形善等差别随心。又语业声性随心转。弹指声等性不随心。又他命终方成杀业。他坏不坏成离间等。如是于戒遣他受持无自受持。若于犯戒遣他毁犯有自毁犯。于中遣杀成能杀人。遣他行淫不成淫者。如是已说不善业道与思俱转数有不同。善业道与思总开容至十。别据显相遮一八五。二俱转者。谓善五识及依无色。尽无生智现在前时无散善七。此相应慧非见性故。无色定俱无律仪故。三俱转者。谓与正见相应。意识现在前时无七色善。四俱转者谓恶无记心现在前位。得近住近事勤策律仪。六俱转者。谓善五识现在前时得上三戒。七俱转者谓善意识无随转色正见相应现在前时得上三戒。或恶无记心现前时得苾刍戒。九俱转者。谓善五识及依无色。尽无生智现在前时得苾刍戒。或静虑摄尽无生智相应意识现在前时。十俱转者。谓善意识无随转色。正见相应现在前时得苾刍戒。或余一切有随转色正见相应心正起位。别据显相所遮如是。通据隐显则无所遮。谓离律仪有一八五。一俱转者。谓恶无记心现在前时得一支远离。五俱转者。谓善意识无随转色正见相应现在前时得二支等。八俱转者。谓此意识现在前时。得五支等。善恶业道。于何界趣处。几唯成就。几亦通现行。颂曰

  不善地狱中　　粗杂嗔通二
  贪邪见成就　　北洲成后三
  杂语通现成　　余欲十通二
  善于一切处　　后三通现成
  无色无想天　　前七唯成就
  除处通成现　　除地狱北洲

论曰。且于不善十业道中。那落迦中三通二种。谓粗恶语杂秽语嗔。三种皆通现行成就。苦逼相骂故有粗恶语。怨叹悲叫故有杂秽语。身心粗强[怡-台+龍]戾不调由互相憎故有嗔恚。贪及邪见成而不行。无可爱境故。现见业果故。无相害法故无杀生。谓彼但由业尽故死。无摄财女故无盗淫。以无用故无虚诳语。或虚诳语令他想倒。彼想常倒故无诳语。彼常离故。或无用故。无离间语。北俱卢洲贪嗔邪见皆定成就而不现行。不摄我所故。身心柔软故。无恼害事故。无恶意乐故。唯杂秽语彼通现成。由彼有时染心歌咏。寿量定故无有杀生。无摄财物及女人故无不与取及欲邪行。无诳心故无虚诳语。或无用故常和穆故无离间语。言清美故无粗恶语。彼人云何行非梵行。谓彼男女互起染时。执手相牵往诣树下。树枝垂覆知是应行树不垂枝两愧而别。除前地狱北俱卢洲。余欲界中十皆通二。谓于欲界天鬼傍生及人三洲。十恶业道皆通成现。然有差别。谓天鬼傍生。前七业道唯有处中摄无不律仪。人三洲中二种俱有。虽诸天众无有杀天。而或有时杀害余趣。有余师说。天亦杀天。虽天身支断已还出。斩首中截则不更生。故欲天中有杀业道。已说不善。善业道中无贪等三。于三界五趣皆通二种。谓成就现行。身语七支无色无想但容成就必不现行。谓圣有情生无色界成就过未无漏律仪。无想有情必成过未第四静虑静虑律仪。然圣随依何静虑地曾起曾灭无漏尸罗。生无色时成彼过去。若未来世六地皆成。二处皆无现起义者。无色唯有四蕴性故。无想有情无定心故。律仪必托大种。定心二处互无故不现起。余界趣处除地狱北洲。七善皆通现行及成就。然有差别。谓鬼傍生有离律仪处中业道。若于色界唯有律仪。三洲欲天皆具二种。善恶业道得果云何。颂曰

  皆能招异熟　　等流增上果
  此令他受苦　　断命坏威故

论曰。且先分别十恶业道各招三果。其三者何。异熟等流增上别故。谓于十种若习若修若多所作。由此力故生捺落迦。是异熟果。从彼出已来生此间人同分中受等流果。谓杀生者寿量短促。不与取者资财乏匮。欲邪行者妻不贞良。虚诳语者多遭诽谤。离间语者亲友乖穆。粗恶语者恒闻恶声。杂秽语者言不威肃。贪者贪盛。嗔者嗔增。邪见者痴增上。何缘邪见令痴转增。习异不应令异增长。经主作是释。彼品痴增故。岂不邪见相应无明。非相用增依邪见故。今观此义邪见起时。于有事中无行相转坏现见事。此与贪嗔相应无明。彼痴增重贪嗔于有境有行相转故。或见行者由邪见力。能令真智远而更远。以痴增者邪见便增由痴转令倒推求故。邪见增者痴复转增。由见转令障真智故。由此说邪智是正智近怨。以与无明为朋党故。是名业道等流果别。如何短寿是杀等流。人寿必应是善业果。经主于此作如是释。不言人寿即杀业果。但言由杀人寿量短。应知杀业与人命根作障碍因令不久住。此所言义极难了知。若杀为因能招寿短。短名目何法是杀果非寿。譬如金铤短即是金。寿亦应然短岂非寿。如何可说寿非杀果。若谓杀业能感命灾故杀为因非感寿者。此中应辩。何谓命灾不可说言。谓刀毒等。刀等但是灾之缘故。又不应说是杀等流。彼是有情增上果故。命灾命障其义是一。既说杀业作命障因。应辩此中命障何谓若谓命障。即寿不生此复应思为有非有若非有者果。体不成非住本心人。说无为有果若是有者此非异寿便违所说寿非杀果。理应释言。不说人寿是杀异熟。但应说言是杀生业近增上果。谓虽人寿是善业招。而由杀生增上力故。令彼相续唯经少时。以欲界中不善胜善。有增上力能伏善故。若尔何故说名等流果。显增上果中有最近故。若二俱立增上果名。则不显果有近远别。若谓不然如何不善。以修所断无覆无记为等流果。与理无违是故可言即人短寿是杀生业所引等流。此十所招增上果者。谓外所有诸资生具。由杀生故光泽鲜少。不与取故多遭霜雹。稼穑微薄果实希小。欲邪行故多诸尘埃。虚诳语故多诸臭秽。离间语故所居险曲。粗恶语故多诸恶触。田丰荆棘硗确碱卤。杂秽语故时候变改。贪故果少。嗔故果辣。由邪见故果少或无。是名业道增上果别。为一杀业感地狱已。复感短寿外恶果耶。有余师言。即一杀业先受异熟。次近增上后远增上故有三果。理实杀时能令所杀受苦命断坏失威光。令他苦故生于地狱。断他命故人中寿短。先是加行果。后是根本果。根本近分俱命杀生。由坏威光感恶外具。是故杀业得三种果。余恶业道如理应思。由此应准知。善业道三果且于离杀。若习若修若多所作。由此力故生于天中受异熟果。从彼没已来生人中。受极长寿近增上果。即复由此感诸外具。有大威光远增上果。余善三果翻恶应说。又契经说八邪支中分色业为三谓邪语业命离邪语业邪命是何。虽离彼无而别说者。颂曰

  贪生身语业　　邪命难除故
  执命资贪生　　违经故非理

论曰。嗔痴所生语身二业。如次唯名邪语邪业。从贪所生身语二业名邪语邪业。亦说名邪命。以难除故异二别立。贪细能夺诸有情心。极聪慧人犹难禁护。故此对二为极难除。诸在家人邪见难断。以多妄执吉祥等故。诸出家者邪命难除。所有命缘皆属他故。为于正命令殷重修。故佛离前别说为一。有余师执。缘命资具贪欲所生。身语二业方名邪命非余贪生。所以者何。为自戏乐作歌舞等。非资命故。此违经故。理定不然。戒蕴经中观象斗等。世尊亦立在邪命中。邪受外尘虚延命故。由此非独命资粮。贪所发身语方名邪命。正语业命翻此应知。何缘业道中先身后语。于八道支内先语后身。以业道中随粗细说。道支次第据顺相生。故契经中言寻伺已发语

说一切有部顺正理论第四十二阿毗达磨顺正理论卷第四十三

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩业品第四之十一

如前所说果有五种。何等业有几果。颂曰

  断道有漏业　　具足有五果
  无漏业有四　　谓唯除异熟
  余有漏善恶　　亦四除离系
  余无漏无记　　三除前所除

论曰。道能证断及能断惑得断道名即无间道。此道有二种。谓有漏无漏。有漏道业具有五果。等流果者。谓自地中后等。若增诸相似法。异熟果者。谓自地中断道所招可爱异熟。离系果者。谓此道力。断惑所证择灭无为。士用果者。谓道所牵俱有解脱所修及断。言俱有者。谓俱生法。言解脱者。谓无间生。即解脱道。言所修者。谓未来修。断谓择灭。由道力故彼得方起。增上果者。有如是说。谓离自性余有为法。唯除前生。有作是言。断亦应是道增上果。道增上力能证彼故。若尔何故毗婆沙中。唯说欲界十随眠断。为苦法智忍离系士用果。曾不说是增上果耶。非由不说便非彼果。以即彼文说苦法智。为苦法智忍等流士用果。曾不说是增上果故。然实苦法智是彼增上果。而不说者义极成故。此亦应然举士用果。理则已举增上果故。非唯可生是增上果。说非择灭是心果故。离此更无余果义故。即断道中无漏道业。唯有四果谓除异熟。余有漏善及不善业亦有四果谓除离系。异前断道故说为余。次后余言例此应释。谓余无漏及无记业。唯有三果除前所除。谓除前所除异熟及离系。已总分别诸业有果。次辩果门业有果相。于中先辩善等三业。颂曰

  善等于善等　　初有四二三
  中有二三四　　后二三三果

论曰。最后所说皆如次言。显随所应遍前门义。且善不善无记三业一一为因。如其次第对善不善无记。三法辩有果数后例应知。谓初善业以善法为四果除异熟。以不善为二果。谓士用及增上。以无记为三果除等流及离系。中不善业以善法为二果。谓士用及增上。以不善为三果除异熟及离系。以无记为四果除离系。等流果者。谓见苦所断一切不善业及见集所断遍行不善业。以欲界中身边见品。诸无记法为等流故。后无记业以善法为二果。谓士用及增上。以不善为三果除异熟及离系。等流果者。谓身边见品。诸无记业以五部不善为等流故。以无记为三果如不善。已辩三性当辩三世。颂曰

  过于三各四　　现于未亦尔
  现于现二果　　未于未果三

论曰。过去现在未来三业一一为因。如其所应以过去等为果。别者谓过去业以三世法各为四果除离系。现在世业以未来为四果如前说。以现在为二果。谓士用及增上。未来世业以未来为三果。除等流及离系。不说后业有前果者。前法定非后业果故。已辩三世当辩诸地。颂曰

  同地有四果　　异地二或三

论曰。于诸地中随何地业。以同地法为四果除离系。若是有漏以异地法为二果。谓士用及增上。若是无漏以异地法为三果。除异熟及离系不堕界故。不遮等流。已辩诸地当辩学等。颂曰

  学于三各三　　无学一三二
  非学非无学　　有二二五果

论曰。学等三业一一为因。如其次第各以三法为果。别者谓学业以学法为三果。除异熟及离系。以无学法为三亦尔。以非二为三果。除异熟及等流。无学业以学法为一果谓增上。理应言二谓加等流。以无学为三果。除异熟及离系。以非二为二果。谓士用及增上。非二业以学法为二果。谓士用及增上。以无学法为二亦尔。以非二为五果已辩学等当辩见所断等。颂曰

  见所断业等　　一一各于三
  初有三四一　　中二四三果
  后有一二四　　皆如次应知

论曰。见所断等三业如次。一一为因各以三法为果。别者初见所断业。以见所断法为三果。除异熟及离系。以修所断法为四果除离系。以非所断法为一果。谓增上。中修所断业以见所断法为二果。谓士用及增上。以修所断。法为四果除离系。以非所断法为三果。除异熟及等流。后非所断业以见所断法为一果。谓增上。以修所断法为二果。谓士用及增上。以非所断法为四果除异熟。皆如次者随其所应遍上诸门。略法应尔因辩诸业应复问言。如本论中所说三业。谓应作业不应作业。及非应作非不应作业。其相云何。颂曰

  染业不应作　　有说亦坏轨
  应作业翻此　　俱相违第三

论曰。有说染污身语意业名不应作。以从非理作意生故。有余师言。诸坏轨则身语意业。设是不染亦不应作。由彼不合世轨则故。谓诸无覆无记身业。若住若行若饮食等。诸有不合世俗礼仪。皆说名为坏轨身业。诸有无覆无记语业。坏形言时及作者等。但有不合世俗礼仪皆说名为坏轨。语业等起前二思名坏轨。意业此及染业名不应作。应作业者与此相翻。俱违前二是第三业。若依世俗后亦可然。若就胜义前说为善。谓唯善业名为应作。唯诸染业名不应作。无覆无记身语意业。名非应作非不应作。然非一切不应作业皆恶行摄。唯有不善是恶性故得恶行名。以招爱果名为妙行。招非爱果名为恶行。有覆无记虽是不应作而非恶行摄。由此所行决定不能招爱非爱果故。今于此中复应思择。为由一业但引一生。为引多生。又为一生但一业引。为多业引。颂曰

  一业引一生　　多业能圆满

论曰。若依正理应决定说。但由一业唯引一生。此一生言显众同分。以得同分方说名生。若说一生由多业引。或说一业能引多生。如是二言于理何失。且初有失。谓一生中前业果终后业果起。业果别故应有死生。或应多生无死生。理业果终起如一生故。二俱有过。一本有中应有众多死生有故。或应乃至无余涅槃中间永无死及生故。何缘定限一趣处中。有异业果生便有生死。有异业果起而无死生。一业果终余业果起。理定应立有死有生。又许一生定为多种造作增长业所引故。则应决定无中夭者。或应不受果而永弃彼业。然先已说先说者何。谓理必无时分定业。所感异熟转余时受。又理必无时分定业非造作增长必受异熟故。若谓有生由定不定多种业引。或复有生唯为多种。定业所引故有中夭。及有尽寿此亦不然。时分果业定不定受无决定故。若有一类中年老年时分果业决定应受婴孩童子少年果业。不定受者彼复如何。理必无容离前有后。或应前位所有果业必是定受定受果故。然于此中无决定理。令前位业决定受果。令后位业受果不定。故无一生多业所引。后亦有失一业引多生时分定业应成杂乱故。此无杂乱如先已辩。故无一业能引多生。若尔何缘尊者无灭自言。我忆昔于一时于殊胜福田一施食异熟。从兹七返生三十三天。七生人中为转轮圣帝。最后生在大释迦家。丰足珍财多受快乐。毗婆沙者已释此言。一施食为依起多胜思愿。能引位别多异熟生。故作如是言。一施食异熟。不应异熟能复感生。但为显依一施食境。起多思愿所招异熟分位差别故作是言。或显初基故作是说。彼由一业感一生中大贵多财及宿生智。乘斯更造感余生福。如是展转至最后身。生富贵家得究竟果。如有缘一迦栗沙钵拏。方便勤求息利成千倍。言我本由一迦栗沙钵拏。遂至今时成大富贵。是故一业唯引一生。虽言一生由一业引。而许圆满由多业成。譬如画师先以一色图其形状后填众彩。今于此中一色所喻为一类业。为一刹那。若喻一类违此宗理。以非一业引一生。言可约一类类必多故。多引一生不应理故。若言一色喻一刹那。非一刹那能图形状。即所立喻于证无能。今见此中喻一类业。如何引业约类得成引一趣业有众多故。此言意显一类业中唯一刹那引众同分同类异类。多刹那业能为圆满故。说为多故如一色先图形状。后填众彩此言应理。是故虽有同禀人身。而于其中有具支体诸根形量色力庄严。或有于前多缺减者。为但由业能引满生。不尔一切业一果法势力强故。亦引满生与此相违能满非引。如是二类其体是何。颂曰

  二无心定得　　不能引余通

论曰。二无心定虽有异熟。而无势力引众同分。以与诸业非俱有故。一切不善善有漏得。亦无势力引众同分。以与诸业非一果故。诸余不善善有漏法。皆容通二谓引及满。薄伽梵说重障有三。谓业障烦恼障异熟障。如是三障其体是何。颂曰

  三障无间业　　及数行烦恼
  并一切恶趣　　北洲无想天

论曰。业障体者。谓五无间。一者害母。二者害父。三者害阿罗汉。四者破和合僧。五者恶心出佛身血。烦恼障体者。谓数行烦恼下品烦恼。若有数行虽欲伏除难得其便。由彼展转令上品生。难可伏除故亦名障。上品烦恼若不数行。对治道生易得其便。虽极猛利而非障摄。虽住欲界具缚有情。平等皆成一切烦恼。而现行别为障不同。故烦恼中随品上下。但数行者名烦恼障。异熟障体者。谓三恶趣全及善趣一分。即北洲无想。何故名障能障圣道。及道资粮并离染故。非唯无间是业障体。所有定业能障见谛一切皆应是业障摄。谓有诸业造作增长。能感恶趣卵生湿生。女身人天第八有等。并感大梵顺后受业或色无色一处二生。有此皆无入见谛理。何缘不说是业障收见。此类中有非定故。谓于如是业种类中。皆有强缘可令回转。不障圣道及道资粮故。于此中虽有少业不可转者不立为障。无间种类皆不可转故。唯于此立为业障。毗婆沙说此五因缘。易见易知说为业障。谓处趣生果及补特伽罗。处谓此五定以母等为起处故。趣谓此五定以地狱为所趣故。生谓此五定无间生感异熟故。果谓此五决定能招非爱果故。补特伽罗谓此五逆依行重惑补特伽罗。共了此人能害母等。余业不尔不立为障。余障废立如应当知。此三障中烦恼最重。以能发业业感果故。有余师言。烦恼与业二障皆最重。以有此者第二生中亦不可治故。无间何义。此无间业于无间生必受果故。无余生果业能隔故。有说造逆补特伽罗。从此命终定堕地狱中无间隔故名无间。彼有无间得无间名与无间法合故名无间。如与沙门合故名沙门。三障应知何趣中有。颂曰

  三洲有无间　　非余扇搋等
  少恩少羞耻　　除障通五趣

论曰。非一切障诸趣皆有。且无间业唯人三洲。非北俱卢余趣余界。于三洲内唯女及男。非扇搋等如无恶戒。有说父母于彼少恩彼于父母少羞耻故。谓彼父母生不具身爱念。又微故言恩少彼于父母惭愧亦微。要坏重惭愧方触无间罪。然上座言彼扇搋等若害母等亦成无间。彼愚痴类作不应作业。岂容乘此生睹史多天。岂但有人作不应作不。生彼天处。即定生地狱故。虽征责而词乖理。都无思虑闇发此言。又彼自征傍生趣等。亦害父母何非无间。便自释言觉慧劣故。想变坏故。慈爱薄故。岂不此因于扇搋等亦容得有故无无间。设许彼类有无间罪。非上座说令少信知故。我所宗于理为善。若有人害非人父母。亦不成逆罪少恩羞耻故。谓彼于子无如人恩子于彼无如人惭愧。已辩业障唯人三洲。余障应知五趣皆有然烦恼障遍一切处。若异熟障全三恶趣。人唯北洲。天唯无想。岂不三洲处扇搋等身非圣道器故异熟障摄。无如是理。以于彼生引业所牵同分相续。可成男等为圣道器唯三恶趣。无想北洲决定无容证圣道义。故唯于彼立异熟障。有说彼处唯属异生。余处皆容与圣者共故不说是异熟障摄。于前所辩三重障中。说五无间为业障体。五无间业其体是何。且上座言三业为体。身业语业一一独能招异熟果。理难成故以但意业所作事重故。许能感殊胜异熟。此极疏恍。疏恍者何汝已许思依身语转名身语业。今许意业为无间体。便应暂起欲造逆思即成无间。又言意业所作事重许感殊胜异熟果者。此唯妄许违自宗故。谓若有思动发身语。此思可说所作事重然彼不可说为意业。以依身语二门转故。若思不能动发身语彼许是意业。然所作非重宁说意业所作事重。若谓动发身语二思是意业思所作重事故。说意业所作重者此亦非理。事非重故唯思不成身语二业。意业引彼事重岂成所作事重。言显动发身语故所作重非意业思。若观果思所作重故。亦说意业所作重者。意业前思能引意业果。果事重故亦应名事重。如是则应有大过失。又非意业与身语思。因果性故共感异熟。勿彼意业与彼前思亦因果故同感异熟。如是则应有非爱过。又彼先说证此因。言身业语业独招异熟难成故者。此言何义岂与意业共招异熟。即令此彼体类是同。独思离心能招异熟亦难成故。则应许心是无间体或体是思。又应推征说有意业是无间者。且害母者由何思力引地狱生。为思惟思为业道思。若思惟思如何于母全未有损害定引地狱生若业道思如何可说非身语业独能感果。非由思惟思彼方取果故。又彼自许先思惟思后业道思。先是意业后身语业前后相望时相各异无一果理如何可言身业语业独感异熟。其理难成故彼所言在圣教外。然我所宗决定义者。颂曰

  此五无间中　　四身一语业
  三杀一诳语　　一杀生加行

论曰。五无间中四是身业。一是语业。三是杀生。一虚诳语根本业道。一是杀生业道加行。以如来身不可害故。破僧无间是虚诳语。既是虚诳语何缘名破僧。因受果名或能破故。若尔僧破其体是何。能所破人谁所成就。颂曰

  僧破不和合　　心不相应行
  无覆无记性　　所破僧所成

论曰。僧破体是不和合。性无覆无记。心不相应行蕴所摄岂成无间。如是僧破因诳语生。故说破僧是无间果。非能破者成。此僧破但是所破僧众所成。此能破人何所成就。破僧异熟何处几时。颂曰

  能破者唯成　　此虚诳语罪
  无间一劫熟　　随罪增苦增

论曰。能破僧人成破僧罪。此破僧罪诳语为性。即僧破俱生语表无表业。此必无间大地狱中经一中劫受极重苦余逆不必生于无间。然此不经一大劫者。欲界无有此寿量故。一中劫时亦不满足。经说天授人寿四万岁时。来生人中证独觉菩提故。然不违背寿一劫言。一劫少分中立一劫名故。现有一分亦立全名。如言此日我有障碍。或如说言贼烧村等。若造多逆初一已招无间狱生余应无果。无无果失造多逆人。唯一能引余助满故。随彼罪增苦还增剧。谓由多逆感地狱中大柔软身。多猛苦具受二二四五倍重苦。或无中夭受苦多时。如何可言余应无果。上座于此作如是释。或于地狱死已更生。若尔宁非顺后受业。彼于此难反诘答言若有先造余不善业已引地狱。后造无间此复云何成无间业。为有天世于中间耶。岂不随前无间即受。我先已辩时分定业。无转余位受异熟理。由此不应作如是诘。有说先造余定恶业引次地狱生后不造无间。有说设造唯成满业如造多逆先引后满。非唯能引名无间业。故彼反诘于答无能。然彼所言为有天世于中间者。此极粗疏于感次生无用同故。如为天世善业所间隔。恶业无力感次地狱生。便说名为顺后受业。如是地狱余业所间无力能感次地狱生。云何不如天世所隔。令后造逆成顺后受。故对法宗所释无失。经说五逆顺生受故。谁于何处能破于谁。破在何时。经几时破。颂曰

  苾刍见净行　　破异处愚夫
  忍异师道时　　名破不经宿

论曰。能破僧者要大苾刍。必非在家苾刍尼等。以彼依止无威德故。唯见行人非爱行者。以恶意乐极坚深故。于染净品俱躁动故。要住净行方能破僧。以犯戒人无威德故。即由此证造余逆后不能破僧。以造余逆及受彼果处无定故。于斯且举净行为初类。显端严语具圆等。丑陋讷等无破能故。要异处破非对大师。以诸如来不可轻逼。言词威肃对必无能。唯破异生非破圣者。他不能引得证净故。有说得忍亦不可破。由决定忍佛所说故。为含二义说愚夫言。要所破僧忍师异佛。忍异佛说有余圣道。应说僧破在如是时。此夜必和不经宿住。如是名曰破法轮僧。能障佛法轮。坏僧和合故。谓由僧坏邪道转时。圣道被遮暂时不转。言邪道者。提婆达多妄说五事为出离道。一者不应受用乳等。二者断肉。三者断盐四者应被不截衣服。五者应居聚落边寺众。若忍许彼所说时名破法轮。亦名僧破。何洲人几破法轮僧破羯磨僧。何洲人几。颂曰

  赡部洲九等　　方破法轮僧
  唯破羯磨僧　　通三洲八等

论曰。唯赡部洲人少至九。或复过此能破法轮。非于余洲以无佛故。要有佛处可立异师。要八苾刍分为二众以为所破能破第九故众极少犹须九人。等言为明过此无限。唯破羯磨通在三洲。极少八人多亦无限。通三洲者。以有圣教及有出家弟子众故。要一界中僧分二部别作羯磨故须八人。过此无遮故亦言等于何时分容有破僧破羯磨僧。从结界后迄今亦有至法未灭破法轮僧。除六时分。何等为六。颂曰

  初后疱双前　　佛灭未结界
  于如是六位　　无破法轮僧

论曰。初谓世尊成佛未久有情有善阿世耶故恶阿世耶犹未起故。后谓善逝将般涅槃。圣教增广善安住故。必僧和合佛方涅槃。有余师言。证法性定故。众咸忧戚故。非初非后于圣教中戒见二疱。若未起位亦无破僧。要见疱生方敢破故。未立止观第一双时。法尔由彼速还合故佛灭后时他不信受。无有真佛为敌对故。未结界时无一界内。僧分二部可名僧破。于此六位无破法轮。如是破僧诸佛皆有。不尔要有宿破他业。于此贤劫迦叶波佛时。释迦牟尼曾破他众故。具止傍论应辩逆缘。颂曰

  弃坏恩德田　　转形亦成逆
  母谓因彼血　　误等无或有
  打心出佛血　　害后无学无

论曰。何缘害母等成无间非余。由弃恩田坏德田故。谓害父母是弃恩田。如何有恩身生本故。如何弃彼谓舍彼恩德田。谓余阿罗汉等。具诸胜德及能生故。坏德所依故成逆罪。若有父母子初生时。为杀弃于豺狼路等。或于胎内方便欲杀。由定业力子不命终。彼有何恩弃之成逆。彼定由有不活等畏于子事急起欲杀心。然弃等时必怀悲愍数数缘子爱恋缠心。若弃此恩下逆罪触。为显逆罪有下中上故说弃恩皆成逆罪。或由母等田器法。然设彼无恩但害其命。必应无间生地狱中。诸聪慧人咸作是说。世尊于法了达根源。作如是言但应深信。父母形转杀成逆邪。逆罪亦成依止一故。由如是义故有问言。颇有令男离命根。非父阿罗汉而为无间罪触不。有谓母转形与此相违。问女亦尔设有女人羯剌蓝堕。余女收取置产门中生子。杀何成害母逆因。彼血生者识托方增故。第二女人但如养母。虽诸所作皆应咨决。而害但成无间同类。上座于此作如是言。若羯剌蓝有命无堕。若有堕者必已命终。有情必无住粪秽故。由无是事为问唐捐。设有如斯害后成逆弃重恩故。害前不然于子重恩非关彼故。上座决定于业趣中。不能审知功能差别如何中有穿度金刚。母腹所拘不往余处。母腹中火能消金石。而羯剌蓝于中增长。地狱中有现母腹中而不能烧腹。及同类此亦应尔业力难思。虽此腹中羯剌蓝堕。何妨转至余腹中增。曾闻经中说有尊者童子迦叶。如是而生既置产门。吸至胎处故不可说住粪秽中。或有但从口饮入腹。亦由业力转至胎处。有情业用不可思议。虽无欲心而由业力。有吸至腹即成胎藏。后母虽有持养等恩而于子身非能生本。若持养等害便成逆。杀养母人应成无间。故彼所立弃重恩田。便有不成或不定失。前母虽阙持养等恩。而于子身是能生本。若非持养害不成逆。如前所说于子有怨。子反害之应无无间。故彼所立非关彼因。亦有不成及不定失。故唯人趣结生胜缘。害成害母逆非唯持养者。若于父母起杀加行。误杀余人无无间罪。于非父母起杀加行。误杀父母亦不成逆。若一加行害母及余。二无表生表唯逆罪。以无间业势力强故。妙音尊者作如是言。于此位中亦有二表。表是积集极微成故。今观彼意表有多微。有逆罪收有余罪摄。有于阿罗汉无阿罗汉想。亦无决定解此非阿罗汉。无简别故害成逆罪。非于父母全与此同。以易识知而不识者虽行杀害无弃恩心。阿罗汉人无别标相既难识是亦难知非故漫心杀亦成无间。若有害父父是阿罗汉。得一逆罪以依止一故。若尔喻说当云何通。佛告始欠持。汝已造二逆所谓害父杀阿罗汉。彼显一逆由二缘成。或以二门诃责彼罪。若于佛所恶心出血。一切皆得无间罪耶。要以杀心方成逆罪。打心出血无间则无。无决定心坏福田故。若杀加行位彼未成无学。将死方得阿罗汉果。能杀彼者有逆罪耶。无。于无学身无杀加行故。若造无间加行不可转。为有离染及得圣果耶。颂曰

  造逆定加行　　无离染得果

论曰。无间加行若必定成中间决无离染得果。余恶业道加行中间。若圣道生业道不起。转得相续定违彼故。非已见谛者业道罪所触。无间加行为有可转。而言若彼不可转耶。有作是言。皆不可转故本论说。颇有未害生杀生未灭。此业受异熟定生地狱耶。曰有。如作无间业加行位命终指鬘。虽发欲害母心而未正兴害母加行。于世尊所虽有害心亦未正兴害佛加行。彼作是意近方下手。世尊为遮彼业障故。至未生信不令得近室利鞠多。于薄伽梵亦不全起。无所顾心以发意言。世尊若是一切智者自知避故。有余师说。亦有可转本论不言无间加行皆不可转。但说加行不息。死者定生地狱。加行息者非彼所论。然我所宗无间加行总说有二。一近二远。于中近者不可转故。本论依之而兴问答。谓有于母起害加行。才击无间母命未终。或母力强反害其子。或为王等擒捉而杀。或子寿尽自致命终。本论依斯作如是说。于中远者由尚未至不可转位容有可转。若不尔者世尊应说无间加行亦无间罪。譬喻者言。五无间业尚有可转况彼加行。故契经言若有一类。于五无间造作增长。无间必堕奈落迦中。准此一类言知别有一类。虽造无间不生地狱。不尔一类成无用言。又世尊言娑罗设解。我所说义但无解能。此中既唯说不解语是决定障。故知世尊说一切业皆悉可转。又世尊记旋绕制多一切皆当得生天故。又世尊记提婆达多。断善根后不可治故。又如烦恼障业障亦可转。如是所言皆非能立。于经及理不善了故。且彼所引有一类经。意显有人具造五逆。无间必堕奈落迦中。或有乃至唯造一逆。或有造讫多门增长。或有唯造后更不增。皆无间生堕于地狱。且举初故说一类言。或显有人乘无间业无间必堕奈落迦中。有乘余业故言一类。不说一类便谓唯乘无间业因无间生彼。婆罗经意显造逆人不解如来所说深义。业障碍故当所获得。彼异熟果增上力故。观谛善根因被损故。或有悔忧所损恼故。于佛所说不能深解。若执经义但如其文。是则极成无间不转。言无间者显无隔故。又彼天授粗解佛言。何缘必生无间地狱。故知此据解深说解。记生天证理亦不成。佛于彼经差别说故。谓彼经说诸有依人旋绕制多皆生天故。有方便者名有依人。即是有容生天理义。然譬喻者略引彼经便开有情多造恶行。以许造作猛利极重。诸恶行者起下善心。或无记心于制多所。暂时旋绕便总灭故。断善后证理亦不成。唯断善根亦可回转。佛不应说彼不可治。故知彼言更有别义。谓彼天授先起恶欲。由此已应堕于恶趣。次起加行将破僧时。由此已应堕于地狱。次后妄语破坏僧时。由此已招无间劫寿。后起邪见断善根已。定不可令现起白法。故说此后必不可治。非谓彼尔时方定堕地狱。然于此位容有生疑。提婆达多虽至此位佛何不疗。如未生怨为遣彼疑。陈不疗意言。我不见提婆达多可令现身起少白法。故我弃舍不欲疗治。少白法言显善悔愧。此中意显佛晓诸亲。天授如斯造重恶业。断诸善本都无愧心。我当如何能救疗彼。言可疗者谓可化令生善。悔心伏恶行病。若未增者令其不增。若有已增令渐微薄。非要绝本方名疗治。如世良医疗病法尔。烦恼障喻证亦不成。我亦不许彼可转故。谓烦恼障发时定业。必护异熟皆不可转。故譬喻者不善了知经及理趣。以大无义蕴在己心妄兴邪辩。于诸恶行无间业中何罪最重。于诸妙行世善业中何最大果。颂曰

  破僧虚诳语　　于罪中最大
  感第一有思　　世善中大果

论曰。为破僧故发虚诳语。诸恶行中此罪最大。如何此罪虚诳语收。由所发言依异想故。谓彼于法有法想。于非法有非法想。于大师有大师想。于己身有非一切智想。然由深固恶阿世耶。隐覆此想作别异说。设有不以异想破僧。则不能生劫寿重罪。何缘此罪恶行中最。由此毁伤佛法身故。障世生天解脱道故。谓僧已破乃至未合。力能遮遏诸异生等。未入正定令不得入。若已入正定令不得余果。若已得余果令不得离染。若已得离染令不证漏尽。习定温诵思等业息。以要言之由僧被破。大千世界法轮不转。天人龙等身心扰乱。由此定招无间地狱一劫异熟。非余恶行故恶行中此罪最重。若尔何故世尊或时于诸罪中说邪见重。又说意业罪中最大。据五无间说破僧重。据五僻见说邪见重。据一切业说意业大。或约修见俱所断罪。如其次第说为最重。或依广果断诸善根害多有情。如次说重。感第一有异熟果思。于世善中为最大果。能感最极静异熟故。约异熟果故作是说。如其通就五果说者。是则应说与金刚喻定相应思能得大果。谓此能得异熟果外诸有为无为四阿罗汉果。虽诸无漏无间道思。皆除异熟得余四果。然此所得最为殊胜。诸结永断为此果故。为简此故说世善言。为唯无间罪定生地狱。诸无间同类亦定生彼。非定无间生。非无间业故。无间同类其相云何。颂曰

  污母无学尼　　杀住定菩萨
  及有学圣者　　夺僧和合缘
  破坏窣堵波　　是无间同类

论曰。言同类者是相似义。若有于母阿罗汉尼行非梵行。为极污辱是名第一同类业相。若有杀害住定菩萨。是名害父同类业相。若有杀害有学圣者。是名第三同类业相。若有侵夺僧和合缘。是名破僧同类业相。若有破坏佛窣堵波。是名第五同类业相。有异熟业于三时中极能为障。言三时者。颂曰

  将得忍不还　　无学业为障

论曰。若从顶位将得忍时。感恶趣业皆极为障。以忍超彼异熟地故。如人将离本所居国。一切债主皆极为障。若有将得不还果时。欲界系业皆极为障。若有将得无学果时。色无色业皆极为障。此后二位喻说如前。然于此中除顺现受。及顺不定受异熟。不定业并异熟定中非异处熟者

说一切有部顺正理论卷第四十三阿毗达磨顺正理论卷第四十四

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩业品第四之十二

如上所言住定菩萨为从何位。得住定名。彼复于何说名为定。颂曰

  从修妙相业　　菩萨得定名
  生善趣贵家　　具男念坚故

论曰。从修能感妙三十二大士夫相异熟果业。菩萨方得立住定名。以从此时乃至成佛常生善趣。及贵家等。生善趣者。谓生人天。由此趣中多行善故。妙可称故立善趣名。于善趣内常生贵家。谓婆罗门。或刹帝利。巨富长者。大婆罗门家。于贵家中根有具缺。然彼菩萨恒具胜根。恒受男身尚不为女。何况有受扇搋等身。生生常能忆念宿命。所作善事常无退屈。谓于利乐一切有情。一切时中一切方便。心无厌倦名无退屈。由无退屈故说为坚岂不未修妙相业位菩提心不退应立住定名。何故要修妙相业位。菩萨方受住定位名。尔时人天方共知故。先时但为诸天所知。或于尔时趣等觉定。先唯等觉决定非余。何相应知修妙相业。颂曰

  赡部男对佛　　佛思思所成
  余百劫方修　　各百福严饰

论曰。菩萨要在赡部洲中。方能造修引妙相业。此洲觉慧最明利故。唯是男子非女等身。尔时已超女等位故。此不应说于前颂中。恒受男身义已显故。若谓先说造此业。已恒受男身。今说为明初造此业亦非女等故。此与前义有差别。此救非理义已成故。谓先已说造此业已。非女等身已显造时。亦非女等以非女等。适造此业即转形故。能招善逝殊妙相业。必依净身方能引起。故由先说此义已成。造此业时唯现对佛。谓亲见佛不共色身相好端严种种奇特。有欲引起感此类思。不对如来无容起故。此妙相业唯缘佛思。佛是可欣顺德境故。感妙相业唯思所成。非修所成不定界故。所感异熟此所系故。非闻所成彼羸劣故。亦非生得加行起故。谓彼唯于三无数劫。修行施等波罗蜜多圆满身中方可得故。唯是加行非生得善。唯余百劫造修非多。诸佛因中法应如是。唯薄伽梵释迦牟尼。精进满时能超九劫。九十一劫妙相业成。是故如来告聚落主。我忆九十一劫以来。不见一家因施我食。有少伤损唯成大利。从此自性恒忆宿生。故说齐斯非前不忆。一一妙相百福庄严。此中百思名为百福。谓将造一一妙相业时先起五十思净治身器。其次方起引一相业。于后复起五十善思。庄严引业令得圆满。五十思者依十业道。一一业道各起五思。且依最初离杀业道。有五思者一离杀思。二劝导思。三赞美思。四随喜思。五回向思。谓回所修向解脱故。乃至正见各五亦然。有余师言。依十业道各起下等五品善思。前后各然如熏静虑。有余师说。依十业道各起五思。一加行净。二根本净。三后起净。四非寻害。五念摄受。复有师言。一一相业各为缘佛。未曾习思具百现前而为严饰。百福一一其量云何。有说以依三无数劫增长功德。所集成身发起如斯。无对无数殊胜福德量唯佛知。有说若由业增上力。感轮王位王四大洲自在而转是一福量。有说若由业增上力得为帝释王。二欲天自在而转是一福量。有说唯除近佛菩萨所余一切有情。所修富乐果业是一福量。有余师言。此量太少应言世界将欲成时。一切有情感大千土。业增上力是一福量。今薄伽梵昔菩萨时。三无数劫中各供养几佛。颂曰

  于三无数劫　　各供养七万
  又如次供养　　五六七千佛

论曰。初无数劫中供养七万五千佛。次无数劫中供养七万六千佛。后无数劫中供养七万七千佛。三无数劫一一满时。及初发心各逢何佛。颂曰

  三无数劫满　　逆次逢胜观
  然灯宝髻佛　　初释迦牟尼

论曰。言逆次者自后向前。谓于第三无数劫满。所逢事佛名为胜观。第二劫满所逢事佛名曰然灯。第一劫满所逢事佛名为宝髻。初无数劫首逢释迦牟尼。谓我世尊初发心位。逢一薄伽梵号释迦牟尼。彼佛出时正居末劫。灭后正法唯住千年。时我世尊为陶师子。于彼佛所起殷净心。涂以香油浴以香水。设供养已发弘誓愿。愿我当作佛一如今世尊。故今如来一一同彼。我释迦菩萨于何位中。何波罗蜜多修习圆满。颂曰

  但由悲普施　　被析身无忿
  赞叹底沙佛　　次无上菩提
  六波罗蜜多　　于如是四位
  一二又一二　　如次修圆满

论曰。菩萨发愿初修施时。未能遍于一切含识。施一切物唯运悲心。彼于后时串习力故。悲心转盛能遍施与。一切有情非一切物。若时菩萨普于一切。能舍一切但由悲心。非自希求胜生差别。齐此布施波罗蜜多修习圆满。有说菩萨观诸世间。匮乏资财贫苦所逼。为欲饶益亦带悲心。发愿自求胜生差别。以诸菩萨曾无一时不运悲心而行施故。若时菩萨被析身支虽未离欲。贪而心无少忿齐此戒忍波罗蜜多修习圆满。忍圆满者。于彼有情心无忿。故戒圆满者不起害他身语业故。心无忿故身语无恶故。无忿时戒忍圆满。若时菩萨勇猛精进。赞叹底沙便超九劫。齐此精进波罗蜜多修习圆满。谓昔有佛号曰底沙。彼佛有二菩萨弟子。一名释迦牟尼。一名梅怛俪药。佛因观察自所化田。分明照知此二弟子。能寂所化先熟非自身。慈氏自身先熟非所化。知已复作如是思惟。速熟一身其事少易。遂以方便入宝龛中。结加趺坐依殊胜定。不共佛法普现在前。能寂因行遇见彼佛。威光赫奕特异于常。欻为净心执持举体。一足而立经七昼夜。以妙伽他赞彼佛曰

  天地此界多闻室　　逝宫天处十方无
  丈夫牛王大沙门　　寻地山林遍无等

如是赞已便超九劫。于慈氏前证无上果。若时菩萨处金刚座。将登无上正等菩提。次无上觉前住金刚喻定。齐此定慧波罗蜜多修习圆满。理应此位无间方圆得尽智时此方满故。别别能到圆德彼岸故。此六名波罗蜜多。契经说有三福业事。一施类福业事。二戒类福业事。三修类福业事。此云何立福业事名。颂曰

  施戒修三类　　各随其所应
  受福业事名　　差别如业道

论曰。三类皆福或业或事随其所应如业道说。谓如分别十业道中。有业亦道。有道非业。此中有福亦业亦事。有福业非事。有福事非业。有唯是福非业非事。且施类中身语二业。具福业事三种义名。善故是福。作故亦业。是能等起身语业思。转所依门故亦名事。彼等起思唯名福业。思俱有法唯受福名。戒类既唯身语业性。故皆具受福业事名。修类中慈唯名福事。业之事故慈相应思。以慈为门而造作故。慈俱思戒唯名福业。余俱有法唯受福名。悲等准此皆应思择。有说福业显作福义。谓福加行事显所依。谓施戒修是福业之事。为成彼三起福加行故。有说唯思是真福业。福业之事谓施戒修。以三为门福业转故。何法名施施招何果。颂曰

  由此舍名施　　谓为供为益
  身语及能发　　此招大富果

论曰。虽所舍物及能舍具皆可名施。而于此中所立施名但依舍具。谓由此具舍事得成故。舍所由是真施体。如所度境不得量名。所立量名依能度具。或为角胜贮藏称誉。传习随他亲爱亲附。由如是等舍事亦成。然非此中正意所说。为简彼故说为供为益。言于已涅槃唯为。供养于余亦为益。彼大种诸根有行施时。但为益彼具名何谓。谓身语业及此能发。能发谓何谓。无贪俱能起此聚即身语业。及能起心并此俱行总名施体。如有颂曰

  若人以净心　　辍己而行施
  此刹那善蕴　　总立以施名

应知如是施类福业事。回向解脱亦得离系果。而且就近决定为言但说能招大财富果。依何立此大财富名。以财妙广不可夺故。角胜等施毒刺所伤。虽施而无大财富果。言施类福者。显施为体义。如泥类器木类柱等。亦见类言非显体义。如闻类智非今所许。戒修类言准此应释。为何所益而行施耶。颂曰

  为益自他俱　　不为二行施

论曰。施主施时观于二益。一为自益感果善根。二为益他诸根大种。施主有二。一有烦恼。二无烦恼。有烦恼者。复有二种。一未离欲贪。二已离欲贪。于此二中各有二种。一诸圣者。二诸异生。此中未离欲贪圣者。及已未离欲贪异生。奉施制多唯为自益。谓自增长二种善根。一者能招大富为果。二者为得上义资粮。诸有已离欲贪圣者。奉施制多除顺现受不招大富。由彼已能毕竟超彼异熟地故。而容为得上义资粮。是故亦名唯为自益。非此能益他根大种故。不益他无烦恼者。施他有情唯为益他。谓能益他诸根大种非自增长二种善根故。非自益有烦恼者。施他有情为二俱益无烦恼者。奉施制多除顺现受不为二益。有师唯约施招大富分别施果。彼作是说此中一切。未离欲贪及离欲贪。诸异生类持己所有。奉施制多此施名为唯为自益。非彼由此有获益故。若诸圣者已离欲贪。施诸有情除顺现受。此施名曰唯为益他。以彼由此获饶益故。非为自益超果地故。若彼一切未离欲贪及离欲贪。诸异生类持己所有施诸有情。此施名为为二俱益。若彼圣者已离欲贪。奉施制多除顺现受。此施名曰不为益二。以此唯为供养报恩。前已总明施招大富。今次当辩施果别因。颂曰

  由主财田异　　故施果差别

论曰。施有差别由三种因谓。主财田有差别故。施差别故果有差别。言主财田有差别者。谓如是类施主财田胜劣与余主财田异。且由施主有差别者。颂曰

  主异由信等　　行敬重等施
  得尊重广爱　　应时难夺果

论曰。或有施主于因果中得决定信。或有施主于因果中心怀犹豫。或有施主率尔随欲。或有施主具净尸罗。或少亏违。或全无戒。或有施主于佛教法具足多闻。或有少闻。或无闻等。而行惠施由施主具信戒闻等。差别功德故名主异。由主异故施成差别。由施差别得果有异。诸有施主具如是德。能如法行敬重等四施。如次便得尊重等四果。谓若施主行敬重施。便感常为他所尊重。若自手施便能感得于广大财爱乐受用。若应时施感应时财。所须应时非余时故。若无损他施便感资财。不为王火等之所侵坏。由所施财有差别者。颂曰

  财异由色等　　得妙色好名
  众爱柔软身　　有随时乐触

论曰。由所施财或阙或具色香味触。如次便得或阙或具妙色等果。谓所施财色具足故。便感妙色香具足故。便感好名如香芬馥。遍诸方故味具足故。便感众爱如味美妙。众所爱故触具足故。感柔软身及有随时生乐受触。若有所阙随应果减。如是亦由具色香等。故名财异由财异故。施体及果皆有差别。由所施田有差别者。颂曰

  田异由趣苦　　恩德有差别

论曰。由所施田趣苦恩德各有差别。故名田异由田异故施果有殊。由趣别者如世尊说。若施傍生受百倍果。施犯戒人受千倍果。百倍千倍果量如何。随所施田由受食等。令其寿等增尔所量。施主由斯于人天中受等过彼百倍千倍。故世尊说。施主施时施所施田寿等五事。施主由此于人天中还当获得寿等五果。由苦别者如七有依福业事中。先说应施客行病侍园林常食。及寒风等随时衣药。复说若有具足净信男子女人。成此所说七种有依福业事者。所获福德不可取量。今于此中由缘差别故苦有异。由除受者差别苦故果有差别。由恩别者如父母师及余有恩。如熊鹿等本生经说。诸有恩类于有恩所。起诸恶业果现可知由此比知行报恩善其果必定由德别者如契经言。施持戒人果百千倍。乃至施佛果最无量。虽皆无量亦有少多。如殑伽河大海水滴。如望财施法施为尊。就财施中何为最胜。颂曰

  脱于脱菩萨　　第八施最胜

论曰。若已解脱者施已解脱田。于财施中此最为胜。若诸菩萨以胜意乐等欲利乐一切有情。为大菩提而行惠施。虽非解脱施解脱田。而施福中此最为胜。除此更有八种施中。第八施福亦最为胜。八施者何。一随至施。二怖畏施。三报恩施。四求报施。五习先施。六希天施。七要名施。八为庄严心。为资助心为资瑜伽。为得上义而行惠施。随至施者。谓随有情投造已来随宜。施与衣服饮食非深敬重。怖畏施者。谓睹灾厄为令静息而行惠施。或见此物坏相现前。宁施不亡故行惠施。习先施者。谓习先人父祖家法而行惠施。为严心者。谓为引发信等圣财故行惠施。资助心者。谓欲灭除诸悭吝垢而行惠施。资瑜伽者。谓求定乐展转生因而行惠施。谓由施故便得无悔。展转乃至心一境性。得上义者。谓得涅槃。由初舍财乃至展转一切生死皆能舍故。又行惠施是胜生因。依此能引发证涅槃法故。余施易了故不别释。如世尊说施圣果无量。颇施非圣果亦无量耶。颂曰

  父母病法师　　最后生菩萨
  设非证圣者　　施果亦无量

论曰。如是五种设是异生施者。亦能招无量果。住最后有名最后生法师。四田中是何田所摄是恩田摄。所以者何。以说法师能示将堕诸恶趣者。安隐城门开示生天解脱道故。能令已作非理行者转于如理所作中行。能善宣扬黑白品法自性及果对治等故。能施无智盲者慧眼。由说法师所说教力。无倒观察染净品故。以要说者。善说法师乃至能为佛所作事。故唯此是胜义恩田施者。必应招无量果。一切能感无量果业。上下品类皆平等耶。不尔云何。由六因故令一切业成轻重品。其六者何。颂曰

  后起田根本　　加行思意乐
  由此下上故　　业成下上品

论曰。后起者。谓作此业已。或顿或数随前而作。田谓于彼造善造恶。根本者谓根本业道。加行者谓引彼身语。思谓由彼业道究竟。意乐者谓所有意趣。我应当造如是如是。若有六因皆是上品。此业最重翻此最轻。除此中间非最轻重。谓或有业唯由后起所摄受。故得成重品定安立彼异熟果故。乃至或有唯由意乐。由二三等如理应知。如契经言。审思作业名为造作。亦名增长。何因说业名增长耶。由五种因何等为五。颂曰

  由审思圆满　　无恶作对治
  有伴异熟故　　此业名增长

论曰。由审思故者。谓审思而作非率尔思作。亦非全不思。由圆满故者。谓齐此量业应堕恶趣。此业圆满名为增长。余唯造作。如有一类于恶行中。由一为因便堕恶趣。或有一类乃至由三。十业道中或有由一或乃至十方堕恶趣。由无恶作对治故者。谓无追悔无对治业。由有伴故者。谓作不善业不善为助伴。如盗他财。复污他室。杀他子等。由异熟故者。谓时不定业定。与异熟善上相违。异此应知唯名造作。如上所说。未离欲等奉施制多。唯为自益既无受用者。施福如何成。颂曰

  制多舍类福　　如慈等无受

论曰。非我唯许所舍财物。受者受用施福方成。所许者何谓。诸施福略有二类。一舍二受。舍类福者。谓由善心但舍资财施福便起。受类福者谓所施田受用施物施福方起。于制多所奉施供具。虽无受类有舍类福。然舍类福初舍资财此福即成对治贪故。无贪俱思所等起故。舍资财已随所施田受用。或不施福无失。若不尔者有施僧伽。或别人等诸资生具。或彼未用物便坏失。如是施主物应唐捐施福不生无当果故。彼既未用福由何生。用福虽无而有受福制多无受福由何生。复何因证知福生要由受不受于彼无摄益故。此非定证。所以者何。如修慈等福亦生故。谓修慈定于诸有情平等发起与乐意乐。虽无受者亦无摄益。而胜解力有多福生。修悲等定得福亦尔。施制多福类亦应然。于有德田追生胜解起极尊敬。奉施制多虽无受者亦无摄益。由自思力有多福生然不唐捐。起施敬业要因起业方起胜思。胜思方能生胜福故。如有一类欲害怨家。怨命虽终犹怀怨想。发起种种恶身语业。生多非福非但起心。如是大师虽已过去追申敬养。起身语业方生多福非但起心。有设难言于善田所。殖施业种既爱果生。殖在恶田果应非爱。此难非理。所以者何。颂曰

  恶田有爱果　　果种无倒故

论曰。现见田中种果无倒。从未度迦种苦果终不生。赁婆种中不生甘果。非由田力种果有倒。然由田过令所殖种。或生果少或果全无。如是虽于恶田殖施。而由施主利乐他心。唯爱果生不招非爱。已辩施类戒类当辩。颂曰

  离犯戒及遮　　名戒各有二
  非犯戒因坏　　依治灭净等

论曰。言犯戒者。谓诸不善色即从杀生。乃至杂秽语此中性罪立犯戒名遮。谓佛所遮即非时食等。虽非性罪而佛为护正法有情。别意遮止受戒者犯亦名犯戒。简性罪故但立遮名。离性及遮俱说名戒。此各有二。谓表无表。以身语业为自性故。戒具四德得清净名。随有所减不名清净。言四德者。一者不为犯戒所坏。言犯戒者谓审思犯。二者不为彼因所坏。彼因谓贪等烦恼随烦恼。三者依治谓依念住等。此能对治犯戒及因故。四者依灭谓依涅槃回向涅槃非有财故。等言为显复有异说。有说戒净由五种因。一根本净。二眷属净。三非寻害。四念摄受。五回向寂。有余师说。戒有四种。一怖畏戒。谓怖不活恶名治罚恶趣畏故受护尸罗。二希望戒。谓贪诸有胜位多财恭敬称誉受持净戒。三顺觉支戒。谓为求解脱及止观故受持净戒。四清净戒。谓无漏戒。彼能永离业惑垢故。已辩戒类修类当辩。颂曰

  等引善名修　　极能熏心故

论曰。等引善者谓于定中等持自性。及彼俱有即此名修。极熏心故修是熏义如花熏麻。谓诸定善于心相续。极能熏习令成德类。非不定善故独名修。前辩施福能招大富。戒修二类所感云何。颂曰

  戒修胜如次　　感生天解脱

论曰。戒感生天。修感解脱。胜言为显就胜为言。谓施亦能感生天果就胜说戒。持戒亦能感离系果。就胜说修。如是戒修亦感大富。就胜说施准例应知。经说四人能生梵福。一为供养如来驮都。建窣堵波于未曾处。二为供养四方僧伽。造寺施园四事供给。三佛弟子破已能和。四于有情普修慈等。如是梵福其量云何。颂曰

  感劫生天等　　为一梵福量

论曰。有余师说。随福能感一劫生天。受诸快乐齐是名曰一梵福量。由彼所感受快乐时。同梵辅天一劫寿故。以于余部有伽他言

  有信正见人　　修十胜行者
  便为生梵福　　感劫天乐故

已离欲者修四无量。生上界天受劫寿乐。若未离欲建窣堵波。造寺和僧能勤修习慈等加行。彼亦如修无量根本感劫天乐。岂不前说欲界无有善业能招一劫异熟。无一善业犹如不善。唯一刹那能招劫寿。依如是理故作是说。然于一事发起多思。次第能招劫量天乐。谓于彼死复于中生。故劫乐言无违前失。有余师说。此如所辩妙相业中所说福量。谓说唯除后有菩萨。所余一切有情所修。感富乐果业是一福量等。契经说施略有二种。一者财施。二者法施。财施已辩。法施云何。颂曰

  法施谓如实　　无染辩经等

论曰。若能如实为诸有情。以无染心辩契经等。令生正解名为法施。说如实言显法施主。于契经等解无颠倒。说无染言显法施主。不希利养恭敬名誉。不尔便为自他俱损。契经等者等余十一。即显契经乃至论议。言契经者。谓能总摄容纳随顺世俗胜义坚实理言。如是契经是佛所说。或佛弟子佛许故说。言应颂者。谓以胜妙缉句言词。随述赞前契经所说。有说亦是不了义经。言记别者。谓随余问酬答辩析。如波罗衍拏等中辩。或诸所有辩曾当现。真实义言皆名记别。有说是佛诸了义经。言讽颂者。谓以胜妙缉句言词。非随述前而为赞咏。或二三四五六句等。言自说者。谓不因请世尊欲令正法久住。睹希奇事悦意自说妙辩等流。如说此那伽由彼那伽等。言缘起者。谓说一切起说所由。多是调伏相应论道。彼由缘起之所显故。言譬喻者。为令晓悟所说义宗。广引多门比例开示。如长喻等契经所说。有说此是除诸菩萨。说余本行能有所证示所化。言言本事者。谓说自昔展转传来。不显说人谈所说事。言本生者。谓说菩萨本所行行。或依过去事起诸言论。即由过去事言论究竟是名本事。如曼驮多经。若依现在事起诸言论。要由过去事言论究竟是名本生。如逻刹私经。言方广者。谓以正理广辩诸法。以一切法性相众多。非广言词不能辩故。亦名广破。由此广言。能破极坚无智闇故。或名无比。由此广言理趣幽博余无比故。有说此广辩大菩提资粮。言希法者谓于此中唯说希奇出世间法。由此能正显三乘希有故。有余师说辩三宝言世所罕闻故名希法。言论议者。谓于上说诸分义中。无倒显示释难决择。有说于经所说深义已见真者。或余智人随理辩释亦名论议。即此名曰摩怛理迦。释余经义时此为本母故。此又名为阿毗达磨。以能现对诸法相故。无倒显示诸法相故。如是所说十二分教略说应知三藏所摄。言三藏者。一素怛缆藏。二毗柰耶藏。三阿毗达磨藏。如是三藏差别云何。未种善根未欣胜义。令种欣故为说契经。已种已欣令熟相续。作所作故为说调伏。已熟已作令悟解脱。正方便故为说对法。或以广略清妙文词。缀缉杂染及清净法。令易解了名为契经。宣说修行尸罗轨则。净命方便名为调伏。善能显示诸契经中。深义趣言名为对法。或依增上心戒惠学所兴论道。如其次第名为契经调伏对法。或素怛缆藏是力等流。以诸经中所说义理。毕竟无有能屈伏故。毗柰耶藏是大悲等流辩说尸罗济恶趣故。阿毗达磨藏是无畏等流。真法相中能善安立。问答决择无所畏故。如是等类三藏不同。毗婆沙中已广分别。前已别释三福业事。今释经中顺三分善。颂曰

  顺福顺解脱　　顺决择分三
  感爱果涅槃　　圣道善如次

论曰。顺福分善。谓感世间人天等中爱果种子。由此力故能感世间高族大宗大富妙色。轮王帝释魔王梵王。如是等类诸可爱果。顺解脱分善。谓安立解脱善阿世耶令无倾动。由此决定当般涅槃。辩此善根自性地等。应知如辩贤圣处说。顺决择分善。谓暖等四此亦如后辩贤处说。如世间所说书印算文数。此五自体云何应知。颂曰

  诸如理所起　　三业并能发
  如次为书印　　算文数自体

论曰。如理起者正加行生。三业应知即身语意。能发即是能起此三。如其所应受想等法。此中书印以前身业及彼能发五蕴为体。非诸字像即名为书。所雕印文即名为印。然由业造字像印文。应知名为此中书印次算及文。以前语业及彼能发五蕴为体。后数应知以前意业。及彼能发四蕴为体。但由意思能数法故。应辩圣教诸法相中。少分异名令不迷谬。颂曰

  善无漏名妙　　染有罪覆劣
  善有为应习　　解脱名无上

论曰。善无漏法亦名为妙。胜染无记及有漏法故唯此法独受妙名。诸染污法亦名有罪。是诸智者所诃厌故亦名有覆。以能覆障解脱道故。亦名为劣极鄙秽故应弃舍故。准此妙劣余中已成。故颂不辩即有漏善。无覆无记总名为中。诸有为善亦名应习。余非应习义准已成。何故无为不名应习。以不可说在相续中。数习令增及无果故。谓若有法于相续中。可数令生习令增长。如圣道等可名应习。无为不尔故不立应习名。然劝以涅槃置在心中者。教有情类令趣涅槃。劝令数现起缘涅槃善智。故作是言非谓应习。又为果故习无为无果故。不善无记非应习者。以彼体非升进法故。解脱涅槃亦名无上。以无一法能胜涅槃。是善是常超众法故。涅槃是善何理。应知以契经言极安隐故。又说安隐是善义故。余法有上义准已成。即一切有为虚空非择灭

说一切有部顺正理论卷第四十四阿毗达磨顺正理论卷第四十五

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩随眠品第五之一

广辩诸业并决择已。诸契经中说感有处。皆言诸业能为引因。然见世间有离染者。虽亦造善身语意业。而无功能招后有果。故于感有业应非因。业独为因非我所许。要随眠助方有感能。非离随眠业独能感。故缘起教初说随眠。此复何因随眠有几。颂曰

  随眠诸有本　　此差别有六
  谓贪嗔亦慢　　无明见及疑

论曰。由此随眠是诸有本。故业离此无感有能。何故随眠能为有本。诸烦恼现起为十六事故。一坚固根本令得坚牢。对治远故烦恼根本谓烦恼得。二生依粗重能辩所依中无堪任性故。三建立相续能数令余连续起故。四修治自田令所依止顺彼住故。五憎背功德性相能违诸功德故。六为厌诃本发智所。厌诃身语意业故。七引毒等流能引如自随烦恼故。八拥解脱路弃背亲近正说者故。九能发业有发起能招后有业故。十摄自资粮能数数摄。起非理作意故。十一迷于所缘能害自身正觉慧故。十二殖众苦种能生一切生死苦故。十三将导识流于后有所缘能引发识故。十四违越善品令诸善法皆退失故。十五广系缚义令不能越自界自地。以能长养染污界故。十六摄世非爱诸增上果。因此外物皆衰变故。由是随眠能为有本。故业因此有感有能虽离染者亦造善业。而无势力能招后有。是故智者应勤精进。思择随眠速令除灭。以何门义思择随眠。谓观随眠此见所断。此修所断。此唯一部此二此四此通五部。此是遍行此非遍行。此自界遍此他界遍。此有漏缘此无漏缘。此有为缘此无为缘。此云何起云何随增。此由遍知所缘故断此由断灭所缘故断。此由永害助伴故断。此由清净相续故断。此与彼相应此与彼不相应。此断已可退此断已不可退。此有非爱异熟此全无异熟。此是彼等无间此是彼所缘。此因所缘断此因所缘不断。此体虽已断而所缘故缚。此于定地无容得有。此非世间治道所灭。此唯意识身此通六识身。此能等起身语二业。此能断善根此能续善根。此是见性此非见性。此唯九品断此唯一品断。此一品断或九品断此田彼故成就。此由彼故不成就。此由彼故相应。此由彼故不相应。此于彼位容有现行。此虽未断而不现行。此唯在欲界断此亦在上界断。有成就此果有不成就此果。此同对治此别对治。以如是等众多义门应善思择。诸随眠相如是。善知随眠相已方能决定除灭随眠。亦能为他无倒显说。自他相续善品更生。能速了知遣除方便。是故若欲利乐自他。应于随眠如是思择。随眠差别略有六种。谓贪嗔慢无明见疑。经主于此作如是释。颂说亦言意显慢等亦由贪力于境随增。谓契经言因爱生恚。如嗔由贪力于境随增。慢等亦由贪故复言亦。此释无理非文意故。谓此本为标数列名。不明此因彼于境随增义。今详亦字为满句言。若必欲令此有别义。更为方便作无过释。谓嗔如贪虽有多类。而可总说为一随眠。慢等亦然故复言亦。或此为显如贪与嗔行相不同是故别立。如是慢等。行相虽同余义有殊故亦别立。及声为显释据相违。或显总摄随眠类尽。若诸随眠数唯有六。何缘经说有七随眠。颂曰

  六由贪异七　　有贪上二界
  于内门转故　　为遮解脱想

论曰。即前所说六随眠中。分贪为二故经说七。何等为七。一欲贪随眠。二嗔随眠。三有贪随眠。四慢随眠。五无明随眠。六见随眠。七疑随眠。欲贪随眠依何义释为欲贪。体即是随眠为是欲贪之随眠义。于余六义征问亦尔。经主于此作是释言。此是欲贪之随眠义。然随眠体非心相应。非不相应无别物故。烦恼睡位说名随眠。于觉位中即名缠故。何名为睡。谓不现行种子随逐。何名为觉。谓诸烦恼现起缠心。何等名为烦恼种子。谓自体上差别功能。从烦恼生能生烦恼。如念种子是证智生能生当念功能差别。又如芽等有前果生能生后果功能差别。今详彼释于理不然。自许随眠离诸烦恼无别物故。不染污法为烦恼体理不成故。不可说为睡随眠体。故无少物名睡随眠。又若随眠是烦恼种。离诸烦恼无别有物。则不应说谓自体上差别功能。从烦恼生能生烦恼名烦恼种。又彼所执烦恼功能。若是烦恼以生为性则不可说此睡烦恼。离觉烦恼无别有物。若非烦恼以生为性。如是生性岂非别物。又不应说烦恼睡位说名随眠。若此功能即是烦恼亦非烦恼。如是言义曾所未闻。若此功能非烦恼性。亦非余性而说是生。此极希有无体而许。是现在故非无体法。可得说言从烦恼生能生烦恼。又彼所立宗因相违。所以者何。谓彼所说然随眠体。非心相应非不相应无别物故。今应责彼无别物言。为离觉时诸缠自体。为离睡位所依自体。为离异二第三聚法无别物耶。然皆非理彼法非此品类性故。又此离彼无别体故。又离相应不相应外。应别有一违二法生。然此第三必不可得。故彼所说但有虚言。又彼初言然随眠体非心。相应非不相应。此言诚实都无体故。后不应说差别功能。从烦恼生能生烦恼。以无体法非因果故。又彼此中据何别理。唯执烦恼不现行位种子随逐说名随眠非余法种亦立斯号。如彼所执亦有心等差别功能。从心等生能生心等名为种子。何不亦说心等随眠。上座此中立多因证。谓随眠者。是诸有情相续所持烦恼类故。不由功力恒随逐故。由遍知彼息众苦故。观彼速能依对治故。智者恒观为病性故。如是所立皆非证因。许有情身中具五蕴类故。或且彼许有业类故。心等功能不由功力亦恒随故。契经中言遍知诸法息众苦故。若观现行缠过失者。彼最能速依对治故。经言有智应常观察五种取蕴为病性故。谁有鉴者于彼所立证随眠因心能生喜。又随眠体于自相续既恒随逐何非现行。以现行名目现在故。由此经主恶立随眠。又所立喻如念种子是证智生能生当念功能差别。亦不相似以我宗言念种子者。即于证智后初重缘实念。从先证智俱起念生能生后时忆智俱念。此显即念前后相引为能赴感差别功能。彼自体俱生无别实烦恼。从前缠起能生后缠可名随眠。烦恼种子故喻于法相去极遥。由此应知彼第二喻。于所况法亦无证能。谓芽等中有实色等。从前果位实色等生生后果时实色等法。彼宗所立烦恼随眠差别功能无如是事。又无芽等同类相续因果俱时。有自体中烦恼种子。与缠俱义则不应计。于自体中烦恼功能。从前已灭诸烦恼起。犹如芽等从前果生功能差别。如斯乃是食米脐宗岂得引来摸托圣旨恶说法者妄所执故。况经主论劣甚彼宗。谓彼宗中许有别法说名为行是智果因。然经主宗无别实物名为种子。如何说是烦恼果因故为甚劣。上座于此谓佛世尊自说诸缠与随眠异。谓诸烦恼现起名缠以能现前缚相续故。烦恼随界说名随眠。因性恒随而眠伏故。以契经说幼稚童子婴孩眠病。虽无染欲而有欲贪随眠随增。此唯说有诸随眠性。又说一类于多时中为欲贪缠缠心而住。此文唯说有烦恼缠。又说一类非于多时为欲贪缠缠心而住。设心暂尔起欲贪缠寻如实知出离方便。彼由此故于欲贪缠能正遣除并随眠断。此文通说缠及随眠由此故知。现起烦恼烦恼随界名缠随眠。若随眠声目烦恼得此不应理曾无说故。又已除遣别有得故如是随眠以何为体。若彼随眠以彼为体。是随彼法功能性故。或此通用四蕴为体功能随逐心心所故。此相应性亦不相应如诸心所。然其自体不可说故而不记别。遣此多同破经主义。再详仍有粗过未除。且彼叙前宗随眠声目得。便作是斥此不应理。复辨因言曾无说故。又已除遣别有得故。此因无能随界同故。谓曾无处说随界名随眠。不说虽同而许得理胜。以契经说并随眠断故非无实体。法可与有俱断。由此已遣已遣得言。离得说何为随眠性。而说遣缠位并随眠断耶。非经部师能定显示。此随眠性是有可断又非随眠体。有说。随眠声故随眠声目得无失。谓佛但说有七随眠而随眠声有处说色。如契经说。有色随眠。若觉若思便随增故。如是随眠得虽非随眠。而说随眠声理亦为善。又彼所释前后相违。许贪等言说随眠故。谓彼先释贪等非随眠。后释经言随眠即贪等。又审思择上座所宗。缠与随眠断俱非理。是故应舍随眠异缠俱非理因如后当辩。今引违彼前所引经。谓有经言汝今何故乔答摩所修梵行耶。为求断故。求断何法。断贪嗔痴及三结等。此中不别说断随眠。上座此中作如是释。此中贪等即是随眠。岂不前言并随眠者。是随眠得非目随眠。不尔二经应相违害。曾无说故已显非理。非经部宗经有断义心相应故。去来无故非随眠断故缠后不生名断经说并断言显二俱时断故。又此经说缠胜随眠。先说遣缠并随眠故。不尔应说随眠并缠。若断随眠缠方断者。则随眠胜理应先说。又随眠未断缠容有不生。故非不生即名为断。或缠不生位即得断名。非随眠断故缠方名断。或应随眠断缠方不生。非于未断时有不生理。彼随眠体亦无断义。无别物故。如空花等。又彼所说若彼随眠以彼为体。是随彼法功能性故此亦非善。若欲贪缠所引随眠即欲贪者学心应与欲贪体一。与彼随眠无别体故。学心是学诸欲贪缠非学无学。如何可说若彼随眠以彼为体。又随眠位诸欲贪缠已灭无体。如何可说有欲贪随眠。以欲贪为体故彼所说有言无义。又彼所言或此通用四蕴为体。功能随逐心心所故亦不应理。欲贪随眠体无差别。执差别法以为自体。非观理者生喜处故。又受想识欲贪所随。即说名为欲贪自体。亦非鉴者生喜处故。又彼所说此相应性亦不相应如诸心所。彼言如有不识槃豆时缚迦花。拘枳罗鸟有作是问。拘枳罗鸟其色如何。答言。鲜白正似槃豆时缚迦花。曾无处说亦无理证。诸心所体是不相应。宁说随眠如诸心所。是相应性亦不相应。若作是言心所自体异类行相则不相应所许。随眠与随眠体异类行相既得相应则不应言诸随眠体。如诸心所亦不相应。又不应许诸心所法有不相应。非待相应方建立有不相应故。又彼所言随眠自体不可说故而不记别。诚如所言。彼宗随眠犹如马角不可说故。以要言之。彼宗所执多分无有实体可记。欲于佛教求正解者。不应习近如是论师。以聪慧人习彼论者。所有觉慧皆渐昧劣。彼论所说多不定故。前后义文互相违故。不任诘故。越圣教故。对法诸师咸作是说。欲贪等体即是随眠。如契经言。若触乐受便生欣悦。庆慰耽着坚执而住。即于乐受有贪随眠。此中随眠声即说欣悦等。经主此中作如是释。经但说有不言尔时。即有随眠何所违害。于何时有。于彼睡时。或假于因立随眠想。此释非理。尔时随眠说现有声理不成故。谓非正起贪缠刹那有贪随眠可说现有。即于乐受有贪随眠言显乐受中现有随眠故。又随眠自体应不可知故。谓经所说有随眠声若有性俱。若即有性于无体法理俱不成。无非有俱及有性故。又经但说有随眠言。宁知非尔时于余时方有。有谓有体。是现有义。如契经说。于诸欲中若有欲贪心被缚住。乃至广说。又如经说。有诸有情于可爱境有欲有贪。乃至广说。岂亦执此有及缚言。非于尔时余时有缚。又如经说。此无故彼无。岂亦可言是余时无义。故经主释定为非理。由此已遣于因假立。谓经但说有随眠言。宁知说因非随眠体。又随眠体尔时无故。不应于有立非有名。故知随眠即欲贪等。于自相续随增眠故。然我今释大母经中欲贪随眠即欲贪体。非此意辩诸随眠得。欲贪随眠所随增者是随缚义。如何随缚非由自体由起得故。如强怨敌虽住远方密遣使随伺求瑕隙。故本论释总随眠名。谓恒随行及恒随缚。此说起得非显得体。又即彼经言并随眠断者。显欲贪缠无余尽义。谓断八品修所断时。一品随眠犹能随缚。为显体断说正遣除。并随眠断言显随缚皆尽。如契经说。于此所生无量种类恶不善法。无余永灭并随缚断。此意亦显并随眠灭。是故随眠即欲贪等非随界等。其理善成。分别论师作如是说。诸随眠体是不相应。不觉不思有随眠故。谓契经说。不觉不思亦为随眠随增随缚。又道烦恼应俱时故。谓圣道起与心相应。若断与心相应烦恼。则应圣道有烦恼俱。又应非无学亦无烦恼故。谓执随眠心相应者。异生有学善无记心现在前时应无烦恼。然非所许。故知随眠是不相应行蕴所摄。此可破经部非预我宗。我宗许去来有实体故。谓虽现在不觉不思。而为去来觉思所引。诸随眠体与心相应实相随眠随增随缚。乃至未断觉思等前。于相续中恒现起得随增随缚曾无间断。由此亦无道惑俱失。亦无非无学有无烦恼过。以烦恼得非烦恼故。由此去来烦恼缚故。如汝宗圣者现起烦恼时无烦恼道俱及成异生过。我宗有学起圣道时无道烦恼俱及无烦恼失。又何用执此不相应以能为因生诸缠故。此不应理。曾无说故。佛说烦恼但以无明相不律仪。非理作意邪分别等为因故生。不说随眠为因故起。然分别论及经部师妄执随眠为缠因性。又此所计有太过失。谓若随眠为缠因故。执随眠体是不相应。经说无明因谓非理作意。此非理作意应是不相应。此不许然彼云何尔。又随眠体若许相应。可能为缠随眠因性。非余妄计不相应者。以契经说。诸有苾刍。于彼彼事中。若多起寻伺。由此由此心便沉着。又如是理世现可知。以下欲贪先数现起。后便数起上品欲贪。又若随眠非相应性。唯此能作贪等缠因。未离欲贪诸有情类。若遇境界缠起应同。以现生因无差别故。既不许尔。故执随眠与缠为因。定为横计。然随眠体定是相应。以经说随眠为欢悦等故。谓前所引契经中说。若触乐受生欢悦等。即于乐受有贪随眠。非不相应名欢悦等。又经说随眠映蔽心等。故谓契经说贪映蔽心。由此便能行身语意恶行。若随眠体是不相应。应一切时造诸恶行。又契经说。心受贪染若随眠体。是不相应应不染心。或应恒染。若谓所引皆是诸缠。此中并无随眠声故。如何不谓皆是随眠。以于此中无缠声故。又彼所释违害自宗。若无随眠声即执为缠者。如契经说。无明为因生贪嗔痴。亦应执缠为因生缠。非随眠力。是则违害先所立宗随眠为因生诸缠义。又随眠体若不相应。彼与善心为相违不。若相违者。则诸善心应毕竟不生随眠恒有故。不相违者。则诸随眠应不染恼心。然经说染恼。如契经说。贪染恼心令不解脱。无明染慧令不清净。若谓贪染恼非贪随眠。以何理为因证知如是。如贪染为性能染恼心。如是贪随眠亦染为性。如何不说能染恼心。又如爱结体即是爱能染恼心。应贪随眠体即是贪亦能染恼。或彼应辨差别因缘。由何爱结是相应性。贪随眠体是不相应。佛观有情意乐差别。于诸烦恼立种种名。如一欲贪说名欲漏欲取欲扼欲贪随眠欲瀑流贪欲盖爱结等种种名。于一欲贪差别名内。若随眠体是不相应。执是欲贪之随眠者。则欲漏等应不相应。亦应执为欲之漏等。若欲漏等非不相应。应许随眠是相应法。等是欲贪名差别故。由此理证欲贪随眠体即欲贪能为染恼。以契经说贪染恼心令不解脱。故不可执随眠恒有。是不相应。以诸善心容有起位。故随眠体定是相应。经主此中先叙尊者法胜所说。以诸随眠染恼心故。覆障心故。能违善故。非不相应。后即斥言。此皆非证。许随眠体是不相应。不许随眠为上三事。但许三事是缠所为。此都未详彼大德意。彼大德意如我先辩。若谓随眠如烦恼得。体虽恒有不障善心。此亦不然。随眠烦恼差别名体曾无说故。且分别论执随眠体是不相应可少有用。彼宗非拨过去未来。勿烦恼生无有因故。然犊子部信有去来。执有随眠非相应法。如是所执极为无用。如彼论言。诸欲贪缠一切皆是欲贪随眠。有欲贪随眠非欲贪缠。谓不相应行欲贪随眠。何缘彼部作如是执。以经论文俱可得故。释彼一切皆如前说。若但如文而取义者。如契经说。有色随眠。此文亦应不别观察。解释理趣如文而取。则随眠体非唯可执。通相应性及不相应。亦应执通有色无色。有见无见等种种差别门。又彼何缘憎背诸得。若信有得具能释通。诸圣教中幽隐文义。诸邪执类不能如实设难弹斥信有得宗。执不相应随眠论者。常为无量过难所随。不能释通圣教文义。而固方便背正执邪。未审蕴何在心故尔。何劳征问。以诸世间得及前因无始皆等。而现见有唯贪猛利。广说乃至。有杂行者。非无别因有如是事故。应由别有不相应随眠此亦不然。若信实有去来二世。虽不别立不相应行名为随眠。贪猛利等皆得成就。谓由近远二同类因境等别缘资助觉发。令其引果势力别故。且止广诤。如契经言。有贪随眠此何为体色无色爱。佛说有贪此名何因唯于彼立彼贪。多托内门转故。谓欲界贪多于欲境外门而转。不名有贪。上二界贪多于定境内门而转。故名有贪。又由有人于色无色起解脱想。为遮彼故。谓上二界有求解脱。妄想为先得生于彼。故有计彼为真解脱。佛为遮其真解脱想。故于上界立以有名。贪二界贪立有贪想。夫言有者是生身义。此则显示欲求解脱。于一切有不应希求。经主于斯复作是释。此中自体立以有名。彼诸有情多于等至及所依止深生味着。故说彼唯味着自体非味着境。离欲贪故。由此唯彼立有贪名。此释与前义有何别。谓前已说上二界贪多于定境内门而转。又说有人于色无色生身有境起解脱想。则为已说定及生身皆得有名俱自体故。详经主释。义不异前。但构浮词似有少异。上座说有二类随眠。一唯欲缠。二通三界。自兴疑问。岂不有贪。有论说言。唯上二界都无圣教。于色无色偏说有声。故难依信。然于处处诸圣教中。皆以有声通说三界。岂不于境亦说有声。欲贪随眠不应别立。此难非理。转有异故。谓诸欲贪于外门转。内门转者说名有贪。又如耽境与耽有异。所引随眠差别亦尔。又缘境界缘生身贪。对治不同故别立二。又必损伏欲贪及嗔。外仙方能入色无色。故欲贪体非即有贪。以彼有情缘自相续。我爱随逐恒无断故。上座于斯极为恶立随眠差别。以欲贪声容说一切欲界贪故。欲界生身亦欲界摄。如何缘彼贪非欲贪。如说色贪非唯缘色。总说一切缘色界贪。如是欲贪非唯缘欲总说一切缘欲界贪。上座所持契经亦说。若缘欲界起染起贪。起阿赖耶起尼延底。起诸耽着。是欲贪相。故执有贪通三界者。非为善执。又非佛说唯通三界可说有声。所以者何。有声或说一界少分二界少分三界少分。如七有经极七有等。如应配释。故此所说欲贪随眠。通摄一切欲界贪尽。余二界爱总名有贪。立名因缘。如先已辨。若唯缘内贪名有贪。则色界中色声触爱。非缘内起应非有贪。则诸随眠应立有八。又言有者。不唯生身。以契经中说业有中有。故如欲有声兼说欲境。如是欲界缘生身贪亦是欲贪随眠所摄。是故一切欲界系贪。皆以欲贪随眠声说。或于欲境亦说有声。欲贪随眠别说无用。言转异故。理亦不然。说多分言容可尔故。谓约多分理则可。然以欲界贪多外门。转色无色爱多于内门。非执欲贪。唯缘外起。唯缘内起。方名有贪。可说二贪转异故别。或彼应许色无色贪一向无缘外门转者。又诸耽境即是耽有。以诸境界亦名有故。或诸耽有即是耽境。诸有亦为境界摄故。由此所言。又如耽境与耽有异。非为善说。又彼所说由境身贪对治不同别立二者。此言对治为别为通。若谓此言约别对治。即境界贪应分多种。谓色声等诸境界贪。制伏对治各有异故。若谓此言约通对治。此二对治有异有同。如何定言对治有异。或色无色二界中贪治有不同。应亦分二。又言损伏欲贪及嗔。外仙方能入色无色。故欲贪体非即有贪。以彼有情缘自相续。我爱随逐恒无断者。此言极与圣教理违。唯不现行名为损伏。若欲界系缘生身贪。亦名有贪亦名我爱。若此我爱恒随现行。彼定无容入色无色。若不损伏下生身贪。而诸外仙容入上地。则不应说伏欲贪嗔。外仙方能入色无色。若谓现起欲境贪嗔。能障外仙入色无色。非欲界系缘生身贪。能障外仙此有何理。厌下身境方生上故。虽彼复言。岂不乃至阿罗汉向住欲界者。于欲界身有我慢爱必无是事。或何不许阿罗汉果亦有是事。若离欲界染不断欲界贪。离有顶染时亦应无断理。由彼于此非对治故。或应一切下地烦恼与有顶染俱时断灭。修前治道便为无用。或应说彼差别因缘。等欲界贪断有渐顿。若谓此证由安隐经。不尔。不了彼经义故。谓彼具寿已见谛理。依修所断欲界所系我爱我慢。故作是言。我色等中不随执我。然于如是五取蕴中。有我慢爱随眠未断。谓此烦恼随身见行。身见断故此不现起。然犹未永断。未得对治故。作如是释。何所相违有所相违。谓彼经说。佛为彼说此法门时具寿安隐成阿罗汉。诸漏永尽心善解脱。由此知彼先是不还。曾已进修阿罗汉向。于出观位作如是言。我色等中乃至广说佛为说法。经但言成阿罗汉果。不言余故。此不成证。彼契经中偏举所得最胜果故。如拊掌喻契经等说。非诸圣者作是寻思。我我似何。乃至广说。世尊方便开悟其心。经但言成阿罗汉果。谓经说彼悟佛所言成阿罗汉心善解脱。非说异生闻法顿证阿罗汉果。作是说者。偏举最胜。此亦应然。或彼契经约取蕴类作如是说。然于如是五取蕴中。有我慢爱随眠未断。理实但有上取蕴中我慢我爱。自称释子必不应言已离欲贪。犹有欲界我慢我爱随眠未断。况言此二恒随现行。是故有贪唯色无色非于欲界。其理极成。既说有贪在上二界。义准欲界贪名欲贪。故于颂中不别显示

说一切有部顺正理论卷第四十五阿毗达磨顺正理论卷第四十六

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩随眠品第五之二

如前所说六种随眠。复约异门建立为十。如何成十。颂曰

  六由见异十　　异谓有身见
  边执见邪见　　见取戒禁取

论曰。六随眠中见行异为五余非见。五积数总成十故。于十中五是见性。一有身见。二边执见。三邪见。四见取。五戒禁取。五非见性。一贪。二嗔。三慢。四无明五疑。见与非见合成十种。又即六种复约异门建立。便成九十八种。依何门建立成九十八耶。颂曰

  六行部界异　　故成九十八
  欲见苦等断　　十七七八四
  谓如次具离　　三二见见疑
  色无色除嗔　　余等如欲说

论曰。六种随眠由行部界门差别故成九十八。谓于六中由见行异建立为十如前已辩。即此所辩十种随眠。部界不同成九十八。部谓见四谛修所断五部。界谓欲色无色三界。且于欲界五部不同乘十随眠成三十六。谓见苦谛至修所断。如次有十七七八。四即上五部于十随眠。一二一一如其次第。具离三见二见见疑。谓见苦谛所断具十。一切皆违见苦谛故。见集灭谛所断各七。离有身见边见戒取。见道谛所断八。于前七增戒取。修所断四。离见及疑。如是合成三十六种。前三十二名见所断。才见谛时彼则断故。最后有四名修所断。见四谛已后后时中数数习道彼方断故。由此已显十随眠中。萨迦耶见唯在一部。谓见苦所断边执见亦尔。戒禁取通在二部。谓见苦见道所断。邪见通四部。谓见苦集灭道所断。见取疑亦尔。余贪等四各通五部。谓见四谛及修所断。如是总说见分十二。疑分为四余四各五。故欲界中有三十六。经主于此自问答言。此中何相见苦所断。乃至何相是修所断。若缘见此所断为境名见。此所断余名修所断。此不应理。所以者何。遍行随眠缘五部故。则见苦集所断随眠。亦应通是见集苦等所断。又见灭道所断随眠。缘非所断法。当言何所断。故彼非善立所断相应言。若见缘苦为境名为见苦。即是苦法苦类智忍。此二所断总说名为见苦所断。乃至见道所断亦然。数习名修。谓见迹者为得上义。于苦等智数数熏习。说名为修。此道所除名修所断。是名为善立所断相。色无色界五部各除嗔。余与欲同。故各三十一。由是一切正理论师。以六随眠约行部界门差别故立九十八。于此所辩九十八中。八十八见所断忍所害故。十随眠修所断智所害故。何缘于此约界不同建立随眠非约地异。如无欲色异界随眠于一事中俱随增理。初二静虑异地亦然。若谓地虽殊而有同对治。非欲色界对治有同。是则不应别立无色。以无色与色有同对治故。若修所断对治渐生。故色无色应别立者。诸地亦尔。何不别说。故应立二百八十四随眠。设许如斯亦无有过。且约界异立九十八。所以然者。由离界贪建立遍知沙门果故。谓立此二由断随眠。此断随眠约界非地。故不约地建立随眠。宿旧师言。佛于法性明了通达能说示他。定应善观四静虑地诸烦恼法性少相似虽有四地而合说一。于四无色合说亦然。经但说色贪无色贪等故。由此义故正理论师建立随眠约界非地。如何四地性少相似。有说。同是摄支地故。此释非理。所以者何。诸近分地中有生烦恼故。有说。同是遍照地摄故。有说。等是色贪类惑故。我说。此中少相似者。唯薄伽梵明了通达。要于永断第四静虑下下品惑方立遍知。下位不然。故知四地必有少分性类相似。非上地烦恼能缘缚下地。下三静虑得离系时。宁不别立断遍知体。定知一类烦恼未除。虽已离系与系相似。要同类惑永断无余。方得名为究竟离系。故唯约界建立随眠不约地立。于理为胜有余师说。如有为怨禁在囹圄。方便走出乃至未到。与怨城林田空闲等不相似处。虽越怨狱未大安隐。如是若断下三定贪。未到彼贪不相似处。虽越少分未大安隐。故唯约界建立随眠。有余师言。若越欲界便为已越。多趣多生大蕴处界无量苦法。若越色界。便为已越一取蕴全多处多界。若越无色界。便为已越一切生死摄蕴处界尽。离下三定所越不然故立随眠约界非地。然诸古昔正理论师。亦许随眠约地建立。故设如是假问答言。颇有异生于九十八随眠永断具成就耶。有。谓异生生在欲界得第三定未离彼贪。颇有异生得第三定。于向所说九十八种随眠永断不具成耶。有谓彼异生从欲界已殁。颇有住见道苦法智忍位。具成九十八随眠永断耶。有。谓彼异生得入正决定。颇有诸圣补特伽罗。于十智中唯成就四而得八十二随眠永断耶。有。谓具缚入正决定。于正住在苦类智时。若色界中四静虑地同一系缚如欲何过。此则善顺约断界贪建立遍知及沙门果。又顺本论说。遍行因为因能生自界染法。不尔经论理相违故。且引经文证四静虑非同一系。如契经言。彼作是思。我当安住寻伺寂静第二定中。虽作是思而不能入。复作是念。何因何缘。我于此中心不能入。作是念已。便自了知。以我犹于寻伺过患未识未达。未见未知于无寻伺静虑功德。未能修习多修习故。于第二定心不能入。广说乃至。我由住此数数发动寻伺俱行。诸想作意过患令起。今定应断。乃至广说。此中意显。如越欲界。如是当越静虑地等。下地所有诸想作意能障离染。及能退故。说为过患非自地者。故知色界非一系缚。又见过患能为厌因。厌为离因。离故解脱。若同一缚此应唐捐。又说寻等渐次息故。谓契经说。若瑜伽师入第二定寻伺便息。广说乃至。得入无边虚空处定色想便息。色界诸地若同一缚。诸瑜伽者。既无力能顿舍寻伺喜乐色想。以心怖怯极重担故。应毕竟无舍寻等者。又说离喜断乐言故。谓契经言。离喜断乐非同一缚。欲界诸处有毛端量未得离贪。可说名为全离欲系。唯除已断见所断法。虽永未离修所断贪而名离缚。非彼境故。色界诸地若同一缚。应有余缚。离断不成。此等名为经相违故。次引论文证四静虑非同一系。如本论言。谁成乐根。谓生遍净若生下地。若圣上生。谁于此不成。谓异生生上非下地法。生上地时。虽曰不成。而不由断于同一缚。欲界等中不见如斯定成等理。然于本论说遍行因为因能生自界染者。且就约界建立随眠辩遍行因。故作是说。亦有本说生自地染。此等名为论相违故。如何一系与理相违。且与随经理相违者。不应于二定说内等净支。未断寻伺俱诸烦恼浊故。又生第四静虑有情。亦应成染寻伺喜乐。然契经说寻等息言。又契经言。离喜断乐与随本论理相违者。谓本论中说。第二等味相应定。能与初等味相应定。唯作二缘。谓增上缘及等无间。色界诸地若同一缚。诸上地贪于下地爱。亦应能作因及所缘。又除受生时。应为等无间。又初定爱乃至应与第四定贪为等无间。又应从初味定无间。乃至第四净定现前。又除受生。应从第四净定无间初味定起。如是上下等无间缘。展转相生应立多难。又不应于第四业内。说四思能断白白异熟业。又不应说上近分定能断下惑。同一缚故。又得初定诸不还者。与得四定所断应同。是故定应许上下地如界业惑因果皆殊。由理不同。一系缚故。如前所说上界除嗔。以何因缘彼嗔非有。彼嗔随眠事非有故。谓于苦受有嗔随增。苦受彼无。故嗔非有。又嗔随眠干涩相故。谓此烦恼其相干涩犹如风病。彼有情类由奢摩他润滑相续。故彼无有干涩相嗔。又彼非嗔异熟因故。谓嗔必感非爱异熟。上二界无诸非爱事。外无毒刺茅灰等缘。内无热风癫痫等故。有说。彼无恼害事故。慈等善根所居处故。诸所摄受皆远离故。有余师说。嗔性躁急速可远离。故瑜伽师离欲贪时即能止息。如不居穴诸干涩垢。才加洗拭速可遣除。分别论师作如是说。无九十八所立随眠。经说随眠唯有七故。谓契经说。若欲永断七种随眠。汝等从今应于我所勤修梵行。由此故知正理论者唯依自计立九十八随眠。若离圣言依自计立。则应许有无量随眠。无量有情身中转故。今观具寿于圣教理不能审谛。如实观察于此所立理教极成。随眠数中能固非拨。且非彼所引七随眠经有证定数能非了义故谓余经言。若欲于色厌离欲灭永解脱者。应于我所勤修梵行。乃至于识说亦如是。此经唯说欲断随眠。应于我所勤修梵行。故知此经非了义说。又于余处亦有唯依欲离一界染。一随眠少分说。应于我所勤修梵行言如契经言。若于乐受欲永害贪随眠应于我所勤修梵行。又契经言。若于苦受欲永害嗔随眠。应于我所勤修梵行。岂以彼经所说极少便应非拨说七随眠。故知此经文同彼非了义。今应详辩。此契经中欲断七随眠应修梵行。意谓此经意为显随眠种类有殊故标七数。如契经说。法有二种。非离二种别有余法。岂由此不许说十八界耶。然意类中说余六界。故二十八互不相违。又如经中说盖有五。非无明体非盖所摄。经说无明能覆盖故。又即五盖余经说十。如契经说。苾刍当知。贪欲盖体差别有二。一内二外。乃至广说。又如经说。由四因故大地振动非无余因。又如经言。世有三法宜应开发。然有说四。又如经言。谛唯有一更无第二。然为梵志说谛有三及说四等。又如经说智有二种。谓尽无生非无余智。又如经说。心有二种谓善不善。非无无记。如是等类无量契经佛顺机宜说意各别。不能了达圣教理趣。唯计损坏他宗为德。此类岂能逮善说果。如世尊告邬陀夷言。若于如来异门所说。一切一切物一切一切种。不欲于中求解义者。汝应知彼于圣教中求斗诤住。乃至广说。又彼所说则应许有无量随眠。许亦何失。约依身别数无量故。然就体类分别随眠但成六种。此六约门异成十六。或十或二十八或三十六。或七十四或九十八。谓佛处处约界行部诸门差别显示随眠。正理论师随佛所说约界等异立九十八随眠。且诸随眠体类有六。谓贪嗔慢无明见疑。体类别故如前已辨。以薄伽梵于契经中说三界贪总名爱结故知体类唯六随眠。即六随眠约界差别世尊且说贪分二种。谓欲有贪随眠异故。由贪差别可类解余。为显随眠定不定界各成二故作如是说。然唯说贪界差别者。以多处说贪为首故。谓诸建立烦恼教中。处处说贪以为上首。如说九结三不善根五盖。上分三业道缚业缘集等无量。契经以贪随眠是生死本故。于诸处多说在初。既说最初分为二种。由此类显余亦应然。然不可说嗔亦约界分二。由欲有贪显余差别。此非如慢等说上亦有故。由如是教已显随眠。随其所应定散界别。佛余处复约有贪异门。显定界随眠亦有差别。谓世尊说上分结中色无色贪别立为二。由贪差别可类解余。为显随眠。于诸定界色无色异故作是说。然非上分结唯修所断故。则唯修所断有贪界。有别见所断惑。与修所断种类既同。必亦异故前总显示见修所断定散界别。今别显示唯修所断色无色殊。以无漏道如是断故。谓色无色见所断贪同一对治。修所断贪各别对治。故于定界见所断贪不显界别。修所断贪则显界别。如是别引二经证贪有三界殊。显余亦别。今复总引一经为证。如契经言。爱有三种。一欲爱。二色爱。三无色爱。由爱差别可类解余。为显随眠欲色无色界差别故作如是说。已举圣教证诸随眠界有差别理亦有异。谓有一类补特伽罗。于欲界法总得离系非色无色。彼由断此诸随眠故不欲界生。此所断随眠应知欲界系。色无色界类此应知。是故随眠由圣教理。界定有异数成十六。已显界别。行异云何。即六随眠见由行异。世尊处处说见有五。有身见等如前已列。故六随眠约行有异敷积成十如前已辨。行界合分成二十八。已显行别。部异云何。部谓随眠约别对治。谓有一类由见苦断。有由见集灭道亦然。有由后时随于一智数数修习增胜故断。若异此者立四谛见及后果智则为唐捐。然见道中于四圣谛必渐现观如后当辩。如是五部决定差别。佛于经中自正显示。如世尊言

  我昔与汝等　　涉生死长途
  由不能如实　　见四圣谛故
  若能见四谛　　永断诸有缚
  则生死都灭　　便无后诸有

此中若能见四谛者。显断见四谛所断四无明。复言永断诸有缚者。显断修道所断无明。岂不此中有缚说爱。如何引证五部无明。此中无明不说成故。谓诸世间无有一物爱结所系非无明者。但修所断许有爱结有无明结岂更须成非不愚痴有爱生故。复有别证显诸烦恼诸部差别。如契经言。于苦无智于集无智于灭无智于道无智。此中总收前际愚等。约四谛境立四无智。应知此处以无明声显一切随眠。如缘起中辩。故诸烦恼有部差别。然非无明有五部故。类显余惑皆有五部。以余烦恼有遮说故。谓世尊说永断见疑得预流果。由此为证遮见及疑是修所断。又经但说。断往恶趣。贪嗔痴慢得预流果。故预流果无见及疑。有修所断贪嗔痴慢。由此为证知六随眠。约部不同成二十八。部行合分成三十六。部界合分成七十四。约部行界总分随眠成九十八如前已辨。故对法者随佛圣教。推求正理分别随眠。立九十八不可倾动。然彼朽昧上座复言。虽经非无所引名相。而曾无处说此随眠。是见苦所断乃至修所断。今应征诘入见道时。已见苦谛未见集等。为有现起见所断惑。而言未拔彼随眠耶不尔何烦张戏论网。又如汝执烦恼相缘。不见所缘而得永断。如是烦恼虽缘三谛。见苦谛时何妨顿断。然有征难。若见苦时便能顿断见所断惑。见后三谛应无用者。理亦不然。彼于此位。不求见集等。不欲断随眠。然由先智展转引发。法尔次第见于集等。若不尔者。现观中间求见等心应为间杂。又曾无处佛说随眠有九十八。若有应说佛有说处。我则信受上座如是征诘随眠。巨细推寻未为切中。且先已辨。佛于经中说诸随眠见苦断等。谓契经说。不见四谛久涉生死。见便都灭。如何可说佛曾无处。说有随眠见苦断等。又说于苦等有四无智。如何四无智唯见苦断。故知定有五部随眠。又彼诘言。已见苦谛未见集等。为有现起见所断惑。而言未拔彼随眠者。此甚浮词。未见苦时见苦断惑亦不现起。应言已拔。则不应说见苦时断。若未见苦既不能拔见苦所断一切随眠。余亦应然。未见集等亦不能断彼所断得。能治彼得道未生故。或彼应辩二差别因。何故随眠等不现起。而一未拔余已拔耶。故彼所诘有言无理。又言。如汝烦恼相缘不见所缘而得永断。如是烦恼虽缘三谛。见苦谛时容顿断者非我宗许。诸烦恼相缘皆不见所缘而得永断。虽见灭道所断惑中。有漏缘随眠不见所缘断。而彼烦恼依灭道生。明无漏缘诸烦恼起。是彼烦恼所长养故。义说亦名迷于灭道。故是缘彼道力所灭。非缘三谛所有随眠。有苦等中计为乐等。亦无明托迷苦惑生。宁见苦时彼便顿断。故彼引此例彼不齐。又彼所言彼于此位。不求见集等。不欲断随眠。然由先智展转引发。法尔次第见集等者。此亦无理。彼于此位亦不求见苦不欲断随眠。然由先时暖等位智。展转引发法尔见苦。尔时应不断见苦断随眠。此既断随眠见余亦应尔。又非我等说现观时。起加行心求见求断。然我亦说现观位中。于见集等离别加行。但由先智展转引发法尔次第见于集等。即于见时有断有证。深成有用非类汝宗。若谓定无见余三谛所断烦恼。则见集等习彼境智应全无用。大师说此岂不唐捐。法尔自应能见集等。佛但应说习见苦智。又四圣谛其相不同。如何解余谛断迷余谛惑。故非见苦顿断随眠。又彼所说曾无有处。佛说随眠有九十八。若有应说佛有说处我则信者。此亦不然。我不见汝曹有信佛教相。以我先据圣教正理。建立随眠有九十八。汝等都无信受心故。又复汝等具吉祥伦。今时何从逮殊胜智。知曾无处佛说随眠。行部界殊有九十八。传闻增一阿笈摩中从一法增乃至百法。佛灭度后此土有情。内慧念命日日损减。外药草等味势熟德渐渐衰退功能鲜少。人多为恶事业牵缠。岂能具持如来圣教。故今增一阿笈摩中。唯从一增至十法在。于中犹有多分零落。况于过十能有受持。故知经中说随眠处。定有具说九十八文。如是传闻理必应尔。故佛于彼十应经中说甚深经渐当隐没乃至最后隐没无余又自古来诸圣造论。处处皆说有九十八随眠。兼有明文释有理趣。故知根本阿笈摩中。定有诚文标此名数。今更略引诸阿笈摩。证多契经今已隐没。如佛于彼婆拖梨经告婆拖梨。我于往昔为苾刍众。宣说少年贤良马法。尔时汝类于此法门少不实有。彼经今者已没不现。又佛于彼苦蕴经中。为释种大名说。我于往昔一时住在王舍大城游广胁山。见诸离系皆高举手。自苦求常。便告之言。乃至广说。彼经今者已没不现。又彼庆喜大空经中作如是言。我于往昔佛一时住释种大城。居彼所营大客馆内。时告我曰。汝阿难陀。我所住空汝欲知不。我便请问。佛为我说。我寻解佛所说义趣。彼经今者亦已隐没。又佛于彼邬陀夷经作如是言。我于往昔说有四受更代现前。彼经今时亦已隐没。又薄伽梵于他经中作如是言。我于往昔一时住在王舍大城游于山谷。时有众多出家外道。来至我所请问我义。乃至广说。彼经今者亦没不现。又佛于彼出爱王经告言。大王。我忆往昔曾作是说。非去来今有诸沙门婆罗门等。于一切法顿见顿知。能顿见知无有是处。彼经今者亦已隐没。又雨相外道于瞿博迦经作如是言。我忆往昔曾见释氏乔答摩尊。住那地迦城郡市迦林内。赞静虑等一切法门。彼经今时亦没不现。又彼庆喜于满经中言。我幼时见满慈子。为众广说甚深法门。彼经今时亦已隐没。又佛于彼蓝薄迦经作如是言。我于往昔一时曾告五苾刍言。我未出家恒乐观察居家迫迮多诸过患。应速厌离。乃至广说。彼经今者亦没不现。又彼圣者护国经中。彼言。大王。有四厌道。唯薄伽梵正见正知。虽诸如来应正等觉曾广宣说。而诸世间不能精勤修厌离行。当知定是竭爱驮娑。彼经今时亦已隐没。又给孤独于趣经中言。我曾于薄伽梵所亲闻亲受如是法门。若有有情施园林等。由此因力身坏命终。生于天中受妙快乐。广说乃至。法施为因。彼经今时亦没不现。又彼庆喜涅槃经中白无灭言。我曾佛所亲闻亲受如是法门。佛世尊依无动寂静第四静虑明眼涅槃。彼经今时亦已隐没。有如是等无量契经。皆于今时隐没不现。本所结集多分凋零。上座何容辄作是说。佛曾无处说九十八随眠。已辩随眠差别理趣。本所说义今次应辩。前说八十八见所断等。此见修所断为定尔耶。不尔。云何。颂曰

  忍所害随眠　　有顶唯见断
  余通见修断　　智所害唯修

论曰。于忍所害诸随眠中。有顶地摄唯见所断。唯类智忍方能断故。余八地摄通见修断。谓圣者断唯见非修。法类智忍如应断故。若异生断唯修非见。数习世俗智所断故。智所害诸随眠。一切地摄唯修所断。以诸圣者及诸异生。如其所应皆由数习无漏世俗智所断故。颂言余通见修断者。此言不说义准可知。云何可知。由前后故。谓前别说忍所害随眠有顶唯见断。后复总说智所害唯修。余通准知故。令义显故正说无失。有余师说。外道诸仙不能伏断见所断惑。如大分别诸业契经。说离欲贪诸外道类。有缘欲界邪见现行。及梵网经亦说彼类。有缘欲界诸见现行。谓于前际分别论者有执全常。有执一分。有执诸法无因生等。非色界惑缘欲界生。于欲界境已离贪故。定是欲界诸见未断。此说不然。见修所断皆能连续欲界生故。虽断一分余分亦应续自界生如预流等。然诸外道亦有乃至生有顶天。彼有欲界烦恼现行必不应理。又有何理彼诸外仙。由断修惑名离欲者。非由不断见所断惑亦说名为不离欲者。又先因释能安隐经。已显如斯所说理趣。故彼所引二种契经。与理相违成不了义。毗婆沙者释彼经言。彼起见时从离欲暂退。犹如天授暂退已还得。若唯二十八定见所断。何缘处处经说八十八耶。彼文遍依次第者说。此据尽理故不相违。又彼意明圣道用胜。又设先离下八地贪。要由见道起无漏得。得彼择灭故说无过。见修所断异相云何。若由唯见慧所断惑名见所断。若由见智慧所断惑名修所断。如是若由一品顿断。若由九品渐渐而断。若圣断已毕竟不退。若圣断已或退不退。若断容证四三二果。若断容证三二一果。若圣断时彼非择灭。必定应在择灭前证。若前或后或俱时证。如是等类异相众多

说一切有部顺正理论卷第四十六阿毗达磨顺正理论卷第四十七

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩随眠品第五之三

如前所辩六随眠中。由行有殊见分为五。名先已列。自体如何。颂曰

  我我所断常　　拨无劣谓胜
  非因道妄谓　　是五见自体

论曰。由因教力有诸愚夫。五取蕴中执我我所。此见名为萨迦耶见。有故名萨。聚谓迦耶。即是和合积聚为义。迦耶即萨名萨迦耶。即是实有非一为义。此见执我。然我实无。勿无所缘而起此见。故于见境立以有声。复恐因斯执有是我。为遮彼执复立身声。谓执我者于一相续。或多相续计有一我。此皆非身。身非一故。由如是见缘萨迦耶。故说名为萨迦耶见。即是唯缘五取蕴义。如契经说。苾刍当知世间沙门。婆罗门等诸有执我等。随观见一切。唯于五取蕴起。由此但于我我所见。世尊标别萨迦耶名。勿以我无许智缘无境。或智缘有执我体非无。不尔则应缘有漏见无不建立萨迦耶名。经主此中作如是释。坏故名萨。聚谓迦耶。即是无常和合蕴义。迦耶即萨名萨迦耶。此萨迦耶即五取蕴。为遮常一想故立此名。要此想为先方执我故。若尔何用标以萨声。但迦耶声足遮常故。则应但立迦耶见名。无法是常而可聚集。何用身上标以坏声。即于所执我我所事。执断执常名边执见。以妄执取断常边故。于实有体苦等谛中。起见拨无名为邪见。五种妄见皆颠倒转。并应名邪。而但拨无名邪见者。以过甚故。如说臭酥恶执恶等此唯损减余增益故。于劣谓胜名为见取。有漏名劣。圣所断故。执劣为胜总名见取。理实应立见等取名。略去等言但名见取。或见胜故但举见名。以见为初取余法故。于非因道谓因道见。一切总说名戒禁取。谓大自在时性。或余实非苦因妄起因执。道有二种。一增上生道。二决定胜道。投水火等种种邪行。非生天因妄执为因名第一道。唯受持戒禁性士夫智等。非解脱因妄执为因。名第二道。如前际等或戒禁胜。是故但立戒禁取名。应知五见自体如是。若于自在等非因计因。如是戒禁取迷于因义。此见何故非见集断。颂曰

  于大自在等　　非因妄执因
  从常我倒生　　故唯见苦断

论曰。于自在等非因计因。彼必不能观察深理。但于自在等诸蕴粗果义。妄谓是常一我作者。此为上首方执为因。是故此执见苦所断。谓执我者是有身见。于苦果义妄执为我。故现观苦我见即除。无我智生非于后位。若有身见见集等断。于相续中我见随故。则无我智应不得生。以见唯法时我见则灭故。无我智起我见已除。然有身见于自在等相续法中计一我已。次即于彼相续法上。起边执见计度为常。由此应知于自在等法。常我二执唯见苦所断。故有颂言

  未如实见苦　　便见彼为我
  若如实见苦　　则不见为我

由此已显灭边执见。以无我论宗断见是正见摄。执有我论者断见是边执见。故知二见俱见苦断。以无常等诸无漏行见苦谛时二见既灭。于自在等非因计因。随二见生亦俱时灭。故说计因执唯见苦所断。然于非道计为道中。若违见道强则见道所断。岂不如计自在等为因。执苦为因。唯许见苦断非见集断。如是亦应于非道计道执苦为道。唯许见苦断非见道断。此难不然以于苦谛见为无常等非彼对治故。谓若有执自在等为因。必先计为无始无终等故。此因执唯见苦断。以无常等想治常等想故非见苦谛。无常等时。能治非道计为道执。故彼道执非见苦断。由此亦遮见集所断。由见因等非彼治故。谓非于集见因等时能治非道计为道执。要于道谛见道等时。方能治彼非道道执故。彼道执应见道断。若尔如是非道道执。理必应通见集灭断。谓如邪见拨无真道。后即计此能得清净。此戒禁取许见道断。如是邪见拨无集灭。后亦计为能得清净。彼二戒禁取应见集灭断。此难不然。体不成故。谓戒禁取其体有二。一非因计因。二非道计道。若有计彼谤集邪见能得清净。岂不此见无断集用则不应生。以都无心信有因故。又苦与集无别物故。自在等蕴亦应被拨。若有计彼谤灭邪见能得清净。岂不此见无证灭用则不应生。如何拨无灭谛见后计灭方便非不唐捐。如是不成戒禁取体而言应有。故彼非难。如何非难。见道所断戒禁取体亦应不成。以于拨无道谛见后即计有道应不成故。谓缘道谛邪见或疑。若拨若疑无解脱道。如何即执此能得永清净。此戒禁取体非不成。以许有于谤道邪见执为能证永清净道。由彼计为如理解故。谓彼先以余解脱道蕴在心中。后执非谤真道邪见为如理觉。言如理者。彼谓拨疑真解脱道是不颠倒。以如理故执为净因。由此得成戒禁取体。彼心所蕴余解脱道非见道所断。戒禁取所缘以彼唯缘自部法故。道有多类于理无失。由此经主所作是言。若彼拨无真解脱道。妄执别有余清净因。是则执余能得清净非邪见等。此缘见道所断诸法理亦不成。彼全未详对法宗义。若尔见灭谛所断戒禁取。体亦应成。与道同故。谓有先以余解脱处蕴在心中后执谤真解脱邪见为如理觉。以如理故执为净因。如前应成戒禁取体。无如是理。总计解脱是常是寂执谤彼心为清净因。理不成故。如计涅槃体实非实。谓若希求解脱方便。彼应必定计有解脱。诸计解脱决定有者。必应许彼体是常寂。若不许尔不应希求。如正法中于涅槃体。虽有谓实谓非实异。而同许彼是常是寂故。于非拨俱见为过如是。若有以余解脱蕴在心中。彼必总计涅槃常寂。由此不执谤解脱见为如理解。故见灭所断戒禁取定无。又如天授。虽总许有常寂涅槃。而离八支别计五法为解脱道。外道所计理亦应然。是故有于八支圣道能谤邪见。谓如理觉无于谤灭。谓如理解以戒禁等自体行相与圣道殊。无谓涅槃常寂体相。有差别者。是故无灭与道同义。有余师言。有执于道谓非道邪见为道戒禁取。不言此是彼灭道故。设执于灭谓非灭邪见。言此是道戒禁取不成。谓执此为所拨灭道定不应理。适拨无故。若执此为余涅槃道。则应一体有二解能。见此是彼得方便故。又无见灭所断诸法。用余部法为所缘义。然彼外道必应计度余苦差别为解脱故。今应思择非道计道。谓执戒禁为解脱因。或执我见能证解脱。此为见苦断。为见道断耶。若执二俱见苦断者。则见道断毕竟应无。或应说别因等。非道计道何缘此二见苦所断。所余乃是见道断耶。若执二俱见道断者。应说何故见道断耶。非见道时能了彼境。或了彼自体。或断彼所缘。或应遍知建立理坏。谓若见道所断随眠。能缘见苦所断为境。谁遮遍知建立坏失。如现观位苦智已生集智未生。见苦所断犹为见集所断缘缚。虽已永断未立遍知。如是乃至灭智已生道智未生。见苦所断犹为见道所断缘缚。亦应虽断未立遍知。然非所许应辩理趣。我宗说二俱见苦断。如本论言有诸外道起如是见立如是论。若有士夫补特伽罗。受持牛戒鹿戒狗戒。便得清净解脱出离。永超众苦乐至超苦乐处。如是等类非因执因。一切应知是戒禁取见苦所断如彼广说。此复何因见苦所断。唯见苦所断缘牛戒等故。但计粗果为彼因故。由此己遮经主所难。迷苦谛故有太过失。缘有漏惑皆迷苦故。以非一切缘有漏惑皆以果苦为所缘故。如何得有太过失耶。非许二俱见苦所断。见道所断便毕竟无。非道计道有二类故。一缘戒禁等。二缘亲迷道。缘戒禁等违悟道信。力不如缘亲迷道者。缘戒禁等者。行相极粗故。不远随逐故。意乐不坚故。少设劬劳即便断灭。缘亲迷道与此相违。由此应知非道计道。诸戒禁取有二类别。一见苦断。二见道断。如前所说常我倒生。为但有斯二种颠倒。不尔。颠倒总有四种。一于无常执常颠倒。二于诸苦执乐颠倒。三于不净执净颠倒。四于无我执我颠倒。如是四倒其体云何。颂曰

  四颠倒自体　　谓从于三见
  唯倒推增故　　想心随见力

论曰。从于三见立四倒体。谓边见中唯取常见以为常倒。诸见取中取计乐净为乐净倒。有身见中唯取我见以为我倒。如是所说是一师宗。然毗婆沙决定义者。约部分别十二见中。唯二见半是颠倒体。谓有身见苦见取全。边执见中取计常分。断常二见行相互违。故可说言二体各别。诸计我论者。即执我于彼有自在力是我所见。此即我见由二门转。岂不诸烦恼皆颠倒转。故应皆是倒非唯四种。不尔建立倒相异故。何谓倒相。谓具三因。何谓三因。一向倒故。推度性故。妄增益故。增声亦显体增胜故。非余烦恼具此三因。谓戒禁取非一向倒所计。容有能离欲染等故。少分别时得清净故。断见邪见非妄增益。于坏事门此二转故。余部见取非增胜故。所余烦恼非推度故。由此颠倒唯四非余。岂不经中说诸颠倒总有十二。如契经言。于无常计常有想心见倒。于苦不净无我亦然。不尔想心非推度故。随见倒力亦立倒名。与见相应。行相同故。然非受等亦如想心。可立倒名。有别因故。谓于无常等起常等见时。必由境中取常等相。能取相者是想非余。故立倒名非于受等。又治倒慧亦立想名。谓无常等行中。说为无常等想。由慧与想近相资故。相从立名。受等不尔。由所依力有倒推增。取境相成故心名倒。如契经说。心引世间于惑瀑流处处漂溺。毗婆沙说。唯想与心可立倒名。世极成故。谓心想倒世间极成。受等不然。故经不说。由此心想随见倒力立颠倒名非于受等。上座于此言以何缘。颠倒唯三不增不减。唯有尔所应成倒故。谓此三倒。想倒摄想。心倒摄识。见倒摄行。不可说受亦倒所摄。触为因生如应领故。岂不行蕴更有所余作意等法彼何非倒。不尔但由彼颠倒故。令心想见成颠倒体。故契经言。所有无量恶不善法。一切皆由非理作意为根本起。广说乃至。一切皆是作意所生触为其集。由此证知想心见倒。皆非理作意无明触所生。由彼倒故此成倒体。今观彼说前后相违。由是定知非契经义。若想心见由从非理作意等生。彼颠倒故此成倒体。受亦非理作意等生何缘非倒。若受从倒作意等生非颠倒者。想心见三应非倒体。无别因故。又言不可受亦倒。摄触为因生如应领故。岂不想倒亦应不成。触为因生如应想故。由说想等倒无明触所生。岂不触为因如应领。故弥能证受体是颠倒摄。受亦无明触所生故。由此彼说唯有尔所应成倒故。倒唯有三不增减者。言成无义。又若非理作意力故。想等成倒非理作意。亦应是倒然曾不说。故彼所言从自执起。或虽许彼体是颠倒。而不说为颠倒体者。则应想等亦不说倒。是则违害经说倒名。若谓如仁有别因故。虽由见力诸心心所皆有倒义。而经但说想心倒名。非余受等。我宗亦尔。即由此因。是故定无想等非倒。或余是倒违经过失。此亦非理。不相似故。谓如我宗由见势力。虽心心所皆有倒义。由别因故唯于想心立颠倒名。非于受等。然所由见正立倒名。如是汝宗由作意力。令心心所皆有倒义。所由作意应立倒名。又如我宗想等体非倒。但由见力假立以倒名。真实倒名目所由见。汝宗应亦尔。由作意力。想等实非倒假立倒名。则真实倒名目所由作意。不应由非倒诸法势力。令余非倒法得倒名故。又何不许由想势力。能令作意成颠倒体。要由妄想取相势力。方起俱生非理作意。故契经说。由取相势力能令贪等恶不善法生。又契经言。由想乱倒故心焦热。不言心热由于非理作意故生。又理应由胜倒法力。令想心体亦名颠倒理非作意倒胜想等。如何但言由作意力想等成倒非想等力。能令作意成颠倒耶。故彼所言唯凭自执。又经亦说欲为法本。或说烦恼无明为根。如何不言由彼势力。能令想等亦成颠倒。但说颠倒由作意成。是故应知依对法理。立颠倒体最为殊胜。如是诸倒何所断耶。正理论者言。唯见苦所断。以常颠倒等唯于苦转故。了无常等觉唯缘苦生。故不应后见集灭道时。方舍常乐我净见故。若尔便违经论正理。且违经者。谓契经言。若有多闻诸圣弟子。于苦圣谛如实见知。如是于集灭道圣谛如实见知。当于尔时彼圣弟子。无常计常想心见倒皆已永断。乃至广说。若诸颠倒唯见苦断。经不应说。如实见知集等谛时皆已永断。又契经说。若闻如来说苦集灭道四圣谛法已。便能永断常等四倒。非诸颠倒唯见苦断。佛为断彼可说余三见集等觉非彼治故。又庆喜告辩自在言

  由有想乱倒　　故汝心焦热
  远离彼想已　　贪息心便净

言违论者。如本论言。此四颠倒诸预流者。几种已断几未断耶。应作是言。一切已断。若四颠倒唯见苦断。则随信法行亦有已断者。何故唯说预流已断。违正理者。未离欲圣若离乐净想。如何起欲贪。我宗于三皆无违害。且我今见初经义者。若圣弟子于四圣谛得现观时。无始时来所集四倒皆已永断。不可由此便证四倒。一一皆由见四谛断。前已成立身边二见。唯见苦断常我倒体。即是身边二见所摄。如何见集等断常我倒耶。然此经中于具见谛说已永断。何所相违。于第二经无违害者。非薄伽梵说四谛法唯为断。斯四种颠倒总为毕竟静息众苦。然有闻已随对治力永断四倒。何所相违。理实应然。故彼经说

  佛说此法时　　为永寂众苦
  有闻已知实　　无常乐我净

非四颠倒总摄众苦。故知彼经义如我释。又彼经说。若诸有情为此四种想心见倒乱倒其心。彼心便于彼彼迷乱。乃至广说。此中可说由想见倒乱倒其心。心相应故。如何心倒能乱倒心。是故彼经应观密意。不可如说执为定依所引伽他。于对法理亦无违害。所以者何。非我等言欲贪映蔽想无乱倒。但作是言。非诸乱倒皆名颠倒。所以然者。见倒俱行乱倒想心方名倒故。若诸乱倒皆成倒者。则诸烦恼皆应成倒。诸阿罗汉游衢路时。想乱倒力心便迷谬。或想乱倒见绳谓蛇。故乱倒中少分立倒。以要最胜方立倒名。最胜因缘如先已辩。故有染想学位现行。非得倒名。何所违害。又经不说彼辩自在。定居学位为证不成。论说预流已断倒者。为除疑故作如是言。勿诸世间见预流者。以花严体用香熏衣。贮畜珍财耽淫嗜味便疑颠倒仍未全除。无知覆心故为此事。为除如是世间所疑。故说预流诸倒已断。或预流者已断无别。随信法行有断未断。显定已断故说预流。正理无违如伽他释。或太过失。谓何不言诸圣犹应我想现起。非于女等及于自身离有情想心有起欲贪故。不应许圣有我想心。于唯有法智已生故。由此颠倒唯见苦断。分别论者作如是言。常我各三乐净见倒。如是八倒唯见所断。四通见修断。谓乐净想心。破此如前释伽陀理。故彼所说唯凭妄计。彼上座言。诸预流者。见倒已全断。心想倒有余。非于无常乐我净想不忘失者烦恼可行。故安隐经作如是说。圣者安隐作如是言。我色等中不随执我。然于如是五取蕴中。有我慢爱随眠未断。故知圣者有我想心。常乐净三准亦定有。上座此说违自意趣。违经违理不可信依。言彼说违自意趣者。且彼自释倒经起因言。为有愚流转还灭次第理者。欲令于彼解无颠倒。故说此经非善遍知四圣谛理。于诸生死已作分齐。诸烦恼障极少为余。将得涅槃如临至掌。具如是德补特伽罗。可有愚于流转还灭次第理趣。起颠倒者圣智照明在身中故。又彼自辩诸倒体中。问言见倒何见为体。即自答言。且苦谓乐。不净谓净。邪见为体复自问言。岂不邪见拨无施与。乃至广说。还自答言。若于生死计乐计净。彼定拨无真阿罗汉正至正行。岂不此言便显圣者。既于生死有乐净想。彼定应有拨阿罗汉正至正行邪想现行。若谓圣者邪见断故无邪想者。则应圣者见倒断故无颠倒想。言违经者。谓契经说。想心见倒皆见谛断。二经证此具引如前。若谓此八想心颠倒。于修位中终由如实见知圣谛方得永断。离此无余永断方便。故此所说不违经者。岂不见倒应同彼执。同想心说见谛断故。若谓诸见有余经中遮修所断故。但应说想心二倒通修断者。余经合说心想见三有四倒故。何缘不许离见倒时心想非倒。若谓经说有学圣者有想乱倒。此前已释。前释者何。谓非乱倒皆名颠倒或非彼经说辩自在定居学位。言违理者。且有学圣为求乐故受用境时。境中虽无谛理乐净。而有事乐净能引想心。故乐净想心圣容现起都无。常我诸行聚中常我想心何容现起。以乐净倒托有事生托无事生。常我二倒由有乐受是胜义摄。此义决定如后当辩。有漏法中有少分净。契经说有三净业故。净解脱境。经所说故。乐净实有世极成故。诸行聚中若事若理。都无常我实体可得。故未见谛者。于诸行中妄起执常我想心见倒。亦托少分事乐净中。一向执为理实乐净故。有执乐净想心见倒成。已见谛者。于行聚中以毕竟无常我事故。亦定不起常我想心。由此应知圣者相续。常我二倒决定非有。乐净想心托有事故。于圣相续亦得现行。有得乱倒名无。名颠倒者。倒唯迷理分别起故。然彼所引安隐契经不能证圣有常我想心倒。不成倒义如前已辩。如是详察上座所言。于圣教理无不违害。故彼所说不可信依。辩见随眠差别相已。为余亦有差别相耶。亦有。云何。颂曰

  慢七九从三　　皆通见修断
  圣如杀缠等　　有修断不行

论曰。有愚痴者。先于有事非有事中。校量自他心生高举。说名为慢。由行转异分为七种。一慢二过慢。三慢过慢。四我慢。五增上慢。六卑慢。七邪慢。于他劣等族朋等中。谓己胜等高举名慢。岂不此二俱于境中如实而转不应成慢。方劣言胜。方等言等。称量而知。何失名慢。于可爱事心生爱染如实而转。如何成贪。此既耽求诸可意事。无有颠倒应非烦恼。然由此起能染恼心。既许成贪是烦恼性。如是虽实胜劣处生。而能令心高举染恼。名慢烦恼。于理何失。故先略述慢。总相中说讫。有非有二俱容起慢。如于处非处愤恚俱名嗔。于他等胜族朋等中。谓己胜等。名为过慢。于他殊胜族朋等中。谓己胜彼。名慢过慢。于五取蕴执我我所心便高举。名为我慢。由此证知于未缺减有身见位。可言有我想心二倒。非缺减时于未证得地道断等殊胜得中谓已证得。名增上慢。未得得言。其义何别。前得后得义无异故。此言为显未得德得。得复有得宗所许故。诸有在家或出家者。于他工巧尸罗等德多分胜中。谓己少劣心生高举。名为卑慢。此中于己心高举者。于他多胜谓己少劣。有增己故亦说为高。有余师言。于己功力不信谓劣。名为卑慢。如是谓劣高举不成。是故应知前说为胜。于无德中谓己有德。名为邪慢。言无德者。谓诸恶行。违功德故立无德名。犹如不善彼于成此无德法中。谓己有斯殊胜功德。恃恶高举。故名邪慢。若谓无德者。是遮有德言。于实无德中谓有名邪慢。彼辩增上邪慢别中。说无种子名增上慢。有种子者名为邪慢。或全增益名增上慢。少分增益名为邪慢如是差别理应不成。是故应知前说为胜。有说。唯除我我所见。以余邪见为先。所生令心高举。名为邪慢。有余师说。恃全实事高举名慢。恃少实事心生高举。名为过慢。恃无实事心生高举。名慢过慢。于五取蕴我爱为先。恃我高举。名为我慢。于证少德谓已证多。心生高举。名增上慢。摄受少事心谓为足。恃生高举。名为卑慢。实鄙恶类。自谓有德。心生高举。名为邪慢。然本论说慢类有九。类是品类义。即慢之差别。九类者何。一我胜慢类。二我等慢类。三我劣慢类。四有胜我慢类。五有等我慢类。六有劣我慢类。七无胜我慢类。八无等我慢类。九无劣我慢类。此九皆依有身。见起我胜者是过慢类。我等者是慢类。我劣者是卑慢类。有胜我者是卑慢类。有等我者是慢类有劣我者是过慢类。无胜我者是慢类。无等我者是过慢类。无劣我者是卑慢类。是故此九从三慢出。谓慢过慢及卑慢。三行次有殊成三三类。无劣我慢类高举如何成。谓有如斯于自所乐胜有情聚。虽于己身知极下劣。而自尊重如呈瑞者。或旃荼罗。彼虽自知世所共恶。然于呈瑞执所作时。尊重自身故成高举。如是七慢何所断耶。有余师言。我慢邪慢唯见所断。余通见修。理实应言七皆通二。故能安隐作如是言。我色等中不随执我。然于如是五取蕴中。有我慢爱随眠未断。谓修所断圣未断时。定可现行此不决定。谓有已断而可现行。如已离欲贪信苦眠眼等。有虽未断而定不行。如未离欲贪圣者杀缠等。言杀缠者。谓由此缠发起故思断众生命。等者等取盗淫。诳缠无有爱全。有爱一分。无有名何法。谓三界无常。于此贪求名无有爱。由此已简无漏无常。彼定非贪安足处故。有爱一分。谓愿当为蔼罗筏拏大龙王等。等言为显阿素洛王北俱卢洲无想天等。此杀缠等虽修所断。而诸圣者定不现行。此修断不行言成无用。以当说圣有而不起故。若圣身中有容现起。遮言不起是有用言。非圣身中有见所断。容可现起而更须遮。既有而遮已知修断。及不行义何烦预说。若谓前说慢通见修。勿杀等缠亦通见断故说修断。此亦不然。说杀缠等言已简见断故。又观后释义足可知。如慢类等见所增故。由是此言但应在法。又释中言。此诸缠爱。一切皆缘修所断故。唯修断者此非定因。见所断亦缘修所断法故。若作是释。此含唯言是则此因能为定证。岂不见所断亦有无常无有爱。何缘唯修所断。实亦见断。且随经说。谓契经中说有三爱。欲爱有爱无有爱三。于此经中说无有爱取缘众同分无常为境者。贪求异熟相续断故。如契经言。一类苦逼作如是念。愿我死后断坏无有无病乐哉。今且据斯说唯修断非见所断。无无有爱。如前已说。慢类我慢有修所断。圣者犹有不说自成。此等何缘圣者犹有而不现起。颂曰

  慢类等我慢　　恶作中不善
  圣有而不起　　见疑所增故

论曰。等言为显杀等诸缠。无有爱全有爱一分。以诸圣者善修空故。善知业果相属理故。此慢类等我慢恶悔。圣虽未断而定不行。又此见疑亲所增故。见疑已断故不复行。谓慢类我慢有身见所增。杀生等缠邪见所增。诸无有爱断见所增。有爱一分常见所增。不善恶作是疑所增。故圣身中虽有未断。而由背折皆定不行

说一切有部顺正理论卷第四十七阿毗达磨顺正理论卷第四十八

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩随眠品第五之四

九十八随眠中几是遍行。几非遍行颂曰

  见苦集所断　　诸见疑相应
  及不共无明　　遍行自界地
  于中除二见　　余九能上缘
  除得余随行　　亦是遍行摄

论曰。唯见苦集所断随眠。力能遍行。然非一切。谓唯诸见疑彼相应不共无明非余贪等。见有七见。疑有二疑。相应无明即摄属彼。不共有二。故成十一。如是十一。于诸界地中各能遍行。自界地五部。谓自界地五部法中。遍缘随眠为因生染。是故唯此立遍行名。且约界说言三十三是遍然有师说。三十三中二十七是遍。余六应分别。彼师于此唐设劬劳。以相应无明如所相应惑。遍非遍理不说成故。由是此中标别数者取自力起。不共无明非此无明。见苦集所断有非是遍。是故但言三十三是遍。此说为善。依何义立此不共名。如是说者。相杂名共。以非共故立不共名即是彼此各别为义。如契经说。不共佛僧。此显佛僧二宝各别。以不共行故名不共无明。非余随眠相杂行故。或普名共。即是遍义。由非共故立不共名。此不共名显非共有。即是不遍诸烦恼义。与诸随眠不相应故。有余师说。与余烦恼不相关涉。名为不共。即是惛重无动摇义。相应无明与余烦恼共相应故。相有警动。不共无明由自力起。于诸事业皆不欲为惛重无动摇。如珊若娑病。是故名曰不共无明。何故唯于见苦集断诸随眠内有遍行耶。唯此普缘诸有漏法。意乐无别势力坚牢。故能为因遍生五部见灭见道所断随眠。唯有能缘有漏一分。所缘有别势不坚牢。不能为因遍生五部。故唯前二部有遍行随眠。何缘得知修断染法。以见所断遍行为因。如何不知世间现见有我见者。由我见力外境贪增。我见若无。便于外境贪微薄故。又由至教。如说。云何见断为因法。谓诸染污法。又说。云何无记为因法。谓不善法无记有为法。由此等证知彼为因。若遍行因生修断染。已断未断有何差别。彼已断时修所断染。亦得现起如未断故。又若一切修所断染。皆用见断为遍行因。因已断时修所断染既得现起。何故圣者慢类等法必不现行。且初难言。已断未断何差别者。甚有差别。谓未断位。于自身中能为遍因取果与果。后已断位。虽能为因不能取果。唯除先时已取果者。今有与义。又已断位。虽能为因不障圣道。于自相续不复能引自得令生。与此相违是未断位。何故圣者慢类等法。必不行者前已说因。修断既同宁有起不起。此难非理。因有近远故。谓修断染有以见疑为邻近因连续而起见疑。若断彼必不行。与彼相违容有起义。又非择灭得未得殊。故有现行不现行者。由此所说二过俱无。此遍行名为目何义。但于一切有漏法中。能周遍缘是遍行义。谓上所说三十三随眠。自界地中各能缘五部。虽有于受偏起我执。而此非唯缘自身受。以兼缘此种类法故。若起邪见。谓所修行妙行恶行皆空无果。此亦非唯缘自身业。总拨一切业生果能。由此准知余遍缘义。贪等烦恼唯托见闻。所思量事方得现起。以于妻等起贪等时缘显非形缘形非显。故知贪等皆非遍缘。且据随眠能遍缘义释遍行义。故作是说。若据随眠同聚诸法所有遍义。释遍行名。则诸随眠具三遍义。谓于五部遍缘随眠。及能为因遍生染法。彼相应法具二遍义。谓于三义唯阙随眠。彼俱有法具一遍义。谓但为因遍生染法。故前所释无缺减过。虽尔无一能遍随眠。于自体等不随眠故。则应无有遍行随眠。此难不然。以于五部无碍转故。立遍行名。非顿随眠诸有漏故。又于自体俱有法中。由于去来彼种类法。有随眠故遍义亦成。何因无明修所断者。唯名自相惑非见所断耶。由此无明所缘少故。见所断法非所缘故。又此但随贪等转故。贪等唯是自相惑故。见断无明有是不共。彼唯行在异生身中。闻思位中修观行者。以苦等行观诸行时。由彼无明损翳慧眼。令起多品诸颠倒见。故应举喻显彼过失。如日初没。有一丈夫。遥见怨家便作是念。彼有怨家我不应往。正思念已。至黄昏时。夜前行闇损翳其目。不能记忆怨相状故。便于怨所起是杌觉或谓非怨或谓亲友。如是应了不共无明。修断无明则不如是。但由因力或境逼故。以贪嗔等为上首生。能遮障爱味过患出离觉。于所逼境唯不能知。非于诸境中皆无欲行转。如珊若娑病惛重无动摇故。此无明唯自相惑若遍行惑能缘五部萨迦耶见。缘见灭道所断法生为见何断。若见苦断贪等亦应缘五部故唯见苦断又如见取缘见灭道所断。能缘无漏境者。以彼亲迷迷灭道故。亦是见灭见道所断。如是身见亦是亲迷迷灭道故应见彼断。或应辩此差别因缘。又如见灭见道断见取。要由遍知境所缘故断。如是身见例亦。应然。复如身见遍知所缘断。如是见取例亦应然。如是二途宗皆不许。是故所立于理不然。理必应然。义有别故。且初所例贪等亦应缘五部故唯见苦断。或且举此反例身见。理亦应通五部摄者。此例非理。贪等亦应一念顿缘五部法故。谓有身见一刹那中顿缘五部。受乃至识为我我所。理不应言一念身见体分五部。贪等皆是自相惑故。尚无一念顿缘二部。况能缘五。故例不成。后所例言。如见灭道所断。见取身见亦然。俱是亲迷迷灭道故。应亦见灭见道断者。亦不应理萨迦耶见不能称誉。谤彼见故。又所缘境无分限故。非有身见要先称誉谤灭道见。方计为我。亦非于境作分限缘。见取必由称誉能谤灭道邪见。方计第一于所缘境作分限缘。义既有殊不可为例。然有身。见见苦谛时。遍知所缘即全永断。非见取者此有别因所缘行解等不等故。谓如三界见苦所断诸蕴无我。乃至修断诸蕴无我其相亦然。故见苦时无我见起。缘所见苦我见皆除。计胜不然。有于少法观余少法计为胜故。由此身见随行见取。虽缘见灭道所断法生粗。故如身见唯见苦断。如缘修道所断法生。谤灭道见随行见取。虽亦缘彼所断法生。而彼望前极微细故。乐净行解所不摄故。亲执不欲灭道无明。所引邪见为最胜故。虽见苦位遍知所缘。而要所缘永断方断。是故见取非如身见唯见苦时即全永断。故所说断差别理成。或缘见灭见道所断见取各三。谓见苦集及见灭道随一断故。若于见灭见道所断。执果分胜是见苦断。执因分胜是见集断。若唯执彼为真实觉。不偏执彼因分果分。随缘何生与彼俱断。故见取断非如身见。虽尔应说见苦见集所断见取差别。云何非由所缘行相有别。俱缘一切有漏为境。并执第一行相转故。有作是言。若缘见苦见集所断。见为最胜如其次第。见苦集断彼越所宗许遍行故。若必尔者应许见苦所断。见取有见集断。见集所断有见苦断。然不许尔故不可依。今详此二有差别者。若由常乐我净等见力近引生。于诸行中执为最胜是见苦断。若由拨无后有因见力近引生。于诸行中执为最胜是见集断。有余师言。所有见取若异熟果为门而入。于诸行中执为最胜是见苦断。若业烦恼为门而入。于诸行中执为最胜是见集断若有身见戒取见取。顿缘五部名为遍行。是则遍行非唯尔所。以于是处有我见行。是处必应起我爱慢。若于是处净胜见行。是处必应希求高举。是则爱慢应亦遍行。此难不然。虽见力起而此二种分限缘故。谓虽是处我见等行。是处必应起我爱慢而不可说爱慢顿缘。先已说为自相惑故。是故遍行唯此十一。余非准此不说自成。前说十一于诸界地中。各能遍行自界地五部为有他界他地遍行。简彼故言自界自地。亦有他界他地遍行。谓十一中除身边见。所余九种亦能上缘。上言正明上界上地。兼显无有缘下随眠。缘下则应遍知界坏。上境胜故。缘无此失。且欲见苦所断邪见。谤色无色苦果为无。见取于中执为最胜。戒取于彼非因计因疑怀犹豫。无明不了见集所断。如应当说色缘无色。倒此应知准界应思约地分别。然诸界地决定异者。欲界乃至第四静虑。有缘上界上地遍行。三无色中阙缘上界。有顶一地二种俱无。虽有随眠通缘自上。然理无有自上顿缘。以自地中诸境界事。是所缘境亦所随眠。若上地中诸境界事。是所缘境非所随眠。不可一念烦恼缘境。有随眠处有不随眠。勿于相应亦有尔故。于上界地必顿缘耶。非必顿缘或别或总。故本论说。有诸随眠是欲界系缘色界系。有诸随眠是欲界系缘无色界系。有诸随眠是欲界系缘色无色界系。有诸随眠是色界系缘无色界系。约地分别准界应知。身边见何缘不缘上界地。缘他界地执我我所。及计断常理不成故。谓非于此界此地中。生他界地蕴中有计为我。执有二我理不成故。执我不成故执我所不成。所执必依我执起故。边见随从有身见生。故亦无容缘他界地。由此唯九缘上理成。有余师言。身边二见爱力起故取有执受为己有故。以现见法为境界故必不上缘。生欲界中若缘大梵。起有情常见为何见摄耶。理实应言。此二非见。是身边见所引邪智现见蕴中执我常已。于不现见比谓如斯故。有先观有执受蕴为无我已。后亦于彼非执受蕴无我智生。知一一身皆无有我。若尔身见应非遍行。唯于执受蕴方计为我故。非他相续自所执受。不尔亦取种类法故。谓于受中计为我者。不言我受是我非余。但作是思。此受是我。非大梵受有同此失。无惑顿缘自上地故。身见唯自界自地遍行故。经主于此作是责言。何缘所余缘彼是见。此亦缘彼而非见耶。以欲界生不作是执我是大梵。亦不执言梵是我所。故非身见。身见无故边见亦无。边见必随身见起故。非有余见作此行相。故是身见所引邪智。诸作是说。生欲界中缘梵计常。此非边见于劣计胜是见取摄。彼说非理。违本论故。如本论说。无常见常是边见中常边见摄。上座应计此我常见。如乐净见邪见所摄。以上座执于四倒中乐净二倒邪见为体。彼自释言。若于生死计乐计净。彼定拨无真阿罗汉正至正行。是故于苦不净境中计乐计净。是邪见摄。今详彼说理亦应许。若于生死计我计常。彼定拨无真阿罗汉。无差别因故应亦邪见摄。然彼所说理定不然。于事增减是别见故。谓诸邪见实有事中。定拨为无。宁执乐净。乐净二见实无事中定执为有。宁是邪见。是故上座诸法相中背理凶言不应收采。傍论已了。应申正论。为遍行体唯是随眠。不尔。云何。并随行法谓上所说遍行随眠。并彼随行受等生等。皆遍行摄。同一果故。然随行中唯除诸得。得与所得非一果故。由是遍行因与随眠相对具成四句差别。九十八随眠中。几缘有漏。几缘无漏。颂曰

  见灭道所断　　邪见疑相应
  及不共无明　　六能缘无漏
  于中缘灭者　　唯缘自地灭
  缘道六九地　　由别治相因
  贪嗔慢二取　　并非无漏缘
  应离境非怨　　静净胜性故

论曰。唯见灭道所断邪见疑。彼相应不共无明各三成六。能缘无漏。谓见灭道断。二邪见二疑相应无明。即摄属彼不共有二故合成六。如是六种诸界地中。能缘灭道名缘无漏。余缘有漏不说自成。有说。无明无所缘故非缘无漏。何缘知此定无所缘。无智性故。非无智性可说缘境。譬如世间非智外闇。谓如外闇有损见能。不可说言彼能取境。无智亦尔。障解境智。不可说言与智俱转。是故知此定无所缘。定有所缘心相应故。且已成立无明实有。若无明体非心相应。譬如外闇障心心所。令于境中不能取者。则心心所应永不生。应相续中恒现有故。如无心定无想异熟。不应说彼名迷所缘。非外黑闇障心心所。令于诸境皆不得生。色处所摄眼识境故。但于余境有损见能。无明亦然。但于苦等四圣谛理障真见生。非于境中障我等见。既不能障一切见生。故知无明有所缘境。又如眠体应有所缘。如眠但能损覆智用。非不与智于境俱转。以眠亦有取境用故。然于所缘令心昧钝。无明亦尔。非无所缘。何故无缘见灭道断。见灭道断不共无明。见苦集时彼皆断故。谓如见取于诸有漏法。由因果门乐净行等转。如是见取虽亦能缘见灭道断。而真实见苦集谛时一切永断。迷因果理对治生故。如是能障八行觉生。不共无明苦集现观对治生故一切皆断。除此更无缘见所断诸法为境。不共无明岂不此应如彼见取。非全如彼行相别故。谓于有漏见取生时。行相众多迷谬而转。修观行者见苦集时于见灭道所断诸法见为苦等。虽已能违计乐净等迷因果行。而于见灭见道所断。见为功德余最胜行。所有见取犹未能违。是故虽于苦集二谛已得现观。犹有见灭见道所断见取未除。不共无明无别行相。唯有惛重不欲行转。于四圣谛各别亲迷。除此更无余别行相。缘见所断非迷苦集。何须固访不共无明。有别行相缘见灭道断。令见灭道断同见取耶。何缘此中缘见所断。所起一切不共无明。见苦集时悉皆永断。非缘修断不共无明。见苦集时一切永断。不应于此重责其缘。许不共无明有修所断者。彼必应许不共无明。有唯能缘修所断法。非迷苦集二圣谛理。说此无明缘见断法。及无漏法理不成故。又必应许圣思法时离染恚高有染障故。谓彼修习正法观时。应有惛迷不欲行转。如眠惛昧障蔽其心。不共无明是修所断。故知圣者集智已生。犹有唯缘修所断法障思正法。不共无明见苦集时此何不断。此无明是智所害故。诸忍非彼对治道故。不迷苦集二谛理故。不缘亲迷谛理法故。谤灭邪见为见灭耶。不见灭耶。若见灭者。如何见灭谤言无灭。若不见灭者。如何无漏缘。又如何言此物非有应言见灭。但寻教见即谤如是所说灭无。岂不此见亲能缘灭。如何即拨此灭为无。如有目者于多杌处。遥见人立拨为非人。虽亲缘人而非不谤。故有见灭而拨为无。然非所有谤灭道慧。皆是见灭见道所断谓若有慧非审察生。闻说灭道便生诽谤。唯缘名故非见彼断。若慧于境因审寻伺推度而生。决定拨无。所说灭道方见彼断。如为离系说如是言。若能知风为水所镇。即知寻伺所引诸见生起可息。乃至广说。此无漏缘于一一地。各缘几地灭道为境。诸缘灭者缘自地灭。谓欲界系缘灭随眠。唯缘欲界诸行择灭。乃至有顶缘灭随眠。唯缘有顶诸行择灭。诸缘道者缘六九地。谓欲界系缘道随眠。唯缘六地法智品道。若治欲界若能治余。诸法智品皆能缘故。色无色界八地所有缘道随眠。一一唯能通缘九地类智品道。若治自地若能治余。诸类智品皆能缘故。何缘谤苦谤集邪见。欲界系者能缘九地。初静虑者能缘八地。乃至有顶唯缘彼地。谤灭邪见于九地中。一一唯能缘自地灭此有所以。所以者何。谓若有法此地爱所润。此地身见执为我我所。彼诸法灭还为此地见灭所断。邪见所缘此所以非未遣疑。故谓何理故邪见缘灭。非如缘苦集通缘自他地。或诸邪见缘苦集者。何不如缘灭但缘于自地。故上所以未遣此疑。非未遣疑但不了意。然上意显若诸行中。此地我爱我见转者。彼由耽着此地行故。若闻说有此地行灭。便起此地邪见拨无。非上行中有下耽着。宁下邪见拨彼灭无。虽界地相望因果隔绝。而九地苦集展转相牵。又生依立因更互为因故。一地邪见容有缘多灭。无相牵及相因理故。谤灭邪见唯缘自地灭。若尔善智缘灭谛时。应分齐缘如谤灭见。不应一念智顿缘多地灭。此二所缘理无别故。且有善智缘一地灭。然有顿缘多地灭者。由于前理与邪见异。谓前已说若诸行中。有耽著者闻此行灭。便起此地邪见拨无。非上行中有下耽着。宁下邪见拨彼灭无。善智不由耽着引起。缘多地灭于理何违。然善智生观诸行过。审观过已希求彼灭。故一地智缘多地境。且如暖等以总行相。观诸行过欣求彼灭。不应执彼同于邪见。于所缘境有分限缘。迷悟理殊。不应为例。谓修观者观自地中过失所恼。欣自地灭。由此亦能观于他地。诸行出离过失功德故。善智起悟境理通容有顿缘多地行灭。诸邪见起于境迷谬。固执所隔不能总缘。何缘邪见缘苦集灭。有通唯别缘道不然。由治有殊互相因故。谓所缘道虽诸地别。而展转相属互为因果故。因此邪见六九总缘。灭不相因唯缘自地。岂不法类二智品道。亦互相因下上邪见。应俱能缘法类品道。如缘苦集诸地无遮。此责不然。非对治故。若尔六地法智品道。应非欲界邪见总缘。上五地中法智品道。于欲界法非对治故。未至地亦非全属上地者非欲治故治欲者亦非全邪见。唯是忍所治故。色无色界谤道邪见。应亦能缘法智品道。有法智品道治色无色故。若谓法智非全治彼。苦集法智品非彼对治故。亦非全能治色无色。不能治彼见所断故。初品法智不能治彼初品烦恼。非此所治故法智品非彼所缘。是则应许色无色邪见。不能总缘九地类智品。非类智品总能对治上二界中诸烦恼故。谓非第二静虑地等类智品道。亦能为初静虑地等烦恼对治。初静虑等亦非全。两节推征如前说。又缘道谛三界随眠。非苦集灭忍所对治。故谤道见理应无能下上总缘。六九地道如是过网理实皆无。法类相望种类别故。法类智品治类同故。互相因故。互相缘故。谓法智品道同是欲界中。缘道谛惑对治种类。此同断道由互相因互相缘故。设非对治亦欲缘道烦恼所缘。类智品道与法智品。虽互相因。由对治门种类别故。不相缘故。非欲缘道烦恼所缘。准此已遮色无色界缘道烦恼。亦应能缘治色无色法智品过。谓于此中虽有少分法智品道。能治上界少分烦恼亦互相因。而由治门种类别故。与类智品不相缘故。非上缘道烦恼所缘。于九地中类智品道。由一种类展转相因。更互相缘治类同故。虽非对治而可总为上八地中缘道惑境。是故如颂所说理成。何故贪嗔慢及二取见。无漏断不缘无漏。以诸欣求真解脱者。于贪烦恼定应舍离。若缘无漏如善法欲。希求涅槃及圣道故。求解脱者不应离贪。又灭道谛应是所断。佛说离贪境名断故。如契经说。汝于色中。若能断贪色亦名断。又于贪境见过失故方得离贪。若许有贪缘无漏者。应于灭道见过失时。贪方得离。此见非净。岂能尽惑。又于贪境见功德故贪方得生。若许有贪缘无漏者。灭静等行观无漏时贪应增长。如何因此能尽诸惑。既俱不尽惑。生死应无穷。是故知贪不缘无漏。缘怨害事方得生嗔。无漏事中离怨害相。故缘无漏嗔必不生。又嗔随眠其相粗恶。诸无漏法最极微妙。故嗔于彼无容得行。诸慢随眠高举相故性不寂静。诸无漏法极寂静故不生高举。又生慢者作是念言。我得此法。非无漏法力能为缘起如是慢。以无漏法能治慢故。二取若能缘无漏者。是则应与正见相同。无漏是真净胜性故。二取既无倒。应非见所断。是故二取非无漏缘。若尔有于谤涅槃者。邪见等上起嗔随眠。既称所缘应无有过。于有过法起憎背心。正合其仪应远离故。则应嗔恚非见灭断。无如是失。愚灭相者于能谤者方起嗔故。谓于余处执解脱已。于谤真解脱方起不忍心。是故要愚真灭相者。方于谤灭邪见等上。起极憎背见灭断嗔。诸有不愚真灭相者。于能谤灭邪见等上。若生厌背非嗔随眠。乃是无贪善根所摄。又如腹内积多病者。为活命故虽食美食。病所杂故皆成衰损。腹无病者。凡有所食一切于身有益无损。如是若有于非灭中妄谓是灭生贪爱者。相续秽故。于邪见等所起憎嫌。皆说名为缘见灭断。邪见等法所起嗔恚。若有如理于真灭中知是真灭。无贪爱者相续净故。于能谤灭邪见等中。所生厌背皆无过失。若于知有涅槃正见。所起嗔恚见何所断。此不应责见所断嗔。理必无容缘善法故。此缘正见。定修所断。然已见谛者此不复行。缘谤灭见贪已永断故。宁不信有缘无漏嗔。岂不此嗔世现知有。谓有外道言。涅槃中永灭诸根。是大衰损故。我于此定不欣求。此本非嗔乃是邪见。故本论说。于乐计苦。是见灭断邪见所摄。理必应然。以一切苦至极乐处方得永灭。极乐处者。唯真涅槃。此极乐言。显胜义乐。彼不能了此乐相故。又不能知生死过故。耽着诸有不乐出离。故起邪见非拨涅槃。宁执此为缘灭嗔恚。然上座说。许邪见疑及二无明缘无漏者。则应灭道俱成有漏。若谓灭道非惑所魅。要有漏事惑所魅者。是则若有于彼事中。有所求得可起烦恼。定无灭道成有漏失。由彼不成有漏相故。以佛说有漏唯是爱恚事。灭道既非爱恚事摄。故彼虽被邪见等缘。而决定无成有漏失。若尔不许贪嗔随眠是共相惑。非一切境皆为贪嗔所系缚故。应有有漏事亦成无漏失。彼定不了对法义宗。以许未来自相烦恼。定能系缚诸有漏事。非灭道谛与三时中贪嗔随眠为依为境。故与彼事不可例同。岂不世间诸外道类。现于无漏亦有起嗔。谓现有于他正见等真涅槃道。及涅槃中起极憎嫌。经中处处亦见广说憎灭道者。又诸烦恼依总相说。皆入贪嗔二品摄故。如说三随眠。复说七随眠。有说三结。复说九结。非三随眠不摄七随眠。非三结不摄九结。又如经说大病有三。岂身见等非大病摄。若彼品摄亦名大病。贪嗔亦然。总摄无失。谓贪能总摄乐相应烦恼。嗔复能总摄苦相应烦恼。故许邪见疑二无明能缘灭道。则应灭道亦是嗔事成有漏失。如是所说理皆不然。且初所言诸外道类。现于无漏有起嗔者。彼由不了无漏相故。但阙乐欲非谓起嗔。谓彼深心乐着生死不乐出离。故起邪见。非谤灭道岂即名嗔。彼或拨无或谓有过。故于无漏唯不忍许。非不忍许即名为嗔。如佛弟子于外道说。自性士夫时方我等。亦不忍许岂即是嗔。又彼所言依总相说。贪嗔总摄一切烦恼。以邪见等缘灭道故。灭道则应嗔事所摄。成有漏者理亦不然。违自意故。太过失故。不决定故。应异说故。谓彼上座处处自言。世尊不应作迷谬说。若佛于此但举贪嗔。意欲总摄一切烦恼。岂不此言极为迷谬。或若举二便能摄余。则后说余便为无用。故彼所说自意相违。如何彼言有太过失。谓先已释贪慢二取。不缘灭道其理极成。准汝所言应有缘义。以有邪见与乐相应。灭道亦应成贪事故。或虽许二总摄诸惑。而非总能缘灭道者。则应唯许邪见等缘。不应许嗔离怨相故。又约余义有太过失。谓应但说大病有二。以许贪嗔总摄诸惑。业因缘集应无有三。如是等门数皆应减。不决定者。谓彼所言唯说贪嗔能摄诸惑。如随眠等少能摄多。此不定然有处说少唯如名摄不摄余故。有说总名许摄别故。如缘起处说爱缘取。彼宗唯许爱为取缘。非摄所余乐相应惑。取名虽总唯许摄爱。又契经言。吾当为汝说诸爱网。此中唯说贪求相故摄爱非余。又见余经总说烦恼而不摄见。如五浊中或举别名而总摄惑。如契经说无明缘行。又于此中三随眠等。亦容说彼非摄一切。应异说者。谓若世尊欲依总相说诸烦恼。不应于此说贪与嗔。但应说无明如无明缘行。此能总摄一切烦恼。与诸烦恼相随行故。若说贪嗔唯能自摄彼前所说。是则若有于彼事中。有所求得可起烦恼者。此言有何义非我宗说。要于境中有所求得方起烦恼。但由于境不能了知。起背起求起中烦恼。若尔宁说惑所魅言。谓若境中惑得自在。能摄受境令顺生增。非惑生时摄取于境。置于心首宝玩名魅。但是境中惑得自在。摄令顺已得生增义。若非所魅惑于境中。虽缘彼生而不增长。如人举目观日月轮。能令眼根损减增长。是故贪等不缘无漏其理极成。灭道虽为邪见等境。而非有漏

说一切有部顺正理论卷第四十八阿毗达磨顺正理论卷第四十九

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩随眠品第五之五

为显上义复应思择九十八随眠中。几由所缘故随增。几由相应故随增。颂曰

  未断遍随眠　　于自地一切
  非遍于自部　　所缘故随增
  非无漏上缘　　无摄有违故
  随于相应法　　相应故随增

论曰。遍行随眠差别有二。谓于自界地他界地遍行。不遍随眠差别亦二。谓有漏无漏缘。且遍行中自界地者。普于五部自界地法所缘随增。不遍行中有漏缘者。唯于自部自界地法所缘随增。不遍行中无漏缘者。及遍行中他界缘者。于所缘境无随增义。所以者何。彼所缘境非所摄受及相违故。谓若有法为此地中身见及爱摄为己有。可有为此身见爱。地中所有随眠所缘随增理。言随增者。谓诸随眠于此法中随住增长。即是随缚增惛滞义。如衣有润尘随住中。如有润田种子增长。非诸无漏及上地法。为诸下身见爱摄为己有故。缘彼下惑非所缘随增。以不随缚增惛滞故。若下地生求上地等。是善法欲非谓染污。为求离染此欲生故。圣道涅槃及上地法。与能缘彼下惑相违。故彼二亦无所缘随增理。如于炎石足不随住。如火焰中鹅不增长。此随眠起亲由所依。然正起时兼托彼境。如是已辩所缘随增。随何随眠于相应法。由相应故于彼随增。所说随增谓至未断故。初颂首摽未断言。由此应知诸缘无漏。他界他烦恼唯相应随增。诸缘有漏自界地遍具有所缘相应随增。如何随眠于相应法。及所缘境有随增义。先轨[簐-欠+丸]师作如是说。如城邑侧有杂秽聚。粪水土等所共合成。于此聚中由粪过失。令水土等亦成不净。由水等力令粪转增。更互相依皆甚可恶。如是烦恼相应聚中。由烦恼力染心心所。烦恼由彼势力转增。更互相依皆成秽污。此聚相续秽污渐增。亦令随行生等成染。如猪犬等居杂秽聚。生极耽乐眠戏其中。粪秽所涂转增不净。复由猪等秽聚渐增。如是所缘自地有漏。由烦恼力有漏义成。彼复有能顺烦恼力。令其三品相次渐增。如滑净人误堕秽聚。虽触粪秽而非所增。人亦无能增彼秽聚。如是无漏异界地法。虽有亦被烦恼所缘。而彼相望互无增义。此缘无漏异地随眠。但由相应有随增理。有余于此复作是说。如酒杂毒酷烈转增。毒势亦增功能等故。如是有漏与诸烦恼。相助俱增功能等故。如以良药。置诸毒中。令毒功能有损无益。如是无漏虽被惑缘。令惑功能有损无益。故缘无漏有邪见生。而彼无能断善根力。亦有至教显诸随眠。有无漏缘无随增理。如契经说苾刍当知。疑食者何。所谓三世于过去世有惑有疑。现在未来说亦如是。无为虽是烦恼所缘非所随增故此不说。既不说此无漏有为。准此亦应非疑所食。如经总说诸行无常。理实于中唯说有漏法以于后说彼寂为乐。故本论亦言无漏缘烦恼随增。唯有相应非所缘。去来随眠有随增。不应言定有能发得故。若异此者诸异生类。无染心位应离随眠。然世尊言幼稚童子婴孩眠病。虽无染欲而有欲贪随眠随增。故说随增乃至未断。若彼已断则无所缘相应随增随眠。宁有彼犹不失随眠相故。谓由对治坏其势力故不随增。然彼随眠体相不失。故言犹有。或据曾当有此用故。今虽无用亦号随眠。如失国王犹存王号。工匠停作其名尚存。上座此中作如是说。随眠无有相应所缘二随增义。但有自性于相续中。随缚不舍为有自体。随缚相续为有有性无自体耶。彼自答言唯有有性。诸缠可有相应所缘。若尔亦应执有我性及瓶等性。异蕴色等如是僻执宜自隐覆。九十八随眠中几不善几无记。颂曰

  上二界随眠　　及欲身边见
  彼俱痴无记　　此余皆不善

论曰。色无色界一切随眠。四支五支定所伏故。无有势力招异熟果故。彼皆是无记性摄。若谓彼能招异熟果。应上二界有非爱受。染招爱受理不成故。然无圣道成无记失。唯有漏法有异熟故。此种类中无异熟者。方可说为无记性故。岂不经言诸圣弟子。若有能入第四静虑。能舍不善修习善法此亦何失。如契经言诸圣弟子。已证不动心善解脱。具末尼宝能舍不善修习善法。非诸阿罗汉有不善可舍。又已永断诸不善者。亦许勤修四正断故。当知皆约厌坏对治。远分对治说无有失。云何知然以契经说。离诸欲恶不善法故。上座释言约定位说。彼释非理欲界亦应如彼说故。欲界亦有善三摩地。应言离欲恶不善法无差别故。又诸异生入初静虑。亦说离欲恶不善法。非汝所宗诸异生类。有漏相续离诸烦恼。彼许有学法尚有随眠故。契经既说入初静虑。离诸欲恶不善法言。故上二界定无不善。若异此者异生现入初静虑时。应如欲界非离自地恶不善法。又生此界上界烦恼亦容现行。应定位中亦有不离恶不善法。惑所发业能招后有。故知生此容起彼惑。既曾无说彼不离言。由此定知彼释非理。又言上界烦恼亦应感非爱果如欲界惑。谓如欲界不善烦恼。虽助施等感人天生。然彼非无所招异熟。色无色界烦恼亦然。烦恼功能有差别故。非唯能感苦受异熟。理亦不然欲界中有诸恶趣故。诸处皆同一随眠故。他化自在烦恼亦能招恶趣果。非色无色有别处所。可受烦恼非爱异熟故。彼应执恶异熟因有无果者。或彼应执上界有受非爱果处。又于欲界人天趣中。有受不善圆满果义。非色无色可与此同。又如汝宗一切烦恼。虽同不善功能别故。有感苦受有无感能。如是亦应许诸烦恼虽同于境乱倒而缘。而彼功能有差别故。有是无记有是不善。又彼烦恼若不善性。既不许招苦受异熟。许彼能感乐受果耶。不尔。若然应成无记诸有漏业。若不能招爱非爱果。一切皆许是无记性宁独言非。又言无知性非善巧。一切烦恼彼摄受故。由此皆应是不善者亦不应理。虽彼皆同非善巧性无知摄受。而许其中有差别故。如汝虽许不善性同。而望苦受因非因异。又彼学法应成不善。谓彼自许诸有学法。望不善巧所摄随眠。亦得名为有随眠故。又彼不应说诸烦恼。皆非善巧无知摄受。摄受自体理不成故。理无二思同时起故。若谓引生名为摄受。则诸善行应成不善。无明为缘引彼生故。由此不可以彼为因。证色无色廛烦恼是不善。身边二见及相应痴。欲界系者。亦无记性颠倒转故宁非不善。且有身见顺善行故。违断善故定非不善。若谓亦能顺不善故应成不善。以身见后一切烦恼容现行故。由此但是有覆无记。非我说彼顺善行故即成善性。如何难言顺不善故成不善性。如有漏善虽顺两边不失善性此亦应尔。若谓贪求天上快乐。顺福行故应无记者此例不然。即我见力于天快乐起希求故。谓为我当受天快乐。即此为门能造福行。然贪于彼断善根时。说为强因故是不善。或由我见天爱方行。谓由见我当受天乐。方于彼乐起贪求故。我慢亦随身见后起。令心高举故不顺修善业。又违亲近善友等故。谓由我慢心自举恃。近善友等皆难得成。边执见中执断边者。计生断故不违涅槃。顺厌离门故非不善。如世尊说若起此见。我于一切皆不忍受。当知此见不顺贪欲随顺无贪乃至广说。又世尊说。于诸外道诸见趣中此见最胜。谓我不有我所亦不有。我当不有我所当不有。又此不畏大怖处故。如契经说愚夫异生无正闻者。有能不畏大可怖处。谓我不有我所亦不有。我当不有。我所当不有而不惊怖。上座于此作如是言。何有如斯下劣边见能顺解脱。以诸有情一切妄见皆入此摄。然我不知有何意趣。执此边见能顺解脱。此见下劣诚如所言。非方便门执生断故。然此行相。世尊有时为诸苾刍无问自说。或有一类作是思惟。谓我不有我所亦不有。我当不有我所当不有。如是胜解时便断下分结。故知此见能顺解脱。由是应知非不善性。又于如是边执见中。无非方便中执为方便见。无于下劣执为胜见。无于实有拨为无见。无非我常执我常见。如何乃说以诸有情一切妄见皆入此摄。执常边见顺我见生。是无记理如我见说。然彼未得证真理智。又未承奉达真理师。恒起我能为梯蹬慢自作是说。然我不知有何意趣。执此边见能顺解脱实如所言。有余复言。身边二见生死本故应是不善彼说不然因有三故。一者起因。二者生因。三异熟因。由起因故不越界地。由生因故令得受生。由异熟因故生已受异熟。身边二见是起生因。非异熟因名生死本。故本论说身见能令三有相续。乃至广说。然经主言俱生身见是无记性。如禽兽等身见现行。若分别生是不善性。此不应理不能分别而言见摄。见道所断理不成故。此不应言是修所断。与无我解正相违故。应知但是修道所断。不染无记邪智所摄。若不许然有太过失。谓禽兽等前际等中不能分别。亦应得有疑等现行如有身见。色无色界亦有分别烦恼现行应是不善。彼有不善如前已遮。故欲界中身边二见。唯是有覆无记性摄。余欲界系一切随眠。与上相违皆不善性。此谓欲界显欲界中上所说余皆是不善颂。无烦说此余皆不善故。于上所说不善惑中。有几能为不善根体。颂曰

  不善根欲界　　贪嗔不善痴

论曰。唯欲界系一切贪嗔。及不善痴不善根摄。如其次第世尊说为贪嗔痴三不善根。体唯不善烦恼为不善法。根名不善根宗义如是。岂不一切已生恶法。皆为后因非唯三种。无越三理以不善根翻对善根而建立故。何缘不建立不慢等善根佛于法中知而建立。有余师说。五识身中无恶慢等可翻对故。又具五义立不善根。谓通五部。遍依六识。是随眠性。发恶身语。断善根时为强加行。慢等不尔非不善根。义准已成故颂不说。如不善惑有不善根。无记惑中有是根不。亦有何谓。颂曰

  无记根有三　　无记爱痴慧
  非余二高故　　外方立四种
  中爱见慢痴　　三定皆痴故

论曰。迦湿弥罗国诸毗婆沙师。说无记根亦有三种。谓诸无记爱痴慧三。一切应知无记根摄。慧根通摄有覆无覆。根是因义无覆无记慧。亦能为因故无记根摄。此三有力生诸无记。何缘疑慢非无记根。疑二趣转慢高转故。谓疑犹豫二趣动转。故不立根根坚住故。慢高举相向上而转。故不立根根趣下故。世间共见根相如是。隐于土下故名为根。是体下垂上生苗义。此三如彼故亦名根。余非随眠惑无胜用。故不立彼为无记根。外方诸师立此有四。谓诸无记爱见慢痴。无记名中遮善恶故。何缘此四立无记根。以诸愚夫修上定者。不过依托爱见慢三。此三皆依无明力转。故立此四为无记根。彼作是言无覆无记。慧力劣故非无记根。根义必依坚牢立故。由慢力故诸瑜伽师。退失百千殊胜功德。故慢力胜立无记根。此四能生无记染法。上座于此作如是言。无无记根无圣教故。善恶猛利起必由根。无记羸劣不由功用。任运而起何藉根为。无圣教言且为非理。无记烦恼有极成故。谓何缘故少分染起。藉同类根少分不尔。无记染法有同类根。是染法故如不善法。又何定执此无圣教。非彼上座耳所未闻。便可拨言此非圣教。无量圣教皆已灭没。上座不闻岂非圣教。然于古昔诸大论师。皆共详论无说根义。故知必有圣教明文摽以总名无别名数。由斯诤论或四或三。又圣教中处处说有记无记法。又处处说记无记法从根而生。有处亦依有记根上。方便建立无记根名。故不应言此无圣教。又羸劣法转应计为由根力生非猛利者。是故非彼所立理趣。能遮我等立无记根。诸契经中说有十四诸无记事。彼为同此非善不善名无记耶。不尔。云何应舍置故。谓问记论总有四种其四者何。颂曰

  应一向分别　　反诘舍置记
  如死生殊胜　　我蕴一异等

论曰。等言为摄有约异门。且问四者。一应一向记。二应分别记。三应反诘记。四应舍置记。此四如次如有问者。问死生胜劣一异等。记有四者。谓答四问。若作是问。一切生者皆当死耶。应一向记。一切生者皆定当死。若作是问。一切死者皆当生耶。应分别记。有烦恼者死已当生。无烦恼者死已不生。若作是问。人为胜劣。应反诘记。为何所方为方诸天为方恶趣。若言方天应记人劣。若言方恶应记人胜。若作是问。蕴与有情为一为异。应舍置记有情无实故。一异性不成如马角等利钝等性。有作是说。彼第二问不应分别应一向记。谓问死者皆当生耶。此应一向记言不尔。设彼复问谁当生耶。应一向记有烦恼者。或彼复问谁不当生应一向记无烦恼者彼第三问不应反诘。应一向记谓问人趣为胜劣耶。应一向记亦胜亦劣所待异故。如有问识为果因耶。应一向记亦果亦因所待异故。彼第四问既全不记。蕴与有情若异若一不应名记。岂不如彼生闻梵志问世尊言。乔答摩氏我有亲爱先已命终。今欲为其施所信食。彼为得此所施食耶。世尊告言。此非一向。若汝亲爱生于如是饿鬼族中有得此食。既许彼是应分别记。此中亦问一切死者皆当生耶。于此亦应不一向记。应为分别有烦恼者生非无烦恼者。如何此非应分别记。一向为问非一向答。此与经说文义既同。俱应名为应一向记。或应俱名应分别记理所逼故。必应许同于人趣中。差别问故应差别记。谓有问言人趣为胜。此应反诘汝何所方。问劣亦应如是反诘。若双问者应一向记亦胜亦劣。非于此中胜劣双问。但随问一说一。为声意显别问。为胜为劣故此问成应反诘记。应舍置中难定非有。问记四种经所说故。不尔问记应但说三。若尔何缘经列四处。前三有记第四无耶。不记问者意所问故。若尔何故亦立记名以说。此中如所应故谓此亦说应舍置言。应置问中应言应置。若作余语记便不成。此中如何说有四问。谁言于此问有四耶。以问唯一相无别故。但约四记显问有殊。是故说为四应记。问何谓问相。有作是说。依二无遮是谓问相。此非问相。是扇帙略所造论中所说疑相。实问相者谓有相违或无相违。为欲了达所未了义。有所陈请设无陈请但依二义随观遮一。有所踌躇未能决了是名疑相。以实问相蕴在心中。对法诸师安立问记。一向记者。若有问言行无常耶。应一向记。分别记者。若有直心请言愿尊为我说法。应为分别法有众多。谓去来今欲说何者。若言为我说过去法。应复分别过去法中亦有众多色乃至识。若请说色应分别言。色中有三善恶无记。若请说善应分别言。善中有七谓离杀生广说乃至离杂秽语。若彼复请说离杀生。应分别言。此有三种。谓无贪嗔痴三善根所发。若彼请说无贪发者。应分别言。此复有二。谓表无表欲说何者。如是分别至究竟时。便令问者了所问义。故此分别记相即成。由此已遮有作是难。于分别后既更无容有余记言不应成记。以即分别说为记故。谓分别时问者自了所欲问义。分别终时已能影显所记义故。由是分别记相得成。未分别时彼未能解。分别已解故名为记。此于能记立以记名。然于此中置讫埵者。唯为显后不离前义。如世间说度山至河。非此为明山前河后。但欲令解非离度山有至河义。置讫埵缘如是此中。要有分别方成记义。非离分别故唯为显后不离前。非为显成前后别义。反诘记者。若有谄心请言。愿尊为我说法。应反诘彼法有众多。欲说何者不应分别。过去未来现在等异。所以然者。记者知其心怀谄曲求非故。问不应为彼分别诸法。但应反诘令默然住。或令自记无便求非。反诘终时已能影显所说义故。由是亦应许此反诘即名为记。由反诘言记被问故。有作是难此记亦不成诘。后无容有余记言故。问俱不与问相相应。请言愿尊为我说法。此不成问但应名请。此中前难应准前遮。然此与前有差别者。谓若反诘令彼自然。有正解生方得名记。如契经说我还问汝。如汝所忍应如实答。又如经说。汝意云何。色为无常为是常等。非佛于此自为分别。但由反诘令彼自解。岂不此中名佛为记。若能记者默无所言。令他解生名最胜记。又此中说反诘记者。有以反诘为记方便。如是应知依二义释反诘记名。一由反诘即名为记。二由反诘为方便已方记彼问。问与问相不相应者。此亦非理。依二无遮得问相名。非我许故汝虽许尔然自违宗。叙彼宗中当显违理。有虽不以二道为依而但希望知诸道相。作如是问为我说道。此岂不是问于道相。此依何二言无所遮。故汝所言唯能显己憎他善说爱自妄计岂由此故能破我宗。又彼云何安立问记。彼亦少分采取正宗。兼率己情作如是说。若问诸行常无常耶。应一向记言皆是无常性。问有两向谓常无常。然于记中唯有一向。如是一切皆应准知。如是名为应一向记。应分别记者。如生闻梵志问世尊言。乔答摩氏我有亲爱先已命终。今欲为其施所信食。彼为得此所施食耶。世尊告言。此非一向趣有五种。谓那落迦傍生饿鬼天人别故。若汝亲爱生地狱中。尔时唯应食地狱食。汝所施食彼不能受广说乃至。若生人中尔时唯应食人中食。汝所施食亦不能受。然有处所名饿鬼族。若汝亲爱生彼族中。则能受汝所施饮食。若据我宗如是所问。应分别记理实无违。然据汝宗如是所问。应一向记不应分别。进退推征如前已辨。应反诘记者。彼谓若问我常无常耶。应反诘言。依何我问若依色我乃至识。我应答无常若有问我有耶无耶。应反诘言依何我问。若言依彼十二处中随一我问。应答言有。若依余问应答言无。今谓此中反诘非理。且初问我常无常耶。应一向答是无常性。以唯于蕴执有我故。诸蕴唯是无常性故。以契经说。苾刍当知世间沙门婆罗门等。诸有执我等随观见一切。唯于五取蕴起。无容更有第二记故。应一向记不应反诘。设彼答言不依色我乃至识我。当如何记离蕴必无起我见者所问非理。当如何记以不应记非常无常。亦不可言我是常性。必无如是种类蕴故。离蕴必无起我见故。由此定是应一向记第二问我有耶无耶。亦不应反诘。汝依何我问。以诸我见必定唯于十二处中随一处起。离此无容有我见故。唯应一向答言是有。然于此中容可反诘。汝向所问我有无者。为问常我为无常耶。若问无常应记言有。彼于取蕴说我声故。若问常我应记言。无诸取蕴中皆无常故。如是理趣圣教所显。故拊掌喻契经中说。苾刍寻伺我我是何。佛知其心广为摽释十八界已。告言苾刍。汝等若谓此法是我。当言此我无常无恒广说乃至。苾刍汝等意谓此眼为常无常。白言大德。是无常性。既是无常为苦非苦。白言大德。亦是苦性。既无常苦即变易法为有。多闻诸圣弟子于此执有我我所耶。苾刍白言。不尔大德。此中意说若执无常法为无常。我应言我是有。若执眼等诸无常法。以为常我应言我无。又离如斯眼等法外。无别少分常住之法可计为我。故常我无。由此余经亦作是说。所有诸行皆空无常。无恒无住无不变易。亦复空无我我所性。又前说我无常无恒。不可保信有变易法。余处复说苾刍。汝今亦生亦老乃至广说。此等意显常住我空。无常不空故作是说。如上所引经说。世尊反诘苾刍。汝等意谓此眼等界无常无常。以此为问于后方记无常常我是有是无。又阎莫迦西腻迦等契经亦说。反诘苾刍诸蕴常无常记我为无有。以此准彼理亦应然。谓于此中有作是问。我体为有为是无耶。应反诘言。所问我者为问常我为无常耶。若问无常应记言有。若问常我应记言无。故彼所言皆不应理。应舍置者。彼谓苾刍问世尊言。大德应说过去诸劫其数有几。佛告苾刍。过去诸劫数有尔所不易可说。此中苾刍不知劫数故以问佛世尊。答彼过去劫数不可了知。如应舍置而为记别。是故说此名应舍置。此中何有依二无遮。而汝于斯许有问相。世尊未说有何未遮。可说为问世尊说已。有何所遮可说为记。苾刍先问由总不知。世尊说已仍未了达。于此有可问记二相。而汝亦许成问记耶。及契经言有四问记。然彼自说即由此因。列四名中前三有记。唯于第四不说记声。若尔何缘先作是解如应舍置而为记别。岂不前后自互相违。若随应置而为记者。应许第四亦有记声。若谓此中无记相故。于列名处不说记声。如何复言随应舍置。而为记别故。自相违。又于他宗不应设难。既全不记蕴与有情。若异若一不应名记。是故彼宗极为恶立。诸问记相前释可依

说一切有部顺正理论卷第四十九阿毗达磨顺正理论卷第五十

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩随眠品第五之六

因辩随眠不善无记傍论已了。今应思择何等随眠于何事系。何名为事。事虽非一而于此中辩所系事。此复有二。其二者何。谓就依缘及部类辩。就依缘者。谓眼识俱所有随眠。唯于色处为所缘系。于自相应诸心心所意处法处为相应系。如是乃至若身识俱所有随眠。唯于触处为所缘系。于自相应诸心心所意处法处为相应系。若意识俱所有随眠。于十二处为所缘系。于自相应诸心心所意处法处为相应系。就部类者。谓见苦断遍行随眠。于五部法为所缘系。于自相应诸心心所为相应系。见苦所断非遍随眠。唯于自部为所缘系。于自相应诸心心所为相应系。如是一切随应当说就三世辩何等有情有何随眠能系何事。颂曰

  若于此事中　　未断贪嗔慢
  过现若已起　　未来意遍行
  五可生自世　　不生亦遍行
  余过未遍行　　现正缘能系

论曰。若有情类于此事中随眠随增名系此事。夫为能系必是未断。故初未断如应遍流。且诸随眠总有二种。一者自相谓贪嗔慢。二者共相谓见疑痴。贪嗔慢三是自相惑如前已辩。诸圣教中处处见有分明文证。且如经言告衣袋母。汝眼于色若不见时。彼色为缘起欲贪不。不尔大德乃至广说。又契经说佛告大母。汝意云何。诸所有色。非汝眼见非汝曾见。非汝当见非希求见。汝为因此起欲起贪起亲起爱起阿赖耶起尼延底起耽着不不尔大德。乃至广说。故此事中有贪嗔慢于过去世已生未断。现在已生能系此事以贪嗔慢是自相惑。非诸有情定遍起故。岂不已断系义便无。既说系言已显未断。何缘说此被未断系。复说过去已生未断。此未断言应成无用。无无用过。此未断言显有品别渐次断故。即于此论。次下文中。亦说未来意遍行等。谓彼贪等九品不同。修道断时九品别断有缘此事。上品随眠已起已灭已得永断。彼于此事尚有未来余品随眠。未起未灭未得永断犹能为系。是故本论于此义中。虽说未来爱等所系。而于过去说未断言。故未断言深成有用。然过去世此品随眠得永断时未来亦断。容有余品未来随眠能系此事未得永断。以未来世意识相应贪嗔慢三遍缘三世。虽于此事或生不生。但未断时皆名能系。未来五识相应贪嗔。若未断可生唯系未来世。由此已显五识相应可生随眠。若至过去唯系过去至现亦尔。义准若与意识相应可生随眠。若至过现未断容系非自世法。非唯意识相应随眠。若在未来能缚三世。诸与五识相应随眠。若定不生亦缚三世。谓彼境界或在未来或在现在或在过去。彼虽已得毕竟不生。而未断时性能系缚。所余一切见疑无明。去来未断遍缚三世。由此三种是共相惑。一切有情俱遍缚故。若现在世正缘境时。随其所应能缚此事。以何为证知贪等惑。缘过去等三世境生。即于其中能为系缚。由圣教证故契经言。欲贪处法总有三种。一者过去欲贪处法。二者未来欲贪处法。三者现在欲贪处法。若缘过去欲贪处法生于欲贪。此欲贪生当言于彼过去诸法系非离系。乃至广说。又契经言。若于过去未来现在所见色中起爱起恚。应知于此非色系眼非眼系色。此中欲贪是真能系。如是等类圣教非一。今应思择过去未来。为实有无方可辩系。然于过未实有无中。自古诸师怀朋党执互相弹斥竞兴论道。俱申教理成立己宗。处处传闻如斯诤论。实有论者广引理教。种种方便破无立有。实无论者广引理教。种种方便破有立无。由是俱生大过失聚。故我今者发大正勤。如理思惟立去来世。异于现在非毕竟无。谓立去来非如现有。亦非如彼马角等无。而立去来体具是有。唯此符会对法正宗。于此先应辩诸有相。以此有相蕴在心中。方可了知去来定有。由所辩相显了易知。令固执者亦能契实。此中一类作如是言。已生未灭是为有相。彼说不然已生未灭即是现在差别名故。若说现世为有相者。义准己说去来是无理。于此中复应征责。何缘有相唯现非余。故彼所辩非真有相。我于此中作如是说。为境生觉是真有相。此总有二。一者实有。二者假有。以依世俗及胜义谛而安立故。若无所待于中生觉。是实有相如色受等。若有所待于中生觉。是假有相如瓶军等有余于此更立第三。谓相待有如此彼岸。此即摄在前二有中。名虽有殊所目无异。又彼所执违越契经。契经唯言有二有故。实有复二。其二者何。一唯有体。二有作用。此有作用复有二种一有功能。二功能阙。由此已释唯有体者。假有亦二其二者何。一者依实。二者依假。此二如次如瓶如军。诸圣教中总集一切说有言教。略有四种。一实物有。二缘合有。三成就有。四因性有。如契经说有色无常。我于其中等随知见。又如经说世间所无。我知我见无有是处如是等文说实物有。如契经说。要由有树方得有影。汝等苾刍若有和合。更无有师与我等者。如是等文说缘合有如契经说。有随俱行善根未断又如经言有内眼结。又如经说彼二无暖。又如经说非有爱者名有眼人。如是等文说成就有。如契经说此有彼有此无彼无如是等文说因性有。如契经说无有淤泥。如诸欲者设欲施设终无理趣。如是等教说毕竟无。非诸唯执有现世者。能具正辩圣教有言。如斯理趣后当具显。是谓我宗所辩有相譬喻论者作如是言。此亦未为真实有相许非有亦能为境生觉故。谓必应许非有亦能为境生觉。旋火轮我二觉生时境非有故又有遍处等胜解作意故。若一切觉皆有所缘。是则应无胜解作意。又幻网中说缘非有见故。又契经说知非有故。如契经言。于无欲欲则能如实了知为无。又诸世间梦中翳目多月识等境非有故。又于非有了知为无。此觉以何为所缘境又若缘声先非有者。此能缘觉为何所缘。是故应知有及非有。二种皆能为境生觉故此所说非真有相。对法诸师作如是说。无无境觉二缘定故。以契经中说六种觉。皆决定有所依所缘。谓眼觉生依眼缘色至意觉生依意缘法。无第七觉离境而生。可执彼为缘无境觉。若许有觉离境而生。亦应许有离所依觉。则应生盲等有眼等。觉生差别因缘不可得故。又非无法可说名为是六境中随一所摄故执有觉缘无而生。违理背教极为疏野。有余于此作是难言。若见少分有所缘觉。谓一切觉皆有所缘。既见少分缘去来觉。应眼等觉亦缘去来。若不许然亦不应许。以见少分有所缘觉。谓一切觉皆有所缘。是故不应立斯比量。或立便有不定过失。故无境觉实有极成。此但有言都无理趣。要由有境为别所缘。觉方有殊如眼等觉。谓如现在差别境中。眼等觉生而非一切。皆以一切现在为境。如是于有差别境中。一切觉生而非一切。皆以一切有法为境。又见少分有所缘觉。彼此极成以此例余。皆应有境可无过失。不见少分无所缘觉。彼此极成如何能证。有觉无境可无过失。然譬喻者先作是言。有非有皆能为境生觉者此不应理。觉对所觉要有所觉觉方成故。谓能得境方立觉名。所得若无谁之能得。又能了境是识自性。所识若无识何所了。故彼所许无所缘识。应不名识无所了故。夫言非有谓体都无。无必越于自相共相。何名所觉或所识耶。若谓即无是所觉识。不尔觉识必有境故。谓诸所有心心所法。唯以自相共相为境。非都无法为境而生。辩涅槃中已略显示。又执有觉缘无境生。此觉应是狂乱性故。谓执有觉无境论者。彼所执有缘无境觉。此觉定应狂乱为性。如世尊说。世间所无我若观之我应狂乱。非薄伽梵有狂乱理。故知定无缘无境觉。理不应说容有少分。可生心处非佛所缘。又必定无缘无境觉说。无不可知及不可得故。如契经说前际不可知。又契经言。作者不可得。此意显觉必定有境。以彼无故不可知得。若许有觉缘无境生。前际应可知作者。应可得无所有中无障碍故。亦不可说于非有中。少分是境少分非境。以此非有与彼非有。不可说言有胜劣故。又说定无知见无故。如契经说世间所无。我知我见无有是处。经主释此契经义言。意说他人怀增上慢。亦于非有现相谓有。我唯于有方观为有。若异此者则一切觉皆有所缘何缘于境得有犹豫。或有差别如是解释。但率己情非于非有。有所现相如何可说。增上慢人亦于非有现相观有。若于非有可得现相。于第十三处应现相。可得如是所说非有之相。超十二种所知聚故。定无有能观彼相者理趣阙故。经意不然理实应言增上慢者。亦于未现相谓已现相。我唯于现相观为现相。理应容有颠倒境智。必无有智无境而生。故一切觉皆缘有境。由此于境得有犹豫。谓我于此所见境中为是正知为是颠倒。即由此故差别理成。同有相中见有别故。非无与有少有相同。如何于中得有差别。唯于有法有差别故。但于有境觉有差别故。唯有境觉有差别理成。非于有无可辩差别。经主于此重决断言理必应然。以薄伽梵于余处说。善来苾刍汝等若能为我弟子。无谄无诳有信有勤。我旦教汝令暮获胜。我暮教汝令旦获胜。便知萨是萨非萨是非萨。彼谓此显知有无义。由不详审故作是言。此中萨声正显妙义。非萨声显非妙义故。谓有世间由邪教力。令其弟子起颠倒解。非妙谓妙妙谓非妙。佛则不然由正教力。令诸弟子解无颠倒。于妙不妙能如实知。如是名为此中经意理必应尔故。次复言有上是有上。无上是无上。勿有谓上知萨非萨言。正显弟子知有非有义故。次后复说知有上无上。为令解上知萨非萨言。正显弟子知妙非妙义。言妙非妙者是无失有失。有失是有上无失是无上。故有上无上显妙非妙义。或为显此妙非妙中有胜有劣。故复为说有上无上令其了知。若作如斯释经义者。显佛说法有大义利。谓令弟子于诸法中了妙非妙胜劣差别。能于诸法发大正勤。有断有修逮殊胜法。非唯令知有及非有。可名说法有大义利。又此经文前后所说。无不皆与我释相符。谓此经中前作是说。若有诸法令诸有情。能证不能证彼彼胜解迹。如来于中得无所畏。能正了知如是诸法。云何于此能正了知。谓正了知如是诸法。此于彼彼胜解迹中。有能作证有不能者。于正了知得无畏者。以善通达诸法性故。此中意显佛知诸法。此是能障碍此是出离道。于如是法无倒了知。经次复言。若有于我正师子吼。有惑有疑善来苾刍。乃至广说。于此经后复作是言。苾刍当知。此是定道。此非定道。乃至广说。是故经主所释经义极为迷谬意趣粗浅于缘无识为证不成。故说定无知见无故。无缘无觉其理极成。又彼所言自相违害。谓说有觉非有为境。若觉有境则不应言此境非有。若境非有则不应言此觉有境。以非有者是都无故。若谓此觉境体都无。则应直言此觉无境。何所怯怖怀谄诈心。矫说有觉非有为境。是故定无缘非有觉。又彼所说旋火轮我。二觉生时境非有者。亦不应理许二觉生。如人等觉亦有境故。谓如世间于远闇处。见杌色已便起人觉。作如是说。我今见人。非所见人少有实体。非所起觉缘无境生。即以杌色为所缘故。若不尔者何不亦于无杌等处起此人觉。旋火轮觉理亦应然。谓轮觉生非全无境。即火[火*曹]色速于余方周旋而生为此觉境。然火[火*曹]色体实非轮。而觉生时谓为轮者。是觉于境行相颠倒。非此轮觉缘无境生。我觉亦应准此而释。谓此我觉即缘色等蕴为境故。唯有行相非我谓我颠倒而生。非谓所缘亦有颠倒。故契经说苾刍当知。世间沙门婆罗门等。诸有执我等随观见一切唯于五取蕴起。理必缘蕴而起我见。以于诸蕴如实见时。一切我见皆永断故。胜解作意准此应知谓瑜伽师见少相已。自胜解力于所见中。起广行相生如是觉。此觉即缘诸蕴为境。住空闲者作如是言。如是相生是胜定果。谓胜定力于定位中。引广相生如所变化。又彼所言幻网中说。缘非有见理亦不然。即彼经中说缘有故。谓彼经说见幻事者。虽所执无非无幻相。若不许尔幻相应无。幻相是何谓幻术果。如神通者所化作色。如是幻相有实显形。从幻术生能为见境。所执实事是毕竟无。故彼经中说为非有。由诸幻事有相无实。能惑乱他名能乱眼。又引经说知非有故。如契经言。于无欲欲。则能如实了知无者。此亦不然知对治故。又约断灭说为无故。谓彼永断说为彼无。非此无言显无体性。又说世间梦中翳目多月识等境非有者理亦不然。且梦中识缘非有境非极成故。谓由将睡计度思惟。或正睡时天神加被。或由身内诸界互违。故睡位中于过去境。起追念觉说之为梦。过去非有理不极成。如何引证有缘无觉。梦所见境皆所曾更。然所曾更非唯所见。如菩萨梦是所曾闻。而有梦中见兔角者。曾于异处见兔见角。令于梦中由心惛倒。谓于一处和合追忆。或大海中有此形兽曾见闻故今梦追忆。所余梦境准此应思。故梦不能证缘无觉。依翳目识境亦非无。谓此识生亦缘形显。由根有翳取境不明。故于境中起颠倒解。行相虽倒境实非无。以翳目人要有色处。见种种相非色全无。异此则应无色处见。缘多月识境亦非无。谓眼识生但见一月。由根变异发识不明。迷乱觉生谓有多月。非谓此觉缘非有生。即以月轮为所缘境。若不尔者无处应见。既无月处此识不生。故此即缘月轮为境。然梦等识缘有境生行相分明有差别故。如觉等位缘青等心。宁引证成有缘无识言于非有了知为无。此觉以何为所缘者。此缘遮有能诠而生。非即以无为所缘境。谓遮于有能诠名言。即是说无能诠差别。故于非有能诠名言。若了觉生便作无解。是故此觉非缘无生。岂不说无能诠是有。如何了觉拨彼为无。非了觉生拨名言体。但能了彼所诠为无。谓了觉生缘遮有境。不以非有为境而生。何等名为能遮有境。谓于非有所起能诠。此觉既缘能诠为境。不应执此缘无境生理必应尔。如世间说非婆罗门及无常等。虽遮余有而体非无。此中智生缘遮梵志及常等性。能诠所诠即此能诠能遮梵志及常等性。于自所诠刹帝利身诸行等转。然诸所有遮诠名言。或有有所诠有无所诠者。有所诠者如非梵志无常等言。无所诠者如说非有无物等言。因有所诠而生智者。此智初起但缘能诠。便能了知所遮非有。后起亦有能缘所诠。知彼体中所遮非有。因无所诠而生智者。初起后起但缘能诠。于中了知所遮非有。然非有等能诠名言。都无所诠亦无有失。以非有等都无体故。若都无体亦是所诠。则应世间无无义语。有作是说。一切名言皆有所诠名能诠故。若尔非有无物等言。及第二头第三手等。能表无法所有名言何为所诠。而言皆有以缘此想为此所诠。若无所诠有能诠者。应无所觉有能觉生。此既不然彼云何尔。此例非等以觉生时要托所缘。如羸凭杖诸心心所。法尔生时必托四缘非如色等。诸能诠起非托所诠。由因刹那等起力发。随自心想所欲而生。非要凭托所诠方起。故经说有无义言声。心心所法起必托境。故经说彼名有所缘。非有不应说名为有。了达无我正觉生时。此觉即缘诸法为境。如契经说。当于尔时。以慧正观诸法无我。经主叙彼所设难言。若有缘声先非有者。此能缘识为何所缘。若谓即缘彼声为境。求声无者应更发声。若谓声无住未来位。未来实有如何谓无。若谓去来无现世者此亦非理其体一故。若有少分体差别者。本无今有其理自成。故识通缘。有非有者此亦非理。前于思择涅槃体中已辩释故。彼于彼处已作是言。如说有声有先非有有后非有。乃至广说。我先已释。为于毕竟非有物上说此有言。为此有言。即于有上遮余而立。若别有物居声先后。可遮声故说非有言。谓彼物中此声非有。诸互非有定依有说。若于毕竟非有物中。而说有言何不违理。既尔经主不应复言。若谓即缘彼声为境。乘斯展转起多释难。准先所释有非有言。此中缘声先非有识。缘声依处非即缘声。谓但缘声所依众具。未发声位为声非有。如于非有了知为无。即缘有法遮余而起。此亦应尔宁为别释。设许即缘彼声为境。所设过难理亦不成以许去来。虽体是有而与现在有义不同。然不即成本无今有。作用与体非一异故。如是等义后当广辩。又如何知声先非有。以未生故此亦同疑。谓于此中正共思择。声未生位为有为无。故问宁知声先非有。如何但答以声未生。未生与先义无别故。既未生故不能为因。证声未生都无有体。如何可以声未生无。证能缘识以无为境。又后当辩。一切识生无不皆缘有法为境。且无非有为所缘觉。由前决择其理极成。此觉既无我先所说。为境生觉有相理成。若有诸师以此有相。摽于心首应固立宗。过去未来决定是有。以能为境生诸觉故。复应思择如上所言。实有假有俱能生觉。既缘过未亦有觉生。过去未来为实为假。有说唯假彼说不然。假法所依去来无故。若谓现在是彼所依。理亦不然不相待故。谓不待现亦有能缘去来为境诸智转故。先作是说。若有所待。于中觉生是假有相。又世现见诸假所依。若都尽时假不转故。谓世现见补特伽罗瓶衣车等诸假有法。所依尽时彼则不转。然见现在诸法尽时。过去未来犹可施设。故彼所救理定不然又假所依与能依假。现见展转不相违故。诸有为法行于世时。过去未来与现不并。如何依现假立去来。是故去来非唯假有。又未曾见前后位中。转假为实实为假故。若执未来唯是假有。应许现在亦假非实。或许现在是实有故。应许过去亦实非假。如是彼言极违理故。宜速舍弃不应固执。又假定非圣道境故。谓非假有补特伽罗瓶衣等事是圣道境然诸圣道亦以去来诸有为法为所缘境。若异此者过去未来诸有为法。则不应为现观忍智之所了知。又现观时若不许以去来受等为其所缘。则自身中受等诸法。毕竟不为现观所缘。彼执不能缘过未故。无二受等俱现行故。是则圣道于诸有为。不能遍知便违经说。若于一法未达未知。我说不能作苦边际。是故圣道必缘去来。如就应知证去来世。非唯假有可成所知。如是就余应断应证。及应修等差别法门。随其所应皆证过未非唯假有义可得成。假法定非所断等故。又假与实不可定言。是一是异如世伊字。三点所成一异难说。去来今世前后位殊。如何可言去来二世。体唯是假依现在立。是故彼论与理相违。不顺圣言无可收采。即说定有过去未来。云何应知彼定有相。如对法者所说应知。对法诸师如何说有。由有因果染离染事。自性非虚说为实有。非如现在得实有名。谓彼去来非如马角。及空花等是毕竟无非。如瓶衣军林车室数取趣等。唯是假有非如现在是实有性。所以者何。非如马角及空花等。诸毕竟无瓶衣军林。车室等假可得名有因果等性。又非已灭及未已生。可得说言同现实有。以如是理蕴在心中。应固立宗去来定有。诸有为法历三世时。体相无差有性宁别。岂不现见有法同时。体相无差而有性别。如地界等内外性殊。受等自他乐等性别。此性与有理定无差。性既有殊有必有别。由是地等体相虽同。而可说为内外性别。受等领等体相。虽同而可说为乐等性别。又如眼等在一相续。清净所造色体相同。而于其中有性类别。以见闻等功能别故。非于此中功能异有。可有性等功能差别。然见等功能即眼等有。由功能别故有性定别。故知诸法有同一时。体相无差有性类别。既现见有法体同时。体相无差有性类别。故知诸法历三世时。体相无差有性类别。如是善立对法义宗。经主于中朋附上座。所立宗趣作是诘言。过去未来若俱是有。如何可说是去来性。此诘于义都不相关。同实有中许有种种。有性差别理极成故。三世有论亦可诘言。过去未来若俱非有。如何可说此去此来。说常有宗依有体法。由自性异因缘不同。容可立有性类差别。说去来世无体论者。去来世体既决定无。自性因缘不可说异。如何分判去来世别。如彼唯托实无体中。矫立言词尚能说有去来世异。况此凭托实有体中。以正道理不能说有去来世别

说一切有部顺正理论卷第五十阿毗达磨顺正理论卷第五十一

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩随眠品第五之七

如是略述三世有无理趣正邪有差别已。为令此义决定增明复依颂文广显宗趣。颂曰

  三世有由说　　二有境果故
  说三世有故　　许说一切有

论曰。实有过去未来现在。了教正理俱极成故。若尔三世由何有别。如是征责起何非次。且应诘问何谓教理。我引教理成立己宗。过去未来现在实有。有义既显别易思择。既尔现在实有极成。何教理证去来实有。且由经中世尊说故谓世尊说过去未来。色尚无常何况现在。若能如是观色无常。则诸多闻圣弟子众。于过去色勤修厌舍。于未来色勤断欣求。现在色中勤厌离灭。若过去色非有。不应多闻圣弟子众。于过去色勤修厌舍。以过去色是有故。应多闻圣弟子众。于过去色勤修厌舍。若未来色非有。不应多闻圣弟子众。于未来色勤断欣求。以未来色是有故。应多闻圣弟子众。于未来色勤断欣求。又契经言。告舍利子。杖髻外道恍惚发言不善寻求不审思择。彼由愚戆不明不善。作如是言若业过去尽灭变坏都无所有。所以者何。业虽过去尽灭变坏。而犹是有何缘知。此所引契经说有去来。定是了义曾无余处决定遮止。犹如补特伽罗等故。谓虽处处说有补特伽罗。而可说为实无有体人。契经等分明遮故由此说有。补特伽罗所有契经皆非了义。又如经说应害父母。理亦应是不了义经。以余经言是无间业。无间必堕捺落迦故。又如经言诸习欲者。无有恶业而不能作。此亦应是不了义经。以余经中遮诸圣者。由故思造诸恶业故。如是等类随应当知非此分明决定说有去来世。已复于余处分明决定遮有去来。可以准知此非了义。然此决定是了义说。以越余经不了相故。恍惚论者何太轻言。但违己宗经便判为不了。岂不亦有遮去来经。如胜义空契经中说。眼根生位无所从来。眼根灭时无所造集。本无今有有已还去。若未来世先有眼根。则不应言本无今有。奇哉凡鄙朋执覆心。粗浅义中不能明见。且置我释汝云何知。由后契经前成非了义。非由前故后经成不了。然依此说胜义空经。依此不能遮去来有。非遮离行有作者言。能遮去来是实有故。然此眼根生位无所从来等言。应审寻思此言何义。若眼生位许体是有。则未来有其义已成。若执犹无何所疑虑。而言生位无所从来。非诸体无有从来处。何劳于此遮所从来。但应明言生位非有。既遮生位有所从来。故知大师不许别有。现积集处眼从彼来次后说灭时无所造集故。以世间有邪论者。说眼根生位从火轮来。眼根灭时还造集彼。遮彼故说此两句经。或遮眼根出从自性。没还归彼故说此言。或遮眼根自在所作。故说如是两句经文。谓遮眼根有胜作者。显彼唯有因果相属。已遣他宗为显自意故。次复说本无今有。有已还去两句经文。谓此中所言本无今有者。显本无集处。从自因缘生。或有欲令因是果藏。故佛说果因中本无。但由彼因有别果起。或此为显眼根生时。能至本来所未至位。依此义说本无今有。此经文意理必应然。故次复言有已还去。此显起作用牵自果。已还去至如本无作用位。若佛为遮去来是有。方便说此本无等言。如前句言本无今有后句应说有已还无。既不言无但言还去。则知不许过去是无。非汝所宗许过去有。唯言无有未来眼根。如何引斯契经为证。说是语已。世尊复观当有。迷斯契经意趣。便谓无有过去未来。增长谤因谤果邪见。为遮彼故复作是言。有业有异熟作者不可得。此显要有过去业因。方有未来异熟果起。非更别有作者作用。故为显示无有实我。唯决定有因果相属。如来说此胜义空经。非为欲遮去来实有。与前所引经义无违。故前契经是了义说。有说定有遮去来经。如契经言。于无内眼结如实了知我无内眼结。又契经说。此无彼无。又契经言彼二无暖。彼经非证即彼经中。有文证成去来有故。如彼经言。于有内眼结如实了知我有内眼结。非善心位有结现行。故知彼经说有过未。又彼经说行有识有。非异熟果异熟因俱。故知彼经说有过未。又彼经说告二苾刍。有四句法门我当为汝说。此证身内定有未来。语文等体为当所说。故知彼经说有过未。然彼经说结等无者。显不成就不造不得。如决定说有去来经。决定遮经曾不见有故。我所引有去来经理应许为真了义说。于前所引真了义经。已正遣除非了义执。此与彼计决定相违。经主于中欲以强力逼令非了。作是释言。我等亦说有去来世。谓过去世曾有名有。未来当有有果因故。依如是义说有去来。非谓去来如现实有。故说彼有但据曾当因果二性非体实有。世尊为遮谤因果见。据曾当义说有去来。有声通显有无法故。如世间说。有灯先无有灯后无。又如有言。有灯已灭非我今灭。说有去来其义亦应尔。若不尔者。去来性不成。此释有言定非善说。不许实有去来世故。假有如前理不成故。无容更有余有义故。如何决判经中有言。而言我说有去来世。虽言过去曾有名有。未来当有有果因故。而实方便矫以异门说。现在有何关过未故。彼所言我等亦说有去来者。但有虚言竟不能伸去来有义。若去来世但是曾当。法体实无不应名有。或若许有则不应说去来二世但是曾当。又若实无以曾有故。亦说过去为实有者则应现在。虽实有性非曾有故。应执为无过去应通曾有非有。即由此理类说未来。彼亦应通当有非有。然于实有过去体上。亦有少分可名曾有。由此得成过去有性。如是实有未来体上。亦有少分可名当有。由此得成未来有性。世间现见于实有法可说曾当。曾不见于非实有法说曾当义。如舍利子白世尊言。阐陀苾刍昔曾于一婆罗门邑。往乞食家说此语时彼家现有。世尊亦说。庆喜苾刍当为上座。乃至广说。说此语时庆喜现有故。于实有过去未来说有曾当理善成立。又若无实过去未来。则无所遮谤因果见。谓若实有过去为因。能感未来实有为果。而拨为无者名谤因果见。若去来世因果实无。于无见无岂名为谤。宁为遮彼说有去来。岂不先言曾当是有。我亦先说应通有无。又于此中有何别理。唯据曾当有说有去来。非据非曾当说无现在。说此亦有遮常见能。故彼所言无深理趣。又我先说曾当有言。但以异门说现在有非关过未。如何能遮。言有声通显有无者。此亦非理不极成故。执能通显应设诚言。然世极成有唯显有。曾不见有有声显无。如何乃言有声通显。而世间说有灯先无。有灯后无。如声理释此前已说后当更辩言。若不尔者。去来性不成。理亦不然彼不成故。非彼过去有过去性。非彼未来有未来性。非无自体可立性名。故彼去来性不成立。或彼应设种种劬劳。成立去来是实有性。不尔二世性必不成。如是且如彼宗所说。定不能释去来有经。非以彼宗不能释故。便舍善逝所说契经。故应信知去来实有。经主又释杖髻经言。业虽过去而犹有者。依彼所引现相续中。与果功能密说为有。若不尔者。彼过去业。现实有性过去岂成理必应尔。以薄伽梵于胜义空契经中说。眼根生位无所从来。乃至广说。此如愚者于駃流中。以船系于乘船者足。望船停止终无是处。且彼所执现相续中。与果功能智者审谛。推寻其相竟不可得。如何过去业自体已无。依与果功能可说为有。诸巧伪者所执。随界功能熏习种子增长。不失法等处处已破。彼岂能障此了义经。所说有言令成不了。设许有彼所引功能。亦不应由斯说无法为有。勿彼因无故亦说功能无。差别因缘不可得故。又世尊说与彼不同。谓佛明言业虽过去尽灭变坏。而犹是有彼业所引与果功能。于相续中设许现有。体非过去尽灭变坏。如何依彼可说是言。若必定然佛应明说。业虽过去尽灭变坏。而于相续有彼功能佛既但言彼业犹有。故知实有彼过去业。又佛但说过去有言。如何定知约功能说。岂不已说。若不尔者。彼过去业。现实有性过去岂成。我于前文岂不已说。前文何说谓说体相。虽复无差而于其中见有性别。如是所说有性不同。汝等于中谁能说过。依如是义故。有颂言

  诸法体相一　　功能有性多
  若不如实知　　名居佛教外

然彼所引胜义空经。如前通释于彼非证。又彼宗不许实有过去业。而经不说有已还无。如何可引证成彼义。故率己情巧为谬释不能违害去来实有。上座于此释前经言。若过去色非有。不应多闻圣弟子众于过去色勤修厌舍。乃至广说。此说意言若过去色非过去者。不应多闻圣弟子众。于过去色勤修厌舍。应如现在勤厌离灭。或若过去色自他相续中非曾领纳。不应多闻圣弟子众勤修厌舍。要曾领纳方可厌舍。未曾领纳何所厌舍。以彼色是过去及过去曾领受故。应多闻圣弟子众。于过去色勤修厌舍。又释第二杖髻经言。彼过去业亦可说有。有因缘故有随界故。未有能遮彼相续故。彼异熟果未成熟故。最后方能牵异熟故。然去来世非实有体。可笑如是解释经义。此岂能遮去来实有。如是谬释一切智经岂能庄严印度方域。且彼初释前所引经。若谓前经有如是义。若过去色非是过去。不应于中勤修厌舍。应如现在勤厌离灭。此非经意徒设劬劳。以若彼色非是过去。应是现在或是未来。是则不应但如现在。此言翻是扰乱契经。岂得名为释经意趣。又若尔者。经但应言。若过去色非过去非若过去色非有。又经次后应作是言。以过去色是过去非。以过去色是有文。既不尔彼释定非。若谓前经有如是义。若过去色非有过去。不应于中勤修厌舍。非于无法可修厌舍。要过去色有过去性。方可于中勤修厌舍。如现在色有现在性。方可于中勤厌离灭。则与我释其义无差。弥更显成过去实有。由此彼释徒设劬劳。定不能遮过去实有。彼第二释前所引经。少有彼经所说义趣。谓曾领纳应勤厌舍。未曾领纳何所厌舍。然不知彼作是释经。欲如何遮过去实有。若非实有厌舍唐捐。释杖髻经亦不应理。无法不成因缘性故。彼随界言无所诠故。一刹那宗无相续故。无法不能招异熟故。不尔生死应无穷故。由此我说实有去来。又具二缘识方生故。谓契经说识二缘生。如契经言。眼色为缘生于眼识。如是乃至意法为缘生于意识。若去来世非实有者。能缘彼识应阙二缘经主此中作如是说。今于此义应共寻思。意法为缘生意识者。为法如意作能生缘。为法但能作所缘境。若法如意作能生缘。如何未来百千劫后当有彼法。或当亦无为能生缘生今时识。又涅槃性违一切生。立为能生不应正理。若法但能为所缘境。我说过未亦是所缘。经主此言乖于论道。谓对法者作如是言。佛说二缘能生于识。此则唯说实及假依。为根为境方能生识。二唯用彼为自性故。非无可为二缘所摄。由此知佛已方便。遮无为所缘识亦得起。既缘过未识亦得生。故知去来体是实有宗承既尔。而经主言。如有无亦能为所缘境者。但违戾佛非对法宗。对法诸师承佛意旨。置于心首咸作是言。过去未来决定实有。所言此义应共寻思。应共此中寻思何法。意为意识所依生缘。法为所缘能生意识。所依缘别生缘义同。佛说二缘能生识故。如所依阙识定不生。所缘若无识亦不起。二种俱是识生缘故。于明了义何所寻思。若谓意根与所生识。一类相续无间引生可名能生。法不尔者。眼根及色望眼识生。应非能生彼非眼识。一类相续无间引故。又未来世近当生法。应望意识亦非能生。以彼亦非与所生识。一类相续无间引故。然彼自许亦是能生。由彼自言百千劫后。当有非有及与涅槃。如何为缘能生今识。若未来世近当生法。望今意识亦非能生。如何但言百千劫后。当有非有及与涅槃。如何为缘能生今识。故彼所说。语亦有过。此中善逝决定判言。所依所缘皆能生识。各别相续亦是能生。母是能生世极成故。又彼所说如何未来百千劫后当有诸法。为能生缘生今识者。亦应诘彼如何未来近当生法能生今识以据因果染离染事。若远若近性皆等故。又一切法自性皆无作者作用。不应于此定执能生所生差别。故一切法有自体者。皆但为识所依所缘。非说但声能显有识。以无体法为所缘境。经主于此自难释言。若无如何成所缘境。我说彼有如成所缘。如何成所缘谓曾有当有。非忆过去色受等时。如现分明观彼为有。但追忆彼曾有之相。逆观未来当有亦尔。谓如曾现在所领色相。如是追忆过去为有。亦如当现在所领色相。如是逆观未来为有。若如现有应成现世。若体现无则应许有缘无境识其理自成。譬喻师徒情参世俗。所有慧解俱粗浅故。非如是类尔焰稠林。可以世间浅智为量。唯是成就清净觉者。称境妙觉所观境故。若诸世间觉不净者。要曾领受方能追忆。因此寻思去来世异理必应尔。彼于未来由未领纳观极闇昧。清净觉者观于去来。脱未领纳观极明了。若过未有如成所缘。于杌缘人于块缘鸽。岂可彼有如成所缘。故于去来缘异有异。不可彼有如成所缘。有据曾当缘据现故。又彼自语前后相违。谓先既说非忆过去色受等时。如现分明观彼为有。但追忆彼曾有之相。后不应言如曾现在所领色相。如是追忆过去为有。以非现在领色相时领曾有相。唯领现有亦非追忆过去色时。忆现有相唯忆曾有故。领现在与忆过去。现曾有相条然差别。若如现有追忆过去。而说彼有如成所缘。是则极成过去实有。以如现在领实有相。如是追忆过去为有。既许彼有如所追忆。如何过去体非实有。故彼后说自违前宗。又彼所言若如现有应成现世。若体现无则应许有缘无境识。此先已说先说者何。谓非去来有如现在。以于一切同实有中。许有种种有性别故。又一切识必有境故。谓见有境识方得生。如世尊言。各各了别。彼彼境相名识取蕴。所了者何。谓色至法非彼经说有识无境。由此应知缘去来识。定有境故。实有去来。此中所应与经主诤。如前已辩故不重述。此中上座作如是言。智缘非有亦二决定。推寻因果展转理故。其义云何。要取现已于前后际能速推寻。谓能推寻现如是果。从如是类过去因生。此因复从如是因起。乃至久远随其所应。皆由推寻如现证得。或推寻现如是类因。能生未来如是类果。此果复引如是果生。随其所应乃至久远。皆推寻故如现证得。如是展转观过去因。随其所应乃至久远。如现证得皆无颠倒。虽于此位境体非有。而智非无二种决定。彼谓如是因智生时。自相续中因缘有故。谓昔曾有如是智生。传因生今如是相智。今智既以昔智为因。故今智生如昔而解。即以昔境为今所缘。然彼所缘今时非有。今虽非有而成所缘。故不可言无二决定。如是展转观于未来。果传传生准前应说。上座于此自难释言。若智缘前曾所取境。可以昔境为今所缘。若缘过去曾未取境。或逆思惟未来世事。宁以昔境为其所缘。于相续中必定应有因智果智。先时已生今智生时。亦以彼智曾所缘境为其所缘。彼智为因生今智故。今智如彼亦能推寻。从如是因生如是果。或如是果从如是因。随其所应皆能证得。随所证得皆无颠倒。虽于此位境体非有。而智非无二种决定。如是一切上座所言皆如哑人梦有所说。辩四缘处已广推征。应准彼文例破此说。此说但可诱诳愚蒙。智者推寻都无实义。今仍于此略重思择。且应诘彼自释难中。言相续中必定应有因智果智。先时已生今智生时。亦以彼智曾所缘境为所缘者。何谓已生因智果智。而言今智缘彼所缘。为即曾缘今智境者。为更别有缘余境智若即曾缘今智境者。此境既为昔智所缘。如何名为曾未取境。若更别有缘余境智既执彼境为今所缘。今智如何名以过未曾未取境为其所缘。谓先已生因智果智所缘因果。为今所缘此境先时已为智取。如何复名曾未取境。曾即未曾不应正理。又设许彼有旧随界因果。展转相续力故。虽经多劫久已灭境。而今时取理可无违。若于未来百千劫后。当有境界今如何取。不可说言因果展转相续力故。彼亦可取未来体无。如马角故于相续中无随界故。又若展转寻过去因。于曾取境中方有识生者则于近远曾取境中。应有速迟取时差别。非身现住波吒厘城。忆昔所更缚喝国事。寻因展转方有识生。率尔便生缘彼识故。又从耳识无间便生。缘于先时曾所取识。如是识起用何为因。且不可因当时随界。耳识不缘彼境界故。亦不可因曾取彼识。曾取彼识尔时无故。不可无法为因生无。勿马角等亦有生故。辩四缘中已广征遣。故唯说有一刹那宗。缘去来识生必无二决定若信实有过去未来二决定义方可成立。又已谢业有当果故。谓先所造善不善业。待缘招当爱非爱果。思择业处已广成立。非业无间异熟果生。非当果生时异熟因。现在若过去法其体已无。则应无因有果生义。或应彼果毕竟不生。由此应知过去实有。经主于此作如是言。非经部师作如是说。即过去业能生当果。然业为先所引相续。转变差别令当果生。譬如世间种生当果。谓如从种有当果生。非当果生从已坏种。非种无间有当果生。然种为先所引相续。转变差别能生当果。谓初从种次有芽生。叶乃至花后后续起。从花次第方有果生。而言果生从于种者。由种所引展转传来。花中功能生于果故。若花无种所引功能。应不能生如是类果。如是从业有当果生。非当果生从已坏业。非业无间有当果生。然业为先所引相续。转变差别能生当果。业相续者谓业为先。后后刹那心相续起。即此相续后后刹那。异异而生名为转变。即此转变于最后时。有胜功能无间生果。异余转变故名差别。如是等理准前应知。此说如前思择业处已曾遮遣。今因义便理未尽者复应广破。且业为先心后续起名业相续。理必不然以业与心有差别故。言差别者。谓业与心体类及因皆有异故。体有异者相各别故。类有异者心心所法类各别故。因有异者因二因三而得生故。此既有异如何可言后心续生是业相续。又心与业俱时而生。辩俱有因及于余处已广成立。于思相续识相续中。曾不见有自类相续俱时而起。故知业心非一相续。又汝宗执灭定有心。佛言灭定诸意行灭。如何心业一相续耶。若许业心同一相续。如心不灭意行应然。如意行灭心亦应尔。然在灭定必无有心。不相应中已广成立。业相续断故后果应不生。非种芽等次第相续。后果生中有如是理。故彼唯有虚妄分别。又彼所说果从华生理不极成。诸已灭种体犹实有。我宗许故设许极成。如彼相续此业相续理亦不成。由前所辩差别理故。又爱非爱果因定故。谓诸恶行决定为因招非爱果。若诸爱果决定应以妙行为因。若执如花是种相续转变差别能生果者。有何定理妙恶行因。各别能招爱非爱果。恶行无有感爱果能。妙行无能感非爱果。无记于二俱无感能应说此中有何定理。如是三种所有功能。一切与心体不异故。亦不应说种类有异。非别种类而可说言无有别体。曾不见故。又花由与芽等相续。容可执有种子功能。功能与花无别体故。非善不善可体无别。勿此中有大过失故。又种芽等是一相续。既执花有种子功能。芽等功能花亦应有。此彼差别不可得故。是则芽等及种功能。一切与花无别体故。既从花内所有功能。花为助缘能生于果。即由此故芽等应生。然于尔时唯能生果不生芽等。此有何因非于花中。可有细分种等所引功能别居。由此尔时唯种所引。花为缘助能引果生。非于花中芽等所引。若谓芽等所引功能。虽住花中而要待果。或芽等起芽等方生。若尔如先种子所引。生自果已复为因生后芽等中。种子相续则应先业所引功能。生自所招异熟果已。复为因起后业相续。然汝宗说异熟后边。别业为因引业相续。非前业种引后业能。是故不应以种相续。喻业相续能生于果。又种芽等无始时来。一一种类各一相续。初未曾闻稻种芽等展转乃至引稗果生。然汝所宗一业相续。爱非爱果俱能引生。故彼不应为同法喻。又若识体带思功能。思体复带识功能者。功能与法无别体故。此识此思由何相别。又若尔者顺现等业应成杂乱。如是等过于处处文。我数数说由此憎背。去来有者业果感赴其理定无故。诸愚蒙隐灭经者。计有相续转变差别。能招当果理必不成。经主此中又作是难。若执实有过去未来则一切时果体常有。业于彼果有何功能。此难至时当如理释。且汝业果感赴不成。然应去来定是实有。说有相故犹如现在。如契经说。过去未来色尚无常何况现在。无常即是有为相故。现有彼相实有极成。若执去来非实有者。应非如现在说有有为相。非毕竟无空花马角。亦容可说彼有无常。故知去来定是实有。谓据曾当说有相者此亦非理。言无别故非契经说。过去未来色曾无常当无常故。由此彼救但率己情。又彼所言曾无常等。但方便说现在无常。谓说曾当现无常故。若尔已说现在无常。不应复言何况现在。或应唯说现在无常。去来无常。由此已了。即现已灭未生位故。若一切时体恒有者。则无常性不应得成。辩世别中当如理释。且不应说无法无常。上座此中作如是释。即体无故名为无常。若体非无无无常理若尔现在应体是常。若现非无是无常者。则不应说无故无常。彼复难言若经三世自性恒住应说为常。此难不然。为如何等非有别法经于三世。自性恒住共许是常。一切是常皆不经世。又不应说性恒住言。许去来今有性异故。由此彼设过难不成。又彼释经说去来色是无常者现无体故。此释不然。由次后说何况现在。应许现在色非无常现有体故。由此为证非现无体故。是无常彼此极成。现在有体而无常故理必应尔。以契经言诸行无常。有生灭法非于无法。佛说无常然诸去来体虽实有。而可说是有生灭法。如是理趣我后当辩。且非无体亦可得说有无常相其理极成。是故应知去来实有。又布剌拏契经说故。知去来世决定实有。谓彼经说此满苾刍。眼见色已能了知色。了知色贪彼于有。内眼所识色贪能如实了知。我有内眼所识色贪乃至广说。非如实见与贪俱生。谓见相续中有贪随眠者此亦非理。有不成故设有成者见亦不成。实见随眠体无别故。非许有智缘自体境。如何可说能见随眠。若谓未修贪对治故。信有贪者理亦不然。应说此贪在何位故。谓设许彼信知有贪。应说信贪于何位有。若言贪有非去来今。应说如何信贪为有。不可常法说名为贪。是故必应信去来有。又契经说。于内受中随观而住。乃至广说。有如是等众多至教。能证去来决定是有。复有别理证有去来。谓彼若无无杀生理。以现在世命根刹那。离设劬劳灭相能灭。若未来世其体实无。应说如何成杀生事。能碍何法令其非有。为已生者为当生耶。且法已生必不可碍如前说故。其当生者亦不可碍都无有故。过去已灭杀义不成。故无去来定无杀理。又去来世体实非无。能缘彼觉有差别故。如现在世色声等法。诸非有法无差别故。缘彼不能起差别觉。诸有处俗及出家人。信有如前所辩三世。及有真实三种无为。方可自称说一切有。以唯说有如是法故。许彼是说一切有宗。余则不然有增减故。谓增益论者。说有真实补特伽罗及前诸法。分别论者唯说有现。及过去世未与果业。刹那论者唯说有现一刹那中十二处体。假有论者说现在世所有诸法亦唯假有。都无论者说一切法都无自性皆似空花。此等皆非说一切有。经主此中作如是谤。若说实有过去未来。于圣教中非为善说。若欲善说一切有者。应如契经所说而说。经如何说。如契经言。梵志当知一切有者唯十二处。或唯三世如其所有而说有言。为彼经中说唯有现十二处体非过未耶。不尔。若然为于余处见有明教遮过未耶。不见不闻处处经说。去来二世亦是有耶。我闻何缘违背圣教。谤说有者为非善说。又汝等说现十二处。少分实有少分实无。如上座宗色声触法如何是说一切有宗。有余但由烦恼增上。说一切法唯是假有。岂亦是说一切有宗。有余复由邪见增上。说一切法自性都无。彼亦说言现虚幻有。岂如此有而说有言。亦得名为说一切有。故为遮有补特伽罗。及为总开有所知法。佛为梵志说此契经。非为显成唯有现在一刹那顷十二处法。故诸憎厌实有去来。不应自称说一切有。以此与彼都无论宗。唯隔一刹那见未全同故

说一切有部顺正理论卷第五十一阿毗达磨顺正理论卷第五十二

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩随眠品第五之八

如是所许一切有宗。自古师承差别有几。谁所立世最善可依。颂曰

  此中有四种　　类相位待异
  第三约作用　　立世最为善

论曰。尊者法救作如是说。由类不同三世有异彼谓诸法。行于世时。由类有殊非体有异。如破金器作余物时。形虽有殊而体无异。又如乳变成于酪时。舍味势等非舍显色。如是诸法行于世时。从未来至现在。从现在入过去虽舍得类非舍得体。尊者妙音作如是说。由相有别三世有异。彼谓诸法行于世时。过去正与过去相合。而不名为离现未相。未来正与未来相合。而不名为离过现相。现在正与现在相合。而不名为离过未相。如人正染一妻室时。于余姬媵不名离染。尊者世友作如是说。由位不同三世有异。彼谓诸法行于世时。至位位中作异异说。由位有别非体有异。如运一筹置一名一。置百名百。置千名千。尊者觉天作如是说。由待有别三世有异。彼谓诸法行于世时。前后相待立名有异。非体非类非相有殊。如一女人待前待后。如其次第名女名母。如是诸法行于世时。待现未名过去。待过现名未来。待过未名现在。此四种说一切有中传说。最初执法转变故应置在数论朋中。今谓不然。非彼尊者说有为法其体是常。历三世时法隐法显。但说诸法行于世时。体相虽同而性类异。此与尊者世友分同。何容判同数论外道。第二第四立世相杂。故此四中第三最善。以约作用位有差别。由位不同立世有异。如我所辩实有去来。不违法性圣教所许。若拨去来便违法性。毁谤圣教有多过失。由此应知尊者世友。所立实有过去未来。符理顺经无能倾动。谓彼尊者作如是言。佛于经中说有三世。此三世异云何建立。约作用立三世有异。谓一切行作用未有名为未来。有作用时名为现在。作用已灭名为过去非体有殊。此作用名为何所目。目有为法引果功能。即余性生时能为因性义。若能依此立世有殊。或能作余无过辩异。智者应许名鉴理人。若有由迷立世别理。怖他难故弃舍圣言。或了义经拨为不了。许有现在言无去来。或许唯现仍是假有。或总非拨三世皆无此等皆违圣教。正理智者应斥为迷理人。诸有谤无实三世者。为无量种过失所涂。多设劬劳难令解脱。诸说三世实有论师。设有小违易令解脱。故有智者勿谤言无。然我且依尊者世友。约作用立三世有殊。随己堪能排诸过难。旦彼经主作是难言。若约作用立三世别。彼同分摄眼等诸根。现在前时有何作用。若谓彼能取果与果。是则过去同类因等。既能与果应有作用。有半作用世相应杂。此难都由不了法性。诸法势力总有二种。一名作用。二谓功能。引果功能名为作用。非唯作用总摄功能。亦有功能异于作用。且闇中眼见色功能为闇所违非违作用。谓有闇障违见功能。故眼闇中不能见色。引果作用非闇所违。故眼闇中亦能引果。无现在位作用有阙。现在唯依作用立故。诸作用灭不至无为。于余性生能为因性。此非作用但是功能。唯现在时能引果故。无为不能引自果故。唯引自果名作用故。由此经主所举释中。与果功能亦是作用。良由未善对法所宗。以过去因虽能与果无作用故世相无杂。然彼经主于此义中。迷执情深复广兴难。谓广论者不能善通。矫为我宗作理穷释。颂曰

  何碍用云何　　无异世便坏
  有谁未生灭　　此法性甚深

论曰。彼言若法自体恒有。应一切时能起作用。以何碍力令此法体。所起作用时有时无。此难意言。诸法体相既恒无别。以何碍力非一切时唯一性类。此难非理体相无别。于性类一非证因故。谓不可以体相无别。于性类一为能证因。现见世间体相无别。性类有别如前已辩。谓地界等受等眼等。或难意言。我宗诸行众缘和合本无而生。然彼众缘种种差别。有时和合有不合时。法不恒生可无过失。汝宗诸行及彼众缘。于一切时许常有体。勿许诸法本无今有。应常现在何能为碍。此亦不然前义成故。谓且前说体相虽同。而性类殊义已成立。而言诸行自体众缘于一切时许常有体。何碍令彼作用非恒。非一切时常现在者。若解前义此难应无。以体虽同而性类别。足能成立作用非恒。故彼不应作如是难。若犹固执应反诘言。汝宗众缘及所生行。亦有前后体相无差。而刹那刹那许渐渐有异。既前后念彼缘无差。何碍令其非无异起。而许后后转转有异。谓前念行与缘俱生。体相无亏与缘俱灭。由此因力后念果生应与前因品类无别。别无别类二种生缘。前后刹那无差别故。何缘为碍令后异前。若谓有为法性应尔。如何不许作用亦然。又受不应缘虽有异。而损益相无有差别。余心心所例亦应然。薪糠等缘虽有差别。而现见火暖相无异。故有为法体类多途。不可责令总为一例。于一切位性类无差。又说众缘许常有故。所生作用应常有者。亦不应理缘虽常合。而见有时缘果无故。如汝熏习或如眼等。谓汝不许从已灭因。隔中间时而有果起。多因所引种子差别。于相续中同时现有。而非彼果恒俱时生。然或有因所引种子。经多劫后方有果生。设于中间有果生者。生时及果俱不决定。既一切时一切因。有何碍诸果不恒俱生。而或一因此时生果此时不生。或有一时此因生果此因不生。又眼等缘虽恒现有。而眼等识非恒时生。是故不应作如是难。既许缘常有作用亦应常。若谓我宗相续转变。待别缘故方能生果。是则应许作用亦然。诸引果缘总有二种。一者俱生。二者前生。俱生缘中复有二种。一同聚生。二异聚生。异聚生缘复有二种。一有情数。二无情数。前生缘中亦有二种。一同相续。二异相续。异相续缘复有二种。一同相续聚生。二不同相续聚生。不同相续聚生复有二种。一有情数。二无情数。待如是等同不同时。自他相续众缘力故。诸法乃有引果功能。如是功能名为作用。故不应说许常有缘。作用亦应一切时有。众缘不可常和合故。又我未了具寿所言。意欲取何名为作用。而今征诘过去未来。何碍令其作用非有。即未来法众缘合时。起胜功能名为作用。此有作用名为现在。此作用息名为过去。非彼法体前后有殊。如何难言由何碍力。令去来世作用非有。此义意言即未来法。众缘合位有作用起。作用起已不名未来。此于尔时名已来故。作用息位不名现在。此于尔时已过去故。若作用犹在未得过去名。此法尔时名现在故。由此约作用辩三世差别。故彼设难由未了宗。如是我宗善安立已彼犹不了。又责作用云何得说为去来今。此难意言法由作用。可得建立为去来今。作用由谁有三世别。岂可说此复有作用。若此作用非去来今。而复说言作用是有则无为故应常非无。故不应言作用已灭。及此未有法名去来。对法诸师岂亦曾有成立作用为去来耶而汝今时责非无理。即未来法作用已生名为现在。即现在法作用已息名为过去。于中彼难岂理相应。非我说去来亦有作用。如何责作用得有去来。若说去来无有作用。应说作用本无今有有已还无。如仁所言我决定说。诸法作用本无今有有已还无。作用唯于现在有故。若尔作用是法差别。应说与法为异不异。若异应言别有自体。本无今有有已还无。诸行亦应同此作用。若言不异应说如何。非异法体而有差别。又宁作用本无今有有已还无。非彼法体我许作用。是法差别而不可言与法体异。如何不异而有差别。如何汝宗于善心内。有不善等别类诸法。所引差别种子功能。非异善心而有差别。又何种子非同品类。又彼上座即苦受体。如何说有摄益差别。又如诸受领纳相同。于中非无乐等差别。又如汝等于相续住。虽前后念法相不殊。外缘亦同而前后异。若不尔者异相应无。如火等缘所合之物。虽前后念粗住相同。而诸刹那非无细异。我宗亦尔法体虽住而遇别缘。或法尔力于法体上差别用起本无今有有已还无。法体如前自相恒住。此于理教有何相违。前已辩成体相无异。诸法性类非无差别。体相性类非异非一。故有为法自相恒存。而胜功能有起有息。若谓我许法相续时。刹那刹那自相差别。本无今有有已还无。汝许有为自相恒住。唯有差别本无今有有已还无。如何为喻。若我亦许自相本无。或汝亦言自相本有义则是一。岂应为喻。喻谓彼此分异分同。今于此中所引喻者。谓法相续自相虽同。而于其中非无差别。自相差别体无有异。且举自相相续恒存。不论法体住与不住。其中差别待缘而有。故非恒时许有差别。汝虽许法本无而生。不许念念有别相起。如何不应为同法喻。然汝许法前后刹那自相虽同而有差别。我亦许法前后位中。自相虽同而有差别。故为同喻其理善成。由此已成作用与体。虽无有异而此作用待缘而生。非法自体待缘生故。本无今有有已还无。亦善释通契经所说。本无今有亦善符顺。有去来经亦善遣除应常住难。以有为法体虽恒存。而位差别有变异故。此位差别从缘而生。一刹那后必无有住。由此法体亦是无常。以与差别体无异故。要于有法变异可成。非于无中可有变异。如是所立世义善成。经主于中复作是说。若尔所立世义便坏。谓若作用即是法体。体既恒有用亦应然。何得有时名为过未。故彼所立世义不成。此与我宗不相关预。谓我不说作用即体。如何令用与体俱恒。又我不言用所附体。一切时有即名过未。如何所立世义不成。汝说云何如我宗说。诸有为法差别作用。未已生位名为未来。此才已生名为现在。此若已息名为过去。差别作用与所附体不可说异。如法相续如有为法。刹那刹那无间而生名为相续。此非异法无别体故亦非即法。勿一刹那有相续故不可说无。见于相续有所作故。如是现在差别作用。非异于法无别体故亦非即法。有有体时作用无故不可说无。作用起已能引果故。依如是义故。有颂曰

  相续无异体　　许别有所作
  作用理亦然　　故世义成立

因果相属和合相应。心净性等皆可为喻。是故过去现在未来。体相虽同性类各别。由是所立三世义成。经主此中复作是说。彼复应说若如现在法体实有去来亦然。谁未已生谁复已灭。谓有为法体实恒有。如何可得成未已生已灭。先何所阙彼未有故名未已生。后复阙何彼已无故名为已灭。故不许法本无今有有已还无。则三世义。应一切种皆不成立。奇哉鲜福感如是果。所发觉慧大不聪明。不能谛观数无义语。宁于实义及圣教中。不设劬劳思惟简择能怀[怡-台+龍]戾。于实义中发勇悍心。指存违逆屡申正理曾不似闻。今更励声启灭经者。诸大德听非我宗言。过去未来如现实有。三世实有性各别故。大德不应随己所解。讪谤如理释佛教师。古昔大仙无不皆是一切智者。所垂光明善释契经。破诸愚闇令一切智名称普闻。大德何缘与迷圣教及正理者共结恶朋。讪谤如斯具胜功德增上觉慧佛圣弟子。陷无量众置恶见坑。幸愿从今绝无义语。如其不绝深有损伤。违逆牟尼至教理故。定不能证诸法真实。又未审知汝如何解我现在义。言如现在法体实有去来亦然。然我宗言诸有为法。能引果位名为现在。此引果位先无后无。前已约斯立三世异。宁言过未如现实有。又略说者如诸有为。实体虽同而功能别。如是三世实体虽同。于中非无作用差别。以有性类有无量种。故于我宗不可为难。依如是义故有颂言

  如色等皆苦　　许多苦性异
  三世有亦然　　未生有差别

是故现在过去未来。三种有性条然差别。宁如现在去来亦然依有可言有未生灭。约所无故未生灭成。谓于有中先阙作用。彼未有故名未已生。有法后时复阙作用。彼已无故名为已灭。故唯有中有未生灭。由斯建立三世理成。无中如何可立三世。谓若过未其体都无。谁未已生谁复已灭。故依彼立三世不成。又无不应名言依故。经说三世皆是言依。故知去来亦实有体。彼又轻调对法者曰。许体恒有说性非常。如是义言所未曾有。依如是义故有颂言

  许法体恒有　　而说性非常
  性体复无别　　此真自在作

彼于非处为轻调言。以佛世尊亦作是说。如来出世若不出世。如是缘起法性常住。而佛复说缘起无常。岂佛世尊亦可轻调。许法常住复说无常。如是义言所未曾有。若据别义说常无常。是故不应轻调佛者。岂不于此例亦应然。法体恒存法性变异。谓有为法行于世时。不舍自体随缘起用。从此无间所起用息。由此故说法体恒有。而非是常性变异故。如何讥是自在所为。对法诸师容作是调。许有三世拨无去来。如是义言所未曾有。虽言过未有据曾当。而但异门说现在有非关过未如先已说。依如是义故有颂曰

  虽许有三世　　拨已灭未生
  有更无第三　　岂非天幻惑

经主于此复作是言。又应显成雨众外道所党邪论。彼作是说。有必常有无必常无。无必不生有必不灭。此亦非处置贬斥言。已灭未生约异门说。俱许通有及非有故。谓去来世色等诸法。有有生灭所知法性。及有前生俱行果性。而无现在能引果性。有引果用名为现在。过去未来无如是性。此岂同彼雨众所说。唯有现在一念论宗。必定不能离同彼过。以说现世决定唯有。过未二世决定唯无。非许去来亦容是有。非许现在亦容是无。故同彼宗过极难离。若谓现有转成过无。从未来无转成现有。此亦非理有无别故。非有与无可转成一。如何现有转成过无。如何未无转成现有。非汝现在是有亦无。非汝去来是无亦有。现在唯有去来唯无。有无条然宁相转作。是故唯汝同雨众宗。然我所宗决定唯有。定唯无者皆不可生。现在马角不可生故。若谓马角由无因故不可生者。理亦不然招马果业应是角因。许角及身俱本无故。非无与无可有差别。彼因何故一有一无。经主此中复作是说。若执实有过去未来。则一切时果体常有。业于彼果有何功能。此亦不然体虽恒有。而于位别有功能故。谓业能令果起殊胜。引果作用是业功能。作用已生名现在位。故于位别业有功能。若业能令无转成有。招马果业何不为因。能令本无马角成有。依如是义故有颂曰

  若无可成有　　及有可成无
  许从色色生　　宁非马角受
  如马角与受　　非因果相属
  因色与果色　　无相属亦然
  相属理同无　　许从色生色
  非受与马角　　此真自在作

是故决定无体之法。必无有因亦无生理。何有憎背去来有宗。可有因果感赴相属。又若去来非实有者。能系所系如何得成。经主于此作是释言。彼所生因随眠有故。说有去来能系烦恼。缘彼烦恼随眠有故。说有去来所系缚事。此释意言。过去烦恼所生随眠。现在有故说有过去。能系烦恼未来烦恼。所因随眠现在有故。说有未来能系烦恼。缘过未事烦恼随眠。现在有故说有去来。所系缚事如是一切皆无义言。以相续中过去烦恼。所生现在烦恼随眠。理实都无如前已辩。如何由彼可得说言成就过去能系烦恼。设许现在有彼随眠。宁由有法说无成就以有与无不相属故。又若有果说成就因。异熟果生因应成就然汝不许。以汝宗言。诸异熟因所引能与。诸异熟果现在功能。异熟生时已灭无故。若无用故不成就者。彼亦应尔如何成就。不应过去烦恼已无。可言今时彼犹有用。今有用者唯是随眠。过去烦恼成何所用。设许有现未来烦恼。所因随眠亦不应说成就未来能系烦恼。勿因此有非爱过故。谓若有因说成果者。诸有已断善根有情。许有能生善根因故。亦应说彼成就善根。既彼善根亦成亦断。应定说彼是何有情。为断善根为不断者。又有学者有无学因。应说彼成阿罗汉果。则应有学是阿罗汉。若彼虽成阿罗汉果。而不说彼名阿罗汉。则阿罗汉成无学果。亦应不说名阿罗汉。或阿罗汉反应不成阿罗汉果。无差别故。是则一切圣教正理。由彼所言皆彼违害。是故若拨去来为无。定不应成去来烦恼。如何说有去来能系。又彼所言缘彼烦恼随眠有故。说有去来所系缚事。此亦违彼所立义宗。彼执去来体非实有事不成故。去来非有而名为事。如是言义曾所未闻。设许彼宗于现相续。有缘彼事烦恼随眠。此应条然与烦恼异。能引烦恼久已灭故。所引随眠现在有故。既条然异如何可言由现随眠系过未事。缘过未事现在随眠。曾未已生非能系故。又诸现在善无记心体非是结。不应能系过去未来所系事境。离心无有随眠可得。故彼所说都无有义。经主于此诡设谤言。毗婆沙师作如是说。如现实有过去未来所有于中不能通释。诸自爱者应如是知。法性甚深非寻思境岂不能释。便拨为无今定谓仁。窃自造论矫托题以毗婆沙名。真毗婆沙都无此语。又不如彼自率己情。妄说去来如现实有。三世实有性各别故。详彼意欲为圣教灾。诡设虚言谤正论者。岂由如是所设谤言。令我义宗有所亏损。宁有我部诸大论师。博究精通圣教正理。具包众德名称普闻。于小难中不能通释。故于非处诡设谤言。既率己情妄标宗致。似未披览真毗婆沙。所设难词我已通释。更有何难言不能通。我于前来正对经主决择过未。尽彼所能随彼言词皆已征遣。兼略征遣上座言词。然不随文广征遣者。以彼所说少有依俙。可准前来义征遣故。或有极浮浅不任推究故。或唯谤圣贤妄自夸诞故。若随彼说一一酬言。谁有智人闻不嗤诮。设不鉴者复托彼宗。矫饰文词妄兴过难。诸有达鉴好观论者。今应详审留心谛听。我从今去还依旧宗。随彼所言纵辩酬遣。且有一类鉴智盲徒。谓我所宗同黄仙执。此不应理以彼所宗。执因转变即为果体。果还隐没入自性中。故去来今其体是一。我宗所立世无杂乱。谓有作用唯现刹那。此位定非二世摄故。因果条然不相作故。诸法灭已不还生故。果不隐入自性中故。因无始故多因生故。因果非我所住持故。如是等类差别无边。宁谓我宗同黄仙执。有余复说定无去来。契经说为曾当有故。谓世尊说。诸聪慧者于过去世怀犹豫时。应为决言过去曾有。于未来世怀犹豫时。应为决言未来当有。曾不于彼说实有言。故知去来定非实有。此亦非理以曾当声。有时见于现在说故。然不可说现在亦无。又胜功能过去曾有。唯于现在有作用故。由此过去应得二名。自相实有用曾有故。由此准释未来二名。现在应名实有现有。现于实体有作用故。然三世事皆是言依。且于去来说不共义。为无杂乱故作是说。岂由此说非实有成。有余复言。若去来世是实有者。何缘不许染净二识俱时而生。此二识因皆实有故。此亦非理。诸识生时。要托所依所缘合故。设一切识所依所缘俱和合者。亦不应许眼等诸识俱时而生。如彼理趣此中亦尔。又汝亦应同此责故。汝宗既许本无而生。染净相违何不俱起。若作是说有因者生。岂不前言俱本无故。不可分别有因无因。差别因缘曾未说故。又说过未无体论者。旧随界等染净二因。现相续中恒俱有故。如是过难极切彼宗。我宗诸因非恒现故。有言。过去决定实无。已舍现在行自相故。不尔诸行体应是常。由此则应无解脱理。此亦非理。若言过去舍行自相。应非行摄。非体今无可名为行。既许是行则不应言舍行自相。非离自相别有行体。可得说言已舍自相唯有行体。又先已说。先说者何。非全无中有无常性。过去无体应非无常。我宗何故无解脱理。契经但言现苦已灭余苦不续。先取涅槃不言涅槃。要舍法相不舍法相。而有行灭名为涅槃如先已辩。又言过去若实有者应无涅槃。说阿罗汉有诸蕴时无涅槃故。又若过去苦常有者。则诸有情应无解脱。此亦非理。若言过去苦蕴有故则无涅槃。汝宗既言去来无体。苦蕴无故应恒涅槃。或诸有情本应解脱。过去众苦皆无有故。若谓但由现苦已灭余苦不续即名涅槃。则不应言由有过去众苦蕴故应无涅槃。又言去来定非实有。行相无故。行相者何。谓有初后去来二世。由各阙一故行相无。此亦不然。譬如生死虽阙一种行相成故。有情生死虽复无初。而不可言彼无行相。又彼现在过亦应同。谓拨实无去来论者。所执现在无初后故。又我过去具有初后。过去初者作用已生。从此后时说名为后。未来亦是有初有后。法性类故不应为难。又言去来若是实有。已断未断应无差别。不尔现在亦应同故。谓现在世已断未断。既无差别亦应是无。然诸染法不染一分断已不成不染一分断已虽成而无愚缚已断未断是谓差别。又言去来有便违教。谓圣教说此有彼有此无彼无。不应现有故未来有。不应过无故现在无。以执去来体恒有故。唯应现在或有或无。由此去来定非实有。今应审察经彼有言。为显有体显有生义。若显有体。汝宗有失。谓前经言此有彼有。汝彼现有此过去无。许行灭无识现有故。后经所说此无彼无。汝彼未无此现在有。许现行有识犹无故。汝引此教欲破我宗。如咒起尸自被害者。若谓彼有显有生义。谓有此因故方有彼果生。如说此因有彼舍利。不显有体但显有生。此于我宗全无有难。故去来世实有理成。对法诸师释彼有者。谓此有故令彼有生。非因能令法体成有。但能令法有作用生。若谓众缘所令有者。唯此是果法体应非。此难不然。无异体故。若尔体用应俱因成。此亦不然。如先已说。先何所说。作用与体虽无别体而有差别。谓众缘合能令法体有异分位差别而生。此差别生非异法体。故彼法体假说生义。依如是义故有颂言

  从众缘方有　　此有是世俗
  虽生体无别　　此有是胜义

又言无未来受用无尽故。非未来世受用可尽。此亦非理。如生死法用无尽期有极成故。无有情类本无而生。无数有情久已灭度。而生死法受用无尽。以此现在比知未来。虽无尽期而非不有。又言去来有相无故。谓变碍故说名为色。去来不然。故非实有。此亦非理。约少分故。谓非一切现在诸色皆有变碍。然非是无或应如识许是实有。如契经言。了别了别故名为识。何所了别谓了别色。至了别法非汝所宗。识缘过未有所了别然许识体是有非无现在有故。由此彼说遮有不成。又言去来体非实有。若是实有应障碍故。谓有色物必据处所。互相障碍已灭未生。色若实有应有障碍。既无障碍应非是色。由有此失故知实无。此亦非理如汝宗说。非有而生彼法阙故。谓如汝说非有而生唯未来生定非过去。如是我说有法障碍。唯现有碍定非去来。现在位中有别用故。有余师说。未来世灯为已然不。若已然者与现在灯应无差别。若不然者应体非灯。此责不然。唯有体故。谓去来世体有用无体。谓去来所知法性有所知性。故说为有。非谓去来有然等用。或应如识许是实有。如汝许有无所缘识无所了别而体非无。我未来灯亦复如是。虽无然用而体非无。又言去来非眼取故。若去来色是实有者。何故不为眼所取耶。此亦不然。眼根唯以有胜用色为境界故。三世诸法体相虽同。而有性异。如前已辩。不可以眼色为境故。便抑难令取一切色。一极微色不可取故。由此取现不取去来。位别用殊不应为难。又言彼无有为相故。谓去来世有为相无。又非无为故非实有。此亦非理。彼法性故。谓未来是可灭法性。现在世是正灭法性。过去世是已灭法性。故彼皆非离有为相。诸可生法因力故生。此法生义如前已辩。诸不生法是生法种类。故彼亦受可生法性名。所以不生由缘阙故。此缘阙义如前已辩。或应以识为同法喻。如汝许有缘无境识。无所了别而体非无。如是汝心谓去来世无有为相何。妨是有。又汝现在不应有生。体已生故。非有住异才生无间许即灭故。亦无有灭。以汝所宗。灭名为无。现是有故。又汝宗许诸有为相依相续立。非一刹那故。汝刹那亦应非有

说一切有部顺正理论卷第五十二阿毗达磨顺正理论卷第五十三

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩随眠品第五之九

因辩随眠。于如是位系如是事。傍论已了。今于此中复应思择。诸事未断彼必被系耶。设事被系彼必未断耶。若事未断彼必被系。有事被系而非未断。系非未断其相云何。颂曰

  于见苦已断　　余遍行随眠
  及前品已断　　余缘此犹系

论曰。且见道位苦智已生集智未生。见苦所断诸事已断。见集所断遍行随眠。若未永断能缘此者于此犹系。及修道位随何道生。九品事中前品已断余未断品。所有随眠能缘此者于此犹系。及声兼明。前前已断。后后未断。皆能系义。此中何用说缘此言。修断九品必相缘故。非是所缘者有时非所缘。故缘此言定为无用。若谓别说有不能缘即遍行中亦应简别。以有见集所断遍行。不缘见苦所断事故。经主何意简此非彼。今详经主或作是思。此中所言前品已断。约世俗道随其所应。总分见修所断烦恼。以为九品渐次断除。前品已断中有余未断品。遍行烦恼亦能为系。简缘他地遍行随眠。说缘此言可成有用。然于前说余遍行中。阙缘此言义不成立。或应以后所说及声。兼显前文摄缘此义。谓于前说见苦已断。及此前品已断事中。皆有所余缘此犹系。此文杂乱于见位中。余及遍行应随去一。然此烦说阙缘此言。应问慈尊自言意趣。何事有几随眠随增。此中但应辩所缘相。谓辩何法何识所缘。则易了知此所系事。定有尔所随眠随增。且法与识数各有几。诸法虽多略为十六。三界五部及诸无漏。能缘彼识名数亦然。此中何法为几识境。颂曰

  见苦集修断　　若欲界所系
  自界三色一　　无漏识所行
  色自下各三　　上一净识境
  无色通三界　　各三净识行
  见灭道所断　　皆增自识行
  无漏三界中　　后三净识境

论曰。若欲界系见苦见集修所断法各五识缘。谓自界三即如前说。及色界一即修所断。无漏第五皆容缘故。且欲界系见苦断法。为自界三识所缘者。谓欲见苦所断一切。及欲见集所断遍行。欲修所断善无记识。色修所断善识非余。无漏识中唯法智品。见集修断如应当知。若色界系即前所说。三部诸法各八识缘。谓自下三。皆如前说。及上界一即修所断。无漏第八皆容缘故。且色界系见苦断法。为自界三及上界一识所缘者。准前应知。为下界三识所缘者。谓欲见苦见集所断。上缘相应修断善识。若无漏识唯类智品。见集修断如应当知。若无色系即前所说。三部诸法各十识缘。谓三界三。皆如前说。无漏第十皆容缘故。准色界系如应当知。见灭见道所断诸法。应知一一增自识缘。此复云何。谓欲界系见灭所断为六识缘。五识即如前增欲见灭断。见道所断义准应知。色无色系见灭道断随应为九。十一识缘八十如前各增自识。若无漏法为十识缘。谓三界中各后三部。即见灭道修所断识。无漏第十皆容缘故。不委释者如应当思。应以如前所略建立十六法。识蕴在心中。思择随眠所随增事。恐文烦广略示方隅。且有问言。所系事肉眼根有几随眠随增。应观眼根总唯有二。谓欲色界各修所断。此随所应欲色修断。及彼遍行随眠随增若有问言。缘眼根识。复有几种随眠随增应观此识总有八种。谓欲色界各有三识。即见苦集所断遍俱。及修所断合而成六。无色界一即修所断。空处近分所摄善识。无漏第八皆缘眼根。且应了知一切无漏。决定不为随眠随增。前七随应欲色各三部。无色修断遍随眠随增。谓欲界系见苦所断遍行俱识。欲见苦断见集断遍随眠随增。翻此应知见集断识。修所断识欲修所断。及诸遍行随眠随增。准此应知。色界三识无色善识。能缘第四静虑眼根。无色修断及彼遍行随眠随增。若复有问言。缘缘眼根识。复有几种随眠随增。应观此识有十三种。谓于三界各有四识。除见灭断合成十二。并诸无漏识能缘缘眼根。此随所应三界四部。除见灭断随眠随增。谓欲界系见苦所断。遍行俱识能缘眼根。此识容为欲见苦断见集断遍。修道所断善无记识。及色界系修断善识。并法智品无漏识。缘此诸能缘缘眼根识。随应欲界见苦见集。修道所断色修所断。及彼遍行随眠随增。余随所应当如理释。乃至无漏缘眼根识。此识容为三界所系。见道所断无漏缘识修所断善无漏识。缘此诸能缘缘眼根识。随应三界见道所断。修所断遍随眠随增。若别疏条前十二种。各有尔所随眠随增。应言欲界见苦所断诸缘缘识欲见苦断见集断遍随眠随增。翻此应知见集断识修所断识。欲修所断及诸遍行随眠随增。见道断识欲见道断。及诸遍行随眠随增。然无漏缘唯相应缚。所余但作所缘随增。准此应知色无色界有差别者。见道断识欲界上界如次应知。缘法类品缘眼根识余所系事例眼应思。今于此中复应思择。若心由彼名有随眠。彼于此心定随增不此不决定。谓彼随眠未断随增非已断故。如本论说。彼于此心或有随增或不随增。云何随增。谓彼随眠与此心相应及缘心未断。云何不随增。谓彼随眠与此心相应已得永断。何等名曰有随眠心。有随眠名依何义立。复由何等名有随眠。且前所言三界各五部十五种识名有随眠心。如是诸心各有二种。谓遍非遍行有漏无漏。缘染不染心有差别故。依二义立有随眠名。一是随眠所随增故。二以随眠为助伴故。由随眠故名有随眠。相应随眠通断未断。所缘唯未断心名有随眠。云何与心相应烦恼。乃至未断于心随增。谓彼随眠能引起得。于心相续能为拘碍。又与来世为同类因。引相续中心等流起故。乃至未断说于心随增。断则不然无随。增义非由断故令彼离心。故虽已断而名有彼。以助伴性不可坏故。谓对治力于相续中。能遮随眠令不现起。及能遮彼所引起得。于心相续不为拘碍。故说已断相应随眠无随增理。非对治力能遮随眠俱行伴性故。彼虽已断心名有随眠。若诸随眠缘心未断。随心断未断于心随增故。恒令心得有随眠名。若彼缘心随眠已断。心不由彼名有随眠。道力令心离随眠故。虽为助伴及能所缘。俱非道力能令相离。而对助伴能所缘疏故。此有名唯据未断助伴性亲断亦名有。此中身见相应之心。由所相应无明身见。随增伴性名有随眠由自部余见集断遍。唯随增性名有随眠。所余俱非故非有彼。其余见苦见集所断。遍不遍心如理应思。见灭所断邪见俱心。由所相应无明邪见。随增伴性名有随眠。由自部摄有漏缘遍。唯随增性名有随眠。所余俱非故非有彼。其余见灭见道所断若缘无漏缘有漏心。如其所应例应思择。修道所断贪相应心。由所相应无明及爱。随增伴性名有随眠。由自部余及诸遍行。唯随增性名有随眠。所余俱非故非有彼。余修所断烦恼俱心。如其所应例应思择。诸修所断不染污心。由自部摄随眠及遍。唯随增性名有随眠。如是所论皆约未断。彼若断已有伴性者。唯由伴性名有随眠。依此义门应作是说。颂曰

  有随眠心二　　谓有染无染
  有染心通二　　无染局随增

论曰。有随眠心总有二种。有染无染心差别故。于中有染所有随眠。若未断时相应具二所缘唯一。若已断时相应有一所缘都无。彼无染心所有烦恼。唯未断位名有随眠。断已都无非助伴故。此缘无染所有随眠。在有心前或俱时断。断缘染者通前后俱。相应与心必俱时断。故染通二名有随眠。无染局一有随增性如上所辩。十种随眠次第生时谁前谁后。诸随眠起无定次第。可一切后一切生故。然有一类烦恼现行。前后相牵非无次第。今且就彼辩次第者。谓有一类不善观察。由邪闻力宿习力故。因缘所引无我行中。最初欻生我我所见。次于如是所计行中。迷因谓常。迷果谓断。堕断边者便增邪见。执为最胜。即是见取。堕常边者为我得乐离众苦故。事自在等修胜生因及解脱道。起戒取已。于诸邪师。执因道中有差别故。无师为决遂复生疑。诸所执中谁真谁妄。随谓一胜于彼起贪。计为己朋恃而生慢。于他朋见陵蔑起嗔。若于其中不决真妄。疑所扰乱于观生劳。起厌怠心便自谏止。终难决定何用观察。胜仙能了非我所知。彼既自摧勤观察志。便背观察爱乐无知。由此息心憩无明室。是为一类十种随眠相牵现行前后次第。复有一类禀性愚痴。于诸沙门梵志所说。不能审察胜劣有殊。遂复生疑。此中谁胜。因此观察堕我见者。由我见力便执断常。为我当来得乐离苦。便妄计执颠倒果因。若观察时堕无我者。不了真实无我理故。便拨无有施等果因。于此见中执为最胜。由见胜德于中起贪。因此于中陵他起慢。于余见趣憎背起嗔。彼由如斯顺违欢戚。便起无量烦恼杂染。远正等觉所说圣教。沉沦苦海拔济为难。复有于斯别立次第。颂曰

  无明疑邪身　　边见戒见取
  贪慢嗔如次　　由前引后生

论曰。谓诸烦恼次第生时。先由无明于谛不了。不欲观苦乃至道谛。由不了故无观察能。既闻二途便怀犹豫。为苦非苦乃至广说。若遇邪说便生邪见。拨无苦谛乃至广说。于取蕴中既拨无苦。因此便起萨迦耶见。从此复执我有断常。随执一边计为能净。于如是计执为第一。见已见德缘之起贪。谓此胜他恃而生慢。于他所起违见生嗔。如执我徒憎无我见。或于己见取舍位中。必应起嗔憎嫌所舍。此依一类辩十随眠。相牵现行前后次第。理实烦恼行相无边以所待缘有差别故。无有决定次第而生。故上所论略标一二诸烦恼起。由几同缘此起因缘乃有多种。或同分是此起因缘。谓见有情随众同分。定有此类烦恼现行。如鸽鸳鸯贪最猛盛。蚖蛇蝮蝎嗔最炽然。如是所余随类应说。或富乐是此起因缘。谓多有情具善意乐。堪逮殊胜。由获富乐。起诸烦恼便无堪能。要舍富乐方堪逮胜。或方域是此起因缘。谓生南方贪多猛盛。生北方者嗔多炽然。如是余方随应当说。或邪论是此起因缘。谓习兵书便增嗔恚。听倡逸论便长欲贪。学外道书愚痴转盛。若闻正法烦恼不生。由怖生死贪等息故。或寡闻是此起因缘。谓无知人烦恼炽盛。诸多闻者烦恼轻微。以习多闻伏烦恼故。或多眠是此起因缘。谓多睡眠烦恼增长。或乐等是此起因缘。谓乐增贪苦增嗔等。或饮食是此起因缘。谓饮酒等烦恼炽盛。或年位是此起因缘。谓少壮老起烦恼异。或数习是此起因缘。谓习此惑此便增盛。或身境是此起因缘。谓遇与身相称境界。随应便发此类烦恼。或时分是此起因缘。谓有有情于此时分。随应便发此类烦恼。如是等类因缘无边。然于其中胜唯三种。颂曰

  由未断随眠　　及随应境现
  非理作意起　　说惑具因缘

论曰。由三因缘诸烦恼起。且如将起欲贪随眠。未断未遍知欲贪随眠故。顺欲贪境现在前故。缘彼非理作意起故。余随眠起类此应知。未断未遍知欲贪随眠者。三缘故说未断遍知。谓得未断故。对治未生故。未遍知境故。又断有二。一有分断。二无分断。故说未断未遍知言。此说随眠由因力起。顺欲贪境现在前者。且应征问此境是何。若谓于中有欲贪系。亦嗔所系应名嗔境。则顺嗔境亦顺欲贪。如是欲贪境无定故。不应说有顺境现前。若谓可意名顺贪境。此可意境亦非决定。一所爱境余不爱故。若谓遍依一相续说。非不决定亦不应理。现见一色于一有情。有时顺情有时违故。然必应许有定境界。缘彼方有欲贪现前。由此故言顺贪境现。向所设难后当通释。此则说随眠由境界力起。缘彼非理作意起者。谓有如木境界现前。及有如钻燧非理作意起。钻境界木欲贪火生。此中何名非理作意。谓于上妙衣服花鬘严具。涂香雕妆彩饰娇姿所显女想粪聚。起有情想所住持心俱。颠倒警觉名非理作意。此则说随眠由加行力起。若诸随眠起皆具三因缘。云何许有阿罗汉退。非阿罗汉随眠未断。且非定许烦恼现前。方得名为阿罗汉退。或此且据从前烦恼无间引生故说无过。以烦恼生总有二种。一从烦恼无间引生。二次所余非烦恼起。若异此者善无记心无间不应有烦恼起。此中不据次所余生。是故不应举退为难。或此且据具因缘说。实有唯托境界力生。譬喻部师作如是说。由分别力苦乐生故。知诸境界体不成实。以佛于彼摩建地迦契经中说。诸癞病者触苦火时以为乐故。又说一色于一有情。名可意境。非于余故。又如净秽不成实故。谓别生趣同分有情。于一事中取净秽异。既净秽相非定可得。故无成实净秽二境。正理论者作如是言。一切境界无不成实。经说有色乐随行故。又说贪着可爱色故。又言有可爱眼所识色故。又意近行境决定故。又契经说。如是色中。净妙相没过患相现。然为断贪说于可爱可嗔痴事。应断贪者。此依不净了知净界。由于此中有净界故。说诸母邑为可爱境。又离贪者不观彼故。又契经说。诸色聚中。皆有爱味过患相故。理亦应尔。见诸事中。诸烦恼生有差别故。谓于可意诸境事中。虽有生嗔非如贪重。未离贪者遇可意事时。任运生贪。分别起嗔故。以因加行虽无差别。而见烦恼现行别故。知诸境体非不成实。由境界力令彼别故。岂不已显境不成实。许一事中起贪嗔故。不尔一聚中容有二境故。谓可意聚中有少可嗔相。如妙衣服少被粪涂。诸乐净人总生憎恶。又如于蒜憎其香者。于其味等亦总生嫌。于彼味中有生贪者。于彼香等亦总生爱。故知诸法同聚俱生。谓一聚中有可贪等法。故于一聚容起贪嗔痴。非起贪境即起余二。故诸境界无不成实。若尔既有成实净相。随观净见应皆如实。乘如实见应不生贪。然于境中无实净相。妄计为净乘此生贪。故知诸境皆不成实。不尔说境非成实者。取不净见同此失故。谓无成实不净相中。随观不净应非如实。此复如何能伏烦恼。若伏烦恼由胜解力。是则不应作如是计。要如实见方能离贪。起贪要由不如实见。然应境事虽亦实有少分净相。由胜解力观为不净能伏烦恼。虽亦实有少分不净。而增益故于中起贪。又若诸法无成实性。但由分别力起贪或离贪。圣教如何可作是说。此事可厌此事可欣。此事顺结此不顺结。此事应修此不应修。又若一事或有起爱起恚起痴。即言境中可爱等相。不成实者岂不曾闻。有怀僻见所作颂义理亦应成。如彼论中有如是颂

  以有于一事　　见常见无常
  见俱见俱非　　故法皆无性

若尔颠倒亦应不成。于实净中取为净故。不尔此中于少净种。由作意力增益转故。谓于可意不可意境。作意增益不净净相。由此颠倒起嗔起贪。非增益依亦不成实。故于少种由作意力。增益而转非不颠倒。又贪等乐等于境界生无有决定故。境虽成实而颠倒体非不得成。若尔善心亦应成倒。有取可意境为不可意故。不尔如是胜解作意。能断烦恼故非颠倒。有善作意由胜解力。于境界中唯取净相。云何非倒。非此胜解于诸烦恼有断力故。彼为自观于贪已断有势力不。故虽于境取净相转而非颠倒。或今但念如昔染心所取境相。为自观察所得修果为成不成。无别增益故非颠倒。或善作意于诸事中。随应但缘净不净相故非颠倒。贪等作意于诸事中。随应总缘为净不净故不同善。然彼所言由分别力。苦乐生故境不成实。摩建地迦经为证者理必不然。现见有于非所欲境亦生贪故。不尔便为拨境界力又现见有由根过故。于甘等味颠倒而取。于冷暖等颠倒亦然。彼不可言此由境界不成实故遂致如是。又说一色于一有情名可意境。非于余故。知诸境界不成实者。理亦不然前己说故。前说一聚容有二境。谓一聚中容有可意不可意种。于中增益遂总谓为可不可意有说。约位境体成实。谓于此时境成可意非不可意。余位相违。又如净秽不成实故。知无成实净秽境者理亦不然。于不净中计净颠倒应不成故。谓若都无成实不净。设取为净如何得成。于不净中净想颠倒。既许一境亦净不净。于中起想何倒非倒。又如于非常常想成倒。故知不净性决定成实。或于有漏行通取常非常应非常性亦不成实。或如非常性不净性亦尔。故净不净非不成实。言别生趣同分有情。于一事中取净秽异。知无成实净秽境者。理亦不然。前释一聚容有二境义已成故。言净秽相非定可得。故无成实净秽境者。理亦不然。准前说故。谓非无相有净秽性。性若无者颠倒不成。故不应言相不可得。便为净秽不成实因。又佛世尊于有漏法。决定成立有不净性。其义云何。谓有漏法为烦恼所染名胜义不净。故知净秽非不成实。若尔岂不诸有漏法皆是不净。或有于中起净妙觉。此觉境界既不成实。余例应然此觉所增虽不成实。而不净境是成实故。于中谓净颠倒义成。后贪起时随此净见。故所增相虽不成实。而无所缘非成实过。又先已说不净聚中有少净种。净种净性无异体故。净境非无但由于中总增成倒。又色等法有净自体。但由有漏立不净名。故一切境非不成实。有余师说。依五识身所起烦恼境界成实。非于一境二心转故。五识唯取现在境故。所取色等刹那性故。所余烦恼境不成实。由一刹那取色等已。后相续起异分别故。此亦应就总聚遮遣。谓于过去可爱聚中。有可增境能发嗔恚。先缘可爱于聚生贪。后忆可憎于聚生恚。是故意地所起烦恼所缘境界非不成实。即上所说随眠并伴。佛说为漏瀑流轭取。漏谓三漏一欲漏。二有漏。三无明漏。言瀑流者。谓四瀑流。一欲瀑流。二有瀑流。三见瀑流。四无明瀑流。轭谓四轭。如瀑流说。取谓四取。一欲取。二见取。三戒禁取。四我语取。如是漏等其体云何。颂曰

  欲烦恼并缠　　除痴名欲漏
  有漏上二界　　唯烦恼除痴
  同无记内门　　定地故合一
  无明诸有本　　故别为一漏
  瀑流轭亦然　　别立见利故
  见不顺住故　　非于漏独立
  欲有轭并痴　　见分二名取
  无明不别立　　以非能取故

论曰。欲界烦恼并缠除痴。四十一物总名欲漏。谓欲界系根本烦恼三十一并十缠。色无色界烦恼除痴。五十二物总名有漏。谓上二界根本烦恼各二十六。色无色界虽复亦有惛沉掉举。而缠不应依界分别。上界缠少不自在故。由是有漏唯说烦恼。若缠亦依界分别者。则有漏体有五十六。故品类足作如是言。云何有漏。谓除无明。余色无色二界所系。结缚随眠随烦恼缠。何缘合说二界烦恼为一有漏。同无记性。于内门转依定地生。由三义同故合为一。彼界烦恼亦于外门有缘色声触境转故。应更别说第二合因谓彼随眠同一对治。设依此义无坏颂文。谓此应言何缘合说。二界烦恼为一有漏同无记对治定地故。合一何缘唯彼得有漏名此即如前名有贪释义准三界十五无明。为无明漏体故颂不别说。何缘唯此别立漏名为显无明过患胜故。谓独能作生死根本。如契经说。无明为因生于贪染乃至广说。又如颂曰

  诸所有恶趣　　此及他世间
  皆无明为根　　贪欲所等起

已辩三漏复应思择。如本论说。结缚随眠随烦恼缠为前二漏。若具五义方得漏名。是则十缠应非漏体。若随具一便得漏名。染思恨等亦应名漏。则上所结物数唐捐今于此中唯据胜显说一百八诸惑为漏。谓非染污思等恨等非漏所摄。唯此诸惑稽留有情久住生死。或令流转于生死中从有顶天至无间狱。用强易了。是故偏说。瀑流及轭体与漏同。然于其中见亦别立。谓前欲漏即欲瀑流及欲轭。如是有漏即有瀑流及有轭。析出诸见为见瀑流及见轭者。以猛利故。谓漂合执义立瀑流轭取。如余烦恼但除无明总互相资能漂合执。诸见亦尔由猛利故离余相助能漂合执故亦别立瀑流轭取。又诸烦恼皆令众生漂沦染法。离诸善品无解邪解。涌泛波涛漂激众生。于善更远。故无明见于此别立。若尔何不别立见漏令住名漏。如后当说。见不顺彼义有别故。谓令异生及诸圣者。等住生死故名为漏。诸见无有令圣住能。漏义不全故不别立。漂合执义圣异生殊。故后三门皆别立见。谓此诸惑能漂异生。容有令离一切善品。漂诸圣者则不可然。漂已能令诸异生类。遍与非爱界趣生合。令圣者合则不可然。合已能令诸异生类。无不依执令圣不然。由此三门异生异圣。于中见胜是故别立。有余师说。见躁利故于令住义独不能辩。故于漏门与余合立。若与余合便有住能。如于调象王系缚生象子。如是已显二十九物名欲瀑流。谓贪嗔慢各有五种。疑四缠十二。十八物名有瀑流。谓贪与慢各十疑八。三十六物名见暴流。谓三界中各十二见。十五物名无明暴流。谓三界无明各有五。应知四轭与瀑流同。四取应知体同四轭。然欲我语各并无明。见分为二。与前轭别即前欲轭并欲无明三十四物总名欲取。谓贪嗔慢无明各五。疑有四并十缠即前有轭并二界无明三十八。物总名我语。取谓贪慢无明各十疑有八。于见轭中除戒禁取。余三十物总名见取。所除六物名戒禁取。由此独为圣道怨故。双诳在家出家众故。何缘无明不别立取依能取义建立取名。然诸无明非能取故。谓不了相说名无明。彼非能取不猛利故。但可与余合立为取。余建立取及广决择。如缘起中应如理解。瀑流轭取若能总摄一切烦恼便违契经。如契经言。云何欲轭谓愚夫类。无闻异生不如实知。诸欲集没爱味过患。及与出离。乃至广说。彼于诸欲欲贪欲欲。欲亲欲爱欲乐欲闷。欲耽欲嗜欲喜欲藏欲随欲着。缠压于心是名欲轭。有轭见轭应知亦尔。此于爱体说三轭名。又余经说欲贪名取。由此故知于欲等四所起欲贪名欲等取。如何具摄诸烦恼耶。此不相违经意别故。就所化者机行差别。密意说故犹如瀑流。谓契经说。有四瀑流。然余经中佛观所化机行差别说如是言。苾刍若能多住于此。便为已渡前五瀑流。第六瀑流亦当能渡。云何知此是密意言非唯以爱为三轭体。以契经中说有九结。结之与轭义类相似。故知烦恼皆有轭相。佛观所化机行所须。于多体中且略举一。又如经说。若断一法。我能保汝得不还果。一法者。谓萨迦耶见。非唯断此得不还果。又如经说。应断害忿非余烦恼不应断害。又如说无明能盖有情类。然于余处说盖有五。此经亦尔。随所化生现相续中。为爱所恼故略为彼说爱无失。欲有二轭可略举爱爱彼摄故。见轭云何。爱与见轭性各别故举亦无失。以见轭名依训释门通二义故。若见即轭名为见轭如无明轭。若于见轭名为见轭。犹如有轭佛令弟子知二义故。虽亦于爱立见轭名。而亦无有违法性失如是已辩随眠并缠。经说为漏瀑流轭取。此随眠等名有何义。颂曰

  微细二随增　　随逐与随缚
  住流漂合执　　是随眠等义

论曰。根本烦恼现在前时。行相难知故名微细。是故圣者阿难陀言。我今不知于同梵行起慢心不。不说全无以慢随眠行相微细。彼尚不了慢心有无。况诸异生余例应尔。有释。于一刹那极微亦有随增故名微细。二随增者。谓于所缘及所相应。皆随增故。如何烦恼有于所缘相应随增。如前已辩。或如怨害伺求瑕隙。及如见毒。应知烦恼于自所缘有随增义。如热铁丸能令水热及如触毒。应知烦恼于自相应有随增义。二皆同乳母令婴儿随增。乳母能令婴儿增长。及令伎艺渐次积集。所缘相应令诸烦恼相续增长及得积集。言随逐者。谓无始来于相续中起得随逐。言随缚者。极难离故。如四日疟及鼠毒等。有说。随缚谓得恒随。如海水行随空行影。由此所说诸因缘故。十种烦恼立随眠名。依训词门释此名者。谓随流者相续中眠故名随眠。即顺流者身中安住增惛滞义。或随胜者相续中眠故名随眠。即是趣入如实解位为惛迷义。或有狱中长时随逐。覆有情类故名随眠。何缘随眠唯贪等十。非余忿等。唯此十种习气坚牢非忿等故。谓唯此十习气坚牢。起便难歇如担山火。或如怨结。故名随眠。若尔恨应是随眠性。不尔随眠任运转故。要设功用恨方随转。然诸随眠性尤重故。不设功用亦坚固转。或恨随嗔有所作故。谓诸恨垢是嗔等流随嗔所为方有所作。忆念种种嗔恚相时。随嗔所为结恨不舍。故无恨垢成随眠失是为训释。建立随眠稽留有情久住生死。或令流转于生死中。从有顶天至无间狱。由彼相续于六疮门泄过无穷。故名为漏。极漂善品故名瀑流。于界趣生和合名轭。执取彼彼自体名取。经主此中复作是说。若善释者应作是言。诸境界中流注相续泄过不绝。故名为漏。若势增上说名瀑流。谓诸有情若坠于彼。唯可随顺无能违逆。涌泛漂激难违拒故。于现行时非极增上。说名为轭。但令有情与种种类苦和合故。或数现行故名为轭。执欲等故说名为取。彼有何善。释四名中。二与我同。二违理故。谓彼所说诸境界中。流注相续泄过不绝。故名为漏。即我宗说由彼相续。于六疮门泄过无穷。故名为漏。非离诸漏有别相续。由彼势力于境泄过。即诸烦恼或总或别。流注不绝得相续名。说于六疮门即说于六境。彼言不绝即我无穷。与我何殊独言彼善。彼势增上说名瀑流。即我宗言极漂善品。与我何别。彼独善耶。言现行时非极增上说名为轭。令与种种苦和合故。此与理违。于现行时若非增上。何能令与种种苦合。如何可说彼释为善。又诸善法数数现行。亦令有情与众苦合。应与烦恼俱立轭名。若言我释亦同此过。此难非理。我说烦恼由发业门。有此能故所释取义亦与理违。谓若取名唯因爱者。说取缘有义如何成。应但说言爱缘有故。又如前际后际业缘。亦应通摄一切烦恼。如缘起中已广思择。由彼所释违正理故。毗婆沙师不作是说

说一切有部顺正理论卷第五十三阿毗达磨顺正理论卷第五十四

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩随眠品第五之十

如是已辩随眠并缠。世尊说为漏瀑流等。为唯尔所为更有余。颂曰

  由结等差别　　复说有五种

论曰。即诸烦恼结缚随眠。随烦恼缠义有别故。复说五种且结云何。颂曰

  结九物取等　　立见取二结
  由二唯不善　　及自在起故
  缠中唯嫉悭　　建立为二结
  或二数行故　　为贱贫困故
  遍显随惑故　　恼乱二部故

论曰。结有九种。一爱结二恚结三慢结四无明结五见结六取结七疑结八嫉结九悭结。以此九种于境于生。有系缚能故名为结。如契经说。苾刍当知。非眼系色非色系眼。系谓此中所有欲贪。又契经说。诸愚夫类。无闻异生结缚故生。结缚故死。由结缚故从此世间往彼世间。或有此故令诸有情合众多苦故名为结。是众苦恼安足处故此中爱结谓三界贪。此约所依及所缘故。所言贪者。谓有心所乐。可意想所摄受行。即于诸有及诸有具。所起乐着说名为贪。何缘此贪说名为爱。此染心所随乐境故。恚谓于违想及别离欲所摄。受行中令心增背。慢谓七慢。如前已释。言无明结者。谓三界无知。此约所依非所缘故。以诸无漏法不堕界故。无明亦用彼为所缘故。此广分别如缘起中。见结取结俱邪推度相。别显彼相广如五见中。于前分别边执见处。见计为我有漏行中。计断计常名边执见。于中断见名何所目。谓执死后行不续生。岂不此即是拨后有邪见。虽有此责现见世间。有行相同而体差别。如慈与爱体异行同如何行同而体差别。如起加行欲饶益他。若属染心从爱所起。若从慈起属不染心。是谓行同而体差别。如是于行见不续生。从邪方便生此属断见。离方便而起此属邪见。亦是行同而体差别。此断常见由何而生。且断见生或由寻伺。见诸行法有穷尽故。于缘起理不觉了故。或由定力于他有情许有烦恼。彼命终后不见中生二有续故。宿住随念智有碍故。由如是等有断见生。若常见生或由寻伺。见行相似相续转故。能忆先时所更事故。受持外道常见论故。或由定力随念宿住所更事故。如有颂言

  由观见死生　　或忆念前际
  以阙正道故　　外仙我见增

此中三见名为见结。见戒禁取名为取结。依如是理故有说言。颇有见相应法为爱结系非见结系。非不有见随眠随增。曰有。云何集智已生灭智未生。见灭道所断二取相应法。自部爱结为所缘系非见结系。遍行见结已永断故。自部见结所缘相应二俱无故。非不有见随眠随增。二取见随眠于彼随增故。何缘三见别立见结。二取别立为取结耶。三见二取物取等故。谓彼三见有十八物。二取亦然故名物等。说此物等于义何益。于结义中见有益故。此言意说如贪嗔等。一一独能成一结事。三见二取各十八物。和合各成一结事故。若异此者应说五见各为一结。如贪嗔等故见及取各十八物。共立一结方敌贪等。若尔身见边见见取有十八物。戒取邪见十八亦然。岂非物等。不尔本释其理决定。所以者何。以取等故三见等所取二取等能取。所取能取有差别故。谓于诸行计我断常。或拨为无后起二取执见第一。或执为净不杂乱故本释为善。有说。由物及声等故。有说。贪著有及财者见结于彼系用增上。若有贪着涅槃乐者。取结于彼系用增上。疑结谓于四谛犹豫。此异于慧有别法体。于四谛者。谓于苦谛心怀犹豫为苦非苦。乃至于道犹豫亦然。前四能牵正决定起。后四能引邪决定生。自外事中邪犹豫转。非迷谛故不名为疑。已见谛者彼犹未灭。简彼故言于谛犹豫。令心不喜说名为嫉。此异于嗔有别法体。故有释嫉不耐他荣。谓此于他诸兴盛事。专求方便破坏为先。令心焦热故名不喜。是嗔随眠等流果故。专心为欲损坏他故。正随忧根而现行故。唯欲界系非色无色。欲界诸处皆通现成。唯除北洲成而不现。令心吝着说名为悭。谓勿令斯舍离于我。令心坚执故名为悭。耽着法财以为上首。不欲离己故名吝着。此是欲贪等流性故。专心护己资具等故。唯欲界系非色无色。何故缠中嫉悭二种。建立为结非余缠耶。若立八缠应作是释。二唯不善自在起故。谓唯此二两义具足。余六无一具两义者。无惭无愧虽唯不善非自在起。悔自在起非唯不善余两皆无。若立十缠应作是释。唯嫉悭二过失尤重。故十缠中立二为结。由此二种数现行故。谓生欲界虽有九六三结无结。而经唯说嫉悭二结恼乱人天。以胜趣中二数行故。又二能为贱贫因故。谓虽生在二善趣中。而为贱贫重苦所轭。现见卑贱及诸乏财。乃至极亲亦不敬爱。又二遍显随烦恼故。谓随烦恼总有二种。一戚俱行。二欢俱行。嫉悭遍显如是二相。又此二能恼二部故。谓在家众于财位中。由嫉及悭极为恼乱。若出家众于教行中。由嫉及悭极为恼乱。或能恼天阿素洛众。谓因色味极相扰恼。或此能恼人天二众。如世尊告憍尸迦言。由嫉悭结人天恼乱。或此二能恼自他众。谓由嫉故恼乱他朋。由内怀悭恼乱自侣。故十缠内立二为结。佛于余处依差别门。即以结声说有五种。颂曰

  又五顺下分　　由二不超欲
  由三复还下　　摄门根故三
  或不欲发趣　　迷道及疑道
  能障趣解脱　　故唯说断三

论曰。何等为五谓有身见戒禁取疑欲贪嗔恚。如是五种于下分法。能为顺益故名下分。然下分法略有二种。一下界谓欲界。二下有情谓诸异生。虽得圣法而不能超下分界者。由为欲贪嗔恚二结所系缚故。虽离欲贪而不能越。下有情者由为身见戒取疑结所系缚故。诸有情住欲界狱中。欲贪及嗔犹如狱卒。由彼禁约不越狱故。身见等三如防逻者。设有方便超欲界狱。彼三执还置狱中故。顺下分结由此唯五。已见谛者由欲贪嗔。不超下界其义可尔。唯此但是欲界系故。离欲贪者见断一切皆令不越下分有情。何故世尊唯说三种。虽有此责而佛世尊略摄门根且说三种。言摄门者见所断惑类总有三。唯一通二通四部故。说此二种摄彼三门类显彼故。言摄根者身见等三。是余三根以边执见见取邪见。如其次第随有身见戒禁取疑三种胜根而得转故。说此三种摄彼三根。故顺下分唯有此五。若唯此五名顺下分结。何故世尊诃具寿大母。痴人何故如是受持唯立尔所名下分结。以彼唯立如是五种。正现行时名下分结。世尊意立设不现行亦顺下分。是故诃彼显身见等。若行不行但未断时皆顺下分。依如是理故责彼言。若尔汝同婴儿外道所解庸浅乃至广说。若已断便失顺下分性耶。顺下分相虽断不失然若被断失彼结名。若已断时不名结者。三结先断已失结名。契经不应作如是说。断五下分结得成不还果。以不还果总说有二。一次第证二超越成。断二断三如次得果。由不定故说五无失。约容有说可断五故。诸得预流六烦恼断。何缘但说断三结耶。此亦如前摄门根故。虽但有一通于二部。即举彼相以显彼体。由此故说摄彼三门。或有余师作如是释。趣异方者有三种障。一不欲发。谓见此余方功德过失故息心不往。二迷正道。谓虽发趣而依邪路不至彼方。三疑正道。谓不谙悉见有二路人皆数游。便于正道心怀犹豫。此于趣彼为是为非。如是应知趣解脱者。亦有如是相似三障。谓由身见于蕴涅槃。见执我断功德过失。故于解脱不欲发趣。由戒禁取虽求解脱。而迷正路依世间道。徒经辛苦不至涅槃。由疑不能善自观察。见诸邪道有多人修。便于正道心怀犹豫。于趣解脱为是为非。佛显预流永断如是。趣解脱障故说断三。虽见行常亦不趣解脱。见世道胜亦迷失正道。拨无圣道者亦不信正道。而前三种是后三根后三必随前三转故。举本摄末但说前三。佛于余经如顺下分。说顺上分亦有五种。颂曰

  顺上分亦五　　色无色二贪
  掉举慢无明　　令不超上故

论曰。如是五种体有八物。掉举等三亦界别故。唯修所断名顺上分。顺益上分故名顺上分结。要断见所断彼方现行故。见所断惑未永断时。亦能资彼令顺下分。故要永断见所断惑。方现行者名顺上分。此中既说色无色贪及顺上言。知掉举等亦色无色非欲界系。品类足论既作是言。结法云何。谓九结。非结法云何。谓除九结所余法。由此证成掉举一种。少分是结谓二界系。少分非结谓欲界系。于少是结谓圣者。于少非结谓异生。有位是结谓已离欲贪。有位非结谓未离欲贪。由如是等差别不定。品类足论不说为结。掉举扰恼三摩地故。于顺上分建立为结。即由此理顺上分中。不说惛沈顺等持故。已辩结缚云何。颂曰

  缚三由三受

论曰。以能系缚故立缚名。即是能遮趣离染义。结缚二相虽无差别。而依本母说缚有三。一者贪缚。二者嗔缚。三者痴缚。所余诸结品类同故摄在三中。谓五见疑同痴品类。慢悭二结贪品类同。嫉结同嗔故皆三摄。又为显示已见谛者。余所应作故说三缚。通缚六识身置生死狱故。又佛偏为觉慧劣者。显粗相烦恼故但说三缚。有余师说。由随三受势力所引说缚有三。谓贪多分于自乐受。所缘相应二种随增。少分亦于不苦不乐。于自他苦及他乐舍。唯有一种所缘随增。嗔亦多分于自苦受。所缘相应二种随增。少分亦于不苦不乐。于自他乐及他苦舍。唯有一种所缘随增。痴亦多分于自舍受。所缘相应二种随增。少分亦于乐受苦受。于他一切受唯所缘随增。是故世尊依多分理。说随三受建立三缚。何类贪等遮趣离染说名为缚。谓唯现行。若异此者皆成三故。则应毕竟遮趣离染。若尔诸有非一切智。欲为有情说对治者。如何方便得如实知。所化有情贪等行别。而为如实说对治门。如何不知贪等行别。诸贪行者有如是相谓多言论面色熙怡。含笑先言多为爱语。离忿能忍黠慧好奇。耽话乐诗爱歌着舞。喜以妆服严具莹身。好事朋从数加沐浴。性多淫逸轻躁欢娱。多笑舒颜软心愍物。录德鄙吝怯弱随媚。欣多知友厌背寂静。性无沉密不察所作。轻有悲哀多无义语。肌肤软腻容貌端严。巧为怨伤好乐忌苦。轻交薄行多汗体温。身臭处形纤软爪齿。鲜须发美面易皱发早白。于巧明术性好存功。欣说有宗多喜乐福。好居众首爱集明鉴。喜自顾瞻近寻分赏。恭施爱视目送浅观。通俗别机多觉少恚。不能久制身四威仪。轻能弃舍财法友欲。而复因斯寻生追悔。闻智巧术欲习速成。才得成已寻复忘失。此等名为贪行者相。诸嗔行者有如是相。谓性躁烈卒暴凶险。多怀忿恨难与共居。乐讥他多忧戚。无慈喜斗。怒目低精少睡少言。沉思难喜坚持所受。固友固怨所为急躁。黠慧沉密难坏知恩。刚决勤勇无悲乐断。志猛念强坚锐难当。好多观察性欣出离。乐施利根多正直言。意怀难得是处见过。触事猜疑嫉妒形残。多诸病恼寡知友饶。怨结惨容色信坚固。少惊无畏大勇多愁。头项臂粗难可摧伏。强额多力为性佷戾。巧术闻智欲习易成。既得成已卒难忘失。财法友欲舍已不追。此等名为嗔行者相。诸痴行者有如是相。谓多犹豫乐说无宗。虽无能为而多高举。不敬阙信乐闇多沈。不乐审观伏眠难觉。多乐敬奉外道邪天。所作凶勃所作左僻。胜解劣多忘失。懒堕无策心昧[夢-夕+登]瞢。破坏法桥常喜闭目。所作不了蹙面颦眉。不聪明不相委。不相信不别机。憎嫉贤良所为专执。于善恶说不鉴是非。戾若狻貌卒难开晓。不能了别怨亲处中。须发毛爪多长坚利。眼口衣服眵垢可厌。不好花鬘严具庄饰。所作昧略轻有所为。多食多愁少惭少愧。不教便作令作不为。应怖情安应安反怖。应伤反悦应悦反伤。应笑反啼应啼反笑。于所应作难劝修行。不应作中难令止息。少福德烦恼羸。不能别知酢淡等味。多寱语唾齘齿好舐。唇齿秽密。能久安住身四威仪。此等名为痴行者相。诸慢行者有如是相。谓心高身矬小。体实坚鞕好物参誉。于可遵崇不能敬重。夸炫自德乐毁他能。不可引导坚持可受。不乐听闻师友教敕。于他所有多不印顺。贪敬殉名大眉耐苦。少亲友薄风范心广。大志勇决少怀忧戚。多乐出家言论知量。所为不躁知足大欲。具妙辩才不谄不柔难可回转。有大胜解不可摧伏。发言质直不曲顺情。此等名为慢行者相。诸见行者有如是相。谓执坚固钝根谄曲。乐恶喜福轻尔发言。好谈论爱思择。难屈伏强习诵。凡有所作不随他缘。难得意怀难令生喜。少厌舍阙正信好持斋戒。厌报灾祥。亲恶朋疏善友。性无悲愍怀聪睿慢。乱顾视惨姿颜多恶。梦多分别喜怀猜阻。心恒扰乱耽恶所作。性好寻思乐施少忧。坚守难厌见行共相。总述如是别相。一一如理应思。诸疑行者有如是相。谓多不会遍见过失。喜怀愁戚志性刚决。无善懈怠乐着睡眠。好不定言事无专一。数生追悔难得意怀。少语远寻营私堪忍。恒为谋略鲜有欢娱。不躁不明不知方便。交友易坏难喜忘恩。凝视低睛多不信顺。所习论智不究根源。微览枝条状如遍悉。凡有所作多不成功。此等名为疑行者相。若于如是六种相中。有具二三乃至皆具。应知此类名杂行者。余随烦恼诸行者相。此等流故准此应释。已分别缚。随眠云何。颂曰

  随眠前已说

论曰。随眠有六或七或十或九十八。如前已说。随眠既已说。随烦恼云何。颂曰

  随烦恼此余　　染心所行蕴

论曰。能为扰乱故名烦恼。随诸烦恼转得随烦恼名。有古师言。若法不具满烦恼相名随烦恼。如月不满得随月名。然诸随眠名为烦恼。即此亦得随烦恼名。以是圆满烦恼品故。由此故说即诸烦恼。有结缚随眠随烦恼缠义。所余染污心所行蕴。随烦恼起随恼心故得随烦恼名。不得名烦恼。以阙圆满烦恼相故。若尔染污思等心所。一切应是随烦恼摄理实应然。若尔何故别说行蕴。勿如思等受想亦应随烦恼摄。此彼何别非无别义。谓烦恼相应烦恼同蕴法。由二义相似得随烦恼名。染心所言显染思等得名随烦恼。由烦恼相应说行蕴言。为简受等要烦恼同蕴名随烦恼故。由此本论作如是言。除诸烦恼余染心所。行蕴所摄名随烦恼。或若有法从烦恼起。烦恼相应行蕴所摄。与诸烦恼相极相邻。方可建立名随烦恼。然兼为遣随烦恼中。有异论师谬作是解。悭即是爱沈即无明忿即嗔等。说此余言显彼皆是此之余义。有于此义仍复生疑。谓此余言亦应摄受。为遮彼故说行蕴言。不尔但应言此余染心所。本论不应说行蕴所摄言。以决定无余蕴所摄从烦恼起。是故于此说行蕴言。还显此义。由此若法与诸烦恼要三义相似。得随烦恼名。一是烦恼垢。二烦恼相应。三烦恼同蕴故我于此明见颂中有如是义。谓此烦恼亦名随烦恼。及此之余染心所行蕴。此之余者显相属义。意显若余是此所起方可建立随烦恼名。然兼为遮悭即爱等。若尔何故说行蕴言。说此余言义已成故。不尔遮滥说行蕴言。谓贪嗔痴如次所起染乐苦舍。容滥此余故行蕴言。还为显示无余蕴摄是烦恼垢。若不尔者但说此余。以何言遮前所说滥。故复须说行蕴摄言。随烦恼名为目几法。经种种说故有众多。谓愤发不忍及起恶言类。如世尊告婆罗门言。有二十一诸随烦恼能恼乱心。乃至广说后当略辩。缠烦恼垢摄者。且应先辩。缠相云何。颂曰

  缠八无惭愧　　嫉悭并悔眠
  及掉举惛沈　　或十加忿覆
  无惭悭掉举　　皆从贪所生
  无愧眠惛沈　　从无明所起
  嫉忿从嗔起　　悔从疑覆诤

论曰。根本烦恼亦名为缠。经说欲贪缠为缘故。若异此者贪等云何可得名为圆满烦恼。然诸论者离诸随眠。就胜说缠或八或十。谓品类足说有八缠。毗婆沙宗说缠有十。即于前八更加忿覆。如是十种系缚含识置生死狱故名为缠。或十为因起诸恶行。令拘恶趣故名为缠。无惭无愧嫉悭并悔。掉举惛沈如前已辩。令心昧略惛沈相应。不能持身是为眠相。眠虽亦有惛不相应。此唯辩缠故作是说。于此顿说眠三相者。此三与眠义相顺故。解字义者作是释言。眠谓于身能为滋润。即是有力能长养身。由心安眠身增益故。此善等别略有四种。谓善不善有覆无覆。诸瑜伽师久善思择。诸诵习者劳役长时。施主多时行益他事。此等加行憩息位中。所引睡眠皆名为善。然于加行闻思善心。眠不现行性相违故。此于加行修所成心亦不现行彼能治故。唯于一类生得善心。眠可现行性羸劣故。诸屠羊等不律仪人。专心久行不善加行。诸耽欲者于欲境中。专心久行不善加行。诸余一切习恶行者。长时数起不善加行。此等加行憩息位中。所引睡眠皆名不善。一切烦恼于睡位中。无不皆容现在前故。有覆无记准此应释。无覆无记唯异熟生。起工巧等眠便坏故。有余师说。于眠位中亦威有仪工巧心起。然非初位彼可即行。于后梦中方可行故。因自友损怨益而生。嗔恚为先心愤名忿。有余师说。因处非处违逆而生。力能令心无顾而转。乃至子上令心愤发说名为忿。隐藏自罪说名为覆。罪谓可诃即是毁犯尸罗轨则。及诸净命隐藏即是匿罪欲因。有余释言。抆拭名覆。谓内怀恶抆拭外边。是欲令他不觉察义。前说若法从烦恼起。方可建立名随烦恼。此中何法何烦恼起。无惭悭掉举是贪等流。要贪为近因方得生故。无愧眠惛沈是无明等流。此与无明相极相邻近故。嫉忿是嗔等流。由此相同嗔故。悔是疑等流。因犹豫生故。覆有说是贪等流。有说。是无明等流。有说。是俱等流。诸有知者因爱生故。诸无知者因痴生故。即由此相故。有说言。心著称誉利养恭敬。不了恶行所招当果。是于自罪隐匿欲因为爱无明二等流果。随恼心法说名为覆。如是十种从烦恼生。是烦恼等流故名随烦恼。余烦恼垢其相云何。颂曰

  烦恼垢六恼　　害恨谄诳憍
  诳憍从贪生　　害恨从嗔起
  恼从见取起　　谄从诸见生

论曰。于可毁事决定坚执。难令舍因说名为恼。由有此故世间说为不可导引。执恶所执于他有情。非全不顾拟重摄受为损恼因。悲障恼心说名为害。于非爱相随念分别生续。忿后起心结怨名恨。有余师言。欲舍怨结不能解脱。此因名恨。由有此故怨结缠心。自恼长时空无有果。于可爱境令不随顺。于策励事令心忘失。于诸有恩令不能报。令于喜事似有所忧。令于友朋不相委信。令于亲属怀弃舍心。令于面上易发惨色。于美谈话庆慰软言。令心怅悒都无所顾。事不获免示有欢娱。是诸贤良所远离处。能为株杌坏实福田。此等名为恨所有法。恨与忿相有差别者。如桦皮火其相猛利。而余势弱说名为忿。如冬室热其相轻微。而余势强说名为恨。由此故有说恨相言。忿息已续生令心浊名恨。于己情事方便隐匿。矫以谋略诱取他情。实智相违心曲名谄。于名利等贪为先故。欲令他惑邪示现因。正定相违心险名诳。释此名者。谓先筹度设此方便。令彼后时生颠倒解故名为诳。然世间说为利为名。现相惑他名为诳事。说诳所引身语业事。是诳果故假立诳名。如以通名说通果事。心险心曲相差别者。如道如杖于他于自因贪因见故有差别。谓如险道于诸有情。欲趣余方能为损碍。如是行者欲趣涅槃。心与诳俱能为损碍。如卷曲杖虽断其根。而于稠林难挽令出。如是信阙有谄曲者。虽以方便断欲界根。仍难引接令出生死。又幻惑他说名为诳。匿自情事说名为谄。又诳与谄如次是贪诸见等流。如后当辩。憍相如前已广分别。有余师说。从贪所生恃己少年无病寿等诸兴盛事。心傲名憍。有余师言。于自相续兴盛诸行。耽染为先不顾于他。谓己为胜心自举恃。说名为憍。由不顾他与慢有异。如是六种从烦恼生。秽污相粗名烦恼垢。于此六种烦恼垢中。诳憍是贪等流。害恨是嗔等流。恼是见取等流。谄是诸见等流。如言何曲。谓诸恶见故。谄定是诸见等流。此六亦从烦恼生故。如缠亦得随烦恼名。已说诸缠及烦恼垢。今次应辩彼断对治。诸缠垢中谁何所断。颂曰

  缠无惭愧眠　　惛掉见修断
  余及烦恼垢　　自在故唯修

论曰。且十缠中无惭无愧。通与一切不善心俱。眠欲界中通与一切意识俱起。惛沉掉举通与一切染污心俱。故五皆通见修所断。余嫉悭悔忿覆并垢。自在起故唯修所断。唯与修断他力无明共相应故名自在起。与自在起缠垢相应。所有无明唯修断故。此诸缠垢谁通何性。颂曰

  欲三二余恶　　上界皆无记

论曰。欲界所系眠惛掉三。皆通不善无记二性。所余一切皆唯不善。即欲界系七缠六垢。上二界中随应所有。一切唯是无记性摄。即谄诳憍惛沉掉举。此诸缠垢谁何界系。颂曰

  谄诳欲初定　　三三界余欲

论曰。谄诳唯在欲界初定。宁知梵世有谄诳耶。以大梵王匿己情事现相诳惑马胜苾刍。传闻此唯异生所起。非诸圣者亦可现前。惛掉憍三通三界系。所余一切皆唯在欲。谓十六中五如前辩。所余十一唯欲界系

说一切有部顺正理论卷第五十四阿毗达磨顺正理论卷第五十五

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩随眠品第五之十一

所辩随眠及随烦恼。于中有几唯依意地。有几通依六识地起。颂曰

  见所断慢眠　　自在随烦恼
  皆唯意地起　　余通依六识

论曰。略说应知诸见所断。及修所断一切慢眠随烦恼中自在起者。如是一切皆依意识。依五识身无容起故。所余一切通依六识。谓修所断贪嗔无明。及彼相应诸随烦恼。即无惭愧惛掉及余大烦恼地法所摄随烦恼。即是放逸懈怠不信。依六识身皆容起故。理应通说诸随烦恼。今此且依粗显者说。复应思择如先所辩。乐等五受根。对今此中所辩一切烦恼随烦恼。何烦恼等何根相应。于此先应辩诸烦恼。颂曰

  欲界诸烦恼　　贪喜乐相应
  嗔忧苦痴遍　　邪见忧及善
  疑忧余五喜　　一切舍相应
  上地皆随应　　遍自识诸受

论曰。欲界所系诸烦恼中。贪喜乐相应以欢行转遍六识故。嗔忧苦相应以戚行转遍六识故。无明遍与前四相应。欢戚行转遍六识故。与余烦恼遍相应故。邪见通与忧喜相应。欢戚行转唯意地故。何缘邪见欢戚行转。如次先造罪福业故。疑忧相应以戚行转唯意地故。怀犹豫者求决定知心愁戚故。余四见慢与喜相应。以欢行转唯意地故。有余师说。不应此五唯喜相应。现见此五现行位中亦有忧故。谓世现见执有我者。亦自感伤我受苦故。执我断者亦生忧戚。故契经言诸愚夫类。于我断坏心生惊恐。执自苦行为净胜者。内心必怀极愁戚故。已之闻智族等下劣。每为他人所轻陵者。与慢俱起必有戚故。由是此五亦忧相应。彼说不然异心起故。谓自感伤我受苦者。此但缘苦而自感伤。当于尔时不执有我。若起我见现在前时。于我必应有欢行转。怀断见者见断德故。不因断相而生惊恐。怀常见者于断生怖。然生怖位则不计常。执自苦行为净胜者。必异心中缘自所受。种种苦事而生愁戚。若执苦行为净胜时。必应生欢见彼德故。为他轻陵而生戚者。如是忧戚必在异心。谁有为他轻陵生戚。而即起慢侮蔑于他。故五喜俱诚为善说。如是别说欲界随眠。欢戚行殊四受俱已。通说皆与舍受相应。所以者何。以说舍受痴随增故。无明遍与烦恼相应无简别故。烦恼相续至究竟时。取境赊缓起处中欲。渐渐衰微相续便断。尔时烦恼与舍相顺。是故皆与舍受相应。岂不舍根非欢非戚。如何欢戚烦恼相应。如处中人俱无违故。谓欢与戚俱起相违。舍于两边俱能随顺。是故舍受通与欢戚。烦恼相应亦无有过。又贪嗔性非即欢戚。与欢戚法相随顺故。容可与彼欢戚法相应。由彼相应说为欢戚行。如是舍受性非即欢戚。与欣戚品法相随顺故。容可与彼欢戚品相应。由彼相应说为欢戚行。欲界既尔上地云何。皆随所应遍与自地。自识俱起诸受相应。谓若地中具有四识。彼一一识所起烦恼。各遍自识诸受相应。若诸地中唯有意识。即彼意识所起烦恼。遍与意识诸受相应。上诸地中识有多少。谓初静虑具四余一受有多少。谓初二三四等如次。具喜乐舍。喜舍乐舍唯舍应知。随诸地中所有烦恼。如应与彼识受相应。何缘二疑俱不决定。而上得与喜乐相应。非欲界疑喜受俱起。以诸烦恼在离欲地。虽不决定亦不忧戚。虽怀疑网无废情怡。如在人间求得所爱。虽多劳倦而生乐想。有说色界喜乐与疑得相应者。俱寂静故依平等义。建立相应既等寂静相应无失。如欲喜根非处生故。相不寂静疑则不然。由此喜疑无相应理。谓世现见有贫贱人。头面身支垢腻臭秽。手足皴裂匮食乏衣。复为重担之所镇压。虽遭此等种种艰辛。而有欢娱歌舞啸咏。或见他苦而反生欢。如是喜根有非处起。疑则不尔故无等义。由不等故无相应理。有说色界虽复怀疑。而于疑中生善品想。故彼得与喜乐相应。谓彼现见诸离欲者。多分因疑能引正定。有说初二三静虑中与疑俱生。应全无受故但应与本性受俱。已辩烦恼诸受相应。今次复应辩随烦恼。颂曰

  诸随烦恼中　　嫉悔忿及恼
  害恨忧俱起　　悭喜受相应
  谄诳及眠覆　　通忧喜俱起
  憍喜乐皆舍　　余四遍相应

论曰。随烦恼中嫉等六种。一切皆与忧根相应。以戚行转唯意地故。有余师说。恼喜相应见取等流应欢行故。悭喜相应以欢行转唯意地故。欢行转者悭相与贪极相似故。谄诳眠覆忧喜相应。欢戚行转唯意地故。欢戚行者。谓或有时以欢喜心而行谄等。或时有以忧戚心行。有余师言。既说诳是贪等流故。但应欢行不应说与忧根相应。是欢等流不应戚故。又正诳时不应戚故。或应说诳是痴等流。憍喜乐相应欢行唯意故。在第三静虑与乐相应。若在下诸地与喜相应。此上所说诸随烦恼。一切皆与舍受相应。相续断时皆住舍故。有通行在唯舍地故。舍于一切相应无遮譬如无明遍相应故。余无惭愧惛沉掉举。四皆遍与五受相应。前二是大不善地法摄故。后二是大烦恼地法摄故。说二及声显难及释。谓于恼诳设难如前。理应释言果因相别如无惭掉。虽贪等流而与忧苦有相应义。故知所说与受相应。不唯同因但据相别。许有忧戚而行诳者。情有所忧而行诳故。所说烦恼随烦恼中。有依异门佛说为盖。今次应辩盖相云何。颂曰

  盖五唯在欲　　食治用同故
  虽二立一盖　　障蕴故唯五

论曰。如契经言。若说五盖为不善聚是为正说。所以者何。如是五种纯是圆满不善聚故。其五者何。一欲贪盖。二嗔恚盖。三惛眠盖。四掉悔盖。五疑盖。契经既说盖唯不善。故知唯在欲非色无色界。由此为证知惛掉疑体。虽皆通欲色无色。而但欲界有得盖名。为显惛沉掉举二种唯欲界者。有立为盖故与眠悔和合而立。眠悔唯是欲界系故。为显眠悔唯染污者有得盖名。故与惛沉掉举二种和合而立。惛掉唯是染污性故。疑准前四在欲可知。何缘欲贪嗔恚疑盖。各于一体别立盖名。而彼惛眠掉悔二盖。各于二体合立盖名。欲贪嗔疑食治各别。是故一一别立盖名。由惛与眠及掉与悔。所食能治事用皆同。故体虽殊俱合立一。欲贪盖食谓可爱相。此盖对治谓不净想。嗔恚盖食谓可憎相。此盖对治谓慈善根。疑盖食谓三世。如契经说于过去世生如是疑。乃至广说此盖对治。谓若有能如实观察。缘性缘起惛眠盖食。谓五种法一[夢-夕+登]瞢。二不悦。三频申。四食不平性。五心昧劣性。此盖对治谓光明想。此盖事用谓俱能令心性沈昧。掉悔盖食谓四种法。一亲里寻二国土寻。三不死寻。四随念昔种种所更。戏笑欢娱承奉等事。此盖对治谓奢摩他。此盖事用谓俱能令心不寂静。由此说食治用同故。惛眠掉悔二合为一。或贪嗔疑是满烦恼。一一能荷一覆盖用。惛眠掉悔非满烦恼。二合方荷一覆盖用。此五名盖其义云何。谓决定能覆障圣道。圣道加行故立盖名。若尔则应诸烦恼等皆得名盖。一切皆能覆障圣道及加行故。如世尊告诸苾刍言。若为一法所覆障者。则不能了眼是无常一法。谓贪乃至广说一一别说如杂事中。何故世尊说盖唯五。理实应尔然佛世尊。于立盖门唯说五者。唯此于五蕴能为胜障故。谓贪恚盖能障戒蕴。如次令远离欲恶故。惛沉睡眠能障慧蕴。此二俱令远毗钵舍那故。掉举恶作能障定蕴。此俱令远奢摩他故。如是四盖渐次令超出离白法。由此于后令于业果四谛生疑。疑故能令乃至解脱解脱智见皆不得起。故唯此五建立为盖。若尔掉悔盖应惛眠。前说顺戒定慧蕴。次第而说故不尔。此中坏次第者。世尊意欲显别义故。谓契经中佛依正理说惛眠盖毗钵舍那能治非止。说掉悔盖唯奢摩他能治非观。此依伏断说观止门。别治惛眠掉悔二盖。若依永断此观止门对治一切用无差别。为显此理故坏次第。岂不契经作如是说。修等持者怖畏惛眠。修择法者怖畏掉悔。由此证知惛眠障定。掉悔障慧其理必然。理必不然互相顺故。惛沈顺定顺上分中。因言已辩掉举顺慧以性捷利似择法故。非顺彼法可言障彼。又若惛眠能障定者。则应许定能治惛眠。不应契经作如是说。惛眠对治谓光明想。掉悔障慧为难亦然。故彼所言唯陈自执。然契经说。修等持者怖畏惛眠。修择法者怖畏掉悔。此言意别。谓惛眠盖相顺等持。欲修等持惛眠易起。故修定者怖畏惛眠。非谓惛眠近能障定。怖畏掉悔准此应知。若谓契经作如是说。心昧劣位修定非时。心轻躁位修慧非时。故知惛眠近能障定。掉悔障慧理必应然。理亦不然就近说故。谓此经意正说惛眠。于法相中不能简择。是故择法为彼近治惛眠。亦能近障择法。故昧劣位修定非时。定非惛眠近对治故。惛悔于慧准此应知。若谓经说彼现起位。修此非时故知唯彼但为此障。则不说者障义既无便应非盖。非不障胜法。而盖义可成。由此应知俱为俱障。俱为俱治其理必然。但于此中就近障治。故作如是差别而说。有余别说唯立五因彼说云何。谓在行位先于色等种种境中。取可爱憎二种相故。后在住位由先为因。便起欲贪嗔恚二盖。此二能障将入定心。由此后时正入定位。于止及观不能正习。由此便起惛眠掉悔。如其次第障奢摩他毗钵舍那令不得起。由此于后出定位中。思择法时疑复为障。故建立盖唯有此五。乍可枉谤当圣慈尊。以圣慈尊犹一生隔。未证无等大我智故。宁可枉谤现能寂尊。彼说何缘名枉谤佛。以彼所说前后相违。及与契经理相违故。如何彼说前后相违。谓若欲贪嗔恚二盖。现起能障将入定心。障既现前何能入定。若别修治伏已入者。则不应言正入定位。于止及观不能正习。又不能习止及观者。云何名为正入定位。又彼所说正入定言。为闻思所成。为修所成定。若言我说闻思所成名正入定。则不应说后出定位。思择法时闻思所成有分别故。即思择法何待出时。若说我言修所成定。名正入定理亦不然。修所成心正现前位。惛眠掉悔何容现前。若不现前宁障止观。如何彼说经理相违。谓彼所言惛眠掉悔。如其次第障奢摩他毗钵舍那。违前教理故彼所说。唯立五因无有功能证盖唯五。由此前说理善可依。何故无明不立为盖不说成故。如契经说无明所覆覆即是盖。有余师说。等荷担者立诸盖中。无明于中所荷偏重是故不说。若立无明为一盖者。一切烦恼所荷障能。合比无明犹不能及。故不立在诸盖聚中。慢复何缘不立为盖。以有由慢能修胜法。为盖义劣不立盖中。有余师言。夫为盖者令心趣下。慢则不然以能令心趣上法故。非慢有力能压伏心。令其趣下故不立盖。诸见何故不立盖中。见诸有情阙无我见者。虽执有我而能离染故。有说诸见慧为体故。性捷利故不顺盖义。为盖必与此义相违。随烦恼中余不立盖。准前所说应如理思。上二界惑不立盖者。离三界染初非障故。初为障故建立盖名。又上界惑唯无记故。盖唯不善如前已说。今应思择诸随眠等由何而断。由慧观见彼所缘故随眠等断。若尔欲界他界遍行。及三界中见灭道断。有漏缘惑应无断义。缘苦集谛法智忍生。唯缘欲界苦集谛故。缘灭道谛诸智忍生。唯缘无漏为境界故。无如是失。我许诸惑永断方便有多种故。为有几种总有四种。何等为四。颂曰

  遍知所缘故　　断彼能缘故
  断彼所缘故　　对治起故断

论曰。断见所断惑由前三方便。一由遍知所缘故断。谓欲界系见苦集断自界缘惑。色无色界见苦集断所有诸惑。以上二界他界地缘。亦由遍知所缘断故。缘苦集谛类智忍生。俱能顿观二界境故。及通三界见灭道断。无漏缘惑如是诸惑。皆由遍知所缘断故。二由断彼能缘故断。谓欲界系他界缘惑。以欲界系见苦集断。自界缘惑能缘于彼。此惑于彼能作依持。依持断时彼随断故。如羸病者却倚而立。去所倚时彼随倒故。如何于彼能作依持。由此于彼能为因故。岂不此即说由害因故断。实尔此彼但是异名。然为止滥故作是说。谓欲界惑自他界缘。皆有此彼互为因义。然无此彼展转相缘。故于此中说能缘断。欲令易了唯他界缘。由断此因彼便随断。三由断彼所缘故断。谓见灭道断诸有漏缘惑。以无漏缘惑能为彼所缘。所缘断时彼随断故。如羸病者杖策而行。去彼杖时彼随倒故。何缘于此所断惑中。有断能缘故说所缘断。如缘欲苦集起现观时。有断所缘故说能缘断。如缘诸灭道起现观时。虽实尔时此彼俱断。而由所断有胜有劣。故胜断时言劣随断。谓若于彼惑所缘中。无漏慧生能为对治。彼惑名胜所余名劣。何缘彼惑偏得胜名。于彼所缘无漏慧起。专为敌彼发功用故。依如是义故可说言。缘欲苦集所起现观。于自所断烦恼等中。以自界缘为胜怨敌。缘诸灭道所起现观。于自所断烦恼等中。以无漏缘为胜怨敌。由胜断故余劣随断。若许惑断方便有多。有由能缘断故随断。有由所缘断故随断。何故前说由慧观见彼所缘故随眠等断。但应于此先立宗言。永断诸惑由多方便。勿先立宗与后解释言义各异。前后相违如先立宗后释无异。宁谓我说前后相违。谓我宗言由慧观见彼所缘故诸惑断者。此言意显由慧观见。欲界所系见苦集断。自界缘惑所缘境故。一切欲界见苦见集所断诸惑皆得永断。由慧观见上二界系见苦集断。所有诸惑所缘境故。一切上界见苦集断诸惑永断。由慧观见三界所系。见灭道断无漏缘惑所缘境故。一切见灭见道所断诸惑永断。非此意显所有惑断。二由慧见彼所缘。而后复言我许诸惑永断方便有多种别。如何可说我先立宗。与后解释言义各异。故不应谓前后相违。或我但言由慧观见彼所缘故诸惑断者。显余兼断不说自成。谓若但能由慧观见彼所缘故彼惑断时。所余诸惑能缘断故。所缘断故无不断理。是故从首且略立宗。若由慧见少惑所缘。则一切惑皆随断者。何故乃言我许诸惑永断方便有多种别。但应立有一。谓遍知所缘。非唯立遍知所缘故断。即能显所断惑有二类。一谓与慧所缘境同。二谓与慧所缘境别。由此必有生如是疑。诸惑所缘与慧同者。慧见彼境彼断可然。余惑所缘与慧异者。彼惑永断由何方便。由此故说多方便言。显理遣疑深成有用。或复断惑定有多门。然立宗中且举胜者。显余皆属此初门故已说三方便。断见所断惑断修所断惑。由第四方便。谓彼但由治起故断。以若此品对治道生。即此品中诸惑顿断。如下下品治道起时。上上品惑即皆顿断。至上上品治道起时。下下品惑即皆顿断。如是理趣后当广辩。岂不一切见所断惑断时。亦由对治道起。以若此部对治道生。则此部中诸惑断故。理实应尔。然于此中为显三界修所断惑。无不皆由九品道。断治道决定故。说此言见所断中唯有顶惑对治决定。如前已辩。或见所断诸惑断时。方便定三故就别说。修所断惑能断方便。不决定故就总而说。岂不所明第四方便。与前宗义有不相关。谓修位中以灭道智。能断三界修所断惑。慧非见此惑所缘故。此与宗义实不相关。前宗唯辩见所断故。设彼总摄亦不相违。见彼惑所缘此惑治生故。所言对治总有几种。颂曰

  对治有四种　　谓断持远厌

论曰。诸对治门总有四种。一断对治。谓道亲能断诸惑得即无间道。二持对治。谓道初与断得俱生即解脱道。由如是道持断得故。令诸惑得不相续生。三远分对治。谓道能令前所断惑得转更成远。即胜进道于解脱道。后所起道名为胜进。乃至彼得俱起生等亦得道名。令与惑得相违诸得相续增故。四厌患对治。谓道随于何界何地中。见诸过失深生厌患。即是于彼以种种门观过失义。此唯诸厌作意聚摄。由此势力设于后时。属妙境界亦不贪着。应知多分是加行道。若尔何缘于最后说。阿毗达磨非次第求。岂不曾闻何烦征诘。或不定故说不在初。谓彼非如无间道后定有解脱。解脱道后方有胜进。是故不定以加行道。或有起在无间道前。或有生于胜进道后非决定故。又不定者。谓或有一补特伽罗由一加行。乃至证得阿罗汉果。或二或多是故不定。又不定者无间道等如前加行。亦能与后为加行故不可定言。唯尔所是加行道摄说多分言。应知为显无间解脱胜进道中缘苦集谛者。亦厌患对治已说惑对治。当辩断惑理诸惑永断为定从何。为从所缘。为从相应。为从自性。何故生疑。于此三种皆见过故。且不应说断从所缘。谓若此法是彼所缘。未曾有时非所缘故。亦不可说断从相应。谓相应法互为因故。此法无时非因性故。又由此惑令心成染。此心无时成不染故。亦不可说断从自性。谓法无容舍自性故。以断惑时不可令彼所断诸法失所断性。是故应思惑从何断。颂曰

  应知从所缘　　可令诸惑断

论曰。诸惑永断定从所缘。以于所缘遍知力故。令惑永断如前已说。然惑所缘总有二种。谓有系事及无系事。缘有系事为境诸惑。及从此惑力所引生。不缘此事为境诸惑。如是二惑于一有情。现相续中引起诸得。设无染污心现在前。此得恒行无有间断。为去来世诸惑果因。如是应知缘无系事为境诸惑及因此惑势力所引。随后现行不缘此事。为境诸惑所引起得类亦同前。言为去来惑果因者。谓此诸得在现世时。是过去惑等流性故说之为果。是未来惑生缘性故说之为因。然此诸得与断对治。等流诸得现行相违。能持去来所得诸惑故。令一切缘此事惑及缘余惑相续而转。缘此事境诸断对治。等流起时惑得便绝。所得诸惑于自所缘。虽体犹有而由因果得永绝故可说名断。以于少境若未遍知。缘此境惑及因此惑力所引起。缘余境惑所引去来。惑果因得现相续中无间而转。若于少境得遍知时。惑所引得便不复转。故知惑断定从所缘。然于此中虽惑与道无俱行理。而道观见苦等境故诸惑便断。此义难了应举喻明。譬如有人为鼠所啮。虽无热闷迷乱等时。而由热等因毒在身故。恒名有病者非无病人。要服毒相违阿揭陀药方名无病者非有病人。虽阿揭陀与热等病。不俱时在一身中行。而阿揭陀威德力故。灭身中毒热等不生。说阿揭陀能除众病。如是圣道虽与诸惑。不俱时在一身中行。而圣道生威德力故。灭果因得诸惑不生。能令行者身器清净。惑不续故说名为断。已说诸惑永断所从。如前所言远分对治。一切远性总有几种。颂曰

  远性有四种　　谓相治处时
  如大种尸罗　　异方二世等

论曰。一切远性总有四种。一相远性如四大种。虽复俱在一聚中生。以相异故亦名为远。二治远性如持犯戒。虽复俱在一身中行。以相治故亦名为远。三处远性如海两岸。虽复俱在一大海边。方处隔故亦名为远。四时远性如去来世。虽复俱依一法上立。时分隔故亦名为远。望何说远望。现在世无间已灭。及正生时。与现相邻如何名远。彼非一切五识境故。亦非一分意识境故。或时分中有作用者。说名为近过去未来。定无作用故说名远。不可难言诸无为法。永无作用应名为远。以时远近依时而立。故于三时若有作用说名为近。若无作用说名为远。诸无为法越一切时。如何约时难令成远。如处远近依处而立非处不然。若难无为相有异故。应成相远理亦无遮。相远贯通一切法故。若尔何故无为名近。且虚空体遍一切处。相无碍故说名为近。非择灭体不由功用。于一切体一切处时。皆可得故说名为近。择灭无为诸有精进。正修行者断诸惑时。于一切体无有差别。速证得故说名为近。无为名近理趣既然。而经主说去来二世例亦应然。谓在去来静虑等法。如无为法等速得故亦应近者。由先释理为例不成。无多有情于一切体。无有差别共得义故。或许例然亦无有失。如一切法虽互相望。相有异故皆名相远。而依余理许说少分名近无失。如是去来虽约时分。无作用故皆名时远。而依余理许说少分名近无失。非依余理名为远故。与相时分远义相违。有余师言。由近胜解所证得故解脱名近。谓现胜解观解脱时。如对目前而证得故。如何现世说名为近。以与时远相有异故。谓现在世可有普为一切识境有作用故。经主此中作如是说。若依正理应说去来。离法自相故名为远。未来未得法自相故。过去已舍法自相故。彼说偏与正理相违。诸自相无皆非远性。此成远性必有自相。远性摄故如余远性。谓见所余相远性等。是远性摄自相非无。既许去来是远性摄。必应许彼自相非无。说自相无而名远性。故彼偏与正理相违。等声为明举法未尽

说一切有部顺正理论卷第五十五阿毗达磨顺正理论卷第五十六

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩随眠品第五之十二

如是已辩诸惑对治。修能对治胜进位中。所断诸惑为再断不。所得离系有重得耶。颂曰

  诸惑无再断　　离系有重得
  谓治生得果　　练根六时中

论曰。所断诸惑由得自分。无间道故便顿永断。离退后时无再断义。断已复断则为唐捐。所得离系虽无随道渐胜进理。而道进时容有重起彼胜得理。以离系得道所摄故舍得道时彼亦舍得。故诸离系有重得理此依容有。时总有六谓治道起得果练根。说治生言通目二义。若据住此能证离系目无间道。若据住此正证离系目解脱道。言得果者。谓得预流一来不还阿罗汉果。言练根者谓增进根。由此六时得未曾道。有舍曾道得离系故。说得果言既无差别。如摄四果应摄练根。以转根时必得果故。何劳长说此练根言。为显练根异断惑得果故。得果外说练根无失。然得离系随其所应。有具六时乃至唯二。谓欲界系见四谛断。及色无色见三谛断。所得离系得具六时。色无色界见道谛断。所得离系得唯五时。由治生时即得果故。说得果已不说治生。欲界修断五品离系。亦五时得除预流果。第六离系得唯四时。得果治生时无别故第七八品亦唯四时。得果四中除前二故。第九离系得唯三时。亦治生时即得果故。色无色界修所断中。唯除有顶第九离系。所余离系亦唯三时。得果四中除前三故。有顶第九得唯二时。得果治生同一时故。此约钝说若就利根。前诸位中除练根得。岂不八地容世俗道断。应分二种对治生时得不尔。此说渐次得故。惑此唯约无漏得故。若依越次通有漏得。则世俗道八地染中随离少多。入圣道者彼得离系。随其所应有具六时。乃至唯一以利根故除练根时。谓欲界中先断五品入见谛者。彼见所断五品离系。具六时得。谓有二种自治生时。及得果时复四成六。彼修所断五品离系。唯五时得除预流果。先断六品入见谛者。彼见所断六品离系。亦五时得除一如前。彼修所断六品离系。唯世俗道治生时得。必不起彼无漏对治。是一来果向道摄故。非住果时起彼向道。以住胜果不起劣故。先断八品入见谛者。彼见所断八品离系。亦五时得除一如前。彼修所断前六离系。唯一时得如前应知。七八离系唯四时得。谓二治生及二得果。先断九品依未至地入见谛者。彼见所断九品离系。亦四时得如前应知。依根本地入见谛者。彼见所断九品离系。亦一时得如前应知。根本非欲断对治故。若依未至若依根本。彼修所断九品离系。亦一时得如前应知。必不起彼无漏对治。是不还果向道摄故。先断上七地入见谛者。彼见三谛断七地。离系亦四时得如前应知。见道谛断七地离系。唯三时得谓一治生。及二得果无漏治生即得果故。彼修所断七地离系唯三时得。谓二治生及一得果。具离八地入圣道者。见修位中断有顶惑。见三谛断离系三时。谓一治生及二得果。见道谛断离系二时。由治生时即得果故。修断八品离系二时。谓一治生及一得果。第九离系唯一时得。以治生时即得果故。诸分离染见修位中。进断所余准此应说。以何因证得后果时。重得先时所断离系。由至教故。谓契经中依正证得阿罗汉果。说如是言应如是知应如是见。彼从欲漏心得解脱。乃至广说。由此位中亦得欲界。厌患对治等无学法智故。知彼离系亦应重得前言。断欲六品九品入见谛者。彼先修断六九离系无无漏得。为永不得暂不得耶。应决定言彼永不得。岂不证得阿罗汉。时必得先时见修所断。一切离系诸无漏得。若彼先时所断离系。有无漏得今时舍者。于彼今应得无漏得。若先无者今时亦无。得离系时唯自治起。及舍劣道得胜时故。诸有先依根本静虑入见谛者。得无学时宁从欲漏心得解脱。就依未至入见谛者。及次第者说故无失。或诸证得阿罗汉者。定得无学法智品摄。厌患对治由此数能厌患欲界。令欲界结无复系能。依此故言彼从欲漏心得解脱。由此即释契经所言。阿罗汉果永断嗔恚。就厌患彼说为断故。若尔何故引此契经。证后果时。得前离系。经言从欲漏心得解脱者。有具二因有一因故。谓于欲离系得。无漏得者二因故言心脱欲漏。一得彼无学离系得故。二得彼无学厌患治故。若不得者唯由一因。故此契经义皆成立。此中理趣如前已辩。复云何知得阿罗汉二界离系。必舍学得得无学得非欲界耶。学位定应先得彼故。谓设先离无所有染。随依何地入见谛时。必得二界诸见所断无漏断治。彼见所断是一断治顿所断故。上地见道现在前时。必修未来下地道故。下静虑遍能为上断治故。岂不已离无所有处染。依第三定等入见谛时。应修未来上地见道。同为有顶断对治故。不尔未离此地染者。即依此地入见谛时。自及上诸地见谛所断。见一一谛时能顿断故。如有未离第四定染。依第四定入见谛时。顿断五地见所断染。乃至未离初静虑染。依初静虑入见谛时。顿断八地见所断染。上地曾无断下地故。非第四等与第三等。所对治法一切皆同。由是已离第三等染。依第三等入见谛时。虽上地能治自上地。而非与下所治恒同。故依下时不能修上。诸异生位以世俗道断见所断。所有离系唯由下地。见道势力于自上地无漏得起。谓依上地见道现前。必修未来下地见道。由彼势力于下离系。得无漏得非上地故。由此学位定应遍于色无色摄。见断离系得无漏得非欲理成。欲唯未至地见道所断故。岂不应如第四定等。非第三等下地对治。然第四等见道现前。能修未来下地所摄。一切见道由彼道力。于诸下地见断离系。得无漏得。如是根本虽非欲治。然根本地见道现前应修未来。未至地摄一切见道。由彼道力应于欲界见断离系得无漏得。此例不齐。见道有二。一欲界对治。二上界对治。欲治有三。谓断对治厌患对治远分对治。色无色治三种亦然。欲治三中初断对治。唯未至摄余通六地。上治三种皆通六地。然上二界断治见道。唯能对治自上地染。余治见道亦治下地。上地虽非下地断治。而上见道现在前时。遍修未来下地见道。下与上地同所治故。无有欲界断治见道。能与根本同一所治。可根本地见道现前。能修未来未至地摄。欲见断法断治见道。由彼道力能于欲界见断离系得无漏得故彼所引为例不齐。诸根本地欲界厌患远分对治。色无色界三种对治。见道现前还修未来未至地摄。如是二种三种对治非由未来。欲界厌远对治力故。便于欲界见断离系得无漏得。唯断对治力能断系得故诸先离欲。若依未至入见谛者。欲界厌患远分对治。见道现前亦修未来。欲断对治欲断治地道正现在前故。由如是理非先。离欲入见谛者。皆于欲界见断离系得无漏得。诸先离欲入见谛者。毕竟无容于欲修断。所有离系得无漏得。以未至摄欲界修断。断对治收无漏修道。于不还果身中现前。及未来修俱非理故。理无容有不还果身中。有一来不还二向道。故诸有先离无所有染入圣道者唯除菩萨。余亦定于二界一切修断离系得无漏得。彼皆必于二界修断。自胜果道遍现前故。如是理趣以何证知。说圣者生第四静虑。以上诸地定成乐根。及说圣者生于无色。定有色贪尽断遍知得故。菩萨何缘不亦如是。不由加行一切功德。能现前故如灭定等。谓声闻独觉无自在功力。能超间起诸对治道。欲证后道必藉前道。以为加行方能证故。菩萨亦有超起功力。以于诸法相连接中。得殊胜智加行广故。若尔菩萨应见道中。不起法智品唯起类智品。因同前故无如是事。于色无色蕴有无我智生。必以有执受蕴无我智为先故。或初业地于法类品次第观中。曾极串习后次观苦。世第一法有苦现观。见道续生一切如前任运起故。或异生位从无始来。数以世间有欺诳智。观察欲色苦集灭道。故虽已断欲色二界见所断或。为以出世无欺诳智重遍观察。菩萨亦修彼对治道。诸先离染随其所应。后见道生至住果位。胜果道障既先已除。得胜果道斯有何失。许如是义便为善通。十门品说亦善安立。菩萨成下修断无为理不应然。且住果者得非果道违毗婆沙。非住果时未趣后果。可有已得非果道义。又理必然非此断治现在前位。如何由彼能得未来此断治道。又见具缚渐得果者。于后成就胜果道时。果所摄道必不行故。诸先离染至得果时。若有亦得胜果道理。彼果摄道应永不行。又非住有顶见道谛断断对治时。亦有得欲界诸修所断断对治理。又诸获得胜果道时。随应亦得诸世俗道。世出世道相系属故。若先离染随其所应。后见道生至住果位。必亦获得胜果道者。得预流时应修俗智。同对治故等离障故。由此我说得离系等。符教顺理为善安立。即诸离系彼彼位中。得遍知名随胜立故。遍知有二。一智遍知。二断遍知。智遍知者体即是慧。有说此通有漏无漏。有漏慧者谓除胜解作意相应。所余世间分别法性。能取诸法自相共相。闻思所成及暖顶忍。世第一等修所成慧无漏慧者谓出世间。见道修道无学道慧。前有漏慧顺无漏智。现观性故亦名遍知。如契经说。我作如是如理思时。实现观生便知老死由生故有。又言于一法未达未遍知。我说不能作苦边际。非无漏慧遍知一切法故。智遍知亦通有漏慧。唯无漏慧为智遍知。是我宗中正意所许。如说为于未现观法起现观故。思惟取蕴非由闻等所成俗慧可证。得预流至阿罗汉果。说预流等九根得故。又转法轮契经中说。以无漏慧遍知苦等。应知此即是未知当知根。然菩萨言实现观生者。于世间慧假立现观名。彼行相转似现观故。言于一法未达等者。依于此法若未遍知。障苦尽者密说无过。故定无漏慧方得遍知名。断遍知者体即离系。能遍知故名为遍知。是智异名如何目断。是智果故如业解果。谓契经说六处名业是业果故。又说无为应果名解是解果故。如是遍知目断无失。若尔忍果应非遍知。毗婆沙师作如是释。诸忍皆是智眷属故。于忍所作立智作名。如臣所为亦名王作。有余师释。诸解脱道于所得断。亦有功能以于断得能任持故。令诸系得不复生故。由此忍果有智果义。此释不然。以说诸断唯是诸无间道。离系士用果故。或金刚喻等持相应无漏。睿智力能总集诸断。无漏离系得故。忍果尔时亦成智果。渐得果等得一来不还忍果。无为已成智果故。许身见等三顺下结。永断无为名智果故。当说余三是智果故。为一一断道所得离系各立一遍知。为一切断道所得离系总立一遍知。二俱不然。以有极广极略过故。若尔云何。颂曰

  断遍知有九　　欲初二断一
  二各一合三　　上界三亦尔
  余五顺下分　　色一切断三

论曰。诸断总立九种遍知。唯立九缘如后当辩。何等名曰九种遍知。且三界系见谛所断烦恼等。断立六遍知。谓欲界系初二部断立一遍知。初二部言即显见苦见集所断。次二部断各立一遍知。次二部言显见灭道断。如欲界三上界亦尔。谓色无色二界所系。亦初二断一二各一合三。余三界系修道所断。烦恼等断立三遍知。谓欲界系修道所断。烦恼等断立一遍知。应知即是五顺下分结尽遍知并前立故。色界所系修道所断。烦恼等断立一遍知。应知此即是色爱尽遍知。无色界系修道所断。烦恼等断立一遍知。即一切结永尽遍知。此亦并前合立一故。此三前六总九遍知。如见道中唯见所断烦恼等断得遍知名。如是修道中亦唯修断不一。唯修断二通见修。已说并前而建立故。当说二时集遍知故。若异此者则不应说。五顺下分尽一切尽遍知。以何因缘色无色界。见断法断合立遍知。修断断中各别建立。如对治起而建立故。谓如色界诸蕴无我。无色诸蕴无我亦然。以彼见所断无事同故。等非身俱故对治亦同。如无色中等至殊胜。色界等至则不如是。彼修所断有事别故。对治不同是故别立。如是所立九种遍知。应辩于中几何道果。颂曰

  于中忍果六　　余三是智果
  未至果一切　　根本五或八
  无色边果一　　三根本亦尔
  俗果二圣九　　法智三类二
  法智品果六　　类智品果五

论曰。于此九中且应先辩。与忍智道为果差别。忍果有六谓三界系。见断法断六种遍知。智果有三。谓顺下分色爱一切结尽遍知。由此三遍知是修道果故。由此已辩见修道果。与静虑地为果别者。未至静虑果具有九。谓此为依断一切故。根本静虑果五或八所言五者毗婆沙师说。根本静虑非欲断治故。所言八者尊者妙音说。根本静虑亦欲断治故。除顺下分结尽遍知。以彼唯是未至果故。无容修彼断对治故。中间静虑如根本说。岂不依止根本虑静。入见谛时亦修未来。依未至地欲断治道。得断治故亦应证彼。欲见断法断无漏离系得。宁说根本唯得五果。此责不然。尔时所修依未至地断对治者。唯色无色断对治故。根本地道既不能为欲断对治。彼现起位如何能修欲断治道。由彼所修未至断治。唯治上界故果唯五。复云何知起余对治。必不能修余对治道宗所说故。谓于思择先离色染入见谛者。至修位中色尽遍知。得不得处如是说故。有言既说离空处染时。亦修未来诸静虑地故。岂不已说余治修余。此责不然。非诚证故。说断空处修静虑时。但修未来无色对治。非色对治为证。岂成此乃证余不修余治。有作是说。此证俱不成。见修道中所修相异故。谓第四定见道现前。唯修未来六地见道。修道现起所修不然。又见道中一无间道。顿断八地修道不然。又彼所修同不同分智行相异。是故见道与彼修道所修各别。又修道中亦有余治现在前位修余治道。如离欲时修诸类智。离色无色时修苦集法智故。见道位理亦应然。又根本静虑亦能治欲界。如世尊言六出离依。喜为因依住。便能舍离六出离依忧。乃至广说。此舍离言说离欲染。非宗边地许有喜根。由此极成根本静虑能治欲界。是故根本静虑地果有八遍知。此中有余作如是斥。非不现起断治道力。能引无漏离系得生名得遍知。如沙门果如世俗道得二果时。虽修未来无漏断治。而不名曰得沙门果。如是根本静虑现前。纵修未来欲断治道。而不由彼引离系得。故不可得八遍知果。此无深理以许圣位用世俗道。离诸染时得无漏世俗二离系得故。非俗无漏二智俱行故。由未来无漏道力能引无漏离系得生。非沙门果亦不成证。安立因果与得无漏。离系得理各有别故。言世俗道得二果时。有不名为沙门果者。是现非彼未来果义。无漏断得障得断故。尔时必起无漏断得。此无漏得亦由未来。无漏引起如何成证。又世俗道得二果时。亦许所得名沙门果。未来无漏解脱道等。亦得名为沙门果故。谓世俗道得二果时。未来无漏解脱道等。障得断故得皆现起。彼为是谁沙门之果。是现未来沙门之果。谓世俗道现在前时。有无漏得名现在道。彼是此道之等流果。亦未来道之士用果。相应俱有因通三世故。彼以士用果为其果故。诸无为法越三世故名沙门果何理能遮。由此彼执根本静虑。八遍知果其理还成。然实不成彼证非故。且彼所说谓第四定。见道现前唯修未来六地见道。修道现起所修异者此不成证。谓所修地虽复不同。然俱唯修上界治故。虽所修地少有不同。何理即令修余对治。以离有顶治道起时。虽修未来依九地道。而不可以所修异故。即令彼能修余对治。不尔彼应修世俗道。又即由此于见道中。虽一刹那顿断八地。而修八地治道非余。随断少多恒修同治。又由同分不同分修。见修道中修相有异。即证见道不修未来。余对治道理善成立。见道所修唯同分故。如集等忍现在前时。虽先已得苦等忍智。非见集等所断治故。于此位中不能修彼。然余地道于此能修。是此位道同对治故。或见道位虽修未来无量功德。而在忍位修忍非余。于智位中唯能修智。如是忍智尚不互修况修未来。余对治道义可成立。又修道中亦定无有。余治现起修余治义。虽诸类智离欲时。修离色无色时。修苦集法智。而非断对治。非对治故修此何缘修由因长养。辩智品中当广显示。又彼所引意近行经。约加行中现见忧喜。相对治故说亦无失。或修观者由先现见。耽嗜依忧能为逼恼。后例观彼出离依忧。行既同前亦为逼恼。遂欣初定妙喜现前。因此勤修断忧治道。故说因喜能舍离忧。或出离依忧断对治无间。容初静虑妙喜现前。蕴此于心密说现在。出离依忧喜近能相对治。为欲慰喻遭出离忧。所逼恼者令安泰故根本静虑于一切种。定无能为欲断对治。谁弃乐行依苦勤修。为欲证得三沙门果。由如是理毗婆沙师。说根本静虑遍知果唯五。我能此中更广决择。恐远本义故应且止。与无色地为果别者。无色边地果唯有一。谓依空处近分地道。得色爱尽遍知果故。圣依俗道离诸染位。所得断果亦名遍知。以得无漏离系得故。前三根本果亦唯一。谓依无色前三根本。得一切尽遍知果。故由此已辩静虑无色。总得遍知果多少别。与俗圣道为果别者。俗道果二谓俗道力。唯能获得顺下分尽。及色爱尽遍知果故圣道果九。谓圣道力乃至能越。三有顶故。应知九中二是共果七不共果。唯圣果故与法类智为果别者。法智果三谓法智。力能断三界修所断故。类智果二。谓类智力断色无色修所断故。与法类品为果别者。法智品果六。谓即是前法智法忍所得六果。类智品果五。谓即是前类智类忍所得五果。品言通摄智及忍故。法品六中四不共果。三属法忍一属法智。二是共果。谓最后二双属法类二种智故。类品五中三不共果皆属类忍。二是共果谓最后二义如前释。何缘一一道所得断。不各各立为一遍知。以永断时说遍知故。如契经说吾今为汝宣说遍知。乃至广说。此中何等名为遍知。谓贪永断嗔永断痴永断。乃至广说。说永断言显所得断。都无随缚方名遍知。云何名为有随缚断。云何名为无随缚断。断具三种或四种缘。名无随缚不具名有。谓或有断虽得离系得。而阙余得故容还永舍。或复有断余得虽生。未缺坚牢生死之首。以八地染虽数曾离。未能缺彼故还坠恶趣狱。或复有断虽亦缺彼。而余烦恼系缚未除。于永断义未得圆满。或复有断余缚亦除。而犹未能越所属界。以同类惑未断无余。于永断义亦未圆满。如是诸断名有随缚。是故于彼不立遍知。唯九位中三四缘具。断无随缚可立遍知。何谓具缘。颂曰

  得无漏断得　　及缺第一有
  灭双因越界　　故立九遍知

论曰。见断法断具三缘故便立遍知。修断法断具四缘故方立遍知。见断法断具三缘者。谓得无漏离系得故。缺有顶故。灭双因故。此中异生虽复亦有离八地染名灭双因。而断非遍知阙余二缘故。见圣谛位第二三刹那诸断。虽有无漏离系得。余二缘阙未立遍知。第四五刹那虽亦缺有顶。双因未灭不立遍知。见集断因有未灭故。集法智位欲二部断。具三缘故得遍知名。后五刹那法类智位。断具三缘故皆得遍知名。修断法断具四缘者。三缘如上越界第四。谓诸界中圣未越地。彼所得断唯具二缘。若已越地未越界者。彼所得断犹阙一缘。若越界时四缘方具。随应彼断得遍知名。岂不应五缘谓加离俱系。有余说此即灭双因。及越界缘故不别说。若尔亦勿立越界缘。越界亦即灭双因故。双因俱系虽依一物。而系与因其义各异。谓于五部令起名因。即于其中能缚名系。且苦智生集智未生。二部虽无互令起力。而有展转能为因性。见集断惑缚义如本。见苦所断缚义都无。故非灭双因即是离俱系。又不可说因义即系。以无漏缘惑不系他聚故。由此我宗二种俱说。今不说者但可说言。说此彼自成不可言无异。体义宽故且说双因。虽诸越界位皆灭双因。而灭双因时非皆越界。故灭双因外别立越界缘。灭三地双因未立遍知故。谁成就几遍知。颂曰

  住见谛位无　　或成一至五
  修成六一二　　无学唯成一

论曰。异生位中虽能离染。乃至八地不成遍知。于圣位中依未至定入见谛者。从初乃至集法忍位亦无遍知。至集法智集类忍位唯成就一。至集类智灭法忍位便成就二。至灭法智灭类忍位便成就三。至灭类智道法忍位便成就四。至道法智道类忍位便成就五。依根本定入见谛者。至集类忍亦无遍知。后位随应如理思择。住修道位未离欲者。道类智为初乃至未得全离欲界染。及离欲退皆成就六。至全离欲以离欲第九解脱道为初。乃至离色界最后无间道。先离欲者从道类智。乃至未起色尽道前唯成一遍知。谓顺下分尽。从色爱尽及无学位。起色缠退亦一如前。有色爱者从色爱永尽。先离色者从起色尽道。至未全离无色爱前。成下分尽色爱尽二。从无学退起无色缠成二遍知名。如前说住无学位唯成就一。谓一切结永尽遍知。若依根本入正决定道类智时。彼所有断亦得顺下分断遍知名者。宁许根本果唯有五遍知。唯色无色界见断法断。得彼遍知名故无有失。何缘唯此亦得彼名。以渐次得不还果者。于此断上立彼名故。又先俗道所断下分。今圣道力令永不生。故彼所得断假说为此果。今实不得欲断遍知。是故此中应作四句。谓若将得断者。亦将得遍知耶。或有将得断非将得遍知。谓诸位中将所得断未于彼断将立遍知。或将得遍知非将得断。谓未离欲入见谛者。于集法忍正灭位中。欲界见苦所断法断。将得遍知众缘具故。非将得断先已得故。于集类忍正灭位中。二界见苦所断法断。诸先离欲若依根本入见谛者。后三类忍正灭位中。随其所应彼先所断。色无色界见断法断。彼欲见修所断法断。于一切位非将得断先已得故。非将得遍知此非彼治故。若依未至入见谛者。三法类忍正灭位中。随其所应彼先所断。欲色无色见断法断。于修道位离欲界染第九无间正灭位中。三界见断及欲八品修断法断。离第四定第九无间正灭位中。前三九品第四八品。先离色者四地九品修断法断。金刚喻定正灭位中。一切前位所断法断。或将得断亦将得遍知。谓诸位中将所得断。亦于彼断将立遍知。此诸位言显无间道。自所断法断将得遍知名。如未离欲入见谛者。于集法忍正灭位中。欲界见集所断法断。于集类忍正灭位中。二界见集所断法断。如是乃至于道类忍正灭位中。二界见道所断法断。诸先离染入见谛者如应当思。修道位中于离欲界。第四静虑有顶染时。第九无间所断法断。或非将得断非将得遍知。谓除如前所说诸相。何故不还阿罗汉果。总集诸断立一遍知。颂曰

  越界得果故　　二处集遍知

论曰。具二缘故于所得断。总集建立为一遍知。一者越界。二者得果。所言集者是合一义。若于无色分离染故得预流果。全离染故得阿罗汉。若于欲界分离染故得一来果。全离染故得不还果。若于色界分离全离俱不得果。唯于二处具足二缘。谓得果时亦即越界故。阿罗汉及不还果。集所得断立一遍知。尔时总起一味得故。余二果时得虽一味而未越界。色爱尽时虽是越界无一味得故。于彼位不集遍知。要具二缘方总集故。谁舍谁得几种遍知。颂曰

  舍一二五六　　得亦然除五

论曰。言舍一者谓从无学及色爱尽。全离欲退。言舍二者谓诸不还。从色爱尽起欲缠退。及彼获得阿罗汉时。诸先离欲依根本定。入见谛者道类忍时。言舍五者经主释言。谓先离欲道类智位。此但应说道类忍时。道类智时彼已舍故。夫言得舍据将说故。又应简言依未至定入见谛者。若依根本入见谛者。于欲界断不得无漏离系得故。不得欲界见断法断三种遍知。非先不得可言今舍。言舍六者谓未离欲所有圣者。得不还时。得亦然者谓有得一得二得六。言得一者谓胜进位。集类忍等九种位中。及从无色起色缠退。言得二者。谓从无学起无色界诸缠退时。言得六者。谓不还退无得五者理无容故。谓先离欲依未至定入见谛者。道类忍时舍五遍知得不还果。此果若退可得五遍知。此退既无故无容得五。岂不胜进得圣果时。于诸无为更起胜得乍可名得。宁舍遍知约断实然恒成就故。但今且据九遍知中。若得异名本名便失。说名为舍亦无有过

说一切有部顺正理论卷第五十六阿毗达磨顺正理论卷第五十七

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩贤圣品第六之一

如是已辩随眠等性。虽有无量。总建立为三界五部随眠等断。随所系事虽亦无量。就胜位立九种遍知。然断必由道力故得。此所由道其相云何。颂曰

  已说烦恼断　　由见谛修故
  见道唯无漏　　修道通二种

论曰。世尊唯说烦恼有二。一见所断。二修所断。如契经言诸漏有二。谓有诸漏是见所断。或有诸漏是修所断。然诸论中开二为五。即五所断如先已说。先何处说。谓先颂言欲见苦等断十七七八四。彼二颂中已具分别。然就略摄唯二如经。断彼但由见修道故。道唯无漏亦有漏耶。见道应知唯是无漏。修道通二此中问答。俱不应说前已说故。谓前说忍所害随眠。有顶地摄唯见断等。彼言已显有顶见修所断随眠。如其次第唯圣见道。修道所断下八地摄。见断随眠圣见道断凡修道断。修断圣凡俱修道断。既说见道唯依圣身。岂不已成唯是无漏。既说修道通依凡圣身。岂不已成通有漏无漏。是则今说义不异前。由此不应造颂再说。说已复说成无用故。所说见道唯无漏因。谓一刹那断九品故。此因非证有漏亦能一刹那中断五部故岂能顿断便无漏摄。如向所言由见谛故。此所见谛其相云何。颂曰

  谛四名已说　　谓苦集灭道
  彼自体亦然　　次第随现观

论曰。佛于经中说谛有四。一苦二集三灭四道。于此论中亦先已说。于何处说谓初品中。分别有漏无漏法处。彼如何说谓彼颂言。及苦集世间此说苦集谛。择灭谓离系此说灭谛。无漏谓圣道此说道谛。如是彼处已显谛名。应知彼文亦已显体。谓除圣道余有为法。为果性边皆名苦谛。为因性边皆名集谛。物虽无异数分无失。依彼建立现观位中。诸忍智等行相别故。如四正断出离寻等。择灭无为名为灭谛。学无学法皆名道谛。有说名色名为苦谛。以五取蕴为其体故。唯业烦恼名为集谛。由烦恼力能系缚心。令属余趣由业力故。能令自体差别而生。唯烦恼灭名为灭谛。由烦恼灭故于色等解脱。唯观与止名为道谛。此二摄受诸圣道故。此非谛相别意说故。谓说法者为应时机。胜解堪能分位差别。依别意趣密作是言。非谓此文依谛相说。善对法者勿执此文。有余复言唯八苦相。是苦是苦谛除此所余。诸有漏法是苦非苦谛。唯顺后有爱是集是集谛。余爱余有漏是集非集谛。唯顺后有爱。灭是灭是灭谛。余爱余有漏灭是灭非灭谛。唯有学八道支是道是道谛。余有学无学全是道非道谛。此说违教及违正理。经说有漏法皆是苦谛故。谓诸有漏皆取蕴摄。佛说取蕴名为苦谛。云何知然。略说一切五取蕴苦契经说故。又说有苦非苦谛言于理有阙相无别故。又彼何缘不作是执。有眼等是色非色蕴。有青等是色非色处。然此俱名身非身。念住境既不可尔故理有阙。又爱非苦谛与至教相违。如说云何苦灭圣谛。谓即诸爱究竟断尽。非爱自性苦谛不摄。可爱断尽名苦灭谛。若谓诸爱是众苦因故。爱断尽时说众苦皆灭此亦无失。许殊胜苦得永断时众苦灭故。如取蕴一分得永断尽时。可说一切取蕴皆灭。如说于色应断贪欲。贪欲断时便名色断。乃至于识说亦如是。复有何理决定说爱非苦谛摄。若谓经言是集故者有太过失。如说道谛名趣苦灭。应不能断集执义如言故。又详至教意爱亦苦谛摄。如契经中问见谛者。汝于眼触所生诸爱。复等随观见为我我所不。彼便答言不尔大德。又伽他言未如实见苦便见彼为我。乃至广说。颂显身见唯见苦所断。前经显爱为身见所缘。故知契经意许爱苦谛摄。又说爱之集应如实了知。若爱定非苦谛摄者。则爱唯是苦果之集。如何复劝知爱之因。爱既有因故亦是果。既亦是果亦苦谛摄。故有漏法为果性边。皆是苦谛理善成立。诸有漏法为因性边。皆集谛摄非唯是爱。以契经说是应断故。谓世尊言集谛应断。复作是说苾刍当知。若有于色乃至于识。未达未遍知未断未离染。彼定不能永尽众苦。既于五蕴皆说断言。故非唯爱是集谛摄。此非诚证以爱断时假于色等说断言故。如说于色应断贪欲。贪欲断时便名色断。乃至于识说亦如是。此是诚证所以者何。爱虽行蕴摄而是集谛故岂说于行应断贪欲。便谓爱体非集谛收故。虽于彼说应断贪色等无妨是集谛摄。又应断言无简别故。谓色等蕴若自体断。若于彼体能缘爱断。皆可于彼说应断言。契经复言集谛应断。故五取蕴为因性边。皆集谛摄法相似故。又说眼等是因性故。如经说眼为因色为缘生眼识。眼识既是苦谛自性。所言因者是集异名。义准识因是集谛摄由此证眼等是集谛理成。又于一物说苦集故。谓契经言生等是苦。复言生集故老死集。又契经说如实了知。此是老死此老死集。故知苦集一物分二。不可说言此经所说。虽名苦集非苦集谛。此依异门说圣谛故。谓此经文前作是说。如实知苦知苦集等。次彼尊者大俱祉罗作是问言。唯舍利子更有异门说圣谛不。彼答言有。谓如实知此是老死。老死集等此中虽阙说圣谛声。而乘前言知说圣谛。于此文后彼复问言。齐何名为诸圣弟子。于此正法毗柰耶中。正见神通皆得圆满成就正见乃至广说非圣弟子。离见圣谛可于正法毗柰耶中。正见神通得圆满等。故知于此意说圣谛。又若不说是圣谛言。便非圣谛有太过失。谓契经说于苦无知。如是乃至于道无知。非此中阙说圣谛声。便谓无知不迷圣谛。于谛现观无为障能。若尔彼无知应非见谛断。又契经说知苦并因。此中虽无圣谛言说。而此非不说见苦集圣谛。又契经言彼见诸谛。见诸谛故名现观者。此虽说谛不说圣言。而彼定名见圣谛者。又于余经见有此例谓如有处具说欲贪。有余处但言由欲往诸趣。虽阙贪想知即欲贪故。阙圣谛言亦知说圣谛。由此于一物说苦集。故集谛。非唯爱其理极成。又于食等说有二故。谓契经说诸圣弟子。如实知食及知食集。广说乃至。云何名为如实知食。谓食有四广说乃至。如是名为如实知食。云何名为如实知食集。谓爱后有爱喜俱行爱。彼彼喜爱广说乃至。齐此名为诸圣弟子。于此正法毗柰耶中。正见神通得圆满等。食既如苦谛说爱等为因。由此证知食亦苦谛。复有经说食是苦集。如说众苦皆由食生。又如经言食集故身集。触集故受集。非身及受非苦谛摄。既于一物说苦苦因。故知取蕴皆是集谛。经何唯说爱为集谛。依别意趣故作是说。谓契经说喜俱行爱。喜即是爱理定无有爱与爱俱。故知此经以爱声说。爱俱取蕴理必应尔。现见余经有非彼体说为彼故。谓契经言依爱断爱。此于善法欲说以爱声。又契经言离爱离热。此于触一分说以爱声。此中于渴说爱名故。又契经言爱增为取。又经说业以爱为因。此二经爱名说一切烦恼。然契经说起四种爱。此经但以爱声说贪。经说爱声义非一故。执经说爱为集谛言。谓唯目贪非为善说。又此经说定有别意。以伽他说业爱无明皆能为因。招后诸行一切烦恼。皆能为因招后有故。爱声通说一切烦恼非唯目贪。由此证知喜俱行爱非即目爱。后更当辩。复有契经证成此义。谓佛于彼有因有缘。有绪经中说业因爱。余经复说一切烦恼皆是业因。以契经言取缘有故知前说业爱为因缘。爱声通诠一切烦恼。譬如经说无明缘行。故非唯爱是集谛摄理必应尔。以世尊告西腻迦言。我昔与今皆定施设。慢类为苦慢即是集。若谓如上所引契经。非五取蕴皆名集谛。故于所立为证不成。此亦不然遮汝所许我义成故。谓所引经证诸烦恼。皆是集谛遮汝所许。集谛唯摄顺后有爱。既遮汝义我宗所说。诸有漏法为因性边。皆是集谛无能遮止。故上所引为证理成。设许彼经爱唯说爱亦无有失。于招后有爱为胜因就胜说故。谓爱最是不厌有因。以爱力能庄饰诸有。令成种种美妙相故。如密怨敌现相诈亲。令诸有情不见其过。诸有情类爱行最多。爱力能令难趣离欲。故于招有爱是胜因。以爱为因力能引起。不别离欲和合欲故。法尔力能违逆解脱。故于宣说众苦因时。为令有情见彼过失。就胜说彼以为集谛。非谓所余异彼相法无集谛性。若但如文而作解者有太过失。或由此故其义亦成。谓契经说。爱集故苦集爱集即无明。故契经言。云何为爱因谓即无明。是既说苦集即是爱因。应但无明为集谛性。或即执爱为爱集者。岂非即苦亦是苦因。由此便成即于一物。由因果别立苦集谛。又契经言。受集故爱集。触集故受集。岂非爱受亦苦亦集。由此苦集非物故异。是故一切有漏五蕴。为因性边皆集谛摄。上座于此意谓不然。由契经中无此说故。说苦应知集应断故。谓广分别圣谛经中。曾不说言五种取蕴。皆集谛摄唯说是爱。又薄伽梵明二谛别说苦应知说集应断。是故唯爱是集谛摄。又诸无学者后有不续故。谓阿罗汉有五取蕴。有苦集故应续后有。然无是事故知唯爱。是集谛摄非余取蕴。此虽有语而实无义。言契经中无此说者。且不应理违自宗故。谓彼上座自作是言。苦因理通一切烦恼。以爱胜故说爱非余。非契经中辩圣谛处。说诸烦恼皆是苦因但作是言爱为集谛。故彼所说唯率己情。若谓余经说余烦恼。是集性故知诸烦恼。皆是苦因并集谛摄。但就胜故说爱非余。岂不所言经不说故。唯爱是集言有义空。又非此经不说取蕴。爱声通显诸有漏故。此前已说后更当辩。故彼所言空无有义。又彼所说应知应断。二谛别者理亦不然。二谛俱通由此成故。谓契经说五种取蕴。一切应断前已显成。既说皆是苦谛所摄。故非苦集由物故异。又佛于苦亦说断言。谓说世医拔毒箭者。不能了达一切世间。生为本苦永断良药。广说乃至。唯有诸佛究竟了达。一切世间生为本苦永断良药。又经说苦灭灭是断异名。又应知言亦通集谛。经说众苦尽由遍知法。故由此不应就应知断。辩苦集谛二相差别。言诸无学者后有不续。故证知唯爱是集谛者。理亦不然余因阙故。后有不续犹如爱等。谓如经中说受缘爱。诸阿罗汉非无有受。但余缘阙故爱不生又如经中说。眼及色为因缘故眼识得生。而或有时虽有眼色余缘阙故眼识不生。应知此中理趣亦尔。马鸣尊者亦作是言。烦恼业身能取后有。为因引发后有续生。设坏业身后有难绝。若烦恼阙后有便无。要阙能趣因生身方尽故。如阙种子有地无苗。又契经言识为种子。业为因故后有得生。非应果身无识无业。是故不必因皆无故。方令后果不相续生。应果身中虽有眼等。余因阙故后有不续。有作是言。现世诸蕴展转力生。故但可互为缘。要由彼力令识种子住后有田方名集谛。此亦非理除爱余法亦后有因。契经说故如契经说。一类有情余慢未断未遍知故。彼类便作生般涅槃。又契经说。若有于慢未现观。是慢我记有后生。又说无明爱结覆系。愚夫智者同感有身。又契经言诸有情类种种非一。众多苦生皆欲为因。乃至广说。又愚痴类爱乐诸有。由爱久处生死瀑流。是则无明为生死本。乍可唯说彼为集谛。不应唯爱是集谛体。或复何缘定知唯爱。能续后有非诸惑耶。若谓唯爱名顺后有。非余法者理亦不然先已说故。先何所说。谓先说爱声说一切烦恼。通说余法理亦如前。又业亦能招感后有。亦顺后有宁唯说爱。若谓唯爱所引发业能感后有。理亦不然。一切烦恼所引发业。无不能为后有因故。以契经说无明缘行。许此无明声总说诸惑故。或爱亦由无明引发。方有势力能续后有。经说无明为爱因故。乍可集谛唯是无明。无明总为诸有本故。由此为证非唯爱力。令识种子住后有因。故不应言集谛唯爱。又应责彼有漏法中。何缘唯执爱为集谛。若是烦恼故嗔等何不然。若通三界故慢等何不然。若牵后有故业行何不然。如契经言。若造福行便能引起随福行识非福不动。广说亦然。若希求相故何缘不说欲。若说为集故何不说食等。若执取性故何非身见等。如是余法亦有彼相。而执集谛唯是爱者。但由于经阙观察智。又未曾见有处决定。说集谛唯是续后有因爱。岂不经说后有爱言。虽尔不言此爱唯是。能令后有相续因性。如说云何如实知食集。谓爱后有爱。乃至广说。非引段食名续后有。是故知此后有爱言。为简别前非续后有。谓薄伽梵观所化宜。且以爱声显集谛体。然于多法皆有爱声。为简所余说后有爱。谓若有爱未永断时。后有可生方名集谛。是此经义非续后有。岂不但说喜俱行爱。彼彼喜爱足能简别。皆许无失彼此同故。谓如唯执续后有因爱。名集谛论者。后有爱言已能简余爱。复说余重简我宗亦然不应为难。或爱是总后有爱言简取无明及一果法。以后有爱声说无明等。故后有爱声亦容通说一切烦恼。或取蕴故。未了今说何等无明。故次复言喜俱行爱。即是意地贪相应义。意贪名喜有分别故彼彼意爱。谓于诸境或于自体起差别贪。此中贪名通目一切贪俱生品。为欲建立贪等行俱有差别故。由此与彼相应无明。亦得说名彼彼喜爱。故薄伽梵随所化宜。以别意说爱为集谛。不应随名便兴固执。谓集谛唯是续后有因爱。有言圣道为苦三缘圣道现前。亦能长养诸根大种应集谛摄。此亦不然。以诸圣道力能永断众苦道故。非能毕竟断苦道法。可名苦集义相违故。又若彼是此集离彼法此不生。圣道虽无而苦恒起。故知圣道定非苦集。又不可说苦是圣道等流。谓等流言显因同类。有漏无漏类既有别。为因非同类为果非等流。故不应言圣道是集。又非圣道是长养因。然圣道现前根大长养者。道能遮止损害缘故。今彼自类前为胜因。后果转增名为长养。由此圣道定非集谛。故唯有漏为因性边。皆集谛摄理得成就。契经所说业为生因。爱为起因斯有何义。谓于后有差别芽生。业能为因如所殖种。爱非爱异熟随业差别故。若于后有无别芽生。爱能为因如能润水。爱润诸后有令无别起故。如稻等芽随自类种故有差别。诸芽无别皆得滋长由水为因。应知二因义别如是理必应许爱为起因见有爱者后有起故。谓有爱离爱二俱命终。唯见有爱者后有更起。由此理证爱为起因。起有起无定随爱故。又世现见有希求者能摄受故。谓世现见有所希求便能摄受。于现既尔于当亦然。必希求为因能摄受后世。若于后有爱必驰趣于彼。故知爱体能为后因。何缘证知有离爱者。现见可尽法由因永尽故。谓见水等与火等合。渐减渐微乃至都尽。又见数习不净观等。贪等渐减善法渐增。由此比知无漏智火。至极盛位爱等永亡。是故证知有离爱者。有余师说。爱非爱境现在前时。诸根凝寂不变异者是离爱相。如不见有风等所生。变异相者比知无病。又如闇坏及了境时。知日轮出及诸根有。如是行者虽处闇中。身语意业亦清净者。应比知彼必已离爱。心怀过者若处闇中。诸根定应有变异故。又如游履所未行处。离能引导及所策杖。盲者定应不正失路。遥观彼相知彼定盲。如是心中怀过失者。身语意业必不清净。诸根定应有变异转。善比量者于他相续。可如是比知离爱未离爱。如是唯有对法者宗。辩集谛体理善成立。彼立灭谛亦不应理。诸烦恼等灭皆寂静相故等。寂静相有灭是灭谛。有灭非灭谛。理不成故由此不应作如是说。顺后有爱灭是灭谛非余。由此应知诸有漏断。皆是灭谛理善成立。言唯有学八圣道支。名为道谛亦不应理。说一切善法皆圣谛摄故。如契经言所有善法。一切摄在四圣谛中。由此彼应许除有学八道支外。所有圣道亦道谛摄。或非善性。又应已见四圣谛者。犹未获得佛证净故。以于道谛得现观时。许未现观无学道故。由此已见四圣谛者。有未获得佛证净失。缘佛信根犹未得故。又道皆有道等相故。谓余有学无学圣道。若趣生死应非无漏。若趣涅槃应道谛摄。若俱不趣应不名道。如何彼乃言是道非道谛。是故一切学无学道。皆道谛收理善成立。若谓无学不能灭苦。如何说是苦灭道摄此难不然。道相既等于苦亦有灭功能故。然已灭故不劳更灭。非无学道无灭功能。又对治道有多种故。由此契经言。不动心解脱珍宝具足能舍不善。即由此故诸无学者。修习正断亦无有失。是故最初立谛为胜。因前果后理数必然。由此定应列谛名处。苦居集后道在灭前。何故此中果前因后。随现观位次第而说。谓随行者现观位中。前观前说后观后说。然或有法说次随生如念住等。或复有法说次随便如正胜等。谓此中无决定理趣。发勤精进先断已生。后遮未生但随言便。所应断法已生易施设非未生。所应修法未生易施设非已生。断必自粗修必从细。言随此便故作是说。何缘现观次第必然。加行位中如是观故。何缘加行必如是观。谓若有法最为逼恼。修加行位理应先观。次求彼因次求彼脱。后应求彼解脱方便。譬如良医先观病者。所患病状次寻其因。次思病愈后求良药。故契经言夫医王者。谓具四德能拔毒箭。一善知病状。二善知病因。三善知病愈。四善知良药。如来亦尔为大医王。如实了知苦集灭道。故加行位依此次观。现观位中观次亦尔。由加行力所引发故。如纵心诵先所诵文。故列圣谛名随现观次第。现等觉故立现观名。正觉所缘故唯无漏。此觉真净故得正名。此圣谛名为目何义。经言圣者谛故得圣谛名。此义意言。唯诸圣者于四谛理。能如实见无有虚妄。非圣相违故理虽通而名圣谛。依如是义故有颂言

  圣者说是乐　　非圣说为苦
  圣者说为苦　　非圣说是乐

然四谛理无有差别。在圣在凡皆如实故。依能见者偏立圣名。或义意言。唯诸圣者于四谛理。以圣行观于一切时。行相无别圣行谛理极相称故。以谛随行立圣谛名。非如世间六非圣行。先观此地为静等三。后复观为粗等三相。非相称故不随彼名。或义意言。唯诸圣者于四谛理。以圣智观一得正决定无还不定理。故谛随智得圣谛名。即由此理圣智观谛。得立苦集灭道智名。凡智虽能见四谛理。得决定已容不定故。谛不随彼得凡谛名。由此但应名世俗智。唯受一分是苦自体所余并非。如何可言诸有漏行皆是苦谛。颂曰

  苦由三苦合　　如所应一切
  可意非可意　　余有漏行法

论曰。有三苦性。一苦苦性。二行苦性。三坏苦性。诸有漏行如其所应。与此三种苦性合故。皆是苦谛亦无有失。所以者何。诸有漏行有三可意非可意。余可意者。何谓诸乐受。及彼资具余二类然。此中可意有漏行法。由坏苦合故名为苦。未离染者于彼坏时。必定应生忧愁等故。以薄伽梵契经中言。诸乐受生时乐住时乐坏时。苦顺乐受诸行如乐受。应知诸非可意有漏行法。由苦苦合故名为苦。苦受自体及顺苦法现前。必能恼身心故。以薄伽梵契经中言。诸苦受生时苦住时苦坏时乐顺苦受诸行如苦受。应知除此所余有漏行法。由行苦合故名为苦。因缘所造皆是无常。有漏无常无非是苦。故有漏法皆是苦性。岂不一切有漏行法。据此皆容是行苦性。不应但说非苦乐受。及彼资粮为行苦性。虽有此理然于此中。依不共故作如是说。谓初后苦如其所应。唯在可意非可意法。余有漏法唯是行苦。不共所依故作是说。然薄伽梵契经中言。苦受生时住时苦者。由彼苦受性是苦故。坏时乐者苦受坏时。设无乐受由苦受息。似乐显现故亦名乐于相续息位立以坏名故。苦受息时名苦受坏。此于欲界。二界漏尽如次暂时长时。毕竟乐受生时住时乐者。由彼乐受性是乐故。坏时苦者。谓诸有情未离染时心恒求乐。于乐坏位起忧愁等。故说乐受为坏苦性。乐受坏时设无苦受。似苦显现亦名为苦。不苦不乐受生时住时。皆非苦非乐性是彼故。即彼坏时苦乐随一容现前故。可言俱有苦乐坏时无容有二。故佛于此作别异说。谓无智苦智生为乐。以于此受无智增广。此受无明所随增故。由无智故恶趣等中。具有无边行苦生起。极微细故甚为难觉。唯圣能觉。故有颂言

  如以一睫毛　　置掌人不觉
  若置眼睛上　　为损及不安
  愚夫如手掌　　不觉行苦睫
  智者如眼睛　　缘极生厌怖

是故此中无智便苦。若永断此得阿罗汉。由此故言智生为乐。薄伽梵说应果乐故。此三苦性其体是何。应定判言三受为体。由三受故顺三受法。如应亦得三苦性名。坏苦亦应是行苦摄。坏是无常差别名故。无常所随名行苦故。由此所立三苦不成。此难不然。义有异故于可意行。刹那无常亦名行苦。唯相续断得坏苦名故义有别。又障三乐建立三苦。谓苦苦性障无逼恼乐。行苦性障涅槃乐。坏苦性障受乐。是故行苦与坏苦性。其义各异无杂乱失。即由此理圣道虽有为非行苦摄。顺涅槃乐故。圣道能引涅槃得故理必应尔。以本论中先约三界辩三苦别。此言为遮有执圣道堕苦相摄。以诸圣道理决定非堕界法故。既尔欲界苦应无三。于色界中苦应无二。由是次约可意等三。诸行不同辩三苦别。此何苦合皆得苦名。由此复依乐等三受。自性有异辩三苦别。由如是理故本论中。前后三重辩三苦相。有说道谛非唯行苦亦是坏苦。现见退法退圣道时亦忧愁故。又诸圣道是可意摄。圣所爱故应是坏苦。又既许有无漏乐受。不苦乐受亦应是苦。所以者何。以契经说诸所有受无非苦故。又许道谛体是有为理应是苦。经言诸有所造所为皆是苦故。此说非理所以者何。处无明趣诸无智者。于诸因果相属理愚。不善了知诸法性相。于有为法别离位中。发生忧愁失所著故。如是无智者无圣道可失。若处明趣诸有智者。于诸因果相属不迷能善了知诸法性相。于有为法别离位中。不生忧愁无所著故。彼圣道设退亦不生坏苦。若以圣道圣所爱故。名为可意执为坏苦。如是圣道有不爱故。亦名非可意应执为苦苦。是则圣道应苦谛摄三苦合故。然非所许故可意摄非坏苦因。契经所言诸所有受。所造所为皆是苦者。依有漏法密说无过。如世间说一切烧等。皆依少分说一切言。此亦应然理极成故。或此经说其义有余。如别经言我圣弟子。以慧为剑能断一切。结缚随眠随烦恼缠。非染无记有漏善慧。力能永断一切结等。故以慧言显以圣慧。又如经说乐与乐俱行。理不应言受与受俱起。此显除受有为有漏。诸可意法与乐受俱。应知此经义亦如是。圣道非苦由此极成。有余师言。圣道非苦以能违逆是苦相故。非圣道起违逆圣心。由此能令众苦尽故。有余师言。诸有漏法其性乐住。无常逼时违其所乐。是故生苦圣道不然故非苦摄。去来世法是现种类。同现说苦理亦无失。如契经说一切受生皆名苦生。又契经说乐受生时名为乐生。二经如何不相违背。前依行苦皆名苦生。后辩受自相名乐生无失。或前契经对还灭乐。密说一切受生皆苦。第二契经依流转乐。说乐受起名为乐生。或前契经从多说苦。后经依少亦说有乐。谓生死中苦多乐少。如蜜一滴在毒瓶中。故经多言诸受皆苦

说一切有部顺正理论卷第五十七阿毗达磨顺正理论卷第五十八

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩贤圣品第六之二

此中余部有作是言定无实乐受唯是苦。云何知然由理教故。由何等理后苦增故。谓于一切所作事业及威仪中。若久习住皆于后位苦增可得。理必无有习住乐因。令于后时苦渐增盛。故知决定无实乐受。又处生死有动作故。谓有动作是生死法。身有沐浴饮食等事心有于境了别等业。事业驱迫尝不安宁。故生死中无非是苦。又由微苦伏胜乐故。谓少苦因蚊虻[此/束]等。所生微苦现在前位。力能摧伏广大乐因。沐浴涂香饮食眠等。所生胜乐令不现前。故有漏蕴唯是苦性。又于对治重苦逼中。愚夫起乐增上慢故。谓若未遇饥渴寒热。疲欲等苦所逼迫时。于能治中不生乐觉。是故乐觉由治苦生。非缘乐生故无实乐。又于众苦易脱位中。世间有情乐觉生故。依如是义故有颂言

  如担重易肩　　及疲劳止息
  世间由此苦　　脱彼苦亦然

故愚夫类于辛苦中。有乐觉生实无有乐。由何等教。如世尊言。诸所有受无非是苦。又契经说。此生时苦生此灭时苦灭又契经言。于苦谓为乐名想颠倒等。又契经言。汝应以苦观于乐受。此谓他宗对法诸师咸作是说定有实乐。云何知然苦乐生因功能别故。体实有异犹如贪嗔。现见贪嗔生因各别。别因生已功能复异。因能异故体别极成。苦乐生因既亦有别。世间现见大种互违。便有苦生调和生乐别因生已功能亦异。苦能损害乐能摄益。生因功能见有别故。定知苦外实有乐体。上座于此亦作是言。虽现非无摄益受位。而于苦类未为超越。以有漏法唯是苦因。故生死中受唯是苦。此亦非理所以者何。言相违故。唯立宗故。成非爱故不极成故。言相违者。谓若非无摄益受位不应唯苦。若言唯苦不应摄益。理但应言下苦受位。有劣损害无容摄益。唯立宗者。谓彼但说未越苦类竟不说因。以何证知摄益受位。于苦受类未为超越成非爱者。谓彼宗中执信与贪不越思类。是则彼二体应成一。染净二品更相杂故。解脱应无成非爱失。彼既无杂此亦应然。受类虽同而苦乐异。不极成者。谓生死中乐受定无非极成故。是则有漏亦是乐因。以我宗许有乐受故。如何可言诸有漏法唯苦因故。证乐是苦故彼所说有言无义。又应决定有实乐受异于苦受。以苦与乐有爱非爱相差别故。若谓乐受可爱性不成。以离染时复成非爱故。此亦非理于离染时由异门观为非爱故。非观行者观乐性边以为非爱。但以余相厌患乐受如后当说。又离苦外实有乐受。以契经中佛说有故。如契经说受有三种。谓乐及苦不苦不乐。若受自性实皆苦者。佛说三受有何胜利。若谓世尊随世故说。谓世于苦下上中位。如其次第起乐等觉。世尊随彼说乐等三。理亦不然非极成故。谓第三受世不极成。如何世尊随世说有。故说三受唯依真见。又于观乐受说如实言故。不应随世说有三受。非下苦受如实是乐。又乐亦有下等三故。不应言乐唯是下苦。又应非福感爱果故。谓非福业许有三品。下品能招下苦受果。汝言下苦体即是乐。岂不非福应感爱果。又如如苦成下品时。如是如是成上品乐。下品非福既感下苦。汝宗下苦即是上乐。岂不下因能招上果。便与因果感赴理违。又如如苦成下下时。如是如是乐成上上。是则下下非福为因。能感上上乐受为果。谁复为善设大功用。又福非福各有九品。如何下下非福为因。能感上上乐受为果。又上上福下下非福。同感下下苦受为果。则福非福应无差别。于余八品征难亦尔。又应一果二因所感。或应许福即是非福。是则违害如来至教。又下三定许有乐受。上地唯有不苦不乐。谁知苦受下下上中。设大劬劳厌下欣上。又定渐胜执苦渐增。于非理中谁复过此。又若下苦即名为乐。乐受领纳应不猛利。理非下受领纳分明。执下分明中翻闇昧。谁有智者能忍此执。故知苦外实有乐受。又彼容起余执过故。谓若苦乐无异体者。是则容他更起异执。唯许可爱别离位中。于乐受无起于苦觉。无别苦受名余执过。或容有计唯有乐受。是真实有余受实无。但于乐受上下中位。如次立为乐等三受。彼与此执理无别故。如彼但由自分别力执唯有苦。约品立三此亦应然故彼非善。又苦乐受定实有异说六触处。为天世间及那落迦有差别故。谓契经说。苾刍当知有六触处名天世间。若诸有情得生彼者。眼所见色一向可意。于彼都无不可意色。广说乃至由此因缘。彼处一向受诸喜乐。有六触处名那落迦。与上相违亦应广说。下苦名乐如前已遮。故不可言假说喜乐。若无实乐经但应言。天世间唯下苦。那落迦唯上苦。又数说一向应成无用言。谓先已言一向可意。后说一向受诸喜乐。若于下苦假立乐名。则一受中有苦有乐。如何可说一向乐言。故彼所计不应正理。又契经说如实言故。证知决定实有乐受。如契经说。受乐受时如实了知受于乐受。苦非二受亦如是说。又如经说。所有乐根所有喜根。应知此二皆是乐受。乃至广说。复作是说。若以正慧如实观见。如是五根三结永断乃至广说。若受唯苦如何可言。如实了知此是乐受。故知乐受自相是乐。然彼所言后苦增故。无实乐者其理不然。生苦乐因非唯境故。谓我不许唯外境力能生苦乐。若唯境者初与事业。威仪合时便应发生增上苦受。谓由此境于最后时。为缘发生增上苦受。初时已与如是境合。若唯境力生苦乐者。境才合时应生上苦。既不如是故知观身。相续分位转变差别。外境方作苦乐生因。谓至所依如是分位。冷暖等触能为乐因。无至此时非乐因理。为苦因者理亦应然。故观别因便令外境。为苦乐受各别生因。是故不应由事业等。后生增上苦便拨无实乐。现见世间地水粪等。观种芽等相续分位。转变差别为芽叶等诸果生因。何缘后时诸威仪等。方能生苦非于初时。以经久时身心劳倦。身中便有异大种生。由此后时方生苦受。以诸外境要待别因。方能为因生苦乐受。故生苦乐因非不定。亦不可以后时苦增。便谓初时已生苦受。若见威仪等后引苦生。便谓彼初时已生苦受。见异生后位有圣乐生。应执彼先时已生圣乐。此中亦可作如是计。先有圣乐微故不知。后时渐增方觉为有。则有毕竟无异生失。若谓不可习住乐因。令于后时苦渐增盛。故知决定无实乐受。既尔若有习住乐因。而于后时苦不增盛。如下三静虑应实有乐受。若三定中亦无实乐。则不应说后苦增故。知决定无真实乐受非毕竟故。契经中说。静虑无色亦名有苦。非由彼有损害性故。又观下过得离染时。非必由观为损害性。观为粗障亦得离染。又非唯厌下是离染因。欣上德亦为离染因故。谓上诸地功德渐增。欣彼亦能离下地染。故不应说彼苦。若无世道不应能离彼染。既或有处有定乐因。故有漏中有自相乐。是故彼说后苦增故。无实乐者非如理因。言处生死有动作故。受唯苦者理亦不然。圣道亦应有动作故。谓若乐受动作为先。然后获得名有动作。圣道亦以勤勇为先。然后证得应有动作。若以乐受有所攀缘。圣道亦然。应有动作是则道谛亦应是苦。然非所许先已辩故。又彼论中先许诸法皆无动作。后言生死有动作故都无有乐。是则彼说前后相违。故所立因无能证力。言由微苦伏胜乐故。知无乐者理亦不然观待别因前已说故。谓先已说境为乐因。要待所依大种差别。故蚊[此/束]等正所害身。非能为因助沐浴等生于乐受。不应尔时唯受苦故。便拨无乐。有助因时能生乐故。若有漏蕴唯是苦性。应沐浴等时常生苦非乐。以身有时待缘生苦。有时复待别缘生乐。故知苦乐因缘决定。因缘定故必有别体。若谓何理锯解身等时。虽与乐因涂香等和合。而不生乐但生苦受。与涂香等乐因合时。若与苦因蚊[此/束]等合便不生乐。转生苦受此如前解。谓见有处所有乐因。唯能生乐曾不生苦。如三静虑以于欲界苦着乐微。故遇乐缘不能夺苦。然或有位苦因生乐。谓见世间增苦味者。由数习等于彼生欣。又见世间烧铁石等。初触身分能为乐因。若尔后时极习近彼。宁即由彼复能生苦。我先说境为苦乐因。要待所依分位差别。其义已显宁更征难。或苦与乐种类有殊。故彼生时法尔差别。不应于此相例推征。故有漏蕴非皆苦性。以契经说。佛告大名。若色一向是苦非乐。非乐所随广说乃至。有情于色不应生染。言于对治重苦逼中。愚夫起乐增上慢故。无实乐者理亦不然。由对治门证有乐故。谓为无彼而求此法。即有实法为彼对治既为无苦。起胜方便而求于乐即有实乐。能对治苦何理相违。又苦先除后入三定。三定乐觉治何苦生。又因殊胜声香等境。起增上乐治何苦生。故彼所立因无能遮实乐言。于众苦易脱位中。世间有情乐觉生故。无实乐者理亦不然先已说故。先何所说。谓苦乐因非唯境故。若唯境者初荷担时。肩应即生增上苦受。既不如是故易肩时。担观所依分位差别。乃至未灭能为乐因。亦不应言诸愚夫类。于新起苦有乐觉生。初遭鞭等时应生乐觉故。现见彼苦亦有重轻。初受轻时应生乐觉。或彼应说以何因缘。重担在肩久不易脱。便生重苦初易不然。理不应言唯此重担。未易肩位为重苦缘。于易肩时便生轻苦。缘既是一苦何重轻。由此证知别有所待。身位差别为苦乐因。故生死中有少实乐。然世尊说诸所有受。无非苦者亦不相违。佛于经中自释通故。谓如庆喜问世尊言。佛于余经说有三受。谓乐及苦不苦不乐依何密意。此经复言诸所有受无非是苦。佛言。庆喜我依诸行皆是无常。及诸有为皆是变坏。密作是说诸所有受无非是苦。故知此经依二苦说。不依苦苦说皆苦言。由此定知实有三受。以彼尊者不问佛言。依何密意说有三受。佛亦不说我密说三。但言密意我说皆苦。既言皆苦是密意说。非了义故不可为依。宁即凭斯拨无实乐。又契经说。此生时苦生此灭时苦灭亦不相违。有漏法随应三苦性合故。如色想等体虽非苦。犹如苦受而说为苦。如是乐等体虽非苦。犹如苦受说苦何违。或诸有漏皆苦谛摄。依如是理说亦无违。岂不由斯即证无乐。不尔前已说非苦说苦故。谓如色等非苦说苦。乐等亦尔非苦说苦。若尔观乐苦谛摄时。如何不成颠倒作意。此先已说先说者何。谓是行苦坏苦性故。依如是义故有颂言

  诸佛正遍觉　　知诸行无常
  及有为变坏　　故说受皆苦

然有漏乐难成易坏。行者厌患观之为苦。不由乐受是苦性故。谓苦易成随欲便得。如暂屏气生极苦受。然极难坏为欲令灭。多设劬劳犹相续住。乐则不尔虽多设劬劳。仍难令其现前及久住。故修行者于乐受中。生极厌患观之为苦。由此乐受亦苦谛摄。故不可以契经中言。此生时苦生此灭时苦灭。便定非拨乐受自性。又契经言。于苦谓乐名颠倒者亦不相违一向谓乐成颠倒故。谓有漏乐理亦名苦。生住时乐坏时苦故。性是无常行苦摄故。一向谓乐如何非倒。又诸愚夫由见取力。于烦恼火遍所烧然。有漏行中计寂静德。故于苦计乐成想等颠倒。若谓此如常我想等。于一向苦计乐成倒。理亦不然。遮色等蕴一向是苦。契经说故。即由此故我先已许。全及分增益俱得名颠倒。故非由此无乐理成。又契经言。汝应以苦观乐受者理亦无违。即由此经有乐成故。谓此经说汝等苾刍。应以毒箭观于苦受。应以苦观乐受。应以无常观非二受。若谓三受唯一苦性。佛不应劝作差别观。既劝别观故知性异。此中苦受体非毒箭。然为恼害与毒箭同。故劝观苦犹如毒箭。如是乐受体非是苦性是乐故。由当变坏虽体是乐劝观如苦。后变坏时必当苦故。如掷坏器未至地时。虽体尚全已说为坏。非苦乐受亦非无常性是受故。由必被灭虽非无常性劝观如无常。生已后时必当灭故。又无常相恒随逐故。以非二受能引愚痴。由痴故于多劫已坏执为常住。及我我所为欲违彼常我见故。劝以无常观非二受。今详经意劝如是观。令于三界法起离染加行。谓初以毒箭观于苦受者。是于欲界法起离染加行。以欲界中苦受多故。次应以苦观乐受者。是于色界法起离染加行。以色界中乐受胜故。乐是欣乐生死本故。佛于乐受劝观为苦。然诸乐受自性是乐能摄益故。亦得名苦以是无常变坏法故。观为乐时能为系缚。以欣乐乐法是生死本故。观为苦时能令解脱。以厌患苦法能越生死故。佛以观苦能令解脱。故劝有情观乐为苦。后应以无常观非二受者。是于无色法起离染加行。以彼寿限极长远故。恐有情类执彼为常故。劝观无常如假借严具。是故知佛劝如是观。令于三界法起离染加行。不可引斯拨无乐受。由此乐受于生死中。定实有宗不可倾动。傍论已了应复正论。如是所说四圣谛中。几是世俗几是胜义。此中一类作如是言。二是世俗二是胜义。有一类言三是世俗。有为皆是亡失法故。有言二谛约教有别。谓诸宣说补特伽罗。城园林等相应言教皆世俗摄。此为显示实义为先。非从诳他作意引起故名为谛。诸有宣说蕴处界等。相应言教皆胜义摄。此为诠辩诸法实相。破坏一合有情想等。能诠真理故名为谛。此四谛教能令有情。证真实理故是胜义。此中上座作如是言。三谛皆通世俗胜义。谓一苦谛假是世俗。所依实物名为胜义。集谛道谛例亦应然。唯灭谛体不可说故。同诸无记不可说有。如契经说。具寿庆喜六触处尽。离灭静没有异无异。皆不可论汝欲论耶。乃至广说今详上座所说义宗。违害世俗胜义谛相。如是二谛其相云何。颂曰

  彼觉破便无　　慧析余亦尔
  如瓶水世俗　　异此名胜义

论曰。诸和合物随其所应。总有二种性类差别。一可以物破为细分。二可以慧析除余法。谓且于色诸和合聚破为细分。彼觉便无名世俗谛犹如瓶等。非破瓶等为瓦等时。复可于中生瓶等觉。有和合聚虽破为多。彼觉非无犹如水等。若以胜慧析除余法。彼觉方无亦世俗谛。非水等被慧析除色等时复可于中生水等觉故。于彼物未破析时以世想名施设为彼施设有故名为世俗。依世俗理说有瓶等。是实非虚名世俗谛。如世俗理说为有故。若物异此名胜义谛。谓彼物觉彼破不无及慧析余。彼觉仍有名胜义谛。犹如色等如色等物。碎为细分渐渐破析乃至极微。或以胜慧析除味等。彼色等觉如本恒存。受等亦然但非色法。无细分故不可碎彼。以为细分乃至极微。然可以慧析至刹那。或可析除余想等法。彼受等觉如本恒存。此真实有故名胜义。以一切时体恒有故。依胜义理说有色等。是实非虚名胜义谛。如胜义理说为有故。由彼上座所说义宗。违此所立二谛相故不应正理。且彼所言谓一苦谛。假是世俗特乖正理。所以者何。非于苦谛可以蕴等。渐渐分析乃至极微。或一刹那令舍苦觉。以析乃至极微刹那。一一恒与苦相合故。云何可谓如瓶水等。于所依物未破析时。假施设有名世俗谛。又如触法界。苦谛亦应然。谓彼自言蕴唯世俗。所依实物方是胜义。处亦如是。界唯胜义岂不触法界亦依多立一。理应如蕴是世俗有所依实物方是胜义。则应许界体兼二种。亦是世俗亦是胜义若谓二界于破析时。界相不舍故唯胜义。非如蕴处是聚是门。于破析时舍聚门义。是则苦谛例亦应然于破析时不舍相故。又彼自说二谛相言。若于多物施设为有名为世俗。但于一物施设为有名为胜义。又细分别所目法时。便失本名名为世俗。若细分别所目法时。不失本名名为胜义。于彼所说且就初门。触法二界应成假有。非但于一物施设为有故。由此彼应作如是说。但于多物施设为有名为世俗。亦于一物施设为有名为胜义。如是可言二界实有。便与说苦谛是世俗义。违非但于多物施设为有故。所以者何。于多物一物皆施设有。如触法界故就第二门亦违彼说。苦谛通是世俗有义。谓细分别苦谛体时。不失本名如触法界。故知上座于谛义中所说所书不观前后。彼诸弟子披后忘前。重览前文后文已失。由是所立前后相违。应例推征集谛道谛。又彼所说唯灭谛体。不可说故同诸无记。不可说有理亦不然。既尔应成世俗有故。谓佛所说如来死后为有为无。命者与身为一异等诸无记事一切皆是世俗有摄。以如来等与色等法。非即非离是世俗有。灭谛既同彼应世俗有摄。谓如瓶等与色等物。非即非离是世俗有。又说。依蕴施设有情。许诸有情世俗有故。知如来等世俗有摄灭谛亦应然同不可记故然不可谓涅槃俗有非俗有理。如前已说。是故不可定说涅槃。同无记事体非实有定应许是胜义谛摄。若尔何故尊者舍利子。不为庆喜分明记耶岂不后文亦分明记。乃至六处有可有诸戏论。六处既灭绝诸戏论。薄伽梵说此谓涅槃。由此证知离有戏论。必定别有无戏论灭。然彼庆喜不作是问。六触处灭为有为无故。亦不酬是有无义。但作是问灭与六处。为有别异为无异耶。是故答言。此无戏论。若谓灭体假实都无。岂不定应答言无异所以然者。谓毕竟无。据理皆应如是说故。无有少分毕竟无法。不可定言有异无异。亦有异亦无异。非有异非无异。应作是言此定无异。然舍利子不作是说故知彼灭非毕竟无。亦不可言是世俗有。无所依故如前已说。故知灭谛唯胜义有。离二谛外诸圣教中无容说有第三有故。若尔何故言不可论。理但应言此定有异。亦无有过不可论言。但显不应复推征义谓此有异义已显成。不应于中复为征问以六触处有诸戏论。六处永灭绝诸戏论。薄伽梵说此谓涅槃。即已显成别有灭谛又契经说灭界是有由如是等不应复问。或显庆喜发问无端故。以此言止其所问。谓诸弟子归投世尊长时精勤修诸梵行。究竟唯为证得涅槃。不应今时复为疑问或彼庆喜作是寻思。六处既无灭依何立。若有六处灭义应无。故寄彼言以申此难。由此故答此不可论。以涅槃中绝戏论故。或应方便别求此经。不可论言所有意趣。理必不可定执涅槃。其体是无同无记事。由此我等于彼所言。定不信依有过失故。彼必应许寂灭涅槃。于二谛中随一谛摄。然我宗说四皆胜义。诸世俗谛依胜义理。世俗自体为有为无若言是有谛应唯一。若言是无谛应无二此应决定判言是有。以彼尊者世友说言无倒显义名是世俗谛。此名所显义是胜义谛。名是实物如先已辩。岂不已言谛应唯一理实应尔。所以者何非胜义空可名谛故既尔何故立二谛耶即胜义中依少别理。立为世俗非由体异。所以尔者。名是言依。随世俗情流布性故。依如此义应作是言诸是世俗必是胜义。有是胜义而非世俗。谓但除名余实有义。即依胜义是有义中。约少分理名世俗谛。约少别理名胜义谛。谓无简别总相所取。一合相理名世俗谛。若有简别别相所取。或类或物名胜义谛。如于一体有漏事中。所取果义名为苦谛。所取因义名为集谛。或如一体心心所法。有具六因及四缘性。然依此义名相应因。非即由斯名俱有等。由如是理于大仙尊。所说谛中无有违害。如说。一谛更无第二。诸胜生类于中无诤。有谓异谛频显示故。我定说彼非真沙门。谓于世间有诸外道。学穷诸论见仍未决。至佛法中闻说二谛。谓亦不定倍复生疑。世尊为令得决定解。哀愍为说一谛等言。此一谛言总显圣教所说谛义无第二言是重审决显谛唯一。何谓一谛故次复言。谓诸胜生类于中无诤者。胜生言显内法有情。已见谛迹言于中者。显胜义谛即四圣谛。彼于此谛一切无疑。由此故言于中无诤。此则善顺胁尊者言。唯圣教中有苦圣谛。非余亦有乃至广说。世尊亦说唯有一道。更无余道能得清净。复言究竟唯一无别。然诸世俗依胜义理。有世俗体亦无有诤。以见谛者于诸世间。方域言词不坚执故。谓彼了达如是诸名。随世俗情假施设转。取蕴一分摄于中何所诤。言有谓异谛频显示故者。有言显示有诸外道。谓声为显彼情妄。谓以彼所执谛相有乖。而妄谓为我立是谛。频自显示言胜义摄异谛声显乖于谛义。谓诸圣谛义无乖违苦。真无常非不无常灭。真寂静非不寂静。彼所立谛与此相违。于谛义乖故言异谛。为显因义复说故声。谓唯佛法中有真圣谛。彼说异谛故知是外道。以彼所说圣谛义乖。故非真沙门定是外道摄。由此后文复作是说。我定说彼非真沙门。以彼所言异真圣谛。故是外道非真沙门。如说。苾刍诸有舍我。所说苦谛别立苦谛。此但有言乃至广说。说显示言显诸外道。持己所执宣畅授他。以妄文词增益实义。频言为显数起异端。别别颁宣所执谛理。此显外道未证胜义。所说言词不决定故。由此说彼非真沙门。故佛众中正师子吼。他论无有梵志沙门。凡所自称空无实义。以世俗谛亦胜义摄。不违大师所说一谛。即由此义为婆罗门。说真婆罗门必具有三谛。说不杀害一切有情。是谛非虚名第一谛说诸集法皆是灭法。是谛非虚名第二谛。说我我所无处谁物。是谛非虚名第三谛。以诸先代婆罗门说真修行者有三种谛。说禀祠礼杀生为法。是谛非虚名第一谛。说己所作皆得常果。是谛非虚名第二谛。说己身等属自在天是谛非虚名第三谛。谓彼先代诸婆罗门施设此三。诳求脱者依之行者空无所获。佛为遮彼如次说三。以诸世间盲闇所覆。不能简别所说是非。信婆罗门所传明论。谓此三种是谛非虚。蔽执修行皆堕恶趣世尊哀愍斥彼言虚。赞己所立。三种名谛。今详三谛应知为起。三解脱门前加行道。谓第一空缘有情故。第二无愿缘起尽故。第三无相缘相无故以处谁物名为相故。或即为起三解脱门。或显加行学无学地。有言此三为显三蕴。如是三谛随其所应三圣谛摄。由此定知如是三谛胜义谛摄。言圣谛者为简余谛故说圣言。谓一切法自相非虚亦得名谛。然成圣性不由觉彼缘自相境所有智生。无力能令入见道故。于法自相得善巧已。别有所觉方成圣性。此所觉谛是诸圣者。同意所许故名圣谛。诸法共相名此所觉。谓觉取蕴苦等相故。觉能生法因等相故。觉彼寂灭灭等相故。觉灭方便道等相故。方得成圣余则不然。不可说言治五部故。所觉圣谛应有五种。即由修习缘四谛道。渐增盛时治修断故。此四圣谛总体云何。一切有为及诸择灭以是烦恼圣道境故。染净因果性差别故。空非择灭有自体故。正见境故亦是谛摄然非烦恼圣道境故。亦非染净因果性故。亦非欣厌所行境故。非觉悟彼得成圣故。不预此中圣谛所摄。何缘烦恼不缘彼生。以彼二法是无漏故不能违害有漏法故。谓爱但缘有漏为境。欣无漏法违诸有故。不名为爱是善法欲。若境极能顺生贪爱此境遍是烦恼所缘。由爱所缘便于彼灭。及彼灭道不欲疑谤。空非择灭与此相违。故定不为烦恼境界。岂不于二譬喻等师缘之亦生不欲疑谤。宁说缘彼烦恼不生。非缘彼生无智疑见。障证苦灭及苦灭道。如缘苦等成染污性。如阿罗汉于道路等。亦有无智疑谤现行。岂可说为染污烦恼。是故皆是不染污性。由此说无缘彼烦恼。有说。非谤空非择灭但谤其名不缘其体。此二唯善俗智境界。于苦等谛何不亦然。是故应知前说无失

说一切有部顺正理论卷第五十八阿毗达磨顺正理论卷第五十九

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩贤圣品第六之三

今应思择。于圣谛中求真见者初修何行。求见圣谛初业地中。所习行仪极为繁广。欲遍解者当于众圣。所集观行诸论中求。以要言之初修行者。应于解脱具深意乐观涅槃德背生死过。先应方便亲近善友。善友能为众行本故。具闻等力得善友名。譬如良医于疗疾位。先审观察诸有病者。何等本性如何变异。何所规度有何势力。何处何时习何成性。何志何失何法所随。何食何业住何分位。彼从先来串服何药。次观诸药味势熟德。随应授与令热令腻。或令进汤引诸病出。凡所授药功不唐捐。具悲智尊亦复如是。先观烦恼重病所逼。初欲习业诸弟子众。何等本性为贪行耶。广说乃至为杂行耶。如何变异谁令变耶。为经久住为暂尔耶。令违本性有何德耶。何所规度为求世荣为求出世坚固功德。有何势力彼所依身。为极坚固堪耐劳苦。独处闲居专精受行。杜多功德为极愞软。为居何处有居此处。此德失生处亦顺生诸得失。故理须观察为在何时。有在此时欣乐于此时。亦顺生欣乐心故理须观察或根熟位说名为时。习何成性彼于先来。串习何德今成此性。有何志性为性怯劣为性强勇。堪处闲居为性劬劳。为极勇猛堪能担荷大劬劳担。有何过失为增上慢。为被他言之所牵引。为多寻伺为性愚蒙。为多谄曲为性躁扰。为贪敬奉为爱利养。为多邪解为多疑惑。何法所随为何烦恼。坚所随逐何可动耶。彼宜何食顺益彼身。身依食住故应观察。彼有何业是先所为令顺先修故应观察住何分位。功德过失随年位殊。故应观察彼宜授与。何等法药为应舍置。为应诃摈为应赞励为应诲示。次应观察诸对治门。随其所应授与令学。各令获益功不唐捐。由此世尊契经中说。亲近善友名全梵行。行者既为能说正法。善友摄持应修何行。颂曰

  将趣见谛道　　应住戒勤修
  闻思修所成　　谓名俱义境

论曰。诸有发心将趣见谛。应先安住清净尸罗。然后勤修闻所成等。故世尊说依住尸罗。于二法中能勤修习。谓先安住清净戒已。复数亲近诸瑜伽师。随瑜伽师教授诫勖。精勤摄受顺见谛闻。闻已勤求所闻法义。令师教诫所生慧增。渐胜渐明乃至纯熟。非唯于此生喜足心。复于法义自专思择。如是如是决定慧生。自思为因决慧生已。能勤修习诸烦恼等。自相共相二对治修。今于此中略摄义者。谓修行者住戒勤修。依闻所成慧起思所成慧。依思所成慧起修所成慧。此三慧相差别云何。谓如次缘名俱义境。理实三慧于成满时。一切皆唯缘义为境。尔时难辩三慧相别。故今且约加行位。辩说闻思修缘名俱义。非唯缘名境有决定慧生故。闻所成慧不但缘名境。然随师说名句文身故。于义差别有决定慧生。此慧名为闻所成慧。约入方便说但缘名。闻慧成已为知别义。复加精勤自审思择。欲令思择无谬失故。复念师教名句文身。由此后时于义差别。生决定慧名思所成。此加行时由思义力。引念名故说缘俱境。思慧成已等引现前。不待名言证义差别。此决定慧名修所成。诸瑜伽师此中立喻。如彩画者习彩画时。最初从师敬受画本。审谛瞻相临本仿学。数毁数习乃至刮真。然后背本数思数习。为令所习无谬失故。复将比校所仿画本。令己所造等本或增。不尔所习无增进理。由此后时所作转胜。无劳观本随欲皆成。习三慧法应知亦尔。毗婆沙师复别立喻。如有一类浮深驶水。曾未学者不能离岸。及浮所依曾学未成。能暂舍离去之不远。恐乏沉溺复还趣岸。或执所依曾善学者。能无劳倦不顾岸依。虽经极深险难洄澓。能免沦没自在浮渡。如是应知三慧相别。经主谓此思慧不成。谓此既通缘名缘义。如次应是闻修所成。今详三相无过别者。谓修行者依闻至教。所生胜慧名闻所成。依思正理所生胜慧名思所成。依修等持所生胜慧名修所成。彼由未达毗婆沙意故作是言。然毗婆沙辩三相别意不如是。谓若有慧于加行时。由缘名力引生义解。此所引慧名闻所成。若加行时由思义力引念名解。由此于后生决定慧名思所成。若不待名唯观于义。起内证慧名修所成。如彼所宗辩此三慧。虽皆决定相无差别。而依至教正理等持。为因不同三相有别。如是我宗辩此三慧成时缘义。相虽无别而依缘名缘俱缘义。加行别故三相有别。且思所成是思正理。所生决慧为此加行。势力坚强无有谬失。重念师教名句文身。是思所成加行助伴。约加行说通缘名义。非成满位亦可通缘。是故于三决慧生位。虽俱缘义相无差别。而加行中有差别故。毗婆沙者约之显别。既尔思慧非为不成。闲居者言闻所成慧现在前位。轻安光明未遍所依。亦不坚住思慧行位。轻安光明未遍所依。少得坚住修慧行位。定力所引殊胜大种。遍身中故便有殊胜。轻安光明遍满身中。相续坚住由此行者。所依极轻容貌光鲜。特异常位三慧之相差别如是。余不定位亦有光明。然非皆是闻思慧摄。此中二慧名所成者。是因闻思力所生义。第三修慧名所成者。是即以修为自性义。如言命器食宝所成。诸有欲于修精勤学者。如何净身器令修速成。颂曰

  俱身心远离　　无不足大欲
  谓已得未得　　多求名所无
  治相违界三　　无漏无贪性
  四圣种亦尔　　前三唯喜足
  三生具后业　　为治四爱生
  我所我事欲　　暂息永除故

论曰。身器清净略由三因。何等谓三因。一身心远离。二喜足少欲。三住四圣种。谓若欲令修速成者。要先精勤清净身器。欲令身器得清净者。要先修习身心远离。身远离者。谓远恶朋心远离者。谓离恶寻由身心离恶朋寻故。身器清净心易得定。此二由何易可成者。由于衣等喜足少欲。言喜足者无不喜足。少欲者无大欲。诸有多求资生具者。昼狎恶朋侣。夜起恶寻思。由此无容令心得定。所无二种差别云何。谓于已得妙多衣等。恨不得此倍妙倍多。即于此中显等倍胜。更欣欲故名不喜足。若于未得妙多衣等。求得故名大欲。诸所有物足能治苦。若更多求便越善品是此中义。如契经言。随有所得身安乐者。令心易定及能说法。故有希求治苦物者。是为助道非为过失。故经主言。应作是说于所已得。不妙不多怅望不欢名不喜足。于所未得衣服等事。求妙求多名为大欲不应正理。所以者何。若已得物未能治苦怅望不欢。若都未得能治苦物。希求得者此不障定有何过失。又弹对法所辩相言。岂不更求亦缘未得。此二差别便应不成。理亦不然非对法者。言于已得妙多衣等。更别欣求余所未得。妙多衣等名不喜足。如何说二差别不成。若尔所言有何意趣。谓于已得足能治苦妙多衣等。即于此中显等倍胜。更生欣欲恨先不得。此衣服等倍妙倍多名不喜足。于已获得足能治苦。更倍希求方能障定。非于已得未能治苦。更倍希求便能障定。故对法者所说无失。或不喜足虽更希求与大欲殊故无有失。谓先已得诸资生具无所乏少。而更希求如是希求。从于已得心不喜足。所引生故果受因名名不喜足。于先未得诸资生具。心无所顾过量希求。如是希求名为大欲。二种差别其相如是。喜足少欲能治此故。与此相违应知相别。谓治不喜足不喜足相。违是喜足相能治大欲。大欲相违是少欲相是于已得能治苦物。不更希求名为喜足。于所未得能治苦物。不过量求名少欲义。喜足少欲界系通三。亦有越三无漏摄者。谓欲界系善心相应。喜足少欲是欲界系二界无漏例此应说。所治二种唯欲界系。以何证知色无色界亦有能治喜足少欲。以现见有生在欲界。从色无色等引起时。所治二种现行远故。能治二种现行增故。已说喜足少欲别相二种通相。所谓无贪以二俱能对治贪故。所治通相所谓欲贪。圣种应知如能治说。谓亦通三界无漏是无贪。如无色中虽无怨境。而亦得有无嗔善根。故无色中虽无衣等。而亦得有无贪善根。如彼不贪身亦不贪资具故。无色界具四圣种受欲圣者。于圣种中有阿世耶。而无加行众圣种故名为圣种。圣众皆从此四生故。展转承嗣次第不绝。前为后种世所极成。众圣法身皆从于衣生。喜足等力所引起。是圣族姓得圣种名。四中前三体唯喜足。谓于衣服饮食卧具。随所得中皆生喜足。此三喜足即三圣种。无贪善根有多品类。于中若治不喜足贪。此乃名为前三圣种。第四圣种谓乐断修断。谓离系修。谓圣道乐。谓于彼情深欣慕。以乐断及修名乐断。修即是欣慕灭及道义。或乐断之修名乐断。修即是欣慕灭之道义为证惑灭乐修道故。由此能治有无有贪故此亦以无贪为性。岂不第四亦能治嗔等。则应亦以无嗔等为性非无此义。然以前三为资粮故。前三唯是无贪性故。此亦自能对治贪故从显偏说。何缘唯立喜足为圣种非少欲耶。以少欲者容于衣等物有希求故。谓有意乐性下劣者。于未得境不敢多求。设已得多容求不歇。见喜足者少有所得。尚不更求。况复多得。故唯喜足建立圣种。或为遮止苦行者欲。不说少欲以为圣种。非彼外道心有胜欲。恒有劣欲熏相续故或随所得生欢喜心。不更欣求名为喜足。断乐欲乐此为最胜。欲界有情多乐欲乐。此乐欲乐违出家心。于离惑中令心闇钝。能障梵行静虑现前。为过最深喜足能治。故唯喜足建立圣种。非于未得多衣等中。起希求时心生欢喜。何况于少是故少欲。于能对治乐欲乐中。非最胜故不立圣种。缘衣服等所生喜足。如何可说是无漏耶。谁言如是喜足是无漏。若尔圣种宁皆通无漏。由彼增上所生圣道。彼所引故从彼为名。故言圣种皆通无漏。不作是言缘衣服等。所有喜足皆通无漏。少欲无漏准此应释。谓彼增上所生圣道。彼所引故从彼为名。非圣道生缘衣等境。世尊何故说四圣种。以诸弟子舍俗生具。及俗事业归佛出家。为彼显示于佛圣法。毗奈耶中有能助道生具事业。谓有厌离生死居家。出家求脱有何生具。于随所得衣服等中深生喜足。作何事业深乐断修。异此无能证涅槃故。何缘唯四不增不减齐此满足圣生因故。谓圣生因略有二种。一弃舍过。二摄持德。如次即是前三第四。是故唯四不增不减。或闻思修所成诸善。皆是圣种解脱依故。然为对治四种爱生。是故世尊略说四种。以契经说有四爱生。故契经言。苾刍谛听爱因衣服。应生时生应住时住应执时执。如是爱因饮食卧具。及有无有皆如是说。为治此四故唯说四圣种。于药喜足何非圣种。不说于彼有爱生故。为治爱生建立圣种。经唯说有四种爱生。是故于药不立圣种。或即摄在前三中故。谓药有在衣服中摄。有在饮食中摄有在卧具中摄。故于药喜足不别立圣种。或若于中引憍等过。对治彼故建立圣种于药无引憍等过生。故圣种无于药喜足。或一切人皆受用者。于彼喜足可立圣种。非彼尊者缚矩罗等。曾无有病受用药故。或一切时应受用者。于彼喜足可立圣种。非一切时受用药故。或医方论亦见说有于药喜足。毗奈耶中方见说有。衣等喜足圣种唯在内法有故。有言虽有于药喜足而不建立为圣种者。诸药有能顺梵行故。谓世现见乐学戒者。于药喜足障梵行故。或佛为欲暂息永除我我所事欲故说四圣种。谓为暂息我所事欲故说前三圣种为永灭除及我事欲故说第四圣种。经主于此自作释言。我所事者。谓衣服等。我事者。谓自身缘彼贪名为欲。若作此释义不异前。颂中不应别为文句。与前所说治四爱生。言虽有殊义无别故。由此我部毗婆沙师。更约异门释此文句。我所我执立以欲名。谓为暂时息我所执。故世尊说前三圣种。即于衣等所生喜足。及彼增上所引圣道。为永灭除及我事执。故世尊说第四圣种。即乐断修及彼增上。所引圣道皆名圣种。此门意显令有身见。暂息永除说四圣种。如是已说将趣见谛所应修行及修行已。为修速成净治身器。既集如是圣道资粮。欲正入修由何门入。颂曰

  入修要二门　　不净观息念
  贪寻增上者　　如次第应修

论曰。诸有情类行别众多。故入修门亦有多种。然彼多分依二门入。一不净观。二持息念。故唯此二名曰要门。为诸有情入皆由二。不尔如次贪寻增者。谓贪增者入依初门。寻增上者入依息念。如非一病一药能除。就近治门说不净观。能治贪病非不治余。息念治寻应知亦尔。然持息念缘无差别微细境故。所缘系属自相续故。非如不净观缘多外境故。能止乱寻既已总说。贪寻增者入修如次。由前二门此中先应辩不净观。如是观相云何。颂曰

  为通治四贪　　且辩观骨锁
  广至海复略　　名初习业位
  除足至头半　　名为已熟修
  系心在眉间　　名超作意位

论曰。修不净观正为治贪。然贪差别略有四种。一显色贪。二形色贪。三妙触贪。四供奉贪。对治四贪依二思择。一观内尸。二观外尸。利根初依前。钝根初依后。谓利根者先于内身。皮为边际足上顶下。周遍观察令心厌患。为欲伏治显色贪者。应专随念内身分中。脓血脂精涎洟髓脑。大小便等变异显色。及应随念众病所生。内身皮上变异显色。黄白青黑如云如烟。斑驳黧黯不明不净。由此令心极生厌患。便能伏治缘显色贪。以知此身为如是等。非爱显色所依止处。故于一切皆得离染。为欲伏治形色贪者。应别观察诸内身支。是发毛等三十六物。聚集安立和合所成。离此都无毛等形色。复以胜解分割身支。为二或多散掷于地。种种禽兽争共食啖。骨肉零落支体分离。由此令心极生厌患。便能伏治缘形色贪。为欲伏治妙触贪者。应以胜解除去皮肉。唯观骸骨涩如瓦砾。由此令心极生厌患。便能伏治缘妙触贪。为欲伏治供奉贪者。应以胜解观察内身。如眠醉闷颠痫病等。不能自在运动身支。如老病时或至未至。被如是事缠缚其身。又观内身不自在行。无不系属众缘故生。于中都无少许身分。可为供奉威仪所依。徒妄执为能供奉者。彼决定有能供奉事。然供奉名所目义者。谓以彼彼身分为缘。决定能为舞歌笑睇。含啼戏等威仪事业。观彼事业都无定性。如箜篌等所发音曲。一切皆类幻化所为。由此令心极生厌患。便能伏治缘供奉贪。是名利根初习业者。思所成慧观察内身。能伏四贪令不现起。若钝根者由根钝故。烦恼猛利难可摧伏。藉外缘力方能伏治。故先明了观察外尸。渐令自心烦恼摧伏。谓彼初欲观外尸时。先起慈心往施身处。如世尊说。初修行者欲求方便速灭欲贪当起慈心之澹泊路。精勤修观乃至广说。至彼处已为欲伏治四种贪故。应如四种澹泊路经。修不净观观外尸相。以况内身。彼相既然。此亦应尔。由此方便。渐能令心亦于内身深生厌患。便能伏治前说四贪。由于内身见自性故。为不净观速得成满。应修八想伏治四贪。为欲伏治显色贪故。修青瘀想及异赤想。为欲伏治形色贪故。修被食想及分离想。为欲伏治妙触贪故。修破坏想及骸骨想。为欲伏治供奉贪故。修膖胀想及脓烂想。许缘骨锁修不净观通能伏治如是四贪。以一骨琐中具离四贪境故。应且辩修骨琐观。然于引发诸善根时。补特伽罗约所修行。说有三位。一初习业。二已熟修。三超作意。且观行者欲修如是不净观时。应先系心于自身分。或于足指或于眉间。或鼻頞中或于额等。随所乐处专注不移为令等持得坚牢故。从入已去名初习业。入言为显最初系心。假想自身足指等处。下至能见钱量白骨。由胜解力渐广渐增乃至具见全身骨琐谓于此位诸瑜伽师。假想思惟皮肉烂坠。渐令骨净初量如钱。乃至遍身皆成白骨。彼于此位有多想转。想转言显不舍所缘。数数转生余胜解想。有余师说。观行未成作意但由想力故转。观行成已便由慧力。此位未成故由想转。应知此中所言作意。总显一切心心所法。皆由想力相续而转。见全身已复方便入。缘外白骨不净观门。谓为渐令胜解增故。观外骨琐在己身边。渐遍一床一房一寺。一园一邑一田一国。乃至遍地以海为边。于其中间骨琐充满。为令胜解渐复增故。于所广事渐略而观。乃至唯观自身骨琐。齐此渐略不净观成。名瑜伽师初习业位为令略观胜解转增。于自骨中复除足骨。思惟余骨系心而住。渐次乃至除头半骨。思惟半骨系心而住。齐此转略不净观成名瑜伽师已熟修位。为令略观胜解自在。除半头骨系心眉间。专注一缘湛然而住。齐此极略不净观成。名瑜伽师超作意位。应知至此不净观成。诸所应为皆究竟故。住空闲者作如是言。此观尔时有究竟相。谓有净相欻尔现前。由此或令入息减少。或令发起不欣乐心。了知所修地究竟故。净色相起扰乱心故。如人温诵所熟诵文。又由得先所未得故。进证得余胜善根故。如畦中水泛溢漫流。如是相名为此观究竟相。有余师说。若于尔时不于外缘起加行觉名不净观。究竟圆满所缘自在。若小若大应作四句。如理应思今应思择。此不净观既是胜解作意所摄。理应名为颠倒作意。则应此观体非是善。非此所缘体皆是骨。皆作骨解岂非颠倒。此不净观且不可言。皆是胜解作意所摄。以不净观总有二种。一依自实。二依胜解。依自实者。谓由作意相应慧力。如实观察自内身支所有不净。若形若显差别诸色。如九仙骨二商佉等。或如身中发毛爪等。广说具有三十六物。此等名为依自实观。由与自相作意相应。是故不能永断烦恼。依胜解者。谓胜解力假想思惟。诸不净相此非颠倒作意所摄。以与烦恼性相违故。夫颠倒者本所欲为不能成办。此随所欲能伏烦恼。如何颠倒若谓此境非皆是骨。谓皆是骨宁非倒者。理亦不然如应解故。谓诸于杌起人觉者。不作是解我今于杌以人相观故是颠倒。今观行者作如是思。诸境界中虽非皆骨。我今为伏诸烦恼故。应以胜解遍观为骨。既随所欲如应而解。能伏烦恼宁是颠倒。此观势力能伏烦恼令暂不行。既有如斯巧方便力如何非善。是故无有如所难失。此不净观何性几地缘。何境何处生何行相。缘何世为有漏为无漏。为离欲得为加行得。颂曰

  无贪性十地　　缘欲色人生
  不净自世缘　　有漏通二得

论曰。如先所问今次第答。谓此观以无贪为性。违逆作意为因所引。厌恶弃背与贪相翻。应知此中名不净观。名不净观应是慧者。理亦不然。观所顺故谓不净观能近治贪故。应正以无贪为性。贪因净相由观力除。故说无贪为观所顺。诸不净观皆是无贪。非诸无贪皆不净观。唯能伏治显色等贪。方说名为此观体故。此约自性若兼随行。具以四蕴五蕴为性。通依十地谓四静虑。及四近分中间欲界。唯尔所地此容有故。此观唯缘欲界色处境。欲界显形为此观境故。若尔何故契经中言。耳根律仪所防护者。住不净观乃至广说。此言为说诸为色贪所摧伏者。彼必由为缘声等贪之所摧伏故。欲摧伏缘色贪者。必先应住耳根律仪。由此方能住不净观。有说。此观唯依意识能引。所余违逆行相故若有住耳根律仪彼必应先住不净观。此不净观力能遍缘。欲界所摄一切色处。若谓尊者阿泥律陀。不能观天以为不净。舍利子等于佛色身亦不能观以为不净。如何此观遍缘欲色。此难不然。胜无灭者能观天色为不净故。佛能观佛微妙色身为不净故。由是此观定能遍缘欲色为境。由此已显缘义非名。亦已显成通缘三性。初习业者唯依人趣。能生此观非北俱卢。天趣中无青瘀等故不能初起。先于此起后生彼处亦得现前。此观行相唯不净转。是善性故体应是净。约行相故说为不净。是身念住摄加行非根本。虽与喜乐舍三根相应。而厌俱行如苦集忍智。随在何世缘自世境。若不生法通缘三世。此观行相非无常等十六行摄。故唯有漏通加行得及离染得。离彼彼地染得彼彼定时。亦即获得彼地此观。离染得已于后后时。亦由加行令得现起。未离染者唯加行得。此中一切圣最后有异生皆通未曾。余唯曾得

说一切有部顺正理论卷第五十九阿毗达磨顺正理论卷第六十

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩贤圣品第六之四

说不净观相差别已。次应辩持息念。此差别相云何。颂曰

  息念慧五地　　缘风依欲身
  二得实外无　　有六谓数等

论曰。言息念者。即契经中所说阿那阿波那念。言阿那者。谓持息入是引外风令入身义。阿波那者。谓持息出是引内风令出身义。如契经说。苾刍当知。持息入者。饮吸外风令入身内。持息出者。驱摈内风令出身外。慧由念力观此为境。故名阿那阿波那念。有余师说。言阿那者。谓能持来。阿波那者。谓能持去。此言意显入息出息有能持义。慧由念观此故得此念名。辩属身风略有六种。一入息风。二出息风。三发语风。四除弃风。五随转风。六动身风。谓诸有情处胎卵位。先于脐处业生风起。穿身成穴如藕根茎。最初有风来入身内。乘兹口鼻余风续入。此初及后名入息风。此入息风适至身内。有风续出名出息风。如锻金师开[橐-石+非]囊口自然风入。风性法尔但有孔隙。必随入故入已按之其风还出。入息出息次第亦然。理实此风无入无出。但如是转能损益身。相续道中假名入出。入息转位能逐身中。腐败污垢诸臭秽物。增长火界令身轻举。出息转时能除郁蒸。损减火界令身沉重。发语风者。谓有别风是欲为先。展转所引发语心起。所令增盛生从脐处。流转冲喉击异熟生。长养大种引等流性。风大种生鼓动齿唇。舌齶差别由此势力。引起未来显名句文。造色自性此居口内。名语亦业流出外时。但名为语。心生大种其理极成。谓见贪嗔痴心起者。面有润惨乱色异常。又亦传闻怀嗔毒者。面门生焰非有慈心。贪引火生焚身等故。除弃风者。谓有别风。随便路行能蠲二秽。由秽内逼有苦受生。由苦受生发除弃欲。由除弃欲引起风心。此心起风成除弃业。又此风力令身安隐。随转风者。谓有别风遍随身支诸毛孔转。由此故得随转风名。此不依心但依业力。随身孔隙自然流行。由此能除依孔隙住。腐败污垢诸臭秽物。动身风者。谓有别风。能击动身引起表业。应知此起以心为因。遍诸身支能为击动。因显风义乘辩六风。然于此中正明二息。此中意辩持息念故。此念自性是慧非余。以契经说了知言故。此品念胜故得念名。由念力记持入出息量。故为显缘息定慧得成。由念功能故说为念。并随行性应准前门。此念所依唯通五地。谓依欲界静虑中间。及初二三静虑近分。由此但与舍根相应为对治寻。修此念故乐苦等受。能顺引发亲里等寻故对治寻。要任运受现在前位。若尔何故辩息念中言觉喜乐。此亦无过以诸勤修持息念位。中间有彼无色相生。诸瑜伽师虽觉彼相。于持息念不名乖越。约此密说觉喜乐言。不可由斯执持息念。亦容得与余受相应。理实此中亦觉余法以身念住。加行位中亦说观于多六法故。谓若诸法随属于身。于彼法相如理观察。亦名于身住循身观。或彼行者转缘风觉。暂时观察喜受乐受。是故说言觉喜觉乐。由此故说诸圣弟子。尔时于受住循受观。岂不此位出持息念。不尔彼加行意乐不息故。速复更起缘风念故。若尔何故唯觉喜乐不觉余受。由此二受为贪染因力最胜故。行者欲令心于贪染。速解脱故偏观喜乐。有余师说。此非息念是彼加行所生功德。故觉喜乐立息念名有说。下三根本静虑正在定位亦有舍受。彼说此念通依八地。上定现前息便无故。此念但缘息风为境。非通缘上所说六风。此念初依欲界身起。唯人天趣除北俱卢。唯加行得非离染得。未离染者定由加行现在前故。非离染得地所摄故。已说皆是近分地摄非根本故。又此念唯是胜加行引故。不应说此有离染得。此唯真实作意相应。有说。亦通胜解作意。正法有情方能修习。外道无有无说者故。彼不能觉微细法故。此与我执极相违故。彼我执有故此念无。由具六因此相圆满。何等为六。一数二随三止四观五转六净。数谓系心数入出息。从一至十不减不增。恐心于境极聚散故。然于此中容有三失。一数减失。二数增失。三杂乱失。数减失者。于二等谓一等。数增失者于一等谓二等。杂乱失者。于五入数为出于五。出数为入是于入谓出于出谓入义。离此三失名为正数

或三失者。一太缓失。二太急失。三散乱失。太缓失者。谓由加行太慢缓故。便有懈怠惛睡缠心。或复纵心驰散外境。太急失者。谓由加行太躁急故。便令身心不平等起。若时力励数入出息。息被逼迫便令身中不和风起。由此风故初令身支诸脉洪数。此风增位能引病生。以身支病生名身不平等。或由力励数入出息。心被逼切便致狂乱。或为重忧之所摧伏。如是名曰心不平等。故有说言。诸有一切美妙饮食长养身支。无如有方便调入出息者。诸有一切毒刺刀火烈灰坑等损坏身支。无如无方便调入出息者。散乱失者。谓由心散便为一切烦恼摧伏。若十中间心散乱者。复应从一次第数之。终而复始乃至得定。凡数息时应先数入。以初生位入息在先。乃至死时出息最后。如是觉察死生位故。于无常想渐能修习随谓系心。随入出息念入出息。为短为长为远至何。复还旋返且念入息。为行遍身为行一分。随彼息入。行至喉心脐髋髀膝。胫踝足指念恒随逐。有余师言。念此入息从足下出。穿度金轮下至风轮复还旋返。若念出息离身为至一磔一寻。随所至方念恒随逐。有余师说。念出息风至吠岚婆复还旋返。经主于此斥彼师言。此念真实作意俱起。不应念息至风轮等。彼言息念本根虽与实作意俱。中间有余胜解作意相应起者。为令真实作意速成。故于中间起斯假想。虽尔无有出息念失。以息念加行意乐不歇故。止谓系念唯在鼻端或在眉间乃至足指。随所乐处安止其心。观息住身如珠中缕。为冷为暖为损为益。观谓观察此息风已。兼观息俱大种造色。及依色住心及心所。具观五蕴以为境界。转谓移转缘息风觉。安置后后胜善根中。谓念住为初至世第一法。净谓升进入见道等。有余师说。念住为初金刚喻定为后名转。尽智等方名净。息相差别云何应知。颂曰

  入出息随身　　依二差别转
  情数非执受　　等流非下缘

论曰。随身生地息彼地摄。以息是身一分摄故。此入出息转依身心差别故。本论说息依身转。亦依心转随其所应。若入出息唯依身转不依心转。则入无想定或入灭尽定。及生无想天息亦应转。乃至广说。具四缘故息方得转。依此理说随所应言。显息必依身心差别。言四缘者。一入出息所依身。二毛孔开。三风道通。四入出息地粗心现前。于此四中随有所阙息便不转。无心位中心无有故。生无色界四种皆无故息不转。处卵胎中羯剌蓝等。毛孔未开风道未通故息不转。若处卵胎羯剌蓝位。入出息转则应躁动。身微薄故便应散坏。頞部昙等位身虽渐厚。而无孔隙故息犹不转。入第四定毛孔不开。无现粗心故息不转。何缘但说入定非生。岂不已说生如说生。无想有本不说生无想者。但言入定生彼已成以契经中作如是说。此先入定后方生彼。有余师说。生第四定能发表业心现前时亦有息转。生彼容有息现前义故不说生。毗婆沙师不许此义。若尔生彼如何发言。彼亦有风然不名息。无损益果故无有失。言诸根熟诸根满者。此言不显眼等诸根。现见彼阙息亦转故。但于四缘具说根熟满声。以诸根声显增上义。四缘于息转有增上力。论假说为根亦无有过。如是诸根。处卵等位名未成熟。诸有正入第四定等名未圆满。言入第四定毛孔不开。如何有色身而无毛孔。毛孔者谓空界。岂有色聚离空界耶。理实应然但今于此约通息道说有色身。而无毛孔亦无有失。何缘但入第四静虑。身无毛孔非余定耶。以彼等持极淳厚故。引第四定大种遍身即由此缘。尊者世友说。入彼定身毛孔合。若入世俗第四静虑。身无毛孔其理可然。以彼定能引彼地摄。微密大种充满身故。若入无漏第四定时。此身如何亦无毛孔。以彼但引随所生地。大种现前造无表故。彼无漏定所引大种。虽生处摄而极微密。与彼相似故无有过。若生彼地身无毛孔。如何生彼能发语言。非发语言要由毛孔。但由颔动亦得发声。如机关声岂由毛孔。有余师说。生于彼地咽喉以上亦有毛孔。有说。生彼能发语心。现在前时暂开毛孔。此入出息有情数收。无觉身中息无有故。是虽从外来而系属内义。此入出息非有执受。以息阙减执受相故。身中虽有有执受风。而此息风唯无执受。此入出息体是等流。是同类因所生果故。身中虽有长养异熟风。而此息风唯是等流性。身增长位息便损减。身损减时息增长故。非所长养断已于后更相续故。非异熟生余异熟色无此相故。唯自上地心之所观。非下地心所缘境故。谓生欲界起欲界心。彼欲界身欲界息。依欲界心转即彼心所观。若生欲界起初定心。彼欲界身欲界息。依初定心转即彼心所观。起二三定心皆准前应说。生初静虑起三地心。生二生三起二起自准生欲界如理应说。若生上地起下地心。彼上地身上地息。依下地心转非彼心所观。如是欲界息四地心所观。初二三定息如其次第。为三二地自地心所观。有息地四无息地五。住有息地起无息地心息必不转。住无息地起有息地心息亦不转。住有息地起有息地心。随其所应有入出息转。所辩持息念成满相云何。应作是言。若观行者注想观息微细徐流。谓想遍身如筒一穴。息风连续如贯末尼。不能动身不发身识。齐此应说持息念成。有余师言。增长自在所作事办名此念成。初增长言显持息念。下中上品次第成立。乃至若时随其所乐。能入能出名为自在。若于此位能摄益身。远耽嗜依寻名所作事办。有余师说。若具六相远离三失。或若具足修十六种殊胜行相。齐此应说持息念成。经说息念有十七种。谓念入出息了知我已念入出息。短入出息长觉遍身。止身行觉喜觉乐觉。心行止心行觉心令心欢喜。令心摄持令心解脱。随观无常随观断随观离随观灭。如是一一皆自了知。此十七中初是总观。后十六种是差别观。约四念住如次应知。各有四门成十六种。如何觉心行可受念住摄。因受果名故无有过。非此中说心行谓思。应知此中受名心行。谓由耽着乐受味故。便于彼彼境界。或生思造作心名为心行。受是思因故名心行无失。或但能觉受自体者。义准亦于思等自体。次第能觉生住坏相。如尝大海一渧水碱。则亦遍知大海水味。故唯觉受名觉心行。广解一一相如经释中辩。如是已说入修二门。由此二门心便得定。心得定已复何所修。颂曰

  依已修成止　　为观修念住
  以自相共相　　观身受心法
  自性闻等慧　　余相杂所缘
  说次第随生　　治倒故唯四

论曰。已修成止以为所依。为观速成修四念住。非不得定者能如实见故。如何修习四念住耶。以自相共相观身受心法。谓修观者专心一趣。以自共相于身等境。一一别观修四念住。分别此法与所余法。有差别义名观自相。分别此法与所余法。无差别义名观共相。且身念住观自相者。谓观察身内外十处。自性各别从眼至触。一一皆有处自相故。如是于彼各别法中。有正智生名观自相。此自相观得成满时。有道色起尔时方立。自相种性身念住名。此亦遍知彼法自相。由此各别有正智生。非诸境中总生一智。有说。非此自相观中观无表色。以无表色与无色品极相似故。有说。此观亦观无表。亦别于无表有道色生故。次身念住观共相者。谓观察身一一处相。虽有差别而身相同。又于尔时观十一处。俱是色相无有差别。谓皆不越大种所造。如是于彼一类法中。有正智生名观共相。此共相观得成满时。有道色起尔时方立。共相种性身念住名。此亦遍知彼法共相。由此总有一正智生。非诸境中各生一智。或身念住观自相者。谓观于身各别自性。次身念住观共相者。谓观身上与余有为。俱无常性与余有漏。俱是苦性。与余一切法俱空无我性。若时观身无二念住故。唯极微集故。一一差别尔时名曰身念住成。如是应知受等念住相及成满随其所应。体皆非色故无极微差别。或如前说观究竟相。谓后后位善根增长。如畦中水泛溢漫流。有说。欻然非爱相起。此有二种。其二者何。一能发嗔。二令不乐。此中但有令不乐相。以所习事若未自在。为求成满故起欣乐。此于所习已得自在。止息希求故无欣乐。此四念住各有三种。自性相杂所缘别故。自性念住以慧为体。契经说为一趣道故。一是独义求战胜者。由此执此害烦恼怨。依此而行能趣圆寂。是故于此立趣道名。唯此独尊名一趣道。此即是慧于断烦恼。趣涅槃中慧最胜故。如契经说。姊妹当知诸圣弟子执智慧剑。能断一切结缚随眠。直趣涅槃无挂碍故。又契经说。若有于身住循身观名身念住。于受心法说亦如是。诸循观名唯目慧体。非慧无有循观用故本论亦说。身念住云何。谓缘身慧余三说亦尔。故知唯慧得念住名。慧中何等名自性念住。应知唯取闻思修所成。此中随闻加行所起。缘别义慧名闻所成。若随思义加行所起。非不待名亦非在定。缘别义慧名思所成。若在定中随观别义。不待名慧名修所成。即此亦名三种念住。相杂念住以慧所余俱有为体。慧俱有法与慧俱时相杂住故。如契经说。苾刍当知说善法聚言即说四念住。既于念住说善聚言。故以慧俱多法为体。本论亦说由身增上所生善道。通有漏无漏亦名身念住。乃至广说。此文总说与慧相应。俱有诸法名为念住。此文不言缘身道者。勿谓此如自性念住。体唯取相应道为其体故。所缘念住以慧所缘诸法为体。以一切法无不皆是。慧所缘故应名慧住。何故经中标以异名作异广释。此亦无失。约前三种释念住名皆唯慧故。且就自性释念住名。谓诸法中若有一法。由念得住彼名念住。此是何法是慧非余。宁知慧住要由念力。以有念者慧增明故。谓慧得住由念所持。是念力资方得住义。如是标释念住名时。唯依于慧不依余法。是故广释如所标名。名义相符斯有何失。若就相杂释念住名。谓与慧俱念方得住。令念得住故慧得念住名。念住相应及俱有法。与念住相杂名相杂念住。岂不定等亦与慧俱方得安住。则应许慧体令定等。住故得定等住名。不尔此中为显念慧。相资力胜故偏立念住名。谓慧若于身受心法。以自共相循循观时。要念力持方得明了。以于此地串习记持。方能进修余未习地。是故于慧简择法时。念最能为坚强助伴。念于身等得安住时。要慧力持方能明记。故世尊说若有于身。住循身观者念便住不谬。尊者无灭亦作是言。若有能于身住循身观缘身念得住。乃至广说。或若行者观身等竟。无间不能观于受等。便应追念先加行时。所有曾修受等行相。由追念故彼相现前。因此便能观察受等。故说有念慧得增明。如是念生由先慧力。故念与慧为胜助伴。或此二法于一切时。所有功能相随胜劣。故说二种相资最胜。若就所缘释念住名。谓慧由念令念住故。便于慧体立念住名。念住所缘身等诸法。是念住所缘名所缘念住。故约三种释念住名。皆显慧强独名念住。由此念住是慧理成。故释与标无相违失。分别论者作如是言。念住即用念为自体。此中不应置念根故。标释两文俱说念故。此中不说慧住名故。彼言非理。所以者何。虽于此中置念名想。而依业用已置慧根。如信定慧根虽不如次置证净静虑。了别谛中而由功能义已置故。标释两文显说慧故。谓前已辩标念住名。依慧非余显标慧故释中具以循观正知。二种慧名再说慧故。由此标释都不相违。说念住言义如前说。前何所说。谓前所言为显念慧相资力胜。是故偏立念住名等。又为具显三种念住。故不于此说慧住言。谓说念言显相杂念住。复说住言显所缘念住。说循观言显自性念住。若言慧住唯局慧体。自相不舍得慧住名。此则但明自性念住。便为弃舍相杂所缘。则彼俱应不名念住然不应许。以于契经及本论中皆说三故。由此为证诸念住言。目慧非余决定成立。何缘故说三种念住。为愚行相资粮所缘。三种有情故说三种。或根胜解分位各三。机宜不同故说三种。三中相杂能断烦恼。非二能断太减增故。与慧杂住得相杂名。理则但应慧俱有法。可得名曰相杂念住。非慧与慧可有相杂。无有一身二慧俱故。由此知慧非相杂摄。不应唯说相杂念住。能断烦恼理应具言。自性相杂能断烦恼。于断烦恼慧为首故。无如是过。断烦恼时于慧亦立相杂名故。谓得止观平等运道能断烦恼。其理决定。所余一切心心所等。有止品摄有观品收。此平等时彼亦平等。由是一切相杂理齐。显断惑时相杂理等。故亦于慧立相杂名。多于所成有胜能故。自性念住非。不亦能断诸烦恼体是慧故。然名自性谓无所待。断烦恼时必待余法故。断烦恼位慧立相杂名。由此所言相杂念住。能断烦恼理善成立。此中断烦恼但由修所成。然非此中闻思无用。随顺修故如殖树根。修所成中唯法念住能断烦恼。缘四五蕴或缘涅槃能断惑故。法念住中共相作意能断烦恼。自相作意缘少分境故无此能。四念住内前之三种。唯不杂缘第四通二。然三谛智唯有杂缘能断烦恼。唯灭谛智虽不杂缘亦断烦恼。杂缘智内至缘三蕴。亦定无有断惑功能。即于此中总缘一切。有漏无漏为无为等。亦定无有断惑功能。然不杂缘少杂多杂。于断烦恼非全无用。引发能断故修治身器故。彼于断惑但可能为。加行胜进二道自体。唯有处中杂缘法念住。及唯缘灭不杂法念住。亦为无间解脱道体。若断烦恼唯法念住。则法念住为无间道。此无间道现在前时。云何能修余三念住。若三念住非断治摄。乘无间道于未来修。断有顶染时应修世俗智。诸无间道中应修他心智。彼何障碍非未来修。故于此中应详理趣。非要同治方未来修。亦非所修都无限齐。后辩修处当广为释。身等念住各有三种。缘内外俱有差别故。且身念住有三种中。缘自相续说名为内缘他身等说名为外。双缘二种说为内外。以有我爱而慢缓者。应观内身犹如外故。或内如前缘无执受说名为外。缘他相续说为内外。待无执受及待自身得二名故。或缘根境及俱名三。或缘有情及非情数。通缘二种。差别为三。或缘有情外非情数。及发毛等差别为三。以彼皆从内身生故。离根住故具得二名。或缘有情现在名内。缘外非情三世名外。缘情去来说为内外。有情类故堕法数故。又彼未来当堕情数。正堕法数彼过去时。曾堕情数正堕法数。彼不生法是生类故。受等三种一一各三。随其所应准前应释。此四念住说次随生。生复何缘次第如是。生次如是相随顺故。有情多分于诸色中好受用故。不逮胜法好受用色以何为缘。谓于受中情深欣乐。欣乐于受由心不调。心之不调由诸烦恼。心由信等可令调伏。随观此理四念住生。或随所缘粗细生故。然非由此心最后观。法中涅槃极微细故。彼想思等循观受时。准义已能了知其相。同依心起等安危故。有余师说。色可聚散可取可舍。相似相续不净苦等易了知故。多分缘身生贪等故。男女展转起贪处故。不净观持息念及分别界。三入修门一切多缘身为境故。修念住位应最初观。此观为因生轻安触。由轻安触引生乐受。经说身安便受乐故。如是乐受依心而生。净心为因得解脱果。由是受等随次而观。故念住生如是次第。此四念住不增不减。能治净等四颠倒故。观身不净治于不净。谓净颠倒虽净颠倒通缘五蕴。然但观身自性非净便能总伏。如人已观粪体不净。亦不欣乐从粪所生。如是已观身体不净。亦不欣乐从身所生。由此观身为不净者。于五取蕴皆不欣乐。以有为身净想迷者。彼方欣乐依身所生。是故观身为不净者。于身所起亦不欣乐。如有安住不净观时。虽不亲观声等为境。而于歌等弃如粪秽。如是安住身念住时。虽不亲观受等为境。观身自体为不净故。终不欣乐受等三境。又虽不观色无色境。以为不净而于彼境。非不引生不乐行相。是故净倒虽缘五蕴身念住成便能总伏。后三念住虽各别观。例此应思能总伏理。观受是苦能治于苦谓乐颠倒。谓若有法真可欣欲。是为乐义于多过患。所杂行中见有可欣殊胜功德。是名于苦谓乐颠倒。此倒必用耽受为先。以于受中深耽着着己。方于一切逼恼所依。有漏行中妄生乐想。是故观受为苦性时。便能总伏计乐颠倒。观心无常能治无常谓常颠倒。谓观行者憎厌受故。于所依心见有众多。品类差别引无常观令现在前。便于有为不生常想。故能总伏计常颠倒。观法无我能治无我谓我颠倒。谓有一类闻我无常。心不生喜遂作是念。谁令此心有多差别。彼即是我为遮彼计。复应谛观除三所余。亦唯是法便于一切不起我想。故能总伏计我颠倒。或为对治段触识思食。如次建立身等四念住。数唯有四不增不减

说一切有部顺正理论卷第六十阿毗达磨顺正理论卷第六十一

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩贤圣品第六之五

如是熟修不净观持息念。二加行已能次第引所缘不杂。身受心法念住现前。复于不杂缘法念住无间。引所缘杂法念住生。次应修总缘共相法念住。此法念住其相云何。颂曰

  彼居法念住　　总观四所缘
  修无常及苦　　空无我行相

论曰。杂缘法念住总有四种。二三四五蕴为境别故。唯总缘五名此所修。彼居此中修四行相。总观一切身受心法。所谓无常苦空无我。然于修习此念住时。有余善根能为方便。彼应次第修令现前。谓彼已熟修杂缘法念住。将欲修习此念住时。先应总缘修无我行。次观生灭次观缘起。以观行者先观诸行从因生灭。便于因果相属观门易趣入故。或有欲令先观缘起。此后引起缘三义观。此观无间修七处善。于七处善得善巧故。能于先来诸所见境。立因果谛次第观察。如是熟修智及定已。便能安立顺现观谛。谓欲上界苦等各别。于如是八随次第观。修未曾修十六行相。彼由闻慧于八谛中。初起如斯十六行观。如隔薄绢睹见众色。齐此名为闻慧圆满。思所成慧准此应说。次于生死深生厌患。欣乐涅槃寂静功德。此后多引厌观现前方便勤修渐增渐胜。引起如是能顺决择。思所成摄最胜善根。即所修总缘共相法念住。从此无间生何善根。颂曰

  从此生暖法　　具观四圣谛
  修十六行相　　次生顶亦然
  如是二善根　　皆初法后四
  次忍唯法念　　下中品同顶
  上唯观欲苦　　一行一刹那
  世第一亦然　　皆慧五除得

论曰。从顺决择胜思所成。总缘共相法念住后。有修所成顺决择分。初善根起名为暖法。是总缘共相法念住差别。如是所起是当所修。能烧烦恼薪圣道火前相。如钻火位初暖相生。法与暖同故名暖法。住空闲者执暖法前。已起修所成共相法念住。虽亦有此而不皆然。若有先离欲界染者。依色界摄修所成慧。厌患生死欣乐涅槃。多厌行俱作意次第。能引异类暖善根生。诸有先时未离欲染。依思所成慧引暖善根生。故彼不应作一向执。此善根起分位长故。能其观察四圣谛境。由此具修十六行相。观苦圣谛修四行相。一无常二苦三空四无我。观集圣谛修四行相。一因二集三生四缘。观灭圣谛修四行相。一灭二静三妙四离。观道圣谛修四行相。一道二如三行四出。此相差别如后当辨。如契经说。此二痴人违越我法毗柰耶故。于中乃至亦无暖法。诸无暖者一切皆名违越正法毗柰耶不。不尔。二人资粮已备。有障法故退所应得故。言违越法毗柰耶。非诸无暖皆名违越。或此二人遇佛出世。舍所亲爱归佛出家。于古圣贤所游径路。已得安足若勤修习必于现身逮得胜利。以彼违越法毗柰耶。于诸胜利皆悉退失。下至暖法亦不能证。是故诸有遇佛出家。同此二人不能起。暖方名违越法毗柰耶。非诸无暖皆名违越。然诸暖法虽缘四谛。而从多分说厌行俱。以起彼时蕴相多故。行者修习此暖善根。下中上品渐次增进。于佛所说苦集灭道。生随顺信观察诸有。恒为猛盛焰所焚烧。于三宝中信为上首。有修所成顺决择分。次善根起名为顶法。是总缘共相法念住差别。顶声显此是最胜处。如吉祥事至成办时。世间说为此人至顶。谓色界摄四善根中。二是可动二不可动。可动二中下者名暖。上者名顶。动中上故。不动二中下者名忍。于四谛境极堪忍故。上者名为世第一法。世中胜故犹如醍醐闲居者言修此善品。其相至顶故名顶法。此境行相与暖法同。谓观四谛境修十六行相。何故唯说彼缘灭道。如契经说于佛法僧生少小信是名为顶。说信佛僧显缘道谛。信法言显缘灭谛故。无如是过。此信法言已具显缘三谛信故。如说于苦得现观时得法证净。乃至广说。或由灭道于生信胜。无过失故此中偏说。或由灭道可信可求。余不可求故此不说。如是暖顶二种善根。初安足时唯法念住。后增进位四皆现前。初安足言显以行相。最初游践四圣谛迹。后增进言显从此后。下中上品次第数习。诸先所得后不现前。于彼不生钦重心故。以胜加行引此善根。故已得中不生钦重。然此顶法虽缘四谛。缘三宝信多分现行。此顶善根下中上品。渐次增长至成满时。有修所成顺决择分。胜善根起名为忍法。是总缘共相法念住差别。于四谛理能忍可中此最胜故。又此位忍无退堕故名为忍法。世第一法虽于圣谛。亦能忍可无间必能入见道故。必无退堕而不具观四圣谛理。此具观故偏得忍名。故偏说此名顺谛忍。此忍善根安足增进。皆法念住与前有别。此与见道渐相似故。以见道位中唯法念住故。然此忍法有下中上。下中二品与顶法同。谓具观察四圣谛境。及能具修十六行相。上品有异唯观欲苦。与世第一相邻接故。由此能准暖等善根。皆时具缘三界苦等。义已成立无简别故。忍下中上如何分别。旦下品忍具八类心。谓瑜伽师以四行相。观欲界苦名一类心。如是次观色无色苦。集灭道谛亦如是观。成八类心名下品忍。中忍减略行相所缘。谓瑜伽师以四行相。观欲界苦乃至具足。以四行相观欲界道。于上界道减一行相。从此名曰中品忍初。如是次第渐减渐略行相所缘。乃至极少唯以二心观欲界苦。如苦法忍苦法智位。齐此名为中品忍满。上忍唯观欲界苦谛。修一行相唯一刹那。此善根起不相续故。上忍无间有修所成。初开圣道门世功德中胜。是总缘共相法念住差别。顺决择分摄最上善根生。此即说名世第一法。此有漏故名为世间。是最胜故名。为第一。有士用力离同类因。引圣道起故名最胜。是故名为世第一法。有余师说。此有漏故名为世间。成此必无断善根理故名第一。彼说不然。诸有修习施戒闻等殊胜善根。亦不断善不往恶趣。非皆可名世第一法。故彼所说非决定因。又彼自说与定相应。念住等差别名世第一法。然有得定念住差别。于后退失复断善根如天授等。故伽他说

  乃至彼愚夫　　由生长无义
  损害诸白分　　知于顶退堕

依天授说如是伽他。又理应然天授曾得神境通等胜功德故。由彼得定念住摄善。仍断善根是故彼宗。世第一法亦非决定不断善根。又成世间离欲道者亦不断善。应名第一成彼必无断善根故。若谓彼道非为决定。不断善根以有退故。是则汝宗世第一法。许有退故应容断善。以彼宗许第一有退。如言此退亦不相违。谓此退言于教及理。皆无违故许亦无失。然彼复说此或无退。以善根中此殊胜故。如是于证理亦不成。于诸行中殊胜作意亦应不退。彼宗许此于善根中是殊胜故。非此即是世第一法。以彼教中各别说故。若谓如是世第一法一切不退。此亦非因彼于善根亦殊胜故。一切不退应名第一。故彼所言不断善故名第一者非为善说。彼复有说此有漏故。名为世间。住等引中观四谛故名为第一。理亦不然。已见谛者有住等引。俗智现前观察四谛应名第一。若谓第一能入离生。又必应依异生身者。亦不应理因相等故。又诸行中殊胜作意。亦有此相应名第一又无经说此观四谛。故彼所言定不应理。由此所说此有漏故名为世间。入离生故名为第一。于理为善。此如上忍缘欲苦谛。修一行相唯一刹那。如如减略行相所缘。如是如是渐近见谛。故世第一唯缘欲苦。修一行相唯一刹那。说无间入离生位故。此位决定无相续理。若谓于此既有处说。起世第一当入离生。应相续者亦不应理。显入离生定由此故。谓此意显诸欲当入正性离生。一切必应起世第一故作是说。或于此中所言起者。显世第一未已生位。当至已生位入正性离生。不可引彼证此相续。又若相续第一不成。谓有二义可名第一。居异生身最后边故譬如树端。或世法中最为胜故譬如胜士。依此二理相续不成。以望后刹那前非第一故。谓前望后非最后边。亦非最胜何名第一。由此故说开圣道门。此为最胜故名第一。尚无二心俱时而起。为初圣道等无间缘。况有多心故无相续。由此本论言唯一心。所以者何。若非一者后于前心为劣等胜。且劣非理要胜进时。入离生故等亦非理。前既有障后应尔故。后若胜者前非第一。此中有难暖善根等。亦应准彼如是推征。暖顶忍位若多心者。后于前心为劣等胜。且劣非理非劣能入顶等位故。等亦非理前不能入后应尔故。后若胜者前非暖等。彼难不然。于暖顶忍曾不有说第一声故。谓于此中思择第一。彼声为说一心多心。然第一声唯说最胜。最胜心位可名第一。尚不说等何况劣心。暖顶忍中不言第一。何劳思择为劣等胜。由暖等位无第一言。可得析为下中上品。有多品故可非一心。世第一法无容如是。以上上品一刹那心。能入离生可名第一。非暖顶忍能入离生。是故不应如世第一。推征暖等唯上上品。许是第一名所显故。谓色界系有九善根。下下下中下上名暖。中下中中中上名顶。上下上中名忍。上上名世第一。彼又难言。如暖顶忍缘诸谛故。非唯一心世第一法。亦缘多谛宁唯一心。亦不应理。彼不了达此论宗故。夫欲设难须达论宗。知他所许方可征例。非我论宗许世第一。能缘多谛为例不成。又暖等中虽皆具有下中上品。曾不于彼说第一声故。第一声说上上品。上上品故唯一刹那。谓前三中皆有上品不说第一。故说第一唯上上品。由此第一刹那理成。对法诸师作如是说。为苦法忍等无间缘。故立一刹那名世第一法。有作是难此说不然。曾无此说故。无差别言故。异类为缘成过失故。唯一刹那不可说故。谓曾无圣教作如是说。能为苦法忍等无间缘故。立一刹那名世第一法。又诸圣教无差别言。但总相说起世第一。当入离生斯有是处。又若第一为苦法忍等无间缘。是则不应说名异类犹如暖等。谓如暖等能为顶等等无间缘。非是异类如是第一。若为苦忍等无间缘应非异类。若是异类能为苦忍等无间缘便成过失。又多物合一用方成故。若一刹那应不可宣说世第一法。能为苦忍等无间缘。唯一刹那义已成立。于如是说理应弃舍不应酬对。然彼愚类不了正宗。于此义中固为征难。今愍彼类略复开晓。反诘彼宗与此同故。言虽无别义已成故。等无间缘许异类故。许彼理实不可说故。谓亦无圣教说念住等名世第一。及成此必无断善根理故名第一。彼宗何故作如是言。又圣教中但总相说起世第一。当入离生义已显成世第一法。为苦法忍等无间缘。以苦法忍是离生一分故。说世第一无间入离生故。对法诸师为令所说易可了故。于离生位摽初刹那名苦法忍。彼宗亦许有苦法忍。以彼宗许苦法忍位有多刹那故。彼论言如世第一非唯一念。苦法忍等例亦应然。或彼宗但许于离生位有多刹那。即许初刹那以世第一为等无间。非彼一切离生刹那。可有一时俱生理故。由此彼说曾无说故。言无别故皆不应理。又我宗许异类亦作等无间缘理必应尔。以有诸法俱生相违。彼生必由互相开避。前法为后等无间缘。非俱生相违唯诸同类故。异类相望亦为此缘。由此应知若染不染。有漏无漏及界地等。同类异类心心所法。展转容作等无间缘。既尔彼言若世第一。为苦法忍等无间缘。是则不应说名异类。如暖等者有言无义。又我不言世第一法有能说者。如何为此许世第一有多刹那。然我所宗许世第一实不可说。而说名为世第一者。如说刹那谓如刹那实不可说。为欲展转相开示故。世间非不说为刹那。说世第一应知亦尔。然彼所言要多物合一用成者。此亦不定用有二种。一者世俗。二者胜义。即是假实世俗。一用依多物成。胜义一用依一物成。世第一法既是胜义。宁说彼一用要依多物成。以许此中实不可说。故世第一唯一刹那由此所说。为苦法忍等无间缘。立一刹那名世第一理善成立。此义已了。今复应思暖等四法以何为体。暖等自性皆慧为体若并助伴皆五蕴摄。定俱必有随转色故然除彼得。勿诸圣者暖等善根重现前故。然已见谛不许暖等重现在前。已见谛者加行现前成无用故。有余师言。依异生法无容圣者身中行故。有说此二俱非过失。得虽暖等摄如异生性故。谓如异生性是不得圣法。得圣法已彼犹现行。然彼体非异生性摄。不得一切圣法方名异生性故。如是暖等得。虽是暖等体。而无圣者身中行失。俱生相续体非体故。如沙门果诸无漏得。若谓相续沙门果得亦沙门果故。非喻者则应于后胜果道中有果现前。成违宗失。以宗安立八圣者中。住胜果道时于前沙门果。许得成就遮在身行故。彼所许有违宗过。又应果向俱时现行。立八圣者便不成就。住后果向前果唯成。而不现行可立八故。谓诸后向说前位果不在身行。为遮全果在身现行故作是说。得虽是果而非全故。设后位现行无住前果失。彼应许毕竟无住果者。毕竟无全果顿现行故。又胜果道无全现行故。亦应无住胜果道。然胜果道一分现行。亦许名为住胜果道。住少分果例亦应然。若谓定中有所得道。于出定位彼道不行与果何殊。而决定说唯是住向非住果者。又住果者起有漏心。果道不行应非住果。以非全果现在前故。或应与彼复共思择。何缘唯约圣道现行。立八圣者非约成就。勿住果向二圣相杂无如是失。以若住后胜果道时彼道胜故。如苾刍位虽成勤策近住律仪。而从胜故但名苾刍非勤策等。虽如是立八圣亦成。而约现行立八圣者。证知非住胜果道时。果不全现行故不名住果。由此前说于宗违害。及应果向俱时现行。二种过失彼定不免。是故前言俱生相续体非体故。圣者身中暖等诸得虽亦现起。而无暖等圣身行过故。应于此更辨。何缘暖等诸得非暖等体由此已遮。有余师说。勿世第一有相续过故。得定非世第一体。复有别失谓暖等三位。相续故得应彼体。或不应言世第一法一刹那故得非彼体。如是所说言有理无。故应舍此摄受前说。谓暖等得如异生性理不应然。异生性体与诸圣法极相违故。暖等得体与诸圣法。都不相违如何成例。以暖等得通在圣身。异生性得则不如是。故彼所引为例不齐。又沙门果诸相续得。虽亦许为沙门果体。而无八圣位相杂失。以诸安住胜果道者。果摄所得法必定不行故。安住果者胜果道摄。诸所得法亦不成故。若尔应许如苦忍等。谓且应如苦法智忍自性是慧。若并助伴即兼俱得五蕴为性。苦法智等现在前时。彼苦法忍得不名苦法忍。不尔应有相续过故。智现行时应修忍故。忍智二体应俱行故。如是暖等俱生诸得。虽亦名为暖法等体。而顶法等现在前时。彼暖等得不名暖等。不尔应暖等顶等为因故。及有如前所说过故。如是所说亦无深理。以暖法等性类同故。暖顶忍三位相续故。谓前已说色界所系有九善根。分为暖等以同类故互不相违。后念起前亦无有过。又暖顶忍位相续长。体虽已灭得相续起。名为暖等斯有何失。非世第一一刹那故。彼得便非世第一体。与余善根性类同故。顺决择分相无异故。若俱生得亦彼体者。何理能遮彼相续得。后得非故前亦应非由此极成。若并助伴皆五蕴性然除彼得。此中暖法初安足时。于三谛中随缘何谛。法念住现在修未来四随一行相。现在修未来四。唯修同分非不同分。缘灭谛法念住现在修未来一。随一行相现在修未来四。非初观蕴灭能修缘蕴道。后增进位于三谛中。随缘何谛随一念住。现在修未来四。随一行相现在修未来十六。缘灭谛法念住现在修未来四。随一行相现在修未来十六。此初安足唯修同分者。先未曾得如是种性故。于诸谛中行未广故。后增进位与此相违。故彼能修同分异分。顶初安足于四谛中。随缘何谛法念住。现在修未来四随一行相。现在修未来十六。后增进位于三谛中。随缘何谛随一念住现在修未来四随一行相。现在修未来十六。缘灭谛法念住。现在修未来四随一行相。现在修未来十六。忍初安足及后增进。于四谛中随缘何谛法念住。现在修未来四随一行相现在修未来十六。此依忍类总相而说差别说者略所缘时。随略彼所缘不修彼行相。谓具缘四具修十六。若缘三二一修十二八四。世第一法缘欲苦谛。法念住现在修未来四随一行相。现在修未来四唯同分修无缘余谛。世第一法是故唯修尔所行相。有余师说。近见道故似见道故。唯修尔所谓苦法忍。唯缘欲苦谛修四行相。世第一亦然。已辩所生善根相体。今次应辩彼差别义。颂曰

  此顺决择分　　四皆修所成
  六地二或七　　依欲界身九
  三女男得二　　第四女亦尔
  圣由失地舍　　异生由命终
  初二亦退舍　　依本必见谛
  舍已得非先　　二舍性非得

论曰。此暖顶忍世第一法。四殊胜善根名顺决择分。由下中上及上上品。分为四种如前已说。决谓决断。择谓简择决断简择。谓诸圣道。以诸圣道能断疑故。及能分别四谛相故。分谓分段即是见道是决择中一分摄故。暖等为缘引决择分。顺益彼故得顺彼名。故此名为顺决择分。如是四种皆修所成。非闻思所成。远决择分故此四善根皆依六地。谓四静虑未至中间。欲界中无阙等引故。余上地亦无见道眷属故。又无色界心不缘欲界故。欲界先应遍知断故。于三界中彼最粗故。此四善根能感色界五蕴异熟为圆满因。不能牵引众同分故。极厌诸有欣圆寂故。或声为显二有异说。谓暖顶二。尊者妙音说。依前六及欲七地。对法诸师不许彼说。非闻思所成顺决择分故。此四善根依欲身起。人天九处除北俱卢。唯依欲九身容入离生故。除增上忍世第一法。余三善根三洲初起。后生天处亦续现前。所余亦依天处初起。有余师说。若于先时曾已修治此四加行。彼于天处皆得初起。此四善根唯依男女。前三男女俱通得二。第四女身亦得二种。勿后得男身不成暖等故。依男唯得男身善根。圣转至余生亦不为女故。暖顶忍位容有转形故。二依善根展转为因性。世第一法依女身者。能为二因女得圣已。容有转得男身理故。依男身者但为一因。已得女身非择灭故。圣依此地得此善根。失此地时善根方舍。失地言显迁生上地异生。于地若失不失但失众同分。必舍此善根圣身见道力所资故。此四善根无命终舍。宁知命终舍唯异生非圣。以本论说。卵胎中异生唯成就身不成身业故。岂不异生先依下地起暖法等。后生上地亦必定舍。暖等善根无如是失。以彼异生尔时舍善根由舍同分故。谓住死有无圣道资。舍诸善根非由上地中有等起。若诸圣者住死有中。由圣道资不舍暖等。但由上地中有等起。舍下善根舍时虽同而所由别。是故异生无失地舍。圣者必无由命终舍。异生命终虽舍忍法。而定无有堕诸恶趣。得恶趣生非择灭故。身是忍法曾所居故。能感恶趣诸业烦恼。不复能在身中行故。如师子窟杂兽不居。初二善根亦由退舍。如是退舍异生非圣。后二异生亦无退舍。依根本地起暖等善根。彼于此生必定得见谛。以根利故厌有深故。依未至中间起暖等者。于此生不必得入见谛。有余师言。依根本定起暖等者。此生必定得至涅槃厌有深故。若先舍已后重得时。所得必非先之所舍由先舍已。后重得时亦大劬劳方得起故。于先所舍不钦敬故。如先已舍别解脱戒。后重受时得未曾得。暖等亦尔后得非先。若先已得暖等善根。经生故舍遇了分位。善说法师便生顶等。若不遇者还从本修。失退二舍非得为性。退舍必因起过而得失舍。或有由德增进得此善根有何胜利。颂曰

  暖必至涅槃　　顶终不断善
  忍不堕恶趣　　第一入离生

论曰。四善根中若得暖法。虽有退断善根。造无间业堕恶趣等。而无久流转必至涅槃故。若尔何殊顺解脱分。若无障碍去见谛近。此与见道行相同故。是等引摄胜善根故。若得顶法虽有退等。而增毕竟不断善根。观察三宝殊胜功德为门引生净信心故。若得顶已不断善根。如何经说天授退顶。由彼曾起近顶善根依未得退密作是说。若得忍法虽命终舍住异生位。而增无退不造无间不堕恶趣。然颂但说不堕恶趣言。义准已知不造无间业。造无间业者必堕恶趣故。忍位无退如前已辩。得忍不堕诸恶趣者。已远趣彼业烦恼故。得恶趣生非择灭故。由下忍力已得一切恶趣无生。由上忍力复得少分生等无生。少分生者谓卵湿生。由此二生多愚昧故。等言为显处身有惑处。谓无想大梵北洲。无想大梵僻见处故。北俱卢洲无现观故。身谓扇搋等多诸烦恼故。有谓第八等圣必不受故。或谓见断惑必不复起故。得世第一法虽住异生位。而能趣入正性离生。颂虽不言离命终舍。既无间入正性离生。义准已成无命终舍。何缘唯此能入离生。已得异生非择灭故。能如无间道舍异生性故。此四善根各有三品。由声闻等种性别故。随何种性善根已生。彼可移转向余乘不。颂曰

  转声闻种性　　二成佛三余
  麟角佛无转　　一坐成觉故

论曰。未殖佛乘顺解脱分。依声闻种性起暖顶善根。容可转生佛乘暖顶。是经长时方能起义。若起彼忍无向佛乘。以声闻乘加行最久。经六十劫自果必成。菩萨专求利他事故。为欲拔济无边有情。弘誓庄严经无量劫。故往恶趣如游园苑。若不尔者无成佛义。起忍得一切恶趣非择灭故。起彼忍无向佛乘断绝众多利他事故。若时菩萨已殖佛乘顺解脱分。为遮恶趣展转坚摄施戒慧三。尔时无劳起余乘忍。故声闻暖顶可转向佛乘。起忍则无转成佛义。依声闻种性起暖顶忍三。皆可转生独觉乘道。非声闻种性忍法已生。于独觉菩提有能障义。故起彼忍亦成独觉。此在佛外故颂言余。起独觉乘种性暖顶。为有转向余乘理。不然。独觉乘总有二种。一麟角喻。二先声闻。若先声闻如声闻说。麟角及佛俱不可转。以俱一坐成菩提故。第四静虑是不倾动。最极明利三摩地故。堪为麟角大觉所依。故彼俱依第四静虑。从身念住至尽无生。唯于一坐能次第起。故麟角喻及佛种性。暖等善根皆不可转。颇有初殖顺解脱分。此生即能起顺决择分耶。不尔云何。颂曰

  前顺解脱分　　速三生解脱
  闻思成三业　　殖在人三洲

论曰。顺决择分今生起者。前生必起顺解脱分。诸有创殖顺解脱分。极速三生方得解脱。谓初生殖顺解脱分。次生成熟第三生。起顺决择分即入圣道。若谓第二生起顺决择分。第三生入圣乃至得解脱。彼言便与前说相违。谓依根本地起暖等者。彼必于此生得入见谛。或彼应许极速二生。谓第二生依根本地。起暖等者彼于现生。必入圣道得解脱故。顺解脱分闻思所成非修所成。诸有未殖顺解脱分者。彼不能殖故。顺解脱分三业为体。最胜唯是意地意业。此思愿力摄起身语。亦得名为顺解脱分。有由少分施戒闻等。便能种殖顺解脱分。谓胜意乐至诚相续。厌背生死欣乐涅槃。与此相违虽多修善。而不能殖顺解脱分。由意业胜殖此善根。故唯人中三方能殖。厌离般若余处劣故。有佛出世若无佛时。俱能种殖顺解脱分

说一切有部顺正理论卷第六十一阿毗达磨顺正理论卷第六十二

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩贤圣品第六之六

已因便说顺解脱分。入观次第是正所论。于中已明诸加行道。世第一法为其后边。应说从斯复生何道。颂曰

  世第一无间　　即缘欲界苦
  生无漏法忍　　忍次生法智
  次缘余界苦　　生类忍类智
  缘集灭道谛　　各生四亦然
  如是十六心　　名圣谛现观
  此总有三种　　谓见缘事别

论曰。从世第一善根无间。即缘欲界苦圣谛境有无漏摄法智忍生。此忍名为苦法智忍。宁知此忍是无漏摄。从世第一无间而生。以契经中言世第一无间入正性决定。或正性离生。尔时名越异生地故。此忍既是决定离生。一分所摄定是无漏。从世第一无间而生。说无漏言为欲简别世第一法。所从世忍此无漏忍。以欲苦法为其所缘名苦法忍。谓于苦法无始时来。身见所迷执我我所。今创见彼唯苦法性。忍可现前名苦法忍。此能引后苦法智生。是彼智生障之对治。故复名曰苦法智忍。经主此中作如是释。为显此忍是无漏故。举后等流以为摽别。此能生法智是法智因。得法智忍名如花果树。详彼意谓唯说忍言。恐此有同加行忍失。此无深理。非为彼法有此法生。此法必应与彼同类如花果树。断对治等因果类殊。又不极成以苦法智。是无漏性非为极成。如何忍生彼同彼是无漏。又此无同加行忍失。说世第一无间生故。说此能越异生地故。非有漏忍能成此事。又如何知此苦法忍。以苦法智为等流果。若谓此忍是无漏故及前生故。理亦不然。未说此忍无漏理故。由此证知前释为善。即此名入正性决定。亦复名入正性离生。由此是初入正性决定。亦是初入正性离生。故经说正性。所谓涅槃或正性言目诸圣道。能决趣涅槃或决了谛相故。诸圣道得决定名。至得决定说名为入。若尔何缘于无漏慧。唯初见谛得决定名。以于尔时于诸谛理。初得难毁决定见故。或于尔时望余位道。有非一种决定相故。谓见道位刹那刹那。定间杂得忍智行相。余道不然。又见道中障治定别。以定唯断见所断故。余道不然。谓修位中或有双断见修断惑。或唯断修。又见道中解脱道后定起无间。余道不然。又见道中定是无漏。定十五念。定不起等。余道不然。故独名定。有余师说。于见位中决定初得八圣同分。故唯见道立决定名。烦恼名生。如契经说何谓生。具谓诸烦恼。见位初越故名离生。有说生言目根未熟。见位初越故名离生。至得离生说名为入。如本论说。世第一无间舍异生性。为世第一。为苦法智忍。为共能舍。有余师言。唯世第一若谓此是异生法故应无舍力。此难不然。性相违故。依彼舍彼如上怨肩而害怨命。有余师说。唯苦法忍此忍生时舍异生性。此忍灭位断十随眠。如灯生时能除闇障。灯至灭位烧炷尽油。若谓二能属灯明触。不应引喻一法二能。此难不然。如一法上生位灭位。二有性殊两位功能亦应异故。理不应许生时有性如灭。亦不应许灭时有性如生。又非功能离于有性。离有性外别有功能。自体不成世中已辩。又见一法一刹那中有多功能。如四正断故所立喻理非不成。然于此中所立喻意如灯据总。体虽是一实物异故功能有殊。谓有生时起功能者。有于灭位方有功能。如是一物由时别故。所有功能亦应有别。故苦法忍生时。有能舍异生性。灭时有用断十烦恼。斯有何失。若责未来宁有作用。此先已释。先释者何。此于功能假说作用。定无作用于去来有。辩世相中已具思择。有余师说。此二共舍如无间道解脱道故。谓世第一如无间道。与异生性成就得俱灭故。苦法智忍如解脱道。与异生性不成得俱生故。此忍无间即缘欲苦。有法智生名苦法智。于唯是苦法得决断慧故。应知此智亦无漏摄。前无漏言遍流后故。如缘欲界苦圣谛境。有苦法忍苦法智生。如是复于法智无间。总缘余界苦圣谛境。有类智忍生名苦类智忍。此忍无间即缘此境。有类智生名苦类智。最初证知诸法真理故名法智。此后境智与前相似故得类名。是后随前而证境义。或从前生故后得前类名。如世间言子是父类。即是从欲界苦决定觉所生。余界苦决定觉义。如缘苦谛欲界及余。生法类忍法类智四。缘余三谛各四亦然。即缘一一有四心义。谓复于前苦类智后。次缘欲界集圣谛境。有法智忍生名集法智忍。此忍无间即缘欲集。有法智生名集法智。次缘余界集圣谛境。有类智忍生名集类智忍。此忍无间即缘此境。有类智生名集类智。次缘欲界灭圣谛境。有法智忍生名灭法智忍。此忍无间即缘欲灭。有法智生名灭法智。次缘余界灭圣谛境。有类智忍生名灭类智忍。此忍无间即缘此境。有类智生名灭类智。次缘欲界道圣谛境。有法智忍生名道法智忍。此忍无间即缘欲道。有法智生名道法智。次缘余界道圣谛境。有类智忍生名道类智忍。此忍无间即缘此境。有类智生名道类智。如是次第有十六心。总说名为圣谛现观。以于三界四圣谛境。次第现前如实观故。既于三界四圣谛境。旋环纷扰作意思惟。宁不能为现观障碍。初习业地于诸谛境。多返旋环已淳熟故。又在见道行极速故。又由不起阿世耶故。又此势力极猛利故。必无能为此障碍者。即由此理说见道位。名为无相不可施设。住此位中相难了故。法类忍智于诸谛境。行相差别难施设故。此中上座。违越百千诸瑜伽师。依真现量证智所说。展转传来如大王路。谛现观理率意。别立现观次第。谓瑜伽师。于四谛境先以世智。如理观察次引生忍。欲慧观见此忍增进。作无间缘亲能引生。正性决定引起圣道。光明相故此忍现前。如后圣道于四谛境。忍可欲乐简择观察。推度分明如隔轻纱。光中观像此位名入正性决定。后于四谛以妙决择。无动智见名为预流。佛说涅槃名为正性。此能定趣得决定名。故前名入正性决定。即能入位名谛顺忍。此忍非在世第一前。彼谓佛说五取蕴已。复作是言若于此法。以下劣慧审察忍可名随信行。若于此法以增上慧。审察忍可名随法行。故依得忍建立随信随法行者。非依得智。又以世尊于成证净。见谛圆满正见者中。决定除斯随信法行。以于集总伽他中说。二最胜二净通达外二种。故此二种未得圣智。此复何殊世第一法。由圣定忍与前有异。谓出世故此名为圣。无动摇故此名为定。由圣定故名为见谛。然此犹名未得圣道。若得圣道转名预流。是故世尊告舍利子。八支圣道说名为流。若尔何缘名为圣者。由此已得圣定忍故。住此忍位为经久如。引圣道力强故非久然阙缘故。有时暂出作余事业。非不得果可于中间有命终理。此圣定忍有何为障。虽已现行而未断惑。智未满故未决定故。次起苦法智名预流初心。尔时便能顿断三结。能永断彼旧随界故。从此引生苦类智等。是故现观定有八心。今详彼宗现观次第。违教违理前后相违。违教者何。如世尊说诸有永断三结名为预流。彼于四圣谛中具现观故。此经显示二决定理。一显非得苦智即名预流。二显非苦智时顿断三结。此经意说。遍知四谛名预流故。又说预流方能毕竟断三结故。如何违理。且彼所说苦法智位即名预流。应住忍时名预流向。此预流向如预流果佛说有学。以契经说诸有学者有十八故。要得学法名有学者。故知圣忍亦名学法。忍是学法非圣道收。如是所言何大违理。又违别理。谓世尊言。是随信行随法行者。入正性决定越异生地。未得预流果。乃至广说。如何许彼越异生地。而未得名成就圣道。又说八种补特伽罗。从预流向至阿罗汉。此八圣者应延应请。应合掌礼。乃至广说。非无圣道可厕此流。又说如所余得圣道者故。谓契经说。若有五根增上猛利极圆满者。名俱解脱阿罗汉果。广说乃至。若有五根极劣钝者。名随信行非无圣道。可同此说。如何彼说。前后相违。谓诸道名目正见等此有二种。谓世出世。离此二外无第三道。既许圣忍是出世间。应如法智等亦圣道所摄。若不许此是圣道摄。亦应不许是出世间。许出世间非圣道摄。岂不彼说前后相违。若苦智时非预流者。善逝所说当云何通。经说。世尊告舍利子。八支圣道说名为流。于我无违何烦会释。谓我不说初入圣道即名预流。说预流名目得初果。经亦不说得八圣道皆名预流。但说名流何违须释。理应遍预知八谛境。圣道流者名预流故。然经摽列家家七返一间一来。欲阿罗汉五种不还十圣者已。复作是说。诸有成就佛证净者。一切皆名见谛圆满。正见者摄此成证净见谛圆满正见者中。前五圣者此处通达彼处究竟。后五圣者此处通达彼处究竟。乃至广说。于此经中不说随信随法行二。有别所以谓要具足见四圣谛。方得名为见谛圆满。及成证净无缺减者。彼随信行随法行者。乃至证得道类忍时。犹得名为成就邪见。故未名得见谛圆满及成证净无缺减者。非于三谛得现观时可名已成佛僧证净。即由此证苦法智时。仍未名为得预流者。由此经说诸预流者。见谛圆满具成证净。故彼所引如是契经。自害己宗非违他说。或此唯说于其位中。可有语言容命终者。彼随信行随法行者。二事俱无故此不说。理不应说随信行者随法行者。不成证净。如契经说。若有于彼四种证净一切皆无。我说彼居外异生品。此二行者许是有学。说为异生。不应正理。又此不摄在十圣者中。便无证净等有大过失。谓佛独觉亦不摄在十圣者中。岂可说言佛及独觉。在成证净见谛圆满正见者外。若谓佛独觉在罗汉中。二最胜经便为无用。谓彼经说有十圣者。四向四果并佛独觉。唯佛独觉名为最胜。虽阿罗汉亦可摄彼。而更别说以最胜故。应知此经理亦如是。非二摄在阿罗汉中。然此经中不说彼二。岂由不说故彼无证净等。理既应许佛及独觉。非十圣摄成证净等。随信法行宁不许然。又此契经。非了义说。由此经说。十种圣者皆具成就十圣道支。即八道支。谓正见等。又加正智及正解脱。余契经说。诸有学者但可成就前八道支。具成就十唯阿罗汉。此契经意应更寻求。是故定知非了义说。又预流等此处通达。当于彼处得究竟者。谓彼现身当全离欲。生色无色方般涅槃。彼住预流一来等位为十圣摄为不摄耶。若摄便违此经所说。非此经说预流果等。于此处通达彼处究竟故。若不摄者应许彼类。亦是不成证净等者。准此应责欲阿罗汉。在有学位十中摄不。若谓随所举摄其余位。则随信法行亦在十中。此若不然彼云何尔又佛独觉在有学位当言摄在何圣者中。不摄便应无证净等故。此经意应更思求。由此定知非了义说。非由不说在十圣中。随信法行无证净等。是故不可以不说在十圣者中。便定证成随信法行未得圣智。又此随信随法行者。应起圣道如余果向。谓如已得预流果等。于后进趣一来等时。未得彼果名彼果向。中间必有圣道现前。准此应知随信法行既是预流向。应定起圣道圣果向摄无差别故。由此契经说二行者。未得预流果中间不命终。然圣道流总有二种。谓是果非果摄要至果流名预流果。此二虽得预非果流。而未得名预果流者。此若未得果中间不命终。既以果声标所未得位。故知此二非全未预流。不尔经中应作是说。未得预流位中间不命终。何烦果声标所未得。又若随信随法行者未得圣道。便应创得住见道位即名预流。尔时此名理应未得。住见道者见未净故。要见净已方名预流。经言预流见已清净。为令见净故修圣道。若离圣道无别有法能令见净。由此见道见未净故未名预流。然彼亦说随信法行。能令见净而复执彼未得圣道。非为善执。彼谓佛说若于此法。以下劣慧审察忍可名随信行。乃至广说。故由忍力能令见净非由圣道。此无至教亦无正理。证忍非圣道但率己妄情。故于彼言无劳广遣。经唯说圣道能令见净故。又彼所立现观八心。法类二心用应无别。谓法智品已能具见一切谛相。于后复起类智品道。更何所为。彼作是言。且苦法智由缘内外。念住势力之所引生。故此智生随逐于彼了知苦相。次苦类智随法智生。于诸行中能随决了。与前所了相似苦相。余法类智例此应知。今详彼言。法类二智无有少分力用差别。谓苦法智于诸行中。已能遍知一切苦相。次起类智于诸行中。更别有何应随决了。或彼应说苦法智时。于苦相中有何未了。为随决了生苦类智。彼许三界行苦相。无别总相思惟入正性决定。以彼宗说要总相观三界苦法能入现观。既尔法智已总相知。后类智生复何所用。又苦法智随念住生。随彼遍知三界苦相。应名类智失法智名。差别因缘不可得故。由此理证知彼所宗。极为妄立法类别相。又彼所立皆以圣教为胜所依。依何至教定知现观。心唯有八。若不依凭至教所说。随己所欲不审思求。见少圣言便生欢喜。由斯轻尔别立宗趣。是则所立种种宗途。皆应得成。何执唯八。谓若见说应观一切唯法无我。是则应执一心现观。若复见说断诸疑网由知苦因。是则应执二心现观。又若见说法从因生。乃至广说。是则应执三心现观。又若见说如实知苦。乃至知道。是则应执四心现观。又若见说如实了知集没爱味过患出离。是则应执五心现观。又若见说修七处善。是则应执七心现观。如是等说其数寔多。岂可随言起种种执扰乱圣教詃惑有情。故瑜伽师依真现量。证智所说展转传来。如大王路谛现观理。虽被分析成多部异。然应方便简伪依真。无容率己更立宗趣。如人舍宅已被焚烧。更持干草用资猛焰。又彼所说圣忍位中。由阙缘故有时暂出作余事业。亦不应理。以诸见道修道初心加行一故。云何知尔。更不说有别加行故。又说中间无命终故。若谓随信随法行者。世尊说彼应不放逸。修集诸根如余有学。应有出观。故契经言。苾刍谛听。何等色类。我说彼为应不放逸。广说乃至。复次苾刍非俱解脱。非慧解脱。非身证非见至。非信胜解。应不放逸修集诸根如随信行。广说乃至。苾刍当知。如是色类。我说彼为应不放逸。所以者何。谓彼具寿应不放逸。修集诸根于随顺身妙卧具等亦不染着。亲近承事供养善友。得漏尽故成心解脱。如是应说随法行者。非二行者都不出观。可有如上所说道理。又如佛告婆拖黎言。苾刍当知。置俱解脱。广说乃至。置信胜解。若随法行来至我所。我设告彼善来苾刍。可处泥中为我桥道。我当践汝渡此淤泥。于意云何。彼随法行。我将践位舍我起不。正践彼时有动转不。后以言词申劳倦不。婆拖黎曰。不也世尊。说随信行应知亦尔。非二行者正在定中。可为世尊之所告敕。及起身业发语言理。又天神告沃揭罗言。长者当知。此俱解脱。此慧解脱。广说乃至。此随法行。此随信行。此阿罗汉果。此阿罗汉向。广说乃至。此预流果。此预流向。汝应供养深自庆幸。又契经说。若有供养一预流向。乃至广说。由此证知随信法行。由阙缘故有时暂出。如是所引为证不成。于彼先时立后名故。如余经说。无明所覆爱所系缚。愚夫智者同感此身。非诸智者无明所覆感得此身。然先感身后成智者。于先非智者立后智者名。又如余经说。中般涅槃等亦于前位立后位名。中有等时得阿罗汉果。要至最后方般涅槃故。又如余经说。欲阿罗汉等此处通达。非阿罗汉等可有通达义。但说先时如是应知。说随信行随法行者。应不放逸。修集诸根及处泥等。皆于前位立后位名。以必当成随信行等。于未成位预立彼名。如何得知经有此意。以前经说。谓彼具寿得漏尽故。成心解脱。非随信行随法行者。可得漏尽成心解脱。然于后位立前位名。以漏尽时追说前位。曾为随信随法行者。如是前位应不放逸。修集诸根及处泥等。后必当成随信法行。故于前位立后位名。如余契经。互说无失。由是前说。以诸见道修道初心加行一故。随信随法行无出观理成。故彼所言于圣忍位由阙缘故。有时暂出作余事业但率己情。又彼所言苦法智起力能顿断三结随界。尔时名曰预流初心。此亦不然。理不成故。谓苦法智顿断三结旧随界者。为生时断为灭时断。若生时断。最后学心应成无学。由彼生已无烦恼故。若灭时断。住苦法智便非预流。尔时三结随界转故。以契经说三结已断方名预流。是故汝曹宁作是说。苦法智忍断三结随界。苦法智起成预流初心。必不应言苦法智断。然彼所说圣定忍位未决定故。不断烦恼智亦应言未得决定。以苦法智现在前时。未已断疑旧随界故。若不为与疑随界俱。圣忍何缘言未决定。又渐现观是上坐宗。苦法智时余疑未断。应如圣忍未得决定。应亦未能断诸烦恼。然彼宗说初苦智时。力能顿断三结随界。彼与圣道极相违故。谓最下品圣道生时。势力已能浣濯相续。令彼三结随界顿断。由相续中缘无常苦空无我见都未有时。萨迦耶见戒禁取疑容相续转故。苦法智现在前时顿断三结。若尔便应于后后位观余圣谛功并唐捐。彼反诘言。何不乘难此位应得阿罗汉果。岂不为断余未断结。此全无理。迷集等疑苦智能灭。理不成故。谓于集等有迷惑者。非由见苦于彼能解。以见苦相时未见彼相故。非未解彼灭迷彼疑。非苦智违集等疑故。或应苦智亦与诸余见断结相违。无差别因故。非常等见都未有时。于相续中诸见所断。皆有断义故。苦智生应皆顿断。宁唯三结。由此彼说非应理因。彼反诘言。亦不应理。以未应得阿罗汉故。设于尔时见道所断所有诸结皆断尽者。亦未容得阿罗汉故。以能具见一切谛者修所断结犹未断故。由此或应许苦法智不能顿断三结随界。或复应许苦法智时顿断一切见所断结。如是则应于后后位观余圣谛功并唐捐。既尔不应许渐现观。又详上坐所立义宗。似许预流都未见谛。以彼上座自作是说。谓最下品圣道生时。势力已能浣濯相续。令彼三结随界顿断。圣道生位必在未来。然彼所宗未来未有。若圣道未有能浣濯相续。令彼三结随界顿断。岂不说彼未见谛位。三结随界身中已无。便成预流都未见谛。若彼意谓圣道生时。于相续中犹有随界。如何可说圣道生时。势力已能浣濯相续。三结随界犹住其身。而言已能浣濯相续。如是意趣极为难了。若复意谓圣道正生。三结随界尔时正灭。亦不应说圣道生时。势力已能浣濯相续。夫言正灭必是现在。圣道生时随界有故。又彼设谓随界灭时不能为因牵后随界。即依此义名已浣濯。亦不应说已浣濯言。但可说为正浣濯故。又前所说则成预流。都未见谛过终难免。彼于一谛理见仍未满故。于一二三谛见未圆满时。犹可名为见未见谛。要具见谛方名预流。以经说预流见谛圆满故。况于一谛犹见未圆。而可名为得预流者。若谓圣道现在名生。尔时已能浣濯相续。则旧随界是忍所断。尔时智起彼体已无。则于自宗有相违过。又彼许忍非圣道收。如何能断三结随界。又现在世名为已生。说为生时不应正理。是故上座所立义宗。理或不应许渐现观。或定应许见道谛时。方能无余永断三结。是则符顺我对法宗。不应自言别立宗趣

说一切有部顺正理论卷第六十二阿毗达磨顺正理论卷第六十三

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩贤圣品第六之七

如是已破上座所宗。唯执八心名谛现观。余部于此有作是言。诸圣谛中唯顿现观。彼言既总理或无违。以谛现观总有三种。其三者何。谓见缘事。唯无漏慧于诸谛境。如实觉了名见现观。是即由见分明现前。如实而观四谛境义。即无漏慧并余相应。同一所缘名缘现观。是即由见等心心所法同。能取所缘四谛境义。即诸能缘并余俱有。同一事业名事现观。是即由见等心心所法。并余俱有戒及生相等。于诸谛中同所作义。戒生相等是现观因。于现观中彼有事用。故亦于彼立现观名。如是应知非相应法。唯一现观除慧所余。心心所法有二现观。唯无漏慧具足有三。诸说名为顿现观者。谓于一谛得现观时。于余谛中亦得现观。故于前说顿现观察。应审推征依何现观。若言依事应赞言善。以于苦谛得现观时。于苦具三于余唯事。谓初观见苦圣谛时。尽烦恼故即名断集。得择灭故即名证灭。起对治故即名修道。以见苦位于集等三。有断证修事现观故。约事现观名顿无失。若言依见应拨言非。此现观必渐诸谛相别故。一见理无多行相故。随彼自相一一谛中。世尊说言各各见故。如契经说。正见云何。谓圣出世无漏无取。广说乃至。诸圣弟子以苦行相思惟于苦。以集行相思惟于集。以灭行相思惟于灭。以道行相思惟于道。无漏作意相应择法。一见理无非一行相。故必无有别相谛中。随其自相俱时见理。由此定应许渐现观。若谓以一无我行相顿观四谛。理必不然。此不应名无漏慧故。谓无漏慧于诸谛中。一一别观方名见谛。异此应说以非我行相。思惟苦等不应说言。以苦等行相思惟苦等。又彼应说非我现观。能治何等迷三谛惑。非谤集等惑非我观能治以二行相都不相违。由此不应名真现观。如迷谛惑别有四门。现观亦应如彼有别。唯迷苦境有我执生。唯悟此生非我行相。能为对治非顿总缘。若顿总观诸法非我。如何于谛能别了知。爱真有因灭真寂静道真出离。若不了知如是等相何名见谛。若观灭道如苦行相。应名邪智非如实知。是故但缘苦为非我。可名现观非一切缘。又若见苦时断迷道等惑。修所断惑何不能断。若尔于苦得现观时。应于一切所作已办。既非所许故理不然。若谓数修能对治道。方能渐断修所断惑。非治顿起可名数修。亦应要由解道等见。方能永断迷道等惑。非解苦时名解道等。如何能断迷道等惑。又由佛说非四谛中。总相顿观成真现观。故有设难。谛应如蕴。一时总观成真现观。若异此者法相无边。现观应无究竟时。者唐捐其功。如善授经佛告长者。于四圣谛非顿现观。必渐现观。广说乃至。无处无容于苦圣谛未现观已。能现观集。如是乃至。无处无容于灭圣谛。未现观已能现观道。如是庆喜及一苾刍。二经所言意皆同此。二经一一各有别喻。若言我等不诵此经。理不应然。如向所引。分明显示渐现观经。顿现观经不可得故。谓若汝等不诵此经。复无别经分明显说必顿非渐。是汝所诵可为定量非拨此经。岂无分明说现观教。是故汝等应诵此经。此经不违诸余圣教及法性故。不可非拨。又共所诵转法轮经。说现观中别观四谛。如彼经说。此苦圣谛。是先未闻法。应如理思惟。广说乃至。此道圣谛。是先未闻法。应如理思惟。不可判为初修业地。说此无间证等觉故。更不别说现观位故。若判此为初修业地。应言何处说入真现观时。既更无文此即现观。故渐现观不违教理。又应诘彼顿现观宗。执顿现观依何教理。具依教理。且教者何。如契经言诸圣弟子。入谛现观故俱时断三结。此中不见说渐次言。又契经说。于观四谛应知慧根。此既总说观四谛言知顿现观。又契经说。修非常想断诸欲贪。乃至广说。非渐现观唯非常想。能断一切欲贪等结。又契经说。若断一切疑由知萨因苦。萨是并义。此经意言遍知有取苦。并遍知苦集。显顿现观。又契经说。若于苦无疑。于集灭道即亦得无疑。既顿舍疑非渐现观。如是谓教。其理者何。谓见苦时。断所断集。为见故断。为不见耶。若见如何遮苦集谛俱时现观。若不见者见苦谛时不应断集。经说圣慧见时断故。又如顿取五种色衣。谓如顿观五色衣者。总取衣上五种显色。如是总以一种行相。顿观苦等别谛理成。又如日船灯体虽一而能顿起。种种功能圣慧亦然。其体虽一作四事业亦无有过。谓日出时一刹那顷。除冷遣闇生暖发光。船于一念舍此趣彼负重截流。灯亦一时发时破闇尽油烧炷。又断见苦所断惑时。若即得初果应顿观四谛。若未得果则断一切见断惑时。亦应未得。差别因缘不可得故。又执于谛渐现观者。既必定许于苦等谛。一时顿具知断证修。亦必应许顿皆通达。如说于苦为通达遍知。乃至于道为通达修习。故约见现观顿现观理成。如是所言皆不成证。且彼引教说俱时声。为证不成有别义故。见于无间亦说俱声。如曼驮多俱时堕落。然非此说一刹那心。但说现观故俱时断三结。谓于四谛渐现观故。尔时便能永断三结。故非由此顿现观成。或俱时声显俱有义。如世间说有一母驴。与其十子俱时负驮。此则显示永断三结。与谛现观俱时有义。非唯于苦得现观故。便能一时永断三结。世间亦见有说俱声。而不唯显一刹那义。如说动足俱时时财。又说入城俱时富贵。引慧根教证亦不成。如信等根慧亦尔故。如契经说。于四证净应知信根。非缘佛信即缘僧等。又如经说于四念住。应知念根非缘身念。即缘受等慧根亦尔非缘苦慧即缘集等。此言意显于一一谛。有一慧根。故此无能证顿现观。非常想教证亦不成。此于余谛理不能现观故。由非常想唯以苦谛为所缘境非四谛故。若观苦谛修非常想。尔时即名观四谛者。苦应即四四应即苦。如是便成非所爱过。故缘一谛修非常想。必定不能现观四谛。然详经意。说有学者修非常想断诸欲贪。及能蠲除顺上分结。谓说修位起缘苦道。断修所断三界系贪。掉慢无明非说见道。如何引此证顿现观。萨因苦教证亦不成。见次第中亦言萨故。如言萨子提婆达多。然此萨声亦显有义。此即显示知有因苦。非知苦位即知苦因。或复相违行相别故。非苦行相即能知集。或复相违故知有因。苦圣谛位非即知集。此意显苦非无有因。理必应然。由此经说知。有因苦。曾无余经世尊于集说知言故。由此为证。知此经中非说知因但说知苦。又若见说知并因苦。即言苦集一时现观。此既不言并知灭道。应许现观非顿理成。又理无容顿断疑故。谓无容见有因苦时迷灭道疑亦皆顿断。经何故说断一切疑。今此经中言一切者。唯显见此所断诸疑。谓此契经说前后际所有缘起。有情于彼愚因果故生多疑惑。谓我过去为曾有等。乘此契经作如是说。知萨因苦断一切疑。惑此纵说断一切疑。如何便能证唯顿断。由此或可显邻近义。谓显苦时知有因苦。便极邻近断一切疑。是一切疑必当断义。如言汝等若无愤发。则为证得究竟涅槃。是故此经显初现观。不可引证唯顿非渐。由此已释若于苦无疑。于集灭道亦得无疑。教以时促故定当断。故不出观故说亦得言。非见苦时一切疑断。或依至果密说此言。以至果时并无疑故。有作是诵。若于道无疑。于苦集灭亦得无疑。故已通其教。理亦不然。且见苦时断所断集。由无常等四种行相随一现前见彼故断。苦集二物无差别故。以约行相苦集智别。非约所缘有差别故。见苦所断集可如是断。见集所断集断则不然。以离因等四种行相。了知集谛则不能断。以说于集为通达永断。乃至于道为通达修习。若异此者。经但应言。集应永断。乃至广说。此即证成现观非顿。然非要见方能断集。勿修道中缘灭道智。不能永断修所断集。经言圣慧见时断者。说见时能断非见所断法如所证修。非要由见所证修法。勿修道位苦集智起无所证修。断亦应然。非要由见。言如顿取五种色衣。理亦不然。于一刹那分明取五。非所许故。眼识总取五色衣时。不能了别青黄等异。唯能总作显行相转。意识随后次第了别。由行相速生增上慢。谓于一时顿取五色。然必无有现观起时。不能分明了苦等异。唯于四谛总行相转。如不明了总缘眼识。故不应引喻顿现观。虽亦许有总相缘智。顿缘别相多境而起。然不能了多境别相。于真现观为喻不成。如日船灯亦不应理。一体多业此不成故。以总日中暖触除冷。光色遣闇暖光自类。后从前生非从一起。既无一体作四事业。故此无能喻顿现观。又日初出无遍除遣诸冷闇能。故非顿喻灯不成喻。类此应知尽油烧炷非别用故。船之舍趣亦无有别。负重截流各非全分。故亦无喻顿现观能。虽有多能同依一体。而非现观可与彼同。四行相殊互相违故。况此三喻体皆非一。如何可引证顿现观。引得果证理亦不然。如断上惑成应果故。如渐断上界一切烦恼。成阿罗汉果无有过失。如是应知渐断一切见所断惑成预流果。又如学位同而有差别故。如预流等学位虽同。而于其中非无差别。如是第八类亦应然。又修道中亦应征责。断下下道所断惑时。若即得一来应顿断六品。若许尔者修断不成。若未得一来后亦不应得。无别因故。余位亦然。故彼所言无能证用。说于苦谛为通达等。不违我宗。有别义故。于苦至道为通达言。显见道前四善根位。于四圣谛欣乐别观。从此便能入见道位。如其次第。于四谛中正能遍知。乃至修习。此意为显渐次现观。如是所说岂违我宗。然通达言正显见道。于四谛迹乐欲见者。必应先起求通达心。故此位中说为通达。或为通达即是见道。为达谛理见道生故。恐唯见谛即谓事成。显见谛时别有所作。故次复说遍知等言。或此经应言于苦等谛由通达遍知。乃至修习显所作事由慧故成。若不许然不应重说。通达遍知义无别故。此所引教但如其文。足能证成渐现观义。以说于苦为通达遍知。乃至于道为通达修习。分明显说渐现观义。若异此者不应别说。既一一别说为通达言。故四圣谛境相各别。故唯一慧体一刹那中。无容决了四别相故。如谛别相审觉了时。方能断迷别相惑故。证知现观非顿必渐。今正详彼所引契经。显由四见力成四事现观。非显由一见四事现观成。不应引来证顿现观。已辩现观具十六心。此十六心为依何地。颂曰

  皆与世第一　　同依于一地

论曰。随世第一所依诸地。应知即此十六心依。彼依六地如先已说。谓四静虑未至中间。何缘必有如是忍智。前后次第相杂而起。颂曰

  忍智如次第　　无间解脱道

论曰。十六心中四法类忍名无间道。四法类智名解脱道。名如前说。能忍可先来未见欲苦。初念无漏慧名苦法忍。以契经中世尊自说。若于此法以下劣慧。或增上慧审察忍可。名随信行随法行故。应知此忍即无间道。何处说此无间道名。经说一法难可通达。名为无间心等持故。又世尊说。有苦法智有苦类智。乃至广说。非此二智同缘三界苦等境起。如先已辩。故于苦法忍所见欲苦中。决断解生名苦法智。前忍能断十烦恼得。后智能与彼离系得俱生。经说智生随于前忍。故知后智名解脱道。从此无间忍色无色。未曾见苦第三刹那。无漏慧生名苦类忍。是见欲苦忍种类故。次于苦类忍所观上苦中。决断解生名苦类智。忍智如次断烦恼得名无间道。离系得俱名解脱道。准前应说。于余三谛准苦应知。故前八忍名无间道。后之八智名解脱道。复以何缘说断对治名无间道。说离系得俱时起智名解脱道。经主释言约断惑得无能隔碍故名为无间道。已脱惑得与离系得。俱时起故名解脱道。若尔解脱道亦应名无间。约与离系得俱亦无能隔碍故。应作是释。无间隔故名为无间。无间即道名无间道。是无同类道能为间隔。令于解脱道不为缘义。诸无间道唯一刹那。诸解脱道或相续故。于自所治诸烦恼得已得解脱。与彼断得俱时起道名解脱道。自所治言欲显何义苦类忍等诸无间道。亦与他所治离系得俱生。勿彼亦名解脱道故。若苦法忍后即有苦类忍。与前忍果断得俱生。余位亦然。斯有何失。若尔此位缘欲苦等。已断疑智应不得生。许此不生复有何过。则于后修位我已知苦等。诸决定智应不得生。于苦等境中先未生智故。若于先位未有智生。后已知言便成无义。若见道位唯忍能断惑。应与本论九结聚相违。以本论中说四法类智及修所断为九结聚故。此不相违。以依诸忍是智眷属密意说故。此十六心皆见谛理。一切皆说见道摄耶。颂曰

  前十五见道　　见未曾见故

论曰。见未曾见四圣谛理名为见道。故于现观十六心中前十五心是见道摄。道类忍位于诸谛中见圆满故。至第十六道类智时。虽亦有一先未知谛。而无一谛先未见者。以一切忍皆见性故。由此尔时不名见道。岂不亦见曾未见谛。谓道类智见道类忍。相应俱有一念道故。诸有唯见曾未见者名为见道。尔时通见曾未曾见。故无此失。或此约谛不约刹那。非尔时观未曾见谛。非于一谛多刹那。中未见一刹那可名未见。谛如刈畦稻唯余一科。不可名为此畦未刈。故见未见名为见道。是见道相义善成立。故我宗说现观后边道类智品是修道摄。兼修异境智行相故。谓见道位唯修未来自同类境。智及行相道类智位。如余修道通修未来同异类境智及行相。故修道摄。若谓见道有种种类。如或有时唯修无漏。有时通修有漏无漏。如是应许有时唯修自同类境智及行相。有时通修同异类境智及行相。此例不然。唯修同境种种类故。若许便有太过失故。谓于见道极成刹那。唯约能修与自同境智及行相。名种种类。然道类智未来所修。如余极成修道位故。决定不可以见道中。有未来修余种种类故。例亦更有余种种类修。若许例然。应尽智等亦见道摄。所以者何。所立见道种种类因无差别故。谓亦可例如见道中。苦法智等亦见亦智。忍唯是见名种种类。如是应许无学位中。无学正见亦见亦智。尽无生智唯智非见。有种种故亦见道摄。既不许然。则不应许以修同境种种类故。亦修同异境种种智行相。故先所言道类智品。兼修异境智行相故。是修道摄。理无倾动。又见道应依色无色身故。谓先离欲入离生者。道类智时证不还果。彼命终已生色无色。乃至未得阿罗汉果。成道类智无舍因故。既不许彼成就见道。故道类智是修道摄。若许生在色无色界成就见道。斯有何失。有应生彼入离生失。以见道位一一刹那。皆是所入离生性故。若谓生彼虽成不行。此但有言无行障故。若谓生彼行无用故虽成不行。如已获得胜进道者果行无用。应生彼圣弃背圣道。以若获得增上道时。于下劣道可生弃背。既未获得增上圣道。生彼重起斯有何过。又于尔时现观已满。见道现前成无用故。谓起见道为成现观。道类智位现观已成。见道现前都无胜用。此现起故非见道摄。既是修道摄未得胜果道。生上二界应容现行。又道类智品已知根摄故。谓余极成修位摄道已知根摄。此道类智既许摄在已知根中。勿有一圣成二根失非极成。见道许是已知根。是故圣道若一根摄。亦应许是一道所收故。道类智是修道摄。又成彼圣者得差别名故。谓成修道补特伽罗。名信胜解或名见至。成道类智补特伽罗。亦得此名故非见道必无极成。成见道者得信胜解见至二名。是故一名所目圣道。应知皆是一道所收。故道类智是修道摄。又遮见道中修他心智故。谓道类智如余极成。修道所摄诸解脱道。亦有能修他心智者。然本论说见道位中。决定不能修他心智。故道类智如余修道。是修道摄。修彼智故。又成此位中有练根等故。等言为显容相续起。命终受生舍前道等。故道类智是修道摄。非见道摄其理极成。或有欲令是见道摄。一谛现观最后心故。如缘三谛现观后心。谓现观中于四圣谛。一一各有四刹那心。三最后心即见道摄。故道类智定是见道。此亦非理。道类智忍时见道已满故。谓第十六道类智时。无一谛理未见今见。如后念故非见道摄。见道中间苦等七智。有余谛理当应见故。未息求见阿世耶故。不可判为非见道摄。道类智忍虽有一谛未知当知。而于诸谛见已圆满。是见道最后故得已满名。由此中间苦等七智。见中间转故是见道所摄非道类智。可与彼同越见相故是修所摄。或如余别应有别故。谓如三谛现观后心。能于未来修世俗智。非缘道谛现观后心。如是亦应许彼三智。是见道摄非道类智。又道类智是沙门果。见后边起隔生成就。诸未来所修非定不生法。余三类智则不如是。故应唯彼是见道摄。故彼所说如缘三谛现观后心。此亦后心应见道摄定为非理。若尔应言此道类智。非数习故是见道摄。谓钝根者起修道时。要由数习。由彼圣道数习起故得修道名。此道类智设钝根者。亦能顿起不由数习。犹如前位见道刹那。故应如前是见道摄。此亦非理。以钝根者起尽智时亦唯顿故。与金刚喻定一加行起故。或彼应说尽智如何。由数习生非道类智。如彼尽智同类数数现在前故许修道摄。此道类智例亦应然。不应判为见道所摄。有余师说。此道类智必不退故是见道摄。谓钝根者于道类智。亦必无退有退修道。故定应许是见道摄。此亦不然。由忍所断必无重起故此不退。谓道类智设许退者。必由见断烦恼现前。设诸钝根见断已断。必无重起故此不退。又无退住无间道中。若退道类智必退道类忍。然现观忍许必无退。故道类智定无退理。又道类智以能任持见道所断烦恼断故。虽钝根者亦无有退。若谓由此应见道摄。此难不然。一来果等亦应同此见道摄故。谓彼后时舍预流果。至一来等解脱道中。亦能任持见断法断。彼亦应是见道所摄。若谓后位亦能任持修断法断无斯过者。理亦不然。应二性故。或不应说以能任持见断断故应见道摄。彼此别因不可得故。谓有何理一来等位。俱能任持二断法断。但名修道非见道摄。是故不可约能任持烦恼断故立见修道。或见法性有种种故。非由不退便见道摄。谓见诸圣有退堕者。然非圣者一切可退。见诸钝根有退堕者。然非钝根一切皆退。见退法性有退堕者。然非退法一切皆退。虽有从果胜果道退。而非一切皆有退理。谓渐次退非超越者。不经生退非经生者。如彼容退有不退者。此亦应然何偏固执。谓虽许有从修道退而非一切。除初刹那余修退时不必见退故。容有退初修若退亦必退见故无退理。以必定无退见道故。非不退故是见道摄。有余师说。此由见道加行成故是见道摄。谓道类智即由见道加行所成。如余见道不应说为修道所摄。此亦非理。若期心不出第十七等心亦应同故。若谓不定故。理亦不然。虽不定有者修道摄故。谓有见道加行所生非见道摄。由此见道加行成故非决定因。又应此因有太过失。谓世第一既与见道一加行生。应见道摄。又诸解脱与无间道一加行生。应无间摄。故彼所立非定证因。有余师言。别有至教显道类智是见道摄。如本论说有九结聚。若道类智是修道摄。彼所断结应名修断。不应复立修断结聚。或应见断结聚唯七。然第八结。理必应是道类智断。以解脱道与无间道同所作故。如说九根得预流果。此亦非理。教意别故。以本论中说见断结。是诸忍断非智断故。又以正理证道类智。正所断结非见所断。以圣教中说二结聚。一见所断。二修所断。然无漏慧有三类别。一唯是见。二唯是智。三通二种。于此三中唯是智者不能断结。唯见断者名见所断。通二断者名修所断。不尔立名应无有义。道类智体既通智见。故彼所断非见断摄。然非所立九结聚名全无有义。为显无间是解脱道助伴摄。故显此复何用证成。本论中所说八十九有为沙门果。以无间道是沙门故。此力引生解脱道故。若无间道不断结得。则解脱道无容得生。如臣剪除诸怨贼处。王方自在安住其中。或由智故忍有差别。故于忍所断论者说智名。或复何劳方便通释。此文正应说法类智忍断。然不说者略中间言。所说九根得预流义。如辩根处已具思择。不可由斯证道类智。如道类忍是见道摄。故见道位唯十五心

说一切有部顺正理论卷第六十三阿毗达磨顺正理论卷第六十四

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩贤圣品第六之八

已辩见修二道生异。当依此道分位差别。建立众圣补特伽罗。且依见道十五心位。建立众圣有差别者。颂曰

  名随信法行　　由根钝利别
  具修惑断一　　至五向初果
  断次三向二　　离八地向三

论曰。见道位中圣者有二。一随信行。二随法行。由根钝利别立二名。诸钝根名随信行者。由先信敬力修集加行故。诸利根名随法行者。由先乐观察修集加行故。诸有情类种性差别。法尔先来如是安住。谓有情类若从先来。凡所施为一切事业。不乐审察能与不能。专信敬他随他言转。彼后修得无漏道时。在见位中名随信行。由信随行名随信行。先随信他行于义故。彼有随信行名随信行者。或由串习此随信行。以成其性故名随信行者。彼信为上首慧为随转故。随法行者翻此应释。谓有情类。若从先来凡所施为一切事业。乐审观察能与不能。非由信他随教理转。彼后修得无漏道时。在见位中名随法行。由法随行名随法行。先随教法行于义故。彼有随法行名随法行者。或由串习此随法行。以成其性故名随法行者。彼慧为上首信为随转故。即二圣者由于修惑。具断有殊立为三向。谓彼二圣若于先来。未以世道断修断惑名为具缚。或先已断欲界一品乃至五品。至此位中名初果向。趣初果故。言初果者。谓预流果。此于一切沙门果中必初得故。若先已断欲界六品或七八品。至此位中名第二果向。趣第二果故。第二果者。谓一来果。遍得果中此第二故。若先已离欲界九品。或先已断初定一品。乃至具离无所有处。至此位中名第三果向。趣第三果故。第三果者。谓不还果。数准前释。如是随信随法行者。由先具缚断惑有殊。数别各成七十三种。谓于欲界具缚为初。至断九品以为第十。如是乃至无所有处。地地各九为七十三。诸后具缚即前离九。故后七地无别具缚。次依修道道类智时。建立众圣有差别者。颂曰

  至第十六心　　随三向住果
  名信解见至　　亦由钝利别

论曰。即前随信随法行者。至第十六道类智心。名为住果不复名向。随前三向今住三果。谓前预流向今住预流果。前一来向今住一来果。前不还向今住不还果。阿罗汉果必无初得。异生无容离有顶故。见道无容断修惑故。至住果位舍得二名。谓不复名随信法行。转得信解见至二名。此亦由根钝利差别。诸钝根者先名随信行今名信解。由信增上力胜解显故。诸利根者先名随法行今名见至。由慧增上力正见显故。何缘先时断修所断。欲一至五或七八品。初定一品广说乃至。无所有处第九品惑。至第十六道类智心。但名预流一来不还果。非一来不还阿罗汉向。颂曰

  诸得果位中　　未得胜果道
  故未起胜道　　名住果非向

论曰。依得圣道建立八圣如先已说。故得果时于胜果道必定未得。以得果心于胜果道。所对治惑非对治故。非非彼治现在前时。得彼治道如先已说。又非得果时即有胜果道。所断烦恼离系得生。道类忍不能断彼系得故。若道力能断彼系得。此道引彼离系得生。可说此道能证彼灭。以得前果时未得胜果道故。住果者乃至未起胜果道时。虽先已断修所断惑欲一品等。但名住果不名后向。后于何时得先所断修惑离系无漏得耶。于胜果道现前时得。为诸先断彼修断惑。入离生位得前果已。此生定起胜果道耶。理必应然。以本论说。圣生第四静虑以上。无漏乐根定成就故。若不然者。诸先已离三静虑染。后依下地得入离生。彼得果已。若生第四静虑以上。如何可说定成乐根。理不应言。唯如是类。此生必定起胜果道。非余先断诸下地惑。决定因缘不可得故。彼障已断。必欣彼故。障已断道易现前故。如是已依先具倍离。及全离欲入见谛者。十六心位立众圣别。当约修惑辩渐次生。能对治道分位差别。颂曰

  地地失德九　　下中上各三

论曰。失谓过失即所治障。德谓功德。即能治道如先已辩。欲修断惑九品差别。上四静虑及四无色。应知亦然。生死无非九地摄故。如所治障一一地中各有九品。诸能治道无间解脱九品亦然。失德如何各分九品。谓根本品有下中上。此三各分下中上别。由此失德各分九品。谓下下下中下上中下中中中上。上下上中上上品。应知此中下下品道。势力能断上上品障。如是乃至上上品道势力。能断下下品障。上上品等诸能治德初未有故。此德有时上上品等失已无故。应知此中智虽胜。惑未增盛故道名下品。相续中惑虽极难断。细随行故障名下品。依如是理应立譬喻。如浣衣位粗垢先除。于后后时渐除细垢。谓彼粗垢于所住衣非甚坚着。少用功力以水浣洗便能遣除。细垢不然。由甚坚着所住衣故。以灰汁等及多功力方能遣除。又如粗闇小明能灭。要以大明方灭细闇。谓粗重闇才举小明便能令灭。若细轻闇要举大明方能令灭。失德相对理亦应然。由此可言白胜黑劣。若异此者。上上品道现在前时。方能对治下下品障。如何可言白法力胜黑法力劣。又刹那顷能治道生。于无始来展转增益。诸坚固惑能永拔根。由此故言白胜黑劣。如时经久所集众病。服少良药能令顿愈。又如长时所集众闇。一刹那顷光明能灭。已辩失德差别九品。次当依彼立圣者别。且诸有学修道位中。总亦名为信解见至。随位复有多种差别。先应建立都。未断者。颂曰

  未断修断失　　住果极七返

论曰。诸住果者于一切地。修所断失全未断时。名为预流生。极七返。七返言显七往返生。是人天中各七生义。极言为显受生最多。非诸预流皆定七返。故契经说。极七返生是彼最多七返生义。经说与此义无差别。诸无漏道总名为流。由此为因趣涅槃故。预言为显最初至得。彼预流故说名预流。此预流名为目何义。若初得道名为预流。则预流名应目第八。若初得果名为预流。则倍离欲全离欲者。至道类智应名预流。此预流名目初得果。然倍离欲全离欲者。至道类智不名预流。约修惑断立彼果故。预流必依遍得果者。初所得果以立名故。一来不还非定初得。唯有此果必初得故。何缘此名不目第八。未具得向果无漏道故。未具得见修无漏道故。未遍至得现观流故。八忍八智名现观流。道类智时皆具至得。是故第八不名预流。由此预流唯是初果。彼从此后欲人天中。各受七生应言十四。何故说彼极受七生。此责不然。七数等故如七叶树及七处善。若谓经说见圆满者。无处无容受第八有。不应说彼于人天趣各受七生。此亦不然。经约一趣密意说故。若谓此经非密意说。则彼亦应不受中有。若人天趣合受七生。经但应言受人天七。何缘经说天七及人。既说及言定知各七。又必应尔。饮光部经。分明别说各受七故。若依一趣密意而说。故与经说见圆满者。无第八有言不相违。如何上流有遍没者。彼一趣受过八生故无相违失。遮第八言依极七有。地非约上地故。谓若于此地说诸圣者极受七生。即于此地中遮第八有非色无色契经所说七返有言。非约三界无差别说。宁应谓此遮第八言。总约三界无差别说。故此经说遮第八言。如七有言唯约欲界。密意说故无相违失。有余谓此会释不然。余处曾无如是说故。此中无有密说相故。谓曾无处作如是言。上流受生过于七有。可以证此遮八有经。依欲界说非约一切。又非遮止第八有经。违害所余无别意教。必有别意故判为密意说。故此会释不应正理。岂不遮止第八有经。与上流经极相违害。无相违害。以上流经总说上流有余意故。谓此唯说全超半超。名为上流无遍没故。如是会释理定不然。余处曾无如是说故。生处定因曾不说故。谓曾无处说诸上流。唯有二种无有遍没。又曾不说生处定因。言此上流定于色界。唯生此处彼处不生。然契经说七士趣处。举多譬喻以显上流。次第遍生色界诸处。观彼经意既说上流。至道等边无缘故灭。显不还者于色界中。一切处生过于八有。故知定有遍没上流。谓彼经中依六士趣各说一喻。唯于第七上流士趣说十一喻。显彼圣者于色界中。有次第生一切处者。故彼经说如有上流乃至道边。或水边等无所依故即便尽灭。显彼圣者过于此处。无生处故便般涅槃。故上流经无余意趣。遮第八教与彼相违。即是此经密意说相。又见经说无差别言。于中非无差别意趣。如契经说。无处无容有二轮王俱时出现。此经虽复无差别言。非不但依一四洲说。此中亦可作如是言。余处曾无如是说故。此中无有密说相故。岂即谓此会释不然。故彼此中徒兴固执。复何缘故感八有业。能障见谛非七有业。若谓圣者于欲界中。极受七生无第八故。此无因故亦同所疑。若谓齐此时相续必熟故。此亦不然。无定因故。谓有何等决定因缘。于第七生为尽诸漏。根未熟者至第八生。为尽诸漏根亦不熟。若谓圣道种类尔故。如为七步毒蛇所螫。此喻不然。寿量定者过此齐限亦得往故。又若圣道种类法然。则由道生遮第八有。宁说彼业能障见谛。谓但应言由圣道起遮第八有。不应言感第八有业能障见谛。若有已作及已增长第八有业。圣道于彼无能遮力故不得生。彼亦不应能障见谛。至第八有方般涅槃。于正理中有何违害。有余于此作是释言。由彼有余七结在故。谓二下分五上分结。此亦无能证。唯七有唯贪嗔结。引七有故。又无契经说不还者受极七有。又无经说五上分结引欲界生。故彼所言无能证力。但由法尔极受七生。于中不应强申理趣。中间虽有圣道现前。余业力持不证圆寂。唯依佛出世有别解律仪。故彼第七有若不遇佛法便在家。得阿罗汉果。既得果已必不住家。苾刍威仪法尔成就。虽不会遇前佛所说。而于余命生极厌心。不经久时便入圆寂。有言。彼往余道出家。理不应然。往余道者。由恶见力邪业转故。云何彼名无退堕法。以不生长退堕业故。违彼生长业与果故。强盛善根镇彼身故。加行意乐俱清净故。诸有决定堕恶趣业。尚不起忍。况得预流。故有颂言

  愚作罪小亦堕恶　　智为罪大亦脱苦
  如团铁小亦沉水　　为钵铁大亦能浮

经说预流作苦边际。依何义立苦边际名。依齐此生后更无苦。是令后苦不相续义。或苦边际所谓涅槃。如何涅槃。可是所作除彼得障。故说作言如言作空。谓毁台观若于人趣得预流果。人中满七天准应知。非圣亦有极七返生。相续成熟得涅槃义。然非决定。是故不说。已辩修惑都未断者。名预流果极七返生。今次应辩断位众圣。且应建立一来向果。颂曰

  断欲三四品　　三二生家家
  断至五二向　　断六一来果

论曰。即预流者进断修惑。若三缘具转名家家。一由断惑。断欲修惑三四品故。谓惑于先异生位断。或今预流进修位断。二由成根。得能治彼无漏根故。谓已成就彼能治道。三品四品无漏诸根。三由受生。更受欲有三二生故。谓断三品更受三生。若断四品更受二生。此三二生由异生位。造作及增长感三二生业。非诸圣者于圣位中。更能新作牵后有业。以背生死向涅槃故。由此契经说诸圣者。唯受故业更不造新。若三缘中随阙一种。阙二全阙不名家家。何故成根。颂中不说预流果后。说进断惑成能治彼无漏诸根。义准已成。故不具说。若尔应不说三二生言。说断三四品义已成故。谓已进断三四品惑。决定余有三生二生。故说家家相不圆满。则应于颂更说等声。方可具收家家三相。或应不说三二生言。然颂中言三二生者。以有增进于所受生。或少或无或过此故。有余师说。亦有具足家家三缘而非家家。谓异生位先断修惑。三品四品住见道中。但以家家生所显故。是预流果胜进位故。非住见道有斯义故。虽三缘具不名家家。今详彼言定不应理。非住见道具彼三缘。尔时不能修修惑对治故。要得治彼无漏诸根。方是三缘中成无漏根义。故住见道非具三缘。无具三缘非家家者。应知总有二种家家。一天家家。谓欲天趣生三二家而证圆寂。或一天处或二或三。二人家家。谓于人趣生三二家而证圆寂。或一洲处或二或三。若有七生不必满七。非家家位中间涅槃。何类所摄摄属七生。七中极声显极多故。由此已显生未满前。得般涅槃亦是彼摄。根最钝者具经七生。非诸利根生定满七。宁无断五亦名家家。以断五时必断第六。非一品惑能障得果。犹如一间未越界故。即预流者进断欲界一品修惑乃至五品。应知转名一来果向。若断第六成一来果。彼往天上一来人间而般涅槃。名一来果。过此以后更无生故。即由此义证家家中。若天家家受三生者。人间受二天上受三。受二生者人一天二。如应例释人中家家。若谓不然。彼一来果有何异彼二生家家。彼贪嗔痴唯余下品故。即一来果名薄贪嗔痴。已辩一来向果差别。次应建立不还向果。颂曰

  断七或八品　　一生名一间
  此即第三向　　断九不还果

论曰。即一来者进断余惑。若三缘具转名一间。一由断惑。断欲界中修断七品或八品故。二由成根。得能治彼无间解脱无漏根故。三由受生。更受欲有天或人中余一生故。若三缘中随阙一种。阙二全阙不名一间。成无漏根颂中不说。及应复说一生所因。准家家中如应当释。所言间者是隙异名。调彼位中。由有一隙容一生故。未得涅槃。或此间名目间隔义。谓于彼位有余一生。为间隔故不证圆寂。有一间者说名一间。如何有余一品修惑能为障碍令受欲界生。名为一间。未得不还果。若断此品便为超越欲界所系诸业烦恼异熟等流二果地故。彼极为碍容更受生。断六品时未越彼地。故无断五中间受生。现身不能证一来果。即断修惑七八品者。应知亦名不还果向。先断三四七八品惑入见谛者。后得果时即名家家及一间不。此未名曰家家一间。未得治彼无漏根故。初得果位果道现前。尔时未修胜果道故。要至后位起胜果道。方得名曰家家一间。治彼无漏根尔时方得故。若进断惑预流一来。方立家家一间名者。何故善逝。手箭经中说七生一来与彼同断惑。如彼经说。云何家家。谓永断遍知。身见等三结。极七返有应知亦然。云何一间。谓永断遍知身见等三结。及已能薄欲贪嗔痴。一来亦尔。无相违失。不言唯故。如经所说。预流一来。谓说预流永断三结。非所余结彼未能断。如说预流永断六法。一有身见。二边执见。三邪见。四顺恶趣贪。五顺恶趣嗔。六顺恶趣痴。又说一来永断三结。薄贪嗔痴不言薄慢。又不说断边见邪见。如预流果。非一来果不令慢薄不断边邪。然彼经中不言唯故。起彼治故必亦断彼。如是所说家家一间。既不言唯进断无失。又契经说。彼生数减定知彼望预流一来。转更成多诸烦恼断。以诸烦恼是生因故。即由此故知彼望前。必定已生殊胜对治。若尔何故说家家一间与七生一来所断相似。显此即是彼差别故。或所进断细难觉故。或应更审求同说因。不可引斯少分密教。便决定证家家一间。与预流一来所断惑相似。上座意谓。家家一间与七生一来。但利根有异。谓随信行随得预流。若成预流转名信解。亦即名曰极七返生。诸随法行随得预流。若成预流转名见至。即于此位亦名家家。由彼圣者根猛利故。生三二家便证圆寂。又即信解随得一来。若成一来仍名信解。即于此位经于二生。即诸见至随得一来。若成一来仍名见至。即于此位亦名一间。由彼圣者根猛利故。受一间生便证圆寂。如是安立不应正理。以极声显生最多故。若预流果经三二生。便般涅槃名家家者。极七返有唯经三二生便般涅槃。与家家何异。又彼既谓即预流果。若利根者生三二家便般涅槃。是家家摄。极七返有亦许中间。经三二生便证圆寂。如何执彼定是钝根。非即钝根可亦名利。故彼所立不应正理。又若一间由利根故。唯受一有便般涅槃。如何可说即一来果。许一来言目二生故。又彼论说不遮一来。唯于天趣有重生理。诸一间者可无是事。此非亦是一趣重生。非一来故。二生所隔立一间名。可不成故。谓不应说有一来者。唯于天趣具受二生。以说一来般涅槃故。若二生者如何可说名为一间。故彼所言可无是事。此言应理。又一来者。彼定无容许天趣中有重生理。与彼所许于天趣中。二生家家应无别故。若谓如说极七返有。据极满者说七返言。而实于中有不满者。如是就极立一来名。谓极一来便证圆寂。而实亦有天上重生。不来人中证圆寂者。此亦非理。前过随故。又彼所许钝根一来。若于天中受一生已。不来人趣便般涅槃。与彼一间有何差别。无决定理限彼钝根。必来人中方证圆寂。若不来者便成一间。非即钝根可亦名利故彼所立不应正理。又彼所许违害契经。以有经中说信解性。若有获得殊胜善根。亦说名为利根等故。谓契经说。若有五根增上猛利极圆满者。名俱解脱阿罗汉果。若有五根渐劣渐钝名慧解脱。乃至广说。于此经中时解脱者。得八解脱亦名利根。若未获得八解脱者。不时解脱亦名钝根。若诸信解得灭尽定。亦说名为利根身证。若未获得灭尽定者。虽是见至而名钝根。如是一来信解性者。得胜治故转名一间。若未获得胜对治者。虽见至性唯名一来。如是应知家家七返。故彼所立家家一间唯是利根。其理非善。又彼部论作如是言。品别断惑非真圣教。彼部所立家家一间。唯是利根岂真圣教。非彼上座自许己身。及我许彼是真大圣。宁谓自言是圣教摄。佛曾无处作如是言。又彼所言违余圣教。不可自谓是圣教摄。然品别断惑非非真圣教。以薄伽梵说一来果。永断三结薄贪嗔痴。非贪嗔痴如材木等。可由斫等令其渐薄。但可品别渐次断之。下品为余说之为薄。又契经说。诸不还者。已无余断贪欲嗔恚。由此为证知一来时。犹有余品贪嗔未断。今至此位方断无余。又契经说。预流果位已永断一切趣恶趣贪等。由此证知一来果等。有品已断有品未除。又已显成得胜治故。方可建立家家一间。既彼位中得胜对治。知尽贪等与前有别。是故品别断惑理成。随眠品中亦已显示。又彼论说有何因缘。于断惑时许品别断。唯许九品非十非千。此责不然。唯有如是九品差别对治生故。谓断惑位一一地中。九品道生便能永断自地所摄诸烦恼故。无劳建立若十若千。又与见修所断同故。谓彼宗许断烦恼时。亦有分为品别断义。以见修道所断诸惑许入圣时前后断故。既许如是亦可责言。有何因缘于断惑位许品别断。然唯建立见修二品非三非千。彼既许然此亦应尔。又薄伽梵于契经中亦作是言。九品断惑。前来依彼已具辩成。佛于法性自在通达。作如是说。但可信依不应于中轻为征诘故一来果胜进道中。方建立一间非住一来果。亦预流果胜进道中。方建立家家非住预流果。如是所说理趣必然。即先成就一来果者。断欲界惑九品尽时。舍一来名得不还果。必不还受欲界生故。此或名为五下结断。如契经说。若有永断五下分结名为不还。此据集断密作是说。必无五结俱时断理。或二或三先已断故。理实应说于此位中断二或三得不还果

说一切有部顺正理论卷第六十四阿毗达磨顺正理论卷第六十五

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩贤圣品第六之九

依不还位。诸契经中。以种种门建立差别。今次应辩彼差别相。颂曰

  此中生有行　　无行般涅槃
  上流若杂修　　能往色究竟
  超半超遍没　　余能往有顶
  行无色有四　　住此般涅槃

论曰。此不还者总说有七。且行色界差别有五。一中般涅槃。二生般涅槃。三有行般涅槃。四无行般涅槃。五者上流。此于中间般涅槃故。说此名曰中般涅槃。如是应知。此于生已。此由有行。此由无行般涅槃故名生般等。此上流故名为上流。言中般者。谓有一类补特伽罗。已于生结得非择灭。起结不尔。彼于欲界遇逼恼缘之所逼恼。便能自勉修断余结殊胜加行。加行未满遇舍命缘。遂致命终由起结力。受色中有厌多苦故。乘前起道进断余结。成阿罗汉得般涅槃。言生般者。谓有一类补特伽罗。由先具造顺起生业及增长故。欲界没已受色界生。由具勤修速进道故。生已不久成阿罗汉。尽其寿量方般涅槃。约有余依说为生般。非才生已便般无余。彼舍寿中无自在故。言有行般无行般者。谓有一类补特伽罗。生已多时方成无学。于中有一勇猛精进。有一禀性慢缓懈怠。如次名为有行无行。谓若一类。先欲界中依不息加行。三摩地力。断五下分结。成不还果。后生色界。经于多时还能进修前种类道成阿罗汉。名有行般。无行般者。与此相违。或色界生经多时已。依止苦行解脱余结。名有行般。以彼修习依功用道般涅槃故。与此相违名无行般。岂不中般生般现般。所依止行亦有此故。应立有行无行般名。无如是失。此义虽等而彼各有差别位故。谓中般等。虽亦定依苦行乐行解脱余结。而彼各有分位不同。对此名为不共差别。此无如是分位别故。约道不同显其差别。如何以此例彼令同。故于此中所辩无失。由此有说二差别者。由缘有为无为圣道。如其次第得涅槃故。应知亦无余同此失。经主所难有大过失。为已善通此义虽等。而彼各有差别位故。然有经说无行在先。亦有经中先说有行。时既无异随说无违。有行可尊故我先说。言上流者。谓有一类补特伽罗。上流行增非初生处即证圆寂。谓欲界没往色界生。未即于中能证圆寂。要转生上方般涅槃。即此上流差别有二。由因及果有差别故。因差别者。此于静虑由有杂修无杂修故。果差别者。色究竟天及有顶天为极处故。谓若于静虑有杂修者。能往色究竟方般涅槃。杂修能感净居果故。即此复有三种差别。全超半超遍没异故。言全超者。谓色界中。从一处没往色究竟。由彼先在欲界身中。已具杂修四种静虑。遇缘退失上三静虑。以初静虑爱味为缘。命终上生梵众天处。由于先世串习势力。复能杂修第四静虑。从彼处没生色究竟。以于色界十六处所。最初处没最后处生。顿越中间。是全超义。言半超者。谓色界中从初天等。渐次而没下至中间。能越一处方能往趣色究竟天。超而非全是半超义。言遍没者。谓于色界爱味多故一切处生。由彼遍于四静虑地十六处所。一一皆有下等爱味。为感生缘。从梵众天一一处所。一生没已至色究竟。方般涅槃。故名遍没。由此义准初静虑中。大梵所居非是别处。即是第二梵辅天摄。若异此者大梵所居。僻见处故。一导师故。必无圣者于中受生。遍没半超应无差别。应知此谓二上流中。由有杂修静虑因故。往色究竟般涅槃者。余于静虑无杂修者。能往有顶方般涅槃。谓彼先无杂修静虑。由于诸定爱味为缘。此没遍生色界诸处。唯不能往五净居天。色界命终于三无色。次第生已后生有顶方般涅槃。二上流中前是观行后是止行。乐慧乐定有差别故。二上流者。于下地中得般涅槃。亦不违理。而言此往色究竟天及有顶天。依极处说。无不还者。于已生处受第二生。由彼于生容求胜进非等劣故。唯欲界没往色界生。有中有中般涅槃者。非色界没生色界者。以色界中无灾害故。若本有位有余障缘。不得涅槃。中有亦尔。中有薄劣非本有故。又彼若有应属上流。中般上流应无差别。谓定无有差别因缘。可作是言。唯欲界没。受色中有便般涅槃。得中般名非色界没。何缘有学未离欲贪。无中有中般涅槃者。欲界中有依身微劣。于多事业无堪能故。住本有位。于欲界法尚难越度。况中有中。能越欲界至得应果。多事业者。谓越三界及永断除二种烦恼。并得二三沙门果证。住中有位无如是能。又此有前未曾数习。九品差别烦恼治故。又不还等果非中有身得。断增上惑所证得故。离三界染极为难故。无欲中有能般涅槃。色界中有与此皆异。故有于中得涅槃者。又此地中有得般涅槃。唯起此地中所有圣道。初静虑地中有位中般涅槃者。唯起自地根本静虑圣道现前。非未至中间难令现前故。在中有位依身微劣。要易起者方能现前。此五名为行色界者。行无色者差别有四。谓在欲界离色界贪。从此命终生于无色。此中差别唯有四种。谓生般等有差别故。此并前五成六不还。复有不行色无色界。即住于此能般涅槃。名现般涅槃。并前六为七。或应总立九种不还。谓现涅槃分为二种。一于先位善辩圣旨。二临终时方能善辩。于上流内亦分二种。一行色界。二行无色。并前四为八。足转生成九。言转生者。谓于前生已得预流或一来果。于今生内方得不还。前现般言唯目现世初得入圣至涅槃者。或不还者由根差别。随其所应分成九种。或行色界五不还中。复有异门分成九种。颂曰

  行色界有九　　谓三各分三
  业惑根有殊　　故成三九别

论曰。即行色界五种不还。总立为三各分三种。故成九种何等为三。中生上流有差别故。云何三种各分为三。中般涅槃分为三者。初起至远近当生处。得般涅槃有差别故。生般涅槃分为三者。才生有行无行异故。此皆生已得般涅槃。是故并应名为生般。于上流中分为三者。全超半超遍没异故。然诸三种一切皆由速非速经久得般涅槃。故分为九种。不相杂乱。如是三种九种不还。由业惑根有差别故。有速非速经久差别。且总成三由先所集。顺起生后业有异故。如其次第下中上品。烦恼现行有差别故。及上中下根有异故。此三一一如其所应。亦业惑根有差别故。各有三别。故成九种。谓初二三由惑根别。各成三种非由业异。后三亦由顺后受业有差别故。分成三种。故说如是行色不还。业惑根殊成三九别。若尔何故诸契经中佛唯说有七善士趣。颂曰

  立七善士趣　　由上流无别
  善恶行不行　　有往无还故

论曰。中生各三上流为一。经依此立七善士趣。何故前二各分为三。第三上流唯立为一。以上行故名为上流。由此义同但立为一。前之二种虽亦义同。然为其中别相难了。欲令易了故各分三。上流有三相别易了。无烦于彼更别建立。又前二别唯有尔所。易显示故各分为三。第三上流别义多种。卒难显示故总立一。谓初中般唯在将生。根惑品殊故分三种。第二生般唯在已生。亦根惑殊故分三种。上流通有将生已生。将生上流复有二种。谓于静虑杂不杂修。已生上流分二亦尔。复于如是二上流中。若无杂修容生二界。若有杂修唯生一界。生一界者复分为三。全超半超遍没异故。于半超内差别有多。由此上流别相烦广。若一一辩难可周悉。故依等义总立上流。中生位中差别义少。易显了故分之为六。虽彼一一亦有同义。而等第三。于上流中虽有异义。而等前二。为相影显故唯立七。唯此已断欲贪嗔等非善士法。及与无学大善士果极相近故。经唯说此名善士趣。非谓预流及一来者。都不可说名善士趣。佛亦说彼名善士故。如契经言。云何善士谓若成就有学正见。乃至成就有学正定。往上名趣。谓趣上果及趣上。生故唯说七。或唯此七皆能行善不行不善。余则不然。又唯此七往上界生不复还来。余则不尔。故但依此立善士趣诸在圣位曾经生者。亦有此等差别相耶。不尔。云何。颂曰

  经欲界生圣　　不往余界生
  此及往上生　　无练根并退

论曰。若在圣位经欲界生。必不往生色无色界。由彼证得不还果已。定于现身般涅槃故。若于色界经生圣者。容有上生无色界义。然天帝释作如是言。曾闻有天名色究竟。我后退落当生彼者。由彼不了对法相故。言我后者三十三天。自在异熟最后边际。言退落者。谓于后时。若不获得阿罗汉果。当生彼者。谓愿当生色究竟天勿生欲界。以天帝释缘五死相极生忧苦。来归世尊死相才除。便作是说为令喜故。又观遮彼无多益故。佛不遮止。即此已经欲界生者。及已从此往上界生。诸圣必无练根并退。何缘不许经欲界生及上生圣者有练根并退。以曾经生于自相续。蕴积圣道极坚牢故。及得殊胜所依身故。由此彼无练根退理。前说上流杂修静虑为因能往色究竟天。先应杂修何等静虑。由何等位知杂修成。复为何缘杂修静虑。颂曰

  先杂修第四　　成由一念杂
  为受生现乐　　及遮烦恼退

论曰。诸欲杂修四静虑者。必先杂修第四静虑。以彼等持最堪能故。诸乐行中彼最胜故。谓彼静虑最有堪能。现在前时。令所依止自体势力增长广大故。若依彼杂修静虑。后虽退失生余天中。由于先时杂修彼力。复能依彼杂修静虑。即由此理第四静虑。诸乐行中最为殊胜。彼轻安乐极上妙故。谁于静虑能杂熏修。唯诸圣者通学无学。学位唯通信解见至。于无学位通时非时。必先三洲杂修静虑。退生色界亦能杂修。岂不杂修诸静虑者。必先已离三静虑贪。如何可言杂修静虑。通于见至而成上流。谓要人间杂修定已。后退三定生梵众天。于彼复须离三定染。方能重起杂修静虑。从彼没已乃生净居。方名上流。如先已说。非诸见至可有斯理。彼于离染必不退故。无如是失。彼从先来住见至根非所许故。谓彼先住信解种性。杂修静虑然后退失。彼惧于后复有退时。便修练根成见至性。从欲界没生色界中。乘前复能杂修静虑。故六种性皆有上流。于杂修时作何方便。彼必先入第四静虑。多念无漏相续现前。从此引生多念有漏。后复多念无漏现前。如是旋还后后渐减。乃至最后二念无漏。次引二念有漏现前。无间复生二念无漏。名杂修定加行成满。从此以后不由功力。任运唯从一念无漏。引起一念有漏现前。无间复生一念无漏。如是有漏中间刹那前后刹那无漏杂故。名杂修定根本圆成。如是杂修第四定已。乘此势力随其所应。亦能杂修下三静虑。杂修静虑五蕴为体。然于此中诸世俗智。是四法四类八智所杂修。有余师言。诸世俗智唯为苦集。类智杂修彼二能缘此为境故。若尔无容多无漏智现前杂故。则不应言此由彼杂。故得自在杂修静虑应不圆成。此不从余灭道法类。苦集法智无间而生。及无间生彼诸智故。杂修静虑略有三缘。一为受生。二为现乐。三为遮止起烦恼退。谓不还中若诸见至。杂修静虑为前二缘。一为受生。二为现乐。为受生者希求胜生。谓厌共生欣不共故。为现乐者欣乐胜定。谓世俗定最能资身。由此能令现法乐住。前后无漏为其助伴。若诸信解为前二缘。亦为遮防起烦恼退。谓钝根者起二无漏。方便防护清净等持。令味相应等持转远。不令净为染等无间缘。故阿罗汉中不时解脱。但为现乐杂修静虑。时解脱者为求现乐。亦为遮防起烦恼退。若杂修静虑为生五净居。何缘净居处唯有五。颂曰

  由杂修五品　　生有五净居

论曰。由杂熏修第四静虑。有五品故净居唯五。何谓五品。谓下中上胜上极上。品差别故。此中初品。三心现前便得成满。谓初无漏。次起有漏后起无漏。第二中品。六心现前方得成满。谓二有漏为四无漏之所杂修。如是所余随其次第。有九十二十五念心。如应现前方得成满。如是五品杂修为因。如次能招五净居果。如是十五有漏无漏心。皆是先来未曾得今得。有余师说。初五无漏是从先来未得今得。余十皆是曾所得心。前五现前时已未来修故。有不起定杂修成满。有要数起方得圆成。有余师言。由信等五次第增上感五净居。谓或有时信根增上杂修静虑。或有乃至慧根增上杂修静虑。随此差别感五净居。诸感净居为是业力。为杂修力。若是业力杂修静虑则为唐捐。若杂修力与品类足所说相违。如彼论说。杂修静虑及由业故生净居天。诸所有处等名非异生法。有说。业力感净居天。然不唐捐。杂修静虑以修行彼思现前故。有余师言。是杂修力。而不违害品类足文。彼论先说杂修定者。为显先时入彼定故。次后复说及由业故生净居者。为显后时即由彼力生净居故。此中决定俱由二力。以随阙一不生彼故。然唯有漏感彼异熟。非无漏力弃背有故。经说不还有名身证。依何胜德立身证名。颂曰

  得灭定不还　　转名为身证

论曰。有灭定得名得灭定。即不还者。若于身中。有灭定得转名身证。谓不还者。由身证得似涅槃法。故名身证。如何说彼但名身证。以无心故。依身生故。以身俱生得势力故。彼已灭位犹名得彼。此中经主作如是言。理实应言彼从灭定起得先未得。有识身寂静便作是思。此灭尽定最为寂静极似涅槃。如是证得身之静寂故名身证。由得及智现前证得身寂静故。今谓彼从灭定起位。虽得先未得有识身寂静。而非唯彼位方得身证名。先后二时俱得名故。由此设无缘灭定智。得势力故立身证名。是故前说于理为胜。举后边故唯作是言。得灭定不还转名为身证。理实身证于八解脱。无不具足。由身证住。以灭尽定用余解脱为门。而入故得。灭定决定亦应得余解脱。如契经说。入灭定时先灭言行。乃至广说。何缘佛说有学福田。身证不还不预其数。谓世尊告给孤独言。长者当知。福田有二。一者有学。二者无学。有学十八。无学唯九。何等名为十八有学。谓预流向预流果。一来向一来果。不还向不还果。阿罗汉向。随信行随法行。信解见至。家家一间。中生有行无行上流。是名十八。何等名为九种无学。谓退法。思法。护法。安住。堪达。不动法。不退法。慧解脱。俱解脱。是名为九。理亦应说。而不说者。以佛观见有学无学由断及根有殊胜故。能生胜果名为福田。然诸不还所得灭定。是有漏故不可说言。自性解脱故名清净。彼所依身犹有烦恼。未永断故不可说言。相续解脱故名清净。故不约成彼立有学福田。无学位中有漏功德。虽非自性解脱所收。相续解脱故名清净。由此亦能生殊胜果。是故约定及根差别。说九应果皆名福田。或立有学依因无故。不置身证有学数中。何谓建立有学依因。谓诸无漏三学及果。灭定非学亦非学果故。不约成彼说有学差别。然今于此不还位中。约无异门密说身证。若异此者不应唯说。得灭定不还转名为身证。此义于后当更分别。若说身证兼约异门。即上所言非善答问。三无色解脱亦通无漏故。已辩不还粗相差别。若细分析数成多千。此中且依行色界五。约诸地等五门分别。谓五约地数成二十四。定地中各五种故五。约种性数成三十六。种性中各五种故五。约生处数成八十。十六处中各五种故。五约种性根数成九十。谓退法种性下中上根。有差别故数成十五。乃至不动种性亦然。五约地种性数成百二十。谓四地中各三十故。五约地种性根数成三百六十。谓四地中各九十故。五约生处种性数成四百八十。谓十六处各三十故。五约生处种性。及根数成一千四百四十。谓十六处各九十故。五约离染处种性根积数总成一万一千九百六十不还差别。谓以离染九品不同。乘前一千四百四十。已辩第三向果差别。次应建立第四向果。颂曰

  上界修惑中　　断初定一品
  至有顶八品　　皆阿罗汉向
  第九无间道　　名金刚喻定
  尽得俱尽智　　成无学应果

论曰。即不还者。进断色界及无色界修所断惑。从断初定一品为初。至断有顶八品为后。应知转名阿罗汉向。即此所说阿罗汉向中。断有顶惑第九无间道。亦说名为金刚喻定。此定坚锐喻若金刚。无一随眠不能破故。先已破故不破一切。实有能破一切功能。此既能摧最细品惑。故知一切无间道中。唯此刹那名极上品。故能永断一切随眠。虽见道中亦有能断有顶烦恼无漏对治。然彼九品惑可为一品断。知彼烦恼势力微劣。见道既为劣惑对治。知非能破一切随眠。若有破能何碍不破。故彼不得金刚喻名。又诸随眠中无事者易断。见道治彼知非极上。由此不立金刚喻名。此中所明金刚喻定。能治一切有事惑中最后微微极难断品。故知能破一切随眠。由此力能一刹那顷。证一切惑断无漏离系得。如是所说金刚喻定。唯与六智随一相应。谓四类智灭道法智。缘四圣谛十六行相。通依九地义准已成。故此差别说有多种。且未至摄有五十二。谓苦集类智观有顶苦集。作非常等因等行相。与彼相应差别成八。灭道法智观欲灭道。作灭静等道等行相。与彼相应差别亦八。灭类智于八地灭。一一别观作四行相。与彼相应成三十二。道类智于八地道。一切总观作四行相。与彼相应差别成四。以治八地类智品道。同类相因必总缘故。灭唯别缘道则不尔。于随眠品已具成立。如未至摄有五十二。中四静虑应知亦然。空无边处有二十八。谓除灭道法智品八。及除观下四地灭谛各四行相相应十六。以依无色必无法智。及缘下灭类智品故。缘下地道于理无遮。道必总缘前已释故。余如前故有二十八。识无边处有二十四。无所有处唯有二十。谓彼于前复除观下。灭圣谛境四八行相。随其次第准前应释。诸有欲令三无色地。有缘下地灭类智者。彼作是说。空无边处加前十六。识无边处加前二十。无所有处加二十四。如是总说依无色地。金刚喻定七十二种。或复说有百三十二。有余师说。道类智品于八地道。亦各别观故前六地各有八十。空无边处唯有四十。识无边处有三十二无所有处有二十四。复有欲令灭类智品。于八地灭有别总观。故前六地中各百六十四。空无边处唯五十二。识无边处有三十六。无所有处有二十四。彼俱非理。道必总缘灭唯别缘前已辩故。尊者妙音作如是说。金刚喻定总有十三。谓断有顶见修断惑。无间道摄十三刹那。此亦不然。以四类忍前八无间道非极上品故。此定既能断有顶地第九品惑。能引此惑尽。得俱行尽智。令起金刚喻定。是断惑中最后无间道所生尽智。是断惑中最后解脱道。故说此定所引尽智。与第九品尽得俱起。或此尽言显一切尽。谓第九品及所余惑。皆得择灭故名为尽。金刚喻定能引诸惑。尽得俱行尽智令起。此与一切烦恼尽得。最初俱生故名尽智。有余师说。惑尽身中此最初生故名尽智。如是尽智至已生时。便成无学阿罗汉果。已得无学应果法故。为得别果。所应修学。此无有故得无学名。岂不无学亦希别果。以无学者亦转根故。此难不然。如先有学求得别果此不然故。谓如预流非一来等。于后获得一来等时。舍预流等名得名一来等。皆舍别果得别果名。此则不然。退非思等于后获得思法等时。虽舍退等名得名思法等。非舍别果得别果名。前后皆名阿罗汉故。唯舍前果得别果时。舍前果名得名别果。更无别果是所应学。故名无学前释无过。即是行向住前果者。求别名果此无有义。既说尽智至已生时。便成无学阿罗汉果。义准尽智未已生时。前七圣者皆名有学。为得别果勤修学故。住本性位何名有学。学意未满故。学得常随故。何故无学名阿罗汉。诸自利行修学已成。唯应作他利益事故。如契经说。不自调伏能调伏他。无有是处。或有三种补特伽罗。谓诸异生有学无学。异生虽学戒定慧三。而犹未能如实见谛。容有舍正作邪学理。故不于彼立有学名。诸有已能如实见谛。正学无退得有学名。由此世尊为显定义。于有学者重说学言。如契经中佛告憺怕。学所应学学所应学。我唯说此名有学者。诸已善学戒定慧三。不复学者立名无学。此是一切有学异生。所应供养故名应果。依如是义故有颂曰

  于戒定慧三　　若已善修学
  毕竟离忧垢　　堪为世福田

学法云何。谓有学者无漏有为法。无学法云何谓无学者无漏有为法。诸无为法虽是无漏。而不名为学无学法。以有得者异生等身亦成就故。若无得者都不系属学无学故。如是有学及无学者。总成八圣补特伽罗。行向住果各有四故。名虽有八事唯有五。谓住四果及初果向。以后三果向不离前果故。此依渐次得果者说。若倍离欲全离欲者。住见道中名为一来。不还果向非前果摄。何故尽智唯是无学。诸有学者亦自了知。我已永尽地狱等故。此前已说。前说者何。谓尽得俱方名尽智。预流等位犹有余惑。既无尽得亦无尽智。由此契经作如是说。诸有学者成就八支。若成十支名阿罗汉。若尔何故尊者舍利子告大长者给孤独言。汝已具成就正智正解脱。无相违失。依彼成就能往诸恶趣邪。智邪解脱。真对治道密意说故。若尔何不说有学成十支。有余无智故心未善脱故。若尔何缘经作是说。诸有成就佛证净者。一切皆名已得正见。乃至已得正解脱者。见圆满者亦如是说。亦无违失。所以者何。我不说言诸有学者无有正智及正解脱。但作是说。彼不立支。不立支因如前已说

说一切有部顺正理论卷第六十五阿毗达磨顺正理论卷第六十六

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩贤圣品第六之十

如上所言修道有二。一者有漏。二者无漏。今应思择于此二种由何等道离何地染。颂曰

  有顶由无漏　　余由二离染

论曰。有顶地中所有烦恼。唯无漏道能令永离定非有漏。所以者何。唯此力能治上地故。唯于次上近分地中。起世俗道治下地惑。有顶地惑既无上地。故无有漏能离彼染。何缘世俗道不治自地惑。是自随眠所随增故。非彼随眠所随增事。应有势用治彼随眠。以顺生长彼烦恼故。若有势用能治彼者。此必非彼之所随增。以缘此时彼损减故。何缘下地起世俗道。不能对治上地随眠。非彼随眠所随增故。不顺生长彼烦恼故。应许能治上地随眠。上地定非下地世俗。厌行断道所缘境故。非厌下地能离上染。上地望下极微妙故。由此证知唯无漏力。能离有顶其理善成。余八地中所有烦恼。通由二道能令永离。世出世道俱能离故。既通由二离八地染。各有几种离系得耶。颂曰

  圣二离八修　　各二离系得

论曰。诸有学圣用有漏道。离下八地修断染时。能具引生二离系得。有漏无漏二种断道。于八地中所作同故。用无漏道离彼亦然。亦以于中所作同故。由此有学离八修断。世出世道随一现前。各未来修世出世道。既说圣者二离八修。各能引生二离系得。准知圣者离有顶修。及见断时用无漏道。唯引无漏离系得生。亦不未来修世俗道。与世俗道不同事故。异生离八用有漏道。唯引有漏离系得生。亦不未来修无漏道。未入圣故不说自成。有余师言。以无漏道离下八地修断染时。何缘知亦生有漏离系得。有舍无漏得烦恼不成故。谓有学圣以无漏道离彼染时。若不引生同治有漏离系得者。则以圣道具离八地。后依静虑得转根时。顿舍先来诸钝圣道。唯得静虑利果圣道。上惑离系应皆不成。是即还应成彼烦恼。然非所许。是故定知。诸有学圣以无漏道离下八地修断染时。亦具引生二离系得。此证非理。所以者何。彼圣设无有漏断得。亦不成就上地烦恼。如分离有顶得转根时。及异生上生不成惑故。谓如分离有顶地染。后依静虑得转根时。无漏断得既已顿舍。彼地离系无有漏得。而彼地惑亦不成就。又如异生生二定等。虽舍欲界等烦恼断得。而不成就欲界等烦恼。以欲界等有漏离系得。初定等摄。唯彼能治故。若生上地此得必舍。生上地必舍下有漏善故。此二虽无烦恼断得。而胜进故遮惑得生。彼亦应然。故证非理。由此但可作如是言。二道于中所作同故。随一现起引二得生。不可说言为成断故。已辩离染由道不同。今次应辩由地差别。由何地道离何地染。颂曰

  无漏未至道　　能离一切地
  余八离自上　　有漏离次下

论曰。诸无漏道通依九地。谓四静虑未至中间及三无色。若未至摄能离欲界乃至有顶。余八地摄随其所应。各能离自及上地染不能离下。未离下时上道必无现在前故。诸有漏道一切唯能离次下地。非自地等自地烦恼所随增故。势力劣故。先已离故。诸依近分离下地染。如无间道皆近分摄。诸解脱道亦近分耶。不定。云何。颂曰

  近分离下染　　初三后解脱
  根本或近分　　上地唯根本

论曰。诸道所依近分有八。谓四静虑无色下边。所离有九。谓欲八定。初三近分离下三染。第九解脱现在前时。或入根本或即近分。上五近分各离下染。第九解脱现在前时。必入根本非即近分。近分根本等舍根故。下三静虑近分根本。受根异故。有不能入转入异受。少艰难故。离下染时必欣上故。若受无异必入根本。诸出世道无间解脱前既已说。缘四谛境十六行相义准自成。世道缘何作何行相。颂曰

  世无间解脱　　如次缘下上
  作粗苦障行　　及静妙离三

论曰。世俗无间及解脱道。如次能缘下地上地。为粗苦障及静妙离。谓诸无间道缘自次下地。诸有漏法作粗苦等。三行相中随一行相。若诸解脱道。缘彼次上地。诸有漏法作静妙等。三行相中随一行相。约容有说二道各三。非诸有情于离染位。无间解脱皆各具三。诸下地中由多掉举寂静微劣。故名为粗。虽大劬劳暂令掉举势用微劣。仍不能引美妙乐生。故名为苦有极多种灾害拘碍。及能覆障。令无功能见出离方。故名为障。诸上地中不作功用掉举微劣。故名为静。不设劬劳掉举微劣引生胜乐。故名为妙于下地中所有灾害。能决定见心不生欣。及能越彼。故名为离。应知此中已兼显示无间解脱。行相各三相翻而生。如其次第。谓无间道缘下为粗。解脱道中缘上为静。余相翻起如次应知。然离染时起则不定。世俗无间及解脱道。能离下等九品染故。应知亦有九品差别。此中异生离欲界染。九无间道粗等三行。随一现前各未来修。粗等三行八解脱道。静等三行。随一现前各未来修。粗等六行后解脱道现。在未来所修如前八解脱道与前别者。复修未来初静虑摄。无边行相。如是乃至离无所有染。无间解脱道所修应知。若诸圣者以世俗道。离欲界染九无间道。粗等三行随一现前。各于未来修十九行。谓粗等三有漏无漏。十六圣行八解脱道。静等三行随一现前。各未来修二十二行。谓前十九加静等三。后解脱道现在未来所修如前。八解脱道与前别者。复修未来初静虑摄无边行相。离初定染九无间道。粗等三行随一现前。各于未来修十九行。谓粗等三及唯无漏十六圣行。此十六行是下地摄。以上地边无圣行故。后修圣行准此应知。八解脱道静等三行随一现前。各未来修二十二行。谓前十九加静等三。后解脱道现在未来所修如前。八解脱道与前别者。复修未来二静虑摄无边行相。如是乃至离无所有染。无间解脱道所修应知。有余师言。异生圣者离欲无间解脱道中。亦修不净息念慈等。离余上地所修如前。初静虑边善根广故修如是行。上诸定边善根少故所修如前。又欲界中有多烦恼。为欲断彼修多对治。上地不然故。修治少。离欲界染九无间道。未来所修粗等三行。唯缘欲界八解脱道。未来所修粗等三行。通缘欲界及初静虑。静等三行缘初静虑。后解脱道未来所修。粗等三行通缘三界。静等三行缘初静虑。乃至有顶离初定染。九无间道未来所修。粗等三行缘初静虑。八解脱道未来所修。粗等三行缘初二定。静等三行缘第二定。后解脱道未来所修。粗等三行通缘三界。静等三行缘第二定。乃至有顶离二静虑三静虑染。随其所应皆准前说。离四定染九无间道。未来所修粗等三行。缘第四定八解脱道。未来所修粗等三行。缘第四定及缘空处。然非一念。以界别故。静等三行唯缘空处。后解脱道未来所修。粗等三行静等三行。皆缘空处乃至有顶离空处染九无间道。未来所修粗等三行。唯缘空处八解脱道。未来所修粗等三行。缘空识处静等三行。唯缘识处后解脱道。未来所修粗等三行。静等三行俱缘识处。乃至有顶离识处染。无所有染随其所应皆准前说。何缘最后解脱道中。未来所修粗等三行。静虑摄者通缘三界。无色摄者唯自上缘。诸静虑中有遍缘智。无色根本必不下缘。故二所修所缘有别。此中一类譬喻论师。为欲显成分别论义。作如是说。无有异生实断烦恼。有退失故。谓若有能实断有顶萨迦耶见必无退失。若有退失必未实断。既许异生于下八地。诸烦恼断可有退失。故无异生实断烦恼。彼说非理。于有顶惑有伏无伏。皆有失故。谓诸异生于有顶惑。为许有伏许无伏耶。若许异生伏有顶惑。如伏下地诸烦恼已。彼于下地必不受生。如是既能伏有顶惑。应于有顶亦不受生。是则异生应证圆寂。若伏有顶犹生有顶。非伏下地犹生下地。是则不应。以有顶惑断已不退例下令同。若许异生无伏有顶。以世俗道于彼无能。唯许彼能伏下地惑亦不应。以有顶地惑断已不退例下令同。如是推征二皆有失。故不可说彼实无断。然彼所言见有顶摄。身见等惑断已无退。证知下地所有诸惑。亦应如彼断已无退。既见异生于下地惑断已还退。故知彼于下地诸惑实未能断。此不应理。断者异故谓非我等许诸异生。于有顶惑有能断义。以断有顶世俗道生无所依故。及即于中解脱道起无所缘故。下诸地惑异生能断。既能断者凡圣有殊。亦应许有退不退异。如何举圣断无退理。例异生断亦令无退。又不成故。谓非我等许有顶惑断已无退。此既不成。如何可以彼无退理例下令同。虽有顶摄萨迦耶见断已无退。而彼不许彼地有伏如下地惑。故不可以彼断无退。例下地惑断无退理。无伏有伏彼此既殊。有退无退亦应许别。又道异故。谓非此道断有顶摄萨迦耶见。即由此道诸异生类。断下八地所有烦恼。道既有异应许惑断。有退不退二种差别。以诸惑断是道果故。若谓此义应生疑者。理亦不然分明说故。谓彼或作如是思惟。彼此治道既有差别便可生疑。诸异生类既有退失。为断不断此不应疑。世尊处处分明显说。诸异生中有断烦恼及离染故。谓契经说诸异生中。有断五盖断乐断苦。又契经说。嗢达洛迦遏逻摩子能断诸欲。又契经说。昔有外仙为世导师名为妙眼。彼于欲界已得离染。又见契经分别业处。说有欲界离染外仙。由此证知道有异故。诸异生类于八地惑。虽有实断而有退义。非道异故不能实断。是故于此不应生疑。若谓此中唯不现起名断离染。如余处说断离染言。此亦不然。无决定因故。有大过失故。谓彼或作如是思惟。唯不现行名断离染。如于死位亦说断言。非正死时实有治断。又如有说于村邑中。有诸童男或诸童女。戏聚砂土为舍为城。宝玩须臾还得离染。彼言意显于彼境中。贪不复行非实断离。是故此中唯不现起名断离染。为证不成。此定不然无定因故。此中所说断离染言。有何定因堪为诚证。唯显烦恼暂不现行。非为显成断诸惑得。若谓圣者断必无退。异生有退故知未断。此亦不然非极成故。非圣不退是所极成。故于此中无定因证。又此所说断离染言。若唯不行有太过失。以于余处有说圣道名断离染。汝亦应计唯不现行如余处说。是故彼执决定非理。如何知此断离染言。非伏现缠。是断惑得此如圣者亦上生故。谓有学圣断下惑得方得上生。彼此同许此异生类。亦得上生故亦应许断下惑得。若谓道异故不同者。则已显成异生断退。有退无退足显道别。何要断伏方显道异。由道异故令诸烦恼。伏断差别非道异故。虽已实断退无退殊。如是所言何理为证。又应一切善无记心。而命终者虽烦恼得。身中未断亦得上生。所以者何。离现缠故。谓于此位善无记心现在前者。自地烦恼必不现前故名为离。非由此故烦恼不行。与由余缘少有差别。又非别法有差别故。可令此中亦有差别。等虽不起无所遣故。谓非别法于相续中。少有所遣余无此力。可说彼法有所遣故。虽等不行而时有别。若彼意谓得此地中。伏对治者则生此地。故命终位善无记心。现在前者生自非上。以命终位善无记心。非上地摄伏对治故。此亦不然。诸依上地伏治下地诸烦恼者。为由上地业力故生。为由上地伏治道力。若由业力生上地者。但伏此地下地烦恼。必定应有感此地业。由此业力应定生此。若由道力生上地者。依此地道伏欲界惑。命终但应生于此地。则异生类欲界命终。应无乃至生有顶者。唯应得受初静虑生。此道定能感此生故。由此未断下地惑得。决定无能生上地者。故彼所说道既有异。便可生疑。诸异生类既有退失。为断不断如是所疑定不应理。由此所说由道异故。诸异生类于八地惑。虽有实断而退理成。复有余师说。世俗道于断烦恼决定无能。故世尊言。要得圣慧方断烦恼非诸异生。已得圣慧岂能断惑。又契经说。此胜彼者。谓胜彼已彼更不生。彼若更生此非胜彼。诸异生类虽断烦恼。而诸烦恼有时更生。是故定知彼无实断。又契经说。若身见等未永断时贪等未断。要彼断已此方断故。又契经说。萨迦耶见戒禁取疑三法未断。终不能断贪嗔痴故。诸异生类既未能断有身见等。是故定知必未实断贪等烦恼。此亦不然。赞胜者故密说有顶贪嗔痴故。谓佛世尊为赞胜者。说断烦恼要得圣慧。以诸圣慧于断烦恼。如理观中最为胜故。世间亦有就胜说言。要真国王方能护国。要真善士不陷诳愚。是故此经唯约毕竟。断烦恼道密意而说。不可由斯便能遮止。诸世俗道断烦恼用。由此已释此胜彼经。谓约无余永无退失。断惑圣道密意说故。如世间说食此食已。终无变吐名食此食。烧此物已终不复生名烧此物。非后变吐及后生者。非食非烧但约毕竟。无变生说此亦应然。若不尔者所断烦恼。后若更生于正断时应不名胜。虽非永胜暂胜非无。如何引斯证无实断。有身见等未永断时。贪嗔等三必未断者。此于我说理亦无违。此约有顶密意说故。谓有顶地见惑先断。后时方断修所断惑。此约无余断见惑已。后时方断修断惑说。既密意说不可为证。此经决定是密意说。以即于此复作是言。若于三法未已断者。必不能断有身见等。何谓三法。一非理作意。二习近邪道。三心下劣性。是谓为三。然必无能先断三法。后时方断有身见等。以见道前无彼治故。证知此经是密意说。此于先伏说已断声。后见道现前实断身见等。正理论者作如是言。依世俗道亦能断惑。以有教理分明证故。且有教者。谓契经言。汝等若能永断一法。我保汝等得不还果。一法者何。谓有身见。此经意说。先离欲者入谛现观断有身见。现观满时得不还果。非先未离欲界贪者。现观满时得不还果。故世俗道实能断惑。若彼意谓。断身见已后时渐得不还果。证依如是义密说此言。非断身见时得不还果故。此亦非理。若依此说经亦应言得应果故。谓断身见于后时中。亦渐次得阿罗汉果。然契经中不作是说。故知但约先离欲者。入谛现观断有身见。现观满时得不还果。密作是说亦得成证。然于圣谛现观位中。无不得果而退出义。又彼无容更得余果。故说汝等若断身见。我保汝等必得不还非无间得。故无有过理必应尔。以余经中世尊亦说。得第四定后入现观得不还果。谓契经言。彼由如是尸罗圆满。能离诸欲恶不善法。广说乃至。具足安住第四静虑。彼由如是等持圆满。于苦圣谛如实见知。广说乃至。得不还果。若谓岂不即此经言。彼由如实见知四谛。便能永断五下分结。若彼先离欲界染时。已能实断欲贪等结。则不应说先离欲者。今圣道起方断彼结。非先已断有更断义。故所引教为证不成。此亦不然。此经意显尔时唯得不还果故。谓诸渐次得不还者。尔时必断五结无余。为令了知先离欲者。入谛现观唯得不还。故说尔时断五下结。此言意说便能断尽。非谓今时能总断五理必应尔。以见道力不能无余断贪嗔结。要无余断方证不还。由此定知先离欲者。已能实断二下分结。为显彼见谛唯证不还故。说彼今时断五下结。或此意显彼于今时。断彼更生密作是说。谓若不入圣谛现观。彼异生类虽断贪嗔。后时定应还退失故。或此于远假说近声。如说王今从何来等。谓虽先断贪嗔二结。而同世俗说今便断。如王至此久离所从。而假说今从何来等。或彼三结入现观时。所有离系得无漏得。贪嗔二结得永不生。故说尔时断五无失。若谓虽说得第四定后入现观得不还果。而不定说断伏下地。如何定知彼下地惑。皆已实断得非唯伏现缠。此不应疑。以此经说得不还故。不可说言后渐方得。先已破故。又先已说离欲异生。亦如圣者生上地故。谓唯能伏下地烦恼。便生上地非所极成。唯能实断下地烦恼。便生上地是所极成。故于此中不应犹豫。如是名为有教证。故知世俗道亦能断惑。言有理者。谓烦恼力能系缚自身。令界地别故。若欲界惑得未实断。有能往生色无色界。则诸烦恼应无功能。缚界地生令有差别。若谓未伏下地烦恼必不生上是彼功能。此亦不然。虽伏此地所有烦恼亦生此故。谓有能伏有顶烦恼。然复得生有顶地故。然依自地起世俗道。亦能制伏自地烦恼。如不净观持息念等。亦伏自地现行烦恼断烦恼得。要于此地诸烦恼中。得解脱道制伏烦恼令暂不行。工巧威仪亦有此力。况善心起而无功能。如住此间能伏八地。所有烦恼令不现行。于有顶何缘独不能制伏。彼定应许如是理趣。若不许然诸有已离无所有染。期心不起入谛现观。证无学者如何不伏有顶烦恼。便起断彼圣道现前。故住此间必于有顶有伏烦恼。善方便智既不可说。不断有顶诸烦恼得。唯由伏彼烦恼现行便不生彼。于下八地例亦应然。由此定知诸世俗道。亦断烦恼其理极成。又应诸预流得生无色故。若伏下地即得上生。有诸异生先伏二界。后入见道现观满时。应得预流非不还果。三界修惑许具缚故。见道非彼断对治故。彼住果位若致命终。决定应许生无色界。下二界惑先已伏故。若生彼已断欲等惑成阿罗汉。便违契经。如契经言。有五圣者此处通达此处究竟。非彼圣者有决定因。要还此生方证圆寂。若谓既说极七返有故。定从彼还来此生理亦不然。此言唯约欲界人天密意说故。宁知七返约欲界说。唯约欲界修断惑断。立家家等名差别故。谓断五种下分结故名不还果。于下分中欲贪嗔恚。及痴薄故名一来果。不还果向名为一间。一来果向名为家家。此既唯约欲修惑断立差别名。故知但依欲界修惑。都未断位立七返有。若依未越此地烦恼立七返生。则知但于所未越地受七返有。故七返有非色无色。又先已离二界贪者。不应建立七返有名。以彼唯是利根摄故。极七返生钝根摄故。又彼所说违自宗经。非彼宗经许七返有。或容有受第八生义。色无色界生处极多。于彼无容极唯七有。又彼天处满第七生。决定无容还来生此。是则还与契经相违。故契经言。有五圣者此处通达此处究竟。又七返生非必定受。极声唯说极多者故。预流往彼受第二生便般涅槃。亦此通达彼处究竟。定违前经。是故必无唯伏下地所有。烦恼便得上生。既诸异生有上生理。知世俗道亦能断惑。有作是执。诸有先离欲界贪者。后入见谛道现观时得预流果。欲贪嗔恚虽不现行。而有彼得恒随缚故。即彼复谓道现观时。虽必定得预流果证时极促故。诸契经中不作是言。先离欲者道现观位证预流果。又作是说。谛现观俱得不还者。此于无间立以俱声。如契经说。诸有情类生无想天。后想起俱便从彼没。复作是言。道现观位得胜道故。离欲界贪即于尔时得不还果。如是一切前后相违。如幼稚童自室言故。谓彼若说先离欲者。道现观时得预流果。欲贪嗔恚虽不现行。而有彼得恒随缚故。则不应说道现观位得胜道故。离欲界贪即于尔时得不还果。以必不可道现观时。双得预流不还果故。若后门是应舍前门。若前门是应舍后门。前后相违无俱是故。若彼意谓如上地道现在前时。必定应修下地摄道。以殊胜道现在前时能修劣故。此亦应尔道现观位得胜道故。离欲界贪故。于尔时得不还果。此不应理。所以者何。彼宗不立有未来故。执离法外无别得故。不现行道能离欲贪。及嗔恚结理不成故。见道不能断修断故。二道无容俱现前故。又彼所说道现观位得胜道者。其体是何。非于尔时有余胜道。可正显示为此所得。既不能说所得道相。宁说此道能离欲贪。而说尔时得不还果故。彼所说但率己情。又不应谓道现观时。虽必定得预流果。证时极促故。诸契经中不作是言。先离欲者道现观位证预流果。亦不应说谛现观俱得不还者。此于无间立以俱声。所以者何。阙一来故。预流果后必先证得一来果故。非预流无间即证不还果。契经应言先离欲者。道现观位证预流果。谛现观俱得一来果。从此无间方得不还。而不说然故不应理。故彼论者于正法义。背面而住经述己情。不可与其考量正理。傍论已了应辩本义。本说诸位善根相生。前既已说金刚喻定无间。必有尽智续生。尽智无间有何智起。颂曰

  不动尽智后　　必起无生智
  余尽或正见　　此应果皆有

论曰。先不动法诸阿罗汉。尽智无间无生智起。此智是彼本所求故。必与尽智俱时而得。谓彼求得顺诸所解。若无便有入涅槃障。诸阿罗汉共得智时。即亦志求得无生智。然其尽智理应先起。是因位中先所求故。先不动法金刚定后。得无生智而未现前。尽智无间方得现起。除先不动余阿罗汉。尽智无间有尽智生。或即引生无学正见。非无生智后容退故。谓若先是时解脱性。虽于因位双求二种。而至极果容有退故。金刚喻定正灭位中。不得无生唯得尽智。故尽智后尽智现前。或即引生无学正见。先不动法无生智后有无生智起。或无学正见此无学见。一切应果之所共有犹如尽智。故金刚定正灭位中。一切皆得无学正见。然此正见非正所求。故尽无生二智无间。或有即起或未现前。于此位中总略义者。若先不动初起尽智唯一刹那。次无生智亦一刹那或有相续。若时解脱初起尽智。或一刹那或有相续。此二所起无学正见。皆无决定刹那相续如前说。彼非正求故

说一切有部顺正理论卷第六十六阿毗达磨顺正理论卷第六十七

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩圣贤品第六之十一

如说沙门及沙门果。何谓沙门性。此果体是何。果位差别总有几种。颂曰

  净道沙门性　　有为无为果
  此有八十九　　解脱道及灭

论曰。言沙门者。能永息除诸界趣生生死魑魅。或能勤励息诸过失。令永寂静故名沙门。如薄伽梵自作是释。以能勤劳息除。种种恶不善法杂染过失。广说乃至。故名沙门。沙门所有名沙门性。此即沙门所修熏法。熏是排遣生臭惑义。即以无漏圣道为体非世俗道。以能无余究竟静息诸过失故。由此异生虽能已断无所有处染而非真沙门。以诸过失尚有余故。暂时静息非究竟故。既无漏道是沙门性。通以有为无为为果。故沙门果体通有为无为。此果佛说总有四种。谓初预流后阿罗汉。道类智品。是谓有为预流果体。见断法断。是谓无为预流果体。道类智品或离欲界第六。无漏解脱道品。是谓有为一来果体。见断法断。及欲界系修所断中前六品断。是谓无为一来果体。道类智品。或离欲界第九无漏解脱道品。是谓有为不还果体。见断法断欲修断断。是谓无为不还果体。尽智无生智无学正见品。是谓有为阿罗汉果体。三界见修所断法断。是谓无为阿罗汉果体。然薄伽梵于契经中。但说无为沙门果体。如说云何名预流果。谓断三结。乃至云何阿罗汉果。谓已永断贪嗔痴等。岂不不还果已许永断嗔。此亦无违释义别故。此中意说。净除一切烦恼垢者。断名永断非尚有余。烦恼垢者少无余断得永断名。然余处说遍知。云何谓永断贪。乃至广说。此中意说。若一切种及一切断即名永断。一切种者谓断自性。及断能缘即名永断。唯见苦断诸法断位见苦断法。已断自性未断能缘。见集断法已断能缘。未断自性非永断故未名遍知。言一切者。谓见灭断等十一惑中。随一部永断。由此具显有九遍知。及显异生断非遍知所摄。譬喻者说沙门果体。唯是无为由教理故。教如前说今当辩理。以诸有为是可坏故。不可保信沙门果体。是可保信故唯无为。且教不然准前释故。谓前处处已作是释。非彼所引有余意经。可能证成胜义理趣。契经虽言预流果体谓断三结。而不言唯如四修定中现法乐住。定谓经说此是初静虑。然实此定理亦通余。故不言唯显有别意。此经亦尔不应固执。若谓有余经说现法乐住通四静虑。此不尔者。理亦不然与彼同故。谓余经说六法永断。名为预流岂唯三结。又预流者。理实亦应有边执见及贪等。断此非预流果无别证因。由此彼所言不令生喜。故非由此所引契经。证唯无为是沙门果。理亦非理。若无颠倒智望无为法最可保信故。谓观行者如实智生。能自了知我生尽等。虽是可坏法而极可保信。以能显了无倒义故。由此定知四沙门果。其体通摄有为无为。复有至教证沙门果亦通有为。如契经说。根到彼岸为缘显了。果到彼岸果到彼岸为缘显了。补特伽罗亦到彼岸。唯依有为法立补特伽罗。补特伽罗由果显了。故知果体亦通有为。然譬喻宗理最不可依。无为立补特伽罗。彼执无为无有体故。不应无体法为立假者因。谓彼执无为唯不转为相。故不可依托立补特伽罗。若谓但依彼得建立。得是道故必是有为。由此应知依向果道。建立八种补特伽罗。补特伽罗既依道立。道体通向果果岂唯无为。又设劬劳求得名果。果位摄道既是所求。如何可言彼道非果。如何知道亦是所求。以契经中有伽他说

  智人居静室　　勇猛谛思惟
  求八解三明　　证慢掉尽故

又契经言。无相心定以解为果。解体即是尽无生智。定即沙门此即显成。阿毗达磨说沙门果体。通有为无为。理教显然不可倾动。然经但说果是无为。以此无为唯是果故。谓诸择灭唯沙门果。道通沙门故略不说。或以无为法是果非有果。道通二种故略不说。或无为法离有为过。为令欣乐是故偏说。或此唯说无为果。经是有余言不应封执。谓此唯说三结断等。不遍说余烦恼断故。如契经说。心速回转精进能证无上菩提。超段食想越诸色想。没有对想非余不然。应知此经亦复如是。如由别意唯说无为为沙门果。亦由别意说沙门果唯有四种。若废别意直论法相。即沙门果有八十九。皆解脱道择灭为性。谓为永断三界烦恼。有八十九无间道起。见道所摄其数有八。法类智忍各有四故。修道所摄有八十一。九地各九无间道故。此八十九唯沙门性。此沙门性无间所生。八十九解脱道亦有为沙门果。是彼等流士用果故。即诸无间所断惑断。八十九诸择灭。唯无为沙门果。是彼离系士用果故。彼能断此得障得故。岂不沙门性。亦摄解脱道诸无间道。亦彼等流士用果故。应无间道亦是有为沙门果摄。不尔且非诸无间道。一切皆是解脱道果。虽有是者。而但可言。无间道力解脱道起。彼力能断此起障故。彼道无间此必生故。非解脱道力引无间道起。此不能断彼起障故。非此无间彼必生故。谓虽亦有无间而生而不皆然。及非此力谓有余时余加行力所引起故。或有毕竟不复生故无相类失。何故契经说。沙门果非八十九唯说四耶。岂不已言经有别意。有何别意。且有释言唯四位中。诸观行者分明欢悦觉慧生故。谓唯四位极可信非余。设有退失未死还得故。有余复言。唯此四位。如次能越恶趣彼因。人天趣生所显示故。唯上中品贪等势力。往恶趣生非下品故。或有本有二。谓欲界有顶二越有顶。二越欲界。故唯立四为沙门果。或诸烦恼总有二类。一者无记。二者不善。初越二种后越无记。一来不还唯越不善。以恶难越故唯立四。有余师言。非薄伽梵于八十九不现证知。然唯说四沙门果者。颂曰

  五因立四果　　舍曾得胜道
  集断得八智　　顿修十六行

论曰。若断道位具足五因。佛于经中建立彼断。及与断得俱时而生。净解脱道为沙门果。言五因者。一舍曾道。谓舍先得果向道故。二得胜道。谓得果摄殊胜道故。三总集断。谓一果得总得先来所得断故。四得八智。谓一时中总得四法四类智故。五能顿修十六行相。谓能顿修非常等故。住四果位皆具五因。余位不然故唯说四。若唯净道是沙门性。有漏道力所得二果。如何亦是沙门果摄。颂曰

  世道所得断　　圣所得杂故
  无漏得持故　　亦名沙门果

论曰。且无漏道所得择灭。沙门果摄其理极成。得二果时诸世俗道。所得择灭体数甚少。与多圣道所得择灭。总一得得共成一果。是故于此以少从多。俱说名为沙门果体。谓世俗道得二果时。此果非唯以世俗道。所得择灭为断果性。兼以见道所得择灭。于中相杂总成一果。同一果道得所得故。由此契经言。云何一来果。谓断三结薄贪嗔痴。云何不还果。谓断五下结故。世俗道所得择灭。与无漏道所得杂故。以少从多名沙门果。又世俗道所得择灭。无漏断得所任持故。由此力所持退不命终故。无漏断得印所印故。亦得名为沙门果体。如故人物王印所印。不复名为能集者物。此亦应尔故亦名沙门果。有余师说。此灭当为金刚喻定。真沙门果故亦得立沙门果名。此灭虽非彼离系果。是彼士用果名彼果无失。有余复说。由此无为因沙门性增上力得。是故亦应名沙门果。以世俗道断烦恼时。亦修治彼沙门性故。此中上座作如是言。理必应无已见谛者。用世俗道断烦恼义。由彼能见一切有境。皆如炎猛热铁丸故。许世俗道观上地法。起静妙等欣行觉故。由此诸圣理必不应。以有摄法出离诸有。有余复说。如有少年喜自严身耽欲乐净。彼颈被系狗蛇人尸膖烂虫蛆。臭秽难忍深生羞耻厌恶缠心。未若众圣厌恶诸有。而说缘有静等想生。如是所言不令生喜。故圣于有如无想定此非真过。所以者何。且彼如何许诸圣者。见诸有境如热铁丸。于有境中已断乐倒。而于有漏行生此是乐觉。为欲生乐求乐缘故。又彼如何许诸圣者。厌诸有境剧厌三尸。于有境中已断净倒。而于有漏行生此是净想。于极臭处如烂粪泥。女人死尸好习近故。由此彼难非真过失。若谓圣者求诸乐缘。习近女时由失正念。于断惑位正念现前。是故不应引之为例。此亦非理违所说故。谓彼所言违如是说。圣如所见无别异行。又诸圣者安住正念。虽见诸行体皆是苦。而于其中亦生乐觉。如契经说。受乐受时如实了知受于乐受。若谓圣者暂时觉乐余亦应然。于上地境亦暂时观为静等故。非圣观有犹如涅槃。发起毕竟静妙离想。但思上境少静等相。厌离下地粗动等法。世尊亦说以有出有。如说圣者以色出欲无色出色。恐谓无能出无色者。故佛重说诸有所作。诸有所思灭皆能出。又我宗说诸有圣者。以世俗道离下染时。以上世定为首观察起静等觉。非以上生宁可责言。如何圣者于诸有境起静等觉。圣厌有生非有德故。又有至教证诸圣者。于世定中起静等觉。如契经说。具寿舍利子。速往盲林入灭受想定。从定起已高声唱言。此灭涅槃甚乐甚静。谓彼尊者于此灭定觉乐静故。便于涅槃起甚快乐甚寂静觉故。从定起高声唱言。此灭涅槃甚乐甚静。谓灭定中灭少流转。尚有如是乐静二相。况涅槃中流转总灭。或即灭定假说涅槃。以乐及静分相似故。又佛亦说此定甚妙。谓薄伽梵说灭定已复言。此妙过六轻安。以灭定体有妙性故。可以对余挍量胜劣。又渐损减契经中言。如是四种寂静解脱。超一切色无色所收。我说苾刍修彼定者。从彼定起必应唱言。如是定中极为寂静。故不可说唯有顶地。善有漏定寂静非余。若谓不应缘暂静等。起静等想便能断惑。此亦不然。待下地法上地便是毕竟静故。谓初静虑待欲界法。无或寂静不寂静义。岂可说言厌欲界法观初静虑。为静等时非毕竟故障离欲染。又既见有自地善心。能暂思惟自地不净。虽为自地烦恼所缚。而亦能令烦恼不起。如何观下灾横所逼。观上永脱下地灾横非下所缚。胜定现前而不。能断下地惑得。故汝不应不生欢喜。然愚夫类于无想天。执为真实究竟出离。于无想定方能发起。圣者于彼不执出离。故无想定圣者不起。更以余想不能起故。由此彼喻于证无能。是故极成有学圣者。以世俗道亦能断惑。有作是说。以契经中说四沙门果渐次而得故。知诸异生无实断惑。此不应理。以彼经中约次第者密意说故。由此即彼契经中说。且有一类于诸行中。如理思惟。乃至广说。理必应尔。以余经说得四定者入见谛故。不可才遇义缺减经。便兴固执拨余圣教。以诸圣教有多差别。无一经中具众义故。谓诸圣教略有二种。于义有了有不了故。又无所待有所待故。又说世俗胜义谛故。又总相说别相说故。又随自意他意说故。又属法相属法教故。如是等类有无量门。有契经中虽有所说。非离余说义可显了。且如经说于诸行中。如理思惟义犹未了。何等为行行有多种。谓契经说无明缘行。又契经说。入息出息寻伺想思名身等行。又契经说。欲等名行即八断行。又契经说。诸行非常即有漏法。又契经说。一切行无常此经意说一切有为法。又说寿行此即命根。如是等行有无量种。于诸行境如理思惟。为欲界系为色无色。为三界系为无漏摄。为在何地分位。如何此如理言。为显何义如何生起。何故名世复以何缘名为第一。何故所缘以行声说。于能缘上说作意声。以思惟名自作意故。如是等类皆可推征。故圣教中必应有处。具释诸法自性名等。以薄伽梵为欲摄益所化有情。观处观时观根性等。种种差别随应为说尔所法门。非一经中见有具说。故离欲说义难显了故不应说。以契经中说四沙门果渐次而得故。知诸异生无实断惑。如是已说依世俗道。断修所断得二果时。所得择灭名沙门果。然沙门果酬沙门性。此沙门性如前已说。即此复有差别名耶。亦有云何。颂曰

  所说沙门性　　亦名婆罗门
  亦名为梵轮　　真梵所转故
  于中唯见道　　说名为法轮
  由速等似轮　　或具辐等故

论曰。依世俗理则诸沙门异婆罗门。如契经说。应施沙门婆罗门等。依胜义理则诸沙门即婆罗门。如契经说。此初沙门乃至第四。在正法外无真沙门及婆罗门。乃至广说。以能遣除恶不善法。与勤止息相极相似。故沙门体即婆罗门。如说能遣除恶不善法。广说乃至。故名婆罗门。即婆罗门性亦名为梵轮。是真梵王力所转故。佛与无上梵德相应。是故世尊独应名梵。由契经说佛亦名梵。亦名寂静。亦名清凉。寂默冲虚萧然名梵。佛具此德故立梵名。既自觉悟为令他觉。转此授彼故名梵轮。即梵轮中唯依见道。世尊有处说名法轮。以阿若多憍陈那等五苾刍众。见道生时地空天神即传宣告。世尊已转正法轮故。如何见道说名为轮。以速行等似世轮故。如圣王轮旋环不息。速行舍取能伏未伏。镇压已伏上下回转。见道亦尔故名法轮。谓圣王轮旋环不息。见道亦尔无中歇故。如圣王轮行用速疾。见道亦尔各一念故。如圣王轮取前舍后。见道亦尔舍苦等境取集等故。此则显示见四圣谛。必不俱时如圣王轮。降伏未伏镇压已伏。见道亦尔能见未见能断未断。已见断者无迷退故。如圣王轮上下回转。见道亦尔观上苦等已观下苦等故。由此见道独名法轮。尊者妙音作如是说。如世间轮有辐毂辋。八支圣道似彼名轮。谓正见正思惟正勤正念。似世轮辐。正语正业正命似毂。正定似辋故名法轮。毗婆沙师本意总说。一切圣道皆名法轮。以说三转三道摄故。于他相续见道生时。已至转初故名已转。然唯见道是法轮初故说法轮。唯是见道诸天神类。即就最初言转法轮不依二道。然诸师多说见道名法轮。以地空天神唯依此说故。曾无说三道皆名法轮故。唯见道具前所说轮义故。虽诸见道皆名法轮。而憍陈那身中先转故。经说彼见道生时名转法轮非余不转。憍陈那等见道生时。说名世尊转法轮者。意显彼等得转法轮。本由世尊故推在佛。令所化者生尊重故。如是则说如来法轮。转至他身故名为转。若异此者天神应说。菩提树下佛转法轮。不应唱言世尊今在。婆罗痆斯国转无上法轮。故转授他此中名转。有说此教名为法轮。转至他身令解义故。此但方便非真法轮。如余杂染无胜能故。此中思择四沙门果。何沙门果依何界得。颂曰

  三依欲后三　　由上无见道
  无间无缘下　　无厌及经故

论曰。前三果但依欲界身。得阿罗汉果依三界身。前之二果未离欲故非依上得。理且可然。第三云何非依上得。已离欲者亦可得故。由理教故。且理云何。依上界身无见道故。非离见道已离欲者。可有超证不还果义。何缘上界身必不起见道。且依无色无容听闻无我教故。离闻此教必定无容入见道故。又彼界生不缘下故。见道先缘欲界苦故。由此无色非见道依。依色界身无胜厌故。非离胜厌能入见道。谓欲界中有诸苦受。为生少乐多藉劬劳。人天中生寿量短促。乏财多病亲友乖离。违境既多厌心增胜。若生色界与此相违。谓彼异生耽胜定乐。长寿无病无贫无离。违境既无厌心微劣。非厌微劣能入见道。能引见道胜厌无故。依色界身不起见道。不应言彼都无有厌。以生彼者现有厌故。如契经说。勿怖大仙彼焰必无来近此理。烧梵宫已于彼当灭。此中怖声唯目厌体。又于余处有伽他言

  闻有长寿天　　具妙色令誉
  而心怀怖厌　　如鹿对师子

此怖厌言显怖即厌。即于彼处显此义言。为厌所缠心处于厌。如契经说。为着所缠心处于着。此亦如是先未了相。为厌所缠彼心为厌所随缚故。后已了相虽处厌中。而不为厌之所随缚。是谓此中怖厌别义。实怖与厌相差别者。谓瞩彼相恐为衰损。心生惊怯故名为怖。若观彼相心不欣欲。情乐弃舍故名为厌。欲界具二上界唯一。又此二体差别云何。不审察为先心惊掉名怖。若审察为先心不乐名厌。或引愚痴心怯。名怖。若引弃舍心背名厌。有余师说。恐为衰损心欲捐舍是名为怖。欲捐舍故于彼境中。心不生欣是名为厌。今观此经所说怖者。是恐自害被损坏义。世间亦见有如是言。但掷器来勿怖其破。由此理证上界无见道。教复云何。由契经说故。经言有五补特伽罗。此处通达彼处究竟。所谓中般乃至上流。此通达言唯目见道。是证圆寂初方便故。经既不言彼处通达。故知见道上界定无。已说学位预流果等有多差别。为阿罗汉亦有多种差别相耶。亦有云何。颂曰

  阿罗汉有六　　谓退至不动
  前五信解生　　总名时解脱
  后不时解脱　　此从见至生

论曰。于契经中说阿罗汉。由种性异故有六种。一者退法。二者思法。三者护法。四安住法。五堪达法。六不动法。然余经说无学有九。谓初退法后俱解脱。彼不退法此不动摄。彼二解脱通此六摄。故阿毗达磨唯说有六种。言退法者。谓彼获得如是类根。安住此根与退缘会便退所得。无退缘者便般涅槃。或有精勤进得胜性。说彼修集此种性时。谓有一类由他缘力。方于佛法至诚归趣。彼极少时取少分相。便乘速进奢摩他力。所持慧光入无学地。于无学地趣入相中。彼先不能审谛取故。无有恒时尊重行故。信乐寂止背胜观故。与顺退法相随顺故。数失正念远于道器。所获胜德容数退失。如于圣教习诵究竟。由遇散乱病逸等缘。于习诵文不能记忆名为退失先所习诵。由此譬喻应知退法。言思法者。谓有获得如是类根。安住此根能于诸欲极多厌恶。由斯厌恶起自害思。或此类根虽性昧钝。而多缘力之所集成。于加行中念力坚固。多住厌观少有欣情。恒作是思勿遇病等。便于正念有所忘失。于加行中致有慢缓。由加行慢缓令我有退失。由斯筹虑起自害思。或由艰辛方逮胜位。观诸财宝追求贮积。守护受用咽弃等时。无不引生种种苦恼。彼审观已由此苦缘。身命虽存都无胜用。又观身器是粪秽车。避危就安摄养无益。犹如牢狱丘冢秽尸。爱乐此身岂名智者。由斯观解起自害思。复有余师作如是说。彼类法尔禀斯种性。不顾身命耽求解脱。执刀自拟用以励心。如说以刀扣于自颈。由斯励己心得解脱。此类名为思法种性。言护法者。谓有一类。恒于时爱心解脱中。系念现前专精防护。彼作是念。我且未能修习练根。达安住法但于时爱心解脱中。能不放逸精勤防护。如是种类名为护法。安住法者。谓离胜退缘虽不自防。而亦能不退。离胜加行亦不练根。多住处中故名安住。有余师说。彼所获德非劣非胜故名安住。堪达法者。谓性堪能好修练根速达不动。有余师说。彼性能得一切功德故名堪达。然非一切功德之器。不动法者。谓有一类根性殊胜于行自在。于断烦恼随烦恼中得方便智。不为一切随顺退法之所倾动具无生智。性不怯弱获得第一安隐住处。内分力强胜观行摄。于一切义殷重委解。已能善取漏尽地相。不护所证故名不动。有余复释此六异相。谓六种性先学位中。初二阙恒时及尊重加行。然至无学思法少勤。护法唯有恒时加行。安住唯有尊重加行。堪达具二而是钝根。不动具二而是利根。有作是言。退法必退乃至堪达必达不动。若不尔者立名唐捐。彼执欲界具足有六。色无色界中唯安住不动。彼无退失自害自防。及修练根。故唯有二理实无定。然退应果唯从先来退种性退。乃至达不动唯堪达所能。立退等名约容有说。故六阿罗汉通三界皆有。六中前五从信解生。即此名为时爱心解脱。以一切时爱心解脱。故亦说名为时解脱者。谓待时处补特伽罗。资具等合时方得解脱故。以所依止功能薄劣。要待胜时方解脱故。或复一切胜定现前。要待胜时是此时义。离系缚故名为解脱。此即待时及解脱义。略初言故如言酥瓶。不动法性说名为后。即此名为不动心解脱。彼心解脱非惑所动故。亦说名为不时解脱。以不待时得解脱故。或复胜定随处随时。随所遇缘随欲便起。离系缚故名为解脱。即不待时及解脱义。有余释此二差别言。以于暂时得解脱故名时解脱。后容退故以能毕竟得解脱。故名不时解脱。后无容退故此从学位见至性生。如是所明六阿罗汉所有种性。为是先有为后方得。不定云何。颂曰

  有是先种性　　有后练根得

论曰。退法种性。必是先有思法等五。亦有后得。谓有先来是思法性乃至不动。有先退法练根成思。至不动等多种差别。如理应思

说一切有部顺正理论卷第六十七阿毗达磨顺正理论卷第六十八

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩贤圣品第六之十二

如是六种阿罗汉中。唯前五种容有退义。谁从何退为性为果。颂曰

  四从种性退　　五从果非先

论曰。不动种性必无退理。故唯前五容有退义。于中后四有退种性。退法一种无退性理。由此种性最居下故。五种皆有从果退理。虽俱有退然并非先。谓无学位中。从退法种性修练根行转成思等。此四皆有退性果义。退法种性虽必先得。而是退法故容退果。诸学位中从退法性。修练根行转成思等。及得学果皆容退失。诸无学者先学位中。所住种性彼从此性必无退理。学无学道所成坚故。诸有学者先凡位中。所住种性彼从此性亦无退理。世出世道所成坚故。二先位中住思等性必无有退。此所得果此性二道所成坚故。彼从思等修练根行。转得护等唯可退性。转所得性进得学果亦有退义。由此种性非二道成不坚牢故。若就四果辩退果义。虽五种性皆可退果。而先所得必无有退。谓四果中先所得者。即预流等前三随一。从此先果必无退义。是断见惑所得果故。圣断见惑必无退故。何缘见惑圣断无退。以彼不缘所执事故谓见所断烦恼现行。无不皆由我见势力。以彼烦恼起我见为根故。由此见惑不缘所执。以所执事都无体故。然有所缘谛为境故。彼所执事都无种子。于所缘境极乖违故。圣者相续真非我解恒所随故。虽暂失念而必无容重执是我。以见所断依我事生。故圣断已必无退义。修所断惑虽颠倒转。而非无种有所执事。谓于色等染着憎背。高举不了行相转时。于色等中非无少分。净妙怨害高下甚深。故非境中极乖违转。由此圣者有时失念。执净妙等相退起修断惑。又见断惑迷于谛理。执我等相谛理中无。理定可依圣见无退。修所断惑迷粗事生。事变难依有失念退。又见断惑要审虑生。圣审虑时必不起惑。修所断惑非审虑生。圣失念时容有退义。由此无退先所得果。此中无学退法有三。一增进根。二退住学。三住自位而般涅槃。思法有四三如前说。更加一种退住退性。余三如次有五六七。应知后后一一增故。何缘练根成思等者。退彼应果住学位时。住先退性非所退者。得思等道今已舍故。岂不学位转成思等。得应果时。虽舍所得学思等道。而住应果思等种性此亦应然。此例不齐。以彼学道摄。彼无学道为等流果故。非无学位所舍思等。与此学道为同类因。可能引学思等种性。故应退住先所舍者。有余于此别立证因。谓若退住所退种性。得胜种性故应是进非退此非证因。若无二义可有是进非退过故。然得胜性虽可名进。而起惑故亦名为退。由此彼难于理无失。又彼退起障涅槃法。圣欣涅槃过于圣道。设得胜性退涅槃故。但应名退不应名进。然经主意作如是言。阿罗汉果亦无有退。一来不还世俗道得。容有退义引经证言。圣慧断惑名为实断。初后二果但由圣慧。断惑而证故无退理。又契经言。我说有学应不放逸非阿罗汉。今详经主非善立宗应审推征。以世俗道得中二果。为实已拔障彼惑种。为不尔耶。若实已拔而许有退。即阿罗汉退义应成。许治道力已拔惑种而更生故。若不许彼烦恼更生如何名退。若谓所退唯道非断理亦不然。如后当显断。如治道说可退故。亦不可说欲界惑生。可以上界烦恼为种勿如自界。欲界亦以彼为因故界应成一。若实未拔欲界惑种。得不还果应非不还。如契经言。我不见有一结未断。非由彼结之所系缚还来此间。若谓有经。说有欲结而非彼系还来此间。如安隐经此亦非理。于辩随眠品已破彼论故。又无不拔欲界惑种而生上界。辩世俗道能断惑中已成立故。又契经说。若实能断五下分结成不还果。如何可言于欲界结。有未能拔得不还果。故定应许若得彼果。必已实断障彼惑得。若不尔者断性不成。然我于前已曾具显。诸沙门果亦断为性。然引经言。圣慧断惑名实断者。彼未达义今详经义。由现见有以世俗道断八地惑。后还退失结恶趣生。如嗢达洛迦曷逻摩子等。唯无漏慧能离有顶染。离已无有复结后有生。依此故言圣慧断惑名为实断。非此为遮世俗道力能断惑义。故诸阿罗汉虽有刹那生。而皆法然起如是智。我生已尽不受后有。诸佛出世正所作者。为令有情后生不续。世尊为欲显自本意故。不称赞世道断惑。容于后时结后有故。唯圣慧断能绝后生。世道无能令后生绝。故佛偏赞圣慧断惑。若为暂断惑诸佛出世。则诸佛出世唐捐其功。外道亦能成此事故。虽有圣道唯暂断惑。亦有世道能永息生。然息一切生断一切烦恼。唯圣慧力故佛偏赞。虽有圣慧断烦恼已后还暂起。而非诸佛出世唐捐息多生故。然世尊言。我说有学应不放逸非无学者。此有别意谓见有学退向道时。由先已断烦恼力故结后有生。如邬陀夷契经所说。非不已断色界诸惑。可有证得灭尽定理。经说超越有顶地时。名超灭定所超法故。如说超过一切非想非非想处。乃至广说。非彼朋类许有圣者。以世俗道离烦恼义。必无不退灭尽定者。及不现起色界诸惑。先得灭定生色界理。要染污心方结后有。无异界识结异界生。经既说彼后生色界。故知有学有退向道。由先已断烦恼势力。结后有生其理决定。故薄伽梵劝诸有学。令不放逸非无学者。诸无学者设退起惑。无容由彼结后有生。故佛无劳劝不放逸。以诸无学于绝后有所作已办。故佛说彼已不放逸无劳更劝。或阿罗汉约诸漏尽。亦不应劝彼令修不放逸。故彼经说诸有学者。希求无上安隐涅槃。未能得心无放逸住。故我说彼应不放逸。然彼因此修集诸根。广说乃至。便得漏尽。诸无学者漏已尽故。无劳重劝令不放逸。设彼无学退起烦恼。劝令重断修不放逸。还是劝有学非劝无学者。故劝学者令不放逸。不劝无学此说善通。又契经中亦说无学应不放逸。如契经说。胜己应护言无别故。此即异门劝不放逸。由彼文说与魔战故。若谓此中但说有学。不尔亦说无学位故。谓此文中初说远位。次说学位。后说无学。唯诸无学遍胜所胜。是故世尊唯劝守护。又此中说无执着故。唯诸烦恼立执著名。烦恼皆有执着用故。彼无烦恼名无执着。此是无学理定应然。余经说应果亦应摄护故。如余经说。诸圣弟子。心从贪等离染解脱。彼解脱蕴未满能满。已满为摄护修欲勤精进。非彼无退可须摄护。若谓为彼自在现前应修加行。而摄护者令彼自在复何所用。谓彼设于无学解脱。不自在转复有何过。若谓为得现法乐住。但于增上心所现前。应求自在宁于解脱。既于解脱为得自在加行摄护。故知容有烦恼现前退解脱义。谓阿罗汉虽顿得解脱。而为自在数修令现前此意为令解脱无退故。应经说胜己应护。无执着言显无学位。即依此义余处复言。心未脱者当令解脱。若已解脱当善守护。若无退义已证解脱。何劳劝彼当善守护。若彼复谓诸无学者。已无惑种不应起惑。学有惑种起惑可然。不尔无学有惑种故。过去有性前已广辩。诸后果起由过去因。拘橼等喻其义已显。由与烦恼相违法生。断诸系得得离系得。依此位立烦恼断名。非为欲令惑种无体。修习治道方名断惑。如灯生闇灭灯灭闇还生。断惑及退应知亦尔。然无诸惑断皆有退起过。如执无法可生论者。无一切无皆可生过。若谓缘合果皆可生。不尔果生待众缘故。谓非一切有烦恼种。则诸烦恼一切可生。未断惑时现见亦有。由余缘阙惑不生故。犹如外法虽现有种。余缘阙故芽不得生。又欲难令见所断退此如前释。前释者何谓彼不缘所执事故。见所断惑无所味转。要分别力方能引生。修所断惑有所味转。唯境界力即能引起。或彼应许诸阿罗汉。设无过去烦恼种子。亦有退起诸烦恼义。如有善根已无余断。善根无种后可还生。理实善根有无余断。如说如是补特伽罗。善法隐没恶法出现。有随俱行善根未断。彼于后时一切悉断。此义如前已具决择。然不可以无种惑生。令诸应果皆退起惑。此于前来已具释故。若无尊重恒时加行。及坚固道方退起故。又如汝宗异生相续。虽无无漏种而苦法忍生。如是亦应许阿罗汉。虽无惑种而有惑生。此中有言非苦法忍。虽无种子而可得生。此于余处已具征遣。为破一类复应思择。异生相续无漏法种。有漏无漏二俱有失。且非异生心及心所。与无漏法为种子性。未有无漏所引功能。如烦恼等种子性故。谓如彼所计于相续中。惑所引功能方名惑种。此与烦恼为能生因。若相续中善等所引。名善等种为善等因。非诸异生心等相续。已有无漏所引功能。故不应成无漏法种。若此无漏所引功能。而得名为彼法种子。如是便有太过之失。一切应成一切种故。如是无学法应成烦恼种。及诸烦恼法应成无学种便无建立染净定相。则彼自宗计如外熏习有。善等熏习唐捐其功。由许异生心心所法。无无漏法所引功能。而得名为无漏种故。又异生类心心所中。无漏法种若是有漏。性类别故应非彼种。如何能作无漏生因。非苦种中可生甘果。诸能为种可名生因。故从有漏因唯应生有漏。宁执有漏为无漏种。无漏法种若是无漏。应异生类相续中无。或应异生毕竟非有。皆成有为无漏法故。然彼论说此心心所。虽为无漏种而体非无漏。犹如木等非火等性。谓如世间木为火种地为金种。而不可说木是火性地是金性。如是异生心及心所。虽是无漏种而体非无漏。彼说非理。以木等中先有火等自类种故。云何知然。由教及理。谓契经说。此木聚中有种种界。乃至广说。又见从木可有火生。诸求火者便摄取木。以木聚中必有火界。是故说木名为火种。以于木中火界增故。非先无火得火种名。地中出金理亦应尔。谓地差别于中出金。若地无金可成金种。则求金者应随取地。不应求取地之差别。故知地中别有金种。非无金地得金种名。是故彼言犹如木等非火等性。如是异生心及心所。虽为无漏种而体非无漏。理定不然。又彼部论言。钻前无热故谓所钻木。未被钻时热犹未有。故知木内未被钻位无火极微。于地等中金等亦尔。如是推度教理相违。圣说大种不相离故。理亦应尔。诸色聚中见诸大种所作业故。思大种处已广成立。然未钻时不觉热者。彼聚非热大种增故。又彼所言。许无漏法用有漏法为能生因。于教及理俱无违害。此亦不然违教理故。谓经说同类唯同类为因。无明为因故生染着。明为因故离染着生。从此善根余善根起。若于彼彼多随寻伺。便于彼彼心多趣入。有如是等无量契经。有漏无漏其类既别。如何可说前为后因。又有漏心是惑依止。宁与自性净法为因。违教且然。言违理者。若有漏法为无漏因。无漏为因应生有漏。设许何过。如从异生心心所法。引诸圣者心心所生。亦应从圣心心所法。引异生者心心所生无异因故。若谓异生善心心所。与无漏法同是善故。可与无漏为能生因。此过同前同前何过。谓同类故应互为因。如是则应圣心心所引异生类心心所生。便有圣凡更相作失。所竞退义由此应成。以净染心同有漏故。则阿罗汉有漏净心。应得名为诸漏种子。诸漏亦是有漏性故。如是便害彼论所言。无学身中无惑种故。所断诸惑终无退理。若阿罗汉犹有惑种。是则不应名漏尽者。又彼所言如世第一。以无漏法为士用果。既无毕竟无异生失。如是无漏法以有漏为因。亦无毕竟无异生失。此亦非理。等无间缘类异类同皆无失故。如四缘处已广分别。然诸因缘与等无间亲疏异故为例不成。若不许然缘数应减。又例便有太过之失。谓若许作等无间缘。则此亦应有因缘义。如从色界染心命终生欲界中。受生心者。既许色于欲为等无间缘。亦应许有为因缘义。若许欲界惑色界惑为因。诸圣离欲贪应有欲贪种。则诸圣道断惑应退。便害彼说惑种无故。无退无漏道果解脱。又不应许色界惑中有欲惑种。能为欲惑等无间缘非色界惑。所以然者。以诸异生能实断惑前已成故。惑种与彼无别体故。若谓此如外法熏习。不尔。此彼不相似故。谓彼外法能熏所熏。二法俱时相续而住。有别味等住所熏中。经于多时相续随转。内法不尔宁有熏习。故彼所立世第一喻。翻成违害自所立宗。或如从无色还生色界者。虽无色种而有色生。已成异生实断惑故。如是无学设无惑种。亦退起惑于理何违。然彼所言诸从无色生色界者。若无色种彼定不应还生于色。以无色圣者不还生色故。此亦非理不相似故。谓彼异生于有顶摄。见断惑断未能作证。非在彼界有于见道。所断惑断能作证义。必由先证见断惑断。后方能证修断惑断。由此异生生无色界。必无能越有顶地者。引彼异熟业力尽时。色种虽无必还生色故。异生类生无色时。于色未能证不生法。以彼于后必生色故。生无色圣必已先断。有顶惑中见断一分。于离色地修所断时。已离彼地定感色业。即于无色决定能证。有顶地中修断惑断。圣从此界生彼界时。于色已能证不生法。以色于后必不生故。由此圣者后色不生。非为身中色种非有。故彼所说无色圣者。色不生故色种若无应不生色。定不应理。由此彼言异生与圣。断若无异所得应同。理亦不然断有异故。谓先已说异生未能断有顶地见所断惑。故从无色定还生下。圣此相违断宁无异。又阿罗汉若无惑种。故无退者学有惑种。则无漏道断果退成。以学有成自界地摄。一分修断烦恼种故。若不许然则不应说。无学无惑种。故定无有退。傍论已了。经主复言。又增一经作如是说。一法应起。谓时爱心解脱一法应证。谓不动心解脱若应果性。名为时爱心解脱者。何故于此增一经中再说应果。又曾无处说阿罗汉果。名为应起但说名应证。理亦不然由此成故。谓既说有二种解脱。则已显成应果有退。经言。不动心解脱身作证。我决定说无因缘从此退。义准说余容有退理。经主又说。若谓有退。由经说有时爱解脱我亦许然。但应观察彼之所退。时爱解脱为应果性为静虑等。然彼根本静虑等持。要待时现前故名时解脱。彼为获得现法乐住。数希现前故名为爱。今于彼意未审了知。言静虑等持为有漏无漏。若是无漏无学身中。无漏有为皆应果性。则为已许时爱解脱。是应果性其理极成。便违彼宗应果无退。若是有漏非为极成。若谓过同此无同理。此与不动相似说故。谓契经言不动解脱。许是无学身中无漏其理极成。契经既说时爱解脱。亦应极成许是无学身中无漏。又如不时成无漏故。谓契经说有阿罗汉。不时解脱彼此极成。不时解脱是应果性。既有经说有阿罗汉。名时解脱亦应极成。此时解脱是应果性。又如不动说作证故。谓如于不动说身作证。言不动解脱是应果性。经亦于时爱说身作证言。应时爱解脱亦是应果性。如契经说。若由如是诸行相状。能于时爱心解脱中。身已作证后于如是。诸行相状不能如理数数思惟。便退所证。乃至广说。若谓由此说彼应是有漏。非由无漏诸行相状得阿罗汉。此于后时有数思惟有不思惟。不退及退可应正理。此亦不然依类说故。谓经不说。此即是彼但约种类。言于后时有数思惟不思惟等。此中意说学无学位。同以非常等行。观色取蕴等境。如言应服先所服汤或过同故。谓以有漏诸行相状。证得时爱心解脱者。亦无于后以前行等数数思惟。非前所修现法乐住。加行即是后时现法乐住自体故。此所说非证有漏。由此不应作如是诘。但应观察彼所退等。又彼所言时爱解脱。即是根本静虑等持。其理不成。以契经说等持解脱性各别故。如契经言。为先等持后解脱。为先解脱后等持。乃至广说。虽复有说现法乐住。即是时爱心解脱体。然不应理曾无说故。谓曾无经作如是说。时爱心解脱即现法乐住。但是童竖居自室言。若谓所言虽无经证。然有决定正理可依。谓此如彼说有退故。如说有退现法乐住。亦说有退时爱解脱。故知此彼名异义同。如是所说理趣非善。立所许等多过起故。谓我宗许于现法乐。若不动法唯有受用退。若时解脱亦有已得退。非不动法亦退自在。但余事务无暇现前。虽暂不现前而不失自在。若异此者现法乐住。通以有漏无漏为体。并由事务不现在前。是则皆应退失自在。后于自在既求证得。应有为得未得退义。然佛遮此为得未得。说退不退法二阿罗汉故。又圣教中唯以解脱为珍贵故。此既无退应唯说有一阿罗汉。然经说余余处余类退现法乐。及有说余余处余类退时解脱。故知时解脱非现法乐住。由斯理趣应斥彼说。但是童竖居自室言。又彼应言退静虑者。为于诸欲有离无离。若言有离则于离欲无所退失。而言退失离生喜乐岂不相违。又乔底迦如何知已。六返退失深自厌患。便执利刀自刎而死。若言无离应起烦恼。不起烦恼宁退静虑。若谓失治不失断果。如何当释邬陀夷经。又道能持所得断果。要证得道方证断故离胜进位舍道非断。谁当信此违正理言。又静虑中定自在性。离诸静虑无别可得。故烦恼起方有退义。或自在性有何差别。勿许别有定自在性。或自在性名何所目。若有别法名自在性有前说过。前过者何。谓不现前皆退自在。后求证得便违契经。若自在性都无别法。是则应无自在退理。便应无有退法种性。又如钝根诸阿罗汉。世俗根本静虑等持。要待时现前故名时解脱。何缘无漏独不许然。无漏转应待时方起。以彼最是未曾得故。即由有退阿罗汉果。故增一经说二解脱。然彼所责。何故于此增一经中再说应果。今详再说正为显示。有退不退二种应果。然此中说时爱应起。不动应证别有所因。谓为令知时爱解脱。恒时尊重加行所持。方免退失恐退失故。应数现前故说应起。不动解脱必无退理。但证得时名办所作。故但于彼说应证言。又时解脱亦说应证。经说于中身作证故。又经多说惑灭为应果。诸经皆言灭应作证故。然无处说阿罗汉果。名应起者以不遍故。又彼自问若时解脱非应果性。何故契经言时解脱应果。彼即自答。谓有应果根性钝故。要待时故定方现前。若与彼相违名不时解脱。彼如是答其义不成。有学亦应如是说故。谓学亦有根钝利别。待不待时定现前故。应得时解脱不时解脱名。然无此名故是僻执。若谓有学未解脱故。不立此名理则已成。时爱解脱是应果性。许未解脱者无解脱名故。由此彼释乔底迦经言。乔底迦昔在学位。于时解脱极啖味故。又钝根故数数退失。深自厌责执刀自害。由于身命无所恋惜。临命终时得阿罗汉便般涅槃。故乔底迦亦非退失阿罗汉果。此与圣教都不相符。若在学位有时解脱。为所味者理则应成。在有学位名时解脱。然无圣教说如是言。若有学时未解脱故。不可说为时解脱者。既未解脱不应言彼学位。已得时解脱性为所啖味。故彼释此乔底迦经亦依僻执。然彼上座率自执言。时爱解脱以世俗道。暂伏烦恼令心离系。暂时脱故名时解脱。此是现法乐住性故。有烦恼故建立爱名。此即是贪所染事义。不动解脱以无漏道。永断烦恼令心离系。相续转故随眠永尽。上座依止下劣意乐。极恶处置阿罗汉果。谓彼应果身相续中。幸有所余不共功德。不建立为现法乐住。而立与学及诸异生。共有暂时离诸系缚。贪所缘果法为现法乐住谁复贵重。应果身中昔暂伏除烦恼方便。为现法乐修令现前。由此善成未解脱者。决定未得时解脱性。又唯应果说有退故。谓契经说五因五缘。令时解脱阿罗汉果退失。时爱心解脱性。曾无圣教说。有学者名时解脱。及说彼遇退失因缘退时解脱。故时解脱学者未有。或何不计彼有不动解脱。又彼所执极为粗浅。谓圣教中解脱为贵。诸有学者已遍见真善。别圣教中不共胜功德。宁为世俗粗动善根。于能尽苦身起自杀加行。故此所执极不令善。有言唯厌烦恼现行。便于自身起杀加行。未断有本执刀自杀。此释经义极无深理。谓诸圣者极怖后有。烦恼能为后有近因。圣既见彼猛利过失。于能弃惑违后有道。若一暂退不能现行。尚应粉身况频退者。彼自知应果由此必还证。深见烦恼现行过失。欣先所退阿罗汉果。故自杀身取阿罗汉。诸有学者曾未证得应果妙乐。尚许厌怖烦恼现行。执刀自杀况阿罗汉过彼千倍。然唯退失阿罗汉果。有怖烦恼而自害义。自知死后惑不生故。本有学者自知命终。烦恼必行更招后有。增生死苦何容自杀。若如彼释则乔底迦。应甚庸愚无端自杀。然魔于彼所杀身边。求彼识者疑彼退已。住学位中而命终故。以魔方便。颂讥佛言

  云何人中尊　　弟子越圣教
  住余有学位　　不得心命终

非佛世尊诸圣弟子。皆至无学方致命终。如何天魔独以彼圣学位舍命讥刺世尊。以乔底迦先证无学。后退住学而致命终。故彼天魔举以讥佛理必应尔。由彼魔言。世尊弟子越圣教故。何谓圣教谓绝后有。此颂意言。云何佛子违越所得。绝后有界应般涅槃。而还退堕续后有位而致命终。故知乔底迦非唯退静虑。又彼所引对法藏言。欲贪随眠由三处起。一欲贪随眠未断遍知故。二顺彼缠法正现在前故。三于彼正起非理作意故。此于退义亦不相违。约烦恼无间生烦恼说故。非唯从烦恼无间烦恼生。如是言义如先已说。或起烦恼总有二种。一从非理作意。二从如理作意。此文且说从非理者故无有过。不应惑起皆以非理作意为先。勿有无初失善无容生过。又烦恼起必有俱生非理作意。烦恼起位即可说为随眠未断。此文不说诸烦恼起。必以贪等未断为先。是故此文非证彼义。又此所引对无记心现行。退宗不成违难。对染心品现行退宗。此约具因故亦无失。谓烦恼起若因缘具则有此三。然于三中随有所阙亦有起义。如说成就十种法者生捺落迦。非于十中。随成就一不得生彼。又如经说。三处现前能生多福。非唯有信无多福生。其例非一此中总集。烦恼生缘。言有此三非一切尔。此文意显烦恼生时。或因力偏增。或境或加行。说由三处而起欲贪。若执要具三则言应不遍。谓缘自界可说具三。非缘余法有具三理。故对法文不违退义。通彼教已彼立理言。若阿罗汉有令烦恼毕竟不起。治道已生是则不应退起烦恼。若阿罗汉此道未生。未能永拔烦恼种故应非漏尽。若非漏尽宁可说彼名阿罗汉。此非过失是所许故。谓我宗许先退法性。智力劣故虽已断惑。而于诸惑未证不生。若尔何缘说名为断。此先已释。谓与烦恼相违法生。断诸系得得离系得说名为断。故言断者由治道生。拔相续中如种惑得。非要令惑毕竟不生。智力劣者复可生故。然无应果非漏尽失。已得诸漏离系得故。既许诸惑断犹有体。忘失治道退缘现前。烦恼复生违何正理。故彼经主所立理言。于无退中无能证用

说一切有部顺正理论卷第六十八阿毗达磨顺正理论卷第六十九

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩贤圣品第六之十三

如是已破经主所宗。有余师言。如见断惑所有解脱必无退理。是无漏道所得果故。有顶地系修所断惑。所有解脱亦无退理。彼说非理。道力异故前已说故。余无漏道所得解脱见有退故。谓见修道力用各异。见道位中以一品道断多品惑。修道位中多品道断多品惑故。若谓此异由烦恼力。谓见断惑依无事转。修道所断依有事故。此亦不然。以世俗道断此烦恼亦多品故。或复但应以见断惑。依无事故断无退理。非无漏道所得果故。若谓异生断无事惑亦有退故。证知诸圣见断解脱无有退者。是无漏道所得果故。则不应言以无事故。虽多品惑一品道断。故知由道力异义成。由此见修不应为例。又前已说。前说者何。谓见断生由审察力。修所断惑由境力起。非诸圣者于所缘中。无片依希横兴计度。故见所断解脱无退。诸异生类犹未见真。故于所缘容横计度。虽有已断下八地中。见所断惑亦容有退。圣已见真于见所断必无有退。然失念故于外境中。取妙等相便有染着。憎背高举不了行转。由此道理修断解脱圣亦有退。故彼所言诸异生者。断无事惑亦有退故。证知诸圣见断解脱无有退者。是无漏道所得果故。理定不然。又余无漏果亦见有退故。谓彼所宗必无。圣者烦恼断果世道所得。以彼论言圣者惑断。是世道果理不成故。邬陀夷经说。有圣者先得有顶定。后生色界中离退上断无生下义。彼宗不许圣以世道伏惑。不许圣起静等行故。圣无观有为静等故。非彼宗离见非常等。所有圣道能实断惑。异生断惑至圣位中。必无退理双道镇故。由此但依无漏道断。经说先得灭受想定。后还退故生色界中是故极成。余无漏道所得断果亦有退义。故彼所言如见断惑解脱无退。有顶修断解脱亦尔。是无漏道所得果故。理定不然。上座此中亦作是说。定无阿罗汉退阿罗汉果。所以者何。由理教故。云何为理。谓应果必无非理作意故。阿罗汉后心应生烦恼故。谓若应果安和位中。住等运相许退起惑。如何死时息不调顺。诸根扰乱烦恼不生。若烦恼生应续后有。云何为教。谓契经说。尊者戍拏即于佛前白言大德。若有苾刍。诸漏已尽成阿罗汉。广说乃至。能不忘失心解脱性。设有殊妙眼所识色来现在前。彼于所证心解脱中无劳防护。斗战喻经作如是说。诸圣弟子住无怖心。彼于尔时魔不能扰。蓝薄迦经亦作是说。若漏已尽成阿罗汉。行住坐卧无不安隐。所以者何。魔不坏故。毒箭喻经亦作是说。佛告善宿。乐涅槃者所有非想非非想结。尔时皆得永断遍知。如断树根截多罗顶。无遗余故后更不生。诸辩退经咸作是说。若与弟子共相杂住。我说由斯便从先来所证。四种增上心所。现法乐住随一有退。若由远离独处闲居。勇猛精勤无放逸住所得不动。心解脱身作证。我决定说无因缘从此退。又契经说。若有苾刍诸漏已尽成阿罗汉。我终不说彼阿罗汉应不放逸。所以者何。由彼具寿已不放逸。不复能为放逸事故。叙彼上座所执如是。理且非理。非理作意前已说故。前说者何。谓前已言。不应惑起皆以非理作意为先。论文且说从染生者。若诸染起必染为先。则余性心应无行义。又彼所立因义不成。与所立宗品类同故。谓染作意得非理名。彼所立因显阿罗汉。无起染故不生烦恼。以无烦恼名阿罗汉。今欲推究阿罗汉心烦恼既无。有退生不。彼立宗曰必不退生。复立因言无起染故。既尔岂不是品类同。此不成因智者所判。又彼所说无非理言。为无已生。为无正起。如是二种俱不极成。或彼意言无惑种故。诸阿罗汉不退起惑前已广答。种有无理故。一切种彼因有失。由此亦已遣无颠倒故。因颠倒与惑无别性故。后心起惑亦不成因。所以者何。以阿罗汉后心不是等无间缘。如何有能引余心义。趣无余依般涅槃故。背诸生死流转事故。一向处中任运转故。若于此位起烦恼者。应障诸蕴毕竟断灭。故阿罗汉死有位中。决定无能退起烦恼。又住此位极顺厌心。设于先时有烦恼者。得至此位尚断无余。如契经言。彼于现法多辩圣旨。或临终时况彼先时已无烦恼。今有趣入无余涅槃。作意现前宁方起惑。故无后心应起惑过。又言应果安和位中。住等运相许退起惑。亦不应理非所许故。谓我唯许安和位中。有顺惑心方能起惑。若正坚信等运相心。能障惑生如何起惑。故彼所立遮有退理。不能证成。应果无退教亦非证。且戍拏经。于有退宗都无违损。依遮受欲说此经故。谓彼尊者独处空闲。欻尔思惟我家巨富眷属广大应速归家。坐受欲乐行施修福。佛知其念遣使命来。为现神通记说教诫。令伏令悟得成应果。成应果已作是思惟。我今应时来见善逝。此意为显今蒙命来。胜于先时无邪思惟。作是念已复依异门。显记自身与诸应果。有不受欲应果共相。白言大德。若有苾刍。诸漏已尽成阿罗汉。彼于尔时住于六处心得解脱。谓住出离无害远离爱尽取尽。及不忘失心解脱性。设有殊妙眼所识色来现在前。彼于所证心解脱中无劳防护。此意显示一切应果。由对治力之所摄持。无处无容受诸欲境。是故设有妙境现前无劳护心。是此中义或彼尊者。依自说故不应为证。非诸应果皆与戍拏根性等故。或此总依诸应果说。以彼自说差别言故。如彼自言。谓住出离无害远离。乃至广说。此显若能住出离等。无劳防护。余则不然。我宗亦言恒时尊重。修加行者便能不退。如是义意毒箭喻经。世尊于中分明显示。我后至彼当广分别。斗战喻经亦不成证。此依遮止怖后有说。如余处说此亦尔故。谓此经言魔不能扰。非此经意说烦恼魔。但说欲天大自在主。以此经后作如是言。尔时彼魔忽然不现。此中意显若般涅槃魔。则无能求其心识谓佛弟子正舍命时。多有魔来求其生识。勿彼神识越我境界。如于余处亦遮应果怖畏后有。如契经言

  已拔爱根　　无愁何怖

又余经说

  如树根未拔　　苗斫斫还生
  未拔爱随眠　　苦灭灭还起

又契经说

  若已见圣谛　　令诸有路绝
  生死本既灭　　更不招后有

又一切处赞应果言。舍诸重担尽诸有结。所以名为尽。有结者。谓结招有名为有结。诸阿罗汉于有结中。心善解脱故名为尽。是故非彼所引契经。能遮我宗应果退义。由此已释蓝薄迦经。彼皆自知不受后有。虽亦有怖退现法乐。而于威仪无不安隐。故诸应果法有智生。能自了知不受后有。观别意说。毒箭喻经故亦不能遮有退义。若阿罗汉于三界结。一切皆得永断遍知。如断树根截多罗顶。无遗余故后更不生。如何此中偏说非想。故知此说定观别意。今当辩此起说所因。谓此经中

佛告善宿。乐世财者若住现前为说如斯相。应言论彼心便住所说义中。亦能于中造随法行。广说乃至。引喻况己。具寿善宿。白世尊言。此补特伽罗于村邑等处。为欲贪结系缚其心。广说乃至。为说不动相应言论。不乐听受如是广说。乐不动者。于无所有处相应言论。不乐听受。乐无所有处者。于非想非非想处。相应言论不乐听受。乐非想处者。于般涅槃相应言论不乐听受。乐涅槃者。亦于非想非非想处。相应言论不乐听受经中如是次第广说。非我于此作如是言。诸阿罗汉乐闻非想非非想处相应言论。心住其中造随法行。由此于彼随趣乐着。如何引此证阿罗汉。不于非想非非想处。为欲贪结系缚其心。是故世尊为遮应果。贪彼生故说二喻言。我等所宗亦许此理。何容引此遮应果退。此必应遮阿罗汉果。造招非想后有行结。由此中说彼善男子。若得正解心善解脱。于所匪宜色等六处。眼见等已不随系住。广说乃至。于彼境中不由寻思。随观而住不为贪结。随坏其心集感后生恶不善法。乃至不集后生老死。于自如是能如实知。今详此中所说意者。显诸应果能如实知。于后有资粮我终不积集。然可说佛于此经中。依毒箭喻显有退理。谓佛于此说如是言。如有良医善拔毒箭。先观毒箭入之浅深。次设方宜拔之令出。后傅妙药令毒无余。方告彼言咄哉善士。我已为汝拔除毒箭。令汝身内毒势无余。汝宜从今谨慎所忌。食所宜食时净其疮。若食匪宜疮必溃漏。乃至善宿于意云何。彼蒙良医拔箭除毒。若慎所忌唯食所宜。时净其疮岂不定得。无病安乐气力增盛。由如是喻显佛良医。拔所化生后有毒箭。令引彼结亦尽无余。若于匪宜色等六处。眼见等已随系而住。广说乃至。于彼境中由起寻思随观而住。烦恼溃漏因此而生。若不许然心解脱者。有何过起与溃漏同。又此经中佛自合喻言。若一类能正了知。依是病痈毒箭苦本。便住依尽无上无依。心解脱中斯有是处。住已于彼依顺取法。身取心执无有是处。此经于后辩此义言。依即是身苦所依故。顺取即是能益取法。以是诸惑所依执故。此中有言依即顺取。如实义者依顺取异。谓如次第身匪宜境。言身取者。谓眼等根取匪宜境。言心执者。谓眼等识执匪宜境。乐涅槃者多住涅槃心解脱故。于依顺取身取心执无有是处。今详此中略意趣者。谓诸应果若多安住。出离等六心解脱中。于六匪宜不随系住。如慎所忌烦恼不生。若不多住出离等六。于六匪宜便随系住。后生毒箭虽已永拔。然于眼等烦恼漏生。如犯匪宜疮中溃漏。如是上座引此契经。但害自宗岂违他义。又彼所说诸辩退经。皆唯说退增上心所。不言解脱此亦不然。余契经中说时解脱阿罗汉。退由五因缘。不言彼退失增上心所。故乔底迦经亦说退失。时解脱性阿罗汉果。遮彼僻执如前应知。炭喻经中亦说有退阿罗汉果。如后辩成。邬陀夷经亦说有退无漏道果。毒箭喻经亦说有退如前已辩。彼所引经唯据胜品阿罗汉说。故不成证。有释此经。佛依自说言。与弟子相杂住故。不放逸经前对经主。已具决择故亦非证。是故上座立无退失阿罗汉果。理教并无。分别论师作如是说。一切圣道皆无有退。故所断惑毕竟不生。云何知然。由教理故。教谓经说告迦叶波。若有如是众多善法。我说彼善法无住况有退。诸阿罗汉既有如是。众多善法故无有退。又契经言如是应果。永离垢永究竟。无明为因生诸染着。明为因故离诸染着。诸阿罗汉皆无过罪。唯尽故不造新离染无贪。已焚有种不复生长诸有萌芽。如烧油尽灯便永灭是谓为教。复立理言。非种被烧有生芽理。如是一切多同前破。少有异者今别遮遣。且彼初教为证不成。学位便应许有退故。非有学位有多善法与无学同。有学位中有成不善如异生故。必观别意经作是说。余经说应果有退不退故。若谓说退别约世俗。亦应据别说无退言。谓余经中说退无别。而许约别说退非余。此无退言虽无差别。理亦应许据别为言。然此经中所说义者。世尊为赞于善法中。尊重恒修所获胜利。或意为显正修善时。无住无退非谓恒尔。或非应果善法皆同。慧解脱等有差别故。此中唯据成就众多胜善法者说。无有退翻此有退理在不疑。永离垢等如先已释。先释者何。依续后生烦恼垢等。密说无过准此应释。尽故等言无明为因。生染着等如前无种。应无退释彼所立理堕非理失。许后有芽必不生故。唯立喻说理不成故。或应诘问分别论师。汝许以何烧诸烦恼。彼定应答以智火烧。应复难言此不应理。智应依烦恼如火依薪故。然不应说无漏智生。以诸烦恼为所依附。又惑尽位智亦应亡。如薪尽时火随灭故。又如薪尽必有余灰。阿罗汉身中应有余惑故。若谓法喻不可全同。勿毕竟无同法喻故。既尔何故不如是取。惑无烧理但少如烧故不应言法全同喻。若尔如何说断惑。如烧薪如不更生芽不生后有故。由此于退无能遮理。正理论者作如是言。修道断惑容有退者。此中教理上论文中。因破他宗多分已说。今为成立自所许宗。当复显示前未说者。谓从应果亦有退义炭喻经中分明说故。如说多闻诸圣弟子。若行若住有处有时。失念故生恶不善觉。引生贪欲或嗔或痴。如是多闻诸圣弟子。迟失正念速复还能令所退起尽没灭离。以何为证知。此多闻诸圣弟子是阿罗汉。何劳征问。由此经言。彼圣弟子。心于长夜随顺远离等。如余经说。故谓此经内作如是说。如是多闻诸圣弟子。若行若住或王或亲来至其前。请受财位。广说乃至。由此多闻诸圣弟子。心于长夜随顺远离。趣向远离临入远离。随顺出离趣向出离。临入出离随顺涅槃。趣向涅槃临入涅槃。欣乐寂静欣乐远离及出离故。我说彼遍于一切顺漏法。已能永吐已得清凉。又此经中先作是说。彼观诸欲如一分炭。由此观故于诸欲中。欲欲欲贪欲亲欲爱。欲阿赖耶欲尼延底。欲耽着等不染其心。余契经中说阿罗汉。具八力等与此经同。谓余经言告舍利子。诸阿罗汉有八种力。何等为八。谓阿罗汉诸漏已尽。其心长夜随顺远离。趣向远离。乃至广说。又彼经中亦作是说。彼观诸欲如一分炭。广说乃至。皆如此经。复作是言。彼已修习已善修习。念住正断神足根力觉支道支。戍拏经中说阿罗汉。安住出离无害远离。爱尽取尽及不忘失心解脱性。毒箭喻经亦作是说

佛告善宿。乐涅槃者。所有非想非非想结。尔时皆得永断遍知。由此证知此经所说。诸圣弟子是阿罗汉。其义决定不应生疑。经主此中作如是说。实后所说是阿罗汉。然彼乃至于行住时。未善通达容有此事。谓有学者于行住时。由失念故容起烦恼。后成无学则无起义。前依学位故说无失。详经主意。谓此经中先说学位后说无学。今应审察决定可依。为世尊言。为经主意。然此经内无少依希可引证成。前依学位后文方据无学位说。谓此经中先说弟子。由观诸欲如一分炭。已令欲等不染其心。次说有时失念起惑。次复说彼速还得离。于后即说彼行住时。王等来请不受财位。由彼长夜顺远离等。乃至说彼于顺漏法。已能永吐已得清凉。此经始终都不见佛。为说异法亦不见说。彼修异行别有所证。以何证知彼圣弟子。先住学位后成无学。今详此经本为遮止。如经主等此妄计度。是故先说诸圣弟子。由观诸欲如一分炭。能令欲等不染其心。此即显成已证应果。次复说彼失念起惑。即已显成应果有退。由如是理知此经中。初后二文皆说无学。又彼所说然彼乃至。于行住时未善通达容有此事。理亦不然。由此经中说彼弟子。若行若住随觉通达。有时忘失起烦恼故。若谓不说善通达言。此亦不然。义已说故谓此经说。彼圣弟子若行若住。随觉通达有时忘失。同诸世间心起贪忧。恶不善法岂不已说。善通达言。若通达言。显善通达如何善通达。容更起烦恼此责不然。前已说故。谓失念故起诸烦恼。既尔即应未善通达。不尔无忘失。唯世尊有故。若尔何故契经中言。具寿舍利子成六恒住法。应知此经说意有二。谓显一切阿罗汉果。非皆具成六恒住法。或显一切虽皆具成。而非皆能现前安住。若异此者。世尊不应以此为门。显彼殊胜非苾刍众。知舍利子声闻众中。智慧第一是大法将。能转法轮而不信知是阿罗汉。须薄伽梵以诸应果。共有功德赞述劝知。又契经中说阿罗汉。不时解脱世间希有。又说若有补特伽罗。成六恒住世甚希有。由此证知非阿罗汉。于匪宜境见闻等时。一切皆能心安住舍。及能恒住正念正知。故诸应果有忘失念。由是彼说此中无有善通达言。故知前文说有学位不应正理。又若必尔有太过失。谓契经说我生已尽。不言善尽应是有学。又契经说已见圣谛。不言善见应是异生。又契经言令有路绝。不言善绝应非应果。此等既不尔知彼说不然。故通达言义必有善有余。于此复确执言。此炭喻经定说学位。云何知然义为依故。依何等义。谓有学者许有烦恼非无学故。无学已断诸颠倒故。惑种无故必无退理。又是圣道果所摄故。如见断惑断无退理。详彼具寿以自所执邪义为依。都不欲依善逝所说契经正义。如何汝等久匿己情恒矫说言。我依经说不以对法正理为依。以对法宗有越经故。今乃显露不顾经文。随己妄情横立义理。学正理者作如是言。以义为依知说学位。岂不虽许以义为依。而称世尊为我师者。所立义理不应违经。若与经违便非正理。若非正理为证不成。如何辄言义为依故。所言有学许有烦恼。于无学退何所相违。然此经中不说有学。唯说无学前已辩成。故知应果有失念退。经主所说义最可依。非汝随情妄所执义。若唯有学有烦恼故。烦恼可生非无学者。世尊何故不差别说。令所化生起无谬智。知失念退学位非余。非佛世尊已超众过。作迷谬说令众生疑。虽此经中无差别说。准余知此说无学位。故彼所说是自室言。又彼所言无学已断。诸颠倒等证无退因。如前已遮故无证用。由此无学有起惑退。其理极成不可倾动。上座于此复谬释言。此炭喻经说不还位。以有学位惑垢未除。容有遇缘失念起惑。非诸无学有起惑理世尊虽说。彼于一切诸顺漏法。已能永吐已得清凉。而由但言于诸顺漏不言于漏。故说无失此不成释。所以者何。诸漏亦名顺漏法故。谓顺漏法摄有漏尽。理不应言不摄诸漏。许此圣弟子于一切有漏。已能永吐已得清凉。而言未成阿罗汉果。曾未闻此悟教理言。或应许漏非顺漏法。则与自执教理相违。又彼云何许不还者。于有顶地诸顺漏法。已能永吐已得清凉。若此地中诸漏未断。定于此地诸顺漏法未得离系。许于此法未得离系。而言于此已能永吐已得清凉。如是所言显慧奇特。漏顺漏法俱时断故。既说于顺漏已吐已清凉。则证知彼已尽诸漏。故无容释此说不还。又彼所言此经虽说其心长夜顺远离等。余经说此名应果力。而要具八方得名为。阿罗汉力是故无过。以何为证知要具八。名应果力一一不然。此中都无教理为证。但率自意庄饰言词。又彼如何许总具八方得名力。一一不然非彼所宗。诸阿罗汉许八种力俱时现行。故不应言总方成力。又非应果此一一法现在前时。为诸烦恼之所摧伏阙于力义。如何可计一一非力。故彼所说定不应理。又设许总方得名力。而举一一亦摽应果。如戍拏经说。阿罗汉唯住远离无害。出离爱尽取尽及不忘失心解脱性。毒箭喻经但作是说。乐涅槃者永断非想非非想结。岂举不遍便非应果。我今观彼诸所发言。但为令他知己能语。如是且举炭喻契经。证有应果退应果性。又说应果有二种故。如说有二阿罗汉果。一者退法二者不退。若谓唯退现法乐住。理必不然。由此经中说有二种阿罗汉故。若唯说退现法乐者。应唯有一退法应果。一切皆有现行退故。如契经说。我说由斯所证四种增上心所。现法乐住随一有退所得。不动心解脱身作证。我决定说无因缘从此退。若谓唯约退定自在。诸契经中说为退法。非诸应果皆有此退。谓于静虑现在前中。可退自在名为退法。若余事务无暇现前。暂不现前不失自在。虽有受用退而名不退法。是故应果有二义成。此救不然。以契经说阿罗汉果有二种故。又前已说于诸静虑。退自在者于诸欲中。若舍远离应起烦恼。若不舍者既于离欲无所退失。而言退失离生喜乐岂不相违。故于静虑退失自在。理必应有烦恼现前。若阿罗汉无起烦恼。则应无有失自在定。便应一切阿罗汉果。唯有一种谓不退法。若时解脱是应果性。则二应果体不相杂。是故我说经说应果。有二种故有退理成。又说知所断不生方便故。如契经说。我如良医如实了知所治断法。定有于后不生方便。由此准知所断烦恼有更生理。故约善知能令所断不生方便。自赞善巧我如良医。若诸世间病愈无发则不应赞。唯此良医善知病愈不生方便。故知断惑有可退生。若谓此经约异生说。不尔彼说有觉支故。谓说我有内念觉支如实知有。乃至广说。故知决定不说异生。又说应果有二智故。如说阿罗汉有尽无生智。若诸断尽皆永不生。是则唐劳立无生智。若谓为别异生所断。显阿罗汉安隐第一。故依大益立无生智。此不应理。唯尽智生汝宗许已成第一安隐故。又阿罗汉皆自了知。我生已尽梵行已立。所作已办不受后有。如是安隐岂非第一。以诸异生虽得有顶三摩钵底。而有退堕乃至当生恶趣中故。唯尽智起已能自知。我都无后生更无少所作。显阿罗汉得第一安隐其义已成。何藉无生智。虽此第一安隐已成。而诸应果更起无生智世尊具说尽无生智言。由此定知有阿罗汉。烦恼已断恐后更生。方便勤求永不生智。故立无生智有大益理成。由此证知应果有退

说一切有部顺正理论卷第六十九阿毗达磨顺正理论卷第七十

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩贤圣品第六之十四

复以何缘诸阿罗汉等。离有顶染同不受后生。然于其中有于烦恼证不生法。而非一切。有说由根有差别故。此释非理。以契经说退不退法根品同故。如说五根增上猛利。极圆满故名俱解脱。然有俱解脱是退种性故。非根胜故证惑不生。若尔由何种性别故。六种种性唯应果有余亦有耶。修习练根唯无学位。余位亦有。颂曰

  学异生亦六　　练根非见道

论曰。有学异生种性亦六。六种应果彼为先故。由所安住种性差别。故有断惑后生不生。定于何时于所断惑证不生法。谓得能止此类烦恼殊胜道时。若尔此不生应是择灭非非择灭。若是非择灭则非择灭应是道果。如是便与圣教相违。如说云何非果法。谓非择灭及虚空无。此不生成择灭失。以胜道转非为此故。既非所为故非道果。谓胜道转为证择灭非非择灭故。道转时所证不生不名道果。如然灯者本为破闇非为尽油。而灯生时非唯破闇亦令油尽。然此油尽非本所为。是故不说名然灯果。此亦应然故无有失。故胜种性胜道生时。亦证不生然非道果。今详由道所证不生。定不由根应皆得故。但由殊胜种性力得故。不动者惑必不生。前说无学退法有三。一增进根。二退住学。三住自位而般涅槃。思等四随应有四五六七。非唯无学有增进根。有学异生亦有此义。唯非见道能修练根。此位无容起加行故。谓见道位速疾运转无暇于中更修余事。唯于信解异生位中。能修练根如无学位。如说不动退现法乐。如何不动法亦许有退义。无相违过。所以者何。颂曰

  应知退有三　　已未得受用
  佛唯有最后　　利中后钝三

论曰。应知诸退总有三种。一已得退。谓退已得殊胜功德。二未得退。谓未能得应得功德。三受用退。谓诸已得殊胜功德不现在前。三中前二非得为体。第三唯彼不现在前。此三退中世尊唯有一受用退。以有决定所作事业牵引其心。虽有所余无量希有不共佛法无暇起故。除佛世尊余不动法具有未得及受用退。谓于殊胜无诤定等。应得功德未能得故有未得退。有余事业牵引其心。已得功德无暇起故有受用退。余五种性容具有三。亦容退失已得德故。约受用退说不动法。退现法乐无相违过。经主于此作如是言。约无退宗不应为难。如何不动退现法乐。非约静虑退不退故。经说动法及不动法。一切应果无漏解脱。皆名不动心解脱故。然于静虑起自在中。可有退者名为退法。不可退者名不退法。如是思等如理应思。若尔不退安住不动有何差别。皆于静虑起自在中无退失故。非练根得名为不退。练根所得名为不动。此二所起殊胜等至。设遇退缘亦无退理。安住法者但于已住。诸胜德中能无退失。不能更引余胜德生。设复引生从彼可退。是不退等三种差别。如是建立阿罗汉果。退不退等差别不成。且约退失现法乐住。起自在性建立退法。如前种种推征已破。不退等三有相杂失。且依彼执不退安住。二圣者相应无差别。许二俱非练根得故。已得胜德俱无退故。未得胜德俱能起故。虽言安住新起胜德。可有退理异于不退。而安住名不依彼立。安住名显离进退故。又彼宗许安住利根。宁言有退新起胜德。若许有退应名退法。彼宗退法亦非全退。全退便应起烦恼故。所言不动由练根得。异不退法理亦不成。以彼所宗于现法乐。怖失自在故修练根。练所得根为退不退。若许有退应名退法。以彼自说若于静虑。退失自在名退法故。若许不退如由退力。立退法名如是。亦应由不退力名为不退。是则不动与不退同。如何于中固立差别。若谓本性是利根者名不退法。后修练根方成利者名不动法。为显此别建立二名。是则应同安住堪达。彼许安住本性利根。非练根得同无退故。虽言不退能新引起。殊胜功德与安住异。理亦不然。不约新起殊胜功德立不退故。谓彼所宗言此种性。于新胜德若起不起。性利根故于现法乐。不失自在是不退相。安住亦然故应无别。堪能达故得堪达名。彼宗不言从此种性。更至别类无漏解脱。定应但许练有漏根。则定依先退法种性。修练根行转名堪达。是则堪达亦练根成。此所成根为退不退。若许有退应名退法。若无退失应名不动。俱练根得并不退故。又不应说练有漏根。得究竟时名不动法。由此不动法是应果性故。非阿罗汉为于少劣。暂现法乐得自在故。起大加行修习练根。展转修令至不动法。是故经主但述己情不可依凭。趣圣教理唯有对法正理可凭。悟阿罗汉退等差别。谓就应果身中所成无漏功德有胜劣异。建立六种种性差别。诸阿罗汉为得后后。转胜转增无漏功德。起大加行修习练根。致大劬劳可有斯理。非为世俗如腐烂尸易坏难成。下劣功德暂时现起设大劬劳。故彼所宗不可依据。诸阿罗汉既许退果为更生不。彼于退位带惑命终应更受生。诸住果时所不作事退时作不。彼既起惑应有更为果相违事。无如是过。所以者何。颂曰

  一切从果退　　必得不命终
  住果所不为　　暂增故不作

论曰。无从果退中间命终。退已须臾必还得故。若有寿量将临尽者。必无退理无失念故。要有余寿方有退理。退已不久必还证得。如契经说。苾刍当知。如是多闻诸圣弟子。退失正念速复还能。令所退起尽没灭离。若谓不然修梵行果。应非安隐可委信处。又住果位所不应为。违果事业由暂增故。虽暂失念烦恼现行。如住果时必无作理。如高族者暂失位时。不等凡庸造鄙下业。又谁有退谁无退耶。修不净观入圣道者容有退失。修持息念入圣道者必无退失。尊重止观无贪痴增。如次应知有退无退。何界何趣容有退耶。唯欲界人三洲有退。六欲天处得圣果者有说利根故无有退。以有胜智能制伏心。令背妙境入圣道故。有说退者由阙资缘。或所依身不平等故。六欲天处二事并无。虽有钝根随信行性。生彼得圣亦无退理。诸有退者为起惑退。为先退已惑方现前。或有欲令由起惑退。品类足论当云何通。如彼论说。欲贪随眠由三处起。一欲贪随眠未断遍知故。二顺彼缠法正现在前故。三于彼正起非理作意故。乃至广说无相违失。所以者何。烦恼现前略有二种。已断未断有差别故。此中偏说未断起者。又烦恼起略有二门。染不染心无间起故。此中偏说染无间者。或烦恼起总有三缘。然烦恼生所藉不定。或有唯藉境界力生。或藉境因或兼加行。此约具者故说由三。或起惑时三缘必具。非理作意正起现前。所断随眠必还成故。何心无间起惑退耶。且从无学起惑退者。若起色缠无色缠退。唯从自地顺退分定。相应善心无间而起。非住欲界有上地摄。无覆无记心现在前。唯除通果心。然无从彼退岂不顺退分。各于自地离染时舍。如何无学者未退起惑。彼心现前理实如是。然顺住分品类有三。一少顺退。二少顺进。三守自住。前言自地顺退分定。即顺住分中。少分顺退者。少顺退故得顺退名。然此定心与守自位。多相涉故顺住分摄。诸有未失顺退分者。彼心无间烦恼现前。若舍彼心从顺住摄。少顺退者起烦恼退。故于文义无所相违。若起欲缠而退失者。从自地善无覆无记。二心无间皆容现前。诸从学位起惑退者。起色无色烦恼退时。若先全离此地染者。唯从此地顺退分定。相应善心无间而起。若未全离此地染者。从此地摄善及染污。二心无间皆容现前。起欲界缠而退失者。若先全离欲界系染。从自地善无覆无记。二心无间皆容现前。若未全离欲界染者。从欲善染无覆无记。三心无间皆容现前。若未现前获得清净。静虑无色必无能起。色无色缠退失所得。彼惑从彼无间起故。但起欲缠退失所得。若现前得清净静虑。犹未现前得净无色。必无能起无色缠退。起欲色缠退失所得。若已现前获得清净静虑无色。通起欲色无色界缠退失所得。诸有退失先所得时。若起上缠现在前退。不失下善不成下惑。若起下缠现在前退。定失上善定成上惑。复有欲令要先退已。后时对境惑方现前。施设足论当云何释。如彼论说无色三缠一一现起。退无色尽住色尽中。识身足论复云何释。如彼论说。无色界系染心现前。舍无学善续有学善。退无学心住有学心。此俱不相违依觉时说故。谓先虽退而未觉知。后起惑时方自觉退。如有先诵四阿笈摩。中废多时虽忘不觉。后诵不得方自知忘。此亦应然故无违失。住何心退后起惑耶。住欲界中无覆无记。威仪工巧异熟生心。退已后时方能起惑。然此欲界系无覆无记心。或有总违三界烦恼。此心正起无有退得三界惑义。或有但违欲色烦恼。此心正起容有退得无色惑义。或有但违欲界烦恼。此心正起容有退得二界惑义。或有不违三界烦恼。此心正起容有退得三界惑义。一切退已随其所应。起惑前心皆如上说。于此二说前说为善。如上所言有练根得。今应思择诸圣练根。有几无间几解脱道。用有漏道为无漏耶。依何身依何地。颂曰

  练根无学位　　九无间解脱
  久习故学一　　无漏依人三
  无学依九地　　有学但依六
  舍果胜果道　　唯得果道故

论曰。求胜种性修练根者。无学位中转一一性。各九无间九解脱道如得应果。所以者何。彼钝根性由久串习。非少功力可能令转。学无学道所成坚故。有学位中转一一性。各一无间一解脱道。如得初果非久习故。彼加行道诸位各一。学无学位修练根时。皆渐次修后后种性。得胜种性方舍前劣。故诸无学修练根时。加行无间前八解脱。如应皆是退法等收。第九解脱是思法等。诸有学者修练根时。加行无间是退等摄。解脱道时名思法等。我所承禀诸大论师。咸言练根皆为遮遣。见修断惑力所引发。无覆无记无知现行。故学位中修练根者。正为遮遣见惑所发。无学位中修练根者。正为遮遣修惑所发。如如断彼能发惑时。所起无间解脱多少如是。如是断彼所发无知现行道数亦尔。是故无学修练根时。用九无间九解脱道。学位练根二道各一。然见修惑所发无知。随所障殊有多品类。故转退等成思等时。诸道现前各有所遣。由此无有超得胜性。有余师说。一切练根皆一加行。无间解脱前说为善理如前故。如是无间及解脱道。一切唯是无漏性摄。圣者必无用有漏道而转根理。以世俗法体非增上无堪能故。一切加行皆通二种。如是所说但据现行。兼未来修复有差别。谓无学位修练根时加行。未来亦通修二九无间道及八解脱。未来所修亦唯无漏。第九解脱未来修二。兼修三界所有功德。与初尽智所修同故。若有学位修练根时加行。未来亦通修二无间解脱。未来所修亦唯无漏如得初果。若尔岂不广论相违。如广论言从信解性修练根行。得见至时十四化心尔时亦得。宁不许学解脱道中亦于未来。修有漏道此无违失所以者何。彼论但依得俱生说。如下地道现在前时。上地化心亦说为得。谓如已离三静虑染。依初静虑入见谛者。亦说彼得四定化心。然理不应由下见道。现在前故修上地法。彼文但依见道与彼得俱生。说此亦应然。有余师言。诸未来法有得。得故即说名修既彼得俱。宁不修彼。故诸有学修练根时。解脱道中亦修有漏。然非一切皆能通修。谓若预流未趣后果。修练根行解脱道中。如得果时唯修无漏。由见道得一来不还。未趣后时应知亦尔。分离有顶中间练根。解脱所修亦唯无漏。余有学位修练根时。解脱所修皆通二种。前说为善。所以者何。非彼得俱皆名修彼。勿一切法能修一切。又有学位修练根时。正为遮遣见惑所发。与断见惑道数既同。如何所修异见道果。若余趣后中间练根。解脱道中亦修有漏。无间道位何不许然。如离染时二道等故。然无学位修练根时。道数所修如断有顶。若有学位修练根时。道数所修如断上界。见道所断由彼但与邻得果时道相似故。学无学位修练根时。加行皆通曾未曾得。无间解脱唯是未曾一切皆通。法智类智修练根者。唯三洲人唯依此身有怖退故。以何等故名为练根。调练诸根令增长故。谓道力故令根相续。舍下得中舍中得上。渐渐增胜名为练根。故练根名目转根义。虽八解脱渐得胜根。而由本心求胜性故。未得胜性不舍前劣。如得后果方舍前向。如在圣位种性有六。能修练根于见道前。暖等加行应知亦尔。有差别者若圣位中。得胜种性必舍前劣。暖等位中修练根者。但得胜性劣性不行。名为转根非舍劣得。无学练根通依九地。谓四静虑未至中间及三无色。唯此九地有无漏道余地无故。有学练根唯依六地除三无色。所以者何。以转根者容有舍果及胜果道。所得唯果非胜果道心欣果故。无有学果无色地摄。故学练根但依六地。设许学位依无色练。根定是不还住胜果道位。无不还果无色地摄。故不依无色修练根得果。以初二果唯未至摄。不还唯通六地摄故。有说唯有住果练根。勿有舍多得少过故无如是过。以练根者心期胜果不求多故。由此学位修练根者。若住果道加行等三皆果道摄。若住胜道加行无间胜果道摄。解脱道果道摄。住无学位修练根者。加行等三唯果道摄。诸住果位修练根时。舍果得果住胜道位。修练根时舍二得果。又诸圣位修练根时。与本得果地同或异。谓初二果依地必同。彼此俱依未至地故。不还应果依地不定。或依本地或上或下。有差别者若诸不还。依下练根不得上果。阿罗汉不尔如本得果故。分断有顶结练根得果时。虽舍彼断不成彼结。如异生者生上七地。随应舍下断而不成下结。俱是进时非退时故。诸无学位补特伽罗。总有几种由何差别。颂曰

  七声闻二佛　　差别由九根

论曰。居无学位圣者有九。谓七声闻及二觉者。退法等五不动分二。后先别故名七声闻。独觉大觉名二觉者。由下下等九品根异。令无学圣成九差别。有学无学补特伽罗。一切总收无过七种。一随信行。二随法行。三信解。四见至。五身证。六慧解脱。七俱解脱。依何立七事别有几。颂曰

  加行根灭定　　解脱故成七
  此事别唯六　　三道各二故

论曰。依加行异立初二种。谓依先时随信他语及自随法能于所求。一切义中修加行故。立随信行随法行名。依根不同立次二种。谓依钝利信慧根增。如次名为信解见至。依得灭定立身证名。由身证得灭尽定故。依解脱异立后二种。谓依唯慧离烦恼障者。立慧解脱依兼得定。离解脱障者立俱解脱。此名虽七事别唯六。谓见道中有二圣者。一随信行二随法行。此至修道别立二名。一信解二见至。此至无学复立二名。谓时解脱不时解脱。然唯应说有二圣者。随信随法行有异故。即此二种随道差别。虽立异名而无别体。如是所说补特伽罗。以根性道离染依别。诸门分析数成多千。且如最初一随信行。根故成三谓下中上。性故成五谓退法等。道故成十五谓八忍七智。离染故成七十三。谓具缚离八地染。依身故成九。谓三洲欲天。若根性道离染依身。相乘合成一亿四万七千八百二十五种。随法行等如理应思。如是等门差别无量。若欲委细一一分别。施功甚多所用极少。故我于此略示方隅。有智学徒应广思择。前说依解脱立后二种。立后二种相由何应知。颂曰

  俱由得灭定　　余名慧解脱

论曰。诸阿罗汉得灭尽定者名俱解脱。由慧定力双解脱烦恼解脱障故。所余未得灭尽定者名慧解脱。但由慧力于烦恼障得解脱故。何等名为解脱障体。诸阿罗汉心已解脱。而更求解脱为解脱彼障。谓于所障诸解脱中。有劣无知无覆无记。性能障解脱是解脱障体。于彼彼界得离染时。虽已无余断而起解脱。彼不行时方名解脱彼。有余师说。此解脱障即以于诸定不自在为体。有余师说。此解脱障即以诸定不得为体。有余师说。于彼加行不勤求故。不听闻故不数习故解脱不生。即此名为解脱障体。初说应理。所以者何。必有少法力能为障。令彼于定不自在转。若不尔者。彼有何缘于诸定中不得自在。不得定者必有所因。不可说言即因不得。自体不应还因自故。或烦恼障亦应可说。即以应果不得为性。彼既不然此云何尔。阿罗汉果亦由于加行。不勤求等故体不得生。岂便无别烦恼障体。故后三说皆不应理。又无漏心亦有从此名得解脱。由约在身及约行世说解脱故。谓要解脱解脱障时。方起在身及行世故。诸阿罗汉有名同者根亦同耶。应作四句。第一句者。慧解脱中有时解脱不时解脱。俱解脱中有二亦尔。第二句者。时解脱中有慧解脱有俱解脱。不时解脱有二亦尔。第三句者。慧解脱中二。时解脱自互相望二。不时解脱俱解脱亦尔。第四句者。慧解脱中取时解脱。俱解脱中不时解脱。展转相望与此相违应知亦尔。如世尊说五烦恼断。不可牵引未名满学。学无学位各由几因。于等位中独称为满。颂曰

  有学名为满　　由根果定三
  无学得满名　　但由根定二

论曰。学于学位独得满名。要具三因谓根果定。故见至身证独得名为满。少有阙者尚非满学。况一切阙而得满名。何等名为少有阙者。谓信解得灭定。或见至不还未得灭尽定。或见至未离欲。或信解不还未得灭尽定。何等名为一切阙者。谓信解未离欲有许少阙亦得满名。彼作是言有有学者。但由根故亦得满名。谓诸见至未离欲染。有有学者但由果故。亦得满名。谓信解不还未得灭尽定。有有学者由根果故亦得满名。谓见至不还未得灭尽定。有有学者由果定故亦得满名。谓诸信解得灭尽定。有有学者具由三故独得满名。谓诸见至得灭尽定。无有学者但由定故。及根定故亦得满名。此不可依。如何有学于诸有学胜功德中。犹未具证而许名满故。如前说理定可依。无学位中无非果满故不由果建立满名。自位相望独名满者。要具二种谓根与定。故唯不时俱解脱者。望余无学独得满名。随阙一者尚非满无学。何况双阙得满无学名。何等名为随阙一者。谓时解脱得灭尽定。或不时解脱不得灭尽定。何等名为双阙二者。谓时解脱不得灭定。有许阙一亦得满名。此不可依理如前说。如契经说。二阿罗汉一具三明二不退法。于前所说诸应果中。二阿罗汉何应果摄。且不退法摄在不动。然此不动差别有二。一者唯能不退应果。二者不退一切胜德。此中第一但名不动。如思法等由练根得。仍有退失阿罗汉果。此异彼故得不动名。然于应果一切胜德。犹可退失不名不退。第二亦无退诸胜德。故经于彼立不退名。以不动中于胜功德有可退者。是故契经于不动。内立不退法具三明者。有言此摄在慧解脱。俱解脱中岂不宿住死生漏尽。三种妙智名曰三明。若具成此三名具三明者。作如是说为欲显何。若具三明必起静虑。三明要依静虑发故。非慧解脱静虑现前。苏尸摩经分明说故。宁说慧解脱亦摄具三明。此不相违经据满故。然有已得七解脱者。未得灭定故亦名慧解脱。依不得灭尽定体。建立慧俱二解脱故。理必应尔。以契经言有具三明非俱解脱。既有此说便决定知。有具三明非俱解脱。离慧解脱此为是何。是故所言具三明者。二解脱摄定为应理。有言非理。所以者何。彼不了达所引经故。于余契经有相违故。谓彼所引恣举经言。有具三明非俱解脱。据遮圆满俱解脱说。然有极下唯得最初。根本静虑现在前者。亦说名为俱解脱故。如余经说。时迦莫迦问庆喜言。世尊处处说俱解脱。此俱解脱名何所目佛数说耶。庆喜答言。俱解脱者。谓入离欲恶不善法。有寻有伺离生喜乐。初静虑中具足安住。及由慧故见诸漏尽。齐此方名俱解脱者。准此经说知恣举经。据遮圆满俱解脱说。即此经后复作是言。应知所余名慧解脱。又遮慧解脱起初根本定故。次庆喜告迦莫迦。具寿当知非慧解脱。已入离欲恶不善法。有寻有伺离生喜乐。初静虑中具足安住。然能以慧见诸漏尽。世尊说为慧解脱者。由此彼谓苏尸摩经。且据圆满慧解脱说。唯约已得灭尽定者立俱解脱。其理不成。故此经中意显此义。具三明者必俱解脱。要起根本静虑现前。方有得名具三明故。有俱解脱非具三明。谓阿罗汉得八解脱。而未能起三明现前。今详诸经真实意趣。慧俱解脱若圆满者其体各异。未起根本已得灭尽位悬隔故。不圆满者二体相杂。随说皆通不应为诤。然欲简别令无杂者。应就灭定不得得说。以慧解脱无得灭定根本静虑。虽不现行然于去来必成就故。由此可说具三明者。理通摄在二解脱中

说一切有部顺正理论卷第七十阿毗达磨顺正理论卷第七十一

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩贤圣品第六之十五

广说诸道差别无量。谓世出世见修道等。今应思择于诸道中。略说有几可能遍摄。颂曰

  应知一切道　　略说唯有四
  谓加行无间　　解脱胜进道

论曰。加行道者。谓此无间无间道生。无间道者。谓此能灭所应断障。解脱道者。谓已解脱所应断障最初所生。胜进道者。谓除无间加行解脱所余诸道。何义名道。谓寻求依。依此寻求涅槃果故。由此一切修苦智等。无不皆为寻求涅槃。或此道名目涅槃路。三乘贤圣涉此夷途。速达二种涅槃界故。道于余处立通行名。以于谛中能善通达。复能速往涅槃城故。此有几种依何建立。颂曰

  通行有四种　　乐依本静虑
  苦依所余地　　迟速钝利根

论曰。经说通行总有四种。一苦迟通行。二苦速通行。三乐迟通行。四乐速通行。此四通行有差别者。依地依根建立异故。云何依地建立差别。谓依根本四静虑中。所生圣道名乐通行。任运转故如乘船筏。任运转者。由此地中止观双行无增减故。又此诸地所有等持。摄受五支四支成故。依余无色未至中间。所生圣道名苦通行。虽道非苦苦受相应。艰辛转故亦名为苦。如依陆路乘马等行。艰辛转者。由此地中止观虽俱而增减故。谓无色地观减止增。未至中间观增止减。又此诸地所有等持。不摄五支四支成故。有余师说。未至地道难可成办故立苦名。谓有先来都未得定。多起功用方得现前。此既现前为胜加行。根本静虑易起故乐。静虑中间同一地摄。异心品灭异心品生。极为艰辛故亦名苦。譬如以木析木极难。谓一地中有寻有伺。粗心品灭无寻唯伺。细心品生多用功力。诸无色定亦甚难成。故亦名苦极微细故。谓无色定行相眇然。不易测量修难成办。又从静虑起无色时。五蕴定灭四蕴定起。极为难办故立苦名。云何依根建立差别。谓即苦乐二通行中。钝根名迟利根名速。二行于境通达稽迟。说名迟通翻此名速。或迟钝者所起通行名迟通行。速此相违。或趣涅槃有迟有速。由根钝利如后当辩。此行五蕴四蕴为性。由依色定无色定别。而名通者显慧胜故。如见道位虽具五蕴。以慧胜故偏立见名。如见道边诸世俗智。金刚喻定亦以五蕴四蕴为体立智定名。然有经中说四通行。五根为性亦就胜说。慧胜中胜故立通名。为诸有情无中根者。而今但说迟速行耶。有一类言无中根者。如契经说诸利根中。唯有指鬘最为第一。诸钝根中唯有蛇奴最为第一。此经不说别有中根故知非有。又于三道各说二故。谓见道中唯见说有。随信法行二道差别。修道位中唯见说有。信解见至二道差别。无学道中唯见说有。时及不时二道差别。若许有中根应各说三道。若尔应与契经相违。如说。有情世间生长。有利中钝三根差别。此不相违。依佛出世彼有情类。初中后时入道不同作是说故。初入道者如阿若多憍陈那等。后入道者如善贤等。中谓所余。或据有情种解脱分有上中下故说无违。然理定应有中根者。谓随法行一种性中。有大声闻独觉大觉。不可说彼根品无差。又契经中说随法行是钝根摄。如说。五根增上猛利。极圆满者名俱解脱。乃至广说。然通行中不别说有中品行者不明了故。于世典中亦随明了。唯见显示上下非中。由此已释道唯二意。又彼所引根第一经。已定证成有中根者。谓既说有第一利根。知更有余利而非极。但对钝者说之为利。又既说有第一钝根。知更有余钝而非极。但对利者说之为钝。故应决定许有中根。经中明说有三根故。依根立道必亦有三。但不分明故唯说二。然中根性摄在二中。以利钝中有非极故。应知通行随此相说。唯立迟速无别处中。然上所言由根利钝。于趣圆寂有速有迟。此据等修勤加行说。若不据等则钝利根。趣向涅槃迟速不定。又契经说。有现法迟身坏速等四句差别。此约加行有勤不勤。不约转根及有退说。以诸圣者若已经生。不退不转根不生上界故。大觉独觉到究竟。声闻依何通行入圣。证极果大觉唯依乐速通行。谓以第四静虑为依。由极利根入正决定。证得无上正等菩提。于独觉中麟角喻者。如大觉说余则不定。于到究竟二声闻中。舍利子依苦速通行。及乐速通行入圣证极果。彼依未至入正决定。依第四定得漏尽故。目连唯依苦速通行。谓依未至入正决定。依无色定得漏尽故。二圣先来乐慧乐定。故证极果依色无色。许到究竟诸大声闻。法尔唯应渐次得果。故彼入圣道皆依未至地道。亦名为菩提分法。此有几种名义云何。颂曰

  觉分三十七　　谓四念住等
  觉谓尽无生　　顺此故名分

论曰。经说觉分有三十七。谓四念住四正断四神足五根五力七等觉支八圣道支。尽无生智说名为觉。随觉者别立三菩提。一声闻菩提。二独觉菩提。三无上菩提。无智睡眠皆永断故。及如实知已作己事。不复作故此二名觉。三十七法顺趣菩提。是故皆名菩提分法。此三十七体各别耶。不尔云何。颂曰

  此实事唯十　　谓慧勤定信
  念喜舍轻安　　及戒寻为体

论曰。此觉分名虽三十七。实事唯十即慧勤等。谓四念住慧根慧力择法觉支正见以慧为体。四正断精进根精进力精进觉支正精进以勤为体。四神足定根定力定觉支正定以定为体。信根信力以信为体。念根念力念觉支正念以念为体。喜觉支以喜为体。舍觉支以行蕴摄舍为体。轻安觉支以轻安为体。正语正业正命以戒为体。正思惟以寻为体。如是觉分实事唯十。前五即是信等五根。由境等殊分为三十。更加喜舍轻安戒寻。戒分为三复总成七。并前合成三十七种。毗婆沙师说有十一。身业语业不相杂故。戒分为二余九同前。念住等三名无别属。如何独说为慧勤定。颂曰

  四念住正断　　神足随增上
  说为慧勤定　　实诸加行善

论曰。四念住等三品善法。体实遍摄诸加行善。然随同品增上善根。如次说为慧勤及定。何缘于慧立念住名。慧由念力持令住故。何故说勤名为正断。于正修习断修位中。此勤力能断懈怠故。或名正胜于正持策。身语意中此最胜故。何缘于定立神足名。诸灵妙德所依止故。经主此中作如是说。有余师说。神即是定足。谓欲等彼应觉分。事有十三增欲心故。又违经说。如契经言。吾今为汝说神足等。神谓受用种种神境。分一为多乃至广说。足谓欲等四三摩地。此中佛说定果名神。欲等所生等持名足无如是。失彼许等。持体即是神亦是神足。彼所言足谓欲等者。为显等持有四种。故举因显果说欲等言。然诸等持总有二种。一于善根加行位胜。二于善根成满位胜。前名神足后名为神。故契经言由欲增上。所得胜定名欲等持。此言即说加行位定。复言方便为断已生恶不善法。乃至为令已生善法安住增广。由前欲定生起于欲。发勤精进摄心持心。此说善根成满位定摄心。谓慧持心谓定能摄持心是彼相故。复言如是欲勤精进摄心持心。乃至广说云何欲等由欲等持。此言为明后起欲等。是等引者修欲等持。加行成时所证果义。复言此位。若欲若勤若信若轻安若念若正智若思若舍。皆名胜行。依何修造立胜行名。依修造神故名胜行。由如是理。故次说言如是胜行。及前欲定合名欲定胜行神足。所言神足者是神所依义。以前欲定是前生定因。后起欲等是俱生定因故。胜行中不复说。定因定果定无容俱故。俱生欲等于所修定有何功能。若离俱生欲等诸法定不生故。以定于彼俱生聚中最殊胜故。说是所修起先欲定为加行者本。为求得后胜定故。由如是理彼说等持。体即是神亦是神足。故无觉分增欲心失。又彼亦无违契经过。故彼自释此契经文。言以神声说于神果。如遍知果说遍知声。如是所言定为应理。由此经说云何名为趣修神足道。谓八支圣道顺清净。经说言大德。我今定说有如是神。然如是神性是下劣。诸异生类本所成法。非圣非圣性。非通非通性。不能得菩提。不能得涅槃。由是不应修此神足。是八圣道所应趣求。但为断除能证根本静虑定障。便为应理。虽定即神而此经说。神果变现事相名神。欲令寻粗悟入于细。兼为显定是彼近因。故作是言无违经过。何缘信等立根力名。以增上故。难屈伏故。何缘此五先说为根后名为力。由此五法依下上品分先后故。又依可屈伏不可屈伏故。下品信等势用劣故。犹为所治同类屈伏。上品翻此故得力名。所说觉支为有何义。能觉悟义名为觉支。若尔觉支唯应有一。不尔念等是择法分。皆顺择法从胜为名。或觉之支是觉支义。若尔应许觉支唯六。不尔择法是觉亦觉支。所余六种是觉支非觉。所说道支为有何义。寻求依义名为道支。若尔道支唯应有一。不尔。余七是正见分皆顺正见从胜为名。或道之支是道支义。若尔应许道支唯七。不尔。正见是道亦道支。所余七种是道支非道。当言何位何觉分增。颂曰

  初业顺决择　　及修见道位
  念住等七品　　应知次第增

论曰。初修业位说念住增。谓此位中为息颠倒。由念势力于身等境。自相共相能审了知。坏二种愚慧用胜故。于暖法位说正断增。谓此位中见生死过涅槃功德。遂能勇猛发勤精进。不坠生死速趣涅槃勤用胜故。于顶法位说神足增。谓此位中能制心识。趣不退位终不匮乏。信等善根定用胜故。于忍法位说五根增。谓此位中永息恶趣。终不退堕速入离生。增上义成根义胜故。世第一位说五力增。谓此位中不为烦恼之所屈伏。力义胜故。虽忍位中亦容如是。然非决定是故不说。或此位中不为一切。余异生法之所屈伏。故于此位力义偏增。修道位中近菩提位。助觉胜故说觉支增。或此位中断九品惑。数数觉故觉支义增。见道位中所有道义。皆具足故说道支增。谓寻求依及通往趣。二义具故说名为道。见道位中二义最胜。谓见道位圣慧初生。如实寻求谛理胜故。又于此位不起期心。能速疾行往趣胜故随数增故。于契经中先七后八非修次第。有余于此立次第言。行者最初由慧势力。于身等境自相共相。如实了知导起众善。如有目者将导众盲。是故最初说四念住。由四念住了众境已。于断恶修善能发起正勤。故于第二说四正断。由正勤力令相续中。过失损减功德增盛。于殊胜定方能修习。是故神足说在第三。胜定为依便令信等。与出世法为增上缘。由此五根说为第四。根义既立能招恶趣。恶业烦恼不能屈伏。由此五力说为第五力义既成。能如实觉四圣谛境。无疑虑故说七觉支在于第六。既如实觉四圣谛境。厌舍生死欣趣涅槃。故说道支以为第七。于中一一辩其次第。如释。经论应正思求今此论中思择法相。于次第理无劳烦述。今于此中应辩觉分。几唯无漏几有漏耶。颂曰

  七觉八道支　　一向是无漏
  三四五根力　　皆通于二种

论曰。此中七觉八圣道支唯是无漏。唯于修道见道位中方建立故。谓修道位七觉支增邻近菩提。谓治有顶故觉支体一向无漏。一切觉分皆助菩提。唯此独摽觉支名者以最邻近。菩提果故由此理趣证七觉支。应知但依治有顶说。此为上首类治下地。唯于无漏立觉支名。若不许然宁不通二。或于一切菩提分中。依近菩提立觉支号。道中修道位近菩提性近菩提。唯是无漏故无漏修道方立觉支名。见道位中八道支胜故。此一向无漏性摄。虽正见等亦通有漏。然彼不得圣道支名。圣道支名目无漏故。又诸论者许觉分法。觉支后说定是无漏。若说在前便通二种。既觉支后方说道支。故八道支一向无漏。所余通二义准已成。谓觉分中前位增者。彼于后位势用亦增。后位增者非于前位。故毗婆沙作如是说。从初业位至尽无生念住常增。乃至广说。此三十七何地有几。颂曰

  初静虑一切　　未至除喜根
  二静虑除寻　　三四中除二
  前三无色地　　除戒前二种
  于欲界有顶　　除觉及道支

论曰。初静虑中具三十七。于未至地除喜觉支。于下地法犹怀疑虑。未能保信故不生喜。又未至定初现前时。未能断除下地烦恼。后虽已断而类同前。故起彼时皆无有喜。有说。一切近分地道。皆力励转故无喜义。第二静虑除正思惟。彼静虑中已无寻故。由契经说彼地无寻。彼上等持转寂静故。由此二地各三十六。第三第四静虑中间。双除喜寻各三十五。前三无色除戒三支。并除喜寻各三十二。欲界有顶除觉道支。无无漏故各二十二。如是诸地随其所应。觉分现前少多无定。谓随位别后必兼前。可一体上义分多种。故有多种俱时起义。唯四念住必不俱生。以约所缘分为四故。尚无二慧俱时而生。况有一时四慧并起。不可一慧约境分多。以若总缘法念住摄。必无一慧于一刹那。缘四境生四行相故。由此理趣初静虑中。总而言之具三十七。然于一念顿现在前。极多但容有三十四。如是未至第二静虑。极多但容有三十三。三四中间极三十二。前三无色极二十九。欲界有顶极唯十九。一切皆除三念住故。其中减者随位应思。何故心王不立觉分。理亦摄在念住等中。彼实摄诸加行善故。然不别立如慧等者。心于杂染清净分中。势用均平无所偏党。觉分唯在清净分中。势用增强。是故不立。有余师说。觉分多缘诸法共相。心王多分缘自相生。是故不立。有余复说修习觉分。本为对治一切烦恼。然诸烦恼心所非心。故能治法非心唯所。障治相翻而建立故。有说。觉分辅佐于觉觉是心所慧为体故。不可心王辅佐心所。如王不可辅佐于臣。所以心王不立觉分。有余师说。心导世间于界趣生轮回无绝。修习觉分为断生死。由此心王不立觉分。有余师说。无始时来心为众多。烦恼杂染驰散诸境。[怡-台+龍]悷难调为调伏心修习觉分。非所调伏即是能调。是故心王不立觉分。何缘诸大心所法中。唯立四法为菩提分。实总摄在念住等中。彼实摄诸加行善故。然别建立念定慧者。由此三种顺清净品。势用增强可立觉分。想思触欲于染分中。势用增强故不别立。于假想观胜解偏增。觉分唯摄顺真实观。由此胜解非觉分摄。有余师说。至无学位胜解方增。经但立为无学支故。菩提分法有学位增。由此为因力能引起三菩提故。所以胜解非觉分摄。作意势力能发动心。令于所缘易脱不定。觉分于境审谛观察。令心专一与彼相违。是故作意非觉分摄。若尔宁立寻为觉分。寻于境界虽策发心。而欲令心推求至理。非令于境浮飘易脱。于谛观察有策发能。说此力能策正见故。由此作意不可例寻。有余师言。若染若净初取境位。作意力增说为非理。如理作意至境相续。彼势力微故不立为烦恼觉分。烦恼觉分要于至境。相续位中方增盛故。受于杂染清净分中。势用俱增故立觉分。由此流转缘起支中立为受支。及于还灭菩提分中立喜觉支。有余师说。受于杂染虽是增上。而与净品作饶益事。亦有功能如旃荼罗。性虽鄙劣能与豪族作饶益事。故于静虑为饶益支。菩提分中立觉支号。何缘三受皆通无漏。觉分唯喜非余二耶。觉分所为行相猛利。乐舍行相迟钝故非。有余师言。乐舍二受为轻安乐。行舍所覆相不明了。是故不立。何缘大善心所法中。唯立四法为菩提分。实亦总是念住等摄。彼实总摄加行善故。然别立信勤安舍者。由此四种顺觉强故。如何此四顺觉用强。发趣菩提信为上首。将修众行信为初基。清净果因以信为本。若无信者修趣不成。故立信根以为觉分。有余师说。如清水珠置浊水中。水便澄洁令诸有目鉴众色像。如是以信置心品中。能令俱生心品澄净。由此能见四圣谛理。渐次增长成三菩提。故信最应立为觉分。勤于众行遍能策发。令其速趣三乘菩提。若无正勤虽已发趣。中间懈废终无所成。是故立勤以为觉分。有余师说。无始时来所以不能。见四圣谛都由懈怠。不乐听闻如理思惟四圣谛理。勤能治彼令乐听闻。如理思惟四谛理故。能见四谛速证菩提。故勤亦应立为觉分。轻安息务令心调适。行舍正直令心平等。故能增长诸出世行。令其速趣三乘菩提。故立安舍以为觉分。有余师说。无始时来惛掉乱心不见谛理。由此不证三乘菩提。轻安舍惛行舍止掉。由斯见谛速趣菩提。故此亦应立为觉分。若尔惭愧自性善摄。于众善品得白法名。亦应立为菩提分法。彼不应立以无惭愧。唯与一切恶心相应。于散戒中为胜障碍。于见谛理为障力微。与彼相违名为惭愧。自性善摄得白法名。虽于散戒有胜功力。而于定善为助力微。菩提分中取顺定善。助觉谛理故彼不立。若尔应立无贪无嗔。彼是善根自性善故亦不应立。以诸贪嗔六识相应。遍通五部是随眠性。发粗恶业为胜加行。断灭善根障散善强违见谛劣。翻彼故立无贪无嗔。得善根名自性善摄。于散善业功力虽强。助定善中势用微劣。菩提分法取顺定善。助觉谛理故彼不立。若尔不放逸应立为觉分。不放逸故众行皆成。佛每劝令修不放逸。亦不应立于散位中。放逸令心驰散五欲。能违施等散善用强。非定位中此障用胜。翻对彼故立不放逸。但于五欲能防护心。令不驰散专修施等。故于散善力用虽强。助定善中势用微劣。菩提分法取顺定善。助觉谛理故彼不立。若尔不害应立觉分。害能逼恼无量有情堕三恶道。彼能治故亦不应立。害缘事生恼诸有情。障修散善不害翻此助定力微故亦不应立为觉分。有余师说。大善法中若所治强。自性胜者立为觉分余则不然。所治强者。谓与一切染心相应。自性胜者。谓助见谛如先所说。信勤安舍具足二义。惭愧等六无具二者。谓惭等五二义并无。不放逸一种唯阙自性胜。何缘欣厌非觉分耶。理实亦是念住等摄。彼实总摄加行善故。然不别立为觉分者。由此二种行相相违。俱不遍缘四圣谛境。无一地位容恒现前。心品陜少。是故不立。有余师说。夫欣厌者。由慧观境势力引生觉分。谓能顺生觉慧。义相违故不应别立。何缘寻伺二种皆容有加行善及有无漏。而于觉分一是一非。实亦俱通义如前说。然别立寻不立伺者。寻于圣道策正见强。由彼起时行相猛利。寻求谛理。有助见能立为道支。伺则不尔。以行相起极微劣故。有余师说。二俱行时寻行相粗映蔽于伺。唯伺起位行相转微。故觉分中不别立伺。策发正见自有正勤。何更立寻以为觉分。勤策正见有异于寻。故道支中应并建立。谓勤策彼令速进修。寻力策令速观圣谛。何缘表业不立觉分。觉分唯是顺定善法心俱无表有胜顺能。表业不然。是故不立。何缘不立不相应行以为觉分。彼于助觉无别胜能。不相应故。非如无表虽不相应。而于道轮有为毂用。故于觉分不别建立。有余师说。二无心定能灭心故与觉相违。四相及得于所相成有迁成用。此于染净起用平等。菩提分法顺净用增故不别立。何缘不立信为觉及道支。初发趣时信用增上。已入圣位立觉道支。信于尔时势用微劣。故不立在觉道支中。何缘于觉支立喜轻安舍。非亦立彼在道支中。彼偏顺觉不顺道故。云何顺觉且修道中。地地各修九品胜觉。如如于谛数数觉悟。如是如是发生胜喜。由生胜喜复乐观谛。如人掘地获宝生喜。由生喜故复乐更掘。故喜于觉随顺力增。要由轻安息诸事务。及由舍力令心平等。方能于境审谛觉察。故立安舍在觉支中。云何此三不顺于道。速疾运转是圣道义。此于速运少有相违。并能令心安隐住故。何缘于道立寻戒支。于觉支中非亦立彼。彼偏顺道不顺觉故。云何顺道且见道中寻策正见。令于上下八谛境中速疾观察。戒能为毂成见道轮。令于谛中速疾回转。故寻及戒俱立道支。此复云何不顺于觉。且寻于谛不寂静转。于圣谛理寻求相故。觉已见谛安静而转。故寻于觉少有相违。觉是相应有所缘境。所依行相戒此相违。故于觉支不建立彼。通运名道不可为例。何缘觉分不摄圣种。分别论者许觉分摄。故彼宗建立四十一觉分。我许摄在念住等中。而不立为别觉分者。以诸觉分在家出家。俱能受行及有欣乐。圣种唯有诸出家人。受行欣乐在家有乐。必无受行故不别立。有余师说。若许圣种总是无贪如前已释。若许第四体即是勤。在觉分中无劳征难。何缘证净非觉分摄。实亦摄在念住等中。而不立为别觉分者。以诸觉分进修义增。数习方能证菩提故。四种证净证得义增。见圣谛时渐顿得故。由此证净非觉分摄。有余师说。此即信戒随应亦在觉分中摄

说一切有部顺正理论卷第七十一阿毗达磨顺正理论卷第七十二

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩贤圣品第六之十六

修觉分时必获证净。此有几种依何位得。实体是何法有漏无漏耶。颂曰

  证净有四种　　谓佛法僧戒
  见三得法戒　　见道兼佛僧
  法谓三谛全　　菩萨独觉道
  信戒二为体　　四皆唯无漏

论曰。经说证净总有四种。一于佛证净。二于法证净。三于僧证净。四圣戒证净。且见道位见三谛时。一一唯得法戒证净。见道谛位兼得佛僧。谓见苦时得圣爱戒及法证净。于何等法如何而得法证净耶。谓唯于苦达唯有法。无实有情生决定信。如是次第见集谛时。亦唯如前得二证净。达唯集法能为苦因。无内士夫生决定信。从此无间见灭谛时。亦唯如前得二证净。达唯灭法是真涅槃。诚可遵求生决定信。从此次后见道谛时。兼于佛僧得二证净。于佛相续诸无学法。得佛证净于僧相续。学无学法得僧证净。兼言为显见道谛时。亦得圣戒及法证净。达唯道法是证灭因。诚可遵求生决定信。然所信法略有二种。一别二总。总通四谛别唯三谛。全菩萨独觉道。菩萨道者唯有学法。独觉道者通学无学。若无漏信缘别法生名不杂缘。于法证净若无漏信。兼缘佛僧名为杂缘。于法证净故见三谛唯得二种。见道谛时具足得四。见道谛位为于现前得佛法僧三证净不。非皆现得。见道谛时现行总缘诸道谛故。应知现在唯有杂缘一法证净。乘此势力修得未来多刹那信。于中有别缘佛法僧。或有总缘二三宝者。诸别缘者名三证净。诸总缘者法证净摄。道类智时修八智故。亦得三谛法戒二种。道法忍等三刹那中。未来唯修道谛四种。由所信别故名有四。应知实事唯有二种。谓于佛等三种证净以信为体。圣戒证净以戒为体故唯有二。若七支戒实唯一者。如何觉分中实事有十一。应唯有十种或十六或多。以觉分中身语二业。说有差别及相有异。正命一种虽有别说。离身语业无别体相。依有别相前觉分中。说言实事有十一种。虽身语业一一有多。然种类同故各立一如四念住。前三证净谓慧与信。若不杂缘随所缘别。虽有多种而类同故。各立为一此亦应然。今证净中依身语业圣戒相等。及契经中同说不缺。不穿等故总立为一。随身语业类别分二。圣戒相同总立为一。故二与一无相违过。为依何义立证净名。如实觉知四圣谛理故名为证。正信三宝及妙尸罗俱名为净。由证得净立证净名。正信是心清净相摄可名为净。尸罗不是清净相摄宁立净名。此四皆是清净相摄。离不信垢破戒垢故。又此四种唯无漏故。离垢无漏故立净名。此四何缘次第如是。余三以佛为根本故。佛于正说有功能故。于彼证净立在最初。正说功能由悟法故。于彼证净立为第二。现观法藏唯圣僧故。于彼证净立为第三。观法藏能依圣戒故。圣戒证净立在最后。有言。佛是正说法师。是故最初立佛证净。佛何所说爱尽涅槃。是故第二立法证净。为谁说法为向果僧。是故第三立僧证净。僧依圣戒而得建立。是故第四立戒证净。有说。此四犹如导师。道路商侣及所乘乘。故说此四次第如是。经言。学位成就八支。无学位中具成就十。学位亦成正脱正智。何缘于彼不建立支。正脱正智以何为体。颂曰

  学有余缚故　　无正脱智支
  解脱为无为　　谓胜解惑灭
  有为无学支　　即二解脱蕴
  正智如觉说　　谓尽无生智

论曰。有学位中尚有余缚。未解脱故无解脱支。非离少缚可名脱者。非无解脱体可立解脱智。故有学位不立二支。谓立支名依胜助用。在有学位既有余缚。虽有解脱无胜助用。无胜解脱故彼胜智亦无。故此二支非在有学。无学已脱一切缚故。依内解脱生二智故。有胜助用理可立支。有学不然故唯成八。解脱体有二。谓有为无为。有为解脱胜解为体。无为解脱惑灭为体。前复有曰说学无学。依十圣身说名为学。依第八圣立无学名。唯有为中无学解脱。可得建立为解脱支。惑灭无为无支用故。支摄解脱复有二种。谓时不时有差别故。有说。慧心有差别故。应知此二即解脱蕴。经主此中意作是说。非唯胜解得此蕴名。若尔是何。谓真智力能永除遣贪及嗔痴。即心离垢名解脱蕴。以何为证。如契经言。云何解脱清净最胜。谓心从贪离染解脱。及从嗔痴离染解脱。于解脱蕴未满为满。已满为摄修欲勤等。此何所证。若唯胜解是解脱蕴。经不应言。谓心从贪离染解脱。及从嗔痴离染解脱。于解脱蕴乃至广说。由此证知即心离垢。名解脱蕴非唯胜解。此不成证。谓经亦说。云何名心清净最胜。谓离诸欲恶不善法。乃至安住第四静虑。于等持蕴未满为满。已满为摄修欲勤等。非心离垢即名等持。差别品中已广成立。如由欲等众行功能。令诸等持圆满而起。等持圆满名心清净。等持令心离秽浊故。非心离垢即名等持。如是亦由欲等势力。令解脱蕴圆满而生。解脱圆满说心解脱。解脱令心离秽浊故。非心离垢即名解脱。故我所立不违契经。又如增上慢相应邪胜解名邪解脱。不可说此即增上慢所染污心。如是离此慢相应正胜解名正解脱。不可说此即是离慢所得净心。又若此中即心离垢。名解脱蕴无别解脱。经不应前说心清净最胜。清净离垢义无别故。又此经说。解脱蕴言。理实亦非唯是胜解。意取胜解及同聚法。总说名为解脱蕴故。由此彼说非唯胜解。名解脱蕴于我无违。是故所言二解脱蕴。体是胜解其理极成。如是已说正解脱体。正智体者。谓显正见。如前觉说即尽无生。前名菩提今名正智。所言无学心解脱者。心于何位正解脱耶。为于未来现在过去。颂曰

  无学心生时　　正从障解脱

论曰。如本论说。初无学心未来生时从障解脱。且应思择本论此文。说未来言应成烦重。说生时言义已显故。此责不然。随问答故。谓先问者问无学心。于何世中正得解脱。是故今答言在未来。恐彼谓通未来一切。复为简别言是生时。或但应言生时解脱。然或有谓生时是现在。为遮彼故言未来生时。现是已生非生时故。或就相续立解脱名。则一切未来皆名正解脱。若就行世立解脱名。则唯生时名正解脱。为别显二义说未来生时。诸烦重言必显别义。理应推究无容非拨。依如是义故有颂曰

  文于义已足　　而复说余言
  非无义有文　　应思求别义

虽于此位诸所有蕴。皆得解脱而但说心。然不可言有缺减失。以心所等随从心故。染净法中心为主故。虽无有我而可于心。假说缚者脱者等故。若已说胜义已说余。或于此中如举喻法。举心一法令类思余。虽诸学心亦于生位从障解脱。而论但说初无学心生时脱者。据无余断证解脱故。又此唯说纯解脱故。此中有心是自性解脱非相续解脱。应作四句。有学无漏无学世俗。无学无漏余世俗心。如次应知四句差别。此中虽举正生刹那。而实未来皆得解脱。与正生者生障同故。依此势力所修未来。世俗善根亦得解脱。依净相续彼得生故。为重显示初无学心。未来生时从障解脱。是故本论复作是言。谓无间道现趣已灭。及解脱道现趣已生。尔时无学心名从障解脱。无间道者。谓金刚定并定眷属。临过去位立以现名。次后施设过去名故。趣已灭者显在正灭。邻次必入已灭位故。解脱道者。谓初尽智并智眷属。临现在位立以现名。次后施设现在名故。趣已生者显在正生。邻次必入已生位故。言尔时者。谓正灭生时。无学心者初尽智俱起。从障解脱者非唯烦恼障。色无色界感生果业。亦是尔时所脱障故。此业亦障阿罗汉得。由此古昔诸大论师咸作是言。业于得忍不还应果极为障碍。作如是释本论所言。则已释经心解脱义。道于何位令生障断。颂曰

  道唯正灭位　　能令彼障断

论曰。唯言为显正灭非余。如生未生道俱解脱。非灭已灭俱令障断。宁知正灭位能断障非余。以说道正生正从障脱故。道未生位未得解脱。道已生位已得解脱。俱不可立正解脱名。若道正灭时不能断障。如何道生位得正脱名。故正灭时道能断障。于前后位断用定无。如何未生亦名解脱。与正生者生障同故。如世现见开水路时。近水远水皆言离障。如是既见能断惑道身中已生。亦应可说近心远心皆得解脱。或如正起初无学心。有得正生名正解脱。如是彼类未来所修。无漏心等有得起故。定不生法尚得名为正得解脱。况当生者。此中所说正解脱言。显已解脱心今正得解脱。如是所说岂不相违。已解脱言据自性解脱。今解脱言据从障解脱。所望各异何义相违。或已解脱言据本有解脱。据在身行世说今解脱言。由此所言无相违失。诸行世者皆解脱耶。不尔要勤破生障者。有余师说。正解脱时亦得名为心已解脱。性是已舍烦恼障故理必应然。以解脱道依无烦恼相续转故。已出障故名已解脱。今行世故名今解脱。由此所说互不相违。经说。心从贪今得解脱。此所言解脱其义云何。为是令心与贪相离。为令贪性不复缘心。心名有贪为相应故。为所缘故。为得随故。若相应故应唯染心名得解脱。便违自宗说离贪心得解脱故。又若此法与彼相应。必定无容令此离彼。心应毕竟不解脱贪。若所缘故应染污心亦得解脱。理不应说贪相应心名为解脱。又彼贪性若缘此心。无暂不缘及余缘义。如何可说心脱彼贪。若得随故应有学心亦名有贪。依止贪得所随相续而现起故。正理论者作如是言。唯离贪心今得解脱。何等名曰有贪离贪二种心相。谓心若与贪相应者名有贪心。若不相应亦不为贪。同类因者名离贪心。乃至有痴离痴亦尔。既说离贪心得解脱。即立解脱唯不染心。然不染心总有四种。谓有漏中分善无记。及无漏中分学无学。言离贪心今解脱者。今解脱有二。谓行世相续诸有漏心。一切皆有相续解脱。加行得者亦许兼有行世解脱。诸无漏心一切皆有行世解脱。无学摄者亦许兼有相续解脱。诸有说言。若心悟入清净安住得解脱者。应知此辩行世解脱。诸有说心正善解脱者。应知此辩相续解脱。诸有说言阿罗汉果成就正智及正解脱。如是名为正解脱满。应知此辩自性解脱。由阿罗汉二解脱满。故说名心正善解脱。谓诸圣道皆名正性解脱。依彼名正解脱。诸阿罗汉证无缺减。故说彼心正善解脱。如是所辩二解脱中。诸染污心皆无容有。故彼不可名得解脱。外离染者可具说二。谓正解脱及邪解脱。然不可说心正解脱。由彼身中阙圣道故。亦不可言心不解脱。于当地染具足离故。又虽许彼有正解脱。不许名心正解脱者。非如圣者如理转故。谓若诸圣于五部结。能正分析渐次而断。是故说名心正解脱。外离染者于五部结不正分析。总以世道俱时而断故。虽断结而不应名心正解脱。然许名为正解脱者。以实能断诸邪缚故。如世尊言。贪等烦恼杂染心故令不解脱。由此证知贪等断故。不染污心名得解脱。如浊水灭后水生时。离浊澄清名为净水。如是与染俱行心灭。依净相续诸心转时。离缚而生名为解脱。未离染者不染污心。依有染身似变异转。如杂血乳不名解脱。诸有学心虽是无漏。而由相续不清净故。非如无学心名相续解脱。如依病眼有昧识生。眼无病时发明净识。而无眼识自性转过。如是烦恼所损相续。依之虽有善净识生。由烦恼力不明利转。离烦恼时识便明利。由彼相续顺烦恼生。故能依心不名解脱。若彼相续违烦恼生。此能依心方名解脱。故离染者身相续中。不染污心所依相续。昔被贪等之所损害。今离贪等故亦名今解脱。若与贪等相应之心。必不可令解脱贪等。故依正理诸论师言。唯离贪心今得解脱。分别论者作如是言。唯有贪心今得解脱。如有垢器后除其垢。如颇胝迦由所依处。显色差别有异色生。如是净心贪等所染。名有贪等后还解脱。圣教亦说心本性净。有时客尘烦恼所染。此不应理。刹那灭法如器垢除不应理故。谓垢与器俱刹那灭。不可转有垢即成无垢器。但缘合故有垢器灭。无垢器生名器除垢。又器与垢非互为因。容可计为垢除器在。贪心相望必互为因。如何从贪心可解脱。又道与惑有俱行过。谓彼不许实有去来。不可言心住彼解脱。若于现在有有贪心。道复现行令心解脱。岂不道惑俱时现行。过失必随不可得离。若谓道起断贪随眠。说与彼俱亦无有过。执随眠体非心相应。说何有贪心今时得解脱。又随眠体彼执非贪。以彼自言贪是缠故。为说何等名有贪心。而言今时从贪解脱。故彼所说朋助恶宗。又彼不审思引颇胝迦喻。理实彼体无异色生。隔颇胝迦见显色故。谓如彼体不揽他形。如是亦无揽他显理。而共于彼见异显色。隔彼见他所依显故。设许彼体有异显生。亦不应言颇胝迦宝。本体恒在有异色生。前余色俱颇胝迦灭。后与余色俱新生故。由此彼喻轻尔而立。所引至教与理相违。故应此文定非真说。且应征诘诸有染心。云何名为本性清净。彼言心性本是不染。若尔与染心所相应。尔时此心转成染者。是则烦恼应转成净。由与清净心体相应。此彼别因不可得故。又心性净理无被染。先后与俱皆不成故。谓若先有自性净心。后烦恼生方被染者。应净心体非刹那灭。若先有惑后净心生。被先已生惑所染者。应此惑体非刹那灭。若心与惑俱时而生。则不应言心本性净。有时客尘烦恼所染。许心与烦恼是一时。生一果一等流一异熟法。而说心本净烦恼为客尘。是戾正言非应理论。又于三世推征烦恼毕竟无力能。染净心过去未来无作用故。现在俱堕一刹那故。又若说心以净为性。后与烦恼相应位中。转成染者应失自性。既失自性应不名心。故不应说心本性净。有时客尘烦恼所染。若抱愚信不敢非拨言此非经。应知此经违正理故非了义说。若尔此经依何密意。依本客性密作是说。谓本性心必是清净。若客性心容有染污。本性心者。谓无记心。非戚非欣任运转位。诸有情类多住此心。一切位中皆容有故。此心必净非染污故。客性心者。谓所余心。非诸有情多分安住。亦有诸位非皆容有。断善根者。必无善心。无学位中必无染故。此心有染非唯净故。如言。河水本性澄清。有时客尘坌少令浊。如是但约心相续中。住本性时说名为净。住客性位容暂有染。此释与教正理无违。宁杂染心本性是净。至除染位名得解脱。岂不心起贪得所随皆名有贪心。非但贪俱者此不应理。非心随得可名有贪。补特伽罗可说随得名有贪故。谓诸得起得所得法。不令属余法但令属有情。故诸有情由得势力名为有戒。有贪者等心心所等法。则不然要与彼俱方名有彼。若异此者诸有贪心。亦应得名有嗔痴等。有嗔等者应名有贪。又寻得俱诸心心所。应皆可说名为有寻。则应毕竟无无寻唯伺定。又先已说先说者何。谓应有学心亦名有贪故。许亦何过。若是有贪应是所断。非真对治不应圣者为永断贪。修有贪心为真对治。又如佛说有寻伺言。依寻伺相应非彼得俱起。如是佛说有贪心言。唯依贪相应非贪得俱起。若尔有漏及有随眠应唯漏相应。随眠相应法此不必尔。以诸色等亦名有漏有随眠故。由二有言义通多释。谓随增漏与漏法同。俱得名为有漏法故。若于是处随眠随增。及随眠相应名有随眠故。又诸有为法随因缘生灭。不随因缘本性转变。若此法性随因缘生。即此法性随因缘灭。非贪势力令不染心转成染污。但有自性染污心起与贪相应。由贪相应得有贪号。心性是染本不由贪。故不染心本性清净。诸染污心本性染污。此义决定不可倾动。如契经中说有三界。谓断离灭。于前所说二解脱中此何为体。如是三界差别云何。颂曰

  无为说三界　　离界唯离贪
  断界断余结　　灭界灭彼事

论曰。断等三界即分前说。无为解脱以为自体。然三界体约假有异。若就实事则无差别。云何名为约假有异。谓离贪结名为离界。断余八结名为断界。灭余一切贪等诸结。所系事体名为灭界。何缘三界如是差别。谓有漏法总略有三。一者能系而非能染。二者能系亦是能染。三者非二。顺系染法断此三法所证无为。如次名为断等三界。有余师说。唯断能系别有无为断余不尔。彼说能系有缘八结。有缘爱结有缘余事。断此三种所证无为。如次名为断等三界。有余师说。唯断能染别有无为断余不尔。彼师说。爱有缘八结。有缘爱结有缘余事。断此三种所证无为。如次名为断等三界。随所系事别得择灭。故三说中初说为善。此中上座作如是言。但随己情作此分别。建立圣谛涅槃等中。唯以爱为门说断众惑故。如契经言。云何集圣谛谓爱后有爱。乃至广说。云何灭圣谛。谓诸爱断离灭。云何名涅槃。谓诸爱断离灭。若于色等已断欲贪。我说。彼名已断色等。一切行断名为断界。一切行离名为离界。一切行灭名为灭界。佛所说经皆是了义。无别意趣不应异释。此说不然。先已说故谓我先说。若就实事如是三界体无差别。然一一体假说为三。由此无为是无相法。假立名相必待有为。谓此无为一一自体。断八结得故名断界。离爱结得故名离界。灭彼蕴得故名灭界随所待异假立三名。理实无为体无三别。于一一体具三义故。虽于离爱所得义中。世尊亦言是断是灭。然依近治唯说离声。虽灭诸蕴所得义中。契经亦说。是断是离。而诸经中多言蕴灭。故于此义唯说灭声。虽断余结所得义中。契经亦言。是离是灭。然离灭名别目前二。故于此义唯说断声。或此无为随所系事有多种故。体实有多三界由斯体实各别。然依合立一涅槃性。故说三界展转相即。是故经说。一切行断名为断界。乃至广说。理实此经定非了义。非一切行皆是应断。亦非皆是所应离事。然此经说。皆断离言。故知此经待别意说。若谓余处已简别言。诸有漏法一切应断。此虽总说一切行言。准彼即知此唯有漏。故无此经非了义失。此不成救。筏喻经中说。无漏道亦可断故。如言我说筏喻法门。法尚应断何况非法。不可由此便作是言。无漏行断亦名断界。勿说断界即二界体。圣道亦应是所离事。以所离事唯贪所缘。故彼所言经皆了义。无别意趣理定不然。现见此经别意说故。彼复于此异门说言。若从诸行贪爱永断。诸行尔时皆名断故名为断界。如契经说。若于色等已断欲贪。我说彼名已断色等。若于诸行烦恼不生。诸行尔时从贪得离故名离界。即一切行不复转时名为灭界。如是上座于断等三。建立差别极为杂乱。如贪断故色等名断。如是亦应由贪离故色等名离。由贪灭故色等名灭。是则唯依贪爱永断说断离灭。如说于色无余断爱。离爱灭爱乃至广说。故从诸行贪爱断时。即应具成断离灭界。无劳复计余法离灭。又于诸行烦恼不生。诸行离贪既名离界。爱余烦恼所以不生。由诸行中烦恼已断。何缘不许亦名断界。此不生法有离界名无灭界名斯有何理。诸不生法最应名灭。以契经言由无明灭诸行灭故。又涅槃时诸行不转既名灭界。未涅槃时诸烦恼灭宁非灭界。要由离爱余烦恼断。行方不转名般涅槃。应灭界中有断离界。如是三界应无差别。若谓此三虽复杂乱由少因故。无为界中约分位殊立三界别。何缘不许对法诸师。如前所明三界差别。若假若实俱无乱故。是故上座率自妄情谤斥我宗。言随己见如是自爱憎背他言。谈正理时不应收采。准此已释诸契经中。断离灭想三相差别。或初业地我当断想名为断想。若离染地我正断想名为离想。若已办地我已断想名为灭想。或于已受蕴重担中。见不舍过起欲舍想名为断想。以舍与断名差别故。若于余蕴不复生中见胜功德。起欲求想名为灭想。不生与灭名差别故。既得离染清净相续。于诸蕴法无所顾恋。于般涅槃见静妙想名为离想。无恋与离名差别故。若事能厌必能离耶。不尔云何。颂曰

  厌缘苦集慧　　离缘四能断
  相对互广陜　　故应成四句

论曰。唯缘苦集所起忍智。说名为厌余则不然。四谛境中所起忍智。能断惑者皆得离名。广陜有殊故成四句。有厌非离。谓缘苦集不令惑断所有忍智。缘厌境故。非离染故。应知此中先离欲染。后见谛者苦集法忍。及见道中苦智集智。但名为厌缘厌境故。忍不名离惑先断故。智不名离非断治故。并修道中加行解脱胜进道摄。苦智集智但名为厌缘厌境故。不名为离非断治故。有离非厌。谓缘灭道能令惑断。所有忍智能离染故。缘欣境故。应知此中未离欲染。入见谛者灭道法忍。及诸所有灭道类忍。并修道中无间道摄。灭智道智但名为离。是断治故不名为厌缘欣境故。有厌亦离。谓缘苦集能令惑断所有忍智。应知此中未离欲染。入见谛者苦集法忍。及诸所有苦集类忍。并修道中无间道摄苦智集智。有非厌离。谓缘灭道不令惑断所有忍智。应知此中先离欲染后见谛者。灭道法忍及见道中灭智道智。并修道中加行解脱胜进道摄。灭智道智

说一切有部顺正理论卷第七十二阿毗达磨顺正理论卷第七十三

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩智品第七之一

如是已依诸道差别。建立贤圣补特伽罗。所依道中作如是说。正见正智名无学支。故于此中应审思择。为有慧见非智。及有慧智非见。而别建立见智二支。亦有云何。颂曰

  圣慧忍非智　　尽无生非见
  余二有漏慧　　皆智六见性

论曰。慧有二种有漏无漏。唯无漏慧立以圣名。此圣慧中八忍非智性。所以者何。非决断性故唯决断义是智义故。如何八忍不能决断。自所断疑得随相续生故。或求见境意乐止息。加行奢缓说名为智。诸忍正起推度意乐。加行猛利故非智摄。而名见者推度性故。尽及无生二智非见性。推度意乐一向止息故。所起加行极奢缓故。而名智者决断性故。所余皆通智见二性。已断自疑推度性故。谓前八忍尽无生余。有学八智无学正见。一一皆通见智性摄。岂不忍余诸无间道。亦自所治惑得随生。无非正起推度意乐。加行猛利应非智摄。尽无生余解脱道等。此相违故皆应非见。此难不然。余无间道无自品疑得随相续生故。又彼唯见曾所见境。非如八忍极违智故。余解脱等非全息求。所起加行非极奢缓。以皆于后有所作故。由此一切皆通二种。并具推度决断用故。诸有漏慧皆智性摄。于中唯六亦是见性。谓五染污见世正见为六。有余师说。能发身语五识所引。及命终时意识相应。善有漏慧亦非见性。外门转故如能引故。势力劣故。此亦不然。不应许故。非决定故。契经说故。谓不应许唯内门转。方是见性勿圣慧中。外身命住非见性摄。然契经说。于外身循身观是见性摄。亦非决定如五识身。所引意识如是性转。以彼善等所引意识。有时亦是不善等故。由此不应所引意识同。能引五识是无分别性。如契经说。有命终时得正见俱善心心所。故说所有意地善慧。皆见性摄于理为善。如是所说圣有漏慧。皆择法故并慧性摄。智有几种相别云何。颂曰

  智十总有二　　有漏无漏别
  有漏称世俗　　无漏名法类
  世俗遍为境　　法智及类智
  如次欲上界　　苦等谛为境

论曰。智有十种摄一切智。一世俗智。二法智。三类智。四苦智。五集智。六灭智。七道智。八他心智。九尽智。十无生智。如是十智总唯二种。有漏无漏性差别故。如是二智相别有三。谓世俗智法智类智。前有漏智总名世俗。瓶衣等物性可毁坏。显在俗情故名世俗。此智多取世俗境故。多顺世间俗事转故。从多建立世俗智名。非无取胜义顺胜义事转。然是爱境无胜功能。息内众惑故非无漏。或复出世引发世间得世俗名。体即无智智随属彼得彼智名。意显此名目有漏智。有说。诸趣名为世俗。此智多是往诸趣因。从果为名名世俗智。有说。此智无始时来。生死身中显现而转。由此故立世俗智名。或诸有中随流无绝名世俗智。以一切时随顺诸有相续转故。或复此智于一切境。能遍映发得世俗名。独能遍缘一切法故。后无漏智分为二种。法类二名所目别故。此二名义如前已释。然有师释。类谓比类以所现见事比不现见境。比量所摄得类智名。此释不然。说实见故。谓非比量智可立实见名。诸契经中总说法类。若如实见苦则定见非我。于四圣谛如实见故。能如实见四圣谛故。有如是等无量契经。又圣位中等决定故。谓见迹者等决定知诸行非常。诸法非我涅槃寂静。非真现见可与比知等是决定。谓以此类彼名为比知。彼非决定然亦有异故。由此真见与比度知。理不应言等是决定。非诸圣智有比度理。故有智者必不应言。有圣谛境比智所证。又圣应无缘灭智故。谓若类智比智摄者。则应缘灭法智亦无。以灭总非现见事故。然许现量总有三种。依根领纳觉慧别故。依根现量。谓依五根现取色等五外境界。领纳现量。谓受想等心心所法正现在前。觉慧现量。谓于诸法随其所应证自共相。此中若就依根领纳。说类智境非现见事。则灭法智理亦应无。灭非依根领纳境故。若就觉慧则不应言。类智所缘是比智境。是故一切如理所引。实义决择皆现量智。类智既然故现量摄。是名二智相别成三。定心相应圣行相转。有漏无漏二智何别。无漏于境行相明利。彼有漏智与此相违。如朅地罗余木二炭。于所烧炼势用不同。及胜劣香能熏用别。炎铁草火热势有殊。二智相望差别亦尔。或俗智后起增上慢。无漏不然故有差别。又世俗智与法类智。境有宽陜故有差别。谓世俗智遍以一切有为无为为所缘境。以契经说有世俗智能遍知苦。广说乃至遍知虚空非择灭。故亦有以非我行相。总缘一切法为境。以契经说诸行非常。一切法非我涅槃寂静故。然有经说。能以正慧观一切法为非我者。虽一切法实皆非我。而此一切声非总目。诸法唯目苦谛所摄法尽故。次复言此能厌苦。有余于此作是释言。此慧实能缘一切法。然此行相本为厌果。故偏依彼说厌苦言。如为烧舍而纵于火。然火起时亦烧余物。此不应理。此经复言此道力能得清净故。闻思二慧亦能遍缘。作一切法非我行相。此道岂能得清净果。若谓说此能得清净。不言即此是能清净故无有过。理亦不然。如遮余道说此言故。如契经说。唯有此道能得清净更无余道。岂可于彼亦作是言。能得清净非是能净。故知此经说以正慧。观一切法为非我者唯目苦谛。所摄诸法非收余法说一切声。如言诸行皆非常苦。而非圣道是苦非常。故诸行言唯遍苦谛。此亦应尔唯观苦境。起非我行非观余谛。除此以外必应别有。总观诸法非我行相。诸观行者现所知故。谓观行者必应先修。观一切法非我行相。净治身器令有堪能。依之趣入缘三义观。若不尔者一合我相。所扰乱故应不能修。建立诸法无相杂观。法智但缘欲界四谛。以本论说法智云何。谓缘欲界系诸行无漏智。缘欲界系诸行因无漏智。缘欲界系诸行灭无漏智。缘欲界系诸行能断道无漏智。及缘法智缘法智地。无漏智是名法智。岂不法智缘四谛境。何故复言及缘法智。缘法智地无漏智耶。此二亦缘道谛为境。以前所说缘欲界系诸行。能断道无漏智言。不能目一切缘道法智。但说能缘能断道故。为摄缘余加行解脱胜进道摄法智为境。及已离欲身中所起法智法忍。为境法智。复说缘法智。缘法智地言。或前所言缘断道智。但目缘未至能对治。欲界见修所断为境法智。为摄缘余五地法智品。为境法智复说后二言。若尔彼文应作是说。缘欲界诸行对治无漏智。若作是说总摄能缘。一切法智品为境法智尽。以对治言目多义故。不尔应有非爱过故。谓缘色界系为境。无漏智亦应名法智。有色界行是欲界行对治摄故。岂不所言缘欲界行能断道智。亦有此失彼无此失。能断道言已遮色界欲对治故。谓此依谛辩法智境。道言即显是道谛摄。非汝所说亦有道言。故此过失在汝非我。又设许彼更置道言。亦不能摄诸法智尽法智通能治三界故。又亦应许缘类智品诸无漏智是法智摄。类智品亦为欲远分对治。许对治言目多义故。由此本论所说无失。类智能通缘上二界四谛。由此三智境有差别。即于如是三种智中。颂曰

  法类由境别　　立苦等四名
  皆通尽无生　　初唯苦集类

论曰。法智类智由境差别。分为苦集灭道四智。何缘俗智亦缘苦等。作苦等行相而非苦等智。由彼先以苦等行相观苦等已。后时复容观苦等境为乐等故。又得如是世俗智已。后缘谛疑容现行故。如是六智若无学摄。非见性者名尽无生。此二初生唯苦集类。以缘苦集六种行相。缘有顶蕴为境界故。金刚喻定若缘苦集。与此境同缘灭道异。若尔岂不至教相违。如说。于尽有初智生。从此无间能自了达无违教失。此于尽言是有第七声非境第七故。谓有烦恼无余尽故。有初智生非此智生缘尽为境何所违害。彼言意显有惑身中。无此智生要有惑尽。于前所说九种智中。颂曰

  法类道世俗　　有成他心智
  于胜地根位　　去来世不知
  法类不相知　　声闻麟喻佛
  如次知见道　　二三念一切

论曰。有法类道及世俗智。成他心智。余则不然。岂不道智离法类无。应但言三成他心智。理实如是为显他心智。但知同类境故作是言。谓为显成此法类智。知他无漏心心所法。是道智摄非苦集智。以无漏智决定不能。知他有漏心心所故。他身无漏心心所法细故胜故。非己有漏他心智境其理可然。何缘己身无漏他心智。不能知他有漏心心所。于有漏境无漏智生。行相所缘异此智故。谓无漏智缘有漏时。必是总缘厌背行相。是故决定不能别缘他心心所成他心智。以诸圣智缘有漏时。必于所缘深生厌背。乐总弃舍不乐别观。缘无漏时生欣乐故。既总观已亦乐别观。如有见闻非所爱事。总缘便舍不乐别缘。于所爱中则不如是。总见闻已亦乐别缘。是故于他有漏心等。必无圣智一一别观。成缘有漏心无漏他心智。以他心智决定于他心心所法别别知故。岂不亦有三念住摄苦集忍智。虽有而非但缘一法缘多体故。又他心智有决定相。谓不知胜去来二世。并法类品不互相知。胜复有三。谓地根位。地谓下地智不知上地心。义唯能知自地下地。根谓信解时解脱根智。不知见至不时解脱心。位谓不还声闻应果独觉大觉。前前位智不知后后胜位者心。义唯能知自下根位。然他心智及所知境。根地既殊知亦有异。所知有漏心心所法。曾未曾得各有十五。谓欲四静虑各下中上根能知。但除欲界三品曾未曾得各有十二。所知无漏及彼能知。皆除欲三各有十二。且诸有漏曾未曾得。下根所摄他心智生。随其所应能知下地三根心品。自地下根中品亦知自地中品。上品总了自下地三。无漏下根他心智起。唯知自地下地下根。中亦知中上兼知上。何缘有漏无漏智生。知下地心多少有异。有漏三品。可一身成。无漏随根立圣者别。尚无有一成二品根。况有成三故有差别。如何说一补特伽罗成九品道断九品惑。此道差别非根有异。由因渐长后道转增。如次能令多品惑断。或诸种性各有九品。成一九品必不成余。故前后言无相违失。故依上地起下根心。有上根心依下地起。地根互胜必不相知。地位位根相对亦尔。此他心智不知去来。本为知能缘心心所法故。法类二品不互相知。此二如次以欲上界。全分对治为所缘故。此他心智见道中无。总观谛理极速转故。然皆容作他心智境。三乘圣者起此智时。中下二乘必须加行。声闻加行或上或中。麟喻但须下品加行。佛无加行随欲现前。若诸有情将入见道。声闻独觉预修加行。为欲知彼见道位心。彼诸有情入见道位。声闻法分加行若满。知彼见道初二念心。若为更知类分心故。别修加行至加行满。彼已度至第十六心。虽知此心非知见道。是故说彼唯知二念。麟喻法分加行若满。知彼见道初二念心。若为更知类分心故。别修加行至加行满。知彼第八集类智心。有余师言。知第十五。有说麟喻知四刹那。谓初二心第八十四。此言应理。所以者何。许从知初二念心已。唯隔五念知第八心。若复更修法分加行。经五念顷加行应成。何不许知第十四念。有余亦说知四刹那。谓初二心第十一二。佛于一切殊胜功德。随欲现前心自在故。于十五念能次第知。以佛世尊三无数劫。精勤修习无量资粮。故获难思殊胜妙智。具大势用随欲能知。虽此智生亦知心所。然修加行本为知心。如空处等名他心智。胁尊者曰。引此智生要先知心后方知所。从初但立他心智名。引此智时修何加行。先应观察身之显形。所乐言音表心差别。谓彼行者初修业时。为欲审知他心差别。先审观察自身显形。所乐言音因何有别。遂知显等差别由心。次复审观他身显等。亦由心异有差别生。由此后时离欲身意。调柔清净引胜定生。依定发生有威德智。此智真实照见他心。如明珠中种种色缕。差别之相了然可得。是名修世俗他心智加行。若修无漏他心智时。以观非常等苦智为加行。此加行位通缘色心。至成满时缘心非色。又加行位缘自他心。至成满时缘他非自。尽无生智二相何别。颂曰

  智于四圣谛　　知我已知等
  不应更知等　　如次尽无生

论曰。如本论说云何尽智。谓无学位若正自知。我已知苦我已断集。我已证灭我已修道。由此所有智见明觉。解慧光观是名尽智。云何无生智。谓正自知我已知苦不应更知。广说乃至。我已修道不应更修。由此所有广说乃至是名无生智。由本意乐二智转时。力能引起如是解智。非于无漏二智转时。作如是解无分别故。谓出二智后得智中。方作如是二类分别。此二分别二智后生。是尽无生力所引故。此二俗智是彼士用果。故举二果表二智差别。理必应然说由此故。依为此义说由此声。即是为此所有智义。不尔应言如是所有。诸观行者本修行时。定起如斯要期意乐。谓我当证阿罗汉时。要应起此自审察智。故今出观此智必生。为令此生所起之智。随应建立尽无生名。即后智生所依止义。故言此释理必应。然岂不二智非见性摄。如何乃言智见明等。有作是释乘言便故。然实二智是于后时。所起见因故亦名见。谓离尽智后出观时。必不现行审察见故。先不动姓及后练根。得不动时离无生智。后审察见亦不现行。故此见名从果而立。或如见故假立见名。如立光名现照转故。光是色处智体非光。照用如光名光无失。如是二智实非见体。现照如见立以见名。或诸世间决解名见。如言我见齐尔所时。此日月轮当被侵蚀定故名见。此亦应然即由此因。经作是说解脱智见蕴。谓尽无生智要有解脱。此智得生以智为体名解脱智。由前因故亦得见名。故此蕴名解脱智见。何缘本论作如是言。见云何且诸智亦是见。然有见而非智。谓八忍岂不应说见外有智。如说。智外有别见耶。应知此中说亦声故。见外有智其义已成。若谓不然彼论应说所有智皆是见。既言亦是明知有非。谓尽无生俗智一分。然智外见分明显说。不分明说见外智者为遮僻执。譬喻部师。说于下智立忍名想。或如前说有多种因。尽无生等亦得名见。何缘论说无生智中。复作是言我已知苦等。理但应说不复更知等。二行不应俱时转故。若次第转前与尽智。无差别故不应重说。应知此说意为遣疑。恐有生疑如时解脱。先起尽智后得无生。如是应许不时解脱。先起无生后得尽智。为显一切尽智先起。故复先说已知等言。或先但言我已知等。显时解脱唯有尽智。后复重言我已知等。显不时解脱尽后起无生。故虽重言而无有失。无生智者何谓无生。正理师言。谓非择灭有无生故。此智得生智托无生名无生智。灭虽常有而得非常。得彼灭时此智方转。要由得起方名有灭。于有灭位此智方生。或无生言因彼灭得。如涅槃得亦名涅槃。经说以涅槃置在心中故。有彼得位此智方生。智托无生名无生智。有余于此作是难言。若托无生名无生智。则无生智缘非谛法。是则所说违害自宗。无漏慧生唯缘四谛。彼不审察设此难词。我上已言于出观后。方起如是分别智故。或此托声是有第七。非境第七如尽智故。或许此智缘无生得。此苦谛摄非非谛故。如是十智互相摄者。谓世俗智摄一全一少分。法类智各摄一全七少分。苦集灭智各摄一全四少分。道智摄一全五少分。他心智摄一全四少分。尽无生智各摄一全六少分。何缘二智建立为十。颂曰

  由自性对治　　行相行相境
  加行辨因圆　　故建立十智

论曰。由七缘故立二为十。一自性故立世俗智。以世俗智为自性故。二对治故立法类智。全能对治欲上界故。三行相故立苦集智。此二智境体无别故。四行相境故立灭道智。此二行相境俱有别故。五加行故立他心智。非此不知他心所法。本修加行为知他心。虽成满时亦知心所。而约加行故立他心智名。加行如前已具分别。六事辨故建立尽智。事辨身中定初生故。七因圆故立无生智。一切圣道为因生故。谓有尽智非无生智为因故生。无无生智不以尽智为因故起如上。既言法智类智全能对治欲上界法。为有少分治上欲耶。颂曰

  缘灭道法智　　于修道位中
  兼治上修断　　类无能治欲

论曰。修道所摄灭道法智。兼能对治上界修断。望欲界法四谛法智。全能对治于欲见断法智。亦为持对治故。能治所治皆得全名。望上俱缺俱名少分。何缘唯有灭道法智。兼治上界非苦集耶。所缘寂静出离同故。谓欲上灭及能治道。展转相望相无别故。以诸择灭皆善皆常。一切圣道皆能出离。所缘苦集欲上不同。少多细粗上下别故。又苦集智缘所厌境。无容厌彼于此离贪。理厌此地时断此地烦恼。若许异厌异离贪应异离贪异解脱。若许不厌色无色界。而能离彼界贪习厌。离贪理则应坏。灭道二智不缘厌境。缘下治上亦无过失。又如不净观及欣涅槃欲。谓不净观缘欲界境。唯能令心厌背欲界。欣涅槃欲现在前时。普能令心厌背三界。如是缘欲苦集智生。唯能令心离欲界染。缘欲界法灭道智生。普能令心离三界染。故许灭道法智品增。乃至得成金刚喻定。由此大圣妙善了知。依全治门立法类智。法智少分有治上能。类智必无能治欲界。要于自界所作已周。方可兼为他界所作。非诸类智已事成时。他事未成有须助义。故无类智治欲界法。岂不第十六道类智生。乘此便则能治欲界惑。将断欲惑类智不行。设许现行由自界障所拘碍故。必无势力能助成他。法智所作由此类智无能治欲。于此十智中谁有何行相。颂曰

  法智及类智　　行相俱十六
  世俗此及余　　四谛智各四
  他心智无漏　　唯四谓缘道
  有漏自相缘　　俱但缘一事
  尽无生十四　　谓离空非我

论曰。法智类智一一具有。非常苦等十六行相。十六行相后当广释。世智有此及更有余。能缘一切法自共相等故。谓世俗智或有具作十六行相。如于暖顶忍等位中。或有不具如世第一。重三摩地及现观边世俗智等。或有别作非圣行相。如不净观息念慈等。俗智此等行相无边。苦等四智一一各有缘自谛境四种行相。他心智中若无漏者。唯有缘道四种行相。此即道智一分摄故。若有漏者取自所缘。心心所法自相境故。如境自相行相亦尔。故此非前十六所摄。如是二种于一切时。一念但缘一事为境。谓缘心时不缘心所。缘受等时不缘想等。若尔何故薄伽梵说如实了知有贪心等。非俱时取贪等及心。如不俱时取衣及垢。有贪心等三。对心相心解脱处已辩差别。毗婆沙师作如是说。聚心者谓善心。此于所缘不驰散故。散心者谓染心。此与散动相应起故。经主谓此不顺契经。经言此心云何内聚。谓心若与惛眠俱行。或内相应有止无观。云何外散。谓心游涉五妙欲境随散随流。或内相应有观无止。西方者释乃顺契经。谓眠相应说名为聚。余染污者名为散心。而无染眠俱心通聚散失。不许眠俱染名为散心故。不审经意妄为褒贬。此彼二经意各别故。此经中说有贪等心。为令知心染净品别。谓为如实了知诸心。黑品白品差别理趣。说有贪心离贪心等。彼经中说聚心散心。为令了知修神足障。由彼经说自审己心。勿太沉勿太举勿内聚勿外散。谓彼行者修神足时。应自审察修神足障。此心懈怠此心掉举。此心惛眠此于色等非理作意所引流散。此彼经意所为既殊。不可引彼经遮释此经相。彼经但说修神足时。心于内外太聚散失。不欲分别心染净相。此经所说与彼相违虽诸染心皆有怠等。为显诸染过失差别。随其增位立沈等心。立策等心应知翻此。故我宗释符顺契经。亦善分别诸心异相。傍论已了应述本义。如何他心智有行相所缘。而说不观所缘行相。以不观他心所缘行相故。谓但知彼有染等心。不知彼心所染色等。亦不知彼能缘行相。不尔他心智应亦缘色等。又亦应有能自缘失。无漏他心智应缘苦等境。是则亦应许空无相相应。既不许然知不观二。诸他心智有决定相。谓唯能取欲色界系。及非所系他相续中。现在同类心心所法。一实自相为所缘境。空无相不相应尽无生所不摄。不在见道无间道中余所不遮。如应容有尽无生智除空非我。各具有余十四行相。由与出观心转相违。故在观中无二行相。谓从二智出观后时必自了知我生尽等。此中意说尽无生智虽是胜义而涉世俗。我生尽等是世俗故。空非我是胜义必涉胜义。此观后决了知空非我。故由此二智离空非我。为有无漏。越此十六更是所余行相摄不。颂曰

  净无越十六　　余说有论故

论曰。对法诸师有一类说。无越十六无漏行相。离此所余不可得故。岂不有说尽无生智。必自了知我生尽等。此不相违前已说故。谓前已说无漏观。后世俗智中作此行相非无漏智。此行相转由尽无生引起俗智。推功于本言彼了知。故许此智离空非我。本意乐力令此二智。后必引生我生尽等。非由观内此行相转。令于后时起此行相。我等行相观内虽无。而由不愚自证解脱。义言此位必已应有。我生尽等行相势分。由先世俗行相引生。能引后时世俗行相。故离十四无尽无生。若谓此应言离十六无者。此不应理除十四余有尽无生非极成故。谓离十四有依密说。计我生尽等为尽无生智。遮彼故说离十四无。余不极成宁对遮此。若尔既有无漏他心智。应越十六有无漏行相。谓他心智皆以一实自相为境。道等行相皆以聚集共相为境。彼此既殊知离十六。决定别有无漏行相非定许故。所难不然。谓我所宗非决定许。共相行相但缘聚集。许有受心二念住故。如观一受体是非常。此智生时以共相行相。观一实自相为境极成。如是宁不许无漏他心智。以共相行相缘一实自相。谓知他心是真道等。即缘一实是道等相。若谓应如受心念住。总缘三世所有受心。为非常等共相行相。无漏他心智亦总缘三世。他无漏心等为道等行相。便违自宗他心智起。唯缘现在一实自相。此亦不然加行异故。此智加行为欲知他现能缘心。有贪等别修非常等。念住加行为总厌背。诸有漏法由前加行势力有殊。至成满时现总缘别。是故无有应相例过。若谓非常非受自体。故应观受为非常时。非缘一实自相为境。宁可引此喻他心智。则彼应许受非非常。不应于受起非常观。如受与心其体各别。必定无有观受为心。虽即观受以为无常。而无一物有多体过。领纳无常体无别故。如损益等非离领纳。所余行相余法亦然。若尔应与至教相违。如说。于身住循身观应言法智。乃至广说。又说。观老死应言是四智俱不相违。且初所说非显法智等。离十六行相住循身观。观身为身但如实观。为非常等我先已许共相行相。亦以一实自相为境。故彼所说于我无违。后老死声总目取蕴。观五取蕴为非常等。是四智摄何所相违。若尔如说受乐受时。如实了知受于乐受。如何是法类世俗道智摄。此应思择受现在时。必不了知不自缘故。亦不可说了知去来。去来不名受乐时故。而契经说。受乐受时如实了知受于乐受。故知此说别有密意。释此密意如尽无生。谓出观后时方起此行相。故无漏行相越十六外无。有一类言有越十六。本论说故如本论言。颇有不系心能了别。欲界系法耶。曰能了别。谓非常故。苦故空故非我故因故集故生故缘故。有是处有是事如理所引了别。此证不成迷论意故。论显不系行相众多。于中有缘欲界系者。依容有说有是处言有是事言。显无颠倒即由此故余无此言。谓彼论中复作是说。颇有见断心能了别欲界系法耶。曰能了别。谓我故我所故。断故常故无因故无作故。损减故尊故胜故上故第一故。能清净故能解脱故。能出离故惑故疑故犹预故。贪故嗔故慢故痴故。不如理所引了别。除此无容有余行相。由此不说有是处言。由皆颠倒转不言有是事。故净行相无越十六。理教无违不可倾动

说一切有部顺正理论卷第七十三阿毗达磨顺正理论卷第七十四

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩智品第七之二

所言行相有十六者。为但名别实亦有异。何谓行相能行所行。颂曰

  行相实十六　　此体唯是慧
  能行有所缘　　所行诸有法

论曰。有说。行相名虽十六实事唯七。缘苦谛境治四倒故名实俱四。缘三谛境。名四实一。如是说者。实亦十六所治所行相有别故。言所对治相有别者。为治常见故修非常行相。为治乐诸行故修苦行相。为治我所见故修空行相。为治我见故修非我行相。为治无因论故修因行相。为治自在等一因论故修集行相。为治转变因常因论故修生行相。为治知为先能生论故修缘行相。为治归自在为涅槃论。显诸蕴永灭是涅槃。故修灭行相。为治执自体所有解脱。是杂染惑苦不正见。故修静行相。为治执涅槃如被咒诅。遂致殄灭是弊坏论。故修妙行相。为治执解脱还退见故修离行相。为治执无解脱道。故修道行相。为治苦行是真道见。及谤真道是邪论。故修如行相。为治不修道生死自净。及世间离染是真道。故修行行相。为治尝遭不永离染道所诳惑。于真圣道亦不敬。故修出行相。言所行境相有别者。苦圣谛有四相。一非常二苦三空四非我。有生灭故非常。逼迫性故违圣心故苦。无主宰故空。违我相故非我。集圣谛有四相。一因二集三生四缘能生法故因。有多种故集。恒孳产故生。各别助故缘。灭圣谛有四相。一灭二静三妙四离。息众苦故灭。三有为相三火灭故静有余师说。众苦息故静。如说。苾刍诸行皆苦。唯有涅槃最为寂静。善故常故妙。一切灾患永解脱故极安隐故离。道圣谛有四相。一道二如三行四出。能通寻求诸法性相至解脱故道。无倒转故如。如实趣故行有余师说。定能趣故行。如说。此道能至清净。余见必无至清净理。一向趣故决能至故出。如是所治及所行境。相有别故实有十六。如是行相以慧为体岂不心心所皆名有行相。如是无慧与慧相应。如何可言慧有行相非有行相。唯慧相应心等皆名有行相者。是心心所等于所缘品类相中有能取义。若依唯慧得行相名。则慧之余心心所法。与行相等名有行相。如等漏故得有漏名。是与漏体同对治义。如是所余心心所法。等与行相行于所缘。是俱时行无前后义。或心心所有行相者。多如已知根总名有行相。或依无间亦说有声。如有所依故无有过。谓如心心所皆名有所依。意识相应诸心所法。与所依识亦俱时生识之所依。唯无间灭有行相理应知亦然。无间灭慧于现何能。此于现有能如无间灭意。若尔应受等得有受等名。许亦无违然非所辩。此中经主依附他宗作如是言。诸心心所取境类别。皆名行相理未必然。应思何等名心心所取境类别。若谓境相品类差别。一切能像理必不成。境有善常等众相差别故。或诸色法亦行相收色法亦能像余相故。若谓能取境差别相。则应五识行相不成。不能取境差别相故。有分别识方能取境青非黄等差别相故。然非所许故理不成。由此我宗所释为善。谓唯诸慧于境相中。简择而转名为行相。慧及诸余心心所法。有所缘故皆是能行。此能行名应唯目慧行相体故。余心心所既非行相宁是能行。若谓所余名能行者。以与行相相应起故。是则慧等与受相应应名能受。虽有此语而理不然。谓慧异门称为行相。能行即是取境别名。非能行言偏为诠慧。宁以受等体非行相。便作是难应非能行。如于境中慧能简择。便许说慧名为能行。既于境中想能取像。识能了等宁非能行。故能行名通目取境。故应受等亦是能行。所行名通一切有法。若实若假皆所行故。由此三门体有宽陜。慧通行相能行所行。余心心所唯能所行。诸余有法唯是所行。颂诸有言应随除一。随说一种义已成故。如世尊言一切法者。谓十二处唯此是有。故说诸法是所行言。已说所行唯是有法。或说有法是所行言。已说所行是一切法。诸假有法不离所依。亦随所依诸处摄故。为摄有尽俱说无失。已辩十智行相差别。当辩性摄依他依身。颂曰

  性俗三九善　　依地俗一切
  他心智唯四　　法六余七九
  现起所依身　　他心依欲色
  法智但依欲　　余八通三界

论曰。如是十智三性摄者。谓世俗通三性。余九智唯是善。依地别者。谓世俗智通依欲界乃至有顶。他心智唯依四根本静虑。不依近分静虑中间。此智所缘极微细故。谓依彼地道力微劣。不能了达他相续中。现在微细心心所法。亦不依无色无此加行故。又通性故余地非依。五通所依止观等故。法智通以六地为依。谓未至中间四根本静虑。不依余近分彼唯有漏故。亦不依无色此缘欲界故。所余七智九地为依。谓下三无色及前说六地总说如是。然有差别。谓此所说七种智中。类智决定依九地起。苦集灭道尽无生智。若法智摄六地为依。类智摄者通依九地。依身别者。谓他心智。依欲色界俱可现前。不依无色彼自无故。不起下地他心智者。此智随转色彼无容起故。法智但依欲界身起非上二界。入出此智诸有漏心唯欲有故。又法智随转色。所依大种唯欲系故。又此能治起破戒惑。破戒唯欲非上界故。余八智现起通依三界身。已辩性地身当辩念住摄。颂曰

  诸智念住摄　　灭智唯最后
  他心智后三　　余八智通四

论曰。灭智摄在法念住中。他心智后三摄。所余八皆通四。如是十智展转相望。一一当言几智为境。颂曰

  诸智互相缘　　法类道各九
  苦集智各二　　四皆十灭非

论曰。法智能缘九智为境除类智。类智能缘九智为境除法智。道智能缘九智为境。除世俗智非道摄故。苦集二智。一一能缘二智为境。谓俗他心。世俗他心尽无生智皆缘十智。灭智不缘唯以择灭为所缘故。十智所缘总有几法。何智几法为所缘境。颂曰

  所缘总有十　　谓三界无漏
  无为各有二　　俗缘十法五
  类七苦集六　　灭缘一道二
  他心智缘三　　尽无生各九

论曰。十智所缘总有十法。谓有为法分为八种。三界所系无漏有为。各有相应不相应故。无为分二种善无记别故。俗智总缘十法为境。法智缘五谓欲界二。无漏道二及善无为。类智缘七谓色无色。无漏道六及善无为。苦集智各缘三界所系六。灭智缘一谓善无为。道智缘二谓无漏道。他心智缘欲色无漏三相应法。尽无生智缘有为八。及善无为。颇有一念智缘一切法不。不尔。岂不非我观智知一切法皆非我耶。此亦不能缘一切法。不缘何法此体是何。颂曰

  俗智除自品　　总缘一切法
  为非我行相　　唯闻思所成

论曰。以世俗智观一切法。为非我时犹除自品。自品谓自体相应俱有法。何故不缘自体为境。诸对法者立此因言。诸法必无待自体故。此言意显诸法生时。随其所应待四缘性。随有所阙法则不生。不阙便生立为缘性。诸法无有阙自体时。故毕竟无阙不生义。宁可建立为所待缘。若谓体应如虚空等。由无障碍可立为缘。理亦不然。以虚空等望所生法。他性极成法为他缘理极成故。又由现喻显诸智生。必不能缘自体为境。谓见刀刃指端及肩。如次不能自割触负。又邪见他心智及念住苦智等。皆有建立不成过故。若谓如灯自他俱照智应尔者。理亦不然。灯之照体不成实故。谓显色聚差别名灯。眼识生因说名为照。闇相违故说为能坏。瓶等障因由有此故。瓶等可了名照瓶等。除假说外无实有照能照自体。犹如盐等唯彼自体如是转故。又若许灯是能照故。便许自照亦能照他。如是应许闇是障故。力能自障亦能障他。火能烧故自烧烧他。彼既不然灯云何尔。若谓灯力破障瓶灯。及了瓶灯二觉闇故应俱名照。理亦不然。闇与瓶灯合不合故。谓闇瓶合可曰障瓶。今虽有瓶而觉不起。由此说闇能障瓶觉。灯生闇灭瓶显觉生。故世说灯有照瓶用。曾无有闇与灯合时。勿不相违无相治失。故不可说闇能障灯。既无有灯不能生觉。亦不可说闇为觉障。故灯生时虽令闇灭。而不可说被照如瓶。复有何因执智知用。但如灯照非刀割等。谓见何理执智与灯。法喻冥然非与刀等故引灯喻为证力微。有作是言。智于自体不知自相共相。可知理亦不然。已辩自体不以自体为所缘故。于自自相既永不能取。则定无有以自为所缘。既非所缘宁取共相。故应于此立比量言。自相亦应为自体境。自体相故。犹如共相。或应共相非自体境。自体相故犹如自相。故缘共相理亦不成。又智现前若缘自体。应许自体亦是所依。若许自缘及自依者。则应自体能自建立。自建立故应许是常。常故应无能缘他义。又智所知应无别故。必无有智能缘自体。若谓自共相如次能所缘。理亦不然。前已说故。谓前已说既不自缘自相为境自体相故。亦不应缘共相为境。即由此理不缘相应。以与相应一境转故。许缘相应者便应许自缘。亦不能缘俱有法者。以俱有法极相近故。如眼不见扶眼根色。契经亦说一刹那智。不能顿知一切法境。如契经说。无有沙门婆罗门等。于一切法顿见顿知。义准唯渐此智唯是欲色界摄。无色界中虽有此类。而缘法少非此所明。此通闻思修所成慧。皆能除自品缘一切法故。然经主说非修所成。以修所成地别缘故。若异此者应顿离染。此不应理。言修所成唯地别缘非极成故。谓我宗许静虑地摄。修所成慧有能总缘。随所依身自上境故。厌下欣上方能离染。此既总缘唯欣行相故。于离染无有功能故。彼所言甚为非理。已辩所缘复应思择。谁成就几智耶。颂曰

  异生圣见道　　初念定成一
  二定成三智　　后四一一增
  修道定成七　　离欲增他心
  无学钝利根　　定成九成十

论曰。诸异生位及圣见道。第一刹那定成一智。谓世俗智。第二刹那定成三智。谓加法苦。第四六十十四刹那。如次后后增类集灭道智。诸未增位成数如前。故修位中亦定成七。如是诸位若已离欲各各增一。谓他心智唯除异生生无色者。然异生位及见道中。唯可成就俗他心智。道类智时具成二种。尔时初得不还果故。兼得无漏以成果体。余修位中皆具成二。生无色者便舍世俗。诸时解脱定成九智。谓加尽智。不时解脱定成就十。谓增无生。于何位中顿修几智。且应思择。何谓为修。谓习善有为令圆满自在。非染无记者无胜爱果故。非善无为者不在相续故。又无为无果故。已辩修义本问应答。且于见道十五心中。颂曰

  见道忍智起　　即彼未来修
  三类智兼修　　现观边俗智
  不生自下地　　苦集四灭后
  自谛行相境　　唯加行所得

论曰。见道位中随起忍智。皆即彼类于未来修。然具修自谛诸行相念住。何缘见道唯同类修。所作所缘俱定别故。有说。此种性先未曾得故。唯苦集灭三类智时。能兼修未来现观边俗智。于一一谛现观后边。方能兼修故立斯号。由此余位未能兼修。自谛所为未圆满故。有言。若此于法智位。修应说名为现观中俗智。经不应立现观边名。三位所修何胜何劣。若据相续后胜于前。因增长身起彼得故。若就界说上皆胜下。故前所修色界系者。界胜身劣后位所修。欲界系者界劣身胜。此有四句如理应思。道类智时何不修此。此智唯是见道眷属。彼修道摄故不能修。此意说言修。七处善为种子故。见道得生故见道生时说彼为眷属。或世俗智从无始来。于三谛中曾知断证。未曾修道故今不修。或由今时见真道故。伪道羞避故非所修。或现观边方修此智。道无边故此位不修。谓三谛中依事现观。容一行者总得其边。必无有能遍修道者。异根性道不能修故。于自根性虽容得修。百千分中不起一故。虽见道位未遍断集未。遍证灭而于当位断集证灭其事已周。道类智时迷道谛惑。诸对治道亦不遍修。以种性根有多品故。由此于三谛世尊说边声。如契经中说。有身苦边有身集边有身灭边。曾无经说有身道边。无能修道至边际故。此世俗智是不生法。于一切时无容起故。此起依身定不生故。谓随信行随法行身。容有为依引此智起。在见道位此无容生。故此依身住不生法。依不生故此必不生。若尔依何说有修义。依得修故说名为修。谓于尔时起得自在。余缘障故体不现前。即由此因说名为得。以证彼得起自在故。以有诸法得即现前如尽智等。或有诸法先得后现前如无生智等。或有诸法得永不现前如此智等。或有诸法不得而现前如外色等。无有情数法不得而现前故。虽不生而有修义。经主此中作如是诘。既不能起得义何依故所辩修。理不成立。如古师说修义可成。彼说云何由圣道力。修世俗智于出观后。有胜缘谛俗智现前。得此起依故名得此如得金矿名为得金。此但有言所诘等故。如何此智不现在前。言得起依说名为得。非得此依故可名此现前。勿此所依即此体故。若谓于后位见不见功能故有差别。亦不应理。所许起依不久住故。非起依已舍有此现前时。故舍起依必不现起。后如何见能起功能。诸有起依必可现起。有起依位宁不现前。既不现前起依宁有故。彼所说既不能起得。义何依为非理诘。自许不起亦名得故。随依何地见道现前能修未来自地下地。谓此俗智七地为依。即未至中间四静虑欲界。若依未至见道现前。能修未来一地见道。二地俗智至依第四见道现前。能修未来六地见道。七地俗智苦集边修。四念住摄灭边修者。唯法念住随于何谛现观边修。即以此行相缘此谛为境。谓若苦谛现观边修。即以缘苦四种行相。若欲界系缘欲界苦。色界系者缘上苦谛。若于集谛现观边修。即以缘集四种行相若欲界系缘欲界集。色界系者缘上集谛。若于灭谛现观边修。即以缘灭四种行相。若欲界系缘欲界灭。色界系者缘上灭谛。此世俗智唯加行得。即由见道加行得故。欲界摄者是思所成。色界摄者是修所成。非闻所成彼微劣故。智增故立智名。若并随行以欲四蕴。色界五蕴为其自性。次于修道离染位中。颂曰

  修道初刹那　　修六或七智
  断八地无间　　及有欲余道
  有顶八解脱　　各修于七智
  上无间余道　　如次修六八

论曰。修道初念。谓第十六道类智时。现修二智谓道及类。名异非体。未离欲者未来修六。谓法及类苦集灭道。离欲修七。谓加他心。有顶治故不修世俗。先已离欲入圣道者。何缘见道中不修他心智。以他心智游观德摄。依容豫道方有修义。见道位中为观谛理。加行极速故不能修。无间道中义亦同此。今第十六道类智时。容豫道收故修此智。断欲修断九无间道。八解脱道俗四法智随应现修。断上七地诸无间道。四类世俗灭道法智随应现修。断欲加行有欲胜进。俗四法类随应现修。此上未来皆修七智。谓俗法类苦集灭道。断有顶地前八解脱。四类二法随应现修。此于未来亦唯修七。然除世俗加他心智。断有顶地九无间道。四类二法随应现修。未来修法类苦集灭道六。断欲修断第九解脱。俗四法智随应现修。断上七地诸解脱道。四类世俗灭道法智随应现修。断欲修断第九胜进。断上八地诸加行道。俗四法类随应现修。断上七地有顶八品。诸胜进道俗四法类。及他心智随应现修。先所修道容现前故。此上未来皆修八智。谓俗法类四谛他心。四类不能断欲界染。苦集二法非上对治。何缘起彼治此智未来修。若许兼修非对治者。离有顶染等应兼修世俗。此难非理。唯同对治于未来修非所许故。谓亦许有相属故修。如见道中修世俗智。或由因力相资故修。如断欲时兼修四类。断上染位修苦集法。若断欲染不修类智。断上不修苦集二法。则渐次得不还果者。应无容起类智现前。阿罗汉应无起苦集。法智先所得者皆已舍故。先未得者非所修故由约种类。若先已得为同类因。力引等流智生此智。由先彼智引故于彼智类。复能为因故此智生。因力资彼虽非同治亦未来修。次辩离染得无学位。颂曰

  无学初刹那　　修九或修十
  钝利根别故　　胜进道亦然

论曰。无学初念谓断有顶。第九解脱若集类尽。随应现修缘有顶故。胜进九十随应现修。未来随应修九修十。谓钝根者唯除无生。利根亦修无生智故。次辩余位修智多少。颂曰

  练根无间道　　学六无学七
  余学六七八　　应八九一切
  杂修通无间　　学七应八九
  余道学修八　　应九或一切
  圣起余功德　　及异生诸位
  所修智多少　　皆如理应思

论曰。学位练根诸无间道。四法类智随应现修。未来修六四谛法类。似见道故不修世俗。能断障故不修他心。诸解脱道四法类智随应现修。未离欲者未来修六四谛法类。已离欲者未来修七。谓加他心。有余师言。解脱道位亦修世俗。诸加行道俗四法类随应现修。未离欲者未来修七。已离欲八。谓加他心。诸胜进道若未离欲。俗四法类随应现修未来亦七。若已离欲俗四法类及他心智。随应现修未来亦八。无学练根诸无间道。四类二法随应现修。未来修七四谛法类尽。不修世俗如治有顶。故五前八解脱四类二法随应现修。未来修八四谛法类他心及尽。四第九解脱苦集类尽随应现修。未来修九。最后解脱苦集类尽。随应现修未来修十。诸加行道现修如学。未来修九诸胜进道。钝者九智随应现修未来亦九。利者十智随应现修未来亦十。学位杂修诸无间道。四法类俗随应现修未来修七。诸解脱道唯四法类。加行增俗诸胜进道。又加他心随应现修未来皆八。无学杂修诸无间道现修如学。未来所修钝八利九。诸解脱道唯四法类。加行增俗随应现修。未来所修钝九利十。诸胜进道与练根同。学位修通五无间道。现修俗智未来修七。宿住神境二解脱道五加行道。现修俗智他心解脱法类道俗及他心智。一切胜进并苦集灭随应现修。此上未来皆修八智。无学修通五无间道。现修如学。未来所修钝八利九。解脱加行现修如学。未来所修钝九利十。诸胜进道与练根同。天眼天耳二解脱道。无记性故不名为修。圣起所余四无量等修所成摄。有漏德时现在皆修一世俗智。有学未来未离欲七已离欲八。无学未来钝九利十。除微微心此于未来唯修俗故。若起所余无漏功德静虑摄者。四法类智随应现修。无色摄者唯四。类智随应现修。未来所修同前有漏。异生离染现修俗智。断欲三定第九解脱。及依根本四静虑定。起胜进道离染加行。未来修二。谓加他心。所余未来唯修世俗。修五通时诸加行道。二解脱道现修俗智。一解脱道现俗。他心诸胜进道二。随应现未来一切皆修二种。五无间道现未唯俗。依本静虑修余功德。皆现修俗未来修二。唯顺决择分必不修他心。以是见道近眷属故。依余地定修余功德。皆唯世俗现未来修。诸未来修为修几地。诸所起得皆是修耶。颂曰

  诸道依得此　　修此地有漏
  为离得起此　　修此下无漏
  唯初尽遍修　　九地有漏德
  生上不修下　　曾所得非修

论曰。诸道依此地及得此地时。能修未来此地有漏。谓依此地世俗圣道现在前时。未来唯修此地有漏。以有漏法系地坚牢难修余故。随依何地离下地染。第九解脱现在前时亦修未来。所得上地根本近分。有漏功德离下地缚必得上故。圣为离此地及得此地时。并此地中诸道现起。皆能修此及下无漏。谓随何地有漏无漏。加行等道正现在前。为欲断除此地烦恼。未来修此及下无漏。下于上染同能治故。虽下圣道断烦恼时。诸上地边有能同治。然由有漏系地坚牢。未离下时未能修彼。随依何地离下地染。第九解脱现在前时亦修未来。所得上地及诸下地无漏功德随起。此地世俗圣道现在前时。未来皆修此及下地无漏功德。唯初尽智现在前时。力能遍修九地有漏。意地所摄闻思修所成。不净观等无量胜功德。谓随何地尽智现前。通修未来自上下地。何缘唯此初尽智时。力能遍修诸有漏德。创能殄灭无始时来一切善根烦恼怨故。如有摧伏国所共怨。一切俱来庆赖称善。又烦恼缚断无余故。如能缚断所缚气通。又彼心王登自在位。一切善法起得来朝。譬如大王登祚洒顶。一切境土皆来朝贡。然此生上必不修下。谓身在欲得阿罗汉。通修三界九地善根。至生有顶唯修一地。初尽智言显离有顶及五练根位。第九解脱道皆舍前道创得果故。于见道位三类智边。虽亦能修自下俗智。先已说故此不复论。诸所言修唯先未得。今起今得是能所修。谓若先时未得今得。用功得者方是所修。若法先时曾得弃舍。今虽还得而非所修。非设劬劳而证得故。若于先时未得而起。极用功起势力胜故。此方能修未来功德。若先已得今起现前。彼不能修未来功德。非多功起势力劣故。修用止息故不能修未来。若曾得现前能修未来者。则薄伽梵得尽智时。应未具修一切功德。为具证得应更进修。便同二乘功德不满。为唯约得说名为修。不尔。云何。修有四种。一得修。二习修。三对治修。四除遣修。如是四修依何法立。颂曰

  立得修习修　　依善有为法
  依诸有漏法　　立治修遣修

论曰。诸未曾得功德现前。及得未来所余功德。新修得故皆名得修。曾得未曾功德现起。现修习故皆名习修。此二但依善有为立。未来唯得现具二修。于身等法得能治故。所治身等名对治修。故于身等得对治时。即说名为修于身等。余有漏法类亦应然。缘身等境烦恼断故。说身等法名除遣修。故缘身等烦恼断时。亦说名为修于身等。余有漏法例亦应然。此二但依有漏法立。故有漏善具足四修。无漏有为余有漏法。如次各具前后二修。有于此中约当修义。分别诸法具修多少。有法具四名为当修。有法具三。有法具二。有法具一。有法全无。谓善有漏未永断时。可得可生具足四种。此未永断故当具治遣修。以可得故当具得修。是可生故当具习修。已得可生具三除得。可得不生具三除习。已得不生及不可得。已生具二。谓治遣修。染及无记未断亦尔。若善有漏已永断时。可得可生具得习二。可得不生具一谓得。已得可生具一谓习。有为无漏应知亦尔。除前所说皆是全无。谓无漏法中已得不生等。若不生法不住身中。但由得故即名修者。应许择灭亦名为修。无差别故。此难非理。彼同类法住身中故。谓不生法虽不住身。同类住身名修无失。又彼由得为果住故。谓未来世不生善法。由令得生表为果住。义言我等阙缘不生。非谓今时不蒙招引。择灭异此。不可为例。又未来世不生善法。亦有因力摄益现身。择灭不然。故无修义。又由择灭唯是果故。谓修本为获得胜果。灭非有果。故不应修。又由择灭无增减故。谓可修法。依下至中依中至上。择灭不尔。于修无用故不可修

说一切有部顺正理论卷第七十四阿毗达磨顺正理论卷第七十五

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩智品第七之三

如是已辩诸智差别。智所成德今当显示。于中先辩佛不共德。且初成佛尽智位修不共佛法有十八种。何谓十八。颂曰

  十八不共法　　谓佛十力等

论曰。佛十力四无畏三念住及大悲。如是合名为十八不共法。唯于诸佛尽智时修。余圣所无。故名不共。且佛十力差别云何。颂曰

  力处非处十　　业八除灭道
  定根解界九　　遍趣九或十
  宿住死生俗　　尽六或十智
  宿住死生智　　依静虑余通
  赡部男佛身　　于境无碍故

论曰。佛十力者。一处非处智力具以如来十智为性。为依何义立此力名。佛于经中自作是说。苾刍谛听。如来于处如实知处。如来于非处如实知非处。乃至广说。知一切法自性功能理定是有。名为处智。知一切法自性功能理定非有。名非处智。此智通缘情非情境。与一切智皆不相违。恐于略说少功难悟。故复此中析出余九。如薄伽梵多界经中自广分别。处非处义身等恶行。感非爱果。定有是处。感可爱果。必无是处。乃至广说。于彼经中所未说者我依余教复略分别。谓诸如来犹有误失。诸应分别而一向记。无力无畏三念住等不共功德。必无是处诸圣犹起见所断惑。覆罪堕恶。必无是处。造无间者现身见法堕邪性者现入正性。外道法内有真沙门。有虽受生而无有死。有不还者复欲界生。有阿罗汉更受后有。有舍二种识犹现行处。有十三界有十九蕴有第六世。有第四谛有第五。必无是处。如来所使有能遮遏。世尊使者事未究竟。正在慈定灭尽定中。随信法行者有能为损害。北俱卢死堕恶趣中。及有中夭。必无是处。诸行不灭涅槃非常。异生有能断有顶惑于一相续二心俱行无漏为因招异熟果。五识得与觉支相应。眠梦位中有生有死。得果退等。必无是处。有五识身无寻无伺。缘名过未离世为境。有鼻舌识有覆无记。有生上界入现观者。有耳见色有眼闻声。舌嗅香等。必无是处。如是等类得非处名。与此相违皆名是处。岂不处智已知非处。诸非处智亦已知处。何劳双说处非处名。虽理实然而双说者。为欲遮止无因论故说是处名。为欲遮止恶因论故说非处名。依一智体双说无失。宁知于一处非处力中。恐略难悟析出余九力。以余皆有此力义故。谓如实知恶行能感可爱异熟。妙行能感非爱异熟。必无是处。与此相违定有是处又如实知顺退分定能逮胜德。顺胜进分能引退堕。必无是处。与此相违定有是处。又如实知若此品根能证此果。此根未满此界已证。必无是处。与此相违定有是处。又如实知下劣胜解。鄙恶喜乐能逮胜德。必无是处。与此相违定有是处。又如实知诸有情类界性各别而情契合。必无是处。与此相违定有是处。又如实知趣生死行能证涅槃。趣涅槃行能招生死必无是处。与此相违定有是处。又如实知前际有始必无是处。与此相违定有是处。又如实知未断生结死已不生。或彼已生毕竟不死。或彼不往善趣恶趣必无是处。与此相违定有是处。又如实知非理作意能得漏尽必无是处。与此相违定有是处。我于如是一一力中。略举方隅显处非处。若尽其事言论无穷。故应皆名处非处力。恐略难悟别立异名。二业异熟智力。八智为性除灭道智。谓善分别如是类业。感如是类诸异熟果。无挂碍智名业异熟智力。或说名为自业智力。谓善分别如是类果。是自所造业力所招。非妻子等所能与夺。如是类业必招自果不可贸易。无挂碍智名自业智力。又佛自说此力相言。苾刍谛听。佛于过去未来现在。诸业法受别处别因别事别果皆如实知。乃至广说。诸业有三法受有四。业及法受故名为业。法受或业之法故名业法。即是诸业之品类义。此显如来于过去等。诸业品类处等差别。及所受果能如实知。此中别处者是别方所义。知于某处造如是业。当于某处此业方熟。谓知此业天等处造。此业当于人等处熟。是名如实了知别处。言别因者。是别缘义。知如是业遇此缘熟。或知此业由此缘造。是名如实了知别因。言别事者。是别物义。知如是业至成熟时。力能引生色等别物。或即知业自性不同名知别事。谓知此业此物为性。余则不然。是名如实了知别事。言果别者。是别异熟义。知如是业定感异熟果。此业不定能感异熟。此业异熟经尔所时有不尔者。此业异熟尚有所余有无余者。如是等类异熟差别。极细难了而能了知。是名如实了知别果。三静虑解脱等持等至智力。四根上下智力。五种种胜解智力。六种种界智力。如是四力皆九智性。唯除灭智。谓如实知诸静虑等自性名得。方便摄持味净无漏。顺退住进决择分等无挂碍智。名静虑等智力。又佛自说此力相言。苾刍谛听。佛于静虑解脱等持等至。杂染清净安立皆如实知。乃至广说。静虑等相定品当辩。杂染谓能障证静虑等。清净谓即此诸法清净。诸净法住名为安立。或顺退分名为杂染。顺胜进分顺决择分名为清净。顺住分名安立。若如实知诸有情类能逮胜德根品差别无挂碍智。名根上下智力。又佛自说此力相言。苾刍谛听。佛于有情诸根上下皆如实知。乃至广说。此意显佛知诸有情诸根胜劣无有谬误。虽有中根而待胜劣。是劣胜摄故不别显。此中根名为目何法。谓目信等断善根者。总相续中亦有去来信等善法。或目意等。若如实知诸有情类喜乐差别无挂碍智。名种种胜解智力。又佛自说此力相言。苾刍谛听。佛于有情种种胜解皆如实知。乃至广说。此意显佛知诸有情喜乐种种品类差别。喜乐胜解名差别故。若如实知诸有情类。前际无始数习所成。志性随眠及诸法性。种种差别无挂碍智。名种种界智力。又佛自说此力相言。苾刍谛听。佛于世间种种界非一界皆如实知。乃至广说。种种界者显各别义。非一界者显众多义。应知此中界与志性。随眠法性名之差别。如是四力并缘有为。故十智中唯摄九智。七遍趣行智力。或声显此义有二途。若谓但缘诸能趣道。九智除灭。若谓兼缘道所趣果。十智为性。谓如实知生死因果。及知尽道无挂碍智。名遍趣行智力。又佛自说此力相言。苾刍谛听。佛于一切遍趣行中皆如实知。乃至广说。此意显佛能如实知趣生死行趣涅槃行。趣生死中有趣地狱。乃至趣天。趣一一中复有多种。趣涅槃行有三乘别。趣一一中复有多种。依总说一遍趣行名。八宿住随念智力。九死生智力。如是二力皆俗智性。此二力相有差别故。谓如实知自他过去宿住差别无挂碍智。名第八力。若如实知诸有情类于未来世诸有续生无挂碍智。名第九力。又佛自说此二相言。苾刍谛听。佛于过去种种宿住一生二生。乃至广说。佛天眼净超过于人见诸有情。乃至广说。广辩此二如六通中。十漏尽智力。或声亦显义有二途。若谓但缘漏尽为境。六智除道苦集他心。若谓兼缘漏尽方便。十智为性。理应如是以辩相中言于尽及为尽无挂碍。智二种俱名漏尽智力。又佛自说此力相言。苾刍谛听。佛漏尽故于诸无漏心慧解脱。自现通达具证领受。能正自知我生已尽。乃至广说。此后三力即是三通。以六通中此三殊胜。在无学位立为三明。在如来身亦名为力。神境天耳设在佛身。亦无大用故不名力。且如天眼能见有情。善恶趣中异熟差别。由此能引殊胜智生。亦正了知能感彼业。由此建立死生智名。神境天耳无此大用。是故彼二不立为力。然不别说他心力者。义已摄在根等力中。以他根等中有心心所故。又薄伽梵具一切智。于工论等亦得自在。而于佛事齐此已成。余智于中无别胜用。是故虽有亦不别说。唯依遍觉十种所知。佛所应为皆圆满故。何等名曰十种所知。谓诸法中因非因义。多分散地业果差别。定地功德品类不同。所化有情根解界异。所治能治因果差别。前际后际经历不同。离染不续方便有异。但由觉此佛事已成。余设有无不致益损。故唯十种得名为力。又佛观察所化有情。设教应机唯须十智。谓由初智观所化生。于诸乘中堪无堪异。由第二智观所化生。于相续中业障差别。由第三智观所化生。于静虑等有味无味。烦恼为障轻重差别。由知此二因亦知异熟障。由第四智观所化生。趣清净品功能差别。由第五智观所化生。于证净品加行差别。由第六智观所化生。于证净品禀志性别。由第七智观所化生。诸所施为有益无益。种种差别正观修止。由第八智观所化生。过去世中所集差别。由第九智观所化生。当来世中结生差别。由第十智观所化生。所证解脱方便有异。于此十智若随阙一。便不具足化有情事。多复无用故不增减。已辩自性依地别者。第八第九依四静虑。余八通依十一地起。欲四静虑未至中间并四无色。名十一地。诸胜德地总有尔所。已辩依地。依身别者。皆依赡部男子佛身。唯此堪为力所依故。如是十智二乘亦有。何故在佛方受力名。夫受力名谓无碍转。佛智于境无碍转故。得名为力。余则不然。以诸二乘尚不能见诸有情相续顺解脱分善。况复能知所余深细。如舍利子舍求度人。不能观知鹰所逐鸽。前后二际生多少等。大目干连不能观见。业风所引诸鬼差别。是故二乘天眼通等。观界远近与佛有殊。非无碍故不名为力。二乘与佛漏尽既同。彼智何缘唯佛名力。唯世尊有遍达有情。一切漏尽别相智故。谓薄伽梵于诸有情。一切漏尽品类差别。智无挂碍。二乘不然。是故力名唯属于佛。又唯诸佛智猛利故。如何猛利。佛智力能速断烦恼并习气故。如强弱力补特伽罗。执利钝刀斩截草等。诸有情类蕴相无别。佛如何观有种种界。诸有情类蕴相虽同。而于其中非无差别。谓彼诸蕴体虽无异。而有无量品类不同。佛如量知都无挂碍。故世尊得有种种界智力。或诸如来名称高远。希有智慧妙用无边。唯佛能知非余所测。于余所了无别相中。何怪如来能知别相。已辩诸佛心力方隅。当辩菩萨时亦所成身力。颂曰

  身那罗延力　　或节节皆然
  象等七十增　　此触处为性

论曰。佛生身力等那罗延。有余师言。佛身支节一一皆具那罗延力。理实诸佛身力无边犹如心力。能持无上正等菩提大功德故。大觉独觉及转轮王。支节相连如其次第。似龙蟠结连锁相钩。故三相望力有胜劣。那罗延力其量云何。十十倍增象等七力。谓凡象。香象。摩诃诺健那。钵罗塞建提。伐浪伽遮怒罗。那罗延。后后力增前前十倍。有说前六十十倍增。敌那罗延半身之力。此力一倍成那罗延。有余师说。此量如千蔼罗伐拏天象王力。此象王力其量云何。三十三天将游戏苑。象王知已化作诸头种种庄严。往天宫所。诸天眷属数有多千。乘已腾空如持桦叶。速至戏苑随意欢娱。天大象王力势如是。此力千倍等那罗延。于诸说中唯多应理。如是身力触处为性。此应总是诸触差别。有说。唯是大种差别。有说。是造触离七外有。有说。力是重劣者是轻。如是名为佛生身力。佛四无畏相别云何。颂曰

  四无畏如次　　初十二七力

论曰。佛四无畏如经广说。一正等觉无畏。十智为性。犹如初力。二漏永尽无畏。六十智性。如第十力。三说障法无畏。八智为性。如第二力。四说出道无畏。九十智性。如第七力。何缘诸佛无畏唯四。但由此量显佛世尊。自他圆德俱究竟故。谓初无畏显佛世尊自智圆德。第二无畏显佛世尊自断圆德。此二显佛自利德满。为显世尊利他圆德。是故复说后二无畏。第三无畏遮行邪道。第四无畏令趍正道。谓佛处处为诸弟子。说障法令断除即是令修断德方便。又于处处为诸弟子。说出道令正行。即是令修智德方便。此二显佛利他德满。但由此四随其所应。显佛自他智断圆德。至究竟故唯立四种。如何可说无畏即智。应言无畏是智所成。理实应然。但为显示无畏以智为亲近因。是故就智出无畏体。夫无畏者谓不怯惧。由有智故不怯惧他。故智得为无畏因性。唯佛四妙智是四无畏因。谓诸如来于一切法一切相妙。智是初无畏因。若诸如来一切烦恼并习气断妙智。是第二无畏因。唯我世尊由具此故。侵毁不戚供赞不欢。虽恒违拒而常饶益。虽加斫刺而深怜愍。虽有殊胜辅翼神通智慧技能而不傲慢。于欲离背不起嗔嫌。于乐亲承不偏怜爱。虽行摄事不求辅翼。虽行诃责不愿乖离。虽暂驱摈不以粗语。虽永摈黜不令堕邪。虽无所畏而不粗犷。虽常亲爱而不生贪。虽显自德不殉名利。虽显他过不为耻辱。虽摄门徒不成自党。虽诃邪侣不坏他朋。族望有情数来亲附。但示正法不与交游。此等皆由漏尽妙智。故此妙智为第二因。若诸如来知弟子众。有损有益妙智。是后二无畏因。或无畏体即四妙智。怯惧名畏。此即于法无所了达。怀恐怖义。智于此畏有近治能。与畏相违故名无畏。岂不非无智即是畏体。如何说智体即是无畏。此责不然。智与多法为近治故如即无疑。谓智如能近治无智。亦于怖畏有近治能。故得智名。亦名无畏。如治无智亦能治疑。故得智名。亦名决定。所治无智虽不即疑而智无疑。名二体一。如是无智虽与畏殊。而无畏名即目智体。一善能断多恶法故。有说。无智亦摄畏体。故于此中不应为难。力与无畏有何差别。此无差别体俱智故。然于智体别义名力。复依别义立无畏名。谓不屈因说名为力。不怯惧因说名无畏。或初安立说名为力。立已不动说名无畏。或非他伏说名为力。能摧伏他说名无畏。有余师说。譬如良医遍达医方。说名为力。善疗众疾。说名无畏。有说骁健。说名为力。勇悍不怯。说名无畏。如是二种义亦有别。谓成办事义是力义。不怯惮义是无畏义。佛三念住相别云何。颂曰

  三念住念慧　　缘顺违俱境

论曰。佛三念住如经广说。诸弟子众一向恭敬能正受行。如来缘之不生欢喜。舍而安住正念正知。是谓如来第一念住。诸弟子众唯不恭敬不正受行。如来缘之不生忧戚。舍而安住正念正知。是谓如来第二念住。诸弟子众一类恭敬能正受行。一类不敬不正受行。如来缘之不生欣戚。舍而安住正念正知。是谓如来第三念住。虽有所化不敬受行。而佛世尊亦雨法雨。由此方便彼于余时或余有情入正法故。非前说四今复说三。可总说言念住有七。今三摄在前四中故。谓在缘外法念住摄。然此三种体通念慧。谓由安住正念正知。于三境中不生欢戚。不可见有诸大声闻。于三境中不生欢戚。便谓此三种非佛不共法。唯佛于此并习断故。善达有情种性别故。或弟子众随属如来。有顺违俱应甚欢戚。佛能不起可谓希奇。非属诸声闻不起非奇特。故唯在佛得不共名。诸佛大悲云何相别。颂曰

  大悲唯俗智　　资粮行相境
  平等上品故　　异悲由八因

论曰。如来大悲俗智为性。普缘一切有情为境。作苦苦等三行相故。非无漏智有如是理。此大悲名依何义立。依五义故此立大名。一由资粮故大。谓大福德智慧资粮所成办故。二由行相故大。谓此力能于三苦境作行相故。三由所缘故大。谓此总以三界有情为所缘故。四由平等故大。谓此等于一切有情作利乐故。五由上品故大。谓最上品更无余悲能齐此故。有余师说。由大加行所证得故。唯大士身所成就故。入大功德珍宝数故。能拔有情大苦恼故。立大悲名。悲与大悲有何差别。此二差别由八种因。一由自性。无嗔无碍自性异故。二由依身通余。唯佛依身异故。三由行相。一苦三苦行相异故。四由所缘。一界三界所缘异故。五由依地。通余第四静虑异故。六由证得。离欲有顶证得异故。又悲为先离染时得。唯离染得有差别故。七由救济。希望事成救济异故。八由哀愍。平等不等哀愍异故。有余师说。诸佛大悲远细遍随。能普饶益。声闻等类所起悲心。不能悲愍色无色界。佛于上界起极悲愍。心过于二乘。悲愍无间狱。已辩佛德异余有情。诸佛相望法皆等不。颂曰

  由资粮法身　　利他佛相似
  寿种姓量等　　诸佛有差别

论曰。由三事故诸佛皆等一。由资粮等圆满故。二由法身等成办故。三由利他等究竟故。由寿种姓身量等殊。诸佛相望容有差别。寿异谓佛寿有短长。种异谓佛生刹帝利婆罗门种。姓异谓佛姓乔答摩迦叶波等。量异谓佛身有小大等。言显诸佛法住久近等。如是有异。由出世时所化有情机宜别故。诸有智者思惟如来三种圆德深生爱敬。其三者何。一因圆德。二果圆德。三恩圆德。初因圆德复有四种。一无余修。福德智慧二种资粮修无遗故。二长时修。经三大劫阿僧企耶修无倦故。三无间修。精勤勇猛刹那刹那修无废故。四尊重修。恭敬所学无所顾惜修无慢故。次果圆德亦有四种。一智圆德。二断圆德。三威势圆德。四色身圆德。智圆德有四种。一无师智。二一切智。三一切种智。四无功用智。断圆德有四种。一一切烦恼断。二一切定障断。三毕竟断。四并习断。威势圆德有四种。一于外境化变住持自在威势。二于寿量若促若延自在威势。三于空障极远速行。小大相入自在威势。四令世间种种本性。法尔转胜希奇威势。威势。圆德复有四种。一难化必能化。二答难必决疑。三立教必出离。四恶党必能伏。色身圆德有四种。一具众相。二具随好。三具大力。四内身骨坚越金刚。外发神光踰百千日。后恩圆德亦有四种。谓令永解脱三恶趣生死。或能安置善趣三乘。总说如来圆德如是。若别分析则有无边。唯佛世尊能知能说。要留命行经多大劫。阿僧企耶说乃可尽。如是则显佛世尊身具有无边。殊胜奇特因果恩德如大宝山。有诸愚夫自乏众德。虽闻如是佛功德山及所说法。不能信重。诸有智者闻说如斯。生信重心彻于骨髓。彼由一念极信重心。转灭无边不定恶业。摄受殊胜人天涅槃。故说如来出现于世。为诸智者无上福田。依之引生不空可爱殊胜速疾究竟果故。如薄伽梵自说。颂曰

  若于佛福田　　能殖少分善
  初获胜善趣　　后必得涅槃

已说如来不共功德。共功德今当辩。颂曰

  复有余佛法　　共余圣异生
  谓无诤愿智　　无碍解等德

论曰。世尊复有无量功德。与余圣者及异生共。谓无诤愿智无碍解通。静虑无色等至等持。无量解脱胜处遍处等。随其所应。谓前三门唯共余圣。通静虑等亦共异生。虽佛身中一切功德。行相清净殊胜自在。与声闻等功德有殊。然依类同说名为共。且共余圣。三功德中。无诤云何。颂曰

  无诤世俗智　　后静虑不动
  三洲缘未生　　欲界有事惑

论曰。有阿罗汉忆昔多生。受杂类身发自他惑。由斯相续受非爱果。便作是念。有烦恼身缘之起惑。尚招苦果。况离烦恼具胜德身。思已发生如是相智。由此方便令他有情。不缘己身生贪嗔等。此皆但以俗智为性。缘他未来修断惑故。非无漏智此行相转。若无诤体是智所摄。如何说习无诤等持。此不相违一相应品。有多功德随说一故。如一山中有种种物。随举一种以标山名。理应无诤。是智所摄护他相续。当来惑生巧便为先事方成故。然一切诤总有三种。蕴言烦恼有差别故。蕴诤谓死。言诤谓斗。烦恼诤谓百八烦恼。由此俗智力。能止息烦恼诤故得无诤名。此智但依第四静虑违苦因故。第四静虑乐通行中最为胜故。不动应果能起非余。余尚不能自防起惑。况能止息他身烦恼。此唯依止三洲人身。非北及余性猛利故。缘欲未起有事惑生。勿令他惑缘我生故。诸无事惑不可遮防。内起随应总缘境故。已辩无诤。愿智云何。颂曰

  愿智能遍缘　　余如无诤说

论曰。以愿为先引妙智起。如愿而了故名愿智。此智自性地种性身与无诤同。但所缘别。以一切法为所缘故。如何愿智能知未来。审观过现而比知故。如观稼穑有盛有微。比知其田有良有薄。若尔何故立愿智名。有学异生亦能知故。不尔所知定不定故。而闻传说诸大声闻。记未来事有不定者。非起愿智有此谬知。余俗智观所记别故。惑彼所记无不定失。但观于始不观终故。如先降雨未至地间。为罗怙罗之所承弃。先所怀孕其实是男。彼于后时转形成女。王舍城鬼初战得胜。后为广严诸鬼摧伏。人欲相伐鬼先战故。或实愿智方见未来。然加行时先起比智。观过现世准度未来。引愿智生方能真见。即由此故能知无色。谓先观彼因行等流。有比智生引真愿智。或观欲色死生时心。比度而知所生从处。引生愿智方能实知。或比智知亦无有失。以证比智所缘必同。若比不知如何能证。是则愿智应不可言。力能遍缘三界三世。不时解脱诸阿罗汉。欲于彼境正了知时。先作要期愿我知彼。后入边际第四静虑。以为加行。从此无间。如先愿力引正智起。于所期境皆如实知。边际定言如后当释。此愿智力能知过去。与宿住智差别云何。愿智通知自相共相。诸宿住智知共非余。知共相中亦有差别。愿智明了宿住不然。于现所缘对他心智。辩差别相如理应思

说一切有部顺正理论卷第七十五阿毗达磨顺正理论卷第七十六

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩智品第七之四

已辩愿智。无碍解云何。颂曰

  无痴解有四　　谓法义词辩
  名义言说道　　无退智为性
  法词唯俗智　　五二地为依
  义十六辩九　　皆依一切地
  但得必具四　　余如无诤说

论曰。诸无碍解总说有四。一法无碍解。二义无碍解。三词无碍解。四辩无碍解。此四总说如其次第。以缘名义言及说道。不可退转智为自性。谓无退智缘能诠法。名句文身立为第一。趣所诠义说之为名。即是表召法自性义。辩所诠义说之为句。即是辩了法差别义。不待义声独能为觉。生所依托说之为文。即是迦遮吒多波等。理应有觉不待义声。此觉不应无所缘境。此所缘境说之为文。文谓不能亲目于义。但与名句为诠义依。此三能持诸所诠义。及轨生解。故名为法。即三自性说之为身。自性体身名差别故。三与声义极相邻杂。为境生觉别相难知。故说身言显有别体。若无退智缘一切法。所有胜义立为第二。义即诸法自相共相。虽名身等亦是义摄。而非胜义。有多想故。谓有如义有不如义。有有义有无义。有依假转。有依实转。了此无间。或于后时诸所度量名为胜义。为欲显示义无碍解。所缘之境非语及名。故此所缘说为胜义。谓此但取依语起名。名所显义非取泛尔。心之所行说名为义。若无退智缘诸方域。俗圣言词立为第三。即能了知世语典语。于诸方域种种差别。若无退智缘应正理无滞碍说。及缘自在定慧二道。立为第四。即于文义能正宣扬。无滞言词说名为辩。及诸所有已得功德。不由加行任运现前自在功能。亦名为辩。此能起辩立以辩名。了辩及因智名辩无碍解。即前所说能正宣扬。善应物机不违胜义。所有言说名应正理。即前所说无滞言词。不待处时及有情等。辩析自在。名无滞碍。即上所言已得功德。不由加行任运现前。名为自在定慧二道。又能所诠相符会智。名初二无碍解。谓达此名属如是义。及达此义有如是名。名能所诠相符会智。达时作等加行言词。名第三无碍解。达所乐言说及自在道因。名第四无碍解。又色等六所知谓义。即此善等有为无为。色非色等差别谓法。即诠此二言说谓词。三智即前三无碍解。即缘三种无挂碍智。名第四无碍解。又达世俗胜义二谛。名初二无碍解。此即行者自利圆德。能善宣说如是二谛。名第三无碍解。于此善巧问答难通。名第四无碍解。此即行者利他圆德。有说愚痴犹预散乱。是于宣辩有滞碍因。由解脱此三得现法乐住。及由此故利他行成。此智名为辩无碍解。若得如是定能宣说。符会正理无滞言词。及得现前自在功德。又于名等胜义言词。无滞说中各得善巧。如次建立四无碍解。前三善巧说名为因。由境不同故有差别。第四名果能说无滞。又由四分别他事成。谓巧于文了达于义。妙闲声韵定慧自在。故无碍解建立有四。此即总说无碍解体。兼显四种所缘差别。契经略举此数及名。诸对法中广显其相。又经列此先义后法。诸对法中先法后义。此为显示二智生时。或义因名。或名因义。故经与论作差别说。谓听法者先分别名。既正知名次寻其义。正知义已欲为他说。次必应求无滞说智。依此次第故名在先。然此四中义智最胜。余是助伴故义在先。谓于义中若正了达。次应方便寻究其名。既已知名欲为他说。次应于说求巧便智。是故此四次第如是。辩无碍解若缘说时。何异第三词无碍解。第三了达训释言词。如有变碍故名色等。此达应理无滞碍说。有说词诠诸法自性。辩能显示诸法差别。有说于法直说名词。展转无滞分析名辩。缘此二种三四有别。四中法词俗智为性。非无漏智缘名身等。及世言词事境界故。法无碍解通依五地。谓依欲界四本静虑。上地中无名身等故。彼不别缘下名等故。词无碍解唯依二地。谓依欲界初本静虑。上诸地中无寻伺故。彼地必无自语言故。此因非理。所以者何。非发语智名无碍解。勿无碍解定中无故。由此不应作如是说。无寻伺故上地中无。无斯过失。因义异故。何谓因义。谓此意言寻伺二法能发语故。相不寂静自性粗动。上无此故寂静微细。词无碍解缘外言词。亦不寂静粗动类摄。是故此解上地中无。初静虑中亦有寻伺。故于定内亦有此解。由此极成但依二地。义无碍解十六智性。谓若诸法皆名为义。则十智性。若唯涅槃名为义者则六智性。谓俗法类灭尽无生。辩无碍解九智为性。谓唯除灭缘说道故。此二通依一切地起。谓依欲界乃至有顶。辩无碍解于说道中。许随缘一皆得起故。通依诸地。亦无有失。然于其中但缘说者。唯依二地与第三同。有说尽无生非无碍解摄。以无碍解是见性故。彼说第二或四或八。第四唯七。准上应知。此四应知如四圣种。随得一种必具得四。非不具四可名为得。随欲现起或具不具。有余师言。有不具得无理得一必令得四。有说此四无碍解生。如次串习算计佛语。声明因明为前加行。若于四处未得善巧。必不能生无碍解故。理实一切无碍解生。唯学佛语能为加行。要待前生久习名等。四种善巧今乃能修。无碍解名释有多义。谓于彼彼境领悟无碍名无碍解。或于彼彼境决断无碍名无碍解。或于彼彼境正说无碍名无碍解。有余师说。钵剌底是助声目现前义。如钵剌底日火蝩来。是日火蝩现前来义。三目无倒毗陀目智。此言意显于境现前。无颠倒智名无碍解。四无碍解三乘俱得。何故经说唯我世尊。独名成就四无碍解。无相违失。经自释故。谓彼经言唯佛无谬。成就无上故作是说。声闻独觉自分境中。智无退故名无碍解。诸佛世尊于一切法。圆满知故名无碍解。有余师说。无别第四即依前三总集建立。此说非理。缘法义词与缘说道智相别故。此四依地自性所缘。与无诤别。前来已辩种性依身如无诤说。谓不动种性依三洲人身。如是所说无诤智等。颂曰

  六依边际得　　边际六后定
  遍顺至究竟　　佛余加行得

论曰。无诤愿智四无碍解。六种皆依边际定得。边际定力所引发故。边际静虑体有六种。前六除词余五少分。及除此外复更有余。加行所得上品静虑。名边际定。故成六种。词无碍解虽依彼得。而体非彼静虑所摄。边际名但依第四静虑故。此一切地遍所随顺故。增至究竟故得边际名。由此不应亦通余地。云何此名遍所随顺。谓正修学此静虑时。从初静虑次第顺入乃至有顶。复从有顶次第逆入至初静虑。从初静虑次第顺入。展转乃至第四静虑。名一切地遍所随顺。云何此名增至究竟。谓专修习第四静虑。从下至中从中至上。如是三品复各分三。上上品生名至究竟。如是静虑得边际名。此中三乘非无差别。而各于自得究竟名。此中边名显无越义。胜无越此故名为边际言。为显类义极义。如说四际及实际言。如是二言显此静虑。是最胜类定中最极。殊胜功德多此引生。乐通行中此最胜故。有言无诤体即是悲。哀愍有情修无诤故。趣入无诤以悲为门。如何异悲别有自体。此说非理。不决定故。谓修无诤非定由悲。于诸有情拔苦行相。但为令彼烦恼不生。寂静思惟为门而入。设许决定以悲为门。亦不可言以悲为体。勿慧由定发体即是定故。若住无诤能息他惑。则应世尊不住无诤气嘘。指鬘等缘佛生惑故。实非无诤恒现在前。以佛世尊具无量德。随时所欲起一现前。宁一切时偏住无诤。佛于圣住多住于空。先由此门入离生故。能引舍故。极微妙故。最难修故。是不共故。佛于梵住多住于悲。最能济拔有情苦故。无诤不然。故多不起。世尊对彼具寿善现。饶益他志虽胜无边。而不恒时住无诤者。为欲永拔彼烦恼故。初纵令起后方调伏。如是可谓真实哀愍。愿智为先方起无诤。非起愿智无诤为先。谓要先知诸有情类。由我安住如是威仪。烦恼便生。余则不尔。然后方起无诤现前。愿智无缘由无诤起。虽俱边际静虑为先。加行有殊得有差别。有说此二展转相摄。理不应然。行相别故。谓别行相为息他惑。起别行相为了所知。若加行中为息他惑。后从定起他惑不生。如是即名无诤事办。若加行位为知所了。后起定时了所知境。如是名曰愿智事成。行相既殊如何相摄。如是所说无诤智等。除佛余圣唯加行得。非离染得。非皆得故唯佛于此。亦离染得。诸佛功德初尽智时。由离染故一切顿得。后时随欲能引现前不由加行。以佛世尊于一切法自在转故。已辩前三唯共余圣德。于亦共凡德且应辩通。颂曰

  通六谓神境　　天眼耳他心
  宿住漏尽通　　解脱道慧摄
  四俗他心五　　漏尽通如力
  五依四静虑　　自下地为境
  声闻麟喻佛　　二三千无数
  未曾由加行　　曾修离染得
  念住初三身　　他心三余四
  天眼耳无记　　余四通唯善

论曰。通有六种。一神境智证通。二天眼智证通。三天耳智证通。四他心智证通。五宿住随念智证通。六漏尽智证通。虽六通中第六唯圣。然其前五异生亦得。依总相说亦共异生。如是六通解脱道摄。慧为自性如沙门果。解脱道言显出障义。胜进道中亦容有故。如是通慧无间道无。此位定遮他心智故。勿阿罗汉舍无间道。即名亦舍漏尽通故。品类足说。善慧是通二应非通。无记性故。义各别故。此彼无违。彼说所知及所通法。举诸智慧为能知通。以显所知及所通法。虽诸智慧皆能知通。而且说善胜遍缘故。所知所通虽无广陜。而能知外有别能通。故说所知已复说所通法。此所辩通唯胜定果。通无记慧。与彼何违。又彼但言通谓善慧。不言唯善。故亦无违。如说能知谓诸善智。岂恶无记皆非智摄。彼此通别应作四句。有彼非此。谓除四通所余善慧。有此非彼。谓解脱道二无记慧。有彼亦此。谓即四通。有非彼此。谓除前说。除他心漏尽。余四俗智摄。西方诸师说。宿住通六智。谓俗法类及苦集道。俗智能了过去俗事。余随所应各缘自境。然观经意唯俗智摄。如说随忆无量宿住。谓或一生乃至广说。非无漏智此行相转。他心通五智摄。谓法类道世俗他心。漏尽通如力说。谓或六或十智。由此已显漏尽智通。依一切地缘一切境。前之五通依四静虑不依无色。近分中间彼无五通所依定故。要摄支定是五通依。非漏尽通亦不依彼。诸地皆能缘漏尽故。不待观色为加行故。前三通境无色不能缘。由此三通但别缘色。故修他心通色为门。故修宿住通渐次忆念。分位差别方得成满。于加行中必观色故。依无色地无如是能。若尔中间及五近分。亦容缘色应有五通。不尔由前所说因故。谓摄支定是五通依。若不摄支等持劣故。又彼止观随一减故。若尔何缘有漏尽通。乐苦迟速地皆能尽漏。故五是别修殊胜功德。要殊胜地方能发起。若宿住通不依无色。应不能忆无色界事。契经何故说佛世尊无上法中。言佛能忆过去有色无色等事。此是决定比智所知。非宿住通。故无有失。谓诸外道。若见有情欲色命终不知生处。执有情类死已断灭。见生欲色不知所从。便执有情本无而有。声闻独觉见彼命终。二万劫中不见所在。便谓彼殁生于空处。而彼或生上不尽寿命终。如是乃至八万劫中不见所在。便谓彼殁生于非想非非想处。而或生下地经二三生等。见生欲色时谓所从亦尔。世尊观彼死时生时。如实比知所生从处。有尽寿量。有中夭者。虽亦比知非不决定。故与余圣比知有别。修神境等前三通时。思轻光声以为加行。成已自在随所欲为。诸有欲修他心通者。先审观己身心二相。前后变异展转相随。后复审观他身心相。由此加行渐次得成。成已不观自心诸色。于他心等能如实知。诸有欲修宿住通者。先自审察次前灭心。渐复逆观此生分位。前前差别至结生心。乃至能忆知中有前一念。名自宿住加行已成。为忆念他加行亦尔。此通初起唯次第知。串习成时亦能超忆诸所忆事。要曾领受忆净居者。昔曾闻故从无色殁来生此者。依他相续初起此通。所余亦依自相续起。如是五通境唯自下。且如神境随依何地。于自下地行化自在。于上不然。势力劣故。余四亦尔。随其所应。是故无能取无色界他心宿住为二通境。即此五通于世界境。作用广陜诸圣不同。谓大声闻麟喻大觉不极作意。如次能于一二三千诸世界境。起行化等自在作用。若极作意如次能于二千三千无数世界。如是五通若有殊胜势用猛利。从无始来曾未得者由加行得。若曾串习无胜势用。及彼种类由离染得。若起现前皆由加行。佛于一切皆离染得。随欲现前不由加行。三乘圣者后有异生。通得曾得未曾得者。所余异生唯得曾得。约四念住辩六通者。约境约体二义有殊。有说二通即天眼耳。所余四种以慧为性。彼说眼耳通是身念住境。余四皆是法念住境。然实六种皆慧为性。经说皆能了达境故。由此皆是法念住境。若约体辩则六通中。前三唯身。但缘色故。谓神境通缘外四处。天眼缘色。天耳缘声。若尔何缘说死生智知有情类。由现身中成身语意诸恶行等。非天眼通能知此事。有别胜智是通眷属。依圣身起能如是知。是天眼通力所引故。与通合立死生智名。他心智通三念住摄。谓受心法缘心等故。宿住漏尽经主欲令一一皆通四念住摄。通缘五蕴一切境故。而实宿住法念住摄。虽契经说念曾领受苦乐等事。是忆前生苦乐等受所领众具。即是杂缘法念住摄。漏尽如力或法或四。不应定言四念住摄。若约善等分别六通。有余师言。六皆是善而实眼耳唯无记性。余之四通一向是善。经主于此作是释言。天眼耳通无记性摄。是眼耳识相应慧故。若尔宁说依四静虑。随根说故。亦无有失。谓所依止眼耳二根。由四静虑力所引起即彼地摄。故依四地通依根故说依四言。或此依通无间道说。通无间道依四地故。此释不然。六通皆是解脱道摄。眼耳二识是解脱道。理不成故。应作是说。四静虑中有定相应。胜无记慧。能引自地胜大种果。此慧现前便引自地天眼天耳。令现在前为所依根发眼耳识。故眼耳二识相应慧非通。但可说言是通所引。如契经说无学三明。彼于六通以何为性。颂曰

  第五二六明　　治三际愚故
  后真二假说　　学有闇非明

论曰。言三明者。一宿住智证明。二死生智证明。三漏尽智证明。如其次第。以无学位。摄第五二六通为其自性。六中三种独名明者。如次对治三际愚故。谓宿住智通治前际愚。死生智通治后际愚。漏尽智通治中际愚。是故此三独标明号。又宿住通忆念前际自他苦事。死生智通观察后际他身苦事。由此厌背生死众苦。起漏尽通观涅槃乐。故唯三种偏立为明。又此三通如次能舍常断有见故立为明。又此能除有有情法三种愚故。偏立为明。有余师言。宿住能见过去诸蕴。展转相因次第传来都无作者。由此能引空解脱门。死生能观有情生死。下上旋转犹如灌轮。故不希求三有果报。由此能引无愿解脱门。厌离为门归无相法。故起漏尽无相解脱门。是故三通独标明号。此三皆名无学明者。俱在无学身中起故。于中最后容有是真通无漏故。余二假说体唯非学非无学故。由此最后得无学名。自性相续皆无学故。前之二种得无学名。但由相续不由自性。如施设论作如是言。有等持相应无覆无记慧。不由善故及无漏故得立圣名。由圣身中此可得故。说名为圣。此亦应尔。故名无学。有学身中有愚暗故。虽有前二不立为明。虽有暂时伏灭愚暗。后还被蔽。不可立明。要暗永无。方名明故。契经中说示导有三。彼于六通以何为性。颂曰

  第一四六导　　教诫导为尊
  定由通所成　　引利乐果故

论曰。三示导者。一神变示导。二记心示导。三教诫示导。如其次第。以六通中第一四六。为其自性。唯此三种引所化生。令初发心最为胜故。能示能导立示导名。三示导中教诫最胜。定由通所成故。定引利乐果故。谓前二导咒等亦能。不但由通故非决定。如有咒术名健驮梨。持此便能腾空自在。或有药草具胜功能。若服若持飞行自在。复有咒术名伊刹尼。持此便能知他心念。或由观相听彼言音。亦能了知他心所念。教诫示导。除漏尽通。余不能为。故是决定。或前二导外道亦能。第三不然。故名决定。又前二导有但令他暂时回心。不能引得毕竟利益及安乐果。教诫示导亦定令他引当利益及安乐果。以能如实方便说故。由此教诫最胜非余。神境二言为目何义。颂曰

  神体谓等持　　境二谓行化
  行三意势佛　　运身胜解通
  化二谓欲色　　四二外处性
  此各有二种　　谓似自他身

论曰。神名所目唯胜等持。由此能为神变事故。而契经说。神果名神。意为举粗以显细故。又显胜等持是彼近因故。然神变事体实非神。此广如前觉分中辨。诸神变事说名为境。此有二种。谓行及化。行复三种。一者运身。谓乘空行犹如飞鸟。二者胜解。谓极远方作近思惟便能速至。若于极远色究竟天。作近思惟即便能至。本无来去。何谓速行。此实亦行但由近解。行极速故得胜解名。或世尊言。静虑境界不思议故。唯佛能了。三者意势。谓极远方举心缘时。身即能至。此势如意得意势名。如心取境顷至色究竟故。于此三中意势唯佛。运身胜解亦通余乘。谓我世尊神通迅速。随方远近举心即至。由此世尊作如是说。诸佛境界不可思议。如日舒光蕴流亦尔。能顿至远故说为行。若谓不然此没彼出。中间既断行义应无。或佛威神不思议故。举心即至不可测量。故意势行唯世尊有。胜解兼余圣运身并异生。化复二种。谓欲色界。若欲界化外四处除声。若色界化唯二谓色触。以色界中无香味故。此二界化各有二种。谓属自身他身别故。身在欲界化有四种。在色亦然。故总成八。虽生在色作欲界化。而无色界成香味失。化作自身唯二处故。有说亦化四如衣等不成。非神境通能起化事。要此通果诸能化心。此能化心有几何相。颂曰

  能化心十四　　定果二至五
  如所依定得　　从净自生二
  化事由自地　　语通由自下
  化身与化主　　语必俱非佛
  先立愿留身　　后起余心语
  有死留坚体　　余说无留义
  初多心一化　　成满此相违
  修得无记摄　　余得通三性

论曰。能变化心总有十四。谓依根本四静虑生。初静虑生唯有二种。一欲界摄。二初静虑。第二第三第四静虑。如其次第有三四五。无上依下。下地劣故。上下地系一静虑果。所依行等地有胜劣。一地系上下静虑果。地虽等所依行胜劣。下系上果下果上系。如次地劣胜所依行胜劣如得静虑化心亦然。果与所依俱时得故。然得静虑总有三时。离染受生加行异故。谓离下染得上静虑时。亦得此定所引化心果。从上地殁生色界时。及由加行起胜功德。但有新得所依静虑。亦兼得彼所引化心。依欲界身得阿罗汉。及练根位得应果时。十四化心一时总得。乃至身在第四静虑。得阿罗汉得五化心。无从化心直出观义。此从净定及自类生。能无间生自类净定故唯从二生二非余。唯自地化心起自地化事。化所发语由自下心。谓欲初定化唯自地心语。上化起语由初定心。彼地自无起表心故。若生欲界第二定等。化事转时如何起表。非威仪路工巧处心。依异界身而可现起。彼必依止自界身故。此无有过。引彼界摄大种现前为所依故。谓引色界大种现前。与欲界身密合而住。依之起彼能发表心。无定地表心依散地身过。或起依定能发表心。如依定生天眼耳识。若一化主起多化身。要化主语时诸化身方语。言音诠表一切皆同。故有伽他作如是说

  一化主语时　　诸所化皆语
  一化主若默　　诸所化亦然

此但说余。佛则不尔。诸佛定力最自在故。与所化语容不俱时。言音所诠亦容有别。若上三地所化语时。初定表心现前发者。此心起位已出化心。应无化身化如何语。由先愿力留所化身。后起余心发语表业。故无化语阙所依过。非唯化主命现在时。能留化身令久时住。亦有令住至命终后。即如尊者大迦叶波。留骨锁身至慈尊世。唯坚实体可得久留。异此饮光应留肉等。有余师说。愿力留身必无有能令至死后。圣大迦叶留骨锁身。由诸天神持令久住。初习业者由多化心。要附所依起一化事。习成满者由一化心。能不附所依起众多化事。总有二类能变化心。一修所成。二生得等。所起化果亦如彼说。修所成化摄处如前。不能化为有情身故。生所得等。于欲界中化为九处。色界化七依不离根。言化九等理实无有能化作根。修果无心余化容有。修果起表由化主心。余容自心起身语表。修果饮食若为资身。必在化主身中消化。若为余事吞金石等。或即住彼化事身中。或随所宜置在别处。余化饮食随住所依。修果化心唯无记性。余通三性。谓善恶等。如天龙等能变化心。彼亦能为自他身化。天眼耳言为目何义。为目慧体。为目色根。若慧不应名天眼耳。若色根者不应名通。此前已说前何所说。谓说根本四静虑中。有定相应胜无记慧。名为天眼及天耳通。此所引生胜大种果名天眼耳。其体是何。颂曰

  天眼耳谓根　　即定地净色
  恒同分无缺　　取障细远等

论曰。此体即是天眼耳根。谓缘声光为加行故。依四静虑于眼耳边。引起彼地微妙大种。所造净色眼耳二根。见色闻声名天眼耳。如是眼耳何故名天。体即是天。定地摄故。极清净故。立以天名。由此经言。天眼耳者无有皮肉筋缠血涂。唯妙大种所造净色。然天眼耳种类有三。一修得天。即如前说。二者生得。谓生天中。三者似天。谓生余趣由胜业等之所引生。能远见闻似天眼耳。如藏臣宝菩萨轮王。诸龙鬼神及中有等。修得眼耳过现当生恒是同分。以至现在必与识俱。能见闻故处所必具无翳无缺。如生色界一切有情。能随所应取彼障隔。极细远等诸方色声。故于此中有如是颂

  肉眼于诸方　　被障细远色
  无能见功用　　天眼见无遗

前说化心修余得异。神境等五各有异耶。亦有。云何。颂曰

  神境五修生　　咒药业成故
  他心修生咒　　又加占相成
  三修生业成　　除修皆三性
  人唯无生得　　地狱初能知

论曰。神境智类总有五种。一修得。二生得。三咒成。四药成。五业成。曼驮多王及中有等。诸神境智是业成摄。有余师说。神境有四。即前行三变化为一。言变化者。如契经言。分一为多。乃至广说。他心智类总有四种。前三如上加占相成。余三各三。谓修生业。除修所得皆通善等。非定果故不得通名。人中都无生所得者。余皆容有。随其所应本性生念业所成摄。人由先业能忆过去。于地狱趣初受生时。唯以生得他心宿住知他心等。及过去生苦受逼已更无知义。彼忆过去以何证知。如契经言。彼自忆念。我等过去曾闻他说诸欲过失。而不厌离。故于今时。受斯剧苦。彼唯能忆次前一生。余趣随应恒有知义。傍生知过去。如蠡声狗等鬼知过去。如有颂言

  我昔集众财　　以法或非法
  他今受富乐　　我独受贫苦

天知过去。如有颂言

  我施逝多林　　蒙大法王住
  贤圣僧受用　　故我心欢喜

又契经说。诸生天者初生必起三种念言。我从何殁今生何处。乘何业故来生此间

说一切有部顺正理论卷第七十六阿毗达磨顺正理论卷第七十七

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩定品第八之一

如是已辩诸智差别。次当分别智所依定。唯诸静虑能具为依。故于此中先辩静虑。或于先辩共功德中。已辩智所成无诤等功德。余所成德今次当辩。于中先辩所依止定。且诸定内静虑云何。颂曰

  静虑四各二　　于中生已说
  定谓善一境　　并伴五蕴性
  初具伺喜乐　　后渐离前支

论曰。一切功德多依静虑。故应先辩静虑差别。此总有四种。谓初二三四。岂诸静虑无如慈等不共名想。而今但说初等四数建立别名。此中非无不共名想。然无唯遍摄一地名。以诸静虑各有二种。谓定及生有差别故。诸生静虑如先已说。谓第四八前三各三。无有别名总诠一地。诸定静虑总相无别。谓此四体总而言之。皆善性摄。心一境性以善等持为自性故。若并助伴五蕴为性。此二既同难知差别。相虽无别而地有异。为显地异就数标名。故说为初乃至第四。此中经主自兴问答。何名一境性。谓专一所缘。彼答非理。眼意二识若同一所缘应名一境性。故于此处应求别理。谓若依止一所依根。专一所缘名一境性。岂不一念无易所缘。应一切心中皆有一境性。理实皆有。一一刹那。心心所法一境转故。然非一切皆得定名。以于此中说一境性。但为显示由胜等持。令善心心所相续而转故。若尔即心依一根转。引缘自境余心续生。此即名为心一境性。应离心外无别等持。此难不然。前已说故。谓先广辩心所法中。已辩等持离心别有。谓若心体即三摩地。令心作等亦应无别。差别因缘不可得故。如是等难具显如前。故非即心名三摩地。依何义故立静虑名。由依此寂静方能审虑故。审虑即是实了知义。如说心在定能如实了知。审虑义中置地界故。此论宗审虑定以慧为体。依训释理此是凝寂。思度境处得静虑名。定令慧生。无浊乱故。有说此定持胜遍缘。如理思惟故名静虑。胜言简欲界。遍缘简无色。如理思惟。简异颠倒。能持此定。是妙等持。此妙等持名为静虑。此言显示止观均行。无倒等持方名静虑。若尔染污宁得此名。由彼亦能邪审虑故。于相似处亦立此名。如世间言朽败种等。故无一切名静虑失。若善性摄心一境性。并伴立为四静虑者。依何相立初二三四。具伺喜乐建立为初。谓若位中善一境性。具与寻伺喜乐相应。如是等持名初静虑。颂中但说与伺相应。已显与寻亦相应义。以若有伺与喜乐俱。必无与寻不相应故。为显第二除伺建立。故颂但说具伺非寻。异此应言具寻喜乐。举寻有伺不说自成。渐离前支立二三四。离伺有二离二有乐。具离三种如其次第。故一境性分为四种。已辩静虑。无色云何。颂曰

  无色亦如是　　四蕴离下地
  并上三近分　　总名除色想
  无色谓无色　　后色起从心
  空无边等三　　名从加行立
  非想非非想　　昧劣故立名

论曰。此与静虑数自性同。谓四各二生如前说。即世品说。由生有四。定无色体总而言之。亦善性摄。心一境性依此故说亦如是言。然助伴中此除色蕴。无色无有随转色故。虽一境性并伴无差。离下地生故分四种。谓若已离第四静虑。生立空无边处。乃至已离无所有处生立非想非非想处。离名何义。谓由此道解脱下地惑。是离下染义。即此四根本并上三近分。总说名为除去色想。空处近分未得此名。缘下地色起色想故。非缘下色想可立除色名。若尔何缘大种蕴说。除去色想是第四定。彼缘欲界住自身中所有诸色。渐除去故非无色界。可有此想是除色想。前加行故立根本名。亦无有失。依何义故立无色名。鲁波言显可变示义。依可变示说名为色。阿言即显能制约义。为欲显示生死海中亦有暂时制约色处。依制约义说名为无。由彼界中制约变示。依无色义名阿鲁波。或此阿言兼显极义。虽于余界亦有不可变示法。而无色界是不可变示中极无。在此在彼所依诸色故。或此阿言兼显有义。为遮此界唯是色无故。说阿言显有无色。谓世亦有唯是遮言。亦见有能遮而兼表。如何显此非但是遮。故说阿言具显遮表。若异此者应说[褒-保+可]声。或此界中都无有色。理应建立[褒-保+可]鲁波名。然此名为阿鲁波者。[褒-保+可]鲁波体名阿鲁波。声虽短长而义无别。有言彼色微故亦名无。如物黄微亦名无黄物。如是所说。但有虚言。色相于彼不可说故。谓不可说彼有身语律仪。身语体既无。律仪不成故。若许彼界有身有语。如何乃许彼界色微。若彼界中身量小故。则傍生趣应有无色。有虫至微不可见故。若谓彼界身极清妙故。则中有色界应名无色。若谓彼身清妙中极。应唯有顶得无色名。如定生身有胜劣故。又生静虑所有色身。由定功能渐渐殊胜。上地望下清妙转增。非下地根所能取故。与彼何异不名无色。若见有名不如义故。及见有名通二义故。不可如名定执义者。则无色界有色无色。应审寻求教理为证。有执彼界决定有色。经说寿暖识和合而转故。既许彼界寿识非无。理应有暖。暖即是色。又说名色与识相依。如二芦束相依住故。既许彼界识体非无。是则亦应许有名色。又世尊说。四识住故。既许彼界有能住识。必应许有所住色等。如世尊言。若说离色乃至离行识有去来。此但有言。乃至广说。如是谓教亦有正理。若彼界中都无有色。彼没生下色从何生。或阿罗汉蕴相续断。应许后时蕴还相续。由斯教理彼色非无。此证不然。不审思故且初二教。如余契经。约欲色界密意而说。如说。名色缘生六处。及六触处名为士夫。岂许彼经通说三界。但依容有作如是说。若谓此经言无简别不应异释。理亦不然。无简别言有义异故。即如向者所引二经。又外物中应有寿识。彼有暖触及名色故。如此经言虽无简别而许外暖离寿识生。及外名色不依识转。如是经言。虽无简别。应许无色寿识离暖。唯名与识展转相依。又识住经亦不成证。此经意说。总离四种识有去来。无有是处。不言随离一识则无去来。故识住经言总意别。如世尊说。五无间等经谓契经言。造五无间者。次生必堕奈落迦中。岂随阙一无容堕彼。又说地动由四种因。虽无简别言应作差别解。又说有情由四食住。岂色无色住亦由段食耶。准彼诸经应通此教。若谓经说有一类天超段食故。又说彼天喜为食故。彼无段食。契经亦说。无色有情。故不应言彼界有色。若谓色少得无色名。如食少盐名无盐者。亦不应理。以契经言一切色想皆超越故。由此彼所引诸阿笈摩。不能证成无色界有色。彼所立理亦不成证。以彼界中虽都无色后没生下色从心生。现见世间色非色法。亦有展转相依起故。谓心异故色差别生。色根有别识生便异。故从无色将生下时。顺色生心相续而住。由彼势力引下色生。然不可言唯从彼起。亦以先世色俱行心相续为缘。久已灭色为自种子。今色方起。许同类因通过现故。诸阿罗汉般涅槃已。诸蕴相续。无余断故。现无少分诸蕴生缘。不可例同从无色没。故所立理为证不成。又无色界决定无色。契经说彼出离色故。谓契经言。出离诸色名无色界。若彼界中犹有色者。宁说出离。若谓余经说有不能出有。故知此经定有余意。此亦非理。彼契经中遮遍永出密意说故。有余于此作是释言。出离色经意作是说。欲界系法色界中无。色界系法无色界无。非无色中全无有色。但遮色界说出离言。或此契经意作是说。由色界系智出离欲界系惑。无色界系智出离色界系惑。非无色中全无有色。但遮色惑说出离言。又若经言出离诸色名无色界。即谓彼界都无有色。如是无色出离色界非色法故。彼界亦应无非色法。或如有非色。色法亦应有。非无色中有色界系色及非色。然经但说出离色言。故知不依总出色界名为无色。唯依离色说无色言。又如色界出离诸欲。诸欲种类色界都无。非色界中无色种类。如是无色界出离诸色。诸色种类无色界都无。非无色界中无无色种类。又如灭界出离有为。灭界都无诸有为法。如是无色界既出离诸色。亦应诸色彼界都无。又无色中决定无色。契经说彼除色想故。谓无色界断缘色贪。故说名为除去色想。若许彼界犹有诸色。于彼界色既未离贪。不应说为除去色想。虽有余部作如是言。非约色身言彼有色。以契经说离色染时。心于五界已得离染。唯于识界未得离染。故知无色定无色身。然有无漏随心转色。此但有虚言。彼无大种故。非无大种可有造色。无漏律仪随身生处。所有大种为能生因。有漏造色则不如是。勿有界地相杂过故。无漏不然。随身大造。彼无身故。无无漏色。又随转色彼界定无。以契经言彼有受类乃至识类。不言有色。若有色者应作是说。彼有色类如静虑中。又无色界决定无色。以契经言无色解脱。最为寂静超诸色故。非无色界有不超色。为简异彼说超色言。但为显成诸无色地。乃至细色亦决定无。是故说彼超过诸色。若谓所说超诸色言。依超粗色密意说者。此亦非理。说一切故。谓契经说。无色有情一切色想皆超越故。乃至广说。若谓无色实有色者。彼色自相定应可知。如何可言超色想等。故无色界细色亦无。教理极成不可倾动。如是已释无色总名。何故别名空无边等。且前三种名从加行。修加行位思无边空。及无边识无所有故。若由胜解思惟无边。空加行所成。名空无边处。谓若有法虽与色俱。而其自体不依属色。诸有于色求出离者。必应最初思惟彼法。谓虚空体虽与色俱。而待色无方得显了。外法所摄其相无边。思惟彼时易能离色。故加行位思惟虚空。成时随应亦缘余法。但从加行建立此名。有余师说。初离色地创违色故假立空名。有余复言。诸观行者由解脱色。即于此地受等蕴中。多住空想。依此建立空无边名。若由胜解思惟无边识加行所成。名识无边处。谓于纯净六种识身。能了别中善取相已。安住胜解。由假想力思惟观察无边识相。由此加行为先所成。随其所应亦缘余法。但从加行建立此名。有余师言。由意乐故及等流故。建立此名。谓瑜伽师将入此定。先起意乐缘无边识。从此定出起此等流识相。最为可欣乐故。将入已出俱缘识境。若由胜解舍一切所有加行所成。名无所有处。谓见无边行相粗动。为欲厌舍起此加行。是故此处名最胜舍。以于此中不复乐作无边行相。心于所缘舍诸所有。寂然住故。由想昧劣立第四名。谓此地中想不明胜。如无想故得非想名。而想非全无故名非非想。此地犹有昧劣想故。此言显示有顶地想。非如下七地故得非想名。非如三无心故名非非想。岂不有顶加行位中。诸瑜伽师。亦作是念。诸想如病如箭如痈。无想天中如痴如闇。唯有非想非非想天。与上相违寂静美妙。宁此不就加行立名。理实应然。以观行者必先厌想。及无想故。然或有问行者何缘修加行时作如是念。必应举此为酬问因。故说立名由想昧劣。此四无色皆言处者。以是诸有生长处故。谓此四处为有无有。生长种种业烦恼故。为破妄计彼是涅槃。故佛说为生长有处。已辩无色。等至云何。颂曰

  此本等至八　　前七各有三
  谓味净无漏　　后味净二种
  味谓爱相应　　净谓世间善
  此即所味着　　无漏谓出世

论曰。此上所辩静虑无色。根本等至总有八种。于中前七各具有三。有顶等至唯有二种。此地昧劣无无漏故。初味等至谓爱相应。爱能味着故名为味。彼相应故此得味名。爱相应言依自性说。此以等持为自性故。若并助伴应作是言。爱俱品法名味等至。此但取爱一果品法。净等至名目世善定。离惑垢故与无贪等。诸白净法共相应故。此是善故与味有殊。是有漏故与无漏别。此即是前所味着境。此无间灭彼味定生。缘过去净深生味着。尔时虽名出所味定。于能味定得名为入。诸从定出总有五种。一出地。二出刹那。三出行相。四出所缘。五出种类。从初静虑入第二等。名为出地。于同一地行相所缘。相续转位前念无间入于后念。名出刹那。从无常行相入苦行相等。名出行相。从缘色蕴入缘受等。名出所缘。从有漏入无漏。从不染污入染污等。名出种类。依出种类此中说言。从所味出入能味定。岂不二言更相违反。能味是爱非所入定。所入是定不名能味。如何可言入能味定。无相违过。现见相应随举一名说俱品故。如劝长者作意记别。互相杂故俱得二名。由爱相应等持名味。等持力故爱得定名。故无二言更相违过。有说定爱相续现前。诸后刹那缘前为境。所味即是前灭刹那。后生刹那说名能味。此能味爱现在前时。缘过去境不缘现在。自性相应及俱有法。以必不观自性等故。不缘未来未曾领故。于所缘境专注不移。方名为定。爱相应定亦专一境。故得定名。余惑相应则不如是。谓余烦恼于自所缘。不能令心专注如爱。故三摩地若与爱俱。专注一缘与善相似。无漏定者。谓出世定。爱不缘故非所味着。如是所说八等至中。静虑摄支非诸无色。以诸无色极寂静故。谓瑜伽师乐修善品。若于广大功德聚中。别建立支精勤修习。若诸无色寂静增故。心心所法昧劣而转。是故于彼不建立支。或彼地中等持偏胜。非一偏胜可立支名。要多法增方名支故。由此静虑独得立支。定慧均行多法增故。由此近分亦不立支。色近分中唯慧增故。有余师说。若诸地中有别心所。无余断灭方于此地立支非余。初静虑中忧苦断灭。第二静虑寻伺无余。第三灭喜。第四断乐。无色地中虽总渐灭。而无随地无余断灭。此释未能遣他疑问。何缘唯此方建立支。是故应如前释为善。于四静虑各有几支。颂曰

  静虑初五支　　寻伺喜乐定
  第二有四支　　内净喜乐定
  第三具五支　　舍念慧乐定
  第四有四支　　舍念中受定

论曰。唯净无漏四静虑中。初具五支。一寻。二伺。三喜。四乐。五心一境性。心一境性是定异名。定与等持体同名异。故言定者即胜等持。此中说为心一境性。第二静虑唯有四支。一内等净。二喜。三乐。四心一境性。第三静虑具有五支。一行舍。二正念。三正慧。四受乐。五心一境性。第四静虑唯有四支。一行舍清净。二念清净。三非苦乐受。四心一境性。何缘初三支各具五。第二第四唯各四支。各唯尔所堪立支故。或由欲界多诸恶法及妙五欲难断难舍。第二静虑有重地喜。其相动踊喜中之极。引五部爱难舍难断。为对治彼故初三各五支。初三不然故余各四。或为随顺超等至法。谓最初起超等至时。入异类难入同类易。然超等至初起位中。或从初入三。或从二入四。故二第四各唯四支。初及第三各具有五。后起则易故上无支。静虑支名既有十八。于中实事总有几种。颂曰

  此实事十一　　初二乐轻安
  内净即信根　　喜即是喜受

论曰。此支实事唯有十一。谓初五支即五实事。第二静虑三支如前。增内净支足前为六。第三静虑等持如前。增余四支足前为十。第四静虑三支如前。增非苦乐支足前为十一。何缘心等非静虑支。此应准前菩提分辩。有异彼者今略分别。受中立三非忧苦者。忧苦唯是欲界摄故。三受随地为利益支。顺定用强故皆支摄。何缘精进非静虑支。诸静虑支顺自地胜。精进顺上故不立支。或静虑支适分安乐。精进求胜策励疲苦。寻伺二种能助等持。制策于心令离粗细。对治欲恶故并立支。何缘无表非静虑支。诸静虑支助定住境。彼不缘境故不立支。故静虑支随地差别。虽有十八。而于实事种类中求应唯九种。然受相异故分十一。由此故说有是初支。非第二支。应作四句。第一句谓寻伺。第二句谓内净。第三句谓喜乐等持。第四句谓除前余法。余支相对如理应思。此中支名为目何义。目显成义。何所显成。谓显成此是初静虑。乃至此是第四静虑。或此支名目随顺义。如拘橼等名为饮支。谓十八支各顺自地。或资具义说名为支。如祠祀支即牛马等。谓寻伺等展转相资。毗婆沙师显静虑地等持最胜。故作是说。三摩地是静虑亦静虑支。寻伺等是静虑支非静虑。宁知静虑地等持最胜耶。以契经中作如是说。于四静虑应知定根。然于相成及相防护。义相似故作如是言。如四支军。亦无有失。如王与众虽互相资。而于其中王最为胜。岂不三定乐体是同。则静虑支应无十一。第三定乐以受为体。初二静虑乐即轻安。故静虑支实有十一。轻安行舍遍四静虑。何缘初二唯立轻安。后二地中唯立行舍。以此于彼偏随顺故。谓欲界中有诸恶法。初静虑地有寻伺想。能逼恼心犹如毒箭。初二离彼故轻安增。第二静虑喜极动涌。第三静虑乐受极增。二俱能为爱胜生处。三四弃彼故行舍增。或欲及初有色根识。所引粗重甚于余地。初二离彼故轻安增。三四地中离粗重远。寂静转胜故行舍增。谓轻安乐如初舍担。若更易地气分微薄。故唯初二建立轻安。三四地中任运而转。寂静转胜故立行舍。或初二定有轻安缘。喜与轻安为胜缘故。如契经说。喜故轻安。三四定中无喜缘故。轻安微劣。不立为支。行舍轻安互相覆蔽。若处有一第二便无。轻安治沈其相飘举。行舍治掉其相寂止。故安与舍互相覆蔽。何理为证知三乐支。二是轻安第三是受。已说于彼偏随顺故。谓第三定乐非轻安。安非彼支。次前已说。初二定乐必非乐受。是身心受俱非理故。谓初二乐必非身受。正在定中无五识故亦非心受。应即喜故要离喜爱。余地心悦方可异前立为乐受。喜即喜受。于一心中二受俱行。不应理故。若谓喜乐更互现起。无斯过者。理亦不然。说具五支及四支故。若谓五四约容有说。不必俱行。亦不应理。应有有寻无伺定故。然经但说有三等持。有寻有伺乃至广说。若静虑支非必俱起。何缘不说有有寻无伺定。又于欲界初静虑中。亦应具有三三摩地。是则违害契经所言。经主此中假引他说。谓定无有心受乐根。三静虑中说乐支者。皆是身受所摄乐故。若尔便害契经所说。如契经说。云何乐根。谓顺乐触力所引生身心乐受。实无违害。有余于此增益心言。余部经中唯说身故。何缘不谓余部契经。有余于彼削除心字。以契经说第二定等。无余识身心一趣故。若固说彼有身受乐。与理相违。如后当辩。虽第三定所立乐支。契经说为身所受乐。然不能证彼地乐根非心受摄。亦说离生喜是身所证故。岂可由此便执喜根非心受摄。又非色法亦见说身。谓六触身六受身等。若谓无色说名为身。无有身前不标名者。此非决定无色界中说身见故。又见于彼说身坏故。又说彼身下劣生故。又见经说此非汝身。亦非余身。谓六触处故。又色身前亦标别名故。如契经说。所有色身。故身前名有无不定。故知于此说意为身。此说身名为有何德。为显彼乐受自内所证故。谓彼地乐非所依缘。所能显了唯自内证。此则显彼乐受中极。亦见于自说以身声如说。由身证甘露界。则是自证甘露界义。或为显示如是乐受。相似先时由身所证。非似下地心所证者。为欲简别下心所证。故说彼为身所受乐。或为显示一切乐根。无不依止依色身识。由此已显轻安乐中亦有依止依非色识。则说彼乐一切地有。由是理趣此契经中。不分明说为意身所受乐。又若说意言有非受过故。谓若说为意所受乐。便谓此乐是境界受。然此不显第三定乐。为意所缘名境界受。但为显此能领相应。自所随触名自性受。是故于此不说意言。然为遣疑不总相说。若但总说所受乐者。便疑此乐受为境为现前。若标身言便无此惑。由有此德故应说身。又有乐根是心受摄。以经言我说入第三静虑。具足住修习乐。又说修习此乐受时。于乐随增贪随眠断。不可说此是身受乐。故不可说三静虑中所有乐支皆身受摄。定应信有心受乐根。又如何知初二定乐。是身受乐非心轻安。第四静虑轻安倍增。而不说彼有乐支故。此前已说。前说者何。轻安于彼不随顺故。又此轻安能生于乐。犹如乐境亦得乐名。故有乐地方得名乐。彼地无乐不得乐名。若尔第三定轻安应名乐。不尔。已说不随顺故。后二静虑所有轻安。体虽胜前而相昧劣。由前所说多种因缘。是故轻安在彼非乐。若初二乐即是轻安。便与契经有相违过。如契经说。若于尔时诸圣弟子。于离生喜身作证具足住。彼于尔时已断五法。修习五法皆得圆满。广说乃至。何等名为所修五法。一欣。二喜。三轻安。四乐。五三摩地。此经轻安与乐别说。若轻安即乐如何说有五。无违经过。由此经中所说乐言是乐根故。非此经内立静虑支。总说能修初定五法。又我宗不说轻安即乐根。但说轻安是乐因故。于初二定立为乐支。如此所言于义何失。以于一切佛圣教中。非唯乐受说名为乐。见有余法亦名乐故。谓契经言。乐有三种。一者断乐。二者离乐。三者灭乐。又契经言。乐有五种。一出家乐。二远离乐。三寂静乐。四菩提乐。五涅槃乐。有如是等众多契经。所说乐名目种种法。是故若说初二静虑乐根为支。便违正理。若说初二所有乐支即是轻安。无所违害

说一切有部顺正理论卷第七十七阿毗达磨顺正理论卷第七十八

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩定品第八之二

我宗定说。初二静虑乐根为支。违何正理。汝执身受方有乐根。非诸定中可起身识。岂不与此正理相违。此亦无违。以我宗许正在定位。由胜定力起顺乐受。妙轻安风遍触于身发身识故。如是救义未离前失。但起身识非在定故。谓我宗亦许正在定位。有离生喜乐所引极微遍在身中。如团中腻力能对治诸烦恼品。身之粗重摄益于身。亦说名为无恼害乐。然不许此在定位中。能触动身发生身识。此等持果如是生时。有力能令等持坚住。故此妙触起不唐捐。若此位中容起身识。外散乱故应坏等持。若谓此风从胜定起。引内身乐顺起等持。故身识生无坏定失。亦不应理。虽顺等持而身识生便非定故。正在定位有与定相违。不定识生如何不坏定。纵顺定故非永退失。然散心生宁非出定。非起顺定加行散心。已得名为正住定位。是故身识现在前时。理应名为已从定出。既尔宁说是静虑支。又此乐生应名定刺。由此乐受身识俱生。间杂定心令不续故。又以欲界身根为依。理不应生色界触识。故不可说身在欲界。身识俱受领色界中静虑所生妙轻安触。若谓此触依内起故。容依欲身发生彼识。此但有语无理教故。谓何理教证依欲身取色轻安非所余触。故彼所执违越理教。唯对法宗所说无失。上座于此作如是言。如何得知轻安名乐。无少圣教于轻安体立以乐名。又见于此余说名乐。于义无益故。若轻安体应说轻安名。非说轻安有无乐过。经说轻安是乐因故。如契经说。心喜故身轻安。轻安故身受乐。是故知乐非即轻安。破此同前经主所引。然彼所说。若是轻安体应说轻安名。此说非理。为避静虑支不易说过故。勿说初静虑离生喜轻安。又此义中轻安名乐。于义有益。下苦所恼。为令欣求上地生故。谓一切地皆有轻安。如何令知上地皆乐。发勤精进离下地染。故于轻安体假立以乐名。于此义中深成有益。虽轻安乐遍一切地。而今于此静虑支中。唯乐果因方说名乐。第二静虑虽无乐根。而说彼轻安为乐果因者。以乐根喜根俱说名乐故。言轻安故身受乐者。弥证轻安得名为乐。以轻安起能治身中惛沈品粗重性。令身轻妙安隐受乐。除此乐外必定无余。是尸罗等次第所得。故对法宗所说无过。今应思择。第三定中。意地悦受既得喜相。应名为喜。何故名乐。此名为乐亦有所因。以诸喜根不寂静故。谓喜动涌扰乱定心。如水波涛涌泛漂激。初二静虑意地悦受。有如是相故得喜名。第三定中此心悦受。其相沉静转得乐名。故此定中舍用增上。弃舍喜故立行舍支。第四定中复弃舍乐。故彼行舍得名清净。何缘念慧诸地皆有。而念唯在上二静虑。慧在第三定方得立为支。随其所应偏随顺故。谓喜与乐于三有中。是诸有情极所耽味。第三静虑所味中极。有生死中最胜乐故。理应立慧观察厌舍。若无慧者自地善根尚不能成。况进求胜。为治如是自地过失。第三静虑立慧为支。余地不然故不立慧。第二静虑有最胜喜。轻躁娆乱如逻刹私。第三定中有最胜乐。如天妙欲极为难舍。第三四定由行舍支。随其所应。虽已弃舍而恐退起立念遮防。余地不然故不立念。然第三念势用坚强。非唯助舍亦能助慧。通能防备自他地失。第四不尔。无自失故。由此第四不立慧支。或初二定寻喜飘动。虽有念慧防照用微。第四定中二舍所蔽。顺无明故慧用不增。故慧唯三。念通上二。或第三定乐过甚微。不立慧支。无能照察。若不照察则无厌求自地过患上地功德。然下寻喜上色过粗。虽照厌求未为奇特。故余三地。慧不立支。以第三定中乐过难。觉故佛说圣者应说。应知由此定中慧用。最胜能知细过故立。为支虽第四边慧亦能了。而但总相未为奇特。谓彼与乐系地不同。是离染道总观下过。非如自慧同一系缚。能别观失方谓希奇。故自立支。上慧不尔。又诸已得第三静虑。于第四边非皆自在。故于将离乐受染时。彼慧无容立为支体。故唯三定立慧为支。然正了时及初已离。皆应防守须立念支。何故轻安立为支体。以初二定轻安用增。触前所无殊胜位故。由此势用精勤不舍。能令相续有所堪能。能助等持令牵胜德有殊胜用故立为支。内等净名为目何法。目寻伺息于定心坚。有说先时寻伺鼓动令心于境不甚坚牢。今于所缘方能一趣。故说内等净目于定心坚。彼显此名目殊胜定。则内等净应无别物。第二静虑应唯三支。彼释但应朋友信受。无正教理堪为证故。非无圣教说有四支。言有三支依何圣教。故内等净体即信根。谓若证得第二静虑。则于定地。亦可离中有深信生。名内等净。故虽诸地皆有信根而可立支。唯第二定以今创信诸定地法。与散地法俱可离故。又初静虑寻伺识身。如热淤埿信不明净。后二静虑行舍用增。映夺信根故无内净。谓由警觉信力方增。舍此相违故能映夺。信是净相故立净名。如清水珠令心净故。内心平等为缘故生。由此信根名内等净。或第二定所有功德。平等为缘引生此净。由此建立内等净名。非唯寻伺静息为体。此等皆是心所摄故。如受想思别有实体。有余部说。喜非喜受。喜是行蕴心所法摄。三定中乐皆是喜受。故喜喜受其体各异。非三定乐可名喜受。二阿笈摩分明证故。如辩颠倒契经中说。渐无余灭忧等五根。第三定中无余灭喜。于第四定无余灭乐。又余经说。第四静虑。断乐断苦先喜忧没。故第三定必无喜根。由此喜受是喜非乐。如先所说八等至中。前七各三第八有二。诸染污定如何知有。此由契经及论说故。谓契经说。净无漏定已。犹言世尊未说一切定。故知有余染定未说。本论亦说。于诸静虑。自地一切随眠随增。由此等文知有染定。故说静虑总有二种。由定及生有差别故。定复有二。谓染不染。不染复二种。谓净及无漏。无漏复二。谓学无学。如是差别理有众多。染静虑中为有支不。有。非一切。何定无何。颂曰

  染如次从初　　无喜乐内净
  正念慧舍念　　余说无安舍

论曰。且有一类随相说言。初染中无离生喜乐。非离烦恼而得生故。虽染污定亦喜相应。非因离生故非支摄。此不唯说离欲生喜。亦说因离自地染生。以契经中先作是说。离诸欲恶不善法已。复作是言。离生喜乐。此中重说离生言者。为显亦有喜离自地惑生。为显喜支唯是善性。故薄伽梵与乐合说。轻安相应必是善故。由此染定必无喜支。故初染支唯有三种。第二染中无内等净。彼为烦恼所扰浊故。虽诸世间说有染信。而不信摄故不立支。乐是轻安唯善性摄。例同初定故不重遮。故此染支唯有二种。第二染定许有喜支。初染中无以何为证。以初定喜说从离生。第二中无离生言。故第三染中无正念慧。彼为染乐所迷乱故。染污定中虽有念慧。而得失念不正慧名。故此二支染中非有。行舍唯是大善法摄。例同第四故此不遮。故此染支唯有二种。第四染中无舍念净。彼为烦恼所染污故。由此第四染唯二支。有余师说。初二染定但无轻安。后二染中但无行舍。大善摄故。彼说染中喜信念慧。皆是支摄。皆通染故。契经中说。三定有动第四不动。依何义说。颂曰

  第四名不动　　离八灾患故
  八者谓寻伺　　四受入出息

论曰。下三静虑名有动者有灾患故。第四静虑名不动者无灾患故。灾患有八。其八者何。寻伺四受入息出息。此八灾患第四都无故。佛世尊说为不动。然经唯说第四静虑。不为寻伺喜乐动者。经密意说论依法相。以薄伽梵有处说言。断乐断苦先喜忧没。具足安住第四静虑。又说彼定身行俱灭。入息出息名为身行。故知此定非唯独免。寻伺喜乐四动灾患。有余师说。第四静虑如密室灯。照而无动故名不动。喻经说故寻伺何过。而求静息此能令心于定境界。虽恒系念而不寂静。如树枝条依茎而住。与风合故动摇不息。诸瑜伽师虽不愿乐。于境行相心速易脱。而寻伺力令彼驰流。故于定中寻伺有过。喜乐于定亦能鼓动。唯此四种与定相应。而能动心故经偏说。然实二息忧苦二受。亦能鼓动故论说八。寻伺二法既有此过。不应说在静虑支中。经但应言寻伺寂静。何容亦说有寻有伺为显寻伺。虽定相应而于定中。能为灾患不说不了。故定应说或此于定。初作资粮作欲恶寻远分治故。后于胜定方为灾患。故说寻伺功不唐捐。舍有行仪方便法尔。设是所舍初必应依。如欲渡河先依船筏。后至彼岸理应总舍。故契经言依色出欲。依无色出色依道出无色。若得涅槃亦出圣道。此二容有与一心俱。如胜劣风与一枝合。若此二业谓能鼓动。如何说此与定相应。粗浅定心寻伺所策。方能出离欲界粗染。故此得与初定相应。由此相应未为清净。如灯与日俱见色缘。灯细暗俱照不明了。日光离暗照用分明。如是应知初静虑定。虽作自事而寻伺俱。未照而无动如第四静虑。若寻在定能动乱心无漏定俱亦为灾患。何缘建立为一道支。已说彼能策正见故。行者于定未串习时。不能了知此为灾患。故于此地不欲厌舍。若已串习便能觉知。初静虑中有此灾患。如水澄净便有池中。潜下虫鱼能为浊乱。行者既见初静虑中。寻伺二法能为动乱。便于一地总生厌舍。谓此粗浅理应舍故。于初静虑寻伺既然。于上地中喜等亦尔。如定静虑诸受差别生亦尔不。不尔云何。颂曰

  生静虑从初　　有喜乐舍受
  及喜舍乐舍　　唯舍受如次

论曰。生静虑中初有三受。一者喜受意识相应。二者乐受三识相应。三者舍受四识相应。第二有二。谓喜与舍意识相应。无有乐受无余识故。心悦粗故。第三有二。谓乐与舍意识相应。第四有一。谓唯舍受意识相应。是谓定生受有差别。上三静虑无三识身及无寻伺。如何生彼能见闻触及起表业。非生彼地无眼识等。但非彼系所以者何。颂曰

  生上三静虑　　起三识表心
  皆初静虑摄　　唯无覆无记

论曰。生上三地起三识身。及发表心皆初定系。生上起下如起化心。故能见闻触及发表。此四唯是无覆无记。不起下染已离染故。不起下善以下劣故。如是别释静虑事已。净等等至初得云何。颂曰

  全不成而得　　净由离染生
  无漏由离染　　染由生及退

论曰。八本等至随其所应。若全不成而获得者。诸净等至由二因缘。一由离染。谓在下地离下染时。二由受生。谓从上地生自地时。下七皆然有顶不尔。唯由离染无上地故。无从上地于彼受生。此中但说本等至者。以诸近分未离染时。有全不成由加行得。遮何故说全不成言。为遮已成更得少分。如由加行得净本等至。及由退故得彼顺退分。即依此义作是问言。颇有净定由离染得。由离染舍。由退得。由退舍。由生得。由生舍耶。曰有。谓顺退分。且初静虑顺退分摄。离欲染时得。离自染时舍退。离自染得退。离欲染舍。从上生自得。从自生下舍。余地所摄应如理思。无漏但由离染故得。谓圣离下染得上地无漏。此亦但据全不成者。若先已成余时亦得。谓尽智位得无学道。于练根时得学无学。余加行及退皆如理应思。虽有由入正性离生。获得根本无漏等至。而非决定。以次第者尔时未得根本定故。此中但论决定得者。圣离下染必定获得。上地根本无漏定故。染由受生及退故得。谓上地没生下地时得下地染。及于此地离染退时得此地染。无由离染及加行得。如是二时能舍染故。何等至无间有几等至生。颂曰

  无漏次生善　　上下至第三
  净次生亦然　　兼生自地染
  染生自净染　　并下一地净
  死净生一切　　染生自下染

论曰。无漏次生。自上下善。善言具摄净及无漏。极相违故必不生染。然于上下各至第三。远故无能超生第四。故于无漏七等至中。从初静虑无间生六。谓自二三各净无漏。无所有处无间生七。谓自下六上地唯净。第二静虑无间生八。谓自上六并下地二。识无边处无间生九。谓自下六并上地三。第三四空无间生十。谓上下八并自地二。类智无间能生无色。法智不然依缘别故。从净等至所生亦然。而各兼生自地染污。故有顶净无间生六。谓自净染下净无漏。从初静虑无间生七。无所有八第二定九。识处生十余生十一。从染等至生自净染。并生次下一地净定。谓为自地烦恼所逼。于下净定亦生尊重故有从染生。次下净极相违故不生无漏。若于染净能正了知。可能从染转生下净。是则此净还从净生。以正了知是净摄故。非诸染污能正了知。如何彼能从染生净。先愿力故谓先愿言。宁得下净不须上染。先愿势力随相续转故。后从染生下净定。如先立愿方趣睡眠。至所期时便能觉悟。如是所说净染生染。但约在定净及染说。若生净染生染不然。谓命终时从生得净。一一无间生一切染。若从生染一一无间。能生自地一切。下染不生上者未离下故。所言从净生无漏者。为一切种皆能生耶。不尔云何。颂曰

  净定有四种　　谓即顺退分
  顺住顺胜进　　顺决择分摄
  如次顺烦恼　　自上地无漏
  互相望如次　　生二三三一

论曰。诸净等至总有四种。一顺退分摄。二顺住分摄。三顺胜进分摄。四顺决择分摄。地各有四有顶唯三。由彼更无上地可趣。故彼地无有顺胜进分摄。于此四中唯第四分能生无漏。所以者何。由此四种有如是相。顺退分能顺烦恼。顺住分能顺自地。顺胜进分能顺上地。顺决择分能顺无漏。故诸无漏唯从此生。有余师言。顺退分者住彼可退。顺住分者住彼不退。亦不升进。顺胜进分者住彼能升进。顺决择分者住彼起圣道。有言住彼顺通达谛。由此无间能入离生。应知此中决定义者。谓诸圣道必此无间生。非此无间必能生圣道。若异此者是则应说。唯世第一法名顺决择分。有余师言。顺退分者。与诸烦恼下上相杂。染净展转现在前故。顺住分者。能以种种粗等行相。弃背下地静等行相摄受自地。顺胜进分者。观自地过上地功德。顺决择分者。如暖顶忍世第一法。无漏无间何分现前。有说通三除顺退分。理实唯二谓后二种。诸有修习超等至等。唯顺决择最坚胜故。诸瑜伽师作如是说。若观行者于自地定。不善通达不恒安住。于上地定不能欣求。数数现行顺下地想。彼之等持名顺退分。或由自地离染退得名顺退分。成就此定补特伽罗名为退者。如成牛行说名为牛。凶勃难回说名牛行。于自地定耽着不舍。于上地定不能欣求。彼之等持名顺住分。于自地定虽能多住而不耽着。于上地定欣乐。牵引彼之等持。名顺胜进分。于自上定皆不耽着多住厌想。为欲令断彼之等持。名顺决择分。诸有安住顺退分者。于广大果心多系缚。诸有安住顺住分者。数住自定不能上求。诸有安住顺胜进者。能展转求所余胜定。然胜进分总有二种。一者自地殊胜功德。二者上地殊胜功德。若能牵引彼名顺胜进分。此有二类或厌或欣。诸有安住顺决择者。乐断诸有乐修无漏。是名安住四分者别。若顺烦恼名顺退分。诸阿罗汉宁有退理。非彼犹有顺退分定。可令现行离染舍故。虽有此难而实无违。谓顺住中有顺退者。亦得建立顺退分名。从彼有退如先已说。此四相望互相生者。初能生二谓顺退住。第二生三除顺决择。第三生三除顺退分。第四生一谓自非余。有说亦生顺胜进分。如上所言净及无漏。皆能上下超至第三。行者如何修超等至。加行成满差别云何。颂曰

  二类定顺逆　　均间次及超
  至间超为成　　三洲利无学

论曰。本善等至分为二类。一者有漏。二者无漏。往上名顺还下名逆。同类名均异类名间。相邻名次越一名超。谓观行者修超定时。先于有漏八地等至。顺逆均次现前数习。次于无漏七地等至。顺逆均次现前数习。次于有漏无漏等至。顺逆间次现前数习。次于有漏顺逆均超现前数习。次于无漏顺逆均超现前数习。是名修习超加行满。后于有漏无漏等至。顺逆间超名超定成。此中超者谓顿超二。一者超地。二者超法。唯能超一故至第三。远故无能超入第四。修超等至唯欲三洲除北俱卢。然通男女不时解脱诸阿罗汉。要得无诤妙愿智等。边际定者能超非余。定自在故无烦恼故。时解脱者虽无烦恼。定不自在。诸见至者虽定自在有余烦恼。故皆不能修超等至。胜解作意不能无间。修超等至势力劣故。此诸等至依何身起。颂曰

  诸定依自下　　非上无用故
  唯生有顶圣　　起下尽余惑

论曰。诸等至起依自下身。依上地身无容起下。上地起下无所用故。自有胜定故下势力劣故。已弃舍故可厌毁故。总相虽然若委细说。圣生有顶必起无漏无所有处。为尽自地所余烦恼。自无圣道欣乐起故。唯无所有最邻近故。起彼现前尽余烦恼。离无漏道必无有能。断彼余惑成阿罗汉。是故有顶无漏无所有处依九地身。有漏无所有处依八地身。有漏无漏识无边处依七地身。空无边处依六地身。乃至初定依二地身谓自及欲。若成就依有漏如起无漏。一切依九地身。诸等至中谁缘何境。颂曰

  味定缘自系　　净无漏遍缘
  根本善无色　　不缘下有漏

论曰。味定但缘自地有漏法。以有漏法是所系事故。所系言显是三有摄。不缘无漏法爱行相转故。若爱无漏应非烦恼。不缘上地法爱界地别故。不缘下地法已离彼贪故。净及无漏俱能遍缘。自上下地有为无为皆为境故。有差别者无记无为非无漏境。唯于有法说能遍缘。无非所缘前已说故。根本地摄善无色定。不缘下地诸有漏法。以下地法不寂静故。本善无色极寂静故。由此理故经于无色。皆言超越一切下地。于诸静虑不如是说。以本无色不缘下系。是故于下说超越言。诸静虑中有遍缘智。故于下地不言超越。既说超越色想等言。故知但依超所缘说。若此超越为显离系。应说超一切非唯色想等。又静虑中应言超越。自上地法无不能缘。虽亦能缘下地无漏。而但缘类不缘法品。以但能缘目全治故。法非全治如先已说。又法品道于无色界。虽能对治是客非主。亦不能缘下地法灭。既遮无色根本缘下。义准近分有缘下能。彼无间道必缘下故。味净无漏三等至中。何等力能断诸烦恼。颂曰

  无漏能断惑　　及诸净近分

论曰。诸无漏定皆能断惑。本净尚无能况诸染能断。谓本净定不能断下已离染故。不能断上以胜己故。不能断自与自地惑同一缚故。又自于自非对治故。若净近分亦能断惑。以皆能断次下地故。中间摄净亦不能断。近分有几何受相应。于味等三为皆具不。颂曰

  近分八舍净　　初亦圣或三

论曰。诸近分定亦有八种。与八根本为入门故。一切唯一舍受相应。作功用转故未离下怖故。此八近分皆净定摄。唯初近分亦通无漏。皆无有味离染道故。上七近分无无漏者。于自地法不厌背故。唯初近分通无漏者。于自地法能厌背故。此地极邻近多灾患界故。以诸欲贪由寻伺起。此地犹有寻伺随故。若尔何缘毗婆沙说。诸近分地有结生心。非无染心有结生理。故应近分有味相应。今于此中遮有定染。不遮生染故不相违。或有余师作如是说。初近分定亦有定染。未起根本亦贪此故。由此未至具有三种。中间静虑与诸近分。为无别义为亦有殊。义亦有殊谓诸近分。是离染道入根本因中间不然。复有别义。颂曰

  中静虑无寻　　具三唯舍受

论曰。初本近分寻伺相应。上七定中皆无寻伺。唯中静虑有伺无寻。故彼胜初未及第二。依此义故立中间名。由此上无中间静虑。一地升降无如此故。谓中间定初静虑摄而有差别。谓此减寻上立中间。减何成异故中间定初有上无。岂不契经说七依定。宁知别有未至中间。由有契经及正理故且有未至。如契经言诸有未能入初定等。具足安住而由圣慧。于现法中得诸漏尽。若无未至圣慧依何。又苏使摩契经中说。有慧解脱者不得根本定。岂不依定成慧解脱。由此证知有未至定有中间定。如契经说有寻伺等三三摩地。经说初定与寻伺俱。第二等中寻伺皆息。若无中静虑谁有伺无寻。以心心所渐次息故。理应有定有伺无寻。又大梵王是世界主。离中间定谁为胜因。由此证知有中间定。然佛不数说有未至中间。以二即初静虑摄故。说初静虑即已说彼。唯初近分名未至者。为欲简别余近分故。非此近分乘先定起。又非住此已起爱味。依如是义立未至名。非上定边亦名未至。皆乘先定势力引生。及住彼时已起味故。毗婆沙者作如是说。未至本地立未至名。是本地德未现前义。此中间定具味等三。以别系属一生处故。谓极修习中间定者。未来当在大梵处生。故亦具三如根本定。非根本地起爱贪彼。如所味有别能味亦别故。此有胜德可爱味故。无漏定生亦渐减故。此亦一向舍受相应。无三识身故无乐受。无喜受者已不共初。然于初贪未能离故。又由自勉功用转故。由此说为苦通行摄。非忧苦者已出欲故。由此一向舍受相应。此定能招大梵处果。多修习者为大梵故

说一切有部顺正理论卷第七十八阿毗达磨顺正理论卷第七十九

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩定品第八之三

已辩等至云何等持。经说等持总有三种。一有寻有伺三摩地。二无寻唯伺三摩地。三无寻无伺三摩地。如是三种相别云何。颂曰

  初下有寻伺　　中唯伺上无

论曰。前来因事屡辩此三。今于此中略显别相。有寻有伺三摩地者。谓与寻伺相应等持。此初静虑及未至摄。无寻唯伺三摩地者。谓唯与伺相应等持。此即中间静虑地摄。无寻无伺三摩地者。谓非寻伺相应等持。此从第二静虑近分。乃至非想非非想摄。契经复说三种等持。一空三摩地。二无愿三摩地。三无相三摩地。如是三种相别云何。颂曰

  空谓空非我　　无相谓灭四
  无愿谓余十　　谛行相相应
  此通净无漏　　无漏三脱门

论曰。空三摩地谓空非我。二种行相相应等持。故说空等持近治有身见。身见亦有二行相故。谓空行相近治我所见。非我行相近治我见。观法非我名非我行相。观此中无我名空行相。由此空行相近治我所见。以此中都无我。故此法非我所。岂不空行相即非我行相。知此非我此中无我。二种行相竟有何别。非无差别言此中无我。不能显我毕竟无体故。谓此但显彼此互无。不能显成毕竟无我。以有体法亦互无故。若言此法非我便显。我毕竟无以一切法。法相等故。由此若修非我行相便治我见。修空行相治我所见。如何无别无相三摩地。谓缘灭谛四种行相相应等持。涅槃离诸相故名无相。缘彼三摩地得无相名。相略有十。谓色等五男女二种三有为相。或复相者是因异名。涅槃无因故名无相。或相谓世蕴上中下。涅槃异彼故名无相。无愿三摩地。谓缘余谛十种行相相应等持。十行相者。谓苦非常因集生缘道如行出。如是空等三三摩地。三摩地相虽无差别。而依对治意乐所缘。如其次第建立三种。由意乐故不愿三有。理且可然有过患故。宁由意乐不愿圣道。以诸圣道依属有故。若尔何用修习圣道。以是涅槃能趣因故。非离圣道有得涅槃。为求涅槃故修圣道。道如船筏必应舍故。亦由意乐不愿圣道。故缘道行相亦得无愿名。以本期心厌有为故。空非我相非所厌舍。以与涅槃相相似故。由此二行相虽缘可厌法。不取可厌相不得无愿名。此三等持通净无漏。世出世间等持摄故。世间摄故通十一地。出世摄者唯通九地。上七定边无胜德故。于中无漏者名三解脱门能与涅槃为入门故。非诸有漏法是真解脱门。性住世间违解脱故。三三摩地缘境别者。若有漏空缘一切法。若无漏空唯缘苦谛。无愿能缘苦集道谛。无相唯缘灭谛为境。三三摩地念住别者。无相唯法余皆通四。契经复说三重等持。一空空三摩地。二无愿无愿三摩地。三无相无相三摩地。如是三种相别云何。颂曰

  重二缘无学　　取空非常相
  后缘无相定　　非择灭为静
  有漏人不时　　离上七近分

论曰。此三等持缘前空等。取空等相故立空空等名。空空等持缘前无学空三摩地。取彼空相空相顺厌胜非我故。谓彼先起无学等持。于五取蕴思惟空相。从此后起殊胜善根相应等持。缘前无学空三摩地。思惟空相于空取空故名空空。如烧死尸以杖回转。尸既尽已杖亦应烧。如是由空烧烦恼已。复起空定厌舍前空重空等持。空行相后起即复还与空行相相应。唯此最能顺厌舍故。非我行相则不如是。见无我者于诸有为法。起厌背心不如见空故。诸有已见诸法无我。而于诸有犹生乐者。以于诸行中不审见空故。由此空定虽二行相俱。而但名空不说为非我。空于厌舍极随顺故。无愿无愿缘前无学。无愿等持取非常相。谓彼先起无学等持。于五取蕴中思惟非常相。从此后起殊胜善根。相应等持缘前无学。无愿三摩地思惟非常相。于无愿不愿名无愿无愿。举喻显示如前应知。重无愿等持非常行。相后起即复还与非常行相相应。唯此可能缘厌道故。非苦行相能缘圣道。圣道非苦趣苦灭故。苦法不能趣苦寂灭。亦非因等四能缘圣道。以圣道不能令苦续故。非道等四者此厌舍道故。非欣行相能为厌舍。岂不如无愿不愿圣道。而作道等四此亦应然。此例不然。无愿正厌有兼于圣道起不愿心故。谓前无愿正厌于有。圣道依有故兼不愿。虽望意乐说不愿道。而于圣道非正憎厌。故亦能作道等四种。无愿无愿正憎厌道。故以非常观道过失。道等行相无容厌道。是故于此不作彼四。若道非常故可厌者。应于圣道作苦行相有彼相故。如契经言。诸非常即是苦非诸圣道。可有苦相安立谛理相各别故。谓依别相立苦谛名。圣道如何亦有苦相。又契经中简别说故。如契经说略说一切五取蕴苦。若道非常故有苦相应但说蕴。既言取蕴方是苦摄。由此证知圣道非苦。若谓譬如观集为苦。谛相虽别而见非倒。以五取蕴通苦集故。如是应知观道为苦。谛相虽别见亦非倒。以无漏蕴通苦道故。由此不坏安立谛理。此亦非理。且定不应观集为苦见非颠倒。以五取蕴因性名集。果性名苦其性各异。若观因为果必观果为因。差别因缘不可得故。则是倒见非谛观摄。宁为不坏安立谛理。是则应无苦集智异。或应苦道智如苦集智。所缘无别故共立遍知。谓彼既言苦集同体。观集为苦非颠倒见。二智境同故不别立遍知。如是应言苦道同体。观道为苦非颠倒见。二智境同故不别立遍知。既不许然道宁是苦。又道与苦事各别故。谓契经说无漏五根。于去来今能断众苦。又说道能断以生为本苦。又契经说道应修习苦应永断故道非苦。若谓经言法如船筏亦应断者。理亦不然。经不说法治所断故。谓于先时修圣道法所作已办。更不应修依应舍义说名应断。非治所断与苦不同。或经中法声目契经等法。应断言显得旨忘诠。或经所言法尚应断。显已与果无用因法。可舍名断如顺住分。非如苦性道亦可断。是故苦道其体各异。又若经言诸非常即是苦。即言圣道亦有苦相。经次亦言诸是苦即非我。应执涅槃非非我性。或应亦许是苦非常。许则定应非涅槃性。若谓但言诸是苦皆非我。不言非我皆是苦。何不亦言诸是苦皆非常。不言非常皆是苦。若谓非常体即是苦。苦即非我但名有异。则空无愿应无差别。以许非我即苦等故。若谓经言苦即非我。许一切苦皆非我性。此经既说非常即苦。应许非常皆是苦性。理实如是以此经中。所言非常不说道故。为依何法说非常言。以诸愚夫于五取蕴。执为常等起四颠倒。为破彼执说非常言。乘此复言非常即苦。此言意显有漏非常。皆是苦性苦皆非我。非说一切非常非我。理必应尔。以契经中于计常境说非常故。或于此中言非常者。非唯带生灭要命终受生。谓诸愚夫计人天乐。故经依彼有粗非常。说即是苦如三恶趣。以何为证知此经中。非常等言唯依有漏。由此经后复作是说。色受等诸法非我故。非常。岂可涅槃亦非常性。故知此经唯约圣慧。四种行相缘苦谛说。若谓圣道非常故应苦。宁不许道无漏故非苦。若谓于乐计为苦见。如何但言见灭断者。于灭谓苦其过重故。谓见涅槃以为苦者。极能增长乐生死心。见道不然是故偏说。如病厌药易可疗治。若厌病愈难为救疗。或诸圣道依苦而转。故见为苦过非甚重。由此论中略而不说。有余说故义不相违。又契经言。若于喜乐如实知乐。我定说彼于四谛理。如实现观故知有为非全是苦。由此于道可观非常。成重无愿必不观苦。无相无相即缘无学无相三摩地。非择灭为境。以无漏法无择灭故。但取静相非灭妙离。谓彼先起无学等持。于择灭中思惟静相。从此后起殊胜善根相应等持。即缘无学无相三摩地非择灭为境。思惟静相于无相灭。复观为无相名无相无相。举喻显示如前应知重无相等持。静行相后起即复还。与静行相相应。唯此能观非择灭故。非妙行相境无记故非离行相。以虽证得彼非择灭。犹缚随故非灭行相。以非择灭非永解脱一切苦故。又若观灭滥非常故。所言静者惟显止息。故非择灭得有静相。以修圣道经久劬劳。于彼息中便生乐想。故重无相取静非余。重三等持唯是有漏。以于圣道生厌舍故。非无漏定厌舍圣道。二缘圣道取空非常。理可名为厌舍圣道。无相无相但缘无为作静行相。何名厌道此欣无学无相等持。不转之因故名厌道。谓彼定起义作是言。无相等持不生为善。此既欣赞圣道不生。如何不名厌舍圣道。前无相定非此所缘。如何此名无相无相。或应许此定不缘非择灭。但缘无学无相不生。此亦不然准前释故。谓缘无相定非择灭。此非择灭亦离诸相。缘无相无相故得无相无相名。缘无相境作静行相。是故此定从境立名。唯三洲人能起此定通依男女。以依女身亦能自在。延促寿故唯无学位。以有学者但欣圣道未能厌故。此亦非一切唯不时解脱。以时解脱爱圣道故。依十一地除上七边。以上七边无胜德故。若在欲界从未至摄圣道后起。若在有顶无所有摄圣道后生。余皆自地圣道后起就总类说。此从法类苦灭四智无间而生。若就别说欲界摄者非类后生。上界摄者非法后起。前二非灭后起。第三非苦后生。余行相后起此定故。应得此者皆尽智时由离染得。后由加行方起现前。唯我世尊不由加行。顺趣解脱起此现前。于道尚厌岂欣诸有。此后亦起圣道现前。然厌道故非无间起。欲界摄者是思所成。余修所成依定起故。契经复说四修等持。一为住现法乐修三摩地。二为得胜知见修三摩地。三为得分别慧修三摩地。四为诸漏永尽修三摩地。如是四种相别云何。颂曰

  为得现法乐　　修诸善静虑
  为得胜知见　　修净天眼通
  为得分别慧　　修诸加行善
  为得诸漏尽　　修金刚喻定

论曰。如契经说有修等持。若习若修若多所作。得现乐住乃至广说。善言通摄净及无漏。修诸善静虑得住现法乐。而经但说初静虑者。于中乐想最增盛故。谓超欲界众多过失。故于此中乐想增盛。如游砂碛热渴疲劳。创饮浊水亦生胜乐。或圣道乐此具有故。谓具一切菩提分法。四沙门果九断遍知三界对治。又诸定首诸定乐因。是故偏说。岂不经说如是苾刍。住此先受离生喜乐。后生梵众受乐同此。何故不言住后法乐。详此唯说现法乐者。为令弃舍乐现欲乐。说现定乐令其欣乐。或现乐住是后乐依。但说所依能依已显。如契经说。先住此间入诸等至后方生彼。或现法乐三乘皆住。后乐不定是故不说。谓或退堕或上受生或般涅槃便不住故。虽诸静虑即现法乐。依近分故说为得。言修近分力得根本故。或即依现乐说为得言。如言石子体故无有过。有说此定佛依自说。如说菩萨居赡部林。起初世间似无漏定。能引一切有情共乐。由此不说后法乐住。即由此故亦但说初。菩萨尔时唯得初故。若依诸定修天眼通。便能获得殊胜知见。此依何义立知见名。本静虑中有遍照智。此遍照故立以见名。见体即知故名知见。眼根名见世所极成。为简异彼以知标见。或即此见决断所缘。故名为知即亦名见。谓本静虑是乐行道。不多劬劳而现前故。不劬劳故其体坚牢。由体坚牢故用决定。用决定故立以知名。见义如前故名知见。为知为见修此等持。即是为求决定照义。此亦善逝依自而说。谓为显佛以天眼通。观诸有情死生险难。方为拔济起静虑等。故为知见修天眼通。有余师言。为欲胜伏诸随烦恼起胜知见。起此胜知见不离光明想。此光明想引天眼通。由天眼通得胜知见。若修三界诸加行善。及无漏善得分别慧。谓从欲界乃至有顶。诸闻思修所成善法。及余一切无漏有为。总说名为加行善法。修此善法能引慧生。于诸境中差别而转。故言修此得分别慧。如说善逝住二寻思。能如实知诸受起等。此显修善得分别慧。说加行言为简生得。非修习生得得未曾得故。若修金刚喻定便得诸漏永尽。谓若修习第四静虑。金刚喻定并随转法。便能获得诸漏永尽。第四静虑佛依自说。无上菩提依此得故。金刚喻定顿证漏尽。引尽智生是故偏说。有说一切有顶断治。第四静虑皆此所摄。此经所说若习若修。若多所作义差别者。为欲显示习修得修所治。更远如其次第如是。已辩所依止定。当辩依定所起功德。诸功德中先辩无量。颂曰

  无量有四种　　对治嗔等故
  慈悲无嗔性　　喜喜舍无贪
  此行相如次　　与乐及拔苦
  欣慰有情等　　缘欲界有情
  喜初二静虑　　余六或五十
  不能断诸惑　　人起定成三

论曰。无量有四。一慈二悲三喜四舍。言无量者无量有情为所缘故。此四能引无量福故。无量爱果此为因故。有说此能违无量戏论故。贪等诸惑皆名戏论。何缘无量四无增减。对治四种多行障故。如契经说。若习若修若多所作慈能断嗔。悲能断害。喜断不欣慰。舍断欲贪嗔故唯有四。嗔谓心所。欲杀有情欲恼有情心所名害。耽着境界于诸善品。不乐住因名不欣慰。于妙欲境起染欣乐。情无厌足名为欲贪。此中慈悲无嗔为性。若尔此二有何差别。性虽无别然慈能治。杀有情嗔欢行相转。悲是对治恼有情嗔戚行相转。是谓差别。如苦与乐领纳。虽同而损益殊故。体有别苦乐体别如先已辩。慈悲二种差别亦然。有作是言。悲是不害近治害故理实如是。但害似嗔似嗔名说。悲之行相亦似无嗔立无嗔名实是不害。诸古师说。喜即喜受何缘观行者尔时喜受生。若缘与乐与慈无异。若缘拔苦应与悲同。又契经言。欣故生喜喜即喜受如先已辩。此喜行相与彼欣同。喜故生喜义有何异。若言下上义有异者。轻安与乐义亦应然。差别因缘不可得故。又违本论云何名喜。谓喜喜相应受想行识等。此中意显喜俱品法。喜增上故总立喜名。非受受俱其理决定。若喜即喜受何言与受俱。若言对法以理为量应如无过。诵本论文此亦不然。理为量论要有经证方可定文。若与经违理必可坏。不应随意辄改论文。是故此喜定非喜受。以欣为体或即无贪。谓别有贪是恶心所。于有情类作是思惟。云何当令诸所有乐。彼不能得皆属于我。喜能治彼故是无贪。此与喜根必俱行故。三地可得如悔忧俱。喜亦无贪分明相者。于他盛事心不贪着。知他获得深生欣慰。心热对治说名为喜。故知此喜亦无贪性。舍无量体唯是无贪。此与第三有差别者。离爱恚想等缘有情。如创入林等生树觉。平等行因说名为舍。若舍无量亦能治嗔。宁唯无贪与慈何异。又许此舍正治欲贪。与不净观有何差别。且舍与慈有差别者。慈能对治嗔所引嗔无嗔为体。舍能对治贪所引嗔无贪为体。岂不如舍无贪为性。亦能对治贪所引嗔。如是许慈无嗔为性。亦应能治嗔所引贪。此难不然。行相违故谓舍行相。双违贪嗔舍亲非亲差别相故。从此爱恚俱不生故。即由此故舍唯无贪。正能治贪兼治嗔故。慈之行相违嗔非贪。于诸有情与乐转故。由此慈舍虽俱违嗔。而慈顺贪舍能违害。是故此二极有差别。或修舍者治非处嗔。慈治处嗔故有差别。不净与舍如次能治。淫贪余贪故有差别。此四无量非损益他。何缘唯善非无记性。能近对治贪嗔等故。爱非爱相不能引故。力能令心自在转故。慈等体相已略分别。此阿世耶有差别者。观有情类如己谓慈。乐有情类离苦谓悲。于他兴盛欣慰谓喜。于亲怨相不思谓舍。又不观他有损有益。等观一切如友谓慈。于遭苦者哀愍谓悲。由胜解力想有情类。得益离损欣慰谓喜。于有情相等观谓舍。此四行相有差别者。云何当令诸有情类得如是乐。如是思惟入慈等至。云何当令诸有情类离如是苦。如是思惟入悲等至。诸有情类得乐离苦岂不快哉。如是思惟入喜等至。诸有情类平等平等无有亲怨。如是思惟入舍等至。如是所愿竟无有成岂不唐捐。修定功力能伏嗔等宁谓唐捐。应是颠倒何能伏惑。愿得乐等宁谓颠倒。谓此不言已得乐等。但由胜解愿诸有情当得乐等。能伏诸惑故修此四功不唐捐。于定蕴中说四行相六何令等。具如前说。言如是思惟入某等至者。此言若就等无间缘。慈等应无无间生理。别别思惟所引起故。若俱生者入言相违。初业位中别加行引。至成满位亦有俱生。定蕴就初说入无过。且慈无量愿得何乐。有说愿得第三定乐。诸受乐中此最胜故。若自未证由闻故知。有说愿得涅槃妙乐。于诸乐中此最胜故。有说愿得阿罗汉乐。此已解脱诸烦恼故。初修业者未证此乐。未现证故不能运心。但缘己身随所证乐。及他所证现可知者。愿诸有情同证此乐。故但缘现如理所生。无染污乐愿他同受。若于所受已舍苾刍。设未获得真实对治。亦处空闲受远离乐。力能映夺天帝等喜。如五乐等伽他中说又住远离勤修善者。定有善得念念恒流。如大海水遍满相续。喜轻安乐由此引生。以无吝心缘如是乐。愿诸含识一切同受。有余受胜学无学乐。如何观劣以授于他。不于当来还招劣果。若谓不欲以此与胜。便违遍缘有情为境。但由无吝福资所依。实不能令他得乐故。如有贫者以己所受粗弊资具。召施富人虽诸富人不求此惠。而彼施者亦无有失。表自敬心无所吝故。此亦如是故无有失。如于良田殖一细种。后所得果多而复大。如半核娑诸瓜瓠等。故非观劣以授于他。便于当来还招劣果。皆缘欲界有情为境。能治缘彼嗔等障故。谓于欲界有怨亲中。三聚有情能生嗔等。于中有舍怨亲等相。便能伏除嗔等烦恼。是故此境唯欲有情。必不能缘色无色界。大悲体是无痴善根。由此力能通缘三界。若四无量唯缘有情。何故经言。思一方等此由胜解。总缘器中一切有情故无有失。此四通在欲色界系。以契经说无量能招梵释轮王殊胜果故。品类足论依修所成。说七智知色界修断。及彼遍行随眠随增。有余师言。此四无量加行通欲本唯色界。此四无量依地别者。若喜即喜受唯是修所成。彼应说喜唯初二定。以于余地无喜根故。若喜异喜受亦通思所成。彼应说喜通依七地。与乐舍受亦相应故。有余说。喜唯喜受俱。彼则应言喜通三地。或应如颂唯二非余。慈悲舍三通依六地。谓四静虑未至中间。或有欲令唯依五地。谓除未至是容豫德。已离欲者方能起故。有说此四唯欲及初得无量名。余地不尔。经说无量名梵住故。又说修无量生梵世故。又说招梵释轮王果故。有说随应通依十地。谓欲四本近分中间。若悲亦依下三静虑。如何得与喜乐相应。悲缘苦有情戚行相转故。此如无漏厌作意生。是故通依下三静虑。彼真实作意能顺生欣。喜乐相应可无有过。此胜解作意不顺生欣。如何可言与彼相似。疑是戚性不顺生欣。如何许疑喜乐俱起。胜解作意应与彼同。然此于欣极相随顺。力能引生真作意故。疑则不尔极违真故。彼尚相应此宁不许。此胜解作意理应违欣。有欢戚处中行相别故。悲既戚行相转应非喜乐相应。勿二行相俱时转故。若尔应不许与舍受相应。舍受处中行相转故。既非不许舍受相应。与喜乐俱理定应许。勿全不与受相应故。虽言此四能治嗔等。而不能断诸烦恼。得胜解作意相应起故。真实作意方能断惑。又此唯缘有情境故。缘法作意方能断惑。又此唯缘现在境故。通缘三世或缘非世方能断惑。又解脱道此可得故。要无间道方能断惑。有作是说。有漏根本静虑摄故。此因有失。不应说三依六地故。未至中间此应无故。经何故说此断嗔等。亦不相违。断有二故。或由此力引断道故。谓伏嗔等引断道生。是故经中说断嗔等。若尔何故契经中说。由善修慈住不还果。此中圣道以慈名说。如于余处说想名等。或依圣者先得慈心。后数修行得离欲说。或依为得修所成慈。精进修行得离欲说。有说此四依欲色身。无色不缘怨亲等故。修此必应先缘彼故。如实义者。唯依欲身于欲界中唯人能起。若喜非喜受成一必具四。若喜即喜受成一定成三。生第三定等唯不成喜故。依何义故契经中说。修四无量慈极至遍净。悲极至空无边处。喜极至识无边处。舍极至无所有处。云何色界法能招无色果。又四静虑无不有慈。何缘修慈唯极遍净。有余于此倦于思寻。仰推慈尊当解此义。传闻具寿迦多衍尼子。曾以此义问设摩达多。彼尊寻思便入寂定。至明清旦欲为解释。时衍尼子复入寂定。时未会遇各般涅槃。由此迄今无能释者。毗婆沙者作是释言。应知此经依相似说。谓乐受法与慈相似。慈作与乐行相转故乐至遍净。上地皆无故说修慈极于遍净。求离苦法与悲相似。悲作拔苦行相转故。色身能作粗苦生因。有身便有断首等故。空处近分厌离色身。故说修悲极于空处。轻安乐法与喜相似。喜作安乐行相转故。识无边处轻安乐增。缘自无边识为门故。无边识相极增安乐。故说修喜极于识处。能弃舍法与舍相似。舍作弃舍行相转故。无所有处由近分中。弃舍无边行相成满。是故说修舍极无所有处。有言此经依相顺说。谓从慈定起欣等流顺第三定。从第三定起欲等流。亦顺慈定如是乃至。舍无所有起欲等流展转相顺。此不显理但有虚言。或应于中更求深趣。有言此经就意乐说。谓乐慈者乐第三定。乃至乐舍者乐无所有处。此亦无理由何证知。是故应如前释为善。初欲引起四无量时。先于有情分为三品。所谓亲友处中怨仇。三各分三谓上中下。上亲友者。谓生法身赖彼重恩舍便难住。中亲友者。谓财法交极相亲爱。下亲友者。谓唯财交亦相亲爱。上处中者。谓于自昔曾不见闻。中处中者。谓虽见闻而不交往。下处中者。谓虽交往而离恩怨。上怨仇者。谓夺名誉命及亲友。中怨仇者。谓夺己身命缘资具。下怨仇者。谓夺亲友命缘资具。于诸有情。分品别已。初修慈者。先于上亲发起清净与乐胜解。若由无始数习所成。恶阿世耶令心刚强。少遭逼恼便怀深恨。缘此还息与乐胜解。复应策励思其重恩。于彼复生与乐意乐。数习力故恨意永亡。与乐胜解相续无替此既成已。于中下亲亦渐次修如是胜解。于亲三品既得等心。次总于处中下中上怨所。渐次修习与乐意乐。乃至最后于上怨亲。得平等心都无升降。齐此名曰修慈成满。修悲及喜例此应说。谓观三苦遍逼有情。不应于中复加以苦。但应如已勤加济拔。渐次修习欲济拔心。乃至怨亲等无升降。齐此名曰修悲成满想。诸有情得乐离苦。深生欣慰如己无差。齐此名曰修喜成满。初修舍者。先舍处中非先舍怨亲恚爱难舍故。又处中品顺舍力增于中如前。先舍上品次舍中下及与怨亲。从下至中从中至上。先舍怨者以亲难舍故。如契经说。贪难断非嗔如是渐次修习。于舍至上亲友等上处中。普于有情舍差别相。齐此名曰修舍成满。若于有情乐求功德。彼于慈等能速修成。非于有情乐求过者。以断善者有德可录。麟喻独觉有失可取。先福罪果现可见故

说一切有部顺正理论卷第七十九阿毗达磨顺正理论卷第八十

        尊者众贤造

        三藏法师玄奘奉　诏译

    辩定品第八之四

已辩无量。次辩解脱。颂曰

  解脱有八种　　前三无贪性
  二二一一定　　四无色定善
  灭受想解脱　　微微无间生
  由自地净心　　及下无漏出
  三境欲可见　　四境类品道
  自上苦集灭　　非择灭虚空

论曰。解脱有八。一内有色想观外色解脱。二内无色想观外色解脱。三净解脱身作证具足住。四无色定为次四解脱。灭受想定为第八解脱。八中前三无贪为性近治贪故。然契经中说。想观者想观增故。如宿住念除去色想。三中初二不净相转。作青瘀等诸行相故。第三解脱清净相转。作净光鲜行相转故。三并助伴皆五蕴性。初二解脱一一通依初二静虑。能治欲界初静虑中显色贪故。初二通摄近分中间。五地皆能起初二故。欲及初定有显色贪。由眼识身所引起故为解脱彼。初二定中建立初二不净解脱。二三定中眼识无故。亦无所引缘显色贪故。三四定中无不净解脱。初二解脱相似善根。虽欲界中亦容得有。而为欲界贪所陵杂。故不建立二解脱名。三四定中虽亦得有。去所治远势力微劣。又乐净伏故不得名第三解脱。依后静虑离八灾患心澄净故。第四并近分立后静虑名。相似善根下地虽有。非增上故不名解脱。欲界欲贪所陵杂故。初二定中不净伏故。第三定中乐所迷故。又并八灾所扰乱故。次四解脱如其次第。以四无色定善为性。非无记染非解脱故。亦非散善性羸劣故。彼散善者如命终心。有说余时亦有散善。唯生得善无闻思故。诸近分地九无间道。八解脱道亦非解脱。不背下地故缘下道杂故。又未全脱下地染故。契经说彼超过下故。有说近分诸解脱道。亦名解脱背下地故。然于余处唯说根本者。以近分中非全解脱故。第八解脱即灭尽定。厌背受想而起此故。或总厌背有所缘故。然上座言。即诸有情相续分位名灭尽定。此亦非理前已广辩。此灭尽定实有体故。又不可说此定有心。曾不见有心无受想思故。无容于此越路而行。如说此中受想等灭寂静安乐。阿罗汉等乃有如是殊胜解脱。非无义本相续及心。可说名为安乐寂静。阿罗汉等殊胜解脱如何计度。有一类心无有所缘离行相转。有所缘者理必有触。若许有触宁无受果。应言何碍受等不生。故灭定中无有心。理非迷正理才览经文。便能会通圣教深趣。识非永灭言不离身。如病未永除暂息亦名有。微微心后此定现前。前对想心已名微细。此更微细故曰微微。次如是心入灭尽定。谓有顶地心有三品。即想微细及微微心。由上中下品类别故。要下品后灭定现前。故次微微入灭尽定。从灭定出或起有顶净定心。或即能起无所有处无漏心。如是入心唯是有漏。通从有漏无漏心出。八中前三唯以欲界色处为境。有差别者二取不净。一取净相。既诸色中亦有净界。总观为不净宁非颠倒摄。如于苦法计乐成倒。谓诸行中亦有苦杂。一向计乐成颠倒故。第三取净为难亦尔。此非过失是所许故。谓亦许此是倒思惟。若尔如何性非不善。此是离染所得果故。既不称实何能违染。令顺生贪作意远故。如未离欲于净不净。思惟净相能顺生贪。非此净中见于净相。不颠倒故可善性摄。如是离欲于净不净。思惟不净能远离贪。非此净中见不净相。是颠倒故不善性摄。亦应例释不净见净。或此非谓颠倒思惟。诸不净法总有二种。一者自体。二者相杂。诸清净法杂不净故亦名不净。世所极成故此思惟不名颠倒。不净杂净例亦应尔。然观行者初修观时。非亦于净界取不净相。但于不净界取不净相。令心极厌恶违逆行相转。后渐增广违逆行相。普于欲界色处境中。总起厌心不生贪染。若于纯净界色界色聚中。胜解无能取不净相。既唯欲界诸色聚中。胜解方能取不净相。故知欲界诸色聚中。决定亦有不净界性。既如不净作不净解。如何可言是颠倒性。第三取净例此应知。此于所缘既如实转。如何说是胜解作意。由胜解力此于境生。故说此为胜解作意。即由此故得解脱名。胜解解脱义相邻故。或于少事由胜。解力渐渐增益观名胜解作意。谓于少净渐增益观。因此便生无量贪染。此既生已心于所缘。遂被拘执不自在转。于少不净渐增益观。与前相违增诸善本。如观乐受为坏苦性。杂苦相故观之为苦。能伏烦恼不名颠倒。如是净界与不净杂。亦可于中观为不净不名颠倒。能远离贪缘净解脱。应知亦尔。观未成满但得名为胜解作意。后成满时离染果故引圣道故。亦得名为真实作意。如是已辩初三所缘。次四解脱。各以自上苦集灭谛。及一切地类智品道彼非择灭。及与虚空为所缘境。无色解脱弃背下地。故并不缘下地苦集行相。别者初二不净。第三唯净俱非十六。无色解脱摄本定故。所作行相十六。或非念住俱者。初三解脱身念住俱。次四解脱通四念住。智相应者。初三第七唯世俗智。第四五六八智。相应根相应者。初二解脱喜舍相应。次五解脱唯舍相应。世差别者。皆通三世。缘世别者。初三解脱已生可生。各缘自世不生缘三。次四解脱缘三非世。三性别者。皆唯善性。缘性别者。初三解脱通缘三性。次四解脱缘善无记。学等别者。初三后二唯是俱非。中三解脱皆通三种。缘学等者。初三解脱但缘俱非。四缘三种。见断等者。初三后二唯修所断。中三有漏修断余非。缘见断等者。初三缘修断。次四解脱各通缘三。缘自身等者。初缘自他身。次二缘他。四缘三种。得差别者。第八第三唯未曾得。余六通二。通二谓圣内法异生外法。异生唯是曾得。经言有色观诸色者。为显何义。非未除色能如实通此经深义。然诸先圣传授释言。未能伏除缘内色想是有色义。云何知然。第二解脱差别说故。谓于第二既作是言。内无色想观外诸色。故知初解脱未除内色想。由此论者建立最初。名内有色想观外色解脱。谓观行者如害怨。尸虽已离欲贪。而为令坚固以不净行相。复观外诸色。由于外色数观察故。于内色中亦生厌想。如乐净者颈系狗尸。极怀羞惭深生厌恶。如是观外不净相已。方内色身亦是不净观心净故见内身中。三十六物不净充满。观如箧中众色类物。名初解脱极成满位。此成满位解脱何法。谓心于色不乐。憎背诃毁厌恶遮止欲贪。即解脱欲贪是无贪性故。若谓说观故应是慧者。理必不然。近治欲贪故体若是慧应近治痴既近治贪故无贪性。修观行者从此后时。渐复遣除缘内色想。谓以胜解想自命终。舆载遗身置弃尸处。种种禽兽争共食啖。须臾身尽唯见禽兽。或于是处以火焚烧。乃至遗灰风所飘鼓。须臾身尽唯见空界。或想自身如酥盐等。为火水等之所融消。乃至身无唯见火等。名内无色想观外色解脱此胜解力除色想故。虽缘身起而不见身。既已遣除缘内色想。心相续转无别事业。胜轻安乐任运现前。于此位中数数修习。缘色处境厌背行相。是名第二解脱成满。亦如第一解脱欲贪。虽于先时修不净想。已得解脱缘色欲贪。而无始来我爱难遣。若观身有仍恐退生。故后复修内无色想。厌恶色观清净过前。行者尔时依初静虑。得此二观深生味着。为欲令此转增进故。入第二静虑复修二解脱。复修二法次第如前。何缘此中厌逆色想。可得说与喜受相应。地力使然如苦集智。或由观见所习善根。至成满时故应生喜。既于色想已得解脱。虽游厌观而不妨喜。次复进入第三静虑。妙乐迷故心便奢侈。由此不能修诸解脱。但起解脱相似善根。此静虑中地力法尔。事欣厌观俱不能成。从此进修第四静虑。舍增上故心渐澄净。诸不净想无复增上。故彼不名初二解脱。但可名曰相似善根。彼瑜伽师久观不净。厌恶转故令心沈戚。为欲策发令暂生欢。或为暂解久修劳倦。或为自审验不净观堪能。故彼复依第四静虑。于欲界色起净胜解。先取宝衣花等净相。由胜解力渐广思惟。遍于所缘作净行相。如契经说。彼于后时。应取少净相总思惟诸色。此虽策心而不掉举。虽观净相而不起贪。既知善根势力增上。次复于境略聚其心。于一所缘观净而住此位。名曰净解脱满。能究竟舍不净想故。此净解脱亦如第二内无色想观外诸色。然有差别谓所依地所治行相有差别故。内外道身共不共故。通曾未曾得。唯未曾得故少用功而得。多用功得故。又净解脱观顺贪相而贪不生。第二解脱观违贪相得贪不起。余五解脱应知。如前思不相应无色处释。何缘唯说内无色想。除内色想不说外耶。得初静虑时外想已除故。谓得初静虑外色想已除。第四静虑中更无劳除遣。诸功德法渐次得故。又外色想易可遣除。故除彼时未立解脱。或外色想空处方除。故于此中但说除内。此中所说内无色想。为但遮色想别目余想耶。若谓此言但遮色想。此言无用说观外色。无内色想义已成故。若谓此言别目余想。应说此想为何所缘。此非唯遮以别说故。为缘何法缘虚空界。若非不净行相转者。如何可名第二解脱。此无过失。彼加行故。谓此中言内无色想。是第二加行名。第二解脱多因缘故。得解脱名。谓已解脱此方生故。或此力能引解脱故。或是种种解脱性故。或与解脱胜解俱故。此诸解脱依男女身。圣者异生皆能修起。唯灭尽定但依圣身。于圣身中通学无学。经说灭定超诸有顶。如何可说亦依学身。此虽有顶自地所摄。然如上地法超余方得故。如超一切第四定贪。方入根本空无边处。至超一切无所有贪。入本非想非非想处。如是超越诸有顶贪。方可得入灭受想定。谓有顶贪若断未断。要应总伏方入此定。故虽自地而名超越。或诸有学已离有顶。见所断故名为超越。或有顶法总有二种。有心无心位差别故。超有心故名为超越。或随所应说超无过。唯第三八说身证者。举二边际类显所余。色解脱中净为边际。于诸无色灭定为边。或此各在一界边故。或唯此二种唯内道得故。唯未曾得故。多功用得故。尽大种造色心心所法故。有说第三初于身色以胜解力。取清净相后渐遣除解脱成满缘身解脱此为究竟。故偏于此立身证名。灭定无心唯依身住。故亦于彼立身证名就胜故。然理实皆尔依通有理。有契经言何名身证。谓八解脱。此八解脱何有情起。若于所缘恒求对治。是贪爱行乐修多道。如是有情能起解脱。行者何为修解脱等。为令烦恼转更远故。为于等至得自在故。既得自在便能引发。无诤等德及圣神通。由此便能转变诸境。起留舍等种种事业。已辩解脱次辩胜处。颂曰

  胜处有八种　　二如初解脱
  次二如第二　　后四如第三

论曰。胜处有八。内有色想观外色少。若好若恶于此诸色胜知胜见。有如是想是名为初。内有色想观外色多。广说乃至。是名第二内无色想观外色少。广说乃至。是名第三内无色想观外色多。广说乃至。是名第四内无色想观外色。青青显青现青光。譬如乌莫迦花。或如婆罗痆斯深染青衣于此诸色。胜知胜见有如是想。是名第五内无色想观外色。黄黄显黄现黄光。譬如羯尼迦花。或如婆罗痆斯。深染黄衣广说乃至。是名第六内无色想观外色。赤赤显赤现赤光。譬如槃豆时缚迦花。或如婆罗痆斯。深染赤衣广说乃至。是名第七内无色想观外色。白白显白现白光。譬如乌沙斯星。或如婆罗痆斯。极鲜白衣广说乃至。是名第八能制伏境。故名胜处。谓虽一切所缘色境。清净光华美妙具足。而善根力悉能映蔽。譬如仆隶虽服珍奇。而为其主之所映蔽。或于是处转变自在。不随起惑故名胜处。胜于处故立胜处名。或此善根即名为处处能胜。故立胜处名。少谓所缘或自在少与此相反说名为多。好恶色言显劣胜色。有说于好能不起贪。于恶不嗔故名为胜。若尔胜处体应具无贪嗔。故于此中有别意趣。谓不净行相总观好恶色。如观恶色好色亦然。总取不净心自在转。何劳复观恶色不净。由曾见净起诸烦恼。以颠倒觉曾见净故。今如实见为治昔贪。故于恶色亦观不净。初观此境名为胜知。后观成时名为胜见。能自了达我于此中。有胜知胜见名有如是想。此四胜处自性地等。如次同前初二解脱。谓初二胜处是初解脱果。次二胜处是第二果。彼为资粮能入此故。总观不净能制伏己。复于此境观净制伏。谓即乘前内无色想。别观青等四显色相。所言青者谓花等青。言青显者谓衣等青青现青光。显前二种所有青相。纯深无杂非如青边。所发青影及孔雀尾金刚等青。然青光言显青鲜洁。非如日等外发光明。或为显成青色显著。举花衣喻。显加行中取彼为门入胜处观。非于观内见似此色。乌莫迦花花中青胜俱生青内举此为门。婆罗痆斯善于染色。和合青内举此为门。非加行中但取此二。非皆有故不举珠宝。若处空闲先取花相。若居聚落先取衣青。青观既然黄等亦尔。然于夜分先取白星。昼则取衣余皆如上。于晴夜分乌沙斯星。诸白色中最为胜故。此四胜处自性地等。应知如前第三解脱。以净解脱为此四因。彼为资粮能入此故。前三解脱于诸色中。但能总取不净净相。今八胜处于诸色中。分别少多青等异相。故前解脱但于色中。弃背欲贪及不净想。今八胜处能于所缘。分折制伏令随心转。由此证知第三解脱。总取净相故立一名。八胜处中后四胜处。差别取故分为四种。若净解脱亦差别缘。取净性同立为一者。后四胜处应亦立一。差别因缘不可得故。已辩胜处次辩遍处。颂曰

  遍处有十种　　八如净解脱
  后二净无色　　缘自地四蕴

论曰。遍处有十。谓周遍观地水火风青黄赤白。及空与识二无边处。经于此处皆言一想。上下及傍无二无量。于一切处无间无隙。周遍思惟故名遍处。遍于处故立遍处名。或此善根即名为处。行相遍故立遍处名。此中地等显示所缘。所说遍言显示行相。行相虽等而所缘别是故遍处分为十种。经言一者显此等至。思惟一类境相现前。想言显是胜解作意。若异此者应言一知。上下傍言显意流转。言无二者显。无间隙。无量言显胜解无边。由胜等持磨莹力故。令观行者心自在生。能于所缘周遍观察。何故唯十得遍处名。此上更无遍行相故。唯第四定空识无边。可得说有无边行相。前八遍处如净解脱。自性皆是无贪善根。若并助伴皆五蕴性。后四胜处加行引生。故与彼同如净解脱。又如净解脱依第四静虑。及缘欲界色处为境。如何地等亦名色处。地地界等有差别故。显形名地等如先已说。故说地等遍处不言地界等。故前八种但缘色处。风与风界既无差别。如何可言亦缘色处。此难非理。以诸世间亦说黑风团风等故。由此前八缘色理成。后二遍处如次空识二。净无色为其自性。各缘自地四蕴为境。此解脱等三门功德。为由何得。依何身起。颂曰

  灭定如先辩　　余皆通二得
  无色依三界　　余唯人趣起

论曰。第八解脱如先已辩。以即是前灭尽定故。余解脱等通由二得。谓由离染及加行得。以有曾习未曾习故。前八遍处初修习时。皆以眼识为其加行。空处遍处初修亦尔。以初必缘空界色故。由胜解力后成满时。通缘自地四蕴为境。识处遍处初修习时。但以意识为其加行。以初必缘识为境故。由胜解力后成满时。亦缘自地四蕴为境。四无色解脱二无色遍处。一一通依三界身起。然其初起多依下地。依自下地皆容后起。唯无所有亦依上地。所余一切依欲界身。唯在人中三洲除北。余慧力劣无圣教故。治欲贪故上二界无。有说初起唯依人趣。要由教力所引起故。人中有教天趣中无。设有着乐不能初起。故人初起退生欲天。由宿习力有后起义。复以何缘第三静虑。有通无量等无解脱等耶。无解脱缘前已具辩。解脱无故胜处亦无。解脱为门入胜处故。胜处无故遍处亦无。胜处为门入遍处故。又第三定耽着妙乐。于生死中此乐胜故。不能发起解脱等三。此三皆欲背生死故。通无量等随顺于乐。故依此定亦能修起。此解脱等三门功德。若随得一得一切不。此不皆尔。其义云何。得后必前前非必后。谓得遍处必具得三。得胜处者必得解脱。遍处不定或得或无。若得解脱余二不定。以入遍处胜处为门。解脱为门入胜处故。此解脱等差别云何。唯能弃背名为解脱。兼析所缘名为胜处。加无边解得遍处名。此三善根渐次修故。有余师说。此三善根由下中上故有差别。谓能弃舍胜伏所缘。行相无边有劣胜故。有余师说。解脱唯因遍处唯果胜处通二。今应思择上二界中。说者既无何缘起定。颂曰

  二界由因业　　能起无色定
  色界起静虑　　亦由法尔力

论曰。生上二界总由三缘。能进引生色无色定。一由因力。谓于先时近。及数修为起因故。二由业力。谓先曾造感上地生顺后受业。彼业异熟将起现前。势力能令进起彼定。以若未离下地烦恼。必定无容生上地故。三法尔力。谓器世界将欲坏时。下地有情法尔能起上地静虑。以于此位所有善法。由法尔力皆增盛故。诸有生在上二界中起无色定。由因业力非法尔力。无云等天不为三灾之所坏故。生在色界起静虑时。由上二缘及法尔力。若生欲界起上定时。一一应知加由教力。由教力者。谓人三洲。天亦闻教微故不说。前来分别诸胜法门。皆为弘持世尊正法。何谓正法当住几时。颂曰

  佛正法有二　　谓教证为体
  有持说行者　　此便住世间

论曰。世尊正法体有二种。一教二证。教谓契经调伏对法。证谓三乘诸无漏道。若证正法住在世间。此所弘持教法亦住理必应尔。现见东方证法衰微教多隐没。北方证法犹增盛故。世尊正教流布尚多。由此如来无上智境众圣栖宅。阿毗达磨无倒实义此国盛行。非东方等所能传习。二中教法多分依止。持者说者得住世间。证正法住唯依行者。然非行者唯证法依。教法亦应依行者。故谓有无倒修行法者。能令证法久住世间。证法住时教法亦住。故教法住由持说行。但由行者令证法住。故佛正法随此三人。住尔所时便住于世。阿毗达磨此论所依。此摄彼中真实要义。彼论中义释有多途。今此论中依何理释。颂曰

  迦湿弥罗议理成　　我多依彼释对法
  少有贬量为我失　　判法正理在牟尼

论曰。迦湿弥罗国毗婆沙师议。阿毗达磨理善成立。我多依彼释对法宗。经主此中述己本意。言依此国诸善逝子。议对法理大毗婆沙。发起正勤如理观察。为令正法久住世间。饶益有情故造斯论。多言显示少有异途。谓形像色去来世等。然诸法性广大甚深。如实说者甚为难遇。自惟觉慧极为微劣。不能勤求如实说者。故于广论所立理中。少有贬量为我过失。诸法正理广大甚深。要昔曾于无量佛所。亲近修习真智资粮。方于智境一切无惑。麟喻独觉尚于法相不能决判。况诸声闻彼所证法随他教故。由此决判诸法正理。唯在真实大牟尼尊。是故定知阿毗达磨。真是佛说应随信受。无倒修行勤求解脱

说一切有部顺正理论卷第八十


阿毗昙八犍度论

    No. 1543 [No. 1544]

    阿毗昙八犍度论序

        释道安撰

阿毗昙者。秦言大法也。众祐有以见道果之至赜。拟性形容。执乎真像。谓之大也。有以道慧之至齐。观如司南察乎一相。谓之法。故曰大法也。中阿含世尊责优陀耶曰。汝诘阿毗昙乎。夫然。佛以身子五法为大阿毗昙也(戒定慧名无漏也)。佛般涅槃后迦旃延(义第一)。以十部经浩博难究。撰其大法为一部八犍度四十四品也。其为经也。富莫上焉。邃莫加焉。要道无行而不由。可不谓之富乎。至德无妙而不出。可不谓之邃乎。富邃洽备故。故能微显阐幽也。其说智也周。其说根也密。其说禅也悉。其说道也具。周则二八用各适时。密则二十迭为宾主。悉则味净遍游其门。具则利钝各别其所以。故为高座者所咨嗟。三藏者所鼓舞也。其身毒来诸沙门。莫不祖述此经。宪章鞞婆沙。咏歌有余味者也。然乃在大荒之外。葱岭之表。虽欲从之。未由见也。以建元十九年罽宾沙门僧伽禘婆诵此经甚利。来诣长安。比丘释法和请令出之。佛念译传。慧力僧茂笔受。和理其指归。自四月二十日出至十月二十三日乃讫。其日捡校译人颇杂义辞。龙蛇同渊。金鋀共肆者。救救如也。和抚然恨之。余亦深谓不可。遂令更出。夙夜匪懈。四十六日而得尽定损可损者四卷焉。至于事须悬解起尽之处皆为细其下。梵本十五千七十二首卢(四十八万二千五百四言)。秦语十九万五千二百五十言。其人忘因缘一品云。言数可与十门等也。周览斯经有硕人所尚者三焉。以高座者尚其博。以尽漏者尚其要。以研机者尚其密。密者龙象翘鼻鸣不造耳。非人中之至恬。其孰能与于此也。要者八忍九断。巨细毕载。非人中之至练。其孰能致于此也。博者众微众妙。六八曲备。非人中之至懿。其孰能综于此也。其将来诸学者游槃于其中。何求而不得乎

阿毗昙八犍度论卷第一

        迦旃延子造

        符秦罽宾三藏僧伽提婆共竺佛念译

八犍度颂曰

  杂结使智行　　四大根定见

    阿毗昙杂犍度第一

  世间第一法　　智人爱恭敬
  无惭色无义　　最后说思品

    世间第一法跋渠第一

云何世间第一法。何故言世间第一法。世间第一法何等系。当言欲界系耶。色界系耶。无色界系耶。世间第一法。当言有觉有观耶。无觉有观耶。无觉无观耶。世间第一法。当言乐根相应耶。喜根护根相应耶。世间第一法。当言一心耶。当言众多心耶。世间第一法。当言退耶不退耶。云何顶。云何顶堕。云何暖。此二十身见几我见我所见有几见。若无常有常见。于此五见是何等见何等谛断。此见若有常无常见。若苦乐见。若乐苦见。若不净净见。若净不净见。若无我有我见。若无因有因见。若有因无因见。若有无见。若无有见。于此五见是何等见何等谛断。此见此章义愿具演说。云何世间第一法。答曰。诸心心法次第越次取证。此谓世间第一法。次有说者。于诸五根次第越次取证。此谓世间第一法。如我义。诸心心法次第越次取证。是谓世间第一法。以何等故言世间第一法。答曰。如此心心法。诸余世间心心法为上为最。无能及者。故名世间第一法。复次此心心法。舍凡夫事得圣法。舍邪事得正法。于正法中越次取证。以是故言世间第一法。世间第一法何等系。当言欲界色界无色界系耶。答曰。世间第一法当言色界系。非欲界非无色界。以何等故世间第一法。不当言欲界系。答曰。不以欲界道得断盖缠。亦不能除欲界结。乃以色界道得断盖缠。亦能除欲界结。若以欲界道得断盖缠。亦能除欲界结。如是世间第一法当言欲界系。但不以欲界道得断盖缠。亦不能除欲界结。乃以色界道得断盖缠。亦能除欲界结。以是故世间第一法不当言欲界系。以何等故世间第一法。不当言无色界系。答曰。于等法中越次取证。先从欲界于苦思苦。后色无色界同也。若圣道起先办欲界事。后色无色界同也。设于等法中越次取证。先无色界于苦思苦。后欲色界同也。若圣道起先办无色界事。后欲色界同也。如是世间第一法当言无色界系。但等法中越次取证。先从欲界于苦思苦。后色无色界同也。若圣道起先办欲界事。后色无色界同也。以是故世间第一法。不当言无色界系。复次入无色定除去色想。不以无色想分别欲界。如缘苦法忍亦缘世间第一法。世间第一法当言有觉有观耶。无觉有观耶。无觉无观耶。答曰。世间第一法。或有觉有观。或无觉有观。或无觉无观。云何有觉有观。答曰。依有觉有观三昧。得世间第一法。是谓有觉有观。云何无觉有观。答曰。依无觉有观三昧。得世间第一法。是谓无觉有观。云何无觉无观。答曰。依无觉无观三昧。得世间第一法。是谓无觉无观。世间第一法当言乐根相应耶。喜根护根相应耶。答曰。世间第一法。或乐根相应。或喜根相应。或护根相应。云何乐根相应。答曰。依第三禅得世间第一法。是谓乐根相应。云何喜根相应。答曰。依第一第二禅。得世间第一法。是谓喜根相应。云何护根相应。答曰。依未来禅依禅中间依第四禅。得世间第一法。是谓护根相应。世间第一法。当言一心为众多心耶。答曰。世间第一法。当言一心非众多心。以何等故世间第一法。一心非众多心。答曰。若世间第一法中间。不起余世间法唯有无漏。若当起者若小若等若妙。设使小者不越次取证。以何等故。不以退道于等法中越次取证。若当等者亦不越次取证。以何等故本不以此道越次取证。若当妙者。彼本心心所念法。此非世间第一法。若后心心所念法。此是世间第一法也。世间第一法。当言退不退耶。答曰。世间第一法不退也。以何等故世间第一法不退乎。答曰。世间第一法。谛顺谛满谛办。无空缺处无所有。不起若干心不得思惟。譬如士夫渡水度山谷阪若险难处。正身不回身未到顷意正必到。世间第一法亦复如是。谛顺谛满谛办。无空缺处无所有。不起若干心不得思惟。譬如五大駃水。一为恒迦。二为担扶那。三为萨牢。四为伊罗跋提。五为摩醯。尽趣大海无能断流无能障者。尽趣大海海满海办世间第一法亦复如是。谛顺谛满谛办。无空缺处无所有。不起若干心不得思惟。复次世间第一法苦法忍中间。彼无有一法疾于心者。当于尔时无能制者不得思惟。以是故世间第一法当言不退。云何顶法。云何顶法退。答曰。譬如漏一刻顷欢喜向佛法僧。如世尊言。与十六婆罗门说诸摩那。如漏一刻顷欢喜向佛法僧。是谓顶法。云何顶法退。答曰。以得顶法若命终已退不复现在。如有一人与善知识相得。从其闻法思惟内挍计。信有佛道好法顺僧。色无常痛想行识无常。信思惟苦习尽道。彼或于余时不得善知识不闻法。不思惟内挍计。于世俗信退。是谓顶法退。云何暖法。答曰。于正法中起慈欢喜。如世尊说。马师比丘满宿比丘。此二痴人于我法中无有毫厘暖法此二十身。见几见是我见我所见有几见。答曰。五是我见十五是我所见。云何五我见。答曰。色我见痛想行识我见。是谓五我见。云何十五我所见。答曰。色我有见我中色色中我。痛想行识我有见。我中识识中我。是谓十五我所见也。若无常有常见。是边见苦谛所断。有常无常见。是耶邪见尽谛所断。苦有乐见以恶法为最此名见盗苦谛所断乐有苦见。是耶邪见尽谛所断。不净有净见。以恶法为最。此是见盗苦谛所断。净有不净见。是耶邪见。或尽谛断或道谛断。若尽观不净此耶邪见尽谛所断。若道观不净此耶邪见道谛所断。无我有我见。是身耶邪见苦谛所断。有因无因见。是耶邪见习谛所断。无因有因见无作因作此戒盗苦谛所断。若有而言无见。是耶邪见或苦谛断。或习谛断。或尽谛断。或道谛断。若言无苦是耶邪见苦谛所断。若言无习尽道此耶邪见习尽道断。若无而言有见。此非见此耶邪智

阿毗昙初世间第一法跋渠竟(梵本五百二十八首卢)

    阿毗昙杂犍度智跋渠第二

颇有一智知一切法乎。颇有一识识一切法乎。颇有二心展转相因乎。颇有二心展转相缘乎。以何等故一人前后二心不俱生乎。若人不可得亦无前心而就后心。以何等故忆本所作。以何等故忆识强记。以何等故忆而不忆。以何等故祭祀饿鬼则得。祭余处不得。当言一眼见色二眼见色耶。耳声鼻香亦复如是。诸过去者一切无现耶。若无现者一切过去乎。诸过去者一切尽耶。若尽者一切过去乎。诸过去者一切没耶。若没者一切过去乎。若苦生疑是苦非苦耶。当言一心为众多心乎。若习尽道生疑是道非道。当言一心为众多心乎。颇有一心有疑无疑乎。云何名身。云何句身云何味身。有佛世尊告诸弟子。汝等痴人。此义云何。以何等故佛世尊告诸弟子汝等痴人乎。有六因。相应因共有因自然因一切遍因报因所作因。云何相应因。云何共有因。云何自然因。云何一切遍因。云何报因。云何所作因。若心使俱诸使心俱。彼使此心所使耶。设使心所使此心俱使。彼使此心俱使耶。若心使俱诸使心俱。彼使此心当断耶。设使心当断此心俱使。彼使此心俱断耶。灭因识云何灭因识灭因识几使所使。此章义愿具演说

颇有一智知一切法乎。答曰。无也。若此智生一切诸法无我。此何所不知乎。答曰。不知自然。不知共有法。不知相应法也。颇有一识识诸法乎。答曰。无也。若此识生一切诸法无我。此何所不达乎。答曰。不识自然。不识共有法。不识相应法。颇有二心展转相因乎。答曰。无也。此非一人若前未来俱生二心。非未来心与前心因。颇有二心展转相缘乎。答曰有。若一思惟无当来生心。彼当念时便生二心。若思惟有当来生心。彼当念时便生二心。若念无当来道生心。彼当念时便生二心。若念有当来道生心。彼当念时便生二心。若二有知他人心展转心作缘。以何等故一人前后二心不俱生。答曰。无有第二次第缘。众生一一心转。如人不可得空也。前心不住。后心云何忆本所作。答曰。众生法中得如此智忆本所作。譬如刻印作字有所印处知字。则现亦知他所作已所作亦自知。彼亦不从来问。我亦不从往问汝作何字。彼亦不答我作是字。如印所作字自知作字。自所作亦知他所作亦知。如是众生法随所作则知所作法亦知。譬如有两两人知他人意各各相因。心彼一不从二。问汝云何相因彼亦不作是。答我作如是因缘亦知他人意法。得如是意各各相因。如是众生法得如是知随前法则知。复次一切心所念法定有因缘。及修意所作有力意常不忘失。以何等故忆而复忆。答曰。众生之法心自然回彼。次第智生。修意力强专意不忘。以何等故忆而不忆。答曰。众生之法意不自回彼。不次第智生。意渐渐微亦常多忘。以何等故祭祀饿鬼则到非余处也。答曰。此道自尔生入处法受身分尔是故得到。譬如鸟鸳鸯雁鹤孔雀鹦鹉千秋共命鸟。能飞虚空然鸟不神于人。不大于人。神力不能胜人。德不能大人。法自应尔生彼受身而飞行。譬如一泥犁一畜生道一饿鬼界。皆识宿命亦知他意。亦能雷电兴云风雨。作此种种。然不能胜人。神不能大人。力不能胜人。然其法自尔生入受身所作便果。复次有人长夜行淫。如是贪如是念如是欲如是思惟。彼便娶妇生儿。为儿娶妇为孙娶妇。亦作是言。我当有儿。儿当有儿。我死后若堕饿鬼。复当念我与我揣食。彼长夜作如是欲。作如是念。作如是贪。作如是思惟。所念便果。当言一眼见色耶。二眼见色耶。答曰。二眼见色。以何等故二眼见色。答曰。如合一眼而视色不净便起不净识。如开两眼而视色便起净识。如合一眼而视色起净识。如开两眼而视色起不净识。不得作是说两眼见色。但合一眼而视色起不净识。开两眼视色起净识。是故两眼见色。如合坏灭没亦如是。耳声鼻香亦复如是。诸过去者一切不现耶。答曰。或过去非不现。云何过去非不现。答曰。如优陀耶言。一切结过去于园离园去。于欲不染欲如炼真金。是谓过去非不现。云何不现非过去。答曰。如有一人乘神足不现。或以咒术或以药草。此谓不现非过去。云何过去亦不现。答曰。诸行起始起生始生成始成。得尽去无现变易过去。过去世摄过去世。是为过去亦不现。云何不过去亦不现。答曰。除上尔所事诸过去者一切尽乎。答曰。或过去非尽。云何过去非尽。答曰。如优陀耶言。一切结过去于园离园去。于欲不染欲如炼真金是谓过去不尽。云何尽不过去。答曰。如世尊言。是谓圣弟子尽地狱畜生饿鬼恶趣道。是谓已尽不过去也。云何过去亦尽乎。答曰。诸行起始起生始生成始成。得尽去无现变易过去。过去世摄过去世。是谓过去亦尽。云何非过去非尽。答曰。除上尔所事。复次我今当说结。结或过去非尽或尽非过去。或过去亦尽。或不过去亦不尽。云何过去不尽。答曰。诸过去结不尽。有余不灭不吐。是谓过去不尽。云何尽不过去乎。答曰。诸未来结已尽无余已灭已吐。是谓尽不过去。云何过去亦尽。答曰。过去结已尽无余已灭已吐。是谓过去已尽。云何不过去亦不尽。答曰。未来结不尽有余不灭不吐。及现在诸结。是谓不过去亦不尽。诸过去者尽没乎。答曰。或过去不没。云何过去不没。答曰。如优陀耶言。一切结过去于园离园去。于欲不染欲如炼真金。是谓过去不没。云何没非过去。答曰。我今当说狭小事如小舍。言舍没街巷器。小眼见色言眼没。是谓没非过去。云何过去亦没。答曰。诸行起始起生始生成始成。得尽去无现变易过去。过去世摄过去世。是为过去亦没。云何非过去亦非没。答曰。除上尔所事。复次我今当说结。结或过去非没。或没非过去。或过去亦没。或不过去亦不没。云何过去非没。答曰。诸过去结未尽有余不灭不吐。是谓过去非没。云何没不过去。答曰。诸未来结以尽无余已灭已吐。是谓没不过去。云何过去亦没。答曰。诸过去结已尽无余已灭已吐。是谓过去亦没。云何不过去亦不没。答曰。诸未来结不尽有余不灭不吐。及现在结。是谓不过去亦不没。若苦生疑是苦非苦。当言一意为众多意耶。答曰。是苦一意无苦二意若习尽道生疑是道非道。当言一意为众多意耶。答曰。是道一意无道二意。颇有一意是疑不疑。答曰。无也。于苦有疑于苦无疑。非为苦疑非为苦无疑。于习尽道疑于道无疑非为道疑非为道无疑。云何名身。云何句身。云何味身。名身云何。答曰。名者分别语有增数相施设说转名。是为名身。云何句身。答曰。如是句身得义满记彼此业。世尊亦说

  诸恶莫作　　诸善奉行　　自净其意
  是诸佛教

诸恶莫作此一句。诸善奉行此二句。自净其意此三句。是诸佛教此四句。如是句义满记彼此业。是谓句身。云何味身。答曰。字身说味身。世尊亦说。颂是偈相。字是味相。名是依偈造者。偈体如是字说味身。是谓味身。如佛世尊告诸弟子称言痴人。此义云何。以何等故佛世尊称言痴人。答曰。佛世尊法中。不顺戒行犯众过事。无果实行故称痴人。复次佛世尊不顺教诫教使顺法故称痴人。是佛世尊常训诲语。如今和上阿阇梨教训弟子。称言痴人所作非法造不善事。佛世尊亦复如是告诸弟子称曰痴人。有六因。相应因共有因自然因一切遍因报因所作因。云何名相应因。答曰。痛痛相应法相应因中因。痛相应法痛相应因中因。想思更乐忆欲解脱念三昧。慧慧相应法相应因中因。慧相应法慧相应因中因。是谓相应因。云何共有因。答曰。心心所念法共有因中因。心所念法心共有因中因。复次心心所回身行口行共有因中因。复次心心所回心不相应行共有因中因。心所回心不相应行心共有因中因。复次共生四大展转共有因中因。是谓共有因(因中因展转相生义也)。云何自然因。答曰。本生善根后生善根。与善根相应法。自界自然因中因。过去善根未来现在善根。与善根相应法。自界自然因中因。过去现在善根未来善根。与善根相应法。自界自然因中因。无记根亦复如是(四痛一爱二五邪见三憍慢四无明也)。本生不善根后生不善根。与不善根相应法。自然因中因。过去不善根。未来现在不善根。与不善根相应法。自然因中因。过去现在不善根。未来不善根。与不善根相应法。自然因中因。是谓自然因。云何一切遍因。答曰。本生苦谛断一切遍使。后生习尽道思惟断使。与使相应法。自界一切遍因中因。过去苦谛断一切遍使。未来现在习尽道思惟断使。与使相应法。自界一切遍因中因。过去现在苦谛所断一切遍使。未来习尽道思惟断使。与使相应法。自界一切遍因中因。习谛所断亦复如是。是谓一切遍因。云何报因。答曰。诸心心所念法受报色。心心法心不相应行。彼心心法此报报因中因。复次诸身口行受报色。心心法心不相应行。是彼身口行此报报因中因。复次诸心不相应行受报色。心心法心不相应行。彼心不相应行此报报因中因。是谓报因。彼云何所作因。答曰。眼缘色生眼识。彼眼识眼所作因中因若色彼共有法彼相应。耳声耳识鼻香鼻识舌味舌识。身细滑身识。意法意识。彼共有法彼相应。色法无色法。可见法不可见法。有对法无对法。有漏法无漏法。有为法无为法。如是诸法所作因除其自然。耳鼻舌身意缘法生意识。彼意识意所作因中因。若彼法共有法彼相应。眼色眼识耳声耳识鼻香鼻识舌味舌识身细滑身识。彼共有法彼相应。色法无色法。可见法不可见法。有对法无对法。有漏法无漏法。有为法无为法。如是诸法所作因中因。除其自然。是谓所作因。若心使俱诸使心俱。彼使此心所使耶。答曰。或所使或不所使。云何所使。答曰。诸使未尽此所使。云何不所使。答曰。诸使尽此不所使。设使心所使此心俱使。彼使此心俱使耶。答曰。或是彼非余。或是彼是余。云何是彼非余。答曰。苦智生习智不生。若心习谛所断苦谛所断。缘是谓是彼非余。云何是彼是余。答曰。人染污心一切被缚系。是谓是彼是余。若心使俱诸使心俱。彼使此心当灭耶。答曰。或灭或不灭。云何灭。答曰。诸使于彼缘灭是谓灭。云何不灭。答曰。诸使于彼缘未尽是谓不灭。相应诸使此使何所灭。答曰。诸使缘灭也。如是汝语使缘灭耶。答曰。如是若作是语诸使尽谛道谛所断无漏缘此使何所灭。此灭彼灭此事不然。如向者语。诸使尽谛道谛所断有漏缘。此尽彼当言尽。设诸使心所断此断心俱使。彼使此心俱使耶。答曰。或是彼非余。或是彼是余。云何是彼非余。答曰。若心无染思惟所断。是谓是彼非余。云何是彼是余。答曰。若心有染是谓是彼是余。尽缘识云何。答曰。苦智生习智未生。若心习谛所断苦谛所断缘。是谓尽缘识。彼识几使所使。答曰。十九一心耶不也。欲爱未尽苦智生习智未生。若欲界心习谛所断苦谛所断缘。是谓尽缘识。此识几使所使。答曰。欲界习谛所断七。欲爱尽色爱未尽苦智生习智未生。若色界心习谛所断苦谛所断缘。是谓尽缘识。彼识有几使所使。答曰。色界习谛所断六。色爱尽无色爱未尽。若苦智生习智未生。若无色界心习谛所断苦谛所断。缘是谓尽缘识。彼识几使所使。答曰。无色界习谛所断六

智品第二竟(梵本二百三十首卢长二十字)

阿毗昙八犍度论卷第一阿毗昙八犍度论卷第二

        迦旃延子造

        符秦罽宾三藏僧伽提婆共竺佛念译

    阿毗昙杂犍度人跋渠第三

一人此生十二种缘。几种过去。几种未来。几种现在。又世尊言。无明缘行受缘有。彼云何无明缘行。云何受缘有。无明缘行受缘有。有何差别。颇行缘无明非缘明。缘明不缘无明。不缘明不缘无明耶。出息入息当言依身回。当言依心回耶。如色界众生依身回。心如是无色界众生依何所回。心无有中爱当言见谛断。当言思惟断。无有名是何等法。又世尊言。彼欲心得解脱嗔恚愚痴。心得解脱何等心解脱。有欲无欲有嗔恚无嗔恚。有愚痴无愚痴。过去未来现在未解脱心。当言解脱耶。已解脱心当言解脱耶。又世尊言。于是当习厌无淫习。无淫解脱习解脱泥洹彼云何厌云何无淫。云何解脱云何泥洹。又世尊言。有断界无淫界有尽界。彼云何断界。云何无淫界。云何尽界。若断界彼无淫界耶。设是无淫界彼断界耶。若断界彼尽界耶。设尽界彼断界耶。若无淫界彼尽界耶。设尽界彼无淫界耶。又世尊言。有断想有无淫想有尽想。彼云何断想。云何无淫想。云何尽想。此章义愿具演说

一人此生十二种缘。几种过去几种未来几种现在。答曰。二种过去无明行。二未来生死也。八现在识名色六入更乐痛爱受有。又世尊言。无明缘行受缘有。彼云何无明缘行。云何受缘有。答曰。无明缘行者。于是现行前世时所作行。彼行报今生得有。是谓无明缘行。受缘有者。于是现行于此生所作行。诸行受报当得未来有。是谓受缘有。无明缘行受缘有。有何差别。答曰。无明缘行。于是现行前世时所作行。彼行报今生得有。彼行缘说一结无明。受缘有。于是现行今生作行。彼行报当得未来有。彼行缘说一切结。无明缘行受缘有。是谓差别。颇行缘无明不缘明。答曰。无也。缘明不缘无明。答曰。此亦无也。不缘明不缘无明。答曰。此亦无也。何以故无。此众生从久远道言非道。彼于后时人间造行作粟散小王。或作边王转为大王。至遮迦越所欲自在。展转相因无所不统。得为人主人界神界药草树木展转生长。此是前心四缘彼后心一增上缘。复次我今当说因缘。颇行缘无明不缘明耶。答曰有。无明报染污行。颇行缘明不缘无明。答曰有。除初明诸余无漏行。颇有行不缘明不缘无明。答曰有。除无明报。诸余不隐没无记行。初明。善有漏行。出息入息当言依身回。当言依心回耶。答曰。出息入息如随巧便。亦随身回亦随心回。若出息入息但依身回不依心回者。此则入无思想定灭尽定。出息入息回也。若出息入息依心回不依身回者。此则无色界人出息入息也。若出息入息依身回依心回不如巧便。此则卵胎皮膜转厚如酥酪。在母腹中诸根未具诸根未熟。入第四禅出息入息回。但出息入息如其巧便依身回依心回。下至摩诃阿鼻泥梨。上至净居天。于其中间所有众生。诸根不缺一切支节完具。出息入息如其巧便。尽依身回依心回。如色界众生依身心回。如是无色众生依何等心回。答曰。命根处所。亦复有余心不相应行。无有中爱。当言见谛断。当言思惟断耶。答曰。无有中爱思惟断。不得言见谛断。或复有言无有中爱。或见谛断。或思惟断。云何见谛断。答曰。见谛所断法无有中诸淫。是谓见谛断。云何思惟断。答曰。思惟所断法无有中诸淫。是谓思惟断。如我义无有中爱思惟所断。如是无有中爱思惟所断耶。答曰如是。若作是说。须陀洹能起此爱使我断坏。乃至死答曰。无听我所说。设当无有中爱思惟所断。彼如是。当言须陀洹能起此爱断坏乃至死。答曰。虽有此言是义不然。不得作是语。须陀洹能起此爱无有中爱思惟所断。不应言无有中爱思惟所断。此事不然。颇有是言。须陀洹淫欲未尽。地狱畜生饿鬼耶。答曰。如是。颇有是言。须陀洹能起此爱。我当作伊罗槃那龙王摩那斯善住。若阎浮地狱王。答曰。无听我所说。若须陀洹爱未尽地狱畜生饿鬼。当作是语。须陀洹能起此爱。我作伊罗槃那龙王摩那斯善住。若阎浮地狱王。答曰。虽有此言是义不然。不得作是语。须陀洹能起此爱。我作伊罗槃那摩那斯善住。若阎浮地狱王。须陀洹欲意未尽地狱畜生饿鬼。不得作是语。须陀洹爱未尽地狱畜生饿鬼此爱思惟断。此事不然颇作是语。诸缠所缠杀父母此缠思惟所断。须陀洹未尽耶。答曰。如是。颇作是语。须陀洹能起此缠诸缠杀父母。答曰。不也。听我所说。诸缠所缠杀父母此缠思惟所断。须陀洹未尽彼如是语。须陀洹能起此缠诸缠杀父母。答曰。虽有此言是事不然。不应作是语。须陀洹能起此缠诸缠杀父母。诸缠所缠杀父母此缠思惟所断。须陀洹未尽不得作是语。诸缠所缠杀父母此缠思惟所断。须陀洹未尽此事不然。颇作是语。思惟所断法无有思惟断耶。答曰如是。颇作是语。须陀洹能起彼缘爱耶。答曰不也。听我所说。若思惟所断法无有思惟所断。彼如是语须陀洹能起彼缘爱。答曰虽有此言是事不然。不应作是语。须陀洹能起彼缘爱。思惟所断法无有思惟所断。不得作是语。思惟所断法无有思惟所断此事不然。无有名何等法。答曰。三界无常。又世尊言。彼欲心解脱恚心痴心。解脱云何心得解脱有淫怒痴无淫怒痴。答曰。无淫怒痴。复有如是言。与淫怒痴心相应彼心解脱。彼不应作是语。何以故。非彼心此淫怒痴相合相依相应。彼淫怒痴未断如是心不解脱。彼淫怒痴彼淫怒痴断。如是心解脱彼淫怒痴。世尊亦言。日月此五曀云烟雾尘阿须伦。非彼日月此曀相合相依相应。此曀未尽如是彼日月不明不热不广不净。如此曀尽彼日月明热广净。如是非彼心此淫怒痴相合相依相应。彼淫怒痴未断如是心不解脱。彼淫怒痴彼淫怒痴断心得解脱。彼淫怒痴何等心解脱。过去耶。未来耶。现在耶。答曰。未来心起即时解脱无余障。此云何。如无碍道现前即灭。尽智现在前必生。若彼无碍道灭而生尽智。如是未来心生即时解脱无余障。未解脱心当言解脱耶。已解脱心当言解脱耶。答曰。已解脱心当言解脱。若已解脱不得言当解脱。若当解脱不得言已解脱。已解脱心当解脱。此事不然。如向者语。世尊善说契经

  若断欲无余　　如入水莲花
  比丘灭此彼　　如蛇脱皮去

已灭灭耶不灭灭耶。答曰。已灭灭也。若已灭不得言当灭。若当灭不得言已灭。已灭当灭此事不然如向者语。世尊善说契经

  慢尽自定意　　善心一切脱
  一靖居无乱　　畏死度彼岸

已度度耶未度度耶。答曰。已度度也。若已度不得言当度。若当度不得言已度。已度当度此事不然如向者语。世尊善说契经

  麋鹿依林　　鸟归虚空　　法归分别
  真人归灭

又世尊言。习厌习无。淫习无淫解脱。习解脱泥洹。彼云何厌。云何无欲。云何解脱。云何泥洹。云何厌。答曰。行臭处不净意常避之暂不喜见是谓厌。云何无欲。答曰。彼厌相应无淫怒痴善根。是谓无欲。云何解脱。答曰。彼无淫怒痴善根相应。心已解脱当解脱今解脱。是谓解脱。彼云何泥洹。答曰。淫怒痴尽无余。是谓泥洹。又世尊言。有断界有无淫界有灭界。云何断界。答曰。除爱结诸余结尽是谓断界。云何无淫界。答曰。爱结灭。是谓无淫界。云何灭界。答曰。诸结法灭是谓灭界。所谓断界是无淫界耶。答曰如是。设是无淫界是断界耶。答曰如是。所谓断界是灭界耶。答曰如是。设是灭界是断界耶。答曰如是。所谓无淫界是灭界耶。答曰如是。设灭界是无淫界耶。答曰如是。又世尊言。有断想有无淫想有灭想。彼云何断想。答曰。除爱结诸余结灭诸想性。是谓断想。云何无淫想。答曰。爱结灭诸想性。是谓无淫想。云何灭想。答曰。诸结法灭诸想性。是谓灭想

人跋渠第三竟(梵本一百四十八首卢长十六字)

    阿毗昙杂犍度爱恭敬跋渠第四

云何爱恭敬。云何供养恭敬。云何身力身力摄。几入几识识。云何数缘灭。云何非数缘灭。云何无常无常非数缘灭。有何差别。云何有余泥洹界。云何无余泥洹界。泥洹者。当言学耶。无学耶。非学非无学耶又世尊言。彼成就无学戒身。无学定身。无学慧身。无学解脱身。无学解脱知见身。彼云何无学戒身定身慧身解脱身解脱知见身。又世尊言。一究竟非众究竟。究竟名是何法耶。又世尊言。有诸异学实当断诸受。于现法中不施设断一切诸受施设断欲受戒受见受非我受。此义云何。以何等故。外道异学于现法中不施设断我受。有二智知智尽智。彼云何知智。云何尽智。若归佛归法归比丘僧。彼何归趣。此章义愿具演说

云何爱恭敬。云何供养恭敬。云何身力。爱恭敬者彼云何爱云何恭敬。爱云何。答曰。若爱相爱作爱是谓爱。恭敬云何若恭敬善恭敬善下此云何。如一爱师意润。彼由恭敬法僧和上阿阇梨同和上阿阇梨。及诸尊重等梵行者。爱意润。彼由恭敬如是。若爱彼作恭敬。是谓爱恭敬。供养恭敬者。二供养法供养衣食。供养恭敬云何。若恭敬善恭敬善下。此云何。如一作供养师。彼由恭敬僧和上阿阇梨同和上阿阇梨及诸尊重等梵行者。作供养彼由恭敬。如是若供养彼作恭敬。是谓供养恭敬。云何身力。答曰。若身力身精进身强身方便身勇。是谓身力。身力摄一入细滑入。二识识身识意识。如二壮夫与共相扑。一人力胜一人力劣。其多力者。捉而知之我力大彼。彼不如我其力。劣者。捉复自知彼力大我。我不如彼。如彼多力少力。俱摄一入细滑入。二识识身识意识。譬如二人一人强。力一劣。彼处处捉若扑若堕若执此捉。亦知彼强力此劣。如彼多力少力俱摄一入细滑入。二识识身识意识云何。数缘尽云何。非数缘尽云何。无常数缘尽云何。答曰。其尽者。是解脱。是谓数缘尽。非数缘尽云何。答曰。其尽者。非解脱是谓非数缘尽。无常云何。答曰。诸行变易灭尽不住。是谓无常。无常非数缘尽有何差别。答曰。无常者。诸行变易灭尽不住。非数缘尽者。已脱苦患愁忧诸恼。不随欲意未得离欲。无常非数缘尽此是差别。云何有余泥洹界无余泥洹界。云何有余泥洹界。答曰。若无著寿住活四大未没。彼造色五根与心周旋。是谓有余泥洹界。于有余泥洹界有结使灭尽。得到彼岸而取果证。是谓有余泥洹界也。云何无余泥洹界。答曰。无著余久过去般泥洹四大灭尽。彼造色五根无心可回旋。是谓无余泥洹界。于无余泥洹界。诸结使尽是谓无余泥洹界。泥洹者。当言学耶无学耶。亦非学非无学耶。答曰。泥洹亦非学非无学也。或有作是言。泥洹或是学或是无学。或是非学非无学。云何学。答曰。学得诸结使灭尽得。到彼岸而取果证。是谓为学。云何无学。答曰。无学得诸结使灭尽。得到彼岸而取果证。是谓无学也。云何非学非无学。答曰。有漏得诸结使灭尽。得到彼岸而取果证。是谓非学非无学。如我义泥洹亦非学非无学。如是泥洹亦非学非无学耶。答曰。如是。颇作是说。诸先以世俗道断欲嗔恚永尽无余。此不修四圣谛。若得四谛始得四谛。得阿那含学耶。答曰如是。颇作是说。诸先以世俗道得诸结使灭尽。得到彼岸而取果证。得阿那含果。此是学耶。答曰。非也。若当先以世俗道得诸结使灭尽。得到彼岸而取果证得阿那含果。当是学者。先亦是学未得阿那含果。未得彼时如是学此事不然。颇作是言。向阿罗汉果证诸结尽学。得阿罗汉无学耶答曰如是。颇作是说。向阿罗汉果证诸结尽学得阿罗汉果彼是无学耶。答曰。不也。若当向阿罗汉果证结尽学。得阿罗汉是无学者。本是无学未得阿罗汉。不得彼时如是无学。此事不然。颇作是说。阿罗汉结尽无学。失阿罗汉学耶。答曰如是。颇作是说。阿罗汉诸结尽无学。失阿罗汉彼是学耶。答曰。不也。若当阿罗汉结尽无学。失阿罗汉当是学者本亦是学。未失阿罗汉不得彼时如是学。此事不然。何以故。泥洹非学非无学不有学不有无学。若当泥洹非学非无学有学学有无学。此二种法乱法不定法则有坏法。亦不可知住法。世尊亦不说泥洹非学非无学有学学有无学。但泥洹不有学不有无学。以是故常一切时一切住不腐败无变易法。泥洹非学非无学。又世尊言。彼无学成就戒身定身慧身解脱身无学解脱知见身。彼云何无学戒身定身慧身解脱身。云何无学解脱知见身。云何无学戒身。答曰。无学身护口护命清净(八等之一)。是谓无学戒身。云何无学定身。答曰。无学空无想无愿是谓无学定身。云何无学慧身。答曰。无学思惟相应缘择法择观种种观分别。此谓无学慧身。云何无学解脱身。答曰。无学思惟相应意解脱已解脱当解脱。此谓无学解脱身云何无学解脱知见身。答曰。尽智无生智。复次无学苦智习智无学慧身。无学尽智道智无学解脱知见身。复次无学苦智习智道智无学慧身。无学尽智无学解脱知见身。又世尊言。一究竟非众究竟。究竟名何等法。答曰。世尊说。或道究竟或泥洹究竟。云何为道。答曰。如所说

  如不知道　　一聪明慢　　未到究竟
  未道御死

此道云何泥洹。答曰如所说

  究竟到不畏　　无缚亦无悔
  已脱于有刺　　此身是后边
  是谓最毕竟　　息迹无有上
  尽一切之相　　练迹无有上

如彼数目犍连婆罗门。往至佛所问如此事。一切世尊瞿昙沙门弟子。如是教如是训毕究竟无余泥洹。世尊告曰。此目犍连不定或得或不得此泥洹。又世尊言。外道异学实断诸受。于现法中不施设断。诸受施设断欲受戒受见受非我受彼有如是说。佛世尊说。少法彼不得如是说。何以故。佛不妄说法。复有作是说。以现少灭彼不得如是说。何以故。若见天人于我受中少灭证。然佛世尊。广为说法无有极。乃至天人奉行。于彼有异学梵志受佛语名持入阴盖意止觉意具足不具足。于彼有异学梵志。受欲受名者彼如是说。我施设断欲受诸戒受见受名者。彼如是说我施设断戒受见。受如众多比丘中食后云集升讲堂。有异学众多梵志往至如是问。沙门瞿昙为弟子如是说法。于是断五盖覆。心慧力羸。专四意止修七觉意。我等亦当为弟子如是说法。于是断五盖覆。心慧力羸。专四意止修七觉意。此我等与彼沙门瞿昙有何等异。此婆罗门不识盖况当识意止觉意。然佛世尊广为说法无有极。乃至天人奉行。于彼有异学梵志。受佛语名持入阴盖意止觉意具足不具足。于彼有异学梵志。受欲受名者彼如是说。我施设断欲受诸戒受见受名者。彼如是说我施设断戒受见受。如彼檀提婆罗门身生痈疽如蛇。无常实苦实空实无我。复以二手摩抆身言。此瞿昙不病此泥洹。此檀提梵志不识不病。况当识见泥洹然佛世尊广为说法。乃至天人奉行。彼异学梵志闻佛语名持入阴盖意止觉意是具足不具足者。于彼有异学梵志受欲受名者。彼如是说。我施设断欲受诸戒受见受名者。彼如是说。我施设断我施设断戒受见受。此义云何。以何等故。外道异学不施设断我受。答曰。外道异学。长夜着己身着众生。着人。着寿命。彼多闻者。非如是时说我施设断我受。有二智知智尽智。彼云何知智云何尽智。云何知智。答曰。诸智见明觉修行。是谓知智。云何尽智。答曰。淫怒痴尽无余。一切结尽无余。是谓尽智。世尊或说知智。或说泥洹。云何知智。答曰。如所说。此贤年少者一切世能解若此爱生苦能已智聪明若用行则说不用则不说不作歌诵者。能已智聪明。此曰。知智。云何泥洹。答曰。如所说当说智知法已知人。云何智。答曰。淫怒痴尽无余。一切结尽无余。是曰智也。云何知法。答曰。五盛阴是。云何已知人。答曰。漏尽阿罗汉。是此泥洹诸归佛趣。彼何归趣。答曰。诸法实有数想施设说语回转。佛者彼觉行归趣无学法。归法趣者彼何归趣。答曰。爱尽无淫灭说泥洹。彼此归趣。诸归僧趣彼何归趣。答曰。诸法实有数想施设说语回转。僧者彼僧行归趣。学法无学法

爱恭敬品第四竟。(梵本三百七十三首卢长十字)

    阿毗昙杂犍度无惭愧跋渠第五

云何无惭云何无愧。无惭无愧有何差别。云何惭云何愧。惭愧有何差别。云何增不善根。云何微。云何欲界增善根。云何微。若心过去一切彼心变易耶。设心变易一切彼心过去耶。若心染污一切彼心变易耶。设心变易一切彼心染污耶。一切调尽与戏相应耶。一切戏尽与调相应耶。一切睡尽与眠相应耶。一切眠尽与睡相应耶。眠当言善耶不善耶。无记耶。眠时当言福回耶非福回耶。非福非不福回耶。梦名何等法。五盖摄诸盖。诸盖摄五盖。诸盖彼是覆耶设覆彼是盖耶。诸欲界系无明使。一切彼不善耶。设诸不善者。一切彼欲界系无明使耶。诸色无色界无明使者。一切彼无记耶。设诸无记者。一切彼色无色界无明使耶。诸苦谛习谛所断无明使一切。彼一切遍耶。设诸一切遍一切彼苦谛习谛所断无明使耶。诸尽谛道谛所断无明使一切。彼非一切遍耶设诸非一切遍一切。彼尽谛道谛所断无明使耶。云何不共无明使。云何不共调缠。此章义愿具演说

云何无惭云何无愧。云何无惭。答曰。可惭不惭可避不避。亦不避他不恭敬。不善恭敬。不善往来。是谓无惭云何无愧。答曰。若不愧不善愧不愧他。可羞不羞不羞他。不畏恶事。恶事不见畏。是谓无愧。无惭无愧有何差别。答曰。不善往来无惭。恶事不见畏无愧。无惭无愧是谓差别。云何惭云何愧。云何惭。答曰。可惭惭。可避避。可避他恭敬善恭敬善往来。是谓为惭。云何为愧。答曰。可愧愧。可羞羞。可羞他。恶事畏见恶事畏。是谓愧。惭愧有何差别。答曰。善往来惭。恶事见恶事怖愧。惭愧是谓差别。云何增不善根。云何微云何增答曰。诸不善根断善根者。断欲界淫此最初灭时。是谓为增。云何微。答曰。度欲无淫最后灭者。诸已灭欲得无淫。是谓微。云何欲界系增善根。云何微云何增。答曰。菩萨于正法越次取证。修行得等智。若如来得尽智。于淫怒痴尽得善根。是谓增云何微。答曰。断善根。时诸最后灭诸已灭得数断善根。是谓微。诸心过去一切彼心变易耶答曰。如是。诸心过去一切彼心变易。颇有心变易彼心不过去耶。答曰。有未来现在欲嗔恚相应心。世尊亦说。若贼来俱锯刃割截身体。彼当俱锯刃割截身体时心有变易。亦复说。若比丘变易心也。诸心染污一切彼心变易耶。答曰。如是。诸心染污一切彼心变易也。颇有心变易彼心不染污耶。答曰有。过去欲不相应心。未来现在嗔恚相应心。世尊亦说。若贼来俱锯刃割截身体。彼当俱锯刃割截身体时。心有变易。一切调与戏相应耶。答曰。或调不与戏相应。云何调不与戏相应。答曰。不戏不息不休调稍稍调心炽盛。是谓调不与戏相应。云何戏不与调相应。答曰。不染污心若所作恶悔戏。是谓戏不调相应。云何调与戏相应。答曰。染污心所作恶悔戏。是谓调戏相应。云何非调非戏相应。答曰。除上尔所事。一切睡眠相应耶。答曰。或睡不眠相应。云何睡不眠相应。答曰。未眠时身不软心不软。身重心重。身瞪瞢心瞪瞢。身愦心愦。身睡心睡睡所缠。是谓睡不眠相应。云何眠不睡相应。答曰。不染污心眠梦。是谓眠不睡相应。云何睡眠相应。答曰。染污心眠梦。是谓睡眠相应。云何不睡不眠。答曰。除上尔所事。眠当言善耶。不善耶。当言无记耶。答曰。眠或善或不善或无记。云何为善。答曰。善心眠梦是谓善。云何不善。答曰不善心眠梦是谓不善。云何无记。答曰。除上尔所事。眠时所作福当言回耶。所作不福当言回耶。所作福所作不福当言回耶。答曰。眠时或所作福当言回。或所作不福当言回。或所作福所作不福。不当言回。云何眠时所作福当言回。答曰。如梦中施与作福持戒守斋。如眠时余福心回。何以故。如善心眠。如是眠时所作福当言回。云何眠时所作不福当言回耶。答曰。如梦中杀生盗行邪淫。如言妄语饮酒。如眠时余不福心回。何以故。如不善心眠。如是眠时所作不福当言回也。云何眠时所作福所作不福不当言回耶。答曰。如眠时非福心非无福。心不回。何以故。如无记心眠。如是眠时所作福所作非福不当言回也。梦名何等法。答曰。眠时诸缘心心念法。回觉已便忆如说如是如是我见梦。五盖摄诸盖。诸盖摄五盖。答曰。诸盖摄五盖。非五盖摄诸盖。不摄何等。答曰。无明盖也。世尊亦说。无明覆爱结系。如是愚得此身。聪明亦如是。若盖彼覆耶。答曰。或盖彼不覆。云何盖彼不覆。答曰。过去未来五盖是谓盖彼非覆。云何覆彼非盖。答曰。除五盖诸结使现在前。是谓覆彼非盖也。云何盖彼覆。答曰。五盖展转现在前是谓盖。彼覆云何非盖彼非覆。答曰。除上尔所事。诸欲界系无明使一切彼不善乎。答曰。如是。诸不善一切彼欲界系无明使。颇有欲界系无明使非彼不善乎。答曰有。欲界身见边见相应无明使。诸色无色界无明使一切彼无记耶。答曰。如是。诸色无色界无明使一切彼无记也。颇有无记非彼色无色界无明使耶。答曰有。欲界身见边见相应无明使。诸苦谛习谛所断无明使。彼一切遍耶。答曰如是。诸一切遍一切彼苦谛习谛所断无明。使颇有苦谛习谛所断无明使。彼非一切遍耶。答曰有。苦谛习谛所断。非一切遍相应无明使。诸尽谛道谛所断无明使一切。彼不一切遍耶。答曰。如是。诸尽谛道谛所断无明使。非一切彼非一切遍耶。颇不一切遍非彼尽谛道谛所断无明使耶。答曰有。苦谛习谛所断不一切遍相应无明使。云何不共无明使。答曰。苦不忍习尽道不忍。云何不共调缠。答曰。无不共调缠

无惭愧跋渠第五竟(梵本二百二十首卢)

阿毗昙八犍度论卷第二阿毗昙八犍度论卷第三

        迦旃延子造

        符秦罽宾三藏僧伽提婆共竺佛念译

    阿毗昙杂犍度色跋渠第六

色法生老无常当言色耶。非色耶。无色可见不可见。有对无对。有漏无漏。有为无为。过去未来现在。善不善无记。欲界系色界系无色界系。学无学非学非无学。见谛所断思惟所断法。无断法。生老无常。当言见谛所断。当言思惟所断。当言无断耶。云何老。云何死。云何无常。诸死彼无常耶。设无常彼死邪。行力强无常力强。又世尊言。此三有为有为相。兴衰住若干。彼一心中云何兴。云何衰。云何住。若干此章义愿具演说

色法生老无常当言色耶。当言非色耶。答曰。当言非色。无色当言即无色。可见当言不可见。不可见当言即不可见。有对当言即无对。无对当言即无对。有漏当言即有漏。无漏当言即无漏。有为当言即有为。无为当言即无为。过去当言即过去。未来当言即未来。现在当言即现在。善当言即善。不善当言即不善。无记当言即无记。欲界系当言即欲界系。色界系当言即色界系。无色界系当言即无色界系。是学当言即是学。不学当言即不学。非学非无学当言即非学非无学。见谛所断当言即见谛所断。思惟所断当言即思惟所断。非断法生老无常当言见谛所断。当言即思惟所断。当言非断耶。答曰。当言即无断。云何老。云何死。云何无常。云何老。答曰。行衰退根熟坏身色变得老毁。是谓老。云何死。答曰。彼众生生彼彼生处。若命终当命终退不现。丧没寿失舍阴命根闭。是谓死。云何无常。答曰。诸行散退没是谓无常。诸谓死即无常耶。答曰如是。诸死彼无常。颇有无常。彼非死耶。答曰有。除死诸余行。无常行力强无常力强。答曰。行力强非无常。行者过去未来现在行。灭无常者现在行散。或作是说。无常力强非行。行亦无常如我意行力强。非无常行者。过去未来现在行灭。无常者现在行散也。又世尊言。此三有为相有为相兴衰住若干。彼一心云何兴。云何衰。云何住若干。答曰。兴者生。衰者无常。住若干老也

色品第六竟(梵本三十七首卢秦六百八十九言)

    阿毗昙杂犍度无义跋渠第七

又世尊言

  知无义俱　　诸空持戒　　彼不得义
  如出时没

以何等故与无义俱诸空持戒世尊说苦。又世尊言。彼正身坐系念在前。彼云何系念在前。又世尊言。目犍连鞮舍梵天。不说第六人行无想(三道向得)。云何第六人行无想。又世尊言。此闻法已时地神举声放声。如来转法轮于波罗奈鹿苑园中。若沙门婆罗门天魔梵天若世间未曾转。地神有此智知如来转法轮不。又世尊言。彼比丘漏尽阿罗汉。三十三天集坐善法讲堂。数数云集行彼某名尊者。彼某名尊者弟子。于某村某聚落出家信家非家。剃除须发着袈裟衣。作道人尽有漏成无漏。心解脱慧解脱。于现法自知行作证。生已尽梵行已成所作已办。名色已有知如真。三十三天有此智知比丘漏尽不。又世尊言。彼诸化法教化亦诸向法次法。此八万四千摩竭大臣三结已尽。得须陀洹不堕恶趣。法定正道至七有。往来七生天人尽苦际。彼云何化法教化。云何向法次法。云何多欲云何无厌。多欲无厌有何差别。云何少欲云何知足。少欲知足有何差别。云何难满云何难养。云何易满云何易养。此章义愿具演说又世尊言

  知无义俱　　诸空持戒　　彼不得义
  如出时没

以何等故与无义俱。诸空持戒世尊说苦。答曰。此是死道共死死相。不能如是苦离死。以是故与无义俱诸空持戒世尊说苦。又世尊言。彼正身坐系念在前。彼云何系念。答曰。彼近明善方便正念。骨想青想骨琐想。膖胀想。食不尽想。烧焦想。骨节异处想。又世尊言。目犍连鞮舍梵天不说第六人行无想。云何第六人行无想。答曰。坚信坚法于此义现第六无想人。彼无想不可数不可施设。若此住若彼住不可数。若苦法忍若苦法智。若苦未知忍若苦未知智。若习法忍若习法智。若习未知忍若习未知智。若尽法忍若尽法智。若尽未知忍若尽未知智。若道法忍若道法智。若道未知忍若道未知智。如是无想不可数不可施设。若此住若彼住。以是故坚信坚法。于此义现第六无想人。又世尊言。此闻法已时地神举声放声。世尊转法轮于波罗奈仙人鹿苑园中。若沙门婆罗门若天魔梵。若世间未曾转。地神有此智知世尊转法轮不耶。答曰不也。云何知。答曰。世尊起世俗心。我转法轮名某比丘见法。此彼知亦告他我转法轮。名某比丘见法此彼闻彼尊者亦起世俗心。世尊转法轮我已见法。此彼知亦告他佛转法轮。我已见法。此彼闻彼。或从大尊天闻。又世尊言。彼比丘漏尽阿罗汉。三十三天集坐善法讲堂。数数云集行彼某名尊者。彼某名尊者弟子。于某村某聚落出家信家非家。剃除须发着袈裟衣。作道人尽有漏成无漏。心解脱慧解脱。于现法自知行作证。生已尽梵行已成所作已办。名色已有知如真。是三十三天有此智知比丘漏尽不。答曰。不知。云何知。答曰。世尊起世俗心。名某比丘漏尽得阿罗汉。此彼知亦告他。名某比丘漏尽得阿罗汉。此彼闻彼尊者亦起世俗心。我漏尽得阿罗汉。此彼知亦告他。我漏尽得阿罗汉。此彼闻彼。或从大尊天闻。又世尊言。彼诸化法教化亦诸向法次法。此八万四千摩竭大臣三结已尽。得须陀洹不堕恶趣。法定正道至七有。往来七生人天尽苦际。彼云何化法教化云何向法次法。云何化法教化。答曰。诸摩竭大臣已生天见法。此谓化法教化。云何向法次法。答曰。诸摩竭大臣本为人时见法。此谓向法次法。云何多欲。云何无厌。多欲云何。答曰。未得色声香味细滑衣食床卧病瘦医药具。诸欲已欲当欲。此谓多欲。无厌云何。答曰。以得色声香味细滑衣食床卧病瘦医药具。不喜不善喜。亦不喜他不厌不善厌亦不厌他。此谓无厌。多欲无厌有何差别。答曰。未得色声香味细滑衣食床卧病瘦医药具。若索求索强索巧方便缘。已得色声香味细滑衣食床卧病瘦医药具。复方便复欲复愿复念。少不喜少不善喜得他少不喜。多欲无厌。此谓差别。云何少欲云何厌。少欲云何。答曰。未得色声香味细滑衣食床卧病瘦医药具。诸非欲非已欲非当欲。此谓少欲。厌云何。答曰。以得色声香味细滑衣食床卧病瘦医药具。诸喜善喜亦善喜他厌善厌善厌他。此谓厌。少欲厌有何差别。答曰。未得色声香味细滑衣食床卧病瘦医药具。若不索不求索不强索。不巧方便缘方便。已得色声香味细滑衣食床卧病瘦医药具。不复方便不复作欲不复作愿不复作念少喜少善喜得他喜。少欲厌。此谓差别。云何难满云何难养。难满云何。答曰。欲多食欲多啖此谓难满。云何难养。答曰。贪餮常悕望食此谓难养。云何易满云何易养易满云何。答曰。诸不大食不大啖不悕望食此谓易满。云何易养。答曰。不贪餮常不悕望食。此谓易养也

阿毗昙无义跋渠第七竟(梵本九十七首卢晋言一千五百八十言)

    阿毗昙杂犍度思跋渠首第八

云何为思云何为想。思想有何差别。云何为觉云何为观。觉观有何差别。云何为掉云何心乱。掉心乱何差别。云何无明云何不顺智。云何为慢云何为憍。慢憍有何差别。若生增上慢我见苦是苦此增上慢。何缘若生增上慢我见习是习见尽。是尽见道是道此增上慢。何缘若生增上慢我生已尽梵行已成所作已办。名色已有知如真。此增上慢。何缘云何不胜生慢上慢作慢。云何觉欲自害。云何害他。云何俱害。云何觉恚自害。云何害他。云何俱害。云何觉杀自害。云何害他。云何俱害。知为多智。为多智为多识。为多有漏行多无漏行。多有为多无为多。云何行事成云何除事成。云何凡夫性凡夫事。当言善耶。不善耶无记耶。当言欲界系耶。当言色无色界系耶。见谛所断耶。思惟所断耶。凡夫性名何等法。诸法邪见相应。彼邪志耶。设邪志彼邪见耶。所有诸法邪见相应。彼邪方便邪念邪定耶。设邪定彼邪见耶。诸法乃至邪念相应彼邪定耶。设邪定彼邪念耶。此章义愿具演说

云何为思。云何为想。云何为思。答曰。诸思等思增思心行意作是谓思。云何为想。答曰。诸想等想缘想称观此谓想。思想何差别。答曰。思者行想者慧。思想此为差别。云何为觉云何为观。云何为觉。答曰。诸心觉稍稍觉案。次分别稍稍分别是谓觉。云何观。答曰。诸择一一择顺择顺回案。次顺往界是谓观。觉观有何差别。粗心为觉细心为观。觉观是谓差别。云何为掉云何心乱。云何为掉。答曰。心不息不休掉心炽盛。是谓掉。云何心乱。答曰。心散心乱心妄心动不一心。是谓心乱。掉心乱有何差别。答曰。不息相调。不一心相心乱。是谓差别。云何无明。云何不顺智。无明云何。答曰。三界无知也。云何不顺智。答曰。无巧便慧也。如是无巧便慧不顺智耶。答曰。如是。颇作是语诸顺智言妄语。彼一切失意不顺智顺智言妄语耶。答曰。如是。颇作是语顺智无妄语耶。答曰。不也。听我所说诸顺智言妄语。彼一切失意不顺智。顺智言妄语。彼作是语顺智无妄语。答曰。虽作是语此事不然。不应作是语顺智无妄语但诸顺智言妄语。彼一切失意不顺智。顺智言妄语。不应作是语诸顺智言妄语。彼一切失意不顺智。顺智言妄语。此事不然。颇作是说一切无明。不顺智相应诸顺智言妄语。彼一切无明往无明愚无明所缠失意不顺智顺智言妄语耶。答曰。如是。颇作是说顺智无妄语耶。答曰。不也。听我所说若一切无明不顺智相应。诸顺智言妄语。彼一切无明往无明愚无明所缠失意不顺智。颇智言妄语。彼如是说顺智无妄语耶。答曰。虽有是语此事不然。不应作是说顺智无妄语。但一切无明不顺智相应。诸顺智言妄语。彼一切无明往无明愚无明所缠失意不顺智。顺智言妄语。不应作是语。一切无明不顺智相应诸顺智言妄语。彼一切无明往无明愚无明所缠失意不顺智。顺智言妄语此事不然。云何慢。云何憍。慢云何。答曰。于卑谓妙(自谓胜也)。于妙相似从此起慢。作慢心炽盛是谓慢。憍云何。答曰。我生胜姓。色族伎术业富端正。从此起憍作憍一一憍一一作憍。是谓憍。慢憍何差别。答曰。于他胜心炽盛是谓慢相。自于法中心有染污。是谓憍相慢憍是谓差别。若生增上慢我见苦是苦。此增上慢何缘。答曰。如一(非辟)。与善知识相得从其听法内思惟得顺苦忍。彼苦是苦忍欲意喜。如是彼思惟忍相应思惟不妄时。于其中间见疑不行。设有行者亦复不觉(不得忍不觉有此行也)。便作是念。我见苦是苦。从此起慢是谓增上慢。此增上慢何缘。答曰。即彼苦缘智亦如是。若生增上慢我见尽是尽。此增上慢何缘。答曰。如一与善知识。相得从其闻法内思惟得顺尽忍。彼尽是尽忍欲意喜。如是彼思惟忍相应思惟不妄时。于其中间见疑不行。设有行者亦复不觉。便作是念。我见尽是尽从此起慢。是谓增上慢。此增上慢何缘。答曰。即彼尽缘道亦如是。若生增上慢我生已尽。此增上慢何缘。答曰。如一便作是念。此道此迹我依此道依此迹。已知苦已断习。已尽作证已思惟道我生已尽。从此起慢。是谓增上慢。此增上慢何缘。答曰。即彼生缘。若生增上慢。我梵行已成。此增上慢何缘。答曰。如一便作是念。此道此迹。我依此道依此迹。已知苦已断习。已尽作证已思惟道我梵行已成。从此起慢。是谓增上慢。此增上慢何缘。答曰即彼心心所念法缘。若生增上慢。我所作已办。此增上慢何缘。答曰。如一便作是念。此道此迹。我依此道依此迹。我已知苦已断习。已尽作证已思惟道我已断使。已害结已吐结我所作已办。从此起慢。是谓增上慢。此增上慢何缘。答曰。即彼心心所念法缘。若生增上慢。我名色已有知如真。此增上慢何缘。答曰。如一便作是念。此道此迹。我依此道依此迹。我已知苦不复当知。已断习不复当断。以尽作证不复当作证。以思惟道不复当思惟。我名色已有知如真。从此起慢。是谓增上慢。此增上慢何缘。答曰。即彼心心所念法缘。云何于卑起慢。答曰。此一见他胜我。若生若姓若色若族伎术行业。若富若戒。见已便作是念。此少胜我生姓色族伎术行业富戒。此彼非十倍二十倍非百倍不如是。谓于卑起慢。云何觉欲而自害。云何害彼。云何俱害。云何自害答曰。如淫欲所缠身。生热心热身烧心烧。亦复淫欲所缠长夜不忍不软不爱受报。如是自害。云何害他。答曰。如淫欲所缠悕望他妻。若见彼夫便起嗔恚。如是害他。云何俱害。答曰。如淫欲所缠窃盗他妻。若彼夫见捉其妻执。其人捶打缚杀如是俱害。云何觉恚。自害云何害他。云何俱害。云何自害。答曰。如嗔恚所缠身。生热心热身烧心烧。亦复嗔恚所缠长夜不忍不软。不爱受报。如是自害。云何害他。答曰。如嗔恚所缠打他若手若杖若石。若刀如是害他。云何俱害。答曰。如嗔恚所缠打他。若手若杖若石若刀。为彼所打若手若杖若石若刀。如是俱害。云何觉杀自害。云何害他。云何俱害。云何自害。答曰。如杀心所缠身。生热心热身烧心烧。亦复杀所缠长夜不忍不软不爱受报。如是自害。云何害他。答曰。如害所缠断他命。如是害他。云何俱害。答曰。如害所缠断他命他亦报此断命。如是俱害。知多耶智多耶。答曰。知多非智多彼智者知也。智多耶识多耶。答曰。识多非智多。一切智识所摄。识非智所摄。不摄何等。答曰。忍相应识。有漏行多无漏行多。答曰。有漏行多非无漏行。有漏行十入二入少有所入。无漏行二入少有所入。有为多无为多。答曰。有为多非无为。有为十一入一入少有所入。无为一入少有所入。云何行事成。云何除事成。云何凡夫性。行事成云何。答曰。无学身护口护命清净。是谓行事成。云何除事成。答曰。无学根护。是谓除事成。云何凡夫性。答曰。圣法若不得已不得当不得。复次诸圣暖圣忍圣见圣味圣慧。若不得已不得当不得。是谓凡夫性。凡夫性当言善耶。当言不善耶。当言无记耶。答曰。凡夫性当言无记。不当言善。不当言不善也。以何等故凡夫性不当言善。答曰。方便求善法已得善法。不求方便我作凡夫也。已断善根永灭善法。不得成就善法。设凡夫性是善者。彼断善根彼非凡夫。以是故凡夫性不得言善。以何等故凡夫性不当言不善。答曰。得欲爱尽。不善根永尽。不成就不善法。设凡夫性不善者。彼凡夫欲爱尽。彼非凡夫人耶以是故凡夫性不当言不善也。凡夫性当言欲界系。当言色无色界系。答曰。凡夫性或欲界系。或色无色界系。以何等故。凡夫性不定言欲界系。答曰。欲界没生色界。永灭欲界系法。得不成就欲界系法。若凡夫性定欲界系者。彼诸凡夫生无色界者。彼非凡夫耶。以是故凡夫性不当言定欲界系。以何等故凡夫性不当言定色界系。答曰。色界没生无色界。永灭色界系法。不得成就色界系法。若凡夫性定色界系。彼诸凡夫无色界生。彼非凡夫耶。以是故凡夫性不当言定色界系。以何等故凡夫性不当言定无色界系。答曰。等越次取证。先从欲界于苦思苦后色无色界同。圣道已生先办欲界事。后色无色界同。若等越次取证。先从无色界于苦思苦。后欲界色界同。圣道已生先办无色界事。后欲界色界同。如是凡夫性定无色界系。但等越次取证先从欲界于苦思苦。后色无色界同。圣道已生先办欲界事。后色无色界同。以是故凡夫性不当言定。无色界系。凡夫性当言见谛断。当言思惟断。答曰凡夫性当言思惟断。不当言见谛断以何等故凡夫性思惟断非见谛断。答曰。见谛所断法永染污。凡夫性不染污此云何。世间第一法在前速灭苦法忍现在前速生。如此世间第一法灭苦法忍生。于其中间三界凡夫性得不成就。非余见谛所断法永灭。凡夫性名何等法。答曰。三界无染污心不相应行。诸法邪见相应彼邪志耶。答曰。或邪见非邪志。云何邪见非邪志。答曰。邪见相应邪志。诸余邪志不相应邪见相应法。是谓邪见非邪志。云何邪志非邪见。答曰。邪志相应邪见诸余邪见不相应邪志相应法。是谓邪志非邪见。云何邪见邪志。答曰。除邪见相应邪志。诸余邪见邪志相应法。是谓邪见邪志。云何非邪见非邪志。答曰。邪见不相应邪志。邪志不相应邪见。诸余心心所念法。色无为心不相应行。是谓非邪见非邪志。诸法邪见相应彼邪方便也。答曰。或有邪见非邪方便。云何邪见非邪方便。答曰。邪见相应邪方便。是谓邪见非邪方便。云何邪方便非邪见。答曰。邪见诸余邪见不相应。邪方便相应法。是谓邪方便非邪见。云何邪见邪方便。答曰。除邪方便。诸余邪见相应法是谓邪见邪方便。云何非邪见非邪方便。答曰。邪见不相应。邪方便诸余心心所念法。色无为心不相应行。是谓非邪见非邪方便。邪念邪定亦如是。诸法邪志相应。彼邪方便耶。答曰。或邪志非邪方便。云何邪志非邪方便。答曰。邪志相应邪方便。是谓邪志非邪方便。云何邪方便非邪志。答曰。邪志诸余邪志不相应。邪方便相应法。是谓邪方便非邪志。云何邪志邪方便。答曰除邪方便。诸余邪志相应法。是谓邪志邪方便也。云何非邪志非邪方便。答曰。邪志不相应。邪方便诸余心心所念法。色无为心不相应行。是谓非邪志非邪方便。邪念邪定亦如是。诸法邪方便相应彼邪念耶答曰。或邪方便非邪念。云何邪方便非邪念。答曰。邪念是谓邪方便非邪念。云何邪念非邪方便。答曰。邪方便是谓邪念非邪方便。云何邪方便邪念。答曰。除邪念(去不与所念相应也)。诸余邪方便相应法。是谓邪方便。邪念云何非邪方便非邪念。答曰诸余心心所念法。色无为心不相应行。是谓非邪方便非邪念。邪定亦如是。诸法邪念相应彼邪定耶。答曰或邪念非邪定。云何邪念非邪定。答曰。邪定是谓邪念非邪定。云何邪定非邪念。答曰。邪念是谓邪定非邪念(同故言非)。云何邪念邪定。答曰。除邪定诸余邪念相应法。是谓邪念。邪定云何非邪念非邪定。答曰。诸余心心所念法。色无为心不相应行。是谓非邪念非邪定

思想品第八竟(梵本二百二十首卢长十八字)

杂犍度第一尽(自初讫此三千五百言)

阿毗昙八犍度论卷第三阿毗昙八犍度论卷第四

        迦旃延子造

        符秦罽宾三藏僧伽提婆共竺佛念译

    阿毗昙结使犍度不善跋渠初(自此尽十二品)

  不善有报　　见亦见苦　　若见有觉
  如相应根　　欲界获得　　断亦五人
  身见如是　　一切遍后

三结三不善根三有漏。四流四轭四受四缚。五盖五结五下分结五见。六身爱七使九结九十八使。此三结几不善几无记。此乃至九十八使几不善几无记。此三结几有报几无报。此乃至九十八使几有报几无报。此三结几见谛断几思惟断。此乃至九十八使几见谛断几思惟断。此三结几见苦谛断。几见习尽道谛断。几思惟断。此乃至九十八使几见苦谛断。几见习尽道谛断。几思惟断。此三结几见几不见。此乃至九十八使几见几不见此三结几有觉有观。几无觉有观。几无觉无观。此乃至九十八使几有觉有观。几无觉有观。几无觉无观。此三结几乐根相应。几苦根相应。几喜根相应几忧根相应。几护根相应。此乃至九十八使几乐根相应。几苦根相应。几喜根相应。几忧根相应。几护根相应此三结几欲界系。几色界系。几无色界系。此乃至九十八使几欲界系。几色界系。几无色界系。诸结是欲界者。此结在欲界耶。设在欲界结是欲界结耶。所有结是色无色界结。此结在色无色界耶设结在色无色界。是色无色界结耶。所有结非欲界结。此结不在欲界耶。设不在欲界。此结非欲界结耶。所有结不是色无色界。此不在色无色界结耶设结不在色无色界。此非色无色界结耶。见谛成就世尊弟子色未尽为色系耶。设为色系此色未尽耶。若痛想行识未尽为识所系耶。设为识所系识未尽耶。见谛成就世尊弟子。色已尽此色解耶。设色解者此色尽耶。若痛想行识尽此识解耶。设识解者此识尽耶。五人坚信。坚法。信解脱。见到。身证。坚信人。于此三结几成就几不成就。此乃至九十八使几成就几不成就。乃至身证人此三结几成就几不成就。此乃至九十八使几成就几不成就。身见彼身见几缘缘身见戒盗疑。乃至无色界思惟所断无明使几缘缘。无色界思惟所断无明使。彼无色界思惟所断无明使几缘缘。无色界思惟所断无明使。欲界身见戒盗疑。乃至无色界思惟所断慢使几缘缘。此章义愿具演说。三结乃至九十八使。彼三结几不善几无记。答曰。一无记二当分别。戒盗疑在欲界者则不善。在色无色界则无记。贪嗔恚愚痴定不善。有漏中一无记二当分别。欲漏或不善或无记。云何不善。答曰。无惭无愧彼相应欲漏是谓不善。云何无记。答曰。无惭无愧不相应欲漏。是谓无记。无明漏或不善或无记。云何不善。答曰。无惭无愧相应无明漏是谓不善。云何无记。答曰。无惭无愧不相应无明漏。是谓无记。流中一无记三当分别。欲流或不善或无记。云何不善。答曰。无惭无愧彼相应欲流。是谓不善。云何无记。答曰。无惭无愧不相应欲流。是谓无记。无明流或不善或无记。云何不善。答曰。无惭无愧相应无明流。是谓不善。云何无记。答曰。无惭无愧不相应无明流。是谓无记。见流或不善或无记。云何不善。答曰。欲界三见。是谓不善。云何无记。答曰。欲界二见。色无色界五见。是谓无记。轭亦如是。受中一无记三当分别。欲受或不善或无记。云何不善。答曰。无惭无愧彼相应欲受。是谓不善。云何无记。答曰。无惭无愧不相应欲受。是谓无记。戒受或不善或无记。云何不善。答曰。在欲界者。是谓不善。云何无记。答曰。在色无色界者。是谓无记。见受或不善或无记。云何不善。答曰。欲界二见。是谓不善。云何无记。答曰。欲界二见。色无色界四见。是谓无记。缚中二不善二当分别。戒盗身缚我见身缚在欲界。是不善。在色无色界。是无记。盖及嗔恚悭嫉结定不善爱结憍慢结在欲界。是不善。在色无色界。是无记。五下分结中二不善一无记二当分别。戒盗疑在欲界。是不善。在色无色界。是无记。见中二无记三当分别。邪见见盗戒盗在欲界。是不善。在色无色界。是无记。六身爱中二不善四当分别。眼更爱耳身更爱在欲界。是不善。在色界。是无记。意更爱在欲界。是不善。在色无色界。是无记。七使中二不善一无记四当分别。憍慢使疑使在欲界。是不善在色无色界。是无记无明使或不善或无记。云何不善。答曰。无惭无愧相应无明使。是谓不善。云何无记。答曰。无惭无愧不相应无明使。是谓无记。见使或不善或无记。云何不善。答曰。欲界三见。是谓不善。云何无记。答曰。欲界二见。色无色界五见。是谓无记。九结中三不善六当分别(分别不善及无记也)。爱结憍慢结失愿结疑结在欲界是不善。在色无色界。是无记。无明结或不善或无记。云何不善。答曰。无惭无愧相应无明结。是谓不善。云何无记。答曰。无惭无愧不相应无明结。是谓无记。见结或不善或无记。云何不善。答曰。欲界一见。是谓不善。云何无记。答曰。欲界二见。色无色界三见。是谓无记。九十八使三十三不善六十四无记一当分别。欲界苦谛所断无明使或不善或无记。云何不善。答曰。无惭无愧相应无明使。是谓不善。云何无记。答曰。无惭无愧不相应无明使是谓无记(一门不善竟)。此三结几有报几无报。答曰。诸不善则有报。诸无记是无报。此乃至九十八使。几有报几。无报答曰。诸不善是有报。诸无记是无报(二门报无报竟)。此三结几见谛断。几思惟断。答曰。身见见谛。初二种或见谛断或见谛思惟断。云何见谛断。答曰。若身见尼维先若那阿先若系。坚信坚法行苦忍断。是谓见谛断。余残若凡夫断思惟断(进学分别意根似也)。世尊弟子断见谛断戒盗疑见谛。初二种或见谛断。或见谛思惟断。云何见谛断。答曰。若戒盗疑尼维先若那阿先若系。坚信坚法行忍断。是谓见谛断余残若凡夫断思惟断。世尊弟子断见谛断。贪嗔恚愚痴。及欲漏思惟。初二种或思惟断或见谛思惟断。云何思惟断。答曰。若学见迹思惟断。是谓思惟断。余残若凡夫断思惟断。世尊弟子断见谛断。有漏无明漏见谛。初三种或见谛断或思惟断。或见谛思惟断。云何见谛断。答曰。若有漏无明漏尼维先若那阿先若系。坚信坚法行忍断。是谓见谛断。云何思惟断。答曰。若学见迹思惟断。是谓思惟断。余残若凡夫断思惟断。世尊弟子断见谛断。流中欲流思惟。初二种有流无明流见谛初三种见流见谛。初二种轭亦如是。受中欲受思惟。初二种戒受见受见谛初二种我受见谛初三种缚中欲爱身缚嗔恚身缚思惟。初二种戒盗身缚我见身缚见谛。初二种盖中贪欲嗔恚睡眠掉思惟。初二种悔定思惟断。疑盖若凡夫断思惟断世尊弟子断见谛断。结中嗔恚结思惟。初二种爱结憍慢结见谛。初三种嫉结悭结定思惟断。五下分结中贪欲嗔恚思惟。初二种身见戒盗疑及五见见谛。初二种六身爱中五身爱定思惟断。意更爱见谛。初三种七使中贪欲使嗔恚使思惟。初二种有爱使憍慢使无明使见谛。初三种见使疑使见谛。初二种九结中嗔恚结思惟。初二种爱结憍慢结无明结见谛。初三种见结失愿结疑结见谛。初二种嫉结悭结定思惟断。九十八使中二十八使见谛断十思惟断。余残若凡夫断思惟断。世尊弟子断见谛断(三门见谛竟也)。此三结几见苦谛断。几见习尽道谛断。几思惟断。答曰身见见苦断。戒盗有二行。或见苦断或见道断。疑有四行。或见苦断。或见习尽道断。贪嗔恚愚痴欲漏有漏无明漏。欲流有流无明流五行。见流四行。轭亦如是。受中欲受我受五行。戒受二行。见受四行。缚中欲爱身缚嗔恚身缚五行。戒盗身缚二行。我见身缚四行。盖中贪欲盖嗔恚睡眠掉盖五行。悔盖定思惟断。疑盖四行。结中爱结嗔恚结憍慢结五行。嫉结悭结定思惟断。五下分中贪欲嗔恚五行。身见见苦断。戒盗二行。疑四行。见中身见边见见苦断。邪见见盗四行。戒盗二行。身爱中五身爱思惟断。意更爱五行。使中贪欲使嗔恚使有爱使憍慢使无明使五行。见使疑使四行。结中爱结嗔恚结憍慢结无明结五行。见结失愿结疑结有四行。嫉结悭结定思惟断。九十八使中二十八见苦断。十九见习断。十九见尽断。二十二见道断。十思惟断(四门苦谛竟)。此三结几见几不见。答曰。二见一不见。贪嗔恚愚痴不见。漏中一不见二当分别。欲漏或见或不见。云何见。答曰。欲界五见。是谓见。云何不见。答曰。除欲界五见。诸余欲漏。是谓不见。有漏或见或不见。云何见。答曰。色无色界五见。是谓见。云何不见。答曰。除色无色界五见。诸余有漏。是谓不见。流中一见三不见。轭亦如是。受中二见二不见。缚中二见二不见。盖结不见。下分中二见三不见。见则见也。身爱不见。使中一见六不见。结中二见七不见。九十八使中三十六见。六十二不见(五门见门竟)。此三结几有觉有观。几无觉有观。几无觉无观。答曰。尽三行或有觉有观。或无觉有观。或无觉无观。贪嗔恚愚痴。及欲漏有觉有观。余残三行。或有觉有观。或无觉有观。或无觉无观。流中欲流有觉有观。余残三行或有觉有观。或无觉有观。或无觉无观。轭亦如是。受中欲受有觉有观。余残三行。或有觉有观。或无觉有观。或无觉无观。缚中欲爱身缚嗔恚身缚。有觉有观。余残三行。或有觉有观。或无觉有观。或无觉无观。盖及嗔恚结嫉结悭结有觉有观。余残三行。或有觉有观。或无觉有观。或无觉无观。下分中贪欲嗔恚有觉有观。余残及见三行。或有觉有观。或无觉有观。或无觉无观。身爱中五身爱有觉有观。意更爱三行。或有觉有观。或无觉有观。或无觉无观。使中贪欲使嗔恚使有觉有观。余残三行。或有觉有观。或无觉有观。或无觉无观。结中嗔恚结嫉结悭结有觉有观。余残三行。或有觉有观。或无觉有观。或无觉无观。九十八使中。欲界有觉有观。色界三行或有觉有观。或无觉有观。或无觉无观。无色界无觉无观(六门觉观竟)。此三结几乐根相应。几苦根相应。几喜根相应。几忧根相应。几护根相应。答曰。身见戒盗三。除苦根忧根。疑四除苦根。贪三除苦根忧根。嗔恚三。除乐根喜根。愚痴及欲漏无明漏五。有漏三。除苦根忧根。流中欲流无明流五有流三。除苦根忧根。见流四。除苦根。轭亦如是。受中欲受五。戒受我受三除苦根忧根。见受四。除苦根。缚中嗔恚身缚三。除乐根喜根。余残缚三。除苦根忧根。盖中贪欲盖三。除苦根忧根。嗔恚盖三。除乐根喜根。睡掉五眠三。除乐根苦根悔疑二根相应。忧根及护根。结中嗔恚结三。除乐根喜根。爱结憍慢结三。除苦根忧根。嫉结悭结二根相应。忧根及护根也。下分中贪欲三。除苦根忧根。嗔恚三。除乐根喜根。身见戒盗三。除苦根忧根。疑四。除苦根。见中邪见四。除苦根。余残见三。除苦根忧根。身爱中五身爱二根相应。乐根护根意更爱三。除苦根忧根。使中贪欲使有爱使憍慢使三。除苦根忧根嗔恚使三。除乐根喜根。无明使五。见使疑使四。除苦根。结中嗔恚结三。除乐根喜根。爱结憍慢结失愿结三。除苦根忧根。无明结五。见结疑结四。除苦根。嫉结悭结。二根相应。忧根护根。九十八使中欲界中身见边见见盗戒盗见谛所断。欲憍慢二根相应。喜根及护根。疑见谛所断嗔恚二根相应。忧根及护根。邪见见谛所断无明三。除乐根苦根。思惟所断贪欲三。除苦根忧根。嗔恚三。除乐根喜根。憍慢二根相应。喜根及护根。无明使五。色界三。除苦根忧根。无色界一。护根相应也(七门根门竟)。此三结几欲界系。几色界系。几无色界系。答曰。尽有三行。或欲界系。或色界系。或无色界系。贪嗔恚愚痴。及欲漏欲界系。有漏或色界系。或无色界系。余残三行。或欲界系。或色界系。或无色界系。流中欲流欲界系。有流或色界系。或无色界系。余残三行。或欲界系。或色无色界系。轭亦如是。受中欲受欲界系。我受或色界系。或无色界系。余残三行。或欲界系。或色无色界系。缚中欲爱身缚嗔恚身缚欲界系。余残三行。或欲界系。或色无色界系。五盖及嗔恚结嫉结悭结欲界系。余残三行。或欲界系。或色无色界系。下分中贪欲嗔恚欲界系。余残及五见三行。或欲界系。或色无色界系。身爱中鼻更爱舌更爱欲界系。眼更爱耳身更爱。或欲界系。或色界系。意更爱三行。或欲界系。或色无色界系。使中贪欲使嗔恚使欲界系。有爱使。或色界系。或无色界系。余残三行。或欲界系。或色无色界系。结中嗔恚结嫉结悭结欲界系。余残三行。或欲界系。或色无色界系。九十八使中三十六欲界系。三十一色界系。三十一无色界系(八门系门竟也)。诸所有结使是欲界者。彼结使在欲界耶。答曰。或是欲界结使。彼结使不在欲界。云何是欲界结使。彼结使不在欲界。答曰。结使所缠魔波旬住梵天上。如来语言亦结使所缠。从色界没办欲界中阴。是谓是欲界结使。彼结使不在欲界。云何结使在欲界。彼结使不是欲界。答曰。结使所缠从欲界没。办色界中阴。亦所有结使是色无色界。住欲界现在前。是谓在欲界结使。彼结使不是欲界。云何是欲界结使。彼结使亦在欲界。答曰。结使所缠从欲界没。办欲界中阴生阴。亦诸结使在欲界者。住欲界现在前。是谓结使是欲界彼结使亦在欲界。云何亦不是欲界结使。彼结使亦不在欲界。答曰诸结使所缠从色界没。办色界中阴生阴。色界没生无色界。无色界没生无色界。无色界没生色界。亦所有结使在色无色界。住色界现在前。诸所有结使在无色界。住无色界现在前是谓结使亦不是欲界。彼结使亦不在欲界。诸所有结使是色界彼结使在色界耶。答曰。或有结使是色界。彼结使不在色界。云何结使是色界彼结使不在色界。答曰。结使所缠从欲界没办色界中阴。亦所有结使是色界。住欲界现在前。是谓色界结使彼结使不在色界。云何在色界结使彼结使不是色界。答曰。诸结使所缠魔波旬住梵天上。如来语言亦结使所缠。从色界没办欲界中阴。亦所有结使在无色界。住色界现在前。是谓在色界结使彼结使不是色界。云何是色界结使彼结使亦在色界。答曰。诸结使所缠从色界没办。色界中阴生阴。亦所有结使是色界。住色界现在前。是谓是色界结使彼结使亦在色界。云何结使不是色界彼结使亦不在色界。答曰。诸结使所缠从欲界没。办欲界中阴生阴。从欲界没生无色界。无色界没生无色界。无色界没生欲界。亦所有结使在无色界。住欲界现在前。亦所有结使在无色界。住无色界现在前。是谓结使不是色界彼结使亦不在色界。非亦如是诸所有结使是无色界。彼结使在无色界耶。答曰。如是诸所有结使在无色界。彼结使是无色界也。颇是无色界结使彼结使不在无色界耶。答曰。有诸所有结使是无色界。住欲色界现在前。诸所有结使不是无色界。彼结使亦不在无色界耶。答曰。如是诸所有结使不是无色界。彼结使亦不在无色界。颇结使不在无色界。彼结使非不是无色界耶。答曰。有诸所有结使是无色界。住欲界色界现在前(九门竟)。见谛成就世尊弟子。色未尽为色所系耶。答曰。如是。设为色所系色不尽耶。答曰。如是。若痛未尽为痛所系耶。答曰。如是。痛未尽为痛所系。颇为痛所系非痛未尽耶。答曰有家家斯陀含。一种欲界系增上中思惟所断结尽。彼相应痛下结使系。想行识亦复如是(十门竟)。见谛成就世尊弟子。若色已尽彼色脱耶。答曰。如是。若色不系彼色尽耶。答曰。如是。若痛已尽彼痛不系耶。答曰。如是。若痛不系彼痛尽耶。颇痛尽彼痛非不系耶。答曰。有家家斯陀含。一种欲界系增上中思惟所断结尽。彼相应痛下结使系。想行识亦复如是(十一门竟)。五人坚信坚法信解脱见到身证。坚信人于此三结。成就几不成就几。答曰。苦未知智未生一切成就。苦未知智生。二成就一不成就。贪嗔恚愚痴欲爱未尽。一切成就。欲爱已尽。一切不成就。有漏中欲爱未尽一切成就。欲爱已尽。二成就一不成就。流中欲爱未尽。一切成就。欲爱已尽。三成就一不成就。轭受亦如是。缚中欲爱未尽。一切成就。欲爱已尽。二成就。二不成就。盖中欲爱未尽。道法智未生。一切成就若欲爱未尽。道法智生四成就一不成就。欲爱已尽。一切不成就。结中欲爱未尽。一切成就。欲爱已尽。二成就三不成就。下分中欲爱未尽。苦未知智未生。一切成就。若欲爱未尽苦未知智生。四成就一不成就欲爱已尽苦未知智未生。三成就二不成就。若欲爱已尽苦未知智生。二成就三不成就。见中苦未知智未生。一切成就。苦未知智生。三成就二不成就。身爱中欲爱未尽。一切成就。欲爱已尽。梵天爱未尽。四成就二不成就。梵天爱尽。一成就五不成就。使中欲爱未尽。一切成就。欲爱已尽。五成就二不成就。结中欲爱未尽。一切成就。欲爱已尽。六成就三不成就。九十八使中欲爱未尽。苦法智未生。一切成就。苦法智生苦未知智未生。欲界苦谛所断。不成就。余残成就。苦未知智生习法智未生。三界苦谛所断。不成就。余残成就。习法智生习未知智未生。三界苦谛所断。不成就。及欲界习谛所断余残成就。习未知智生尽法智未生。三界苦习所断。不成就。余残成就。尽法智生尽未知智未生。三界苦谛习谛所断不成就。及欲界尽谛所断余残成就。尽未知智生道法智未生。三界苦谛习谛尽谛所断不成就。余残成就。道法智生三界苦集尽谛所断不成就。及欲界道谛所断余残成就。欲爱已尽色爱未尽。苦未知智未生。欲界一切不成就。余残成就。苦未知智生习未知智未生。欲界一切不成就。及色无色界苦谛所断余残成就。习未知智生尽未知智未生。欲界一切不成就。及色无色界苦谛习谛所断余残成就。尽未知智生欲界一切不成就。及色无色界苦谛习谛尽谛所断余残成就。色爱已尽无色爱未尽。苦未知智未生。欲色界一切不成就。余残成就。苦未知智生。习未知智未生。欲色界一切不成就。及无色界苦谛所断余残成就。习未知智生。尽未知智未生。欲色界一切不成就。及无色界苦谛习谛所断余残成就。尽未知智生。欲色界一切不成就。及无色界苦谛习谛尽谛所断余残成就。坚法亦如是。信解脱人。此三结几成就几不成就。答曰。一切不成就贪嗔恚愚痴欲爱未尽一切成就欲爱已尽。一切不成就。有漏中欲爱未尽。一切成就。欲爱已尽。二成就一不成就。流中欲爱未尽。三成就一不成就。欲爱已尽。二成就二不成就。轭亦如是。受中欲爱未尽。二成就二不成就。欲爱已尽。一成就三不成就。缚中欲爱未尽。二成就二不成就。欲爱已尽。一切不成就。盖中欲爱未尽。四成就一不成就。欲爱已尽。一切不成就。结中欲爱未尽。一切成就。欲爱已尽。二成就三不成就。下分中欲爱未尽。二成就三不成就。欲爱已尽。一切不成就。见不成就。身爱中欲爱未尽。一切成就。欲爱已尽。梵天爱未尽。四成就二不成就。梵天爱尽。一成就五不成就。使中欲爱未尽。五成就二不成就。欲爱已尽。三成就四不成就。结中欲爱未尽六成就三不成就。欲爱已尽。三成就六不成就。九十八使中。欲爱未尽。十成就八十八不成就。欲爱已尽。色爱未尽。六成就九十二不成就。色爱已尽。无色爱未尽。三成就九十五不成就。见到亦复如是。身证人。此三结几成就几不成就。答曰。一切不成就。贪嗔恚愚痴不成就。有漏中二成就一不成就。流中二成就二不成就。轭亦如是。受中一成就三不成就。缚不成就。盖不成就。结中二成就三不成就。下分不成就。见不成就。身爱中一成就五不成就。使中三成就四不成就。结中三成就六不成就。九十八使中三成就九十五不成就(十二门竟)。身见。彼身见几缘缘。答曰。或四三二一。谁四。答曰。如身见次第生身见。即彼思惟前生后生因。次第缘增上。是谓四。谁三。答曰。如身见次第生身见。即彼不思惟前生后生因。次第增上无缘。如身见次第生。若干心生身见。即彼思惟前生后生因缘增上无次第。是谓三。谁二。答曰。如身见次第生。若干心生身见。即彼不思惟前生后生因增上。是谓二。谁一。答曰。后生前生。若与缘缘增上。不与缘一增上。未来过去现在若与缘缘增上。不与缘一增上。未来现在过去若与缘缘增上。不与缘一增上。欲界系色界系一增上。色界系欲界系。若与次第次第增上。不与次第一增上。欲界系无色界系一增上。无色界系欲界系若与次第次第增上。不与次第一增上。色界系无色界系一增上。无色界系色界系。若与次第次第增上。不与次第一增上。如身见身见如是不一切遍。不一切遍不一切遍。一切遍身见戒盗有几缘缘。答曰。或四三二一。谁四。答曰。如身见次第生。戒盗即彼思惟前生后生因次第缘增上。是谓四。谁三。答曰。如身见次第生。戒盗即彼不思惟。前生后生因次第增上无缘。如身见次第生。若干心生戒盗。即彼思惟前生后生因缘增上无次第。是谓三。谁二。答曰。如身见次第生。若干心生戒盗。即彼不思惟前生后生因增上。是谓二。谁一。答曰。后生前生。若与缘缘增上。不与缘一增上。未来过去现在若与缘缘增上。不与缘一增上。未来现在过去若与缘缘增上不与缘一增上。欲界系色界系一增上。色界系欲界系若与次第无缘次第增上。若与缘无次第缘增上。若与次第缘次第缘增上。若不与次第缘一增上。欲界系无色界系一增上。无色界系欲界系。若与次第无缘次第增上。若与缘无次第缘增上。若与次第缘次第缘增上。若不与次第缘一增上。色界系无色界系一增上。无色界系色界系。若与次第无缘次第增上。若与缘无次第缘增上。若与次第缘次第缘增上。若不与次第缘一增上。如身见戒盗如是。不一切遍一切遍。一切遍不一切遍

阿毗昙不善品第九竟(梵本六百二首卢秦长十四字也)

阿毗昙八犍度论卷第四阿毗昙八犍度论卷第五

        迦旃延子造

        符秦罽宾三藏僧伽提婆共竺佛念译

    阿毗昙结使犍度一行跋渠第二之一

一行历六小七亦大。七摄钩琐有由何定灭结使。诸道断智八人。九结爱结嗔恚结憍慢结无明结见结失愿结疑结悭结嫉结。若身中爱结系彼有嗔恚耶。若有嗔恚结系复有爱结耶。若身中有爱结系。有憍慢结无明结见结失愿结疑结悭结嫉结复有耶。若有嫉结系复有爱结耶。身中乃至悭结系复有嫉结耶。设有嫉结复有悭结耶(一行竟)。若身中过去爱结系未来复有耶。若有未来过去复有耶(一)。若有过去现在复有耶。若有现在过去复有耶(二)。若有未来现在复有耶。若有现在未来复有耶(三)。若有过去未来现在复有耶。若有未来现在过去复有耶(四)。若有未来过去现在复有耶。若有过去现在未来复有耶(五)。若有现在过去未来复有耶。若有过去未来现在复有耶(六)。乃至悭嫉亦复如是。若身中有过去爱结系。过去嗔恚结复有耶。若有过去嗔恚结。过去爱结复有耶(一)。若身中有过去爱结系。未来复有嗔恚结耶。若有未来嗔恚结。过去复有爱结耶(二)。若身中有过去爱结系。现在复有嗔恚结耶。若有现在嗔恚结。过去复有爱结耶(三)。若身中有过去爱结系。过去现在复有嗔恚结耶。若有过去现在嗔恚结。过去复有爱结耶(四)。若身中有过去爱结系。未来现在复有嗔恚结耶。若有未来现在嗔恚结。过去复有爱结耶(五)。若身中有过去爱结系。过去未来复有嗔恚结耶。若有过去未来嗔恚结。过去复有爱结耶(六)。若身中有过去爱结系。过去未来现在复有嗔恚结耶。若有过去未来现在嗔恚结。过去复有爱结耶(七事竟)。过去爱过去嗔恚过去憍慢(一)。未来(二)。现在(三)。过去现在(四)。未来现在(五)。过去未来(六)。过去未来现在憍慢(七)。乃至悭嫉亦复如是(大七竟)。身见几使所摄。戒盗疑乃至无色界思惟所断无明。几使所摄(门竟)。三结三不善根。三结为摄三不善根。三不善根为摄三结。三结乃至九十八使。三结为摄九十八使。九十八使为摄三结乃至九结。九十八使为九结摄九十八使。九十八使为摄九结(琐门竟)。此三结几受欲有。几受色有。几受无色有。此乃至九十八使。几受欲有。几受色无色有(有门竟)。身见由何三昧尽。戒盗疑乃至无色界思惟所断无明使。由何三昧尽(三昧门竟)。若结过去彼结已系耶。若彼结已系彼过去结耶。若结未来彼结当系耶。若彼结当系彼未来结耶。若结现在今系彼结耶。若今系彼结现在耶(三世结处竟)。若以道灭欲界结。于彼道退得彼结系。不得彼结系。若以道灭色无色界结。于彼道退得彼结系。不得彼结系(道退竟)。九断智。欲界中苦谛习谛所断结尽一断智。色无色界苦谛习谛所断结尽二断智。欲界尽谛所断结尽三断智。色无色界尽谛所断结尽四断智。欲界道谛所断结尽五断智。色无色界道谛所断结尽六断智。五下分结尽七断智。色爱尽八断智。一切结尽九断智。九断智为摄一切断智。一切断智为摄九断智。八人趣须陀洹证得须陀洹。趣斯陀含证得斯陀含。趣阿那含证得阿那含。趣阿罗汉证得阿罗汉。向须阿洹证于九断智。成就几智。不成就几智。乃至向阿罗汉证阿罗汉。于九断智成就几智不成就几智。此章义愿具演说。九结爱结嗔恚结憍慢结无明结见结失愿结疑结悭结嫉结。身中有爱结系。复有嗔恚结耶。答曰。如是。若有嗔恚结则有爱结。颇有爱结无嗔恚结耶。答曰有。若色无色界法爱结未尽。若身中有爱结系。复有憍慢耶。答曰。如是。若有憍慢有爱结耶。答曰。如是。若身中有爱结系有无明结耶。答曰。如是。有爱结则有无明结耶。颇有无明无爱结耶。答曰有。苦智生习智未生。若苦谛所断法中。习谛所断无明结未尽。若身中有爱结系复有见结耶。答曰。或有爱无有见也。云何有爱无有见耶。答曰。习智已生尽智未生。若尽谛道谛所断见不相应法爱结未尽。若思惟所断法爱结未尽。尽智已生道智未生。若道谛所断见不相应法爱结未尽。若思惟所断法爱结未尽。见谛成就世尊弟子。思惟所断法爱结未尽。是谓爱非见。云何见非爱。答曰。苦智已生习智未生。苦谛所断法习谛所断见结未尽。是谓见非爱。云何二俱系。答曰。人身体支节尽系。若四谛思惟所断法二俱系。苦智已生习智未生。若习尽道谛思惟所断法二俱系。习智已生尽智未生。尽谛道谛所断见相应法二俱系。尽智已生道智未生。道谛所断见相应法二俱系。是谓身中二俱系。云何身中二俱不系耶。答曰。习智已生尽智未生。苦谛习谛所断法二俱不系。尽智已生道智未生。苦习尽谛所断法二俱不系。见谛成就世尊弟子。四谛所断法二俱不系。欲爱已尽于欲界法二俱不系。色无色爱尽色无色界法二俱不系。是谓身二俱不系。疑亦如是。若身中有爱结系复有失愿耶。答曰。或有爱无失愿。云何有爱无失愿耶。答曰。习智已生尽智未生。思惟所断法爱结未尽。尽智已生道智未生。思惟所断法爱结未尽。见谛成就世尊弟子。若思惟所断法爱结未尽。是谓爱无失愿。云何有失愿无爱。答曰。苦智已生习智未生。若苦谛所断法习谛所断失愿结未尽。是谓失愿无爱。云何身二俱系。答曰。人身体支节尽缚。四谛思惟所断法二俱系。苦智已生习智未生。若习尽道谛思惟所断法二俱系。习智已生尽智未生。尽谛道谛所断法二俱系。尽智已生道智未生。若道谛所断法二俱系。是谓二俱系。云何二俱不系。答曰。习智已生尽智未生。苦谛习谛所断法二俱不系。尽智已生道智未生。苦习尽谛所断法二俱不系。见谛成就世尊弟子。四谛所断法二俱不系。欲爱尽于欲界法二俱不系。色无色界爱尽色无色界法二俱不系。是谓身二俱不系。若身中爱结系复有悭结耶。答曰。如是。有悭则有爱也。颇有爱无悭耶。答曰。有欲界四谛所断法爱结未尽。乃至色无色界法爱结未尽。嫉亦如是。(爱门竟)。憍慢门亦如是。若身中有嗔恚结系。复有憍慢结耶。答曰。如是。有嗔恚结系则有憍慢结耶。颇有憍慢无嗔恚耶。答曰。有色无色界法憍慢结未尽。若身中有嗔恚结系有无明结耶。答曰。如是。有嗔恚则有无明也。颇有无明无嗔恚耶。答曰。有欲爱未尽。苦智已生习智未生。欲界中苦谛所断法。习谛所断无明结未尽。若色无色界法无明结未尽。若身中有嗔恚结系有见结耶。答曰。或有嗔恚无见。云何嗔恚无见。答曰。欲爱未尽习智已生尽智未生。欲界中尽谛所断道谛所断。见不相应法嗔恚结未尽。欲界中思惟所断法嗔恚结未尽。尽智已生道智未生。欲界中道谛所断。见不相应法嗔恚结未尽。欲界中思惟所断法嗔恚结未尽。见谛成就世尊弟子。欲爱未尽欲界思惟所断法嗔恚结未尽。是谓嗔恚无见也。云何见无嗔恚。答曰。欲爱未尽苦智已生习智未生。欲界中苦谛所断法。习谛所断见结未尽。色无色界法见结未尽。是谓见无嗔恚。云何身二俱系。答曰。人身体支节尽缚。欲界中四谛思惟所断法二俱系。欲爱未尽苦智已生习智未生。欲界中习尽道谛思惟所断法二俱系。习智已生尽智未生。欲界中尽谛道谛所断见相应法二俱系。尽智已生道智未生。欲界中道谛所断见相应法二俱系。是谓身二俱系。云何身二俱不系。答曰。习智已生尽智未生。苦谛习谛所断法二俱不系。色无色界思惟所断法二俱不系。尽智已生道智未生。苦习尽谛所断法二俱不系。色无色界思惟所断法二俱不系。见谛成就世尊弟子。四谛所断法二俱不系。欲爱已尽欲界法二俱不系。色无色界爱尽色无色界法二俱不系。是谓身二俱不系。疑亦如是。若身中有嗔恚结系复有失愿耶。答曰。或有嗔恚无失愿也。云何有嗔恚无失愿。答曰。欲爱未尽习智已生尽智未生。欲界思惟所断法嗔恚未尽。尽智已生道智未生。欲界思惟所断法嗔恚未尽。见谛成就世尊弟子。欲爱未尽欲界思惟所断法嗔恚未尽。是谓嗔恚无失愿。云何有失愿无嗔恚。答曰。欲爱未尽苦智已生习智未生。欲界苦谛所断法习谛所断失愿未尽。色无色界法失愿未尽。是谓失愿无嗔恚。云何二俱系。答曰。人身体支节尽缚。欲界四谛思惟所断法二俱系。欲爱未尽苦智已生习智未生。欲界习尽道谛思惟所断法二俱系。习智已生尽智未生。欲界尽谛道谛所断法二俱系。尽智已生道智未生。欲界道谛所断法二俱系。是谓身二俱系。云何身二俱解脱。答曰。习智已生尽智未生。苦谛习谛所断法二俱解脱。色无色界思惟所断法二俱解脱。尽智已生道智未生。苦谛习谛尽谛所断法二俱解脱。色无色界思惟所断法二俱解脱。见谛成就世尊弟子。四谛所断法二俱解脱。色无色界思惟所断法二俱解脱。欲爱已尽欲界法二俱解脱。色无色爱尽色无色界法二俱解脱。是谓身二俱解脱。若身中有嗔恚结系有悭结耶。答曰。如是。有悭结则有嗔恚结。颇有嗔恚结无悭耶答曰。有欲界四谛所断法嗔恚未尽嫉结亦如是(嗔恚竟)。若身中有无明结系有见结耶。答曰。如是。有见则有无明也。颇有无明无见耶。答曰。习智已生尽智未生。尽谛道谛所断见不相应法无明结未尽。思惟所断法无明结未尽。尽智已生道智未生。道谛所断见不相应法无明结未尽。思惟所断法无明结未尽。见谛成就世尊弟子。思惟所断法无明结未尽。疑亦如是。若身中有无明结系有失愿结耶。答曰。如是有失愿则有无明也。颇有无明无失愿耶。答曰。有习智已生尽智未生。思惟所断法无明结未尽。尽智已生道智未生。思惟所断法无明结未尽。见谛成就世尊弟子。思惟所断法无明结未尽。若身中有无明结系有悭结耶。答曰。如是。有悭结则有无明也。颇有无明无悭耶。答曰。有欲界四谛所断法无明结未尽。色无色界法无明结未尽。嫉亦如是(痴门竟)。若身中有见结系有失愿耶。答曰。如是。有见结则有失愿也。颇有失愿无见耶。答曰。有习智已生尽智未生。尽谛道谛所断见不相应法失愿结未尽。尽智已生道智未生。道谛所断见不相应法失愿未尽。若身中有见结系有疑结耶。答曰。或有见无疑也。云何有见无疑耶。答曰。习智已生尽智未生。尽谛道谛所断见相应法见结未尽。尽智已生道智未生。道谛所断见相应法见结未尽。是谓见无疑也。云何有疑无见耶。答曰。习智已生尽智未生。尽谛道谛所断疑相应法疑结未尽。尽智已生道智未生。道谛所断疑相应法疑结未尽。是谓疑无见也。云何身二俱系。答曰。人身体支节尽缚。四谛思惟所断法二俱系。苦智已生习智未生。习尽道谛思惟所断法二俱系。是谓身二俱系。云何身二俱解脱。答曰。习智已生尽智未生。苦谛习谛所断法二俱解脱。尽谛道谛所断见疑不相应法二俱解脱。思惟所断法二俱解脱。尽智已生道智未生。苦谛习谛尽谛所断法二俱解脱。道谛所断见疑不相应法二俱解脱。思惟所断法二俱解脱。见谛成就世尊弟子。四谛所断法二俱解脱。欲爱已尽欲界法二俱解脱。色无色爱尽色无色界法二俱解脱。是谓身二俱解脱。若身中有见结系有悭结耶。答曰。或有见无悭。云何有见无悭耶。答曰。欲界四谛所断法见结未尽。色无色界法见结未尽。是谓见无悭。云何有悭非见。答曰。欲爱未尽习智已生尽智未生。欲界思惟所断法悭结未尽。尽智已生道智未生。欲界思惟所断法悭结未尽。见谛成就世尊弟子。欲爱未尽欲界思惟所断法悭结未尽。是谓悭非见。云何身二俱系。答曰。人身体支节尽缚。欲界思惟所断法二俱系。欲爱未尽苦智已生习智未生。欲界思惟所断法二俱系。是谓二俱系。云何二俱解脱。答曰。习智已生尽智未生。苦习谛所断法二俱解脱。尽道谛所断见不相应法二俱解脱。色无色界思惟所断法二俱解脱。尽智已生道智未生。苦习尽谛所断法二俱解脱。道谛所断见不相应法二俱解脱。色无色界思惟所断法二俱解脱。见谛成就世尊弟子。四谛所断法二俱解脱。色无色界思惟所断法二俱解脱。欲爱已尽欲界法二俱解脱。色无色爱尽。色无色界法二俱解脱。是谓二俱解脱。嫉亦如是(第五见门竟历四也)。若身中有失愿结系有疑结耶。答曰。如是。有疑结则有失愿也。颇有失愿无疑耶。答曰。有习智已生尽智未生。尽谛道谛所断疑不相应法失愿结未尽。尽智已生道智未生。道谛所断疑不相应法失愿结未尽。若身中有失愿结系有悭结耶。答曰。或有失愿无悭。云何有失愿无悭耶。答曰。欲界四谛所断法失愿结未尽。色无色界法失愿结未尽。是谓有失愿无悭。云何有悭无失愿耶。答曰。欲爱未尽习智已生尽智未生。欲界思惟所断法悭结未尽。尽智已生道智未生。欲界思惟所断法悭结未尽。见谛成就世尊弟子。欲爱未尽欲界思惟所断法悭结未尽。是谓悭无失愿。云何二俱系。答曰。人身体支节尽缚。欲界思惟所断法二俱系。欲爱未尽苦智已生习智未生。欲界思惟所断法二俱系。是谓身二俱系。云何二俱解脱。答曰。习智已生尽智未生。苦习谛所断法二俱解脱。色无色界思惟所断法二俱解脱。尽智已生道智未生。苦习尽谛所断法二俱解脱。色无色界思惟所断法二俱解脱。见谛成就世尊弟子。四谛所断法二俱解脱。色无色界思惟所断法二俱解脱。欲爱已尽欲界法二俱解脱。色无色界爱尽色无色界法二俱解脱。是谓二俱解脱。嫉亦如是(第六失愿门历三也)。若身中有疑结系有悭结耶。答曰。或有疑无悭。云何有疑无悭耶。答曰。欲界四谛所断法疑结未尽。色无色界法疑结未尽。是谓有疑无悭。云何有悭无疑。答曰。欲爱未尽习智已生尽智未生。欲界思惟所断法悭结未尽。尽智已生道智未生。欲界思惟所断法悭结未尽。见谛成就世尊弟子。欲爱未尽欲界思惟所断法悭结未尽。是谓有悭无疑也。云何二俱系。答曰。人身体支节尽缚欲界思惟所断法二俱系。欲爱未尽苦智已生习智未生。欲界思惟所断法二俱系。是谓二俱系。云何二俱解脱。答曰。习智已生尽智未生。苦谛习谛所断法二俱解脱。尽谛道谛所断疑不相应法二俱解脱。色无色界思惟所断法二俱解脱。尽智已生道智未生。苦谛习谛尽谛所断法二俱解脱。道谛所断疑不相应法二俱解脱。色无色界思惟所断法二俱解脱。见谛成就世尊弟子。四谛所断法二俱解脱。色无色界思惟所断法二俱解脱。欲爱已尽欲界法二俱解脱。色无色界爱尽。色无色界法二俱解脱。是谓二俱解脱。嫉亦如是(第七疑门竟)。若身中有悭结系有嫉结耶。答曰。如是。若有嫉有悭结耶。答曰。如是。一行竟(历六道也)

身中有过去爱结系有未来耶。答曰。如是。设有未来有过去耶。答曰。本兴未尽则系。若本不兴本兴已尽则不系。若有过去有现在耶。答曰。若现在前。设现在有过去耶。答曰。若本兴不尽则系。若本不兴本兴已尽则不系。若有未来有现在耶。答曰。若现在前。设有现在有未来耶。答曰。如是。若有过去有未来现在耶。答曰。未来则系现在。若现在前设有未来。现在有过去耶。答曰。若本兴未尽则系。若本不兴兴者已尽则不系。若有未来有过去现在耶。答曰。或有未来无过去现在。或有未来及过去无现在。或有未来及现在无过去。或有未来过去现在。云何有未来无过去现在耶。答曰。若身中有爱结未尽。若本不兴本兴已尽不现在前。是谓未来无过去现在。云何未来及过去无现在耶。答曰。身中本兴爱结未尽。有此身爱结不现在前。是谓未来及过去无现在。云何未来及现在无过去耶。答曰。身中有爱结现在前。若本不兴兴者已尽。是谓未来及现在无过去。云何未来及过去现在耶。答曰。身中爱结本兴未尽。又此身爱结现在前。是谓未来及过去现在。设有过去现在有未来耶。答曰。如是。若有现在有过去未来耶。答曰。未来则系过去。若本兴未尽则系。若本不兴兴者已尽则不系。设有过去未来有现在耶。答曰。若现在前(爱历六尽也)。嗔恚憍慢悭嫉亦复如是。身中有过去无明结系有未来耶。答曰。如是。设有未来有过去耶。答曰。如是。若有过去有现在耶。答曰。若现在前。设有现在有过去耶。答曰。如是若有未来有现在耶。答曰。若现在前。设有现在有未来耶。答曰。如是。若有过去有未来现在耶。答曰。未来则系现在若现在前。设有未来现在有过去耶。答曰。如是。若有未来有过去现在耶。答曰。过去则系现在若现在前。设有过去现在有未来耶。答曰。如是。若有现在有过去未来耶。答曰。如是。设有过去未来有现在耶。答曰。若现在前(无明历六竟也)。见失愿疑亦复如是。身中有过去爱结系。有过去嗔恚结耶。答曰。若本兴未尽则系。若本不兴兴者已尽则不系。设有过去嗔恚结有过去爱结耶。答曰。若本兴未尽则系。若前不兴兴者已尽则不系。身中有过去爱结系有未来嗔恚结耶。答曰。若未尽。设有未来嗔恚结有过去爱结耶。答曰。若前兴未尽则系。若前不兴兴者已尽则不系。身中有过去爱结系有现在嗔恚结耶。答曰。若现在前。设有现在嗔恚结有过去爱结耶。答曰。若前兴未尽则系。若前不兴兴者已尽则不系。身中有过去爱结系有过去现在嗔恚结耶。答曰。或有过去爱结无过去现在嗔恚结。或有过去爱结及过去嗔恚结无现在。或有过去爱结及现在嗔恚结无过去。或有过去爱结及过去现在嗔恚结。云何身中有过去爱结无过去现在嗔恚结耶。答曰。身中爱结前兴未尽。又此身中前不兴嗔恚结。若前兴便尽不现在前。是谓身过去爱结系无过去现在嗔恚结。云何身中过去爱结系及过去嗔恚结无现在耶。答曰。身中爱结嗔恚结前兴未尽。又此身中嗔恚结不现在前。是谓身过去爱结系及过去嗔恚结无现在。云何身中过去爱结系及现在嗔恚结无过去耶。答曰。身中爱结前兴未尽。又此身中嗔恚结现在前。若本不兴兴者已尽。是谓身过去爱结系及现在嗔恚结无过去。云何身过去爱结系及过去现在嗔恚结耶。答曰。若身中爱结嗔恚结前兴不尽。又此身中嗔恚结现在前。是谓身过去爱结系及过去现在嗔恚结也。设有过去现在嗔恚结有过去爱结耶。答曰。若本兴爱结未尽则系。若前不兴兴者便尽则不系。身中有过去爱结系。有未来现在嗔恚结耶。答曰。或有过去爱结系。无有未来现在嗔恚结也。或有过去爱结系。及未来嗔恚结无现在。或有过去爱结系及未来现在嗔恚结。云何身有过去爱结系无未来现在嗔恚结耶。答曰。色无色界法前兴爱结未尽。是谓身过去爱结系无未来现在嗔恚结。云何身过去爱结系及未来嗔恚结无现在耶。答曰。身中前兴爱结未尽。又此身中嗔恚结未尽不现在前。是谓身过去爱结系及未来嗔恚结无现在。云何身过去爱结系及未来现在嗔恚结耶。答曰。身中前兴爱结未尽。又此身中嗔恚结现在前。是谓身过去爱结系。及未来现在嗔恚结也。设有未来现在嗔恚结有过去爱结乎。答曰。若本兴未尽则系。若本不兴兴者已尽则不系。身中有过去爱结系。有过去未来嗔恚结乎。答曰。或有过去爱结。系。无过去未来嗔恚结。或有过去爱结系及未来嗔恚结无过去。或有过去爱结系及过去未来嗔恚结。云何身有过去爱结系无过去未来嗔恚结耶答曰。色无色界法前兴爱结未尽。是谓身过去爱结系无过去未来嗔恚结。云何身过去爱结系及未来嗔恚结无过去。答曰。身前兴爱结未尽。又此身中嗔恚结未尽。若本不兴兴者已灭。是谓身过去爱结系及未来嗔恚结无过去。云何身过去爱结系及过去未来嗔恚结耶。答曰。身中爱结嗔恚结前兴未尽。是谓身过去爱结系及过去未来嗔恚结。设有过去未来嗔恚结有过去爱结乎。答曰。若本兴未尽则系。若前不兴兴者已尽则不系

阿毗昙八犍度论卷第五阿毗昙八犍度论卷第六

        迦旃延子造

        符秦罽宾三藏僧伽提婆共竺佛念译

    阿毗昙结使犍度一行跋渠之余

身中有过去爱结系。有过去未来现在嗔恚结乎。答曰。或有过去爱结系。无过去未来现在嗔恚结。或有过去爱结系。及未来嗔恚结。无过去现在。或有过去爱结系。及过去未来嗔恚结无现在。或有过去爱结系。及未来现在嗔恚结无过去。或有过去爱结系。及过去未来现在嗔恚结。云何身有过去爱结系。无过去未来现在嗔恚结乎。答曰。色无色界法前兴爱结未尽。是谓身过去爱结系。无过去未来现在嗔恚结。云何身过去爱结系。及未来嗔恚结。无过去现在嗔恚结乎。答曰。身中前兴爱结未尽。又此身中嗔恚结未尽。若前不兴兴者已尽不现在前。是谓身过去爱结系及未来嗔恚结。无过去现在。云何身有过去爱结系。及过去未来嗔恚结。无现在乎。答曰。身中爱结嗔恚结前兴未尽。又此身中嗔恚结不现在前。是谓身过去爱结系及过去未来嗔恚结无现在。云何身过去爱结系。及未来现在嗔恚结无过去乎。答曰。身中前兴爱结未尽。又此身中嗔恚结现在前。若前不兴兴者已尽。是谓身过去爱结系。及未来现在嗔恚结无过去。云何身有过去爱结系。及过去未来现在嗔恚结乎。答曰。身中爱结嗔恚结前兴未尽。又此身中嗔恚结现在前。是谓身过去爱结系。及过去未来现在嗔恚结。设有过去未来现在嗔恚结。有过去爱结乎。答曰。若前兴未尽则系。若本不兴兴者已尽则不系(嗔七事竟也)。悭嫉亦如是。身中有过去爱结系。复有过去憍慢结耶。答曰。若前兴未尽则系。若前不兴兴者已尽则不系。设有过去憍慢结有过去爱结乎。答曰。若前兴未尽则系。若前不兴兴者已尽则不系。身中有过去爱结系。复有未来憍慢结乎。答曰。如是。设有未来憍慢结。复有过去爱结乎。答曰。若前兴未尽则系。若前不兴兴者已尽则不系。身中有过去爱结系。复有现在憍慢结乎。答曰。若现在前。设有现在憍慢结复有过去爱结乎。答曰。若前兴未尽则系。若前不兴兴者已尽则不系。身中有过去爱结系。有过去现在憍慢结乎。答曰。或有过去爱结无过去现在憍慢结。或有过去爱结及过去憍慢无现在。或有过去爱结系及现在憍慢无过去。或有过去爱结及过去现在憍慢。云何身中有过去爱结系。无过去现在憍慢乎。答曰。身中前兴爱结未尽。又此身中憍慢若前不兴兴者已尽不现在前。是谓身过去爱结系无过去现在憍慢。云何身有过去爱结系及过去憍慢无现在。答曰。身中爱结憍慢结前兴未尽。又此身中憍慢结不现在前。是谓身过去爱结系及过去憍慢结无现在。云何身有过去爱结系及现在憍慢无过去乎。答曰。身中前兴爱结未尽。又此身中憍慢结现在前。若本不兴兴者已尽。是谓身过去爱结系及现在憍慢无过去。云何身有过去爱结系及过去现在憍慢乎。答曰。身中爱结憍慢结前兴未尽。又此身中憍慢结现在前。是谓身过去爱结系及过去现在憍慢。设有过去现在憍慢结有过去爱结乎。答曰。若前兴未尽则系。若本不兴兴者已尽则不系。身中有过去爱结系。有未来现在憍慢结乎。答曰。未来则系现在若现在前。设有未来现在憍慢结。有过去爱结乎。答曰。若前兴未尽则系。若前不兴兴者已尽则不系。身中有过去爱结系。有过去未来憍慢结乎。答曰。未来则系。过去若本兴未尽则系。若前不兴兴者已尽则不系。设有过去未来憍慢。有过去爱结耶。答曰。若前兴未尽则系。若前未兴兴者已尽则不系。身中有过去爱结系。有过去未来现在憍慢结耶。答曰。或有过去爱结及未来憍慢无过去现在。或有过去爱结。及过去未来憍慢无现在。或有过去爱结及未来现在憍慢无过去。或有过去爱结及过去未来现在憍慢也。云何有过去爱结及未来憍慢无过去现在。答曰。身中前兴爱结未尽。又此身中憍慢未尽。若前不兴兴者已尽。又此身中憍慢不现在前。是谓过去爱结系及未来憍慢无过去现在。云何过去爱结系。及过去未来憍慢无现在乎。答曰。身中前兴爱结憍慢未尽。又此身中憍慢不现在前。是谓过去爱结及过去未来憍慢无现在也。云何有过去爱结及未来现在憍慢无过去乎。答曰。身中前兴爱结未尽。又此身中憍慢结现在前。又此身中本不兴憍慢兴者已尽。是谓过去爱结及未来现在憍慢无过去。云何有过去爱结及过去未来现在憍慢乎。答曰。身中前兴爱结憍慢未尽。又此身中憍慢现在前。是谓过去爱结及过去未来现在憍慢。设有过去未来现在憍慢。有过去爱结乎。答曰。若本兴未尽则系。若本不兴兴者已尽则不系(憍慢竟也)。身中有过去爱结系。有过去无明结乎。答曰。如是。设有过去无明结。有过去爱结乎。答曰。若本兴未尽则系。若本不兴兴者已尽则不系。身中有过去爱结系。有未来无明结乎。答曰。如是。设有未来无明结。有过去爱结乎。答曰。若本兴未尽则系。若本未兴兴者已尽则不系。身中有过去爱结系。有现在无明结乎。答曰。若现在前。设有现在无明结有过去爱结乎。答曰。若前兴未尽则系。若前未兴兴者已尽则不系。身中有过去爱结系。有过去现在无明结乎。答曰。过去则系。现在若现在前。设有过去现在无明结。有过去爱结耶。答曰。若前兴不尽则系。若前不兴兴者已尽则不系。身中有过去爱结系。有未来现在无明结乎。答曰。未来则系。现在若现在前。设有未来现在无明结。有过去爱结耶。答曰。若前兴未尽则系。若前不兴兴者已尽则不系。身中有过去爱结系。有过去未来无明结耶。答曰。如是。设有过去未来无明结。有过去爱结耶。答曰。若本兴未尽则系。若前不兴兴者已尽则不系。身中有过去爱结系。有过去未来现在无明结耶。答曰。过去未来则系。现在若现在前。设有过去未来现在无明结。有过去爱结耶。答曰。若本兴不尽则系。若前不兴兴者已尽则不系(无明竟也)。身中有过去爱结系。有过去见结耶。答曰。若不尽。设有过去见结有过去爱结耶。答曰。若本兴不尽则系。若前未兴兴者已尽则不系。身中有过去爱结系。有未来见结耶。答曰。若不尽。设有未来见结有过去爱结耶。答曰。若本兴未尽则系。若前不兴兴者已尽则不系。身中有过去爱结系。有现在见结耶。答曰。若现在前。设有现在见结有过去爱结耶。答曰。若本兴未尽则系。若前未兴兴者已尽则不系。身中有过去爱结系。有过去现在见结耶。答曰。或有过去爱结。无过去现在见结也。或有过去爱结及过去见结无现在也。或有过去爱结及过去现在见结。云何有过去爱结无过去现在见结耶。答曰。身中爱结前兴未尽。又彼身中见结尽是。谓过去爱结。无过去现在见结。云何有过去爱结。及过去见结无现在耶。答曰。身中爱结前兴未尽。又彼身中见结未尽不现在前。是谓过去爱结。及过去见结无现在也。云何有过去爱结及过去现在见结耶。答曰。身中前兴爱结未尽。又彼身中见结现在前。是谓过去爱结。及过去现在见结。设有过去现在见结。有过去爱结耶。答曰。若本兴未尽则系。若前未兴兴者已尽则不系。身中有过去爱结系。有未来现在见结耶。答曰。或有过去爱结。无未来现在见结。或有过去爱结系。及未来见结无现在也。或有过去爱结及未来现在见结。云何有过去爱结无未来现在见结耶。答曰。前兴爱结未尽又彼身中见结尽。是谓过去爱结系。无未来现在见结。云何有过去爱结及未来见结无现在耶。答曰。身中前兴爱结未尽。又此身中见结未尽亦不现在前。是谓过去爱结系及未来见结无现在也。云何身中过去爱结系及未来现在见结。答曰。身中前兴爱结未尽。又此身中见结现在前。是谓身中过去爱结系及未来现在见结。设有未来现在见结。有过去爱结耶。答曰。若本兴未尽则系。若前未兴兴者已尽则不系。身中有过去爱结系。有过去未来见结耶。答曰。若不尽。设有过去未来见结有过去爱结耶。答曰。若本兴未尽则系。若前未兴兴者已尽则不系。身中有过去爱结系。有过去未来现在见结耶。答曰。或有过去爱结系。无过去未来现在见结。或有过去爱结系及过去未来见结无现在。或有过去爱结系及过去未来现在见结也。云何身中有过去爱结系。无过去未来现在见结耶。答曰。身中爱结本兴未尽。又此身中见结尽。是谓身中过去爱结系。无过去未来现在见结也。云何身中有过去爱结系及过去未来见结无现在耶。答曰。前兴爱结未尽。又彼身中见结未尽不现在前。是谓身中过去爱结系及过去未来见结无现在也。云何身中有过去爱结系及过去未来现在见结耶。答曰。身中爱结本兴未尽。又彼身中见结现在前。是谓身中过去爱结系及过去未来现在见结也。设有过去未来现在见结系。有过去爱结耶。答曰。若本兴未尽则系。若本未兴兴者已尽则不系(见七事竟也)。失愿疑亦复如是。过去爱过去嗔恚过去憍慢(一)。未来(二)。现在(三)。过去现在(四)。未来现在(五)。过去未来(六)。过去未来现在憍慢(七)。乃至悭嫉亦复如是。身见三使而相受入戒盗六疑十二贪五嗔恚五愚痴四一使少有所入。五有漏中欲有漏三十一。有漏五十二。无明漏十五。流中欲流十九。有流二十八无明流十五。见流三十六。枙亦如是。受中欲受二十四。戒受六。见受三十。我受三十八。缚中欲爱身缚五。嗔恚身缚五。戒盗身缚六。我见身缚十二。盖中贪欲五。嗔恚五。睡眠调悔不与众使而相受入。疑盖四结中嗔恚结五。爱结憍慢结各十五。悭结嫉结不与诸结而相受入。下分中贪欲五。嗔恚五。身见三。戒盗六。疑十二。见中身见边见各三。邪见见盗各十二。戒盗六。身爱中鼻更爱舌更爱。一使少相受入。眼更耳更身更爱二使少相受入。意更爱十三使而相受入。二使少有所入。使中贪欲使五。嗔恚使五。有爱使十。憍慢使无明使各十五。见使三十六。疑使十二。结中嗔恚结五。爱结憍慢结无明结各十五。见结失愿结各十八。疑结十二。悭结嫉结不与诸使而相受入。九十八使中欲界身见欲界身见而相受入。欲界戒盗疑乃至无色界思惟所断无明使。无色界思惟所断无明使而相受入(相摄门竟也)。三结三不善根。三结为受入三不善根。三不善根为受入三结。答曰。各各不相受入。三结三有漏三结受入二漏少分。二漏少分受入三结也。余残各各不相受入。三结四流三结受入三流少分。三流少分受入三结也。余残各各不相受入。扼亦如是。三结四受一结受入一受。二结受入三受少分。三受少分受入二结。余残各各不相受入。三结四缚为三结受入四缚耶。答曰。或结非缚。云何结非缚。答曰。二结是谓结非缚。云何缚非结。答曰。三缚是谓缚非结。云何结缚。答曰。一结是谓结缚。云何非结非缚。答曰。除上尔所事。三结五盖一结少分受入一盖。一盖少有受入一结少分。余残各各不相受入。三结五结为三结受入五结。五结受入三结。答曰。各各不相受入。三结五下分结。为三结受入五下分结。五下分结受入三结。答曰。五三非三五非受入何等。答曰。贪欲嗔恚。三结五见为三结受入五见耶。答曰。或结非见。云何结非见。答曰。一结是谓结非见。云何见非结。答曰。三见是谓见非结。云何是结见。答曰。二结是谓结见。云何非结非见。答曰。除上尔所事。三结六身爱。为三结。受入六身爱。为六身爱受入三结。答曰。各各不相受入。三结七使。一结受入一使。二结受入一使少分。一使少分受入二结。余残各各不相受入。三结九结。一结受入一结。二结受入二结少分。二结少分受入二结余残各各不相受入。三结九十八使。三结为受入二十一使。二十一使受入三结。余残各各不相受入。乃至九结九十八使。为九结受入九十八使。九十八使为受入九结。答曰。九九十八非九十八九不受入。何等。答曰。悭嫉也(钩锁门竟)。此三结几受欲有几色有无色有。答曰。一切少有所入。欲有所入。色有所入。无色有所入。贪嗔恚愚痴及欲漏受欲有有漏所入。色有所入。无色有所入。余残所入欲有所入。色有所入。无色有所入。流中欲流受欲有。有流所入。色有所入。无色有所入。余残所入。欲有所入。色无色有所入。扼亦如是。受中欲受受欲有。我受所入。色无色有所入。余残所入。欲有所入。色无色有所入。缚中欲爱身缚嗔恚身缚受欲有。余残所入。欲有所入。色无色有所入。盖及嗔恚悭嫉受欲有。余残所入。欲有所入。色无色有所入。下分中贪欲嗔恚受欲有。余残及见所入。欲有所入。色无色有所入。爱身中鼻更爱舌更爱受欲有。眼耳身更爱所入。受欲有所入。色有所入。意更爱所入。欲有所入。色无色有所入。使中贪欲使。嗔恚使。受欲有。有爱使所入。色有所入。无色有所入。余残所入。欲有所入。色无色有所入。结中嗔恚结。悭结。嫉结。受欲有。余残所入。欲有所入。色无色有所入。九十八使。三十六使。受欲有。三十一受色有。三十一受无色有(有门第三竟也)。身见由何三昧灭答曰。或依四或依未至。戒盗疑或依四或依未至。贪欲嗔恚愚痴及欲漏依未至。有漏无明漏或依七或依未至。流中欲流依未至。有流无明流或依七或依未至。见流或依四或依未至。扼亦如是。受中欲受依未至。戒受见受或依四或依未至。我受或依七或依未至。缚中欲爱身缚嗔恚身缚依未至。戒盗身缚我见身缚。或依四或依未至。盖及嗔恚悭结嫉结依未至(禅六事中一也)。余残或依七(四禅三空也)。或依未至。下分中贪欲嗔恚依未至。余残及见或依四或依未至。爱身中鼻舌更爱依未至。眼耳身更爱或依初或依未至。意更爱或依七或依未至。使中贪欲使嗔恚使依未至。有爱使憍慢使无明使或依七或依未至。见使疑使或依四或依未至。结中嗔恚结悭结嫉结依未至。爱结憍慢结无明结。或依七或依未至。见结失愿结疑结。或依四或依未至。九十八使中欲界依未至。色界及无色界四谛所断。或依四或依未至。无色界思惟所断或依七或依未至(四门三昧也)。所有结过去已为结所系耶。答曰。如是。所有结过去已为结所系也。颇已为结所系此结不过去耶。答曰。有诸未来现在结所系。所有结未来当为结所系耶。答曰。或有未来结不当为结所系。云何未来结不当为结所系。答曰。诸未来结永尽无余。已灭已吐于彼结尽定不退。是谓未来结不当为结所系。云何当为结所系此非未来结。答曰。诸结过去永尽无余。已尽已吐于彼结尽定退。是谓当为结所系。此结非未来云何结未来当为结所系。答曰。诸未来结永尽无余。已灭已吐于彼结尽定退。是谓未来结当为结所系。云何非未来结亦不当为结所系。答曰。诸结过去永尽无余。已灭已吐于彼结尽定不退及现在结。是谓亦非未来结亦非当为结所系。所有结现在今为结所系耶。答曰。如是。诸现在结今为结所系也。颇今为结所系此结非现在耶。答曰。有诸过去未来结所系(结处竟也)。所可用道断欲界结。于彼道退还为结所系不为结所系。答曰。还为结所系。所可用道断色无色界结。于彼道退还为结所系不为结所系。答曰。还为结所系(道退处竟)。九断智欲界中。苦谛习谛所断结尽初断智。色无色界苦谛习谛所断结尽二断智。欲界尽谛所断结尽三断智。色无色界尽谛所断结尽四断智。欲界道谛所断结尽五断智。色无色界道谛所断结尽六断智。五下分结尽七断智。色爱尽八断智。一切结尽九断智。九断智为受入一切断智。一切断智为受入九断智。答曰。一切九。非九一切。不受入何等。答曰。见谛成就世尊弟子。欲爱未尽欲界思惟所断结尽。不受入九断智(二道不得受七断智名也)。欲爱已尽色爱未尽。色界思惟所断结尽。不受入九断智。色爱已尽无色爱未尽。无色界思惟所断结尽。不受入九断智(九断智竟也)。八人趣须陀洹证得须陀洹。趣斯陀含证得斯陀含。趣阿那含证得阿那含。趣阿罗汉证得阿罗汉。趣须陀洹证者。于此九断智成就几不成就几。答曰。或不成就或一二三四五。云何不成就。答曰。苦法忍不成就苦法智不成就。苦未知忍不成就苦未知智不成就。习法忍不成就习法智一。习未知忍习未知智二。尽法忍尽法智三。尽未知忍尽未知智四。道法忍道法智五。道未知忍得须陀洹成就六断智趣。斯陀含证者。于此九断智。成就几不成就几答曰。若倍欲尽越次取证(顿得频来故曰倍也)。或不成就。或一二三四五六。云何不成就。答曰。苦法忍不成就。苦法智不成就。苦未知忍不成就。苦未知智不成就。习法忍不成就。习法智一。习未知忍习未知智二。尽法忍尽法智三。尽未知忍尽未知智四。道法忍道法智五。道未知忍。若得须陀洹证趣斯陀含果六。得斯陀含成就六断智。趣阿那含证者。于此九断智成就几不成就几。答曰。若欲爱尽越次取证或不成就。或一二三四五六。云何不成就。答曰。苦法忍不成就。苦法智不成就。苦未知忍不成就。苦未知智不成就。习法忍不成就。习法智一。习未知忍习未知智二。尽法忍尽法智三。尽未知忍尽未知智四。道法忍道法智五。道未知忍。若得斯陀含果趣阿那含果六(通二道数也)。得阿那含成就一断智。五下分结尽断智。是趣阿罗汉证者于此九断智。成就几不成就几。答曰。或一或二色爱未尽成就一断智。五下分结尽。是色爱已尽成就二断智。五下分结尽断智。色爱尽断智得阿罗汉成就一断智。一切结尽断智

结使品一行犍度第二竟(梵本一千四十首卢秦万一千九百二十二言)

阿毗昙一(行跋渠)

阿毗昙八犍度论卷第六阿毗昙八犍度论卷第七

        迦旃延子造

        符秦罽宾三藏僧伽提婆共竺佛念译

    阿毗昙结使犍度人跋渠第三

  二种界结几果有五　　九十五结并三结种
  此门普广说于果实　　门有欲已八人当学
  三种摄身死生受有　　死而不生有欲在后

二种依身欲界二。色界二。无色界二。颇有欲界结一时得系耶。一时得不系耶。渐得系渐不得系。颇色界结一时得系。一时得不系。渐得系渐不得系。颇无色界结一时得系。一时不得系。渐得系渐不得系耶。欲界见谛所断结尽为何果摄。欲界思惟所断。色界见谛所断。色界思惟所断。无色界见谛所断。无色界思惟所断结尽。为何果所摄。五结种苦谛所断结种。习谛尽谛道谛思惟所断结种。苦谛所断结种断为何果摄习谛尽谛道谛思惟所断结种断为何果摄。九结种苦法智所断结种。苦未知智所断。习法智所断习未知智所断。尽法智所断尽未知智所断。道法智所断。道未知智所断。思惟所断结种。苦法智所断结种尽。为何果摄。苦未知智所断。习法智所断习未知智所断。尽法智所断尽未知智所断。道法智所断道未知智所断。思惟所断结种尽。为何果摄。十五结种欲界苦谛所断结种。欲界习尽道谛思惟所断结种。色界苦谛所断结种。色界习尽道谛思惟所断结种。无色界苦谛所断结种。无色界习尽道谛思惟所断结种。欲界苦谛所断结种尽。为何果摄。欲界习尽道谛思惟所断结种尽。为何果摄。色界苦谛所断结种尽。为何果摄。色界习尽道谛思惟所断结种尽。为何果摄。无色界苦谛所断结种尽。为何果摄。无色界习尽道谛思惟所断结种尽。为何果摄。身见尽。为何果摄。戒盗疑乃至无色界思惟所断无明使尽。为何果摄。见谛成就世尊弟子。欲爱未尽欲界思惟所断结尽。为何果摄。欲爱已尽色爱未尽。色界思惟所断结尽为何果摄。色爱已尽无色爱未尽。无色界思惟所断结尽。为何果摄。八人趣须陀洹证得须陀洹。趣斯陀含证得斯陀含。趣阿那含证得阿那含。趣阿罗汉证得阿罗汉。趣须陀洹证结尽。为何果摄。得须陀洹乃至趣阿罗汉证得阿罗汉结尽。为何果摄。诸学法成就须陀洹。须陀洹摄彼法耶。若诸法须陀洹所摄是学法耶。斯陀含阿那含亦复如是。诸无学法成就阿罗汉。阿罗汉摄彼法耶。若阿罗汉摄彼法是无学法耶。诸须陀洹成就无漏法须陀洹果摄彼法耶。若须陀洹果摄彼法者。是无漏法耶。斯陀含阿那含阿罗汉亦复如是。诸法成就须陀洹是须陀洹果摄彼法耶。若须陀洹果摄彼法者。须陀洹成就彼法耶。斯陀含阿那含阿罗汉亦复如是。从欲界没还生欲界。尽受欲界有耶。若受欲界有尽欲界没还生欲界耶。从色界没还生色界。尽受色界有耶。设受色界有尽色界没还生色界耶。从无色界没还生无色界尽受无色界有耶。设受无色界有尽无色界没还生无色界耶从欲界没还生欲界。此人有几。几使所使。为几结系。从色界没还生色界。此人有几。几使所使。为几结系。从无色界没生无色界。此人有几。几使所使。为几结系。若不从欲界没不生欲界。尽不受欲界有耶。若不受欲界有尽不欲界没不生欲界耶。不色界没不生色界。尽不受色界有耶。若不受色界有尽不色界没不生色界耶。不无色界没不生无色界。尽不受无色界有耶。若不受无色界有。尽不无色界没不生无色界耶。若不欲界没不生欲界。此人有几。几使所使为几结系。不色界没不生色界。此人有几。几使所使。为几结系。不无色界没不生无色界。此人有几。几使所使。为几结系。颇欲界没不生欲界耶。颇欲界没不生色无色界耶。颇色界没不生色界耶。颇色界没不生欲界无色界耶。颇无色界没不生无色界耶。颇无色界没不生欲界色界耶。若欲界没不生欲界此人有几。几使所使。为几结系。若欲界没不生色无色界此人有几。几使所使。为几结系。若色界没不生色界此人有几。几使所使。为几结系。若色界没不生欲界无色界此人有几。几使所使。为几结系。若无色界没不生无色界此人有几。几使所使。为几结系。颇欲界没不生欲界色无色界耶。颇色界没不生欲界色无色界。颇无色界没不生欲界色无色界耶。若欲界没不生欲界色无色界此人有几。几使所使。为几结系。若色界没不生欲界色无色界此人有几。几使所使。为几结系。若无色界没不生欲界色无色界此人有几。几使所使。为几结系。颇欲爱未尽命终不生欲界。颇色爱未尽命终不生欲界色界。颇无色爱未尽命终不生欲界色界无色界。若欲爱未尽命终不生欲界此人有几。几使所使为几结系。若色爱未尽命终。不生欲界色界此人有几。几使所使为几结系。若无色爱未尽。命终不生欲界色无色界此人有几。几使所使。为几结系。此章义愿具演说

二种欲界二种色界二种无色界。四谛所断结种。思惟所断结种。颇欲界结一时可系耶。答曰。得凡夫人欲界无爱。退从色无色界没生欲界也。一时不可系耶。答曰。得凡夫人得欲界无爱。渐可系耶。答曰。不得。渐得不系耶。答曰得。世尊弟子先灭四谛所断结。后思惟所断也。颇色界结一时可系耶。答曰得。凡夫人从色无爱退从上地没。生欲界若梵天上。一时得不系耶。答曰得。凡夫人得色无爱渐得可系耶。答曰。不得。渐得不系耶。答曰得。世尊弟子先灭四谛所断结后思惟也。颇无色界结一时可系耶。答曰。不得。一时得不系耶。答曰。不得。渐得系耶。答曰。不得。渐得不系耶。答曰得。世尊第子先灭四谛所断结后思惟也(二种界竟)

欲界四谛所断结尽为何果摄。答曰。四沙门果。或无处所。欲界思惟所断或阿那含果阿罗汉。或无处所。色界四谛所断四沙门果。或无处所。色界思惟所断或阿罗汉。或无处所。无色界四谛所断四沙门果。思惟所断阿罗汉。五结种苦谛所断结种习谛尽谛道谛思惟所断结种。苦谛所断结种尽为何果摄。答曰。四沙门果。或无处所。习谛尽谛所断四沙门果。或无处所。道谛所断四沙门果。思惟所断阿罗汉(五种竟)。九结种。苦法智所断结种苦未知智所断。习法智所断习未知智所断。尽法智所断尽未知智所断。道法智所断道未知智所断。思惟所断结种。苦法智所断结种尽为何果摄。答曰。四沙门果或无处所(未入道果也)

苦未知智所断。习法智所断习未知智所断。尽法智所断尽未知智所断。道法智所断四沙门果。或无处所。道未知智所断四沙门果。思惟所断阿罗汉(九种门竟)。十五结种。欲界苦谛所断结种。欲界习谛尽谛道谛思惟所断结种。色界苦谛所断结种。色界习尽道谛思惟所断结种。无色界苦谛所断结种。无色界习尽道谛思惟所断结种。欲界苦谛所断结种。尽为何果摄。答曰。四沙门果。或无处所。欲界习谛尽道谛所断四沙门果。或无处所。欲界思惟所断阿那含果阿罗汉。或无处所。色界苦谛所断四沙门果。或无处所。色界习尽道谛所断。四沙门果。或无处所。色界思惟所断阿罗汉。或无处所。无色界苦谛所断四沙门果。或无处所。无色界习尽谛所断四沙门果。或无处所。无色界道谛所断四沙门果。无色界思惟所断阿罗汉(十五种竟)。身见尽为何果摄。答曰。四沙门果。或无处所。戒盗疑四沙门果。贪嗔恚愚痴及欲漏或阿那含果阿罗汉。或无处所。有漏无明漏阿罗汉。流中欲流阿那含果阿罗汉。或无处所。有流无明流阿罗汉。见流四沙门果。扼亦如是。受中欲受阿那含果阿罗汉果。或无处所。戒受见受四沙门果。我受阿罗汉果。缚中贪欲身缚嗔恚身缚阿那含果阿罗汉果。或无处所。戒盗身缚我见身缚四沙门果。盖中贪欲嗔恚睡眠。调戏阿那含果阿罗汉果。或无处所。疑盖四沙门果。或无处所。结中嗔恚结悭结嫉结阿那含果阿罗汉果。或无处所。爱结憍慢结阿罗汉果。下分中贪欲嗔恚阿那含果阿罗汉果。或无处所。身见四沙门果或无处所。戒盗疑四沙门果。见中身见边见四沙门果。或无处所。邪见见盗戒盗四沙门果。爱身中鼻更舌更爱阿那含果阿罗汉果。或无处所。眼耳身更爱阿罗汉。或无处所。意更爱阿罗汉果。使中贪欲使嗔恚使阿那含果阿罗汉果。或无处所。有爱使憍慢使无明使阿罗汉果。见使疑使四沙门果。结中嗔恚结悭结嫉结阿那含果阿罗汉果。或无处所。爱憍慢无明结阿罗汉果。见失愿疑结四沙门果。九十八使欲界苦习尽道谛所断四沙门果。或无处所。欲界思惟所断阿那含果阿罗汉。或无处所。(二道门无处)。色界苦习尽道谛所断四沙门果。或无处所。色界思惟所断阿罗汉果。或无处所。无色界苦习尽谛所断四沙门果。或无处所。无色界道谛所断四沙门果。无色界思惟所断阿罗汉果(相摄门竟)。见谛成就世尊弟子。欲爱未尽欲界思惟所断结尽。为何果摄。答曰。斯陀含果。或无处所。欲爱已尽色爱未尽。色界思惟所断结尽。为何果摄。答曰。无处所。色爱已尽无色爱未尽。无色界思惟所断尽。为何果摄。答曰。无处所(无欲门竟)。八人趣须陀洹证得须陀洹。趣斯陀含证得斯陀含。趣阿那含证得阿那含。趣阿罗汉证得阿罗汉。趣得须陀洹证者结尽。为何果摄。答曰。无处所。得须陀洹即须陀洹。趣斯陀含证结尽。为何果摄。答曰。须陀洹果。或无处所。得斯陀含即斯陀含。趣阿那含证结尽。为何果摄。答曰。斯陀含果。或无处所。得阿那含即阿那含。趣阿罗汉证结尽。为何果摄。答曰。阿那含果。或无处所。得阿罗汉即阿罗汉(八人竟)。诸学法成就须陀洹。此法须陀洹果所摄耶。答曰。或摄或不摄。云何摄。答曰。有为须陀洹果得而不失。是谓摄。云何不摄。答曰。须陀洹增益进得众妙无漏根。得已结尽逮证是谓不摄。设诸法须陀洹果所摄彼是学法耶。答曰。或学或非学非无学。云何学。答曰。有为须陀洹果是谓学。云何非学非无学。答曰。无为须陀洹果。是谓非学非无学。斯陀含阿那含亦复如是。诸无学法成就阿罗汉。阿罗汉摄彼法耶。答曰。如是。设阿罗汉摄法。彼是无学法耶。答曰。或彼无学或非学非无学。云何无学。答曰。有为阿罗汉是谓无学。云何非学非无学。答曰。无为阿罗汉。是谓非学非无学。诸无漏法成就须陀洹。彼法须陀洹所摄耶。答曰。或摄或不摄。云何摄。答曰。得须陀洹果不失。是谓摄。云何不摄。答曰。须陀洹增益进得无漏微妙根。得已结尽受证。亦非数缘尽成就须陀洹。是谓不摄。设诸法须陀洹所摄是无漏法耶。答曰。如是。斯陀含阿那含亦复如是。诸无漏法成就阿罗汉。彼法阿罗汉所摄耶。答曰。或摄或不摄。云何摄。答曰。得阿罗汉果不失是谓摄。云何不摄。答曰。非数缘尽成就阿罗汉。是谓不摄。设诸法阿罗汉所摄彼法是无漏耶。答曰。如是。诸法成就须陀洹。彼法须陀洹所摄耶。答曰。或有法成就须陀洹。彼法非须陀洹果所摄。云何诸法成就须陀洹。彼法非须陀洹果所摄。答曰。须陀洹增益进得无漏微妙根。得已结尽受证亦诸非数缘尽。成就须陀洹有漏法成就须陀洹。是谓诸法成就须陀洹。此法非须陀洹果所摄。云何诸法须陀洹果所摄。此法不成就须陀洹。答曰。未得须陀洹果得已便失。是谓诸法须陀洹果所摄。此诸法不成就须陀洹。云何诸法成就须陀洹。是须陀洹果所摄法。答曰。得须陀洹果不失。是谓诸法成就须陀洹。是须陀洹果所摄法。云何诸法不成就须陀洹。非须陀洹果所摄法。答曰。除上尔所事。斯陀含阿那含亦复如是。诸法成就阿罗汉。是阿罗汉所摄法耶。答曰。或有诸法成就阿罗汉。此法非阿罗汉所摄。云何诸法成就阿罗汉。此法非阿罗汉法所摄。答曰。亦非数缘尽成就阿罗汉及有漏法。成就阿罗汉。是谓诸法成就阿罗汉。此法非阿罗汉所摄。云何诸法阿罗汉所摄。此法不成就阿罗汉。答曰。若未得阿罗汉得已便失。是谓诸法阿罗汉所摄。此法不成就阿罗汉。云何诸法成就阿罗汉。是阿罗汉所摄法。答曰。得阿罗汉不失。是谓诸法成就阿罗汉。是阿罗汉所摄法。云何诸法不成就阿罗汉。此法亦非阿罗汉所摄。答曰。除上尔所事(第二摄门竟)。从欲界没还生欲界。尽受欲界有耶。答曰。或从欲界没还生欲界不受欲界有。云何从欲界没还生欲界不受欲界有。答曰。欲界没而办色界中阴。是谓欲界没还生欲界不受欲界有也。云何受欲界有非欲界没不生欲界。答曰。若色界没而办欲界中阴。是谓受欲界有非欲界没不生欲界。云何欲界没还生欲界受欲界有。答曰。从欲界没而办欲界中阴生阴。是谓从欲界没还生欲界受欲界有。云何不欲界没不生欲界不受欲界有。答曰。从色界没而办色界中阴生阴。从色界没生无色界。无色界没生无色界。从无色界没生色界。是谓不欲界没不生欲界不受欲界有。从色界没还生色界。尽受色界有乎。答曰。或色界没还生色界不受色界有。云何色界没还生色界不受色界有。答曰。从色界没而办欲界中阴。是谓从色界没还生色界不受色界有。云何受色界有不色界没不生色界。答曰。从欲界没而办色界中阴。是谓受色界有不色界没不生色界。云何从色界没还生色界受色界有。答曰。从色界没办色界中阴生阴。是谓色界没还生色界受色界有。云何不色界没不生色界不受色界有。答曰。从欲界没办欲界中阴生阴。从欲界没生无色界。无色界没生无色界。无色界没生欲界。是谓不色界没不生色界不受色界有。无色界没生无色界。尽受无色界有耶。答曰。如是无色界没生无色界。尽受无色界有。颇有受无色界有不无色界没生无色界耶。答曰有。若欲色界。没生无色界。从欲界没还生欲界。此人有四。欲界凡夫圣人色界凡夫圣人。从色界没还生色界。此人有三。欲界凡夫。色界凡夫圣人。无色界没还生无色界。此人有二。无色界凡夫圣人。欲界凡夫人九十八使所使。九结所系。贤圣人十使所使。六结所系。色界凡夫人六十二使所使。六结所系。贤圣人六使所使。三结所系。无色界凡夫人三十一使所使。六结所系。贤圣人三使所使。三结所系(死生处竟)。若不欲界没不生欲界。尽不受欲界有耶。答曰。或有不欲界没不生欲界。非不受欲界有。云何不欲界没不生欲界非不受欲界有耶。答曰。从色界没办欲界中阴。是谓不欲界没不生欲界。非不受欲界有。云何不受欲界有非不欲界没非不欲界生。答曰。从欲界没办色界中阴。是谓不受欲界有非不欲界没非不欲界生。云何不欲界没不生欲界不受欲界有。答曰。从色界没办色界中阴生阴。从色界没生无色界。无色界没生无色界。无色界没生色界。是谓不欲界没不生欲界不受欲界有。云何非不欲界没非不欲界生非不受欲界有。答曰。从欲界没办欲界中阴生阴。是谓非不欲界没非不生欲界非不受欲界有。不色界没不生色界尽不受色界有耶。答曰。或不色界没不生色界非不受色界有。云何不色界没不生色界非不受色界有耶。答曰。从欲界没办色界中阴。是谓不色界没不生色界非不受色界有。云何不受色界有非不色界没非不生色界。答曰。从色界没办欲界中阴。是谓不受色界有非不色界没非不生色界。云何不色界没不生色界不受色界有。答曰。从欲界没办欲界中阴生阴。从欲界没生无色界。无色界没生无色界。无色界没生欲界。是谓不色界没不生色界不受色界有。云何非不色界没非不生色界非不受色界有。答曰。从色界没办色界中阴生阴。是谓非不色界没非不生色界非不受色界有。不无色界没不生无色界尽不受无色界有耶。答曰。如是。不无色界没不生无色界尽不受无色界有。颇有不受无色界有非不无色界没不生无色界耶。答曰。有无色界没生欲界色界。非欲界没不生欲界。此人有五。欲界凡夫。色界凡夫圣人。无色界凡夫圣人。不色界没不生色界。此人有六。欲界凡夫圣人。色界凡夫圣人。无色界凡夫圣人。不无色界没不生无色界。此人有四。欲界凡夫圣人。色界凡夫圣人。向使所使向结所系(不生不死处竟)。颇欲界命终不生欲界耶。答曰。不生。办欲界中阴。办色界中阴生阴。生无色界而般涅槃。颇欲界命终不生色界耶。答曰。不生。办色界中阴办欲界中阴。生无色界而般涅槃。颇欲界命终不生无色界耶。答曰。不生。办欲色界中阴生阴。若般涅槃。颇色界命终不生色界耶。答曰。不生。办色界中阴办欲界中阴生阴。生无色界而般涅槃。颇色界命终不生欲界耶。答曰。不生。办欲界中阴办色界中阴生阴。生无色界而般涅槃。颇色界命终不生无色界耶。答曰。不生。办欲色界中阴生阴而般涅槃。颇无色界命终不生无色界耶。答曰。不生。办欲色界中阴生阴若般涅槃。颇无色界命终不生欲界耶。答曰不生。办欲界中阴办色界中阴生阴。生无色界而般涅槃。颇无色界命终不生色界耶。答曰。不生。办色界中阴办欲界中阴生阴。生无色界而般涅槃。若欲界命终不生欲界。此人有六。欲界凡夫圣人。色界凡夫圣人。无色界凡夫圣人。若欲界命终不生色界。此人有六。欲界凡夫圣人。色界凡夫圣人。无色界凡夫圣人。若欲界命终不生无色界。此人有四。欲界凡夫圣人。色界凡夫圣人。色界命终不生色界。此人有五。欲界凡夫色界凡夫圣人。无色界凡夫圣人。色界命终不生欲界。此人有五。欲界凡夫。色界凡夫圣人。无色界凡夫圣人。色界命终不生无色界。此人有三。欲界凡夫。色界凡夫圣人。无色界命终不生无色界。此人有二。欲界凡夫色界凡夫。无色界命终不生欲界。此人有四。欲界凡夫。色界凡夫。无色界凡夫圣人。无色界命终不生色界。此人有四。欲界凡夫。色界凡夫。无色界凡夫圣人。向使所使向结所系(不生处竟)。颇欲界命终不生欲界色界无色界。答曰。不生。办欲色界中阴若般涅槃。颇色界命终不生欲界色无色界。答曰。不生。办欲界色界中阴若般涅槃。颇无色界命终不生欲界色无色界。答曰。不生。办欲色界中阴若般涅槃。若欲界命终不生欲界色界无色界。此人有四。欲界凡夫圣人。色界凡夫圣人。若色界命终不生欲界色界无色界。此人有三。欲界凡夫。色界凡夫圣人。无色界命终不生欲界色无色界。此人有二。欲界凡夫。色界凡夫。向使所使向结所系(第三不生处竟)。颇欲爱未尽命终不生欲界。答曰。不生。办欲界中阴。颇色爱未尽命终不生欲色界。答曰不生。办欲色界中阴。颇无色爱未尽命终不生欲色无色界。答曰。不生。办欲色界中阴。若欲爱未尽命终不生欲界。此人有二。欲界凡夫圣人。若色爱未尽命终不生欲色界。此人有四。欲界凡夫圣人。色界凡夫圣人。若无色爱未尽命终不生欲界色无色界。此人有四。欲界凡夫圣人。色界凡夫圣人。欲界凡夫人。九十八使所使。九结所系。圣人十使所使六结所系。色界凡夫。六十二使所使六结所系。圣人六使所使三结所系。无色界凡夫人。三十一使所使六结所系。圣人三使所使。三结所系

阿毗昙人跋渠第三竟(梵本四百六十七首卢秦六千一百五十三言)

阿毗昙八犍度论卷第七阿毗昙八犍度论卷第八

        迦旃延子造

        符秦罽宾三藏僧伽提婆共竺佛念译

    阿毗昙结使犍度十门跋渠第四

  几使所使　　并及二缘　　次第有觉
  相应诸根　　亦成就根　　若不成就
  断智作证　　十门普周

二十二根。十八持。十二入。五阴五盛阴。六大色法无色法。可见法不可见法。有对法无对法有漏法无漏法。有为法无为法。过去法未来法现在法。善法不善法无记法。欲界系法色界系法无色界系法。学法无学法非学非无学法。见谛所断法思惟所断法无断法。四谛四禅四等四无色。八解脱八除入十一切入。八智三三昧三结三不善根三有漏。四流四扼四受四缚。五盖五结五下分结五见。六身爱七使九结九十八使。眼根几使所使。乃至无色界思惟所断无明使几使所使(一门)。眼根缘缘识几使所使。至无色界思惟所断无明使缘缘识几使所使(二门)。眼根缘缘识几使所使。至无色界思惟所断无明使缘缘识几使所使(三门)。意根次第有几心生。至无色界思惟所断无明使次第有几心生(四门)。眼根诸使所使此使。当言有觉有观无觉有观无觉无观耶至无色界思惟所断无明使诸使。所使此使当言有觉有观无觉有观无觉无观耶(五门)。眼根诸使所使。此使几根相应。至无色界思惟所断无明使诸使所使。此使几根相应(六门)。谁成就眼根乃至谁成就无色界思惟所断无明使(七门)。谁不成就眼根乃至谁不成就无色界思惟所断无明使(八门)。眼根断智时几使几结断智。乃至无色界思惟所断无明使。断智时几使几结断智(九门)。眼根尽作证时。几使几结尽作证耶。至无色界思惟所断无明使尽作证时。几使几结尽作证(十门)。此章义愿具演说。眼根几使所使。欲界色界通一切。及思惟所断。耳鼻舌身根亦复如是。意根一切。男根女根欲界通一切及思惟所断。命根三界通一切。及思惟所断。乐根色界一切。欲界通一切及思惟所断。苦根欲界通一切及思惟所断。喜根色界一切。欲界一切。除欲界疑无漏缘及彼相应无明。忧根欲界一切。护根一切。信根精进根念根定根慧根。三界通一切及思惟所断。未知根已知根无知根无有眼持耳鼻舌身持。色持声持细滑持。眼识耳识身识持。欲色界通。一切及思惟所断。香持味持鼻识持舌识持。欲界通一切及思惟所断。意持法持意识持一切。眼入耳鼻舌身入。色声细滑入欲色界通一切及思惟所断。香味入欲界通一切及思惟所断。意入法入一切。色阴欲色界通一切及思惟所断。痛想行识阴一切。色盛阴欲色界通一切及思惟所断。痛想行识盛阴一切地种。乃至空种。欲色界通一切及思惟所断。识种一切。色法欲色界通一切及思惟所断。无色法一切。可见法有对法。欲色界通一切及思惟所断。不可见法无对法一切。有漏法一切。无漏法无有。有为法一切。无为法无有。过去未来现在法一切。善法三界通一切及思惟所断。不善法欲界一切无记法色无色界一切。及欲界二种欲界习谛所断通一切。欲界系法欲界系一切。色界系法色界系一切。无色界系法无色界系一切。学法无学法无有。非学非无学法一切。见谛所断法见谛所断一切。思惟所断法思惟所断一切及通一切。无断法无有。苦谛习谛一切。尽谛道谛无有。禅中色界一切。四等色界通一切及思惟所断。无色中无色界一切。初第二第三解脱八除入八一切入。色界通一切及思惟所断。余残解脱一切入无色界通一切及思惟所断。法智未知智无有。知他人心智色界通一切及思惟所断。等智一切。除见相应无漏缘。苦智习智尽智道智空无相无愿无有。结中身见苦谛所断一切。及习谛所断通一切。戒盗苦谛所断一切。及习谛所断(诸云一切四谛思惟)通一切。道谛所断有漏缘疑。见谛所断有漏缘及疑相应无明。无漏缘不善根中。贪嗔恚欲界有漏缘愚痴欲界一切。除欲界无明无漏缘。漏中欲漏欲界一切有漏。色无色界一切无明漏一切。除无明无漏缘。流中欲流欲界一切。有流色无色界一切。无明流一切。除无明无漏缘。见流见谛所断有漏缘。及见相应无明无漏缘。轭亦如是。受中欲受欲界一切。戒受苦谛所断一切。及习谛所断通一切。道谛所断有漏缘。见受见谛所断有漏缘。及见相应无明无漏缘。我受色无色界一切。缚中欲爱身缚嗔恚身缚。欲界有漏缘戒盗身缚苦谛所断一切。及习谛所断通一切。道谛所断有漏缘我见身缚。见谛所断有漏缘。盖中贪欲嗔恚。欲界有漏缘睡眠调欲界一切。戏欲界通一切及思惟所断。疑盖欲界见谛所断有漏缘。及欲界疑相应无明无漏缘。结中嗔恚结欲界有漏缘。爱结憍慢结三界有漏缘。悭结嫉结欲界通一切及思惟所断。下分结中贪欲嗔恚欲界有漏缘。身见苦谛所断一切。及习谛所断通一切。戒盗苦谛所断一切。及习谛所断通一切。道谛所断有漏缘。疑见谛所断有漏缘。及疑相应无明无漏缘。见中身见边见苦谛所断一切。及习谛所断通一切。邪见见谛所断有漏缘。及邪见相应无明无漏缘。见盗见谛所断有漏缘。戒盗苦谛所断一切。及习谛所断通一切。道谛所断有漏缘。爱身中鼻舌更爱欲界通一切及思惟所断。眼耳身更爱欲色界通一切及思惟所断。意更爱三界有漏缘。使中贪欲使嗔恚使欲界有漏缘。有爱使色无色界有漏缘。憍慢使三界有漏缘。无明使一切。除无明无漏缘。见使见谛所断有漏缘。及见相应无明无漏缘。疑使见谛所断有漏缘。及疑相应无明无漏缘。结中嗔恚结欲界有漏缘。爱结憍慢结三界有漏缘。无明结一切。除无明无漏缘。见结见谛所断有漏缘。及见相应无明无漏缘。失愿结见谛所断有漏缘。疑结见谛所断有漏缘。及疑相应无明无漏缘。悭结嫉结欲界通一切及思惟所断。九十八使欲界苦谛所断。欲界苦谛所断一切及欲界习谛所断通一切。欲界习谛所断。欲界习谛所断一切。及欲界苦谛所断通一切。欲界尽谛所断欲界尽谛所断一切。及欲界通一切。欲界道谛所断欲界道谛所断一切。及欲界通一切欲界思惟所断欲界思惟所断。一切及欲界通一切。色无色界亦复如是(使门竟)

眼根缘识几使所使。答曰。欲色界三种。无色界通一切及思惟所断。缘缘识(合解二门)。四种(四谛除尽中并思惟)。耳鼻舌身根亦复如是。意根缘识有为缘缘缘识有为缘。男根女根缘识欲界三种(苦习思惟)。色界通一切。及思惟所断。缘缘识欲界四种。色界三种。无色界通一切。及思惟所断。命根缘识三界三种缘缘识四种。乐根缘识欲界四种。色界有为缘无色界二种及通一切。缘缘识欲界无色界四种。色界有为缘。苦根缘识欲界三种。色界通一切及思惟所断。缘缘识欲界四种。色界三种。无色界通一切及思惟所断。喜根缘识欲色界有为缘。无色界二种。及通一切缘缘识欲色界有为缘无色界四种。忧根缘识欲界有漏缘。色界通一切及思惟所断。缘缘识欲界有为缘。色界三种无色界通一切及思惟所断。护根缘识有为缘缘缘识有为缘。信精进念定慧根缘识四种缘缘识四种。未知根已知根无知根缘识二种及通一切缘缘识四种。眼持耳鼻舌身持。色持声细滑持缘识欲色界三种无色界通一切及思惟所断。缘缘识四种。眼识耳识身识持缘识欲色界三种。缘缘识欲色界四种。无色界二种及通一切。香持味持鼻识舌识持缘识。欲界三种色界通一切及思惟所断。缘缘识欲界四种色界三种无色界通一切及思惟所断。意持意识持缘识有为缘。缘缘识有为缘。法持缘识一切缘缘识有为缘。眼入耳鼻舌身入。色声细滑入。缘识欲色界三种。无色界通一切及思惟所断。缘缘识四种。香入味入缘识欲界三种色界通一切及思惟所断。缘缘识欲界四种色界三种。无色界通一切及思惟所断。意入缘识有为缘。缘缘识有为缘。法入缘识一切缘缘识有为缘色阴缘识欲色界四种无色界二种。及通一切缘缘识四种。痛想行识阴缘识有为缘缘缘识有为缘色盛阴缘识欲色界三种。无色界通一切及思惟所断。缘缘识四种。痛想行识盛阴缘识有漏缘。缘缘识有为缘。地种乃至空种缘识欲色界三种。无色界通一切及思惟所断。缘缘识四种。识种缘识有漏缘。缘缘识有为缘。色法缘识欲界色界四种。无色界二种及通一切。缘缘识四种。无色法缘识一切。缘缘识有为缘。可见法有对法缘识欲色界三种。无色界通一切及思惟所断。缘缘识四种。不可见法无对法缘识一切(四谛思惟通三界也)。缘缘识有为缘。有漏法缘识有漏缘。缘缘识有为缘。无漏法缘识三种(尽道思惟)。及通一切。缘缘识有为缘。有为法缘识有为缘。缘缘识亦有为缘。无为法缘识二种及通一切(思惟尽也)。缘缘识有为缘。过去未来现在法缘识有为缘。缘缘识有为缘。善法缘识一切。缘缘识有为缘。不善法缘识欲界有漏缘。色界通一切及思惟所断。缘缘识欲界有为缘。色界三种。无色界通一切及思惟所断。无记法缘识欲界三种。色无色界有漏缘。缘缘识欲界四种。色无色界有为缘。欲界系法缘识欲界有漏缘。色界通一切及思惟所断。缘缘识欲界有为缘色界三种。无色界通一切及思惟所断。色界系法缘识欲界三种。色界有漏缘。无色界通一切及思惟所断。缘缘识欲界三种。色界有为缘无色界四种。无色界系法缘识欲色界三种。无色界有漏缘。缘缘识欲界三种色界四种。无色界有为缘。学法无学法缘识二种及通一切。缘缘识四种。非学非无学法缘识四种道谛所断有漏缘。缘缘识有为缘。见谛所断法缘识有漏缘。缘缘识有为缘。思惟所断法缘识三界三种。缘缘识四种。无断灭法缘识三种及通一切。缘缘识有为缘。苦习谛缘识有漏缘。缘缘识有为缘。尽谛缘识二种(尽谛思惟)及通一切。缘缘识有为缘。道谛缘识二种及通一切。缘缘识四种。禅缘识欲界四种。色界有为缘。无色界二种及通一切。缘缘识欲界无色界四种。色界有为缘。四等中慈悲护缘识欲色界三种。无色界通一切及思惟所断。缘缘识欲界三种。色无色界四种。净解脱后四除入八一切入亦复如是。喜缘识欲色界三种。缘缘识欲界三种。色界四种。无色界二种及通一切。初第二解脱初四除入亦复如是。无色中空处识处不用处缘识欲界三种。色界四种。无色界有为缘。缘缘识欲界三种。色界四种。无色界有为缘。有想无想处缘识欲色界三种。无色界有漏缘。缘缘识欲界三种。色界四种。无色界有为缘。解脱中空处解脱识处解脱不用处解脱。缘识欲界三种。色无色界四种。缘缘识欲界三种。色无色界四种。有想无想处解脱。及灭尽解脱缘识。三界三种。缘缘识欲界三种。色无色界四种。空处入识处入亦复如是(无色有色治同)。法智缘识欲界二种。欲界通一切。色界通一切及思惟所断。缘缘识欲界四种。色界三种。无色界通一切及思惟所断。未知智缘识色无色界二种。及色无色界通一切。欲界通一切及思惟所断。缘缘识欲界三种。色无色界四种。知他人心智缘识欲色界四种。无色界二种及通一切。缘缘识四种。等智缘识有漏缘。缘缘识有为缘。苦智习智尽智道智空无愿无相。缘识二种及通一切。缘缘识四种。结中身见缘识三界三种。缘缘识四种。戒盗缘识三界三种。及道谛所断。有漏缘缘缘识四种。疑缘识有漏缘。缘缘识有为缘。贪嗔恚愚痴及欲漏。缘识欲界有漏缘。色界通一切及思惟所断。缘缘识欲界有为缘。色界三种无色界通一切及思惟所断。有漏缘识欲界三种。色无色界有漏缘。缘缘识欲界三种。色无色界有为缘。无明漏缘识有漏缘。缘缘识有为缘。流中欲流缘识欲界有漏缘。色界通一切及思惟所断。缘缘识欲界有为缘。色界三种。无色界通一切及思惟所断。有流缘识欲界三种色无色界有漏缘。缘缘识欲界三种。色无色界有为缘。余残缘识有漏缘。缘缘识有为缘。扼亦如是。受中欲受缘识欲界有漏缘。色界通一切及思惟所断。缘缘识欲界有为缘。色界三种。无色界通一切及思惟所断。戒受缘识三界三种。及道谛所断有漏缘。缘缘识四种。见受缘识有漏缘。缘缘识有为缘。我受缘识欲界三种。色无色界有漏缘。缘缘识欲界三种。色无色界有为缘。缚中欲爱身缚嗔恚身缚。缘识欲界有漏缘。色界通一切及思惟所断。缘缘识欲界有为缘。色界三种。无色界通一切及思惟所断。戒盗身缚缘识三界三种。及道谛所断有漏缘。缘缘识四种。我见身缚缘识有漏缘。缘缘识有为缘。盖中贪欲嗔恚睡眠调戏缘识欲界有漏缘。色界通一切及思惟所断。缘缘识欲界有为缘。色界三种。无色界通一切及思惟所断。缘缘识欲界三种。色界通一切及思惟所断。缘缘识欲界四种。色界三种。无色界通一切及思惟所断。结中嗔恚结缘识欲界有漏缘。色界通一切及思惟所断。缘缘识欲界有为缘。色界三种。无色界通一切及思惟所断。悭嫉结缘识欲界三种。色界通一切及思惟所断。缘缘识欲界四种。色界三种。无色界通一切及思惟所断。余残缘识有漏缘。缘缘识有为缘。下分中贪欲嗔恚缘识欲界有漏缘。色界通一切及思惟所断。缘缘识欲界有为缘。色界三种。无色界通一切及思惟所断。身见缘识三界三种。缘缘识四种。戒盗缘识三界三种。及道谛所断有漏缘。缘缘识四种。疑缘识有漏缘。缘缘识有为缘。见中身见边见缘识三界三种。缘缘识四种。戒盗缘识三界三种。及道谛所断有漏缘。缘缘识四种。余残缘识有漏缘。缘缘识有为缘。爱身中鼻舌更爱缘识欲界三种。色界通一切及思惟所断。缘缘识欲界四种。色界三种。无色界通一切及思惟所断。眼耳身更爱。缘识欲色界三种。缘缘识欲色界四种。无色界二种及通一切。意更爱缘识有漏缘。缘缘识有为缘。使中贪欲嗔恚使。缘识欲界有漏缘。色界通一切及思惟所断。缘缘识欲界有为缘。色界三种。无色界通一切及思惟所断。有爱使缘识欲界三种。色无色界有漏缘。缘缘识欲界三种。色无色界有为缘。余残缘识有漏缘。缘缘识有为缘。结中嗔恚结缘识欲界有漏缘。色界通一切及思惟所断。缘缘识欲界有为缘。色界三种。无色界通一切及思惟所断。悭嫉结缘识欲界三种。色界通一切及思惟所断。缘缘识欲界四种。色界三种。无色界通一切及思惟所断。余残缘识有漏缘。缘缘识有为缘。九十八使欲界苦谛所断使。缘识欲界三种(苦习思惟)。色界通一切及思惟所断。缘缘识欲界四种。除尽色界三种。无色界通一切及思惟所断。习谛所断。思惟所断亦复如是。欲界尽谛所断使。缘识欲界三种。及欲界尽谛所断有漏缘。色界通一切及思惟所断。缘缘识欲界有为缘。色界三种。无色界通一切及思惟所断。欲界道谛所断使。缘识欲界三种。及欲界道谛所断有漏缘。色界通一切及思惟所断。缘缘识欲界四种。色界三种。无色界通一切及思惟所断。色界苦谛所断使。缘识欲色界三种。无色界通一切及思惟所断。缘缘识欲界三种。色无色界四种。习谛思惟所断亦复如是。色界尽谛所断使。缘识欲色界三种。及色界尽谛所断有漏缘。无色界通一切及思惟所断。缘缘识欲界三种。色界有为缘。无色界四种。色界道谛所断使。缘识欲色界三种。色界道谛所断有漏缘。无色界通一切及思惟所断。缘缘识欲界三种。色无色界四种。无色界苦谛所断使。缘识三界三种。缘缘识欲界三种。色无色界四种习谛思惟所断亦复如是。无色界尽谛所断使。缘识三界三种。及无色界尽谛所断有漏缘。缘缘识欲界三种。色界四种。无色界有为缘。无色界道谛所断使。缘识三界三种。及无色界道谛所断有漏缘。缘缘识欲界三种。色无色界四种(三门竟)。意根次第生十五心。乐根次第生十一心(三界五无色界一也)。喜根次第生十心(欲界五二禅五)。苦根忧根次第生五心。护根信根精进念定慧根。次第生十五心。未知根次第不生心(十五心文更无也)。已知根无知根。次第生三心。眼识耳识身识持。次第生十心(欲界五一禅五习谛思惟)。鼻识舌识持。次第生五心(欲界五)。意持法持意识持。意入法入。痛阴想行识阴。痛盛阴想行识盛阴。识种无色法。不可见法。无对法。有漏法。有为法。次第生十五心。无漏法次第生三心(三界思惟)。无为法次第不生心。过去法次第生二心(未来现在二世思惟)。未来法次第不生心。现在法善法无记法。欲界系法色无色界系法。次第生十五心。不善法次第生五心。学法无学法次第生三心。非学非无学法。见谛所断法。思惟所断法。次第生十五心。无断法次第生三心。苦谛习谛次第生十五心。尽谛次第不生心。道谛次第生三心。禅次第生十五心。四等次第生六心(欲一思惟色五也)。无色定次第生十五心。初第二解脱初四除入。次第生六心。净解脱。后四除入。八一切入。次第生五心(四色四大)。空处解脱空处入。识处解脱识处入。次第生六心(无色五色一也)。不用处解脱。有想无想解脱。次第生五心。灭尽解脱。次第不生心。法智次第生二心。未知智次第生三心。知他人心智次第生六心(色五欲一)。等智次第生十五心。苦智习尽道智。空无愿无相。次第生三心。身见戒盗疑。次第生十五心。贪嗔恚愚痴及欲漏。次第生五心。余残十五心流中欲流。次第生五心。余残十五心扼亦如是。受中欲受次第生五心。余残十五心缚中欲爱身缚嗔恚身缚。次第生五心。余残十五五盖及嗔恚悭嫉结。次第生五心。余残十五下分中贪欲嗔恚。次第生五心。余残及五见生十五心。爱身中鼻舌更爱。次第生五心。眼耳身更爱。次第生十心。意更爱次第生十五心。使中贪欲嗔恚使次第生五心。余残十五心结中嗔恚悭嫉结。次第生五心。余残十五九十八使欲界。次第生五心。色界十心。无色界十五心(仍下也次第门竟)。男根女根苦根忧根诸使所使此。使有觉有观。未知根已知根无知根无觉无观余。残根三行眼。识耳识身识持。或有觉有观。或无觉有观。香持味持鼻识舌识持。有觉有观。余残持三行。香入味入有觉有观。余残入三行。阴盛阴种色法无色法。可见法不可见法。有对法无对。法有漏法有为法。过去未来现在法。善法无记法。色界系法三行。不善法欲界系法。有觉有观。无色界系法无觉无观。学法无学法无。非学非无学法四谛思惟所断法三行。无断灭法无。苦谛习谛三行。尽谛道谛无。禅中初禅或有觉有观。或无觉有观。余残禅无觉无观。四等三行。无色定无觉无观。初二解脱初四除入三行。余残解脱除入一切入无觉无观。法智未知智无。知他人心智等智三行。苦智习尽道智空无愿无相无。身见戒盗疑三行。贪嗔恚愚痴。及欲漏有觉有观。余残三行。流中欲流有觉有观。余残三行。扼亦如是。受中欲受有觉有观。余残三行。缚中欲爱身缚嗔恚身缚有觉有观。余残三行。五盖及嗔恚悭嫉结有觉有观。余残三行。下分中贪欲嗔恚有觉有观。余残及五见三行。爱身中鼻舌更爱有觉有观。眼耳身更爱。或有觉有观。或无觉有观。意更爱三行。使中贪欲嗔恚使有觉有观。余残三行。结中嗔恚悭嫉结有觉有观。余残三行。九十八使欲界有觉有观。色界三行。无色界无觉无观(五门觉竟)。眼根诸使所使此使与四根相应除苦根。耳鼻舌身根亦复如是。意根五。男根女根三除乐根。苦根命根四除苦根。乐根四除苦根。苦根四除乐根。喜根忧根三除乐根苦根。护根信精进念定慧根四除苦根。未知根已知根无知根无使使。眼持耳鼻舌身意识持四除苦根。余残持五。眼入耳鼻舌身入四除苦根。余残入五。阴盛阴种。色法无色法。可见法不可见法。有对法无对法。有漏法有为法五。无漏法无为法无。过去未来现在法。善法不善法无记法。欲界系法五。色界系法三。除苦根忧根。无色界系法一护根。学法无学法无。非学非无学法五。四谛所断法四。思惟所断法五。无断灭法无。苦谛习谛五。尽谛道谛无。禅中初禅三除苦根忧根。二禅二喜根护根。三禅二乐根护根。四禅一护根。四等中慈悲护三除苦根忧根。喜二喜根护根。无色定一护根。初第二解脱初四除入二喜根护根。余残解脱除入一切入一护根。法智未知智无知他人心智三。除苦根忧根。等智五苦智习尽道智空无愿无相无。身见戒盗疑及贪四除苦根。嗔恚四除乐根。愚痴及欲漏无明漏五。有漏三除苦根忧根。流中欲流无明流五。有流三。除苦根忧根。见流四除苦根。扼亦如是。受中欲受五。戒受见受四除苦根。我受三除苦根忧根。缚中嗔恚身缚四除乐根。余残缚四除苦根。盖中贪欲四除苦根。嗔恚四除乐根。睡调五。眠戏疑。三除乐根苦根。结中嗔恚结四除乐根。爱结憍慢结四除苦根。悭嫉结三除乐根苦根。下分中贪欲四除苦根。嗔恚四除乐根。身见戒盗疑及五见六爱身四除苦根。使中贪欲使憍慢使见使疑使四除苦根。嗔恚使四除乐根。有爱使三除苦根忧根。无明使五。结中嗔恚结四除乐根。爱结憍慢结见结失愿结疑结四除苦根。无明结五。悭嫉结三除乐根苦根。九十八使欲界见谛所断三除乐根苦根。思惟所断爱四除苦根。嗔恚四除乐根。憍慢三除乐根苦根无明五。色界三除苦根忧根。无色界一护根(根门第六竟)。谁成就眼根。答曰。色界欲界若得不失。耳鼻舌根亦复如是。谁成就身根。答曰。欲色界。谁成就意根。答曰。一切众生。谁成就男根女根。答曰。欲界若得不失谁成就命根。答曰。一切众生。谁成就乐根。答曰。遍净天。若下遍净天。若圣人生上。谁成就苦根。答曰。欲界。谁成就喜根。答曰。光音天若下光音若圣人生上。谁成就忧根。答曰。欲爱未尽。谁成就护根。答曰。一切众生。谁成就信根精进念定慧根。答曰。不断善根。谁成就未知根已知根无知根。答曰。若得不失。谁成就眼持耳鼻舌持。答曰。色界欲界若得不失。谁成就身持色声细滑持。答曰。欲色界。谁成就眼识耳身识持。答曰。梵迦夷天若下梵迦夷。若生上而现在前。谁成就香持味持鼻识舌识持。答曰。欲界爱未尽。谁成就意持。法持意识持。答曰。一切众生。谁成就眼入耳鼻舌入。答曰。色界欲界若得不失。谁成就身入色声细滑入。答曰。欲色界。谁成就香入味入。答曰。欲界。谁成就意入法入。答曰。一切众生。谁成就色阴。答曰。欲色界。若圣人生无色界(法身)。谁成就痛想行识阴。答曰。一切众生。谁成就色盛阴。答曰。欲色界。谁成就痛想行识盛阴。答曰。一切众生。谁成就地种乃至空种。答曰。欲色界。谁成就识种。答曰。一切众生。谁成就色法。答曰。欲色界若圣人生无色界。谁成就无色法。答曰。一切众生。谁成就可见法有对法。答曰。欲色界。谁成就不可见法无对法。答曰。一切众生。谁成就有漏无漏法。有为无为法。过去未来现在法。答曰。一切众生。谁成就善法。答曰。不断善根。谁成就不善法。答曰。欲爱未尽。谁成就无记法。答曰。一切众生。谁成就欲界系法。答曰。欲色界。谁成就色界系法。答曰。欲色界。谁成就无色界系法。答曰。一切众生。谁成就学法无学法。答曰。若得不失。谁成就非学非无学法。答曰。一切众生。谁成就见谛所断法。答曰。未生道未知智。谁成就思惟所断无断灭法苦谛习谛。答曰。一切众生。谁成就尽谛。答曰。若得不失谁成就道谛。答曰。若得。禅中谁成就初禅。答曰。梵迦夷天。若下梵迦夷。若圣人生上。谁成就二禅。答曰。光音天。若下光音。若圣人生上。谁成就三禅。答曰。遍净天。若下遍净。若圣人生上。谁成就四禅。答曰。果实天。若下果实。若圣人生上。谁成就四等。答曰。若得不失。无色中谁成就空处。答曰。生空处者。若空处下。若圣人生上。谁成就识处。答曰。生识处者。若下识处。若圣人生上。谁成就不用处。答曰。生不用处者。若下不用处。若无垢人(上诸圣人皆此人也)生上。谁成就有想无想处。答曰。一切众生。谁成就解脱除入一切入。答曰。若得不失。谁成就法智未知智。答曰。若得。谁成就知他人心智。答曰。若得不失。谁成就等智。答曰。一切众生。谁成就苦智习尽道智空无愿无相。答曰。若得。结中谁成就身见。答曰。若未知智未生。谁成就戒盗疑。答曰。道未知智未生。谁成就贪欲嗔恚愚痴及欲漏。答曰。欲爱未尽。谁成就有漏无明漏。答曰。无色界爱未尽。流中谁成就欲流。答曰。欲爱未尽。谁成就有流无明流。答曰。无色界爱未尽。谁成就见流。答曰。道未知智未生。扼亦如是。受中谁成就欲受。答曰。欲爱未尽。谁成就戒受见受。答曰。道未知智未生。谁成就我受。答曰。无色界爱未尽。缚中谁成就欲爱身缚嗔恚身缚。答曰。欲爱未尽。谁成就戒盗身缚我见身缚。答曰。道未知智未生。盖中谁成就贪欲嗔恚睡眠调戏盖。答曰。欲爱未尽。谁成就疑盖。答曰。欲爱未尽。若道法智未生。结中谁成就嗔恚悭嫉结。答曰。欲爱未尽谁成就爱结憍慢结。答曰。无色界爱未尽下分中谁成就贪欲嗔恚。答曰。欲爱未尽。谁成就身见。答曰。苦未知智未生。谁成就戒盗疑。答曰。道未知智未生。见中谁成就身见边见。答曰。苦未知智未生谁成就邪见见盗戒盗。答曰。道未知智未生。爱身中谁成就鼻舌更爱。答曰。欲爱未尽。谁成就眼耳身更爱。答曰。梵天上爱未尽。谁成就竟更爱。答曰。无色界爱未尽。使中谁成就贪欲嗔恚使。答曰。欲爱未尽。谁成就有爱憍慢无明使。答曰。无色界爱未尽。谁成就见使疑使。答曰。道未知智未生。结中谁成就嗔恚悭嫉结。答曰。欲爱未尽。谁成就爱憍慢无明结。答曰。无色界爱未尽。谁成就见结失愿疑结。答曰。道未知智未生。九十八使谁成就欲界苦谛所断使。答曰。欲爱未尽。若苦法智未生谁成就欲界习谛所断使。答曰。欲爱未尽。若习法智未生。谁成就欲界尽谛所断使。答曰。欲爱未尽。若尽法智未生谁成就欲界道谛所断使。答曰。欲爱未尽若道法智未生。谁成就欲界思惟所断使。答曰。欲爱未尽。谁成就色界苦谛所断使。答曰。色爱未尽。若苦未知智未生。谁成就色界习谛所断使。答曰。色爱未尽若习未知智未生。谁成就色界尽谛所断使。答曰。色爱未尽。若尽未知智未生谁成就色界。道谛所断使。答曰。色爱未尽。若道未知智未生。谁成就色界思惟所断使。答曰。色爱未尽。谁成就无色界苦谛所断使。答曰。苦未知智未生。谁成就无色界习谛所断使。答曰。习未知智未生。谁成就无色界尽谛所断使。答曰。尽未知智未生。谁成就无色界道谛所断使。答曰。道未知智未生。谁成就无色界思惟所断使。答曰。无色界爱未尽(成就第七竟也)。谁不成就眼根。答曰。无色界欲界若未得若得便失。耳鼻舌根亦复如是。谁不成就身根。答曰。无色界意根无不成就。谁不成就男根女根。答曰。色无色界。欲界未得若得便失。命根无不成就。谁不成就乐根。答曰。凡夫人生遍净天上。谁不成就苦根。答曰。色无色界。谁不成就喜根。答曰。凡夫人生光音天上。谁不成就忧根。答曰。欲爱已尽。护根无不成就。谁不成就信精进念定慧根。答曰。善根本断。谁不成就未知根已知根无知根。答曰。若未得若得便失。谁不成就眼持耳鼻舌持。答曰。无色界。欲界若未得若得便失。谁不成就身持色声细滑持。答曰。无色界。谁不成就眼识耳识身识持。答曰。生梵天上不现在前。谁不成就香持味持鼻识舌识持。答曰。色无色界意持法持竟识持无不成就。谁不成就眼入耳鼻舌入。答曰。无色界。欲界若未得若得便失。谁不成就身入色声细滑入。答曰。无色界。谁不成就香入味入。答曰。色无色界意入法入无不成就。谁不成就色阴。答曰。凡夫人生无色界。痛想行识阴无不成就。谁不成就色盛阴。答曰。无色界。痛想行识盛阴无不成就。谁不成就地种乃至空种。答曰。无色界。识种无不成就。谁不成就色法。答曰。凡夫人生无色界。无色法无不成就。谁不成就可见法有对法。答曰。无色界。不可见法无对法无不成就。有漏无漏有为无为。过去未来现在法无不成就。谁不成就善法。答曰。善根本断。谁不成就不善法。答曰。欲爱已尽。无记法无不成就。谁不成就欲界系法。答曰。无色界。谁不成就色界。系法。答曰。无色界。无色界系法无不成就。谁不成就学无学法。答曰。若未得若得便失。非学非无学法无不成就。谁不成就见谛所断法。答曰。道未知智生。思惟所断无断灭法。苦谛习谛无不成就。谁不成就尽谛。答曰。若未得若得便失。谁不成就道谛。答曰。未得。禅中谁不成就初禅。答曰。凡夫人生梵天上。谁不成就二禅。答曰。凡夫人生光音天上。谁不成就三禅。答曰。凡夫人生遍净天上。谁不成就四禅。答曰。凡夫人生无色界(译人云经本尔)。谁不成就四等。答曰。若未得若得便失。无色中谁不成就空处。答曰。凡夫人生空处上。谁不成就识处。答曰。凡夫人生识处上。谁不成就不用处。答曰。凡夫人生不用处上。有想无想处无不成就。谁不成就解脱除入一切入。答曰。若未得若得便失。谁不成就法智未知智。答曰。未得。谁不成就知他人心智。答曰。若未得若得便失。等智无不成就谁不成就苦智习尽道智空无相无愿。答曰。未得结中谁不成就身见。答曰。苦未知智生。谁不成就戒盗疑。答曰。道未知智生。谁不成就贪嗔恚愚痴及欲漏。答曰。欲爱已尽。谁不成就有漏无明漏。答曰。无色界爱已尽。流中谁不成就欲流。答曰。欲爱已尽。谁不成就有流无明流。答曰。无色界爱已尽。谁不成就见流。答曰。道未知智生。轭亦如是。受中谁不成就欲受。答曰。欲爱已尽。谁不成就戒受见受。答曰。道未知智生。谁不成就我受。答曰。无色界爱已尽。缚中谁不成就欲爱身缚嗔恚身缚。答曰。欲爱已尽。谁不成就戒盗身缚我见身缚。答曰。道未知智生盖中谁不成就贪欲嗔恚睡眠调戏。答曰。欲爱已尽。谁不成就疑盖。答曰。欲爱已尽。若欲爱未尽道法智生。结中谁不成就嗔恚悭嫉结。答曰。欲爱已尽。谁不成就爱结憍慢结。答曰。无色界爱已尽。下分中谁不成就贪欲嗔恚。答曰。欲爱已尽。谁不成就身见。答曰。苦未知智生。谁不成就戒盗疑。答曰。道未知智生。见中谁不成就身见边见。答曰。苦未知智生。谁不成就邪见见盗戒盗。答曰。道未知智生。爱身中谁不成就鼻舌更爱。答曰。欲爱已尽。谁不成就眼耳身更爱。答曰。梵天上爱已尽。谁不成就意更爱。答曰。无色界爱已尽。使中谁不成就贪欲嗔恚使。答曰。欲爱已尽。谁不成就有爱使憍慢使无明使。答曰。无色界爱已尽。谁不成就见使疑使。答曰。道未知智生。结中谁不成就嗔恚悭嫉结。答曰。欲爱已尽。谁不成就爱结憍慢无明结。答曰。无色界爱已尽。谁不成就见失愿疑结。答曰。道未知智生。九十八使谁不成就欲界苦谛所断使。答曰。欲爱已尽。若欲爱未尽苦法智生。谁不成就欲界习谛所断使。答曰。欲爱已尽。若欲爱未尽习法智生。谁不成就欲界尽谛所断使。答曰。欲爱已尽。若欲爱未尽尽法智生谁不成就欲界道谛所断使。答曰。欲爱已尽。若欲爱未尽道法智生。谁不成就欲界思惟所断使。答曰。欲爱已尽。谁不成就色界苦谛所断使。答曰。色爱已尽。若色爱未尽苦未知智生。谁不成就色界习谛所断使。答曰。色爱已尽。若色爱未尽习未知智生。谁不成就色界尽谛所断使。答曰。色爱已尽。若色爱未尽尽未知智生。谁不成就色界道谛所断使。答曰。色爱已尽。若色爱未尽道未知智生。谁不成就色界思惟所断使。答曰。色爱已尽。谁不成就无色界苦谛所断使。答曰。苦未知智生。谁不成就无色界习谛所断使。答曰。习未知智生。谁不成就无色界尽谛所断使。答曰。尽未知智生。谁不成就无色界道谛所断使。答曰。道未知智生。谁不成就无色界思惟所断使。答曰。无色界爱已尽(不成就八门竟也)。眼根断智时凡夫人到色爱尽。三十一使得断智结不悉尽。圣人三使(色界三使)。得断智结不悉尽。如眼根如是耳鼻舌身根。眼持耳鼻舌身持。色声细滑持。眼入耳鼻舌身入。色声细滑入。色阴色盛阴地种乃至空种。色法可见法。有对法色界系法。第四禅慈悲护净解脱。后四除入八一切入。知他人心智断智时。凡夫人到色爱尽。三十一使断智结不悉尽。圣人三使断智结不悉尽。意根得断智时到无色界爱尽。三使得断智三结永尽。如意根如是命根护根信精进念定慧根。意持法持意识持意入法入。痛阴想行识阴。痛盛阴想行识盛阴。识种无色法。不可见法。无对法。有漏法有为法。过去未来现在法。善法无记法无色界系法。非学非无学法。思惟所断法苦谛习谛有想无想处有想无想处解脱。灭尽解脱等智断智时。到无色界爱尽。三使断智三结永尽。男根女根断智时。凡夫人到欲爱尽。三十六使断智三结永尽。圣人四使断智三结永尽。如男根女根如是。苦根忧根。香持味持鼻识舌识持。香入味入不善法。欲界系法断智时。凡夫人到欲爱尽。三十六使断智三结永尽圣人四使断智三结永尽。乐根断智时到遍净天爱尽。即彼乐根断智结使不悉尽。喜根断智时到光音天爱尽。即彼喜根断智结使不悉尽。眼识耳识身识持断智时到梵天上爱尽。即彼三识持断智结使不悉尽。见谛所断法得断智时色爱未尽。道未知智现在前。十四使断智三结永尽。色爱已尽道未知智现在前。七使断智三结永尽。禅中初禅断智时到初禅爱尽即彼初禅断智结使不悉尽。第二禅断智时到第二禅处爱尽。即彼第二禅断智结使不悉尽。如第二禅喜初第二解脱。初四除入亦复如是。三禅断智时到第三禅爱尽。即彼三禅断智结使不悉尽无色中空处断智时到空处爱尽。即彼空处。断智结使不悉尽。空处解脱空处入亦复如是。识处断智时到识处爱尽。即彼识处断智结使不悉尽。识处解脱识处入亦复如是。不用处断智时到不用处爱尽。即彼不用处断智结使不悉尽。不用处解脱亦复如是。结中身见断智时色爱未尽。苦未知智现在前十八使断智结不悉尽。色爱已尽苦未知智现在前。九使断智结不悉尽。如身见如是。下分中身见见中身见边见断智时色爱未尽。苦未知智现在前十八使断智结不悉尽。色爱已尽苦未知智现在前。九使断智结不悉尽。戒盗疑断智时色爱未尽。道未知智现在前。十四使断智三结永尽。色爱已尽道未知智现在前。七使断智三结永尽。如戒盗疑如是。见流见轭戒受见受戒盗身缚我见身缚。下分中戒盗疑。见中邪见见盗戒盗。使中见使疑使。结中见失愿疑结。断智时色爱未尽。道未知智现在前。十四使断智三结永尽。色爱已尽道未知智现在前。七使断智三结永尽。贪欲嗔恚愚痴及欲漏断智时凡夫人到欲爱尽三十六使断智三结永尽。圣人四使断智三结永尽。如是欲流欲轭欲受欲爱身缚嗔恚身缚。盖中贪欲嗔恚睡眠调戏。结中嗔恚悭嫉结。下分中贪欲嗔恚。爱身中鼻舌更爱。使中贪欲嗔恚使。结中嗔恚悭嫉结断智时。凡夫人到欲爱尽。三十六使断智三结永尽。圣人四使断智三结永尽。有漏无明漏断智时。到无色界爱尽。三使断智三结永尽。如是有流无明流有轭无明轭。我受爱结憍慢结无明结。意更爱有爱使憍慢使无明使。爱结憍慢结无明结。断智时。到无色界爱尽三使断智三结永尽。疑盖断智时凡夫人到欲爱尽。三十六使断智三结永尽。圣人道法智现在前。八使断智结不悉尽眼耳身更爱断智时。到梵天上爱尽。即彼三爱身断智结使不悉尽。九十八使中。欲界苦谛所断使断智时。凡夫人到欲爱尽。三十六使断智三结永尽圣人苦法智现在前。十使断智结不悉尽。欲界习谛所断使断智时。凡夫人到欲爱尽。三十六使断智三结永尽。圣人习法智现在前。七使断智结不悉尽。尽谛所断亦复如是。欲界道谛所断使得断智时。凡夫人到欲爱尽。三十六使断智三结永尽。圣人道法智现在前。八使断智。结不悉尽。欲界思惟所断使断智时。凡夫人到欲爱尽。三十六使断智三结永尽。圣人四使断智三结永尽。色界苦谛所断使断智时。凡夫人到色爱尽。三十一使断智结不悉尽。无垢人苦未知智现在前。十八使断智结不悉尽。色界习谛所断使断智时。凡夫人到色爱尽。三十一使得断智结不悉尽。无垢人未知智现在前。十二使断智结不悉尽。尽谛所断使亦复如是。色界道谛所断使得断智时。凡夫人到色爱尽。三十一使断智结不悉尽。无垢人道未知智现在前。十四使断智三结永尽。色界思惟所断使断智时。凡夫人到色爱尽。三十一使得断智结不悉尽。无垢人三使断智结不悉尽。无色界苦谛所断使断智时色爱未尽。苦未知智现在前。十八使断智结不悉尽色爱已尽。苦未知智现在前。九使断智结不悉尽。无色界习谛所断使断智时色爱未尽。习未知智现在前。十二使断智结不悉尽色爱已尽。习未知智现在前。六使断智结不悉尽。尽谛所断使亦复如是。无色界道谛所断使断智时。色爱未尽道未知智现在前。十四使断智三结永尽色爱已尽。道未知智现在前。七使断智三结永尽。无色界思惟所断使断智时。到无色界爱尽。三使断智三结永尽(断智九门竟)。眼根尽作证时。凡夫人到色爱尽。三十一使尽作证结不悉尽。无垢人三使尽作证结不悉尽。得阿罗汉九十八使尽作证九结永尽。如眼根如是。耳鼻舌身根。眼持耳鼻舌身持色声细滑持。眼入耳鼻舌身入。色声细滑入。色阴色盛阴。地种乃至空种。色法可见法有对法色界系法。第四禅慈悲护净解脱。后四除入八一切入。知他人心智尽作证时。凡夫人到色爱尽。三十一使尽作证结不悉尽。无垢人三使尽作证结不悉尽。得阿罗汉九十八使尽作证九结永尽。意根尽作证时得阿罗汉。九十八使尽作证九结永尽。如意根如是。命根护根信精进念定慧根。意持法持意识持意入法入。痛阴想行识阴。痛盛阴想行识盛阴。识种无色法不可见法无对法。有漏法有为法。过去未来现在法善法无记法。无色界系法。非学非无学法。思惟所断法。苦谛习谛。有想无想处。有想无想解脱。灭尽解脱等智尽作证时得阿罗汉。九十八使尽作证九结永尽。男根女根尽作证时。凡夫人到欲爱尽。三十六使尽作证三结永尽。得阿那含果九十二使尽作证六结永尽(悭嫉嗔除道迹三也)。得阿罗汉九十八使尽作证九结永尽。如男根女根如是。苦根忧根。香持味持鼻识舌识持。香入味入不善法欲界系法尽作证时。凡夫人到欲爱尽。三十六使尽作证三结永尽。得阿那含果九十二使尽作证六结永尽。得阿罗汉九十八使尽作证九结永尽。乐根尽作证时到遍净天爱尽。即彼乐根尽作证时结使不悉尽。得阿罗汉果九十八使尽作证九结永尽。喜根尽作证时到光音天爱尽即彼喜根尽作证结使不悉尽。得阿罗汉九十八使尽作证九结永尽。眼识耳识身识持尽作证时到梵天上爱尽。即彼三识持尽作证结使不悉尽。得阿罗汉。九十八使尽作证九结永尽。见谛所断法尽作证时。得须陀洹果八十八使尽作证三结永尽。得斯陀含果八十八使尽作证三结永尽。得阿那含果九十二使尽作证六结永尽。得阿罗汉果九十八使尽作证九结永尽。禅中初禅尽作证时到初禅爱尽。即彼初禅尽作证结使不悉尽得阿罗汉九十八使尽作证九结永尽。二禅尽作证时到二禅爱尽。即彼二禅尽作证结使不悉尽。得阿罗汉九十八使尽作证九结永尽。喜初第二解脱初四除入亦复如是。三禅尽作证时到三禅爱尽。即彼三禅尽作证结使不悉尽。得阿罗汉九十八使尽作证九结永尽。无色中空处尽作证时到空处爱尽。即彼空处尽作证结使不悉尽。得阿罗汉九十八使尽作证九结永尽。空处解脱空处入亦复如是。识处尽作证时到识处爱尽。即彼识处尽作证结使不悉尽。得阿罗汉九十八使尽作证九结永尽。识处解脱识处入亦复如是。不用处尽作证时到不用处爱尽。即彼不用处尽作证结使不悉尽。得阿罗汉九十八使尽作证九结永尽。不用处解脱亦复如是。结中身见尽作证时苦未知智现在前。十八使尽作证结不悉尽。得须陀洹斯陀含阿那含阿罗汉果。九十八使尽作证九结永尽。下分中身见。见中身见边见尽作证时。苦未知智现在前。十八使尽作证结不悉尽。得须陀洹斯陀含阿那含阿罗汉果。九十八使尽作证九结永尽。戒盗疑尽作证时得须陀洹斯陀含阿那含阿罗汉果。九十八使尽作证九结永尽。如是见流见轭戒受见受。戒盗身缚我见身缚。下分中戒盗疑。见中邪见见盗戒盗。使中见使疑使。结中见结失愿疑结尽作证时。得须陀洹果斯陀含阿那含阿罗汉果。九十八使尽作证九结永尽。贪嗔恚愚痴及欲漏尽作证时。凡夫人到欲爱尽。三十六使尽作证三结永尽。得阿那含果九十二使尽作证六结永尽。得阿罗汉果九十八使尽作证九结永尽。如是欲流欲轭欲爱。缚中欲爱身缚嗔恚身缚。盖中贪欲嗔恚睡眠调戏结中嗔恚悭嫉结。下分中贪欲嗔恚爱身中鼻舌更爱。使中贪欲使嗔恚使结中嗔恚结悭嫉结。尽作证时凡夫人到欲爱尽三十六使尽作证三结永尽。得阿那含果九十二使尽作证六结永尽。得阿罗汉果九十八使尽作证九结永尽。有漏无明漏尽作证时得阿罗汉果。九十八使尽作证九结永尽。流中有流无明流。有轭无明轭。我爱结憍慢结。意更爱有爱使憍慢使无明使。爱结憍慢结无明结。尽作证时得阿罗汉果。九十八使尽作证九结永尽。疑盖尽作证时。凡夫人到欲爱尽。三十六使尽作证三结永尽。无垢人道法智现在前。八使尽作证结不悉尽。得须陀洹果乃至阿罗汉果。九十八使尽作证九结永尽。眼耳身更爱尽作证时。到梵天上爱尽。即彼三爱身尽作证结使不悉尽。得阿罗汉果九十八使尽作证九结永尽。九十八使中欲界苦谛所断使尽作证时。凡夫人到欲爱尽。三十六使尽作证三结永尽。无垢人苦法智现在前。十使尽作证结不悉尽。得须陀洹乃至阿罗汉果。九十八使尽作证九结永尽。欲界习谛所断使尽作证时。凡夫人到欲爱尽。三十六使尽作证三结永尽无垢人习法智现在前。七使尽作证结不悉尽。得须陀洹乃至阿罗汉果。九十八使尽作证九结永尽。尽谛所断使亦复如是。欲界道谛所断使尽作证时。凡夫人到欲爱尽。三十六使尽作证三结永尽。无垢人道法智现在前。八使尽作证结不悉尽。得须陀洹乃至阿罗汉果。九十八使尽作证九结永尽。欲界思惟所断使尽作证时。凡夫人到欲爱尽。三十六使尽作证三结永尽。得阿那含果九十二使尽作证六结永尽。得阿罗汉果九十八使尽作证九结永尽。色界苦谛所断使尽作证时。凡夫人到色爱尽。三十一使尽作证结不悉尽。无垢人苦未知智现在前十八使尽作证结不悉尽。得须陀洹果乃至阿罗汉果。九十八使尽作证九结永尽。色界习谛所断使尽作证时。凡夫人到色爱尽三十一使尽作证结不悉尽。无垢人习。未知智现在前。十二使尽作证结不悉尽得须陀洹果乃至阿罗汉果。九十八使尽作证九结永尽。尽谛所断使尽作证时亦复如是。色界道谛所断使尽作证时。凡夫人到色爱尽。三十一使尽作证结不悉尽。无垢人道未知智现在前。十四使尽作证三结永尽。得须陀洹果乃至阿罗汉果。九十八使尽作证九结永尽。色界思惟所断使尽作证时。凡夫人到色爱尽。三十一使尽作证结不悉尽。无垢人三使尽作证结不悉尽。得阿罗汉果九十八使尽作证九结永尽。无色界苦谛所断使尽作证时。苦未知智现在前。十八使尽作证结不悉尽得须陀洹果。乃至阿罗汉果。九十八使尽作证九结永尽。无色界习谛所断使尽作证时。习未知智现在前。十二使尽作证结不悉尽。得须陀洹果乃至阿罗汉果。九十八使尽作证九结永尽。尽谛所断亦复如是。无色界道谛所断使尽作证时。得须陀洹果乃至阿罗汉果。九十八使尽作证九结永尽。无色界思惟所断使尽作证时。得阿罗汉九十八使尽作证九结永尽(尽证十门竟)

结使犍度十门跋渠第四竟(梵本一千六十首卢长十二字)

阿毗昙八犍度论卷第八阿毗昙八犍度论卷第九

        迦旃延子造

        符秦罽宾三藏僧伽提婆共竺佛念译

    智犍度第三

五跋渠颂曰

  八种有五处　　知他人心智
  若能修行智　　相应最在后

    阿毗昙八道跋渠第一

  八十种智　　择恒在前　　诸相应觉
  世见无漏

又世尊言。八种成就学迹。十种漏尽阿罗汉。八种学迹几种成就过去。几种成就未来。几种成就现在。十种漏尽阿罗汉。几种成就过去。几种成就未来。几种成就现在。云何为见。云何为智。云何为慧。若见是智耶。设智是见耶。若见是慧耶。设慧是见耶。若智是慧耶。设慧是智耶。见摄智耶为智摄见见摄慧耶为慧摄见智摄慧耶。为慧摄智。若成就见彼智耶。设成就智彼见耶。若成就见彼慧耶。设成就慧彼见耶。若成就智彼慧耶。设成就慧彼智耶。若见已灭无余彼智耶。设智已灭无余彼见耶。若见已灭无余彼慧耶。设慧已灭无余彼见耶。若智已灭无余彼慧耶。设慧已灭无余彼智耶。问定理摄成就灭。所谓等见是择法觉意耶。设是择法觉意是等见耶。所谓等智是择法觉意耶。设是择法觉意是等智耶。念觉意现在前时。几觉意几道种现在前。精进喜猗定护觉意。等见等志等语等业(身也)等命等方便等念等定现在前时。几觉意几道种现在前。诸法与念觉意相应。择法觉意彼耶。设诸法与择法觉意相应。念觉意彼耶。诸法念觉意相应。精进喜猗定护觉意等见等志等方便等念等定彼耶。设诸法与等定相应。念觉意彼耶。诸法乃至等念相应。等定彼耶。设诸法与等定相应。等念彼耶。云何世俗等见。云何世俗等智。若世俗等见是世俗等智耶。设是世俗等智是世俗等见。世俗等见世俗等智所摄耶。设是世俗等智世俗等见所摄耶。若成就世俗等见。彼世俗等智耶。设成就世俗等智。彼世俗等见耶。若世俗等见已灭无余。彼世俗等智耶。设世俗等智已灭无余。彼世俗等见耶。问定理摄成就灭。云何无漏等见。云何无漏等智。若无漏等见是无漏等智耶。设是无漏等智是无漏等见耶。无漏等见无漏等智所摄耶。设无漏等智无漏等见所摄耶。若成就无漏等见彼无漏等智耶。设成就无漏等智。彼无漏等见耶。问定理摄成就。此章义愿具演说

又世尊言。八种成就学迹。十种漏尽阿罗汉。八种学迹几种成就过去。几种成就未来。几种成就现在。答曰。若依有觉有观三昧。学初见现在前。彼不过去八种未来八种。现在彼灭已不失。若依有觉有观三昧。学见现在前。彼八种成就过去八未来八。现在彼灭已不失。若依无觉无观三昧。学见现在前。彼八过去八未来七现在(无等志也)。彼灭已不失。若依无色定学见现在前。彼八过去八未来四现在(除等志等语等业等命无色义)。彼灭已不失。若入灭尽三昧若世俗心现在前。彼八过去八未来现在无有(有觉有观竟)。若依无觉无观三昧。学初见现在前。彼无过去未来八现在七。彼灭已不失。复依无觉无观三昧。学见现在前。彼过去七未来八现在七。彼灭已不失。若依无色定学见现在前。彼过去七未来八现在四。彼灭已不失。若入灭尽定世俗心现在前。彼过去七未来八现在无。彼灭已不失。复依有觉有观三昧。学见现在前。彼过去七未来八现在八(无觉观竟)。若依无色定。学初见现在前。彼过去无。未来八。现在四。彼灭已不失。复依无色定。学见现在前。彼过去四未来八现在四。彼灭已不失。复入灭尽定世俗心现在前。彼过去四未来八现在无。若灭已不失。复依有觉有观三昧。学见现在前。彼过去四未来八现在八。彼灭已不失。复依无觉无观三昧。学见现在前。彼过去四未来八现在七(学迹竟)。十种漏尽阿罗汉。几种成就过去。几种成就未来。几种成就现在。答曰。若依有觉有观三昧。无学初智现在前。彼过去无未来十现在九(无等见也)。彼灭已不失。复依有觉有观三昧。无学智现在前。彼过去九未来十现在九。彼灭已不失。若依无觉无观三昧。无学智现在前。彼过去九未来十现在八(无等志等见)。彼灭已不失。若依无色定。无学智现在前。彼过去九未来十现在五(初上无戒)。彼灭已不失。若入灭尽定。世俗心现在前。彼过去九未来十现在无(智竟)。彼灭已不失。若依有觉有观三昧。无学初见现在前。彼过去九未来十现在九。彼灭已不失。复依有觉有观三昧。无学若智若见现在前。彼过去未来十现在九。彼灭已不失。复依无觉无观三昧。无学若智若见现在前。彼过去未来十现在八。彼灭已不失。复依无色定。无学若智若见现在前。彼过去未来十现在五。彼灭已不失。复入灭尽定。世俗心现在前。彼过去未来十现在无(有觉观竟)。若依无觉无观三昧。无学初见现在前。彼过去无未来十现在八。彼灭已不失。复依无觉无观三昧。无学见现在前。彼过去八未来十现在八。彼灭已不失。复依无色定。无学见现在前。彼过去八未来十现在五。彼灭已不失。复入灭尽定。世俗心现在前。彼过去八未来十现在无。彼灭已不失。复依有觉有观三昧。无学见现在前。彼过去八未来十现在九(见竟)。彼灭已不失。复依无觉无观三昧。无学初见现在前。彼过去八未来十现在八。彼灭已不失。复依无觉无观三昧。无学若智若见现在前。彼过去九未来十现在八。彼灭已不失。复依无色定。无学若智若见现在前。彼过去九未来十现在五。彼灭已不失。复入灭尽三昧。世俗心现在前。彼过去九未来十现在无。彼灭已不失。复依有觉有观三昧。无学若智若见现在前。彼过去九未来十现在九(无觉观竟)。若依无色定。无学初见现在前。彼无过去未来十现在五。彼灭已不失。复依无色定。无学见现在前。彼过去五未来十现在五。彼灭已不失。若入灭尽定。世俗心现在前。彼过去五未来十现在无。彼灭已不失。复依有觉有观三昧。无学见现在前。彼过去五未来十现在九。彼灭已不失。复依无觉无观三昧。无学见现在前。彼过去五未来十现在八(见竟)。彼灭已不失。复依无色定。无学初见现在前。彼过去五未来十现在五。彼灭已不失。复依无色定。无学若智若见现在前。彼过去六未来十现在五。彼灭已不失。复入灭尽三昧。世俗心现在前。彼过去六未来十现在无。彼灭已不失。复依有觉有观三昧。无学若智若见现在前。彼过去六未来十现在九。彼灭已不失。复依无觉无观三昧。无学若智若见现在前。彼过去六未来十现在八(真人竟)。云何为见。云何为智。云何为慧。云何为见。答曰眼根。五见。世俗等见。学见。无学见也。云何为智。答曰。除所修行忍。诸余意识身相应智。及五识身相应智。尽智无生智也。云何为慧。答曰。意识身相应慧。及五识身相应慧。尽智无生智(问竟)。诸见彼智耶。答曰。或见非智。云何见非智。答曰。眼根所修行忍。是谓见非智。云何智非见。答曰。除五见及世俗等见。诸余意识身相应有漏慧。及五识身相应慧。尽智无生智。是谓智非见。云何智见。答曰。除所修行忍。及尽智无生智诸余无漏慧。五见世俗等见。是谓智见。云何非智非见。答曰。除上尔所事。所谓见是慧耶。答曰。或是见非慧(梵言明智十智之一)。云何是见非慧耶。答曰。眼根。是谓见非慧。云何是慧非见。答曰。除五见。及世俗等见。诸余意识身相应有漏慧。五识身相应慧。尽智无生智。是谓慧非见。云何见慧。答曰。除尽智无生智。诸余无漏慧。及五见世俗等见。是谓见慧。云何非见非慧。答曰。除上尔所事。诸智彼慧耶。答曰。如是智是慧也。颇有慧非智。答曰。有所修行忍(定理竟)。所谓见是智摄耶。答曰。或见非智。云何见非智。答曰。眼根所修行忍。是谓见非智。云何智非见。答曰。除五见世俗等见。诸余意识身相应有漏慧。五识身相应慧。尽智无生智。是谓智非见。云何见智。答曰。除所修忍及尽智无生智。诸余无漏慧。五见世俗等见。是谓见智。云何非智非见。答曰。除上尔所事。所谓见彼慧所摄耶。答曰。或见非慧。云何见非慧。答曰。眼根。是谓见非慧。云何慧非见。答曰。除五见世俗等见。诸余意识身相应有漏慧。五识身相应慧。尽智无生智。是谓慧非见。云何见慧。答曰。除尽智无生智诸余无漏慧。五见世俗等见。是谓见慧。云何非见非慧。答曰。除上尔所事。智摄慧慧摄智耶。答曰。慧摄智非智摄慧。不摄何等。答曰。所修行忍(忍智不得慧也)。成就与灭亦复如是。问定理摄成就灭也。所谓等见是择法觉意耶。答曰。或等见非择法觉意。云何等见非择法觉意。答曰。世俗等见。是谓等见非择法觉意。云何择法觉意非等见耶。答曰。尽智无生智。是谓择法觉意非等见。云何等见择法觉意。答曰。除尽智无生智。诸余无漏慧。是谓等见择法觉意。云何非等见亦非择法觉意。答曰。除上尔所事。所谓等智是择法觉意耶。答曰。或等智非择法觉意。云何等智非择法觉意。答曰。世俗等智。是谓等智非择法觉意。云何择法觉意非等智。答曰。所修行忍。是谓择法觉意非等智。云何等智择法觉意。答曰。除所修行忍。诸余无漏慧。是谓等智择法觉意。云何非等智非择法觉意。答曰。除上尔所事。念觉意现在前时。几觉意。几道种现在前。答曰。若依未来有觉有观三昧。学念觉意现在前。彼六觉意现在前。及八道种无学六觉意现在前及九道种。若依初禅学念觉意现在前。彼七觉意现在前。及八道种无学七觉意现在前及九道种。若依禅中间。学念觉意现在前。彼六觉意现在前。及七道种无学六觉意现在前及八道种。若依二禅学念觉意现在前。彼七觉意现在前。及七道种。无学七觉意现在前。及八道种。若依三禅四禅学念觉意现在前。彼六觉意现在前。及七道种。无学六觉意现在前及八道种。若依无色定学念觉意现在前。彼六意觉现在前。及四道种。无学六觉意现在前。及五道种法。精进猗定觉护意等见等方便等念等定亦复如是。喜觉意现在前时。几觉意几道种现在前。答曰。若依初禅学喜觉意现在前。彼七觉意现在前。及八道种。无学七觉意现在前。及九道种。若依二禅学喜觉意现在前。彼七觉意现在前。及七道种。无学七觉意现在前。及八道种。等志现在前时。几觉意几道种现在前。答曰。若依未来有觉有观三昧。学等志现在前。彼六觉意现在前。及八道种。无学六觉意现在前。及九道种(智见不并)。若依初禅学等志现在前。彼七觉意现在前。及八道种。无学七觉意现在前。及九道种。等语现在前时。几觉意几道种现在前。答曰。若依未来有觉有观三昧。学等语现在前。彼六觉意现在前。及八道种。无学六觉意现在前。及九道种。若依初禅学等语现在前。彼七觉意现在前。及八道种。无学七觉意现在前。及九道种。若依禅中间学等语现在前。彼六觉意现在前。及七道种。无学六觉意(无喜)现在前。及八道种。若依二禅学等语现在前。彼七觉意现在前。及七道种(无等志也)。无学七觉意现在前。及八道种。若依三禅。四禅。学等语现在前。彼六觉意现在前。及七道种。无学六觉意现在前。及八道种。等业等命亦复如是。诸法念觉意相应彼择法觉耶。答曰。或念觉意非择法觉意。云何念觉意非择法觉意。答曰。择法觉意。是谓念觉意非择法觉意。云何择法觉意非念觉意。答曰。念觉意。是谓择法觉意非念觉意。云何念觉意择法觉意。答曰。除择法觉意诸余念觉意相应法。是谓念觉意择法觉意。云何非念觉意非择法觉意。答曰。诸余心心法色无为心不相应行。是谓非念觉意非择法觉意。精进猗定护觉意等方便等定亦复如是。诸法念觉意相应彼喜觉意耶。答曰。或念觉意非喜觉意。云何有念觉意非喜觉意。答曰。喜觉意及喜觉意不相应。念觉意相应法。是谓念觉意非喜觉意。云何喜觉意非念觉意。答曰。喜觉意相应念觉意。是谓喜觉意非念觉意。云何念觉意喜觉意。答曰。除念觉意诸余喜觉意相应法。是谓念觉意喜觉意。云何非念觉意亦非喜觉意。答曰。喜觉意不相应念觉意。及余心心法色无为心不相应行。是谓非念觉意亦非喜觉意。等见等志亦复如是。诸法念觉意相应彼等念耶。答曰。如是。设诸法等念相应彼念觉意耶。答曰。如是。诸法择法觉意相应彼精进觉意耶。答曰。或择法觉意非精进觉意。云何择法觉意非精进觉意。答曰。精进觉意。是谓择法觉意非精进觉意。云何精进觉意非择法觉意。答曰。择法觉。意是谓精进觉意非择法觉意。云何择法觉意精进觉意。答曰。除精进觉意诸余择法觉意相应法。是谓择法觉意精进觉意。云何非择法觉意亦非精进觉意。答曰。诸余心心法色无为心不相应行。是谓非择法觉意亦非精进觉意。猗定护觉意等方便等定等念亦复如是。诸法择法觉意相应彼喜觉意耶。答曰。或择法觉意非喜觉意。云何择法觉意非喜觉意。答曰。喜觉意及喜觉意不相应。择法觉意相应法。是谓择法觉意非喜觉意。云何喜觉意非择法觉意。答曰。喜觉意相应择法觉意。是谓喜觉意非择法觉意。云何择法觉意喜觉意。答曰。除择法觉意。诸余喜觉意相应法。是谓择法觉意喜觉意。云何非择法觉意非喜觉意。答曰。喜觉意不相应择法觉意。及余心心法色无为心不相应行。是谓非择法觉意亦非喜觉意。等志亦复如是。诸法择法觉意相应彼等见耶。答曰。如是。诸法等见相应彼择法觉意。颇择法觉意无等见耶。答曰。有等见不摄择法觉意。诸法精进觉意相应。彼有喜觉意耶。答曰。或精进觉意非喜觉意云何精进觉意非喜觉意。答曰。喜觉意及喜觉意不相应。精进觉意相应法。是谓精进觉意非喜觉意。云何喜觉意非精进觉意。答曰。喜觉意相应精进觉意。是谓喜觉意非精进觉意。云何精进觉意喜觉意。答曰。除精进觉意。诸余喜觉意相应法。是谓精进觉意喜觉意。云何非精进觉意非喜觉意。答曰。喜觉意不相应精进觉意。诸余心心法色无为心不相应行。是谓非精进觉意非喜觉意。等见等志亦复如是。诸法精进觉意相应彼猗觉意耶。答曰。或精进觉意非猗觉意。云何精进觉意非猗觉意。答曰。猗觉意。是谓精进觉意非猗觉意。云何猗觉意非精进觉意。答曰。精进觉意。是谓猗觉意非精进觉意。云何精进觉意猗觉意。答曰。除猗觉意诸余精进觉意相应法。是谓精进觉意猗觉意。云何非精进觉意非猗觉意。答曰。诸余心心法色无为心不相应行。是谓非精进觉意非猗觉意。定护觉意等念等定亦复如是。诸法精进觉意相应彼等方便耶。答曰。如是。设诸法等方便相应。彼精进觉意耶。答曰。如是。诸法喜觉意相应。彼猗觉意耶。答曰或喜觉意非猗觉意。云何喜觉意非猗觉意。答曰。喜觉意相应猗觉意。是谓喜觉意非猗觉意。云何猗觉意非喜觉意。答曰。喜觉意及喜觉意不相应。猗觉意相应法。是谓猗觉意非喜觉意。云何喜觉意猗觉意。答曰。除猗觉意。诸余喜觉意相应法。是谓喜觉意猗觉意。云何非喜觉意亦非猗觉意。答曰。喜觉意不相应猗觉意。诸余心心法色无为心不相应行。是谓非喜觉意非猗觉意。定护觉意等方便等念等定亦复如是。诸法喜觉意相应彼等见耶。答曰。或喜觉意非等见。云何喜觉意非等见。答曰。喜觉意相应等见。及余等见不相应。喜觉意相应法。是谓喜觉意非等见。云何等见非喜觉意。答曰。等见相应喜觉意。诸余喜觉意不相应。等见相应法。是谓等见非喜觉意。云何喜觉意等见。答曰。除喜觉意相应等见。诸余喜觉意等见相应法。是谓喜觉意等见相应法。云何非喜觉意非等见。答曰。喜觉意不相应等见。等见不相应喜觉意。诸余心心法色无为心不相应行。是谓非喜觉意非等见。等志亦复如是。诸法猗觉意相应彼定觉意耶。答曰。或猗觉意非定觉意。云何猗觉意非定觉意。答曰。定觉意。是谓猗觉意非定觉意。云何定觉意非猗觉意。答曰。猗觉意。是谓定觉意非猗觉意。云何猗觉意定觉意。答曰。除定觉意。诸余猗觉意相应法。是谓猗觉意定觉意。云何非猗觉意非定觉意。答曰。诸余心心法色无为心不相应行。是谓非猗觉意非定觉意护觉意等方便等念等定亦复如是。诸法猗觉意相应彼等见耶。答曰。或猗觉意非等见。云何猗觉意非等见。答曰。等见及等见不相应。猗觉意相应法。是谓猗觉意非等见。云何等见非猗觉意。答曰。等见相应猗觉意。是谓等见非猗觉意。云何猗觉意等见。答曰。除猗觉意诸余等见相应法。是谓猗觉意等见。云何非猗觉意非等见。答曰。等见不相应猗觉意。及余心心法色无为心不相应行。是谓非猗觉意非等见。等志亦如是。诸法定觉意相应。彼护觉意耶。答曰。或定觉意非护觉意。云何定觉意非护觉意。答曰。护觉意。是谓定觉意非护觉意。云何护觉意非定觉意。答曰。定觉意是谓护觉意非定觉意。云何定觉意护觉意。答曰。除护觉意。诸余定觉意相应法。是谓定觉意护觉意。云何非定觉意非护觉意。答曰。诸余心心法色无为心不相应行。是谓非定觉意非护觉意。等方便等念亦复如是。诸法定觉意相应彼等见耶。答曰。或定觉意非等见。云何定觉意非等见。答曰。等见及等见不相应。定觉意。相应法。是谓定觉意非等见。云何等见非定觉意。答曰。等见相应定觉意。是谓等见非定觉意。云何定觉意等见。答曰。除定觉意诸余等见相应法。是谓定觉意等见。云何非定觉意非等见。答曰。等见不相应定觉意。诸余心心法色无为心不相应行。是谓非定觉意非等见。等志亦如是。诸法定觉意相应彼等定耶。答曰。如是。设诸法等定相应彼定觉意耶。答曰。如是。诸法护觉意相应彼等见耶。答曰。或护觉意非等见。云何护觉意非等见。答曰。等见及等见不相应护觉意相应法。是谓护觉意非等见。云何等见非护觉意。答曰。等见相应护觉意。是谓等见非护觉意。云何护觉意等见。答曰。除护觉意诸余等见相应法。是谓护觉意等见。云何非护觉意非等见。答曰。等见不相应护觉意。诸余心心法色无为心不相应行。是谓非护觉意非等见。等志亦如是。诸法护觉意相应彼等方便耶。答曰。或护觉意非等方便。云何护觉意非等方便。答曰。等方便是谓护觉意非等方便。云何等方便非护觉意。答曰。护觉意是谓等方便非护觉意。云何护觉意等方便。答曰。除等方便诸余护觉意相应法。是谓护觉意等方便。云何非护觉意非等方便。答曰。诸余心心法色无为心不相应行。是谓非护觉意非等方便。等念等定等亦复如是。诸法等见相应彼等志耶。答曰。或等见非等志。云何等见非等志。答曰。等见相应等志。及等志不相应等见相应法。是谓等见非等志。云何等志非等见。答曰。等志相应等见及等见不相应等志相应法。是谓等志非等见。云何等见等志。答曰。除等见相应等志。诸余等见等志相应法。是谓等见等志。云何非等见非等志。答曰。等见不相应等志。等志不相应等见。诸余心心法色无为心不相应行。是谓非等见非等志。诸法等见相应等方便耶。答曰。或等见非等方便。云何等见非等方便。答曰。等见相应等方便。是谓等见非等方便。云何等方便非等见。答曰。等见及等见不相应等方便相应法。是谓等方便非等见。云何等见等方便。答曰。除等方便诸余等见相应法。是谓等见等方便。云何非等见非等方便。答曰。等见不相应等方便。诸余心心法色无为心不相应行。是谓非等见非等方便。等念等定亦如是。诸法等志相应彼等方便耶。答曰。或等志非等方便。云何等志非等方便。答曰。等志相应等方便。是谓等志非等方便。云何等方便非等志。答曰。等志及等志不相应等方便相应法。是谓等方便非等志。云何等志等方便。答曰。除等方便诸余等志相应法。是谓等志等方便。云何非等志非等方便。答曰。等志不相应等方便。诸余心心法色无为心不相应行。是谓非等志非等方便。等念等定亦如是。诸法等方便相应彼等念耶。答曰。或等方便非等念。云何等方便非等念。答曰。等念是谓等方便非等念。云何等念非等方便。答曰。等方便是谓等念非等方便。云何等方便等念。答曰。除等念诸余等方便相应法。是谓等方便等念。云何非等方便非等念。答曰。诸余心心法色无为心不相应行。是谓非等方便非等念。等定亦如是。诸法等念相应彼等定耶。答曰。或等念非等定。云何等念非等定。答曰。等定是谓等念非等定。云何等定非等念。答曰。等念是谓等定非等念。云何等念等定。答曰。除等定诸余等念相应法。是谓等念等定。云何非等念非等定。答曰。诸余心心法色无为心不相应行。是谓非等念非等定。云何世俗等见。云何世俗等智。世俗等见云何。答曰。意识身相应善有漏慧。世俗等智云何。答曰。意识身相应善有漏慧。五识身相应善慧。若世俗等见是世俗等智耶。答曰如是。若世俗等见彼世俗等智。颇有世俗等智非世俗等见。答曰有。五识身相应善慧。世俗等见摄世俗等智耶世俗等智摄世俗等见耶。答曰。世俗等智摄世俗等见。非世俗等见摄世俗等智。不摄何等。答曰。五识身相应善慧。成就灭亦复如是。问定理摄成就灭。云何无漏等见云何无漏等智。无漏等见云何。答曰。尽智无生智不摄无漏慧。无漏等智云何。答曰。除所修忍诸余无漏慧。若无漏等见是无漏等智耶。答曰。或无漏等见非无漏等智。云何无漏等见非无漏等智。答曰。所修行忍。是谓无漏等见非无漏等智。云何无漏等智非无漏等见。答曰。尽智无生智。是谓无漏等智非无漏等见。云何无漏等见无漏等智。答曰。除所修行忍。尽智无生智诸余无漏慧。是谓无漏等见无漏等智。云何非无漏等见非无漏等智。答曰。除上尔所事。无漏等见摄无漏等智耶。答曰。或无漏等见非无漏等智。云何无漏等见非无漏等智。答曰。所修行忍。是谓无漏等见非无漏等智。云何无漏等智非无漏等见。答曰。尽智无生智是谓无漏等智非无漏等见。云何无漏等见无漏等智

答曰。除所修行忍。尽智无生智诸余无漏智。是谓无漏等见无漏等智。云何非无漏等见非无漏等智。答曰。除上尔所事。若成就无漏等见彼无漏等智耶。答曰。如是。若成就无漏等智。亦无漏等见。颇成就无漏等见非无漏等智耶。答曰。有苦法忍现在前。问定理摄成就

阿毗昙智犍度八十种跋渠第一竟(梵本四百三十三首卢秦七千二百四十六言)

阿毗昙八犍度论卷第九阿毗昙八犍度论卷第十

        迦旃延子造

        符秦罽宾三藏僧伽提婆共竺佛念译

    阿毗昙智犍度五种跋渠第三

  邪见等见逆　　学者亦无学
  非学非无学　　梵忍及五种

云何邪见云何邪智。若邪见是邪智耶。设是邪智是邪见耶。邪见摄邪智耶。邪智摄邪见耶。若成就邪见彼邪智耶。设成就邪智彼邪见耶。若邪见已灭无余彼邪智耶。设邪智已灭无余彼邪见耶。问定理摄成就灭。云何等见云何等智。若等见是等智耶。设是等智是等见耶。等见摄等智等智摄等见。若成就等见彼等智耶。设成就等智彼等见耶。若等见已灭无余彼等智耶。设等智已灭无余彼等见耶。问定理摄成就灭也。诸逆慧尽是结耶。设是结尽是逆慧耶

云何学见。云何学智。云何学慧。若学见是学智耶。设是学智是学见耶。学见是学慧耶。设学慧是学见耶。学智是学慧耶。设学慧是学智耶。学见摄学智耶。学智摄学见耶。学见摄学慧学慧摄学见学智摄学慧学慧摄学智。若成就学见彼学智耶。设成就学智彼学见耶。若成就学见彼学慧耶。设成就学慧彼学见耶。若成就学智彼学慧耶。设成就学慧彼学智耶。问定理摄成就也。云何无学见。云何无学智。云何无学慧。无学见是无学智耶。设无学智是无学见耶。无学见是无学慧耶。设是无学慧是无学见耶。若无学智是无学慧耶。设无学慧是无学智耶。无学见摄无学智耶。无学智摄无学见耶。无学见摄无学慧。无学慧摄无学见耶。无学智摄无学慧。无学慧摄无学智。若成就无学见彼无学智耶。设成就无学智彼无学见耶。若成就无学见彼无学慧耶。设成就无学慧彼无学见耶。若成就无学智彼无学慧耶。设成就无学慧彼无学智耶。问定理摄成就也。云何非学非无学见。云何非学非无学智。云何非学非无学慧。非学若非无学见。是非学非无学智耶。设是非学非无学智。是非学非无学见耶。若非学非无学见。是非学非无学慧耶。设非学非无学慧。是非学非无学见耶。若非学非无学智。是非学非无学慧耶。设非学非无学慧。是非学非无学智耶。若非学非无学见。摄非学非无学智耶。非学非无学智摄。非学非无学见耶。非学非无学见。摄非学非无学慧耶。非学非无学慧。摄非学非无学见耶。非学非无学智。摄非学非无学慧耶。设非学非无学慧。摄非学非无学智耶。若成就非学非无学见。彼非学非无学智耶。设成就非学非无学智。彼非学非无学见耶。若成就非学非无学见。彼非学非无学慧耶。设成就非学非无学慧。彼非学非无学见耶。若成就非学非无学智。彼非学非无学慧耶。设成就非学非无学慧。彼非学非无学智耶。若非学非无学见已灭无余。彼非学非无学智耶。设非学非无学智已灭无余。彼非学非无学见耶。若非学非无学见已灭无余。彼非学非无学慧耶。设非学非无学慧已灭无余。彼非学非无学见耶。若非学非无学智已灭无余。彼非学非无学慧耶。设非学非无学慧已灭无余。彼非学非无学智耶。问定理摄成就灭也。如彼梵天作是语。我于此梵天大梵。富造化妙造众生类。于此五见是何等见用。何等谛断此见。如彼梵迦夷天作是语。此梵天大梵富造化妙造众生类。于此五见是何等见用。何等谛断此见。如彼长爪梵志作是语。一切瞿昙我不忍一切我忍有忍不忍。于此五见是何等见用。何等谛断此见。所谓此见阿罗汉失不净。其形像精魔迦夷天(身也)。阿罗汉失不净。于此五见是何等见用。何等谛断此见。所谓此见阿罗汉自脱不知。阿罗汉自脱狐疑得阿罗汉由他知。于此五见是何等见用。何等谛断此见。所谓此见称唯苦道苦道种五。于此五见何等见用。何等谛断此见。此章义愿具演说

云何邪见云何邪智。邪见云何。答曰。五见不定义五见尽邪见。若定所谓此见无施无报无说。是谓邪见。邪智云何。答曰。意识身相应染污慧。五识身相应染污慧。是谓邪智。若邪见是邪智耶。答曰。如是。邪见是邪智颇有邪智非邪见。答曰。有除五见诸余意识身相应染污慧。五识身相应染污慧。邪见摄邪智邪智摄邪见耶。答曰。邪智摄邪见。非邪见摄邪智。不摄何等。答曰。除五见。诸余意识身相应染污慧。五识身相应染污慧。若成就邪见彼邪智耶。答曰。如是。若成就邪见彼邪智也。颇成就邪智非邪见耶。答曰。有学见迹。若邪见已灭无余彼邪智耶。答曰。如是。若邪智已灭无余彼邪见也。颇有邪见已灭无余非邪智耶。答曰。有学见迹。问定理摄成就灭也。云何等见云何等智。等见云何。答曰。尽智无生智不摄意识身相应善慧。等智云何。答曰。除所修行忍。诸余意识身相应善慧。五识身相应善慧等见是等智耶。答曰。或等见非等智。云何等见非等智。答曰。所修行忍。是谓等见非等智。云何等智非等见。答曰。五识身相应善慧尽智无生智。是谓等智非等见。云何等智等见。答曰。除所修行忍尽智无生智。诸余意识身相应善慧。是谓等智等见。云何非等见非等智。答曰。除上尔所事。等见摄等智耶。答曰。或等见非等智。云何等见非等智。答曰。所修行忍是谓等见非等智。云何等智非等见。答曰。五识身相应善慧尽智无生智。是谓等智非等见。云何等见等智。答曰。除所修行忍尽智无生智。诸余意识身相应善慧。是谓等见等智。云何非等见非等智。答曰。除上尔所事。成就灭亦如是。问定理摄成就灭也。诸逆慧尽是结耶。答曰。或逆慧非结。云何逆慧非结。答曰。除二结(见失愿)诸余染污慧。是谓逆慧非结。云何结非逆慧。答曰。七结是谓结非逆慧。云何逆慧是结。答曰。二结是谓逆慧。结云何非逆慧非结。答曰。除上尔所事。云何学见云何学智云何学慧。学见云何。答曰。学慧。学智云何。答曰。学八智。学慧云何。答曰。学见学智学慧。此之谓也。若学见是学智耶。答曰。如是。学智是学见。颇有学见非学智耶。答曰。有所修行忍。若学见是学慧耶。答曰。如是。设是学慧是学见耶。答曰。如是。若学智是学慧耶。答曰。如是。若学智是学慧。颇有学慧非学智耶。答曰。有所修行忍。学见摄学智学智摄学见耶。答曰。学见摄学智非学智摄学见。不摄何等。答曰。所修行忍。学见摄学慧耶。答曰。如是。学慧摄学见耶。答曰。如是。学智摄学慧学慧摄学智耶。答曰。学慧摄学智非学智摄学慧。不摄何等。答曰。所修行忍。若成就学见彼学智耶。答曰。如是。若成就学智彼学见也。颇成就学见非学智耶。答曰。有苦法忍现在前。若成就学见彼学慧耶。答曰。如是。设成就学慧彼学见耶。答曰。如是。若成就学智彼学慧耶。答曰。如是。若成就学智彼学慧也。颇成就学慧非学智耶。答曰。有苦法忍现在前。问定理摄成就。云何无学见。云何无学智。云何无学慧。无学见云何。答曰。尽智无生智不摄无漏慧。无学智云何。答曰。无学八智。无学慧云何。答曰。无学见无学智无学慧。此之谓也。无学见是无学智耶。答曰。如是。无学见是无学智。颇有无学智非无学见耶。答曰。有尽智无生智也。无学智是无学慧耶。答曰。如是。无学慧是无学智耶。答曰。如是。无学见摄无学智。无学智摄无学见。答曰。无学智摄无学见。非无学见摄无学智。不摄何等。答曰。尽智无生智。无学见摄无学慧。无学慧摄无学见。答曰。无学慧摄无学见。非无学见摄无学慧。不摄何等。答曰。尽智无生智。无学智摄无学慧耶。答曰。如是。无学慧摄无学智耶。答曰。如是。成就亦如是。问定理摄成就也。云何非学非无学见。云何非学非无学智。云何非学非无学慧。非学非无学见云何。答曰。眼根五见世俗等见也。非学非无学智云何。答曰。意识身相应有漏慧。五识身相应慧也。非学非无学慧云何。答曰。意识身相应有漏慧。五识身相应慧。若非学非无学见。是非学非无学智耶。答曰。或见非智。云何见非智。答曰。眼根是谓见非智。云何智非见。答曰。除五见世俗等见。诸余意识身相应有漏慧。五识身相应慧。是谓智非见。云何见智。答曰。五见世俗等见是谓见智。云何非见非智。答曰。除上尔所事。非学非无学见。是非学非无学慧耶。答曰。或见非慧。云何见非慧。答曰。眼根是谓见非慧。云何慧非见。答曰。除五见世俗等见。诸余意识身相应有漏慧。五识身相应慧。是谓慧非见。云何见慧。答曰。五见世俗等见是谓见慧。云何非见非慧。答曰。除上尔所事。非学非无学智。是非学非无学慧耶。答曰。如是。设非学非无学慧。是非学非无学智耶。答曰。如是。非学非无学见。摄非学非无学智耶。答曰。或见非智。云何见非智。答曰。眼根是谓见非智。云何智非见。答曰。除五见世俗等见。诸余意识身相应有漏慧。五识身相应慧。是谓智非见。云何见智。答曰。五见世俗等见。是谓见智。云何非见非智。答曰。除上尔所事。非学非无学见摄非学非无学慧耶。答曰。或见非慧。云何见非慧。答曰。眼根是谓见非慧。云何慧非见。答曰。除五见世俗等见。诸余意识身相应有漏慧。五识身相应慧。是谓慧非见。云何见慧。答曰。五见世俗等见。是谓见慧。云何非见非慧。答曰。除上尔所事。非学非无学智。摄非学非无学慧耶。答曰。如是。非学非无学慧。摄非学非无学智耶。答曰。如是。成就灭亦如是。问定理摄成就灭也。如彼梵天作是说。我于此梵大梵富。以卑法盗为最。此是见盗苦谛所断。造化无作言作。此是戒盗苦谛所断。言妙者以卑法盗为最。此是见盗苦谛所断。造众生类无作言作。此是戒盗苦谛所断。如彼梵迦夷天作是言。此梵大梵富。以卑法盗为最。此是见盗苦谛所断。造众生类无作言作。此是戒盗苦谛所断。言妙者以卑法盗为最。此是见盗苦谛所断。造众生类无作言作。此是戒盗苦谛所断。如彼长爪梵志作是语。一切瞿昙我不忍。此边见断灭所摄苦谛所断。一切瞿昙我忍。此边见有常所摄苦谛所断。我有忍有不忍。彼有忍者。此边见有常所摄苦谛所断。彼有不忍者。此边见断灭所摄苦谛所断。所谓此见阿罗汉失不净。其形像精魔迦夷天。阿罗汉失不净污床褥无作言作。此是戒盗苦谛所断。所谓此见阿罗汉自脱不知。言阿罗汉无此智。此耶邪见道谛所断。所谓此见阿罗汉自脱狐疑。阿罗汉已越狐疑。此耶邪见道谛所断。所谓此见得阿罗汉由他知得。阿罗汉不由他知。此耶邪见道谛所断。所谓此见称言苦道苦道种无作言作。此是戒盗苦谛所断(五竟此品以名)

阿毗昙五种跋渠第十四竟(梵本二百首卢长十四字秦三千五百四十九言)

    阿毗昙智犍度知他心跋渠第三

  知他人心四　　及爱亦有五
  明信灭颠倒　　修行三昧道

云何知他人心智。云何识宿命智。若知他人心智即知他人心耶。设知他人心是知他人心智耶。若识宿命智即识宿命耶。设识宿命是识宿命智耶。若识宿命智彼知过去他人心所念法耶。设知过去他人心所念法。是识宿命智耶。云何等意解脱。云何无疑意解脱。以何等故等意解脱言爱耶。诸等意解脱。彼一切尽智相应耶。设尽智相应。彼一切等意解脱耶。诸无疑意解脱。彼一切无生智相应耶。设无生智相应彼一切无疑意解脱耶。云何学明。云何学智。云何无学明。云何无学智。修行法时最初得。何等信佛耶法耶僧耶。此四颠倒须陀洹几灭几不灭。此三三昧须陀洹。几成就过去。几成就未来。几成就现在。若道过去一切彼道已修已猗耶。设道已修已猗一切彼道过去耶。若道未来一切彼道不修不猗耶。设道不修不猗一切彼道未来耶。若道现在一切彼道当修耶。设道当修一切彼道现在耶。此章义愿具演说

云何知他人心智。云何识宿命智。知他人心智云何。答曰。若智所修所修果。忆所修已得不失。所可用智现在前。他众生他人所觉所观所行。已觉意性如实知之。是谓知他人心智。识宿命智云何。答曰。若智所修所修果。忆所修已得不失。所可用智现在前。如其相貌无数生识宿命。是谓识宿命智。若知他人心智。即知他人心耶。答曰。或知他人心智非知他人心。云何知他人心智非知他人心。答曰。若知他人心智过去未来。是谓知他人心智。即非知他人心。云何知他人心非知他人心智耶。答曰如是。睹相闻他语知他人心。是谓知他人心。非知他人心智。云何知他人心智。亦知他人心。答曰。若智所修所修果。忆所修已得不失。所可用智现在前。他众生他人所觉所观所行。已觉意性如实知之。是谓知他人心智。亦知他人心。云何不知他人心智。亦不知他人心。答曰。除上尔所事。若识宿命智即识宿命耶。答曰。或识宿命智即不识宿命。云何识宿命智即不识宿命。答曰。若识宿命智过去未来。是谓识宿命智彼不识宿命。云何识宿命非识宿命智。答曰。如生识宿命如其色像。生得此智识宿命。是谓识宿命非识宿命智。云何识宿命智彼识宿命耶。答曰。若智所修所修果。忆所修已得不失。所可用智现在前。如其相貌无数生识宿命。是谓识宿命智。彼识宿命云何非识宿命智。非识宿命耶。答曰。除上尔所事。若识宿命智。彼知过去他人心所念法耶。答曰。或识宿命智。彼不知过去他人心所念法。云何识宿命智。彼不知过去他人心所念法。答曰。若智所修所修果。忆所修已得不失。所可用智现在前。过去生时知自更持阴入心。是谓识宿命智彼不知过去他人心所念法。云何知过去他人心所念法。非识宿命智耶。答曰。若智所修所修果。忆所修已得不失。所可用智现在前。过去于此生他众生他人心智所更持阴入心是谓知过去。他人心所念法。非识宿命智。云何识宿命智。亦知过去他人心所念法。答曰。若智所修所修果。忆所修已得不失。所可用智现在前。过去生时他众生他人智所更持阴入心。是谓识宿命智亦知过去他人心所念法。云何非识宿命智。亦不知过去他人心所念法。答曰。若智所修所修果。忆所修已得不失。所可用智现在前。过去于此生知自所更持阴入心。是谓非识宿命智亦不知过去他人心所念法。云何等意解脱。云何无疑意解脱。等意解脱云何。答曰。等意解脱阿罗汉尽智。无学等见所可相应心脱已脱当脱。是谓等意解脱。无疑意解脱云何。答曰。无疑意法阿罗汉尽智无生智。无学等见所可相应心脱已脱当脱。是谓无疑意解脱。以何等故等意解脱言爱耶。答曰。等意解脱阿罗汉护此法。自爱取藏彼等意解脱。阿罗汉善自护爱取藏我于此法莫退。譬如母人有一子。爱忍常不离目。彼母人养护摄覆。此不寒不热不饥不渴无有众恼。如是等意解脱。阿罗汉此法自护取藏彼等意解脱。阿罗汉善自护取藏我莫于此法退。以是故等意解脱言爱也。诸等意解脱与尽智相应耶。答曰。或等意解脱不与尽智相应。云何等意解脱不与尽学相应。答曰。等意解脱阿罗汉无学等见所可相应。心脱已脱当脱(三世)。是谓等意解脱不与尽智相应。云何尽智相应非等意解脱。答曰。无疑法阿罗汉尽智所可相应心脱已脱当脱。是谓尽智相应非等意解脱。云何等意解脱尽智相应。答曰。等意解脱阿罗汉尽智所可相应。心脱已脱当脱。是谓等意解脱尽智相应。云何非等意解脱不尽智相应。答曰。无疑法阿罗汉无生智。无学等见所可相应心脱已脱当脱。是谓非等意解脱不尽智相应。诸无疑意解脱尽无生智相应耶。答曰。如是。诸与无生智相应尽无疑意解脱。颇有无疑意解脱不与无生智相应耶。答曰。有无疑法阿罗汉尽智。无学等见所可相应心脱已脱当脱。云何学明云何学智。学明云何。答曰。学慧也。学智云何。答曰。学八智也。云何无学明云何无学智。无学明云何。答曰。无学慧也。无学智云何。答曰。无学八智也。修行法时最初得何等。信佛耶法耶僧耶。答曰。修行苦法修行习法修行尽法修行道法佛法僧也。此四颠倒须陀洹几灭几未灭。答曰。一切灭也。此三三昧须陀洹几成就过去。几成就未来。几成就现在。答曰。尽成就未来。已灭不失即成就过去。若现在前成就现在。若道前过去一切彼道已修已猗耶。答曰。如是。若道过去。一切彼道已修已猗。颇有道已修已猗此道不过去耶。答曰。有未来道已修已猗也。若道未来。一切彼道不已修不已猗。答曰。或道未来。此道非不已修非不已猗。云何道未来此道非不已修非不已猗耶。答曰。未来道已修已猗。是谓道未来。此道非不已修。非不已猗也。云何道不已修不已猗此道不未来耶。答曰。未曾得道现在前。是为道不已修不已猗。此道不未来。云何道未来。此道不已修不已猗。答曰。若道未来不已修不已猗。是谓道未来此道不已修不已猗。云何道非未来。此道非不已修非不已猗。答曰。过去道本得现在前。是谓道非未来。此道非不已修非不已猗。若道现在前。一切彼道尽修猗耶。答曰。如是。若道现在前一切彼道尽修猗。颇道修猗此道不现在前耶。答曰。有如本未得道现在前。余未来彼种所修道也

阿毗昙知他人心智跋渠第三竟(梵本百三十二首卢也秦二千七十四言一万三千一百六十九言)

阿毗昙八犍度论卷第十阿毗昙八犍度论卷第十一

        迦旃延子造

        符秦罽宾三藏僧伽提婆共竺佛念译

    智犍度修智跋渠第四之一

  摄成就修缘　　缘灭作证智
  亦作无常念　　七处最在后

八智法智未知智知他人心智。等智苦。智习智尽智道智法智摄几智。乃至道智摄几智。若成就法智于此八智。成就几。不成就几。乃至成就道智于此八智。成就几。不成就几。若修法智彼修未知智耶。设修未知智有法智耶。若修法智时。有知他人心智等智苦智习智尽智道智。设修道智彼法智耶。若乃至修尽智有道智耶。设修道智有尽智耶。颇法智法智缘。颇法智知他人心智等智苦智习智尽智道智缘。颇道智道智缘。颇道智法智未知智知他人心智等智苦智习智尽智缘耶。法智法智有几缘缘。法智未知智知他人心智等智苦智习智尽智道智几缘缘。道智道智几缘缘。道智法智未知智知他人心智等智苦智习智尽智几缘缘。若诸结在欲界系。彼结法智灭耶。设结法智灭者是欲界系结耶。诸结在色无色界系。彼结未知智灭耶。设彼结未知智灭。是色无色界系结耶。诸结苦谛所断彼结苦智所断耶。设彼结苦智所断。彼结苦谛所断耶。诸结习谛尽谛道谛所断。彼结道智所断耶。设彼结道智所断。彼结道谛所断耶。诸结法智所灭法智。彼结得尽证耶。设彼结法智得尽证法智灭彼结耶。诸结未知智所灭未知智。彼结得尽证耶。设彼结未知智得尽证未知智灭彼结耶。诸结苦智习智尽智道智所灭道智彼结得尽证耶。设彼结道智得尽证道智灭彼结耶。眼根用几智知。乃至无色界思惟所断无明使用几智知。又世尊言。习无常想修行广布。尽欲爱。尽色爱无色爱。尽调尽憍慢尽无明。此想当言法智相应。未知智知他人心智等智苦智习智尽智道智。当言有觉有观耶。无觉有观耶无觉无观耶。当言乐根相应耶。喜根护根相应耶。当言空无相无愿。当言欲界系缘耶。色无色界系缘不系缘耶。又世尊言。比丘七处善三观义达于此法。得尽有漏分别色苦色习色尽色道迹。色味色患色弃出如实知之。此智当言法智耶。当言乃至道知耶。痛想行识亦如是。云何色尽。云何色弃出。色尽色弃出有何差别。云何痛想行。云何识尽。云何识弃出。识尽识弃出有何差别。此章义愿具演说

八智法智未知智知他人心智。等智苦智习智尽智。道智法智。摄法智五智。少有入知他人心智苦智习智尽智道智也。未知智摄未知智五智。少有入知他人心智苦智习智尽智道智也。知他人心智摄知他人心智四智。少有入法智未知智等智道智也。等智摄等智一智。少有入知他人心智也。苦智摄苦智二智。少有入法智未知智也。习智尽智亦如是。道智摄道智三智。少有入法智未知智知他人心智也(一摄门竟)。若成就法智。于此八智成就几不成就几。答曰。或三四五六七八。云何三。答曰。苦法智无知他人心智三(法苦等也)。知他人心智四(上三)。苦未知忍无知他人心智三。知他人心智四。苦未知智无知他人心智四。知他人心智五(仍习上)。习法忍无知他人心智四。知他人心智五。习法智无知他人心智五。知他人心智六。习未知忍习未知智尽法忍无知他人心智五知他人心智六。尽法智无知他人心智六。知他人心智七。尽未知忍尽未知智道法忍无知他人心智六。知他人心智七。道法智无知他人心智七。知他人心智八。道未知忍道未知智无知他人心智七。知他人心智八。若成就未知智于此八智。成就几。不成就几。答曰。或四五六七八。云何四。答曰。苦未知智无知他人心智四(法苦等)。知他人心智五。习法忍无知他人心智四。知他人心智五。习法智无知他人心智五。知他人心智六。习未知忍习未知智尽法忍无知他人心智五。知他人心智六。尽法智无知他人心智六。知他人心智七。尽未知忍尽未知智道法忍无知他人心智六。知他人心智七。道法智无知他人心智七。知他人心智八。道未知忍道未知智无知他人心智七。知他人心智八。若成就知他人心智。于此八智成就几。不成就几。答曰。或二四五六七八。云何二。答曰。凡夫人二(等智他心智也)。无垢人苦法忍现在前二。苦法智四。苦未知忍四。苦未知智五。习法忍五。习法智六。习未知忍习未知智尽法忍六。尽法智七。尽未知忍尽未知智道法忍七。道法智八。道未知忍道未知智八。若成就等智。于此八智成就几。不成就几。答曰。或一二三四五六七八。云何一。答曰。无知他人心智凡夫人一。无垢人苦法忍现在前一。知他人心智凡夫人二。无垢人苦法忍现在前二。苦法智无知他人心智三。知他人心智四。苦未知忍无知他人心智三。知他人心智四。苦未知智无知他人心智四。知他人心智五。习法忍无知他人心智四。知他人心智五。习法智无知他人心智五。知他人心智六。习未知忍习未知智尽法忍无知他人心智五。知他人心智六。尽法智无知他人心智六。知他人心智七。尽未知忍尽未知智道法忍无知他人心智六。知他人心智七。道法智无知他人心智七。知他人心智八。道未知忍道未知智无知他人心智七。知他人心智八。若成就苦智。于此八智成就几。不成就几。答曰。或三四五六七八。云何三。答曰。苦法智无知他人心智三。知他人心智四。苦未知忍无知他人心智三。知他人心智四。苦未知智无知他人心智四。知他人心智五。习法忍无知他人心智四。知他人心智五。习法智无知他人心智五。知他人心智六。习未知忍习未知智尽法忍无知他人心智五。知他人心智六。尽法智无知他人心智六。知他人心智七。尽未知忍尽未知智道法忍无知他人心智六。知他人心智七。道法智无知他人心智七。知他人心智八。道未知忍道未知智无知他人心智七。知他人心智八。若成就习。智于此八智成就几。不成就几。答曰。或五六七八。云何五。答曰。习法智无知他人心智五。知他人心智六。习未知忍习未知智尽法忍无知他人心智五。知他人心智六。尽法智无知他人心智六。知他人心智七。尽未知忍尽未知智道法忍无知他人心智六。知他人心智七。道法智无知他人心智七。知他人心智八。道未知忍道未知智无知他人心智七。知他人心智八。若成就尽智。于此八智成就几。不成就几。答曰。或六七八。云何六。答曰。尽法智无知他人心智六。知他人心智七。尽未知忍尽未知智道法忍无知他人心智六。知他人心智七。道法智无知他人心智七。知他人心智八。道未知忍道未知智无知他人心智七。知他人心智八。若成就道智于此八智成就几。不成就几。答曰。或七八。云何七。答曰。道法智无知他人心智七。知他人心智八。道未知忍道未知智无知他人心智七。知他人心智八(二成就门竟)。若修法智时彼未知智耶。答曰。或修法智非未知智。云何修法智非未知智耶。答曰。所修行苦法智习法智尽法智道法智。学见迹若阿罗汉。本得法智现在前。是谓修法智非未知智。云何修未知智非法智。答曰。所修行苦未知智习未知智尽未知智学见迹。若阿罗汉本得未知智现在前。是谓修未知智非法智。云何修法智未知智。答曰。所修行道未知智学见迹。若阿罗汉若本未得无漏智。若世俗智现在前。得是时修法智未知智。是谓修法智未知智。云何不修法智不修未知智。答曰。学见迹若阿罗汉本得世俗智现在前若本不得世俗智现在前。不得是时修法智未知智。一切凡夫人染污心无记心。入无想三昧入灭尽三昧。无想天一切忍现在前。不修法智不修未知智。是谓不修法智不修未知智。若修法智时彼知他人心智耶。答曰。或修法智非知他人心智。云何修法智非知他人心智。答曰。所修行苦法智习尽法智道法智无知他人心智所修行道未知智学见迹若阿罗汉。本得法智现在前。彼非知他人心智。若本不得无漏智现在前。得是时不修知他人心智。若本不得世俗智现在前。得是时修法智非知他人心智。是谓修法智非知他人心智。云何修知他人心智非法智。答曰。知他人心智凡夫人。若本得若本不得。知他人心智现在前。若本不得世俗智现在前彼非知他人心智。得是时修知他人心智。学见迹若阿罗汉。若本得知他人心智现在前此非法智。是谓修知他人心智非法智。云何修法智知他人心智。答曰。知他人心智所修行道。未知智学见迹若阿罗汉。本得法智现在前。修彼是知他人心智。若本不得无漏智现在前。得是时修法智知他人心智。若本不得世俗智现在前。得是时修法智知他人心智。是谓修法智知他人心智。云何不修法智非知他人心智。答曰。所修行苦未知智习尽未知智。学见迹若阿罗汉。本得无漏智现在前。彼非法智知他人心智。若本得世俗智现在前。彼非知他人心智。若本不得世俗智现在前。得是时。不得修法智知他人心智。一切无知他人心智。凡夫人染污心无记心。入无想三昧灭尽三昧。无想天一切忍现在前不修法智非知他人心智。是谓不修法智非知他人心智。若修法智时彼等智耶。答曰。或修法智非等智。云何修法智非等智。答曰。所修行苦法智习尽道法智修道未知智。学见迹若阿罗汉本得法智现在前。若本不得无漏智现在前。得是时修法智非等智。是谓修法智非等智。云何修等智非法智。答曰。凡夫人若本得若不得。世俗智现在前。所修行。苦未知智边。习尽未知智边。学见迹若阿罗汉。若本得若本不得世俗智现在前。不得是时修法智。是谓修等智非法智。云何修法智等智。答曰。学见迹若阿罗汉。本不得无漏智现在前。得是时修世俗智。若本不得世俗智现在前。得是时修无漏智。是谓修法智等智。云何不修法智等智。答曰。学见迹若阿罗汉。本得无漏智现在前彼非法智。一切染污心无记心。入无想三昧灭尽三昧。无想天一切忍现在前。不修法智等智。是谓不修法智等智。若修法智时彼苦智耶。答曰。或修法智非苦智。云何修法智非苦智。答曰。所修行习尽道法智学见迹若阿罗汉。本得法智现在前彼非苦智是谓修法智非苦智。云何修苦智非法智。答曰。所修行苦未知智学见迹若阿罗汉。本得苦智现在前彼非法智。是谓修苦智非法智。云何修法智苦智。答曰。所修行苦法智所修行道未知智。学见迹若阿罗汉。本得法智现在前。此是苦智若本不得无漏智若世俗智现在前。得是时修法智苦智。是谓修法智苦智。云何不修法智苦智。答曰。所修行习尽未知智。学见迹若阿罗汉。本得无漏智现在前。彼非法智亦非苦智。若本得若本不得世俗智现在前。不得是时不修法智苦智。一切凡夫人染污心无记心。入无想三昧灭尽三昧无想天一切忍现在前。不修法智苦智。是谓不修法智苦智。若修法智时彼习智耶。答曰。或修法智非习智。云何修法智非习智。答曰。所修行苦法智尽道法智。学见迹若阿罗汉。本得法智现在前此非习智。是谓修法智非习智。云何修习智非法智。答曰。所修行习未知智。学见迹若阿罗汉本得习智现在前此非法智。是谓修习智非法智。云何修法智习智。答曰。所修行习法智。所修行道未知智。学见迹若阿罗汉。本得法智现在前彼是习智。若本不得无漏智。若世俗智现在前。得是时修法智习智。是谓修法智习智。云何不修法智习智。答曰。所修行苦尽未知智。学见迹若阿罗汉。本得无漏智现在前此非法智习智。若本得若本不得世俗智现在前。不得是时修法智习智。一切凡夫人染污心无记心。入无想三昧灭尽三昧。无想天一切忍现在前。不修法智习智。是谓不修法智习智。若修法智时彼尽智耶。答曰。或修法智非尽智。云何修法智非尽智。答曰。所修行苦法智习道法智。学见迹若阿罗汉。本得法智现在前此非尽智。是谓修法智非尽智。云何修尽智非法智。答曰。所修行尽未知智。学见迹若阿罗汉。本得尽智现在前此非法智。是谓修尽智非法智。云何修法智尽智。答曰。所修行尽法智所修行道未知智。学见迹若阿罗汉。本得法智现在前此是尽智。若本不得世俗智。若无漏智现在前。得是时修法智尽智。是谓修法智尽智。云何不修法智尽智。答曰。所修行苦未知智习未知智。学见迹若阿罗汉。本得无漏智现在前此非法智尽智。若本得若本不得世俗智现在前。不得是时修法智尽智。一切凡夫人染污心无记心。入无想三昧灭尽三昧。无想天一切忍现在前。不修法智尽智。是谓不修法智尽智。若修法智时彼修道智耶。答曰。或修法智非道智。云何修法智非道智。答曰。所修行苦法智习尽法智。学见迹若阿罗汉。本得法智现在前此非道智。是谓修法智非道智。云何修道智非法智。答曰。学见迹若阿罗汉。本得道智现在前此非法智。是谓修道智非法智。云何修法智道智。答曰。所修行道法智所修行道未知智。学见迹若阿罗汉。本得法智现在前此是道智。若本不得世俗智。若无漏智现在前。得是时修法智道智。是谓修法智道智。云何不修法智道智。答曰。所修行苦未知智习尽未知智。学见迹若阿罗汉。本得无漏智现在前此非法智道智。若本得若本不得世俗智现在前。不得是时修法智道智。一切凡夫人染污心无记心。入无想三昧灭尽三昧。无想天一切忍现在前。不修法智道智是谓不修法智道智(法智竟)。若修未知智时彼知他人心智耶。答曰。或修未知智非知他人心智。云何修未知智非知他人心智。答曰。所修行苦未知智习尽未知智。无知他人心智。所修行道未知智。学见迹若阿罗汉。本得未知智现在前。此非知他人心智。若本不得无漏智现在前。得是时修未知智非知他人心智。若本不得世俗智现在前。得是时修未知智非知他人心智。是谓修未知智非知他人心智。云何修知他人心智非未知智。答曰。知他人心智凡夫人。若本得若本不得知他人心智现在前。若本不得世俗智现在前。此非知他人心智。得是时修知他人心智。学见迹若阿罗汉。本得知他人心智现在前此非未知智。是谓修知他人心智非未知智。云何修未知智知他人心智。答曰。知他人心智所修行道未知智。学见迹若阿罗汉。本得未知智现在前。此是知他人心智。若本不得无漏智。若世俗智现在前。得是时修未知智知他人心智。是谓修未知智知他人心智。云何不修未知智知他人心智。答曰。所修行苦法智习尽道法智。学见迹若阿罗汉。本得无漏智现在前。此非未知智知他人心智。若本得世俗智现在前。此非知他人心智。若本不得世俗智现在前。得是时不修未知智知他人心智。一切无知他人心智。凡夫人染污心无记心。入无想三昧灭尽三昧。无想天一切忍现在前。不修未知智知他人心智是谓不修未知智知他人心智。若修未知智时彼等智耶。答曰。或修未知智非等智。云何修未知智非等智。答曰。所修行道未知智。学见迹若阿罗汉。本得未知智现在前若本不得无漏智现在前。得是时修未知智非等智。是谓修未知智非等智。云何修等智非未知智。答曰。凡夫人若本得若本不得世俗智现在前。学见迹若阿罗汉。若本得若本不得世俗智现在前。得是时不修未知智。是谓修等智非未知智。云何修未知智等智。答曰。所修行苦未知智边。习尽未知智边。学见迹若阿罗汉。本不得世俗智现在前。得是时修未知智。若本不得无漏智现在前。得是时修等智。是谓修未知智等智。云何不修未知智等智。答曰。所修行苦法智习尽道法智。学见迹若阿罗汉。本得无漏智现在前此非未知智。一切染污心无记心。入无想三昧灭尽三昧。无想天一切忍现在前。不修未知智等智。是谓不修未知智等智。若修未知智时彼苦智耶。答曰。或修未知智非苦智。云何修未知智非苦智。答曰。所修行习未知智尽未知智。学见迹若阿罗汉。本得未知智现在前此非苦智。是谓修未知智非苦智。云何修苦智非未知智。答曰。所修行苦法智。学见迹若阿罗汉。本得苦智现在前此非未知智。是谓修苦智非未知智。云何修未知智苦智。答曰所修行苦未知智所修行道未知智。学见迹若阿罗汉。本得未知智现在前此是苦智。若本不得世俗智。若无漏智现在前。得是时修未知智苦智。是谓修未知智苦智。云何不修未知智苦智。答曰。所修行习尽道法智。学见迹若阿罗汉。本得无漏智现在前此非未知智苦智。若本得若本不得世俗智现在前。得是时不修未知智苦智。一切凡夫人染污心无记心入无想三昧灭尽三昧。无想天一切忍现在前。不修未知智苦智。是谓不修未知智苦智。若修未知智时彼习智耶。答曰。或修未知智非习智。云何修未知智非习智。答曰。所修行苦未知智尽未知智。学见迹若阿罗汉。本得未知智现在前此非习智。是谓修未知智非习智。云何修习智非未知智。答曰。所修行习法智。学见迹若阿罗汉。本得习智现在前此非未知智。是谓修习智非未知智。云何修未知智习智。答曰。所修行习未知智道未知智。学见迹若阿罗汉。本得未知智现在前此是习智。若本不得世俗智。若无漏智现在前。得是时修未知智习智。是谓修未知智习智。云何不修未知智习智。答曰。所修行苦法智尽道法智。学见迹若阿罗汉。本得无漏智现在前。此非未知智习智。若本得若本不得世俗智现在前。得是时不修未知智习智。一切凡夫人染污心无记心。入无想三昧灭尽三昧。无想天一切忍现在前。不修未知智习智。是谓不修未知智习智。若修未知智时彼尽智耶。答曰。或修未知智非尽智。云何修未知智非尽智。答曰。所修行苦未知智习未知智。学见迹若阿罗汉。本得未知智现在前此非尽智。是谓修未知智非尽智。云何修尽智非未知智。答曰。所修行尽法智。学见迹若阿罗汉。本得尽智现在前此非未知智。是谓修尽。智非未知智。云何修未知智尽智。答曰。所修行尽未知智道未知智。学见迹若阿罗汉。本得未知智现在前此是尽智。若本不得世俗智。若无漏智现在前。得是时修未知智尽智。是谓修未知智尽智。云何不修未知智尽智。答曰。所修行苦法智习道法智。学见迹若阿罗汉本得无漏智现在前。此非未知智尽智。若本得若本不得世俗智现在前。得是时不修未知智尽智。一切凡夫人染污心无记心入无想三昧灭尽三昧。无想天一切忍现在前。不修未知智尽智。是谓不修未知智。尽智若修未知智时彼道智耶。答曰。或修未知智非道智。云何修未知智非道智。答曰所修行苦未知智习尽未知智。学见迹若阿罗汉。本得未知智现在前此非道智。是谓修未知智非道智。云何修道智非未知智。答曰。所修行道法智。学见迹若阿罗汉。本得道智现在前此非未知智。是谓修道智非未知智。云何修未知智道智。答曰。所修行道未知智。学见迹若阿罗汉。本得未知智现在前此是道智。若本不得世俗智若无漏智现在前。得是时修未知智道智。是谓修未知智道智。云何不修未知智道智。答曰。所修行苦法智习尽法智。学见迹若阿罗汉。本得无漏智现在前。此非未知智道智。若本得若本不得世俗智现在前。得是时不修未知智道智。一切凡夫人染污心无记心。入无想三昧灭尽三昧。无想天一切忍现在前。不修未知智道智。是谓不修未知智道智(未知智竟)

若修知他人心智时彼等智耶。答曰。或修知他人心智非等智。云何修知他人心智非等智。答曰。知他人心智所修行道未知智。学见迹若阿罗汉本得无漏智现在前。此是知他人心智。若本不得无漏智现在前。得是时修知他人心智非等智。是谓修知他人心智非等智。云何修等智非知他人心智。答曰。无知他人心智。凡夫人若本得若本不得世俗智现在前。所修行苦未知智边。习尽未知智边。学见迹若阿罗汉。本得世俗智现在前。此非知他人心智。若本不得世俗智现在前。得是时不修知他人心智。是谓修等智非知他人心智。云何修知他人心智等智。答曰。知他人心智凡夫人。若本得若本不得知他人心智现在前。若本不得世俗智现在前。此非知他人心智。得是时修知他人心智。学见迹若阿罗汉。本得知他人心智现在前此是等智。若本不得世俗智现在前。得是时修知他人心智。若本不得无漏智现在前。得是时修知他人心智等智。是谓修知他人心智等智。云何不修知他人心智等智。答曰。所修行苦法智习尽道法智。无知他人心智。所修行道未知智。学见迹若阿罗汉。本得无漏智现在前此非知他人心智。若本不得无漏智现在前。得是时不修知他人心智等智。一切无知他人心智。凡夫人染污心无记心。入无想三昧灭尽三昧。无想天一切忍现在前。不修知他人心智等智。是谓不修知他人心智等智。若修知他人心智时彼苦智耶。答曰。或修知他人心智非苦智。云何修知他人心智非苦智。答曰。知他人心智凡夫人。若本得若本不得。知他人心智现在前。若本不得世俗智现在前。此非知他人心智。得是时修知他人心智。学见迹若阿罗汉。本得知他人心智现在前。是谓修知他人心智非苦智。云何修苦智非知他人心智。答曰。所修行苦法智苦未知智。无知他人心智。所修行道未知智。学见迹若阿罗汉。本得苦智现在前。若本不得无漏智现在前。不得是时修知他人心智。若本不得世俗智现在前。得是时修苦智非知他人心智。是谓修苦智非知他人心智。云何修知他人心智苦智。答曰。知他人心智所修行道未知智。学见迹若阿罗汉。本不得无漏智。若世俗智现在前。得是时修知他人心智苦智。是谓修知他人心智苦智

阿毗昙八揵度论卷第十一阿毗昙八揵度论卷第十二

        迦旃延子造

        符秦罽宾三藏僧伽提婆共竺佛念译

    智揵度之四修智跋渠之余

云何不修知他人心智苦智。答曰。所修行习法智习未知智尽法智尽未知智道法智。学见迹若阿罗汉。本得无漏智现在。前此非知他人心智苦智。本得世俗智现在前。此非知他人心智。若本不得世俗智现在前。得是时不修知他人心智苦智。一切无知他人心智。凡夫人染污心无记心。入无想三昧灭尽三昧。无想天一切忍现在前。不修知他人心智苦智。是谓不修知他人心智苦智。若修知他人心智时彼习智耶。答曰。或修知他人心智非习智。云何修知他人心智非习智。答曰。知他人心智凡夫人若本得若本不得。知他人心智现在前。若本不得世俗智现在前。此非知他人心智。得是时修知他人心智。学见迹若阿罗汉。本得知他人心智现在前。是谓修知他人心智非习智。云何修习智非知他人心智。答曰。所修行习法智习未知智无知他人心智所修行。道未知智学见。迹若阿罗汉本得。习智现在前。若本不得无漏智现在前不得是时不修知他。人心智若本不得世俗。智现在前得是时修习智非知他人心智是。谓修习智非知他人心智。云何修知他人心智习智。答曰。知他人心智所修行道未知智。学见迹若阿罗汉。本不得世俗智。若无漏智现在前。得是时修知他人心智习智。是谓修知他人心智习智。云何不修知他人心智习智。答曰。所修行苦法智苦未知智尽法智尽未知智道法智。学见迹若阿罗汉。本得无漏智现在前。此非知他人心智若本不得世俗智现在前得是时不修知他人心智习智。一切无知他人心智。凡夫人染污心无记心。入无想三昧灭尽三昧。无想天一切忍现在前。不修知他人心智习智。是谓不修知他人心智习智。若修知他人心智时彼尽智耶。答曰。或修知他人心智非尽智。云何修知他人心智非尽智。答曰。知他人心智凡夫人。若本得若本不得知他人心智现在前。若本不得世俗智现在前。此非知他人心智。得是时修知他人心智。学见迹若阿罗汉。本得知他人心智现在前。是谓修知他人心智非尽智。云何修尽智非知他人心智。答曰。所修行尽法智尽未知智。无知他人心智。所修行道未知智。学见迹若阿罗汉。本得尽智现在前若本不得无漏智现在前。得是时不修知他人心智。若本不得世俗智现在前。得是时修尽智非知他人心智。是谓修尽智非知他人心智。云何修知他人心智尽智。答曰。知他人心智所修行道未知智。学见迹若阿罗汉。本不得世俗智。若无漏智现在前。得是时修知他人心智尽智。是谓修知他人心智尽智。云何不修知他人心智尽智。答曰。所修行苦法智苦未知智习法智习未知智道法智。学见迹若阿罗汉。本得无漏智现在前。此非知他人心智尽智。若本得世俗智现在前。此非知他人心智。若本不得世俗智现在前。得是时不修知他人心智尽智。一切无知他人心智。凡夫人染污心无记心。入无想三昧灭尽三昧。无想天一切忍现在前。不修知他人心智尽智。是谓不修知他人心智尽智。若修知他人心智时彼道智耶。答曰。或修知他人心智非道智。云何修知他人心智非道智。答曰。知他人心智凡夫人。若本得若本不得知他人心智现在前。若本不得世俗智现在前。此非知他人心智。得是时修知他人心智。学见迹若阿罗汉本得知他人心智现在前此非道智。是谓修知他人心智非道智。云何修道智非知他人心智。答曰。所修行道法智无知他人心智。所修行道未知智。学见迹若阿罗汉。本得道智现在前。此非知他人心智。若本不得无漏智现在前。不得是时修知他人心智。若本不得世俗智现在前。得是时修道智非知他人心智。是谓修道智非知他人心智。云何修知他人心智道智。答曰知他人心智所修行道未知智。学见迹若阿罗汉。本得知他人心智此是道智。若本不得世俗智若无漏智现在前。得是时修知他人心智道智。是谓修知他人心智道智。云何不修知他人心智道智。答曰。所修行苦法智苦未知智。习法智习未知智。尽法智尽未知智。学见迹若阿罗汉。本得无漏智现在前。此非知他人心智道智。若本得世俗智现在前。此非知他人心智。若本不得世俗智现在前。不得是时修知他人心智道智。一切无知他人心智。凡夫人染污心无记心。入无想三昧灭尽三昧。无想天一切忍现在前。不修知他人心智道智。是谓不修知他人心智道智。若修等智时彼苦智耶。答曰。或修等智非苦智。云何修等智非苦智。答曰。凡夫人若本得若本不得。世俗智现在前。所修行习尽未知智边。学见迹若阿罗汉。若本得若本不得世俗智现在前。不得是时修苦智。是谓修等智非苦智。云何修苦智非等智。答曰。所修行苦法智。学见迹若阿罗汉。本得苦智现在前。若本不得无漏智现在前。不得是时修等智。是谓修苦智非等智。云何修等智苦智。答曰。所修行苦未知智边。学见迹若阿罗汉。本不得世俗智若无漏智现在前。得是时修等智苦智。是谓修等智苦智。云何不修等智苦智。答曰。所修行习法智尽道法智。学见迹若阿罗汉。本得无漏智现在前此非苦智。一切染污心无记心。入无想三昧灭尽三昧。无想天一切忍现在前。不修等智苦智。是谓不修等智苦智。若修等智时彼习智耶。答曰。或修等智非习智。云何修等智非习智。答曰。凡夫人若本得若本不得世俗智现在前。所修行苦未知智边。尽未知智边。学见迹若阿罗汉。本得若本不得世俗智现在前。得是时不修习智。是谓修等智非习智。云何修习智非等智。答曰。所修行习法智道未知智。学见迹若阿罗汉。本得习智现在前。若本不得无漏智现在前。得是时不修等智。是谓修习智非等智。云何修等智习智。答曰。所修行习未知智边。学见迹若阿罗汉。本不得世俗智若无漏智现在前。得是时修等智习智。是谓修等智习智。云何不修等智习智。答曰。所修行苦法智尽道法智。学见迹若阿罗汉。本得无漏智现在前此非习智。一切染污心无记心。入无想三昧灭尽三昧。无想天一切忍现在前。不修等智习智。是谓不修等智习智。若修等智时彼尽智耶。答曰。或修等智非尽智。云何修等智非尽智。答曰。凡夫人若本得若本不得。世俗智现在前。所修行苦未知智边。习未知智边。学见迹若阿罗汉。若本得若本不得世俗智现在前。得是时不修尽智。是谓修等智非尽智。云何修尽智非等智。答曰。所修行尽法智道未知智。学见迹若阿罗汉。本得尽智现在前。若本不得无漏智现在前。得是时不修等智。是谓修尽智非等智。云何修等智尽智。答曰。所修行尽未知智边。学见迹若阿罗汉。若本不得世俗智。若无漏智现在前。得是时修等智尽智。是谓修等智尽智。云何不修等智尽智。答曰。所修行苦法智习法智道法智。学见迹若阿罗汉。本得无漏智现在前此非尽智。一切染污心无记心。入无想定灭尽定。无想天一切忍现在前。不修等智尽智。是谓不修等智尽智。若修等智时彼道智耶。答曰。或修等智非道智。云何修等智非道智。答曰。凡夫人若本得若本不得。世俗智现在前。所修行苦未知智边。习尽未知智边。学见迹若阿罗汉。若本得若本不得。世俗智现在前。得是时不修道智。是谓修等智非道智。云何修道智非等智。答曰。所修行道法智道未知智。学见迹若阿罗汉本得道智现在前。若本不得无漏智现在前。得是时不修等智。是谓修道智非等智。云何修等智道智。答曰。学见迹若阿罗汉。本不得世俗智。若无漏智现在前。得是时修等智道智。是谓修等智道智。云何不修等智道智。答曰。所修行苦法智习法智尽法智。学见迹若阿罗汉。本得无漏智现在前此非道智。一切染污心无记心。入无想三昧灭尽三昧。无想天一切忍现在前。不修等智道智。是谓不修等智道智。若修苦智时彼习智耶。答曰。或修苦智非习智。云何修苦智非习智。答曰。所修行苦法智苦未知智。学见迹若阿罗汉。本得苦智现在前。是谓修苦智非习智。云何修习智非苦智。答曰。所修行习法智习未知智。学见迹若阿罗汉。本得习智现在前。是谓修习智非苦智。云何修苦智习智。答曰。所修行道未知智。学见迹若阿罗汉。本不得世俗智。若无漏智现在前。得是时修苦智习智。是谓修苦智习智。云何不修苦智习智。答曰。所修行尽法智尽未知智道法智。学见迹若阿罗汉。本得无漏智现在前。此非苦智习智。若本得若本不得世俗智现在前。不得是时修苦智习智。是谓不修苦智习智。一切凡夫人染污心无记心。入无想三昧灭尽三昧。无想天一切忍现在前。不修苦智习智。是谓不修苦智习智。若修苦智时彼尽智耶。答曰。或修苦智非尽智。云何修苦智非尽智。答曰。所修行苦法智苦未知智。学见迹若阿罗汉。本得苦智现在前。是谓修苦智非尽智。云何修尽智非苦智。答曰。所修行尽法智尽未知智。学见迹若阿罗汉。本得尽智现在前。是谓修尽智非苦智。云何修苦智尽智。答曰。所修行道未知智。学见迹若阿罗汉。本不得世俗智。若无漏智现在前。得是时修苦智尽智。是谓修苦智尽智。云何不修苦智尽智。答曰。所修行习法智习未知智道法智。学见迹若阿罗汉。本得无漏智现在前。此非苦智尽智。若本得若本不得世俗智现在前。不得是时修苦智尽智。一切凡夫人染污心无记心。入无想三昧灭尽三昧。无想天一切忍现在前。不修苦智尽智。是谓不修苦智尽智。若修苦智时彼道智耶。答曰。或修苦智非道智。云何修苦智非道智。答曰。所修行苦法智苦未知智。学见迹若阿罗汉。本得苦智现在前。是谓修苦智非道智。云何修道智非苦智。答曰。所修行道法智。学见迹若阿罗汉。本得道智现在前。是谓修道智非苦智。云何修苦智道智。答曰。所修行道未知智。学见迹若阿罗汉。本不得无漏智。若世俗智现在前。得是时修苦智道智。是谓修苦智道智。云何不修苦智道智。答曰。所修行习法智习未知智。尽法智尽未知智。学见迹若阿罗汉。本得无漏智现在前。此非苦智道智。若本得若本不得世俗智现在前。不得是时修苦智道智。一切凡夫人染污心无记心。入无想三昧灭尽三昧。无想天一切忍现在前。不修苦智道智。是谓不修苦智道智。若修习智时彼尽智耶。答曰。或修习智非尽智。云何修习智非尽智。答曰。所修行习法智习未知智。学见迹若阿罗汉。本得习智现在前。是谓修习智非尽智。云何修尽智非习智。答曰。所修行尽法智尽未知智。学见迹若阿罗汉。本得尽智现在前。是谓修尽智非习智。云何修习智尽智。答曰。所修行道未知智。学见迹若阿罗汉。若本不得世俗智。若无漏智现在前。得是时修习智尽智。是谓修习智尽智。云何不修习智尽智。答曰。所修行苦法智苦未知智道法智。学见迹若阿罗汉。本得无漏智现在前。此非习智尽智。若本得若本不得世俗智现在前。不得是时修习智尽智。一切凡夫人染污心无记心。入无想三昧灭尽三昧。无想天一切忍现在前。不修习智尽智。是谓不修习智尽智。若修习智时彼道智耶。答曰。或修习智非道智。云何修习智非道智。答曰。所修行习法智习未知智。学见迹若阿罗汉。本得习智现在前。是谓修习智非道智。云何修道智非习智。答曰。所修行道法智。学见迹若阿罗汉。本得道智现在前。是谓修道智非习智。云何修习智道智。答曰。所修行道未知智。学见迹若阿罗汉。本不得无漏智。若世俗智现在前。得是时修习智道智。是谓修习智道智。云何不修习智道智。答曰。所修行苦法智苦未知智。尽法智尽未知智。学见迹若阿罗汉。本得无漏智现在前。此非习智道智。若本得若本不得世俗智现在前。不得是时修习智道智。一切凡夫人染污心无记心。入无想三昧灭尽三昧。无想天一切忍现在前。不修习智道智。是谓不修习智道智。若修尽智时彼道智耶。答曰。或修尽智非道智。云何修尽智非道智。答曰。所修行尽法智尽未知智。学见迹若阿罗汉。本得尽智现在前。是谓修尽智非道智。云何修道智非尽智。答曰。所修行道法智。学见迹若阿罗汉。本得道智现在前。是谓修道智非尽智。云何修尽智道智。答曰。所修行道未知智。学见迹若阿罗汉。本不得世俗智若无漏智现在前。得是时修尽智道智。是谓修尽智道智。云何不修尽智道智。答曰。所修行苦法智苦未知智。习法智习未知智。学见迹若阿罗汉。本得无漏智现在前。此非尽智道智。若本得若本不得世俗智现在前不得是时修尽智道智。一切凡夫人染污心无记心。入无想三昧灭尽三昧。无想天一切忍现在前。不修尽智道智。是谓不修尽智道智(三修智门竟)

颇法智法智缘耶。答曰。有未知智无缘余残有缘。颇未知智未知智缘耶。答曰。有法智无缘余残有缘。颇知他人心智知他人心智缘耶。答曰。有余残有缘。颇等智等智缘耶。答曰。有余残有缘。颇苦智苦智缘耶。答曰。无也。知他人心智等智有缘余残无缘。习智亦如是。颇尽智尽智缘耶。答曰。无余残亦无缘。颇道智道智缘耶。答曰。有等智无缘。余残有缘(四缘起门)法智彼法智因。次第缘增上未知智因。次第增上无缘。知他人心智因。次第缘增上等智。次第缘增上无因也。苦智习尽智因。次第增上无缘道智因。次第缘增上未知智。彼未知智因。次第缘增上知他人心智因。次第缘增上等智。次第缘增上无因。苦智习智尽智因。次第增上无缘道智因。次第缘增上(颇似习四)法智因。次第增上无缘。知他人心智。彼知他人心智因。次第缘增上等智因。次第缘增上苦智习智因。次第缘增上若有因无缘。若有缘无因。尽智因。次第增上无缘道智法智未知智因。次第缘增上等智。彼等智因。次第缘增上苦智习智。次第缘增上无因尽智道智。次第增上无因无缘法智未知智。次第缘增上无因。知他人心智因。次第缘增上苦智。彼苦智因。次第增上无缘。习智尽智因。次第增上无缘。道智法智未知智知他人心智因。次第缘增上等智。次第缘增上无因。习智尽智亦如是。道智彼道智因。次第缘增上法智未知智知他人心智因。次第缘增上等智。次第缘增上无因。苦智习智尽智因。次第增上无缘。诸结在欲界系。彼结法智灭耶。答曰。或结欲界系。彼结非法智灭。云何结在欲界系。彼结非法智灭耶。答曰。诸结欲界系忍灭亦余智亦不灭。是谓结欲界系此结非法智灭。云何结法智灭。此结非欲界系。答曰。诸结色无色界系法智灭。是谓结法智灭。此结不欲界系。云何结欲界系彼结法智灭。答曰。诸结欲界系法智灭。是谓结欲界系彼结法智灭。云何诸结不欲界系。彼结非法智灭。答曰。诸结色无色界系忍灭。亦余智亦不灭。是谓结不欲界系彼结非法智灭。诸结色无色界系。彼结未知智灭耶。答曰。如是。诸结未知智灭。彼结色无色界系。颇结色无色界系。彼结非未知智灭耶。答曰。有诸结色无色界系忍灭。亦余智亦不灭。诸结见苦断彼结苦智灭耶。答曰。彼结非苦智灭。彼结忍灭。设诸结苦智灭彼结见苦断耶。答曰。彼结非见苦断。彼结思惟断。诸结见习尽道断彼结道智灭耶。答曰。彼结非道智断彼结忍灭。设诸结道智灭彼结见道断耶。答曰。彼结非见道断彼结思惟灭(六灭法门)诸结法智灭彼结法智尽作证耶。答曰。如是。诸结法智灭彼结法智尽作证。颇结法智尽作证。彼结非法智灭耶。答曰。有诸结忍灭亦余智。彼结法智尽作证。诸结未知智灭。彼结未知智尽作证耶。答曰。如是。诸结未知智灭。彼结未知智尽作证。颇结未知智尽作证。彼结非未知智灭耶。答曰。有诸结忍灭亦余智。彼结未知智尽作证。诸结苦智习尽道智灭。彼结道智尽作证耶。答曰。如是。诸结道智灭。彼结道智尽作证。颇结道智尽作证。彼结非道智灭耶。答曰。有诸结忍灭亦余智。彼结道智尽作证(七正灭门)。眼根七智知。除知他人心智。尽智道智耳鼻舌身根亦如是。意根九智知除尽智。乐根喜根护根信精进念定慧根亦复如是。男根女根六智知。除未知智知他人心智尽智道智。命根七智知。除知他人心智尽智道智。苦根忧根七智知。除未知智尽智道智。未知根已知根无知根。七智知。除苦智习智尽智。眼持耳鼻舌身持。色声细滑持。七智知。除知他人心智尽智道智。眼识耳识身识持八智知。除尽智道智。香持味持六智知。除未知智知他人心智尽智道智。鼻识舌识持七智知。除未知智尽智道智。意持意识持九智知。除尽智。法持十智知。眼入耳鼻舌身入色声细滑入七智知。除知他人心智尽智道智。香入味入六智知。除未知智知他人心智尽智道智。意入九智知除尽智。法入十智知。色阴八智知。除知他人心智尽智。痛想行识阴九智知。除尽智。色盛阴七智知。除知他人心智尽智道智。痛想行识盛阴八智知。除尽智道智。地种乃至空种七智知。除知他人心智尽智道智。识种八智知。除尽智道智。色法八智知。除知他人心智尽智。无色法十智知。可见法有对法七智知。除知他人心智尽智道智。不可见法无对法十智知。有漏法八智知。除尽智道智。无漏法八智知。除苦智习智。有为法九智知。除尽智。无为法六智知。除知他人心智苦智习智道智。过去未来现在法九智知。除尽智。善法十智知不善法七智知。除未知智尽智道智。无记法八智知。除尽智道智。欲界系法七智知。除未知智尽智道智。色界系法七智知。除法智尽智道智。无色界系法六智知。除法智知他人心智尽智道智。学法无学法七智知。除苦智习智尽智。非学非无学法九智知。除道智。见谛所断法思惟所断法八智知。除尽智道智。无断法八智知。除苦智习智。苦谛习谛八智知。除尽智道智。尽谛六智知。除知他人心智苦智习智道智。道谛七智知。除苦智习智尽智。禅九智知。除尽智。四等七智知。除法智尽智道智。无色中空处识处不用处七智知。除法智知他人心智尽智。有想无想处六智知。除法智知他人心智尽智道智。初第二第三解脱八除入八一切入七智知。除法智尽智道智。空处解脱识处解脱不用处解脱七智知。除法智知他人心智尽智。有想无想解脱灭尽解脱六智知。除法智知他人心智尽智道智。空处一切入识处一切入亦如是。法智六智知除未知智苦智习智尽智。未知智六智知。除法智苦智习智尽智。知他人心智九智知。除尽智。等智八智知。除尽智道智。苦智习智尽智道智空无愿无相七智知。除苦智习智尽智。身见戒盗疑八智知。除尽智道智。贪嗔恚愚痴及欲漏七智知。除未知智尽智道智。有漏七智知。除法智尽智道智。余残八智知除尽智道智。流中欲流七智知。除未知智尽智道智。有流七智知。除法智尽智道智。余残八智知。除尽智道智。枙亦如是。受中欲受七智知。除未知智尽智道智。我受七智知。除法智尽智道智。余残八智知。除尽智道智。缚中欲爱身缚嗔恚身缚七智知。除未知智尽智。道智。余残八智知。除尽智道智。盖及嗔恚结悭结嫉结七智知。除未知智尽智道智。余残八智知。除尽智道智。下分中贪欲嗔恚七智知。除未知智尽智道智。余残及五见八智知。除尽智道智。爱身中鼻舌更爱七智知。除未知智尽智道智。余残八智知。除尽智道智。使中贪欲使嗔恚使七智知。除未知智尽智道智。有爱使七智知。除法智尽智道智。余残八智知。除尽智道智。结中嗔恚结悭结嫉结七智知。除未知智尽智道智。余残八智知。除尽智道智。九十八使欲界七智知。除未知智尽智道智。色界七智知。除法智尽智道智无色界六智知。除法智知他人心智尽智道智(八智知门)

又世尊言。习无常想修行广布尽欲爱尽。此想当言法智相应苦智相应。当言有觉有观。当言护根相应。当言无愿相应。当言欲界系缘尽色界爱尽。此想当言未知智相应苦智相应。或有觉有观或无觉有观或无觉无观。或乐根相应或喜根相应或护根相应。当言无愿相应。当言色界系缘尽无色界爱尽。此想当言未知智相应苦智相应。或有觉有观或无觉有观或无觉无观。或乐根相应或喜根护根相应。当言无愿相应。当言无色界系缘尽憍慢尽无明。此想或法智相应。或未知智相应苦智相应。或有觉有观。或无觉有观。或无觉无观。或乐根相应。或喜根护根相应。当言无愿相应。或欲界系缘。或色无色界系缘尽(九无常想门)

又世尊言。比丘七处善三种观义达。于此法得尽有漏。知色苦四智法智未知智苦智等智。色习四智法智未知智习智等智。色尽四智法智未知智尽智等智。色尽道迹四智法智未知智道智等智。色味四智法智未知智习智等智。色患四智法智未知智苦智等智。色弃出四智法智未知智尽智等智。痛想行识亦如是。云何色尽云何色弃。出色尽云何。答曰。若爱色具彼若灭是谓色尽。诸余色缘爱彼若灭是谓色弃出。复次垢色具彼若灭是谓色尽。诸余色缘垢彼若灭是谓色弃出。复次若爱若垢色具。彼若灭是谓色尽。诸余色缘若爱若垢彼若灭是谓色弃出。色尽色弃出。是谓差别。痛想行识尽是谓差别

阿毗昙修智品第四竟(梵本九百三十首卢秦一万五千九百七十二言)

阿毗昙八犍度论卷第十二阿毗昙八犍度论卷第十三

        迦旃延子造

        符秦罽宾三藏僧伽提婆共竺佛念译

    智犍度智相应跋渠第五之一

  人智三昧根　　觉意道相应
  二智种一行　　六小七大七

七人八智三三昧三根七觉意八道种智相应。及种二智种一行。历六二七。七人坚信坚法信解脱见到身证慧解脱俱解脱。八智法智未知智知他人心智等智苦智习智尽智道智。三三昧空无愿无相。三根未知根已知根无知根。七觉意念觉意择法觉意精进觉意喜觉意猗觉意定觉意护觉意。八道种等。见等志等语等业等活等方便等念等定智相应。及种四十四智种。七十七智种。一行六七大七。七人坚信坚法信解脱见到身证慧解脱俱解脱。八智法智未知智知他人心智等智苦智习尽道智。坚信人于此八智。成就几。不成就几。乃至俱解脱人于此八智。成就几。不成就几。坚信人于此八智。几过去成就。几未来成就。几现在成就。乃至俱解脱人于此八智。几成就过去。几成就未来。几成就现在。坚信人法智现在前时。几智现在前。乃至道智现在前时。几智现在前。乃至俱解脱人法智现在前时。几智现在前乃至道智现在前时。几智现在前。坚信人于此三三昧。成就几。不成就几。乃至俱解脱人于此三三昧。成就几。不成就几。坚信人于此三三昧。几成就过去。几成就未来。几成就现在。乃至俱解脱人于此三三昧。几成就过去。几成就未来。几成就现在。坚信人空三昧现在前时。几智现在前。无愿无相三昧现在前时。几智现在前。乃至俱解脱人空三昧现在前时。几智现在前。无愿无相三昧现在前时。几智现在前。坚信人未知根现在前时。几智现在前。坚法人亦如是。俱解脱人已知根现在前时。几智现在前。见到身证亦如是。慧解脱人无知根现在前时。几智现在前。俱解脱亦如是。坚信人念觉意现在前时。几智现在前。乃至护觉意现在前时。几智现在前。乃至俱解脱人念觉意现在前时。几智现在前。乃至护觉意现在前时。几智现在前。坚信人等见现在前时。几智现在前。乃至等定现在前时。几智现在前。乃至俱解脱人等见现在前时。几智现在前。乃至等定现在前时。几智现在前。诸法法智相应彼未知智耶。设诸法未知智相应。彼法智耶。诸法法智相应。彼知他人心智。等智苦智习尽道智。空无愿无相。未知根已知根无知根。念觉意择法精进喜猗定护觉意。等见等志等方便等念等定耶。设诸法等定相应彼法智耶。诸法乃至等念相应彼等定耶。设诸法等定相应彼等念耶。又世尊言。当说四十四智种。老死苦智。老死习智。老死尽智。老死尽道迹智。此智当言法智耶。乃至道智耶。生有乃至行智亦如是。又世尊言。当说七十七智种。生缘老死知智。不缘余生缘老死知智。过去久远生缘老死知智。不缘余过去久远生缘老死知智。未来久远生缘老死知智。不余缘未来久远生缘老死知智。如法界住智。无常有为心所因缘生尽法。变易法。无欲法。灭法。散法。断智慧法。此智当言法智乃至道智耶。乃至无明缘行知智亦如是。若成就法智彼未知智耶。设成就未知智彼法智耶。若成就法智彼知他人心智等智苦智习尽道智耶。设成就道智彼法智耶。乃至成就尽智彼道智耶。设成就道智彼尽智耶(一行竟)。若成就过去法智。彼未来耶。设彼未来彼过去耶。若彼过去彼现在耶。设彼现在彼过去耶。若彼未来彼现在耶。设彼现在彼未来耶。若彼过去彼未来现在耶设彼未来现在彼过去耶。若彼未来彼过去现在耶。设彼过去现在彼未来耶。若彼现在彼过去未来耶。设彼过去未来彼现在耶(历六竟)。乃至道智亦如是。若成就过去法智彼过去未知智耶。设成就过去未知智。彼过去法智耶。若成就过去法智。彼未来未知智耶。设彼未来未知智。彼过去法智耶。若成就过去法智。彼现在未知智耶。设彼现在未知智。彼过去法智耶。若成就过去法智。彼过去现在未知智耶。设彼过去现在未知智。彼过去法智耶。若成就过去法智。彼未来现在未知智耶。设彼未来现在未知智。彼过去法智耶。若成就过去法智。彼过去未来未知智耶。设彼过去未来未知智。彼过去法智耶。若成就过去法智。彼过去未来现在未知智耶。设彼过去未来现在未知智。彼过去法智耶。乃至道智亦如是(七竟)。过去法智过去未知智。过去知他人心智(一也)。未来(二也)。现在(三也)。过去现在(四也)。未来现在(五也)。过去未来(六也)。过去未来现在知他人心智(七也)。乃至道智亦如是。此章义愿具演说

七人。坚信坚法信解脱见到身证慧解脱俱解脱。八智。法智未知智知他人心智等智苦智习尽道智。坚信人于此八智。成就几不成就几。答曰。或一二三四五六七八。云何一。答曰。苦法忍。无知他人心智。一知他人心智。二苦法智无知他人心智。三知他人心智。四苦未知忍。无知他人心智三知他人心智。四苦未知智。无知他人心智。四知他人心智。五习法忍。无知他人心智四知他人心智。五习法智。无知他人心智。五知他人心智。六习未知忍习。未知智尽法忍。无知他人心智。五知他人心智。六尽法智无知他人心智。六知他人心智。七尽未知忍尽未知智道法忍。无知他人心智。六知他人心智。七道法智。无知他人心智。七知他人心智。八道未知忍。无知他人心智。七知他人心智。八坚法亦如是。信解脱人于此八智。成就几。不成就几。答曰。或七或八。无知他人心智。七知他人心智。八见到亦如是。身证慧解脱俱解脱一切成就(成就竟)。坚信人于此八智。成就过去几。未来几。现在几。答曰。苦法忍。无知他人心智。过去未来一。现在无。知他人心智。过去未来二。现在无。苦法智。无知他人心智。过去一。未来三。现在二。知他人心智。过去二。未来四。现在二。苦未知忍无知他人心智。过去未来三。现在无。知他人心智。过去未来四。现在无。苦未知智。无知他人心智。过去三。未来四现在二。知他人心智。过去四。未来五。现在二。习法忍。无知他人心智。过去未来四。现在无。知他人心智。过去未来五。现在无。习法智。无知他人心智。过去四。未来五。现在二。知他人心智。过去五。未来六。现在二。习未知忍。无知他人心智。过去未来五。现在无也。知他人心智。过去未来六。现在无。习未知智。无知他人心智。过去未来五。现在二。知他人心智。过去未来六。现在二。尽法忍。无知他人心智。过去未来五。现在无也。知他人心智。过去未来六。现在无。尽法智。无知他人心智。过去五。未来六。现在二。知他人心智。过去六。未来七。现在二。尽未知忍。无知他人心智。过去未来六。现在无。知他人心智。过去未来七。现在无。尽未知智。无知他人心智。过去未来六。现在二。知他人心智。过去未来七。现在二。道法忍无知他人心智。过去未来六。现在无。知他人心智。过去未来七。现在无。道法智。无知他人心智。过去六。未来七。现在二。知他人心智。过去七。未来八。现在二。道未知忍。无知他人心智。过去未来七。现在无。知他人心智。过去未来八。现在无。坚法亦如是。信解脱人于此八智。成就过去几。未来几。现在几。答曰。无知他人心智。未来成就七。诸已灭不失则成就过去。诸现在前则成就现在。知他人心智。成就未来八。诸已尽不失则成就过去。诸现在前则成就现在。见到亦如是。身证慧解脱俱解脱尽成就未来。若已尽不失则成就过去。诸现在前则成就现在(三世竟)。坚信人法智现在前时。几智现在前。答曰。二法智苦智二。法智习智二。法智尽智二。法智道智二。未知智现在前时。几智现在前。答曰。二未知智苦智二。未知智习智二。未知智尽智二。苦智现在前时几智现在前。答曰。二苦智法智二。苦智未知智二。习智尽智亦如是。道智现在前时几智现在前。答曰。二道智法智二。坚法亦如是。信解脱人法智现在前时几智现在前。答曰。或二或三。法智苦智二。法智习智二。法智尽智二。法智道智无知他人心智二。知他人心智三。未知智现在前时。几智现在前。答曰。或二或三。未知智苦智二。未知智习智二。未知智尽智二。未知智道智无知他人心智二。知他人心智三。知他人心智现在前时。几智现在前。答曰。或二或三。知他人心智无道智二。若道智三。等智现在前时。几智现在前。答曰。或一或二。等智无知他人心智一。若知他人心智二。苦智现在前时。几智现在前。答曰。二苦智法智二。苦智未知智二。习智尽智亦如是。道智现在前时。几智现在前。答曰。或二或三。道智法智无知他人心智二。若知他人心智三。道智未知智无知他人心智二。若知他人心智三。见到身证亦如是。慧解脱人法智现在前时。几智现在前。答曰。或二或三。法智苦智无尽智无生智二。若尽智无生智三。法智习智无。尽智无生智二。若尽智无生智三。法智尽。智无尽智无生智二。若尽智无生智三。法智道智无尽智无生智无知他人心智二。若尽智无生智知他人心智三。未知智现在前时。几智现在前。答曰。或二或三。未知智苦智无尽智无生智二。若尽智无生智三。未知智习智无尽智无生智二。若尽智无生智三。未知智尽智无。尽智无生智二。若尽智无生智三。未知智道智无尽智无生智无。知他人心智二。若尽智无生智知他人心。智三知他人心智现在。前时几智现在前。答曰或二。或三知他人心智无道。智二若道。智三等智现在。前时几智现在前。答曰。或一或二。等智无知他人心智一。若知他人心智二。苦智现在前时。几智现在前。答曰。或二或三。苦智法智无尽智无生智二。若尽智无生智三。苦智未知智无尽智无生智二。若尽智无生智三。习智尽智亦如是。道智现在前时。几智现在前。答曰。或二或三。道智法智无尽智无生智无知他人心智二。若尽智无生智知他人心智三。道智未知智无尽智无生智知他人心智二。若尽智无生智知他人心智三。俱解脱亦如是(八智竟)。坚信人于此三三昧成就几。不成就几。答曰。或二或三。尽法忍未生成就二不成就一。尽法忍生一切成就。坚法人亦如是。信解脱见到身证慧解脱俱解脱一切成就坚信人于此三三昧成就过去几。未来几。现在几。答曰。若依空三昧越次取证彼苦法忍。无有过去未来二现在一。苦法智过去一(空也)未来二(益无愿)现在一(空也)。苦未知忍苦未知智习法忍。过去一未来二现在一(无愿)。习法智。过去未来二现在一。习未知忍习未知智。过去未来二现在一(同上)。尽法忍过去二未来三(益无相)现在一(无相)。尽法智。过去未来三现在一。尽未知忍尽未知智。道法忍道法智道未知忍。过去未来三现在一(无愿)。若依无愿三昧越次取证。彼苦法忍无有过去未来二现在一。苦法智过去一(无愿)未来二现在一。苦未知忍苦未知智。习法忍习法智。习未知忍习未知智。过去一未来二(空无愿)现在一(无愿也)。尽法忍过去二(空无愿)未来三现在一(无相)。尽法智过去二(无愿无相)未来三现在一(无相)。尽未知忍尽未知智。道法忍道法智道未知忍。过去三(无愿无相)未来三现在一(无愿)。坚法亦如是。信解脱见到身证慧解脱俱解脱。一切未来成就。若已尽不失则成就过去。诸现在前则成就现在。坚信人空三昧现在前时。几智现在前。答曰。或二或无。苦智法智二。苦智未知智二。忍无也。无愿三昧现在前时。几智现在前。答曰。或二或无。苦智法智二。苦智未知智二。习智法智二。习智未知智二。道智法智二。忍无也无相三昧现在前时。几智现在前。答曰。或二或无。尽智法智二。尽智未知智二。忍无也。坚法亦如是。信解脱人空三昧现在前时。几智现在前。答曰。二苦智法智二。苦智。未知智二。无愿三昧现在前时。差智现在前。答曰。或二或三。苦智法智二。苦智未知智二。习智法智二。习智未知智二。道智法。智无知他。人心智二。若知他人心智三。道智未知智无知他人心智二。若知他人心智三。无相三昧现在前时。几智现在前。答曰。二尽智法智二。尽智未知智二。见到身证亦如是。慧解脱人空三昧现在前时。几智现在前。答曰。二苦智法智二。苦智未知智二。无愿三昧现在前时。几智现在前。答曰。或二或三。苦智法智无尽智无生智二。若尽智无生智三。苦智未知智无尽智无生智二。若尽智无生智三。习智法智无尽智无生智二。若尽智无生智三。习智未知智无尽智无生智二。若尽智无生智三。道智法智无尽智无生智无知他人心智二。若尽智无生智知他人心智三。道智未知智无尽智无生智无知他人心智二。若尽智无生智知他人心智三。无相三昧现在前时。几智现在前。答曰。或二或三。尽智法智无尽智无生智二。若尽智无生智三。尽智未知智无尽智无生智二。若尽智无生智三。俱解脱亦如是(三三昧竟)。坚信人未知根现在前时。几智现在前。答曰。或二或无。苦智法智二。苦智未知智二。习智法智二。习智未知智二。尽智法智二。尽智未知智二。道智法智二。忍无也。七觉意八道种亦如是。坚法亦如是。信解脱人已知根现在前时。几智现在前。答曰。或二或三。苦智法智二。苦智未知智二。习智法智二。习智未知智二。尽智法智二。尽智未知智二。道智法智无知他人心智二。若知他人心智三。道智未知智无知他人心智二。若知他人心智三。七觉意八道种亦如是。见到身证亦如。是慧解脱人无知根现在前时。几智现在前。答曰。或二或三。苦智法智无尽智无生智二。若尽智无生智三。苦智未知智无尽智无生智二。若尽智无。生智三。习智法智无尽智无生智二。若尽智无生智三。习智未知智无尽智无生智二。若尽智无生智三。尽智法智无。尽智无。生智二。若尽智无生智三。尽智未知智无尽智无生智二。若尽智无生智三。道智法智无尽智无生智无知他人心智二。若尽智无生智知他人心智三。道智未知智无尽智无生智无知他人心智二。若尽智无生智知他人心智三。七觉意八道种亦如是。等见现在前时几智现在前。答曰。或二或三。苦智法智二。苦智未知智二。习智法智二。习智未知智二。尽智法智二。尽智未知智二。道智法智无知他人心智二。若知他人心智三。道智未知智无知他人心智二。知他人心智三。俱解脱亦如是(三根竟)。诸法法智相应。彼非未知智。彼知他人心智耶。答曰。或法智非知他人心智。云何法智非知他人心智。答曰。知他人心智不摄法智相应法。是谓法智非知他人心智。云何知他人心智非法智。答曰。法智不摄知他人心智相应法。是谓知他人心智非法智。云何法智知他人心智。答曰。法智摄知他人心智相应法。是谓法智知他人心智。云何非法智非知他人心智。答曰。法智知他人心智。诸余法智知他人心智。不摄不相应及余心心所法。色无为心不相应行。是谓非法智非知他人心智。苦智习尽道智等见亦如是。诸法法智相应。彼非等智彼空三昧耶。答曰。或法智非空三昧。云何法智非空三昧。答曰。法智相应空三昧。诸余空三昧不相应法智相应法。是谓法智非空三昧。云何空三昧非法智。答曰。空三昧相应法智。诸余法智不相应空三昧相应法。是谓空三昧非法智。云何法智空三昧。答曰。除法智相应空三昧。诸余法智空三昧相应法。是谓法智空三昧。云何非法智非空三昧。答曰。法智不相应空三昧。空三昧不相应法智。及余心心所念法。色无为心不相应行。是谓非法智非空三昧。无愿无相喜觉意等志亦如是。诸法法智相应。彼未知根耶。答曰。或法智非未知根。云何法智非未知根。答曰。未知根不摄法智相应法。是谓法智非未知根。云何未知根非法智。答曰。未知根相应法智。诸余法智不摄不相应未知根相应法。是谓未知根非法智。云何法智未知根。答曰。未知根摄法智相应法。是谓法智未知根。云何非法智非未知根。答曰。未知根不摄法智。诸法智未知根不摄不相应。及余心心法色无为心不相应行。是谓非法智非未知根。已知根无知根亦如是。诸法法智相应彼念觉意耶。答曰。或法智非念觉意。云何法智非念觉意。答曰。法智相应念觉意。是谓法智非念觉意。云何念觉意非法智。答曰。法智诸余法智不相应念觉意相应法。是谓念觉意非法智。云何法智念觉意。答曰。除念觉意。诸余法智相应法。是谓法智念觉意。云何非法智非念觉意。答曰。法智不相应念觉意。及余心心法色无为心不相应行。是谓非法智非念觉意。精进猗定护觉意等方便等念等定亦如是。诸法法智相应。彼择法觉意耶。答曰。如是。诸法法智相应。彼择法觉意也。颇有择法觉意相应。非法智耶。答曰。有法智不摄择法觉意相应法(法智竟)。未知智门亦如是。诸法知他人心智相应。彼等智耶。答曰。或知他人心智非等智。云何知他人心智非等智。答曰。等智不摄知他人心智相应法。是谓知他人心智非等智。云何等智非知他人心智。答曰。知他人心智。不摄等智相应法。是谓等智非知他人心智。云何知他人心智等智。答曰。知他人心智摄等智相应法。是谓知他人心智等智。云何非知他人心智非等智。答曰。知他人心智等智。诸知他人心智等智。不摄不相应及余心心法。色无为心不相应行。是谓非知他人心智非等智。道智择法觉意等见亦如是。诸法知他人心智相应。彼非苦智习智尽智。非空三昧无相三昧。彼无愿耶。答曰。或知他人心智非无愿。云何知他人心智非无愿。答曰。知他人心智相应无愿诸无愿不相应。知他人心智相应法。是谓知他人心智非无愿。云何无愿非知他人心智。答曰无愿相应知他人心智。诸知他人心智不相应无愿相应法。是谓无愿非知他人心智。云何知他人心智无愿。答曰。除知他人心智相应无愿。诸余知他人心智无愿相应法。是谓知他人心智无愿。云何非知他人心智非无愿。答曰。知他人心智不相应无愿。无愿不相应知他人心智。及余心心所念法。色无为心不相应行。是谓非知他人心智非无愿。念觉意精进喜猗定护觉意等志等方便等念等定亦如是。诸法知他人心智相应。彼非未知根彼已知根耶。答曰。或知他人心智非已知根。云何知他人心智非已知根。答曰。已知根不摄知他人心智相应法。是谓知他人心智非已知根。云何已知根非知他人心智。答曰。已知根摄知他人心智。诸知他人心智不摄不相应。已知根相应法。是谓已知根非知他人心智。云何知他人心智已知根。答曰。已知根摄知他人心智相应法。是谓知他人心智已知根。云何非知他人心智非已知根。答曰。已知根不摄知他人心智。诸余知他人心智。已知根不摄不相应。及余心心法。色无为心不相应行。是谓非知他人心智。非已知根。无知根亦如是。诸法等智相应彼不与上。相应诸法苦智相应彼非习智尽道智。非无相。彼空三昧耶。答曰。或苦智非空三昧。云何苦智非空三昧。答曰苦智相应空三昧。诸余空三昧不相应苦智相应法。是谓苦智非空三昧。云何空三昧非苦智。答曰。空三昧相应苦智。诸苦智不相应空三昧相应法。是谓空三昧非苦智。云何苦智空三昧。答曰。除苦智相应空三昧。诸苦智空三昧相应法。是谓苦智空三昧。云何非苦智非空三昧。答曰苦智不相应空三昧。空三昧不相应苦智。及余心心法色无为心不相应行。是谓非苦智非空三昧。无愿亦如是。余残如法智。诸法习智相应。彼非尽智道智。非空无相。彼无愿耶。答曰。或习智非无愿。云何习智非无愿。答曰。习智相应无愿。是谓习智非无愿。云何无愿非习智。答曰。习智诸余习智不相应。无愿相应法是谓无愿非习智。云何习智无愿。答曰。除无愿。诸余习智相应法。是谓习智无愿。云何非习智非无愿。答曰。习智不相应无愿。及余心心法色无为心。不相应行是谓非习。智非无愿。余残如法智。诸法尽智相应彼非道智空无愿。彼无相耶。答曰。或尽智非无相。云何尽智非无相。答曰尽智相应无相。是谓尽智非无相。云何无相非尽智。答曰。尽智诸余尽智不相应。无相相应法。是谓无相非尽智。云何尽智无相。答曰。除无相诸余尽智相应法。是谓尽智无相。云何非尽智非无相。答曰。尽智不相应无相。及余心心法。色无为心不相应行。是谓非尽智非无相余残如法智。诸法道智相应。彼非空三昧非无相。彼无愿耶。答曰。或道智非无愿。云何道智非无愿。答曰。道智相应无愿。是谓道智非无愿。云何无愿非道智。答曰。道智诸道智不相应无愿相应法。是谓无愿非道智。云何道智无愿。答曰。除无愿诸道智相应法。是谓道智无愿。云何非道智非无愿。答曰。道智不相应无愿。及余心心法色无为心不相应行。是谓非道智非无愿。余残如法智诸法空三昧相应。彼非无愿无相。彼未知根耶。答曰。或空三昧非未知根。云何空三昧非未知根。答曰。未知根不摄空三昧相应法。是谓空三昧非未知根。云何未知根非空三昧。答曰。未知根摄空三昧。诸空三昧不摄不相应未知根相应法。是谓未知根非空三昧。云何空三昧未知根。答曰。未知根摄空三昧相应法。是谓空三昧未知根。云何非空三昧非未知根。答曰。未知根不摄空。三昧诸空三昧未知根不摄不相应。及余心心法色无为心不相应行。是谓非空三昧非未知根。已知根无知根亦如是。诸法空三昧相应。彼念觉意耶。答曰。或空三昧非念觉意。云何空三昧非念觉意。答曰。空三昧相应念觉意。是谓空三昧非念觉意。云何念觉意非空三昧。答曰空三昧诸余空三昧不相应念觉意相应法。是谓念觉意非空三昧。云何空三昧念觉意。答曰。除念觉意。诸余空三昧相应法。是谓空三昧念觉意。云何非空三昧非念觉意。答曰。空三昧不相应念觉意。及余心心法色无为心不相应行。是谓非空三昧非念觉意。择法精进猗护觉意等见等方便等念亦如是。诸法空三昧相应。彼喜觉意耶。答曰。或空三昧非喜觉。意云何空三昧非喜觉意耶。答曰。空三昧相应喜觉意。诸喜觉意不相应空三昧相应法。是谓空三昧非喜觉意。云何喜觉意非空三昧。答曰。喜觉意相应空三昧。诸空三昧不相应喜觉意相应法。是谓喜觉意非空三昧。云何空三昧喜觉意。答曰。除空三昧相应喜觉意。诸空三昧喜觉意相应法。是谓空三昧喜觉意。云何非空三昧非喜觉意。答曰。空三昧不相应喜觉意。喜觉意不相应空三昧。及余心心法色无为心不相应行。是谓非空三昧。非喜觉意等志亦如是。诸法空三昧相应彼定觉意耶答曰。如是。设诸法空三昧相应。彼定觉意颇诸法定觉意相应。彼非空三昧耶。答曰。有空三昧不摄定觉意相应法等定亦如是。诸法无愿相应。彼非无相彼未知根耶。答曰。或无愿非未知根。云何无愿非未知根。答曰。未知根不摄无愿相应法。是谓无愿非未知根。云何未知根非无愿。答曰。未知根摄无愿。诸无愿不摄不相应未知根相应法。是谓未知根非无愿。云何无愿未知根。答曰。未知根摄无愿相应法。是谓无愿未知根。云何非无愿非未知根。答曰。未知根不摄无愿。诸无愿未知根不摄。不相应及余心心法色无为心不相应行。是谓非无愿非未知根。已知根无知根亦如是。诸法无愿相应。彼念觉意耶。答曰。或无愿非念觉意。云何无愿非念觉意。答曰。无愿相应念觉意。是谓无愿非念觉意。云何念觉意非无愿。答曰。无愿诸无愿不相应。念觉意相应法。是谓念觉意非无愿。云何无愿念觉意。答曰。除念觉意。诸余无愿相应法。是谓无愿念觉意。云何非无愿非念觉意。答曰。无愿不相应念觉意。及余心心法色无为心不相应行。是谓非无愿非念觉意。择法精进猗护觉意等方便等念亦如是

阿毗昙八揵度论卷第十三阿毗昙八犍度论卷第十四

        迦旃延子造

        符秦罽宾三藏僧伽提婆共竺佛念译

    智犍度中相应跋渠第五之余

诸法无愿相应彼喜觉意耶。答曰。或无愿非喜觉意。云何无愿非喜觉意。答曰。无愿相应喜觉意。诸余喜觉意不相应。无愿相应法。是谓无愿非喜觉意。云何喜觉意非无愿。答曰。喜觉意相应无愿。诸无愿不相应喜觉意相应法。是谓喜觉意。非无愿。云何无愿喜觉意。答曰。除无愿相应喜觉意。诸无愿喜觉意相应法。是谓无愿喜觉意。云何非无愿非喜觉意。答曰。无愿不相应喜觉意。喜觉意不相应无愿。及余心心法色无为心不相应行。是谓非无愿非喜觉意。等见等志亦如是。诸法无愿相应。彼定觉意耶。答曰。如是。诸法无愿相应彼定觉意。颇诸法定觉意相应。彼非无愿耶。答曰。有无愿不摄定觉意相应法。等定亦如是。无相门亦如是。诸法未知根相应。彼非已知根。无知根彼念觉意耶。答曰。或未知根非念觉意。云何未知根非念觉意。答曰。未知根摄念觉意。是谓未知根非念觉意。云何念觉意非未知根。答曰。未知根不摄念觉意相应法。是谓念觉意非未知根。云何未知根念觉意耶。答曰。未知根摄念觉意相应法。是谓未知根念觉意。云何非未知根非念觉意。答曰。未知根不摄念觉意。及余心心法。色无为心不相应行。是谓非未知根非念觉意。择法精进定觉意等见等方便等念等定亦如是。诸法未知根相应。彼喜觉意耶。答曰。或未知根非喜觉意。云何未知根非喜觉意。答曰。未知根摄喜觉意。诸喜觉意不摄不相应。未知根相应法。是谓未知根非喜觉意。云何喜觉意非未知根。答曰。未知根不摄喜觉意相应法。是谓喜觉意非未知根。云何未知根喜觉意。答曰。未知根摄喜觉意相应法。是谓未知根喜觉意。云何非未知根非喜觉意。答曰。未知根不摄喜觉意。诸未知根喜觉意。不摄不相应及余心心法。色无为心不相应行。是谓非未知根。非喜觉意。诸法未知根相应。彼猗觉意耶。答曰。或未知根非猗觉意。云何未知根非猗觉意。答曰。未知根相应猗觉意。是谓未知根非猗觉意。云何猗觉意非未知根。答曰。未知根不相应。猗觉意相应法。是谓猗觉意非未知根。云何未知根猗觉意。答曰。未知根相应猗觉意相应法。是谓未知根猗觉意。云何非未知根。非猗觉意。答曰。未知根不相应猗觉意。及余心心法色无为心不相应行。是谓非未知根非猗觉意。护觉意亦如是。诸法未知根相应。彼等志耶。答曰。或未知根非等志。云何未知根非等志。答曰。未知根相应等志。诸等志不相应。未知根相应法。是谓未知根非等志。云何等志非未知根。答曰。未知根不相应。等志相应法。是谓等志非未知根。云何未知根等志。答曰。未知根相应。等志相应法。是谓未知根等志。云何非未知根非等志。答曰。未知根不相应等志。诸未知根等志不相应。及余心心法色无为心不相应行。是谓非未知根非等志。已知根门亦如是。诸法无知根相应。彼念觉意耶。答曰。或无知根非念觉意。云何无知根非念觉意。答曰。无知根摄念觉意。是谓无知根非念觉意。云何念觉意非无知根。答曰。无知根不摄念觉意相应法。是谓念觉意非无知根。云何无知根念觉意。答曰。无知根摄念觉意相应法。是谓无知根念觉意。云何非无知根。非念觉意。答曰。无知根不摄念觉意。及余心心法色无为心不相应行。是谓非无知根。非念觉意。择法精进定觉意等方便等念等定亦如是。诸法无知根相应。彼喜觉意耶。答曰。或无知根非喜觉意。云何无知根非喜觉意。答曰。无知根摄喜觉意。诸喜觉意不摄不相应。无知根相应法。是谓无知根非喜觉意。云何喜觉意非无知根。答曰。无知根不摄喜觉意相应法。是谓喜觉意非无知根。云何无知根喜觉意。答曰。无知根摄喜觉意相应法。是谓无知根喜觉意。云何非无知根非喜觉意。答曰。无知根不摄喜觉意。诸无知根喜觉意不摄。不相应及余心心法色无为心不相应行。是谓非无知根非喜觉意。等见亦如是。诸法无知根相应。彼猗觉意耶。答曰。或无知根非猗觉意。云何无知根非猗觉意。答曰。无知根相应猗觉意。是谓无知根非猗觉意。云何猗觉意非无知根。答曰。无知根不相应猗觉意相应法。是谓猗觉意非无知根。云何无知根猗觉意。答曰。无知根相应猗觉意相应法。是谓无知根猗觉意。云何非无知根非猗觉意。答曰。无知根不相应猗觉意。及余心心法色无为心不相应行。是谓非无知根非猗觉意。护觉意亦如是。诸法无知根相应。彼等志耶。答曰。或无知根非等志。云何无知根非等志。答曰。无知根相应等志。诸等志不相应。无知根相应法。是谓无知根非等志。云何等志非无知根。答曰。无知根不相应。等志相应法。是谓等志非无知根。云何无知根等志。答曰。无知根相应等志相应法。是谓无知根等志。云何非无知根非等志。答曰。无知根不相应等志。诸无知根等志不相应。及余心心法色无为心不相应行。是谓非无知根非等志。余残如上相应也(相应门竟)。又世尊言。我今当说四十四智种。老死苦智四智。法智未知智苦智等智。老死习智四智。法智未知智习智等智。老死尽智四智法智未知智尽智等智。老死尽道迹智四智。法智未知智道智等智。生有乃至行智亦如是(四十四智门竟)。又世尊言。我今当说七十七智种。生缘老死知智四智。法智未知智习智等智。不缘余生缘老死知智四智。法智未知智习智等智。过去久远生缘老死知智四智。法智未知智习智等智。非余过去久远生缘。老死知智四智。法智未知智习智等智。未来久远生缘。老死知智四智。法知未知智习智等智。不缘余未来久远生缘。老死知智四智。法智未知智习智等智。如法界住智。无常有为心所缘生尽法。变易法无欲法尽法。断智慧此智一等智乃至无明缘行知智亦如是(七十七智门竟)。若成就法智彼未知智耶。答曰。若得设成就未知智。彼法智耶。答曰如是。若成就法智彼知他人心智耶。答曰。若得不失则成就。若不得设得便失则不成就。设成就知他人心智。彼法智耶。答曰。若得若成就。法智彼等智耶。答曰。如是。设成就等智彼法智耶。答曰。若得若成就。法智彼苦智耶。答曰。如是。设成就苦智彼法智耶。答曰。如是。若成就法智彼习智尽道智耶。答曰。若得设成就。道智彼法智耶。答曰。如是(法智竟也)。若成就未知智。彼知他人心智耶。答曰。若得不失则成就。若不得。设得便失则不成就。设成就知他人心智。彼未知智耶。答曰。若得若成就。未知智彼等智耶。答曰。如是。设成就等智彼未知智耶。答曰。若得若成就。未知智彼苦智耶。答曰。如是。设成就苦智彼未知智耶。答曰。若得若成就。未知智彼习尽道智耶。答曰。若得设成就。道智彼未知智耶。答曰。如是(未知智竟)。若成就知他人心智。彼等智耶。答曰。如是。设成就等智。彼知他人心智耶。答曰。若得不失则成就。若不得设得便失则不成就。若成就知他人心智。彼苦智习尽道智耶。答曰。若得设成就。道智彼知他人心智耶。答曰。若得不失则成就。若不得设得便失则不成就(知他心竟)。若成就等智。彼苦智习尽道智耶。答曰。若得设成就。道智彼等智耶。答曰。如是。若成就苦智。彼习尽道智耶。答曰。若得设成就。道智彼苦智耶。答曰。如是。若成就习智。彼尽道智耶。答曰。若得设成就尽道智彼习智耶。答曰。如是。若成就尽智彼道智耶。答曰。若得设成就。道智彼尽智耶。答曰。如是(一观竟)。若成就过去法智。彼未来耶。答曰。如是。设彼未来彼过去耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若彼过去彼现在耶。答曰。若现在前。设彼现在彼过去耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若彼未来彼现在耶。答曰。若现在前。设彼现在彼未来耶。答曰。如是。若彼过去彼未来现在耶。答曰。未来则成就。现在若现在前。设彼未来现在彼过去耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若彼未来彼过去现在耶。答曰。或未来无过去现在。及过去无现在。及现在无过去及过去现在。云何未来非过去现在。答曰。若得法智不尽设尽便失。不现在前。是谓未来非过去现在。云何未来及过去非现在。答曰。若法智已尽不失。又此法智不现在前。是谓未来及过去无现在。云何未来及现在无过去。答曰。若法智现在前不尽设尽便失。是谓未来及现在非过去。云何未来及过去现在。答曰。若法智已尽不失。又此法智现在前。是谓未来及过去现在。设彼过去现在。彼未来耶。答曰。如是。若彼现在彼过去未来耶。答曰。未来则成就过去。若尽不失则成就若不尽设尽便失则不成就。设彼过去未来彼现在耶。答曰。若现在前(法智经六)。未知智苦智习尽道智亦如是。若成就过去知他人心智。彼未来耶。答曰。如是。设彼未来彼过去耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若彼过去彼现在耶。答曰。若现在前。设彼现在彼过去耶。答曰。如是。若彼未来彼现在耶。答曰。若现在前。设彼现在彼未来耶。答曰。如是。若彼过去彼未来现在耶。答曰。未来则成就现在。若现在前。设彼未来现在彼过去耶。答曰。如是。若彼未来彼过去现在耶。答曰。或未来无过去现在。及过去无现在及过去现在。云何未来无过去现在耶。答曰。若得知他人心智不失。若不尽设尽便失不现在前。见谓未来无过去现在。云何未来及过去非现在耶。答曰。若知他人心智已尽不失。又此知他人心智不现在前。是谓未来及过去非现在。云何未来及过去现在

答曰。若知他人心智已尽不失。又此知他人心智现在前。是谓未来及过去现在。设彼过去现在彼未来耶。答曰。如是。若彼现在彼过去未来耶。答曰。如是。设彼过去未来彼现在耶。答曰。若现在前(他人心智经六)。若成就过去等智。彼未来耶。答曰。如是。设彼未来彼过去耶。答曰。如是。若彼过去彼现在耶。答曰。若现在前。设彼现在彼过去耶。答曰。如是。若彼未来彼现在耶。答曰。若现在前。设彼现在彼未来耶。答曰。如是。若彼过去彼未来现在耶。答曰。未来则成就。现在若现在前。设彼未来现在彼过去耶。答曰。如是。若彼未来彼过去现在耶。答曰。过去则成就。现在若现在前。设彼过去现在彼未来耶。答曰。如是。若彼现在彼过去未来耶。答曰。如是。设彼过去未来彼现在耶。答曰。若现在前(六竟)。若成就过去法智。彼过去未知智耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。设成就过去未知智。彼过去法智耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就过去法智。彼未来未知智耶。答曰。若得设成就。未来未知智彼过去法智耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就过去法智。彼现在未知智耶。答曰。若现在前。设成就现在未知智。彼过去法智耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就过去法智。彼过去现在未知智耶。答曰。或成就过去法智。无过去现在未知智也。及过去无现在。及现在无过去。及过去现在未知智。云何成就过去法智。无过去现在未知智耶。答曰。若法智已尽不失。又此未知智不尽。设尽便失不现在前。是谓成就过去法智。非过去现在未知智。云何成就过去法智。及过去未知智非现在前。答曰。若法智未知智也已尽不失。又此未知智不现在前。是谓成就过去法智。及过去未知智非现在。云何成就过去法智。及现在未知智非过去。答曰。若法智已尽不失。又此未知智现在前。若不尽已尽便失。是谓成就过去法智。及现在未知智非过去。云何成就过去法智。及过去现在未知智耶。答曰。若法智未知智已尽不失。又此未知智现在前。是谓成就过去法智。及过去现在未知智。设成就过去现在未知智。彼过去法智耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就过去法智。彼未来现在未知智耶。答曰。或成就过去法智。非未来现在未知智。及未来无现在及未来现在未知智。云何成就过去法智。非未来现在未知智。答曰。若法智已尽不失。又此不得未知智。是谓成就过去法智。非未来现在未知智。云何成就过去法智。及未来未知智非现在。答曰。若法智已尽不失。又此得未知智不现在前。是谓成就过去法智。及未来未知智非现在。云何成就过去法智。及未来现在未知智。答曰。若法智已尽不失。又此未知智现在前。是谓成就过去法智及未来现在未知智。设成就未来现在未知智。彼过去法智耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就过去法智。彼过去未来未知智耶。答曰。或成就过去法智。无过去未来未知智。及未来非过去及过去未来未知智。云何成就过去法智非过去未来未知智。答曰。若法智已尽不失。又此不得未知智。是谓成就过去法智。非过去未来未知智。云何成就过去法智。及未来未知智非过去。答曰。若法智已尽不失。又此得未知智。若不尽设尽便失。是谓成就过去法智及未来未知智非过去。云何成就过去法智。及过去未来未知智。答曰。若法智未知智以尽不失。是谓成就过去法智。及过去未来未知智。设成就过去未来未知智。彼过去法智耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就过去法智。彼过去未来现在未知智耶。答曰。或成就过去法智。无过去未来现在未知智。及未来非过去现在。及过去未来非现在。及未来现在非过去。及过去未来现在未知智。云何成就过去法智。非过去未来现在未知智。答曰。若法智已尽不失。又此不得未知智。是谓成就过去法智。非过去未来现在未知智。云何成就过去法智。及未来未知智非过去现在。答曰。若法智已尽不失。又此得未来未知智。若不尽设尽便失不现在前。是谓成就过去法智及未来未知智。非过去现在。云何成就过去法智。及过去未来未知智非现在。答曰。若法智未知智已尽不失。又此未知智不现在前。是谓成就过去法智。及过去未来未知智非现在。云何成就过去法智。及未来现在未知智非过去。答曰。若法智已尽不失。又此未知智现在前。若不尽设尽便失。是谓成就过去法智。及未来现在未知智非过去。云何成就过去法智。及过去未来现在未知智。答曰。若法智未知智已尽不失。又此未知智现在前。是谓成就过去法智。及过去未来现在未知智。设成就过去现在未来未知智。彼过去法智耶。答曰。若尽不失则成就。若不尽设尽便失。则不成就(法智未知智七竟)。若成就过去法智。彼过去知他人心智耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。设成就过去知他人心智。彼过去法智耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就过去法智。彼未来知他人心智耶。答曰。若得不失则成就。若不得设得便失则不成就。设成就未来知他人心智。彼过去法智耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就过去法智。彼现在知他人心智耶。答曰。若现在前。设成就现在知他人心智。彼过去法智耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就过去法智。彼过去现在知他人心智耶。答曰。或成就过去法智。非过去现在知他人心智。及过去非现在及过去现在知他人心智。云何成就过去法智。非过去现在知他人心智。答曰。若法智已尽不失。又此知他人心智。不尽设尽便失不现在前。是谓成就过去法智。非过去现在知他人心智。云何成就过去法智及过去知他人心智非现在。答曰。若法智知他人心智已尽不失。又此知他人心智不现在前。是谓成就过去法智。及过去知他人心智非现在。云何成就过去法智。及过去现在知他人心智耶。答曰。若法智已尽不失。又此知他人心智现在前。是谓成就过去法智。及过去现在知他人心智。设成就过去现在知他人心智。彼过去法智耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就过去法智。彼未来现在知他人心智耶。答曰。或成就过去法智。非未来现在知他人心智。及未来非现在。及未来现在知他人心智。云何成就过去法智。非未来现在知他人心智。答曰。若法智已尽不失。又此不得知他人心智设得便失。是谓成就过去法智无未来现在知他人心智。云何成就过去法智。及未来知他人心智非现在。答曰。若法智已尽不失。又此得知他人心智不失不现在前。是谓成就过去法智。及未来知他人心智非现在。云何成就过去法智。及未来现在知他人心智。答曰。若是法智已尽不失。又此知他人心智现在前。是谓成就过去法智。及未来现在知他人心智。设成就未来现在知他人心智。彼过去法智耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就过去法智。彼过去未来知他人心智耶。答曰。或成就过去法智。无过去未来知他人心智。及未来非过去。及过去未来知他人心智。云何成就过去法智。非过去未来知他人心智耶。答曰。若法智已尽不失。又此不得知他人心智。设得便失。是谓成就过去法智。非过去未来知他人心智。云何成就过去法智。及未来知他人心智非过去耶。答曰。若法智已尽不失。又此得知他人心智不失。若不尽设尽便失。是谓成就过去法智。及未来知他人心智非过去。云何成就过去法智。及过去未来知他人心智。答曰。若法智知他人心智已尽不失。是谓成就过去法智及过去未来知他人心智。设成就过去未来知他人心智。彼过去法智耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就过去法智。彼过去未来现在知他人心智耶。答曰。或成就过去法智。无过去未来现在知他人心智。及未来非过去现在。及过去未来非现在及过去未来现在知他人心智。云何成就过去法智。非过去未来现在知他人心智。答曰。若法智已尽不失。又此不得知他人心智。设得便失。是谓成就过去法智。非过去未来现在知他人心智。云何成就过去法智。及未来知他人心智。无过去现在耶。答曰。若法智已尽不失。又此得知他人心智不失。若不尽设尽便失不现在前。是谓成就过去法智。及未来知他人心智。非过去现在。云何成就过去法智。及过去未来知他人心智非现在。答曰。若法智知他人心智已尽不失。又此知他人心智不现在前。是谓成就过去法智。及过去未来知他人心智非现在。云何成就过去法智。及过去未来现在知他人心智耶。答曰。若法智已尽不失。又此知他人心智现在前。是谓成就过去法智。及过去未来现在知他人心智。设成就过去未来现在知他人心智。彼过去法智耶。答曰。若尽不失则成就。若不尽设尽便失则不成就(知他人心智七竟)。若成就过去法智。彼过去等智耶。答曰。如是。设成就过去等智。彼过去法智耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就过去法智。彼未来等智耶。答曰。如是。设成就未来等智。彼过去法智耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就过去法智。彼现在等智耶。答曰。若现在前设成就现在等智。彼过去法智耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就过去法智。彼过去现在等智耶。答曰。过去则成就。现在若现在前。设成就过去现在等智。彼过去法智耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就过去法智。彼未来现在等智耶。答曰。未来则成就。现在若现在前。设成就未来现在等智。彼过去法智耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就过去法智。彼过去未来等智耶。答曰。如是。设成就过去未来等智。彼过去法智耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就过去法智。彼过去未来现在等智耶。答曰。过去未来则成就。现在若现在前。设成就过去未来现在等智。彼过去法智耶。答曰。若尽不失则成就。若不尽设尽便失则不成就(等智七竟)。若成就过去法智。彼过去苦智耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。设成就过去苦智。彼过去法智耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就过去法智。彼未来苦智耶。答曰。如是。设成就未来苦智。彼过去法智耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就过去法智。彼现在苦智耶。答曰。若现在前设成就现在苦智。彼过去法智耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就过去法智。彼过去现在苦智耶。答曰。或成就过去法智无过去现在苦智。及过去无现在。及现在无过去。及过去现在苦智。云何成就过去法智。非过去现在苦智耶。答曰。若法智已尽不失。又此苦智不尽。设尽便失不现在前。是谓成就过去法智。非过去现在苦智。云何成就过去法智。及过去苦智非现在耶。答曰。若法智苦智已尽不失。又此苦智不现在前。是谓成就过去法智。及过去苦智非现在。云何成就过去法智。及现在苦智非过去耶。答曰。若法智已尽不失。又此苦智现在前。若不尽设尽便失。是谓成就过去法智。及现在苦智非过去。云何成就过去法智。及过去现在苦智耶。答曰。若法智苦智已尽不失。又此苦智现在前。是谓成就过去法智及过去现在苦智。设成就过去现在苦智。彼过去法智耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就过去法智。彼未来现在苦智耶。答曰。未来则成就。现在若现在前。设成就未来现在苦智。彼过去法智耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就过去法智。彼过去未来苦智耶。答曰。未来则成就过去。若尽不失则成就。若不尽设尽便失则不成就。设成就过去未来苦智。彼过去法智耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就过去法智。彼过去未来现在苦智耶。答曰。或成就过去法智及未来苦智。非过去现在及过去未来非现在。及未来现在非过去。及过去未来现在苦智。云何成就过去法智及未来苦智。非过去现在耶。答曰。若法智已尽不失。又此得苦智若不尽。设尽便失不现在前。是谓成就过去法智。及未来苦智非过去现在。云何成就过去法智。及过去未来苦智非现在耶。答曰。若法智苦智已尽不失。又此苦智不现在前。是谓成就过去法智。及过去未来苦智非现在。云何成就过去法智。及未来现在苦智非过去耶。答曰。若法智已尽不失。又此苦智现在前。若不尽设尽便失。是谓成就过去法智。及未来现在苦智非过去。云何成就过去法智。及过去未来现在苦智耶。答曰。若法智苦智已尽不失。又此苦智现在前。是谓成就过去法智。及过去未来现在苦智。设成就过去未来现在苦智。彼过去法智耶。答曰。若尽不失则成就。若不尽设尽便失。则不成就(苦智七竟)。习尽道智亦如是(小七竟)。过去法智过去未来知智过去知他人心智(一)未来(二)现在(三)过去现在(四)未来现在(五)过去未来(六)过去未来现在(七)。知他人心智七。乃至道智亦如是(大七竟)

智相应品第五竟(梵本一千四十三首卢秦一万五千一百九言)

阿毗昙八揵度论卷第十四阿毗昙八犍度论卷第十五

        迦旃延子造

        符秦罽宾三藏僧伽提婆共竺佛念译

    行犍度第四

    恶行跋渠第一

  恶行邪语　　众生及命　　身无有教
  自行在后

此章义愿具演说

三恶行三不善根。三恶行摄三不善根。三不善根摄三恶行耶。三妙行三善根。三妙行摄三善根。三善根摄三妙行耶。三恶行十不善行迹。三恶行摄十不善行迹。十不善行迹摄三恶行耶。三妙行十善行迹。三妙行摄十善行迹。十善行迹摄三妙行耶。三行十行迹。三行摄十行迹。十行迹摄三行耶。三行四行黑有黑报。白有白报。白黑白黑报。不黑不白无行报行尽。三行摄四行。四行摄三行耶。复次三行现法报。生报后报乐报苦报。不苦不乐报。过去未来现在。善不善无记。欲界系色无色界系。学无学非学非无学。见谛所断思惟所断无断。前摄后后摄前耶。四行黑有黑报。白有白报。黑白黑白报。不黑不白无行报行尽。三行现法报生报后报。乐报苦报。不苦不乐报。过去未来现在。善不善无记。欲界系色无色界系。学无学非学非无学。见谛所断思惟所断无断。四行摄三行。三行摄四行耶。三行现法报生报后报。复次三行乐报苦报不苦不乐报。过去未来现在。善不善无记。欲界系色无色界系。学无学非学非无学。见谛所断思惟所断无断。前摄后后摄前耶。三行乐报苦报不苦不乐报。复次三行过去未来现在。善不善无记。欲界系色无色界系。学无学非学非无学。见谛所断思惟所断无断。前摄后后摄前耶。三行过去未来现在。复次三行善不善无记。欲界系色无色界系。学无学非学非无学。见谛所断思惟所断无断。前摄后后摄前耶。三行善不善无记。复次三行欲界系色无色界系。学无学非学非无学。见谛所断思惟所断无断。前摄后后摄前耶。三行欲界系色无色界系。复次三行学无学非学非无学。见谛所断思惟所断无断。前摄后后摄前。三行学无学非学非无学。复次三行见谛所断思惟所断无断。前摄后后摄前耶。颇行受报身痛受报非心耶。颇行受报心痛受报非身耶。颇行受报身心痛受报耶。颇行受报身心痛不受报而受报耶。三障行障垢障报障。彼云何行障。云何垢障。云何报障。此三恶行何者最大。此三妙行何者最大果。此章义愿具演说。三恶行三不善根。三恶行摄三不善根耶。答曰。或恶行非不善根。云何恶行非不善根。答曰。身口恶行邪见不善思。是谓恶行非不善根。云何不善根非恶行。答曰。痴不善根。是谓不善根非恶行。云何恶行不善根。答曰。贪嗔恚不善根。是谓恶行不善根。云何非恶行非不善根。答曰。除上尔所事。三妙行三善根。三妙行摄三善根耶。答曰。或妙行非善根。云何妙行非善根。答曰。身口妙行善思。是谓妙行非善根。云何善根非妙行。答曰。等见不摄无痴善根。是谓善根非妙行。云何妙行善根。答曰。不贪不嗔恚善根等见。是谓妙行善根。云何非妙行非善根。答曰。除上尔所事。三恶行十不善行迹。三恶行摄十不善行迹。十不善行迹摄三恶行。答曰。三摄十非十摄三。不摄何等。答曰。除行迹摄身口恶行。诸余身口恶行。及不善思。三妙行十善行迹。三妙行摄十善行迹。十善行迹摄三妙行。答曰。三摄十非十摄三。不摄何等。答曰。除行迹摄身口妙行。诸余身口妙行及善思。三行十行迹。三行摄十行迹。答曰。或行非行迹。云何行非行迹。答曰。除行迹摄身口行。诸余身口行意思。是谓行非行迹。云何。行迹非行答曰。后三行迹。是谓行迹非行。云何行行迹。答曰。七行迹。是谓行行迹。云何非行非行迹。答曰。除上尔所事。三行四行黑有黑报。白有白报。黑白黑白报。不黑不白无报行行尽。三行摄四行。四行摄三行。答曰。三四非四三。不摄何等。答曰。除学思作尽。诸余无漏行及无色界善行。无记行三行。复次三行现法报生报后报。前摄后后摄前。答曰。前后非后前。不摄何等。答曰。不定无记无漏行三行。复次三行乐报苦报不苦不乐报。前摄后后摄前。答曰。前后非后前。不摄何等。答曰。无记无漏行三行。复次三行过去未来现在。善不善无记。学无学非学非无学。见谛所断思惟所断无断。前摄后后摄前。答曰。随种相摄三行。复次三行欲界系色无色界系。前摄后后摄前。答曰。前后非后前。不摄何等。答曰。无漏行(三行竟)

四行黑有黑报。白有白报。黑白黑白报。不黑不白无报行行尽。三行现法报生报后报。四行摄三行耶。答曰。或四非三。云何四非三。答曰。学思作尽。欲界系善不善不定行。色界系善不定行。是谓四非三。云何三非四。答曰。无色界系善定行。是谓三非四。云何四三。答曰。欲界系善不善定行。色界系善定行。是谓四三。云何非四非三。答曰。除学思作尽。诸余无漏行。无色界系善不定行无记行。是谓非四非三。四行黑有黑报白有白报白黑白黑报。不白不黑无报行行尽。三行乐报苦报不苦不乐报。四行摄三行。答曰。或四非三。云何四非三。答曰。学思作尽。是谓四非三。云何三非四。答曰。无色界系善行。是谓三非四。云何四三。答曰。欲界系善不善行。色界系善行。是谓四三。云何非四非三。答曰。除学思作尽思惟进行。诸余无漏行无记行。是谓非四非三。四行黑有黑报。白有白报。黑白黑白报。不黑不白无报行行尽。三行过去未来现在。善不善无记。学无学非学非无学。见谛所断思惟所断无断。四行摄三行三行摄四行。答曰。三摄四非四三。不摄何等。答曰。除学思作尽诸余无漏行。无色界系善无记行也。四行黑有黑报。白有白报。黑白黑白报。不黑不白无报行行尽也。三行欲界系色无色界系。四行摄三行。三行摄四行。答曰。或四非三。云何四非三。答曰。学思作尽。是谓四非三。云何三非四。答曰。无色界系善行无记行。是谓三非四。云何四三。答曰。欲界系善不善行。色界系善行。是谓四三。云何非四非三。答曰。除学思作尽。诸余无漏行。是谓非四非三(四行竟)。三行现法报生报后报。复次三行乐报苦报不苦不乐报。前摄后后摄前。答曰。后前非前后。不摄何等。答曰。不定行也。三行现法报生报后报。复次三行过去未来现在。善不善无记。学无学非学非无学。见谛所断思惟所断无断。前摄后后摄前。答曰。后前非前后。不摄何等。答曰。不定无记无漏行也。三行现法报生报后报。复次三行欲界系色无色界系。前摄后后摄前。答曰。后前非前后。不摄何等。答曰。不定无记行(现生后报三竟)。三行乐报苦报不苦不乐报。复次三行过去未来现在。善不善无记。学无学非学非无学。见谛所断思惟所断无断。前摄后后摄前。答曰。后前非前后。不摄何等。答曰。无记无漏行也。三行乐报苦报不苦不乐报。复次三行欲界系色无色界系。前摄后后摄前。答曰。后前非前后。不摄何等。答曰。无记行(三痛竟)。三行过去未来现在。复次三行善不善无记。学无学非学非无学。见谛所断思惟所断无断。前摄后后摄前。答曰。随种相摄三行过去未来现在。复次三行欲界系色无色界系。前摄后后摄前答曰。前后非后前。不摄何等。答曰。无漏行(三世竟)。三行善不善无记。复次三行欲界系色无色界系。前摄后后摄前。答曰。前后非后前。不摄何等。答曰。无漏行。三行善不善无记。复次三行学无学。非学非无学。见谛所断思惟所断无断。前摄后后摄前。答曰。随种相摄(善不善竟)。三行欲界系色无色界系。复次三行学无学非学非无学。见谛所断思惟所断无断。前摄后后摄前。答曰。后前非前后。不摄何等。答曰。无漏行(三界竟)。三行学无学非学非无学。复次三行见谛所断思惟所断无断。前摄后后摄前。答曰。随种相摄(三三稍除自二三痛至此七也)。颇行受报身痛受报非心耶。答曰。受报不善行也。颇行受报心。痛受报非身耶。答曰。受报善无学行。颇行受报身心痛受报耶。答曰。受报善有学行。颇行受报身心痛不受报而受报耶。答曰。受报善不善行受报。色心心所念法心不相应行也。三障行障垢障报障。彼云何行障。云何垢障。云何报障。行障云何。答曰。五无救行。垢障云何。答曰。诸众生淫欲偏重。嗔恚愚痴偏重。彼淫欲偏重嗔恚愚痴偏重。难教难语难济难脱。是谓垢障。云何报障。答曰。地狱处。畜生处。饿鬼处。郁单曰。无想天处。是谓报障。此三恶行何者最大。答曰。坏僧妄语。由此行报阿鼻大地狱受劫寿。此三妙行何者最大果。答曰。有第一有三昧思行报。有想无想受八十千劫寿

阿毗昙恶行品第一竟(梵本一百九十二首卢二千七百八言)

    阿毗昙行揵度中邪语跋渠第二

诸邪语彼是邪命耶。设是邪命彼是邪语耶。诸邪业彼是邪命耶。设是邪命彼是邪业耶。诸等语彼是等命耶。设是等命彼是等语耶。诸等业彼是等命耶。设是等命彼是等业耶。三恶行三曲三秽三浊。身曲身秽身浊。口曲口秽口浊。意曲意秽意浊。彼云何身曲身秽身浊。云何口曲口秽口浊。云何意曲意秽意浊。三恶行摄三曲秽浊。三曲秽浊摄三恶行。三妙行三净。三妙行摄三净。三净摄三妙行。三妙行三满。三妙行摄三满。三满摄三妙行。三净三满三净摄三满。三满摄三净。诸身恶行彼尽无巧便身行耶。设无巧便身行彼尽身恶行耶。诸口恶行彼尽无巧便口恶行耶。设无巧便口行。彼尽口恶行耶。诸意恶行彼尽无巧便意行耶。设无巧便意行。彼尽意恶行耶。诸身妙行彼尽巧便身行耶。设巧便身行。彼尽是身妙行耶。诸口妙行彼尽巧便口行耶。设巧便口行彼尽口妙行耶。诸意妙行彼尽巧便意行耶。设巧便意行。彼尽意妙行耶。诸法由行得彼法。当言善耶。不善无记耶。颇过去行过去报未来现在报耶。颇未来行未来现在过去报耶。颇现在行现在过去未来报耶。颇如身行受报口行意行不然耶。颇如口行受报身行意行不然耶。颇如意行受报身口行不然耶。颇如身行口行受报意行不然耶。颇如身行意行受报口行不然耶。颇如口行意行受报身行不然耶。颇如身行口行受报意行亦然耶。颇如身行口行意行不受报而受报耶。颇三行不前不后受报耶。现法报生报后报。乐报苦报不苦不乐报。欲界系色无色界系。颇二行不前不后受报耶。善不善见谛所断思惟所断。此章义愿具演说

诸邪语彼是邪命耶。答曰。或邪语非邪命。云何邪语非邪命。答曰。除邪命作口四恶行。诸余口恶行是谓邪语非邪命。云何邪命非邪语。答曰。邪命作身三恶行。是谓邪命非邪语。云何邪语邪命。答曰。邪命作口四恶行。是谓邪语邪命。云何非邪语邪命。答曰。除邪命作身三恶行。诸余身恶行。是谓非邪命邪语。诸邪业彼是邪命耶。答曰。或邪业非邪命。云何邪业非邪命。答曰。除邪命作身三恶行。诸余身恶行。是谓邪业非邪命。云何邪命非邪业。答曰。邪命作口四恶行。是谓邪命非邪业。云何邪业邪命。答曰。邪命作身三恶行。是谓邪业邪命。云何非邪业邪命耶。答曰。除邪命作口四恶行。诸余口恶行。是谓非邪业邪命(身竟)。诸等语彼是等命耶。答曰。或等语非等命。云何等语非等命。答曰。除等命作口四妙行。诸余口妙行。是谓等语非等命。云何等命非等语。答曰。等命作身三妙行。是谓等命非等语。云何等语等命。答曰。等命作口四妙行。是谓等语等命。云何非等语等命。答曰。除等命作身三妙行。诸余身妙行。是谓非等语等命(等语竟)。诸等业彼是等命耶。答曰。或等业非等命。云何等业非等命。答曰。除等命作身三妙行。诸余身妙行。是谓等业非等命。云何等命非等业。答曰。等命作口四妙行。是谓等命非等业。云何等业等命。答曰。等命作身三妙行。是谓等业等命。云何非等业等命。答曰。除等命作口四妙行。诸余口妙行。是谓非等业等命(业竟)。三恶行三曲秽浊。身曲身秽身浊。口曲口秽口浊。意曲意秽意浊。身曲云何。答曰。虚伪盛身行也。身秽云何。答曰。嗔恚盛身行。身浊云何。答曰。淫盛身行。口曲云何。答曰。虚伪盛口行。口秽云何。答曰。嗔恚盛口行。口浊云何。答曰。淫盛口行。意曲云何。答曰。虚伪盛意行。意秽云何。答曰。嗔恚盛意行。意浊云何。答曰。淫盛意行。三恶行摄三曲秽浊耶。答曰。或三恶行非曲秽浊。云何恶行非曲秽浊。答曰。除欲界系虚伪欲盛嗔恚身口意恶行。诸余身口意恶行。是谓恶行非曲秽浊。云何曲秽浊非恶行耶。答曰。色界系虚伪爱身口意行。无色界系爱盛意行。是谓曲秽浊非恶行。云何恶行曲秽浊。答曰。欲界系虚伪欲盛嗔恚身口意恶行。是谓恶行曲秽浊。云何非恶行曲秽浊。答曰。除上尔所事。三妙行三净。三妙行摄三净。三净摄三妙行。答曰。随种相摄。三妙行三满。三妙行摄三满。答曰。或妙行非满。云何妙行非满。答曰。除无学身口妙行。诸余身口妙行尽意妙行是谓妙行非满。云何满非妙行。答曰。无学心是谓满非妙行。云何妙行满。答曰。无学身口妙行。是谓妙行满。云何非妙行满。答曰。除上尔所事。三净三满三净摄三满耶。答曰。或净非满。云何净非满。答曰。除无学身口净。诸余身口净尽意净。是谓净非满。云何满非净。答曰。无学心是谓满非净。云何净满。答曰。无学身口净。是谓净满。云何非净满。答曰。除上尔所事(满竟)。诸身恶行尽无巧便身行耶。答曰。如是。诸身恶行尽无巧便身行。颇无巧便身行彼非身恶行耶。答曰。有隐没无记身行。不隐没无记无巧便身行也。诸口恶行尽无巧便口行耶。答曰。如是。诸口恶行尽无巧便口行。颇无巧便口行彼非口恶行耶。答曰。有隐没无记口行。不隐没无记无巧便口行也。诸意恶行彼尽无巧便意行耶。答曰。或意恶行彼非无巧便意行。云何意恶行。彼非无巧便意行耶。答曰。意三恶行是谓意恶行。彼非无巧便意行。云何无巧便意行。彼非意恶行耶。答曰。隐没无记思。不隐没无记无巧便思。是谓无巧便意行。彼非意恶行。云何意恶行彼是无巧便意行耶。答曰。不善思。是谓意恶行。彼是无巧便意行。云何非意恶行彼非无巧便意行耶。答曰。除上尔所事(恶行竟)。诸身妙行尽巧便身行耶。答曰。如是。诸身妙行彼尽巧便身行。颇巧便身行彼非身妙行。答曰。有不隐没无记巧便身行也。诸口妙行尽巧便口行耶。答曰。如是。诸口妙行彼尽巧便口行。颇巧便口行彼非口妙行耶。答曰。有不隐没无记巧便口行也。诸意妙行彼尽巧便意行耶。答曰。或意妙行彼非巧便意行。云何意妙行彼非巧便意行。答曰。意三妙行。是谓意妙行彼非巧便意行。云何巧便意行彼非意妙行。答曰。不隐没无记巧便思。是谓巧便意行彼非意妙行。云何意妙行彼是巧便意行。答曰。善思是谓意妙行。彼是巧便意行。云何非意妙行非巧便意行耶。答曰。除上尔所事(妙行竟)。诸法由行得彼法。当言善不善无记耶。答曰。报义诸法由行得此法当言无记也。如是报义诸法由行得彼法无记耶。答曰。如是。若作是说。本无如来善心说语软语妙语软美语。此语善耶。答曰。如是。听我所说若报义诸法由行得彼法无记不应作是说。本无如来善心说语软语妙语软美语此语善。虽有是语此事不然。若作是语本无如来善心说语软语妙语软美语此语善。不应作是语。报义诸法由行得此法无记报义诸法由行得此法无记。此事不然。当作是语本无如来本余生时作善行受报报现在前。彼由此因缘得咽喉四大行四大。四大出声声非报也。颇过去行过去报耶。未来现在报耶。答曰。如是。颇未来行未来报耶。答曰。有无过去现在。颇现在行现在报耶。答曰。有过去无未来有(三世竟)。颇如身行受报。口行意行不然耶。答曰。有如身不净口净。当于尔时有善心若无记心。如身有净口不净。当于尔时有不善心若无记心。是谓如身行受报。口行意行不然。颇如口行受报。身行意行不然。答曰。有如身有净口不净。当于尔时有善心若无记心。如身不净口净。当于尔时有不善心若无记心。是谓如口行受报。身行意行不然。颇如意行受报身行口行不然耶。答曰。有如身不净口不净。当于尔时有善心如身净口净。当于尔时有不善心。是谓如意行受报身行口行不然。颇如身行口行受报意行不然耶。答曰。有如身不净口不净。当于尔时有善心若无记心如身净口净。当于尔时有不善心若无记心。是谓如身行口行受报意行不然。颇如身行意行受报口行不然耶。答曰。有如身有不净口净。当于尔时有不善心如身净口不净。当于尔时有善心。是谓如身行意行受报口行不然。颇如口行意行受报身行不然耶。答曰。有如身有净口不净。当于尔时有不善心如身不净口净。当于尔时有善心。是谓如口行意行受报身行不然。颇如身行口行受报意行亦然耶。答曰。有如身有不净口不净。当于尔时有不善心如身净口净。当于尔时有善心。是谓如身行口行受报意行亦然。颇如身行口行意行不受报而受报耶。答曰。有诸心不相应行受报。色心心所念法心不相应行也。颇三行不前不后受报现法报生报后报。答曰。受报现法报色。生报心心所念法。后报心不相应行。复次现法报心心所念法。生报色。后报心不相应行。复次现法报心不相应行。生报心心所念法。后报色(三竟)。乐报苦报不苦不乐报亦如是。欲界系色色界系心心所念法。无色界系心不相应行。复次欲界系心心所念法。色界系色无色界系心不相应行。复次欲界系心不相应行。色界系色无色界系心心所念法也(三界竟)。颇二行不前不后受报善不善耶。答曰。受报善色不善心心所念法心不相应行。复次善心心所念法心不相应行不善色(善不善二竟)。见谛所断思惟所断亦如是

阿毗昙邪语品第二竟(梵本二百四十五首卢秦五千一百言)

阿毗昙八犍度论卷第十五阿毗昙八揵度论卷第十六

        迦旃延子造

        符秦罽宾三藏僧伽提婆共竺佛念译

    行犍度害众生跋渠第三

颇害众生众生害不尽。颇不害众生众生害尽耶。颇害众生众生害尽。颇不害众生众生害不尽。颇不害众生众生害不尽。彼行受报必生地狱耶。颇行不善苦痛行不熟。彼行彼初受报彼必染污心。颇害众生命。后不受戒。当言一切众生中净耶。若一切众生中净。彼一切众生中受戒耶。设一切众生中受戒。彼一切众生中净耶。若身成就彼有身行耶。设成就身行彼有身耶。若成就身彼有口行耶。设成就口行彼有身耶。若成就身彼有意行耶。设成就意行彼有身耶。若成就身彼有身行口行耶。设成就身行口行彼有身耶。若成就身彼有身行意行耶。设成就身行意行彼有身耶。若成就身彼有口行意行耶。设成就口行意行彼有身耶。若成就身彼有身行口行意行耶。设成就身行口行意行彼有身耶(身竟)。若成就身行彼有口行耶。设成就口行彼有身行耶。若成就身行彼有意行耶。设成就意行彼有身行耶。若成就身行彼有口行意行耶。设成就口行意行彼有身行耶(身行竟)。若成就口行彼有意行耶。设成就意行彼有口行耶。若行欲未尽彼报欲未尽耶。设报欲未尽彼行欲未尽耶。若行欲尽彼报欲尽耶。设报欲尽彼行欲尽耶。若行有果彼行一切有报耶。设行有报彼行一切有果耶。若行无果彼行一切无报耶。设行无报彼行一切无果耶。若行不善彼行一切颠倒耶。设行颠倒彼行一切不善耶。若行非不善一切彼行非颠倒耶。设行非颠倒彼行一切非不善耶。若成就不善行。彼成就色无色界行耶。设成就色无色界行。彼成就不善行耶。若成就欲界善行。彼成就色无色界善行耶。设成就色无色界善行。彼成就欲界善行耶。若成就欲界行。彼成就色界行耶。设成就色界行。彼成就欲界行耶。若成就欲界行。彼成就无色界行耶。设成就无色界行。彼成就欲界行耶。若成就欲界行。彼成就色界行无漏行耶。设成就色界行无漏行。彼成就欲界行耶。若成就欲界行。彼成就无色界行无漏行耶。设成就无色界无漏行。彼成就欲界行耶。若成就色界行。彼成就无色界行无漏行耶。设成就无色界行无漏行。彼成就色界行耶。若成就无色界行。彼成就无漏行耶。设成就无漏行。彼成就无色界行耶。若成就欲界行色无色界行无漏行。彼命终后生何处。此章义愿具演说

颇害众生众生害不尽耶。答曰。有如断众生命。方便不息求。颇不害众生众生害尽耶。答曰。有如不害众生命方便息求。颇害众生众生害尽耶。答曰。有如害众生命方便息求。颇众生不害众生害不尽耶。答曰。有如不害众生命方便不息求。颇不害众生众生害不尽。彼彼行受报必生地狱耶。答曰。有如作无救方便中间命终。颇行不善苦痛行未熟。彼行彼初受报彼必染污心耶。答曰。有如作无救行。彼初受地狱中阴。颇害众生命彼后不受戒。当言一切众生中净耶。答曰。有如方便欲害众生中间值法。若一切众生中净(见谛人)。彼一切众生中受戒耶(受戒改往)。答曰。或一切众生中净。彼非一切众生中受戒(此言质约译人欲示)。云何一切众生中净。彼非一切众生中受戒。答曰。如不受戒中间值法。是谓一切众生中净。彼非一切众生中受戒。云何一切众生中受戒。彼非一切众生中净。答曰。如受戒越戒。是谓一切众生中受戒。彼非一切众生中净。云何一切众生中净。彼一切众生中受戒。答曰。如受戒不越戒。是谓一切众生中净。一切众生中受戒。云何不一切众生中净。彼不一切众生中受戒耶。答曰。除上尔所事。若成就身彼有身行耶。答曰。或成就身非身行。云何成就身非身行。答曰。卵膜渐厚处母胎凡夫人。若生欲界不有威仪。不处非威仪身。无教设有教便失。是谓成就身非身行。云何成就身行非身耶。答曰。无垢人生无色界。是谓成就身行非身。云何成就身身行。答曰。卵膜渐厚处母胎无垢人。若生欲界处威仪不处威仪。不威仪亦不不处威仪。身有教设有教不失。若生色界是谓成就身身行。云何不成就身非身行。答曰。凡夫人生无色界。是谓不成就身非身行。若成就身彼有口行耶。答曰。或成就身非口行。云何成就身非口行。答曰。卵膜渐厚处母胎凡夫人。若生欲界不威仪亦非不处威仪。口无教设有教便失。是谓成就身非口行。云何成就口行非身。答曰。无垢人生无色界。是谓成就口行非身。云何成就身口行。答曰。膜渐厚处母胎无垢人。若生欲界处威仪不处威仪。不威仪亦不不处威仪。口有教设有教不失。若生色界是谓成就身口行。云何不成就身非口行。答曰。凡夫人生无色界。是谓不成就身非口行。若成就身彼有意行耶。答曰。如是。若成就身彼有意行。颇成就意行非身耶。答曰。有生无色界也。若成就身彼有身口行耶。答曰。或成就身非身口行。及身行非口行及口行非身行及身口行。云何成就身非身口行。答曰。卵膜渐厚处母胎凡夫人。若生欲界非威仪亦不不处威仪。身口无教设有教便失。是谓成就身非身口行。云何成就身及身行非口行。答曰。若生欲界非威仪亦不不处威仪。身有教设有教不失。口无教设有教便失。是谓成就身及身行非口行。云何成就身及口行非身行。答曰。若生欲界不威仪亦不不处威仪。口有教设有教不失。身无教设有教便失。是谓成就身及口行非身行。云何成就身及身行口行。答曰。膜渐厚处母胎无垢人。若生欲界处威仪不处威仪。不威仪亦不不处威仪。身口有教设有教不失。若生色界。是谓成就身及身口行。设成就身口行彼成就身耶。答曰。或成就或不成就。云何成就。答曰。向所说是谓成就。云何不成就。答曰。无垢人生无色界。是谓不成就。若成就身彼成就身行意行耶。答曰。或成就身及意行。无身行及身行意行。云何成就身及意行非身行。答曰。卵膜渐厚处母胎凡夫人。若生欲界不威仪。亦不不处威仪。身无教设有教便失。是谓成就身及意行非身行云何成就身及身行意行。答曰。卵膜渐厚处母胎无垢人。若生欲界处威仪不处威仪。不威仪亦不不处威仪。身有教设有教不失。若生色界。是谓成就身及身行意行。设成就身行意行。彼成就身耶。答曰。或成就或不成就。云何成就。答曰。向所说是谓成就。云何不成就。答曰。无垢人生无色界。是谓不成就。若成就身彼成就口意行耶。答曰。或成就身及意行。非口行及口行意行。云何成就身及意行非口行。答曰。卵膜渐厚处母胎凡夫人。若生欲界不威仪亦不不处威仪。口无教设有教便失。是谓成就身及意行非口行。云何成就身及口行意行。答曰。卵膜渐厚处母胎无垢人。若生欲界处威仪不处威仪。不威仪亦不不处威仪口有教设有教不失。若生色界。是谓成就身及口行意行。设成就口意行彼成就身耶。答曰。或成就或不成就。云何成就。答曰。向所说是谓成就。云何不成就。答曰。无垢人生无色界。是谓不成就。若成就身彼有身口意行耶。答曰。或成就身及意行。非身口行及身意行。非口行及口意行。非身行及身口意行。云何成就身及意行非身口行。答曰。卵膜渐厚处母胎凡夫人。若生欲界不威仪亦不不处威仪。身口无教设有教便失。是谓成就身及意行非身口行。云何成就身及身意行非口行。答曰。若生欲界不威仪亦不不处威仪。身有教设有教不失。口无教设有教便失。是谓成就身及身意行非口行。云何成就身及口意行非身行耶。答曰。若生欲界不威仪亦不不处威仪。口有教设有教不失。身无教设有教便失。是谓成就身及口意行非身行。云何成就身及身口意行。答曰。卵膜渐厚处母胎无垢人若生欲界。处威仪不处威仪。不威仪亦不不处威仪。身口有教设有教不失。若生色界。是谓成就身及身口意行。设成就身口意行彼成就身耶。答曰。或成就或不成就。云何成就。答曰。向所说是谓成就。云何不成就。答曰。无垢人生无色界。是谓不成就(身竟)。若成就身行彼成就口行耶。答曰。或成就身行非口行。云何成就身行非口行。答曰。若生欲界不威仪。亦不不处威仪。身有教设有教不失。口无教设有教便失。是谓成就身行非口行。云何成就口行非身行。答曰。若生欲界不威仪。亦不不处威仪。口有教设有教不失。身无教设有教便失。是谓成就口行非身行。云何成就身口行。答曰。卵膜渐厚处母胎无垢人。若生欲界处威仪不处威仪。不威仪亦不不处威仪。身口有教设有教不失。若生色界无垢人生无色界。是谓成就身口行。云何不成就身口行。答曰。卵膜渐厚处母胎凡夫人。若生欲界不威仪亦不不处威仪。身口无教设有教便失。若生无色界凡夫人。是谓不成就身口行。若成就身行彼成就意行耶。答曰。如是。若成就身行彼成就意行。颇成就意行非成就身行。答曰。有卵膜渐厚处母胎凡夫人。若生欲界不威仪亦不不处威仪。身无教设有教便失。若凡夫人生无色界。若成就身行彼成就口意行耶。答曰。或成就身行及意行。非口行及口意行。云何成就身行及意行非口行。答曰。若生欲界不威仪亦不不处威仪。身有教设有教不失。口无教设有教便失。是谓成就身行及意行非口行。云何成就身行及口意行。答曰。卵膜渐厚处母胎无垢人。若生欲界处威仪不处威仪。不威仪亦不不处威仪。身口有教设有教不失。若生色界无垢人生无色界。是谓成就身行及口意行。设成就口意行彼成就身行耶。答曰。或成就或不成就。云何成就。答曰。向所说是谓成就。云何不成就。答曰。若生欲界不威仪。亦不不处威仪。身无教设有教便失。口有教设有教不失。是谓不成就。若成就口行彼成就意行耶。答曰。如是。若成就口行彼成就意行。颇成就意行非口行耶。答曰。有卵膜渐厚处母胎凡夫人。若生欲界不威仪亦不不处威仪。口无教设有教便失。凡夫人生无色界。若行淫未尽彼报淫未尽耶。答曰。如是。若行淫未尽彼报淫未尽。颇报淫未尽非行耶。答曰。有须陀洹见谛所断行淫尽。彼报淫未尽。若行淫尽彼报淫尽耶。答曰。如是。若报淫尽彼行淫尽。颇行淫尽非报耶。答曰。有须陀洹见谛所断行淫尽。彼报淫未尽。若行有果彼行尽有报耶。答曰。如是。若行有报此行有尽有果。颇行有果彼行无报耶。答曰。有无记无漏行。若行无果彼行尽无报耶。答曰。无行不有果。颇行无报耶。答曰。有无记无漏行。若行不善彼行尽颠倒耶。答曰。或行不善此行非颠倒。云何行不善彼行非颠倒。答曰。犹如有一有见果实。如是见如是语。有行有行果报。彼身恶行口意恶行。犹如有一不见有见想。不闻不别不识有识想。彼不以此想。不以此忍。不以此见。不以此欲不以此智慧。我不见不闻不别不识。犹如有一见无见想。闻别识无识想。彼不以此想。不以此忍。不以此见。不以此欲。不以此智慧。我见闻别识。是谓行不善彼行非颠倒。云何行颠倒此行非不善。答曰。犹如有一无见无果实。如是见如是语。无行无行果报。彼身妙行口意妙行。犹如有一无见有见想。不闻不别不识有识想。彼以此想。以此忍。以此见。以此欲。以此智慧。我见闻别识。犹如有一见无见想。闻别识无识想。彼以此想。以此忍。以此见。以此欲。以此智慧。我不见闻别识。是谓行颠倒彼行非不善。云何行不善彼行颠倒。答曰。犹如有一见无见无果实。如是见。如是语。无行无行果报。彼身恶行口意恶行。犹如有一不见不见想。不闻不别不识有不识想。彼不以此想。不以此忍。不以此见。不以此欲。不以此智慧。我见闻别识。犹如有一见有见想。闻别识有识想。彼不以此想。不以此忍。不以此见。不以此欲。不以此智慧。我不见不闻不别不识。是谓行不善彼行颠倒。云何行非不善彼行非颠倒。答曰。犹如有一见有果实。如是见。如是语。有行有行果报。彼身妙行口意妙行。犹如有一不见有不见想。不闻不别不识有不识想。彼以此想。以此忍。以此见。以此欲。以此智慧。我不见不闻不别不识。犹如有一见有见想。闻别识有识想。彼以此想。以此忍。以此见。以此欲。以此智慧。我见闻别识。是谓行非不善此行非颠倒。非亦如是。若成就不善行。彼成就色无色界行耶。答曰。如是。若成就不善行彼成就色无色界行。颇成就色无色界行。非成就不善行耶。答曰。有若生欲界欲爱尽。若生色界若成就欲界善行。彼成就色无色界善行耶。答曰。或成就欲界善行。非色无色界善行。云何成就欲界善行。非色无色界善行。答曰。若生欲界不断善本。不得色无色界善心。是谓成就欲界善行。非色无色界善行。云何成就色无色界善行。非欲界善行。答曰。若生色界得无色界善心。是谓成就色无色界善行非欲界善行。云何成就欲界善行。色无色界善行。答曰。若生欲界得色无色界善心。是谓成就欲界善行色无色界善行。云何不成就欲界善行。非色无色界善行。答曰。善根本断。是谓不成就欲界善行。非色无色界善行。若成就欲界行彼成就色界行耶。答曰。如是。设成就色界行彼成就欲界行耶。答曰。如是。若成就欲界行。彼成就无色界行耶。答曰。如是。若成就欲界行。彼成就无色界行耶。颇成就无色界行。彼不成就欲界行。答曰。有若生无色界。若成就欲界行。彼成就无漏行耶。答曰。或成就欲界行。不成就无漏行。云何成就欲界行。非无漏行耶。答曰。若凡夫人生欲色界。是谓成就欲界行非无漏行。云何成就无漏行非欲界行耶。答曰。无垢人生无色界。是谓成就无漏行非欲界行。云何成就欲界行无漏行耶。答曰。无垢人若生欲界色界。是谓成就欲界行无漏行。云何不成就欲界行无漏行。答曰。凡夫人生无色界。是谓不成就欲界行无漏行。若成就色界行。彼成就无色界行耶。答曰。如是。若成就色界行。彼成就无色界行耶。颇成就无色界行。非成就色界行耶。答曰。有生无色界若成就色界行。彼成就无漏行耶。答曰。或成就色界行非无漏行。云何成就色界行非无漏行。答曰。凡夫人生欲界色界。是谓成就色界行非无漏行。云何成就无漏行非色界行。答曰。无垢人生无色界。是谓成就无漏行非色界行。云何成就色界行无漏行。答曰。无垢人生欲界色界。是谓成就色界行无漏行。云何不成就色界行无漏行。答曰。凡夫人生无色界。是谓不成就色界行无漏行。若成就无色界行。彼成就无漏行耶。答曰。如是。若成就无漏行。彼成就无色界行。颇成就无色界行非无漏行耶。答曰。有凡夫人。若成就欲界行。色无色界无漏行。此命终后当生何所。答曰。或欲界。或色界无色界。或无处所

阿毗昙害众生品第三竟(梵本三百九首卢四千六百三十一言)

阿毗昙八揵度论卷第十六阿毗昙八揵度论卷第十七

        迦旃延子造

        符秦罽宾三藏僧伽提婆共竺佛念译

    行犍度中有教无教跋渠第四

  有教及无教　　诸行彼果实
  或有漏学者　　思惟戒在后

若成就身教彼成就无教耶。设成就无教彼成就教耶。若成就善不善隐没。无记不隐没。无记身教彼成就无教耶。设成就无教彼成就教耶。若成就过去身教。彼成就无教耶。设成就无教彼成就教耶。若成就过去善不善隐没。无记不隐没。无记身教彼成就无教耶。设成就无教彼成就教耶。若成就未来身教彼成就无教耶。设成就无教彼成就教耶。若成就未来善不善隐没。无记不隐没。无记身教彼成就无教耶。设成就无教。彼成就教耶。若成就现在身教。彼成就无教耶。设成就无教彼成就教耶。若成就现在善不善隐没。无记不隐没。无记身教彼成就无教耶。设成就无教彼成就教耶。口教亦如是。诸行欲界系彼行欲界系果耶。设行欲界系果。彼行欲界系耶。诸行色界系。彼行色界系果耶。设行色界系果。彼行色界系耶。诸行无色界系果。彼行无色界系耶。设行无色界系果。彼行无色界系耶。诸无漏行彼行无漏果耶。设行无漏果。彼行无漏耶。诸行不欲界。彼行不欲界果耶。设行非欲界果。彼行非欲界耶。诸行非色界。彼行非色界果耶。设行非色界果。彼行非色界耶。诸行非无色界。彼行非无色界果耶。设行非无色界果。彼行非无色界耶。诸行非无漏彼行非无漏果耶。设行非无漏果。彼行非无漏耶。颇有漏行有漏果耶。有漏行无漏果耶。有漏行有漏无漏果耶。颇无漏行无漏果耶。无漏行有漏果耶。无漏行有漏无漏果耶。颇有漏无漏行有漏无漏果耶。有漏无漏行有漏果耶。有漏无漏行无漏果耶。颇学行学果耶。学行无学果耶。学行非学非无学果耶。颇无学行无学果耶。无学行学果耶。无学行非学非无学果耶。颇非学非无学行非学非无学果耶。非学非无学行学果耶。非学非无学行无学果耶。又世尊言。不修身不修戒不修心不修智慧。云何不修身不修戒不修心不修智慧。若不修身。彼不修戒不修心不修智慧耶。设不修慧。彼不修身耶。若不修戒彼不修心不修慧。设不修慧彼不修戒耶。若不修心彼不修智慧耶。设不修智慧彼不修心耶。又世尊言。修身修戒修心修慧。云何修身修戒修心修慧。若修身彼修戒修心修慧耶。设修慧彼修身耶。若修戒彼修心修慧耶。设修慧彼修戒耶。若修心彼修慧。设修慧彼修心耶。颇成就过去戒。非未来现在此种耶。及未来非现在。及现在非未来。及未来现在此种耶。颇成就未来戒非过去现在此种。及过去非现在及现在。非过去及过去现在此种耶。颇成就现在戒非过去未来此种。及过去非未来及未来非过去及过去未来此种耶。此章义愿具演说

若成就身教彼成就无教耶。答曰。或教非无教。云何教非无教。答曰。生欲界非律仪亦不不处律仪。身有教彼不得无教。本有教不失彼不得无教。是谓教非无教。云何无教非教。答曰。无垢人处母胎卵膜渐厚。若生欲界处律仪不得戒律仪。身无教本有教便失彼得无教。若生色界身无教。若无垢人生无色界。是谓无教非教。云何教无教。答曰。生欲界处律仪。不得戒律仪身有教彼得无教。本有教不失彼得无教处。戒律仪不处戒律仪处。亦不律仪亦不不律仪处。身有教彼得无教。本有教不失彼得无教。若生色界身有教。是谓教无教。云何非教无教。答曰。凡夫人处母胎卵膜渐厚。若生欲界不律仪亦不不律仪处。身无教本有教便失。彼不得无教凡夫人生无色界。是谓非教无教也。若成就善身教。彼成就无教耶。答曰。或教非无教也。云何教非无教。答曰。生欲界不律仪处善身有教。彼不得无教本有教不失。彼不得无教不律仪。亦不不律仪处善身有教。彼不得无教本有教不失彼不得无教。是谓教非无教。云何无教非教。答曰。无垢人处母胎卵膜渐厚。若生欲界律仪处不得戒律仪。善身无教本有教便失彼得无教。若生色界善身无教。无垢人生无色界是谓无教非教也。云何教无教。答曰。生欲界律仪处不得戒律仪。身有教彼得无教本有教不失。彼得无教戒律仪处不律仪处。不律仪亦不不律仪。善身有教彼得无教。本有教不失彼得无教。若生色界善身有教。是谓教无教。云何非教无教。答曰。凡夫人处母胎卵膜渐厚。若生欲界不律仪处。善身无教本有教便失彼不得无教。不律仪亦不不律仪处。善身无教本有教便失彼不得无教。若凡夫人生无色界。是谓非教无教。若成就不善身教彼成就无教耶。答曰。如是。若成就无教彼成就教也。颇成就。教非无教耶。答曰。有生欲界律仪处。不善身有教彼不得无教。本有教不失彼不得无教。不律仪亦不不律仪处。不善身有教彼不得无教。本有教不失彼不得无教也。若成就隐没无记身教。彼成就无教耶。答曰。无有成就无教。颇成就教耶。答曰。有生色界隐没无记身教也。若成就不隐没无记身教。彼成就无教耶。答曰。无有成就无教。颇成就教耶。答曰。有生欲界若生色界。不隐没无记身有教也(不定教竟)。若成就过去身教。彼成就无教耶。答曰。或教非无教。云何教非无教。答曰。生欲界不律仪亦不不律仪处。本身有教不失彼不得无教。是谓教非无教。云何无教非教。答曰。无垢人处母胎膜渐厚。若生欲界律仪处不得戒律仪。本身无教有教便失。若生色界本身无教。若学生无色界。是谓无教非教。云何教无教。答曰。生欲界律仪处不得戒律仪。本身有教不失彼得无教。戒律仪处不律仪处。不律仪亦不不律仪处。本身有教不失彼得无教。若生色界本身有教不失。是谓教无教。云何非教无教。答曰。凡夫人处母胎卵膜渐厚。若生欲界不得律仪。亦不不律仪处。本身无教设有教便失。阿罗汉凡夫人生无色界。是谓非教无教。若成就过去善身教。彼成就无教耶。答曰。或教非无教。云何教非无教。答曰。生欲界不律仪处。本善身有教不失彼不得无教。不律仪亦不不律仪处。本善身有教不失彼不得无教。是谓教非无教。云何无教非教。答曰。无垢人处母胎卵膜渐厚。若生欲界律仪处不得戒律仪。本善身无教有教便失。若生色界本善身无教。若学生无色界。是谓无教非教。云何教无教。答曰。生欲界律仪处不得戒律仪。本善身有教不失彼得无教。律仪处不律仪处。不律仪亦不不律仪处。本善身有教不失彼得无教。若生色界本善身有教不失。是谓教无教。云何非教无教。答曰。凡夫人处母胎卵膜渐厚。若生欲界不律仪处。善身本无教有教便不失。律仪处亦不不律仪处。本善身无教有教便失。阿罗汉凡夫人生无色界。是谓非教无教。若成就过去不善身教。彼成就无教耶。答曰。如是。若成就无教彼成就教也。颇成就。教非无教耶。答曰。有生欲界律仪处。本不善身有教不失彼不得无教。不律仪亦不不律仪处。本不善身有教不失彼不得无教也。若成就过去隐没无记。不隐没无记身教。彼成就无教耶。答曰。无有成就教非无教(过去竟)。若成就未来身教。彼成就无教耶。答曰。无有成就教也。颇成就无教。答曰。有无垢人处母胎卵膜渐厚。若生欲界得色界善心。若生色界无垢人生无色界也。若成就未来善身教。彼成就无教耶。答曰。无有成就教。颇成就无教耶。答曰。有无垢人处母胎膜渐厚。若生欲界得色界善心生色界。无垢人生无色界也。若成就未来不善。隐没无记不隐没无记身教。彼成就无教耶。答曰。无有成就教非无教(未来竟)。若成就现在身教彼成就无教耶。答曰。或教非无教。云何教非无教。答曰。生欲界律仪处不得戒律仪。身有教彼不得无教。本有教不失彼不得无教。不律仪亦不不律仪处。身有教彼不得无教。本有教不失彼不得无教。若生色界身有教。是谓教非无教。云何无教非教。答曰。生欲界戒律仪处不得戒律。入定不入定。身无教本有教便失彼得无教戒律。仪不律亦不不律处。身无教本有教便失彼得无教。若生色界入定。是谓无教非教。云何教无教。答曰。生欲界律处不得戒律。身有教彼得无教本有教不失。彼得无教戒律处。不律亦不不律处。身有教彼得无教本有教不失彼得无教。是谓教无教。云何非教无教。答曰。凡夫人处母胎卵膜渐厚。若生欲界律处不得戒律不入定。身无教本有教便失彼不得无教。不律亦不不律处。身无教本有教便失彼不得无教。若生色界不入定。身无教生无色界。是谓非教无教。若成就现在善身教。彼成就无教。答曰。或教非无教。云何教非无教。答曰。生欲界律处不得戒律。善身有教彼不得无教。本有教不失彼不得无教。不律处不律亦不不律处。善身有教彼不得无教。本有教不失。彼不得无教。若生色界善身有教。是谓教非无教。云何无教非教。答曰。生欲界律处不得戒律入定不入定。善身无教本有教便失。彼得无教戒律处。不律亦不不律处。善身无教本有教便失彼得无教。若生色界入定。是谓无教非教。云何教无教。答曰。生欲界律处不得戒律。善身有教彼得无教。本有教不失彼得无教。戒律处不律处不律亦不不律处。善身有教彼得无教本有教不失彼得无教。是谓教无教。云何非教无教。答曰。处母胎卵膜渐厚。若生欲界律处不得戒律不入定。善身无教本有教便失。彼不得无教。不律处不律亦不不律处。善身无教本有教便失。彼不得无教。若生色界不入定善身无教生无色界。是谓非教无教若成就现在不善身教彼成就无教耶。答曰。或教非无教。云何教非无教。答曰。生欲界戒律处不善身有教彼不得无教。本有教不失。彼不得无教。不律亦不不律处。不善身有教彼不得无教。本有教不失。彼不得无教。是谓教非无教。云何无教非教。答曰。生欲界戒律处。不善身无教本有教便失。彼得无教。不律处不律亦不不律处。不善身无教本有教便失。彼得无教。是谓无教非教。云何教无教。答曰。生欲界律处不善身有教彼得无教。本有教不失。彼得无教。不律处不律亦不不律处。不善身有教彼得无教。本有教不失。彼得无教。是谓教无教。云何非教无教。答曰。凡夫人处母胎卵膜渐厚。若生欲界律处不善身无教本有教便失。彼不得无教。不律亦不不律处。不善身无教本有教便失。彼不得无教。若生色无色界。是谓非教无教。若成就现在隐没无记身教。彼成就无教耶。答曰。无有成就无教。颇成就教耶。答曰。有生色界隐没无记身有教也。若成就现在不隐没无记身教。彼成就无教耶。答曰。无有成就无教。颇成就教耶。答曰。有生欲界若生色界不隐没无记身有教(现在竟)。口教亦如是。诸行欲界彼行欲界果耶。答曰。如是。诸行欲界彼行欲界果。颇行欲界果彼行非欲界耶。答曰有。如色界道欲界化化作欲界语也。诸行色界彼行色界果耶。答曰。如是。诸行色界果彼行色界。颇行色界彼行非色界果耶。答曰有。如色界道欲界化化作欲界语。如色界道断结趣证也。诸行无色界彼行无色界果耶。答曰。如是。诸行无色界果。彼行无色界耶。颇行无色界。彼行非无色界果耶。答曰有。如无色界道断结趣证也。诸行无漏彼行无漏果耶。答曰。如是。诸行无漏彼行无漏果也。颇行无漏果彼行非无漏耶。答曰有。如色无色界道断结趣证也。诸行非欲界彼行非欲界果耶。答曰。如是。诸行非欲界果。彼行非欲界。颇行非欲界彼行非不欲界果耶。答曰有。如色界道欲界化化作欲界语诸行非色界。彼行非色界果耶。答曰。如是。诸行非色界彼行非色界果。颇行非色界果。彼行非不色界耶。答曰有。如色界道欲界化化作欲界语。如色界道断结趣证也。诸行非无色界彼行非无色界果耶。答曰。如是。诸行非无色界。彼行非无色界果。颇行非无色界果。彼行非不无色界耶。答曰有。如无色界道断结趣证也。诸行非无漏。彼行非无漏果耶。答曰。如是。诸行非无漏果彼行非无漏。颇行非无漏彼行非不无漏果耶。答曰有。如色无色界道断结趣证。颇有漏行有漏果耶。答曰有。所谓依果报果。颇有漏行无漏果耶。答曰有。解脱果颇有漏行有漏无漏果耶。答曰有。所谓依果报果解脱果(有漏竟)。颇无漏行无漏果耶。答曰有。所依果解脱果。颇无漏行有漏果耶。答曰无。颇无漏行有漏无漏果耶。答曰无。颇有漏行有漏无漏果耶。答曰无。颇有漏无漏行有漏果耶。答曰无。颇有漏无漏行无漏果耶。答曰。有解脱果(有漏无漏竟)。颇学行学果耶。答曰有。所依果颇学行无学果。答曰有。所依果。颇学行非学非无学果耶。答曰。有解脱果(学竟)。颇无学行无学果耶。答曰有。所依果。颇无学行学果耶。答曰无。颇无学行非学非无学果耶。答曰有。解脱果(无学竟)。颇非学非无学行非学非无学果耶。答曰有。所依果报果解脱果。颇非学非无学行学果耶。答曰无也。颇非学非无学行无学果耶。答曰无。又世尊言不修身不修戒不修心不修慧。云何不修身。答曰。身欲未尽贪未尽念未尽渴未尽。复次以无碍道尽色爱。彼道不修不猗。如是不修。身不修戒亦如是。云何不修心。答曰。心欲未尽贪未尽念未尽渴未尽。复次以无碍道尽无色爱。彼道不修不猗。如是不修心不修慧亦如是。若不修身彼不修戒。答曰。如是。设不修戒彼不修身耶。答曰。如是。若不修身彼不修心耶。答曰。如是。若不修身彼不修心。颇不修心非不修身。答曰有。色爱尽上爱未尽。若不修身彼不修慧。答曰。如是。若不修身彼不修慧。颇不修慧非不修身。答曰有。色爱尽上爱未尽。若不修戒彼不修心耶。答曰。如是。若不修戒彼不修心。颇不修心非不修戒耶。答曰有。色爱尽上爱未尽。若不修戒彼不修慧。答曰。如是。若不修戒彼不修慧。颇不修慧非不修戒。答曰有。色爱尽上爱未尽。若不修心彼不修慧耶。答曰。如是。设不修慧彼不修心。答曰。如是。又世尊言。修身修戒修心。修慧云何修身。答曰。身爱尽贪尽念尽渴尽。复次以无碍道尽色爱。彼道修猗。如是修身戒亦如是。云何修心。答曰。心爱尽贪尽念尽渴尽。复次以无碍道尽无色爱彼道修猗。如是修心修慧亦如是。若修身彼修戒耶。答曰。如是。设修戒彼修身耶。答曰。如是。若修身彼修心耶。答曰。如是。若修心彼修身耶。颇修身不修心耶。答曰有。色爱尽上爱未尽。若修身彼修慧耶。答曰。如是。若修慧彼修身耶。颇修身不修慧。答曰有。色爱尽上爱未尽。若修戒彼修心耶。答曰。如是。若修心彼修戒耶。颇修戒不修心耶。答曰有。色爱尽上爱未尽。若修戒彼修慧耶。答曰。如是。若修慧彼修戒。颇修戒不修慧。答曰有。色爱尽上爱未尽。若修心彼修慧耶。答曰。如是。设修慧彼修心耶。答曰。如是。颇成就过去戒。非未来现在此种耶。答曰有。教戒尽不失。此种不现在前及未来非现在此种耶。答曰有。道共定共戒尽不失。此种不现在前及现在非未来此种耶。答曰有。教戒已尽不失。此种现在前及未来现在此种耶。答曰有。道共定共戒尽不失此种现在前(过去竟)。颇成就未来戒非过去现在此种耶。答曰有。阿罗汉生无色界及过去非现在此种。答曰有。道共定共戒尽不失。此种不现在前及现在非过去此种耶。答曰有。最初得无漏律。及过去现在此种耶。答曰有。道共定共戒尽不失。此种现在前(未来竟)。颇成就现在戒非过去未来此种耶。答曰有。最初得戒律仪。及过去非未来此种耶。答曰有。教戒尽不失。此种现在前。及未来非过去此种。答曰有。最初得无漏律仪。及过去未来此种耶。答曰有。道共定共戒尽不失。此种现在前

阿毗昙有教无教跋渠第四竟(梵本三百七十三首卢秦四千九百五十四言)

    阿毗昙行揵度自行跋渠第五

云何自行以何等故自行所可用行。自行彼行当言过去耶。未来现在耶。所可用行自行彼行成就耶。设行成就彼行自行耶。所可用行非自行。彼行不成就耶。设行不成就彼行不自行耶。所可用行自行。彼行必受报耶。设行必受报彼行自行耶。所可用行非自行。彼行必不受报耶。设行必不受报。彼行非自行耶。所可用行成就彼行必受报耶。设行必受报彼行成就耶。所可用行不成就。彼行必不受报耶。设行必不受报彼行不成就。如有须陀洹不善行苦痛报未熟彼以何故障地狱道畜生饿鬼。又世尊言。是谓世尊弟子。尽地狱尽畜生尽饿鬼不堕恶道。须陀洹有此智。悟我尽地狱尽畜生尽饿鬼尽。不堕恶道为不自悟。云何学谋害一切学谋害果耶。云何住寿行。云何舍寿行。云何心乱。以何等缠相应法尽不善。佛语云何佛语当言善耶无记耶。佛语名何等法。契经诗记偈因缘叹本末譬喻生方广未曾有法义。名何法印。名何法数。名何法算。名何法书。名何法颂。名何法种种伎艺。名何法。若学戒成就。彼成就非学非无学戒耶。设成就非学非无学戒。彼成就学戒耶。若成就无学戒。彼成就非学非无学戒耶。设成就非学非无学戒。彼成就无学戒耶。此章义愿具演说

云何自行。答曰。若行报是谓今得。此有彼行生受报。是谓自行。以何等自行。答曰。此行自果自依自报。复次此行受报时。此意受报非余。以是故自行所可用行自行。此行当言过去耶。未来现在耶。答曰。彼行过去世所可用行。自行彼行成就耶。答曰。或行自行此行非成就。云何行自行彼行不成就耶。答曰。行报于今得有。彼行生受报彼行失。是谓行自行彼行不成就。云何行成就此行非自行。答曰。行报不于今得有。此行生不受报彼行不失。是谓行成就此行非自行。云何行自行彼行成就。答曰。行报于今得有。彼行生受报彼行不失。是谓行自行彼行成就。云何行非自行。彼行不成就耶。答曰。行报不于今得有。彼行生不受报彼行失。是谓行非自行彼行不成就。非亦如是所可用行。自行彼行必受报耶。答曰。或行自行彼行必不受报。云何行自行彼行必不受报。答曰。行报于今得有。彼行生受报彼行后报。是谓行自行彼行必不受报。云何行必受报彼行非自行。答曰。行报不于今得有。彼行生不受报彼行报未熟。是谓行必受报彼行非自行。云何行自行彼行必受报。答曰。行报于今得有。彼行生受报彼行非后报。是谓行自行彼行必受报。云何行非自行彼行必不受报。答曰。行报不于今得有。彼行生不受报彼行报熟。是谓行非自行彼行必不受报。非亦如是所可用行成就彼行必受报耶。答曰。或行成就彼行必不受报。云何行成就彼行必不受报。答曰。诸行过去不善。设善有漏报熟彼行不行。诸行未来不善。设善有漏得必不生。若无记无漏行成就。是谓行成就彼行必不受报。云何行必受报彼行不成就。答曰。诸行过去不善。设善。有漏报不熟彼行失。诸行未来不善设善有漏不得必生。是谓行必受报彼行不成就。云何行成就彼行必受报。答曰。诸行过去不善。设善有漏报不熟彼行不失。诸行未来不善。设善有漏得必生。诸行现在不善设善有漏。是谓行成就彼行必受报。云何行不成就彼行必不受报。答曰。诸行过去不善。设善有漏报熟彼行失。诸行未来不善。设善有漏不得必不生。若无记无漏行不成就。是谓行不成就。彼行必不受报。非亦如是。若有须陀洹不善行苦痛报未熟。彼以何故障地狱道畜生饿鬼。答曰。二结种缚系。必堕地狱畜生饿鬼。见谛断结种。思惟断结种。彼须陀洹见谛断结尽。思惟断不尽。彼参差具不往地狱畜生饿鬼。譬如车二轮不坏能有所至。一轮坏不有所至。如是二结种缚系往地狱畜生饿鬼。见谛断思惟断结种。彼须陀洹见谛断结尽。思惟断结不尽。彼参差具不往堕地狱畜生饿鬼。譬如鹰鸟二翅不坏能飞至空。一翅坏不能至空。如是二结种缚系往堕地狱畜生饿鬼国中。彼须陀洹见谛断结尽思惟断结不尽。彼参差具不往地狱畜生饿鬼也。又世尊言。是谓世尊弟子地狱尽畜生饿鬼尽尽不堕恶道。须陀洹有此智。悟我地狱尽畜生饿鬼尽。尽不堕恶道为不自悟耶。答曰。不自悟。云何得知。答曰。往信世尊。如世尊言。诸自省察四法。彼殷勤自进我地狱尽畜生饿鬼尽。尽不堕恶道。复次须陀洹有四法智。苦智习智尽智道智。须陀洹无尽智无生智也。云何学谋害。答曰。如学欲未尽。被他捶打若手石刀杖。彼痛所逼发心使彼酷痛。使彼妇无子如是学谋害。如学淫尽为彼捶打若手石刀杖。彼痛所逼从无欲退已。退便发心言使彼酷痛使彼妇无子。如是学谋害一切学所谋害果耶。答曰。不也。诸众生有大力所作行彼则不果也。云何住寿行。答曰。如阿罗汉。以衣钵户钥履屣针筒及余什具施僧。若人便发心言。我缘是报使增益寿。作是愿已入顶四禅。彼所缘报则成寿报如是住寿。云何舍寿。答曰。如阿罗汉。以衣钵户钥履屣针筒及余什具施僧。若人便发心言。我所得寿报即成施报。作是愿已入顶四禅。彼寿报即成施报如是舍寿。云何心乱。答曰。以四事心乱。非人形。狂象形马形羠形[犛-未+牙]牛形。见已怖懅心乱。若非人嗔捶打肢节。彼得酷痛心乱。或诸大错心乱。本行报对心乱。以何等缠相应法尽不善耶。答曰。无惭无愧。佛语云何。答曰。如来语(一)所说(二)[日*弊](博计反)诃罗(三)婆沙(四苏诈反)耆罗(五)尼留谛(六)语句(七)语声(八)口行(九)口教(十天竺十种皆语也)。是谓佛语。佛语当言善耶无记耶。答曰。佛语或善或无记。云何善。答曰。善心如来语所说。如上十事是谓善。云何无记。答曰。无记心如来语所说。如上十事是谓无记。佛语名何等法。答曰。名身句身语身次第住。契经(一)诗(二)记(三)偈(四)因缘(五)叹(六)本末(七)譬喻(八)生(九)方广(十)未曾有(十一)法义(十二十二部经)。名何等法。答曰。名身句身语身次第住。印名何法。答曰。巧所造身行。彼所克智数名何法。答曰。巧所造口行。彼所克智算名何法。答曰。巧所造意行。彼所克智书名何法。答曰。巧所造身行。彼所克智颂名何法。答曰。巧所造口行。彼所克智种种克行名何法。答曰。慧为首方便所扰。彼彼所克诸智也若学成就戒彼成就非学非无学戒耶。答曰。或学成就戒非非学非无学戒。云何学成就戒非非学非无学戒。答曰。学生无色界。是谓学成就戒非非学非无学戒。云何成就非学非无学戒非学耶。答曰。阿罗汉凡夫人生欲色界。是谓非学非无学成就戒非学。云何学成就戒非学非无学耶。答曰。学生欲色界。是谓学成就戒非学非无学。云何非学成就戒非非学非无学。答曰。阿罗汉凡夫人生无色界。是谓非学成就戒非非学非无学。若成就无学戒。彼成就非学非无学戒耶。答曰。或无学成就戒。非非学非无学。云何无学成就戒非非学非无学耶。答曰。阿罗汉生无色界。是谓成就无学戒非非学非无学。云何成就非学非无学戒非无学。答曰。学凡夫人生欲色界。是谓成就非学非无学戒非无学。云何成就无学戒非学非无学耶。答曰。阿罗汉生欲色界。是谓成就无学戒非学非无学。云何非无学成就戒非非学非无学。答曰。学凡夫人生无色界。是谓非成就无学戒非非学非无学也

自行八渠第五竟(梵本一百八十五首卢秦二千三百七十八言)

行揵度第四竟

阿毗昙八揵度论卷第十七阿毗昙八犍度论卷第十八

        迦旃延子造

        符秦罽宾三藏僧伽提婆共竺佛念译

    四大犍度第五

  四大所造　　是谓缘也　　见谛成就
  自造在后

    净根跋渠第一

四大所造入。几可见几不可见。几有对几无对。几有漏几无漏。几有为几无为。几过去几未来几现在。几善几不善几无记。几欲界系几色界系几不系。几学几无学几非学非无学。几思惟断几不断(入竟)。若成就四大。彼造色成就耶。设造色成就。彼成就四大耶。若不成就四大。彼不成就造色耶。设不成就造色。彼不成就四大耶(造色竟)。若成就四大。彼成就善色耶。设成就善色。彼成就四大耶。若成就四大。彼成就不善色耶。设成就不善色。彼成就四大耶。若成就四大。彼成就隐没无记色耶。设成就隐没无记色。彼成就四大耶。若成就四大。彼成就不隐没无记色耶。设成就不隐没无记色。彼成就四大耶(只门竟)。若成就四大。彼成就善不善色耶。设成就善不善色。彼成就四大耶。若成就四大。彼成就善隐没无记色耶。设成就善隐没无记色。彼成就四大耶。若成就四大。彼成就善不隐没无记色耶。设成就善不隐没无记色。彼成就四大。若成就四大。彼成就不善隐没无记色耶。设成就不善隐没无记色。彼成就四大耶。若成就四大。彼成就不善不隐没无记色耶。设成就不善不隐没无记色。彼成就四大耶。若成就四大。彼成就隐没无记不隐没无记色耶。设成就隐没无记不隐没无记色。彼成就四大耶(双竟)。若成就四大。彼成就善不善隐没无记色耶。设成就善不善隐没无记色。彼成就四大耶。若成就四大。彼成就善不善不隐没无记色耶。设成就善不善不隐没无记色。彼成就四大耶。若成就四大。彼成就善隐没无记不隐没无记色耶。设成就善隐没无记不隐没无记色。彼成就四大耶。若成就四大。彼成就不善隐没无记不隐没无记色耶。设成就不善隐没无记不隐没无记色。彼成就四大耶(三竟)。若成就四大。彼成就善不善隐没无记不隐没无记色耶。设成就善不善隐没无记不隐没无记色。彼成就四大耶(四大竟)。若成就善色。彼成就不善色耶。设成就不善色。彼成就善色耶。若成就善色。彼成就隐没无记色耶。设成就隐没无记色。彼成就善色耶。若成就善色。彼成就不隐没无记色。设成就不隐没无记色。彼成就善色耶(只竟)。若成就善色。彼成就不善隐没无记色耶。设成就不善隐没无记色。彼成就善色耶。若成就善色。彼成就不善不隐没无记色耶。设成就不善不隐没无记色。彼成就善色耶。若成就善色。彼成就隐没无记不隐没无记色耶。设成就隐没无记不隐没无记色。彼成就善色耶(双竟)。若成就善色彼成就不善隐没无记不隐没无记色耶。设成就不善隐没无记不隐没无记色。彼成就善色耶(善竟)。若成就不善色。彼成就隐没无记色耶。设成就隐没无记色。彼成就不善色耶。若成就不善色。彼成就不隐没无记色耶。设成就不隐没无记色。彼成就不善色耶。若成就不善色。彼成就隐没无记不隐没无记色耶。设成就隐没无记不隐没无记色。彼成就不善色耶(不善竟)。若成就隐没无记色。彼成就不隐没无记色耶。设成就不隐没无记色。彼成就隐没无记色耶。四大由何三昧灭。造色嗔恚有对更乐。有觉有观乐根苦根。喜根忧根护根。抟食更乐食意念食识食。由何三昧灭。四大已尽无余。当言作何果。造色嗔恚有对更乐有觉有观。乐根苦根喜根忧根护根。抟食乐食意念食识食由何三昧灭。四大已尽无余。当言作何果。此章义愿具演说

四大造入几可见。答曰一。几不可见。答曰。八二少入。几有对。答曰。九一少入。几无对。答曰。一少入。几有漏。答曰。九二少入。几无漏。答曰。一少入。几有为。答曰。九二少入。几过去。答曰。十一少入。几未来。答曰。十一少入。几现在。答曰。十一少入。几善。答曰。三少入。几不善。答曰。三少入。几无记。答曰。七三少入。几欲界系。答曰。二九少入。几色界系。答曰。九少入。几不系。答曰。一少入。几学。答曰。一少入。几无学。答曰。一少入。几非学非无学耶。答曰。九二少入。几思惟断。答曰。九二少入。几不断。答曰。一少入(入竟)。若成就四大。彼成就造色耶。答曰。如是。若成就四大。彼成就造色。颇成就造色非四大耶。答曰。有无垢人生无色界也。若不成就四大。彼不成就造色耶。答曰。如是。若不成就造色。彼不成就四大。颇不成就四大非不造色耶。答曰。有。无垢人生无色界(造竟)。若成就四大。彼成就善色耶。答曰。或成就四大非善色。云何成就四大非善色。答曰。凡夫人处母胎卵膜渐厚。若生欲界不戒律处。善身口无教本有教便失。不戒律不不戒律处。善身口无教本有教便失。是谓成就四大非善色。云何成就善色非四大耶。答曰。无垢人生无色界。是谓成就善色非四大。云何成就四大善色。答曰。无垢人处母胎卵膜渐厚。若生欲界戒律处不戒律处。亦不戒律不不戒律处。善身口有教本有教不失。若生色界。是谓成就四大善色也。云何非成就四大非善色。答曰。凡夫人生无色界。是谓非成就四大非善色。若成就四大。彼成就不善色耶。答曰。如是。若成就不善色。彼成就四大耶。颇成就四大非不善色。答曰。有处母胎卵膜渐厚。若生欲界戒律处。不善身口无教本有教便失。亦不戒律不不戒律处。不善身口无教本有教便失若生色界耶。若成就四大。彼成就隐没无记色耶。答曰。如是。若成就隐没无记色。彼成就四大。颇成就四大非隐没无记色耶。答曰。有生欲界。若生色界隐没无记身口无教也。若成就四大。彼成就不隐没无记色耶。答曰。如是。设成就不隐没无记色。彼成就四大耶。答曰。如是(只竟)。若成就四大。彼成就善不善色耶。答曰。或成就四大非善不善色。及善色非不善色。及不善色。非善色及善不善色。云何成就四大非善不善色耶。答曰。凡夫人处母胎卵膜渐厚。若生欲界亦不戒律不不戒律处。善不善身口无教。本有教便失。是谓成就四大非善不善色。云何成就四大及善色非不善色。答曰。无垢人处母胎卵膜渐厚。若生欲界戒律处。不善身口无教。本有教便失。亦不戒律不不戒律处。善身口有教本有教不失。不善身口无教本有教便失。若生色界。是谓成就四大及善色非不善色。云何成就四大及善色非善色耶。答曰。生欲界不戒律处。善身口无教本有教便失。亦不戒律不不戒律处。不善身口有教本有教不失。善身口无教本有教便失。是谓成就四大及善色非善色。云何成就四大。及善不善色耶。答曰。生欲界戒律处。不善身口有教本有教不失。不戒律处。善身口有教本有教不失。亦不戒律。不不戒律处。善不善身口有教本有教不失。是谓成就四大及善不善色。设成就善不善色。彼成就四大耶。答曰。如是。若成就四大。彼成就善隐没无记色。答曰。或成就四大非善隐没无记色。及善色非隐没无记色。及善隐没无记色。云何成就四大非善隐没无记色。答曰。凡夫人处母胎卵膜渐厚。若生欲界不戒律处。善身口无教本有教便失。亦不戒律不不戒律处。善身口无教本有教便失。是谓成就四大非善隐没无记色。云何成就四大及善色非隐没无记色。答曰。无垢人处母胎卵膜渐厚。若生欲界戒律处不戒律处。亦不戒律不不戒律处。善身口有教本有教不失。若生色界隐没无记身口无教。是谓成就四大及善色非隐没无记色。云何成就四大及善隐没无记色。答曰。生色界隐没无记。身口有教。是谓成就四大及善隐没无记色。设成就善隐没无记色。彼成就四大耶。答曰。如是。若成就四大。彼成就善不隐没无记色耶。答曰。或成就四大及不隐没无记色非善色。及善不隐没无记色。云何成就四大。及不隐没无记色非善色耶。答曰。凡夫人处母胎卵膜渐厚。若生欲界不戒律处。善身口无教本有教便失。亦不戒律不不戒律处。善身口无教本有教便失。是谓成就四大。及不隐没无记色非善色。云何成就四大。及善不隐没无记色。答曰。无垢人处母胎卵膜渐厚。若生欲界戒律处不戒律处。亦不戒律不不戒律处。善身口有教本有教不失。若生色界。是谓成就四大及善不隐没无记色。设成就善不隐没无记色。彼成就四大。答曰。如是。若成就四大。彼成就不善隐没无记色。答曰。无。若成就四大。彼成就不善不隐没无记色。答曰。或成就四大。及不隐没无记色。非不善色及不善不隐没无记色。云何成就四大。及不隐没无记色。非不善色耶。答曰。处母胎卵膜渐厚。若生欲界戒律处。不善身口无教本有教便失。亦不戒律不不戒律处。不善身口无教本有教便失。若生色界。是谓成就四大。及不隐没无记色非不善色。云何成就四大。及不善不隐没无记色。答曰。生欲界戒律处。不善身口有教本有教不失。不戒律处亦不戒律不不戒律处。不善身口有教本有教不失。是谓成就四大。及不善不隐没无记色。设成就不善不隐没无记色。彼成就四大耶。答曰。如是。若成就四大。彼成就隐没无记不隐没无记色。答曰。或成就四大。及不隐没无记色。非隐没无记色及隐没无记。不隐没无记色。云何成就四大。及不隐没无记色。非隐没无记色耶。答曰。生欲界若生色界。隐没无记身口无教。是谓成就四大。及不隐没无记色。非隐没无记色。云何成就四大。及隐没无记。不隐没无记色。答曰。生色界隐没无记身口有教。是谓成就四大。及隐没无记不隐没无记色。设成就隐没无记不隐没无记色。彼成就四大耶。答曰。如是(只竟)。若成就四大。彼成就善不善隐没无记色耶。答曰。无。若成就四大。彼成就善不善不隐没无记色。答曰。或成就四大及不隐没无记色。非善不善色及善不隐没无记色。非不善色及不善不隐没无记色。非善色及善不善不隐没无记色。云何成就四大及不隐没无记色。非善不善色。答曰。凡夫人处母胎卵膜渐厚。若生欲界亦不戒律不不戒律处。善不善身口无教本有教便失。是谓成就四大。及不隐没无记色。非善不善色。云何成就四大。及善不隐没无记色。非不善色。答曰。无垢人处母胎卵膜渐厚。若生欲界戒律处。不善身口无教本有教便失。亦不戒律不不戒律处。善身口有教本有教不失。不善身口无教本有教便失。若生色界。是谓成就四大及善不隐没无记色非不善色。云何成就四大及不善不隐没无记色非善色耶。答曰。若生欲界不戒律处。善身口无教本有教便失。亦不戒律不不戒律处。不善身口有教本有教不失。善身口无教本有教便失。是谓成就四大及不善不隐没无记色非善色。云何成就四大及善不善不隐没无记色。答曰。若生欲界戒律处。不善身口有教本有教不失。不戒律处。善身口有教本有教不失。亦不戒律不不戒律处。善不善身口有教本有教不失。是谓成就四大及善不善不隐没无记色。若成就善不善不隐没无记色。彼成就四大耶。答曰。如是。若成就四大。彼成就善隐没无记不隐没无记色。答曰。或成就四大及不隐没无记色。非善隐没无记色。及善不隐没无记色。非隐没无记色。及善隐没无记色。不隐没无记色。云何成就四大及不隐没无记色。非善隐没无记色。答曰。凡夫人处母胎卵膜渐厚。若生欲界不戒律处。善身口无教本有教便失。亦不戒律不不戒律处。善身口无教本有教便失。是谓成就四大及不隐没无记色。非善隐没无记色。云何成就四大及善不隐没无记色。非隐没无记色。答曰。无垢人处母胎卵膜渐厚。若生欲界戒律处不戒律处。亦不戒律不不戒律处。善身口有教本有教不失。若生色界隐没无记身口无教。是谓成就四大及善不隐没无记色。非隐没无记色。云何成就四大及善隐没无记不隐没无记色。答曰。生色界隐没无记。身口有教。是谓成就四大。及善隐没无记不隐没无记色。设成就善隐没无记不隐没无记色。彼成就四大耶。答曰。如是。若成就四大。彼成就不善隐没无记不隐没无记色耶。答曰。无(三竟)。若成就四大。彼成就善不善隐没无记不隐没无记色。答曰。此亦无也(四大竟)。若成就善色。彼成就不善色耶。答曰。或成就善色非不善色。云何成就善色非不善色。答曰。无垢人处母胎卵膜渐厚。若生欲界戒律处。不善身口无教本有教便失。亦不戒律不不戒律处。善身口有教本有教不失。不善身口无教本有教便失。若生色界。无垢人生无色界。是谓成就善色非不善色。云何成就不善色非善色。答曰。生欲界不戒律处。善身口无教本有教便失。亦不戒律不不戒律处。不善身口有教本有教不失。善身口无教本有教便失。是谓成就不善色非善色。云何成就善不善色。答曰。生欲界戒律处不善身口有教本有教不失。不戒律处善身口有教本有教不失。亦不戒律不不戒律处。善不善身口有教本有教不失。是谓成就善。不善色。云何不成就善不善色耶。答曰。凡夫人处母胎卵膜渐厚。若生欲界。亦不戒律不不戒律处。善不善身口无教本有教便失。凡夫人生无色界。是谓不成就善色不善色。若成就善色。彼成就隐没无记色耶。答曰。如是。若成就隐没无记色。彼成就善色。颇成就善色非隐没无记色耶。答曰。有。无垢人处母胎卵膜渐厚。生欲界戒律处不戒律处。亦不戒律不不戒律处。善身口有教本有教不失。若生色界隐没无记身口无教若无垢人生无色界。若成就善色。彼成就不隐没无记色。答曰。或成就善色。非不隐没无记色。云何成就善色非不隐没无记色。答曰。无垢人生无色界。是谓成就善色非不隐没无记色。云何成就不隐没无记色非善色耶。答曰。凡夫人处母胎卵膜渐厚。若生欲界不戒律处。善身口无教本有教便失。亦不戒律不不戒律处。善身口无教本有教便失。是谓成就不隐没无记色非善色。云何成就善色不隐没无记色。答曰。无垢人处母胎膜渐厚。若生欲界戒律处不戒律处。亦不戒律不不戒律处。善身口有教本有教不失。若生色界。是谓成就善色不隐没无记色。云何不成就善色不隐没无记色。答曰。凡夫人生无色界。是谓不成就善色不隐没无记色(双竟)。若成就善色。彼成就不善隐没无记色耶。答曰。此亦无也。若成就善色。彼成就不善不隐没无记色耶。答曰。或成就善色。非不善不隐没无记色。及不隐没无记色。非不善色及不善不隐没无记色。云何成就善色。非不善不隐没无记色。答曰。无垢人生无色界。是谓成就善色非不善不隐没无记色。云何成就善色及不隐没无记色。非不善色。答曰。无垢人处母胎卵膜渐厚。若生欲界戒律处。不善身口无教本有教便失。亦不戒律不不戒律处。善身口有教本有教不失。不善身口无教本有教便失。若生色界。是谓成就善色及不隐没无记色。非不善色。云何成就善色及不善不隐没无记色。答曰。生欲界戒律处。不善身口有教本有教不失。不戒律处。善身口有教本有教不失。亦不戒律不不戒律处。善不善身口有教本有教不失。是谓成就善色及不善不隐没无记色。设成就不善不隐没无记色。彼成就善色耶。答曰。或成就或不成就。云何成就。答曰。向所说是谓成就。云何不成就。答曰。生欲界不戒律处。善身口无教本有教便失。亦不戒律不不戒律处。不善身口有教本有教不失。善身口无教本有教便失。是谓不成就。若成就善色。彼成就隐没无记。不隐没无记色耶。答曰。或成就善色非隐没无记不隐没无记色。及不隐没无记色非隐没无记色。及隐没无记不隐没无记色。云何成就善色。非隐没无记不隐没无记色。答曰。无垢人生无色界。是谓成就善色非隐没无记不隐没无记色。云何成就善色及不隐没无记色。非隐没无记色。答曰。无垢人处母胎膜渐厚。若生欲界戒律处不戒律处。亦不戒律不不戒律处。善身口有教本有教不失。若生色界隐没身口无教。是谓成就善色及不隐没无记色。非隐没无记色。云何成就善色及隐没无记不隐没无记色。答曰。生色界隐没无记。身口有教。是谓成就善色。及隐没无记不隐没无记色。设成就隐没无记不隐没无记色。彼成就善色耶。答曰。如是(双竟)。若成就善色。彼成就不善色隐没无记不隐没无记色耶。答此亦无也(善色竟)。若成就不善色。彼成就隐没无记色耶。答曰。此无也。若成就不善色。彼成就不隐没无记色。答曰。如是。若成就不善色。彼成就不隐没无记色。颇成就不隐没无记色。非不善色耶。答曰。有。处母胎卵膜渐厚。若生欲界戒律处。不善身口无教本有教便失。亦不戒律不不戒律处。不善身口无教本有教便失。若生色界。若成就不善色。彼成就隐没无记不隐没无记色耶。答曰。此无(不善竟)。若成就隐没无记色。彼成就不隐没无记色耶。答曰。如是。若成就隐没无记色。彼成就不隐没无记色。颇成就不隐没无记色。非隐没无记色耶。答曰。有。生欲界若色界。隐没无记身口无教也。四大由何三昧灭。答曰。或依四或依未来造色。或依四或依未来有对更乐有觉有观。或依初或依未来乐根。或依三或依未来喜根。或依二或依未来。苦根忧根抟食。依未来护根更乐食意念食识食。或依七或依未来。四大已尽无余。当言作何果。答曰。阿罗汉果。或无处所造色有对更乐有觉有观乐根喜根阿罗汉果。或无处所苦根忧根抟食阿那含果阿罗汉果。或无处所护根更乐食意念食识食阿罗汉果

阿毗昙净根跋渠第一竟(梵本三百九十二首卢秦五千八百八十九言)

阿毗昙八揵度论卷第十八阿毗昙八揵度论卷第十九

        迦旃延子造

        符秦罽宾三藏僧伽提婆共竺佛念译

    四大犍度中缘跋渠第二

四大彼四大几缘缘。四大造色几缘缘。造色彼造色几缘缘。造色四大几缘缘。四大心心法几缘缘。心心法彼心心法几缘缘。心心法四大几缘缘。四大眼入几缘缘。眼入彼眼入几缘缘。眼入四大几缘缘。四大乃至法入几缘缘。法入彼法入几缘缘。法入四大几缘缘(入竟)。四大眼根几缘缘。眼根四大几缘缘。四大乃至无知根几缘缘。无知根四大几缘缘(根竟)。以何等故。四大一起一住一尽。然不相应。心心法一起一住一尽。然彼相应。颇过去四大造过去色未来现在色。颇未来四大造未来色过去现在色。颇现在四大造现在色过去未来色。若成就过去四大。彼成就过去造色耶。设成就过去造色。彼成就过去四大。若成就过去四大。彼成就未来四大。设成就未来四大。彼成就过去四大耶。若成就过去四大。彼成就未来造色。设成就未来造色。彼成就过去四大耶。若成就过去四大。彼成就现在四大。设成就现在四大。彼成就过去四大耶。若成就过去四大。彼成就现在造色。设成就现在造色。彼成就过去四大耶(过去四大竟)。若成就过去造色。彼成就未来四大耶。设成就未来四大。彼成就过去造色耶。若成就过去造色。彼成就未来造色。设成就未来造色。彼成就过去造色。若成就过去造色。彼成就现在四大。设成就现在四大。彼成就过去造色耶。若成就过去造色。彼成就现在造色耶。设成就现在造色。彼成就过去造色(过去造色竟)。若成就未来四大。彼成就未来造色。设成就未来造色。彼成就未来四大。若成就未来四大。彼成就现在四大。设成就现在四大。彼成就未来四大耶。若成就未来四大。彼成就现在造色。设成就现在造色。彼成就未来四大耶(未来四大竟)。若成就未来造色。彼成就现在四大。设成就现在四大。彼成就未来造色。若成就未来造色。彼成就现在造色耶。设成就现在造色。彼成就未来造色耶(未来造色竟)。若成就现在四大。彼成就现在造色耶。设成就现在造色。彼成就现在四大(三世成就竟)。过去四大。彼过去四大几缘缘。过去四大过去造色几缘缘。过去造色。彼过去造色几缘缘。过去造色过去四大几缘缘。过去四大未来四大几缘缘。未来四大。彼未来四大几缘缘。未来四大过去四大几缘缘。过去四大未来造色几缘缘。未来造色。彼未来造色几缘缘。未来造色过去四大几缘缘。过去四大现在四大几缘缘。现在四大彼现在四大几缘缘。现在四大过去四大几缘缘。过去四大现在造色几缘缘。现在造色。彼现在造色几缘缘。现在造色过去四大几缘缘(过去四大竟)。过去造色未来四大几缘缘。未来四大过去造色几缘缘。过去造色未来造色几缘缘。未来造色过去造色几缘缘。过去造色现在四大几缘缘。现在四大过去造色几缘缘。过去造色现在造色几缘缘。现在造色过去造色几缘缘(过去造色竟)。未来四大未来造色几缘缘。未来造色未来四大几缘缘。未来四大现在四大几缘缘。现在四大未来四大几缘缘。未来四大现在造色几缘缘。现在造色未来四大几缘缘(未来四大竟)。未来造色现在四大几缘缘。现在四大未来造色几缘缘。未来造色现在造色几缘缘。现在造色未来造色几缘缘(未来造色竟)。现在四大现在造色几缘缘。现在造色现在四大几缘缘(三世竟)。若成就欲界系四大。彼成就欲界系造色耶。设成就欲界系造色。彼成就欲界系四大耶。若成就色界系四大。彼成就色界系造色耶。设成就色界系造色。彼成就色界系四大耶。欲界系四大。彼欲界系四大几缘缘。欲界系四大欲界系造色几缘缘。欲界系造色。彼欲界系造色几缘缘。欲界系造色。彼欲界系四大几缘缘。色界系四大。彼色界系四大几缘缘。色界系四大。色界系造色几缘缘。色界系造色。彼色界系造色几缘缘。色界系造色。色界系四大几缘缘。若成就欲界系四大。彼成就色界系四大耶。设成就色界系四大。彼成就欲界系四大耶。若成就欲界系四大。彼成就色界系造色耶。设成就色界系造色。彼成就欲界系四大耶。若成就欲界系造色。彼成就色界系四大。设成就色界系四大。彼成就欲界系造色。若成就欲界系造色。彼成就色界系造色耶。设成就色界系造色。彼成就欲界系造色耶。欲界系四大。色界系四大几缘缘。色界系四大。欲界系四大几缘缘。欲界系四大。色界系造色几缘缘。色界系造色。欲界系四大几缘缘。欲界系造色。色界系四大几缘缘。色界系四大。欲界系造色几缘缘。欲界系造色。色界系造色几缘缘。色界系造色。欲界系造色几缘缘。诸色欲界系。彼色一切欲界系四大造耶。设色欲界系四大造。彼色一切欲界系耶。诸色色界系。彼色一切色界系四大造耶。设色色界系四大造。彼色一切色界系耶。诸色过去。彼色一切过去四大造耶。设色过去四大造。彼色一切过去耶。诸色未来。彼色一切未来四大造耶。设色未来四大造。彼色一切未来耶。诸色现在。彼色一切现在四大造耶。设色现在四大造。彼色一切现在耶。云何地。云何地种。云何水。云何水种。云何火。云何火种。云何风。云何风种。地何入摄几识识。地地种。水水种。火火种。风风种。四大几入摄几识识。此章义愿具演说。四大彼四大因增上。四大造色因增上。造色彼造色因增上。造色彼四大因增上。四大心心法缘增上。心心法彼心心法因次第缘增上。心心法四大因增上。四大眼入因增上。眼入彼眼入因增上。眼入四大增上。耳鼻舌身入香味入亦如是。四大色入因增上。色入彼色入因增上。色入四大因增上。声细滑入亦如是。四大意入缘增上。意入彼意入因次第缘增上。意入四大因增上。四大法入因缘增上。法入彼法入因次第缘增上。法入四大因增上(入竟)。四大眼根因增上。眼根四大一增上。耳鼻舌身根。男根女根亦如是。四大意根缘增上。意根四大因增上。乐根苦根喜根忧根护根信根精进念定慧根亦如是。四大命根一增上。命根四大一增上。四大未知根缘增上。未知根四大一增上。已知根无知根亦如是(根竟)。以何等故。四大一起一住一尽。然不相应。心心法一起一住一尽。然彼相应。答曰。如说得四大若大若小。然非心心法。复次心心法共缘四大无缘不得无缘相应。颇过去四大。造过去色未来现在色。答曰。有。颇未来四大造未来色。答曰。有。无过去现在。颇现在四大造现在色。答曰。有。无过去未来有。若成就过去四大。彼成就过去造色耶。答曰。无过去成就四大。有过去成就造色。无垢人处母胎卵膜渐厚。若生欲界戒律处不戒律处。亦不戒律不不戒律处。身口本有教不失。若生色界。若学生无色界也。若成就过去四大。彼成就未来四大耶。答曰无。有成就过去四大。亦非成就未来四大也。若成就过去四大。彼成就未来造色耶。答曰。无成就过去四大。有成就未来造色无垢人处母胎卵膜渐厚。若生欲界得色界善心。若生色界。无垢人生无色界也。若成就过去四大。彼成就现在四大耶。答曰。无成就过去四大。有成就现在四大。生欲界色界也。若成就。过去四大。彼成就现在造色耶。答曰。无成就过去四大。有成就现在造色。生欲界色界也(过去四大竟)。若成就过去造色。彼成就未来四大耶。答曰。无成就未来四大。有成就过去造色。无垢人处母胎卵膜渐厚。若生欲界戒律处不戒律处。亦不戒律不不戒律处。身口本有教不失。若生色界学生无色界也。若成就过去造色。彼成就未来造色耶。答曰。或成就过去造色。非未来造色。云何成就过去造色。非未来造色。答曰。生欲界戒律处。不得色界善心。不戒律处不戒律亦不不戒律处。身口本有教不失。是谓成就过去造色非未来造色。云何成就未来造色非过去造色。答曰。阿罗汉生无色界。是谓成就未来造色非过去造色。云何成就过去造色未来造色。答曰。无垢人处母胎卵膜渐厚。若生欲界得色界善心。若生色界学生无色界。是谓成就过去造色未来造色。云何不成就过去未来造色。答曰。凡夫人处母胎卵膜渐厚。若生欲界亦不戒律不不戒律处。身口本无教有教便失。若凡夫人生无色界。是谓不成就过去未来造色。若成就过去造色。彼成就现在四大耶。答曰。或成就过去造色。非现在四大。云何成就过去造色非现在四大。答曰。学生无色界。是谓成就过去造色非现在四大。云何成就现在四大非过去造色。答曰。凡夫人处母胎卵膜渐厚。若生欲界亦不戒律处亦不不戒律处。身口本无教有教便失。是谓成就现在四大非过去造色。云何成就过去造色现在四大。答曰。无垢人处母胎卵膜渐厚。若生欲界戒律处不戒律处。亦不戒律不不戒律处。身口本有教不失。若生色界。是谓成就过去造色现在四大。云何非成就过去造色现在四大。答曰。阿罗汉凡夫人生无色界。是谓非成就过去造色现在四大。若成就过去造色。彼成就现在造色耶。答曰。或成就过去造色非现在造色。云何成就过去造色。非现在造色。答曰。学生无色界。是谓成就过去造色非现在造色。云何成就现在造色非过去造色。答曰。凡夫人处母胎卵膜渐厚。若生欲界亦不戒律处不不戒律处。身口本无教有教便失。是谓成就现在造色非过去造色。云何成就过去造色现在造色。答曰。无垢人处母胎卵膜渐厚。若生欲界戒律处不戒律处。亦不戒律不不戒律处。身口本有教不失。若生色界。是谓成就过去造色现在造色。云何非成就过去造色现在造色耶。答曰。阿罗汉凡夫人生无色界。是谓不成就过去现在造色(过去造色竟)。若成就未来四大。彼成就未来造色耶。答曰。无成就未来四大。有成就未来造色。无垢人处母胎卵膜渐厚。若生欲界得色界善心。生色界无垢人生无色界也。若成就未来四大。彼成就现在四大耶。答曰。无成就未来四大。有成就现在四大。生欲色界。若成就未来四大。彼成就现在造色耶。答曰。无成就未来四大。有成就现在造色。生欲色界(未来四大竟)。若成就未来造色。彼成就现在四大。答曰。或成就未来造色非现在四大。云何成就未来造色非现在四大。答曰。无垢人生无色界。是谓成就未来造色非现在四大。云何成就现在四大非未来造色。答曰。凡夫人处母胎卵膜渐厚。若生欲界不得色界善心。是谓成就现在四大非未来造色。云何成就未来造色现在四大。答曰。无垢人处母胎卵膜渐厚。若生欲界得色界善心。若生色界。是谓成就未来造色现在四大。云何非成就未来造色现在四大。答曰。凡夫人生无色界。是谓非成就未来造色现在四大。若成就未来造色。彼成就现在造色耶。答曰。或成就未来造色。非成就现在造色。云何成就未来造色。非现在造色。答曰。无垢人生无色界。是谓成就未来造色非现在造色。云何成就现在造色非未来造色。答曰。凡夫人处母胎卵膜渐厚。若生欲界不得色界善心。是谓成就。现在造色。非成就未来造色。云何成就未来现在造色。答曰。无垢人处母胎卵膜渐厚。若生欲界得色界善心。若生色界。是谓成就未来现在造色。云何非成就未来现在造色。答曰。凡夫人生无色界。是谓非成就未来现在造色(现在造色竟)。若成就现在四大。彼成就现在造色。答曰。如是。设成就现在造色。彼成就现在四大。答曰。如是(三世成就竟)。过去四大彼过去四大因增上。过去四大过去造色因增上。过去造色彼过去造色因增上。过去造色过去四大因增上。过去四大未来四大因增上。未来四大彼未来四大因增上。未来四大过去四大一增上。过去四大未来造色因增上。未来造色彼未来造色因增上。未来造色过去四大一增上。过去四大现在四大因增上。现在四大彼现在四大因增上。现在四大过去四大一增上。过去四大现在造色因增上。现在造色彼现在造色因增上。现在造色过去四大一增上(过去四大竟)。过去造色未来四大因增上。未来四大过去造色一增上。过去造色未来造色因增上。未来造色过去造色一增上。过去造色现在四大因增上。现在四大过去造色一增上。过去造色现在造色因增上。现在造色过去造色一增上(过去造色竟)。未来四大未来造色因增上。未来造色未来四大因增上。未来四大现在四大一增上。现在四大未来四大因增上。未来四大现在造色一增上。现在造色未来四大因增上(未来四大竟)。未来造色现在四大一增上。现在四大未来造色因增上。未来造色现在造色一增上。现在造色未来造色因增上(未来造色竟)。现在四大现在造色因增上。现在造色现在四大因增上(三世竟)。若成就欲界系四大。彼成就欲界系造色。答曰。如是。设成就欲界系造色。彼成就欲界系四大耶。答曰。如是。若成就色界系四大。彼成就色界系造色耶。答曰。如是。若成就色界系四大。彼成就色界系造色也。颇成就色界系造色。非成就色界系四大耶。答曰。有生欲界得色界善心。色界四大不现在前也。欲界系四大彼欲界系四大因增上。欲界系四大欲界系造色因增上。欲界系造色彼欲界系造色因增上。欲界系造色。欲界系四大因增上。色界系四大。彼色界系四大因增上。色界系四大。色界系造色因增上。色界系造色彼色界系造色因增上。色界系造色色界系四大因增上。若成就欲界系四大。彼成就色界系四大耶。答曰。或成就欲界系四大。非色界系四大。云何成就欲界系四大。非色界系四大。答曰。生欲界色界四大不现在前。是谓成就欲界系四大。非色界系四大。云何成就色界系四大非欲界系四大。答曰。生色界欲界化不化不作欲界语。是谓成就色界系四大非欲界系四大。云何成就欲界色界系四大。答曰。生欲界色界四大现在前。若生色界欲界化化作欲界语。是谓成就欲界色界系四大。云何不成就欲界系四大非色界系四大。答曰。生无色界。是谓不成就欲界系四大非色界系四大。若成就欲界系四大。彼成就色界系造色耶。答曰。或成就欲界系四大非色界系造色。云何成就欲界系四大非色界系造色。答曰。生欲界不得色界善心。是谓成就欲界系四大非色界系造色。云何成就色界系造色非欲界系四大。答曰。生色界欲界化化不作欲界语。是谓成就色界系造色非欲界系四大。云何成就欲界系四大色界系造色。答曰。生欲界得色界善心。若生色界欲界化化作欲界语。是谓成就欲界系四大色界系造色。云何不成就欲界系四大。非色界系造色。答曰。生无色界。是谓不成就欲界系四大。非色界系造色。若成就欲界系造色。彼成就色界系四大耶。答曰。或成就欲界系造色非色界系四大。云何成就欲界系造色非色界系四大。答曰。生欲界色界四大不现在前。是谓成就欲界系造色非色界系四大。云何成就色界系四大非欲界系造色。答曰。生色界欲界化不化不作欲界语。是谓成就色界系四大非欲界系造色。云何成就欲界系造色色界系四大。答曰。生欲界色界四大现在前。若生色界欲界化化作欲界语。是谓成就欲界系造色色界系四大。云何不成就欲界系造色色界系四大。云何不成就欲界系造色非非色界系四大。答曰。生无色界。是谓不成就欲界系造色非色界系四大。若成就欲界系造色。彼成就色界系造色。答曰。或成就欲界系造色非色界系造色。云何成就欲界系造色非色界系造色。答曰。生欲界不得色界善心。是谓成就欲界系造色非色界系造色。云何成就色界系造色非欲界系造色。答曰。生色界欲界化不化不作欲界语。是谓成就色界系造色非欲界系造色。云何成就欲界系造色色界系造色。答曰。生欲界得色界善心。若生色界欲界化化作欲界语。是谓成就欲界系造色色界系造色。云何不成就欲界系造色非色界系造色。答曰。生无色界。是谓不成就欲界系造色非色界系造色。欲界系四大。色界系四大一增上。色界系四大。欲界系四大一增上。欲界系四大。色界系造色一增上。色界系造色。欲界系四大一增上。欲界系造色色界系四大一增上。色界系四大。欲界系造色一增上。欲界系造色。色界系造色一增上。色界系造色。欲界系造色一增上也。诸色欲界系。彼色一切欲界系四大造耶。答曰。或色欲界系。彼色非欲界系四大造。云何色欲界系。彼色非欲界系四大造。答曰。欲界系四大。是谓色欲界系彼色。非欲界系四大造。云何色欲界系四大造。彼色非欲界系。答曰。诸色不系。欲界系四大造。是谓色欲界系四大造。彼色非欲界系。云何色欲界系。彼色欲界系四大造。答曰。诸色欲界系。欲界系四大造。是谓色欲界系。彼色欲界系四大造。云何色不欲界系。彼色非欲界系四大造。答曰。色界系四大。诸色色界系色界系四大造。诸色不系色界系四大造。是谓色非欲界系。彼色非欲界系四大造。诸色色界系彼色一切。色界系四大造耶。答曰。或色色界系彼色。非色界系四大造。云何色色界系彼色。非色界系四大造。答曰。色界系四大。是谓色色界系彼色。非色界系四大造。云何色色界系四大造。彼色非色界系。答曰。诸色不系色界系四大造。是谓色色界系四大造。彼色非色界系。云何色色界系。彼色色界系四大造。答曰。诸色色界系。色界系四大造。是谓色色界系彼色。色界系四大造。云何色非色界系。彼色非色界系四大造。答曰。欲界系四大。诸色欲界系欲界系四大造。诸色不系欲界系四大造。是谓色非色界系。彼色非色界系四大造。诸色过去彼色。一切过去四大造耶。答曰。或色过去彼色非过去四大造。云何色过去彼色非过去四大造。答曰。过去四大。是谓色过去彼色。非过去四大造。云何色过去四大造。彼色非过去。答曰。诸色未来现在过去四大造。是谓色过去四大造彼色非过去。云何色过去彼色过去四大造。答曰。诸色过去过去四大造。是谓色过去彼色过去四大造。云何色非过去。彼色非过去四大造。答曰。未来现在四大。诸色未来现在现在四大造。诸色未来未来四大造。是谓色非过去彼色非过去四大造。诸色未来彼色一切未来四大造耶。答曰。如是诸色未来四大造。彼色一切未来也。颇色未来彼色非未来四大造耶。答曰。有未来四大。诸色未来过去现在四大造。诸色现在彼色一切现在四大造耶。答曰。或色现在彼色非现在四大造。云何色现在。彼色非现在四大造。答曰。现在四大。诸色现在过去四大造。是谓色现在。彼色非现在四大造。云何色现在四大造。彼色非现在。答曰。诸色未来现在四大造。是谓色现在四大造彼色非现在。云何色现在彼色现在四大造。答曰。诸色现在现在四大造。是谓色现在彼色现在四大造。云何非现在色彼色。非现在四大造。答曰。过去未来四大诸色过去未来过去四大造。诸色未来未来四大造。是谓色非现在。彼色非现在四大造。云何地地种。云何水水种。云何火火种。云何风风种。地云何。答曰。形处。地种云何。答曰坚。水云何。答曰。形处。水种云何。答曰湿。火云何。答曰形处。火种云何。答曰热。风云何。答曰风。风种云何。答曰动。地一入摄色入。二识识眼识意识。地种一入摄细滑入。二识识身识意识。水一入摄色入。二识识眼识意识。水种一入摄细滑入。二识识身识意识。火一入摄色入。二识识眼识意识。火种一入摄细滑入。二识识身识意识。风风种一入摄细滑入。二识识身识意识

缘跋渠第二竟(梵本五百四十七首卢秦六千五百五十言)

阿毗昙八揵度论卷第十九阿毗昙八犍度论卷第二十

        迦旃延子造

        符秦罽宾三藏僧伽提婆共竺佛念译

    四大揵度中见谛跋渠第三

见谛成就世尊弟子。欲爱未尽。诸色界系身口戒律。成就彼色何四大造。生欲界有漏入初禅。有漏入第二第三第四禅。彼诸身口戒律彼色何四大造。生欲界无漏入初禅。无漏入第二第三第四禅。彼诸身口戒律彼色何四大造。生色界有漏入初禅。有漏入第二第三第四禅。彼诸身口戒律彼色何四大造。生色界无漏入初禅。无漏入第二第三第四禅。彼诸身口戒律彼色何四大造。世尊弟子生无色界。诸无漏成就身口戒律。彼色何四大造。无色界没生欲界最初得四大。彼四大何四大因。无色界没生色界最初得四大。彼四大何四大因。色界没生欲界最初得四大。此四大何四大因。生欲界色界化化作色界语。彼色何四大造。生色界欲界化化作欲界语。彼色何四大造。化当言四大非四大耶。当言造色非造色耶。当言有心无心耶。当言用谁心语。中阴当言四大非四大耶。当言造色非造色。当言有心无心。当言用谁心语。久远世名何法。劫名何法。心起住灭名何法。颇法四缘生三缘生二缘生一缘生。云何法因相应。云何法因不相应。云何法因相应因不相应。云何法非因相应。亦非因不相应。云何法共缘缘云何法不共缘缘。云何法共缘缘不共缘缘。云何法非共缘缘。非不共缘缘。又世尊言。彼内无色想观外色。云何内无色想外观色。又世尊言有无色想。云何有无色想。诸有无色想彼一切色爱尽。设色爱尽彼一切有色无想耶。诸不有色无想一切色爱未尽耶。设色爱未尽彼一切不有色无想耶。四识所止七识所止。四识所止摄七识所止。七识所止摄四识所止。四识所止九众生居。四识所止摄九众生居。九众生居摄四识所止。七识所止九众生居。七识所止摄九众生居。九众生居摄七识所止。此章义愿具演说

见谛成就世尊弟子。欲爱未尽诸色界系。成就身口戒律。彼色何四大造。答曰。色界系也。生欲界有漏入初禅。有漏入第二第三第四禅。彼诸身口戒律彼色何四大造。答曰。色界系也。生欲界无漏入初禅。无漏入第二第三第四禅。彼诸身口戒律彼色何四大造。答曰。欲界系也。生色界有漏入初禅。有漏入第二第三第四禅。彼诸身口戒律。彼色何四大造。答曰。色界系。生色界无漏入初禅。无漏入第二第三第四禅。彼诸身口戒律。彼色何四大造。答曰色界系。世尊弟子生无色界。诸无漏成就身口戒律。彼色何四大造。答曰。或欲界系或色界系也。无色界没生欲界。最初得四大。彼四大何四大因。答曰。欲界系也。无色界没生色界最初得四大。彼四大何四大因。答曰。色界系也。色界没生欲界最初得四大。彼四大何四大因。答曰。欲界系。欲界生色界化化作色界语。彼色何四大造。答曰。色界系也。色界生欲界化化作欲界语。彼色何四大造。答曰。欲界系。化当言四大非四大耶。答曰。化当言四大。当言造色非造色耶。答曰。当言造色。当言有心无心耶。答曰。无心。当言用谁心语。答曰。化者心语。中阴当言四大非四大耶。答曰。中阴当言四大。当言造色非造色。答曰。当言造色。当言有心无心耶。答曰。当言有心。当言用谁心语。答曰。当言自用心语。世名何法。答曰。行数名。劫名何法。答曰。月半月春夏岁数名。心起住灭名何法。答曰。时节须臾数名。颇法四缘生耶。答曰。生一切心。心法三缘生耶。答曰生。无想定灭尽定二缘生耶。答曰生。除无想定灭尽定。诸心不相应行色一缘生耶。答曰。不生。云何法因相应答曰。一切心心法。云何法因不相应。答曰。色无为心不相应行。云何法因相应因不相应。答曰。彼心心法少因相应少因不相应。云何法非因相应非不因相应。答曰。彼心心法少因不相应少因非不相应。云何法共缘缘。答曰。诸意识身共相应心心法缘也。云何法不共缘缘。答曰。诸五识身共相应。色无为心不相应行缘。云何法共缘缘不共缘缘。答曰。诸五识身共相应。意识身共相应。心心法缘色无为心不相应行缘。云何法非共缘缘非不共缘缘。答曰。色无为心不相应行。又世尊言。彼内无色想外观色。云何内无色想外观色。答曰。如此身当死。已死当弃冢间。已弃冢间当埋地。已埋地当种种虫食。已种种虫食。彼不观此身但见彼种种虫。如此身当死已死当弃冢间。已弃冢间当积薪已积薪。当火烧已火烧。彼不观此身但见火。如此身雪聚凝酥醍醐当置火上。已置火上当融消。已融消彼不观此身但见火。如是内无色想外观色。又世尊言。有无色想。云何有无色想。答曰。如此身当死。已死当弃冢间。已弃冢间当埋地。已埋地当种种虫食。已种种虫食当处处散。已处处散彼不观此身。亦不见彼种种虫。如此身当死。已死当弃冢间。已弃冢间当积薪。已积薪当火烧。已火烧当灭。已灭彼不观此身亦不见火。如此身雪聚凝酥醍醐当置火上。已置火上当融消。已融消当灭。已灭彼不观此身亦不见火。如是有无色想。诸有色无想彼一切色爱尽耶。答曰如是。诸有色无想彼一切色爱尽。颇色爱尽彼非有色无想耶。答曰。有色爱尽彼不入三昧。诸不有色无想。彼一切色爱未尽耶。答曰如是。诸色爱未尽彼一切不有色无想。颇不有色无想。彼非色爱不尽耶。答曰。有色爱尽彼不入三昧。四识所止七识所止。四识所止摄七识所止耶。答曰。或四非七。云何四非七。答曰。地狱色痛想行。畜生饿鬼果实天色痛想行。有想无想痛想行。是谓四非七。云何七非四。答曰。人欲界天心梵迦夷天光音遍净空处识处不用处心。是谓七非四。云何四七。答曰。人欲界天色痛想行梵迦夷天光音遍净色痛想行空处识处不用处痛想行。是谓四七。云何非四非七。答曰。地狱心畜生饿鬼果实有想无想心。是谓非四非七。四识所止九众生居。四识所止摄九众生居耶。答曰。或四非九。云何四非九。答曰。地狱色痛想行。畜生饿鬼无想众生不摄果实色痛想行。是谓四非九。云何九非四。答曰。人欲界天心梵迦夷天光音遍净无想众生无色界心。是谓九非四。云何四九。答曰。人欲界天色痛想行梵迦夷天光音遍净无想众生色痛想行无色界痛想行。是谓四九。云何非四非九。答曰。地狱心畜生饿鬼无想众生不摄果实心。是谓非四非九。七识所止九众生居。七识所止摄九众生居。九众生居摄七识所止。答曰。九七非七九。不摄何等。答曰。二处无想众生有想无想天

见谛跋渠第三竟(梵本一百六十九首卢秦二千九十二言)

    阿毗昙四大犍度中内造跋渠第四

内四大彼内四大几缘缘。内四大不内四大。不内四大彼不内四大。不内四大内四大几缘缘。因相应法彼因相应法几缘缘。因相应法因不相应法。因不相应法彼因不相应法。因不相应法因相应法几缘缘。共缘法彼共缘法几缘缘。共缘法无缘法无缘法。彼无缘法无缘法共缘法几缘缘。色法彼色法几缘缘。色法无色法无色法。彼无色法无色法色法几缘缘。可见不可见。有对无对亦如是。有漏法彼有漏法几缘缘。有漏法无漏法。无漏法彼无漏法无漏法有漏法几缘缘。有为法彼有为法几缘缘。有为法无为法无为法彼无为法无为法有为法几缘缘。所可缠自缠受。地狱有彼得诸根四大。彼根四大彼心心法几缘缘。彼心心法彼根四大几缘缘。所可缠自缠受。畜生饿鬼天人。有彼得诸根四大。彼根四大彼心心法几缘缘。彼心心法彼诸根四大几缘缘。生欲界有漏入初禅。有漏乃至入有想无想定。彼根长益四大。增益彼根彼四大彼心心法几缘缘。彼心心法彼根彼四大几缘缘。生欲界无漏入初禅。无漏乃至入不用定。彼诸根四大增益。彼根四大彼心心法几缘缘。彼心心法。彼根四大几缘缘。生色界有漏入初禅。有漏乃至入有想无想定。彼根四大增益。彼根四大彼心心法几缘缘。彼心心法彼根四大几缘缘。生色界无漏入初禅。无漏乃至入不用定。彼根四大增益。彼根四大彼心心法几缘缘。彼心心法彼根四大几缘缘。内名何义。不内名何义。受为何义。不受为何义。结为何义。不结为何义。见处为何义。不见处为何义。诸法内彼法内入摄耶。设法内入摄彼法内耶。诸法外彼法外入摄。设法外入摄彼法外耶。二痛三痛。二痛摄三痛。三痛摄二痛。二痛四痛五痛六痛。十八痛三十六痛。百八痛。二痛摄百八痛。百八痛摄二痛。乃至三十六痛百八痛三十六痛摄百八痛。百八痛摄三十六痛。以无碍道趣须陀洹果。证彼修道时。几意止现在前修。几修未来。几意断。几神足。几根力。几觉意。几道种。几禅。几等。几无色定。几解脱。几除入。几一切入。几智。几三昧现在前修。几未来修。几无碍道趣斯陀含阿那含果。飞耳知他人心自识宿命彻视漏尽智证通。修彼道时。修几意止现在前。几修未来。几意断。几神足。几根力。几觉意。几道种。几禅。几等。几无色定。几解脱。几除入。几一切入。几智。几三昧现在前修。几修未来。此章义愿具演说

内四大彼内四大因增上。内四大不内四大因增上。不内四大彼不内四大因增上。不内四大内四大因增上。因相应法彼因相应法。因次第缘增上。因相应法因不相应法。因次第增上。无缘因不相应法彼因不相应法。因增上。因不相应法因相应法因缘增上。无次第。共缘法彼共缘法。因次第缘增上。共缘法无缘法。因次第增上。无缘无缘法彼无缘法因增上。无缘法共缘法因缘增上。无次第。色法彼色法因缘增上。色法无色法因缘增上。无次第。无色法彼无色法。因次第缘增上。无色法色法。因增上。无缘无次第。可见不可见有对无对亦如是。有漏法彼有漏法因次第缘增上。有漏法无漏法。次第缘增上。无因无漏法彼无漏法因(因此也)次第(续得也)缘(由上有此)增上(续也)。无漏法有漏法次第缘增上。无因有为法彼有为法因次第缘增上。有为法无为法无。无为法彼无为法无。无为法有为法缘增上。所可缠自缠受地狱有。彼得诸根四大。彼根彼四大彼心心法一增上。彼心心法彼根四大一增上。所可缠自缠受畜生饿鬼天人有。彼得诸根四大。彼根四大彼心心法一增上。彼心心法彼根四大一增上。生欲界有漏入初禅。有漏乃至入有想无想定。彼根长益四大增益彼根。彼四大彼心心法一增上。彼心心法彼根四大一增上。生欲界无漏入初禅。无漏入乃至入不用定。彼根长益四大增益彼根。彼四大彼心心法一增上。彼心心法彼根四大一增上。生色界有漏入初禅。有漏乃至入有想无想定。彼根长益四大增益彼根。彼四大彼心心法一增上。彼心心法彼根四大一增上。生色界无漏入初禅。无漏乃至入不用定。彼根长益四大增益彼根。彼四大彼心心法一增上。彼心心法彼根四大一增上。内为何法。答曰。自己数名。不内名何义。答曰。自己不数名。受为何义。答曰。有漏法数名。不受为何义。答曰。无漏法数名。结为何义。答曰。有漏法数名。无结为何义。答曰。无漏法数名。见处为何义。答曰。有漏法数名。不见处为何义。答曰。无漏法数名。诸法内彼法内入摄耶。答曰。或法内彼法非内入摄。云何法内彼法非内入摄。答曰。如所说内痛内法法观而处。是谓法内彼法非内入摄。云何法内入摄。彼法非内耶。答曰。如所说外身外心心观而处。是谓法内入摄彼法非内也。云何法内彼法内入摄耶。答曰。如所说内身内心心观而处。是谓法内彼法内入摄。云何法非内彼法非内入摄。答曰。如所说外痛外法法观而处。是谓法非内彼法非内入摄。诸法外彼法外入摄耶。答曰。或法外彼法非外入摄。云何法外彼法非外入摄。答曰。如所说外身外心心观而处。是谓法外彼法非外入摄。云何法外入摄彼法非外耶。答曰。如所说内痛内法法观而处。是谓法外入摄彼法非外。云何法外彼法外入摄耶。答曰。如所说外痛外法法观而处。是谓法外彼法外入摄也。云何法非外彼法非外入摄。答曰。如所说内身内心心观而处。是谓法非外彼法非外入摄。二痛三痛二痛摄三痛。三痛摄二痛。答曰。随种相摄。二痛四痛五痛六痛。二痛摄六痛。六痛摄二痛。答曰。随种相摄。二痛十八痛二痛摄十八痛。十八痛摄二痛。答曰。二摄十八非十八摄二。不摄何等。答曰。苦根有漏乐根有对相应护根无漏痛也。三十六痛百八痛亦如是。乃至六痛十八痛。六摄十八十八摄六。答曰。六摄十八非十八摄六。不摄何等。答曰。苦根有漏乐根有对相应护根无漏痛也。三十六痛百八痛亦如是。十八痛三十六痛亦如是。三十六痛百八痛。三十六痛摄百八。百八痛摄三十六痛。答曰。随种相摄。以无碍道趣须陀洹果证。修彼道时。修一意止现在前未来四。四意断未来四。四神足未来四。五根未来五。五力未来五。六觉意未来六。八道种未来八。无禅无等无。无色定无解脱无。八除入无。十一切入无。智无未来。一三昧未来一(道迹竟)。以无碍道趣斯陀含果证。若倍欲尽越次取证。修彼道时。修一意止现在前未来四。四意断未来四。四神足未来四。五根未来五。五力未来五。六觉意未来六。八道种未来八。无禅无等无。无色定无解脱无。八除入无。十一切入无。智无未来一三昧未来一。若得须陀洹果以世俗道取斯陀含果。修彼道时修一意止现在前。未来四。四意断未来四。四神足未来四。五根未来五。五力未来五。无觉意未来六。无道种未来八。无禅无等无。无色定无解脱无。八除入无。十一切入一智未来七。无三昧未来三。若得须陀洹果以无漏道。取斯陀含果修彼道时。修一意止现在前。未来四。四意断未来四。四神足未来四。五根未来五。五力未来五。六觉意未来六(无喜)。八道种未来八。无禅无等无。无色定无解脱无。八除入无。十一切入二智(法二对四)。未来七。一三昧未来三(频来竟)。以无碍道取阿那含果证。若欲爱尽。越次取证修彼道时。修一意止现在前。未来四。四意断未来四。四神足未来四。五根未来五。五力未来五。六觉意未来。六八道种未来八。无禅无等无。无色定无。解脱无。八除入无。十一切入无。智未来无。一三昧未来一。若依初禅取阿那含果。修彼道时修一意止现在前未来四。四意断未来四。四神足未来四。五根未来五。五力未来五。七觉意未来七。八道种未来八。一禅未来一。无等无。无色定无解脱无。八除入无。十一切入无。智未来无。一三昧未来一。若依初禅中间取阿那含果。修彼道时修一意止现在前未来四。四意断未来四。四神足未来四。五根未来五。五力未来五。六觉意未来七。七道种未来八。无禅未来一。无等无。无色定无解脱无。八除入无。十一切入无。智未来无。一三昧未来一。若依二禅取阿那含果。修彼道时修一意止现在前(法意止也)。未来四。四意断未来四。四神足未来四。五根未来五。五力未来五。七觉意未来七。七道种未来八。一禅未来二。无等无。无色定无解脱无。八除入无。十一切入无。智未来无。一三昧未来一。若依三禅取阿那含果。修彼道时修一意止。现在前未来四。四意断未来四。四神足未来四。五根未来五。五力未来五。六觉意未来七。七道种(无等志也)未来八。一禅未来三(一三禅)。无等无。无色定无。解脱无。八除入无。十一切入无。智未来无。一三昧未来一。若依四禅取阿那含果。修彼道时修一意止现在前未来四。四意断未来四。四神足未来四。五根未来五。五力未来五。六觉意未来七。七道种未来八。一禅未来四。无等无无色定无解脱无。八除入无十一切入无。智未来无。一三昧未来一(超越不还尽)。若得斯陀含果以世俗道。取阿那含果修彼道时修。一意止现在前未来四。四意断未来四。四神足未来四。五根未来五。五力未来五。无觉意未来六。无道种未来八。无禅无等无无色定无解脱无八除入无。十一切入一智未来七(等智)。无三昧未来三。若得斯陀含果以无漏道取阿那含果。修彼道时修一意止。现在前未来四。四意断未来四。四神足未来四。五根未来五。五力未来五。六觉意未来六。八道种未来八。无禅无等无无色定无解脱无八除入无。十一切入二智未来七。一三昧未来三(不还竟)。以无碍道神足智证通。若依初禅凡夫人修神足道。修彼道时修一意止。现在前(身止)未来四。四意断未来四。四神足未来四。五根未来五五力未来五。无觉意未来无。无道种未来无。一禅未来一。无等未来四。无无色定未来无。无解脱未来二。无八除入未来四。无十一切入未来无。一智未来一。无三昧未来无(三向趣一)。若依初禅无垢人修神足道。修彼道时修一意止。现在前未来四。四意断未来四。四神足未来四。五根未来五。五力未来五。无觉意未来七。无道种未来八。一禅未来一。无等未来四。无无色定未来无。无解脱未来二。无八除入未来四(禅四枝)。无十一切入未来无。一智未来七。无三昧未来三。若依二禅凡夫人修神足道。修彼道时。修一意止现在前未来四。四意断未来四。四神足未来四。五根未来五。五力未来五。无觉意未来无。无道种未来无。一禅未来一。无等未来四。无无色定未来无。无解脱未来二(第一第二)。无八除入(八想四观四色)未来四。无十一切入未来无。一智未来一。无三昧未来无。若依二禅无垢人修神足道。修彼道时。修一意止现在前未来四。四意断未来四。四神足未来四。五根未来五。五力未来五。无觉意未来七。无道种未来八。一禅未来二。无等未来四。无无色定未来无。无解脱未来二。无八除入未来四(四观)。无十一切入未来无。一智未来七。无三昧未来三。若依三禅凡夫人修神足道。修彼道时。修一意止现在前未来四。四意断未来四。四神足未来四。五根未来五。五力未来五。无觉意未来无。无道种未来无。一禅未来一。无等未来三(除喜)。无无色定无解脱无八除入无十一切入一。智未来一(等智)。无三昧未来无。若依三禅无垢人修神足道。修彼道时。修一意止现在前未来四。四意断未来四。四神足未来四。五根未来五。五力未来五。无觉意未来七。无道种未来八。一禅未来三。无等未来三。无无色定无解脱无八除入无十一切入一智未来七。无三昧未来三。若依四禅凡夫人修神足道。修彼道时。修一意止现在前未来四。四意断未来四。四神足未来四。五根未来五。五力未来五。无觉意未来无。无道种未来无。一禅未来一。无等未来三。无无色定未来无。无解脱未来一。无八除入未来四。无十一切入未来八。一智未来一。无三昧未来无。若依四禅无垢人修神足道。修彼道时。修一意止现在前未来四。四意断未来四。四神足未来四。五根未来五。五力未来五。无觉意未来七。无道种未来八。一禅未来四。无等未来三。无无色定未来无。无解脱未来一(净解脱也)。无八除入未来四(四色)。无十一切入未来八。一智未来七。无三昧未来三(神足竟)。天耳知他人心自识宿命彻视亦如是。以无碍道尽漏智证通。若依未来有觉有观三昧。取阿罗汉。修彼道时。修一意止现在前未来四。四意断未来四。四神足未来四。五根未来五。五力未来五。六觉意未来七。八道种未来八。无禅未来四。无等未来无。无无色定未来三。无解脱未来三。无八除入无十一切入二智未来六(未对知四)。一三昧未来三。若依初禅取阿罗汉。修彼道时。修一意止现在前未来四。四意断未来四。四神足未来四。五根未来五。五力未来五。七觉意未来七。八道种未来八。一禅未来四。无等未来无。无无色定未来三。无解脱未来三。无八除入无十一切入二智未来六。一三昧未来三。若依禅中间取阿罗汉。修彼道时。修一意止现在前未来四。四意断未来四。四神足未来四。五根未来五五。力未来五。六觉意未来七。七道种未来八。无禅未来四。无等未来无。无无色定未来三。无解脱未来三。无八除入无十一切入二智未来六。一三昧未来三(三过向一)。若依二禅取阿罗汉道。修彼道时。修一意止现在前未来四。四意断未来四。四神足未来四。五根未来五。五力未来五。七觉意未来七。七道种未来八。一禅未来四。无等未来无。无无色定未来三。无解脱未来三。无八除入无十一切入二智未来六。一三昧未来三。若依第三第四禅取阿罗汉。修彼道时。修一意止现在前未来四。四意断未来四。四神足未来四。五根未来五。五力未来五。六觉意未来七。七道种未来八。一禅未来四。无等未来无。无无色定未来三。无解脱未来三。无八除入无十一切入二智未来六。一三昧未来三。若依无色定取阿罗汉。修彼道时。修一意止现在前未来四。四意断未来四。四神足未来四。五根未来五。五力未来五。六觉意未来七。四道种(除戒志)未来八。无禅未来四。无等未来无。一无色定未来三。无解脱未来三。无八除入无十一切入二智未来六。一三昧未来三

内造品第四竟(梵本三百五十三首卢秦四千五百二十三言)

四大犍度第五竟(三日诵)

阿毗昙八犍度论卷第二十阿毗昙八犍度论卷第二十一

        迦旃延子造

        符秦罽宾三藏僧伽提婆共竺佛念译

    根犍度第六

  二十二根有　　更乐始心等
  始发鱼因缘

    阿毗昙根跋渠第一

二十二根。眼根耳根鼻根舌根身根意根。男根女根命根。乐根苦根喜根忧根护根。信根精进根念根定根慧根。未知根已知根无知根。此二十二根。几学几无学几非学非无学。诸根学彼根学人乎。设学人根彼学根乎诸根无学彼无学人根乎。设无学人根彼无学根乎。诸根非学非无学。彼根非学非无学人根乎。设根非学非无学人。彼根非学非无学乎。此二十二根几善几不善乎几无记。几有报几无报耶。几见谛断几思惟断几不断。几见苦断几见习见尽见道思惟断几不断。几见几不见。几有觉有观。几无觉有观。几无觉无观。几乐根相应。几苦根几喜根几忧根几护根几欲界系。几色界系。几无色界系。几不系。几因相应。几因不相应。几因相应因不相应耶。几不因相应非因不相应。几共缘相缘。几不共缘相缘。几共缘相缘不共缘相缘乎。几不共缘相缘非不共缘相缘耶。诸根此法彼根凡夫人耶。设根凡夫人彼根此法耶。色阴摄几根。痛想行识阴摄几根。善根摄几持几入几阴。不善根摄几持几入几阴。隐没无记根摄几持几入几阴。不隐没无记根摄几持几入几阴。根法摄几持几入几阴。无根法摄几持几入几阴。根无根法摄几持几入几阴。颇缘根生根耶。颇缘根生不根耶。颇缘根生根不根耶。颇缘不根生不根耶颇缘不根生根耶。颇缘不根生根不根耶。颇缘根不根生根耶。颇缘根不根生不根耶。颇缘根不根生根不根耶。颇缘眼根生眼根耶。颇缘眼根乃至生无知根耶。颇缘无知根生无知根耶。颇缘无知根生眼根。乃至已知根耶。眼根彼眼根几缘缘眼根。乃至无知根几缘缘无知根彼无知根几缘缘无知根。眼根乃至已知根几缘缘。此章义愿具演说。二十二根眼根耳鼻舌身根意根。男根女根命根。乐根苦根喜根忧根护根。信根精进念定慧根。未知根已知根无知根。于此二十二根几学几无学几非学非无学。答曰。二学一无学十非学非无学。九当分别。意根或学或无学或非学非无学。云何学。答曰。学意所念诸意根相应。是谓学。云何无学。答曰。无学意所念诸意根相应。是谓无学也。云何非学非无学。答曰。有漏意所念诸意根相应。是谓非学非无学也。乐根喜根护根信根精进念定慧根亦复如是。诸根学彼学家根耶。答曰。或学根彼根非学家。云何学根彼根非学家耶。答曰。诸根学学家不成就。是谓根学彼根非学家也。云何学家根彼根非学。答曰。诸非学非无学根学家成就。是谓学家根彼根非学。云何学根彼根学家乎。答曰。诸学根学家成就。是谓学根彼根学家。云何非学根彼根非学家乎。答曰。无学根。诸非学非无学根。学家不成就。是谓非学根彼根非学家也。诸无学根无学家彼根乎。答曰。或无学根彼根非无学家。云何无学根彼根非无学家。答曰。诸无学根无学家不成就。是谓无学根彼根非无学家。云何无学家根彼根非无学。答曰。诸非学非无学根。无学家成就。是谓无学家根。彼根非无学。云何无学根无学家彼根乎。答曰。诸无学根无学家成就。是谓无学根无学家彼根也。云何非无学根彼根。非无学家。答曰。学根诸非学非无学根。无学家不成就。是谓非无学根彼根非无学家。诸根非学非无学。彼根非学非无学家根乎。答曰。如是。诸根非学非无学家。非学非无学彼根也。彼根非学非无学。彼根非学非无学家。答曰。有诸非学非无学根。非学非无学家不成就。于此二十二根。几善几不善几无记乎。答曰。八善八无记。六当分别。意根或善或不善或无记。云何善乎。答曰。善心所念诸意根相应是谓善。云何不善。答曰。不善心所念诸意根相应。是谓不善也。云何无记。答曰。无记心所念诸意根相应是谓无记也。乐根苦根喜根护根亦复如是。忧根或善或不善。云何善。答曰。善心所念诸忧根相应是谓善。云何不善。答曰。不善心所念诸忧根相应。是谓不善也。于此二十二根。几有报几无报乎。答曰。一有报十一无报十当分别。意根或有报或无报。云何有报。答曰。不善善有漏意根。是谓有报也。云何无报。答曰。无记无漏意根。是谓无报。乐根喜根护根亦复如是。苦根或有报或无报。云何有报。答曰。不善善苦根。是谓有报。云何无报。答曰。无记苦根。是谓无报。信根精进根念根定根慧根。诸有漏彼有报诸无漏是谓无报。于此二十二根。几见谛断几思惟断几无断。答曰。九思惟断三不断十当分别。意根或见谛断或思惟断或不断。云何见谛断乎。答曰。诸意根坚信坚法行忍断。何者见谛断。八十八使诸意根相应。是谓见谛断也。云何思惟断。答曰。诸学见迹思惟断。何者思惟断。十使诸意根相应。亦无染意根有漏。是谓思惟断。云何不断。答曰。无漏意根是谓无断。护根亦如是。乐根或见谛断或思惟断或不断云何见谛断耶。答曰。诸乐根坚信坚法行忍断。何者见谛断。答曰。二十八使诸乐根相应。是谓见谛断也。云何思惟断。答曰。诸学见迹思惟断。何者思惟断。五使诸乐根相应。亦无染有漏乐根。是谓思惟断。云何不断。答曰。无漏乐根是谓不断也。喜根或见谛断或思惟断或不断。云何见谛断。答曰。诸喜根坚信坚法行忍断。何者见谛断。五十二使诸喜根相应。是谓见谛断。云何思惟断。答曰。诸学见迹思惟断。何者思惟断。六使诸喜根相应。亦无染有漏喜根。是谓思惟断。云何不断乎。答曰。无漏喜根是谓不断也。忧根或见谛断或思惟断。云何见谛断。答曰。诸忧根坚信坚法行忍断。何者见谛断。十六使诸忧根相应。是谓见谛断。云何思惟断乎。答曰。诸学见迹思惟断。何者思惟断。二使诸忧根相应。亦无染忧根。是谓思惟断。信精进念定慧根。诸有漏彼思惟断。诸无漏彼不断。于此二十二根。几见苦断。几见习尽道思惟断几不断。答曰。九思惟断三不断十当分别。意根或见苦断。或见习尽道思惟断或不断。云何见苦断。答曰。诸意根坚信坚法行忍断。何者见苦断。二十八使诸意根相应见习断。十九使见尽断。十九使见道断。二十二使诸意根相应。是谓见谛断也。云何思惟断。答曰。诸意根学见迹思惟断。何者思惟断。十使诸意根相应。亦无染有漏意根。是谓思惟断也。云何不断。答曰。无漏意根是谓不断。护根亦如是。乐根或见苦断。或见习尽道思惟断或不断。云何见苦断。答曰。诸乐根坚信坚法行忍断。何者见苦断。九使诸乐根相应见习断。六使见尽断。六使见道断。七使诸乐根相应是谓见谛断。云何思惟断乎。答曰。诸学见迹思惟断。何者思惟断。五使诸乐根相应。亦无染有漏乐根是谓思惟断。云何不断。答曰。无漏乐根是谓不断。喜根或见苦断或见习尽道思惟断或不断。云何见苦断耶。答曰。诸喜根坚信坚法行忍断。何者见苦断。十七使诸喜根相应见习断。十一见尽断。十一见道断。十三使诸喜根相应是谓见谛断。云何思惟断。答曰。诸学见迹思惟断。何者思惟断。六使诸喜根相应。亦无染有漏喜根是谓思惟断。云何不断。答曰。无漏喜根是谓不断。忧根或见苦断或见习尽道思惟断。云何见苦断。答曰。诸忧根坚信坚法行忍断。何者见苦断。四使诸忧根相应见习断四见尽断四见道断。四使忧根相应是谓见谛断。云何思惟断乎。答曰。诸学见迹思惟断。何者思惟断。二使诸忧根相应。亦无染忧根是谓思惟断。信精进念定慧根。诸有漏彼思惟断。诸无漏彼不断。于此二十二根。几见几不见乎。答曰。一见十七不见四当分别。慧根或见或不见。云何见。答曰。尽智无生智不摄。意识身相应善慧是谓见。云何不见耶。答曰。五识身相应。善慧尽智无生智是谓不见。未知根或见或不见。云何见。答曰。未知根摄慧是谓见。云何不见。答曰。未知根摄八根是谓不见。已知根亦如是。无知根或见或不见。云何见乎。答曰。尽智无生智不摄无知根摄慧是谓见。云何不见乎。答曰。无知根摄八根尽智无生智是谓不见。于此二十二根。几有觉有观。几无觉有观。几无觉无观。答曰。二有觉有观。八无觉无观。十二当分别。意根或有觉有观或无觉有观或无觉无观。云何有觉有观。答曰。有觉有观心所念诸意根相应。是谓有觉有观。云何无觉有观。答曰。无觉有观心所念诸意根相应。是谓无觉有观。云何无觉无观。答曰。无觉无观心所念诸意根相应。是谓无觉无观。护根信精进念定慧根未知根已知根无知根亦复如是。乐根或有觉有观或无觉无观。云何有觉有观乎。答曰。有觉有观心所念诸乐根相应。是谓有觉有观。云何无觉无观。答曰。无觉无观心所念乐根相应。是谓无觉无观。喜根亦如是。乐根喜根护根九根少入相应。苦根忧根六根少入相应。于此二十二根。几欲界系。几色界系。几无色界系。几不系乎。答曰。四欲界系。三不系。十五当分别。眼根或欲界系或色界系。云何欲界系。答曰。欲界系四大造诸眼根。是谓欲界系。云何色界系乎。答曰。色界系四大造诸眼根。是谓色界系。耳鼻舌身根亦复如是。意根或欲界系或色界系或无色界系或不系。云何欲界系乎。答曰。欲界系心所念诸意根相应。是谓欲界系。云何色界系乎。答曰。色界系心所念诸意根相应。是谓色界系。云何无色界系乎。答曰。无色界系心所念诸意根相应。是谓无色界系。云何不系乎。答曰。无漏心所念诸意根相应。是谓不系。护根信精进念定慧根亦复如是。命根或欲界系或色界系或无色界系。云何欲界系乎。答曰。欲界系寿是谓欲界系也。云何色界系乎。答曰。色界系寿。是谓色界系。云何无色界系。答曰。无色界系寿。是谓无色界系。乐根或欲界系或色界系或不系。云何欲界系。答曰。欲界系心所念诸乐根相应。是谓欲界系。云何色界系乎。答曰。色界系心所念诸乐根相应。是谓色界系。云何不系乎。答曰。无漏心所念诸乐根相应。是谓不系。喜根亦如是。于此二十二根。几因相应。答曰。十四。几因不相应乎。答曰。八。几因相应。几因不相应乎。答曰。彼十四少因相应。少因不相应。几因不相应非不因相应。答曰。彼十四少因不相应。少因非不相应。于此二十二根。几共缘相缘乎。答曰。十三少入。几不共缘相缘。答曰。一十三少入。几共缘相缘不共缘相缘。答曰。十三也。几不共缘相缘。非不共缘相缘。答曰。八也。诸根此法彼根非凡夫。诸根凡夫彼根非此法。色阴摄七根。痛阴摄五根三根少入。想阴不摄根。行阴摄六根三根少入。识阴摄一根三根少入。善根摄八持二入三阴。不善根摄八持二入二阴。隐没无记根摄六持二入二阴。不隐没无记根摄十三持七入四阴根法摄十三持七入四阴。无根法摄六持六入三阴。根无根法摄十八持十二入五阴。颇缘根生根耶。答曰。生也。颇缘根生不根。答曰。生。颇缘根生根不根。答曰。生也。颇缘不根生不根。答曰。生也。颇缘不根生根。答曰。生也。颇缘不根生根不根。答曰。生也。颇缘根不根生根。答曰。生也。颇缘根不根生不根。答曰。生也。颇缘根不根生根不根乎。答曰。生也。颇缘眼根生眼根。答曰。生也。颇缘眼根乃至生无知根。答曰。生也。颇缘无知根生无知根乎。答曰。生也。颇缘无知根生眼根乃至已知根。答曰。生(生竟)。眼根彼眼根因增上耳鼻舌身根男根女根命根苦根一增上。余缘增上。耳鼻舌根亦复如是。身根彼身根因增上男根女根亦因增上。命根苦根眼根耳鼻舌根一增上。余缘增上(身竟)。意根彼意根因次第缘增上。命根八(五情男女命)。因增上。苦根因次第增上无缘。余因次第缘增上。乐根喜根护根信精进念定慧根亦复如是。女根彼女根因增上。男根命根苦根眼耳鼻舌根一增上。身根因增上。余缘增上。男根亦如是。命根彼命根因增上。苦根眼根耳鼻舌身根男根女根一增上。余缘增上。苦根彼苦根因增上。无缘无次第。命根八因增上。无漏缘增上乐根因缘增上无次第。余因次第缘增上。忧根彼忧根因次第缘增上。命根八因增上苦根因次第增上。无缘无漏缘增上。余因次第缘增上。未知根彼未知根因次第缘增上。已知根亦因次第缘增上。无知根因缘增上无次第。命根八及苦根一增上。忧根缘增上。余因次第缘增上。已知根彼已知根因次第缘增上。无知根亦因次第缘增上。命根八及苦根一增上。忧根未知根缘增上。余因次第缘增上。无知根彼无知根因次第缘增上。命根八及苦根一增上。忧根未知根已知根缘增上。余因次第缘增上

二十二根品第二十七竟(梵本三百一十四首卢秦四千四十二言)

    阿毗昙根犍度有跋渠第二

受欲界有。几根最初得行。受色无色界有。几根最初得行。颇欲界系意所念法晓了欲界。晓了色无色界耶。颇色界系意所念法。晓了色界晓了欲界无色界乎。颇无色界系意所念法。晓了无色界晓了欲界色界耶。晓了欲界晓了几根乎。晓了色界无色界晓了几根耶。几根晓了欲界。几根晓了色界无色界。几根取须陀洹果。几根取斯陀含阿那含阿罗汉果耶。诸根取须陀洹果已得须陀洹果。此根当言成就。当言不成就。诸根取斯陀含阿那含阿罗汉果。已得阿罗汉果。此根当言成就当言不成就。诸根取须陀洹果。彼根为何系结灭。彼根何果摄。诸根取斯陀含阿那含阿罗汉果。彼根为何系结灭。此根为何果摄。取须陀洹果诸根弃彼根。为何系结灭。此根何果摄。取斯陀含阿那含阿罗汉果。弃诸根。彼根为何系结灭。此根何果摄。取须陀洹果得诸根。彼根为何系结灭。此根为何果摄。取斯陀含阿那含阿罗汉果得诸根。彼根为何系结灭。此根为何果摄。诸根成就须陀洹。彼根为何系结灭。此根为何果摄。诸根成就斯陀含阿那含阿罗汉。彼根为何系结灭。此根为何果摄。诸根须陀洹结灭。此根为何系结灭。此根为何果摄耶。诸根斯陀含阿那含结灭。此根为何系结灭。此根为何果摄。诸根须陀洹果摄。此根为何系结灭耶。诸根斯陀含阿那含阿罗汉果摄。此根为何系结灭。诸苦智彼苦无漏智耶。设苦无漏智是苦智乎。诸习智尽。智道智是道无漏智耶。设是道无漏智。是道智耶。诸无漏根欲界系缘。此根法智相应耶。设无漏根法智相应。彼根欲界系缘。诸无漏根色无色界系缘。此根未知智相应耶。设诸无漏根未知智相应。彼根色无色界系缘。法智当言法智耶。未知智知他人心智等智苦智习智尽智道智。当言有觉有观耶。无觉有观耶。无觉无观耶。当言乐根喜根护根空无相无愿相应耶。当言欲界系缘。当言色界无色界系缘。当言不系缘。未知智亦复如是。等意解脱当言得学根得无学根耶。无疑意解脱。当言得学根得无学根乎。一切结尽。当言得学根得无学根耶。以无碍道取须陀洹果证。此道当言法智相应。未知智知他人心智。等智苦智习智尽智道智。当言有觉有观耶。无觉有观耶。无觉无观耶。当言乐根相应喜根护根空无相无愿。当言欲界系缘。当言色无色界系缘。当言不系缘。以无碍道取斯陀含阿那含阿罗汉果证。此道当言法智相应。未知智知他人心智。等智苦智习智尽智道智。当言有觉有观耶。无觉有观耶。无觉无观耶。当言乐根相应耶。喜根护根空无相无愿。当言欲界系缘耶。当言色无色界系缘。当言不系缘。几根断尽起。当言得须陀洹果耶。几根断尽起。当言得斯陀含阿那含阿罗汉果耶。此章义愿具演说

受欲界有几根最初得行。答曰。卵生胎生合会生二。身根命根也。化生或六七八。无形六。一形七。二形八。受色界有几根最初得行。答曰。六。受无色界有几根最初得行耶。答曰。一。颇欲界系心所念法晓了欲界乎。答曰。不晓了。晓了色界无色界耶。答曰。不晓了。颇色界系心所念法晓了色界乎。答曰。晓了。晓了欲界耶。答曰。晓了。晓了无色界乎。答曰。不晓了。颇无色界系心所念法晓了无色界乎。答曰。晓了。晓了欲界乎。答曰。不晓了。晓了色界乎。答曰。晓了。晓了欲界为晓了几根乎。答曰。四(男女忧苦)。晓了色界为晓了几根耶。答曰。五(五情)。晓了无色界为晓了几根乎。答曰。八(五根意命护也)。几根晓了欲界乎。答曰。凡夫人七(五根意护)。无垢人八(加已知也)。几根晓了色界乎。答曰。凡夫人七。无垢人十(加乐喜也)。几根晓了无色界耶。答曰。十一(加无知)。几根取须陀洹果乎。答曰。九(意护未知已知五根)。几根取斯陀含果乎。答曰。若倍欲尽越次取证九。若得须陀洹果。以世俗道取斯陀含果七无漏八。几根取阿那含果。答曰。若欲爱尽越次取证九。若得斯陀含果。以世俗道取阿那含果七无漏八。几根取阿罗汉果乎。答曰。十一(数皆如上)。诸根取须陀洹果。已得须陀洹果。当言成就此根不成就乎。答曰。无碍道不成就。解脱道成就也。诸根取斯陀含阿那含阿罗汉果。已得阿罗汉果。当言成就此根不成就乎。答曰。无碍道不成就。解脱道成就。诸根取须陀洹果。此根为何系结灭乎。答曰。或色界系。或无色界系。或无处所。诸根取斯陀含果阿那含果。此根为何系结灭。答曰。或欲界系或色无色界系。或无处所。诸根取阿罗汉果。此根何系结灭耶。答曰。或无色界系。或无处所。诸根取须陀洹果。此根何果摄乎。答曰。须陀洹果或无处所。诸根取斯陀含果。此根何果摄耶。答曰。斯陀含果。或无处所。诸根取阿那含果。此根何果摄。答曰。阿那含果。或无处所。诸根取阿罗汉果。此根何果摄。答曰。阿罗汉果。或无处所。取须陀洹果弃诸根。此根为何系结灭乎。答曰。或欲界系或色无色界系。或无处所。取斯陀含阿那含果弃诸根。此根为何系结灭。答曰。或欲界系。或色无色界系。或无处所。取阿罗汉果弃诸根。此根为何系结灭。答曰。或色界系。或无色界系。或无处所。取须陀洹果弃诸根。此根为何果摄。答曰。无处所。取斯陀含果弃诸根。此根为何果摄。答曰。须陀洹果或无处所。取阿那含果弃诸根。此根为何果摄。答曰。斯陀含果。或无处所。取阿罗汉果弃诸根。此根为何果摄。答曰。阿那含果。或无处所。取须陀洹果获诸根。此根为何系结灭。答曰。无处所。取斯陀含阿那含阿罗汉果获诸根。此根为何系结灭。答曰。无处所。取须陀洹果获诸根。此根为何果摄。答曰。须陀洹果。取斯陀含阿那含阿罗汉果获诸根。此根为何果摄。答曰。阿罗汉果。须陀洹成就诸根。此根为何系结灭。答曰。或欲界系。或无处所。斯陀含成就诸根。此根为何系结灭。答曰。或欲界系。或无处所。阿那含成就诸根。此根为何系结灭。答曰。或色界系或无色界系。或无处所。阿罗汉成就诸根。此根为何系结灭。答曰。无处所也。须陀洹成就诸根。此根为何果摄。答曰。或须陀洹果。或无处所。斯陀含阿那含阿罗汉成就诸根。此根为何果摄。答曰。阿罗汉果。或无处所。诸根须陀洹结灭。此根为何系结灭。答曰。欲界系也。诸根斯陀含结灭。此根为何系结灭。答曰。欲界系也。诸根阿那含结灭。此根为何系结灭。答曰。或色无色界系也。诸根须陀洹结灭。此根为何果摄。答曰。无处所也。诸根斯陀含阿那含结灭。此根为何果摄。答曰。无处所也。诸根须陀洹果摄。此根为何系结灭。答曰。无处所也。诸根斯陀含阿那含阿罗汉果摄。此根为何系结灭。答曰。无处所也。诸苦智是苦无漏智乎。答曰。如是。诸苦智是苦无漏智也。颇苦无漏智非苦智乎。答曰。有诸苦习智也。诸习智彼是习无漏智乎。答曰。如是。诸习智彼是习无漏智也。颇习无漏智彼非习智乎。答曰。有诸习苦智也。诸尽智彼是尽无漏智乎。答曰。如是。设尽无漏智彼是尽智答曰。如是。诸道智彼是道无漏智乎。答曰。如是。设道无漏智彼是道智。答曰。如是。无漏诸根欲界系缘此根。法智相应乎。答曰。或无漏根欲界系缘。此根非法智相应。云何无漏根欲界系缘。此根非法智相应乎。答曰。苦法忍彼相应根。苦法智习法忍。彼相应根习法智。是谓无漏根欲界系缘。此根非法智相应也。云何无漏根法智相应。此根非欲界系缘。答曰。诸根缘尽缘道法智相应。是谓无漏根法智相应。此根非欲界系缘。云何无漏根欲界系缘。彼根法智相应。答曰。诸根缘苦缘习法智相应。是谓无漏根欲界系缘。彼根法智相应。云何无漏根非欲界系缘。非法智相应乎。答曰。苦未知忍苦未知智彼相应根。习未知忍习未知智彼相应根。尽法忍彼相应根。尽法智尽未知忍尽未知智彼相应根。道法忍彼相应根。道法智道未知忍道未知智彼相应根。是谓无漏根。此根非欲界系缘。彼根非法智相应。诸无漏根色无色界系缘。彼根未知智相应乎。答曰。或无漏根色无色界系缘。彼根非未知智相应。云何无漏根色无色界系缘。彼根非未知智相应乎。答曰。苦未知忍彼相应根。苦未知智习未知忍。彼相应根习未知智。是谓无漏根色无色界系缘。彼根非未知智相应也。云何无漏根未知智相应。彼根非色无色界系缘。答曰。诸根缘尽缘道未知智相应。是谓无漏根未知智相应。彼根非色无色界系缘。云何无漏根色无色界系缘。彼根未知智相应乎。答曰。诸根缘苦缘习未知智相应。是谓无漏根色无色界系缘。彼根未知智相应。云何无漏根非色无色界系缘。彼根非未知智相应。答曰。苦法忍苦法智彼相应根。习法忍习法智彼相应根。尽法忍尽法智尽未知忍彼相应根。尽未知智道法忍道法智彼相应根。道未知忍彼相应根道未知智。是谓无漏根。彼根非色无色界系缘。彼根非未知智相应法。智当言法智。答曰。法智当言法智。或彼知他人心智。苦智习智尽智道智。或有觉有观。或无觉有观。或无觉无观。或乐根相应。或喜根护根空无相无愿。或欲界系缘。或不系缘(法智尽)。未知智当言未知智。答曰。未知智当言未知智。或知他人心智。苦智习智尽智道智。或有觉有观。或无觉有观。或无觉无观或乐根相应。喜根护根空无相无愿。或色无色界系缘。不系缘(未知智尽)。等意解脱。当言得学根得无学根。答曰。等意解脱。当言得学根得无学根。无疑意解脱。当言得学根得无学根。答曰。若始得无疑。当言得学根得无学根。若等意解脱阿罗汉。得无疑。当言得无学根。一切结尽。当言得学根。得无学根乎。答曰。一切结尽当言得学根得无学根。以无碍道取须陀洹果证。此道当言忍相应。当言有觉有观。当言护根相应无愿相应。当言不系缘(道迹竟)。以无碍道取斯陀含果证。若倍欲尽越次取证。此道当言忍相应。当言有觉有观。当言护根相应无愿相应。当言不系缘。若得须陀洹果。以世俗道取斯陀含果。此道当言等智相应。当言有觉有观护根相应。当言欲界系缘。若得须陀洹果。以无漏道取斯陀含果。此道当言法智相应。或苦智习智尽智道智。当言有觉有观。当言护根相应。或空无相无愿。或欲界系缘或不系缘(往还竟)。以无碍道取阿那含果证。若欲爱尽越次取证。此道当言忍相应。或有觉有观或无觉有观或无觉无观。或乐根喜根护根相应。无愿相应。若得斯陀含果。以世俗道取阿那含果。此道当言等智相应。当言有觉有观。当言护根相应。当言欲界系缘。若得斯陀含果。以无漏道取阿那含果。此道当言法智相应。或苦智习尽道智。当言有觉有观。当言护根相应。或空无相无愿相应。或欲界系缘或不系缘(不还竟)。以无碍道取阿罗汉果证。若依未来有觉有观三昧。取阿罗汉果。此道或法智相应。或未知智。或苦智习尽道智。当言有觉有观。当言护根相应。或空无相愿。或无色界系缘或不系缘。若依初禅取阿罗汉果。此道或法智相应或未知智。或苦智习尽道智。当言有觉有观。当言喜根相应。或空无相无愿。或无色界系缘或不系缘。若依禅中间取阿罗汉果。此道或法智相应。或未知智或苦智习尽道智。当言无觉有观。当言护根相应。或空无相愿。或无色界系缘或不系缘。若依二禅取阿罗汉果。此道或法智相应。或未知智或苦智习尽道智。当言无觉无观。当言喜根相应。或空无相无愿。或无色界系缘或不系缘。若依三禅取阿罗汉果。此道或法智相应。或未知智。或苦智习尽道智。当言无觉无观。当言乐根相应。或空无相愿。或无色界系缘或不系缘。若依四禅取阿罗汉果。此道或法智相应。或未知智。或苦智习尽道智。当言无觉无观。当言护根相应。或空无相愿。或无色界系缘或不系缘。若依无色定取阿罗汉果。此道当言未知智相应。或苦智习尽道智。当言无觉无观。当言护根相应。或空无相愿。或无色界系缘。或不系缘(真人竟)。几根灭尽起得须陀洹果乎。答曰。根不悉灭七尽起。一灭不起(未知)。一起不尽(已知)。当言得须陀洹果也。几根灭尽起当言得斯陀含果耶。答曰。若倍欲尽越次取证。根不悉灭七尽起一灭不起一起不尽。当言得斯陀含果也。若得须陀洹果。以世俗道取斯陀含果。根不悉灭七尽起。当言得斯陀含果。若得须陀洹果。以无漏道取斯陀含果。根不悉灭八尽起(如已知)。当言得斯陀含果也。几根灭尽起。当言得阿那含果乎。答曰。若欲爱尽越次取证。根不悉灭七尽起。一灭不起一起不尽。当言得阿那含果也。若得斯陀含果。以世俗道取阿那含果。禅不现在前四根悉灭(忧苦男女)。七尽起当言得阿那含果。若禅现在前四根悉灭也。六尽起(五根竟)。一灭不起一起不尽。当言得阿那含果也。若得斯陀含果。以无漏道取阿那含果。禅不现在前四根悉灭八尽起。当言得阿那含果也。若禅现在前四根悉灭七尽起(五根意已知)。一灭不起(护根)。一起不尽(或乐喜)。当言得阿那含果也。几根灭尽起。当言得阿罗汉果乎。答曰。若依未来有觉有观三昧。取阿罗汉果。一根悉灭(命也)。七灭尽起一灭不起(已知)。一起不尽(无知)。当言得阿罗汉果。初禅中间第四禅无色定亦复如是。若依初禅取阿罗汉果。二根悉灭(命护)。六灭尽起一灭不起一起不尽一尽起。当言得阿罗汉果也。二禅三禅亦复如是(三禅乐根)

有品第二十八竟(梵本三百二十八首卢秦言四千二百七十二言)

    阿毗昙根犍度更乐跋渠第三

十六更乐有对更增语更。明更无明更非明非无明更。爱更恚更。乐痛更。苦痛更。不苦不乐痛更。眼更耳更鼻更舌更身更意更。何等有对更乃至意更为何等耶。有对更摄几更。乃至意更摄几更乎。有对更几根相应。乃至意更几根相应耶。诸根有对更因有对更此根相应乎。设根有对更相应。彼根有对更因乃至意更因亦复如是。诸此种成就眼根。彼成就此种身根乎。设成就此种身根。彼成就此种眼根乎。耳鼻舌根亦复如是。地狱几根成就。畜生饿鬼断善本邪定等定不定。阎浮提拘耶尼弗于逮郁单曰。四天王身三十三天。炎摩兜术化自在他化自在天。梵加夷天。光音。遍净。果实天。中阴。无色。坚信坚法信解脱见到。身证慧解脱俱解脱成就几根乎。眼根得断智时。几根得断智。乃至慧根得断智时。几根得断智。眼根得尽证时。几根得尽证。乃至慧根得尽证时。几根得尽证。此章义愿具演说

十六更乐有对更乐增语更乐。明更乐无明更乐。非明非无明更乐。爱更乐恚更乐。乐痛更乐苦痛更乐。不苦不乐痛更乐。眼更乐耳更乐鼻更乐舌更乐身更乐意更乐。云何有对更乐乎。答曰。五识身相应更乐。云何增语更乐乎。答曰。意识身相应更乐。云何明更乐。答曰。无漏更乐。云何无明更乐乎。答曰。染污更乐。云何非明非无明更乐。答曰。无染污有漏更乐。云何爱更乐乎。答曰。欲相应更乐。云何恚更乐。答曰。嗔恚相应更乐。何谓乐痛更乐。答曰。乐痛相应更乐。何谓苦痛更乐。答曰。苦痛相应更乐。何谓不苦不乐痛更乐乎。答曰。不苦不乐痛相应更乐。何谓眼更乐耶。答曰。眼识身相应更乐。耳鼻舌身更乐亦如是。何谓意更乐乎。答曰。意识身相应更乐。有对更乐摄六更乐七更乐少入。增语更乐摄三更乐七更乐少入。明更乐摄明更乐四更乐少入。无明更乐摄三更乐十一更乐少入。非明非无明摄非明非无明更乐十一更乐少入。爱更乐摄爱更乐十一更乐少入。恚更乐摄恚更乐十一更乐少入。乐痛更乐摄乐痛更乐十二更乐少入。苦痛更乐摄苦痛更乐十一更乐少入。不苦不乐痛更乐摄不苦不乐痛更乐十三更乐少入。眼更乐摄眼更乐八更乐少入。耳鼻舌身更乐亦复如是。意更乐摄三更乐七更乐少入。有对更乐一根相应八根少入。增语更乐五根相应八根少入。明更乐三根相应九根少入。无明更乐六根少入相应。非明非无明更乐十一根少入相应。爱更乐四根少入相应。恚更乐四根少入相应。乐痛更乐二根相应九根少入。苦痛更乐二根相应六根少入。不苦不乐痛更乐一根相应九根少入。眼更乐九根少入相应。耳更乐鼻更乐舌更乐身更乐亦复如是。意更乐五根相应八根少入。诸根因有对更乐。有对更乐此根相应乎。答曰。如是。诸根有对更乐相应。彼根因有对更乐。颇根因有对更乐。此根非有对更乐相应。答曰。有诸根因有对更乐诸余更乐相应。若根因有对更乐报生无缘乃至因意更乐亦复如是。除二更乐。诸根因明更乐此根明更乐相应乎。答曰。如是。诸根明更乐相应彼根因明更乐乎。答曰。如是。诸根因非明非无明更乐。此根非明非无明更乐相应。答曰。如是。诸根非明非无明更乐相应。此根因非明非无明更乐。颇根因非明非无明更乐。此根非明非无明更乐相应乎。答曰。有诸根因非明非无明更乐报生无缘。诸此种成就眼根。彼成就此种身根乎。答曰。或此种成就眼根非此种身根。云何此种成就眼根非此种身根乎。答曰。生欲界不得眼根。设得便失得天眼。是谓此种成就眼根非此种身也。云何此种成就身根非此种眼根乎。答曰。生欲界不得眼根。设得便失不得天眼。是谓此种成就身根非此种眼根也。云何此种成就眼根此种身根。答曰。生欲界得眼根不失若生色界。是谓此种成就眼根此种身根也。云何非此种成就眼根。非此种身根乎。答曰。生无色界。是谓非此种成就眼根。非此种身根也。耳根亦如是。若此种成就鼻根。彼此种成就身根乎。答曰。如是。若此种成就鼻根。彼此种成就身根。颇此种成就身根非此种鼻根耶。答曰。有生欲界不得鼻根。设得便失。舌根亦如是。地狱成就几根。答曰。若极多成就十九。若极少八。畜生若极多十九。若极少十三。饿鬼亦如是。断善根若极多十三若极少八。邪定若极多十九若极少八。等定若极多十九若极少十一。不定若极多十九若极少八。阎浮提拘耶尼弗于逮亦复如是。郁单曰若极多十八若极少十三。四天王身若极多十九若极少十七。三十三天炎天兜术天化自在天他化自在天亦复如是。梵加夷天若极多十六若极少十五。光音天亦复如是。遍净天若极多十六若极少十四。果实天若极多十六若极少十三。中阴若极多十九若极少十三。无色若极多十一若极少八。坚信坚法若极多十九若极少十三。信解脱见到若极多十九若极少十一。身证慧解脱俱解脱若极多十八若极少十一。眼根得断智时到色爱尽。五根得断智耳鼻舌身根亦复如是。意根得断智时到无色爱尽。八根得断智命根护根信精进念定慧根亦如是。男根女根得断智时到欲爱尽。四根得断智苦根忧根亦复如是。乐根得断智时到遍净爱尽。即彼乐根得断智。喜根得断智时到光音爱尽。即彼喜根得断智。眼根尽作证时到色爱尽。五根尽作证得阿罗汉。十九根尽作证。耳鼻舌身根亦复如是。意根尽作证时得阿罗汉。十九根尽作证。命根护根信精进念定慧根亦复如是。男根女根尽作证时到欲爱尽。四根尽作证得阿罗汉。十九根尽作证。苦根忧根亦复如是。乐根尽作证时到遍净爱尽。即彼乐根尽作证得阿罗汉。十九根尽作证也。喜根尽作证时到光音爱尽。即彼喜根尽作证得阿罗汉。十九根尽作证也

阿毗昙更乐品第二十九竟(梵本一百四十一首卢秦言一千九百一言)

阿毗昙八犍度论卷第二十一阿毗昙八犍度论卷第二十二

        迦旃延子造

        符秦罽宾三藏僧伽提婆共竺佛念译

    根犍度始心跋渠第四

一切众生当言始心兴始心住始心灭乎。诸心有欲诸心无欲。此心当言始兴始住始灭。有嗔恚无嗔恚有痴无痴。有染污无染污有乱无乱。有怠无怠有小有大。有修不修有三昧无三昧。诸心不解脱诸心解脱。此心当言始兴始住始尽寿当言与心回不与心回耶。当言顺回。当言始生住。又世尊言

人命消尽。如小河水。诸众生恒。寿彼寿尽。云何尽耶。入无想定灭尽定。寿行当言回不回入。无想定几根尽。何系心心法尽。无想三昧起几根现在前。何系心心法现在前。入灭尽定几根尽。何系心心法尽。灭尽三昧起几根现在前。何系心心法现在前。生无想众生几根灭。何系心心法灭。几根现在前。何系心心法现在前。无想众生没几根灭。何系心心法灭。几根现在前。何系心心法现在前。无想众生当言想生。当言无想生耶。又世尊言。想生彼众生彼处没彼想灭。彼众生彼处没为不灭住。何处灭此想。此想当言善耶。为无记耶。此想几使所使几结所系。又世尊言。一切众生由食存。无想众生何食乎。眼根摄几根。乃至无知根摄几根。信力乃至慧力。念觉意乃至护觉意。等见乃至等定。法智乃至道智。空无相愿三昧摄几根乎。意根几根相应。乃至无知根几根相应耶。信力乃至慧力。念觉意乃至护觉意。等见乃至等定。法智乃至道智。空无相愿三昧几根相应乎。欲界没生欲界几根灭。灭何系心心法耶。几根现在前何系心心法现在前。欲界没生色界。欲界没生无色界。色界没生色界。色界没生欲界。色界没生无色界。无色界没生无色界。无色界没生欲界。无色界没生色界。几根灭灭何系心心法。几根现在前。何系心心法现在前。阿罗汉般泥洹几根最后灭耶。此章义愿具演说

一切众生当言始心兴始心住始心灭。答曰。如是。诸心有欲诸心无欲。此心当言始兴始住始灭。答曰。如是。有嗔恚无嗔恚有痴无痴。有染污无染污有乱无乱。有怠无怠有小有大。不修修不定定。诸心无解脱诸心解脱。此心当言始兴始住始灭耶。答曰。如是。寿当言与心回耶。为不与心回。答曰。寿当言不与心回。当言顺回始生住耶。答曰。欲界众生。不入无想三昧灭尽三昧则顺回。若入无想定灭尽定。及色无色界天当言始生住。又世尊言

人命消尽。如小河水。诸众生恒。寿彼寿尽。云何知彼寿尽。答曰。世尽劫尽入无想三昧灭尽三昧。寿行当言顺回当言住耶。答曰。当言住。入无想三昧几根尽。答曰。七。何系心心法灭。答曰。色界系。无想三昧起几根现在前。答曰七。何系心心法现在前。答曰。色界系。入灭尽三昧几根尽。答曰七。何系心心法尽。答曰。无色界系。灭尽三昧起几根现在前。答曰。或七(五根意护)或八(加已知根)。有漏心七。无漏心八。何系心心法现在前。答曰。或无色界系或不系。生无想天几根尽。答曰。八(五情意命护)。何系心心法尽。答曰。色界系。几根现在前。答曰八。何系心心法现在前。答曰。色界系。无想众生没几根尽。答曰八。何系心心法尽。答曰。色界系。几根现在前。答曰。或八或九或十。无形八。一形九(加女或男)。二形十。何系心心法现在前。答曰。欲界系。无想众生当言想生无想生耶。答曰。无想众生当言想生。又世尊言想起。彼众生彼处没为想灭。彼众生彼处没为不灭耶。答曰。彼想灭。彼众生彼处没非不灭住。何处灭彼想。答曰。即住彼灭。彼想此想当言善为无记耶。答曰。此想或善或无记。此想几使所使。答曰。色界有漏缘。几结系。答曰六。又世尊言。一切众生由食存。无想天何食。答曰。更意念识。眼根摄眼根。耳鼻舌根亦复如是。身根摄三根。意根摄意根三根少入。乐根喜根护根信根精进念定慧根亦复如是。女根摄女根身根少入。男根摄男根身根少入。命根摄命根。苦根摄苦根。忧根摄忧根。未知根摄未知根九根少入。已知根无知根亦复如是。信力摄一根三根少入。精进念定慧力亦复如是。念觉意四根少入。择法精进喜定觉意亦复如是。猗护觉意不摄根。等见等方便等念等定法智未知智四根少入摄。知他人心智三根少入摄。等智一根少入摄。苦智习尽道智空无相愿三昧四根少入摄。意根十根相应(五信五痛)。三根少入。乐根喜根护根九根相应少入。苦根忧根六根少入相应(五根加意)。信根四根相应。九根少入精进念定慧根亦复如是。未知根九根少入相应。已知根无知根亦复如是。信力四根相应。九根少入精进念定慧力亦复如是。念觉意十一根少入相应。法精进定觉意亦复如是。喜觉意九根相应少入。猗觉意护觉意三根相应九根少入。等见等志等方便等念等定。法智未知智十一根相应少入。知他人心智十根相应少入。等智二根相应八根少入。苦智习尽道智。空无相愿三昧十一根相应少入。欲界生欲界几根尽。答曰。或四或九或八或十三或九或十四或十或十五。欲界系无记心渐命终四。善心九。无形一时无记心命终八。善心十三。一形一时无记心命终九。善心十四。二形一时无记心命终十。善心十五。何系心心法尽。答曰。欲界系。几根现在前。答曰。或八或九或十。无形八。一形九。二形十。何系心心法现在前。答曰。欲界系。欲界生色界几根尽。答曰。或四或九或十四。欲界系无记心渐命终四。善心九。一时无记心命终九。善心十四。何系心心法尽。答曰。欲界系。几根现在前。答曰。八。何系心心法现在前。答曰。色界系。欲界生无色界几根尽。答曰。或四或九或十四。欲界系无记心渐命终四。善心九。一时无记心命终九。善心十四。何系心心法尽。答曰。欲界系几根现在前。答曰。三。何系心心法现在前乎。答曰。无色界系(欲界竟)。色界生色界几根尽。答曰。或八或十三。无记心命终八。善心十三。何系心心法尽。答曰。色界系。几根现在前。答曰。八。何系心心法现在前乎。答曰。色界系。色界生欲界几根尽。答曰。或八或十三。无记心命终八。善心十三。何系心心法尽。答曰。色界系几根现在前。答曰。或八或九或十。无形八。一形九。二形十。何系心心法现在前。答曰。欲界系。色界生无色界系几根尽。答曰。或八或十三。无记心命终八。善心十二。何系心心法尽。答曰。色界系。几根现在前。答曰。三。何系心心法现在前乎。答曰。无色界系(色界竟)。无色界生无色界几根尽。答曰。或三或八。无记心三。善心八。何系心心法尽。答曰。无色界系。几根现在前乎。答曰。三何系心心法现在前。答曰。无色界。系无色界。生欲界几根尽。答曰。或三或八。无记心三。善心八。何系心心法尽。答曰。无色界系。几根现在前。答曰。或八或九或十。无形八。一形九。二形十。何系心心法现在前。答曰。欲界系。无色界生色界几根尽。答曰。或三或八。无记心三。善心八。何系心心法尽。答曰。无色界系。几根现在前乎。答曰。八。何系心心法现在前。答曰。色界系。阿罗汉般泥洹几根最后灭。答曰。或四或九或八或三。欲界渐般泥洹四。一时九。色界八。无色界三

阿毗昙始心品第三十竟(梵本二百六十九首卢秦言二千二百二十一言)

    阿毗昙根犍度始发心跋渠第五

诸法心共一起一住一尽。彼法心相应耶。设法心相应彼法心共一起一住一尽。诸法心共一起一住一尽。彼法心共一缘耶。设诸法心共一缘。彼法心共一起一住一尽。诸法心共起非不用心。彼法起心共起非不用心耶。彼法住尽心共住尽。非不用心耶。云何不修眼根。云何不修耳鼻舌身意根。云何修眼根。云何修耳鼻舌身意根。若不成就学根得学根。彼一切越次取证耶。设越次取证。彼一切不成就学根。得学根。若不成就学根得学根。彼一切世间第一法次第耶。设世间第一法次第。彼一切不成就学根。得学根。若无漏根弃得无漏根。彼一切果果由耶。设果果由。彼一切弃无漏根。得无漏根耶。若弃无漏根得无漏根。彼一切无漏根尽。无漏根现在前。设无漏根尽无漏根现在前。彼一切弃无漏根得无漏根。诸未知根彼一切不修谛修有。设不修谛修有。彼一切未知根最初尽智生。彼一切无碍道次第耶。设无碍道次第。彼一切尽智最初无生智起。彼一切尽智次第耶。设尽智次第。彼一切无生智耶。如缘无碍道彼缘尽智。如缘尽智彼缘无碍道。如缘尽智彼缘无生智耶。如缘无生智彼缘尽智。尽智当言尽智法智未知智知他人心智苦智习智尽智道智。当言有觉有观。当言无觉有观。当言无觉无观。当言乐根相应。喜根护根空无相无愿。当言欲界系缘。当言色无色界系缘。当言不系缘。无生智无学等见亦如是。诸法无学等见相应。彼法无学等志相应耶。设诸法无学等志相应。彼法无学等见相应。诸法无学等见相应。彼法无学等方便等念等定等解脱等智相应耶。设诸法无学等智相应。彼法无学等见相应。诸法无学乃至等解脱相应。彼法无学等智相应。设诸法无学等智相应。彼法无学等解脱相应。此章义愿具演说

诸法心共一起一住一尽。彼法心相应耶。答曰。如是。诸法心共相应。彼法心共一起一住一尽。颇法心共一起一住一尽。彼法非心相应耶。答曰。有心回转色心回转心不相应行。诸法心共一起一住一尽。彼法心共一缘耶。答曰。如是。诸法心共一缘彼法心共一起一住一尽。颇法心共一起一住一尽。彼法非心共一缘。答曰。有心回转色心回转心不相应行。诸法心共起非不用心。彼法起心共起非不用心。彼法住尽心共住尽非不用心耶。答曰。欲色界众生。不入无想三昧灭尽三昧。诸根四大彼法起心共起非不用心。住尽心共住尽非不用心。入定不用心。云何不修眼根。答曰。眼根爱未尽贪未尽念未尽渴未尽。复次以无碍道尽色爱。彼道不修不猗。如是不修眼根。耳鼻舌身根亦复如是。云何不修意根。答曰。意根爱未尽贪未尽念未尽渴未尽。复次以无碍道尽无色爱。彼道不修不猗。如是不修意根。云何修眼根。答曰。眼根爱尽贪尽念尽渴尽。复次以无碍道尽色爱。彼道修猗。如是修眼根。耳鼻舌身根亦如是。云何修意根。答曰。意根爱尽贪尽念尽渴尽。复次以无碍道尽无色爱。彼道修猗。如是修意根。若不成就学根得学根。彼一切越次取证耶。答曰。如是。诸越次取证。彼一切不成就学根。得学根颇不成就学根得学根。彼非越次取证耶。答曰有。阿罗汉果退也。若不成就学根得学根。彼一切世间第一法次第耶。答曰。如是。诸世间第一法次第。彼一切不成就学根得学根。颇不成就学根得学根。彼非世间第一法次第耶。答曰有。阿罗汉果退也。若弃无漏根得无漏根。彼一切果果游耶。答曰。如是。诸果果由彼一切弃无漏根得无漏根。颇弃无漏根得无漏根。彼非果果由耶。答曰有。所修道未知智现在前。若等意解脱阿罗汉得无疑也。若弃无漏根得无漏根。彼一切尽无漏根。无漏根现在前耶。答曰。或弃无漏根得无漏根。彼非尽无漏根无漏根现在前。云何弃无漏根得无漏根。彼非尽无漏根。无漏根现在前。答曰。世俗道取斯陀含果。阿那含果。阿罗汉果退。阿那含斯陀含果退。是谓弃无漏根得无漏根。彼不尽无漏根无漏根现在前。云何尽无漏根无漏根现在前。彼非弃无漏根得无漏根。答曰。如本得无漏根尽现在前。是谓尽无漏根无漏根现在前。彼非弃无漏根得无漏根。云何弃无漏根得无漏根。彼尽无漏根无漏根现在前。答曰。所修道未知智现在前。无漏道取斯陀含阿那含果得阿罗汉果。等意解脱阿罗汉得无疑。是谓弃无漏根得无漏根。彼尽无漏根无漏根现在前。云何非弃无漏根不得无漏根。非尽无漏根无漏根现在前。答曰。除上尔所事。诸未知根彼一切不修谛修有。答曰。或未知根彼非不修谛修有。云何未知根彼非不修谛修有。答曰。诸未知根若过去未来。是谓未知根彼非不修谛修有。云何不修谛修有。彼非未知根。答曰。诸无根法不修谛修有。是谓不修谛修有。彼非未知根。云何未知根彼不修谛修有。答曰。诸未知根不修谛修有。是谓未知根彼不修谛修有。云何非未知根非不修谛修有。答曰。除上尔所事。最初尽智生。彼一切无碍道次第耶。答曰。如是。设无碍道次第。彼一切尽智耶。答曰。如是。最初无生智生。彼一切尽智次第耶。答曰。如是。设尽智次第彼一切无生智。答曰。或彼尽智。或无生智。或无学等见也。诸缘无碍道彼缘尽智。答曰。若缘彼种无碍道彼缘尽智。若不缘此种无碍道。彼不缘尽智。如缘尽智彼缘无生智耶。答曰。如是。如缘无生智。彼缘尽智耶。答曰。如是。尽智当言尽智。答曰。尽智当言尽智。或彼法智未知智苦智习尽道智。或有觉有观。或无觉有观。或无觉无观。或乐根相应。或喜根护根。或空无愿无相。或欲界系缘。或色无色界系缘。或不系缘。无生智亦如是。无学等见当言无学等见耶。答曰。无学等见当言无学等见。或彼法智未知智知他人心智苦智习尽道智。或有觉有观。或无觉有观。或无觉无观。或乐根相应。或喜根护根或空无愿无相。或欲界系缘。或色无色界系缘。或不系缘(无学见竟)。诸法无学等见相应。彼无学等志耶。答曰。或等见非等志。云何等见非等志。答曰。等见相应等志。诸等志不相应等见相应法。是谓等见非等志。云何等志非等见。答曰。等志相应等见。诸等见不相应等志相应法。是谓等志非等见。云何等见等志。答曰。除等见相应等志。诸等见等志相应法。是谓等见等志。云何非等见等志。答曰。等见不相应等志。等志不相应等见。诸余心心法。色无为心不相应行。是谓非等见等志。诸法无学等见相应。彼无学等方便耶。答曰。或等见非等方便。云何等见非等方便。答曰。等见相应等方便。是谓等见非等方便。云何等方便非等见。答曰。等见诸等见不相应。等方便相应法。是谓等方便非等见。云何等见等方便。答曰。除等方便诸等见相应法。是谓等见等方便。云何非等见等方便。答曰。等见不相应等方便。诸余心心法。色无为心不相应行。是谓非等见等方便。等念等定等解脱亦如是。诸法无学等见相应。彼非无学等智。设诸法无学等智相应。彼非无学等见(无学见竟)。诸法无学等志相应。彼无学等方便。答曰。或等志非等方便。云何等志非等方便。答曰。等志相应等方便。是谓等志非等方便。云何等方便非等志。答曰。等志诸等志不相应。等方便相应法。是谓等方便非等志。云何等志等方便。答曰。除等方便诸等志相应法。是谓等志等方便。云何非等志非等方便。答曰。等志不相应等方便。诸余心心法。色无为心不相应行。是谓非等志非等方便。等念等定等解脱亦如是。诸法无学等志相应。彼无学等智耶。答曰。或等志非等智。云何等志非等智。答曰。等志相应等智。诸等智不相应等志相应法。是谓等志非等智。云何等智非等志。答曰。等智相应等志。诸等志不相应等智相应法。是谓等智非等志。云何等志等智。答曰。除等志相应等智。诸等志等智相应法。是谓等志等智。云何非等志等智。答曰。等志不相应等智。等智不相应等志。诸余心心法。色无为心不相应行。是谓非等志等智(等志竟)。诸法无学等方便相应。彼无学等念耶。答曰。或等方便非等念。云何等方便非等念。答曰。等念。是谓等方便非等念。云何等念非等方便。答曰。等方便。是谓等念非等方便。云何等方便等念。答曰。除等念。诸等方便相应法。是谓等方便等念。云何非等方便等念。答曰。诸余心心法。色无为心不相应行。是谓非等方便。等念等定等解脱亦如是。诸法无学等方便相应。彼无学等智耶。答曰。或等方便非等智。云何等方便非等智耶。答曰。或等方便非等智。云何等方便非等智。答曰。等智诸等智不相应。等方便相应法。是谓等方便非等智。云何等智非等方便。答曰。等智相应等方便。是谓等智非等方便。云何等方便等智。答曰。除等方便。诸等智相应法。是谓等方便等智。云何非等方便等智。答曰。等智不相应等方便。诸余心心法。色无为心不相应行。是谓非等方便等智(方便竟)。等念等定门亦如是。诸法无学等解脱相应。彼无学等智耶。答曰。或等解脱非等智。云何等解脱非等智。答曰。等智诸等智不相应。等解脱相应法。是谓等解脱非等智。云何等智非等解脱。答曰。等智相应等解脱。是谓等智非等解脱。云何等解脱等智。答曰。除等解脱。诸等智相应法。是谓等解脱等智。云何非等解脱等智。答曰。等智不相应等解脱。诸余心心法。色无为心不相应行。是谓非等解脱等智

始发心品第三十一竟(梵本二百四十二首卢秦言三千九百四十二言)

    阿毗昙根揵度鱼子跋渠第六

二十二根。眼根耳鼻舌身根意根。男根女根命根。乐根苦根喜根忧根护根。信根精进念定慧根。未知根已知根无知根。若成就眼根。于此二十二根。成就几不成就几。乃至成就无知根。于此二十二根。成就几不成就几(成就竟)。若成就眼根。于此二十二根。成就过去几未来几现在几。若成就乃至无知根。于此二十二根。成就过去几未来几现在几(三世成就竟)。若不成就眼根。于此二十二根。成就几不成就几。若不成就乃至无知根。于此二十二根。成就几不成就几(不成就竟)。若不成就眼根。于此二十二根。成就过去几未来几现在几。若不成就乃至无知根。于此二十二根。成就过去几未来几现在几(三世不成就竟)。诸根善彼根因善根本耶。设诸根因善根本彼根善耶。诸根不善彼根因不善根本耶。设诸根因不善根本。彼根不善耶。诸根无记彼根因无记根本耶。设诸根因无记根本。彼根无记耶。颇根不因善根本。亦不因不善根本。亦不因无记根本。彼根非不因耶。此章义愿具演说

二十二根。眼根耳鼻舌身根意根。男根女根命根。乐根苦根喜根忧根护根。信根精进念定慧根。未知根已知根无知根。若成就眼根。彼必成就五根(加下眼)。余或成就或不成就。耳鼻舌根亦如是。若成就身根。彼必成就四根(身命意护)。余或成就或不成就。若成就意根。彼必成就三根(意命护)。余或成就或不成就。命根护根亦如是。若成就男根女根。彼必成就八根。余或成就或不成就。若成就乐根彼必成就四根。余或成就或不成就。若成就苦根。彼必成就七根。余或成就或不成就。若成就喜根。彼必成就五根。余或成就或不成就。若成就忧根。彼必不成就一根。彼必成就八根。余或成就或不成就。若成就信根。彼必成就八根。余或成就或不成就。精进念定慧根亦如是(加意命护根)。若成就未知根。彼必不成就二根(已知无知根)。必成就十三根(信五加意苦身命护喜乐未知)。余或成就或不成就。若成就已知根。彼必不成就二根(未知无智)。必成就十一根(除上忧苦二)。余或成就或不成就。若成就无知根。彼必不成就三根(未知已知加忧根也)。必成就十一根。余或成就或不成就(成就竟)。若成就眼根。彼必不成就过去未来八根。必成就过去未来二根现在三根。余或成就或不成就耳鼻舌根亦如是。若成就身根。彼必不成就过去未来八根。必成就过去未来二根现在二。余或成就或不成就。若成就意根。彼必不成就过去未来八根。必成就过去未来二根现在一。余或成就或不成就。命根护根亦如是。若成就男根女根。彼必不成就过去未来八根。必成就过去未来五根现在三。余或成就或不成就。若成就乐根。彼必不成就过去未来八根。必成就过去未来二根未来一现在一。余或成就或不成就。若成就苦根。彼必不成就过去未来八根。必成就过去未来五根现在二。余或成就或不成就。若成就喜根彼必不成就过去未来八根。必成就过去未来二根未来二现在一。余或成就或不成就。若成就忧根。彼必不成就过去未来八根。彼必不成就过去未来现在一根。必成就过去未来四根。过去未来现在二。现在二。余或成就或不成就。若成就信根。彼必不成就过去未来八根。必成就过去未来七根现在一。余或成就或不成就。精进念定慧根亦如是。若成就未知根。彼必不成就过去未来八根。必不成就过去未来现在二根。必成就过去未来现在七根。过去未来三未来现在一现在二。余或成就或不成就。若成就已知根。彼必不成就过去未来八根。必不成就过去未来现在二根。必成就过去未来七根。未来三现在一。余或成就或不成就。若成就无知根。彼必不成就过去未来八根。必不成就过去未来现在三根。必成就过去未来七根。未来三现在一。余或成就或不成就(三世成竟)。若不成就眼根。彼必不成就一根。必成就三根。余或成就或不成就。耳鼻舌根亦如是。若不成就身根。彼必不成就十根。必成就八根。余或成就或不成就。意根命根护根无不成就。若不成就男根女根。彼必不成就一根。必成就三根。余或成就或不成就。若不成就乐根。彼必不成就九根。必成就八根。余或成就或不成就。若不成就苦根。彼必不成就五根。必成就八根。余或成就或不成就。若不成就喜根。彼必不成就八根。必成就八根。余或成就或不成就。若不成就忧根。彼必不成就一根。必成就八根。余或成就或不成就。若不成就信根。必不成就八根。必成就八根。余或成就或不成就。精进念定慧根亦如是。若不成就未知根。彼必不成就一根。必成就三根。余或成就或不成就。已知根无知根亦如是(不成竟)。若不成就眼根。彼必不成就过去未来现在一根。必不成就过去未来七根。必成就过去未来二根现在一。余或成就或不成就。耳鼻舌根亦如是。若不成就身根。彼必不成就过去未来现在十根。必不成就过去未来一根。必成就过去未来五根过去未来现在二根现在一。余或成就或不成就。意根命根护根无不成就。若不成就男根女根。彼必不成就过去未来现在一根。必不成就过去未来七根。必成就过去未来二根现在一。余或成就或不成就。若不成就乐根。彼必不成就过去未来现在九根。必不成就过去未来六根。必成就过去未来七根现在一。余或成就或不成就。若不成就苦根。彼必不成就过去未来现在五根。必不成就过去未来六根。必成就过去未来七根现在一。余或成就或不成就。若不成就喜根。彼必不成就过去未来现在八根。必不成就过去未来六根。必成就过去未来七根现在一。余或成就或不成就。若不成就忧根。彼必不成就过去未来现在一根。必不成就过去未来八根。必成就过去未来七根现在一。余或成就或不成就。若不成就信根。彼必不成就过去未来现在八根。必不成就过去未来八根。必成就过去未来四过去未来现在二根现在二。余或成就或不成就。精进念定慧根亦如是。若不成就未知根。彼必不成就过去未来现在一根。必不成就过去未来八根。必成就过去未来二根现在一。余或成就或不成就。已知根无知根亦如是(三世不成就竟)。诸根善彼根因善根本耶。答曰。如是。诸根善彼根因善根本。颇根因善根本。彼根非善耶。答曰有。善根本报无记根也。诸根不善彼根因不善根本耶。答曰。如是。诸根不善。彼根因不善根本。颇根因不善根本。彼根非不善。答曰有。不善根本报无记根。若欲界身见边见相应根也。诸根无记。彼根因。无记根本耶。答曰。或根无记。彼根不因无记根本。云何根无记彼根不因无记根本。答曰。无记无缘根。是谓根无记彼根不因无记根本。云何根因无记根本。彼根非无记。答曰。不善根是谓根因。无记根本彼根非无记。云何根无记彼根因无记根本。答曰。无记根本有缘根。是谓根无记彼根因无记根本。云何根非无记彼根非因无记根本。答曰。善根是谓根非无记。彼根非因无记根本。颇根非因善根本。非因不善根本。非因无记根本。彼根非不因耶。答曰有。诸无缘根。因色心不相应行

鱼子品第三十二竟(梵本一百七十三首卢秦言三千三百四十二言)

阿毗昙八犍度论卷第二十二阿毗昙八犍度论卷第二十三

        迦旃延子造

        符秦罽宾三藏僧伽提婆共竺佛念译

    根犍度缘跋渠第七之一

因者诸缘。当作次渐。五三及四。四亦共八。八等有八。八亦复四

诸根因过去彼根缘过去耶。设诸根缘过去彼根因过去耶。诸根因未来因现在。因善因不善因无记。因欲界系因色界系因无色界系因不系。因学因无学因非学非无学。因见谛断因思惟断因无断。彼根缘无断耶。设诸根缘无断彼根因无断耶(五三竟)。诸根因见苦断。彼根缘见苦断耶。设诸根缘见苦断。彼根因见苦断耶。诸根因见习见尽见道断。彼根缘见道断耶。设诸根缘见道断。彼根因见道断耶(四竟)。诸根因见苦断。彼根缘苦法智断耶。设诸根缘苦法智断。彼根因见苦断耶。诸根因见苦断。彼根缘苦未知智断耶。设诸根缘苦未知智断。彼根因见苦断耶。诸根因见习见尽见道断。彼根缘道法智断耶。设诸根缘道法智断。彼根因见道断耶。诸根因见道断。彼根缘道未知智断耶。设诸根缘道未知智断。彼根因见道断耶(四八竟)。诸根因苦法智断。彼根缘苦法智断耶。设诸根缘苦法智断。彼根因苦法智断耶。诸根因苦未知智断。彼根缘苦未知智断耶。设诸根缘苦未知智断。彼根因苦未知智断耶。诸根因习尽道法智断。彼根缘道法智断耶。设诸根缘道法智断。彼根因道法智断耶。诸根因道未知智断。彼根缘道未知智断耶。设诸根缘道未知智断。彼根因道未知智断耶(八共竟)。诸根因苦法智断。彼根缘见苦断耶。设诸根缘见苦断。彼根因苦法智断耶。诸根因苦未知智断。彼根缘见苦断耶。设诸根缘见苦断。彼根因苦未知智断耶。诸根因习尽道法智断。彼根缘见道断耶。设诸根缘见道断。彼根因道法智断耶。诸根因道未知智断。彼根缘见道断耶。设诸根缘见道断。彼根因道未知智断耶(八四竟)。此章义愿具演说

诸根因过去。彼根缘过去耶。答曰。或根因过去缘过去。缘未来缘现在缘无为无缘。云何根因过去缘过去。答曰。诸根因过去缘过去。复次诸根未来现在因过去缘过去。云何根因过去缘未来。答曰。诸根过去缘未来。复次诸根未来现在因过去缘未来。云何根因过去缘现在。答曰。诸根过去缘现在。复次诸根未来现在。因过去缘现在。云何根因过去缘无为。答曰。诸根过去缘无为。复次诸根未来现在。因过去缘无为。云何根因过去无缘。答曰。诸根无缘因过去法。设诸根缘过去。彼根因过去耶。答曰。或根缘过去因过去因未来因现在。云何根缘过去因过去。答曰。诸根缘过去因过去。复次诸根未来现在因过去缘过去。云何根缘过去因未来。答曰。诸根未来缘过去。云何根缘过去因现在。答曰。诸根现在缘过去。复次诸根未来因现在缘过去(过去竟)。诸根因未来彼根缘未来耶。答曰。或根因未来缘未来。缘过去缘现在缘无为无缘。云何根因未来缘未来。答曰。诸根未来缘未来。云何根因未来缘过去。答曰。诸根未来缘过去。云何根因未来缘现在。答曰。诸根未来缘现在。云何根因未来缘无为。答曰。诸根未来缘无为。云何根因未来无缘。答曰。诸根无缘因未来法。设诸根缘未来。彼根因未来耶。答曰。或根缘未来。因未来因过去因现在。云何根缘未来因未来。答曰。诸根未来缘未来。云何根缘未来因过去。答曰。诸根过去缘未来。复次诸根未来现在因过去缘未来。云何根缘未来因现在。答曰。诸根现在缘未来。复次诸根未来因现在缘未来(未来竟)。诸根因现在彼根缘现在耶。答曰。或根因现在缘现在。缘过去缘未来缘无为无缘。云何根因现在缘现在。答曰。诸根现在缘现在。复次诸根未来因现在缘现在。云何根因现在缘过去。答曰。诸根现在缘过去。复次诸根未来因现在缘过去。云何根因现在缘未来。答曰。诸根现在缘未来。复次诸根未来因现在缘未来。云何根因现在缘无为。答曰。诸根现在缘无为。复次诸根未来因现在缘无为。云何根因现在无缘。答曰。诸根无缘因现在法。设诸根缘现在彼根因现在耶。答曰。或根缘现在因现在因过去因未来。云何根缘现在因现在。答曰。诸根现在缘现在。复次诸根未来因现在缘现在。云何根缘现在因过去。答曰。诸根过去缘现在。复次诸根未来现在因过去缘现在。云何根缘现在因未来。答曰。诸根未来缘现在(一三竟)。诸根因善彼根缘善耶。答曰。或根因善缘善缘不善缘无记无缘。云何根因善缘善。答曰。诸根善缘善。复次诸根无记因善缘善。云何根因善缘不善。答曰诸根善缘不善。复次诸根无记因善缘不善。云何根因善缘无记。答曰。诸根善缘无记。复次诸根无记因善缘无记。云何根因善无缘。答曰。诸根无缘因善法。设诸根缘善彼根因善耶。答曰。或根缘善因善因不善因无记。云何根缘善因善。答曰。诸根善缘善。复次诸根无记因善缘善。云何根缘善因不善。答曰。诸根不善缘善。复次诸根无记因不善缘善。云何根缘善因无记。答曰。诸根无记缘善。复次诸根不善因无记缘善(善竟)。诸根因不善彼根缘不善耶。答曰。或根因不善缘不善。缘善缘无记无缘。云何根因不善缘不善。答曰。诸根不善缘不善。复次诸根无记因不善缘不善。云何根因不善缘善。答曰。诸根不善缘善。复次诸根无记因不善缘善。云何根因不善缘无记。答曰。诸根不善缘无记。复次诸根无记因不善缘无记。云何根因不善无缘。答曰。诸根无缘因不善法。设诸根缘不善彼根因不善耶。答曰。或根缘不善因不善因善因无记。云何根缘不善因不善。答曰。诸根不善缘不善。复次诸根无记因不善缘不善。云何根缘不善因善。答曰。诸根善缘不善。复次诸根无记因善缘不善。云何根缘不善因无记。答曰。诸根无记缘不善。复次诸根不善因无记缘不善(不善竟)。诸根因无记彼根缘无记耶。答曰。或根因无记缘无记缘善缘不善无缘。云何根因无记缘无记。答曰。诸根无记缘无记。复次诸根不善因无记缘无记。云何根因无记缘善。答曰。诸根无记缘善。复次诸根不善因无记缘善。云何根因无记缘不善。答曰。诸根无记缘不善。复次诸根不善因无记缘不善。云何根因无记无缘。答曰。诸根无缘因无记法。设诸根缘无记彼根因无记耶。答曰。或根缘无记因无记因善因不善。云何根缘无记因无记。答曰。诸根无记缘无记。复次诸根不善因无记缘无记。云何根缘无记因善。答曰。诸根善缘无记。复次诸根无记因善缘无记。云何根缘无记因不善。答曰。诸根不善缘无记。复次诸根无记因不善缘无记(二三竟)。诸根因欲界系彼根缘欲界系耶。答曰。或根因欲界系。缘欲界系。缘色界系缘无色界系缘不系无缘。云何根因欲界系缘欲界系。答曰。诸根欲界系缘欲界系。云何根因欲界系缘色界系。答曰。诸根欲界系缘色界系。云何根因欲界系缘无色界系。答曰。诸根欲界系缘无色界系。云何根因欲界系缘不系。答曰。诸根欲界系缘不系。云何根因欲界系无缘。答曰。诸根无缘因欲界系法。设诸根缘欲界系。彼根因欲界系耶。答曰。或根缘欲界系。因欲界系。因色界系。因无色界系。因不系。云何根缘欲界系因欲界系。答曰。诸根欲界系缘欲界系。云何根缘欲界系因色界系。答曰。诸根色界系缘欲界系。云何根缘欲界系因无色界系。答曰。诸根无色界系。缘欲界系。云何根缘欲界系因不系。答曰。诸根不系缘欲界系(欲界竟)。诸根因色界系彼根缘色界系耶。答曰。或根因色界系缘色界系。缘欲界系。缘无色界系。缘不系无缘。云何根因色界系缘色界系。答曰。诸根色界系缘色界系。云何根因色界系缘欲界系。答曰。诸根色界系缘欲界系。云何根因色界系缘无色界系。答曰。诸根色界系缘无色界系。云何根因色界系缘不系。答曰。诸根色界系缘不系。云何根因色界系无缘。答曰。诸根无缘因色界系法。设诸根缘色界系。彼根因色界系耶。答曰。或根缘色界系。因色界系因欲界系因无色界系因不系。云何根缘色界系因色界系。答曰。诸根色界系缘色界系。云何根缘色界系因欲界系。答曰。诸根欲界系缘色界系。云何根缘色界系。因无色界系。答曰。诸根无色界系缘色界系。云何根缘色界系因不系。答曰。诸根不系缘色界系(色界竟)。诸根因无色界系。彼根缘无色界系耶。答曰。或根因无色界系。缘无色界系。缘欲界系。缘色界系。缘不系无缘。云何根因无色界系缘无色界系。答曰。诸根无色界系缘无色界系。云何根因无色界系缘欲界系。答曰。诸根无色界系缘欲界系。云何根因无色界系缘色界系。答曰。诸根无色界系缘色界系。云何根因无色界系缘不系。答曰。诸根无色界系缘不系。云何根因无色界系无缘。答曰。诸根无缘因无色界系法。设诸根缘无色界系。彼根因无色界系耶。答曰。或根缘无色界系。因无色界系。因欲界系。因色界系。因不系。云何根缘无色界系。因无色界系。答曰。诸根无色界缘无色界系。云何根缘无色界系因欲界系。答曰。诸根欲界系缘无色界系。云何根缘无色界系因色界系。答曰。诸根色界系缘无色界系。云何根缘无色界系因不系。答曰。诸根不系缘无色界系(三三竟)。诸根因学彼根缘学耶。答曰。或根因学缘学缘无学缘非学非无学。云何根因学缘学。答曰。诸根学缘学。复次诸根无学因学缘学。云何根因学缘无学。答曰。诸根学缘无学。复次诸根无学因学缘无学。云何根因学缘非学非无学。答曰。诸根学缘非学非无学。复次诸根无学因学缘非学非无学。设诸根缘学彼根因学耶。答曰。或根缘学因学因无学因非学非无学。云何根缘学因学。答曰。诸根学缘学。复次诸根无学因学缘学。云何根缘学因无学。答曰。诸根无学缘学。云何根缘学因非学非无学。答曰。诸根非学非无学缘学(学竟)。诸根因无学彼根缘无学耶。答曰。或根因无学。缘无学缘学缘非学非无学。云何根因无学缘无学。答曰。诸根无学缘无学。云何根因无学缘学。答曰。诸根无学缘学。云何根因无学缘非学非无学。答曰。诸根无学缘非学非无学。设诸根缘无学彼根因无学耶。答曰。或根缘无学因无学因学因非学非无学。云何根缘无学因无学。答曰。诸根无学缘无学。云何根缘无学因学。答曰。诸根学缘无学。复次诸根无学因学缘无学。云何根缘无学因非学非无学。答曰。诸根非学非无学缘无学(无学竟)。诸根因非学非无学。彼根缘非学非无学耶。答曰。或根因非学非无学。缘非学非无学。缘学缘无学无缘。云何根因非学非无学。缘非学非无学。答曰。诸根非学非无学。缘非学非无学。云何根因非学非无学缘学。答曰。诸根非学非无学缘学。云何根因非学非无学缘无学。答曰。诸根非学非无学缘无学。云何根因非学非无学无缘。答曰。诸根无缘因非学非无学法。设诸根缘非学非无学。彼根因非学非无学耶。答曰。或根缘非学非无学。因非学非无学。因学因无学。云何根缘非学非无学因非学非无学。答曰。诸根非学非无学。缘非学非无学。云何根缘非学非无学因学。答曰。诸根学缘非学非无学。复次诸根无学因学缘非学非无学。云何根缘非学非无学因无学。答曰。诸根无学缘非学非无学(四三竟)。诸根因见谛断彼根缘见谛断耶。答曰。或根因见谛断缘见谛断。缘思惟断缘无断无缘。云何根因见谛断缘见谛断。答曰。诸根见谛断缘见谛断。云何根因见谛断缘思惟断。答曰。诸根见谛断缘思惟断。复次诸根思惟断。因见谛断缘思惟断。云何根因见谛断缘无断。答曰。诸根见谛断缘无断。云何根因见谛断无缘。答曰。诸根无缘因见谛断法。设诸根缘见谛断。彼根因见谛断耶。答曰。或根缘见谛断因见谛断。因思惟断。因无断。云何根缘见谛断因见谛断。答曰。诸根见谛断缘见谛断。云何根缘见谛断因思惟断。答曰。诸根思惟断缘见谛断。云何根缘见谛断因无断。答曰。诸根无断缘见谛断(见谛断竟)。诸根因思惟断。彼根缘思惟断耶。答曰。或根因思惟断缘思惟断。缘见谛断缘无断无缘。云何根因思惟断缘思惟断。答曰。诸根思惟断缘思惟断。云何根因思惟断缘见谛断。答曰。诸根思惟断缘见谛断。云何根因思惟断缘无断。答曰。诸根思惟断缘无断。云何根因思惟断无缘。答曰。诸根无缘因思惟断法。设诸根缘思惟断彼根因思惟断耶。答曰。或根缘思惟断因思惟断。因见谛断因无断。云何根缘思惟断因思惟断。答曰。诸根思惟断缘思惟断。云何根缘思惟断因见谛断。答曰。诸根见谛断缘思惟断。复次诸根思惟断因见谛断。缘思惟断。云何根缘思惟断因无断。答曰。诸根无断缘思惟断(思惟竟)。诸根因无断彼根缘无断耶。答曰。或根因无断缘无断。缘见谛断缘思惟断。云何根因无断缘无断。答曰。诸根无断缘无断。云何根因无断缘见谛断。答曰。诸根无断缘见谛断。云何根因无断缘思惟断。答曰。诸根无断缘思惟断。设诸根缘无断彼根因无断耶。答曰。或根缘无断因无断。因见谛断因思惟断。云何根缘无断因无断。答曰。诸根无断缘无断。云何根缘无断因见谛断。答曰。诸根见谛断缘无断。云何根缘无断因思惟断。答曰。诸根思惟断缘无断(五三竟)。诸根因见苦断彼根缘见苦断耶。答曰。或根因见苦断缘见苦断。缘见习断缘见尽断。缘见道断。缘思惟断。缘无断无缘。云何根因见苦断缘见苦断。答曰。诸根见苦断缘见苦断。复次诸根见习断因见苦断缘见苦断。云何根因见苦断缘见习断。答曰。诸根见苦断缘见习断。复次诸根见习断因见苦断缘见习断。云何根因见苦断缘见尽断。答曰。诸根见苦断缘见尽断。复次诸根见习断。因见苦断缘见尽断。复次诸根见尽断。因见苦断缘见尽断。云何根因见苦断缘见道断。答曰。诸根见苦断缘见道断。复次诸根见习断。因见苦断缘见道断。复次诸根见道断。因见苦断缘见道断云何根因见苦断缘思惟断。答曰。诸根见苦断缘思惟断。复次诸根见习断。因见苦断缘思惟断。复次诸根思惟断。因见苦断缘思惟断。云何根因见苦断缘无断。答曰。诸根见尽见道断。因见苦断缘无断。云何根因见苦断无缘。答曰。诸根无缘因见苦断。法设诸根缘见苦断。彼根因见苦断耶。答曰。或根缘见苦断。因见苦断。因见习断。因思惟断。因无断。云何根缘见苦断因见苦断。答曰。诸根见苦断缘见苦断。复次诸根见习断。因见苦断缘见苦断。云何根缘见苦断因见习断。答曰。诸根见习断缘见苦断。复次诸根见苦断。因见习断缘见苦断。云何根缘见苦断因思惟断。答曰。诸根思惟断缘见苦断。云何根缘见苦断因无断。答曰。诸根无断缘见苦断(苦谛竟)。因见习断缘见习断。亦如上。诸根因见尽断。彼根缘见尽断耶。答曰。或根因见尽断缘见尽断。缘无断无缘。云何根因见尽断缘见尽断。答曰。诸根见尽断缘见尽断。云何根因见尽断缘无断。答曰。诸根见尽断缘无断。云何根因见尽断无缘。答曰。诸根无缘因见尽断法。设诸根缘见尽断。彼根因见尽断耶。答曰。或根缘见尽断因见尽断。因见苦断。因见习断。因思惟断。因无断。云何根缘见尽断因见尽断。答曰。诸根见尽断缘见尽断。云何根缘见尽断。因见苦断。答曰。诸根见苦断缘见尽断。复次诸根见习断因见苦断缘见尽断。复次诸根见尽断。因见苦断缘见尽断。云何根缘见尽断因见习断。答曰。诸根见习断缘见尽断。复次诸根见苦断因见习断缘见尽断。复次诸根见尽断因见习断缘见尽断。云何根缘见尽断因思惟断。答曰。诸根思惟断缘见尽断。云何根缘见尽断因无断。答曰。诸根无断缘见尽断(尽谛竟)。因见道断缘见道断亦如上(四谛竟)。诸根因见苦断。彼根缘苦法智断耶。答曰。或根因见苦断缘苦法智断。缘苦未知智断。缘习法智断。缘习未知智断。缘尽法智断缘尽未知智断。缘道法智断。缘道未知智断。缘思惟断。缘无断无缘。云何根因见苦断。缘苦法智断。答曰。诸根见苦断缘苦法智断。复次诸根见习断因见苦断缘苦法智断。云何根因见苦断缘苦未知智断。答曰。诸根见苦断缘苦未知智断。复次诸根见习断因见苦断。缘苦未知智断。云何根因见苦断缘习法智断。答曰。诸根见苦断缘习法智断。复次诸根见习断因见苦断。缘习法智断。云何根因见苦断。缘习未知智断。答曰。诸根见苦断缘习未知智断。复次诸根见习断。因见苦断缘习未知智断。云何根因见苦断缘尽法智断。答曰。诸根见苦断缘尽法智断。复次诸根见习断因见苦断缘尽法智断。复次诸根见尽断。因见苦断缘尽法智断。云何根因见苦断缘尽未知智断。答曰。诸根见苦断缘尽未知智断。复次诸根见习断。因见苦断缘尽未知智断。复次诸根见尽断。因见苦断缘尽未知智断。云何根因见苦断缘道法智断。答曰。诸根见苦断缘道法智断。复次诸根见习断因见苦断缘道法智断。复次诸根见道断。因见苦断缘道法智断。云何根因见苦断缘道未知智断。答曰。诸根见苦断缘道未知智断。复次诸根见习断。因见苦断缘道未知智断。复次诸根见习断。因见苦断缘道未知智断。云何根因见苦断缘思惟断。答曰。诸根见苦断缘思惟断。复次诸根见习断因见苦断缘思惟断

复次诸根思惟断。因见苦断缘思惟断

云何根因见苦断缘无断。答曰。诸根见尽见道断。因见苦断缘无断。云何根因见苦断无缘。答曰。诸根无缘因见苦断法。设诸根缘见苦断彼根因苦法智断耶。答曰。或根缘见苦断。因苦法智断。因苦未知智断。因习法智断。因习未知智断。因思惟断因无断。云何根缘见苦断因苦法智断。答曰。诸根因苦法智断。缘见苦断。复次诸根习法智断。因苦法智断缘见苦断云何根缘见苦断因苦未知智断答曰。诸根苦未知智断缘见苦断。复次诸根习未知智断。因苦未知智断缘见苦断。云何根缘见苦断因习法智断。答曰。诸根习法智断缘见苦断

阿毗昙八犍度论卷第二十三阿毗昙八犍度论卷第二十四

        迦旃延子造

        符秦罽宾三藏僧伽提婆共竺佛念译

    根揵度中七缘跋渠之二

复次诸根苦法智断因习法智断缘见苦断。云何根缘见苦断因习未知智断。答曰。诸根习未知智断缘见苦断。复次诸根苦未知智断。因习未知智断缘见苦断。云何根缘见苦断因思惟断。答曰。诸根思惟断缘见苦断。云何根缘见苦断因无断。答曰。诸根无断缘见苦断(四八苦谛竟)。因见习谛断缘习法智断。因见习断缘习未知智断亦如上诸根因见尽断。彼根缘尽法智断耶。答曰。或根因见尽断。缘尽法智断。缘尽未知智断。缘无断无缘。云何根因见尽断缘尽法智断。答曰。诸根见尽断缘尽法智断。云何根因见尽断。缘尽未知智断。答曰。诸根见尽断缘尽未知智断。云何根因见尽断缘无断。答曰。诸根见尽断缘无断。云何根因见尽断无缘。答曰。诸根无缘因见尽断法。设诸根缘见尽断。彼根因尽法智断耶。答曰。或根缘见尽断。因尽法智断因尽未知智断。因苦法智断因苦未知智断。因习法智断。因习未知智断。因思惟断因无断。云何根缘见尽断因尽法智断。答曰。诸根尽法智断缘见尽断。云何根缘见尽断因尽未知智断。答曰。诸根尽未知智断缘见尽断。云何根缘见尽断因苦法智断。答曰。诸根苦法智断缘见尽断。复次诸根习法智断因苦法智断缘见尽断。复次诸根尽法智断。因苦法智断缘见尽断。云何根缘见尽断。因苦未知智断。答曰。诸根苦未知智断缘见尽断。复次诸根习未知智断。因苦未知智断缘见尽断。复次诸根尽未知智断。因苦未知智断缘见尽断。云何根缘见尽断因习法智断。答曰。诸根习法智断缘见尽断。复次诸根苦法智断。因习法智断缘见尽断。复次诸根尽法智断。因习法智断缘见尽断。云何根缘见尽断因习未知智断。答曰。诸根习未知智断缘见尽断。复次诸根苦未知智断。因习未知智断缘见尽断。复次诸根尽未知智断。因习未知智断缘见尽断。云何根缘见尽断因思惟断。答曰。诸根思惟断缘见尽断。云何根缘见尽断因无断。答曰。诸根无断缘见尽断(四谛八尽竟)。因见道断缘道法智断。因见道断缘道未知智断亦如上(四八竟)。诸根因苦法智断。彼根缘苦法智断耶。答曰。或根因苦法智断缘苦法智断。缘苦未知智断。缘习法智断。缘习未知智断。缘尽法智断。缘尽未知智断。缘道法智断。缘道未知智断。缘思惟断。缘无断无缘。云何根因苦法智断。缘苦法智断。答曰。诸根苦法智断缘苦法智断。复次诸根习法智断。因苦法智断缘苦法智断。云何根因苦法智断缘苦未知智断。答曰。诸根苦法智断缘苦未知智断。复次诸根习法智断。因苦法智断缘苦未知智断。云何根因苦法智断缘习法智断。答曰。诸根苦法智断缘习法智断。复次诸根习法智断。因苦法智断缘习法智断。云何根因苦法智断缘习未知智断。答曰。诸根苦法智断缘习未知智断。复次诸根习法智断。因苦法智断缘习未知智断。云何根因。苦法智断缘尽法智断。答曰。诸根苦法智断。缘尽法智断。复次诸根习法智断。因苦法智断缘尽法智断。复次诸根尽法智断。因苦法智断缘尽法智断。云何根因苦法智断缘尽未知智断。答曰。诸根苦法智断缘尽未知智断。复次诸根习法智断。因苦法智断缘尽未知智断。云何根因苦法智断缘道法智断。答曰。诸根苦法智断缘道法智断。复次诸根习法智断因苦法智断缘道法智断。复次诸根道法智断。因苦法智断缘道法智断。云何根因苦法智断缘道未知智断。答曰。诸根苦法智断缘道未知智断。复次诸根习法智断。因苦法智断缘道未知智断。云何根因苦法智断缘思惟断。答曰。诸根苦法智断缘思惟断。复次诸根习法智断。因苦法智断缘思惟断。复次诸根思惟断因苦法智断缘思惟断。云何根因苦法智断缘无断。答曰。诸根尽法智断。道法智断。因苦法智断缘无断。云何根因苦法智断无缘。答曰。诸根无缘因苦法智断。设诸根缘苦法智断彼根因苦法智断耶。答曰。或根缘苦法智断因苦法智断。因习法智断因思惟断因无断。云何根缘苦法智断因苦法智断。答曰。诸根苦法智断缘苦法智断。复次诸根习法智断。因苦法智断缘苦法智断。云何根缘苦法智断因习法智断。答曰。诸根习法智断缘苦法智断。复次诸根苦法智断。因习法智断缘苦法智断。云何根缘苦法智断因思惟断。答曰。诸根思惟断缘苦法智断。云何根缘苦法智断因无断。答曰。诸根无断缘苦法智断。诸根因苦未知智断彼根缘苦未知智断耶。答曰。或根因苦未知智断缘苦未知智断。缘习未知智断。缘尽未知智断。缘道未知智断。缘思惟断缘无断。云何根因苦未知智断缘苦未知智断。答曰。诸根苦未知智断缘苦未知智断。复次诸根习未知智断。因苦未知智断缘苦未知智断。云何根因苦未知智断。缘习未知智断。答曰。诸根苦未知智断。缘习未知智断。复次诸根习未知智断。因苦未知智断缘习未知智断。云何根因苦未知智断。缘尽未知智断。答曰。诸根苦未知智断缘尽未知智断。复次诸根习未知智断因苦未知智断。缘尽未知智断。复次诸根尽未知智断。因苦未知智断。缘尽未知智断。云何根因苦未知智断。缘道未知智断。答曰。诸根苦未知智断。缘道未知智断。复次诸根习未知智断。因苦未知智断缘道未知智断。复次诸根道未知智断。因苦未知智断缘道未知智断。云何根因苦未知智断缘思惟断。答曰。诸根苦未知智断缘思惟断。复次诸根习未知智断。因苦未知智断缘思惟断。复次诸根思惟断。因苦未知智断缘思惟断。云何根因苦未知智断缘无断。答曰。诸根尽未知智断道未知智断。因苦未知智断缘无断。设诸根缘苦未知智断。彼根因苦未知智断耶。答曰。或根缘苦未知智断。因苦未知智断。因苦法智断因习法智断。因习未知智断因思惟断因无断。云何根缘苦未知智断因苦未知智断。答曰。诸根苦未知智断缘苦未知智断。复次诸根习未知智断。因苦未知智断缘苦未知智断。云何根缘苦未知智断因苦法智断。答曰。诸根苦法智断缘苦未知智断。复次诸根习法智断。因苦法智断缘苦未知智断。云何根缘苦未知智断因习法智断。答曰。诸根习法智断缘苦未知智断。复次诸根苦法智断因习法智断。缘苦未知智断。云何根缘苦未知智断因习未知智断。答曰。诸根习未知智断缘苦未知智断。复次诸根苦未知智断。因习未知智断缘苦未知智断。云何根缘苦未知智断因思惟断。答曰。诸根思惟断缘苦未知智断。云何根缘苦未知智断因无断。答曰。诸根无断缘苦未知智断(八共八苦智竟)。因习法智断缘习法智断。因习未知智断缘习未知智断。亦如上。诸根因尽法智断。彼根缘尽法智断耶。答曰。或根因尽法智断缘尽法智断缘无断无缘。云何根因尽法智断缘尽法智断。答曰。诸根尽法智断缘尽法智断。云何根因尽法智断缘无断。答曰。诸根尽法智断缘无断。云何根因尽法智断无缘。答曰。诸根无缘因尽法智断法。设诸根缘尽法智断彼根因尽法智断耶。答曰。或根缘尽法智断。因尽法智断。因苦法智断。因习法智断。因思惟断因无断。云何根缘尽法智断因尽法智断。答曰。诸根尽法智断缘尽法智断。云何根缘尽法智断因苦法智断。答曰。诸根苦法智断。缘尽法智断。复次诸根习法智断。因苦法智断缘尽法智断。复次诸根尽法智断因苦法智断缘尽法智断。云何诸根缘尽法智断因习法智断。答曰。诸根习法智断缘尽法智断。复次诸根苦法智断。因习法智断缘尽法智断。复次诸根尽法智断。因习法智断。缘尽法智断。云何根缘尽法智断因思惟断。答曰。诸根思惟断缘尽法智断。云何根缘尽法智断因无断。答曰。诸根无断缘尽法智断。诸根因尽未知智断。彼根缘尽未知智断耶。答曰。或根因尽未知智断。缘尽未知智断缘无断。云何根因尽未知智断缘尽未知智断。答曰。诸根尽未知智断缘尽未知智断。云何根因尽未知智断缘无断。答曰。诸根尽未知智断缘无断。设诸根缘尽未知智断。彼根因尽未知智断耶。答曰。或根缘尽未知智断。因尽未知智断。因苦法智断。因苦未知智断。因习法智断。因习未知智断。因思惟断因无断。云何根缘尽未知智断因尽未知智断。答曰。诸根尽未知智断缘尽未知智断。云何根缘尽未知智断因苦法智断。答曰诸根苦法智断缘尽未知智断。复次诸根习法智断因苦法智断缘尽未知智断。云何根缘尽未知智断。因苦未知智断。答曰。诸根苦未知智断缘尽未知智断。复次诸根习未知智断。因苦未知智断缘尽未知智断。复次诸根尽未知智断。因苦未知智断缘尽未知智断。云何根缘尽未知智断因习法智断。答曰。诸根习法智断缘尽未知智断。复次诸根苦法智断。因习法智断缘尽未知智断。云何根缘尽未知智断。因习未知智断。答曰。诸根习未知智断缘尽未知智断。复次诸根苦未知智断。因习未知智断缘尽未知智断。复次诸根尽未知智断。因习未知智断缘尽未知智断。云何根缘尽未知智断因思惟断。答曰。诸根思惟断缘尽未知智断。云何根缘尽未知智断因无断。答曰。诸根无断缘尽未知智断(八共八尽智竟)。因道法智断缘道法智断。因道未知智断缘道未知智断。亦如上(八共八竟)。诸根因苦法智断。彼根缘见苦断耶。答曰。或根因苦法智断。缘见苦断缘见习断缘见尽断缘见道断缘思惟断缘无断无缘。云何根因苦法智断缘见苦断。答曰。诸根苦法智断缘见苦断。复次诸根习法智断因苦法智断缘见苦断。云何根因苦法智断缘见习断。答曰。诸根苦法智断缘见习断。复次诸根习法智断因苦法智断缘见习断。云何根因苦法智断缘见尽断。答曰。诸根苦法智断缘见尽断。复次诸根习法智断因苦法智断缘见尽断。复次诸根尽法智断因苦法智断缘见尽断。云何根因苦法智断缘见道断。答曰。诸根苦法智断缘见道断。复次诸根习法智断因苦法智断缘见道断。复次诸根道法智断因苦法智断缘见道断。云何根因苦法智断缘思惟断。答曰。诸根苦法智断缘思惟断。复次诸根习法智断因苦法智断缘思惟断。复次诸根思惟断因苦法智断缘思惟断。云何根因苦法智断缘无断。答曰。诸根尽法智道法智断因苦法智断缘无断。云何根因苦法智断无缘。答曰。诸根无缘因苦法智断设诸根缘苦法智断。彼根因见苦断耶。答曰。或根缘苦法智断。因见苦断因见习断因思惟断因无断。云何根缘苦法智断因见苦断。答曰。诸根见苦断缘苦法智断。复次诸根见习断因见苦断缘苦法智断。云何根缘苦法智断因见习断。答曰。诸根见习断缘苦法智断。复次诸根见苦断因见习断缘苦法智断。云何诸根缘苦法智断因思惟断。答曰。诸根思惟断缘苦法智断。云何根缘苦法智断因无断。答曰。诸根无断缘苦法智断。诸根因苦未知智断彼根缘见苦断耶。答曰。或根因苦未知智断。缘见苦断。缘见习断。缘见尽断。缘见道断。缘思惟断缘无断。云何根因苦未知智断缘见苦断。答曰。诸根苦未知智断缘见苦断。复次诸根习未知智断。因苦未知智断缘见苦断。云何根因苦未知智断缘见习断。答曰。诸根苦未知智断缘见习断。复次诸根习未知智断。因苦未知智断缘见习断。云何根因苦未知智断缘见尽断。答曰。诸根苦未知智断缘见尽断。复次诸根习未知智断。因苦未知智断缘见尽断。复次诸根尽未知智断。因苦未知智断缘见尽断。云何根因苦未知智断缘见道断。答曰。诸根苦未知智断缘见道断。复次诸根习未知智断。因苦未知智断缘见道断。复次诸根道未知智断。因苦未知智断缘见道断。云何根因苦未知智断缘思惟断。答曰。诸根苦未知智断缘思惟断。复次诸根习未知智断因苦未知智断缘思惟断。复次诸根思惟断因苦未知智断缘思惟断。云何根因苦未知智断缘无断。答曰。诸根尽未知智道未知智断。因苦未知智断缘无断。设诸根缘苦未知智断。彼根因见苦断耶。答曰。或根缘苦未知智断。因见苦断因见习断。因思惟断因无断。云何根缘苦未知智断因见苦断。答曰。诸根见苦断缘苦未知智断。复次诸根见习断因见苦断缘苦未知智断。云何根缘苦未知智断因见习断。答曰。诸根见习断缘苦未知智断。复次诸根见苦断因见习断缘苦未知智断。云何根缘苦未知智断因思惟断。答曰。诸根思惟断缘苦未知智断。云何根缘苦未知智断因无断。答曰。诸根无断缘苦未知智断(八四苦智竟)。因习法智断缘见习断。因习未知智断缘见习断。亦如上。诸根因尽法智断。彼根缘见尽断耶。答曰。或根因尽法智断缘见尽断缘无断无缘。云何根因尽法智断缘见尽断。答曰。诸根尽法智断缘见尽断。云何根因尽法智断缘无断。答曰。诸根尽法智断缘无断。云何根因尽法智断无缘。答曰。诸根无缘因尽法智断。设诸根缘尽法智断彼根因见尽断耶。答曰。或根缘尽法智断。因见尽断。因见苦断。因见习断。因思惟断因无断。云何根缘尽法智断因见尽断。答曰。诸根见尽断缘尽法智断。云何根缘尽法智断因见苦断。答曰。诸根见苦断缘尽法智断。复次诸根见习断因见苦断缘尽法智断。复次诸根见苦断缘尽法智断。云何根缘尽法智断因见习断。答曰。诸根见习断缘尽法智断。复次诸根见苦断因见习断缘尽法智断。复次诸根见尽断因见习断缘尽法智断。云何根缘尽法智断因思惟断。答曰。诸根思惟断缘尽法智断。云何根缘尽法智断因无断。答曰。诸根无断缘尽法智断。诸根因尽未知智断。彼根缘见尽断耶。答曰。或根因尽未知智断缘见尽断缘无断。云何根因尽未知智断缘见尽断。答曰。诸根因尽未知智断。缘见尽断。云何根因尽未知智断缘无断。答曰。诸根尽未知智断缘无断。设诸根缘尽未知智断。彼根因见尽断耶。答曰。或根缘尽未知智断。因见尽断。因见苦断。因见习断。因思惟断因无断。云何根缘尽未知智断因见尽断。答曰。诸根见尽断缘尽未知智断。云何根缘尽未知智断因见苦断。答曰。诸根见苦断缘尽未知智断。复次诸根见习断因见苦断缘尽未知智断。复次诸根见尽断。因见苦断缘尽未知智断。云何根缘尽未知智断因见习断。答曰。诸根见习断缘尽未知智断。复次诸根见苦断。因见习断缘尽未知智断。复次诸根见尽断因见习断缘尽未知智断。云何根缘尽未知智断因思惟断。答曰。诸根思惟断缘尽未知智断。云何根缘尽未知智断因无断。答曰。诸根无断缘尽未知智断。因道法智断缘见道断。因道未知智断缘见道断。亦如上

阿毗昙根犍度缘跋渠第三十三竟

根犍度第六竟斯经序曰。其人忘因缘一品故阙文焉。近有罽宾沙门昙摩卑。谙之来经密川僧伽谛婆译出此品。八犍度文具也。而卑云八犍度是体耳。别有六足可百万言。卑诵二足今无译可出慨恨良深。秦建元十五年正月十九日于扬州正官佛图记

阿毗昙八犍度论卷第二十四阿毗昙八犍度论卷第二十五

        迦旃延子造

        符秦罽宾三藏僧伽提婆共竺佛念译

    定犍度第七(尽三十八品)

  过去得　是谓缘　解脱　阿那含　一行观在后

    阿毗昙过去得跋渠第一之一

若得过去法彼得过去。设得过去彼得过去法。若未来现在。善不善无记。欲界系色界系无色界系。学无学非学非无学。见谛断思惟断。若得不断法。彼得不断。设得不断彼得不断法。诸法善无色生彼善心俱耶。设善心俱彼法善。无色不善无记。欲界系色界系无色界系。学无学非学非无学。见谛断思惟断不断。法无色生彼不断心俱耶。设不断心俱彼法不断无色耶。一切初禅五种耶。一切第二禅四种。一切第三禅五种。一切第四禅四种耶。味相应初禅。入当言味起当言味耶。味相应乃至有想无想。入当言味起当言味耶。诸味相应初禅。彼一切隐没无记耶。设隐没无记。彼一切味相应初禅耶。诸味相应乃至有想无想。彼一切隐没无记耶。设隐没无记。彼一切味相应乃至有想无想。颇不入初禅入第二禅耶。颇乃至不入不用定。入有想无想耶。颇不入初禅生初禅耶。颇乃至不入有想无想。生有想无想耶。若得初禅非第二。彼命终生何所。若乃至得不用定。非有想无想。彼命终生何所。云何意所念入慈。云何意所念入悲喜护。慈何系结灭。悲喜护何系结灭净。初禅何系结灭净。乃至有想无想何系结灭。初解脱乃至第八解脱。初除入乃至第八除入。初一切入乃至第十一切入。法智乃至道智。空无愿无相何系结灭。慈报何所受报。悲喜护报何所受报净。初禅报何所受报净。乃至有想无想报何所受报。初解脱乃至第八解脱。初除入乃至第八除入。初一切入乃至第十一切入。知他人心智等智报何所受报。此章义愿具演说

若得过去法彼得过去耶。答曰。或彼过去或未来或现在。设得过去彼得过去法耶。答曰。或彼过去或未来或现在或无为(过去竟)。若得未来法彼得未来耶。答曰。或彼过去或未来或现在。设得未来彼得未来法耶。答曰。或彼过去或未来或现在或无为(未来竟)。若得现在法彼得现在耶。答曰。或彼过去或未来或现在。设得现在彼得现在法耶。答曰。或彼过去或未来或现在或无为(现在竟)。若得善法彼得善耶。答曰。如是。设得善彼得善法耶。答曰。如是。若得不善法彼得不善耶。答曰。如是。设得不善彼得不善法耶。答曰。如是。若得无记法彼得无记耶。答曰。如是。设得无记彼得无记法耶。答曰。如是。若得欲界系法。彼得欲界系耶。答曰。如是。设得欲界系彼得欲界系法耶。答曰。如是。若得色界系法彼得色界系耶。答曰。如是。设得色界系彼得色界系法耶。答曰。或彼色界系。或不系。若得无色界系法。彼得无色界系耶。答曰。如是。设得无色界系。彼得无色界系法耶。答曰。或彼无色界系或不系。若得学法彼得学耶。答曰。如是。设得学彼得学法耶。答曰。或彼学或非学非无学。若得无学法彼得无学耶。答曰。如是。设得无学彼得无学法耶。答曰。或彼无学或非学非无学。若得非学非无学法。彼得非学非无学耶。答曰。或彼学或无学或非学非无学。设得非学非无学。彼得非学非无学法耶。答曰。如是。若得见谛断法。彼得见谛断耶。答曰。如是。设得见谛断彼得见谛断法耶答曰。如是。若得思惟断法。彼得思惟断耶。答曰。如是。设得思惟断。彼得思惟断法耶。答曰。或彼思惟断或不断。若得不断法彼得不断耶。答曰。或彼思惟断或不断。设得不断彼得不断法耶。答曰。如是(得竟)。诸法善无色生彼善心俱耶。答曰。或法善无色生。善心俱。不善心俱。无记心俱。云何法善无色生善心俱。答曰。诸法彼心相应彼俱有善。是谓法善无色生善心俱。云何法善无色生不善心俱。答曰。如不善心若退若生善法得生。是谓法善无色生不善心俱。云何法善无色生。彼无记心俱耶。答曰。如无记心。若退若生善法得生。是谓法善无色生无记心俱。设诸法善心俱生。彼法善无色耶。答曰。或法善心俱生善无色无记无色。云何法善心俱生善无色。答曰。诸法彼心相应。彼俱有善。是谓法善心俱生善无色。云何法善心俱生无记无色。答曰。如善心胜进无记法得生。如住善心无记根。长益四大增益软美饱。彼法诸得生老无常。是谓法善心俱生无记无色(善竟)。诸法不善无色生。彼不善心俱耶。答曰。或法不善无色生。不善心俱无记心俱。云何法不善无色生不善心俱。答曰。诸法彼心相应。彼俱有不善。是谓法不善无色生不善心俱。云何法不善无色生无记心俱。答曰。如无记心若退若生不善法得生。是谓法不善无色生无记心俱。设诸法不善心俱生。彼法不善无色耶。答曰。或法不善心俱生。不善无色善无色无记无色。云何法不善心俱生不善无色。答曰。诸法彼心相应。彼俱有不善。是谓法不善心俱生不善无色。云何法不善心俱生善无色。答曰。如不善心若退若生善法得生。是谓法不善心俱生善无色。云何法不善心俱生无记无色。答曰。如不善心若退若生无记法得生。如住不善心无记根。长益四大增益软美饱。彼法诸得生老无常。是谓法不善心俱生无记无色(不善竟)。诸法无记无色生。彼无记心俱耶。答曰。或法无记无色生。无记心俱善心俱不善心俱。云何法无记无色生无记心俱。答曰。诸法彼心相应彼俱有无记。是谓法无记无色生无记心俱。云何法无记无色生善心俱。答曰。如善心胜进无记法得生。如住善心无记根。长益四大增益软美饱。彼法诸得生老无常。是谓法无记无色生善心俱。云何法无记无色生不善心俱。答曰。如不善心若退若生无记法得生。如住不善心无记根。长益四大增益软美饱。彼法诸得生老无常。是谓法无记无色生不善心俱。设诸法无记心俱生彼法无记无色耶。答曰。或法无记心俱生。无记无色善无色不善无色。云何法无记心俱生无记无色。答曰。诸法彼心相应彼俱有无记。是谓法无记心俱生无记无色。云何法无记心俱生善无色。答曰。如无记心若退若生善法得生。是谓法无记心俱生善无色。云何法无记心俱生不善无色。答曰。如无记心若退若生不善法得生。是谓法无记心俱生不善无色(无记竟)。诸法欲界系无色生。彼欲界系心俱耶。答曰。或法欲界系无色生。欲界系心俱。色界系心俱。无色界系心俱。不系心俱。云何法欲界系无色生。欲界系心俱。答曰。诸法彼心相应。彼俱有欲界系。是谓法欲界系无色生。欲界系心俱。云何法欲界系无色生。色界系心俱。答曰。如色界系心。若生若胜进欲界系法得生。如住色界系心欲界系根。长益四大增益软美饱。此法诸得生老无常。是谓法欲界系无色生。色界系心俱。云何法欲界系无色生。无色界系心俱。答曰。如无色界系心住欲界系根。长益四大增益软美饱。此法诸得生老无常。是谓法欲界系无色生。无色界系心俱。云何法欲界系无色生不系心俱。答曰。如不系心胜进欲界系法得生。如不系心住欲界系根。长益四大增益软美饱。此法诸得生老无常。是谓法欲界系无色生不系心俱。设诸法欲界系心俱生彼法欲界系无色耶。答曰。或法欲界系心俱生。欲界系无色。色界系无色。无色界系无色不系无色。云何法欲界系心俱生欲界系无色。答曰。诸法彼心相应。彼俱有欲界系。是谓法欲界系心俱生欲界系无色。云何法欲界系心俱生色界系无色。答曰。如欲界系心。若退若生色界系法得生。是谓法欲界系心俱生色界系无色。云何法欲界系心俱生。无色界系无色。答曰。如欲界系心。若退若生无色界系法得生。是谓法欲界系心俱生。无色界系无色。云何法欲界系心俱生不系无色。答曰。如欲界系心退不系法得生。是谓法欲界系心俱生不系无色(欲界竟)。诸法色界系无色生。彼色界系心俱耶。答曰。或法色界系无色生。色界系心俱。欲界系心俱。无色界系心俱。不系心俱。云何法色界系无色生。色界系心俱。答曰。诸法彼心相应。彼俱有色界系。是谓法色界系无色生色界系心俱。云何法色界系无色生。欲界系心俱。答曰。如欲界系心。若退若生色界系法得生。是谓法色界系无色生。欲界系心俱。云何法色界系无色生。无色界系心俱。答曰。如无色界系心住色界系根。长益四大增益软美饱。此法诸得生老无常。是谓法色界系无色生。无色界系心俱。云何法色界系无色生不系心俱。答曰。如不系心胜进色界系法得生。如不系心住色界系根。长益四大增益软美饱。此法诸得生老无常。是谓法色界系无色生不系心俱。设诸法色界系心俱生。彼法色界系无色耶。答曰。或法色界系心俱生。色界系无色欲界系无色无色界系无色不系无色。云何法色界系心俱生。色界系无色。答曰。诸法彼心相应。彼俱有色界系。是谓法色界系心俱生色界系无色。云何法色界系心俱生欲界系无色。答曰。如色界系心。若胜进欲界系法得生。如色界系心住欲界系根。长益四大增益软美饱。此法诸得生老无常。是谓法色界系心俱生。欲界系无色。云何法色界系心俱生无色界系无色。答曰。如色界系心若退若生。无色界系法得生。是谓法色界系心俱生无色界系无色。云何法色界系心俱生不系无色。答曰。如色界系心。若退若胜进不系法得生。是谓法色界系心俱生不系无色(色界竟)。诸法无色界系无色生彼无色界系心俱耶。答曰。或法无色界系无色生。无色界系心俱。欲界系心俱。色界系心俱。不系心俱。云何法无色界系无色生。无色界系心俱。答曰。诸法彼心相应彼俱有无色界系。是谓法无色界系无色生无色界系心俱。云何法无色界系无色生。欲界系心俱。答曰。如欲界系心若退若生。无色界系法得生。是谓法无色界系。无色生欲界系心俱。云何法无色界系无色生。色界系心俱。答曰。如色界系心若退若生。无色界系法得生。是谓法无色界系。无色生色界系心俱。云何法无色界系。无色生不系心俱。答曰。如不系心胜进。无色界系法得生。是谓法无色界系。无色生不系心俱。设诸法无色界系心俱生。彼法无色界系无色耶。答曰。或法无色界系心俱生。无色界系无色。欲界系无色。色界系无色。不系无色。云何法无色界系心俱生。无色界系无色。答曰。诸法彼心相应。彼俱有无色界系。是谓法无色界系心俱生。无色界系无色。云何法无色界系心俱生。欲界系无色。答曰。如无色界系心。住欲界系根。长益四大增益软美饱。此法诸得生老无常。是谓法无色界系心俱生。欲界系无色。云何法无色界系心俱生。色界系无色。答曰。如无色界系心。住色界系根。长益四大增益软美饱。此法诸得生老无常。是谓法无色界系心俱生。色界系无色。云何法无色界系心俱生。不系无色。答曰。如无色界系心。若退胜进不系法得生。是谓法无色界系心俱生不系无色(无色竟)。诸法学无色生。彼学心俱耶。答曰。或法学无色生。学心俱。非学非无学心俱。云何法学无色生学心俱。答曰。诸法彼心相应彼俱有学。是谓法学无色生学心俱。云何法学无色生。非学非无学心俱。答曰。如非学非无学心。若退若胜进学法得生。是谓法学无色生。非学非无学心俱。设诸法学心俱生。彼法学无色耶。答曰。或法学心俱生。学无色。非学非无学无色。云何法学心俱生学无色。答曰。诸法彼心相应彼俱有学。是谓法学心俱生学无色。云何法学心俱生。非学非无学无色。答曰。如学心胜进非学非无学法得生。如学心住非学非无学根。长益四大增益软美饱(增益多竟)。彼诸法得生老无常。是谓法学心俱生。非学非无学无色(学竟)。诸法无学无色生彼无学心俱耶。答曰。或法无学无色生。无学心俱。非学非无学心俱。云何法无学无色生。无学心俱。答曰。诸法彼心相应彼俱有无学。是谓法无学无色生。无学心俱。云何法无学无色生。非学非无学心俱。答曰。如非学非无学心若退若胜进无学法得生。是谓法无学无色生。非学非无学心俱。设诸法无学心俱生。彼法无学无色耶。答曰。或法无学心俱生。无学无色非学非无学无色。云何法无学心俱生。无学无色。答曰。诸法彼心相应彼俱有无学。是谓法无学心俱生无学无色。云何法无学心俱生非学非无学无色。答曰。如无学心胜进。非学非无学法得生。如无学心住非学非无学根。长益四大增益软美饱。此法诸得生老无常。是谓法无学心俱生。非学非无学无色(无学竟)。诸法非学非无学无色生。彼非学非无学心俱耶。答曰。或法非学非无学无色生。非学非无学心俱(有漏)。学心俱。无学心俱。云何法非学非无学无色生。非学非无学心俱。答曰。诸法彼心相应。彼俱有非学非无学。是谓法非学非无学无色生。非学非无学心俱。云何法非学非无学无色生学心俱。答曰。如学心胜进。非学非无学法得生。如学心住非学非无学根(五色男女命苦忧也)。长益四大增益软美饱。此法诸得生老无常。是谓法非学非无学无色生学心俱。云何法非学非无学无色生无学心俱。答曰。如无学心胜进。非学非无学法得生。如无学心住非学非无学根。长益四大增益软美饱。彼法诸得生老无常。是谓法非学非无学无色生无学心俱。设诸法非学非无学心俱生。彼法非学非无学无色耶。答曰。或法非学非无学心俱生。非学非无学无色。学无色。无学无色。云何法非学非无学心俱生。非学非无学无色耶。答曰。诸法彼心相应。彼俱有非学非无学。是谓法非学非无学心俱生。非学非无学无色也。云何法非学非无学心俱生学无色。答曰。如非学非无学心。若退若胜进学法得生。是谓法非学非无学心俱生学无色。云何法非学非无学心俱生无学无色。答曰。如非学非无学心。若退若胜进无学法得生。是谓法非学非无学心俱生无学无色(非学无学竟)。诸法见谛断无色生。彼见谛断心俱生耶。答曰。或法见谛断无色生。见谛断心俱。思惟断心俱。云何法见谛断无色生。见谛断心俱。答曰。诸法彼心相应彼俱有见谛断。是谓法见谛断无色生。见谛断心俱。云何法见谛断无色生思惟断心俱。答曰。如思惟断心若退若生。见谛断法得生。是谓法见谛断无色生。思惟断心俱。设诸法见谛断心俱生。彼法见谛断无色耶。答曰。或法见谛断心俱生。见谛断无色思惟断无色。云何法见谛断心俱生。见谛断无色。答曰。诸法彼心相应彼俱有见谛断。是谓法见谛断心俱生。见谛断无色。云何法见谛断心俱生思惟断无色。答曰。如见谛断心若退若生。思惟断法得生如见谛断心住思惟断根。长益四大增益软美饱。彼法诸得生老无常。是谓法见谛断心俱生。思惟断无色(见谛竟)

诸法思惟断无色生。彼思惟断心俱耶

阿毗昙八犍度论卷第二十五阿毗昙八犍度论卷第二十六

        迦旃延子造

        符秦罽宾三藏僧伽提婆共竺佛念译

    定犍度中过去得跋渠第一之二

答曰。或法思惟断无色生。思惟断心俱。见谛断心俱。不断心俱。云何法思惟断无色生思惟断心俱。答曰。诸法彼心相应。彼俱有思惟断。是谓法思惟断无色生。思惟断心俱。云何法思惟断无色生。见谛断心俱。答曰。如见谛断心若退若生思惟断法得生。如见谛断心住思惟断根。长益四大增益软美饱。彼法诸得生老无常。是谓法思惟断无色生。见谛断心俱。云何法思惟断无色生不断心俱。答曰。如无断心胜进思惟断法得生。如无断心住思惟断根。长益四大增益软美饱。彼法诸得生老无常。是谓法思惟断无色生不断心俱。设诸法思惟断心俱生。彼法思惟断无色耶。答曰。或法思惟断心俱生。思惟断无色。见谛断无色。不断无色。云何法思惟断心俱生。思惟断无色。答曰。诸法彼心相应。彼俱有思惟断。是谓法思惟断心俱生思惟断无色。云何法思惟断心俱生见谛断无色。答曰。如思惟断心若退若生。见谛断法得生。是谓法思。惟断心俱生。见谛断无色。云何法思惟断心俱生不断无色。答曰。如思惟断心若退若胜进。不断法得生。是谓法思惟断心俱生不断无色(思惟竟)。诸法不断无色生彼不断心俱。答曰。或法不断无色生。不断心俱。思惟断心俱。云何法不断无色生不断心俱。答曰。诸法彼心相应。彼俱有不断。是谓法不断无色生不断心俱。云何法不断无色生。思惟断心俱。答曰。如思惟断心若退若胜进。不断法得生。是谓法不断无色生。思惟断心俱。设诸法不断心俱生彼法不断无色耶。答曰。或法不断心俱生。不断无色思惟断无色。云何法不断心俱生不断无色。答曰。诸法彼心相应彼俱有不断。是谓法不断心俱生不断无色。云何法不断心俱生。思惟断无色。答曰。如不断心胜进思惟断法得生。如不断心住思惟断根。长益四大增益软美饱。彼法诸得生老无常。是谓法不断心俱生。思惟断无色(不断竟)。一切初禅五种耶。答曰。不染污五种染污非五种。无何等。答曰。远离喜乐也。一切第二禅四种耶。答曰。不染污四种染污非四种。无何等。答曰。内信也。一切第三禅五种耶。答曰。不染污五种染污非五种。无何等。答曰。念智也。一切第四禅四种耶。答曰。不染污四种染污非四种。无何等。答曰。护念净也。味相应初禅。入当言味耶。起当言味耶。答曰。诸味彼入也。味已则起味相应。乃至有想无想入当言味耶。起当言味耶。答曰。诸味彼入也。味已则起诸味相应。初禅彼一切隐没无记。答曰。如是。诸味相应初禅彼一切隐没无记也。颇隐没无记彼非味相应初禅耶。答曰。有除爱诸余垢现在前诸味相应。乃至有想无想彼一切隐没无记耶。答曰。如是。诸味相应乃至有想无想彼一切隐没无记。颇隐没无记彼非味相应。乃至有想无想耶。答曰。有除爱诸余垢现在前。颇不入初禅入第二禅。答曰。入颇不入乃至不用定入有想无想耶。答曰。入。颇不入初禅生初禅耶。答曰。生。颇不入乃至有想无想生有想无想耶。答曰。生。若得初禅非第二。彼命终生何所。答曰。或梵天。或光音。或遍净。或果实。或空处。或识处。或不用处。或有想无想。或无处所。若得乃至不用处非有想无想。彼命终生何所。答曰。或不用处。或有想无想。或无处所。云何意所念入慈。答曰。乐众生。云何意所念入悲。答曰。苦众生。云何意所念入喜。答曰。悦众生。云何意所念入护。答曰。护众生耳。慈何系结灭。答曰。无处所。悲喜护何系结灭。答曰。无处所。净初禅何系结灭。答曰。无处所。净乃至有想无想何系结灭。答曰。无处所。初第二第三解脱何系结灭。答曰。无处所。空处解脱何系结灭。答曰。或空处系。或识处系。或不用处系。或有想无想处系。或无处所。识处解脱何系结灭。答曰。或识处系或不用处系。或有想无想处系。或无处所。不用处解脱何系结灭。答曰。或不用处系。或有想无想系或无处所有想无想解脱灭尽解脱何系结灭。答曰。无处所。初除入何系结灭。答曰。无处所乃至第八除入何系结灭。答曰。无处所。初一切入何系结灭。答曰。无处所。乃至第十一切入何系结灭。答曰。无处所。法智何系结灭。答曰。或欲界系或色无色界系。或无处所。未知智何系结灭。答曰。或色无色界系或无处所。知他人心智何系结灭。答曰。无处所。等智苦智习尽道智空无愿无相何系结灭。答曰。或欲界系或色无色界系。或无处所。慈报何所受报。答曰。或梵天或光音或遍净。或果实天或无处所。悲护亦如是。喜报何所受报。答曰。梵天光音或无处所。净初禅报何所受报。答曰。梵天上或无处所。乃至有想无想报何所受报。答曰。有想无想或无处所。初第二解脱。初四除入报何所受报。答曰。梵天光音或无处所。净解脱后四除入。八一切入报何所受报。答曰。果实或无处所。空处解脱报何所受报。答曰。空处或无处所。空处一切入亦如是。识处解脱报何所受报。答曰。识处或无处所。识处一切入亦如是。不用处解脱报何所受报。答曰。不用处或无处所。有想无想解脱报何所受报。答曰。有想无想或无处所。灭尽解脱何报所受报。答曰。有想无想或无处所。知他人心智报何所受报。答曰。或梵天或光音或遍净。或果实或无处所。等智报何所受报。答曰。或欲界或色界无色界。或无处所

阿毗昙过去得跋渠第三十四竟(梵本四百七十九首卢秦六千四百四十三言)

    阿毗昙定犍度中缘跋渠第二

八三昧四禅四无色定。味相应净无漏。颇成就味相应初禅。非净非无漏耶。成就净非味相应非无漏耶。成就无漏非味相应非净耶(只竟)。味相应成就净非无漏耶。味相应成就无漏非净耶。成就净无漏。非味相应耶(只竟)。味相应成就净无漏。不成就得弃退亦如是。若修世俗初禅。彼修无漏初禅耶。设修无漏初禅。彼修世俗初禅。若修世俗乃至不用处。彼修无漏不用处。设修无漏不用处。彼修世俗不用处。若最初入无漏初禅。得是时诸余未来无漏得心心法。彼一切法当言有觉有观。若最初无漏入第二禅。得是时诸余未来无漏得心心法。彼一切法当言喜根相应耶。若最初无漏入第三禅。得是时诸余未来无漏得心心法。彼一切法当言乐根相应。若最初无漏入第四禅。得是时诸余未来无漏得心心法。彼一切法当言护根相应。若最初无漏入空处。得是时诸余未来无漏得心心法。彼一切法当言摄空处。若最初无漏入识处。得是时诸余未来无漏得心心法。彼一切法当言摄识处。若最初无漏入不用处。得是时诸余未来无漏得心心法。彼一切法当言摄不用处耶。味相应初禅彼味相应初禅几缘缘。净几缘缘。无漏几缘缘。味相应上几缘缘。净无漏上几缘缘(味竟)。净初禅彼净初禅几缘缘。无漏几缘缘。味相应上几缘缘。净无漏上几缘缘。自地味相应几缘缘(净竟)。无漏初禅彼无漏初禅几缘缘。味相应上几缘缘。净无漏上几缘缘。自地净几缘缘。乃至不用处亦如是。味相应有想无想彼味相应有想无想几缘缘。净几缘缘。味相应下几缘。缘净无漏下几缘缘(味竟)。净有想无想彼净有想无想几缘缘。味相应下几缘缘。净无漏下几缘缘。自地味相应几缘缘。此章义愿具演说

八三昧四禅四无色定。味相应净无漏。颇味相应成就初禅。非净非无漏耶。答曰。有欲爱未尽也。净成就非味相应非无漏耶。答曰。有凡夫人生欲界若梵天上。梵天上爱尽也。成就无漏非味相应非净耶。答曰。有无垢人上生梵天也。味相应成就净非无漏耶。答曰。有凡夫人生欲界欲爱尽。梵天上爱未尽。若生梵天上于彼爱未尽。味相应成就无漏非净耶。答曰。无也。成就净无漏非味相应。答曰。有无垢人生欲界若梵天上。梵天上爱尽味相应成就净无漏。答曰。有无垢人生欲界。欲爱尽梵天上爱未尽。若生梵天上梵天上爱未尽(成就竟)。颇味相应不成就初禅。非不净非不无漏。答曰。有无垢人生欲界若梵天上。梵天上爱尽不成就净。非不味相应非不无漏。答曰。无不成就无漏。非不味相应非不净。答曰有凡夫人生欲界欲爱尽。梵天上爱未尽。若生梵天上于彼爱未尽。味相应不成就净非不无漏。答曰。有无垢人上生梵天上。味相应不成就无漏非不净。答曰。有凡夫人生欲界若梵天上。梵天上爱尽不成就净无漏非不味相应。答曰。有欲界爱未尽。不成就味相应净无漏。答曰。有凡夫人上生梵天上(不成竟)。颇味相应得初禅。非净非无漏耶。答曰。得梵天上无爱退也。得净非味相应非无漏耶。答曰。得凡夫人逮欲爱尽也。得无漏非味相应非净耶。答曰。得依初禅越次取证。当逮阿罗汉果得味相应净非无漏耶。答曰。得上地没生梵天也。乃至得净无漏非味相应耶。答曰。得无垢人逮欲爱尽也。余得耶。答曰。不得(得竟)。颇味相应弃初禅非净非无漏耶。答曰。弃逮梵天上爱尽也。弃净非味相应。非无漏。答曰。弃凡夫人于无欲爱退欲界。若梵天上没生上地也。乃至弃净无漏非味相应耶。答曰。弃无垢人于无欲爱退也。余弃耶。答曰。不弃(弃竟)。颇味相应初禅退。非净非无漏。答曰。不退也。净退非味相应非无漏。答曰。退凡夫人于无欲爱退也。乃至净无漏退非味相应。答曰。退无垢人于无欲爱退也。余退也。答曰。不退也(退竟)。若修生俗初禅。彼修无漏初禅耶。答曰。或世俗非无漏云何世俗非无漏。答曰。本得世俗初禅现在前。若本不得世俗初禅现在前。不得是时修无漏初禅。若本不得世俗智现在前彼非初禅。得是时修世俗初禅非无漏。是谓世俗非无漏。云何无漏非世俗。答曰。本得无漏初禅现在前。若本不得无漏初禅现在前。不得是时修世俗初禅。若本不得世俗智现在前。彼非初禅得是时修无漏初禅非世俗。若本不得无漏智现在前彼非初禅。得是时修无漏初禅非世俗。是谓无漏非世俗。云何世俗无漏。答曰。本不得世俗初禅现在前。得是时修无漏初禅。若本不得无漏初禅现在前。得是时修世俗初禅。若本不得世俗智现在前。彼非初禅得是时修世俗无漏初禅。若本不得无漏智现在前。彼非初禅得是时修世俗无漏初禅。是谓世俗无漏。云何非世俗非无漏。答曰。本得世俗智现在前彼非初禅若本不得世俗智现在前。不得是时修世俗无漏初禅。若本得无漏智现在。前彼非初禅。若本不得无漏智现在前。不得是时修世俗无漏初禅。一切染污心无记心。入无想定灭尽定。非修世俗初禅非无漏。是谓非世俗初禅非无漏。第二第三禅亦如是。若修世俗第四禅。彼修无漏第四禅耶。答曰。或世俗非无漏。云何世俗非无漏。答曰。本得世俗第四禅现在前。若本不得世俗第四禅现在前。不得是时修无漏第四禅。若本不得世俗智现在前。彼非世俗第四禅。得是时修世俗第四禅。非无漏第四禅。是谓世俗非无漏。云何无漏非世俗。答曰。本得无漏第四禅现在前。若本不得无漏第四禅现在前。不得是时修世俗第四禅。若本不得世俗智现在前。彼非第四禅。得是时修无漏第四禅非世俗。若本不得无漏智现在前彼非第四禅。得是时修无漏第四禅非世俗。是谓无漏非世俗。云何世俗无漏。答曰。本不得世俗第四禅现在前。得是时修无漏第四禅。若本不得无漏第四禅现在前。得是时修世俗第四禅。若本不得无漏智现在前。彼非第四禅。得是时修世俗无漏第四禅。若本不得无漏智现在前。彼非第四禅。得是时修世俗无漏第四禅。是谓世俗无漏。云何非世俗非无漏。答曰。本得世俗智现在前。彼非第四禅。若本不得世俗智现在前。不得是时修世俗无漏第四禅。若本得无漏智现在前。彼非第四禅。若本不得无漏智现在前。不得是时修世俗无漏第四禅。一切染污心无记心。入无想三昧灭尽三昧。无想天不修世俗第四禅。非修无漏。是谓非修世俗第四禅非无漏。乃至不用定亦如是。若最初入无漏初禅。得是时诸余未来无漏得心心法。彼一切法当言有觉有观耶。答曰。或彼有觉有观。或无觉有观。或无觉无观。若最初无漏入第二禅。得是时诸余未来无漏得心心法。彼一切法当言喜根相应耶。答曰。或彼乐根相应。或喜根或护根。若最初入无漏第三禅。得是时诸余未来无漏得心心法。彼一切法当言乐根相应耶。答曰。或彼乐根相应。或喜根护根。若最初入无漏第四禅。得是时诸余未来无漏得心心法。彼一切法当言护根相应耶。答曰。或彼乐根相应。或喜根护根。若最初入无漏空处。得是时诸余未来无漏得心心法。彼一切法当言摄空定耶。答曰。或彼摄空定或识定不用定。若最初入无漏识定。得是时诸余未来无漏得心心法。彼一切法当言摄识定耶。答曰。或彼摄空定。或识定不用定。若最初入无漏不用定。得是时诸余未来无漏得心心法。彼一切法当言摄不用定耶。答曰。或彼摄空定。或识定不用定。味相应初禅彼味相应初禅。因次第缘增上。净次第缘增上无因无漏缘增上。余味相应一增上。净无漏第二第三第四禅缘增上。净无漏无色定一增上(味初禅竟)。净初禅彼净初禅。因次第缘增上。无漏次第缘增上无因。除自地味余一切味相应一增上。净无漏第二第三禅。次第缘增上无因。净无漏第四禅缘增。上净无漏无色定一增上。味相应自地次第缘增上(无因净竟)。无漏初禅彼无漏初禅。因次第缘增上。一切味相应一增上。净初禅第二第三禅。次第缘增上无因。无漏第二第三禅。因次第缘增上。净第四禅净无色定缘增上。无漏第四禅无漏无色定。因缘增上。净自地次第缘增上(无漏竟)。乃至不用定亦如是。味相应有想无想。彼味相应有想无想。因次第缘增上。净次第缘增上无因。味相应次第增上。净不用处次第缘增上。余净无漏下缘增上(味相应竟)。净有想无想彼净有想无想。因次第缘增上。味相应下一增上。净无漏识处不用处。次第缘增上无因。余净无漏缘增上。味相应自地次第缘增上无因

阿毗昙缘跋渠第二竟(梵本一百八十四首卢秦一千六百六十四言)

阿毗昙八犍度论卷第二十六阿毗昙八揵度论卷第二十七

        迦旃延子造

        符秦罽宾三藏僧伽提婆共竺佛念等译

    定犍度中解脱跋渠第三

摄相应在亦尔(胡曰优波蓝)　成就禅无色　七人七顿得

由何三昧尽十想。四禅四等四无色定八解脱。八除入十一切入八智三三昧。十想。无常想无常苦想。苦无我想不净想观食想。一切世间不可乐想。死想断想无欲想尽想。无常想摄几禅几等几无色定几解脱几除入几一切入几智几三昧。乃至尽想亦如是。初禅摄几禅几等几无色定几解脱几除入几一切入几智几三昧。乃至第四禅亦如是。慈摄几等几无色定几解脱几除入几一切入几智几三昧。乃至护亦如是无色中空处摄几无色定几解脱几除入几一切入几智几三昧。乃至有想无想。亦如是初解脱摄几解脱几除入几一切入几智几三昧。乃至第八解脱亦如是。初除入摄几除入几一切入几智几三昧。乃至第八除入亦如是。初一切入摄几一切入几智几三昧。乃至第十一切入亦如是。法智摄几智几三昧。乃至道智亦如是。空无愿无相摄几三昧相应共亦如是。若成就初禅于此四禅。成就几不成就几。四等四无色定八解脱八除入十一切入八智三三昧。成就几不成就几。乃至第四禅亦如是。七人坚信坚法信解脱见到身证慧解脱俱解脱。坚信人味相应四禅。成就几不成就几。净成就几不成就几。无漏成就几不成就几。乃至俱解脱人味相应四禅。成就几不成就几。净成就几不成就几。无漏成就几不成就几。坚信人味相应四无色定。成就几不成就几。净成就几不成就几。无漏成就几不成就几。乃至俱解脱人味相应。四无色定。成就几不成就几净成就几不成就几。无漏成就几不成就几。颇成就味相应四禅。非净非无漏耶。成就净非味相应非无漏耶。成就无漏非味相应非净耶。成就味相应净非无漏耶。成就味相应无漏非净耶。成就净无漏非味相应耶。成就味相应净无漏耶(成竟)。不成就得弃退亦如是。颇成就味相应四无色定。非净非无漏耶。成就净非味相应非无漏耶。成就无漏非味相应非净耶。成就味相应净非无漏耶。成就味相应无漏非净耶。成就净无漏非味相应耶。成就味相应净无漏耶(成竟)。不成就得弃退亦如是。颇味相应四禅顿得顿弃耶。渐得渐弃耶。颇净四禅顿得顿弃耶。渐得渐弃耶。颇无漏四禅顿得顿弃耶。渐得渐弃耶。颇味相应四无色定顿得顿弃耶。渐得渐弃耶。颇净四无色定顿得顿弃耶。渐得渐弃耶。颇无漏三无色定顿得顿弃耶。渐得渐弃耶。身教由何三昧尽。身无教口教口无教。三恶行三妙行。三不善根三善根。四不圣语四圣语。四胞胎四生四识住。五盛阴五欲。五优婆塞戒。六内入六外入。六识身六更乐身六痛身六想身六思身六爱身。七识所止世八法九众生居。十行迹四禅四等四无色定。八解脱八除入十一切入。知他人心智等智。由何三昧尽。此章义愿具演说

十想无常想无常苦想苦无我想不净想观食想一切世间不可乐想死想断想无欲想尽想。无常想摄四禅四无色定。四解脱无常苦想苦无我想死想断想无欲想尽想亦如是。不净想观食想摄四禅初第二解脱。一切世间不可乐想摄第三第四禅(想竟)。禅中初禅摄初禅四等初第二解脱初四除入八智三三昧。二禅摄二禅四等初第二解脱初四除入八智三三昧。第三禅摄第三禅三等八智三三昧。第四禅摄第四禅三等净解脱后四除入八一切入八智三三昧(禅竟)。慈摄慈悲喜。护摄护。无色中空处摄空处。空处解脱。空处入。六智三三昧。识处摄识处识处解脱识处入。六智三三昧。不用处摄不用处不用处解脱六智三三昧。有想无想处摄有想无想处有想无想解脱灭尽解脱一智(无色竟)。初第二第三解脱摄初第二第三解脱。空处解脱摄空处解脱空处入六智三三昧。识处解脱摄识处解脱识处入六智三三昧。不用处解脱摄不用处解脱六智三三昧。有想无想解脱摄有想无想解脱。一智灭尽解脱摄灭尽解脱(解脱竟)。初除入摄初除入。乃至第八除入摄第八除入。初一切入摄初一切入。乃至第十一切入摄第十一切入。法智摄法智五智少入。知他人心智苦智习尽道智。未知智摄未知智五智少入知他人心智苦智习尽道智。知他人心智摄知他人心智四智少入法智未知智道智等智。等智摄等智苦智习尽道智。空无愿无相摄无相(摄竟)。共在亦如是。无常想四禅相应。四无色定四解脱四智一三昧(无愿)。无常苦想苦无我想死想断想无欲想尽想亦如是。不净想观食想。四禅相应。初第二解脱及等智一切世间不可乐想。第三第四禅相应。及等智禅中初禅初禅相应。四等初第二解脱初四除入八智三三昧第二禅第二禅相应。四等初第二解脱初四除入八智三三昧第三禅。第三禅相应。三等八智三三昧第四禅。第四禅相应。三等净解脱后四除入八一切入八智。三三昧慈慈相应。及等智悲喜护护相应。及等智无色中空处空处相应。空处解脱空处入六智三三昧识处识处相应。识处解脱识处入六智三三昧不用处不用处相应。不用处解脱六智三三昧有想无想处有想无想处相应。有想无想解脱及等智初第二第三解脱初第二第三解脱相应。及等智空处解脱空处解脱相应。空处入六智(四谛未知智等智也)三三昧识处解脱。识处解脱相应。识处入六智三三昧不用处解脱。不用处解脱相应。六智三三昧有想无想解脱。有想无想解脱相应。及等智初除入初除入相应。及等智乃至第八除入。第八除入相应。及等智初一切入。初一切入相应。及等智乃至第十一切入。第十一切入相应。及等智法智未知智。三三昧少入相应。知他人心智。一三昧少入相应。等智无三昧相应。苦智二三昧少入相应。习尽道智一三昧少入相应。空无相无愿三昧无三昧相应(相应竟)。若成就初禅。于此四禅成就几不成就几。答曰。或一二三四。云何一。答曰。欲爱尽梵天上爱未尽。是谓一。云何二。答曰。梵天上爱尽光音爱未尽是谓二。云何三。答曰。光音爱尽遍净爱未尽是谓三。云何四。答曰。遍净爱尽是谓四。若成就初禅于此四等成就几不成就几。答曰。或无或三或四。云何无。答曰。生无色界是谓无。云何三。答曰。生遍净若果实是谓三。云何四。答曰。生欲界若梵天上光音是谓四。若成就初禅于此四无色定。成就几不成就几。答曰。或无或一二三四。云何无。答曰。色界爱未尽是谓无。云何一。答曰。色爱尽空处爱未尽是谓一。云何二。答曰。空处爱尽识处爱未尽是谓二。云何三。答曰。识处爱尽不用处爱未尽是谓三。云何四。答曰。不用处爱尽是谓四。若成就初禅于此八解脱。成就几不成就几。答曰。或无或一二三四五六七八。云何无。答曰。生遍净于彼爱未尽是谓无。云何一。答曰。生遍净于彼爱尽果实爱未尽。若生果实于彼爱未尽。若生空处于彼爱未尽是谓一。云何二。答曰。生欲界若梵天上。光音爱尽遍净爱未尽。若生光音于彼爱尽遍净爱未尽。若生遍净果实爱尽空处爱未尽。若生果实于彼爱尽空处爱未尽。若生空处于彼爱尽识处爱未尽。若生识处于彼爱未尽是谓二。云何三。答曰。生欲界若梵天上。遍净爱尽果实爱未尽。若生光音遍净爱尽果实爱未尽。若生遍净空处爱尽识处爱未尽。若生果实空处爱尽识处爱未尽。若生空处识处爱尽不用处爱未尽。若生识处于彼爱尽不用处爱未尽。若生不用处于彼爱未尽。是谓三。云何四。答曰。生欲界若梵天上。果实爱尽空处爱未尽。若生光音果实爱尽空处爱未尽。若生遍净识处爱尽不用处爱未尽。若生果实识处爱尽不用处爱未尽。若生空处识处不用处爱尽。不得灭尽三昧。若生不用处于彼爱尽。不得灭尽三昧。若生有想无想处。不得灭尽三昧。是谓四。云何五。答曰。生欲界若梵天上。空处爱尽识处爱未尽。若生光音空处爱尽识处爱未尽。若生遍净不用处爱尽不得灭尽三昧。若生果实不用处爱尽不得灭尽三昧。若生有想无想处得灭尽三昧。是谓五。云何六。答曰。生欲界若梵天上。识处爱尽不用处爱未尽。若生光音识处爱尽不用处爱未尽。若生遍净得灭尽三昧。若生果实得灭尽三昧。是谓六。云何七。答曰。生欲界若梵天上。不用处爱尽不得灭尽三昧。若生光音不用处爱尽不得灭尽三昧。是谓七。云何八。答曰。生欲界若生梵天上。得灭尽三昧。若生光音得灭尽三昧。是谓八。若成就初禅于此八除入。成就几不成就几。答曰。或无或四或八。云何无。答曰。生遍净于彼爱未尽。若生无色界是谓无。云何四。答曰。生欲界若梵天上。光音爱尽遍净爱未尽。若生光音于彼爱尽遍净爱未尽。若生遍净于彼爱尽。若生果实于彼爱未尽。是谓四。云何八。答曰。生欲界若梵天上。遍净爱尽。若生光音遍净爱尽。是谓八。若成就初禅于此十一切入。成就几不成就几。答曰或无或一二八九十。云何无。答曰。生欲界若梵天上。光音爱尽遍净爱未尽。若生光音于彼爱尽遍净爱未尽。若生遍净于彼爱未尽。若生不用处有想无想处。是谓无。云何一。答曰。生空处于彼爱未尽。若生识处是谓一。云何二。答曰。生空处于彼爱尽是谓二。云何八。答曰。生欲界若梵天上。遍净爱尽果实爱未尽。若生光音遍净爱尽果实爱未尽。若生遍净于彼爱尽果实爱未尽。若生果实于彼爱未尽。是谓八。云何九。答曰。生欲界若色界。色爱尽空处爱未尽。是谓九。云何十。答曰。生欲界若色界空处爱尽。是谓十。若成就初禅于此八智。成就几不成就几。答曰。或二四五六七八。云何二等。答曰。凡夫人二。无垢人苦法忍现在前二。苦法智四苦未知忍四。苦未知智五。习法忍五。习法智六。习未知忍习未知智尽法忍六。尽法智七。尽未知忍尽未知智道法忍七。道法智八。道未知忍道未知智八。若成就初禅于此三三昧。成就几不成就几。答曰。或无或二三云何无等。答曰。凡夫人无。无垢人尽法忍未生二。已生三(初竟)。乃至第四禅亦如是。七人坚信坚法信解脱见到身证慧解脱俱解脱。坚信人味相应四禅。成就几不成就几。答曰。或无或一二三四。云何无。答曰。色界爱尽是谓无。云何一。答曰。遍净爱尽果实爱未尽是谓一。云何二。答曰。光音爱尽遍净爱未尽是谓二。云何三。答曰。梵天上爱尽光音爱未尽。是谓三。云何四。答曰。梵天上爱未尽是谓四。净成就几不成就几。答曰。或无或一二三四。云何无。答曰。欲爱未尽是谓无。云何一。答曰。欲爱尽梵天上爱未尽是谓一。云何二。答曰。梵天上爱尽光音爱未尽是谓二。云何三。答曰。光音爱尽遍净爱未尽。是谓三。云何四。答曰。遍净爱尽是谓四。无漏成就几不成就几。答曰或无或一二三四。云何无。答曰。依未来越次取证是谓无。云何一。答曰。依初禅越次取证是谓一。云何二。答曰。依二禅越次取证是谓二。云何三。答曰。依三禅越次取证是谓三。云何四。答曰。依四禅越次取证是谓四。坚法亦如是。信解脱人味相应四禅。成就几不成就几。答曰。或无或一二三四。云何无。答曰。色爱尽是谓无。云何一。答曰。遍净爱尽果实爱未尽是谓一。云何二。答曰。光音爱尽遍净爱未尽是谓二。云何三。答曰。梵天上爱尽光音爱未尽是谓三。云何四。答曰。梵天上爱未尽是谓四。净成就几不成就几。答曰。或无或一二三四。云何无。答曰。生欲界欲爱未尽。若生无色界是谓无。云何一。答曰。生欲界欲爱尽。梵天上爱未尽。若生梵天上于彼爱未尽。若生光音于彼爱未尽若生遍净于彼爱未尽。若生果实是谓一。云何二。答曰。生欲界若梵天上。梵天上爱尽光音爱未尽。若生光音于彼爱尽遍净爱未尽。若生遍净于彼爱尽。是谓二。云何三。答曰。生欲界若梵天上。光音爱尽遍净爱未尽。若生光音遍净爱尽是谓三。云何四。答曰。生欲界若梵天上。遍净爱尽是谓四。无漏成就几不成就几。答曰。或无或一二三四。云何无。答曰。欲爱未尽是谓无。云何一。答曰。欲爱尽梵天上爱未尽是谓一。云何二。答曰。梵天上爱尽光音爱未尽是谓二。云何三。答曰。光音爱尽遍净爱未尽是谓三。云何四。答曰。遍净爱尽是谓四。见到亦如是。身证人味相应四禅。成就几不成就几。答曰。一切不成就。净成就几不成就几。答曰。或无或一二三四。云何无。答曰。生有想无想处是谓无。云何一。答曰。生果实是谓一。云何二。答曰。生遍净是谓二。云何三。答曰。生光音是谓三。云何四。答曰。生欲界若梵天上是谓四。无漏成就几不成就几。答曰。一切成就。俱解脱亦如是。慧解脱人味相应四禅。成就几不成就几。答曰。一切不成就。净成就几不成就几。答曰。或无或一二三四。云何无。答曰。生无色界是谓无。云何一。答曰。生果实是谓一。云何二。答曰。生遍净是谓二。云何三。答曰。生光音是谓三。云何四。答曰。生欲界若梵天上是谓四。无漏成就。几不成就几。答曰。一切成就。坚信人味相应四无色定。成就几不成就几。答曰。或一二三四。云何一。答曰。不用处爱尽是谓一。云何二。答曰。识处爱尽不用处爱未尽是谓二。云何三。答曰。空处爱尽识处爱未尽是谓三。云何四。答曰。空处爱未尽是谓四。净成就几不成就几。答曰。或无或一二三四。云何无。答曰。色爱未尽是谓无。云何一。答曰。色爱尽空处爱未尽是谓一。云何二。答曰。空处爱。尽识处爱未尽是谓二。云何三。答曰。识处爱尽不用处爱未尽是谓三。云何四。答曰。不用处爱尽是谓四。无漏成就几不成就几。答曰。一切不成就。坚法亦如是。信解脱人味相应四无色定。成就几不成就几。答曰。或一二三四。云何一。答曰。不用处爱尽是谓一。云何二。答曰。识处爱尽不用处爱未尽是谓二。云何三。答曰。空处爱尽识处爱未尽是谓三。云何四。答曰。空处爱未尽是谓四。净成就几不成就几。答曰。或无或一二三四。云何无。答曰。生欲界若色界色爱未尽是谓无。云何一。答曰。生欲界若色界。色爱尽空处爱未尽。若生空处于彼爱未尽若生识处于彼爱未尽。若生不用处于彼爱未尽。若生有想无想处是谓一。云何二。答曰。生欲界若色界。空处爱尽识处爱未尽。若生空处于彼爱尽。识处爱未尽。若生识处于彼爱尽不用处爱未尽。若生不用处于彼爱尽。是谓二。云何三。答曰。生欲界若色界。识处爱尽不用处爱未尽。若生空处识处爱尽不用处爱未尽。若生识处不用处爱尽是谓三。云何四。答曰。生欲界若色界不用处爱尽。若生空处不用处爱尽是谓四。无漏成就几不成就几。答曰。或无或一二三。云何无。答曰。色爱未尽是谓无。云何一。答曰。色爱尽空处爱未尽是谓一。云何二。答曰。空处爱尽识处爱未尽是谓二。云何三。答曰。识处爱尽是谓三。见到亦如是。身证人味相应四无色定。成就几不成就几。答曰。一成就三不成就净成就几不成就几。答曰。或一或四。云何一。答曰。生有想无想处是谓一。云何四。答曰。生欲界若色界是谓四。无漏成就几不成就几。答曰。一切成就。慧解脱人味相应四无色定。成就几不成就几。答曰。一切不成就。净成就几不成就几。答曰。或一二三四。云何一。答曰。生有想无想处是谓一。云何二。答曰。生不用处是谓二。云何三。答曰。生识处是谓三。云何四。答曰。生欲界若生色界若生空处是谓四。无漏成就几不成就几。答曰。一切成就。俱解脱人味相应四无色定。成就几不成就几。答曰。一切不成就。净成就几不成就几。答曰。或一或四。云何一。答曰。生有想无想处是谓一。云何四。答曰。生欲界色界是谓四。无漏成就几不成就几。答曰。一切成就(七人竟)。颇成就味相应四禅。非净非无漏耶。答曰。有欲界爱未尽也。成就净非味相应非无漏耶。答曰。有凡夫人生欲界若梵天上。色爱尽也。成就无漏非味相应非净耶。答曰。有无垢人生无色界也。成就味相应净非无漏耶。答曰。无也。成就味相应无漏非净耶。答曰。无也。成就净无漏非味相应耶。答曰。有无垢人生欲界若梵天上。色爱尽也。成就味相应净无漏耶。答曰。无也(七问竟)。颇不成就味相应四禅。非不净非不无漏耶。答曰。有无垢人生欲界若梵天上。色爱尽不成就净。非不味相应非不无漏耶。答曰。无不成就无漏。非不味相应非不净耶。答曰。无不成就味相应净。非不无漏耶。答曰。有无垢人生无色界。不成就味相应无漏非不净耶。答曰。有凡夫人生欲界若梵天上。色爱尽不成就净无漏。非不味相应耶。答曰。有欲界爱未尽。不成就味相应净无漏耶。答曰。有凡夫人生无色界也(问不成就七竟)。颇得味相应四禅。非净非无漏耶。答曰。得色爱尽欲界缠退。若无色界没生欲界也。得净非味相应非无漏耶。答曰得。凡夫人逮第三禅爱尽也。得无漏非味相应非净耶。答曰得。依第四禅越次取证。当逮阿罗汉果。乃至得净无漏非味相应耶。答曰得。无垢人逮第三禅爱尽余得耶。答曰。不得(得七问竟)。颇弃味相应四禅。非净非无漏耶答曰不弃。弃净非味相应非无漏耶。答曰。弃凡夫人第三禅爱尽欲界缠退乃至弃净无漏非味相应耶。答曰弃。无垢人第三禅爱尽欲界缠退。余弃耶。答曰不弃(弃七问竟)。颇退味相应四禅非净非无漏耶。答曰不退。退净非味相应非无漏耶。答曰退。凡夫人第三禅爱尽欲界缠退也。乃至退净无漏非味相应耶。答曰退。无垢人第三禅爱尽欲界缠退。余退耶。答曰。不退(退七问竟)。颇成就味相应四无色定。非净非无漏耶。答曰。有色爱未尽。乃至成就净无漏非味相应耶。答曰。有生欲色界得阿罗汉。若生空处得阿罗汉。成就余耶。答曰。无也(无色七竟)。颇不成就味相应四无色定。非不净非不无漏耶。答曰。有阿罗汉生欲色界。若阿罗汉生空处乃至不成就净无漏。非不味相应耶。答曰。有色爱未尽也。余不成就耶。答曰。无(无色不成竟)。颇得味相应四无色定。非净非无漏耶。答曰。得阿罗汉欲色界缠退也。得净非味相应非无漏耶。答曰。得凡夫人逮不用处爱尽得无漏。非味相应非净耶。答曰。得当逮阿罗汉果也。乃至得净无漏非味相应。答曰。得无垢人逮不用处爱尽。余得耶。答曰。不得(得七竟)。颇弃味相应四无色定。非净非无漏耶。答曰。不弃。弃净非味相应非无漏耶。答曰。弃凡夫人不用处爱尽。欲色界缠退。乃至弃净无漏。非味相应。答曰。弃无垢人不用处爱尽欲色界缠退。余弃耶。答曰。不弃(弃七竟)。颇退味相应四无色定非净非无漏耶。答曰。不退。退净非味相应非无漏耶。答曰。退凡夫人不用处爱尽。欲色界缠退。乃至退净无漏。非味相应耶。答曰。退无垢人不用处爱尽。欲色界缠退。余退耶。答曰。不退(七都竟)。颇味相应四禅顿得耶。答曰得。色爱尽欲界缠退。若无色界没生欲界梵天上。顿弃耶。答曰不弃。渐得耶。答曰不得。渐弃耶。答曰弃。颇净四禅顿得耶。答曰不得。顿弃耶。答曰弃。第三禅爱尽欲界缠退。欲界梵天上没生无色界渐得耶。答曰得。渐弃耶。答曰弃。颇无漏四禅顿得耶。答曰得。依第四禅越次取证当逮阿罗汉。顿弃耶。答曰弃。无垢人第三禅爱尽欲界缠退渐得耶。答曰得。渐弃耶。答曰不弃。颇味相应四无色定顿得耶。答曰得。阿罗汉欲色界缠退顿弃耶。答曰不弃。渐得耶。答曰不得。渐弃耶。答曰弃。颇净四无色定顿得耶。答曰不得。顿弃耶。答曰弃。不用处爱尽欲色界缠退渐得耶。答曰得。渐弃耶。答曰弃。颇无漏三无色定顿得耶。答曰得。当逮阿罗汉顿弃耶。答曰弃。无垢人识处爱尽欲色界缠退渐得耶。答曰得。渐弃耶。答曰不弃。身教由何三昧尽。答曰。或依初禅或依未来。口教亦如是。身无教或依四或依未来。口无教亦如是。三恶行三妙行三不善根三善根。四无圣语四圣语。四生胞胎卵生合会生。依未来化生。或依七或依未来。色识所止或依四或依未来。痛想行识所止。或依七。或依未来色阴。或依四。或依未来痛想行识阴。或依七或依未来色盛阴。或依四或依未来痛想行识盛阴。或依七或依未来。五欲五优婆塞戒。或依未来。眼入耳鼻舌身入色声细滑入。或依四或依未来。香入味入。依未来。意入法入。或依七或依未来。眼识耳识身识。彼相应更乐痛想思爱。或依初或依未来。鼻识舌识。彼相应更乐痛想思爱依未来意识。彼相应更乐痛想思爱。或依七或依未来。初识止依未来。第二识止或依初或依未来。第三识止或依二或依未来。第四识止或依。三或依未来。第五识止或依五或依未来。第六识止或依六或依未来。第七识止或依七或依未来世。八法依未来。初众生居或依未来。第二众生居或依初或依未来。第三众生居或依二或依未来。第四众生居或依三或依未来。第五众生居或依四或依未来。第六众生居或依五或依未来。第七众生居或依六或依未来。第八第九众生居或依七或依未来十行迹依未来。禅中初禅或依初或依未来。第二禅或依二或依未来。喜初第二解脱初四除入亦如是。第三禅或依三或依未来第四禅或依四或依未来。慈悲护净解脱。后四除入八一切入亦如是。无色中空处。空处解脱空处一切入。或依五或依未来。识处识处解脱识处一切入。或依六或依未来。不用处不用处解脱。有想无想处。有想无想解脱灭尽解脱。或依七或依未来。知他人心智或依四或依未来。等智或依七或依未来

解脱跋渠第三竟(梵本五百七十三首卢秦六千六百八十一言)

    阿毗昙定犍度阿那含跋渠第四(第三十七)

五阿那含中般涅槃。生般涅槃。行般涅槃。无行般涅槃。上流往阿迦腻吒。五阿那含摄一切阿那含耶。一切五耶。何者最胜中般涅槃生般涅槃耶。何者最胜乃至无行般涅槃上流往阿迦腻吒。诸学彼一切不到欲到。不获欲获。不证欲证学耶。设不到欲到不获欲获不证欲证。学彼一切学耶。诸无学彼一切不到欲到不获欲获不证欲证无学耶。设不到欲到不获欲获不证欲证。不学彼一切无学耶。顺流义云何。逆流义云何。实住义云何。诸实住彼一切阿罗汉耶。设阿罗汉彼一切实住耶。诸还迹彼一切到彼岸。设到彼岸彼一切还迹耶。齐何所菩萨得何物菩萨。又世尊言。汝今弥勒未来久远。名弥勒怛萨阿竭阿罗诃三耶三佛。此是何智此智当言为辩何事。又世尊言。是谓尊弟子现法辩诸教。尽生具梵行所作已办。名色已有如实知之此是何智。当言此智为辩何事。愿智云何愿智当言善耶无记耶。余迹云何余迹名何法。又世尊言。我弟子中第一比丘。第一智醯兜摩纳。捷智婆犹颇隶脂梨此何差别。又世尊言。我弟子中第一比丘心回善祝利般特迦。想回善摩诃般特迦。此何差别。又世尊言。我弟子中第一比丘大智慧舍利弗。得辩才摩诃拘絺罗。此何差别。又世尊言。我比丘第一弟子中。少欲头陀行摩诃迦叶。无著少欲薄拘卢。此何差别。又世尊言。学摩诃南灭五盖已游。云何学五盖灭已游。又世尊言。是谓法知足比尼知足。比尼知足法知足。云何法知足比尼知足。云何比尼知足法知足。又世尊言。法次法向彼。云何法云何次法向彼。法轮云何。齐何当言转法轮。等法云何齐何当言等法住。齐何当言等法尽。若生彼何世摄。若尽彼何世摄。若最初无漏入初禅。彼何世摄。若最初无漏乃至入不用定。彼何世摄。此章义愿具演说

五阿那含中般涅槃。生般涅槃行般涅槃无行般涅槃上流往阿迦腻吒。五阿那含摄一切。阿那含一切五。答曰。一切五非五一切。不摄何等。答曰。现法般涅槃无色界阿那含。何者最胜中般涅槃生般涅槃耶。答曰。等尽住中般涅槃胜。非生般涅槃。若此生般涅槃结尽多者彼则胜也。何者最胜乃至无行般涅槃上流往阿迦腻吒。答曰。等尽住无行般涅槃胜。非上流往阿迦腻吒。若此上流往阿迦腻吒。结尽多者彼则胜也。所谓是学士。彼一切不到欲到。不获欲获。不证欲证学耶。答曰。或是学士。彼不到欲到不获欲获不证欲证不学也。云何是学士。彼不到欲到不获欲获不证欲证不学耶。答曰。学士性住。是谓是学士彼不到欲到不获欲获不证欲证不学也。云何不到欲到不获欲获不证欲证。学彼非是学士耶。答曰。阿罗汉若凡夫人方便上求。是谓不到欲到不获欲获不证欲证。学彼非是学士也。云何是学士亦不到欲到不获欲获不证欲证学耶。答曰。学士方便上求。是谓是学士亦不到欲到不获欲获不证欲证学也。云何亦不是学士。亦不到欲到不获欲获不证欲证不学耶。答曰。阿罗汉若凡夫人性住。是谓亦不是学士。亦不到欲到不获欲获不证欲证不学也。所谓是无学士彼一切不到欲到不获欲获不证欲证无学耶。答曰。或是无学士。彼不到欲到不获欲获不证欲证。非不学也。云何是无学士。彼不到欲到不获欲获不证欲证非不学耶。答曰。阿罗汉方便上求。是谓无学士。彼不到欲到不获欲获不证欲证。非不学也。云何不到欲到不获欲获不证欲证。不学也。彼不是无学士耶。答曰。学士若凡夫人性住。是谓不到欲到不获欲获不证欲证。不学彼不是无学士也。云何亦是无学士亦不到欲到不获欲获不证欲证。不是学耶。答曰。阿罗汉性住。是谓亦是无学士。亦不到欲到不获欲获不证欲证不学也。云何是非无学士。亦不到欲到不获欲获不证欲证。非不学耶。答曰。学士若凡夫人。方便上求。是谓是非无学士。亦不到欲到不获欲获不证欲证。非不学也。顺流义云何。答曰。诸生诸去诸有诸所生诸所居。彼种彼门彼缘彼道彼迹向。是故顺流。逆流义云何。答曰。诸生尽去尽有尽所生尽所居尽。彼种彼门彼缘彼道彼迹向。是故逆流。实住义云何。答曰。彼非如此诸生诸去诸有诸所生诸所居。彼种彼门彼缘彼道彼迹向。彼非如此诸生尽去尽有尽所生尽所居尽。彼种彼门彼缘彼道彼迹向。是故实住。诸实住彼一切阿罗汉耶。答曰。如是。诸阿罗汉彼一切实住。颇实住彼非阿罗汉耶。答曰。有阿那含。世尊亦说。若灭五垢学足。无漏法心得自在定根彼实住。是谓实住人诸还迹。彼一切到彼岸耶。答曰。如是。诸还迹彼一切到彼岸。颇到彼岸彼非还迹。答曰。有阿那含世尊亦说。云何比丘得到彼岸。答曰。五下分结已尽无余。齐何菩萨。答曰。齐相报行作无厌。得何事名菩萨。答曰。相报行也。又世尊言。汝弥勒未来久远。名弥勒恒萨阿竭阿罗诃三耶三佛。此是何智。答曰。因智道智。此智当言辩何事。答曰。相报行因智。诸无漏根力觉道种。得阿耨多罗三耶三佛此道智。又世尊言。是谓尊弟子现法具教尽死生。立梵行所作已办。名色有如实知之此是何智。答曰。道智。此智当言辩何事。答曰。诸无漏根力觉道种得尽漏。是谓道智。愿智云何。答曰。如阿罗汉诸欲解义。彼作愿已入顶第四禅。彼从三昧起知彼彼义。是谓愿智。愿智当言善耶。当言无记耶。答曰。愿智或善或无记。云何他迹。答曰。一切阿罗汉内时善别不尽外。是谓内时善别。他迹他义名何法。答曰。他无垢。又世尊言第一比丘。我弟子第一智醯兜摩纳(真人名也)。捷智婆犹果衣。此何差别。答曰。尊者醯兜摩纳专正心无伪。尊者婆犹果衣少务心柔和。是谓差别。又世尊言。是第一比丘我弟子心回善祝利般特迦。想回善摩诃般特迦。此何差别。答曰。尊者祝利般特迦心心观多游。尊者摩诃般特迦多游法法观。是谓差别。又世尊言。我弟子中第一比丘。大智慧舍利弗。得辩才摩诃拘絺罗。此何差别。答曰。尊者舍利弗多游义辩。尊者摩诃拘絺罗多游四辩。是谓差别。又世尊言。我弟子中第一比丘。少欲头陀摩诃迦叶。无著少欲薄拘卢。此何差别。答曰。尊者摩诃迦叶。若得食若好若丑。彼等意食无彼此意。尊者薄拘卢。得食若好若丑。彼别其好而食粗者。复次尊者摩诃迦叶广识大德。得衣食床卧具病瘦医药彼等受行头陀。尊者薄拘卢少识非大德。亦不得衣食床卧具病瘦医药。彼不等受行头陀。此不为难少识比丘。不等受行头陀。是谓差别。又世尊言。摩诃南学灭五盖游。云何学灭五盖游。答曰。须陀洹斯陀含。于此义学解彼五盖灭。渐灭离渐离障。渐障背渐背游。以是故须陀洹斯陀含于此义学脱。又世尊言。是谓法知足比尼知足。比尼知足法知足。云何法知足比尼知足。云何比尼知足法知足。答曰。圣八道种谓之法。除淫恚痴比尼谓之比尼。彼圣八道种不修不广彼淫恚痴比尼不作证。彼淫恚痴比尼不作证。比尼不作证已。圣八道种不修不广。如是法知足比尼知足。如是比尼知足法知足。又世尊言。法次法向彼。云何法。云何次法向彼。答曰。涅槃谓之法。圣八道种谓之次法向彼。复次戒解脱谓之法。戒解脱比尼谓之次法向彼。复次身戒律口戒律谓之法。等持谓之次法向彼。法轮云何。答曰。圣八道种。齐何当言转法轮。答曰。齐尊者阿若拘邻见法。等法云何。答曰。无漏根力觉道种。齐何当言等法住。答曰。诸行法者住。齐何当言等法灭。答曰。诸行法者灭。诸生摄何世。答曰。未来。若灭何世摄。答曰。现在若最始入无漏初禅。摄何世。答曰。未来。若最初乃至入不用定。摄何世。答曰。未来

阿那含品第四竟(梵本一百五十七首卢秦二千四百二言)

阿毗昙八犍度论卷第二十七阿毗昙八犍度论卷第二十八

        迦旃延子造

        符秦罽宾三藏僧伽提婆共竺佛念译

    定犍度中一行跋渠第五

一行历六二七是修断三昧越智禅二定起。想拘律陀聚觉意断眼视彻听有逮凡夫果退。生界五通苦最在后三三昧空无愿无相。若成就空彼成就无愿也。设成就无愿彼成就空也。若成就空彼成就无相耶。设成就无相彼成就空耶。若成就无愿彼成就无相耶。设成就无相彼成就无愿耶(一行竟)。若成就过去空彼成就未来耶。设成就未来彼成就过去也。若成就过去彼成就现在也。设成就现在彼成就过去耶。若成就未来彼成就现在耶。设成就现在彼成就未来耶。若成就过去彼成就未来现在耶。设成就未来现在彼成就过去耶。若成就未来彼成就过去现在耶。设成就过去现在彼成就未来耶。若成就现在彼成就过去未来耶。设成就过去未来彼成就现在耶(空六竟)。无愿无相亦如是。若成就过去空。彼成就过去无愿也。设成就过去无愿。彼成就过去空耶。若成就过去空。彼成就未来无愿耶。设成就未来无愿彼成就过去空耶。若成就过去空。彼成就现在无愿耶。设成就现在无愿。彼成就过去空耶。若成就过去空。彼成就过去现在无愿耶。设成就过去现在无愿。彼成就过去空耶。若成就过去空。彼成就未来现在无愿耶。设成就未来现在无愿。彼成就过去空耶。若成就过去空。彼成就过去未来无愿耶。设成就过去未来无愿。彼成就过去空耶。若成就过去空彼成就过去未来现在无愿耶。设成就过去未来现在无愿。彼成就过去空耶(空愿七竟)。无相亦如是。过去空过去无愿过去无相。未来现在过去现在。未来现在过去未来。过去未来现在无相(七竟)。若修空三昧彼修无愿耶。设修无愿彼修空耶。若修空三昧彼修无相耶。设修无相彼修空耶。若修无愿三昧。彼修无相耶。设修无相彼修无愿耶。颇结空灭非无愿无相耶。无愿灭非空非无相耶。无相灭非空非无愿耶。空无愿灭非无相耶。空无相灭非无愿也。无愿无相灭非空耶。空无相无愿灭。颇结非空非无愿非无相灭而灭结耶。云何意所念越次取证。何系行意所念越次取证。尽智当言身身观意止耶。当言痛心法法观意止耶。无生智亦如是。诸无漏初禅乐。诸猗觉意此何差别。诸无漏第二禅乐。诸猗觉意此何差别。若从三昧起彼因缘起耶。设因缘起彼三昧起耶。又世尊言。乃至想定齐是得教。若世尊弟子生有想无想处。彼依何等逮阿罗汉果。又尊者摩诃目揵连言。诸贤者我自思惟。在耆阇崛山醍醐池侧入不用定。有众多龙象擎鼻哮吼而闻声。为尊者摩诃目犍连。入定闻彼声起闻声耶。诸不定彼一切无明实无明语耶。设无明实无明语彼一切不定耶。诸定彼一切明实明语耶。设明实明语彼一切定耶。诸不定彼一切不成就觉意耶。设不成就觉意。彼一切不定耶。诸定彼一切成就觉意耶。设成就觉意彼一切定耶。若成就觉意彼成就无漏法耶。设成就无漏法彼成就觉意耶。若不成就觉意彼不成就无漏法耶。设不成就无漏法。彼不成就觉意耶。若得觉意彼得无漏法耶。设得无漏法彼得觉意耶。若弃觉意彼弃无漏法耶。设弃无漏法彼弃觉意耶。若退觉意彼退无漏法耶。设退无漏法彼退觉意耶。若不尽彼无余耶。设无余彼不尽耶。若尽彼有余耶。设有余彼尽耶。诸于此生眼本不见色彼辨天眼。依何等辨天眼。耳声亦如是。以何等故凡夫人退见谛思惟断结。还有世尊弟子思惟断。以何等故阿罗汉果退非须陀洹果。以何等故阿那含斯陀含果退。非须陀洹果。阿罗汉果退。诸得无漏根力觉道种。当言本得得本不得得。阿那含斯陀含果。退诸得无漏根力觉道种。当言本得得本不得得。无色界没生欲界。诸得持阴入四大。善根不善根无记根。结缚使垢缠。当言本得得本不得得。无色界没生色界。诸得持阴入四大。善根无记根。结缚使垢缠。当言本得得本不得得。色界没生欲界。诸得持阴入四大。善根不善根无记根。结缚使垢缠。当言本得得本不得得。若依初禅。神足智证通修道。彼齐何能至几所。若依初禅。彻听闻声智证通修道。彼能齐何系。若依初禅。知他人心智证通修道。彼能齐何系知心心法。若依初禅。自识宿命智证通修道。彼能齐何系自识宿命。若依初禅。天眼智证通修道。彼能齐何系眼见色。第二第三第四禅亦如是。若意所念苦苦逮阿罗汉果。彼齐何系行意所念苦苦逮阿罗汉果。习亦如是。若尽尽意所念逮阿罗汉果。彼何系行意所念尽尽逮阿罗汉果。道亦如是。此章义愿具演说。三三昧空无愿无相。若成就空彼成就无愿耶。答曰。如是。设成就无愿彼成就空耶。答曰。如是。若成就空彼成就无相耶。答曰。若得设成就无相。彼成就空耶。答曰。如是。若成就无愿彼成就无相耶。答曰。若得设成就无相。彼成就无愿耶。答曰。如是(一行竟)。若成就过去空。彼成就未来耶。答曰。如是。设成就未来彼成就过去也。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就过去彼成就现在也。答曰。若现在前。设成就现在彼成就过去也。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就未来彼成就现在耶。答曰。若现在前。设成就现在彼成就未来耶。答曰。如是。若成就过去彼成就未来现在耶。答曰。未来成就现在。若现在前。设成就未来现在彼成就过去耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就未来彼成就过去现在耶。答曰。成就未来非过去现在。及过去非现在。及现在非过去。及过去现在。云何成就未来非过去现在。答曰。若得空三昧。不尽设尽便失不现在前。是谓未来非过去现在。云何未来及过去非现在。答曰。若得空三昧尽不失。又彼空三昧不现在前。是谓未来及过去非现在。云何未来及现在非过去耶。答曰。若空三昧现在前。若不尽设尽便失。是谓未来及现在非过去。云何未来及过去现在。答曰。若空三昧尽不失。又彼空三昧现在前。是谓未来及过去现在。设成就过去现在。彼成就未来耶。答曰。如是。若成就现在彼成就过去未来耶。答曰。未来成就过去。若尽不失则成就。若不尽设尽便失则不成就。设成就过去未来。彼成就现在耶。答曰。若现在前。无愿无相亦如是(六竟)。若成就过去空三昧。彼成就过去无愿耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。设成就过去无愿。彼成就过去空耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就过去空三昧。彼成就未来无愿。答曰。如是。设成就未来无愿。彼成就过去空耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就过去空。彼成就现在无愿耶。答曰。若现在前。设成就现在无愿。彼成就过去空耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就过去空。彼成就过去现在无愿耶。答曰。或成就过去空非过去现在无愿。及过去非现在。及现在非过去。及过去现在无愿。云何成就过去空。非过去现在无愿。答曰。若空三昧尽不失。又彼无愿三昧不尽设尽便失亦不现在前。是谓成就过去空三昧。非过去现在无愿。云何成就过去空。及过去无愿非现在。答曰。若空无愿三昧尽不失。又彼无愿三昧不现在前。是谓成就过去空及过去无愿非现在。云何成就过去空。及现在无愿非过去。答曰。若空三昧尽不失。又彼无愿三昧现在前不尽。若尽便失是谓成就过去空。及现在无愿非过去。云何成就过去空。及过去现在无愿。答曰。若空无愿三昧尽不失。又彼无愿三昧现在前。是谓成就过去空及过去现在无愿。设成就过去现在无愿。彼成就过去空耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就过去空。彼成就未来现在无愿耶。答曰。未来成就现在。若现在前。设成就未来现在无愿。彼成就过去空耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就过去空三昧。彼成就过去未来无愿耶。答曰。未来成就过去。若尽不失则成就。若不尽设尽便失则不成就。设成就过去未来无愿。彼成就过去空耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就过去空。彼成就过去未来现在无愿耶。答曰。或成就过去空及未来无愿非过去现在。及过去未来非现在。及未来现在非过去。及过去未来现在无愿。云何成就过去空及未来无愿。非过去现在。答曰。若空三昧尽不失。又彼得无愿三昧。不尽设尽便失亦不现在前。是谓成就过去空及未来无愿。非过去现在。云何成就过去空三昧。及过去未来无愿非现在。答曰。若空无愿三昧已尽不失。又彼无愿三昧不现在前。是谓成就过去空。及过去未来无愿非现在。云何成就过去空。及未来现在无愿非过去。答曰。若空三昧尽不失。又彼无愿三昧现在前。不尽设尽便失。是谓成就过去空。及未来现在无愿非过去。云何成就过去空。及过去未来现在无愿。答曰。若空无愿三昧尽不失。又彼无愿三昧现在前。是谓成就过去空。及过去未来现在无愿。设成就过去未来现在无愿。彼成就过去空耶。答曰。若尽不失则成就。若不尽设尽便失则不成就(空愿七竟)。若成就过去空三昧。彼成就过去无相耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。设成就过去无相。彼成就过去空耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就过去空。彼成就未来无相耶。答曰。若得设成就未来无相。彼成就过去空耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就过去空。彼成就现在无相耶。答曰。若现在前。设成就现在无相。彼成就过去空耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就过去空。彼成就过去现在无相耶。答曰。或成就过去空。非过去现在无相。及过去非现在。及现在非过去。及过去现在无相。云何成就过去空。非过去现在无相。答曰。若空三昧尽不失。又彼无相三昧不尽设尽便失亦不现在前。是谓成就过去空非过去现在无相。云何成就过去空。及过去无相非现在。答曰。若空无相三昧尽不失。又彼无相三昧不现在前。是谓成就过去空。及过去无相非现在。云何成就过去空。及现在无相非过去。答曰。若空三昧尽不失。又彼无相三昧现在前。不尽设尽便失。是谓成就过去空。及现在无相三昧非过去。云何成就过去空。及过去现在无相。答曰。若空无相三昧尽不失。又彼无相三昧现在前。是谓成就过去空三昧。及过去现在无相。设成就过去现在无相。彼成就过去空耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就过去空。彼成就未来现在无相耶。答曰。或成就过去空非未来现在无相。及未来非现在。及未来现在无相。云何成就过去空。非未来现在无相。答曰。若空三昧尽不失。又彼不得无相三昧。是谓成就过去空。非未来现在无相。云何成就过去空。及未来无相非现在。答曰。若空三昧尽不失。又彼得无相三昧不现在前。是谓成就过去空。及未来无相非现在。云何成就过去空。及未来现在无相。答曰。若空三昧尽不失。又彼无相三昧现在前。是谓成就过去空。及未来现在无相。设成就未来现在无相。彼成就过去空耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就过去空。彼成就过去未来现在无相耶。答曰。或成就过去空非过去未来现在无相。及未来非过去现在。及过去未来非现在。及未来现在非过去。及过去未来现在无相。云何成就过去空非过去未来现在无相。答曰。若空三昧尽不失。又彼不得无相三昧。是谓成就过去空非过去未来现在无相。云何成就过去空。及未来无相非过去现在。答曰。若空三昧尽不失。又彼得无相三昧。不尽设尽便失亦不现在前。是谓成就过去空。及未来无相非过去现在。云何成就过去空。及过去未来无相非现在。答曰。若空无相三昧尽不失。又彼无相三昧不现在前。是谓成就过去空。及过去未来无相非现在。设成就过去未来无相。彼成就过去空耶。答曰。若尽不失则成就。若不尽设尽便失则不成就。若成就过去空。彼成就过去未来现在无相。答曰。或成就过去空。非过去未来现在无相。及未来非过去现在。及过去未来非现在。及未来现在非过去。及过去未来现在无相。云何成就过去空。非过去未来现在无相。答曰。若空三昧尽不失。又彼不得无相三昧。是谓成就过去空。非过去未来现在无相。云何成就过去空。及未来无相非过去现在。答曰。若空三昧尽不失。又彼得无相三昧。不尽设尽便失亦不现在前。是谓成就过去空。及未来无相非过去现在。云何成就过去空。及过去未来无相非现在。答曰。若空无相三昧尽不失。又彼无相三昧不现在前。是谓成就过去空。及过去未来无相非现在。云何成就过去空。及未来现在无相非过去。答曰。若空三昧尽不失。又彼无相三昧现在前。不尽设尽便失。是谓成就过去空。及未来现在无相非过去。云何成就过去空。及过去未来现在无相。答曰。若空无相三昧尽不失。又彼无相三昧现在前。是谓成就过去空。及过去未来现在无相。设成就过去未来现在无相。彼成就过去空耶。答曰。若尽不失则成就。若不尽设尽便失则不成就(空无相七竟)。如空无相无愿亦尔。过去空过去无愿过去无相(一也)未来(二也)现在(三也)过去现在(四也)未来现在(五也)过去未来(六也)过去未来现在无相(七无相七竟)。若修空三昧彼修无愿耶。答曰。或空非无愿。云何空非无愿。答曰。本得空三昧现在前。是谓空非无愿。云何无愿非空。答曰。本得无愿三昧现在前。若本不得无愿三昧现在前。不得是时修空三昧。是谓无愿非空。云何空无愿。答曰。本不得空三昧现在前。得是时修无愿三昧。若本不得无愿三昧现在前。得是时修空三昧。若本不得无相。若本不得世俗智现在前。是时修空无愿三昧。是谓空无愿。云何非空无愿。答曰。若本得若本不得。无相三昧现在前。若本得世俗智。若本不得世俗智现在前。是时非修空无愿三昧。一切凡夫人染污心无记心。入无想三昧灭尽三昧无想天。不修空三昧非无愿。是谓非空非无愿。若修空三昧彼修无相耶。答曰。或空非无相。云何空非无相。答曰。本得空三昧现在前。若本不得空三昧现在前。不得是时修无相三昧。若本不得无愿三昧现在前。得是时修空三昧非无相。是谓空非无相。云何无相非空。答曰。本得无相三昧现在前。若本不得无相三昧现在前。不得是时修空三昧。是谓无相非空。云何空无相。答曰。本不得空三昧现在前。得是时修无相三昧。若本不得无相三昧现在前。得是时修空三昧。若本不得无愿。若本不得世俗智现在前。是时修空无相三昧。是谓修空无相。云何非修空非修无相。答曰。若本得若本不得无愿三昧现在前。本得世俗智。若本不得世俗智现在前。不得是时修空无相三昧。一切凡夫人染污心无记心。入无相三昧灭尽三昧无想天。非修空三昧非无相。是谓非空非无相。若修无愿三昧。彼修无相耶。答曰。或无愿非无相。云何无愿非无相耶。答曰。本得无愿三昧现在前。若本不得无愿三昧现在前。不得是时修无相三昧。若本不得空三昧现在前。得是时修无愿三昧非无相。是谓无愿非无相。云何无相非无愿。答曰。本得无相三昧现在前。若本不得无相三昧现在前。不得是时修无愿三昧。是谓无相非无愿。云何无愿无相。答曰。本不得无愿三昧现在前。得是时修无相三昧。若本不得无相三昧现前。得是时修无愿三昧。若本不得空。若本不得世俗智现在前。得是时修无愿无相三昧。是谓修无愿无相。云何非修无愿无相。答曰。本得空三昧现在前。本得世俗智。若本不得世俗智现在前。不得是时修无愿无相三昧。一切凡夫人染污心无记心。入无相三昧灭尽三昧无想天。非修无愿三昧非无相。是谓非无愿无相。颇结空灭非无愿非无相耶。答曰。不灭。无愿灭非空非无相耶。答曰。灭诸结。习谛道谛断无愿断无相灭非空非无愿耶。答曰。灭诸结。尽谛断无相断空无愿灭非无相耶。答曰。灭诸结。苦谛断空无愿灭空无相灭非无愿耶。答曰。不灭。无愿无相灭非空耶。答曰。不灭。空无愿无相灭。答曰。灭诸结。学见迹思惟灭。颇结非空非无愿非无相灭。而灭结耶。答曰。灭诸结凡夫人灭。云何意所念越次取证。答曰。无常苦空无我。何系行意所念越次取证。答曰。欲界系尽智。当言身身观意止耶。答曰。尽智。或彼身身观意止。或痛心法法观意止。无生智亦如是。诸无漏初禅乐。诸猗觉意此何差别。答曰。无差别。诸无漏第二禅乐。诸猗觉意此何差别。答曰。无差别。从三昧起彼从缘起耶。答曰。或三昧起非缘。云何三昧起非缘。答曰。犹如有一诸想意所念入初禅。彼意所念想入第二禅。是谓三昧起非缘。云何缘起非三昧。答曰。犹如有一诸想意所念入初禅。彼如其定余二想意所念。是谓缘起非三昧。云何三昧起缘。答曰。犹如有一诸想意所念入初禅。彼意所念余第二想入第二禅。是谓三昧起缘。云何非三昧起非缘。答曰。犹如有一诸想意所念入初禅。彼如其定久住。是谓非三昧起非缘。又世尊言。所谓想三昧齐是得教。若世尊弟子生有想无想处。彼依何等逮阿罗汉果。答曰。无漏不用定。又尊者大目犍连言。我自忆诸贤。在耆阇崛山醍醐池侧入不用定。有众多龙象擎鼻哮吼闻声。尊者大目犍连入定闻声起闻耶。答曰。尊者大目犍连起闻声非入定。诸不定彼一切无明实无明语耶。答曰。如是。诸不定彼一切无明实无明语。颇无明实无明语。彼非不定耶。答曰。有邪定也。诸定彼一切明实明语。答曰。如是。诸明实明语。彼一切定也。颇定彼非明实明语。答曰。有邪定也。诸不定彼一切不成就觉意耶。答曰。如是。诸不定彼一切不成就觉意也。颇不成就觉意彼非不定耶。答曰。有邪定。诸定彼一切成就觉意耶。答曰。如是。诸成就觉意彼一切定。颇定彼非觉意成就耶。答曰。有邪定。若成就觉意。彼成就无漏法耶。答曰。如是。诸成就觉意彼成就无漏法。颇成就无漏法非觉意耶。答曰。有凡夫人也。若不成就觉意。彼不成就无漏法耶。答曰。无有不成就无漏法。有不成就觉意凡夫人也。若得觉意彼得无漏法耶。答曰。如是。若得觉意彼得无漏法。颇得无漏法非觉意耶。答曰。有凡夫人也。若弃觉意彼弃无漏法耶。答曰。无有弃无漏法。无有尽弃觉意。若退觉意彼退无漏法耶。答曰。无有退无漏法。无有尽退觉意。若不尽彼不知耶。答曰。如是。诸不知彼不尽。颇不尽彼非不知耶。答曰。有诸知已知非断。知尽诸尽彼知耶。答曰。如是。诸尽彼知也。颇知非尽耶。答曰。有诸知已知非断智尽。诸于此生眼本不见色。彼后辨天眼。彼依何等辨天眼。答曰。犹如有一性自识宿命。彼本于余生眼见色。依彼辨天眼耳声亦如是。以何等故凡夫人退见谛思惟断结还得。世尊弟子思惟断耶。答曰。凡夫人所可用道见谛断结灭。彼思惟断于彼道退得彼结系也。世尊弟子以余道见谛断结灭余思惟断。彼所可用道见谛断结灭。于彼道不退。所可用道思惟断结灭。于彼或有退或有不退。彼世尊弟子所可用道见谛思惟断结灭。彼道思惟断结灭彼道不退。以何等故阿罗汉果退非须陀洹果。答曰。见谛断法无替思惟断有替。彼有净想无净想。彼净想不顺意所念不顺无净想。退彼无一法若我。若无是我诸彼取我无我见退。以何等故阿那含斯陀含果退。然非须陀洹果。答曰。见谛断法不替思惟断替。彼有净想不净想。彼不顺意所念。不顺不净想。退彼无一法若无我。是我诸彼取我无我见退。阿罗汉果退诸得无漏根力觉道种。当言本得得。当言本不得得。答曰。当言本得得。阿那含果斯陀含果。退诸得无漏根力觉道种。当言本得得。当言本不得得。答曰。当言本得得。无色界没生欲界。诸得持阴入四大。善根不善根无记根。结缚使垢缠。当言本得得。当言本不得得。答曰。善若染污当言本得得报。当言本不得得。无色界没生色界。诸得持阴入四大。善根无记根结缚使垢缠。当言本得得。当言本不得得。答曰。善若染污当言本得得报。当言本不得得。色界没生欲界。诸得持入阴四大。善根不善根无记根。结缚使垢缠。当言本得得。当言本不得得。答曰。善若染污当言本得得。报当言本不得得。若依初禅修神足智证通修道。彼齐能至几所。答曰。梵天。若依初禅彻听智证通修道。彼齐能何系耳闻声。答曰。梵天上系。若依初禅知他人心智证通修道。彼齐能何系知他人心法。答曰。梵天上系。若依初禅自识宿命智证通修道修。彼齐能何系自识宿命。答曰。梵天上系。若依初禅彻视智证通修道。彼齐能何系眼见色。答曰。梵天上系。第二光音系。第三遍净系。第四果实系。若意所念苦苦逮阿罗汉果。彼何系意所念苦苦逮阿罗汉果。答曰。无色界系。习亦如是。若意所念尽尽逮阿罗汉果。彼何系行意所念尽尽逮阿罗汉果。答曰。或欲界系。或色界系。或无色界系。若意所念道道逮阿罗汉果。彼何系行意所念道道逮阿罗汉果。答曰。或欲界系。或色无色界系

阿毗昙一行跋渠第五竟

定犍度第七竟

阿毗昙八犍度论卷第二十八阿毗昙八犍度论卷第二十九

        迦旃延子造

        符秦罽宾三藏僧伽提婆共竺佛念译

    见犍度第八

意止　欲　想　缘智　见　偈品在后

    意止跋渠第一

四意止。身身观意止。痛心法法观意止。若修身身观意止彼修痛耶。设修痛彼修身耶。若修身身观意止彼修心耶。设修心彼修身耶。若修身身观意止彼修法耶。设修法彼修身耶。若修痛痛观意止彼修心耶。设修心彼修痛耶。若修痛痛观意止彼修法耶。设修法彼修痛耶。若修心心观意止彼修法耶。设修法彼修心耶。身身观意止。当言法智未知智知他人心智。等智苦智习尽道智耶。当言有觉有观耶。当言无觉有观耶。当言无觉无观耶。当言乐根相应喜根护根空无愿无相耶。当言欲界系缘。色无色界系缘。当言不系缘耶。痛心法法观意止亦如是。又世尊言。彼乐痛痛时知乐痛痛。此智当言法智耶。当言乃至道智。苦痛痛时知苦痛痛。不苦不乐痛痛时。知不苦不乐痛痛。此智当言法智。当言乃至道智。乐身苦身不苦不乐身。乐心苦心不苦不乐心。乐食苦食不苦不乐食。乐不食苦不食。不苦不乐不食。依乐戆依苦戆。依不苦不乐戆。依乐出要。依苦出要。依不苦不乐出要痛痛时。知不苦不乐出要。此痛智当言法智。当言乃至道智。又世尊言。彼有欲心彼有欲心如实知之。此智当言法智。当言乃至道智。无欲有嗔恚。无嗔恚有愚痴。无愚痴有染污。无染污有乱。无乱有怠。无怠少多。修不修定。不定有解脱心无解脱心如实知之。无解脱心解脱心如实知之。此智当言法智。当言乃至道智。又世尊言。眼缘色生内结。彼比丘实彼内结有。此内结如实知之。不实彼内结无。此内结如实知之。如未生内结。便生已生。便尽已尽便不生。彼亦如实知之。此智当言法智。当言乃至道智。耳鼻舌身亦如是。意缘法生内贪欲。彼比丘实彼内贪欲。有此内贪欲如实知之。不实内贪欲无此内贪欲如实知之。如未生内贪欲便生已生便尽已尽。不生彼亦如实知之。此智当言法智。当言乃至道智耶。嗔恚睡眠调戏疑亦如是。生内念觉意。彼比丘实彼内念觉意有。此内念觉意如实知之。不实内念觉意无。此内念觉意如实知之。如未生内念觉意。便生已生便住。不忘不退益广思惟满。此亦如实知之。此智当言法智。当言乃至道智耶。法精进喜猗定护觉意亦如是。又世尊言。彼自观淫嗔恚愚痴盛。彼云何淫嗔恚愚痴盛。又世尊言。彼自观淫嗔恚愚痴薄。彼云何淫嗔恚愚痴薄。云何死时痛齐何处。死时痛死时痛何入摄。几识识。阿罗汉当言善心般涅槃。当言无记心般涅槃。以何等故。佛世尊先二弟子般涅槃。然后佛世尊。又世尊言。入不移动三昧如来般涅槃。如来入定般涅槃。起般涅槃四有。本时有死有中有生有。彼云何本时有。云何死有。云何中有。云何生有。诸欲有彼一切有五行耶。设有五行彼一切欲有耶。诸色有想天彼一切有五行耶。设有五行彼一切色有想天耶。诸色有无想天。彼一切有二行耶。设有二行彼一切色有无想天耶。诸无色有彼一切有四行耶。设有四行彼一切无色有耶。颇有五行。四行三行二行一行耶。此章义愿具演说

四意止身身观意止。痛心法法观意止。若修身身观意止。彼修痛耶。答曰。或身非痛。云何身非痛。答曰。本得身身观意止现在前。是谓身非痛。云何痛非身。答曰。本得痛痛观意止现在前。若本不得痛痛观意止现在前。不得是时修身身观意止现在前。若本不得心。若本不得法。得是时修痛痛观意止非身。是谓痛非身。云何身痛。答曰。本不得身得是时痛。若本不得痛得是时身。若本不得心本不得法。得是时身修痛痛观意止。是谓身痛。云何非身非痛。答曰。本得心本得法。若本不得法法观意止现在前。不得是时修身痛痛观意止现在前。一切染污心无记心。入无想定灭尽定无想天。非修身身观意止非痛。是谓非身非痛。若修身身观意止彼修心耶。答曰。或身非心。云何身非心。答曰。本得身身观意止现在前。是谓身非心。云何心非身。答曰。本得心心观意止现在前。若本不得心心观意止现在前。不得是时修身身观意止。若本不得痛本不得法。得是时修心心观意止非身。是谓心非身。云何身心。答曰。本不得身。得是时心。若本不得心得是时身。若本不得痛本不得法。得是时修身心心观意止。是谓身心。云何非身非心。答曰。本得痛本得法。本不得法法观意止现在前。不得是时修身心心观意止。一切染污心无记心。入无想三昧灭尽三昧无想天。非修身身观意止非心。是谓非身非心。若修身身观意止。彼修法耶。答曰。或身非法。云何身非法。答曰。本得身身观意止现在前。是谓身非法。云何法非身。答曰。本得法法观意止现在前。若本不得法法观意止现在前。不得是时修身身观意止。若本不得痛。本不得心。得是时修法法观意止非身。是谓法非身。云何身法。答曰。本不得身得是时法。若本不得法得是时身。若本不得痛本不得心。得是时修身法法观意止。是谓身法。云何非身非法。答曰。本得痛本得心心观意止现在前。不得是时修身法法观意止。一切染污心无记心。入无想三昧灭尽三昧无想天。不修身身观意止非法。是谓非身非法。若修痛痛观意止。彼修心耶。答曰。或痛非心。云何痛非心。答曰。本得痛痛观意止现在前。是谓痛非心。云何心非痛。答曰。本得心心观意止现在前。是谓心非痛。云何痛心。答曰。本不得痛。得是时心。本不得心得是时痛。若本不得身。本不得法。得是时修痛心心观意止。是谓痛心。云何非痛非心。答曰。本得身本得法。若本不得法法观意止现在前。不得是时修痛心心观意止。一切染污心无记心。入无想三昧灭尽三昧无想天。非修痛痛观意止非心。是谓非痛非心也。若修痛痛观意止。彼修法耶。答曰。或痛非法。云何痛非法。答曰。本得痛痛观意止现在前。是谓痛非法。云何法非痛。答曰。本得法法观意止现在前。若本不得法法观意止现在前。不得是时修痛痛观意止。是谓法非痛。云何痛法。答曰。本不得痛是时得法。本不得法是时得痛。本不得身本不得心。得是时修痛法法观意止。是谓痛法。云何非痛非法。答曰。本得身本得心心观意止现在前。不得是时修痛法法观意止。一切染污心无记心。入无想三昧灭尽三昧无想天。不修痛痛观意止非法。是谓非痛非法。若修心心观意止。彼修法耶。答曰。或心非法。云何心非法。答曰。本得心心观意止现在前。是谓心非法。云何法非心。答曰。本得法法观意止现在前。若本不得法法观意止现在前。不得是时修心心观意止。是谓法非心。云何心法。答曰。本不得心是时得法。若本不得法是时得心。本不得身本不得痛。得是时修心法法观意止。是谓心法。云何非心非法。答曰。本得身本得痛痛观意止现在前。不得是时修心法法观意止。一切染污心无记心。入无想三昧灭尽三昧无想天。非修心心观意止非法。是谓非心非法。身身观意止当言法智耶。答曰。身身观意止。或彼法智未知智。等智苦智习智道智。或有觉有观。或无觉有观。或无觉无观。或乐根相应。或喜根或护根。或空或无愿。或欲界系缘。或色界系缘。或不系缘。痛痛观意止。当言法智耶。答曰。痛痛观意止。或彼法智未知智知他人心智。等智苦智习道智。或有觉有观。或无觉有观。或无觉无观。或乐根相应。或喜根或护根。或空或无愿。或欲界系缘。或色无色界系缘。或不系缘。心心观意止亦如是。法法观意止。当言法智耶。答曰。法法观意止。或彼法智未知智知他人心智。等智苦智习尽道智。或有觉有观。或无觉有观。或无觉无观。或乐根相应或喜根或护根。或空无愿无相。或欲界系缘。或色无色界系缘。或不系缘。又世尊言。彼乐痛痛时知乐痛痛。四智法智未知智等智道智。苦痛痛时知苦痛痛一等智。不苦不乐痛痛时。知不苦不乐痛痛。四智法智未知智等智道智。乐身苦身不苦不乐身苦心一等智。乐心不苦不乐心。四智法智未知智等智道智。苦食乐食不苦不乐食苦无食。一等智乐无食不苦不乐无食。四智法智未知智等智道智。依乐戆。依苦戆。依不苦不乐戆。依苦出要。一等智。依乐出要依不苦不乐出要。四智法智未知智等智道智。又世尊言。有欲心有欲心如实知之。一等智。无欲四智法智未知智等智道智。有嗔恚一等智。无嗔恚三智法智等智道智。有愚痴一等智。无愚痴四智法智未知智等智道智。有染污一等智。无染污四智法智未知智等智道智无。乱四智法智未知智等智道智。有乱一等智。有怠一等智。无怠四智法智未知智等智道智。少一等智。多四智法智未知智等智道智。不修一等智。修四智法智未知智等智道智。不定一等智。定四智法智未知智等智道智。无解脱一等智。解脱四智法智未知智等智道智。又世尊言。眼缘色生内结。彼比丘实内结有。此内结如实知之一等智。不实内结无。此内结如实知之。四智法智未知智等智道智。如未生内结便生。彼亦如实知之。彼一等智。如生便尽已尽不生此亦如实知之。四智法智未知智等智道智。耳声身细滑意法亦如是。鼻缘香生内结。彼比丘实内结有。此内结如实知之一等智。不实内结无。此内结如实知之。三智法智等智道智。如未生内结便生。此亦如实知之一等智。如生便尽已尽不生此亦如实知之。三智法智等智道智。舌味贪欲嗔恚睡眠调戏疑亦如是生。内念觉意。彼比丘实内念觉意。有此内念觉意如实知之。四智法智未知智等智道智。不实内念觉意无。此内念觉意如实知之一等智。如未生内念觉意。便生已生便住。不忘不退增益思惟广满。彼亦如实知之。四智法智未知智等智道智。法精进喜猗定护觉意亦如是。又世尊言。彼自观淫嗔恚愚痴盛。彼云何淫嗔恚愚痴盛。答曰。少淫嗔恚愚痴。处中中便增上。如是淫嗔恚愚痴盛。又世尊言。彼自观淫嗔恚愚痴薄。彼云何淫嗔恚愚痴薄。答曰。增淫嗔恚愚痴中中便少。如是淫嗔恚愚痴薄。云何死时痛。答曰。诸节节疼。若命行尽齐何处死时痛。答曰。齐支节疼。命行尽死时痛一入摄细滑入。二识识身识意识。支节疼先身识后意识。阿罗汉当言善心般涅槃。无记心般涅槃。答曰。阿罗汉无记心般涅槃。以何等故佛世尊先二弟子般涅槃。后佛世尊。答曰。彼尊者长夜作无断行受报。彼莫使空无果无报。复次佛世尊常法先二弟子般涅槃后佛世尊。又世尊言。入不移动三昧如来般涅槃。如来入定般涅槃起般涅槃。答曰。如来起般涅槃非入定。四有本时有死有中有生有。云何本时有。答曰。死生际五阴。于此中间齐是诸有。是谓本时有。云何死有。答曰。死五阴。是谓死有。云何中有。答曰。中有五阴。是谓中有。云何生有。答曰。生五阴。是谓生有。诸欲有彼一切有五行耶。答曰。或欲有彼有非五行。云何欲有彼有非五行。答曰。欲界众生不自住心。入无想定灭尽定诸有。是谓欲有彼有非五行。云何有五行彼非欲有。答曰。色界想天自住心。不入无想定灭尽定。诸有若色界无想天不得无想诸有。是谓有五行彼非欲有。云何欲有彼有五行。答曰。欲界众生自住心不入无想定灭尽定诸有。是谓欲有彼有五行。云何非欲有彼有非五行。答曰。色界想天不自住心。入无想定灭尽定。诸有若色界无想天得无想。诸有若无色界有。是谓非欲有彼有非五行。诸色有想天彼一切有五行耶。答曰。或色有想天彼有非五行。云何色有想天彼有非五行。答曰。色界想天不自住心。入无想定灭尽定。诸有是谓色有想天彼有非五行。云何有五行彼非色有想天。答曰。欲界众生自住心不入无想定灭尽定。诸有若色界无想天不得无想。诸有是谓有五行彼非色有想天。云何色有想天彼有五行。答曰。色界想天自住心。不入无想定灭尽定。诸有是谓色有想天。彼有五行。云何非色有想天彼有非五行。答曰。欲界众生不自住心。入无想定灭尽定。诸有若色界无想天得无想。诸有若无色界有。是谓非色有想天彼有非五行。诸色有无想天。彼一切有二行耶。答曰。或色有无想天。彼有非二行。云何色有无想天彼有非二行。答曰。色界无想天不得无想诸有。是谓色有无想天。彼有非二行。云何有二行。彼非色有无想天。答曰。欲界众生不自住心。入无想定灭尽定。诸有色界想天不自住心。入无想定灭尽定诸有。是谓有二行彼非色有无想天。云何色有无想天彼有二行。答曰。色界无想天得无想诸有。是谓色有无想天彼有二行。云何非色有无想天彼有非二行。答曰。欲界众生自住心不入无想定灭尽定。诸有若色界想天。自住心不入无想定灭尽定。诸有无色界有。是谓非色有无想天彼有非二行。诸无色界有彼有尽四行耶。答曰。如是。诸有四行彼尽无色界有。颇无色界有彼有非四行耶。答曰。有无色界众生不自住心。诸有颇有五行耶。答曰有。欲界众生自住心不入无想定灭尽定诸有也。色界有想天自住心不入无想定灭尽定。诸有若色界无想天不得无想。诸有颇有四行耶。答曰有。无色界众生自住心。诸有颇有三行耶。答曰无。有三行。颇有二行。答曰有。欲界众生不自住心入无想定灭尽定。诸有色界想天不自住心。入无想定灭尽定。诸有色界无想天得无想天诸有。颇有一行耶。答曰有。无色界众生不自住心诸有

阿毗昙意止品第三十九竟(梵本三百一十五首卢秦四千六百二十二言)

    阿毗昙见犍度中欲跋渠第二

若弃欲界有受欲界有。彼一切尽欲界系法。欲界系法现在前耶。设尽欲界系法。欲界系法现在前。彼一切弃欲界有受欲界有。若弃欲界有受色界有。彼一切尽欲界系法。色界系法现在前耶。设尽欲界系法色界系法现在前。彼一切弃欲界有。受色界有耶。若弃欲界有受无色界有。彼一切尽欲界系法。无色界系法现在前。设尽欲界系法。无色界系法现在前。彼一切弃欲界有。受无色界有耶。若弃色界有。受色界有。彼一切尽色界系法。色界系法现在前耶。设尽色界系法。色界系法现在前。彼一切弃色界有。受色界有耶。若弃色界有。受欲界有。彼一切尽色界系法。欲界系法现在前耶。设尽色界系法。欲界系法现在前。彼一切弃色界有。受欲界有耶。若弃色界有受无色界有。彼一切尽色界系法。无色界系法现在前耶。设尽色界系法。无色界系法现在前。彼一切弃色界有。受无色界有耶。若弃无色界有。受无色界有。彼一切尽无色界系法。无色界系法现在前耶。设尽无色界系法。无色界系法现在前。彼一切弃无色界有。受无色界。有若弃无色界有。受欲界有。彼一切尽无色界系法。欲界系法现在前耶。设尽无色界系法。欲界系法现在前。彼一切弃无色界有。受欲界有耶。若弃无色界有。受色界有。彼一切尽无色界系法。色界系法现在前耶。设尽无色界系法。色界系法现在前。彼一切弃无色界有。受色界有耶。以何等故欲界使非色界无色界所使。以何等故色界使非欲界无色界所使。以何等故无色界使非欲界色界所使。以何等故欲界非遍一切使。非一切欲界所使。以何等故色界非遍一切使。非一切色界所使。以何等故无色界非遍一切使。非一切无色界所使。十想无常想无常苦想苦无我想。不净想观食想一切世间不可乐想。死想断想无淫想尽想。若修无常想彼意所念无常想耶。设意所念无常想彼修无常想耶。乃至尽想亦如是。若欲觉觉时彼意所念欲觉耶。设意所念欲觉彼欲觉觉耶。嗔恚害觉亦如是。若出要觉觉时彼意所念出要觉耶。设意所念出要觉。彼出要觉觉时耶。无嗔恚无害觉亦如是。诸法因无明彼法缘无明耶设法缘无明。彼法因无明耶。诸法因明彼法缘明耶。设法缘明彼法因明耶。诸法因无明彼法缘明耶。设法缘明彼法因无明耶。诸法因明彼法缘无明耶。设法缘无明彼法因明耶。诸法因无明彼法不善耶。设法不善彼法因无明耶。诸法因明彼法善耶。设法善彼法因明耶。颇法不因明不因无明。彼法非不因有因耶。此章义愿具演说

若弃欲界有受欲界有。彼一切尽欲界系法。欲界系法现在前耶。答曰。如是。若弃欲界有受欲界有。彼一切尽欲界系法。欲界系法现在前。颇尽欲界系法。欲界系法现在前。彼非弃欲界有。不受欲界有耶。答曰有。如未命终尽欲界系法。欲界系法现在前也。若弃欲界有受色界有。彼一切尽欲界系法。色界系法现在前。答曰。如是。若弃欲界有受色界有。彼一切尽欲界系法。色界系法现在前。颇尽欲界系法。色界系法现在前。彼非弃欲界有。非受色界有耶。答曰有。如未命终尽欲界系法。色界系法现在前也。若弃欲界有受无色界有。彼一切尽欲界系法。无色界系法现在前。答曰。如是。设尽欲界系法。无色界系法现在前。彼一切弃欲界有。受无色界有耶。答曰。如是。若弃色界有受色界有。彼一切尽色界系法。色界系法现在前。答曰。如是。若弃色界有受色界有。彼一切尽色界系法。色界系法现在前也。颇尽色界系法。色界系法现在前。彼非弃色界有。非受色界有耶。答曰有。如未命终尽色界系法。色界系法现在前也。若弃色界有。受欲界有。彼一切尽色界系法。欲界系法现在前。答曰。如是。若弃色界有受欲界有。彼一切尽色界系法。欲界系法现在前。颇尽色界系法。欲界系法现在前。彼非弃色界有。非受欲界有耶。答曰有。如未命终尽色界系法。欲界系法现在前也。若弃色界有受无色界有。彼一切尽色界系法。无色界系法现在前。答曰。如是。若弃色界有受无色界有。彼一切尽色界系法。无色界系法现在前。颇尽色界系法。无色界系法现在前。彼非弃色界有。不受无色界有。答曰有。如未命终尽色界系法。无色界系法现在前也。若弃无色界有受无色界有。彼一切尽无色界系法。无色界系法现在前。答曰。如是。若弃无色界有。受无色界有。彼一切尽无色界系法。无色界系法现在前。颇尽无色界系法。无色界系法现在前。彼不弃无色界有。不受无色界有耶。答曰有。如未命终尽无色界系法。无色界系法现在前。若弃无色界有受欲界有。彼一切尽无色界系法。欲界系法现在前耶。答曰。如是。设尽无色界系法。欲界系法现在前。彼一切弃无色界有。受欲界有耶。答曰。如是。若弃无色界有受色界有。彼一切尽无色界系法。色界系法现在前。答曰。如是。若弃无色界有受色界有。彼一切尽无色界系法。色界系法现在前。颇尽无色界系法。色界系法现在前。彼不弃无色界有。非受色界有。答曰有。如未命终尽无色界系法。色界系法现在前也。以何等故欲界使。非色无色界所使耶。答曰。则界坏。若欲界无爱无知也。以何等故色界使非欲界所使。答曰。则界坏。然彼非此缘。以何等故色界使非无色界所使。答曰。则界坏。色界无爱无知。以何等故无色界使非欲界色界所使。答曰。则界坏。然彼非此缘。以何等故欲界非一切遍使。非一切欲界所使。答曰。遍一切有。彼亦非此缘。以何等故色界非一切遍使。非一切色界所使耶。答曰。遍一切有。彼亦非此缘。以何等故无色界非一切遍使。非一切无色界所使耶。答曰。遍一切有。彼亦非此缘。十想无常想无常苦想苦无我想不净想。观食想一切世间不可乐想。死想断想无淫想尽想。若修无常想彼意所念无常想耶。答曰。或修无常想。彼非意所念无常想。云何修无常想。彼非意所念无常想。答曰。犹如余缘修无常想。是谓修无常想。彼非意所念无常想。云何意所念无常想彼。非修无常想。答曰。犹如余意所念无常想。是谓意所念无常想。彼非修无常想也。云何修无常想彼意所念无常想耶。答曰。如缘无常想修无常想。是谓修无常想。彼意所念无常想也。云何非修无常想。彼非意所念无常想耶。答曰。除上尔所事。乃至尽想亦如是。若欲觉觉时。彼意所念欲觉耶。答曰。或欲觉觉时彼非意所念欲觉。云何欲觉觉时。彼非意所念欲觉耶。答曰。犹如余缘欲觉觉时。是谓欲觉觉时彼非意所念欲觉也。云何意所念欲觉。彼非欲觉觉时。答曰。犹如余意所念欲觉。是谓意所念欲觉彼非欲觉觉时。云何欲觉觉时。彼意所念欲觉耶。答曰。犹如欲觉缘欲觉觉时。是谓欲觉觉时彼意所念欲觉也。云何非欲觉觉时。彼非意所念欲觉。答曰。除上尔所事嗔恚害觉亦如是。若出要觉觉时。彼意所念出要觉耶。答曰。或出要觉觉时。彼非意所念出要觉。云何出要觉觉时。彼非意所念出要觉耶。答曰。犹如余缘出要觉觉时。是谓出要觉觉时。彼非意所念出要觉。云何意所念出要觉。彼非出要觉觉时。答曰。犹如余意所念出要觉。是谓意所念出要觉。彼非出要觉觉时也。云何出要觉觉时。彼意所念出要觉。答曰。犹如出要觉缘出要觉觉时。是谓出要觉觉时。彼意所念出要觉也。云何非出要觉觉时。彼非意所念出要觉。答曰。除上尔所事。无嗔恚不害觉亦如是。诸法因无明彼法缘无明耶。答曰。如是。诸法因无明彼法缘无明。颇法缘无明彼法不因无明耶。答曰有。除无明报诸余不隐没无记行若善行也。诸法因明彼法缘明耶。答曰。如是。诸法因明彼法缘明也。颇法缘明彼法不因明耶。答曰。有初明若有漏行也。诸法因无明彼法缘明耶。答曰。如是。诸法因无明彼法缘明也颇法缘明彼法不因无明耶。答曰。有除无明报。诸余不隐没无记行。若善行也。诸法因明彼法缘无明耶。答曰。如是。诸法因明彼法缘无明也。颇法缘无明彼法不因明耶。答曰有。初明若有漏行也。诸法因无明彼法不善耶。答曰。如是。诸法不善彼法因无明也。颇法因无明彼法非不善耶。答曰有。无明报染污行也。诸法因明彼法善耶。答曰。如是。诸法因明彼法善也。颇法善彼法不因明耶。答曰有。初明若善有漏行也。颇法不因明不因无明。彼法非不因耶。答曰有。除无明报诸余不隐没无记行。初明若善有漏行也

阿毗昙欲品第四十竟(梵本一百八十六首卢秦二千九百五十六言)

阿毗昙八犍度论卷第二十九阿毗昙八犍度论卷第三十

        迦旃延子造

        符秦罽宾三藏僧伽提婆共竺佛念译

    见犍度想跋渠第三

十想。无常想无常苦想苦无我想不净想。观食想一切世间不可乐想。死想断想无淫想尽想。诸法无常想生彼法无常想相应耶。设诸法无常想相应。彼法无常想生耶。乃至尽想亦如是。诸法无常想生。彼法无常想一缘耶。设诸法无常想一缘。彼法无常想生耶。乃至尽想亦如是。颇法智分别不断不修不作证耶。颇法智分别不断不修作证耶。颇法智分别不断修作证耶。颇法智分别断修作证耶。颇法智分别断不修作证耶。颇法智分别断不修不作证耶。颇法无缘缘因无缘缘。法缘俱生有有像非不有非不有像。余色余痛余想余识余彼相应法。彼法于彼法当言因耶。当言缘耶。复次当言缘。当言非因耶。彼法当言善耶不善耶无记耶。彼法几使所使。几结系。若法心俱生非不用心。如是心生彼法亦然耶。如心尽彼法亦然耶。如彼得心彼法亦然耶。如彼弃心彼法亦然耶。如彼心受报彼法亦然耶见相应痛几使所使。见不相应痛几使所使。疑相应痛几使所使。疑不相应痛几使所使。因道缘生摄几持几入几阴。眼更等生想痛除心相应法。耳更等生想痛除心不相应法。诸余法摄几持几入几阴。鼻舌身更等生想痛除心相应法。意更等生想痛除心不相应法。诸余法摄几持几入几阴。此章义愿具演说

十想。无常想无常苦想苦无我想不净想观食想一切世间不可乐想死想断想无淫想尽想。诸法无常想生彼法无常想相应耶。答曰。或法无常想生。彼法非无常想相应。云何法无常想生。彼法非无常想相应。答曰。犹如无常想在前必尽。诸余想在前必生。彼想诸相应法。是谓法无常想生。彼法非无常想相应。云何法无常想相应。彼法非无常想生。答曰。犹如余想在前必尽。无常想在前必生。彼想诸相应法。是谓法无常想相应。彼法非无常想生。云何法无常想生。彼法无常想相应。答曰。犹如无常想在前必尽。无常想在前必生。彼想诸相应法。是谓法无常想生。彼法无常想相应也。云何法非无常想生。彼法非无常想相应。答曰。犹如余想在前必尽。犹如余想在前必生。彼想诸相应法。是谓法非无常想生。彼法非无常想相应。乃至尽想亦如是。诸法无常想生。彼法无常想一缘耶。答曰。或法无常想生。彼法非无常想一缘也。云何法无常想生。彼法非无常想一缘耶。答曰。犹如无常想在前必尽。犹如余想在前必生。彼有余缘。是谓法无常想生。彼法非无常想一缘也。云何法无常想一缘。彼法非无常想生。答曰。犹如余想在前必尽。无常想在前必生。彼有此缘。是谓法无常想一缘。彼法非无常想生也。云何法无常想生。彼法无常想一缘耶。答曰。犹如无常想在前必尽。无常想在前必生。彼有此缘。是谓法无常想生。彼法无常想一缘也。云何法非无常想生。彼法非无常想一缘耶。答曰。犹如余想在前必尽。犹如余想在前必生。彼有余缘。是谓法非无常想生。彼法非无常想一缘。乃至尽想亦如是。颇法智分别不断不修不作证耶。答曰有。虚空非数缘尽也。颇法智分别不断不修作证耶。答曰。有数缘尽。颇法智分别不断修作证耶。答曰有。无漏有为法也。颇法智分别断修作证耶。答曰有。善有漏法也。颇法智分别断不修作证耶。答曰有。天眼天耳也。颇法智分别断不修不作证耶。答曰有。除天眼天耳也。诸余无记有为法若不善法也。颇法无缘缘因无缘缘法缘俱生耶。答曰有。诸五识身俱相应。诸意识身俱相应。色无为心不相应行。缘彼法诸得生老无常。是谓法无缘缘因无缘缘法缘俱生。有有像有彼法非无彼法。是故有有像非不有非不有像。然有彼法非不有彼法。是故非不有非不有像。余色彼法非色。余痛彼法非痛。余想彼法非想。余识彼法非识。余彼相应法彼法非相应。是故余不相应法。彼法于彼法。当言因。当言缘耶。或当言缘。当言非因耶。答曰。前生后生当言因当言缘。后生前生当言缘。不当言因。彼法当言善耶。不善耶当言无记耶。答曰。彼法善中当言善。不善中当言不善。无记中当言无记。彼法几使所使。答曰。三界有漏缘。几结系。答曰九。诸法心俱生非不用心。如彼心生彼法亦然耶。答曰。先心生后彼法也。如彼心尽彼法亦然耶。答曰先。心尽后彼法也。如彼得心彼法亦然耶。答曰。先得心后彼法也。如彼弃心彼法亦然耶。答曰。先弃法后弃彼心也。如彼心受报彼法亦然耶。答曰。或是或非。见相应痛几使所使耶。答曰。有漏缘。亦见无漏缘。若彼相应无明也。见不相应痛几使所使。答曰。除见无漏缘。若彼相应无明。诸余一切疑相应痛。几使所使。答曰。见谛断有漏缘。亦疑无漏缘。若彼相应无明也。疑不相应痛。几使所使。答曰。除疑无漏缘。若彼相应无明。诸余一切见谛断也。因道缘生摄十八持十二入五阴也。眼更等生想痛。除心相应法。耳更等生想痛。除心不相应法。诸余法摄十八持十二入五阴。鼻舌身更等生想痛。除心相应法。意更等生想痛。除心不相应法。诸余法摄十八持十二入五阴也

阿毗昙想品第四十一竟(梵本一百四首卢秦一千六百二十二言)

    阿毗昙见犍度智时跋渠第四

诸聚智时彼聚断耶。设聚断彼聚智耶。诸聚厌彼聚无欲耶。设聚无欲彼聚厌耶。诸聚厌彼聚修厌耶。设聚修厌彼聚厌耶。诸聚无欲彼聚修厌耶。设聚修厌彼聚无欲耶。若法诸法因或时法彼法不当言因耶。若法诸法次第缘增上。或时彼法彼法不当言次第缘增上耶。诸意更彼一切三等更。设三等更彼一切意更耶。诸慢彼作慢耶。设作慢彼慢耶。诸慢心增上设心增上彼慢耶。诸行非护耶。设非护彼行耶。诸行彼护耶。设护彼行耶。若聚不得不成就彼聚耶。设聚不成就不得彼聚耶。诸聚得成就彼聚耶。设聚成就不得彼聚耶。除苦圣谛及法入。诸余法摄几持几入几阴耶。习亦如是。除尽圣谛及法入。诸余法摄几持几入几阴。道亦如是。除色法及法入。诸余法摄几持几入几阴。无色可见不可见。有对无对。有漏无漏。有为无为。过去未来现在。善不善无记。欲界系色无色界系。学无学非学非无学。见谛断思惟断。除无断法及法入。诸余法摄几持几入几阴。除起法及诸法必不生。诸余法摄几持几入几阴。未生色无色。可见不可见。有对无对。有漏无漏。有为无为。过去未来现在。善不善无记。欲界系色无色界系。学无学非学非无学。见谛断思惟断。除不断法及诸法必不生。诸余法摄几持几入几阴。颇一持一入一阴。摄一切法耶。此章义愿具演说

诸聚智彼聚断耶。答曰。或聚智彼聚不断。云何聚智彼聚不断。答曰。以苦智习尽道智不除垢。是谓聚智彼聚不断。云何聚断彼聚不智。答曰。以苦忍习忍尽忍道忍断垢。是谓聚断彼聚不智。云何聚智彼聚断耶。答曰。以苦智习尽道智断垢。是谓聚智彼聚断。云何聚不智彼聚不断。答曰。以苦忍习尽道忍不断垢。是谓聚不智彼聚不断。诸聚厌彼聚无欲耶。答曰。或聚厌彼聚非无欲。云何聚厌彼聚非无欲。答曰。以苦忍习忍。以苦智习智不断垢。是谓聚厌彼聚非无欲。云何聚无欲彼聚非厌。答曰。以尽忍道忍以尽智道智断垢。是谓聚无欲彼聚非厌。云何聚厌彼聚无欲耶。答曰。以苦忍习忍。以苦智习智断垢。是谓聚厌彼聚无欲也。云何聚非厌彼聚非无欲。答曰。以尽忍道忍以尽智道智不断垢。是谓聚非厌彼聚非无欲。诸聚厌彼聚修厌耶。答曰。如是。诸聚厌彼聚修厌也。颇聚修厌彼聚非厌耶。答曰有。以尽智道智断垢也。诸聚无欲彼聚修厌耶。答曰。或聚无欲彼聚非修厌。云何聚无欲彼聚非修厌。答曰以尽忍道忍断垢。是谓聚无欲彼聚非修厌。云何聚修厌彼聚非无欲耶。答曰。以苦忍习忍以苦智习智不断垢。是谓聚修厌彼聚非无欲。云何聚无欲彼聚彼修厌。答曰。以苦忍习忍以苦智习尽道智断垢。是谓聚无欲彼聚修厌。云何聚非无欲。彼聚非修厌。答曰。以尽忍道忍不断垢。是谓聚非无欲彼聚非修厌。若法诸法因或时彼法彼法不当言因。答曰无。若法诸法次第或时彼法彼法不当言次第。答曰。若彼法未生也。若法诸法缘增上。或时彼法彼法不当言缘增上耶。答曰无。诸意更彼一切三等更耶。答曰。如是。诸意更彼一切三等更。颇三等更彼非意更耶。答曰。有五识身相应更。世尊亦说比丘有意持法持。有无明持无明痛更。触有得耶无得耶有无得耶。诸慢彼一切自己耶。答曰。如是。诸慢彼一切自己也。颇自己非慢耶。答曰有。见世尊亦说比丘我是自己。于我比丘是自己。诸慢彼增上盛耶。答曰。如是。诸慢彼增上盛也。颇增上盛非慢耶。答曰有。除慢诸余垢现在前。世尊亦说比丘若增上者。是魔所系不增上者是解脱波旬也。诸行彼非护耶。答曰。或行彼非不护。云何行彼非不护。答曰。身护口护。是谓行彼非不护。云何非护彼非行。答曰。根非护。是谓非护彼非行。云何行非护。答曰。身非护口非护。是谓行非护。云何非行彼非不护。答曰。根护。是谓非行彼非不护。诸行彼护耶。答曰。或行彼非护。云何行彼非护。答曰。身不护口不护。是谓行彼非护。云何护彼非行。答曰。根护。是谓护彼非行。云何行彼护。答曰。身护口护。是谓行彼护。云何非行彼非护。答曰。根非护。是谓非行彼非护。若聚不得不成就彼聚耶。答曰。如是。若聚不得不成就彼聚颇聚不成就彼聚非不得。答曰有。若聚得便失也。若聚得彼聚成就耶。答曰。如是。若聚成就彼得聚也。颇聚得彼聚非成就耶。答曰有。若聚得便失也。除苦圣谛及法入。诸余法摄二持(意识)一入一阴。习亦如是。除尽圣谛及法入。诸余法摄十七持十一入二阴。道亦如是。除色法及法入。诸余法摄七持一入(意也)一阴。除无色法及法入。诸余法摄十持十入一阴。除可见法及法入。诸余法摄十六持十入二阴。除不可见法及法入。诸余法摄一持一入一阴。除有对法及法入。诸余法摄七持(意识竟)一入一阴。除无对法及法入。诸余法摄十持十入一阴。除有漏法及法入。诸余法摄二持一入一阴。除无漏法及法入。诸余法摄十七持十一入二阴。除有为法及法入。除一切法无聚空论。除无为法及法入。诸余法摄十七持十一入二阴(色识)。除过去现在法及法入。诸余法摄十七持十一入二阴。除未来法及法入。诸余法摄十七持十一入二阴。除善不善法及法入。诸余法摄十七持十一入二阴。除无记法及法入。诸余法摄九持三入二阴。除欲界系法及法入。诸余法摄十三持九入二阴。除色无色界系法。学无学法及法入。诸余法摄十七持十一入二阴。除非学非无学法及法入。诸余法摄二持一入一阴。除见谛断法无断法及法入。诸余法摄十七持十一入二阴。除思惟断法及法入。诸余法摄二持一入。一阴除起法及诸法必不起。诸余法摄十八持十二入五阴。除未生法及诸法必不生。除一切法无聚空论。除色法及诸法必不生。诸余法摄八持二入四阴。除无色法及诸法必不生。诸余法摄十一持十一入一阴。除可见法及诸法必不生。诸余法摄十七持十一入五阴。除不可见法及诸法必不生。诸余法摄一持一入一阴。除有对法及诸法必不生。诸余法摄八持二入五阴。除无对法及诸法必不生。诸余法摄十持十入一阴。除有漏法及诸法必不生。诸余法摄三持二入五阴。除无漏法及诸法必不生。诸余法摄十八持十二入五阴。除有为法及诸法必不生。除一切法无聚空论。除无为法及诸法必不生。诸余法摄十八持十二入五阴。除过去现在法及诸法必不生。诸余法摄十八持十二入五阴。除未来法及诸法必不生。除一切法无聚空论。除善不善法及诸法必不生。诸余法摄十八持十二入五阴。除无记法及诸法必不生。诸余法摄十持四入五阴。除欲界系法及诸法必不生。诸余法摄十四持十入五阴。除色无色界系法学无学法及诸法必不生。诸余法摄十八持十二入五阴。除非学非无学法及诸法必不生。诸余法摄三持二入五阴。除见谛断法无断法及诸法必不生。诸余法摄十八持十二入五阴。除思惟所断法及诸法必不生。诸余法摄三持二入五阴。颇有一持一入一阴。摄一切法耶。答曰有。一持法摄一入意入一阴色阴也

阿毗昙智跋渠第四竟(梵本一百七十八首卢秦二千三百四十一言)

    阿毗昙见犍度见跋渠第五

  邪见断垢净　　无因无智见
  智力无精进　　作七士身因
  四本缘豪无　　无因自亦他
  我作作无因　　此彼我六见
  欲乐及诸禅　　空有无非风
  我作亦有慢　　若得若当得
  故说是见品

所谓此见无施无福无说。此邪见习谛断。无善恶行果报。此邪见苦谛断也。无今世后世无父无母。此邪见习谛断也。无世阿罗汉乐法。此邪见道谛断也。无等法此邪见尽谛断也。无趣得诸今世后世。自智作证成就游。此邪见道谛断也。所谓此见于此命活。余处断坏无有死。此边见摄断灭见苦谛断也。所谓此见四大人身。彼若命终时彼当尔时。地即属地。身水即属水。身火即属火。身风即属风。身空五人持尸往弃冢间。迹现根归虚空。此边见摄。有常见苦谛断也。所谓此见骨白鸽色我变为灰。若火我缘此非见是邪智。若有漏行我缘此邪见习谛断也。若无漏行我见。此邪见道谛断也。所谓此见贪者叹施。智者叹受。诽谤智法。此邪见道谛断也。所谓此见彼空妄语此愚非智。诸作是说有于此命活。余处断坏曾无有死。此愚边见摄。有常见苦谛断也。所谓此见。无因无缘众生有垢。无因无缘众生有垢。此邪见习谛断也。所谓此见。无因无缘众生净。无因无缘众生净。此邪见道谛断也。所谓此见。无因无缘众生无智无见。无因无缘众生无智无见。此邪见习谛断也。所谓此见。无因无缘众生智见。无因无缘众生智见。此邪见道谛断也。所谓此见无力无精进。无力精进。无自作无他作无士作。非自作非他作非士作。士力士精进士方便。一切众生一切虫一切神。无力无自在无精进无方便。有行报无因无缘众生受苦乐。于六六生若诽谤有漏力精进。此邪见习谛断也。若诽谤无漏力精进此邪见道谛断也所谓此见造教造断教断煮教煮愁烦椎胸呻吟志乱。害众生不与取淫邪行。妄语饮酒。穿墙坏藏偷金淫他妻。害村害城害众生。作如是者此非恶。以刀以轮此地上所有诸虫。彼一切一日之中。断截挝捶作一肉聚。彼无有恶无因缘恶报。于恒水左施福说法于恒水右断截挝打来。彼无福无恶。施与戒完具欢喜说钱财。彼因缘无福。彼因缘无福报。此邪见习谛断也。所谓此见七士身不作作不化化实住。聚常住彼立非移动各不相干。若福若恶福恶。若苦若乐苦乐。彼何者。所谓地身水身火身风身苦乐命七。是谓七士身不作作不化化实住聚常住彼立不移动各不相干。若福若恶福恶若乐若苦乐苦。若士乐士苦不豫世事。七身中间乃得过去亦不害命。彼无作是说。若害若杀不到命终而到命终。此边见有常见摄。苦谛断也。所谓此见因四百千生门。六十百千大劫。六百三行行半行。六十二迹向。六十二尘持。六十二中劫百二十根。百三十六大地狱。四十九百千梵志家。四十九百千裸形村。四十九百千龙国。于中入六六生八士地。七想行七无想行。七尼犍子行。七阿须伦七非阿须伦。七天七恚七人七非人。七泉七百泉。七崄七百崄。七山七百山。七梦七百梦。是谓八十四百千大劫。若愚若智往来经历尽其苦际。彼无有作是说。我以此戒果净行。不行熟行当熟已熟。当倍已倍二倍苦乐已进无退。譬如缕丸执缕放走。如是八十四百千大劫。若愚若智往来经历尽其苦际。无作作缘此戒盗苦谛断也。所谓此见诸此人所更。彼一切本所作因无作作缘。此戒盗苦谛断也。所谓此见此人所更。彼一切富者化因无作作缘。此戒盗苦谛断也。所谓此见此人所更。彼一切无因无缘。此邪见习谛断也。所谓此见我作苦乐无作作缘。此戒盗苦谛断也。所谓此见他作苦乐。无作作缘。此戒盗苦谛断也。所谓此见我作他作。苦乐无作作缘。此戒盗苦谛断也。所谓此见非自作非他作。非我作非教他作。无因无缘众生苦乐所更。此邪见习谛断也。所谓此见彼是我。彼是世我。是彼常法非变易法。此边见有常见摄苦谛断也。所谓此见实有此我。此边见有常见摄苦谛断也。所谓此见实无此我。此边见断灭见摄苦谛断也。所谓此见我观我眼色我住。此身见苦谛断也。所谓此见我观非我眼我住色众具因。此身见苦谛断也。所谓此见无我见我色我住眼众具因。此身见苦谛断也。所谓此见此是我。若语若觉作教作生等生。于彼彼作善恶行受报。此边见有常见摄苦谛断也。所谓此见彼净脱出。若五欲乐娱乐以秽法盗为最。此见盗苦谛断也。所谓此见彼净脱出。若解脱欲乃至第四禅成就游。无作作缘。此戒盗苦谛断也。所谓此见我豪依空见起增慢。我相似依空见起慢。我卑依空见起小慢。有胜我者依见起小慢。有似我者依见起慢。有卑我者依见起增慢。无豪我者依见起增慢。无似我者依见起增慢。无卑我者依见起小慢。所谓此见无风无雨无射怀妊不孕河不流火不然。日月不出不没。垢净无住处。此边见断灭见摄。苦谛断也。所谓此见

  我造众生　　他亦有造　　一一无有见
  不观此是箭

依我造众生者。我作我造我化故曰我造众生。他亦有造者。他作他造他化故曰他亦有造。一一无有见者。一一非一切箭者。见彼不看不视不觉。故曰一一无有见。不观此是箭当观此箭缘。若触于生受我作彼非有他作。彼非有当观此箭缘者。此箭谓之见。此箭缘别生别老别病别死。视此见箭视觉也。故曰观箭缘。若触于生受者生谓之依。学于彼此见染着触。故曰若触于生受也。我作彼非有者。彼非有我作我造我化。故曰我作彼非有他。作彼非有者。彼非有他作。他造他化故曰他作彼非有。慢住此众生。慢取慢缚见。逆生死不过。慢住此众生者。七慢彼住属成就。故曰慢住此众生。慢取者。彼取重取恒取故曰慢取。慢缚者。彼缚重缚恒缚故曰慢缚。见逆者。断灭见有常见俱。逆有常见断灭见。俱逆故曰见逆。生死不过者。无穷彼不越不等越。故曰生死不过

  若得若当得　　二尘杂俱散　　异学戒　　诸学
  诸持戒诸活　　诸梵活诸养全

若得若当得者。已得持阴入故曰若得。若当得者。不得持阴入必当得。故曰若当得。二尘杂俱散者。二尘欲嗔恚愚痴彼散云多散。故曰二尘杂俱散。异学戒者。学彼从彼故曰异学戒。诸学者。诸众生如是见如是语。彼净脱出诸学象颈马脊车弓地。钩强诸辇出入。故曰诸学也。诸持戒者。诸众生如是见如是语。彼净脱出若持牛戒守狗戒鹿戒象戒秃枭戒裸形戒。故曰诸持戒也。诸活者。诸众生如是见如是语。彼多活久活。若洗人泉不人泉上人泉。恒门三藕泉。故曰活。诸梵活者。诸众生如是见如是语。彼净脱出诸两。两梵行改往等爱。故曰诸梵活。诸养全者。诸众生如是见如是语。彼净脱出。若事火日月星宿药严饰宫。故曰诸养全。此一边无作作缘。此戒盗苦谛断也。诸众生如是见如是语。好欲净欲食欲。充根欲欲中无事。此二边以秽法盗为最。此见盗苦谛断。此二边不知戒盗见盗。如实不知如实不见。彼取彼受彼走见起眼成见。彼眼成者。谓之佛世尊彼见取时受时走时。见起故曰眼成见。彼此二边知戒盗见盗。如实知如实见。不取彼不受彼不走彼见不起。眼成见彼眼成者。谓之佛世尊。彼见不取时不受时不走时不起时。故曰眼成见。彼此非染非秽非愚。彼不欲净解脱出。彼不复轮转。轮转谓无量生死。彼非不尽非有余故。故曰不复轮转。此边我说苦苦者五盛阴。彼此边后边最后边。故曰此边我说苦也

见品第四十三竟(梵本二百七十六首卢秦三千三百七言)

    阿毗昙见犍度中偈跋渠第六

见婆罗门二母尽洒若负一。不信三十六恶见。无望沫讲堂堕皮

  视者视时视　　不视时亦视
  不视者亦视　　不视视亦视

视者视时视。视谓之诸已见苦习尽道。视时视谓之诸余见苦习尽道彼亦见此见苦习尽道。故曰视者视时视。不视时亦视者。谓之诸余不见苦习尽道。彼视此不见苦习尽道。故曰不视时亦视。不视者亦视不视。谓之不见苦习尽道视谓之诸见苦习尽道。故曰不视者亦视不视视亦视。彼见苦习尽道此不见苦习尽道。故曰不视视亦视(见竟)

  不应捶婆罗门　　亦不放婆罗门
  不是捶婆罗门　　亦不是放婆罗门

不应捶婆罗门者。婆罗门者谓之阿罗汉。彼不捶若手若石若刀若杖。故曰不应捶婆罗门。亦不放婆罗门者。彼阿罗汉不放不敬。衣食卧具病瘦医药。故曰亦不放婆罗门。不是捶婆罗门者。彼不是弊丑。诸捶阿罗汉若手若石若刀若杖。故曰不是捶婆罗门。亦不是放婆罗门者。彼不是弊丑。诸放阿罗汉不敬衣食卧具病瘦医药。故曰亦不是放婆罗门(二竟)

  捐舍于父母　　亦王及二学
  舍邦土翼从　　无碍过梵志

捐舍于父母者。母谓之爱生故也。如说。爱为生士。彼心驰走。人因生死。彼苦大畏。父谓之有漏行。有彼当舍离断。故曰捐舍于父母也。亦王及二学者。王谓之有漏心意识。如说。六增上王。染着诸尘。非染无污。染谓之愚。二学谓之戒盗见盗。故曰亦王及二学也。舍邦土翼从者。邦土谓之垢。翼从谓之彼相应有觉有观彼当舍离断。故曰舍邦土翼从。无碍过梵志者。三碍贪欲嗔恚愚痴。彼尽于欲界中过出要。色无色界过出要。梵志者于此见尽要。故曰无碍过梵志也(三竟)

  捐舍于父母　　亦王及二学
  已害于五虎　　彼谓之清净

捐舍于父母者。母谓之爱生故也。如说

  爱为生士　　彼心驰走　　人因生死
  彼苦大畏

父谓之有漏行。有彼当舍离断。故曰捐舍于父母也

亦王及二学者。王谓之有漏心意识。如说

  六增上王　　染着诸尘　　非染无污
  染谓之愚

二学谓之戒盗见盗。故曰亦王及二学也。已害于五虎者。世尊现嗔恚。如彼虎凶恶无慈。如是嗔恚缠。众生凶恶无慈。彼世尊现当尽。云何五。答曰。数为五。五盖中五。五下分结中五。彼当舍离断。故曰已害于五虎也。彼谓之清净者。尽欲清净。嗔恚愚痴已尽谓之清净。彼故谓之清净也(四竟)

  若已尽不生　　已尽不将随
  彼佛无量行　　无迹何迹将

若已尽不生者。结尽无余谓之尽。或生或不生谁生。答曰。若彼结尽退。此生谁不生。答曰。若彼结尽不退此不生。故曰若已尽不生也。已尽不将随者。此结不尽有余以二事将随。于现法中乐色声香味细滑。若身坏有苦生。彼尽无余不将随。故曰已尽不将随也。彼佛无量行者。云何佛。答曰。如彼如来无余智见明觉思惟。已得度成就谓之佛。二边有着常断此非佛世尊行也。四意止无量无边无限此佛世尊行。故曰彼佛无量行也。无迹何迹将者。迹谓之垢。彼垢无一可将。若染若秽若愚。故曰无迹何迹将(五竟)

  若丛染枝洒　　无爱可将随
  彼佛无量行　　无迹何迹将

若丛染枝洒者。丛谓之爱。如说。比丘我今当说爱丛水枝洒。若彼诸众生覆隐没荫盖缠。云何洒。答曰。此爱不尽有余洒。若生五趣过去未来现在也。彼尽无余不洒。故曰若丛染枝洒也。无爱可将随者爱尽无余也。此爱不尽有余二事将随。于现法中乐色声香味细滑法。若身坏有苦生。彼尽无余不将随。故曰无爱可将随也。彼佛无量行者。云何佛。答曰。若彼如来无余智见明觉思惟。已得度成就谓之佛。二边断灭有常。彼非佛世尊行也。四意止无边无限无量此佛世尊行。故曰彼佛无量行也。无迹何迹将者。迹谓之垢。彼垢无一可将。若染若秽若愚。故曰无迹何迹将(六竟)

  已截绳束高　　亦意等相依
  觉为已度堑　　彼是世梵志

已截绳束高者。世尊现高慢绳爱。譬如车载现高绳系。如是众生高慢爱系。彼世尊现当灭。故曰已截绳束高。亦意等相依者。三意欲嗔恚愚痴也。等相依谓之彼相应觉观。故曰亦意等相依也。觉为已度堑者。佛世尊现当断无明。如说。云何比丘已度岸。答曰。无明堑尽无余。故曰觉为已度堑也。彼是世梵志者。梵志现已灭恶法。故曰彼是世梵志也(七竟)

  一本二展转　　三垢五弥广
  诸海十二转　　文尼度沃焦

一本二展转者。世尊现无明是本。如说

  诸余恶趣　　今世后世　　彼无明本
  悭贪等生

二展转谓之名色。故曰一本二展转也。三垢五弥广者。三垢贪淫嗔恚愚痴五弥广也。谓之五趣地狱畜生饿鬼天人。故曰三垢五弥广也。诸海十二转者。世尊现海六入是海也。如说。海海比丘愚凡人说语此非圣典海。大水处大水聚数。眼入为海。波色回使若忍彼色使。不度眼海俱回使俱神俱罗刹。耳鼻舌身意入海。彼法回使若忍彼法使。彼不度意海俱回使。俱神俱罗刹。十二转者谓之十二入。若眼色中回色眼中回。乃至意法中回法意中回。故曰诸海十二转也。文尼度沃焦。沃焦者。无限生死彼无学文尼已度。学文尼方度。故曰文尼度沃焦(八竟)

  不信不往知　　若那罗断际
  害淫舍离淫　　彼是无上士

不信不往知者。世尊弟子已实见四谛。谓之不信。何故。答曰。彼不信余。若佛若法若僧若苦习尽道也。不往知者。谓之泥洹。如说。有比丘不生不往不有。无为于此长久远。不得今得因道因迹。故曰不信不往知也。若那罗断际者。彼断一切三界际。若那罗者名也。如说。众生谓之那罗。磨[少/兔]舍三磨纳婆四富楼沙五福伽罗六祁披七禅豆(八人名字也)。故曰若那罗断际也。害淫舍离淫者。害淫现形尽。舍离淫现命淫尽。故曰害淫舍离淫也。彼是无上士者。彼第一士大士妙士高士无上士。故曰彼是无上士(九竟)

  诸三十六水　　意流有倍　　顺流二见
  由淫觉出

诸三十六水者。水谓之三十六爱种也。故曰诸三十六水也。意流有倍者。意生意首意所缚着。倍者极增上满。故曰意流有倍。顺流二见者。二见谓之断灭见有常见。彼流至地狱畜生饿鬼。故曰顺流二见。由淫觉出者。三觉欲觉嗔恚觉害觉。欲生欲首欲所缚着。故曰由淫觉出也(十竟)

  弃身恶行　　及口恶行　　弃意恶行
  诸秽杂想

弃身恶行者。现灭身三恶行。故曰弃身恶行也。及口恶行者。现灭口四恶行。故曰及口恶行也。弃意恶行者。现灭意三恶行也。故曰弃意恶行也。诸秽杂想者。若知诸余杂想亦当灭。故曰诸秽杂想(十一也)

如鬘童子。见见有足闻闻足知知足识识足如非此。如非此者如非彼。如非彼者。如非下非上非两中间。此是苦边。或鬘童子见见有足。或无谁有。答曰。若眼见色不起垢。是谓有。谁无。答曰。若眼见色起垢。是谓无。闻闻足知知足识识足亦如是。如彼鬘童子。见见有足闻闻足知知足识识足如非此。若染若秽若愚若非此。若染若秽若愚者如是非彼取缚。若如非彼取缚者。如是如非下。欲界非上。无色界非两中间。色界此是苦边苦。谓之五盛阴。彼是边后边最后边。故曰此是苦边(十二竟)

磨舍(一)兜舍(二)僧贳磨(三)萨披多罗毗比栗多(四)此是苦边

磨舍者。不悕望。若欲若恚若愚故曰磨舍也。兜舍者。喜佛道喜善说法。顺圣憎别苦习尽道。色无常痛想行识无常。故曰兜舍也。僧贳磨者。欲生制息之。嗔恚愚痴生制息之。故曰僧贳磨也。萨披多罗毗比栗多者(昙蜜罗国语也)。一切欲界心脱离。一切色无色界心脱离。故曰萨披多罗毗比栗多也。此是苦边者。苦谓之五盛阴。彼是边后边最后边。故曰此是苦边也(十三竟)

  知身如聚沫　　觉法如野马
  断魔华小华　　不往见死王

知身如聚沫者。如彼沫聚无力羸虚空不坚。五盛阴如是。无力羸虚空不坚。故曰知身如聚沫也。觉法如野马。如野马者。从日光出不久弹指顷不住。本无忽有设有便尽。五盛阴如是斯须弹指顷不住。本无忽有设有便尽。故曰觉法如野马也。断魔华小华者。四魔阴魔垢魔死魔自在天子。世尊为彼现见谛断。华垢尽小华思惟断。故曰断魔华小华也。不往见死王者。如是见谛思惟断结已尽无余。自在天子不随意自恣。故曰不往见死王也(十四竟)

  守堂若彼此　　诸觉喜足我
  知世间兴衰　　善心尽解脱

守堂若彼此者。三讲堂空无愿无相。诸缘内生外缘。故曰守堂。若彼此也。诸觉喜足我者。觉谓之智达。聪明智慧成。喜于佛道善说法顺圣僧别苦习尽道。色无常痛想行识无常想妙。我具身口意行成就。故曰诸觉喜足我也。知世间兴衰者。世间谓之五盛阴。诸比丘游观兴衰。如此色如此色习如此色尽如此痛想行识。此识习此识尽。故曰知世间兴衰也。善心尽解脱者。彼思义思法思善思妙一切有道没。生脱当脱已脱。故曰善心尽解脱(十五竟)

  脱若堕已堕　　贪餮复来还
  已逮安隐处　　乐往至乐所

脱若堕已堕者。脱谓欲界也。已堕谓生色界。若堕谓办色界中五阴也。故曰脱若堕已堕也。贪餮复来还者。有世间道垢尽圣智未生。彼自身娱乐自身恃怙。复堕地狱畜生饿鬼。故曰贪餮复来还也。已逮安隐处。已逮者。谓佛佛弟子。安隐者。谓之泥洹彼娱乐。故曰已逮安隐处也。乐往至乐所者。彼道乐至泥洹。故曰乐往至乐所也(十六竟)

  若无根无皮　　叶无况有枝
  彼猛缚解脱　　谁堪能诽谤

若无根无皮者。世尊现无明根。如说

诸此恶趣今世后世彼无明本悭贪等生

皮者四识住彼不尽有余不欲不忍。故曰若无根无皮也。叶无况有枝者。世尊现叶我慢。如说。云何比丘烧叶。答曰。我慢。尽无余枝者。爱如说比丘我今当说爱丛水枝洒。于此众生覆隐况阴盖缠。故曰叶无况有枝也。彼猛缚解脱者。猛谓佛弟子猛勇。智慧成就猛胜除恶法三缚。欲嗔恚愚痴彼脱已脱当脱。故曰彼猛缚解脱也谁堪能诽谤者。彼人当称誉不可毁訾也。若毁訾者受罪多。如说。若毁便誉若誉便毁口招祸殃不觉乐故。曰

若无根无皮叶无况有枝。彼猛缚解脱谁堪能诽谤

偈品第四十四竟(梵本二百一十首卢秦三千九百五十七言)

见犍度第八尽

八犍度共四十四品

阿毗昙八揵度论卷第三十


阿毗昙甘露味论

    No. 1553

阿毗昙甘露味论卷上

        尊者瞿沙造

        曹魏代译失三藏名

    布施持戒品第一

云何布施。自持财物施与。为三种故。自为身故。为他人故。为彼我故。供养塔寺佛辟支佛阿罗汉。自为身故。施与众生。为他人故。布施与人。为彼我故。思田物好得好报。云何思好。信净与供养。云何田好。有三种田。有大德。有贫苦。有大德贫苦。云何大德。佛菩萨辟支佛阿罗汉阿那含斯陀含须陀洹。云何贫苦。畜生老病聋盲喑哑。如是种种贫苦。云何大德贫苦。有佛菩萨辟支佛阿罗汉阿那含斯陀含须陀洹。老病聋盲喑哑贫苦。大德田者。恭敬心得大报。贫苦田者。怜愍心得大报。大德贫苦田者。恭敬怜愍心得大报。是为福田好。云何物好。不杀他不偷不夺不系不鞭不欺不诳。净物随多少随时布施。是为物好。信云何。知后世果若涅槃一心不动。是谓信净。云何自除悭贪。恭敬于人。是谓净供养。云何奉迎礼拜。自手施与等。是谓供养。云何田异。行善持戒禅定智慧解脱得果等功德若有是。是谓田异。救济危厄异因缘得异苦有无苦。发心供给得妙果报。布施佛即时一切得福。布施众僧若受用得一切福。未受用不得一切福。供养法故得大报。若学人聪明大智慧。以法故供养。是谓供养。法布施得富。受施竟得乐力寿等功德。除结胜得大果报。若施畜生受百世报。若施不善人受千世报。若施善人受千万世报。若施离欲凡夫受千万亿世报。若施得道人得无数世报。若施佛至涅槃受报。布施有六难。一者憍慢施。二者求名施。三者为力施。四者强与施。五者因缘施。六者求报施。众僧中分别施。是谓布施六难。云何持戒。有二种律仪。不善善律仪。云何不善。杀生偷盗淫劮。是谓身三恶律仪。两舌恶口妄言绮语。是谓口四恶律仪。贪恚恶邪。是谓意三恶律仪。云何杀生。有他生知是生。故夺命。如是杀生。有他受物知是他受物。故盗心偷夺。如是盗。有妇女他所有。知他妇女。故欲共淫。若道非道中。自有妇犯非道。如是淫劮。若知言不知不知言知。若疑言不疑不疑言疑。如是妄语。若有实欲别离故异说。是谓两舌。染污心他人不爱言。如是恶口。不知时无义言。如是绮语。财物他有贪爱应我有。如是贪。见彼不喜。欲令苦痛。如是恚。恶邪有二种。实有物而言无颠倒见闻。云何实有物而言无。无罪无福报。无今世后世。无父母无佛辟支佛阿罗汉余得道等。如是实有而言无。云何颠倒。见闻善恶天作非行报果。如是恶邪。是谓三种不善业。悔是三事除却不作。是谓三种善业。常远三种恶行三种善。是谓持戒坚固。布施持戒禅定思惟。必得三果。得财富得生天得解脱。世三十种福田。父母老病善人离欲凡夫有漏七人四道向四道果。从灭禅入起。辟支佛菩萨佛比丘僧。有去来人饥渴

    阿毗昙甘露味界道品第二

三界。欲界色界无色界。是三界中有五种道。地狱畜生鬼神人天及中阴道。云何地狱。大地狱八种。第一僧时披。第二黑绳。第三合会。第四鲁腊。第五摩呵鲁腊。第六般那。第七波多般。第八阿鼻。一一大地狱各有十六地狱眷属。云何畜生。无脚两脚四脚多脚。水行陆行空行。云何鬼神道。种种身。欲界不善行三种上中下。上报地狱。中报畜生下报饿鬼。云何人道。四种人。东弗于逮人。西瞿耶尼人。南阎浮提人。北郁单曰人。欲界四种善行报生。云何天道。欲界有六天。第一四天王天。第二忉利天。第三盐天。第四兜术天。第五尼摩罗天。第六他化自在天。欲界中六种善报生。色界十七处。梵富楼梵迦夷摩呵梵。少光无量光光曜。少净无量净遍净。果实。得德。大果。不烦。不恼。善观。快见。阿迦尼吒。四禅三种。上中下报。十二处生四禅有漏无漏杂报。五净居圣人生三处。圣人凡夫共生大果处。凡夫得无想定生无想天。无色界空处识处不用处有想无想处。得无色定。是次第生无色处。随定力得生处。是为天道。欲受欲用欲畜。以是因缘说欲界。无欲有色。以是因缘说色界。无色界四阴。以是因缘说无色界。人中五十岁是四王天一日一夜。如是三十日为一月。十二月为一岁。四天王寿天上五百岁。当人间一万岁。是僧时泥犁中一日一夜。如是三十日为一月。十二月为一岁。僧时泥犁寿五百岁。复次人中百岁是忉利天一日一夜。如是三十日为一月。十二月为一岁。忉利天寿天上千岁。当人间三亿六万岁。是黑绳泥犁中一日一夜。如是三十日为一月。十二月为一岁。黑绳泥犁寿千岁。复次人中二百岁是盐天一日一夜。如是三十日为一月。十二月为一岁。盐天寿天上二千岁。当人间数十四亿四万岁。是鲁腊泥犁中一日一夜。如是三十日为一月。十二月为一岁。鲁腊泥犁寿二千岁。复次人中四百岁是兜术天一日一夜。如是三十日为一月。十二月为一岁。兜术天上寿四千岁。当人间数五十七亿六万岁。是摩呵鲁腊泥犁中一日一夜。如是三十日为一月。十二月为一岁。摩呵鲁腊泥犁寿四千岁。复次人中八百岁是化应声天一日一夜。如是三十日为一月。十二月为一岁。化应声天上寿八千岁。当人间数二百三十亿四万岁是多般泥犁中一日一夜。如是三十日为一月。十二月为一岁。多般泥犁中寿八千岁。复次人中千六百岁是他化自在天一日一夜。如是三十日为一月。十二月为一岁。他化自在天上寿万六千岁。当人间数九百二十一亿六万岁。是般多槃泥犁中一日一夜。如是三十日为一月。十二月为一岁。般多槃泥犁中寿万六千岁僧渴半劫寿。阿鼻泥犁寿一劫。畜生中寿有弹指顷。半日一日一月一岁十岁一百千万亿岁乃至一劫寿。饿鬼中寿乃至七万岁。人中阎浮提人寿或无数岁。或至十岁。今时寿百岁多少过。瞿耶尼人寿二百五十岁。东弗于逮人寿五百岁。北郁单曰人寿千岁不增减。余处众生寿有增减。是谓欲界中众生寿。云何色界中寿。梵迦夷天寿半劫。梵富楼天寿一劫。摩呵梵天寿一劫半。是谓初禅寿。少光天寿二劫。无量光天寿四劫。光曜天寿八劫。是谓二禅寿。约净天寿十六劫。无量净天寿三十二劫。遍净天寿六十四劫。是谓三禅寿。果实天寿一百二十五劫。得德天寿二百五十劫。大果天寿五百劫。无急天寿千劫。无恼天寿二千劫。善观天寿四千劫。快见天寿八千劫。阿迦腻吒天寿万六千劫。是谓四禅寿。空处寿二万劫。识处寿四万劫。不用处寿六万劫。有想无想处寿八万劫。是谓无色界寿。如是三界众生寿

    阿毗昙甘露味住食生品第三

有四识住。云何四。色痛想行。欲界色界中识多缘色住。空处识处识多缘痛住。不用处识多缘想住。有想无想识。多缘行住。有四种食情命根大长故。云何四食。一者抟食。二者乐食。三者意思食。四者识食。揣食三入摄。香味细滑入。以何等故色入不摄。揣食眼见食。情命根大不长故。揣食有二种。有粗有细。云何粗。饭饼如是一切。云何细。饮消香涂身。云何乐食。眼更乐耳鼻舌身更乐。有漏意更乐。能后世生相续不断。乐食多鸟卵鹅雁。如是一切。意思食多水虫卵鱼。如是一切。识食多有想无想处。及中阴众生。揣食多欲界中。余三食多色无色界中。揣食第一粗。乐食细。意思食次细。识食最细。四种生卵生胎生湿生化生。泥犁天中阴一切化生。鬼神二种生。胎生及化生。余众生四种生。化中众生一时得六情根。余残生最初得身根命根。诸余根次第得。四有。生有死有本有中有。死生中间细五阴。是谓中有。中有生有譬如印作字。如父子相似。除无色界余一切受中阴。无色界终生欲色界受中阴。譬如中阿那含有中阴。余生中有生有亦如是

    阿毗昙甘露味业品第四

杂心中缘杂垢起杂行。杂行中杂受报。云何杂行。有三种行。身行口行意行。善行不善行无记行。学行无学行非学非无学行。见谛断行。思惟断行。无断行。现世报生报后报。乐报苦报不乐不苦报。黑报白报杂报。不黑不白无报行。行尽必受报行。不必受报行。云何身行。身动身作。云何口行。口动口作。云何意行。意动意思。云何善行。善身作善口作善意思。云何不善行。不善身作不善口作不善意思。云何无记行。无记身动无记口动无记意思。云何学行。学身无教学口无教学意思。云何无学行。无学身无教无学口无教无学意思。云何非学非无学行。有漏身动口动意思。云何见谛断行。坚信坚法见忍断八十八结相应思。云何思惟断行。信解脱见到思惟断十使相应思。及染污身行口行善有漏行无记行。云何无断行。诸无漏行。云何现世报。若作善恶行今世得非后世得。云何生报。随善恶后行第一生得非余生。云何后法报。随行善恶后第二生得。若第三第四若过得报。云何乐报。欲界善行。色界乃至三禅善行。是受乐报。云何苦报。不善行受报。云何不苦不乐报。第四禅善有漏行。及无色界善有漏行。云何黑黑报。不善行黑黑报。云何白白报。善有漏行白白报。云何杂报。欲界善恶杂行杂受报。云何不黑不白无报行。行尽三界漏尽时。无碍道摄无漏思也。云何必受报行。五逆行必受恶报。现世报生报后报余残。有缘有人必受报。无缘无人不必受报一切有漏行故作熟得报。不故作不熟不得报。故作不熟不得报。三种行。身业教无教。口业教无教。意业有教。云何教行。若身口意作。云何无教行。身口作意起余心时。常在不失无教色。善不善心不生无记心不生无教色。所以者何。无记心力劣故。无记有二种。有隐没不隐没。结使所覆是隐没。不覆是不隐没。云何隐没无记法。欲界中身耶边耶。及彼相应无明共有法。色无色界一切结使。及色界身口行。是谓隐没无记法。云何不隐没无记法。坐卧立行伎巧报法变化心虚空非智缘尽。是谓不隐没无记法。无教三种。一无漏。二定共。三戒律仪。云何无漏戒。正语正业正命。云何定共戒。得禅离欲恶法。云何戒律仪。受戒时得善有漏身口行。云何得三种律仪。一切得道无漏律仪成就。一切得禅定共律仪成就。欲界人受戒戒律仪成就。戒律仪人最初教作时。现前无教成就。若尽不失成就过去得禅人一切过去未来定共律仪成就若入定过去未来现在成就。无漏律仪未来一切成就。若入道现在前成就。若尽不失成就过去律仪人。若作重恶不善成就。不善教无教。若不重恶成就不善教无无教。若恶心灭不成就教无教。不律仪人现在成就不善无教。若尽不失成就过去不善无教。若作重善成就善教无教。若不重善成就善教无无教。若善心灭不成就教无教。若中间人若作重善若不善。成就善不善教无教。若作不重善不善。成就教无无教。若善不善心灭不成就教无教。得色界善心成就禅律仪。若心退不成就禅律仪。一切色界善心中律仪心相应。除眼心耳身心闻慧死时心。六地无漏心力成就无漏律仪。云何六地。未到禅地初禅中禅二禅三禅四禅。退六地心不成就无漏律仪。有二事失无漏律仪若退若得道果。有二事失禅律仪。若退若命终。有三事失戒律仪。一犯戒。二舍戒。三恶邪起若法灭尽时。有人言失戒律仪。有言不失实不失。有四事失不律仪。一受戒。二不更作。三一心息求。四得道善色。云何失。若断善根。若命终。余残染污心数法。断结时断有五种果。一报果。二所依果。三增上果。四身力果。五解脱果。善有漏法或四果或五果。能断结使是谓五果。不能断结是谓四果。除解脱果。不善法有四果。除解脱果。无漏法或四果或三果。若断结四果除报果。若不断结三果除报果解脱果。无记法三果除报果解脱果。云何报果。不善法善有漏法得报果。云何所依果。善不善无记法。常行增长益至竟得。是谓所依果。云何增上果。若好若不好共俱受最上受。是谓增上果。云何身力果。身行为作等。是谓身力果。云何解脱果。智灭结是谓解脱果。善根不善根无记根三种。善根不贪不恚无痴。善根三种。不善根贪欲嗔恚愚痴。四种无记。根无记爱无记无明无记见无记。慢三种法。善法不善法无记法。云何善法。善身口业善心。心相应法。及心不相应行及智缘尽。是为善法。云何不善法。不善身口业不善心心相应法。及心不相应行。是为不善法。云何无记法。无记身口业无记心心相应法。及心不相应行虚空非智缘尽。是谓无记法。不饮酒布施供养尊重等。是谓善身口业摄。饮酒挝打憍慢尊重等。是不善身口业摄。是为十业道不摄欲界身口业。欲界四大造。如是色界无漏身口业何四大造。若依六种地。即彼地四大造若生无色界。如是本得无漏身口业。即彼地四大造。三种命终。有命尽福不尽。有福尽命不尽。有福尽命尽也

    阿毗昙甘露味阴持入品第五

诸有漏法四事离。云何四。无常无我无乐无净烦恼诸漏。何以故。趣一切生处。心漏连注随世界故。是谓有漏。三界有百八烦恼。九十八结十缠是烦恼何处生。是说有漏法。亦名受阴及烦恼处。从是中有二种五阴。有漏无漏。受阴一切有漏。云何色阴。诸四大造。十二入除意入。诸余入及法入摄无教色。是谓色阴。是色阴二种。可见不可见。云何可见。一入色入。云何不可见。九入及法入摄。无教色复有三种色。有可见有对。有不可见有对。有不可见无对。色入可见有对。余九入不可见有对。法入无教色不可见无对。是谓色阴。云何痛阴。受痛六更乐生。是有二种痛。身痛心痛。三种痛。苦痛乐痛不苦不乐痛。四种痛。身记无记心记无记。五种痛。五痛根。是六种痛。眼更痛耳鼻舌身意更痛。十八种痛。眼有喜乐护。三十六种痛。十八痛中有善不善。百八种痛。过去未来现在各三十六。一一众生须臾起无数。痛是谓痛阴。云何想阴。意种种缘一切法想。是三种小大无数种种收入摄。以是因缘想是谓想阴。云何行阴。有为法中行作种种诸法。是行阴二种。心相应法不相应。云何心相应。一思二更乐三忆等诸法。是名心相应。云何心不相应。一得二无想三灭尽定等心不相应。是谓行阴。云何识阴。青黄赤白等诸法分别识。是识有六种。眼识耳鼻舌身意识。云何眼识。眼情依止识色。是谓眼识。如是耳鼻舌身意。意情依止识法是谓意识。是谓识阴。十二入。眼入耳鼻舌身意入。是内六入。色入声香味细滑法入。是外六入。亦复眼识乃至意识合十八。持四大净造色识因缘是谓眼。如是四大净造声香味细滑识因缘。是谓耳鼻舌身。一切眼识尘色十二种。长短明闇青黄赤白粗细色边空色身教色。一切耳识尘声。众生数声非众生数声。一切鼻识尘香。好香臭香等香。一切舌识尘味。辛酸碱苦甘等六十三种味。一切身识尘。细滑轻重坚软寒热饥渴四大等。一切意识尘法。是谓一切法。五识不能分别意识分别。心意识无差别说有差别。情尘识合是生更乐共生痛等。十大地十烦恼大地。十小烦恼地。是诸法共心生。共缘共住共起共灭。譬如灯明热共起共住共尽。问十八持几善几不善几无记。答八无记。十当分别。色持声持七识持法持有善不善无记。云何善色。善身教。云何不善色。不善身教。云何无记色。除善不善身教。诸余色持。是谓无记。如是声尘眼识有善不善无记。云何善。善忆相应眼识。云何不善。不善忆相应眼识。云何无记。无记忆相应眼识。如是耳鼻舌身意。意识持法持。或善不善无记。云何善。法持摄善身口业善痛想行阴及智缘尽。云何不善。法持摄不善身口业不善痛想行阴。云何无记。法持摄无记痛想行阴及虚空非智缘尽。问十八持几有漏几无漏。答十八持十五持有漏。三当分别。云何三。意持法持意识持。有漏忆相应意持。是谓有漏。无漏忆相应意持。是谓无漏。意识亦如是。法持中摄有漏身口业有漏痛想行阴。是谓有漏。法持摄无漏身口业无漏痛想行阴及无为法。是谓无漏。问十八持几欲界系几色界系几无色界系几不系。答四持欲界系。香味鼻识舌识。以揣食处故。十四当分别。眼持欲色界系。云何欲界系。欲界系四大造。如是耳鼻舌身色声细滑持欲界系。欲界系四大造。云何色界系眼持。色界系四大造。如是耳鼻舌身色声细滑持色界系。色界系四大造。眼识欲色界系。云何欲界。欲界忆相应眼识。耳身识持亦如是。云何色界。色界忆相应眼识。耳身亦如是。意持欲界系色无色界系。或不系云何欲界系。欲界忆相应意持。云何色界系。色界忆相应意持。云何无色界系。无色界忆相应意持。云何不系。无漏忆相应意持。意识持亦如是。法持或欲界系。或色无色界系。或不系。法持摄欲界系身口业。及痛想行阴。是谓欲界系。云何色界系。法持摄色界系身口业。及痛想行阴。是谓色界系。云何无色界系。法持摄无色界痛想行阴。是谓无色界系。云何不系。法持摄无漏身口口业。无漏痛想行阴及无为法。是谓不系。问十八持几内入摄几外入摄。答十二持内入摄。眼耳鼻舌身意。眼识持耳鼻舌身意识持。六外入摄。色持声香味细滑法持。问几有觉有观。几有觉无观。几无觉无观。答十无觉无观。五情五尘五识有觉有观。三当分别。意持或有觉有观有觉无观无觉无观。云何有觉有观。欲界初禅有觉有观。中间禅有觉无观。上地无觉无观。意识亦如是。法持摄身口业诸不相应行无为无觉无观。余残如意持。问几共缘几不共缘。答七心持共缘。何以故。自尘缘故。十持不共缘。五情五尘。法持当分别。法持摄身口业识心不相应行无为不共缘。余残共缘。问十八持几受几不受。答九持情根合若现在是受。于中心心数法止住过去未来不受。非彼心心数法止住。声持七识持法持是不受。非彼心心数法止住。问十八持几有为几无为。答十七持有为。法持当分别。或有为或无为。云何有为。法持摄身口业痛想行阴是谓有为。智缘尽非智缘尽虚空。是谓无为

    阿毗昙甘露味行品第六

一切有为法无势力起。因他力共生。是诸法有四相起住老无常。问若有四相。是应更复有相。答更有四相。彼相中余四相俱生。生为生住为住老为老无常为无常。问若尔者不可尽答展转自相为诸行法二种。有心相应有心不相应。云何心相应。痛想思更乐忆欲解脱信精进念定慧觉观。邪行不邪行善根不善根无记根。一切使恼结缚缠一切智慧。如是种种心相应法。是谓心相应行。云何心不相应行。得生住老无常无想定灭尽定无想处。种种方得物得入得名众句众味众凡夫性。如是种种法。是谓心不相应行。因缘次第缘缘缘增上缘。一切有为法从是四缘生。云何因缘。五因相应共有自然遍报因。是谓因缘。云何次第缘。诸法中心心数是。是法灭是法起。是为次第缘。云何缘缘。缘尘故心心数法生。是谓缘缘。云何增上缘。一切万物不相障碍。是谓增上缘。六因。相应因共有自然遍报所作因。云何相应因。心诸数法因。诸心数法心因。是谓相应。云何共有因。诸法各各相伴。心诸心数法因。诸心数法心因。复次共生四大共有因。造色心不相应行。心心数法心不相应行因。云何自然因。谓彼前生善后生善。前生不善后生不善。前无记后无记。云何遍因。谓身见计我我有常。诸阴受有常我乐净等生诸烦恼。云何报因。谓善生乐报。不善生苦报。云何所作因。一切诸法各各不相障碍不留不住。报心有五因除遍因。如是心数法。一切烦恼有五因除报因。报生色及不相应行有四因。除相应因遍因。染污色及不相应行有四因。除相应因报因。余残心心数法有四因。除报因遍因。余残心不相应行或二因或三因。除相应因遍因报因。或除自然因。或不无初。无漏心相应法有三因。除自然因报因遍因。是无漏心心中生色及心不相应行有二因。共因所作因。心心数法是从四缘生。无想定灭尽定是从三缘生。除缘缘。心不相应行及诸色法是从二缘生。除次第缘缘缘。无有法一缘生。余法力故生。一法三事会更乐共生。痛想思忆欲解脱信精进念定慧护共心起合成就。是诸法共心俱三法会更乐身心受痛缘分别识想动思心不忘忆欲作欲心无碍解脱信。种种事勤精进缘胜不忘。念心不动定。分别法慧心不着护事缘起。心法相应得诸法成就。痛想思更乐忆欲解脱念定慧是十大地法。何以故。一切心共生。云何相应共一缘行不增不减。是谓相应。十烦恼大地。一切不善心中共生。不信懈怠忘心乱闇钝邪忆邪解脱调无明邪行。云何不信。心不入法。云何懈怠心寇在作。云何忘不念。云何心乱不一心。云何闇钝不晓事。云何邪忆非道念。云何邪解脱不舍颠倒。云何调心走不息。云何无明三界中无智。云何邪行不住善法。十小烦恼地。嗔优波那不语波陀舍摩夜舍耻悭嫉慢大慢。云何嗔心忿动。云何优波那心含毒住。云何不语覆藏罪事。云何波陀舍非法事急持不舍。云何摩夜身口欺人。云何舍耻心忮收。云何悭心惜畏尽。云何嫉见他好事嗔。云何慢于卑贱我胜。于上我等。云何大慢。等中我大于大中我胜大。此十烦恼地意识相应。非五识故言小也。于中七烦恼欲界系。舍耻欲界及梵天慢大慢三界系。十善大地不贪不恚信猗不放逸精进护不娆恼。云何不贪自身他身财物不欲不利。云何不恚。若众生边非众生边心不起恚。云何信。知实事心清净。云何猗。心善离重得轻冷。云何不放逸。心系善法。云何精进。习近善法。云何护。于诸法离住。云何不娆恼。一切众生中身口意不犯恶。云何惭。自作恶事羞。云何愧。于人中作不可事愧。是十法一切善心相应。是故说大地。三处爱处不爱处中处爱处者。淫欲悭贪惜等诸烦恼生。不爱处者。嗔恚斗诤嫉妒等诸烦恼生。中处者。愚痴憍慢等诸烦恼生。一切结使烦恼三毒所摄。所以者何。有三不善根。一切结使烦恼。此三毒。生能断三善根。能恼乱三界众生。是故三毒所摄

    阿毗昙甘露味因缘种品第七

十二因缘者。无明行识名色六入更乐痛爱受有生老死。是十二因缘有三种。一烦恼二业三苦。三种烦恼无明爱受。二种业行及有。七种苦识名色六入更乐痛生老死。二种过去摄。二种未来摄。八现在摄。诸烦恼业因业苦因苦烦恼因烦恼烦恼因烦恼业因业苦因苦苦因。彼种次第起。过去无明与一切烦恼相应是无明。缘此造业。造业造世间果是名行。彼行因缘染污心得身根分别识。譬如犊子识母是识。是识共生四无色阴。亦相续生色是名色。依眼等根境界是六入。情尘心和是更乐。更乐生受是痛。痛所著是爱。渴具所烦劳是受。劳造业是有。未来果是生。生起无量苦是老死。复次无明不知四谛。内外法去来今佛法众因缘。如是种种实法不知。是谓无明。痴人作三种行。有德行无德行不动行。云何有德行。得好报。云何无德行。得恶报。云何不动行。生色无色界。复次布施持戒禅。云何布施。二种布施。一者财施。二者法施。五种持戒。若受戒至竟净除恶心垢。常念守护不求世间报。禅者不净观数息等意一切有漏善定法。是有德行。云何无德行。三不善根十不善道等种种罪。是谓无德行。云何不动行。初禅乃至有想无想定。是谓不动行。三因缘有漏识受第一七有是谓识。从识有名色痛想行识阴是谓名。四大及造色是谓色。二事俱说名色名色生六入。六入生更乐。更乐有六种。二种身意起有对增语。六识分别故六种更乐。更乐生爱不爱不爱不不爱。有三种痛。苦乐不苦不乐。云何苦痛。嗔恚使所使。云何乐痛。欲使所使。云何不苦不乐痛。无明使所使。起乐住乐尽不乐。是谓乐痛。起苦住苦尽不苦。是谓苦痛。不智不乐智时乐。是谓不苦不乐痛。生三种渴。欲渴色渴无色渴。求无厌足想渴。生四种受。欲受见受戒受我受。欲界系除十二见。诸余烦恼。是谓欲受。四邪见是谓见受。外持戒求索道。是谓戒受。色无色界系除二十四见。诸余烦恼。是谓我受。四受生诸结使业处。三种有。欲有色有无色有。有生得五阴是谓生。行衰。古是老。二种老。一渐消渐消老。二年熟老。二种死。有自死他杀死。得愁忧悲恼苦。云何愁心。不用不欲事来心热是谓愁。云何悲哭。种种说哭是谓悲。云何苦。身恼苦是谓苦。云何忧。心恼是谓忧。云何恼。县官水火盗贼等种种急。及余事。是谓恼。如是无量苦聚是无明等因缘。是因缘尽诸报果尽。如是无量苦聚尽。六种合得人身。云何六种。四大空识。地水火风。三大有色。地水火量度长短粗细。风风种一种。四大常合无差别。坚相地湿相水热相火动相风。外四大成就内四大种。色中空。眼识缘有内外。是谓空种。五识及有漏意识。是谓识种。生卅六种。坚高地。水润合。火煮除烂臭。风动坐起动作。生长因空。余食消化风持去。识力有命。是谓人

    阿毗昙甘露味净根品第八

淫怒痴心相应。是谓烦恼。是谓结缚。欲除是三种者。一制二除三智断。云何制。若未得无漏心。持戒思惟却淫怒痴心不受是谓制。云何除。得禅定离淫恶不善法是谓除。云何智断。觉意缘苦习断是谓断。若制若除或时净或不净。无漏智断。是谓清净。二十二根。诸外入男女命。苦乐忧喜护信精进念定慧。未知已知大知根。内六根如前说。男相男识是谓男根。女相女识是谓女根。三界中活相是谓命根。六识相应乐痛是谓乐根。五识相应苦痛是谓苦根。意识相应乐痛是谓喜根。意识相应苦痛是谓忧根。六识相应不苦不乐痛是谓护根。诸善法中信是谓信根。如是精进念定。慧根。坚信坚法道摄。无漏九根是未知根。信解脱见到道摄。无漏九根是已知根。无学道摄。无漏九根是大知根。云何根义。有力有利是谓根。六情男女命九根世界中有力有利五痛根烦恼生有力有利。信等五根善法中有力有利。三无漏根道中有力有利。得道故诸根各自有力有利二十二。根几欲界系几色无色界。系几不系四根欲界系男女。忧苦根五根欲色界系。眼耳鼻舌身根有漏喜乐根欲色界系。有漏护意命根信等五根一切三界系。无漏意根护根喜乐根信等五根是不系。是九根合是三无漏根。未知根已知根大知根。二十二根几受几不受。乐等五根信等五根一切无漏根是不受。余残根或受或不受。二十二根几善几不善几无记。八根善。信等五三无漏八无记根。眼等五根男女命根六当分别意根乐等五痛根。或善或不善或无记。二十二根几有漏几无漏。信等五乐喜护意或有漏或无漏。后三根一向无漏。十根有漏。眼耳鼻舌身男女命忧苦。三种生最初得二根。身根及命根。化生或六七八无形。六一形七二形八。眼等五及命男女根。余残根次第得。色界中最初得。六根五情命根。无色界最初得一命根。欲界无记心渐命终四。或八或九或十。若善心死九。若十三若十四若十五。二十二根几见谛断几思惟断几不断。四根或见谛断或思惟断或不断。意乐喜护根忧根。或见谛断或思惟断。信等五根或思惟断或不断。三无漏根不断。余残根思惟断

    阿毗昙甘露味结使禅智品第九

九十八使二种断。见谛断思惟断。二十八见苦断。十九见习断。十九见尽断。二十二见道断。十思惟断。欲界系见苦断十使见习断。七使见尽断。七使见道断。八使思惟断。四是三十六使欲界系。除嗔恚余残结使色无色中各断三十一。略言实十使。身邪边邪邪见盗戒盗疑爱恚慢无明。云何身邪。五阴中计我。如是见谓身邪世界有边无边。如是见谓边邪。无四谛因缘果报。如是见谓邪见。有漏法中计常第一。如是见谓见盗。非净因缘中求净道。如是见谓戒盗。未得道心痴不了。是不是有不有。是谓疑痴心。诸法中欲着是谓爱。痴心中不欲对来心忿动是谓嗔。自大心贡高是谓慢。诸法实相不知。是谓无明。是诸使欲界苦谛。一切习谛七尽谛亦尔。道谛八诸邪。疑见谛断。欲界四思惟断。色无色界六思惟所断。贪恚慢无明五行断。疑邪邪见盗四谛断。身邪边邪苦谛断。戒盗苦谛道谛断。欲界苦谛断六五邪疑。习谛断三二邪疑。无明二种苦谛断。无明或遍或不遍。云何遍六使相应及不共无明是谓遍。云何不遍。三使相应无明是不遍。如是习三使相应及不共无明是谓遍。余残不遍。诸使除爱恚慢。余残一切遍。何以故。是诸使五缘。是一切遍使中二邪。及彼相应无明。自界一切遍非他界。色界亦如是。无色界一切遍使自界一切遍。余残一切遍使自界一切遍亦缘他界。无明一切使相应因。及不共无明。三界尽谛道谛所断。邪邪疑无明。是十八使无漏缘。余有漏缘。诸有漏缘使及彼。相应无明有漏缘。余残无明无漏缘。一切三界结使护根相应。梵天光耀天中诸使护根相应及喜根。遍净天诸使护根乐根相应。欲界系邪邪见无明。三根相应。喜根忧根护根。疑二根相应。忧根护根。嗔恚三根相应。忧根苦根护根。余残欲界见谛断。二根相应。喜根护根。欲界中思惟所断。六识相应。除慢慢意识相应。一切见谛所断。意识相应。十小烦恼是说缠。一嗔二自罪怖三睡四眠五调六戏七悭八嫉九无惭十无愧。云何嗔。心恶利动。云何自罪怖。畏人见闻。云何睡。心沉心重身重一切结使相应。云何眠。心合卧出不自在眠。欲界系意识相应。云何调。心不善不自与一切结使相应。云何戏。作善不善后悔。与忧根相应。云何悭。爱惜心吝。云何嫉。见他得好事不欢喜。欲使得苦。是二结欲界系思惟所断。云何无惭。自作恶不羞。云何无愧。作恶不愧他。是二一切不善法相应。三结爱恚无明六识相应。色界二爱无明四识相应。余残结使意识相应。一时无碍道断。结使作证时重作证。断欲界结得三断智。欲界苦谛习谛所断一断智。尽谛所断二断智。道谛所断三断智。色无色界四谛所断结尽三断智。欲界中五下分结尽七断智。色界思惟所断八断智。一切结使烦恼尽九断智。灭结无余是谓断智。有如是诸结使。心不相应缠心相应。是事不然一切心相应。何以故。起结使烦恼坏善法。见结使是时善法生。是故知一切结使心相应。是诸一切结使二事断禅智相应心。云何禅断初柔软心。云何智分别诸法。入定一心诸法无常等观思惟。是谓智禅智俱行共思惟得解脱。三时善精进一心护坐禅时。若心柔软。是时应思惟精进。若心调是时应一心思惟善。若是二事俱不柔软不调。是时放心去。譬如锻金师持金着火中。时时囊吹。时时持水浇。时时放休。何以故。若常吹金便焦融。常水浇冷不热。若常放不调熟。坐禅亦如是。囊吹如精进。着水浇如禅。放舍如护。何以故。常精进心调。常定一心心柔软。常护不受诸心。是故时时勤精进。时时一心定。时时护。如是心和调。一切结使中得解脱

    阿毗昙甘露味三十七无漏人品第十

坐禅法先系心一处。若顶上若额端若眉间若鼻头若心中。令心一处住。若念走摄来还着处处。是心者譬如猕猴。系颈着柱绕柱走不得去极便住。心走亦如是。系心着法便不去极便住。渐渐观身痛意法。是人法意止中。淳淑一心得实智慧。观一切行实相。生灭不住故无常。积灾患故苦。内无人故空。不自在故非我。从是得暖法意中起。譬如钻火木中生。佛法中生信净善根。四缘观十六行。四行观苦谛。从因缘生不住故无常。无常力坏故苦。无人故空。不自在故非我。四行观习谛。生相似果故习因。生死不绝故习。不可尽故有。不相似相续故缘。四行观尽谛。一切苦患闭故尽。除一切结使火故止。胜一切法故妙。出三界故度。四行观道谛。能到涅槃故道。非颠倒故应。圣人所行故住。能离世间恼故出。观十六行善法常勤精进。是谓暖法。从是暖善根增胜长。是谓顶善根。信三宝。若信五阴无常若苦空非我。如是缘四谛十六行。胜暖法故说顶已增上。顶随谛忍名忍善根。是有三种上中下。缘四谛观。观十六行。顺谛增上善根。是名世间第一法。一心时心心数法。是谓世间第一善根。有言信等五根是世间第一法。如实义一心时心心数法。是世间第一善根。能开涅槃门。是凡夫法中第一缘。观一谛四行。无常苦空非我。何以故。第一无漏心缘苦谛。世间第一法亦如是。六禅地未到禅中间禅四禅。是忍顶暖善根。六地中有世间第一法。次第起无漏人。是名苦法忍。未曾见始见能忍故说忍。是初忍无碍道。次第苦法智生。实知苦相。苦法智解脱道。是二心缘欲界系苦。未知忍无碍道。未知智解脱道。是二心缘色无色界系。苦习尽道谛亦如是。是正观诸法十六净心。十五心中利根。是说随法行。钝根是说随信行。是二人未离欲界结向第一果。欲界结使六种断向第二果。若九种结尽向第三果。向第一果欲到十五心中行人。亦复果中间行人。是二人随法行。随信行到十六心中得果住。是二人先未断结。满十六心俱须陀洹。若断六种结。满十六心俱斯陀含。若断九种结。满十六心俱阿那含。得第三果。八十八结尽。是人无漏戒善根成就故说须陀洹。利根得果名见到。钝根得果名信解脱。是二人若欲界系思惟断结。不尽七死七生。若先尽三品是名家家。三死三生。八直道水流到涅槃。是中行须陀洹。六种结尽是说斯陀含。八种结尽是说一种。生欲界天还生人中便般涅槃。是名一种及斯陀含。五阿那含。中般涅槃。生般涅槃。行般涅槃。无行般涅槃。上流阿迦尼到阿那含。复有无色界生阿那含。色无色界苦尽得般涅槃不生下界。是说阿那含。欲界结使九种。色无色界亦如是。是诸结使两道断。无碍道解脱道。先无碍断解脱道成就。譬如得毒蛇着瓶中盖口。世俗道出世出世界道界道。断欲界色无色界系诸结使。世俗道亦能断除世界上系。八地离欲得灭尽定。是说身证阿那含。若俱解脱阿罗汉法似涅槃身中着。五下分结尽得阿那含。五上分结尽得阿罗汉。是色无色界中诸余结。使缠缚是说心调。如金刚定次第灭智生。是时得阿罗汉果。是最上有离欲无碍道。亦最后学心是金刚定次第。初无学灭智生。我诸生尽灭。我得阿罗汉。一切结尽大小烦恼断灭。是说阿罗汉。一切人天中应受供养。是名阿罗汉。是无学九种。一退法。二不退法。三思法。四守法。五住法。六能进法。七不动法。八慧解脱。九俱解脱。云何退法。软智软精进。五退具中行退道果。是谓退法。云何不退法。利智勤精进。五退具中不行不退道果。是谓不退法。云何思法。软智软精进。勤观身不净可恶。思惟自灭身。是思法。云何守法。软智勤精进自守身。是守法。云何住法。中智中精进中道行不增减。是住法。云何能进法。少利智勤精进能得不动善。是能进法。云何不动法。利根大勤精进。先时得不动善。是不动法。云何慧解脱。不得灭尽定。是慧解脱。云何俱解脱。能得灭尽定。是俱解脱。随信行五种阿罗汉名时解脱。是诸阿罗汉二智灭智无学直见。随法行一种阿罗汉利根是名不时解脱。是阿罗汉三智灭智无生智无学直见。八阿罗汉爱时解脱成就不动法。成就随信行见谛道十五心中无漏九根。是名未知根。十六心得果。是无漏九根。是名已知根。是九根俱无学法。是名大知根。得果时失向道。道中断结使尽。二种成就。有为无为。得大果时一切失本二种得一种成就。九种断结使诸不隐没法。第九心一切得断。能进法阿罗汉得不动善非余。信解脱学得利根。名见到非余。见谛道中结使各各异。无漏法各各异。以是故渐渐见谛。不一时见无碍道力得果。以是故二种果有为果无为果

阿毗昙甘露味论卷上阿毗昙甘露味论卷下

        尊者瞿沙造

        曹魏代译失三藏名

    智品第十一

十智。法智未知智等智知他人心智苦智习智尽智道智灭智无生智。云何法智。欲界系诸行苦中无漏智。欲界系诸行习中无漏智。欲界系诸行尽中无漏智。欲界系诸行道断故。道中无漏智及法智地中无漏智。是谓法智。云何未知智。色无色界系诸行苦中无漏智。色无色界系诸行习中无漏智。色无色界系诸行尽中无漏智。色无色界系诸行道断故。道中无漏智及未知智。未知智地中无漏智。是谓未知智。云何等智。一切有漏智慧。若善不善无记。是谓等智。云何知他人心智。禅中思惟力得欲界中知他心心数法。是谓知他心智。云何苦智。五受阴中无常苦空非我无漏智观。是谓苦智。云何习智。五受阴习因有缘无漏智观。是谓习智。云何尽智。尽止妙出无漏智观。是谓尽智。云何道智。八直道应住出无漏智观。是谓道智。云何灭智。见苦断习无证思惟道。是四法中无漏智观。是谓灭智。云何无生智。我已见苦不复更见。我已断习不复更断。已尽作证不复更作证。已思惟道不复更思惟道。是四法中无漏智观。是谓无生智。是十智中二智十六行。法智未知智暖顶忍法中等智十六行。世间第一法中等智四行。余残无行。无漏他心智四行。如道智。有漏知他心智无行。苦智四行。习智四行。尽智四行。道智四行。灭智无生智。各十四行。除空无我行。未到禅及中禅地有九智。除知他心智。余四禅中十智。无色定八智。除法智知他人心智。第一无漏心成就一等智。第二无漏心成就三智。等智法智苦智。第三无漏心过。第四无漏心成就四智。等智法智苦智未知智。第五无漏心过。第六无漏心成就五智。等智法智苦智未知智习法智。第七无漏心过。第八无漏心亦过。第九无漏心成就六智。等智法智苦智未知智习智尽智。第十第十一无漏心过。十二无漏心成就七智。等智法智苦智未知智习智尽智道智。若已离欲曾知他人心智。二种修智。得修行修。先未得功德今得是谓得修。先得功德现在前入是谓行修。见谛道中现在前修彼即当来修。如是诸忍现在前修亦当来修。苦未知智习未知智尽未知智。是三未知智中修等智。道未知智中或修六或修七。若未离欲修六智。已离欲修七智。知他人心智过须陀洹果。十七心中修七智。除灭智无生智知他心智。是十七心中信解脱得利根时。无碍解脱两道中修六智。除他心智等智灭智无生智。得阿那含果。解脱道中修八智。除灭智无生智。如是七地离欲时。解脱道中修八智。除灭智无生智。是谓无碍道中修七智。除他人心智灭智无生智。有想无想离欲时。八解脱道中修七智。除等智灭智无生智。九无碍道中修六智。除等智知他心智灭智无生智。初无学心中修有漏无漏诸善根。初无学心苦未知智相应。有言习未知智相应。何以故。有想无想处生缘相应。初无学心见谛八忍求觅故名见。非智灭智无生智是智非见。余残无漏慧亦慧亦见亦智。除意识相应善有漏慧。及五邪见。余残有漏慧。亦智亦慧非见。法智九智缘。除未知智。未知智九智缘除法智。道智九智缘除等智。苦智习智一切有漏法缘。余残智十智缘。等智他心智灭智无生智。二智尽法智道法智。能灭三界结。六通四通。等智身通耳通眼通宿命通他心通。五智法智未知智道智等智他心智漏尽通。无漏九智除等智。四意止身意止八智。除他心智尽智。痛意止心意止九智。除尽智。法意止十智四辩法辩辞辩。等智应辩义辩。各十智愿智七智。除他心智灭智无生智。十力第一力十智知。二力三力四力五力六力九智除尽智。七力十智。八力九力一智等智。十力九智除等智。第一无畏十智知。二无畏九智知除等智。三无畏八智知除道智尽智。四无畏八智知除苦智习智

    阿毗昙甘露味禅定品第十二

得禅定一心心不分散智慧清净。譬如油灯离风处明清净。云何禅定。八禅定四禅四无色定。四禅初禅二三四禅。是诸禅定三禅味净。无漏爱相应是谓有味。善有漏禅是谓净。无烦恼是谓无漏。有顶中二种定。有味及净。无无漏定善法。空闲静处坐若立若卧若行若步定意智巧心中软信。如是心应入禅定。禅相应欲精进念慧一心。是诸善法。趣初禅定。离欲离恶不善法。有觉有观离欲生得喜乐。是谓初禅。染着外入是谓贪欲。嗔恚睡眠调戏疑。此诸盖是谓恶不善法。是二内外恶法断是谓离。心回转缘是谓觉。心受行思惟是谓观。恶不善法断。力得禅是谓离欲。心生悦是谓喜。身心安隐是谓乐。心系缘中是谓一心。是初禅五支。淫欲大苦罪不乐离力安隐出。如是思惟欲等。诸善法心中生。是谓得初禅道。是三痛根相应。喜乐护根。乐根三识身相应。眼耳身识。喜根意识相应。护根四识相应。是初禅有别身别想有别身一想。四心初禅眼耳身意。是谓初禅诸觉观。灭内净一心无觉无观定生得喜乐相应。是谓二禅觉观。如前说。断却是谓灭。诸地信无垢是谓内清净。意识系缘不散是谓一心。喜乐支如前说。是二痛根相应。喜根护根。别身一想喜相应。根本近地护根相应。除灭觉观垢。除灭思惟功德。是道趣二禅。离喜垢故。护行下受身乐无漏人。是说乐护念下乐入三禅。离喜如前说。护心放舍乐二种痛乐不烦恼。是乐身中行念守看。是乐难知实法。是故无漏说乐。亦行护欲等诸善法。是道趣三禅。观喜恶罪不喜乐观禅。止乐护念智一心。是谓五支如前说。是谓三禅。断乐苦先灭忧喜根。护念净入四禅。欲等诸善法。亦复观乐苦垢不苦不乐。善止是道入四禅。四支护念善智一心禅力灭喘息。是谓四禅。一切禅支善。未到禅地有觉有观。中间禅无觉有观。是二地护根相应。未到禅地二种净无漏非味。四禅中三种味净无漏。是谓禅法。离色忆亦观无量空。入空定观色垢空处善止。观是道趣空定。忆无量识入识处。观空处垢识处善止。观是道趣识定。无量识行是为苦。忆不用处行入不用定。观无量识处垢。不用处善止。观是道趣不用定。有想处病无想处痴。如是思惟入有想无想定。观不用处垢。有想无想善止。观是道趣有想无想定。是谓有想无想定。趣涅槃道二种。一观身不净。二念数息。身意止中第一二解脱。四除入中广说不净法。入定数息一二乃到十念。守出入息如守门人。观一切法起灭。是二相自相六种分别。观身无常苦空非我。如是一切诸法观。恐畏世界渐渐灭垢。行善法起至涅槃。未到禅地中间禅地四禅地三无色地有二种。有漏无漏。有顶一切有漏十想。无常苦苦无我。观食一切世间不可乐不净死断无欲尽想。忆念诸行无常。是谓无常想。忆念生等苦满世间。是谓苦想。忆念内外无常苦不自在空。是谓苦无我想。忆念多勤苦得食啖时不净。是谓观食想。忆念生老病死等怖畏种种烦恼满世界。是谓一切世间不可乐想。自身内实观。是谓不净想。忆念一切生必得死。是谓死想。忆念灭一切烦恼善止。是谓断想。忆念非常离欲。是谓无欲想。忆念五受阴更不生尽止妙离涅槃。是谓尽想。是十想常忆念得尽苦际

    阿毗昙甘露味杂定品第十三

三昧等通一切入。阴入智解脱禅。三三昧空三昧无愿三昧无想三昧。心系缘无漏故是谓三昧。一心观五受阴空无我非我。是谓空三昧。入是三昧不愿淫怒痴更有生。是谓无愿三昧。是三昧缘离十想法。云何十想。色等五尘。男女生老无常。是谓无想三昧。空三昧二行。空行无我行。无愿三昧十行。无常苦行亦习道行。无想三昧尽四行。四等慈悲喜护。自得快乐事念与一切众生。是有三种心。先所亲眷属。次及中人后怨家贼。一心思惟。一切三界众生身及怨家等无异。除内嗔恚。是慈等相应痛想行识。能起正语正业。亦不相应诸行。是谓慈等。一心思惟。三界众生身心种辛苦欲拔济。如是思惟能除外恼。是悲等相应痛想行识。能起正语正业。亦不相应诸行。是谓悲等。一心思惟。三界众生欢喜得乐能除忧苦。喜等相应痛想行识。能起正语正业。亦不相应诸行。是谓喜等。一心思惟。三界众生乐苦喜放护。能除欲嗔。护等相应痛想行识。能起正语正业。亦不相应诸行。是谓护等。六通神足天眼天耳识宿命他心智漏尽通。除第六通。余残凡夫亦得。云何神足通是有三种。一者飞行二变化三圣人通有三种飞行。一自身去譬如飞鸟。二于此土忽然不现到他方。三心力自在如屈申臂。是谓诸佛神通非余道。常观身空学轻举。是道趣神通。能大能小能多少能少多。能转作种种物。是谓变化神通。凡夫人变化至七日。不过七日灭。佛佛弟子自在变化。变化时观世间净作不净。不净作净。除净不净念心念护。是谓圣人神通。是三种通从四神足力生。一切色缘渐渐得轻举。诸佛一时得。天眼通自眼边。色界四大造净生得天眼。自地下地近远彻视。见一切细微色。忆念日月星宿火明珠。是道得天眼通。天耳通自耳边。色界四大造净生得天耳。天人地狱饿鬼畜生种种声忆念识知。是道趣天耳通。识宿命通念先世事所来生处。是道趣宿命通。知他人心通。常念他染污心及他清净心悉知。自心生灭能分别知。是道趣知他心通。三界漏一切我尽。如是知五受阴无常等忆念。是道得漏尽通。宿命通及天眼漏尽是谓明。宿命通知因缘世次第是谓明。天眼通知因缘如行业得报是谓明。漏尽通欲界色无色界漏尽我尽诸漏是谓明。十一切入。忆念一切地不念余。是谓地一切入。乃至识一切入亦如是。八解脱。内有色想外观色。内无色想外观色。净解脱作证四无色定灭尽定。是谓八解脱。缘观转心得解脱。是谓解脱。观内色不净及观外色。是谓初解脱。不观内色观外色不净。是第二解脱。分别观内外色一切净色。是第三解脱。四无色定四解脱灭尽解脱。内有色想外观色少好丑。是缘胜知见第一除入。内有色想外观色无量好丑。是缘胜知见第二除入。内无色想外观色少好丑。是缘胜知见第三除入。内无色想外观色无量好丑。是缘胜知见第四除入。内无色想外观色青是缘胜知见第五除入。黄赤白亦如是。内不除色想外净少色观。一无量缘。二内除色想外净少色观。三无量缘。四余青黄赤白忆念。四除入净缘胜。是故说除入。好色形像端正除垢故解脱。是谓除入。名别三解脱四除入。八一切入净解脱摄。十智如前说。三等慈悲护及五通。根本四禅中有。六地中法智未到禅中间禅根本四禅。喜等第一第二解脱。初四除入禅初禅二禅中有余残除入净解脱八一切入第四禅中有。余残解脱二一切入自名摄。灭尽解脱有顶中摄。三三昧七智漏尽通九地中摄。除有顶中等智。十地中有无色界三解脱。或有漏或无漏。余三解脱八除入十一切入有漏。有顶中一切有漏钝不捷疾。是故有漏。灭尽定无智慧。是故有漏。五通中多无记心四等缘众生。是故有漏。欲爱未尽三界结使成就。欲爱已尽色无色界结使成就。色爱尽无色界结使成就。无色界爱尽三界结使不成就。欲界爱尽净无漏初禅成就。如是一切地中圣人无漏成就。圣人生上下地无漏成就。求得五通四等下地结垢不成就。世俗道依未到禅地离下地欲。如是一切地无漏道依根本禅地。自地亦上地离欲。如是一切地。是故凡夫有顶中不能离欲。暖法顶法忍法世间第一法离欲。人修有漏禅定二时。现在未来。见谛道中苦习尽。未知智中现在前修无漏智。未来二种有漏无漏智。余残心中现前无漏未来无漏。世尊弟子若离欲爱。依未到禅地现在前修有漏道。未来修有漏无漏道。第九解脱道现在修有漏道。未来修有漏无漏。初禅及修无漏未到禅。若依未到禅现在修无漏道。未来修有漏无漏道。第九解脱道中现在前修无漏道。未来修有漏无漏道。初禅世尊弟子若离初禅爱欲。依未到二禅地现在前修有漏道。未来修有漏无漏道。第九解脱道中现在前修有漏道。未来修无漏。三种初禅及修净无漏第二禅。若离初禅爱。依无漏道趣二禅。自地修无漏。他地修有漏无漏道。第九解脱道中现在前修无漏道。未来修无漏。三种初禅及净无漏第二禅。乃至不用处。离欲亦复如是。有顶中离欲时。修一切无漏禅定。第九解脱道中现在前修无漏道。未来修无漏。及修三界系善根二十三种定。有味八净八无漏七一切无漏七地无漏自然因。自地无漏。自地无漏三种因。相应因共有因自然因。第一有味定。第一有味定因非他因第一净定。第一净定因非他因。第一无漏定。次第起六种定。第一禅二种净无漏。如是第二第三禅。无漏第二禅次第生八地。自地二上地四下地二。无漏第三禅第四禅空处定。次第生十上地四下地四自地二。无漏识处次第生九。上地三下地四自地二。无漏不用处定次第生七。上地一下地四自地二。第四无色定次第生六。下地四自地二。净禅亦如是。有味次第生二。自地有味亦复净。如是一切地诸禅定净无漏。一切缘一切法缘。有味自地。自地有味缘亦复净。缘有味不能无漏缘诸净。无漏无色定不缘有漏地。有味无色定自地有味缘。及缘净不能缘无漏。四等八除入三解脱八一切入。是诸法一切欲界缘。五通欲色界缘。一切薰禅无漏禅薰有漏禅。得四禅人先薰第四禅后薰下三禅。得五净居报。不动法阿罗汉。得一切禅定。是能得顶禅。能住寿亦能舍寿。愿智从心所愿。尽知去来今诸法。多知未来法。四辩法辩辞辩应辩义辩。令他心不起恚。是谓无诤。四禅中摄。亦复欲界愿智第四禅摄。亦复欲界法辩辞辩欲界摄。及梵天中余二辩九地摄。欲界四禅四无色净禅二时。得离欲时得生时。得有味禅二时。得退时得生时。得无漏禅二种得。若退时得若离欲得九地摄。无漏能断结使。变化有十四心。色界十心欲界四心。初禅有二变化心。初禅一欲界一。二禅有三变化心。二禅一初禅一欲界一。三禅有四变化心。三禅一二禅一初禅一欲界一。四禅有五变化心。四禅一三禅一二禅一初禅一欲界一。何等禅成就。是果下地变化心。成就三禅地住。梵天识现在前能见闻。尔时成就。即灭尔时不成就

    阿毗昙甘露味三十七品第十四

意止意断神足根力觉道。是七法到涅槃。是中七觉无漏。六当分别或有漏或无漏。有言。七觉意八直道一切无漏。余残当分别。四意止一切地禅定中有摄四种智常念守。是谓念止。三种念身中行智慧。是谓身念止。如是痛心法念止。是谓四念止。以何等故。不说三念止若五念止。以破四颠倒故说四念止云何身念止。净想颠倒坏故。身实相观三十六不净。若死虫生臭烂骨在等。如是观身净想颠倒坏。云何痛念止。观诸有痛生住灭苦。乐痛中淫欲使。苦痛中嗔恚使。不苦不乐痛中无明使。观无常苦空无我。是谓痛念止。云何心念止。观染污心不染污心。若一心若散心苦无常等观。是谓心念止。云何法念止。观内法观外法。观内外法。若观去来法。若观诸结使几断几不断。若观苦无常。观习因缘观尽止。是谓法念止。云何四意断。心中生恶不善法欲除却。欲勤精进制心住善法。未生恶不善法莫令生。勤精进制心住善法。未生善法欲使生。勤精进住善法。已生善法念住莫失。增长广大勤精进住善法。是谓四意断。云何四神足。欲定精进定心定勤慧定从是得一切功德。是谓四神足。欲定断诸行。成就第一神足。欲作是谓欲。心不分散是谓定。欲精进念慧喜猗。是谓诸行合欲定。如是精进心慧欲大欲得定故。是谓欲定。如是精进心慧。是谓四神足。信精进念定慧。是谓五根。四不坏信中有信。是谓信根。四意精进。是谓精进根。四念止中念不忘。是谓念根。四禅定中一心。是谓定根。四谛中慧。是谓慧根。根利疾第一。是谓根义。信等五力恶不善法不能坏。是谓力。小是根大是力。念择法精进喜猗定护。是谓七觉。云何念。念有为法生灭种种罪涅槃至妙。是谓念觉。是中分别思惟。是谓择法觉。是中思惟勤精进。是谓精进觉。是中得善法味欢悦。是谓喜觉。是中思惟身心轻软安隐随定是谓猗觉。是中因缘摄心住不乱。是谓定觉是中放心息不念不欲。是谓护觉。种种智慧得禅定力。除一切烦恼。是谓七觉果。一切烦恼断念等七法是名觉。直见直思直语直业直命直念直方便直定。是谓八直道。四谛中实智慧。是谓直见。是中善不嗔不恼三种觉观。是谓直思。四种邪语断。是谓直语。三种邪业断。是谓直业。不善邪命断。是谓直命。是中思惟勤精进。是谓直方便。是中思惟念不忘。是谓直念。是中一心住。是谓直定。是谓八直道趣涅槃。信精进念定慧喜猗护思戒。是十法分别说三十七信法。是谓信根信力精进精进根精进力四意断精进觉意直方便念根念力念觉意直念喜喜觉慧慧根慧力四念止择法觉直见猗猗觉定定根定力四神足定觉直定护护觉思直思戒直语直业直命直因缘。四种智慧住是名念止。直精进是名意断。缘中一心住不散。是名四神足。钝根人心中生。是名五根。利根人心中生。是名五力。见谛道中。是名八直道。思惟道中。是名七觉。是十法摄三十七品。未到禅地三十六除喜觉。二禅地亦三十六除直思。三禅四禅中间禅三十五除喜觉直思。初禅三十七。三空定三十二除喜觉直思直语直业直命。有顶中二十二除七觉八道。欲界亦二十二除七觉八道

    阿毗昙甘露味四谛品第十五

四谛苦谛习尽道谛。云何苦谛。一种恼相为苦。二种身苦心苦。三种苦苦别离苦行无常苦。四种身内外苦心内外苦。五种五盛阴苦。六种三界苦三毒苦。七种七识处苦。八种苦生老病死怨憎会恩爱别离所求不得苦。一切种种苦是谓苦谛。云何习谛。是种种苦因五受阴是谓习谛。云何尽谛。苦习尽无余智缘尽是谓尽谛。行八直道是谓道谛。是四谛次第应知断证。自思惟实相。实得果得行人。不欺诳是谓谛。粗识故次第。苦谛粗易识。以是先苦谛。识苦推苦因从习中生。以是习谛第二。是苦谛何处灭尽。得解脱思惟涅槃中。以是故尽谛第三。是尽云何得。思惟行八直道断结使得尽谛。以是故道谛第四。五受阴报果时是谓苦谛。五受阴因缘时是谓习谛。亦谓苦谛。譬如人亦名子亦名父。习谛多是结使。何等结使。九结爱结嗔恚憍慢无明疑见失愿悭嫉结。三界欲是爱结。众生中心忿动恶利是嗔恚结。七种慢是慢结。三界系愚痴是无明结。三见是见结。二见是失愿结。四谛中不定了是疑结。心惜爱吝是悭结。妒他含恚是嫉结。尽谛二种。有漏断结使尽是一种。无漏道断结使尽是二种。种种诸净法。若四辩法辞应义。一切名字知实相。是谓法辩。一切语言谈论智。是谓辞辩。一切法知实相。是谓应辩。一切智慧语言禅定通智。是谓义辩。须陀洹四不坏信佛不坏信。法不坏信。僧不坏信。净戒中不坏信。阿罗汉果摄诸无学法。种种佛大功德中无漏信。是谓佛不坏信。涅槃中无漏及无漏谛中学无学法中。及菩萨实功德中无漏信净。是谓法不坏信。得无漏道果信有四双八辈一切功德。佛弟子众中信非余处。是谓僧不坏信。无教无漏戒。是中无漏信。是谓戒不坏信。净实智慧共合信。以是故无能胜是无漏戒。是故不坏信是谓四不坏信。有四事修定。修定于现法中得乐居。修定得智见。修定分别慧。修定得漏尽诸善。初禅能得现在乐居。生死智通是谓智见。方便求功德。是欲界无教戒闻思修功德。一切色无色界法。一切无漏有为法。是谓分别慧。金刚喻四禅。是最后学心共相应漏尽。是谓修定。得漏尽第四禅所摄。四道苦难知苦易知。乐难知乐易知。随信行无漏法钝根是苦难知。随法行无漏法利根苦易知。根本四禅中利根及钝根法说乐道。何以故。止观道等故。他地中止观多少故是说。苦未到禅中间禅二处止道少观道多。无色中观道少止道多。是谓苦道难得。故七识住一欲界中诸天及人。色界梵众天除初生天。是异身异想。二梵众天初生异身一想。三二禅生天一身异想。四三禅生天一身一想。五空处生天。六识处生天。七不用处生天。是谓七识住。何以故。不坏识故。恶趣中苦痛坏识故。不立识住。第四禅无想定坏识故。亦不立识住。非想非非想处灭尽定坏识故。亦不得立识住。九众生居此七识住。及无想众生非想非非想处。是谓九众生居。于中居止故。衣被饮食卧具喜断结使。思惟缘力得道。是说四圣种。若好若不好。衣被饮食卧具知足三圣种。求守失苦。是三苦失善道。不食命不活。以是故趣得知足三苦失离欲心中得乐欢喜。是谓第四。百八种痛眼耳鼻舌身意更乐生。是谓六更。有三种眼见色忧喜护。乃至意念法忧喜护。是中有善不善。善十八不善十八。是谓三十六。三种是谓百八。三十六过去。三十六未来。三十六现在。五识不能分别。是故无忧喜。意行中心数法相续不断常忆是谓念。忆因缘随顺是法。因缘重忆识念力强。是故不忘过去法。眼人心心数法因缘梦见有。无因无缘梦见。是梦若过去世若未来世。若梦见人生角。是先牛角。是强思惟人何以不生角。如是念已。梦见人生角心散心乱是谓痴。若身病故痴。若鬼魅故痴。若先世因缘故痴。三支。戒支定支慧支。云何戒支。欲界有教无教戒。色界中无教戒。云何定支。修十四定。云何慧支。三种慧闻思惟修。欲界二种闻思惟。色界二种闻思惟。无色界一种思惟。二种律仪。一情律仪。二戒律仪。云何情律仪。不得起淫母等想。若姊妹女想。见女人不应忆。不生念女根想。从是多罪恼。观心身离是谓情律仪。除却淫欲种种不善法。不毁戒行无玷污。心无瑕秽净却七淫欲。是谓戒律仪。烦恼恶业恶业报。是有三障。逆业极重烦恼三恶道报。是三事若一事不受圣法。是故说障。不善觉观有三种。淫欲恚恼。是破三种善觉观。不淫不恚不恼。三种病淫怒痴是病有三种药。身不净观。慈念众生。观十二因缘。是谓三种药。修身修戒修心修慧。是法不受一切恶报。或少少受报。或今世或后世少受报。云何修身。种种观无常等。云何修戒。持戒不犯常守护。云何修心。除恶觉观行善觉观。云何修慧。种种分别善法增益智慧。行善人易得好道。行不善人易得恶道。或有善人堕恶道。或有恶人生好道。先世大力因缘余报未尽。若死时最后心善不善。是故善堕恶道。不善人生好道

    阿毗昙甘露味杂品第十六

四沙门果六法五阴智缘尽。是谓分别四果。阿罗汉果九地所摄。除有顶中。第三果六地所摄。除四无色。以无法智故。须陀洹斯陀含未到禅地所摄。以未离欲人身故。有四颠倒。无常有常想。心颠倒想颠倒见颠倒。苦有乐想。不净有净想。非我有我想。心颠倒想颠倒见颠倒。一切颠倒见苦谛断。何以故。行缘苦处三见摄颠倒身见边见见盗。一切六十二见五邪见所摄五阴中不实我见有实我是身见。常断依止因缘果报不识是边见。谛真实法无今世后世。无涅槃及四谛等。是邪见。非真实乐净观有乐净。譬如断树木竖立。夜中遥看。谓是人。是见盗。非因见因非道见道是戒盗。身见苦谛断。五阴中计我故。常想断想。苦谛断缘现在五阴故邪见。若谛苦见苦断。如是谛习尽道见习尽道断见盗。若苦谛中计有乐净等见苦断。如是习尽道中计有乐净等见习尽道断。戒盗非道求涅槃。及非因见因是戒盗。见苦见道断。六修得修行修断修除修分别修律仪修。云何得修。未曾得善法功德而得。得已诸余功德亦得。云何修行。曾得诸功德今现在行。云何断修。善法断诸结使。云何除修。能却诸不善法。云何分别修。分别观身实相。云何律仪修。六情染污尘缘胜故。五根忧根初禅灭。无余苦根二禅灭。无余喜根三禅灭。无余乐根四禅灭。无余护根无想三昧灭。无余三界。断界无欲界尽界。除爱结诸余烦恼断是谓断界。爱结断是谓无欲界。诸余法断是谓尽界。灭淫欲得心解脱。灭愚痴得慧解脱。内外入不相系。淫欲是能系。譬两牛为轭所系。以是故爱不爱尘中应护心不应有爱嗔恚心。十法欲界色界无色界无漏相应不相应善无为无记无为。是谓十法。五法法智缘。云何五。欲界系相应不相应法无漏相应不相应法善无为法。是为五法。未知智缘七法。何等七。色界系相应不相应法。无色界系相应不相应法。无漏相应法不相应法善无为法。他心智缘三法。欲界系相应法。色界系相应法。无漏相应法。等智缘十法。欲界系相应法不相应法。色界系相应法不相应法。无色界系相应法不相应法。无漏相应不相应法。善无为法无记无为。苦智习智各各六法缘。三界系相应法不相应法。是谓六法。尽智缘一法。善无为法。道智缘二法。无漏相应法不相应法。灭智无生智缘九法。除无记无为法。自地烦恼自地使所使。一切遍使自地他地中一切遍。余各自地使所使。有二种法。相应不相应法。云何相应法。诸心心数法。云何不相应法。得等十七法。十七法者。一成就。二无想定。三灭尽定。四无想处。五命根。六种类。七处得。八物得。九入得。十生。十一老。十二住。十三无常。十四名众。十五字众。十六味众。十七凡夫性。得诸法时心不相应法俱得是谓成就。厌生死涅槃想。四禅力多少时灭心心数法是谓无想定。厌于劳辱息止想。有想无想定力多少时灭心心数法是谓灭尽定。生无想天中心心数法不行断止是谓无想处。四大诸根等相续不坏是谓命根。种种生处他众生身心语言相似是谓众生种类。到异方土所得。是谓处得。诸行杂物是谓物得。得诸内外入是谓入得。诸行起是生。行熟是老。是行未灭是住。行灭是无常。合字义是名众。合名说事是句众。合广说是语众。未得圣无漏道是凡夫性。是谓十七。心不相应法是中几善几不善几无记。二善。七无记。八当分别。无想定灭尽定是谓善。无想处种类名众句众语众命根凡夫性是谓无记。成就生老住无常。善中善不善中不善无记中无记。处得物。得入得有善不善无记。几欲界系几色界系几无色界系几不系。三欲界系。二色界系。一无色界系。十一当分别。或欲界系或色界系或无色界系有不系。名众句众语众是欲色界系。无想定无想处是色界系。灭尽定是无色界系。成就命根种类处得物得入得凡夫性是三界系。生老住无常欲界系法中欲界系。色界系法中色界系。无色界系法中无色界系。不系法中是不系。是中几有漏几无漏。十三有漏。四当分别。生老住无常有漏中有漏无漏中无漏。得初无漏心。是时舍凡夫性。生他界时亦舍凡夫性得他界凡夫性。离欲时第九解脱道中断。云何三无为。智缘尽非智缘尽虚空。云何智缘尽。有漏无漏智慧力诸结使断得解脱。是谓智缘尽。云何非智缘尽。未来因应生不生。是谓非智缘尽。云何虚空。无色处无对不可见。是谓虚空。共依因相应因共有因。先生自似因未生后诸法因。如是遍因亦次第缘。众生中报因。一切有为法。有为法果亦涅槃果。何以故。一切有为法因缘生涅槃道果。诸相应法一缘中一时共行。他相中非自相中。心心数法无处无方土。所以者何。缘一切处故。道生时诸结使欲灭。是故欲生道得解脱。不灭道时欲灭无碍道断结使。欲生解脱得解脱。三爱欲爱有爱不有爱。诸物求索是谓欲爱。得时贪惜是谓有爱。见断求断是谓不有爱。思惟所断三十七品。除直思直语直业直命猗护。余残是根法。四念止一一现在前。何以故。分别缘诸法。诸法他相应自不相应。缘诸法中结使应离。是为断有断未离。云何断未离。得苦智未得习智。习谛所断。苦谛所断。缘三谛中得二不坏信。苦谛习谛尽谛法戒不坏信。道谛中得四不坏信。一切心数法随心行。共一缘故。如是无教戒生住老坏随心行。一切有漏法应断何以故。罪垢故。一切有漏无漏法应知。何以故。智缘一切法过去未来诸法远。何以故。不办事故。现在诸法近。何以故。办事故。无为亦近。何以故。疾得故。一切有漏法见处五见缘故。极多少成就十九根情不坏。有二根亦复见谛人不坏情未离欲。是谓十九。最少八根断善根。渐命终有残身根。亦复无色界凡夫更乐三事合情缘识。是更乐五种。有对增语明无明非明非无明。五识相应是谓有对。意识相应是谓增语。染污更乐是谓无明。无漏更乐是谓明不染污。有漏更乐是谓非明非无明。两道得果。一断结使。二得解脱。阿罗汉报心般涅槃。一切法放舍故。四有生有死有本有中有。初生得五阴是谓生有。死时五阴是谓死有。除生死五阴中间是谓本有。死已能到诸趣五阴是谓中有。苦习谛智忍缘诸法是谓厌。厌物缘故。四谛中诸智忍是为离欲。欲灭故。三有漏欲有无明。欲界除无明余残烦恼。是谓欲有漏。色无色界除无明余残烦恼是有有漏。三界系痴是无明漏。是诸漏一切尽。是时得一切苦尽。得一切智甘露味。得道圣人名瞿沙造

阿毗昙甘露味论卷下


阿毗昙五法行经

    No. 1557

阿毗昙五法行经

        后汉安息三藏安世高译

苦法黠可苦法黠。习法黠可习法黠。尽法黠可尽法黠。道法黠可道法黠。苦法者。谓形体万物皆当衰老死亡。是为苦。痴人谓可常保持。是为乐黠。可知是为苦。便不复向生死。是为苦法黠。可

习法者。谓习欲习得习淫习怒习痴习好习美。黠可者如是为习。从习得尽便不欲。是为习法黠。可尽法者。谓人物会当消散灭尽。便得亦不喜。失亦不忧。是为尽法黠。可道法者。行道得道。作善上天。作恶入恶。道黠可者知去恶就善。是为道法黠。可黠者。觉可者。知

本不知是为苦。苦为一意知为苦。是为二意。习为一意知为习。是为二意。尽为一意知为尽。是为二意。道为一意知为道。是为二意。此八意在外

非常苦空非身。本习生因缘尽。止如意要道处受观

尽。苦空非身何缘得尽。尽从苦来。从苦得尽。因尽便得空。得空便知非我身。是四意为随苦谛

何等为苦。一切在生死皆为苦。会欲亦不欲会欲。谓人诸所欲得亦不欲。谓人意诸所不欲。是皆为苦。贪从习出。随非常意求灭苦从习得

何等为法。谓因缘作是得是是为法。当为识已识为却意当为断。从四谛中苦谛。习谛为证有。道见苦知从习起。见习知苦见尽谛知非常

何等为可。谓喜道不忘道。常求道以道为可。何等为黠。常问道为黠。已问能受能行是为黠。习亦如是。尽灭亦如是。道亦如是

苦为罪法为行结。黠为三十七品经。可为行行者为行道。如是为习。如是为尽。如是为道。皆为增上

第一为苦。何等为苦。一切恶不可意为苦。已识苦不欲者。便行道不离为可。苦生有本。苦为何等。本从万物。万物无有亦不尽。已不尽人亦不忧。已不忧人亦无有苦

第二为习。何等为习。意随爱为习。断爱无有习。持何等行为断爱。万物皆从因缘生。断因缘不复生。当那得断因缘。持意念道。已持意念道。意不得两念。便在道是。为习

第三为尽。苦法为万物。以败便得忧。已得忧便老。已老便得病瘦死。是名为外尽苦法。何以故。为外尽苦法。为自罪未除。何以故。为自罪未除。为生死未灭。何以故。生死未灭为非一意。何以故。非一意为不堕禅弃故。何以故。不堕禅弃不受行如佛语。是名为外尽。内尽为何等。意堕守。已堕守余意不得生。已余意不得生便灭结。已灭结便罪尽。已罪尽便尽无有。是名为内尽

第四为道。何等为道。苦可意道名为八种。何等为八种。如是安般守意说八行意。不堕生死但有堕道。已堕道便断上头三事。何等三事。苦习尽。已断苦习尽便定。已定所向便得道。何等为得道。已苦灭不复生是为得。有五法行。何等五。一者色。二者意。三者所念。四者别离意行。五者无为

色为何等。所色一切在四行。亦从四行所。四行为何等。地种水种火种风种。亦从四行因。所色为何等。眼根耳根鼻根舌根身根。色声香味细滑。亦一处不更

意为何等。所意心识。是为何等。六识身。六识为何等。眼识耳识鼻识舌识身识心识

所念法为何等。若所念法意共俱。是为何等。痛想行痒念欲。是意定黠。信进计念贪不贪善本恶本不分别本。一切结缚便劳。从起所黠所见所要亦所有。如是法意共俱。是名为意所念法

别离意行为何等。所别离意不共。是为何等。得不思想政尽政不思想念想。下辈苦得处得种得。入生老止非常名字绝具如应。亦余如是法分别意行。是名分别意行

无为何等。空灭未离灭不须受

地种为何等坚者。水种何等湿者。火种何等热者。风种何等起者。眼根何等。眼识相着可色。耳根何等。耳识相着可色。鼻根何等。鼻识相着可色。舌根何等。舌识相着可色。身根何等。身根相着可色。色为何等。若色端正不端正等色。俱中央色想。像上头一识更。眼识色更为心识更。是色两识。更知何等。两眼识心识。声为何等。从受行出声。亦不从受行出声。从受行本声。亦不从受行本受声。若上头一识更知耳识已。更心识便知是声。两识更知耳识心识。香为何等。若根香若茎香若花香若实香。香香臭香等香所香。是名为香。若上头一识。一识更知鼻识已。更心识便如是香。两识更知鼻识心识。味为何等。若酢味甜味盐味苦味碱味辛味涩味。亦所啖觉味。若上头一识知舌识。舌识已更心识便知是味。两识更知舌识心识。细滑更为何等。若滑若粗若轻若重若寒若热若饥若渴。为上头一识知身识身。识已更心识便知。是一处乐为两识更知身识心识。心识一处不更。色为何等。若色法识想着。是为何等。若身善者不善者不更。若常一识知心识

眼识为何等。眼相依色因知。耳识为何等。故耳根相依声因知。鼻为何等。鼻根相依香因知。舌识为何等。舌根相依味因知。身识为何等。身根相依乐着因知。心识为何等。心根相依法因知。痛为何等。为乐是亦为三辈少多无有量。想为何等。所对行为何等。所作是亦为三辈。善恶不分别福殃度。愿乐为何等。三会是亦为三辈。善乐恶乐亦不善亦不恶乐意念。何等为意念。是亦为三辈。善恶不分别。欲为何等。欲作是何等。意可意为何等。念思惟何等。为一意。黠为何等。为观法。信为何等。可意。进为何等。观念。计为何等。所念使求增望念愿。愿是名为计。分别念为何等。所观观随不绝相随。是名为念。计念为何等。异意大为计。意微为念。计念是为异。贪为何等。不随善法不信至诚不行不应行。是名为贪。不贪为何等。随善法信至诚行应行。是名为不贪。善本何等。有三善本。无有贪善本。无有嗔恚善本。无有愚痴善本。是名为善本。不善本为何等。不善本有三。贪为不善本。嗔恚为不善本。愚痴为不善本。是名为不善本。不分别本为何等有五不分别。爱不分别。憍慢不分别。痴不分别。疑不分别。行是名为不分别本

结为何等。有九结。一为持念结。二为憎结。三为憍慢结。四为痴结。五为邪结。六为失愿结。七为疑结。八为嫉结。九为悭结

持念结为何等。三界中贪。增结为何等。为人间不可息。憍慢结为何等。憍慢结名为七辈。何等七。一为憍慢。二为憍。三为自慢。四为自计慢。五为欺慢。六为不如慢。七为邪慢。憍慢为何等。不如者我为胜如者等。从是憍慢自计意起。意识合意。是名为憍慢。慢为何等辈中胜胜中等。从是所慢亦自计自计胜者胜。是名为自慢。亦说者憍慢慢当为一切合会。是名为自慢。自计慢为何等。为五阴自身是我身计自念。从是慢慢自知意生意起合意。是名为自计慢。欺慢为何等。未得计得未知计知未尽计尽。从是憍慢自计意观意起合意。是名欺慢。不如慢为何等远不如自计少不如。若豪若业。若业若何。若罪若病不及十倍百倍。自计如是为不如。从是憍慢自计自见意生意起合念。自为是名为不如慢。邪慢为何等。不贤者自计贤者。从是有憍慢自念自计。意生意起合念。是名为邪慢。是为七慢。慢名为憍慢结

痴结为何等。三界中所有痴。是名为痴结

邪结为何等。邪结有三辈名为邪结。一为身邪。二为边邪。三为邪邪。身邪为何等。是身是我身。是名为身邪。边邪为何等。一者断灭。二者常在。是名为边邪。邪邪为何等。邪邪为诤本坏福。是为三邪

失愿结为何等。失本不受功挍恩。是名失愿结。是两失名为失愿结。盗结为何等。两盗名盗结。一为受盗。二为戒盗。受盗为何等。为五阴念尊大最无有极。从是所欲所意。所可所用。是名为盗结。盗戒为何等。从是净从是离从是解从是要出用。是故所人所意所可所愿。是名为盗戒。是两盗名为盗结

疑结为何等。为疑四谛。是名为疑结。嫉结为何等。乱意为嫉结

悭结为何等。不能制意。是名为悭结。故一切结

缚者为何等。所结者名为缚故说缚

使者为何等。使者为七。何等为七。一为欲使。二为不可使。三为欲世间使。四为憍慢使。五为痴使。六为邪使。七为疑使

欲使为何等。欲使名为五使。何等为五者欲。从苦见断欲。着欲从习见断欲。着欲从尽见断欲。着欲从道见断欲。着欲从思惟见断欲。是名为五使。名为欲使

不可使名为何等。五使名为不可使。何等为五。从苦见不可断。从习见不可断。从尽见不可断。从道见不可断。从思惟见不可断。是五使名为不可使。世间欲可使为何等。十使名为世间可欲使。何等为十。着色见苦断欲。着色见习断欲。着色见尽断欲。着色见行道断欲。从色因着思惟断欲。从无有色因着见苦。断欲。从无有色因着见习断欲。从无有色因着见尽断欲。从无有色因着见道断欲。从无有色因着思惟断欲。是十使名为欲世间使。憍慢使为何等。憍慢使有十五。何等为十五。着欲见苦憍慢断。着欲见习憍慢断。着欲见尽憍慢断。着欲见道憍慢断。着欲思惟见憍慢断着色见苦憍慢断。着色见习憍慢断。着色见尽憍慢断。着色见道憍慢断。着色思惟憍慢断。着无有色见苦憍慢断。着无有色见习憍慢断。着无有色见尽憍慢断。着无有色见道憍慢断。着无有色思惟憍慢断。是十五使名为憍慢使

痴使为何等。十五使名为痴使。何等为十五。着欲见苦痴断。着欲见习痴断。着欲见尽痴断。着欲见道痴断。着欲思惟痴断。着色见苦痴断。着色见习痴断。着色见尽痴断。着色见道痴断。着色思惟痴断。着无有色见苦痴断。着无有色见习痴断。着无有色见尽痴断。着无有色见道痴断。着无有色思惟痴断。是十五使名为痴使

邪使为何等。三十六使为邪使。何等为三十六。十二使着欲。十二使着色。十二使着无有色。是名为三十六使。十二使着欲为何等。着欲见苦断身邪。着欲见苦断要邪。着欲见苦断邪邪。着欲见习断邪邪。着欲见尽断邪邪。着欲见道断邪邪。着欲见苦断见盗。着欲见习断见盗。着欲见尽断见盗。着欲见道断见盗。着欲见苦断戒盗。着欲见道断戒盗。是名为十二使着欲使

十二使着色为何等。着色见苦断身邪。着色见苦断要邪。着色见苦断邪邪。着色见习断邪邪。着色见尽断邪邪。着色见道断邪邪。着色见苦断见盗。着色见习断见盗。着色见尽断见盗。着色见道断见盗。着色见苦断戒盗。着色见道断戒盗。是名为十二使。着色使

十二使。着无有色为何等。着无有色见苦断身邪。着无有色见苦断要邪。着无有色见苦断邪邪。着无有色见习断邪邪。着无有色见习断邪邪。着无有色见道断邪邪。着无有色见苦断见盗。着无有色见习断见盗。着无有色见尽断见盗。着无有色见道断见盗。着无有色见苦断戒盗。着无有色见道断戒盗。是名为十二使着无有色使。是为三十六使。名为三十六邪使

疑使为何等。十二使名为疑使。何等十二。着欲见苦断疑。着欲见习断疑。着欲见尽断疑。着欲见道断疑。着色见苦断疑。着色见习断疑。着色见尽断疑。着色见道断疑。着无有色见苦断疑。着无有色见习断疑。着无有色见尽断疑。着无有色见道断疑。是名为十二疑。使是为尘是为尘脑。有时尘无有脑者。除尘所余乱意念法。是为脑非尘。从起为八。一为睡。二为瞑。三为乐。四为疑。五为猗。六为恣态。七为不愧。八为不惭。是故说从起八

所黠为何等。十黠。何等为十。一为法黠。二为比黠。三为知人心黠。四为巧黠。五为苦黠。六为习黠。七为灭黠。八为道黠。九为尽黠。十为无为黠

法黠为何等。在生死欲所无有结黠。在生死欲本所无有结黠在。生死欲灭无有结黠。在生死欲坏道行无有结黠。亦在法黠亦在法地所无有结黠。是名为法黠

比黠为何等。在色无有色行无有结黠。在色无有色本无有结黠。在色无有色行灭无有结黠。在色无有色行断为道无有结黠。亦在比黠亦在比地无有结黠。是名为比黠

知人心黠为何等。所黠行所黠福所黠合。已得不舍。常在前常念不忘。为人故为他众故恩行。是故意念知。是名为知人心黠

巧黠为何等。世间所行黠。是名巧黠。苦黠为何等。受五阴非常苦空非身念所无有结黠。是名为苦黠

习黠为何等。世间本亦本集生因缘思念无有结黠。是名为习黠

灭黠为何等。灭灭为黠。最要念不结黠。是名为灭黠

道黠为何等。道为道如应受观者。欲出念无有结黠。是名为道黠

尽黠为何等。已识苦已舍习尽已有证。道已行从是黠见知意得应。是名为尽黠

无为黠为何等。苦已更不复更。习已毕不复毕。尽已有证不复用证。道已行不复行。从是所黠所见所知所意得。是名为无为黠。故说所黠

所有见为何等。所有黠见为见。有时见非黠。为何等。八更者可。八更者可为何等。苦法黠可苦譬黠可。习法黠可习譬黠可。尽法黠可尽譬黠可。道法黠可道譬黠可。故说所见。若得是为黠。不有时得。非黠八更可如上说。故说所更

德为何等。得法为德。无有思想思惟为何等。天上一处名为一切净。在有无有欲前。有思想出所意念法灭不随。是名为不思想思惟。灭思惟为何等。二十六天上名为不欲。中得道者。上头行要出所意念法灭倒。是名为灭思惟不思想为何等。无有思想人化生天上。上头意亦堕天上时意除是中间。乃从是若意念法灭倒。是名为不思想

念根为何等。三界中命会为何等。人同居得。处为何等。同郡县。种得为何等。为五阴。入得为何等。所内外得入。是名为入得。生为何等。得阴。老为何等。阴熟。止行何等。宿命行来望。非常为何等。已生复亡。名字为何等。知分别。绝为何等。字为具。政用为何等。字会

空为何等。虚空无所有无所著无所色。是名为空。尽尚未离为何等。已尽不复更不复着。尽为何等。度世无为。是名为五法五行行说具

阿毗昙五法行经


阿毗昙心论

    No. 1550 [cf. Nos. 1551, 1552]

阿毗昙心论卷第一

        尊者法胜造

        晋太元元年僧伽提婆共惠远于庐山译

    界品第一

  前顶礼最胜　　离恼慈哀颜
  亦敬顺教众　　无著应真僧

说曰。法相应当知。何故应知法相者。常定知常定相。彼曰。定智有定智相则为决定。以是故说法相应当知。问世间亦知法相此极愚。亦知坚相地湿相水热相火动相风。无碍相空非色相识。如是一切不应已知复知。若已知复知此则无穷。无穷者。此事不然。云何说法相应当知。答世间不知法相。若世间知法相。一切世间。亦应决定。而不决定。法相者常定不可说知法相而不决定。若然者不决定亦应决定。但不尔。是以世间不知法相。复次坚相地无常相苦相非我相。若不尔者。坚相应有常相乐相有我相。而不尔。是故坚相即无常相苦相无我相。若世间于地知坚相者。无常相苦相无我相亦应知而不知。是故世间不知地坚相。问前说法相应当知此法云何。答

  若知诸法相　　正觉开慧眼
  亦为他显现　　是今我当说

问佛知何法。答

  有常我乐净　　离诸有漏行

诸有漏行转相生故离常。不自在故离我。坏败故离乐。慧所恶故离净。问若有常我乐净。离诸有漏法者。云何众生于中受有常我乐净。答

  计常而为首　　妄见有漏中

众生于有漏法。不知相已。便受有常我乐净。如人夜行有见起贼相彼亦如是。问云何是有漏法。答

  若生诸烦恼　　是圣说有漏

若于法生身见等诸烦恼。如使品说是法说有漏。问何故。答

  所谓烦恼漏　　慧者之假名

烦恼者说漏。漏诸入故。心漏连注故。留住生死故。如非人所持故。是故说有漏。问此更有名耶。答

  是名为受阴　　亦复烦恼诤
  是法说盛阴

说劳说诤。问何故。答

  烦受诤起故　　是彼应当知

身见等诸烦恼。劳于众生故说烦恼。恼受身故说受。忿怒心故说诤。从身见等生诸有漏法。是生劳故说劳。生受故说受。生诤故说诤。已说盛阴。阴相今当说

  若远离烦恼　　无漏诸有为
  一切杂受阴　　是阴圣所说

谓法离身见等诸烦恼。亦解脱诸漏有为从因生故。是一切及前说盛阴。此总说阴。是五阴色痛(应云觉也)想行识。问色阴云何。答

  十种谓色入　　亦无教假色
  是分别色阴　　牟尼之所说

十种。谓色入者。眼色耳声鼻香舌味身细滑。亦无教假色者。如业品说。此色是色阴。分别色阴时。是世尊说

  所名曰识阴　　此即是意入
  于十八界中　　亦复说七种

谓识阴即是意入。亦界中七种分别。眼识耳鼻舌身意识及意

  余则有三阴　　无教三无为
  谓是说法入　　亦复是法界

余则有三阴者。痛阴想阴行阴。无教三无为者。虚空。数缘灭。亦非数缘灭。此总说法入亦复是法界。如是此法说阴界入。但阴一向有为界。及入有为无为。已说阴界入。一一相今当说

  界中一可见　　十则说有对
  无记谓八种　　余则善不善

界中一可见者。色界此可视在此在彼是故可见。当知十七不可见。十则说有对者。十界有对眼色耳声鼻香舌味身细滑。是各各相对各各相障碍。处所若有一则无二是故有对。当知八无对。无记谓八种者。眼耳鼻香舌味身细滑。此非乐报可记。亦非苦报可记故曰无记。余则善不善者。色声意法及六识。善身动是善色。不善身动是不善色。余色无记。如是声口动净心七识界。善不善烦恼相应是不善余无记。法界识心相应彼如心说。若不相应如杂品说

  有漏有十五　　余二三三有
  欲有中有四　　十一在二有

有漏有十五者。五内界五外界五识界漏止住故。余二者。意界意识界法界。此或有漏或无漏。若漏止住是有漏。异则无漏。三三有者。意法识界是三有中可得。欲有色有无色有。欲有中有四者。香味鼻识舌识是一向欲有。中摄非色无色有。离欲揣食故一切香味是性揣食。十一在二有者。欲有色有十一界内五色声细滑及是境界识。此非无色中以离色故

  有觉有观五　　三行三余无
  有缘当知七　　法入少所入

有觉有观五者。五识界与觉观俱粗故觉观相应。三行三者。意法识界此三行。若欲界及初禅是有觉有观。若中间禅是无觉少观。是上无觉无观。余无者。谓余界非觉。俱亦非观。俱不相应故。有缘当知七者。七界有缘有此缘故故曰有缘。如人有子谓之有子彼亦如是。眼识缘色耳识缘声鼻识缘香舌识缘味身识缘细滑意识缘诸法。法入少所入者。若心心数法。是有缘余则无缘

  九不受余二　　为无为共一
  一向是有为　　当知十七界

九不受者。受名谓若色根数。亦不离根是心心数法。所行于中止住故。异则不受。于中九界不受。声心法界非于中心心数法止住。余二者。五内界若现在是受。于中心心数法止住。过去未来不受。非彼心心数法止住。色香味细滑若不离根及现在是受。如心心数法根中止住。彼中亦尔。不离根故余则不受。为无为共一者。一法界有为及无为。于中三种有常故不可有为。余法界无常故有为。有为无为合施设故。是以为无为共一。一向是有为当知十七界者。十七界无常故一切有为。是故一向有为。问如是分别法相已。云何摄法为自性为他性。答自性。问何故。答

  诸法离他性　　各自住己性
  故说一切法　　自性定所摄

诸法离他性者。谓眼离耳。如是一切法不应说若离者。是摄以故非他性所摄。各自住己性者。眼自住眼性。如是一切法应当说。若住者是摄。故说一切法自性之所摄。已施设自性所摄。于中可见法一界一阴一入所摄。如是一切法。复次此义契经品当广说

    行品第二

已说诸法自相。如法生今当说。问若诸法自性所摄者。亦当以自力故生。答

  至竟无能生　　用离等侣故

一切法不能自生。所以者何。诸行性劣无势力故。如羸病人不能自力起。问若不自力起。当云何起。答

  一切众缘力　　诸法乃得生

如羸病人由他扶起。彼亦如是。如心由伴生。今当说

  若心有所起　　是心必有俱
  心数法等聚　　及不相应行

心者意。意者识。实同而异名。此心若依若缘若时起。彼心共俱心数法等聚生。问何者心数法等聚。答

  想欲更乐慧　　念思及解脱
  作意于境界　　三摩提与痛

想者事立时随其像貌受。欲者受缘时欲受。更乐者。心依缘和合不相离。慧者于缘决定审谛。念者于缘忆不忘。思者功德恶俱相违于心造作。解脱者于缘中受想时彼必有是。作意者于缘中勇猛发动。定者受缘时心不散。痛者乐不乐俱相违缘受

  一切心生时　　是生圣所说
  同共一缘行　　亦复常相应

一切心生时是生圣所说者。此十法一切心生时共生。是故说名大地。同共一缘行者。一切心共俱同一缘行不相离。亦复常相应者。各各共俱及与心俱常相应共行。离增减故故曰相应。已说心数法谓通一切心中。不通今当说

  诸根及觉观　　信猗不放逸
  进护众烦恼　　或时不相应

诸根者。善根无贪无恚无愚痴。觉者于心粗相续。观者于心细相续。信者成实真净。猗者善心时于身心离恶故快乐。不放逸者。信善时方便不舍。进者作事专著。护者作事。行以不行求以不求。自守无为。众烦恼者。如使品说此法非一切心中可得。或时相应或时不相应。问何故说心数。答意谓之心。彼眷属故说心数。已说诸心数法相。如所生今当说

  不善心品中　　心数二十一
  秽污二损减　　欲界非不善

不善心品中。心数二十一者。不善名若心生欲界诸烦恼除欲界身见边见。是转成不爱果故谓不善。此心品中当知有二十一心数法。十大地觉观。二烦恼无惭无愧。睡调不信放逸懈怠秽污二损减。欲界非不善者。谓心品是欲界秽污非是不善。如身见边见相应心。此品中当知有十九心数法。除无惭无愧一向不善故

  善不共二十　　无记有十二
  悔及于眠心　　是能以为增

善不共二十者。不共名谓心独一无明烦恼。生是二十心数。除一烦恼余如前说。善名谓净心能转成爱果。此心共俱当知有二十。十大地觉观信进。猗不放逸善根护惭愧。无记有十二者。不秽污心品中有十二心数法。十大地觉观。悔及于眠心是能以为增者悔名事不成恨为悔是善不善。彼相应心品中增悔余心数法如前说。眠名灭心一向合不自在为眠。是一切五品中生彼尽增益。余心数法如前说。若悔眠不行三品中是增二。余心数法如前说。问此欲界心相续说色界云何。答

  初禅离不善　　余知如欲有
  禅中间除觉　　于上观亦然

初禅离不善余知如欲有者。初禅无不善彼中有四品。善秽污不共无记是如欲界说。善中二十无记十二秽污十九。已离不善当知亦离无惭无愧。一向不善故不共有十八。禅中间除觉者。中间禅无觉彼一向除觉余如初禅说。于上观亦然者。第二第三第四禅亦复无观。及无色界于中一切除观觉前已除。已说心数法由伴生色今当说

  极微在四根　　十种应当知
  身根有九种　　余八种谓香

极微在四根十种应当知者。谓极微在眼中是知有十种。地种水火风种。色种香味细滑种。眼根种身根种。耳鼻舌极微亦如是。身根有九种者。谓余身根极微九种彼有一根种余如上说。余八种者。于中余非根色中极微有八种。问此极微何界说。答谓香欲界中有香。色界中离香彼一切除香味种。余种如欲界说问前已说若心生彼中必心数法生。及心不相应行。于中已说心数法。心不相应行云何。答

  一切有为法　　生住变异坏

一切有为法各各有四相生住异坏。世中起故生。已起自事立故住。已住势衰故异。已异灭故坏。此相说心不相应行。问若一切有为法各有四相者是为相。复有相。答是亦有四相。彼相中余四相俱生。生为生住为住异为异坏为坏。问若尔者便无穷。答

  展转更相为

此相各各相为。如生生各各相生。如是住住各各相生。异异各各相异。坏坏各各相坏。是以非无穷。后四相各行一法。前四相各行八法。生者生八法。前三后四及彼法余亦如是。已说诸行伴。如由伴生今当说

  所作共自然　　普遍相应报
  从是六种因　　转生有为法

一切因尽在六因中。此因生一切有为行。于中所作因者。生法时不障碍不留住。由此故生不相似法。如由地万物得生。共因者。诸行各各相伴由此故生。如心心数法心不相应行及极微种。自然因者谓彼自已相似如习善生善。习不善生不善。习无记生无记。如物种随类相因。一切遍因者。谓诸烦恼转相续生。如见我审入计着。由此见故于我有常无常审入计着。谤阴相审入计着。于阴相犹豫受有常乐净等生。诸烦恼如是。说诸一切遍如。使品说相应因者。心及心数法。各各力于一缘中。一时行相离则不生。报因者。谓行生于生中转成果。如善爱果不善不爱果由此故生。已说诸因。诸法随因中生今当说

  若心因报生　　心数及烦恼
  是从于五因　　兴起应当知

若心心数法因报生及诸烦恼。是从五因生。报因生者。从所作因生。彼生时相似不相似物不障碍故住。从共因生伴力故生。彼各各相伴。及心不相应行共伴从自然因生。彼有相似前生无记法从相应因生。俱一时一缘中行从报因生彼善不善。谓此果秽污心心数法除报因无记故。是从一切遍因生由此故生。余四因如前说

  是彼不相应　　诸余相应法
  除其初无漏　　是从四因生

是彼不相应者。若色从报生。及心不相应行是从四因生。所作因共因报因自然因。秽污色及心不相应行亦从四因生。所作因共因自然因一切遍因。诸余相应法除其初无漏。是从四因生者。余心心数法除其初无漏。亦从四因生。所作因共因自然因相应因

  谓余不相应　　因生当知三
  及诸余相应　　初生无漏法

谓不相应法前所说于中。余若有自然因除初无漏。是从三因生。所作因自然因共因。初无漏相应亦从三因生。所作因共因相应因。是前无自然

  于中不相应　　应从二因生
  若从一因中　　生者必无有

于中不相应应从二因生者。初无漏品中。色心不相应行从二因生。所作因共因。已说一切有为。于中若从一因生者必无有。已说诸因。如此因如来定知诸法相。觉力教化故说。缘今当说

  次第亦缘缘　　增上及与因
  法从四缘生　　明智之所说

次第缘者。一一心生相续无间。缘缘者。心心数法境界。缘彼故心心数法生。增上缘者。是所作因一切万物。万物生时不作挂碍。但自所作为要。是说增上缘。因缘者。共因相应因自然因报因一切遍因。已说诸缘。诸法随缘生今当说

  心及诸心数　　是从四缘生
  二正受从三　　谓余说于二

心及诸心数是从四缘生者。心心数法从四缘生。前开导故生是彼次第缘。境界是彼缘缘除其自已。余一切诸法。是彼增上缘。二正受从三者。无想定灭尽定是从三缘生。于中入定心是彼次第缘。于中自地前生功德是彼因缘。及余俱生生住异坏。亦彼因缘彼增上缘如前说。谓余说于二者。离彼余心不相应行。及色从二缘生。因缘及增上缘。问以何故此诸法谓之行。答

  多法生一法　　一亦能生多
  缘行所作行　　如是应当知

多法生一法一亦能生多者。无有一法能自力生。但一法由多法生。多法亦由一法生。以是故谓缘行所作行如是应当知

    业品第三

已说诸行己性及由诸因缘生。今谓此有因能严饰果种。生种生差别可得。今当说

  业能庄严世　　趣趣在处处
  以是当思业　　求离世解脱

业能庄饰世趣趣在处处者。三世于五趣中。种种身差别严饰。是世严饰事唯业。是以当思业求离世解脱

  身业及口意　　有有之所造
  从是生诸行　　严饰种种身

身业及口意有有之所造者。谓身口意业生生所造作。从是生诸行严饰种种身。此业相今当略说

  身业教无教　　当知二俱有
  口业亦如是　　意业唯无教

身业教无教当知二俱有者。身业性二种有教性无教性。于中有教者。身动是善不善无记。善从善心生。不善从不善心生。无记从无记心生。无教者。若作业牢固。转异心中此种子生。如善受戒人不善。无记心中。彼犹相随恶业人恶戒相随。口业亦如是者。口业性亦二种。意业唯无教者。意业性一向无教。所以者何。不现故思微相续故。问此五业几善。几不善。几无记。答

  教当知三种　　善不善无记
  意无教亦然　　余不说无记

教当知三种善不善无记者。身口教说三种善不善无记。于中善身教者。行施持戒等善心作身动。不善身教者。杀生不与取非梵行等。不善心作身动。无记身教者。无记心作身动。如威仪工巧伎术。如是口动善者。如不虚言饶益相应。应时言等从善心生。口业不善者。如妄言两舌恶口绮语等。从不善心生。口业无记者。从无记心生。口业意无教亦然者。意业无教亦三种善不善无记。善心相应思是善。不善心相应思是不善。无记心相应思是无记。余不说无记者。余有二身无教及口无教。彼二种善不善。无无记。所以者何。无记心羸劣。彼不能生强力业。谓转异心中彼相似相随。是故身无教口无教无无记。问无记业何业性。何处系。答

  色有无记二　　隐没不隐没
  隐没系在色　　余在于二界

色有无记二隐没不隐没者。身口业是色性以业色性故。二种隐没及不隐没。隐没者。谓烦恼所覆亦从诸烦恼生。异者是不隐没。隐没系在色者。若隐没一向系色界。所以者何。思惟断烦恼能起身口业。此欲界思惟断烦恼一向不善。不以不善烦恼能起无记业。余在于二界者。不隐没无记业。亦系在欲界。亦系在色界。意业如心说是余处分别。故今不说

  身口业无教　　当知善不善
  三相禅无漏　　调御威仪戒

身口业无教当知善不善者。业若色性于中若无教性是善不善。三相禅无漏调御威仪戒者。无教戒有三相。无漏禅生调御威仪。无漏者。谓戒道共俱行。正语正业正命。禅生者。谓禅俱行离恶。调御威仪戒者。谓欲界戒

  无教在欲界　　教依于二有
  当知非心俱　　谓余心俱说

谓欲界无教是非心共俱。所以者何。谓受戒戒虽善心不善心无记心随行。而不与善不善无记共。俱教者亦在欲界亦在色界。但非心共俱。所以者何。由身故色界无教。及无漏与心共俱。所以者何。由心故此非余心中随行。已分别诸业。若成就业今当说

  无漏戒律仪　　见谛所成就
  禅生若得禅　　持戒生欲界

无漏戒律仪见谛所成就者。见谛谓无漏见见圣谛。初生无漏见时见于欲界苦谛。是故一切圣人成就无漏戒。禅生若得禅者。谓得禅是成就禅戒。持戒生欲界者。若受戒者故成就欲界戒。已略说成就。如过去未来。现在可得。今当说

  谓住威仪戒　　无教在于今
  当知恒成就　　或复尽过去

谓住威仪戒无教在于今当知恒成就者。若住威仪一切时成就无教戒。彼终不离至命尽所缚。或复尽过去者。或成就过去无教戒。若尽不失。谓初已尽是成就过去。过去者假名为尽

  若有作于教　　即时立中世
  当知成过去　　已尽而不舍

若有作于教即时立中世。若作身口教。尔时即成就现在教。现在者假名中世。当知成过去已尽而不舍者。若彼教已尽不失。尔时即成就过去

  谓得禅无教　　成就灭未至
  中若入正受　　教亦如前说

谓得禅无教成就灭未至者。若得禅彼成就过去未来。所以者何。如彼禅成就戒亦复尔。中若入正受者。现在假名中。彼若入定空尔时成就现在无教。所以者何。与定俱故。教亦如前说者。如住威仪戒。若作教尔时成就现在教。若不作教尔时不成就教。若尽不失尔时成就过去。若不尽设尽便失。尔时不成就。住禅戒亦复如是

  悉成就当知　　得道若未生
  中间在道心　　尽不舍前世

悉成就当知得道若未生者。一切得道成就未来无漏无教。所以者何。如彼无漏心成就戒亦复尔。中间在道心者。已合道若入于定。尔时即成就现在。尽不舍前世者前世是过去彼于此无教。若尽不失如得圣果。及退者成就过去无教

  若作恶不善　　立戒成就二
  至彼缠所缠　　尽已尽当知

若作恶不善立戒成就二者。如此住威仪戒。或住禅戒或住无漏戒。或作不善浊重缠。尔时于不善中起无教。即成就教及无教。若非浊重缠不起无教。问几时成就。答至彼缠所缠。若缠所缠随可得成就。尽已尽当知者。彼缠若尽教及无教亦随尽

  处不威仪戒　　无教成就中
  恶而不爱果　　亦复过去尽

处不威仪戒无教成就中恶而不爱果者。若住不威仪戒。尔时成就不善无教。不善名不爱果。亦复过去尽者。灭非不灭

  有教现于时　　是说成就中
  亦复尽过去　　善于上相违

有教现于时是说成就中亦复尽过去者。教谓如前说。善于上相违者。如住威仪戒说。不善如是住不威仪。说善至彼善心

  若处中所作　　即成就中世
  亦复过去尽　　或二亦复一

处中者。不威仪亦非不威仪住是居中容。彼如善住说善。或复二有教及无教。或一向教。或善不善。或一。问云何得色界戒云何舍。为根本禅得。为余方便。答非一向根本禅

  色界中善心　　得定威仪戒
  是失彼亦失　　无漏有六心

色界中善心得定威仪戒者。若得色界善心或离欲或不离欲。彼一切得色界戒。所以者何。一切色界善心中戒常共俱。问云何失。答是失彼亦失。问无漏云何。答无漏有六心无漏戒。无漏六地心共得。问云何失。答是失彼亦失。六地者。未来禅中间禅根本四禅。问此戒几时舍。答

  调御威仪戒　　是舍于五时
  禅生及无漏　　二时觉所说

调御威仪戒是舍于五时者。威仪戒五时舍。罢道犯戒死时。邪见增法没尽。禅生及无漏二时觉所说者。禅戒二时舍退及上生。无漏戒亦二时舍退及得果。问余业云何舍。答

  不善戒有二　　善无色亦然
  秽污说一时　　若业住于意

不善戒有二者。不作方便及死时善无色亦然者。善无色业亦二时舍。善根断时及上生。秽污说一时若业在于意者。秽污意业一时舍离欲时。已说诸业性及成就。如此业世尊种种分别。今当说

  若业与苦果　　当知是恶行
  意恶行增上　　贪嗔恚邪见

若业与苦果当知是恶行者。谓业是不善尽说是恶行。不善者苦果。意恶行增上贪嗔恚邪见者。不善思愿是意恶行。复三种说意恶行。贪嗔恚邪见

  此相违妙行　　最胜之所说
  若于中最上　　是名为十道

此相违妙行最胜之所说者。此相违一切善业及无贪无恚正见。若于中最上是名为十道者。若于不善业中。若业最上者是说业道。如杀生不与取邪行妄言两舌恶口绮语贪恚邪见。于中杀生者。众生想舍众生意断他命求方便成业。不与取者。物他所有他想不与辄取。邪行者。妇女他所有犯于道。若自所有时时犯非道。妄言者。异想意欺诳他说。两舌者。憎他故亲相离方便说。恶口者。以嗔于他不爱言。绮语者。不善心无义言。贪者欲界欲恚者忿怒。邪见者谤因果此是业道。余者非业道。谓此行方便求及饮酒等。不正业思愿者是根本业。此以彼十为道

  若业现法报　　次受于生报
  后报亦复然　　余则说不定

谓业能成现法果时则不定。问如世尊说。三业乐报苦报不苦不乐报。此云何。答

  若欲界中善　　及色界三地
  是应有乐报　　受者定不定

若欲界中善及色界三地是应有乐报者。欲界善业生报与乐俱。及色界初禅第二第三。亦生报与乐俱。此总说乐报。问此亦是定耶。答受者定不定。若定若不定是四地中。善一切有乐报

  生不苦不乐　　谓在于上善
  若受于苦报　　是说不善业

生不苦不乐谓在于上善者。第四禅地善业及无色中是不苦不乐报。是生报与不苦不乐俱。于中无乐痛。若受于苦报是说不善业者。不善业是苦报。必与苦痛俱。受报此亦定不定如上。问世尊说四业。黑黑报。白白报。黑白黑白报。不黑不白无报。此云何。答

  色中有善业　　是白有白报
  黑白在欲界　　黑报说不净

色中有善业是白有白报者。色界善业是白报一向不净故。及离不善故彼一向极妙报。是谓白有白报。黑白在欲中者。欲界善业黑白黑白报。所以者何。是不善所坏羸劣故故说黑白。彼杂受报爱不爱故说黑白报。黑报说不净者。不善谓不净是黑增恶故。鄙贱故是说黑报

  若思能舍离　　是尽无有余
  彼在无碍道　　谓是第四业

谓道能灭此三业是无碍道。若有思此思是第四业。于中四思思惟道灭。第二业十三有二道。见谛道四。思惟道九。是无漏思不增恶故不黑。不五乐故不白。与无穷相违故无报。问世尊说身口意曲秽浊。此云何。答

  曲生于谄伪　　秽从嗔恚生
  欲生谓为浊　　世尊之所说

曲生于谄伪者。若业从伪生。是曲欺诳故。秽从嗔恚生者。若业从恚生。是秽一向诤故。欲生谓为浊世尊之所说者。若业从欲生。是浊一向尘垢故。问如世尊说三净身口意。此云何。答

  净一切妙行　　满者是身口
  谓无学意满　　即是无学心

净一切妙行者。若有妙行是一切净。离烦恼不净故。问满云何。答满者是身口。无学意中身口妙行。是谓满善除一切挂碍故。谓无学意满即是无学心者。若无学意满是无学心。所以者何。无学心者。已逮得文尼相故。已说诸业假名果。今当说

  善恶不善业　　是俱有二果
  善或成三果　　一果谓余说

善恶不善业是俱有二果者。善业成二果所依果及报果。无漏业亦有二果。所依果及解脱果。不善业亦有二果。所依果及报果。善或成三果者。谓善有漏业能除诸烦恼是三果。所依果报果及解脱果。一果谓余说者。谓余无记业是一果所依果。无余。问造色相是身口业。是业何四大造。答

  自地若有大　　依于身口业
  无漏随力得　　是彼谓之果

自地若有大依于身口业者。若欲界诸业是依于欲界大此所造故。色界业亦如是。问无漏诸业云何。答无漏随力得是彼谓之果者。无漏色若依四大得即依彼地。若住欲界得道。彼身口业欲界四大造。如是一切地谓力除色界欲及无色界。彼若命终生无色中。若未得而得身口业。是身口业即彼地四大造。问如世尊说三障。业障烦恼障报障。是相云何。答

  无间无救业　　广能生烦恼
  恶道受恶业　　障碍亦应知

此三法障碍者。必不受圣法是故说障碍。问此业何等最大恶。答

  若业坏僧者　　是说为极恶

谓业坏僧是业最恶。是阿鼻大地狱住劫。问何者最大妙。答

  第一有中思　　当知彼最大

非想非非想处于有第一。彼地摄思是大妙极。大果彼八万劫寿报

阿毗昙心论卷第一阿毗昙心论卷第二

        尊者法胜造

        晋太元元年僧伽提婆共惠远于庐山译

    使品第四

已说诸业。诸烦恼今当说

  一切有根本　　业侣生百苦
  九十八使者　　文尼当说思

譬怨不识则害成。若识则得离。诸烦恼亦然。当知如怨家。问云何知。答

  一切诸使品　　当知立二种
  见谛所断种　　亦思惟所断

若有使者。尽见断及思惟断。谓从见道是见断。从思惟道是思惟断。于中

  说二十八使　　是系在见苦
  谓当见苦时　　断灭尽无余
  见习断当知　　十九灭亦然
  增三见道断　　十说思惟止

是谓九十八使已说。种界今当说

  第一烦恼种　　在欲当知十
  二种种有七　　余八见道断
  在欲界当知　　四是思惟断
  谓余在二界　　是亦当分别

在欲界当知四是思惟断者。此三十六使是欲界系。谓余在二界是亦当分别者。余六十二使。于中三十一色界系。三十一无色界系。已说界诸使。今当说

  受边见邪见　　及与五我见
  二盗应当知　　是烦恼说见

从因相续不识诸法性。于中或有常相。或有断相。断常是二边世尊之所说。于中若见受边是谓受边见。诽谤真实义此见是邪见。若有情识类愚于中计我是谓身见。有漏法受第一此见是见盗。非因见因此见是戒盗。此五烦恼是慧性故说见

  欲犹豫嗔恚　　慢痴说非见
  是界差别故　　转行种种名

欲犹豫嗔恚慢痴说非见者。欲名受念想思。于诸行中乐着犹豫名如前所见。于中或思惟嗔恚名所作相违忿怒。慢名自举。痴名所有不识。此五烦恼说非见。是谓一切诸烦恼。是界差别故转行种种名者。是十烦恼或从苦行。或从习或从灭或从道。于中若从苦行者。是见苦断如是至道。余思惟断

  下苦于一切　　离三见行二
  道除于二见　　上界不行恚

下苦于一切者。下苦是欲界苦。于中行一切十烦恼。凡愚于欲界苦不了因见断。不了果见常谤果谤苦邪见。苦受第一见盗。谓法于法非因计因戒盗。自见欲他见恚从见中或从自见举慢。不了无明。离三见行二者。习及灭各七行。身见行于现五阴。习者细微不现。是故于中不行。灭亦如是。受边见者亦行于现。戒盗行于界彼亦非习灭。道除于二见者。身见边见不行于道有漏境界。故戒盗者行于道。似道故终竟不解至不见正道。上界不行恚者。如欲界分别。色无色界亦尔。除其恚彼中无恚意止柔软故。诸见及疑非思惟所断。余欲界四思惟所断。色界三无色界二。问云何彼缘境界。答

  普遍在苦因　　疑见及无明
  是一切种使　　乐在一地中

见苦断种及见习断。疑见及无明此烦恼是普遍。一切五种行于自地。所以者何。一切有漏法是苦习性。问何故行于自地非他地。答非境界故不行于上。离欲故不行于下。是谓欲界十一一切遍烦恼。色无色界亦尔。余不一切遍自种境界故

  初烦恼五种　　四说为第二
  境界于上界　　未离慧所说

欲界见苦断邪见。谤色无色界苦见盗。受第一戒盗受解脱方便疑惑无明不了。见习断邪见谤色无色界因见盗。于因受第一疑惑无明不了。如是色无色界一切地。乃至无所有处

  邪疑是俱生　　及不共无明
  息止道二断　　当知无漏缘

见灭断邪见谤于灭。是缘灭故无漏缘。如是疑惑于灭。及彼相应无明无漏缘。如是见灭断不共无明。谓不欲于涅槃。彼亦无漏缘。见道断亦复如是。是十八使无漏缘。问云何有漏种诸使所缚。答

  若种在欲界　　一切诸遍使
  缘缚于己地　　在上界亦然

诸一切遍使。是于自地中缘使一切种

  其余诸结使　　当知自种缘
  所使于自界　　及是相应品

其余诸结使当知自种缘所使于自界者。一切不遍使自于种中。缘诸法即彼所使。及是相应品者。一切遍及不一切遍是一切自品中相应所使

  若无漏所行　　及他地缘恼
  是相应所使　　境界解脱故

若无漏所行及他地缘恼是相应所使者。若使无漏缘及上地缘。是自品相应所使非缘使。所以者何。境界解脱故。此使不缘于境界。无漏诸法解脱一切烦恼。上地诸法解脱下地烦恼。问此使当言不善为无记。答

  己身见边见　　此相应无明
  是欲中无记　　色无色一切

己身见边见此相应无明是欲中无记者。欲界身见边见及相应无明是无记。所以者何。己身见数数行。若当不善者欲界众生。应无有乐多作不善故。复次若不善者相违于福。此中计我人行福令我得乐。不善者相违于善。是以身见非不善。断见是无常见厌于生死是亦非不善。是故非不善有常见亦不违善。如身见是故非不善。余欲界烦恼一向不善。色无色一切者。色界无色界诸使尽无记。所以者何。正受所坏故。不善者受苦痛报彼中无苦痛。问一切诸烦恼尽缚自所有境界为不。答

  贪欲嗔恚慢　　知或过去缚
  未来受一切　　余二世尽受

贪欲嗔恚慢知或过去缚者。谓过去爱恚慢。是不必于前一切自境界起爱者。不能于前一切法中起。非以不见生故。未来受一切者。谓未来爱恚慢缚一切有漏法。所以者何。缘一切有漏故。余二世尽受者。见疑及无明总缘一切法。是故缚过去未来诸有漏法。现在使不定故不说。若有者受自相彼应说如过去。已说诸使境界。次第今当说

  次第是转生　　自地于自地
  上地亦生下　　此事当分别

次第是转生自地于自地者。一切诸烦恼于自地烦恼次第缘。可得一一次第生一切。上地亦生下此事当分别者。梵天上命终次第生欲界一切。若彼中秽污心命终。此中一向秽污心相续。如是一切地

已说诸使自相。如此烦恼世尊教化故多种说今当分别。问世尊说七使。欲爱恚有爱慢见疑及无明。此云何。答

  欲界五种欲　　此说欲爱使
  色无色如上　　有爱当分别

欲界五种欲此说欲爱使者。见苦习灭道思惟断。色无色如上有爱当分别者。色界爱五种无色界亦尔

  恚即是恚使　　五种如前说
  憍慢及无明　　十五在三界

恚即是恚使五种如前说者。嗔恚亦如是五种。憍慢及无明十五在三界者。慢欲界五种。色界五种。无色界五种。无明亦尔

  见使三十六　　说普在三界
  疑使有十二　　此七有异名

见使三十六说普在三界者。欲界十二见五见苦断。二见习断二见灭断。三见道断。色无色界亦尔。疑使有十二者。欲界有四见苦习灭道断。色无色界亦尔此七有异名者。此烦恼说扼受流漏。问何以等故答

  扼缚及受流　　漏一切无穷
  诸扼及受流　　烦恼是说漏

系一切众生故说扼。受生具故说受。流下一切众生故说流。漏一切无穷故说漏。已说种种相。相应根今当说

  诸使在三界　　尽护根相应
  随地诸根使　　相应于色身

诸使在三界尽护根相应者。一切九十八使尽护根相应。诸烦恼后时依于无求而止。随地诸根使相应于色有者。梵天及光曜有喜根。彼地诸使喜根相应及护根。遍净有乐根彼地诸使。乐根相应及护根

  邪见及无明　　欲界中乐苦
  嗔恚疑唯苦　　谓余一向乐

邪见及无明欲界中乐苦者。欲界邪见无明乐根相应及苦邪见者作恶业为喜净业为忧。彼相应无明亦尔。嗔恚疑唯苦者。疑忧戚为本不决定故。不喜嗔恚亦尔谓余一向乐者。欲界余使一向乐相应非苦。彼欢喜为本

  二勋坚着身　　见断唯应意
  欲界诸烦恼　　此根是相应

二勋坚着。名诸烦恼思惟断。彼身痛相应心痛。于中身痛者乐根及苦根。心痛者喜根及忧根俱有。护根一切身痛思惟断意俱有。见断唯应意者。见谛断结唯意相应。欲界诸烦恼此根是相应者。是谓欲界诸烦恼。已分别相应根。上烦恼今当说

  无惭亦无愧　　睡悔及与悭
  嫉掉眠烦盛　　故设上烦恼

此八事说上烦恼诸使是烦恼。于中此上从中起此。是使垢依于使。问何者使垢。答

  一切烦恼俱　　说睡及与掉
  无惭不善俱　　无愧亦复然

一切烦恼俱说睡及与掉者。掉名于心不止息。是一切烦恼相应。烦恼是不止息眠虽名沈意。彼亦一切烦恼相应。以沉心使生烦恼。无惭不善俱无愧亦复然者。无惭名行恶时不惭他。无愧名自恶不厌不着。此二上烦恼。一向不善相应非无记

  谓苦在于意　　悔思惟所断
  眠唯在欲意　　余各自建立

谓苦在于意悔思惟所断者。悔名作善作恶事不成而悔。不可说是喜故一向苦相应。是意忧根相应从恶行生故。说思惟断苦相应故当知是欲界。眠唯在欲意者。眠意闭故眠是一向欲界在意地。彼于欲界一切烦恼相应。一切诸烦恼行于眠时。余各自建立者。谓余二上烦恼嫉及悭。嫉名见他乐生热。悭名守护惜着。彼俱自建立非余烦恼相应。问诸烦恼几识相应。答

  欲嗔恚无明　　当知依六识
  谓欲思惟断　　色中随所得

欲嗔恚无明当知依六识。谓欲思惟断者。欲界思惟所断。爱恚无明六识相应。色中随所得者。爱无明色界随所可得。梵天上四识彼中。此二烦恼四识相应。余烦恼在意识中。已说诸烦恼。如所断今当说

  一时断烦恼　　而于中解脱
  无量时所得　　正智之所说

一时断烦恼而于中解脱者。此烦恼无碍道一时断。非已断复断。无量时所得正智之所说者。此得尽数数如欲界见断。五时得尽证自分。及四沙门果如是。一切如贤圣品说

  欲界中解脱　　圣说四断智
  离色无色界　　当知五断智

永尽无余谓之断智。于中若欲界见苦习所断。若尽得无余解脱是一断智。见灭断二。见道断三。思惟断四。色无色界见苦习断一断智。见灭断二。见道断三。色界思惟断四。无色界思惟断五。问以何等故于断分断智。答智果故说断智。如瞿昙性中生亦名瞿昙。此亦复尔。问此诸使为心相应。为不相应。答相应。所以者何

  心为使烦恼　　障碍清净违
  诸妙善可得　　当知相应使

心为使烦恼者。若使心不相应不以烦心。若烦心者是故相应。障碍名若使心不相应。不障碍诸善法。若障碍者善法不生。不障碍使生是故相应。净相违诸妙善可得者。若使不相应不与善相违。若不与善相违者善心亦应生。若不相应是烦恼性亦不应作患。若相违常相随不生善。不相随则生善。因此事故是相应使

    贤圣品第五

已说使品。贤圣品今当说

  如此圣断劳　　众恐怖之本
  等方便正智　　今当说善听

不亭心者无能起正见是以

  始自身处所　　系缚心令定
  亦欲缚识足　　及尽烦恼怨
  是方便于身　　真实相常定
  诸痛及此心　　法亦如是观

此身不净相无常相苦相无我相。是相定真实彼自身一处系心离心乱。始真实观身相。次观痛后观心。彼伴彼依及彼相应余心数法。观亦诸心不相应行。如其性如其相所有如是。彼身痛心法意正次第生

  入法中总观　　同观诸法相
  此四是无常　　空无我非乐

入法中总观同观诸法相者。入法意止中彼圣总观诸行相。观诸行相已增长养止。生无垢智眼。一切身痛心法总观。问云何。答

  此四是无常　　空无我非乐

此身痛心法展转相生。故无常不自在。故空非主故无我。恶灾患故苦

  从是名暖法　　即是意中生
  行是十六行　　正观四真谛

从是名暖法即是意中生者。彼如是观生善暖。于中当生无漏智火能烧一切行薪。问彼何行何境界。答行是十六行正观四真谛。彼行是十六行境界。四真谛四行观苦谛。此苦性劣从因缘生故无常。无常力所坏故苦。内离人故空。不自在故无我。四行观习此习成相似果故因。行相续习。一切生死无穷可得故有。不相似事相续故缘。四行观灭此灭覆一切患尽故灭。除一切烦恼火故止。胜一切法故妙。舍生死故离。四行观道此道至非品故道。非颠倒故如。一切圣所履故迹。生死患转出故乘。是谓彼行十六行境界。四真谛善根谓之暖法

  彼起已成立　　生顶及于忍
  得世第一法　　依倚于一相

彼起已成立生顶及于忍者。若已成暖法于中复于欲界生善根如顶。亦十六行观四真谛。胜暖法故说顶。已增上顶生善根名为忍。亦十六行观四真谛堪任故说忍。若忍已成立。得世第一法依倚于一相。一切世俗功德中。最胜生善根名世间第一法。开涅槃门故。于凡夫意中最胜故。说第一法。问以何等故说依倚于一相。答于凡夫意中。更无有比二功德。若有者彼亦应开涅槃门而不开。是故说依倚于一相。问彼几行何缘何地所摄。答

  彼行苦四行　　说摄依六地

彼行苦者。彼即缘苦谛非余四行者。谓行苦谛境界无常为首。所以者何。如初无漏心缘彼亦复尔。说摄依六地者。彼法摄于六地。未来禅中间禅根本四禅。非欲界不定界故。非无色界无见道故。问余善根何地所摄。答

  忍亦摄六地　　余则依于七

忍亦摄六地者。谛顺忍六地所摄如世间第一法。余则依于七者。暖及顶七地所摄。此六及欲界未除欲。欲界已除欲色界

  世第一法次　　必兴起法忍
  忍次生于智　　俱观于下苦

世第一法次必兴起法忍者。世间第一法次第。生无漏法忍名苦法忍。彼未曾观今观时堪任故曰忍。是谓初无漏无碍道。忍次生于智者。彼次第生苦法智。同境界受真实性解脱道。问彼忍及智何缘。答俱观于下苦。下苦者欲界苦彼同缘

  上苦亦如是　　因灭道亦然
  是正观诸法　　说十六净心

上苦亦如是者。上苦是色无色界苦。彼亦如是生忍无碍道智解脱道。苦未知忍及苦未知智。因者是习谛彼亦如是生四道。如苦习法忍。习法智习未知忍。习未知智。灭者灭亦如是生四道。灭法忍灭法智灭未知忍灭未知智。道亦然者。道亦如是生四道。道法忍。道法智道未知忍道未知智。是正观诸法说十六净心者。是见法。见法者。谓之正观是见异名

  从法行利根　　此在十五意
  从信行当知　　钝见亦在中

从法行利根此在十五意者。彼十五心顶若利根是说从法行。从信行当知钝见亦在中者。即彼十五心顶若钝根是说从信行

  未离欲界欲　　趣向于始果
  舍六趣至二　　三向九无漏

未离欲界欲趣向于始果者。彼从信行及从法行趣沙门果时。若未离欲俱趣须陀洹果。舍六趣至二者。欲界烦恼九种。微微微中微上。上中微中。中中上上微上中上上。彼若凡夫时已离六种。彼于后若趣证。是俱趣第二果。三向九无漏者。若已离九种是俱趣阿那含果

  若至十六心　　是名住于果
  信解脱濡见　　见到说利见

若至十六心是名住于果者。十六心名道未知智心相应。彼生已说住于果。未曾离欲界欲俱须陀洹。已曾离六品俱斯陀含。尽离九品俱阿那含。信解脱濡见见到说利见者。若彼趣时从信行钝根是信解脱。若彼从法行利根是见到

  未尽思惟断　　极生生死七
  家家有三尽　　俱在道迹果

未尽思惟断极生生死七者。彼信解脱及见到未离欲界思惟所断烦恼。是生生死七。彼有天上七生及人中。故说极生生死七。家家有三尽者。若三种尽上微上中上上是说家家。彼天上及人中。或生二家或生三家。后般涅槃故说家家。俱在道迹果者。极七有及家家当言俱住须陀洹

  六尽一往来　　离八谓一种
  九灭尽不还　　已出欲污泥

六尽一往来者。若有六种尽上三中三是斯陀含。彼余一生天上一生。人中一往来已般涅槃。故说斯陀含。离八谓一种者。若八品尽是一种。彼余唯一生无余故说一种。九灭尽不还者。若一切九品尽是阿那含。彼不复来欲界故说阿那含。所以者何。已出欲污泥

  如是九烦恼　　若在上八地
  彼双道所灭　　世尊之所说

如是九烦恼若在上八地者。如欲界九种烦恼暖暖至上。上上界亦如是。八地中梵世。光曜。遍净。果实无量空处。无量识处。无所有处。非想非非想处。彼双道所灭世尊之所说者。此一切烦恼欲界。及色无色界双道所灭。以无碍道灭。解脱道得证。问此道为世俗。为无漏。答

  有垢无垢道　　俱能离八地
  住中说身证　　谓获灭尽定

欲界地一。色界地四。无色界地三亦世俗道灭亦无漏。凡夫从世俗道尚得远离。况复圣住中说身证。谓获灭尽定者。住于八地无欲中。谓学得灭尽定是身证。所以者何。法似涅槃身所触故说身证

  金刚喻定次　　必逮得尽智
  生意我生尽　　离于一切漏

金刚喻定次必逮得尽智者。金刚喻定名非想非非想处。离欲时第九无碍道最后学心。于中一切诸烦恼永尽无余。一切圣行毕竟故。说金刚喻三摩提。此次第生尽智最初无学智。生意我生尽离于一切漏者。彼生定意我一切生尽。彼于尔时无著。解脱于一切漏。问无著几种。答

  无著有六种　　是从信生五
  逮得于二智　　当知时解脱

无著有六种者。世尊说六无著。退法念法护法等住。必升进不动法。于中若濡智及濡进。是得退具便退故说退法。暖智及暖进数数恶身。恶身已念坏故说念法。暖智而广进。进力常自护心故说护法。中智及等进是不增不损等。住于中道故说等住。少利而广进彼必得不动。故说必升进利智。及广进是始得不动故说不动。是从信生五逮得于二智者。于中五曾从信行彼有二智。尽智及无学等见。当知时解脱者。彼当知时解脱是求时。不能一切时随所欲学善

  不动法利根　　是不时解脱
  获得于三智　　成就等解脱

不动法利根是不时解脱者。谓一向利根是不动法。彼不时解脱能一切时。随所欲学善不求时。获得于三智者。彼有三智尽智无生智无学等见。成就等解脱者。谓此五无著时解脱。是成就等意解脱。谓不动法是成就不动解脱

  慧解脱当知　　不得灭尽定
  唯有俱解脱　　成就灭尽定

慧解脱当知不得灭尽定者。此六无著若不成就灭尽定。是说慧解脱是慧力解脱非定力。唯有俱解脱成就灭尽定者。此六无著若得灭尽定是说俱解脱。彼俱力解脱慧力及定力。已说贤圣。人法今当说

  从信行诸法　　及从法行法
  圣道见谛道　　是尽同一相

从信行法从法行法是说见道

  于中诸根法　　是名未知根
  谓余有学法　　佛说已知根

于中诸根法是名未知根者。于见道法中谓根根数如心。及痛信首五根是未知根。谓余有学法佛说已知根者。离见道学法诸余学法中。即彼根说已知根

  当知无知根　　在于无学中
  已得果便舍　　前道应当说

当知无知根在于无学中者。无学法中即彼根说无知根。已得果便舍前道应当说者。此无漏法升进得果时。舍无碍道所摄及解脱道

  已尽为解脱　　得摄于一果
  不秽污第九　　灭尽应当说

已尽为解脱得摄于一果者。无碍道至解脱道。于其中间得烦恼尽。但得果时一切烦恼。尽得一解脱果。不秽污第九灭尽应当说者。说诸烦恼九种道所灭。但不秽污第九无碍道一时断不渐渐

  若有相似名　　彼能获不动
  无著及信脱　　彼同性增道

若有相似名彼能获不动者。谓无著不能一切得不动。性必升进得彼是相似名。无著及信脱彼同性增道者。谓信解脱一向性必升进。是增益诸根逮得见到非余。问云何知渐渐见谛。答

  建立功德恶　　次第见真谛

非以见功德时见恶。亦不以见恶时见功德。亦非初总观彼恶。亦非一时一切厌。亦非总功德诸功德亦非一时合。是以建立功德恶次第见真谛。问云何知有为无为果。答以无碍道力得有为无为果。无碍道力得有为果及无为果。是故以无碍道力。得有为无为果

阿毗昙心论卷第二阿毗昙心论卷第三

        尊者法胜造

        晋太元元年僧伽提婆共惠远于庐山译

    智品第六

  智慧性能了　　明观一切有
  有无有涅槃　　是相今当说

谓智贤圣品已略说有无。有境界今当说

  三智佛所说　　最上第一意
  法智未知智　　及世俗等智

此三智摄一切智。于中法智名谓境界。于欲界苦习灭道无漏智境界。是初受法相故曰法智。从法智根现见已。非根现亦见未知智。未知智名谓境界。色无色界苦习灭道无漏智境界。是后受法相故曰未知智。等智名谓有漏智。是多取等谛智男女长短为首

  苦习息止道　　二智如可得
  此名与四智　　解脱师所说

此二智法智未知智。若行于谛如是相似名所说。苦谛境界说苦智。习谛境界说习智。灭谛境界说灭智。道谛境界说道智。解脱师所说

  若智观他心　　是从三中说
  尽无生智二　　境界在四门

若智观他心是从三中说者。他心智谓有漏境界。是等智境界。欲界道是法智境界。色界道是未知智。尽无生智二者。无学二智尽智无生智。于中所作已竟受无学智是尽智。不复更作受无学智。是无生智是亦法智未知智。问尽智无生智何谛境界。答境界在四门。此二智四谛境界苦习灭道。已说十智。行今当说

  二智十六行　　法智未知智
  如是行或非　　是说为等智

二智十六行法智未知智者。法智性是十六行四行受。苦四行习四行灭四行道未知智。色无色界亦尔。如是行或非是说为等智者。暖顶忍第一法中摄等智行。无漏行二谛所摄。十六行第一法摄四行闻思。及余思惟等智十六行。离此余等智非十六行。谓施戒慈如是比

  四智有四行　　决定行所说
  正观他心智　　此或是或非

四智有四行决定行所说者。苦智四行如上说。习灭道智亦如是。正观他心智此或是或非者。无漏他心智四行如道智有漏非

  尽智无生智　　离空无我行
  说有十四行　　受相为最胜

尽智无生智离空无我行说有十四行者。尽智无生智十四行除空无我行。所以者何。彼行等谛我已作不复更作。空无我者不以此行。受相为最胜者。非一切无漏智在十六行。十六行者是总行。更有无漏智受十六相。如身意止是自相智。不在十六行前受十六行。此自相行于诸无漏智前受故胜。已说十六行。如此智所得今当说

  第一无漏心　　或有成就一
  二或成就三　　于上增益一

第一无漏心或有成就一者。第一无漏心苦法忍相应。未离欲成就一等智。已离欲成就他心智。二或成就三者。第二无漏心苦法智相应。未离欲成就三法智苦智等智。已离欲成就他心智。于上增益一者。于上四时增说一。四时得苦未知智。得未知智习法智。得习智灭法智。得灭智道法智。得道智。忍中不得智。问此智何地所摄。答

  九智圣所说　　依倚于上地
  禅中有十智　　无色地中八

九智圣所说依倚于上地者。未来禅中间禅。无他心智根本禅摄故。禅中有十智者。根本四禅中有十智无色地中八者。无色中有八智除法智他心智。法智者境界。于欲界不以无色境界。于欲界他心智行。乘色无色中无色。已说地。修今当说。修有二种得修行修。得修者。谓功德未曾得而得。得已诸余功德彼所倚。亦得得已后时不求而生。行修者。谓曾得功德今现在前行。问此诸智云何修。答

  若以得为修　　智者诸圣见
  彼即当来修　　诸忍亦如是

若已得为修智者诸圣见彼即当来修者。见谛道中谓智现在前修。即彼当来修法智乃至道智。诸忍亦如是者。忍亦如是苦法忍现在前修。即苦法忍当来修。非智非余忍如是一切

  是于三心中　　得修于等智
  或修七或六　　最后心所说

是于三心中得修于等智者。即见谛道中。三心须当来修等智。苦未知智。习未知智。灭未知智。行此三谛时得修等智。所以者何。此三谛习已观非道谛。谓地见道即彼地等智及欲界。或修七或六最后心所说者。道未知智离欲修七智。谓阿那含果所摄。未离欲修六智除他心智。彼中非想非非想道得沙门果。是以不修等智

  十七无漏心　　于上思惟道
  当知修于七　　六修增益根

十七无漏心于上思惟道当知修于七者。须陀洹果上思惟道。十七心须修七智。此道未来禅所摄是以无他心智。尽智无生智是无学。以故无余七智必修。所以者何。彼意此功德常不空。若不修者曾得已舍复未更得。于其中间应空而不空是以必修。六种增益根者。增益根名谓信解脱。增益诸根逮得见到。彼有九无碍道九解脱道。是一切无碍道一切解脱道修六智。此说未离欲是以无他心智。尔时学道不学断烦恼。彼未曾得修功德非已曾得。是以不修等智

  得不还果时　　远离于七地
  思学诸通道　　解脱修习八

得不还果时者。若得不还果修八智彼中要得根本禅是以修他心智余智如前。远离于七地者。四禅三无色离欲时。一切九解脱道修八智。于中一切修下地禅。思学诸通道解脱修习八者。三通如意足天眼天耳。一切九解脱道修八智。所以者何。摄根本禅故

  此无碍道中　　及灭第一有
  彼八解脱道　　说者修习七

七地离欲时一切无碍道中。修七智除他心智。所以者何。此无碍道修灭结。智他心智非灭结。以故不修非想非非想处第一有。彼离欲时八解脱道中修七智除等智。所以者何。等智于非想非非想处转。还以非离故

  离于第一有　　六修无碍道
  乘上应当知　　修习于下地

离于第一有六修无碍道者。第一离欲时九无碍道中。修六智除他心智及等智。乘上应当知修习于下地者。此修一切地当知修自地诸智。及下地所摄。谓依初禅离欲彼修二地功德。自地所摄及未来禅。如是至无所有处

  漏无漏一切　　诸地修功德
  初无学心中　　此未知智意

漏无漏一切诸地修功德初无学心中者。得无著果时九地及自地。亦一切诸地于中修。所以者何。非想非非想处地烦恼相违。一切地有烦恼意不明净。无烦恼意明净。是以离彼修一切。问此无学初心何智相应。答此未知智意。是初无学心未知智相应。彼作是念我生已灭。是非想非非想处生缘。所以者何。最后尽故是以苦未知智相应。问又世尊言见智慧此三为一种为种种。答此是慧之差别慧性所有。但以事故世尊或说见或说智。问此义云何。答

  谓决定能知　　诸忍非智性
  尽智则非见　　无生智亦然

谓决定能知诸忍非智性者。修行八忍能求故见能视故慧。但非智不决定故。所以者何。用始缘故。尽智则非见无生智亦然者。尽智无生智视故慧决定故智。但非见不求故无所为故。余无漏慧种三性所有见智及慧

  善俗有漏智　　在意及诸见
  当知此则见　　说一切是慧

善俗有漏智在意及诸见当知此则见者。意识地中善有漏慧。三性见智及慧。五见烦恼性此见所有观察故。亦不离智及慧。余有漏慧种非见性所有。所以者何。无记意识相应慧种。非见性所有不观察故。秽污慧种亦非见性。所有烦恼所坏故。五识相应慧种亦非见性。所有不观察故亦不离智性。说一切是慧者。谓前所说离如忍中。离智尽智无生智离见。除善意识地及五见已余有漏慧离见慧不如是。所以者何。一切智种一切见种即是慧种故。问一一智几智缘。答

  法智未知智　　晓了于九智
  因智及果智　　是二智境界

法智未知智晓了于九智者。法智观九智缘九智除未知智。所以者何。未知智者非欲界果非欲界因非欲界灭非欲界道。未知智亦如是九智缘除法智。因智及果智是二智境界者。习智是因智。彼有漏他心智及等智缘同习故。余非缘无漏故。苦智亦如是此即果智

  道智是九智　　解脱智无缘
  余一切境界　　决定智所说

道智是九智者道智境界九智不缘等智有漏故。余尽缘同道谛故。解脱智无缘者。解脱智是灭智。非缘智缘无为故。余一切境界决定智所说者余有四智缘一切十智。等智缘十智境界一切法故。他心智亦缘十智。具他心境界故。尽智无生智亦缘十智。一切有为境界故。问又世尊言。未知智如离非想非非想处得无著果。未知智是彼道。非以此可知未知智。是彼道非余耶。答亦有法智是色无色界道。问何者。答

  若息止及道　　法智之所行
  是灭于三界　　非欲未知智

若息止及道法智之所行是灭于三界者。谓灭法智及道法智。在思惟道是灭于三界结。或有法智离色无色界欲。谓此重见恶是于欲界思惟灭及道。离色无色界欲非苦智非习智。所以者何。不同苦习同于灭道故。问颇有未知智灭欲界不。答非欲未知智。无有未知智能灭于欲界。所以者何。无彼重见恶而悲此。问神通智性所有彼。亦应当说一一几智。答

  如意足等智　　天眼耳亦然
  六于宿命中　　五说他心智

如意足等智天眼耳亦然者。如意足说等智天眼天耳亦如是。无漏智不以此行。六于宿命中者。宿命通有六智。法智忆法智分未知智忆未知智分等智忆俗。苦智忆过去苦习智。忆过去习道智忆过去道。五说他心智者。他心智通有五智。法智知他心中法智及彼相应心心数法未知智亦如是。等智知他俗心心数法。道智知他无漏心心数法他心智五

  九智漏尽通　　圣人之所说
  八境界于身　　法十九智二

九智漏尽通圣人之所说者。漏尽通无漏九智。一切漏相违故。问又世尊言。身身观意止观者。是慧此意止何智所有。答八境界于身八智观身色假名为身。是八智所知除他心智及灭智。若智缘色者是身意止。此二智不缘色。法十者。法意止有十智离色痛心余法。谓法是境界有十智自相界。及一切总如是法意止。九智二者。痛及心九智除灭智。谓智缘痛是痛意止。谓智缘心是心意止。问诸如来有智力。云何如来力施设智。及如来四无所畏智性。所有如所说我等正觉。此诸法未等正觉不见此相。如是一切此亦应当分别。一一几智性所有。答

  是处非处力　　及无畏第一
  此是佛十智　　余此中差别

是处非处力及无畏第一此是佛十智者。佛有十智是处。非处力。是处智名受诸法真实相真实行。受知此法如是相如是行。是谓是处智非处智。名诸法他相他行不可得。则知非此法如是相如是行是名非处智。是佛十智初无畏。亦十智等正受故。余此中差别者。是处非处力差别有十力初无畏差别。有四无所畏处非处智。是境界差别故十种分别。初无畏亦境界差别故四种分别。问四辩亦智性所有。此亦应当分别。一一几智。答

  法辩辞辩一　　应义辩俱十
  愿智是七智　　智最胜所说

法辩辞辩一者。法辩名觉诸法名是等智。非以无漏智受名。世俗中名是假号。无漏智不以此行。辞辩名觉正说。此亦等是俗中假智号。应义辩俱十者。应辩名观及现无所挂碍方便智是十智义辩名觉诸法真实。彼亦十智受真实相故(其人云辞应二辞应一等智法义二辩十智也)。问愿智有几智。答愿智是七智智最胜所说。愿智有七智除他心智尽智无生智。愿智者利捷疾境界。于三世受一切诸法。是七智性所有(其人云一等智)

    定品第七

问如是知诸智。此智当云何。答

  智依于诸定　　行无挂碍行
  是以思惟定　　欲求其真实

智依于诸定行无挂碍行者。如灯依油离风处光焰甚明。如是智依于定意离诸乱。智光甚明必定无疑行于缘。是以思惟定欲求其真实

  决定说四禅　　及与无色定
  此中一一说　　杂味净无漏

决定说四禅及与无色定者。有八定四禅及四无色定。此中一一说杂味净无漏者。初禅有三种味相应净无漏。如是一切诸定门。云何味相应。云何净。云何无漏。答

  善有漏是净　　无热谓无漏
  气味爱相应　　最上无无漏

善有漏是净者。谓善是净故说净。无热谓无漏者。烦恼假名热谓定无烦恼是无漏。气味爱相应者。谓禅无色定爱相应。是具足共相应共行是说味相应。最上无无漏者。最上非想非非想处彼中无无漏。不揵疾行故是有三种余各三种。问禅何性所有。答

  五枝有觉观　　亦复有三痛
  若干种四心　　谓之是初禅

五枝者。谓五枝摄受初禅令坚固。亦从此得名觉观。喜乐一心觉名。当入定时生善功德。始粗心思惟观名。令心细相续相连喜名。于定中悦乐名。已悦于身心中安隐快乐一心名。于缘中心专不散。此种住定时是枝及入时舍时是故五枝。初禅有觉观者。有觉有观即是初禅。问以受五枝今觉观何用。答枝者谓善是于五枝中。说秽污及无记。亦有觉有观而不是善。亦复有三痛者。初禅有三痛乐根喜根护根。于痛中乐根是身痛。喜根是意地。护根在四识。若干种者梵世中若干种有上有下。是说具足生处。四心者初禅有四心。眼识耳识身识意识。谓之是初禅者。此一切诸法谓是初禅。已说初禅。第二今当说

  二痛若干种　　二禅有四枝
  五枝是第三　　此禅说二痛

二痛者。第二禅有二痛喜根及护根。若干种者。于中身有若干种。已离觉观有若干心。或时入喜根或时入护根。但喜是根本边有护根。二禅有四枝者。第二禅有四枝。内净喜乐一心内净名。是信于离中生信。已得初禅离便作是念。一切可离余枝如前说。此种于第二禅是枝。五枝是第三者。第三禅有五枝乐护念智一心。乐者意识地中乐根。护者已乐于乐不求余(其人云护虽有义不应云枝也)念者。是护方便不舍智者不令乐。一心者定此种于第三禅中是枝。此禅说二痛者。第三禅有二痛。乐根及护根。乐根是根本。护根是边

  离息入息出　　第四有四枝
  此枝谓说善　　亦复分别种

离息入息出者。息入者来息出者去。是第四禅中无。所以者何。彼由定力故身诸毛孔合。第四有四枝者。第四禅有四枝。不苦不乐护净念。一心求离苦乐。不苦不乐余如前说。问何禅是枝相应。答此枝谓说善。善禅枝相应枝非秽污亦非无记。亦复分别种者。谓种随处已说。当知是余处不应有。如初禅有觉有观。四心说此种余一切地无。第四禅离息入息出。是三中无不应说。已说四禅四无色定。谓余今当说。问如世尊言。有根本依。若未离欲。未有根本依。而有无漏功德。是无漏功德何地所摄。答未来禅所摄。又世尊所说有三定。有觉有观无觉少观无觉无观。于中初禅是有觉有观。第二禅是无觉无观。谓无觉少观。定是何地所摄。答是中间禅所摄。是未来禅中间禅相今当说

  相应有觉观　　俱在未来禅
  观相应中间　　明智之所说

相应有觉观俱在未来禅者。未来禅中有觉有观。观相应中间明智之所说者。中间禅少有观而无觉。彼渐渐心息止

  无依而二种　　除其味相应
  中禅有三种　　俱为说一痛

无依而二种除其味相应者。未来禅一向善有漏及无漏。有漏者净。无漏即无漏。中禅有三种者。中间禅有三种味净无漏生死居故。俱为说一痛者。未来禅及中间禅俱有一痛护根非根本地故。已说诸定余功德。于中摄今当说

  三摩提有通　　无量修一切
  除入及诸智　　解脱于中起

三摩提者。三三摩提空无愿无相。无漏心系缚故。有通者。有六通如意足智天耳智他心通智忆宿命智生死智漏尽通智。无量者。四无量慈悲喜护。无量众生境界故曰无量。修一切者。十一切入。地一切入。水火风青黄赤白一切入。无量空处一切入。无量识处一切入。尽具解故一切入。除入者。八除入内未除色想不净观少境界。一无量境界。二除色相少境界。三无量境界。四复除色想青黄赤白观除入。除净境界故故曰除入。及诸智者。诸智有十如前说。解脱者。八解脱未除色想不净思惟一。除色想不净思惟二。净思惟三。四无色及灭尽定。境界背不向故说解脱。于中起者。此诸功德九地中可得及于中起(其人云应十地)。已说诸功德随地可得今当说

  一慧悲及护　　慈亦有五通
  说遍四禅中　　六中有现智

一慧悲及护慈亦有五通说遍四禅中者。一慧谓他心智三无量。及五通是一切功德根本四禅中非余。六中有现智者。现智是法智。六地中有根本四禅未来禅中间禅

  除入中说四　　于中亦有喜
  初解脱及二　　功德初二禅

前四除入喜等初第二解脱。此功德初第二禅中非余

  除入谓有余　　及与解脱一
  亦八一切入　　佛说最上禅

后四除入净解脱前八一切入。是功德第四禅中非余

  余脱即名说　　二一切亦然
  灭尽最在后　　余九谓无漏

余脱即名说二一切亦然者。余四解脱自名所说。及二一切入亦如是。无量空处解脱无量空处一切入。于无量空处中所摄如是至非想非非想处。灭尽最在后者。灭尽定非想非非想处所摄。所以者何。谓未离彼欲亦入。余九谓无漏者。谓余无漏法九地所摄。如三三摩提七智漏尽通是九地所摄。四禅三无色未来。及中间等智是十地所摄。此亦非想非非想处可得以定数故。问此功德几有漏几无漏。答

  三解脱当知　　有漏及无漏
  定智已分别　　谓余尽有漏

三解脱当知有漏及无漏者。无量空处无量识处。无所有处解脱是有漏无漏。定智无分别者。定如契经品说。无漏智及诸通如智品说。谓余尽有漏者。余一切功德一向有漏。如三通威仪法故色声受相故。无量众生缘故。一切入意解希望故。三解脱亦如是。非想非非想处非揵疾行故。想智灭离觉观故。除入亦意解希望故。已说诸功德。相成就今当说

  未能度于欲　　成就味相应
  度下未至上　　成就净诸定

未能度于欲成就味相应者。谓地若未离欲。于彼地成就味相应度。下未至上成就净诸定者。谓离欲界欲。若未生梵世上地。彼成就净初禅。及初禅地有漏功德。如是一切尽当知

  住上应当知　　无漏成就禅
  求得诸功德　　知非无欲中

住上应当知无漏成就禅者。谓离下地欲彼住上地。亦成就下地无漏。如见谛离欲住梵世上地。成就无漏初禅。及初禅地定等诸无漏功德。如是一切尽当知。世俗功德系在随生处。无漏在断中。是以离生处舍有漏功德不舍无漏。求得诸功德知非无欲中者。已说离下地欲成就上功德。当知非一切功德离欲时得。如如意足智天眼智天耳智无记性。所有欲及灭尽定此求得。非离下地欲时得。已说成就因缘今当说。定种有二十三。八味相应八净七无漏。问此一一种几种因。答

  妙无漏无染　　七种谓之因
  净味相应禅　　当知因有一

妙无漏无染七种谓之因者。一一无漏七种自然因。自地相应因共因。净味相应禅。当知因有一者。味相应初禅。于味相应初禅因非余。非善因不相似故。非余地秽污因行相违故。净初禅于净初禅因。非秽污因不相似故。非无漏因亦不相似故。非余地净因自地果报故。及自地系缚故。如是一切尽当知。已说因缘次第缘。今当说。问一一次第生几种。答

  无漏禅次第　　兴起六种禅
  七八九有十　　起禅亦空定

无漏初禅次第生六种自地净及无漏。如是第二第三禅无漏。无所有处次第生七。自地二下地四上地一。无漏第三禅次第生八。自地二下地二上地四。无漏无量识处次第生九。自地二下地四上地三。余无漏次第生十。自地二下地四上地四

  净六有七八　　九十生十一
  味相应诸禅　　兴二乃已十

净六有七八九十生十一者。净非想非非想处次第生六。自地味相应及净下地四。净无漏无所有处无量识处。非味相应离欲故。如是一切尽当知。一切自地味相应。味相应诸禅兴二乃以十者。味相应禅次第生二。自地味相应及净不生余。各各相违故。如是一切自地二下地一净(其人云不应有下地一净)。一切味相应死时生。已说次第缘缘。今当说问一一几种缘。答

  净以无漏禅　　必缘一切地
  秽污相应禅　　独缘于己地

净以无漏禅必缘一切地者。净及无漏禅一切地缘一切种。秽污相应禅独缘于己地者。味相应禅缘于自地味相应禅及净。非无漏爱无无漏缘。亦不乐于他地

  无色无有力　　缘下有漏地
  善有根本地　　秽污如味禅

无色无有力缘下有漏地者。无色定不能缘下地有漏法极寂静故。问何谓无色不能缘下地有漏法。答善有根本地净。及无漏根本无色。是自地缘及上地非下地缘。秽污如味禅者。如味相应说无色亦然

  谓余于色界　　无量等功德
  是必欲界缘　　世尊之所说

谓色界余功德如无量等。一切入除入及解脱。唯缘欲界缘无量苦众生。青等诸色此则欲界。所以者何。神通二界缘故。问世尊所说勋禅是云何。答勋一切四禅无漏者。勋有漏是无漏力故。受净居果报。问若一切四禅勋者。以何等故下三禅中无净居果。答

  若能勋诸禅　　是依第四禅
  三地爱尽故　　净居果实中

若得第四禅是能勋禅。第四禅者先勋余者后。谓得第四禅离三禅欲。以是故下地无有净居果实中。有问世尊言。有愿智是云何。答谓

  无著性不动　　是得一切定
  彼由定力故　　能起顶四禅

于中若彼意生功德。愿智不诤辩首诸功德。愿智者如所愿入定。或过去或未来或现在。或有为或无为是一切尽知。不诤者。欲令他意不起诤。便不起辩者。诸法义及味决定。无疑不挂碍无所畏。问是愿智不诤及辩何地摄。答

  三地有愿智　　无诤依五地
  法辞辩依二　　二辩依于九

三地有愿智者。愿智三地所摄。第四禅初禅及欲界。入第四禅知初禅及欲界。说无诤依五地者。无诤五地可得根本四禅四及欲界。欲令一切不诤。法辞辩依二者。法辩名缘味是欲界及梵天世。非上地离觉观故。辞辩名是味撰智。彼亦二地中可得。欲界及梵天世。二辩依于九者。义辩及应辩九地中可得。四禅四无色及欲界。已说初禅。当知已说未来及中间。此是初禅眷属故。问云何得此定。答

  断欲亦复生　　而得于净禅
  秽污退及生　　无漏唯断欲

断欲亦复生而得于净禅者。净初禅二时得。离欲时及上地没生梵天世。如是一切尽当知。秽污退及生者。秽污味相应是退时得。若欲界及梵天世缠退于尔时得。味相应初禅生时得者。若上地命终生欲界及梵天世于尔时得。味相应初禅如是一切尽当知。无漏唯断欲者。无漏唯断欲时得。谓圣得离欲于尔时得无漏初禅。如是一切尽当知。问此功德谁能除烦恼。答

  无漏除烦恼　　亦复定中间
  一切定中间　　相应于护根

无漏除烦恼者。无漏初禅八地除烦恼。如是一切尽当知。亦复定中间者。定中间名谓下地除欲。以方便道故终不得根本生。未得离欲余不能除。一切定中间相应于护根者。一切定中间护根相应终不得喜至不得义。问变化心有几。谓有如意足能变化答八。四禅果欲界。四禅果初禅地。问彼谁成就。答

  下地变化意　　成就彼种果
  若合三种心　　上地应当说

下地变化意成就彼种果者。谓若成就禅是成就彼果下地变化心。问如说初禅有四心。住于上地欲闻欲见。彼云何见闻。答

梵世地识现在前。问彼几时成就。答若合三种心上地应当说。若时彼识现在前。若眼识若鼻识若耳识若身识。尔时成就彼识。若不现在前即灭尔时不成就

阿毗昙心论卷第三阿毗昙心论卷第四

        尊者法胜造

        晋太元元年僧伽提婆共惠远于庐山译

    契经品第八

已说定品契经品今当说

  一切智所说　　契经微妙义
  此吾今当说　　宜应善心听

虽有一切阿毗昙契经义。然诸契经应具分别今当说。世尊说三界欲界色界无色界。问此云何。答

  欲界十居止　　色界说十七
  无色中有四　　三有亦复然

欲界十居止者。此欲界十居止。地狱畜生饿鬼人。六欲天。四王天。三十三天。炎摩。兜师哆。化乐。他化自在。是众生起欲想。此处所中若可得物尽望淫欲所有。是以说欲界。问色界云何。答色界说十七。色界说十七者。居梵身梵富楼光。少光无量光光曜。少净无量净遍净。无挂碍受福果实。无想众生不烦不热善见善现色究竟。此处所不起欲想。但成极妙色。非男非女形是故色界。无色中有四者。无色界四。居无量空处。无量识处。无所有处。非想非非想处。此处所无色彼离色欲。是以说无色界。问世尊说三有欲有色有无色有。此云何。答三有亦复然谓前三界分别即是三有。问如世尊所说七识住。是云何。答

  善趣是欲界　　及色界三地
  无色亦如是　　慧知诸识住

此欲界中若趣善数。如人及六欲天。色界前三地无色前三地。初禅地上。二禅地三二禅地上。三禅地三三禅地上。四禅地九。于中前三地及无色前三地。是说七识住。何以故。不坏识故恶趣中苦痛坏故。不得立识住。第四禅无想定坏故。亦不得立识住。非想非非想处。灭尽定坏故。不得立识住。是故不说

  第一有无想　　众生居说九
  诸有漏四阴　　是说四识住

第一有无想众生居说九者。此七识住及无想众生非想非非想处。是说九众生居。于中众生居止是故说众生居。诸有漏四阴是说四识住者。有漏色痛想行。若识相续有此伴。是故说识住。问世尊说十二枝缘起。此亦应当说相。答

  诸烦恼及业　　有体渐渐生
  是名说有枝　　众生一切生

于中烦恼是无明爱受名说业者。行及有名说体者。余枝是一切众生渐渐生依体立烦恼。烦恼所作业业所作体。是故十二种分别。问此枝为一时行为渐渐。答非一时。十二苦阴说十二枝。无明为首

  彼是次第立　　受于生死中
  过去及未来　　处中说于八

彼有枝次第立。于中前生时一切烦恼。共有及伴说无明。由此故造业。业造果是行。彼生种心是识。彼共生四阴相续是名色。于中所依眼为首。诸根是六入。根境界心和合是更乐。更乐所生受是痛。痛所著是爱。痛具所烦劳是受。彼所劳造业是有。于中更受果是生彼生中无量起灾患是老死。如是此有枝一切生中。二摄过去世。二未来。八现在生中摄。问世尊说六界此云何。答

  诸大谓有四　　及与有漏识
  亦色中间知　　是界说生本

诸大谓有四及与有漏识亦色中间知者。四大地水火风有漏识及色中间可知。谓眼所受此六法说界。问以何等故于众多法中说六界。答是界说生本。是六法生死之本。此中有士夫想。于中身地所生。水所润火成熟除烂腐臭。风所起。空中间饮食。由风行出入识所立。此中起士夫想。是生死性故说界。问世尊说四圣谛此相云何。答

  诸行若有果　　有漏是说苦
  若有因是习　　苦尽谓之灭

诸行若有果有漏是说苦者。一切有漏从行因中生。亦作一切苦患。是故一切行说苦谛。若有因是习者。一切有漏行他因。是以一切行说习谛。如一女亦说母亦说女前后故。如是有漏行亦说苦谛亦说习谛。已生当生故。苦尽谓之灭者。一切有漏行灭休息止谓之灭谛

  若有无漏行　　是说为道谛
  彼为二事故　　见着则知微

若有无漏行是说为道谛者。一切无漏行说道谛。何以故。休息苦时尽是具故。问何以故说谛。答彼为二事故。二事说谛。自相真实非颠倒。及见彼得非颠倒意。问如前因后果。以何等故。世尊前说果后说因。答见着则知微。圣谛虽有前习后苦。先修道后得灭。但应前见苦谛后见习谛。如是应先见灭谛后见道谛。何以故。苦粗习细灭粗道细。是故世尊先说苦谛后说习谛。先说灭谛后说道谛。问世尊说四圣沙门果此几种。答

  圣果有六种　　最胜在九地
  第三在六地　　二俱依未来

圣果有六种者。六种四沙门果无漏五阴及数缘灭。问四沙门果何地所摄。答最胜在九地。最胜是无著果。是九地所摄。根本四禅三无色未来及中间。第三在六地者。不还果六地所摄。具足四禅未来及中。非无色以无法智故。二俱依未来者。须陀洹果及斯陀含未来禅所摄。以未离欲故。问世尊说四道。苦非速通苦速通乐不速通乐速通此何相。答

  从信行诸法　　无烦恼迟想
  从法行诸法　　无烦恼速想

从信行诸法无烦恼迟想者。从信行无漏法是非速。钝根辈所摄是迟。若受此当知信解脱时解脱。亦受同钝根故。从法行诸法无烦恼速想者。从法行无漏法利根辈所摄是速。若受此当知见到不时解脱亦受同利根故

  根本禅地中　　知假名乐想
  小及难得故　　余皆是苦想

根本禅地中知假名乐想者。根本四禅中利根及钝根法说乐道。何以故。止观导等故及乐行故。小及难得故余皆是苦想者。余地摄无漏是苦想。所以者何。以小故。未来禅中间禅止道小。无色中观小。是故极苦一向难得及小故说苦。问世尊说四不坏净。于佛不坏净。于法僧圣戒不坏净此云何。答

  自觉声闻法　　解脱亦余因
  清净无垢信　　圣戒及决定

自觉声闻法解脱亦余因清净无垢信者。自觉是佛。彼佛无著果所摄。无学功德是佛法。于此法若无漏信。是说于佛不坏净。已取正证声闻。彼学无学功德是说声闻法。于此法若无漏信。是说于僧不坏净。涅槃中无漏信及余有为法。如苦谛习谛信。菩萨无漏功德信。学无学辟支佛法信。是说于法不坏净。圣戒者无漏戒。是说于戒不坏净。问以何等故不坏净。一向无漏非有漏。答及决定此是决定。从正见中生故。无漏信无漏戒定无漏。有漏信者为不信所坏。有漏戒者为非戒所坏。是以不决定。无漏不坏至后生是以决定。故不坏净一向无漏。问世尊说修定有四。有修定于现法中得乐居。有修定得知见。有修定分别慧。有修定得漏尽。此何相。答

  初禅若有善　　说现法是乐
  若知于生死　　是说名知见

初禅若有善说现法是乐者。净及无漏初禅能得现法乐居。若知于生死是说名知见者。生死智通。是说修定知见共依五阴

  慧分别当知　　求得诸功德
  金刚喻四禅　　是名为漏尽

慧分别当知求得诸功德者。方便生功德名欲界戒。闻思修功德一切色无色界善法。一切无漏有为法。是一切修定分别慧。金刚喻四禅是名为漏尽者。金刚喻名最后学心共相应。共有第四禅所摄。是说修定漏尽。何义此如来自已说。问世尊说四如意足四正断四意止。彼亦应当说相。答

  善有为诸法　　求方便等起
  佛说如意足　　亦现正意断

善有为诸法求方便等起佛说如意足者。求方便等起如前修定分别慧。说是一切如意足。如意乘器故。亦现正意断者。即此一切功德说正断

  彼亦是意止　　四圣种亦然
  谓有恩力生　　彼圣之所说

彼亦是意止者。即此法亦说意止。问世尊说四圣种此云何。答四圣种亦然。即此法亦说四圣种。问何以故。此一切功德。说意止正断如意足圣种。答谓有恩力生。彼圣之所说。此诸法谓定恩力生由定住。是故说如意足。精进恩力生故说正断。念恩力生故说意止。少欲知足恩力生故说圣种。已共分别道品。自相今当说

  净信精进念　　喜慧及倚觉
  护思惟戒定　　是法谓道品

此十法说道品非余。于中信是信根信力精进是四正断。精进根精进力精进觉枝正方便。念是念根念力念觉枝正念。喜是喜觉枝。慧是四意止慧根慧力。择法觉枝正见。倚是倚觉枝。护是护觉枝。思惟是正志。戒是正语正业正命。定是四如意足定根定力定觉枝正定。问何以此法如是多种分别。答

  处方便一意　　濡钝及利根
  见道思惟道　　佛说三十七

处者。正念立缘中故说意止。方便者。正方便故说正断。一意者。立一意故说如意足。濡钝意得故说根。利根者。利根意得故说力。见道者。见道得故说道支。思惟道者。思惟道得故说觉支。是谓分别事故。佛说三十七。此十法事故佛说三十七。问此道品何地所摄。答

  禅第二未来　　是说三十六
  三四三十五　　中间禅亦然

禅第二未来是说三十六者。第二禅无正志未来禅无喜觉枝。余有三四三十五。中间禅亦然者。第三第四禅中间禅。无喜觉枝无正志余有

  第一说一切　　三空三十一
  最上二十一　　欲界二十二

第一说一切者。初禅具有三十七。三空三十一者。三空中有三十一。喜正志正语正业正命身意止彼中无余有。最上二十一者。非想非非想处。无七觉八道及身意止。欲界二十二者。除觉枝道枝余有。问世尊说四食揣食更乐食意思食识食。是何想。答

  诸食中揣食　　是欲界三种
  识思及更乐　　是食谓有漏

诸食中揣食是欲界三种者。欲界揣食三种香味细滑。除饥渴故说食。识思及更乐是食谓有漏者。有漏识有漏思有漏更乐。是说食有何义。后生相续不断故说食。问世尊说三三摩提空无愿无相。此三摩提云何行几行。答

  无愿有十行　　二行是空定
  圣行中四行　　说是无想定

无愿有十行者。无愿三摩提行十行。无常行苦行习谛四行道谛四行。二行是空定者。空三摩提二行空及无我行。圣行中四行说是无想定者。无想三摩提灭谛四行。问世尊说四颠倒。于无常有常想心颠倒想颠倒见颠倒。苦有乐想不净有净想非我有我想。心颠倒想颠倒见颠倒。此何见断为何性。答

  晓了见苦断　　四种是颠倒
  三见性所有　　舍见正见说

晓了见苦断四种是颠倒者。一切四颠倒见苦断以行苦处故。三见性所有舍见正见说者。颠倒是见性三见中最上即是说颠倒。身见是说我见我是我见故。边见见有常及断。见盗不净见净彼一切行苦处。及见性所有心想见作乱故。说心颠倒想颠倒见颠倒。但非性颠倒。问世尊说多见六十二首。是何见所摄。答一切见是五见所摄。身见为首。问云何知。答

  诽谤于真实　　此说为邪见
  非实而见实　　是二见及智

诽谤于真实此说为邪见者。谓见诽谤真实法无。此如说无施无齐无说。如是一切说邪见。非实而见实是二见及智者。五阴中不真实我见。我观有是实见说身见。非真实乐净观有乐净。是见见盗及余邪智思惟所断。如夜有见。谓是贼。如竖木人像

  净见谓戒盗　　是非因见因
  受边说此见　　依断灭有常

净见谓戒盗是非因见因者。谓法于法非因见是因。此见是戒盗。如苦行至解脱。受边说此见依断灭有常者。谓见无常事见常。是谓有常见。谓因缘相续不识已见断。是谓断见谓之受边见

  建立诸诽谤　　因依于二边
  若有事转行　　是正见应断

建立诸诽谤者。说邪见。彼若诽谤苦是见苦断。若诽谤习是见习断。若诽谤灭是见灭断。若诽谤道是见道断。身见建立于苦我是我是见苦断。见盗建立苦为乐是见苦断。若习是见习断。若灭是见灭断。不受正法是故见灭断道亦复然。戒盗若行有漏处是见苦断。若行无漏处是见道断。见断灭计常是亦见苦断。现五阴受断灭计常非不现。此中分别一切诸见。问世尊说二十二根。此云何。答

  诸界在于内　　身三及命根
  是根生死依　　圣人之所说

诸界在于内者。眼耳鼻舌意。身三者。身根三种身根男根女根。及命根者。命根第九。是根生死依圣人之所说者。此九根生死依故。说根众生是生死想

  从痛诸烦恼　　信首依清净
  九根谓无漏　　是三依于道

从痛诸烦恼者。乐根苦根喜根忧根护根。是诸痛从此诸烦恼故说根。信首依清净者。信根精进念定慧根。依此解脱故说根。九根谓无漏是三依于道者。信首五根三痛及意根。是若无漏依道故说根。谓从信行法行道所摄是未知根。谓思惟道所摄是已知根。谓无学道所摄是无知根。问此中几欲界系。几色界系。几无色界系。答

  欲界四善八　　色种性有七
  诸心数者十　　一心慧所说

欲界四者男根女根苦根忧根。是一向欲界系。余如界品说。善八者。信首五根及三无漏。色种性有七者。色根有七五色根男根女根余者非色。问几性心几性心数几非性心非性心数。答诸心数者。十信首五根及五痛。一心慧所说者。意根是余根非性心非性心数。问几有报几无报。答

  一及十有报　　是慧之所说
  十三中是报　　见实者分别

一者忧根一定有报。一向善不善故。现在方便起是不从报生。非威仪非工巧。是以非无记故一向有报。及十有报是慧之所说者。信首五根谓有漏是有报。谓无漏是无报。意根及三痛谓无记及无漏是无报。余善不善是有报。苦根谓无记是无报余有报。问几是报几非是报。答十三中是报。见实者分别十三根中。或性是报或非色根。七命根意根及四痛无记法者。善不善中生故报。问生时几根最初得报。答

  二或六七八　　谓初时可得
  欲中有报相　　亦六及上一

二或六七八谓初时可得者。谓渐渐成根。如卵生湿生胎生。是最初时二根生身根及命根。化生无形得六根。五色根及命根。一形七二形八。欲中有报想者。此说是一向欲界众生。亦六及上一者。色界最初得六根。无色一根。彼尔时一向秽污心。是以一向秽污得心心数法非报。问命终时几根最后舍。答

  四舍八与九　　或复舍于十
  死时渐渐灭　　善舍各增五

四舍八与九或复舍于十死时渐渐灭者。无记心渐命终时。最后舍四根身意命护根。无形一时无记心命终舍八根。一形九二形十。善舍各增五者。即彼善心加增信首五根。如是色无色界随根可得亦如是。问几见断几思惟断几无断。答

  二断无断四　　二种根有六
  三微妙不断　　谓余思惟断

二断无断四者。四根见断思惟断无断意根及三痛。二种根有六者。信首五根及忧根。三微妙不断者。三无漏是不断。谓余思惟断者。九根思惟断命根八及苦根。已说诸经门今当说。问世尊说六识。眼识耳鼻舌身意识此识识何法。答

  若取诸根义　　是五种心界
  受一切诸法　　是谓意识界

若取诸根义是五种心界者。义名五种色是五识识。眼识识色乃至身识识细滑。受一切诸法是谓意识界者。意识识一切诸法。此境界一切诸法。问有十法欲界相应不相应。色界相应不相应。无色界相应不相应。有为无漏相应不相应。无为二种善及无记。此中应分别智。一一智境界几法。答

  五法应当知　　法智之境界
  未知智为七　　他心境界三

五法应当知法智之境界者。五法法智境界欲界相应不相应。无漏相应不相应无为善。未知智为七者。未知智境界七法。色无色界及无漏相应不相应无为善。他心境界三者。他心智境界三法欲色及无漏相应

  有漏智有十　　因果境界六
  解脱智一法　　道二谓余九

有漏智有十者。有漏智是等智。彼一切十法境界一切法境界故。因果境界六者。苦智及习智是境界六法。三界相应不相应。解脱智一法者。灭智境界一法唯无为善。道二者。道智境界二法。有为无漏相应不相应。谓余九者。余尽智无生智是境界九法。除其无为无记是谓智解

  自地烦恼定　　所使于自地
  一切遍是种　　随在于彼类

自地烦恼定所使于自地者。欲界诸烦恼所使于欲界。梵世诸烦恼所使于梵世。如是至非想非非想处尽当知。一切遍是种随在于彼类者。通一切遍不通一切遍。诸烦恼所使随种通一切遍亦他种。如身见见苦断。此中苦谛所断一切使所使。及见习断通一切。如是至命根思惟断。此思惟所断一切所使及通一切

  三界烦恼定　　定在于三界
  二界应当知　　一界亦复然

三界烦恼定定在于三界者。谓法三界所摄是定在于三界。此中三界一切使所使。如意根定在三界。此中一切使所使。二界应当知者。谓法二界所摄是定于二界。此中二界一切使所使。随界可得。如觉观定在欲色界。此中欲色界一切使所使。一界亦复然者。谓法定在一界。此中一界一切使所使如忧根。定在欲界一切使所使

  此佛说契经　　显示于诸法
  识智及诸使　　分别此三门

此佛契经中。若说诸法是三门应分别。识门智门使门。如欲有中五根义是六识识。色界四识除鼻识舌识。相应不相应故七智知。五种故欲色界使所使

    杂品第九

已说契经品杂品今当说

  已说随相应　　一一分别法
  于上众杂义　　今略说善听
  有缘亦相应　　有行或与依
  心及心数法　　是同一义说

心及心数法此名差别。一切行一缘是故说有缘。更互相应故说相应。境界行故说行。由依生故说依

  从缘生亦因　　有因及有为
  说处有道路　　有果应当知

有为法中此名差别。由依缘故说缘。生他故说因。由依因故说有因。由依造有故说有为。多方便善显现故说处。依过去未来现在道路故说道路。有转成果故说有果

  有恶亦隐没　　秽污下贱黑
  善有为及习　　亦复名修学

有恶亦隐没秽污下贱黑者。不善及隐没无记法此名差别。不可说辈中立故说有恶。烦恼所覆故说隐没。烦恼垢污故说秽污。凡鄙故说下贱。无智闇乱故说黑。善有为及习者。善有为法此名差别。慧中生故说善行时。能得功德及可行故说习及修。已说心相应行。心不相应行今当说

  无思想二定　　亦众生种类
  句身味名身　　命根与法得
  凡夫性所有　　及诸法四相
  非色不相应　　说是有为行

无思想者。生无想天心心数法不起。二定者。无想定灭尽定。无想定名厌于生死解脱想。由第四禅心相续一时断。灭尽定名厌于劳务息止想。由非想非非想心相续一时断。亦众生种类者。生处已生于此处众生依及心相似。句者名会所说如所行非常谓兴衰法味者句会事。广说如偈及契经。名者字会说义如说常命根者。根及大等相续不断。得者成就诸法不舍。凡夫性者。未取正证离圣法是凡夫性。所有四相者。生住老无常。非色者。此一切诸法如上所说。非色非色所摄。不相应者无缘故。说是有为行者。有为造故说有为行。问此中几善几不善几无记。答

  善二三种五　　七应是无记
  二在色当知　　一在无色地

善二者。无想定灭尽定。三种五者。得生老住无常。善中善不善中不善无记中无记。七应是无记者。七无记无想天众生种类。句味名命凡夫性所有。问此中几欲界系几色界系几无色界系。答二在色。当知一在无色地。二在色当知者。无想定及无想天是色界。一在无色地者。灭尽定在无色界

  二界说于三　　谓余在三界
  有漏无漏五　　其余定有漏

二界说于三者。句味名亦在欲界亦在色界。非无色界离言语故。谓余在三界者。众生种类命得凡夫性所有。及四相通在三界。问此中几有漏几无漏。答曰。有漏无漏五其余定有漏五者。得生老住无常。在有漏中有漏。在无漏中无漏。其余定有漏者。谓余一切定有漏。问此离圣法假名凡夫三界中无记。此云何舍云何断。答

  初无漏心中　　圣不成就舍
  凡夫流诸界　　离欲时灭尽

初无漏心中圣不成就舍者。第一无漏心中得圣法时得不成就舍。凡夫流诸界者。流诸界时谓处所命终此处所舍。谓处所生彼处所得无记故。离欲时灭尽者。谓地凡夫所有。若此地离欲尔时得灭凡夫性。已说心不相应行。无为今当说。三无为法数缘灭非数缘及虚空。于中数缘灭者解脱诸烦恼。依于数缘灭有漏法离烦恼解脱。数缘力智力计挍事有而无。是名数缘灭。无挂碍之相是名曰虚空。谓不障碍色是虚空

  诸法众缘起　　亦从依与缘
  不具以不生　　此灭非是明

一切有为法从众缘而生无缘则不生。如眼识依眼依色依空依明依地依寂然。若此一切共和者便得生。若余不具便不得生。如眼时眠一切时生。尔时是余事不具眼识不得生。若彼眼识应当生而不生。眼生已终不复更生离此缘故。是有未来不复当生。彼起具差违不和是非数缘灭。如是一切行尽当知。已说无为因今当说。问有为法说是因。此中云何因为谁因。答

  前因相似增　　或俱依倚生
  二因及一缘　　一向已生说

前因相似增者。前生法后生相似因转增。如濡善于自地濡善因。及中因上因中于中因。及上因上唯上因。行法时有住有增终不减。以是故非为濡因。或俱依倚生者。或因俱生如相应因及共有因。二因及一缘一向已生说者。自然因已生当言因。非不生前者后因。未生者无前后。若为有者应随时生不从因。但不尔是故不有一切。遍因亦如是及次第缘。问谓此报者为是众生数为非众生数。答报是众生数报者众生。数法中。说非不众生数。所以者何。众生数者不共有。非众生数共有是故非报。问是果法云何。答有为解脱果。一切有为法性果。所有由因缘故无为解脱亦应说道果。问有缘法云何行缘。答有缘者共俱有缘法是相应是共俱一缘中行不别。问何处行。答行于他境界。他境界中行非自性。离自行及缘差别故。问心心数法为有处所为无处所。答无处所。所以者何。普因故普因生心心数法。因二眼生一识。若有住处者应住一眼中一识故。若尔者第二眼不应见色而见。是故非一眼中住。如是一切尽知。若如是者。以是故无住处。问世尊说心解脱云何。心解脱为过去为未来为现在。答生时而解脱道生时解脱。所以者何。道生时诸烦恼灭。是故生时解脱。问道生时断烦恼为不。答

  道灭时灭结　　明慧之所说

道灭时断诸烦恼非生时。所以者何。道生时是未来。未来道者不能行事。以是故无碍道灭时断烦恼。解脱道生时解脱。问世尊说有爱无有爱。有爱几种无有几种。答

  有爱有五种　　无有独一相

有爱有五种。有爱名于生不生物。若爱是名有爱。此五种有苦断见习灭道断及思惟断。无有独一相者。无有爱名已见断。乐于断是名无有爱。此一向思惟断。所以者何。从见爱思惟断。此是不转行相续中。爱非爱见是故思惟断。问世尊说三界断界无欲界灭界此何相。答

  爱处余烦恼　　灭尽是三界

爱断是无欲界。处断是灭界。余烦恼断是断界。问十心欲界。善秽污无记色界。善秽污无记无色界。善秽污无记及无漏。此心几秽污心中可得。几善心中可得。几无记心中。答

  秽污心得十　　正觉之所说
  善心中得六　　无记即无记

秽污心得十正觉之所说者。秽污心中得一切十心界。及地来还时三界善秽污及无记。此心一切得退时得无漏。善心中得六者。善心中得六心。欲界善求学得及身口行。亦变化心无记。色界善变化心无记。无色界善心及无漏。无记即无记者。无记心唯无记以劣故。问前已说道品十法。此中几根性所有。几非根。答

  道品有六法　　当知是为根

此中六法根性。所有信首五根及喜余者非根所有。问诸法为自性相应。为他性。答

  相应于诸法　　是说谓为他

诸法他性相应不自性。非为自性于自性伴。问若此解脱当云何。答

  缘中解于缚　　大仙人所说

诸烦恼于缘中愚即彼不起愚。缘中缚即于中解。不可以相应解相应。所以者何。以空故。问若断即是解脱为异。答如是若解脱者即是断。问颇断非解脱不。答有。或断已故缚。见道及思惟。苦智已生习智未生。见苦所断烦恼断。而见习所断烦恼缚。如是思惟所断一切种。更互相缘故。问见四真谛云何得不坏净。答

  二解于三谛　　四由见正道
  兴起清净信　　修习于二世

二解于三谛者。观苦习灭得于法不坏净。苦智习灭相应信。是名不坏净得是及圣戒。四由见正道兴起清净信者。见道时具得四。问几世修。答修习于二世。诸法修于二世。现在修行未来者得修。问心共行法云何。答

  一切心数法　　说是心共行
  此相及余法　　作亦应当知

一切心数法说是心共行者。一切心数法说心共行心近故。此相者。此心有四相生住老无常。亦心近故。及余法者。余心数法相亦心共行。作亦应当知者。无教戒如前说。问断法云何。答断诸有漏法。一切有漏法断杂恶故。问知法云何。答知及诸无垢有漏及无漏。是一切知法一切智境界故。问远法云何。答过去未来是说远不办事故。问近法云何。答余说近。现在近办事故。无为近速得故。问定法云何。答

  无间无救业　　及诸无漏行
  慧者说是定

五无间业是定必至地狱故。无漏行亦是定必至解脱果故余不定。问见处云何。答见处必有漏一切有漏法见处五见处所故。问若成就根是成就几根。答

  说有十九根　　谓成就极多
  少成就极八　　晓了根所说

说有十九根。谓成就极多者。十九根成就极多如二形。及具根者未离欲见谛。少成就极八晓了根所说者。成就八根如不具身根断善根。及生无色中凡夫。问几种更乐。答五种

  增有对无明　　处中明更乐
  圣道俱有二　　能兴起成果

意识相应更乐是说增更乐。五识相应更乐是谓有对更乐。秽污更乐是说无明更乐。无漏更乐是说明更乐。有漏非秽污更乐。是说非明非无明更乐。问何等道德果为无碍道为解脱道。答圣道俱有二能兴起成果。二道共得果。一者解缚。二者得解脱。此二道成果。问无著住何心般涅槃。答无著心中得无为涅槃。无著一切事无所作无为无所求住。从报心中便般涅槃。问几有。答

  生有及死有　　根本亦复中

生有者。始生时阴是谓生有。死有者死时阴是谓死有。根本有者。除生有及死有。于其中间阴是谓根本有。中有者。有所至阴是谓中有。问说有厌有离欲。云何厌云何离欲。答

  诸智在苦因　　此忍修于厌
  灭欲得无欲　　说普在四中

诸智在苦因此忍修于厌者。若智及忍缘苦习。是说厌行厌处故。灭欲得无欲。说普在四中者。四谛中智及忍说离欲能断欲故

    论品第十

  威仪不威仪　　若离复获得
  不由此致胜　　能决定者答

答有从无色生色

  颇得圣果时　　一切离诸恶
  有为净善法　　得已而不修

答有退时得过去

  道者兴起时　　未远离诸恶
  解脱时离恶　　愿答已必定

答有谓当来愿

  颇光曜烦恼　　兴起于定时
  清净初禅中　　获得堕衰退

答有无著果修及勋修

  颇见谛道中　　逮得诸善法
  是法亦有缘　　圣者不见缘

答有欲界中修行等智

  颇慧有漏果　　远离净功德
  不离从于意　　此亦是彼果

答有欲界变化心

  颇住无碍道　　成就于诸灭
  诸烦恼从彼　　非如无漏见

答有修学诸道时

  颇结不解脱　　无垢者获得
  而不断烦恼　　谓此无垢尽

答有从光曜中生梵天时

  颇无漏净地　　未曾得已得
  不离欲非退　　不依于见道

答有离色欲取证时。得无漏无色思惟道

  颇未得诸法　　而逮得此法
  不舍彼不得　　若能知者答

答有余初无漏心品。得余无漏功德。舍凡夫事余者一切不得

阿毗昙心论卷第四


阿毗昙心论经

    No. 1551 [cf. Nos. 1550, 1552]

    阿毗昙心论经序

今欲解释阿毗昙心利益弟子故。问曰。不须解释。所以者何。古昔论师已释阿毗昙心。利益弟子故不须释。答曰。不然应须解释。所以者何。古昔论师虽释阿毗昙心太广太略。彼未学者迷惑烦劳无由能取。我今离于广略。但光显修多罗自性。是故须释。问曰。何故释阿毗昙心利益弟子耶。答曰。彼中已说不颠倒法相。释不颠倒法相令彼觉悟真实。是故离诸过恶生诸功德。得勇猛第一义利。问曰。若如是者。随意解释。答曰。我当解释。但诸师造论以吉为初。一切吉中三宝最胜。是故本师为显三宝少分功德故。于论初先说此偈

阿毗昙心论经卷第一

        法胜论大德优波扇多释

        高齐天竺三藏那连提耶舍译(六卷成部)

    界品第一

  前顶礼最胜　　离热饶益言
  彼言说相应　　罗汉见实等

前者先也。顶礼者净信曲躬礼也。最胜者。世尊为应供者之所供养。又于一切法中胜故名最胜。复次世尊。于一切法于一切种而得自在故名最胜。离热者。离烧义也。谓烦恼热能烧身心。世尊离彼故名离热。此是自己智断成就。彼师如是说者。彰于如来自利满足。次说饶益言者。世尊言说。能饶益一切众生。饶益者谓安隐也。安隐饶益一义异名。此彰世尊利他满足。此略说天人师自利利他功德满足。彼二种世尊等作究竟。是故应供中胜。彼言说相应者。谓道理义显示相应如是功德。相应天人师语。礼敬此者名礼法宝。罗汉见实等者。应受天人阿修罗等供养故名阿罗汉。此说无学。实者谓四圣谛。以学见者彼名见实。此唯说学。此学无学等。谓第一义僧。礼敬此者名礼僧宝。问曰。何故礼敬。答曰

  佛开觉慧眼　　若知诸法众
  亦为他显现　　我今说少分

佛者。知一切法。知一切种。故名为佛。开觉慧眼者。谓无碍智眼义也。若者。若佛所说所显所宣所释法也。知者解也。法者持也。持于自性。为他作缘故名为法。法有积聚。故名法众。法众群聚一义异名。亦为他显现者。自觉知己利世间。故为他显示。或有觉知不为他说。如升摄波林经说。我今说少分者。于彼佛说法中。我今但说少分法相。岂能尽说如是义已。问曰。何法是佛所说而欲说耶。答曰。所谓有漏无漏。有烦恼无烦恼。受荫有诤无诤。色无色等我今当说

  一切有漏行　　离我乐常净
  此受于我等　　不见有漏故

一切有漏行离我乐常净者。诸有漏行。离我离乐离常离净。彼中世间不能观察。无明覆障闇智。于此四门颠倒而见。故名颠倒。问曰。何因故知诸有漏行离于我耶。答曰。我事无故属因缘故行名为他。非我自性。计我者说。我不属他除此更无。是故我性不可得。无我因故诸行离我。问曰。何因故知诸行离乐。答曰。作逼迫故。诸有漏行是苦自性亦是苦缘是故逼迫。逼迫名苦是故离乐。问曰。何因故知诸行离常。答曰。以生灭故。现见诸行生而即灭。无见常者是故离常。问曰。何因故知诸有漏行离于净耶。答曰。污染事故。诸有漏事烦恼境界。不净污染是故离净。问曰。如是诸行离于我等。世间何故取我等耶。答曰。此受于我等不见有漏故。诸有漏行不如实见。世间不能观察作我等解。犹如怨家匿藏恶欲。诈出美言游行家内实非亲友作亲友解。我我所覆故不见无我。是故现见行等作业以迷惑。故无我事中而见于我。对治覆苦事故于行住等想谓为乐。故于苦受阴中而作乐解。相似相续覆无常事。彼现见色相似相续。记忆宿事诵持经论。故于无常行中而作常解。皮色覆于不净事。故彼于发毛爪齿处等少时见净。于不净中而作净解。虽见屎尿。虽复不净。犹生迷惑。此虽不净余者应净。犹如野干看紧叔迦华。问曰。何故论初先说颠倒。答曰。为知不颠倒法相故我先已说。欲令弟子解真实故。以不颠倒心安隐易解。是故论初先说颠倒。问曰。为当但有此离我等诸有漏法。更有余耶。答曰。更有

  若处生烦恼　　是圣说有漏
  以彼漏名故　　慧者说烦恼

若处生烦恼是圣说有漏者。若依若聚若缘。若众生数非众生数。生身见等烦恼是法说有漏。问曰何故。答曰。以彼漏名故慧者说烦恼。观察烦恼为作漏名。故以彼法生于烦恼。依漏起故名为有漏。如有怖道有毒食等。应如是说。若事属漏。为漏所摄。彼名有漏。此说无漏缘生烦恼。非无漏法属于烦恼为烦恼摄。无漏法但缘生烦恼。问曰。漏义云何。答曰。从有顶下至无间狱。于其中间六入疮漏。是故名漏犹如疮漏。又留住生死故名为漏。问曰。此更有名耶。答曰。更有

  亦名有烦恼　　取荫及有诤
  烦取诤生故　　知彼自性说

亦名有烦恼取荫及有诤者。是有漏法。亦名有烦恼。亦名取荫亦名有诤。问曰。何故彼诸名说。答曰。烦取诤生故知彼自性说。诸烦恼取诤等漏之异名。从烦恼生彼亦生烦恼故名有烦恼。如是从取生彼亦生取故名有取。从诤生彼亦生诤故名有诤。问曰。是荫世尊所说为取荫。即是荫为离取荫别有荫耶。答曰。若取荫者彼即是荫。或有荫而非取荫。问曰。何者是耶。答曰

  若行离烦恼　　此是无漏荫
  及前有取荫　　是荫圣所说

若行离烦恼此是无漏荫者。此荫更有余说。有二种荫。无漏有漏。若行离身见等烦恼。是名无漏。是荫非取荫。及前有取荫。是荫圣所说者。若此无漏荫及前所说取荫合说为荫。谓色等五荫。问曰。荫义云何。答曰。聚义是荫义。问曰。若如是者荫但假名无有实事。非但一物得有聚名和合故名聚。答曰。非但有相亦有实事。有此事者便有彼相故荫有相。如佛所说碍相是色荫等。是故有事界等所摄智识使等境界。如四圣谛故荫有事非但假名。问曰。荫界入等有何差别。答曰

  十种谓色入　　亦名无教色
  是分别色荫　　世尊之所说

色有二种。一者微尘积聚色。二者非微尘积聚色。微尘积聚色者。谓十色入眼乃至触。非微尘积聚色者。名无教色法入所摄。彼业品当说。此等一切是色荫相入色荫数佛说为色荫以此触彼。以彼触此是故名色。以此恼彼以彼恼此义也。如佛所说。如手等触。触故名色。问曰。若如是者。除无教色彼非是色何以故。非手等可触以无对故。汝意若谓。以所依者是可触故。彼亦是可触故无过者。受等亦应是色。汝意若谓。彼所依四大是可触故。彼亦是可触者。我当说言。现见所须作功业事。作画作泥。若如是者受等心数亦应是色。故汝有过。彼等亦依眼等诸根。彼亦应是可触。答曰。非但生心心数因。非心心数依眼等根。如光依珠。彼生时眼等作因。如是眼等是触彼非触也。复次造色依大如光依珠。是故大是触故彼亦是触。问曰。虽如是说汝相犹自不成。何以故。除过去未来微尘色故。答曰。相不可坏过去色触已灭。未来色亦如是相生。如是微尘亦是可触。以微细故不可得知。是故一切诸色皆是可触

  所名为识荫　　是说为意入
  于十八界中　　亦说为七界

识荫者。谓六识身。是十二入中说为意入。于十八界中。分别为七心界。眼识界耳识界鼻识界舌识界身识界意识界意界等。识者能知于缘故名为识。识者。能取缘义也

  余则有三荫　　无教三无为
  是说为法入　　彼亦是法界

如前所说受等诸法总为一法入。十八界中为一法界。彼入义者门义是入义如窗牖。如佛所说。婆罗门眼为门乃至见色。入字义者是输义也。能增长心心数法。以是义故名之为入。界义者性义是界义。如朱砂界雄黄界等。界字义者能持自相与他作缘是故名界。是界事有十七。或复十二何以故。除六识界更无意界。是故十七即六识身。展转相续名为意界。如父子名子展转相续次第名父。如是除意界外无别六识界。是故十二依及依者。缘差别故。故有十八。彼界入事等摄一切法。故彼荫一向但是有为。问曰。荫中何故不摄无为。答曰。无荫相故。二种荫相共相别相。共相者。聚义是荫义及无常等。别相者色碍等。是二种相无为中无。是故不摄无为。余更有何义。谓非颠倒事及断方便。无为非颠倒事及断颠倒方便。颠倒事故说取荫。为断颠倒方便故说无漏荫。是故荫中不摄无为。如是说荫界入境界最广。故建立于界欲说种种义。故如是说

  界中一可见　　十界说有对
  八界是无记　　余则善不善

界中一可见者。十八界中当知一界可见。所谓色界。何以故。是眼识境界故是故可见。复次可示此示彼是故可见。余十七种定不可见。十界说有对者。十八界中五内界。谓眼耳鼻舌身。五外界谓色声香味触。是等十界说有对。三种有对。所谓障碍有对。境界有对。缘有对障碍有对者。如手左右手相对。境界有对者。谓根与境界相对。缘有对者。意识于一切法。此中唯取障碍有对。更相障碍故名有对。彼一切十种界更互相对。若不尔者。彼不增长。如上座鸠摩罗多说若心欲起时为他所障碍。当知是有对。相违是无对。余八界定无对八界是无记者。十八界中当知八界是无记。所谓眼耳鼻舌身香味触。彼无爱不爱果可记。是故无记。余则善不善者。余十界说无记善不善。谓色声界身口意作。是善不善。何以故。从善不善心起故。余者是无记。眼识等七心界。是善不善无记。心相应法界。是善不善无记。心数法界。是自性相应善不善无记。彼自性善者。谓惭愧不贪等三善根。相应善者。与彼受等心数相应。自性不善者。谓无惭无愧贪等三不善根。相应不善者。与彼受等心数相应。与二相违是无记。不相应法界杂品当说。无为中一善二无记。数缘是善。虚空非数灭是无记。于中善摄爱果安隐故名为善。善摄者谓道谛苦集谛少分。爱果者谓苦集谛少分。安隐者谓灭谛。相违名不善彼苦集谛少分。除此名无记。无善不善可记故名无记。无果可记亦名无记

  十五定有漏　　余二三三有
  欲有中有四　　十一在二有

十五定有漏者。五内界五外界五识界。此十五界一向有漏。余二者。余有三界。意界法界意识界等。彼有二种。有漏无漏。有漏者生漏共漏相应满足迹处故名有漏。与此相违是名无漏。略说未知欲知根等。诸无漏根俱生法及彼得。出世间解脱得。及无为是无漏。余是有漏。三三有者。即此三界于三有中可得。欲有中有四者。香味鼻识舌识界等一向欲界摄。彼非色界离抟食爱故。十一在二有者。五内界色声触界。及缘彼三识界。此等十一在欲色界。非无色界无色故。彼为欲界使所系是欲界系。为色界使所系是色界系。为无色界使所系是无色界系

  有觉有观五　　三种三余无
  有缘当知七　　亦法界少分

有觉有观五者。五识界一向有觉有观与觉观相应义故。三种三者。意界法界意识界。彼有三种。欲界初禅有觉有观。中间禅无觉有观。第二禅上乃至有顶无觉无观。法界有觉有观者。欲界及梵世除觉观心数。法界无觉有观者。中间禅除观心数。法界无觉无观者。第二禅上乃至有顶心数法界。中间禅观一切无教等。不相应法界欲界梵世观此三中不摄。若欲说者应言无观有觉。余无者。余十界无觉无观彼与觉观不相应故。有缘当知七亦法界少分者。七心界及心数法界是有缘。有此缘故名为有缘。彼有境界可取故说有缘。复有余缘名如手缘杖。此等世俗言说。当知余定无缘

  九不受余二　　有为无为一
  一向是有为　　当知十七界

九不受者。九界决定不受受名。若色在根数及不离根。若割截残坏心心数法。于中受在中住故异则不受。彼七心界声界法界。此等九界名为不受。彼非心心数法止住处故。余二者。余九界二种五内界若在现在名受。或此现在识虽空亦名有受。以彼种类众生数摄故说为受。如是过去未来及非众生数名为不受。色香味触与根不相离。在现在者名受。如根中心心数法。止住彼中亦尔余名不受。略说若法生而未灭。众生数有对可牵可推彼名为受。彼生而未灭者除过去。未来众生数者除现在。非众生数有对者除生未灭。心心数法可牵可推者除声界。有为无为一者。因缘和合作故名为。此能生义也。作者何有因义也。有因义者有为义也。有为故名作。一法界合有为无为。此中三种常故无为。虚空数灭非数灭。受等三荫及无作色名有为。一向是有为当知十七界者。余十七界有因故一向是有为。问曰。如是分别法相竟。云何摄法为自性为他性。答曰

  诸法离他性　　各自住己性
  是故一切法　　自性之所摄

诸法离他性者。谓眼离耳。如是一切事若性离性。相摄者是说不相应。是故非他性摄。彼有何过。若一生灭余一切亦生灭。此非道理是故他性不摄。各自住己性者。眼自住眼性如是一切法。是故一切法自性之所摄者。是故自性摄一切法。此师所说自相摄义也。此亦二种生及分齐。生者。色阴摄十色入乃至法入中色。眼界摄眼界。分齐者。此一念摄一念不摄余念。若余摄名者。如台观摄基陛梁椽等是世俗言说。彼眼界一界一入一阴所摄。当知一切法亦如是

    行品第二

已说诸法相生差别今当说。问曰。若一切法自性摄者。亦应自力能生耶。答曰

  初无一能生　　以离伴侣故
  一切彼此力　　诸法乃得生

初无一能生以离伴侣故者。有为诸行自性羸劣。是故无法自力能生。问曰。云何得生。答曰。一切彼此力诸法乃得生。有为诸法彼此力生。如二羸人彼此力起。此一切行略说四种。所谓色心心数法心不相应行。彼生亦有四种作取作依作增上作伴。彼作取者。依果报果及丈夫果少分。作依者。诸界六入造色四大。作增上者。一刹那生事一切诸法。作伴者。心心数法彼此为伴及诸有为相。如是等有为我当先说。共心俱生作伴

  若有心生处　　必与心共生
  诸心法等聚　　及不相应行

心者。心意识义一异名。是心善等分别。界分别。种分别。依分别无漏等分别。无量种差别。是心若依若缘若刹那生。决定共心心数法及心不相应行生。问曰心心数法云何。答曰

  想欲及触慧　　念思与解脱
  作意于境界　　三摩提受等

想者。于缘能取相貌。谓取男女粗细木杌长短等相。欲者爱乐如见己乐等。触者。依缘心和合如日光珠异和合生火。慧者。能知于缘如此是色非味非是等。念者。系念于缘。思者。善不善俱相违心转。解脱者。于缘中心转不障碍故。作意者。取缘勇健。有人言心专注义也。三摩提者。取缘时心不乱也。受者。于乐不乐俱相违缘中受也

  一切心生时　　是生圣所说
  同于一缘转　　亦复常相应

一切心生时是生圣所说者。是想等十法共一切心俱生故名大地。是大心地故名大地。同于一缘转者。此十法共一切心。俱一缘中转不别缘也。有五种同。所谓相貌缘时依事。同一相貌一缘一时一依一事。同者共相应义。亦复常相应者。此常与心相应彼此俱生。相应取缘故名相应。已说一切心中相应法。非一切心中相应法今当说

  诸根有惭愧　　信猗不放逸
  不害精进舍　　或热及觉观

诸根者。不贪不嗔二善根也。不痴善根体即是慧。大地共故此中不说。不贪者于有无有不着。不嗔者于众生数不恚。惭者尊重己身于恶羞耻。愧者尊重世间法。信者不颠倒因果。信猗者善心离恶身中怡泰。不放逸者。调柔方便于可作不可作。舍作方便一向心此是修善义。不害者于众生数不恼心。精进者舍离过恶修习功德。守护增长策励心。舍者心平等一切善心俱顺道理。此十法一切善心中可得故名善大地。或热者我见等烦恼使品当说。心粗名觉是捷利义。心细名观是微少义。此法非一切心中可得。或有可得或不可得。次后若聚乃至心数生我今当说。此心心数法善等分别有五种聚。所谓不善不共善。隐没无记。不隐没无记。欲界成就五种。色无色界成就四种除不善

  不善心聚中　　心数二十一
  三见中灭一　　欲二见少三

不善心聚中心数二十一者。不善心者若心与无惭无愧相应。此心聚中有二十一心数。谓十大地及觉观。二烦恼贪嗔慢疑。及彼中一无明贪乃至疑等。彼此不相应无明。与彼相应与一切烦恼相应故。七种起烦恼。谓无惭无愧睡掉不信放逸解怠。问曰。一切不善心中悉有二十一耶。答曰不尔。三见中灭一欲二见少三。不善心聚中邪见见取戒取心相应有二十法。此中除慧。欲二见少三者。欲界身边二见相应有十八法。除慧前已说。除无惭无愧见是慧性故。见相应聚中无慧。非一聚中有二慧事。身边二见是无记。无惭无愧一向不善是故少三

  善心二十二　　不共有二十
  无记有十二　　悔眠俱被增

善心二十二者。十大地十善大地及觉观。不共有二十者不善心聚二十一中除一烦恼。不共者唯一无明非余使。无记有十二者不隐没无记聚中有十二心数。谓十大地及觉观。彼中无信等功德无贪等过恶。何以故无记故。不隐没者非是秽污。悔眠俱被增者。追变名悔。是悔三种。善不善无记。于中善不善行作名善不善。彼四种差别。或有善建立不善。如作施等已悔。或有不善建立善。如作恶已悔。或有不善建立不善。如作恶已悔少。或有善建立善。如作施等善已悔少。若余威仪等悔。彼是无记。是故与悔相应聚中增悔。余心数如前说。于中悔人非贪等使转。非无痴人生悔。是故不善悔相应聚中。但一无明是烦恼非余。是故有二十一种。善悔相应聚中但增于悔。如是二十三种。不隐没无记者。十三种此于三聚中转。谓不共善不隐没无记。眠者寐也。此于一切五聚中转。何以故。眠者有不善秽污无记心。是故彼中增一眠。余心数如前说。如是三聚二种悔眠俱转彼中增二。此是欲界心法次第。问曰。色无色界云何。答曰

  初禅离不善　　当知如欲界
  中间禅除觉　　于上观亦然

初禅离不善当知如欲界者。初禅离不善聚离无惭无愧故。余有四聚如欲界说。中间禅除觉者。中间禅除觉。余如初禅说。于上观亦然者。二禅以上乃至有顶。除觉观。余如初禅说。已说心心数法由伴力生。色法今当说

  微尘在四根　　十种应当知
  身根九外八　　谓在有香地

微尘在四根十种应当知者。谓眼根微尘有十种。当知十种不相离义也。谓地水火风色香味触眼根身根。此等十种常不相离。耳鼻舌亦如是。身根九者。除眼根等。余悉同前。外八者。非根法中八种微尘。谓四大色等四尘。问曰。何界微尘如是说耶。答曰。谓在有香地。此是欲界中义彼有香故。色界微尘离于香味。是故彼中除于香味。余如前说。问曰。前说若心起时。彼心数法及不相应行生。已说心心数法。不相应行云何。答曰

  一切有为行　　生住及异坏
  是亦有四相　　彼此更相为

一切有为行生住及异坏者。一切有为行有四种相。生住异坏未生生故名生生。已自事立故名住住。已衰变故名异异。已势灭故名坏。如是说。若有为法得如是相者。名心不相应行。我今当说有为相。此事可知故名相。彼生住老无常。生者有为事生。住者安立。老者衰变。无常者坏也。彼非一时作生者以生为业。余者生竟作业。是故有为生住异坏非是一相。问曰。若一切有为法有四相者。此亦是有为此更有余相耶。答曰。是亦有四相。是亦有四种相。共彼生谓生生住住异异坏坏。问曰。若如是者便为无穷。答曰。彼此更相为。此相彼此相为生。生生生生。生生生如是。住住住彼此相住。异异异彼此相异。坏坏坏彼此相坏。故非无穷。此后四为一法生生。生生事非余法。如是住住。住住事非余法。余亦如是。前四种相各为八法生生八法。谓前三相后四起相。及彼所相法。当知余亦如是。已说诸行共生随伴故生。无伴不生今当说

  所作共相似　　普遍相应根
  从此六种因　　转生有为法

此六种因转生有为法。所作因者。若法于余法生中不作障碍。以此力故彼法得生。如眼生时一切法除自性。如是耳等除自性。非自性与自性作因。共因者。诸行与伴共生如心心数法。心不相应行有为相。如是四大微尘随心戒等。相似因者。若义能生相似法。如习善生善。习不善生不善。如习工巧能知工巧。如种麦生麦。如是等。一切遍因者。若诸烦恼必相续生。如执着我见者以见力故。于我执着断常。谤于阴相疑或取清净。及最胜慢等过生。余亦如是。一切遍应当知。相应因者。心心数法彼此力。俱一时一缘中转。问曰。若心心数法一时彼共生因与相应因何差别。答曰。不相离义是相应因。同一果义是共生因。如执杖杖业。如渡河牵手不断等。报因者。谓世间生中受生。相续事果名生。如善爱果不善不爱果。已说诸因法。若法从因生今当说

  报生心心法　　及余杂烦恼
  悉从五因生　　共生应当知

若报生心心数法。及秽污心心数法等从五因生。报生心心数法五因者。谓所作因共生因相似因相应因报因。所作因者。彼法生时相似不相似事不作障碍。共生因者。彼此伴生彼生等。心不相应行伴力生。相似因者。前生无记法。或作是解。是报因生非威仪等何以故。彼胜故非胜与劣作因。相应因者。彼此力一时一缘中转。报因者。彼或善不善业。此则彼果秽污。心心数法无报因。何以故。隐没非无记果报性故。遍因第五由彼力故此得生。余四因如前说

  是彼不相应　　及余相应法
  除最初无漏　　彼从四因生

是彼不相应者。若报生色及报生心。不相应行从四因生。谓所作因共生因相似因报因。秽污色及秽污心。不相应行亦从四因生。谓所作因共生因相似因遍因。及余相应法除最初无漏。从四因生者。余心心数法除最初无漏。亦从四因生。谓所作因共生因相似因相应因。余者谓不隐没无记除报

  若余不相应　　相似当知三
  及诸余相应　　最初无漏法

若余不相应相似当知三者。前所说心不相应及余彼余名余。彼谓善不隐没无记除报。若彼相似因成就。除初无漏从三因生。谓所作因共生因相似因。及诸余相应最初无漏法者。彼初生无漏相应亦从三因生。谓所作因共生因相应因。彼无相似前生无漏故无相似因

  彼中不相应　　是从二因生
  若从一因生　　必定无此事

彼中不相应是从二因生者。彼初生无漏聚中色。及心不相应行。从二因生。谓所作因共生因。已说一切有为法。若从一因生必定无此事者。一切法必定从所作因共生因生。余因不定。是故无法从一因生。已说因差别。世尊以如是因为化众生故说缘。我今当说

  次第亦缘缘　　增上及与因
  法从四缘生　　世尊之所说

如是四缘生一切有为法。彼次第缘者。心一一生次第相续作容受方便。缘缘者。心心数法境界攀挽方便缘彼故能生。增上缘者。法生时不作障碍。如王自在即是前说所作因。因缘者。除所作因其余五因彼是因缘。问曰。因之与缘有何差别。答曰。或有说者。无有差别。我说因者如种子法。缘者彼持方便如地粪等。已分别缘。若法随缘生今当说

  心及诸心法　　是从四缘生
  二正受从三　　余法说于二

心及诸心法是从四缘生者。心心数法从四缘生。前容受此法是次第缘。境界是缘缘。除自性余一切法是增上缘。共生因自分因相应因是因缘。或时有遍因报因。二正受从三者。无想正受灭尽正受从三缘生。彼二入定心是次第缘。彼前生正受念及正受心。界地善自分名相似因。共生生住异坏名共生因。如此二因是彼因缘增上缘如前说。余法说于二者。余心不相应行。及色从二缘生。谓因缘增上缘。问曰。此法何故名行。答曰

  多法生一法　　是亦能生多
  缘行所作故　　名行应当知

多法生一法是亦能生多者。一法以多法力故生。是亦能生多法。如是一切彼此力。缘行所作故名行应当知者。此亦是缘亦是行故名缘行。缘行所作故名缘行。所作此亦能作缘行是故名行。如是说者。此行为他所作。亦能作他。是故名行

阿毗昙心论经卷第一

非次第是转生自地。于自地者。一切诸烦恼于自地。烦恼次第缘可得。一一次第生。一切上地亦生下。此事当分别者。梵天上命终次第生欲界一切。若彼中秽污心命终。此中一向秽污心相续。如是一切地

已说诸使自相。如此烦恼世尊教化故多种说。今当分别。问世尊说七使。欲爱恚有爱慢见疑及无明。此云何。答

  欲界五种欲　　此说欲爱使
  色无色如上　　有爱当分别

欲界五种欲此说欲爱使者。见苦习灭道思惟断。色无色如上有爱当分别者。色界爱五种。无色界亦尔

  恚即是恚使　　五种如前说
  憍慢及无明　　十五在三界

恚即是恚使五种如前说者。嗔恚亦如是五种。憍慢及无明十五在三界者。慢欲界五种。色界五种。无色界五种。无明亦尔

  见使三十六　　说普在三界
  疑使有十二　　此七有异名

见使三十六说普在三界者。欲界十二见。五见苦断。二见习断。二见灭断。三见道断。色无色界亦尔。疑使有十二者。欲界有四。见苦习灭道断。色无色界亦尔。此七有异名者。此烦恼说扼受流漏。问以何等故。答

  扼缚及受流　　漏一切无穷
  诸扼及受流　　烦恼是说漏

系一切众生故说扼。受生具故说受流。下一切众生故说流漏。一切无穷故说漏。已说种种相。相应根今当说阿毗昙心论经卷第二

        法胜论大德优波扇多释

        高齐天竺三藏那连提耶舍译(六卷成部)

    业品第三　别译

已说诸行因缘力生。次观察世间生灭差别。由于烦恼业因故生。当思彼业师欲广说于业。是故说此

  业庄饰世间　　趣趣各各异
  是以当思业　　求离世解脱

业庄饰世间趣趣各各异者。如是一切世间五趣。种种身生业能庄饰。当思彼业为世间因生种种身。如世尊说众生差别。由业所作谓高下优劣。是以当思业求离世解脱。彼业自性种地成就善不善差别。为知彼故当勤思惟。问曰。何者彼业。云何思惟。为世间因生种种身。答曰

  身口意集业　　在于有有中
  从彼生诸行　　及受种种身

身口意集业在于有有中者。有三种业。谓身口意业。彼身所作或业依身名为身业。若口所作名为口业。意相应名为意业。众生世世造作身口意业。从彼生诸行及受种种身者。彼业生于诸行及外众具宅舍色力。罪福命等及受众生种种身。此行有二种。谓众生数非众生数共不共。不共者。各各众生业增上生。共者。一切众生业增上生。如是地狱等五趣净不净。种种业身受苦乐种种差别。以彼众生种种。是故求解脱者必定应知是业

  身业应当知　　有教及无教
  口业亦如是　　意业唯无教

身业应当知有教及无教者。身业二种。谓有教数及无教数。彼有教数者身动。无教者。身动灭已。与余识相应。彼相续转如受戒竟。虽不善无记心善戒随生。如捕鸟等虽善无记心恶戒随生。口业亦如是者。口业亦有二种。谓有教性无教性。意业唯无教者。意业唯无教。性非如色教。此业不可示他故名无教。有言辞故名教。此五业中

  有教当知三　　善不善无记
  意业亦如是　　余不说无记

有教当知三善不善无记者。身教口教当知三种善不善无记。善者谓行施受戒等。善心起动身。不善者谓杀生等不善心起动身。无记者有二种。谓隐没不隐没。隐没者谓秽污无记心起动身。不隐没者非秽污无记心起动身。所谓威仪工巧。口教亦如是应当知。意业亦如是者。意业亦有三种。彼善心相应必善。不善心相应名不善。秽污无记心相应必隐没无记。非秽污无记心相应。名不隐没无记。余不说无记者。余有二业。谓身口无教。彼有二种。谓善不善。无记。何以故羸劣故。以无记心羸劣故不能起强业。若与余识俱与彼事相续。如执须摩那华。虽复舍之犹见香随。何以故。香势续生故。非如执木石等。已说彼诸业

  色无记二种　　隐没不隐没
  隐没系在色　　余在于二界

色无记二种隐没不隐没者。若色性业教无记名前已说。此有二种。当知隐没不隐没。隐没系在色者。若隐没者。系在色界梵世非上地。何以故。彼无记作心故。非在上地下地烦恼起现在前。何以故。以离欲故。亦不在欲界。修道断烦恼能起身口业。何以故。外门转故。见道断烦恼内门行故。不能起身口业。欲界修道断烦恼但是不善。非不善烦恼能起无记业。余在于二界者。若不隐没无记系在欲色二界。意业如心说。何以故。彼隐没不隐没通三界。故于中

  若教无教戒　　略说有三种
  无漏及禅生　　依顺解脱戒

若教无教戒略说有三种者。无教戒略说当知有三种。问曰云何。答曰。无漏及禅生依顺解脱戒。无漏戒者与道俱生。谓正语正业正命。禅生戒者与禅俱生。谓离欲不离欲凡夫及圣人。依顺解脱戒者。谓众聚和合。于彼士夫边。启请受得。此三种戒摄一切戒。问曰。如是分别有教无教戒竟。何者与心俱生。何者不与心俱生。答曰

  无教在欲界　　教依于二有
  当知非心俱　　谓余心俱说

欲界无教若顺解脱戒所摄。及不摄。彼一切非心俱。不随心转义。问曰。何故不随心转。答曰。彼受戒已。不善无记心亦随生故。不与善不善无记心随转。何以故。无心亦随转故。教者欲色二界不随心转。何以故。属身故。余心亦有故。谓余心俱说者。余谓禅无漏戒。彼二种随心转。何以故。异心不随转故。以彼心力生二种。彼常随心作随顺义。故彼二种过去过去成就。未来未来成就。现在现在成就。已说业差别。若业成就今当说

  无漏戒律仪　　见实则成就
  禅生若得禅　　持戒生欲界

无漏戒律仪见实则成就者。谓从初苦法忍。及一切圣人成就无漏戒。是戒在于六地。未来中间根本四禅。此色地亦无漏。彼未离欲见谛成就未来地戒。若离欲一切有学极少成就三地。或有六地一切阿罗汉成就六地。禅生若得禅者。成就禅戒非余。是戒在九地。谓禅近地中间四禅。若人若得诸地若凡夫若圣人。是得成就彼地戒。持戒生欲界者。若受戒者彼成就顺解脱戒。是戒欲界人得非余趣受。已略说成就差别。随成就过去未来现在戒。今当说有三种人。谓住戒人。住非戒人。住非戒非非戒人。住戒人者亦有三种。以戒有三种故。彼者

  若住解脱戒　　彼无教现在
  当知恒成就　　或尽成过去

若住解脱戒彼无教现在当知恒成就者。若住顺解脱戒。彼人从初刹那受无教戒。现在一切时成就彼现在无教。常次第相续乃至命未尽。何以故。要期分齐故。或尽成过去者。或有住顺解脱戒。成就过去无教戒。谓已灭不舍。舍事有五因缘。后当说

  若有作于教　　成就于中世
  彼尽而不舍　　当知成过去

若有作于教成就于中世者。中世名现在。若人作身口教求受戒时。成就现在教戒。彼尽而不舍当知成过去者。尽者过去义。彼教尽时若不舍者成就过去教戒。此舍因缘如前说。略说如是初念教时。成就现在教及无教。彼后乃至教未尽未来。成就过去现在教及无教。此教尽已若不舍者。成就过去现在无教。彼但成就于过去教。非现在教

  若得禅无教　　成就灭未来
  中若入正受　　教亦如前说

若得禅无教成就灭未来者。若得禅者成就过去未来禅戒。如成就禅彼人无教。虽决定灭由彼禅力故初如是彼得过去。如禅第二念等三世成就乃至未起禅。若起不舍成就过去未来无漏戒。与禅同故此中不说。既说禅戒亦说彼已。何以故。若有见谛教者彼人决定得于禅戒。故说禅戒即是说彼

  若作不善业　　住戒成就二
  共烦恼缠俱　　当知彼尽尽

若作不善业住戒成就二者。若人住顺解脱戒若住禅戒。彼不见谛作于不善。增上缠时不善无教便起。彼人尔时成就不善教及无教。问曰。何者住禅戒作不善耶。答曰。若未离欲依未来禅得作不善。问曰。几时成就无教耶。答曰共烦恼缠俱。是人乃至未舍于不善缠。当知彼尽尽。若舍彼缠彼教无教亦舍

  若住非戒处　　无教成就中
  当知不爱果　　或复尽过去

若住非戒处无教成就中当知不爱果者。住非戒者所谓屠羊杀鸡杀猪捕鱼捕鸟等。是人于一切时成就现在不善无教。是人初发作业刹那时。即于一切众生所成就不善戒摄无教。若人初杀生时即得杀生所摄无教。于后随所杀生。更得杀生所摄无教。非律仪摄戒。先已得故更不重得。或复尽过去者。第二念以去杀生。及非律仪摄无教。成就过去现在。乃至不舍刹那谢过去者名尽

  若刹那住教　　是说成就中
  亦复尽过去　　善于上相违

若刹那住教是说成就中者。随住教时成就现在教刹那现在名刹那住。亦复尽过去者。随教刹那谢于过去未断以来。是时成就过去现在。若尽而未舍但成就过去。善于上相违者。如住律仪说不善。如是住非律仪说善。极净信心作施等善。彼时善无教起彼舍此亦舍

  若处中所作　　是说成就中
  亦复尽过去　　或二亦复一

若处中所作是说成就中者。处中谓非律仪非不律仪。彼若作善成就现在善教。若作不善成就现在不善教。亦复尽过去者。是教若灭未断亦成就过去现在。若尽已不舍但成就过去。或二者。或教无教过去现在。若极欲作必定方便不舍。亦复一者。方便尽已但成就现在无教。有人乃至命未尽来。成就现在无教不欲止故。问曰。已说教顺解脱戒。禅无漏戒云何得耶。答曰

  色界中善心　　得禅律仪戒
  是舍彼亦舍　　无漏有六心

色界中善心得禅律仪戒者。若有人得色界善心。或时离欲或不离欲。彼一切得禅律仪戒。一切色界善心戒。常随顺唯除六心。所谓眼耳身识及闻慧。心临命终心起作业心。问曰。此云何舍。答曰。是舍彼亦舍。若舍色界善心亦舍于彼。无漏有六心者。彼无漏戒六心共得。所谓未来中间根本四禅。彼舍此亦舍。问曰。如是诸戒彼何者戒。几时舍耶。答曰

  顺解脱调伏　　是舍于五时
  禅生无漏戒　　二时智所说

顺解脱调伏是舍于五时者。谓舍自分种类时。舍戒时。断善根时。二根生时。正法隐没时舍。或有人说。犯戒根本梵行时舍。罽宾者说。有四时舍。除后二种。禅生无漏戒二时智所说者。禅戒二时舍退及度界地。无漏戒亦二时舍退及得果。彼根次第得果相似故不别说。有人别之彼三时舍。问曰。非律仪云何舍。答曰

  非律仪四时　　如是善无色
  秽污唯一时　　是说在于意

非律仪四时者。谓受戒时。得禅戒时。二根生时。舍自分种类时。彼戒非戒于三时舍。谓本势过。希望止。方便息。是说舍戒非戒应当观察。问曰。已说色自性业。无色自性业竟复云何。答曰。如是善无色善无色业亦四时舍。谓得果时退时。断善根时。度界地时。秽污唯一时是说在于意者。秽污意业于一时舍。谓离欲时。随处处离欲彼彼舍。已说业自性及成就。随彼业世尊无量门分别。今当说

  若业与苦果　　当知是恶行
  复有意恶行　　贪嗔及邪见

若业与苦果当知是恶行者。若业感不爱果当知是恶行。谓杀生等所有不善身口意业。及后眷属是谓恶行。隐没无记。无果报故不说恶行。复有意恶行贪嗔及邪见者。彼不善思是意恶行如前所说。复有贪嗔邪见业分。当知如业以果成因故。如女为梵行垢。如是等已说

  彼相违善行　　最胜之所说
  于中若增上　　圣说十业道

彼相违善行最胜之所说者。与恶行相违当知悉是善行。谓一切善业意业无贪无嗔正见。于中若增上圣说十业道者。彼善行恶行业中。若增上业胜者说名业道。彼恶行中增上者名不善业道。若善行中增上者是善业道。不善业道者。谓杀生等七种及贪嗔邪见等。善业道者。谓离杀等七种。及不贪不嗔正见。或行方便重非业道。或业道重。故如是说。杀生者。于彼他众生想。作欲杀意欲害命方便。彼业究竟是名杀生不与取者。于他物中作他物解。不与想欲劫夺意。取属于己是名不与取。邪行者。于所行处非道非处非时。于非所行处行是名邪行。妄语者。异想诳他想言说是名妄语。两舌者。秽污心欲破坏他语业是名两舌。粗恶语者。以嗔忿心。他不爱语说是名粗恶语。软见贪等被踬顿。不善语无益语非法语。是名绮语。贪者。爱他资产恶欲是名为贪。嗔者。增上恼他坏他心过恶是名为嗔。邪见者。谤无因果是名邪见。此为十不善业道。与此相违名善业道。余业不名业道。谓此业道后方便。及饮酒打拍等恶行。礼拜等善行离饮酒思。如是等是业非业道。问曰业道有何义。答曰。是业是道故名业。道又业之道故名业。道业道业道故名业道。七业亦业亦道是思之道故。三是业道此非业义。问曰。何故诸烦恼中。此贪等三说是业道非余。答曰。增上恶故自烦恼他故。此极过恶余不如是。彼对治不贪等白道。于此业道摄不摄业。略说二种。谓定不定。定有二种。报定时定。时定有三种。问曰云何。答曰

  谓现法果业　　次受于生果
  后果亦复然　　当知时各定

若业于此生作。即此生熟名现法受业。若业次生熟者名生受业。过次生后余生熟者名后受业。此等三种名时决定。报决定者。报决定熟非时决定。若得因缘便熟。余名不定。问曰。如世尊说乐受等三业。云何差别。答曰

  欲界中善业　　及色界三地
  是说为乐受　　此亦定不定

欲界中善业及色界三地是说为乐受者。欲界中善业能生与乐俱行报。色界初禅二禅三禅地中。亦生与乐俱行报。彼总说乐受。问曰。此业亦时定耶。答曰。此亦定不定。若定若不定。此四地中善业悉名乐受。此是乐受所摄果报。故名乐受

  生不苦不乐　　彼在于上善
  若受于苦报　　是说不善业

生不苦不乐彼在于上善者。若第四禅及无色界善业名不苦不乐受。彼业能生不苦不乐俱行报故。若受于苦报是说不善业者。谓不善业名为苦受。彼业能生苦受俱行报。故此业亦定不定。问曰。如世尊说。黑黑报等四业。云何分别。答曰

  若色中善业　　是白是白报
  黑白欲界中　　二黑说不净

若色界中善业是白是白报者。色界中善业是白。一向无恼故。彼报亦白。一向可爱故。黑白欲界中者。欲界善业杂于不善故名黑白。彼无一业黑白二报杂受。问曰。若报非黑云何名黑。答曰。以不爱故名之为黑。爱者名白。二黑说不净者。不善业名黑。不可爱故。彼黑还生黑报

  若思能破坏　　彼诸成就业
  无碍道相应　　是说第四业

若道能断彼三种业。谓无碍道摄十七学思。是第四业此不可呵故名不黑。无有染着故名不白。与流转相违故名无报。彼见道中法智分摄。相应四思及离欲界八无碍道相应八思。此十二思断黑黑报业。第九无碍道相应一思断黑白报业。初禅离欲乃至第四禅离欲第九无碍道摄。相应四思断白白报业。余非报业。无色善业此中不数。何以故。无二白事。谓鲜洁白可喜乐白。故不说白。此经中世尊说中有。问曰。如世尊说。身口意业曲过涩等何者是耶。答曰

  谄生谓为曲　　过从嗔恚生
  欲生谓为涩　　世尊之所说

谄生谓为曲者。方便谄他覆藏己事心曲名谄。此在欲界梵世非上地。彼在意地修道所断。若业从谄起以果成因。故世尊说。曲彼非曲性。过从嗔恚生者。从嗔生业以果成因。故世尊说过。欲生谓为涩者。若业从欲生。果中说因。故世尊说涩。问曰。如世尊说。三种清净三种寂静。彼相云何。答曰

  一切妙行净　　无学身口净
  所谓意净者　　即是无学心

一切妙行净者。所有身口意有漏无漏妙行一切说净。问曰。有漏妙行不净处所云何说净。答曰。与烦恼不净相违故。彼少分净能引道第一义净故。问曰。云何名净。答曰。无学身口净。无学身口妙行。名身口净。所谓意净者即是无学心。彼无学心名为意净。得牟尼相离烦恼语言。断三界辫发。揃依有顶烦恼髻。身有起作意不寂静。是故不说牟尼。牟尼者是寂静义。为断乐水洗净等教是故说净。为断牟尼教故说身口意牟尼。已说业和合差别。业果差别今当说

  善业不善业　　是俱说二果
  善或成三果　　余一果当知

善业不善业是俱说二果者。善业有二种果。彼有漏善有依果报果。依果者前生后生界地自分善。报果者无记。无漏断烦恼业有依果解脱果。依果者前生圣道后生圣道。一切相似增长不减。解脱果者。谓无碍道断诸烦恼。彼不善业亦有二果。依果报果。善或成三果者。若有漏善断烦恼者。彼有三果。依果报果解脱果。如世俗断结道。余一果当知者。谓无记业及余无漏不断结者。彼有一果。所谓依果。问曰。彼身口业造色自性四大所起。彼何者业何四大造。答曰

  自地若有大　　身口业所依
  无漏随力得　　是还依彼力

自地若有大身口业所依者。若欲界身口业。彼但欲界四大造。色界亦如是。无漏随力得是还依彼力者。无漏身口业随力所得。还依彼地。如是四大生。若欲界无漏道起。彼还依欲界。如是四大造无漏身口业应当知。如是色界还依彼地。如是四大造无漏业应当知。问曰。若生无色界。舍于学戒得无学戒。彼舍依何地戒。得依何地戒耶。答曰。随依彼地生随依彼地灭。依彼地过去戒。及依五地未来戒等皆悉舍之。更得依五地未来戒。五地者。谓欲界四禅。问曰。如世尊说三障。是相云何。答曰

  无间无救业　　广生诸烦恼
  恶道受恶报　　障碍应当知

有三种障。所谓业障烦恼障报障。障碍圣道及圣道方便故名为障。业障者五无间业。所谓杀母杀父杀阿罗汉破僧恶心出佛身血。作此业已必定次生无间地狱故名无间。杀母杀父弃背恩义故堕无间地狱。其余三种坏福田故。烦恼障者。谓勤烦恼及利烦恼。勤烦恼者数行烦恼。利烦恼者增上烦恼。现行烦恼名之为障非成就者。何以故。一切众生平等成就诸烦恼故。报障者随所住报。非圣道器报过恶故。问曰。彼何者是。答曰。一切恶道北郁单越无想众生。一向是凡夫地故。问曰。此三业中何者最为大恶。答曰

  妄语破坏僧　　当知极过恶
  有顶世中思　　善中最大乘

妄语破坏僧当知极过恶者。一切业中破僧妄语最为极恶。彼得阿鼻地狱经一劫住。十三聚火围绕其身。何以故。彼法非法想非法法想。亦破坏见法想破僧起异道故破坏法轮。是故此业一切业中最为极恶。有二种破僧。谓破法轮及破羯磨。破羯磨者同一界内别处布萨作羯磨等。问曰。何者善业得最大果。答曰。有顶世中思。善中最大果有顶正受思。一切善中得最大果。彼八万劫极寂灭故。果报因缘故有顶中思说为大果。余金刚喻相应思一切大果。彼一切结究竟尽果故

    使品第四

业及烦恼因缘流转已广说。业彼业烦恼力故。受种种生非离烦恼。是故师欲分别烦恼。作如是说

  一切有根本　　业侣生百苦
  九十八种使　　牟尼说当思

一切有者。谓欲有色有无色有。此等三有九十八使以为根本。何以故。此为业侣。能生种种受生等苦。彼业由于烦恼力故受生有。力非离烦恼。是故欲求解脱者应当知之。知已远离。何以故。如不识怨则为所害。经中佛说有七种使。彼界行种分别为九十八使。所谓贪使界分别为三种。分别为五界种。分别为十五。慢无明使亦复如是。嗔使界分别为一种。分别为五。疑使界分别为三种。分别为四界种。分别为十二。见使界分别为三种。分别为四。行分别为五。行种分别为十二。身边二见同见苦断故为一种。戒取见苦见道断故为二种。邪见见取为四种。如是为十二使。界行种分别为三十六使。是故有九十八使。问曰。云何知耶。答曰

  一切诸使品　　当知立二分
  谓见道断分　　及以修道断

见道所断乃至修道所断。唯有此等诸使更无有余。见者视也。彼为见所断故名见道断。此言为忍所害义也。修者是数习义。为修所断故名修道断。此说为得性道所断义也

  烦恼二十八　　当知障见苦
  彼当见苦时　　断尽无有余

彼见道修道所断九十八使中。二十八使障于见苦故。见苦断此后当说

  见集断十九　　当知灭亦然
  增三见道断　　十说修道灭

见集断十九者。十九使障于见集故见集断。当知灭亦然者。当知见灭亦断十九使也。增三见道断者。二十二使见道所断。十说修道灭者。当知十使修道所断。已说使种差别。彼界差别今当说

  最初烦恼种　　欲界当知十
  二中各有七　　八种见道断

最初烦恼种欲界当知十者。如前所说初见苦断烦恼种类。彼中十使系在欲界。所谓身见边见邪见见取戒取贪嗔慢疑无明。二中各有七者。如前所说见集灭断烦恼种类。彼中各有七使亦系欲界。当知于此十中除身见边见戒取为七。八种见道断者。此欲界系七中增于戒取

  欲界应当知　　四是修道断
  谓余上二界　　当知同可得

欲界应当知四是修道断者。谓贪嗔慢无明等如是彼三十六使。系在欲界应当知。谓余上二界者。余六十二使系在色无色界。当知同可得者。如是三十一使系在色界。三十一使系无色界。三十六中除五嗔使。已说使数种界差别。使自性今当说

  所谓有身见　　边见及邪见
  二取应当知　　此五见烦恼

此五烦恼皆是见性。身见者彼于五受荫中。执我我所是名身见。边见者于彼计着断常是名边见。邪见者诽谤四谛。审尔计着是名邪见。戒取者于自在等自性丈夫中间智等。彼非解脱苦因中妄执为因。取戒等此中除等名取戒故名戒取。见取者于有漏法执为最胜。取见等此亦除等名故名见取。此智慧性故说名见。此等五见摄一切见。此一邪见邪执着故。以行差别故说五种

  贪欲及疑嗔　　慢无明非见
  境界差别转　　说有种种名

贪欲及疑嗔慢无明非见者。贪者彼于有中爱想乐着是名为贪。疑者于谛实义计以为实。或谤实义彼中犹豫是名为疑。嗔者若他侵陵。不能容忍便生恶欲。于众生所极作逼迫破坏。非处生心恼彼是名为嗔。慢者于自地中称量心举是名为慢。无明者于谛相中不知不净是名无明。此五烦恼非慧性故。使不说见。如是一切烦恼境界差别转说有种种名者。此十烦恼随于境界。差别转故立种种名。此中若缘苦转说见苦断。如是见集断等亦尔

  不苦于一切　　离三见二转
  道除于二见　　上界不行嗔

下苦于一切者。欲界中苦是名下苦。彼一切十使与见苦相违。问曰。云何相违。答曰。世间不能观察。彼于苦阴不如实知。闻说阴苦不喜不乐。此不观察是名愚痴。以愚痴故于中生疑。为但是阴为有我耶。起如是心是名为疑。疑故邪说或本习故。谤言无阴是名邪见。计有于我是名身见。见彼相似相续不断故生常见。见彼因果相续坏灭。以迷惑故生于断见。执于断常故名边见。于此见中取以为净是名戒取。于此见等取为最上是名见取。若爱己见是名为贪。若恚他见是名为嗔。以此自高是名为慢。如是次第此十烦恼与苦相违。离三见二转者。除身见边见戒取。其余七使集及灭转。彼于苦因不知是名无明。痴故生疑疑于苦因。为有为无是名为疑。疑故邪说或因本习。谤无苦因是名邪见。于彼取胜是名见取。余如前说。如是于灭谛涅槃不知是名无明。以愚痴故迷惑涅槃为有为无。是名为疑。余如前说。道除于二见者。道除身边二见余八种转。于彼不信受道是名无明。余一切如前说。戒取者于此诸见。牛戒等中信以为净。问曰。彼身见等何故不于集灭道中转耶。答曰。身见于果中行我我所转。无有作如是解。于此苦因及灭道等计于我者。是故身见于苦中转。故见苦实悉断无余。边见从身见生。是故苦缘。若见断身见者。彼缘彼见亦断边见。问曰。若戒取不信于因。计自在因为道。彼云何见苦断耶。答曰。彼愚于果。计自在等阴名而起彼常分别。于自在等以作因想。彼时能以无常等行观察苦谛。计自在等因想即断故见苦断亦不信道彼计非道为道。为道故见道断见真道故灭中无此。何以故。如是因道灭中无故。上界不行嗔者。色无色界除嗔。余如欲界说。何以故。彼无损害相故。有善欲故。性寂静故。心滋润故。是故无嗔。已说诸使自性差别。缘差别今当说

  普遍在苦因　　疑见及无明
  是使一切品　　谓在于一地

见苦见集所断品中。疑见及相应无明不共无明。此十一使当知界。界自界地中一切遍。此于自地一切五品中缘使上不使下。何以故。离欲性故。下不使上。何以故。非境界故。故说使于自地。问曰。一切遍义云何。答曰。缘一切有漏事义故名一切遍义。彼一切一切众生。一切有漏事中。本来起故。是名一切遍义。无有一有漏法。若凡夫人本来不取执我我所等者。问曰。何故见苦见集所断品中。说一切遍非灭道耶。答曰。一切有漏缘故。同一意故。是以坚固一切有漏事苦集谛摄。见灭见道所断诸使。少分有漏缘少分无漏缘。非同一意故。非坚固亦非一切缘。问曰。何故贪嗔慢等非一切遍。答曰。此是自相使故。于一众生少分亦生。一切遍使则不如是。一切遍者缘一切界一切地故。贪等作意起求贪欲。具一切遍者但于他现生恶行犹如河流。已说自界地一切遍。他界地一切遍今当说

  初烦恼五种　　四说为第一
  于上境界转　　普遍智所说

前说十一一切遍中。除身边二见余九烦恼。他界地中说一切遍。彼欲界见苦所断邪见。谤色无色界苦果。见取取胜戒取于非苦因取为苦因。疑彼中犹豫无明迷惑。如是欲界见集所断邪见。谤色无色界阴。因见取于因事取胜。疑于因事犹豫无明迷惑。如是色界邪见谤无色界苦果。如是应广说。地亦如是。初禅地谤第二禅苦。如是应广说。乃至不用处谤非想非非想处。复次无色界异彼无他界一切遍。何以故。上无界故。非想非非想处无他地。一切遍上无地故。问曰。何故身边二见。非他界地一切遍耶。答曰。非异界地生。于异界地阴生我我所无此理也。无二身事行此非现见故。彼无我故。无生我所理也。边见者于己阴中计存断常

  邪见及与疑　　俱生独无明
  见灭道二断　　当知无漏缘

见灭断邪见谤于灭谛。疑者疑于灭谛。彼二相应无明及独一无明。无明不见相于灭处转。此三烦恼缘灭谛故。是无漏缘道中亦尔。如是三界有十八使定无漏缘。问曰。何故见灭所断。贪等烦恼非无漏缘。答曰。如其无漏缘者。则不见贪过。是故贪使非无漏缘。若贪灭道者。是善法欲非贪使也。非嗔者毁呰相不生故。自性柔软作故。无漏非可慢也。清净最胜是涅槃道故非二取

阿毗昙心论经卷第二阿毗昙心论经卷第三

        法胜论大德优波扇多释

        高齐天竺三藏那连提耶舍译(六卷成部)

    使品之二(别译)

问曰。彼何者使。何处使

  欲界一切种　　一切遍使使
  缘缚于自地　　上地亦如是

欲界一切种一切遍使使缘缚于自地者。欲界一切遍使使。欲界一切种上地亦如是者。色无色界自地亦如是

  其余诸结使　　当知于自种
  缘使于自地　　一切共依品

其余诸结使当知于自种缘使于自地者。非一切遍使。于自种类自地法中。缘使所使此彼境界。一切共依品者。一切遍使及不遍使。于自种类自品相应法中相应使

  若无漏所行　　他地缘烦恼
  彼相应所使　　境界解脱故

若无漏所行他地缘烦恼彼相应所使者。若使无漏缘。及他界地缘烦恼。彼相应所使非缘使。问曰。何故。答曰。境界解脱故。此使解脱境界故。无漏诸法解脱一切烦恼。问曰。云何缘而不使。答曰。无住处故彼对治无漏。是故不得住处。譬如炎炽琉璃蚊蚋等虫。乐升其上而不能住。如人履于热地以热触故不能停足。彼亦如是。上地诸法解脱下地。是故缘而不使。问曰。此使云何为是不善为是无记。答曰

  身见及边见　　彼俱生无明
  是欲中无记　　色无色一切

身见及边见彼俱生无明是欲中无记者。欲界身边二见。及彼相应无明是无记。何以故。与施戒等不相违故。身见常见于施戒修不相违。何以故。欲受未来可爱果故。是故作施等事。不善则与施等相违。是故无记。又诸众生常行此见。若此烦恼是不善者。欲界应无有一众生得受乐者。何以故。常行不善故。复次此见愚于自事不逼迫他。是故身见非是不善。断见随顺离欲近于无我。能作厌离无常行故亦非不善。欲界诸余烦恼皆是不善。色无色一切者。色无色界所有诸使悉是无记。四支五支三昧所制伏故不能生报。譬如善咒制伏毒蛇不能为害。彼亦如是。复次不能为报因者。不善能生苦受报。上无苦受不可欲界受于彼果。问曰。云何一切烦恼。决定于自境界中转。为当不耶。答曰不也问曰。云何。答曰

  贪嗔慢当知　　过去或缘缚
  未来说一切　　余一切三世

贪嗔慢当知过去或缘缚者。若过去世贪嗔慢等彼非一切。于自境界中过去世缚。何以故。非不见不闻。不闻不分别事起贪嗔慢。何以故。分齐缘故。或时有人于眼生贪非余身分。何以故。自相使故。非贪等使共取境界如身见等。未来说一切者。若未来世贪嗔慢等。缘缚三世诸有漏法。彼中若五识身。必定生法系缚未来。若不生法系缚三世。及意地生不生法。亦缘缚三世诸有漏法。何以故。彼缘一切有漏法故。余一切三世者。见疑无明是名为除。彼共相缚故。若过去未来缘缚三世诸有漏法。何以故。彼是共相使故。现在使不定。是故不说。若有者彼自相使随现在前。彼现在未来缚。未来缚者。谓意地及不生五识身等。过去世者。若于彼起已灭不断于彼中缚。若共相使现在前者。彼缚三世诸有漏法。已说使世差别。次第转今当说

  烦恼次第转　　自地于自地
  上地亦生下　　次第应当知

烦恼次第转自地于自地者。谓一切使于自地使次第缘转。一一次第生于一切。上地亦生下次第应当知者。于梵世地命终次第生欲界。一切彼中染污心命终。次第欲界中阴秽污心生。如是乃至有顶中生或生如是生。如生无色界还生无色界。问曰。如世尊说贪等七使。云何差别为九十八。答曰

  欲界五种贪　　此说欲爱使
  色无色亦尔　　有爱应当知

欲界五种贪此说欲爱使者。所谓见苦集灭道修道断等。五种欲贪说欲爱使。此如前说。色无色亦尔有爱应当知者。色界五种。无色界中亦有五种说有爱使

  嗔即是嗔使　　五种如前说
  憍慢及无明　　十五在三界

嗔即是嗔使五种如前说者。欲界嗔有五种。见苦断等说为嗔使。憍慢及无明十五在三界者。欲界憍慢亦有五种见苦断等。色无色界亦有五种。此十五种慢说为慢使。无明亦尔

  见使三十六　　当知在三界
  疑使有十二　　略说为七种

见使三十六当知在三界者。见使三十六当知十二系在欲界谓见苦断五。见集断二。见灭断二。见道断三。色无色界亦尔。疑使有十二者。四种系在欲界。谓见苦集灭道断。色无色界亦尔。此十二种说为疑使。略说为七种者。此界性种差别为九十八使。世尊经中略说为七种。问曰。使有何义。答曰。彼微细义是为使义。使微细行。粗者名缠。常随入义名使。如胡麻抟相。着义名使。犹如小儿着于乳母。相续义名使。犹如鼠毒。如四日疟病。如责日息。如铁黑色不舍。如读诵渐积。如是烦恼。世尊说为扼流取漏缚。问曰。何故。答曰

  厄取及漂流　　泄漏与系缚
  以是义故说　　厄流取漏缚

苦系义说厄。此有四种。谓欲厄有厄见厄无明厄。取生生具故说为取。此亦四种。谓欲取见取等。漂众生故说流。亦有四种。如厄中说。彼流出义是漏义。一切生中行漏有三种。谓欲漏有漏无明漏。能系缚世间义故名缚。问曰。何者为结。答曰。结有九种。谓爱结恚结慢结无明结见结他取结疑结悭结嫉结。已说烦恼名差别。根相应今当说

  诸使在三界　　尽舍根相应
  随地诸根使　　相应至色有

诸使在三界尽舍根相应者。三界一切烦恼尽与舍根相应。何以故。无明与舍根相应。彼随顺一切烦恼。及随顺别烦恼。一切烦恼后时悉皆处中而息。随地诸根使相应至色有者。如梵世有喜根乐根。彼中诸使与此相应。如光曜天有喜根。彼地诸使与喜根相应。遍净天亦有乐根。彼中诸使与乐根相应

  邪见及无明　　欲界中乐苦
  嗔恚疑唯苦　　谓余一向乐

邪见及无明欲界中乐苦者。欲界邪见与苦根乐根相应。邪见者作恶业则喜。作善业则忧。无明者与一切根相应。嗔恚疑唯苦者。欲界疑使不定故不喜故。与忧根相应。嗔恚于不爱相转故。与苦根忧根相应。谓余一向乐者。欲界诸余烦恼与喜根乐根相应。彼除邪见。谓余见贪慢等喜转

  谓熏二种身　　见断唯意地
  欲界诸烦恼　　说诸根相应

谓熏二种身者。修道所断烦恼名熏。彼与身受心受相应。除慢唯意地故。彼苦根乐根是说身受。忧根喜根是说心受。舍根二种受。一切身受修道所断。心受二种断。见断唯意地者。见断烦恼与心受诸根相应。一切见断烦恼在意地故。欲界诸烦恼说诸根相应者。此必定欲界烦恼法如是。上地随地根相应亦如是。疑者色界中唯与喜根乐根相应。彼疑善助道想与喜相应。已说烦恼。起烦恼今当说

  无惭与无愧　　睡悔及悭嫉
  掉眠烦恼上　　故说起烦恼

使者亦说烦恼。彼增上者是起烦恼。此等八法彼中生故。名起烦恼亦名为缠。彼中睡眠无愧三种依于痴起。掉悭无惭三种依于贪起。悔依疑起。嫉依嗔起。自身作恶不嫌名为无惭。不顾他不羞名为无愧。睡时令心无所堪能。以眠着故。令五根不能转意不自在。于爱不爱境界生于分别。心不寂静是名为掉。于可作不作作不可作想。后退变心热是名为悔。见他资产。心中不喜。是名为嫉。于法于财福德吝惜。与施相违悭心是名为悭

  一切烦恼伴　　当知睡与掉
  无惭及无愧　　必定不善俱

一切烦恼伴当知睡与掉者。此二起烦恼与一切烦恼相应。何以故通三界故。一切烦恼不寂静故。当知掉烦恼现前。于善无能故当知睡。无惭与无愧必定不善俱者。此二起烦恼与不善使相应。欲界一向不善故

  悔在意说苦　　修道之所断
  眠唯在欲意　　余各自建立

悔在意说苦者。悔在意地下劣处生。故与忧根相应。说苦者当知在欲界非上界。问曰为谁所断。答曰修道之所断。悔在善行恶行中故修道所断。眠唯在欲意者。眠在欲界意地。眠时一切烦恼共行。是故欲界意地一切烦恼相应。余各自建立者。余谓悭嫉彼自力转。不与余烦恼相应。义除无明决定修道所断。与不共无明使相应。问曰。此使与几识身相应。答曰

  贪欲嗔恚痴　　当知依六识
  谓欲修道断　　上地随所得

贪欲嗔恚痴当知依六识。谓欲修道断者。欲界修道所断。爱恚无明六识相应。若见道断者唯在意地。上地随所得者。色无色界爱无明等。随所得识身即与相应。如梵世四十四识身可得。彼中二使即与四识身相应。此上唯与意识相应。彼中余使一向在意地故。已分别烦恼。断分别今当说

  一切断烦恼　　方便智所说
  如此得解脱　　当知非一时

一切断烦恼方便智所说者。此诸烦恼谓在无碍道中。一时顿断不数数断。彼断有四种。谓知缘。伴断。断缘。自清净。彼知缘者。谓见苦集所断自界缘及无漏缘。伴断者。谓他界缘。断缘者。谓灭道所断有漏缘。自清净者。谓修道所断随彼彼所断。如是如是自身清净。如此得解脱当知非一时者。此得解脱随彼数数得。如欲界见断五时作证。谓自分对治时。如见苦断苦法智。如是乃至见道断道法智。及四沙门果此前所断。须陀洹果摄一解脱得生。斯陀含阿那含阿罗汉果摄亦如是。色无色界三谛亦如是。此中说自分对治。比智分见道断者。断作证决定凡夫。圣者色无色界见道所断一时断。是故此中无自分对治。有顶地中见苦集灭断者。决定五时如前说。贤圣次第法见道断者。但四沙门果自分对治。即是须陀洹果决定修道断。欲界三时谓凡夫地阿那含果及阿罗汉果。一切悉断法此自分对治。须陀洹果中不说色界二种。谓自分对治。阿罗汉果。自分对治者。一切色界离欲无色界。但阿罗汉果一切断法。已说灭作证。断知今当说

  欲界中解脱　　佛说四断知
  色无色解脱　　当知五断知

因尽断得无漏解脱。得度界建立断知。何以故。解脱无余随得断知名。彼有九种。彼中欲界见苦集断。断者得无余解脱。何以故。开一切遍因故。断故此一断知见灭断。第二见道断。第三修道断。第四此断下分分别。色无色界亦尔。见断三如前说。色界修道断第四。此无余离色欲故。分别无色界修道断。第五此一切结尽分别。于此断知分别有二。谓得阿那含果及阿罗汉果。以此二处度界得果故。问曰。诸使为与心相应。为不相应。毗婆阇婆提说。心不相应是故生疑。答曰。决定相应。何以故

  为心作烦恼　　障碍净法相
  诸妙善可得　　故非不相应

为心作烦恼者。若使决定心不相应者。不应为心作烦恼。应如色等境界。然为心作烦恼。如说贪欲秽心。以此言故当知相应。障碍者。若使心不相应者。善智生时不应障碍。应如虚空不作障碍。今为障碍故知相应。净相违者。若使与心不相应者。便应与善不相违。不相违故则应非过。然为过故当知相违。若相违者故知相应。诸妙善可得者。若汝使与善相违心不相应者。使恒相续于中善应不能得起。现见善法能得起故。是故诸使非不相应。是相应也

    贤圣品第五

已说流转次第。不流转次第今当说

  贤圣弃如此　　烦恼众怖犷
  精进方便智　　彼方便善听

贤圣者。于人天中应受供养故名贤圣。弃者舍离义也。如者若方便如是义。此者次第说使辨其相貌。烦恼者。相续烦劳众生故名烦恼。众怖犷者。谓是一切苦恼因义。正精进者。如法精进义也。方便智者。谓舍摩他制发舍时智义。方便者。谓彼方便义也。善听者。谓至心听。听智摄持义。方便者据始业。地人乃至无学地人。戒等所作方便行者。始业今当说

  始于身一分　　行者系自心
  系缚于识足　　为杀智慧怨

始于身一分行者系自心者。问曰。何处系耶答曰。若鼻端若眉间。不净阿那波那。界入三方便观故。自身分中说系心非外法。虽有外缘方便不说。问曰。何故系心。答曰。系缚于识足心。性躁乱动转不住。如惊猿猴。此是系一缘中义。问曰。何故系一缘中。答曰。为杀智慧怨。实智怨者。所谓烦恼。为断彼义是故一心得观。如实非乱心也。见如实故能断烦恼以是义故作如是说

  此方便于身　　真实相决定
  诸受及自心　　法亦随顺观

心系一缘故观身实相。身实相者。谓不颠倒相如义也。问曰。何者是身实相。答曰。自相及共相。彼自相者。谓十色入及法入中少分色也。彼共相者。所谓无常苦空无我。如是等义不乱心。行者三方便中随意现前。方便行次第身实相得决定。此行者观微尘色念念散坏。是时身念处观满。如畦水流法入受念处。无色法中受是最粗。故观身后次观于受。是人观受自相共相。尔时受念处满。彼受依心。是故受后次观于心。此处亦自相共相。决定意解心念处满。尔时为观其余法故。入法念处。其余法者。所谓二荫及无为法。彼亦观于自相共相。尔时法念处满

  入法中总观　　得法真实相
  此四是无常　　空无我非乐

入法中总观得法真实相者。入余法念处已。行者知分齐缘念处修方便。于一切法余共相坏缘念处。数数惯习修身受缘共相法念处。如是身心缘如是三二。当知如是坏缘。数数惯习修已。一切身受心法念处一来总观。问曰。云何。答曰。此四是无常空无我非乐。总观一切有为诸法。无常等如是义。彼念念展转坏灭故是无常。虚无故空。不自在故无我。三苦常随逐故非乐。彼人欲坏烦恼觅其元首。如所见法因果差别。分别于谛彼中二种。因果有漏无漏。彼有漏者集因苦果。彼无漏者道因灭果。彼人如是分别谛已。初发趣次第闻思。念处自相共相。摄取分齐缘谛中分布。彼时坏缘法念处四谛中。思惟十六行观

  从是名为暖　　于觉法而生
  十六行等起　　观察四圣谛

从是名为暖于觉法而生者。行者思惟共法念处。次后最初修事。共法念处相续建立。圣者名暖善根。问曰。彼法几行何境界。答曰。十六行等起观察四圣谛。行者以十六行观察四谛。彼以四行观察苦谛。此苦本无今有已有还离故无常。三苦随逐故苦。内离人故空。不自在故无我。如是亦以四行观察集谛。此集生相似果故因。能生流转故集。能牵一切生死故有。能和合不相似事故缘。亦以四行观察灭谛。此灭与一切生死相违故灭。离一切烦恼火故止。于一切法中胜故妙。能舍生死故离。亦以四行观察道谛。此道能至非品故道。不颠倒故正。一切圣足所履处故迹。出过生死故出。问曰。暖有何义。答曰。智于所知。如钻燧相研能穷尽诸有。生无漏智火。暖为相故名暖

  是法增长已　　生顶及于忍
  次世第一法　　依于一刹那

是法增长已生顶及于忍者。行者入正精进故得善助道。随顺众具增长胜进力故。暖得增长成就已。彼人修一切苦法念处。生胜善根名顶。问曰。顶是何义。答曰。不动善根。彼住此顶时。离诸过故能入忍中。彼若不者还退住暖。如人登山。若不至顶则堕四边。行者如是。正方便相续。顶增长已次生善根名顺谛忍。是修一切共法念处。胜进彼二法以十六行观察四谛。问曰。忍有何义。答曰。彼于四谛无常等行。乐欲增长是故名忍。是故说顺谛忍。能除四谛增上愚。暖顶能除四谛下中愚。非增上忍增长已。次世第一法依于一刹那。忍增长已一切共法念处胜进。故生如是一切世间功德中最胜善根。彼初开圣道门故名世第一法。有说。世间中最胜故名世第一法。此法一刹那起。此行者开涅槃门已。灭与苦法忍次第缘故。一念暖顶忍及彼最上功德。此一切善根皆五阴性。问曰。汝言世第一法与圣道作次第缘。云何是五阴性。答曰。心心数法与次第缘色心不相应行。随顺一果。是故非过。问曰。此世第一法何缘。答曰。苦谛。彼缘苦谛义也。问曰。几行。答曰。四行。若苦谛境界四行如上所说彼行此行。问曰。几地所摄。答曰。六地生。当知未来中间根本四禅。问曰。余达分善根几地所摄。答曰。余亦依六地彼亦六地。如世第一法。问曰。何故达分善根六地所摄。答曰。从彼能生见道。彼地有见道有见道处即有此等。何以故。见道眷属故。是故如是

  世间第一法　　次必起于忍
  忍次生于智　　能觉于下苦

世间第一法次必起于忍者。暖等次第生如上因分。乃至能生世第一法。世第一法次第生无漏法。欲界见苦断十使对治名苦法忍。昔所未见法欲知乐名忍。此最初无漏无碍道。忍次生于智者。苦法忍次第生苦法智。解脱道自性。问曰。此忍智何缘。答曰。能觉于下苦。下苦谓欲界苦。此二种缘如是义

  谓色无色苦　　集灭道亦然
  此法无间等　　从于十六心

谓色无色苦者。色无色界苦亦如是。生忍无碍道智解脱道。圣者亦说苦比忍苦比智。集灭道亦然者。集灭道亦如是生四种。异义二忍为无碍道。二智为解脱道。此法无间等说于十六心者。此十六心须成就无间等。无间等。是见义。此十五心须是见道。最后一心是修道摄。从此名修地乃至金刚喻定。此后名所作已办地。略说三地。谓见地。修地无学地随此地建立人今当说

  随法行利见　　此在于十五
  随信行非利　　当知亦在中

随法行利见此在于十五者。见道所摄十五心人。若利根者说随法行。智慧随法行故名随法行。此障不信于他义也。随信行非利。当知亦在中者。即此十五心人。若软慧者说随信行。是信他法得行义也。彼人信现在前慧随顺。与彼相违说法行

  未离欲界欲　　趣向于初果
  第二舍于六　　第三九无垢

未离欲界欲趣向于初果者。此随信行随法行人。先未离欲具一切缚。至决定。分名向须陀洹果。第二舍于六者。欲界修道所断烦恼分别九种。所谓下下下中下上。中下中中中上。上下上中上上。彼信行法行人在凡夫地。已刬六种烦恼后入决定。是时说向斯陀含果。第三九无垢者。若刬九种烦恼后入决定。是时说向阿那含果

  若至十六心　　是说住于果
  软见信解脱　　净见说见到

若至十六心是说信于果者。在十六心道比智相应彼起。若利根若软根俱说信果。先未离欲须陀洹果。离六种欲斯陀含果。离九种欲阿那含果。软见信解脱者。若软根者向地中名信行。彼住三果名信解脱。净见说见到者。彼利根者住果名见到

  未尽修道断　　当知七往来
  家家有三尽　　彼住须陀洹

未尽修道断当知七往来者。此人住果未断修道断故当知七生死。彼人中受七生。欲界天中受七生。及中阴二十八生俱受七生。故名七生。如七叶树。如七处善。家家有三尽者。若住果若凡夫人。欲界修道断中三种尽。上上上中上下。彼说家家。家家者从家至家往来而入涅槃。故名家家。人中二三家天中二三家往来。此有二种。谓人家家及天家家。以业根断烦恼差别故名家家。业者于凡夫分作受二三有集业。根者得无漏根。断烦恼者。断三四种烦恼。彼住须陀洹者彼七往来。及家家说住须陀洹果。问曰。何故名须陀洹。答曰。须陀名圣道流。洹名为入若人相续初见修道入彼流中。又是人得须陀洹果。故名须陀洹。如裹孕女儿。以法名人

  六尽斯陀含　　离八一种子
  九品尽不还　　已出欲泥故

六尽斯陀含者。若人断六种尽。谓上品三种中品三种是斯陀含。从此命终生于天上。复生人中而般涅槃。名斯陀含。离八一种子者。一生种子义。彼人余唯一生。若人若天有一种一种子。谓人一种子天一种子。或烦恼差别名一种子。彼余唯一有未尽故名一种子。是人为阿那含果向。当知斯陀含果中胜道摄。九品尽不还者。若人欲界一切九种烦恼断名阿那含。不还来欲界生故名阿那含。问曰。何故不还来。答曰。已出欲泥故。出爱欲泥。是故不复还来欲界

  如是九烦恼　　在于上八地
  彼双道所断　　世尊之所说

如是九烦恼在于上八地者。如是欲界修道断烦恼如前说。九种烦恼下下乃至上上。当知八地亦如是。谓四禅四无色定彼双道所断。世尊之所说者。彼三界烦恼。当知无碍解脱道断。无碍道断结得解脱道证。解脱下下道断上上种。乃至上上道断下下种。此略说一百七十八道及见道。问曰。云何决定出世间道。断烦恼为当不耶。答曰。不也。问曰。云何。答曰。

  有垢无垢道　　俱能胜八地
  住彼说身证　　谓得灭正受

有垢无垢道俱能胜八地者。有垢者世间道无垢者无漏道。彼八地欲界四禅三无色定。世间出世间道能过彼有顶。中必出世间道能过彼世俗道。亦无碍道解脱道。彼无碍道三种转。谓苦粗障解脱道亦三种。谓上妙出世间道。如前所说无常行等。住彼说身证谓得灭正受者。彼八地离欲中住学人。若得灭尽定者。彼名身证。身证涅槃相似法故。是名身证

  金刚喻三昧　　次必生尽智
  生意我生尽　　罗汉离诸漏

金刚喻三昧次必生尽智者。生有顶离欲第九无碍道。最后学心名金刚喻三昧。犹如金刚无不能坏。次后必生尽智。此初无学心彼二智异。或苦比智或集比智。如彼人从尽智起。作如是缘尽随顺生慧。生意我生尽者非想非非想处四阴。当知此中生。何以故。最后断故。罗汉离诸漏者。彼尽智起时一切漏尽名阿罗汉。于天人中应受供养。故名阿罗汉。问曰。阿罗汉有几种。答曰

  阿罗汉六种　　五从于信生
  彼得于二智　　当知时离垢

阿罗汉六种者。谓退法思法护法住法必升进法不动法。彼中若人软智软方便。最初与退具相应。必定退故名退法。若人软智软方便。常厌恶身念欲坏灭。彼死成就思法。若软智增上精进。以精进力自护。是名护法。若中智等精进彼住此道。不进不退故名住法。少利智极精进必能进至不动。名必升进法。若利智广精进。初得不动。是名不动法。五从于信生彼得于二智者。此六种阿罗汉中。前五种本是信行。彼有二智。尽智无学正见。彼或时退。是故不生无生智。彼尽智或一刹那。若次第无学正见现在前。或增长。若彼现在前当知时无垢者彼时解脱。观察若国土若时若伴若说法若衣食等。进修善根。此善根分。不一切时随所欲进修。故名时解脱

  不动法利根　　是非时解脱
  彼得于三智　　自解脱成就

不动法利根是非时解脱者。若人一向利根是不动法。当知非时解脱。彼人善分于一切时随所欲进。不观于时故名非时解脱。彼得于三智者。彼生三智。谓尽智无生智无学正见。彼是不退法。是故生无生智。是人尽智一刹那无生智或一刹那若次第无学正见现在前或时得胜进便彼现在前。自解脱成就者。彼人成就自相似名解脱。当知时解脱者。彼决定时得解脱。成就不动者非非彼烦恼之所能动。犹如王印。故名不动

  当知慧解脱　　不得灭尽定
  唯有俱解脱　　成就灭尽定

当知慧解脱不得灭尽定者。是六种阿罗汉中。若不得灭尽定者。当知是慧解脱。慧解脱者彼唯慧力得解脱故名慧解脱。唯有俱解脱成就灭尽定者。彼六种阿罗汉中。若得灭尽定者。当知是俱解脱。以慧力故。于烦恼障而得解脱。以定力故。于解脱障而得解脱。以是义故名俱解脱。如上所说贤圣士夫。略说二种。谓学无学。为断烦恼故。学是名为学。非断烦恼故名无学。何故不学学已竟故。已分别贤圣人。法差别今当说

  若随信行法　　及随法行法
  如是见谛道　　是尽同一相

若随信行法若随法行法。若见谛彼同一相见谛道中。信行法行差别。以法名人

  彼中诸根数　　是说未知根
  诸余有学法　　智者说智根

彼中诸根数是说未知根者。彼见谛道所摄之中若根数法。所谓意根乐根喜根舍根。信等五根是名未知根。未知欲知故名未知根。彼见道所摄士夫当知如是根。诸余有学法智者说知根者。见道已上即此诸根数法说为知根。知已复知故名知根。若修道所摄士夫当知如是根

  于中无学法　　当知知已根
  得果舍前道　　此义应当知

于中无学法当知知已根者。于无学法中即此诸根数法名知已根。知已更无所知。故名知已根。若无学所摄士夫当知如是根。问曰。此贤圣人一一次第如上所说。彼人一切成就先所得道。为当不耶。答曰。得果舍前道。此义应当知。若此士夫入道已。当知胜进行。此得果已舍于前道。何以故。不欲令彼果向一故。若退根。及增进根。彼亦舍道。此中不说得须陀洹果舍于见道。得斯陀含果或舍见道。或舍须陀洹果胜道得阿那含果。或舍见道。或舍斯陀含果胜道得阿罗汉果。舍阿那含果。舍阿那含果胜道。若增进根差别者。舍果胜道亦得果利根所摄学无学。舍果亦得果。若退者舍胜得劣。问曰。如得果者舍于向道。彼亦舍断不耶。答曰。舍道非断

  已尽为解脱　　得依于一果
  不秽污第九　　除断应当知

已尽为解脱得依于一果者。先所断烦恼。一解脱得得果摄。是故不舍断。向道中所有解脱道得如是解脱。问曰。断烦恼如前说。彼不秽污。云何断耶。答曰。不秽污第九除断应当知。已说九种烦恼。九种道断彼不秽污。决定第九无碍道时顿断非渐渐断。不秽污者。谓善有漏不隐没无记行。秽污色亦必定最后断。问曰。何故烦恼九种断非善等耶。答曰。烦恼相违故。圣道与烦恼相违。不与善相违。厌恶烦恼故亦舍善。同一系缚故。问曰。已说阿罗汉胜进根。云何阿罗汉得不动。答曰

  若有相似名　　彼能得不动
  此人亦信脱　　彼性亦增道

若有相似名彼能得不动者。非一切阿罗汉皆能得不动。若功德名相似者彼能得之。谓必升进。此人亦信脱彼性亦增道者。此语有余。若信解脱必升进性能得见到非余。增道者根增如是义。问曰。已说次第见谛。未说其因。当说彼因。答曰

  功德恶差别　　次第见真谛
  无碍道力得　　有为无为果

功德恶差别次第见真谛者。此中二谛过恶差别。二谛功德差别。非见过恶者见于功德。非见功德者见于过恶。何以故。行缘差别故。非不于谛真实见故而谛无间等。非此一智能总观谛功德过恶差别。以是义故。次第见谛。问曰。见谛得沙门果。彼云何。为是有为是无为耶。答曰。无碍道力得有为无为果。若断烦恼无为。若解脱道有为。彼二种皆无碍道力得。是故二种俱说沙门果

阿毗昙心论经卷第三阿毗昙心论经卷第四

        法胜论大德优波扇多释

        高齐天竺三藏那连提耶舍译(六卷成部)

    智品第六(别译)

今欲分别涅槃分智。何以故。以智能断诸烦恼故。欲广释智。故先说此

  若智性能了　　观察一切有
  有无有涅槃　　彼相我当说

有无有者。所谓涅槃。是故智者观有无有。有者一切有漏法谓苦集义。有无有者谓灭谛也。一切有无有。故名有无有。于彼中无有义也。此说有对治谓是灭。是故灭非无也。非无物有对治。如灭尽正受心心数法不行故。对治说灭。是有物如是涅槃一切有对治。是故有事如除病得无病。彼相谓寂灭寂灭相等。彼攀缘智。智者观察于彼。非无境界而有智转。是故若智观察此即是道。问曰。彼何者是。答曰

  三智佛所说　　最上第一觉
  法智随顺智　　及以世俗智

此三智摄一切智。法智者。若智欲界境界。或欲界灭对治。或境界无漏。彼初取法决定行。故名法智。随顺智者。若智色无色界境界。色无色界灭对治。或境界无漏。次法智后次第随顺。故名随顺智。世俗智者。若有漏智多受俗数。谓男女等故说世智。如是等名世俗智

  苦集及灭道　　二智而随生
  如是四种智　　牟尼随名说

法智随顺智者。随圣谛转。世尊随名说苦谛境界。故说苦智。如是集灭道谛境界。故曰集灭道智。于此苦集二智行差别。苦行转名苦智。集行转名集智。缘无差别同缘五阴。故灭道二智行缘差别

  若智观他心　　是从三中说
  尽无生智二　　当知在四门

若智观他心是从三中说者。三智中他心智有漏。是世智。若欲界对治境界。彼是法智。若色无色界对治境界。是随顺智心心数境界。彼心心数方便成就。故名他心智。尽无生智二者。尽智无生智是二智。谓法智随顺智。彼所作究竟受是尽智。不复更作受是无生智。问曰。尽智无生智何谛境界。答曰。当知在四门。此缘四谛义也。除初尽智彼缘二谛。已分别十智。行分别今当说

  二智十六行　　法智随顺智
  上已说及余　　是说世俗智

世智十六行转。前后皆有彼十六行。暖顶忍摄。余闻思修慧第一法摄。四行无间等边十二行。彼外更有行。谓施戒慈等

  四智有四行　　决定行所说
  若知他心智　　如是行或非

四智有四行决定行所说者。苦智有四行。集灭道智亦如是。若知他心智如是行或非者。若无漏他心智。彼有四行。如道智是道智少分故。若有漏者行则异。但摄有漏心心数法

  尽智无生智　　离空无我行
  说有十四行　　受相为最上

尽智无生智离空无我行说有十四行者。尽智无生智第一义转。亦亲近世智作意我生尽。如是等取我众生相似行。空行无我行。定是第一义转非世俗缘。是故尽智无生智。空行无我行不转故有十四行。问曰。所有无漏智。一切十六行摄不耶。答曰。不尔。受相为最上。彼十六行是共行。若复取自相无漏智。如身念处等。彼非十六行摄。已说行差别。得今当说

  最初无漏心　　或有成就一
  二或成就三　　于上四增一

最初无漏心或有成就一者。最初苦法忍相应心。未离欲成就一智谓世智。离欲成就他心智不现在前。非见道次第他心智现在前。何以故。与流转相违故。二或成就三者。第二无漏苦法智相应心。未离欲成就三法智苦智世智。若离欲成就他心智。于上四增一者。于上四心刹那中。当知一一增苦比智。得比智集法智。得集智灭法智。得灭智道法智。得道智集灭道比智。及忍不得未曾得智。问曰。在何地。答曰

  九智圣所说　　此依于二地
  当知禅有十　　无色地中八

九智圣所说此依于二地者。九智依未来禅中间禅除他心智。当知禅有十者。根本四禅各有十智。问曰。何故中间禅未来禅无他心智。答曰。微细境界故。此境界微细于他身中。心心数法未来禅。少道非少道能取微细义。彼根本禅道止观双行。是强力道故彼能取。无色地中八者。除法智他心智。法智者欲界境界。无色界于欲界依对治行缘远。是故无色界无法智。他心智缘色能生。是故于色界转非无色中。余未来有顶有一世智。何以故。有漏故。已说地差别。修差别今当说。修有六种。所谓得修习修对治修出离修戒修观察修。彼得修者。若于善法不得。得现在未来故。习修者。先所得功德现前修习。对治修者。诸有漏法修对治道。出离修者。若修道时舍离秽法。戒修者。若能调伏诸根道。观察修者。若观察身等。此中唯取二修。谓得修习修

  若得修诸智　　谓在圣见道
  彼即当来修　　诸忍亦如是

若得修诸智谓在圣见道彼即当来修者。若见道诸智现前修。彼即当来修。谓苦法智现在修。彼亦未来修。非忍非余智。如是乃至道法忍。诸忍亦如是者。忍中亦如是。苦法忍现在修彼亦未来修。非智非余忍。一切忍亦如是。问曰。何故见道唯修自分道。修道修自分非自分耶。答曰。未修智故。故见道中智未习未练。修道中二种并作

  于彼三心中　　得修于世智
  或修七或六　　当知最后心

于彼三心中得修于世智者。彼见道三心中得修世智。谓苦集灭比智。随彼地见道即彼地有世智。及欲界世智修。若彼依未来地得决定彼修未来及欲界世智。如是依第四禅得决定。彼修七地世俗智。问曰。道比智何故不修。答曰。彼无边故。谛无间等边成就故。名无间等边。无能修一切道。于他道不能修。于自身修。乃至未来彼行者自分不现前。于三谛自他俱能知能断能证。是故随得边故能修。是故彼能修非余。是故法智亦不修。何以故。谛无间等未究竟故。于此谛世俗智本曾作证。是故此智修但有善名。方便犹未得。或修七或六当知最后心者。若离欲界欲道比智彼修七智。阿那含果所摄。除世俗智尽智无生智。若未离欲修六智除他心智。非想非非想处对治彼得沙门果。是以不修世智

  于彼上修道　　十七无漏心
  当知修七种　　增益根修六

于彼上修道十七无漏心当知修七种者。若未离六种欲。从须陀洹果上修道中。十七刹那当知修七智。此道未来禅摄故。无他心智亦无尽智无生智。以无学故。是故彼中修余七智。彼若以世俗道进彼世俗智现在前七种未来。若出世间道四种法智。一一现在前。余七智未来。增益根修六者。增益根者。谓或信解脱。练治诸根进得见到。彼增进根。一切无碍道解脱道中得修六智。未离欲故无他心智。又复修道精进非断烦恼。精进是人未得修进功德。是故不修世智

  得不还果时　　出过上七地
  熏修诸神通　　解脱修习八

得不还果时者。若得阿那含果时必得根本禅。是故修他心智。及前说七种。出过上七地者。彼四禅三无色离七地欲时。九解脱道中亦修八智。若以世俗道修进。彼世俗智现在前未来八。若出世间道修进彼时四比智。及灭道法智一一现在前未来八。熏修诸神通解脱修习八者。熏修起一解脱道。彼中八法智比智。一一现在前未来八。起神通境界宿命智解脱道中。世俗智现在前未来八智。他心智解脱道法智比智。若世智中他心智。一一现在前未来八。天耳生死通。解脱道无记故不修

  此无碍道中　　及出第一有
  彼八解脱道　　当知修于七

七地离欲一切无碍道中修七智。无碍道中修对治智。是故不修他心智。彼非对治故。熏修起二心无碍道相似。初是无漏第二世俗。无漏心中八法智比智一一现在前。未来七除他心智。一切无碍道不修他心智。世俗道世俗智现在前未来亦七。起四神通无碍道中。世俗智现在前未来定七。他心智有漏亦然。无漏他心智道法比智。一一现前未来定七。有顶离欲八解脱道。四比智二法智。一一现在前未来亦七。世俗智于彼中退。非对治故。世俗智未曾至有顶。彼或时作方便不决定

  出过第一有　　无碍道修六
  上乘应当知　　修习于下地

出过第一有无碍道修六者。第一有离欲九无碍道修六智。除他心智世俗智余现在前。解脱道前已说。六智谓四比智二法智。上乘应当知修习于下地者。一切地中当知修自地智及下地智。若初禅进彼修自地功德。亦修未来禅摄功德。如是乃至不用处次第亦如是。若人乃至不用处离欲依初禅。乃至有顶离欲。是人九地无漏智修进。如是一切应当知

  无学初心修　　诸地生功德
  漏无漏一切　　此是随顺智

无学初心修诸地生功德漏无漏一切者。得阿罗汉果一切地。漏无漏功德一切修进。问曰。何故此地修一切功德。答曰。断一切缚得苏息故。如来解缚法降伏烦恼。力士众咸庆快。心得自在。首系解脱绢。如王登祚诸方万姓贡上珍宝尽难胜。烦恼怨离杀怨家故。一切国土人皆归伏。彼先虽得下地功德。有烦恼相续故不明净。今除烦恼尽故功德明净。及入出定心成就。是故熏修。若住欲界得阿罗汉果法或如是。若住色界得阿罗汉者。彼二界功德修进满足。是故一界生。如是地地应当知。问曰。无学初心何智相应。答曰。此是随顺智。此随顺智相应。彼作如是意。我生已尽。非想非非想处阴取此中生彼人缘彼。何以故。最后断故。是故彼苦比智或集比智。问曰。世尊说若见智慧。此为一为异耶。答曰。彼是慧性。世尊观因缘故。故如是说

  诸忍则非智　　尽无生非见
  若余诸圣慧　　当知三种性

诸忍则非智者。八无间等忍非智。何以故。不决定故。决定义是智义。忍不决定。自品对治疑随生故。忍者求欲转。智者求欲断。是故忍非智。尽无生非见者。尽无生二智能见示故。慧决定故。智何故非见。无求故中平故。若余诸圣慧当知三种性者。余无漏慧事见智慧性

  若善有漏智　　在意则是见
  烦恼见是智　　此及余说慧

若善有漏智在意则是见者。善有漏意地智能求故亦说见。烦恼见是智者。若烦恼见自性。谓身见等彼从测量。思觉转故推求故名见。彼决定故名智。此及余说慧者。若已说者。见事慧事。及余未说者。如无记意地五见。外秽污意地及五识身相应。所有智一切是慧。当知此中未说者说。彼中若无记不能测量。不能觉察。不能推求故非见。秽污烦恼所污故。五识身相应不能分别现境界故。一往堕故。诸见不尔。问曰。一一智缘几智。答曰

  法智随顺智　　观察于九智
  因智及果智　　二智境当知

法智随顺智观察于九智者。法智缘九智除比智。比智亦缘九智除法智。道法智缘一切。法智彼分亦余智苦集法智。缘欲界世智。如是道比智缘自分比智。苦集比智缘色无色界世智。及世俗他心智。问曰。何故法智比智不更互彼此相缘。答曰。上下缘差别故。如二人观地虚空。因智及果智二智境当知者。集智缘有漏他心智及世俗智。何以故。集谛分数故。不缘余智。余无漏故。苦智亦尔

  道智缘九智　　灭智无境界
  余一切境界　　决定智所说

道智缘九智者。道智缘九智除世俗智。何以故。有漏故。余九智缘。何以故。道谛分数故。灭智无境界者。灭智不缘智。何以故。缘无为故。余一切境界决定智所说者。余四智缘十智。世智缘十智。何以故。一切法境界故。如是他心智一切他心心数境界故。彼有漏他心智缘有漏智。如是无漏缘无漏。彼中法智法智分随顺。随顺智分地根人度非缘。尽无生智亦如是。一切有为境界故。问曰。如佛说。随顺智若有顶离欲。得阿罗汉果。不尽是随顺智耶。答曰。彼分对治法智断故。亦有法智彼分对治。问曰。何者是耶。答曰

  若彼灭道中　　法智之所转
  彼三界对治　　非欲随顺智

若彼灭道中法智之所转彼三界对治者。诸修道中灭道法智亦色无色界对治。彼人生欲界舍色无色界结。彼自地阴所逼恼。彼中极见其过故。为离彼故求对治。三界中离欲去彼有顶离欲。但法智无碍道。彼随顺智解脱道。问曰。何故非苦集法智去。答曰。苦集不等故。欲界苦集下劣。色无色上胜。不应观察下劣厌离于上。有何过异处恼异处厌离灭道相似。是故观彼厌离三界欲。此道理说也。问曰。颇有随顺智。亦于欲界为对治耶。答曰。非欲随顺智。无有随顺智为欲界对治。无有一人于彼见增上过。无此道理也。若于色无色离欲。然后于欲界离欲者。无有如是理也。或初难断自地不能离。譬如国王不能降伏自国。而欲降伏他国。如王降伏自国然后降伏他国。法智亦尔。问曰。神通何智性。答曰

  神足天眼耳　　当知一世智
  六智忆宿命　　五说他心智

神足天眼耳当知一世智者。神足天眼天耳是一世智。非无漏智如是转。彼神足通智能示现种种事。示现种种事是智慧能。天耳通者。天耳识相应慧。生死智通者。天眼识相应慧。六智忆宿命者。忆念过去处神通六智。谓法智忆法智分。随顺智忆随顺智分。世智忆世智分。苦智忆过去苦。集智亦如是。道智出世间行。罽宾论师说但一世智。五说他心智者。他心智通五智。谓法智随顺智世智道智及他心智等

  九智漏尽通　　决定智所说
  八智身中转　　法十九智二

九智漏尽通决定智所说者。漏尽通无漏九智漏尽智摄故。问曰。如他心智尽无生智不摄。云何言摄耶。答曰。无学正见摄故。彼一切三种智说漏尽通。问曰。念处何智性。答曰。八智身中转。苦有色身名彼中八智转。除他心智及灭智。法十者。除色受心余法名法念处。彼中十智转如前说。九智二者。受心中除灭智九智转。问曰。如来十力四无所畏是智性。彼智云何差别。答曰

  是处非处力　　及以初无畏
  当知佛十智　　余此中差别

是处非处力及以初无畏当知佛十智者。若彼是处非处力十智。如是初无畏我正遍知。如是广说彼亦十智。何以故。正取故。余此中差别者。处非处力差别。余力初无畏差别余无畏。问曰。佛何故差别作多种。答曰。佛随处化众生。欲故差别多种。有人信乐广说不乐总说。有人乐于略说。力义者随自乐欲。能成就义是力义。无障碍义是力义。能制义是力义。无能侵欺义是力义。能映夺他义是力义。彼处非处力者。因果中决定无碍者。是名处非处力。自业智力者。善不善业处事因报。若多若少若定不定。如是等义中若无碍智。是名自业智力。彼禅解脱三昧正受智力者。此禅等自性名字得方便。摄有味净无漏退住胜达分。如是等义中若无碍智。是名定力根差别智力者。于众生下中上根能知。若无碍智。是名根差别智力。种种解智力者。众生下中上自解知无障碍。是名种种解智力。种种性智力。知众生性知法差别性。若无碍智。是名种种性智力。一切至处道力者。一切生死转业。能尽一切生法。知无障碍智。是名至处道智力。忆宿命智力者。自他过去生死展转。忆知无障碍智。是名忆宿命智力。生死智力者。众生未来有相续见无障碍智。是名生死智力。漏尽智力者。若漏尽漏尽方便。若无碍智。是名漏尽智力。如来十力无畏。如经中广说。不怯弱义是无畏义。无恐怖义是无畏义。无逃避义是无畏义。不下劣义是无畏义。如师子自力雄猛满足不假于伴。如师子无畏是无畏义。问曰。无碍现见亦是智性。彼云何差别。答曰

  法辩辞辩一　　乐义辩俱十
  七智是愿智　　智者之所说

法辩辞辩一者。彼法无碍者句味现前。若无碍智是名法无碍。是世智。辞无碍者。言音正不正方便随方俗语。若无碍智。是名辞无碍彼亦世智。乐义辩俱十者。乐说无碍者法辞义相应。任放不怯弱说种种说。若无碍智是名乐说无碍。此有十智。义无碍者。于法自相共相。若无碍智是名义无碍。是亦十智。能受真实相故。问曰。愿智有几智。答曰。愿智是七智。智者之所说。愿初转乐欲义转。故名愿智。彼七智罽宾论师。说除他心智尽智无生智

    定品第七之一

如是知诸智。智依义今当说

  智依于三昧　　无挂碍而转
  是故思惟定　　求于真实相

智依于三昧无挂碍而转者。如灯依净油炷。离风动处光焰不动而甚明净。如是三昧依智。离诸乱风无障碍转。其心不动如是义也。转行于缘无有疑惑。是故思惟定求于真实相者。若无定不能生真实智。无有离真实智能趣涅槃。是故求真实相者。必定须知三昧。彼三昧者何。谓善一心。是最胜根义也。如是一根转自善心相续名一心。最胜者。或云境界名也。如是一缘转是善心相续名一心。问曰。何者是三昧。云何知耶。答曰

  决定说四禅　　及与无色定
  是中一一说　　有味净无漏

决定说四禅及与无色定者。略说八种三昧摄一切三昧。是中一一说有味净无漏者。是中一一三昧。有三种味相应净无漏

  善有漏名净　　无热说无漏
  有味爱相应　　有顶无无漏

善有漏名净者。彼中若有漏善当知名净。无热说无漏者。若离烦恼者当知是无漏。问曰。若无漏第一义净。何故世间烦恼相续说名为净。不说无漏为净。答曰。无漏不待言说自知是净。世间法净不障他人不知。为欲成彼故。说离烦恼。是名彼非相违。能牵无漏故。是故说净。有味爱相应者。若三昧爱相应者是味相应。亦有与余烦恼相应禅等。见疑增上慢修定者。缘缚力禅等爱相应。非余烦恼共相应。非余烦恼能如是缘缚心。如爱为三昧缘缚。有顶无无漏者。有顶有净味相应非无漏。不捷利故。圣道捷利。问曰。此禅何等性耶。答曰

  五支有觉观　　亦复有三受
  彼种种四心　　是说为初禅

五支者除五支故名五支。问曰。除支更有禅耶。答曰。不然。彼支一一是禅各各相支义须分别。分义是支义。如车支如王支。问曰。何者是支。答曰。觉观喜乐及一心。彼觉者正受初分别粗心利义。观者粗心随顺相续法说细。心微细少义也。喜者入定心悦。乐者身心乐离粗重。猗息心调柔方便。一心者心系一缘有觉有观。问曰。初说五支今何故说有觉有观。答曰。支者善有觉有观。此说秽污。三受者此中有三受。三识身乐根意地喜根四识身舍根。彼种种者。梵世种种身彼上下身。以觉观力故生。四心者。彼有四心眼耳身意识。是说为初禅者。此诸法是说初禅。俱生正受此禅中摄

  第二有四支　　种种及二受
  第三有五支　　此禅说二受

第二有四支者。内净是信义也。离初禅欲决定界地过故。正信喜乐一心。彼无共种种身。何以故。无觉观故。成就种种心。或时喜根现在前。有时舍根现在前。彼根本喜根未来舍根。二受者喜根舍根必定意地。如是等事说第二禅。第三有五支此禅说二受者。第三禅五支舍念安慧乐。一心乐着乐故不求余名舍护。喜食故名念。恐第二禅地喜牵自地过。一切世间胜乐对治。及正智乐意地乐根一心名定。二受者乐根舍根。此中二受乐根舍根。此等法是说第三禅

  离息入息出　　第四有四支
  支者谓说善　　随事如先说

离息入息出第四有四支者。第四禅无出入息。三昧力故。彼身无孔。四支者彼不苦不乐受舍念清净一心。问曰。味相应等三种禅悉成就耶。答曰。支者谓说善。善禅与支相应。当知非秽污。问曰。秽污中无何者。答曰。初禅中无离生喜乐。问曰。秽污中亦有喜何故言无。答曰。猗乐彼离生与喜相应。故说离生喜乐。此一向善故彼无。余者有喜。于此有喜彼非支秽污。第二禅无内净烦恼浊乱故。猗乐先舍。是故第三禅中无忆念安慧。最胜乐惑心故无忆念。若彼有念者是失念。失念故非支。非安隐非安隐故非支。舍亦无。一向善故。第四禅中除。何以故。二种等故。第四禅无舍。念清净非善故无舍。烦恼染污故念不清净是故非支。彼或失念故非支随事如先说者。若事善禅中已说。秽污禅中不除。彼秽污禅中亦说。彼初禅中觉观一心。余人欲立喜者。是故秽污初禅四支。彼第二禅喜一心余人欲立信者。是故第二禅三支。第三禅乐一心。余人欲立念慧。是故第三禅四支。第四禅不苦不乐一心。亦有欲立念者。是故第四禅三支。一切摄故说支是善。问曰。已说初禅有觉有观。未来禅中间禅初禅摄。彼云何彼中有觉观。答曰

  相应有觉观　　智说未来禅
  观相应中间　　明智之所说

相应有觉观智说未来禅者。未来依有觉观。观相应中间明智之所说者。中间禅有观无觉。何以故。止息地故。次第方便人相续止息。问曰彼何自性答曰

  未来二自性　　或离味相应
  中间禅三性　　二俱有一受

未来二自性或离味相应者。未来禅净无漏二非味相应。正受爱故说味。厌离欲道于中无执着。是故无味受生爱不除。何以故。于彼连节缚故。未来禅连节缚堕。中间禅三性者。净无漏味相应。二俱有一受者。未来禅中间禅必定一受谓舍根。问曰。何故未来禅无喜。答曰。有怖畏故。近欲界故。彼行者有怖畏。是故彼中喜不生。所作未究竟故。欲界离故。彼起此未得。是故所作未究竟是人不生喜。又止少故。中间禅亦止少。是故彼中无喜。已说地。彼中功德今当说

  三昧通无量　　一切入处修
  除入及诸智　　解脱于中起

三昧者三三昧。空无愿无相。彼空有二种。有漏无漏。有漏者有漏无漏法空无我思惟。无漏者有漏法空无我思惟。若三昧无愿亦二种。有漏无漏。有漏者有为法无常苦因道等行思惟。若三昧无漏者。有漏法无常苦因道等行思惟。若三昧无相者。灭等行思惟。若有漏无漏三昧此中一向取。无漏当知。通者六通如智品说。无量者。四无量慈悲喜舍。此无量众生缘故。故名无量。彼慈者欲令一切众生得乐。如是想心转恚对治。是无恚善根性故说名慈。苦众生如何得脱。如是想转害对治。无恚善根性名悲。喜众生如是想转嫉对治喜根名喜。舍者舍众生想。如是心转欲爱嗔恚对治故。无痴善根性是名舍。彼一切共伴共方便。欲界中四阴性色界五阴性。一切入处修者。十一切入。如修多罗中说。彼中八无贪善根性贪对治故。及伴及方便五阴性。于上四阴性相续无间无有空缺。广作意解。是说一切入处。除入者八除入。如经中说。彼一切无贪。贪对治故。及伴及方便。欲界是四阴色界是五阴。能映夺缘故名除入。极增上极光曜极最胜缘此善根速得除入。如奴虽庄严犹为主欺。或说非一切圣人能欺缘。彼依缘烦恼不能起。是故名除入。智者十智如智品说。解脱者。八解脱如经说。彼初三解脱不贪善根。贪对治故。共伴共方便五阴。性余四无色解脱四阴性。灭尽定不相应行阴性。问曰。解脱有何义。答曰。不现前断后心故名解脱。初三色贪背舍故。净不净背舍。于上四种一切行转背舍。想受灭一切缘转背舍。及断后故。于中起者。三昧等解脱边功德禅中生。当知已说解脱边功德。今随彼彼地可得今当说

  五通四禅中　　及见他心智
  六中有法智　　五中三无量

五通四禅中者。五通摄受支三摩提故。及见他心智者。他心智亦如是。六中有法智者。法智六地四根本禅中间及未来。五中三无量者。五地中除喜无量。四禅中及欲界

  除入中说四　　及与喜无量
  亦二种解脱　　初禅第二禅

初四除入及喜无量初第二解脱。初禅第二禅欲界色贪对治故。初禅中立二解脱。四除入初禅地色贪对治故。第二禅立二解脱。四除入第二禅无色贪。何以故。眼识身无故。是第三不立解脱。是故是中亦不立除入及一切处。欲入解脱中入除入欲入除入故。入一切处。彼为胜乐所惑。彼不能生如是善根。喜根亦如是。故初第二禅中有非余禅

  余有四除入　　及与一解脱
  亦入一切入　　佛说最后禅

后四除入净解脱。及八一切处。在第四禅非余

  余脱自名说　　二一切亦然
  灭尽最在后　　余无垢九地

余脱自名说者。无边虚空处解脱。乃至非想非非想处解脱。二一切亦然者。余自名说无边虚空处无边识处。灭尽在后者。决定有顶摄。随顺断后边次第下地心心数法断已。乃至非想非非想地初断上上。次断上中。后断下下。一切断已彼灭尽定。余无垢九地者。若余无漏功德。所谓三三昧七智及漏尽通彼九地中四禅中三无色中未来中间世智。有顶处亦有。是故说遍一切地

  三解脱当知　　有漏及无漏
  定智通已说　　其余悉有漏

三解脱当知有漏及无漏者。无边虚空处无边识处不用处解脱。当知有漏无漏。定智通已说者。定修多罗品当更广说。彼无漏智神通智品已说。其余悉有漏者。如是三通威仪故。受色声自相故。无量众生缘故。一切除入初三解脱。彼一切信解念处故。非想非非想非捷利行故。想受灭无慧故皆有漏

阿毗昙心论经卷第四阿毗昙心论经卷第五

        法胜论大德优波扇多释

        高齐天竺三藏那连提耶舍译(六卷成部)

    定品之二(别译)

已说功德自性。亦说有漏无漏。成就今当说

  当知未离欲　　成就味相应
  离下未至上　　成就净诸定

当知未离欲成就味相应者。若人若此地未离欲。成就此地味相应。离下未至上成就净诸定者。离欲界欲未生第二禅等中梵世。若离欲若不离欲。成就净初禅。及彼地余善功德

  住上应当知　　成就下无漏
  方便生功德　　当知非离欲

住上应当知成就下无漏者。圣人生梵世上。成就无漏初禅及余无漏。三昧神通及智等诸功德。彼地有漏功德生处缚。无漏断缚。是故离生处舍有漏非无漏。如是一切地随其义说。方便生功德当知非离欲者。已说离下地欲成就诸功德。当知说得成就不现在前。方便现在前者彼非离欲。方便得者如天眼耳。彼无记故。无漏净味相应不摄。是故得彼三种禅时不得灭尽。是灭尽定者方便故。彼得现前二十三种正受。八味相应八净七无漏。问曰。彼中一一几种因。答曰

  所谓无漏定　　一一七种因
  味净相应禅　　当知因有一

所谓无漏定一一七种因者。一一无漏七种无漏中。自分因中因自地者。亦相应共生因。味净相应禅当知因有一者。味相应初禅味相应初禅因非余。初禅因不相似故。非余地秽污因行相违故。非秽污行相违亦非自分。如是净初禅净初禅因。非秽污非无漏。何以故。不相似故。非余地净因自地果报故及自地系缚故。如是一切。问曰。一一次第生几种。答曰

  无漏禅无色　　逆顺超次第
  次第生六种　　当知乃至十

无漏初禅次第生六种。自地净及无漏。如是第二第三禅如是超越正受。无漏无所有处次第生七。自地二下地四上地一。无漏第二禅次第生八。自地二初禅地二上地四。无漏无边识处次第生九。自地二下地四上地三。余无漏次第生十。自地二下地四上地四

  或六至十一　　谓净次第生
  从二乃至十　　当知说有味

或六至十一。谓净次第生者。净非想非非想处次第生六。自地味相应及净下地四。净及无漏非味相应。离欲故。净初禅次第生七。自地三上地四。净及无漏净不用处次第生八。自地三上地一下地四。净第二禅次第生九。无边识处次第生十。余十一。如是一切当知正受时如是说非死时。是故彼中上下地味相应不摄生。得净次第上下味相应生。从二乃至十当知说有味者。味相应初禅次第生二。自地味相应及净。彼此不相违故。有顶味相应次第生十。正受味三自地二。及下地净自地烦恼所恼故。依不用处地净以自救护。如是一切地下地净三。及死时上地退下地一切味相应。问曰。前说正受。烦恼今当说。答曰。净次第正受烦恼说味相应。及受生烦恼。何以故。烦恼力生非定力。是故此中说一切烦恼净必定定力。是故说共正受烦恼。问曰。彼中一一缘几种。答曰

  净及无漏禅　　一切地中转
  自地有漏法　　味相应所缘

净及无漏禅一切地中转者。净及无漏禅缘一切地一切事。自地有漏法味相应所缘者。味相应禅缘自地味相应。及净非无漏。何以故。非无漏缘。有爱亦非爱他地

  无色则不行　　于下有漏事
  若根本彼善　　秽污如味禅

无色则不行于下有漏事者。无色正受不缘下地有漏法。何以故。下地不寂灭故。亦缘下地无漏。如比智分。问曰。一切有漏不缘下地耶。答曰。不尔。若根本彼善。若根本无色净及无漏。彼缘自地及上地不缘下地。未来禅若缘下地。彼于下地粗想缘厌离秽污。如味禅者如味相应禅说。无色秽污亦如是

  色界若有余　　无量等功德
  彼欲界境界　　世尊之所说

若色界功德。谓四无量一切处。等彼缘欲界。何以故。除神通说无量等。彼五神通缘欲色界。问曰。如前说熏禅中修智。彼云何熏。答曰

  若能熏诸禅　　是依第四禅
  三地爱尽故　　净居唯广果

若能熏诸禅是依第四禅者。得第四禅能熏禅非余。彼人数数入无漏四禅起无漏。数数入有漏禅复还入无漏。还入有漏渐略乃至住二刹那。如是方便若一无漏心若一有漏心。是时一念有漏一念无漏。二念一有漏一无漏。是说成就。问曰。此何处得果。答曰。净居天中。何以故。三地爱尽故。净居唯广果。若得第四禅离三地爱。是故此得第四禅人。净居广果中凡夫共修熏禅。不与凡夫共。五种者。下中上上中上上。彼如是五种不广天无热天善见天善现天及色究竟天。是故彼中得果。问曰。如前说七种愿智是云何。答曰

  无著不动法　　得一切正受
  彼三昧智力　　能起顶四禅

彼人烦恼不能逼恼心相续故一切正受力心相续生故得三功德。谓愿智无诤及无碍。彼愿智者。若欲知过去未来现在及无为。彼时愿智边际。住第四禅正受能知。无诤名于他相续中。烦恼诤不欲起。此人他相续中。不起烦恼诤。无碍名如前说。问曰。愿智何地摄。答曰

  三地有愿智　　无诤五地中
  二地法辞辩　　二辩依九地

三地有愿智者。第四禅初禅及欲界。决定第四禅中得。欲界唯人中能起欲界。梵世相应心记起言说心。彼处有。是故说三地。无诤五地中者。根本四禅及欲界。此决定于四禅中得。人中能起非余处。二地法辞辩者。法辩欲界梵世。此五地根本四禅及欲界。此但名缘言从名转。是故起语言道。有觉观处说辞辩。欲界及梵世。何以故。言语缘故。二辩依九地者。义辩乐说辩。欲界四禅中及四无色定。未来中间禅根本初禅摄。问曰。云何得此正受。答曰

  离欲及受生　　而得于净禅
  秽污退及生　　无漏唯离欲

离欲及受生而得于净禅者。净初禅二时得。离欲时得及上地没生梵世。彼地过舍。如是一切。秽污退及生者。味相应禅退上得下。或第二禅中若欲界缠若梵世缠退。尔时得味相应初禅生得者。如上地没生欲界及梵世。尔时得味相应。初禅如是一切。无漏唯离欲者。无漏禅离欲得。谓圣人离欲界欲。彼得无漏初禅。昔所未得故得。如是一切。问曰。此功德何者能除烦恼。答曰

  无漏除烦恼　　正受中间者
  一切定中间　　相应于舍根

无漏除烦恼者。无漏禅无色除烦恼非世俗。问曰。何故世俗不断烦恼。答曰。同一系缚故。世俗共烦恼一缚。是故自地烦恼不能断。如人被反缚不能自解。若彼对治及断中生。问曰。一切世俗不能断烦恼耶。答曰。有世俗能断烦恼。问曰。何者是。答曰。正受中间者。谓未来禅犹未得根本禅。若作方便得离下地欲。彼初禅未来有漏无漏。余未来一向有漏。为根本禅无色正受。是故说世俗不断烦恼。问曰。此近禅何处。答曰。一切定中间相应于舍根。一切正受中舍根相应。未得所求故不生喜。问曰。虽说神足境界智证神通。未说几种变化心今当说。答曰。十四欲界初禅果。初禅地初禅果。欲界二禅果。初禅地二禅果。二禅地二禅果。乃至第四禅亦如是。问曰。彼谁成就。答曰

  下地变化心　　成就彼种果
  随彼识相应　　彼上地成就

下地变化心成就彼种果者。若人成就禅。是人成就彼果下地变化心。如得初禅是初禅地欲界中初禅果。成就如是一切应当知。问曰。汝先说第二禅等无五识身。若生于上若欲见闻。彼云何见闻。答曰。梵世识现前。问曰。何故上地无此识。答曰。无觉观故。问曰。彼几时成就。答曰。随彼识相应。彼上地成就。乃至彼识相应尔时成就。或眼识或耳识或身识。随尔时现在前尔时成就。此识灭时名舍。何以故。系属根故

    修多罗品第八

一切智口所说最深微细义。此余我今当说

  一切智口说　　甚深微细义
  我今说少分　　修多罗谛听

问曰。如佛说三界。彼何者是。答曰

  欲界十居处　　色界说十七
  无色界有四　　决定唯彼有

欲界十居处者。谓地狱畜生饿鬼人六欲界天。种类此十居处。当知说欲界。此众生有欲想转。若此处具足彼一切爱欲相应。是故说欲界。色界说十七者。梵身梵富楼。少光无量光光曜。少净无量净遍净。无荫福生大果无想众生。不广不热善见善现色究竟。此十七居处说色界。此居处欲想不转。彼极大色非男女相。是故说色界。无色界有四者。无色界有四居处。无边虚空处。无边识处。无所有处。非想非非想处。此居处中色不生。何以故。离色欲故。又次第灭故。若无色中生色者。便无次第灭。然有次第灭。若无者。应色中生欲过。是故无色中不生色。是故说无色。问曰。如佛说三有。欲有色有无色有。此云何。答曰。决定唯彼有。前所说界此即是有。问曰。如世尊说七识住。彼何者是。答曰

  善趣是欲界　　及色界三地
  无色亦三地　　当知为识住

欲界善趣数。谓人天。色界前三地。无色界前三地。此七地说识住处。问曰。何故三恶道第四禅有顶不说识住耶。答曰。若地为见断修断。若不断生识彼说识住。三恶趣中无不断事。第四禅中无想众生。及净居天。无见断事。是故第四禅不摄。有顶一向有漏。若识乐住说识住。三恶道中识不乐住。何以故。苦逼迫故。净居天向涅槃故识不乐住。无想众生亦一向无心。是故第四禅不摄。有顶行不捷利。是故彼亦不摄。三种众生或乐境界乐乐乐想。彼中乐境界众生人及欲界天。乐乐三禅地乐想三无色。是故彼说识住。问曰。九众生居云何。答曰

  有顶及无想　　是说众生居
  四种有漏阴　　当知识住处

有顶及无想是说众生居者。前说七识住。及无想天有顶。此说九众生居。问曰。何故恶道无想众生外。第四禅不说众生居耶。答曰。随何处乐住不欲去。彼处名众生居。恶道中无此二。广果中虽欲乐住亦欲乐去。问曰。如佛说四识住。彼云何。答曰。四种有漏阴。当知识住处。有漏色受想行。是名阴说识住。取俱识生住执着长养故名识住。是故无漏非识住。彼坏有故。彼亦非取和合识住处。问曰。何故识非识住处。答曰。彼因由不成。如王道王非是道。无住分俱生识名住处。三和合名住处。此识非如是。问曰。无有他识现前缘耶。答曰。自和合不生故。彼亦不成就彼。亦众生数非众生数。问曰。云何外识。住处事作。答曰。和合俱生依缘住多故无过。彼亦缘住彼自分地界非他分地界。问曰。如世尊说十二缘起。彼有何相。答曰

  诸烦恼及业　　有事次第生
  当知是有支　　众生一切生

无明爱取是烦恼。行及有是业。余支是事。如是此烦恼业事。彼彼生中次第起故说缘起支。彼中烦恼依事。烦恼作业业作事。如是

  彼诸分建立　　谓众生受生
  过去及未来　　中间当知八

彼诸分建立谓众生受生者。此分差别说十二支。问曰。此云何。答曰。过去及未来中间当知八。于中无明者过去烦恼。行者过去业。识者相续心及眷属名色者已受生相续连缚不灭。未生四种色根六入未具。是名名色。六入者已生四种色根。未能为触作所依。是时名六入。触者此诸根已能为触作所依。未能分别苦乐。不能分别利衰。是时名触。受者能分别苦乐利衰因。能知差别食分别爱不起淫欲。是时名受。爱者于欲具中。爱求欲不能求有分别。是时名爱。取者能取有分别。有者此于彼境界求趣向速疾。广生诸有趣当来生。是时名有。生者彼死次第相续连节缚。是时名生。老死者次后名色受等是名老死。问曰。世尊说六界。此云何。答曰

  所谓四大种　　及诸有漏识
  亦色中间见　　是界说生本

所谓四大种及诸有漏识亦色中间见者。四大及五识身有漏意识。若色孔眼所取虚空数。此说六界。问曰。何故十八界中。别说六界耶。答曰。是界说生本。彼法生本此中丈夫想。地所成立。水和合润渍。火熟除臭烂。风界推。空中间孔。饮食入出。相应识力建立得名丈夫想。是故此名界想。何以故。是生性故。如世尊说。因六界因缘入母腹胎。修多罗句如是。彼大亦生是故名大生。如大众生如大生。于此中地坚相水湿相火热相风轻举相。色边受色相名虚空界。色者是与思异事也。识者了知相也。问曰。圣谛有何相。答曰

  果相似诸行　　有漏是说苦
  因相似是集　　灭谛众苦尽

果相似诸行有漏是说苦者。一切有漏行从因生。逼恼相是故说苦。因相似是集者。一切有漏行他因相似。是故彼说苦集。如一稻种子前后相望故。亦说果亦说因。如是有漏行观已生当生故。亦说苦说集。灭谛众苦尽者。一切有漏行究竟尽灭。是说灭谛

  若无漏诸行　　是说为道谛
  彼二种名故　　从粗次第见

若无漏诸行是说为道谛者。一切无漏行说道谛。彼一切苦灭故说道。问曰。何故说名谛。答彼二种名故。二种事故名谛。谓自相不虚。及见彼生不颠倒心觉。问何故虚空非数灭非谛摄。答曰。非因果故。此观察苦尽故。观察圣谛彼非苦苦因非离苦方便。但欲尽苦故观察。譬如病因病药。病差如观察病。问曰。圣谛有何义。答曰。圣者如实觉已。为他显示故名圣谛。是中逼迫相是苦。生相是集。寂静相是灭。出离相是道。问曰。如见因有果。何故佛先说果后说因耶。答曰。从粗次第见。如是但见无间等故世尊前说果。行者先得苦无间等。后苦因。先灭后道。何以故。先知果已。后断因。修智生故。彼行者于苦自性无间。已彼时为断苦因。故决定智生是过患因故。如是彼行者先见灭相。彼时为欲证灭。故修方便生决定智。是故先说果。如是先见粗后见细故。苦粗集细施设推求故。信故灭粗道细。是故先说灭后说道。如修多罗说。比丘当为说灭为趣灭故说道。如是等。是故先求灭后修道。如向城道先觅道已然后得入。一切皆信灭而不信道。是故欲易知故从粗次第说。问曰。世尊说四沙门果。彼几事。答曰

  圣果事有六　　最胜在九地
  第三在六地　　二种依未来

圣果事有六者。六事说沙门果。五无漏阴及数缘灭。问曰。沙门果何义。答曰。圣道说沙门。彼精进成就故名沙门果。问曰。世俗道亦精进丈夫得。彼亦得沙门果。答曰。彼见圣道果差别。问曰。此何果何地摄。答曰。最胜在九地。阿罗汉果九地摄。未来中间四禅三无色。第三在六地。阿那含果六地摄。除无色。二种依未来。须陀洹斯陀含果未来摄。何以故。未离欲故。问曰。迹有何相。答曰

  随信行诸法　　无烦恼钝根
  随法行诸法　　无烦恼速相

随信行诸法无烦恼钝根者。随信行人自身无漏法软分摄者。当知钝信行摄故。信解脱时解脱亦摄。当知软根故。随法行诸法无烦恼速相者。随法行自身法利根所摄故。当知速相彼摄故。见到不时解脱法亦摄。当知。何以故。利根故

  彼禅根本中　　当知是乐通
  小及难得故　　当知余说苦

彼禅根本中当知是乐通者。根本四禅若软根法。及利根法当知乐迹。止观等得道故及乐行故。小及难得故当知余说苦者。余者无漏地摄道名苦以少故。彼未来中间禅止道少。无色中观少无漏。未来禅难得。何以故。世间从未来得故得彼故易修。禅中间禅一地中间心心数断除现前。谓觉断观现前成就如木断木。无色界微细难成就五阴转断。四阴转现前。彼难如是难得故说难。非圣道苦自性非苦受相应。此中建立胜道故。入涅槃城义故名迹义。问曰。不坏净云何。答曰

  佛及声闻法　　解脱亦余因
  清净无垢信　　圣戒谓决定

佛及声闻法解脱亦余因清净无垢信者。一切种正觉智菩提佛。彼阿罗汉摄功德佛法。当知于彼中若无漏信彼名佛不坏净。他教授得正决定声闻。当知彼中学无学得声闻法。若彼无漏信彼是僧不坏信。若于涅槃若无漏信。转余有为法中。如苦谛集谛等信如是无漏。菩萨功德学无学辟支佛法。一切法中不坏信。彼苦集中正信清净。灭道中希求信。无漏戒圣道俱生第四不坏净。云何名不坏。知已决定清净信名不坏信。问曰。何所知不坏。答曰。四圣谛中。问曰。何故无漏不坏信。答曰。决定故彼实智俱生无漏信。及戒决定有漏信者。能障欺呵不信。持戒破戒呵欺障。无漏余不生能障欺呵。是故决定无漏不坏信差别者。问曰。修定有何相。答曰

  初禅若有善　　当知现法乐
  谓得生死智　　是说名知见

初禅若有善当知现法乐者。净及无漏初禅现法乐住。是名修定得现法乐。谓得生死智。是说名知见者。生死智通是说修定得知见

  慧分别当知　　方便生功德
  金刚喻四禅　　是名为漏尽

慧分别当知方便生功德者。所有方便生功德。乃至欲界有教戒闻思修功德。三界中随所有。若有为无漏。彼一切说名修定得分别慧。金刚喻四禅是名为漏尽者。金刚喻定者。最后学心彼共眷属相应。第四禅地漏尽故是说修定。此世尊自说已功德。菩萨阎浮提树影中。初禅正受彼见法乐住。十一起烦恼清净天眼智见。如趺只罗经说。彼经说知受生如是等慧差别。依第四禅无上正真道证漏尽。问曰。如意足何自性。答曰

  善有为诸法　　方便之所起
  佛说如意足　　是亦说正烧

善有为诸法方便之所起佛说如意足者。若彼方便所起法。已说彼一切如意器故说如意足。自心自在起种种功德。成就如意足名如意足。足支具因一义也。何者是谓三昧。彼四种增上差别。如欲增上生三昧名欲三昧。如是精进心增上生名简择三昧。初起欲故欲增上。欲生已欲所求为得故。精进定增上起精进已。不舍精进随顺趣向心名心定。此欲精进心道理现前。如意足具身中究竟故名慧三昧。若不简择余此一心一切成就。一切心中生故方便差别。彼增长故说余功德。彼亦说正烧。此如是所说功德亦说为正烧。依道理能烧烦恼草故名正烧。或以能断烦恼故说正断。入正决定故名正胜。彼舍过恶功德生。守护增长策勤业名精进正胜。彼四种业差别故。一心建立精进能作四业。现在烦恼得断。未来不生。于善法容受生故。生已相续不失方便力。彼亦四种差别

  彼亦说念处　　亦说四圣种
  随其势力生　　以彼名说彼

彼亦说念处亦说四圣种。彼前所说功德说念处如修多罗。身受心法内外俱自相共相是名念处。彼四种缘差别故。彼一切缘分齐差别故。身念处身缘非余法。如是受念处说受念处非余心念处。说心念处非余法念处。二种余法缘。以想阴行阴有为缘。及坏缘。以身受身心受。如是等乃至一切法缘。问曰。云何圣种。答曰。圣种亦如是。彼所说功德亦说圣种。圣以此为种故名圣种。此法自性是圣种故说圣种。于此种中生故名圣种。四种爱生对治故。说四差别。因衣服故爱生。广说四种如修多罗。问曰。云何以此功德为如意足。乃至四正断等耶。答曰。随彼势力生以彼名说彼。此法以定力生故名如意足。精进力生故说正断。念增上生故说念处。知足增上生故说圣种。已说助菩提分。共此自相今当说

  净信精进念　　智慧及喜猗
  觉分及与舍　　思戒三摩提

如佛所说三十七助菩提分法。彼名有三十七事有十。于中信等如偈中结集。彼中信根信力名信。正断精进根精进力精进觉支正精进。此是精进。念根念力念觉支正念。是名念四念处。慧根慧力择法觉支正见。是等名慧。喜猗舍觉支。正思惟戒。是正语正业正命。如意足定根定力定觉支正定八支是定支。问曰。何故如是多种说。答曰

  处方便一心　　软及利亦然
  见道亦修道　　故说三十七

处者正缘处故说念处。方便者正方便说正断。一心者一心中住处。是故说如意足。软根相续见名根。利事此亦是根利根相续见故名力。彼中增上义是根义。余不能陵名力见道得见故名道分。修道见故名觉支。说三十七。此十法如是各各业差别故佛说三十七。此中觉支一向无漏。余有漏无漏。问曰道品云何有漏。菩提是无漏。彼菩提器菩提眷属。是故名菩提分。如是此中与菩提远有漏。随顺菩提故名菩提分。是故无过

  二禅三十六　　未来禅亦然
  三四及中间　　是悉三十五

二禅三十六者。除思何以故此地无觉观故。未来禅亦然者。亦三十六除喜觉支。何以故未成就是故无喜我已先说。三四及中间是悉三十五者。第四第三中间三十五除喜除正思惟

  初禅说一切　　三空三十二
  有顶二十二　　欲界亦如是

初禅说一切者。初禅中一切三十七。三空三十二。除喜正思正语正业正命。有顶二十二者。一切无觉支道支是故二十二。随何处觉支次说道分。彼中当知有漏无漏。欲界亦如是者。欲界亦二十二。一向是有漏二处一向有漏故。问曰四食何地何性。答曰

  诸食中抟食　　欲界说三入
  识食及思触　　是食说有漏

诸食中抟食欲界说三入者。抟食是欲界三入香味触。事有十三十一事是触。四大七种造色。所谓涩滑重轻冷饥渴及香味。问曰何故色声非食。答曰见闻非增长。满足根大资益义是食义。或见或闻妄分别力故生。乐受触生喜彼喜不能润益根大。是故触为食能利益。非色声香味离分别亦能资益身。识食及思触是食。说有漏者识思触是有漏。彼持生相续缚能牵有是故名食。无漏触等虽利益诸根大。彼不能牵有故断除有是故非食。有三种事故名食。能牵后有。牵已复牵摄持自身是故名食。彼意思识牵未来有。抟食触食生已诸有摄持。或复一切诸食皆能牵有。皆能摄持诸根。问曰先所说诸三昧。何者三昧几种转。答曰

  无愿有十行　　空二行当知
  四行说无相　　是说为圣行

无愿有十行者。无愿三昧总说十行。缘三谛故十行转。苦中无常苦二行。集中四行如前说。道中四行亦如前说。问曰何故不缘灭。答曰不愿求故名无愿。是不乐求义也。不愿何等谓苦彼因尽则无。是故彼因亦舍彼因修道尽是故缘道。是故此定缘苦因道不缘灭。或复说于有为不愿是故缘三谛。是中修道如服苦药。如是如空二行当知。身见近对治故。空三昧有二行。何等为二。空无我。身见取我我所行见。我对治故说无我行。我所对治故说空行。如彼法无我是故无我。四行说无相者。无相三昧灭四行转。除有为行但缘于法。行说无相此中显示解脱门。故一向无漏三昧。问曰颠倒云何断何自性。答曰

  谓彼四颠倒　　当知见苦断
  于彼增上见　　见实者废立

谓彼四颠倒当知见苦断者。一切四颠倒依苦转。是故见苦断已说三见中。于彼增上见者。此四颠倒三见中少分是见自性。经中想心浊故说想心倒。见实者废立。何以故增上见中。若得增上如是力颠倒建立。如我见颠倒非我所见。如是边见常见颠倒非断见。见取净乐见颠倒。问曰谁增上。答曰推建立一向颠倒。是故颠倒彼如是想。是故非一切见是颠倒。邪见断见虽推及一向倒。坏事转建立戒取。推建立非一向颠倒。取少净非胜见胜取少胜。我见力建立我所。是故我所见不立颠倒。问曰世尊说多见如六十二见彼见何见摄。答曰五见摄。问曰此云何。答曰

  诽谤于真实　　此见说邪见
  非实而建立　　二见及是智

诽谤于真实此见说邪见者。若见谤真实有义言无所有。如无施等是为邪见。非实而建立二见及是智者。于阴中非实我所建立身见。非真实乐净建立见取。若余非实建立。如见杭建立人想。邪智非邪见

  又戒威仪取　　非因而见因
  若摄受边见　　依常见断见

又戒威仪取非因而见因者。如自在天因牛戒见等。生天世间流转解脱。若摄受边见依常见断见者。若见诸行常是名常见。如说常者彼不知因果连续。是故于事中立断是名断见。是二见名受边见。除此更无余见。是故一切见入此见中当知。问曰此见何断何不断。答曰

  诽谤而建立　　因见依二边
  随于此事转　　若见彼则断

诽谤邪见已说。彼若谤苦彼说见苦断。如是集等建立不实说二见。彼身见于苦建立见苦断。见取若见苦断乐等建立是故见苦断当知。如是见集断等戒取。若依于有漏转彼见苦断。若依无漏转彼见道断当知。断见常见依苦转。是故见苦所断

阿毗昙心论经卷第五阿毗昙心论经卷第六

        法胜论大德优波扇多释

        高齐天竺三藏那连提耶舍译(六卷成部)

    修多罗品之二(别译)

问曰。世尊说二十二根。彼云何。答曰

  谓眼等四根　　身根有三种
  如意根及命　　此根生死依

谓眼等四根者。眼耳鼻舌。彼眼根眼识依净色。于色已见今见未来或当知此。或复有异彼余自分。问曰何谓自分。答曰彼相似义也。如色不曾见今不见当不见。何以故识空故。如是一切如识自依说。身根有三种者。身根亦如是。彼说三种身根男根女根。如意根何者意根。若心意识彼复六识身。若已知法今知法当知法。或复是自分彼无生法如是当来。及命者命根第九彼三界寿。此根说生死依故说根。众生生死故

  受是烦恼伴　　信等依涅槃
  九根若无漏　　此三依于道

受是烦恼伴者。苦乐忧喜舍受。杂烦恼烦恼伴依地故说根。信等依涅槃者。言精进念定慧依寂灭伴故说根。九根若无漏。是三依于道者。信等五喜乐舍意根等。有漏无漏此中若无漏。彼依于道三根说。如贤圣品说。如是诸根名二十二。事十七。男根女根身根少分。三无漏无异。问曰何者是根义。答曰彼增上义是根义。如人主兽王一切法有增上主。彼最胜增上主名根。彼取六境界增上主。男女二根众生差别分别增上主。初时无差别。命根持众生身增上。受有烦恼增上。信等涅槃增上。无漏道差别增上

  欲界四善八　　色种根有七
  诸心数有十　　一心智者说

欲界四者。如是根四在欲界。男女忧苦决定欲界相应。问曰何故色界无男女根。答曰无受用事故。鼻舌二根亦应无。为端严身故生无妨。又男女二根令身丑恶故无。无苦根非逼迫果故。彼他不恼故无忧根。何以故无知生故。彼智知欲界。余色根意根界品已说。舍根信等五根三界相应不相应。喜乐根色欲相应不相应。无漏三根决定不相应命根。杂品当说。问曰几善。答曰善八。信等五三无漏必定是善非不善。余忧根受等善不善无记忧根命根后当说。余如界品说。如是取色七者眼等五及男女根。此等是色余非色。问曰几心性几非心性如是广说。答曰诸心数有十。五受五信等。一心智者说者。意根一种心自性。无漏前已说九根无漏。三余非心心数决定。问曰几有报几无报。答曰

  一及七有报　　此义应当知
  十三中是报　　见实者所说

一及十有报此义应当知者。忧根一向有报。何以故善不善故。问曰何故忧根无记无。答曰忧根与喜下劣行相违。非身边见相应故。非隐没无记分别转故。非不隐没无记。非工巧报生威仪等分别生。若彼分别生谁在于后。非离欲灭离欲不断故。非不隐没无记。是故非不隐没无记。忧根信等中若有漏彼有报。若无漏彼无报。意根及三受若不善善有漏彼有报。无记无漏无报。苦根善不善有报。无记无报余根非有报。问曰何故不善善有漏有报。答曰坚固住故资助力。如畦水润粪覆烂坏坚固种子生。非无漏无资缘故。如在仓中种子。虽坚不生爱水不润故。余烦恼如粪无故不能烂坏。非无记有报。如烂种子虽置畦中不生。问曰几根是报。答曰十三中是报见实者所说。七色根意根命根。除忧根四受是有报。亦有非报色长养非报余是报。命根正受果寿行数。彼非报余是报。意根及受善秽污非报。威仪工巧变化心数非报。余是报余根决定非报。问曰几根最初生时得报。答曰

  二或六七八　　初念生时得
  欲中有报相　　色六及上一

若众生根次第生。卵生湿生胎生彼初念二根报生身根及命根。意根彼是秽污是故不取。非秽污心为连系报。非秽污是故非报。舍根亦如是。化生无根六色根五及命根。一切化生不少眼根等。一根七二根八。欲中有报根故。此法用欲界众生当知。色六及上一者。色界得六。无色界一但命根。问曰死时最后舍几根。答曰

  舍四八与九　　亦说舍于十
  渐终及顿没　　善舍各增五

舍四八与九亦说舍于十渐终及顿没者。无记心渐终舍四身意命舍根。无根一时无记心死舍八。谓眼等根命意舍根。一根九二根十不善心亦尔。问曰善心舍几根。答曰善舍各增五。于是中加信等五根。色无色随所得亦如是。问曰几见断如是等应当广说。答曰

  二断无断四　　六根则二种
  三无漏不断　　余则修道尽

二断无断四者。意根及三种受此见断修断。若无漏无断。六根则二种者忧根见修断。信等五根修道断不断。三无漏不断者。一向无漏故。余则修道尽者。余九根修道断。彼眼等八不秽污故。修道断堕生死故非不断。苦根五识身是故修道断。问曰世尊说六识身。彼取何法。答曰

  若取识根义　　五种心境界
  若取一切法　　是则意识界

若取识根义五种心境界者。色等五境界五识身取。眼识取色色形相色者。谓青等无量种。形相者长等无量种。彼眼等不到取眼着药。捭则不见。耳识声亦不到取。鼻香舌味身触此到取。一切五识身能取现在境界。问曰意识云何取。答曰若取一切法是则意识界。若五识身所取。彼若不取过去未来。现在法及无为一切意识取。除彼刹那自体共生相应法。问曰初知不坏境界已说此境界。云何十种差别。答欲界相应不相应如是。色界无色界如是。无漏有为无为善无记。问曰十智一一智几法境界。答曰

  五法应当知　　法智之境界
  七种随顺智　　他心境界三

五法应当知法智之境界者。欲界相应不相应及无漏无为善。七种随顺智者。色无色无漏相应不相应善无为。他心境界三者。欲色界无漏相应

  有漏当知十　　因果智有六
  解脱智一法　　道智二余九

有漏当知十者。世俗智一切十种法境界。因果智有六者。苦集智三界相应不相应。解脱智一法者。灭智中一无为善。道智二者。道智有为无漏相应不相应。余九者。尽智无生智境界九法除无为。无记使境界如前说。复欲总说故说此

  自地诸烦恼　　定使于自地
  自种一切遍　　在彼种类中

自地诸烦恼定使于自地者。欲界一切使所使。欲界乃至有顶地彼地亦然。胜故对治故下地上地不使。离欲现前上地下地不使。自种一切遍在彼种类中者。自种类法自种类使所使。一切遍他类亦使如身见。见苦断使所使见集断等他类亦使。如是一切遍使说。乃至修道断修道断一切使。所使一切遍使

  三界定烦恼　　如是定三界
  如是说二界　　一界生亦然

三界定烦恼如是定三界者。三界摄烦恼中三界使所使。随方便如意根。三界于中一切三界使所使。如是说二界者二界所摄法二界使所使。如方便如觉观欲界及色界。于中欲界色界使所使。一界生亦然者。一界所摄法一界使所使。如忧根欲界于中欲界使所使

  此佛所说经　　若事我已说
  识智及诸使　　观察此三门

此佛所说经中。若我所说法此三门应宣说。识门智门使门。如欲界中根事一切有。是故欲界六识身当知相应不相应故。七智知除比智灭智道智。五种类摄故。欲界一切使所使。色界三根事有此四识识七智知。色无色界一切使所使。无色界无五境界。但一识识六智知。除他心智法智灭智道智。无色界一切使所使。如是一切应当知

    杂品第九

  已说定相续　　种种诸余法
  于上众杂义　　我今当略说

已说定相续种种诸余法者。已说诸法彼此相续种种聚。于上众杂义我今当略说者。于上所说广义今略说

  有缘有相应　　有行及有依
  心及心数等　　是说总略义

此是心心数法名。于种种法中攀缘转故名有缘。俱同行同方便名相应。境界行作故名有行。依根转故名有依

  从缘生亦因　　有因及有为
  说事及世道　　有果此决定

此是有为法名。彼彼缘和合得生故名缘生。他法生故因由因力故。有因诸法和合作故名有为。多因差别显示故名说事。未有有转自相行名世。彼有果名有果

  有罪亦隐没　　秽污下贱黑
  善有为及习　　亦复名修学

有罪亦隐没秽污下贱黑者。此是不善隐没无记法种种名。可厌恶故名有罪。烦恼覆蔽故名隐没。烦恼垢污故名秽污。凡鄙故名下贱。无智闇分故名黑。善有为及习亦复名修学者。善有为法如此名也。智中有或相续此法名智是故善。如世间说善巧人歌舞善巧手。或善者慧名彼慧善谈说故名善。摄取如是义也。功德增上成就说习。亦说修心。不相应行此中当说

  无想二正受　　亦众生种类
  句味与名身　　命根与法得
  谓彼凡夫性　　及诸法四相
  非色不相应　　说是有为行

无想名无想众生生。心心数法不转。二无心定者。无想定灭尽定。无想定名厌于生死解脱想。第四禅力心相续次第中间灭。灭尽定名厌散乱心寂灭想。初住想心思念。非想非非想过恶心心数次第灭。众生种类名一趣生众生。身根长短来去住饮食自共分。句名字集随所欲说义。分齐究竟名句。如婆伽罗那云。言说味者字生。名者随义名也。如牛马等。如毗伽罗论言句。命者随得根大。心和合事次第相续不坏。因得名得法到成就得一义也。凡夫性者。未到正决定聚远离圣士夫法。四相者生老住无常如行品说。非色者。非此法色自性。不相应者不相应无缘也。说是有为行者。行隐摄故。问曰此行几是善如是等广说。答曰

  二善五种三　　当知七无记
  二在于色界　　一在无色地

二善者。无想正受灭尽正受。一向是善有报故。无想正受无想报灭尽正受。除命根有顶四阴。五种三者。得生老住无常等。善中善不善中不善无记中无记。当知七无记者。无想种类句味名命根凡夫性。问曰几欲界如是等。应广知。答曰二在于色界。无想正受广果地故。一在无色地者。灭尽定非想非非想处摄故

  二界三当知　　余在于三界
  有漏无漏五　　其余定有漏

二界三当知者。名句味欲界色界。非无色界离语言故。余在于三界者种。类得命凡夫相。问曰几有漏几无漏如是等。答曰有漏无漏五。得生老住无常相等。有漏中有漏无漏中无漏。得者有漏中有漏。无漏尽为无漏。数灭圣凡夫有漏无漏。非数缘无为唯有漏。其余定有漏者。当知余行决定有漏。问曰离圣法名凡夫。彼云何舍云何断。答曰

  最初无漏心　　是圣不得舍
  愚夫流转界　　离欲时灭尽

最初无漏心是圣不得舍者。圣者苦法忍舍凡夫性。是舍凡夫对治愚夫流转界者。此凡夫事界流转舍。随彼处决舍地生随地得。不隐没无记故如是一刹那得。离欲时灭尽者。随地离欲若凡或圣。彼地凡夫事断。问曰三无为已说彼有何相。答曰

  断烦恼远离　　是名数缘灭
  无诸障碍相　　是名为虚空

断烦恼远离是名数缘灭者。若身见等烦恼数缘力所灭。彼断次第断若远离欲得。彼数分名数灭。无诸障碍相是名为虚空者。容受色无障碍。住来去等事得是名虚空

  依于众缘法　　有依及攀缘
  若不具不生　　此灭非是智

有为法依缘力能生彼无不生。如眼识眼色明空。忆彼生和合意作眼识生余。阙一则不生。若与余识相应。念念眼生灭和合。阙此眼识不生。若彼眼依识欲生彼不生。若彼眼生灭已。彼必定不复生。如是色彼缘阙。彼眼识未来灭不复生。如是余识身如得生说。若彼生灭彼初非智缘。如是事不数数而灭名非数灭。略说未来不生法中。缘阙毕竟不生。自然灭名非数灭。问曰已说有为法因。彼何法何因。答曰

  前因相似增　　或俱依倚生
  二因及一缘　　一向已生说

前因相似增者。前前法如是相似未来因。亦增因非灭因。如软善根软中上自地善根因中增。增增因修习法住增非减。非胜法为下因。或俱依倚生者。如相应共有因。二因及一缘一向已生说者。自分因已生说非未生前生后生自分因。说非未生有前后。如是一切遍因。亦说当知次第缘过去现在。阿罗汉最后心心数除。余过去现在心心数。彼一切名次第缘一种。一种不差别前聚后聚。次第缘故名次第缘。问曰何故色心不相应行非次第缘耶。答曰众杂事色杂如是。一时欲界色界不相应现前。如受戒凡夫及圣人亦不相应行。三界不相应一时现前。心心数不杂事故得名次第缘。问曰报为众生数。非众生数耶。答曰

  报是众生数　　有为解脱果
  有缘说俱转　　谓于他相转

报是众生数者。众生数法必定得名为报。何以故不共故非非众生数共故。问曰报者何义。答曰不相似受故。如善不善无记。问曰果法说何者。答曰有为解脱果。一切有为法善不善无记果。因缘相依故数缘灭。无为者彼说道果。问曰有缘法云何缘中转。答曰有缘说俱转。若法有缘彼一时缘转不别异。问曰何处缘转。答曰谓于他相转。他攀缘义也。非自性自性缘。何以故自性离自性故。一切事中如眼不自见。指端不自触。刀不自割。相应不缘。何以故一缘故。俱生亦不缘太相近故。如眼着药捭眼眵。眼睫太近故不见。自依不能缘。问曰彼有住处无住处耶。答曰

  遍因无处所　　欲生时解脱
  烦恼智心中　　道欲灭时灭

遍因无处所者。此遍因心心数二眼因生一识。如是耳鼻舌识亦然。若有处所应一眼中生。若然者应一眼见非二眼见。或两识生不然是故无处所。问曰何心解脱。为过去现在未来耶。答曰欲生时解脱。欲生时道灭烦恼。是故欲生时得解脱。无学心障中得解脱。问曰道生时断烦恼耶。答曰烦恼智心中道欲灭时舍。道欲灭时断。烦恼欲生是未来。未来道不能作事。是故无碍道欲灭时舍烦恼。解脱道欲生时解脱烦恼得。次说烦恼名。问曰有爱有几种。答曰

  有爱有五种　　无有唯一相
  爱事余烦恼　　断离是三界

有爱有五种者。有爱名有中贪着彼五种。苦集灭道见修道断。无有唯一相者。无有爱名断见。自身断乐。彼亦修道断。何以故见爱见道断。此亦转爱是故修道断。此须陀洹虽不断亦不共行。何以故断见所长养故。彼皆上现前彼须陀洹断尽。因缘相应知故。问曰如世尊说断界离界灭界何者是。答曰爱事余烦恼断离是三界。断爱离界彼爱染着相应事。断灭界彼亦染亦相应。彼若余烦恼断彼断界。彼相应非染。近对治故如是建立。如是一切一相十一心。欲界善不善隐没无记不隐没无记。色界三除不善。无色界三亦如是及无漏。问曰此中几秽污心得几善几无记。答曰

  秽污心得十　　智者如是说
  善心必得六　　无记即无记

秽污心得十智者如是说者。界地地来还二界善秽污隐没无记心得相续心。余无色界善秽污不隐没无记。彼现前事得。问曰欲界色界不隐没无记云何。答曰变化心色界欲生时得。彼禅力得非余。是故非无记得退非无漏。如无学退学得。如是等如是得故缘次第说。非一人一刹那中得十。善心必得六者。善心得六如尽智。欲界善无漏心中。变化心亦无记。如是色界无色界善心及无漏。无记即无记者。不隐没无记心唯得无记心。非余现前亦得前已说。非彼刹那未得心得。问曰十法菩提分彼中几根性。答曰

  菩提分六法　　当知是根性
  诸法若相应　　当知是他分

菩提分六法当知是根性者。信等五及喜觉支。余者非根自性。问曰为自性相应法。为他性相应法。答曰诸法若相应当知是他分他分相应。当知非自性自性伴。一时无二故。问曰何处得解脱。答曰

  缘中得解脱　　大仙如是说
  亦少断而缚　　见道及修道

缘中得解脱大仙如是说者。缘中离烦恼不能于相应解脱。何以故一刹那故。烦恼心一念缘中。众生愚惑于缘不愚。故解脱烦恼成就。问曰若不相应亦断不断耶。所断者相应不相应耶。答曰若不相应亦断。亦少断而缚见道及修道。有少分断亦非解脱。如苦智生集智未生。若见苦断烦恼断。彼见集断一切遍烦恼缚。修道中亦一种断。彼中八种缚乃至八断究竟下下缚。问曰见谛云何得不坏净。答曰

  二觉于三谛　　四由见正道
  能起不坏净　　修习于二世

二觉于三谛四由见正道能起不坏净者。苦集灭无间等。得法不坏净及圣爱戒。彼三法自性故。见道一切得四种佛法僧彼中有故。问曰几世法修。答曰修习于二世。现世修行未来得修。问曰何法随心转。答曰

  一切心数法　　说与心俱转
  若心相及余　　作亦应当知

一切心数法说与心俱转者。一切心数法说与心共行。何以故共心一缘故。若心相及余者。此心相生等彼亦随心转共心一生灭故。及余者。如是余心数相亦随心转。一种方便安隐故。作亦应当知者。此业名也。彼中说心数处。已说思身口业。未尽今当说彼禅道无教戒彼力生故说作。彼随心转心一果故。心作一事一切随心转说。问曰断法云何。答曰

  断诸有漏法　　智者亦无垢
  灭未来说远　　此余说则近

断诸有漏法者。一切有漏法断有过故。是故无漏不断。彼无垢故无过去垢故名断。如衣有垢浣事。问曰知法云何。答曰知者亦无垢。若有漏法及无漏法。是一切知法。一切法智境界故。随方便智如智品说。问曰远法云何。答曰灭未来说远。不办事故四种远。作事远处远相远自分远。不办事远者过去未来世道。处远者海此彼岸。相远者如地与虚空湿与暖异。分远者善法不善法。欲色无色虽一相彼亦是远。此余则说近者。余现在及无为彼当知近。现在能办事故近。无为随处速得。数缘非数缘灭。随处得。虚空者遍一切处。问曰决定法云何。答曰

  所谓无间业　　及诸无垢行
  慧者说决定　　见处是有漏

所谓无间业及诸无垢行慧者说决定者。无间业邪定如是法决定将向地狱故。余亦有恶行决定能趣地狱。彼不定无间非不定。已说决定无垢行正决定得解脱果。除五无间业余者不定。有漏及无为不定。问曰见处法云何。答曰见处是有漏。一切有漏法是见处五见相应故。若此法秽污见缘。相应使俱生伴法中住。彼法名见处。问曰几根众生成就答曰

  说有十九根　　谓成就极多
  极少成就八　　晓了根所说

说有十九根谓成就极多者。若一切多成就根彼十九。如不断善根不缺根二根故。此凡夫是故彼无无漏根不缺根。如是未离欲圣人。彼一根二无漏无。极少成就八晓了根所说者。若一切少成就但八。如余身根断善根。彼有身意命根五受等。及生无色界凡夫彼意命舍根信等五根有。问曰几种触。答曰

  增语及有对　　明无明处中
  所谓得果者　　是则双道事

增语及有对明无明处中者。彼意识相应触增语触。何以故增语依转故。由增语转彼名增语。由意识故语转。是故意识与彼相应触名增语触。或增语名彼意识分别境界非余五识。是故增语境界相应触名增语触。五识身相应触名有对触。何以故有对依缘故。五有对触。秽污无明触。无漏明触非秽污。有漏非明非无明触。问曰云何无碍道得果者。为无碍道解脱道耶。答曰所谓得果者是则双道事。双道俱得果。无碍道断结得。解脱道得解脱证。如以毒蛇一手着瓮中一手蔽头。如怨家一手推出一手闭门。问曰阿罗汉住何心入涅槃。答曰

  无著住报心　　得入于涅槃
  生有及坏有　　本有亦复中

无著住报心得入于涅槃者。一切所作事中平住任运心。阿罗汉住报生心中入涅槃。亦住威仪心入涅槃。何以故任运行故。说住报心入涅槃。彼自然心断随顺故。住无记心入涅槃。善心中相续彼次第心自息。不善心身离欲时舍秽污心。有顶离欲时舍善无记现前。彼最后心是故住如是无记心入涅槃。问曰几种有。答曰四种有。生有及坏有本有亦复中。彼生有者。生刹那若阴生。坏有者死时最后阴。本有名生有死有中间阴名本有。中间有名死已乃至未受生有。此中间处所阴名中有。或有不立中有者。彼人处所中间不相续。彼言不相应。何以故心数依处转见。此心数依处见非余。彼何所依共报身。此不存中阴者。欲界处相续见行相违心数转。是故不生相续。若存中阴者彼依处。如是中有阴生见。法不相违心数转。相应成就处相续故。是故必有中阴。问曰如佛说有厌离。云何厌云何离。答曰

  诸智在苦因　　及忍修于厌
  离欲得无欲　　说在于四中

诸智在苦因及忍修于厌者。苦集缘智及忍说厌厌事转故。离欲得无欲说在于四中者。苦集灭道中智及忍说厌离。能坏欲故。彼中忍见道坏智者。修道无碍道断烦恼不复见道智。无碍道修道中有四智

    问论品第十

  离律不律仪　　而得于律仪
  不因彼得胜　　若能知者说

答曰有无色界没生色界。凡夫法彼人界流转时。舍戒系属界故。是人生色界时。得彼禅戒退分故是故不增

  颇得沙门果　　圣贤离诸过
  得有为善法　　不名为修习

答曰有如本得退得过去彼但得不增。是故名不修习。余习修不能现前。本所得者更得

  颇道兴起时　　未离诸过咎
  解脱时离恶　　能决定者说

答曰有如未来修如前生现前。尽智除。若余未来尽智。彼欲生时得彼时未解脱。何以故本时障解脱。一切未来无学。相续心解脱故

  颇光曜烦恼　　起已定相应
  清净初禅中　　而得于退法

答曰有光曜缠生。退阿罗汉得尽智者。初清净禅尽智力。得彼时舍彼学无学。或熏修初禅等

  颇有见谛道　　得于诸善法
  彼法是有缘　　智者不见缘

答曰有欲界中无间等边得世智。欲界阴不见比智彼无间边得世智。是故彼时不见欲界阴

  颇果有漏慧　　相应净功德
  不相应智慧　　彼时得彼果

答曰有如欲界离欲。非梵世离欲。彼欲界第四禅果。变化心不相应断故。成就彼于此禅中彼果。彼禅中不相应慧不断故。如是色界变化心说。于下上地离欲不离欲

  颇住无碍道　　成就于诸灭
  障碍彼烦恼　　非彼无漏见

答曰有如有漏通生住无碍道。随地通能生彼地离欲。彼有通离欲断。是故彼住无碍道彼远离成就。常相续得远离

  颇有烦恼灭　　无垢者获得
  非舍彼烦恼　　于彼无垢尽

答曰有如光曜中梵世生。欲生时欲界烦恼远离得。如是彼前已断彼远离得。世俗故彼地系属。是故地流转舍。又复还来得彼得名远离得

  颇无垢净地　　未曾得而得
  非离欲非退　　不依于见道

答曰有如色离欲证决定无漏。无色修道中方便得

  颇未得法中　　而得于胜利
  不舍彼不利　　若曾学者否

答曰有彼初生无漏品。除余无漏功德。得时彼不舍凡夫事。苦法忍彼退一切无漏功德。不得凡夫事

大德优波扇多为利益弟子故造此阿毗昙心论

阿毗昙心论经卷第六


鞞婆沙论

    No. 1547 [cf. Nos. 1543-1546]

鞞婆沙论卷第一

        阿罗汉尸陀槃尼撰

        符秦罽宾三藏僧伽跋澄译

  爱乐觉意叶　　清净戒妙枝
  无比三十二　　奇相华严身
  最智甘露果　　坚固精进根
  具足圣道树　　我顶礼如来
  善快说无比　　息道无为城
  归命功德仙　　消除爱忧戚
  离生老病死　　安隐永无欲
  大仙所演法　　我今稽首礼
  妙戒高显现　　山岳不移动
  清净智慧法　　解脱大牟尼
  禅等丛林树　　神足石无边
  圣众大雪山　　我今稽首礼
  如是稽首礼　　世称无有比
  大师广演教　　吾今奉受持
  我说正觉语　　增益无上乐
  圣众等欲闻　　专心一意听

    鞞婆沙说阿毗昙八揵度

杂结使智行四大根定见(迦旃延子造先杂揵度总序曰)

问曰。谁作此经。答曰佛。何以故。答曰。甚深智微妙法性一切智境界。谁有此界。无余唯佛也。问曰。若尔者。云何作。答曰。尊者舍利弗问佛答。复有说者。五百比丘问佛答。复有说者。诸天问佛答。复有说者。化问佛答。何以故。答曰。此法应尔。如知应当说。无能问者。彼时世尊化作化端正极妙。宗敬悦可。剃除须发被僧迦梨。叉手而问世尊答。如彼因缘经所说也。问曰。若尔者。何以故说尊者迦旃延作此经。答曰。彼尊者诵习转教他人广施设。此诵习广施设。谓之造也。或曰。彼尊者迦旃延作此经。问曰。如甚深智微妙法性一切智境界。谁有此界。无余唯佛。云何彼作。答曰。彼尊者本学利作誓愿。于五千佛修阿毗昙。令我于当来三耶三佛施设阿毗昙章句。是故彼妙智观已作此经。问曰。若尔者。佛阿毗昙何者是。答曰。彼佛说道处处方处处城。种种教化故。彼尊者迦旃延子。过去佛法中。以愿智观一向略作揵度品数立章门。于中种种不相似立杂揵度。说结立结揵度。说智立智揵度。说行立行揵度。说四大立四大揵度。说根立根揵度。说定立定揵度。说见立见揵度。如佛说一切法句。彼尊者昙摩多罗。于过去佛法中愿智观一向略。若说无常偈立无常品。至说梵志立梵志品。如是彼佛说道处处方处处城。种种教化故。彼尊者迦旃延子。过去佛法中。以愿智观一向略作揵度品数立章门。于中种种不相似立杂揵度。说见立见揵度。复次一切佛世尊出世说三藏。契经律阿毗昙。问曰。契经律阿毗昙何差别。一说者无差别。何以故。答曰。从一智海出故无差别。大悲出故无差别。欲饶益一切众生故无差别。入一解脱门故无差别。或曰。有差降。契经说种种。律说戒。阿毗昙说相。或曰。契经依力。律依大悲。阿毗昙依无畏。或曰。契经说增上意。律说增上戒。阿毗昙说增上慧。问曰。若尔者。契经亦说增上戒增上慧。律亦说增上意增上慧。阿毗昙亦说增上意增上戒。此何差别。答曰。若契经说增上戒者。当知律。若说增上慧者。当知阿毗昙。如律说增上意者。当知契经。若说增上慧者。当知阿毗昙。如阿毗昙说增上意者。当知契经。若说增上戒。当知律。是为契经律阿毗昙差别。问曰。何以故彼作经者立此经。答曰。饶益他故。勤者闻者受者持者思者量者观者。无量结恶行须臾除。或复依此度法性。譬如人欲益他故于闇冥处燃明。有眼者令见色。如是彼作经者。饶益他故立此经。若有意智者彼依此度法性。佛世尊亦饶益他故。说十二部经契经律阿毗昙何以故。答曰。设众生有因力不缘他力而开解。如是众生不知差降。如缘他力而开解。如是众生知有差降。犹如此中优钵罗钵头摩拘牟头分陀利。池中必有优钵罗至分陀利华。如日天子未出光不照时。华不敷不舒不香。如日天子出光照时华敷舒香。如是众生因力不缘他力而开解。如是众生不知差降。如缘他力而开解。如是众生知有差降。敷信也。舒根力觉道也。香戒也。如彼偈所说

  如盖屋密　　而入闇中　　虽有此色
  眼所不睹　　如是有一　　无智之人
  不闻不知　　法之善恶　　有明有色
  而眼得见　　闻已能知　　法之善恶
  闻法能知　　闻恶不作　　闻除非义
  闻得至灭

如是余契经所说(出杂阿含)。贤圣弟子一心听法。当尔时灭五盖。具满修七觉意。如是余契经说(出增一)。一因二缘发于等见。从他闻内正思惟。如是余契经说(增一四法说)。有四法饶益人。云何为四。亲近善知识。听善法内正思惟。次法向法。如佛世尊饶益他故说十二部经。如是彼作经者。饶益他故立此经。或以三事故。增益智故。开意故。离计人故。增益智者。尽诵内外法无能益智。如阿毗昙也。开意者。众生意在睡眠不知。何者己界一切遍使。何者非己界一切遍使。何者己地一切遍使。何者非己地一切遍使。何者己界缘。何者非己界缘。何者己地缘。何者非己地缘。何者有漏缘。何者无漏缘。何者有为缘。何者无为缘。云何摄。云何相应。云何成就。云何不成就。云何因。云何缘。若此意转不由他度不由他闻。自见自在身作证。由何力。唯阿毗昙也。离计人者。诵尔所阿毗昙前句后何。如是四句不说计人。一切中说无我行。非众生非命非长养非士空净聚也。以三事益智开意。离计人故作此经。或曰。坏无明故。犹如燃灯除去闇冥而生明。如是阿毗昙灯除无明生慧明。是为坏无明闇故。或曰。见无我像故。如镜极磨治谛见其像。如是阿毗昙镜极了觉知谛见无我像。是为见无我像故。或曰。渡生死河故。如依船百众生千众生安隐渡河。如是依阿毗昙船已。无数那术众生安隐渡生死河。是为渡生死河故。或曰。见契经故。如人手执灯见彼彼色不迷惑。如是慧者执阿毗昙已。于彼彼契经不迷惑。是为见契经故立此经。问曰。何者阿毗昙性。答曰。无漏慧根也。摄彼同性故。摄一界一入一阴。少所入及方便及相应及共有。摄三界二入五阴。三界者。意界法界意识界。二入者。意入法入。五阴者。色痛想行识阴。问曰。若尔者。阿毗昙无漏慧根。此经何故名阿毗昙。答曰。此阿毗昙具名阿毗昙。如余具以具为名。乐具乐为名。如所说偈

  彼乐抟食　　乐为持衣　　乐为行步
  依山窟间

垢具垢为名。如彼偈说

  女垢梵行　　女缚世间　　苦行梵行
  此洗无水

使具使为名。如契经所说(出杂阿含)。比丘色所使爱色。若比丘所使彼即是爱。若爱爱已为魔所缚。欲具欲为名。如彼契经说(同上)。五欲功德世间爱乐念。钩具钩为名。如契经所说(同上)。五欲功德是魔魔钩。缚具缚为名。如契经所说(同上)。比丘受色为魔所缚。不受者为离魔。行具行为名。如契经所说(同上)。此六细滑入本行报。报具报为名。如契经所说(出中阿含)。诸贤彼一施报。七生天上为天王。七生人为人王。如此中余具余为名。如是阿毗昙具名阿毗昙。但阿毗昙性无漏慧根是。如佛契经说。此鬼长夜无谀谄。无幻质直设问事者。尽欲知故无触娆意。此亦如法。我宁可以甚深阿毗昙授之(出中阿含)。问曰。此中云何说甚深阿毗昙。答曰。即是无漏慧根。如佛契经说。梵摩婆罗门长夜无谀谄。无幻质直设问者。尽欲知故无触娆意。此亦如法。我宁可以甚深阿毗昙授之(同上)。问曰。此中云何说甚深阿毗昙。答曰。即是无漏慧根。如佛契经说。异学须跋无谀谄。无幻质直设问事者。尽欲知故无触娆意。此亦如法。我宁可以甚深阿毗昙授之(出杂阿含)。

问曰。此中云何说甚深阿毗昙。答曰。即是无漏慧根。如佛契经说。阿难。缘起甚深明亦甚深(出中阿含)。问曰。此中云何说甚深。答曰。此中说因及缘甚深。如佛契经说。此处甚深。如此经缘起此亦极甚深。所谓舍离一切生死。爱尽无欲灭尽涅槃(出杂阿含)。问曰。此中云何说甚深。答曰。此中因及缘。因及缘舍离说甚深。如佛契经说。一切法甚深故难见。难见故甚深(出杂阿含)。问曰。此中云何说甚深。答曰。此中说一切法甚深。如佛契经说。何故汝愚人盲无目。论甚深阿毗昙(出中阿含)。问曰。此中云何说甚深阿毗昙。答曰。意生也。如佛契经说。先尼我法甚深难见难觉。非察行汝不审彼法。何以故。如汝长夜异见异忍异欲异乐(出杂阿含)。问曰。此中云何说甚深。答曰。此中说空三昧甚深。何以故。答曰。空无我。彼异学计有我。不审知彼但阿毗昙性无漏慧根。由彼故诸世间所修慧不净。安般念意止暖来顶忍世间第一法一切阿毗昙得名。由彼故诸思慧用。断诸法自相及共相。坏愚种及缘愚。于法中不颠倒行。此亦一切阿毗昙得名。由彼故诸生所得报闻善慧。彼于此十二部闻受持思惟称量。观此一切阿毗昙得名。虽有是但阿毗昙性无漏慧根。问曰。阿毗昙有何句义。尊者婆须蜜说曰。此究竟智。此断智。此第一义智。此无欺智。是谓阿毗昙。重说曰。此无非法在上。是谓阿毗昙。若有学自相共相。彼尽其力不能胜。以是故无非法在上。是谓阿毗昙。尊者昙摩多罗说曰。诸尊染污清净缚解轮转出要。谓之法也。从此故名身句身味身次第严治安处造作。是谓阿毗昙。尊者瞿沙说曰。诸趣解脱当求智时。未显示显示。是谓阿毗昙。所谓此苦苦因。此道道果。是求道。此无碍道解脱道。是增益道。是向是果。是故说诸趣解脱当求智时未显示显示是谓阿毗昙。昙无德说曰。此法无比。是谓阿毗昙。问曰。此有何无比。答曰。如所说偈

  智为世间妙　　能趣有所至
  能用等正智　　生老病死尽

复次慧过一切法上。如所说诸妙圣弟子。以慧刀断一切结缚使。恼缠重断打重打割剥(出杂阿含)。以是故说此法无比。是谓阿毗昙。鞞婆阇婆提说曰。此法明能照。是谓阿毗昙。如所说世间无有明与慧等(同上)。复如所说诸所有明。慧明说第一(同上)。是故说此法明能照。是谓阿毗昙。舍提说曰。未尽能尽未择能择。是谓阿毗昙。问曰。何所尽。答曰。结缚使恼缠也。问曰。何所择。答曰。界入阴缘起。是故说未尽能尽未择能择。是谓阿毗昙。譬喻者。说曰。法次法向。是谓阿毗昙。问曰。云何法次法。答曰。佛契经说。涅槃第一义法。彼次更有何法。谓圣八道也。是故说法次法。是谓阿毗昙。尊者婆跋芩说曰。增上事增上转故。是谓阿毗昙。如所说最上长增上长最上慢增上慢。此亦尔(序阿毗昙竟也)

三结三不善根三有漏。四流四轭四受四缚。五盖五结五下结五上结五见。六身爱。七使九结九十八使。此一切佛契经除五结九十八使。除五结已当立五上结。何以故。答曰。彼是佛契经除九十八使已无所立。问曰。何以故尔。答曰。尊者昙无多罗。尽以阿毗昙于四阿鋡契经等观于中。非佛契经舍之。此非佛契经。是故应舍之。或曰。此五结于章不应舍。何以故。答曰。此佛说契经增一阿鋡五法中于久时已来亡失。彼作经者愿智观已立此阿毗昙章。佛说无量部久时亡失。说者增一阿鋡从一法至百法。今从一法至十法。于此一多有失不存。如是至十。复说尊者舍那婆阿罗汉。是耆婆师。彼般涅槃日。即彼日亡失七十千生经。阿毗昙中亡失十千经。从是以来佛法不复行。如是此无量部久时亡失。如是佛契经说五结。一增阿含于五法中久时亡失。彼作经者愿智观已立此阿毗昙章。问曰。九十八使非佛契经。何以故。于此章不舍。答曰。此一切是契经义。契经采契经说。佛契经中说七使分别界分别种分别行。摄已便有九十一使。或曰。俱非佛契经。于章中俱不应舍。问曰。五结非佛契经。于此章中何以不舍。答曰。彼作经者意欲尔。如我别说一切遍结。别说非一切遍。别说一切遍非一切遍。彼别说一切遍结如三结。别说非一切遍如五结。别说一切遍非一切遍如九结。是故彼作经者意欲尔。三结至九十八使问曰。何以故作章。答曰。为立门故。不可以无章而得立门。不可以手庄虚空。问曰。何处可庄。答曰。庄可庄处。如是不可以无章而得立门。或曰。莫令无章空论也。或曰。以久住故。如此阴品数善造善作章善立门。百千中可一能得持。亦有不者。何况散解乱合聚谁能得持。是谓以久住故。或曰。自无乱知见现故。若有作经乱知见者。彼经亦乱。以此可知。彼作经者无乱知见。结作此经不乱善正。是谓自无乱知见现故作章。问曰。何以故佛契经立作章。答曰。欲现佛契经无量义故。此外部少义无义。少义者。诵罗摩那十二千章二句义。罗摩泥将私陀去波罗弥。还将来。无义者。以一女故杀十八垓众生。如铁城满中草。外部如是少义无义。问曰。佛契经云何。答曰。无量义无边味。如大海无量甚深极广无边。佛契经亦如是。无量义无边味者。如尊者舍利弗比。如是百千那术数作百千经。尽彼智住不可得。佛契经二句义至底度彼岸。是谓佛契经现无量义故。或曰。忍问答现契经故。此外部问亦不忍。答亦不忍。犹如猕猴子。亦不忍捣不忍重捣。以杵捣便解散。如是此外部问亦不忍。答亦不忍。问事已如被杵捣。问曰。佛契经云何。答曰。如成就波罗捺衣。杵捣亦忍重捣亦忍。捣重捣益有色柔软。佛契经亦如是。问亦忍答亦忍。如问如答。戒色益好功德柔软。是故忍问答。现佛契经故。或曰。佛契经开示妙故。佛说契经。此三事覆则妙开则不妙。云何三。无明者。婆罗门语女。三事开则妙覆则不妙。云何三。明日月佛语(出杂阿含)。是谓佛契经开示妙故佛契经作章。问曰。何以故先作章后立门。答曰。治地法故。如人欲种树。先治其地然后种树。彼作经者亦如是。治地法先作章种树法后立门。或曰。基法故。如人作舍。彼先作基然后立舍。彼作经者亦如是。基法故先作章。立舍法后立门。或曰。木摸法故。如像师像师弟子前治摸然后立枝节。彼作经亦如是。木摸治法前作章。枝节法后立门或曰。画法故。如画师画弟子先摸然后傅釆。彼作经者亦如是。摸法者先作章。傅釆法后立门。或曰。綖法故。如彼巧鬘师鬘弟子前绳綖已然后结种种华鬘。彼作经者亦如是。綖法前作章。鬘法后立门。或曰。现尊法佛世尊亦复尔。说分别法。世尊前说。比丘人有六界聚六更四处(一真谛处二施处三慧处四息处也)十八意行。然后分别。是为比丘六界六更四处十八意行。彼作经者亦如是。说法者前作章。分别法者后立门。是谓现尊法故。或曰。现修行法故。如彼修行前以四大造色作章已。然后彼色微细破散。彼作经者亦如是。四大造色法前作章。破散色法然后立门。是谓现修法故。或曰。现论法故。此论之法前问后答。是故现论法故。是谓彼作经者先作章后立门。问曰。何以彼作经先立三结。后立至九十八使。答曰。前已说阿毗昙说相。当求阿毗昙相。不应索次第。契经当求次第。何以故。此品次第说。此品律说本末当求本末。此义由何生。但阿毗昙说相。当求阿毗昙相。不应求次第。复次可说所以。彼作经先立三结后立至九十八使。但阿毗昙多破散乱合聚。谁能尽说次第。但阿毗昙说相当求相。不应求次第。前后无在。尊者婆奢说曰。一切疑法不违。若先立三不善根。后立至九十八使。彼亦当有此疑。是故一切疑法不违前后无在。或曰。彼作经者意欲尔。如我先立三结后立至九十八使。以是故尔。或曰。增益法故。前现三后四五六七九九十八使。是故增益法故。或曰。次第立四沙门果故。三结永尽立须陀洹果是故彼前立三不善根。余尽立斯陀含果。永尽立阿那含果。是故此次立彼三有漏。永尽立阿罗汉果。是故彼后诸流扼受乃至九十八使。此一切广说有漏漏有差降有漏增。此三有漏。谓是流扼受至九十八使。是故次第立四沙门果故。或曰。次第立结树故。此是结树前现三后四五六七九九十八使。是故彼作经者。先立三结。后立至九十八使。广说章处尽

    鞞婆沙三结处第一

三结身见戒盗疑。问曰。三结有何性。答曰。身见者。三界有一种。此三种。戒盗者三界有二种。此六种。疑者。三界有四种。此十二种。此二十一种是三结性。此三结性。已种相身所有自然。说性已。当说行。何以说结结义云何。答曰。缚义是结义。苦系义是结义。杂毒义是结义。缚义是结义者。缚是结。结是缚。云何知。答曰。有契经。彼契经尊者舍利弗问尊者摩诃拘絺罗。云何贤者拘絺罗。眼系色耶。色系眼耶。答曰。尊者舍利弗。不眼系色。不色系眼。至意法不意系法不法系意。但此中若淫若欲是彼系也。尊者舍利弗。譬如二牛一黑一白一轭一鞅缚系。尊者舍利弗。若有作是说。黑牛系白牛。白牛系黑牛。尊者舍利弗。彼为等说不。答曰。不也贤者拘絺罗。何以故。答曰。贤者拘絺罗。非黑牛系白牛。非白牛系黑牛。但以轭鞅系是彼系。如是尊者舍利弗。不眼系色不色系眼。至意法不意系法不法系意。但此中若淫若欲是彼系(出杂阿含)。是谓缚义是结义。苦系义是结义者。欲界结欲界众生欲界中苦系。色界结色界众生色界中苦系。无色界结无色界众生无色界中苦系。诸欲界结彼是系相。系苦中非是乐。诸色无色界结彼是系相。系苦中非是乐。是谓苦系义是结义。杂毒义是结义者。极妙生处世俗正受如解脱。除入一切入彼圣所。除结杂毒故。如极妙食杂毒。慧者能除。以杂毒故。如是极妙生处世俗正受。彼圣能除结杂毒故。是谓系义是缚义苦系义是结义杂毒义是结义。如佛契经说三结尽须陀洹。问曰。如阿毗昙所说。八十八见所断尽须陀洹。如华池喻。契经所说。无量苦尽须陀洹(出杂阿含)。何以故说三结尽须陀洹。答曰。是世尊余言略言。欲令行言。世尊为教化故。或曰。为人故。为眷属故。为器故。为教化故。彼受化者能辩说尔所事。或曰。佛世尊所说尽为教化故。如医疗治尽为病人故。彼医为病者。审知病根而说随病投药。不说减少恐病不差。亦不说增恐捐其功。处中而说欲令病差。如佛世尊所说。尽为教化故。彼世尊为受化者。知身知使已为投道药。亦不减说恐结病不尽。亦不说增恐捐其功。处中而说。或曰。诱进教化故。事易行故。手扶佐故。此中应说跋耆子喻。有说者。有比丘名跋耆子。于世尊境作沙门。世尊为渐渐设出二百五十戒。彼闻已厌。至世尊所说。世尊设出二百五十戒。半月次来令族姓子学。唯世尊。我不能行尔所戒。世尊善不粗言劝。善哉善哉跋耆子。汝跋耆子。能行三戒增上戒增上意增上慧不。彼闻已便踊跃作是念。我能善行此三戒。彼说曰。唯世尊。我当学。善逝。我当燃炽行。彼学三戒时渐渐学一切戒海。若世尊如是为教化。说八十八见断尽须陀洹无量苦尽须陀洹。彼闻已厌。谁能破此八十八苦山。谁能拔此八十八苦树根。谁能度此八十八苦河。谁能竭此八十八苦海。如佛契经说三结尽须陀洹。彼受化者闻已。便欲我能善断此三结彼断三结时渐渐一切见断结尽。是谓诱进教化故事易行故手扶佐故。此中说跋耆子喻(出律)。或曰。盛患重过多苦。问曰。身见有何盛患。答曰。身见六十二见根。见是结根。结是行根。行是报根。一切世间依报。依报已生死中趣善法趣不善法趣无记法。问曰。戒盗有何盛患。答曰。戒盗中生诸苦行。问曰。疑有何盛患。答曰。为过去故疑犹豫。为当来故疑犹豫。为现在故疑犹豫。于内中疑犹豫。此云何。何谓此此众生从何所来当何所至。何因何有。是谓盛患重过多苦。或曰。功德怨家故。问曰。云何功德。答曰。须陀洹果。彼何近不亲怨家。答曰。三结是。或曰。谓须陀洹果证时。而为作碍不令入门。住如守门人。或曰。谓三解脱门相违。彼身见空定相违。戒盗无愿相违。疑无相相违。是谓三解脱门相违故。以是故尔。或曰。谓尽无余乃至阿罗汉。亦有相似身见得苦。未知智永尽。彼已尽已知。乃至阿罗汉亦有相似。如彼阿罗汉作是念。是我衣钵。是我弟子沙弥。是我舍。是我园。似如有我。戒盗得道未知智永尽。彼已尽已知。乃至阿罗汉亦有相似。如彼阿罗汉行乞食粪扫衣露坐。受沙门十二净行。似如净行。疑得道未知永尽。彼已尽已知。乃至阿罗汉亦有相似。彼阿罗汉见二道而疑。此是道非道耶。见二衣而疑。是我衣耶非我衣耶。远见已而疑。是男耶是女耶。莫作是念。阿罗汉不尽此理定。须陀洹已尽。况阿罗汉。以是故说三结尽须陀洹。或曰。此现门现略现度。若有见断结者。或一种二种四种。彼身见已说。当知已说一种。戒盗已说当知已说二种。虽无余二结可得二种。当知即彼戒盗二种。及彼相应法。疑已说。当知已说四种。或曰。若有见断结者。或己界一切遍。或非己界一切遍。身见已说。当知已说己界一切遍。戒盗疑已说当知非己界一切遍。问曰。何以故。说一已界一切遍二非己界一切遍。答曰。若彼有非己界一切遍结。或有漏缘。或无漏缘。彼身见戒盗已说。当知已说有漏缘。疑已说。当知已说。无漏缘。如己界一切遍非己界一切遍。如是己地一切遍非己地一切遍。己界缘非己界缘。己地缘非己地缘。尽当知。若有见断结者。或有漏缘或无漏缘。彼身见戒盗已说。当知已说有漏缘。疑已说。当知已说无漏缘。问曰。何以故。二有漏缘一无漏缘。答曰若有有漏缘结者。或己界一切遍非己界一切遍。彼身见已说。当知已说己界一切遍。戒盗疑已说。当知已说非己界一切遍。如有漏缘无漏缘。如是诤不诤。世间出世间。住不住。依欲不依欲。尽当知。若有见断结者。或有为缘或无为缘。彼身见戒盗已说。当知已说有为缘。疑已说。当知已说无为缘。如有为缘无为缘。如是有常缘无常缘。有恒缘无恒缘有住缘不住缘。尽当知。或曰。若有见断结者。或见性非见性。彼身见戒盗已说。当知已说见性。疑已说。当知已说非见性。如见性非见性。如是观不观。行非行。坚持不坚持。求不求转不转。尽当知。是故说现门现略现度。以是故说三结尽须陀洹。问曰。始得道是须陀洹耶。为始得果是须陀洹耶。若始得道是须陀洹者。应第八是须陀洹。第八者坚信坚法彼始得道贤信道坚法道。若始得果是须陀洹者。彼应倍欲尽欲爱尽是须陀洹。彼始得果斯陀含果阿那含果作此论已。说曰。始得道是须陀洹。问曰。若尔者。应第八是须陀洹。彼始得道坚信道坚法道。答曰。始得道是须陀洹。始道入道彼坚信坚法。虽始得道是始入苦。或曰。始得道是须陀洹。若见断结永尽已知忍相违。已尽已知耶见永断。或曰。始得道是须陀洹。有想人故。可说人故。施设人法故。或曰。始得道是须陀洹。思惟道故。果摄道故。道未知智故。或曰。始得道是须陀洹。若处得三事。未曾得道。舍曾道。结尽得一味。或曰。始得道是须陀洹。若处得五事。未曾得道。舍曾道。结尽得一味。得八智。一时修十六行。或曰。始得道是须陀洹可有生。更有说者始得果是须陀洹。问曰。若尔者。倍欲尽欲爱尽。应是须陀洹。彼始得果。斯陀含果阿那含果。答曰。始得果是须陀洹。最初解脱故。最初度故。最初住果故。或曰。始得果是须陀洹。次第故具缚故不越次故。或曰。始得果是须陀洹。四向四住果故。或曰。始得果是须陀洹。四双八辈故。或曰。始得果是须陀洹。余未得增行故。余未得增行者。世间道未有所尽而得果。或曰。始得果是须陀洹。无差降故。无差降者。亦如上世间道。未有所尽而得果。或曰。始得果是须陀洹。若果道不坏地亦不坏。道不坏者。一向无漏道得果。地不坏者。依未来得。非余阿罗汉果者。虽道不坏一向无漏道得果。然彼地坏依九无漏地得。斯陀含果者。虽地不坏依未来得非余。然彼道坏世间无漏道得果。阿那含果者道亦坏地亦坏。道坏者世间无漏道得果。地坏者依六地得。此须陀洹果道亦不坏地亦不坏。以是故始得果是须陀洹。更有说者。亦不始得道是须陀洹。亦不始得果是须陀洹。问曰。若尔者为云何。答曰。由彼须陀洹果故。是须陀洹法故名为人。如药汤。由药故名为药汤。由酥故名为酥瓶。由蜜故名为蜜瓶。如是彼由须陀洹果故。是须陀洹由法故名为人。如药汤也。须陀洹者。八圣道名为水是彼入。以是故名须陀洹。问曰。如斯陀含阿那含阿罗汉入圣道水。彼何以故不名为须陀洹。答曰。始起受名始方便度。以是故名须陀洹。非斯陀含阿那含阿罗汉。不堕恶法者。终不堕三恶趣。问曰。如斯陀含阿那含阿罗汉。亦不堕恶法。何以故。但说须陀洹不堕恶法而非余。答曰。各各有差降故。此须陀洹不堕恶法是差降。斯陀含一往来是差降。阿那含不还欲界是差降。阿罗汉更不还有是差降。是谓各各差降故。一须陀洹名不堕恶法。非斯陀含阿那含阿罗汉。问曰。如凡夫人亦不堕恶法。何以故。说圣人不堕恶法。答曰。彼非定或堕恶法或不堕恶法。此圣人一向不堕恶法。无有一圣人堕恶法。如彼非定。以是故。圣人不堕恶法。非凡夫人。定者聚正定住故名为定。当言须陀洹定般涅槃变易故。趣正觉者。尽智无生智谓之觉。彼人依此有向有趣有乐有欲。是故说趣正觉极七还有者。问曰。如此极十四还有。极二十八还有。若取本有数者。天上本有七人间七此十四。若取本有中阴数。天上本有七中阴七人间本有七中阴七。是二十八。何以故。说极七还有是须陀洹。答曰。法应七故不过七。一一趣故。世尊说极七还有是须陀洹。若天上本有七中阴七人间本有七中阴七彼一切皆不过七。以是故世尊说。极七还有须陀洹。如余契经说。四圣谛三转十二行。此不应三转十二行。应十二转有四十八行。但三转十二法故。不过三转十二行。观一一谛故。世尊说四圣谛三转十二行。如余契经说。比丘七处善观三种义。速于此法中得漏尽。此不应七处。若应有三十五处善。亦有无量处善。但七法故不过七观。一一阴故。世尊说。比丘七处善观三种。速于此法中得漏尽。如余契经说。比丘我当为说法。谓有二眼及色。耳声鼻香舌味身细滑意法。此不应一二。应有六二。但二法故。不过二观。一一入故。眼及色故。乃至意及法故。世尊说。比丘我当为说法。谓有二也。如是若天上本有七中阴七人间本有七中阴七。一切不过七。一一趣故。天趣故人趣故中阴故。七本有七。是故一一趣故。世尊说。极七还有是须陀洹。问曰。何以故须陀洹极七还有亦不增减。婆奢说曰。一切有疑法不违。若增若减者彼亦当有此疑。是故说一切疑法不违。或曰。是彼齐报因故。如彼齐报因。齐报果应尔。是故说是彼齐报因故。或曰。行力故须陀洹生七有。圣道力故不至八。如人为七步蛇所螫。彼以四大力故能行七步。毒力故不至八。如是须陀洹行故生七有。圣道力故不至八。如人前食故命至七日。食势尽不至八。如是须陀洹本行故生七有。行尽不至八。或曰。彼住增上忍时。除欲界七生色无色界一一处一一生。余一切生得非数缘尽。若生得非数缘尽。此生至竟不现在前。或曰。七生处故。生生处者。欲界六天及人。此中须陀洹应生。是故。七生处故。或曰。彼八生空无圣道故。若须陀洹至八有者。彼见谛已为非见谛。得果已为非得果。等行已为非等行。得圣人已为是凡人。无说有咎。以是故须陀洹不至八有。或曰。世间中现事故。世间中现事者。至七世名为亲。若至八非亲。如是若须陀洹至八。于恒沙佛法中远离他不亲。无说有咎。以是故须陀洹不至八。若须陀洹极满天上七生人间七。彼中说。是但须陀洹有差降七生天上人间六天上六人间五天上五人间四天上四人间三天上三人间二天上二人间一。但须陀洹极满天上七人间七。彼中说。是若极七生有是须陀洹。问曰。彼七何处满。或有说者。若身得须陀洹果。彼身于七中。或有说数。或有不说数。谓有说数者。若天上得果人间般涅槃。人间得果天上般涅槃。谓有不说数者。若天上得果天上般涅槃。人间得果人间般涅槃。如是说者。若身中得须陀洹果。彼身于七中不数。何以故。答曰。若彼身中得须陀洹果者。彼身中阴凡夫时。若此身于七中数者。应有二十七。不应二十八。若尔者。与施设所说相违。彼所说彼二十八有。往生后有。后依后得身。得无漏道。用尽余结。无说有咎。是彼身于七中不数。问曰。极七生有须陀洹。于六生中圣道现在前耶。不现在前耶。若现在前者。何以不般涅槃。若不现在前者。彼意应无圣道。作此论已。有一说者现在前。问曰。何以不般涅槃。答曰。彼行乐世间行力故不般涅槃。问曰。极七生有须陀洹极满七。佛未出世。彼为白衣般涅槃为云何。答曰。不然。彼定出家般涅槃。彼如是若五百若千辟支佛。住仙人窟中。本尽为声闻。是故说极七生有。七生天上人间者。从天至人从人至天。如人从园至园从节会至节会。彼亦如是。从天至人从人至天。是故说七。天人往生者。往谓中阴。生谓本有。是故说往生。信苦边者。问曰。苦边者。当言中当言外。若言苦中应无苦边。若苦外者世间现事云何通。如金筹初亦金中亦金后亦金。如是须陀洹初亦苦中亦苦后亦苦。云何有苦边。作此论已。有一说者。阿罗汉最后阴是苦边。或有说者。灭尽涅槃是苦边。问曰。若阿罗汉最后阴是苦边者。云何有苦边。答曰。如是有苦边。谓更不受苦。更不结着苦。更不与苦作缘。问曰。若灭尽涅槃是苦边者。譬喻云何通。答曰。此不必通。此亦非契经非律非阿毗昙。不可以世间喻坏贤圣语。世间事异贤圣事异。作苦边者。苦谓之五盛阴。彼是边最边后边。是故说作苦边。广说三结处尽

鞞婆沙论卷第一鞞婆沙论卷第二

        阿罗汉尸陀槃尼撰

        符秦罽宾三藏僧伽跋澄译

    三不善根处第二

三不善根者。贪不善根恚不善根痴不善根。三不善根有何性。答曰。贪不善根者。欲界爱五种六识身。恚不善根者。恚有五种六识身。痴不善根者。欲界无明尽有四种。见习见尽见道思惟所断。见苦断痴种少所入。问曰。何以故。答曰。谓此有十种。五见相应疑爱恚慢相应。不共有十。于中八种立不善根。二种不立。欲界身见边见相应也。问曰。因者说是根。彼欲界身见边见相应无明一切不善法因。彼何以故不立不善根。答曰。谓性不善。亦一切不善法因。彼立不善根。此欲界身见边见相应无明。虽一切不善法因。非性不善。问若尔者为云何。答曰。无记是。是故说欲界无明尽四种见尽见道思惟所断。一种少所入见苦断也。六识身相应。此十五种三不善根性。此是三不善根性已种相身所有自然。说性已当说行。何以故说不善根不善根义云何。尊者婆须蜜说曰。生义养义增义不善根义。重说曰。长义受义满义不善根义。重说曰。因不善义是不善根义。重说曰。转不善义是不善根义。重说曰。顺不善义是不善根义。重说曰。受不善义是不善根义。尊者昙摩多罗说曰。诸尊处所中种不善法转顺受。是故说不善根义。问曰。若因不善义是不善根义者。前生不善五阴后生不善五阴。亦是因前生十恶行。后生十恶行。亦是因前生四十四不善使。后生四十四不善使。亦是因意故时无量不善。何以故说三不善根。答曰。佛世尊法真谛。余真不能过上者。彼尽知法相。定知定行。有不善根相者立不善根。无不善根相不立不善根。尊者瞿沙说曰。世尊觉此随彼力随重重彼随彼近。此三不善根一切不善法因。非余不善法。或曰。谓一切不善法首在前主将法故。此力故一切不善法转。或曰。谓一切不善法因根。导本所作缘等有习等起。于中因种子法故。根坚法故。或曰。谓一切不善法来持等持生养增。是故说不善根。或曰。谓功德怨家。问曰。此中何功德。答曰。三善根是。问曰。此何近不亲怨家。答曰。三不善根是。或曰。如守门人不令入门。住守门法故。或曰。谓三善根相违。于中贪不贪相违。恚不恚相违。痴不痴相违。或曰。谓说行本如所说(出中阿含)。迦蓝此三行本习。迦蓝贪行本习。迦蓝恚痴行本习。或曰。谓各各相生各各相转。如所说从爱生爱。从爱生恚。从恚生恚。从恚生爱。于中无明。或曰。说相违相违不相违相违故。众生多起斗诤缚。谓天阿须伦往共斗。婆罗他(兄也)摩诃婆罗他(弟也)罗摩(兄也)罗叉那(弟也)为私陀故(妻也)罽那(兄也)阿詶那(弟也)。为彼一女故。杀十八垓人。何以故。答曰。不相违相违故。不相违者爱。相违者恚。问曰。何以故不说痴。答曰。于中已说。若彼智者天境界故不作此恶。何况人间恶欲故。人为国故为宫故尔所恶。何况园田作尔所恶。何况长者为粪扫故作。于春时多起斗诤缚。是故说谓不相违相违。以此故尔。或曰。谓三痛所使。如所说乐痛中贪使所使。苦痛中恚使所使。不苦不乐痛中痴使所使。问曰。如此中一切所使。答曰。多故乐痛中多贪所使。苦痛中多恚所使。不苦不乐痛中多痴所使。贪因乐痛中起已。即彼乐痛中受根已。增不善五阴。增不善五阴已。多起恶行。多起恶行已。生死中多受苦。恚因苦痛起。彼于苦痛中受根已增不善五阴。增不善五阴已。多起恶行。多起恶行已。于生死中多受苦。痴因不苦不乐痛起。彼于不苦不乐受根已。增不善五阴。增不善五阴已。多起恶行。多起恶行已。于生死中多受苦。是故说谓此三痛所使。以此故尔。或曰。谓五种六识身使性。能起身行口行。断善根时多方便。五种者。见苦断至思惟断。六识身者。眼识相应乃至意识相应。使性者。贪者欲使。恚者不可使。痴者无明使。能起身行口行者。为贪故作身行口行。为恚痴故作身行口行。断善根时多方便者。如施设中所说。若断善根彼云何断以何行。答曰。有一人性欲重恚重痴重。彼欲重恚重痴重故。难语难教难解难脱。是故说谓五种六识身使性能起身行口行断善根时多方便。彼立作不善根。问曰。如邪见能断善根。彼何以故不立不善根中。答曰。方便堪任增上力。一切善恶多用方便力。非堪任作。有说者如菩萨。见世间生老病死苦盲无将导。始发无上正真道意。于中初意最胜。不退转不移动。于此上三阿僧祇作行。不后得尽智无生智。当来修三界善根。或曰。彼邪见若断善根。彼一切是不善根力。若彼不善根。令善根薄穿减少力。然后彼邪见断善根。或曰。谓彼断善根时转不转。贪者转恚者不转痴者转不转。彼邪见能不转非转。以是故尔。或曰。此前已说谓五种。彼邪见非五种是四种。非六识身是意识。虽有使性不能起身行口行。何以故。答曰。无有见断结能起身行口行。断善根时不多方便。彼邪见最后时用。谓彼邪见离此聚。以是故不立不善根中。谓此五阴离不善根中。彼亦离此聚色阴。非五种非六识身非使性。不能起身行口行。断善根时不多方便。痛阴想阴识阴。彼相应行阴。谓彼离结。是五种六识身非使性。不能起身行口行。断善根时不多方便。不相应行阴五种。非六识身非使性。不能起身行口行。断善根时不多方便。结中五见及疑。非五种非六识身。虽有使性不能起身行口行。断善根时不多方便。慢五种非六识身。虽使性不能起身行口行。断善根时不多方便。余说十缠。嗔缠不语缠睡缠眠缠调缠悔缠无惭缠无愧缠悭缠嫉缠。于中嗔不语非五种。非六识身非使性。不能起身行口行。断善根时不多方便。眠五种非六识身非使性。不能起身行口行。断善根时不多方便。睡调此二五种六识身非使性。不能起身行口行。断善根时不多方便。无惭无愧。此二五种六识身非使性。能起身行口行。断善根时多方便。悭嫉。此二非五种非六识身非使性。不能起身行口行。断善根时不多方便。愤依诳谄高害。此一切说是结。垢依结非根本结。谓五种六识身使性。能起身行口行。断善根时多方便。彼立不善根。若离此聚中彼不立不善根。或曰。谓此三不善根能起十恶行。起十恶行已生十恶道。问曰。云何此三不善根能起十恶行。起十恶行已生十恶道。答曰。佛说契经杀有三种。贪故恚故痴故。至邪见三种。贪故恚故痴故。阿毗昙亦说。谓此三不善根一切不善法因根。导本作缘有习起。如是三不善根能起十恶行。问曰。云何起十恶行已生十恶道。答曰。佛说契经习杀生修多修。生地狱畜生饿鬼中。若来生人中短寿。阿毗昙亦说。习增上杀修多修。生大阿鼻泥犁中。于中减于中软。生热地狱大热地狱叫唤大叫唤想黑绳等活地狱。生畜生饿鬼中。如是起十恶行已生十恶道中。是故说三不善根。或曰。谓彼亦说增亦说薄。如所说云何增欲增恚增痴。答曰。因软欲故便有中。因中便有增。因软恚故便有中。因中便有增。因软痴故便有中。因中便有增。如是增欲增恚增痴。问曰。云何欲软恚软痴软。答曰。增上欲薄便有中。中薄便有软。增上恚薄便有中。中薄便有软。增上痴薄便有中。中薄便有软。如是欲薄恚薄痴薄。是故说。谓彼亦说增亦说薄。以故尔。或曰。谓彼退时多因多缘。如所说若比丘比丘尼。自观增欲恚痴。比丘比丘尼当知我于善法中退。世尊说此是退。是故说。谓彼退时多因多缘。以故尔。或曰。谓说结障碍。如所说云何结障碍。答曰。若众生性欲重恚重痴重。彼性欲恚痴重故。难教难语难解难脱。是故说结障碍以故尔。或曰。此现门略度。若有尔所不善根。或欲分恚分痴分。如彼契经说。婆罗门若有二十一结染着意。彼必生恶道趣泥犁中。说者尊者昙摩多罗说。此契经中一切结立三分。尔所欲恚痴分。若说欲当知已说欲分。若说恚痴当知已说恚痴分。如欲恚痴分。如是亲分不亲分亲不亲分。益分不益分益不益分。乐分不乐分乐不乐分。尽当知。是故说现门略度。或曰。谓说内垢。如所说欲是内垢。恚痴是内垢。如内垢者。如是内不亲怨敌尽当知。或曰。谓说尘。如所说欲是尘恚痴是尘。如尘如是。垢秽障大刺毒刀尽当知。以是故立三不善根。问曰。此结云何行。答曰。若意中行欲此中无恚。若恚无欲。此二要有痴。问曰。何以故。若意中行欲此中无恚。若恚无欲。答曰。性相违故。贪性喜恚性忧。贪身长养受。恚身不长养受。贪身软安隐缘中不碍。软安隐者。若贪现在前一切身软。缘中不碍者。若意中染着受。长夜亲不厌。恚身不软不安隐缘中碍。不软不安隐者。若恚现在前一切身不软。缘中碍者。若意中恚现在前。眼不喜有所视。是谓性相违故。若意中行欲。此中无恚。若恚无欲。此二要有痴。此三不善根说五种六识身。问曰。何以故。三不善根说五种六识身。答曰。若此有见断非思惟者。彼思惟断不善心应非根。若思惟非见断者。彼见断不善心应非根。若有五识身非意识者。谓彼意识不善心应非根。若有意识非五识者。谓彼五识不善心应非根。一切不善心中此三不善根。是根或二或一。贪相应不善意有二根。贪及彼相应无明。恚相应不善意有二根。恚及彼相应无明。离此已诸不善意。彼尽是一根无明。是此说多有根。身见法根。世尊法根。欲法根。不放逸法根。性根说一切法。问曰。何以故说身见法根。答曰。计我故。计我已生六十二见。以故尔。问曰。何以故说世尊法根。答曰。说故谁说染着清净缚解轮转出要佛也。以故尔。问曰。何以故说欲法根。答曰。欲得善法。欲得者彼得善法。不欲得者彼不得善法。以故尔。问曰。何以故说不放逸法根。答曰。坚持善法故。不放逸者。彼能坚持善法。放逸者。彼坚持善法已便失。况能更坚持。问曰。何以故说性根一切法。答曰。不舍自己种故。问曰。如汝说无为中亦应有根。彼亦不舍己种。答曰。若无为中有根者无在。彼亦不舍己种。以故无在更有欲。治此咎故说。性根者与因故。问曰。云何与因。答曰。前生后生因。问曰。如汝说苦法忍应无根。何以故。彼他不与自然因。答曰。彼苦法忍虽他不与自然因。而彼与他彼涅槃。他不与因。亦不与他因。彼云何性根与因故此不论。如是说性根者。不舍己种故。以是故说性根一切诸法。广说三不善处尽

    鞞婆沙三有漏处第三

三有漏者。欲有漏恚有漏痴有漏。问曰。漏有何性。答曰。欲有漏性四十一种。爱五恚五慢五疑四见十二十缠。此四十一种欲有漏性。问曰。身恶行口恶行烦恼性耶。非烦恼性耶。若烦恼性者。此欲有漏中何故不说。若非烦恼性者。施设所说云何通。彼中说身恶行口恶行。非结非缚非使。是烦恼非缠当弃舍灭。因生苦故。作此论已说曰如烦恼性。问曰。若尔者。此欲有漏中何故不说。答曰。应说此身恶行口恶行立欲有漏中。应作四十三种欲有漏性。若不说者是略言。更有说者如非烦恼性。问曰。以是故欲有漏中不说。彼施设云何通。答曰。此施设所说应尔。身恶行口恶行非结非缚非使非烦恼非缠。当弃舍灭。因生苦故应尔。问曰。若不尔者何意。答曰。彼虽非烦恼性。为烦恼所烦恼。是故说烦恼。问曰。彼非结性为结所系。何故不说结。非缚性为缚所缚。何故不说缚。非使性为使所使。何故不说使。非缠性为缠所缠。何故不说缠。答曰。应说若未说者是略言。或曰。现二门二略二度二炬二明二光二数。如彼非烦恼性为烦恼所烦恼。是故说烦恼。如是彼非结性为结所系。亦应说结。非缚性为缚所缚。亦应说缚。非使性为使所使。亦应说使。非缠性为缠所缠。亦应说缠。若彼非结性为结所系而不说结。非缠性为缚所缚而不说缚。非使性为使所使而不说使。非缠性为缠所缠而不说缠。如是彼非烦恼性为烦恼所烦恼。亦不应说烦恼。是故说现二门至二数。有有漏性五十二种(应加睡调五十四也)。爱十。色界五。无色界五慢十。色界五。无色界五。疑八。色界四。无色界四。见二十四。色界十二。无色界十二。此五十二种有有漏性。无明有漏性十五种。欲界五色界五无色界五。此十五种无明有漏性。此百八种三有漏性。彼亦名百八种烦恼。是谓三有漏性已种相身所有自然。说性已。当说行。何以故说有漏。有漏有何义。答曰。留住义是有漏义。渍义是有漏义。漏义是有漏义。增上主义是有漏义。持义是有漏义。醉义是有漏义。留住义是有漏义者。众生以何留住欲界。众生以何留住色无色界有漏也。渍义是有漏义者。如渍种子而生萌芽。如是众生为结所渍生有萌芽。漏义是有漏义者。如漏刻水漏。如乳房出乳。如是众生六入门中常结漏。增上主义是有漏义者。如人为人增上主。不得令众生东西南北自在。如是众生结为增上主。不得越界趣轮转生死。持义是有漏义者。如人为非人所持。不应说而说。不应语而语。不应取而取。不应盗而盗。如是众生为结所持。不应说而说。至不应盗而盗。醉义是有漏义者。如人饮根酒茎酒叶酒华酒果酒。醉失惭愧不知事非事。如是此众生结酒所醉。失惭愧不知事不事。是故说留住义渍义漏义增上主义持义醉义是有漏义。问曰。若留住义是有漏义者。行亦留住众生在生死中。如所说二因二缘生死行及结行结。是生死种子不断不破不除不没。复次若七岁八岁得阿罗汉果。于彼上至百岁。住生死中受无量苦。头痛身热乃至四百四病。彼一切结尽。但因行故住生死中。如因行故。众生住生死中者。何以故。立结有漏中而不立行。答曰。此结是行本。不可以不断结而断行。或曰。彼因结故而起行。无结受报。如人以泥团抟壁干亦不堕。因本故。如是彼因结故而起行。无结受报。或曰。结尽般涅槃。非行尽阿罗汉。行住如须弥。而阿罗汉尽灭阴入无余涅槃界。或曰。彼行不定。或住生死或断生死。此结一向定住生死中。以是故立结有漏中非行。彼婆须蜜。施设所说。云何欲有漏。答曰。除欲界无明。诸余欲界结缚使烦恼缠也。云何有漏。答曰。除色无色界无明。诸余色无色界结缚使烦恼缠也。云何无明漏。答曰。三界无智也。此说好三界无智。若说三界不智。而不取三界无智。若说三界无智此说好。问曰。何以故欲界结。除无明立欲有漏。色无色界结。除无明立有有漏。何以故。一切三界无明别立无明有漏。答曰。若留住欲界。彼一切依欲故欲得欲故求欲故乐欲故欲爱欲故。以是故欲界结。除无明立欲有漏。若留住色无色界。彼一切依有故欲得有故求有故乐有故欲受有故。以是故色无色界结。除无明立有有漏。谓彼住欲界。住色无色界者。彼一切由无明故。以是故一切三界无明别立无明有漏。或曰。欲界结及欲爱我及二及毒。以是故欲界结。除无明立欲有漏。色无色界结无欲受我。非二非毒。以是故色无色界结。除无明立有有漏。谓彼欲界爱我。色无色界爱我。彼一切由无明故。以是故一切三界无明别立无明有漏。作譬喻者说。二根本结无明及有爱何以故。答曰。谓彼二根本结。无明者本缘起根。有爱者当来有。问曰。若尔者。彼三有漏云何。答曰。彼说者爱或不善或无记。或有报或无报。或受二果或受一果。或无惭无愧相应。或无惭无愧不相应。彼若有不善有报受二果无惭无愧相应者。彼是欲界爱。因彼故诸余欲界结。除无明得欲有漏名。谓无记无报一果无惭无愧不相应。此谓说色无色界爱。因彼故色无色界结。除无明有有漏得名。问曰。于此论中更有论生。何以故。欲界爱故。欲界结除无明欲有漏得名。何以故。色无色界爱故。色无色界结。除无明有有漏得名。答曰。谓爱故界断地断种断。谓爱故爱一切盛结。以是故欲界爱故。欲界结除无明欲有漏得名。以是故色无色界爱故。色无色界结除无明有有漏得名。问曰。何以故。一切三界无明别立无明漏。答曰。谓无明前无智后无智中无智。内无智外无智内外无智。行无智报无智行报无智。觉无智法无智僧无智。苦无智习尽道无智。于六更乐入如真无智。无见痴冥故以故尔。或曰。谓种重行重。种重者。一切结重与一无明等。行重者。一切结共作行。复别立不共无明使。以故尔。或曰。谓彼说懒怠。如所说此比丘懒怠者。谓无明是。有说。水中有虫名懒怠。自盲教他亦盲。如是此无明已自盲。诸有行者亦盲。以故尔。或曰。谓九种一种缘中痴。九种者增上至软软。一种缘中痴者。彼有想无想软软一种也。问曰。此事能一切非己界遍使。邪见有九种。一种缘中谤言无见。盗九种。一种缘中受。第一戒盗九种。一种缘中受净。疑九种。一种缘中犹豫。如此事能一切非己界遍使。彼何不共事独说无明。答曰。不也。问曰。若尔者此云何。答曰。此欲界痴起九种。一种亦起九种。如一种起九种。如是至第九种亦起九种。如欲界起九九种。如是至有想无想处起九九种。一切非己界遍使。无此事。谓彼尔所种尔所度今众生生死痴。以故尔。或曰。谓彼住一时中。五种因五种缘五种使所使。以故尔。或曰。谓前普遍。问曰。前者云何。答曰。于四圣谛不欲故。无明缠故。苦是苦不欲不忍。习是习尽是尽道是道。不欲不忍。如饥饿人。初得恶食饱满。后得极妙食而不欲。如是彼痴如恶食。无明缠故。后甘露四谛而不欲。不欲故苦是苦不欲不忍。习是习尽是尽道是道不欲不忍。不欲故生犹豫。有苦耶无苦耶。有习尽道耶。无习尽道耶。是疑如是无明中转生疑。一切犹豫令定故。若得正说。便从正定有苦习尽道。此是正见。若得邪说。便从邪定无苦习尽道。此是邪见。如是彼疑中转生邪见。若无苦习尽道而有我。此是身见。如是彼邪见中转生身见。若有我者便作是念。是常耶是断耶。若见次第相似便作是念。有常也。此是计常见若见坏事便作是念。断也。此是断见。如是彼身见中转生俱边见。于中取一边净。以此为净为解脱出要。此是戒盗。如是彼边见中转生戒盗。若此为净解脱出要。是第一上最上妙最妙。此是见盗。如是彼戒盗中转生见盗。若彼已见便爱。此是爱使。他见便恚。此是不可使。彼见故贡高。此是慢使。如是彼见中转生使。使中转生缠。缠者十缠。嗔缠不语缠睡缠眠缠调缠悔缠无惭缠无愧缠悭缠嫉缠。于中嗔缠嫉缠依不可使。不语缠亦依爱亦依无明。依爱者。爱故覆藏。依无明者。无智故覆藏。睡调悭者依爱。眠无惭无愧悔依无明。更有说结垢依结。非根本结。愤依谄诳高害。于中愤害依不可使。依诳高依见盗。诳依五见。如是无明中转生一切结。是故说前。普者从阿鼻至第一有可得。是故说普。遍者非如前说。住一时中五种。因五种缘五种所使。问曰。若不尔者此云何。答曰。自界一切遍使中亦共一切遍使。非己界一切遍使中亦共一切遍使。己地一切遍使中亦共一切遍使。非己地一切遍使中亦共一切遍使。己界缘使中共缘使。非己界缘使中共缘使。己地缘使中共缘使。非己地缘使中共缘使。有漏缘使中共有漏缘使。无漏缘使中共无漏缘使。有为缘使中共有为缘使。无为缘使中共无为缘使。共一切结去洒散入内杂。谓彼尔所门尔所度令众生生死中痴。以是故。一切三界无明别立无明有漏。如佛契经说。彼不正思惟未生欲有漏便生。生已增广。问曰。如此结如所起随所灭住不过一时。何以故。说未生欲有漏便生生已增广。答曰。此说软中上故彼结软生。若不正思惟不依正事。便生中中增上。以故尔。尊者婆须蜜说曰。如佛说。若不正思惟未生。欲有漏便生。生已增广。云何增广。答曰。不应增广。但生复生故增广也。彼结一过生。若不正思惟不依正事便生至百千。是故说增广。重说曰。软中上故说增广。彼结软生。若不正思惟不依正事。便有中中增上。是故说增广。重说曰。不增广但生复生。重生故说增广。彼结软生。若不正思惟不依正事便有中。中有增上增上极增上。是故说增广。重说曰。不增广。但度境界故说增广。因一界生彼结生住已缘余界。舍彼已复缘余界。依眼生彼结。若不正思惟不依正事。彼复依耳鼻舌身意生缘色生。若不正思惟不依正事。彼复缘声香味细滑法生。是故说增广。尊者昙摩多罗说曰。诸尊不应增广。但人于一有中多行缠故说增广。问曰。彼何所说。答曰。彼尊者谓。一切众生结等生恶趣等至生第一有。亦等于中或多行结或不尔。是故说。诸尊人于一有中多行缠故说增广。或曰。受依果报果故说增广。谓结未起时亦不受依果报果。起已便受依果报果。是故受依果报果故说增广。或曰。与果受果故说增广。若结未起时亦不与果亦不受果。生已便与果受果。是故与果受果故说增广。或曰。与缘故说增广。彼结未起时不与次第缘。若起已便与次第缘。是与缘故说增广。如佛契经说。七有漏能多起忧悲恼。问曰。如三有漏。何以故说七有漏。答曰。此中说有漏具名有漏。如余具余为名。阿毗昙具以阿毗昙为名。乐具乐为名。如所说偈

  乐为揣食　　乐为持衣　　乐为行步
  依山窟间

垢具垢为名。如所说偈

  女垢梵行　　女缚世间　　苦行梵行
  此洗无水

使具使为名。如所说。比丘色所使色所爱。比丘所使者。即彼爱彼。爱已为魔所缚。欲具欲为名。如所说。五欲功德世间爱乐。念退具退为名。如所说。五因五缘等。意解脱阿罗汉若退若忘。云何为五。一者多诵。二者业。三者和合诤。四者远行。五者长病。行具行为名。如所说。此六更乐入本所作本所思本行所报。报具报为名。如所说。诸贤。我已一施报故。七生天上为天王。七生人为人王。如是有漏具有漏为名。尊者婆奢说曰。彼所说法竟。更有受化者来。彼能知此义异句异味。以是故。世尊。此义说异句异味也。尊者瞿沙说曰。佛说此契经中二漏。一者见断。二者思惟断。见断者如己像。思惟断者治故。彼思惟断者二种。一者须臾治。二者根本断。于五品中现须臾治。最后品现根本断。如佛契经说。彼如是知如是见。欲有漏心解脱。有有漏无明漏心解脱。问曰。如彼欲界除欲时。欲有漏心解脱。有想无想处除欲时。有有漏心解脱。何以故。有想无想处中说。欲有漏心解脱。有有漏无明漏心解脱。答曰。本已解脱。解脱为名。如已来来为名。如所说。大王从何所来。当尔时非是来。彼已来也。已取证证为名。如所说。菩萨于正中取证时得等智。如来得尽智无生智时。于欲得无欲无恚无愚痴。善根本已尽尽为名。如所说。彼苦已尽乐已尽。忧喜本已没。不苦不乐护念清净。于四禅成就游也。已正受正受为名。如所说。云何念入慈正受。答曰。欲令众生乐。已痛痛为名。如所说。彼觉乐痛时知乐痛。如是本已解脱。解脱为名。或曰。二俱永灭故说。二俱者。欲有漏无明有漏。有有漏无明有漏。彼欲界除欲时。虽有参差未永尽。彼有想无想处除欲时。永尽是二俱永灭故说。或曰。缚断故说。本际不可知。如彼有有漏无明有漏。于彼欲有漏断已。断还复缚。若有想无想处除欲已。彼缚至竟断。是缚断故说。或曰缘断故说。本际不可知。如彼有有漏无明有漏。彼欲有漏断已。断与三缘。次第缘缘缘增上缘。若有想无想处除欲已彼缘尽断。是缘断故说。或曰。责治故说。谓彼修行人有想无想处除欲已。彼欲有漏有有漏无明有漏。责数呵谏。我脱欲有漏有有漏无明有漏。谓将我生死中去欺调。是责治故说。问曰。如所说。彼如是知如是见。欲有漏心解脱。有有漏无明有漏心解脱。如一切心数法解脱。何故独说心解脱。答曰。妙说妙义故。彼一切心心数品中何者最妙心也。如所说。王共眷属行。或曰。谓说心主。因彼故立心数法。心者说大地。因彼故立十大地。或曰。谓彼神通作证时无碍道缘心。或曰。谓说远行。如所说偈

  远行独去　　无身依身　　难御能御
  是世梵志

或曰。谓说前去。如所说偈

  意法在前　　意妙意疾　　意为念恶
  若说若作　　罪苦自随　　轮道轹杀
  意法在前　　意妙意疾　　意为念善
  若说若作　　福乐自随　　影逐其形

或曰。谓彼说如王。如所说偈

  第六增上王　　以染而染之
  不染则无染　　染者谓之愚

或曰。谓说城主。如所说。比丘城主者。识盛阴是。或曰。谓能起善不善戒。如所说。他婆提不善戒从何所起者。我说有所起从心中起是。他婆提善戒从何所起者。我说有所起从心中起是。或曰。谓不等者生恶道。等者生天上。不等生恶道者。如所说。今是时鹦鹉童子。是兜他子若命终。如申臂顷入泥犁中。何以故。如彼于我起不善心。众生恶心故。身坏命终生恶趣中。等生天上者。如所说。今是时鹦鹉童子。是兜他子若命终。如申臂顷生天上。何以故。如彼于我起善心。众生善心故。身坏命终生天上。是故说谓不等生恶道等生天上。以故尔。或曰。谓彼心若依若行若缘随转。心数法亦尔。若心依眼随转心数法亦尔。若心依耳鼻舌身意随转。心数法亦尔。若心青行随转心数法亦尔。若心赤黄白行随转心数法亦尔。若心色缘随转。心数法亦尔。若心声香味细滑法缘随转。心数法亦尔。如鱼随所转。诸子亦尔。如是心若依若行若缘。随所转心数法亦尔。或曰。谓未调御不调御身行口行。所谓调御调御身行口行。谓不调御心数法亦尔。谓调御心数法亦尔。谓不定不定身行口行。谓定定身行口行。谓不正不正身行口行。谓正正身行口行。谓不软不软身行口行。谓软软身行口行。谓不持不持身行口行。谓持持身行口行。如彼法澡罐不覆口则漏覆则不漏。如是心不持已心数法。则漏色声香味细滑法中。心持已心数法。则不漏色声香味细滑法中。是故说谓不持心数法亦不持。谓持心数法亦持。喻如法澡罐。广说三有漏处尽

    鞞婆沙四流处第四

四流者。欲流有流无明流见流。问曰。四流有何性。答曰。欲流性二十九种。爱五恚五慢五疑四十缠。是二十九种欲流性。有流性二十八种。爱十色界五无色界五慢十色界五。无色界五。疑八色界四无色界四。是二十八种有流性。无明流性十五种。欲界无明五色界五无色界五。是十五种无明流性。见流性三十六种。欲界见十二色界十二无色界十二。是三十六种见流性。此百八种四流性。此是流性。已种相身所有自然。说性已当说行。何以故说流。流有何义。答曰。流下义是流义。漂义是流义。堕义是流义。流下义是流义者。流下诸界诸趣诸生流转生死中。是故说流下义。漂义是流义者。漂诸界诸趣诸生漂转生死中。是故说漂义是流义。堕义是流义者。堕诸界诸趣诸生堕转生死中。是故说堕义是流义。是故说流下义漂义堕义是流义。问曰。若流下诸界诸趣诸生流转生死中者。不应立上分结此亦将至上堕生上上界缚。答曰。不然。问曰。若不尔者此云何。答曰。诸界故立上分结。谓彼将至上堕生上上界缚。解脱故正智故圣道故善法故立流。虽生至第一有中故是下。解脱故正智故圣道故善法故。尊者婆跋罗茶亦尔说。久时生上。流下故是故说流。施扼故是故说扼。问曰。何以故。流中别立见流而不立有漏中。答曰。譬喻者四有漏。欲有漏有有漏无明有漏见有漏。谓我此欲流彼欲有漏。谓我此有流彼有有漏。谓我此无明流彼无明有漏。谓我此见流彼见有漏。说曰。彼譬喻者。于此中不问不答。问曰。若三有漏者此云何。答曰。佛世尊法真谛余真无能过。彼知法相尽知行。若有有漏相立有漏中。或曰。此见动摇除欲时随顺也。住欲时不随顺住义是有漏义。是故余不动摇。结住结烂结杂已立有漏中流下随顺。是故流中别立见流。或曰此见狂捷利行。住时不随顺住义是有漏义。是故余不动摇。结住结烂结杂已立有漏中流下随顺。是故流中别立见流。如二狂牛系在一扼。彼挽扼破已而走。如系一狂一不狂。彼不狂者能制狂者。如是见狂捷利行。住时不随顺住义是有漏义。是故余不动摇。结住结烂结杂已立有漏中流下随顺。是故流中别立见流。如四流四扼亦尔。问曰。何以故。一切经说流已。后说四扼。亦尔。答曰。所谓流则是扼。扼则是流。流下故说流。施扼故说扼。如此众生流所流下。扼者施扼。彼当云何不受生死苦。如彼牛在犁中。施扼已以杖捶。当云何不挽犁。如是众生流所流下扼者施扼。彼当云何不受生死苦。以是故一切经说流已后说扼亦尔。广说四流四扼处尽

    鞞婆沙四受处第五

四受者。欲受戒受见受我受。问曰。四受有何性。答曰。欲受性三十四种。爱五恚五慢五无明五疑四十缠。是三十四欲受性。戒受性六种。欲界二色界二无色界二。是六种戒受性。见受性三十种。欲界十色界十无色界十。是三十种见受性。我受性三十八种。爱十色界五无色界五慢十色界五无色界五无明十色界。五无色界五疑八色界四无色界四。此百八种四受性。此四受性已种相身所有自然。说性已当说行。何以故说受。受有何义。答曰。二事故说受。能燃行捷疾行。能燃行者。燃五趣中行。捷疾行者利故。或曰。三事故说受烧受断是故说受。问曰。云何烧义。答曰。薪义是受义。坏义是受义。缠义是受义。薪义是受义者。如因薪火燃。如是众生因结薪行火燃。是故薪义是受义。坏义是受义者。如利刺极入身中能坏身。如此受利刺极入法中能坏法身。是故坏义是受义。缠义是受义者。如蚕虫要以绵自缠而于中死。如是此众生要以结自缠而生恶趣中。是故缠义是受义。薪义坏义缠义是受义。问曰。何以故。无明有漏中别立无明漏。流中无明流。扼中无明扼。然受中不别立无明受。答曰。佛世尊于法真谛。余真无能过。彼尽知法相尽知行。谓法能担彼别立。或曰。前已说二事故。说受行燃捷疾行。彼无明虽燃五趣行。但非捷疾行。钝故烂故不利行故不定故不断故。或曰此前已说三事故。名为受能烧受断彼无明。虽有烧受但不断。捷利者。能断彼钝烂不利行不定不断。以是故受中不别立无明受。问曰。何以五见流中合立见流。扼中合立见扼。何以受中四见立见。受一见立戒受。答曰。佛世尊于法真谛。余真无能过。彼尽知法相尽知行。谓法能担别立。或曰。前已说二事故。说受行然捷疾行。彼戒盗等然五趣行等余见。或曰。前已说三事故。名为受能烧受断。彼戒盗等烧受断等余见。或曰。违道故远解脱故。违道者。欲种种苦行为清净。远解脱者。如彼依此见而远涅槃。或曰。二事欺诳故。二事者。此内法外法。问曰。云何此内法欺诳。答曰。等受持乞食粪扫衣露坐。受持沙门十二净行。如人似净行。如彼尊者婆耶。日日澡浴如似净行。如是此内法欺诳。此外法云何欺诳。谓欲种种苦行为净。此尊者瞿沙亦尔说。此世间现事如见火二事。欺诳如小儿。以是故受中四见立见。受一见立戒受。问曰。何以故说我受为行耶为缘耶。若行是我受者。应身见是我受。此是我行。若缘是我受者而无我。作此论已说曰。亦非行亦非缘。问曰。若不尔此云何。答曰。处所故。此欲界结欲处故。转行众生处故。具处故。色无色界结非欲处故。转行非众生处故。非具处故。但我处故。以故尔。如佛契经说。此四受者何本何习何生何缘。答曰。此四受无明本无明习无明生无明缘。问曰。如一切契经说。爱缘受。何以故。此契经中说无明缘受。答曰。为异学故。彼异学亦出家舍家妻子。无家无守不畜财宝。彼亦无多恶。但由无明故。依诸见令彼生恶趣中。如彼老象入污泥中而陷没。如是彼异学由无明故。依诸见令彼生恶趣中。以是故佛契经说。四受无明本无明习无明生无明缘。广说四受处尽

    鞞婆沙四缚受处第六

四缚者。欲爱身缚。嗔恚身缚。戒盗身缚。我见身缚。问曰。四缚有何性。答曰。欲爱身缚欲界爱五种。嗔恚身缚恚五种。戒盗身缚三界六种。我见身缚三界十二种。此二十八是四缚性。此缚性已种相身所有自然。说性已当说行。何以故说缚。缚有何义。答曰。束义是缚义。连续义是缚义。束义是缚义者。如彼施设所说。此无明未尽未知已彼彼身彼彼依彼彼得已身亦是因亦是缘。束而束遍束。连续相连续。如巧鬘师鬘师弟子。绳长綖已结作种种鬘。彼綖于彼华亦是因亦是缘。结而结遍结。连续相连续。如是此无明未尽未知已彼彼身彼彼依彼彼得已身亦是因亦是缘。束而束遍束。连续相连续。是故说束义是缚义连续义是缚义。相连续是缚义者。如彼契经说。当尔时香食(中阴也)。二心中必有一。或爱相应。或恚相应。是故说连续义是缚义。问曰。若此众生生死中。束而束遍束是缚义者。一切结亦尔。众生生死中束而束遍束。何以故。立四缚不立余。答曰。是世尊余言略言欲令行言。世尊为教化故。或曰。为人故为眷属故为器故为教化故。尊者瞿沙说曰。世尊于法真谛余真无能过。彼尽知法相尽知行。若有缚相立缚中。无缚相不立缚中。或曰。谓极缚三界众生。欲爱身缚嗔恚身缚极缚欲界众生。戒盗身缚我见身缚极缚三界众生。或曰。谓二事极缚白衣及学道者。欲爱身缚嗔恚身缚极缚白衣。戒盗身缚我见身缚极缚学道者。如白衣及学道。如出家及不出家。舍家妻子及不舍家妻子。有家无家。有畜财宝不畜财宝尽当知。或曰。谓能起二诤。一者淫欲故诤。二者见欲故诤。如彼契经。持澡罐杖梵志至尊者迦栴延所。而问迦栴延。何因何缘。王王共诤。梵志梵志共诤。居士。居士共诤。县县共诤。国国共诤。答曰。此梵志因淫欲着故。令此王王共诤。梵志梵志共诤。居士居士共诤。县县共诤。国国共诤。重问曰。迦旃延此沙门亦无家无所守不畜财宝。迦栴延何固何缘。沙门沙门共诤。答曰。见欲着故。此梵志沙门沙门共诤。谓彼能起二诤。一者淫欲。二者见欲。以故尔。如诤如是二边二箭二转二戏尽当知。以是故立四缚不立余。广说四缚处尽

鞞婆沙论卷第二鞞婆沙论卷第三

        阿罗汉尸陀槃尼撰

        符秦罽宾三藏僧伽跋澄译

    五盖处第七

五盖者。欲爱嗔恚睡眠调悔疑。问曰。五盖有何性。答曰。欲爱欲界五种六识身。嗔恚五种六识身。睡调二俱三界五种。不善无记一切染污心可得。于中不善者立盖中。无记不立盖中。眠欲界五种善不善无记。于中不善者立盖中。谓善无记不立盖中。悔欲界思惟断善不善。于中不善者立盖中。善者不立盖中。疑三界四种不善无记。于中不善者立盖中。无记者不立盖中。此三十种是五盖性此是性。问曰。彼有何相。答曰。谓彼性即是相相即是性。一切法中不可离性说相。尊者婆须蜜说曰。于中欲得欲者便起欲爱。令众生相违故起嗔恚。心没故起睡。已没不动便眠不息。相者是调心中生恨。种种恨所作恶故生悔。心中行未成意不定故便生疑。已说恨相当说行。可以故说盖。盖有何义。答曰。障义是盖义。坏义是盖义。破义是盖义。堕义是盖义。卧义是盖义。障义是盖者。而作障碍圣道及圣道方便善根。如彼契经所说。有树大树子小。而树大谓覆余小树。覆余树已坏破堕卧。此云何。一千阇那。二伽宾阇罗。三伊说多。四闭钵罗。五必楼叉。六优昙跋罗。七尼拘类。八那梨伽罗。此树大树子小。而树大覆余小树。覆余树已坏破堕卧。如大树覆小树已亦不生华不转成果。如是众生欲界心树盖所覆。不生觉意华。亦不转成沙门果。是故说障义坏义破义堕义卧义是盖义。问曰。若此盖作障碍圣道及圣道方便善根者。一切诸结亦作障碍圣道及圣道方便善根。何以故立五盖不立余。答曰。是世尊有余言略言欲令行言。世尊为教化故。或曰。佛世尊于法真谛余真无能过者。彼尽知法相尽知行。谓有盖相立盖中。或曰。谓彼三界除欲时。极作障碍非余。或曰。谓彼正受障碍及果障碍。正受障碍者。九次第正受作障碍。果障碍者。九断智果作障碍。或曰。欲爱者于离欲中而远离。嗔恚者于离恶中而远离。睡眠者于观中而远离。调悔者于止中而远离。彼远离已离欲离恶。止观失已便心中生疑。有恶法报耶。无恶法报耶。或曰。欲爱嗔恚者坏戒身。睡眠坏慧身。调悔坏定身。彼已坏三身。于心中便生疑。有恶法报耶。无恶法报耶。或曰。欲爱嗔恚坏戒。睡眠坏观。调悔坏止。彼坏三法已。于心中便生疑。有恶法报耶。无恶法报耶。或曰。谓欲界众生数数行行。此中几慢行。几见行。地狱中云。何行慢。岂可言我极烧汝。不知一切畜生岂有见耶。尊者瞿沙说亦尔。谓此欲界众生数数行行而不见咎。欲令见咎故说五盖。或曰。谓此因时作障碍。果时亦作障碍。因时作障碍者。若盖现在前。尔时不可善有漏心现在前。何况无漏果时作障碍者。若生恶趣中受恶报时。当尔时障碍一切诸功德。以是故佛契经立五盖非余。问曰。名五盖种有几。答曰。名五盖种有七。欲爱嗔恚疑者。名亦三种亦三。睡眠者名有一种有二。调悔者名有一种有二。如是五盖名有。五种有七。如名如种如是名数种数。名异种异。名别种别。名觉种觉。如是尽当知。问曰。若盖种有七。云何名立五盖。答曰。以三事故。一食一治等担。一食一治者。欲爱以何为食。谓净想也。以何为治。不净想也。如彼一食一治故立一盖。嗔恚以何为食。谓相违想也。以何为治慈也。如彼一食一治故立一盖。睡眠以何为食。愁忧不乐不欲食心没也。以何为治观也。如彼一食一治故二俱立一盖。调悔以何为食。亲里想国想种种想本戏笑想。已忆今忆当忆。以何为治止也。如彼一食一治故二俱立一盖。疑以何为食。因前故犹豫。因后故犹豫。因中故犹豫。内亦有犹豫。何谓此云何此众生从何所来当至何所。何因有云何有。以何为治。观缘起法也。如彼一食一治故立一盖。是故说一食一治。重担者。等欲爱嗔恚。疑别盖重担等。睡眠调悔二俱盖重担。如彼村人能独担材担。彼独担不能者二共担材担。如彼屋施椽。强者施一弱者施二。如是等欲爱嗔恚疑独盖重担等。睡眠调悔二俱盖重担。是三事故名立五盖。问曰。何以故佛契经。前说欲爱盖后说乃至疑。答曰。顺他说故如是顺他说。如是应味次第顺。或曰。世尊顺说故他亦顺受。故佛说如是顺受亦如是顺。或曰。本末顺故。本末顺者。前生欲爱。是故佛前说后至疑。是故佛后说。尊者婆须蜜说曰。爱乐境界故而起欲爱。若失爱乐境界而生嗔恚。已失爱乐境界便生忧戚。是睡身已着睡便眠。眠觉已便起调。起调已便起悔。悔随顺疑。有善法报耶。无有善法报耶。是本末顺故。佛契经前说欲爱后说乃至疑。此佛契经中五盖说十。问曰。何以故佛契经五盖说十。答曰。三事故内外故种故善不善故。内外者云何。佛说契经有内欲爱有外欲爱。如内欲爱即是盖。非智非等觉不转成涅槃。如外欲爱即是盖。非智非等觉。不转成涅槃。有内嗔恚想。有外嗔恚想。如内嗔恚想即是盖。非智非等觉。不转成涅槃。如内嗔恚想即是盖。非智非等觉。不转成涅槃。种者有睡有眠。如睡即是盖。非智非等觉不转成涅槃。如眠即是盖非智非等觉不转成涅槃。有调有悔。如调即是盖。非智非等觉不轮成涅槃。如悔即是盖。非智非等觉。不转成涅槃。善不善者。有疑善法有疑不善法。如疑善法即是盖。非智非等觉。不转成涅槃。如疑不善法即是盖。非智非等觉。不转成涅槃。是三事内外故种故善不善法故。佛世尊契经五盖说十。说曰。七使中无明不立盖中。慢不立盖中。见不立盖中。色无色界结不立盖中。问曰。何以故无明不立盖中。答曰。等重担故立五盖。无明极重也。问曰。慢何以故不立盖中。答曰。盖者心覆。慢者心受起能高。问曰。见何以故不立盖中。答曰。盖者灭慧见者性慧。不以慧灭慧。问曰。此论中更有论生。何以故盖灭慧不灭余。答曰。妙言妙义故。于一切品中何者最妙慧也。盖能灭慧况不灭余。如一胜彼当千。于凡小者有何想。如是盖能灭慧况余。问曰。色无色界结何以故不立盖中。答曰。盖者三界除欲时能障碍。非色无色界结除三界结时障碍。或曰。盖者正受障碍及果障碍。非色无色界结正受障碍及果障碍。或曰。盖者九断智果道障碍。非色无色界结九断智果道障碍。或曰。盖者九次第正受障碍。非色无色界结九次第正受障碍。或曰。盖者四沙门果障碍。非色无色界结四沙门果障碍。或曰。盖者三三昧障碍。非色无色界结三三昧障碍。或曰。盖者三地障碍非色无色界结三地障碍。或曰。盖者三根障碍。非色无色界结三根障碍。或曰盖者三道障碍。非色无色界结三道障碍。或曰。盖者三慧障碍。非色无色界结三慧障碍(一闻慧二思慧三思惟慧也)。如是说如是思如是出要尽当知。或曰。三正受障碍非色无色界结三正受障碍。如是三戒三思惟三法身尽当知或曰。盖者一向不善。非色无色界结不善。尊者瞿沙亦尔说。一切结应不善。圣道相违故。但盖咎故一向说不善。如佛契经说无明所盖爱所系。如是愚得此身。慧者亦尔。问曰。如无明亦可盖亦可结。爱亦可结亦可盖。何以故。无明说盖爱说结。答曰。应说若不说者。是世尊有余言现义义门义略义度当知义。或曰。现二门二略二度二炬二明二光现二数。如无明说盖。亦应说结如爱。说结亦应说盖。是故说现二门二略二度二炬二明二光现二数。或曰。前已障碍是盖义更无二结令此众生慧眼障碍。如无明前已说。缚义是结义更无二结。令此众生缚生死中。如爱如此众生无明所盲爱所缚。如是不能至涅槃。如人有二怨家。一来近已以一把土坌其目。二来近已系手足。彼盲被缚已不能有所至。如此众生无明所盲爱所缚。如是不能至涅槃。以是故说颂

  无明能使盲　　爱缚众生死
  彼于中可得　　诸恶不善法

此中说邻那摩倏喻。说者有二贼。一者邻那二摩倏。欲作贼时一来近已。以一把土坌其目。二来近已系手足。彼盲被缚已不能有所至。如是此众生无明所盲爱所缚。彼已盲已缚如是不能至涅槃以是故说颂(颂如上故不重写)。此中邻那摩倏喻(亦如上也)。以是故佛契经无明说盖爱说结。广说五盖处尽

    鞞婆沙五结处第八

五结者。爱结恚结慢结悭结嫉结。问曰。五结有何性。答曰。爱结者。三界爱五种此十五种。慢结亦尔。恚结者。五种悭结嫉结思惟所断。此三十七种。是五结性。此结性已种相身所有自然。说相已当说行。何以故说结结义云何。答曰。缚义是结义。苦系义是结义。杂毒义是结义。缚义是结义者。缚是结结是缚云何知。答曰。有契经尊者舍利弗问尊者摩诃拘絺罗。云何系者。拘絺罗。眼系色耶。色系眼耶。答曰。尊者舍利弗。不眼系色不色系眼。至意法不意系法不法系意。但此中若淫若欲是彼系也。尊者舍利弗。譬如二牛一黑一白一扼一鞅缚系。尊者舍利弗。若有作是说。黑牛系白牛白牛系黑牛。尊者舍利弗。彼为等说不。答曰。不也贤者拘絺罗。何以故。答曰。贤者拘絺罗。非黑牛系白牛。非白牛系黑牛。俱以鞅扼系。是彼系如是。尊者舍利弗。不眼系色不色系眼。至意法不意系法不法系意。但此中若淫若欲是彼系。是谓缚义是结义。若系义是结义者。欲界结欲界众生欲界。苦中系。色界结色界众生色界苦中系。无色界结无色界众生无色界苦中系。诸欲界结彼是系相。系苦中非是乐。诸色无色界结彼是系相。系苦中非是乐。是谓苦系义是结义。结杂毒义是结义者。极妙生处世俗正受。如解脱除入一切。入彼圣所除结杂毒故。如极妙食。杂毒慧者。能除以杂毒故。如是极妙生处世俗正受。彼圣能除结杂毒故。是谓系义是缚义苦系义是结义结杂毒义是结义。广说五结处尽

    鞞婆沙五下结处第九

五下分结者。欲爱嗔恚身见戒盗疑。问曰。五下分结有何性。答曰。欲爱者欲爱五种六识身。嗔恚者恚五种六识身。身见者三界一种是三种。戒盗者三界二种是六种。疑者三界四种是十二种。此三十一种是五下分结性。是下分结性已种相身所有自然。说性已当说行。何以故说下分结。下分结有何义。答曰。下堕下断下缚故说下分结。问曰。若下堕下分结义者。一切结下堕欲界三十六使。有想无想处二十八使。下堕下断下缚。因有欲界三十六使有想无想处二十八。下分结时须立无量下分结。何以故立五下分结。答曰。是世尊有余言。略言欲令行言。世尊为教化故。或曰。佛世尊于法真谛余真无能过。彼尽知法想尽知行。若有下分想彼立下分结中。若无下分相彼不立下分结中。或曰。下者说二种。一者界下。二者地下。界下者欲界是。地下者凡夫是。谓此众生不度下界。何以故。因欲爱嗔恚故不度下地。何以故。因身见戒盗疑故。复说下二种。一者界下。二者众生下。界下者欲界是。众生下者凡夫是。如此众生不度下界何以故。因欲爱嗔恚故。不度众生下。何以故。因身见戒盗疑故。或曰。谓彼说如守狱门人。如人系在狱中立二人。守狱门三人防逻。敕防逻人。若此狱囚作方便伤害。守狱门人突狱门走者。汝等三人随其远近摄来还系狱中。彼狱囚作方便伤害。守狱门人突狱门走。彼三防逻者。随其远近摄来还系狱中。如是此众生不净恶露伤害欲爱慈伤害恚。出欲界狱中至第一有。彼身见戒盗疑还摄来系欲界狱中。尊者瞿沙亦尔说。二下分结未尽未知不能出欲界狱中。三下分结未尽未知至第一有。还摄来系欲界狱中。尊者婆跋罗茶亦尔说。二系故不得出。三未尽故还来欲界中。或曰。此现门现略现度。若有尔所结。或一种二种四种五种。身见说已。当知已说一种。戒盗说已。当知已说二种。虽无余二结可得二种。当知即彼戒盗二种。及戒盗相应法。疑说已。当知已说四种。欲爱嗔恚说已。当知已说五种。故曰现门现略现度。以是故佛立五下分结。若问何以故佛欲爱嗔恚立五下分结中。谓彼三不善根处所中。答彼一切报此间。若问何以故佛身见戒盗疑立五下分结中。谓彼三结处所中。答彼一切报此间。如是彼二论报此论。如佛契经说。诸比丘。持我所说五下分结不。彼诸比丘默然。世尊再三告诸比丘。持我所说五下分结不。彼诸比丘亦再三默然。当尔时尊者鬘童真亦在众坐。于是尊者鬘童真从座起整衣服。偏袒右肩叉手向世尊。白世尊曰。唯世尊。我持世尊所说五下分结。如是说已。世尊告鬘童真曰。汝鬘童真。云何持我所说五下分结。鬘童真曰。世尊。初说欲爱下分结我持之。嗔恚身见戒盗疑。世尊。说五下分结我持之。世尊曰。汝鬘童真。云何持我所说五下分结。从何口受持我所说五下分结。我不一向说。汝愚痴人一向说。问曰。如此五下分结。佛一切契经中说。何以故世尊呵责鬘童真。答曰。尊者鬘童真行结故说。尊者鬘童真说。若行者是结不行者非是结。世尊未尽结故呵责。世尊说结行者不行者诸未尽者皆是结。或曰。尊者鬘童真结现在前故说。尊者鬘童真说。若结现在前即是结。不现在前非是结。世尊成就结故呵责。世尊说结若现在前者不现在前者诸结成就皆是结。以此事故孩童呵责喻而呵责之。鬘童真彼众多异学。不以此孩童呵责喻。责汝耶。鬘童如孩童年小未有欲意。欲令彼无有欲使耶。但所使故名为欲爱使。或曰。鬘童真现在结故说。尊者鬘童真说。若结现在是结余者非是结。世尊三世结故呵责。或曰。尊者鬘童真未尽结故说。尊者鬘童真说。若结未尽是结。余者非结。世尊说尽未尽故呵责。以是故佛世尊呵责鬘童真。广说五下分结处尽

    鞞婆沙五上结处第十

五上分结者。色爱无色爱调慢无明。问曰。五上分结有何性。答曰。色爱者。色界爱思惟断。无色爱者。无色界爱思惟断。调慢无明者。色无色界思惟断。此八种是五上分结性。是谓上分结性。已种相身所有自然。说性已当说行。何以故说上分。上有何义。答曰。将至上堕生上上界缚。是故说上分。问曰。若将至上堕生上上界缚是故说上分者。不应立流。此亦流下诸界诸趣诸生。流转生死中。答曰。不然。问曰。若不尔者此云何。答曰。诸界故立上分结。谓彼将至上堕生上上界缚。解脱故正智故圣道故善法故立流。离生至第一有中故是下。解脱故正智故圣道故善法故。尊者婆跋罗茶亦尔说。久时生上流下是故说流。说曰此上分结生上不是下。问曰。此论中更有论生。何以故上分生上不是下。答曰。见谛思惟断结亦生上亦生下。此上分结一向思惟所断。以是故生上不生下。或曰。谓此圣意中可得非凡夫。彼圣人阿那含意中可得。非须陀洹斯陀含。问曰。于此论中更有论生。何以故上分结阿那含意中可得。非须陀洹斯陀含。答曰。即彼事如上说。谓彼生上不生下。是须陀洹斯陀含亦生上亦生下。彼阿那含一向生上不生下。或曰。谓度界及得果。度界者欲界也。得果者阿那含果也。须陀洹斯陀含虽得果未度界。或曰。谓度界及下分永尽知。须陀洹斯陀含亦不度界。亦不下分结永尽知。或曰。谓得果行功德不行恶须陀洹斯陀含虽得果彼亦行功德亦行恶。或曰。谓得果不同凡夫行事转。须陀洹斯陀含虽得果彼同凡夫行事转。手搏加卷起身行口行。与妻子共居。捉持金银栴檀香华鬘着。身卧高广大床。摩触女身两两相近。阿那含永无此事。或曰。谓得果不复还世问。不入母胎。铜釜无囚狱。不复处生熟藏中。须陀洹斯陀含虽得果故有此事。以是故五上分结。阿那含意中可得非余。问曰。何以故一爱立二上分结。调慢无明立一。答曰。应立若未立者。是世尊有余言现义门现义略现义度当知义。或曰。佛世尊于法真谛余真无能过。彼尽知法性尽知行。诸法独能担彼独立。谓不能不独立。或曰。现二门二略二度二炬二明二光现二数。如爱立二上分结。如是调慢无明亦应立二。如调慢无明立一上分结。爱亦应立一。此上分应有四应有八。是故说现二门至现二数。或曰。谓爱断于界断于地断于种。或曰。谓爱故盛一切结。以是故爱立二上分结。调慢无明立一。问曰。如睡调二俱。三界有五种。一切染污意可得。何以故。调立上分结而不立睡。答曰。佛世尊于法真谛余真无能过。彼尽知法性尽知行。谛有上分相立上分结。无上分相不立上分结。或曰此谓盛患重过多苦以盛患故。婆须蜜经云。不善大地中以盛患故施设所说。凡夫起欲使时便生五法。一者欲爱使。二者欲爱使种。三者无明使。四者无明使种。五者调。以盛患故。阿毗昙杂揵度中问。云何不共无明使。云何不共调缠。此睡非多盛患非多重过非多苦。以是故不立上分结中。或曰。此调于四枝五枝定能起意。彼睡于定随顺。复次若意睡盛彼速发定。以是故调立上分结中不立睡问曰。五上分结。调是结性耶。非结性耶。若结性者。彼婆须蜜经云何通。彼经说结法云何九结是非结法。云何除九结已余法。是结非结性者。此经云何通。此中说五上分结。色爱无色爱调慢无明。是作此论已说曰。是结性也。问曰。以是故此经中立五上分结。彼婆须蜜经云何通。彼说结法云何九结是非结法。云何除九结已余法。是外者作是说。此经应尔。结法云何九结。及五上分调是非结法。云何除九结及五上分调余法。是外者此经如是说罽宾此经何以故不作是说。答曰。应说若未说者何意。答曰。彼罽宾说。此五上分结调不定。或是结或非是结。或有结者或无结者。有时结有时非结。或是结或非是结者。谓色无色界是结。谓欲界非是结。或有结者或无结者。谓圣人意可得是结。谓凡夫人意可得是非结。有时结有时非结者。彼圣人中谓阿那含意可得是结。谓须陀洹斯陀含意可得是非结。以不定故。或是结或非是结。或有结者或无结者。有时结有时非结。以是故不立结中。问曰。于此论中更有论生。何以故色无色界调立结。欲界调不立结。答曰。此欲界非定界。非思惟地。非除欲地。此欲界中结如放逸马。以是故调此欲界不现。色无色界是定界思惟地除欲地。彼结不如放逸马。是故彼中调现。以是故色无色界调立结中。欲界调不立结中。或曰。此欲界多结非是法法想。如嗔愤不语。依诳谄高害。此非是法法想。坏故此中调不现。彼色无色界无此非是法法想。结于彼中调现。以是故色无色界调立结中。欲界调不立结中。或曰。此欲界非定界。非思惟地。非除欲地。此中无有定。谓调可乱意。色无色界是定界。是思惟地。是除欲地。彼四枝五枝定中调起意。以是故色无色界调立结中。欲界调不立结中。广说五上分结处尽

    鞞婆沙五见处第十一

五见者。身见边见邪见见盗戒盗。问曰。此五见有何性。答曰。身见三界一种此三种。边见亦尔。邪见者三界有四种。此十二种。见盗亦尔。戒盗者三界有二种此六种。是三十六种五见性。是见性已种性身所有自然。性说已当说行。何以故名为见。见有何义。答曰。观故行故坚受故缘深入故。观者能视也。问曰。如邪观颠倒观云何是视。答曰。虽邪观颠倒观但慧故名视。此是慧性。如人见不了了亦名为见。如是邪观颠倒观但慧故名为视。此是慧性故。曰观行者能有所行。问曰。一时顷云何行。答曰。捷利故名为行。故曰行。坚受者。邪事坚受故。此见邪事极坚受。非圣道刀不舍。如佛佛弟子兴已。以圣道刀堕见牙然后舍。以是故说颂曰

  若受恶慧　　如鳣鱼啮　　失搔摩衔
  非斧不离

说者大海中有虫。名失搔摩罗。彼虫若有所衔时。若草若木彼极衔非刀不离。要以刀堕其牙然后得离。如是此见邪事极坚受。非圣道刀不舍。若佛佛弟子兴已。以圣道刀。堕见牙然后舍。故曰坚受。缘深入者。此见缘中极入如针堕泥。是观故行故坚受故缘深入故名为见。或曰。二事故名为见。明故行故也。或曰更有二事故名为见。彼相成就故。彼事办故也。或曰。三事故名为见。彼相成就故彼事办故。缘深入故也。或曰。更有三事故名为见。意故着故行故也。或曰。更有三事故名为见。意故方便故无智故。意者恶意也。方便者恶方便也。无智者此二事俱也。复说意者正受人也。方便者察行人也。无智者依二闻也。如是共行说已今当别说。何以故名为身见。答曰。此见己身转行。是故说身见。问曰。余见亦己身转行。何以故说一身见不说余。答曰。此身见一向己身转行。非是他身亦非非身。余见亦己身转行。亦他身转行。亦非身转行。己身转行者。己界缘也。他身转行者。他界缘也。非身转行者。尽道缘也。此身见一向己身转行。非他身非非身转行。是故说一身见非余。或曰。谓己身转行我。是我转行此是身行。余者虽己身转行无此事。或曰。谓己身转行我作。是我作转行是身见。余者虽己身转行无此事。或曰谓己身转行着行惜行。我所行转行此是身见。余者虽己身转行无此事。或曰。谓己身转行诸事我受尽是己身所转行。余者虽己身转行无此事。或曰受己身故名为身见。己身者五盛阴。此见受彼故曰身见。余见者虽己身转行无此事。问曰。何以故名为边见。答曰。受二边故名为边见。二边者。一者断二者常。此见受彼二边故曰边见。如彼契经说。迦旃延。世间习者。正观如实世间有非有。如观阴持入展转相生。便作是念。此起已灭非是常也。迦旃延。世间灭者。正观如实世间无者非有。如观身转生上。彼作是念。此终亦生非是断。或曰。此因二行所转断行及常行。故曰边见。或曰。彼异学边受痴受不正受谓有我彼或常或断。如佛契经说诸比丘。我不共世间诤。世间共我诤。问曰。世尊以何故不共世间诤。答曰。世尊善等能共事不粗言。若断见异学共俱。彼断见异学有因无果谓彼果断。世尊说者。汝有因我亦有因。如汝谤果汝自当知。若常见异学共俱。彼常见异学无有因而有果。谓彼无因是有常。世尊说者。汝有果我亦有果。汝谤因汝自当知。彼世尊取一边因取二边果。已离断常处中说法。是故说。比丘我不共世间诤。世间共我诤。尊者婆须蜜说曰。如世尊所说。比丘我不共世间诤。世间共我诤。何以故佛不共世间诤。世间共佛诤。答曰。世尊说法世间说非法。不可说法共非说法诤。重说曰。世尊于等中随顺。世间不与世尊第一义随顺。是故说。比丘我不共世间诤。重说曰。善除二诤根故。二诤者爱及见。此二世尊已尽世间未尽。是故说。比丘我不共世间诤。尊者昙摩多罗说曰。诸尊如马依恶道。当观不得正道。如是彼异学不正说。当观是非正说。世尊现义现法现善现妙故。当观是正说。是故说比丘我不共世间诤。世间共我诤。问曰。何以故说邪见。答曰。邪行故说邪见。问曰。如一切见邪行。何以故说一邪见不说余。答曰。二事故名邪见。及无行转说邪见。余者虽邪行转无此二事。或曰。谓邪行转谤众生恩及法恩。谤众生恩者。说无有父母。谤法恩者。说世间无阿罗汉善逝等正法等正趣。谓此世后世自知作证成就游也。余者虽行转无此事。或曰。谓邪行转及无行转。说无有施无有齐无有说。无善行恶行果报。无有此世后世。如是广说。余者虽邪行转无此事。或曰。谓邪行转尽谤因及果。亦谤过去当来现在如来。无著等正觉道。亦谤三宝及四谛。余者虽邪行转无此事。或曰。谓邪行转谤现事。如人堕大火坑中。诳他故说我极乐。如是众生受有如热铁丸。邪见故说无苦。余者虽邪行转无此事。或曰。谓邪行转说恶。如所说居士邪见人。诸身行口行意行思愿及彼相应行。一切彼法不爱不念不喜不喜不欲而转。何以故居士见恶谓邪见居士。如苦瓠子婆檀鞮伽子摩楼多子尸婆梨子种着地中。若受地味水味火味风味。彼一切味转苦无味不甜。何以故居士谓种子苦也。如是居士邪见人。诸身行口行意行思愿及彼相应行。一切彼法不爱不念不喜不喜不欲而转。何以故居士见恶谓邪见故。余者虽邪行转无此事。问曰。何以故说见盗。答曰。见故名为见盗。问曰。如此盗一切五阴。何以见盗故名为见盗答曰。因见起盗。一切五阴故说见盗。或曰。设见盗及盗五阴但第一行故名为见盗。问曰。何以故说戒盗。答曰。戒故名为戒盗。问曰。如此盗一切五阴。何以故戒盗故名为戒盗。答曰。因戒起盗。一切五阴故说戒盗。或曰。说戒盗及盗五阴但净行故说戒盗。问曰。何以故说盗。答曰。他所见而盗故说盗。谓彼身见受我。边见者受断及常。邪见谤言无彼见盗。而受第一戒盗受清净。是他所见而盗故说盗。广说五见处尽

    鞞婆沙六身爱处第十二

六身爱者。眼更爱耳鼻舌身意更爱。问曰。应说一爱。如九结中三界爱立爱结。应说二如七使中欲界爱立欲使。色无色界爱立有使。应说三如所说欲爱色爱无色爱。应说四如起四爱。彼说比丘比丘尼。因依爱起而起着而着立而立。因食床卧。依此有比丘比丘尼爱起而起着而着立而立。应说五如见苦断见习尽道思惟断。应说九如九种增上。增上上增上中增上下。中上中中中下。下上下中下下。应说十八。如说十八意行。应说三十六如三十六刀。应说百八爱。如百八痛。时故意故无量爱云何一爱广施六中云何无量爱略施六中。云何立六身爱。答曰。依故立六身爱。若有一爱及无量。彼一切依六行六门六迹六道六度六识身相应。是依故说六身爱。问曰。恚及无明亦依六行六门六迹六道六度六识身相应。何以故说六爱身。不说六恚及无明身。答曰。是世尊有余言。此现义义门义略义爱当知义。如说六身爱恚无明亦尔。若不说何意。答曰。谓爱界断地断种断。或曰。谓爱盛一切诸结。或曰。谓爱不大增恶难除。恚大增恶易除。无明亦大增恶难除以故尔。问曰。何以故说身。答曰。多身故说身。非一爱时名眼更爱。非一爱时乃至意更爱。但多爱时说眼更爱。多爱时说乃至意更爱。如非一象名象军。非一马名马军。非一车名车军。非一步名步军。但多象名象军。多马名马军。多车名车军。多步名步军。如是非一爱时说眼更爱。非一爱时说乃至意更爱。但多爱时说眼更爱。多爱时说乃至意更爱。是多身故名为身。广说六身爱处尽

    鞞婆沙七使处第十三

七使者。欲使恚使有使慢使无明使见使疑使。问曰。七使有何性。答曰。欲使者欲界爱五种六识身。恚使者恚五种六识身。有使者色无色界爱五种。慢使者三界五种。此十五种。无明使亦尔。见使者三十六种。疑使者三界四种。此十二种。此九十八种是七使性。是使性已种相身所有自然。说性已当说行。何以故说使。使有何义。答曰。罽宾说三句。如豪使亦尔。所使是使相逐是使。如豪使亦尔者。豪者说细如豪。所说七使成一豪。是说豪使亦尔。所使是使者。至一时中所使。一使中亦所使。是所使是使也。相逐是使者。彼意中所使。犹影相逐。如空行水行此亦尔。空行者鸟。水行者虫说者如鸟飞空迳游大海。彼诸水虫作是念。此大海水无量深广。非是凡鸟能从此岸至彼岸。除一金翅鸟。虫知此鸟飞必堕水。见影便逐鸟极堕水虫得而食。如是未除欲众生。一切时七使得现在相逐。若结现在前。当尔时爱非爱依果报果。是故相逐是使。或曰。如豪使亦尔者。熏坚着故。所使是使者行也。相逐是使者事也。或曰。如豪使亦尔者。细事也所使是使者性也。相逐是使者。熏坚着也。或曰。如豪使亦尔者。过去使也。所使是使者现在也。相逐是使者当来也。或曰。如豪使亦尔。所使是使者。心相应使也。相逐是使者。心不相应使也。问曰。如使无不心相应。答曰。彼使得以使为名。外者说四句。如豪使亦尔。相入是使。所使是使。相逐是使。如豪使亦尔者。豪者说细也。如所说此极细行也。相入是使者。于意中相入。如麻中有油。如杏人中腻。所使是使者。于意中所使如乳母为婴儿所使。相逐是使者。于意中相逐如影逐身。或曰。如豪使亦尔者性也。相入是使者事也。所使是使者行也。相逐是使者。熏坚着也。或曰。以三事得知使。一者性二者果三者人。性者欲使者如甜药草。恚使者如苦果子。有使者如乳母衣。慢使者如憍贵人。无明使者如盲人。见使者如迷失道。疑使者如惑二道。是说性也。果者欲使修习多修习生雀鸳鸯鸽中。恚使修习多修习生蛇蚖中。有使修习多修习生色无色界中。慢使修习多修习生下贱中。无明使修习多修习生愚闇中。见使修习多修习生异道中。疑使修习多修习生边地中。是说果也。人者欲使者当观如难陀。恚使者当观如贳合及鸯掘摩。有使者当观如阿私陀阿罗兰郁头蓝子也。慢使者当观如摩那多陀。无明使者当观如郁鞞罗。见使者当观如鬘童真。疑使者当观如须那刹多罗。是说人。以是三事得知使。一者性。二者果。三者人。问曰。悭嫉何以故不立使中。答曰。佛世尊于法真谛。余真无能过。彼尽知法相尽知行。谓有使相立使中。谓无使相不立使中。或曰。说结二种。一者具结。二者不具结。具结者立使中。不具者不立使中。或曰。谓结见断思惟断彼立使中。此悭嫉一向思惟断。以是故不立使中。或曰。此悭嫉者厚浊使者清薄。或曰。悭嫉熏不坚着。使者熏坚着。如处所烧草树皮。火灭地即冷。悭嫉行亦尔。如处所烧狗骨木。彼火灭久地故。热使行亦尔。以是故悭嫉不立使中。广说八使处尽

    鞞婆沙九结处第十四

九结者。爱结恚结慢结无明结见结失愿结疑结悭结嫉结。问曰。九结有何性。答曰。爱结三界五种是十五种。慢结无明结亦尔。恚结五种六识身。见结十八种。失愿结亦尔。疑结三界四种是十二种。悭嫉结欲界思惟断。此五种是九结性。是结性已种相身所有自然。说性已当说行。何以故说结。结有何义。答曰。缚义是结义。苦系义是结义。结杂毒义是结义。缚义是结义者。缚是结结是缚。云何知。答曰。有契经。彼契经尊者舍利弗问尊者摩诃拘絺罗。云何贤者拘絺罗。眼系色耶色系眼耶。答曰。尊者舍利弗。不眼系色不色系眼。至意法不意系法不法系意。但此中若淫若欲是彼系也。尊者舍利弗。譬如二牛一黑一白一扼一鞅缚系。尊者舍利弗。若有作是说。黑牛系白牛白牛系黑牛。尊者舍利弗。彼为等说不。答曰。不也。贤者拘絺罗。何以故。答曰。贤者拘絺罗。非黑牛系白牛非白牛系黑牛。但以扼鞅系是彼系。如是尊者舍利弗。不眼系色不色系眼至意法不意系法不法系意。但此中若淫若欲是彼系。是谓缚义是结义。苦系义是结义者。欲界结欲界众生欲界中苦系。色界结色界众生色界中苦系。无色界结无色界众生无色界中苦系。诸欲界结彼是系相。系苦中非是乐。诸色无色界结彼是系相。系苦中非是乐。是谓苦系义是结义。结杂毒义是结义者。极妙生处世俗世受。如解脱除入一切。入彼圣所除结杂毒故。如极妙食杂毒。慧者能除。以杂毒故。如是极妙生处世俗正受。彼圣能除结杂毒故。是谓系义是缚义。苦系义是结。义杂毒义是结义。共行说已当别说行。爱结云何。答曰。三界爱也。问曰。何以故使中欲界爱立欲使。色无色界爱立有使。如是余契经中说三爱。欲爱色爱无色爱。何以故。此契经一切三界爱立一爱结。答曰。佛世尊于法真谛。余真无能过。彼尽知法相尽知行。谓法独能担彼独立。若不能独担彼立品。或曰。世尊教化或有利根或中根或软根。利根者一切三界爱说一爱结。中根者说二爱。如使中欲界爱立欲使。色无色界爱立有使。软根者说三爱如所说三爱欲爱色爱无色爱。或曰。复次世尊教化。或欲略或欲广或欲略广。谓欲略者彼三界爱说一爱结。谓欲广者彼说三爱。如所说三爱。欲爱色爱无色爱谓欲广略者彼说二爱。如使中欲界爱立欲使。色无色界爱立有使。或曰。复次世尊教化或始行或少习行或已成行。谓始行者彼说三爱如所说三爱。欲爱色爱无色爱。谓少习行者彼说二爱。如使中欲界爱立欲使。色无色爱立有使。谓已成行者彼三界爱说一爱结。或曰。前已说苦系义是结义。谓欲界爱此是系相。系苦中非是乐。谓色无色界爱彼一切系相。系苦中非是乐。是等共一相故。以是故世尊一切三界爱立爱结。问曰。恚结云何。答曰。于众生起恶。问曰。如非众生亦起恶。何以故说于众生起恶。答曰。因众生起恶。于非众生亦起恶。或曰。多故多因众生起恶少非众生。或曰。多增恶故。多增恶于众生起恶。少增恶非众生。问曰。慢结云何。答曰。七慢谓之慢结。七慢者。慢增上慢慢增慢我慢欺慢不如慢邪慢此七慢谓之慢结。问曰。无明结云何。答曰。三界无知也。问曰。见结云何。答曰。三见谓之见结。三见者。身见边见邪见。是三见谓之见结。问曰。失愿结云何。答曰。二盗谓之失愿结二盗者。见盗及戒盗。是二盗谓之失愿结。问曰。何以故使中五见立一见使。结中二见立见结。二见立失愿结。答曰。佛世尊于法真谛余真无能过。彼尽知法相尽知行。谓法能独担彼独立。谓不能独担彼立品。或曰。前已说苦系是结义。谓身见彼名女系。苦中非是乐。谓边见及邪见彼亦名女系。苦中非是乐。是等共一名一性故。三立一见结。谓戒盗彼名界。系苦中非是乐。谓见盗亦名界。系苦中非是乐。是共一名一性故。是二见立一失愿结。或曰。谓彼种等摄亦等。种等者谓见结十八种。失愿结亦十八种。摄等者见结摄十八使。失愿结亦摄十八使。谓彼种等摄亦等。以是故结中三见立见结。二见立失愿结。问曰。疑结云何答曰。于谛犹豫也。问曰。何以作是说于谛犹豫。答曰。不定者欲令定故。欲令定者。若远见生犹豫。是女耶非女耶。是男耶非男耶。见二道已生犹豫。是道耶非道耶。见二衣生犹豫。是我衣耶非我衣耶。莫作是念。是根本疑结。此是一切欲界不隐没无记耶行也。谓彼不定说欲令定。问曰。疑结云何。答曰。于谛犹豫是谓根本疑结。问曰。嫉结云何。答曰。心恚也。心恚者此结恚相也。问曰。悭结云何。答曰。心不欲舍也。心不欲舍者此结贪相也。问曰。何以作是说。答曰。不定者欲令定故。欲令定者。此世间嫉中悭想悭中嫉想。嫉中悭想者谓见他好物而起嫉彼物于我好。彼物于我好。世间见已作是念。此人极悭。彼非悭是嫉也。悭中嫉。想者。如守己妻子财宝。是物于此中莫出。是物于此中莫出。世间见已作是念。此人极嫉。此非嫉是悭也。谓彼不定嫉中悭想悭中嫉想。说欲令定。问曰。嫉结云何。答曰。心恚也。心恚者此结恚相也。问曰。悭结云何。答曰。心不欲舍也。心不欲舍者此结贪相也。问曰。何以故十缠悭嫉立九结中余不立。答曰。佛世尊于法真谛余真无能过。彼尽知法相尽知行。谓有结相立结中。谓无结相不立结中。或曰。现后现边。彼十缠何谓后何谓边。悭嫉也。以是故十缠中悭嫉立九结中。余不立也。或曰。谓卑结贱妾结秽结弊结。若见他得恭敬供养。何故见已起嫉者。有百千无量钱财。于中不能持一钱。从今世至后世于中何故起悭。是谓卑结贱妾结秽结弊结。故十缠悭嫉立九结中不立余。或曰。谓因此悭嫉众生生死中受无量轻易。世间二所轻易。一者贫穷。二者丑陋。嫉结修习多修习便丑陋。悭结修习多修习便贫穷。此二贫穷及丑陋。父母轻易兄弟姊妹亦轻易。至己妻子亦轻易。以是故十缠悭嫉立九结中不立余。或曰。谓此悭嫉如守狱卒。如众生系在狱中。立二狱卒守门令不得出。如园观极严治已。立二人守门不令入。如是此众生不出恶趣如狱囚者。由悭嫉故。不入天人如园观者。由悭嫉故。以是故十缠悭嫉立九结中不立余。或曰。谓因悭嫉天阿须罗数数共斗。如彼契经。释提桓因至世尊所而问。大仙人。天及人阿须罗揵沓和迦留罗罗刹如是及余各异身有几结。世尊告曰。拘翼。天及人阿须罗揵沓和迦留罗罗刹。各异身有二结。悭及嫉。问曰。如此天及人或九结或六结或三结或无结。有九结者一切凡夫人。有六结者如凡夫欲爱尽。及圣人欲爱未尽。有三结者如圣人欲爱尽。无结者阿罗汉。天及人独成就二结。悭及嫉。何以故。告拘翼。天及人阿须罗揵沓和迦留罗罗刹。如是及余各异身有二结悭及嫉耶。答曰。谓悭嫉是豪贵结。彼释提桓因于二天中增上豪贵主。彼为此重担悭嫉所缠。世尊为彼讥刺义故说。拘翼天及人阿须罗揵沓和迦留罗罗刹。如是及余各异身有二结。悭及嫉。汝因悭嫉重担所缠。或曰。以此悭嫉故。令天阿须罗数数共斗。彼释提桓因畏阿须罗。为阿须罗所娆。离战处不久。至世尊所而说义。世尊。何因何缘天及阿须罗数数共斗。世尊为说义。拘翼。因悭嫉故天及阿须罗数数共斗。天上食妙。阿须罗有美女。彼诸天于食悭。不欲令阿须罗得。于女嫉令我得。阿须罗于女悭。不欲令天得。于食嫉令我得。彼天来下为女故。阿须罗至天上为食故。如是天及阿须罗数数共斗。彼释提桓因畏阿须罗所娆。离战处不久至世尊所而问。大仙人。天及人阿须罗揵沓和迦留罗罗刹。如是余各异身有几结。世尊告曰。拘翼。天及人阿须罗揵沓和迦留罗罗刹。及余各异身有二结悭及嫉。以是故十缠悭嫉立九结中不立余。广说九结处尽

    鞞婆沙九十八使处第十五

九十八使者。欲爱五恚五。色无色爱十慢十五无明十五见三十六疑十二。问曰。何以故作此论。答曰。如守本文沙门。断彼意故作此论。如名守本文沙门者。是一切佛契经如本所说而执持。问曰。彼何以故作是念。答曰。彼作是说。更谁有力胜于佛者。谓佛契经说七使。彼当能作九十八使耶。谓彼欲尔者欲断彼意故。此中九十八使说如实相。以是故作此论。佛契经说七使。彼分别界行种起九十八使。分别种者。谓七使。欲爱使中分别种。于九十八使中起五种恚使亦尔。分别界种者。谓七使中有爱使者。使分别界种。于九十八使中起十使。若七使中慢使。亦分别界种。于九十八使中起十五种。无明使亦尔。谓七使中疑使。彼亦分别界种。于九十八使中起十二种。分别界行种者。谓七使中见使。分别界起十五欲界五见色无色界五见。分别行者。十八欲界六色无色界六。分别种者有四。如是五见分别界行种。于九十八使中起三十六使。是谓七使分别界分别行分别种。便起九十八使。广说九十八使处尽。鞞婆沙说不善品小章竟

鞞婆沙论卷第三鞞婆沙论卷第四

        阿罗汉尸陀槃尼撰

        符秦罽宾三藏僧伽跋澄译

    解十门大章

二十二根。十八界十二入五阴。五盛阴六界。色法无色法。可见法不可见法。有对法无对法。有漏法无漏法。有为法无为法。过去法未来法现在法。善法不善法无记法。欲界系法色界系法无色界系法。学法无学法非学非无学法。见断法思惟断法。无断法。四谛四禅四等四无色定。八解脱。八除入。十一切入。八智三三昧。三结。三不善根。三有漏四流四扼四受四缚。五盖五结五下分结五见。六身爱七使九结。九十八使

    鞞婆沙二十二根处第十六

二十二根者。眼根耳鼻舌身意根。男根女根命根乐根苦根喜根忧根护根信根精进念定慧根。未知根已知根无知根。问曰。何以故。彼作经者依二十二根而作论。答曰。彼作经者意欲。亦如所欲。如是作经与法不相违。以是故依二十二根而作论。或曰。彼作经者无事。问曰。何以故彼作经者无事。答曰。此是佛契经。佛契经说二十二根。彼作经者于佛契经中依本末处所已。此阿毗昙中作论。彼作经者不能二十二根中减一根。已立二十一。增一已立二十二。问曰。何以故。答曰。所谓是一切佛契经。亦不增亦不减。不增者无增可减。不减者无减可增。如不增不减。如是无量深无边。无量深者无量义故。无边者无边味故。如大海无量深无边。如是佛契经无量深无边。无量深者无量义故。无边者无边味故。如尊者舍利弗。如是比百千那术。以佛契经二句作百千经。令智尽而住不能尽佛契经。或曰。得其边崖。如佛契经此论。是故作经者无事。问曰。置彼作经者。何以故佛契经说二十二根。答曰。佛世尊为教化故说二十二根。彼受化者应须二十二根。或曰。契经有本末有因有缘。问曰。契经有何本末。答曰。说者有生闻梵志。彼中食后彷佯游行至世尊所。到已共世尊面相慰劳已。在一面坐。一面坐已。生闻梵志白世尊曰。瞿昙。我欲少有所问。听我所问当为我说。世尊告曰。梵志。随所欲问。梵志曰。瞿昙。根谓根。瞿昙。根有几所。云何瞿昙。根根所摄。施设而施设。世尊告曰。汝梵志。有二十二根。从眼根至无知根。此梵志有尔所根。如是如来根根所施设而施设。梵志。若如是说此非根。如沙门瞿昙所施设。我舍此根更施设余根者。彼但有言。数问已不知增益生痴。何以故。如非境界。如梵志问佛答。是故契经不必索本末此应索。彼梵志何以故问根不问界入阴谛沙门果道品缘起。有一说者。谓彼梵志疑而问。不疑不问。或曰。彼梵志善能求喜行。彼尽游九十六种道。为施设根故。彼或有一为施设根如尼揵。是故彼不截菜。亦不饮冷水。谓彼于外物计有命想。问曰。彼尼揵于外物有何根想。一说。者意根也。复有说者。命根也。如是说者意根及命根。更复有施设二根行及意。复有施设二根。若眼不见色耳不闻声。彼是圣修诸根如彼波罗施。问曰。何以故名波罗施。答曰。是彼名名波罗施。或曰。彼姓波罗施。是故名波罗施。如姓婆蹉拘蹉婆罗婆羯提罗。如是彼姓波罗施。是故名波罗施。若母刹利种父梵志种。此亦名波罗施。母梵志种父刹利种。亦名波罗施。如从驴马生名为骡。此梵志姓名波罗施。彼弟子名郁多罗。中食后彷佯行至世尊所。到已共世尊而相慰劳已。却坐一面。坐一面已。世尊告曰。郁多罗。汝师波罗施为弟子说修根不。郁多罗白世尊曰。如是瞿昙。波罗施为弟子说修根。世尊告曰。郁多罗。云何波罗施为弟子说修根。郁多罗曰。唯瞿昙。眼不见色耳不闻声。彼是圣修诸根。世尊告曰。如是郁多罗。盲者为修根。郁多罗。盲者眼不见色。彼时尊者阿难在世尊后。手执拂拂世尊。于是尊者阿难告郁多罗曰。如是郁多罗。聋者为修根。郁多罗。聋者耳不闻声。问曰。如尊者舍利弗。如是比百千那术。世尊能答彼能断意。何以故世尊答一。阿难答二。何以故。世尊不止阿难。答曰。世尊知阿难言在咽喉欲语。世尊三阿僧祇劫百千苦行已终不断他辩。以是故本师赞曰

  己弟子说法时　　专心听不断论
  以是故在众说　　于中间无能难

以是故不止。或曰。世尊作是念。若我说阿难比丘说亦尔。彼不增不减。如不增不减。以是故不止。或曰。断彼异学意故。若世尊说一阿难不说二。彼异学还至己众已。当自称誉。彼师伏我非弟子。我师往者彼不能伏。若世尊说一阿难说二。令彼异学势力断。彼作是念。我不与弟子何况师。是断彼异学意故。世尊说一阿难说二。或曰。欲满彼异学意愿故。彼异学作是念。此沙门瞿昙不可伏不可胜。一切师最妙。谓本大师者彼亦不能伏。此况复如我比。我正可共弟子论。世尊常欲满彼意所欲愿。随所应解而为说。是故欲满彼异学意愿故不止。或曰。义证故。阿难彼异学所宗敬。能说因提书。及容色妙故。世尊说。以此住问是法应汝所说不。以是义证故。世尊说一阿难说二。或曰。异学不欲令弟子有所说恐还难问使我堕不如故。世尊无此事。如尊者舍利弗所有智。百千那术数不能及佛。况复余者。以是故世尊不止阿难。或曰。现己无悭嫉妒故。异学不欲令弟子有所说。恐我所得供养弟子得故。世尊无此事。如世尊所得恭敬供养。尽令一切众生得。佛不得者于此处亦不忧戚。是谓现己无悭嫉妒故不止阿难。或曰。现善说法故。成就说法故。一见一慧一欲一忍故。彼异学法不善说。如破塔不可依。如是彼意尽坏志亦坏。师志异弟子志异。此法无彼咎。如师志弟子亦尔。义同义句同句味同味乃至同第一义。是谓善说法故。成就说法故。一见一慧一欲一忍故。以是故。世尊说一阿难说二。故世尊不止阿难。问曰。世尊说彼异学有何咎。彼说亦尔。盲及聋圣修根。答曰。佛报彼梵志。极大咎断一切意。世尊说曰。若汝言聋盲圣修根者。为唐出家虚剃须发空修梵行。应坏此二根眼根及耳根。如是即圣修根。以是故。佛报梵志。极大咎断一切意。复有施设五根。香味眼皮耳根。香者鼻根。味者舌根。眼者眼根。皮者身根。耳即耳根。施设如毗施师也。复有施设十一根。五觉根五行根。五觉根者。眼耳鼻舌身根。五行根者。手根足根口根大便根小便根意根。为十一如僧呿也。复有施设百二十根。问曰。云何异学施设百二十根。答曰。九十八使及二十二根也。如是说此不论。彼异学不能分别如此法。问曰。若不能分别者。云何彼异学施设百二十根。答曰。二眼二耳二鼻舌根身根意根命根五痛根五信此地狱。二十畜生。二十饿鬼。二十天上。二十人间。二十阿须罗。欲令六趣彼亦二十。是彼异学施设百二十根。复有说者。彼异学非施设此百二十根。问曰。若不尔者复云何。答曰。彼异学施设百二十因陀罗。如所说。龙主迦留罗主阿须罗主天主人主梵天主。如此极上极妙身。一一应受百二十主。彼梵志闻已重更生疑。不知何者第一义施设一根耶。至百二十根耶。彼闻释种家生童男。三十二相庄严身。八十种好金色圆光。梵音声如伽毗凌伽鸟。视之无厌。彼生时行七步。二龙洗浴。梵志相记于二处非余。若在家者为转轮王如法法王。若除须发被着袈裟信乐舍家学道。当成如来无所著等正觉。世间悉闻。彼已出家学道降魔眷属已。成无上最正觉。得一切智及一切现断一切疑。授一切定决一切论。我当往问。何者第一义。施设一根至百二十根耶。彼便至世尊所。到已共世尊面相慰劳。慰劳已却坐一面。白世尊曰。唯瞿昙。我欲有所问。听我所问当为我说。世尊告曰。梵志。随所欲问。梵志曰。瞿昙。根谓根。瞿昙。根有几所。云何瞿昙。根根所摄施设而施设。此不说谁施设几根。问曰。何以故不说。答曰。彼作是念。若我说者彼闻已取彼胜者答我。世尊告曰。汝梵志有二十二根。从眼根至无知根。此梵志有尔所根。如是如来根根所摄施设而施设。梵志若如是说非此根。如沙门瞿昙所施设。我舍此根更施设余根者。彼但有言数问已。不知增益生痴。何以故。如非境界。问曰。何以故说。此梵志有尔所根。如是如来根根所摄施设而施设。答曰。止彼本所闻。谓彼施设一根至百二十根。此非如彼所说。我是一切智一切见。犹不能增减二十二根。况复异学以见坏意成就凡智。以是故彼梵志问根。不问界入阴谛沙门果道品及缘起二十二根者。眼根至无知根问曰名有二十二根种有几阿毗昙者说曰。师说也。名有二十二根。种有十七。阿毗昙者五根。不欲令是种男根女根未知根已知根无知根。问曰。男根女根何以不欲令是种。答曰。彼说如阿毗昙中所说。云何女根身根少分。云何男根身根少分。彼离身根不欲令男女根别有种。问曰。未知根已知根无知根。何以故。不欲令是种。答曰彼说此九根合聚未知根。九根合聚已知根。九根合聚无知根。合聚九根者。意根三痛根信五。此九根或时未知根。知时已知根。或时无知根。见道中未知根。思惟道中已知根。无学道中无知根。坚信坚法意中未知根。信解脱见到身证意中已知根。慧解脱俱解脱意中无知根。如此九根或未知根。或已知根或无知根。以是故。彼名有二十二根。种有十七。尊者昙摩多罗说。名有二十二根。种有十四。彼尊者昙摩多罗。此五根不欲令是种。更有三命根护根定根。问曰。彼何以故。命根不欲令是种。答曰。此命根不相应行阴所摄。彼尊者昙摩多罗不相应行阴非是种。问曰。彼何以故。护根不欲令是种。答曰。彼尊者昙摩多罗说。有尔所痛。谓若乐若苦彼不苦不乐痛。亦不能苦亦不能乐。此云何痛。问曰。彼佛契经云何通。佛说三痛乐痛苦痛不苦不乐痛。答曰。彼说有乐痛苦痛。或软或增上或钝或利谓彼乐痛苦痛软乐痛苦痛钝乐痛苦痛止。是彼不苦不乐痛。但彼离苦乐不欲更有痛。以故尔。问曰。彼何以故。定根不欲令是种。答曰。彼从契经起。佛契经说。定根云何。答曰。善意一心。彼昙摩多罗离心更无别定种。以是故。彼名二十二根。种有十四。尊者佛陀提婆说。名有二十二根。种或二或五。谓彼尽是有为法二分四大及心。彼说色根者是四大差降。无色根者是心差降。以是故。彼名有二十二根。种或二或五。如是说者名有二十二根。种有十七。如名如种如是名数种数名相种相名异种异名别种别名觉种觉。如是尽当知。尊者瞿沙说曰。应说一根。是第一义意根也。问曰。何以故。答曰。谓此是内是普是共缘。内者内入所摄。普者从阿鼻地狱至第一有可得。共缘者一切法缘。谓余根离此聚中。眼根耳鼻舌身根男女根。虽是内。非是普非是共缘。五根中除护根。余四痛虽共缘。非是内。非是普。护根及信五虽普及共缘。非是内。未知根已知根无知根无别种。彼前已说。谓根合聚。问曰。余根何因得根名。答曰。依故猗故染着故净故已净故。依者眼根耳鼻舌身根也。猗者命根也。染著者五痛也。净者信五也。已净者未知根已知根无知根也。问曰。若尔者男根女根何因得根名。答曰。此欲界中淫稷淫种。此淫稷淫种因男根女根也。或曰。因五事故。一者生生。二者生欲乐。三者能止结。四者依起染污身识。五者定行淫人。生生者胎生也。生欲乐者。彼淫人于此处起欲乐已遍身中生乐。如圣人从眉间起圣乐已遍身中生乐。如是彼淫者此处起欲乐已遍身中生乐。能止结者。须臾止也。依染污身识者。依余三种生识善不善无记。依男根女根已必生不善身识非是善。非是无记。定行淫人者。习淫心非不习淫心。是五事故。一生生。二生欲乐。三能止结。四依起染污身识。五定行淫人。以是故。男根女根得名。更有说者。此中命根六。当说第一义根。命根六者。眼根耳鼻舌身命根。问曰。何以故。答曰。谓此根本众生种。问曰。若此根本众生种。彼余根何因得名。答曰。因种因染着因净因已净。因种者意根也。因染著者五痛也。因净者信五也。因已净者三无漏根也。以是故余根得名。问曰。男根女根何因得根名。答曰。谓此中转生人。亦生出要人。转生人者。如六师也。生出要人者。佛辟支佛声闻也。以是故男根女根得名。或曰。命根八当说第一义根。命根八者。眼根耳鼻舌身男女命根也。问曰。何以故。答曰。谓此根本众生种。问曰。若此根本种者。彼余根何因得名。答曰。因种因染着因净因已净得根名。因种者意根也。因染著者五痛也。因净者信五也。因已净者三无漏根也。以是故余根得名。此是根根性己种相身所有自然。说性已当说行。何以故名根。根有何义。答曰。增上义是根义。明义是根义。收义是根义。宗义是根义。最义是根义。胜义是根义。妙义是根义。生义是根义。问曰。若增上是根义者。一切有为法各各相增。无为法亦有为法增。何以故。立二十二根。答曰。此增上缘或增上或软或妙或下。谓彼增上缘增上及妙。当知二十二根。谓增上缘软及下。当知余法。或曰。虽一切有为法各各相增及无为法有为法增。但余无有增上缘如是增如是明如是收如是宗如是最如是胜如是妙。如二十二根。如人各各相增。但余无有增上缘。如村中主国中王四天下转轮王。大千国梵王。三千大千世界佛世尊。如是虽一切有为法各各相增及无为法有为法增。但余无有增上如是增如是明如是收如是宗如是最如是胜如是妙。如二十二根。是故说增上义明义收义宗义最义胜义妙义生义是根义。问曰。若增上义是根义。此根义何所为增上缘。答曰。眼根四事为增上缘。一者己身端严。二者持己身。三者依生识。四者不共事。己身端严者。极令身妙具足一切支节。若眼根不具。彼非端正多所增恶。若眼具已。颜貌端正众不增恶。是谓己身端严也。持己身者。眼见好恶除恶从好。令身久住。是谓持己身也。依生识者。依此眼生眼识。是谓依生识也。不共事者。眼根见色此事余根无也。耳根亦四事为增上缘。一者己身端严二者持己身。三者依生识。四者不共事。己身端严者。极令身妙具足一切支节。若耳根不具。彼非端正多所增恶。若耳根具足颜貌端正众不增恶。是谓己身端严也。持己身者。耳闻好恶除恶从好。令身久住。是谓持己身也。依生识者。依此耳生耳识。是谓依生识也。不共事者。耳根闻声此事余根无也。更有说者。眼根持生死身为增上缘。如所说偈

  眼见诸恶　　如实当求　　慧以存世
  除去诸恶

耳根持法身为增上缘。如所说偈

  闻法能知　　闻恶不作　　闻除非义
  闻得至灭

更有说者。眼根耳根俱持生死身及法身为增上缘。持生死身如前所说。持法身者。眼根近善知识诵习耳根闻法。近善知识及闻法已。思惟念向法次法。以是故彼契经说。彼时梵摩梵志二根不坏。眼根及耳根。问曰。何以故。一切根中说二根不坏。眼根及耳根。答曰。谓二根入佛法中是门是度是道。以是故。一切根中说二根不坏。眼及耳根。鼻根舌根身根亦四事为增上缘。一者己身端严。二者持己身。三者依生识。四者不共事。己身端严者。极令身妙具足一切支节。若三根不具者非端正多所增恶。三根具者颜貌端正众不增恶。是谓己身端严也。持己身者。依此三根通揣食。谓揣食即三入香味细滑是。是谓持己身也。依生识者。依此三根生三识。是谓依生识也。不共事者。谓鼻嗅香舌知味身知细滑。此事余根无也。意根二事为增上缘。一者次生当来有。二者自在。次生当来有者。如所说。阿难。若识不入母胎。宁名色膜渐厚不。阿难曰。不也世尊。是谓次生当来有也。自在者。如所说。比丘。心牵世间心烦恼心生自在。更有说者。意根复有二事增上缘。一者染着。二者清净。染著者。如所说。心染着众生染着。清净者。如所说。心清净众生清净。是谓意根二事为增上缘。女根男根亦二事为增上缘。一者施设根。二者断根。施设根者。本有一士夫。亦不知男亦不知女。若少生造色。因少造色故。女形异处所异持衣异所说异饮食异去来异男形亦异。更有说者。此男根女根复有二事为增上缘。一者染着。二者清净。染著者非淫故说增上主。此中无疑。问曰。若非淫者此云何。答曰。若有具此二根。彼受非威仪。能起五逆断善根。灭一切善种子。破坏一切善根。此不成男性不成男。无形二形不能作尔所恶。清净者。若具此二根。彼受具足戒威仪。能起定威仪无漏威仪。除欲界结色界结。得须陀洹果斯陀含果阿那含果阿罗汉果辟支佛果佛果。此不成男性不成男。无形二形不能发尔所功德。是谓男根女根二事为增上缘。命根二事为增上缘。一者施设根。二者断根。施设根者。至命存说有根死已有何根。更有说者。命根四事为增上缘。种类续种类持种类行种类不断。是谓命根四事为增上缘。五痛根一向染着。为增上缘。因五痛令众生趣东西南北。过栈道过刺道。过蒺[卄/梨]道。过山崄道。过罗刹渚入大海。洄澓涛波失搔摩罗山。同水色黑风暴起度恶龙处。所求财物尽为五痛故。更有说者。乐根喜根亦有二事为增上缘。一者染着。二者清净。染著者。如所说。乐痛爱使所使。清净者。如所说。乐己心定。苦根忧根亦二事为增上缘。一者染着。二者清净。染著者。如所说。苦痛恚使所使。清净者。如所说。因苦习。信护根亦二事为增上缘。一者染着。二者清净。染著者。如所说。不苦不乐痛痴使所使。清净者。如所说。谓依六出要护彼习彼依彼立已。谓此依六欲护便弃舍。如是彼得断。如是五痛根二事为增上缘。信五根一向清净为增上缘。如所说偈

  信能度流　　不放逸海　　谛舍除苦
  以慧清净

如所说。舍利弗信邪成就。若比丘比丘尼除去不善修行于善。复如所说。阿难精进能转成道。如所说。舍利弗圣弟子成就精进力。除去不善修行于善。如所说。我说一切中念如所说。舍利弗圣弟子成就于念如守门人。除去不善修行于善。如所说偈

  定者是道　　非定非道　　定已自知
  五阴兴衰

如所说。舍利弗圣弟子成就三三昧。须除去不善修行于善。如所说偈

  慧为世间妙　　能起有所至
  能用等正智　　生老病死尽

如所说。慧过一切法上。如所说。诸妹圣弟子以慧刀断一切结缚使恼缠重断。打重打割剥未知根。未见处当见处为增上缘。已知根已见处。当除诸恶为增上缘。无知根已除诸恶现法受乐为增上缘。是谓事于中此二十二根为增上缘。共行说已当说别行。云何眼根。答曰。谓眼色已见当见今见。及此余所有已见者过去。当见者未来。今见者现在。及此余所有者。谓彼眼识或空或非空。如眼根如是耳鼻舌身根亦尔。问曰。意根云何。答曰。谓意法已识当识今识。及此余所有。已识者过去。当识者未来。今识者现在。及此余所有者。谓彼意识相应。问曰。女根云何。答曰。身根少分。男根云何。身根少分。问曰。如身极微从足至顶满。何以故。于身根少处说女根男根。尊者婆须蜜说曰。此二根令众生得名是男是女。问曰。二形二形得名。欲令彼二形得名耶。尊者昙摩多罗说曰。诸尊此二根中生佛辟支佛声闻仙人文尼善乐善御。问曰。云何命根。答曰。三界寿也。问曰。何以故。不相应行阴中命根立。根种类不立。答曰。命根报果。一切报因行故。此种类不定。或报果或依果。以是故。命根立根中。种类不立。问曰。云何乐根。答曰。乐痛触更乐。谓身心中生善乐能觉是痛。是谓乐根。问曰。苦根云何。答曰。苦更乐触。若生身不善苦觉是痛。是谓苦根。问曰。喜根云何。答曰。喜更乐触。若心中生善乐觉是痛。是谓喜根。问曰。忧根云何。答曰。忧更乐触。若心中生不善苦觉是痛。是谓忧根。问曰。护根云何。答曰。不苦不乐更乐触。若心中生非善非不善觉是痛。是谓护根。问曰。信根云何。答曰。行无欲时为善法故。若信能信重信兢重。已解当解今解。屈伏意心净。是谓信根。问曰。精进根云何。答曰。行无欲时为善法故。若精进方便力精勤已能当能今能心正持。是谓精进根。问曰。念根云何。答曰。行无欲时为善法故。若念次念数念。已忆当忆今忆。不忘心正忆。是谓念根。问曰。定根云何。答曰。行无欲时为善法故。若心住等住上住无乱不散摄正定。是谓定根。问曰。慧根云何。答曰。行无欲时为善法故。若择选择法择视等视上视了等了上了山地眼觉黠慧行观。是谓慧根。问曰。云何未知根。答曰。若人未见未观。谓学慧慧根。及诸根坚信坚法未观四谛能观。若人未见者。谓彼不见。谛未观者。谓彼未观谛。学慧慧根者即是慧根也。及诸根坚信坚法未观四谛能观者。谓八根也。此九根合聚。谓未知根也。问曰。何以故。慧说二名余道品一。答曰。妙说妙义故。一切彼品中何者最妙慧是。如所说。王及眷属行。或曰。谓慧能三观。一者事观。二者见观。三者缘观。谓彼相应法虽有二观。事观缘观但非见观。性慧非慧故。谓彼共有法虽有一观。是事观但非见观。性非慧故。亦非缘观。非缘法故。此慧能三观以故尔。或曰。谓慧见结不得久住。如地隐虫见物还入。如是慧见结不得久住。或曰。谓慧照意结贼不娆。如室有灯贼不敢娆。如是慧照意结贼不娆。或曰。谓无智则缚。智则解脱。或曰。于佛法中谓智快乐。能觉则妙。如盲入珍宝渚。如是无智入佛法中。如有目入珍宝渚。如是有智入佛法中。是说于佛法中有智快乐能觉则妙。或曰。谓慧能观余道品盲。如彼盲聚一有目者而为将导。如是余道品盲慧者。能观而为将导入宝真谛。或曰。谓彼如人说眼首觉觉种道道种。或曰。谓慧能照一切法。此外事。如日月星宿摩尼药璎珞宫殿。能照一界一入一阴一世少所入一界者色界。一入者色入。一阴者色阴。一世者现在。此慧能照十八界十二入五阴三世。或曰。谓慧能断诸法自相及共相。立法自相及共相。坏种痴及坏缘痴。于法中不颠倒行。或曰。谓彼说如讲堂。如所说诸贤。我依戒立戒。升戒已登无上慧讲堂。少方便而观千世界。或曰。谓断结时说如利刀。如所说。诸妹圣妹圣弟子。以慧刀断结缚使烦恼缠重断。打重打割剥。或曰。谓彼说如珍宝。如所说。舍利弗圣弟子成就慧珍宝。除不善修行于善。或曰。佛世尊爱乐慧。佛世尊非爱色非族姓非力非钱财。非豪贵非眷属。但爱乐慧。以是慧二名。余道品一。问曰。已知根云何。答曰。谓人已见已观学慧慧根。及诸根信解脱见到身证已观谛能上观。谓人已见者。谓彼已见谛。已观者。谓彼已观谛。学慧慧根者。即是慧根。及诸根信解脱见到身证已观谛能上观者。谓八根此九根合聚谓已知根。问曰。如无学亦能上观。如彼退法至无退法。无退法至念法。念法至护法。护法至上法。上法至无疑。何以故。说学上观不说无学。答曰。应说。若不说者。是世尊有余言。此现义门现义略现义度当知义。或曰。谓更断结更受果。彼说上观。彼无学更不断结亦更不受果。以是故。不说上观。或曰。谓更断系得(得者法得之得)。更受解脱得。彼说上观。彼无学不更断系得。亦不更受解脱得。以是故。不说上观。或曰。谓更断无智更得智。彼说上观彼无学虽更得智。不更断无智染污无智故以是说学上观不说无学。问曰。无知根云何。答曰。谓人已见已观。无学慧慧根。及诸根慧解脱俱解脱已观谛现法受乐。谓人已见者。谓彼已见谛。已观者。谓已观谛。无学慧慧根者。即是慧根。及诸根慧解脱俱解脱已观谛现法受乐者。谓八根。此九根合聚谓无知根。问曰。如学现法亦受乐。何以故。说无学现法受乐不说学。答曰。应说。若不说者。是世尊有余言。此现义门现义略现义度当知义。或曰。妙说妙义故。若说妙法者。学法胜非无学。若说人妙无学人胜非学人。或曰。谓此猗乐快受彼学意结所热。是故猗乐不快受。此无学意结热灭。是故猗乐快受。或曰。谓此猗乐极广大受。彼学或结怨家尽或不尽。是故猗乐不极广大受。如王或降怨家或未降。是故王境界不极广大受。如是彼学或结怨家尽或不尽。是故猗乐不极广大受。此无学一切结怨家尽。彼猗乐极广大受。如王降一切怨家。彼王境界极广大受。如是此无学一切结怨家尽。是故猗乐极广大受。或曰。谓现法乐非后乐。彼学现法乐后亦乐。此无学是现法乐非后乐。以是故。无学说现法受乐不说学。问曰。此说及诸根慧解脱俱解脱已观谛现法受乐。彼三明阿罗汉有耶无耶。若有者此中何以不说。若无者彼契经云何通。彼契经尊者舍利弗至世尊所问。唯世尊。五百比丘中几比丘三明。几比丘俱解脱。几比丘慧解脱。世尊告曰。舍利弗。此五百比丘九十比丘三明。九十比丘俱解脱。余比丘慧解脱。舍利弗。此众无枝叶亦无节清净坚住。问曰。尊者舍利弗知耶不知耶。若知者何以问。若不知者云何称声闻波罗蜜。作此论已。说曰。知也问曰。若知者何以故问。答曰。或有知而问。如所说。佛世尊知而问。或曰。为他故而问。虽尊者舍利弗知。彼众中有不知者。彼不知者彼不成就无畏法。不能问世尊。尊者舍利弗知亦成就无畏法。彼为他故问世尊。或曰。入等性现差降故问。佛为彼五百比丘说法。尽得阿罗汉果不受当来有。彼世尊心欢悦故说等同。谁能第一义。世尊心欢悦。谓断当来有。尊者舍利弗作是念。虽一切得阿罗汉果断当来有。第一义世尊心欢悦。但未知谁勤精进。谁不勤精进。以是故。入等性现差降故问。或曰。佛因彼道果说等同。尊者舍利弗道差降故问。或曰。佛因彼无为解脱等同。尊者舍利弗于有为解脱差降故问。或曰施主思愿关故问。若施主夏四月受供养。彼思愿开意如是此极妙福田。莫作是念。施种恶田。或曰。少欲灰覆功德藏显示世间故。如人灰覆藏发显示故。如是少欲灰覆功德藏显示世间故问。或曰。现弟子功德故问。此应尔如弟子问师答。是现弟子功德故问。或曰。不实贡高智焦增智慢。断贡高慢故问。谓彼成就增智慢。不喜问世尊说舍利弗比丘问。阎浮利十六分慧不能及。何况汝等凡智见成就。是谓不实贡高智焦增智慢。断贡高慢故问。或曰。断谤故问。异学诽谤世尊说者。沙门瞿昙从舍利弗目揵连受法而说。夜受昼说。如尊者。舍利弗叉手而问世尊答。是谓断诽谤故。或曰。断于法嫉妒故问。若嫉妒者他说功德而不喜闻。何况自说。尊者舍利弗无此咎。是故断于法嫉妒故问或曰。现无贡高及求善法故问。或曰。现世尊善说印可故问。如王縢书法令。若无王印可一切关守便有留难。如是若善说无如来印可。于过去佛法中四部众便有留难。如王縢书法令。若王印可一切关守无有留难。如是若善说如来印可。于过去佛法中四部众无有留难。是谓现世尊善说印可故。尊者舍利弗问。作此论已说曰有三明阿罗汉。问曰。若尔者于彼经通。此经中何以不说。答曰。应说。若不说者。世尊有余言。或曰。彼已说在此中。若有此三明阿罗汉。或性慧解脱或俱解脱。已说慧解脱。当知已说性慧解脱三明阿罗汉也。已说俱解脱。当知已说性俱解脱三明阿罗汉。说者更有二师。尊者视违罗。尊者瞿沙披摩。尊者视违罗者称说慧妙。尊者瞿沙披摩者称说灭尽定妙。尊者视违罗说慧胜。非灭尽定。慧者等缘。灭尽定者无等缘。尊者瞿沙披摩说。灭尽定胜非慧。慧者凡人亦有。灭尽定者非凡人。若称说。慧者非灭尽定。彼说若有三明无八解脱者。是说三明阿罗汉。谓三明有八解脱。彼亦说三明。何以故。谓彼慧胜非灭尽定。一明二明者慧解脱。若称说。灭尽定者非慧。彼说若有八解脱无三明。是说俱解脱。若有八解脱及三明。此亦说俱解脱。何以故。谓彼灭尽定胜非慧。一明二明者慧解脱。说者彼此但虚论。不益经不益义。如是好。如前所说。此三明阿罗汉。或得灭尽定。或不得。若得灭尽定彼说俱解脱。不得者说慧解脱复次未知根已知根无知根。更别说行未知根云何。答曰。未知当知未观当观未断当断。是故说未知根。问曰。若未知当知未观当观未断当断是说未知根者。彼苦法忍生已。观欲界五阴。于上生苦法智。欲界五阴已观重观。如此已观当观。何以故说未知根不说已知根。答曰。苦法忍生欲界始观五阴。未已观于彼上苦法智生已观欲界五阴。或曰。苦法忍生欲界五阴。虽观欲界五阴。但未知彼上苦法智生。知欲界五阴因智。故名为观非是忍。或曰。于彼上当生道未曾所观意阴覆堕下。以是故说未。知根非已知根。问曰已知根云何。答曰已知当知已观当观未断当断。是故说已知根。问曰。若已知当知已观当观未断当断。是说已知根者。道未知忍生。除共有相应法。余一切法智及观。于彼上生道未知智彼共有相应法智及观。如此中未知当知未观当观。何以说已知根。不说未知根。答曰。外者十六心见道。彼初道未知智时。于见谛道中彼共有相应品智及观。是故彼已知而知非未知。已观而观非未观问曰。此中依外不问不答若十五意见道此说云何。尊者僧伽婆修说曰。当道未知忍现在前时。修当来无量道未知忍。若彼当来修无量道未知忍者。是彼观共有相应法。说曰。此不论。问曰。何以故此不论。答曰。非是当来道能观。问曰。若不尔者。此云何。答曰。多故多已观当观少未观当观。如地无量无边。知是已观当观。如地一丸。如是未观当观。如空无量无边如是已观当观。如空一蚊蚋处。如是未观当观。如海无量无边。如是已观当观。如海一渧。如是未观当观。如须弥山王无量无边。如是已观当观。如须弥山芥子数。如是未观当观。是谓多故。或曰。于彼上当生道。已曾所观。已曾所观意阴覆堕下。以是故说已知根非未知根。问曰。无知根云何。答曰。已知当知已观当观无有未断可断。是谓无知根。问曰。若已知当知已观当观无有未断可断者。佛辟支佛声闻。亦已知当知已观当观无有未断可断。何以故三等一说佛不说余。答曰。谓始觉觉一切法不破正智。或曰谓始得尽智。除二种障结障及解脱障。或曰。谓意中除二种无知闇痴染着。及不染着等及第一义。或曰。谓意中除二种。疑惑犹豫处处及结处。或曰。谓多闻无厌。或曰。谓得尽甚深缘起底。非如一切声闻辟支佛。作譬喻三兽渡河兔马香象。兔者浮而渡河。马者少多触沙而渡。香象者尽底蹈沙而渡。如是三乘渡缘起河。佛辟支佛声闻。如兔浮渡河。如是当观声闻缘起智。如马少多触沙而渡。如是当观辟支佛缘起智。如香象尽底蹈沙而渡。如是当观佛世尊缘起智。是故说谓得尽甚深缘起底。非如一切声闻辟支佛。或曰。谓四圣谛的智箭极深入。如非一切声闻辟支佛。作譬喻如一的三人共射。一者摩诃能伽。二者钵骞提。三者那罗延。摩诃能伽者虽着的不能入。何况能过钵骞提者虽着的能入不能令过。那罗延者射破的彻过入地。彼的亦不现。坚软随彼力软中上。射破的亦有软中上。如是三乘射四圣谛的。佛辟支佛声闻。如摩诃能伽虽着的不能入。况当能过。如是当观声闻四圣谛智。如钵骞提虽着的能入不能令过。如是当观辟支佛四圣谛智。如那罗延射破的彻过入地。如是当观佛四圣谛智。此四圣谛的亦不现。坚软随彼智力有软中上。四圣谛的便有软中上。是故说谓。四圣谛的智箭极深入如非一切声闻辟支佛。或曰。谓知自觉尽及具。辟支佛者虽自觉及具非是尽。声闻者不能自觉。何况具尽。是说谓知自觉具及尽。或曰。谓缘自觉及尽行。辟支佛者虽有自觉不能尽行。声闻不能自觉。何况尽行。或曰。谓说无二种辩才不尽所说无异。或曰。成就身及身所依明行成。转轮圣王虽身成就无身所依。声闻辟支佛虽成就身。所依非是身。佛亦成就身。及身所依明行成。或曰。谓三成就色挨妙语。复三成就誓果教授。或曰。三不护及三不共意止。或曰。谓四不护及四不谏。或曰。谓成就四智因智时智想智他说智。复有四智。无滞智无住智无错智无碍智。或曰。谓觉种种因觉种种果觉种种治觉种种意。或曰。一无二独福力降魔。如非一切声闻辟支佛。说者谓菩萨食难陀难陀波罗乳糜已。作如是意。坐道树下要不破结加坐至尽有漏。彼时魔波旬宫殿六反震动。彼作是念。不知是谁力。彼见菩萨坐道树下。作如是意。要不破结加趺坐至尽有漏。彼时魔波旬雨华而至菩萨所。到已善言语菩萨悉达阿[少/兔]。是浊世时众生意刚强。如此时难可得成无上正真道。且起我当给汝七宝及以千子。领四天下为转轮圣王。菩萨说曰。波旬。汝唐疲劳。速令此地及泉源池水庄严村城舍宅人民飞在空中。空及日月星辰速令堕地。要不与汝起至尽有漏。魔波旬说曰。我以爱善之言用告汝。汝不起者当见极恶。作是语已。还至天上告六欲天。诸贤。当持鉾戟刀钩金椎钺斧罥索长钩。我有怨家今在道树下坐。彼时菩萨魔波旬还去不久。便作是念。常凡人共诤由当防护不应默住。何况欲界豪贵菩萨。去欲结迹先已备习彼速除欲。已发于神足种种变化。谓作鼠形者化作猫。谓作猫形化作狗。谓狗形化作豹形。谓豹形化作虎。谓虎形化作师子。谓戴火化作雨。谓雨化作盖。菩萨自化作琉璃台。在中结加趺坐。谓障形不障眼。变化已菩萨作是念。我种种变化若我他行法时有所娆乱者。魔波旬必能娆乱我。若我他行法时不作娆乱者。魔波旬终不能娆乱我。菩萨因此事念宿命。神通作证发已。观百众生千众生行法时极供给所。当菩萨作是念。如我种种变化。如本行善因。令如此魔百千亿来者。彼终不能娆乱我。何况一魔。菩萨作是念住。于是魔波旬及十八亿魔作丑陋面牙齿。恐怖声极恶音声。执持种种鉾戟。满三十六由延往诣道树所。到已语菩萨曰。悉达阿[少/兔]。汝见此恶众不。速起莫于此中受无量苦。菩萨说曰。波旬汝语如小儿。汝昔一斋之施。谓因果力今得如是自在。魔说曰。我一斋之施汝施几斋。菩萨说曰。我施无量百千斋。魔说曰。我斋之施得汝为证。谁为汝证。彼时菩萨满百千福相好庄严紫磨金色。以合曼掌按地。地即大动。此以为证。彼时此地如七宝器声。彼魔众闻已。恐怖散坏顾面奔走放恶音声复道而还。菩萨所生眼。魔众过一由延不复见。菩萨因此天眼神通作证发已。但见而耳不闻。菩萨因此天耳神通作证发已。能闻不知以何意来。菩萨因此知他心神通作证发已。观释释众妙意来。魔魔众恶意来。菩萨作是念。魔波旬何因来此观守境界故来。以何故守境界。便作是念。以结故。菩萨因此断一切结已。三十四心顷成无上正真等正觉道。三十四心顷者。见道十五心道未知智第十六。谓道已知智。此菩萨有想无想处除欲时。是方便道。有想无想处断九品结。九无碍道九解脱道。是谓三十四心顷。谓一切三耶三佛。依此以降魔及官属成最正觉。是说谓一无二独。以福力降魔及官属已。成无上正真道已。如非一切声闻辟支佛。或曰。谓已知智满及觉道行及行缘及缘根及根义。或曰。谓有十力四无所畏十八不共法。或曰。谓离世八法。不可得功德边。救诸危厄而为作归。或曰。谓大悲久远来微入普入一切众生等转行。久远来者。三阿僧祇具修行远来也。微入者。觉三苦微入也(一者苦苦二者行苦三者变易苦也)。普来者三界缘普入也。一切众生等转行者怨亲中间等意故。一切众生等转行也。是故说谓。大悲久远来微入普入一切众生等转行。以是故等三说一佛。非声闻辟支佛。问曰。何以故色阴中。眼根耳鼻舌身根立根。色声香味细滑不立根。答曰。谓内彼立根。外者不立根。谓现在时众生数彼立根。不定者不立根。谓受彼立根。不受者不立根。谓断时痛痒重担彼立根。不定者不立根。谓根彼立根。谓根义不立根。以故尔。问曰。何以故痛阴中。乐痛立二根。乐根及喜根。苦痛亦立二根。苦根及忧根。何以故不苦不乐立一根护根。答曰。应说若不说者。世尊有余言。现义现义门现义略现义度当知义。或曰。现二门二略二度二炬二明二光现二处。如乐痛苦痛立二根。不苦不乐亦应立二根。此有差降。谓于彼可得起二根。如不苦不乐立一根。如是乐痛苦痛亦应一根。有此等行。谓彼起一根。是说现二门二略二度二炬二明二光现二数。或曰。离相违故。乐痛苦痛相违。苦痛亦乐痛相违。彼不苦不乐痛更无余痛相违。是离相违故。以故尔。或曰。转行余故。此乐痛异乐根。转行异喜根。痛苦亦异苦根。转行异忧根。彼不苦不乐痛一切转行。余以故尔。或曰。乐痛或利或不利。或狂或不狂。或住或不住。或定或不定。谓彼不利狂狂不住定彼立一根。是乐根利狂不住不定彼立喜根。苦痛亦尔。彼不苦不乐痛一切不利不狂住定。以是故乐痛立二根。乐根及喜根。苦痛亦立二根。苦根及忧根。不苦不乐立一根。护根。问曰。想何以故不立根。答曰。多有法不立根中。何以独问想。问曰。色阴或立根或不立根。如是行阴或立根或不立根。痛阴及识阴尽立根。此想何以故尽不立根耶。答曰。谓无根相。无根相故不立根。或曰。根自力转行此想因他力转行。如弟子及庸作人随彼教敕。教取即取。教舍即舍。如是想。若痛所觉彼想即想。若思所思彼想即想。若识所识彼想即想。尊者婆须蜜说曰。何以故想不立根者。增上义是根义。想非增上。问曰。如一切有为法各各相增。无为法有为法增。何以故想非增上。答曰。谓诸法能增结彼立根。非想能坏结。问曰。想亦能坏结。世尊所说无常想。修习多修习。坏一切欲爱及色爱无色爱。坏一切无明及慢。何以故说想不能坏结。尊者昙摩多罗说曰。诸尊想者因他受想。彼从他起。如受所依。如彼余心数法作缘已然后受想。是故说诸尊想者因他受想。彼从他起如所受依。以是故想不立根。问曰。结何以故不立根。答曰。增上义是根义。结非增上。痛于结增上故。问曰。结增上于解脱中退没。在生死远离于善。何以故说结非增上。答曰。不如是增上。如于解脱中退没在生死远离于善。此是说下贱弊恶非增上。问曰。此痛因结增上。何以故痛立根结不立。答曰。虽痛因结起。因结得增上。但结是下贱。如城中豪贵主立守门人。彼守门者虽极增恶但非此增上缘。如是增上主。如是痛虽因结起。因结得增上。但结下贱。以是故痛立根结不立。问曰。何以故。痛善染污不隐没无记一切立根。慧者谓善彼立根。染污不隐没无记不立根。答曰。痛者结所宗。是故善染污不隐没无记尽立根。慧者善法所宗。谓善彼属善法。谓染污彼断善法。谓不隐没无记不可用。以是故痛善染污隐没无记尽立根。慧者谓善彼立根。染污不隐没无记不立根。问曰。若妙义是根义者。涅槃于一切法最妙。何以故不立根。答曰。彼涅槃坏根非根。非根如车坏非车。瓶坏非瓶。财物坏非财物。如是涅槃根坏非根。或曰。根者堕生老无常。涅槃者不堕生老无常。或曰。根者有因得有为相。涅槃者无因得无为相。或曰。根者转世作行受果能知缘。涅槃者非转世不作行不受果不知缘。或曰。根者前后可得。涅槃者无前后。或曰。根者软中上可得。涅槃者离软中上。或曰。根者堕世。涅槃者离世。或曰。根者是阴。涅槃者离阴。或曰。根者缚苦。涅槃者离苦。或曰。有为法者因行故。说妙义根义。但涅槃一切有为法中妙广说。二十二根处尽

鞞婆沙论卷第四鞞婆沙论卷第五

        阿罗汉尸陀槃尼撰

        符秦罽宾三藏僧伽跋澄译

    十八界处第十七

十八界者。眼界色界眼识界。耳界声界耳识界。鼻界香界鼻识界。舌界味界舌识界。身界细滑界身识界。意界法界意识界。说曰。此界亦是略说。亦是广说。略说者因大经故。如大本起大般泥洹。广说者因入故。入者亦是略说亦是广说。略说者界故。广说者阴故。阴者亦是略说亦是广说。略说者入故。广说者如所说诸有为求。是苦因彼故。更有说者。界者亦是略说亦是广说。即此界故。此界中说色心广心数法略。入亦是略说亦是广说。即此入故。入中说色广心心数法略。阴亦是略说亦是广说。即此阴故。阴中说心数法广色心略。更有说者。界者一向说广。问曰。何以故界一向说广。答曰。摄一切法故。大本起大般泥洹虽说广。但彼非摄一切法。入中虽摄一切法。但不说广。阴中不摄一切法。阴者虽摄有为法。但不摄无为。亦不说广。此界一向说广及摄一切法。此是佛世尊略说广说。非尔所广说。如大本起大般泥洹。亦非尔所略说。如二施法施财施。问曰。若不尔者此云何。答曰。若法前说广后说略。谓十八界法此摄受。立十二入中。谓十二入法此摄受。立五阴中。除无为法。谓五阴法此摄受。说诸有为求是苦。诸有为求者。是谓世尊一向略说。此是佛略说广说。世尊因此告舍利弗。舍利弗。我能为诸弟子法略说广说。但知者难。因此略说广说故。尊者舍利弗白世尊曰。唯世尊。但当略说及广说法。能有知法者。因此略说广说故。作譬喻。如海中大龙海中长养身已。升在虚空云覆虚空。放电光震大音声。我当降雨。彼时百谷药木树神恐怖作是念。海龙大身。若雨者当有所坏。彼时此地亦不畏惧堪受龙雨。百岁千岁我能尽受如海大龙。如是世尊从幢英佛定光惟卫式弃随叶拘留秦拘耶含牟尼迦叶三耶三佛。长养法身。以大悲乘虚空。以大慈云覆阴世间。放智电光震大法音。舍利弗。我能为诸弟子法略说广说。但知者难。如百谷药木树神恐怖。如是一切声闻恐怖作是念。世尊能异名异句异味异法异义。若说法者。恐不能知。如地不畏惧堪受龙雨。如是尊者舍利弗六十劫中长养智见。堪受世尊略说广说。能有知法者。因此略说广说故。问曰。如有法如舍利弗百千那术数。非其境界所知。何以故舍利弗堪受世尊。答曰。堪受声闻境界非佛境界。堪受声闻智非佛智。堪受声闻行非佛行。或曰。堪受依佛。尊者舍利弗作是念。此世尊等说饶益不空说法。一向满具随器说法。以是故尊者舍利弗堪受世尊。十八界者。眼界乃至意界。问曰。名十八界种有几。答曰。名十八界种或十七或十二。若取六识者失意界。如是名十八种十七。若取意界失六识。如是名十八种十二。是名十八界种或十七或十二。如名如种。如是名数种数名相种相名异种异名别种别名觉种觉尽当知。问曰。若十八界种或十七或十二。云何名立十八界。答曰。以三事故身依缘。谓十八界六身六依六缘。六身者六内界。眼界耳鼻舌身意界。六依者六识界。眼识界耳鼻舌身意识界。六缘者六外界。色界声香味细滑法界。是谓三事故身依缘。是立十八界。如佛契经所说。六十二界彼尽入中。此三事故身依缘。问曰。何以故世尊说六十二界。答曰。断异学意故。此身见六十二见根。断身见故。佛契经说六十二界。如彼佛契经所说。拘翼。此世种种界无量界。彼谓知界。于彼彼界强力盗一向入说。此佛契经以见名说界。此尽入十八界中。以三事故身依缘。佛所说契经以大树作喻说。诸比丘如大树叶。界亦尔数。此佛契经以见名说界。此亦尽入十八界中。以此三事故身依缘。是谓名立十八界。此是界性。已种相身所有自然。说性已当说行。何以故说界。界有何义。答曰。性义是界义。段义分义微义异相义不相似义断义。种种事是界事。舍提说曰。趣趣者是界。持长养是界。性义是界义者。一身一意有十八性。如一山中多有性。铁性铜性白镴性铅锡性金性银性琉璃性水精性。如是一身一意有十八性。是性义是界义。段义是界义者。次第布肉便数有男有女。如竹篾次第织便数名盖是扇。如木片便数为车宫舍讲堂台观。如是次第布肉段便数为男女。是段义是界义。分义是界义者。女十八分男十八分。是分义是界义。微义是界义者。女十八微男十八微。是微义是界义。异相义是界义者。眼相异至意相异。是异相义是界义。不相似义是界义者。眼界不相似至意界不相似。是不相似义是界义。断义是界义者。眼界断三界。至意界断三界。是断义是界义。种种事是界事者。谓眼界事非至意界事。谓意界事非至眼界事。是种种事是界事。舍提说曰。趣趣者是界。持长养是界。趣趣是界者。趣诸界诸趣诸生趣轮转生死。持者己性。长养者他性。是谓性义是界义。段义分义微义异相义不相似义断义种种事是界义。舍提说曰。趣是界持长养是界。如是共行说已。当说别行。云何眼界。答曰。谓眼见色。已见当见今见。及此余所有。已见者是过去。当见者未来。今见者现在。此及余所有者。谓彼眼识或空或非空。更有说者。谓我眼见色是我所有。余一切众生余所有。谓我眼不见色是我余所有。余一切众生亦余所有。更有说者。谓我眼见色是我所有。余一切众生亦所有。谓我眼不见色是我余所有。余不见色亦余所有。问曰。如无此事。一眼二人见色。况多。何以故说。谓我眼见色是我所有。余一切众生亦所有。答曰。颇有此以他眼见色耶。但眼所用事因见色。彼见已便灭。谓用事已便灭。以是故说。谓我眼见色是我所有。余一切众生亦所有。更有说者。谓我眼见色是我所有。余一切众生亦非所有。亦非余所有。谓我眼不见色是我余所有。余一切众生非所有。亦非余所有。此者不论。此眼云何非所有非余所有。问曰。若不论者此云何。答曰。如是好。如前所说。谓我眼见色是我所有。余一切众生余所有。谓我眼不见色是我余所有。余一切众生亦余所有。问曰。如一眼能见色二眼不见色。云何见非见因非见见因。答曰。因见不见来。因不见见来。是各各相来故谓之因。见不见持不见见持。是各各相持故谓之因。见不见等持不见见等持。是各各等相持故谓之因。因见不见生因不见见生。各各相生故谓之因。见不见养不见见养。各各相养故谓之因。见不见长不见见长。各各相长故谓之因。或曰。谓眼见及不见。此二俱一界一入一根一见。一界者眼界。一入者眼入。一根者眼根。一见者眼见。如眼界耳鼻舌身界亦尔。问曰。色界云何。答曰。谓色眼已见当见今见。及此余所有。已见者过去色。当见者未来色。今见者现在色。及此余所有者。罽宾说余所有。色四种。有过去色。谓眼不见已灭。有当来色。谓眼不见当灭。有现在色。谓眼不见而灭。复有当来色不生法是。谓罽宾说。余所有色四种。外者说余所有。色五种。有过去色。谓眼不见已灭。有当来色。谓眼不见当灭。有现在色。谓眼不见而灭。复有当来色不生法。不生法色者有二种。或眼识空或非空。是谓外者余所有色说五种。说曰。复有所有色。或一众生境界。或二或至百千。谓一众生见至百千。此云何。如说法者升乎高座。百千众生见已起彼缘识。彼所有不起者余所有。如月初生。百千众生见已起彼缘识。彼所有不起余所有。如大聚会庄严一女伎人。百千众生见已起彼缘识。彼所有不起者余所有。说曰。复有余所有色。或一众生不见。或二乃至百千。如山根山谷山腹山内。此大地内大海内须弥山王内。虽彼天眼境界。但不用故不见。问曰。非佛眼境界耶。答曰。颇有佛天眼常现在前耶。如色界。声香味细滑界亦尔。问曰。云何眼识界。答曰。眼缘色生眼识。问曰。如除己性余一切法缘生眼识。何以故说眼缘生眼识。答曰。谓彼近与增上缘。彼眼色生眼识时。极近与增上缘。非如已生老无常。或曰。谓彼依及缘。依者眼。缘者色。或曰。谓彼内及外。内者眼。外者色。或曰。谓彼根及根义。根者眼。根义者色。是说眼缘色生眼识。问曰。如色缘生识。何以说眼识不说色识。答曰。应说如彼外尘经所说。色更乐缘生识。若不说者是世尊有余言。此现义门现义略现义度当知义。或曰。妙说妙义故。虽色缘生识。但彼眼生识时。妙义如伎染衣书。如所说某处作伎。非无女伎。非无弹伎。非无歌伎。非无教伎。非无守者。但彼伎主极妙事。是说某处作伎。如说人染衣。非是人染衣是色染衣。但彼人于染极妙事。是说人染衣。如说以笔书作字。非无墨非无纸非无人方便。但彼笔于字极妙。是说笔妙。如是虽色缘生识。但彼眼生识时妙事。是妙说妙义故。如彼染衣书。或曰。眼及眼识一依一意可得色不定。或曰。眼内色不定。或曰。眼在己意(意者神也)。色不定。尊者婆须蜜说曰。如色缘生识。何以故说眼识不说色识。答曰。依眼非色。重说曰。眼妙非色。重说曰。眼己意可得非色。重说曰。眼近事色不定。重说曰。眼受非色。重说曰。眼增减识亦增减非色。重说曰。眼增上缘非色。尊者昙摩多罗说曰。若无眼者必不生识。问曰。若无色者亦不生识。答曰。若无一色者更有二乃至百千色。若无眼者以那术色在前。不可依此生识。是故说数事

  依猗及妙　　己意近受　　增及上缘
  师想在后

眼知色者。问曰。如识知色非眼知色。何以故说眼知色。答曰。此说应当尔。眼到眼识所教谓之见应尔。问曰。若不尔者何意。答曰。具故。如商人行导。彼非商人。行是足行。但彼商人于行为具。是说商人行导。如是虽识知色。但彼眼见色具。是故说眼知色。或曰。除重说咎故。如后当说眼知色谓心意识。问曰。心意识有何差别。一说者无有差别。心意识一义无若干义。如此诵十种名。彼说火有十名。火炎燃炽尽薪恶黑烟居明炎雪怨。此是火十名彼同是一。如是诵火色者。说火色有十名

  火赤多疫死　　黄色起刀兵
  红炎有饥馑　　杂色宜五谷
  青色丰欢乐　　白色国兴盛
  黑色境减损　　此名火十色

如是余契经说。谓痛等痛别痛觉。是痛此虽多名是一。痛如是余契经说偈

  释统勋大　　千眼拘翼　　日夫天王
  因提在后

此虽十名故是一。如是说心意识同一义非若干。或曰。有差别。心者过去。意者当来。识者现在。或曰。界施设心。入施设意。阴施设识或曰。性义是心义。输门义是意义。聚义是识义。或曰。猗性憍逸说心。性义是界义。恃财憍逸说意。输门义是入义。恃命憍逸说识。阴者如怨家。或曰。思是心觉是意知是识。尊者婆婆罗茶说曰。能思能截是心。能觉能恻是意。能知能别是识。能思者是有漏。能截者是无漏。能觉者是有漏。能恻者是无漏。能知者是有漏。能别者是无漏。心意识是谓差别。如眼识。耳鼻舌身意识亦尔。问曰。意界云何。答曰。谓意法已知当知今知。及此余所有。已知者过去。当知者未来。今知者现在。及此余所有者。谓意或空或不空。问曰。云何法界。答曰。谓法意已知当知今知。已知是过去。当知是未来。今知是现在。问曰。六识何以不立余所有。答曰。行故立六识。彼过去意不作行。或曰。生故立六识。彼过去意无生法也。以是故六识不立余所有。问曰。法界何以故不立余所有。答曰。已说意当知已略说法界。谓彼不说此中说。谓彼说有余此说无余。是故法界不立余所有。或曰。非是因法界故立所有余所有。若因法界故立所有余所有者。是一切十二入亦当立所有余所有。但非法界故立所有余所有。以是故作此论。颇色界法中或所有或余所有耶。答曰。有十色入。是所有余所有。谓彼生老无常此所有。问曰。何以故。答曰。谓彼入法界中。法界者无余所有。以故尔。颇无色法中所有余所有耶。答曰。有七意界是所有余所有。谓彼生老无常此所有。问曰。何以故。答曰。谓彼入法界中。法界者无余所有。以故尔。颇有处系在眼。彼处亦系在色。亦系在能生眼识耶。答曰。或是处或余处。问曰。云何是处。答曰。生欲界见欲界色。彼欲界眼欲界色。能生欲界眼识。生初禅中。初禅地眼见初禅地色。彼初禅地眼初禅地色。能生初禅地眼识。此谓是处。问曰。云何余处。答曰。生欲界中。初禅地眼见欲界色。彼初禅地眼欲界色。能生初禅地眼识。复生欲界。二禅地眼见欲界色。彼二禅地眼欲界色。能生初禅地眼识。二禅地眼见初禅地色。彼二禅地眼初禅地色。能生初禅地眼识。二禅地眼见二禅地色。彼二禅地眼二禅地色。能生初禅地眼识。复生欲界。三禅地眼见欲界色。彼三禅地眼欲界色。能生初禅地眼识。三禅地眼见初禅地色。彼三禅地眼初禅地色。能生初禅地眼识。三禅地眼见二禅地色。彼三禅地眼二禅地色。能生初禅地眼识。三禅地眼见三禅地色。彼三禅地眼三禅地色。能生初禅地眼识。复生欲界。四禅地眼见欲界色。彼四禅地眼欲界色。能生初禅地眼识。四禅地眼见初禅地色。彼四禅地眼初禅地色。能生初禅地眼识四禅地眼见二禅地色。彼四禅地眼二禅地色。能生初禅地眼识。四禅地眼见三禅地色。彼四禅地眼三禅地色。能生初禅地眼识。四禅地眼见四禅地色。彼四禅地眼四禅地色。能生初禅地眼识。是谓生欲界。如生欲界。生初禅二禅三禅四禅亦尔。是谓余处。颇有余处系在眼余处系在色。余处系在能生眼识耶。答曰。有生欲界。二禅地眼见欲界色。彼二禅地眼欲界色。能生初禅地眼识。复生欲界。三禅地眼见欲界色。彼三禅地眼欲界色。能生初禅地眼识。三禅地眼见二禅地色。彼三禅地眼二禅地色。能生初禅地眼识。复生欲界。四禅地眼见欲界色。彼四禅地眼欲界色。能生初禅地眼识。四禅地眼见二禅地色。彼四禅地眼二禅地色。能生初禅地眼识。四禅地眼见三禅地色。彼四禅地眼三禅地色。能生初禅地眼识。是谓生欲界。如生欲界。生初禅二禅三禅四禅亦尔。是谓余处系在眼。余处系在色。余处系在能生眼识。颇有处系在身。彼处亦系在眼。亦系在色。亦系在能生眼识耶。答曰。或是处或余处。问曰。云何是处。答曰。生欲界。欲界眼见欲界色。彼欲界身欲界眼欲界色。能生欲界眼识。生初禅。初禅地眼见初禅地色。彼初禅地身初禅地眼初禅地色。能生初禅地眼识。是谓是处。问曰。余处系云何。答曰。生欲界。初禅地眼见欲界色。彼欲界身初禅地眼欲界色。能生初禅地眼识。初禅地眼见初禅地色。彼欲界身初禅地眼初禅地色。能生初禅地眼识。复生欲界。二禅地眼见欲界色。彼欲界身二禅地眼欲界色。能生初禅地眼识。二禅地眼见初禅地色。彼欲界身二禅地眼初禅地色。能生初禅地眼识。二禅地眼见二禅地色。彼欲界身二禅地眼二禅地色。能生初禅地眼识。复生欲界。三禅地眼见欲界色。彼欲界身三禅地眼欲界色。能生初禅地眼识。三禅地眼见初禅地色。彼欲界身三禅地眼初禅地色。能生初禅地眼识。三禅地眼见二禅地色。彼欲界身三禅地眼三禅地色。能生初禅地眼识。三禅地眼见三禅地色。彼欲界身三禅地眼三禅地色。能生初禅地眼识。复生欲界。四禅地眼见欲界色。彼欲界身四禅地眼欲界色。能生初禅地眼识。四禅地眼见初禅地色。彼欲界身四禅地眼初禅地色。能生初禅地眼识。四禅地眼见二禅地色。彼欲界身四禅地眼二禅地色。能生初禅地眼识。四禅地眼见三禅地色。彼欲界身四禅地眼三禅地色。能生初禅地眼识。四禅地眼见四禅地色。彼欲界身四禅地眼四禅地色。能生初禅地眼识。是谓生欲界。如生欲界。生初禅二禅三禅四禅亦尔。是谓余处。颇有余处系在身。亦余处系在眼。亦余处系在色。亦余处系在能生眼识耶。答曰。有生欲界。三禅地眼见二禅地色。彼欲界身三禅地眼二禅地色。能生初禅地眼识。复生欲界。四禅地眼见二禅地色。彼欲界身四禅地眼二禅地色。能生初禅地眼识。四禅地眼见三禅地色。彼欲界身四禅地眼三禅地色。能生初禅地眼识。是谓生欲界。生二禅。三禅地眼见欲界色。彼二禅地身三禅地眼欲界色。能生初禅地眼识。复生二禅。四禅地眼见欲界色。彼二禅地身四禅地眼欲界色。能生初禅地眼识。四禅地眼见三禅地色。彼二禅地身四禅地眼三禅地色。能生初禅地眼识。是谓生二禅。如生二禅。三禅亦尔。是谓余处。如眼界色界眼识界说已。耳界声界耳识界亦尔。颇有处系在鼻。彼处亦系在香。彼处亦系在能生鼻识耶。答曰。有欲界鼻欲界香。能生欲界鼻识。如鼻界香界鼻识界说已。舌界味界舌识界亦尔。颇有处系在身。彼处亦系在细滑。彼处亦系在能生身识耶。答曰。或是处或余处。问曰。云何是处。答曰。生欲界觉欲界细滑。彼欲界身欲界细滑。能生欲界身识。生初禅觉初禅地细滑。彼初禅地身初禅地细滑。能生初禅地身识。是谓是处。问曰。云何余处。答曰。生二禅觉二禅地细滑。彼二禅地身二禅地细滑。能生初禅地身识。生三禅觉三禅地细滑。彼三禅地身三禅地细滑。能生初禅地身识。生四禅觉四禅地细滑。彼四禅地身四禅地细滑。能生初禅地身识。谓细滑能觉自地非觉他地。是谓余处。颇有处系在意彼处亦系在法。彼处亦系在能生意识耶。答曰。或是处或余处。问曰。云何是处。答曰。生欲界中知欲界法。彼欲界意欲界法。能生欲界意识。如是至生有想无想地知有想无想地法。彼有想无想地意有想无想地法。能生有想无想地意识。此谓是处。问曰。余处云何。答曰。生欲界中知初禅地法。彼欲界意初禅地意识法。或三界系或不系。初禅次第知欲界法。彼初禅地意欲界意识法。或初禅地或至有想地无想地。彼生欲界中知二禅地法。彼欲界意二禅地意识法。或三界系或不系。二禅次第知欲界法。彼二禅地意欲界意识法。或二禅地或至有想无想地。彼生欲界中知三禅地法。彼欲界意三禅地意识法。或三界系或不系。三禅次第知欲界法。彼三禅地意欲界意识法。或三禅地或至有想无想地。彼生欲界中知四禅地法。彼欲界意四禅地意识法。或三界系或不系。四禅次第知欲界法彼四禅地意欲界意识法。或四禅地或至有想无想地。彼生欲界中知虚空地法。彼欲界意虚空地意识法。或三界系或不系。虚空处次第知欲界法。彼虚空地意欲界意识法。或虚空地或至有想无想地。彼生欲界中知识地法。彼欲界意识地意识法。或三界系或不系。识处次第知欲界法。彼识地意欲界意识法。或识地或至有想无想地。彼生欲界中知不用地法。彼欲界意不用地意识法。或三界系或不系。不用处次第知欲界法。彼不用地意欲界意识法。或不用地或有想无想地。彼生欲界中知有想无想地法。彼欲界意有想无想地意识法。或三界系或不系。有想无想处次第知欲界法。彼有想无想地意欲界意识法。有想无想地。是谓生欲界中。生初禅中知二禅地法。彼初禅地意二禅地意识法。或三界系或不系。二禅次第知初禅地法。彼二禅地意初禅地意识法。或初禅地或至有想无想地。彼生初禅中知三禅地法。彼初禅地意三禅地意识法。或三界系或不系。三禅次第知初禅地法。彼三禅地意初禅地意识法。或初禅地或至有想无想地。彼生初禅中知四禅地法。彼初禅地意四禅地意识法。或三界系或不系。四禅次第知初禅地法彼四禅地意初禅意识法。或初禅地或至有想无想地。彼生初禅中知空处地识处不用处有想无想处地法。彼初禅地意有想无想地意识法。或三界系或不系。有想无想次第知初禅地法。彼有想无想地意初禅地意识法。或初禅地或至有想无想处地。是谓生初禅。如生初禅。至生有想无想处亦尔。此说是生。问曰。云何正受。答曰。欲界善心次第初禅正受。彼欲界意初禅意识法。或三界系或不系。初禅次第二禅正受顺。彼初禅意二禅意识法。或三界系或不系。从二禅初禅正受逆。彼二禅意初禅意识法。或初禅地或至有想无想处地初禅次第三禅正受顺起。彼初禅意三禅意识法。或三界系或不系。从三禅起初禅正受逆超。彼三禅意初禅意识法。或初禅地或至有想无想地。二禅次第三禅正受顺。彼二禅意三禅意识法。或三界系或不系。从三禅起二禅正受逆。彼三禅意二禅意识法。或二禅地或至有想无想地。二禅次第四禅正受顺超。彼二禅意四禅意识法。或三界系或不系。从四禅起二禅正受逆超。彼四禅意二禅意识法。或二禅或至有想无想处。三禅次第四禅正受顺。彼三禅意四禅意识法。或三界系或不系。从四禅起三禅正受逆。彼四禅意三禅意识法。或三禅地或至有想无想地。三禅次第虚空处正受顺超。彼三禅意虚空处意识法。或三界系或不系。从虚空处起三禅正受逆超。彼虚空处意三禅意识法。或三禅地或至有想无想地。四禅次第虚空处正受顺。彼四禅意虚空处意识法。或三界系或不系。从虚空处起四禅正受逆。彼虚空处意四禅意识法。或四禅地或至有想无想地。四禅次第识处正受顺超。彼四禅意识处意识法。或三界系或不系。从识处起四禅正受逆超。彼识处意四禅意识法。或四禅地或至有想无想地。虚空处次第识处正受顺。彼虚空处意识处意识法。或三界系或不系。从识处起虚空处正受逆。彼识处意虚空处意识法。或虚空处或至有想无想处。虚空处次第不用处正受顺超。彼虚空处意不用处意识法。或三界系或不系。从不用处起虚空处正受逆超。彼不用处意虚空处意识法。或虚空处或至有想无想地。识处次第不用处正受顺彼识处意不用处意识法。或三界系或不系。从不用处起识处正受逆。彼不用处意识处意识法。或识处或至有想无想处识处次第有想无想处正受顺超彼识处意有想无想处意识法。或三界系或不系。从有想无想起识处正受逆超。彼有想无想处意识处意识法。或识处或至有想(无想处)。从不用处次第有想无想处正受顺。彼不用处意有想无想处意识法。或三界系或不系。从有想无想处起不用处正受逆。彼有想无想处意不用处意识法。或不用处或有想无想处。是谓正受。问曰。余正受云何。答曰。此设欲界四种变化意。一者初禅果。二者二禅果。三者三禅果。四者四禅果。初禅果变化心次第世俗初禅现在前。彼欲界意初禅意识法者。彼变化或六入或四。六者己心住。四者非己心住。世俗初禅次第初禅果欲界变化化。彼初禅地意欲界意识法者。变化或六入或四入。问曰。应有六。何故四。答曰。彼不化香味故。问曰。何以不化香味。答曰。莫令成就是故不化。更有说者。彼化香味但彼不成就。如女有女根男有男根。但彼不成就。如是彼化香味但不成就。如是说者必化香味。欲界二禅果变化心次第世俗二禅现在前。彼欲界意二禅意识法者。或六入或四。世俗二禅次第二禅果欲界变化化。彼二禅意欲界意识法者。变化六入。欲界三禅果变化心次第世俗三禅现在前。彼欲界意三禅意识法者。或六入或四。世俗三禅次第三禅果欲界变化化。彼三禅意欲界意识法者。变化六入。欲界四禅果变化心次第世俗四禅现在前。彼欲界意四禅意识法者。彼变化或六或四。世俗四禅次第四禅果欲界变化化。彼四禅意欲界意识法者。变化六入。此余正受也。问曰。若成就眼界彼亦成就色界耶。答曰。如是。若成就眼界彼亦成就色界。颇成就色界不成就眼界耶。答曰。有生欲界不得眼界。设得便失。不得者。生盲及处母胎卵膜渐厚。设得便失者。如眼界。若脱若腐若破若堕若挑若陷若瞟若曀若烟若尘。如是余患坏眼也。问曰。若成就眼界。彼亦成就眼识界耶。答曰。或成就眼界非眼识界。云何成就眼界非眼识界。答曰。生二禅三禅四禅。眼识界不现在前。是谓成就眼界非眼识界。云何成就眼识界非眼界耶。答曰。处胎卵膜渐厚。若生欲界不得眼根。设得便失。是谓成就眼识界非眼界。云何成就眼界亦成就眼识界耶。答曰。生欲界具诸根。亦生初禅及生二禅三禅四禅。眼识界现在前时。是谓成就眼界亦成就眼识界。云何不成就眼界。亦不成就眼识界耶。答曰。生无色界。是谓不成就眼界亦不成就眼识界。问曰。若成就色界。彼亦成就眼识界耶。答曰。或成就色界非成就眼识界。云何成就色界非眼识界耶。答曰。生二禅三禅四禅。眼识界不现在前时。是谓成就色界非眼识界。云何成就眼识界非色界耶。答曰。此无也。云何成就色界亦成就眼识界耶。答曰。生欲界具诸根。亦生初禅及生二禅三禅四禅。眼识界现在前时。是谓成就色界亦成就眼识界。云何不成就色界亦不成就眼识界耶。答曰。生无色界。是谓不成就。色界亦不成就眼识界。问曰。若不成就色界。彼亦不成就眼界耶。答曰。如是。若不成就色界。彼亦不成就眼界颇不成就眼界非不色界耶。答曰。有生欲界不得眼根。设得便失。问曰。若不成就眼界。彼亦不成就眼识界耶。答曰。或不成就眼界非眼识界。云何不成就眼界非眼识界。答曰。处胎卵膜渐厚。若生欲界不得眼根。设得便失。是谓不成就眼界非眼识界云何不成就眼识界非不眼界。答曰。生二三四禅眼识界不现在前。是谓不成就眼识界非不眼界。云何不成就眼界眼识界。答曰。生无色界。是谓不成就眼界眼识界。云何非不成就眼界眼识界。答曰。生欲界具足眼根。生初禅亦生二三四禅。眼识界现在前。是谓非不成就眼界眼识界。问曰。若不成就色界彼亦不成就眼识界耶。答曰。如是若不成就色界彼亦不成就眼识界。颇不成就眼识界非不色界耶。答曰。有生二禅三禅四禅。眼识界不现在前也。问曰。若眼界成就得不成就。彼亦色界成就得不成就耶。答曰。如是若色界成就得不成就。彼亦眼界成就得不成就。颇眼界成就得不成就非色界耶。答曰有。生欲界得眼根便失也。问曰。若眼界成就得不成就。彼亦识界成就得不成就耶。答曰。或眼界成就得不成就非眼识界。云何眼界成就得不成就非眼识界。答曰。生欲界得眼根便失。是谓眼界成就得不成就非眼识界。云何眼识界成就得不成就非眼界。答曰。生二三四禅从眼识界起。是谓眼识界成就得不成就非眼界。云何眼界成就得不成就亦眼识界。答曰。欲色界没生无色界。是谓眼界成就得不成就亦眼识界。云何非眼界成就得不成就亦眼识界。答曰。生欲界具足眼根。生初禅亦生二三四禅。眼识界现在前。是谓非眼界成就得不成就亦眼识界。问曰。若色界成就得不成就。彼亦眼识界成就得不成就耶。答曰。如是若色界成就得不成就。彼亦眼识界成就得不成就。颇眼识界成就得不成就非色界耶。答曰有。生二禅三禅四禅。从眼识界起也。问曰。若不成就眼界得成就彼亦色界不成就得成就耶。答曰。如是若色界不成就得成就。彼亦眼界不成就得成就。颇眼界不成就得成就非色界耶。答曰有。生欲界不具眼根获眼根也。问曰。若不成就眼界得成就。彼亦眼识界不成就得成就耶。答曰。或眼界不成就得成就非眼识界。云何眼界不成就得成就非眼识界。答曰。生欲界眼根不具得眼根。是谓眼界不成就得成眼识界。云何眼识界不成就得成就非眼界。答曰。生二禅三禅四禅。眼识界现在前。是谓眼识界不成就得成就非眼界。云何眼界不成就得成就亦眼识界。答曰。无色界没生欲色界。是谓眼界不成就得成就亦眼识界。云何非眼界不成就得成就亦眼识界。答曰。生欲界眼根具足。生初禅亦生二禅三禅四禅。眼识界现在前。是谓非眼界不成就得成就亦眼识界。问曰。若不成就色界得成就。彼亦眼识界不成就得成就耶。答曰。如是。若不成就色界得成就。彼亦眼识界不成就得成就。颇不成就眼识界得成就非色界耶。答曰有。生二三四禅。眼识界现在前也。如眼界色界眼识界余界亦尔。广说十八界处尽

鞞婆沙论卷第五鞞婆沙论卷第六

        阿罗汉尸陀槃尼撰

        符秦罽宾三藏僧伽跋澄译

    十二入处第十八

十二入者。眼入色入耳入声入鼻入香入舌入味入身入细滑入意入法入。问曰。何以故。彼作经者依十二入而作论。答曰。彼作经者意欲尔。如所欲如是作经与法不相违。以是故。依十二入而作论。或曰。彼作经者无事。问曰。何以故。彼作经者无事。答曰。此是佛契经。彼契经有生闻梵志。彼中食后彷徉游行至世尊所。到已共世尊面相慰劳已在一面坐。一面坐已。生闻梵志白世尊曰。瞿昙。我欲少有所问。听我所问当为我说。世尊告曰。梵志。随所欲问。梵志曰。瞿昙。一切谓一切。瞿昙一切有几所。云何瞿昙。一切一切有施设而施设。世尊告曰。汝梵志。有十二入。从眼入至法入。此梵志有尔所一切。如是如来一切施设而施设。梵志若如是说。此非一切。如沙门瞿昙所施设。我舍此一切。更施设余一切者。彼但有言。数问已不知增益生痴。何以故。如非境界。问曰。若有作是说。尔所一切谓十八界。尔所一切谓五阴及无为。尔所一切谓四圣谛及虚空非数缘尽。尔所一切谓名及色。此亦但有言。数问已不知增益生痴。如非境界耶。答曰。此不然。问曰。若不然者此云何。答曰。此说除义不说除味。此说除施设义不说除施设味。谓一切法性彼尽摄十二入中。若有作是说。我舍十二入义更施设义者。彼终不能施设。是故此说除义不说除味。此说除施设义不说除施设味。说者此十二入妙说快说最说上说。问曰。何以故。此十二入妙说快说最说上说。答曰。谓此入不乱说。及摄一切法界者。虽摄一切法但是乱说。谓一心立七心界阴。虽非乱说但彼不摄一切法。谓摄有为不摄无为。此入非是乱说。及摄一切法。或曰。谓此入中说及摄一切法界者。虽摄一切法但是广说。阴者不摄一切法。亦非中说此入。是中说及摄一切法。以是故。说者十二入妙说快说最说上说。以是故作此论。欲观一切法者。彼当依十二入观。依十二入观已。生十二入法明。及现十二义像。如人莹磨十二镜自观其像。彼一切十二镜中见其像。如是欲观一切法者。彼当依十二入观。依十二入观已。生十二法明。及现十二义像。此入一身一意可得。但有行若干差降。如十二人一家可得。但行各各异。如是十二入虽有一身一意可得。但有行若干差降。此是入性。已种相身所有自然。说性已当说行。何以故说入。入有何义。答曰。输门义是入义。输道义藏义仓义摽义机义田义泉义流义海义白义清义是入义。输门义是入义者。如村城国赀输可得令王官丰富。如是依及缘心心数法可得。谓长养众生。是谓输门义是入义。输道义亦尔。藏义是入义者。如藏中有金银琉璃摩尼可得。谓益众生。如是此依及缘心心数法可得。谓长养众生。是谓藏义是入义。仓义是入义者。如仓中饮食具可得。谓长养众生。如是依及缘心心数法可得。谓长养众生。是谓仓义是入义。摽义是入义者。如此摽下百千众生断其命。如是此依及缘中众生无常所灭。是谓摽义是入义。机义是入义者。如因机织施经纬。如是因此依及缘心心数法施设。是谓机义是入义。田义是入义者。如田中生种种谷。谓长养众生。如是此依及缘心心数法可得。谓长养众生。是谓田义是入义。泉义是入义者。如彼契经。有天到世尊所。以偈而问

  泉从何转　　何转不转　　何所苦乐
  无余灭尽

世尊以偈答曰

  眼耳及鼻　　舌身并意　　泉从是转
  此转不转　　此苦及乐　　无余灭尽

是泉义是入义。流义是入义者。如彼契经。有天到世尊所。以偈而问

  流一切流　　以何制流　　说防护流
  以何塞流

世尊以偈答曰

  谓世诸流　　念者制流　　我说防流
  以慧塞流

是谓流义是入义。海义是入义者。如彼契经说比丘海者。凡愚所未闻。凡人口说也。彼非此圣法中海。是大积聚水数

  眼是入大海　　彼色为涛波
  若忍色涛波　　彼不度眼海
  涛波所回转　　邪魅罗刹持

耳鼻舌身亦尔

  意是入大海　　彼法为涛波
  若忍法涛波　　彼不度意海
  涛波所回转　　邪魅罗刹持

是谓海义是入义。清白义是入义者。此说白清亦尔。轻故彼外书说亦名地亦名作。如彼契经。异学摩竭檀提说。沙门瞿昙。地坏地已坏何所作。是谓输门义是入义。输道藏义仓义摽义机义田义泉义流义海义白义清义是入义。共行说已当说别行。眼入云何。答曰。谓眼色已见当见今见。及此余所有。已见过去。当见未来。今见现在。及此余所有者。谓彼眼识或空或不空。如眼入耳鼻舌身意入亦尔。问曰。色入云何。答曰。谓色眼已见当见今见。及此余所有。已见过去。当见未来。今见现在。及此余所有。如色入声香味细滑亦尔。问曰。何以故。说色入如十色入。何以故。说一色入。答曰。色入者是一名。余者二名。色入者同名。余入者同不同名。彼说不同名。或曰。色入者二眼界。是说色入。或曰。色入者三眼界。肉眼天眼圣慧眼。是说色入。余入者非三眼界。是故不说色入。或曰。色入者二眼界及眼识缘。是说色入。余入者非二眼界。亦非眼识缘。是故不说色入。尊者瞿沙亦尔说。二眼界故及眼识缘故说一色入。或曰。谓色入者能断坏。是说色入。余入者不能断坏。是故不说色入。或曰。色入者大碍能舍。是说色入。余入者非大碍亦不能舍。是故不说色入。或曰。色入者。方所有及施设方。由延所有及施设由延。方所有者。方色入所有。方施设者。因色施设方。由延所有者。由延色入所有。由延施设者。因色施设由延。谓色入。方所有及施设方。由延所有及施设由延。是说色入。余入者。非方所有。亦非施设方。非由延所有。亦非施设由延。是故不说色入。或曰。谓色入者二十种。二十一种是说色入。余入者非二十种。亦非二十一种。是故不说色入。或曰。色入者可施设住此住彼。是说色入。余入者不可施设住此住彼。是故不说色入。或曰。色入者色名及色所有。是说色入。余入者虽色所有但非色名。是故不说色入。有法非色所有。但堕色名。如所说。谓彼息解脱度色无无色。如是色正受身作证游行。此说十一种。是细滑入。何者四大。软涩轻重寒热饮食饥渴。是谓十一种。是细滑入。问曰。何以故。说细滑入。为有所触是细滑入耶。为性细滑是细滑入耶。为细滑缘是细滑入耶。若有所触是细滑入者。不应极微触极微。若性细滑是细滑入者。心心数法亦性细滑非触细滑。若细滑缘是细滑入者。应心心数法缘细滑入非细滑缘细滑。作此论已。答曰。有所触是说细滑入。问曰。不应极微触极微。答曰。不可施设一极微。若施设者多合聚已施设。或曰。谓因身触。谓因身触者是说触。尊者婆须蜜说曰。极微当言触耶。当言非触耶。答曰。当言非触。但等谛交易故。便有触想。尊者昙摩多罗说曰。诸尊极微者当言不触。但色合无中间故。触则有想。如等谛交易故。问曰。谓水中影镜中像是实耶非实耶。若实者面不入镜中。镜亦不入面中。除此已云何更有色。譬喻者说曰。非是实。问曰。何以故非实。答曰。所谓面不入镜中。镜亦不入面中。除此已云何更有色。阿毗昙者说曰。实有种相。是色入及眼识所知。问曰。如面不入镜中。镜亦不入面中。除此已云何更有色。答曰。我无量种成色非是一种。如缘月及阴燧珠。缘器便得水。此真实水用事。如缘日及阳燧珠燧鐟。缘牛粪人方便便得火。真实用火事。如是谓水中影镜中像实有种相。是色入及眼识所知。问曰。如呼声响应。彼是实耶为非实耶。若是实者。谓此发声即灭。除此已云何更有声。譬喻者说曰。非实。问曰。何以故非实。答曰。此间发声即灭。除此已云何更有声。阿毗昙者说曰。实有种相。是声入及耳识所知。问曰。如此发声彼即灭。除此已云何更有声。答曰。我无量种成声非是一种。谓颊齶龂咽舌齿相缘而发声。问曰。法入云何。答曰谓法意识已知当知今知。已知过去。当知未来。今知现在。问曰。如一切十二入尽是法性。何以故说一法入。答曰。如是虽一切十二入是法性。但有一法处所。如十八界虽是法性。但有一法界处所。十智虽是法性。但有一法智处所。七觉意虽是法性。但有一择法觉意处所。六思念虽是法性。但有一念法处所。四意止虽是法性。但有一法意止处所。四辩虽是法性。但有一法辩处所。四信虽是法性。但有一信法处所。三宝三自归虽是法性。但有一法宝一法归处所。如是十二入虽是法性。但有一法入处所。或曰。法入者是一名。余入者有二名。法入者同名。余入者同不同名。彼说不同名。或曰。谓彼法常入不异生老无常不坏。谓灭尽涅槃彼入法入中。是故说一法入。或曰。谓一切有为法封印想。谓三有为相。彼入法入中。是故说一法入。或曰。谓一切有为法说显现诵习。谓名彼入法入中。是故说一法入。或曰。谓觉法是法不觉是我。谓空三昧彼入法入中。是故说一法入。问曰。身见亦入法入中。谓觉法是我。何以故。不因身见说法入耶。答曰。此非如如觉身见。是如如觉空三昧。是谓因空三昧。故说法入非身见。或曰。此法可得。如风所从来。此名风入。如是法入中法可得。是故说法入。或曰。多法可得故说一法入。法入中多有法入。谓色法无色法。可见法不可见法。有对法无对法。相应法不相应法。依法不依法。行法不行法。身法不身法。共缘法不共缘法。是谓多法可得故说一法入。如佛契经。内六入前说眼入。后说乃至意入。外六入前说色入。后说乃至法入。问曰。何以故。世尊内六入前说眼入。后说乃至意入。外六入前说色入。后说乃至法入。答曰。他说随顺故。如是他说随顺。如是应味次第顺。或曰。世尊顺说故他亦顺受。故佛说如是顺受亦如是顺。或曰。因粗细故。内六入何者最粗眼入是。是故佛前说。何者最细意入是。是故佛最后说。外六入何者最粗色入是。是故佛前说。何者最细法入是。是故佛最后说。是因粗细故。佛契经内六入前说眼入。后说乃至意入。外六入前说色入。后说乃至法入。佛契经说。比丘此岸者内六入是。比丘彼岸者外六入是。问曰。何以故。佛契经内六入说此岸。外六入说彼岸。答曰。近远法故。如河近者此岸远者彼岸。如是谓心心河依者近缘者远。是谓近远法故。或曰。下上法故。如河谓所下处是此岸所上处是彼岸。如是心心法所依下所缘上。是谓下上法故。或曰。彼岸者第一义灭尽涅槃。彼摄外入。以是故佛契经内六入说此岸。外六入说彼岸。问曰。云何河。答曰。心心法是。如河两岸所持众生数非众生数漂流入大海。如是心心法河内外入岸所持漂流众生入生死海。问曰。云何船。答曰。圣道是如依船筏。无量众生而得渡河。如是依圣道船筏。无量众生渡生死河。佛契经说。六入当知。内六更乐入当知内。问曰。如此外亦当知。何以故。世尊说六入当知内六更乐当知内。答曰。世尊于契经中说内观。世尊说内入诸根意。莫向外前内想内身。身观后外后内外。是前内观故。或曰。世尊教弟子不颠倒观故。世尊说曰。莫颠倒观常乐净我。当观无常苦空无我因习本缘。以圣八行破坏有。是谓不颠倒观故。或曰。世尊教弟子不共观故。世尊说莫共观粗涩。当观如病痈箭蛇无常苦空无我。内六更乐火烧有。是不共观故。或曰。佛契经说内意止。问曰。何以故。佛说内意止。答曰。为我故计有我。是吾作是我作。爱我已便有爱具。长养内故求外具。以是故佛契经说。六入当知。内六更乐入当知内。问曰。六入六更乐入何差别。一说者无差别。六入者眼入耳鼻舌身意入。六更乐入亦眼入耳鼻舌身意入。是故无差别。更有说者。有差别。谓近者是六入。谓远者是六更乐入。问曰。如汝说六入者是现在。六更乐者过去未来。更有说者。谓近者是六更乐。谓远者是六入。问曰。如汝说六更乐入是现在。六入者是过去未来。或曰。谓当行时转是六更乐入。余者是六入。或曰。谓依六入作行是六入。谓依六更乐作行是六更乐入。或曰。谓所有是六更乐入。余所有者是六入。如说比丘钵彼性是钵如比丘用事。是故说比丘钵如是谓所有是六更乐入。余所有者是六入。尊者陀罗难提说曰。性入者是六入。行入者是六更乐入。如说铁酥钵性是铁。钵如依酥用事。是故说铁酥钵。如是性入者是六入。行入者是六更乐入。佛契经说。二入无想众生及有想无想天。问曰。何以故。佛契经说。二入无想众生及有想无想天。答曰。余地二种名。一者识住。二者众生居。欲令二入中作二名。谓此虽有众生居名但无识住名。是谓二名。故佛契经说。二入无想众生及有想无想天。或曰。佛契经众生居识住处等施设已。谓众生居于识住中不摄。彼立二入。无想众生及有想无想天。或曰。多寿故。一切凡夫处所无有尔所寿如无想天。一切处所无有尔所寿。如有想无想天。是谓多寿。故佛契经说。二入无想众生及有想无想天。或曰。断异学意故。异学二入中计意解脱想。世尊说此是生死入非是解脱。是谓断异学意。故佛契经说。二入无想众生及有想无想天。或曰。行法故。异学于二入中计意无行解脱。世尊说此中复行诸界诸趣诸生轮转生死中。是谓行法。故佛契经说。二入无想众生及有想无想天。或曰。退转法故异学于二入中计意不退转解脱。世尊说此中复退转诸界诸趣诸生轮转生死中。是谓退转法。故佛契经说。无想众生及有想无想天。此佛契经。尊者舍利弗到世尊所已而说曰。世尊。此无上事谓世尊施设入。彼世尊无余智无余分别。更无无上智。谓余智若沙门婆罗门等等觉。问曰。尔所一切谓十二入。尊者舍利弗非一切智非一切见。云何知尔所一切谓十二入。答曰。说无余故知。如佛契经说十一入已后说法入。尊者舍利弗意决定诸法未说未现彼一切。当知在入中。或曰。以妙愿智观已知。或曰以相貌知。如佛契经说。尔所一切谓十二入。尊者舍利弗得无坏信。彼世尊所说倍极信。以故知尔所一切十二入。是谓相貌知也。问曰。云何尊者舍利弗相貌知非现知耶。答曰。现知亦知。尊者舍利弗因十二入故亦知一切法。问曰。若尊者舍利弗因十二入故亦知一切法。佛舍利弗有何差别。答曰。佛世尊一切知尽知。尊者舍利弗虽一切知。但不能尽知。或曰。尊者舍利弗总十二入。故知一切法非一一相。佛世尊知总相。亦知一一相有无量内入。谓尊者舍利弗从他。如世尊说此契经。舍利弗以何口说此妙。一向师子吼。更无有沙门婆罗门于世尊等等觉。何况出上。尊者舍利弗白世尊曰。躬从世尊闻。躬自受持如如来所说。阿难无有此处。前后有二如来兴出世无有是处。问曰。云何世尊为受化说界云何入。答曰。世尊教化一切法中无智。或非一切法中无智。谓一切法为说界。非一切法中无智者为说入。或曰。世尊教化或利根或钝根。利根者为说入。钝根者为说界。或曰。世尊教化或大因力或多缘力。大因力者为说入。多缘力者为说界。或曰。世尊教化或多内力或多外力。内多力者为说入。外多力者为说界。或曰。世尊教化内思念长养身。或从他闻。内思念长养身者为说入。从他闻者为说界。或曰。世尊教化或始开则知。或分别知。始开知者为说入。分别知者为说界。或曰。于界有愚为说界。于入有愚为说入。或曰。有猗性者为说界。性义是界义。猗财物者为说入。输门义是入义。如是世尊教化为说界。如是教化为说入。广说十二入处尽

    鞞婆沙五阴处第十九

五阴者。色阴痛阴想阴行阴识阴。问曰。色阴云何。答曰。佛契经说。色阴云何。诸所有色。过去未来现在。若内若外若粗若细若恶若妙若远若近。彼一切非我我非彼非是我。如是以慧如真实观。是谓色阴。如是更有契经说。色阴云何。诸所有色。彼一切四大及四大造色。阿毗昙中说。色阴云何。十色入及诸色在法入中。问曰。此三种说何差别。答曰。一切三说中各各断意。问曰。谓契经说。色阴云何。诸所有色。过去未来现在。若内若外若粗若细若恶若妙若远若近。彼一切非我我非彼非是我。如是以慧如真实观。于中断何意。答曰。是时彼异学牢罗尸弃。过去未来欲令非种。欲断彼意故契经说。色阴云何。诸所有色。过去未来现在。若内若外乃至如是以慧如真实观。问曰。如所说色阴。云何诸所有色彼一切四大及四大造色于中断何意。答曰。观当来故。佛世尊说契经。一切智善觉善见过去未来现在。我般涅槃后当来世。必有谓离四大不欲令有造色。欲断彼意故契经说色阴云何。诸所有色。彼一切四大及四大造色。问曰。如所说色阴云何。十色入及诸色在法入中。于中断何意。答曰。彼时有尊者昙摩多罗。谓法入中色不欲令有种。问曰。何以故。尊者昙摩多罗谓法入中色不欲令有种。答曰。彼说谓色因五识身五识身缘是谓色。彼在法入中色。非因五识身。非五识身缘。是故彼非色。欲断彼意故说数。色阴云何。十色入及诸色在法入中。问曰。若尔者尊者昙摩多罗所说云何通。彼说谓色因五识身五识身缘是谓色。彼在法入中色。非因五识身非五识身缘。答曰。可说谓非因五识身。但六识身缘。彼在法入中色。虽不因五识身亦非五识身缘。但因意识身意识身缘。或曰。虽彼在法入中色非因五识身亦非五识身缘。但彼因依缘依。问曰。云何彼依。答曰。四大也。问曰。痛阴云何。答曰。佛契经说。痛阴云何。六身痛。此如契经所说阿毗昙亦尔。问曰。想阴云何。答曰。佛契经说。想阴云何。六想身。此如契经所说阿毗昙亦尔。问曰。行阴云何。答曰。佛契经说。行阴云何。六思身。阿毗昙说。行阴云何。答曰。行阴二种。一者心相应。二者心不相应。问曰。心相应行阴云何。答曰。痛想思更乐忆欲解脱念定慧善根不善根无记根结缚使烦恼缠所知所见所观。如是诸所有心相应行。是谓心相应行阴。问曰。云何心不相应行阴。答曰。得无想定灭尽定无想命根种类得处得种得入生老死无常名身句身味身。如是诸所有心不相应行。是谓心不相应行阴。问曰。何以佛世尊一切相应不相应行阴中。一思立行阴耶。答曰。此思施设行时摄受种。是故佛一切相应不相应行阴中。一思立行阴。如爱施设习时摄受种。是故佛一切有漏种一爱立习谛。如是此思施设行时摄受种。是故佛一切相应不相应行阴中一思立行阴。问曰。识阴云何。答曰。佛契经说识阴。云何六识身。此如契经所说。阿毗昙亦尔。此是阴性已种相身所有自然。性说已当说行。何以故说阴。阴有何义。答曰。聚义是阴义。团义积义捡义。世施设阴施设。多语是阴义。聚义是阴义者。诸所有色过去未来现在。彼一切一向捡已立一色阴。如是至识阴。是谓聚义是阴义。团义是阴义者。无量有为种团合已立五阴。是谓团义是阴义。积义是阴义者。犹粪积聚种种积。如是阴种种积。捡义是阴义者。诸所有色过去未来现在。若内若外若粗若细若恶若妙若远若近。彼一切一向捡已立一色阴。乃至识阴亦尔。是谓捡义是阴义。世施设阴施设者。谓色阴三世乃至识阴亦三世。是世施设阴施设。多语是阴义者。谓色多语乃至识阴亦多语。问曰。如汝说一极微不应有色阴。谓彼无多语。答曰。不可以一极微施设。若施设者。便多聚敛施设。阿毗昙者若掌护阴施设。彼说极微摄一界一入一阴少入。若不掌护者。彼说极微一界一入一阴。如人大谷聚取一粒去。他问人何所持。彼人若掌护谷聚者。说此谷聚中一粒。若不掌护者。说此谷一粒。如是阿毗昙者。若掌护阴施设。彼说极微一界一入一阴少入。若不掌护者。彼说极微一界一入一阴。是说多语阴语。是谓聚义是阴义团义积义捡义世施设阴施设多语阴语是阴义。问曰。何以故。世尊前说色阴后说识阴。答曰。随顺他故。如是随顺他。应味次第顺。或曰。世尊说随顺受教者亦顺。或曰。粗细故。五阴中何者最粗。色阴是。是故佛前说四无色阴。何者最粗。痛阴是。是故佛前说。问曰。此痛无形无处亦不可见。云何粗细可知。答曰。行故知。如所说手痛足痛头痛如是。如是痛是行故知有粗细。何者最细识阴是。是故佛后说。以是故。佛契经前说色阴后说至识阴。问曰。何故心数法中痛阴想阴别立阴。余心数法立行阴。答曰。佛世尊于法真谛。余真无能过。彼尽知法相尽知行。谓法独能担彼别立。谓品能担彼立品。或曰。此现二门二略二度二炬二光二明现二数。如痛阴想阴别立阴。如是余心数法亦应立。如余心数法立一行阴。如是痛想亦立行阴中。如是阴或立三或十三。是故说此现二门二略二度二炬二光二明二数。或曰。谓此二界宗因。痛宗禅因想宗无色。或曰。谓因二法行者二界多求痛劳。因痛于禅疲劳。因想于无色疲劳。或曰。谓因二法众生生死中受无量苦。贪于乐痛及着颠倒想。或曰。谓二法灭立二定。无想定及灭尽定。或曰。谓二法治故。彼行者入二定。无想定及灭尽定。或曰。谓此二法别受二识住名。痛识住。及想识住。余心数法一行识住。以是故。一切心数法。痛阴想阴别立阴。余心数法立一行阴。问曰。何以故。说行阴如一切五阴有为。何故立一行阴。答曰。谓彼思有为想此入中。是故说行阴。或曰。谓彼一切有为法。封印想谓三有为想。彼入中是故说一行阴。或曰。谓一切有为法显现诵习。谓名彼尽入中。是故说一行阴。或曰。谓一切有为法因习本缘。谓生彼尽入中。是故说一行阴。或曰。多法合聚故说一行阴。多有法入此中。相应不相应依不依行不行身不身共缘不共缘。是谓多法合聚故说一行阴。问曰。无为何以故。不立阴中。答曰。谓非阴名亦非阴性。非色名亦非色性。是故不立色阴中。非痛名亦非痛性。是故不立痛阴中。非想名亦非想性。是故不立想阴中。非行名亦非行性。是故不立行阴中。非识名亦非识性。是故不立识阴中。若作是念者。何以故。不立行中。阴者多有种。多种者非无为。或曰。阴者堕生老无常。无为者无生老无常。或曰。阴者兴衰法有因得有为相。无为者非兴衰法无因得无为相。或曰。阴者世回转作行受果知缘。无为者非世回转不作行不受果不知缘。或曰。阴者堕于世。无为者不堕世。或曰。阴者堕于阴。无为者离于阴。或曰。阴者苦所缚。无为者离苦缚。或曰。阴者软中上。无为者无软中上。或曰。阴者前后可得。无为者无前后。以是故。无为不立阴中。彼佛契经说八万法身。问曰。法身者有何齐限数。有一说者。一数经名法身。谓彼一身。是谓一身齐限数。如是至一切八万。更有说者。谓契经说。意止此是一法身齐限数。如是契经说。意断神足根力觉种道种。是谓一法身齐限数。如是至一切八万。算者说。八字一句三十二字为一首卢数

  有五百千　　亦复五千　　五百五千
  一法身数

如是至八万。如是说者。佛契经教化故说八万度。谓度受化于圣道得度。彼八万度名八万法身。问曰。谓此有尔所身何以故。立五阴身。答曰。彼一切入五阴身中。谓欲者佛语教性。彼尽入色阴中。谓欲者佛语名性。彼尽入行阴中。是故一切八万法身尽入五阴中。此佛说契经。谓余五阴身。戒身定身慧身解脱身解脱知见身。问曰。如此余五阴身。何以故。立五阴。答曰。彼亦尽入中。戒身入色阴中。余者入行阴中。以是故佛契经说五阴。广说五阴处尽

    鞞婆沙五盛阴处第二十

五盛阴者。色盛阴痛盛阴想盛阴行盛阴识盛阴。问曰。色盛阴云何。答曰。谓色过去未来现在。欲生而生。恚怒痴及余若干心烦恼生而生。彼欲生而生者爱是。恚者嗔是痴者无明是。及余若干心烦恼生而生者。谓彼心相应烦恼。说曰。此不应说恐生而生。问曰。何以故。答曰。恐者无智性。谓众生无智彼便恐。更有说者。恐者身见性。谓众生计有我彼便恐。此亦入中。如所说及余若干心烦恼。如是说者此恐应说。问曰。何以故。答曰。恐者心数法心相应。问曰。此恐何所。答曰。在欲界非色无色界。问曰。若色无色界无恐者。彼契经云何通。彼风吹火至梵处。谓众生生光音天不久。未曾见世间成败。不知世间成败彼见火已恐怖惊愕身毛竖。火不来至此耶。谓众生前生光音天。彼见世间成败。彼知世间成败。见火已慰劳彼众生。诸众生勿恐怖。诸众生勿恐怖。是火极至彼不至此。如汝所说。色无色界恐怖者。此云何通。如是余偈云何解

  世尊知一切　　说法成就眼
  如来人师子　　世中无比士
  彼时长寿天　　名称色微妙
  闻已惊恐怖　　如鹿畏师子

若色无色界无恐怖者。此云何通。答曰。恐怖者此说厌。问曰。恐怖厌者何差别。答曰。名即是差别。此恐怖彼厌。是谓差别。或曰。恐怖者欲界。厌者三界。或曰。为结障碍恐怖。为善根障碍是厌。尊者婆须蜜说曰。恐怖及厌何差别。答曰。为结障碍是恐怖。为善根障碍是厌。重说曰。为不善法障碍是恐怖。为善法障碍是厌。重说曰。二谛摄是恐怖。三谛摄是厌。重说曰。无智性是恐怖。慧性是厌。尊者昙摩多罗说曰。诸尊思念恶起诤是恐怖。诤已心惧相是厌。恐怖及厌是差别。问曰。恐怖者为凡夫为圣人。答曰。恐怖者凡夫非圣人。问曰。何以故。恐怖者凡夫非圣人耶。答曰。彼圣人恐怖已尽。更有说者。凡夫亦有恐怖。圣人亦有恐怖。问曰。如圣人恐怖已尽。何所有恐怖。答曰。有五恐怖。死恐怖恶趣恐怖不活恐怖恶名恐怖众中恐怖。此五恐怖圣人已尽。余恐怖圣人未尽。圣人者。须陀洹斯陀含阿那含阿罗汉辟支佛非佛。何以非佛。答曰。如来无所著等正觉恐怖永尽。如色盛阴痛想行识盛阴亦尔。此是盛阴性。已种相身所有自然。说性已当说行。何以故说盛阴盛阴有何义。答曰。受所生是故说盛。谓生受是故说盛。受所养是故说盛。谓养受是故说盛。受所长是故说盛。谓长受是故说盛。受所来是故说盛。谓来受是故说盛。受所持是故说盛。谓持受是故说盛。受所等持是故说盛。谓等持受是故说盛。或曰。受所转是故说盛。谓转受是故说盛。或曰。受着此中如尘垢。是故说盛。或曰。受于此中所摄是故说盛。或曰。此是受屋室居处。依此已爱生而生。见慢无明及余若干心烦恼生而生。或曰。此受所有是故说盛。如外职所有。如内职所有。如王所有。如是此受所有是故说盛。但内更无所有。若有问者。汝属谁谓作是。答我是受所有。或曰。受所广施设是故说盛。谓广施设受是故说盛。广者说痛为名。此盛阴界中不别施设。地中不别施设。除其意。谓因我阴余得盛阴名。因余阴我得盛阴名。若此意不别施设者。此外物不可施设阴以故尔。问曰。阴及盛阴何差别。答曰。名即是差别。彼阴此盛阴。或曰。阴有漏无漏。盛阴一向有漏。或曰。阴染污不染污。盛阴一向染污。或曰。阴摄三谛。盛阴摄二谛。或曰。阴或断或不断。盛阴一向断。或曰阴或受相应或不相应。盛阴一向相应。或曰。阴得或结相应或不相应。盛阴得一向结相应不离结。或曰。阴或学或无学或非学非无学。盛阴一向非学非无学。阴及盛阴是谓差别。广说五盛阴处尽

    鞞婆沙六界处第二十一

六界者。地界水界火界风界空界识界。问曰。何以故作此论。答曰。此是佛契经。此佛契经十八界总已说六界。问曰。何以故。此佛契经十八界总已说六界。答曰。为教化故。世尊教化。或有利根或有钝根。利根者说六界。钝根者说十八界。如利根钝根。如是因力缘力内力外力内思惟长养。从他闻尽当知。或曰。略者说六。广者说十八。如略如广如是分别不分别。卷及舒改不改。渐渐一时尽当知。以是故作此论。六界者。地界水界火界风界空界识界。此六界于十八界中摄十界七界少所入。摄十界者。四大及空界摄十界。眼界色界耳界声界鼻界香界舌界味界身界细滑界。七界少所入者。识界摄七心界。少所入谓彼有漏无漏。谓有漏者摄。无漏者不摄。是故少所入。六界者地界水界火界风界空界识界。问曰。地界云何。答曰。佛契经说。地界云何坚是。此佛总说地界云何坚是。但彼坚无量差别。内异外亦异。外异者。如此屋墙壁树木岩石山金银琉璃摩尼水精珠铜铁铅锡白镴。内异者。如发毛爪齿筋骨脾肾心肝肠胃腹大小便手足异。及余支节异。足极坚非手。谓内外坚。彼一切总已说地界云何坚是。问曰。水界云何。答曰。佛契经说。水界云何湿是。此佛总说水界云何湿是。但彼湿无量差别。内异外亦异。内异者。如此目泪涎唾膏肪髓脑胆脓血小便支节间各异。外异者。涌泉深渊流水澹水河水池水大海。至下水轮谓内外湿。彼一切总已说。水界云何湿是。问曰。火界云何。答曰。佛契经说。火界云何热是。此佛总说。火界云何热是。但彼热无量差别。内异外亦异。内异者。令身热身温暖身烧身燋热得名数。饮食啖味令身安隐。手足各异支节亦异。外异者。如炬火灯火大聚火极大火鐟火泥犁火沷燋火。谓内极利非外。谓此饮食举着釜中极煮色不变。食入腹中已色即变。谓内外热。彼一切总已说。火界云何热是。问曰。风界云何。答曰。佛契经说。风界云何。谓吹起是。此佛总说风界。云何吹起。是但吹起无量差别。内异外亦异。内异者。下风上风支节风腹中风力风脊风起风屈申风喘息风百脉风支节间各异。外异者。如尘土风无尘风随蓝风飘风成败风不成败风至风轮。谓内外吹起。彼一切总已说。风界云何吹起是。问曰。空界云何。答曰。佛契经说。空界云何。谓色边色。谓色者造色是。于彼间施设。如眼空耳空鼻空口空咽喉空。饮食来往处空。住消处空。下过处空。更有说者。空界云何。空边色是。此说空色不空色。不空色者众生数。空色者非众生数。谓彼空非众生数色边施设。如树间叶间墙间屋间牖间户间。是谓空非众生数色边施设。旧阿毗昙说。皮性膜性肉性筋性骨性髓性。色可知处亦可知。尊者婆须蜜说曰。云何知有空界。答曰。契经可知。世尊亦说。谓此空中空诸所色覆所不覆。问曰。云何契经可知非现知耶。答曰。现亦可知。谓昼所有明是空界所有。谓夜所有闇是空界所有。重说曰。形可知处亦可知。重说曰。夜闇障故不见。昼明障故不见。尊者昙摩多罗说曰。诸尊空界虽不可知。但非无智处。空界是色非是色。亦非此住非彼住。亦非空者相貌声世转可知。问曰。空空界何差别。答曰。空者非色。空界是色。空者不可见。空界者可见。空者无对。空界者有对。空者无为。空界者有为。问曰。此论中更有论生。若空无为者。此契经云何通。彼时世尊手扪摸空。手扪摸空已告诸比丘。比丘于意云何。手宁着此空缚空受空不。答曰。不也世尊。若空无为者。何以故。世尊以手扪摸无为耶。如是余契经偈云何通

  谓无积聚　　亦无我所　　空则无想
  于离中行　　如鸟飞空　　足迹难寻

此云何通。如是余契经偈云何解

  此空无足迹　　如外无沙门

此云何通耶。如是余契经云何通。于比丘意云何。若巧画师画弟子。宁能以色庄染此虚空不。答曰。不也世尊。何以故。唯世尊。此虚空非色不可见无对。是故巧画师画弟子。不能以色庄染此虚空。此云何通。如是余偈云何解

  如鹿依林　　鸟飞虚空　　法归分别
  真人趣灭

此云何通。答曰。谓世尊契经说。于比丘意云何。手宁着此空缚空受空不。答曰。不也世尊。此佛契经以虚空界说虚空。如佛所说契经偈

  谓无积聚　　亦无我所　　空则无想
  于离中行　　如鸟飞空　　足迹难寻

此佛契经偈虚空即说虚空。如佛所说契经偈

  此空无足迹　　如外无沙门

此佛契经偈虚空界说虚空。如佛契经说。于比丘意云何。若巧画师画弟子。宁能以色庄染此虚空不。答曰。不也世尊。唯世尊。此虚空非色不可见无对。是故巧画师画弟子。不能以色庄染虚空。此佛契经以虚空界说虚空。如佛契经说偈

  如鹿依林　　鸟飞虚空　　法归分别
  真人趣灭

此佛契经说偈。以虚空界说虚空。问曰。彼虚空此虚空界为缘故住耶。为起故住耶。作此论已。有一说者。亦非缘故住。亦非起故住。问曰。若不尔者此云何。答曰。彼虚空此普散。虚空界与次第缘普散。虚空界次第四大。四大次第心数法。若有欲虚空界非种者。谤彼尔所法展转。问曰。识界云何。答曰。有漏意及六识。问曰。无漏法何以不立六界中。答曰。无漏法者。能灭坏破。有此界增受长养有。或曰。无漏法者。能断有相续。能断轮转生老死。此界者。能相续有轮转生老死。或曰。无漏法者。非身见种非颠倒种。非爱种非使种。非贪处非恚处非痴处。非杂污非杂毒非杂浊。非在有。不堕苦习谛。此界者。身见种颠倒种爱种使种。贪处恚处痴处。杂污杂毒杂浊。在有堕苦习谛。或曰。无漏法者。苦尽趣道。有尽趣道。贪尽趣道。尽生老死趣道。界者。苦习趣道。有习趣道。贪习趣道。生老死习趣道。以是故无漏法不立界中。尊者婆须蜜说曰。何以故此界说有漏。答曰。此界有漏所生。非无漏法有漏所生。重说曰。此生于有漏。不无漏法生于有漏。重说曰。界者士数。非无漏法士数。重说曰。界者报数。不无漏法报数。重说曰。界者入母胎。如所说因此界入母胎。非因无漏法入母胎。重说曰。界者久时住。不无漏法久时住。是故说数

  二漏为士　　数及报应　　母胎久住
  作界满偈

问曰。阴盛阴界何差别。答曰。阴者已成势。盛阴者转势。界者重转势。或曰。阴者施设有为。盛阴者施设行。界者施设有漏。阴盛阴界。是谓差别。广说六界处尽

鞞婆沙论卷第六鞞婆沙论卷第七

        阿罗汉尸陀槃尼撰

        符秦罽宾三藏僧伽跋澄译

    色无色法处第二十二

色法者无色法者。问曰。何以故作此论。答曰。断计我人意故。及现大妙智故。断计我人意者。此色法无色法非是我。现大妙智者。若有行智成就智。彼以此二句便知一切法。谓此俱摄一切法。具足一切法。是谓断计我人意故及现大妙智。故作此论。色法无色法者。问曰。色法云何。答曰。十色入及一入少所入法入是。问曰。无色法云何。答曰。一入意入是。及一入少所入法入是。问曰。何以故说色法无色法。答曰。谓二眼界是色。谓非二眼界是无色。或曰。谓三眼界。肉眼天眼圣无上慧眼是色。谓非三眼界是无色。或曰。谓二眼界及眼识缘是色。谓非二眼界及非眼识缘是无色。或曰。谓四大所有及造色所有是色。谓非四大所有。及非造色所有是无色。或曰。谓二十种。及二十一种是色。谓非二十种。及非二十一种是无色。或曰。谓方所有及方施设。由延所有及由延施设是色。谓非方所有及非方施设。非由延所有及非由延施设是无色。或曰。谓色名及色所有是色。谓非色名及非色所有是无色。或曰。谓粗可见睹可现是色。谓细非可见非睹是无色。尊者婆须蜜说曰。云何为色相。答曰。渐渐生相是色相。重说曰。渐渐开张相是色相。重说曰。方所受相是色相。重说曰。处施设相是色相。重说曰。有障阂相是色相。重说曰。愚相是色相。重说曰。三相是色相。有色可见有对。有色不可见有对有色不可见无对。重说曰。持去相持来相是色相。重说曰。种相是色相。问曰。过去当来色及极微。复无教色不可种。欲令非是色耶。答曰。过去色已种。当来色当种。极微者虽非一可种。但余极微合聚种。无教色者。虽不可种但教色可种。彼教色种已无教色。亦当言种如动树。当知影亦动此亦尔。重说曰。覆虚空相是色相。重说曰。四大因相是色相。重说曰。色者无色相。问曰。何所说。答曰。色者无一色相。何以故。谓眼界异相至细滑界亦异相。重说曰。有对相是色相。此说数

  渐渐生成　　开施设方　　处障阂愚
  三去来种　　覆空与因　　一相并对

余者无色。广说色无色处尽

    鞞婆沙可见不可见法处第二十三

可见法者不可见法者。问曰。何以故作此论。答曰。断计我人意故。及现大妙智故。断计我人意者。此是可见法。不可见法是非我。现大妙智者。若有行智成就智。彼以此二句便知一切法。谓此俱摄一切法。具足一切法。是谓断计我人意故及现大妙智故作此论。复何以故作此论。答曰。或有欲令一切法可见。慧眼界故。谓若有欲尔者。断彼意故说可见法不可见法。是谓断他意。现己意说法如等故作此论。莫令断他意。亦莫现己意但说如等法故作此论。可见法不可见法者。问曰。可见法云何。答曰。一入是。问曰。不可见法云何。答曰。十一入是。问曰。何以故说可见不可见法。答曰。谓眼行是可见。谓非眼行是不可见。或曰。谓眼光是可见。谓非眼光是不可见。或曰。谓二眼界是可见。谓非二眼界是不可见。或曰。谓三眼界是可见。谓非三眼界是不可见。或曰。谓二眼界及眼识缘是可见。谓非二眼界亦非眼识缘是不可见。尊者瞿沙亦尔说。二眼界及眼识缘故说可见。余者不可见。尊者婆须蜜说曰。可见法有何义。答曰。可示现是可见。重说曰。可示他是可见。眼行光来是可见。重说曰。可说此彼是可见也。不可见有何义。答曰。不可示现是不可见。重说曰。不可示现他是不可见。重说曰。非眼行光来是不可见。重说曰。不可说此彼是不可见。广说可见不可见法处尽

    鞞婆沙有对无对处第二十四

有对法者无对法者。何以故作此论。答曰。断计我人意故。及现大妙智故。断计我人意者。此是有对法。无对法非是我。现大妙智者。若有行智成就智。以此二句便知一切法。谓此俱摄一切法。具足一切法。是谓断计我人意故及现大妙智故作此论。有对法无对法者。问曰。有对法云何。答曰。十入是。无对法云何。答曰。二入是。问曰。何以故说有对无对法。答曰。有对者说三种。一者障碍有对二者界有对。三者缘有对。障碍有对者。如手手相碍。手与外种相碍。外种外种相碍。外种与手相碍。界有对者。如眼界有碍。如是至意法界有碍。缘有对者。如意识共相应一切法碍。婆须蜜经说。因眼色阂。因色眼亦碍。至因意法碍。因法亦意阂。彼尊者婆须蜜说。此一向界碍是谓三种有对。于三种有对中此因界有对作论。非余有对。或曰。谓大障碍能舍是有对。谓非大障碍非舍是无对。或曰。谓粗可见睹可现是有对。谓细不可见不可睹不可现是无对。或曰。谓种生长是有对。内事种者。谓时精系。母胎生者。谓时彼精。渐厚长者。谓时肉段生。胞外种者。谓时以种子。种地中生者。谓时子生。萌芽长者。谓时生茎节华果。谓种生长是有对。谓若不种不生不长是无对。或曰。谓可知此住彼住是有对。谓不可知此住彼住是无对。或曰。谓因四大造色所有是有对。谓不因四大非造色所有是无对。或曰。谓方所有施设方由延所有由延施设是有对。谓非方所有非施设方非由延所有非由延施设是无对。或曰。谓可知长短是有对。谓非可知长短是无对。尊者婆须蜜说曰。何以故说有对无对。答曰。谓大障碍是有对。谓非大障碍是无对。重说曰。谓能舍是有对。谓非能舍是无对。重说曰。谓大障碍者即是能舍。谓能舍者即是有对。余者无对。重说曰。微合是有对。重说曰。阴是有对。重说曰。覆虚空是有对。重说曰。微合者即是阴。阴者覆虚空。覆虚空者即是有对。余者是无对。问曰。何入障碍何入。有一说者。五入障碍内中身入。外色香味细滑。余入不可触。更有说者。九入障碍除眼入。如是说者。一切十入障碍。问曰。何以故。答曰。如手手相障碍。如是若以手覆眼为非障碍耶。是故一切十入障碍。谓手手相障碍时。尔时五五相障碍。手与外事障碍时。尔时五障碍。四外事外事相障碍时。尔时四四相障碍。外事障碍手时。尔时四障碍五。广说有对无对法处尽

    鞞婆沙有漏无漏处第二十五

有漏法者无漏法者。何以故作此论。答曰。断计我人意故。现大妙智故。断计我人意者。此是有漏法。无漏法非是我。现大妙智者。谓行智成就智。彼以此二句知一切法。谓此俱摄一切法。具足一切法。以是故作此论。复何以故作此论。答曰。欲令断他意故。或有欲令佛身一向无漏。鞞婆阇婆提欲令佛身一向无漏。问曰。何以故彼欲令尔。答曰。彼从佛契经起已。欲令佛身一向无漏。佛说契经。如来生世间长世间。不着世间法行。如来无所著等正觉。出一切世间上。彼从此契经起。欲令佛身一向无漏。欲断彼意故。于此佛身说有漏。问曰。若佛身是无漏者。当有何咎。答曰。若佛身一向无漏者。彼无喻女不应起淫意。鸯掘魔不应起嗔恚。慢高儿不应起慢。郁鞞罗迦叶不应起痴意。如此此中或有着或有嗔或痴或有慢。以是故知佛身是有漏。问曰。若佛身一向有漏者。此鞞婆阇婆提契经云何通。答曰。彼契经因法身故说。如来生世间长世间者。此说生身不着世间法行。如来无所著等正觉出一切世间上者。此说法身。或曰。离世八法故说。世八法者。随顺世间。世间亦随顺八法。八法虽顺世尊。然世尊不随顺八法。是谓离八法故说。世八法者。利不利称不称誉不誉乐苦。此世八法摄十八界十二入五阴。此总说世八法摄十八界十二入五阴。但利有二种。有众生数非众生数。众生数利者。象马牛羊[犛-未+牙]牛奴婢妻子利是众生数。非众生数利者。谷珍宝金银水精琉璃摩尼真珠车渠马瑙是非众生数利。于中众生数利摄十八界十二入五阴。非众生数利摄六界六入二阴。称不称誉不誉乐苦摄一界一入二阴。彼一切总已说。世八法摄十八界十二入五阴。世八法者。利不利称不称誉不誉乐苦。问曰。利云何。答曰。前已说利有二种。众生数非众生数。此已得当得今得。是谓为利。非利云何。答曰。如此法非已得非当得非今得。是谓非利。称云何。答曰。面称其德是谓称。不称云何。答曰。面前讥贬其阙是谓不称。誉云何。答曰。不面前称扬其德是谓誉。不誉云何。答曰。不面前说其过是谓不誉。乐云何。答曰。乐痛六识身乐是谓乐。苦云何。答曰。苦痛六识身是谓苦。说曰。世世此八法一向是欲界。问曰。若世八法一向是欲界者。当除欲界结时世八法亦尽。何以独说世尊离世八法。不说声闻。答曰。离相似故说。说者若二阿罗汉根等。一者极得供养。二者不具供养。于彼一者起相似不如慢。二者起相似增上慢。如佛世尊得供养。一切众生有是供养。世尊无者。世尊于彼不起相似慢如毛发想。是谓离相似故说世尊离世八法不说声闻。问曰。世尊亦有世八法。世尊有利者。一日中优伽长者三百千供养。不利者婆罗披罗门村如澡钵入还空钵出鞞罗。若三月食麦。有称者始生时至阿迦贰吒。功德香称充满其中。不称者曰旃遮女孙陀利女。十六大国丑名流布。不誉者喜骂梵志以五百骂偈骂佛。誉者彼还以五百赞偈叹佛。如是婆利多耆奢为首。如是比曰千以百千赞偈叹佛。乐者一切生死禅最为乐。苦者金锵刺足疹患脊风头痛。调达以恶伤足出血。何以故说世尊离世八法耶。答曰。为意不倾动故说。世尊以四利为首不自贡高。四不利为首不以损减。四利为首不以欢喜。四不利为首不以忧戚。四利为首心无染着。四不利为首心无憎恶。四利为首亦不悦豫。四不利为首亦不愁悒。四利为首不兴乐想。四不利为首不以为苦。如须弥山王峙金刚轮。四种风吹不能倾动。如是世尊善住戒德轮。世八法风不能移转。是谓意不倾动故说世尊离世八法。是谓断他意现己意说如等法故作此论。莫令断他意。亦莫现己意。但说如等法故作此论。有漏法无漏法者。问曰。有漏法云何。答曰。十入二入少所入。问曰。无漏法云何。答曰。二入少所入。问曰。何以故说有漏无漏法。答曰。谓有增受长养有是有漏。谓能灭坏破有是无漏。谓有能相续有轮转生死是有漏。谓能断有相续。能断轮转生死是无漏。谓有身见种颠倒种爱种使种。贪处恚处痴处。杂污杂毒杂浊在有堕苦习谛是有漏。谓非身见种非颠倒种非爱种非使种。非贪处非恚处非痴处。非杂污非杂毒非杂浊非在有不堕苦习谛是无漏。或曰。谓苦习趣道有习趣道贪习趣道生老死习趣道是有漏。谓苦尽趣道有尽趣道贪尽趣道生老死尽趣道是无漏。尊者婆须蜜说曰。有漏相云何。答曰。有漏所生是有漏相。重说曰。此生于有漏是有漏相。重说曰。有所长养相是有漏相。重说曰。长养有相是有漏相。重说曰。谓种因有漏生是有漏相。无漏相云何。答曰。非有漏所生是无漏相。重说曰。不生有漏是无漏相。重说曰。谓种因无漏生是无漏相。广说有漏无漏法处尽

    鞞婆沙有为无为法处第二十六

有为法者无为法者。问曰。何以故作此论。答曰。断计我人意故。现大妙智故。断计我人意者。此是有为法。无为法非是我现大妙智者。若行智成就智。彼以此二句知一切法。谓此俱摄一切法。具足一切法。是谓断计我人意现大妙智故作此论。有为法无为法者。有为法云何。答曰。十一入及一入少所入。问曰。无为法云何。答曰。一入少所入。问曰。何以故说有为法无为法。答曰。谓堕生老无常是有为。谓不堕生老无常是无为。或曰。谓兴衰法有因得有为相是有为。谓非兴衰法无因得无为相是无为。或曰。谓转世作行受果知缘是有为。谓不转世不作行不受果不知缘是无为。或曰。谓堕世是有为。谓不堕世是无为。或曰。谓堕阴是有为。谓离阴是无为。或曰。谓苦缚是有为。谓离苦是无为。或曰。谓前后可得是有为。谓前后不可得是无为。或曰。谓软中上是有为。谓离软中上是无为。尊者婆须蜜说曰。有为相云何。答曰。堕阴相是有为相。重说曰。堕世相是有为相。重说曰。灾患相是有为相。无为相云何。答曰。不堕阴相是无为相。重说曰。不堕世相是无为相。重说曰。不灾患相是无为相。重说曰。不忧戚相是无为相。重说曰。不愁无尘安隐相是无为相。广说有为无为法处尽

    鞞婆沙三世处第二十七

过去法者当来法者现在法者。问曰。何以故作此论。答曰。断他意故。谓不欲令有过去未来。于世有愚说现在无为。断彼意故。此过去未来真实说有种相。问曰。若过去未来非种者当有何咎。答曰。若彼非种者。不应缘彼有意生。何以故。谓意无境界。若无境界生意者。是则无所依而生意。若无所依无所缘而生意者。应阿罗汉入无余涅槃已还生意。何以故。谓彼无依无缘而生意。若彼生意者。是则无脱无离不得出要。莫言有咎。是故有过去未来真实有种有相。复次若无过去未来者当有何咎。答曰。若彼非种者。不应有成就不成就。如二头三手六阴十三入无成就不成就。如是若过去未来非种者。彼应无成就不成就。若彼成就不成就。是故以此可知有过去未来真实有种有相。谓彼欲令过去未来非种者。应当尔诘。若尔时因现在。彼时果何所在。过去耶未来耶现在耶。若说有过去者。是则有过去。莫言无过去。若言无过去者。此事不然。若说未来者。是则有未来。莫言无未来。若言无未来者。此事不然。若说有现在。是则一时有因有果。若一时有因有果者。如世尊所说偈

  作恶不即受　　如萨阇乳酪
  罪恶烧所追　　如灰覆火上

与此偈相违彼作恶不即受。如萨阇乳酪者。有说者。有草名萨阇。若末着乳中已即时成酪。作恶不如是即受。问曰。若不尔者云何。答曰。罪恶烧所追。如灰覆火上者。如以灰覆火初下足冷谓足下转转下便烧。如是众生生死作恶行而乐中转。舍身已生恶趣受恶果报。若非过法未来现在者。是故应无果。若无果者是故彼因不实。如二头三手六阴十三入。或有常如无为。若尔时果现在。彼时因何所在。过去耶未来耶现在耶。若说有过去者。是则有过去。莫言无过去。若言无过去者。此事不然。若说未来者。是则有未来。莫言无未来。若言无未来者。此事不然。若说有现在者。是则一时有因有果。若一时有因果者。如世尊所说偈

  作恶不即受　　如萨阇乳酪
  罪恶烧所追　　如灰覆火上

与此偈相违彼作恶不即受。如萨阇乳酪者。有说者。有草名萨阇。若末着乳中已即时成酪。作恶不如是即受。问曰。若不尔者云何。答曰。罪恶烧所追。如灰覆火上者。如以灰覆火初下足冷谓足下转转下便烧。如是众生生死作恶行而乐中转。舍身已生恶趣受恶果报。若非过去未来现在者。是故应无因。若无因者是故彼果不实。如二头三手六阴十三入。或有常如无为。或曰。若过去未来非种者。是则无有学道。如尊者婆须蜜所说偈

  若无去来　　是则无师　　谓无师者
  终无学道

或曰。若过去未来非种者。是则知已虚妄。如佛所说偈

  言无过去　　说有年岁　　岂非是常
  知已妄语

彼是无智果痴果闇果不勤果。谓欲令过去未来非种。但过去未来真实有种有相。是谓断他意现己意说如等法故作此论。莫令断他意。亦莫现己意。但说如等法。故作此论。过去法未来法现在法。问曰。过去法云何。答曰。过去十八界十二入五阴。未来法云何。答曰。未来十八界十二入五阴。现在法云何。答曰。现在十八界十二入五阴。问曰。若此行无来去无住。若来者是则来不应去。若去者是则去不应来。如尊者婆须蜜所说偈

  行终不来　　斯由空故　　亦无有去
  终则不住

若行无去来云何立三世。答曰。因行故立三世。如彼法未作行是说未来。若作行是说现在。若作行已灭是说过去。如眼未见色是说未来。若见是说现在。若见已灭是说过去。如是至意。若未来种是说未来。若现在种是说现在。若种已灭是说过去。如未生不去是说未来。如生未去是说现在。如生已去是说过去。如未生不没是说未来。如生未没是说现在。如生已没是说过去。如未生不坏是说未来。如生未坏是说现在。如生已坏是说过去。如未起不去是说未来。如起未去是说现在。如起已去是说过去。如未起不没是说未来。如起未没是说现在。如起已没是说过去。如未起不坏是说未来。如起未坏是说现在。如起已坏是说过去。因此可知一切如所说。比丘。有生真实有作有为思缘起尽法衰法无欲法灭法坏法。此不坏者。无有是处。彼有生者即是生。真实者谛有是。有作者有为是。有为者灾患是。思者因思念是。缘起者因缘是。尽法衰法无欲法灭法坏者要当有是。此不坏者终不自在。或曰。谓三世前是说过去。谓三世后是说未来。谓三世中是说现在。或曰。谓三世果是说未来。谓二世果是说现在。谓一世果是说过去。或曰。谓三世因是说过去。谓二世因是说现在。谓一世因是说未来。问曰。如此二世一损可知。二增可知。一损可知者未来是。二增可知者过去是。何以故。未来不减过去不满。尊者婆须蜜说曰。颇有数尔所过去。未来为不数。而作是念。增减可知耶。但过去未来无量故增减不可知。如大海以百千瓶器取彼水增减不可知。如是过去未来无量故增减不可知。重说曰。当来未生故减不可知。过去增故满不可知。重说曰。当来未起故减不可知。过去没故满不可知。尊者昙摩多罗说曰。诸尊若世有二种者。应有增减。可知但因事合会故法生而灭。问曰。为未起而起耶。为已起而起耶。若未起而起者。何得法不未有法而有。若已起者。何得法不转还有。作此论已。答曰。因事故已起而起。因事故未起而起。因事故已起而起者。谓一切法各自有种性相住。因事故未起而起者。谓未来中起一切未来是未起。问曰。为所有起彼即灭耶。为所有起更余灭耶。若所有起彼即灭者。为未来起即未来灭耶。若所有起更余灭者。为色起痛灭耶。为至行起识灭耶。作此论已。答曰。因事故谓所有起即灭。因事故所有起更余灭。因事故谓所有起即灭者。谓色起色灭痛想行识起识灭。因事故所有起更余灭者。谓未来起现在灭。阴故所有起即灭。世故所有起更余灭。问曰。为世起耶。为世中起耶。若世起者。何得不有余世余行。若世中起者。应有舍有。作此论已。答曰。因事故世起。因事故世中起。因事故世起者。谓时起彼即是世。因事故世中起者。谓未来世中起彼当来世空。问曰。为已性中起耶为他性中起耶。若已性中起者。何得性非有性。亦不有性而有性。若他性中起者。应有舍有作此论已。答曰。非已性中起。亦非他性中起。问曰。若非已性中起亦非他性中起者。此云何。答曰。彼法已性起已即灭。问曰。彼过去未来为合聚如今现在屋舍房室墙壁树木耶。为离散耶。若合聚如今现在屋舍房室墙壁树木者。檀越施法何得不空。何得不有方处可见。何得不有常存。若过去未来离散不如现在合聚者。云何说过去。如是彼有过去世时。有拘舍婆提王城名善法讲堂。王名善见。云何说当来。如是彼有当来世时鸡头末王城。王名蠰伽。佛名慈氏如来至真等正觉。过去境界宿命智云何立。未来境界妙愿智云何立。又未来离散者。尔时彼法从未来世至现在世。何得不合时无而有离散时有而无。作此论已。有一说者。彼过去未来合聚。如今现在屋舍房室墙壁树木。问曰。若尔者。檀越施法何得不空。答曰。显示故不空也。问曰。何得不有方处。答曰。有方处。问曰。何故不见。答曰。不多作行故不见。若多行者便见。问曰。何得不有常存。答曰。时变不停故不常存。更有说者。彼过去未来离散现在者一合聚。问曰。若过去未来离散者。云何说有过去。如是彼有过去世时。有拘舍婆提王城名善法讲堂。王名善见。答曰。如前现在时有观而说。问曰。云何说当来。如是彼有当来世时鸡头末王城。王名蠰伽。佛名慈氏如来至真等正觉。答曰。彼亦如后现在时有观而说。问曰。过去境界宿命智云何立。答曰。彼亦如前现在时有观而说。问曰。未来境界妙愿智云何立。答曰。彼亦如后现在时有观而说。问曰。若未来离散者。尔时彼法从未来世至现在世。何得不合时无而有离散时有而无。答曰。谓一切法已性种相住也。此说有四种萨婆多。一者事异。二者相异。三者时异。四者异异。事异者说。彼法与世随转时事。便有异非种异。如乳成酪变时味有异色不异。如是彼法从当来世至现在世。彼舍当来事不舍种。从现在世至过去世。彼舍现在事不舍种。相异者说。彼法世随转时过去时。成就过去相。非不成就未来现在相。当来时成就当来相。非不成就过去现在相。现在时成就现在相。非不成就过去未来相。如人染着一女。余者非不染着。此亦如是。时异者说。彼法与世随转时随时得名。时故非种故。如算子初下位一转十至百千。彼一算子随转时得名。如一女人亦名为女亦名为妇亦名为母亦名为大母。彼一女人随时得名。如是彼法随时得名。时故非种故。说曰。此最不乱施设世。此因行立三世。如彼法未作行是说未来。若作行是说现在。如作行已灭是说过去。是故此最不乱施设世。异异者说。彼法随世转时说异异。非时故非种故说者。此最乱施设世。此说者未来一时。现在世二。现在一时。过去二。此一世中施设三世。此最乱施设世。广说三世处尽

    鞞婆沙善不善无记处第二十八

善法者不善法者无记法者。问曰。善法云何。答曰。善五阴及数缘尽。不善法云何。答曰。不善五阴。无记法云何。答曰。无记五阴及虚空非数缘尽。问曰。何以故说善法不善法无记法。答曰。谓生善趣彼是善。谓生不善处是不善。谓不生善处亦不生不善处是无记。或曰。谓善有芽及解脱芽转成。谓不善有芽转成是不善。谓亦非善非不善有芽转成是无记。或曰。谓善果及乐痛果是善。谓不善果及苦痛果是不善。谓非善果亦非乐果。非不善果亦非苦果。是无记。或曰。四事故说是善。一者性。二者相应。三者等起。四者第一义。性者。或有说。惭愧性是善。或有说。三善根性是善。相应者。谓彼相应心数法。等起者。谓等起身行口行。第一义者。涅槃安隐义故说善。尊者跋[跳-兆+荼]亦尔说

  善性是智　　相应识俱　　起身口行
  涅槃第一

四事故。说不善性相应等起第一义性者。或有说。无惭无愧性是不善。或有说。三不善根性是不善。相应者。谓彼相应心心数法。等起者。谓彼等起身行口行。第一义者。一切生死不安隐故说不善。尊者跋[跳-兆+茶]亦尔说

  不善性智　　相应识俱　　起身口行
  生死第一

余者无记。尊者瞿沙说曰。谓法正思惟性。正思惟相应。正思惟等起。正思惟所依果报果是善。谓法非正思惟性。非正思惟相应。非正思惟等起。非正思惟所依果报果是不善。余者无记。或曰谓惭愧性。惭愧相应惭愧等起。惭愧所依果报果是善。谓法无惭无愧性。无惭无愧相应。无惭无愧等起。无惭无愧所依果报果是不善。余者无记。或曰。谓法三善根性。三善根相应。三善根等起。三善根所依果报果是善。谓法三不善根性。三不善根相应。三不善根等起。三不善根所依果报果是不善。余者无记。或曰。谓法五根性。五根相应。五根等起。五根所依果报果是善。谓法五盖性。五盖相应。五盖等起。五盖所依果报果是不善。余者无记。彼施设亦说善者。何以故善。答曰。善果爱果意乐果意欲果。以是故善。已说果。今当说报。复次善报爱报意乐报意欲报。以是故善。不善者。何以故不善。答曰。不善果不爱果意不乐果意不欲果是不善。已说果。今当说报。复次不善报不爱报不意乐报不意欲报是不善。余者无记。问曰。何以故说无记。如佛世尊。此苦一向记。此习尽道一向记。复次尔所一切谓十二入。佛亦一向记。一向分别。一向施设。一向显示此。何以故说无记。答曰。不以不说故名为无记。问曰。若不尔者此云何。答曰。善者记于善。不善者记于不善。此无记者不记善亦不记不善是无记。或曰。善者二事故记性及果。不善亦二事故记性及果。此无记虽性记非果记。以是故无记。或曰。善者生善趣。不善者生恶趣。此无记者不生善趣亦不生恶趣。或曰。善者受善报。不善者受不善报。此无记者不受善报亦不受不善报。以是故说无记。说曰。或复不说故名无记。如彼契经。梵志至世尊所。到已而问。瞿昙。世是常耶为非常耶。世尊告曰。梵志此是无记。云何瞿昙。世有边耶为无边耶。世尊告曰。梵志。此是无记。云何瞿昙。是命是身耶。为命异身异耶。世尊告曰。梵志。此是无记。云何瞿昙。如来终耶如来不终耶。如来终不终耶。如来亦不终亦不不终耶。世尊告曰。梵志。此是无记。如说。云何瞿昙。世是常耶为非常耶。世尊告曰。梵志。此是无记。问曰。何以故不说。答曰。断异学意故异学至世尊所而问。云何瞿昙。人是常耶人非常耶。世尊作是念。我若说无人者。彼当言我不问此有以无。我若说常无常者而无有人。何得有常无常。如有问人。士夫石女儿有恭敬耶。善言耶。彼人作是念。我若作是说。石女无有儿。彼当言我不问女有儿无儿。我若说有恭敬有善言。而石女无有儿。何得有恭敬善言。如是异学至世尊所而问。云何瞿昙。人是常为非常耶。世尊作是念。我若言有人。彼当言我不问有无。我若言常无常。而无有人。何得有常无常。此是不实问非实论。非真谛问。非真谛论。是谓不实不真谛故世尊不记。如说如说云何瞿昙。世有边耶世无边耶。是命耶是身耶。为命异身异耶。世尊告曰。梵志。此是无记。问曰。何以故世尊不记。答曰。断异学意故。异学至世尊所而问。是命耶是身耶为命异身异耶。世尊作是念。我若说有身无有命。彼当言我不问此有无。我若言命异身异而有身无有命。何得身异命异。如有人问。云何士夫牛角兔角相似不。彼人作是念。我若言牛有角兔无角。彼当言我不问此谁有谁无我若言等相似。而牛有角兔无角。何得等相似。如是异学至世尊所而问。是命耶是身耶为命异身异耶。世尊作是念。我若言有身无有命。彼当言我不问此有无。我若言命异身异。而有身无有命。何得身异命异。此是实问不实问。实论非实论。真谛问不真谛问。真谛论非真谛论。是谓实不实真谛不真谛故世尊不记。如说。云何瞿昙。如来终耶如来不终耶

如来终不终耶如来亦不终亦不不终耶。世尊告曰。梵志。此是无记。问曰。世尊何以故不记。答曰。断异学意故。异学者欲令法无有而有。彼异学至世尊所而问。云何瞿昙。此人无有而有耶。为有而有耶。何此而无有而有。如是有而无耶。为有而有。为有已常耶。世尊作是念。无有此无有而有。此亦无有有已而有常。此是不实问不实论。非真谛问。非真谛论。是谓不实不真谛故世尊不记。此是不说故谓之无记。谓佛说谓佛演说佛分别施设显示。说曰。此说四论记。一者一向记论。二者分别记论。三者诘问记论。四者止记论。一向记论者。若有作是问。如来至真无所著等正觉耶。世尊善说法耶。如来弟子善向耶。一切行无常一切法无我涅槃息灭耶。此当为一向记。是谓一向记论。何以故一向记论。答曰。此论趣义趣法趣智趣等觉趣涅槃。是故一向记论。分别记论者。若作是问。法过去耶。当为彼分别记。何以故。答曰。过去法者。或善或不善或无记。或欲界系或色界系或无色界系。或学或无学。或非学非无学。或见断或思惟断或不断。是谓分别记论。诘问记论者。若作是问。法过去耶。当还诘彼贤士问何法。何以故。过去法者。或善或不善或无记。或欲界系或色界系或无色界系。或学或无学或非学非无学。或见断或思惟断或不断。是谓诘问记论。问曰。分别记论诘问记论何差别。答曰。正无差别。问差降故便有差别。问者二种。或有欲知而问。或有触娆而问。欲知而问者。彼若言为我说法。当语彼多有法。或过去未来现在。我当为说何者。若言为我说过去。当语彼过去法亦多。或有色阴至识阴。我当为说何者。若言为我说色。当语彼色亦多。或善或不善或无记。我当为说何者。若言为我说善色。当语彼善色亦多。或离于杀至不知时言。我当为说何者。若言为我说离杀。当语彼离杀亦多。或不贪生或不恚生或不痴生。我当为说何者。若言为我说不贪生。当语彼不贪生亦多。或有教或无教。我当为说何者。谓彼欲知而问。为彼法性分别开示善记令彼知。有触娆而问者。彼若言为我说法。当语彼多有法。当为说何者。不应语彼或过去未来现在。若言为我说过去。当语彼过去法亦多。我当为说何者。不应语彼或有色阴至识阴。若言为我说色。当语彼色亦多。我当为说何者。不应语彼或善或不善或无记。若言为我说善。当语彼善色亦多。我当为说何者。不应为彼说或离于杀至不知时言。若言为我说离杀。当语彼离杀亦多。我当为说何者。不应语彼或不贪生或不恚生或不痴生。若言为我说不贪生。当语彼不贪生亦多。我当为说何者。不应语彼或有教或无教。谓彼触娆问应当尔令彼或自答或默然住。是谓答故无差别。问差降故便有差别。止记论者。若作是问。云何瞿昙。世是常耶世无常耶。世尊告曰。梵志。此是无记。云何瞿昙。世有边耶世无边耶。是命是身耶。命异身异耶。如来终耶如来不终耶如来终不终耶。如来亦不终亦不不终耶。世尊告曰。梵志。此是无记。是谓止记论。何以故止记论。答曰。此论不趣义不趣法不趣智不趣等觉不趣涅槃。是故止记论。问曰。云何此论名记论。谓此中不答一句。答曰。此是如等法第一义。答谓默然是。问曰。何以故。答曰。谓默然伏于彼。何况记而不伏。说者有异学名伤坻罗。为论故至罽宾。彼时足昼林有阿罗汉尊者跋修罗。得三明三藏六通。离三界结。于内外法尽学知。彼伤坻罗闻此林中有如此大论师。彼作是念。当往而问。彼到已共尊者跋修罗。相慰劳已却坐一面。却坐一面已。语尊者跋修罗。比丘。我等谁当先立论。我耶汝耶。尊者跋修罗曰。我是主人我应先立论。然汝是客令汝先立论。彼便先立论。说曰。一切论当有诘论。尊者跋修罗默然住。伤坻罗弟子便举声言。伏沙门伏沙门。尊者跋修罗说曰。伤坻罗还去。汝伤坻罗者自当知。彼时伤坻罗便还去不远作是念。不知彼沙门何所说。伤坻罗还去。汝伤坻罗者自当知。伤坻罗复作是念。我立此论一切论当有诘论。我此论有咎有诤有过。彼沙门若作是论。彼亦有此咎。彼伤坻罗告弟子曰。彼沙门得我便来。当共往礼彼沙门。弟子对曰。师众中得胜。何用礼彼沙门为。伤坻罗曰。宁从智者伏。不从愚者胜。彼伤坻罗便还至尊者跋修罗所。举身投地已。说曰。汝为我师。我为弟子。汝得胜。我不如。是谓或应默然而成论。况复记说而不成论。是故说如等法第一义。答谓默然。是广说善不善无记处尽

    鞞婆沙欲界色界无色界系法处第二十九

欲界系法者。色界系法者。无色界系法者。问曰。欲界系法云何。答曰。欲界系五阴。色界系法云何。答曰。色界系五阴。无色界系法云何。答曰。无色界系四阴。问曰。何以故说欲界系法。何以故说色无色界系法。答曰。因欲系足。是故说欲界系。因色系足。是故说色界系。因无色系足。是故说无色界系。足者结也。如所说偈

  若已尽不生　　已尽不将随
  彼佛无量行　　无迹何迹将
  若丛深枝洒　　无爱可将随
  彼佛无量行　　无迹何迹将

如有足者。彼能趣东西南北。如是若有结足者。彼便趣诸界趣诸趣趣诸生趣轮转生死中。是故说因欲界系足是欲界系。因色无色界系足是色无色界系。或曰。因欲系缚。是故说欲界系。因色系缚。是故说色界系。因无色系缚。是故说无色界系。如系人在坚柱坚杙。彼因坚柱坚杙说是缚。如是因欲系缚是故说欲界系。因色系缚是故说色界系。因无色系缚是故说无色界系。或曰。谓有欲乐是欲界系。谓有欲乐是色界系。谓有欲乐是无色界系。欲者爱乐者见。或曰。谓欲界着所著惜所惜已所已是欲界系。谓色界着所著惜所惜已所已是色界系。谓无色界着所著惜所惜已所已是无色界系。或曰。谓欲界垢杂垢污杂污毒杂毒是欲界系。谓色界垢杂垢污杂污毒杂毒是色界系。谓无色界垢杂垢污杂污毒杂毒是无色界系。广说欲界色无色界系法处尽

    鞞婆沙学无学非学非无学法处第三十

学法者无学法者非学非无学法者。问曰。学法云何。答曰。学五阴。无学法云何。答曰。无学五阴。非学非无学法云何。答曰。有漏五阴及无为。问曰。何以故说学无学非学非无学。答曰。谓不贪道学断贪是学。谓不贪道不学断贪是无学。余者非学非无学。或曰。谓不恚道学断恚是学。谓不恚道不学断恚是无学。余者非学非无学。或曰。谓不痴道学断痴是学。谓不痴道不学断痴是无学。余者非学非无学。或曰。谓道学断爱非爱本是学。谓道学断爱者。以此别无学。道非爱本者以此别世俗道。谓道不学断爱亦非爱本是无学。谓道不学断爱者以此别学。道亦非爱本者以此别世俗道。余者非学非无学。或曰。谓不离爱意中无漏法可得是学。谓离爱意中无漏法可得是无学。余者非学。非无学。或曰。谓结得缚意中无漏法可得是学。谓结得不缚意中无漏法可得是无学。余者非学非无学。或曰。谓摄见地思惟地是学。谓摄无学地是无学。余者非学非无学。或曰。谓摄见道思惟道是学。谓摄无学道是无学。余者非学非无学。或曰。谓摄未知根已知根是学。谓摄无知根是无学。余者非学非无学。或曰。谓五人坚信坚法信解脱见到身证意中无漏法可得是学。谓二人慧解脱俱解脱意中无漏法可得是无学。余者非学非无学。或曰。谓七人四向三果意中无漏法可得是学。谓一人意中无漏法可得是无学。余者非学非无学。或曰。十八人意中无漏法可得是学。谓九人意中无漏法可得是无学。余者非学非无学。广说学无学非学非无学处尽

    鞞婆沙见断思惟断不断法处第三十一

见断法者思惟断法者不断法者。问曰。见断法云何。答曰。谓坚信坚法观时忍断。此云何。见断八十八使及彼相应法。是谓见断法。思惟断法云何。谓学见迹思惟断。此云何。思惟断十使及彼相应法。是谓思惟断法。不断法云何。答曰。虚空不数缘尽数缘尽学法无学法。是谓不断法。问曰。何以故说见断思惟断。如见不离思惟。思惟不离见。见者是慧。思惟者是不放逸。何者真实。答曰。此中说真实。少见道者慧多不放逸。少思惟道者不放逸多慧少。是故说此中真实少。更有说者。此中说等真实。见道者所有慧亦与不放逸等。思惟道者所有不放逸而与慧等。是故说此中等真实。见断法者思惟断法者。尊者婆须蜜说曰。如见四圣谛时断一切结。何以故说见断法思惟断法。答曰。以见断以见除以见舍。是故说见断。复有作是说。亦思惟断亦见断。但以见断以见除以见舍。是故说见断。何以故说思惟断者。答曰。彼即以道修习多修习。数数断少少断品品断稍稍断渐渐断令薄。是故说思惟断。复有作是说。见断亦思惟断。但彼即以道修习多修习。数数断少少断品品断稍稍断渐渐断令薄。是故说思惟断。何所说。答曰。彼作是说。见道是利道。彼始起以一种慧断九种结。思惟道是钝道彼数数行。以九种慧断九种结。如二刀截一处。一利二钝利者始下便断。钝者数数下乃断。如是见道是利道。彼始起以一种慧断九种结。思惟道是钝道。彼数数行以九种慧断九种结。更有说者。见道亦九种慧断九种结。思惟道亦九种慧断九种结。如多中毒谁不欲一时吐。问曰。若尔有何得见道是利道。答曰。所以见道是利道者。如思惟道以九种慧断九种结。如是见道亦以九种慧断九种结。但速于彼。是故说见道是利道。如是说者此不论。如前说如见道以一种慧断九种结。思惟道以九种慧断九种结。或曰。谓道多见断结。是谓见断。谓道思惟多断结。是思惟断。或曰。谓道三相。眼明慧相断结是见断。谓道四相。眼明智慧相断结是思惟断。或曰。谓道四相。眼明觉慧相断结是见断。谓道五相。眼明觉智慧相断结是思惟断。或曰。谓忍断结是见断。谓智断结是思惟断。或曰。谓未知根断结是见断。谓已知根断结是思惟断。或曰。谓断结如方便破石是见断。谓断结如方便挽藕丝是思惟断。或曰。未见谛见谛时断结是见断。谓已见谛见谛时断结是思惟断。或曰。谓大力断结如摩呵能伽是见断。谓断结如履坏器上是思惟断。或曰。谓断结时修异智修异知修异行是见断。谓断结时修不异智修不异知修不异行是思惟断。或曰。谓向不成就果断结是见断。谓向成就果断结是思惟断。或曰。谓非稍稍断是见断。谓稍稍断结是思惟断。或曰。谓坚信坚法断结是见断。谓信解脱见断。身证断结是思惟断。或曰。谓始起道断结是见断。谓数数起道断结是思惟断。或曰。谓断结摄四沙门果是见断。谓断结或摄三果或二或一是思惟断。或曰。谓道断结不替是见断。谓道断结或替不替是思惟断。或曰。谓已断结不退是见断。谓已断结或退或不退是思惟断。或曰。谓已解脱不复缚是见断。谓已解脱或缚或不缚是思惟断。或曰。谓已离不系是见断。谓已离或系或不系是思惟断。或曰。谓断结时忍无碍道智解脱道是见断。谓断结时智无碍道智解脱道是思惟断。或曰。谓断结时忍方便道忍无碍道智解脱道是见断。谓断结时智方便道智无碍道智解脱道是思惟断。或曰。谓断结时四行修道是见断。谓断结时十六行修道是思惟断。或曰。谓断结时缘一一谛修道是见断。谓断结时缘四谛修道是思惟断。或曰。谓断结时一相似修道是见断谓断结时相似不相似修道是思惟断。或曰。谓断结时修一三昧是见断。谓断结时修三三昧是思惟断。或曰。谓断结时不住是见断。谓断结时或住不住是思惟断。余者无断。广说见断思惟断无断处尽

鞞婆沙论卷第七鞞婆沙论卷第八

        阿罗汉尸陀槃尼撰

        符秦罽宾三藏僧伽跋澄译

    四圣谛处第三十二之一

四谛者。苦谛习谛尽谛道谛。问曰。四谛有何性。阿毗昙者说曰。五盛阴是苦谛。有漏因是习谛。数缘灭是尽谛。学无学法是道谛。譬喻者说曰。名及色是苦谛。行及结是习谛。行及结灭是尽谛。止及观是道谛。鞞婆阇婆提说曰。八苦相是苦是苦谛。余苦虽苦非苦谛。当来有爱是习是习谛。余爱及余有漏法。虽习非习谛。当来有爱灭是尽是尽谛。余爱及余有漏法灭虽尽非尽谛。学八种道是道是道谛。余学法及一切无学法虽道非道谛。问曰。如汝说阿罗汉应不成就二谛。习谛及道谛。不成就习谛者。谓彼当来有爱是习谛。彼阿罗汉除欲时当来有爱尽也。不成就道谛者。谓彼学八种道是道谛。彼阿罗汉得果时舍学八种道。尊者瞿沙说曰。己阴及他阴。众生数非众生数。彼一切苦是苦是苦谛。但观时观己阴。不观他阴众生数非众生数

问曰。何以故尔。答曰。谓彼观是苦此他阴众生数非众生数不能生苦无命。此他阴众生数非众生数。于此己阴生苦。若无此己阴者。彼他阴众生数非众生数当生何苦。以是故。彼作此智。生经中设数己阴极生苦。他阴不如此。因己阴他阴生苦。不因他阴己阴生苦。以是故观己阴不观余。谓己阴因及他阴众生数非众生数。彼一切习是习谛。但观时观已阴因。不观他阴众生数非众生数。谓己阴尽。及他阴众生数非众生数尽。彼一切是尽是尽谛。但观时观己阴尽。不观他阴众生数非众生数尽。谓己阴道及他阴众生数非众生数道。彼一切是道是道谛。但观时观己阴道。不观他阴众生数非众生数道。如是说者。谓己阴及他阴。众生数非众生数。彼一切是苦是苦谛。观时亦尽观

问曰。如彼观时观苦。彼他阴众生数非众生数不生苦当何观。答曰。设不生苦。但彼一切有无智欲令生智。有疑欲令生定。有谤欲令生信。复次何得他阴众生数非众生数不生我苦。若他以手以足打我者。我宁不生苦耶。如是若于上若木若石堕我上者。我宁不生苦耶。以是故谓己阴及他阴众生数非众生数彼一切是苦。是苦谛观时尽观苦相故。谓己阴因及他阴。众生数非众生数因彼一切是习。是习谛观时尽观本末故。谓己阴尽及他阴。众生数非众生数尽彼一切是尽。是尽谛观时尽观止相故。谓己阴道及他阴。众生数非众生数道彼一切是道。是道谛观时尽观出要相故。此是诸谛性。已种相所有自然。说性已当说行。何以故说谛。谛有何义。答曰。实义是谛义。审义如义不颠倒义不虚义是谛义。问曰。若实义是谛义者。虚空非数缘尽亦实亦审。亦如彼何以故不立谛。答曰。谓法痈痈因离痈能离痈。痈者是苦谛。痈因者是习谛。离痈者是尽谛。能离痈者是道谛。彼立谛。彼虚空非数缘尽非痈非痈因非离痈非能离痈。是故彼不立谛。或曰。谓法刺刺因离刺能离刺。刺者是苦谛。刺因者是习谛。离刺者是尽谛。能离刺者是道谛。彼立谛。彼虚空非数缘尽非刺非刺因非离刺非能离刺。是故彼不立谛。或曰。谓法病病因离病能离病。病是苦谛。病因是习谛。离病是尽谛。能离病是道谛。彼立谛。彼虚空非数缘尽非病非病因非离病非能离病。是故彼不立谛。或曰。谓法灾患灾患因离灾患能离灾患。灾患者是苦谛。灾患因者是习谛。离灾患者是尽谛。能离灾患者是道谛。彼立谛。彼虚空非数缘尽非灾患非灾患因非离灾患非能离灾患。是故彼不立谛。或曰。谓法苦苦因离苦能离苦。苦者是苦谛。苦因者是习谛。离苦者是尽谛。能离苦者是道谛。彼立谛。彼虚空非数缘尽非苦非苦因非离苦非能离苦。是故彼不立谛。或曰。谓法阴阴因离阴能离阴。阴者是苦谛。阴因者是习谛。离阴者是尽谛。能离阴者是道谛。彼立谛。彼虚空非数缘尽非阴非阴因非离阴非能离阴。是故彼不立谛。或曰。谓此岸彼岸河筏。此岸者是苦谛。彼岸者是尽谛。河者是习谛。筏者是道谛。彼立谛。彼虚空非数缘尽非此岸非彼岸非河非筏。是故彼不立谛。或曰。彼虚空非数缘尽。无漏故不摄苦谛习谛。无记故不摄尽谛。无为故不摄道谛。或曰。彼虚空非数缘尽。常故非三谛。无记故非尽谛。或曰。彼虚空非数缘尽。非阴故非三谛。无记故非尽谛。或曰。彼虚空非数缘尽。非世故非三谛。无记故非尽谛。或曰。谓法喜处缘及厌处缘。彼立谛。彼虚空非数缘尽非喜处缘亦非厌处缘。以是不立谛。或曰。谓法邪见及无漏见缘是立谛。彼虚空非数缘尽非邪见亦非无漏见缘。是故彼不立谛。或曰。谓法是因是果彼立谛。彼虚空非数缘尽非是因非是果。是故彼不立谛

问曰。若不颠倒义是谛义者。不应颠倒谛所摄。以颠倒故。答曰。行故相貌故一向颠倒住故说颠倒。如彼有审实种相。如是谛所摄。或曰。如彼有因有果。是谛所摄。如无常计常苦计乐不净计净无我计我如是说颠倒。问曰。若不虚义是谛义者。不应虚谛所摄。以虚故。答曰。奸伪欺诳一向佞谄住故说妄语。如彼有审实种相。是谛所摄。或曰。如彼有因有果是谛所摄。如不见言见见言不见。不闻言闻闻言不闻。不分别言分别分别言不分别(鼻舌身三情总名也)。不知言知知言不知。是说妄语。是谓实义是谛义。审义如义不颠倒义不虚义是谛义。问曰。苦有何相。习尽道有何相。尊者婆须蜜说曰。逼迫相是苦相。本末相是习相。止相是尽相。出要相是道相。重说曰。已转成是苦相。当转相是习相。离行相是尽相。能离行相是道相。重说曰。已成轮转生死是苦相。当轮转生死是习相。已离轮转生死是尽相。能离轮转生死是道相。尊者昙摩多罗说曰。诸尊。处所中作谛相。彼五盛阴堆阜如铁团。入三苦依在内杂如铁团着火中。火入铁同火色。观苦当如是。此苦行所转结所变易有所趣连续有。此合会有当观习谛。中起离结行不复连续有。此合会有当观是尽谛。修习止观知兴衰法有因得尽。此合会有当观道谛。是故说诸尊处所中作谛相。如世尊所说偈

  一谛无有二　　谓众生生疑
  难陀观诸谛　　我说非沙门

问曰。如四谛。何以故佛说一谛无有二。尊者波奢说曰。一一谛故。世尊说一谛无有二。一谛者是苦谛。更无二苦谛。一谛者是习谛。更无二习谛。一谛者是尽谛。更无有二尽谛。一谛者是道谛。更无有二道谛。是故世尊说一谛无有二。或曰。一谛者是尽谛。断多计解脱意故。异学欲令多有解脱无身无量意净聚无想聚世尊说彼非解非脱非出要非离。唯有一第一义解脱。谓尽谛是。是谓断多计解脱意故。世尊说一谛无二。或曰。一谛者道谛是。断多计道意故。异学欲令多有道。不食卧灰上叉手随日月服气食果裸形卧棘上着弊草衣。世尊说此非道是恶道此不可依非是人所行恶人所行。唯一第一义道。谓道谛是。是谓断多计道意故。世尊说一谛无二。如世尊所说契经。二谛等谛第一义谛。问曰。云何等谛云何第一义谛。答曰。等谛者。苦谛习谛等入此中。谓妇人男子小儿小女。若来若去若坐若住现种种行。第一义谛者。尽谛道谛。更有说者。等谛者三谛。彼尽亦说如城现如彼岸。第一义谛者是道谛。更有说者。一切四谛是等谛。亦第一义谛彼道谛。亦说如筏观如山。是故一切四谛是等谛。亦第一义谛。苦谛习谛中等如前所说。妇人男子小儿小女。若来若去若坐若住现种种行。第一义者。无常苦空非我。因习有缘尽谛中等如所说。如园观彼岸城。三耶三佛所说第一义者。尽止妙离。道谛等者如所说筏大石山。生七花成八种水。第一义者。道正趣出要。是故一切四谛中趣等亦趣第一义。问曰。若一切四谛中起等亦起第一义者。彼等应有十八界十二入五阴第一义。亦应有十八界十二入五阴。彼等谛第一义谛何差别。尊者婆须蜜说曰。等谛者是诸法名。第一义谛是诸法性。重说曰。等谛者是俗数。第一义谛者贤圣数。等谛第一义谛是谓差别。问曰。彼等于第一义中是第一义耶。为非耶。若等于第一义中是第一义者。应有一谛。是第一义谛无有二谛。若等谛于第一义中非第一义者。亦应有一谛。是第一义谛无有二谛。作此论已。答曰。有此等于第一义中是第一。若等谛于第一义中非第一义者。如来说二不是真实。若如来说二真实者。是故可知等谛于第一义中是第一义。问曰。若等谛于第一义中是第一义应有一谛。是第一义谛无有二谛。答曰。是一谛第一义谛。问曰。若是一谛第一义谛者。云何如来说二谛。答曰。因事故如来说二谛。若事是等谛。此事非第一义谛。若事第一义谛。此事非等谛。如一痛说四缘。因缘次第缘增上缘所缘缘。彼虽一痛说四缘。但若事因缘非此事乃至增上缘。若事增上缘非此事乃至因缘。如是一痛说六因。相应因共有因自然因一切遍因报因所作因。彼虽一痛说六因。但若事相应因非此事乃至所作因。若事所作因非此事乃至相应因。如是一谛第一义谛。若事等谛非此事第一义谛。若事第一义谛非此事等谛。尊者陀罗难提说曰。性名等谛。苦谛习谛所摄。如世尊契经所说。异学梵志梵志有三谛。云何为三。此异学梵志梵志作是说。不害一切众生。若异学梵志梵志作是说。不害一切众生。是谓异学梵志梵志一谛。复次异学梵志梵志作是说。我于他无所为他于我无所为。若异学梵志梵志作是说。我于他无所为他于我无所为。是谓异学梵志梵志二谛。复次异学梵志梵志作是说。诸所习法皆是尽法。若异学梵志梵志作是说。诸所习法皆是尽法。是谓异学梵志梵志三谛。问曰。此中云何说梵志云何谛。答曰。梵志者外。谛者即此三。余者尽虚妄。更有说者。梵志者此内法。谛者即此三。世尊说契经断异学意故。异学自言是梵志。常逼促他为斋故。杀牛亦杀羊鸡猪。亦杀种种众生为斋故。世尊说逼促他非梵志。谓不害一切众生。是第一义梵志。异学自言是梵志。有所为故行梵行。为天女为天食。世尊说。若有所为故行梵行非梵志。谓无所著无所爱无所为行梵行。是第一义梵志。异学自言是梵志。着断灭计常。世尊说。若着断灭计常非梵志。谓诸所习法皆是尽法。是谓第一义梵志。是谓梵志。此内法谛者即此三。佛说契经断异学意故。或曰。此中说三分法身戒身定身慧身。彼不害一切众生者是戒身。我不为他他不为我者是定身。诸所习法皆是尽法者是慧身。如三身三戒三思惟亦尔。或曰。此中说三三昧方便。空无愿无相。彼不害一切众生者。是空三昧方便。我不为他他不为我者。是无愿三昧方便。诸所有习法皆尽者。是无相三昧方便。或曰。此中说根本三三昧。空无愿无相三昧。彼不害一切众生者。是空三昧。我不为他他不为我者。是无愿三昧。诸所习法皆是尽法者。是无相三昧。以是故此中说根本三三昧。如佛契经说。此是已行正法。所谓广说四谛。问曰。何以故说已正行。答曰。谓已行者已修道行非因他修道。是谓说已正行问曰。云何知。答曰。有佛契经。契经中有头陀梵志。到世尊所而说偈言

  我观世天人　　梵志行无积
  我今礼大仙　　拔我疑网刺

问曰。此梵志何所说。答曰。彼梵志懈怠。至世尊所已。沙门瞿昙为我故修道。令我意中结尽。世尊为彼说偈

  我不能脱汝　　梵志及余世
  若知极妙道　　汝可度此流

问曰。如来何所说答曰。世尊说。梵志。不因他修道令汝结尽。若梵志。因他修道汝结尽者。我在道树下时一切众生皆应结尽。我于一切众生极有大悲。但梵志。非因他修道令汝结尽梵志。如己病服药。非他病得愈。如是梵志。己有结病服圣道药。非他结病得愈。如梵志己服乐己病愈。如是梵志己有结病。服圣道药己结病愈。以此契经可知。自行四谛非因他行。是故说己正行。或曰。不正令入正。是故说己正行。不正者凡夫是。正者圣道是。令不正凡夫使入于正道果。是故说己正行。或曰。正令入正。是故说己正行。正者世间第一法。正者苦法忍。今正世间第一法使入正苦法忍。是故说己正行。问曰。何以故圣谛说己正行。非说界入阴。答曰。谓此圣谛极上受化者亦极上。说界者为始行。说入者为少习行。说阴者为己成行。此圣谛一向近法身。谓彼近见圣谛者。或曰。谓说圣谛取证得果。除结漏尽非界入阴。以是故圣谛说己正行非界入阴。问曰。四圣谛者。云何立四圣谛为种耶。为因果耶。为观耶。若种者应有三。离苦无习离习无苦。是一谛尽二道三。若因果者应有五。如苦有因有果。是二谛道亦有因有果。是四谛尽谛五若观者应有八。前观欲界苦。后观色无色界。前观欲界行因。后观色无色界。前观欲界行尽。后观色无色界。前观欲界行道。后观色无色界。作此论已。答曰。因果故便立四谛。问曰。若尔者应有五。如苦有因有果。彼一切苦习趣道。有习趣道贪习趣道轮转生死习趣道。如是道有因有果。彼一切苦尽趣道。有尽趣道贪尽趣道轮转生死尽趣道。云何因果故立四谛。答曰。因三事。有漏无漏故因果故诽谤信故。此四圣谛二种有漏无漏。有漏者有因有果。谓有漏因彼立一谛习谛是。谓有漏有果立二谛苦谛是。无漏种者亦有因有果。谓无漏有因有果者。立一谛道谛是。谓无漏有果无因者。立二谛尽谛是。问曰。谓无漏种有因有果。何以故立一谛非二。答曰。诽谤信故此苦有二种。谤无苦无习。如此中二种谤。应当发二种信。彼道谓有因有果。彼一切同一谤无有道。如同一谤如是应当发一信。是谓因三事有漏无漏故因果故诽谤信故立四圣谛。更有说者。亦因观故立四圣谛。谓欲界苦及色无色界苦。彼一切同一观逼迫一相故。谓欲界行因。及色无色界行因。彼一切同一观本末一相故。谓欲界行尽。及色无色界行尽。彼一切同一观一止相故。谓欲界行道。及色无色界行道。彼一切同一观一出要相故。是谓同一观故立四圣谛。问曰。云何四圣谛为善根圣耶。为无漏圣耶。为圣所成就耶。若善根圣是圣谛者。便有二谛善尽谛道谛。二谛三种善不善无记。苦谛习谛是。若无漏圣是圣谛者。便有二无漏尽谛道谛。二有漏苦谛习谛。若圣所成就是圣谛者。非圣亦成就。如所说。谁成就苦谛习谛。答曰。一切众生。作此论已。答曰。圣所成就是故圣谛。问曰。如非圣亦成就。如所说。谁成就苦谛习谛。答曰。一切众生。答曰。谓成就一切四圣谛。彼是圣。非圣者虽有成就。但不成就一切四圣谛。是故不说圣。问曰。彼圣亦不成就四圣谛。谓具缚入苦法忍中。答曰。少一时项于彼上生苦法智已。成就一切四圣谛。或曰。此是圣所谛圣所知圣所见圣所了圣所观圣所觉。是故说圣谛。或曰。谓得圣戒是圣。彼圣有此谛。是故说圣谛。或曰。谓得圣财是圣。彼圣有此谛。是故说圣谛。或曰。谓圣得止观是圣。彼圣有此谛。是故说圣谛。或曰。谓得圣印是圣。彼圣有此谛。是故说圣谛。尊者僧伽婆修说曰。彼时凡人共圣人诤。凡人说此是我。圣人说此非我。凡人说此是乐。圣人说此是苦。凡人欲令无因不正因。圣人欲令有因正因。彼共诤便至世尊所。到已如此义白世尊。世尊说。如圣所说。此是圣所谛圣所知圣所见圣所了圣所观圣所觉。问曰。如汝说一切洹沙三耶三佛说圣谛。一切皆有诤耶。此者不论。如是好如前所说。圣所谛圣所知圣所见圣所了圣所观圣所觉。是故说四圣谛。云何四。苦圣谛苦习圣谛苦尽圣谛苦尽道圣谛。苦圣谛云何。生苦老苦病苦死苦怨憎会苦爱别离苦所求不得苦。略言之五盛阴苦。彼生苦者。因一切苦故。老苦者少壮变故。病苦者境界断故。死苦者大忧悲故。怨憎会苦者一切厌恶故。爱别离苦者所念相违故。所求不得苦者不从愿故。略言之五盛阴苦者众苦依故。复次生苦者起苦故。老苦者容色败故。病苦者一切不堪故。死苦者多烦恼热故。怨憎会苦者见不善故。爱别离苦者善见相违故。所求不得苦者善望意断故。略言之五盛阴苦者彼一切苦依。此转非不依。是故说略言之五盛阴苦。问曰。如五盛阴亦广苦。何以故世尊说略言之五盛阴苦。答曰。如是略亦苦广亦苦。但多苦故。世尊说略言之五盛阴苦多苦患故。如彼贼帅屏处呵责众中亦呵责。用多过故。如是五盛阴略亦苦广亦苦。但世尊说略言之五盛阴苦多苦患故。问曰。阴中有乐耶无乐耶。若阴中有乐者。何以故世尊说苦谛无说乐谛。若阴中无乐者。摩诃男契经云何通。彼所说摩诃男若色一向是苦者非乐。乐喜长养离乐。摩诃男。非是因众生着色。此众生不应着色摩诃男。若痛想行识一向是苦者非乐。乐喜长养离乐。摩诃男。非是因众生着识。此众生不应着识。摩诃男。如色非一向苦乐乐喜长养不离乐。摩诃男。是因众生着色。以是故众生着色。摩诃男。如痛想行识非一向苦乐是乐乐喜长养不离乐。摩诃男。是因众生着识。以是故众生着识。复次说三痛。乐痛苦痛不苦不乐痛。苦阴中无乐者。此二经云何通。作此论已有一说者。阴中有乐。问曰。若阴中有乐者。摩诃男契经善得通。此经云何通。何以故说苦谛不说乐谛。答曰。虽阴中有乐但少。以少故立苦分中。犹如毒瓶一渧蜜堕中不因一渧蜜故毒瓶。得名蜜瓶。但毒多故名为毒瓶非蜜瓶。如是虽阴中有乐但少。以少故立苦分中。更有说者。阴中无乐。问曰。若阴中无乐者。此经若为通。以是故说苦谛不说乐谛。摩诃男契经云何通。答曰。此说是俗数亦说圣数。如俗数者阴中可有乐。如彼行疲小息便言乐。寒小得热便言乐。热得少凉便言乐。饥少得食便言。乐渴少得饮便言乐。如圣数者如是阴中无乐。如圣观地狱中。界入阴炽然。至第一有亦尔。如是俗数阴中有乐。圣数阴中无乐。云何苦习爱习圣谛。谓此爱当来有喜欲俱爱乐彼有。问曰。如阿毗昙所说。习谛云何有漏缘。何以故佛世尊一切有漏种独当来有爱立习谛耶。答曰。此爱施设习时摄受种。是故佛一切有漏种。一当来有爱立习谛。如思施设行时摄受种。是故佛一切相应不相应行阴中。一思立行阴。如是此爱施设习时摄受种。是故佛一切有漏种。一当来有爱立习谛。或曰。谓爱过去当来现在苦说根本。如所说。此爱过去当来现在苦因根。将本作缘有习等起。或曰。谓爱数数转苦时增上主。如所说偈

  如树根不拔　　断截还复生
  不拔爱根本　　数数还受苦

谓爱数数转苦增上主以故尔。或曰。谓说爱如母。如所说偈

  爱中生士夫　　彼心驰趣向
  众生入生死　　受苦甚恐怖

谓爱说如母以故尔。或曰。谓爱男种女种生长养。谓此众生趣向东西南北。以供养父母及妻子奴婢。一切皆由爱故。如此鸟从一山谷杀虫还以养子。一切皆由爱故。谓爱男种女种生长养以故尔。或曰。谓爱众生数非众生数生长养。谓此众生畜象马驼牛驴骡猪羊奴婢。金银琉璃车磲马瑙珊瑚虎珀。谓爱众生数非众生数生长养以故尔。或曰。谓爱数数微细行。如削(音笑)刀削物不觉。如是此爱数数微细行。行时不可觉以故尔。或曰。谓爱无厌足。如人饮碱水饮已增渴。如是众生未除欲。若得境界已增益其爱。谓爱无厌足以故尔。或曰。谓难舍不可除。如人为二罗刹所持。一为母形。二为己形。谓己形者彼易防护。谓母形者不可防护。如是众生未除欲者。多为二结所持。爱及嗔恚。恚者如己形此易防护。爱者如母形不可防护。谓爱难舍不可除以故尔。或曰。谓爱说如罗刹。如罗刹见商人船坏而往问讯。善来诸贤。善来大仙人。此间园观快乐无极。宫舍可乐此多诸珍宝。种种具足尽持相与。可共我等娱乐此间。如彼各随所欲然后断其命根而食之。食彼人时若有余残发毛爪齿。尽取食之无有遗余。食彼人时血渧堕地。以指爪掴而食之。如是此爱因时和颜悦色。果时便异断慧命根。堕地狱中极受恶苦。谓爱说如罗刹以故尔。或曰。谓爱润渍相着。此爱润渍着众生不至涅槃。如蝇胶着蜜瓶。及湿牛皮力不能飞。如是此众生爱所润渍着无力至涅槃以故尔。或曰。谓此爱起生死蛊道。如有水处彼能起蛊道。如是爱起生死蛊道。以故尔。或曰。谓爱性坏散。有为能合会。如以水合会性散坏沙如是此爱性坏散。有为能合会以故尔。或曰。谓爱润渍一切生死不萎干。如水润渍一切药草树木不萎干。如是爱润渍一切生死不萎干。以故尔。或曰。谓爱润渍识种子生有萌芽。如水渍种子萌芽得生。如是爱润渍识种子生有萌芽以故尔。或曰。谓爱若意中着。彼余结皆着。如衣有腻尘垢染着。如是此爱谓意中着。彼余结皆着以故尔。或曰。谓爱若意中乐。彼余结皆乐。如有水处虾蟆鱼乐中。如是谓爱若意中乐。彼余结皆乐以故尔。或曰。谓爱受三有种名。彼初者名为爱种。广者名为受种。已灭者名为无明种。谓爱受三有种名以故尔。或曰。谓爱说如罗网说水说洒。如所说比丘。我当为说爱罗网水洒。谓此众生所缠裹阴盖覆弊以故尔。或曰。谓说不可计如所说偈

  本有斯一爱　　此爱便有二
  爱为连钩锁　　彼爱不可计

谓说爱不可计以故尔。或曰。谓爱说广如所说偈。问曰

  广无过于地　　深无能踰海
  高无出须弥　　力无胜那延

佛答偈曰

  广无过于爱　　腹为难可满
  憍慢最增上　　大士无胜佛

或曰。谓爱染污一切正受增上主。如阿毗昙所说。味相应初禅。当言入味耶。当言起味耶。答曰。若味是入已味是起。味相应乃至有想无想处。当言入味耶。当言起味耶答曰。若味是入已味是起。谓爱染污一切正受增上主以故尔。或曰。谓依爱于母胎有所依。因父母不净便有精以故尔。或曰。谓爱持去狂愚如罗刹女。如所说。伽弥尼持去者是爱。以故尔。或曰。谓爱当来有依欲令得当来身乐欲。乐欲已愿求。愿求已便转成。以故尔。或曰。谓爱界断地断种断根断。以故尔。或曰。谓爱盛一切结以故尔。或曰。谓爱为首说十法。如所说阿难。因爱求因求利因利计。挍因计挍欲因欲着因着悭不舍因悭不舍家因家守。因守故阿难便知。便知有刀杖。因有刀杖便斗诤。谀谄欺诳妾言意中便生无量不善法。以是故佛契经。一切有漏种独一当来有爱立习谛。爱尽苦尽圣谛云何。谓此爱当来有喜欲俱无余断舍吐尽无欲灭止没。问曰。如此亦习尽何以故世尊说苦尽不说习尽。答曰。应说如说苦尽习尽亦尔。若未说者是世尊有余言。此现义义门义略义度当知义。或曰。为教化者。令彼欲故。如佛说苦尽。如是受化者闻已欲得尽。彼作是念。彼尽极妙。谓离此弊恶苦。以是故佛契经说苦尽不说习尽。苦尽道圣谛云何。谓八圣道。是正见正志正语正业正命正方便正念正定。问曰。如此习尽道。何以故说苦尽道不说习尽道。答曰。应说如说苦尽道。说习尽道亦尔。若未说者。是世尊有余言。此现义义门义略义度当知义。或曰。彼习此中已说。谓离习无有苦。离苦无有习。已说苦尽道。当知已说习尽道。或曰。为教化者令彼欲故。如佛说苦尽道。如是受化者闻已欲得道。彼作是念。彼道极妙。谓能断此弊恶苦以故尔。或曰。不受苦时现道功故。彼道问其义。能令因不作因耶。能令果非果耶道义。答曰。我不能令因不作因。不能令果非果。但所因及缘生苦者。彼缘彼因要当坏。彼更不复受苦。更不复与苦相续。更不复与苦作因。是谓不受苦现道功故。以故尔。或曰。断诽谤故说苦尽道。谓七岁八岁得阿罗汉果。于彼上或百岁在生死中多受苦。世间者诽谤彼道。何所能而令彼受尔所苦。世尊说谓道所应为已为断当来苦。寿尽已更不复受苦。更不复连续苦。更不复与苦作因。是谓断诽谤故佛契经说苦尽道非说习尽道。如世尊契经说。谓无量种诸善法和合。彼一切尽摄入四圣谛。四圣谛者于彼说第一。谓摄故。诸野众生足一切尽摄入象足中。象足者于彼说第一。谓广大故。是故诸无量种善法和合。彼一切尽摄入四圣谛。四圣谛者于彼中说第一。谓摄故。问曰。设使有三圣谛有为和合。彼尽谛无为云何和合。答曰。假使不和合。但摄故名为和合。或曰。此说得故。虽彼尽谛不和合。但彼得是和合。是谓得和合故说。或曰。和合说二有和合起和合。此三谛二和合。有和合起和合。彼尽谛起和合。但有和合。是谓有和合。故如世尊契经说。慧根当何所观。四圣谛是。问曰。为摄故说。为缘故说。若摄故说者。不应慧根摄四圣谛。亦非四圣谛摄慧根。若缘故说者。是一切法缘。作此论已。答曰。非摄故说。亦非缘故说。问曰。若不尔者此云何。答曰。因事故。此慧根事。得四圣谛增上主。是故世尊说。慧根何所观四圣谛是。如信根事得四不坏信增上主。是故世尊说。信根何所观。四不坏信是。精进根事于四意断增上主。是故世尊说。精进根何所观。四意断是。念根事于四意止增上主。是故世尊说。念根何所观。四意止是。定根事于四禅增上主。是故世尊说。定根何所观。四禅是。如是此慧根于四圣谛增上主事。是世尊说。慧根何所观。四圣谛是。云何四。谓苦圣谛习尽道圣谛。问曰。如前因后果。何以故世尊前说苦后说习。答曰。此苦粗是故以前说。习细是故后说。如人前学射箕泥团草朿。然后能射着毛不僻错。如是此苦粗彼学已然后观习细。问曰。如前修道然后尽作证。何以故。世尊前说尽作证后说修道。答曰。谓观尽观道随顺。问曰。云何观尽观道随顺。答曰。彼行者前尽作证已。然后求道。当以何道得至涅槃。如人欲进路时。问他人士当示我道。彼还问欲至何所。曰我欲至某城。彼曰。此是道已知。彼城说道易。如是若前说道后说尽。便不知趣何道。如前说尽后说道。已知尽便修道易。或曰。彼行者因道前除三谛痴。然后道道缘现在前。谓除道谛痴。如人先见他面不自见面。以明净镜自照其面。如是彼行者彼因道先前除三谛痴。后道道缘现在前。谓除道谛痴。以是故世尊前说尽后说道。问曰。如前断习后知苦。何以故世尊前说知苦后说断习。答曰。欲拔苦根本故。如树前执持枝叶后断其根易。如是生死树前知苦已后断习易。以故尔。或曰。谓此观苦能来观习。观习已能来观尽。观尽已能来观道。不可以不观苦而观习尽道。或曰。谓苦慧能来习尽道慧。不可以不起苦慧能起习尽道慧。或曰。谓观苦观习尽道方便门依。不可以不起苦观能起习尽道观。或曰。谓观苦观习尽道。因根将本作缘有习等起。不可以不起苦观能起习尽道观。或曰。谓观苦习尽道生持等持增长养。不可以不起苦观能起习尽道观。或曰。谓苦痴能执持习尽道痴。不可以不除苦痴能除习尽道痴。或曰。谓苦不痴能令习尽道不痴。不可以苦不痴能令习尽道不痴。尊者波奢说曰。彼行者观五阴如痈已然后求因。此从何生。观从习生。云何令无。谓灭尽涅槃云何至。谓圣八道种。如人身中生痈极苦痛脓血流出。彼求所因此从何生。观知或风寒热。云何令无安隐处。云何至安隐。或服药吐下或破。如是彼行者观五阴如痈已后求因。此从何生。观从习生。云何令无。谓灭尽涅槃。云何至。谓八圣道种。复次行者观五阴如患已后求因此从何生。观从习生。云何令无。谓灭尽涅槃。云何至。谓八圣道种。如人有儿作贼凶暴随恶知识。后求因谁坏我儿。观从恶知识生。谁能制之。观善知识是。如是彼行者观五阴如患已后求因。此从何生。观从习生。云何令无。谓灭尽涅槃。云何至。谓八圣道种。以是故彼行者前知苦已后断习。断习已次尽作证。尽作证已后修道。以是故前说苦后说习尽道

鞞婆沙论卷第八鞞婆沙论卷第九

        阿罗汉尸陀槃尼造

        符秦罽宾三藏僧伽跋澄译

    四圣谛处第三十二之余

如世尊契经说。当知苦如阿毗昙说如以智知一切法。何以故世尊说独说知苦。答曰。观时故此说二种时。观时分别时。如观时如是佛契经说。当知苦如分别时。如是阿毗昙说以智知一切法。复次说二种随顺。观随顺分别随顺。如观随顺如是佛契经说。当知苦如分别随顺。如是阿毗昙说以智知一切法。或曰。一向无漏知。故佛契经说。当知苦有漏无漏知故。阿毗昙说以智知一切法。如有漏无漏。如是诤不诤世间出世间。住依欲出一要如是尽当知。或曰。知俗数故此说二种知。知俗数知第一义数。如知俗数。如是佛契经说。当知苦如知第一义数。如是阿毗昙说以智知一切法。云何知俗数。当知苦果是。当断习者除一切结是。是谓俗数。云何第一义数。谓一切德是离一切结尽作证。能除一切世间根本是修道。尊者婆奢说曰。如世尊说。当知苦如阿毗昙说以智知一切法。何以故世尊说当知苦。答曰。断生死根故。世尊说当知苦。身见是六十二见根。六十二见是结根。结是行根。行是报根。依报在一切生死。依报已依报生死中便有善法不善法无记法。此生死根从何断。唯知苦是。谓断生死根故。世尊说当知苦。或曰。谓行者知苦心不错乱。若彼行者知苦已。未断习而起者。起已若问此阴常耶非常耶。彼说无常一时顷不住。乐耶苦耶。彼说苦如热铁丸。净耶不净耶彼说不净如粪。此中为有我耶为非有我耶。彼说非众生非命非人非士。内空无作无教作。无觉无教觉。行聚空净。谓行者知苦心不错乱。以是故世尊说。当知苦。或曰。断阴着故。世尊说当知苦本际不可知。如此众生因阴受无量苦。于阴中痴还于阴爱着吝惜。如彼小儿父母与杖还抱父母。如是本际不可知。如此众生因阴受无量苦。于阴中痴还于阴爱着吝惜。世尊说欲令不用阴当知苦。知苦已于阴中不复着。是谓断阴着。故世尊说当知苦。或曰。本际不可知。如此众生于阴计我想计众生想计聚想计人想计士想计命想。此计我想计众生想计聚想计人想计士想计命想。从何除始入不颠倒法想。唯有知苦。以是故佛世尊说当知苦。或曰。本际不可知。谓此众生于阴计有常想乐想净想我想。此计常想乐想净想我想。从何除始入不颠倒法想。唯知苦以是断颠倒故。世尊说当知苦。或曰。谓行者知苦已。义入佛法中。法入佛法中。第一义入佛法中。于法得无阂自在以故尔。或曰。谓彼行者知苦已不从余师。于此外不求福田以故尔。或曰。谓彼行者知苦已住佛法中。如幢深入地以故尔。或曰。谓行者知苦已除曾所行缘。得未曾行缘。舍同行已得不同行。舍共行已得不共行。舍世行已得出世行以故尔。或曰。谓彼行者知苦已。舍名得名舍境得境舍性得性以故尔。或曰。谓彼行者知苦已。除五人种类得八人种类以故尔。或曰。谓彼行者知苦已。无量时恶行邪见颠倒乱心心数法。何从令住质直。唯知苦以故尔。或曰。谓此苦性如火烧。性如毒害。性如刀割。性如弶杀。如边境贼城。为行结所侵。以是故世尊说。知苦当断习者。如苦亦当断。何以故世尊说断习。说者谓欲令一当来爱习谛者如前答爱。此中尽当答。谓欲令苦亦断非独断习。谓前答当知苦。此中尽当答。彼二论中此论当答。何以故世尊说当断习。答曰。谓因断果亦断。因离果亦离。因舍果亦舍。以是故世尊说当断习或曰。谓断习时二。因俱拔二因俱系。便有离散。有想无想处一切遍使拔以故尔。或曰。于中习起遍三界苦。世尊说。若不欲苦者当断习。习已断不复遍三界苦。或曰。谓习中三界有濡中上果。世尊说若不欲三界果者当断习。已断习不受三界果以故尔。或曰。谓从习起流三界苦。如泉窟出水溢于外。慧者说曰。士夫不欲令水出者当塞其源。已塞其源水便不出。如是从习中出遍三界苦。世尊说若不欲苦者当断习。已断习不复流三界苦。以故尔。或曰。舍阴重故。世尊说当断习。如人负重上山崄。慧者说曰。士夫若不欲重者速舍任。已舍任重便堕。如是此众生负重阴履崄生死。世尊说众生若不欲重阴者当断习。已断习阴便堕不复成就。是谓舍重阴。故世尊说当断习。尽作证者。如阿毗昙说。一切无漏法作证。何以故世尊说尽作证。答曰。谓解脱不系相。或曰。谓因及果果中无因。或曰。谓因非俱因。果非俱果。缘非俱缘。所作非俱所作。或曰。谓沙门果非沙门。梵果非梵。梵行果非梵行。或曰。谓常恒处不变易离生死。或曰。谓一味异道果净一切色故说无上。或曰。谓离三成四舍五。以是故世尊说尽作证。思惟道者。如阿毗昙说思惟一切善有为法。何以故世尊说思惟道。答曰。谓思惟者二思惟。得思惟服思惟。世俗道虽有思惟但四思惟。得思惟服思惟断思惟舍思惟。或曰。谓思惟道者欲得善果。彼道是善善果。是爱爱果。意乐意乐果。意欲意欲果。或曰。谓质直不邪一向趣涅槃。或曰。谓是沙门沙门果。梵梵果。梵行梵行果。俱果或谓安隐乐趣涅槃。或曰。谓不贪除贪。不恚除恚。不痴除痴。或曰。谓思惟能灭坏破有。此世俗道虽有思惟。但增受长养有。或曰。谓思惟能断有相续。能断轮转生老死。世俗道虽思惟。但相续有轮转生老死。或曰。谓思惟非身见种非颠倒种非爱种非使种。非贪处非恚处非痴处。非杂污非杂毒非杂。浊非在有。不堕苦习谛。世俗道虽有思惟。但身见种颠倒种爱种使种。贪处恚处痴处。杂污杂毒杂浊在有堕苦习谛。或曰。谓思惟苦尽趣道。有尽趣道。贪趣道。尽生老死趣道。世俗道虽有思惟。但苦习趣道。有习趣道。贪习趣道。生老死习趣道。以是故世尊说思惟道不说世俗道。说曰。此说十六圣行。无常行苦行空行非我行。因行习行有行缘行。尽行止行妙行离行。道行正行趣行出要行。问曰。十六行有何性。有一说者慧性。谓说慧性者。彼慧是行。能行他所行。谓彼相应法虽能行他所行。但非是行。性非慧故。谓彼共有法虽有他所行。但非能行。非共缘故。亦非是行。性非慧故。更有说者。心心法性。彼有说心心法性者。彼慧行能行他所行。谓彼相应法彼亦是行。能行他所行。谓彼共有法。彼虽他所行非能行。非共缘故非是行。性非慧故。如一说如二如是好如前所说慧性。问曰。名十六行种有几。一说者名十六行种七。谓苦行彼名亦四种亦四。谓习行名四种一。谓尽四行名四种一。谓道四行彼名四种一。是故名十六行种七。问曰。何以故苦行名四种亦四。答曰。谓此断颠倒。犹如彼颠倒名四种亦四。彼治亦尔名四种亦四。如是说者名十六种亦十六。如名如种如是名数数种名相种相名异种异名别种别名觉种觉。如是尽当知。此是诸行性。已种相身所有自然。说性已当说行。何以故说无常行。何以说乃至出要行。答曰。无常者说二事。时及缘。时者一时作事二时不作。缘者诸法性羸随因及缘。苦者如病痈患也。空者内无作无教作。无觉无教觉。非我者不自在故。因者种子法故。习者来故。有者流故。缘者转成故。如泥团轮手水合已便成瓦器。此亦不。尽者灭阴故。止者息三火故。妙者妙愿满故。一离者已离不更离故。道者除恶道故。正者除不正故。趣者向涅槃故。出要者出生死故。复次非常者非究竟住故。苦者劳厌重故。空者除我有见故。非我者除是我见故。因者来故。习者起故。有者可得故。缘者随所缘故。尽者尽生死故。止者止苦火故。妙者善有常故。离者离生老无常故。道者求故。正者正住故。趣者趣城不移故。出要者安隐故。问曰。如苦四行无常苦空非我行。何以故说苦谛不说无常空非我谛。答曰。谓此行久远行。以此行过去三耶三佛说苦谛。或曰。谓此苦行一向堕苦谛非余。他无常行共堕三谛。空行及非我行共堕一切法中。此苦行一同堕苦谛非余。是故说苦谛非余。或曰。谓此苦行一切能信。凡愚及慧此法及外法以故尔。或曰。谓令极断觉所觉行所行缘所缘根为根义。佛契经说。苦智彼所缘是苦谛。或曰。谓此行增舍有能除生死。如彼小儿与极妙食。若言当有苦彼便不欲。如是此苦行增舍有能除生死。以是故佛契经说苦谛。不说无常空非我谛。问曰。如习有四行因行习有缘行。何以故世尊说习谛。不说因有缘谛。答曰。谓此行久远行。以此行过去三耶三佛说习谛。或曰。谓令极断觉所觉行所行缘所缘根为根义。佛契经说。习智彼所缘是习谛。以是故佛契经说习谛。不说因有缘谛。问曰。如尽有四行尽行止妙离行。何以故世尊说尽谛不说止妙离谛。答曰。谓此行久远行。以此行过去三耶三佛说尽谛。或曰。谓令极断觉所觉行所行缘所缘根为根义。佛契经说。尽智彼所缘是尽谛。以是故佛契经说尽谛。不说止妙离谛。问曰。如道有四行道趣正出要行。何以故世尊说道谛。不说正趣出要谛。答曰。谓此行久远行。以此行过去三耶三佛说道谛。或曰。谓欲令极断觉所觉行所行缘所缘根为根义。佛契经说。道智彼所缘是道谛。以是故佛契经说道谛。不说正趣出要谛。说曰。此说涅槃无形。问曰。何以故说涅槃无形。答曰。圣所了故说无形。圣了彼自在身作证。无有能在前论说彼。是故圣所了故曰无形。或曰。离一切色故。故曰无形。此说四色。刹利梵志居士工师。复次四色青黄赤白。彼中无有一色是离一切色。故曰无形。或曰。净一切色故。曰无形。若刹利修道彼得道果。梵志居士工师修道彼得道果。是离一切色故。故曰无形。或曰。亦非色不依色故。故曰无形。色法虽有形。非形依心心数法。虽依形非是形。彼涅槃亦不依色亦不依形。故曰无形。或曰。称叹无量功德故。故曰无形。如人多有功德。说者此人功德多故不可具说。如是涅槃无量功德故。故曰无形。或曰。遍功德故。故曰无形。如摩尼遍有光明彼说无形。如是彼涅槃遍功德故。故曰无形。或曰。如此有为有因有果。彼涅槃无因无果故曰无形。或曰。如此有为法因故说果。果故说因彼涅槃非因故说果。非果故说因。故曰无形。说曰。彼涅槃非说品问曰。何以故说涅槃非品。答曰。断一切品故。故说涅槃非品。如此有为作品生或五或四。谓欲令法常住。彼一切有为法。各各并已有五事生彼法。彼法生彼法住。彼法老彼法无常。谓欲令法无常住。彼一切有为法各各并已有四事生彼法生老无常。如此有为作品。彼涅槃不如是。是故说涅盘非品。说曰。彼涅槃说爱。问曰。何以故涅槃说爱。答曰。圣者不爱生死。涅槃者离生死。或曰。圣者不爱轮转。涅槃者离轮转。或曰。圣者不爱阴。涅槃者离阴。或曰。圣者不爱生。涅槃者离生。或曰。圣者不爱老死。涅槃者离老死。或曰。圣者爱念乐涅槃。以是故说涅槃爱如彼契经说。戒及等意解脱。是爱彼一切为涅槃故。以是故。世尊契经说涅槃爱。说曰。彼涅槃说非可习。问曰。何以故说涅槃非可习。答曰。有为为果故习。涅槃无有果。问曰。何以故说明所服行。答曰。智故得故。明者佛及佛弟子。此缘彼发忍及智。是故说智故得故。说涅槃说非可思惟。问曰。何以故涅槃说非可思惟。答曰谓法意所生此可思惟。彼涅槃意所不生。或曰。有为法果故思惟。彼涅槃无有果。问曰。若涅槃意所不生者。此偈云何通

  树下静思惟　　涅槃令入意
  瞿昙禅无乱　　不久息迹证

答曰。此说意心为名。此意得涅槃作证。说曰。彼涅槃说第一义。说智说阿罗汉果。问曰。何以故涅槃说第一义。答曰。第一正故。第一法故。第一究竟故第一等。是故说第一义。问曰。何以故说智。答曰。智果故彼说智。问曰。何以故涅槃说阿罗汉果。答曰。可供养故说涅槃阿罗汉果。一切世间清净供养尽可供养。故可说涅槃名阿罗汉果。或曰。不生故说涅槃名阿罗汉果。不复生诸界诸趣诸生轮转生死中。故说涅槃名阿罗汉果。说曰。此涅槃说近。如彼契经说。彼成就此十五法。多智多见多觉近住涅槃。我说彼非不至涅槃。问曰。何以故说近。答曰。实者故曰近。或有欲令涅槃不实。谓彼欲令不实者。断彼意故。此说真实有种相。是谓真实故名为近。或曰。精勤正趣等趣意中可得故曰近。或曰。意等故名为近。若刹利思惟道彼得道果。梵志居士工师思惟道彼得道果。是谓等意故名为近。或曰。等处所故名为近。若于村中思惟道。彼中得道果。若静处树下冢间露坐林中思惟道。彼中得道果。是谓等处所名为近。或曰。义故即是近。是故说近。如婆须蜜经所说远法。云何谓过去当来法近法。云何现在法及无为。是谓义近名为近。或曰。近意解故名为近。谓圣缘彼生忍及智。如现在前。犹如在前。是谓近意解故名为近。或曰。得作证故名近。近者现在世此中起彼得作证。是谓得作证故名为近。或曰。舍近故名为近。近者说现在世离此入彼。是谓说涅槃近。如佛契经一一所说闻如是。一时世尊游波罗捺仙人住处鹿野苑中。彼时世尊告五比丘。五比丘。此苦本所未闻法。当正思惟时生眼智明觉。五比丘应当知。此苦本所未闻法。当正思惟。时生眼智明觉。五比丘。我已知苦本所未闻法。当正思惟时生眼智明觉。五比丘。此苦习本所未闻法。当正思惟时生眼智明觉。五比丘应当断。苦习本所未闻法。当正思惟时生眼智明觉。五比丘。我已断苦习本所未闻法。当正思惟时生眼智明觉。五比丘。此苦尽本所未闻法。当正思惟时生眼智明觉。五比丘。彼苦尽应当作证。本所未闻法。当正思惟时生眼智明觉。五比丘。我已苦尽作证。本所未闻法。当正思惟时生眼智明觉。五比丘。此苦尽道本所未闻法。当正思惟时生眼智明觉。五比丘。应当思惟苦尽道本所未闻法。当正思惟时生眼智明觉。五比丘。我已思惟苦尽道本所未闻法。当正思惟时生眼智明觉。五比丘。谓我此四圣谛三转十二行。未生眼智明觉。五比丘。是故我于天及人魔梵沙门梵志众中。不出不离不解不脱。心亦不离颠倒。生未尽梵行未立所作未办。名色未有知如真。五比丘。我不自觉无上正真道。五比丘。谓我此四圣谛三转十二行生眼智明觉。五比丘。是故我于天及人魔梵沙门梵志众中。已出已离已解已脱。心不颠倒。生已尽梵行已立所作已办名色已有知如真。五比丘。我自觉无上正真道。说此法时尊者拘邻远尘离垢诸法法眼生。及八十千天人远尘离垢诸法法眼生。彼时世尊告尊者拘邻。汝拘邻。知法未。拘邻对曰。已知世尊。已知善逝。尊有拘邻知法已。故名阿若拘邻。闻此法时地神举声极举大声。此世尊于仙人住处鹿野苑中转法轮。沙门梵志天及人魔梵及余世间本所未转。增益诸天种。减损阿须伦众。闻此地神声已。空中神四天王三十三天。炎天兜术天尼摩罗天化他应天。举声举大音声。此世尊于仙人住处鹿野苑中转法轮。沙门梵志天及人魔梵及余世间本所未转。增益诸天种。减损阿须伦众。即彼时彼须臾顷一时闻声彻梵天。此世尊于仙人住处鹿野苑中转法轮。沙门梵志天及魔梵及余世间本所未转。增益诸天种。减损阿须伦众。世尊转法轮故。是故名转法轮经。尊者昙摩多罗说曰。我观世尊此所说法身毛皆竖。然世尊说义不违。譬喻不违。而此所说与义相违不次第。不与佛同。不与辟支佛声闻同。于阿罗汉上三过说未知根。云何如此于阿罗汉上三过未知根现在前。我若欲舍此所说。然此所说世尊三阿僧祇行成此所说。然复有证。五比丘为首。八十千天。若欲不舍。而此所说与义相违无次第。不与佛同。不与辟支佛声闻同。于阿罗汉上三过说未知根。云何如此于阿罗汉上三过说未知根现在前。如所说五比丘。此苦本所未闻法。当正思惟时生眼智明觉。此说未知根。五比丘当知。此苦本所未闻法。当正思惟时生眼智明觉。此说已知根。五比丘。我已知苦。本所未闻法。当正思惟时生眼智明觉。此说无知根。如是至道。如是三过说未知根。云何如此于阿罗汉上三过未知根现在前。如是此所说义相违不次第。不与佛同。不与辟支佛声闻同。作此论已。不舍。但当改此契经应当尔。五比丘。此苦习此苦尽此苦尽道。本所未闻法。当正思惟时生眼智明觉。五比丘。当知彼苦。当断习尽作证思惟道本所未闻法。当正思惟时生眼智明觉。五比丘。我已知苦习已断尽已作证已思惟道。本所未闻法。当正思惟时生眼智明觉。如是契经应尔。应尔已便有三转及十二行。作如是说者。此契经不应改。本诸大论师有智强力者所不改。况复尊者昙摩多罗。问曰。若不改此契经者。然此义相违无次第。不与佛同不与辟支佛声闻同。于阿罗汉上三过说未知根。云何如此于阿罗汉上三未知根现在前。答曰。此说二时说时观时。如说时如是佛契经说。如观时如是昙摩多罗所说。如是作已二俱好。尊者僧迦婆修说曰。此契经中不说未知根已知根无知根。问曰。若不尔者此云何。答曰。佛契经说闻慧思慧

问曰。此契经说。五比丘。如我此四谛三转十二行生。眼智明觉。五比丘。我自觉无上至真等正觉。云何佛以闻慧思慧。自觉无上至真等正觉耶。答曰。菩萨以闻慧思慧。极观法极生法明。于法极除愚痴。谓菩萨于无上至真等正觉观如等觉。观如已成事。如人以湿皮覆面。却已以婆罗覆面。谓障小俨色。如是菩萨以闻慧思慧。极观诸法极生法明。于法极除愚痴。谓菩萨于无上至真等正觉观如等觉。观如已成事。说曰。如所说五比丘。如我此四谛三转十二行。生眼智明觉。问曰。如此应十二转有四十八行。如说五比丘。此苦本所未闻法。当正思惟时生眼智明觉。此一转有四行。五比丘。此苦应当知。本所未闻法。当正思惟时生眼智明觉。此二转四行。五比丘。我已知苦。本所未闻法。当正思惟时生眼智明觉。此三转四行。是谓苦三转十二行。如苦如是至道亦尔。如此应十二转有四十八行。何以故。世尊说四谛三转十二行。答曰。三转十二法故。不过三转十二行。观一一谛故。世尊说四圣谛三转十二行。如余契经说。比丘七处善观三种义。速于此法中得漏尽。此不应七处善。应有三十五处善。亦有无量处善。但七法故不过七。观一一阴故。世尊说比丘七处善观三种义。速于此法中得漏尽。如余契经说。七还有成须陀洹。彼不应七转还有。应十四还有二十八还有。但法应七。故不过七。一一趣故。世尊说极七极七还有成须陀洹。如余契经说。当为说法。谓有二眼及色耳声鼻香舌味身细滑意法。此不应一二。应有六二。但二法故不过二。观一一入故。眼及色故。乃至意及法故。如是此三转十二行故。不过三转十二行。观一一谛故。世尊说四圣谛三转十二行。彼生眼者为见故。生智者为决定故。生明者悬鉴故。生觉者觉了故。复次生眼者苦法忍。生智者苦法智生明者苦未知忍。生觉者苦未知智。如是至道亦尔。说曰。如所说拘邻知法未。拘邻对曰。已知世尊。已知善逝。问曰。何以故。世尊为尊者拘邻说知未拘邻。答曰。欲令忆本昔誓故。说者菩萨本宿命时。名忍辱仙人。彼止山林中思惟行忍。彼时有王。名迦蓝浮。将诸妇人眷属围绕到彼山林。无有男子纯与妇人五乐自娱。彼娱乐已王疲极卧。诸妇人等知王眠已。舍王求华游彼山间。遥见一处有菩萨。颜貌端正犹如日月。照于山林在彼而住。见已便至菩萨所。到已头面礼菩萨足。礼已却坐一面。于是菩萨为其说法爱欲不净。此诸妹等。欲者不净臭处可厌。因起嗔恚生无量苦。如是广为说欲不净。彼时迦蓝浮王睡觉不见诸妇人。彼作是念。咄此为灾。谁将诸妇人去。彼拔刀已往诣山间。推求遥见在菩萨前坐。彼作是念。此大鬼神所持久。见菩萨颜貌端正诸女人等坐菩萨前。见已极生嗔恚。便至菩萨所。到已问菩萨曰。仙人得有想无想耶。对曰。不也大王。得不用处识处空处耶。对曰。不也大王。王曰。仙人得四禅三禅二禅一禅耶。对曰。不也大王。彼作是念。咄此为灾。未弃结之人见我妇人。王语菩萨曰。汝在此空静处何所为。而不得尔所功德。菩萨对曰。大王。我修行忍。王作是念。此见我嗔而言行忍。不可柔软言试此人忍。王向菩萨说曰。仙人。若行忍者申右手。我当观汝云何行忍。菩萨无恚意即申右臂。王无慈心弃舍后世。起极恶心以利刀截手投足下。如是左手二足耳鼻割已。说曰。仙人何所愿。菩萨对曰。大王。但有疲劳汝。取我身碎如胡麻。我终不舍于忍。如母爱子。但大王听我誓愿。而汝取我无过之人。以极利刀截身七分。如是我初得佛法。不久起大悲。思惟七种道断汝七使。王作恶已离彼处还彼时山林中有异仙人在边山。彼闻迦蓝浮王加恶于忍辱仙人。于是彼仙人至忍辱仙人所。到已问曰。仙人不极患身苦耶。忍辱仙人对曰。我无苦痛。仙人问曰。因有足故知有行来。因有手知有取受。汝无手足耳鼻七分之余。云何言无苦痛耶。忍辱对曰。不以身坏名为苦痛。心坏乃为苦痛。谓受地狱畜生饿鬼不善之果。复次汝等若有疑者。观此疮处血净流出如牛乳不。仙人问曰。汝遭被困时修何等意。菩萨对曰。彼王以利刀截我身支节时。我于一切众生修于大慈。仙人说曰。善哉善哉修习大行。缘汝斯行饶益一切世间。仙人慰劳已便还所止。仙人还不久。四大天王极大起冻雹风雨已至忍辱仙人所。到向忍辱仙人说曰。仙人当敕我等。我当坏彼迦蓝浮王妻子眷属国土人民。忍辱仙人身毛皆竖说曰。谓截我手足耳鼻断身七分。我于彼不起毛发之恶。况复彼国人民于我无过而欲加之。四大天王说曰。若不欲行恶。何得忧戚止此山林。忍者对曰。我但忧念彼迦蓝浮王。何故彼作尔所恶。谓当受地狱极苦。谓菩萨转后身已。乃至降魔成无上最正觉。觉已为尊者拘邻说法。尊者拘邻远尘离垢诸法法眼生。已说曰。拘邻谓昔截我手足耳鼻。断身七分。我作誓愿。汝取无过之人断身七分。我初得佛法。不久得大悲。修七种道断汝七使。本所誓愿今为果不。尊者拘邻惭愧羞耻。对曰。真果世尊。真果善逝。是谓欲令忆本誓故世尊说拘邻知法未。如尊者拘邻见谛。彼时世尊观当来世知何者多。我三阿僧祇劫多耶。为拘邻受当来阴界入身多耶。世尊观拘邻受一阿鼻泥犁阴界入身多。非佛三阿僧祇劫一时间须臾顷数多。世尊作是念。若我三阿僧祇劫苦行不作余事。但脱拘邻尔所苦。于三阿僧祇果愿已毕。世尊如是观比丘拘邻。应当害一切众生。一切众生亦当害拘邻。比丘拘邻当食一切众生。一切众生亦当食拘邻。比丘拘邻当缚一切众生。一切众生亦当缚拘邻。若我三阿僧祇苦行不作余事。但脱拘邻尔所苦。于三阿僧祇果愿已毕。如所说此世尊于波罗捺仙人住处鹿野苑中转法轮

问曰。转法轮处一切三耶三佛定耶为非定耶。若定者定光如来契经云何通。彼说定光如来无所著等觉于灯王城呵梨那山转法轮。若不定者彼尊者法实偈云何通

  此处过去佛　　第一初说法

作此论已。答曰。转法轮处不定。问曰。若尔者定光如来经善通尊者(法实)偈云何解。答曰。此不必通。非契经非毗尼非阿毗昙。但彼作颂者欲令句义合故。更有说者。此是常定处。如是说者一切三耶三佛处常定。一金刚座处。二转法轮处。三天上来下处。问曰。云何知金刚座处定。答曰。有契经说。过去时有王名顶生。彼领四天下得自在。与四种兵欲至天上。彼时轮住虚空。轮住已一切四种兵亦住。四种兵住已顶生王便恐怖身毛皆竖。王作是念。将不亡失国耶。命不中夭耶。为诸天不欲见我耶。于是彼空中天慰劳顶生王曰。大王勿恐怖。大王勿恐怖。亦不亡失国。命亦不中夭。诸天非不喜见。顶生王问天曰。天若我无此灾患者。何以故轮住空中。天对曰。大王此处一切恒沙之如来无所著等正觉。降魔官属已成无上最正觉。是故此处一切众生无能历上者。是故轮住空中。于是顶生王还从上下已。即于彼处立鋀婆极大供养已。更从余处飞升天上。共释提桓因半座。闻者三千六百释命终。彼之故在座。以此经可知金刚座处常定。问曰。云何知转法轮处常定。答曰。如法实偈所说。问曰。若尔者尊者法实偈善通。彼说定光如来无所著等正觉于灯王城诃梨那山转法轮。答曰。彼灯王城者。即是波罗捺。阿梨那山者。即是仙人住处鹿野苑。以此可知一切三耶三佛转法轮处常定。问曰。云何知从天上来下处常定。答曰。如所说于过去时众多比丘同止彼处。少有所为虽彼处游余处。诸比丘去不久。余异学入住彼处。彼众多比丘于后时还来本处。语异学言。此是我处。异学亦说。此是我处。彼便共极大斗诤。诸比丘厌诤已。语异学曰。当共作真谛言。有真谛者便得此处。异学言可尔可尔。异学多作诚谛语而不成就。比丘说曰。听我诚谛语。彼处有师子幢。彼诸比丘同一声发诚谛语。以此真实之言。若一切恒沙三耶三佛为母故及三十三天说法已来下初至此处者。以此真谛言令师子幢现有变化。彼时师子极大震吼。诸异学闻已惊怖畏惧。便舍而走不入彼处。彼师子口极大吐花。花满彼处。以此可知一切诸三耶三佛从天上下是常定处。以此事知。一切三耶三佛三处常定。金刚座处转法轮处天上下处。问曰。如所说地神举声。彼时诸大天亦集近世尊座。如四大天王释提桓因及大梵天首陀会天及余极妙天龙鬼神近世尊座。诸地神坐处远不近世尊。何以故地神前发音声。答曰。此地神是彼诸天给使。是故彼前发声。或曰。地神者不常定。是故彼前发声。如大聚会极作伎乐。谓不常定人者。便速前举声笑。谓常定人然后庠序笑。如是地神非常定。是故前发音声。余诸天常定。是故最后发声。或曰。地神常当护菩萨故。说者谓菩萨兜术终已。生阎浮提迦罗卫国。不乱入母胎。彼时释提桓因敕遮勒天子。汝遮勒五百青鬼。菩萨在母胎。常当拥护莫令有触娆菩萨者。于是遮勒天子受释教已。便敕五百青鬼。当往迦罗卫国拥护菩萨。彼诸青鬼菩萨在母胎。及生常拥护之。以佛转法轮。地神作是念。菩萨在母胎及生。我等常拥护。此是我等疲劳所得功报。彼欢喜悦豫故前发声。此世尊转法轮。问曰。闻此法已地神举声音彻梵天。何以故声不过梵天。答曰。谓耳识现在前故声彻也。过梵天上无有自地耳识现在前。或曰。梵天请佛转法轮故声彻梵天。首陀会天劝请菩萨。使成无上最正觉。谓与菩萨化作老病人死人及沙门。彼一切首陀会天所作。菩萨见老病死人及沙门已。厌患出家学道。至降魔官属已成无上最正觉。彼时首陀会天踊跃欢喜发大音声。谓我等为菩萨化作老病死人及沙门。是我等疲劳所得功德。以是故成无上正觉时。声彻至首陀会天。大梵天请佛世尊转法轮。彼踊跃欢喜发大音声。此世尊转法轮。是我等疲劳所得功报。以是故转法轮时。声彻梵天不过上。说者谓佛为四天王故圣语说四谛。二知二不知。谓不知者为昙罗国语说。禋倿(苦也)弥倿(习也)陀破(尽也)陀罗破(道也)。此说苦边。一知一不知。谓不知者为弥离车国说语。摩含兜含　僧含摩　萨婆多　鞞梨罗。此说苦边尽知。问曰。世尊为四天王说四谛圣语。为有力耶无力耶。若有力者何以故为二圣语说。一昙罗国。一弥离车国语说。若无力者本师偈云何通

  一音声说法　　悉遍成音义
  彼各作是念　　最胜为我说

一音声说法者。是梵音也。悉遍音者。若有真旦人。彼作是念。谓佛作真旦语说法。如是陀勒摩勒波勒佉沙婆佉梨。谓彼处若有兜佉勒人。彼作是念。谓佛作兜佉勒语说法。现义者着欲者作是念。世尊说不净。恚者作是念。世尊说慈。痴者作是念。世尊说缘起。彼各作是念。最胜为我说者。众中作是念。世尊为我故说法。是故说

  一音声说法　　悉遍成音义
  彼各作是念　　最胜为我说

作此论已。答曰无力。何以故。世尊不可以耳见色以眼听声。问曰。若无力者此偈云何通。答曰。此偈不必通。偈者非契经非律非阿毗昙。但彼作颂者。欲令句义合故。此是赞佛非是实。如鞞婆阇提说。诸佛不眠。以除阴盖故。佛世尊亦常定故。如是更有说者。诸佛世尊不饮不食。除诸着味故。此是赞佛非是实。如是偈赞佛非是实。若通此偈者当何意。答曰。世尊所说应机捷速。世尊语极速。为一说已复为一说。如似一时。或曰。世尊语音一切音。各有境界应适一切音。世尊极知真旦语胜生真旦中者。如是陀勒摩勒波勒佉沙婆佉梨兜佉勒。世尊极知兜佉勒语胜生兜佉勒中者。以是故。说一音声说法。悉遍成音义。更有说者世尊有力。问若尔者此偈为善通。何以故世尊为四天王说四谛。为二圣语说。为一昙罗国语说。为一弥离车国语说。答曰。欲满彼四天王意愿故。二天王愿世尊圣语为我说四谛。一愿昙罗国语。一愿弥离车国语。世尊常欲满他一切善愿。随所欲而为说法。是谓满四天王意愿故。为二圣语说四谛。为一昙罗国语为一弥离车国语说。或曰。断他疑故。莫令有作是念。世尊但善于圣语。不能昙罗国语弥离车国语。是故断他疑故。说我一切中自在。以故尔。或世尊教化。或为变身口或不变。谓不变身口者。若为彼变便不得度。以是故世尊以己力游朋者尸人间一日行十二由延。说者即彼日教化七十千人入圣法中。谓一切缘不变身口。谓教化变身口者。若为彼不变便不得度。以是故。世尊为四天王二圣语说。一昙罗语说一弥离车语说。说四谛时如是行观时一切根本圣行。问曰。四圣谛几性断非缘断。几缘断非性断。几性亦缘断。几亦非性断亦非缘断。答曰。性断非缘断。谓苦谛习谛无漏缘。此性断非缘断。缘断非性断者。谓道谛有漏缘。此缘断非性断。性断缘断者。谓苦谛习谛有漏缘。此性断亦缘断。非性断亦非缘断者。谓尽谛及道谛无漏缘。此非性断亦非缘断。广说四谛处尽

鞞婆沙论卷第九鞞婆沙论卷第十

        阿罗汉尸陀槃尼撰

        符秦罽宾三藏僧伽跋澄译

    四禅处第三十三

四禅者。初禅二禅三禅四禅。问曰。四禅有何性。答曰。五阴是性。此是禅性已种相身所有自然。说性已当说行。何以故说禅。禅有何义。为弃结故禅耶。为正观故禅耶。若弃结为禅者。无色中亦有定谓能弃结。若正观为禅者欲界中亦有定谓能正观。作此论已。有一说者。弃结故名为禅。问曰。若弃结名为禅者。无色中亦有定谓能弃结。何以故不名为禅耶。答曰。谓弃二种结不善及无记。彼名为禅。无色中定虽弃无记结非弃不善。是故彼不名为禅。问曰。若尔者应依未来名为禅。彼弃二种结。不善及无记。答曰。此说呵责弃故。此说二种弃。断弃呵责弃。彼依未来为欲界结故。二种弃断弃呵责弃。上地虽非断弃。但是呵责弃。是谓呵责弃故说。问曰。若尔者尽道法智分。一切未知智分不应是禅。谓彼欲界结亦非断弃亦非呵责弃。答曰。莫具取界莫具取地。可得彼一界一地。欲界结断弃呵责弃。彼无色中一时顷不得。谓此欲界结断弃及诃责弃。尊者瞿沙说曰。一切六地欲界结断弃亦呵责弃。但彼依未来生已弃欲界结。彼余地当何所弃。彼亦能弃。但无结可弃除。如一人有六怨家其谋议。若随所得处当断其命。彼初怨家断此人命。余者当何所断。彼亦能断。但无人当何所断。如是一切六地欲界结断弃呵责弃。但彼依未来生已弃欲界结。彼余地当何所弃。彼亦能弃。但无结可弃。如人持六灯入冥室中。彼初明已弃至冥。余灯当何所弃。彼亦能弃。但无冥可弃。如是一切六地欲界结断弃呵责弃。但彼依未来生已弃欲界结。彼余地当何所弃。彼亦能弃。但无结可弃。如一切日光坏诸闇冥。初日中日西日。但初光出已弃夜闇冥。余光当何所弃。彼余光亦能弃。但无冥可弃。如是彼一切六地欲界结断弃亦呵责弃。但依未来生已弃欲界结。彼余地当何所弃。彼亦能。但无结可弃。或曰。禅者定可得。谓一切缘中定亦弃一切结。欲界定虽一切缘中定。但不弃结。无色界定亦不一切缘中定。亦不弃一切结。以是故不名为禅。或曰。谓禅者普智可得道。亦能弃结。欲界定虽普智可得。但无有道弃结。无色界虽有道能弃结。但无普智可得。谓禅中普智可得道亦弃结。或曰。谓三道可得此名为禅。非欲界无色界三道可得。是故彼不名为禅。或曰。谓三地可得此名为禅。非欲界无色界三地可得。是故不名为禅。或曰。谓三根可得此名为禅。非欲界无色界三根可得。是故不名为禅。或曰。谓三学可得增戒增定增慧。此名为禅。非欲界无色界三学可得。是故不名为禅。或曰。谓摄四枝五枝五阴定可得。是故不名为禅。或曰。谓三示现可得。神足示现。观察示现。教授示现。此名为禅。非欲界无色界三示现可得。是故不名为禅。或曰。谓三神足可得。意解神足。意捷疾神足。身踊神足。意解神足者。如力士屈申臂顷。于中间至阿迦尼吒。意捷疾神足者。如识旋转诸界。于中间至阿迦尼吒。身踊神足者。谓一切身踊如鸟飞虚空如画人飞。此名为禅。非欲界无色界三神足可得。是故不名为禅。或曰。谓具三十七道品可得彼名为禅。非欲界无色界具三十七道品可得。是故不名为禅。更有说者。正观故名为禅。问曰。若正观名为禅者。欲界中亦有定谓能正观。何以故不名为禅。答曰。欲界定虽有定名但无定用。如泥梁虽有梁名无有梁用。如是欲界定虽有定名而无定用。色界定既有定名而有定用。如木梁既有梁名而有梁用。如是色界定既有定名而有定用。或曰。欲界定娆乱不定。如四衢道然灯。四面风吹随风东西。如是欲界定娆乱不定。色界定不娆乱。常定不动如室中灯。风所不吹炎不东西。如是色界定亦不娆乱常定不动。或曰。欲界定不坚无力无士夫功。色界定坚固有力有士夫功。以是故此名为禅。说曰。此名禅十八枝。初禅有五枝。觉观喜乐一心。二禅有四枝。内净喜乐一心。三禅有五枝。猗乐念正智一心。四禅有四枝。不苦不乐护念一心。问曰。禅枝名十八种有几。答曰。禅枝名十八。种有十一。谓初禅五枝此名亦五种亦五。二禅增一枝信。三禅三枝增乐念正智。四禅增二枝不苦不乐护。此禅枝名十八。种有十一。更有说者。禅枝名十八种有十。问曰。何以故。答曰。谓初禅二禅乐及三禅乐。此应同共立一枝。此者不论问曰。何以故。答曰。谓初禅二禅乐此是三禅乐者。应有禅枝名十八种有十。但初禅一禅乐异。三禅乐亦异。初禅二禅猗乐三禅痛乐。初禅二禅乐行阴所摄。三禅乐痛阴所摄。是谓禅枝名十八种有十一。如名如种。如是名数种数。名相种相。名异种异。名别种别。名觉种觉如是尽当知。此是禅性已种相身所有自然。说性已当说行。何以故说禅枝。禅枝有何义。答曰。顺义是枝义。助行义是枝义。摄义是枝义。顺义是枝义者。谓彼地定枝随顺即立彼地中。助行义是枝义者。此枝断结除结时助彼定行。摄义是枝义者。此枝断结除结时出入总摄。是谓顺义助行义摄义是枝义。此应作四句。问曰。谓禅枝是道品耶。答曰。初禅有觉二禅信三禅乐四禅不苦不乐。此禅枝非道品。云何道品非禅枝。云何禅枝亦道品。答曰。余枝此是禅枝亦道品。云何非禅枝亦非道品耶。答曰。除此行已。问曰。谓初禅枝亦是道品耶。答曰。或初禅枝非道品。云何初禅枝非道品。答曰。初禅有觉此是初禅枝非道品。云何道品非初禅枝。答曰。信念精进护正见正语正业正命此是道品非初禅枝。云何初禅枝亦道品。答曰。余枝此是初禅枝亦道品。云何非初禅枝亦非道品。除此行已。问曰。谓二禅枝是道品耶。答曰。或二禅枝非道品。云何二禅枝非道品。答曰。二禅信此是二禅枝非道品。云何道品非二禅枝。答曰。信念精进护正见正志正语正业正命此是道品非二禅枝。云何二禅枝亦道品。答曰。余枝此是二禅枝亦道品。云何非二禅枝亦非道品。答曰。除此行已。问曰。谓三禅枝是道品耶。答曰。或三禅枝非道品。云何三禅枝非道品。答曰。三禅乐是三禅枝非道品。云何道品非三禅枝。答曰。信精进喜护正志正语正业正命此是道品非三禅枝。云何是三禅枝亦道品。答曰。余枝此是三禅枝亦道品。云何非三禅枝亦非道品。答曰。除此行已。问曰。谓四禅枝亦是道品耶。答曰。或四禅枝非道品。云何四禅枝非道品。答曰。四禅不苦不乐。此是四禅枝非道品。云何道品非四禅枝。答曰。信精进喜猗正见正志正语正业正命此是道品非四禅枝。云何是四禅枝亦道品。答曰。禅枝此是四禅枝亦道品。云何非四禅枝亦非道品。答曰。除此行已。问曰。谓禅枝是意止耶。答曰。或禅枝非意止。云何禅枝非意止。答曰。初禅有觉二禅信三禅乐四禅不苦不乐。此是禅枝非意止。云何意止非禅枝。答曰。信精进正语正业正命此是意止非禅支。云何禅支亦意止。答曰。余支此是禅枝亦意止。云何非禅枝亦非意止。答曰。除此行已。如四意止意断神足根力觉道亦如是。问曰。谓初禅枝是意止耶。答曰。或初禅枝非意止。云何初禅枝非意止。答曰。有觉此是初禅枝非意止。云何意止非初禅枝。答曰。信念精进护正见正语正业正命。此是意止非初禅枝。云何初禅枝亦意止。答曰。余枝此是初禅枝亦意止。云何非初禅枝亦非意止。答曰。除此行已。问曰。谓二禅枝是意止耶。答曰。或二禅枝非意止。云何二禅枝非意止。答曰。二禅信此是二禅枝非意止。云何意止非二禅枝。答曰。信念精进护正见正志正语正业正命。此是意止非二禅枝。云何二禅枝亦意止。答曰。余枝此是二禅枝亦意止。云何非二禅枝亦非意止。答曰。除此行已。问曰。谓三禅枝是意止耶。答曰。三禅乐是三禅枝非意止。云何意止非三禅枝。答曰。信精进喜护正见正志正语正业正命。此是意止非三禅枝。云何是三禅枝亦意止。答曰。余枝此是三禅枝亦意止。云何非三禅枝非意止。答曰。除此行已。问曰。谓四禅枝亦是意止耶。答曰。或四禅枝非意止。云何四禅枝非意止。答曰。四禅不苦不乐。此是四禅枝非意止。云何意止非四禅枝。答曰。信精进喜猗正见正志正语正业正命。此是意止非四禅枝。云何是四禅枝亦是意止。答曰。余枝此是四禅枝亦是意止。云何非四禅枝亦非意止。答曰。除此行已。如四意止四意断神足根力觉道亦如是。问曰。谓初禅枝亦是二禅枝耶。答曰。或初禅枝非二禅枝。云何初禅枝非二禅枝。答曰。初禅有觉有观此是初禅枝非二禅枝。云何二禅枝非初禅枝。答曰。二禅信此是二禅枝非初禅枝。云何初禅枝亦二禅枝。答曰。余枝此是初禅枝亦二禅枝。云何非初禅枝亦非二禅枝。答曰。除此行已。问曰。谓初禅枝是三禅枝耶。答曰。或初禅枝非三禅枝。云何初禅枝非三禅枝。答曰。初禅三枝有觉有观喜。此是初禅枝非三禅枝。云何三禅枝非初禅枝。答曰。三禅三枝乐念正智。此是三禅枝非初禅枝。云何初禅枝亦是三禅枝。答曰。余枝此是初禅枝亦三禅枝。云何非初禅枝亦非三禅枝。答曰。除此行已。问曰。谓初禅枝是四禅枝耶。答曰。或初禅枝非四禅枝。云何初禅枝非四禅枝。答曰。初禅有四枝有觉有观喜乐。此是初禅枝非四禅枝。云何四禅枝非初禅枝。答曰。四禅有三枝。不苦不乐护念。此是四禅枝非初禅枝。云何初禅枝亦四禅枝。答曰。一心此是初禅枝亦是四禅枝。云何非初禅枝亦非四禅枝。答曰。除此行已。问曰。谓二禅枝亦三禅枝耶。答曰。或二禅枝非三禅枝。云何二禅枝非三禅枝。答曰。二禅有二枝信喜。此是二禅枝非三禅枝。云何三禅枝非二禅枝。答曰。三禅有三枝乐念正智。此是三禅枝非二禅枝。云何二禅枝亦是三禅枝。答曰。余枝此是二禅枝亦三禅枝。云何非二禅枝亦非三禅枝。答曰。除此行已。问曰。谓二禅枝是四禅枝耶。答曰。或二禅枝非四禅枝。云何二禅枝非四禅枝。答曰。二禅三枝信喜乐。此是二禅枝非是四禅枝。云何是四禅枝非二禅枝。答曰。四禅有三枝。不苦不乐护念。此是四禅枝非二禅枝。云何二禅枝亦四禅枝。答曰。一心。此是二禅枝亦四禅枝。云何非二禅枝亦非四禅枝。答曰。除此行已。问曰。谓三禅枝是四禅枝耶。答曰。或三禅枝非四禅枝。云何三禅枝非四禅枝。答曰。三禅有三枝猗乐正智。此是三禅枝非四禅枝。云何四禅枝。非三禅枝。答曰。四禅二枝不苦不乐护。此是四禅枝非三禅枝。云何是三禅枝亦四禅枝。答曰。余枝此是三禅枝亦四禅枝。云何非三禅枝亦非四禅枝。答曰。除此行已。问曰。初禅有觉。何以故不立道品。答曰。观坏故。问曰。二禅信何以故不立道品。答曰。二禅信者缘内心。道品者缘四谛。问曰。三禅乐何以故不立道品。答曰。猗乐坏故。问曰。四禅不苦不乐何以故不立道品。答曰。护坏故。问曰。精进何以故不立禅枝。答曰。此前已说顺义是枝义。此精进防定随顺。问曰。何谓定随顺。答曰。乐是如所说乐已心定。谓众生殷勤精进彼少受乐。问曰。正语正业正命何以故不立禅枝。答曰。禅枝者相应依行己力共缘。正语正业正命者。不相应不依无行无己力不共缘。问曰。何以故初禅三禅五枝。二禅四禅四枝。答曰。前已说顺义是枝义。谓法诸地随顺彼定此立枝。或曰。起随顺从五枝至五枝。从四枝至四枝。问曰。谓三禅次第入空处。彼从五枝起入无枝。何得随顺。答曰。一切内外事要当初用随顺。说者月德王及遮勒大臣。十二年学成就一金凡。然后师子吼。我等能化令一切地为金。复次如彼行者。谓神足智作证成神通时。始习初如胡麻。便一寸四寸一尺二尺半寻一寻一丈丈五二丈。谓神足智作证成神通已。一发意乃至阿迦贰吒。如是彼行者入超越时。要当初用随顺。从五枝至五枝。从四枝至四枝以故尔。或曰。此欲界难可断难可破难可度。因彼故初禅立五枝。初禅非难可断非难可破易可度。是故二禅立四枝。二禅染污喜难可断难可破难可度。因彼故三禅立五枝。三禅非难可断非难可破非难可度。以是故四禅立四枝。或曰。此欲界五欲可得。因彼故初禅立五枝。初禅无五欲可得。为彼故二禅立四枝。二禅五种喜相应爱可得。因彼故三禅立五枝。三禅无五种喜相应爱可得。因彼故四禅立四枝。以是故初禅三禅立五枝。二禅四禅立四枝。问曰。如初禅信可得。何以故信立二禅枝。不立初禅。答曰。前已说顺义是枝义。谓法诸地随顺定此立枝。或曰。谓处彼行者极信界弃欲。极信地弃欲。谓彼行者此欲界多诸恶。除欲已便作是念。我已度此不定界。此定界不知当云何度。如初禅已除欲。彼意极定作是念。此一切可离从欲界至第一有。谓处彼行者。极信界弃欲极信地弃欲。以是故信立二禅枝不立初禅枝。问曰。如猗一切地可得。何以故立三禅枝。答曰。此前已说。谓法诸地随顺定此立枝。或曰。二禅染污爱不定。如罗刹种可得。谓彼行者三禅地退。世尊说应止彼以是故猗立三禅枝余地不立。问曰。如猗及护一切地可得。何以故猗立三禅枝护立四禅枝。答曰。相坏故猗坏护故不立三禅枝。护坏猗故不立四禅枝。问曰。云何此法相坏。答曰。猗者能止护者不求此极相违。如诸人去住眠觉此极相违如是猗者能止护者不求此极相违。是谓相坏。故猗立三禅枝护立四禅枝问曰。如念及正智四禅可得。何以故念立四禅枝正智不立四禅枝。答曰。三禅道娆乱。自地亦娆乱。道娆乱者。二禅地染污喜不定如罗刹。谓令行者三禅退。世尊说当正念。莫令二禅地喜于三禅地退。已地乱者。彼三禅地乐一切生死中最妙。世尊说当知。莫着此乐令不至上地。四禅虽有道娆乱。但无己地娆乱。道娆乱者。彼三禅中乐一切生死中最妙。世尊说当正念。莫着此三禅地乐令于四禅地退。谓己地无娆乱。可说正智。莫著令不能至上地。以具故念及正智立三禅枝。四禅立念枝不立正智。问曰。此中云何说禅。云何禅枝。答曰。禅者定也。枝者余法也。问曰。如汝说。应初禅三禅有四枝。二禅四禅有三枝。答曰。定者亦是禅亦是禅枝。余枝虽是禅枝非是禅。如正见是道亦是道枝。余者虽是道枝非是道。择法觉意是觉意亦觉枝。余者虽是觉枝非觉。定是神亦是神足。余虽神足非神。非时不食是斋亦是斋枝。余虽是斋枝非是斋。如是定是禅亦是禅枝。余虽是禅枝非是禅。如世尊契经说。四禅现法安乐游处。问曰。何以故世尊说四禅现法安乐游处。答曰。凡夫现法意计着乐。意不舍离欲界。欲令劝离欲界结故。世尊说契经。谓彼着少所乐。不欲弃欲界结。世尊说若欲极广受无量乐者。当弃欲界结。根本地现在前。彼中无量乐可得。是谓凡夫现法意计着乐意不舍离欲界欲令劝离欲界结故。世尊说契经。四禅现法安乐游处。问曰。如此后世安乐游处。何以故世尊说现法安乐游处。不说后世安乐游处。答曰。此应说如现法安乐游处。后世安乐处亦当说。若未说者是世尊有余言。此现义义门义略义度当知是义。或曰。已说现法安乐游处。当知已说后世安乐游处。或曰。现法安乐游处是因。后世安乐游处是果。如因果已作当作已成当成已生当生已连续当连续。如是尽当知。或曰。现法安乐游处者是近。后世安乐游处者是远。或曰。现法安乐游处者是粗。后世安乐游处者是细。如粗及细。如是可见不可见。可现不可现。如是尽当知。或曰。谓一切现法安乐游处。非一切后世安乐游处。或曰。谓现法安乐游处者一切圣。后世安乐游处者非一切圣。或曰。谓一切可信凡夫及慧者。此法及外法。或有不信后世。何况信后世安乐游处。以是故佛契经说。四禅现法安乐游处。如世尊契经说四禅为食。问曰。何以故世尊说四禅为食。答曰。长养法身故。如余食长养众生。如是禅长养法身。是谓世尊契经说四禅为食。如世尊契经说四禅为坐。问曰。何以故世尊说四禅为坐。答曰。为高广故。高者出欲界故。广者摄无量善法故。问曰。何以故名为坐。答曰。诸圣生死疲劳。除生死疲劳故说四禅为坐。如人涉路疲极坐休息。如是诸圣生死疲劳。坐禅休息已除生死疲劳。以是故佛契经说四禅为坐。如世尊契经说。四禅为四功德。四无色为一功德。问曰。何以故世尊说四禅为四功德。说四无色为一功德。答曰。禅者种种若干相非相似。是故可得一一功德。无色者非种种非若干相非不相似。是故一切合已说一功德。或曰。禅者种种功德庄严。是故一切合已说一功德。或曰。禅者多有妙法。是故一一说功德。无色者无多妙法。是故一切合已说一功德。或曰。禅者粗可见可现。是故说一一功德。无色者细不可见难可现。是故一切合已说一功德。以是故佛契经说四禅为四功德。四无色为一功德。如世尊契经说。末那此四增心现法安乐游处。比丘禅起已我说当还入末那。此四息解脱度色至无色。比丘禅起已我说当教他。问曰。何以故佛世尊说四禅起已当还入。说四无色起已当教他。答曰。此禅者种种若干相非相似。是故彼圣起已还复欲入。无色者非种种非若干相非不相似。是故圣起已不欲还入。世尊说若不欲入者当教他。教他已。谓彼心入心起不令忘。或曰。禅者种种功德庄严。是故圣起已复欲还入。无色者非种种功德庄严。是故圣起已不欲入世尊说。若不欲入者当教他。教他已。谓彼心入心起不令忘。或曰。禅者多妙法。是故圣起已还复欲入。无色者无多妙法。是故圣起已不欲还入。世尊说。若不欲入者当教他。教他已。谓彼心入心起不令忘。或曰。禅者粗可见。是故彼圣起已复欲还入。无色者细不可见难可现。是故彼圣起已不欲还入。世尊说。若不欲还入者当教他。教他已。谓彼心入心起不欲令忘。是故佛世尊说四禅起已还当入。如世尊契经说四禅增意。问曰。何以故世尊说四禅增意。答曰。一切地无有定。极坚有力有功如根本地。以是故佛契经说四禅增意。或曰。此中可得增上心心数法。如无量等解脱。除入一切入。以是故佛说四禅增意。或曰。诸圣于此中增上门受乐。如无量等门解脱。除入一切入门。是故说四禅增意。如世尊契经说。四禅是天。诸天道未净。众生当净。已净当增益净。问曰。此为取证故说四禅天道[跳-兆+(厂@火)]耶。为有漏尽耶。若取证故说四禅天道者。应六地取证依未来禅中间根本四禅。若有漏尽者。应九地尽有漏。此六及三无色。作此论已。答曰。为取证故。亦有漏尽故。说四禅天道。问曰。若尔者置无色故应在六地。何以故世尊说四禅诸天天道。尊者瞿沙说曰。具眷属故。世尊契经说。四禅天道依未来禅中间。是初禅眷属是谓具眷属。故世尊说四禅诸天天道。尊者婆奢说曰。此说天是净天。天者三种天。作天生天净天。作天者如王。生天者从四天王至有想无想处。净天者如阿罗汉。彼阿罗汉者此中有二种道。见道及思惟道。忍道及智道。法智道及未知智道。是故说天净天。或曰。谓道及娱乐道。谓道及至竟道。谓道及净天道。以故尔。或曰。佛法中现大妙事故。如彼施设所说。谓转轮王未出世时。大海水出高一由延。谓不知转轮王道。是故无能行转轮王道。谓转轮王出世已。彼时大海水水还减一由延。转轮王道便净金沙布下。令转轮王将四种兵按行天下。如是佛世尊未出世时。不知根本四禅。谓众生欲除结。非根本及无色。谓世尊出世已。便知根本四禅。谓佛教化无量眷属入灭尽涅槃。是谓佛法中现大妙事故说四禅诸天天道。或曰。计着生天道。现第一义天道故。生天者。三十三天。说者三十三天有四园观。一名种种。二名欢乐。三名粗涩。四名杂肆。彼园观中地四阶道。多诸道男女玉女众游戏。有种种香种种伎乐。生种种花。种种饮食肴馔丰盈。种种飞鸟凫雁鸳鸯悲鸣相和。令三十三天无量门无量度受五欲乐。已入园观中。如是佛法中灭尽涅槃。如四园观。彼中设四禅如四阶道。无碍道解脱道如多诸男女。神通道如玉女众游戏。圣戒种种如香。四枝五枝乐如种种伎乐。觉道花如生种种花。无欲喜无上法浆如种种饮食肴馔丰盈。学无学如种种飞鸟。凫雁鸳鸯悲鸣相和。令彼圣无量门无量度受圣乐。入灭尽涅槃如园观。是谓计着生天道现第一义故。世尊说四禅诸天天道未净众生当净已净增益净。云何为四。此比丘离欲恶不善法。有觉有观离生喜乐。初禅成行游处。彼离欲恶不善法者。问曰。如离一切欲界。何以故世尊但说离欲恶不善法。答曰。世尊已说离欲恶不善法。当知已说离一切欲界。或曰。谓欲恶不善法难坏难破难度。是故世尊说当离欲恶不善法。或曰。谓欲恶不善法增上患极重过多诸恶。是故世尊说当离欲恶不善法。或曰。谓始尽已不复成就圣道与彼相违。圣道者不与善有漏法相违。非隐没无记。但与欲恶不善法相违。当弃欲恶不善法时彼弃一切。如灯不与炷相违。非油非灯器。但与闇冥相违。当除闇时亦烧炷亦消油亦热器。如是彼圣道灯不与善有漏法相违。亦非隐没无记。但与欲恶不善法相违。当弃欲恶不善法时彼弃一切。是谓始尽已不复成就圣道与彼相违。以是故世尊说离欲恶不善法。或曰。谓彼行者欲断欲恶不善法故。修初禅地道。以是故世尊说弃欲恶不善法。或曰。谓彼行者离欲恶不善法时离一切欲界。是故世尊说离欲恶不善法。或曰。谓欲恶不善法非上行上不可得。以是故世尊说离欲恶不善法。问曰。离欲恶不善法者。何者欲何者恶不善法。答曰。欲者五欲。恶不善法者淫欲。或曰。欲者欲想。恶不善法者恚想害想。或曰。欲者欲觉。恶不善法者恚觉害觉。或曰。欲界欲有漏。恶不善法者余有漏。或曰。欲者欲流。恶不善法者余流。或曰。欲者欲扼。恶不善法者余扼。或曰。欲者欲爱。恶不善法者余爱。或曰。欲者欲盖。恶不善法者余盖。或曰。欲者现欲爱。恶不善法者即是爱。谓彼是不善因此爱故。说离恶不善法是谓欲。是谓恶不善法。是故说离欲恶不善法。有觉有观者。与觉俱与观俱。是故说有觉有观。离生喜乐者。离恶法中生。如从水生名为水生。从陆生名为陆生。如是离恶法中生。是故说离生喜乐。问曰。如上地离为最上妙。何以故说初禅地离不说余。答曰。始得故初得故。是故说初禅离。或曰。疑者现决定。初禅此欲界极近。为近故如此欲界设豪贵处眷属处。初禅亦尔。如此欲界身识现在前。初禅亦尔。如此欲界有觉有观。初禅亦尔。如此欲界出息入息。初禅亦尔。莫令作是念。彼非是离欲决定。故说彼初禅离。或曰。令彼行心欢喜故。如彼行者此欲界多诸恶。除欲已初禅现在前。己心极欢喜。非复得尽智无生智。或曰。除苦根忧根故。除无惭无愧故。除揣食淫爱故。世尊说初禅地离。或曰。谓初禅地离己地中三漏地围绕。或曰。谓初禅地离上地离依方便门。或曰。谓依初禅三行者。取证得果无欲有漏尽。一具缚二倍弃欲。三弃淫欲。以故尔。或曰。谓初禅具三十七品可得。以是故初禅为离。是故说离生喜乐。初禅者次第数为初。顺次数为初。复次次第顺正受。是故说初。成就游处者。谓此中善五阴到得成就。是故说成就游处。复次比丘有觉有观息内净。一心无觉无观。定生喜乐二禅成就游处。彼有觉有观息者。有觉有观已尽故。问曰。如是息一切初禅者。何以故但说息有觉有观。答曰。已说有觉有观息。当知已说一切初禅息。或曰。谓有觉有观难可断离可破难可度。以故尔。或曰。谓彼行者断有觉有观故。修二禅地道以故尔。或曰。谓彼行者息有觉有观。一切初禅息以故尔。或曰。谓有觉有观非上行不可得。世尊说当殷勤息。以故尔。是故说有觉有观息内净者。内者心。净者信。以彼信令心净。是故说内净。尊者婆须蜜说曰。内净有何义。答曰。有觉有观心定时生浊。有觉有观息已便心净。如器中盛水。若热沸浊不定不见面像。若水清凉不沸浊便定见面像。如是有觉有观心定时生浊。有觉有观息已便心净。重说曰。有觉有观心定时生调。有觉有观息已心便净。如水波涌息已水便清。如是有觉有观心定时生调。有觉有观息已心便净。是故说内净。一心者。欲界六种意六识身。初禅四种意四识身。二禅一种意一识身独意地。是故说一心。无觉无观者。非觉观俱。是故说无觉无观。定生喜乐者。初禅地定中生。是故说定生喜乐。问曰。如初禅有定。何以故说二禅地定。或曰。初禅地定故说二禅地定。或曰。谓二禅地定从初禅定中生。从初禅定中来。从初禅定长养。从初禅定所转。或曰。初禅此欲界极近。极近故知此欲界设豪贵处眷属处。初禅亦尔。如此欲界身识现在前。初禅亦尔。如此欲界有觉有观。初禅亦尔。如此欲界出息入息。初禅亦尔。初禅此所娆乱不定。二禅无此娆乱。彼定而定。或曰。谓二禅离声根本。声根本者。是有觉有观。如所说。居土觉观已然后言说。谓二禅离声根本以故尔。或曰。谓二禅说贤圣默然如所说。比丘贤圣默然者二禅是。谓二禅贤圣默然。以故尔。是故说定生离。喜乐二者禅。次第数便有二。顺次数有二。复次次第顺正受。是故说二。成就游处者。谓二禅地善五阴到得成就。是故说成就游处。复次比丘离喜欲无求游。念住正智觉受身乐。谓彼圣说舍念安乐游处。三禅成就游处。彼离喜欲者已断二禅喜故。问曰。如离一切二禅欲者。何以故但说离喜。答曰。已说离喜欲。当知已说离一切二禅欲。或曰。谓喜成患极重过多诸恶以故尔。或曰。谓彼行者断喜故。修三禅道以故尔。或曰。谓彼行者离喜离一切二禅以故尔。或曰。谓喜非上行上不可得。世尊说当殷勤离以故尔。是故说离喜欲。无求游者。已得三禅乐不余求。念住者。护三禅乐故。正智者觉三禅乐。受身乐者。自觉二种乐。猗乐痛乐。谓彼圣说舍者。说者教他。舍者已放舍。问如圣一切地教他已亦放舍。何以故但说三禅。答曰。谓三禅道有娆乱。己地亦有娆乱。道有娆乱者二禅是。于中染污喜娆乱。如罗刹种令彼行者三禅退。此是道娆乱。己地娆乱者。三禅地一切生死最妙乐。是谓己地乱。彼圣教初修行者当正念住。莫令二禅地喜于三禅地退。此亦应正念。莫于中着乐令不至上地。如彼商人主。彼教初行商人。某方有淫家。某处有戏家。某许有酒家。莫入彼家令失钱财。如是圣教初修行者当正念住。莫令二禅地喜于三禅地退。此亦应正觉。莫于中着乐令不至上地。以是故彼圣三禅说及舍。是故说谓圣说。舍念安乐游处三禅者。次第数便有三。顺次数有三。复次次第顺正受便有三。是故说念安乐游处三禅。成就游处者。谓三禅地善五阴到得成就。是故说成就游处。复次比丘乐断苦断。前忧喜已没。不苦不乐护念净。四禅成就游处。彼乐断苦断者。问曰。如除欲界结时苦尽。已三禅除结乐已尽。何以故三禅除结时说苦尽。答曰。本已断断为名。如已解脱解脱为名。如所说。彼如是知如是见。欲有漏心解脱。有有漏无明有漏心解脱。如已未来为名。如所说。大王从何所来。当尔时非是来彼已来也。已取证为名。如所说。菩萨于正受中取证时得等智。如来得尽智无生智时。于欲得无欲无恚无愚痴。善根本已尽尽为名。已正受正受为名。如所说。云何念入慈正受。答曰。欲令众生生乐。已痛痛为名。如所说。彼觉乐痛时知乐痛如是前已断断为名。或曰。二俱永灭故说。二俱者乐根苦根。欲界除欲时。虽有参差未来永灭。彼三禅乐说是苦。谓彼是无常。如世尊契经说。比丘谓无常即是苦。或曰。彼三禅乐痛说如苦。如佛契经说。比丘乐痛当观如苦痛。当观如刺。不苦不乐痛当观如毒蛇。或曰。此出息入息说是苦。彼圣极有苦想。非凡夫地狱苦想。是故说乐断苦断。前忧喜已没者。欲界除欲时忧已尽。二禅除欲时喜已尽。是故说前忧喜已没。不苦不乐者。已除苦乐故。护者出息入息断。不欲求余念净者。八事念净故。问曰。如一切下地无漏念清净。何以故但说四禅念清净。答曰。念离结烦恼故。有念离结不离烦恼。有离烦恼不离结。有离结亦离烦恼。有不离结亦不离烦恼。离结不离烦恼者。三禅无漏念。离烦恼不离结者。四禅世俗念。离结离烦恼者。四禅无漏念。不离结亦不离烦恼者。三禅世俗念及欲界念。是谓念离结烦恼。故说四禅念清净。或曰。念不失不坏故。三禅成败所及。谓彼所依念亦坏。彼四禅一切成败所不及。谓彼所依念亦不坏。是谓念不失不坏故说四禅念清净。或曰。念离内外娆乱故。初禅内有娆乱觉观如火。如此内有娆乱。外娆乱亦及火所烧。二禅内有娆乱者喜如水。如此内娆乱。外娆乱亦及水所渍溺。三禅内有娆乱者。出息入息如刀风。如此内娆乱。外娆乱亦及风所吹。四禅内无娆乱。如此内无娆乱。外娆乱亦不及。是谓念离内外娆乱故。或曰。谓四禅依中犹如齐。上三无漏地。下亦三无漏地。谓四禅依中如齐以故尔。或曰。谓依四禅三行者。取证得果除欲有漏尽。佛辟支佛声闻以故尔。或曰。谓四禅定不移动。普知依度无极。一切依最妙地。以故尔。或曰。世尊为身清净故说依清净。四禅中身清净轻如灯焰。谓所依念亦清净。是谓世尊为身清净故说依亦清净。或曰。谓四禅智边智上智原。或曰。谓四禅四大边色边造色边处所边以故尔。或曰。谓四禅二广。处所广善根广。以是故说四禅念清净。四禅者次第数便有四。顺次数有四。复次次第正受便有四。是故说四禅。成就游处者。谓四禅善五阴到得成就。是故说成就游处。谓世尊契经说。四禅究竟道。初禅广说已。说曰。梵志此说名如来尽根如来所行如来所服。彼不以为究竟。是如来无所著等正觉。如是二禅三禅四禅广说已。说曰。梵志此说如来尽根如来所行如来所服。彼以为究竟。是如来无所著等正觉。问曰。何以故世尊舍三禅。施设四禅究竟道。答曰。此是佛世尊为己故说。彼梵志闻一切恒沙三耶三佛依四禅成无上最正觉。梵志作是念。若沙门瞿昙施设四禅究竟道者。沙门瞿昙应有一切智一切见。若沙门瞿昙不施设四禅究竟道者。沙门瞿昙非一切智非一切见。于是彼梵志到世尊所。到已面相慰劳。面相慰劳已却坐一面。使梵志坐一面已。白世尊曰。唯瞿昙。我欲有所问。听我所问。世尊告曰。当问恣所问。如是说已。白世尊曰。唯瞿昙。说究竟道。云何究竟道。云何沙门瞿昙施设究竟道。世尊为广说三禅已。说曰。是谓梵志如来尽根如来所行如来所服。彼不以为究竟是如来无所著等正觉。四禅广说已。说曰。梵志。此说如来尽根如来所行如来所服。彼以为究竟是如来无所著等正觉。彼梵志闻已意得定。沙门瞿昙。真实一切智一切见。以是故四禅说究竟道。问曰。何以故名如来尽根。答曰。智故得故。如大象于春时见多青草已彼跳象众入池中食藕根。彼见已欢喜以牙掘地。掘地已安足。如是世尊四禅地护行已。掘诸法地安智足。是谓智故得故说如来尽根。彼如来尽根者。立止故说。如来所行者立观故说。如来所服者立止观故说。如佛契经说四禅安乐游处。答曰。根本地易成。佛契经说安乐游处非根本地。及无色难成故。佛不说安乐游处。问曰。云何此地难成。答曰。彼行者欲界行结所缚。依未来现在前。彼一向苦一向迟。如人坚反缚两手。欲令还自解彼一向苦一向迟。如具彼行者欲界行结所缚。依未来现在前。一向苦一向迟。或有行者。观不净恶露或安般。谓观不净者。彼或十年或二十年。观白骨或成此定或不成。谓数出入息。彼或十年或二十年数息已或成此定或不成。谓成此定已。余欲界结不极勤。初禅现在前。彼初禅谓禅中间现在前。一向苦一向迟。彼一地余灭心心数法。余心心数法现在前。灭粗已微现在前。觉俱灭已观俱现在前。如人以木破木以石破石。彼一向苦一向迟。如是行者彼一地中余心心数法灭已。余心心数法现在前。灭粗已微现在前。觉俱灭已观俱现在前。是一向苦一向迟。谓初禅除欲已不勤。二禅现在前。二禅除欲已不勤。三禅现在前。三禅除欲已不勤。四禅现在前。问曰。谓四禅除欲已空处现在前。何以故此地难成。答曰。无色微难觉不可见。或有不信无色。如彼契经。彼居士至尊者阿难所说曰。尊者阿难。我本闻无色已如临深。云何众生名无色。是谓根本地易成故。佛契经说。安乐游处非根本地。及无色难成故。佛不说安乐游处。或曰。谓不勤求除欲可得。如二人乘马一乘不调一乘极调。谓乘不调者彼极勤御。谓乘调者彼不极勤御如是多有众生除欲。或非根本及无色。或根本地。谓非根本及无色者。彼一向勤求行道。谓根本地者。彼不一向勤求行道。以是故说根本地安乐游处。或曰。谓摄四枝五枝定可得。问曰。非根本地及无色有枝耶无枝耶。若有者何以故根本地说枝余不说。若无者此施设所说云何通。彼中说颇有空处。最妙定最妙地枝可得耶。答曰。有如从空处起次第入空处。作此论已。有一说者。非根本地及无色有枝。问曰。若有者何以不说。答曰。应说谓初禅五枝。除喜已增不苦不乐。此五枝说初禅边。谓二禅有四枝。除喜增不苦不乐。此枝说三禅边。谓四禅有四枝。彼四禅边亦无色定。更有说者。根本地有枝余者无枝。问曰。若根本地有枝余者无枝者。是故此中不说。施设云何通。答曰。彼中说觉枝道枝彼是枝。如是说者根本地有枝余者无枝。或曰。谓乐修道可得。如二人俱趣一方。一从水道。二从陆道。虽同至一方。但水道者乐非陆道。如是多有众生除欲。或非根本地及无色。或根本地。虽至一处无余涅槃界。但彼根本者乐非余。或曰。谓根本地现在前时。一切身四大现在前。非根本地。及无色现在前时。心边四大现在前。更有说者。非根本及无色现在前时。一切身四大现在前。但生乐不如根本地。如二人池水浴。一在岸上。一入池中浴。水俱除垢说者为乐。谓池中者如是虽非根本地。及无色现在前时。一切身四大现在前。但彼乐不如根本地。以故尔。或曰。谓二种乐可得。外及内。外乐者。谓从禅起入非根本地及无色。内乐者。谓从禅起还入禅。谓二种乐可得。以故尔。或曰。二种乐可得。猗乐及痛乐。三禅有二种乐。四禅虽无痛乐。但猗乐极妙非彼二种。谓二种乐可得。以故尔。或曰。谓二法等行精进及止。虽一切地增精进。但因定力根本地精进及止等行。以故尔。或曰。谓无恚乐极广大可得。如所说。谓此中无恚此。是极乐以故尔。或曰。谓乐出要道可得。如多有人渡河。或以材浮囊草束。或极大船彼虽俱渡河。但乘船渡者为乐。如是多有众生除欲。或非根本地及无色。或根本地。彼虽同度至涅槃。但彼根本乐出要至涅槃非余地。以是故契经说四禅安乐游处。广说四禅处尽

鞞婆沙论卷第十鞞婆沙论卷第十一

        阿罗汉尸陀槃尼撰

        符秦罽宾三藏僧伽跋澄译

    四等处第三十四

四无量等慈悲喜护。问曰。何以故次禅说无量等。答曰。从禅生故次说等禅。有余功德次说无量等。问曰。无量等有何性。答曰。慈悲护无贪性取彼共有法相应法。欲界色界有五阴性。喜根性取彼共有法相应法。欲界色界五阴性。问曰。若喜是喜根性者。彼婆须蜜施设云何通彼问。慈云何。答言。慈及慈相应痛想行识。云何痛与痛相应耶。答曰。彼说应尔。慈云何。答曰。慈及慈相应想行识应当尔。若不尔者当有意。答曰。彼总说五阴性。四无量等虽痛不与痛相应。但彼想行识相应。此是无量等性。己种相身所有自然。说性已当说行。何以故说无量。无量等有何义。答曰。除戏故说无量等。问曰。若除戏说无量等者。彼四无量等有二戏用。何等除戏。答曰。慈悲除见戏。谓众生多行见。彼多有恚喜护除爱戏。是故除戏说无量等。或曰。除放逸故说无量等。或曰。圣游戏故说无量等。如豪贵者多种种乐戏。如是圣游戏无量等。是谓圣游戏故说无量等。界者欲界系亦色界系。地者七地。欲界依未来禅中间根本四禅。依者依欲界行者慈乐行悲苦行喜悦行护舍行。缘者或有说欲界无量等缘初禅。初禅地缘二禅。二禅地缘三禅。三禅地缘四禅。更有说者已地缘如是说者一切缘欲界。一切缘众生。一切总缘。缘欲界者。或五阴众生缘。或二阴众生缘。若己心住者。五阴众生缘若不己心住者二阴众生缘。意止者四意止。智者性非智与等智相应。定者非与定相应。痛者总三痛相应。乐根喜根护根。问曰。当言过去耶。当言未来耶。当言现在耶。答曰。当言过去当言未来当言现在。问曰。当言过去缘耶。当言未来缘耶。当言现在缘耶。答曰。当言是过去缘。当言是未来缘。当言是现在缘。问曰。当言己意缘耶。当言他意缘耶。答曰。当言他意缘。问曰。当言名缘耶。当言义缘耶。答曰。当言是名缘。当言是义缘。问曰。无量等如说行亦尔耶。为说异行异耶。有一说者。无量等者如说行亦尔。前行慈。是故世尊前说慈悲喜护亦尔。更有说者。无量等者说亦异行亦异。问曰。何以故说亦异行亦异。答曰。或有但行慈等不行余等。问曰。何以故。答曰。无有等渐渐正受。无有顺正受。亦非逆正受。亦非超正受。如无量等解脱。除入一切入亦尔。问曰。何等人能行无量等。答曰。人有二种。一者求恶。二者求功德。求恶者彼终不能行无量等。谓彼至于阿罗汉所亦求恶。何所犯何所失何所过。常诵习持谓求功德者。彼能行无量等。谓彼至于断善根所求功德。问曰。断善根者无功德何所求。答曰。彼断善根者。端正极妙形见本宿行。见已便作是念。本宿行为极妙。如是受极妙果。是谓求恶者不能行无量等。求功德者能行无量等。问曰。行无量等时作何方便。答曰。此慈前从亲起行。一切众生立三品。亲品怨家品中人品。彼亲品复立三品软中上。上亲品者父母尊师。彼前上亲品乐开解欲令彼乐。然此心极恶难御难制难持。于亲极妙意中不住。彼精进勤不舍还摄意。于上亲品开解欲令彼乐。如人以豆投锥。数数投不住。彼精勤不舍。要投令住。如是彼精勤不舍还摄意。于上亲品乐开解欲令彼乐。于上亲品开解已。中亲及软亲开解。然后中品人及濡怨家开解。然后中然后增上怨家品开解欲令彼乐。如一切众生平等如称无欺。乐开解如上亲品。如是至增上怨家品。如是慈成就。如慈悲喜亦尔。护因中品行。问曰。护何以故因中品行。答曰。当舍亲品者憎爱。舍怨家者憎恚。是故前中品开解。此是众生然后舍怨家。问曰。何以故前舍怨家。答曰。恚易除非爱。然后舍上亲。如一切众生平等如称无欺。舍一切众生已。如中品如是至上亲品。如是护等成就。说曰。前行慈。问曰。何以故前行慈。答曰。彼前求欲饶益众生。慈者是饶益相。已饶益众生。彼作是念。当除不饶益事。悲者除不饶益相。饶益众生已除不饶益事。彼作是念。令众生喜。谓众生喜已然后舍众生。更有说者前行悲。问曰。何以故前行悲。答曰。前欲令众生除不饶益事。悲者除不饶益事。已除不饶益事便欲饶益慈者饶益相。如以除众生不饶益事饶益。彼作是念。令众生喜然后舍众生。更有说者。此二无量等各各相怀悲及喜。若前行悲要当次行喜。问曰。何以故次悲要行喜。答曰。如悲令心忧。彼生喜已除忧。若前行喜要次行悲。问曰。何以故喜次要行悲。答曰。如生喜心调然后起悲摄受。问曰。谓欲令众生乐慈。正受用何乐令众生乐开解。有一说者。谓自受乐饮食乐衣被床座乐。以如此乐令一切众生乐开解。问曰。如汝说一切众生不应乐开解。一切众生无有此乐。更有说者。三禅地增上乐众生乐开解。问曰。如汝说谓不得三禅。彼不能令众生乐开解。更有说者。三禅地宿命智忆已众生乐开解。问曰。作如是说。谓三禅地不得宿命智。彼不能令众生开解。更有说者。谓众生乐是彼缘从彼行慈。问曰。作如是说。非一切众生受如此乐。更有说者。有众生乐根现在前。是彼缘从彼行慈。问曰。作如是说。非一切众生乐根现在前。亦非一切众生如是成就乐根。尊者婆须蜜说曰。谓众生乐慈正受。彼定行所缘以何乐令众生乐开解。答曰。谓彼自受安乐。若饮食乐及衣被床卧乐。是彼缘从彼行慈。问曰。此定不应一切众生缘。亦不一切众生受如此乐。重说曰。三禅地增上乐众生乐开解。问曰。此定不应一切众生缘。亦不一切众生得三禅地乐。重说曰。三禅地宿命智忆已众生乐开解。问曰。此定不应一切众生缘。亦不一切众生得三禅地宿命智。重说曰。谓众生乐是彼缘从彼行慈。问曰。此定不应一切众生缘。亦非一切众生乐。重说曰。有众生乐根现在前。是彼缘从彼行慈。问曰。此定不应一切众生缘。亦非一切众生乐根现在前。尊者昙摩多罗说曰。诸尊见诸众生。乐想与慈愍俱有饶益心。愍念众生平等行如曾见彼行者入城村乞食。见无钱财者。及无床卧裸形恶垢弊衣手足。剖裂头发蓬乱手执瓦器。到家家乞下声软语从他。乞索当施贫穷当惠。困厄当给孤。独复见象众马众车众步众。金冠庄饰光曜照目。着妙衣持盖。随从击鼓吹贝作五倡伎。如彼天子。见此二已。食后还至本处。举衣钵洗足。或坐绳木床。身柔软意柔软。坐已以彼苦者安处乐中。令彼苦者亦如此乐。是故说诸尊见众生。乐想与慈愍俱有饶益心。愍念众生平等行如曾所见。问曰。谓欲令众生乐慈正受。彼众生不得乐彼定当言颠倒耶。当言不颠倒耶。答曰。当言不颠倒。欲饶益故。或曰。当言不颠倒。以妙意故。或曰。当言不颠倒。愍众生故。尊者婆须蜜说曰。当言不颠倒。有众生乐根现在前。是彼缘从彼行慈。重说曰。当言不颠倒。有众生乐。是彼缘从彼行慈。重说曰。当言不颠倒。坏恚故。尊者昙摩多罗说曰。诸尊不由彼行慈故。众生得乐。但从彼行除恚。问曰。颠倒行亦除恚。答曰。谓正行除恚非是颠倒谓以余行除恚是不善。或曰。谓彼如是意开解欲令众生苦者。应有颠倒。但彼如是意开解欲令众生得乐。而彼众生不得乐。彼有何过。或曰。谓彼入善心饶益一切众生故。是非颠倒。说曰。此说三思惟。一自相思惟。二总相思惟。三得解思惟。自相思惟者。如色相思惟。色至识相思惟识是谓自相思惟。总相思惟者。如十六圣行是谓总相思惟。得解思惟者。如此无量等解脱。除入一切入。此三思惟中说无量等意解思惟非余。问曰。无量等为遍缘一切众生耶。为有方齐限耶。若遍缘一切众生者。云何不得众生海边。若有方齐限者。此契经云何通。彼四无量等满一切世间成就游。作此论已。有一说者无量等遍。缘一切众生。问曰。云何不得众生海边。答曰。设得一切众生海边当有何咎。佛契经说。四生卵生胎生湿生化生除此已更无众生。如是得众生海边但总相非自相。更有说者。无量等方有齐限。问曰。此契经云何通。彼四无量等满一切世间成就游。答曰。此众生说方为名。更有说者。佛遍缘一切众生声闻辟支佛方有齐限。更有说者。佛辟支佛遍缘一切众。声闻方有齐限。更有说者。佛辟支佛声闻得度无极遍缘一切众生。余声闻方有齐限如是说者。无量等者。是得解思惟。若佛遍缘一切众生者。辟支佛声闻亦尔。若佛方齐限者。辟支佛声闻亦尔。问曰。如无量等遍缘一切众生。何以故。说意与慈俱满东方已成就游。如是南方西方北方一切诸方。意与慈俱满诸方已成就游。答曰。此契经应当尔。意与慈俱满东方。众生已成就游。如是南方西方北方一切诸方。意与慈俱满。众生已成就游。此应当尔。若不尔者当何意。答曰。此众生说以方为名。问曰。颇不发初禅地无量等。能发二禅地无量等耶。有一说者。不可不发初禅地无量等能发二禅地无量等。问曰。何以故不可不发初禅地无量等能发二禅地无量等耶。答曰。谓初禅地无量等。二禅地无量等依方便门。是故不可不发初禅地无量等能发二禅地等。更有说者。可得不发初禅地无量等能发二禅地无量等。如圣道可得。初禅地不发能发二禅地。何况无量等得解思惟。问曰。无量等一地不可得各各次第现在前。余地各各次第能现在前耶。为不耶。有一说者曰。无量等地亦不可各各次第现在前。要从彼一地相似善根现在前。谓次第无量等现在前。无量等现在前已。有如此行慈乐行悲苦行喜悦行护舍行。问曰。初禅地无量等上。速发二禅地无量等耶。于二禅地无量等上。速发初禅地无量等耶。答曰。二禅地无量等上速发初禅地无量。非初禅地无量等上速发二禅地无量等。如学梵书已速学佉楼书。非学佉楼速学梵书。如是二禅地无量等上。速发初禅地无量等。彼定揵度说。云何思惟慈正受。答曰。众生乐。云何思惟悲正受。答曰。众生苦。云何思惟喜正受。答曰。悦众生。云何思惟护正受。答曰。舍是众生。问曰。此云何说正受。答曰。前正受已正受为名。此中证答如前说。如世尊契经说。谓须涅多罗弟子为梵天人上故说法时。不具一切戒行。彼或生四天王中。或生三十三天中。或生炎天。或生兜术天。或生化自在天。或生他化自在天。谓须涅多罗弟子为梵天上说法时。具一切戒行。彼思惟四梵游处。于欲除欲已多游行故梵天中。问曰。如此所说须涅多罗胜非释迦文。何以故。谓须涅多罗弟子具一切戒行彼生梵天中。谓不具一切戒行。彼生欲界六天中。谓释迦文弟子具一切戒行。彼生善处及灭尽涅槃界。谓不具一切戒行。彼生地狱饿鬼畜生中。答曰。此不然。何故应当从契经索次第何因何缘。佛契经说。须涅多罗以无量等。是戒谓为梵天上说法。谓须涅多罗弟子为梵天上说法时。求等能行具足等。彼生梵天中。谓须涅多罗为弟子梵天上故说法时。求无量等不能具足行无量等。彼行增上善根生欲界六天中。复次尔时一切众生各有妙行。谓不行无量等。彼生欲界六天中。何况求无量等不能。发无量等。云何彼增上善根不生欲界六天中耶。是谓此中说不是犯戒及破戒。释迦文学二百五十禁。是戒为无余涅槃故说法。谓释迦文弟子不犯戒不破戒。便生善处亦入无为涅槃。谓释迦文弟子犯戒越戒不具足戒。生地狱饿鬼畜生中。生人恶趣中。是谓契经次第。于是须涅多罗作是念。我不应尔与弟子俱生一处一趣。我宁可增益思惟慈。增益思惟慈已。当生光音天中。于是须涅多罗后时增益思惟慈。增益思惟慈已。生光音天中。问曰。如已成菩萨除诸疾患。何以故自行二禅发于等。为弟子说初禅。答曰。须涅多罗观弟子根本齐限故。或曰。二禅地无量等。无佛法时不可得发。唯有已成菩萨能发。余一切不能。或曰。须涅多罗菩萨作是念。此梵志长夜欲得梵天。常愿梵天究竟梵天。彼作是念。令我等生梵天上近大梵天。须涅菩萨常欲满他愿故。随所欲而为说法。问曰。如三四禅无量等极妙。何以故说二禅地无量等妙。答曰。彼弟子无量等故。说二禅地无量等妙。或曰。为初禅地无量等故。说二禅地无量等妙。或曰。须涅菩萨作是念。彼三禅四禅地无量等。无佛时不可得尊者瞿沙亦尔说。若上地可得无量等者须涅多罗不应说我宁可增益思惟无量等生光音天。此非凡夫地。但佛威神故。令弟子能彼现在前。问曰。何以故说梵游行处。答曰。初梵可得及一切具。依未来已虽初可得。但非是一切具。上地虽一切可得。但非是初。此初禅中亦初可得。亦一切具。是故说梵游行处。或曰。能除非梵故。曰梵游行处。非梵者欲界结。彼能除是谓除非梵游行处。或曰。谓思惟大梵已得梵天王故。曰梵游行处。或曰以梵音说。故曰梵游行处。或曰。梵者。谓如来彼说分别施设显示。故曰梵游行处。问曰。无量等及梵游行处何差别。有一说者。无有差别。无量等有四。慈悲喜护。梵游行处亦四。慈悲喜护。是故无差别。或曰。谓初禅可得。彼是梵游行处。上地可得。彼是无量等。或曰。除非梵故名梵游行处除。戏故名无量等。或曰。除非梵故名梵游行处。除放逸故名为无量等。或曰。三地可依。未来初禅中禅是名为梵游行处。七地可得。欲界未来禅中禅根本四禅。名为无量等梵游行处。无量等是谓差别。如世尊契经说诸比丘。我自知七岁思惟慈心。七成败不来至此世。世成败时我生光音天中。世不成败生余空静梵宫。彼为梵天余处千反作他化自在天子。三十六为释提桓因。无量百千作转轮圣王。说曰。此中七夏月名七岁。说者菩萨极好时多诸善根。地无沙石生诸金银。在中国为人王。彼国极热。离城不远有山林。谓至夏月彼城中人往诣山林。彼菩萨留人守城已。出城亦诣山林。彼人夏四月各各作务。菩萨别至高显处。发无量等。发无量等已。夏四月游行无量等。过夏四月已。谓人出林中已还入城。菩萨出林已亦还入城。彼时菩萨极设大会施与作福欲得食者与食。渴者与饮。裸者与衣。施与屋舍床卧灯明。亦持戒说者菩萨六往反山林七反。或有说者。菩萨命终已生光音天。或有说者。成败时彼命终生光音天。是故此中七夏月名七岁。问曰。若说无量等果生梵天上及光音天中。此应当尔。谓无量等色界果色界法。若说无量等果生他化自在天子释提桓因及转轮圣王此色界善根。彼欲界不受报。何以说无量等果生他化自在天子及释提桓因转轮圣王。答曰。菩萨于三地发无量等。欲界初禅二禅。欲界无量等果生他化自在天子释提桓因及转轮圣王。初禅地无量等果生大梵。二禅地无量等果生光音天。或曰无量等于此故。欲界有出心入心。如市肆中一切杂物可得。欲界亦尔。此欲界乃至尽智无生智有相似相。谓欲界出心入心。由彼果生他化自在天子释提桓因及转轮圣王。根本无量等生大梵天及光音天中。或曰。谓菩萨极设大会时施与作福。欲得食者与食。渴者与饮。裸者与衣。施与屋舍床卧灯明。由彼果作转轮圣王。若持戒者由彼果作释提桓因及他化自在天子。无量等果生大梵天及光音天中。或曰。此佛契经说三福。一者施二者戒三者思惟。此契经说比丘。我作是念。是谁行果。是谁行报。令我大尊神妙。比丘。我作是念。此三行报令我最尊。极大神妙。云何三。一施二御三摄。施者是施福。御者是戒福。摄者是思惟福。彼施福果作转轮圣王。戒福果作释提桓因及他化自在天子。思惟福果作大梵天及光音天。以故尔。问曰。何以故色界一切善根说无量等。思惟福不说余。答曰。谓无量等者果不可烧。如彼契经。天至世尊所以偈问曰

  何物火不烧　　而风不能坏
  水灾坏地时　　何者水不渍

世尊偈答曰

  福火所不烧　　福风不能坏
  福水所不渍

虽非福亦不烧但烧其果。无量等亦不烧。福亦不烧果。以是故佛契经说。色界一切善根中。说无量等思惟福如佛契经说。慈正受时火所不烧。毒所不中。刀所不伤。不由他横死。问曰。何以故慈正受时。火所不烧。毒所不中。刀所不伤。不由他横死。尊者婆须蜜答曰。彼定无诤。是故诤不能动。重说曰。彼定极大威神。是故诸天所护。重说曰。色界四大现在前故。彼患不能动。如彼色界四大充满。身体合一极厚如石。是故彼患不能动。是谓慈正受时火所不烧毒所不中刀所不伤不由他横死。问曰。悲喜护正受时此患能动耶。不动耶。若动者何以故慈正受不动。悲喜护而动耶。若不动者何以故但说慈正受不动。不说悲喜护正受。作此论已。答曰。悲喜护正受亦不动。问曰。何以故说慈正受不动。不说悲喜护正受耶。答曰。应说如说慈悲喜护亦尔。若不说者。是世尊有余言。此现义义门义度义略当知是义。或曰。悲喜护虽正受时不动。但起时或能动。慈起亦不动。或曰。悲喜护虽正受时不动。起或能伤坏。慈起亦不伤坏。或曰。根本悲喜护正受时虽不动。但悲喜护方便可动。慈方便亦不动。说者有一人。得欲界慈方便。彼以不知犯于王法。为执事所收将送王所。王当尔时乘大象出城。遥见彼人顾问左右。此是何人。臣白王曰。此人犯于王法。愿王罚之。王时手执古律省其过状。此人所犯法。王应手行刑。王怒隆盛以剑投之。彼人见王嗔恚。寻方便行慈正受。如豆投木即还堕地。彼剑如是投身即还堕王足下。时王惊怖问彼人曰。汝行何术。作何蛊道。施何幻化。彼人对曰。大王。愿王欢喜。我不作术不作蛊道及以幻化。王问曰。若不尔者此云何。彼人对曰。我见王嗔。于天王所行于慈心。是故此剑不害我身。是故可知慈方便亦不动。况根本慈耶。以是故说慈正受时不动。不说悲喜护。如佛契经说。慈修习多修习能除诤。悲修习多修习能除恚。喜修习多修习能除不乐。护修习多修习能除害。问曰。无量等能除结耶。不能除结耶。若无量等能除结者。此定揵度云何通彼说。慈除何系结。答曰。无处所。悲喜护除何系结。答曰。无处所。若无量等不除结者。此契经云何通。作此论已。答曰。无量等不能除结。问曰。若尔者定揵度所说善通。此契经云何解。答曰。除结有二种。一者须臾除。二者究竟除。如须臾除者。是佛契经所说。慈修习多修习能除诤。悲修习多修习能除恚。喜修习多修习能除不乐。护修习多修习能除害。如无量等不能究竟除结者。如定揵度所说。如是此二说为善通。如佛契经说。慈修习多修习除淫诤。护修习多修习亦除诤。问曰。何诤慈能除。何诤护能除。答曰。诤有二种处诤非处诤处。诤者慈能除。非处诤者护能除。复有二种诤。一者欲舍众生命。二者系众生。谓舍众生命慈能除。谓系众生者护能除。如是诤慈除。如是诤护除。如佛契经说。不净修习多修习能除淫欲。慈修习多修习除淫欲净。问曰。何淫不净能除。何淫慈能除。答曰六种欲。一色欲。二处欲。三行欲。四淫欲。五更乐欲。六庄饰具欲。色欲者以不净除。处欲者以慈除。行欲者不净除。更乐欲者以慈除。淫欲者以不净除。庄饰具欲者以慈除。如是欲不净除。如是欲以慈除。如世尊契经说。如是修习慈心解脱。如是多修习能得阿那含果。或复上得。问曰。如无量等不能除结。何以故说如是修习慈心解脱。如是多修习能得阿那含果。或复上得。答曰。此佛契经以圣道名说慈。佛说圣道多种名。或以痛为名。或以想为名。或以思为名。或以意为名。或以信为名。或以精进为名。或以念为名。或以定为名。或以慧为名。或以灯为名。或以我为名。或以石山为名。或以华为名。或以水为名。或以痛为名者。如所说。比丘觉已此苦知如真。此习尽道知如真。是谓痛为名。或以想为名者。如所说。无常想修习多修习能除一切淫欲。一切色欲。一切无色欲。一切无明。一切自慢。是谓想为名。或以思为名者。如所说。未那若思及行黑黑报。谓思能除。是谓思为名。或以意为名者。如所说偈

  当制意入处　　谓无所有缘
  终不染着世　　可受一切供

是谓意为名。或以信为名者。如所说偈

  信能度流　　不放逸海　　真谛除苦
  慧应清净

如所说。舍利弗信成就。若比丘比丘尼除去不善修行于善。是谓信为名。或以精进为名者。如所说。阿难精进能转成道。如所说。舍利弗圣弟子成就精进力。除去不善修行于善。是谓精进为名。或以念为名者。如所说。我说一切中念。如所说。舍利弗圣弟子成就于念。如守门人。除去不善修行于善。是谓念为名。或以定为名者。如所说偈

  定者是道　　非定非道　　定以自知
  五阴兴衰

如所说。舍利弗圣弟子成就三三昧。须除去不善修行于善。是谓定为名。或以慧为名者。如所说偈

  慧为世间妙　　能趣有所至
  能用等正智　　生老病死尽

如说所说慧过一切法上。如所说。诸妹圣弟子以慧刀断一切结缚使恼缠。重断打重打割剥。是谓慧为名。或以灯为名者。如所说偈

  勤修不放逸　　受摄及调御
  慧者能然灯　　痴闇不能坏

是谓灯为名或以我为名者。如所说。比丘我者圣八道。是谓我为名。或以石山为名者。如所说。比丘大石山者坚固常住不坏。一切同一体等见是。是谓石山为名。或以华为名者。如所说。比丘生七觉花者七觉是。是谓花为名。或以水为名者。如所说。比丘成就八味水者圣八道是。是谓水为名如此佛说圣道多种名。如是佛契经说。圣道以慈为名。或曰。谓慈意慈解脱计慈意方便。或凡夫时求阿那含果。或圣人时求阿那含果。谓凡夫时求阿那含果者。彼除欲界结时得慈意解脱。彼若取证彼得阿那含果。谓圣人时求阿那含果。除欲界结得阿那含果。于阿那含果上得慈意解脱。以是故说。如是修慈意解脱。如是多修习得阿那含果。或复上得。但无量等不除结。问曰。无量等何者最妙。有一说者。慈为最妙。谓慈正受一切众不能伤害故。更有说者。悲为最妙。谓佛发于大悲而说法。问曰。何故但说大悲而不说大慈大喜大护。答曰。应说如说大悲。大慈大喜大护亦尔。谓从佛意中功德可得尽应说大。何以故。佛世尊无量愍心饶益心善心。是故谓从佛意中功德可得尽应说大。更有说者。此不应难。何以故。若悲即是大悲者可难。但悲异大悲异。问曰。若悲异大悲异者。悲及大悲何差别。答曰。即以名为差别。一者悲。二者大悲。或曰。地亦有差别。悲在七地。大悲根本第四禅地。或曰。意亦有差别。悲佛辟支佛声闻同。大悲但佛非余。或曰。身亦有差别。悲者男女身可得。大悲者男身可得非女身。或曰。除结亦有差别。悲无贪。善根能除贪。大悲无愚痴。善根能除痴。或曰。行亦有差别。悲者能悲不能救。大悲者亦能悲亦能救。如二人在河岸上。彼时河中有漂溺人。彼一人意虽欲拔济。而无有力但索掌而住。彼第二人有意亦有力。拔济彼人着安隐处。如彼一人见已索掌而住无力者。悲亦如是。如彼第二人有意亦有力拔济彼人着安隐处者。大悲亦如是。尊者昙摩多罗说曰。诸尊佛世尊大悲。从久远来极微入遍一切入等摄。一切众生声闻何能悲。及色无色界众生

问曰。何以故说大悲。答曰。以大贾得故名大悲。非如声闻道以一施以一人故。亦非如辟支佛道一杨枝施一把施故。但一切极妙事极爱物施。除非己有。然后可得。是谓大贾得故名大悲。或曰。生大身故名大悲。非如声闻道辟支佛道不具身可得。但彼大士三十二相八十种好庄严其身。紫磨金色圆光一寻。梵音声妙如迦毗陵鸟。视之无厌。是谓生大身故名为大悲。或曰。以大方便求得故名大悲。非如声闻道一种二熟三解脱。亦非如尊者舍利弗六十劫中增益智慧。亦非如辟支佛百劫中增益智慧。但具足三阿僧祇劫。修无量苦行然后可得。是谓大方便求可得故名为大悲。或曰。极多饶益众生故名为大悲如此众生愿求佛道。愿求辟支佛声闻道。得大富生豪贵家。颜貌端正生天上人中。彼一切皆由大悲。是谓多饶众生故名为大悲。或曰。堕大堑众生能拔济之故名为大悲。如佛见众生堕于五趣而度脱之安处道果。彼一切皆由大悲故。是谓堕大堑众生能拔济故名为大悲。或曰。能动大护山故名为大悲。佛世尊于四禅地不共游处名为大护。谓佛护现在前时。尔时一切众生地狱饿鬼畜生炽燃。如甘蔗竹[竺-二+韋]稻麻。丛林炽燃。佛于彼处心无倾动。如大悲现在前已。尔时佛身极坚固力。大悲能动如风吹芭蕉树。是谓能动大护山名为大悲。或曰。以大士能入考掠中故名为大悲。如佛化作末罗力士形。或作瓦师形。或作乞人形。或作妓女形。手牵难陀至五趣中。为鸯崛魔故。回前地令后广。回后地令前广。佛常定不乱。口出广长舌而自覆面。极成就惭愧。为女人现阴马藏。舍妙禅乐。舍极妙佛法。为教化故。过百千亿铁围山大铁围山至恒沙国土。一切由大悲故。是谓大士能入大考掠中名为大悲。如世尊律所说。世尊为众生慈满已而说法。问曰。谓世尊为众生慈满故而说法。彼众生得乐耶。不得乐耶。若众生得乐者。何以不以慈满一切地狱饿鬼畜生天人。而为说法。若彼众生不得乐者。此偈云何通

  如鬼心念恶　　若往着于人
  不触亦不害　　能令生痛畏

彼鬼心念恶者。能动恶果。况佛心念善不动善果耶。作此论已。说曰。世尊为众生慈心满为说法。彼众生得乐。问曰。若乐者何以故。不以慈满一切地狱饿鬼畜生天人。而为说法。答曰。世尊观众生行转不转。谓众生作转行。为彼慈满而说法。谓众生作不转行。不为慈满而说法。更有说者。世尊为众生慈满说法者。彼众生不得乐。问曰。若众生不得乐者。此偈云何通

  如鬼心念恶　　若往着于人
  不触亦不害　　能令生痛畏

答曰。佛世尊无量种慈满。或以神足。或现爱缘。或知乐。或善细滑。或清凉影。或以神足者。如所说。世尊最后游世间。至波婆国阎浮林精舍。波婆国人闻世尊游世间。到此波婆国阎浮精舍。波婆国人闻已。聚集一处共设要令。我等尽当往见世尊。若不往者。当罚旧金钱五百枚。彼设如是要令已。一切往诣世尊所。尔时大臣留枝。于世尊所无敬信意。彼亦往至世尊所。彼时阿难遥见大臣留枝来。见已告言。善来。善哉善哉。留枝。汝能来见世尊。此世尊具足无上福田。不久无常所坏。留枝大臣曰。阿难。我不故来见沙门瞿昙。我但不违亲里要令故耳。尊者阿难谓留枝。不违亲里何等要令。大臣留枝曰。尊者阿难。我等亲里聚集一处共设要令。我等尽当往见世尊。若不往者当罚旧金钱五百枚。尊者阿难。我宁与旧金钱五百枚。不愿来见沙门瞿昙。但我作是念。无令于亲里有诤。于是尊者阿难牵大臣留枝臂。至世尊所。到已白世尊曰。唯世尊。此大臣留枝。本旧亲里。然于世尊无信敬心。唯愿世尊。善为说法。令于世尊有信敬心生于欢喜。彼留枝心行爱志乱不定。诸佛世尊终不为乱志者说法。彼时世尊离处不远。化作沸屎地狱。深广无量。令彼举声。有大臣名留枝。于世尊所无信敬心。彼命终已当生此中。大臣留枝见大地狱。闻声已恐惧生厌。佛世尊知彼恐惧生厌已。随顺说极妙法。大臣留枝闻法已。远尘离垢诸法法眼生。此佛以大慈满大臣留枝。问曰。云何说慈满。答曰。彼神足是。复次或以神足。如所说。调达劝阿阇世王。有象名檀那波勒。以清酒饮之令醉。放使奔趣害于世尊。彼时象遥见世尊。便走趣向彼。时世尊遥见象来。见已左右面化作极高墙。后化作极大涧。深百千丈。上化极大山雷声而下。在前化五大师子。彼象见五大师子已。极大恐怖回视左右。面有极大墙。还回视后有极大涧。深百千丈。而仰视大火山雷声而下。见已谓生一切世火燃想。佛世尊见象大畏惧已。还摄却五大师子。却五大师子已。唯见佛足下清凉。见已至世尊所。到已头面礼世尊足。以鼻投世尊足。彼时世尊诸相庄严紫磨金色。满五千福祐一切。世尊以右手摩象头。摩象头已醉便解。醉解已。世尊为说偈曰

  象莫害大龙　　象龙出世难
  象莫害大龙　　终不生善处
  不应捶而捶　　无恚而生恚
  当受十倍报　　速疾往生彼
  当受极苦痛　　身体亦毁坏
  当遭困重疾　　心乱志恼恶
  或遭灾困厄　　为他所诽谤
  或亲戚离别　　钱财尽亡失
  居宅诸所有　　为火所焚烧
  身坏无有慧　　当生地狱中

彼象闻此偈已。眼便泪出。佛为作象音而说法。彼象闻佛说法。命终生三十三天。此佛为象故慈满。问曰。此中云何慈满。答曰。即彼神足是。谓神足或现爱缘者。如所说。梵志有一儿守稻田。天大瀑雨为雹所杀。及坏稻田。彼梵志以二俱丧故。便意乱生狂裸形而走。乃至舍卫阿那邠邸园。彼梵志应从佛化。世尊遥见梵志从远而来。见已作是念。今此时恒沙佛为说法者不能令度。彼时世尊离彼不远。化作稻田及彼一子。梵志见此二已还得本心。彼作是念。此是我子及以稻田。令我常抱忧患。见已便至世尊所。到已头面礼世尊足。却坐一面。彼于世尊有信敬心内怀欢喜。世尊随顺为说妙法。彼梵志闻佛说法。远尘离垢得法法眼生。此佛为梵志慈满。问曰。此中云何慈满。答曰。即彼现爱缘是。复次现爱缘者。如所说。婆斯吒女梵志有六子。命终念子忧戚。意乱生狂裸形而走。乃至舍卫阿那邠邸园。彼女梵志应从佛化。世尊遥见女梵志从远而来。见已作是念。今此时若恒沙佛为说法者不能令度。彼时世尊离彼不远化作六子。女梵志见六子已逮得本心。此是我子令我常抱忧患。彼有惭愧。便长跪而坐。彼时世尊告阿难。汝阿难取郁多罗僧与彼女梵志。如是世尊。彼尊者阿难受世尊教已。取郁多罗僧与女梵志。女梵志取阿难郁多罗僧被着。至世尊所。到已礼世尊足。礼足已却住一面。彼于世尊有信敬心。内怀欢喜。世尊随顺为说妙法。女梵志闻佛说法。远尘离垢诸法法眼生。此佛为彼女梵志故慈满。问曰。此中云何慈满。答曰。即彼现爱缘是。是谓现爱缘。或现智药者。如所说。摩诃先优婆夷。请佛及僧供养医药。彼时有一比丘。得病服药。医教敕当服肉汁。彼病比丘语侍病者。贤者汝语摩诃先优婆夷。某比丘有患服药。当须肉汁。彼时侍比丘者。便至摩诃先优婆夷所。到已语摩诃先优婆夷。妹当知。某比丘遇患服药。当须肉汁。彼摩诃先优婆夷告使人曰。汝持此物往买肉与彼比丘。彼使人持物往周遍波罗奈城。索肉不能得。说者彼曰。梵摩达王生一童男。尽敕城内不得杀生。彼使人还至摩诃先优婆夷所。到已白摩诃先优婆夷曰。大家当知。周遍城中求索肉不可得。摩诃先优婆夷作是念。此为灾比丘得患而服药。若不得肉或能命终。便持利刀入屋中。割身软肉与使人。汝使人。自煮与彼比丘。彼使人如所敕持与比丘。彼比丘不知。持往与病比丘。彼病比丘亦不知而服。至病得愈。摩诃先优婆夷患身疼痛。彼时摩诃先优婆夷。夫少有事为出行不在。彼摩诃先优婆夷夫还自问内人曰。摩诃先今所在。内人对曰。大家。摩诃先在屋中极患苦痛。彼时摩诃先夫闻已极嗔恚无有敬心。彼作是说。若施者不知。受者亦不知耶。我当往向佛论之。于是摩诃先夫至世尊所。彼时世尊无量百千众前后围绕而为说法。摩诃先夫见已作是念。今不得论。明当请世尊会。然后当论。作是念已。便前至世尊所。到已礼世尊足礼足已却坐一面。彼时世尊为摩诃先夫。无量方便而为说法。劝进等劝进令欢喜等欢喜。无量方便为说法。劝进等劝进令欢喜等欢喜。默然住。彼时摩诃先夫从座起叉手向世尊。白世尊曰。唯世尊。明设微小会。愿世尊及僧愍故当受。世尊受彼摩诃先夫请默然而住。于是摩诃先夫知世尊默然可已。礼世尊足绕世尊已。还本所止。到已即彼夜具诸肴膳。设种种净妙供馔。办已便白时至。彼时世尊晨着衣服。诸比丘前后围绕。往诣彼摩诃先夫舍。到已就座。世尊知而问内人。摩诃先优婆夷今为所在。内人曰。唯世尊。摩诃先优婆夷行来断。极患苦痛在屋中。佛世尊知内缘起。知外亦如是。于是世尊屈伸臂顷。至雪山上取药来已摩着疮上。着疮上已。告摩诃先优婆夷夫曰。呼摩诃先优婆夷出。世尊呼汝。唯然世尊。摩诃先夫受世尊教已。便至摩诃先所。到已语摩诃先。世尊呼汝。闻世尊呼疮即平服同一色。闻已于世尊所倍增信敬。内怀欢喜至世尊所。到已礼世尊足却住一面。世尊随顺为说妙法。摩诃先优婆夷及诸眷属闻说法已。远尘离垢诸法法眼生。此世尊为摩诃先优婆夷故慈满。问曰。此中云何慈满。答曰。即彼智药。复次智药者。如所说。彼时愚痴琉璃王。破迦维罗卫城。将彼释种极妙六女。彼在堂上而自夸说。我能坏汝亲族令无遗余。彼释女对曰。王有宿福。我亲族见谛尽是圣人。但王不应全命而来。彼王作是念故。能为彼敢有所言。彼王舍于后世无有慈心。截彼释女手足已弃着堑中。彼释种女尽应佛化。彼世尊为教化故。便至彼处见彼遭无量苦患。见已作是念。今此时此释六女若恒沙佛为说法者。彼患斯苦不能令受化。佛世尊知内缘起。知外亦如是。于是世尊屈申臂顷。至雪山上取药来已。摩着疮上。摩着疮上已。苦痛即除便生乐痛。生乐痛已。世尊随顺为说妙法。彼六释女闻说法已。远尘离垢诸法法眼生。此世尊为六释女慈满。问曰。此中云何慈满。答曰。即彼智药是。是谓智药。或以更乐者。如所说。世尊游诸房到一房舍。世尊见彼房中有一比丘。遇患苦痛独自无伴。眠大小便中不能起居。世尊知而问比丘。何以故遇此患独自无伴。病比丘质直白世尊曰。唯世尊。我窳惰不能看视他。他亦不看视我。唯世尊我无所依。唯善逝我无所怙。世尊告曰。比丘。汝不为我故出家学道作沙门耶。比丘曰。唯然世尊。唯然善逝。世尊告曰。比丘。我是汝所依及天世间。彼时世尊于彼卧处徐徐扶起。将出外安徐令卧。彼时世尊还入房中。出彼荐席除大小便。泥治卧屋更布新荐席。洗浴病比丘已。更着新衣浣濯故衣。还将入房。徐徐卧新床褥上。以手摩身世尊告曰。比丘。若汝不增勤修不到欲到不获欲获不证欲证者。比丘但更遭重患复甚于此。如世尊以手摩病比丘。所苦即除便得乐痛。得乐痛已。世尊随顺为说妙法。比丘闻说法已。远尘离垢。诸法法眼生。此世尊为彼比丘故慈满。问曰。此中云何慈满。答曰。彼更乐是。复次更乐者。如所说。世尊游耆阇崛山一方。调达亦在一方。彼时调达遭重头痛不可堪忍。彼时世尊以具足相好紫磨金色满百千福手。贯彼山摩调达头。除一切苦痛便得乐痛。得乐痛已。调达作是念。是谁之恩。彼还顾见是世尊手。见已说曰。善哉悉达。善学此医。以此医方足得生活。此世尊为调达故慈满。问曰。此中云何慈满。答曰。即更乐是。是谓更乐。或以凉冷影者。如所说。世尊及尊者舍利弗同游一处。尊者阿难在佛后执拂拂佛。彼时有鸟为鹰所逼。怖畏飞趣尊者舍利弗影中住。身战如独摇树。彼鸟离舍利弗影。飞至佛影中无恐畏。阿难见已叉手白佛曰。甚奇世尊。如此鸟在尊者舍利弗影中时。身战如独摇树。离舍利弗影。至世尊影已便无恐畏。世尊告曰。如是阿难。如是阿难。舍利弗比丘虽离于杀不极清净。是故鸟住影中。身战如独摇树。阿难。我于三阿僧祇劫离于杀。极具足清净行。是故鸟住我影中而无恐怖。此世尊为彼鸟故慈满。问曰。此中云何慈满。答曰。即凉冷影是。复次凉冷影者。如所说。有一贼被截手足弃着堑中。彼贼世尊应化。世尊作是念。若此时恒沙佛为一贼说法者。不能度彼。时世尊往至贼所。到已彼贼在世尊影中。即离苦痛便得乐痛。得乐痛已。世尊随顺为说妙法。贼闻法已。远尘离垢诸法法眼生。此世尊为贼故慈满。问曰。此中云何慈满。答曰。即凉冷影是。是谓凉冷影。如世尊无量种慈满非一种。以是故律说。世尊慈满众生而说法。如世尊契经说。四种人受于梵福。谓人未曾立处。以如来舍利立作鋀婆。是谓初人受于梵福。复次谓人未曾立处。作房舍已施招提僧。是谓二人受于梵福。复次谓人若有斗乱。僧而和合之。是谓三人受于梵福。复次谓人心与慈俱满一方已成就游。如是二三四四维上下满一切诸方已。心与慈俱成就游。如是心与悲喜护俱满一方已成就游。如是二三四四维上下满一切诸方已成就游。是谓四人受于梵福。譬喻者说曰。此非佛契经所说。亦非梵福。佛契经说。无量等是梵福。何以故。谓无量等与果等。如此受梵福。谓金刚座及转法轮。从天下处立鋀婆。如是彼立小小鋀婆。得梵福与等等耶。如此受梵福。谓竹园只桓林深邃林立大僧坊。如是彼立小小房。得梵福与等耶。如此受梵福。谓调达斗乱。僧而和合之。如是彼拘舍弥比丘小小诤。而和合之得梵福。与等耶。是故非佛契经。亦非梵福。佛契经说。无量等亦是梵福。如是说者是佛契经说。亦是梵福。问曰。如此果不与等。答曰。饶益他故。世间福相。如无量饶益他。谓修无量等。如是此亦无量饶益他。谓未曾立处。以如来舍利立鋀婆。谓因彼处百千众生修善身口意行。供养世尊缯彩华盖幢幡伎乐碎末涂香。愿求佛道声闻辟支佛道。得大富生豪贵家。颜貌端正生天上人中。观此极有饶益。如此无量极饶益他。谓发于无量等。此亦如是。无量饶益他。谓未曾立处作房已。施与招提僧。谓因彼处百千众生修善身口意行。诵习读者问者教者。思惟契经律阿毗昙。思惟静默除欲界结。除色界无色界结。得须陀洹斯陀含阿那含阿罗汉果。为佛法僧故佐助众事。愿求佛道声闻辟支佛道。得大富生豪贵家。颜貌端正生天上人中。观此极有饶益。如此无量极饶益他。谓发于无量等。此亦如是无量饶益他。谓和合斗乱僧者。如僧斗乱坏。尔时未取证不取证。未得果不得果。不能除结。不得漏尽。亦不诵习契经律阿毗昙。亦不思惟契经律阿毗昙。亦不思惟静默。不除欲界结。亦不除色无色界结。不得须陀洹斯陀含阿那含阿罗汉果。三千大千世界不转法轮。至首陀会天。意乱。谓和合斗乱僧已。未取证取证得果。能除结得漏尽。诵习契经律阿毗昙。思惟契经律阿毗昙。亦思惟静默。除欲界结。除色无色界结。得须陀洹斯陀含阿那含阿罗汉果。三千大千世界转于法轮。至首陀会天。意亦不乱。观此极有饶益。或曰。谓未曾立处以如来舍利立鋀婆者。如来是梵因。彼处受梵福。谓未曾立处作房施招提僧。因梵行人处受梵福。谓和合斗乱僧者。谓圣道因。彼处受梵福。尊者婆须蜜说曰。谓未曾立处以如来舍利立鋀婆。以四事故受梵福。云何为四。开极妙意。广出财物。及立舍利。所作已讫。谓未曾立处作房施招提僧。以四事故受梵福。开极妙意。广出财物。所作已讫。诵习禅思未定得定。谓和合斗乱僧。以四事故受梵福。除口四过行四净口。除诸非法住于施法。谓修无量等。以四事故受于梵福。离诤不诤。除去五盖。色界果封在色界。问曰。梵福福为几数。有一说者。谓所因行得转轮王。此是梵福数。更有说者。谓所因行得天帝释。是谓梵福数。更有说者。谓所因行得他化自在天子。是谓梵福数。更有说者。谓所因行得大梵。是谓梵福数。更有说者。世败还成时。一切众生所因行施设此大地。是梵福数。更有说者。梵天请世尊转于法轮。圣大梵请佛所转法轮受福。是梵福数。问曰。大梵不隐没无记心请佛世尊。云何受梵福。有一说者。谓始发梵天我当往请佛世尊。即彼时大梵天受梵福。此者不论。何以故。如汝所说应不作行而受报。问曰。若不尔者此云何。答曰。大梵天请世尊转法轮。大梵天闻已便作是念。我请故佛转法轮。彼以此怀欢喜心。发极妙善愿。彼时受梵福。更有说者。除已成菩萨。余一切众生所受福。此是梵福数。如是说者名梵福者。此称誉赞叹。但梵福者无量不可计阿僧祇不可数。如世尊契经说。慈修习多修习生遍净天。悲修习多修习生空处。喜修习多修习生识处。护修习多修习生不用处。问曰。若说慈修习多修习生遍净天者。此应尔。谓慈果报在遍净。谓说悲修习多修习生空处。喜修习多修习生识处。护修习多修习生不用处者。此不应尔。何以故。此是色界功德善根。不应受无色界报。何以故说悲修习多修习生空处。喜修习多修习生识处。护修习多修习生不用处。有一说者。弥勒下已当为说之。余者不能。或曰。为相似故说。慈是乐行乐根。一切生死中最妙。彼三禅中可得。是故佛说修慈生遍净。悲者能呵责坏色。空处亦呵责坏色。是故佛说修悲生空处。喜者悦行。识处意亦悦行。是故佛说修喜生识处。护者能舍不用处。亦说名为舍。是故佛说修护生不用处。或曰。彼行者令意悦乐故。或有行者欲得三禅。或欲得空处识处不用处。谓欲得三禅者。彼除欲界结。意不乐不悦。除初禅欲不乐不悦。于二禅除欲时。三禅现在前意悦乐。谓欲得空处者。彼除欲界欲。意不乐不悦。乃至三禅除欲。意不乐不悦。于四禅除欲时。空处现在前意悦乐。谓欲得识处者彼除欲界欲。意不乐不悦。乃至四禅除欲。意不乐不悦。谓空处除欲时。识处现在前意悦乐。谓欲得不用处者。彼除欲界欲。意不乐不悦。至空处除欲。意不乐不悦。于识处除欲时。不用处现在前意悦乐。是谓行者令意悦乐故。以故尔。或曰。此中说觉支道支。谓觉支道支者能除二禅。彼说慈为名。谓觉支道支除四禅。彼说悲为名。谓觉支道支除空处者。彼说喜为名。谓觉支道支除识处者。彼说护为名。是谓说觉支道支。以故尔。或曰。断异学意故。异学无色中计解脱想。于无量等中说道想。谓异学无色中计解脱想者。彼世尊说无等量共同。尊者瞿沙亦尔说。异学于离中者痴。于不离中计解脱想。谓计解脱想者。彼世尊说无量等共同。广说四无量等处尽

鞞婆沙论卷第十一鞞婆沙论卷第十二

        阿罗汉尸陀槃尼撰

        符秦罽宾三藏僧伽跋澄译

    四无色处第三十五

四无色者。空处识处不用处有想无想处。问曰。何以故作此论。答曰。断他意故作此论。或有欲令无色中有色。或有欲令无色中无色。鞞婆阇婆提欲令无色中有色。育多婆提欲令无色中无色。问曰。鞞婆阇婆提何意欲令无色中有色。答曰。彼从佛契经起无色中有色。彼言。世尊契经说。名色缘识。识缘名色。无色中有识。若无色中有识者。亦当应有色。更余契经说。寿暖识此三法常合终不相离。此三法不可得别施设。若此三法不可得别施设者。无色中有识。若无色中有识者。亦当应有暖。暖者即是色。余契经世尊说。若作是说。我离色离痛想行。独施设识。若来若住若生若终。此不应作是说。无色中有识。若无色中有识者。亦当应有四识住。复更说诘责事。若无色中无色者。谓从欲界色界终生无色界。彼或八万劫色永断。若从彼终生欲界色界。八万劫色永断还复生。若八万劫色永断还复生者。应阿罗汉入无余涅槃界。一切有为行永断后亦当还生。若阿罗汉入无余涅槃界。一切有为行永断后亦当还生者。应无解无脱无离无出要。莫言有咎。是故无色中有色。以此契经证故。鞞婆阇婆提说无色中有色。问曰。育多婆提何意欲令无色中无色。答曰。从佛契经起。欲令无色中无色。彼言。世尊契经说。彼息解脱度色至无色。如是像正受身作证成就游。若度色至无色者。是故无色中无色。更余契经说。离欲至色。离色至无色。若离色至无色者。是故无色中无色。更余契经说。一切度色想。灭有对想。不念杂想。无量空是空成就游。若度一切色想者。是故无色中无色。更余契经禅品中说。谓得可得有可有。若色若痛想行识。彼观此法如病如痈如刺如箭如毒蛇。观无常苦空非我。无色品中说。谓得可得有可有。若痛若想行识。彼观此法如病如痈如刺如箭如毒蛇。观无常苦空非我。若禅品中说。色无色品中不说色者。以是故可知无色中无色。复更说诘责事。若无色中有色者。断法次第不可知。谓诸有法在欲界。此法在色无色界者。如是断法次第不可知。若断法次第不可知者。究竟断法不可知。因断法次第故。至究竟可施设。若至究竟不断者。应无解无脱无离无出要。莫言有咎。是故无色中无色。以此契经证故。育多婆提说无色中无色。如是一说如是二但说。如是无色中无色好。问曰。若无色中无色者。此育多婆提。云何通彼鞞婆阇染提所说契经证。答曰。此契经说有意可通。问曰。有何意云何通。答曰。佛世尊或以欲界故说契经。或色界故。或无色界故。或欲界色界或色无色故。或三界故。或离三界故。欲界故说非色无色界者。如所说。三界欲界恚界害界。此契经欲界故说。非色无色界。为色界故说。非欲界非无色界者。如上禅品所说。此契经色界故说。非欲界非无色界。无色界故说非欲界非色界者。如上无色品所说。此契经无色界故说。非欲界非色界。欲色界故说非无色界者。如此契经名色缘识识缘名色。此契经欲色界故说。非无色界。何以故。此欲色界中有色。是故此名色缘识识缘名色。无色中无色。是故彼名缘识识缘名。以是故此契经欲色界故说。非无色界。色无色界故说非欲界者。如禅经所说经意生经。此契经色无色界故说非欲界。三界故说者。如所说。欲界色界无色界。此契经三界故说。离三界故说者。如所说。比丘。我当说涅槃及涅槃道。此契经离三界故说。如所说。寿暖识。此三法常合终不相离。此三法不可得别施设者。此契经亦欲色界故说。非无色界。何以故。此欲色界中有色。是故此三法常合终不相离。此三法不可得别施设。无色中无色。是故彼寿识此二法常合终不相离。此二法不可得别施设。是谓此契经意之所通。如汝所说。此契经三法常合终不相离。不可得别施设者。此三法亦可得别施设。界故入故阴故。界别施设者。寿者法界所摄。暖者色界所摄。识者七意界所摄。入别施设者。寿者法入所摄。暖者触入所摄。识者意入所摄。阴别施设者。寿者行阴所摄。暖者色阴所摄。识者识阴所摄。如是此三法不能常合。亦可别施设。界故入故阴故。莫作是说。此契经三法常合终不相离。此三法不可别施设。如所说。若作是说。我离色离痛想行。独施设识。若来若往若生若终。此不应作是说者。此契经亦欲色界施设说。何以故。此欲色界中有色。是故此识四识住故施设。无色界中无色。是故彼识三识住故施设。谓作是说。我除四识住独施设识。此终不能施设。谓除一识住识。三识住故施设。彼能施设。如所说若无色中无色者。谓从欲色界终生无色界。彼或八万劫色永断。若从彼终生欲界色界。八万劫色永断还复生。若八万劫色永断还复生者。应阿罗汉入无余涅槃界。一切有为行永断后亦当还生。若阿罗汉入无余涅槃界。一切有为行永断后亦当还生者。应无解无脱无离无出要。莫言有咎。是故无色中有色者。答曰。此不应通。此非契经非律非阿毗昙。不可以世间譬喻坏贤圣法。世间喻异。贤圣法亦异此若通者当有何意。答曰。或因色无色生色无色。或因色无色生无色。或因无色生无色。或因无色生色无色。因色无色生色无色者。若从欲色界终还生欲色界。因色无色生无色者。若从欲色界终生无色界。因无色生无色者。若从无色界终生无色界。因无色生色无色者。若从无色界终生欲色界。或有色相续至竟断或须臾断。谓色相续至竟断者。彼不复还生。谓色相续须臾断者。彼还复生。彼阿罗汉入无余涅槃界。一切有为行永断。是故不复生。问曰。彼鞞婆阇婆提。云何通此育多婆提所说契经证。答曰。彼言。如佛契经说。彼息解脱度色至无色。如是像正受身作证成就游。此契经佛度粗色故说。无色中有色。但微细四大布散空界。说曰。此不论。何以故。说色极微者。犹粗于四阴。然彼说四阴不说色阴。以此不知无色中无色。问曰。如所说离欲至色。离色至无色。此云何通。答曰。如彼色离欲界。于色中故有色。如是无色离色。于无色中亦应有色。说曰。此者不论。何以故。若彼色离此欲界色者可尔。但彼色离此欲界中欲不离色。色中无有欲。如是彼无色离此色界中色。以是故无色中无色。余契经证者。彼不能通。唯彼无智果闇果痴果非精勤果。谓欲令无色中有色。但无色中无色。是谓欲断他意现己意。说如等法。故作此论。莫令断他意。莫现己意。但说如等法。故作此论。四无色者。空处识处不用处有想无想处。空处云何。如婆须蜜经所说。空处者空处正受及生。谓善痛想行识是。问曰。何以故。如禅或说正受及生。或说生非正受。无色者说一切正受及生。答曰。彼无色非种种。非若干相。非不相似。是故一切说正受及生。禅者种种若干相不相似。是故或说正受及生。或说生非正受。或曰。无色者非种种功德庄严。是故一切说正受及生。禅者种种功德庄严。是故或说正受及生。或说生非正受。或曰。无色者无多妙法。是故一切说正受及生。禅者多有妙法。是故或说正受及生。或说生非正受。或曰。无色者细不可见难可现。是故一切说正受及生。禅者粗可见可现。是故或说正受及生。或说生非正受。四无色定者。空处识处不用处有想无想处。空处云何。于是比丘度一切色想。灭有对想。不念杂想。无量空是无量空处成就游。彼度一切色想者。色想者。谓四禅大地布散色想现彼应灭以是故说度一切色想。灭有对想者。对想者。五识身相应想是

问曰。如欲界除欲时灭五识身相应想。或除初禅欲时灭。何以故四禅除欲时说灭有对想。答曰。虽有五识身相应想。或欲界除欲时灭。或初禅除欲时灭。但彼想处未灭。谓四禅除欲已彼想处灭。以想灭故说。或曰。灭依故说。虽有五识身相应想。或欲界除欲时灭。或初禅除欲时灭。但依未灭。谓四禅除欲已所依便灭。是故依灭故说。更有说者。有对相者恚相应想是。问曰。如恚相应想。欲界除欲时永灭。何以故四禅除欲时说。答曰。灭因故说。谓因及缘生恚色因色缘。是彼色四禅除欲时永灭。是谓因及缘灭故说。以是故灭有对想说。不念杂想者。四禅地布散想

问曰。彼何以故说不念。答曰。谓彼四禅布散想。退空处正受。世尊说不思念此想修空处正受道。以是故说不念杂想。无量空是空处成就游者

问曰。何以故说空处。为性耶。为缘耶。若是性者应四阴性。若是缘者应缘四谛。作此论已。答曰。空处者非性亦非缘。但方便故说空处。如彼施设所说。云何方便空处正受。云何方便成空处正受。此始初行时。或住山顶上。或住高阁上。或住高台上。谓此地极高处不念。彼谓此地极下处。彼念是空意解是空。彼观是空分别是空。是从空故成就此正受。以成此定说名为空处。或曰。此法应尔。谓彼地始无色彼名空处。或曰。离色故说空处。彼行者于下地色缘色已。除欲界欲乃至三禅。彼于四禅上更无色可缘除四禅欲。彼尔时生空想。如人攀枝至枝上树极标。彼上更无有枝而可攀缘。尔时便起空想。如是行者于下地色缘色。除欲界欲乃至三禅。四禅上更无色可缘。除四禅欲。彼时便起空想。是离色故便说空处。或曰。谓从空处起相似想。说者有一比丘。得空处正受。彼从定起手抆摸床。同学。问曰。汝何所求。答曰。我自求我。同学说曰。汝在床上更何所求。谓从定起相似想。是说空处。是故说无量空。无量空处成就游者。谓彼空处地善四阴到得成就。是故说无量空处成就游。复次比丘度一切无量空处无量识处成就游

问曰。何以故说识处。为性耶。为缘耶。若性者应有四阴性。若缘者应四谛缘。作此论不。答曰。无量识处者。亦非性亦非缘。但方便故说无量识处。如彼施设所说。云何方便无量识处正受。云何精勤成就无量识处正受。是始初行时。观净眼识想。观净耳鼻舌身意识想。观净大火聚焰。观净灯光。彼念是识意解是识。彼观是识分别是识。是从识故成就此正受。以成此定说名无量识处。或曰。彼相似故从此起。生悦乐悦乐识。是故说无量识处。无量识处成就游者。谓此无量识处善四阴到得成就。是故说无量识处成就游。复次比丘度一切无量识处无所有处成就游。问曰。彼中无何等。答曰。有所有者。无量行彼中无此。是故说无所有处。尊者婆须蜜说曰。彼无我计我。是故说无所有处

问曰。如一切地无我计我。何以故无所有处说无我计我。答曰。一切地计我意无有。如少缚欲穿。如无所有处。是故说无所有处无我计我。重说曰。彼中无有常计常及常住。是故说无所有处。重说曰。彼中无著处无依处无归处。是故说无所有处。成就游者。此中谓无所有处善四阴到得成就。是故说成就游。复次比丘度一切无所有处非想非不想处成就游

问曰。何以故说非想非不想处。答曰。彼想不定非想亦不定。想不定者。如七想正受中想定。此中不尔。非想不定者。如无想定灭尽定。此中亦不尔。问曰。若不尔者此云何。答曰。彼处钝不利不捷疾不定断。是故说非想非不想处。成就游者。此中谓非想非不想处善四阴到得成就。是故说成就游。问曰。何以故彼一界。或二倍寿。或不也。如空处二万劫寿。识处四万劫寿。何以故。无所有处不说八万劫寿。何以故。非想非不想处说十六万劫寿。答曰。彼报因齐限。谓彼因齐限。报亦尔。或曰。空处有无量行。或不无量行。无量行者受万劫寿。不无量行者亦受万劫寿。是故彼受二万劫寿。识处亦有无量行。或不无量行。无量行者受二万劫寿。不无量行者亦受二万劫寿。是故彼四万劫寿。识处上无有无量行。是故彼无量行寿分断。以故尔。或曰。空处中有止有观。止者受万劫寿。观亦受万劫寿。是故彼受二万劫寿。识处亦有止亦有观。止者受二万劫寿。观者亦受二万劫寿。是故彼受四万劫寿。识处止观渐薄。是故观分断。以故尔。或曰。彼一切地性二万劫寿。空处性二万劫寿。识处性亦二万劫寿。以度一地故更二万劫寿。是故彼受四万劫寿。无所有处性亦二万劫寿。以度二地故更受四万劫寿。是故彼受六万劫寿。非想非不想处性亦二万劫寿。以度三地故更受六万劫寿。是故彼受八万劫寿。以故尔。是故彼一界或二倍。或不。说曰。欲界及非想非不想无圣道

问曰。何以故欲界及非想非不想无圣道。答曰。非田非地非器故。以故尔。或曰。此说二边。一欲界边。二非想非不想边。彼圣道除二边故而处其中。以故尔。或曰。此说一于有二根。一欲界有根。二非想非不想有根。彼圣道除二有根而处其中。以故尔。或曰。此欲界非定界。非思惟地。非除欲地。非想非不想。钝不利不捷疾不定断。圣道者是定是思惟能除欲不钝极利捷疾。以故尔。或曰。此欲界增调。非想非不想处增止。圣道者是止观。以是故。欲界及非想非不想处无圣道。广说四无色处尽

    鞞婆沙八解脱处第三十六

八解脱者。色观色。初解脱。内无色想观外色。二解脱。净解脱身作证成就游。三解脱。复次比丘度一切色想。灭有对想。不念杂想。无量空是无量空处成就游。四解脱。复次比丘度一切无量空处。无量识是无量识处成就游。五解脱。复次比丘度一切无量识处。无所有处成就游。六解脱。复次比丘一切度无所有处。非想非不想成就游。七解脱。复次比丘度一切非想非不想处。想灭正受身作证成就游。八解脱

问曰。八解脱有何性。答曰。初三解脱不贪性。无量空处无量识处无所有处非想非不想处四阴性。想灭解脱不相应行阴性。界者。初三解脱系在欲界亦系色界。无量空处解脱。无量识处解脱。无所有处解脱。或系在无色界。或不系。非想非不想想灭解脱系无色界。地者。初二解脱初禅地二禅地。净解脱者根本四禅。无量空处解脱即空处地。无量识处解脱即无量识处地。无所有处解脱即无所有处地。非想非不想想灭解脱即非想非不想处地。依者。初三解脱依欲界。无量空处解脱至非想非不想处解脱依三界。想灭解脱者依欲色界。行者。初二解脱不净行。净解脱是净行。无量空处解脱。无量识处解脱。无所有处解脱。或十六行。或离十六行。非想非不想处想灭解脱离行。缘者。初三解脱色阴缘。空处解脱乃至非想非不想解脱缘四谛。想灭解脱无有缘。意止者。初三解脱身意止。空处解脱乃至非想非不想解脱三意止。想灭解脱法意止。智者。初三解脱。虽性非智与等智相应。空处解脱乃至无所有处解脱。或六智。或非也。非想非不想解脱一等智。想灭解脱非智。定者。初三解脱性非定。亦非定相应。空处解脱乃至无所有处解脱或定或离。非想非不想解脱想灭解脱非定。痛者。初二解脱与二根相应。喜根护根。净解脱至非想非不想解脱。一护根相应。想灭解脱不与痛相应

问曰。当言过去耶。当言未来耶。当言现在耶。答曰。当言过去。当言未来。当言现在

问曰。当言过去缘耶。当言未来缘耶。当言现在缘耶。当言非世缘耶。答曰。七解脱。当言过去缘当言未来缘。当言现在缘。当言非世缘。想灭解脱。当言非缘

问曰。当言己意缘耶。当言他意缘耶。当言非意缘耶。答曰。七解脱。当言己意缘。当言他意缘。当言非意缘。想灭解脱。当言非缘

问曰。当言名缘耶。当言义缘耶。答曰。七解脱。当言名缘。当言义缘。想灭解脱。当言非缘。此是解脱性。已种相所有自然。说性已。当说行。何以故说解脱。解脱有何义。答曰。不向门义是解脱义

问曰。若不向门义是解脱义者。何等解脱。于何事不向门耶。答曰。初二解脱于色欲不向门。净解脱不净不向门。空处解脱乃至非想非不想处解脱。下地相续不向门。想灭解脱二事不向门。一心永灭。二不向门。心永灭者。谓断一切心。不向门者。谓一切共缘相续不向

问曰。如所说。内无色想观外色者。若内无色想时即观外色耶。为观外色非内无色想耶。若内无色想时即观外色者。何得不一时有二种心耶。若一时有二种心者。何得不破心耶。若破心者。何得不有无量心耶。若观外色非内无色想者。此契经云何通。此中说内无色想观外色。作此论已。答曰。观外色无有内无色想

问曰。若观外色无有内无色想者。此契经云何通。此中说内无色想观外色。答曰。此契经说。善根及善根方便。若说内无色想。是彼善根。方便观外色者。此是根本善根。或曰。此中说前挍计分别。彼行者前挍计分别已。如我内无色想当观外色。是故说内无色想观外色。问曰。彼不净想尽。是欲界色入境界耶。为非耶。若彼不净想尽是欲界色入境界者。此尊者阿那律契经。云何通说者。尊者阿那律游于山林中。尔时四妙天女化作上妙色已。到尊者阿那律所。礼尊者阿那律足。于一面住。白尊者阿那律曰。尊者阿那律。我等四妙天女于四事善得自在。云何四。天色天衣天饰天乐。尊者阿那律。我等四妙天女若意所欲。化天四事天五欲等共娱乐。尊者阿那律便作是念。我今宁可于四禅地。不净想现在前已。当观不净。尔时尊者阿那律作是念已。四禅地不净想即现在前。便观四妙天女不净。终不能于不净得解。尔时尊者阿那律告四妙天女曰。诸妹皆作青色。问曰。何以故。尊者阿那律告彼诸妹。皆作青色耶。答曰。尊者阿那律作是念。此色极好种种。若尽同一色者。或于不净得解。尔时四妙天女闻尊者阿那律教已尽化青色。于尊者阿那律前歌舞戏笑。尊者阿那律于不净犹故不解。尊者阿那律复告曰。诸妹尽作黄色尽作赤色。问曰。何以故。尊者阿那律告四妙天女。诸妹皆作黄色尽作赤色。答曰。尊者阿那律作是念。观缘行时或从不净得解。尔时四妙天女闻尊者阿那律教已。尽化黄色尽化赤色。于尊者阿那律前歌舞戏笑。尊者阿那律于不净犹故不解。尊者阿那律复告诸妹。尽作白色。问曰。何以故。尊者阿那律告四妙天女。诸妹尽作白色。答曰。尊者阿那律作是念。此白色观不净时极随顺。若作白色者。或于不净得解。尔时四妙天女闻尊者阿那律教已。尽化作白色。于尊者阿那律前歌舞戏笑。尊者阿那律于不净犹故不解。尊者阿那律作是念。此色甚为极妙。作是念已即闭塞诸根。若彼不净想尽。是欲界色入境界者。此契经云何解。答曰。尊者阿那律虽于不净想不得解。但利根者于不净能得解。如佛辟支佛声闻得度无极

问曰。能于佛身解不净耶。为不耶。答曰。佛身者极妙极好。诸得不净想者。尽来于佛身观不净。终不能于佛足指观不净。况复极妙面得不净耶。唯佛观佛能解不净。更有说者。不净想者有二种。一观别相。二观总相。观别相者。终不能于佛身解不净。观总相者。或能于佛身解不净。复有二种不净想。一坏色。二缘行坏色。不净想者。终不能于佛身解不净。缘行不净想者。或能于佛身解不净。问曰。净解脱为色观色耶。为内无色想观外色耶。若色观色者。彼初解脱及第三解脱何差别。若内无色想观外色者。彼二解脱及第三解脱何差别。作此论已。答曰。净解脱者。内无色想观外色

问曰。若净解脱内无色想观外色者。二解脱及三解脱何差别。答曰。名即是差别。此二此三地亦有差别。二解脱者初禅二禅地。净解脱者根本四禅地。除病亦有差别。二解脱者除色欲。净解脱者除不净。或曰。二解脱者缘观不净不起结。净解脱者缘观净亦不起结。缘观不净不起结者。此非奇。缘净观不起结者。此乃为奇二解脱及三解脱是谓差别。问曰。此说净解脱极妙缘亦极妙。何以故说净解脱极妙缘亦极妙耶。答曰。谓此非是常人所能得。唯净洁自喜。从妙天来者彼能得如所说。有异比丘。来至世尊所。到已礼世尊足却坐一面。世尊。为说妙法。劝进等劝进。以无量方便等劝进已默然住。于是比丘闻世尊所说法内怀欢喜。从坐起整衣服露右肩。叉手向世尊。白世尊曰。唯世尊。愿赐处所。彼时尊者阿难在世尊后。手执拂拂世尊。彼时世尊还顾告阿难曰。为客比丘并一房令得止宿。唯然世尊。彼时尊者阿难受世尊教已。为客比丘并一房与客比丘。客比丘白尊者阿难曰。尊者阿难。为我故极扫洒此房。除诸秽恶悬缯幡盖。烧众名香散种种花。设广大床褥极令柔软。于是尊者阿难闻已。到世尊所白世尊曰。唯世尊。向冥来客比丘如是告敕尊者阿难。为我故极扫洒此房。除诸秽恶悬缯幡盖。烧众名香散种种华。设广大床褥极令柔软。世尊曰。阿难。速为彼客比丘如所言。尊者阿难波斯匿王常请供养。于是尊者阿难受世尊教已。至波斯匿王宫。取种种具便扫洒彼房。除诸秽恶悬缯幡盖。烧众名香散种种花。设广大床褥极令柔软。尊者阿难一切具施设已还所止。于是彼客比丘于房中即其夜发净解脱。三明作证得六神通。于八解脱顺逆已晨朝神足陵虚而去。于是尊者阿难明朝至彼房看。见空房不见客比丘。于是尊者阿难到世尊所已。白世尊曰。唯世尊。昨冥来客比丘如是告敕已。而彼客比丘空房而去。世尊告曰。阿难。勿误彼客比丘。何以故。阿难。彼客比丘者于房中即其夜发净解脱。三明作证得六神通。于八解脱顺逆已。晨朝神足陵虚而去。阿难。彼客比丘净洁自喜。从妙天中来。阿难。若不具种种供给者。彼比丘终不能发尔所功德。是故以此可知。非是常人。所能得。唯洁自喜从妙天中来者可得。是故说净解脱极妙缘亦极妙。问曰。如此二正受。无想正受想灭正受。二俱无心。何以故想灭正受立解脱。无想正受不立耶。答曰。谓勇猛勤行多作方便彼立解脱。谓不勇猛不勤行不多作方便。彼不立解脱。或曰。谓未曾行未曾得未曾转彼立解脱。谓曾行曾得曾转彼不立解脱。或曰。谓不共彼立解脱。谓共彼不立解脱。或曰。谓此法可得非外彼立解脱。谓此法及外可得彼不立解脱。问曰。云何知无想正受此法可得。答曰。有证。如所说。得无想正受。彼从中起止息所往来。持衣钵具。言语柔和饮食庠徐。有长老比丘。得妙智观。观已作是念。彼比丘极妙具足威仪礼节。我宁可观之。得何功德。彼观知乃是凡夫人。唯得无想正受。知已从三昧起。呼彼比丘告曰。子此非是妙。汝离佛法中极妙善根。而与异学同行。何用是为。速当舍之。于是彼比丘求极多方便。欲舍本心终不能离。说者彼比丘乃至退服还家。卒不能离本心。彼命终已生无想天。是故以此可知无想正受此法中亦得。或曰。谓圣人可得。非凡夫人。彼立解脱。谓一向凡夫人可得非圣人。彼不立解脱。或曰。此前已说。二事故名为解脱。一者共缘相续不向门。二者尽断心。彼无想正受不能一切共缘相续不向门。亦不能尽断心。是故想灭正受立解脱。无想正受不立解脱。问曰。何以故无色具足立解脱。禅者不具足立解脱耶。答曰。此禅粗可见。是故不具立解脱。无色极微细不可见。是故具立解脱。或曰。禅者种种非一相不相似是故不具立解脱。无色者非种种非不一相非不相似。是故具立解脱。或曰。禅多有功德多有妙法。是故不具立解脱。无色者无多功德无多妙法。是故具立解脱。或曰。禅者种种善根庄严。是故不具立解脱。无色者无种种善根庄严。是故具立解脱。或曰。禅解脱一向有漏。是故不具立解脱。无色解脱者有漏无漏。是故具立解脱。问曰。何以故禅解脱一向有漏。无色解脱有漏无漏耶。答曰。禅解脱者得解思惟。无色解脱者真实思惟。以是故禅解脱一向有漏。无色解脱有漏无漏

问曰。何以故八解脱说净解脱想灭解脱身作证。不说余。答曰。余亦说。如彼大因经所说。阿难。如比丘于八解脱顺逆身作证成就游。以此可知余亦说身作证。问曰。此一契经说八解脱身作证。余契经何以唯说此二解脱身作证。答曰。此二解脱勇猛勤行多作方便。以是故说二解脱身作证。或曰。谓此二解脱说界边。净解脱者说色界边。想灭解脱者说无色界边。以故尔。或曰。谓此二解脱说地边。净解脱者说四禅地边。想灭解脱者说非想非不想地边。或曰。净解脱者缘观净不起结。世尊说身当作证。想灭解脱者非心法。身所生非心所生。身力可得。非心力可得。世尊说身当作证。或曰。世尊说大因经。八解脱身作证成就游者。彼一切游二解脱故。以是故世尊说。净解脱想灭解脱身作证。说曰。此佛契经说八解脱为方。问曰。何以故世尊说八解脱为方。答曰。为教化故。有受化者应闻方名得解。是故世尊为教化故。说八解脱为方。如余契经。为教化故说谛为方。如是世尊为教化故。说八解脱为方。或曰。此契经有因有缘。如所说。王波斯匿告捕象者。汝捕象人。速捕野象已白我令知。于是捕象者受王教已。至空野处捕象。得已还白王曰。唯尊当知已捕得象。随王处分。于是王告善御象。汝御象人速调御此野象。调已还来白我。彼善御象者受王教已。将野象而调御之。极调已还白王曰。唯尊所敕调象。今已极调。于是王欲试此象。令御象者御已。王乘所出。出城已而彼象遥见大牝象群。见已奔走驰向。彼善御象者极以力御而不能制。彼象被钩斲而无所觉。于是王告善御者。汝速回此象无令断我命根。御者对曰。天王。极以力制而不可禁。王及御象者殆至于死。彼宿缘会象趣树间。于是善御象者手攀枝授与王。于是王及善御者攀枝而下。象奔走趋群。王告御象者曰。汝云何令顶生王乘此不调之象。御者叉手对曰。天王。当赐威颜。此象极已调。王告曰。云何知极调。御者对曰天王。彼象已习人间之食。彼食空野中食不能存命。彼欲止自还。还已当令王见所以为调。于是野象欲止还至王城。彼御象者将象至王所。告象曰。我当令汝有所作。勿得动转。若不忍者。我当令汝如本所更。彼象有智即然可之。宁令我死愿不见本所更事。彼御者以大铁钳。钳大热铁团着其顶上。烧象顶如烧桦皮。彼象不敢动转。于是御象者白王曰。天王。当观象调如此。王告御者曰。前者是谁之过。御者对曰。天王。是心之过。王告曰。何以故不调御心。御者对曰。唯能御形不能调心。王告曰。谁有能调心者。于是御者右膝跪地。叉手面向只桓精舍白王曰。天王。彼佛世尊止此舍卫祇树给孤独园。彼能调心。于是王有心于世尊。欲见世尊。于是王及御者还乘本象。便往祇树给孤独园。彼时世尊为无量百千众眷属围绕说微妙法。于是王下象已。步至世尊所。世尊方便说喻。非一切声闻辟支佛。彼王渐欲近。世尊见已告诸比丘。象师御象走趣一方。或东西南北及诸方。御马师调御马走趣一方。或东西南北及诸方。调牛师调御牛走趣一方。或东西南北及诸方。无上士御人师。调御人趣一切方。一切方者色观色是初方。乃至想灭解脱身作证成就游为八方。以是故佛契经以解脱说为方。问曰。解脱云何如方。答曰。同八事故名为方。解脱者八。方亦八。问曰。如方有十解脱有八。云何同八事故名为方。答曰。如彼御象者能御八方。终不能令至上下。是故同八事故名为方。或曰。如象因方而趣。如是受化者。缘故解脱现在前。尊者瞿沙说曰。解脱及方者。三事同。三事差降。三事同者。如象不趣向方不可调御。世尊亦尔。不因化者不能令解脱现在前。如象调御至一方不趣余方。如是世尊为受化者。令一解脱现在前。非余解脱。如象调御趣一方远离余方。如是世尊为受化者。令一解脱现在前。远离余解脱。此三事同。三差降者。象者不至方不可调御。世尊住一方已。为受化者极令彼远。能令解脱现在前。象者御趣一方不趣余方。世尊为八受化者。能令一时八解脱现在前。象者御趣一方远离余方。世尊为受化者。能令一解脱现在前。余解脱近为习学故。是谓三差降。广说八解脱处尽

    鞞婆沙八除入处第三十七

八除入者。云何为八。此比丘内有色想观外色少。若好若丑彼色坏已知坏已见。作如是想。此初除入。复次比丘内有色想观外色无量。若好若丑彼色坏已知坏已见。作如是想。此二除入。复次比丘内无色想观外色少。若好若丑彼色坏已知坏已见。作如是想。此三除入。复次比丘内无色想观外色无量。若好若丑彼色坏已知坏已见。作如是想此四除入。复次比丘内无色想观外色。青青色青见青光。无量无量净。意爱意乐无厌。如青莲花。青青色青见青光。如成就波罗奈衣。极捣熟令悦泽。青青色青见青光。如是比丘内无色想观外色青青色青见青光。无量无量净。意爱意乐无厌。彼色坏已知坏已见。作如是想。此五除入。复次比丘内无色想观外色黄黄色黄见黄光。无量无量净。意爱意乐无厌。如迦罗尼。黄黄色黄见黄光。如成就波罗奈衣。极捣熟令悦泽。黄黄色黄见黄光。如是比丘内无色想观外色。黄黄色黄见黄光。无量无量净。意爱意乐无厌。彼色坏已知坏已见。作如是想。此六除入。复次比丘内无色想观外色。赤赤色赤见赤光。无量无量净。意爱意乐无厌。如频头迦罗花。赤赤色赤见赤光。如成就波罗奈衣。极捣熟令悦泽。赤赤色赤见赤光。如是比丘内无色想观外色。赤赤色赤见赤光。无量无量净。意爱意乐无厌。彼色坏已知坏已见。作如是想。此七除入。复次比丘内无色想观外色。白白色白见白光。无量无量净。意爱意乐无厌。如明星白白色白见白光。如成就波罗奈衣。极捣熟令悦泽。白白色白见白光。如是比丘内无色想观外色。白白色白见白光。无量无量净。意爱意乐无厌。彼色坏已知坏已见。作如是想。此八除入

问曰。八除入有何性。答曰。无贪善根性。彼相应法共有法总五阴性。界者。或欲界系。或色界系。地者。初四除入初禅二禅地。后四除入第四禅地。何以故。谓从初解脱二解脱。或初四除入故从净解脱成后四除入故。依者。尽依欲界。行者。初四除入不净行。后四除入净行。缘者。尽缘欲界欲界中色入缘。意止者。是身意止。智者。虽性非智。但等智相应。定者。非定。痛者。初四除入喜根相应。后四除入护根相应。问曰。当言过去耶。当言未来耶。当言现在耶。答曰。当言过去。当言未来。当言现在。问曰。当言过去缘耶。当言未来缘耶。当言现在缘耶。答曰。当言过去缘。当言未来缘。当言现在缘。问曰。当言名缘耶。当言义缘耶。答曰。当言名缘。当言义缘

问曰。当言己意缘耶。当言他意缘耶。答曰。当言己意缘。当言他意缘。此是除入性。已种相身所有自然。说性已。当说行。何以故说除入。除入有何义。答曰。缘坏故名为除入。如所说。能坏处所者。是故世尊说除入。是谓缘坏故名为除入。八除入者。云何为八。此比丘内有色想观外色少者。少自在故。少缘故。名为少好者。谓色青黄赤白悦泽名为好。丑者。谓色青黄赤白不悦泽名为丑。彼色坏已知坏已见者。彼色中离欲断欲度欲。便坏已知坏已见。呵责自在教敕自在。如大家已有奴责数自在教敕自在。如是彼色中离欲断欲度欲。便坏已知坏已见。呵责自在教敕自在。是故说彼色坏已知坏已见。作如是想者。如是修彼想也。是故说作如是想。此初除入。初者次第数便有初。次顺数便有初。复次次第正受便有初故曰初。除入者何所除入。当正受时坏色故曰除入。复次比丘内有色想观外色无量者。自在无量故。缘无量故。名为无量。好者。谓色青黄赤白悦泽名为好。丑者。谓色青黄赤白不悦泽名为丑。彼色坏已知坏已见者。彼色中离欲断欲度欲。便名坏已知坏已见。呵责自在教敕自在。如大家已有奴呵责自在教敕自在。如是彼色中离欲断欲度欲。便坏已知坏已见。呵责自在教敕自在。是故说彼色坏已知坏已见。如是作想者。如是修彼想也。是故说作如是想。此二除入。二者。次第数便有二。次顺数便有二。复次次第正受便有二。故曰二。除入者。何所除入。当正受时坏色故曰除入。复次比丘内无色想观外色少者。自在少故。缘少故。名为少好者。谓色青黄赤白悦泽名为好。丑者。谓色青黄赤白不悦泽名为丑。彼色坏已知坏已见者。彼色中离欲断欲度欲便名坏已知坏已见。呵责自在教敕自在。如大家已有奴呵责自在教敕自在。如是彼色中离欲断欲度欲。便坏已知坏已见。呵责自在教敕自在。是故说彼色坏已知坏已见。作如是想者。如是修彼想也。是故说作如是想。此三除入。三者。次第数便有三。次顺数便有三。复次次第正受便有三。故曰三。除入者何所除入。当正受时坏色故曰除入。复次比丘内无色想观外色无量者。自在无量故。缘无量故。名为无量。好者。谓色青黄赤白悦泽名为好。丑者。谓色青黄赤白不悦泽名为丑。彼色坏已知坏已见者。彼色中离欲断欲度欲。便坏已知坏已见。呵责自在教敕自在。如大家已有奴呵责自在教敕自在。如是彼色中离欲断欲度欲。便坏已知坏已见。呵责自在教敕自在。是故说彼色坏已知坏已见。作如是想者。如是修彼想也。是故说作如是想。此四除入。四者。次第数便有四。次顺数便有四。复次次第正受便有四。故曰四。除入者何所除入。当正受时坏色故曰除入。复次比丘内无色想观外色青者。现青想现青种现青聚。是故说青。色者。如此色青如是彼色形亦青。是故说青色。青见者。眼行眼境界眼光。是故说青见青光者。青光青明青焰。是故说青光。无量者。无量无边不可计。是故说无量。无量净者。如彼色无量。如是彼色中净亦无量。是故说无量净。意爱者。彼色爱喜好喜念。是故说意爱。意乐者。意乐着自娱。是故说乐。无厌者。乐欲忍。是故说无厌。如青莲花青青色青见青光。如成就波罗捺衣。极捣熟令悦泽。青青色青见青光。如是比丘内无色想观外色青。青色青见青光。如是无量无量净。意爱意乐无厌。彼色坏已知坏已见者。彼色中离欲断欲度欲。便坏已知坏已见。呵责自在教敕自在。如大家已有奴呵责自在教敕自在。如是彼色中离欲断欲度欲。便坏已知坏已见。呵责自在教敕自在。是故说彼色坏已知坏已见。作如是想者。如是修彼想也。是故说作如是想。此五除入。五者。次第数便有五。次顺数便有五。复次次第正受便有五。故曰五。除入者何所除入。当正受时坏色。故曰除入。如青除入。黄赤白除入亦如是

问曰。何以故无色不立除入。答曰。佛世尊于法真谛。余真无能过。彼尽知诸法相尽知行。谓有除入相彼立除入。谓无除入相彼不立除入。或曰。除入者能坏色。以故名为除入。无色中无色可坏。以故彼不立除入。广说八除入处尽

    鞞婆沙十一切入处第三十八

十一切入者。云何为十。此比丘地一切入。一思惟上下诸方无二无量。水一切入。火一切入。风一切入。青一切入。黄一切入。赤一切入。白一切入。无量空处一切入。无量识处一切入。十思惟上下诸方无二无量。问曰。十一切入有何性。答曰。初八无贪善根性。无量空处无量识处一切入四阴性。界者。初八色界系。无量空处无量识处一切入者。无色界系。地者。初八一切入根本第四禅。何以故。从净解脱成八一切入故。无量空处一切入即无量空处地。无量识一切入即无量识处地。依者。一切依欲界。行者。八一切入净行。无量空处无量识处一切入不施设行。缘者。初八一切入欲界缘。无量空处无量识处一切入无色界缘。意止者。初八一切入身意止。无量空处无量识处一切入三意止。智者。初八一切入虽性非智。但等智相应。无量空处无量识处一切入是等智。定者。非定。痛者。一切护根相应。问曰。当言过去耶。当言未来耶。当言现在耶答曰。当言过去。当言未来。当言现在

问曰。当言过去缘耶。当言未来缘耶。当言现在缘耶。答曰。当言过去缘。当言未来缘。当言现在缘

问曰。当言名缘耶。当言义缘耶。答曰。当言名缘。当言义缘

问曰。当言己缘耶。当言他缘耶。答曰。当言己缘。当言他缘。此是十一切入性。己种相身所有自然。说性已。当说行。何以故说一切入。一切入有何义。答曰。普缘故名一切入。十一切入者。此比丘地一切入者。普缘故一思惟。一者。次第数便有一。顺次数便有一。复次次第正受便有一。上下者。上即上方。下即下方。诸方者。四方及四维也。无二者。不俱不散。无量者。无量无限不可计。水一切入。火一切入。风一切入。青一切入。黄一切入。赤一切入。白一切入。无量空处无量识处一切入。无量一切入者。普缘故。十思性者。次第数便有十。顺次数便有十。复次次第正受便有十。上下者。上即上方。下即下方。诸方者。四方及四维。无二者。不俱不散。无量者。无量不可限不可计

问曰。无所有处非想非不想处。何以故不立一切入。答曰。佛世尊于法真谛。余真无能过上。彼尽知诸法相尽知行。谓有一切入相立一切入。谓无一切入相不立一切入。或曰。无量行故无量空处无量识处立一切入。无所有处非想非不想处无无量行。是故不立一切入

问曰。此中说上下及诸方。八一切入应尔。上下及诸方无量空处无量识处一切入。无地不可见。何以故说上下及诸方。答曰。彼虽无上下。正受故可得上下。谓彼行正受者。或上或下或中。是故说上下。如契经说诸贤行地。一切正受者作是念。谓地即是我。谓我即是地。我与地一无二

问曰。此云何如是行地一切正受者。谓地计是我。答曰。行正受者曾行正受故说。如本曾作沙门故以沙门为名。曾阿练阿练为名。曾戒律戒律为名。曾法师法师为名。如是行正受者。曾行正受故说

问曰。三禅何以故不立解脱除入一切入。答曰。三禅乐一切生死中最妙。行者着彼乐不求此善根以故尔。问曰。若尔者何以故三禅中有神通变化。答曰。如是彼中或有善根或无。莫令彼地善根空。或曰。此神通变化能长养乐。非是损解脱除入一切入。于乐是损非是长养。以是故三禅不立解脱除入一切入

问曰。解脱除入一切入何差别。答曰。解脱者令不向门。除入者坏于缘。一切入者普缘解脱除入一切入。是谓差别。广说十一切入处尽

鞞婆沙论卷第十二鞞婆沙论卷第十三

        阿罗汉尸陀槃尼撰

        符秦罽宾三藏僧伽跋澄译

    八智处第三十九

八智者。法智未知智知他心智等智苦智习智尽智道智。问曰。何以故彼作经者依八智而作论。答曰。彼作经者意欲尔。如所欲如是作经。与法不相违。以是故依八智而作论。或曰。彼作经者无事。问曰。何以故彼作经者无事。答曰。此是佛契经。契经说八智。彼作经者于佛契经中依本末处所。已此阿毗昙中作论。彼作经者不能八智中减一智已立七智。增一智已立九智。问曰。何以故。答曰。所谓是一切佛契经亦不增亦不减。不增者无增可减。不减者无减可增。如不增不减如是无量深无边。无量深者。无量义故。无边者。无边味故。如大海无量深无边。如是佛契经无量深无边。无量深者。无量义故。无边者。无边味故。如尊者舍利弗。如是比百千那术。以佛契经二句作百千经。令智尽而住。不能尽佛契经二句得其边崖。如佛契经此论是故作经者无事。问曰。若佛契经此论佛契经者。说无量智。或说二智。如增一中说二法或说四智。如增一中说四法或说八智。如增一中说八法或说十智。如增一中说十法。如佛契经说无量种智。何以故。彼作经者离无量种智。依八智而作论。答曰。谓八智是中说亦摄一切智。二智虽摄一切智彼但略。十智虽摄一切智但极广。或曰。谓八智数数现在前。尽智无生智不数数现在前。或曰。谓八智数数思惟。尽智无生智不数数思惟。或曰。谓八智是见性及智性。尽智无生智虽是智性但非见性。或曰。谓八智有欲无欲意中可得。尽智无生智一向无欲意中可得。如有欲无欲。如是有恚无恚有痴无痴有慢无慢。如是尽当知。或曰。谓八智学无学意中可得。尽智无生智一向无学意中可得。如学无学。如是作不作求不求息不息如是尽当知。以是故彼作经者离无量种智。依八智而作论。彼作经者或依一智顷作论。如杂揵度所说。颇以一智知一切法耶。答曰。不也。问曰。如此智生一切法无我。此何所不知。答曰。不知自然。不知共有法。不知相应法。问曰。何以故尔。答曰。彼作经者依一智顷作论以故尔。若彼作经者依一切八智作论而问。颇八智一智能知一切法耶。可答有等智。是如是七六五四三二一。若彼作经者依一智作论而问。颇一智知一切法耶。亦可答有等智也。若彼作经一智中依二时顷立论而问。颇一智二时顷知一切法耶。亦可答有一智二时顷。谓一智一时顷除自然相应法共有法。余者尽知一切法。谓一智二时顷者。知自然相应共有法如是彼智二时顷尽知一切法。但彼作经者。一智一时顷立论而问。颇一智知一切法耶。答曰。不也。八智者。法智未知智知他心智等智苦智习智尽智道智。问曰。八智有何性。答曰。慧性摄。一持一入一阴少所入。相应法共有法摄。三持二入五阴。此是智性。己种相身所有自然。说性已当说行。何以故。说智智有何义。答曰。决定义是智义。问曰。若决定义是智义者。疑品中不应有智。彼疑品者非决定。答曰。疑品中有智者性决定。但余事故名疑品。谓彼疑品苦是苦犹豫疑。如是习尽道是道犹豫疑。作譬喻者说曰。谓心中有智不应有无智。谓心中有疑不应有决定。复次譬喻者诘责。阿毗昙师诸尊如丛林。阿毗昙师说法性亦如是。一心中施设智施设无智。一心中施设疑亦施设决定。但阿毗昙师说法性。一心中施设智无智。亦施设非智非无智。一心中施设疑亦施设决定。施设亦非疑亦非决定。智者慧。无智者无明。非智非无智者余法。疑者犹豫。决定者智。非疑非决定者余法。问曰。此当言智耶。当言了耶。答曰。亦名为智。亦名为了。智者决定义故。谓知苦习尽道。了者开义。谓开己意亦开他意。以是故亦名为智。亦名为了。如是共行说已。当说别行。问曰。如一切十智法性。何以故说一法智。答曰。十智虽是法性但事故说一法智。知十八界虽是法性但事故说一法界。如十二入虽是法性但事故说一法入。如七觉意虽是法性但事故说一择法觉意。如六思念虽是法性但事故说一法念。如四信虽是法性但事故说一信法。如四意止虽是法性但事故说一法意止。如四辩虽是法性但事故说一法辩。如三宝三自归虽是法性但事故说一法宝法归。如是虽有十智是法性但事故说一法智。或曰。此法智者。一名余者二名。法智者同名余者同不同名。是故说一法智非余。或曰。谓法智始觉法。如法故说法智。谓后觉如法。是未知智。是说未知智。或曰。谓法智初得无坏信。是故说法智。谓后得无坏信。是未知智。或曰。谓法智。除欲界多非法相结。如恚愤不语依高害谄诳无惭无愧悭嫉。是故说法智。谓除诸结是未知智。或曰。谓法智。法智除欲界结是法智。谓除色无色界结是未知智。问曰。何以故说知他心智。答曰。谓知他心。是故名知他心智。问曰。如知他心数法。何以故。说知他心智不说心数法智。答曰。方便求故知他心智。此法多事故得名。或性故或依故或相应故或方便求故或行故或缘故或行缘故。性故得名者如界入阴。依故得名者如六识身。谓依眼者彼名眼识。谓依乃至意名为意识。相应故得名者如觉乐痛法觉苦痛法觉不苦不乐痛法。方便求故得名者如此知他心智。复次如无量空处无量识处行故得名者如苦智习智。缘故得名者如四意止如五见。正受行缘故得名者如尽智道智。此智名亦同缘亦同。此中方便求故名知他心智。因此故彼行者。精勤方便求欲令我知他心。然后不精勤方便求。自然知他心数法。如人欲求见王。既见王已并见眷属。如是行者精勤方便求欲令我见他心。然后自然知他心数法以故尔。或曰。妙说妙义故。彼品何者最妙心。是如所说。如王行眷属随从以故尔。或曰。谓说心王。因彼故立心数法。心者说大地。因彼故立十大地。或曰。谓彼神通作证时。无碍道缘心以故尔。如是如前心所答。于此中尽答。以故说知他心智。问曰。何以故说等智。答曰。知等故名等智。如此中净不净行尽行裁割缝去来坐卧言语饮食。如是余事是谓知等。故曰等智。问曰。如知第一义苦习尽道乃至一切法。何以故。说等智不说第一义智。答曰。多知等故名为等智。少知第一义。是故不说第一义智。或曰。隐没故名为等智。犹如器盖上名隐没。如是此智隐没故名为等智。或曰。此智谓依于痴与痴相续。痴所持是故名等智。尊者婆须蜜说曰。此智非智相。但多人举作智相。是故名等智。如彼多人举作王性非王种。但多人会推举为王。以多人举故。是故说名多人举。但王如是。此智非智相。但多举非智相。是故名等智。问曰。何以故说苦智。何以故说乃至道智。答曰。谓苦行四行乃至道行四行。是名苦智乃至道智。问曰。世俗智亦苦行四行乃至道行四行。何以故不名苦智至道智。答曰。是世俗智与苦习同一缚。是故不名苦智至道智。或曰。此世俗法诽谤说言。无苦无习尽道。是故不应说苦智至道智。或曰。谓苦行四行乃至道行四行。能灭坏破有。是名苦智乃至道智。世俗智虽苦行四行乃至道行四行。但增受长养有。是故非名苦智至道智。或曰。谓苦行四行乃至道行四行。能断有相续。能断轮转生老死。是故名苦智乃至道智。世俗智虽苦行四行乃至道行四行。能相续有轮转生死。是故不名苦智乃至道智。或曰。谓苦行四行乃至道行四行。苦尽趣道。有尽趣道。贪尽趣道。尽生老死趣道。是故名苦智乃至道智世俗智虽苦行四行乃至道行四行。苦习趣道。有习趣道。贪习趣道。生老死习趣道。是故不名苦智乃至道智。或曰。谓苦行四行乃至道行四行。非身见种。非颠倒种。非爱种。非使种。非贪处非恚处非痴处。非杂污非杂毒非杂浊。非在有不堕苦习谛。是名苦智乃至道智。世俗智虽苦行四行乃至道行四行。是身见种颠倒种爱种使种。贪处恚处痴处。杂污杂毒杂浊在有堕苦习谛。是故非名苦智乃至道智。说曰。四事故名为法智。始知法故名为法智。知现法故名为法智。于法非愚故名为法智。于法非欺故名为法智。遥知故名未知智。此亦四事从因遥知果。从果遥知因。从身行口行遥知心。从见善说法遥知世尊。知他心智亦四事。因次第缘增上。此智有四缘。知亦四缘。等亦四事。名等相续等俗数等所入等。苦亦四事。生苦老苦病苦衰苦习亦四事。行结爱处所。尽亦四事。一者三结尽。二者欲恚薄。三者五下分结尽。四者一切结尽。道亦四事。一者缘。二者现法安乐游。三者身游戏。四者观所作办。尽智亦四事。空三昧不相应不摄见不与知他心智俱。所求已舍。无生智亦四事。一者依二者方便求三者意四者不转。说曰。一智摄一切智。法智是此性非如法智。但十智性是法。二智摄一切智。有漏无漏相续非相续系非系。三智摄一切智。法智未知智等智。四智摄一切智。法智未知智知他心智等智。五智摄一切智。苦智习智尽智道智等智。六智摄一切智。苦习尽道智知他心智等智。七智摄一切智。法智未知智等智苦习尽道智。八智摄一切智。法智未知智知他心智等智苦智习智尽智道智

问曰。若八智摄一切智者。余更有八智法界住智涅槃智生死智念宿命智漏尽智妙智尽智无生智。云何此八智摄彼八智。答曰。此八智尽摄彼八智

问曰。云何此八智摄彼八智

答曰。法界住智者是法性。彼是四智法智未知智知他心智等智。涅槃智者是尽智。彼是四智法智未知智尽智等智。生死智念宿命智者。本阿毗昙师及罽宾说者一等智。尊者瞿沙说曰。生死智念宿命智六智。法智未知智等智苦智习智道智。除知他心智尽智。问曰。何以故除知他心智。答曰。生死智念宿。命智缘过去未来。知他心智缘现在。是故除知他心智。问曰。何以故除尽智。答曰。生死智念宿命智是有为缘。尽智无为缘。是故除尽智。如是说者生死智念宿命智是一宿命智。有漏尽智者。或有说。谓智有漏尽缘是漏尽智。更有说者。漏尽智者漏尽意中可得。是漏尽智。谓说漏尽缘。是漏尽智者此四智。法智未知智尽智等智。谓说漏尽意中可得。是漏尽智者一切十智漏尽意中可得。妙智者本阿毗昙师及罽宾说一智等智。尊者瞿沙说曰。妙智者七智。法智未知智知他心智等智苦智习智道智除尽智。问曰。何以故除尽智。答曰。妙智者有为缘尽智者无为缘。是故除尽智。如是说者妙智一等智尽智。无生智者六智。法智未知智苦智习智尽智道智除知他心智等智。问曰。何以故除知他心智。答曰。尽智无生智知他心智。不相应故除知他心智。问曰。何以故除等智。答曰。尽智无生智是无漏。等智是有漏。是故除等智。如是此八智摄彼八智。说曰。一切智当言一智。智知故。知如法故。十智当言法智。性法故。十智当言妙智。愿满故。十智当言尽智。得漏尽故。十智当言无生智。不转故。问曰。此八智几欲界系。几色界系。几无色界系。几不系。答曰。六智是不系。等智三界系。知他心智或色界系或不系。地者法智。六地未至中间根本四禅。未知智者九地。此六地及三无色。知他心智根本四禅

问曰。何以故根本四禅。答曰。神通故谓神通定可得。彼知他心智可得非根本地及无色。非神通定可得。等智十一地。苦智习智尽智道智法智分六地。未知智分九地。依者法智知他心智依欲界。未知智等智依三界。苦智习智尽智道智法智分依欲界。未知智分依三界。行者法智未知智十六行。知他心智道四行。等智或十六行。或离十六行。苦智习智尽智道智各四行。缘者法智未知智四谛缘。知他心智欲界色界缘。他有漏无漏心心数法等智。或四谛缘或离四谛。苦智苦谛缘。习智习谛缘。尽智尽谛缘。道智道谛缘。意止者法智未知智苦智习智道智四意止。尽智法意止。知他心智心意止。等智或四意止。或离四意止。智者即智定者。法智未知智三三昧相应。知他心智道无愿相应。等智或三三昧相应。或不相应。苦智二三昧相应。习智尽智道智各一三昧相应。痛者法智未知智知他心智苦智习智尽智道智总三根相应。乐根喜根护根。等智五根相应。问曰。当言过去耶。当言未来耶。当言现在耶。答曰。当言过去当言未来当言现在。问曰。当言过去缘耶。当言未来缘耶。当言现在缘耶。答曰。法智未知智等智或过去缘。或未来缘。或现在缘。或离世缘。知他心智当言现在缘。苦智习智道智当言过去缘。当言未来缘。当言现在缘。尽智当言离世缘。问曰。当言名缘耶。当言义缘耶。答曰。当言名缘当言义缘。问曰。当言己意缘耶。当言他意缘耶。当言离意缘耶。答曰。法智未知智等智当言己意缘。当言他意缘。当言离意缘。知他心智他意缘。苦智习智道智当言己意缘。当言他意缘。尽智。当言离意缘。广说八智处尽

    鞞婆沙三三昧处第四十

三三昧者。空三昧无愿三昧无想三昧。问曰。应说一三昧。如十大地十心心数法。如五根五力七觉种八道种。说一三昧应说二三昧。如所说有漏无漏。相续不相续。系不系。应说四三昧。如所说欲界系色界系无色界系不系。应说五三昧。如所说欲界系色界系无色界系断无断。应说六三昧。如所说欲界系色界系无色界系学无学非学非无学。应说九三昧。如所说增上增上中增上软。中上中中中软。软上软中软软。应说十八三昧。有漏九种无漏九种意故。一时顷有无量三昧。云何一三昧广施设三三昧。云何无量三昧略施设三三昧耶。答曰。以三事故。一行二不愿三缘。行者空三昧行二行。空行非我行。不愿者。不愿有故。问曰。若不愿是无愿者亦不愿道耶。答曰。不也。何以故。无愿者是圣道能除有。以故不愿有。圣道者不愿道。何况愿有缘者无想。离十想法故。十想法者。五界想。色声香味细滑。二众生想。男想女想。三有为有为想。生老无常。此者彼中无一。是离十想法故名无想。是谓三事故行不愿缘说三三昧。或曰。除结故说三三昧。空三昧除身见。无愿三昧除戒盗。无想三昧除疑。是谓除结故说三三昧。彼施设中说谓空三昧。即是空三昧非无愿。非无想。谓无愿即是无愿。非空三昧非无想。谓无想三昧即是无想。非空三昧非无愿

问曰。何以故别说三。答曰。行各异故。谓空三昧行。此行非无愿行非无想行。谓无愿行。此行非空三昧行非无想行。谓无想行。此行非空三昧行非无愿行。是谓行各异故别说三三昧。复如所说。谓空三昧即是空三昧。亦是无愿非无想。谓无愿即是无愿。亦是空三昧非无想。谓无想即是无想。非空三昧亦非无愿。问曰。何以故并说二别说一。答曰。一时得故。共除结故。一时得者。若依空三昧取证亦得无愿。若依无愿取证亦得空三昧。共除结者。此二俱具若断除结种。是谓一时得故。共除结故。并说二别说一。复如所说。谓空三昧即是空三昧。亦是无愿亦是无想。问曰。何以故一切并说。答曰。此三昧空无有常计常。常住不变易以是故一切并说谓无愿即是无愿亦是空三昧亦是无想。问曰。何以故此三昧无愿。答曰。此三昧不愿淫恚痴。亦不愿受当来有。是故此三昧是无愿。谓无愿三昧即是无想。亦是空三昧亦是无愿。问曰。何以故此三昧是无想。答曰。此三昧无有色想。无有声香味细滑法想。是故此三昧无想。问曰。三三昧有何性。答曰。行阴性。界者或三界系或不系。地者或十一地或九地。依者依三界。行者空三昧有二行。空行非我行。无愿有十行。无常行因习本缘道正趣出要。无想有四行。尽止妙离。此中应作四句。谓空三昧亦是行空行耶。答曰。或空三昧非行空行。云何空三昧非行空行耶。答曰。谓空三昧行非我行。是谓空三昧非行空行。云何空行非空三昧耶。答曰。谓空三昧行空行时相应诸法。是谓行空行非空三昧。云何空三昧亦是行空行。答曰。谓空三昧行空行。是谓空三昧亦是行空行。云何非空三昧亦非行空行。答曰。若即取此种类。应说谓空三昧行。余行相应法。若不即取此种类。应说除此行如行。如是已行当行。如空行三四句。如是无我行亦三四句。是谓空三昧六四句。无愿三十。无想十二。并说四十八四句。缘者空三昧缘苦谛。无愿缘三谛。无想缘尽谛。意止者空三昧无愿四意止。无想法意。止智者虽性非智。空三昧四智相应。法智未知智苦智等智。无愿七智相应。法智未知智等智知他心智苦智习智道智。无想四智相应。法智未知智尽智等智。定者即定。痛者三痛相应。乐根喜根护根。问曰。当言过去耶。当言未来耶。当言现在耶。答曰。当言过去。当言未来。当言现在。问曰。当言过去缘耶。当言未来缘耶。当言现在缘耶。当言非世缘耶。答曰。空无愿当言过去缘。当言未来缘。当言现在缘。无想者当言非世缘。问曰。当言名缘耶。当言义缘耶。答曰。当言名缘当言义缘。问曰。当言己意缘耶。当言他意缘耶。当言非意缘。答曰。空三昧无愿当言己意缘。当言他意缘。无想三昧当言非意缘。此是三三昧性。已种相身所有自然。说性已当说行。何以故说三昧。三昧有何义。答曰。三事故说三昧。一等二相续三缘缚。等者众生久时心数法乱。谓令正真。因三昧故。相续者众生久时心数法不次第生。若生善便有不善无记。若生不善便有善无记。若生无记便有善不善。谓令一向次第生善相缚相续除不善无记。唯因三昧故。缘缚者众生久时心数法散。色声香味细滑法。谓令摄捡缚一缘中。因三昧故。是谓三事故等相续缘缚说三昧。或曰。以三事故。一摄二不散三不舍说三昧。或曰。复有三事故。一者一意二不散三相续说三昧。如世尊契经说三三昧三解脱门。问曰。三三昧者。空三昧无愿无相解脱门。亦空三昧无愿无相。此二何差别。答曰。三昧者有漏无漏。解脱门者一向无漏。是谓差别。问曰。此论更有论生。何以故三昧有漏无漏。解脱门一向无漏耶。答曰。此是解脱门。解脱门者不应有漏。亦不应系缚。是故三昧有漏无漏。解脱门一向无漏

问曰。解脱门者。为取证故解脱门耶。为有漏尽故解脱门耶。若取证故解脱门者。应苦法忍相应是解脱门余者非。若有漏尽故解脱门者。应金刚三昧相应是解脱门。余者非。作此论已。答曰。解脱者。取证故亦漏尽故。问曰。若取证漏尽故是解脱门者。应苦法忍相应是解脱门余者非。答曰。一切取证故。得一切漏尽。故名为解脱门。问曰。何以故名为门。答曰。向面故名为门。如勇健夫执楯自障。以极利刀害彼怨家。如是行者三昧向面已。以利慧刀害结怨家。如是谓向面故名为门。如世尊契经以三三昧为鬘。问曰。何以故佛世尊说三三昧为鬘。答曰。增上恭敬故。极妙故。如人以鬘冠首。妙故他所恭敬。如是行者以三三昧鬘冠首。妙故天及人增上恭敬。是谓增上恭敬妙故说三三昧为鬘。或曰。如人首冠华鬘风不乱其发。如是圣三三昧冠首善根功德。觉观风不能乱以故尔。或曰。如人以綖结花作鬘久住不速解散。如是圣三三昧结功德鬘。得久住不速遗忘以故尔。或曰。如人以华结作鬘多有所直。如是圣以三三昧结功德鬘多有所直。取证得果除结漏尽。因此事故佛契经说。舍利弗圣弟子成就三三昧鬘。除去不善修行于善以故尔。或曰。谓以三三昧广师子吼。如所说尊者舍利弗游拘萨罗止山林中。离彼不远有异学亦在中止。彼时人民于四月节会游戏。彼异学少有事缘。下山林至人间。遇彼节会得酒肉丰足。彼醉挟瓶还本山林。彼遥见尊者舍利弗。见已轻之。甚奇我亦止于林彼亦止于林。我亦出家彼亦出家。我亦舍妻色彼亦舍妻色。我有如此乐彼有如此苦。即时说偈曰

  美酒我饮醉　　今复持一瓶
  山地草树木　　视之一金色

于是尊者舍利弗作是念。此死瘦梵志能说此偈。我岂不能以偈答之。即时说偈曰

  我饮无想酒　　持空三昧瓶
  山地草树木　　视之如弃唾

尊者舍利弗于此偈中以三三昧作师子吼。我饮无想酒者。此现无想三昧。持空三昧瓶者。此现空三昧。山地草树木视之如弃唾者。此现无愿三昧。如是此偈中尊者舍利弗作师子吼。以是故佛契经说三三昧为鬘。问曰。死瘦者。无命根无意非众生数。彼梵志有命有意是众生数。何以故说言死瘦耶。答曰。以彼轻易意故言死瘦。或曰。彼无慧命根故言死瘦。说曰。此说多有无想。或以空三昧说无想。或以见道说无想。或以无疑说无想。或以非想非不想说无想。或无相即说无想。或以空三昧说无想者。如所说我本无想。三昧所为所行。谓我所为所行者。我今便止不欲。谓彼比丘思惟空法。便忘众生想不见男女。此是空三昧说无想。复次空三昧说无想者。如所说有一比丘。得空解脱门。而不自知何果何功德。彼作是念。谁能为我记此三昧果及功德。复作是念。尊者阿难圣所称誉。世尊印可阿难。必能为我记此三昧果及功德。复作是念。若我至尊者阿难所。问此三昧何果功德者。或能尊者阿难还问我。比丘得此三昧耶。我若说得云何示他功德。我若言不得云何欺彼上尊。比丘我若默然住。云何触娆上尊。比丘复作念。我当寻从尊者阿难。或能自他从尊者阿难所闻此事。于是彼比丘六年中寻从尊者阿难而不闻此事。于是彼比丘后时从坐起。整衣服偏露右肩。叉手向尊者阿难。白尊者阿难曰。尊者阿难。谓此三昧精勤修行不增不减。如水定住。住故解脱。解脱故住。此三昧何果何功德耶。尊者阿难问曰。比丘。汝得此三昧耶。比丘对曰。唯然尊者阿难。得此三昧。尊者阿难说曰。比丘谓此三昧精勤修行不增不减。如水定住。住故解脱。解脱故住。比丘。此三昧智果智功德。比丘不久当得智。精勤修行者勇猛专志。是故说精勤修行。不增不减者不增涅槃不减生死。是故说不增不减。或曰。不增者除我故。不减者除是我故。或曰。不增者除我见故。不减者除有我见故。是故说不增不减。如水定住者。如泉眼出水覆泉眼不舍。如是彼三昧所缘生而不舍彼缘。比丘此三昧智果智功德者。取证得果漏尽故。说智果智功德。于是彼比丘闻尊者阿难善方喻说。内怀欢喜诵习受持已。礼尊者阿难足。绕尊者阿难已而去。彼比丘因尊者阿难教授。独靖寂燕坐心不放逸。精勤游已知法至得阿罗汉。此是空三昧说无想。见道说无想者。如所说目揵连。彼鞮舍梵不为汝记第六无想行人耶。第六无想行人者。坚信坚法。此义说第六无想行人。彼无想不可数不可施设。或此住或彼住。或苦法忍或苦法智。或苦未知忍或苦未知智。或习法忍或习法智。或习未知忍或习未知智。或尽法忍或尽法智。或尽未知忍或尽未知智。或道法忍或道法智。或道未知忍。是谓无想不可数不可施设。以是故坚信坚法。说第六无想人。此中见道说无想。问曰。何以故此见道说无想。答曰。见道速疾道捷疾。道不住故。以是故见道说无想。或无疑说无想者。如所说尊者瞿多有欲想有恚想有痴想。若无者。是谓无想是谓无疑。此中说无疑是无想。问曰。何以故说无疑是无想。答曰。结者能令退因结相故。无疑不减不退。以是故无疑说无想。或非想非不想说无想者。如所说彼度一切无所有处非想非不想处成就游。此中非想非不想说无想。问曰。何以故非想非不想说无想。答曰。彼想亦非定非想亦非定。想非定者。如七想正受。非想亦非定者。如无想正受想灭。正受钝故不利故不捷疾故。无想即说无想者。如所说三三昧空三昧无愿无想。此中无想即说无想。如世尊说。空三昧上尊所居。问曰。何以故说空三昧上尊所居。答曰。上尊多游中故。三千大千国土。佛世尊于功德中最为上尊。彼多游此中。第二上尊尊者舍利弗彼亦多游此中。是谓上尊所居多游此中。名空三昧上尊所居。或曰。谓空三昧于此法不共居故。说空三昧上尊所居。虽百岁在此外法者。但彼故名为小成就。愚法故。虽七岁在此法者。但彼名为上尊成就。上尊法故。谓空三昧于此法不共居故。名为上尊所居

问曰。无愿无想于此外法为有耶为无耶。答曰。虽无根本无愿无想。或有相似无愿行相似是粗行。无想行相似是止行。一切九十六种术无有似空三昧。况根本空三昧。谓空三昧于法此不共居。是故说上尊所居。或曰。定住故说空三昧上尊所居。此众生未观空故。常乱驰逸狂奔不住如水扰动。意如是不住。若观空法已。定住不移动如须弥山。是谓定住。故说空三昧上尊所居。或曰。一切爱非爱便不便善不善乐具苦具不共俱。是故说空三昧上尊所居。如所说尊者舍利弗母命终。弟子退服还家。当尔时黑齿比丘常与尊者舍利弗不相得。彼作是念。我当至彼说此凶问。便诣尊者舍利弗所。到已说曰。尊者舍利弗欲知不。尊母命终。弟子退服还家。尊者舍利弗说曰。黑齿比丘。此者知当如何。如汝所说母命终者此有之性谁生不死者。汝所说弟子退服还家者。此凡夫人性常移动。世尊说唯一圣人常不移动。如所说阿难见谛之人。知已犯戒舍戒退服还家者。非有此处。黑齿比丘作是念。虽有斯言心必不乐。尔时尊者舍利弗见此事。清旦整服持钵入舍卫分卫。分卫已食后举衣钵澡洗手足。以尼师檀着左肩上。入安陀林坐禅。尊者舍利弗安陀林坐禅时作是念。世间颇有极好妙事可爱。谓当变易起我愁忧苦恼耶。复作是念。世间无有极好妙事可爱。谓当变易起我愁忧苦恼。尔时尊者舍利弗晡时从禅起。出安陀林诣祇树给孤独园。尊者阿难遥见尊者舍利弗来。见已说曰。善来尊者舍利弗。为从何来何处坐禅。尔时尊者舍利弗答曰。阿难。从安陀林来在彼坐禅。尊者阿难问曰。尊者舍利弗。在安陀林云何坐禅。答曰。阿难。我于安陀林思惟有觉有观。问曰。云何尊者舍利弗有觉有观三昧。答曰。阿难。我于安陀林坐禅时作是念。世间颇有极好妙事可爱。谓当变易起我愁忧苦恼耶。尊者阿难问曰。作是念时为获何等。答曰。阿难。我作是念。世间无有极好妙事可爱。谓当变易起我愁忧苦恼

问曰。尊者舍利弗。为极爱敬世尊不。答曰。阿难。极爱敬世尊。问曰。若世尊般涅槃。为当起愁忧苦恼不耶。答曰。阿难。世尊般涅槃。我不起愁忧苦恼。但作是念。世尊般涅槃甚速。世间眼灭甚疾。尊者阿难说曰。善哉善哉。尊者舍利弗。世尊般涅槃。不起愁忧苦恼。何以故。如彼我是我极断故。是谓一切爱非爱便不便善不善乐苦具不共俱。是故说空三昧上尊所居。复次如所说。世尊游舍卫祇树给孤独园。尔时尊者阿难在一处坐禅。便作是念。一时世尊游释种处城名尼钳。彼时我从世尊闻如此所说义。阿难。我多游空三昧。云何昔世尊所说善知善受持耶。于是尊者阿难。从下晡起至世尊所。到已礼世尊足却住一面。白世尊曰。唯世尊。世尊昔一时游释种处城名尼钳。彼时我从世尊闻如此所说义。阿难。我多游空三昧。云何昔世尊所说善知善受持耶。如是向世尊说已。世尊告曰。如是阿难如是阿难。我所说汝善知善受持。何以故。阿难。我今亦多游空三昧。问曰。若彼善知善受持者。何以故问世尊。若问者云何善知善受持。作此论已。答曰。善知善受持。问曰。若善知善受持者。何以故问。答曰。尊者阿难以坏释种忧戚意中不定故问。说者彼愚痴流离王伐迦维罗卫尽坏彼族。尊者阿难闻愚痴流离王伐迦维罗卫尽坏我释种。闻已明旦与一比丘为伴。入彼城视本城犹若天宫。今如丘冢。墙壁楼橹埤堄窗牖皆已毁坏。有种种华树种种果树园观。尽已摧折纵横蔽地。若干花池莲华池青莲花池尽颓毁枯竭。异类奇鸟凫雁鸳鸯鸲鹆鹦鹉孔雀千秋青雀飞在空中。烟火所熏徘徊在上。无量男女丧失父母。号哭悲泣随逐阿难。彼时异学优昙钵园中。七万贤圣埋半身在地。以大香象铁把把之。尊者阿难见已增益悲酸。世尊因彼处故。与诸比丘前后围绕。诸根寂定意行不动犹如山地。执心如持油钵。御五根马如净金山而入彼城。于是尊者阿难遥见世尊妙光曜身。阿难见已作是念。甚奇生地同坏种族俱灭。我有如此忧戚。而世尊犹若大山无有倾斜。彼时世尊知尊者阿难意念意行。便告尊者阿难曰。阿难。我多游空三昧。而汝有村想我具足寂静想。而汝有人想。我具足法想。彼时尊者阿难及余比丘丧失亲族。内怀忧戚不能行善。于是世尊因此处故游于人间。次第游行还至舍卫。游舍卫只桓精舍给孤独园。彼时尊者阿难忧戚心除。于寂静处作是念。昔一时世尊游释种处城名尼钳。彼时我从世尊闻如此所说义阿难。我多游空三昧。云何昔世尊所说善知善受持耶。于是尊者阿难从下晡起至世尊所。到已礼世尊足却住一面。白世尊曰唯世尊。世尊昔一时游释种城名尼钳。彼时我从世尊闻如此所说义。阿难。我多游空三昧。云何世尊。所说善知善受持耶。世尊告曰。如是阿难。如是阿难。我所说汝善知善受持。何以故。阿难。我今亦多游空三昧。问曰。若问者云何善知善受持。答曰。彼善知善受持者不耶。受持不颠倒受持。不前不后受持不尽遗忘。但内怀忧戚意中不定故问。说曰。如世尊说。阿难我今亦多游空三昧。彼时诸比丘闻所说作是念。空三昧者。诸佛世尊必不共游居。非诸声闻辟支佛。彼时世尊知诸声闻意念意行已。告尊者阿难曰。阿难。诸有比丘欲多游空三昧者。阿难彼比丘当不念村想不念人想。应念寂静想。问曰。世尊现何等村想。何等人想。何等寂静想。何等地想。何等无量空处想。何等无量识处想。何等无所有处想。何等无想意定。何等有为意解脱。何等无为意解脱。何等漏尽。答曰。村想者。现缘迦维罗卫想。人想者。现杀舍夷人想。寂静想者。现尼拘类树园想。地想者。现四禅想。无量空处乃至无所有处想者。现除此欲色界。或曰。村想现欲界。欲界者说如村。如所说偈

  谓能弃村刺　　骂言及缚害
  比丘离苦乐　　如山不可动

人想者。现凡人想。寂静想者。现二禅想。此说贤圣默然。地想者。现灭色想。因色故便有截耳鼻手足。无量空处想乃至无所有处想者。现除欲色界。是谓现村想至无所有处想。问曰。何以故。常说村想人想当莫念。答曰。谓此二想令诸比丘内多怀忧戚。世尊说当舍此行善法。以是故。常说莫念村想人想。问曰。何以故。舍下想增上想。答曰。制乱故。若世尊不舍下想增上想者便有乱。诸佛世尊法常不乱说。是谓制乱故。或曰。制重说故。若世尊不舍下想增上想者。便为有重。诸佛世尊法常不重说。是谓制重说。故舍下想增上想。阿难此不颠倒。如真实空三昧。谓有为解脱无为解脱。问曰。云何此中有为解脱无为解脱。答曰。有为解脱者。等意解脱。无为解脱者。无碍解脱。问曰。何以故说等意解脱。答曰。以少道得故说等意解脱。问曰。何以故说无碍解脱。答曰。以无量道得故说无碍解脱。问曰。何以故说无碍解脱不动。答曰。结者能令动。无碍者因结不动不转不退。以是故无碍解脱说不动。谓至竟漏尽者。谓现一切漏尽。广说三三昧处。尽广说大章尽

鞞婆沙论卷第十三鞞婆沙论卷第十四

        阿罗汉尸陀槃尼撰

        符秦罽宾三藏僧伽跋澄译

    中阴处第四十一(出阿毗昙结使揵度人品非次)

中阴者。何以故作此论。答曰。断他意故作此论。或有欲令有中阴。或有欲令无中阴。鞞婆阇婆提欲令无中阴。育多婆提欲令有中阴。问曰。鞞婆阇婆提何意欲令无中阴。答曰。彼从佛契经欲令无有中阴。五无间罪作已。增长无间必生地狱中。若以无间生地狱者。是故无中阴。余契经说偈曰

  梵志命根尽　　未至阎王所
  中无顿止处　　必往不可除

若中无顿止处者。是故无有中阴。复更说世俗喻事。如光如影无有中间。如是若终若生无有中间。以此契经证故。鞞婆阇婆提说无有中阴。问曰。育多婆提何意欲令有中阴。答曰。从契经起。欲令有中阴。彼言。世尊契经说。三事合故入母胎中。父母共会。母或时满。有所堪任香阴已至。若香阴至者。是故有中阴。余契经说五阿那含。中般涅槃生般涅槃行般涅槃无行般涅槃上流至阿迦腻吒。若说中般涅槃者。是故有中阴。余契经婆蹉梵志至世尊所问曰。瞿昙。若是时舍此身已未至余处。众生乘意行。瞿昙。当尔时此众生依受何住。沙门瞿昙。为彼众生说依受何住。世尊说曰。婆蹉。若是时舍此身已未生余处。众生乘意行。婆蹉。当尔时彼众生依受爱住。我说彼依受爱住。若说众生舍此身已未生余处。众生乘意行者。是故有中阴。复更说诘责事。若言无中阴者。谓从阎浮提终生郁单越者。彼于此中断彼间未有而有。若尔者应无有法而有。莫言有咎。是故有中阴。如是一说如是二但说有中阴好。问曰。若有中阴者。此育多婆提云何通。彼鞞婆阇婆提所说契经证。答曰。此契经证有意可通。问曰。有何意云何通。答曰。谓佛说契经五无间罪作已。增长无间必生地狱中者。佛于此契经除余趣除余行。除余趣者。谓五无间罪作已增长。必生地狱中不生余趣。除余行者。谓五无间罪要受生报。不受现报不受后报。是谓此契经意之所通。如汝所说。此契经五无间罪作已。增长无间必生地狱中者。有此要当具五无间罪作已增长必生地狱耶。颇有四三二一生地狱耶。或有。除五更余罪生地狱耶。颇有时时五无间罪作已增长即生地狱耶。为或住世百岁耶。此契经或有意或无意。但不说无有中阴。问曰。若尔者如此偈云何通

  梵志命根尽　　未至阎王所
  中无止顿处　　必往不可除

答曰。佛于此偈除余趣除余行。除余趣者。谓此梵志作恶行增长已。必生地狱不生余趣。除余行者。谓此梵志作恶行增长已。必受生报非现法报后报。问曰。此世间喻云何通。如光如影无有中间。如是若终若生无有中间。答曰。此不应通。此非契经非律非阿毗昙。不可以世间喻坏贤圣法。世间喻异。贤圣法异。复次应坏。若坏喻以亦应坏义。光及影非命根无意非众生数。若终若生有命根有意是众生数。设通此喻当有何意。答曰。此喻乃说有中阴非说无中阴。如光如影无有中间。如是死阴中阴无有中间。中阴生阴亦无中间。如是此喻乃说有中阴。非说无中阴。问曰。此鞞婆阇婆提云何通。彼育多婆提所说契经证。答曰。彼说者如所说。三事合故入母胎中父母共合会母。或时满有所堪任香阴已至者。此不应说香阴已至。何以故不应说。此为弹琴耶而言香阴以至。问曰。若不应说者此云何。答曰。当言名阴行。何以故。彼因阴行。是故说当言名阴行。说者此不论。何以故。若说香阴若说阴行。故不能除中阴。问曰。此云何通五阿那含。中般涅槃生般涅槃行般涅槃无行般涅槃上流至阿迦腻吒。答曰。彼说者有天名中。彼生中天命未尽而终。说者此不论。何以故佛契经不说名中天。佛契经说。从四天王至非想非不想天不闻有中天。复次此契经说。生般涅槃行般涅槃无行般涅槃。欲令有天命。生般涅槃行般涅槃无行般涅槃耶。复次如汝说。命未尽而终名中般涅槃者。除菩萨及郁单越人。余一切众生命未尽而终。欲令一切众生中般涅槃耶。问曰。云何通。婆蹉梵志至世尊所问曰。瞿昙。若是时舍此身已未生余处。众生乘意行。瞿昙。当尔时此众生依受何住。沙门瞿昙。为彼众生说依受何住。世尊说曰。婆蹉。若是时舍此身已未生余处。众生乘意行。婆蹉。当尔时彼众生依受爱住。我说彼依受爱住。此云何通。答曰。彼说者。此中说无色界天乘意行。彼梵志有朋友。极敬念而命终。以天眼观欲界而不见。观色界亦不见。如不见已彼便作念。为断灭耶。为云何。彼闻有沙门瞿昙一切智一切见。我当往至彼问其本末。尔时梵志至世尊所。到已白世尊曰。瞿昙。为是时舍此身以未生余处众生乘意行。瞿昙。当尔时此众生依受何住。沙门瞿昙。为彼众生说依受何住。世尊说曰。婆蹉。若尔时舍此身已未生余处众生乘意行。婆蹉。当尔时彼众生依受爱住。我说依受爱住。以此知说无色界天乘意行。问曰。佛契经多说乘意行。或化或中阴或色无色天或始人或地狱。此中云何知无色天乘意行。彼亦问。此云何知中阴乘意行。答曰。即此契经知此中说舍此身已未生余处。以是故此契经说中阴乘意行。问曰。若无中阴者。谓阎浮提命终已生郁单越。彼于此断于彼无有而有。若无有而有者。是则无有法而有。答曰。彼说者彼终不舍死时阴。要当受生时阴。得生时阴已。然彼舍死时阴。如虫名蚇蠖。终不舍后足要当安前足。安前足已然后举后足。如是彼终不舍死时阴。要前受生阴。受生名然后舍死时阴

问曰。如汝说。谓人间命终生地狱中。彼不应舍人间阴得地狱阴。若不舍人间阴得地狱阴者。彼应即人为地狱。若即人为地狱者。是则极坏。如世尊说五趣。地狱饿鬼畜生天人与相违。但彼无智果闇果愚痴果不勤果。谓言无中阴。但有中阴真实有种相。是谓断他意现己意。说如等法故作此论莫令断他意。亦莫现己意。但说如等法故作此论。问曰。若有中阴者形为大小。答曰。如四五月小儿。是中阴形大小。问曰。若形如此者不应有颠倒想。于母所有淫心。于父所有害心。于父所有淫心。于母所有害心。答曰。虽此形小但彼捷疾诸根利。如人画壁作老人形像形小而老。如是彼中阴形虽小。但彼捷疾诸根利

问曰。菩萨中阴形为大小。答曰。如本身有三十二相八十种好庄严其身。紫磨金色圆光一寻。梵音声妙声伽毗陵伽鸟视之无厌。以是故住中阴时。百亿天下妙光普遍。谓日月最妙多力犹不能遍照。彼以妙光普遍。见妙光已众生各各相知。异众生生异众生生。问曰。若如此菩萨生中阴者。尊者法实偈云何通

  菩萨妙清净　　乘大白龙象
  从兜术天下　　降神入母胎

问曰。此偈不必通。何以故。非契经非律非阿毗昙。但作颂者。欲令句义合故。若必通此偈者当何意。答曰。此现方俗吉故。菩萨母梦中见顺。彼相书所记故。但菩萨从九十一劫除畜生。彼岂乘畜生入母胎耶。问曰。趣中阴为云何。答曰。谓生地狱者足在上头向下。如佛所说偈

  诸堕地狱者　　足上头向下
  恶意于仙人　　戒德及苦行

谓生天上者。头上足在下。如箭射虚空。谓生诸方者倾身而去。如鸟飞虚空如神足飞。问曰。中阴形为云何。答曰。地狱者如地狱形。如是乃至天为天形

问曰。中阴者自相见耶。答曰。相见

问曰。若相见者何者见耶。答曰。地狱者还见地狱。如是乃至天还见天。更有说者。天中阴见五趣中阴。人见四饿鬼见三畜生见二地狱见一。如是说者地狱见地狱。如是至天

问曰。此所生眼见中阴耶。答曰。不也。问曰。云何知。答曰有。契经佛契经说。谓若男若女犯戒与恶法俱。彼身坏时未至恶趣。意所乘行如黑羊毛。光如夜闇冥。谓极净天眼彼能见。谓若男若女持戒行与善法俱。彼身坏时未生善趣。意所乘行如白净衣。光如夜月盛明。谓极净天眼彼能见。以此契经可知。谓天眼不极净彼不能见。况所生眼当能见耶。问曰。住中为几时。答曰。生天及地狱者。速生饿鬼畜生。人如合会时不久终已便生

问曰。或有众生合会便生者可尔。谓不合会母或在天竺。父或至震旦。而彼命终当云何生。答曰。当观彼众生缘转不转。若彼于母缘不转于父缘转。彼时母极守贞正。要趣至他人所令彼得生。若于父缘不转于母缘转。彼时父极守贞正。要当趣他女人所令彼得生。问曰。若二俱缘不转二俱不合此终当云何生。答曰。彼众生缘行故。父所营事未讫市肆未成便有还心。彼寻路行时不为刀兵火毒所中。亦不因他终要还己。俱缘合会彼便得生

问曰。谓众生常行欲者此可尔。谓众生时节行欲者。如马春时行欲。犎牛夏时行欲。狗秋时行欲。豹冬时行欲。彼众生命终时云何生。答曰。彼众生缘故。非时所行欲彼便得生。或曰。彼生相似处此名。牛亦名犎牛。犎牛者时节行欲。牛者常行欲。谓应生犎牛者便生牛中。名为狗亦名为狐。狐者常行欲。狗者时节行欲。谓应生狗中者便生狐中。名为熊亦名为罴。罴者常行欲。熊者时节行欲。应生熊者便生罴中。尊者婆须蜜说曰。中阴者当言七日住。当言过耶。答曰。中阴住当言七日。何以故。身羸故住七日不过七日。问曰。谓满七日父母不合会者。彼时为断耶。答曰。不断但还生中阴。重说曰。中阴者当言七七日。尊者昙摩多罗说曰。中阴者父母不合会亦可久时住。问曰。中阴者有衣无衣耶。答曰。色界一切诸天有衣。何以故。如法身不裸形。生身亦尔。欲界中菩萨有衣。及白净比丘尼有衣。余一切众生无衣。更有说者。白净比丘尼有衣。菩萨无衣。问曰。何以故。白净比丘尼有衣菩萨无衣。答曰。白净比丘尼以衣布施圣众故。问曰。菩萨所施衣多。非白净比丘尼所施衣毛数。何以故。白净比丘尼有衣菩萨无衣。答曰。白净比丘尼以衣施圣众作誓愿。令我于中阴有衣。以是故于中阴有衣。即以此衣入母胎中。以此衣出母胎。谓白净比丘尼增长衣亦随身增长。谓大己出家学道。取所著衣割截作五衣。成阿罗汉果。舍有余涅槃界。入无余涅槃界而般涅槃。即以衣缠身而耶维之。菩萨所作功德。尽愿求无上正真道。是故最后身于一切众生中成最妙果。以是故。白净比丘尼有衣菩萨无衣

问曰。中阴食为云何。答曰。诸仓厨中器所盛食而取食之。问曰。如雨下甚多。如是众生堕阿鼻地狱。中阴其数如此。何况余趣中阴数耶。若尽来食者。此诸众生当何所食。复次此食极重。化身甚细。云何食此而得消化。答曰。此者不论

问曰。若不尔者当云何。答曰。以香为食。诸有德众生食花果香妙食香。诸无德众生圊厕不净及污泥气以为食。问曰。中阴何处。答曰。欲界色界非无色界。问曰。何以故。欲界色界非无色界。答曰。谓有色者便有中阴。无色中无色是故无中阴。问曰。何以故。有色便有中阴。答曰。如印印泥则有文现。如是本有中有。若有色者见已便知有如此中阴。是故谓有色者便有中阴。或曰。谓有来往便有中阴。无色界中无有来往。是故无色中无有中阴。问曰。于此身终即生此身。彼云何有来往。答曰。谓此众生或有识从足指灭者。或从顶灭。或从脐灭。或从心灭。谓从足指灭者。当知生恶趣中。谓从顶灭者。当知必生天上。谓从脐灭者。当知必生诸方。谓从心灭者。当知必般涅槃。谓此众生多爱着面。谓识从足指灭者。还来趣面是彼往来。复次从足指灭即趣足指。无色界中亦无有此。以是故。无色界无有中阴。问曰。中阴趣所摄趣耶。若趣所摄者。此施设云何通。彼所问四生为摄五趣耶。五趣为摄四生耶。彼中答。四生摄五趣。非五趣摄四生。问曰。不摄何等。答曰。中阴也。若离趣者。此尊者昙摩难陀所说云何通。彼所说中阴者随趣所摄。如种子萌芽未成实名为稻。如是地狱中阴。虽未至地狱名为地狱。如是至天作此论已。答曰。中阴趣所摄。问曰。若中阴趣所摄者。尊者昙摩难陀所说为善通。如施设所问。四生摄五趣耶。为五趣摄四生耶。彼中答。四生摄五趣非五趣摄四生。问曰。不摄何等。答曰。中阴也。此云何通。答曰。此所说应当尔。四生摄五趣耶。五趣摄四生耶。答曰。随种相摄此应当尔。更有说者。中阴离趣。问曰。若中阴离趣者。施设所说善通。如尊者昙摩难提所说。中阴随趣所摄。如稻子萌芽未成实名为稻。如是地狱中阴虽未至地狱名为地狱。如是至天。答曰。彼尊者说不向余趣不说摄。谓彼地狱中阴彼不趣余趣。要当生地狱。如是至天。是故尊者昙摩难提说。不向余趣不说摄。如是说者中阴离趣。何以故。中阴者是乱趣者非乱。不应非乱摄乱。亦不应乱摄非乱。或曰。中阴者不定趣者定。不应不定摄定。亦不应定摄不定。或曰。趣者已到为名中阴者方当趣。以是故中阴离趣。问曰。中阴者具诸根耶。为不具诸根耶。有一说者具诸根。更有说者不具诸根。问曰。若不具诸根者。诸本有不具诸根。彼即是中阴耶。有一根者即是。更有说者异。如是说者中阴具诸根。何以故。中阴者始行。复次彼众生六门常求有。是故中阴具诸根。问曰。中阴去速耶。为神足去速耶。有一说者神足去速非中阴。更有说者。中阴去速非神足。何以故。行力强非神足力。如是说者神足去速非中阴

问曰。若神足去速非中阴者。何以故。说行力强非神足。答曰。当听所以说行力强非神足力者。神足者能止神足佛能止一切众生。一切众生不能止佛。辟支佛者除佛能止一切众生。一切众生不能止辟支佛。尊者舍利弗者。除佛辟支佛已能止一切众生。一切众生不能止。尊者舍利弗。乃至利根止钝根。钝根不能止利根。中阴者非众生所能止。非法非咒术亦非药。非佛辟支佛及声闻度无极能止。要当往生。是故说行力强非神足力。但神足去速非中阴。如世尊契经所说。三事合会已入于母胎。父母合会为淫欲故。母或时满。时满者。彼女人以欲满体如满溢河。如是彼女人淫欲满体。更有说者。母或时满者。是女人病。是故说或时满。有所堪任者。彼女人极有力。怀妊持至九月十月。是故说有所堪任。香阴已至。香阴者中阴也。香阴于彼时有二意爱心及害心。若女者彼于父有爱心于母有害心。作是念。无此女者我共此男合会。彼不见母自见共父合会。谓父母不净彼作是念是我有。见已便闷。闷已此阴转厚。阴转厚已便舍中阴得生阴。若男者彼于母有爱心于父有害心。作是念。若无此男者我与此女合会。彼不见父便与女人合会。谓父母不净彼作是念是我有。见已便闷。闷已此阴转厚。阴转厚已便舍中阴得生阴。一切凡夫如是颠倒意入母胎。唯一菩萨无颠倒心入母胎。谓世尊说此契经。父母有德香阴无德。不得入母胎。香阴有德父母无德。亦不得入母胎。父母有德香阴亦有德。三事等合得入母胎。问曰。如此豪贵者亦与贱女共会。或贱男共贵女合会。云何三事等和合。答曰。谓豪贵与贱女人共会者。彼贱女人随彼得贵。谓若贱男与贵女共会。彼贵女随彼得贱处。如是三事等和合。问曰。中阴由何处入母胎。答曰。中阴随所欲入。何以故。谓中阴者。于垣墙树木山河石壁尽无所阂。如是说者。中阴从产门入母胎。以此事故。双生儿前出为小后出为大。何以故。谓彼先入故。问曰。如一胎中有五趣中阴可得。如猪狗鱼虾蟆。谓胎中地狱中阴可得。云何不烧彼胎。答曰。彼火行所作。谓作恶行者便被烧。谓不作恶行者便不被烧。复次彼根本大地狱。犹尚不恒被烧。何况中阴恒被烧耶。如彼目连施设所说。或有时活大地狱有冷风起。展转唱音言。等活众生等活众生。彼众生还活肌肉血脉还生。如彼根本大地狱犹尚不恒被烧。何况中阴恒被烧耶。此说中阴四种。一中阴。二意乘行。三香阴。四求有。问曰。何以故说中阴。答曰。二阴中间故名为中阴。二阴者死阴生阴。此二阴中间生故名为中阴。问曰。何以故说意乘行。答曰。意所生故名意乘行。众生或以行生。或以结生。或意生行生者地狱是。要毕其行终不中死。结生者卵生胎生及欲界化生天。意生者化中阴及色无色界天始初人。此中意生故中阴名意乘行。问曰。何以故说香阴。答曰。以香存命故。中阴名香阴。问曰。何以故说求有。答曰。于六入门常求有。是故中阴说求有。如世尊契经说。调达即身入地狱。问曰。调达有中阴耶无中阴耶。答曰。调达有中阴。但死阴即灭中阴寻生。中阴即灭生阴寻生。说者释提桓因以契经白世尊。偈曰

  于此坐终已　　大仙我天身
  既还复其命　　净眼我自知

问曰。释提桓因为终更生。为不终不生。若终更生者彼中阴云何。若不终不生者此偈云何通(偈如上也)。作此论已。答曰。释提桓因终已更生问曰。若终已更生者云何。答曰。诸天中阴生阴化生也。化者死身不现不可知。问曰。如所说。此天如十六男女形。在天膝上坐。尔时诸天不见耶。答曰见。但诸天作是念。此释提桓因极大力极大德极大神足。于如来前现其神足。更有说者。彼诸大威德天。如因陀罗披楼那伊沙那(此三释子亦如五)。如是彼诸大天等本有中有大小。一种如是释提桓因终已更生身大。但诸天不知。如是说者释提桓因不终不生。问曰。若释提桓因不终不生者。此偈云何通(偈如上也)。答曰。除五衰相故说偈。诸天有五衰相有五死相。五衰相者。诸天身洁净柔软从香池浴。还出池已水不着身。衰时。便着。诸天身力强目初不眴。衰时便眴。诸天五欲境界极妙极好端正无比。常不乐一处意如陶轮。衰时便守一处。诸天衣裳璎珞相[打-丁+棠]。声妙。犹五乐音。衰时便无音声。诸天遍有光明。如摩尼宝。影不可见。衰时便有影现。更有说者。影不可见但光不极妙是谓五衰相。五死相者。诸天花冠未曾萎而萎。宝衣未曾有垢而有垢。腋下汗流。形色变易。不乐本座。是谓五死相。衰相者犹可禁制。死相者不可禁制。释提桓因生五衰相。不久当生五死相便作是念。我当何恃怙脱五死相。观唯有佛。便往至世尊所听微妙法。欢喜见谛即除五衰相。故彼以软爱言白世尊。说此偈(偈如上也)。或曰。除恶道故说此偈。佛于恶道拔济释提桓因。安处天人中。彼即除恶道故。以软爱言白世尊。我应于恶道即灭断坏。遭遇世尊拔济恶道。如人出狱中囚着安隐处。彼囚数至人所。以软爱言答谢彼人。我应于狱中断坏。遭蒙仁恩得脱此难。如是佛世尊于恶道拔济释提桓因。安处天人中。彼即除恶道故。以软爱言白世尊。我应于恶道即灭断坏。遭遇世尊拔济恶道。以无上慧得存此命。皆世尊恩。是谓除恶道故说偈。或曰。见断结病尽故说偈。世尊脱释提桓因见断结病。安处第一义如医疗病令得除愈。彼人数数至医所。以软爱言答谢彼人。我应于病断坏。遭蒙仁恩得免此疾。如是佛世尊说释提桓因见断结病。安处第一义。彼即除见断结病尽故。以软爱言白世尊。我应于见断结病断坏。遭遇世尊拔济见断结病。以无上慧得存此命。皆世尊恩。是谓除见断结病故说此偈。或曰。谓欲令现法报行增益长寿。释提桓因见佛听法。受现法报增益长寿。是谓现法受报故说此偈。问曰。中阴为转耶为不转耶。答曰不转。界趣处所故。问曰。若中阴界不转者。此不多闻比丘。生经云何通。说者一比丘不多闻坐禅。因宿缘故得世俗初禅彼作是念。我得须陀洹果。得世俗二禅。复作是念。我得斯陀含果。得世俗三禅。复作是念。我得阿那含果。得世俗四禅。复作是念。我得阿罗汉果。彼于此中未得想得。舍方便不增求未得欲得未获欲获未证欲证。彼即命终生第四禅地中阴。便作是念。我一切结尽断一切生死。应般涅槃不应更生。何以故有此中阴。必无解脱。若令有者我今应有。彼生邪见诽谤涅槃便于四禅地中阴。转生阿毗大地狱中。答曰。彼本有时转非入中阴转。彼于此中未得想得。舍方便不增求未得欲得未获欲获未证欲证。彼临欲命终时。生第四禅地瑞应。彼见已便作是念。我一切结尽。我断一切生死。应般涅槃不应更生何以故有此瑞应。必无解脱。若令有者我今应有。彼生邪见诽谤涅槃。便于四禅地瑞应转生阿毗大地狱中。是谓本有时转非入中阴转

问曰。若中阴趣不转者。彼善行恶行生经云何通。说者舍卫城有二人。一人行善。一人行恶。彼行善者彼即命终。因后生报行故生地狱中阴。便作是念。我当极修善不作恶行。应生天上不堕地狱。何以故生地狱中阴。彼忆修善已转生地狱中阴。得天中阴即生天上。行不善者命终。因后生报行生天中阴。彼作是念。我常极作恶行不修善行。应堕地狱不应生天。何以故生天中阴。见已作是念。必无善恶报果。若有者我今应有。彼生邪见诽谤因果。转天中阴得地狱中阴即生地狱。若中阴趣不转者。此二人云何转。答曰。彼本有时转非入中阴转。凡一切众生命欲终时。必有善恶瑞应。彼善行者善瑞应。不善行者恶瑞应。善瑞应者如所说偈

  若见善行者　　终时作是言
  我视苑园观　　流河水花池

恶瑞应者。如所说偈

  若见恶行者　　终时作是言
  我视火刀剑　　鸱犬及狐狼

彼善行者。因后生报行。命欲终时生地狱瑞应。见已作是念。我常极修善不作恶行。应生天上不应堕地狱。何以故生地狱瑞应。彼忆修善已。转地狱瑞应终已生天上。彼不善行因后生报行。命欲终时生天瑞应。见已作是念。我常极作恶行不修善行。应堕地狱不应生天。何以故生天瑞应。必无善恶报果。若令有者我今应有。彼生邪见诽谤因果。转天瑞应终已生阿鼻大地狱中。是谓本有时转非入中阴转。问曰。若中阴处所不转者。瓶沙王生经云何通。如所说从兜术中阴至兜术天。当尔时四天王毗沙门大天王。设肴馔食香气极妙。瓶沙王闻彼香已。转兜术中阴生四天王。若中阴处所不转者。瓶沙王云何转。答曰。瓶沙王亦本有时转非入中阴转。说者阿阇世王父王法王无过无恶。捡在牢狱刑刀削足。禁制饮食使不得通。长抱苦恼不能堪忍。便作是念。世尊不见我苦。善逝不念我苦

尔时世尊及五百比丘游摩竭国耆阇崛山。尔时世尊知瓶沙王意之所念。告尊者目揵连曰。目揵连。汝往至瓶沙王所。持我言善慰劳大王。世尊作是说。大王。我与汝所作已作免于恶趣。汝所作恶行定当受报。恶行报者如来尚不免。况今大王。尔时尊者大目揵连受世尊教已。即入三昧。于耆阇崛山没至彼牢狱。尔时尊者目揵连从三昧起。告瓶沙王曰。大王。世尊作是说。大王我与汝所作已作免于恶趣。汝今所作恶行定当受报。恶行报者如来尚不免。况今大王如是尊者目揵连广为说法。瓶沙王饥渴所逼不知法妙。尔时瓶沙王问尊者目揵连。目揵连何处天有极妙食。我生已得食。尊者目揵连称叹四天王天至他化自在天有极妙食。瓶沙王应生兜术天。闻彼饮食已作是念。我先食此近食已。然后当生兜术天。彼命终已生四天王。作毗沙门太子名最胜子。是谓本有时转非入中阴转。以此事可知。中阴界亦不转。趣亦不转。处所亦不转。如尊者目揵连施设所说。始人者以胸臆行名为摩睺勒。生三手众生名为象。问曰。彼众生为终已作摩睺勒象。为不终不生。若终已更生者中阴云何。若不终不生者。何以故说。人或是摩睺勒或是象。作此论已。答曰。彼众生终已更生。问曰。若终已更生者。彼中阴云何。答曰。谓彼本阴中阴尽是化。化者身不可见。更有说者。彼众生亦不终亦不生。问曰。若不终不生者。何以故说。人或是摩睺勒或是象。答曰。谓彼众生从光音终来此彼当尔。是畜生中但形如人。后转饮食恶时恶众生意恶。巧诈滋多故。人形转灭遂成畜生形如虾蟆。初色黑身圆。后色苍形方。如是彼众生从光音天来生畜生中。但人形。以生四恶事故。人形转灭遂成畜生形。是谓彼众生说或摩睺勒或是象。但不终不生。广说中阴处尽

    鞞婆沙四生处第四十二

四生者。卵生胎生湿生化生。问曰。卵生云何。答曰。谓众生卵生。入卵卵所缠卵所裹啄破生等生起等起成转成有。此云何。答曰。如雁鸳鸯孔雀鹦鹉鸲鹆千秋。或龙或金翅鸟或人。如是比众生卵生。入卵卵所缠卵所裹啄破生转生起等起成转成有。是谓卵生

问曰。胎生云何。答曰。谓众生胎网生。入胎网胎网所缠胎网所裹裂坏生等生起等起成转成有。此云何。答曰。象马猪羊骡驴骆驼水牛野鹿。或龙或金翅鸟或人。如是比众生胎网生。入胎网胎网所缠胎网所裹裂坏生等生起等起成转成有。是谓胎生

问曰。湿生云何。答曰。谓众生因竹[竺-二+韋]孔腐树孔。因臭鱼臭肉或因秽食。或因圊厕污泥。或因诸粪除。或因热气郁烝。或各各相近。或各各相逼。生等生起等起成转成有。此云何。答曰。蛣蜣蚊虻飞蛾蝇虫蚁子。或龙或金翅鸟或人。如是比众生因竹[竺-二+韋]孔腐树孔。因臭鱼臭肉。或因秽食。或因圊厕污泥。或因诸粪除。或因热气郁烝。或各各相近。或各各相逼。生等生起等起成转成有。是谓湿生

问曰。化生云何。答曰。谓众生成就一切根具足身支节。一时生等生起等起成转成有。此云何。答曰。一切地狱一切饿鬼一切中阴一切天。或龙或金翅鸟或人。如是比众生成就一切根具足身支节。一时生等生起等起成转成有。是谓化生

问曰。四生有何性。答曰。四阴五阴性。欲色界五阴性。无色界四阴性。是谓四生性。已种相身已有自然。说性已当说行。何以故说生。生有何义。答曰。众生已生扼故名为生。问曰。若众生已生扼故名为生者。界趣亦扼众生。何以故不说生耶。答曰。谓唯有众生扼及一切众生扼。谓界者虽一切众生扼。但非众生数。亦扼趣者。虽众生扼但非一切众生扼。离中阴故。此生唯众生扼及一切众生扼。是故说四生。问曰。四生界有几生。答曰。欲界一切四生可得。色无色界唯一切化生。问曰。此四生趣有几生。答曰。地狱饿鬼天唯一化生。更有说者。饿鬼胎生可得。如彼饿鬼女。向尊者目揵连。说偈

  昼有二五子　　夜间亦二五
  寻生我已食　　我意犹不饱

畜生及人一切四生可得。问曰。云何知人中有卵生。答曰。如所说阎浮利地多有商人。入海采宝得二鹄鸟。形色极妙随意所化。失一一在。谓在者与共游戏覆卧一室。彼合会时遂渐生二卵。卵后渐熟便生二童子。极妙端正。后大出家学道得阿罗汉果。一名尊者耆尸披罗。二名尊者复钵尸披罗。闻久作南山寺主

问曰。云何知人中有湿生。答曰。如所说有顶生王尊者遮罗尊者优波遮罗利女

问曰。云何知人中有化生。答曰。劫初人是也。说曰。一切从四生生尽得圣法。圣人已得圣法者。不复卵生湿生。问曰。何以故圣人已得圣法不复卵生湿生。答曰。卵生湿生畜生趣所摄。圣人者已离畜生趣。或曰。此二生多有愚。圣人者已得观。或曰。卵生湿生者逼迮。圣人者意广。或曰。卵生湿生无可恃怙。圣人者成就恃怙法。若披梨女有恃怙者。不应有轻易女彼极下贱。檀提梵志无喻女无敢轻易者。以有主故。或曰。圣人者湿生卵生二生。若卵从母胎出啄卵出。以此事故鸟名二生。如沙门及梵志。名为二生。从母胎生出家学道。尊者瞿沙说曰。何以故圣人已得圣法不复卵生湿生。答曰。如父趣向子亦尔。问曰。云何如父趣向子亦尔。答曰。如已成菩萨不卵生湿生。如是圣人已得圣法。不卵生湿生。是故说如父趣向子亦尔。是谓圣人已得圣法不卵生湿生。问曰。四生何生最广。有一说者。卵生最广。说者外国四海边山腹岩腹平泽卵满其中。驴骡骆驼象马猪羊水牛野鹿尽蹈破之。如是卵生最广。更有说者。胎生最广。说者一鱼一虾蟆生子。满七稻田七河。如是胎生最广。更有说者。湿生最广。说者如夏月时卤土灰牛屎肉及诸湿处积聚。从欲界至梵天。须臾一时顷虫满其中。如是湿生最广。如是说者化生最广。何以故。谓化生尽摄三趣。二趣少所入。尽三趣者。地狱饿鬼天。二趣少所入者。畜生及人。复次欲色界一切众生皆生中阴。中阴者是生生他。以是故化生最广

问曰。四生何生最妙。答曰。化生最妙。问曰。若化生最妙者。何以故佛世尊不从化生。答曰。不等和合故。谓有化人时尔时无佛。谓有佛时尔时无化生人。是谓不等和合故佛世尊不化生。或曰。化生身无力故。不胜十力四无所畏。或曰。化身柔软不胜无上正真道。或曰。此一向极爱念与亲相续。菩萨恒一向极爱修善。以是故胎生不化生。或曰。菩萨长夜作行求尊父母。父母亦长夜作行求孝顺子。若菩萨从化生者。则誓愿行无果无报。以是故菩萨胎生不化生。或曰。说法受故。若世尊从化生已。诣聚论所呵责者。彼比丘当作念。此人无父母无兄弟姊妹及诸亲族。但来呵责我等。如阎浮利地最豪贵家亲族众多。迦维罗卫最为人中。世尊生彼。如口含唾不乐久停。出家学道住一林中叹誉一林。以是故说法时多有受化。是谓说法受故佛世尊胎生不化生。或曰。断诽谤故。世尊胎生不化生。如世尊在大众中。一切人无不见者。从兜术天终降生母胎。十月已满在林毗园生。即行七步。二龙浴身二十九出家。三十五得道。六年苦行已。食二女乳糜。降魔官属成无上道。犹有异学来诽谤者。过百劫已。于大海中生一幻士食一切施。何况世尊化生者。异学岂不增诽谤耶。是谓断诽谤故世尊胎生不化生。或曰。饶益他故。世尊胎生不化生。若世尊化生者。般涅槃时不见身舍利。若不见者。如今般涅槃灭千载。舍利如芥子。百千众生皆悉供养恭敬。供养恭敬已。愿求佛辟支佛声闻道。豪贵家天上人中形貌端正无有双比。乃至入无余涅槃界。若世尊化生者。尔所功德尽断灭不现。以是故佛世尊胎生不化生。问曰。何以故化生终时身不可见。答曰。化生身者。一时生。一时灭。如人入水。一时没一时出。出已还没不复现。如是化生身。一时生一时灭。或曰。化生身者多有造色少四大。多四大故终时可见。或曰。化生身者多根少非根。多非根故终时可见。化生者少发毛爪齿骨。以是故化生身终时身不可见。问曰。若化生身终时不可见者。彼契经云何通。化生金翅鸟搏撮化生龙而食。若化生不现者。云何以彼为食。答曰。意欲食故取之。但不除饥渴。或曰。化身妙软入腹即当食。如油如酥入腹当食。如是化身妙软入腹即当食。或曰。一时吞是故当食。或曰。彼金翅鸟有方便意。先吞其尾然后至头。命未断时以当食。是故化身当食。问曰。若化身终时不现者。彼余契经云何通。彼地狱卒取彼罪人。从脚剥皮至颈。从颈至足。云何可见。答曰。着身故可见。离身不可见。如重云电光。出则见没则不见。如是着身故可见。离身不可见。问曰。天上鸟是卵生耶。为化生耶。若卵生者应终时身见。诸天见已何得不起憎恶心耶。诸天有六种乐。谓眼见色尽见可乐不见非乐。喜非不喜。念非不念。善色非不善色。快色非不快色。妙非不妙。如是至意作此论已。有一说者。天上鸟卵生。问曰。若卵生者应终时身可见。诸天见已何得不起憎恶心耶。答曰。天上鸟终时可见。但风吹去速。如是说者。天上鸟化生。广说四生处尽

鞞婆沙论卷第十四


俱舍论实义疏

    No. 1561 [cf. Nos. 1558-1560]

俱舍论实义疏卷第一(惣二万八千偈)

        尊者悉地罗末底造(唐言安惠)

  稽首薄伽众德山　　稽首达磨大智海
  稽首僧伽和合众　　掣斯论主及吾师
  我将萤耀助阳光　　随力弘宣对法藏
  为利群生法久住　　愿以威神见护持

    分别界品第一

七义。谓智圆满。断圆满。利他圆满。方便圆满。应供圆满。期心圆满。方便圆满

由敬法故常乐听闻。由听闻故发生闻惠。由闻惠故发□思惠故。发起修惠故生无漏惠。由无漏惠能断诸惑。为诸惑断故即证[卅/卅]。故名所为之利益

七义者。颂言一切种冥灭。是知圆满。诸灭是断圆满。拔众生出生死泥者。利他圆满。敬礼如是者。应供圆满。如理师者。方便圆满。由佛世尊有胜方便说如理教利有情故。论我者当说者。期心圆满。欲造论故。对法藏者。立名圆满。惣摄七义。颂曰

  智断及利他　　方便期造论
  立名对法藏　　惣七义应知

色法．心法．心所有法．不相应法。及无为法。于此五法所知境中。世皆不了。唯佛独悟。永断诸惑故。极远时者。谓过去未来三阿僧祇劫外声闻独觉不能知。何以得知。如昔有一人。于舍利子边求出家。时舍利子观二阿僧祇劫。此人无出家善根。遂不许。此人诣佛以求出家。世尊观之。出僧祇外此人有少善根。遂许出家。说偈言

  彼人解脱种　　我观极微细
  犹如诸矿中　　真金隐兹住

目连观其母。不知生处。往问佛。佛告。汝母生在摩利支世界三千界外。如是多种分别中。声闻等智皆不了达

修福及智所得果。皆为利他非自利。犹月光净照十方。世尊悲愿亦如是。又颂云

  回施之福及利己　　自修回施二福德
  复因利乐诸有情　　如上众多福智聚
  果证非他遂自得　　行愿福及回施福
  自他俱利不唐捐

如是虽说自利从因及果亦能利他人。有颂言

  乳母甘膳用资身　　为子获安非为己
  佛修福智趣菩提　　本为利生非为自

颂云

  时雨虽普降　　无种芽不生
  佛虽化世间　　缘阙不得果

又颂

  善知识者谁　　谓佛令生智
  离放逸恶行　　违此即舍离

对法宜如生得惠与闻惠为因。闻惠与思为因。思惠与修惠为因。修惠与漏惠为因。漏惠与涅槃为因。以此义故得名对法。以能增长闻等惠故。或诸有为悉皆弃舍。唯乐涅槃故名殊胜。苦集道谛为涅槃惠。佛教依法不依人。颂曰

  若离择法定无余　　能灭诸惑胜方便
  由惑世间漂有海　　因此德佛说对法

论曰。若离择法无胜方便能灭诸惑。佛告阿难。我在依于我。我灭度无别所依。应依杖经。勿令忘失

佛云。老耄出家持吾三藏。甚为难得。三藏一经二律三杂藏

昔迦叶佛时有一苾刍。聪明博学具闲三藏。尝以语业毁骂出家在家人等。为鸱鸺鱼狗诸禽兽等。命终之后。承此业报。生于海中。受大鱼身。其形甚大。有十八头具受众苦。世尊出世犹未得脱。后有渔人。其数一千。困捕鱼次。网着此鱼。曳之不出。后数千人同共曳出。见其异类多头形貌可怖。世尊观见知具报终。遂将大众至彼海岸敷座。坐已呼彼鱼云。三藏。汝岂不是过去佛时三藏苾刍。彼鱼闻已涕泪盈目。尔时世尊为说宿因。其鱼生悔更不饮啖。因兹命终生于天上。于彼时中闻法之众各于自乘获大法利

五蕴不能摄一切法。是故不依五蕴而说先有染后要其净。净彼染故以先说有漏之法后说无漏。无为颂

  苾刍意寂静　　于事得永断
  能尽生死际　　更不受后有　阿毗达磨俱舍论实义疏卷第二

        尊者安惠造

论如有颂言

  诸佛出现乐　　演说正法乐
  僧众和合乐　　同修勇进乐

论说。北俱卢洲衣重一两。四天王众天衣重半两。三十三天衣重一铢。夜摩天衣重半铢。睹史多天衣重一铢中四分之一。乐变化天衣重一铢八分之一。他化自在天衣重一铢中十六分之一。已上

色界天衣不可称。彼界若有重何言不可称。色界诸天随其身量所著衣服如光皎净故不可言。表色相今次当说。颂曰

  乱心无心等　　随流净不净
  大种所造性　　由此说无表

六失惣说颂云

  初阙相续及假是　　无心随流表相杂
  重置等言不简别　　故此说中有六失

(此是眼耳鼻舌身意也说诸心)

六失中自异意故。说颂云

  作等余心等　　及无心有记
  无对所造性　　是名无表色

云地与地界有何差别。论颂曰

  地谓显形色　　随世想立名
  水火亦复然　　风即界亦尔

论故义品中作如说

  趣求诸欲人　　常起于希望
  诸欲若不遂　　恼坏如箭中(说六识)

当说论颂曰

  受领纳随触　　想取像为体
  四余名行蕴　　如是受等三
  及无表无为　　名法处法界

三蕴七事。如有颂云

  三蕴与无表　　及三种无为
  此法处所摄　　法界亦如是

颂曰

  识为各了别　　此即名意处
  及七界应知　　六识转为意

颂曰

  惣摄一切法　　由一蕴处界
  摄自性非余　　以离他性故　阿毗达磨俱舍论实义疏卷第三

        尊者安惠造

三科一聚二生门三种族。聚蕴义。生门义。心心所法生长门义。生于眼识以眼为门。此经证门义有六。然心所法有十二。故契经说。眼色为缘生于眼识。三和合。触起俱受想思如是。乃至意法为缘生于意识三和合

种族义是界义。如一山中有多铜铁金银界族说名多界。如是一身或一相续。有十八类。诸法种族名十八界。眼根现在未来过去是

无明颠倒颂曰

  如鱼处泥中　　跃水令浑浊
  无明中倒想　　污患亦复然

蕴名想颂曰

  牟尼说法蕴　　数有八十千
  彼体语或名　　此必行蕴摄

论颂曰

  空界谓窍隙　　传说是明闇
  识界有漏识　　有情生所依

论卷第二

十八界中几有见几无见。几有对几无对。几善几不善几无记。颂曰

  一有见谓色　　十有色有对
  此八除色声　　无记得三种
  五无分别　　由计度随念
  以意地散惠　　意诸念为体

论曰。说分别略有三种。一自性分别。二计度分别。三随念分别。由五识身虽有自性而无余二。说有八种分别非也。唯有自性分别。而无计度随念分别。唯一分别名无分别阿毗达磨俱舍论实义疏卷第四

        尊者安惠造

一刹那颂曰

  内五有熟养　　声无异熟生
  八无碍等流　　亦异熟生性
  余三实唯法　　刹那唯后三

内五即是眼之五界。十八界中几是见几非见颂曰

  眼法界一分　　八种说名见
  五识俱生惠　　非见不度故
  眼见色同分　　非彼能依识
  传说不能观　　被障诸色故

论曰。眼全是见故。法界一分八种是见。余皆非见。论今当略辩。此决定相。颂曰

  眼不下于身　　色识非上眼
  色于识一切　　二于身亦然
  如眼耳亦然　　次三皆自地
  身识自下地　　意不定应知

论又经中说二十二根。谓眼根．耳根．鼻根．舌根．身根．意根．女根．男根．命根．乐根．苦根．喜根．忧根．舍根．信根．勤根．念根．定根．惠根．未知当知根．已知根．具知根

释曰。此是何经所说。谓有梵志名曰生测。来诣佛所。欢喜问讯。在一面坐。而白佛言。施设几根摄诸根尽。佛言。我说二十二根摄诸根尽。若有遮此更说余根。当知彼说有言无义阿毗达磨俱舍论实义疏卷第五

        尊者安惠造

    分别根品第二之一(论卷第三)

颂曰

  传说五于四　　四根于二种
  五八染净中　　各别为增上

论曰。眼等五根至闻声别故。颂云

  譬如明眼人　　能避现险难
  世有聪明者　　能离当苦惠
  多闻能知法　　多闻能离罪
  多闻舍无义　　多闻得涅槃

颂曰

  身由食住　　命托食存　　食已令心
  适悦安泰

若男入胎于母生爱于父生恚。若女入胎于父生爱于母生恚。由如故知能续后有。皆是染心。是以意根于续后有

经云。父母精血入胎者。识所摄持方能成就羯剌蓝也

释曰。此显身语随心转义。如契经言。心能导世间。心能遍摄受。如是心一法。皆自在随行。颂曰

  了自境增上　　惣立于六根
  从身立二根　　女男情增上
  于同住杂住　　清净增上
  应知命五受　　信等立为根
  未当知已知　　具知根亦尔
  于得后后道　　涅槃等增上

论颂云

  身不悦名苦　　即此悦名乐
  及三定心悦　　余处此名喜
  心不悦名忧　　中舍二无别
  见修无学道　　依九立三根

颂曰

  唯无漏后三　　有色命忧苦
  常知唯有漏　　通二余九根

言最后三根定是无漏。除此三根之外不通无漏。契经言。尔时世尊成正觉已作是思惟。我所证法甚深微妙。难见难解。不可思议。非寻思境。是智者所知。非凡愚所及。斯诸众生久习邪教。爱着诸有。诸见所惑乱故不能解了。以不了故不能信受。及生娆恼。我所言说无所利益。唐没劬劳。不如寂法受解脱乐。作是念已默然而住。尔时娑婆世界主大梵天王知佛世尊作如是念。即自思惟。此世界中诸众生等多所失坏。今佛世尊证无上法。深广微妙虑诸众生不能信受。遂处闲寂受现法乐。我应诣彼劝请世尊转妙法轮。作是念已。譬如壮士屈申臂顷。从梵宫没。至于佛所。顶礼佛足。绕三匝已。却住一面。合掌恭敬。而白佛言。世尊。此世界中诸众生等久习异教。见惑萦缠。流转生死。无所归依。无所救护。世尊旷劫为诸众生修行[(妳-女)-小+水]引。今者得成无上正觉。证无上法。出现于世。如优昙花。不为有情随机演说。处于闲寂。静默而住。唯愿世尊。降大悲心。哀愍世间。为诸有情。说正法要。有诸众生。诸结微薄。机宜成熟。利根易化。不闻法故。自然损减。失大法利。唯愿世尊。为诸众生。开甘露门。说微妙法。令诸有情利益安乐。尔时大梵天王。劝请世尊。而说偈言

  世尊出现为优昙　　旷劫难逢今一遇
  普为有情获法利　　唯愿广开甘露门

尔时世尊闻梵天王劝请偈已。起大悲心。即以道眼观诸有情。或有钝根执着诸有。或有中根少厌生死。或有利根而不放逸。如是世尊观诸世间一切有情。处在世间或生或长。根有利钝。或有易化得道。如实知已。受梵王请。许转法轮。而说偈言

  大梵天王善谛听　　我所得法甚微妙
  今为汝等广开演　　令于长夜获安乐

颂曰

  命唯是异熟　　忧及后八非
  色意余四受　　一一皆通二

论唯一命根定是异熟。释曰。无一命根非是异熟。颂曰

  北洲定千年　　西东半日减
  此洲寿不定　　后十初叵量

等。世间有情所余福业。咸发愿言。愿我长寿。亦不愿言愿我住寿至于百年或住九十八十年等。或有尊人及亲友等恒祝之言。愿汝长寿。亦不定言尔所时等以此洲人所作诸业。与贪心俱作是愿。契经中说。苾刍当知。毗婆尸佛时。人寿八万岁。乃至迦叶波佛时。人寿二万岁。我今出世。人寿百岁。少出多减等。寿若无定限者。世尊何故作如是说。劫初诸根大种殊胜。寿即延长。今时渐劣故寿难至于十岁。福尽即死。不因命也。修故塔寺能延其寿。颂曰

  梵行妙成立　　圣道已善修
  寿尽时欢喜　　犹如舍众病


毗婆沙

    No. 1546 [No. 1545; cf. Nos. 1543, 1544, 1547]

    毗婆沙序

        释道挻作

毗婆沙者。盖是三藏之指归。九部之司南。司南既准。则群迷革正。指归既宣。则邪轮辍驾。自释迦迁晖。六百余载。时北天竺有五百应真。以为灵烛久潜。神炬落耀。含生昏丧。重梦方始。虽前胜迦栴延撰阿毗昙以拯颓运。而后进之贤寻其宗致。儒墨竞构。是非纷拏。故乃澄神玄观。搜简法相。造毗婆沙。抑止众说。或即其殊辩。或标之铨评。理致渊旷。文蹄艳博。西域胜达之士。莫不资之以镜心。监之以朗识。而冥澜潜洒。将洽殊方。然理不虚运。弘之由人。大沮渠河西王。天怀遐廓。摽诚冲寄。虽迹缠纷务。而神栖玄境。冉能丘壑。廊馆林野。是使渊叟投竿。岩逸来庭。息心升堂。玄客入室。诚诣既着。理感不期。有沙门道泰。才敏自天。冲气疏朗。关博奇趣。远参异言。往以汉土。方等既备。幽宗粗畅。其所未练唯三藏九部。故杖策冒崄。爰至葱西。综揽梵文。义承高旨。并获胡本十万余偈。既达凉境。王即欲令宣译。然惧环中之固。将或未尽。所以侧席虚衿。企嘱明胜。天竺沙门浮陀摩。周流敷化。会至凉境。其人开悟渊博。神怀深邃。研味钻仰。俞不可测。以乙丑岁四月中旬。于凉城内苑闲豫宫寺。请令传译理味。沙门智嵩道朗等三百余人。考文评义。务在本旨。除烦即实。质而不野。王屡回驾。陶其幽趣。使文当理诣。片言有寄。至丁卯岁七月都讫。合一百卷。会凉域覆没。沦湮遐境。所出经本。零落殆尽。今凉王信向发中。探练幽趣。故每至新异。悕仰奇闻。更写已出本六十卷。送至宋台宣布未闻。庶令日新之美。敞于当时。福祚之兴。垂于来叶。挻以微缘。豫参听末。欣遇之诚。窃不自默。粗例时事。以贻来哲

如来灭后法胜比丘造阿毗昙心四卷。又迦旃延子造阿毗昙。有八犍度凡四十四品。后五百应真造毗婆沙重释八犍度。当且翻时大卷一百。太武破沮渠已后。零落收拾得六十卷。后人分之作一百一十卷。唯释三犍度在。五犍度失尽

阿毗昙毗婆沙论卷第一

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

云何世第一法。何故名世第一法。如是章及解章义。是中应广说。优波提舍问曰。谁造此经。答曰。佛世尊。所以然者。诸法性相甚深微妙。唯一切智乃能究尽。问曰。谁问谁答。答曰。或有说者。尊者舍利弗问佛答。复有说者。五百阿罗汉问佛答。复有说者。诸天问佛答。复有说者。化人问佛答。所以者何。诸法性相应当广说。然无问者。尔时世尊。作化比丘。剃除须发。着僧伽梨。形容端政。彼问佛答。如问众义经因缘问曰。若然者。何故复言迦旃延子造耶。答曰。彼尊者常好受持读诵。为他解说广令流布。名称归彼故言其造。复有说者。即彼尊者迦旃延子造作此经。问曰。向言诸法性相甚深微妙。唯一切智乃能究竟。尊者迦旃延子云何能造。答曰。彼尊者迦旃延子。亦有猛利甚深智慧。善知总相别相。又知文义及前后际。通达三藏。三明六通具八解脱。离三界欲获得愿智。于五百佛所修行立愿。愿使我于未来世释迦牟尼佛遗法之中。造阿毗昙经。问曰。若然者。佛阿毗昙何者是耶。答曰。世尊于处处方邑。为化众生作种种说。彼尊者迦旃延子。于种种说中。立章门造偈颂。制品名作犍度。若说种种不相似义立杂犍度。若说使相立使揵度。若说智相立智犍度。若说业相立业犍度。若说四大相立四大犍度。若说根相立根犍度。若说定相立定犍度。若说见相立见犍度。如法句经。世尊于处处方邑。为众生故种种演说。尊者达摩多罗。于佛灭后种种说中。无常义者立无常品。乃至梵志义者立梵志品。此迦旃延子亦复如是。又诸佛出世尽说三藏。所谓修多罗毗尼阿毗昙

问曰。修多罗毗尼阿毗昙有何差别。答曰。或有说者无有差别。所以者何。从一智海佛河出故。因大慈心说故。复有说者亦有差别。云何差别。名即差别。所谓此修多罗此毗尼此阿毗昙。复次为分别心名修多罗。为分别戒名为毗尼。为分别慧名阿毗昙。问曰。若然者。修多罗中亦分别戒亦分别慧。毗尼中亦分别心。亦分别慧。阿毗昙中亦分别心。亦分别戒。如是三藏。有何差别。答曰。从多分故。修多罗中多说心法。毗尼中多说戒法。阿毗昙中多说慧法。复次修多罗中。若分别心名修多罗。若分别戒名毗尼。若分别慧名阿毗昙。阿毗昙中。若分别戒名毗尼。若分别心名修多罗。若分别慧名阿毗昙。毗尼中。若分别慧名阿毗昙。若分别戒名毗尼。若分别心名修多罗。如是三藏。是名差别。复次修多罗中应次第求。以何等故。世尊说此。次复说此(如说信佛次应信法是次第求义)。毗尼中。应因缘求。如说此戒缘何事制。阿毗昙中。应以相求。不以次第。复次修多罗依力故说。毗尼依大慈故说。阿毗昙依无畏故说。复次种种杂说名修多罗。广说戒律名曰毗尼。说总相别相名阿毗昙。复次未种善根令种善根名修多罗。已种善根欲令成熟名曰毗尼。善根已熟得正解脱名阿毗昙。复次为初入法名修多罗。已入法中为受持戒名曰毗尼。已受戒者为令正解名阿毗昙。修多罗毗尼阿毗昙。是名差别

问曰。彼尊者以何因缘造作此经。答曰。为饶益他故。若有受持读诵通利说正忆念。无量烦恼及诸恶行不现在前。以此勤修能入法相。譬如有人。欲饶益他于黑闇中。然大灯明。为有目者见种种色。彼尊者亦复如是。为饶益他造作此经。佛亦如是为饶益他说十二部经。一修多罗。二祇夜。三婆伽罗那。四伽他。五优陀那。六尼陀那。七阿波陀那。八伊帝目多伽。九阇陀伽。十毗佛略。十一阿浮陀达摩。十二优婆提舍。所以者何。若有众生。虽有内因无外缘者。终不能修胜进之行。若遇外缘则能修行。譬如钵头摩分陀利拘物头优钵罗华在池水中。日光不照不开不敷不香。日光若照则开敷出香。如闇室中有种种物。若无灯照终不可见。有灯则见。众生亦然。虽有内因若无外缘。终不能修胜进之行。若遇外缘。则能修习胜进之行。以是缘故。佛说偈言

  譬如闇室中　　虽有种种物
  若无灯明照　　有目不能见
  若人虽有智　　不从他闻法
  是人终不能　　分别善恶义
  譬如有目人　　因灯见众色
  有智依多闻　　能别善恶义
  多闻能知法　　多闻能远恶
  多闻离无义　　多闻得涅槃

佛经亦说。有二因二缘发于正见。一从他闻法。二内正思惟。又说。人有四法甚为希有。一亲近善知识。二从他闻法。三内正思惟。四如法修行。又说。若我弟子。一心听法能断五盖。具足修行七觉分法。如佛世尊为饶益他故说十二部经。彼尊者亦复如是。复次为破无明闇故。如灯破闇作明。阿毗昙者亦复如是。破无明闇与智慧明。复次欲令无我像得分明故。譬如明镜照诸色像。若人能以阿毗昙慧。善分别总相别相。无我人像自然显现。复次为度生死河故。譬如百千那由他众生。依坚牢船而无所畏。能从此岸到于彼岸。如是百千那由他诸佛世尊。及诸眷属亦复如是。依阿毗昙船而无所畏。能从此岸到于彼岸。复次为诸修多罗经作灯明故。如人执炬于诸闇中终无所畏。如是行者执阿毗昙炬。于诸修多罗义中而无所畏。复次为观察善不善无记法故。如善识宝人善别金刚等宝。如是知者。以阿毗昙慧。分别善不善无记法。复次为现阿毗昙人须弥山不倾动故。如须弥山王安住金轮地上。四方猛风不能倾动。如是智者。以阿毗昙慧须弥山。安置于戒金轮地上。四倒邪风不能倾动。复次以三因缘故。尊者迦旃延子造作此经。一为增益智故。二为开觉意故。三为断我人故。增益智者。于内外法中一切经论莫若阿毗昙。开觉意者。众生常眠无有觉时。不知何者是一切遍使何者不遍使。何者自界缘遍使。何者他界缘遍使。何者有漏缘。何者无漏缘。何者有为缘。何者无为缘。云何为摄。云何相应。云何因。云何缘。谁成就。谁不成就。能了知如是等远近法者。是阿毗昙力。断我人者。彼尊者造阿毗昙经。未曾说有我人。于一切处常说无我无人。以如是等众因缘故。彼尊者造阿毗昙经。问曰。阿毗昙体为何者是耶。答曰。无漏慧根。自体摄一界一入一阴。一界者法界。一入者法入。一阴者行阴若取相应共有摄三界二入五阴。三界者意界识界法界。二入者。意入法入。五阴者色受想行识。又修多罗说。此帝释长夜其心质直无有谄曲。诸有所问。为了知故不为娆乱。我当以甚深阿毗昙。恣汝所问。此中何者是甚深义。所谓无漏慧根。又如经说。有梵志姓犊子。其性质直无有谄曲。诸有所问。为了知故不为娆乱。我当以甚深阿毗昙。恣汝所问。此中何者是甚深义。所谓无漏慧根。复有梵摩瑜婆罗门须跋梵志。亦如上说。如佛告先尼梵志。我法甚深。难解难了难知难见。非思量分别之所能及。唯有微妙决定智者。乃能知之。非汝浅智之所能及。所以者何。空即无我。而汝计我。汝常长夜有异见异欲异心。以是之故。非汝浅智之所及也。此中何者。是甚深义。所谓空三昧也。如说愚人无眼。而与上座智慧比丘论甚深义。此中何者是甚深义。所谓退法是也。如佛告阿难。此十二因缘法甚深。难解难了难知难见。非思量分别之所能及。唯有微妙决定智者。乃能知之。非汝浅智之所能及。此中何者是甚深义。所谓因缘是也。如说此处甚深。所谓缘起。此法离欲寂灭涅槃。此中何者是甚深义。所谓因缘寂静灭性也。如说诸法甚深故难见。难见故甚深。此中何者是甚深。一切诸法体性甚深是也。问曰。阿毗昙体。何者是耶。答曰。无漏慧根。以无漏慧根力故。令生处得慧。能受持十二部经。读诵通利。亦名阿毗昙也。又以无漏慧根力故。能令闻慧知总相别相。又令闻慧建立总相别相。又令闻慧断自性愚及缘中愚。于法不谬。又以无漏慧根力故。能令思慧。不净安般念处等。亦名阿毗昙。又以无漏慧根力故。能令修慧。暖顶忍世第一法。亦名阿毗昙。又以如是等慧。令无漏慧根。转得明净。名阿毗昙

问曰。若无漏慧根。是阿毗昙体者。何故此经复名阿毗昙。答曰。阿毗昙具故亦名阿毗昙。如处处经中说。因种种具立种种名。以漏具故说漏。如说七漏。是烦恼。是炽然。是苦恼。实漏有三。所谓欲漏有漏无明漏。垢具故说垢。如偈说

  女垢梵行　　女缚众生　　苦行梵行
  不因水净

女实非垢。实垢有三。所谓贪嗔痴垢。乐具故说乐。如偈说

  饮食时乐　　着衣亦乐　　经行山窟
  斯亦复乐

饮食等非乐。实乐者是乐受。使具故说使。如说比丘为色所使为色所系。色非是使。实使有七。味具说味。如说比丘眼味于色。色是魔钩。眼非是味。实味是爱。欲具说欲。如说五欲美好能令爱心增长染着。色等非欲。实欲是爱。退具说退。如说时解脱阿罗汉有五因缘退。一者营事勤劳。二者多诵经。三者诤讼。四者远行。五者长病。非营事等是退。实退是不善隐没无记法。业具说业。如说比丘有三种意不善业生苦果报。所谓贪恚邪见。贪恚邪见。体非是业。实业有三。谓身口意。报具故说报。如尊者阿泥卢头说。我以一食施报。七生三十三天。七生波罗柰国。食非生报。生报者是不善。善有漏法。如是等处处经中说。因种种具说种种名。此亦如是。阿毗昙具故说阿毗昙问曰。以何义故名阿毗昙。答曰。尊者和须蜜说。能决定分别十二部经名阿毗昙。复说能觉了十二因缘名阿毗昙复次于四圣谛。能次第得正决定名阿毗昙。复说能解说修习八圣道法。名阿毗昙复说能证涅槃名阿毗昙。尊者婆檀陀说曰。烦恼出要。系缚解脱。生死涅槃。如是等法。以名味句身。次第撰集。分别解说。名阿毗昙。尊者瞿沙说曰。求解脱者诸所施行。未分别者皆分别之。所谓是苦是苦因。是道是道果。是方便道。是无碍道。是解脱道。是胜进道。是向果道。是得果。名阿毗昙。尊者波奢说曰此智是究竟智。此智是第一智。此智是不谬智。名阿毗昙。阿毗昙人说曰。能种种选择觉了。证知一切诸法。名阿毗昙。复说法性甚深。能尽其原底。名阿毗昙。复说能净法眼名阿毗昙。复说显发幽隐甚深智慧。名阿毗昙。复说若人以阿毗昙慧。分别总相别相。无有人能如法说其过者。名阿毗昙。弥沙塞部说曰。如灯能照名阿毗昙。如说一切照中慧照最上昙摩掘部说曰。此法增上名阿毗昙。如说一切诸法慧为最上。譬喻者说曰。种种诸法涅槃为上。此法次故名阿毗昙。声论者说曰。阿毗言除弃亦言选择。除弃者所谓结缚使缠烦恼。选择者所谓阴入界缘起道品等诸法。复次阿毗言增上慢。如说名增上慢。如说上者名增上者。如说上逸名增上逸。此经增上名阿毗昙。复次阿毗言现前。一切诸善道品等法皆现在前。名阿毗昙。复次阿毗言恭敬。此法尊重可敬。名阿毗昙。此经名智慧基本。问曰。何故名智慧基本。答曰。诸究竟智皆出此经。故名基本。复次此经名安智足处。诸究竟智皆因此经而得成立。是故名安智足处。问曰。此经有何利益。答曰。随顺解脱。随顺无我。断计我人。显明无我。发人觉意。出生智慧。除愚痴。断疑网。得决定。背炽然。向出要。得相续。乐寂静。止生死轮。随顺空法。到涅槃岸。能断一切外道异见。于佛法中。能生一切欣乐之心。此经有如是等利。名阿毗昙

    阿毗昙毗婆沙杂犍度世第一法品第一

云何世第一法。问曰。何故此经先说世第一法。为顺次说为逆次说耶。若顺次说者。应先说不净。次说安般。次说念处。次说七处。善三种观义暖顶忍。然后应说世第一法。若逆次说者。应先说阿罗汉果。次说阿那含果。次说斯陀含果。次说须陀洹果。次说见道。然后应说世第一法。又问。为以初入法故说。为以达分善根故说。为以最胜功德故说。若以初入法说者。应说不净若说安般。若以达分善根说者。应先说暖法。以暖法最在初故。如尊者瞿沙论中先说暖法。若以最胜功德说者。应先说阿罗汉果。有如是等事。如佛在世。尊者大迦旃延有正观智慧。成就无量功德无碍精进。入阿毗昙海。心无增减。觉意无边。言论难胜。一切义论无能当者。第二迦栴延子亦有如是智慧功德。何故造作此经。先说世第一法。答曰。诸论师说世第一法种种不同。或有说者不以顺次故说。亦不以逆次故说。但彼作经者意尔。随彼意故造作此经。不违法相。是故先说世第一法。或有说者。阿毗昙应以相求。不求次第。修多罗经应求次第。毗尼应求因缘。阿毗昙经若求次第于文烦乱。是故不应求其次第。或有说者。世尊经说。若人不能正观诸行性相。能起世第一法者。无有是处。若能正观诸行性相。能起世第一法者。斯有是处。如世尊经中先说世第一法。彼作经者。因经造论。故亦应先说世第一法。问曰。置作经者。世尊何故先说世第一法。答曰。世尊为化众生次第说法。诸受化者已得下忍中忍。未得上忍及世第一法。欲令得故。世尊说正观思惟诸行性相。当知即是上忍。次得此世第一法。是故先说。或有说者。为止诸诽谤故。世第一法多诸诽谤。所谓名受诽谤。体受诽谤。界受诽谤。现前受诽谤。退受诽谤。名受诽谤者。或言是性地法非世第一法。体受诽谤者。或言是五根性。界受诽谤者。或言是欲界系。或是色无色界系。或是三界系。或是不系。现前受诽谤。或是多心相续非是一心。退受诽谤者。或言世第一法退。为止如是等诸诽谤故。先说世第一法。复次一切生死非牢固法。如粪扫污泥。此中谁最胜谁牢固谁如醍醐所谓世第一法。是故先说。复次以随顺无我故。此经常说无我。非如外典说我说欲法说有法说财。此经唯说无我解脱涅槃。此世第一法。亦观无我。随顺此经故。是以先说。复次此经于一切论中最胜。世第一法于一切世俗善法中最胜。以此经胜故应先说胜法。复次若住世第一法时。名真佛出世。能得自在受用圣法。佛出世间。众生入法凡有二种。一假名。二真实。假名者。剃除须发而被法服正信出家。真实者。起世第一法。次第能入苦法忍。是假名沙门有二过患。一者破戒。二者舍戒。入正法者无如是过。真实沙门。受用圣法能得自在。随其性分终无退失。复次住世第一法时。无始生死已来。圣道门闭今始能开。未曾能舍凡夫之性今始能舍。未曾能得无漏圣道今始能得。是故先说世第一法。复次住世第一法时。舍名得名。舍数得数。舍界得界。舍性得性。舍名得名者。舍凡夫名得圣人名。数界性亦如是。复次住世第一法时。得心不得心因。得明不得明因。得受不得受因。复次住彼法时。舍旧缘得新缘。舍共得不共。舍世间得出世间。复次为断疑故。众生谓凡夫性。无始亦谓无终。今说世第一法即示其终。复次住彼法时。凡夫退患。凡夫变异。凡夫刚强。悉不复起。暖顶忍法或有起。复次住彼法时。无有不得圣法而命终者。暖顶忍不尔。住彼法时。无有不得圣道而命终者。不得正决定。而得正决定。不得果得果。出不定聚入正定聚。无圣道有圣道。无不坏净有不坏净亦如是。复次住此善根。无有止滞。暖顶忍法而有止滞。复次住彼法时。凡夫人所修念处究竟满足。余则不尔。复次住彼法时。漏无漏心。有断有续。断者有漏心。续者无漏心。余则不尔。复次如须弥山王安金轮上。四方猛风不能倾动。住此法时。四倒邪风不能倾动。复次住彼法时。示始终故犹如明相。是夜末昼初。彼亦如是。世俗之末圣道之初。如示始终。度已度入出方便究竟亦如是。复次欲示相似法有异相故。世第一法。苦谛所摄。能生灭苦道。以苦摄。世俗摄。生死摄。诸有摄。身见所使摄法。生灭苦道。余则不尔。复次世第一法体。是世俗缘。能生出世缘。是故先说。如是有垢无垢。有过无过。有毒无毒。有浊无浊。有身见聚无身见聚。有颠倒聚无颠倒聚。有爱聚无爱聚。有使聚无使聚。亦如是。复次以世第一法有势有力。能有所作犹如健夫。住此法中得正决定故。复次以三事故。一以经义故。二止诽谤故。三即此刹那得果故。经义止谤如上说。即此刹那得果者。世第一法。次第能生苦法忍。名功用果。以是次第诸因缘故。先说世第一法。复次欲逆次说凡夫所得法故。如说世第一法。乃至暖法。是名凡夫所得出要法。如说二十身见等。是名凡夫烦恼法。此二种法。谁能知者。唯无我智。是故第二品中。作如是说。颇有一智知一切法。乃至广说。此无我智。何由而生。由觉缘起。是故第三品中。作如是说。一人此生十二种缘。乃至广说。所以能觉缘起。由于爱敬。是故第四品中。作如是说。云何为爱。云何为敬。乃至广说。此爱敬何因而起。由有惭愧。是故第五品中。作如是说。云何惭云何愧。乃至广说。谁能惭愧。由解法相。是故第六品中。作如是说。色中生住老无常。当言色也非色也。乃至广说。何由能解法相。由断无义修习有义。是故第七品中。作如是说。诸他修苦行。当知无义俱。乃至广说。何由断无义修有义。由正思忆。是故第八品中。作如是说。云何为思云何为忆。乃至广说。以是众因缘事。欲逆次说凡夫所得法。是故先说世第一法

云何世第一法。答曰。于诸心心数法。次第得正决定。是名世第一法。问曰。已能得正决定。当能得正决定。复是世第一法不。答曰。亦是。若说现在当知则说过去未来。问曰。世第一法。得正决定。为住时得为灭已得。若住时得者。亦是凡夫亦是圣人。若灭已得者。何故不言已得正决定而言今得。答曰。应说已得。所以经文不说已得。自有已得说言今得。如说大王从何处来。此名已来而说今来。已觉诸受。已断漏。已得解脱亦如是。或有说者。应作是说。无间得正决定。是名世第一法。评曰。无间得正决定。次第得正决定。有何差别。复有说者。苦法忍虽未生。此第一法决定为次第缘。是故言今得正决定。或有说者。于诸五根。次第得正决定。是名世第一法。问曰。谁作此说答曰。旧阿毗昙人说。问曰。彼何故说五根。是世第一法。答曰。彼不必欲令五根是世第一法。为断异论故。异论者毗婆阇婆提说。信等五根一向无漏故。一切凡夫悉不成就。问曰。彼以何故作如是说。答曰。彼依佛经。佛经说言。五根猛利。通达满足。向阿罗汉。若无五根堕凡夫数。彼以经作如是说故。言信等五根悉是无漏。为断彼人如是论故。说信等五根是世第一法。若信等五根是无漏者。无始已来未曾能起一念无漏。而得世第一法。是故当知五根非纯无漏。复次若五根是无漏者。违佛正经。如说若我于信等五根。不能如实观是集是灭是味是患是舍者。则不能得阿耨多罗三藐三菩提。乃至广说。不应以如是相观无漏法。毗婆阇婆提曰。应以如是相观无漏法。云何应观如经说。不能如实观信等五根者。是别相观信等五根。何由而得。由亲近善知识积集而得。是名观集。云何观灭。未知欲知根灭。已知根生。是名观灭。云何观味。此无漏法。亦为爱缘。是名观味。问曰。无漏法亦为爱所系耶。答曰不也。如汝法中有无漏缘使缘而不缚。我亦如是。云何观患。诸无漏法。是无爱故。是名观患。云何观舍。一切有为涅槃时舍。是名观舍。为断如是种种诸论故作是说。于诸五根次第得正决定。是名世第一法。复次若当五根一向无漏。复违佛经。如说我以佛眼。观众生根有上中下。毗婆阇婆提说曰。佛经说上根者阿罗汉。中根者阿那含。下根者斯陀含须陀洹。育多婆提说曰。若尔者。世尊不转法轮名转法轮。一切圣人已满世间。佛亦不须复转法轮。毗婆阇婆提说曰。世尊所以说诸众生上中下根者。说根所依处。不说根体。育多婆提说曰。若然者复违此经。如说阇提输那婆罗门。往至佛所白佛言。沙门瞿昙说有几根。佛答言。有二十二根。此亦说根所依处。然俱同说是根。一是根所依。一是根体无有是处。是故信等五根。应有漏无漏。问曰。毗婆阇婆提所引佛经。当云何通。答曰。信等五根有二种。有漏无漏。彼经唯说无漏。所以者何。因诸根故说。圣人差别。复次五根有漏无漏。彼经唯说无漏。所以者何。以圣为对治法故。圣人差别。问曰。上言若无五根堕凡夫数。此云何通。答曰。彼言堕凡夫数者。谓断善根凡夫。或有说者。犊子部说。五根。是世第一法。何以故五根是善性。以五根善故余数法亦善。亦以根故。圣人差别。如说五根猛利通达满足。得阿罗汉。广说如上。问曰。以何事故。尊者迦旃延子引犊子部所立义耶。答曰。彼犊子部所说而与此经少有相违。所谓五根是世第一法凡夫性一向染污。彼以欲界苦谛所断十使。是凡夫性。涅槃有三种。学无学非学非无学。阿须罗是第六道。说有我人。为如是等。若五若六。与此经相违。莫谓彼部所说尽与此经同。彼作经者。为断如是意故。次作是说。如我义。于诸心心数法。次第得正决定。是名世第一法。问曰。如汝所说。五根性善。余心心数法性非是善者。应是不善无记。若以五根性善不善无记亲近五根。亦名善者。今五根亦亲近不善无记。应是不善无记。此则不然。何以故根与心心数法。同一所依。同一行。同一所缘。同一果。同一依。同一报。共成一事。而云其性善是亲近善者。是妄想耳。或有说者。诵持修多罗者。说言五根是世第一法。尊者达摩多罗说曰。世第一法。体性是思名差别耳。尊者佛陀提婆说曰。世第一法。体性是心。名差别耳。所以者何信心异。乃至慧心异。若有众生。能于一时以五种心。次第得正决定。无有是处。若一一次第得正决定。斯有是处。问曰。若然者。以不相应法得正决定耶。答曰。不也。所以者何。汝法心不与心相应。有为所缘。有为所缘故。能次第得正决定。我信亦尔。不与信相应。能有所缘。有所缘故。次第得正决定。乃至慧亦如是。问曰。若然者则有大过。所以者何。若但信心得正决定。不以精进念定慧等得正决定者。懈怠失念乱意恶慧。亦应次第得正决定。乃至慧亦如是。为断彼人如是意故故作是说。如我义于诸心心数法。次第得正决定。是世第一法。如我义者谓不颠倒如法性顺。经文同我等意。而作是说。诸心心数法。次第得正决定。是名世第一法。彼迦旃延子。欲显正义故。言世第一法。亦是根亦非根。问曰。如世第一法。现在前未来世中心心数法。亦修彼为是第一法不耶。答曰。或有说者。依如经本非世第一法。何以故经本说诸心心数法。次第得正决定。是世第一法。彼未来者。不能作次第。是故非世第一法。复次若当是者复违经本。如说世第一法。当言一心非众多心。评曰。应作是说。彼未来者。亦是世第一法。问曰。彼未来者不能作次第缘。云何是世第一法耶。答曰。彼未来者虽不能作次第。而能随顺作次第法。譬如比丘布萨时。不在僧中。而与僧欲名得布萨。僧事亦成。如是彼在未来世中。为现在得如与欲者。若未来世中。无现在得不与欲者。今现在者。亦不能作次第。若作次第。当知皆是未来者力。何以故彼未来者。不与圣道作障碍故。复次若彼未来非世第一法者。与智犍度经文相违。所以者何。如未曾得道。今现在前。彼未来世中。相似种修。若彼未来不作世第一法者。云何名彼种相似修。以是事故。彼未来者亦是世第一法。问曰。若未来是世第一法者。经文何故不说耶。答曰。若能与次第缘者经文则说。彼不能与次第缘。是故不说。复次若流转三世者则说。未来不尔。或有说者。从因而生。成就此法。住在身中。是故说之。彼未来者。虽从因生成就此法。不住身中。是故不说。问曰。若然者。云何非是众多心耶。答曰。此中唯说现在刹那能成事者。故非众多心。或有说者。若能令未来世中修者则说。未来不尔。或有说者。若心彼因彼心此果。是以故说。未来不尔。或有说者。能与因能取果住身中。能有所缘。是以故说。未来不尔。或有说者。有二修义。是以故说。彼未来者。唯有得修无有行修。是故不说。问曰。彼世第一法。俱生色心不相应行。为是世第一法不耶。答曰。或有说者。如经本说。彼非世第一法。所以者何。彼不能与次第缘故。评曰。应作是说。彼亦是世第一法。问曰。彼不能与次第缘。云何名世第一法耶。答曰。彼虽不能与次第缘。而能随顺次第缘义。所以者何。彼与世第一法。俱生住灭。同一果一依一报。是以故说。问曰。彼若是世第一法者。经本何故不说耶。答曰。彼不能与次第缘故。是以不说。或有说者。若从因生成就此法。能有所缘是以说之。彼虽从因生成就此法。不能有所缘。是故不说。或有说者。若是相应。有依有势。有行有缘。是以故说。彼非相应。无依无势。无行无缘。是故不说。问曰彼世第一法。得为是世第一法不耶。答曰。彼非世第一法。问曰。以何等故。生住无常。是世第一法。而得非耶。答曰。生等一事。世第一法。同一果。共行不相离。常相随无前后。得则不尔。不同一果。不共行相离。不相随有前后。或离所得法。如树皮离树。以是义故非世第一法。问曰。以何义故。沙门果得即沙门果。而此第一法。得非世第一法耶。答曰。以成就得故。名沙门果。是以得即沙门果。能与次第缘。亦能随顺次第缘义。名世第一法。得则不尔。是故非世第一法。如是余达分善根。得非达分善根。何以故若得即是达分善根者。已得圣果。应重起达分善根现在前。以成就得故而实不尔。是故得非达分善根。或有说者。若共起世第一法。俱生者名世第一法。后生者非。余达分善根亦如是。或有说者。得即是世第一法。其余达分善根得。即是达分善根。问曰。若然者已得圣果。应重起达分善根现在前。答曰。或现前。或不现在前。何者现前所谓得也。何者不现在前所谓诸相应法也。评曰。不应作如是说。如先所说者好

问曰。世第一法为几念处。答曰。现在一坏缘法念处。未来四。问曰。世第一法为几缘。答曰。为四缘。因缘者相应共有因。次第缘者。与苦法忍作次第缘。境界缘者忍智所缘。威势缘者除其自体。余一切法是彼缘生法。于世第一法亦有四缘。因缘者相应共有法。次第缘者苦忍是。境界缘者欲界五阴是。威势缘者除其自体。余一切法是复有义说者。云何名出世第一法。答曰。苦法忍是。所以者何。是圣道种子故。复有说者。金刚喻定是。所以者何。能尽诸结得究竟果故。复有说者。尽智是。所以者何。以初得尽智。余无漏法时净修故。复有说者。正三昧是。所以者何。得一切有为法中正定最胜故。复有说者。涅槃是。所以者何。一切法中最妙胜故。复有说者。阿罗汉最后心是。所以者何。凡夫人最后心。名世第一法。阿罗汉最后心。名出世第一法。评曰。不应作是说。彼阿罗汉最后心。非出世法故。如先说者好。问曰。颇有世第一法不与苦法忍作次第缘耶。答曰。有。世间第一法。色心不相应法则是。问曰。颇有相应法不与苦法忍作次第缘耶。答曰。有。未来修者是也。尊者佛陀提婆说曰。若以信心。得正决定。是名世第一法与苦法忍作次第缘。余精进念定慧心。是名世第一法。而不与苦法忍作次第缘。说相似法沙门说曰。受与受作次第。不与想等。余数法亦如是。心法生时。遇缘便生。若爱前缘生乐受。欲有所想生想。欲有所作生思。问曰。若然者无相似次第义。答曰。有。但非一一次第耳。如汝法中。无想众生。生时心灭。死时心生。想去虽远得作次第。我法亦尔。如受灭想等生。复还生受。相去虽远得作次第。评曰。不应作是说。心与心作次第。受与受作次第。心心数法。一一次第生。作次第缘。若作是说与经文相违。如说云何心次第法。答曰。心心数法是也。若然者复更有过。如依有觉有观三昧入无觉无观三昧。有觉有观三昧。不应与无觉无观三昧作次第缘。不相似故。无觉无观三昧。则不从次第缘生。若依无觉无观三昧入有觉有观三昧亦如是。若然者无解脱。何以故。欲相应心唯次第生。欲相应心不净观等及诸善心。无由得生。若善心不生则无解脱。有如是等过。如先说者好

以何等故名世第一法。问曰。何故作此论。答曰。前虽说世第一法体性。未说所以名世第一法。今欲说故。犹如有人世称言胜。未知为以族姓财力眷属言为胜耶。彼亦如是。今欲说其所以名世第一。名第一者。此心心法于余法为最为胜为长为尊为上为妙。以如是等义故名为第一。问曰。言第一者。于世法中为都胜为分胜耶。若都胜者。彼则不胜见谛边等智何以故。彼等智见道眷属不相离。慧力胜故。一切见道慧力偏多。复次彼亦不胜净修勋禅。何以故修勋禅者。不与凡夫同生一处。复次彼亦不胜得尽智时一切善根。何以故。得尽智时。所修善根。永离一切诸垢障故。复次彼亦不胜空空三昧无愿无愿三昧无相无相三昧。何以故。空空三昧等。乃至恶贱无漏。何况有漏。若分胜者。彼暖顶忍法。亦应言第一。答曰。或有说者应言分胜。何以故。唯胜暖顶忍法等故。复有说言。第一者。彼则胜一切凡夫所得禅无量解脱。除入一切入乃至第一。有中思故。或有说者。彼则都胜。言都胜者。非谓一切事业中胜。但以能开圣道门故。胜彼见道边等智。虽是见道眷属不相离慧力胜。而不能开圣道门。如等智净修勋禅尽智。俱生善根。空空三昧等。不能开圣道门亦复如是。或有说者。一切都胜。以能开圣道门故。见道边等智。虽是圣道眷属。乃至慧性偏多。若当世第一法。不开圣道门者。彼则不修。若得修者。皆是彼世第一法功用之力。余净修勋禅尽智俱生善根空空三昧等。亦复如是。问曰。第一有何义。答曰。最胜义是第一义。得妙果义是第一义。能入胜分破有顶义是第一义。最后心义是第一义。如高幢顶更无有上。问曰。上言最胜等有何差别。答曰。或有说者。无有差别。所以者何。此言皆是叹说上妙之义。或有说者。以善根故。而有差别。于不净安般名为最。于闻慧名为胜。于思慧名为长。于暖法名为尊。于顶法名为上。于忍法名为妙。或有说者。以地故而有差别。若依未至名为最。若依初禅名为胜。若依中间名为长。若依二禅名为尊。若依三禅名为上。若依四禅名为妙。或有说者。边顶义名为最。上义名为胜。增善义名为长。升进义名为尊。坚牢义名为上。满足义名为妙。复有说者。能与苦法忍作次第故名为最。胜诸凡夫善根故名为胜。逮胜进故名为长。胜世俗善根故名为尊。无二故名为上。与无漏相应故名为妙。复有说者。以最故名胜。以胜故名长。以长故名尊。以尊故名上。以上故名妙。复有说者。是凡夫最后心故名为最。犹如树端。能开圣道门故名为胜。根猛利故名为长。于达分善根中胜故名为尊。折伏烦恼名为上。得好果故名为妙复次此心心法。舍凡夫性者。问曰。舍凡夫性为世第一法。为苦法忍耶。若世第一法舍凡夫性者。云何于一刹那。以凡夫法舍凡夫性。若以苦法忍舍凡夫性者。为以生时舍。为以灭时舍。若以生时舍者。云何未起法。能有所作。若以灭时舍者。彼已灭已复何所舍。答曰。或有说者。即彼世第一法时舍。问曰。若然者云何于一刹那。以凡夫法舍凡夫性。答曰。凡夫性。世第一法相妨碍。是故住世第一法时舍。犹如象师乘象策象。马师船师胜怨之人亦复如是。复有说者。苦法忍生时舍。凡夫性灭时。断见苦所断十使。如灯生时破闇。已生燋炷尽油。问曰。若尔者云何未起法。能有所作。又一法不应能作二事。答曰。若然者有何过。一切内法有二种。于未来中。能有所作相应者苦法忍是也。不相应者生相是也。一切外法。于未来世。能有所作。唯灯是也。或有说者。世第一法。苦法忍共舍凡夫性。世第一法如无碍道。苦法忍如解脱道。世第一法与凡夫性。成就得俱灭。苦法忍与不成就得俱生。世第一法。依苦法忍。苦法忍助其势力。能舍凡夫性。譬如羸人依因健者能伏怨家。彼亦如是。得圣法者苦法忍是也。舍邪性者世第一法是也。问曰。邪性有三种。一趣邪性。二业邪性。三见邪性。趣邪性者。三恶趣是也。业邪性者。五无间业是也。见邪性者。五见是也。于此三种邪性为舍何等。若舍趣业邪性者。尔时则不成就。若舍见邪性者。道比智现在前。尔时乃舍。答曰。三种俱舍。问曰。云何俱舍。答曰。不趣不作不行名为舍。不趣者舍趣邪性。不作者舍业邪性。不行者舍见邪性。问曰。若然者住上忍时已舍。何故乃言住世第一法舍耶。答曰。破其所依故。诸烦恼以凡夫性为所依。能起生死过患。犹如师子依于窟穴能害诸狩。彼亦如是。是故说住世第一法时舍。或有说者。苦法忍是邪性对治。问曰。趣邪性业邪性是修道所断。何以乃言苦法忍是其对治耶。答曰。对治有众多。有舍对治有断对治。有持对治。有不作对治。有不趣对治。苦法忍是凡夫性舍对治。断见苦十使是断对治。诸无漏道是持对治。不作无间业及余不善业是不作对治。不趣恶道是不趣对治。如是等名舍邪性。得正性者苦法忍是也。得正决定者见道是也。问曰。一切圣道是正决定。何故独称见道是也。答曰。或有说者。诸烦恼令众生善根不熟。爱润增长染着不离。彼见谛道能令众生善根成熟。干竭爱水离诸染着。不作覆障。不为所坏。不杂余心。是故见道名正决定。或有说者。众生根熟入于圣道。是故见道名正决定。复有说者。拔烦恼根入于圣道。是故见道名正决定。复有说者。舍五人种入八人性。是故见道名正决定。或有说者。扶持长养名正决定。犹如牛马因于水草长养性命。一切圣人。因于见道长养慧命。是故见道名正决定。或有说者。此法解缚永更不系。是故见道名正决定。或有说者。正必定义是决定义。自有决定而非正所谓邪定是故必定名正决定。或有说者。相应如法义是决定义。见道相应如法故名正决定。问曰。诸正是正性耶。答曰。诸正性彼正也。颇正非正性耶。答曰。有。世第一法是也。问曰。以何等故。世第一法是正而非正性耶。答曰。或有说者。众生无始已来。烦恼恶行。邪见颠倒。恼乱此心。住世第一法而能制伏。是故名正体。是有漏为使所使不名正性。复有说者。等义是正义。犹如称悬在中物偏则低。如是世第一法。等住凡夫性。见道中间。若苦法忍。生圣道偏多。是故等义是正义也。复有说者。等义是正义。佛辟支佛阿罗汉等住上上法故。是故等义是正义也。复有说者。等现前行义是正义。一切行人皆同住一刹那故。复有说者。彼世第一法与苦法忍四事同等。所谓地根行缘地者。如苦法忍。依何地与何根相应。行何行缘何法。彼亦如是。与苦法忍四事同故。名为正体。是有漏为使所使。不名正性

阿毗昙毗婆沙论卷第一阿毗昙毗婆沙论卷第二

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    杂犍度世第一法品之二

世第一法。当言欲界系耶。乃至广说。问曰。何故作此论。答曰。先已说世第一法体性。及说所以名世第一法。未说在何界系。如人言胜。已说胜事。未知住处。今欲说故。故作此论。或有说者。为止并义者意故。如摩诃僧祇部说。世第一法是欲界系。如犊子部说。是色无色界系。何以故。若地有圣道处。亦有世第一法。如昙摩掘部说。或言三界系。或言不系。或言非不系法。为止如是等并义意故而作此论问曰。以何等故。世第一法不当言欲界系。应说其所以。不可但以言故。此义便立。答曰。不以欲界道得断诸盖。亦不能制伏缠。亦不能令现前不行。所言断制不行者。谓究竟断制不行。何以故。以欲界中无道能令盖缠究竟断制不行故。问曰。以何等故。欲界中无道能究竟断盖制伏缠耶。答曰。或有说者。欲界中不善根强善根弱。是故无道能断盖制缠。色界善根强。无不善根。是故有道能断盖制缠复有说者。欲界不善根如旧住。善根如客。旧住有势。客则无力。是故无道。色界善根如旧住。无不善。是故有道。复有说者。欲界善不善同一系缚。是故无道。色界善根。欲界不善根。不同系缚。是以色界道。能断欲界盖制缠。复有说者。欲界威仪。无有忌难犹如夫妻。色界威仪。共相敬难犹如母子。复有说者。欲界是破惭愧法。如居士子与旃陀罗子交。色界有惭愧。如王不与旃陀罗交。复有说者。欲界爱结。爱欲界善根。以爱善根故。不能生厌离想。欲界爱不能爱色界善根。以不爱故。能生厌离想。以如是等因缘故。欲界中无道能断盖制缠。色界有道能断盖制缠。或有说者。言断盖者。是究竟断。制伏诸缠不现前行者。是须臾断。如究竟须臾断如是。有缚无缚有影无影有片无片亦如是。复有说者。言断盖者害其根本。言制伏不现前行者。是制伏诸缠。复有说者。言断盖者。拔诸烦恼。制伏不现前行者。是制伏诸缠。问曰。欲界中虽无究竟断盖制缠道。可无须臾断盖制缠道耶。答曰。有。但不可信。何以故。不坚牢。不久住。不相续。不相着。不久住心中不能久伏烦恼得正决定。犹如水上浮萍以小石投之。虽散随合。虾蟆入中。数散数合。有如是等缘故。欲界虽有须臾断道。而不可信。色界断道可信。何以故。牢固久住相续相着。久住心中能制伏烦恼。得正决定。犹如大石投浮萍中散而不合。龙象入中亦散不合。有如是等缘。是故色界道。能拔诸盖制缠害。诸烦恼制伏不行。问曰。若然者如汝所说。世第一法应唯在未至禅。所以者何。断欲界盖制缠对治道。唯在未至禅。余上地则不应有。答曰。对治有二种。一断对治。二过患对治。若依未至禅。断欲界欲。有二种对治道。余上地虽无断对治。有过患对治。尊者瞿沙说曰。六地中尽有断欲界欲二种对治道。所谓断对治。过患对治。何以故依未至禅。断欲界欲。其余诸地而不断者。先已断故。犹如日光于一切时与闇相妨。日初出时已破夜闇。其余日分。虽与闇相违。而不破者。先已破故。亦如六人同一怨家而共议言。随于何处获便害之。犹如有人次持六灯入于闇室。初灯破闇。其余诸灯。虽与闇相违。而不破者。先已破故。如是六地中。尽有断欲界欲二种对治道。乃至广说。复次云何知六地中尽有断欲界欲二种对治耶。若当六地中无断欲界欲二种对治者。行者依上地。得正决定。不应分别欲界。亦不作证。然能分别作证。以是缘故。知六地中尽有断欲界欲二种对治。若以欲界道。能断盖制缠。亦能除欲界结。乃至广说。问曰。世第一法。不能断结。何以言若当以欲界道得断盖制缠。乃至广说。答曰。世第一法。虽不能断结。而此善根妙胜第一。在深远处。宜应与彼地离欲界道同在一处。是故以道证之。问曰。以何等故。世第一法不能断结耶。答曰。彼善根微小法身未长。虽尔有大威势。以善根微小法身未长。不能断结。有大威势故。不为诸结之所毁坏。如师子子身小未长。不能害狩。有大威势。一切诸狩不能侵害。或有说者。世第一法。是一刹那故不能断结。问曰。苦法忍亦一刹那。何以能断结耶。答曰。彼虽一刹那。后有同性相续故。是以能断。或有说者。彼是方便道。不以方便道能断烦恼。但不以欲界道得断盖制缠。亦不能除欲界结。乃以色界道。得断盖制缠。乃至广说。作义者说曰。以何等故。世第一法不欲界系耶。或有说者。欲界卑贱。彼善根尊胜。复有说者。欲界薄淡。彼善根美妙。复有说者。欲界散乱。彼善根寂定。复有说者。欲界非修。彼善根修。复有说者。欲界非离欲法。彼善根随顺离欲法。复有说者。若世第一法是欲界系者。有自缘过。云何名自缘过。如苦法忍缘欲界五阴。若世第一法是欲界系者。亦应缘欲界系五阴。若缘欲界系五阴。彼应自缘。若不缘者复违经文如说如苦法忍所缘。彼世第一法亦缘。便有如是自缘之过。作义者说曰。以何等故。世第一法是色界系。答曰。色界法能与三种道作次第缘。所谓见道修道无学道。余界不能与三道作次第缘。若欲界能与三道作次第缘者。则有世第一法。如三道三地三根。初生法智分。次生比智分。如是等色界种种诸功德。应当广说。以何等故。世第一法。不当言无色界系。答曰。得正决定。先见欲界苦谛苦行。后色无色界俱。问曰。苦谛有四行。何以此中说见苦时。但说苦行。不说无常空无我行耶。答曰。此文应作如是说。得正决定时。先见欲界苦谛。不应言苦行。然不尔者。彼作经者。有何等意。答曰。为现初始次第方便法故。如说苦行。无常空无我行。亦应如苦行说。复有说者。以苦行唯在苦谛中。无常行在三谛中。空无我行在一切法。复有说者。此苦与一切有法相违。能弃生死。犹如小儿。虽有种种美食在前。有人语言。此食是苦。即便舍之。复有说者。一切众生老少愚智。内道外道皆信是苦。复有说者。此苦粗现易以智知。所以者何。佛说苦智。为缘何法。即缘苦法。如智所知觉所觉行所行。根根义缘所缘。应如智说。复有说者。说苦文句。久远所传。古昔诸佛皆说苦行。是以行者先见于苦。问曰。以何等故先见欲界苦。后色无色界俱。答曰。或有说者。欲界苦粗现。在了了易见。是以先见。色无色界苦细不现。不了了难见。是以后见。问曰。若然者色界苦粗。无色界苦细。何以俱见耶。答曰。以定不定故。欲界不定是以先见。色界苦虽粗。与无色界俱同定故。是以俱见。如是定不定。住离欲地住不离欲地。住修地不住修地。说亦如是。复有说者。欲界苦。是行者身生病苦痛。是以先见。色无色界苦。非行者身不生苦痛。是以后见。复有说者。欲界苦近是以先见。色无色界苦远是以后见。如近远。现见不现见俱不俱此身他身亦如是。复有说者。行者成就欲界凡夫性故。是以先见。不成就色无色界凡夫性故。是以后见。复有说者。行者于欲界苦现见故。是以先见。色无色界苦不现见故。是以后见。问曰。若色无色界苦不现见者。行者云何见耶。答曰。现见有二种。一离欲现见。二自身现见。行者于欲界苦。有二种现见。一离欲现见。二自身现见。于色无色界苦。有一种现见。所谓离欲现见。犹如商人有财两担。一自负之。二使人担。于自所负有二种现见。一知物现见。二知轻重现见。于他所担有一种现见。所谓知物现见。复有说者。欲界苦有三种。善不善无记。是以先见。色无色界苦有二种。善无记。是以后见。复有说者。见欲界苦时。断二种结。不善无记。见色无色界苦时。唯断无记。如不善无记。有报无报生一果生二果。无惭无愧相应。无惭无愧不相应。当知亦如是。复有说者。谤言无苦。先从欲界。后色无色界。若信有苦。亦应先从欲界后色无色界。如诽谤生信。无智有智疑决定邪见正见。当知亦如是。若圣道起。先辩欲界事。后色无色界俱。问曰。见道办事有何差别。答曰。或有说者。无有差别。或有说者。亦有差别。知聚是见道。断结是办事。复有说者。知智是见道。断智名办事。如是智作证明得作证明解脱道道果。当知亦如是。复有说者。能见缘境界是见道。所作是办事。复有说者。一刹那是见道。后相续者名办事。如一刹那后相续。入数数入。当知亦如是。复有说者。无碍道所作名见道。解脱道所作名办事。如无碍道所作解脱道所作。远恶修善。舍无义得有义。出下贱入胜处。弃爱炽然。离爱安乐。当知亦如是。若得正决定时。先见无色界苦谛苦行。如是世第一法。当言无色界系。乃至广说。问曰。得正决定时。不先见色界苦。不妨世第一法得名色界系。如是得正决定时。不先见无色界苦谛苦行。世第一法。是无色界系有何过耶。答曰。色界中有遍缘知智能缘下地。是故得有世第一法。无色界中无遍缘知智能缘下地。是故无有世第一法。但圣道起先办欲界事。乃至广说。不应言世第一法是无色界系。作义者说曰。以何等故。世第一法不当言无色界系。或有说者。彼无色界。非因非地非器。以非器等故。是以无世第一法。复有说者。若彼处有观谛善根如暖顶忍者。是处应有世第一法。彼无色中无故无世第一法。复有说者。若有见道处。则有世第一法。无色中无见道故。无世第一法。复有说者。若地有智遍缘一切法。亦有断结对治道。则有世第一法。欲界中。虽有智能缘一切地。而无断结对治道。无色界中。虽有断结对治道。而无智能缘一切地。是故欲界无色界。无世第一法。复有说者。欲界善根不寂静故。无世第一法。无色界道极寂静故。无世第一法。复有说者。欲界善根羸弱故。无世第一法。无色中非其境界故。无世第一法。复次或有说者。入无色定除去色想。乃至广说。问曰。不应言。复次或有说者。若言。复次或有说者。义则不定。应作是说。入无色定除去色想。乃至广说。所以者何。同明一义故。不应如先说无色界苦谛苦行等。应作是说。入无色定除去色想。乃至广说。何以故。此是根本义故。应作是说。而不尔者彼有何义。答曰。言语有二种。一者方便。二者根本。先所说者是方便语。后所说者是根本语。复有说者。先所说者明苦法忍缘欲界法。后所说者明世第一法与苦法忍同一缘。当知无色界不能缘欲界。问曰。除去色想。体性是何。答曰。七地。谓四无色定及三未至。问曰。此处言除去色想。四大犍度。亦说除去色想。如波罗延说偈

  除去色想　　能断欲爱　　于内外法
  无不见者

如众义经说偈

  亦不有有想　　亦不无无想
  如是除色想　　能断渴爱因

如是等有何差别。答曰。或有说者。此处说除去色想者。除下地色想四大犍度。言除去色想者。除有对色。如波罗延众义经所说偈。除去色想者。断缘色爱。或有说者。此处言除去色想者。是四念处四大犍度。言除去色想者。是身念处。如波罗延众义经所说。除去色想者。是法念处。复有说者。此处言除去色想者。是四无色定及三未至四大犍度。言除去色想者。是第四禅。波罗延众义经所说偈。除去色想者。除爱缘色。复有说者。此言除去色想者。此内外道。共除色想法。余三是不共除色想法

世第一法当言。有觉有观无觉有观无觉无观。问曰。何以作此论。答曰。复为止彼人意言世第一法是欲界系故。复有说者。先已说世第一法体性。已说所以。已说界未说地。今欲说故。复有说者。先虽明世第一法是色界系。色界中有三种地。有觉有观无觉有观无觉无观地。未说世第一法为在何地。今欲说故。所以者何。色界善根有在一地者。如净解脱等。有在二地者如喜等。今欲说世第一法所在地故。是以作论。世第一法。或有觉有观。乃至广说。云何有觉有观。答曰。若依有觉有观三昧。得世第一法。如未至禅初禅是也。问曰。上言依者有何义耶。答曰。或有说者。共俱生义。是依义。彼世第一法生时。相应定力故。持彼心品使不散乱。是依义也。何以知之。有成文说共俱生义是依义。如说。若依空三昧得正决定。是中即说俱生是依义。如苦法忍与空三昧相应。是共俱生依义。空三昧亦与世第一法相应。是名依义。复有说者。与次第缘义是依义。如增上忍相应三昧。与世第一法作次第缘。是名依义。评曰。即依彼地。是名依义。如是说者好。云何无觉有观。答曰。若依无觉有观三昧。得世第一法。是名无觉有观。如禅中间是也。云何无觉无观。答曰。若依无觉无观三昧。得世第一法。是名无觉无观。如二禅乃至第四禅是也。问曰。何以说世第一法在三地耶。答曰。为止并义者意故。如弥沙塞部说世第一法是有觉有观有相有势无定。是凡夫性缘有为有觉有观者。能分别故。有相者能缘故。有势者难得故。无定者。无相似心相续故。是凡夫者。凡夫身中可得故。缘有为者。缘诸行故。为止如是并义者意故。说在三地。若依未至地得正决定。彼一地见道修。一地世第一法修。若依初禅得正决定。彼二地见道修。一地世第一法修。若依禅中间得正决定。三地见道修。一地世第一法修。若依二禅得正决定。四地见道修。一地世第一法修。若依三禅得正决定。五地见道修。一地世第一法修。若依四禅得正决定。六地见道修。一地世第一法修。复有说者。若依未至禅得正决定。一地见道修。一地世第一法修。若依初禅得正决定。二地见道修。二地世第一法修。若依禅中间得正决定。三地见道修三地。世第一法修。何以故。皆是一地法故。此中有漏法。一种使所使故。此中诸善。展转为因故。二禅以上如先说。评曰。彼不应作是说。何以故。若依无觉有观三昧。得正决定。得二种世第一法。有觉有观。无觉有观。若然者则违经文。如说云何名无觉有观。若依禅中间得世第一法。是名无觉有观。如先说者好

问曰。以何等故。见道自地他地修。非世第一法耶。答曰。或有说者。见道展转为因。非世第一法。复有说者。见道圣人身中修。以圣人身中修故。自地他地修。世第一法凡夫身中修。以凡夫身中修故。唯自地修。非他地修。复有说者。见道有三事故修。一从因生。二能作对治三能办事。从因生者。六地中展转更相为因。对治者。若对治断一地欲。余地亦名对治。断办事者。如一地事办。余地亦办。世第一法。不从因生者。不展转为因故。非对治者。不断结故。不办事者。非如圣道能办事故。修道亦以此三事故。自地他地修。彼亦展转为因。如法智断欲界结。比智亦修。彼比智非欲界对治道。法智现前时。亦名修亦名对治。办事者。如第四禅地苦智修。如初禅地亦修。如初禅地道办事。第四禅地道亦办。如第四禅地道办事。初禅地亦办。复有说者。无漏法所作异。有漏法所作异。所以者何。世第一法。为爱所系。无漏法者。不为爱所系。复有说者。世第一法。有垢有过患。杂毒滓浊。是以不他地自地修。见道无垢无过。不杂毒不滓浊。是以自地他地修。复有说者。世第一法。在界为界所系在地为地所系。无漏法。在界在地。不为界地所系。复有说者。世第一法。在身有系。无漏法在身不系。复有说者。世第一法。必生报。无漏法不生报。问曰。同是有漏。以何等故。见道边等智。自地他地修。非世第一法耶。答曰。或有说者。见道边等智。不用功而得。以见道力故修。如见道力。能自地他地修。彼见道边等智亦修。世第一法大功力得。是以唯自地修。非他地修。复有说者。见道边等智。是见道眷属。常不相离。如见道自地他地修彼亦如是。世第一法。非见道。眷属相离。是以唯自地修。非他地修。复有说者。见道边等智。坚信坚法。身中可得。若起上地。法现在前。下地便修。世第一法。凡夫身中可得。一切凡夫。不能修于他地。问曰。以何等故。上地见道现在前时下地修。下地见道

现在前时上地不修耶。答曰。或有说者。上地法胜。若现在前时。下地则修。下地法劣。现在前时。不修上地。犹如胜人不造诣劣人。劣人则应造诣胜人。彼亦如是。复有说者。若依上地。得正决定。下地诸法。先已得故。是以故修。若依下地得正决定。上地诸法或得不得。是以不修。复有说者。上地诸法从下地因生。下地诸法不从上地因生。是以不修。复有说者。下地法不能对治上地。上地法能对治下地。以不对治故是以不修。复有说者。若依上地得正决定。尔时离下地欲故。是以修。若依下地得正决定。上地或离欲或不离欲。设使离欲。于上地法不得自在。设得自在。应即上地得正决定而不能得。是以知不自在。复有说者。下地法摄属上地。是以故修。上地法不摄属下地。是以不修。复有说者。犹如六种守护法故。三十三天。为备阿修罗故。安六种守护。一依水住龙。二杵手神。三持花鬘神。四常放逸神

五四天王。六三十三天。若依水住龙。能坏阿修罗者余五无事。而水住龙若不能。杵手神助。余四无事而住。若二不胜持花鬘神助。余三无事而住。若三不胜放逸神助。余二无事而住。若四不胜四天王助。余一无事而住。若五不胜三十三天助。帝释无事而住。彼若不胜尔时帝释躬身自出。执金刚杵雨金刚雹。时阿修罗众即时退散。如是见道断结对治。在六地中。若依未至得正决定。即彼地见道断。见道所断结。其余五地无事而住。若依初禅得正决定。上地则无事而住。未至禅得修。亦随顺初禅。若依中间二禅三禅亦如是。若依四禅得正决定。彼四禅中见道断。见道所断结。下地得修。亦随顺第四禅。复有说者。犹如山陂有六重池次第而下。其在上池次流于下。下池不能逆流于上。如是上地无漏流注下地。是以故修。下地无漏不能流注上地。是以不修。问曰。世第一法颇有觉非有观耶。有观非有觉耶。亦有觉有观耶。非有觉非有观耶。答曰。有。云何有觉非有观耶。答曰。如未至禅初禅觉。相应观是也。所以者何。观不相应故。云何有观非有觉。答曰。觉诸中间禅观相应法。云何有觉有观。答曰。如未至禅初禅。除其觉观。余相应法所谓十大地。十善大地及心。云何非有觉非有观。答曰。谓中间禅观。诸余觉观不相应法。如二禅三禅四禅相应法及色心不相应行。问曰。颇世第一法。非有觉有观。非无觉有观。非无觉无观耶。答曰。有。如未至禅初禅地观。彼非有觉有观。所以者何。如说。云何觉观相应法。答曰。若法与觉观相应。彼观唯与觉相应。不与观相应。云何非无觉有观。答曰。观所以者何。如说。云何无觉有观相应法。答曰。若法不与觉相应与观相应法。彼观唯与觉相应。不与观相应。云何非无觉无观。答曰。观。所以者何。如说。云何无觉无观相应法。答曰。若法不与觉观相应。彼观虽不与观相应。与觉相应。问曰。颇世第一法。非与有觉有观相应。非不是观耶。答曰。有。禅中间观。彼不与觉观相应。非不是观。问曰。颇世第一法。有觉有观地非觉唯观耶。答曰。有。在未至及初禅地觉唯与观相应非觉。问曰。颇世第一法。在无觉有观地。非觉非观相应耶。答曰。有。禅中间观。问曰。颇世第一法。在有觉有观地亦有觉有观无觉有观无觉无观耶。答曰。有。云何有觉有观。如未至禅及初禅地觉观相应法。云何无觉有观。即彼觉是也。云何无觉无观。即彼色心不相应行是也。问曰。颇世第一法。在无觉有观地无觉有观无觉无观耶。答曰。有。云何无觉有观。如禅中间无觉有观相应法是。云何无觉无观耶。彼观色心不相应行。世第一法。当言乐根相应。乃至广说。问曰。何故作此论。答曰。先已说世第一法体性所以界地。未说相应。今欲说故。复有说者。先已说世第一法在三地。未说在六地。今欲以根明六地义。分明了了。如观掌中阿摩勒果。云何世第一法乐根相应。答曰。若依第三禅得世第一法。何者乐根相应。何者非乐根相应。答曰。除乐根。诸余乐根相应法。何者不相应。答曰。乐根色心不相应行。云何喜根相应。答曰。若依初禅二禅。得世第一法。此中谁与相应。谁不与相应。除喜根。诸余喜根相应法。谁不与相应。喜根色心不相应行。云何舍根相应。答曰。若依未至禅第四禅。得世第一法是也。问曰。何以不说禅中间耶。答曰。应作是说。若依未至中间禅第四禅。得世第一法。而不尔者有何义。答曰。中间禅通名未至。是中谁与相应。谁不与相应。谁与相应。除舍根诸余舍根相应法。谁不与相应。舍根色心不相应行。颇有世第一法。不与喜根乐根舍根相应耶。答曰。有。色心不相应行。颇有相应法而不与世第一法相应耶。答曰。有。即三根体是也。世第一法。当言一心为多心。乃至广说。问曰。何以作此论。答曰。先已说世第一法体性。已说所以。已说界。已说地。已说根相应。未说现在前。今欲说故。或有说者。言世第一法是相续现前。为止彼人如是意。欲显世第一法现在前一刹那故。或有说者。先说诸心心数法次第得正决定。或谓有心心数法多彼刹那亦多。为决定此义故。而作此论。复有说者。相续有三种。一时相续。二生相续。三相似相续。或谓无二相续。唯有相似相续。如弥沙塞部所说。为止彼人意故。而作此论。世第一法。当言一心为众多心。答曰。当言一心。不当言众多心。问曰。如世第一法现在前。未来心心数法修。亦名世第一法。此中何以不说。答曰。彼亦应说而不说者。当知此义是有余之说。如有余义。简略义亦如是。复有说者。彼未来者属现在。若说现世当知亦说未来。复有说者。若能与次第缘。是中说之。如是义应如先以次第说。问曰。以何等故。世第一法当言一心。应说所以。不但以言故。此义便立。答曰。此心心法。次第便不起。世间有漏心唯生。无漏苦法忍相应心。若当起者无有是处。为分别故。设使起者。若小若相似若胜。若当小者。不能得正决定。所以者何。不以衰退。未成道得正决定。应以胜进势力道得正决定。若相似者。亦不能得正决定。所以者何。先不以此道得正决定。如初刹那。后刹那亦尔。如初刹那。留难停住不得正决定。后众多刹那。亦留难停住不得正决定。如初刹那不能取圣道。后众多刹那亦不能取圣道。问曰。若然者修道中。若以下心。亦不能取圣道。答曰。见道异本曾得道异。若当胜者。亦不能得正决定。所以者何。前者则非世第一法。问曰。若非者为是何法。答曰。是增上忍。后是世第一法。问曰。以何等故修道中若相似若小。能与无漏作次第。见道唯胜。答曰。修道是本曾得道不多用功力。而现在前。是以若相似若小。能作次第。见道是未曾得道。多用功力乃现在前。是以必用。胜者世第一法。于世第一法因威势。因者共生因。相应因。相似因。三因者是总说义。若别说者。过去于过去。二因相应共生。过去于未来一相似因。未来于未来。二因相应共生。现在于现在二因相应共生。现在于未来一相似因。不障碍生得法。是威势缘

世第一法当言退。当言不退。乃至广说。问曰。何故作此论。答曰。前已说世第一法体性所以界地根一心。未说不退。今欲说故而作此论。或有说。世第一法是退者。为止彼人意故。又欲去他义显自义与法相相应故。问曰。世第一法。当言退。当言不退耶。答曰。不退。问曰。云何不退。应说其所以。不可但以言故。此义便立。答曰。世第一法。随顺谛。转近谛。垂入谛。云何随顺谛。随顺见道故。云何转近谛。转近见道故。云何垂入谛。垂入见道故。复有说者。随顺道谛。转近道谛。垂入道谛。复有说者。随顺苦法忍。转近苦法忍。垂入苦法忍。世第一法。于苦法忍有二种转近。一随顺转近。二垂入转近。彼中间不起不相似有漏心。使苦法忍不现在前。问曰。世第一法是有漏心。向言不起不相似有漏心苦法忍是不相似心。何以言有漏是不相似心无漏是相似心耶。答曰。世第一法。恶贱有漏心。以恶贱故。言不相似。无漏言相似。犹如有人为自亲里之所苦恼。亲近他人作亲里想。于自所亲作他人想。彼亦如是。复有说者。世第一法。苦法忍同办一事故。所谓舍凡夫事。得住圣法。犹如士夫渡河渡谷渡山渡坑。乃至广说。渡河者。从此至彼。渡谷者。从此岸至彼岸。渡山者。从此山至彼山。渡坑者。从高至下从下至高。犹如有人从高上堕。未至地顷。便作是念。欲还本处得如意不。答曰。不得。假使彼人。若以神足。若以咒术。若以药草。还至本处可有是事。住世第一法时。无有一法能障苦法忍使不现前。譬如阎浮提有五大河。一名恒伽。二名夜摩那。三名萨罗由。四名阿夷罗跋提。五名摩醯。流趣大海。乃至广说。问曰。前喻后喻有何差别。答曰。无有差别。所以者何。欲因二喻以明一义令分明故。复有说者。前者以内法具为喻。后者以外法具为喻。复有说者。前喻为止内留难法。后喻为止外留难法。复有说者。前喻为止不如法事。后喻为显如法事。彼五河流趣大海。无能制者无能遮者。无能住者无能移者。彼五大河流趣大海。颇有人能遮住者不。答曰。无也。若以神足咒术药草。使彼大河停住不流。未足为难。无有一法能障世第一法使苦法忍不现在前。造此经时在于东方。此五大河在于东方。故以为喻。复有四大河。从阿耨达池出流趣大海。一名[口*恒]伽。二名辛头。三名博叉。四名私陀。彼[口*恒]伽河从金象口出。绕阿耨达池一匝流趣东海。彼辛头河从银牛口出。亦绕大池一匝流趣南海。彼博叉河从琉璃马口出。绕大池一匝流趣西海。彼私陀河从颇梨师子口出。绕大池一匝流趣北海。彼[口*恒]伽河有四大河。以为眷属。一夜摩那。二萨罗由。三阿夷罗跋提。四名摩醯。彼辛头河亦有四大河。以为眷属。一名毗婆奢。二名伊罗跋提。三名奢多头。四名毗德多。彼博叉河有四大河。以为眷属。一名婆那。二名毗多罗尼。三名朋[仁-二+奢]。四名究仲婆。彼私陀河亦有四大河。以为眷属。一名萨梨。二名毗摩。三名那提。四名毗寿波婆。此中唯说广大有名字者。然彼四河各有五百眷属。合有二千流趣大海。颇有人能遮住者不。答曰。不能。无有是处。以分别故假使有人。以神足咒术药草。能令彼河停住不流。未足为难。无有一法能障世第一法使苦法忍不现在前。复次世第一法。与苦法忍。作次第缘。此文是根本义第一答。所以者何。彼世第一法生时。能与苦法忍次第缘果。若此法能与彼法次第缘果者。此法无有众生。若法若咒术药草。若佛若辟支佛若声闻。能作障碍。使第二刹那不现在前者。无有一法速于心者。能于尔时为作障碍。使不能得正决定。彼言无有一法速于心者。即苦法忍相应心是也。作义者说曰。以何次第故。世第一法不当言退。答曰。或有说者。根本牢固故。彼行者修布施时。悉以回向解脱持戒不净安般念处七处善暖顶忍亦回向解脱。是名根本牢固。复有说者。世第一法后次生见道。无有退见道者。彼亦不退。复有说者。世第一法后次生忍智。无有退忍智者。彼亦不退。复有说者。世第一法后。乃至断非想非非想处见道所断结。无有退非想非非想处见道所断结者。彼亦不退。复有说者。世第一法。是胜进分善根。无有退胜进分善根者。暖法有三种。退分住分胜进分。顶亦有三种。忍有二种住分胜进分。世第一法。有一种。谓胜进分。问曰。此皆是达分善根。何以说三种。答曰。名数异耳。如定犍度说。此善根有三种。于此善根退者名退分。不退不进名住分。胜进者名胜进分。彼说三种。此说达分善根。名数异耳。复有说者。此善根是一刹那。无有退半刹那者。问曰。颇有二圣人同生一处。于世第一法。一成就。一不成就耶。答曰。有。一依初禅得正决定。二依第二禅得正决定。彼俱命终生二禅中。彼依初禅得正决定。则不成就。所以者何。以离地故失。依二禅者。彼则成就。问曰。颇二阿罗汉俱在欲界中。于世第一法。一成就。一不成就耶。答曰。有。一依初禅得正决定。二依二禅得正决定。彼俱命终。生二禅中阴中得阿罗汉果。彼依初禅得正决定者。则不成就。所以者何。以离地故失。问曰。颇有圣人不成就世第一法。成就世第一法解脱得耶。答曰。有。依初禅得正决定。彼命终生二禅中。以离地故。不成就世第一法。彼成就世第一法解脱得。彼得以二禅所摄故。若命终生三禅以上。则不成就世第一法。问曰。颇有圣人不成就世第一法。亦不成就解脱得耶。答曰。有。依初禅得正决定。彼若命终。生第三禅以上。则不成就世第一法及解脱得

如经说。诸比丘。我不见一法速疾回转过于心者。难以喻知。乃至广说。问曰。言速疾回转者。为于世耶为于缘耶。若于世者。一切有为法。亦随世速疾回转。不但心也。若于缘者。诸心心数法受缘。亦速疾回转。不但心也。答曰。此中亦说世速疾回转。亦说缘速疾回转。谓一身中非谓一刹那也。若一刹那言速疾回转者。则有少分速疾回转。少分不速疾回转。亦无于缘速疾回转。所以者何。如说若法能缘彼法。或时不缘。无有是事。是以说世之与缘速疾回转。谓一身中非谓一刹那。彼一身中。或生善心或时染污。或时不隐没无记。或依眼生。乃至依意生。若缘色生乃至缘法生。问曰。若于世于缘。名速疾回转者。心心数法。亦于世于缘。速疾回转。何以独言心耶。答曰。或有说者。此是世尊有余之说。亦是世尊为化众生。简略之说。复有说者。于心法中谁为最胜。所谓心也。是以说心。犹如王来余人亦来。以王胜故但言王来。复有说者。以因心故名为心数。是故说心。以心大故数法亦名大地。是故说心。复有说者。若修证心通法时。彼无碍道唯缘于心。是故说心。复有说者。心是远行法。如说

  独行远逝　　不在此身　　若能调伏
  是世梵志

复有说者。心为尊导。如说

  心为前导　　心尊心使　　中心念善
  亦言亦行　　安乐自追　　如影随形

或有说者。心犹如王。如说

  第六增上王　　此染彼亦染
  无染而生染　　染者名愚小

复有说者。心名城主。如说。比丘当知。言城主者即有漏识。复有说者。心是内法。遍一切处。能有所缘。内者。内入所摄。遍者。从阿毗地狱上至有顶。能有所缘者。缘一切法。复有说者。能起善不善尸罗。如说。善不善尸罗。皆因心起。复有说者。心起恶法生恶道中。心起善法生天人中。如世尊言。诸比丘。都提夜子叔迦摩纳婆。以向如来生恶心故。身坏命终。如掷真珠顷当堕恶道。比丘都提夜子叔迦摩纳婆。以向如来起善心故。如掷真珠顷身坏命终。当生善道。复有说者。此心为主。多所统摄。如说。此五情根各行境界。心悉能行种种境界。复有说者。如心行于缘。数法皆随。犹如雄鱼。其所住处雌鱼皆随。复有说者。心是数法所依之处。复有说者。心所依受身之处无不有心。数法不尔有增有减。复有说者。若心不调伏。不守护。不净修。数法亦尔。若心调伏守护净修。数法亦尔。复有说者。若心不伏数法不伏。以不伏故。流行色声香味触法。若心折伏数法亦伏。以折伏故不行色声香味触法。如滤水筒。上开则漏上闭则止。彼亦如是。复有说者。世尊先说心速疾回转。当知余有缘法。亦速疾回转。如经说。我不见一法速疾回转过于心者。难以喻知。问曰。如余经说以猿猴为喻。今何故言难以喻知。答曰。或有说者。此经难以喻知。不言不以喻知。所以者何。非凡人能作。不易作。不过时作。非无慧者作。非凡人作者。唯佛能作。不易作者。用功能作。不过时作者。佛日出世。尔时能作。非无慧作者。非粗心乱意之所能作。又非凡作者。能知善心起住灭相。亦知出入及知方便。如佛缘觉及诸弟子。善于总相别相。复有说者。言难以喻知者。喻若同若相似。同者。如说心速疾回转。其犹如受。此是心法。经先已说。若非心法。喻不相似。复次难以喻知者。不以少功而能得知。复次难以喻知者。如心速疾能有所缘。彼喻亦尔。而无有法与心等者。犹如猿猴。从一枝至一枝顷。心想回转。有百千刹那。尊者波奢说曰。世尊为化众生。还以心喻心。彼猿猴轻躁躁动皆心所为。问曰。彼心可以一法为定喻不。答曰。或有说者。有谁能作。唯佛能作。但无能知者。如佛化作一刹那以喻心而无知者。是故比丘应善知心。应善知心回转。乃至广说。问曰。善知心善知心回转。有何差别。答曰。或有说者。无有差别。言善知心即是善知心回转。复有说者。有差别。若观心总相是名善知心。观心别相是名善知心回转。复有说者。若观心。是名善知心。若观数法。是名善知心回转。复有说者。若观心念处。是名善知心。若观法念处。是名善知心回转。复有说者。若观识阴。是名善知心若观余阴。是名善知心回转。复有说者。若观意入。是名善知心。若观余入。是名善知心回转。复有说者。若观七识界。是名善知心。若观余界。是名善知心回转。复有说者。若观心自相。是名善知心。若观心所缘行处。是名善知心回转。复有说者。若观识。是名善知心。若观识住处。是名善知心回转。尊者波奢说曰。若知有欲心是名善知心。若知转离欲心是名善知心回转。如有欲心转离欲心。有嗔心转离嗔心。有痴心转离痴心。散乱心摄心。懈怠心精进心。有掉心无掉心。少心多心。有染心无染心定心不定心。修心不修心。解脱心不解脱心。系心不系心。当知亦如是。尊者佛陀提婆说曰。世尊言善知心回转者。即是善知心异名说耳。如定犍度说。我弟子中善知心回转。摩诃般特迦是也。此即说心念处。名善知心回转

问曰。颇住一刹那顷。当得世第一法。不当得所依缘耶。当得所依缘不当得世第一法耶。亦当得世第一法及所依缘耶。亦不当得世第一法及所依缘耶。答曰。有。应作四句。若依未来禅。当得正决定。住增上忍一刹那顷。当得世第一法。不当得所依缘者。除未至禅所摄世第一法现在前及所依缘。谓诸余未来世第一法也。当得所依缘。不当得世第一法者。谓初禅二禅三禅四禅所摄世第一法所依缘也。当得世第一法及所依缘者。谓未来禅所摄世第一法现在前及所依缘也。亦不当得世第一法及所依缘者。谓初禅二禅三禅四禅所摄世第一法。诸余所依缘。问曰。颇住一刹那顷当得世第一法缘有缘法耶。当得缘无缘法耶。当得缘有缘无缘法耶。不当得缘有缘无缘法耶。答曰。有。住增上忍应作四句。初句者。谓世第一法。能缘心心数法也。第二句者。谓世第一法。能缘色心不相应行也。第三句者。谓世第一法。能缘心心数法色心不相应行也。第四句者。除上尔所事

彼作经者说世第一法。凡作七论。五是根本。二因论生论。五根本者。从云何世第一法。乃至根相应。二因论生论者。谓当言一心当言不退。造毗婆沙者。因此造论广现多文

阿毗昙毗婆沙论卷第二阿毗昙毗婆沙论卷第三

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    杂犍度世第一法品之三

云何顶法云何顶法退。云何暖法乃至广说。问曰。此中逆说凡夫所得法。说世第一法已。何以不次说忍耶。答曰。或有说者。彼作经者意欲尔。乃至广说。复有说者。应说云何为忍。以何等故名忍。当云何系乃至广说。而不说者。有何意耶。答曰。此是有余之说简略之义。复有说者。先已说忍而不彰显。如先说。若后心心数法。胜者前者。则非世第一法为是何耶。答曰。增上忍是名说忍。复有说者。若佛经说此中便说。若经不说此中不说。佛经无说忍处是故不说。说曰。如增一阿含中说。若不成就六法。则不能远尘离垢得法眼净。云何为六。一不乐闻法。二虽闻法不摄耳听。三不为知解。四所未得法不方便勤求。五所得法不善守护。六不成就顺忍。若成就六法则。能远尘离垢。得法眼净云何为六喜乐。闻法。乃至成就顺忍。问曰。彼经虽说顺忍。不说是顺谛忍。答曰。顺忍顺谛忍。有何差别。因论生论。以何等故。忍言顺谛。忍暖顶不耶。或有说者。如说忍言顺谛。暖顶亦应说。而不说者。当知皆是有余之说。复有说者。顺者言随顺。彼忍善随顺。暖顶不尔。复有说者。暖法能止缘谛增上愚。顶止中愚。忍止下愚。以止身中愚故。生世第一法。复有说者。暖法能生缘谛下明。顶生中明。忍生上明。以此身中有缘谛明故。能生世第一法。复有说者。暖法于阴悦适。顶法于宝悦适。忍法于谛悦适。以观圣谛身中悦适故。能生世第一法。复有说者。忍于一切时。与见道相似。如见道一切时唯法念处现在前。彼忍亦尔。暖顶不尔。所以者何。先修法念处。后增长三念处。展转现在前。是故不相似也。忍修习法念处。唯增长法念处。以与见道相似故。名顺谛忍。暖顶不尔。不名顺谛。复有说者。忍法侧近见道。暖顶不如。复有说者。忍法亦多相续。亦一刹那现在前。顶暖唯多相续现在前。复有说者。忍法唯一定意。暖顶不尔。复有说者。忍法正观不杂。暖顶有杂。或时起欲界善根。复有说者。忍法正观。不多不广。而能随顺趣向涅槃。暖顶正观。亦多亦广。亦能随顺趣向涅槃。此中应说转买摩尼宝喻。以如是等众因缘故。忍名顺谛。暖顶不得名顺谛

是暖顶及下中忍。行十六行。缘四真谛。增上忍。行四行。缘苦谛。复有说者。增上忍缘道谛。问曰。忍为缘何法得正决定。答曰。或有说言缘于道谛。问曰。若然者云何不缘行倒错耶。若缘行倒错。云何不为得正决定而作留难。答曰。假令缘行倒错。于正决定。不作留难。所以者何。于此善根。修习缘行。先有径路。是以入圣道时。于此缘行。自在能用。如见道中。先起欲界忍智道。次生有顶忍智道。彼有顶忍智道。后复还生欲界忍智道观苦行。后复生观习行。乃至广说。如此皆名缘行倒错。不以缘行倒错。便为见道。而作留难。何以故。以于见道修习缘行先有径路故。忍亦如是。于得正决定。不作留难。诸作是说。缘道谛增上忍。后得正决定。彼有三心。应同一缘一行。所谓世第一法。苦法忍苦法智。二心应同一行。不同一缘。谓苦比忍苦比智。二心同于一缘。不同一行。谓习法忍习法智。评曰。应作是说。应缘苦谛增上忍。后得正决定。彼见道是猛健善根。虽缘行倒错。于正决定。而无留难。彼忍是世俗有漏善根。其性羸劣。若缘行倒错。则与见道。而作留难。如实义者。应观苦增上忍。后得正决定。非先观道忍后得正决定。增上忍行苦行缘苦。而忍方便道广行十六行。缘四真谛。彼行者正观欲界苦。观色无色界苦。欲界行集。色无色界行集。欲界行灭。色无色界行灭。断欲界行道。断色无色界行道。如是三十二心。是名下忍。行者后时渐渐减损行及缘。复更正观欲界苦色无色界苦。乃至观断欲界行道。除观断色无色界行道。从是名中忍。复更正观欲界苦。观色无色界苦。乃至观色无色界行灭。除减一切道。复更正观欲界苦色无色界苦。乃至观欲界行灭。除色无色界行灭。复更正观欲界苦。乃至观色无色界行集除一切灭。复更正观欲界苦。乃至观欲界行集。除色无色界行集。复更正观欲界苦色无色界苦。除一切集。复更正观欲界苦。除色无色界苦。复更正观欲界苦常相续不断不远离。如是观时。深生厌患。复更减损。但作二心。观于一行。如似苦法忍苦法智。如是正观。是名中忍。彼复以一心。观欲界苦。是名上忍。后次生世第一法。世第一法后。次生苦法忍。譬如有人。欲从己国适于他国。多有财宝及诸生业之具。不能持去。以此财物。转以易钱。犹嫌其多不能持去。以钱易金。犹嫌其多不能持去。以金复易多价宝珠。持此宝珠。随其所安。往适他国。如是行者。乃至渐舍。相续不离。生于上忍。忍后次生世第一法。世第一法后。次生苦法忍。诸言缘苦忍后得正决定。彼四心须同一行一缘。所谓增上忍。世第一法。苦法忍。苦法智。二心同一行。不同一缘。所谓苦比忍。苦比智。二心同一缘。不同一行。所谓集法忍集法智。是故如此说者好。问曰。世第一法。为有上中下不。答曰。无也。不得一人心中有。多人心中乃有如尊者舍利弗。是上目连是中。其余声闻是下。性分亦有上中下。佛为上。缘觉为中。声闻为下云何名顶。以何等故名顶。尊者瞿沙说曰。有二种达分善根。一是欲界所谓暖顶。二是色界所谓忍及世第一法。欲界中下者是名为暖。上者名顶。色界中下者名为忍。上者名世第一法。评曰。彼不应作是说此尽是色界法。是修法住定地法。能行圣行法。如是说者好。问曰。何以言顶法耶。答曰。色界善根。有动者有不动者。有住不住。有难无难。有断不断。有退不退。诸彼动者。诸不住有难有断有退者有二。下者是暖。上者是顶。诸彼不动住无难不断不退者有二。下者是忍。上者是世第一法。复有说者。应言下顶。所以者何。在下暖法顶故。复有说者。犹如山顶。故名为顶。如山顶之道人不久住。若无诸难。必过此山。到于彼山。若遇诸难即便退还。如是行者。住顶无久住者。若无诸难。必到于忍。若有诸难。还退到暖。是以犹如山顶。故名为顶。复有说者。胜于暖法。故名为顶。云何为顶。欢喜于佛法僧。生下小信。乃至广说

问曰。何以故。言此信为下小耶。答曰。如尊者瞿沙说。此暖顶二达分善根。是欲界法故言下小。复有说者。此住不久停故。故言下小。复有说者。此信当言异信。何以故。异于色界定地修地行圣行暖法故。故名为异。于佛僧。生下小信。是缘道谛信。于法生下小信。是缘灭谛信。问曰。如顶能缘四谛。此中何以唯说缘二谛信。不说缘苦集信耶。答曰。或有说者。此中说名义最胜法故。于此四谛何者最胜。所谓灭道。何以故。此二谛清净无过故。复有说者。此二谛是妙是离。复有说者。此二谛能生信处。复有说者此二谛有二义。一可信。二可求。复有说者。为生受化者。信乐心故。若世尊说。苦集是可敬信者。则无受化者。何以故。彼受化者。当作是念。此是烦恼恶行。邪见颠倒。何可敬信。而我等常为此苦之所逼迫。若世尊说灭道。是可敬信。彼受化者。心生欣乐。是故灭道最胜可信。复有说者。此灭道有可信敬事。一乐观在前。二无心舍离。复有说者。信佛信僧说缘道信信法是缘三谛信。若如是者则说尽缘四谛信也。如说波罗延摩纳婆等。能于佛法僧。生下小信。是名顶法。彼作经者。引经为证。问曰。如住顶时。亦信阴亦信三宝亦信谛。以何等故。世尊为摩纳婆等。但说信宝。不说信阴谛耶。答曰。或有说者。彼摩纳婆等。非不信苦集谛。但不信三宝。以不信故。佛故为说。复有说者。彼为苦所困。欲求离苦。往诣佛所。如说偈

  为苦所逼诸众生　　不知离苦来诣佛
  愿示法要除众患　　犹如热时入凉池

如实能离苦者。唯有灭道。彼有二义可信。一常乐观。二常喜求。复有说者。信佛说缘二谛信。信僧说缘道谛信。信法说缘灭谛信。复有说者。信佛说缘四谛信。信僧说缘道谛信。信法说缘三谛信。复有说者。三宝是生信敬处是以说之。复有说者。随行者意悦适故是以说之。若于阴生悦适是名为暖。于宝生悦适是名为顶。于谛生悦适是名为忍

问曰。如顶体性。是五阴。何以世尊为波罗延等。以信名说。为诸新学比丘。以慧名说。答曰。或有说者。唯佛世尊决定明解法相。亦知所应作事。非余所及应为众生而说何法。即便说之。复有说者。以波罗延等。未住所作地。未入佛法中。未得舍摩他。未有渐次闻他天言生信。来诣佛所。尔时世尊。因彼善根欲令增长故。以信名说。彼诸新学比丘。与上相违故。即慧名说。复有说者。随他乏少为饶益故。如波罗延等乏少于信。释种比丘乏少于慧。是以波罗延等。说信以饶益之。释种比丘。说慧以饶益之。复有说者。为止谄曲愚痴意故。波罗延等。虽复聪明。乏少于信。无信之慧。能增长谄曲。是故为波罗延等。说信止其谄曲。新学比丘释种出家。虽少有信而乏于慧。无慧之信增长愚心。是故为新学比丘。说慧止其愚心。复有说者。世尊说法。受化者二种。有利根。有钝根。为利根者说信。为钝根者说慧。以波罗延等利根故说信。新学比丘等。钝根故说慧。如利根钝根。内因力外缘力内分力外分力。内正观思惟增益外从他闻法内增益。无愚无贪修不修损身见聚处不损身见聚处。当知亦如是

云何顶法退乃至广说。问曰。以何等故说顶有退。不说暖退。答曰。或有说者如说顶退。亦应说暖退。而不说者。当知皆是有余之说。复有说者。行者在顶之时。多诸留难。有三时诸烦恼业。多诸留难。如从顶至忍。尔时恶道诸烦恼业。多作留难。所以者何。彼诸烦恼。而作是念。若彼行者。已到于忍。我复于谁身中当生果报。离欲界欲时。彼欲界诸烦恼业。多作留难。所以者何。诸烦恼业。而作是念。若彼行者。出于欲界。我复于谁身中。生于果报。离非想非非想处欲时。受未来有诸烦恼业。多作留难。所以者何。诸烦恼业。而作是念。若彼行者。离欲已彼更不受身。我复于谁身中。生于果报。行者于此三时。多诸留难。是故说顶有退。不说暖退。复有说者。行者尔时生大忧恼犹如有人。见珍宝藏。见已欢喜作是思惟。我今永断贫穷根本。后欲取时忽然还灭。彼人尔时于此宝藏生大忧恼。如是行者。住顶法时。自念不久。当得于忍。永断恶道。心生欢喜。后便还退生大忧恼。复有说者。若说顶有退。当知亦说暖有退。复有说者。以顶法不久住故是以有退。复有说者。欲得忍时大获重利。犹如圣人不堕恶道。得忍之时亦复如是。如沙门二十亿九十一劫不堕恶道。与上相违名失重利

云何顶退。答曰。犹如有人。亲近善知识。从其闻法乃至广说。何以复作此论。答曰。前虽说顶体相未说云何得顶云何失顶。今欲说之故作此论。犹如有人。亲近善知识者。说亲近善友。从其闻法者。听随顺方便法。内正观思惟者。自身修行正行。信佛菩提。信善说法。信僧清净功德。是说信宝说色无常。乃至说识无常。是说信阴。知有苦集灭道。是说信谛。彼于余时。不亲近善知识者。亲近恶友。不从他闻法者。不听随顺方便法。不正观思惟者。自身行邪行。失此信法。是名顶退。问曰。顶退体相为是何耶。答曰。是不成就性。不隐没无记。心不相应行。行阴所摄。复有说者。是不信体性。所以者何。有信便得。无信便失。复有说者。以何使缠。而退顶法。即彼使缠性。如是说者。亦是染污性。复有说者。若法随顺退法即是其性。若然者一切诸法。尽是退性。何以故。一切诸法。与威势缘故。尊者佛陀提婆说曰。无所有性。是退性。强生分别。无有相对。彼善根和集名顶。善根离散名退。复有何性。犹如有人多诸财物。他人劫去。后便贫穷人问之言。汝今贫穷为是何性。彼人答言。我本有财。他人劫去今唯贫穷。当有何性。又如有人衣裂。他人问言。汝今衣裂为是何性。彼人答曰。衣本完坚今者破裂。更有何性。又如有人身本着衣。人夺其去。他人问言。汝今裸形无衣为是何性。彼人答言。我本着衣。他人夺去。今者裸形无衣当有何性。如是行者善根和集之时名之为顶。后若离散名之为退。当有何性。是故无所有性是名退性。评曰。不应作是说。如前说者好。顶退是不成就性。不隐没无记。心不相应行。行阴所摄

问曰。如说信佛菩提。是名信佛。乃至广说。以何等故世尊。或说信宝。或说信阴。或说信谛。答曰。或有说者。佛于法明了。乃至广说。复有说者。随众生愚处。佛随其所愚而解说之。复有说者。受佛化者有三种。一多疑心。二染着于我。三为见所覆。为疑者说。宝为染着我者说阴。为见所覆者说谛

云何暖法。乃至广说。以何等故名暖。答曰。或有说者。智缘境界。能生于暖。烧烦恼薪。犹如火攒。上下相依。生火烧薪。复有说者。以有智知有能生暖智。令有萎悴。犹如夏时聚花为[卄/積]花生暖气。还自萎悴。复有说者。智生依阴。在阴智火。还烧于阴。犹如两竹相摩生火还烧竹林。尊者瞿沙说曰。求解脱智火。彼最在初。如火以烟在初为相。无漏智火。亦以暖法在先为相。如日明相在初为相。无漏智日。亦以暖在初为相。是故名暖。云何为暖。于正法毗尼中。生信爱敬。乃至广说。问曰。若然者。说于正法毗尼中生信爱敬。尽得暖耶。答曰。不然。何以故。暖者乃是色界修地定地。能行圣行所摄。于正法毗尼中。生信爱敬者也。彼正法者。说缘道谛信。毗尼者。说缘灭谛信。问曰。暖能缘四谛。何以但说缘灭道谛信。答曰。或有说者。灭道于谛中最胜故。应如先顶中广答。复有说者。灭道是可归依处。是以故说。复有说者。正法说缘三谛信。毗尼说缘灭谛信。是亦名暖。能缘四谛。彼作经者。引经为证。如说佛告马师满宿比丘。我有四句法。当为汝说。为欲知不当恣汝意。彼二人言。我等今者便为非器。何用知为。乃至广说。问曰。佛深知彼人不堪受法。何故告言当恣汝意。答曰。或有说者。人谓彼人无教化者。所以造作众恶。而自毁坏。是以如来。举手语言。我所应作。今已作之。而汝自行邪行。以自毁坏。非我不教化之过。复有说者。为止外道诽谤故。所以告言当恣汝意。若当如来不告彼者。诸外道等。当作是谤。云何大悲。于弟子众。有随顺者。说法教化。不随顺者。不说法教化。若当如来告彼人者。诸外道等。不生诽谤。复有说者。为止诸释。不信心故。若当如来不告彼者。尔时诸释生不信心。云何悉达。不为亲族说法教化。心怀嫉妒。将虑彼人共己相似。若其如来告彼人者。诸释尔时便更不生不信之心。复有说者。彼人自行邪行。如来以彼。即为证人。而语之言。汝本在家。及今出家。自行邪行。非是我过。尔时如来。即以软语。面前责数。是故告言当恣汝意。复有说者。为生彼人将来善根故。佛知彼人。而今虽复不能受化。将来必生追悔善根。所以者何。彼人作是念。彼大悲者。恣我意。而我不受。非如来过。能生如此追悔善根。以此缘故。必出恶道。复有说者。佛知彼人于此命终必生龙中受大苦痛。便作是念。我本从何来生此间。自知本在佛法出家。次作是念。无化我者。我今应往作不利益事。破坏佛塔及诸精舍。杀诸比丘。当于尔时。佛神力故。有如来像。当立其前而告之言。马师满宿。我有四句之法。汝欲知不当知。今苦汝等过。非我咎也。我应作者。皆已作之。而汝今者。自为邪行。欲止彼龙嗔恚缠故。令守护佛法。是以告言当恣汝意。问曰。云何名四句法。答曰。或有说者。是四谛法。何以故。彼二人以不见谛故。造斯恶行。复有说者。四念处是。何以故。彼二人以颠倒故。造斯恶行。复有说者。四正勤是。何以故。彼二人者。多懈怠故。造斯恶行。复有说者。四如意足是。何以故。彼二人者。不能积集诸善故。造斯恶行。复有说者。四圣种是。何以故。彼二人者。贪着利养故。造斯恶行。复有说者。四沙门果是。何以故。彼二人者。实不得沙门。而言我得四沙门果。故造斯恶行。复有说者四善是(一善知界二善知入三善知缘起四善知处非处)。何以故。彼二人者。愚于因果故。造斯恶行。复有说者。如杂阿含中说偈

  贤圣法中善言最　　二常爱言远不爱
  三常实语离虚妄　　四常法言远非法

是名为四。复有说者。如增一阿含所说。无贪无恚正念正定是名为四。彼作是言。我今何用知是法为。世尊告言。汝愚痴人远离我法。乃至无有少许暖法。问曰。彼二人者何以作如是说。我今何用知是法为。答曰。或有说者。彼人自知非是法器趣向善道。犹为非器。况趣涅槃。当是器也。复有说者。诸邪恶行。在彼身中。数数犯禁。自知此身非是法器瓦石可令生牙。我今此身。终不能生解脱法分。复有说者。彼人已作决定业故。复有说者。彼人已近报果法故。彼人恶道报相。已现在前。乃至十指水流而出。复有说者。佛记彼人当成辟支佛菩提。彼作是念。何烦如来。为我说法。我于现世。终不能得入正决定。以是等众因缘故。彼作是言。我今何用知是法为。世尊告言。远离我法愚痴人。于我正法毗尼中。乃至无有少许暖法。问曰。有众多毗尼。有时毗尼有方毗尼。有种性毗尼。有家法毗尼。有罚罪毗尼。有犯毗尼。有明毗尼。有圣毗尼。有欲嗔痴毗尼。此中为说何者毗尼耶。答曰。或有说者。此中说圣毗尼。复有说者。此中说欲嗔痴毗尼。问曰。诸不得暖法。一切皆与马师满宿同耶。答曰。不一切也。众生凡有三种。一有期心。二除期心。三断期心。有期心者。清净持戒者是也。除期心者。所作已办阿罗汉是也。断期心者。犯戒者是也。以彼无有期心。无除期心。但有断期心。是以世尊。而呵啧之。其余众生。断期心者。亦与彼同。如说乃至无有少许暖法。问曰。此暖善根。最胜微妙。住寂静地。今者何以言少耶。答曰。以于达分善根中最是微小故言为少。复有说者。以是见聚善根后边生故。故言少许(见聚善根者谓安般不净四念处也)。此四种善根。所谓暖法顶法忍法世第一法。名为达分。亦名观谛。亦名修治。亦名善根。言达分者无漏圣道。是达此善根。随顺彼法。羽翼彼法。是彼法性分。故言达分。观谛者。以无常等行观谛察谛。故名观谛。修治者。为求圣道及果修治。此身除去秽恶。欲为法器。犹如农夫为求子实修治田地除去恶草。彼亦如是。故名修治。言善根者。圣道言善。涅槃言果。此诸法等。是彼初基始立之本。故名善根。问曰。此暖等善根。有何差别。答曰。暖法能止缘谛增上愚。乃至能止身中愚。故生世第一法。复有说者。暖法能生缘谛下明。乃至身中有缘谛明。故生世第一法。复次暖法。能生缘谛下信。顶法生中信。忍法生上信。以身中有此信故。能生世第一法。复次暖法。于阴悦适。乃至身中悦适故。生世第一法。复有说者。暖是念处所入处。顶是暖法所入处。忍是顶法所入处。世第一法。是忍所入处。如是次第无间亦如是。尊者瞿沙说曰。此善根二是欲界。所谓暖顶。二是色界。所谓忍世第一法。评曰。不应作是说。此是色界故。定地修地。能行圣行所摄法。如是说者好。问曰。暖法有几种。乃至世第一法几种。答曰。或有说者。暖法有三种。谓下下下中下上。顶法有三种。中下中中中上。忍有二种。上下上中。世第一法有一种。谓上上。此四善根以三言之。暖是下。顶是中。忍世第一法是上。复有说者。暖有二种。谓下下下中。顶有三种。谓下上中下中中。忍法有三种。谓中上上下上中。世第一法有一种。谓上上。此善根以三言之。暖是下。顶是下中。忍是中上。世第一法是上。尊者瞿沙说曰。暖有三种。下下下中下上顶有六种。下下乃至中上。忍有八种。下下乃至上中。世第一法一种。谓上上。若以三言之。暖法一种。谓是下顶有二种。谓下中。忍有三种谓下中上。世第一法有一种谓上

得暖法亦舍。舍有二种。离界地时。及退时舍。退时舍者。作无间业。能断善根。亦堕恶道。复有何善利。已为涅槃。作决定因。如吞钩饵法。得顶法亦舍。舍有二种。离界地时。及退时。退时舍者。作无间业。亦堕恶道。复有何善利。更不断善根。若然者。提婆达多。不得顶法耶。如偈说

  无德受供养　　是名为凡小
  有善皆忘失　　是名为顶退

此偈当云何通。答曰。此说得退。复有说者。世尊如顶。彼以恶心向佛。堕于恶道。故言顶堕。得忍亦舍。舍有一种。离界地时。舍彼善根无退。不作无间业。不断善根。复有何善利。不堕恶道。得世第一法亦舍。舍有一种。离界地时舍不退。所以者何。此善根性是不退。不作无间业。不断善根。不堕恶道。复有何善利。彼次第得正决定。复有说者。得暖法亦舍。舍有二种。离地界时。及退时。退时舍者。作无间业。亦堕恶道。复有何善利。唯不断善根。若然者提婆达多。不得暖法。何以故。彼断善根故。得顶法亦舍。舍有二种离地界时。及退时。退时舍者。堕恶道。复有何善利。不作无间业。不断善根。得忍亦舍。舍有一种。离界地时。彼善根无退。不作无间业。不断善根。不堕恶道。复有何善利。不染着我。问曰。若然者尸利掘多安仇利摩罗萨遮尼揵子。便为不得忍。何以故。染着我故。答曰。彼不染着我。以论义故。言有我耳。问曰。彼与如来。竞诤论我。云何乃言不染着我耶。答曰。彼以不断我见暂现在前。非染着也。世第一法得亦舍。离界地时舍。余如先说。西方人。作此论言暖善根。有何意趣。为何所依。有何因缘何法。有何果。有何依。有何报。有何善利。为行几行。为缘名生。为缘义起。为是闻慧。为是思慧。为是修慧。为欲界系。为色无色界系。为有觉有观。为无觉有观。为无觉无观。为乐根相应。为喜舍根相应。为一心。为众多心。为退为不退。乃至世第一法亦如是。问曰。暖有何意趣。答曰。所有布施持戒。乃至上忍善根。尽以回向解脱。是其意趣。为何所依者。依色界定起。有何因缘者。于自地前生善根。是相似因。缘何法者。缘四真谛。有何果者。顶近于暖。是功用果。有何依者。自地相似。后生善法。是其依果。有何报者。谓色界五阴。有何善利者。或有说者。是涅槃决定因。复有说者。不断善根。为行几行者。行十六行。为缘名生为缘义生者。当言缘义生。为是闻思修慧者。当言是修慧。欲色无色界系者。当言色界系。有觉有观无觉有观无觉无观者。当言三行。为何根相应者。当言三随所应说。为一心为众多心者。当言多心。为退不退者。当言退忍。于顶近者。是功用果。顶有何善利。或有说者。不断善根。或有说者。不作无间业。余如暖说。世第一法。于忍近者。为功用果。忍有何善利。有此善利。不堕恶道。复有说者。不染着我亦不退。其余如顶。世第一法。缘苦苦法忍。是功用果世第一法。有何善利次第。得正决定。行四行。当言一心不退。其余如忍生暖法时。若苦集道谛。现在一法念处。未来修四念处。现在行一行。未来修四行。取其同性。非不同性。若缘灭谛。现在一法念处。未来修一法念处。现在一行未来四行。增长暖法。以下增长中。以中增长上时。若缘苦集道谛。现在四念处。展转现在前。未来四。现在一行未来十六。若缘灭谛。现在法念处。未来四。现在一行未来十六。问曰。以何等故。初生暖法时。未来同性者。修非不同性。增长暖时。未来同性。不同性修。答曰。初生时。以行观谛。未曾得彼种而得。增长时。以行观谛。已曾得彼种而得。是以具修。初生顶时。缘苦集灭道。现在一法念处。未来四。现在一行。未来十六。增长时。下增长中。中增长上。若缘苦集道谛。四念处展转现在前。未来四。现在一行未来十六。若缘灭谛。现在一法念处。未来四。现在一行未来十六。初生忍。及增长时。现在一法念处。未来四。现在一行未来十六。尊者瞿沙说曰。初忍时若缘苦集道谛。现在一法念处。未来四。现在一行未来四。同性修不异性。若缘灭谛。现在一法念处。未来亦一法念处。现在一行未来四。同性修不异性。若增长时。缘苦集道谛。四念处展转现在前。未来四。现在一行未来十六。若缘灭谛。现在一法念处。未来四。现在一行未来十六。评曰。彼不应作是说。如前说者好

问曰。以何等故忍一切时。法念处现在前耶。答曰。如见谛道一切时法念处现在前。忍亦相似。问曰。如增长忍时。尽修十六行耶。答曰。不也。如渐除所缘行亦如是。若缘四谛。有十六行。若缘三谛有十二行。若缘二谛有八行。若缘一谛有四行。通一忍生势则有十六。问曰。以何等故。增长忍时。或十六或十二。或八或四行修。答曰。渐除所缘。渐除所行。转近得正决定。是以或时修十六行。乃至四行。生世第一法时。现在一法念处。未来四。现在一行。未来四。问曰。如世第一法曾得彼种。以行观谛。何以故。同性行修不异性耶。答曰。随彼所得。即此法修。如人裸形无衣可夺。彼亦如是。复有说者。世第一法。最近见道。如见道中不修余行。唯修同性。世第一法亦复如是。问曰。若生暖乃至忍时。为常相续。为不相续。答曰。或有说者。言常相续缘于四谛。如见道中十五心常相续现在前。彼暖法生时。常相续缘四真谛。复有说者。此义不定。或相续或不相续。或有暖缘苦而止者。或缘集灭道而止者

问曰。为正观思惟。何法次能生暖耶。答曰。是色界修。地定地心。有厌离有恶贱有渴仰。有不随顺生势不乐。有如此正思惟时。次能生暖。暖次生顶。顶次生忍。忍次生世第一法。世第一法次得正决定。问曰。若离欲者可尔。不离欲者云何。答曰。不离欲者。彼亦可尔。有欲界思慧正观思惟缘苦行。苦行次第生暖法。余如上说

问曰。诸前身生暖法。未生顶法。彼便命终。于此生中。欲生顶法。为即生顶法。为还起暖法耶。答曰。或有说者。若从师顺次闻顶法。即从顶去。若师不为说。还从根本起。问曰。若然者何以言暖次生顶。顶次生忍。忍次生世第一法。答曰。作如是说者。谓一身中次第生者。若前身中。曾得暖法。从根本起者也。问曰。若前身曾得暖法。于此生中。欲生顶法。作何正观思惟。答曰。如暖正观思惟顶亦复尔。如生顶生忍亦尔。问曰。若生暖法为离欲不。答曰。或有说者。不为离欲。所以者何。彼行者爱乐宁生顶法不起有顶中忍。复有说者。若彼行者。自知有力能生顶者即便生顶。自知无力不能生顶。欲得离欲。所以者何。若得离欲我生处转胜

问曰。若依根本地。生达分善根。为有退不。答曰。或有说者。暖顶有退。忍则不退。何以故。此善根是不退法故。评曰。彼不应作是说。何以故。若依根本地生达分善根者。即于现身。得正决定。何以故。此诸善根。尽为生圣道故。若依未至。此则不定

问曰。若依未至禅。生暖法。亦生顶忍世第一法。得正决定耶。答曰。或有说者。若依未至禅。生暖法。乃至生世第一法。得正决定。初禅乃至第四禅亦如是。复有说者。若依未至禅生暖法。次生初禅。暖顶忍世第一法。得正决定。禅中间二禅三禅四禅亦如是。复有说者。若依未至禅。生于暖顶。次生初禅顶忍世第一法。得正决定。禅中间二禅三禅四禅亦如是。复有说者。若依未至禅。生暖顶忍。次生初禅忍。生世第一法。得正决定。乃至第四禅亦如是。此则说声闻次第法。问曰。菩萨云何。答曰。菩萨依第四禅生暖法。乃至生世第一法。得正决定。复有说者。菩萨依初禅。生暖法顶法忍法。二禅三禅亦如是。第四禅中。生暖顶忍世第一法。得正决定。问曰。如达分善根中。不应次生下上。不应次生中下。云何菩萨而能生耶。答曰。自地不能。他地则能。复有说者。欲离如是过。当作是说。若依初禅。生暖法。乃至第四禅。若依初禅生顶法。乃至第四禅。若依初禅生忍法。乃至第四禅。次生世第一法。得正决定。评曰。不应作是说。如前说者好。所以者何一切菩萨尽依第四禅生暖法。乃至生世第一法。得正决定故。问曰。辟支佛复云何。答曰。辟支佛独出世者。当知如佛。若众多出世者。此则不定。与声闻同。如渴伽狩。独生一角彼亦如是。独出世者。当知如佛

问曰。菩萨前身为曾生达分善根不耶。答曰。或有说者。曾生为障恶道故菩萨九十一劫。不堕恶道者。是达分善根之力。此是他性达分善根。非是己性。评曰。不应作是说。应作是说菩萨不曾生达分善根。所以者何。一切菩萨所有善根。不经历世菩提树下。一结加趺坐。生不净观。乃至尽智。问曰。菩萨九十一劫不堕恶道。此岂非忍力耶。答曰。不必以达分善根能障恶道。或以施力。或以戒力。或以不净。或以安般。或以闻慧或以思慧。或以暖顶后乃以忍。尊者佛陀提婆说曰。障于恶道。非不因知缘起法。其义云何彼作是说。觉知缘起法。即是无漏道。非无漏道力不能障恶道。评曰。不应作是说。如先说者好。所以者何。菩萨若行布施。亦以戒以慧。若行戒时。亦以施以慧。若行慧时。亦以施以戒。以是因缘。能障那由他恶道。况十处恶道耶。声闻辟支佛。所有暖顶。菩萨尽能起。以障恶道。唯不起忍。所以者何。忍与恶道相妨。菩萨于三阿僧祇劫。在生死中。以愿力故。生恶道中。此中应说鱼因缘喻。复有说者。起声闻辟支佛忍。以障恶道。不起菩萨忍。所以者何。于得道身大玄远故。求辟支佛人。以生辟支佛忍。不能生佛种忍。以近辟支佛道故。复有说者。求辟支佛人。能起佛种忍。评曰。不应作是说。应作是说。求辟支佛人。不能起佛种忍。问曰。得忍凡夫命终时。为舍忍不。若舍者何故不生恶道。若舍者何故凡夫舍圣人不舍。若不舍者。行揵度四大犍度何故不说耶。如说。若成就身。彼成就身业。乃至广说。答曰。或有说者舍。问曰。若舍者。何以不生恶道。答曰。或有说者。彼善根势力能尔。虽舍不堕恶道。自有善根虽成就。不障恶道。况不成就。所谓生处得善。自有善根。虽不成就。能障恶道。况复成就所谓忍也。是故彼善根势力能障恶道。复有说者。彼善根势力。能令身中堕恶道。烦恼业极令远离于此身中。更不复行。若其不行。何由得堕恶道耶。如人秋时服于下药。药亦不住彼人身中。或有与病俱出。或身中自消。而能除去病患。永使不起。如是彼善根势力。令堕恶道。诸烦恼业。永更不起。复有说者。此善根曾在彼身中。如师子住处在彼身中。虽不成就。勋着之力。能令恶道诸烦恼业。更不复行。况堕恶道。犹如师子所住之处。师子若行不在其余小狩。无能到者。何况在时。复有说者。彼善根住此身中。犹如旧住。诸恶道烦恼业。住此身中。其犹如客。旧住力强。客则不如。复有说者。行者有二种期心。一者期心远离诸恶。二者期心深着善法。以有此二期心故。不堕恶道。是故尊者瞿沙说。彼行者有如是期心。有如是欲如是忍如是可如是意如是敬如是爱如是乐复有说者。彼恶道已得非数缘灭。诸法已得非数缘灭。终不现前。复有说者。彼行者堕法雨驶流河中。不容作余恶道之业。是以不堕恶道。复有说者。依倚圣道故。彼行者依倚圣道。使此身中恶道烦恼业。不现在前况堕恶道。犹如有人畏于怨家。依倚于王。而彼怨家。犹尚不能正面视之。何况加害。复有说者。彼行者以此善根。于自身中。以守护圣道所住处故。犹如王人先守护王所住之地。一切人民不敢复住。复有说者。彼善根决定作人天处故。若作决定处业。必生彼处。犹如贵胜之座处所以定。不应复更坐于余坐。如是彼善根所住处。定亦复如是。复有说者。彼行者以正方便。令彼恶道诸烦恼业更不复行。何况生于恶道。复有说者。彼行者见恶行过患。见善行利益。是故不作恶行堕恶道中。复有说者。有善好期心。在此身中。不作恶行堕恶道中。复有说者。以心柔软故。随顺趣涅槃故。以信根深牢固故。是以不作恶行堕于恶道问曰。若舍者。何以凡夫舍。圣人不舍耶。答曰。彼凡夫人。无圣道对治力以自持御。虽有对治道以自持御。此道羸劣。不坚固久住是以命终时舍。圣人身中。有无漏对治道以自持御。彼以无漏定力牢固久住。是以命终时不舍。此中应说合众釆喻。复有说者不舍。问曰。若不舍者。业犍度四大犍度。何以不说耶。答曰。或有说者。彼中应说。而不说者。当知此义是有余之说。复有说者。彼业犍度中。亦说在第三句中。说圣人在胎是也。圣人有二种。有名数圣人。实义圣人。得达分善根者。谓名数圣人。得正决定者。谓实义圣人。是故彼亦说之。若人有一出家之心。犹得名为圣弟子。何况得达分善根者也。复有说者。或有舍者。有不舍者。谁不舍耶。于此善根。常勤方便故。作方便一切时作方便。善受持善修习者不舍。与上相违舍。如所闻。若于善根。常勤方便。乃至善修习者。虽经生死。而常不舍。如弥多罗达子初生之时。便作是言。结有二种。乃至广说。如先所闻。若于善根。不勤方便。乃至不善修习。于此身中。虽得速舍。如是当知有舍不舍。评曰。如实义者。凡夫人依彼地。生达分善根犹有舍者。何况生于他地

问曰。达分善根言得报。所谓色界五阴。为作彼身初业不。答曰。或有说者。不作初业。所以者何。彼似无漏道。憎恶受生故。余业作初业。彼达分善根。唯作满业。然后受报。复有说者。亦作初业。得身报妙好。随顺行道

此暖等善根。有七十三种。其事云何。欲界有十种。所谓一具缚凡夫。二除一品结。乃至九品尽者。初禅有九。或有除一品结。乃至九品初禅无具缚人。即欲界说故。如是乃至无所有处。有九种顶忍世第一法亦如是。问曰。具缚凡夫。所得暖法。除一品结。乃至九品。为一种耶。答曰不也。具缚凡夫异。除一品结异。乃至九品异

问曰。若退暖法。还生暖法。为本得得不。答曰不也。所以者何。彼不数数得用功而得。不前后相似故。如舍波罗提木叉戒后更受。非本得得彼亦如是。如暖顶亦尔。问曰。增长暖时。暖增长已。还起初者不。答曰。不也。所以者何。得胜进善根。前所得者。无可欣尚。顶忍亦如是

问曰。为于何处生此善根耶。答曰。欲界人中。谓三天下。非郁单越。问曰。欲界六天不能生耶。答曰不能。初生已曾生者。能起现在前。所以者何。若有好身。亦有随顺厌患。正观彼处。则能生暖。此三天下。具有此二。问曰若有好身。则诸天胜人。若取随顺厌患正观。则恶道胜。答曰。如先说俱有者。能天与恶道不俱有故。是以不能。问曰。暖法亦依男身。亦依女身。若依女身得于暖法。复得自身中男子所依暖法耶。答曰。得如是当知。顶忍亦尔。问曰。若依男身。得于暖法。复得自身中女人所依暖法耶。答曰。不得顶忍亦如是。黄门般吒(有男形不能男有女形不能女)无形二形。不能生暖等四善方便法

慧有三种。闻慧思慧修慧。答曰。或有师略说十八界十二入五阴。复有善诵修多罗毗尼阿毗昙生厌恼心。彼作是说。三藏所说要者。唯是十八界十二入五阴。彼即观察界观察界已。复作三种。所谓名体性总相。名者谓眼界乃至法界。体性者谓别相。总相者谓无常苦空无我。如是观时。修习此智。转得定意。于此界中。生厌恼想。复略观十二入。眼界即是眼入。乃至触界即是触入。七识界即是意入。法界即是法入。又略入观阴。彼观十色入及法入中造色。即是色阴。意入即是识阴。法入即是三阴。又略阴即是四念处色阴即是身念处。受阴即是受念处。识阴即是心念处。想阴行阴。即是法念处。又略阴观谛诸五阴果是苦谛。诸五阴因是集谛。五阴灭是灭谛。学无学法是道谛。彼谛复作三种名体性总相。名者谓是苦。乃至道。体性者谓别相。别相者。逼迫行义是苦义。乃至出要。行义是道义。总相者苦有四行。无常苦空无我。集有四行因集有缘。灭有四行灭止妙离。道有四行道如迹乘。修习此智。转得定意时。如见彼谛时。彼亦次第观别。欲界苦作异相别。色无色界苦乃至别断。欲界行道亦别。乃至色无色界行道。当于尔时观谛。犹如观叠外物。作如是观时。是名闻慧满足。如是展转修习。次生思慧。转进修习。次生修慧。能行圣行。如是观时。是名暖法。如是展转增长次生顶。顶次生忍。忍次生世第一法。次生苦法忍。断见苦所断十使。次第生苦法智。如是次第生道比智。得须陀洹果。次第乃至尽智。是名诸善根生次第生法

善根有三种。一福分善根。二解脱分善根。三达分善根。福分善根者。谓能作生天种子。若在人中生豪贵家。有大威势。多饶财宝。眷属成就。颜貌端严。能作转轮圣王帝释魔王梵王种子。解脱分善根者谓能作解脱种子。决定不退因。必至涅槃。达分善根者谓暖法。乃至世第一法。问曰。解脱分善根。于何处种耶。答曰。于欲界中。非色界。欲界中人道。非余道。人道中在三天下。非郁单越。佛出世时非无佛时。复有说者。若无佛时。遇辟支佛。亦种解脱分善根。体性是何。答曰。若身业口业意业。但意业偏多为是五识身。为是意地。答曰。是意地非五识身。为是方便善。为是生得善。答曰。亦是方便善。亦是生得善。为是闻慧。为是思慧。为是修慧。答曰。是闻慧思慧。非修慧。为以何事种此善根。答曰。或以布施。或以持戒。或以多闻。而不必定。所以者何。有人以一揣食施。能种解脱分善根。自有能作长斋般遮于瑟。而不能种解脱分善根。或有持一日斋。能种解脱分善根。自有终身持戒。而不能种解脱分善根。或有诵持一偈。能种解脱分善根。自有善通三藏文义。而不能种解脱分善根是。故不定。何以故。或有种者。有不种者。若以此事。回向解脱涅槃。欲永离生死。有如是勇猛心者是则能种。若不为回向解脱涅槃永离生死。虽多布施终身持戒广学多闻。而不能种解脱分善根。有近有远。近者前身中种。此身成熟来身解脱。远者曾种解脱分善根。经那由他世受身。而不能生达分善根。声闻所得解脱分善根。可回向趣辟支佛。辟支佛所得解脱分善根。亦可回向趣佛。佛所种解脱分善根。不可回转

问曰。有生灭观彼以何为方便耶。答曰。彼行者见春时草木青色。如绀琉璃。见河驶流浮沫着岸。见已作是思惟。此诸外法。今已复生。若入城邑聚落。见诸男女歌舞戏笑。而问之言何以故尔。答言。此中生男生女。彼复思惟如此内法。今已复生。彼行者。于后秋时。见诸草木。为秋日所曝冷风所吹。被诸霜露。枝叶零落。河水枯涸。彼复思惟如此外法。今已复灭。若入城邑聚落。见诸男女乱发举手[口*睪]啕啼哭。而问之言。何以故尔答言。此中男女死丧。彼复思惟此中内法。今已复灭。彼行者深见如此相已。还所住处。自观己身。有少壮老无常之相。次第观于岁月日时昼夜。相续是名方便。于此诸时展转除减。乃至观阴二刹那一生一灭。是名生灭观满足。问曰。此生灭观。为虚想观为实观耶。若是虚想观者。此偈云何通如说

  若有知见能尽漏　　若无知见云何尽
  若能观阴生灭者　　是则解脱烦恼心

非以虚想观能断烦恼。若当非实观者。应不见诸行有来去相。而诸行实无来去。或有作论者。说是虚想观问曰。若尔者此偈云何通。答曰。有转转因故。是以说彼转转相生。犹子孙法。其事云何虚想观能生实想观。实想观能断烦恼。是故说转转因。如子孙法。复有说者。是实想观。问曰。若然者诸行无来去。然彼行者。见于来去。答曰。若生灭观。未满足时。便见诸行有来去相。若其满足。见诸行无来去相。犹如小儿弄于独乐。旋速则见如住。旋迟则见来去。陶家轮喻亦复如是

问曰。为以一心见生灭。为二心一见生一见灭耶。若以一心见生灭者。云何一心而有二虑。若有二虑破一心义。复云何见为以见生生时复见灭耶。见灭灭时。复见生耶。若见生生时。唯见生者。是则为正。若见生生时。复见灭者。是则为邪。若见灭灭时。唯见灭者。是则为正。若见灭灭时。复见生者。是则为邪。若当一心见生一心见灭者。则无生灭观。答曰。应作是说。一心见生。一心见灭。问曰。若然者则无生灭观。答曰。此说通一生中相续生灭观耳。非谓一刹那也

阿毗昙毗婆沙论卷第三阿毗昙毗婆沙论卷第四

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    杂犍度世第一品之四

此二十种身见。几是我见。几是我所见。乃至广说。问曰。何故作此论。答曰。世尊经中。处处说二十种身见而不广分别。唯尊者舍利弗经中一处分别。彼虽分别而不说此二十种身见。几是我见几是我所见。因彼诸经不分别故。今欲分别故作此论。复次毗婆阇婆提作是说。身见无所缘。如身见缘我。实义中无我。彼何所缘。如人见绳谓是蛇见杌谓是人。为止彼人如是意故。亦欲显身见有所缘故。身见缘五阴。但所见事异。非无所缘。如彼人喻见绳谓是蛇见杌谓是人。此亦所见事异。非无所缘。是故止异人意欲显己义。亦欲示决定法相故。而作此论。问曰。此二十种身见。几是我见。几是我所见。答曰。五种是我见。十五种是我所见。问曰。若我见有五。我所见亦应有五。何故说十五我所见耶。答曰。缘行故说五我见。具故说十五我所见。所以者何。此十五我所见。以具故生。应说一我见。所谓五见中我见应说二如我见。我所见应说三谓欲界色无色界。我见应说六。如欲界中有我见我所见。色无色界亦尔应说九。如欲界地我见。乃至非想非非想地我见。应说十八。如欲界地我见我所见。乃至非想非非想地我见我所见。如分别行缘阴。应说二十不分别所起处。见色是我色异我。色属我我在色中。如色四种。受想行识亦如是。如是五四。则有二十。以行缘分别十二入。则有四十八。不分别所起处。如见眼入是我。眼入异我。眼入属我。我在眼入中。如眼入有四。乃至法入亦有四。如是十二四。则有四十八。以行缘分别界。则有七十二。不分别所起处。如眼界是我。眼界异我。眼界属我。我在眼界中。如眼界有四。乃至法界亦有四。如是十八四。则有七十二。若分别缘阴。分别所起处。则有六十五。如说色是我。受是我璎珞。受是我僮仆。受是我器。如受有三。想行识亦三。如是四三有十二。及色有十三。如是五种十三。则有六十五。若分别缘入。分别所起处。则有四百八眼入是我色入是我璎珞是我僮仆是我器。如眼入有三十四。乃至法入亦有三十四。十二种三十四。则有四百八。若分别缘界。分别所起处。则有九百三十六。眼界是我色界是我璎珞是我僮仆是我器。如眼界有五十二。乃至法界有五十二十八种五十二。则有九百三十六。如是种种身。诸刹那相续。则有无量我见我所见。此处分别行缘阴。不分别所起处。则有二十。问曰。以何等故此身见言种答曰此二十种身见。各有差别故言种

问曰。以何等故。因阴说二十我见。非因界入。答曰。或有说者。彼作经者。有如是意如是欲如是可随。彼意作经不违法相。复有说者。为现初起初方便入法。如因阴说。见因界入。亦应如是说。而不说者。当知此义是有余之说。复有说者。此阴说见者。正佛经所说。佛经因阴说二十种我见。彼作经者。亦依佛经作论。说二十种我见。问曰。置作经者。以何等故。世尊。因阴说二十种我见。答曰。为化众生故。佛因阴说二十种我见。若受化者。应闻界入。而得度者。世尊亦因界入。说于我见。以不应闻是故不说。复有说者。诸见生时。多依于阴。少依界入。是故世尊因阴说见。不因界入

色是我者。云何为色诸所有色尽四大。四大所造定诸所有有二种。有尽诸所有。有不尽诸所有。言不尽者。如求糟糠等少物有亦名诸所有。言尽者。如求一切物及糟糠等亦诸所有。此中唯说尽诸所有色。问曰。如我见是自界缘非他界缘。彼云何能见一切色是我。答曰。诸是彼所行。是彼境界者。计以为我。非一切色也。色异我者。云何色异我。于此四阴。展转计异于我。彼作是念。此色是我。有如人有财。名为有财。色属我者。云何色属我。于此四阴。展转计属我。如人有僮仆。言僮仆属我。色中我者。云何色中我。于此四阴。展转计是色中我。彼作是念。色是我器。如油在麻中。腻在揣中。如苏在酪中如刀在鞘中。蛇在箧中。如血在身中。问曰。如受是我。色是具可尔。色粗受细故。如说色是我受是具。云何见粗色。入细受中。尊者波奢说曰。不应责盲人堕坑。亦不应问无明者愚。复有说者。彼见色是我受是具者。彼人见受粗色细。是以见色住于受中。尊者和须蜜说曰。此四大身中。尽能觉触。有所触处。则能生受。以受处处生故。言色裹在受中。尊者佛陀提婆说曰。彼见受遍在身中。从足至头。无不有受处。然计色是我。不遍在身。是故彼见色住在受中

问曰。以何等故。我见说二十种。其余诸见不说耶。答曰。或有说者。彼作经者意欲尔乃至广说。复有说者。此为现。初起初方便初入法。如说身见有二十种。戒取应有四十种。邪见见取应各有八十种。应说而不说者。此义是有余之说。复有说者。为对治我见故。佛说十种空。十种空者。所谓内空。外空。内外空。有为空。无为空。第一义空。无所行空。无始空。性空。空空。此十种空。与何法相对。与我见相对。以空与我见相对故。有二十种我见。余见不尔是故不说

问曰。颇于一阴。起我见我所见耶。答曰。起如于眼入起我见。其余诸色。起我所见。余四阴亦如是。问曰。颇有我见者。一时于五阴。尽计我不耶。若有者。朔迦书云何通如说。唯有一我见。无有五我见。无五我见者。无计五阴是我者是也。所以者何。计我见。唯计一法。五阴是别异法。计我见家。说一我一人无分不坏不变是常。若无者。萨遮尼干子经云何通。如说瞿昙沙门色是我受想行识是我。答曰。无有一时计五阴是我者。问曰。若然者萨遮尼干子经。云何通耶。答曰。彼自大心重故。作如是说复有说者。彼不信佛。内有知见。欲试如来彼为知不。故作不顺理说。次见如来诸论议相。领如师子。钩牙铦利。口四十齿。出梵音声。彼人闻已。心怀怖懅。作不顺理说。复有说者。彼人见如来威德。胜于梵释难近难亲。有如是威德故。作不顺理说。复有说者。天神威逼故。令彼人作不顺理说。复有信佛天神。作如是念。此弊恶人。何以久恼如来故。以威逼能令彼人作不顺理说。复有说者。或有一时计五阴为我。问曰。若然者。朔迦书所说云何通。答曰。彼人于此五阴。尽作一具聚相。问曰。若然者复以何为具。答曰。若计内入为我。则以外入为具。若计外入为我。则以内入为具。问曰。为有见微尘计以为我不。若有者。是则无我见。非是我见。若无者。朔迦书复云何通。如说五大微尘虽各异相。是我是常。若言无常是则无理。问曰。彼书云何通我见见微尘。答曰。此书说边见缘微尘。此义已立。当知我见缘微尘。此义亦立。答曰。无有见微尘计以为我。问曰。若然者。朔迦书复云何通。答曰。此书所说不顺正法理。复有说者。有见微尘计以为我。有推理见义无实见生时义。评曰。不应作是说。如前说者好

问曰。五阴之外。为有起我见者不。若有者此经云何通。如说若有沙门婆罗门。起于我见。尽见五受阴。若无者。说第六我见。复云何有。答曰。无有五阴之外起于我见。问曰。若然者。第六我见云何而有。答曰。思是行阴。于思起我。见其余行阴起于我所见。即是第六我见。佛经说身见。是六十二见根本。余经复说。若有沙门婆罗门。所起诸见。尽依二边。若断若常。此二经有何差别。答曰。云何能生诸见故。说身见为本。守护长养诸见故。是说边见。复有说者。能生诸见。是说身见为根本。使诸见转行是说边见

复有经说。若入地一切处定行者。作是念。地即是我。我即是地。不离不异。余一切处亦如是。问曰。诸得一切处定。必离第三禅欲。彼若见地是我。当知是第四禅地身见。见第四禅中地为我。一切处定法缘欲界。彼云何不相违耶。答曰。此中不定说定。如非沙门说名沙门。复有说者。以本名说故。如王失位犹名为王。行者本曾得此定。后虽失时犹称得定。复有说者。行者于定速疾故失。于彼定起欲界身见。舍于身见还得彼定。如提婆达多。于定速疾。以神足力。自化己身。作太子像。于阿阇世王抱上。回转游戏复现相貌。令阿阇世王知是尊者提婆达多当作太子像时。阿阇世王抱弄呜之唾其口中。贪利养故即便咽之。是以世尊而语之言。汝是死尸食唾之人。若咽唾时彼非离欲。若作太子。为阿阇世王所抱弄时尔时离欲。复有说者。身见见第四禅中地是我。一切处定。亦缘第四禅中地。问曰。若然者一切处定。不缘欲界耶。答曰。一切处定。亦缘欲界。亦缘第四禅。问曰。如色界诸天一切悉白。彼复云何见青黄赤等差别。答曰。彼众生数者。其色悉白。非众生数有青黄赤色。评曰。不应作是说。所以者何。若我见与一切处定。是相应共有法者。应有是过。云何是一切相应共有法。少缘欲界。少缘色界。身见与一切处定。虽非相应共有法。而一人亦得二名。以计我故名为身见。以得定故名得定人。身见缘第四禅中地。一切处定。缘于欲界。不同一时。是故此论为已善通

无常见常。乃至广说。问曰。何以作此论。答曰。此诸邪见于生死中。为诸众生作大系缚。作大衰患作大藏伏。犹如世间系缚衰患藏伏人。若不见不能远避人。若见时则能远避此诸邪见。乃至广说。亦复如是。此中应以二事推求邪见。一以体性。二以对治。如智犍度见犍度。如增益智论。彼中亦以二事。推求邪见。一体性。二对治。如增益智论中说。沙门瞿昙汝是幻。世尊之道已过于幻。此邪见谤道是其体性。见道断是其对治。复作是说。此是阿罗汉。汝何故悭惜阿罗汉名也。世尊之道已过于悭。此邪见谤道是其体性。见道断是其对治。如偈问论如梵网经说。应以起处推求邪见。便有三事所谓起处体性对治。复有说者。不应推求邪见三事。所谓起处体性对治若推求邪见。如责无明。汝何以愚。复有说者。应以三事推求邪见。所谓起处体性对治若能以三事。推求邪见。虽是具缚凡夫。邪见过患不现在前。犹如圣人以无漏道断诸邪见永不复起。如陀婆法师昔在罽宾。与众多修行比丘。共会一处。论说诸见。有作是言者。诸大德。圣人能断多诸过患。邪见恶行永不现前。甚为希有。尔时陀婆法师在此会中。而作是言。圣人以无漏道。断诸邪见。永不现前。有何奇事。如我今者住凡夫地。以此二事。推求邪见。若久住生死者。无有是处。设久住生死。更不现前。以是缘故。应以三事推求邪见。无常有常见者。云何无常。答曰。一切有为法。问曰。彼诸外道为以何事言常耶。答曰。见色相似相续。诸心法忆本所作。能诵持诸论。云何见色相似相续。如昨日所见色今日相似。彼作是念。童幼时色。即老时色。云何心法忆本所作。如昨日所作今日故忆。如是诸先所作。后时皆忆。能诵持经论者。如少所读至老能诵。彼作是念。今日诵心。即往日读心。彼以是故计常。无常计常是边见。边见有二种。有断有常。是则说边见。体性见苦断。是其对治。此见缘苦而生。故见苦断。如草上露日照则干。彼亦如是。若见苦时。彼见则断。复有说者。苦法忍苦法智。是其对治。苦法忍苦法智生时。断此虚妄分别颠倒崄恶断见。问曰。如善说法中。亦说诸法。有自体性相常住。而不是邪见。何故恶说法中。若说此相。便是邪见。答曰。或有说者。善说法虽说有自体性相常住无所作。恶说法中。于一切时。常有所作。复有说者。善说法中。说法性。不数数作。恶说法中。说于法性。则数数作。复有说者善说法中。说于法性。为生所生。为老所老。为无常所坏。恶说法中。不为生所生。乃至广说。复有说者。善说法中。说法性属诸因缘。彼所说法。不属因缘。复有说者。善说法。所说则与生灭相应。彼则不尔。复有说者。善说法中说法。则从因生。能有所作。属于众缘。以是诸因缘故。善说法。虽说体性常住。不堕邪见。恶说法者。堕于邪见。问曰。边见是何义。答曰。取于断边。取于常边。是边见义。如经说。佛告迦旃延。若以正智。观世是集。言无所有。则更不行。无所有者。即断见也。见此有灭未来身生。而作是念。是众生死此生彼。非是断耶。又迦旃延。若以正智。观世是灭。言世有所有。则更不行。言世有所有者。则是常见。知此阴界诸入展转相续。彼作是念。此诸法等。有生有灭。非是常也。复次起我见者。犹是边僻下贱。世所呵责。况复于我。计有断常。复有说者。此见行边处。故有二种义。名行边处。一行常边。二行断边。以是等义。故名边见。问曰。实义常者。是灭尽涅槃。云何无常见常。不名邪见。答曰。诸言无所有。是名邪见。此则不言无所有。更增益所有。是故非邪见

常见无常者。云何为常。答曰。灭尽涅槃。问曰。彼诸外道为以何事言涅槃无常。答曰。彼以四无色定。为解脱涅槃。一名无身。二名无边意。三名净聚。四名世塔。无身者是空处定。无边意是识处定。净聚是无所有处定。世塔是非想非非想处定。彼作是说。如此涅槃。虽久当还。当知释种所说涅槃。亦当复还。是以故言涅槃无常。彼常见无常者。此是邪见。是其自性。见灭所断。是其对治。此见因灭生故。故见灭断。如草上露。乃至广说。问曰。为有邪见。能观是无常行不。若有者波伽罗那经云何通。如说云何邪见使使。答曰。诸谤无因无作。是名邪见使。此中何以不说。若无者此文复云何通。如说常见无常。此是邪见。见灭所断。答曰。有此邪见常见无常。问曰。若然者波伽罗那经何以不说耶。答曰。彼说邪见。行相不尽。自有诸结行相。彼中不尽说。复有说者虽有此见。悉入彼所说中。如谤言无因。当知谤集。如谤言无作。当知谤于三谛。复有说者。谤言无因。是说谤于三谛。谤言无作。是说谤于灭谛。复有说者。无有邪见。能谤常言无常。问曰。若然者此文复云何通。答曰。涅槃有常相。若言无涅槃。亦谤常相。犹如有人。谤人无指。亦谤指所依色香味触彼亦如是。复有说者。彼外道言。五阴是常。释种言涅槃是常非阴。彼作是说。除阴之外。更无有常。以是义故。岂非谤涅槃耶

苦作乐见者。乃至广说。云何为苦。五受阴是实苦。彼诸外道。以何等故。言苦是乐。答曰。以少时乐故言乐。如人极时止息为乐。热时凉为乐。寒时暖为乐。饥渴时得饮食为乐。以是事故。言阴是乐。如说以下法为最。名曰见取。是其自性见苦断。是其对治。问曰。苦有乐见。名曰见取。以何等故无常见常。不名见取。答曰。彼无常常见者。胜不胜法。同为一体。自有法虽言常不胜。如计虚空非数缘灭。苦有乐见。以下法为最。名为见取。无常见常。不名见取。复有说者。阴中有大苦故。以小苦为乐。以此小乐同于涅槃。故名见取。无常见常。阴中无有少常同于常者。所以者何。一刹那顷。更无停住。是散灭法。如说云何灭时法。答曰。现在法。以是事故。无常见常。是名边见。不名见取

乐有苦见者。乃至广说。云何为乐实义。乐者灭尽涅槃。彼诸外道以何等故。以涅槃为苦。答曰。如人坏一根时便以为苦。彼作是念。若坏一根犹以为苦。况众多根。以是事故以乐法为苦。尊者和须蜜说曰。若一根在。犹为苦因。况多根在。不为苦因。若诸根灭。则为解脱。涅槃乐有苦见邪见。是其体性见灭断。是其对治。此见依灭生还见灭断。如草上露。乃至广说。问曰。以何等故见涅槃是苦。名为邪见。非见道谛耶。如说道谛亦是乐。能至乐故。答曰。道有二分。苦分乐分。以道能至乐处。故名为乐分。无常故苦。名为苦分。涅槃无二分纯乐。谤者即是邪见道谛不尔。复有说者。如见犍度所说。有二种乐。一名数乐。二实义乐。上言能至乐处者。是名数乐。非实义乐。复次以涅槃乐故。道得称乐。问曰。为有邪见能缘涅槃。是苦不耶。若有者波伽罗那经云何通。如说云何邪见使使。答曰。诸谤无因无作。乃至广说。应如上常计无常句中说

不净见净者。云何不净。答曰。一切有漏法有二事故不净。一以烦恼。二以境界。彼诸外道。以何事故不净见净。答曰。愚于所行。以少时净故。如治爪齿发肤形容摩身洗浴等。以是事故彼见是净。若此法中。有少净性者。彼计则非邪见。以颠倒想故。计屎尿肠胃等是净。故名为见取。复应以二事知有漏行是不净法。一从烦恼生。二从淫欲生。如说以下法为最。此名见取。是其自性。见苦所断是其对治。乃至广说。问曰。现见屎尿涕唾流出。彼云何言净。答曰。彼作是说。所流出者虽是不净。彼流出处是净。犹如紧首迦树花。其色似肉花盛之时。野干见之便作是念。如我今者定当食肉。久住树下。或时树花有堕地者。即便嗅之乃知非肉。复作是念。堕者虽非是肉。树上余者必应是肉。彼诸外道亦复如是。所流出者。虽非是净。所流出处必应是净。问曰。如善说法中。亦说有漏善行是净。而非邪见。彼说即是邪见。答曰。有少净相。便见少净。问曰。何等是净相。答曰。不杂烦恼。复与烦恼相违。是故非是邪见。彼恶说法中。以不净法。同于实义清净之法。是名邪见。复有说者。如善说法中以善行为净。故非邪见。彼以善不善行不善根烦恼颠倒邪见是净。故名邪见。问曰。如有漏法。杂烦恼故。当知不净。云何说言三净。答曰。如实义。一切有漏法尽是不净。以假名故说净。云何假名。从无贪无恚无痴善根生故。亦能对治贪欲等法。故名假名

净见不净者。此见有二种。乃至广说。云何为净。答曰。道道果。彼诸外道。以何事故。言灭道不净。答曰。彼作是说。如实义诸烦恼。是不净法。道能断之。以道能断诸烦恼。故道亦不净。以涅槃从不净道生故。亦是不净。犹如以刀割不净物刀则不净。以不净刀更割余物。能令余物不净。又如水洗不净物水则不净。若以此水更洗余物物则不净。如是以道断诸烦恼。道则不净。若以此道。生于涅槃亦是不净。言道是不净此见名邪见是其自性。见道断。是其对治。若言灭是不净。此见名邪见。是其自性。见灭断。是其对治。见道断邪见。缘道生故。若道智道忍生时。断见灭断邪见亦如是。无我见我者。乃至广说。云何无我。答曰。一切诸法无我。彼诸外道以何事故见我。答曰。愚于来去威仪法故。彼作是说。若无我者谁来谁去。谁住谁坐。谁屈谁申耶。以有我故。能来去住坐屈申。复次若无我者。则无见闻嗅香知味觉触忆念。以有此事必知有我。彼无我见我。此名身见。是其自性。见苦所断。是其对治。此见缘苦生。乃至广说。我有二种。一假名我。二计人我。若计假名我。则非邪见。若计人我此则邪见。问曰。此中但说我见。何以不说我所见。答曰。我见是颠倒性。我所见非颠倒性。复有说者。我见是根本。若说我见。当知亦说我所见。复有说者。以有我见得有我所见。若说我见当知亦说我所见。己见己所见亦如是。问曰。以何等故。不说我见无我。名为邪见。答曰。以无我故。复有说者。若我见无我。是则正见。不名邪见

非因见因。乃至广说。问曰。彼云何非因见因。答曰。谬见因故。如农夫种殖秋大获实。彼作是言。此皆尸利夜天思陀夜天舍摩夜天恩之所与。若生男女彼作是言。此皆难陀天难陀婆罗天之所与。若富贵者生男女。彼作是言。此皆是毗纽天摩醯首罗天之所与。彼作如是谬见。于因非因计因。此名戒取。是其自性。见苦所断。是其对治。此戒取缘苦生。故还见苦断。问曰。无因见因。是亦名谤因。云何非邪见。答曰。尊者和须蜜说。若谤无因。是名邪见。彼不言无因非因计因。故非邪见

有因无因见。乃至广说。彼诸外道。以何事故。言无因耶。答曰。见内外所有诸物有种种相故。彼作是言谁凿河谁积山。谁纤刺谁釆画禽兽。故说是偈

  谁能造刺纤　　釆画诸禽兽
  此皆无因作　　世无自在者

彼有因无因见。此名邪见。是其自性。见集所断。是其对治。此见缘集生。还见集断。乃至广说。问曰。以何等故。此中说谤因邪见见集所断。见犍度中说谤因邪见。当言见集见道断。答曰。或有说者。彼作经者意欲尔。乃至广说。复有说者。此中不说一切因义。彼说一切因义。复有说者。此中谤生果因。彼中说者。谤生果不生果因。若说涅槃无因。此岂非正见耶复有说者。此中说谤苦因。彼中说谤苦不苦因。复有说者。此中无谤道因义。是故不说。是谤道邪见。唯有谤集因义。是以说是谤集邪见。有作无见。乃至广说。云何为有。答曰。四谛是也。彼诸外道以何事故。言无谛耶。答曰。以有我见。故言无谛。彼作是说。我无有苦。是则谤苦。我无有因。是则谤集。我若无灭。是则谤灭。若无有灭。则无对治。如善法中。作如是言。此阴是苦。无我生信。苦心言有苦谛。此苦有因生信。集心言有集谛。若苦有灭生信。灭心言有灭谛。灭若有对治生信。道心言有道谛。彼有作无见。此名邪见。是其自性。见苦集灭道所断。是其对治。此见缘四谛生。还见四谛断。乃至广说。问曰。以何等故邪见不缘虚空非数缘灭。答曰。或有说者。若法是阴。是阴因。是阴灭。是阴对治。邪见则缘虚空非数缘灭。非阴因灭对治。是以邪见不缘。复有说者。若法是苦。是苦因。是苦灭。是苦对治。邪见则缘虚空非数缘灭。与上相违。是故邪见不缘。复有说者。若法是烦恼。是出要。邪见则缘虚空非数缘灭。与上相违。是故不缘。复有说者。若法为无漏正见所缘。亦为邪见所缘虚空非数缘灭。不为正见所缘。邪见亦不缘。如邪见正见。明非明。智非智。决定疑信诽谤。当知亦如是。问曰。若言无虚空非数缘灭。此心为何所缘。答曰。即缘虚空非数缘灭名。所以者何。此无深重心。如谤烦恼出要法。问曰。为是何智。答曰。此是思惟所断。不隐没无记邪智。有作无见者。有有三种。一相待有。二处所有。三实有。相待有者。因有故有无。因无故有有。处所有者如此处有彼处无。实有者。此实有此实无(如苦实有我实无)。复有说者。有有二种。一物体有。二施设有。物体有者。谓五阴。施设有者谓男女等。谤苦有二种。一谤物体。二谤果。若谤集者谤物体。谤因。若谤灭者谤物体。不谤果。若谤道者谤物体。不谤因。或有说者。亦谤因

无作有见。乃至广说。问曰。何以作此论。答曰。或有说者。应作是说。若无作有见。当言是身见。见苦所断。复有说者应作是说。无作有慧。所以者何。此非见性。复有说者。应作是说。此非是见。所以者何。五见不说故。而不说者。彼有何意。答曰。欲作问答故。如说无作有见。此是何见。是名为问。答曰。此非是见。是名为答。自有虽无是事。而有问答。如十门中。未知欲知根知根知已根无漏无为法亦问。几使所使。此亦是问。答曰。不为使所使。此亦是答。如彼虽无是事。而有问答。此亦如是。无有是事。而作问答。无作有见。此是何见。答曰。此非是见。是邪智。问曰。云何邪智。答曰。或有说者。是思惟所断。不隐没无记法。如行正路作非路想。如行非路作正路想。如男作女想。女作男想。如是等想是也。复有说者。此智亦有隐没无记。所谓与慢相应者。如彼梵天作如是说。我是大梵。诸梵中尊。我能造化。此是邪智。所以者何。无有住见谛所断心。能作是言者。应作是说。如前说者好。是思惟所断。不隐没无记法。问曰。若然者。违智揵度如说。云何邪智。谓染污慧。答曰。不与彼相违。所以者何。无知有二种。所谓实义假名。实义者。与无明使相应。是诸阿罗汉已断尽。假名者如见杌谓是人等者。阿罗汉辟支佛亦有唯有如来等正觉二事俱尽

有四倒所谓常乐净我。为相似法所覆故。不知无常。为适意威仪法所覆故。不知苦。为皮肤所覆故。不知不净。为所作事覆故。不知无我。问曰。此四倒性是何。答曰。是慧性。问曰。若是慧者。此五见。几是倒几非倒。答曰。二见半是倒。二见半非倒。二见半是倒者。身见见取。及边见所摄常见。二见半非倒者。邪见戒取。及边见所摄断见。问曰。以何等故。二见半是倒。二见半非耶。答曰。以三事故名倒。一转行。二增益。三性倒。邪见断见。虽转行性倒。而非增益。所以者何。是坏物性故。戒取虽转行。虽增益性。非是倒。所以者何。有少相似法故。亦说有色界道。能离欲界欲。有无色界道。能离色界欲。此是倒自体。是我是物是相是分是性。已说自体所以。今当说以何等故名为倒。答曰。倒有所增故名倒。此四倒。唯见苦断。所以者何。缘苦生故。还见苦断。复次此倒缘果生。还以见果慧断。复次身见见苦所断性是倒。若身见断亦断。复次苦粗。若于粗苦。有错谬者。贤圣所呵。如人昼日错谬。人之所呵。三谛微细。若于微细有错谬者。不深呵责。如于夜中有脱失者。则世人不深呵责。复次行者已见苦。永无倒心。若当行者见苦已不见集者。无有是处。为分别故。设见苦已。更不见余谛。若问彼言。此阴为是常。为是无常。彼定。答言。是无常乃至无一刹那停住者。若问为是苦为是乐。彼定答言。是苦犹热铁丸。若问为净为不净。彼定答言。是不净犹如粪聚。若问为有我无我耶。彼定答言无我。以无作者。无彼作者。无受者故。如草木粪扫等

阿毗昙毗婆沙论卷第四阿毗昙毗婆沙论卷第五

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    杂犍度智品第二

颇有一智知一切法耶。如此章及解章义。是中应广说。优波提舍。问曰。何以作此论。答曰。为止他义故。如摩诃僧祇部作如是说。自体能知自体。如灯是照性。能自照亦能照他。彼智亦尔。是智性。能自知亦能知他。昙摩掘部。作是说。智能知相应法。弥沙塞部。作是说。智能知共有法。彼作是说。智有二种。一时共生。一与心相应。一不与心相应。心相应智。知心不相应法。心不相应智。知心相应法。犊子部。作是说。人能知非智。为止如是诸异义故。而作此论。颇有一智知一切法耶。答曰。无也。若复有此智生一切诸法无我。此智何所不知耶。答曰。不知自体。是为便止摩诃僧祇意。不知相应。便止昙摩掘部意。不知共有。便止弥沙塞部意。以智知不以人知。便止犊子部意。此中作问作答。作难作通。如说颇有一智知一切法耶。此则是问。答曰。无也。此则是答。若复有此智生一切诸法无我。此智何所不知。此则是难。答曰。不知自体不知相应不知共有。此则是通。问曰。谁作此问。谁作此答。或有说者。毗婆阇婆提问。育多婆提答。如毗婆阇婆提问。育多婆提言。颇有一智知一切法耶。育多婆提答无也。毗婆阇婆提复难。若此智生一切法无我。此智何所不知。育多婆提。作如是通。不知自体不知相应不知共有。复有说者。弟子问师答。复有说者。无有问者。无有答者。但作经者。有如是意。若有人问。颇有一智知一切法。我当答无也。彼复作此难。若此智生一切诸法无我此智何所不知我当答言不知自体不知相应不知共有。此中说一智者。是一刹那智。是故说不知自体。乃至广说。若作是说。此十智中。颇有一智知一切法耶。可作是答有。谓等智是也。如是九八七六五四三亦如是。若作是说。此二智中。颇有一智知一切法也。答曰有。谓等智也。颇即彼等智。能知一切法不。答曰知。若一刹那顷。等智除自体相应共有。能知余一切法次第二刹那生。能知前刹那等智及相应共有。是故等智二刹那顷。一智能知一切法。上言一智不知者。言一刹那一智。问曰。以何等故。自体不知自体。答曰。或有说者。诸法除自体。于他有缘生义。自体于自体。无长无损。无害无利。无育养无坏。无增无减无因无缘。无次第。复有说者。若自体知自体者。则与世间现喻相违。犹如指端不能自触。如眼瞳黑不自见黑。如刀不自割。是故自体不知自体。复有说者。若自体知自体者。则无二处法。如世尊说。眼缘色生眼识。乃至意缘法生意识。复有说者。若自体知自体者。则无三等触。如世尊说。眼缘色生眼识。是三等触。然有此触生。是以无有自体能知自体。复有说者。若自体知自体者。则无邪见。若邪见能自知我是邪见。此则正见。不名邪见。复有说者。若自体知自体者。此智毕竟性能自知。不能知他。然能知他。是故不知自体。复有说者。若自体知自体者。则无取所取。如取所取。智所知亦如是。复有说者。若自体知自体者云何知耶。为知自体是自体。为知他体亦如知自体耶。为知他体是他体。为知自体亦如知他体耶。若知自体是自体。若知他体是他体。是则为正。若知自体如知他体。是则为邪。若此智生。能知自体。亦知他体者。一智则有二作相。有二作相则有二智。有二智则有众多自体。问曰。若自体不知自体者。摩诃僧祇喻云何通。答曰。此喻不必须通。所以者何。此喻非修多罗毗尼阿毗昙中说。不可以世俗现喻难贤圣法。贤圣所作法异世俗所作法异若必欲通者。当云何通。答曰。应说其喻过。若喻有过。所喻法亦有过。云何喻有过。答曰。灯无根无心。非众生数。彼智亦非根非心。非众生数耶。复次灯众微尘所成。彼智亦众微尘所成耶。若不尔者。则不相似。复次如灯体性是照。不若是照性。复何所照。若体性非照。应当是闇。则无明性。为破闇故取灯。若灯体性是闇。则有大不相似过。以何等故。不知相应。答曰。同缘一法生故。是诸心心数法。同缘一法生。以同缘一法故。不能展转相缘。如众多人仰视虚空。不能展转自相见面彼亦如是。复次若慧缘自相应受。彼受为自缘为缘他。若自缘者。有上自缘之过。若缘他者则不与慧共同一缘。以何等故。不知共有法。答曰。以逼近故。如以铜筹盛安阇那药着于眼中。以逼近故。眼不得见。问曰。云何名共有法。答曰。彼回转身口业生住无常是也。西方沙门作如是说云何共有法。慧生时所依阴身。是共有法。问曰。如汝所说。慧生时所依身。是共有法。若然者。眼识生则不自见身众色差别。如眼识余识亦尔。彼作是说。五识生时。能各自缘所依。意识不能。问曰。意能缘一切法。汝先言不能。是则不然。复次若慧生时所依身。是名共有法者。则有大过。何以知之。如苦忍生时。便于自身不得决定。是名于苦得少决定。彼作是言。若苦法忍。不尽决定。苦法智生。尽得决定。如道法忍不尽决定。道法智生尽得决定。彼亦如是者。彼不应作是说。所以者何。于道得决定时异。于苦得决定时异。问曰。其事云何。答曰。如道谛所断邪见。总谤一切道。欲令于道少分决定无有是处。为分别故。设使于道少分决定。便能断谤道邪见。何况尽决定。唯除一刹那相应共有法。如身见或计色是我乃至计识是我。若苦法忍生时。于所依身。不得正决定者。所缘身我见则不应断。所以者何。以苦忍不见我见所缘身故。如身见于苦谛所断烦恼为首。若其不断则余结不断。余结不断则无于苦究竟得正决定。若于苦不得究竟正决定。于集灭道亦不得究竟正决定。以是事故苦法忍现在前。于所依身。亦见是苦得正决定。何以知之。如说苦法忍所缘。世第一法亦缘。彼世第一法。缘欲界五阴尽无有余。颇有一识识一切法。乃至广说。问曰。以何等故。智后次说识。答曰。或有说者。彼作经者意欲尔。乃至广说。复有说者。此是经论旧法。如经说。长老摩诃拘郗罗。往长老舍利弗所问言。长老舍利弗。所言智者云何为智。次作是问。所言识者云何为识。乃至广说。如波伽罗那论中说。云何知法。次问云何识法。如此义等。先说智次说识。如尊者昙摩难提说。若以智以识。有所观察。此事必定。彼作经者。亦随顺旧法。是以先说智次说识。复有说者。识即智。智即识唯长一字。何者阇那秦言智。毗阇那秦言识。长一字者所谓毗也。为断如是意欲说差别义故。先说智次说识。复有说者。以此俱是根本法故。增长法中识为根本。寂灭法中智为根本。复有说者。俱是元首法故。如说道品法中谁为元首。所谓智也。生死法中谁为元首。所谓识也。复有说者。此俱是依法故。如说依智不依识。亦说如行五根识。尽依意识。复有说者。若说智则说数法。所未说者唯是心。是故先说智次说心。复有说者。十二入中。二入能缘。所谓意入法入。若说智即说法入。若说识即说意入。复有说者。此六识各别行境界。如眼识识色。耳识识声。鼻识识香。舌识识味。身识识触。意识唯识法。为止如是意欲说意识能缘一切法故。次智说识。复有说者。智能缘一切法故。次智说识。复有说者。智能缘总相别相。识唯缘别相。为止彼人意欲说识能缘总相别相故。次智说识。复有说者。智行相似不相似境界。识唯行相似境界。为止彼人意欲说识行相似不相似境界故。次智说识。复有说者。欲止犊子部意故。彼说智是道支。识是有枝。彼依佛经。作如是说。识缘名色故。知是有枝。云何圣道。所谓正见。乃至正定。是故说智是道支。为止如是意欲说智识俱是有枝俱是道支故。次智说识。复有说者。止譬喻者意。譬喻者说。智之与识。是次第生法。不一时生。为止彼人意故。作如是说。若此智生一切法无我。此智何所不知。此智必有相应识。便止彼人识智次第生意故。如智能缘一切法无我。识亦如是余文如上说。颇有一识识一切法。此中亦有问有答。有难有通。应如智文说。如说有缘一切法无我行。问曰。此何处经中说。答曰。如偈说

  若能以智观　　一切行无我
  能生厌苦心　　是道得清净

此偈当知说诸行无我。问曰。如说能生厌苦心。此云何能缘一切法。答曰。有说者初半偈说一切法无我行。后半偈说缘苦谛行。复有说者。初半偈是观行时。后半偈说是见苦时。复有说者。此偈举说缘苦时无我行。所以者何。无漏法非是可厌法。问曰。若然者云何是缘一切法无我行。答曰。一切有二种。有少分一切。有一切一切。此中说少分一切。非一切一切。余经亦说。一切皆炽然。无漏法不炽然。当知说少分一切。彼亦如是说少分一切。复有说者余经亦说。一切行无常。一切行无我。涅槃寂静。此经即说一切法无我行。评曰。且置佛经说与不说。如是说者好。应有缘一切无我法行。所以者何。行者在初行地。必有如是观现在前。是以说之。问曰。如空行亦能缘一切法。此中何以不说。答曰。或有说者。彼作经者意欲尔。乃至广说。复有说者。应说而不说者。当知此义是有余之说。复有说者。如空行有所以空。有所以不空。有所以空者。如自中无他。有所以不空者。以自故不空无我行无。如此分别。是以尊者和须蜜作如是说。我不说一切诸法悉空。问曰。以何等故。有漏无我行。能缘一切法。无漏无我行。唯缘于苦。答曰。或有说者。有漏无我行。于观行中势用胜。无漏无我行。得正决定时。自分中胜。如初观行时。行者必观一切法是无我。是以有漏无我行势用胜。能缘一切法。无漏无我行。于自分中明了故胜。是以不缘一切法。复有说者。无漏无我行。能对治四倒。如四倒所缘。彼无漏无我行亦缘有漏无我行。不能对治四倒。是以能缘一切法。复有说者。无漏观谛有分齐。有漏观谛无分齐。复有说者。无漏者。对治烦恼。非一切法是烦恼性。有漏者。不对治烦恼。是以能缘一切法。问曰。如有漏无我行不能尽缘一切法。彼作是念。一切诸法无我。云何非是邪也。答曰。或有说者。彼缘多分。不缘少分。缘多分者。如大海水。少分不缘者。如海水一渧。复有说者。随其所行。随其境界。尽缘自体。相应共有。非其所行。非其境界。是以不缘。问曰。缘一切法无我行。体性是何。答曰。慧是体是性。乃至广说。已说体性。今当说所以名无我行。答曰。此行无我法故。名无我行

界者。在欲色界无色界中。亦有缘一切法无我行。而不能普缘一切法。地者。在七地。谓欲界未至禅中间。根本四禅空处亦有。而不能缘一切法。问曰。为能缘几所法。答曰。缘四无色阴。诸彼因。诸彼灭。诸彼比智分。诸比智分非数缘灭。诸无色非数缘灭及虚空。虚空与众生。若言是一。若言是异。彼空处无我行尽能缘。识处亦有无我行。而不能缘一切法。问曰。能缘几所法。答曰。缘三无色阴。诸彼因。诸彼灭。诸彼比智分。诸比智分非数缘灭。三无色非数缘灭。除一切虚空。彼识处无我行尽能缘。不用处。缘二地。非想非非想处缘一地。余如上说。复有说者。空处无我行能缘。如上所说法。复缘五地。非数缘灭四无色第四禅如是识处缘四地。不用处缘三地。非想非非想处缘二地非数缘灭。评曰。不应作如是说。如前说者好。所依身者。依欲色界身初生依欲界身后依色界。所以者何。初生依欲界身。命终生色界。依色界身。重起现在前。行者唯行无我行。缘者。缘一切法。念处者坏缘法念处。智者等智。三昧相应者不与三昧相应。根相应者。三根相应。谓喜乐舍。第三禅与乐根相应。初禅二禅喜根相应。未至中间禅。及第四禅。舍根相应。欲界二根相应。谓喜舍。问曰。如善忧根相应能缘一切法。此中何以不说与相应。答曰。体性相违。无我行体性欣尚。忧根体性愁悴。是以不与相应。世者。当言在过去未来现在。缘世者缘过去未来现在及非世法。善不善无记者当言善。缘善不善无记者。当言三种缘。欲色无色界系者。当言欲色界系亦无色界系。缘欲色无色界系法者。当言缘欲色无色系法亦缘非系法。是学无学非学非无学者。当言非学非无学。缘学无学非学非无学者。当言三种缘。见谛断修道断不断者。当言修道断。缘见道断法修道断法不断法者。当言三种缘。缘名缘义者。当言二俱缘。缘己身缘他身者。当言缘己身他身亦缘非己非他。闻慧思慧修慧者。当言是三种慧。欲界是闻慧思慧。色界是闻修慧。无色界是修慧。方便得生得者。当言是方便得是生得。如色界闻慧。可言是方便亦可言是生得。云何言方便得。答曰如于此间修总相别相生彼则得。若不修习。虽生彼不得云何亦可言生得。答曰。此虽修习。不生彼间。不名生得。欲界命终生二禅中。二禅命终生初禅中。彼为得不。答曰。或有说者。不得。所以者何。以远故。若即二禅得修习。生初禅中。则得。初禅命终。生二禅中。初禅地法尽舍。二禅命终。还生二禅。彼为得不。答曰。得欲界命终。生无色界中。无色界命终。还生无色界中。彼为得不。答曰。或有说者。不得以远故。复有说者。若即无色修习。还生无色界则得。问曰。为是圣人能生此法。为凡夫人能生此法。答曰。圣人亦能凡夫亦能。凡夫有二种。有内道凡夫有外道凡夫。何道凡夫能生此法。答曰。内道亦能外道亦能。内道凡夫。亦方便得。亦生处得。外道凡夫。唯生处得。复有说者。外道凡夫。唯生处得。不起现在前。所以者何。以计我故

问曰。云何起缘一切法。无我行现在前。答曰。生欲界中。起现在前时。缘一切法。生欲界中。起色界者现在前。亦缘一切法。若生初禅。不入定现在前时。亦缘一切法。若入定现在前时。缘初禅乃至非想非非想处。生初禅起二禅三禅四禅者现在前。亦缘初禅乃至非想非非想处。若生二禅不入定现在前时。能缘一切法。若入定现在前时。缘二禅乃至非想非非想处。若生二禅起三禅四禅者现在前亦缘二禅乃至非想非非想处。生三禅四禅亦如是。无色中缘一切法无我行。若生欲界。若生色界。若生无色界现在前。缘一切法。如上说。问曰。欲界者缘法多。色界者缘法多。答曰。色界者若不入定。所缘与欲界等。若入定欲界者多非。色界者。所以者何。不自缘定共色故。应作是说。不入定时。无有不缘一切色身念处。无有缘一切受受念处。无有缘一切心心念处。无有缘一切法法念处

问曰。一切法无我行。为是欣尚行。为是厌离行。若是欣尚行者。云何缘苦集。若是厌离行者。云何缘可欣尚法。答曰。应作是说。是欣尚非厌离行。问曰。若是欣尚行者。云何能缘苦集。答曰。虽缘苦集。故是欣尚行。所以者何。设使彼多缘有漏法。少缘无漏法。而于无漏法故是欣尚行。如铜钱[卄/積]上置一金钱。铜钱虽多。得一金钱。犹生欣尚。彼亦如是。问曰。此行为断结不耶。答曰。不断。问曰。若不断结。何用起现在前。答曰。欲令心猛利故。心若猛利。能入圣道

问曰。空行无我行。有何差别。答曰。对治我是无我行。对治我所是空行。复次对治五我见是无我行。对治十五我所见。是空行。复次对治己见。是无我行。对治己所见。是空行。我爱我所爱亦如是。复次阴非是我。是无我行。我不入阴中。是空行。复次见眼无我生悦适。是无我行。见我不入眼中生悦适。是空行。乃至意入亦如是。复次性空义。是无我行。行空义是空行

颇有二心展转相因耶。问曰。何以作此论。答曰。为止外道意故。外道作如是说。后心是前心因。所以者何。如水流时。后水能逼前水驶流。如是法生。未来世法逼驶现在。现在逼驶过去。如是未来法是现在因。现在法是过去因。为断如是意故。明后心非前心因。若当后是前因者。则违内外因缘生法。如世尊说。无明缘行。乃至生缘老死。若后是前因。应当行缘无明。乃至老死缘生。如说眼缘色生眼识。若后为前因。应当缘眼识生色。如父母是儿因。若然者应儿是父母因。违如是等内缘生法。云何与外缘生法相违。如种子为牙因。乃至花为果因。若然者应牙为种子因。乃至果为花因。若后为前因。复有大过。何以故。不作业而受果。已作业而无果故。云何不作业而受果。答曰。如先受善不善果。然后作善不善业。先受律仪不律仪戒果。然后受律仪戒。先受阿毗地狱果。然后作五逆业。先受转轮圣王果。然后修转轮圣王业。先得阿耨多罗三藐三菩提。然后行诸波罗蜜。若尔不作业而受果。已作业应无果。作业而无果。则无解脱出要之道。若后是前因。则有如是大过。复次所以作此论者。如摩诃僧祇部说二心俱生。为止如是意故作此论。复次或有说者。言因缘无体性。今欲分明因缘体性故作此论。颇有二心展转相因耶。答曰。无耶。所以者何。无有一人前后二心俱生。复有说者。言前者诸过去心无二俱生者。言后者诸未来心无二俱生者。是故答言。一人前后二心不俱生。复有说者。言前者除过去世。言后者除未来世。不俱者欲明现在一刹那无二心俱生。若作是说。无有一人前后二心俱生。此则止二心俱生者意。次作是说。非未来心与前心因。此则止后与前作因者意。复有说者。若作是说。无有一人前后二心俱生。此则止相应共有因义。次作是说。非未来心与前心因。此则止相似因一切遍因报因义。此中依五因作论故。答曰。无若依六因作论者。应答言有。以有所作因故。如二心二受二想二思二触二作意二解脱二念二定二眼乃至二身二命根二身种类。如是等则无展转因义

颇有二心展转相缘。乃至广说。问曰。不应先作是论。应先作此论。以何等故。一人前后二心不俱生。然后应次作此问。颇有二心。前后展转相缘。应作是说。而不说者有何意耶。答曰。或有说者。彼作经者意欲尔。乃至广说。复有说者。论有二种。一是根本。二是傍生。诸作是问。颇有二心展转相因。颇有二心展转相缘。此是根本论。以何等故。一人前后二心不俱生。是傍生论。是以先论根本。次问傍生。复有说者。阿毗昙应以相求不以次第。若前若后。俱无有过。但莫违其相。不应责次第。颇有二心展转相缘。问曰。何以作此论。答曰。前说无有二心展转相因。亦谓二心无展转相缘义。欲断如是疑故。而作是论。颇有二心展转相缘耶。复有说者。或有言境界缘无体性。为止彼人如是意欲分明境界缘有实体性故作此论。问曰。颇有二心展转相缘耶。答曰。有。问曰。若答言有。此言便足。所以者何。如说若法是彼境界缘。或时不作境界。无有是事。以何等故复作是说。若生无当来心耶。答曰。不应作是说。所以说者。欲饶益弟子令受义时分明了了故。颇有二心展转相缘耶。答曰。有。若发意思惟无有未来。问曰。其事云何。答曰。邪见生言无未来。次后复生邪见。言无过去邪见。亦言无过去诸法。是名二心展转相缘邪见。次生身见。身见复计过去邪见为我。如身见。边见计断常亦如是。见取计过去胜第一。戒取计净能至解脱计是乘疑犹豫计二里。想受计好妙适意。恚计不好妙不适意。慢计自高自举。无明于彼。愚冥不知。如是等名染污心展转相缘。善心云何。答曰。如正见计过去。是无常苦空。无我因集有缘。是有是性分。是有因是有缘。如是等名善心邪见展转相缘。不隐没无记心云何。答曰。非是巧便。非是不巧便。是名无记心邪见展转相缘。若发意思惟有未来。其事云何。答曰。如正见生言有未来。次后生正见。言有过去。亦言有过去诸法。是名二心展转相缘。身见计过去正见为我。乃至不隐没无记缘过去正见亦如是。若发意思惟无未来道。问曰。何以复作此论。答曰。先说有漏心相缘。今欲说无漏心相缘。问曰。其事云何。答曰。若发意思惟无未来道。此心与邪见相应。缘无未来道。后得正决定。缘过去法。作无常苦空无我因集有缘。此中言后时者。遮一念。遮相续。不限时不限身。不限无始已来。以何等故不限时。答曰。或有初夜谤道中夜得正决定。中夜谤道后夜得正决定。或有后夜谤道昼得正决定。有昼谤道夜得正决定。或有一日一夜谤道。一日一夜得正决定。如是半月一月。一时一岁。乃至一身。当知亦如是。若发意思惟有未来道。此心与正见相应。缘有未来道。次后生无漏道。缘过去正见。是无常苦空无我因集有缘。如是正见。缘未来道。未来道生。还缘正见。是名展转相缘。后时者如说。总相观后。能入圣道者。遮一刹那顷。不限相续。不限时不限身。乃至不限无始生死已来。如说三种正观。后能入圣道。不限一刹那顷。乃至不限无始生死已来。如二知他心智。亦展转相缘。问曰。何以复作此论。答曰。前说己身相缘法。今欲说他身相缘法故。如二知他心展转相缘。问曰。此中为说何等二知他心。答曰。此中说根同。同利根。同中根。同下根。同是初禅地他心智。乃至第四禅地他心智。同有漏。同无漏。同是法智分。同是比智分。问曰。彼云何相缘。答曰。俱缘彼心。不缘彼心所缘。若缘心所缘。是则自缘心。不名缘他心。问曰。此中为说何等知他心智。答曰。此中说得证他心智通者。问曰。亦更有余能知他心智。此中何以不说。答曰。或有说者。彼作经者意欲尔。乃至广说。复有说者。此应说而不说者。当知此义是有余之说。复有说者。此中说名义俱好者。复有说者。若体性是通。若体性是修。若是离欲得。若是四支五支禅果。此中说之。复有说者。若智知他心。如实无谬是中说之。因此事故。扰动智海。如二心展转相缘。诸数法亦如是。亦应分别五识种界善染污不隐没无记威仪工巧。彼五识不能展转相缘。各行境界故。意识能展转相缘。缘一切法故。苦谛所断心。与集谛所断心。能展转相缘。苦谛所断心。与修道所断心。展转相缘。集谛所断心。与修道断心。展转相缘。灭谛所断。有漏缘使展转相缘。亦能缘无漏缘使。无漏缘使不能缘有漏缘使。道谛所断有漏缘使。展转相缘。亦能缘无漏缘使。无漏缘使不能缘有漏缘使。无漏缘使于道展转相缘。修道所断善不善隐没无记。能缘五行所断心。其余修道所断。展转相缘不断心。如苦忍苦智。集忍集智。能缘五行所断心道缘道。随其所应展转相缘。界者欲界色界。展转相缘。欲界不系法展转相缘。欲界无色界无展转相缘。色界无色界及不系心展转相缘。善者能缘三种。善染污不隐没无记。染污能缘三种。善染污不隐没无记。善报无记心缘三种。善染污不隐没无记。不善报无记无展转缘。所以者何。意地无不善报无记。如说颇业身受受报非心耶。答曰。有诸不善业威仪无记心展转相缘。其事云何。答曰。威仪有二种。一是威仪。二是威仪心。威仪者谓色香味触。威仪心者能起威仪心是也。四识是威仪方便。非起威仪心。意识是威仪方便。亦是起威仪心。彼四识能缘威仪。不能缘起威仪心。意识能缘威仪亦能缘起威仪心。复有说者。因威仪心更生意识。能缘十二入。是能展转相缘。工巧无记心展转相缘。其事云何。答曰。工巧有二种。一是工巧。二是工巧心。工巧谓色声香味触。工巧心者能起工巧心者是。五识是工巧方便。非起工巧心。意识是工巧方便。亦是起工巧心。五识能缘工巧。不能缘起工巧心。意识能缘工巧。亦能缘起工巧心。复有说者。因工巧心更生意识。能缘十二入。是能展转相缘邪见。或以因谤果。或以果谤因。或不以果谤因。或不以因谤果。云何以因谤果。如说此善恶业无果报。云何以果谤因。如说是人诸所受报无因无缘。云何不以果谤因。众生烦恼无因无缘。云何不以因谤果。如说无过去未来现在。是名不以因谤果。此邪见苦谛所断。先说二心展转相因。展转相缘者此中说二缘义所谓因缘境界缘。问曰。以何等故。此中不说次第缘威势缘耶。答曰。或有说者。彼作经者意欲尔。乃至广说。复有说者。应说而不说者。当知此是有余之说。复有说者。此义以入彼所说中。其事云何。若说因缘当知已说次第缘。所以者何。如说二心无展转相因。当知二心亦无次第缘。若说境界缘。当知亦说威势缘。所以者何。如说二心展转相缘。当知二心亦展转威势缘。是名已入彼所说中

阿毗昙毗婆沙论卷第五阿毗昙毗婆沙论卷第六

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    杂犍度智品之二

以何等故一人前后二心不俱生。问曰。何以作此论。答曰。此是傍生论。所以者何。前说二心不得展转相因。何以故。无有一人前后二心俱生故。虽有是说未说所以。今欲说之。故作此论。以何等故一人前后二心不俱生者。答无第二次第缘。此说心心数法。依次第缘生未来世法。依现在世法和合则生。不和合则不生现在。若与未来次第则生。不与次第则不生。复有说者。以何等故一人前后二心不俱生。乃至广说。答曰。众生法尔。一一心次第生。不得有二。所以者何。无第二次第缘故。复有说者。此说前如两鞅相系。以何等故无第二次第缘。答曰。众生一一心次第生。不得有二。以何等故。众生一一心次第生不得有二。答曰。无第二次第缘。是名展转更相答义。如现在有一次第缘。未来生一心。是中应说。如园中闭众多羊门侠少。喻如羊园侠小门中一一羊出。彼心心法生亦复如是。现在一刹那与未来刹那开次。设现在世有众多刹那者。则与未来众多刹那开次。以无故现在一刹那与未来一刹那开次。作义者说曰。以何等故二心不俱生。答曰。或有说者。如命根是一刹那。依命根心亦一刹那。是故不俱。复有说者。如身根是一刹那。依身根心亦一刹那。是故不俱。复有说者。若二心俱生。则心不可调伏。如今一心犹刚强难伏。何况二心。复有说者。若二心俱生者。则一时有烦恼出要一心烦恼一心出要。若尔者则无解无离无乘。如是等过。复有说者。若二心俱生何妨有三。若有三者则三界身可一时受。若三界一时受身则破界。若界破一人亦是欲界亦是色界无色界。若然则无解脱。乃至广说。若三心俱生何妨有四。若有四心则可一时受四生身。若然者则坏四生。一身亦是胎生亦是卵生亦是湿生亦是化生。则无解脱。乃至广说。复有说者。若四俱生何妨有五。若有五者则可一时受五道身。若然者则五道坏。若五道坏地狱身乃至即是天身。乃至广说。若五俱生何妨有六。若有者则可一时缘六根义。乃至广说。若不妨六乃至百千未来世中一时俱生。一刹那生一刹那灭。若然则无未来。以有未来则有现在。以有现在则有过去。若无未来则无现在。若无现在则无过去。若无过去则无有为。若无有为则无无为。若无有为无为则无一切诸法。有如是等过。不得二心一时俱生。问曰。如众多数法一时生。无如上等诸过。若当二心如数法一时生者。复有何过。答曰。如一次第缘。与未来一心和合。以一心和合故。众生一一心生。复有说者。如作观。与未来一心和合。以一心和合故众生一一心生。若有二心俱生。应有二受俱生。若有二受则破众生身法。若破众生身法则有二种身。若有二身则有十阴。以有如是过故。二心不得俱生

问曰次第缘体性是何。答曰。如波伽罗那说。除过去现在阿罗汉最后心。诸余过去现在心心数法是也。复有说者。诸过去现在心心数法。是次第缘体性。问曰。若然者阿罗汉最后心。无次第缘义。云何名次第缘耶。答曰。不以阿罗汉最后心过故。余心不生。更有余事故。令后心不生。若当生者。能与次第缘。问曰。次第缘者有何相耶。答曰。所言体性即是其相。所言相者。即是体性一切诸法。不可离体性别立其相。尊者和须蜜说曰。相避义是次第缘。复有说者。发迹相避义是次第缘。复有说者能生心义。是次第缘。复有说者。心相续义是次第缘。复有说者。能取义是次第缘。复有说者。心势用义是次第缘。尊者佛陀提婆说曰。次第生心相是次第缘。复有说者。未生刹那令刹那生是次第缘。阿毗昙人说曰。异相法令俱生是次第缘。复有说者。未生法似自己是次第缘。已说次第缘体相。未说所以。以何等故名次第缘。答曰。等无间义是次第缘。问曰。若然者心与心作次第。不与数法作次第耶。数法与数法作次第。不与心作次第耶。答曰。如说相似法沙门所说。心与心作次第。受与受作次第。如是说者则有过。所以者何。贪欲心还与贪欲心作次第。嗔恚还与嗔恚。愚痴还与愚痴。善还与善。不善还与不善。无记还与无记。如是说者。则无解脱涅槃。如是说者好。所谓心与心作次第。亦与数法作次第。数与数作次第。亦与心作次第。前心聚与后心聚作次第。问曰。若心与心作次第。则相随顺非数法耶。若数法与数法作次第。则相随顺非心耶。答曰。若如说相似法沙门所说。心随顺心。数法随顺数法。评曰。不应作是说。作如是说者好。所谓心与数法作次第。数法与心作次第。前心聚与后心聚作次第。等无差别。犹如豆聚。如波伽罗那所说。若法与彼法作次第。或时不作次第耶。答曰有。若彼法未生。问曰。此说未生为前者耶。为后者耶。为如前法未生后法不名次第。若生是次第耶。复如后法未生。前法不名有次第。若生是有次第耶。如世第一法苦法忍作次第。为如世第一法未生。苦法忍不名次第。若生是次第耶。复如苦法忍未生。世第一法不名有次第。若生是有次第耶。若前法未生。后法不名次第。若生是次第者。有心时可尔。无心时云何可尔。如入无想定灭尽定。若一七若过一七。出定心与入定心名为次第。彼第二刹那心必生。所以者何。若法与彼法。能作次第缘。果无有众生。无有法。无有咒术。无有药草。无有佛。无有辟支佛。无有声闻。能遮此法使第二刹那心令不生者。若然者二定则无体。若当后法未生。前法不名有次第。若生是有次第。若然者则苦法忍未生。世第一法不名有次第。何故说未生耶。或有说者。应作是说。前法未生不名次第。问曰。若然者有心时可尔。无心时云何。答曰。有心时已尔。无心时亦可尔。其事云何。如入无想定灭尽定。彼入定心。定初刹那亦取果亦与果。诸余刹那。及出定心。但名取果。彼入定心。灭在过去。定余刹那。及出定心。其现在者与果。彼不应作是说。所以者何。次第缘义。无有异时取果异时与果。即与果时取果。问曰。若与果时取果。有心时可尔。无心时云何。答曰。如入无想定灭尽定。彼入定心。与定初一刹那。取果与果。彼灭在过去。定余刹那。及出定心。若现在前。取果与果。若作是说。则无异时取果异时与果。问曰。若然者过去法则有所作。答曰。虽过去有所作能取果与果。而无有果。过去世见色乃至知法。无如是作事。与果取果。可有是事。复有说者。后法未生前法不名次第。后法若生则前法名次第。问曰。若然者苦法忍未生。世第一法不名次第耶。答曰。可名次第。不名次第缘。若苦法忍生。是名次第。亦名次第缘。如次第次第缘。次第有次第。相续有相续。依有依。当知亦如是

问曰。未来世中有次第缘不耶。若有者诸法应未来世中已次第住。修正方便。则无有用。所以者何。圣道于未来世。已有次第。时到则生。修正方便。复何所为。复有大过。何以故。无有制伏贪欲生不净观。如是亦不能制伏一切烦恼生对治观。若尔则无解脱涅槃。乃至广说。若无者八分经云何通。如说是人十二劫不堕恶趣。乃至二十劫。云何知三业差别是现法报。是生法报。是后法报。何故一切时世第一法。但生苦法忍。何以不生乃至尽智等诸法。何故金刚喻定但生尽智不生余法。答曰。应作是说。未来世中无次第缘。问曰。若无者则无前说诸过。此八分经云何通。答曰。世尊观过去现在以比相。亦知未来世。其事云何。答曰。世尊观过去世。见彼众生修如是业。尔所劫中不堕恶道。见此众生修如是业。尔所劫中当不堕恶道。见诸众生于过去世修如是业。于现世中受如此报。见诸众生于彼造业若受生报若受后报。见诸众生于此造业若受现报若受生报若受后报。复有说者。众生有相是心不相应行住众生身中。世尊不因禅定神通能知众生身中有此法者。尔所劫中不堕恶道。即见此相。知是众生受现法报。次受生报复受后报。评曰。不应作是说。若作此说。明如来唯有比相智无了达智。应作是说。佛世尊有了达智。能知未来。虽未来法乱无定次第。如来以明净智。能知未来乱法无定次第。知诸众生造如此业。经尔所劫不堕恶道。受于现报。次受生报。复受后报悉实无谬。如算数法知于谷聚明了无谬。何况如来有自然智。问曰。以何等故世第一法次生苦法忍。不生乃至尽智等诸法。答曰。此名数定事相不定。所以者何。苦法忍法。在于六地。未知为是何地。苦法忍三根相应。不知定与何根相应。行于四行。不知定行何行。如住增上忍时。地行根定。刹那不定。所以者何。有多刹那故不知生者。是何刹那。次第缘亦不定。住世第一法时。有五事定地根行次第刹那。是名数定事相不定。复有说者。若法依前法相续生。不必次第缘。犹如外物无次第缘依于前法相续而生。如牙依前种相续得生。乃至果依前花相续而生。内法亦尔。不因次第缘。依于前法相续而生。苦法忍依世第一法故相续而生。余乃至尽智。不依世第一法故。是以不生金刚喻定。亦应如是通。然未来世法属于现在。若于现在和合则生。若不和合不生。世第一法后能生修道。无有是处。以分别故。设当世第一法与修道和合。尔时则生。以不与和合故。是则不生。如是苦法忍。属世第一法故生。余乃至尽智不属故不生。复有说者。未来世中。有次第缘。问曰。若未来世有次第缘。诸法应次第住。答曰。未来世中有次第缘义。无次第住。未来世法应从何次第缘。生者已定。然不次第住。后若生时。从何缘生亦定。次第住亦定。犹如众多比丘。乱住一处。腊数已定行列不定。后次第住时。腊数亦定行列亦定。如是法未生时。应属何缘。生者已定。次第住不定。后若生时。从缘生亦定。次第住亦定。问曰。若然者修正方便。则无有用亦无解脱涅槃。答曰。一心次第略说有二种心当生。所谓善与染污。若修正方便。善心便生染污不生。若行邪方便。染污便生善心不生。如一种子后二种当生。所谓牙与烂坏。若遇生牙因缘则便生牙。若遇烂坏因缘则生烂坏。一心次第生二种心亦复如是。评曰。应作是说。未来世中无次第缘。所以者何。次第缘者是次第住法。未来世中无次第住。次第缘者是不乱法未来法乱。复有说者。若未来世有次第缘者。修善者常应修善。不应作恶。若修恶时。常应作恶。不应修善。今现见提婆达多。本欲修善而后作恶。央掘魔罗气嘘恶人。本欲作恶而后修善。以如是等因缘故。知未来世无次第缘。问曰。以何等故色法无次第缘。答曰。或有说者。若法定有所依。定有所行。定有所缘。故有次第缘。色法无有所依。无所行无所缘。是故无次第缘。复有说者。若法是相应。有所依有所行。有势用有所缘。故有次第缘。色法不相应无依无行。无势用无缘。故无次第缘。复有说者。次第缘者。是次第住法。色非次第住法。或二万劫或四万劫。或六万劫或八万劫断绝者。复有说者。次第缘现在前时不乱。色法现在前时乱。如一时中起。欲色界系色现在前。欲界系不系色现在前。色界系不系色现在前。是故尊者和须蜜说曰。欲界增益色未灭。色界增益色生。尊者佛陀提婆说曰。少色无间生多色。多色无间生少色。彼少色无间生多色者。如空中云少便生多。如小种子生于大树。如小迦罗罗后成大人。多色无间生少色者。如烧大草[卄/積]后生少灰。以少色无间生多色多色无间生少色故。无次第缘。问曰。如心数法少无间生多多无间生少。其事云何。答曰。如无觉无观地次生无觉有观。次生有觉有观。如此名少无间生多。如有觉有观地生无觉有观。次生无觉无观。如此名多无间生少。答曰。不应以地定。应以数法定。若一受次第生二受。若二受次第生一受。有如上过。以不生故无如上过

问曰。以何等故心不相应行。无次第缘。答曰。或有说者。若法定有所依。定有所行。定有所缘。故有次第缘。心不相应行不尔。色法三界系。心不相应行三界系。余如上色法说。问曰。以何等故说无想定灭尽定是心次第。不说无想天。答曰。或有说者。亦应说而不说者。当知此是有余之说。复有说者。若用功难得者说。不用功不难得者不说。复有说者。若是善者说。彼是无记故不说。问曰。以何等故无想定灭尽定。是心次第而非次第缘耶。答曰。或有说者。若法能生心能增益。心能取心是次第缘。彼定生时。住心碍心使心不相续。是以不作次第缘。复有说者。此定断心遮心行处。是不相应无势用法。是以不作次第缘。问曰。入无想定灭尽定。心出定心。是其次第。中间有尔许多相续定。云何是次第。答曰。此中更无余心故。得名次第。犹如有人一在前行一在后来。他人问言彼后来人。与谁共来。其人答言与某甲人次后而来。彼二中间。虽有村落树木畜生等物。更无余人故言次第。如是彼二心中间。虽复旷远更无余心故。得名次第

问曰。诸法是心次第亦是无间耶。答曰。或有是心次第非心无间。有是心无间非心次第。有是心次第亦心无间。有非心次第非心无间。是心次第非心无间者。除定初刹那及余有心法。诸余定及出定心。是谓心次第非心无间。是心无间非心次第者。定初刹那。及余有心法。生住无常。是谓心无间非心次第。是心次第亦心无间者。定初刹那。诸余有心法。是谓心次第亦心无间。非心次第非心无间者。除定初刹那及余有心法生住无常。诸余定刹那及出定心生住无常。是谓非心次第非心无间。问曰。诸是心次第。亦是定无间耶。答曰。应作四句。是心次第非定无间者。谓定初刹那。诸余有心时。是谓心次第非定无间。是定无间非心次第者。除定初刹那及余有心法生住无常。诸余定及出定心生住无常。是谓定无间非心次第。是心次第亦定无间者。除定初刹那及余有心法。诸余定及出定心。是谓心次第亦定无间。非心次第非定无间者。定初刹那生住无常。及余有心生住无常。是谓非心次第非定无间

观有三种。所谓别相观。总相观。虚相观。别相观者观色是色相乃至观识是识相。观地是坚相。乃至观风是动相。是名别相观。总相观者十六圣行观是名总相观。虚相观者不净安般无量除入解脱一切处。是名虚相观。问曰。此三种观。何观次第能入圣道。出圣道时何观最初现在前。答曰。或有说者。入圣道时三种能入。出圣道时三种现在前复有说者。总相观能入圣道出圣道时三种现在前。问曰。若虚想观不入圣道。此经云何通。如说不净观次修念觉意。答曰。此说展转相因。如子孙法。其事云何。答曰。先以不净观。善调伏心。使心止息堪任质直柔软。心得自在。然后总相观现在前能入圣道。复有说者。总相观现在前能入圣道。出圣道时亦总相观而现在前。问曰。若然者若依未至若依初禅。若依中间。得正决定出圣道时。欲界总相观现在前可尔。若依二禅三禅四禅得正决定。彼无欲界总相观。所以者何。以大远故。复更不得总相观除达分善根。所以者何。以圣道后不能复起现在前故。出圣道时。为起何等总相观现在前。答曰。于暖顶忍中间。修总相观。所谓诸行无常苦空无我。涅槃寂静。出圣道时。此观现在前。评曰。不应作是说。如前说者好。欲界有三种观。所谓闻慧思慧生得慧。色界有三种。所谓闻慧修慧生得慧。无色界有二种。修慧生得慧。问曰。欲界有三种观慧。何等慧现在前能入圣道。答曰。欲界思慧观现在前。能入圣道。出圣道时。三种观现在前。色界修慧观现在前。能入圣道。出圣道时二种。闻修慧观现在前。非生得慧。无色界修慧现在前。能入圣道。出圣道时。亦修慧观现在前。非生得慧。问曰。以何等故。出圣道时。欲界生得慧现在前。非色无色界。答曰。欲界生得慧猛利。色无色界不猛利。若依未至禅。得阿罗汉。出圣道时。还起未至地及欲界心。若依无所有处。得阿罗汉。出圣道时。还起无所有处及非想非非想处心。若依余地得阿罗汉。出圣道时即起彼地心

初禅有三种。味净无漏。乃至无所有处亦三种。非想非非想处二种。味净味相应次第生。味相应及净不生。无漏净有三种。无漏二种净及无漏不生味净。初禅有四种。有退分住分胜进分达分。乃至非想非非想处亦有四种。退分次第生退分生住分。不生胜进分不生达分。住分次第生住分生退分生胜进分。不生达分。胜进分次第生胜进分生住分生达分。不生退分。达分次第生达分生胜进分。不生住分退分。复有说者。退分次第生三种。不生达分住分胜进分。尽生四种。达分次第生三种除退分。问曰。若坐二禅三禅四禅地。欲入初禅。识现在前。几种观现在前。答曰。随所住地。未离欲者。三种观现在前。所谓善染污不隐没无记。出时亦三种现在前。若离欲二种。有十二种心。欲界系四种。善不善隐没无记不隐没无记。色界系三种。善隐没无记不隐没无记。无色界系亦三种。学无学心。问曰。欲界系善心次第生。几心复从几心次第生。乃至无学心次第生。几心复从几心生。答曰。欲界系善心。次第生九心。欲界系四。色界系二善隐没无记。无色界系一。隐没无记学无学。亦从八心次第生。欲界系四。色界二。善隐没无记。学无学不善心次第生。欲界四心亦从十心次第生。欲界系四。色界系三。无色界系三。隐没无记心亦如是。欲界系不隐没无记心次第生七心。欲界四。色界二。善隐没无记。无色界一。隐没无记。亦从五心次第生。欲界四。色界一。善心。色界系善心次第生十一心。除无色界系不隐没无记心。余次第能生。亦从九心生。自地三。欲界二。善不隐没无记。无色界二。善隐没无记。学无学心色界系隐没无记心次第生六心。色界系三。欲界三。除不隐没无记心。亦从八心次第生。色界三。欲界二。善不隐没无记。无色界三。色界系不隐没无记心次第生六心。色界三。欲界二。不善隐没无记。无色界一。隐没无记。亦从色界三心次第生。无色界善心次第生九心。无色界三。欲界二。不善隐没无记。色界系二。善隐没无记。学无学心亦从六心次第生。无色界三。色界一。善心。学无学心无色界系隐没无记心次第生七心。无色界三。欲界二。不善隐没无记。色界二。善隐没无记。亦从七心次第生。无色界三。欲界二。善不隐没无记。色界二。善不隐没无记。无色界系不隐没无记心次第生六心。无色界三。欲界二。不善隐没无记。色界一。隐没无记。亦从无色界三心次第生。学心次第生五心。欲界善色界善无色界善学无学心。亦从四心次第生。欲界善色界善无色界善。学心无学心次第生四心。欲界善色界善无色界善无学心。亦从五心生。欲界善色界善无色界善学无学心

  九八四与十　　七五当知欲
  十一九六八　　六三当知色
  九六七亦七　　六三知无色
  五四亦四五　　当知学无学

有二十种心。欲界有八心。方便善心。生得善心。不善心。隐没无记心。威仪心。工巧心。报心。通果心。色界有六心。方便善心。生得善心。隐没无记心。威仪心。报心。通果心。无色界有四心。方便善心。生得善心。隐没无记心。报心。无漏有二心。学心无学心。问曰。欲界方便善心次第生几心。亦从几心次第生。乃至无学心次第生几心。亦从几心生。答曰。欲界方便善心次第生十心。欲界七除通果心。色界一。方便善心。学心无学心。亦从八心次第生。欲界四。方便善生得善不善隐没无记。色界二。方便善隐没无记。学无学。欲界生得善心次第生九心。欲界七。除通果心。色界隐没无记心。无色界隐没无记心。亦从十一心次第生。欲界七。除通果心。色界二。方便善隐没无记。学无学。不善心次第生欲界七心。除通果心。亦从十四心次第生。欲界七。除通果心。色界四。生得善隐没无记威仪报。无色界三。除方便善。隐没无记心亦如是。欲界威仪心次第生八心。欲界六。除方便善通果心。色界一。隐没无记心。无色界一。隐没无记心。亦从七心次第生。欲界七。除通果心。报心亦如是。工巧心次第生六心。除方便善通果心。亦从七心次第生。欲界七。除通果心。欲界通果心次第生二心。欲界通果。色界方便善心。亦从二心次第生。欲界通果。色界方便善心。色界方便善心次第生十二心。色界六。欲界三。方便善生得善通果心。无色界一。方便善。学无学心。亦从十心次第生。色界四。除威仪心报心。欲界二。方便善通果心。无色界二。方便善隐没无记。学无学心。色界生得善次第生八心。色界五。除通果心。欲界二。不善心隐没无记。无色界一。隐没无记心。亦从色界五心次第生。除通果心。色界隐没无记心次第生九心。色界五。除通果心。欲界四。方便善生得善不善隐没无记。亦从十一心次第生。色界五。除通果心。欲界三。生得善威仪报心。无色界三。除方便善。色界威仪心次第生七心。色界四。除方便善通果心。欲界二。不善隐没无记心。无色界一。隐没无记心。亦从五心次第生。色界五。除通果心。报心亦如是。色界通果心次第生色界二。方便善通果心。亦从二心次第生。色界方便善通果心。无色界方便善心次第生七心。无色界四。色界一。方便善学无学心。亦从六心次第生。无色界三。除报心。色界一。方便善。学无学心。无色界生得善次第生七心。无色界四。欲界二。不善隐没无记。色界一。隐没无记心。亦从无色界四心次第生。无色界隐没无记心。次第生八心。无色界四。欲界二不善隐没。无记心色界二方便善隐没无记心。亦从十心次第生。无色界四。欲界三。生得善威仪报心。色界三。生得善威仪报心。无色界报心次第生六心。无色界三。除方便善。欲界二。不善隐没无记心。色界一。隐没无记心。亦从无色界四心次第生。学心次第生六心。欲界二。生得善方便善。色界一。方便善心。无色界一。方便善心。学无学心。亦从四心次第生。欲界一。方便善心。色界一。方便善心。无色界一。方便善心。学心。无学心次第生五心。欲界二。方便善心生得善心。色界一。方便善心。无色界一。方便善心。无学心亦从五心次第生。欲界一。方便善心。色界一。方便善心。无色界一。方便善心。学无学心

  十八次生九　　十一生于七
  十四亦生八　　七六及与七
  二生二欲尽　　十二十八五
  九十一七五　　二二当知色
  七六七四八　　十六四无色
  六四亦五五　　当知学无学

以何等故。如人不可得。乃至广说。问曰。何故作此论。答曰。为止他人意故。或有说者。有人以有人故忆本所作。复有说者。物性相入。相入论者作如是说。一切有为法有二分。若昼若夜。夜时昼入夜中。昼时夜入昼中。所以者何。如夜中所作昼则忆之。以夜入昼中故。如昼中所作夜则忆之。以昼入夜中故。是故忆本所作。或有说者。物性变物。性变论者作如是说。迦罗罗变作阿浮陀。乃至中年变作老年。是故忆本所作。如婆吒树叶青变为黄。彼亦如是。或有说者。物性往来。往来论者作如是说。迦罗罗来至阿浮陀中住故。乃至广说。以是事故忆本所作。问曰。物性变论。往来论有何差别。答曰。物性变论言。迦罗罗变作阿浮陀。往来论言。迦罗罗来至阿浮陀中住。俱增长故。或有说者。觉是一性。后所知觉。即是前所作觉。或有说者。意界是常。以意界常故。忆本所作。或有说者。有根本阴。有客阴。客阴所作。根本阴能知。以是故能忆本所作。或有说者。前心往后心。语后心我作如是事。是故忆本所作。恒河沙数诸佛。及佛弟子。不作此论。言有人不言物性相入。不言物性变。不言物性往来。不言觉性是一。不言意界常。不言有根本阴客阴。不言前心往后心。然能忆本所作。如此事。微细甚深难知。为显如此微细甚深难知法故。而作此论。问曰。以何等故。唯说如人不可得前心不住后心。言我有所作而能忆本所作。答曰。应如是说。以何等故。人不可得。物性不相入。物性不变。物性不往来。觉性不一。意界不常。阴性无根本无客阴。前心不往后心。而能忆本所作。而不说者。欲现始终略其中间。令经文易故。若说如人不可得则止。有人者意前心不往后心则止。往来论者意前心后心则止。其余诸论者意。答曰。众生之法得如是相似习智。问曰。前言无人今何以言众生。答曰。欲令所说与法体相顺故。所以者何。若不言众生但言法。法于义虽顺于文不便。若言众生文义俱顺。以是故说于众生。复有说者。前说实义今说假名众生之法。得如是相似习智。习智者是决定。是修习。是自在义。本所作者。随其本事。本事者。如其性如其体。如其相如其物。复有说者。应言忆本共作。云何共作。如本所见曾所更。复有说者。应言忆本作事。云何本作事。随本形色本所。为欲明忆本所作义故而作此论。喻如能书者。乃至广说。如能书者不至彼能书者所。问言。汝作何字。彼亦不答。我作是字。然能书者。得如此所习智。自所作字亦知。他所作字亦知。乃至海外书来亦能读知。如是前心不往后心。然后心能忆本所作。复欲重明此义故。更作喻。如二知他心展转相缘。此亦不问彼汝思何事。彼亦不答我思此事。乃至百由旬外。二心而能相知。如是前心不至后心。后心而能忆本所念

复次诸心心数法。于所缘定。问曰。为于何法定言定耶。为于眼入定。为于色定。为于刹那定。答曰。或有说者。于眼入定。不于色定刹那定也。所以者何。未生心心数法甚多。云何于眼入定。答曰。如眼识于色定。其余诸识。各于自境界定。若眼与青色和合。则生青识。若与余色和合。则生余识。问曰。若然者便有二心。知青色心。则异知黄色等心。复违识身经文。如说过去眼识。为缘过去法。缘现在法缘未来法耶。答曰。缘过去法。不缘现在未来。复有说者。于眼入定色定。于刹那不定。所以者何。未生心心数法甚多。云何于色定。答曰。若缘青色。则生青识。余则不生。缘黄等色亦复如是。问曰。青色众多。有青茎青枝青叶青花青果。若缘青茎识。云何不耶。即是缘青枝青叶青花青果识耶。评曰。应作是说。于三法定。问曰。若然者未生心心数法则多。答曰。未生法多复有何过。未来世竟无住处耶。先已有住处故。问曰。若心心数法。于缘定于所依亦定耶。答曰。于所依亦定。其事云何。如未来心心数法。于所依则远。若生现在前。与所依则俱。若灭则远所依。复有说者。未生心心数法。于所依远。若现在前则俱。若灭俱灭。问曰。若心心数法。于所缘所依定者。彼于何时。能有所缘。为于生时。为于灭时。若以生时。生时是未来。云何未来能有所作。若以灭时。灭是坏散衰退之法。云何坏散衰退之时能有所缘评曰。应作是说。灭时能缘非是生时。所以者何。未生法是未来。未来法不能有所作。灭时名现在。现在法能有所作。问曰。若然者云何以坏散衰退之法。能有所作。答曰。一切有法皆尔。体性羸劣。属众因缘不得自在。若心心数法。于依所缘和合。能有所缘未来世依及境界散乱。如未来过去亦尔。现在则众缘和合。若当现在。不能缘境界者。则毕竟无缘境界义。问曰。若心心数法。于所缘所依定者。此中何以但说所缘。不说所依。答曰。此中说所念事故。不说所依。若有所念。必依所缘。不用所依。如一境界。则为众多心心数法所缘。如前一心缘已后众多心亦缘。犹如一人而有百子。若一子念父余子亦念。彼一境界。为多心所缘。亦复如是

问曰。若所更事异。所念事异。云何不提婆达多所更。延若达多能忆。若延若达多所更。提婆达多能忆。答曰。提婆达多身异。延若达多身异。忆本所作者身则不异。复有说者。如提婆达多延若达多心不得展转为因。忆本所作前为后因。复有说者。若心相续。若身相续。能忆本所作。提婆达多。延若达多。心不相续。身不相续。问曰。若心相续者。何以先见一牛。后见余牛。言是本牛。答曰。曾所更事。要当相似尔乃识之。先所见牛。虽复曾更。而与后牛不相似故。是以不识。若前牛与后牛相似。尔乃可识。前所更意。必当有力。后不失念。而能忆本所作。先生心聚。以意名说。后生心聚。以念名说。以前意有势力故。令后念忆本所作。不失念者。所谓不狂心不乱。不为苦痛所逼是也

有二种心。一同行心。二同缘心。苦法忍苦比忍苦比智。是名同行心。不名同缘心。集法忍。集法智。是名同缘心不名同行心。苦法智亦名同行心亦名同缘心。其余心亦不同行。亦不同缘。同行心所更事。同缘心能忆。同缘心所更事。同行心能忆。有三种心。善不善无记。若善心所更事。善不善无记心能忆。不善无记心亦如是。复有四种心。善不善隐没无记。不隐没无记。如善心所更事。四种心能忆。乃至不隐没无记心所更事。四种心能忆复有四种心。从因缘生心。从次第缘生心。从境界缘生心。从威势缘生心。若一心曾所更事。四心尽能忆。复有五种心。见苦所断心。乃至修道所断心。若见苦所断心所更事。五种心能忆。见集所断修道所断亦如是。见灭所断心所更事。四种心能忆。除见道所断心。道亦如是。除见灭所断心。复有六种心。所谓六识。若六识所更事。意识能忆。复有十二种心。欲界善心。不善心。隐没无记心。不隐没无记心。色界三种。除不善。无色界亦如是。学心。无学心。如十二种心。有相似十二法十二念。如欲界善心所更法。十二念尽能忆。不善亦如是隐没无记心所更法。有八种念能忆。欲界四。色界善不隐没无记学无学。欲界不隐没无记亦如是。色界善心所更法。十二种念能忆。色界隐没无记心所更法。十种念能忆。除欲界隐没无记不隐没无记。色界不隐没无记心所更法。十种念能忆。除无色界隐没无记不隐没无记。无色界善心所更法。十种念能忆。除欲界隐没无记不隐没无记。无色界隐没无记心所更法。九种念能忆。欲界善不善。色界善隐没无记。无色界三种学无学不隐没无记亦如是。学心所更法。十二种念能忆。无学心亦如是

如经说。尊者舍利弗。作如是言。诸长老。若不坏意。内入照了。外入法能生。正观现在前。则意识生。彼云何坏意入。答曰。坏有三种。所谓须臾坏命终坏究竟坏。须臾坏者。若入无想定灭尽定。是名须臾坏。命终坏者。如断善根坏善意。如凡夫人离欲乃至命终时坏不善意。究竟坏者。如苦比智生苦谛所断意究竟坏。乃至道比智生见谛所断意究竟坏。住不退法。斯陀含见谛所断意。及欲界修道所断六种意究竟坏。住不退法。阿那含一切见谛所断意。欲界修道所断染污意究竟坏。住不退法。阿罗汉一切染污意究竟坏

以何等故所念事忘而复忆。答曰。众生之法心相似次第生知见者。有三种相似。所谓方便相似。境界相似。随顺相似。云何方便相似。如人读修多罗。而后忘失。后勤方便。还复通利。毗尼阿毗昙勤方便亦如是。先修不净观。而后忘失。后勤方便。随其境界。还现在前。安般观界方便亦如是。曾闻有婆罗门子读违陀经。而后忘失。还欲通利。尽其方便。而犹不能。往诣师所而问之言。本所读经今悉忘失。还欲通利。虽勤方便犹故不能。今当云何。其师问言。汝本读时云何而读。弟子答言。初读经时。手则索绳口诵经文。师告之言。当如先法还读诵之。弟子如教后便通利。是名相似方便。云何境界相似。如于此处见河池山林经行住处。后至异处。若见如先事者。还复忆念本所见事。是名境界相似。云何随顺相似。如得随顺饮食方土住处说法同行之人。则能忆本所作。曾闻有一比丘读诵阿含。而后忘失。虽勤方便。犹故不能还得通利。往诣大德阿难所。作如是言。本读阿含而今忘失。虽勤方便。犹故不能还令通利。今当云何。阿难语言。可求多油入浴室中。以用涂身暖水洗浴。加求随顺饮食方土住处说法同行之人。彼如其言。具诸方便即还通利。是名随顺相似。云何次第。彼相续不断是名次第。复有说者。次第者。不相续心还令相续。无能遮止。不为对治所坏。亦所更意力强。而不失念者。前生心聚。以意名说。后生心聚。以念名说。前心有力故。能令后心忆本所作不失念者。不狂不心乱。不为苦痛所逼。尊者和须蜜说曰。以三事故所念事忘而复忆。一者善取前相。二者有相似方便。三者不失念

以何等故。先所念事忘而不忆。答曰。众生之法心不相似次第生心知见者。有三种不相似。所谓方便不相似。境界不相似。随顺不相似。云何方便不相似。如人读修多罗而后忘失。复读毗尼阿毗昙亦复忘失。先修不净观。后复忘失。复修安般观界方便。亦复忘失。是名方便不相似。云何境界不相似。本曾见河池山林经行住处如是等事。后至异处。不见如是等事。于前所见更不复忆。是名境界不相似。云何随顺不相似。若不得随顺饮食方土住处同行之人。于前所作永不复忆。是名随顺不相似。不次第者。不相续断绝。是名不次第。亦所更意力弱。而失所念者。彼前生心聚。以意名说。后生心聚。以念名说。前心弱故不能令后心忆本所作。失念者若狂心乱为苦所逼。尊者和须蜜说曰。以三事故。前所念事。忘而不忆。一者不善取前相。二者无相似方便。三者失所念

问曰。色界修慧。亦有忘而不忆耶。答曰。亦有以身羸弱故。心亦羸弱。心羸弱故。所念事忘而不忆。谁有此忘而不忆耶。答曰。圣人凡夫俱有。圣人者须陀洹斯陀含阿那含阿罗汉辟支佛。亦于所念事忘而不忆。唯有如来。忆而不忘。何以知之。如经说。佛告舍利弗。假使诸比丘众。于百年中。若以坐床卧床。舆我而行。若当如来无上智辩。而有退失。无有是处。如持四弓喻。乃至广说。以是事故。知如来无忘

阿毗昙毗婆沙论卷第六阿毗昙毗婆沙论卷第七

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    杂揵度智品之三

何故祭祀饿鬼则到。乃至广说。问曰。何故作此论。答曰。欲解佛经故。如经说生闻婆罗门。往至佛所。问佛言。沙门瞿昙。我有亲里命过。欲施其揣食。为得食不。佛告婆罗门。此事不定。所以者何。有五道生处。地狱乃至天道。婆罗门若汝亲里。生地狱中。即食地狱中食。以自存活。彼云何能受汝所施揣食。生畜生人天中。亦复如是。婆罗门言。沙门瞿昙。若我亲里。不生饿鬼中者。所施揣食。谁当受之。佛语婆罗门。欲令饿鬼道中无汝亲里者。无有是处。彼经虽说施与饿鬼则到未说所以。今者欲说祭祀饿鬼则到。非余处故而作此论。彼佛经。是此论根本因缘。诸经中未说者今尽说之

以何等故。祭祀饿鬼则到。问曰。为以此道高胜故到。为以下贱故到。若以此道是下贱者。地狱畜生是则下贱。若以此道是高胜者。人天则胜。答曰。应作是说。不以胜到。亦不以贱到。云何能到。答曰。此道自尔乃至广说。有二事故。祭祀饿鬼则到。一者是业。二者此道自尔。先已说之。犹鸿雁孔雀鹦鹉舍利瞿翅罗共命等诸鸟。而能飞行乃至广说。然神不胜人。势不胜人。随其所欲。而能飞行。于虚空中。久住游戏。然人欲住虚空。去地四指经须臾间。犹无能者。如彼众鸟而能飞行。生处自尔此饿鬼道。祭祀则到。生处亦尔。亦如一地狱道中。或有能自识宿命者。如经说地狱众生作如是念。诸沙门婆罗门。恒如是说。贪欲是将来过患可畏之处。是以当断贪欲。我等以不能断贪欲因缘故。今受极剧苦痛极恼。问曰。彼作如是念时。为初生时为中时为后时耶。答曰。初生时非中后时。所以者何。初生之时。未受苦痛。若受苦痛。次前灭事。尚不能忆。况复久远。问曰。为住何心作如是念。善耶不善无记耶。答曰。住三种心。能作是念。为是意地。为五识身。答曰。意地非五识身。为是威仪为是工巧。为是报心。答曰。是威仪。非是工巧报心。所以者何。彼处无有工巧。以报心是五识地故。为念几世耶。答曰。一世。于彼处死。来生此间。或有说者。亦能忆念多世。评曰。不应作是说。如先说者好。亦能知他心者。其事云何。答曰。若狱卒杻械种种杀害之器。在前而立。作如是念。彼狱卒意今欲杀我。评曰。不应作是说。若然者人亦能知。可名他心智耶。如是说者好。彼有生处得智。能知此事。为初知为中知为后知耶。答曰。应如前广说。畜生中亦有能自识宿命者。如经中说。伤佉。汝若是我父都提耶者。可升此坐。即便升之。复作是言。汝若是我父都提耶者可食此粳米肉饭。即便食之。复作是言。汝若是我父都提耶者。可示我所宝藏物。即便示之。问曰。作如是念时。为是初为中后耶。答曰。三时俱能。为住何心。答曰。住善不善无记心中悉能。威仪工巧报心亦能。能知几世耶。答曰。或有说者。能知一世。死彼生此处。或有说者能知多世。何以知之。曾闻有一女人。置其婴儿。在于一处。有因缘故。余行不在。时有一狼檐其儿去。时人捕搊而语之言。汝今何故檐他儿去。狼答之言。此小儿母是我等怨家。时人问言。有何怨耶。狼即答言。此小儿母。五百世中常食我儿。我亦五百世中常杀其子。若彼能舍旧怨之心。我亦能舍。时人语其儿母。可舍怨心。儿母答言。我今已舍。时狼观儿母心。虽口言舍。而心不放。即便害其儿命而去。如此者能知他心。亦识宿命。何时知耶。答曰。初中后悉知。住何心知。答曰。善不善无记悉知。意地知非五识身。威仪工巧报心亦能知。彼经文虽不说。而饿鬼道亦有此智。何以知之。曾闻有一女人。为饿鬼所持。即以咒术而问鬼言。何以恼他女人。鬼答之言。此女人者。是我怨家。五百世中。而常杀我。我亦五百世中。断其命根。若彼能舍旧怨之心。我亦能舍。尔时女人。作如是言。我今已舍怨心。鬼观女人。虽口言舍而心不放。鬼即断其命根。舍之而去。为何时知耶。答曰。广说如上。诸天道亦有此生处得智。而无现事可说。为何时知耶。答曰。广说如上。人道中无如此生得智。问曰。何以故无。答曰。非器非田故。复次人中有瞻相智。有睹言相智。彼生得智。为如此智所覆蔽故。复次人中虽无此生得智。而有胜妙者。所谓他心智愿智。问曰。为知几心。答曰。或有说者。地狱还知地狱心。畜生还知畜生心。饿鬼还知饿鬼心。复有说者。地狱还知地狱心。畜生还知畜生心。亦知地狱心。饿鬼还知饿鬼心。亦知地狱畜生心。天尽知五道心。问曰。若畜生不知天心者。施设世界经云何通。如说善住龙王。伊罗拔那龙王。知帝释心所念。犹如猛健丈夫屈伸臂顷。于自住处没。在帝释前立。答曰。此是比智。何以知之。诸天若欲出军斗战之时。善住龙王脊背诸骨。自然出声。彼作是念。今我脊背声出。定知诸天必与阿修罗共战。诸天若欲游戏之时。伊罗拔那龙王背上自然有香手像现。彼作是念。我今背上。有香手像现。定知诸天欲游戏园林。饿鬼亦有生得智。能识宿命。如偈说

  我本求财物　　如法或非法
  他人得其乐　　今我受苦恼

问曰。为何时知。答曰。广说如上。诸天亦有生得智。能自识宿命。如偈说

  我今祇洹林　　恒住诸圣众
  法王亦在中　　今我心欢喜

问曰。为何时知。答曰。广说如上。问曰。以何等故人无生得智自识宿命。答曰。非其器。广说如上。复次为余法所覆蔽。如性自念前生智。复次人中虽无生得智。自识宿命通。而有胜妙者。所谓宿命通愿智彼亦能。雷电兴风降雨者。唯畜生能非余。畜生道中。唯龙能非余。彼畜生中。能兴风降雨。近者是其功用果。所住之处。远边外出者。是其威势果。问曰。为一龙能作如是等事不耶。答曰能作。问曰。若然者。经何以说异耶。如说或有天能雨。或有天能风。乃至广说。答曰。随其所乐故。或有乐为雨者乐为风者。乃至广说。以所乐不同。经说有异。如此等自尔。所欲便果。彼饿鬼道自尔。施其揣食则到。复有说者。五道生处。各有自尔之法。如地狱报色断便还续。生处自尔。畜生中能飞虚空。饿鬼施揣食则到。人中有勇健念力梵行勇健者。不见果而广能修因念力者。久远所作。久远所说。而能忆念梵行者。能得解脱分达分善根得正决定。天中有自然随意所须之物。如是等诸道。各有生处自尔之法。复有说者。方土亦有生处自尔之法。如罽宾土秋时牛咽系郁金花鬘。余方贵胜。所不能得。如那伽罗国。凡人饮蒲桃酒。东方贵人所不能得。如东方贵胜衣绢凡人衣[疊*毛]。如北方人贵胜衣[疊*毛]凡人衣绢。如诸道诸方各有生处自尔之法。随意能果。彼饿鬼亦尔。施其揣食。随意能果

复次有人长夜有如是欲。有如是念。乃至广说。彼人长夜有如是欲如是念。所念便果。犹如边僻聚落中人。为富名故守护家财。多畜牛羊衣服谷米及诸生业之具。为名誉故不施与人。以不施与人故。身坏命终堕饿鬼中。复有说者。有人性亲爱眷属欲饶益之。为眷属故。如法或不如法求财。及其得时。以悭惜故。于己眷属尚无心与。况复余人。以无施心故。身坏命终堕饿鬼中。若在本舍边不净粪秽厕溷中住。诸亲里等。生苦恼心。作如是念。彼积聚财物自不受用。又不能施人。以苦恼心故。欲施其食。请诸眷属亲友知识沙门婆罗门。施其饮食。尔时饿鬼亲自见之。于眷属财物生己有想。作如是念。如此财物。我所积聚。今施与人心大欢喜。于福田所生信敬心。即时增长舍相应思。以如此业。能得现报。是故施其揣食则到。复有说者。过去世时作如是业。施与则到。其事云何。尊者和须蜜答曰。彼诸饿鬼。以悭惜故有颠倒想有颠倒见。以有颠倒想见故。河见非河。水见非水。于好饮食。见是不净。彼诸亲里。为于此人修布施时。能生信心。则除颠倒。见河是河见水是水见食是食。复有说者。饿鬼有二种。一者乐净。二者乐不净。彼乐净者。以悭惜故。于河等颠倒想。如先说。乐不净者。见河则干。于满器饮食。见其中空。若诸亲里。为其人故。修布施时。其鬼见已。于所施物及福田所。生欢喜心。即能增长舍相应思。以是业故。除颠倒想。乐净者。于河见河。见水是水。器中饮食。见是净食。乐不净者。见水满河。于空器中。见食满器。以是事故。作如是说。施与饿鬼揣食则到。复有说者。彼饿鬼前世有少善行。于诸饮食。不生倒想。以悭惜故。身心怯弱。以怯弱故。不能往诣诸饿鬼中有威德者所。或有因缘。往诣其所。心不喜乐。所以者何。以自身卑贱故。彼威德饿鬼。以福德因缘。有种种饮食。此鬼身心怯弱故。不敢食之。若诸亲里。为其人故。修布施时。其鬼见已。于所施物及福田所。生欢喜心。以此信乐心故。便得胜身心。以得胜身心故。而能往诣诸饿鬼中有威德者所。生喜心乐心。所得饮食。尽能食之。以是事故。施于饿鬼揣食则到。尊者佛陀提婆说曰。不应他作他受。但以彼诸亲里为其鬼故修行布施。其鬼若于福田财物。生信敬心。于此果报。亦有其分。以是事故。施与饿鬼揣食则到。非余道也。问曰。为饿鬼作福。为唯得饮食。亦增益其身耶。答曰。亦得饮食。亦增益身。得饮食如先所说。云何增益其身。其身臭者得香。恶色得好。粗触得细。无威德身。得威德身。问曰。余道中亦能得此果报不耶。答曰。若能生信心则得。不能生者则不得。问曰。若诸道中。皆得如是等事。此中何以独说饿鬼道。不说余道。答曰。以诸饿鬼为饥渴故。常有悕望饮食之心。以自存活。余道不必有如是心。是故不说。复有说者。以饿鬼道中常有求心期心。是故施之则到。有五趣所谓地狱畜生饿鬼人天。问曰。五趣体性。为是不隐没无记为是三种。若是无记者。波伽罗那说云何通。如说趣性是一切使所使。若有三种。则坏诸趣体。云何坏趣体。答曰。地狱众生。则应成就他化自在天烦恼业。及善他化自在天亦成就地狱众生烦恼业及不善。应作此说。趣体性是不隐没无记。问曰。若然者。波伽罗那说云何通。答曰。彼应作如是说。地狱畜生饿鬼人趣体性。是欲界一切遍使。及思惟所断。诸使所使。天趣体性。是三界一切遍使。及思惟所断。诸使所使。应如是说。而不说者有何意耶。答曰。彼诵者错谬故作如是说。复有说者。和合诸趣心。是五行所断。是以一切使所使。复有说者。趣体性有三种。问曰。若然者。云何不坏趣体性。答曰。若已成就言之则坏。若以现在行言之则不坏。云何现在行言之则不坏。答曰。如地狱畜生饿鬼成就他化自在天烦恼业及善。而不现前行。如他化自在天成就地狱饿鬼畜生烦恼业及不善。而不现在行。评曰。应作是说。地狱体性。是不隐没无记。何以知之。如尊者舍利弗作如是言。诸长老。若地狱漏现在前。造作地狱苦痛身口意业。所谓身口意曲浊秽果报。生地狱中。生已受彼报。色乃至识。是名地狱趣。诸长老。除此五阴。更无有法名地狱趣。以是事故。知趣体性是不隐没无记。然以报故五趣差别。此是趣性。今当说趣。所以者何。故名为趣。答曰。趣彼生处。趣彼生相续。是名为趣

已说诸趣总相。一一相今当说。云何名地狱趣。答曰。是地狱分。与地狱众生为伴。受地狱身处。所得体性。得诸入。得生彼处。得不隐没无记色受想行识。是名地狱趣。以何等故。名泥梨迦。泥犁迦秦言无有。所以者何。彼中无有喜乐。无气味无欢喜无利无喜无乐无喜乐。故言无有。复有说者。作增上身口意恶行。故生彼处。彼处生相续。是名地狱趣。复有说者。地狱趣者。是名施设。是想施设。不必如名悉有其义。复有说者。是趣卑下。于五道中更无卑下。如地狱趣。故名卑下。复有说者是趣堕落。如偈说

  诸堕地狱者　　其身尽倒悬
  坐诽谤贤圣　　及诸净行者
  诸根皆毁坏　　如彼燋烂鱼

复有说者。泥犁迦。秦言无去处。所以者何。生彼众生。无有去处。无有依处。无有救处。故名无去处。复以何故名阿毗至。阿毗至秦言无间。亦名淳受苦痛。亦名百钉钉身。亦名六苦触。复有说者。众生生彼者。多无处容受。故言无间。不应作是说。所以者何。生余地狱者多。生阿毗至者少。何以知之。作增上身口意恶业。生阿毗至中众生少。有作增上身口意恶业者。如众生少。作增上善行。生有顶中。彼亦如是。复有说者。无有暂乐故名无间。问曰。若然者。余大地狱中。有意乐为乐受间耶。答曰。虽无意乐。乐受有二种。一者依二者报。一切地狱。无报乐受而有依乐受。阿毗至中。依乐受亦无。何以知余大地狱中有依乐受。如施设世界经中说。唱活地狱中。有泠风来。吹众生身。还生血肉。或作是唱。诸众生活。诸众生活。尔时众生即便还活。以是事故。知余地狱有依乐受。阿毗至中无如是事。故无依乐受。复有说者。生阿毗至中众生其身虽大。受苦痛时无有间处。故名无间。问曰。地狱为在何处。答曰。或有说者。阎浮提下四万由旬。有阿毗至地狱。问曰。其余诸狱。为在上下耶。为在傍边耶。答曰。或有说者。阿毗至狱。在于中央。其余诸狱周回四边。如今城在其中村落围绕问曰。此阎浮提纵广七千由旬。下诸地狱各各广大。如偈说

  火焰遍满多由旬　　见者恐怖身毛竖
  诸恶众生常然之　　其焰炽盛不可近

如是地狱一一广大。云何可受。答曰。此大地形。下广上狭。其犹垛谷在地。是故经说大海渐广转深。复有说者。阿毗至狱最在其下。次上有火炙地狱。次炙地狱。次大叫唤地狱。次叫唤地狱。次押地狱。次黑绳地狱。次唱活地狱。彼阿毗至狱。纵广高下二万由旬。周匝八万由旬。其余诸狱。纵广万九千由旬。或有说者。其余诸狱纵广万由旬。复有说者。阎浮提下四万由旬。有阿毗至狱。阿毗至狱。纵广高下二万由旬。周回八万由旬。火炙地狱。纵广高下五千由旬。乃至唱活地狱。各各五千由旬。如是七地狱。合三万五千由旬。余五千由旬。千由旬青色地。千由旬黄色地。千由旬赤色地。千由旬白色地。五百由旬是白墡。五百由旬是泥。一一地狱。有十六眷属。云何十六。答曰。一一地狱各有四门。一一门各有四眷属。一名热沙上下没膝地狱。二名恶虫沸屎地狱。有刀道地狱。有雨刀叶地狱。有刀林地狱。如是三种。是第三眷属。第四名热灰河地狱。如是门门。各有四种眷属。阿毗至狱。通己身及眷属。合有十七。余七地狱亦尔。都合有一百三十六。诸眷属地狱中。以种种苦治罪人。正地狱中。以一种苦治罪人。阎浮提下。亦有正地狱。阎浮提地上。唯有边地狱。或在山上。或在谷中。或在旷野。或在空中。弗婆提瞿陀尼。唯有边地狱。无正地狱。郁单越。无正地狱。亦无边地狱。所以者何。彼是净果报。问曰。以何等故。阎浮提下。有正地狱。余处则无。答曰。阎浮提人。修善猛利。作不善业。亦复猛利。是故阎浮提。有正地狱。余处则无。问曰。如余方亦作五无间诸余重业。为于何处受其报耶。答曰。于此阎浮提下受。问曰。诸地狱卒。为是众生。为非众生耶。若是众生者。多作不善业。当于何处复受此报。若非众生者。昙摩须菩提所说偈。复云何通。如说

  刚强嗔恚人　　常乐作诸恶
  见他苦生喜　　死作阎罗卒

答曰。或有说者。是众生数。问曰。若然者。多作不善业。当于何处复受此报。答曰。即于彼处受报。所以者何。作无间业断善根。增上邪见者。犹于如受报。况地狱卒。复有说者。非众生数。以诸众生罪业因缘故。实非众生。作众生像。而现其前。以种种事。治诸罪人。问曰。若然者。昙摩须菩提偈云何通。答曰。此造文颂不必须通。所以者何。造文颂。有增有减。有得有失。若欲通者。其事云何。答曰。诸以铁锁系缚众生。诣阎罗王所。是众生数。余种种治诸罪人者非众生数。如是说者好。地狱众生其形云何。答曰。其形如人。言语云何。答曰。初生未受苦痛时。尽作圣语。后受苦痛时。虽出苦痛声。乃至无有一言可分别者。但有打棒坏裂之声

云何名畜生趣。答曰。是畜生趣分。与畜生为伴。乃至广说。以何等故。名畜生趣。答曰。其形傍故行亦傍。其行傍故形亦傍。故名畜生趣。复有说者。作身口意过行。生彼道中。故名畜生趣。复有说者。畜生者名施设想。施设不必如名尽有其义。复有说者。遍有故名畜生趣。此遍五道中。地狱中有无足者。如能究陀。有二足者。如乌鸠罗那等。有四足者。如狗等。有多足者。如百足等。饿鬼中亦有无足者。如蛇等。有二足者。如乌鸠罗那等。有四足者。有威德者。则有象马等。无威德者。唯有狗等。有多足者。如百足等。人中亦有无足者。如腹行虫等。有二足者。如鸿雁等。有四足者。如象马等。有多足者。如百足等。天中四天王三十三天。有二足者。如雁孔雀等。有四足者。如象马等。自上有二足者。如雁孔雀鸟等。问曰。闻自上诸天。亦乘象马。今言无者。其事云何。答曰。彼众生福业因缘故。作非众生数象马形。以自娱乐。复有说者。以盲冥故。名为畜生。盲冥者。谓无明也。五道之中。无明多者。莫若畜生。问曰。畜生住处正在何所。答曰。根本住处在大海中。诸渚亦有。其形云何。答曰。其形傍侧。亦有形上向者。如毗舍遮。如伊卢萨迦。如闇卢破鞠罗紧那罗等。言语云何。答曰。世界初成时。一切众生。尽作圣语。后以饮食过患。时世转恶。谄曲心多。便有种种语。乃至有不能言者。云何名饿鬼趣。答曰。是饿鬼分。乃至广说。以何等故。名卑帝梨。卑帝梨。秦言祖父。或有众生。最初生彼道中。名为祖父。后诸众生生彼处。生彼相续者。亦名祖父。是故此趣名为祖父。复有说者。众生长夜。修行广布悭贪之心。生彼趣中。故名饿鬼。复有说者。此是名施设。乃至广说。复有说者。多饥渴故。名曰饿鬼。彼诸众生其腹如山。咽如针孔。于百千岁不闻水声。亦不曾见。何况得触。复有说者。被驱使故名曰饿鬼。彼恒为诸天。处处驱使。是故此趣名曰驱使。复有说者。常于他人有悕望故。名曰饿鬼。以如是等缘故。此趣名饿鬼。问曰。此趣住在何处。答曰。或有说者。阎浮提下五百由旬。有阎罗王住处。是根本住处。其余诸渚亦有。住阎浮提渚者有二种。一有威德。二无威德。有威德者。住花林果林种种树下好山林中。亦有宫殿在虚空中者。无威德者。住不净粪秽屎尿之中。弗婆提瞿陀尼。亦有二种。有威德者。无威德者。郁单越唯有威德者。所以者何。彼地清净果报处。四天王三十三天。唯有威德者。复有说者。阎浮提西。有五百渚。两渚中间。有五百饿鬼城。其二百五十。有威德者住。其二百五十。无威德者住。是故尼弥转轮圣王。告御者摩多罗曰。我欲升天。汝可从是道去。使吾见诸众生受恶。报者受善报者。尔时摩多罗御者。即如王教。从诸城过。尔时彼王。罪福俱见。有威德者。如诸天子。头戴天冠。身着天衣。食甘美饮食。各各游戏。而自娱乐。无威德者。裸形无衣。以发自覆。手执瓦器。行乞自活。其形云何。答曰。有上立者。有傍侧者。或面似猪。如壁上画像。言语云何。答曰。世界初成。一切众生。尽作圣语。余如先说。复有说者。随其死处。往生彼间。如彼本形。随彼本语。评曰。不应作是说。所以者何。若从无色界死。来生此趣。可无形无言耶。应作是说。随彼生处。形言亦尔

人趣云何。答曰。是人分。是人伴侣。乃至广说。以何等故。名摩[少/兔]奢。摩[少/兔]奢。秦言意。昔有王名顶生。化四天下。告诸众生。诸有所作意。当善思。当善筹量。当善忆念。时诸众生即如王教。诸有所作。思量忆念。然后便自有工巧作业种种差别。以人所作先意思故。是故名人。为意如人。先未有此名时。展转相呼多罗裳伽。亦呼阿婆达荼。复有说者。以修下身口意善业。生彼趣中。故名人趣。复有说者。是名施设。广说如上。复有说者。慢偏多故。五道之中慢心多者。莫若于人。是故此趣名为人趣。复有说者。此趣能止息意故五道之中能止息意。莫若人趣。所以者何。人能得解脱分善根达分善根。能亲近善知识等四法。亦能修行亲近善知识等四法。是故此趣名人。问曰。为住何处。答曰。住四天下。亦住八大渚上。所谓一名拘罗婆。二名乔罗婆。三名毗地呵。四名苏毗地呵。五者奢吒。六名郁多罗曼提那。七名婆罗。八名遮摩罗。彼拘罗婆乔罗婆二渚。是郁单越眷属。毗地呵苏毗地呵二渚。是弗婆提。眷属奢吒郁多罗曼提那二渚。是瞿陀尼眷属。婆罗遮摩罗二渚。是阎浮提眷属。复有说者。此二渚是阎浮提。别名三天下。二渚亦如是。复有说者。此诸渚上。尽有人住。但其形短小。此一一渚。有五百小渚以为眷属。或有人住。或无人住。问曰。人形云何。答曰。其形上立言语云何。答曰。世界初成时。尽作圣语。余如上说。云何天趣。答曰。天分天伴侣。得天身。乃至广说。以何等故名天趣。答曰。诸趣中胜故。有何等胜。所谓有胜乐胜吉善胜身胜形体胜。有如是胜故名曰天趣。复有说者。行增上身口意善业。生彼趣中故名天趣。复有说者。此名施设。广说如上。复有说者。诸天无昼夜。常以光明自照故名天趣。复有说者。以善行因缘故。生彼天趣中。常自游戏娱乐故名天趣。为住何处。答曰。住须弥山侧。四边水上。绕须弥山。广万六千由旬。有杵手天住处。次上万由旬。绕须弥山。广八千由旬。是持花鬘天所住之处。次上万由旬。绕须弥山。广四千由旬。是常放逸天所住之处。次上二万由旬。绕须弥山。广二千由旬。是四天王所住之处。有七种金山。四天王城天民村落悉在其中。此处诸天于下最多。次上四万由旬。须弥山顶有善见城。纵广万由旬。是三十三天所住之处。须弥山顶纵广几何。答曰。周匝四万由旬。离须弥山顶四万由旬。中间如云。有焰摩诸天。依地而住。如是次第。上至善见诸天。皆依地住。从善见天。上至阿迦贰吒天。亦依地住

齐量云何。如须弥山顶量。上至他化自在天。量亦如是。如四天下齐量。初禅地齐量亦如是。如千世界齐量。第二禅地齐量亦如是。如二千世界齐量。第三禅地齐量亦如是。如三千大千世界齐量。第四禅地齐量亦如是。复有说者。如须弥山顶齐量。焰摩诸天齐量。转大一倍。如是乃至他化自在天。转大一倍亦尔。如千世界齐量。初禅齐量亦尔。如二千世界齐量。第二禅齐量亦尔。如三千大千世界齐量。第三禅齐量亦尔。第四禅地齐量。则无量无边。是故于第四禅地。起我见者。是见难断难舍。复有说者。第四禅地齐量不定。若诸天子。生彼禅中。则有尔许宫殿处所。若其命终处所便灭。是故不定。评曰。如前说者好。彼地无量无边。问曰。彼第四禅地。三灾所不及。云何非是常耶。答曰非常。堕诸刹那故。诸天其形云何。答曰。其形上立。言语云何。答曰。尽作圣语。已说诸趣种种所以。今当复说阿修罗所以。何故名阿修罗。答曰。修罗是天。彼非天故名阿修罗。复有说者。修罗言端政。彼非端政故。名阿修罗。何以知之。世界初成时。诸阿修罗。先住须弥山顶。后光音诸天。命终生须弥山顶上。亦有宫殿自然而出。诸阿修罗。兴大嗔恚。即便避之。如是有第二天宫。展转乃至三十三天。悉满其上。诸阿修罗。生大嗔恚。舍须弥山顶。退下而住。以嗔恚故。形不端政。以是事故。名不端政。问曰为住何处。答曰。或有说者。须弥山中。有空缺处。犹覆宝器。中有大城。诸阿修罗。在中而住。问曰。若然者。诸龙见阿修罗军。着金银琉璃颇梨铠。手执弓箭种种器杖。从阿修罗城出。此言善通。如说阿修罗言我所住大海同一碱味。此说云何通。答曰。诸阿修罗。村落人民。居在大海。阿修罗王。住须弥山中。复有说者。阿修罗居大海水。以金为地。地上有金台。纵广五百由旬。其上有城。诸阿修罗在中而住。问曰。若然者。此经善通。如说诸阿修罗言我住大海同一碱味。此言善通。如说诸阿修罗军从城而出。乃至广说。此云何通。答曰。诸天以龙在金山中。用为守逻。是以见之。阿修罗城中。有四种园观。一名欢喜。二名喜乐。三名大喜乐。四名爱乐。亦有质多罗波吒梨树。问曰。阿修罗为天趣所摄。为饿鬼趣摄。若是天趣。何以无有得正决定者。若是饿鬼趣者。何以乃与诸天交亲。何以复与诸天战斗。此经复云何通。如说帝释作如是说。毗摩质多罗王。汝本是此处天。答曰。或有说者。此是天趣所摄。问曰。若然者。何以无有得正决定者。答曰。为谄曲所覆故。其事云何。答曰。彼阿修罗作如是念。佛偏为诸天。若佛为说四念处。彼作是念。为我等说四念处。必为诸天说五念处。若佛为说三十七助道法。彼作是念。佛为我等说三十七助道法。必为诸天说三十八助道法。以为如是谄曲心所覆故。不能得正决定。复有说者。是饿鬼趣所摄。问曰。若然者。何以与诸天交亲。答曰。诸天贪美色故。不为族姓。如舍芝阿修罗女。端政无双。是以帝释纳之为妻。亦如头摩紧那罗王女。名曰摩[少/兔]诃利。须陀那菩萨纳之为妻。菩萨是天趣。紧那罗是畜生趣。如此皆为美色。不为族姓。以何等故。复与诸天共战斗耶。答曰亦有。不如与胜者共斗。如奴仆亦与其主。而共斗诤。狗亦与人诤。彼亦如是。此经复云何通。如说毗摩质多罗王。汝本是此处天。答曰。毗摩质多罗王。是帝释妇公。以尊重恭敬故。作如是言

问曰。如拔陀那神女旃陀迦神女旃陀利迦神女伊吒地婆神摩头建陀神等。为是天趣所摄。为饿鬼趣所摄。若是天趣所摄。何以夺人精气。亦断人命。受人祠祀。若是饿鬼趣所摄者。此经云何通。如偈说

  郁多利莫闹　　毕陵伽亦然
  若我见真谛　　汝等亦当得

答曰。或有说者。是天趣所摄。问曰。若然者。何以夺人精气。亦断人命。受人祠祀。答曰。彼不夺人精气。亦不断人命。不受人祠祀。彼所将眷属。或有夺人精气者断人命者受人祠祀者。复有说者。是饿鬼趣所摄。问曰。若然者如所说偈。云何通耶。答曰。彼有信向谛心故。实不见谛。于谛中愚。何由能见。如摩头建陀神所说云何通。答曰。此是自高之言。于诸趣中愚。何能见趣差别。但自高故作如是说。如今富者。于奴仆边。亦自称高。彼亦如是。是四天王给使。自言我是天生四天王天中。诸依地住神。彼尽饿鬼趣所摄。诸毗舍遮神。紧那罗神。醯楼索迦神。婆楼尼神。奢罗破仇罗神。尽畜生趣所摄。彼虽其形上立。犹有畜生相。或有耳尖。或有着甲。诸夜叉罗刹竭吒富单那鸠槃茶等。尽是饿鬼趣所摄。如说是地狱分是地狱伴侣。命根等心不相应行。此说是地狱众生。或有说者。不应作是说言。是处所得体性得诸入得。应言是地狱分地狱伴侣。复有说者。应说所以者何。说处所得者诸界得。体性得者诸阴得。诸入得者说内外入得。问曰。若说界阴入得便足。何以复作是说生。地狱众生。得无记色乃至识。答曰。为说报果故。以报果故。五道差别

阿毗昙毗婆沙论卷第七阿毗昙毗婆沙论卷第八

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    杂犍度智品之四

当言一眼见色。乃至广说。问曰。何以作此论。答曰。为止并义者意故。如尊者昙摩多罗说。眼不见色识见色为止如是意故。言眼见非识见。如犊子部说一眼见色。非二眼一时见。所以者何。以相远故。以捷疾故。人谓两眼一时见色。问曰。若以相远。不得一时见者。身根亦相远。如两臂而能一时觉触。生于身识。两眼亦应尔。是故为止并义者意。而作此论。复次为断人疑意故。而作此论。众生两眼相去。或半指一指。二三四指。半尺一尺。一肘一寻。半拘卢舍。一拘卢舍。半由旬。一由旬。二三四由旬。乃至百由旬。如大海中有众生身。或百由旬。或百四十由旬。或二百一十由旬。如色界阿迦腻吒天。身长万六千由旬。如是等众生。两眼相去甚远。有如此事。人生疑心。为二识一时生两眼中。为一眼各有一识耶为一一识眼中生已复生一眼中。为一识分为二分在两眼中生。为如横木通两眼中耶。若当二识一时生两眼中者。云何不有二心过。若当一眼中生已复生一眼中者。云何不有前后刹那过。若当一识分为二分在二眼中者。云何一识非是分法。若依身法。是名身识。若依眼生。是名眼识。若当如横木通两眼中者。云何一识。不亦是身识亦是眼识耶。而此五识。所依各异。所行识界亦异。一识二依。事不应尔。如是二识一时生两眼中。一识生一眼中已。复生一眼中。一识分为二分。在两眼中。如横木通两眼中。皆不应尔。非不依二眼生于一识。而能分别极远微细之色。如此皆是甚深微妙难知之法。欲说甚深微妙难知之法故。而作此论。问曰。云何一识依二眼生。答曰。是识所依法故。两眼相去虽远能为一识。而作所依。俱是眼识所依法故。设有百眼。而为一识作依者。亦无有过。如百水精器一面往观则有百面像现。彼亦如是。虽是二依生于一识行于境界。当言一眼见色。乃至广说。答曰。当言两眼见色。应说所以令世人生信。何以故。当言两眼见色。不当言一眼见色。如合一眼。不生净眼识。则不能广见境界。于境界不明不了不净。若开两眼。则生净眼识。则能广见境界。于境界明了清净。设如合一眼不生净眼识。不广见境界。乃至广说。开两眼亦不生净识。不广见境界。乃至广说者。不当言两眼见色。但一眼见色。生不净识。不广见境界。乃至广说。若开两眼。生净眼识能广见境界。乃至广说。是故当言两眼见色不当言一眼见色。合者。若以手以衣以叶。诸余障眼具。坏者。若瞟翳。若赤膜若眼云若生白膜。覆者。为烟尘垢所覆。灭者。若烂败。若虫啖。若堕若破。若消涸。若挑出。若自脱。如眼色。耳声鼻香亦如是。如所依净识则净。所依不净识则不净。实义净者。善识是净。染污是不净。或有眼净识不净。或有识净眼不净。或有眼识俱净。或有眼识俱不净。眼净识不净者。如眼无诸障翳生染污识。识净眼不净者。如眼有障翳生善识。眼识俱净者。如眼无障翳生善识。眼识俱不净者。如眼有障翳生染污识。问曰。何故眼耳鼻。有二处所。而舌身无两处所耶。答曰如此诸根。以庄严身。若有二舌。是鄙陋事。世所嫌笑。云何此人而有二舌。如似毒蛇。若有二身。亦是鄙陋为世所笑。云何一人而有二身。如孪子并。问曰。以何等故。但有二眼二鼻二耳。而不多耶。答曰。如此诸根。以庄严身。若有多眼。广说如上。复有说者。若有多眼。则无所益。所以者何。如二眼见色则净。多亦无益。以无益故。唯有二眼。耳鼻亦应如是说。问曰何故二眼二鼻二耳处所。唯说一界一入一根。答曰。行一境界一识所依。以作一事。故说一界。乃至广说

问曰。为眼见色。为识见。为识相应慧见。为和合见。若眼见者。无识时亦应见。若与余识合时。亦应见。若识见者。识即见性。亦是识性。若识相应慧见者。耳识相应慧亦应见应闻。若和合见者。未尝不和合。答曰。眼见色。而必须识。眼有二种。一报眼二长养眼。耳鼻舌身亦如是。色入有三种。有长养报依。香味触亦如是。声有二种。有长养有依。意入有三种。报依刹那。彼苦法忍相应心名曰刹那。法入有四种。有报依刹那物体。物体者。以有无为法故。问曰。颇有唯报眼。无长养眼。颇有唯长养眼非报眼。答曰。无有。有报眼无长养眼者。如人重人。如墙重墙。报眼长养眼亦如是。颇唯有长养眼。无报眼耶。答曰。得天眼者是。或时长养眼有势力。非报眼。或时报眼有势力。非长养眼。或时长养眼报眼有势力。或时长养眼有势力。非报眼者。如少年时眼。或时报眼有势力。非长养眼者。如老病时。彼长养力少。或时长养眼报眼俱有势力者。如中年时。或有众生。长养眼有势力。非报眼。或有报眼有势力。非长养眼。或有长养眼报眼俱有势力。或有长养眼报眼俱无势力。长养眼有势力非报眼者。如富贵人。本眼性劣。以种种所须。令眼明净。或报眼有势力非长养眼者。如田作人。无种种所须之具。本眼自净。或有长养眼报眼俱有势力者。如富贵人。有种种所须之具。本眼明净。或长养眼报眼俱无势力者。如田作人。无种种所须之具。本眼不明净。问曰。为长养眼见色多。为报眼见色多。答曰。长养眼见多。所以者何天眼是长养眼故。或时长养眼见净好非报眼。或时报眼见净好非长养眼。或长养眼报眼俱见净好。或时长养眼报眼俱见非净好。问曰。为善行报眼见净好。为不善行报眼见净好。答曰。总而言之。善行报眼见净好。所以者何善。行报得人。如佛辟支佛转轮圣王。皆是人故。不善行报是畜生。是故总而言之。善行报眼见净好。以身言之。或有象见胜人。如人眼。虽是善行报。而有障翳。畜生眼。虽是不善行报。而无障翳。问曰。眼微尘。为次第傍布。为前后重生。若次第傍布。云何不散坏。若前后重生。云何前者不障于后。答曰。或有说者。次第傍布。于黑瞳子上。对诸境界。犹如器中盛水以糠坌上。亦如阿閦花子次第傍生。眼微尘亦如是。问曰。若然者。云何不散坏耶。答曰。薄膜覆故。而不散坏。复有说者。前后重生于黑瞳子上。问曰。若然者。前者云何不障于后。答曰。造色性不相障碍。复有说者。明净色不相障碍。犹如秋时潢水明净不障细针堕底犹故可见。明净色不相障碍。亦复如是。耳微尘住耳孔内。鼻微尘住鼻孔内。此三根绕头。如着花鬘。舌微尘依舌。如半月像。其中间空犹如毛许。是身根分。余者悉是舌微尘身微尘。次第而立。复有说者。眼微尘其形如铜杵头。耳微尘在耳孔内。其形如灯器。鼻微尘在鼻孔中。其形如爪甲。舌微尘其形如偃月刀。身微尘其形如大刀。男根微尘其形如指[打-丁+沓]。女根微尘。其形如鼓框。以如是等因缘。是佛经说相似喻。眼根微尘。或时是分。或时是彼分。或时是一分。或时是彼一分。耳根鼻根舌根微尘亦如是。身根微尘。或时是彼分。或时是一分。或时是彼一分。无有全是分时。问曰。若无全是分时者。如入冷池水时。如入热镬汤时。如地狱中十三种猛焰绕身之时。此岂非是耶。答曰。如此之时。故是彼分。所以者何。若身根微尘。尽能生身识者则散坏。色入有二十一种。所谓青黄赤白长短方圆适不适高下。光影明闇。烟云尘雾虚空色。问曰。为缘一色能生眼识。为缘多色能生眼识。若缘一色能生眼识者。此云何通。如说眼能缘五色。若缘多色能生眼识者。云何不有二觉意。有二觉意。则有多体。答曰。缘一种色。能生眼识。问曰。若然者。能缘五色云何通。尊者和须蜜。答曰。于缘捷疾故。佛说俱缘。如旋火轮。而实不匝。以捷疾故。而似轮像。彼亦如是。尊者佛陀提婆说曰。于色不决了故言俱缘。如观树林叶。有种种诸色。彼亦如是。复有说者。如五色。能生一色。见一色时。名见五色。复次若诸色集聚。则见多色生一识若诸色别异。则见一色生一识

声入有八种有内大因声。有外大因声。内大因声有二种。有适意不适意。外大因声亦如是。有众生数。有非众生数。众生数有二种。适意不适意。非众生数亦如是。为缘一声能生耳识。为缘多声能生耳识。若但缘一声能生耳识者。如今一时能闻五乐声。亦闻多人诵声。若缘多声生耳识者。云何不有二心。乃至广说。答曰。应作是说。缘一声生耳识。问曰。若然者。不于一时闻五乐声及多人诵声耶。答曰。五乐声多人诵声。同是一声。能生耳识。复有说者。若诸声聚集。则缘多声。能生一识。若声别异。则缘一声。而生一识

香入有四种。有好有恶。好有二种。有等有增减。恶香亦尔。问曰。为缘一香能生鼻识。为缘多香能生鼻识。若缘一香生鼻识者。如今一时能嗅百种和香。若缘多香生鼻识者。云何不有二心。乃至广说。答曰。应作是说。缘一香能生鼻识。问曰。若然者。不能一时嗅百种香耶。答曰。或有说者。百种香能生一种香。生于鼻识。如是说者好。如多香聚集。则嗅多香。生于一识。若香别异。则嗅一香。能生一识

味入有六种。甜酢碱辛苦澹。问曰。为缘一味能生舌识。为缘多味能生舌识。若缘一味能生舌识者。如今一时能尝百味欢喜丸等。若缘多味能生舌识者。云何不有二心。乃至广说。答曰。应作是说。缘于一味。能生舌识。问曰。若然者。不能一时尝百味欢喜丸耶。答曰。或有说者。百味欢喜丸。能生一种味。生于舌识。如是说者好。如多味聚集。则尝多味。生于一识。若味别异。则尝一味生于一识

触入有十一种。四大涩滑轻重冷饥渴。问曰。为缘一触能生身识。为缘多触能生身识。答曰。十一种触。能生十一种身识。复有说者。五触能生一身识。如四大及滑。生一身识。如是四大。乃至及渴。生一身识。问曰。若然者。云何不名总缘境界。答曰。同一触入故。不名总缘境界。评曰。不应作是说。如前说者好

问曰。为嗅尝觉身中香味触。不若嗅尝觉身中香味触者。云何檀越所施。而有果报。复云何不于一切时嗅尝觉耶。若嗅尝觉外香味触。外香味触。与内香味触。无有因义。答曰。应作是说。能缘内香味触。问曰。若然者。云何檀越所施。而有果报。云何不一切时嗅尝觉耶。答曰外香味触。能发内香味触。以是事故。名之为食。复有说者。亦嗅尝觉触。内入外入。若时觉内则不知外。觉外则不知内。问曰。内香味触。体无增减。云何嗅尝觉触。答曰。彼法虽无增减。亦为识所缘所知

法入有七种。无作假色受想行虚空数缘灭非数缘灭。问曰。为缘一法生意入。为缘多法生意入。答曰。一法亦生。二三乃至多法亦生。唯除自体相应共有。余一切法。能生意识。曾闻菩萨六识猛利。为知几所法名为猛利。答曰。菩萨宫边。有阿泥卢头舍。舍中次第行列。然五百灯。菩萨尔时于自宫中。不见彼灯及与灯焰。但见其光。知然五百灯。若一灯灭时。菩萨作是言。彼五百灯中。一灯已灭。以是事故。言眼识猛利。阿泥卢头舍中。有五百伎女。作乐歌舞。菩萨闻声。知有五百伎女中或琴弦绝。或时睡眠不弹琴时。菩萨亦知。是名耳识猛利。菩萨宫中。常烧百种和香。菩萨嗅之。便知是百种香。彼合香者。欲试菩萨。于百种中。或增或减。若烧香时。菩萨亦知本有百种今增尔所种减尔所种。是名鼻识猛利。菩萨食时。常有百味欢喜丸。彼诸使人。于百味中。或增或减。菩萨即知。以是事故。名舌识猛利。菩萨洗浴时。侍者奉劫波育[疊*毛]。菩萨触时。即便知彼织[疊*毛]师身有热病。以是事故。名身识猛利。菩萨意根。于一切法。而无挂碍。以是事故。名意识猛利

问曰。此六根几到境界能知。答曰。到有二种。一者取境界。二者于境界无间。若以取境界言之。六根尽到。若以无间言之。则三到三不到。三到者。谓鼻舌身根。三不到者。谓眼耳意根。问曰。若三是不到。而能知者。何故闻近声。而不见近色。尊者和须蜜答曰。彼界法自尔。复有说者。眼能取远境界。以极近故不见。问曰。耳亦是远境界。何以闻近声。答曰。如以铜筹筋安阇那药置黑瞳上。以近故不见。若声到耳根微尘上。亦复不闻。尊者佛陀提婆说曰。眼因明故能见近。则冥夺于明。是以不见。如是耳因空故闻声。鼻因风故嗅香。舌因水故知味。身因地坚故觉触。意因所观故能知法

问曰。颇有一微尘作所依。一微尘为境界。能生识不。答曰。无也。所以者何。此五识身。依有对缘有对。依积聚缘积聚。依和合缘和合。复有说者。如眼识依自分缘自分彼分。耳识亦如是。意识依自分彼分。缘自分彼分。鼻舌身识。依自分缘自分。复有说者。眼识依自界。缘自界他界。耳识亦如是。意识依自界他界。缘自界他界。余三识依自界缘自界(界者三界)。复有说者。眼识依无记缘三种。耳识亦如是。意识依三种缘三种。余三识依无记缘无记。复有说者。眼识依近缘近远。耳识亦如是。意识依近远缘近远。余三识依近缘近。所以者何。若三尘与三依合时。三识则生。不合时则不生。复有说者。眼识或所依大所缘小。或所依小所缘大。或所依所缘等。所依大所缘小者。如见毛端。所依小所缘大者。如见大山。所依所缘等者。如见蒲桃珠。耳识亦如是。意识所依。虽无大小。而所缘有大小。余三识。所依所缘等。随香与所依等。生鼻识。乃至舌身识亦如是。或有色虽远而是境界。或有色虽不远而非境界。有色亦远亦非境界。有色亦不远亦非不境界。云何有色虽远而是境界。如四天王所居宫远。人眼所不见。此非不是境界。以远故人眼不见。不远亦非境界者。如梵天在此。人眼不见。亦远亦非境界者。如梵天自住宫。亦不远亦非不境界者。除上尔所事。尊者和须蜜说曰。色有四事。故不见极近极远极细障色。迦毗罗弟子。作是说。色有八事。故不见极远极近。根坏意不住。微细障为胜所翳同故不见。问曰。限根为有筋骨皮肉不耶。答曰。无也。是净四大。言有骨等者。是眼根处所。筋骨皮肉是四入。谓色香味触

诸过去者。尽不现耶。乃至广说。问曰。何以作此论。答曰。优陀耶经。是此论本缘。世尊共优陀耶。东方游行。尔时世尊。着一重衣。而自洗浴

时优陀耶。给事世尊。摩拭身体。优陀耶是菩萨少小亲友。常为菩萨按摩调身。今见世尊。光明照耀。胜菩萨时。生于尊敬欢喜之心。白佛言。世尊。我今欲以龙喻之。偈赞叹世尊。世尊告言。随意说之。时优陀耶便说此偈

  一切结过去　　于林离林来
  出欲生喜乐　　犹如山顶金

一切结过去者。过去有二种。一世过去。二巧便过去。世尊于诸结得解脱。是名结过去。于林离林来者。林名居家。离林来者。所谓出家。于林来出家。故名于林离林来。出欲生喜乐者。欲有二种。一烦恼欲。二境界欲。出者。出家欲烦乱。生喜乐者。身心寂静。是名出欲生喜乐。犹如山顶金者。山者日出处山也。金者日也。如日在山顶出时其光明净。世尊于诸烦恼使垢山顶。出时其光明净。亦复如是。复有说者。山者黑沙山也。金者金沙山也。若除黑沙山。则金沙山。其光明净。世尊亦尔。除去一切烦恼使垢黑沙之山。则力无畏念处大悲金沙之山。其光明净。是故说犹如山顶金。是名过去非不现。所以者何。如来身犹现在故。或有不现非过去者。犹如有一。若以神足。若以咒术。乃至广说。若以神足者。尔时世尊入如是三昧。于梵世中。放大光明。普令周遍。出大音声。令梵天王及诸梵众。普使闻知。而无见者。如尊者目连入如是三昧。能令提婆达多不见其身。问曰。此神足于谁不现。答曰。佛于一切众生边不现。辟支佛除佛。余一切众生边不现。舍利弗除佛辟支佛。余一切众生边不现。目犍连除佛辟支佛舍利弗。余一切众生边不现。乃至利根于钝根边。能令不现。咒术者诸仙人。结如是咒。有能诵者。令身不现。彼神足者。于咒术边。令身不现。咒术不能于神足边令身不现。问曰。咒术还于咒术。能令身不现耶。答曰。能如善咒术者。于不善咒术边。能令身不现。药草者有如是药草。人若执之。令身不现。如毗舍遮鸠槃荼等咒术者。能于持药草者边。令身不现。持药草者。于咒术者边。不能令身不现。何以故。咒术力能取药草故。生得处者。如地狱生得处。不能令身不现。若当能令身不现者。乃至须臾不住地狱中受苦。复有说者。虽于地狱卒边不能令身不现。能于余处令身不现。畜生饿鬼天。亦能令身不现。问曰。如是各各能于谁令身不现。答曰。或有说者。地狱还于地狱。令身不现。畜生于畜生地狱。能令身不现。饿鬼能于饿鬼畜生地狱。令身不现。天于五道。能令身不现。评曰。应作是说。地狱能于五道。令身不现。乃至天能于五道。令身不现。所谓障隔也。是谓不现非过去。云何过去亦不现耶。诸法生始生。乃至过去过去世摄。如此尽明生法。是谓过去亦不现。云何非过去非不现。答曰。除上尔所事。诸法第一第二第三句已称已说已行已立名字者。除诸余法未称未说未行未作名字者。作第四句。彼已说者。是何等耶。答曰。所谓一切过去现在世中。取如来身及障隔不现者。其余现在法。一切未来世法。无为法在在者。作第四句。是谓非过去非不现。问曰。以何等故。此中不说结不现耶。答曰。处处有说结是尽是灭。无有处说结不现。如此四句。亦依世俗法。亦依佛经。亦依世谛。亦依第一义谛

诸过去者彼尽耶。乃至广说。过去不尽者。如长老优陀耶所说。广说如上。尽不过去者。如世尊言。此比丘。尽地狱趣。乃至广说。问曰。地狱畜生饿鬼。即说地狱畜生饿鬼尽。何以复言不堕恶道恶趣耶。答曰。更无未曾有事。言不堕恶道者。即是尽地狱畜生饿鬼。但前广说。后是略说。文虽有异义无异也。复有说者。前是广说后是略说。前说是解后说不解。复有说者。尽是地狱畜生饿鬼。如前说不堕恶道恶趣者。是黄门般吒。无形二形。所以者何。此亦是人中恶道恶趣故。复有说者。尽地狱等。如前说不堕恶道恶趣者。是不断善根。所以者何。若断善根。即是恶道恶趣故。如说。身坏命终。如掷真珠须。堕恶道中。复有说者。尽地狱等。如前说不堕恶道恶趣者。说十二非律仪家。所以者何。此亦是恶趣故。复有说者。尽地狱等。如前说不堕恶道恶趣者。说恶道恶趣因。以因说果故。如世尊言。汝等比丘。若见有人作身口意恶业。当知是地狱趣。复有说者。尽地狱等。如前说不堕者。说地狱趣。所以者何。不能成就善果故。恶道者。是饿鬼趣。所以者何。于一切时。常乏少所须故。恶趣者。是畜生趣。所以者何。有众生。生彼趣中。世界成时受身。乃至世界坏时命终。复有说者。不堕者。尽说三恶道。如畜生饿鬼中。虽有成就善果者少。恶道者。尽说三恶道。以人天言之。尽是恶道。恶趣者。亦尽说三恶道。以身心生其中故。尽地狱趣。乃至广说。问曰。如今地狱镬汤狱卒等犹在。何以言尽。答曰。或有说者。不往不生故言尽。不往者不复往彼处。不往者不复生地狱阴界入。复有说者。彼圣人不生故言尽。彼诸阴界入。住不生法故。复有说者。得非数缘灭故言尽。问曰。彼亦尽天趣。亦尽人趣。尽天趣者。不生无想天。尽人趣者。不生郁单越。何以但言尽地狱等趣。答曰。以都尽故说尽。不都尽故说不尽。过去亦尽者。诸行始生。广说如上。亦不过去不尽者。除上尔所事。如前广说。已说者一切过去现世有如来身。未来世中圣人堕恶趣阴界入住。不生者余未来现在法。无为法在在者。作第四句。此说世尽四句。今当说结尽四句

复次今当说结。结有过去不尽。乃至广说。结过去不尽者。诸过去结。不断不知不灭不吐。不断者不以圣道断诸结得。不知者不证解脱得。复有说者。不断者是断知。不知者是智知。不灭者不得数缘灭。不吐者不断诸结得。不证无为得。复有说者。不吐者不舍弃。彼不断等。复是何耶。答曰。具缚人。见道修道所断结是也。圣人若住苦法忍时亦尔。苦比智生。余有四种结。如是次第。乃至道比智生。余有一种见谛具足。修道所断。随相而说。尽不过去者。诸结已断已知已灭已吐。断者以圣道断诸结得。已知者证解脱得。复有说者。已断者所谓断知。乃至广说。断等复是何耶。答曰。阿罗汉三界结使断。乃至广说。断等复是何耶。答曰。阿罗汉三界结使断。乃至欲界凡夫结使断。应随相说。过去亦尽者。诸过去结已断。乃至广说。断者以圣道断。乃至广说。不过去亦不尽者。诸未来结不断。乃至广说。诸过去尽灭耶。乃至广说。作四句。过去不灭者。如长老优陀耶言。乃至广说。是谓过去不灭。灭不过去者。当说小事。小舍言舍灭。乃至广说。此是世所传。如东方人小舍言舍灭。乃至小眼见色言眼灭。故作是说。颇有灭眼能见色耶。答曰。有。如此者是也。是名灭不过去。过去亦灭者。诸行生始生。广说如上。不过去亦不灭者。除上尔所事。广说如上。已说者是何。一切过去法。现在有佛身及小灭。余现在法未来世及无为法在在者。作第四句

复次今当说结。乃至广说。前四句明世灭。今四句明数缘灭结。或过去不灭。乃至作四句。广说如上。问曰。以何等故。但说结不说结法。答曰。或有说者。作结者意欲尔。乃至结说。复有说者。若说结当知亦说结法。所以者何。同一对治断故。复有说者。若缘结法。皆为结故。复有说者。结一向染污故说。结法染污不染污故不说。复有说者。若与圣道相妨者说。善有漏不隐没无记法。不与圣道相妨。所以者何。善有漏法。于道有出有入。于定亦有出有入。不隐没无记。与圣道作所依。烦恼与圣道相妨。所以应断。若断烦恼。彼法亦断以同对治断故。譬如灯明。不与炷油器相妨。唯与闇相妨。欲坏闇故。烧炷尽油热器。如是有漏善法。不与无漏道相妨犹如灯炷油。不隐没无记法。不与无漏道相妨如器。是以说结不说结法。如王不与自国自军相妨。与他国他军相妨。为坏他军故。亦少自损国。少自坏军。如有漏善法。不与无漏道相妨。犹如自军。不隐没无记法。犹如自国。如是若说断结。当知结法亦断。复有说者。若断害烦恼。亦断害生死。以是故说结不说结法。如结结法。受受法使使法垢垢法缠缠法亦如是

若苦生疑。乃至广说。问曰。何故作此论。答曰。此是佛经。如经说。有事论婆罗门。往诣佛所。作如是问。沙门瞿昙。甚为希有。是疑难度。非是易度。佛语婆罗门。如是。如是甚为希有。是疑难度。非是易度。婆罗门于意云何。古昔诸婆罗门。作韦陀者。造咒术者。一名阿吒驹。二名傍摩驹。三名傍摩提婆。四名毗婆蜜哆。五名阇婆阿尼。六名阿祈罗。七名婆罗池殊。八名婆私吒。九名迦叶。十名毗浮。如是等皆不断疑心。而便命终。婆罗门以是因缘故。当知疑心难断难度。佛经说疑。不广分别。佛经是此论根本因缘。彼中未说者。今当尽说。故作此论。若苦生疑。乃至广说。此是甚深微细。难可显现。若缘此苦如是之间。多心已过。以是事故。尊者迦旃延子。说苦法忍生。乃至道比智生。于其中间。有六十刹那现。其性速疾有苦邪。是一意无苦邪。是二意彼邪字者。以成疑义。所以者何。若无邪字者。有苦是正见。无苦是邪见。如是以邪字成。于苦疑亦应以邪字。乃至成于道疑。如此八心。是最少者。若缘谛生疑。亦有多心。颇有一意。是疑非疑。乃至广说。问曰。何以作此论。为以自体。为以境界。若以自体者。疑心相应法。犹豫是疑。慧是非疑。若以境界者。一切凡夫。于如来身疑。一切圣于如来身不疑。若作是说。颇有一意。是疑非疑。何以答言无。答曰。所问者。颇有一意。是疑非疑。是疑者。一意犹豫。亦是决定邪。非疑者。一意决定。亦是犹豫邪。是故答曰无邪。是苦邪此心是疑是苦。此心非疑。是正见无苦邪。此心是疑无苦此心非疑是邪见。如是有四正见。有四邪见。有八疑。问曰。此八疑心。几能生正决定。几能生邪决定。答曰。四能生正决定。四能生邪决定。问曰。何等人疑。能生正决定。何等人疑。能生邪决定。答曰。有人喜亲近善知识。乐听闻法。有人不喜亲近善知识。不乐闻法。若人喜亲近善知识。乐听闻法者。如此人疑。能生正决定。有人不喜亲近善知识不乐闻法者。如此人疑。能生邪决定。复有说者。有人多与内道人共住。有人多与外道人共住。若多与内道人共住者。如此人疑能生正决定。若多与外道人共住者。如此人疑。能生邪决定。复有说者。有人多好习内道经。有人多好习外书。若好习内道经者。如是人疑。能生正决定若好习外书者。如此人疑。能生邪决定

有三种冥身。所谓于过去世疑犹豫。现在未来亦如是。问曰。如疑性。非是无明。何以说是冥身。答曰。与无明相似故。无有法非无明而与无明相似如疑者。是故说疑是冥身。复有说者。冥是无明。彼疑是其处所。是其舍宅。复有说者。疑是住处故。所以者何。若身中有疑。必有无明。如世人言。以亲他故言。汝即是我身。复有说者。同是一法。所以者何。俱是不决定故。问曰。以何等故。世尊说缘世生疑是冥身。不说缘无为是冥身耶。答曰。或有说者。世是粗法。现可了知。若于世脱失诸圣说是冥身。无为法微细。不可现得了知。是故诸圣不说是冥身。如人昼行脱失。为世人所呵笑。如人夜行脱失。则不为世所呵笑。彼亦如是。复有说者。为诸外道故。缘世生疑。说是冥身。诸外道偏愚于世。我曾在过去世不。乃至广说。是故说疑世是冥身。复有说者。疑心多缘世生少缘无为生。复有说者。世乃至小儿。犹于中愚。所谓去来今事。以如是等现事故。世尊说疑世心是冥身。涅槃是非根法。甚深微细觉性。乃能了知。是故疑此法者。不说冥身。如经说。佛告比丘。以五事故令心弊恶。云何为五。所谓有人。于如来所。而生疑心。不解不观不信。是名于如来所不断心弊恶。于法于戒于教亦如是。佛所赞叹。智人所识。修梵行者。常以粗言。讥刺毁訾触恼。无恭敬心。是名于梵行者不断心弊恶。问曰。此心弊恶体性是何。答曰。此心弊恶有二分。所谓疑与嗔恚。四是疑分一是嗔恚。问曰。嗔恚是弊恶。是事可尔。所以者何。如说云何嗔恚结。答曰。若心生害。心生弊恶。心生嗔恚。是名嗔恚结。如疑心性非嗔恚。何以说是弊恶。答曰。或有说者。无有法性非嗔恚。而与嗔恚相似如疑心者。如所说疑隐弊心。令心坚[革*卬]弊恶。犹如良田不种植时坚[革*卬]弊恶。彼亦如是。复有说者。疑隐弊心时。尚不能生邪决定。况正决定。如田弊恶。犹不生草。何况苗稼。复有说者。嗔恚令自身弊恶。疑心能令自身弊恶。亦复如是。如田弊恶人所弃舍。所生稗[禾*秀]。犹不任用。何况粳粮。如是疑结。令众生生心弊恶。犹不能生于邪决定。况正决定。复有说者。同行相对故。同行者俱行愁戚。行相对者。同与欣踊行相对。问曰。以何等故。于佛生疑。说是弊恶。于僧非邪。答曰。佛无过失之行。若于佛生疑。此疑无过而起。僧少有过失之行可见。若于僧生疑。此疑因过而起。以是事故。因佛生疑名为弊恶。因僧生疑不名弊恶。复有说者。一向无过故。佛世尊乃至无有少过。若于佛生疑。此疑无过而起。众僧少不随顺事可见故。若于僧生疑。因过而起。以是事故。因佛生疑名为弊恶。因僧生疑不名弊恶。如佛生疑。法戒教亦如是。问曰。以何等故。于僧生恚名为弊恶。于佛非耶。答曰。若佛生恚。此心偏重。以偏重故。更立重名。名为横恶

阿毗昙毗婆沙论卷第八阿毗昙毗婆沙论卷第九

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    杂犍度智品之五

云何名身。云何句身。云何味身。乃至广说。问曰。何以故作此论。答曰。彼作经者意欲尔。乃至广说。复有说者。彼尊者迦旃延子。于此经中。现种种事。善于义相。或有人疑。彼但善于义不善于文。为断如是等疑。欲现于文义中俱得自在。故作此论。复有说者。如声论家。欲令字是色法字体是声声是色阴所摄。为断如是意故。作如是说。字是心不相应行。行阴所摄。复有说者。此名身句身味身。能照烦恼出要法。所以者何。若称烦恼名。当知此法是烦恼。若称出要名。当知此法是出要。以名身句身味身能显照烦恼出要法故。而作此论。复有说者。以觉知名句味等法故。有三种菩提差别。其事云何。答曰。若增上慧。觉知名等法。是名为佛。若以中慧。名辟支佛。若以下慧。名曰声闻。复有说者。以觉知名等法故。名佛一人。为无量说法者。复有说者。若不能观察名句味身。生大过患。若能观察。生大善利。其事云何。若不能观察名句味身。则烦恼恶行之河。常流不绝。如骂琉璃太子言婢子。何以升释种堂。彼以不能观察四五字故。与百千众生。堕恶道中。彼若能观察四五字者。如山等恶行。亦能堪忍。以不观察故。有如是折减。问曰。行者得他骂时。云何观察名身等。令恚心不生。答曰。或有说者。阿拘卢奢。秦言是。骂拘卢奢。秦言唤声。行者作如是念。我今不应念是阿字。所以者何。若有阿字。是名为骂。若无阿字。名曰唤声。若我不念是阿字者。使他人终日竟夜常作唤声。于我何为生嗔恚心。复有说者。行者作如是念。若以如是等字骂我。于此方是卑陋语。于他方是叹美语。我若于此方卑陋语中。生于忧苦。于异方语。生喜乐者。我则常忧常苦。常喜常乐。谁有苦人与我等者。以是事故。不生恚心。复有说者。骂我者以是等字。行者作是念。赞叹我者。为以是字更有异字。谛观察之更无异字。但此诸字。次第颠倒。言是骂是赞。我今何为于是字中而生嗔恚。复有说者。行者作如是念。若人骂我。以一界少入。一入少入。一阴少入。余不骂我者。十七界一界少入。十一入一入少入。四阴一阴少入。如是不骂我者多。骂我者少。而我何为生嗔恚心。复有说者。行者作是念。此骂名谁所成就。为是骂者。为是受骂者。推之应是骂者成就。若然者便是自骂。于我何为而生嗔恚。复有说者。行者作是念。若以一字则不成骂。二字则成。无有能一时称二字者。若称后字时。前字已灭不至后字。如是但以意分别故。言是骂者。是受骂者。以是事故。不生嗔心。复有说者。行者作是念。骂者及我。一时同一刹那灭。后生诸阴。亦无骂者及受骂者。骂法不可得故。是以不生恚心。复有说者。行者作是念。骂者受骂者。皆悉是空。所以者何。无我无人。无众生。无寿命。无作无作者。无受无受者。但有诸阴空聚。是故不生嗔心。行者应以如是等法观名身句身味身。问曰。何以复依名句味身作论耶。答曰。欲现此经文义具足故。而作此论。复有说者。以依此文能显明阴界入中众多之义。亦能赞叹佛法僧宝。以是事故。而作此论

云何名身(名身胡音有三种一语名名二语名名身三语以上名多名身一语名名者一法一名二语名身者二法二名三语以上名多名身者三法三名以上名多名身句身味身亦如是此所问名身者问多语名身也)

问曰。何以问多语名身。不问名。不问名身耶。答曰。彼作经者意欲尔。乃至广说。复有说者。应问而不问者。当知此是有余之说。复有说者。多与名身。悉入多语名身中。是故问多语名身。不问名与名身。答曰。名者。称语种种语增语。想数施设世所传说是谓名。如是等语。尽说是名。问曰。何故问多名身。而答名耶。答曰。以名成满多名身故。多名身还成满多名身。复次名能生多名身。多名身还生多名身。是故问多名身答名。问曰。名多名身体性是何。答曰。是心不相应行。已说体性。所以今当说。何故名名。答曰。名者。亦名随。亦名求。亦名合(天竺名音中含此三义)。随者。随其所作。有如是名求者。以是名求有此物应。复次求者。四阴名求。以四阴。能取诸界。能取诸趣。能取诸生。是故名求。合者。于义于造相应故名合。问曰。何故名多名身。答曰。众多名合聚故。名多名身。如一鸟不名多鸟身。众多鸟名多鸟身。马等亦如是。如是一名不名多名身。众多名合集名多名身。句身味身当知亦如是。如是有名。有名身。有多名身。名者有一字名二字名多字名。一字名者名曰名。二字名者名曰名身。多字名者或说三字。或说四字。名多名身。二字名者亦名名。四字名名身。或六字或八字。名多名身。三字名者亦名名。六字名名身。或九字或十二字。名多名身。四字名者亦名名。八字名名身。或十二字或十六字。名多名身。如是乃至多字立门亦尔。如名身。味身当知亦如是

云何句身(此问多句身)。答曰。随句义满。现如是事。是名句身。所以引偈者。为作证故。如说

  诸恶莫作　　诸善奉行　　自净其意
  是诸佛教

彼诸恶莫作。是初句。乃至广说随句义满者。满偈义也。现如是事者。显明如是事也。是名句身。此偈有说有解。如说诸恶是说。莫作是解。下诸句亦如是说。如说诸恶于说是足。于解不足。于句不足。于偈不足。莫作于说于解于句足。于偈不足。乃至是诸。于说于解于句足。于偈不足。佛教于说于解于句于偈足。此是偈中。不长不短。八字为一句。三十二字为一偈。此结偈法。名阿[少/兔]吒阐提。是经论数法。亦是计书写数法。六字为句者。名初偈。二十六字为句者。是后偈。或有减。六字为句者。此偈名周利荼。若过二十六字为句者。此偈名摩罗

云何味身。答曰。字说是味身。所以引偈者。为作证故。如说

  欲是偈本　　字即是味　　偈依于名
  造是偈体

欲是偈本者。云何为欲。答曰。欲者欲造偈。欲作偈。是名为欲。本者是所起是所因。是名为本。字即是味者。诸字即是味。偈依于名者。偈依名有。造是偈体者。造者是作偈者。偈从作偈者生。如泉出水。如乳房出乳。偈从造者生。故以为体

有名有名身有多名身。有句有句身有多句身。有味有味身有多味身。彼一字名者名曰名。不名名身。不名多名身。不名句不名句身不名多句身。是名味不名味身不名多味身。二字名者名曰名。不名名身不名多名身。不名句不名句身不名多句身。是名味名味身不名多味身。彼二字名。一字为名者名曰名。二字名名身不名多名身。不名句不名句身不名多句身。是名味名味身不名多味身。四字名者名曰名。不名名身不名多名身。不名句不名句身不名多句身。是名味名味身不名多味身。彼四字名。一字为名者。名曰名。二字名名身。余二字。名多名身不名句。不名句身不名多句身。是名味。名味身名多味身。以二字为名者名曰名。名名身不名多名身不名句不名句身不名多句身。名味名味身名多味身。八字名者名曰名。不名名身不名多名身。是名句不名句身不名多句身。是名味名味身名多味身。彼八字名。以一字为名者名曰名。名名身名多名身。名句不名句身不名多句身。名味名味身名多味身。以二字为名亦如是。四字为名者名曰名。名名身不名多名身。名句不名句身不名多句身。名味名味身名多味身。十六字为名者名曰名。不名名身不名多名身。名句名句身不名多句身。名味名味身名多味身。彼十六字。一字为名者名曰名。名名身名多名身名句名句身不名多句身。名味名味身名多味身。二字四字为名亦如是。八字为名者名曰名。名名身不名多名身。名句名句身不名多句身。名味名味身名多味身。三十二字为名者名曰名。不名名身不名多名身。名句名句身名多句身。名味名味身名多味身。彼三十二字。一字为名者。二字为名者。四字为名者。八字为名者。如前说。十六字为名者名曰名。名名身不名多名身。名句名句身名多句身。名味名味身名多味身。一字一名。如上广说。一字二名者名曰名名名身不名多名身。不名句不名句身不名多句身。名味名味身不名多味身。一字四名者名曰名。名名身名多名身。不名句不名句身不名多句身。名味名味身名多味身。一字八名者名曰名。名名身名多名身。名句不名句身不名多句身。名味名味身名多味身。一字十六名者是名句。名句身不名多句身。余如上说。一字三十二名者。说皆具足。二字一名如前说。二字二名者名曰名。名名身不名多名身。不名句不名句身不名多句身。名味名味身名多味身。二字二名。一字为名者。如前说。四字一名者。如前说。四字二名者名曰名。名名身不名多名身。名句不名句身不名多句身。名味名味身名多味身。彼四字二名。一字二字为名者。如前说。八字一名者。如前说。八字二名者名曰名。名名身不名多名身。名句名句身不名多句身。名味名味身名多味身。彼八字二名。一字二字四字为名。如前说。十六字为一名者。如前说。十六字二名者名曰名。名名身不名多名身。名句名句身名多句身。名味名味身名多味身。彼十六字一名。一字二字四字八字为名者。如前说

问曰。名为随身处所。为随语处所。答曰。或有说者。名随语处所。诸作是说。名随语处所者。生欲界中。作欲界语。语是欲界。名是欲界。人是欲界。所说义。或三界系。或不系。生欲界。作初禅地语。语是初禅地。名是初禅地。人是欲界。所说义。或三界系。或不系。生初禅中。作初禅地语。语是初禅地。名是初禅地。人是初禅地。所说义。或三界系。或不系。生初禅中。作欲界语。语是欲界。名是欲界。人是初禅。所说义。如前说。生二禅三禅四禅中。作初禅地语。语是初禅。名是初禅。人是二禅三禅四禅。所说义。如前说。生二禅三禅四禅中。作欲界语。语是欲界。名是欲界。人是二禅三禅四禅。所说义。如前说。问曰。诸作是说。名随语处所者。名是欲界初禅。余三禅地。为有名不。答曰。或有说者无。复有说者有。而不可说。评曰。不应作是说。如前说者好。复有说者。名随人处。若作是说。名随人处者。生欲界中。作欲界语。语是欲界。名是欲界。人是欲界。所说义。如前说。生欲界中。作初禅地语。语是初禅地。名是欲界。人是欲界。所说义。如前说。生初禅中。作初禅地语。语是初禅。名是初禅。人是初禅所说义。如前说。生初禅中。作欲界语。语是欲界。名是初禅。人是初禅所说义。如前说。生二禅三禅四禅中。作初禅地语。语是初禅。名之与人。即是彼地所说义。如前说。生二禅三禅四禅中。作欲界语。语是欲界。名之与人。即是彼地所说义。如前说。问曰若作是说。名随人处者。二禅三禅四禅地有名。无色界为有名不。答曰或有说者无。复有说者有。而不可说。评曰不应作是说。如前说者好。问曰名为是众生数。为非众生数耶。答曰。名是众生数。问曰。名者为是长养。为是报。为是依。答曰。一切名是依。非长养。非报。问曰若名非报者此经云何通。如佛告阿难。我亦说名从业生。答曰此中说业威势果。言从业生。如作好业亦生好名。问曰名当言善不善无记耶。答曰名当言无记。问曰谁成就此名。为是说者。为是所说法耶。若是说者。断善根人。亦说善法。可成就善耶。离欲人亦说不善。可成就不善耶。若是所说法者。非众生数法。及无为法。亦是所说法。可成就名耶。答曰应作是说。名是说者成就。问曰若然者。断善根人亦说善法。离欲人亦说不善法。可成就善不善耶。答曰不也所以者何彼虽成就善不善法名。然名体是无记法

声闻一心。能起一语。一语不能说一字。问曰如说阿此非一字耶。答曰尔所时已经多刹那。世尊一心起一语。一语说一字。唯佛世尊其言轻疾言声无过。辞辩第一

问曰诸法过去。有过去现在未来名耶。答曰有过去法有过去名者。如毗婆尸佛。以如是名。说过去法。过去法有未来名者。如弥勒佛。以如是名。说过去法。过去法有现在名者。如今现在。以如是名。说过去法颇未来法。有未来现在过去名耶。答曰有未来法有未来名者。如弥勒佛。以如是名。说未来法。未来法有过去名者。如毗婆尸佛。以如是名。说未来法。未来法有现在名者。如今现在。以如是名。说未来法。颇现在法。有现在过去未来名耶。答曰有现在法有现在名者。如今以如是名。说现在法。现在法有过去名者。如毗婆尸佛。以如是名。说现在法。现在法有未来名者。如弥勒佛。以如是名。说现在法

如语能说名名能显义。问曰一切名尽能显义不耶。答曰一切名尽能显义。问曰若然者。以如是名。显断常见。第二头。第三手。第六阴。第十三入。第十九界。如是等名。为显何义。答曰显众生常想断想。第二头想。第三手想。第六阴想。第十三入想。第十九界想。显如是等义。问曰若以名显一切法无我。此何所不显。答曰或有说者。不显自体相应共有。余法悉显。复有说者。唯除自体。余法悉显。复有说者。唯除四字。所谓诸法无我。余法悉显。复有说者。一切法悉显。所以者何如婆字显婆字娑字显娑字

问曰为名多耶为义多耶。答曰或有说者义多。何以故义摄十七界一界少入。十一入一入少入。四阴一阴少入。名摄一界一入一阴少入。复有说者。名多非义多。何以故一义有多名故。如尼犍荼书分别诸名。一义有千名。评曰如是说者好。义多非名多。所以者何。不须更以余事。但以摄界等多故。义摄十七界一界少入。十一入一入少入。四阴一阴少入。名摄一界一入一阴少入。彼名亦是义。若然者。应全摄阴界入。复有说者。若以说法故。则名多于义。所以者何世尊说法。一义以多名说故。若以阴界入。则义多于名

问曰义为可说不耶。若可说者。说火则应烧舌。说刀则割舌。说不净则污舌。若不可说。云何有颠倒耶。如索象则马来。如索马则象来。此经复云何通。如佛告比丘。我所说法。文亦善义亦善。答曰应作是论。义不可说。问曰若然者云何所索非颠倒耶。答曰古时人立于象名。有如是想。索象则象来非马。索马则马来非象。复有说者。语能生名。名能显义。如是语生象名。象名能显象义。马等亦如是。此经云何通者。尊者和须蜜答曰。说显义文故言说义。复有说者。为破外道所说法故。外道所说。或无义。或有少义。世尊所说。有义有多义。是故言说义。复有说者。外道所说。文与义相违。义与文相违。世尊说法。文不违义义不违文。问曰文义有何差别。答曰文者味义者所味。问曰彼味亦为余味所味。彼味亦是所味耶。答曰彼味亦是所味。问曰若然者味与所味有何差别。答曰所味是十七界一界少入。十一入一入少入。四阴一阴少入所摄。味是一界一入一阴少入所摄。复有说者。义是色非色。文是非色。如色非色。相应不相应。有依无依。有势用无势用。有行无行。有缘无缘。文是不相应。乃至是无缘。复有说者。义是可见不可见。文是不可见。义是有对无对。文是无对。义是有漏无漏。文是有漏。义是有为无为。文是有为。义是善不善无记。文是无记。义是堕世不堕世。文是堕世。义是三界系不系。文是欲色界系。义是学无学非学非无学。文是非学非无学。义是见道断修道断不断。文是修道断。义是染污不染污。文是不染污。如染污不染污。有过无过。黑白隐没不隐没。退不退。有报无报。文是不染污。乃至是无报。文义是谓差别

如经说。云何为名。四阴为名。问曰如名是心不相应行阴所摄。以何等故。世尊说四阴非色阴为名耶。答曰。佛说色法。非色法为二分。诸色法为色阴。诸非色法为四阴。诸显义名。是心不相应行。阴所摄

名有六种。所谓功德生处时随欲作事相。功德为名者。如诵修多罗故名修多罗者。诵毗尼故名持律者。诵阿毗昙故名阿毗昙者。以得须陀洹果故名须陀洹。乃至得阿罗汉果者名阿罗汉。生处为名者。城中生者名城中人。如是随何国生。名彼国人。时为名者。如小儿时名为小儿。如老时名为老人。随欲名者。如生时父母为作名。亦沙门婆罗门为作名(作事名者如能)。画故名为画师。能铜铁作故名铜铁师。相为名者。如棷杖执盖故名为棷杖执盖者。复有说者。有四种名。所谓一想。二枳互。三呾地多。四三摩娑。想为名者。如世贵人以奴为名。如贫贱人以贵为名。枳互为名者。能腹行故名复行虫。呾地多为名者。如事毗纽天名事毗纽天者。如从婆修提婆天生名婆修提婆子。三摩沙为名者。如牛驳色名为驳牛。如人属王名为王人。复有说者。名有二种。所谓生作。生为名者。如婆罗门刹利毗舍首陀。作为名者。如生时父母为作名。若沙门婆罗门为作名。复有说者。生为名者。如生时父母为作名。亦沙门婆罗门为作名。作为名者。后时亲友知识。更为作名。名第二名。复有说者。有二种名。所谓有相无相。有相为名者。如无常苦空无我阴入等名。无相为名者。如众生人那罗禅头等名。若佛出世作有相名。若佛不出世。唯无相名。复有说者。有二种名。所谓共不共。不共为名者。如三宝等名。共为名者。诸余名。复有说者。一切名。尽是共。无不共名。所以者何一义可立一切名。一切义可立一名。复有说者。有二种名。所谓决定不决定。决定为名者。如须弥山四天下大海。此世界始成时。是决定名。不决定为名者。诸余等名。复有说者。无决定名。所以者何。诸余边方。亦为须弥山等。更作余名。评曰如是说者好。世界初成时。名须弥山四天下大海名亦如是。问曰如劫尽时。一切散坏。谁复作此名。答曰或有说者。是仙人入定力。复传此名。复有说者。众生有因力。能说此名。问曰诸名为先有共传。为更有新作者。答曰世界初成。须弥山等诸名。先有共传。余名不定。复有说者。名有二种。所谓物作。物为名者。如提婆达多延若达多名。作为名者。如作者刈者煮者读者等名。问曰为有知名边际者不。答曰有唯佛能余无知者。所以者何以佛能知一切名边际故。名一切智

如经说如来出世。便有名身等出现世间。问曰若佛出世。若不出世。常有名身等现于世间。何以言如来出世便有名身等出现世间。答曰言名身等出世者。所谓阴界入名。随顺无我。随顺解脱。随顺空。断人见。生觉意。背烦恼。向出要。止愚痴。生智慧。断犹豫。生决定。厌生死。乐寂静。断外道意。叹内道意。为说如是等名身言出现世间

问曰如火名火。此名为是有相名。为是无相名耶。答曰是有相名。如向所说一切显义名此名是有相。问曰若然者。火有何相。答曰凡义有二种。有相无相。如火外无火相。言是无相。如焰是火相言有火相

佛经有三种名说法。谓去来今。问曰此三种名说法。体性是何。答曰如波伽罗那说。三种名说法体性。摄十八界十二入五阴。问曰如波伽罗那说三种说法体性摄十八界十二入五阴。所说是语所显。是名应是一界一入一阴少入。云何说摄十八界十二入五阴。答曰或有说者。取三种名说法及眷属故。其事云何。答曰语能生名。名能显义。故说及其眷属。复有说者。为三义说法故。言三名说法。所以者何。说者听者。皆为于义。以是事故。尽摄阴界入。问曰何故有为法说是三名说法。不说无为法耶。尊者和须蜜答曰此经为说有为法。有为法不得作第四第五说法。复有说者。此经为说一切法无为法堕现在世中。所以者何。以现在法能证得无为法故。以是故。无为法亦在三种名说法中。复有说者。若有三性者。说是三名说法。三性者所谓语名义。无为法。虽语有义。无语无名。是故说不在三名说法中。问曰何故世尊说世是三名说法。答曰或有说者。为止外道意故。外道于世中愚故。复有说者。为坏未来世中说无过去未来者意故。是故说世是三种名说法。复有说者。外道作如是说若无我者。是人说法。终无所为。为坏如是意。而作是说虽无有我。为世故说。问曰若为过去说法。解未来现在事。若为未来说法。解过去现在事。若为现在说法。解未来过去事。于三种名说法中。为是何名说法。答曰或有说者。如是说者。于三种名说法中。是异说。复有说者。若为过去说法。解未来现在事者。为过去。即过去世。解未来现在事。即未来现在世摄。乃至为现在说。过去未来亦如是。复有说者。若作是说。是说三世义。若为过去。是说过去义。解未来现在。是说未来现在义。未来现在亦如是

如经说。有三种名说法。无第四第五。问曰若说三种名说法。有说有解。于义已足。何以复言无第四第五。答曰无第四者遮有第四世。无第五者决定此义无第五世。复有说者。无第四者遮第四世。无第五者遮无为法。复有说者。应说四种名说法。所谓四圣谛。无第五者无第五谛。无第六者遮虚空非数灭。复有说者。应有五种名说法。所谓五阴。无第六者无第六阴。无第七者遮无为法。此为三世名说法故。无第四第五。应有一种名说法。所谓作观。无第二第三。无第二者无第二作观。无第三者遮作观所不摄法。复有说者。应有二种名说法。所谓定慧。无第三者无第二定若第二慧。无第四者遮定慧所不摄法。此说三世名说法故。无第四第五。无第四者遮第四世。无第五者遮三世所不摄法。以如是数法。应说三解脱门。说四谛五阴六圣明分想。七觉分。八道分。九次第定。十种无学法。如来十力。应有十种名说法。无第十一第十二。无第十一者无第十一力。无第十二者遮十力所不摄法

即彼经说。应以四事察人是长老。为可与语。为不可与语。云何为四。一不住是处非处。二不住智论。三不住分别。四不住道迹。问曰如此四事有何差别。答曰或有说者。不住是处非处者。不如实知是处非处。不住智论者。不如实知智与不智。不住分别者。不如实知世谛第一义谛。不住道迹者。不如实知此身集道迹。不如实知此身灭道迹。复有说者。不住是处非处者。如眼色能生眼识。乃至意法能生意识。名为是处。不如实知者名为不住。不住智论者。不如实知十智。不住分别者。不如实知了义不了义经。不住道迹者。不如实知四种道迹。复有说者。不住是处非处者。不能自定所说是处非处。不住智论者。不能堪忍分别前后问答。不住分别者。不如实知诡诳真实。不住道迹者。他如法问心不悦可复有说者。不住是处非处者。不别有无。不住智论者。不解智人论。不住分别者。不知假设无有是处之言。不住道迹者无有随应觉意。复有说者。不住是处非处者。于所言论不别自义他义。不住智论者。于先所闻。执着不舍。后所闻义不能观察。不住分别者。他说正义。心生疑虑。如人见苏谓是米饭。不住道迹者。不识他人所说次第。以前为中。以中为后。复有说者。不住是处非处者。不知现前可了不可了事。不住智论者。不能以比想筹量所论。不住分别者。不知前后所说次第。不住道迹者。不解他人所问意。尊者婆摩勒说曰。不住是处非处者。不能定所说。不住智论者。不知诡诳及与真实。不住分别者。不堪忍分别前后问答。不住道迹者。他人如法论。心不悦可。尊者僧伽婆秀说曰。不住是处非处者。不知多界经所说。是处非处义。不住智论者。不知四十四智七十七智体分。不住分别者。不知烦恼出要。不住道迹者。不如实知色灭道法。复应以四事察人是长老。应以决定答论作决定答。是可与语乃至广说。云何决定答论。如问佛是等正觉耶。应决定答言是此佛法是善好耶。应决定答言。是此声闻。是善随顺众耶。应决定答言。是一切行无常。一切行无我。涅槃是寂静耶。应决定答言是。是名决定答论。问曰何故如是问者。作决定答。答曰此问于义利益。能增长善。亦进梵行。通达觉意。能得涅槃。是故如是问者。作决定答论。云何分别答论。答曰若作是问。为我说法。彼应作是答。法亦众多。过去未来现在。善不善无记。欲界系色界系无色界系不系。学无学非学非无学。见道断修道断无断。如是等法。为说何法。如是随所问。应分别答。是名分别答论。云何反问答论。答曰如说为我说法。应作是答。法亦众多。有过去乃至无断法。于此法中。为说何法。是名反问答论。问曰分别答反问答。有何差别。答曰若以答而言。无有差别若以所问。应有差别。所以者何。问有二种。有欲知义故问。为触恼故问。若为知义故问。为我说法者。应作是答。法亦众多。有法过去乃至不断。于此法中。为说何法。若言为我说过去法。应作是答。过去法亦众多。有善不善无记。若作是言。为我说善法。应作是答。善法亦众多。有色乃至识。若作是言。为我说色法。应作是答。色亦众多。有不杀生乃至不绮语。若作是言。为我说不杀生法。应作是答。不杀有三种。从不贪不恚不痴生。为说何等。若作是言。为我说从不贪生者。应作是答从不贪生有二种作无作。若为知义故问。应次第分别显说。若为触恼故问者。应答言法亦众多。为说何法。不应语言。有过去未来乃至不断。若作是言。为我说过去法。应作是答。过去法亦众多。不应说善不善无记。若作是言。为我说善法。应作是答。善法亦众多。不应说色乃至识。若作是言。为我说色。应作是答。色亦众多。不应说不杀生乃至不绮语若作是言。为我说不杀生应作是答。不杀生亦众多。不应说从无贪无恚无痴生。若作是言。为我说从不贪生者。应作是答。从无贪生亦众多。不应说作无作。如是为触恼问者。应作如是。答乃至问尽。或时自答。如是有求善义故问。有试他觉意深浅故问。或有求义故问。或有轻他故问。或有质直故问。或有谄曲故问。或有情性软弱故问。或有自恃智故问。如软弱问者。应分别答。若自恃智问者。应反问答。乃至问尽。或时自答。云何置答论。答曰。如诸外道。诣世尊所。作如是问。沙门瞿昙。世界是常无常。佛言是不应答。问曰何故问世界常无常佛不答耶。答曰诸外道以人是常。往诣佛所。作如是问。人为是常是无常耶。佛作是念。毕竟无人。若答言无人。彼当作是言。我不问有无。若答言断常。毕竟无人。有何断常。如人问他言。善男子石女儿。为恭敬孝顺不。彼作是念石女无儿。若我答言石女无儿彼当作是语。我不问有无。若当答言恭敬孝顺者。石女无儿。有何恭敬孝顺。彼亦如是。此问论非是真实。以是非有非实故。佛不答。如是有常无常。亦常无常。非有常非无常。世界有边无边。亦有边无边。非有边非无边。当知亦如是。复作是问。沙门瞿昙。神即身耶。佛言是不应答。问曰何故佛不答此问。答曰诸外道以身是神。往诣佛所。作如是问。沙门瞿昙。是身即神。乃至广说。佛作是念。有身无神若我答言有身无神。彼当作是言。我不问有无。若当答言神异于身。毕竟无神。云何是身是异。如人问他言。善男子兔角牛角。为等相似耶。彼人作如是念。兔无角。牛有角。若我答言兔无角牛有角。彼当作是言。我不问有无。若言等相似。兔无有角。云何言等相似。彼亦如是。是问论是有是无。是虚是实。以是问论是有是无是虚是实故。佛不答。身异神异。亦复如是。复作是问。沙门瞿昙。如来死后为断为常。乃至广作四句。佛言是不应答。问曰何故佛不答耶。答曰。诸外道以神本无今有。往诣佛所。作如是问。沙门瞿昙如此神本无今有已有。为是常。为是断。佛作是念。毕竟无神。云何本无今有已有。若断若常。是问论。非有非实。以是问论非有非实故。佛不答。复作是问。沙门瞿昙自作自受耶。佛言是不应答。问曰何故佛不答耶。答曰诸外道以我作我受。世尊常说无我。复作是问。沙门瞿昙。他作他受耶。佛言是不应答。问曰何故佛不答耶。答曰诸外道作如是说。自在天作我受。世尊常说自行果报。复作是问。沙门瞿昙无作无受耶。佛言是不应答。问曰何故佛不答耶。答曰诸外道作如是说。苦乐不从因生。佛常说有因有缘。问曰如前三答与答法相应。此云何名答论。乃至不论一句。答曰虽无所说。此是根本答论。所以者何与答理相应。乃至不说一句。于理善通。或有默然于理得胜。况有所说而不胜耶。曾闻。有大论师名奢提罗。至罽宾国。于时佛迹林中有阿罗汉名婆秀罗具足三明。离三界欲。通达三藏。于内外经论无不究畅。时奢提罗。闻彼林中有大论师。即诣其所。到已与尊者婆秀罗共相问讯。种种慰劳在一面坐。时奢提罗。语尊者婆秀罗言。谁当先立论门。婆秀罗答曰我是旧住。应先立论门。然汝远来听汝随意先立论门。时奢提罗作如是言。一切论有报论。时婆秀罗闻是语已。默然而坐。时奢提罗诸弟子辈唱如是言沙门释子今堕负处。从坐欲起而去。时尊者婆秀罗作如是言。善去汝师。若是奢提罗者。自知此事。从彼林中。展转前行。其师作是思惟。沙门释子何故作是言。汝师若是奢提罗者。自知此事。即便自忆。我作是言。一切论有报。彼沙门释子默然不言。便为我论无报。沙门释子已为胜我。即如所念。告诸弟子。今我当往还归谢之。诸弟子言于大众中今已得胜。何须复往。时师复言。我宁于智者边负。不于愚者边胜。即时还诣婆秀罗所作如是言。汝是胜者。我堕负处。汝今是师我是弟子。如是默然而能得胜。何况所说

如佛世尊责诸弟子言。是痴人乃至广说。问曰何以作此论。答曰佛世尊。无相似爱。无相似恚。无相似慢。无相似无明。世尊爱恚已断离于憎爱。断一切诤讼根本。如诸弟子。有烦恼习。如毕陵伽婆蹉。有嗔恚习。彼长老骂恒河神言。小住弊婢。长老阿难则有爱习。以怜诸释子故。尊者舍利弗有憍慢习舍随病药等如是等习。佛世尊永无。所以者何已离一切。诸无巧便烦恼习故。然佛有巧便相似言。爱相似言者。如说。善来比丘。快能出家。嗔恚相似言者。汝是释种婢子诸释是汝大家。慢相似言者。如说我成就十力四无所畏。无明相似言者。如说大王从何处来。如告阿难。园林外何以有高声大声。问曰如来以拔习气根本。何以有如是相似言。答曰为守护受化田故。其事云何。此中应广说破僧因缘所以者何即是此经根本因缘故。诸比丘为提婆达多所坏。尊者舍利弗化使还来。彼诸比丘生大惭愧。兼有疑心。我等亲近提婆达多。所受禁戒将不失耶。以惭愧心往诣佛所。尔时世尊。以亲爱软语而告之言。善来比丘快能出家。说是语时彼诸比丘皆得除去惭愧及其疑心。所以骂庵婆吒言婢子者。欲破其憍慢心。以破憍慢心故。次第二身。得生天上见于圣谛。所以说我成就十力四无所畏者。不知佛功德者。欲令知故。所以言大王从何处来者。欲生谈论次第法故。所以问园林外有高声大声者。欲令阿难生。闲静亲近心故。以如是等众因缘故而作此论

何故世尊责诸弟子言是痴人。此有二义。一是呵责。二言是痴人。今欲说痴人义故作是说。云何名痴人。答曰于佛法中。生于愚痴。佛法者所谓道也。问曰云何于道生愚痴耶。答曰不能令道愚痴。但于自身。增长愚痴。复有说者。亦能令道愚痴。所以者何。以道远离故。道不得自在故。复有说者。佛说断愚痴法。是人于此法。不断愚痴。反增愚痴。故作是说。于佛法中。生于愚痴。无生分别者。令佛功用方便无有果实。其事云何。如妇人不产名无产分。如是闻佛所说。不受圣道胎者。是人于佛法中。名无产分

无果者。无依果解脱果。无得者。于佛法中。无所得故。无味者。不得出离味闲静味道品味寂灭味。故言无味。无利者。无善果利故。譬如良医。四方勤求种种药草。以与病人。为除病故。而彼病人。反以药草。弃粪扫中。生二过患。一自病不愈。二唐捐医功。如是诸佛世尊。作百千万种种苦行。勤求无漏圣道之药。为受化者。而解说之。而闻法者。不能修行。生二过患。一不能自愈诸烦恼病。二唐捐诸佛所行功报。复次生愚痴者。能令自身为非器故。名生愚痴。复有说者。断佛期心故。名生愚痴佛期心者。欲令众生解脱诸苦。彼不能修离苦方便。故言断佛期心。复有说者。断于佛法。令不相续。若彼人身修正行。亦令他人修于正行。如是转转。令多众生修于正行。若自身不能修于正行。亦令他人不修正行。如是转转。令多众生不修正行。如是之人。不能利益一身何况多人。复有说者。本出家所为。而不能得。名生愚痴。复次于佛法中。不如义次行。言是痴人。此中以佛语为佛法行者。应如义次行。然复不能行。故言痴人。复有说者。如所应行名。如义次行。彼于佛法中。不如所应行。名不如义次行。不随顺者。于佛法中。不如法随顺。不次第行者。于佛法中。不作相续行。犯众过恶者。犯于佛法。不如法行者。不行次法。谓圣道也。复有说者。不如义语次行者。不于一切时能行。如婆他利比丘。于三月后。乃受不非时食法。复有说者。不如义次行者。此答前说。于佛法中。生于愚痴。云何生愚痴。答曰于佛教戒。不如义次行。乃至不如法修行次法亦如是。以何等故。佛责诸弟子。此答先所说义。答曰诸佛世尊。常训诲语。如今和上阿阇梨。向诸弟子。以怜愍意。言是痴人。佛亦如是。以怜愍饶益故。言是痴人。诸佛世尊。常以四事教化。一以叹美。二以呵责。三以因他。四以放舍。叹美者。如叹美亿耳等。善哉善哉。比丘能以清妙之音声呗颂经法。呵责者。如呵责优陀耶等。因他者。如转法轮时。为五比丘说法。令八万诸天得道。如频婆娑罗王迎佛。令八万人天得道。如帝释问佛。亦有八万诸天得道。放舍者。如犊子性梵志等。诸应以呵责教化者。若不呵责。则不受化。以是故。佛世尊。呵责弟子。如阿阇梨向近住弟子。和上向同住弟子。以苦切语。而呵责之。而彼和上阿阇梨。非是恶心。但以不顺法故。而呵责之。如父母见子为非法事。欲拥护故。以苦切言。而呵责之。而彼父母。无有恶心。若当诸子为非法事。而彼父母生苦恼心。欲制诸子为非法事。以苦切语。而呵责之。佛亦如是不以恶心。若当应以呵责受化。而不呵责。彼人毕竟无有调伏。是故世尊。而呵责之。复有说者。佛大悲心。重于一切时。常作是念。以何方便。能饶益众生。若如来不呵责提婆达多者。诸余比丘。随从者众。复当数数触娆世尊。若当向无比女。不言如是盛屎尿器。彼女欲心。无由得息。若当不骂庵婆罗吒言是婢子者。彼人无由能破憍慢。若不骂其师弗迦罗婆罗者。亦无由能破憍慢。如是等为增益功德故。亦呵责余人。复次以二事故。呵责余人。一善根不熟者。以呵责故。令善根熟。二善根虽熟。不作方便。以呵责故。令生方便。得于道果。问曰以何义故言痴人耶。为以从痴生故。言是痴人。为以现行痴故。言是痴人。若从痴生者。阿罗汉亦是痴人。何以故阿罗汉身。从痴生故。若以现行故。言痴人者。唯阿罗汉得言不痴。所以者何。阿罗汉不现行痴故。若然者。此经云何通。如说。痴人远去。莫我前住。评曰应作是论。现前行痴。名曰痴人。问曰若然者。唯阿罗汉。是不痴人。此经云何通。乃至广说。答曰此经应如是说。速去比丘。莫我前住。曾闻。佛般涅槃时。长寿诸天。嫌如是事。此天德神力比丘。今者何以在我前立。障我等前。使不得见世尊身。此是我等最后见世尊身。所以者何世尊不久当般涅槃。尔时世尊知诸天心所念。告比丘言。远去莫我前住。复有说者。先说应以呵责得度者。而呵责之。若呵责阿罗汉。得胜进者。佛亦呵责言是痴人。问曰人有爱有恚有慢有见有痴。何以言是痴人。不言是爱等人耶。答曰。以痴遍一切处故。若行彼地痴。即是彼地痴人

阿毗昙毗婆沙论卷第九阿毗昙毗婆沙论卷第十

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    杂犍度智品之六

有六因乃至广说。论曰此六因非佛经说。四缘是佛经说。今欲以因解缘。其事云何。相应因乃至报因是因缘。所作因者是次第缘境界缘威势缘。问曰因摄缘缘摄因。答曰随体性相摄。或有说者。应有差别。云何差别。如相应因。乃至报因是因缘。所作因是威势缘。次第缘境界缘是缘非因。为因摄缘。为缘摄因。缘摄因。非因摄缘。不摄何等次第缘境界缘。复有说者。六因亦是佛经说。如增一阿含六法中说。经久远故。而有亡失。彼尊者迦旃延子。以愿智力。观佛经中说六因处。于此阿毗昙中。依六因而作论。曾闻增一阿含。从一法增乃至百法。今唯有一法增乃至十法在余悉亡失。又于一法中。亡失者多。乃至十法。亡失亦多。曾闻有大德阿罗汉名奢那婆数。是尊者耆婆迦和上。彼尊者般涅槃时。即日有七万七千本生因缘。有一万阿毗昙论。灭不复现。从是以后。更不复行。一论师灭。有尔所经论。更不复行。何况若百若千诸论师灭。复有说者。虽无有经一处全说六因。处处经中。别说六因中一一因问曰若然者。何经中说相应因。答曰如说是名见道根本信名不坏智相应。此经说相应因。何处说共生因者。如说眼缘色生眼识。亦生共生受想等。此经说共生因何处说相似因者。如说此人成就善法。亦成就不善法。此人不善法灭。善法更生。此经说相似因。何处说遍因者。如说比丘若有所思。有所分别。是名起使。何处说报因者。如说修行广布杀生。身坏命终。生地狱中。受不善报。此经说报因。何处说所作因者。如说以二因二缘。生于正见。乃至广说。此经说所作因。如是等经。皆说六因。此犍度分别因不分别缘。见犍度。分别缘不分别因。问曰何故彼尊者依六因作论。答曰以此六因。断无因恶因者意故。复有说者。彼尊者所以依六因作论者。欲显现四种果。如观掌中阿摩勒故。若说相应共生因。即显现功用果。若说相似因遍因即显现依果。若说报因。即显现报果。若说所作因。即显现威势果。以是事故。依六因作论

云何相应因。答曰受于受相应法相应因中因。受相应法于受相应因中因。问曰何故此法展转为因。答有为法。性羸劣故。义言问受法不用想。能所觉不受。当答言。不能如是余法相离。不能有所作。是故心心数法。展转相长养。展转相增益。展转相依。而能负重。如二苇束相依而住。众多亦然。如以一绳不能挽大材。多绳则能。彼亦如是。问曰何故不说心耶。答曰。或有说者。彼作经者意欲尔。乃至广说。复有说者。应说心心数法相应因中因。乃至广说。而不说者。当知此义是有余说。复有说者。此文说诸因。义不尽。若尽说者。应作是说。云何相应因心心数法相应因中因。云何共生因一切有为法。云何相似因过去现在法。云何一切遍因过去现在一切遍使。及使相应共有法。云何报因不善及善有漏法。云何所作因一切诸法。应如是说诸因。若不说者。当知说诸因义不尽。复有说者。已说在先所说受相应法中。其义云何。如说受受相应法相应因中因。乃至广说。问曰若然者何以不即心名说耶。答曰等义是相应义。此心是宗主。如偈说心是第六增上王。复有说者。以心故名相应不相应法。如说是名心相应法。是名心不相应法。如是想思触作观欲解脱念定慧慧相应法相应因中因。乃至广说。问曰何以但说十大地数法。不说余数法耶。答曰或有说者。彼作经者意欲尔。乃至广说。复有说者。应说而不说者。当知此义是有余说。复有说者。诸界诸地诸心诸种中可得者说。余数法与上相违故不说

问曰云何是相应义。答曰等义是相应义。问曰若等义是相应义者。此数法于心。或多或少。于善心多。于染污心少。于染污多。于不隐没无记少。于欲界系多。于色界系少。于色界系多。于无色界系少。于有漏多。于无漏少。如是者云何等义是相应义。答曰以体等故。言等义是相应义。若当一心中有二受一想。如是不名为等。非相应义。一心一受余数法亦尔。以是故等义是相应义。复有说者。等不相离义。是相应义。复有说者。等不别异义。是相应义。复有说者。等同受义。是相应义。如车载时。诸分皆载。无不载者。如是心车受缘时。诸大地。于缘等受。无不受者。复有说者。等同受义。是相应义。非前后故。如秋时群鸽一时诣场一时食一时起。如是心心数法。于缘一时造。一时所作。一时灭复有说者。合义是相应义。如水乳不相妨故共合。如是此法与彼法。不相妨故相应。复有说者。等相爱义。是相应义。如人更相随顺言是相爱。如是此法与彼法。更相随顺。言是相应。尊者婆已说曰。有四事等故。是相应义。所谓时所依行境界。时者同一刹那。所依者同一所依。行者同于一行。境界者同行一境界。以是事故。是相应义。复有说者。苇束义是相应义。如苇二束多束相依而住。如是心心数法。性羸劣故。一一不能生。不能取缘。心与十大地合。能行世能取果。能知境界。能有所作。复有说者。系材义是相应义。如一斤麻不能系材。若多合为索则能系材。如是心大地法。广说如上。复有说者。相牵渡河义。是相应义。相牵者展转相牵手。如山谷中驶河。一人则不能渡。若与多人。更相牵手。然后能渡。如是心与大地。广说如上。复有说者。同伴义是相应义。如旷野道。多诸盗贼恶兽。一人则不能过。若集多人。展转相因。然后能过。如是心与大地。广说如上。尊者和须蜜说曰。云何是相应义。相生义是相应义。问曰若然者眼识能生意识。彼是相应耶。答曰所依异。若同所依。能相生者。是相应义。复次不别异义。是相应义。问曰若然者四大亦不别异。是相应耶。答曰四大无有所依。若有所依。不别异者是相应义。复次有所缘义是相应义。问曰若然者五识亦有所缘。是相应耶。答曰所依各异。若同所依。同所缘。是相应义。复次同一缘义。是相应义。问曰若然者眼识意识。同于一缘是相应耶。今现见多人俱共生心。同观初月。是相应耶。答曰所依各异。若同所依。同于一缘。是相应义。复次合义是相应义。问曰若然者寿命暖气识。合在一处是相应耶。答曰彼二无所依。若有所依。亦有合相是相应义。复次一时生义是相应义。问曰若然者四大一时生是相应耶。答曰四大无所依。若有所依。一时俱生是相应义。复次俱生俱住俱灭。是相应义。问曰若然者心回转。色心不相应行。俱生俱住俱灭。则相应耶。答曰无有所依。若有所依。俱生俱住俱灭。是相应义。复次同一所依。同一行。同一所缘是相应义。问曰何以知同一所依同一行同一所缘是相应耶。答曰复何以知同一所依同一行同一所缘非是相应义耶。复次同作一事义是相应义。问曰若然者忍智同作一事是相应耶。答曰彼不同时生。若同时生。同作一事是相应义。尊者佛陀提婆说曰。同伴义是相应义。如识随所缘事。为诸数名。离于俱生。是相应义。尊者瞿沙说曰。同一依同一行同一缘。是相应义。所以者何有为法性羸劣。展转相因力生。不见有一大地独行世者。是故说名相应。此相应因。于三世中。决定能生功用果

云何共生因。乃至广说。问曰。相应因共生因有何差别。答曰。或有说者。若有相应因。则有共生因。颇有共生因非相应因耶。答曰有诸不相应共生因也。问曰。此事可尔所问差别者。于一刹那中受与想有二因。所谓相应因共生因。有何差别。答曰不相离义。是相应因义。同一果义。是共生因义。复有说者。同一所依。同一行。同一缘。是相应因义。同一生一住一灭。是共生因义。复有说者。牵手渡河义。是相应因义。自勤力渡义。是共生因义。复有说者。共财义。是相应因义。能起义是共生因义。复有说者。等义是相应因义。不相离义。是共生因义

云何共生因。答曰心与数法。是共生因中因。乃至广说。先不说心。今则说之。心与数法。是共生因中因。数法转还与心是共生因中因。心与心回转身口业。是共生因中因。身口业者。谓禅无漏戒。问曰何以不说心回转身口业与心是共生因中因。答曰应说而不说者。当知此义是有余说。复有说者。前后广说。中说则略。如所作因前后广说中说则略。此亦复尔。复有说者。心于身口业与因。不随其事。身口业于心随其事。不与其因。如王于其眷属。与其饮食饶益不随其事。眷属于王随其事。不与饮食饶益。如是心身口业。乃至广说。复有说者。身口业从心起属于心。从心生故。是共生因。身口业不能起心。心不属业。亦不从生故。非共生因。评曰不应作是说。如是说者好。心与心回转身口业共生因。当知心回转身口业。与心共生因中因。所以者何同一果同一所作故。问曰若然者何以不说。答曰上已广说故。心不相应行共生因中因。问曰何等是心不相应行。答曰或有说者。心自体生。生与心共生因中因。复有说者。心与自体生老住灭。共生因中因。生与心共生因中因。非老住灭。所以者何增长义是因义。彼是散坏义。复有说者。心与生等生等与心共生因中因。复有说者。心与心数法。生等共生因中因。心生等与心共生因中因。评曰不应作是说。如是说者好。心与心数法。生等共生因中因。心数法生等与心共生因中因。问曰若然者此说云何通。如说除身见生老住灭。诸余苦谛。于身见非共生因。答曰应作是说。除身见相应法生老住灭。诸余苦谛。于身见非共生因。而不说者。当知此义是有余说。复次共生四大共生因中因。诸作是说。四大势无偏者。地大水火风大。共生因中因。三大于地大。共生因中因。诸作是说。四大势有偏者。地大于三大。共生因中因。三大于地大。共生因中因。所以者何地大则有多体。一体与多体。是共生因。多体于一体。是共生因。乃至风大亦如是。评曰如是说者好。四大若有偏势。若无偏势。地大于三大。三大于地大。作共生因。所以者何地大不因地大生于造色。问曰为生已是因。为未生是因。答曰生亦是因。未生亦是因。所以者何生已未生。尽堕因义中。如波伽罗那说。云何从因生法。一切有为法。如彼所说。生与未生。悉是从因生法。此亦如是。问曰造色为有共生因不耶。答曰有。所以者何以一切有为法尽有共生因故。问曰造色与造色。有共生因不耶。答曰无。所以者何自体不与自体作共生因。复有说者。造色与造色。作共生因。其事云何。如眼根共生微尘展转共生因。评曰不应作是说。所以者何有对造色。不得还与有对造色作共生因

一切心尽有俱共回转。所谓数法及生等。非一切心尽有心回转。色有十事。故名回转。云何为十。一共生。二共住。三共灭。四共一果。五共一依。六共一报。七善共善。八不善共不善。九无记共无记。十共堕一世中。共一果者。谓解脱果。共一依者。谓依果。共一报者。谓报果。总而言之。有十事。如世俗断结道回转有八事。除不善无记。除世俗断结道回转。诸余善有漏回转有七事。除解脱果。不善无记无漏断结道回转有七事。除报果。不善无记除无漏断结道回转。诸余无漏回转有六事。除解脱果报果。不善无记不善心回转有七事。除解脱果。善无记无记心回转有六事。除解脱果报果善不善。是故总而言之。有十事。心于心数法回转有五事。一共所依。二共所行。三共所缘。四共果。五共报。数法回转于心。亦同有五事。心与心回转色心不相应行有二事。一果二报。心回转色心不相应行。与心回转有二事。一果二报。问曰何者是回转体性。答曰是四阴五阴。如色界是五阴。欲界无色界是四阴。所以者何。欲界无色界。无心回转戒。此是回转体性。是我是物是相是分是性。已说体性。所以今当说。问曰回转是何义。答曰随顺义。是回转义。取一果义。是回转义。同作一事义。是回转义。如义言。如汝等所作。我等亦作是回转义

问曰何故欲界戒。不与心回转。答曰非其田非其器非其地。以非田非器非地故。复有说者。以欲界非是定地非修地非离欲地。此中戒亦不与心回转。色界是定地修地离欲地。彼中戒与心回转。复次义言。欲界戒语欲界心。汝能为我。若破戒。若起破戒心烦恼。作拥护不。欲界心答言不能。戒言汝若不能。我何为随顺汝耶。犹如有人。怖畏怨家。语他人言。汝能为我作覆护不。我当随顺汝。他人答言不能。其人语言。汝若不能者。我何为随顺汝耶。彼亦如是。色界心能为破戒及起破戒烦恼。而作拥护。是故彼戒随顺于心。问曰一切色界善心。尽有回转戒色不。答曰不尽有也。初禅中。有六善心。无回转戒色。三善识身闻慧死时善心起作善心。二禅三禅四禅中。有二善心。无回转戒色。闻慧死时善心无色界无戒。问曰何故无色界无戒。答曰非其田故。乃至广说。戒与色俱无色界。无色故无戒。复有说者。戒是四大造。无色界无四大故无戒。问曰无无漏四大。亦无无漏戒耶。答曰无漏戒。不以四大故是无漏。以心故是无漏戒。复次戒对治破戒及起破戒烦恼。无色界无破戒及起破戒烦恼。是故无戒。问曰何故无色界无破戒及起破戒烦恼对治耶。答曰破戒及起破戒烦恼。是欲界法。无色界于欲界有四事极远。谓所依(所依者是次第缘)。所行。所缘。对治极远。问曰若然者。二禅三禅四禅。无犯戒及起犯戒烦恼对治。彼亦无回转戒色耶。答曰对治有二种。一断对治。二过患对治。二禅三禅四禅。虽无断对治。有过患对治。如世尊说。不动法心解脱。圣弟子入三昧。断不善法修善法。尔时彼身无不善法。以过患对治故。作如是说。无色界。无过患对治。亦无断对治

有二种戒。一道俱生。二定俱生。道俱生戒。是无漏。定俱生戒。是有漏。若是道俱生戒。非定俱生戒。若是定俱生戒。非道俱生戒。复有说者。道俱生戒。是无漏。定俱生戒。是有漏无漏。是故道作初句。若有道俱生戒。彼有定俱生戒耶。答曰彼若有道俱生戒。亦有定俱生戒。颇有定俱生戒非道俱生戒耶。答曰有谓有漏戒。复有说者。道俱生戒是无漏。定俱生戒是根本禅。是故应作四句。若有道俱生戒。彼亦有定俱生戒耶。若有定俱生戒彼亦有道俱生戒耶。答曰或有道俱生戒非定俱生戒。乃至广作四句。道俱生戒非定俱生戒者。谓未至中间禅无漏。定俱生戒非道俱生戒者。根本禅中有漏戒。道俱生戒亦定俱生戒者。根本禅中无漏。非道俱生戒非定俱生戒者。未至中间禅有漏戒。一切欲界戒。若得道俱生戒。彼亦得定俱生戒耶。若得定俱生戒。彼亦得道俱生戒耶。应作四句。得道俱生戒非定俱生戒者。未离欲得正决定。见道中十五心道比智。离欲者。依未至禅。得正决定。见道十五心圣人。离欲界欲。方便道。九无碍道。八解脱道。未离欲信解脱人。转根作见到方便无碍解脱道。未离欲圣人。起无量心。起不净安般念处。如是等时。得道俱生戒。非定俱生戒。得定俱生戒。非道俱生戒者。凡夫人离欲界欲。最后解脱道。离初禅欲。即以初禅。为方便方便道。最后解脱道。若依二禅边。为方便方便道。最后解脱道。乃至第三禅亦如是。离第四禅欲。若以第四禅为方便方便道。起神通时。五无碍道。三解脱道。离欲凡夫。起无量心。起初第二第三解脱。起胜处。起八一切处。起不净安般念处。依禅起达分善根。无色界死生色界时。色界中上地死。生下地时。如是等时。得定俱生戒。非道俱生戒。得道俱生戒定俱生戒者。离欲人依未至禅。得正决定。道比智依上地。得正决定。见道十五心道比智圣人。离欲界欲。最后解脱道。离初禅欲。方便道。九无碍道。九解脱道。如是乃至离非想非非想处欲。离欲信解脱人转根。得见到方便无尽解脱道时。解脱阿罗汉转根。得不动时。方便道。九无碍。九解脱道。勋禅时。三心起神通时。五无碍道三解脱道。离欲圣人。起无量心解脱胜处。一切处不净安般念处。辩无诤愿智半多俱提迦。空无想无愿空无相无愿灭定微细相。如是等时。得道俱生戒。得定俱生戒。不得道俱生戒定俱生戒者。除上尔所事。若舍道俱生戒。亦舍定俱生戒耶。乃至应作四句。舍道俱生戒非定俱生戒者。得须陀洹果。得斯陀含。顺次得阿那含。未离欲信解脱转根。得见到斯陀含果。于胜进道退。须陀洹果胜进道退。是时舍道俱生戒。不舍定俱生戒。舍定俱生戒不舍道俱生戒者。凡夫人离欲色界欲退时。凡夫人圣人。欲色界命终。生无色界。色界命终。生欲界中。是时舍定俱生戒。不舍道俱生戒。舍道俱生戒亦舍定俱生戒者。依禅得阿那含果阿罗汉果。离欲信解脱转根。得见到时。解脱转根得不动。退阿罗汉果。阿那含胜进道退阿那含果。是时舍道俱生戒。亦舍定俱生戒。不舍道俱生戒不舍定俱生戒者。除上尔所事。若成就道俱生戒。亦成就定俱生戒耶。乃至广作四句。成就道俱生戒非定俱生戒者。生欲界中。未离欲圣人。是名成就道俱生戒非定俱生戒。成就定俱生戒非道俱生戒者。生欲界中。离欲凡夫人。亦生色界中。是名成就定俱生戒非道俱生戒。俱成就者。生欲界中圣人。离欲界欲。亦生色界中。是名俱成就。俱不成就者。生欲界凡夫人。不离欲。生无色界凡夫人。是名俱不成就。若不成就道俱生戒。亦不成就定俱生戒耶。乃至广说作四句。前成就初句作第二句。第二句作第一句。第三句作第四句。第四句作第三句

有四种戒。一逮解脱戒。二禅戒。三无漏戒。四断戒。逮解脱戒者欲界戒。禅戒者色界戒。无漏戒者道俱生戒断戒者禅戒无漏戒。其事云何。离欲界欲。九无碍道中。世俗回转色。是名禅戒断戒。离欲界欲。九无碍道中。无漏回转色。是名无漏戒断戒。问曰何故离欲界欲。九无碍道中回转色。名断戒耶。答曰以离欲界欲九无碍道中回转色。是犯戒及起犯戒烦恼对治。以是事故。应作四句。若是禅戒。彼亦是断戒耶。若是断戒。亦是禅戒耶。乃至广作四句。是禅戒非断戒者。除离欲界欲九无碍道中回转色。诸余世俗回转色。是名禅戒非断戒。是断戒非禅戒者。离欲界欲九无碍道中无漏回转色。是名断戒非禅戒。俱是者离欲界欲九无碍道中世俗回转色。是名俱是。俱非者除离欲界欲九无碍道中无漏回转色。诸余无漏道回转色。是名俱非。若是无漏戒。彼亦是断戒耶。乃至广作四句。是无漏戒非断戒者。除离欲界欲九无碍道中无漏回转色。诸余无漏回转色。是名无漏非断戒是断戒非无漏戒者。离欲界欲九无碍道中世俗回转色。是名断戒非无漏戒。俱是者离欲界欲九无碍道中无漏回转色。是名俱是。俱非者除离欲界欲九无碍道中世俗回转色。诸余世俗回转色。是名俱非

问曰。此四种戒。若成就者。成就几种耶。答曰。或有但成就逮解脱戒。或有但成就禅戒。或有但成就无漏戒。无有但说成就断戒者。或有成就逮解脱戒禅戒者。无有但成就逮解脱戒无漏戒者。无有但成就逮解脱戒断戒者。或有但成就无漏戒禅戒者。或有但成就禅戒断戒者。无有但成就无漏戒断戒者。或有成就逮解脱戒禅戒无漏戒非成就断戒者。或有成就逮解脱戒禅戒断戒非成就无漏戒者。无有成就逮解脱戒无漏戒断戒非禅戒者。或有成就禅戒无漏戒断戒非成就逮解脱戒者。或有成就四种者。成就逮解脱戒非余者。生欲界中受戒。不得色界善心者也。但成就禅戒非余者。生欲界中不受戒。具缚凡夫人。得色界善心。生第二第三第四禅凡夫人也。但成无漏戒非余者。圣人生无色界者也。但成就逮解脱戒禅戒非余者。生欲界中受戒具缚凡夫人。得色界善心者也。但成就禅戒无漏戒者。生欲界圣人不受戒。欲界修道所断具缚圣人。生二禅三禅四禅者也。成就禅戒断戒非余者。生欲界中凡夫人。不受戒离欲界欲。一种乃至九种凡夫人。生初禅中者也。成就逮解脱戒禅戒无漏戒。非断戒者。生欲界中。受戒圣人。欲界修道所断具缚者也。成就逮解脱戒禅戒断戒。非无漏戒者。生欲界中。凡夫人受戒。离一种欲乃至九种是也。成就禅无漏断戒。非逮解脱者。生欲界中。不受戒圣人。离一种欲乃至九种。生初禅中圣人者也。成就四种者。生欲界中。受戒圣人。离一种欲乃至九种

问曰此四种戒。几与心回转。几不与心回转。答曰三与心回转。所谓禅无漏断戒。一不与心回转。所谓逮解脱戒。问曰何故逮解脱戒。不与心回转。答曰非其田乃至广说。复次逮解脱戒粗。心回转戒细。复次逮解脱戒重。心回转戒轻。复次逮解脱戒从有作生。心回转戒从心生。复次逮解脱戒从他生。心回转戒从自生。复次逮解脱戒从众聚和合生。心回转戒不尔。复次逮解脱戒假施设受得。心回转戒从法而得。复次逮解脱戒行不及心。心回转戒行则及心。复次逮解脱戒为破戒所蔽。心回转戒不为破戒所蔽。复次逮解脱戒为恶心劫杀意所蔽。心回转戒不为所蔽。复次心回转戒与心俱生住灭。逮解脱戒不尔。复次心回转戒与心同一果一依一报。逮解脱戒与上相违。复次法应如是。心若善心。回转法亦善心。若不善无记心。回转法亦不善无记。逮解脱戒是善。若与心回转者。唯与善。心回转。不善无记心应断。复次法应如是。欲界系心。欲界系回转。色界系心。色界系回转。无色界系心。无色界系回转。不系心。不系回转。逮解脱戒。是欲界系。若与欲界系心回转。色无色界系心。及不系心。现在前时应断。复次法应如是。学心学回转。无学心无学回转。非学非无学心。非学非无学回转。逮解脱戒。是非学非无学。若与非学非无学心回转。学无学心现在前时应断。复次法应如是。见道所断心。见道所断回转。修道所断心。修道所断回转。无断心。无断回转。逮解脱戒。是修道所断。若与修道所断心回转。见道所断心。无断心。现在前时应断。复次逮解脱戒。若与心回转者。应未来世修。若未来世修。亦无有过。应未来世成就。然无未来世成就。复次逮解脱戒。与心回转者。界地还生时应得。若从色无色界命终。生欲界中。相续心时应得。有如是过。则无三种人差别。谓住戒住非戒。住非戒非非戒。复次逮解脱戒。以四事故舍。一舍戒时。二变成。二形时。三死时。四断善根时。若当逮解脱戒与心回转者。不以此四事亦应舍。复次逮解脱戒。从受以后。一切时生。谓眠狂迷闷等时。若逮解脱戒。与心回转者。有心时则有。无心时应断。复次逮解脱戒。与心回转者。则受戒人。无有上下。然有上下。欲令无如是等过故。逮解脱戒。不与心回转。暖法回转戒。是破戒舍对治。顶法忍法世第一法。见道修道中道比智回转戒。是时于破戒。作二种对治。远分对治。持对治。离欲界欲。方便道回转戒。与破戒作舍对治。离欲界欲。初无碍道回转戒。与破戒作远分对治持对治。与起破戒烦恼。作断对治舍对治。七无碍道回转戒。与破戒作远分对治持对治。与起破戒烦恼。作舍对治断对治远分对治持对治。第九无碍道。与破戒作断对治远分对治持对治。与起破戒烦恼。作断对治舍对治远分对治持对治。除上所说回转戒。诸余回转戒。与破戒及起破戒烦恼。作远分对治持对治。问曰如法智回转戒能舍破戒及起破戒烦恼非比智。何以言比智有回转戒耶。尊者和须蜜答曰彼是因故。复次属彼故。复次与彼相续故。复次从彼生故。复次此已住对治法故。所以者何。若当法智不舍破戒及起破戒烦恼者。比智当舍。复次对治法多比智与破戒及起破戒烦恼。虽不作舍对治断对治。而作远分对治持对治。尊者佛陀提婆说曰。若当法智有回转戒比智无回转戒者。则虽有能对治戒。然世尊说。有能对治戒。有不能对治戒

问曰为欲界戒多。为色界戒多。答曰或有说者。欲戒多。所以者何以根本业前业后业可得故。又以从正性罪遮罪可得故。色界虽有根本业性业。非余处可得。评曰应作是说。色界戒多。但未至禅所可摄戒。与欲界戒等。余者则多。问曰有漏戒多。无漏戒多。答曰或有说者。有漏戒多。有漏戒有二种。一种少入无漏戒。少无漏戒有一种。一种少入。评曰应作是说。无漏戒多。但苦法忍回转戒。则与有漏戒等。余则是多。问曰苦法忍回转戒多。尽智无生智回转戒多。答曰或有说者。苦法智回转戒。于苦法忍回转戒一倍胜。如是次第转倍胜。乃至尽智无生智。于施设经说善通。所谓苦法智胜苦法忍。乃至道比智胜道比忍。离欲界欲。方便道。一无碍一解脱则胜。如是转转胜。乃至第九解脱。所以者何。如渐渐舍破戒及破戒烦恼。彼戒亦渐渐增益。如是次第转转一倍胜。乃至尽智无生智。评曰如是说者好。如苦法忍戒。乃至尽智无生智戒。等无有异。所以者何同从身口七善生故。问曰若然者。施设经说云何通。答曰从因生增益故。作如是说。如苦法智从苦法忍因生而得增益。乃至尽智无生智亦如是。如是等戒。尽是七善。问曰。佛戒多声闻戒多。答曰或有说者。声闻戒多非佛。所以者何佛唯有一界身戒。声闻有二界身戒。评曰应作是说。佛戒多。所以者何力无畏大悲三不共念处。如是等戒。声闻辟支佛所无

问曰生欲界中。得阿罗汉道。得几地身回转戒。答曰如西方沙门。作如是说。得二十六地身回转戒。所以者何初禅地有三种。所谓梵迦夷梵富楼大梵。如罽宾沙门说曰。得二十五地身回转戒。所以者何初禅有二处所。所谓梵迦夷梵富楼。大梵天即梵富楼摄故。犹如村落与阿练若处。得彼地身回转戒。未来世中修。不得起现在前。所以者何即彼地报身。能起彼地身回转戒现在前。诸余地身回转戒。成就不起现在前。生无色界。成就不起现在前。所以者何此戒是六地所摄。未至禅乃至第四禅。无色界自地无戒。下地所摄。不能起现在前。问曰诸生下地。尽能起现在前耶。答曰不尽起也。所以者何一切功德。不必尽起现在前故。过恶犹不尽起现在前。何况诸功德。诸功德皆从方便生。如先所说。依彼地报身。起彼地身回转戒。无有一时起二地报身现在前者。何况多也。是故得二十五地身回转戒。不尽起现在前

问曰何故世尊弟子。生无色界。成就道俱生戒。不成就定俱生戒。何以故无色界阿罗汉。成就道俱生戒。不成就定俱生戒。答曰或有说者。世俗戒缚是系法。是以不成就。无漏戒不缚。不是系法。是以成就。复有说者。世俗戒堕在界中。堕在地中。是故不成就。无漏戒。虽在地中。不堕界中。是故成就

问曰诸佛世尊。有百年时身戒。乃至八万岁时身戒。若百年时。身得阿耨多罗三藐三菩提。为得八万岁时身戒不耶。若得者。云何此身得异身中戒。若不得者。施设经说云何通。如说。诸佛世尊。皆等应作是论得。问曰若然者。云何此身得异身口戒。答曰若以此身。得异身戒。复有何过。复次百年时。得阿耨多罗三藐三菩提。于百年时身所得戒。名得在身中成就现在前。异身中戒。名得不在身中。名成就不现在前。八万岁时身。得阿耨多罗三藐三菩提。于八万岁时身所得戒。名得在身中成就现在前。于余异身。名得不在身中。名成就不现在前。复有说者。不得。问曰若然者。施设经说云何通。如说诸佛皆等。答曰即彼经说。以三事故等。过去世积行皆等。所得法身皆等。利世间皆等。过去世积行皆等者。如一佛于三阿僧祇劫。行四波罗蜜。然后得阿耨多罗三藐三菩提。诸佛皆尔。所得法身皆等者。如一佛成就力无畏大悲三不共念处诸佛亦尔。利世间等者。如一佛度百千万那由他众生令入涅槃。诸佛亦尔。复次根等故言等。所以者何。皆住增上根故。戒亦等。皆得增上戒故。地亦等。皆依第四禅得阿耨多罗三藐三菩提故

云何相似因。乃至广说。问曰何以作此论。答曰为止无过去未来法现在是无为法。以如此文止无过去未来者意故。复次为止说相似法沙门意故。彼作是说。心唯与心作因。受唯与受作因。乃至慧唯与慧作因。为止如是意故。作如是说。心与心数法。心数法与心。作相似因。以如是事故。而作此论

问曰以何等故作如是说。前生善根。与后生善根及善根相应法。作相似因。而不作是说。过去善根。与现在善根及善根相应法。作相似因。答曰。欲现过去。有前后义故。过去法众多。应有前后。若作是说。过去法与现在作相似因者。则不明过去于过去有相似因。若作是说。则明过去于过去有相似因。问曰以何等故。前生善根。不说相应法。后生善根。说相应法。答曰应作是说。前生善根。善根相应法。与后生善根及善根相应法。自界中作相似因中因。而不说者。当知此是有余说。如先所说。此文说因处不尽。复有说者。为止说相似法沙门意故。彼作是说。善根与善根。作相似因。非善根相应法。善根相应法。与善根相应法。作相似因。非善根不善无记根亦如是。为止如是意故。作如是说。善根与善根相应法。善根相应法与善根。作相似因。自界中者。欲界还与欲界。色界还与色界。无色界还与无色界。如说自界。自地亦如是。初禅地还与初禅地。乃至非想非非想处还与非想非非想处。过去善根与未来现在。过去现在与未来善根。作相似因中因。问曰何以复作此论。答曰若别世说。于文不乱。乃至广说。自界无记根亦如是。前生不善根。乃至广说。问曰以何等故。此不善根中。不说自界耶。答曰以不善根唯在欲界故。复有说者。应说自种。见苦所断种还与见苦所断种。乃至修道所断种还与修道所断种。复有说者。应作是说。说善根已。不善无记根亦如是。问曰若然者不善根唯在欲界。云何言自界耶。答曰以自种故。言是自界。问曰以何等故。不作是说。前生不善根。与后无记根。前生无记根。与后生不善根。作相似因耶。答曰或有说者。应作是说。而不说者。当知此义是有余说。复有说者。若作是说则明。不善根在三界中。无记根唯在欲界。少因则有多果。多因则有少果故

问曰未来世有相似因不。若有者此中何以不说。如说云何相似因。答曰前生善根。与后生善根。善根相应法。自界相似因中因。如是过去与未来现在。过去现在与未来。作相似因中因。而不说未来与未来作相似因中因。若有者云何不二心展转为因。若无者此说云何通。如说若法能与彼法作因。或时而不与彼法作因耶。答曰不也。问曰此法与彼法。或时作因。或时不作因。若法生者则作因。若不生者。则不作因。何以言不也。若无者波伽罗那说云何通。如说非心因法云何。答曰得正决定人初无漏心是也。诸余凡夫。必当得正决定者。初无漏心。问曰如未得正决定者。一切无漏心。是非心因法。何以但说初无漏心耶。若无者。复与此经。余所说相违。如说苦谛。或以身见为因。不与身见作因。乃至广说。身见为因。不与身见作因者。除过去现在见苦所断使及使相应法苦谛。除过去现在见集所断一切遍使及使相应法苦谛。除未来世身见及身见相应法。诸余染污苦谛是。谓以身见为因。不与身见作因。问曰如未来身见不能与未来身见作因。何以故除未来身见及身见相应法。若无者识身经说云何通。如说过去染污眼识诸使所使。亦是因耶。若是因。亦使所使耶。应广作四句。是因不为使所使者。诸使在彼心前。是自界一切遍不缘。若缘已断相应使解脱。为使所使非因者。诸使在心后。彼是自界一切遍缘而不断。亦因亦使者。诸使在彼心前。是自界一切遍缘而不断。相应使不解脱。非因非使者。诸使在彼心后。是自界一切遍非缘。缘者已断他界一切遍使。如过去。未来现在亦应如是。广作四句。问曰过去现在四句可尔。未来云何通。若无者施设经说云何通。如说诸法以四事故决定。一因。二果。三所依。四所缘。若无者云何不无因而有因。无果而有果。答曰应作是说。未来世无相似因。以无故。所以不说。亦无二心展转相因过。问曰若然者如所说。若法能与彼法作因。或时不作因。乃至广说。此云何通。答曰或有说者。此中以二因故作论。所谓相应因。共生因。复有说者以四因故作论。所谓相应因。共生因。报因。所作因复有说者。以五因故作论。除所作因。所以者何一切处不遮故。应作是说。以六因故而作论。问曰有法或与彼法作因。或时不作因。何故作如是说。若法能与彼法作因。或时不与彼法作因。答言不也。答曰此说最后生时。能作一切遍相似因义。从是已后生者。无不以此法为因。问曰若然者此说云何通。如说若法能与彼作次第。或时不作次第。答曰。若彼法未生。问曰次第缘最后生时。亦能作次第缘义。从是已后生者。无不以此为次第缘。何以答言未生不说最后生时耶。答曰应说而不说者。当知此义是有余说。复次现异说异文。若以异文。庄严于义。义则易解。复次现二门义故。现二种略义故。现二种入法性故。现二种炬故。现二事故。现二种文影故。现俱生俱通故。如说最后生因义。亦应说最后生缘义。如说次第缘未生义。亦应说因未生义。说现二门义。乃至广说。如波伽罗那说。非心因法。乃至广说。云何通。答曰此说究竟非心因法。如未得正决定者。一切无漏心未生尽。是非心因法。若得正决定时。初无漏心。是非心因法。诸余无漏心。是心因法。是故彼经说。初无漏心。是非心因法。复有说者。此中不说相似因。此说二种凡夫。所谓能得涅槃者。不能得涅槃者。此中说不能得涅槃者。言是非心因。何以知有不得涅槃者。答曰如此所说。必得正决定者。当知亦有不必得正决定者。如是则所说善通。如此波伽罗那第二所说。除未来身见及身见相应法。此云何通。答曰应作是说。除未来身见相应法。诸余染污苦谛。如是者此亦善通。如识身经说。复云何通。答曰如过去作四句。现在亦应作四句。未来世应作三句。或有是因非使所使。或是因为使所使。或非是因非使所使。是因非使所使者。诸使与彼心相应已断。是因为使所使者。诸使与彼心相应不断。非是因非使所使者。如余缘他使所使。他界一切遍使。应作如是说。而不说者有何意。答曰欲现未来世有前后义故。如施设经说。一切有为法。有四事决定。此义云何通。答曰因者说四因。相应因共生因报因所作因。果者。说三果。功用果报果威势果。所依者说六种。所谓眼识及相应法依眼。乃至意识意识相应法依意。缘者眼识眼识相应法缘色。乃至意识意识相应法缘法。云何不无因而有因无果而有果者。答曰如我义。亦无因而有因。无果而有果。言因者。以时故说非谓无法而有。复有说者。未来世中。有相似因

问曰若然者诸所难者。善通经文。何以不说。答曰。应说而不说者。当知此义是有余说。复有说者。此说相似因不尽。此中唯说因。有力能与果取果者。未来世相似因。不能与果取果。若有者云何不二心展转相因。答曰未来世中。有四行相随从。以通此事。如无常行有四行相随从。苦空无我。亦有四行相随从。如无常行。先生为因。后生三行。不能与无常行作因。余三行亦如是。若作是说。依第四禅。得阿罗汉。彼第四禅相随从。有九地无漏未来世修。若出彼禅欲起无漏。初禅现在前时。则无有因。何以故。以无相随从故。若然者过去现在无漏道。则有作相似因者。有不能作者。复违此经文。前生善法。与后生善法。乃至广说。欲令无如是等过者。未来世中。无相似因

问曰色法为有相似因不。答曰譬喻者作如是说。色法无相似因。以缘力故生。其事云何。如凿地深百肘出泥。天雨日曝风吹。而便生草。如此泥未曾生物。如屋上生草树。此处亦未曾生物。谁与彼作相似因。问曰若然者彼文云何通。如说过去四大。与未来四大因威势缘。彼作是答。我无如是经。欲去如是文。故作如先说。以是事故。不必须通。若欲必通者。当云何通。彼威势缘有二种。有近有远。有在此身。有在余身。诸近在此身者。说名为因。若远在余身者。说名为缘。阿毗昙人。作如是说。色法有相似因。问曰若有者。譬喻者说云何通。答曰以有种子在彼法中住。但未得生芽因缘故不生。若得便生。屋上生草树者。若鸟衔种来。若风吹来然后乃生。以是事故。色法有相似因。复有说者。色法有相似因。亦与相似法作因。亦与不相似法作因。与相似法作因者。与此身相似作因。不与余身相似作因。与此身相似作因者。如此身歌罗罗时。与歌罗罗。作相似因。作不相似因者。如歌罗罗与老作因。如此身阿浮陀时。与阿浮陀作因。乃至老时亦作因。与歌罗罗作缘。如是此身老时。与老时作因。与余时作缘非因。若作如是说者。初歌罗罗则无因。最后从色则无果。复有说者。色法有相似因。与相似法作因。不与不相似法作因。亦与此身相似法作因。亦与余身相似法作因。余身相似法。与此身相似法作因。此身相似法亦与余身相似法作因。于余时作缘非因。如是余身老时。与此身老时作因。此身老时。复与余身老时作因。于余时作缘非因。复有能者。色法有相似因。与相似法作因。亦与不相似法作因。与此身作因。亦与余身作因。如余身歌罗罗与此身歌罗罗作因。此身歌罗罗。乃至与老时作因。此身歌罗罗。与余身歌罗罗作因。乃至与余身老时作因。余身阿浮陀。与此身阿浮陀作因。乃至老时作因。此身阿浮陀。与余身阿浮陀作因。乃至老时作因。于歌罗罗时作缘非因。余身老时。与此身老时作因。此身老时。与余身老时作因。于余作缘非因。评曰。应作是说。余身十时。与此身十时作因。此身十时。与余身十时作因。外法当知随所应亦如是说

善五阴展转为因。染污亦如是。展转为因。不隐没无记五阴。或有说者。展转为因。复有说者。不隐没无记四阴。与不隐没无记色阴为因。色阴不能与不隐没无记四阴作因。何以故。性羸劣故。复有说者。不隐没无记色阴。与不隐没无记四阴作因。不隐没无记四阴。不与不隐没无记色阴作因。所以者何四阴是胜法。色阴是下法。胜法不为下法作因。复有说者。不隐没无记四阴。不与色阴作因。不隐没无记色阴。不与四阴作因。不隐没无记四阴。展转为因。不隐没无记四阴有三种。谓威仪工巧报。彼三种展转为因不。答曰。或有说者。展转为因。复有说者。报与报作因。亦与威仪工巧作因。威仪与威仪作因。亦与工巧作因。不与报作因。胜法不与下法作因故。工巧与工巧作因。非报非威仪。胜法不与下法作因故。复有说者。此三法展转为因。所以者何。同在一界。同一缚故。评曰。不应作如是说。前所说者好

染污法有九种。下下下中下上。中下中中中上。上下上中上上。问曰。彼为展转作因不。答曰。展转为因。问曰。若然者。云何有九种。答曰。对治有九种故。此法亦有九种。其事云何。如下下修道对治上上烦恼。乃至上上修道。对治下下烦恼。以对治有九种故。此法亦有九种复有说者。以现前行有九种故。善法亦有九种。从下下乃至上上。问曰。此法为展转为因不。答曰善法有二种。有生得善方便善。彼生得善九种相。于展转为因。问曰。若然者。云何有九种。答曰。以报有九种故。此法有九种。如最胜善能生最胜报。乃至下下善。生下下报。复有说者。以此法现前。行有九种故。方便善亦有九种。下下乃至上上。问曰。此法展转为因不。答曰不也。下下与下下作因。乃至与上上作因。生得善与方便善作因。以方便善胜故。方便善不与生得善作因。以生得善劣故。方便善有三种。闻慧思慧修慧。问曰。此展转作因不。答曰不也。闻慧与闻慧作因。亦与思慧修慧作因。思慧与思慧作因。不与修慧作因。以不同界故。不与闻慧作因。以闻慧下故。修慧与修慧作因。不与闻慧思慧作因。以异界故。以下故。修慧有四种。有暖顶忍世第一法。暖法与暖法作因。乃至与世第一法作因。顶法与顶法作因。乃至与世第一法作因。忍法与忍法作因。亦与世第一法作因

欲界变化心有四种。初禅果乃至第四禅果。问曰。此四种心。为展转作因不。答曰。初禅果为初禅果作因。乃至第四禅果。为第四禅果作因。所以者何。如禅不展转作因。彼果亦如是。复有说者。初禅果与初禅果作因。乃至与第四禅果作因。二禅果与二禅果作因。乃至与第四禅果作因。三禅果与三禅果作因。亦与第四禅果作因。第四禅果与第四禅果作因。复有说者。尽展转为因。所以者何。俱堕一界。同一缚故。评曰。如第二说者好。问曰。如初禅地。有识身有变化心为展转作因不。答曰。识身为变化心作因。非变化心为识身作因。所以者何。胜法不为下法作因故

问曰。若相似因。能取果者。亦能与果耶。答曰。若能与果。亦能取果。颇有能取果不能与果耶。答曰。有阿罗汉最后阴。如此是总说。今当分别说。善不善无记。问曰。若善相似因。能取果者。亦能与果耶。若能与果者。复能取果耶。乃至广作四句。取果不与果者。断善根时。最后舍善根得。与果不取果者。善根得最初现在前。取果与果者。如不断善根余时。不取果不与果者。除上尔所事。若不善相似因。能取果亦能与果耶。乃至广作四句。能取果不能与果者。如离欲界欲最后舍不善得。能与果不取果者。离欲界欲。退不善得最初生。能取果能与果者。如不离欲者余时。不取果不与果者。除上尔所事。若隐没无记法相似因。能取果亦能与果耶。能与果亦能取果耶。乃至广作四句。能取果不能与果者。如离非想非非想处欲。最后舍隐没无记得。与果不取果者。退阿罗汉果时。隐没无记得最初生。取果与果者。不离非想非非想处欲余时。不取果不与果者。除上尔所事。若不隐没无记相似因。取果者亦能与果耶。答曰。若能与果。彼亦能取果。若不取果云何与。颇有取果不与果耶。答曰。有阿罗汉最后心。已说善不善无记相。今当说能缘相。若善相似因。能取果。亦能与果耶。若与果亦能取果耶。乃至广作四句。能取果不与果者。善心次第生不善无记心现在前。与果不取果者。若不善心无记心次第善心现在前。取果与果者。如善心次第善心现在前。不取果不与果者。除上尔所事。若不善心相似因。能取果者。亦能与果耶。若与果者。亦能取果耶。乃至广作四句。取果不与果者。如不善心次第。若善心无记心现在前。与果不取果者。如善心无记心次第不善心现在前。取果与果者。如不善心次第不善心现在前不取果不与果者。除上尔所事。若隐没无记心相似因。能取果亦能与果耶。若能与果。亦能取果耶。乃至广作四句。能取果不与果者。隐没无记心次第善不善不隐没无记心现在前。与果不取果者。善不善不隐没无记心次第隐没无记心现在前。取果与果者。隐没无记心次第隐没无记心现在前。不取果不与果者。除上尔所事。若不隐没无记心相似因。能取果亦能与果耶。若能与果亦能取果耶。乃至广作四句。取果不与果者。不隐没无记心次第善不善隐没无记心现在前。与果不取果者。善不善隐没无记心次第不隐没无记心现在前。取果与果者。不隐没无记心次第不隐没无记心现在前。不取果不与果者。除上尔所事。已说相似因有缘相。相似因相续相。今当说。若相似因。取果亦能与果耶。若能与果亦能取果耶。乃至广作四句。善心后相续生二十善心。取果不与果者。除第二心。余十八心。与果不取果者。初心灭在过去。十八心若生现在前。取果与果者。第二心是也。不取果不与果者除上尔所事。不善隐没无记不隐没无记亦如是。颇一刹那顷。若得相似因。亦得相似因因耶。若得相似因因。亦得相似因耶。乃至广作四句。得相似因不得相似因因者。从上沙门果退。住须陀洹果胜进道。本得须陀洹初果现在前。是时不成就见道得。相似因因不得相似因者。如本住须陀洹果胜进道。能与后生沙门果。作相似因。得相似因亦得相似因因者。除须陀洹初心。诸余须陀洹果。曾起现在前。不得相似因亦不得相似因因者除上尔所事。颇一刹那顷。知相似因。不知相似因所缘耶。知相似因所缘。不知相似因耶。乃至广作四句。知相似因不知相似因所缘者。见道中道法智。缘前生苦集灭智分。知相似因所缘不知相似因者。缘未生法智分。知相似因亦知相似因所缘者。道法忍是也。不知相似因不知所缘者除上尔所事

问曰。相似因有增减不。答曰。有其事云何。或有前身烦恼作增上相似因非今身。曾闻阿难入舍卫城乞食时。摩邓伽女。见已随逐而行。所以者何。以五百世中曾为阿难妻。今见阿难欲觉炽盛。无心能离。如长老弥只迦在庵罗林中坐。是时三恶觉意增上。所以者何。曾闻此长老本昔曾于此林处作王。若本五乐自娱乐处则欲觉增上心生厌患。后至余处恚觉增上。所以者何。本为王时。恒于此处。割截人民手足头耳故。恚觉增上心生厌患。复至余处害觉增上。所以者何。曾于此处。系缚鞭打人民。夺其财物故。害觉增上。如是等过去身烦恼。作增上相似因非此身也。或有欲心与恚心作增上相似因。令恚心增上。或有恚心与欲心作相似因。令欲心增上。如说不善。说善无记亦如是。以是事故。当知相似因因有增减。是相似因。定在过去现在世果是依果

阿毗昙毗婆沙论卷第十阿毗昙毗婆沙论卷第十一

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    杂揵度智品之七

云何一切遍因。前生见苦所断一切遍使。乃至广说。问曰。何以作此论。答或有说者。一切结使。尽是遍使。为止如是意故。亦明结使是一切遍非一切遍而作此论。复有说者。此五种所断结。有一切遍非一切遍。为止如是意。明苦集所断使有一切遍非一切遍故而作此论。复有说者。苦集所断使。尽是一切遍。灭道所断使。尽是无漏缘。为止如是意。明苦集所断有一切遍有非一切遍灭道所断使有有漏缘有无漏缘故而作此论。复有说者。诸使通三界者。是一切遍。如诸见疑爱慢无明。为止如是意明通三界使亦是一切遍非一切遍而作此论。复有说者。无明有爱。是一切遍使。如譬喻者说。彼何故作是说耶。答曰。以是根本使故其事云何。无明是前生缘起因。有爱是后生缘起因。为止如是意亦明遍不遍使故而作此论。复有说者。五结是一切遍使。所谓诸见爱慢无明心。此是毗婆阇婆提所说。如说偈

  一切处五法　　能广生于苦
  诸见爱无明　　慢心是为五

为止如是意亦明一切遍不遍使故而作此论。如是为止他义欲显己义亦现法性相应义故而作此论

云何一切遍因。答曰。前生见苦所断一切遍使。乃至广说。问曰。何故不先说过去。答曰。欲现过去世中有一切遍因故。过去法众多。亦有前后。若先说过去。则不现过去世一切遍因。若先作是说。则明过去世有一切遍因。其事云何。若作是说。过去于未来现在。现在于未来。是一切遍因。则不明过去于过去有一切遍因。若作是说。则明过去世有一切遍因。前生见苦所断一切遍使。后生见集灭道修道所断使。乃至广说。问曰。自种一切遍使。与自种一切不遍使作遍因。不若作者。此中何以不说。若不作者。何以他种作。自种不作。答曰。应作是说作。问曰。若然者何以不说。答曰。应作如是问。前生见苦所断一切遍使。后生见苦集灭道修道所断。乃至广说。而不说者。为有何意。答曰。欲明不成义。自种使不说。义已成。是故欲明不成义故是以不说。复次自种于自种。有二种因。所谓一切遍因。相似因他种唯有一切遍因。无相似因故。是以不说。复次自种于自种。有二种增长。所谓一切遍因门。相似因门。他种唯有一切遍因门增长故。是以不说。问曰。何故前生见苦所断一切遍使。不说相应法。后生使说相应法耶。答曰。应作是文。前生见苦所断一切遍使。及相应法。与后生见集灭道修道所断使及相应法。乃至广说。而不说者。当知此义是有余说。复次为止说相似法沙门意故。彼作是说。使还与使作因。不与使相应法作因。使相应法。与使相应法作因。不与使作因。为止如是说者意故。作如是文。使与使作因。亦与使相应法作因。使相应法。与使相应法作因。亦与使作因。自界者欲界还与欲界作因。色界还与色界作因。无色界还与无色界作因。如说自界。自地亦尔。初禅地还与初禅地作因。乃至非想非非想处。还与非想非非想处作因。过去见苦所断。乃至广说。问曰。何以复作此论。答曰。为止言无过去未来以现在世是无为遍于世故。而作此论。一切遍因未分别为分别故。说见苦所断相似略说故。言见集所断亦如是

问曰。一切遍因体性是何。答曰。欲界有十一遍使。见苦所断七。五见疑无明。见集所断四。二见疑无明。如是色无色界亦十一。以是事故。波伽罗那。作如是说。此九十八使。几是一切遍。几非一切遍。答曰。三十三是一切遍。六十五非一切遍。问曰。如见苦所断无明使非一切遍。何以故。言三十三是一切遍六十五非一切遍。答曰。如西方沙门。此文作如是说。二十七是一切遍。六十五非一切遍。六当分别。见苦所断无明使。或是一切遍。或非一切遍。云何一切遍。见苦所断。非一切遍使。不相应无明使。如是说者好。见苦所断。非一切遍使。不相应无明使。若作是说。一切遍使。相应无明。则不摄不共无明。所以者何。彼不与使相应故。云何非一切遍。见苦所断。非一切遍使。相应无明。见集所断亦如是。西方沙门。作如是说。罽宾沙门。何以不作如是说。答曰。是文应如是说。如西方沙门。若不说当知。义则如是。复次分多故。其事云何。见苦所断无明使有十种。七种是一切遍。三种非一切遍。见集所断无明使有七种。四种是一切遍。三种非一切遍。以分多故。说在一切遍使分中。复次彼见苦所断不共无明使。一向是遍。以自功用力生。以是事故。三十三是一切遍。六十五非一切遍。若说身见是一切遍。当知相应无明。亦一切遍。其义已成。边见见取戒取邪见疑。若说如是等是遍。当知相应无明亦是遍若说爱恚慢是非一切遍当知相应无明亦非一切遍。余所不说者是何唯。有不共无明一向是一切遍。以自功用力生。以是事故。作如是说。三十三是一切遍。六十五非一切遍。皆是一切遍体性。乃至广说

已说体性所以今当说。何故言一切遍。一切遍有何义。一切缘义。是一切遍义。于缘中有力义是一切遍义缘中有力义者。能广缘义。是缘中有力义。复次有三种。一切本曾起故是一切遍义。初一切者。是九品使。中一切者。是一切众生。后一切者。是一切有漏法处。问曰。何以知初一切后一切本曾起耶。答曰。如施设经说。一切皆是苦。于是苦法中。无有一法凡夫人于中不起我我所见无有不起断常亦谤无因无作亦起见最胜。第一亦起见净见解脱见是乘凡夫人无有不曾起疑心无智愚闇者。如是等众生。无有不曾起者。以曾起三种一切故。名一切遍。复次若于一刹那。起现在前。能为五种所断作因。能缘五种所断。能令五种所断生愚。问曰。云何能令缘无漏缘使。于缘生愚。答曰。若计于我。则谤于对治及我寂灭先于中愚然后生谤。复次若于一刹那起现在前。则为五种所断作因。亦能缘使。是一切遍义。彼相应法。虽能作因。亦能缘而不能使。非使性故。彼共俱生等。虽能作因。而不能缘。亦不能使。非缘非使性故

问曰。遍使相应共有法。为是一切遍为非一切遍。若是者何以但说三十三使是遍。若非者何以相应共有法。或是一切遍。或非一切遍。答曰。应作是说。非一切遍。问曰。若然者。何以相应共有法。或是一切遍。或非一切遍。答曰。如相应共有法。或是使或非使。如是相应共有法。或是一切遍。或非一切遍。评曰。应作是说。是一切遍。问曰。若然者何以但说三十三是一切遍。答曰。为使故说。所为有二种。一为法二为使。若为使故。说有三十三。若为法故。说是一切遍。复有说者。此文以彰故。说一切遍。一以因故。二以缘故。三以使故。彼遍使相应法。以因以缘故。名一切遍。不以使故。一切遍使。共有法以因故。不以缘不以使。使则以三事故而以为文。以是事故。使共俱生等。是一切遍。问曰。一切遍得。为是一切遍不。尊者僧伽婆修说曰。是一切遍。若一切遍得。非一切遍者。非一切遍。是一切遍耶。此难非难。所以者何。若作是说。色法得非色。非色是色耶。如是说者好。非是一切遍。问曰。何故一切遍。生老住无常。是一切遍得。非一切遍耶。答曰。生老住无常。与一切遍使同一果。常相随不相离。前后不相远得不同一果不相随相离前后相远于彼聚便为非聚。如树皮离树。彼亦如是。问曰。以何等故。见苦见集所断。立一切遍使见灭见道所断。不立一切遍耶。旧阿毗昙人作如是说。此处是一切遍使。族姓生地故。复有说者。见苦集所断使。同一意。同一作。以同意同作故。所为牢固。以牢固故。立一切遍使。彼见灭道所断使意不同。所作亦不同。以不同故羸劣。羸劣故不立一切遍使。犹如城邑村落人民。若意同所作同者。村主怨敌。不能降伏。若彼诸人。意不同所作不同者。则为村主怨敌之所降伏。彼亦如是。复有说者。见苦集所断使。有二种作相应使。亦作缘使。是故立一切遍。见灭道所断使。或作相应使缘使。或唯作相应使。是故不立一切遍使。复有说者。见苦集所断使。安立二足。安立二足者。即上二种使义。见灭道所断使。不安立二足。不安立二足者。即上二种使义。复有说者。见苦集所断使。于缘得增长。云何于缘增长。答曰。此缘有漏法。以缘有漏法故。能自增长。如人观月。眼得增益。无有损减。彼亦如是。见灭道所断使。于缘不得增长。云何不得增长。以缘无漏法。若缘无漏法。不得增长。如人观日。眼无增长。唯有损减。彼亦如是。复有说者一切见谛所断结。分为二分。见苦集所断作。一切遍分。非一切遍分。见灭道所断作。有漏缘分。作无漏缘分。复有说者。此诸结皆是堕相。云何堕相。答曰。堕在苦集中。为苦集谛所摄故。复有说者。以苦集所断使能遍缘一切有调因果故。复有说者。以我见可得故。问曰。见集所断。有何我见可得耶。答曰。虽无我见可得。而有增长我见法可得。复有说者。若知见苦所断果。若知见集所断因则见灭道所断。根本羸劣。以羸劣故。不立一切遍使。如树断根故羸劣。彼亦如是。以如是等缘故。不立一切遍

问曰。何故见苦集所断使。立一切遍使。立不遍使。不一切遍者爱恚慢。答曰。或有说者。此无一切遍相故。复有说者。此是别相使。若是总相使。立一切遍。云何别相使。答曰。于发爪齿。各各别起爱等诸使。云何总相使。答曰。于一切界。于一切地。一切生处。能取我见。乃至能取无知愚闇。复有说者。难可炽燃。是非一切遍易可炽燃。是一切遍。云何难可炽燃。答曰。为欲故。求璎珞衣服涂香园林楼阁游戏之处。亦求妻妾侍女。为恚故求种种铠仗斗战之具。为慢故。见他庄严治身。亦庄严治身。以是难炽燃故。不立一切遍。云何易炽燃。答曰。诸结若现在前。犹如河流。诸恶行烦恼。不用功流行。亦复如是。复有说者。此七使能缘四谛故。立一切遍。能缘者见疑无明。问曰。何故灭道所断。爱恚慢见取戒取。非无漏缘。答曰。彼灭道无怨害故无爱恚。彼体无可慢故。不生慢。见取见第一戒取见清净。若于灭道。见第一清净者。云何是使。以是事故。爱等诸结非无漏缘

欲界有十一遍使。九是他界缘。二是自界缘。自界缘者。身见边见。问曰。以何等故。身见边见不缘他界。答曰。唯有尔所势力故。复有说者。身见边见从粗法生。亦从现见生。于粗现见阴。而取于我。生欲界中。色无色界阴是粗非现见。问曰。生色界中。欲界阴是粗是现见。何以色界身见。不于欲界阴取我。答曰。若是现见不离欲。能于中取我。生色界中。欲界阴虽是现见。以离欲故。不于中取我。复有说者。生色界中。欲界阴虽是现见法。无有结使。能缘下地。问曰。如是则因论生论。以何等故。无有结使能缘下地。答曰。若离下地欲。上地烦恼现在前。以离下地欲故。上地烦恼。不缘下地。问曰。何以知离下地欲上地烦恼现在前。答曰。如施设经说。有六种非戒。欲界系有二种。有心相应心不相应。色无色界系。亦有二种。有心相应不相应。若欲界系心相应法非戒现在前。则四种非戒现在前。一欲界心相应。二心不相应。三色界心不相应。四无色界心不相应。色界系心相应非戒现在前。则三种非戒现在前。一色界心相应。二色界心不相应。三无色界心不相应。无色界系心相应非戒现在前。则二种非戒现在前。一无色界心相应。二心不相应。此中诸烦恼。以非戒名说。以是事故。知离下地欲。上地烦恼现在前。不缘下地

问曰。以何等故。欲界诸使。能缘色无色界。色无色界诸使。不能缘欲界。答曰。欲界是不定界。非离欲地。非修地。不能善摄伏诸使故。能缘色无色界。色无色界是定地。离欲地。修地。能善摄伏诸烦恼故。彼诸使不能缘下地。如人不摄伏己妻得与他人作非法事。若善摄伏。乃至不能以眼视他况作非法。彼亦如是。复有说者。生欲界中。于色无色界阴。生疑怪心。彼为是常耶非常耶。为第一耶非第一耶。为净耶为非净耶。以有如是疑怪故能缘。生色无色界中。于欲界阴。不生如是疑怪心故。不缘欲界。复有说者。若色无色界使。能缘欲界者。则能缘使欲界。若使欲界者。则界坏。问曰。如欲界诸使缘色无色界而不使。如是色无色界诸使缘欲界而不使者。有何等过。答曰。色无色界。是尊胜界。欲界诸使。缘而不使。欲界是卑贱界。若色无色界诸使。缘则能使。如下贱人于尊胜者不能作不爱事。如尊胜人于下贱者随意能作。彼亦如是

问曰。如欲界有九种他界缘使。色界亦有九种他界缘使。无色界亦有他界缘使不。答曰。或有说者无。所以者何。以上更无界故。复有说者有。以能缘故。不以现在前故有。评曰。不应作是说。更无有界。彼何所缘。初禅地有九种他地缘。一切遍使。乃至无所有处。亦有九种。非想非非想处。为有他地缘一切遍使不。答曰。或有说者无。所以者何。更无上地。又不缘下地。复有说者有以能缘故有。不以现在前故有。评曰。不应作如是说。更无上地。彼何所缘

欲界。邪见能缘三界苦集。非一刹那顷能谤。先谤欲界。若苦若集。异刹那顷。谤色无色界。问曰。以何等故。不于一刹那顷谤三界若苦若集。答曰。欲界邪见。缘欲界亦使。缘色无色界不使。问曰。以何等故。缘欲界使。缘色无色界不使耶。答曰。欲界是缘处使处。缘而则使。色无色界。是缘处。非是使处。虽缘不使。复有说者。欲界是缘聚使聚。缘而则使。色无色界。是缘聚非使聚缘而不使。复次欲界有五种。一切遍果。色无色界无。故缘而不使。复次欲界。若见苦。若见集所断邪见缘三界。若苦若集者。云何而缘为如欲界缘而则使。色无色界。亦缘而则使耶。为如色无色界缘而不使。欲界亦缘而不使耶。若如色无色界缘而不使。欲界亦缘而不使者。无有自界使缘有漏法。而不作二种使缘使相应使者。若一时能缘三界苦集。或有使或不使。彼相应法亦应。或有所使或无所使。彼若然者有如是过。则体无自相。使性亦坏相应法。欲令无如是过故。别缘欲界。若苦若集。别缘色无色界。若苦若集。如是初禅地邪见。能缘八地。若苦若集。非一刹那顷能谤八地。若苦若集。先谤初禅地。若苦若集。异刹那顷。谤余七地。若苦若集。如是乃至无所有处邪见缘二地。若苦若集。非一刹那顷能谤二地。若苦若集。先谤无所有处。若苦若集。后异刹那顷。谤非想非非想处。若苦若集

欲界见苦集所断邪见。能缘三界苦集。欲界见灭所断邪见。能缘欲界诸行灭。问曰。以何等故。欲界见苦集所断邪见。能缘三界。苦集见道所断邪见。唯缘欲界。断诸行对治。尊者婆已说曰。若为欲爱所爱。起我我所见。此法断对治。为欲界见道断邪见所缘。彼我见法。不能他界缘故。复次欲界见苦集所断邪见。所缘异对治异。欲界见道所断邪见所缘。即是其对治。初禅地见苦见集所断邪见。能缘八地。若苦若集。初禅地见灭所断邪见。缘初禅地诸行灭。广说如上。初禅地见苦集所断邪见。能缘八地。若苦若集。初禅地见道所断邪见。或有说缘断初禅地诸行对治。或有说缘九地比智分断对治九地者。从未至禅。乃至无所有处。评曰。说缘一切比智分。此是实义。问曰。以何等故初禅见灭所断邪见。缘初禅地诸行灭。见道所断邪见。缘九地比智分。答曰。灭不展转作因。道展转作因。如是乃至非想非非想处见苦集所断邪见。缘非想非非想处苦集。非想非非想处见灭所断邪见。缘非想非非想处诸行灭。见道所断邪见。缘九地比智分。余问答如初禅说

问曰。如一使不能使一切。云何名遍使。答曰。总而言之。能使一切诸一切遍使。是一切遍因。一切遍因。是一切遍使耶。应广作四句是也。一切遍使非一切遍因者。未来一切遍使是也。一切遍因非一切遍使者。过去现在一切遍使相应共有法是也。是一切遍使一切遍因者。过去现在一切遍使是也。非一切遍使非一切遍因者除上尔所事

问曰。见道所断法。尽为一切染污法作因不。若见道所断法。尽为一切染污法作因者。断亦作因。不断亦作因。断与不断有何差别。若见道所断法。尽为一切染污法作因者。何故圣人修道所断染污。或起现在前。或不起现在前。不起现在前者。谓无有中爱嗔恚缠诸慢。起现在前者。谓诸余爱恚缠慢。若见道所断法。尽为一切染污法作因者。施设经说云何通。如说。颇法不善。以不善为因耶。答曰。有离欲圣人。于彼退最初染污思现在前。若见道所断法。不为一切染污法作因者。波伽罗那说云何通。如说何者是见道所断作因法。答曰。染污法亦见道所断法执。若见道所断法。不为一切染污法作因者。复与此经相违。如说云何无记作因法。答曰。无记有为法不善法。若不作因者。复违此文。如说以身见为因。不为身见作因。乃至广说。若不作因者。复与识身经文相违。如说颇有不善眼识。以不善无记为因。乃至不善意识。以不善无记为因耶。答言有。答曰。应作是说。见道所断法。尽为一切染污法作因。问曰。若然者诸后所说善通。前所说者云何通。答曰。如所说断与不断有何差别者。名即差别。本作因时不断。今虽为因已断。是名差别。复有说者。前作因时。则不为对治所坏。今虽为因。为对治所坏。复有说者。本作因时。能于自身。障碍圣道。今虽为因。不障圣道。复有说者。本作因时。能于自身。办所作事。今虽为因。不复能作。复次本作因时。于自身中。能取果与果。今虽为因。不能取果与果。唯除已取果者。复次本作因时。能于自身。与相似因一切遍因。今虽为因。更不与相似因一切遍因。复次本作因时。能于自身。取依果报果。与依果报果。今虽为因。不能取依报果。复次本作因时。于自身中。生于诸得。如火出烟。今虽为因。更不生得。复次本作因时。于自身中。堕可嫌责。堕在非法。亦自染污。今虽为因。于自身中。不堕嫌责。不堕非法。亦不染污。断与不断。是名差别。何故圣人修道所断染污。或起现在前。或不起现在前。答曰。见道所断法。或与修道染污法。作相续近因。或作不相续远因。若作相续近因者。彼圣人则不起现在前。若作不相续远因者。彼圣人则起现在前。复次若得非数灭者。不起现在前。若不得者。起现在前。何故不起无有中爱现在前。答曰。彼为断见所长养。断见相续生此爱。圣人已断断见。故不起此爱现在前。何故不起嗔恚缠现在前。答曰。彼为邪见所长养。邪见相续生此嗔缠。圣人已断邪见。故不起此嗔缠现在前。何故不起诸慢现在前。答曰。彼为我见所长养。我见相续生此慢。彼圣人我见已断。故此诸慢不现在前。施设经说云何通。答曰。为不断因故说。彼思有二种因。有断不断。彼说不断因。问曰。如圣人未离欲时。彼思以不善为因。何故说退时。答曰。尔时此得断还相续死结还生故。问曰。后相续思。亦以不善为因。何故说最初思耶。答曰。以尔时不成就今成就不相续今相续故。复有说者。非一切见道所断法为一切染污作因问曰。若然者。先所说善通。波伽罗那识身经云何通。答曰。当以总相通。所以者何。自有染污色。以见道所断法为因者。非一切色。乃至行阴亦如是。自有染污眼识以见道所断法为因。非一切识。乃至意识亦如是。是故应以总相通彼所说。尊者奢摩达多。立诸使异。彼作是说。自有见苦所断使。还以见苦所断使为因。自有见苦所断使。以见苦所断为因。亦以见集所断为因。自有见集所断使。以见集所断为因。自有见集所断使。以见集所断为因。亦以见苦所断为因。彼作是说。实无是处。以分别故说。假设圣人见苦不见集。乃至从圣道起。从圣道起已。若见集所断使现在前。此使当言。见集所断因。见集所断生见集所断因。见苦所断生。答曰。应作是说。是使因见集所断生见集所断使因见苦所断生不现在前。所以者何。彼因已断故。如是自有见灭所断使。唯以见灭所断为因。自有见灭所断使。以见灭所断为因。亦以见苦所断为因。自有见灭所断使。以见灭所断为因。亦以见集所断为因。无三种因。见道所断亦如是。自有修道所断法。唯以修道所断为因。自有修道所断法。以修道所断为因。亦以见苦所断为因。自有修道所断法。以修道所断为因。亦以见集所断为因无三种因。诸修道所断。唯以修道所断为因者。圣人起现在前。诸修道所断。以见苦所断为因。亦以见集所断为因者。圣人不起现在前。所以者何。因已断故。尊者奢摩达多。作如是说。则为通前所说。彼作如是说。如圣人离欲界欲。诸修道所断。以修道所断为因者。修道所断。以见苦所断为因者。诸修道所断。以见集所断为因者。尽合集为束。如克契法九品断。后于离欲退。诸修道所断。修道所断为因者。成就亦得。诸修道所断。见道所断为因者。成就而不得。所以者何。因已断故。诸修道所断使。未来世成就亦得。当起现在前。过去者。成就而不得。评曰。不应作是说。所以者何。同一对治断使。于彼对治道退时。云何成就亦得。云何成就不得。如是波伽罗那识身经所说便不通。如前说者好。见道所断法。为一切染污法作因问曰。如爱果断地断种断他界缘使。何以不使他界他地。但使他种耶。答曰。此一切遍使。于自界自地五种中。有依果故能使。他界他地无依果故不使

问曰。一切遍使报。一切不遍使报。展转为因不。答曰。或有说者。一切遍使报。与不一切遍使报为因。非一切遍使报不与一切遍使报作因。所以者何。如一切遍与不一切遍作因。彼一切遍报。亦与不一切遍报作因。如他种不遍使不能与遍使作因。如是不一切遍报。不能与一切遍报作因。评曰。如是说者好。一切遍报。与不一切遍报作因。不一切遍报。与一切遍报作因。所以者何。一切遍使。一切不遍使。异一切遍使报。一切不遍使报。不异一切遍因。定在过去现在。果是依果。云何报因。乃至广说。问曰。何以作此论。答曰。为止他义故其事云何。或有说者。离思更无报因。离受更无报果。如譬喻者说。思是报因。受是报果。为止如是意。令离思有报因离受有报果。复有说者。报熟因则失坏。彼作是说为因。乃至报未熟。报熟因则失坏。如为种乃至牙未生。牙生则种失坏。为止如是意明报熟因不失坏故。复有说者。为止诸外道意故。外道言善恶诸业。无有果报。为止是意明善恶诸业有果报故。复有说者。为止摩诃僧祇部意故。摩诃僧祇部。作如是说。唯心心数法能生报。非余法。为止是意明五阴是报因是报果。为止他义现于己义亦显法相相应义故而作此论

云何报因。答曰。诸心心数法受报色。心心数法心不相应行乃至广说。色者是色阴。心者是识阴。心数法是三阴。心不相应行是彼生老住无常。此五阴是报果。心回转色。亦摄在心心数法中。复次身口业受报色。乃至广说。问曰。如心回转。身口业前已说。今复言身口业者是何。答曰。或有说者。是作无作。所以者何。同受一果故。不应作是说言。同受一果。复有说者。此说作即此刹那生无作。所以者何。同一时受报故。此亦不定。或有前受或有后受。评曰。应作是说。是作无作。复次心不相应行受报色。乃至广说。问曰。彼法生老住无常。已摄在彼法中。今说心不相应行。是何心不相应行。答曰。是无想定灭尽定诸得报

问曰。无想定为受何报。答曰。或有说者。受无想及色命根受身处(此言受身处者是旧言众生种类)。是第四禅有心报。其余阴是共报。复有说者。无想定唯受无想报。命根受身处。是第四禅有心报。余阴是共报。复有说者。无想定受无想报。命根是第四禅有心报。余阴是共报。复有说者。无想定受无想报。余阴是共报。问曰。若然者。如所说云何通。一法是业报非业。答曰。一切命根尽是报。报以业差别故作是说。一法是业。报非业。复有说者。此是世俗言说法。如见短寿人言是人作短寿业。如见长寿人言作长寿业。命根亦从非业生报。复有说者。无心时亦受第四禅有心报。有心时亦受无心报。问曰。云何无心时亦受第四禅有心报。有心时亦受无心报耶。答曰。若尔有何过。如受色报时。亦受非色报。如受非色报时。亦受色报。尊者奢摩达多说曰。无想定报。得无想得受身处有心报。得色得命根。余心不相应行。心心数法非是报。评曰。不应作是说。如是说者好。无想定不能造受身处(受身处有二种一是五阴性二是心不相应行此中言不造者不造具五阴性者也)。所以者何。非是业故。业能造受身处。及能得报命根。无想定报得无想。诸余阴是彼报果(诸余者阴五情根余悉是)。问曰。灭尽定为受何报。答曰。灭尽定不造受身处。若业造受身处。受彼报时。亦受彼四阴报。问曰。诸得为受何报。答曰。得亦不造受身处。若造受身处业。受彼报时。亦受彼报色心心数法心不相应行。色者四入。四入者色香味触。心心数法者苦受乐受不苦不乐受。及相应法。心不相应行者得生老住无常。尊者僧伽婆修作是说。得能造受身处。其事云何。积集诸得。能造受身处。受身痴不猛利卑小如是报。当知皆从得生得。能造受身处。能得报色心心数法心不相应行。色者九入除声入。心心数法者。苦受乐受不苦不乐受及相应法。心不相应行者。命根受身处得生老住无常。评曰。如是说者好。得不能造受身处。所以者何。若得同一果。可言积集业造受身处。诸得不同一果。积集百千亿得。亦不能造受身处。积集何所益。尊者佛陀罗又说曰。得不能造受身处受受身处报时。亦受彼报。如眼处所。色香味触等。展转受报如是。乃至身处所色香味触等。展转受报。生老住无常。无有别报。诸法生老住无常。还与彼法。俱共受报

问曰。已得报当得报者。为是报因不耶。答曰。是报因。问曰。此文何以不说。答曰。以现在显过去未来故。若说现在当知亦说过去未来。复有说者。所以者施设。是地狱乃至天因。何事故施设。答曰。以现在事故施设。如说报现在前。是名地狱众生。以是事故但说现在。如波伽罗那说。云何有报法。答曰。不善法有漏善法。问曰。彼经所说与此文说报因。有何差别。答曰。彼经所说是了义。此文所说是不了义。此有余意彼无余意。此说有余彼说无余。此有岸有影有相续。彼无岸无影无相续。复次此说生。彼说生不生。此说现在彼说三世。此文彼说是谓差别

问曰。有作无作。同一报不。答曰。不也有作报异。无作报异。问曰。身口有作同一报不。答曰。不也即身有作。报亦不同。彼身有作。有尔所微尘有尔所报。即彼生老住无常。俱同一报。所以者何。同一意所起。同一果故。有作有七种。不杀生乃至不绮语。当知如向所解。如欲界中善不善心心数法四阴。作报因得一果。善不善色二阴。作报因得一果。得生老住无常一阴。作报因得一果。初禅地有心回转五阴。作报因得一果。善心无回转四阴。作报因得一果。善身口有作二阴。作报因得一果。得生老住无常一阴。作报因得一果。二禅三禅四禅有心回转五阴。作报因得一果。无回转善心四阴。作报因得一果。得生老住无常。及无想定一阴。作报因得一果。无色界善心四阴。作报因得一果。得生老住无常。及灭尽定一阴。作报因得一果。

有业得一入报。谓法入中命根。有业得二入报。谓意入法入。触入法入亦如是。若得报眼入。得四入。眼入身入触入法入。如眼入耳鼻舌入亦如是。若得身入。得三入。身入触入法入。如身入色香味入亦如是。诸作是说。一切四大。能生色声。一切欲界色香味。终不相离。若业报得眼入尔时得七入。眼身色香味触法。如眼耳鼻舌入亦如是。若得身入。得六入。身色香味触法。若得色入。得五入。色香味触法。如色入香味触入亦如是。有业报得八入九入十入十一入。问曰。何故业或报得多入。或报得少入。答曰。有业得种种果。有业不得种种果。得种种果者得入多。不得种种果者得入少。如小种子法。有得果多者。有得果少者。得多果者。如甘蔗蒲萄稻藕花子等。得少果者。如种娑罗树子。后生极高。唯有一叶。其形如盖。如修芝草等。生虽极高。唯有一叶彼亦如是。问曰。何故一世业得三世报。无三世业得一世报耶。答曰。无有多业生于少果。如是有一刹那业得多刹那报。无有多刹那业得一刹那报

问曰。为先作受身处造业。先作满业。答曰。或有说者。先作造业。然后作满业。若不造者。彼何所满。犹如画师。先摸后以众采满之彼亦如是。复有说者。先作满业。后作造业。如菩萨于三阿僧祇劫修集满业于最后身乃作受身处造业。评曰。应作是说不定。或有先作造业后作满业。或有先作满业后作造业。有三种业。谓现报业。生报业。后报业。云何现报业。若业于此生作。亦令增益彼业。即此生中得报。非余生。是名现报业。云何生报业。若业于此生作。亦令增益彼业。次生中得报。非余生。是名生报业。云何后报业。若业于此生作。亦令增益彼业。后生中得报。是名后报业也。云何报义。答曰。不相似义是报义。报有二种。有相似报。有不相似报。相似报者。如善法有善依。不善法有不善依。无记法有无记依。不相似报者。如善不善法得无记报。问曰。若不相似义是报义者。如地狱作不善业。受无记报。亦不相似。何故言无报耶。答曰。彼亦是报。但是下贱。以下贱故。名为无报。如下贱村名为无村。复次彼亦有报。以极苦切故。名曰无报。犹如无巧便陶师。以多薪烧物。烧过烂坏。言物不熟。彼亦如是。复次无善果故言无报。彼中无有善报。问曰。饿鬼畜生趣中。亦有善报。何故言无报。答曰。以少故言无。复次彼虽有善。但减无增。犹如仓谷有出无入。名曰仓空。复有说者。彼虽有报所趣。非处故言无报。问曰。何故不善有漏法生报。无漏无记法不生报耶。答曰。如外种子。其性不破坚实。粪土调适。溉灌以时。亦以自力亦众具力。然后生牙。如不破坚实种子在良田中。如外种子不破坚实不以粪土调适。溉灌不时。无众具力。不能生牙。如种子在于仓中。如外种子。若不破亦不坚实。羸劣腐坏。虽复粪土调适溉灌以时。以性羸劣。不能生牙如腐种子在良田中。如外缘起法有三种。内缘起法。亦有三种。如初种子。如是不善有漏法。其性不破坚实。以爱水溉灌。诸余烦恼。粪土调适。亦以自力亦众具力。生于有牙。如外种子在良田中。如第二种子。如是无漏善法。其性不破坚实。无爱水溉灌。亦无烦恼粪土调适。无众具力。故不生有牙。如种子在于仓中。如第三种子。如是无记法。亦不不破不坚实。其性羸劣败坏。虽以爱水溉灌烦恼粪土调适。自性羸劣故。不生有牙。如腐种子在良田中。问曰。复以何故。无漏法不生报耶。答曰。行苦集性。则能生报无漏是苦集对治道。则不生报。如是行诸有世俗生死老病道则有报。无漏法断诸有世俗生死老病道。则不生报。复次如无漏法有报者。无漏道则与世俗相续。若与世俗道相续无有是事。复次无漏道。无报器故。若无漏法有报者。何处受耶。若在欲界受。非欲界系法。若在色界受。非色界系法。若在无色界受。非无色界系法。除三界系法更无报器。复次若无漏法能生报者。则胜法为下作因因。是善无漏果。是无记有漏。复次无漏法是对治。若当生报。复须对治。彼对治复对治。如是便为无穷。若无穷者。则无解脱出要。欲令无如是过故。说无漏法无报。何故无记法无报。答曰。有记法能生报。若当无记法能生报者。如是报法。复能生报。若报复生报。便为无穷。乃至广说。欲令无如是过故。说无记法无报

有种种法。以报名说。或有是依。或有增益。或有丰贱饥馑之相。或有梵天当来。或有即报。如是等。以报名说。或有是依以报名说者。如说。谁是受报。当言爱是我说爱是受报。或有增益以报名说者。如说乐受是饮食医药等报。或有丰贱饥馑之相。以报名说者。如说日月在如是道行。有如是相。当有丰贱饥馑等报。或有梵天当来以报名说者。如说。今此光明照曜。为是梵天当来为有余事。我等更不余行。当待此光为有何报。或有即报以报名说者。如今此文报。得色心心数法。乃至广说。问曰。为以一业造一受身处。为以一业造多受身处。若以一业造一受身处者。施设经说云何通。如说。如此众生。本为人时。曾作大王。若作大臣。非法取财。以供己身及与妻子僮仆兵人。以是恶行报故。生阿毗地狱。彼处命终。彼行果报。不得生四天下。生大海中。作水性众生。其形长大。所食亦多。常啖众生。所啖众生。复啖其余众生。如是转转相啖。有余众生着其身者。如拘执毛唼食其身。常受苦痛。受苦痛故。以身揩摩颇梨山上。杀诸众生。流血染水。经百由旬。阿尼卢头经。复云何通。如说诸长老。我以一食报故。七生三十三天。七生波罗奈国。摩诃迦叶因缘。复云何通。如说我以一器[禾*秀]子饭施报故。千反生郁单越。一两盐喻经。复云何通。如说尔许地狱行报。于现身受。现身行报。于地狱受。若一业造多受身处者。涅毗陀经。复云何通。如说以此业报。生地狱中。以余业报。乃至生诸天中。施设经复云何通。如说以业种种差别种种势力种种行缘。便施设诸趣。以趣种种差别种种势力种种行缘。施设诸生。以生种种差别种种势力种种行缘。施设诸根。以根种种差别种种势力种种行缘。施设诸人。复云何有三业差别。现报业。生报业。后报业。施设经说复云何通。如说修行广布增上杀生之罪。身坏命终。堕阿毗地狱中。中者下者。乃至广说。评曰。应作是说。一业造一受身处。若然者后所说善通。前所说云何通。如施设经说者。答曰。此说别业。不说一业。余报本造业时。造五道业。彼以造二趣业故。生二趣中。谓地狱趣业。畜生趣业。地狱业者。生地狱中。畜生业者。生畜生中。阿尼卢头经云何通者。答曰。若取食报食则无报。所以者何。是无记法故。以因食故。作如是说。因食故生多善思以思多故。受生亦多。或有天中取果。或有人中取果。天中取果者。生于天中。人中取果者。生于人中。复有说者。言一食施报者。取初种子。以一食施故。生大富家。饶财多宝。或有说彼有忆前世念。或有说有前因力。复以百千食施。此处命终。复生转胜大富之家。饶财多宝。复行布施。以是事故作如是说。犹如农夫。春时下一斗种。后所获实不敢食用。而复种之。如是勤种不息。后获百千斛子实。其人于大众中。作师子吼唱。如是言。我种一斗子实。今得百千斛。彼人不能以一斗种。得百千斛实。以种子转转相生故。获如是实。如人于一两金。倍息得百千两彼亦如是。复有说者。彼以一食施。造上中下业。下者生人中。中者生天中。上者出家得解脱。摩诃迦叶因缘。亦当如是通。一两盐喻经云何通者。答曰。或有说者。彼中说二人作二业受二报。有二人俱同杀生作地狱业。一人不修身。不修戒。不修心。不修慧。生地狱中。一人修身。修戒。修心。修慧。得生人中。复有说者。此说一人作二业受二报。作一业报。生地狱中。作异业报。得生人中。若不修身等生地狱中。若修身等得生人中。复有说者。此说一人作一业。受二种报。如一人杀生。应受地狱报。彼业报应生人中。若不修身。等生地狱中。应生人中报住不生法中。若修身等得生人中。应生地狱报住不生法中。彼不应作是说。若作是说。则破趣破业。一业亦是地狱业。亦是人业。亦是恶趣。亦是善趣。应作是说。此说一人作一业受一报。如一人杀生。造地狱业报。后时于佛法出家。便勤方便求道。得阿罗汉果。以修道力故。取地狱业。人身中受。以是事故。尊者和须蜜。作如是说。地狱业。能于人身中受不。答曰。能人身中。有修道力故。如煮饭人。以水渍手。取饭之时。则不烧手。不渍则烧。彼亦如是。问曰。盐喻经文说尔许。云何名尔许。答曰。尔许者若少若等。若相似业故言尔许。复有说者。一业能造多受身处。问曰。若然者前所说善通。后所说云何通。答曰。或有业别异转行。或有业不别异不转行。若业别异转行。则通前所说。诸不别异不转行者。通后所说。如是者。前后所说。俱得善通。评曰。应作是说。一业造一受身处。若如是者。现报等三业。则有别异。作增上不善业。生地狱中。受增上不善报。作中业。生畜生中受中报。下业生饿鬼中受下报。复有说者。作增上业。生地狱中。受增上报。中报畜生。饿鬼如前说。复有说者。作增上业。生地狱中。受三种报。中业生畜生中受中。下报饿鬼。如前说。复有说者。增上业。生地狱中。受三种报。中业生畜生中。受三种报。下业生饿鬼中。受中下报。复有说者。增上业生地狱中。受三种报。中业生畜生中。受三种报。下业生饿鬼中受三种报。评曰。应作是说。或有上中下业。生地狱中。各受三种报。畜生饿鬼亦如是。或有作三种业生畜生饿鬼中各受三种报。作欲界增上善业。生他化自在天中。受增上善报。中业生五天中受中报。下业生人中受下报。问曰。若下业生人中受下报者。菩萨是业人中受报。此业最上。何以言生人业是下。答曰。菩萨业胜者。自有异缘。所以者何。此身是力无畏所依故。若以受报轻妙。则他化自在天业胜。所以者何。彼报身轻妙无垢。犹如灯焰。菩萨报身故。有粪秽不净。复有说者。增上善业。生他化自在天。受三种报。五天中人中如前说。如是下中上善业。从他化自在天。转增乃至人中亦如前。不善业广分别。评曰。应作是说。或有上中下业。生他化自在天中。各受三种报。五天人中亦如是。或有作三种业生五天及人中各受三种报。初禅地作不别异三种业。生初禅地。受不别异三种报。作第二禅下业。生少光天中受下报。中业生无量光天受中报。上业生光音天中受上报。作第三禅下业。生少净天中受下报。中业生无量净天中受中报。上业生遍净天中受上报。作第四禅下业。生无挂碍天中受下报。中业生受福天中受中报。增中业生广果天中受上报。修下薰禅。生不烦天中受下报。修中薰禅。生不热天中受中报。修上薰禅。生善见天中受上报。修胜上薰禅。上善见天中。受胜上报。修胜上满足薰禅。生色究竟天中。受胜上满足报。作不别异业。生空处。受不别异报。乃至作不别异业。生非想非非想处。受不别异报

不善业。造地狱受身处。生地狱中。受不善报。色心心数法。心不相应行。色者九入除声入。心心数法者苦受及相应法。心不相应行者命根受身处得生老住无常。不善业造畜生饿鬼受身处。生畜生饿鬼中。受善不善报。色心心数法。心不相应行。色者不善色。有九入除声入。心心数法者苦受及相应法。心不相应行者命根受身处得生等。善色有四入色香味触。心心数法者乐受不苦不乐受及相应法。心不相应行者得生等。复有说者。善业不生畜生饿鬼中善报色。若生报生。心心数法。心不相应行。问曰。今现见畜生饿鬼。形色好妙。或有形色丑陋。答曰。或有不善业。不善业为眷属。善业为眷属。诸不善业为眷属者。形色丑陋。善业为眷属者。彼善业力。障蔽不善业。使形色好妙。善业造。人六欲天受身处。生彼处受善不善报。色心心数法。心不相应行。色者。善报色有九入除声入。心心数法者乐受不苦不乐受及相应法。心不相应行者命根受身处得生等。不善报色有四入。色香味触。心心数法者苦受及相应法心不相应行者。得生等。复有说者。不善业不生人六欲天。不善报色。若生报生。心心数法。心不相应行。问曰。今现见人天。或有形色丑陋形色好妙。答曰。或有善业。善业为眷属。不善业为眷属。善业为眷属者。形色好。不善业为眷属者。彼不善业。障蔽善业。使形色丑陋。善业造色无色界受身处。生彼中受善报。问曰。生人中有二形者。为是善业报。为是不善业报。答曰。一形是善业报。若非时非处。第二形生者是不善报。复有说者。诸根体。是善业报。根处所。是不善业报

问曰。何故欲界不善业受一劫报。善业无受一劫报者。答曰。不善业自有胜事。所以者何。五道中受报故。善业自有胜事。所以者何。于三界中受报故。自有俱胜事。所以者何。俱受五阴报故。问曰。若然者。何以欲界不善业。受一劫报。善业不耶。答曰。欲界是不定界。非离欲地。非修地。是故不善业。受一劫报。善业不受。复有说者。欲界不善根强盛。善根劣弱。复次欲界不善根恒增长。善根恒不增长。复次欲界不善根是旧住。善根是客。旧住势胜。客则不如。复次欲界不善根能断善根。欲界善根。则不能断不善根。复次欲界法。不相忌难。犹如夫妻威仪无忌。如居士子与栴陀罗子交。复次无报器故。欲界中一切处。无器受善业报经一劫者。问曰。如四天下须弥山金山等。此非一劫器耶。答曰。言非报器者。此四天下须弥山金山等。非是善报。复次若欲界善业。能得一劫报者。何由而得。唯有最上善业。然最上善业。离欲时得。以离欲业。不能造受身处。复次先作是说。不善业于五道受报。问曰。因论生论。何故善业不五道受报。答曰。应如先答。欲界善根。此中唯有一不共答。所谓欲界。是不善田种。不善法易种。善法难。如田恶草易长稻等难生

佛经说业是眼因。阿毗昙说四大是眼因。复有说眼是眼因。此三所说有何差别。答曰。以报因故。佛经说业是眼因。以生因所依因住因增长因润益因以生因等故。言四大是眼因。以相似因故。言眼是眼因。问曰。如四大是眼因。眼亦是眼因。何故佛经但说业是眼因。答曰。业是众生自业。以业故生。业是众生取果财处。众生属业。众生以业故。有差别异。所谓贵贱好恶。复次以业种种差别。种种势力。种种行因缘。乃至广说。复有说者以业故寿有增减兴衰进退。复有说者。以业故有愚小聪黠。复有说者。以业故诸界诸生诸趣受报差别。复有说者。以业故七众有次第别异。复有说者。一切众生。皆为业所印。复次以业异故诸根亦异。如种异故牙亦异

佛经说若人修行广布杀生。生地狱中。从彼命终。来生人中。寿命短促。问曰。即以生地狱业。来生人中。得短命耶。答曰。或有说者。即以如说。修行广布杀生。生地狱中。从彼命终。来生人中。寿命短促。复有说者。以杀生故业生地狱中。以业方便。生便短命。复有说者。以杀生业。生地狱中。生便短命。是彼依果。复有说者。杀众生时。使他受二种苦。一者使他受苦痛。二者断他所爱命。以苦痛他故。生地狱中。断他所爱命故。生便短命。问曰。若人短命为是善业报为是不善业报。尊者和须蜜说曰。是善业报。非不善业报。所以者何。以人命等八根是善业报故。以善业造人中二十年寿报。以杀生故。使寿损减。应寿二十年。唯寿十年。十年则断

佛经说人寿十岁时。当生寿二十岁男女。问曰。无有成就他业者。亦无他作他受者。何以故。作如是说。答曰。即彼寿十岁人。转寿二十岁。如是行十善业道。则寿命十倍。尊者瞿沙说曰。诸业各有定报。十岁业有十岁报。乃至八万岁业有八万岁报。随修何等因。受如是报。问曰。人寿十岁时不杀生。为是善业道所摄不。答曰。非是业道所摄。是不作道。非是业道。所以者何。彼作是制。不应杀生。为不作道不为业道。施设经说。颇不受现法报。受生报后报耶。答曰。有若现报业不现前与报。生报业后报业现前与报。尔时受生报。得阿罗汉者。非不得生报。后报亦如是说。问曰。如学凡夫人。亦有是事。何以但言阿罗汉。答曰。阿罗汉能知业是远是近是可转是不可转。复有说者。阿罗汉更不受有彼诸业起现在前。如人欲至他国。债主来责。彼亦如是。学人凡夫人。更受身故。当受此报。是故不说。复有说者。若有自力能了知此业报。是故说之。诸作是说。一业历诸趣。有余报者。彼作是说。阿罗汉于前余生。作业受报。此报有余。以修道力故。舍人身上现法业报受生报后报。所以受者。能以如是缘。发起是报。唯阿罗汉能学人。凡夫人不能。施设经说。有四种人。有寿尽财不尽死者。有财尽寿不尽死者。有寿尽财尽死者。有寿不尽财不尽死者。初句者。如有一人。作短寿业。广令增长。广作财业。亦令增长。彼寿尽财不尽而死。第二句者。如有一人。作少财业。广令增长。复作寿业。亦令增长。彼财尽寿不尽而死。第三句者。如有一人。作少财业。作短寿业。俱令增长。彼财尽寿尽而死。第四句者。如有一人。广作财业。广作寿业。俱令增长。彼财不尽寿不尽。以余恶缘故死。彼尊者目揵连作如是说。明有横死是报因定。在三世报是其果

阿毗昙毗婆沙论卷第十一阿毗昙毗婆沙论卷第十二

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    杂犍度智品之八

云何所作因。乃至广说。问曰。何以作此论。答曰。为止诸法生时无所作者意。亦明法生时因所作而作此论

云何所作因。眼缘色生眼识。彼识以眼作所作因。亦以色。亦以相应共有法。亦以耳声。乃至意识相应共有法。作所作因。如眼识乃至意识亦如是。应说如是等。不应说色法无色法等。所以者何。此六二法。摄一切法。以善说善解。应作是说。而不说者有何意。答曰。初是广说。后是略说。初是别说。后是总说。初是分别。后不分别。初说是次第。后非次第。问曰。何以不作是说。云何所作因。答曰。一切法有自体过故。若说一切法是所作因。自体亦在一切中。欲令无如是过故。不作是说。眼缘色生眼识。问曰。除自体余一切法亦是缘。能生眼识。何以但言眼缘色生眼识耶。答曰。取眼识所依。取眼识所缘故。复次以眼色与眼识作近威势缘故。作如是说。眼色与眼识。作近威势缘。胜眼识俱生生等。是故作是说。除其自体问曰。何故自体不作所作因。答曰。非其田器。乃至广说。复有说者。一切法除其自体。于他法作缘。自体于自体。无损无益。无增无减。无进无退。复有说者。无有差别过。所以者何。因即是果。作即作事。成即成事。乃至生即生事。复次自体不能与自体作依。复次自体不于自体作尊胜。复次与世现见法相违。世现见。眼不自见。指端不能自触。刀不能自割。多力之人。不能自负。彼亦如是。复有说者。不障碍义。是所作因义。自体障碍。自体障碍有二种。一者假名。二者真实。假名障碍者。如人在床座上。真实障碍者。如自体障碍。自体复有说者。若自体作所作因者复违佛经。如经说无明缘行乃至广说。若自体作所作因者。则无明缘。无明不缘行。乃至生缘。生不缘老死。如经说眼缘色生眼识。不应眼缘色生眼识。应缘眼识生眼识。欲令无如是过故。自体不作所作因

所作因即是威势缘。云何威势缘。如说。此法与彼法作威势缘。或时此法不与彼法作威势缘耶。答曰。无也。问曰。法生时除自体。余一切法。是威势缘和合。则生无有。不和合时。何以不数数生。尊者和须蜜说曰。法生时有一和合。无二无多。法灭时亦一和合。无二无多。复有说者。法生已余生法多。彼法无力能更生。如人堕河欲起复堕一河彼亦如是。尊者佛陀提婆说曰。一和合能生一事。无有一事能生二果。问曰。威势缘体性是何。答曰。一切法。问曰。云何是威势缘义。答曰。多胜义。是威势缘义。问曰。如波伽罗那说。云何境界缘。云何威势缘。答曰。一切法。此有何多胜。答曰。若以境界。若以前物言之。则无多胜。若以刹那。则有多胜。若缘一切法无我。此法何所不缘。答曰。不缘自体。自体不缘相应共有。谁不作威势。唯自体

威势缘。即是所作因。云何是所作因义。答曰。如先说。不障碍义。是所作因义。问曰。若不障碍义。是所作因义者。如人阴界入障碍人趣。余趣不能障碍。如眼识障碍所依处。余识不生处所。有房舍树木。则余房舍树木不生。若如是者云何不障碍义。是所作因义。答曰。以如所说故。不障碍义。是所作因义。如义言。人中阴界入。语余趣阴界入言。我障碍人趣。不障碍余趣使汝余趣得生。如是眼识语余识言。我障碍眼处所不障碍余处所。使汝得生。一房舍树木。语余房舍树木言。我障碍此处所。不障碍余处所。使汝得成。以是事故。不障碍义。是所作因义。五阴生时。一切法。与威势缘。若有一法不随顺者则不生。问曰。如色法生时一切法与威势缘。无色法生时。一切法亦与威势缘不。若无色法生时。一切法与威势缘。色法生时。一切法亦与威势缘不。答曰。不也。若与色法威势缘时。与无色法威势缘亦尔者。一切法皆是色耶。若与无色法威势缘时。与色法作威势缘亦尔者。一切法皆是无色耶

阿毗昙者作如是说。法生时有因故生。灭时有因故灭。有缘故生。有缘故灭。有事故生有事故灭。譬喻者作如是说。法生时有因故生。法灭时无因故灭。有缘故生。无缘故灭。有事故生。无事故灭。我不说灭法有因缘应说。喻如射箭空中。去时用力。堕时不用力。谁作其因。如陶家轮。转时用力。住时不用力。谁作其因评曰。不应作是说。如前说者好。问曰。若然者譬喻者说喻云何通。答曰。此不必须通。所以者何。此非修多罗毗尼阿毗昙。不可以世间现喻难贤圣法。世俗法异。贤圣法异。若欲通者当云何通。答曰。彼箭堕亦有因。以何为因。箭去时若楯等种种余物障碍使堕。即是其因。设无障碍者。用力射时。即是其因。若无射者。何由而堕。如是陶家轮转。若以手等余物持令不行。即是其因。设无手等持者。先用力转时。即是其因。若无转者。何由而住。问曰。若法生亦有因。灭亦有因。乃至广说。何以生时不灭。灭时不生。尊者和须蜜说曰。生时和合异。灭时和合异。复有说者。法生时作缘异。法灭时作缘异。云何生时异。生时作缘则随顺。灭时作缘则不随顺。犹如外国皆夏安居时。多持衣钵从一寺至一寺。尔时诸贼善取其相。此诸比丘。出在旷野有人之处。诸贼亲近礼拜而随顺之。前至崄难无人之处。劫其衣钵而不随顺。彼亦如是

一法与多法。作所作因。多法亦与一法作所作因。问曰。一法与多法作因时。为如一法与耶。为如多法与耶。多法与一法作因时。为如多法与耶。为如一法与耶。若如一法与多法作因者。云何非一因果。若如多法与一法作因者。云何一法不作多果。多法与一法作威势缘时云何作。为如多法与耶。为如一法与耶。若如多法与一法作威势缘者。云何不多因多果。若如一法与者。云何多法作一法耶。评曰。应作是说。一法如多法与威势缘。多法如一法与威势缘。问曰。若然者云何多不作一。一不作多。答曰。如我义。一亦作多多亦作一。以所作因义。不以法体有异

过去法与未来现在法。作近所作因。义言过去法语未来现在法言。若我不与汝等作所作因者。则汝无因。一切有为法。无有无因者。现在法与过去未来法。作近所作因。义言现在法语过去未来法言。若我不与汝等作所作因者。则汝过去法无果。未来法无因。一切有为法。无有无果无因者。过去法是未来现在法所作因。未来现在法。是过去法果。未来法是过去现在法所作因。过去现在法。非未来果。所以者何。果法若俱若在后。过去现在。于未来法。不俱不在后。现在法与过去未来法。作所作因。未来法作所作因。未来法与现在法作果。过去法非果。所以者何。果法若俱若在后。过去法于现在法。不俱不在后。色法与色法。作所作因。作威势果。色法与无色法。作所作因及威势果。无色法与无色法。作所作因及威势果。无色法与色法。作所作因及威势果。如是可见与可见。可见与不可见。不可见与不可见。不可见与可见。作所作因及威势果。有对无对有漏无漏亦如是。有为法与有为法。作所作因及威势果。有为法与无为法。作威势果。不作所作因。无为法与无为法。不作所作因。不作威势果。无为法与有为法。作所作因。不作威势果。问曰。何以故有为法有因有缘。无为法无因无缘。答曰。有为法性羸劣须因缘。无为法性猛健不须因缘。如人羸劣依他而住。如人猛健不依他住。彼亦如是。复次有为法有所作故须因缘。无为法无所作故不须因缘。如掘者须钁。如刈者须镰。彼亦如是。复次有为法随世行。能取果能知缘。故须因缘。无为法不随世行。广说如上。如人远行须粮不远行者不须粮。彼亦如是。复次有为法如王及眷属。如因陀罗及眷属。故须因缘。无为法如王。不如王眷属。如因陀罗。不如因陀罗眷属。故不须因缘。问曰。有为法不生。为是有为留难故不生。为是无为留难故不生耶。答曰。有为留难故不生。非无为法。无为法威势缘不与他不生法作留难。若生随顺作缘。如潢池边。克木作师子口摩竭鱼口。水在中流出。水不流时。非此口中为作留难。自有余缘。令水不流。水若流时。为作所依。彼亦如是。问曰。无为法与有为法二种缘。谓境界缘。威势缘。无为法与他作近威势缘时。为与有缘者。为与无缘者。答曰。或有说者。与有缘者不与无缘者。评曰。不应作是说。应作是说。与他作威势缘。等无有异。如小豆聚境界缘。或与或不与。有缘法则与。无缘法则不与

善法与善法。作近所作因。善法与不善法。作近所作因。不善法与不善法。作近所作因

不善法与善法作近所作因。善法与善法作近所作因者。以善业故生大富长者商主家。其家诸人好乐行善。以亲近故亦好行善。是名善与善作近所作因。善与不善作近所作因者。以善业故生王若大臣家。其家诸人好行诸恶。以亲近故亦好行诸恶。是名善与不善作近所作因。不善与不善作近所作因者。以不善业故生恶戒家。以亲近故常作诸恶。是名不善与不善作近所作因。不善与善作近所作因者。以不善业故身生重患。以厌患故修行于善。是名不善与善作近所作因

内法与内法作近所作因。内法与外法。外法与外法。外法与内法作近所作因。内法与内法作近所作因者。如一人能供足多人。内法与外法作近所作因者。如人种外种子。外与外者。如粪土水等长养苗稼。外与内者。如以饮食等长养众生身。如是众生数与众生数。众生数与非众生数。非众生数与非众生数。非众生数与众生数。广说如上

一趣能长养五趣。如多人食一羊肉。或有行善或有行恶。行善者能长养二趣。谓天趣人趣。行恶者长养三趣。谓地狱畜生饿鬼

问曰。如一人杀生一切众生尽与作所作因。何以有得杀罪有不得者。答曰。若作杀方便。亦满杀果得杀罪。若不作方便。不满杀果。不得杀罪。复次若有恶心。而得杀罪。若无恶心杀心。不得杀罪。问曰。如一众生不与取一切众生与作所作因。何以有得不与取罪。有不得者。答曰。若作方便。满其果者。得不与取罪。不作方便。不满其果。不得不与取罪。复次若以贪心取他物想。得不与取罪不者不得

问曰。如外物是一切众生威势所生。何以或于他边得不与取罪。或不得耶。答曰。有功用果威势果者。是人边得不与取罪。唯有威势果无功用果者。是人边不得不与取罪。复次于物作己有想。是人边得罪。于物不作己有想者。是人边不得罪。问曰。威势果。功用果。有何差别。答曰。作者是功用果。食者是威势果。如农夫种。作者是功用果非威势果。食其子实者。是威势果非功用果

问曰。如四天下须弥山等外物。是一切众生业威势故生。众生有得涅槃者。此物等何故不减少耶。尊者和须蜜说曰。有余世界众生来生此间。以其业势力故。使不减少。复次是一切众生业势力故生。设令唯有一众生在。犹不减少。所以者何。彼亦有业威势。在其中故。何况阿僧祇那由他众生在。如尊贵人。业威势故。生园林楼观象马车乘。如是众生数非众生数物等。其人虽死此物不减。彼亦如是。尊者佛陀提婆说曰。以过去业故。所以不减少。问曰。如一转轮圣王。王四天下。而得自在。彼是何业报耶。答曰。是造生处业果报。问曰。为所作因多。为所作因果多。答曰。所作因多。非所作因果。所以者何。所作因是一切法。所作因果是有为法以是事故。作如是论。颇法非是因非次第非境界非威势耶。答曰。有自体于自体是也。于他体有耶。答曰。有有为于无为。无为于无为

佛经说有三种威势。所谓世威势我威势法威势。世威势者。犹如有一烦恼现在前境界易得。为世人讥嫌故。不作恶业。我威势者。犹如有一烦恼现在前境界易得。为我不堕恶道故。不作恶业。法威势者。犹如有一烦恼现在前境界易得。彼以多闻故。不作恶业。亦令世人不讥嫌故。不作恶业。问曰。此三何以说名威势。答曰。以能近生善法故。一切众生。威势尽故死。除佛世尊威势不尽而般涅槃

问曰。所作因为有增减不。答曰有。如有多人挽大材时。其中或有尽手足力者。有不多用力者。如竖大塔住时。纠索其中。有急有缓。如是等是名外法有增减。如与亲里所作因及供给所须。则胜他人。是名内法有增减

若是因缘。亦是次第缘。亦是境界缘。亦是威势缘。如是一一缘。应次第有四缘义问曰。若然者云何有四缘体。答曰。以所作故有四。非以物体故有四。其事云何。如前刹那使后刹那增长。名曰因缘前作次第缘。令后者生名次第缘。后能缘前是境界缘。不为他作障碍是威势缘。因缘如种子法。次第缘是开导法。境界缘是执杖法。威势缘是不障碍法。总而言之因缘有四缘义。非一一法从因缘生。尽有四缘义

问曰。因之与缘。有何差别。尊者和须蜜说曰。因即是缘。若有此则有是。亦是因亦是缘。世尊亦说。阿难有如是因如是缘。如是作生。为老死因。问曰。若有此则有是。是因是缘者。如人见瓶生觉心。瓶是觉因耶。答曰。不以有瓶是觉因。所以者何。自有瓶不生觉心。和合乃生觉心。和合是觉缘非瓶。复有说者。和合是因。和合事是缘。问曰。若一不为因。多亦不为因。答曰。如一一事。不能为因。和合众事。则能为因。其事云何。如一一事不名和合。众事集故乃名和合彼亦如是。复有说者。相似是因。不相似是缘。相似者如麦似麦。如火似火。问曰。麦与麦牙。有何相似。答曰。总而言之麦是牙因。问曰。若然者四大因等。总而言之亦是牙因耶。复有说者。近者是因远者是缘。问曰。若然者因之与缘。无有差别。所以者何。如心次第生善心是因。不名为缘耶。复有说者。不共者是因。共者是缘。问曰。若然者麦亦是牙。亦是烂坏。彼复是缘耶。如眼是眼识生处。不共余识。彼眼复是眼识因耶。复有说者。生是因随生是缘。问曰。若然者生不是缘。随生不是因耶。复有说者。自体长养是因。他体长养是缘。问曰。若然者现在善心缘于善法。唯名为因。不名为缘耶。尊者佛陀提婆说曰作是因所作是缘。复有说者。相似是因。不相似是缘复有说者。近者是因远者是缘。如近远彼此亦如是。此所作因。定是一切法果。是威势果。问曰。若有相应因亦有共生因耶。答曰。若有相应因亦有共生因。颇有共生因无相应因耶。答曰。有不相应法共生因。若有相应因。亦有相似因耶。若有相似因。亦有相应因耶。乃至广作四句。有相应因无相似因者。未来世相应因。有相似因无相应因者。不相应法相似因。有相应因亦有相似因者。相应法相似因。无相应因亦无相似因者。除上尔所事若有相应因亦有一切遍因耶。若有一切遍因。亦有相应因耶。乃至广作四句。有相应因无一切遍因者。未来世相应因。过去现在非一切遍相应因。一切遍因非相应因者。不相应法一切遍因。相应因一切遍因者。相应法一切遍因。非相应因非。一切遍因者。除上尔所事。若有相应因。亦有报因耶。若有报因。亦有相应因耶。乃至广作四句。有相应因无报因者。无记无漏相应因。有报因无相应因者。不相应法报因。有相应因亦有报因者。相应报因。非相应因非报因者。除上尔所事。若有相应因亦有所作因耶。答曰。若相应因。亦有所作因。颇有所作因无相应因耶。答曰。有诸不相应法所作因。若有共生因亦有相似因耶。答曰。若有相似因。亦有共生因。颇有共生因无相似因耶。答曰。有未来世共生因。若有共生因亦有一切遍因耶。答曰。若有一切遍因。亦有共生因。颇有共生因无一切遍因耶。答曰。有非一切遍共生因。若有共生因亦有报因耶。答曰。若有报因者。亦有共生因。颇有共生因非报因耶。答曰有。无记无漏共生因。若有共生因亦有所作因耶。答曰。若有共生因。亦有所作因。颇有所作因非共生因耶。答曰有。无为法所作因。若有相似因亦有一切遍因耶。答曰。若有一切遍因亦有相似因。颇有相似因无一切遍因耶。答曰有。非一切遍相似因。有相似因。亦有报因耶。若有报因亦有相似因耶。乃至广作四句。有相似因无报因者。无记无漏相似因。有报因无相似因者。未来世报因。有相似因亦有报因者。过去现在报因。非相似因非报因者。除上尔所事。若有相似因亦有所作因耶。答曰。若有相似因亦有所作因。颇有所作因非相似因耶。答曰有。未来世无为法所作因。若有一切遍因。亦有报因耶。若有报因。亦有一切遍因耶。乃至广作四句。一切相遍因非报因者。无记一切遍因。有报因非一切遍因者。未来世报因。过去现在非一切遍报因。一切遍因报因者。一切遍报因。非一切报因非报因者。除上尔所事。若有一切遍因。亦有所作因耶。答曰。若有一切遍因。亦有所作因。颇有所作因。非一切遍因耶。答曰有。未来世过去现在非一切遍无为法所作因。若有报因。亦有所作因耶。答曰。若有报因。亦有所作因。颇有所作因。非报因耶。答曰有。无记无漏所作因

问曰。此六因。几色几非色。答曰。二是非色。谓相应因。一切遍因。余是色非色。如色非色。相应不相应。有依无依。有势用无势用。有缘无缘。有对无对。可见不可见。当知亦如是。问曰。此六因。几有漏几无漏。答曰。二有漏。谓一切遍因报因。余有漏无漏。问曰。此六因。几有为几无为。答曰。五是有为。相应因乃至报因。一是有为无为。谓所作因。问曰。此六因。几过去几现在几未来。答曰。二是过去现在谓相似因一切遍因。三在三世。谓相应因共生因报因。一在三世亦不在世。谓所作因。问曰。此六因。几善几不善几无记。答曰。一是不善无记谓一切遍因。一是善不善谓报因。余是善不善无记。问曰。此六因。几欲界系乃至不系。答曰。三是三界系。谓一切遍因报因。余是三界系不系。问曰。此六因。几学几无学几非学非无学。答曰。二是非学非无学。谓一切遍因报因。余是三种。问曰。此六因。几见道所断几修道所断几无断。答曰。一是见道所断谓一切遍因。一是见道修道断。谓报因余是见道断修道断不断。问曰。此六因。几染污几不染污。答曰。一是染污。谓一切遍因。余是染污不染污。如染污不染污。有过无过黑白。隐没不隐没退不退。当知亦如是。问曰。此六因。几有报几无报。答曰。一是有报谓报因。余是有报无报相应因共生因。现在世一刹那顷。取果与果。相似因。一切遍因。所作因。现在取果。过去现在与果。一刹那取果。多刹那与果。报因现在取果。过去与果。一刹那取果。多刹那与果。若心有使使有使心。彼使使此心耶。乃至广说。问曰。何故作此论。答曰。为止一心者论故。彼作是说。有使心无使心。即是一心。所以者何。圣道生时。与使相妨。不与心相妨。如治刀法。与垢相妨。不与刀相妨。如衣器镜垢。与治法相妨。不与衣器镜等相妨。如是圣道生时。与使相妨。不与心相妨。乃至圣道未生心则有使。圣道若生心则无使。我人论者作如是说。人缚人解非法缚解。尊者昙摩多罗作如是说。诸使不相应使。亦不缘使。彼作是说。若作缘使相应使无漏法。若作相应使。一切时恒使无不与心心数相应时。以是事故。欲止他义。欲显己义。欲现与法相相应义故。而作此论也

若心有使者。有五种心名有使。见苦所断心。乃至修道所断心。以二事故。心名有使。一以使性。二以伴性。见苦所断心。见苦所断使。有二事使性伴性。见集所断一切遍使有使性。余使无使性伴性。见集所断心。见集所断使。有二事使性伴性。见苦所断一切遍使有使性。余使无使性伴性。见灭所断心。见灭所断使。有二事使性伴性。见苦见集所断一切遍使有使性。余使无使性伴性。见道所断亦如是。修道所断心。修道所断使。有二事使性伴性。见苦见集所断一切遍使有使性。余使无使性伴性。见苦所断心。与一切遍相应。不一切遍相应。见集所断亦如是。见灭所断心。有漏缘使相应。无漏缘使相应。见道所断亦如是。修道所断心。染污不染污。彼见苦所断一切遍使相应心。见苦所断一切遍使。有二事使性伴性。见苦所断不一切遍使。见集所断一切遍使有使性。余使无使性伴性。见苦所断不一切遍使相应心不一切遍使。有二事使性伴性。见苦见集所断一切遍使。有使性无伴性。余使俱无。见集所断亦如是。见灭所断有漏缘使相应心。见灭所断有漏缘使。有二事使性伴性。见苦见集所断一切遍使。有使性无伴性。余使俱无。见灭所断。无漏缘使相应心。见灭所断无漏缘使俱有。见灭所断有漏缘使。见苦见集所断一切遍使。有使性无伴性。余使俱无。见道所断亦如是。修道所断染污心。修道所断使俱有。见苦见集所断一切遍使。有使性无伴性余使俱无。修道所断不染污心。修道所断使。见苦见集所断一切遍。有使性无伴性性。余使俱无。彼见苦所断心有十种。谓五见相应心。疑爱恚慢。不共无明相应心。见集所断心有七种。谓二见相应心。疑爱恚慢。不共无明相应心。见灭所断亦如是。见道所断心有八种。谓三见相应心。疑爱恚慢。不共无明相应心。修道所断有五种。谓爱恚慢。不共无明相应心。不染污善无记相应心。彼身见相应心。身见身见相应无明。有二事。有使性伴性。余见苦所断使。见集所断一切遍使。有使性无伴性。乃至见苦所断慢使亦如是。见苦所断不共无明相应心。见苦所断不共无明使。有二事使性伴性。余见苦所断使。见集所断一切遍使。有使性无伴性。余使俱无。见集所断。亦应如是说。见灭所断邪见相应心。见灭所断邪见邪见相应无明。有二事使性伴性。见灭所断有漏缘使。见苦集所断一切遍使。有使性无伴性。疑相应心。当知亦如是。见灭所断见取相应心。见灭所断见取。见取相应无明俱有。余见灭所断有漏缘使。诸一切遍有使性无伴性。余俱无见灭所断爱恚慢。当知亦如是。见灭所断不共无明相应心。见灭所断不共无明使俱有。见灭所断有漏缘使。诸一切遍。有使性无伴性。余使俱无。见道所断。亦应如是说。修道所断爱相应心。修道所断爱。爱相应无明俱有。余修道所断使。诸一切遍。有使性无伴性。余使俱无。修道所断恚慢。当知亦如是。修道所断不共无明相应心。修道所断不共无明俱有。余修道所断使。诸一切遍使。有使性无伴性。余使俱无。修道所断不染污心。修道所断使。诸一切遍使。有使性无伴性。余使俱无。所说是集要毗婆沙。若心有使。三界有五种。使有使心。三界亦有五种

若心有使使有使心。彼使使此心耶。答曰。或使或不使。云何使。答曰。诸使未断彼使使此有使心。云何不使。答曰。诸使断。彼使不使。此有使心。所以者何。诸使未断故使。断故不使

问曰。何故缘使未断。名有使心。断则不有。相应使断与不断。恒名有使心耶。答曰。先作是说。以二事故。心名有使。一是使性。二是伴性。诸缘使与心。是名使性。不名伴性。若彼得断。彼使性义亦断。相应使有二事使性伴性。彼若得断。使性则断。伴性不断。不能除心伴性。如去文阇草皮。尊者和须蜜说曰。相应使心。染污缘使心。不染污相应使无别异。缘使不尔。相应使覆蔽心。缘使不尔。相应使同一所依。同一行。同一缘。缘使不尔。相应使与心同一生一住一灭。缘使不尔。亦同一果一依一报。缘使不尔。相应使与心俱生。缘使不尔。无有能除心相应使。如去文阇草皮

设使使心即使使。彼有使心耶。答曰。或是彼非异。或是彼是异。是彼非异者。或有说者。具缚凡夫染污心。评曰。不应作是说。所以者何。具缚者可尔。不具亦可尔。染污心可尔。不染污心亦可尔。应作是说。若心不断。是说为使所使。心名有使。若不为使所使。是说心名无使。是彼是异者。苦智已生。集智未生。若心见苦所断。见集所断缘。是彼者见集所断使所使。是异者。见苦所断不使。问曰。以何等故。他种说是彼自种说是异。答曰。是故先作是说。设使使心即彼使有心。彼见集所断使缘使故。说是彼见苦所断不使故说是异。复有说者。是异者置异处故。云何置异处。断故说置异处。复有说者。本得自在随意所作。今者已断。是故说异。复有说者。今已断故。更无所为。犹如死人。是故说异。复有说者。圣道力使彼异故说异。问曰。修道中亦有是彼是异何故不说。答曰。或有说者。应说而不说者。当知此义是有余说。复有说者。若他种是彼自种是异。此中说之。修道所断自种。是彼自种是异。是故不说。问曰云何缘使。云何相应使。罽宾沙门作如是说。诸使随所行。如爱于境界爱乐可适。广说余使。随所行亦尔。相应使者。如同罪同系。西方沙门作如是说。系缚义。是缘使。亲近义。是相应使。尊者婆已说曰。以四事故使名所使。一堕恶意。二如火热。三如烟尘垢。四是呵责。堕恶意者。如一人作恶令多人亦作。以一烦恼故。令多心心数法尽堕恶意。如火热者。如火烧铁丸所著器中其器皆热。如是烦恼从何心品生令彼皆热。如烟尘垢者。如烟尘垢所著之处令彼皆污。如是诸烦恼。随彼生处。令彼心垢污。呵责者。如一比丘作恶令僧受呵责。如是诸使。随彼生处。令彼心受呵责。云何相应使。答曰。如缘使所使。相应使亦尔。问曰。相应使无缘。云何说如缘使。答曰。相应使虽无缘。有如上四过。问曰。过去未来使能使不耶。答曰。能使。若不使者。无染心现在前。应是无使。人复有说者。出生诸得。如火出烟。过去未来诸结出生。诸得亦复如是。复有说者。若不使者。则违佛经。如经说。佛告摩勒子比丘童子。不知欲事况起欲心。然为欲爱所使。复有说者。以五事。故。过去未来使所使。一不断其因。二得不断。三不转其器。四不知缘。五不得对治

若心有使。使有使心。彼使此心当断耶。此说缘使当断。诸使于缘可制伏。相应使不可制伏。如去文阇草皮。若心有使。乃至广说。云何断诸使。于缘不断不应作是说。诸使于缘不断。所以者何。先已问故。应作是说。诸使不断当断。云何不断。诸使已断。及相应使。诸使云何断。答曰。诸使缘断。先已现义(先已现义者上言缘使当断者是也)。今欲说文。诸使于缘生过患。是故制伏于缘。如人好乐博奕喜入酒舍淫舍而可制伏。如是诸使于缘生过患。亦可制伏。如是汝语诸使缘断耶。此是定他之言。若不定他言。说他过患。反生自过。彼作是说。答曰。如是若作是说。诸使见灭见道所断无漏缘。此使云何断。若言此相应使断。先定言诸使缘断非相应使。若如所说诸使缘断者。诸使于缘不生过患。应作是说。诸见灭见道有漏缘使。此使当断。此使若断。彼使亦断。如树有根茎叶等滋茂。若断其根茎等。更不滋茂。彼亦如是。问曰。若然者。先定言诸使缘断。今则明后缘使断。复有说者。如是使缘断耶。答曰。诸使若见所缘则断。若作是说。诸使见灭见道有漏缘使。此使云何断。若见苦集断。此使非见苦集时断。若见灭道断。此使则不缘灭道应作是说。诸见灭道无漏缘使若断。彼使亦断。所以者何。有漏缘使。依无漏缘使。而得增长。若彼无漏缘使断。此亦断。如人依材得立。若去其材。是人必堕。彼亦如是。问曰。若然者先定言诸使见缘断今则明缘使断。答曰。若尔有何过。诸使见缘则断。何况所缘断而彼不断耶。如果依树。动树则堕。何况断根而不堕耶。彼亦如是。复有说者。如是使缘断耶。答曰。诸使有缘道所断。评曰不应作是说。所以者何。世尊说。此八圣道。能断去来今苦。永无生分。灭尽离欲。得寂灭涅槃。有缘道。无缘道。俱能断使。尊者奢摩达多说曰。以四事故诸使断。一以缘断故。二以后缘故。三以展转相缘故。四得对治故。以缘断者。见灭道所断有漏缘使。以后缘断者。自界使断。他界缘使亦断展转缘断者。余有漏缘使。得对治断者。随所得对治。即以断彼使。复有说者。以四事故诸使断。一知缘故断。二断缘。三断后缘。四得对治断。亦应广说也

设使心当断。彼心有此使耶。答曰。或是彼非异。或是彼是异。云何是彼非异。答曰。若心无染。修道所断。是彼缘使非异相应使使所使。所以者何。以体无使故。是彼是异者染污心。是彼者缘使所使。是异者共住不相离。问曰。以何等故相应使说是异。答曰。是故先作是说。设使心当断。彼心有此使耶。诸缘使说是当断。彼心说有使莫谓诸当断者。是心有使。诸不断者。如相应使非心有使。欲现决定义故。亦说心有使。复有说者。彼相应使。虽不与心可断。而于缘可断。伏复有说者。欲生论本。故作是说。是彼者缘使。是异者相应使。颇使断慧不见所缘。慧见所缘使不断。乃至广作四句。使断慧不见所缘者。见谛道中。见欲界苦集时。断他界缘使。见灭道时。断见灭道所断有漏缘使修道中。以灭道法智离欲时。断修道所断使。慧见所缘使不断者。见色无色界苦集时。欲界他界缘使。见苦时见集所断自界缘使。见灭道所断有漏缘使。修道所断使见集时。当知亦如是。修道中以苦智集智等智离欲时。见道所断有漏缘使。以灭智道智离欲时。无漏缘使。使断慧见所缘者。见苦见集时。自界缘使。见灭道时。无漏缘使。修道中以苦智集智等智离欲时。断修道所断使。使不断慧不见所缘者除上尔所事。颇一刹那顷。使断慧不见所缘。慧见所缘使不断。乃至广作四句。使断慧不见所断者。一品欲乃至离多分欲。道法忍现在前时。彼断欲界见道所断有漏缘使。慧见所缘使不断者。先所断道谛所断无漏缘使。使断慧亦见所缘者。断见道所断无漏缘使。使不断慧不见所缘者。先所断见道有漏缘使。道比忍亦应作如是四句。见灭时亦作如是二四句。颇使灭身作证慧不见灭。身不作证慧见灭。乃至广作四句。初句者见苦时断见苦所断使。见集时断见集所断使。见道时断见道所断使修道中以苦智集智道智等智离欲。断修道所断结。第二句者。见灭时见苦见集见道所断使。第三句者。见灭时断见灭所断使。修道中以灭智离欲第四句者。除上尔所事。颇一刹那顷。使灭身作证慧不见灭。慧见灭身不作证。乃至广作四句。以灭法智。得斯陀含果时。使灭身作证慧不见灭者。色无色界见道所断使。慧见灭身不作证者。欲界余不断使。身作证慧见灭者。欲界先所断使。及今所断使。非身作证非慧见灭者。色无色界修道所断使。云何缘断因识。乃至广说。此中所说识者。所缘断因亦断。诸作是说。自种不与自种。作遍因者。此说缘断因识因都断。其事云何。苦智已生。集智未生。若心集谛所断。苦谛所断缘。此说因都断所缘都断缘断因识。是时集谛所断心缘。集谛所断缘灭道修道所断。此心因都断所缘不断。是时集谛所断心缘。苦集灭道修道所断。此心因都断所缘。有断不断。诸作是说。自种与自种。作遍因者。是说他种因断缘断因识。其事云何。苦智已生。集智未生。若心集谛所断苦谛所断缘。是名缘断因识。所以者何。苦谛所断是彼因。是彼所缘。彼已俱断故。名缘断因识。若以苦谛所断言之。是缘断因识。若以集谛所断言之。因有断不断缘断。是时集谛所断心缘集灭道修道所断因有断不断所缘不断。是时集谛所断心。缘苦所断。乃至修道所断因。有断不断。所缘亦有断不断。如此现义。今当说文缘断因识几使。答曰。十九一心耶。答曰。不也。未离欲界欲。苦智已生。集智未生。若心集谛所断苦谛所断缘。此心为欲界集谛所断七使所使。已离欲界欲。未离色界欲。乃至彼识为几使所使。答曰。色界集谛所断六使。问曰未离欲界欲亦可尔。何以说离欲界欲耶。答曰是中说现前行时。不说成就色界使现在前时。要离欲界欲。非不离欲。是故说现前行时。不说成就离色界欲未离无色界欲。评曰。不应说未离无色界欲。所以者何。若集智未生。当知未离无色界欲。应作是说。离色界欲。苦智已生集智未生。乃至广说。彼识几使所使。答曰。无色界集谛所断六使。问曰修道中亦有缘断因识。其事云何。答曰如上上使断余八种心。是缘断因识。所以者何。彼上上断使。亦是因亦是所缘。乃至八种断余一种未断八种。于一种。亦是因亦是所缘。何故不说耶。答曰应说而不说者。当知此义是有余说。复有说者。他种为因他种为缘。是他种识。是中说之。彼三种尽在修道中。彼虽有九种而尽在修道中。是故不说

问曰以何等故。诸因次第说使。答曰以是阿毗昙藏故。应以十四事了知阿毗昙。何等十四。六因四缘摄相应成就不成就。若了知此十四事。名了知阿毗昙。复有说者。应以七事了知阿毗昙一善知因。二善知缘。三善知总相。四善知别相。五善知摄不摄。六善知相应不相应。七善知成就不成就。若于七法善知者。当知于阿毗昙亦善。于七法善者名阿毗昙人。非谓但诵持其文

阿毗昙毗婆沙论卷第十二阿毗昙毗婆沙论卷第十三

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    杂揵度人品第三上

一人此生十二支缘。几在过去几在未来几在现在。如是章及解章义。此中应广说优波提舍。问曰何故作此论。答曰为止他义故。如毗婆阇婆提说缘起是无为法。问曰彼以何义故说缘起是无为法。答曰彼依佛经。佛经说若佛出世若不出世。法住法界。如来成等正觉。为他显现乃至广说。彼以是义故说缘起法是无为。为止如是说者意故。缘起法堕在世中。若堕在世。当知缘起法定是有为非是无为。所以者何。无有无为法堕在世中。问曰若缘起是有为法。彼经云何通。若佛出世。若不出世。法住法界。乃至广说。答曰应知彼经意趣。问曰彼经意趣云何。答曰彼经说因果决定义故。若佛出世若不出世。无明常是行因。行常是无明果。如是乃至生是老死因。老死是生果。如此义是彼经意趣。若如汝所解。彼经意趣。若佛出世若不出世。地常坚相。乃至风常动相。四大可是无为法耶。若佛出世若不出世。色常色相。乃至识常识相。如是诸阴。复是无为法耶。若佛出世若不出世。诃梨勒果迦中伽卢醯尼药。常是苦味。复是无为法耶。如汝所说。若佛出世若不出世。四大诸阴。诃梨勒果迦中伽卢醯尼药等。常是有为。如是缘起法。若佛出世若不出世。虽住法界亦应是有为。非是无为。是故为止他义欲显己义。亦欲现法相相应义故。而作此论

一人此生乃至广说。彼尊者于此中。欲明五种义故。一者何以唯说一人。二者为说何等人。三者何以说此生。四者为说何等生。五者说何现在。唯说一人者。欲去经文烦闹过故。若说一切众生经文则烦。欲令无烦过故唯说一人。如说一人当知一切众生亦尔。为说何等人者。若人经历十二支缘。犹如登石亦如上梯。若过去无明行起现在前。能生现在识名色六入触受。若现在爱取有起现在前。能生未来生老死者。说如此人。若过去无明行起现在前。能生现在识名色六入触受。若现在爱取有不起现在前。不能生未来生老死者。此中不说如此人。若过去无明行。乃至能生未来生老死者。此中说之。如智揵度中所说。学人成就八种道迹。彼中为说何等学人。答曰若经历诸禅三昧。犹如登石亦如上梯者。先入有觉有观定。次入无觉无观定。次入无色定。出无色定入灭尽定。出灭尽定起世俗心。现在前者彼中说如此人若入有觉有观定从彼定起。乃至入灭尽定。从灭尽定起。无漏心现在前者。彼中不说。若入有觉有观定。从彼定起。乃至入灭尽定。从灭定起。有漏心现在前。彼中说之亦如经说。见此姊妹形容端正。彼于后时羸瘦老劣。复于后时见病着床席。复于后时见其已死。经一日二日乃至七日。复于后时见其色青。乃至骨节散坏。彼中所说女人。要经上尔所时事。若不经上尔所时事。彼中不说。此中说一人者要经历十二因缘。广说如上。何以说此生者。若说现在生。当知说过去未来亦尔。为说何等生者。通此一身以生名说。说何现在者。说此一生现在。不说刹那现在。不说时现在

一人此生十二支缘。几在过去。答曰二谓无明行则止无前世所更事。二在未来谓生老死则止无未来世生事。八是现在识。乃至有则说因果相续。二是过去则止常见。二是未来则止断见。八是现在则显中道。问曰过去亦有十二支缘。未来亦有十二支缘。现在亦有十二支缘。何故说二在过去二在未来八在现在耶。答曰现在法。以因推果以果推因。现在以因推果者。现在爱取有。是未来生老死因。生老死是其果。以果推因者。现在识名色六入触受果。此因是过去无明行。以现在因推果。以现在果推因故。而作是说。此中说众生数缘起法。如波伽罗那经所说。云何缘起法。答曰一切有为法。问曰此说彼说有何差别。答曰此说众生数。彼说众生数非众生数。此说有根法。彼说有根无根法。此说有心法。彼说有心无心法。此说内法。彼说内外法。此文不了义。彼文了义。乃至广说。缘起法有四种。一者刹那。二者相续。三者时。四者次第。此说刹那。彼说相续。此说时。彼说次第。问曰。此中何以唯说众生数缘起法耶。答曰彼尊者依佛经作论。佛经中说众生数缘起法。佛经是此论根本。是故彼尊者依佛经作论。问曰如是因论生论。以何等故世尊经中。唯说众生数缘起法。不说非众生数。答曰随顺有义是支义。此支随顺有故。是故唯说众生数。不说非众生数。如此经说众生数缘起法。当知余经说有支。亦说众生数缘起法。问曰缘起法缘生法有何差别。答曰或有说者无有差别。所以者何。如波伽罗那经所说。云何缘起法。一切有为法。云何缘生法。一切有为法。此义可尔。然亦应更求差别相。因是缘起。果是缘生。如因果。事所事。相所相。成所成。续所续。生所生。取所取。当知亦如是。复有说者。过去是缘起。未来现在是缘生。复有说者。过去是缘起。未来是缘生。复有说者。无明是缘起。行是缘生。乃至生是缘起。老死是缘生。复有说者。无明是缘起。老死是缘生。余十支是缘起缘生。复有说者。二在过去是缘起。二在未来是缘生。余支是缘起缘生。尊者富那奢说曰。此中应作四句。或有缘起非缘生。或有缘生非缘起。乃至广作四句。缘起非缘生者。未来法是也。缘生非缘起者。过去现在阿罗汉最后死阴是也。缘起缘生者。除过去现在阿罗汉死五阴。诸余过去现在法是也。非缘起非缘生者。无为法是也。如法身经所说。诸无明决定生行不相离常相随。是名缘起缘生。若无明不决定生行。或时相离不相随。是名缘生非缘起。乃至生老死。亦应如是说。尊者和须蜜说曰。因是缘起。从因生法是缘生。复次和合是缘起。从和合生是缘生。复次起所起。生所生亦如是。缘起缘生是谓差别

问曰此缘起法体性是何。答曰体是五阴。五阴是缘起体。是性是我。是物是相。已说体性。所以今当说。以何等故名缘起法。答曰或有说者。体性可起待缘而起故名缘起。复有说者。各各从异缘起故名缘起。复有说者。等从缘生故名缘起。问曰诸法或从四缘生。或从三缘生二缘生。云何等从缘生是缘起义耶。答曰。即以是事故。等从缘生是缘起义。若法应从四缘生者。三缘二缘则不能生。从三缘生者。二缘四缘则不能生。从二缘生者。三缘四缘则不能生。以是事故等从缘生。是缘起义。复有说者。法生时除其自体。余一切法与威势缘。以是事故等从缘生。是缘起义。复有说者。等生是缘起义。如说一切众生心等生等住等灭。复有说者。一切众生等同此缘。故名缘起法。问曰如此众生。或有前般涅槃者。或有后般涅槃者。云何等同此缘耶。答曰前般涅槃者。于缘起法前少后多。后般涅槃者。于缘起法前多后少。以是事故等从同缘生。是缘起义。此中说时缘起法。有十二时十二支十二五阴。尊者奢摩达说曰。于一刹那顷。有十二支缘。若以贪心杀生。彼相应愚是无明。彼相应思是行。彼相应心是识。起有作业必有名色。起有作业必有六入。彼相应触是触。彼相应受是受。贪即是爱。彼相应缠是取。彼身口作业是有。如此诸法生是生。此诸法变是老。此诸法坏是死。此所说可尔。但此中说时缘起。有十二时十二支十二五阴。不说一刹那顷也。如识身经说。于前物愚故生爱。愚即是无明。爱即是行。分别前物是识。与识俱生四阴是名色。与名色相随诸根是六入。六入和合是触。触所更是受。受所乐是爱。爱增广是取。能得未来业是有。增长诸阴是生。诸阴变是老。阴散坏是死内热是忧。发声哀泣是悲。身心燋悸是苦恼。如是等事是大苦阴。种种厄难。问曰前说此说有何差别。答曰前说是一心。此说是多心。前说是一刹那后是多相续

如施设经所说。云何无明。过去诸结是也。评曰不应作是说。若然者诸法则离自相。应作是说。云何无明过去诸结时。云何行过去诸行时。云何识相续心及眷属。云何名色。已受生相续。未生四种色根。六入未具。一歌罗罗。二阿浮陀。三卑尸。四伽那。五波罗奢呵。如是等名曰名色。云何六入。已生四种色根。具足六入。此诸根未能为触作所依。是时名六入云何为触。此诸根已能为触作所依。未别苦乐。不能避危害搊火触毒把刃及诸不净。是时名触。云何为受。能分别苦乐避诸危害不搊火触毒不把刃。离诸不净。能生贪爱不起淫欲。于一切物不生染着。是时名受。云何为爱。具上三爱。是时名爱。云何为取。以贪境界故四方追求。是时名取。云何为有。追求之时起身口意业。是时名有。云何为生。如现在识在于未来。是时名生。云何老死。如现在名色六入触受在于未来。是时名老死。复有说者。无明有二种。有破体无明。有不破体无明。缘行有二种。有思有思所造。行缘识有二种。有与悔俱有不与悔俱。识缘名色有二种。有爱处有不爱处。名色缘六入有二种有报有长养。六入缘触有二种。有对触增语触。触缘受有二种。有身受有心受。受缘爱有二种。有淫欲爱有资生爱。爱缘取有二种。有从见生有从爱生。取缘有有二种。有从内生有从外生。有缘生有二种。有一刹那有通一身。生缘老有二种。有眼所见有与慧所见。老缘死有二种。有刹那死有一身死

如说无明因行。问曰以何等故。但说无明缘行。不说无明因行耶。答曰或有说者。亦说无明因行。如摩诃尼陀那经所说。佛告阿难。以如是因如是缘如是事。生为老死因。如生为老死因。乃至无明为行作因亦如是。复有说者。若说无明因行。但说因缘。不说余缘。若说无明缘行。则具说四缘。复有说者。若说无明因行。唯说染污行。若说无明缘行。则说染污不染污行。问曰以何等故唯说无明缘行。不说行缘无明。答曰或有说者。若说行缘无明。则唯说缘不说因。复次此中说时缘起法。前生者是无明后生者是行。问曰如无明是十二支缘。何以但说无明缘行。答曰或有说者。应说而不说者。当知此说有余。乃至广说。复有说者。缘有二种。有近有远。若说无明缘行则说近缘。若于余支则说远缘。是中说近不说远。如近远。此生他生当知亦如是。复次无明与行作缘随顺不同余支。是故说与行作缘不与余支。如说行缘识。亦说名色缘识。复说缘二生识。此三有何差别。答曰或有说者。行缘识说业差别。名色缘识说识住差别。缘二生识。说所依及境界差别。复有说者。行缘识如初取时。名色缘识如守护时。缘二生识如长养时。复有说者。行缘识说初相续。名色缘识说已成立。缘二生识说成立已能缘境界。复有说者。行缘识说行名色。名色缘识说报名色。缘二生识说所依及缘境界。复有说者。行缘识说恶趣识。名色缘识说人及六欲天识。缘二生识说色无色界色识。尊者波奢说曰。行缘识是中阴识。名色缘识是生阴识缘二生识是根本有识。复有说者。行缘识。名色缘识说染污识。缘二生识说染污不染污识。如染污不染污。隐没不隐没。有过无过。退不退。当知亦如是。问曰识缘名色名色缘识有何差别。答曰识缘名色说初相续。名色缘识已相续说成立。如是识缘名色说初生。名色缘识说生已守护。复有说者。此展转相缘。如束苇相依而立。如御者与象展转相依能有所至。亦如船与船师展转相依到彼岸。问曰如化生。云何识缘名色。答曰此说胎生不说化生也。评曰应说化生亦尔。如化生者。初得诸根。未猛利时。说是识时。后若猛利。说名色。名色缘六入。问曰如名色在六入内。何故言名色缘六入耶。答曰如先说。未得四种色根。六入未具歌罗罗阿浮陀卑尸伽那波罗奢佉时。是名名色时。六入缘触。问曰此中说六入缘触。余处复有说名色缘触。复说缘二生触。此三有何差别。答曰六入缘触。说所依差别。名色缘触。说所依及境界差别。所以者何。一切外法和合。皆依于内。缘二生触。说现在触。复有说者。六入缘触说时触。名色缘触即说触体。缘二生触。说三等触。触缘受。问曰触受是相应共有法。何故说触缘受不说受缘触耶。答曰虽是相应共有法。自有法与彼法。有随顺有不随顺。如触与受作缘随顺。受与触作缘不随顺。如灯虽与照俱生。灯是照因。照非灯因。彼亦如是。如向所说。此中说时缘起法。触是前时。受是后时。是故说触缘受。不说受缘触受缘爱。问曰如乐受缘爱可尔。所以者何。为称意故。四方追求苦受。云何与爱作缘。尊者和须蜜说曰。苦受与爱作缘。胜于乐受不苦不乐受。其事云何。如世尊说。为苦受所逼。贪求乐受。受乐受故。为欲爱使所使。复有说者。三种受。尽能与爱作缘。其事云何。义言曰乐受作如是说。我能使生有相续。众生以贪我故。四方追求。苦受作如是说。我亦能使生有相续为我所逼。以贪乐故。四方追求。不苦不乐受。作如是说。有苦乐受处。我亦能使生有相续。何况第四禅已上无苦乐处。而不能也。复有说者。三受悉能与爱作缘。如识身经所说。不如实知三受。便生于爱。问曰此三受云何与爱作缘耶。答曰爱有五种。一求乐爱。二不欲离乐爱。三不生苦爱。四速离苦爱。五愚爱。求乐爱者。未生乐受。欲令生故生爱。不欲离乐爱者。已至乐受。心不欲离故生爱。不生苦爱者。苦受未至。欲令不生故生爱。速离苦爱者。已生苦受。欲令速灭故生爱。未生不苦不乐受。欲令生故生爱。已生欲不失故生爱。亦能生于愚爱。爱缘取。问曰受缘爱取中爱。此二有何差别。答曰。初生爱名爱。爱增广名取。复有说者。下者名爱。上者名取。复有说者。若爱以受为因。是名受缘爱。以爱为因。是名为取。复有说者。若爱是受果。是名受缘爱。若爱是爱果。是名为取。复有说者。若爱从受生。是名受缘爱。若爱从爱生。是名为取。复有说者。若爱能生烦恼。是名受缘爱。若爱能生业。是名为取。问曰以何等故。前生缘起无明在初。后生缘起爱在初耶。答曰或有说者。以此二结是根本使。无明是过去缘起因。爱是未来缘起因。复有说者。无明有六事。一通五种。二通六识。三能起身口业。四是使性。五断善根时。能作坚强方便。六是一切遍爱有。五事如上所说。唯非一切遍。以无明有六事故。在前生缘起法初。以爱有五事故。在后生缘起法初。复有说者。无明有三事故说在初。一常为元首。二与一切结相应。三是一切遍爱。于受生法中胜故。说在后缘起法初。复有说者。无明有四事。一缘有漏无漏。二缘有为无为。三是遍非遍。四能缘自界他界。爱唯缘有漏缘有为。是不遍缘自界。以是事故。爱能生未来苦胜故。说在后缘起法初。此中因事故略说。后当广说。有缘生。问曰以何等故。三有为相中。生独说一支。老死共说一支耶。尊者波奢说曰。佛知诸法相。余无能过。乃至广说。复有说者。随其事相故。法起时生势用胜。法灭时老死势用胜。复有说者。法起时生能使此法相续成立。老死能使不相续不成立。问曰以何等故。病不立有支耶。答曰。或有说者。病无支相故。复有说者。若一切众生。一切时一切处有者说支病。非一切众生一切时一切处尽有。如尊者婆拘罗所说。我于佛法中出家。年过八十不曾有小头痛。何况身病。如此欲界众生不尽有身病。况色无色界老死缘忧悲苦恼。问曰忧悲苦恼。为是有支非耶。答曰非也。所以者何。有支既立忧悲等法。坏散有支。犹如霜雹。是故非支。问曰如忧悲等法坏散有支。犹如霜雹。十二有支尽为作缘。何以唯说老死耶。答曰或有说者。应作是说。无明缘行。乃至忧悲苦恼。而不说者。当知此说有余。复有说者。以终显始故。复有说者。老死时生大忧悲苦恼故。复有说者。当于尔时。行恶行者。生大恐怖故。问曰无明为有因不。老死为有果不。若有者。云何不有十三十四支缘耶。若无者云何无明非是无因法。老死非是无果法耶。答曰应作是说。无明有因。老死有果。但不在有支中。何者是无明因。谓不正念思惟。何者是老死果。谓忧悲苦恼。复有说者。无明有因老死有果。体是有支。非不在有支中。是故有支有非十三十四。无明因是何。谓老死老死果是何。谓无明。现在爱取是过去无明。现在名色六入触受。此四若在未来名老死。如说受缘爱。当知说老死缘无明。十二支缘当知犹如轮转

应知有一种缘起法。如说云何缘起法。谓一切有为法。复有二种缘起法。所谓因果。复有三种缘起法。所谓业烦恼体。行有是业。无明爱取是烦恼。余支是体。复有四种缘起法。所谓无明行生老死。现在八支。应摄在过去未来四支中。现在爱取摄在过去无明中。现在有摄在过去行中。现在识摄在未来生中。现在名色六入触受摄在未来老死中。复有五种缘起法。所谓爱取有生老死。过去现在七支。应摄在现在未来五支中。过去无明是现在爱取。过去行是现在有。现在识是未来生。现在名色六入触受是未来老死。复有六种缘起法。过去因果。现在因果。未来因果。复有七种缘起法。所谓无明行识名色六入触受。诸未来现在五支。应摄在过去现在七支中。现在爱取是过去无明。现在有是过去行。未来生是现在识。未来老死是现在名色六入触受。复有八种缘起法。所谓识乃至有。过去未来四支。应摄在现在八支中。过去无明是现在爱取。过去行是现在有。未来生是现在识。未来老死是现在名色六入触受。复有九种缘起法。如摩诃尼陀那经所说。复有十种缘起法。如城喻经所说。复有十一种缘起法。如智种中说。复有十二种缘起法。如余经处处中说十二有支

此十二支缘。烦恼为业作缘。业为苦作缘。苦为苦作缘。苦为烦恼作缘。烦恼为烦恼作缘。烦恼为业作缘。业为苦作缘。苦为苦作缘。如说无明缘行。是名烦恼为业作缘。行缘识是名业为苦作缘。识缘名色乃至触缘受。是名苦为苦作缘。受缘爱是名苦与烦恼作缘。爱缘取是名烦恼与烦恼作缘。取缘有是名烦恼与业作缘。有缘生是名业与苦作缘。生缘老死是名苦与苦作缘

此十二支缘。二是相续余是三分。二是相续者识与生。三分者业烦恼体。业者行与有。烦恼者无明爱取。体者谓余支。如业烦恼体。当知三集三道亦如是

此十二支缘。如树有根有体有花有果。无明行是其根。识名色六入触受是其体。爱取有是其花。生老死是其果。此十二支缘。或有花有果或无花无果。有花有果者。谓凡夫人学人。无花无果者。谓阿罗汉

问曰此十二支缘。几是刹那几是相续。答曰二是刹那。谓识与生。余是相续。问曰十二支。几是染污几是不染污。答曰。五是染污。谓无明识爱取生。余是染污不染污。评曰此中说时缘起法。应说是染污不染污。如前所说五时。若是心心数法是染污。余染污不染污

此十二支缘。几在欲界几在色无色界。答曰或有说者。此中唯说欲界网生众生。复有说者。欲界有十二支。色界有十一支除名色时。无色界有十支除名色六入时。色界应作是说识缘六入。无色界应作是说识缘触。评曰应作是说。欲界有十二支。色无色界亦有十二支。问曰如色界无名色。无色界无名色六入。云何俱有十二支耶。答曰如初生色界众生。诸根未猛利。名名色时。无色界虽无色有名。虽无色根。而有意根。彼应作是说。识缘名。名缘意入。意入缘触以是义故一切处悉有十二支缘

相似有支。还令相似有支相续。欲界有支还令欲界有支相续。色无色界亦如是。唯除受时。能令不相似支相续。其事云何。如生欲界中未离欲。起欲界爱取有现在前。造未来生老死。彼现在有一爱一取一有。未来有一生一老死。离欲界欲。未离初禅欲。起初禅爱取有现在前。造未来生老死。彼现在有二爱二取二有。未来有二生二老死。如是乃至离无所有处欲。未离非想非非想处欲。起非想非非想处爱取有现在前。造未来生老死。彼现在有九爱九取九有。未来有九生九老死。彼人从欲界命终。生非想非非想处。彼本曾起非想非非想地。现在爱取是过去无明有是行。未来生是现在识。未来老死。是现在名意触受。诸余地若现在。若未来诸支。彼亦不过去。亦不现在。亦不未来。所以者何。若成就因果则有过去未来现在。以不成就因果故。则无过去未来现在。彼复从非想非非想处命终。生无所有处。本曾起无所有处。现在爱取有。爱取是过去无明。有是过去行。未来生是现在识。未来老死是现在名意触受。诸余地若现在未来诸支。亦不过去未来现在。所以者何。以成就因果故。则有过去未来现在。以不成就因果故。则无过去未来现在。从无所有处命终。乃至生欲界中。本曾起欲界爱取有现在前。爱取是过去无明。有是过去行。未来生是现在识。未来老死是现在名色六入触受。诸余地支若现在未来。非过去未来现在。所以者何。若成就因果。则有过去未来现在。若不成就因果。则无过去未来现在。生欲界中。能造业增长。诸有无明现在时。现在有一支即无明也。余支在未来。无明时造诸行。现在有二支谓无明行。十在未来。从行时至识时。一在现在谓识也。二在过去谓无明行。余支在未来。乃至从取时至有时。二支在过去谓无明行。二支在未来谓生老死。八在现在识乃至有。尊者富那奢重明此义。若无明行在现在。当知十支在未来。八在次生中。谓识乃至有。二在第三生谓生老死。若生老死现在前。十支在过去。八支在次前生中谓识乃至有。二在前第三生谓无明行。若八现在前。二在过去谓无明行。二在未来谓生老死。佛经中处处说因缘法。或时说因。或时说果。或时说因果。为谁说因。为谁说果为谁俱说。答曰受化众生凡有三种。有上中下根。为上根者说因。为中根者说因果。为下根者说果。复有众生。初学已学久学应随为说。或有众生。于因中果中因果中愚。若于因中愚者为说因。果中愚者为说果。因果中愚者为说因果。问曰若为下根众生说缘起果。菩萨于一切众生中其根最胜。以何等故观缘起果。答曰或有说者。彼随顺观法故。所以者何。菩萨见老病死作是思惟。此老病死何缘而有皆由有生。乃至广说。复有说者。菩萨见老病死厌世出家。既出家已随其本心观生老死。复有说者。随顺得正决定故菩萨得正决定时先观于果。何况未得正决定不先观也。复有说者。如先所说。为初学者说果。菩萨于最后生名为初学。虽曾无数劫观因缘法。后若观时还从本始。如人先虽数数上树。后若上时还从根上。彼亦如是。复有说者。欲烧增长有树使无余故。如人以火先烧树端至根乃止。彼亦如是。尊者波奢说曰。不以菩萨观因缘果故名为下根。然有二种人。有随见行有随爱行。若随见行者。依空三昧得正决定观缘起因。随爱行者。依无愿三昧得正决定观缘起果。菩萨虽随爱行。能依空三昧得正决定观缘起果。菩萨厌老病死苦。于诸生死不生欲乐。问曰何故菩萨不观无明行耶。答曰或有说者。先已广略观故。观爱取时即是观无明。观有时即是观行。以是事故名先已观。乃至广说。问曰若然者。观老死时即是观名色六入触受。观生时即是观识。何以复更观耶。答曰先是略观后是广观。先不分别后是分别。问曰若然者。识无广略何以重观耶。答曰虽无广略。菩萨畏于生故是以重观。所以者何菩萨厌老病死。推求其本。此老病死由何而有。知从相续识生。谁造相续识知从业而得。业从谁起知从烦恼起。烦恼为何所依知依于体。彼复更思惟。谁造此体知从相续识生。菩萨于是念。从相续识造一切过患。以是事故重观于识不观于行。以行无广略义故齐识而止。问曰若然者。无明有广略义。何以不观耶。答曰以行无广略义故是以不观。不可舍行复观无明。何以故。观缘起法应从次第。不应越次。复有说者。菩萨观有缘生时。即是观业名色。若观行缘识亦是观业名色。如此则是无差别观。复非是观报名色。若观名色缘识。则是观报名色。复有说者。若观有缘生时。是名观远缘法。若观行缘识。亦是观远缘法。如此则是无差别观。复非是观近缘法。若观名色缘识则是观近缘法。如近远。此身他身当知亦如是。复有说者。若观有缘生则是观前生缘法。若观行缘识亦是观前生缘法。复非是观共生缘法。若观名色缘识则观共生缘法。复有说者。识从二缘生谓远缘生伴侣生。若观有缘生是则观远缘。若观行缘识亦是观远缘。如此则是无差别观。复非是观伴缘法。若观名色缘识是则观伴缘法。复有说者。欲离无穷过故。菩萨观老死时。即观此身名色六入触受。观生时即观此身相续识。若观名色六入触受。即观第二生中老死。若观识时即观第二身生。若观无明行即是观第三世。亦可观第四世。如是转转便为无穷。欲离如是过故不观无明行。问曰以何等故。菩萨于起作分中观十支。寂灭分中观十二支耶。答曰菩萨憎恶起作爱乐寂灭。是故于起作分中观十。寂灭分中观于十二。如说比丘我于是识心便转还。问曰以何等故。菩萨于识心中便转还耶。尊者波奢说曰。识住所依。何等是识所依所谓名色。以名色未断故齐识而还。复有说者。以缘还故名为转还。如说识缘名色。亦说名色缘识。以识是名色缘故。说于缘转还。复有说者。以此二法展转相缘故。名于缘转还。复有说者。如步屈虫乘草而行。先安前足得移后足。若至草端无安足处而便转还。彼亦如是。复有说者。菩萨厌老病死。求其原本何由而有。知从相续识生。乃至知烦恼依体推体。复依何而有知从相续识生。作是思惟一切众患皆从此生。若观识缘名色。即观此身相续识。若观名色缘识。即观过去身相续识。以是事故尊者富那奢所说。义便为明了。若生老死二支现在时。十支在过去。八支在次前生中。二支在前第三生中。若观此生过去相续识过患。未来相续识亦如是。故于识心便转还。佛经处处说缘起法。喻如灯如火聚如城。问曰以何等故佛经说缘起法。如灯乃至如城。答曰有人以灯喻缘起法而得明了者。佛说如灯。若以火聚城喻得分明者。佛说如火聚如城。复有说者。或有众生于爱取中。有少分在者。有中分在者。有上分在者。若少分在者说犹如灯。中分在者说犹如火聚。上分在者说犹如城

如佛经说无明缘行。乃至广说。问曰何故作此论。答曰。欲令疑者得决定故。所以者何。行与有体俱是业。人谓是一。今欲说其所以及差别相故作此论

云何无明缘行。答曰为显示分明施设解说诸业相故。若于余生中作业。亦令增长彼业报。今得此身。彼业此生中俱受报。是名无明缘行。问曰作与增长有何差别。答曰或有说者。无有差别。所以者何。作即增长增长即作故。复有说者。应有差别。所以者何。或有以一恶行故堕于恶道。或有以三恶行故堕于恶道。若作一恶行应堕地狱。方便时止。是名为作不名增长。若此行成满。亦名为作亦名增长。以三恶行应堕地狱。若作一行二行。是名为作不名增长。若作三行满足。亦名为作亦名增长。善行生人天当知亦如是。复有说者。若作一无间业应堕地狱。若方便时止。是名为作不名增长。若此业成满。亦名为作亦名增长。若作五无间业应堕地狱。若作一二三四。是名为作不名增长。若具作五无间业。是名为作亦名增长。十恶堕恶道十善生人天说亦如是。复有说者。或以一善业得生人中。或以多善业得生人中。如菩萨以三十二百福故得最后边身。若作三十一百福时。是名为作不名增长。若具三十二百福。是名为作亦名增长。复有说者。业有二种。有决定有不决定。若作不决定业者。是名为作不名增长。若作决定业者。是名为作亦名增长。如是必生报。必不生报。现报生报后报不定报。当知亦如是。复有说者业有二种。有方便业。无方便业。有方便业有作有增长。无方便业有作无增长。如是故作不故作。有先思而作。有不思而作。当知亦如是。复有说者。业或有是造非满。或是满非造。或是造是满。若是造是满。是名为作亦名增长。余者名作不名增长。复有说者。若业不善得恶道果。若业不善得人天果。不善得恶道果者。是名为作亦名增长。不善得人天果者。是名为作不名增长。复有说者不善业。或有心坏方便不坏。有方便坏心不坏。有心坏方便坏。若心坏方便坏者。是名为作亦名增长。余者名作不名增长。复有说者。有善心具足方便不具足有方便具足善心不具足。有善心具足方便具足。善心具足方便具足者。是名为作亦名增长。余者名作不名增长。复有说者。不善业有坏戒不坏见。有坏见不坏戒。有坏戒坏见。坏戒坏见者。是名为作亦名增长。余者名作不名增长。如是善业使戒具足见具足说亦如是。复有说者。有善业以善业为眷属。有善业以不善业为眷属。善业以善业为眷属者。是名为作亦名增长。善业以不善业为眷属者。是名为作不名增长。若说不善。与上相违。复有说者。作不善业。不舍不咄。不诃责。不依对治。是名为作亦名增长。作不善业。舍咄诃责依对治。是名为作不名增长。复有说者。有作善业常生忆念。有作善业不生忆念。常生忆念者。是名为作亦名增长。不生忆念者。是名为作不名增长。复有说者。若作不善业不悔。是名为作亦名增长。若作不善业悔。是名为作不名增长。如是见过不见过。犯恶向他说罪还如法行。犯恶不向他说罪不如法行。说亦如是。复有说者。若作恶知有报。是名为作不名增长。若作恶不知有报。是名为作亦名增长。复有说者。若数数作业不随喜。是名为作不名增长。若数数作业随喜。是名为作亦名增长。复有说者。若作善行于此身中。数生善心。是名为作亦名增长。若作善行。不数生善心。是名为作不名增长。作不善行。说亦如是。复有说者。若作业都竟。如作房舍一切都竟。是名为作亦名增长。若作业不竟。是名为作不名增长。复有说者。若作业为同行人所称誉者。是名为作亦名增长。不者名作不名增长。复有说者。若作和合行得和合果。是名为作亦名增长。若作和合行不得和合果者。是名为作不名增长。和合如作。十善行具足。得人天果。复有说者。若善业决定回向者。是名为作亦名增长。若善业不决定回向者。是名为作不名增长。不善业决定回向亦如是。复有说者。善业为烦恼所覆者。是名为作不名增长。不为烦恼所覆者。是名为作亦名增长。不善业不为善业所覆。是名为作亦名增长。为善业所覆。是名为作不名增长。作与增长。是名差别。若业报今得此有。是名无明缘行。诸过去如是等业。当知尽摄在行分中。云何取缘有。若于此作业。亦令增长。彼业报使。未来有相续。诸未来如是等业。当知尽摄在有分中。问曰以何等故。过去业说名为行。现在业说名为有耶。答曰以过去业已消已用已作已与果无势力报已熟。犹如粪扫弃于空地。更不能生报果。以是事故说名为行。与上相违说名为有。问曰无明缘行。取缘有。有何差别。答曰已说差别。此是过去。此是现在。此是已与果。此是未与果。此是故业。此是新业。问曰如汝所说可尔。应当说缘差别相。答曰无明缘行。为显示业。广说如上。彼业缘世尊说是一结。谓无明结也。取缘有者。若于此作业。乃至广说。彼业缘世尊说。是一切结。所谓诸取。问曰何故过去业缘说是无明。现在业缘说是一切结。答曰诸过去世不现见故。云何为诸趣。答曰所谓趣生方时所为方便起处身缘起者。不知本在何趣造。今有业生者。不知于何生造。今有业方者。不知在何方造。今有业时者。不知于何时造。今有业所为者。不知为是杀生为是打缚乃至为是无义言造。今有业方便者。不知为于众生数为于非众生数作方便造。今有业起处者。为是贪欲嗔恚愚痴处造。今有业身者。不知为是男女身造。今有业缘者。不知为缘过去未来现在为缘色声香味触造。今有业如是。过去世不现见故。说行缘是无明现在世。如上所说趣。乃至缘尽是现见。是故彼业说缘是一切结。复有说者。过去无明缘行。是已作方便。是已与果不猛利。不猛利故说是无明。取缘有。是现在业。不已作方便。未与果性是猛利。以猛利故说是取。复有说者过去业。不知为从贪生为从嗔生为从痴生。自身他身无现见者。然烦恼相应共有法中。尽有无明。是故说是无明。现在业自身他身。俱可现见。亦可知从贪恚痴及余烦恼生。是故说一切结。问曰诸阿罗汉所有业。为是无明缘行。为是取缘有耶。答曰非是无明缘行。亦非取缘有。所以者何。以不从无明生亦不从取生。虽然已与果报已熟。当知尽摄在行分中。若未与果报未熟。当知此业摄在有分中。已离有支不在有支中

问曰凡夫人生欲界中。为造几种业耶。答曰凡夫人生欲界中未离欲能造四种善不善业。已离欲界欲。未离初禅欲。能造欲界四种善业。造初禅三种业。除现报业。如是乃至离无所有处欲。能造欲界四种善业。能造四禅四无色定三种业。除现报业。凡夫人生初禅中未离欲。能造初禅中四种业。若离初禅欲。未离第二禅欲。能造初禅中三种业。除生报业。能造二禅中三种业。除现报业。离二禅欲。未离三禅欲。能造初禅中三种业。除生报业。能造二禅中二种业。除生报现报业。能造三禅中三种业。除现报业。乃至离无所有处欲。能造初禅中三种业。除生报业。三禅三无色定中。能造二种业。除生报现报业。能造非想非非想处三种业。除现报业。如是凡夫人。乃至生无所有处未离欲。能造无所有处四种业。已离欲能造无所有处三种业。除生报业。能造非想非非想处三种业。除现报业。凡夫人生非想非非想处。能造四种业。圣人生欲界中未离欲。能造四种业。若离欲界欲未离初禅欲。能造欲界二种善业。除生报后报业。能造初禅三种业。除现报业。离初禅欲未离二禅欲。能造欲界二种业如前说。若是不退法。唯能造初禅一种业。谓不定报业。若是退法。能造三种业。除现报业。能造二禅中三种业。除现报业。离二禅三禅四禅欲。当知说亦如是。未离空处欲。能造欲界二种业。除生报后报业。若是不退法。能造四禅中一种业。谓不定报业。若是退法。能造三种业。除现报业。能造空处三种业。除现报业。若造生报业。不造后报业。若造后报业。不造生报业。乃至离无所有处欲。未离非想非非想处欲。能造欲界二种业如前说。若是不退法。能造四禅三无色一种业如前说。若是退法。能造三种业如前说。能造非想非非想处三种业。如空处说。圣人生初禅中。未离初禅欲。能造初禅三种业。除后报业。离初禅欲未离二禅欲。能造初禅二种业。除生报后报业。能造二禅三种业。除现报业。离二禅欲未离三禅欲。造初禅二种业。除生报后报业。能造二禅一种业。谓不定报业。能造三禅三种业。除现报业。乃至离四禅欲。未离空处欲。能造初禅二种业如前说。能造余三禅一种业。谓不定报业。能造空处二种业。除现报后报业。乃至离无所有处欲未离非想非非想处欲。能造初禅二种业如前说。能造余三禅三无色定一种业。谓不定报业。能造非想非非想处二种业。除现报后报业。如说生初禅。当知生余三禅亦如是。是中差别者。生余三禅中未离自地欲。能造四种业。圣人生空处未离彼地欲。能造空处二种业。除生报后报业。离空处欲未离识处欲。能造空处二种业如前说。能造识处二种业。除现报后报业。乃至离无所有处欲未离非想非非想处欲。能造空处二种业如前说。能造识处无所有处一种业。谓不定报业。能造非想非非想处二种业。除现报后报业。如是生无所有处。说亦如是。圣人生非想非非想处。若离欲若未离欲。能造彼处二种业。除生报后报业。住欲界中阴中。能造二十二种业。还中阴受定不定报。如是歌罗罗阿浮陀卑尸伽那波罗耆佉婴孩童子。少年中年老时。皆受定不定报。住歌罗罗时。能造二十种业。还歌罗罗时。受定不定报。乃至老时。皆受定不定报。乃至住老时。造二种业。还于老时受二种报。谓定不定报。问曰住中阴中造业。生阴中受报。此报为是生报为是现报耶。答曰当言现报。不当言生报。所以者何。中阴即是此生身故

阿毗昙毗婆沙论卷第十三阿毗昙毗婆沙论卷第十四

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    杂揵度人品中

颇行缘无明。不缘明耶。乃至广说。问曰何故因无明与明而作此论。答曰或有说者。作经者意欲尔。乃至广说。复有说者。无明与明相违。明与无明相违。无明与明作对治。明与无明作对治。复有说者。以俱是无首俱是九种俱是根本。无明是起作法根本。明是寂灭分根本

颇行缘无明。乃至广说。处处广说诸行名。如说无明缘行。阿毗昙人作如是说。此中说时五阴是行。尊者瞿沙作如是说。此中说业是行。如说有害他行。此中说不善业是行。如说无有害他行。此中说善业是行。如说造有为行。如说一造有为行此中说思是行。如说五阴色心心数法心不相应行无为。此中说心不相应行阴是行。如说有此色受想行识。此中说心相应不相应五阴是行。如说三行。谓身口意。身行者谓出入息。口行者谓觉观。意行者谓想思。此中说想阴及二阴少分是行。如说三行有福分非福分不动分。此中说善不善业是行。如说行有五过患。此中说不善法是行。亦说是苦触。复有说者。此中说五取阴是行。如说聪明者。不以行舍行。如说诸行无常。此中说五取阴是行。如说寂灭为乐。此中说寂灭为乐。此中说寂灭是数法无漏行非以数灭。如说诸行无常。诸法无我。涅槃寂静。此中说一切有为法是行。此经亦说一切有为法是行。若说相似行。凡有十一种。欲界有四善不善隐没不隐没。色界有三善隐没不隐没。无色界亦尔及无漏行。无明与明。非欲界善行因。为作三缘。谓次第境界威势缘。无明与不善行作四因。谓相应共生相似遍因。为作四缘。明非其因。为作二缘。谓境界威势缘。欲界隐没无记说亦如是。无明非欲界不隐没无记因。除无明报。为作三缘。谓次第境界威势缘。明非其因。为作一缘。谓威势缘。无明与无明报。作一因谓报因。作四缘谓因次第境界威势缘。明非其因。为作一缘谓威势缘。无明与明。非色界善行因。为作三因除因缘。无明与色界隐没无记行作四因。谓相应共生相似遍因。为作四缘。明非其因。为作二缘谓境界威势缘。明与无明。非色界不隐没行因。无明为作三缘除因缘。明为作一缘谓威势缘。无色界亦如是。无明与无漏行。除初明。诸余无漏行非因。为作二缘谓境界威势缘。明与其相似者。作三因谓相应共生相似因。为作四缘。初明与无明非因。为作二缘谓境界威势缘。无明与初明非因。为作一缘威势缘。如此说。是略毗婆沙

颇行缘无明不缘明耶。答曰无也。所以者何。无有行于无明有缘于明无缘。颇行于明有缘。于无明无缘耶。答曰此亦无也所以者何。无有行于明有缘于无明无缘。颇行于无明与明有缘耶。答曰有。所以者何。众生从久来。无有不谤道言非道者。彼于后时。作地利行。亦令增长。乃至广说。地利行者。得田地园林果者是也王行者得作边地王。如摩菟罗王等大王行者。得王于一方。如瞿沙王无仑荼王秦天子等是也。转轮王行者得王四天下。复有说者。王行者得王一方。如瞿沙王无仑荼王秦天子等是也。大王行者得为转轮王太子已登王位。七宝未至是也。转轮王行者。已登王位。七宝自至是也。复有说者。地利行者。谓一切地处。于中尊贵。王行者。得为转轮王眷属小王。大王行者。居转轮王太子位。转轮王行者。得王四天下。七宝自至。以是因缘。展转生故。使诸众生及种子药草树木皆得生长。亦以如法赋税。以此业力故。使外种子皆得增长。如此义今当广说。如诸外道见。寿命有增有减。心生厌离。复为怨憎会苦爱别离苦。在家诸苦之所逼切而便出家。既出家已少欲知足。精勤苦行持崄难戒。种种苦行欲求解脱。彼依邪道故。转远圣道。以转远故。不能得道。不得道故。便生诽谤。言无有道。虽有解脱。而无其道。若当有者。我等种种苦行应得此道。以不得故当知无道。于修行法而便退还。作是思惟。于生死中多修福者。犹有崄难。况不作者。我今当修施福。即作大祀。以诸饮食充足多人。作如是愿。使我为王。乃至转轮王。如佛弟子见。寿命有增有减。心生厌离。复为怨憎会苦爱别离苦在家诸苦之所逼切而便出家。既出家已。初夜后夜勤修方便。一七二七日没。于其中间。结加趺坐。顶安禅镇行禅鞠法杖。常住山顶岩石间修行精进。虽然以二事故不得道。一善根未熟。二行邪方便。善根未熟者。始于此身而求解脱。佛法之中。速得解脱者。一身中种解脱分善根。二身中成熟。三身中得解脱。而彼未种解脱分善根而求解脱。是名善根未熟。行邪方便者。受错谬对治。以是事故不能得道。以不得故便谤于道。虽有解脱而无其道。若当有者我今种种精进苦行。则应当得。以是事故而便退还。复更思惟。于生死中。多作福者犹为崄难。何况不作。我今当修福业自作亦教他作。施设长斋般阇于瑟因讲经法会等。以种种饮食充足多人。发如是愿。使我为王至转轮位。如愿皆得。若当无道邪见无由生谤。以有道故。邪见便谤。是故无漏道作近缘。若邪见不谤道。后则不生施俱心。如是染污心与不染心作缘。若无施俱心。则外种子不增长。如是内法与外法作近缘。此前心具有四缘。前心者。谓邪见俱心。彼相应共有。是因缘疑。是次第缘。道是境界缘。除其自体。余一切法。是威势缘。彼后心有一威势缘。后心者。谓施俱心也。问曰以何等故。前心有四缘。后心有一缘耶。答曰或有说者。此文应如是说。前心有四缘。后心亦应有四缘。应如是说。而不说者。当知此说有余。复有说者。此中一向说近缘。如识身经所说。不为心作障碍是威势缘。诸法为作境界者是境界缘。前灭心是次第缘。俱生法是因缘。如是皆说近缘。当知此文亦说近缘。前心四缘是近缘。前心四缘于后心。是一威势缘。非因缘非次第缘非境界缘。所以者何。前心与邪见作因缘。邪见相应心。不行布施。疑心不能与施心开次第缘。道心不行施。问曰如后生心体。以在四缘中。前心四缘。于后心。是威势缘故。云何不自体还与自体作威势缘耶。答曰或有说者。此文应如是说。前心四缘。与后心作一威势缘。除其自体。而不说者。当知此说有余。乃至广说。复有说者。我先作是说。此中一向说近缘。后心于前心四缘。是远缘是为舍远取近。复有说者。先已除自体是余论。余日诵余揵度中说。除其自体者。犹当信受。何况此论。此揵度同曰诵前品中说。一切诸法。除其自体。作威势缘而不信受。以是事故。此中虽不言除其自体亦复无过

颇行不缘无明。亦不缘明耶。答曰无也。无有行不缘无明亦不缘明。复次若别为一法说者则有。颇行缘无明不缘明乃至广说。缘无明不缘明者。谓无明报染污行无明报者。无明为作报因明非其因。所以者何。明无因义故。无明与染污行作四因。谓相应共生相似遍因。明非其因。无因义故。缘明不缘无明者除初明。诸余无漏行。明与彼作三因。谓相应共生相似因。无明非其因。无因义故。缘无明缘明者此则无也。所以者何。无有行缘无明。亦缘明者远故。如偈说

  虚空大地相去远　　海彼此岸亦复远
  日出没处斯亦远　　正法邪法远中远

不缘无明不缘明者。除无明报。诸余不隐没无记行。何者是耶。谓一切善行报。不善身口业。得生住老。无常等报。诸长养色。余依色威仪工巧通果法。及初明有漏善行。如是等法。不缘无明不缘明。何以故。无明与明非其因故。问曰如苦法忍得。无明与明。俱非其因。此中何以不说耶。答曰或有说者。应说而不说者。当知此说有余。复有说者。以分别初明共有法时彼亦在中故。评曰不应作是说。如前说者好。问曰无明是何义。答曰不知不解不识是无明义。问曰除明余一切法。亦不知不解不识。彼尽是无明耶。答曰若不知不解不识。是愚痴相者。说是无明。余一切法。虽不知不解不识。无愚痴相故说不是无明。问曰明是何义。答曰知解识义是明义。问曰世俗智亦知解识。何以不说是明耶。答曰或有说者。若知解识。能于真谛决定者是明。世俗智虽知解识。不于真谛得决定故。如远分智虽复猛利。不能于真谛尽得决定。复有说者。若知解识能于真谛。决定了知。究尽第一义者是明。世俗智虽知解识。不能于真谛决定了知究尽第一义故非明。复有说者。若知解识。能断烦恼。更不生者是明。世俗智与上相违故非明。复有说者。若知解识。能破坏有是明。世俗智与上相违故非明。复有说者。若知解识。断生死有相续法及老死相续法者是明。世俗智与上相违故非明。复有说者。若知解识。是尽苦集身见诸取道者是明。世俗智与上相违故非明。复有说者。若知解识。非身见颠倒体。非贪欲嗔恚愚痴之处。不杂垢浊毒。不堕诸有。不堕苦集谛中者是明。世俗智与上相违故非明。复有说者。若知解识。知已更非无知。得决定智。更不生愚痴犹豫邪见者是明。世俗智与上相违故非明。复有说者。世俗智在无明明分中所以者何。于明无明。俱有三缘义故。如人亲友亦亲他怨。是人于他。不名亲友。不名怨家。彼亦如是。复有说者。不杂无明故是明义。世俗智杂无明故非明。复有说者。世俗智分。能生谤道法。是中应说叛臣喻。复有说者。能治义者是明。如人为鬼所著以咒治之。如是凡夫为烦恼鬼所著。以无漏道治。彼世俗智。不能究竟治故非明。除心因法及非心法。诸余法摄二界一入一阴。彼是何耶。谓苦法忍相应心。摄二界者意识界。一入者意入。一阴者识阴。除明因法及诸余法。非明者。摄一界一入一阴。彼是何耶。谓苦法忍是也。摄一界者法界。一入者法入。一阴行阴。说受等诸数法。亦应如是。问曰诸明以明为因耶。设为明因是明耶。乃至广作四句。是明非以明为因者。谓初明也。是明因非明者。明相应共生法也。是明亦以明为因者除初明。诸余明也。非明不以明为因者。除上尔所事。诸明是明因也。设是明因亦是明也。乃至广作四句。是明不为明作因者。谓未来明也。为明作因非明者。谓明相应共生法也。是明亦为明作因者。谓过去现在明也。非明不为明作因者。除上尔所事。苦法忍得有十五。一与苦法忍俱。二与苦法智俱。如是乃至与道比忍俱苦法智得有十四。如是转减。乃至道比忍得有一。问曰见道更有余得不耶。答曰或有说者无。所以者何。如见道灭。彼得亦随灭。犹如日没光亦随没。如是日如见道。日光如诸得。若彼道灭。得亦随灭。评曰应更有得谓未来世是也。此中唯说生者。不说不生者。苦法忍有一得俱生忍。于得不作因。得于忍亦不作因。与后生无漏道。尽为作因。苦法智俱生得有三。二是道得。一是解脱得。二是道得者。一是苦法忍得。二是苦法智得。解脱得者。谓欲界见苦所断十使解脱是也。苦法智于得无因义。得于智亦无因义。苦法忍及俱生得。与彼三得作相似因。苦比忍俱生得有四。三是道得。一是解脱得。苦比忍与得无因义。得于苦比忍。亦无因义。苦法忍及俱生得与四得。作相似因。苦法智及俱生得与三得。作相似因。除苦法忍得。以此事故而作是说。颇有前生无漏不与后生无漏道而作因耶。答曰有胜不与下作因。苦比智俱生得有六。四是道得。二是解脱得。苦比智与六得无因义。六得亦与苦比智。亦无因义。苦法忍俱生得与六得。作相似因。苦法智及俱生得与五得。作相似因。除苦法忍得。苦比忍及俱生得与后三得作因。与前三得不作因。问曰。何故不为前三得作因耶。答曰以下故。胜道不为下作因。问曰以道下故。不为作因可尔。解脱得胜何故不为作因也。答曰解脱得虽胜。下道力所得故不为作因。如是乃至道比忍。有二十二得。俱生十五。是道得。七是解脱得。道比忍与二十二得无因义。二十二得与道比忍。亦无因义。苦法忍及俱生得与二十二得。作相似因。乃至道法智及俱生得与后三得。作相似因。不与前得作因。若苦法忍现在前。未来中所修道。尽为作因。苦法忍。乃至无学道作因。复有说者。苦法忍现在前。未来中所修道不为作因。何以故。乃至无一刹那生。云何名果。评曰说是因者好。俱是一身所得。复是胜道故。如是乃至道比忍现在前。未来中所修道。彼道比忍。尽为作因。从道比智乃至无学道。尽为作因。乃至金刚喻定现在前。未来中所修道。尽为作因。及诸无学道尽为作因。初生尽智。除其自体。与一切无学道作因。信行人道。还与信行人道作因。亦与法行人道作因。法行人道。唯与法行人道作因。复有说者。信行人道。与信行人道作因。不与法行人道作因。无有信行人作法行人者。评曰如是说。为作因者好。俱是一身。复是胜道故。信解脱道。与信解脱道作因。亦与见到道作因。见到道唯与见到道作因。时解脱道与时解脱道作因。亦与不时解脱道作因。不时解脱道。唯与不时解脱道作因。见道与见道作因。亦与修道无学道作因。修道与修道作因。亦与无学道作因。无学道。唯与无学道作因。声闻道还与声闻道作因。辟支佛道还与辟支佛道作因。佛道还与佛道作因。此三道。各不更相为因。无漏道。亦依女身。亦依男身。或有说者。依女身道。还与依女身道作因。依男身道。还与依男身道作因。应展转为因随其利钝根性。如是说者好。或有说一道者。或有说多道者。说一道者。不言见道。即是修道。见道异修道异。见道依九处身得。三天下六欲天。说一道者。阎浮提道。乃至即是他化自在天道。说多道者。阎浮提所依身道异。乃至他化自在天所依身道异。言多道者。复有二种。一者作如是说。若以阎浮提身得见道。此道名得在身中成就亦现在前。余身所依道。是得不在身中成就。不现在前二者作是说。若以阎浮提身得见道。彼道名得。在身中成就。亦现在前。余身所得见道不名得。不在身中。不成就。不现在前。修道依欲界身。亦依色界无色界身。言一道者。若依欲界身所得道。色无色界身所得道。即是一道。言多道者。依欲界身所得道异。依色无色界身所得道异。言多道者。复有二种。一者说。依欲界身得道。此道名得在身中成就现在前。依余身得道名得。不在身中成就不现在前。二者说依欲界身得道名得。在身中成就现在前。依余身中成就现在前。依余身得道。不得不在身中不成就不现在前。评曰不应作是说。若然者。依欲界身。得果已。生色无色中。彼生已起圣道现在前。可言重得果耶。如前说者好。圣道亦依女身。亦依男身。言一道者。依女身道。依男身道。即是一道。言多道者。女身道异。依男身道异。言多道者。复有二种。一者言。若女身所得道。此道名得在身中成就现在前。男身中道。此道名不得在身中成就不现在前。二者言。若依女身所得道。此道名得在身中成就现在前。男身中道。此道不得不在身中不成就不现在前。评曰不应作是说。所以者何。依女身得果。后得男身起圣道现在前。可言重得果耶。如前说好阿耨多罗三藐三菩提。依百岁身而得。乃至亦依八万岁身而得。言一道者。依百岁身。而得阿耨多罗三藐三菩提。即是依八万岁身得者。言多道者。百岁时身所得道异。八万岁身所得道亦异。言多道者。有二种。一者言依百岁身。得阿耨多罗三藐三菩提。此道名得。在身中成就现在前。余道名得。不在身中成就不现在前。二者言百岁身得阿耨多罗三藐三菩提。此道名得。在身中成就现在前。余身道不得。不在身中不成就不现在前。问曰若然者。一切诸佛皆等。此说云何通耶。答曰以三事故言等。一者本修集善行等。二者成就法身等。三者利益世间等。修集善行者。一切诸佛。尽于三阿僧祇劫。修诸方便四波罗蜜。成就法身等者。诸佛尽有十力四无所畏大悲三不共念处。尽住上上根。利益世间等者。欲令无量那由他众生眷属。皆得解脱。入于涅槃。以是三事故名等。复有说者。戒亦等。尽住上上戒故。根亦等。尽住上上根故。道亦等。尽成就上上道故。评曰如前说者好。问曰颇有一法。于一刹那顷。能起二十四得现在前耶。答曰有若依第四禅。得正决定。得六地中苦法忍。一地有四行。谓无常行等。得现在前。问曰颇断烦恼得。得而不舍。舍而不得。乃至广作四句。得而不舍者。凡夫人离欲界欲。乃至离无所有处欲。圣人除转根及得果时。诸余断结道是也。舍而不得者。凡夫人离欲还退时。从色无色界命终。生欲界中时。下地命终。生上地圣人果中间退时是也。亦得亦舍者。凡夫人从无色界命终。生于色界。上地命终生色无色界。下地中圣人得果时转根时及退果时是也。不得不舍者。除上尔所事

入息出息当言依身回耶。乃至广说。问曰。何故作此论。答曰如摄法经所说。世尊何故说入息出息是身行耶。答言此是身法。身是其本。亦属于身。依身故回。如施设经说。如昙摩提那经说。以何等故。死有入息出息不回耶。答言入息出息由心势力。死者无心故入息出息不回。一经说由身。一经说由心。人谓此二经。亦是了义亦是不了义。欲显此二经真实义故。而作此论。入息出息当言依身回耶。当言依心回耶。答曰当言依身回依心回。随其宜便。问曰云何随宜便。答曰。或有说者。如婴孩入息出息少。中年中。老年多。复有说者。此有四事故言随宜便云何为四。一者依身。二者风道通。三者诸孔开。四者入息出息地粗心现在前。此四事说随其宜便。若当入出息。但依身不依心者。入无想灭尽定。入出息亦应回。何以故。彼亦有入出息所依身。风道亦通。诸毛孔亦开。虽无粗心现在故。入出息不回。若入出息。但依心不依身者。无色界众生。亦应入出息回。然彼无此四事故不回。若入出息但依身心不随宜便者。此则在卵等中时。乃至广说。在卵等中身。非入出息所依。风道不通。诸孔不开。唯有入出息地粗心故。是以不回。若当回者则应躁动。复有说者。以卵迦罗逻时软薄故。入出息不回。阿浮陀。卑尸时。身诸孔未开故。入出息不回。入第四禅。虽有入出息所依身风道亦通。诸孔不开。以定力故。身体尽合。复不起入出息地粗心。彼地心微细故。问曰以何等故。说入第四禅者。不说生第四禅者耶。答曰或有说者。作经者意欲尔。乃至广说。复有说者。此文应作是说。入第四禅及生第四禅。而不说者。当知此说有余。乃至广说。复次若说入定。当知亦说生处。如经说前修此定。后生彼处。是故入出息。依身回。亦依心回。随其宜便。从阿鼻狱。上至遍净天。于其中间。诸众生生诸根具者。乃至广说。此中说诸根具足者。具上四事。非眼等根也。问曰以何等故。入第四禅。入出息不回耶。答曰粗心能起入出息。彼心心数法细故。复有说者。躁动心能起入出息。彼心不躁动。如人在烦闹道行。便起于尘。彼亦如是。尊者和须蜜说曰。以何等故。入第四禅。入出息不回耶。以入第四禅者。身诸毛孔合。以无所依故。入出息不回。尊者婆檀陀说曰。入第四禅。身不动摇彼心不动故。身亦不动。复有说者。欲界以爱境界故。令身心粗。初禅以觉观故。第二禅以喜故。第三禅以乐故。第四禅中。永离如是法故入出息。有出息。有入出息地。有无入出息地。入息者来出息者去。四地中有入出息。四地者。谓欲界初禅二禅三禅。五地中。无入出息。五地者。谓第四禅及四无色定。问曰。住入出息地。无入出息地心现在前。为有入出息回不耶。答曰不回。问曰住不入出息地。入出息地心现在前。为有入出息回不耶。答曰不回。问曰若住入出息地身。入出息地心现在前。当言入出息回。为以身故回。为以心故回耶。答曰或有说者。以身故回。诸作是说。以身故回者。生欲界中。欲界中心现在前。此身是欲界。入出息亦是欲界。从欲界心回。即是此心所观境界。生欲界中。初禅心现在前。身是欲界。入出息是欲界。从初禅心回。即是彼心所观境界。问曰若然者。此说云何通。如说欲界入出息。是初禅无碍道中灭。答曰欲界入出息。或从欲界心回。或从初禅心回。若从欲界心回者灭。若从初禅心回者现在前。复有说者。言灭者是数灭也。生欲界中。二禅三禅心现在前。身是欲界。入出息是欲界从二禅三禅心回。即是彼心所观境界。初禅初禅心现在前。身是初禅。入出息是初禅。从初禅心回。即是彼心所观境界生初禅。欲界心现在前。身是初禅。入出息是初禅。从欲界心回。非是彼心所观境界。生初禅。二禅三禅心现在前。身是初禅。入出息是初禅。从二禅三禅心回。即是彼心所观境界。生二禅中。随其相说生第三禅中。第三禅心现在前。身是三禅。入出息是第三禅。从第三禅心回。即是彼心所观境界。生三禅中。欲界心现在前。身是第三禅。入出息是第三禅。从欲界心回。非是彼心所观境界。如是起初禅二禅心现在前。身是第三禅。入出息是第三禅。从初禅二禅心回。非是彼心所观境界。诸作是说。入出息。以身故回者。欲界入出息。为四种心作境界。初禅入出息。为三种心作境界。第二禅入出息。为二种心作境界。第三禅入出息即为第三禅作境界。诸作是说入出息。以心故回者。生欲界中。欲界心现在前。身是欲界。入出息是欲界。从欲界心回。即是彼心所观境界。若初禅心现在前。身是欲界。入出息是初禅。从初禅心回。即是彼心所观境界。若第二第三禅心现在前。身在欲界。入出息是第二第三禅。从第二第三禅心回。即是彼心所观境界。生初禅中。初禅心现在前。身是初禅。入出息是初禅。从初禅心回。即是彼心所观境界。若欲界心现在前。身是初禅。入出息是欲界。从欲界心回。即是彼心所观境界。若第二第三禅心现在前。身是初禅。入出息是第二第三禅。从第二第三禅心回。即是彼心所观境界。生第二禅中说亦如是。生第三禅中。第三禅心现在前。身是第三禅。入出息是第三禅。从第三禅心回。即是彼心所观境界。若欲界心现在前。身是第三禅。入出息是欲界。从欲界心回。即是彼心所观境界。若初禅二禅心现在前。身是第三禅。入出息是初禅二禅。从初禅二禅心回。即是彼心所观境界。诸作是说。入出息依心回者。欲界入出息。即是欲界心所观境界。初禅即初禅。二禅即二禅。三禅即三禅。评曰不应作是说。如前说者好。问曰入出息。为是众生数。为非众生数耶。答曰是众生数。问曰为是内法。为是外法耶。答曰是外法。此身中亦有内风。然入出息是外风。为是长养为是依。为是报耶。答曰是依此身亦有长养风报风。然入出息是依。如经说。佛告阿难。若能令入出息。如射箭筈筈相续者。是名异食。云何名异食耶。答曰虽以上妙饮食长养人身。不如正方便入出息。切害身法莫若邪方便。入出息。如箭筈筈相续。是何义耶。答曰如以后箭射于前箭。是名筈筈相续义。复有说者。相续不断义。是筈筈相续义。问曰入出息。为先入耶。为先出耶。答曰或有说者。言先出。脐边有风起。能开诸孔。然后乃出。复有说者。能开诸孔风。非入出息。诸孔开已。风先入。如饥渴人。少有所食。令身长养。死时最后息出。更不复入名死。复有说者。最后息入。更不复出名死。如说使我常得入出息。入第四禅时息出。出第四禅时息入

如说有阿那般那。有阿那般那念。云何名阿那。云何名般那。云何名修阿那般那念耶。答曰诸入息是阿那。出息是般那。复有说者。出息是阿那。入息是般那。如说比丘吸外风入时名阿那。如内风出散名般那。能缘彼念。是名阿那般那念。修行广布念相应共有法。是名修阿那般那念。阿那般那念。说有六事。云何为六。一数二随三止四观五转六净。数者。有五种。一数二减数三增数四聚数五净数。数者一至二乃至十。减数者。从三至一增数者。从一至三四。聚数者。观六息入六息出。复有说者。聚数者。观入息是出。观出息是入。净数者。观五息出。问曰为先数入息。为先数出息耶。答曰先数入息。所以者何。生时息入。死时息出。如是观者。是名随顺生死观法。是以先观入出。乃至广说。随者观息至咽时。心亦随至。至心至脐。乃至脚指心亦随至。止者。息入时住在咽心亦止观。如是至心至脐。乃至住脚指心亦止观。复有说者。止者观风在身中住。如观明珠中綖。观者不但观风。以风大故。等观四大。不作差别。观此四大能生何物。知生造色。次观造色者。为谁作依。谁有所作知。为心心数法。以是事故。观五阴。转者转此入息观。起身念处。次起受心法念处。次起暖顶忍世第一法。净者。谓苦法忍是也。复有说者。是诸善根。皆是慧分。数有二事。一数入出息。二能舍思觉。随有二事。一能随入出息。二舍离欲觉。止有二事。一能住息在鼻端。二不舍三昧。观有二事。一能观入出息住异相。二能取心心数法相。转有二事。一能知阴。二能入圣道。净有二种。一能断结。二能净见问曰阿那般那念体性是何。答曰是慧以此心品中念偏多故。名阿那般那念。取其相应共有法故。欲界体依。是四阴性色界是五阴性地者。在五地中。欲界未至初禅中间二禅未至。三禅未至。所依身者。依欲界身。亦依色界。然初起时。必依欲界。行者体非行。境界者境界是。风念处者。非根本念处。是念处方便。若取念处眷属者。则是身念处。所以者何。以缘色故。问曰若然者。何故佛经说阿那般那念是四念处耶。答曰以是念处方便故。名四念处。问曰若然者。不净观亦是四念处方便。何故不说名四念处耶。答曰若有众生。应闻阿那般那是念处者。世尊则说。若有众生。应闻不净是念处而得悟者佛亦说之。复有说者。如此经中。亦说不净观是念处。如此经偈说

  若能观青色　　亦能观烂坏
  是名身念处　　观净生欲心
  是中亦有受　　是名受念处
  能以无嗔心　　是名心念处
  亦断于爱恚　　是名法念处

复次何故。说阿那般那念是念处。不说不净观耶。答曰以阿那般那念观牢固可恃。不净观法则不尔。若行者失念。烦恼现在前时。速能还观。如人怖恐速走入城。彼亦如是。复有说者。阿那般那念。不与外道共不净观共。复有说者。不净观能增长众生想。所以者何。观时必观男女身骨故。阿那般那念。能增长法相。所以者何。以是空三昧根本故。是故说四念处。复有说者。阿那般那念。缘近法。是不杂观。非次第观。非是因众生观。不多用功。不净观不尔。是故说是念处。不说不净观也。智者一等智。根相应者。一根相应谓舍根。世者谓是三世。缘世者。谓缘三世。善不善无记者。谓是善缘善不善无记者。谓缘无记。欲色无色界系者。谓欲色界系。缘三界系及不系者。谓缘欲色界系。是学无学非学非无学者。谓是非学非无学。缘学无学非学非无学法者。谓缘非学非无学。见道断修道断无断者。谓修道断缘见道修道不断者。谓缘修道断。缘名缘义者谓缘义也。缘自缘他者谓缘自他。如经说偈

  若于安般念　　具足能修行
  次第而习学　　如佛之所说

问曰此偈中说。谁具足谁不具足。答曰或有说者。此中说佛具足声闻缘觉不具足。复有说者。佛辟支佛是具足。声闻是不具足。复有说者。阿罗汉以上是具足。学人凡夫人是不具足。复有说者。圣人是具足。凡夫人是不具足。评曰如是说者好。若具上六事。名为具足。若不具上六事。名不具足

如经中说。佛言我于二月入于禅定。现如是所应瑞相。云何瑞相。答曰世尊。自敷床而坐。化作比丘眷属围绕是其瑞相。复有说者。世尊令地微动。诸比丘见已寻诣佛所。此亦是其瑞相。尔时世尊告诸比丘。若有外道梵志来问汝言。沙门瞿昙于二月中。为入何定者。汝当答言。入阿那般那定。问曰如诸外道梵志。乃至不识阿那般那定名佛何故作如是说。若诸外道来问汝者。汝当答言。入阿那般那定耶。答曰欲令外道生悕有想。若诸外道。闻阿那般那定名。必生悕有想。以生悕有想故来至我所。以此缘故当入我法。作如是说。问曰如世尊悉入诸禅定解脱三昧。何以但说入阿那般那定耶。答曰以阿那般那定在诸禅定初故

如说当观息短。乃至广说。问曰息为先短后长。为先长后短耶。答曰先观短后观长何以知耶。答曰。如说世尊入定不久入出息速动。入定转久。入出息安住。如人重担上崄难处。身体疲极。入出息速动。若止息时。入出息住。佛亦如是。入息时知息遍身。出息时亦知遍身。问曰系念在鼻端。云何复知入出息遍身耶答曰尊者和须蜜作如是说。遍知此身。是无常法。而不失念。问曰若然者。不名起定耶。答曰不名起。以不舍其方便故。如是展转观此身。是苦空无我秽污不净性。若此阿那般那念未成时。系念在鼻端。后若成已。观身毛孔犹如藕根风从中入出问曰若然者。云何不名起定耶。答曰以不舍方便所期心故。不名起定。尊者婆檀陀说曰。如菩萨观时。先系念在身诸孔风入出处。令心不散乱。亦不舍方便。止息身行。入息出息。乃至广说。止息身行者。令此入出息转微寂静。或时不观。复有说者。观息短时。名入初禅。观息长时。入第二禅。知息遍身。入第三禅。止息身行。入第四禅。如是等四义。亦应如是说。觉喜入出息者。谓初禅二禅也。觉乐入出息者。即观察此乐也。觉心行入出息者。观察想思也。复有说者。觉心行者。观意业思。止息意行。入出息者。令彼意行转微寂静。或时不观。觉心入出息者。谓观察于识也觉随喜心定心解脱心入出息者。如来无随喜心。无定心。无解脱心。观察菩萨本所行。随喜心定心解脱心也。觉无常入出息者观察入出息是无常也。觉断入出息者。观察断过去烦恼也。觉离欲入出息者。观察断未来烦恼也。觉灭入出息者。观察断现在烦恼也。复有说者。觉无常入出息者。观察心心数法是无常也。觉断入出息者。除爱结。观察断余结也。觉离欲入出息者。观察断诸烦恼也。觉灭入出息者。观察断一切结法也。复有说者。觉无常者。是观察身无常也。觉断者。观察断无明也。觉离欲者观察离欲爱也。觉灭者。观察涅槃是寂静也。尊者婆檀说曰。觉无常者。观察五取阴也。觉断者。观察五取阴是空无我也。觉离欲者。观察五取阴是苦也。觉灭者。观察五取阴是不生寂灭法也我作如是念。如是住者。皆是粗定。我应广住微细定中。问曰云何微细定耶。答曰或有说者。第四禅是。复有说者。灭尽定是。是时夜分有欲界三天。来诣菩萨所。一下根。二中根。三上根。彼下根天。见其无入出息。又不动摇无思想行。作如是言。此瞿昙沙门今者已死。彼中根天。见其身犹暖虽复经久而不烂坏。彼作是言。今虽未死后必当死。彼上根天。曾见诸佛及佛弟子入禅法。彼作是言今非是死亦不当死。然住此定法应如是

若有人问云何圣住。云何天住。云何梵住。云何学住。云何无学住。云何如来住。应当答言。是阿那般那念。如是说者是名正答。问曰如阿那般那念。是非学非无学。何故说是学住无学住耶。答曰从学无学边得故。名学无学。能入学无学法故名学无学。复有说者。无烦恼故。名圣清净。天所有故名学。能得学法故名学无学所有故名无学。能生无学法故名无学。如来住者。阿罗汉住。名如来住。未得而得者。胜进是也。已曾得者。一受现法乐。二已至不动。复有说者。圣所有故名圣住。能生圣法故名圣住。天所有故名天住。能生天故名天住。乃至如来所有故名如来住。能生如来。法故名如来住。未得而得者阿罗汉是也。已得受现法乐者。现法乐有四种。一出家乐。二闲静乐。三寂灭乐。四三菩提乐

如色众生依身故心回乃至广说。问曰何以作此论。答曰如欲色界众生依色故心回。无色界无色。或谓彼心无所依而回。为令彼意得决定故而作此论。说有所依。问曰彼何所依耶。答曰命根受身处。如是等诸余心心不相应行。不相应行。名何等。谓凡夫性。不成就得生住老灭。问曰亦依心回。何以但说身耶。答曰以身粗故说身。眼根及次第灭心与眼识作依作所依生眼根四大身根生身根四大命根受身处得生住老灭。如是等法作依不作所依耳识鼻识舌识说亦如是。身根及次第灭心与身识。作依作所依。生身根四大命根受身处得生住老灭。如是等法。作依不作所依。意识前次第灭心与意识。作依作所依。身根生身根四大命根受身处得生住老灭。如是等法。作依不作所依。复有说者。眼根及次第灭心与眼识。作依作所依。生眼根四大身根生身根四大色香味触命根受身处得生住老灭。如是等法。作依不作所依。耳识鼻识舌识说亦如是。身根及次第灭心与身识。作依作所依。生身根四大色香味触命根受身处得生住老灭。如是等法。作依不作所依。意识前次第灭心与意识。作依作所依。身根生身根四大色香味触命根受身处得生住老灭。如是等法。作依不作所依。复有说者。眼根及次第灭心与眼识。作依作所依。俱生四阴。作依不作所依。耳鼻舌身识亦如是。意识前次第灭心与意识。作依作所依。俱生四阴。作依不作所依。如是则说生欲色界者生无色界者云何。答曰意识前次第灭心与意识。作依作所依。俱生三阴。作依不作所依

问曰命根体。为是一为是多耶。若是一者断其手足。何故命不断耶。若是多者断其手足。何以手足中而无命耶。答曰应作是说。体实是一。以一命根在身中故名之有命。如有一受名之有受。如有一思名曰有思。有一心故名曰有心。一心灭故名曰无心。如是有一命故名曰有命。问曰若然者。断其手足何以不死耶。答曰命所依身有二种。有具足不具足。若断手足时。具足者灭。不具足者续生。具足所依身。在不生法中住。不具足者。遇缘便生。问曰何故断手足时不死。断头截腰。而便死耶。答曰若断手足及余身分时。不坏害多入。若断头截腰。则坏害多入。复次若断手足时。不坏害多入因。亦不坏缘。若断头截腰。则坏害多入因。亦破其缘。令多入在不生法中住复次以头是诸根聚处。以腰是入出息住处。若坏害则死。手足等身分。非诸根聚处。亦非入出息住处。是故断截不死。复有说者。命根体是多法。手足中异。如是诸余身分中亦异。问曰若然者。断其手足。弃在于地。何以无命耶。答曰手足中命。虽性各异而属于身。若离于身更不属身。是故不活。复次以离所依长养缘故不活

云何受身处。答曰众生相似法。受身处亦是一体。是不隐没无记。亦是报亦是依。报者说诸趣相似。如地狱众生展转相似。如是余趣余生当知亦展转相似。依者说界相似。如欲界还似欲界。色无色界说亦如是。如界相似。如是方土族姓居家比丘婆罗门学无学。亦应随相说。复有说者。报者初生时所得者是也。依者后时所得者是也。如沙门还似沙门。婆罗门还似婆罗门。此相似法。有得有舍。舍者或身死时舍。或余事故舍。余事者如得正决定。舍凡夫相似。得圣相似。阿罗汉般涅槃时。舍而不得。复有说言。众生相似法有三种。谓善不善无记。如八人相似法是善。五无间业人相似法是不善。诸余人相似法是无记。问曰诸死此生彼。尽舍受身处耶。设舍受身处。尽死此生彼耶。乃至广作四句。死此生彼不舍受身处者。地狱中死。还生地狱中。乃至天中死。还生天中。是舍受身处。非死此生彼者。谓得正决定者是也。死此生彼。亦舍受身处者。地狱中死。生余道中。乃至天中死。生余道中是也。不死此生彼。亦不舍受身处者。除上尔所事

阿毗昙毗婆沙论卷第十四

    校正后序

此卷第十七张第五行。欲令无量那由他眷属(之下)皆得解脱入于涅槃(之上)国本有能断贪欲修悲心者(乃至)兄弟姊妹欲令安乐非等。凡四百五十五字。丹宋二本并无者。详其文势非唯首尾不相连续。至于立文之体。亦非此论。国本妄加耳。故今不取。但恨未详此文来自何经。此须待勘。因书其意以告来贤云阿毗昙毗婆沙论卷第十五

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    杂揵度人品下

无有中爱。当言见道断。当言修道断。乃至广说。问曰。何故作此论。答曰。此是佛经。世尊经说有三种爱。一欲爱。二有爱。三无有爱。世尊经。虽说无有中爱不说见道断修道断。彼经是此论所为根本。彼中不说。此悉说之。以是事故而作此论

问曰。无有中爱。当言见道断。当言修道断。答曰。当言修道断。所以者何。无有是无常诸缘。彼爱是无有中爱。问曰。此亦是见道断。何以但言修道断耶。答曰。为随顺经义故。如经中说。犹如有一为恐怖苦痛所逼。作如是念。使我断坏。乃至死。死后无病。常得安乐。彼经义趣。说受身处无常。彼所缘爱。是修道断。以随顺经义故。说修道断。复次或有说者。无有中爱。或见道断。或修道断。云何见道断。答曰。见道所断无有中爱。乃至广说。此文先说。随顺经义。今者则说真实义。如我义无有中爱。当言修道断。如我义者。如我随顺佛经中义。彼经是此论根本。以是事故。言无有中爱修道所断。如是汝欲令无有中爱修道所断耶。此是毗婆阇婆提(毗婆阇婆提秦言分别论)定育多婆提之言(育多婆提秦言相应论)。若不定他言。说他过者。此则非理故。言汝欲令无有中爱修道断耶。育多婆提答言。如是毗婆阇婆提。作如是言。若作是说。须陀洹。能起此爱。使我断坏乃至死。死后无病。常得安乐耶。答曰不也。问曰。何故须陀洹。不能起此爱耶。答曰。或有说者。须陀洹。信法信业故。复有说者。已见诸法自体生故。复能满足修空解脱门故。复有说者。此爱是断见所增长。依断见生。圣人已离断见故。复有说者。此爱从次第因生。彼次第已断故。尊者奢摩达说曰。见道所断法。是其因。圣人已断见道所断法故。毗婆阇婆提。作如是言。听我所难说。汝违言负处。汝作是言。无有中爱。修道所断。汝亦应说。须陀洹。能起此爱。使我断坏乃至死。死后无病。常得安乐。若作是语。此事不然。不应作是说。无有中爱。修道所断。若说无有中爱修道所断。此事不然。若说此爱修道所断。不应言须陀洹不起此爱。若须陀洹。不起此爱。不应言此爱修道所断。育多婆提。作如是说。我不言诸不断者。必起现在前。自有不断不起现在前。有虽断而起现在前。若当不断尽起现在前者。则无解脱出要。所以者何。凡夫人学人。未来世中不断者多。若当尽起现在前。则不得解脱。以未来世无边故。如是事者。智人所不可。育多婆提。先说如是等法。为说他过而欲立难。如是汝意。欲令须陀洹未尽地狱畜生饿鬼爱耶。毗婆阇婆提答言。如是。育多婆提复更定言。汝意欲令须陀洹能起如此爱。使我作伊罗跋那龙王善住龙王若阎罗王。使我于地狱众生中尊。毗婆阇婆提答言。不也问曰。何故须陀洹不起如是等爱耶。答曰。凡夫人生处。非圣人生处。复有说者。愚者生彼中。彼是智者故。复有说者。彼恶道已得非数灭故。若法得非数灭。不复起现在前。复有说者。爱有二种。一生处爱。二资生爱。须陀洹于恶道。虽不起生处爱。而起资生爱。爱于象马等。如帝释于青衣鬼所而起爱心。问曰。于地狱趣。复云何起耶。答曰。若其父母。生地狱中。从可信人边闻。便生爱心。育多婆提复作是言。听我所难说。汝违言负处。汝作是言。须陀洹未尽地狱畜生饿鬼爱。应作是说。须陀洹能起此爱。使我作伊罗跋那龙王。乃至广说。若作是说。此事不然。若不说须陀洹能起此处。亦不应说须陀洹未尽地狱畜生饿鬼爱也。若须陀洹未尽地狱畜生饿鬼爱。而不起现在前。即是汝违言负处。如汝所说。须陀洹。缘恶道爱未尽。而不起现在前。我所说无有中爱亦如是。育多婆提。复难毗婆阇婆提言。于意云何。为缠所缠杀父母。此缠是修道所断耶。毗婆阇婆提答曰。如是。育多婆提责。毗婆阇婆提答曰。不也。问曰。何故须陀洹。不起此缠耶。答曰。或有说者。有增上恶心者。能起此缠杀父母。彼须陀洹。有增上善心故。复有说者。有增上无惭无愧者。能杀父母。须陀洹有增上惭愧故。复有说者。彼缠邪见所长养。随邪见后生。须陀洹邪见已断故。复有说者。须陀洹已得不作戒。以是事故不起此缠。育多婆提复责毗婆阇婆提。广说如上。育多婆提复更难毗婆阇婆提言。于意云何。修道所断法。无有中爱。此爱当言修道断耶。毗婆阇婆提答曰。如是。修道所断法者。谓有漏善法。无有者。谓断善根。育多婆提。复责毗婆阇婆提言。于意云何。须陀洹能起此爱。我当断善根耶。毗婆阇婆提答曰。不也。问曰。何故须陀洹不起如是爱耶。答曰。圣人爱乐功德。常欲成就善法现在前。不欲远离。是故不起。育多婆提复责毗婆阇婆提。广说如上。诸言不断必起现在前。应说有如上等过。外书中有三种难。一名疑难。二名说过难。三名除坏难。佛经中说。世尊亦以三种难难他。一名转胜难。二名等义难。三名违言难。转胜难者。如长爪梵志作如是言。我一切不忍。佛难言。汝于此见亦不忍耶。等义难者。如波知离问佛。汝知幻耶。佛答言知。波知离言。沙门瞿昙即是幻者。佛问波知离。汝知拘荼国有恶人名萨婆周罗多行恶法者不耶。答言我知。佛言。汝亦是多行恶法人也。违言难者。如优波离居士。先言身业重。后说仙人恶意。故灭迦陵伽大城等。此中育多婆提。以等义难。毗婆阇婆提。使堕负处。无有名何法耶。答曰。三界无常。问曰。何以作此论答曰。欲令毗婆阇婆提无所言故。若不作是说。毗婆阇婆提当作是语。汝虽以言语伏我。然无有中爱体性与法相相应者。或见道断。或修道断。是故彼尊者作如是说。无有名何法。三界无常。复有说者。先说随顺经义趣。后说真实义。复有说者。育多婆提还语毗婆阇婆提。我虽以言伏汝。然无有中爱体性与法相相应。或见道断。或修道断。是故作如是说。无有名何法。三界无常。问曰。无漏法亦有无常。此中何以不说耶。答曰。若法是爱安足处所缘处。此中便说无漏无常非爱安足处非爱所缘处。是故不说

何等心解脱。有欲心耶无欲心耶。乃至广说。问曰。何故作此论。答曰。此是佛经。佛经中说。欲心得解脱。恚痴心得解脱。不作是说。为有欲心得解脱无欲心得解脱。乃至广说。彼经是此论根本。今当广解此经。复次或有说。心性本净。为客烦恼所覆。如毗婆阇婆提说。心性本净。彼客烦恼生覆心故不净。问曰。若当心性本净客烦恼覆故不净可尔者。何不以本性净心令客烦恼亦净耶。汝若不说以心净故令客烦恼净者。为有何因缘。复次为心先生后客烦恼生。为俱生耶。若心先生后客烦恼生者。则心住待客烦恼。客烦恼生。然后覆心。若作是说。是则一心住二刹那。若当俱者。为以何时言心性本净。复无未来世。以住本性净心。是故为止他义。自显己义。亦欲说法相相应义故。而作此论

何等心解脱。有欲恚痴心解脱耶。无欲恚痴心解脱耶。答曰。无欲恚痴心解脱。问曰。无欲恚痴心。即是解脱。复何所解脱耶。答曰。若以烦恼而言。则心名解脱。若以世以身而言。则不名解脱。若诸烦恼不断。彼心不行于世。不于世得解脱。不行于身。不于身得解脱。若诸烦恼断。彼心行于世。于世得解脱。行于身。于身得解脱。复次或有说者。欲相应心得解脱。恚痴相应心得解脱。如毗婆阇婆提作如是说。染污心即是无染污心。若烦恼未断是染污烦恼已断是不染污。犹如同器有垢。未去垢时名曰有垢。已去垢故名曰无垢。彼亦如是。彼如是说者。应当违逆呵责。所以者何。非彼心与欲恚痴相应杂合。若欲恚痴不断。此心不名解脱欲恚痴。若欲恚痴断。此心名解脱欲恚痴。欲证此义故引佛经。世尊经说。日月有五曀。为五曀所覆故日月不明净。云何为五。谓云乃至广说。云者如夏时。少云能遍虚空。烟者如焚烧草木。烟遍虚空。尘者如天不雨时。风动地尘。遍于虚空。雾者如大河边出雾遍于虚空。复有说者。东方国土若昼若夜。雨后日出时。雾从地起。遍于虚空。罗睺罗阿修罗王障者。日月是诸天前军。天与阿修罗。常共斗战。以日月威力故。诸天常胜。罗睺罗阿修罗王。而先欲摧灭。以是一切众生业力故。而不能灭。以手障之。如此诸曀。与日月相远。而不相近。未除彼曀。日月于此诸曀而不明净。若除诸曀。日月于此诸曀。而得明净。如是彼心不与欲恚痴相应杂合。若是欲恚痴不断。彼心不名解脱欲恚痴。若欲恚痴断。彼心名解脱欲恚痴。世尊经说。比丘当知。得第一大身者。谓罗睺罗阿修罗王是也。乃至广说。无有众生能自化身端正第一如罗睺罗阿修罗王者。此说变化非谓实身

何等心解脱。过去耶。未来耶。现在耶。答曰。未来远心生时。无学诸障。得解脱障者。非想非非想处下下烦恼是也。若说未来。则止过去现在。若说无学。则止学心。问曰。如学心亦得解脱。何以但言无学耶。答曰。或有说者。以尊胜故。若求胜法。无学法胜于学法。若求胜人。则无学人。胜于学人。尊者瞿沙说曰。若多胜无过。言是解脱。若得无学心。则解脱多亦胜无过。复次若心得二种解脱者。名为解脱。谓自体解脱。身得解脱。以是事故而作四句。或有心自体得解脱非身。或有身得解脱非自体。乃至广作四句。自体得解脱非身者。谓学心是也。身得解脱非自体者。阿罗汉善有漏不隐没无记心是也。自体解脱身亦解脱者。谓无学心是也。非自体解脱非身解脱者。谓学有漏心一切凡夫心是也。复次无障碍故名解脱。学人则为邪解脱所障。无学不尔。如是学正解脱。与邪解脱相对。无学不尔。复次若心于一切结得解脱。名为解脱。学心有分解脱。有分不解脱。无学不尔。复有说者。若心于五种烦恼事中得解脱。五种缘中得解脱。名为解脱。五种烦恼障碍。五种缘障碍说亦如是。复有说者。若不为如摩楼多爱草所系者是名解脱。复次若能揃有顶所依周罗者。是名解脱。复次若断三界诸烦恼发。是名解脱。复次若减少解脱能令满足。是名解脱。如学人乃至金刚喻定。名不满足。得无学心名为满足。复次若得猗乐。不为烦恼所障。是名解脱。学人虽得猗乐。为烦恼所障。无学人得猗乐。不为烦恼所障。复次若广受猗乐名为解脱。学人以有所作故。受猗乐不广若得无学心。所作已办。则广受猗乐。犹如国王怨敌未尽受乐不广。若怨敌尽者。则广受乐。若所作已办。除去重担。更无欲求亦复如是。复次众生常共烦恼独语。若得远离。牟尼意满足。是名解脱。复次若离染污诸阴重担者。是名解脱。复次若离烦恼热诸入。得清凉入。是名解脱。复次若离烦恼所依诸入。得无烦恼所依诸入。是名解脱。复次若远离烦恼众生聚自立无。烦恼众生聚中。是名解脱。复次若得为世作福田者。是名解脱。如偈说

  欲心坏众生　　如草败良田
  若施无欲者　　必得于大果

复次若害其命。得无间罪者。是名解脱。复次若断诸着决烦恼堤塘。除一切障碍。断于四食。离四识住。破坏四魔。过九众生居者。是名解脱。复次若行不杂。功德学人杂行善法过恶善行恶行。善根不善根。互现在前。若唯行善行等。不行不善行等者。是名解脱。问曰。如五阴悉得解脱。何以独说心得解脱耶。答曰。或有说者。以心胜故。此中应说。如第一品中答。问曰。唯有一刹那心得解脱耶。答曰不也。若说一刹那生心。当知尽说未来一切心。所以者何。未来无学心。得行于世故。问曰得尽智时。未来世所有修三界善根。为得解脱不也。答曰得。所以者何。亦除其障故。问曰。若退阿罗汉果。还得阿罗汉果。先所得过去无漏道。彼为得解脱不耶。答曰不得。以不除障故。如无碍道灭。乃至广说。无碍道者是金刚喻定。问曰。何故名金刚喻耶。答曰。犹如金刚无所不断。无所不坏。无所不穿。若铁若牙。若石若摩尼珠。若颇梨。若山。如是等物无不摧破。彼定亦尔。于一切烦恼。若不摧破。无有是处。以分别故说。若设当具缚凡夫。能起此定则能断一切烦恼。何以故。是一切烦恼对治法故。何以知耶。答曰。得阿罗汉时。证一切三界见道修道所断烦恼解脱得。以是事故。知此定是一切烦恼对治法。问曰。如金刚喻定体性。若是五阴。若是四阴。何以但名定耶。答曰。以定势偏多故名为定。如见道体是五阴。以见势偏多故名为见道。如见道边等智体性。是五阴四阴。以智势偏多故说名为智。如四道。通体性。是五阴四阴。以通势多故说名为通。金刚喻定体性。是五阴四阴。以定势多故说名为定。问曰。若然者。则因论生论。彼处何故定势多耶。答曰。或有说者。以非想非非想处难断难破难过。须坚固定。以安其足。发大精进。如人欲害象时。先安其足。发其武勇。然后可害。如是非想非非想处。难断难破难过。当先安其足。发大精进已。然后能断。如象非想非非想处下下烦恼。复有说者。非想非非想处。微细难知。难可解了。当须大持意法。如人欲射一毛。当须大持意法。彼亦如是。此金刚喻定。若在未至禅。则有五十二金刚喻定。其事云何。金刚喻定。与六智俱。谓四比智二法智。二法智者。谓灭智道智。依未至禅。以苦比智当得阿罗汉果。彼观非想非非想处苦等四行。若一行现在前。当得阿罗汉果。若以集比智。观非想非非想处集等四行。若一行现在前。当得阿罗汉果。若以灭法智。观行现在前当得阿罗汉果若以灭法智。观欲界诸行灭等四行。若一行现在前。当得阿罗汉果。若以道法智。观欲界断诸行道等四行。若一行现在前。当得阿罗汉果。若以灭比智。彼或有观初禅诸行灭等四行。若一行现在前。当得阿罗汉果。如是乃至观非想非非想处诸灭亦如是。如是八四有三十二。若以道比智。观九地中比智分道等四行。若一行现在前。当得阿罗汉果。灭比智三十二。道比智四。前有十六。是名依未至禅有五十二金刚喻定。如是依初禅禅中间第二禅第三禅第四禅。亦有五十二金刚喻定。空处有二十八。若依空处。以苦比智。观非想非非想处苦等四行。若一行现在前。当得阿罗汉果。若以集比智说亦如上。若以灭比智。观空处诸行灭等四行。如前说。或观识处。或观无所有处。或观非想非非想处灭等四行。广说如上。若以道比智。观九地中比智分道等四行。广说如上。灭比智有十六。道比智有四前有八。是名依空处二十八金刚喻定。识处有二十四。无所有处有二十。如是随所应说。此是一家义。复有说者。未至禅中有八十。其事云何。金刚喻定。与六智俱。如上说。若依未至禅。以苦比智。当得阿罗汉果。观非想非非想处苦。如先说。若以集比智。观非想非非想处集。如先说。若以灭法智。观欲界诸行灭。如先说。以道法智。观欲界断诸行道。如先说。若以灭比智。观初禅诸行灭。如先说。或有观乃至非想非非想处诸行灭。亦如上说。此八四有三十二。道比智亦有三十二。合六十四。前有十六。是名依未至地有八十金刚喻定。如是初禅禅中间第二禅第三禅第四禅。亦有八十。空处有四十。若依空处。以苦比智。当得阿罗汉果。广说如上。以集比智说亦如上。若以灭比智。观空处诸行灭。乃至非想非非想处诸行灭有十六。道比智亦有十六。前有八。是名空处有四十金刚喻定。识处有三十二。无所有处有二十四。应随相广说。评曰。应作如是说者好。依未至禅。应有百六十四金刚喻定。其事云何。若依未至禅。以苦比智。观非想非非想处苦。广说如上。若以集比智。观非想非非想处集。说亦如上。若以灭法智。观欲界诸行灭。说亦如上。若以道法智。观欲界断诸行道。说亦如上。若灭比智。观初禅诸行灭。或有乃至观非想非非想处诸行灭。如是八四有三十二。如前说。或有观初禅亦观第二禅。或观第二禅。亦观第三禅。或观第三禅。亦观第四禅。或观第四禅。亦观空处。或观空处。亦观识处。或观识处。亦观无所有处。或观无所有处。亦观非想非非想处。或有观初禅第二禅第三禅。或有观第二禅第三禅第四禅。或有观第三禅第四禅空处。或有观第四禅空处识处。或有观空处识处无所有处。或有观识处无所有处非想非非想处。或有观初禅第二禅第三禅第四禅。或有观第二禅第三禅第四禅空处。或有观第三禅第四禅空处识处。或有观第四禅空处识处无所有处。或有观空处识处无所有处非想非非想处。或有观初禅乃至空处。或有观第二禅乃至识处。或有观第三禅乃至无所有处。或有观第四禅乃至非想非非想处。或有观初禅乃至识处。或有观第二禅乃至无所有处。或有观第三禅乃至非想非非想处。或有观初禅乃至无所有处。或有观第二禅乃至非想非非想处。或有观初禅乃至非想非非想处。若以道比智。观九地中比智分道等四行。若一行现在前。当得阿罗汉果此有四。前苦比智有四。集比智有四。灭法智有四。道法智有四。灭比智有百四十四。如是依未至禅。有百六十四金刚喻定。初禅禅中间乃至第四禅。亦有百六十四。空处有五十二。若依空处。若以苦比智。当得阿罗汉果。观非想非非想处苦等四行。广说如上。若以集比智。观非想非非想处集。广说如上。若以灭比智。或观空处诸行灭。乃至或观非想非非想处诸行灭。广说如上。或有观空处识处。或有观识处无所有处。或有观无所有处非想非非想处。或有观空处乃至无所有处。或有观识处乃至非想非非想处。或有观空处乃至非想非非想处。若以道比智。观九地比智分道等四行。广说如上。此有四。前苦比智有四。集比智有四。灭比智有四十。是名依空处五十二金刚喻定。识处有三十六。若依识处。以苦比智。观非想非非想处苦四行。广说如上。若以集比智。观非想非非想处集四行。广说如上。若以灭比智观识处诸行灭。乃至或观非想非非想处诸行灭。广说如上。若以灭比智。观识处无所有处。或观无所有处非想非非想处。或有观识处乃至非想非非想处。若以道比智。观九地道智分道等四行。广说如上。此有四。前苦比智四。集比智四。灭比智二十四。如是依识处有三十六金刚喻定。无所有处有二十四。依无所有处。若以苦比智。观非想非非想处苦四行。广说如上。若以集比智。观非想非非想处集四行。广说如上。若以灭比智。观无所有处诸行灭。或观非想非非想处诸行灭。广说如上。或观无所有处非想非非想处诸行灭。广说如上。若以道比智。观九地比智分道等四行。广说如上。此有四。前苦比智四。集比智四。灭比智有十二。如是依无所有处有二十四金刚喻定。无色界中。不应说法智。生色界中。不应说法智。不应说生上地依下地离欲。除非想非非想处亦不应说生上地观下地灭余生色界。亦如生欲界说生无色界。如生欲色界说。尊者瞿沙说。金刚喻定有十三。云何十三。谓诸断非想非非想处烦恼。无碍道见道所摄有四。修道所摄有九

已解脱心得解脱耶。未解脱心得解脱耶。答曰。已解脱心言得解脱。如是汝语。已解脱心言得解脱。不应说已解脱心言得解脱。所以者何。若以解脱不得言当解脱。若当解脱不得言已解脱。问曰。已解脱心。何以言得解脱耶。答曰。以是事故。先作是说。若以烦恼而言。名已解脱。若以行世在身而言。名得解脱。我亦说已解脱言得解脱。亦说已作事言作。如是说者复有何过。佛亦说已解脱言得解脱。已作事言作。欲证此义故引佛经。于汝意云何。佛经为是善说不耶。如说偈

  若断欲无余　　如莲花在水
  比丘舍此彼　　如蛇脱皮去

问曰。佛说此偈。为已舍言舍耶。未舍言舍耶。答曰。佛说已舍言舍。此中说断欲无余。言已舍舍。如此偈中。已舍言舍。已作言作。我亦如是。已解脱言得解脱。而无有过。为证此义故复引佛经。如说偈

  慢尽自定意　　善心一切脱
  一靖居无乱　　能度死彼岸

问曰。此偈中为说已度度未度度耶。答曰。此中说已度度。若善心一切得解脱时。名已度而言是度。如此经说。已度言度。已作言作。我亦如是。已解脱言得解脱

又世尊言。习厌无欲习无欲解脱习解脱涅槃。问曰。何以作此论。答曰。此是佛经。佛经说习厌无欲。乃至广说。不分别云何厌云何无欲。乃至广说。佛经是此论根本。彼中不说者。今当说之。以是事故而作此论

习有二种。一者能生。二者能到。能生者。如习厌能生无欲习无欲能生解脱。能到者。如习解脱能到涅槃。复有说者。习有二种。一者随顺。二者随应。随顺者。如习厌得无欲习无欲得解脱。随应者。习解脱应得涅槃。问曰。若是习性。亦是缘性耶。答曰。诸是缘性。则是习性。问曰。颇是习性非缘性耶。答曰有。谓习解脱得涅槃者是也(此习于涅槃无四缘义而能到涅槃)。云何为厌。答曰。无学恶贱五取阴诸行。如经本广说。问曰。如此厌。亦是无学。亦是学。亦是非学非无学。何以唯说无学耶。答曰。或有说者。以名义俱胜故。若求法胜。则无学法胜。若求人胜。则无学人胜。尊者瞿沙说曰。以多胜无过故。唯说无学厌。不说学人凡夫人也。复有说者。世尊说胜法根本故。无学是胜法根本故。无学是胜法根本。非学人凡夫人也。复有说者。若说终者。亦明其始。复有说者。若无二法相对应。如上无学广说。问曰。厌体性是何。答曰。或有说者。体是慧性。问曰。若然者。厌体性是苦忍苦智。彼说善通。此文云何通。如说。云何习厌得离欲。答曰。与厌相应无欲恚痴善根。问曰。若然者。慧还与慧相应耶。答曰。此文应如是说。彼厌相应无欲善根。不应说无恚无痴。应作是说。而不说者。当知此文是诵者长说。复有说者。此厌是心数法与心相应。问曰。若然者。此文善通。见揵度所说体。是苦忍苦智。复云何通。答曰。彼中说厌。以亲近苦忍苦智故。于何处得厌。答曰。苦忍苦智边。评曰。不应作是说。如前说者好。厌体性是慧。云何世俗厌答曰。与不净相应者是也。即是阿那般那体。是缘苦集暖顶忍是世第一法。是缘苦集。见道边等智。与悲相应。第一第二解脱相应。与初四胜处相应。是身如病如痈如疮。无常苦空无我因集有缘等行。粗说则有如是等相。若广说者。量过四海。问曰。若厌体是可厌耶。若体是可厌是厌耶。乃至广作四句。初句者无漏厌是也。第二句者除世俗厌诸余有漏体是也。第三句者世俗厌是也。第四句者除无漏厌诸余无漏体是也。问曰。如一切法无我观。为是厌观也。为是欣踊观耶。答曰。此义前无我行中已说

云何习厌得离欲。答曰。与厌相应无欲。无有欲善根。此文应如是说。不应说无恚无有恚。问曰。无欲体性是何。答曰。体性是无贪

云何习无欲得解脱。答曰。彼无欲相应解脱。乃至广说。一切诸法中。有二法体是解脱。一者有为。二者无为。有为者心数法中解脱是也。无为者数灭是也。此中唯说有为解脱。不说无为解脱。有为解脱有二种。一者染污。二者不染污。染污者。是邪解脱。不染污者。是正解脱。正解脱。复有二种。一者有漏。二者无漏。有漏者。与不净观相应。慈悲喜舍相应。无漏者。与学无学相应。学者有四向住三果。无学者唯住一果。无学复有二种。一时心解脱。二非时慧解脱。时心解脱者。谓五种阿罗汉是也。非时慧解脱者。不动阿罗汉是也。此即是断欲心得解脱。此即是断无明慧得解脱。问曰。若断欲即是慧得解脱断无明即是心得解脱者。摄法论所说。云何通耶。如说云何断欲心得解脱。答曰。无贪善根。云何断无明慧得解脱。答曰。无痴善根。问曰。如无贪无痴善根。非解脱性。何故说是解脱耶。答曰。此文应如是说。云何断欲心得解脱。答曰。无贪善根相应解脱是也。云何断无明慧得解脱。答曰。无痴善根相应解脱是也。此文应如是说。而不说者。有何意耶。答曰。各有所为故。或有为断欲。故勤方便。或有为断无明。故勤方便。或有为断欲勤方便者。名心解脱。或有为断无明勤方便者。名慧解脱。然其解脱。更无别体。复有说者。无贪与贪相应。无痴与痴相对。是故以无贪无痴名说

云何习解脱得涅槃。答曰。若断一切爱尽。乃至广说。问曰。如断一身见尽。亦名涅槃。何以言断一切爱尽耶。答曰。或有说者。此中说满足涅槃。何者是耶。谓断一切爱尽。乃至广说。复有说者。此中诸所说道。尽说无学身中道。如说无学身中道。说无学身中道果亦如是。学人所断有余。非是无余。问曰。云何名涅槃义。答曰。或有说者。诸阴林断更不生。是涅槃义。复有说者。灭一切烦恼义。是涅槃义。复有说者。灭种种大故。是涅槃义。复有说者。不织义。是涅槃义。如因经纬织杖等织[疊*毛]便成。若不因经等。织[疊*毛]不成。如是因业烦恼经纬故。织受生[疊*毛]便成。若不因业等。织受生[疊*毛]不成。以是事故。不织义是涅槃义

问曰。厌无欲解脱涅槃有何差别。答曰。恶贱是厌。不求是无欲。心无垢是解脱。舍担是涅槃。复有说者。恶贱烦恼是厌。断烦恼。是无欲。不与烦恼俱。是解脱。诸阴尽。是涅槃。如尊者瞿沙解此经。如实知见是说见地。厌是薄地。无欲者是无欲地。解脱者是无学地。涅槃者是诸阴不生

世尊说三界。断界无欲界灭界。乃至广说。问曰。何故作此论。答曰。此是佛经。佛经说。尊者阿难。往诣长老上座所。到已乃至广说。问曰。以何等故尊者阿难往诣彼所。答曰。或有说者。彼尊者阿难。是持佛法船[木*他]者。常监临四众。数数往诣诸比丘所。虑诸比丘谬受境界窳堕空过。以是事故往诣彼所。复有说者。尊者阿难作是思惟。若彼长老比丘。有得胜进功德者。我当赞善随喜。若不得者。我当示其方便。尔时阿难往诣彼所。生相似信。信有二种。有相似有不相似。相似信者。彼若是阿练若问阿练若法。是阿毗昙人问阿毗昙法。是持修多罗人问修多罗法。是持律人问于律法。不相似信者。问与上相违。尔时阿难问彼长老上座阿练若法。汝数数观何境界耶。彼答言。我观舍摩他毗婆舍那。阿难复问。若修行广布舍摩他法。有何利耶。彼答言。若修行广布。舍摩他法。是名修心。若修心者。得心解脱。问曰。如阿毗昙义一心中有定有慧。云何分别是修定方便人修慧方便人耶。答曰。以依具故知。或有多依定具。或有多依慧具。多依定具者。性乐独住。常好闲静。乐居空舍。不喜言说。多依慧具者。常好受持读诵修多罗阿毗昙毗尼。亦以教人。观察总相别相。如是等事是名差别。复有说者。或有系心一缘。而不分别法相。或有不系心一缘。而分别法相。系心一缘不分别法相者。是名修定。若不系心一缘分别法相者。是名修慧。阿难问言。若以定方便修心者。得慧。解脱。若以慧方便修心者得心解脱。若以定以慧方便修心者。得何等解脱耶。答言。得界解脱。复问。何等界解脱。答曰。三界。谓断界无欲界灭界。问曰。如断是无缘法。不能有所缘。何故说言得断界解脱耶。答曰。此中观涅槃解脱。以界名说。所以者何。虽勤行精进。而不能生观涅槃解脱者。终不能得心解脱也。以是事故观涅槃解脱。说名为界。尔时尊者阿难从长老上座比丘所闻如是说已。便诣迦梨勒坛上。以如是义。尽问五百比丘。诸比丘皆以如是义答。问曰。是诸比丘云何而答。答曰。或有说者。如今法会处先下座说。彼亦如是。复有说者。一人答。余者印可。尊者波奢说曰。尔时作白羯磨行筹。受筹者名答。尔时尊者阿难问诸比丘已往诣佛所。以如是等义问佛。佛亦以如是义答。问曰。尊者阿难以不可上座比丘及五百比丘所说而往问佛耶。答曰可适。问曰。若可适者。何以复问佛耶。答曰。欲显善说法中同见同欲同意具足问答故。外道法中。意欲不同。破坏法塔。善说法中。意欲同故不坏法塔。以此法妙故。师与弟子。始终所说。不相违背。复有说者。欲令多人远罪过故。其事云何。曾闻彼长老上座比丘。经六十年。在母胎中。却后生已。身形老瘦。无有威德。尔时多人生轻蔑心作如是言。此诸年少气力强盛。初夜后夜勤行精进。于胜进法犹故难得。何况老瘦身者能得此法。然此五百比丘以饮食故。为提婆达多所坏。后还归佛。是时多人生不信心。是诸比丘贪利供养。岂当能得胜进之法。乃令多人作诸罪过。是时阿难欲令多人去罪过故。而往问佛。彼经虽说断界无欲界灭界。而不广说。此论因彼经故。作种种杂说优波提舍。彼经是此论所为根本。诸彼中所不说者。今此悉说。故作此论

云何断界。我今当先说阿毗昙名数近对治法。云何断界。答曰。除爱结。诸余结断。是名断界。诸余者。除爱结余八结是也。云何无欲界。答曰。爱结若断。是近对治有欲对无欲故。云何灭界。答曰。除九结。诸余结法灭。是名灭界。此中一切有漏体。说是结法。复有说者。八结结相应法。及所起处生等若断。是名断界。爱结爱结相应法。及所起处生等。若得离欲。是无欲界。若说九结。则摄一切染污法尽。余唯有有漏善法及不隐没无记。彼若灭。是名灭界。复有说者。有法缚而不染污。有法亦缚亦染。有法不缚不染。缚而不染法若断。是名断界。亦缚亦染法。若得离欲。是无欲界。不缚不染者。他缚他染若灭者。是名灭界。如缚系义亦如是。复有说者。烦恼体若断。是名断界。烦恼于缘得离。是名无欲界。诸烦恼果更不生。是名灭界。复有说者。过去诸阴若断是名断界。未来诸阴离欲。是名无欲界。现在诸阴若灭。是名灭界。复有说者。若苦受断。是名断界。若于乐受离欲。是名无欲界。不苦不乐受若灭。是名灭界。复有说者。若苦苦断。是名断界。坏苦若离欲。是名无欲界。行苦若灭。是名灭界。尊者奢摩达说曰。舍于重担。是名断界。无欲对治有欲。若离有欲。是名无欲界。令生不相续。相续者若灭。是名灭界。复有说者。或有言唯断爱结。问曰。若然者。则违佛经。佛经说。诸行若断。是名断界。诸行离欲。是名无欲界诸行若灭。是名灭界。复违波伽罗那经。如说可断法云何。答言一切有漏法。复说断智法云何。答言一切有漏法。答曰。爱有缘八结者。有还缘爱者。有缘余法者。缘八结爱若断。是名断界。缘爱结爱若断。是名无欲界。缘余法爱若断。是名灭界。复有说者。唯断于使缘八结使若断。是名断界。缘爱结使若断。是名无欲界。缘余法使若断。是名灭界。若断界是无欲界耶。问曰。何以复作此论。答曰。先说阿毗昙名数义。今欲说真实义。若不尔者。人谓但自随己意不顺佛经。今欲随顺佛经故作如是说。若断界是无欲界耶。答曰如是。乃至广说。所言断无欲灭。此三名虽异义无差别

世尊说三想。乃至广说。问曰。何以作此论。答曰。此是佛经。佛经说三想。不广分别。佛经是此论所为根本。彼中不说者。今悉说之。故作此论

问曰。十六行外。更有圣道不耶。若有者。智揵度识身经中。何以不说耶。若无者。此经云何通。如说受乐受时。如实知受乐受。此是何行。又如说我已知苦。为是何行。不复更知。此是何行。乃至我已修道。此是何行。不复更修。此是何行。我生已尽。梵行已立。所作已办。更不受后有。如摄法经所说。比丘尽欲漏。是名尽智。更不复尽。是名无生智。是何等行。有漏无明漏说亦如是。评曰。应作是说。十六行外更无圣道。问曰。若无者。先说善通。此经云何通耶。受乐受时。如实知受乐受。乃至广说。答曰。不以知受乐受故。名如实知乐受。知此乐受。是道如迹乘。故名如实知我已知苦者是二行。谓无常行苦行。不复更知亦是无常行苦行。我已断集是集等四行。更不断集。亦是集等四行。我已证灭是灭等四行。更不证灭。亦是灭等四行。我生已尽。是集等四行。梵行已立。是道等四行。所作已办。是灭等四行。不受后有。是苦等二行。谓无常行苦行。复有说者。我生已尽有五事。一者身。二者对治。三者所作。四者果。五者人。身者。一切处生身尽。对治者得如此对治。能尽一切生。所作者智能所作使诸生尽。果者得智果。能尽一切生。人者言是人。能尽一切生。如摄法经所说。比丘尽欲漏者。是尽智。有六行。不复更尽。是无生智。亦有六行。六行者谓无常苦二行。及集四行。有漏无明漏。说亦如是。复有说者。十六行外。更有圣道。问曰。若有者。智揵度识身经中。何故不说耶。答曰。应说而不说者。当知此说有余。问曰。此有余说有何义耶。答曰。若行能得正决定。得果离欲。及尽诸漏者。智揵度识身经则说。若诸行不能得正决定。不得果不离欲。不尽诸漏者。然是圣所得道。为受现法乐故。为游戏故。观本所作故。受用无上圣法故。而起现在前。复有说者。若行现在断烦恼时。能害烦恼。能有所作。有大功用者则说。现在断烦恼时。彼诸行不能害结。不有所作。无大功用。是故不说。唯在未来世中修。复有说者。若行在方便无碍解脱胜进道者则说。彼说诸行不在无碍道解脱道。或在胜进道。或在远方便道。以是事故。智揵度识身经不说。若作是说。十六行外有圣道者。想是圣道。若行于断是断想。若行无欲是无欲想。若行于灭是灭想。犹如一的。为若木若铁众箭所中。如是一无为体。为三想所行。诸作说。是十六行外。更有圣道者。断想非离欲想非灭想。乃至广说。诸作是说。十六行外更无圣道者。彼想是缘。若缘断是断想。若缘无欲是无欲想。若缘灭是灭想。此文应如是说。若断想是无欲想耶。答曰如是。乃至广说

阿毗昙毗婆沙论卷第十五阿毗昙毗婆沙论卷第十六

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    杂揵度爱敬品第四

云何为爱。云何为敬。乃至广说。如此章及解章义。此中应广说优婆提舍。问曰。何故作此论。答曰。此是佛经。佛经中说。若比丘习惭愧满足。则有爱敬。虽作是说不广分别。云何为爱。云何为敬。今欲说故而作此论。复有说者。所以作此论者。欲断小人法现大人法故。其事云何。答曰。小人爱则妨敬。敬则妨爱。云何爱妨敬。犹如在家法。父母于子。则有亲爱。子于父母有爱无敬。出家法中。和上阿阇梨。于诸弟子。则有亲爱。弟子于和上阿阇梨。有爱无敬。是名爱妨敬云何敬妨爱。犹如在家法中。父母于子。教训严难。欲令诸子远恶修善。子于父母。有敬无爱。出家法中。和尚阿阇梨。于诸弟子教训严难。欲令诸弟子远恶修善。诸弟子于和尚阿阇梨。有敬无爱。如是小人爱则妨敬。敬则妨爱。大人不尔。若爱则加敬。敬则加爱。是故为断小人法欲现威势大人法故。而作此论。佛出世时一人具此二法者多。佛不出世一人具此二法者少。设令有者当知皆是菩萨摩诃萨

云何为爱。答曰。若爱乃至广说。如是等言。尽说爱相。问曰。爱体性是何。答曰。爱有二种一染污。二不染污。染污者体是渴爱。不染污者体是信渴。爱有二种一是渴爱。二是爱。问曰。若渴爱是爱耶。答曰。若渴爱则是爱。颇有爱非渴爱耶。答曰有。不染污爱也。信亦有二种。一是信。二是爱。问曰。若信是爱耶。答曰。或有信非爱。或有信是爱。信非爱者。信而不求者是也。信是爱者。亦信亦求者是也。复有以此义作四句者。或有信非爱。或有爱非信。乃至广作四句。信非爱者。信其事而不求也。爱非信者。染污爱是也。亦信亦爱者。爱其事而求者也。非信非爱者。除上尔所事

云何敬。若敬善敬。乃至广说。如是等言。尽说敬相。问曰。此敬体性是何。答曰。体性是惭愧。云何爱敬。问曰。何故作此论。答曰。先虽说其体。未说此二法俱在一人身中。今欲说故复作此论。云何爱敬。答曰。犹如有一。以爱敬故。意常念佛。凡夫人爱敬佛者。以佛力故。使我得离赋役驱使种种苦事。使我复得种种资生随意之物。圣人爱敬佛者。以佛力故。使我断无始已来无量诸苦。尽恶道因。住决定法。见于真谛正见清净。复有说者。俱爱敬佛。意常念之。以佛力故。使我出家得比丘法及余诸善安乐之利。如尊者优陀耶言。世尊灭我无量恶法。益我无量善法。复次以佛出世故。净三种眼。如尊者舍利弗言。若佛不出世。则我盲无目。过此一生。复次佛于此法最尊胜故。复有说者。佛是法主故。复有说者。无始已来七依之法。隐蔽不现。佛能开示故。复有说者。佛能令无数那由他众生入涅槃城故。复有说者。佛世尊。独出无明壳。转于法轮故。复有说者。以世尊说法故。令无量那由他众生。种诸善根。亦令成熟。使得解脱。以佛说法故。使有念处正断神足根力觉道禅定解脱三摩提。办如是等一切功德。尽现世间。以如是等事如凡夫圣人。爱敬于佛。亦爱敬法。意常念之。所以者何。能尽我身心等苦。亦依此法。能到涅槃。亦爱敬僧。意常念之。所以者何。以僧力故。使我出家受具足戒。得畜百一种物。得共和尚阿阇梨等梵行者。同依佛法。如是等人。我行道时。是我伴侣。以于如是等处有爱有敬。故名爱敬。有人有爱无敬。有敬无爱。乃至广作四句。有爱无敬者。如在家法。父母于子。和尚阿阇梨。于诸弟子。有爱无敬。有敬无爱者。如于有德他师长所不相伏习者。有敬无爱。亦敬亦爱者。如在家法。子于父母。弟子于和尚阿阇梨所。无爱无敬者。除上尔所事。爱敬四趣中尽有。此中所说爱敬。是佛法中所行者也。云何为养。云何为敬。乃至广说。问曰。何故作此论。答曰。为断小人法现大人法故。所以者何。小人养则妨敬。敬则妨养。养妨敬者。如在家法。父母老病。以衣服饮食随病医药。以养父母。而无有敬。出家法中。如诸弟子。威德多闻。善解法相。众所知识。彼以衣服饮食随病医药。以养和尚阿阇梨。其师或时于弟子所。受经问义。如是等养妨于敬。大人不尔。若养则加敬。若敬则加养。佛出世时一人具此二法者多。佛不出世一人具此二法者少。设当有者。当知皆是菩萨摩诃萨也。菩萨若与人养。必加其敬。若与其敬。必加其养。以是事故。欲断小人法现大人法。甚希有故而作此论。云何为养。答曰养有二种。一者财。二者法。问曰财养体性是何。答曰或有说者。所舍物是。复有说者。身口业舍是。复有说者。能令诸根四大长养者是。评曰应作是说。财养体性是五阴。问曰为是何趣耶。答曰除地狱趣。余趣尽有。复有说者。六欲天中无。所以者何。诸天若欲食时。以空金钵置前。随其福力饮食自出。何须财养。复有说者。彼饮食虽等有余财物。可以与他。问曰何处施谁与谁取。答曰或有说者。畜生趣中。还施畜生。饿鬼趣中。施于二趣。人施三趣。天施前三趣。复有说者。能施四趣。若人以饶益他意施饮食。他人食之。四大诸根而得长养。是名为施亦名为养。虽有饶益他意施他饮食。他人食之。不长养诸根四大。是名为施不名为养。若人害心。以杂毒食施他。他人以咒术药草力。若是有德众生。诸根四大。而更增长。是名为养不名为施。彼施者受不善报。问曰法养体是何耶。答曰或有说者。法养体性是名。复有说者。是语。复有说者。若闻法时生未曾有善巧方便。是法养体性。评曰应作是说。取其闻法巧便相应共生法者。体是五阴。问曰何处有法养耶。答曰五趣尽有。何以知地狱趣中有耶。答曰曾闻弥多达子小生地狱中谓是浴室。而便说偈

  人间空处受苦乐　　非我非他之所作
  若受诸触皆缘身　　无有身者谁受苦

时诸众生闻说此偈。缘斯福故。从是命终脱地狱苦。云何知畜生道中亦有法养。答曰如迦宾阇罗鸟等。身行梵行。为他说法者是也。饿鬼中如毕陵迦等是也。人天中者。尽可现见。天中六欲天。及色界诸天。非无色界天。何以知色界诸天亦有耶。答曰如手天子往诣佛所。作如是言。如今世尊。四众围绕而说诸法。闻者欢喜奉行。我还至无热天中。诸天围绕而为说法。闻者欢喜奉行。亦复如是。以是事故。知色界天中亦有法养。若以饶益心。为他说法。他闻法已。生善巧便。是名为施亦名为养。若以饶益心。为他说法。他闻法已。不生善巧方便者。是名为施不名为养。若以讥刺心。为他说法。他人闻已。以智慧心。生善巧便。是名为养不名为施

云何为敬。若敬重敬。乃至广说。敬体性是惭。如前说

云何敬养。问曰。何以复作此论。答曰。先已说敬养体性。未说一人具此二事故而作此论。云何敬养。答曰。犹如有一而敬养佛。问曰。以何敬养佛。答曰。以财敬养佛。不能以法。所以者何。不能生佛未曾有善巧便故。所以者何。以阿罗呵三藐三佛陀不受用他法。法应尔故。问曰。何故此中不说敬养法耶。答曰。作缘义。是养义。彼法离缘故。问曰。若欲施法当施何处。答曰。法有二种。一者名数。二者真实。若欲施名数法者。应施说法人。若书写经。若欲施真实法者。守护此物。当如敬佛塔。云何施僧法养。答曰。于众僧中。作三契经偈。作娑曷遮说决定义。种种问答是也。云何财养。答曰若以种种饮食。施作长斋。般遮于瑟解经法会。供养和尚阿阇梨及余清净梵行者。问曰谁施谁受。答曰佛能施一切众生法养财养。一切众生。能施佛财养。不能施法养。辟支佛能施一切众生法养财养。除佛世尊。一切众生能施佛施辟支佛财养。不能施法养。舍利弗能施一切众生法养财养。唯除佛辟支佛。一切众生能施佛辟支佛舍利弗财养。不能施法养。目揵连能施一切众生财养法养。唯除佛辟支佛舍利弗。一切众生能施佛辟支佛舍利弗目揵连财养。不能施法养。乃至利根者。能施钝根者财养法养。钝根者能施利根者财养。不能施法养。问曰。若无有能施佛法养者。世尊何故称可阿难所说。赞言善哉善哉。如汝所言。精进能生菩提。亦称赞亿耳比丘善哉善哉。汝能以微妙音声。咏诵妙法。以阿槃提国语音声遍满。其言正直易解。令多人乐闻故。此说复云何通。如佛告阿难。我亦增益出家闲静善法。答曰何故称赞阿难者。以阿难所说应时。是以称可。何以知之。曾闻世尊游行人间而患背痛。敷郁多罗僧枕僧伽梨。右胁而卧告阿难言。汝今当为诸比丘说法。尔时阿难为诸比丘解说觉意。诸长老如来。以念觉意故而得成道。亦为他说。乃至广说。择法觉意。精进觉意。当于阿难分别觉意时。世尊自忆念过去无数阿僧祇劫行诸方便。皆是精进力。以忆念故。而起喜心。令此有患四大速灭。无患四大速生。背痛即除。寻起加趺而坐告阿难言。汝说精进耶。阿难言如是。佛言善哉善哉。阿难实如汝所言。精进能生菩提。以是事故称可阿难。称赞亿耳比丘者。或有说者。欲生彼比丘无畏心故。阿槃提国和尚大迦旃延。曾遣亿耳。汝往佛所请求五愿。所谓一求常澡浴。二求皮作敷具。三求毗尼师。作第五人。得受具戒。四求着二重革屣。五求听畜长衣过十夜。以此五事故来诣佛所。世尊威德。乃至梵释护世者。不能侧近正观。以是事故不敢辄求。后世尊称美乃敢求之。是故为令彼比丘生无畏故。而称赞之。复有说者。欲饶益彼比丘故而称赞之。所以者何。彼比丘。于阿槃提土地能作佛事。欲令彼诸人加尊重心故而称赞之。复有说者。以善能诵持优陀那波罗延众义经等。适可佛意故而称赞之。复有说者。以修净业令言音清妙故而称赞之。所言增益出家闲静善法者。诸转转出家。得正决定。证于道果。能离爱欲。亦尽诸漏。种佛道因及缘觉声闻道因。生于尊贵多财之家。眷属成就。有大威势。颜貌端正。能净天道及解脱道者。皆是我力。以我力故。令多众生于我法中出家。有如是等利而起喜心故。言我今增益出家闲静善法。复有说者。欲离诽谤过故。赞叹阿尼卢头等。欲令其人威德尊重故。赞叹目揵连等。欲显有大功德故。赞叹舍利弗等。欲令生无畏故。赞叹如亿耳比丘等

云何身力。云何身力劣。乃至广说。问曰何故作此论。答曰如毗婆阇婆提说。身力身力劣。不由于身。是心所为。为止如是说者意故。欲明力体是触入故。而作此论。复有说者。所以作论者。欲止弥沙塞部意故。彼作是说。身力体是精进。身力劣体是懈怠。为止如是说者意故。欲明身力身力劣体是触入。复有说者。所以作此论者。欲止譬喻者意故。彼作是论。说身力身力劣无有定体。如象力胜马马力胜牛。云何一体。即是身力。是身力劣。欲止如是说者意故。欲明身力身力劣是决定法故。若当身力非决定法。则非入所摄。非识所识。问曰若身力是决定者。譬喻者所说云何通。如象力胜马马力胜牛。答曰此因他故说胜。如马力于象。弱四大则多。强四大则少。牛力于马。弱四大则多。强四大则少。然则强力常强。弱力常弱。以是事故。为止他意欲显己义故。乃至广说而作此论。一切有为法。力有强弱。所以者何。如眼明了能见。是名强力。不如者名为弱力。乃至身亦如是。如意善能知法。是名强力。不如者名为弱力。此中说身力身力劣。而作此论

云何身力。答曰若身力身勇等。乃至广说。如是等名。尽显现力相。如二力士角力。乃至广说。以是义故。知身力身力劣触入所摄。所以者何。由触故。知是人力强是人力劣。犹如二健夫捉一力劣者。彼当捉时。展转相知。如强力者捉劣力者。知其力劣。力劣捉强力者。亦知其力强。强力劣力。俱一入所摄。谓触入二识所识。谓身识意识。身识识别相。意识识别相总相。以如是义。则止说身力不定者意。所以者何。若当身力身力劣不定者。则不应定说一入所摄二识识也

问曰身力身力劣体性是何。答曰或有说者。体是四大。问曰若然者。何大增故身力强。何大增故身力劣耶。答曰或有说者。四大无增。自有相似四大生身力则强。有相似四大生身力则劣。复有说者。地大增故。身力则强。水大增故身力则劣。外物亦尔。如陀婆树佉陀罗树毗摩树婆陀罗树等。以地大偏多故则坚硬。如苇柳瓠胡麻[卄/幹]等。水大偏多故则弱。复有说者。身力力劣。触入所摄。体非四大。是造色性。问曰若然者。造色性有七种。何者增故身力强。何者增故身力劣耶。答曰重偏多故身力强。轻偏多故身力劣。外物亦尔。重者则强。轻者则劣。复有说者。七种造色外。更有身力身力劣。评曰应作是说。四大身等身力则强。四大不等身力则劣

如说菩萨有那罗延力。那罗延力齐量云何。答曰或有说者。十凡牛力。与一村天牛力等。十村天牛力。与一青牛力等。十青牛力。与一凡象力等。十凡象力。与一香象力等。十香象力。与一大力人力等。十大力人力。与一钵建陀力等。十钵建陀力。与半那罗延力等。二半那罗延力。与一那罗延力等。一那罗延力。与菩萨一节力等。是名菩萨身力。复有说者。此说甚少。十凡牛力。与一村天牛力等。乃至十凡象力。与一野象力等。十野象力。与一伽尼罗象力等。十伽尼罗象力。与一阿罗勒迦象力等。十阿罗勒迦象力。与一雪山象力等。十雪山象力。与一香象力等。十香象力。与一青山象力等。十青山象力。与一黄山象力等。如是次十倍。赤白优钵罗拘物头波头摩说亦如是。十波头摩象力。与一大力人力等。十大力人力。与一钵建陀力等。十钵建陀力。与一沙楞伽力等。十沙楞伽力。与一婆楞伽力等。十婆楞伽力。与一章[少/兔]勒力等。十章[少/兔]勒力。与一婆罗章[少/兔]勒力等。十婆罗章[少/兔]勒力。与一半那罗延力等。二半那罗延力。与一那罗延力等。是名那罗延力量。复有说者。此说亦少。千伊那拔罗龙王力。与菩萨一节力等。曾闻三十三天欲游戏时。伊那拔罗龙王。其色纯白。如拘物头华七枝安立。具有六牙。头赤如因提具波色。左右胁各二由延半。前后各一由旬。如是绕身有七由延。高二由旬半。此是常身有八千眷属。彼诸眷属。其色赤白。如拘物头华七枝安立。具有六牙。头赤如因提具波色。三十三天欲游戏时。伊那拔罗龙王身上。自然有香手现。便作是念。今者诸天须我。即自化身。有三十二头。头有六牙。头赤如因提具波色。第三十三者。是其常头。一一牙上。化作七池。一一池中。化作七莲花。一一花上。化作七台。一一台上。化作七绞络帐。一一帐中。有七天女。一一天女。有七侍者。一一侍者。有七伎女。作是化已。往至诸天城中。所化三十二头。三十二辅臣。及其眷属而乘其上。常头帝释。及其眷属。而乘其上。如是凡有一万诸天家族。其身轻举。犹如旋风吹于草叶。乘空而上。诣游戏处。尔时诸天。都不自见有前后者。到游戏处。尔时诸天。各各诣游戏园林。欢娱快意。尔时龙王。亦自化身。作天子形。而自娱乐。如是伊那拔罗龙王力。菩萨身者。有十八大节。一一大节。有千伊那拔罗龙王力。如是等名菩萨身力。复有说者此说犹少。菩萨身力。有十八大节。前所说者。是菩萨十八节中最下节力。第二所说。是菩萨次胜节力。第三所说。是第三节力。如是次第。各转倍胜。尊者婆檀陀说曰。意力无量。当知身力亦无量。何以知之。如阿耨多罗三藐三菩提道在未来世。必生现在前。尔时三千大千世界大地震动。以是事故。知意力无量身力亦无量。问曰若然者何以言菩萨有那罗延力耶。答曰以那罗延力世人所尚。是以为喻。然则意力无量。身力亦无量。问曰以何等故。菩萨修集如是力耶。答曰欲现一切皆胜事故。如菩萨于诸世间。一切事胜。所谓色族财富眷属积集功德及诸名闻力亦应尔。如色族等益于世间力亦应尔。复有说者。为阿耨多罗三藐三菩提故。所以者何。阿耨多罗三藐三菩提。应住如是坚牢身故。无有是处。以分别故说。若当阿耨多罗三藐三菩提住须弥山顶者。须弥山便当摧破。以力无畏甚尊重故。是以如来初成道时。举足欲行。安徐蹈地。地故震动。复有说者。以阿耨多罗三藐三菩提故。于三千大千世界中阎浮提。阎浮提中有金刚座自然而出。菩萨坐上。成等正觉。如是亦为阿耨多罗三藐三菩提故。积集坚牢之身。复有说者。以此力引致应化众生故。是中应说化力人喻诸释子射喻般涅槃时坚石喻。曾闻世尊般涅槃时。诣波波村。尔时五百力士。修治道路。时有一石。长十二丈。广六丈。诸力士等。尽其身力。不能令动。世尊既至。问诸童子。今何所为。答言。修治道路。世尊复问。我今为汝去此石耶。答言可尔。佛告诸人。汝悉远去。尔时世尊。以脚拇指。举此大石。安置右掌中。复以手掷置虚空中。下复接之。以口吹散。令如微尘。散复还合。与本无异。时诸力士。而问佛言。如是之事。为是何力。世尊答言。以足拇指。举着掌中。是我父母生身之力。后以手掷置虚空中者。亦是父母生身之力。以口吹散。令如微尘。是神足力。散复还合。如本无异者。是解脱力。时诸力士。复更问佛。颇更有力胜于世尊如是力不。佛答言有。谓无常力。佛告力士。若是父母所生之力。及神足解脱力。今日中夜。当为无常力之所破坏。尔时力士。闻说是事。心生厌离。佛为说法。得见真谛。是故为欲引致应化众生故。修集此力。问曰。菩萨何时具满此力耶。答曰。菩萨年二十五时。具满此力。从是以后至年五十。其力无减。过是已后。其力转减。复有说者。其力无减。所以者何。意力无减故。身力亦尔。评曰应作是说。法身无减。生身有减。以是报故。如优陀耶言。今见世尊。身色损减。乃至广说。问曰。余众生。有那罗延力不耶。答曰。如初所说菩萨力。余众生尚无。何况余说。然世界初成时。世界众生。有那罗延力者。有半那罗延力者。有钵建陀力者。有大力者。满阎浮提。问曰。彼诸人骨节相次云何。答曰。除彼四种人。其余众生。骨节相远。若人力与象马等者。骨节相近。大力者。骨相接。钵建陀力者。骨节相钩。那罗延力者。骨节连琐。菩萨骨节。蛟龙相结。如渴伽角辟支佛。名曰大力。问曰。转轮王。为有那罗延力无耶。答曰转轮王。无那罗延力。随轮宝德身力及余宝亦然。若其轮是金王四天下。其力最胜。若其轮是银王三天下。其力转减。若其轮是铜王二天下。其力复减。若其轮是铁王一天下。其力最劣。佛在世时。三人有钵建陀力。一是尊者阿难。二是睒弥释子。三是瞿毗迦释女。问曰。辟支佛出世。为如佛独出为有俱者耶。答曰。或有说者。独出无俱所以者何辟支佛根胜舍利弗。如舍利弗。并出于世。犹无是事。何况五百功德者一时俱出。问曰。若辟支佛不并出世。言有五百功德一时出世者为是何人耶。答曰。此皆本是声闻。以缘悟菩提故。名辟支佛。若本种辟支佛。行成辟支佛者。独出世间。当知如佛

已说如来身力。今当说意力。如来有十力。所谓是处非处智力。乃至漏尽智力。问曰力体性是何。答曰体性是智体是智身。已说体性今当说所以。何等是力义。答曰不为他所伏义是力义。不为他所覆盖义是力义。不断伏义是力义。害义决定知义能担义最胜义是力义。界者宿命智力。生死智力。在色界余力。若是有漏是三界系。若无漏者是不系。地者宿命智力。生死智力。在根本四禅地余力。有漏者在十一地无漏者在九地。依者依欲界身。行者是处非处智力。至一切道智力行十六行。亦行非行。知业法集智力。行八行。亦行非行。第三第四第五第六智力。行十二行。亦行非行。宿命智力。生死智力。行于非行。漏尽智力。若以境界。行于四行。若以在身。则行十六行。亦行非行。缘境界者。是处非处智力。缘一切法。知业法集智力。缘苦集谛。第三第四第五第六智力。缘于三谛。除灭谛。至一切道智力。缘于四谛。宿命智力。缘于前世欲色界五阴。生死智力。缘于色入。漏尽智力。若以境界。缘于灭谛。若以在身。缘一切法。念处者。知欲智力。宿命智力。是法念处。生死智力。是身念处。漏尽智力。若以境界。是法念处。若以在身。是四念处。余力是四念处。智者。是处非处智力。至一切道智力是十智。知业法集智力是八智。除灭智道智。第三第四第五第六智力是九智。除灭智宿命智力。如旧阿毗昙人说。是等智尊者婆已说。是四智。法智。比智。苦智。等智。尊者瞿沙说。是六智。除尽智无生智灭智他心智。评曰应如前说。一等智者。好生死智力。旧阿毗昙人说。是一等智。尊者婆已说。是四智。法智。比智。集智。等智真实义者。是一等智漏尽智力。若以境界是六智。除他心智苦智集智道智。若以在身。则有十智。所以者何。此十智于如来身中尽可得故。根者总而言之。则与三根相应。过去未来现在者。是三世法。缘过去未来现在世者。是处非处智力至一切道智力。缘于三世。亦缘非世。第二第三第四第五第六智力。缘于三世。宿命智力过去现在者。缘过去世未来世。当生者缘过去世若不生者。缘于三世。生死智力过去者。缘过去世。现在者。缘现在世。未来当生者。缘未来世不生者。缘于三世。漏尽智力。若以境界。缘非世法。若以在身。缘于三世。亦缘非世。善不善无记者。是善缘善。不善无记者。知禅解脱三摩提智力。缘善无记。漏尽智力。若以境界缘善。若以在身缘善不善无记。余力缘三种。系者。宿命智力。生死智力。色界系余力。有漏者三界系。无漏是不系。缘三界系者。宿命智力。生死智力。缘欲色界系。知业法集智力。缘三界系。漏尽智力。若以境界。缘不系。若以在身。缘三界系及不系。余力缘三界系。缘不系。是学无学非学非无学者。宿命智力。生死智力。是非学非无学。余力若是无漏是无学。若是有漏是非学非无学。缘学无学非学非无学者。知业法集智力。宿命智力。生死智力。缘非学非无学。漏尽智力。若以境界。缘非学非无学。若以在身。能缘三种。余力三种尽缘。见道断修道断不断者。宿命智力。生死智力。是修道断。余力若有漏。是修道断。若无漏。是不断。缘见道断修道断不断者。知业法集智力。宿命智力。缘见道断修道断。生死智力。缘修道断。漏尽智力。若以境界。缘不断。若以在身。缘于三种。余力三种尽缘。缘名缘义者。知欲智力。生死智力。缘义漏尽智力。若以境界缘义。若以在身。则缘名义。余力亦缘名亦缘义。缘自身他身非身者。是处非处智力。至一切道智力。缘自身他身。亦缘非身法。漏尽智力。若以境界。缘于非身。若以在身。三种尽缘。余力缘自身他身。问曰。此诸力。为从方便生。为从离欲得耶。答曰。可言从方便生亦从离欲得。所以者何。以从三阿僧祇劫积集方便生故。言从方便生。以从离非想非非想处欲得故。言从离欲得。问曰。何处生此力。答曰。依欲界身。生阎浮提非余方。依男子身非女身。问曰。知业法集智力。生死智力。有何差别。答曰。从粗至细是生死智力。从细至粗是知业法集智力。如粗细现见不现见因果。当知亦如是。已说力无畏。今当说三藐三佛陀有四无所畏。乃至广说。问曰。无畏体性是何。答曰。体性是慧身。初力是初无畏。第十力是第二无畏。第二力是第三无畏。第七力是第四无畏。一一力摄四无畏。一一无畏摄十力。则有四十力四十无畏。佛略说故。我成就十力四无所畏。广说则成就四十力四十无畏。已说体性。所以今当说。何等是无畏义。答曰。不可动义是无畏义。勇猛义是无畏义。不怯弱义是无畏义。安隐义清净义纯白义是无畏义

问曰。力即是无畏。为异无畏耶。答曰诸力即是诸无畏。如先所说。初力即初无畏。乃至广说。问曰。若然者力与无畏。有何差别。答曰。无有差别。如说无畏即力力即无畏。复有说者。名即差别。所以者何是名为力是名无畏。复有说者。初立是力。已立不动是无畏。复次有坚强是力。勇决是无畏。复次不为他所伏是力。不怯弱是无畏。复次智是力。办是无畏。复次因是力。果是无畏。复次不为他所盖是力。能盖他是无畏。复次自饶益是力。饶益他是无畏。自利利他亦尔。复次自觉是力。为他说是无畏。积集是力。受用是无畏。受财义是力。分财义是无畏。复次知医方是力。治他病是无畏。复次法义无碍是力。辞乐说无碍是无畏。复次赞求法义无碍是力。赞求辞乐说无碍是无畏。诸余分别如力中说

如来有大悲。问曰。大悲体性是何。答曰。是慧。复有说者是照。评曰不应作是说。如前说者好。大悲当知即是是处非处力。地者是第四禅地。其余分别。应随相说。问曰此中何以唯说力无畏大悲。不说三念处耶。答曰是三种于说法分中。胜三念处不尔。说力则显现自义。说无畏则现摧伏他义。大悲则生欲说法心。三念处不尔。是故不说

如来亦说成就七法。彼七法者。当知即是是处非处力。如来若更有余不共法者。当知尽是是处非处力。问曰。此七为是几智性耶。答曰知法知量知众。此是一等智。知义者诸作是说。涅槃是第一义者。是六智性。除苦集智他心智道智。诸作是说。一切法是第一义者。是十智性。知时知人。是九智性。除灭智。自知是八知性。除灭智他心智。尊者婆已说曰。自知是四智性。谓法智比智道智等智。评曰如此诸所说。可有是理。但彼经所说七法义。是一等智。如来有五圣智三昧。此亦是是处非处力。五智者。法智比智道智尽智无生智

阿毗昙毗婆沙论卷第十六阿毗昙毗婆沙论卷第十七

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    杂揵度爱敬品中

云何数灭。云何非数灭。乃至广说。问曰。何故作此论。答曰。为止并义者意。如譬喻者说。三种灭无体。为止如是说者意。欲明三种灭各有体相故而作此论。复次所以作此论者。毗婆阇婆提说。三种灭皆是无为。欲止如是说者意。说三种灭。二是无为。一是有为故而作此论

云何数灭。答曰。若灭得解脱是也。彼法灭。彼得得解脱。得解脱得。是名数灭。云何非数灭。答曰。若灭非解脱是也。彼法若灭。彼得不得解脱。不得解脱得。是名非数灭。云何无常灭。答曰。诸行散灭是也。无常灭。散灭诸行。非如散豆谷等。无常灭。令诸行于前一刹那能有所作。于后刹那。更不能有所作。非无行体。止其所作故。作如是说。问曰。非数灭无常灭。有何差别。答曰。非数灭者。疾瘦困厄自作他作苦恼种种魔事。如是随世等法。若得解脱。是名非数灭。若说疾瘦困厄自作他作苦恼种种魔事等法。若得解脱。是名有漏诸行得非数灭。若说随世等法。若得解脱。是名无漏诸行得非数灭。所以者何无漏诸行。亦在世故。无常灭者。令诸行散灭。乃至广说。问曰。何故但问非数灭无常灭。不问数灭耶。答曰。或有说者。彼作经者意欲尔。乃至广说。复有说者。先已说差别。如说云何数灭。其灭者是解脱。乃至广说。二灭者非解脱。是以问其差别。复有说者以此二灭俱不用功灭故。复有说者尽应问三种灭差别。云何数灭。答曰。若灭是解脱不系相。非数灭者。是解脱非不系相。无常灭。非是解脱。亦非不系相。复有说者。数灭三世阴入界中可得。非数灭未来世不生法中可得。无常灭现在世中可得。复有说者。数灭是善。彼得亦善。非数灭是无记。彼得亦是无记。无常灭有三种。彼得亦有三种。复有说者。数灭是不系。彼得是系不系。非数灭是不系。彼得是系。无常是系不系。彼得亦是系不系。复有说者。数灭是非学非无学。彼得是学无学非学非无学。非数灭是非学非无学。彼得亦是非学非无学。无常灭三种。彼得亦三种。复有说者。数灭是不断。彼得或修道断。或不断。非数灭是不断。彼得是修道断。无常灭三种。彼得亦三种。复有说者。数灭是道果。彼得或是道是道果。或非道非道果。非数灭非道果。彼得非道非道果。无常灭或是道非道果。或是道亦道果。或非道非道果。彼得亦尔。复有说者。数灭是灭谛所摄。彼得是三谛所摄。非数灭非灭谛所摄。彼得苦集谛所摄。无常灭三种谛所摄。得亦尔

问曰。何等是数灭义。答曰。数者是慧。灭是慧果。故名数灭。复有说者。别数得故。言是数灭。如见苦时苦忍苦智所得别。见集见灭见道所得亦别。故名数灭。复有说者。以难得多用功故。名为数灭。问曰。此灭为是一体。为是多体耶。答曰。或有说者。是一体。问曰。若是一体者。证见道所断诸结灭时。亦证修道所断。诸结灭不耶。若证者则修道无用。若不证者。云何一体法。少分证少分不证。复有说者。灭体有五见苦所断烦恼灭。是一种。乃至修道所断烦恼灭。是第五种。问曰。此亦有过。所以者何。如证欲界修道所断上上使灭时。复证余品使灭不耶。若当证者。余品对治道。则无功用。若不证者。云何一体法。少分证少分不证。复有说者。灭体有十三。见道所断有四。修道所断有九。问曰。此亦有过。所以者何。若证欲界修道所断灭时。复证初禅修道所断灭不。若证不证。俱同前过。评曰。应作是说。随有漏法体灭体亦尔。问曰。若然者。先何故问涅槃为一体为多体耶。答曰。先应作是问。若一众生。证一法灭时。一切众生。亦同证此灭不耶。若同者。云何涅槃不是共法。一众生得涅槃时。一切众生。亦应得涅槃。若异者。云何涅槃非是相似法耶。此经复云何通。如说如来解脱。阿罗汉解脱等。无差别。答曰。应作是说。如一众生证此法。一切众生亦同证此法。问曰。若然者。云何涅槃不是共法耶。答曰。以体言之则同。以得言之则异。所以者何。以诸得各异故。问曰。若然者。云何不一众生得涅槃时。一切众生亦得涅槃耶。答曰。若成就涅槃得者得涅槃。若不成就得者。不得涅槃。复有说者若一众生。证此灭时。余众生所证者各异。问曰。若然者。云何涅槃非是相似法。答曰。言非相似者。非相似因。以涅槃无相似因故。言非相似法。问曰。若然者。苦法忍无相似因。亦是非相似法耶。答曰。苦法忍虽不从相似因生。而能与他作相似因。涅槃不从相似因生。亦不与他作相似因。复有说者。以不同故。言不相似。有为法性同。云何性同。同在世。同是阴。同是苦。无有一法是常是善者。复有说者。世法是同。彼非世故不同。如是阴法苦法诸生法诸趣法。当知亦尔。复有说者。前后是相似。彼法无前后。故言不相似。如前后。上中下法亦如是。如来解脱。罗汉解脱。此经云何通者。以俱是常是善故。复有说者。以在一身中决定俱有故。所以者何。一切众生尽有三种菩提性。所谓佛辟支佛声闻菩提。若从佛道去。亦证此法。若从辟支佛声闻道去。亦证此法。是故言无差别。评曰。不应作是说。如前说者好

问曰。外物中数灭为有得者不耶。若得者众生不成就外法云何得。若得者此经复云何通。如说诸长老。我断一切爱。得内解脱。若不得者此经复云何通。如说云何断界。答曰。一切诸行断。是名断界。乃至广说。答曰。应作是说有得者。问曰。若然者不成就外法。云何得耶。答曰。虽不成就外法。而得外法数灭。如过去未来命等八根。虽不成就。得其数灭。我断一切爱。得内解脱。此经云何通者。此说若内得解脱。当知外法亦得解脱。复有说者。以此解脱从自身修方便得。不由外人修方便得。是故言得内解脱。复有说者。不得外法中数灭。问曰。若然者此经云何通。如说一切诸行。断名断界。乃至广说。答曰。有二种一切。有分。一切。有一切一切。此中说分一切。故言一切。复有说者。外物中有数灭。而不可得。评曰。不应作是说。宁当说无。不应说有而不可得。何用是无。用物为亦有亦得。如是说者好。若当外物数灭不可得者。则违波伽罗那经。如说云何得作证法。答言。一切善法。此法是善。亦得可得证。欲令无如是过故。说言可得

问曰。此数灭体。为是阴为非阴耶。若是阴者。何不本是涅槃。何以故。先有诸阴故。若非阴者。云何为无所有法。而修于道。答曰。应作是说。体非是阴亦非阴。然从色阴乃至识阴体得之。此数灭亦名涅槃亦名不相似。亦名非品亦名无跋那(跋那秦言色亦言性亦言称赞亦言字)。亦言最胜亦名智。亦名应亦名不亲近。亦名不修亦名可乐。亦名近亦名妙亦名离。问曰。何故言涅槃。答曰。槃那言林。涅者言离。永离阴林离三火林离四林。故言涅槃。复次不织义是涅槃。如先说。何故名不相似者。无相似因故。如先说。无上中下等故。何故名非品者。离诸品故。如说有为法体性是品。诸作是说。有住相者。四相及彼法五法。是俱生品。诸作是说。无住相者。三相及彼法四法。是俱生品。彼法无如是相故。名为非品。复有说者。世是品法。彼法离世。名为非品。诸阴诸苦诸生诸趣说亦如是。何故名无跋那者。称赞之体。已自成故。不待复更称赞。如人本性贤善。不待称赞。本贤善故。彼亦如是。复次有为法中。或以因称果。或以果称因。彼法无果可以称因。无因可以称果。复次诸圣亲证此法故。不待称赞。复次不称赞者。有无边称故。如人大德言。此人德不可说。彼亦如是。复次不可称赞者。周匝有美称故。如净明珠周匝除闇。彼亦如是。亦如阿波那加珠所在之处。而便安立。如是若解脱得。在人身中。此身名为安立。复次不可称赞者。名为非称。无有人能如法说其过者。名为非称。复有说者。离诸性故。言无跋那。此中无刹利婆罗门居士首陀性故。言无跋那。亦无青黄等色故。言无跋那。有为法。或性是色。或依色。或为色作所依。彼法性。非是色。亦非依色。亦不为色作所依。何故名最胜者。以上妙故名最胜。如世间以上妙饮食衣服缨络等故名最胜。尊者瞿沙说曰。彼法是最胜。以是通畅究竟法故。何故名智者。以智果故。如经中说。六入是业。六入是业果。以业名说。如断是智果以智名说。如天眼天耳是通果以通名说。彼亦如是。是智果故。以智名说。何故名应者。应受供养故名应。世界所有上供。尽应受故。何故名不亲近者。以无可亲近故。有为法以贪其果。而亲近之。如人为贪荫凉花果故亲近于树。彼法与上相违故。名不亲近。问曰。若说不亲近者。何以故。经中说亲近明人耶。答曰。以得智故。明人者佛若佛弟子。以亲近故。得所缘忍智及成就得。是故说亲近。复有说者。明人所依去故说亲近。如说阿罗汉去至涅槃何故名不修者。以不在身中。若法住在身中者。修彼法。不在身中。是故不修。复有说者。以无可修法故。如阿毗昙所说。修法彼中无故。名曰不修。复有说者。以无可亲近事故。所以不修。问曰。若不修者此偈云何通。如偈说

  瞿昙坐树下　　禅思不放逸
  不久履道迹　　涅槃在心中

答曰。如尊者波奢所说言。涅槃在心中者。心中成就涅槃得故。何故名可乐者。以离一切苦故。圣人畏苦涅槃。无身心苦故。圣人乐之。如苦恶戒生死增长老死。说亦如是。世尊经说时。解脱是乐法。无漏戒是乐戒者。以能到涅槃故。何故名近者。以是有法故。或有说是非有法。而彼法实有体性。是故说近。以是事故。世尊经说。行者精进成就十五法。是名学迹。得近涅槃。复次不选择身故名近。若刹利修道。即证婆罗门毗舍首陀修道亦证。复次不选择处所故名近。若于村落。若于静处。修道即得。复次以是近观故名近。诸圣起缘。彼忍智现在前。正观此法。如在目前。复次以比相故知近。如波伽罗那经所说。云何远法。谓过去未来法。云何近法。谓现在前。及无为法。复次住近处得故名处近。近处者谓现在世现在世证故名近。复次舍近法得故名近。近法名现在。圣人舍现在。法入涅槃故名近。尊者瞿沙说曰。精勤次第趣向。修正方便者得故名近。复次圣道所依身定故。此法不尔名近。若依此身。应起圣道。余身不能。涅槃不尔。随修道所依身则能证。是名为近。问曰。何故名妙耶。如道亦是妙。何以独称涅槃为妙。波伽罗那所说。云何妙法。无漏善法是也。答曰。道虽是妙。涅槃是妙中妙。复次道虽是妙。杂无常过故。涅槃不尔。复次道有对治厌恶善根故。如空空三昧无相无相三昧无愿无愿三昧。无有善法能厌恶涅槃者故名为妙。问曰。涅槃何故名离耶。如道亦是离相。如波伽罗那所说。云何离法。答言。欲界系。或色无色界系。出要寂静善定学法无学法。数灭等法是也。答曰。涅槃唯是离道是离是可离。复次舍一切法故言离。有漏法有二种舍。一者离欲舍。二者弃舍。无漏有为法。虽无离欲舍。而有弃舍。涅槃无离欲舍。亦无弃舍。复次第一义是离。以色故离欲。以无色故离色。诸有所作。诸有所思。以涅槃故离

云何非数灭。答曰。是灭非解脱。问曰。何故名非数灭。答曰。不以功作而得。是名非数灭。所以者何。如人住此四方所有色声香味触。是五识身所缘法。不以功作而住。不生法中。故非数灭。问曰。以何法能得此法耶。答曰。或有说者。以过去未来阴入界。非现在世。所以者何。以阴入界现在身中可得故。如此说者。一一刹那中。有失有得。刹那生时失。刹那灭时得。复有说者。未来世中得非过去。所以者何。过去诸阴。曾在身中。今日阴即在身故。此说亦有过。所以者何。未来法生时。此法亦舍故。评曰。于未来不生法中得。如是说者好。以是故。一切时常增益。问曰。数灭多。非数灭多耶。答曰。或有说者。数灭多。非数灭少。所以者何。数灭于过去未来现在法中得。非数灭唯未来不生法中得故。复有说者。非数灭多。数灭少。所以者何。非数灭有漏无漏法中得。数灭唯有漏法中得故。评曰。应作是说。此二法俱无量无边。以是事故应作四句。有法是数灭所得非非数灭所得。有法非数灭所得非是数灭所得。有法亦数灭所得亦非数灭所得。有法非数灭所得亦非非数灭所得。初句者过去现在有漏法。及未来世生者是也。第二句者未来世不生无漏法是也。第三句者谓未来世不生有漏法是。第四句者谓过去现在无漏法。未来世必生无漏法是也

如住此凡夫人得五道中五识非数灭。所以者何。彼中所有色声香味触。缘彼识住。在不生法中故。是以得彼非数灭。如此处色声香味触。彼五处众生。亦于此得非数灭。若恶道分已断者。彼尽得恶道中非数灭。问曰。谁能断恶道。答曰。或是布施。或是持戒。或是闻慧。或是思慧。如不净阿那般那念处。或是修慧。如暖法顶法至忍必断。尊者婆檀陀说曰。若不因觉知缘起法。则不断恶道。此说云何言觉知缘起法者。尽是无漏道。评曰。不应作是说。如是说者好。或以布施。或以持戒。得恶道非数灭。乃至以顶得恶道非数灭。自有众生。得如上善根恶道分断。钝根者。乃至忍断。问曰。为一时得三恶道非数灭。为次第得耶。答曰。或有说者。三种一时得。问曰。若尔者提婆达多生地狱中。岂非得饿鬼畜生非数灭耶。答曰。唯除地狱一生分。余地狱生分。及饿鬼畜生分一时得。评曰。若起达分善根。断恶道者。一切恶道。得非数灭。若施等断恶道。此则不定。若断地狱。则得地狱非数灭。余则不定。余趣亦如是。若以达分善根。断恶道者。彼恶道一时非数灭

已说得恶道非数灭。复云何得生处非数灭。答曰住增上忍时。除人天中七生分色无色界一切处一生分。其余诸生。皆得非数灭。须陀洹趣斯陀含果。住方便道不起。得斯陀含得欲界六生分非数灭。若起得者。住第六无碍道时得也。若斯陀含趣阿那含果。住方便道不起。得阿那含。得欲界一生分非数灭。最后无碍道。当得欲界一切生分数灭。若起得者。最后无碍道得。欲界一生分非数灭。当得欲界一切生分数灭。离初禅欲时。若是不退法。住方便道不起者。得初禅二分二生分非数灭。最后无碍道。当得初禅一切生分数灭。若起者最后无碍道。得二生分非数灭。当得一切生分数灭。若是退法。若起若不起。最后无碍道。当得初禅地一切生分数灭。不得非数灭。乃至离无所有处欲。说亦如是。若离非想非非想处欲。若是不退。住方便道不起者。得非想非非想处一生分非数灭。最后无碍道。当得非想非非想处一切。生分数灭。若起者最后无碍道。得非想非非想处一生分非数灭。当得一切生分数灭。若是退法不起离欲者。住方便道。得八地余生分非数灭。最后无碍道当得非想非非想处一切生分数灭。若起者最后无碍道。得八地中余生分非数灭。当得非想非非想处一切生分数灭

已说生处。诸烦恼复云何。答曰。住增上忍时。得三界见道所断烦恼非数灭。随无碍道随种当得数灭。若是圣人。是不退法。是不起离欲界欲随所断种。住方便道。得非数灭。随无碍道随种。当得数灭。若起者。随无碍道随种。得非数灭。当得数灭。若是退法。若起若不起。随无碍道随种。不得非数灭。当得数灭乃至离非想非非想处欲。说亦如是。问曰。退法者于诸烦恼。何时得非数灭。答曰。或有说者。若信解脱转根得见到时。解脱转根得不动。评曰。应作是说。若得决定更不退。尔时得诸烦恼非数灭。以是事故。而作四句。或有烦恼先得非数灭。后得数灭。先得数灭后得非数灭。或有俱得。或有俱不得。初句者住增上忍。于三界见道所断烦恼。是不退法。不起离欲。住方便道修道所断烦恼。是谓先得非数灭后得数灭。第二句者若是退法。三界修道所断烦恼。是谓先得数灭后得非数灭。第三句者若是不退法起离欲随无碍道随种。得非数灭。得数灭。复有离欲界欲。断上上烦恼时。染污五识身。于所缘得非数灭。得数灭。乃至离八种欲亦如是。若断下下烦恼时。彼下下染污五识身。于所缘得非数灭。得数灭。亦得欲界善不隐没无记行数灭。离初禅欲。断上上烦恼。彼上上染污三识身。于所缘得非数灭。得数灭。离八种欲亦如是。若断下下烦恼时。彼初禅下下染污三识身。于所缘得非数灭。得数灭。亦得初禅地善不隐没无记行数灭。是谓俱得。第四句者除上尔所事

已说烦恼道复云何。答曰。坚信人行坚信道时。于坚法道。得非数灭。坚法人行坚法道时。于坚信道。得非数灭。见到人行见到道时。于信解脱道。得非数灭。非时解脱人。行非时解脱道时。于时解脱道。得非数灭。声闻人于声。闻道决定者。于辟支佛道佛道得非数灭。辟支佛人。于辟支佛道决定者。于佛道声闻道。得非数灭。求佛道者。于佛道决定时。于声闻辟支佛道。得非数灭。阿罗汉有六种。一退法。二思法。三护法。四等住。五能胜进。六不动。问曰。此诸阿罗汉于何时得非数灭耶。答曰。若退法者。于退法决定者。于五种得非数灭。若不决定者不得。乃至能胜进说亦如是。不动法者。得不动法。于五种道。得非数灭。问曰。非数灭。皆是胜进时得。何以不是道果耶。答曰。本离欲时。不为此法作方便得故。若当为非数灭作方便者。非数灭则不可得。所以者何。若心贪着。有是人不能过三恶道。若心为涅槃能过恶道

问曰。非数灭得。是何心果。答曰。或有说者。是造受生处心果。复有说者。若心能使生相续。是彼心功用果。评曰。应作是说。随住何心得非数灭。即彼心果。问曰。于何法得非数灭。答曰。于三界系及不系法中得。生欲界于此四法中得。生色无色界亦如是。非数灭得。随生何地。即彼地系

问曰。非数灭。于何法得增长耶。答曰。生欲界中。于欲界系五识身。而得增长。亦有缘现在欲界意识身而得增长。然微细难现。于色界三识无量解脱胜处一切处。而得增长。无色界唯一切处。生色界中。欲界五识身。而得增长。意识亦得增长。然微细难现。色界三识无量解脱胜处一切处。而得增长。无色界唯一切处。生色界中。于欲界五识色界三识无量解脱胜处一切处。而得增长

问曰。圣人生色界中。于欲界系。何法中得非数灭耶。答曰。初禅命终。生二禅中。初禅果。欲界变化心。得非数灭。若生三禅中。初禅二禅果。欲界变化心。得非数灭。若生第四禅中。初禅二禅三禅果。欲界变化心。得非数灭。乃至第三禅命终。生第四禅中。第三禅果。欲界变化心。得非数灭。问曰。色界命终。生无色界中。于欲界系何法中。得非数灭耶。答曰。若初禅命终。生无色中。四禅果。欲界变化心。得非数灭。第二禅命终。生无色中。三禅果。欲界变化心。得非数灭。第三禅命终。生无色中。二禅果。欲界变化心。得非数灭。第四禅命终。生无色中。一禅果。欲界变化心。得非数灭。圣人生无色界中。于欲色界系法。不得非数灭。所以者何。先已得故

问曰。先入涅槃阿罗汉。得非数灭多。后入涅槃阿罗汉。得非数灭多耶。答曰。前入涅槃者多。迦叶佛时。入涅槃者则多。释迦牟尼佛时入涅槃者。释迦牟尼佛时。入涅槃者则多。弥勒佛时入涅槃者。问曰。何等阿罗汉。成就非数灭最多。答曰。生无色界阿罗汉。住最后心者。于一切法。得非数灭多。颇有阴界入永灭而不得非数灭耶。答曰有。谓阿罗汉住最后心。评曰。不应作是说。所以者何。无有阴界入永灭而不得非数灭者。问曰。阿罗汉住最后心时。非是不得非数灭耶。答曰。非不得。所以者何。阿罗汉。若决定欲入涅槃时。尔时除。若五心六心。当起现在前。余阴界入悉得非数灭

世尊说。有二涅槃界。谓有余身涅槃界。无余身涅槃界。乃至广说。问曰。何故作此论。答曰上说。云何数灭。答曰。若灭是解脱。彼数灭有二种。一是有余身涅槃界。二是无余身涅槃界。未说云何有余身涅槃界无余身涅槃界。今欲说故而作此论。复有说有余身涅槃界有体。无余身涅槃界无体。复有说有余身涅槃界是善。无余身涅槃界是无记。复有说有余身涅槃界是道果。无余身涅槃界非道果。复有说有余身涅槃界是谛所摄。无余身涅槃界非谛所摄。复有说有余身涅槃界是有为。无余身涅槃界是无为。有漏无漏亦如是。为止如是说者意欲明此义俱是无漏。以是事故。为止他义欲显己义。乃至广说而作此论。云何有余身涅槃界。答曰。阿罗汉住寿。四大未灭。乃至广说。四大者即四大是也。诸根者造色是也。相续心者是心心数法也。若此四大造色。心心数法未灭。是有余身涅槃界。复有说者。四大是四大身。诸根即诸根。相续心是觉性。若身诸根。觉性未灭。是有余身涅槃界。如是等诸有余故。名有余身涅槃界。身有二种。一烦恼身。二生身。虽无烦恼身。而有生身。复有说者。身有二种。有染污不染污。染污已尽唯有不染污。是故说四大等。有余故言有余。四大为生何法。谓生造色。依造色能生心心数法。乃至广说。彼断一切结得作证。是名有余身涅槃界。云何无余身涅槃界。若阿罗汉。已入涅槃四大灭。乃至广说。四大者即四大。诸根者是造色。相续心者是心心数法。若此四大诸根心心数法灭。是名无余身涅槃界。复有说者。四大身。诸根即诸根。相续心是觉性。若身诸根觉性灭。是名无余身涅槃界。问曰。此文不应作是说。身诸根觉性灭。名无余身涅槃界。应作是说。阿罗汉断一切结尽入于涅槃。是名无余身涅槃界。而不说者有何意耶。答曰。彼尊者依世俗言。说信经故而作是说。阿罗汉死时。风大能损火大。火大损故饮食不消。饮食不消故四大羸。四大羸故诸根亦劣。诸根劣故不能与心心数法作所依。心心数法无所依故则不生心心数法不生便是无余身涅槃界。身有二种。一者生身。二烦恼身。彼二种身俱灭是名无余身涅槃界。复有说者。身有二种。谓染污不染污。二种身俱灭一切结使断。是名无余身涅槃界。问曰。此中何以不说断一切结得作证耶。答曰。以现在得作证故。言得作证。彼时现在得灭故。不言得作证。复有说者。有众生处有得谁得此得言是提婆达多延若达多。彼中无如是众生差别故。唯此法性。是故不说得作证等

问曰。凡夫人学人断。为是有余身涅槃界。为是无余身涅槃界耶。答曰。亦不名有余身涅槃界。亦不名无余身涅槃界。但名为断。亦名无。亦名为灭。亦名为谛少分。是断智少分。非断智少分。是沙门果少分。非沙门果

问曰。颇有阿罗汉不住有余身涅槃界不住无余身涅槃界耶。答曰。如经本所说有。如说。具三事者。名有余身涅槃界。无三事者。名无余身涅槃界。生色界阿罗汉。入灭尽定。唯有四大诸根。无相续心。生无色界阿罗汉。唯有相续心。无诸根四大。生欲界阿罗汉。唯有四大相续心。有诸根不具者。评曰。如是诸阿罗汉。皆当言住有余身涅槃界。经文应如是说。云何住有余身涅槃界。答曰。阿罗汉住寿。一切结尽得作证。云何无余身涅槃界。答曰。阿罗汉一切结尽入涅槃。若作是说。尽摄生欲界生色无色界有心无心具根不具根者

涅槃当言学耶。乃至广说。问曰。何故作此论。答曰。先说数灭是二种涅槃界。乃至广说。未说是学无学非学非无学。今欲说故。而作此论。复次何故作此论者。为止并义者意故。如犊子部说涅槃有三种。是学无学非学非无学。若学断诸结得作证。是名学。若无学断诸结得作证。是名无学。若非学非无学断诸结得作证。是名非学非无学。为止如是说者意欲显己义故。而作此论

涅槃当言学无学非学非无学耶。答曰。涅槃当言非学非无学。复有说者。涅槃是学无学非学非无学者。此是犊子部所说。所以者何。彼说涅槃有三种性。若学断诸结得作证是名学也。无学非学非无学。说亦如是。作如是说者则有大过。云何一解脱体为三。得所得便有三性。如我义者。如此文。如此义。如此论。如我等意。涅槃是非学非无学。此是尊者迦旃延子。欲显己义经本应齐作是说。不应作余说。所以者何。若作余说。育多婆提所说有过。复有说者。应作余说。所以者何。毗婆阇婆提。问育多婆提。如是汝说涅槃是非学非无学耶。此是问亦是定言。所以者何。若不定他言说。说他过者。是则不可。育多婆提答言。如是。毗婆阇婆提。复作是难。于意云何。若先以世俗道断结作证。乃至广说。得阿那含果。彼是学耶。育多婆提答言。不也。所以者何。我说涅槃是非学非无学。育多婆提欲说毗婆阇婆提过。若当先以世俗道断结得作证。乃至广说。乃至得阿那含果彼是学者。本应是学。若不得果而是学者。此事不可。趣阿罗汉断结作证。阿罗汉断结作证退。说亦如是。育多婆提。于他法中。不顺义者。集置一处。而说其过。若当涅槃是非学非无学。复作学学作无学无学作学者。是则不定。若不定者。则是无常。若无常者。有为无为。无有差别。所以者何。涅槃未曾作非学非无学复作学学作无学无学作学。以是故。涅槃于一切时。是常是寂灭。是非学非无学。广说如经本。复有说者。育多婆提。欲说毗婆阇婆提过。毗婆阇婆提。有二种过。一说涅槃是非学非无学复作学。学作无学无学作学。二说涅槃是非学非无学者常是非学非无学。学常是学。无学常是无学。育多婆提。难毗婆阇婆提言。涅槃是非学非无学复作学。学作无学。无学作学者。如是汝说涅槃是非学非无学。然后作学耶。毗婆阇婆提答言。如是。育多婆提。复难毗婆阇婆提言。于意云何。若先以世俗道。乃至广说。后见四圣谛。得阿那含果。彼是学耶。毗婆阇婆提答言。如是。所以者何。我说涅槃是非学非无学复作学故。育多婆提复问毗婆阇婆提言。汝意云何。先以世俗道。断结得作证。是非学非无学。即彼非学非无学作学耶。毗婆阇婆提答言。如是。所以者何。我说非学非无学后作学故。育多婆提。复说毗婆阇婆提过。若先以世俗道。断结得作证。后得阿那含果。当是学者。本应是学。若不得果。而是学者。是则不可。育多婆提。复难毗婆阇婆提言。趣阿罗汉。断结得作证。是学后作。无学阿罗汉。断结得作证。退作学。说亦如是。育多婆提。于他法中。不顺义者。集置一处。说过如上。若说涅槃是非学非无学常是非学非无学乃至无学常是无学者。育多婆提。难毗婆阇婆提言。汝说涅槃有三种耶。答曰。如是。育多婆提。难毗婆阇婆提言。于意云何。若先以世俗道。断欲爱恚。未见真谛。欲得见故。勤修方便。修方便时。得见真谛。得阿那含。彼是学耶。答曰。如是。所以者何。我说涅槃有三种故。育多婆提。难毗婆阇婆提言。于意云何。若先以世俗道。断结作证。是非学非无学。后得阿那含果。即是学耶。答言。不也。所以者何。我说涅槃是非学非无学常是非学非无学。乃至广说。毗婆阇婆提。反难育多婆提。若当涅槃是非学非无学。后作学者。未得阿那含果时。本应是学。育多婆提。欲去此过故。若不得阿那含果。而是学者。此则不可。育多婆提。复难毗婆阇婆提。若趣阿罗汉果。断结作证。阿罗汉断结作证退。说亦如是。育多婆提。于他法中。不顺义者。集置一处。而说其过。若当涅槃是非学非无学后作学学作无学无学作学非学非无学常是非学非无学乃至无学常是无学者。是则不定。若不定者。则是无常。若无常者。有为无为。无有差别。涅槃未曾作非学非无学后作学学作无学无学作学非学非无学常是非学非无学乃至无学常是无学。以是事故。涅槃于一切时。是常是寂灭。非学非无学。广说如经本。问曰。所说得。复有得不耶。若当有者。得复有得。便为无穷。若无穷者。无成就此得者。答曰。应作此论。得复有得。问曰。若然者是则无穷。答曰。无穷有何过。未来世宽。能容此得。以生死法无穷故。得亦复然。是故难断难除难过。众苦相续。犹如连锁。复有说者。以俱在一世一刹那中故非无穷。评曰。应作是说。法生时。三法俱生。谓法得得得以得故成就彼法及得得以得得故成就得。是故非无穷。以是事故而作此论

颇有行阴色阴同于一得耶。答曰有。所谓色得得是也。乃至行阴识阴。说亦如是。有为无为。亦同一得。所以者何。无为得得无为及得得。是名有为无为同共一得。问曰。有成就过去未来得不。若成就者。云何非是无穷。所以者何。法生时。法得得得俱生。此三灭已。便生六得。三是得。三是得得。是六生十二。十二生二十四。乃至无量无边。若不成就者。定揵度又云何通耶。如说无色界命终。生欲界中。所得阴界入四大。善不善无记根结缚使缠烦恼。当言本得得本不得得。答曰。善染污。当言本得得报。当言本不得得。彼得亦有善。亦有染污。复有说者。有成就过去未来得者。问曰。若然者。云何非是无穷。答曰。假令无穷复有何过。未来世穷无容处耶。以生死是无穷故。难断难除难过。众苦相续。犹如连锁。复有说者。无有成就者。问曰。若然者。如说无色界命终生欲界。乃至广说。此文云何通耶。答曰。此文不说得。说得所不摄法。评曰。不应作是说。应作是说。有成就过去未来得者。所以者何。以得故。沙门果有差别。若不成就过去未来得者。一一刹那沙门果。亦得亦舍。修梵行者。则无休息心。复更有过。以三事故。舍于圣道。一退。二转根。三得果。不因此三。亦舍圣道。然无是处。是故有成就过去未来得者。苦法忍有十五得。一是苦法忍俱。二是苦法智俱。乃至道比忍俱有十五。乃至无学初智。除其自体。尽是因。广说如上。苦集谛得。苦集谛摄。灭谛得。三谛摄。道谛得。即道谛摄。苦集道谛三世摄。彼得亦三世摄。灭谛不在。三世得。三世摄。苦集谛。是善不善无记。彼得亦是善不善无记。灭道谛是善。彼得亦是善。苦集谛是三界系。彼得亦三界系。灭谛是不系。彼得是色无色界系。亦是不系道谛是不系。得亦是不系。苦集谛是非学非无学。彼得亦是非学非无学。灭谛是非学非无学。彼得是学无学非学非无学。道谛是学无学。彼得亦是学无学。苦集谛是见道修道断。彼得亦是见道修道断。灭谛是不断。彼得是修道断不断。道谛是不断。彼得亦是不断。欲界见道修道所断。乃至无所有处。见道修道所断解脱得有三种。学无学非学非无学。非想非非想处。见道所断修道所断八种解脱得有二种。学无学。第九种解脱得是无学。所以者何。彼得与尽智俱生故

问曰。欲界见道修道所断。乃至非想非非想处见道修道所断。彼解脱得几地所摄耶。答曰。或有说者。随其断对治道在何地。彼得亦尔。诸作是说。随其断对治道所在之地。彼得亦尔者。欲界见道修道所断解脱得。未至禅所摄。初禅解脱得。三地所摄。谓未至初禅中间禅。第二禅者。四地所摄。第三禅者。五地所摄。第四禅见道修道所断无色。见道所断者。是六地所摄。空处修道所断者。七地所摄。识处八地。无所有处。非想非非想处九地。复有说者随彼过患对治所在之地。彼得亦尔。诸作是说。彼随有过患对治所在之地。彼得亦尔者。欲色界见道修道所断解脱得。六地所摄。空处见道修道所断。七地识处。见道修道所断八地。无所有处。非想非非想处。见道修道所断九地复有说者。随地有法智分。彼地亦有欲界见道修道所断解脱得。若地有比智分。彼亦色无色界见道修道所断解脱得。诸作是说。随彼有法智分。彼地亦尔者。欲界见道修道所断解脱得。六地所摄。色无色界见道修道所断解脱得。九地所摄。评曰。不应作是说。如前说随地有断对治道。彼得亦尔者好

问若以灭道法智。离色无色界欲。彼色无色界修道所断解脱得。为是法智分。为是比智分耶。答曰。或有说。是法智分。所以者何以是法智所证故。评曰。不应作是说。是比智分

问曰。是法智所证。云何是比智分耶。答曰。虽是法智所证。而以比智所知。然皆是色无色界根本对治。随以何断。而皆是比智分

问曰。若离五种欲入见道者。苦法忍灭苦法智生。彼前所断欲界见苦所断五种欲。彼刹那中所断四种欲。彼九种尽是与苦法忍俱。生无漏得作证。如是乃至道法忍灭道法智生。彼前所断欲界见道所断五种欲。彼刹那中所断四种欲彼九种尽是与道法智俱生无漏得作证。若道比忍灭道比智生。是时得三界见道所断。与道比智俱生解脱得。彼得欲界修道所断五种欲。无漏解脱得不。尊者僧伽婆修答曰得。所以者何。以是须陀洹。亦是斯陀含向故。评曰。不应作是说。言不得者好。所以者何。不可说住果时复得趣果道。彼不得趣果道。为以何事言是趣果问曰。为以何时得彼解脱得耶。答曰。或有说者若修向斯陀含果方便是时便得。评曰。不应作是说言是时得解脱得。应作是说。若得斯陀含果是时便得

问曰。圣人以世俗道离欲。此道为是曾所得道。为是未曾得道耶。答曰。或有说者。是曾所得道。所以者何。如无始以来所用离欲道。今所用道。即是彼道。若以曾所得道。离欲界上上欲时。于离上上欲中。得二种解脱得。一是世俗以曾得者。二是无漏道未来修故。亦得欲界见道所断上上烦恼解脱无漏得。问曰。若作是说。是共对治。亦是不共对治。所以者何。以曾所得道。断见道修道所断烦恼。同在一处。如断草束。亦如刻契。断九种欲。是名共对治道。若圣人以此道断修道所断结时。是名不共。答曰。所曾得道。唯是共对治。所以者何。以见道所断结已断。若当不断。此亦能断。复有说者。圣人所用世俗道。是未曾得道。所以者何。无始以来所用道异。今所用道异。若作是说。以未曾得道。离欲界上上欲时。得二种解脱得。一是世俗。二是无漏。世俗者。以未曾得道故。无漏者。以未来修故。于欲界见道所断上上烦恼非对治。所以者何。以未曾得此道故。若作是说。则是不共对治。第九解脱道。若未曾得道。已曾得道。一时悉得。亦得欲界见道修道所断漏无漏二种解脱得。问曰。以何等故。第九解脱道。已曾得道。已未曾得道修。余无碍解脱道。何以不修耶。答曰。离欲得地时修异。断欲道时异。第九解脱道时。是离欲得地。是故以曾得道未曾得道修。断欲道时不得地。是故未曾得道修。曾得道不修以是事故。智揵度所说善通。如说。若成就现在他心智。亦成就过去未来耶。答曰。如是。评曰。如是说者好。以未曾得道离欲已曾得道未曾得道修。若作是说。以未曾得道离欲已曾得道未曾得道修者。离欲界修道所断上上欲时。得三种解脱得。一是世俗曾得道。二未曾得道。三无漏。于见道所断上上欲。得一解脱得。以曾得道故。以是义故。善去不共对治过。亦作过说

颇有不退不得果不转根。而于见道所断结。得作证耶。答曰有。如此所说者是也。如上上烦恼。乃至下下烦恼说亦如是。如离欲界欲。乃至离无所有处欲。说亦如是

问曰。颇一刹那顷。当得信等五根。得而不舍。舍而不得。乃至广作四句。答曰。有初句者。向阿那含果。住最后无碍道时。当得初禅地善有漏诸根是也。第二句者欲界悔忧俱根是也。第三句者无漏诸根。舍无碍道所摄。当得解脱道所摄。第四句者除上尔所事。问曰。诸得过去。彼法亦过去耶。若法过去。彼得过去耶。乃至广作四句。答曰。有初句者。数灭非数灭。得在过去。彼法非过去是也。第二句者。过去世非众生数法是也。第三句者。过去世众生数法是也。第四句者虚空未来现在非众生数法是也。未来现在亦应如是作四句

问曰。若法修彼法。得亦修耶。答曰。若法修彼法得亦修。颇法得修彼法不修耶。答曰。有数灭是

问曰。若法无得。彼法非不有解脱得耶。若无解脱得。彼法非不有得耶。乃至广作四句。答曰。有初句者。非众生数法。是谓无得非不有解脱得耶。第二句者有为无漏数灭非数灭。是谓无解脱得非不有得也。第三句者虚空。是谓非有得非有解脱得也。第四句者。众生数有漏法。是谓非不有得。非不有解脱得也。问曰。若法有得。彼法无解脱得耶。若法有解脱得。彼法无得耶。乃至广作四句。答曰。有初句者。有为无漏。及数灭非数灭是也。第二句非众生数法是也。第三句者众生数有漏法是也。第四句者虚空是也(此是句应在非句前)

阿毗昙毗婆沙论卷第十七阿毗昙毗婆沙论卷第十八

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    杂揵度爱敬品下

世尊说无学成就戒身。乃至广说。问曰。何故作此论。答曰。此是佛经。佛经中说无学成就戒身。虽作是说而不分别。佛经是此论根本。今欲广解佛经故而作此论。复次所以作论者。先说有余身涅槃界无余身涅槃界。涅槃当言学无学非学非无学。如此皆说无为阿罗汉果。今说有为阿罗汉果故而作此论。云何无学戒身。答曰。无学身戒口戒及净命。如余处无学支中说。正业即是此中无学身戒。正语即是口戒。正命是净命。问曰。如身口戒外更无净命。云何立此三名耶。答曰。以净不净相对故。而立三名。七不善业。从贪嗔痴生。从贪生者。是名邪命。从嗔痴生者。身业是邪业。口业是邪语。从贪生者。不复更作。是正命从嗔痴生。不复更作。身业是正业。口业是正语。复有说者。或有为命故。或以游戏故。或以怨心故。起七不善业。若为命故。是名邪命。若不为命。起身业是邪业起口业是邪语复有说者。或有为命故。行于种种医方咒术。或有为余事故。余如前说。复有说者。或为四种爱故。行诸恶行。或为余事者。若为四种爱。行诸恶行。是名邪命。余如前说。复有说者。若行谄诳等五事。是名邪命。若为余事。余如前说。复有说者。或有遮罪。或有性罪。若作遮罪。是名邪命。若作性罪。余如前说。所以者何。遮罪难除者故。复有说者。有根本不善业。有方便不善业。若行方便不善业。是名邪命。若行根本不善业。余如前说。所以者何以方便业难除者故。与上所说相违。是名正命。无学成就戒身。乃至广说。问曰。如学非学非无学。亦成就戒身。何以但说无学耶。答曰。或有说者。此是如来教化有余略胜之说。复有说者。说最胜义故。所以者何。若以法而言则无学法胜。若以人而言则无学人胜。广说如上。无学法胜学法。复有说者。世尊或称誉叹说最胜弟子。或称中者。或称下者。称最胜者。如偈说

  阿罗汉最乐　　以无渴爱故
  亦断于我慢　　坏裂无明网

称中者如赞七善人。经中所说。称下者如池喻经说。此中唯说称誉赞说最胜弟子。问曰。云何是尸罗义耶。答曰。冷义是尸罗义。所以者何。破戒能令身心热。持戒能令身心冷。复有说者。学习义是尸罗义。所以者何。数数修习善福故

云何无学定身。答曰。无学空三昧。无相三昧。无愿三昧。问曰。定体是一。云何说三耶。答曰。以三事故说三。一以对治。二以期心。三以境界。以对治故说空。空是我见近对治法。问曰。身见有二种。一行于我。二行我所。空有二种。一行于空。二行无我。此行与彼何行作近对治耶。答曰。无我行。对于我见。空行对我所见。复次无我行对五我见。空行对十五我所见。复次无我行对己见。空行对己所见。复次无我行对我亲爱。空行对我所亲爱。复次阴非是我。是无我行。阴中无我是空行。复次眼入非我。是无我行。眼入中无我是空行。乃至意入说亦如是。复次性空是无我行。无所行是空行。以期心故说无愿。无愿者不愿于有。问曰。若以期心。不愿于有。名无愿者。亦期心不愿圣道。而言无愿耶。答曰。期心不愿于阴。而圣道依阴。期心不愿于世。而圣道在世。期心不愿于苦。而圣道依苦。期心不愿增长。而圣道依于增长。问曰。若然者。圣人何以修道耶。答曰。欲至涅槃故。所以者何。圣人观察。除于圣道。更无有法能至涅槃。是以修道。以境界故说无相。无相者。无十相。无十相故言无相。十相者。谓色声香味触男女三有为相。涅槃无如是相。而彼定缘之。复次阴是有相。彼定缘阴不生。复次前后法是有相。彼定缘无前后复次若法有上中下。是名有相。彼定缘无上中下。复有说者。以行故说三。彼空定行于二行。谓空无我行。无愿定行于十行。谓苦无常行。集谛四行道谛四行无相定行于四行。谓灭谛四行。复有说者。以对治故说三。空行是我见近。对治。无愿是戒取近对治。无相是痴近对治

云何无学慧身。答曰。若智若见。若明若觉。若现观。乃至广说。评曰。此说可尔。但此中说正慧身。不说分别慧身。此文应如是说。云何无学慧身。答曰。尽智无生智不摄无学慧是也。云何无学解脱身。答曰。无学正观相应解脱。此解脱是大地。是尽智无生智。无学正见相应解脱

云何无学解脱知见身。答曰。尽智无生智是也。问曰。何故说尽智无生智是无学解脱知见身耶。答曰。以是解脱人身中生故

问曰。无学慧身。无学解脱。知见身。有何差别。答曰。无学苦智集智。是无学慧身。所以者何。此二智缘缚法故。无学灭智道智。是无学解脱知见身。所以者何。缘无缚法故。复次无学苦智集智灭智。是无学慧身。所以者何。此三智缘于解脱。不缘缘解脱。无漏智无学道智。是无学解脱知见身。所以者何。此道智缘于解脱。亦缘缘解脱无漏智解脱有二种。谓有为解脱。无为解脱。有为者苦集智所缘。无为者灭智所缘。智解脱无漏见。是道智所缘。是故道智是无学解脱知见身。以道智缘三智故。复有说者。慧或对治邪慧。或对治无知。若对治邪慧。是无学慧身。若对治无知。是无学解脱知见身。如邪慧无知。利钝愚智亦如是。戒身在六地。谓未至中间根本四禅。余身在九地。问曰。佛辟支佛声闻。此五种身。为有差别不耶。答曰。若以地以体。则无差别。若以根者。则有差别。利根者说胜。中根者说中。下根者说下。如佛告诸比丘。一究竟非众究竟。乃至广说。问曰。何故作此论。答曰。此是佛经。佛经说一究竟。非众究竟。佛经虽说一究竟。而不分别。为以发心故言究竟。为以事成故言究竟。佛经是此论所为根本。诸佛经所不说者今欲说故而作此论

问曰。究竟有二。何以世尊唯说一耶。尊者波奢答曰。一究竟谓发心究竟无二发心究竟一事成究竟。无二事成就究竟。世尊亦说一谛。无有二谛。谓一苦谛。无第二苦谛。乃至一道谛。无第二道谛。复有说者。唯一究竟。无二究竟。谓事成究竟。发心究竟者。皆为事成故发心。复有说者。诸外道等。各各自于所行法中。生究竟想。佛作是说。唯善说法中。有究竟法。恶说法中。无究竟法。复有说者。此中不说第一究竟。但欲说诸外道过失。诸外道等。断见者非于常见。常见者非于断见。佛作是言。若常见者是究竟。断见应非。若断见者是究竟。常见应非。然常断俱非究竟法。是故欲说外道过故说一究竟。非众究竟

如说一究竟非众究竟。乃至广说。究竟名为何法。答曰。世尊或说道究竟。或说涅槃究竟。云何说道究竟。如偈说

  若不知道　　是聪明慢　　未到究竟
  不调而死

不知道者。谓不见八道也。是聪明慢者。外道愚小自谓聪明。而生憍慢未到究竟者。虽复发意。不到究竟。不调而死者。如有烦恼而生有烦恼而死。如偈说道究竟。云何涅槃究竟。如偈说

  到究竟无畏　　无说亦无悔
  能尽于有箭　　此身是后边

到究竟者。究竟有二种。一发心究竟。二成事究竟。是到第一事成究竟也。无畏者。善修空三昧。深解缘起法故。不畏恶道及生死苦。无说者不如诸外道说邪智邪见无义之言也。无悔者善除戒取生毕竟智故。能尽于有箭者。以善修圣道。能令有爱已尽永灭寂静住不流法中。此身是后边者。已尽其因故更不生。更不生故。此身是后边也

  此是最究竟　　无上寂灭道
  能尽一切相　　出要到不死

此是最究竟者。说事成究竟也。寂灭者离三火故。道者智所立处。无上者无所依故。能尽一切相者。显现断一切业断一切烦恼相。出要者除诸烦恼。得清净故。到不死者毕竟到不灭法故

如数目揵连婆罗门。往至佛所而白佛言。沙门瞿昙所化弟子。一切尽到究竟耶。世尊告言。婆罗门此事不定。或有到者有不到者。此中说涅槃是事成究竟有发心有发心究竟。有事成有事成究竟。云何发心究竟。乃至事成究竟。答曰。或有说者。世俗道是名发心非究竟。圣道名发心亦名究竟。世俗道所断是名事成不名究竟。无漏道所断。是名事成亦名究竟复有说者。果中间道。是名发心不名究竟。根本沙门果道。是名发心亦名究竟。果中间道所断。是名事成不名究竟。根本果道所断。是名事成亦名究竟。复有说者。学道是名发心不名究竟。无学道。是名发心亦名究竟。学道所断。是名事成不名究竟。无学道所断。是名事成亦名究竟

如世尊说。有诸外道梵志。乃至广说。问曰。何故作此论。答曰。此是佛经。佛经中说。有诸外道梵志。作如是论。我断诸取。乃至广说。佛经虽作是说而不分别。佛经是此论所为根本。诸佛经中所不说者。今阿毗昙尽欲说故而作此论

此中问三事。一问诸外道实不断诸取。何以佛说诸外道言断诸取。二问如诸外道不施设断诸取。何以言诸外道施设断欲取戒取见取。三问如诸外道施设断欲取戒取见取。不施设断我取。于此三种问中。尊者迦旃延子。先答中者。问曰。如诸外道。不断诸取。何以言断欲取戒见取。乃至广说。答曰。或有说者。此是世尊小小说法之言。此言应当违逆。不应随顺。所以者何。世尊说法。不以无因缘。亦不以少因缘。诸佛所说。尽有因缘。非无因缘。尽有所为。非无所为。尽有所化。非无所化。若他人无缘者。佛终不说。复有说者。世尊现少分断故。作如是说。此言亦应违逆。不应随顺。所以者何。如凡夫人。断欲界戒取见取。乃至断无所有处戒取见取。凡夫亦断初禅地我取。乃至断无所有处我取。是故此言亦不中用。然佛世尊。广说诸法。乃至广说此说。是真实义。佛未出世时。外道异学。得名誉利养。后佛出世。蔽于外道。犹如日光蔽于荧火。外道弟子。归伏世尊。外道利养。转转减少。时诸外道。尽集一处。而共议言。沙门瞿昙。未出世时。世间所有名誉利养。皆归我等。瞿昙既出。如是等事。转转减少。然彼瞿昙。无有实德。但形容端正。善于经论。我等形容粗足相况。然彼所说经法难及。我等今当作何方便得彼经法。若当得者。世间利养。还归我等。作是议言。如我众中苏尸摩纳等。聪明利根兼有念力。必能受持沙门瞿昙所说经法。今可遣往为彼弟子。沙门瞿昙必为此人广说经法。彼诵读已。当为我等而来解说。时诸外道作是议已。即便喻遣苏尸摩纳等。汝当往诣瞿昙沙门所求为弟子。乃至出家于佛法中所闻经法。而能受持。是时如来以十力四无所畏。于大众中。广为人天。解说诸法。有诸外道。在大众边。彷徉而行。以窃法故。心怀恐怖。以恐怖故。受持者少。忘失者多。以是义故。当知世尊广说诸法。诸外道等。唯诵断三受。忘断我受。复有说者。世尊说法。或有满足。有不满足。其所为事。无不满足。如经说。四念处于念处义。便为满足。如说一念处。名不满足。如说众生住身身观者。如爪甲上土。不住身身观者。如大地土。如说五盖七觉支六界。此说亦是不满足。如说十盖十四觉支十八界。是名满足。以是事故。其所为事。无不满足。说法有满足不满足。有诸外道异学受佛法名者。乃至广说。为作证故。而引佛经。如经说。有诸外道梵志。诣诸比丘所集会堂。作如是语。诸长老。如汝师瞿昙。为诸弟子。作如是说。当断五盖。于四念处。安止其心。修七觉支。我等为诸弟子。亦说如是法。乃至广说。彼诸外道。与盖俱生俱死。犹不识盖。何况知见念处觉支。尚不闻香。况知其味。然佛广说诸法。乃至广说。如摩揵提梵志。来诣佛所。被郁多罗僧。以手摩此。如病如痈。如箭如疮之身。作如是言。沙门瞿昙。此身无病。即是涅槃。彼梵志身无疹病。常得饮食身无病故。言身无病。得饮食故。言是涅槃。彼梵志犹尚不识四大调适无病。何况结尽涅槃。复有说者。无病是道。涅槃是道果。彼梵志尚不识无病道。何况无病道果。然佛广演说法。乃至广说。彼所问者今当说之。何故外道梵志。不施设断我取。答曰。如经本说。外道梵志。长夜着我着众生。乃至广说。复有说者。外道异学。于我取心生恐怖。如人在于山岸上立怖畏于下。彼亦如是。复有说者。畏舍己见。随逐他见。外道异学。以我见为己见根本。而不欲舍。复有说者。畏断我命故。复有说者。畏为同梵行者所轻贱故。前所问者今当说之。如诸外道。不知断诸取。何以言断诸取耶。答曰。此是世尊随世言说。为作证故而引佛经。如说有诸众生见灭断坏。实义中无有众生。为随外道世俗言。说有众生。此亦如是乃至广说

有二智。一断智。二知智。乃至广说。问曰。何故作此论。答曰。前说外道异学。施设断诸取。不施设断我取。虽作是说。不分别为是断智为是知智。今欲说故而作此论

有二智。谓断智知智。云何知智。若知见明觉现观是也。智对无智。见对邪慧。明对无明。觉对邪见。现观对邪观。复有说者。此中说无漏知智。所以者何。无有世俗道能现观者。以是事故唯说无漏知智。复有说者。此中亦说有漏无漏知智。何以知之世俗智亦有知见明觉现观相故。问曰。世俗道无现观义。云何言现观耶。答曰。现前观了了是现前观义。世俗道亦能现观故。问曰。若然者。为说何等世俗知智耶。答曰。除虚现观相应慧。所谓无量初第二第三解脱八胜处十一切处。除如是等观相应慧。诸总相别相观者。去缘中愚者。去物体愚者。诸余实观。如闻思修暖顶忍世第一法。如是等也。问曰。何以定知世俗慧是现观也。答曰。如说现前观了了义是现观义。世俗慧亦能了了现观。何以知之。如城喻经说。我未成三菩提等。亦能生是现观。以是事故。知世俗慧能作云何断智。答曰。若一切爱恚痴断。一切烦恼断名为断智。问曰。如断无所缘智有所缘。何以说断名智耶。答曰。或有说者。以断是智果故。断名为智。如阿罗汉。是智果以智名说。如天眼天耳是通果。以通名说。如六入是业果。以业名说。如此六入是本业。如是断是智果。故说名断智。问曰。如修道中断是智果见道中断是忍果。何以说名断智耶。答曰。彼是世俗智果故。若以世俗道。离欲界欲。乃至离无所有处欲。彼欲界乃至离无所有处。是世俗智果。问曰。世俗道有功处可尔。世俗道于非想非非想处无功。非想非非想处。见道所断。尽是忍果。云何彼断复是断智耶。尊者僧伽婆修答曰。有二断智。一是慧果。二是智果。彼是慧果。评曰。不应作是说。所以者何。世尊说二智。一是断智。二是知智。不说断慧。复有说者。断智是无漏知智功用果。所以者何。如须陀洹。以无漏道当得斯陀含果。第六无碍道。当通证三界见道所断及欲界修道所断六品结。斯陀含以无漏道。当得阿那含果。第九无碍道。当通证三界见道所断及欲界修道所断。阿那含当得阿罗汉果金刚喻定。当通证三界见道修道所断断。是金刚喻定功用果。以是事故。断是无漏知智功用果。尊者佛陀罗测说曰。当言断法。所以者何。此是诸圣道第一所应。第一毕竟。第一胜法故。尊者瞿沙说曰。此当言断舍。所以者何。舍弃一切生死法。得此断故。复次从智种中生故言断智。如瞿昙姓中生名瞿昙。彼亦如是。复有说者。彼断虽无所缘而住智相。如过去未来眼。虽不能见。而是见相。如过去未来受。虽无所觉。而是受相。乃至慧说亦如是。如是断虽无所缘。而是智相。是故名断智。问曰。如断身见一结。亦名断智。何以说一切结。尽名断智耶。答曰。断一身见。亦是断智。此中说断一切结尽断智。不说渐渐断智

复次世尊或说智是知智。或说智是断智。云何智是知智。如偈说

  此贤年少者　　欲饶益世间
  爱能生诸苦　　能知是聪明

多求王此论根本。曾闻有王名曰多求。受性暴恶为人轻躁。多劫人民种种财货。是时人民普共集议。退其王位。以其次弟立以为王。时多求王。至国边邑。编草作屣。以自存活。是时弟王问诸臣言。我有大兄今何所在。诸臣答曰。闻在边邑。编草作屣。以自存活。王闻此言。心生愁恼作是思惟。唯有一兄勤苦如此。我今何用在此王位。即遣使往追命使还封一村落。是时人民亲附者众。所得封邑不供食用。复更封与二村三村。乃至半国犹故不足。是时其兄以半国人力。兴兵杀弟自立为王。尔时帝释作是思惟。今此国王不识恩义。作如是恶。我当往诳而苦恼之。尔时帝释自化其身。作婆罗门像。顶戴螺髻身着粗衣。左执军[土*遲]右把法杖。往诣王所以语告言。赞美于王在一面立。时王问言。大婆罗门从何所来。婆罗门言。我从大海外来。王复问言。大海之外有何奇事。婆罗门言。我见一国。人民炽盛。丰乐无极。王复问言。如我今日。多诸兵众。若当讨罸。为可得不。婆罗门言。往必可得。王复问言。谁当为我导引在前婆罗门言。我当导引。王复问言。若可尔者。后更几日当示我路。婆罗门言。却后七日言已便去。时王日日下算计所期日。至七日旦处处推求先婆罗门而都不见。以不见故心生愁苦。坐于静室。时释迦菩萨。在彼王国内。婆罗门村中生有小因缘来诣王城。闻王愁苦无能止者。是时菩萨。语诸臣言。我能去王心中愁苦。是时诸臣。便将菩萨。诣其王所。尔时菩萨。为其国王。说众义经偈

  追求五欲　　若获得时　　以称意故
  必生欢喜

乃至尽说染欲品偈。是时菩萨诵此偈已。心生厌离得离欲爱。以离欲故。复说此偈

  能行说为正　　不行何所说
  若说不能行　　不名为智者

菩萨说此一偈。半为帝释。半为国王。若不能行不应许他。若许他者便应即行。而不行者。是不善事。汝亦应当筹量。彼人为能去不能去。复于何时曾见有人从大海外来。而信其言耶。是时国王。于菩萨所。心生欢喜。便说此偈

  此贤年少者　　欲饶益世间
  爱能生诸苦　　能知是聪明

以此偈说智是知智

云何说智是断智。如说。佛告比丘。我今当说智所知法智成就智者。云何智所知法。答曰。五阴是也。问曰。如智知一切法。何以但说知五阴耶。答曰。若作是问者。如下章答。所以唯知苦。此中应尽说之。评曰。不应作是说。所以者何。此中说断智。不说知智。知五阴不知一切法故。问曰。若然者应作此论。如五阴是二智所知。谓知智断智。何以世尊。舍知智说断智耶。答曰。或有说者。以因此五阴得断知智故。下答知灭等。是中尽应说。云何为智。答曰。一切结尽。乃至广说。问曰。如佛说一切尽是名断界。此中何以说一切结尽是断智耶。答曰。此是如来教化有余略胜之言。复有说者。若说结尽。当知尽说一切有漏行断。如上说。若过去者。一切尽灭耶。彼中答者。此尽应说。云何成就智者。答曰。漏尽阿罗汉是也。问曰。如学人处处有智。何以唯说阿罗汉是智人耶。答曰。或有说者。此是如来有余之说。乃至广说。复有说者。以胜故如上答。无学人胜学人。此中应广说。复有说者。学人随其所知。不悉舍有。无学人。随其所知。悉能舍有。此中亦说。云何为说。答曰。一切结尽。谁尽一切结。唯是无学人。复有说者。此文应如是说。云何知智。答曰。若知见明觉现观等。乃至广说。亦如说贤年少等。乃至广说。云何断智。答曰。一切结尽。亦如说我今当说法智。乃至广说

若归佛趣彼何归趣。乃至广说。问曰。何故作此论。答曰。为非归处生归处想故。欲显真实归趣处故。而作此论。如偈说

  多有归趣　　山川树林　　园观塔庙
  以畏他故　　此归非安　　此归非胜
  其所归趣　　不能免苦　　若归趣佛
  法及众僧　　于四圣谛　　能以慧见
  此趣是安　　此趣是胜　　此趣能免
  一切众苦

是故为非归趣作归趣想。欲现真实归趣处故。而作此论。复有说者。为止众生愚归趣故。众生或谓归佛者谓归趣如来父母所生之身头足等分。为止如是意故。若归趣佛者。当归趣佛菩提。无学法者。若归趣法者。谓归善不善无记法及诸比丘所行。是应作是。不应作法。若归趣法者。当归趣爱尽涅槃法。若归趣僧者。谓归趣四性出家之人。欲令众生于此法中得决定。若归趣僧者。当归趣学无学法。是故欲止众生愚归趣故。而作此论

问曰。若归趣佛。彼何归趣。答曰。佛者实有此法。以有此法故。施设作如是语如是名如是想名为佛。乃至广说。问曰。何故作如是说。佛者实有此法。以有此法故。施设作如是语如是名如是想。名为佛耶。答曰。或有说者。佛不但有名施设作如是语如是名如是想名为佛。而无其实。为止如是意故。而作是说。佛者实有此法。乃至广说。若归趣者。归趣如是无学佛菩提法。问曰。若无学菩提法。是真实佛者。此经云何通。如须达居士所问。云何名佛。彼答言。佛者有释种子。以信出家。剃除须发。身着染衣是名为佛。答曰。此是说佛所依。若说所依。当知亦说依者。问曰。若无学菩提法。是真佛者。何故恶心出血。而得逆罪耶。答曰。或有说者。以心憎恶无学菩提法故。是以恶心出血。而得逆罪。复有说者。坏无学菩提所依故。若坏所依。则坏依者。是故得逆罪。若归趣法。彼何归趣。答曰。若归趣法则归趣爱尽离涅槃。若归趣僧。彼何归趣。答曰。僧者实有此法。乃至广说。是名为僧

问曰。云何为归。云何为趣。归趣是何义耶。答曰。归者。是灭谛道谛少分。趣者。是口语。复有说。趣者。能起口语心是也。复有说者。信可此法。是名为趣。评曰。如是说者好。能起口语心及共有法五阴体是趣。云何是归趣义。答曰。救护义是归趣义。问曰。若救护义是归趣义者。提婆达多。亦归趣佛法僧而堕恶道。不为救护耶。答曰。若归趣者。不破戒行。不越分界。能作救护。若归趣者破于戒行。越于分界。不为救护。如人畏于怨家归趣于王求其救护。王语彼人。若在我国。不越分界。我能为汝而作救护。若越我分界。我则不能为汝救护。如是众生。畏恶道故。归趣于佛。佛作是言。若归趣我。不应破于戒行越于分界。若破戒行。越于分界。我则不能为汝救护。是故救护义。是归趣义。复有说者。随尔所归趣。则有尔所救护。以归趣因缘故。得出恶道。

问曰。若归趣佛者。为归趣一佛。为归趣恒河沙等诸佛。若归趣一佛者。云何不是分归趣耶。若归趣恒河沙等诸佛者。何以但言归趣一佛耶。此经复云何通。如说。我为毗婆尸弟子。我为尸弃弟子。或有乃至我为释迦牟尼佛弟子。评曰。应作是说。归趣恒河沙等诸佛。问曰。若然者。何以言归趣一佛耶。答曰。此文应如是说。我归趣诸佛。而不说者。若归趣一佛。当知亦归趣诸佛。言我为一佛弟子者。随其见真谛处。言我是彼佛弟子

问曰。若归趣法者。为归趣自身诸阴灭。为归趣他身诸阴灭。为归趣自他身诸阴灭耶。若归趣自身诸阴灭者。云何不是分归趣耶。若归趣余者。云何救护义是归趣义。答曰。若归趣者。归趣自身他身。问曰。若然者。云何救护义是归趣义耶。答曰。虽于我无救护。而性是救护。是故救护义是归趣义。问曰。若归趣僧者。为归趣一佛僧。为归趣诸佛僧。若归趣一佛僧者。云何不是分归趣耶。若归趣诸佛僧者。何以言归趣一佛僧耶。此经复云何通。如说。佛告贾客。汝当归趣未来世僧。评曰。应作是说。归趣诸佛僧。问曰。若然者。何以言归趣一佛僧耶。答曰。此文应作是说。归趣诸佛僧。而不说者。若归趣一佛僧。则为归趣诸佛僧。此经云何通者。以现前无僧宝故。复有说者。以僧宝难得故。所以者何。有佛出世而无僧宝

问曰。何处有此归趣耶。答曰。若与戒俱者。唯人中有。若不与戒俱。余趣悉有。问曰。有受戒而不受归趣者。是人为得戒不。答曰。或有说者。不得。所以者何。若欲受戒。应先受归趣故。复有说者。若以自大慢心。而不归趣者。是人不得戒。若人不知。为先受戒。为先受归趣。若不受归趣而受戒。是人得戒。而与戒者得罪

问曰。若不求归趣。为得归趣不耶。答曰。不得。问曰。若不得者。或有在母腹中初生小者。而亦受归趣。此云何通。答曰。此为随顺戒故。此人本前生时。能施他人受戒具。若在腹中。若初生小时。父母为其受归趣。后若长大作非法事时。人便呵言。汝在母腹中及初生小时。已受归趣。今者何为作非法事。其人闻已。即远恶修善。是故为随顺戒。为受归趣。而实不得。复有说者。欲令信佛诸天为拥护故。问曰。若他人为求受归趣者。是人为得不耶。答曰。不得。问曰。若不得者。佛涅槃时。阿难白佛。拘尸城诸某甲人等。归趣世尊。亦归法僧。此言云何通。答曰。或有说者。佛威神力故。般涅槃时。令拘尸城诸力人等他人为求而得于戒。复有说者。尊者阿难入拘尸城。为多力人授归趣戒。而还白佛。世尊复有如是最后弟子众。复有说者。得如迦尸女罗恶不能言者是也。如说。若归趣佛。不堕恶道。问曰。诸归趣佛。尽不堕恶道耶。答曰。此为得不坏信者。作如是说。复有说者。为深心归趣者。作如是说

问曰。如法宝胜佛。何以归趣时。先归趣佛。后归趣法耶。答曰。或有说者。佛于教法中尊故。是以先归趣佛。复有说者。犹如病人。先依附医。然后服药。佛如明医。法如良药。僧如授药人

阿毗昙毗婆沙论卷第十八阿毗昙毗婆沙论卷第十九

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    杂揵度无惭愧品第五

云何无惭云何无愧如此章及解章义。此中应广说优波提舍。问曰。何故作此论。答曰。以此二法所行相似故。世人见行无惭言是无愧。见行无愧言是无惭。此二法实异。人谓是一。欲说其定体亦说差别故。而作此论。复有说者。以此二法能坏世人。世尊亦说。有二黑法能坏世人。谓无惭无愧。复有说者。以此二法行不善法时势力最胜。如说。与何缠相应。此心淳是不善谓无惭无愧。复有说者。以此二法令众生有种种差别相。如说。若世无此二法。则众生无种种差别相谓猪羊鸡犬等。复有说者。阿毗昙以此二法一心中可得。是故尊者迦旃延子。欲说其体及差别相故。而作此论。云何无惭。答曰。若无惭无惭分。乃至广说。如是等尽说一无惭体。而文有种种。问曰。虽说无惭体。亦应说其所行。答曰。如不善所行。无惭所行亦如是。所以者何。与不善法相应故。问曰。此为何所缘耶。答曰。缘于四谛。复有说者。先说所行。未说其体。问曰。若然者。体是何耶。答曰。自身即是其体。何以知之。如说。自身法。是自相似法。是总相。诸作是说。先说是所行者。应作四句。初句者。无惭行。余所行是也。第二句者。行无惭所行无惭相应法是也。第三句者。无惭行无惭行是也。第四句者。即是无惭行。余行相应法是也。若不尔者。除上尔所事。如无惭行作四句。余行亦应作四句。复有说者。先说所缘。未说其体。未说所行。如说。无惭无惭分。无恶贱无恶贱分。是缘苦集谛。如说。不尊重不善尊重。不避他不善避他。是缘灭道谛

云何无愧。答曰。无愧无愧分。无愧他。乃至广说。如是等。尽说一无愧体。而文有种种。问曰。若然者。所行云何。答曰。如不善法所行。无愧所行亦如是。余如无惭说。问曰。所缘云何。答曰。缘四圣谛。广说如无惭。诸作是说。先说是所行者。亦应作四句。初句者。无愧行余行是也。第二句者。无愧相应法行无愧行是也。第三句者。无愧行无愧行也。第四句者。即无愧行余行相应法是也。若不尔者。除上尔所事。如无愧行作四句。余行亦应作四句。复有说者。先说所缘。未说其体。未说所行。如说无愧无愧分。不愧他。不数数愧。无羞无羞分。不羞他。是缘灭道谛。如说行恶不畏。行恶不怖。不见恶事可畏怖。是缘苦集谛

问曰。无惭无愧。有何差别。何故复作此论。答曰。以此二法相似故。虽说其体相。而故须说差别。不避他是无惭。不见恶事可畏怖是无愧。复次不尊重是无惭。不见恶事可畏怖是无愧。复次不恶贱烦恼是无惭。不恶贱恶行是无愧。复次自于身作恶是无惭。于他身作恶是无愧。复次若于一人前作恶不羞是无惭。于多人前作恶不羞是无愧。复次造智者所呵责因时不羞是无惭。造智者所呵责果时不羞是无愧。是名差别。问曰。如此恶法。何以不名为使耶。答曰。此所行粗使性微细。复次此习气不牢固。如烧桦皮。使习气牢固。如烧佉陀罗木。复次此不能自立。使能自立。复次此依于使。无惭依贪欲。无愧依无明。使是根本。以是事故。不名为使

云何为惭。云何为愧。乃至广说。问曰。何故作此论。答曰。此二法所行相似。世人见行于惭名之为愧。见行于愧名之为惭。此二法实异。人谓是一。欲说其定体亦说差别故。而作此论。复有说者。惭愧是无惭无愧近对治。先说无惭无愧。今说惭愧是彼近对治。复有说者。此是佛经。佛经中说。有二白法守护世人。所谓惭愧。若世人无此二法。则谓不施设父母兄弟姊妹男女眷属。有众生种种形差别。谓猪羊鸡犬驴马狐狼等禽狩。以有此二法故。施设有父母兄弟姊妹男女眷属。亦应有猪羊等种种形差别。佛经虽说惭愧。不分别其体亦不说差别。佛经是此论所为根本。彼中所不说者。今欲说故而作此论

云何为惭若惭惭分。乃至广说。如是等语。尽说惭体。如上所说。问曰。惭体如此。所行云何。答曰。如善法所行。此亦复尔。与一切善法相应故。问曰。为缘何法。答曰。缘一切法。诸作是说。先说是所行者。应作四句。初句者。惭行余行是也。第二句者。惭相应法行惭所行是也。第三句者。惭行惭是也。第四句者。即惭相应法行余行是也。若不尔者。除上尔所事。如是余行。亦应作四句。复有说者。此说所缘。如说。惭惭分恶贱恶贱分。此缘苦集谛。尊重善尊重。避他善避他。能制恶事。是缘灭道谛

云何愧。答曰。若愧愧分。愧他。乃至广说。如是等语尽说愧体。问曰。若已说体。所行云何。答曰。如诸善法所行。此亦复尔。乃至广说。若作是说。先说是所行者。应作四句。初句者。愧行余行是也。第二句者。愧相应法行愧所行是也。第三句者。愧行愧是也。第四句者。即愧相应法行余行是也。若不尔者。除上尔所事。余行亦应作四句。复有说者。此说所缘。如说。愧愧分愧他。羞羞分羞他。是缘灭道谛。如说。见可恶事是可怖畏。是缘苦集谛

问曰。惭愧有何差别。何故复作此论。答曰。以此二法相似故。虽说其体相。故须说差别。避他是惭。见恶事可畏是愧。余答与上相违。是惭是愧。有无惭与惭相似。有惭与无惭相似。有无惭与无惭相似。有惭与惭相似。无惭与惭相似者。不可惭事而惭。惭与无惭相似者。不可惭事。而不惭。无惭与无惭相似者。可惭事而不惭。惭与惭相似者。可惭事而惭。愧说亦如是

界者。无惭无愧在欲界。惭愧在三界。若是无漏不系。如法身论说。信力乃至慧力。是学无学非学非无学。惭愧力是非学非无学。复有说者。惭愧是学无学非学非无学人者。凡夫人有圣人亦有。以有此法故。当知是有漏无漏。云何增上不善根。云何微不善根。乃至广说。问曰。何故说增上不善根。不说中耶。答曰或有说者。彼作经者意欲尔。乃至广说。复有说者。应作是问。云何增上不善根。云何中。云何微而不说者。当知此说有余。乃至广说。复有说者。已说初后。当知亦略说中间。复有说者。已说在此二中根。所以者。何若说上。当知中分在微分中。若说微。当知中分在上分中。复有说者。若易见易知者则说。中法难见难知。是故不说。复有说者。若是世现见者即说。若不现见则不说。世尊必知二法。谓上与微。何以知之。如说。利根者谓央掘魔罗。钝根者谓萨波达婆。而不说中者。复有说者。若说于中则文重不便。若不说中则文轻便

云何增上不善根。答曰。不善根能断善根者。乃至广说。问曰。断善根者是邪见。何以言是不善根耶。答曰。或有说者。不善根断善根方便时势胜。所以者何。一切内外法。方便时功。胜于成时。如菩萨见众生老病死苦发菩提心。此心能荷负三阿僧祇劫善行。使不散坏。亦无留难。此心甚难。后得尽智。三界善根。未来中修。未足为难复有说者。邪见所以能断善根。皆以不善根力。不善根。能令善根羸劣微薄。更无势力。亦令因缘多诸留难。然后邪见能断善根。复有说者。此文应如是说。不善根。能断善根。何等不善根。答言邪见相应痴。不善根。亦断欲界欲时。最初灭者是也。问曰。断欲界欲。不应言亦。所以者何。即是一答故。答曰。或有说者。此答前所说。何等邪见。能断善根。答言离欲界欲时初灭者

云何微不善根。答曰。断欲界欲时。最后灭者。彼灭已得名无欲

问曰。不善根断善根时。为一种断。为九种断。若一种断者。此说云何通。如说。云何微善根。答言。善根断时最后灭者。彼灭得名善根断。若九种断者。此文云何通。如说。云何增上不善根。断欲界欲时。最初灭者。云何以一种不善根。断九种善根。答曰。或有说者。一种断。问曰。若然者。此文云何通。如说。云何微善根。答言断善根时最后灭者。彼灭得名善根断。答曰。此以现在不行故。作如是说。如上上善根。先不现在前。后得不成就。乃至第八善根亦如是。彼下善根。于一时得二种现前。不行亦得不成就。所以者何。若断下下善根时。于下下善根。一时得二种。一不现前行。二得不成就。于八种善根。得不成就。不得不现前行。本已得故。以次第得不现前故。而作是说。断善根时。最后灭者。彼灭得名善根断。以一时得九种不成就故。而作是说。断欲界欲时。最初灭不善根。以是义故。此二说善通。复有说者。九种断。问曰。若然者。此说云何通。如说。断欲界欲。最初灭者。乃至广说。答曰。有多名九种。有因九种。有对治九种。有报九种。有善根断九种。因九种者。如下下善根。乃至能为上上善根作因。上上与上上作因。不为余者。对治九种者。如下下对治道断上上烦恼。上上对治道断下下烦恼。报九种者。如施设论所说。修行上上杀生。生阿毗大地狱中。转减者。生热地狱中。乃至转转减者。生畜生饿鬼中。善根断九种者。如下下邪见断上上善根。乃至上上邪见断下下善根。若以断善根邪见。则有九种。若以离欲邪见则有一种。所以者何。断善根九种邪见时。尽从离欲一种中起故。下下邪见。断上上善根。上上邪见。断下下善根。以尽从一种中起故。此二说善通

问曰。断善根体是何耶。答曰。是不成就不隐没无记心不相应行行阴所摄。所以者何。邪见断善根。非如刀之断木。若断善根邪见。在彼身中时。成就善根得则灭。不成就善根得则生。以无善根得故。名断善根。复有说者。能断善根邪见。则是其体。若作是说。当知断善根体是染污法。余义如上顶退中说

问曰。何处断善根。答曰。阎浮提。弗婆提。瞿陀尼。能断善根。尊者僧伽婆修说曰。唯阎浮提能断。非余方。所以者何。如阎浮提人。于善分猛利。于不善分亦猛利。问曰。若然者。此文云何通。如说。阎浮提成就诸根。极多有十九。极少八。如阎浮提。弗婆提瞿陀尼亦如是。彼作是答。此文应如是说。弗婆提瞿陀尼。极多十九。极少十三。阎浮提如先说。评曰。不应作是说。如前说者好。如此文义。阎浮提。极多十九。极少八。弗婆提瞿陀尼亦如是

问曰。为男子能断善根。为女人耶。答曰。如施设论所说。以三事胜故。能断善根。女人三事不如。一男子造业胜于女人。二男子欲有所作胜于女人。三男子能令诸根利胜于女人。是故男子能断。女人不能。问曰。若然者。此文云何通。如说。若成就女根。必成就八根。彼作是答。此文应作是说。若成就女根。必成就十三根。评曰。不应作是说。如是说者好。男子女人。俱能断善根。如此文义。若成就女根。必成就八根。若女人作断善根方便。重于男子。如旃遮婆罗门女谤于世尊

问曰。为爱行人能断善根。为见行人能断善根耶。答曰。见行人能。非爱行者。所以者何。爱行人。于烦恼法。不坚固。于出要法。亦不坚固。见行人。行恶坚固。是故见行人。能断善根。非爱行人。问曰。黄门般吒。无形二形。能断善根不耶。答曰。不能。所以者何。见行人能。彼是爱行。多恚人能。彼是多欲。复有说者。彼心轻躁故。不能断善根

问曰。断何界善根耶。答曰。欲界善根。问曰。若然者。此说云何通。如说。若人杀折脚蚁子。无有悔心。当言此人断三界善根。答曰。此文应如是说。此人当言断三界中善根。而不说者有何意。答曰。欲令三数满故。成就欲界善根。不成就色无色界善根。若断欲界善根。则三界善根不成就。以是义故。为满三数故。作如是说。复有说者。以色无色界善根依欲界善根故。复有说者。若此不断。彼则生长。若此断者。彼则干萎。复有说者。复更得不成就故。所以者何。令彼转更远故。问曰。为断生得善根。为断方便善根耶。答曰。断生得善根。非方便。所以者何。方便善根。先已不成就故

问曰。为缘有漏邪见断善根。为缘无漏邪见断善根耶。答曰。有漏缘。非无漏缘。所以者何。无漏缘使。其性羸劣。有相应使。无缘使故。有漏缘使。其性强盛。有缘使相应使故

问曰。为自界缘邪见断善根。为他界缘邪见断善根耶。答曰。自界缘者。所以者何。如前所说故

问曰。为谤因邪见断善根。为谤果邪见断善根耶。答曰或有。说者。谤因者能。所以者何。如说。杀折脚蚁子无有悔心。当知是人断善根者。复有说者。谤果者能断善根。所以者何。如说。若决定言无善恶果报。当知是人断三界善根。评曰。俱能断善根。如是说者好。所以者何。谤因者如无碍道。谤果者如解脱道。谤因者与成就得俱灭。谤果者与不成就得俱生。是故俱能断善根。问曰。何故以折脚蚁子为喻耶。答曰。以无过于人故。杀无过者。犹无悔心。况有过者。是故引以为喻。问曰。住戒人断善根时。为先舍戒后断。为俱耶。答曰。或有说者。先舍戒后断善根。所以者何。彼人身中。有一邪见生。舍戒后一邪见生。断善根。喻如猛风吹树。先折其枝叶。后拔其根。彼亦如是。评曰。应作是说。若舍彼能生戒心。当知戒亦舍

问曰。善根还相续时。为九种一时相续。为一一种续耶。答曰。或有说者。一一种续。复有说者。地狱中死。还生地狱中。三种相续生畜生饿鬼中。六种相续生人天中。九种相续生。评曰。如是说者好。一时九种相续次第现在前。喻如病人。一时除病。渐渐生力。彼亦如是

问曰。善根为断者多。为相续者多耶。答曰。随其所断。还有尔许相续。若断欲界善根。还欲界善根相续。若断生得善根。还生得善根相续。问曰。若断善根。于现法中。还能令相续不耶。答曰。如说。此人于现法中。不能还令善根相续决定。地狱中生。地狱中死。还能令善根相续。问曰。何等人地狱中生时相续。何等人死时相续耶。答曰。或有说者。若于中阴中乃至死时。受邪见报。以报尽故。死时善根还相续。若中阴中不受邪见报者。则生时善根还相续。所以者何。如邪见与善根相妨。报亦复尔。复有说者。或有以因力断善根者。或有以缘力断善根者。若以因力断善根者。死时相续。若以缘力断善根者。生时相续。复有说者。或有自力断善根者。或有他力断善根者。若以自力断善根者。死时相续。若以他力断善根者。生时相续。复有说者。或以常见。或以断见。若以常见。死时相续。若以断见。生时相续。尊者瞿沙说曰。生地狱中时。不无报现在前。彼作是念。我自作此业。当受此报。若受彼报。亦作是念。是时善根还相续。复有说者。现法中能令善根还相续。尊者佛陀提婆。作如是说。何等人于现法中。能令善根还相续。何等人转身。答言。若得如是善知识多闻。能为是人说次第法语如是言。若于我有信敬心。于诸梵行者。亦应生信敬心。若能生信敬心者。当知是人于现法中。能令善根还相续。何等人转身者。断善根人。有作无间罪者。有不作者。若不作无间罪。是人现法中。还令相续。若作无间罪。是人转身。或有破见破戒。或有破见不破戒。若破见不破戒。是人现法。若破见破戒。是人转身。破其心破方便。当知亦如是。问曰。若现法能生善根者。彼所说云何通。如说。此人于现法。不能还生善根。答曰。此说断善根作无间罪者。若于现法。还相续者。是名成就善根亦现在前。若死时生时。还相续者。是名成就不能令现在前。若于现法。还相续者。不必生地狱中。问曰。若于现法中。还令相续者。能得正决定不耶。答曰。或有说者。不能所以者何。以彼身中曾断善根故。使善根羸劣。善根羸劣故。不能得正决定。而故能生达分善根。复有说者。能生达分善根。得正决定。乃至能得阿罗汉果。如优仇吒婆罗门居士。曾断善根。尊者舍利弗。还令其人生于善根。得正决定。是故当知能生达分善根。乃至亦能得阿罗汉果

问曰。杀断善根人。杀折脚蚁子。何者罪重耶。答曰。或有说者。若住等缠。其罪亦等。是为折脚蚁子断善根人其量正等。复有说者。杀折脚蚁子罪多于彼。所以者何。折脚蚁子。不断善根。彼人断善根。如是说者。呵责断善根者。若以杀生。杀折脚蚁子罪重。若以得罪。杀人罪重。所以者何。若杀于人。则得边罪。若杀折脚蚁子。不得边罪。问曰。于何处受断善根邪见报耶。答曰。于阿毗地狱受。如阿罗汉所趣。最上到于涅槃。断善根者所趣。最下到阿毗狱

问曰。诸断善根尽住邪定聚耶。答曰。如是。若断善根。尽住邪定。颇有住邪定不断善根耶。答曰有。如阿阇世王是也。复有作四句者。或断善根非邪定。或邪定不断善根。乃至广作四句。初句者。富兰那等。自言是佛六师是也。第二句者。阿阇世王是也。第三句者。提婆达多是也。第四句者。除上尔所事

问曰。为不起断九种善根。为数数起断九种善根耶。答曰。或有说者。不起断诸善根。如见道中不起。彼亦如是。复有说者。或有断一二三善根而起已复断。评曰。不应作是说。如说不起者好。云何欲界增上善根云何微。乃至广说。问曰。何故问欲界系善根。不问色无色界耶。答曰。或有说者。作经者意欲尔。乃至广说。复有说者。此问初起方便入法。如问欲界。当知亦问色无色界。亦不说者。当知此问有余。复有说者。先说不善根。谁是不善根近对治。所谓欲界善根也。是故问之。复有说者。若易见易施设者则问。色无色界增上善根。虽易见易施设。而微者。难见难施设。所以不问。复有说者。欲令经文便故。色无色界增上善根。虽易显现。而微者难见。若显现者。经文烦乱。所以者何。无断善根法故。欲界有断善根法故。若说微者。则经文不烦是以问之

云何欲界系上上善根。答曰。菩萨得正决定时。见道边所得等智。如来得尽智时。得欲界无贪无恚无痴善根。问曰。何故见道边等智。得尽智时善根此二法等而论耶。答曰。或有说者。此不等论。但欲说见道边等智。于见道边等智胜者。得尽智时善根。于尽智时善根胜者。所以者何。如辟支佛所得见道边等智则胜声闻。如佛所得见道边等智则胜辟支佛。辟支佛得尽智时善根则胜声闻。佛得尽智时善根则胜辟支佛。以是义故欲说见道边等智于见道边等智胜故。乃至广说。复有说者。此二法等而论之。俱能摧伏过于有顶而得之故。所以者何。摧伏出过见道所断有顶。得见道边等智。摧伏出过修道所断有顶。得尽智时善根。以是义故等而论之。复有说者。欲说转胜法故。如辟支佛得见道边等智。则胜声闻得尽智时善根。菩萨得见道边等智。则胜辟支佛得尽智时善根。问曰。若然者。云何言声闻辟支佛有增上善根耶。答曰。以身胜故说增上。如在辟支佛身中。则胜声闻如在佛身中。则胜辟支佛。复有说者。有二道。见道修道。若以见道力得佛亦胜。若以修道力得佛亦胜。复有说者。此中亦不说胜。亦不说等。但说二种善根

问曰。如菩萨得正决定已。得此等智。何以言得正决定时耶。答曰。或有说者。此文应如是说。菩萨得正决定已。得此等智。而不说者。有何意。答曰。此中得决定已。言得决定时。已来言来。如说。大王从何处来。广说如上。复有说者。得决定时。得此等智。所以者何。此智苦比智时修。从苦比忍决定。得苦比智时故。集比忍集比智灭比忍灭比智亦如是。同于所缘未休息故。问曰。何故言此智是见道边耶。答曰。以二事故。一从见道中得。二从见道后边得。行人见道中得。故言见道中。见苦集灭最后得。故言后边。问曰。如此法体。是四阴五阴。何以说名为智耶。答曰。此中智分多。从多分故。说名为智。如见道亦体是五阴。以见分多故。说名见道。四道通金刚喻定。此智亦如是。问曰。见苦边欲界等智。见集边欲界等智。此二何者为胜。答曰。以见集边等智在胜身中故胜。所以者何。见集时其道转净。胜见苦时。问曰。欲界见苦边等智。色界见苦边等智。何者为胜。答曰。色界者胜。所以者何。以色界法胜于欲界法故。欲界系见集边等智。色界系见苦边等智。何者为胜。答曰。欲界者。以在胜身中修故胜。色界者。以界胜故胜。问曰。见苦边欲界等智。见集边色界等智。此二何者为胜。答曰。色界者。以二事故胜。一以界胜。二以在胜身中故胜。如以苦问集。以苦问灭。以集问灭。当知亦如是

问曰。何故法智边不修此智耶。答曰。以非田非器故。乃至广说。复有说者。此智以见道后边得故。名见道边智。若当法智边亦修者。此智当言见道中智。复有说者。此智能摧伏出过有顶。然后得之。如苦比智现在前。此智便修。是时名摧伏出过见苦所断法。见集见灭说亦如是。复有说者所作已竟。不作方便时。得此等智。如苦法智现在前。此智则修。是时名于苦已竟不作方便。集比智灭比智。说亦如是。法智当多有所作。虽知欲界苦。未知色无色界苦。虽断欲界诸行集。证欲界诸行灭。未断色无色界诸行集。未证色无色界诸行灭。复有说者。若苦比智现在前时。此智修见苦所断爱毕竟灭。集比智现在前时。此智修见集所断爱毕竟灭。灭比智现在前时。此智修见灭所断爱毕竟灭。法智分时。见苦集灭所断爱。不毕竟灭。是以不修。问曰。道比智边。何以不修此智耶。答曰。或有说者。非其田器故。乃至广说。复有说者。此智是见道眷属随从见道边。比智是修道故。复有说者。见道边等智。依坚信坚法身。道比智。依信解脱见到身。复有说者。见道边等智。是向道所得。道比智。是果道所得。复有说者。所作已竟。不作方便。是时此智修。道比智当多有所作。为作何等。谓当得未曾得道。舍曾得道。所断结使。同一味一时得八智。修十六行。复有说者。此智见道边得故。言是见道边等智。若谛有边名者。是处便修。三谛有边名非道谛。如说此身苦边此身集边此身灭边。不说此身道边。问曰。因论生论。何故佛经不说道边耶。答曰。有能尽知苦尽断集尽证灭。无有能尽修道者。佛于道尽得修。不能尽得行修。复有说者。若谛以世间道出世间道能见者说边。无有以世间道见道谛者。如世间道出世间道。有味无味。有爱出要。系不系。当知亦如是。复有说者。前无有际。无始以来。或曾以世俗道。见于三谛。彼世俗道。亦言我是道。后若以真实道。见道谛时。世俗道。惭羞舍去。如村落中。未立主时。自贵者多。后若立主诸自贵者。惭羞舍去。彼亦如是。复有说者。见道边等智体。是有苦谛。是有。是有果。说名为边。苦集谛。是有是有果。灭谛虽非有是有果。道谛非有有。亦非有果故。复有说者。三谛有无量过患无量功德。苦集谛是无量过患。灭谛是无量功德。道谛亦无无量过患。亦无无量功德故。复有说者。凡夫于无始生死已来。于三谛曾已有功。后若得正决定时。皆见道边等智。亦欲证此法。犹如与欲法。我亦当知。苦乃至证灭。然无有凡人曾修圣道者。复有说者。见苦时。不见真道。见集灭时。亦不见真道。见道谛时。乃见真道时。世俗道言我非道。是中应说乌孔雀等喻。复有说者。见道谛时。断缘道谛道使。非三谛。是故世俗道于三谛。自言是道。后见道谛。而便退还。是故不修。界者。在欲色界。问曰。何故无色界中无耶。答曰。非其田器故。乃至广说。复有说者。若地有见道。则有见道边等智。无色界无见道故无。如是因论生论。何故无色界无见道耶。答曰。非其田故。乃至广说。复次若有缘一切法无我行是中则有见道。无色中无缘一切法无我行。故无见道。复次若地有达分善根。则有见道。无色界无达分善根故。无见道。复次若地有忍有智。复次若地有法智分比智分。复次见道法。决定应尔。若依下地。得正决定。则上地不修。无色中。若有见道边等智者。依第四禅。入见谛道。彼则无用故不修。地者。七地中有。谓欲界未至中间根本四禅。若依未至禅。得正决定。彼一地见道修。二地见道边等智修。若依初禅。得正决定。二地见道修。三地见道边等智修。若依中间禅。得正决定。三地见道修。四地见道边等智修。若依二禅。得正决定。四地见道修。五地见道边等智修。若依三禅。得正决定。五地见道修。六地见道边等智修。若依四禅。得正决定。六地见道修。七地见道边等智修。依者。依欲界身。或有说者。依色界身。所以者何。如来展转曾有色界身。亦能作所依故。辟支佛声闻亦如是。报者。后当广说。行者。行十二行。苦边者。行苦四行。集边者。行集四行。灭边者。行灭四行。缘者。欲界缘欲界苦。色界缘色无色界苦。缘集灭说亦如是。复有说者。此是总缘。如缘欲界苦者缘色界苦者。此总缘苦谛。乃至灭谛说亦如是。评曰。此是别缘非总缘。如前说者好。念处者。苦集边是四念处。灭边是法念处。智者。是等智。定者不与定俱。根者总而言之。与三根相应谓喜乐舍根。三世者是未来世。缘三世者。若苦集边者缘于三世。灭边者不缘世。善不善无记者。是善缘善。不善无记者。缘欲界。苦集者。缘三种。色界苦集边者。缘善无记。灭边者。唯缘善。三界系者。是欲色界系。缘三界者欲界苦集者缘欲界系。色界苦集边者。缘色无色界系。灭边者。缘见不系是学无学非学非无学者。是非学非无学。缘学无学非学非无学者。是缘非学非无学。见道断修道断不断者。是修道断缘。见道修道不断者。若苦集边者缘见道修道断。若灭边者缘不断。缘名缘义者。若苦集边者是缘名缘义。若灭边者是缘义。缘自身他身不缘身者。若苦集边者。缘自身他身若灭边者。不缘身。问曰。此智为依凡夫身。为依圣人身耶。若依凡夫身者。何以不名凡夫法。若依圣人身者。此法终不起现在前。若起者。云何不二道俱现在前。或有说者。应作此论。不依凡夫身。亦不依圣人身。评曰。不应作是说。云何名善根。不依凡夫身。不依圣人身。实义者当言依圣人身。问曰。圣人不起现在前。何以言依圣人身耶。答曰。虽不起现在前。以时而言。应在圣人身。复有说者。依坚信坚法身。彼坚信坚法人。不起所期心故。不现在前。问曰。如坚信坚法身虽智忍所依。云何复是此智所依耶。答曰。彼有二种身。一种得见道。亦在身中成就。亦现在前。即此身得此智。不在身中成就。不现在前。第二身得等智。在身中成就。亦现在前。即此身得见道。不在身中成就。不现在前若此身得见道。在身中成就现在前。得是智。不在身中成就。不现在前。如此身坚信坚法起现在前。若此身得是智。在身中成就现在前。得见道不在身中成就。不现在前。若起期心。坚信坚法。亦能起此身现在前。是闻思修慧者。欲界者是思慧以胜故。非是闻慧。以欲界非离欲地非定地非修地故非修慧。若欲修时。堕思慧中。若色界是修慧。非闻思慧。所以者何以胜故非闻。以色界是离欲地定地修地故非思慧。若欲思时。堕修慧中。为在意识五识者。在意地非五识身

问曰。得须陀洹果舍见道。亦舍见道边等智不耶。答曰。不舍。所以者何舍无漏时异。舍有漏时异。无漏法以三时舍。谓退时。得果时。转根时。有漏法亦三时舍。谓退时。离地离界时。善根断时。彼时非退。不离地界。不断善根故不舍。复次修道与见道。二事相妨。一不得俱成就。二不俱现在前。修道与见道边等智。一事相妨。不俱现在前。得俱成就。问曰。若不舍者。于修道中。起现在前不耶。答曰。不起现在前。以是事故。先作是说。修道于见道边等智。一事相妨。成就不现在前。以不妨成就故不舍。妨现在前行故。不现在前。复次以是见道眷属不离见道故。修道中不现在前。复次以依坚信坚法身故。依余身不起现在前。复次以不离向道故。不依余身现在前

问曰。此为有报无耶。答曰。有报。问曰。此报为在何处。答曰。若欲界者。报在欲界。若色界者。报在色界。若在初禅。报在初禅。乃至若在四禅。报在四禅。问曰。如声闻可尔。所以者何。声闻当在色界身故。佛辟支佛。云何可尔。答曰。彼亦有展转凡夫时身在色界受报。问曰。若然者。云何圣人身作因。凡夫身受报耶。答曰。若然者有何过。有圣人身作因凡夫身受报。如恶道有二种因。一见道所断。二是修道所断。六种烦恼。如此圣人身作因。凡夫身应受报无过。彼亦如是。复有说者。佛辟支佛。亦有声闻阴界入展转色界身分。而受此报。评曰。不应作是说。如是说者好。以是有漏善根故言有报。而此报不熟。未曾有受之者

得尽智时。三界善根未来修问曰。为修几耶。答曰。若生欲界。得阿罗汉。则三界善根未来世修。若生初禅。则八地修。乃至若生非想非非想处。则一地修。问曰。此善根为是生得。为是方便耶。答曰。是方便非生得。为是闻思修慧者。若欲界者。是闻思慧。若色界是闻修慧。若无色界是修慧。问曰。如欲界是闻思慧色界是闻修慧。闻思慧羸劣。云何未来世修耶。答曰。以他力故。未来世修。非自力。为是意地是六识身。是意地非五识身。所以者何方便善在意地。生得善在五识问曰。若唯在意地者此说云何通。如说。漏尽阿罗汉。成就六识支。几过去成就。几未来成就。几现在成就。为有耶。为无耶。若有者谁有耶。云何有耶。答曰。有若阿罗汉。初起善眼识现在前。一支过去。六支未来。一支现在。彼灭已不舍。若善耳识现在前。二过去。六未来。一现在。彼灭已不舍。乃至善意识现在前。六过去未来。一现在。此云何通。答曰。此中所说者。最初得阿罗汉清净身所得善根。不取无始生死已来者。复有说者。此说阿罗汉六常住法。问曰。阿罗汉六常住法体性是何。答曰。或有说者。体性是念慧。何以知之。答曰。依佛经故。佛经中说阿罗汉。若眼见色。以念慧力住于舍。心不生忧喜。乃至意知法。广说亦尔。复有说者。若取回转相应共有体。是四阴五阴。此是六常住体性。乃至广说。已说体性所以。今当说。何故名常住。云何常住义。答曰。阿罗汉。常住此法。未曾远离。故名常住。问曰。一切阿罗汉。尽有此常住法不。答曰。或有说者。不尽有。若阿罗汉。是非时解脱。得种智者。此有常住法。评曰。应作是说。一切阿罗汉尽有。所以者何。一切阿罗汉。常有念慧故。界者。是欲界色界。地者五地。谓欲界四禅

问曰。以何等故。得阿罗汉果。三界善根。未来世修。非余时耶。答曰。阿罗汉。必须世俗出定入定心。复次当于尔时。不满解脱。得满足故。学人解脱。乃至金刚喻定不名满足。若得尽智乃名满足。犹如农夫灌田。一畦满已复流一畦。若诸畦已满更不复流。彼亦如是。复有说者。是时心得自在。首系解脱罥。是时所修善根。如贡上法。犹如国王登位首系罥时。一切万姓。贡上珍宝。彼亦如是。复次是时能折伏未曾折伏烦恼。力士诸善根。皆称善故修。犹如大众集会一处。若能扑未曾有力士者。大众称庆。彼亦如是。复有说者。是时能破未曾破烦恼怨家。诸善根如迎法故修。犹如有人能破怨家归国之时多人出迎。彼亦如是。复有说者。无有前际。无始已来。诸善根身。常为烦恼身所覆蔽沉没。不能自免。欲界烦恼尽时。不得止息。乃至非想非非想处。八种烦恼断时。犹不得止息。若九种烦恼尽时。是时乃得止息。如束绢法。九处约之。若断一约乃至八约。其束不散。若九约都断然后乃散。彼亦如是

时解脱阿罗汉。是时二种慧修。谓尽智无学正见尽智。行十四行。无学正见。行十六行。若依未至禅。三十法智修。三十比智修。乃至第四禅亦如是。若依空处。三十比智修。非法智。乃至无所有处亦如是。非时解脱阿罗汉。是时三种慧修谓尽智无生智无学正见。尽智无生智有十四行。无学正见有十六行。若依未至禅。有四十四法智修四十四比智修乃至第四禅亦如是。若依空处。有四十四比智分修。非法智乃至无所有处亦如是

诸心过去。一切彼心变易耶。乃至广说。问曰。何故作此论。答曰。为止于世中愚言无过去未来现在世是无为法。为止如是意欲明过去未来是有法故。而作此论

诸心过去。一切彼心变易耶。心变易有二种。一随世变易。二法变易。过去染污心有二种变易。一随世变易。二法变易。不染污心。唯一种变易。谓随世变易非法也。未来现在染污心。是法变易非随世也。不染污心非法变易。亦非随世变易。诸心过去一切彼心变易耶。答曰。诸心过去一切彼心变易。若为染污者。有二种变易。不染污者。有一种变易。谓随世变易。颇心变易。彼心非过去耶。答曰。有未来现在欲恚相应心。为明此义引佛经为证。如说佛告比丘。若伺贼以锯截汝支节。是时心变易。口不应恶言。若心变易。口出恶言。是汝留难。以是义故。恚相应心。是名变易。如说若比丘淫欲变心。以是义故。欲相应心。是名变易。问曰。一切染污心尽是变易。何以唯说欲恚相应心是变易。不说余使相应心耶。答曰。或有说者。此说有余。乃至广说。复有说者。应说余使相应心。而不说者。当知此义有余。复有说者。若正是佛经所说。此中则说。此二心正是佛经所说。是故说之。如是因论生论。何故世尊说欲恚相应心是变易。不说余使相应心耶。答曰。以欲能变身恚能变境界。所以者何。若于境界生爱。所有心心数法驰骋缘中。是时此身犹无情物。若于境界生恚。犹不能以面向之。何况正视。复有说者。此二能变身。能变生处。欲心能变身者。或有众生。起贪欲缠。能变男形使灭。女形使生。或有众生。起嗔恚缠。能使人身灭。使成蛇身。此中应说外道来作比丘喻。曾闻有尼揵子。来诣佛法出家时。诸比丘在其人前。说恶法中种种过患。其人闻已。于佛法生大嗔恚。以嗔恚故人身即灭。便成蛇身。云何欲心能变生处。如世尊说。告诸比丘。有游戏失念天。彼天若快意游戏受乐之时。身体疲惓心则失念。以失念故于彼命终。云何恚变生处。世尊亦说。有恚害意天。彼诸天心怀恚时。以恶眼相视。恶眼相视故恚心转盛。恚心转盛故。于彼命终。嗔恚复能变生处。如以恚心打他他人即死。复有说者。欲能变时。恚能变形。欲变时者。以欲故有婴孩少壮男女等时差别。恚变形者。以恚故。锯截他手足耳鼻种种身分。以此二法能坏时坏形故。是以说之。复有说者。以此二法能生憎爱种种过患故。是以说之。复有说者。此二法。速能令身色变异。是以说之

若心有染一切彼心变易耶。乃至广说。问曰。何故作此论。答曰。先说淫欲心变易。或谓唯淫欲心是变易非余。今说三界欲心尽是变易故。而作此论

若心有染。一切彼心变易耶。答曰。若心有染。一切彼心变易。若过去心。有二种变易。若未来现在。有一种变易。谓法变易。颇有心变易彼心非有染耶。答曰。有过去欲不相应心。若染污。有二种变易。不染污一种谓随世变易。未来现在恚相应心。如说。伺贼以锯截汝身体。乃至广说。如是心。是法变易非有染。问曰。现在心至过去名变易。未来心至现在。何以不名变易耶。答曰。若变易心。更不变易。故名变易。未来心至现在。复当变易。至过去故不名变易。复有说者。若所作变易。随世变易。是名变易。现在心。虽有随世变易。无所作变易。所以者何。犹有所作。复当变易。至过去世故。问曰。何故名伺贼耶。答曰。昼伺其便。夜则偷劫。问曰。何故以锯为喻耶。答曰。以刀截人。有入时痛出时不痛。有出时痛入时不痛。以锯截人。出入俱痛。是以为喻。若心有恚一切彼心变易耶。答曰。若心有恚一切彼心变易。如前所说。尽应说之。颇变易一切彼心非有恚耶。答曰。有过去恚不相应心。未来现在欲相应心。如是一切烦恼相应心。随相应说

阿毗昙毗婆沙论卷第十九阿毗昙毗婆沙论卷第二十

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    杂揵度无惭愧品下

一切掉尽悔相应耶。乃至广说。问曰。何故作此论。答曰。世尊说掉与悔作一盖。或谓掉外无悔悔外无掉。欲说悔外有掉掉外有悔。决定义故。而作此论

一切掉尽悔相应耶。乃至广说作四句。云何掉不与悔相应。答曰非悔时心不休不息。乃至广说。彼是何耶。答曰。一切色无色界掉。欲界见道所断。四种掉。修道所断。五识身掉。意识地欲恚慢悭愱相应掉。如是等掉。不与悔相应。所以者何。彼品中无悔故。云何悔不与掉相应。答曰。不染污心悔。乃至广说。彼是何耶。如比丘畏戒故悔。若不自举。若使人举。露地卧具。若自闭若使人闭。大小行处门。若为作福悔。何者是耶。有悔因不善悔亦不善。有悔不善因善。有悔因善悔亦善。有悔善因不善。有悔因不善悔亦不善者。犹如有一作恶悔我所作恶少应当益作。有悔不善因善者。犹如有一作善后悔我何故作此善耶。如彼居士施辟支佛食。后便悔言。我宁以此食与奴婢作人何用施是人为。有悔因善悔亦善者。犹如有一作善后悔便悔言我作善少应当益作。如尊者阿尼卢头。作如是言。我若知此大德有如是威神者。我当益施其食。有悔善因不善者。犹如有一于戒不犯我作如是事非是善好。如不举露地敷具如是等戒是也。此四种中。悔善因善。悔善因不善。是悔不与掉相应。云何掉与悔相应。谓染污心悔是也。乃至广说。问曰。何故问掉应悔。而答悔应掉耶。答曰。此文应如是说。云何掉应悔。若心悔时。不休不息。乃至广说。而无说者。有何意耶。答曰。此说染污心悔。应于掉时。诸余染污心。唯掉相应。不与悔相应。复有说者。悔之与掉。体俱是盖。应作是问。云何掉与悔相应。悔云何与掉相应。云何掉不与悔相应。悔不与掉相应。除上尔所事。诸法已立名已称说者。作第一第二第三句。未立名未称说者。作第四句。一切睡眠相应耶。乃至广说。问曰。何故作此论。答曰。世尊说。睡与眠作一盖。或谓睡外无眠。眠外无睡。今欲说睡外有眠。眠外有睡。决定义故。而作此论

一切睡眠相应耶。乃至广作四句。云何睡不与眠相应。若身未动时。身重是说五识身睡。心重是说意识身睡。身心瞪瞢等余句亦如是。彼是何耶。一切色无色界睡。欲界不眠时睡。是谓睡不与眠相应。云何眠不与睡相应。不染污心眠梦。身动心不散心不行。五识在意。识中眠。不污染心者。善心不隐没无记心。是名眠不与睡相应。云何睡与眠相应。答曰。染污心眠梦。乃至广说。余句答余句如上掉悔中说

眠当言善耶乃至广说。问曰。何故作此论。答曰。此因论生论。先说不染污心眠梦。乃至广说。不说眠是善不善无记。彼中不说者。今欲说故。而作此论

眠当言善耶。乃至广说。答曰。眠或善不善无记。云何善。善心眠梦。是谓善。问曰。为是生得善心眠梦。为是方便善心眠梦耶。答曰。生得善。非方便善。问曰。何等众生善心中眠耶。答曰。不眠时。多修行善者。以多修行善故眠时亦善。如行者不眠时念其境界耶。念境界而眠。眠中还见本境界。诵经施主亦如是。如是众生善心眠。何等众生不善心眠耶。答曰。不眠时多作恶行者。如屠儿猎师昼作不善。眠梦亦然。如屠猎师盗贼淫人亦如是。如是等众生不善心眠。何等众生无记心眠耶。答曰。不眠时。多作无记行。亦无记心眠。还见无记事报。无记心中亦眠。威仪工巧心亦眠。还作威仪工巧事。身见边见隐没无记心亦眠。如本有阴。多修行善不善无记。善不善无记心而死不眠时。多行善不善无记。眠时亦善不善无记心而眠

眠中所作善增益。当言回耶。乃至广说。问曰。何故作此论。答曰。前说善心眠。乃至广说。不说眠所作善增益当言回耶不回耶。彼中不说者。今欲说故而作此论

眠中所作善增益当言回耶。乃至广说。或有说。得是增益。或有说。生是增益。云何说得是增益耶。如定揵度说。以何等故。凡夫人退时。见道修道所断烦恼增益。世尊弟子退时。唯修道所断烦恼增益。云何说生是增益。如施设经说。凡夫人若生欲界爱。必生五法。何谓为五。一欲界爱。二欲界爱增益。三无明。四无明增益五掉。此中说善不善思。得爱不爱果。说名增益。彼增益。为生爱果。为生不爱果耶。答曰。若善生爱果。若不善生不爱果。云何善增益。如眠梦时施与。如人常行布施。彼眠梦时。亦行是事。若好行多闻。彼眠梦时。亦行是事。读修多罗阿毗昙持戒善亦如是。若好修定。彼眠梦时。亦行是事。如修不净等善眠。是名善增益。云何不善增益。若好恶事。彼眠梦时。亦行是事。如猎师屠儿梦作杀事。贼取他财。淫人犯他女色。是名不善增益。云何非善增益。非不善增益。如人好行威仪工巧事。彼眠梦时。亦行是事。如行者梦作农夫种植。如铜铁师等梦作铜铁等物

问曰。若眠时所作善增益者。何以佛说愚人眠时无有果报。答曰。如不眠人。能作田种等作。以眠故不作。佛说是人言无果报。如不眠人。能读诵经。能修不净等善根。能生念处。能生暖等达分善根。能得须陀洹果斯陀含阿那含阿罗汉果。以眠故不得如是等果报。是故佛说愚人眠时无有果报。尊者和须蜜说曰以眠时得果少故。佛说无果

佛经中说。宁当眠莫起恶觉。问曰。若眠不善增益者。何故佛说宁当眠不起恶觉耶。答曰。以不眠时数数多起恶觉故。眠时则少。以是事故。佛说宁当眠不起恶觉

问曰。眠时能作生处造业不耶。答曰。或有说者。能作恶道生处造业。如婆罗地迦虫曲蝉虫等。受此微怯弱之身是也

梦名何法。乃至广说。问曰。何故作此论。答曰。先说梦所作事。未说梦体。今欲说故而作此论。复次佛经说。我为菩萨时。梦见五事。波斯匿王梦见十事。如难陀迦母优婆斯。白佛言。我夫命过。为我现梦。余经说偈

  梦中共人会　　寤已便不见
  一切所有物　　死已亦不见

余经亦说。汝等当舍如梦之法。云何如梦法。五阴是也。乃至广说。佛经虽处处说梦而不分别。佛经是此论所为根本。彼中不说者。今欲说故而作此论。复有说者。譬喻者说梦。非实有法。彼以何故。作如是说。答曰。以世现事故。作如是说。如人梦中饮食饱足。诸根增益寤已饥渴。梦中梦作五乐。寤已都不复见。梦四种兵而自围绕。寤已独己。以是事故。梦非实有。为止如是说者意亦明梦是实有法故。而作此论

梦名何法。答曰。眠时心心数法。随其所缘。寤已不忘向他人说我梦见如是事。是名为梦。问曰。如梦所见事。寤已不忆。设忆不向他人说为是梦不。答曰。此亦是梦。此中所说。是满足梦。满足梦者。梦中所见。寤已不忘。亦向他人说者是也

问曰。梦体性是何。答曰。体性是意。所以者何以意力故心心数法生。复有说者。梦体性是心心数法。所以者何。如经本说。心心数法随其所缘。复有说者。心心数法境。是梦体性。所以者何。如经本说。心心数法随其所缘。复有说者。梦体性是五阴

问曰。何处有梦耶。答曰。欲界非色无色界。或有说者。欲界不尽有梦。如地狱众生。所以者何。以苦痛所逼故不得眠。复有说者。地狱亦有眠时。所以者何。如说活地狱中。或时有冷风来。如是唱言。众生活。众生活。时诸众生即便还活。冷风吹故暂时得眠。以是事故。知地狱中亦有眠梦。畜生饿鬼人亦有眠梦。问曰。何等人有梦耶。答曰。凡夫圣人俱梦。圣人从须陀洹至辟支佛尽梦。唯有诸佛不梦。所以者何。唯有诸佛。无有疑故。亦离一切无巧便习气故。问曰。梦中所见。为是所更事为非所更事耶。答曰。是所更事。非不所更事。问曰。若然者。梦见人有角。何处曾见有角人耶。答曰。此是乱想故。异处见人。异处见角。以乱想故。言是一处见人有角。复有说者。大海中有人形虫。头上有角。以曾见故。今亦梦见。问曰。如菩萨梦见五事。为于何处曾见是事耶。答曰。所更有二种。一者曾见。二者曾闻。菩萨所梦是曾闻。于何处闻。过去诸佛。为诸弟子说此五梦。菩萨于彼而得闻之。以曾闻故今亦梦见。问曰。谁现此梦耶。答曰。或有说者。是诸鬼神。为现吉不吉事。尊者和须蜜说曰。以五事故现梦。如偈说

  以疑心分别　　觉习因现事
  非人来相语　　因此五见梦

医方说。有七事故梦。如偈说

  或所更闻见　　所求亦分别
  觉习及诸患　　因此七见梦

问曰。如现在意识不能见色等。云何言梦是意地而能见色等耶。答曰。以见吉不吉相故言见。诸仙人说梦亦如是。尊者佛陀提婆说曰。眠时五识不现在前。不能见色等。如难陀迦母优婆斯所梦。以眠势衰微。是以能见色等。问曰。梦所念事多。第四禅地宿命智所念事多耶。答曰。梦所念事多。非第四禅地宿命智所念事多。以是事故。而作是说。颇不入禅。不起通现在前。能忆念阿僧祇劫事不。答曰有。谓梦中所念是也

仙人所说梦书。若人梦见如是事。当有如是果。问曰。如知未来世事。是愿智境界。彼不得愿智。何由能知耶。答曰。以过去现在事。比未来世事故能知。如诸仙曾有如是梦有如是果。今有如是梦。亦当有如是果。如此皆以比相故知

如经说。当舍如梦等法。云何是如梦等法。答曰。五阴等是也。问曰。以何等故。说五阴如梦。答曰。以不适人意。暂有不经久故。说阴如梦。问曰。于何处眠耶。答曰。如经先说。五道中有眠。中阴中亦眠。在母胎诸根具者亦眠。乃至佛世尊亦眠。问曰。如萨遮尼揵所说。若人眠者。其人亦愚所以者何。以是盖故。此云何通。答曰。非一切眠尽是盖。有眠是盖。有眠非盖。眠非盖者。佛起现在前。欲调适身故。眠是盖者。佛不起现在前。所以者何。已离一切愚故有五盖。五盖摄一切盖耶。乃至广说。问曰。何故作此论。答曰。佛经说五盖。或谓唯五盖更无余盖。欲明五盖外更有无明盖故。而作此论。五盖摄一切盖一切盖摄五盖耶。答曰。一切盖摄五盖非五盖摄一切盖。乃至广说。五盖者所说者是也。一切盖者第六无明盖是也。彼一切盖能摄五盖。以多故。五不摄一切。以有余故。如以大器覆小器则遍。小器覆大器则不遍。彼亦如是。一切摄五。非五摄一切。不摄何等。谓无明盖

佛说无明覆爱结系愚小得此身聪明亦然。问曰。如无明是盖亦是结。爱亦是盖亦是结。何以唯说无明覆不说爱覆耶。答曰。或有说者。欲现种种文种种说故。若有种种文义则易解。复有说者。盖义是覆义。更无有结覆众生慧眼如无明者。系义是结义。更无有结系于众生如爱结者。犹如一人有二怨家。一缚其手足。二以土坌其目。是人被缚无目。不能有所至。如是无明覆众生慧眼。爱结系之。不能起向涅槃。以是事故。尊者瞿沙作如是说。以无明覆爱结系故。不善法得生。是中应说。一名伊利摩。二名摩舍输贼。尊者佛陀罗测说曰。此现二门。乃至广说。如说。无明覆爱结系。说爱结覆无明系亦如是。以是故。欲现二门义。乃至广说。问曰。以何等故。不说无明盖在五盖中耶。答曰。覆义是盖义。此五法覆势用等无明覆势用偏多。如一无明盖覆势用胜于五盖所覆势用。复有说者。以无明体重故不立无明盖。在五盖中

诸盖尽覆耶。乃至广说。问曰。何故作此论。答曰。先解经中五盖所不摄无明盖。今欲说阿毗昙义一切烦恼尽是盖。所以者何。一切烦恼尽覆此身中故。以是事故。尊者迦旃延子。作如是问。诸盖覆耶。乃至广作四句。云何是盖非覆。过去未来五盖是也。所以者何。以是盖相故言盖。过去盖所作已竟。未来盖所作未生。故不名为覆。云何覆非盖。除五盖诸余烦恼现在前。何者是耶谓色无色界一切结。欲界系诸见慢无明盖所不摄。诸缠现在前时是也。云何盖亦覆。五盖展转现在前。若不眠欲爱盖现在前时。三盖现在前。谓欲爱睡掉盖。眠时有四。即增眠盖。嗔恚痴悔说亦如是。不眠睡盖现在前时。二盖现在前。谓睡掉盖。眠时三盖现在前。即增眠是也。云何非盖非覆。除上尔所事。诸法已立名已称说者。作第一第二第三句。未立名未称说者作第四句。何者是耶。行阴作四句。在三世五盖。现在烦恼五盖所不摄者。如是法。作第一第二第三句。诸余相应不相应行阴全四阴无为法。如是等法。作第四句。问曰。如过去烦恼覆过去法。未来烦恼覆未来法。现在烦恼覆现在法。何以故但说现在烦恼是覆。不说过去未来耶。答曰。或有说者。若说现在。当知亦说过去未来。复有说者。现在烦恼。能障圣道。过去未来烦恼。不能障圣道。复有说者。现在烦恼。能取依果报果。非过去未来。复有说者。现在烦恼能取果与果。非过去未来。复有说者。现在烦恼现呵责。染污此身堕不是处。非过去未来。复有说者。现在烦恼能生世愚及缘中愚。复有说者。现在烦恼。有所作。复有说者。现在烦恼障碍所依所行所缘。复有说者。或有为法。或有为人。若为法而言。过去法为过去烦恼所覆。未来现在法为未来现在烦恼所覆。若为人而言。则现在烦恼名覆人。如世人言。谁为烦恼所覆。谓不得解脱人为烦恼所覆。现在阴界入假名为人。过去未来阴界入假名为法。以是事故。现在烦恼名覆。非过去未来也

一切欲界系无明使。尽不善耶。乃至广说。问曰。何故作此论。答曰。或有说。一切结使尽是不善。如譬喻者作如是说。一切烦恼尽是不善。所以者何。无巧便故欲止如是说者意。亦欲说欲界身见边见及相应无明色无色界一切结尽是无记故。复有说者。一切欲界烦恼。尽是不善。一切色无色界烦恼。尽是无记。今欲现欲界身见边见及相应无明亦是无记。以是事故。欲止他义显于己义。亦欲说法相相应义故。而作此论

一切欲界系无明使尽不善耶。答曰。诸不善者。尽欲界系无明使。颇有欲界无明使非不善耶。答曰有。欲界身见边见相应无明使是也。问曰。何故欲界身见边见相应无明非不善耶。答曰。若体是无惭无愧。与无惭无愧相应。从无惭无愧生。是无惭无愧依果者是不善。彼与此相违故非不善。复次此法非一向坏于期心。云何非一向坏于期心耶。答曰。体非无惭愧等故。复次此法不妨布施持戒修定等故。所以者何。计我见者。为我乐故行于布施。为我生善道故行于持戒。为我得解脱故而修于定。边见随身见后生。彼相应无明亦尔。复次此二见。于自法中愚不逼切他。所以者何。我见者。不如是说眼能见色是可见。作如是说。我能见我所是可见。乃至意知法说亦如是。此见未曾逼切于他。边见随身见后生故。相应无明亦尔。复次以此见不能生报故。尊者和须蜜作如是说。何故身见边见是无记耶。答曰。以不能生身口粗业故。问曰。不善烦恼亦有不能生身口粗业者。可是无记耶。答曰。现在虽不起后增益时。能起身口粗业。身见边见终不能起。复次此见不能令众生堕于恶道。问曰。不善烦恼亦有不能令众生堕恶道者。可是无记耶。答曰。不善烦恼后增长时。能令众生堕于恶道。身见边见终不能令众生堕恶道故。复次此见不能生不爱果故。问曰。若能得未来有。即是生不爱果。世尊亦说。比丘我不称美乃至弹指顷生未来有者。所以者何。有皆是苦故。边见随身见后生。相应无明亦尔。尊者佛陀提婆说曰。此二见是颠倒。能生诸烦恼。非安隐法故是不善。若当身见非是不善者谁是不善。世尊亦说。比丘若无明是不善。边见随身见后生。相应无明亦尔

一切色无色界无明使尽无记耶。答曰。一切色无色界无明使尽是无记。广说如经本。问曰。何故色无色界烦恼是无记耶。答曰。若体是无惭无愧。乃至是无惭无愧依果者是不善。色无色界烦恼。与此相违故非不善。复次此诸烦恼不一向坏期心。如上所说。复次以不能生报故。如是因论生论。以何等故。彼诸烦恼不能生报。答曰。此诸烦恼。为四支五支三昧所制持故。犹如毒蛇为咒所持不能螫人。彼亦如是。复次彼无报器故。若当色无色界烦恼当生报者。应生何报。必生苦报。苦报在欲界。不可以色无色界行欲界中受报。复次彼烦恼。非一向受于颠倒。亦少有所因。如色无色界邪见谤苦。彼有少乐故。亦有少胜见取见第一。亦有少净戒取见净。如色界道能净欲界。色无色界道。能净色无色界道。能净无色界。尊者和须蜜说曰以何等故。色无色界烦恼是无记。答言。不能生身口粗业。广说如上。尊者佛陀提婆说曰。若当色无色界烦恼非是不善者。谁是不善。世尊亦说烦恼生业。一切见苦集所断无明使。尽是一切遍耶。问曰。何故作此论。答应如上一切遍因中说。一切见苦集所断无明使。尽是一切遍使耶。答曰。诸一切遍。尽是见苦集所断无明使。颇见苦集所断无明使非一切遍耶。答曰有。非一切遍使相应无明。何者是耶。欲恚慢等相应无明。随相而说

云何不共无明使。答曰。不说苦于苦不忍不可。余谛亦尔。此心一向愚。一向劣。一向痴。是故说不共无明。问曰。若然者。云何非是邪见耶。答曰。邪见谤言无苦。此不欲忍苦。犹如宿食不消憎于乳食。彼亦如是。或有说者。上已说体。所行云何。答曰。无知黑闇愚痴是也。复有说者。先说所行。如不说苦于苦不忍不可是也。问曰。若然者。波伽罗那经所说云何通。如说云何无明使所使。答言若无知黑闇愚痴是也。答曰。彼说无明所行不尽有烦恼所行彼中不说。复有说者。不说苦等。是说无明所缘

问曰。云何是不共义耶。答曰。罽宾沙门作如是说。不与缘四谛烦恼相应故名不共。复有说者。此使缘于四谛。唯是凡夫所行故名不共。尊者婆已说曰。不共余烦恼故名不共。所以者何。以远离烦恼所行各异不待烦恼而生故名不共。尊者婆摩勒说曰。与烦恼别异不共一意故名不共。复有说者。与烦恼别异不共方便故名不共。问曰。不共无明。为是五种所断。为是见道所断耶。若是见道所断者。识身经所说云何通。如说彼是修道所断。不共无明相应心。若是五种者。此中何以不说耶。答曰。或有说者。见道所断。问曰。若然者。识身经所说云何通。答曰。此文应如是说。彼是修道所断。无明使相应心。应作是说。而不说者有何意。答曰。识身经所说。不说不共无明使。若以自功力不因他生者。是不共无明。彼虽不与烦恼相应。不以自功力因他而生。是故不是不共。复有说者是五种断。问曰。此中何以不说耶。答曰。或有说者。若无明缘四谛。不与余使相应故名不共。修道所断无明。有不与烦恼相应者。不缘四谛。复有说者。若不与诸使相应。唯凡夫所行者。是中则说彼修道所断。虽有不与烦恼相应。而是凡夫圣人所行。是故不说。问曰。修道所断不共无明使何等心边可得耶。答曰。欲界十小烦恼大地。色界初禅地谄放逸。第二禅乃至非想非非想处放逸俱者是也。问曰。于何时现在前行耶。答曰。若人起正见。若人起见。心疲劳已。或时起如是等不共无明不共无明不说苦。乃至广说。问曰。如一切心中尽有慧。何以说不忍可苦耶。答曰。为无明所蔽故彼慧不明不了。颇有使不为俱使所使耶。答曰有。缘使已断不共无明使是也。颇有使不为使所使耶。答曰有。即前者是也。颇有使不能使耶。答曰有。无漏缘不共无明使是也。云何不共掉缠耶。答曰。无不共掉缠。问曰。何故作此论。答曰。为止人疑故。如有不与烦恼相应不共无明使亦谓有不共掉缠为止如是疑意故。答曰无不共掉缠。所以者何一切染污心中。尽有无明使。复次如有不与烦恼相应不共无明使。亦谓有不与缠相应不共掉缠。为断如是疑意。答言。无不共掉缠。所以者何。一切染污心有睡掉故。以是事故而作此论

问曰。如睡掉通三界五种断。六识身一切染污心可得。何故不问睡。但问掉耶。答曰。或有说者。作经者意欲尔。乃至广说。复有说者。以掉多放逸过生诸罪咎故。以多过患故波伽罗那经。立掉为烦恼大地。此经本中问。云何不共掉缠。亦立为上分结。施设经亦说。凡夫起欲爱使时。五法现在前。谓欲爱使欲爱使增益。无明使。无明使增益。掉睡无如上等过故不问。复次掉能发动四支五支定觉心。睡随顺三昧。与三昧相似若睡现在前时。如入禅者。复次睡为无明所蔽。似无明所行。愚小不猛利。掉不与无明相似猛利。是故问掉不问于睡。复次睡依于无明。若说无明。当知已说睡复有说者。修善时掉能令远善退失。令人心退故。发动睡则不尔复有说者。掉能令三昧中心心数法散乱。亦于所缘事移动睡则不尔。复有说者。亦应问睡。此文应如是说云何不共睡缠答言。无不共睡缠。而不说者。当知此说有余。复有说者。若说掉当知亦说睡。所以者何。一切处共俱故

    阿毗昙毗婆沙论杂揵度色品第六

色法生住老无常。当言色耶。乃至广说。此章及解章义。是中应广说优婆提舍。问曰。何故作此论。答曰。此是佛经佛经中说。告诸比丘。有三有为相。不解此经义趣故。诸家作种种异说。其义不同。如譬喻者说。三有为相。无有实体。所以者何。三有为相。是不相应行阴所摄。不相应行阴。无有实体。欲止如是说者意。亦明三有为相是实有法故。而作此论。复有说者。言此法是无为法。如毗婆阇婆提。作如是说。若此法是有为者。其性羸劣。以羸劣故。不能生法住法灭法。无为有力。以有力故。能令法生住灭。或有说。此二法是有为。一是无为。如昙摩掘部作如是说。二是有为谓生住。一是无为谓灭。若此是有为。其性羸劣。不能灭法。以是无为故能灭法。为止如是说者意。欲明此三法是有为故。复有说者。此法是相应。为止如是说者意故。复有说者。为止即彼法沙门意故。彼法沙门作如是说。色法生住无常。即是色体。乃至识亦如是。为止如是等说者意。欲显己义亦欲说法相相应义故。而作此论

色法生住老无常。当言色耶非色耶。答曰。当言非色。问曰。非色入有二种。谓意入法入。为意入所摄。为法入所摄耶。答曰。法入所摄非色法。当言非色。即法入所摄。可见法。当言不可见。不可见法。有十一入。除色入。彼非眼入乃至意入所摄。是法入所摄。不可见法。当言不可见。即法入所摄。有对法当言无对。无对是二入。谓意入法入。非意入所摄。是法入所摄。无对法当言无对。即法入所摄。有漏法当言即有漏。从是已后还与彼法相似。无漏即无漏。有为即有为。以是义故。为止说有为相是无为者意故。无为法无过去未来现在当言即过去未来现在。问曰。何以过去法得通三世。生住老无常唯过去耶。答曰。过去法得与彼。不同一果。不共行。相离不相随。于彼聚为非聚。如树皮离树。生等不尔。与彼同一果。乃至广说。如过去者。未来现在说亦如是。善不善无记。当言即善不善无记。三界系不系。学无学非学非无学。见道所断。修道所断不断。说亦如是

云何老云何死云何无常。问曰。何故作此论。答曰。先说真实义有为相。今欲说假名有为相故。复有说者。先说刹那无常。今欲说一世无常故作此论。云何为老。乃至广说。问曰。此中何故不问生耶。答曰。或有说者。彼作经者意欲尔。乃至广说。复有说者。若法于彼法无增益。令彼法散坏者。是中则问。生于彼法。能令增益炽盛。是故不问。复有说。若法能令彼法相离相远。此中则问。生能令彼法相近相随。是故不问。云何为老。答曰。发白零落身体皮皱转转损减身形曲膢。气息损少。身生黑点犹如彩画。扶杖而行。恒患颠伏。行步迟微诸根渐损。转转衰熟。举身战掉是为老。云何为死。答曰。诸行散灭是名为死。如说若死即无常耶。云何死是无常。云何无常非死。答曰。或有说者。最后命根灭一刹那。是名为死。亦名无常余。时阴散灭。是名无常。不名为死。复有说者。与最后命根俱灭五阴。是名为死。亦名无常。余时阴散灭。是名无常。不名为死。复有说者。一生中命根散灭。是名为死。亦名无常。余阴散灭。是名无常。不名为死。复有说者。一生中与命根俱五阴散失。是名为死。亦名无常。余阴散失。是名无常。不名为死。复有说者。众生数阴散失。是名为死。亦名无常。非众生数阴散失。是名无常。不名为死。问曰。业力强无常力强耶。答曰。业力强非无常。业是圣道。无常即无常。世尊。或说道是受。或说是想。或说是思。或说是意。或说是灯明。或说是信进念定慧。或说是筏是石是水是花。或说是慈悲喜舍何处说道是受。如说我实觉苦圣谛。何处说道是想。如说比丘修行广布无常想能断欲爱。乃至广说。何处说是思。如说有业无黑报无白报能尽业。何处说是意。如偈说

  意能烧屋宅　　亦不染于缘
  谓佛天人师　　应受一切供

何处说是灯明。如偈说

  汝起莫放逸　　以戒自调伏
  如是等灯明　　驰流不能灭

何处说是信。如偈说

  信能度大河　　不放逸亦然
  精进除众苦　　慧能到解脱

何处说精进。如说佛告阿难。精进能增长菩提。何处说是念。如说佛告比丘。我说念过一切处。我圣弟子。具足念力。守护。根门。则离不善法。能修善法。何处说是定。如说有定是正道无定是邪道。有定心得解脱。非不定。如是等是也。何处说是慧。如偈说

  慧为世间上　　趣向于至真
  若能正知此　　必尽于老死

何处说是筏。如说比丘当知。筏者即八圣道。何处说是石。如说比丘当知。此是正见大石山。何处说是水。如说比丘当知。此八圣道。是八味水。何处说是花。如说此七觉意花。何处说是慈悲喜舍。如说修慈心三昧。得阿那含果。悲喜舍亦如是。此中说道是业。是故说业力强非无常。业能灭过去未来现在行。其灭是数灭。无常灭现在行。其灭是无常灭。或有说无常力强非业力。所以者何。业能灭过去未来行。无常能灭彼业。若人能杀千人敌者。是人名为二千人敌。彼亦如是是故无常力强非业力。如我义者。业力强非无常力。所以者何。业能令过去未来现在行不行境界。无常何所灭耶。复有说者。业名和合。无常名坏和合。为业力强。无常力强。答曰。业力强非无常力。所以者何。和合事难。坏和合易。复有说者。无常力强非业力。所以者何。彼和合者。必有别离。如我义。业力强非无常力。所以者何。和合事难。坏和合易。如人作瓶时难坏瓶时易。复有说者。若业能作五道受生处造业。是业力强。非无常力。复有说者。无常力强非业力。所以者何。彼业亦为无常所坏。如我义。业力强非无常力。所以者何。法造时难坏时易。此中亦应说瓶喻

世尊说三有为相。问曰。何故作此论。答曰。为止他义故。如譬喻者。不欲令一刹那中有三有为相。彼作是说。若一刹那中。有三有为相者。则一法一时。即生即老。即无常。问曰。若然者。其义云何。答言。法初时名生。后时名无常。此二中间名老。如是说者。则一刹那中。无三有为相。此说不如实分别。所以者何。说一生中相似法故。一生中。初生者名生。最后者名无常。此二中间名老。若作是说者。则一法无三相。为止如是说者意。亦明一法有三相故。问曰。若一法有三相者。云何不一法一时即生即老即无常耶。答曰。所作异故。所以者何。法生时。生有所作。法灭时。老无常有所作。以所作次第各异故。而无有过。是故为止他义。欲显己义亦欲说法相相应义故。而作此论。此三有为相。有为法。有生有灭有住变。云何有为法一刹那中。有生有灭有住变耶。答曰。法起时生。生彼法。法灭时灭。灭彼法。住变是老。老能熟彼法。问曰。若然者。法体是变异者。云何法不舍自体耶。若不变异者。何以说住变是老。答曰。应作是说。法体无变异。问曰。何以说住变是老耶。答曰。此是老名老。名为老亦名住变。复有说者。以其体不异故。名不变异。所作异故。名为变异。所以者何。法生时所作异。灭时所作异。云何生时所作异。灭时所作异。答曰。法生时有力。有功能。有所作法灭时。衰退散坏。以是义故。言有变异。复有说者。法迅速故生。迅速迟微故灭。湿润故生。萎枯故灭。复有说者。以经三世故变异。所以者何。过去法异未来现在法

问曰。此相为是总相。为是别相耶。若是别相者。云何一法而有四相。若是总相者。诸法各自有相。云何是总相耶。答曰。或有说者。此相是别相。问曰。若然者。云何一法而有四相。答曰。此说自相。非如火热。是自相如受自有生住灭受生住灭不能生乃至识。是故言自相。诸法各各自有别相。如色是不久散坏。如病如痈如疮如箭等。百四十种相。相有二种。一者旧相。二是客相。生等于彼法。是客相非是旧相。合聚他物相。本自体相亦如是。复有说者。是总相。问曰。若然者。诸法各自相。云何是总相耶。答曰。相似相。如一法有三相。一切法亦有三相。复有说者。非别相亦非总相。所以者何。非自体故非别相。各有相故非总相。问曰。若此非总相非别相者。当言是何法耶。答曰。此是诸法印帜。若法有此印帜是有为。无印帜者是无为。如大人相非大人体。若有此相者。名为大人。若无此相者。不名大人。彼亦如是。评曰。不应作此说。说总相者好

问曰。法生时。除其自体。余一切法。能生此法。何故唯说能生生此法耶。答曰。法生时。余法虽有功。不名能生。唯生体能生。如女人产时。诸余女人。虽复佐助。不名为产。唯母名产。彼亦如是。尊者和须蜜说曰。唯生能生彼法。非余法。所以者何。若无生者。则彼法不生。问曰。若无余法。彼法亦不生。复次若有生彼法。生非无生。问曰。亦有余法作缘使此法生非无余法缘。尊者佛陀提婆说曰。法生时。生势最胜故生得其名。余法不尔。如作伎书画染法。作伎时。非无伎子毗头梢等而伎得成。然彼伎成师得其名。如画非不因笔墨纸等。而人受其名。画时非不因众彩。而人受其名。染时非不因盆水等。而染者得名。彼亦如是

问曰。生相为有生相不。若有者云何非无穷。彼生复有生故。若无者谁生此生。答曰。应作是说。生相复有生相。问曰。若然者。云何非无穷。答曰。无穷有何过。未来世宽。无住处耶。又生死是无穷法。以是事故。难除难过。能生众生无量连琐之苦。复次此二同在一刹那中。故非无穷。彼一刹那中。生生二法。一生法。二生生生。生生唯生生。问曰。何故生生二法。生生唯生生。答曰。如是亦无有过。犹如女人有生一子者有双生者。复有说者。生相生八法。谓彼法生生老后老住后住无常后无常生生生一法。谓生。问曰。何故生生八法。生生唯生生。答曰。是亦无过。犹如猪犬狼豺等。或生一子或生多子

问曰。诸行为有住相不。若有者有为相中。何以不说。此经复云何通。如说。诸行不住。犹如寿行。乃至广说。若无者此文云何通。如说色法生老住无常。当言色耶。乃至广说。波伽罗那经亦说。云何住诸行生不散坏。答曰。应作是说。诸行有住相。问曰。诸行有住相者。有为相中。何以不说耶。答曰。应说有为法有四相。若不说者。当知此义有余复次住相似无为法故。不说是有为相。复次若相能令诸行历世者是有为相。如生移未来行现在世。老无常移现在行在过去世。住与彼法相着无舍离时。复次分别诸相时。三相堕有为部中。住相堕无为部中。复次若相能令诸行不增益散坏者。说是有为相。住能令诸行增益不散坏。不说是有为相。问曰。若然者生能令诸行增益不散坏。何以说是有为相耶。答曰生能令诸行增益散坏其于老无常。所以者何。若生不生诸行。在现在者。则老无常不能散坏以生生诸行在现在世故。老令衰微。无常能坏犹如有人虽居牢固之处有三怨家。一于牢固之处。挽其人出。二共断其命。此三于彼人俱作不饶益事。若一人不于牢固之处挽出者。则二人无由断其人命。彼亦如是问曰。若诸行有住相者。佛经云何通耶。答曰。佛经说不住。无有久住相。非谓一刹那。如命根等。复次言无住者。无长久时住。住相谓少时住。复次刹那中。住相微细。唯佛所知。所以者何。如以神足屈申臂顷。从此间没。住须弥山顶。于其中间。众多刹那相续。非不相续。是故言从此至彼。如是等相。唯佛境界。非余所知。是故经说无有住相。复有说者。虽有少时住。速为老所衰无常所灭。是故住相有如是过患故佛经不说。复有说者。诸行无住相。是以有为相中不说。佛经善通。此文云何通。如说。色法生老住无常。乃至广说。答曰。此文应如是说。色法生老无常。乃至广说。不应言住。若言住者。有何意耶。答曰。此住是老异名如生名生亦名出现。无常名无常。亦名灭尽。老名老。亦名住。评曰。应作是说。诸行有住相。若诸行无住相者。不能有所缘。欲令无如是过故。说诸行有住相

问曰。何者是变异。为以灭故坏故以为变易故言变异耶。答以灭故言变异者。变异与灭。则是一体。有为法。唯有二相。若以坏者。则法舍自相。若以变易者。云何不助成外道。作如是说。诸法变易。答曰。应作是说。势衰故言变易。所以者何。诸行势盛故生。势衰故言变异。复次诸行有力故生。衰劣故变异。复次诸行未熟名生。已熟名变异。复次诸行渐羸故变异。复次诸行新故名生。旧故名变异。问曰。若然者。云何不助成外道义。答曰。诸行相续不住。外道计有住时。住灭言是变。如乳作酪。如薪作灰。不说刹那势衰故变异。此说刹那势衰变异。不说住时变异。问曰。此有为相与所相。为一为异耶。若一者。云何一法不为多法耶若异者。相与所相则异者。何故不以余相为相。答曰。应作是说相所相不一。是故一不为三。三不为一。问曰。若然者。云何不以余相为相耶。答曰。随相所作处则相所相。是故无过。复次相与所相。常不相离。若相离者。可以余相为相。以相所相不相离故。无如是过。如是杂合不相离共说亦如是。复次相从所相生。生所生异。如烟虽从火生烟火各异。彼亦如是。复次相是所相过患。如病是人之过患。人异病。若当不异者。人病愈时。应当无人。余亦如是。复次佛说此相是有为相。以是言故。当知相异所相。如言此人舍亦如是

问曰。一切刹那中。尽有老者。何以不一切时头生白发耶。答曰。不应作如是问有白发无白发。然老与壮年。或有相妨。或不相妨。相妨者。不生白发。不相妨者。头生白发。复次或有羸弱四大多强盛四大少。或强盛四大多羸弱四大少。若羸弱四大多。强盛四大少。头生白发。若强盛四大多。羸弱四大少。不生白发。多力少力亦如是。复有说者。白发非老。白发是色。老是非色。但此身后时。生如是报滓不好之法。犹如麻油。亦如木酒。后欲尽时。必生浊滓。彼亦如是。问曰。何处有此白发。答曰。界者欲界中。有非色无色界。趣者人畜生饿鬼中。有方者三方有。非郁单曰。所以者何。白发是罪报。彼方非受罪报处。问曰。谁有此白发耶。答曰。凡夫圣人俱有。圣人从须陀洹。至辟支佛。唯除世尊。所以者何。佛世尊无发白渐落皮缓面皱音声破坏。死时无解支节。痛心不错乱。根不渐灭。一时而灭。此是佛身之法。问曰。以何等故佛世尊。无白发渐落皮缓面皱耶。答曰。此是恶色。佛世尊永离恶色故。问曰。佛作何业。无如是报耶。答曰。佛世尊。本为菩萨时。修行善法。信心坚固。未曾衰退。以行相似因故。受如是相似果。以是事故。无白发渐落皮缓面皱

问曰。若一切刹那中。尽是无常者。何以不一切时有死尸现耶。答曰。不应问此事有死尸无死尸。所以者何。有相有相法异。无相无相法异。有心无心说亦如是。复有说者。以根法灭生有根法。所以无死尸。有根法灭。生无根法。所以有死尸。有心无心。众生数非众生数。内法外法。说亦如是。复有说者。众生业力故所以有。众生业力故所以无。众生业力故所以有者。众生须皮肉筋骨齿爪毛角等。以为资生具。所以便有。众生业力故所以无者。一日夜。二十不满。有六十五百千刹那。一一刹那。有五阴生灭。若当一一刹那有死尸者。则一众生死尸。满于世间。以众生业报。所以无。问曰。化生众生。何以无死尸耶。答曰。或有说者。以生时顿得诸根死时顿舍诸根故。如人水中暂出暂没不知没至何所出从何来。复有说者。化生众生。其身轻漂。犹如火焰。风吹至空。不知去处。云雾电光。亦复如是。复有说者。四大多者有死尸。彼造色多故无死尸。复有说者。受身非根法多者有死尸。受身非根法少者无死尸。复有说者。受身可舍法多者有死尸。受身可舍法少者无死尸。可舍法。谓发毛爪齿等也

问曰。有为法。为体是生故生。为与生合故生耶。若体是生者。生相何所作。若与生合生者。何故不与无为法合而使无为法生耶。答曰。应作是说。体是生相。问曰。若然者。生相何所作耶。答曰。虽体是生。由生相故显发。犹如闇中有瓨瓶等物。而由灯显发。不从灯生彼亦如是。复有说者。与生合故生。问曰。若然者。何以不与无生法合。令使无为法生耶。答曰。以无合义故。若有者亦应生。无常说亦如是

问曰。如有为法有三有为相。无为法有三无为相不耶。若有者。云何无为法非是聚法耶。若无者。波伽罗那经所说云何通。如说。云何不生法。答曰。无为法。以无生相故。云何不住法。答曰。无为法。以无住相故。云何不灭法。答曰。无为法。以无灭相故。答曰。应作是说。无为法无无为法相。问曰。若然者。波伽罗那经所说云何通。答曰。对有为法故。如有为法有生住灭。无为法无生住灭故。作如是说

佛经说。汝等比丘。即出现。即生。即没。即灭。问曰。出现与生有何差别。没与死有何差别耶。答曰。或有说者。无有差别。所以者何。出现即生没即死。同是刹那性故。尊者波奢说曰。受中阴身。是名出现。受生阴身。是名生。坏中阴身。是名没。坏生阴身。是名死。复次卵生胎生湿生众生。受身时是出现。所以者何。眼等诸根。渐出现故。化生众生。受身是生。所以者何。顿得眼等诸根故。舍卵胎湿生众生身。是名死。所以者何。有死尸故。舍化生众生身。是名没。所以者何。以无死尸故。尊者和须蜜说曰。入母胎时名生。出胎时名出现。代谢诸阴是名没。死时阴是名死。尊者佛陀提婆说曰。诸趣中。初受身时名生。已在趣中诸阴名出现。中阴中死。向生阴中是名没。舍命根时阴是名死

阿毗昙毗婆沙论卷第二十阿毗昙毗婆沙论卷第二十一

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    杂揵度无义品第七上

  诸他修苦行　　当知无义俱
  毕竟无有利　　如陆地船箄

如此章及解章义。此中应广说优波提舍。问曰。何故作此论。答曰。虽一切阿毗昙尽皆说佛经然此品偏多。所以者何。此论品多以经为论。复次所以作此论者。此是佛经。佛经中说。佛在优楼频螺村尼连禅河边菩提树下。成佛未久。尔时世尊。告诸比丘。我远离苦行。于此苦行。快得解脱。以自愿力故。今得第一菩提。时诸比丘。闻佛所说。深生爱乐。一心不乱。摄耳听法。尔时恶魔波旬。作如是念。沙门瞿昙。今在尼连禅河边优楼频螺村菩提树下。坐为弟子说法。乃至摄耳听法。我今应往为作留难。尔时恶魔。化作婆罗门摩纳婆像。往诣佛所。到已说如是偈言

  汝今舍苦行　　众生清净道
  若更行余道　　毕竟无有净

此偈义者。时魔语世尊言。汝舍古先苦行之道所依耶。不能令人净而生净想。魔以无是净。种种苦行是净道。佛语恶魔。非我不能行于苦行而舍之也。我谛观察此道。不能断烦恼。以无所能故。而我舍之。以是事故。而说此偈

  诸他修苦行　　当知无义俱
  毕竟无有利　　如陆地船箄

诸修苦行。有何义耶。答曰。或有说者。此法之外所行。尽言为他说法者。谓八圣道。及圣道方便。除此余是也。以道是邪道故。与无义俱。以是事故说。诸他修苦行当知无义俱。复有说者。他者言下贱。非他言妙胜。诸外道所行苦行。是下贱法。所以者何。以计我故。是故说诸修苦行当知无义俱。复有说者。他言不死。不死者恶魔也。是故世尊。告不死者。诸他修苦行当知无义俱。复有说者。诸为生天修苦行者。是苦行皆言不死苦行。以是事故。而作是说。诸他修苦行当知无义俱。必竟无有利如陆地船箄。无用邪见所行苦行。不能断结。无用亦如是。时魔复语佛言。若种种苦行是邪行者。汝以何道。而自净耶。尔时世尊。即说此偈

  我修戒定慧　　如是究竟道
  今已逮清净　　无有上菩提

佛经虽作是说。而不广分别。此论即是佛经优波提舍。佛经是此论根本诸佛经中所不说者。今欲说故。而作此论

问曰。世尊何故说诸他修苦行当知无义俱。答曰。此是老死道。近老死法。随顺老死法。不能以是法得尽老死道。所以者何。众生欲度老死海。行此苦行。此诸邪见。所行苦行。还令众生没老死海。尊者瞿沙说曰。一切增长法是无义。一切寂灭法是有义。邪见苦行苦行。是随顺增长法。以随顺增长故。不能生寂灭法。众生欲度老死海故。修诸苦行。而此苦行。必令众生堕老死海。所以者何。以行邪方便。邪方便者。为生天故。行此苦行。是故言堕老死海中

又世尊言。正身结跏趺坐。系念在前。乃至广说。问曰。如一切威仪尽中行道。何故但说结跏趺坐。答曰。或有说者。此是旧所行法所以者何。过去恒河沙诸佛。及佛弟子。尽行此法。复有说者。能生他人恭敬心故。若结跏趺坐起于恶觉犹生他人恭敬之心。是故欲生他人恭敬心故。复有说者。此法非是世俗爱欲法故。余威仪者。世俗用之。复次此法能生三种菩提道故。声闻辟支佛佛菩提。不以余威仪得。但以是得。复次此法行道时。随顺安隐。非余威仪故。复次此法能坏魔军。如佛世尊结跏趺坐能破烦恼及天魔军。复次此法能适可天人心故。复次此法不与外道共故。余威仪与外道共。云何名结跏趺坐。尊者波奢说曰。跏趺坐者。累两足正观境界。则得随顺定。跏趺坐。云何系念在前。面上故名系念在前。复次背烦恼在后。正观寂灭在前。故名系念在前。复次背生死在后。正观涅槃在前。故名系念在前。复次背色等境界在后。正观所缘在前。故名系念在前。复次系念在眼中间。故名系念在前。复次以胜慧力。正观境界。念念不散故名系念在前。复次念与不贪。俱缘于境界。故名系念在前。复次系念在眉中间。故名系念在前

观青想等。乃至广说。问曰。何故系念在面上耶。答曰。无始以来。男于女身起欲心。女于男身起欲心。多因于面。复有说者。以面是七入所依处。行者欲观察诸入故。复有说者。面是随顺不净观。所以者何。面上有七孔流出不净。以此处多出不净故。行者偏观。复有说者。非因照不于自面而生于爱。以不生爱故。系念在面。复次以面上能生猗乐。然后遍身。犹如受欲时。男女根边生乐。然后遍身。复次面上速能生欲心故。如见眼耳鼻口好相即生欲心。问曰。系念在面者。为是初行。为是已行。为是久行人耶。答曰。是久行人。行人有三种。谓初行已行久行。初行者。往至冢间。善取死尸相。谓若青若胀。若烂若坏。若骨若琐。若骨琐。善取如是相已。复观脚骨踝骨膞骨膝骨脑骨臗骨腰骨脊骨臂骨手骨腕骨肩骨项骨额骨齿骨髑髅骨。于冢间。善取如是相已。忆而不忘。速还住处。洗足坐绳床上若草敷上。忆念所见死尸。我身亦尔。如是名为初行。行者于所观境界。能令广亦能令略。云何名广。如观自身骨。观所坐床。亦复是骨。次观屋舍所住之坊僧伽阿蓝村落田地所有国土人民乃至大海内所有大地。皆观是骨。是名为广。云何为略。舍大海内所有骨。观一国土所有骨。舍国土内骨。乃至舍观外骨。唯观己身骨。能作如是广略观。是名已行。舍自脚骨。观自踝骨。舍踝骨。乃至观髑髅骨。髑髅骨有二种。有左分右分。若舍左分。观于右分。若舍右分。观于左分。舍于二分。系念眉间。是名久行。是时名为始入。身念处观。不净观。或有缘少自在多。或有自在少缘多。或有缘少自在少。或有缘多自在多。初句者。谓能数数观自身。于所观境界。不能令转广。第二句者。谓能观大海内骨。不能令此观数数现在前。第三句者。谓唯观自身。不能令此观数数现在前。第四句者。谓能观大海内骨。复令此观数数现在前。不净观。或有缘无量非自在无量。或有自在无量非缘无量。或有缘亦无量自在亦无量。或有缘亦非无量自在亦非无量。初句者。谓行者能观大海内骨。不能令此观数数现在前。第二句者。谓能观自身骨。数数现在前。不能令此观广。第三句者。能观大海内骨。数数现在前。第四句者。能观自身骨。不能令此观数数现在前。是名行者观于骨想。云何观揣食。不净想行者。观手中若器中食。此食为从何处来。知从仓中种种谷中来。观仓中谷。复从何来。知从田中种种种子中来。复观以何长养种子。知以粪水。粪复从何来。知从屎尿粪扫聚中来。如是观时。见不净物。还增益不净物。行者或时入村乞食。或在僧中。欲入村时。所受用水。而作尿想。所嚼杨枝。作臂骨想。所取衣。作人肉想。带作肠想。钵作髑髅想。杖作髀骨想。行石道上时。作髑髅骨想。若至村时。见墙壁屋舍。作骨聚想。见男女大小。作骨人想。其所得食糗。作骨糗想。盐作碎齿想。种种菜。作发想。[麩-夫+并]作皮想。饭作虫想。羹作脓粪秽想。生酥乳酪作脑想。酥油蜜石蜜。作人肪想。蒱桃浆。作血想。肉作人肉想。若入僧时。所受净草。作人发想。得糗等。作骨糗想。余如前说。问曰。行者何故作如是想耶。答曰。彼行者作是念。无始已来。不净为净念。应观此物。不净即作不净想。能作如是想者。能对治欲爱。复次欲对治欲爱故。作如是观。义言行者作师子吼。语不净分。我无始已来。取汝净相。今欲广取汝不净相

问曰。何以说不净观系念在前。不说阿那波那念观界方便耶。答曰。或有说者此说初起方便。如说不净观系念在前。亦应说阿那波那念观界方便。而不说者。当知此说有余。复有说者。随多分故。诸比丘。多修不净观。少有修阿那波那念者。是故说不净观。不说阿那波那念。尊者瞿沙说曰。随其入法时。所用系念在前。不必以不净观也。尊者迦旃延子。解佛经故。佛经说。正心系念在前。除世贪心住无贪法中。乃至断疑盖亦如是。五盖之中。何者最重。谓贪欲盖。不净观。是贪欲盖近对治。不净观。次第亦能断余盖。亦能起禅。是故以不净想系念在前。问曰。不净观体性是何。答曰。是无贪。若取其想应共有。则体是五阴。诸阿练若。说体是慧。所以者何。佛经说若能善摄诸根。是名见不净观。复有说者。不净观体。是厌厌名想。应心数法在如是等。是名心数法中。评曰。不应作是说。说是不贪者好。若取相应共有体。是四阴五阴

界者。是欲色界。地者是十地。谓欲界中间禅根本四禅四禅边。身者在欲界。行者非十六行别行不净行。缘者缘欲界色入。问曰。此为缘欲界一切色入不。答曰。尽缘。问曰。若然者。何以尊者阿尼卢头。不能于快意天身作不净观耶。曾闻尊者阿尼卢头。于一林中。跏趺坐禅。有四快意天女。自化其形。端正极妙。来诣尊者阿尼卢头所。作如是言。尊者阿尼卢头。我是快意天。能于四处。自在变化。若欲见我身何色者。我悉能现。以娱乐之。是时阿尼卢头。作是思惟。我今应当作不净观。即起初禅不净观。而不能令此观现在前。乃至欲起第四禅不净观。亦复不能。复作是念。彼是种种色。若当纯是一色。我则能起。即语天女言。诸姊妹。尽作青色。是时天女。即作青色。复作不净观。犹故不能。复作是言。诸姊妹。尽作黄色。是时天女。即作黄色。复起不净观。犹故不能。复语之言。诸姊妹。尽作赤色。是时天女。即作赤色。复起不净观。犹故不能。问曰。尊者阿尼卢头。何故语诸天女作种种色耶。答曰。彼作是念。移转其色。我或能起不净观。复次欲观彼色好不好相故。如是语。复作是念。白色随顺骨相。彼若作白色者。我能作不净观。即语言。姊妹。汝作白色。是时天女。即作白色。起不净观。犹故不能。复作是念。此诸天女。端正殊妙。即时默然。闭目不看。是时天女。忽然不现。如是义云何通耶。答曰。彼尊者阿尼卢头。虽不能观。余利根者能。如尊者目犍连舍利弗辟支佛佛。问曰。有能于佛身作不净观不耶。答曰。一切声闻辟支佛能观。而不能作不净想。所以者何。佛身极明净。极妙极胜。无诸过咎。众生乐见故。是故一切声闻辟支佛。不能作不净观。唯佛能观。复有说者。声闻亦能观。所以者何。不净有二种。一是色过患。二是色缘起。不能观色过患。而能观色缘起。不净观。复有二种。一是总相。二是别相。能观总相。不能观别相。念处者。根本而言。非念处方便而言。是身念处智者。与等智相应。根者。总与三根相应。定者。不与定相应。过去未来现在者。是三世法。缘过去未来现在者。过去即缘过去法。现在者即缘现在法。未来不生者。缘三世。当生者。缘未来。善不善无记者是善。缘善不善无记者三种尽缘。缘无记法多。三界系者欲色系。缘三界者缘欲界。学无学非学非无学者。是非学非无学。缘学无学非学非无学者缘非学非无学。见道断修道断无断。是修道断。缘见道断修道断不断者。是缘修道断。缘自身他身者。缘自身亦缘他身。缘名缘义者是缘义是离欲得。方便得者。亦是离欲亦是方便。离欲得者离欲界。欲得初禅地者乃至离三禅。欲得第四禅地者。最后身凡夫人圣人。得曾所得。亦得未曾得。其余凡夫。得曾所得。离欲得者。离欲时得。后作方便。起现在前。佛不以方便起现在前。辟支佛起下方便。声闻或作中方便。或作上方便。起现在前不净观。有作方便而得。后作方便起现在前。问曰。何等人能起不净观耶。答曰。凡夫圣人俱能。圣人者。从须陀洹。乃至阿罗汉。何处起者。答曰。先作是说。欲界中是三方。非郁单越。欲界天中。不能使初行现在前。所以者何。以无青等死尸故。先于人中得。后于彼起现在前。闻思修者。是三种。欲界者是闻思修。色界者是闻修。问曰。观一切是骨。而一切非骨。云何此观非颠倒耶。答曰。能断结故。非是颠倒。问曰。观房舍是骨。此观何所缘耶。答曰。或有说者。缘本所见冢间骨琐复有说者缘房舍中所有虚空界。评曰。此是虚想。观其所观。即缘彼法。如是说者妙。问曰。此不净观。为在意地。为在六识身耶。答曰。是意地缘于形色。非五识身。问曰。若是意地非五识身者。此经云何通。如说。眼见色作不净思惟。答曰。先眼识见色。后意地作不净思惟。复有说者。从其门从其道。如六喜观行。是意识地。从眼门道生。乃至身门道生。是故说六不净观。当知亦如是。问曰。从眼门道生不净观。作如是说者可尔。如彼经说。耳闻声。鼻嗅香。身觉触。意知法。作不净思惟。此云何通。所以者何。除色入余入。非不净观境界。答曰。或有说者。不净观不缘声等。更有胜行。能厌离声等。复有说者。为色爱所覆。修不净观。为声香味触法爱所覆。亦修不净观。故作如是说。复有说者。行者观形色是不净。形色所依声香味触法。更以胜不净观厌离行观。故作如是说。复有说者。行者善修不净观。能伏作色。复欲伏于声等境界。若能伏者善。若不能者。还修不净观。犹如斗军时。先安营垒。然后出阵。与怨共斗。若胜怨者善。若不胜者。便还营垒。彼亦如是。是故作如是说。经说。有五现见三昧。云何为五。如说。汝等比丘。当如实观察此身。从足至顶发。种种不净。充满其中。所谓发毛爪齿薄皮厚皮。筋脉肉骨心肺脾肾。肝胆澹荫大小肠胃。屎尿涕唾口中流涎。肪[月*冊]髓脑及以脑腕。脓血汗泪生藏熟藏。犹如有人。于门窗向观见仓中种种杂谷。谓胡麻粳米大。小诸豆大麦小麦等。比丘如实观察此身。亦复如是。若能如是观者。是名初现见三昧。复次比丘。如实观察此身。乃至广说。除去血肉。唯观白骨。识于中行。若能如是观者。是名第二现见三昧。复次比丘。如实观察此身。乃至广说。观于骨身。识于中行。亦住今世。亦住来世。若能如是观者。是名第三现见三昧。复次比丘。如实观察此身。乃至广说。但观骨身。识在中行。住于来世。不住今世。若能如是观者。是名第四现见三昧。复次比丘。乃至观身白骨。识在中行。不住今世。亦不住来世。若能如是观者。是名第五现见三昧。问曰。此五现见三昧。谁之所有。答曰。第一第二现见三昧。凡夫圣人所有。第三者。是须陀洹斯陀含所有。第四者。阿那含所有。第五者。阿罗汉所有。问曰。第一第二三昧。是现见可尔。所以者何。因现见生故。观识行时。云何是现见。答曰。现见是其方便。从现见生故。亦名现见。诸法立名处多。或以自体故立名。或以所依故立名。或以相应故立名。或以对治故立名。或以行。或以缘。或以行缘故立名。或以方便故立名。自体立名者。如谛如阴。谛者。体是逼切故名苦谛。乃至体是求故名道谛。体是色故名色阴。乃至体是识故名识阴。所依立名者。如眼识依眼生故名眼识。乃至意识依意生故名意识。相应立名者。如意业意行。如意触生爱。此法与意相应故立名。对治立名者。如法智比智。若法对治欲界。是名法智。若法对治色无色界。是名比智。行立名者。如苦智集智。所以者何。此智缘同行不同。缘立名者。如无相三昧。缘无十想法故。名无相行。缘立名者。如灭智道智。所以者何。此二智行不同。缘亦不同。方便立名者。如他心智空处识处五现见三昧。以现见为方便。生此定故。名现见三昧。问曰。不净观。何故名现见三昧耶。答曰。能生现见三昧故

问曰。何故佛不净观。独名无上耶。答曰。或有说者。佛不净观。能胜伏一切境界故。独名无上。声闻辟支佛所有不净观。不能胜伏一切境界。如尊者阿尼卢头。不能胜伏境界。不名无上。复有说者。佛不净观是骨观。观骨是骨。观筋肉等是筋肉。乃至广说。评曰。若作是说通。佛是少境界。不净观者。如前说者好。能胜一切境界故。独称无上

如佛告目揵连提舍梵天。何以不为汝说第六人住无相。乃至广说。问曰。何故作此论。答曰。此是佛经。佛经中。佛住舍卫国只陀林中给孤独精舍。尔时有三梵天。身光明照曜。以夜初分。来诣佛所。到佛所已。顶礼佛足。在一面立。时一梵天白佛言。世尊。婆翅多国。有众多比丘尼命过。第二梵天。复白佛言。世尊。彼命过者。有是有余涅槃者。第三梵天。复白佛言。世尊。彼命过者。有是无余涅槃者。时诸梵天。说是语已。绕佛三匝。忽然不现。尔时世尊。过此夜已。使敷床坐。于僧中坐已。告诸比丘。作如是言。昨夜初分。有三梵天。光明照曜。来诣我所。乃至第三梵天。说是语已。绕我三匝。忽然不现。尔时大目揵连。在彼众中。作是思惟。彼天有如是知见。言是有余涅槃无余涅槃者。是何天耶。尔时大目揵连。随其所应。即入三昧。三昧力故。于只陀林。忽然不现。住梵天上。去提舍梵天不远。尔时目揵连。从三昧起。诣提舍梵天所。到已作如是言。提舍。何等梵天。有如是知见。知是有余涅槃。知是无余涅槃。问曰。如目揵连知见。胜于梵天。百千万分。何以问于梵天耶。答曰。欲显提舍梵天功德故。此天本是目揵连弟子。得阿那含果。有大功德。彼诸梵天。无有识者。欲显彼功德令诸梵众恭敬尊重故。是以问之。时提舍梵天。答目揵连言。此梵身诸天。有如是知见。能知有余涅槃者。尔时目揵连。问提舍梵天。一切梵身诸天。尽有此知见。知有余涅槃无余涅槃不也。提舍梵天答曰。非一切梵身天有如是知见。乃至广说。此诸梵天。虽有天寿妙色名誉。而不知足。不知如实最上远离法者。无是知见。若诸梵天。有寿色名誉。而行知足。能知如实最上远离法者。有如是知见。尊者目揵连。复问提舍梵天。此诸梵天云何能知。提舍言。尊者目揵连。若诸比丘。得阿罗汉道是俱解脱。是诸梵天。作是思惟。若此大德有身之时。人天皆见。若身坏命终。人天更不复见。不但俱解脱。若比丘得阿罗汉。是慧解脱。是诸梵天。作是思惟。此比丘得阿罗汉是慧解脱。此大德有身之时。人天皆见。乃至广说。不但慧解脱也。若比丘是身证。此大德亦能胜进。得无学根见到信解脱语亦如是。问曰。彼诸梵天。何以不说坚信坚法耶。答曰。或有说者。若是彼天境界者则说。坚信坚法。非其境界。是故不说。复有说者。若是诸梵所行法者则说。此法非其所行。是故不说。尔时目揵连。闻提舍梵天所说心生欢喜。随其所应。即入三昧。以三昧力。从梵天没。到只陀林。尔时尊者目揵连。从三昧起。往诣佛所。顶礼佛足。在一面坐。先共提舍梵天所论说事。具以白佛。尔时世尊。告目揵连言。提舍梵天。不说第六人行无相耶。尔时大目揵连。即从座起。合掌向佛。而白佛言。世尊。今正是时。唯愿世尊说第六人行无相。若诸比丘闻已。当奉行之。佛告目揵连。谛听善思念之。我今当说。目连当知。若比丘。不观一切相入心无相三昧。是名第六人行无相。佛经虽作是说。而不分别。佛经是此论所为根本。此论是佛经优波提舍。诸经所不说。今欲说故而作此论

云何第六人行无相。答曰。坚信坚法。是第六人行无相人。所以者何。七种圣人。摄一切圣人。提舍梵天。已说五种。不说此二种。是以知之。问曰。此二人。何以说行无相者耶。答曰。彼尊者不可施设立名。在此在彼。乃至广说。问曰。此是二人。何以说一耶。答曰。即如文说。此二俱不可施设立名。在此在彼。以义同故。说名为一。复有说者。此二俱不起不相似心。复有说者。此二所行心等。俱有十五心故。复有说者。此二俱不起期心故。复有说者。此二俱是不可施设。俱是无言说。俱是速疾道。以是义故。二人为第六人。问曰。彼五人是行无相人耶。何以说此行无相者。名第六行无相人。答曰。彼五人者。非行无相人。唯此名行无相人。问曰。若然者。何以说此是第六行无相人。答曰。此是数法第六。非是行无相第六。余处亦说已害第五常行。前四非是常。唯第五者是常。以数法故。第五者是常。非四尽是常。如说。第六增上。五亦如是。如是以数法故言第六。非无相故言第六也。问曰。此所说无相无相解脱门。不动法心解脱。亦说是无相。非想非非想处。亦说是无相。此四有何差别。答曰。此中说见道是无相。所以者何。此是速疾道。不起期心。若人入此法者。不可施设。在此在彼。故说无相。无相解脱门。言无相者。以缘无十相法故言无相。不动法心解脱。言无相者。不为诸烦恼相所覆蔽。亦不更生烦恼相。故言无相。非想非非想处。言无相者。以彼处愚劣不猛利不决定所行以疑。彼无了了想相。无了了非想相。是故言无相。见道有十五心。第十六心俱道比智是修道。声闻能知见道中二心。谓苦法忍。苦法智。若欲观第三苦比忍心。是时乃知第十六道比智相应心。辟支佛知见道中三心。谓苦法忍。若法智。若欲知苦比忍时。是时乃知第八集比智相应心。佛世尊。知见道中所更相续心。问曰。何故声闻知见道中二心。辟支佛知三心。佛悉知耶。答曰。他心智。知相似境界。不知不相似境界。世俗知世俗心心数法。无漏知无漏心心数法。法智知法智分。比智知比智分。声闻辟支佛。作方便他心智。乃现在前。行者欲入见道。声闻他心智现在前。是时知见道中二心。谓苦法忍俱心。苦法智俱心。行者入比智分。声闻作比智分他心智方便。起比智分他心智现在前。欲知第三心。乃知第十六心。行者欲入见道。辟支佛作法智分他心智方便。行者入见道。辟支佛起法智分他心现在前知二心。谓苦法忍苦法智。行者入比智分。辟支佛作比智分他心智方便。起比智分他心智现在前。欲知第三苦比忍心。乃知第八集比智心。佛不作方便。他心智现在前。如行者起见道中一一刹那现在前。佛亦起他心智。知见道一一所更相续心

问曰。有能施坚信坚法人食者不也。答曰不能。若施衣服床座则能。食则不能。所以者何。此是速疾道故。若入此道。必不起期心。不可施设。在此在彼。是故不能施其食。问曰。若不能施其食者。优伽长者经云何通。如说。居士此是须陀洹。此是向须陀洹。乃至广说。答曰。此是天语此天。或有说。是魔王眷属。欲娆乱居士心故。复有说者。彼天是余鬼。欲欺诳居士故。作如是说。复有说者。此天是居士家中受记祠神。欲令居士心生欢喜。亦欲示现情相亲近故。作如是说。复有说者。此天是彼居士本日亲属。欲示其福田非福田故。作如是说。问曰。天于居士。纵令极亲。非其境界。何由而知。答曰。向须陀洹果有二种。一是假名。二是真实。若真实者。非其境界。若假名者。是其境界。复有说者。有能施其食者。而彼未食。所以者何。如行者入见道。若弟子。若比坐。为其受食。若檀越以食着其草上。若衣裓上。如余经说。婆陀利于意云何。若比丘是坚信。我语之言。汝于污泥。以身为桥。我欲从上而过。为违我言不。答言不。此亦说假名须陀洹向。非是真实。所以者何。真实须陀洹向者。不起不相似心。闻佛所说故。复有说者。此中亦说真实须陀洹向。问曰。彼不起不相似心。能闻佛所说。云何言是真实耶。答曰。虽不闻佛所说。以深心敬重佛故。假令见道可起者。亦当随顺佛言。是故佛作是言。有如是功德者。随顺我言。何况汝无功德者也

如说。世尊转法轮。地神唱言。乃至广说。问曰。何故作此论。答曰。为断疑故。人谓地神有现前了了智。知佛转法轮。非是比相智。欲说地神无有现前了了智。有比相智。知佛转法轮故。而作此论

问曰。转法轮非是生得智境界。地神云何知耶。答曰。以五事故知。一世尊起世俗心故知。问曰。何故世尊起世俗心。答曰。见三阿僧祇劫所行今有果报。生欢喜故。起世俗心。复有说者。见本所立弘誓今已果故。复有说者。见本所立愿今已果故。复有说者。欲饶益他意令满足故。以是事故。世尊欲令他知起世俗心。乃至畜生亦知。何况地神。世尊或起世俗心。舍利弗等诸大声闻。入顶第四禅。以愿智力。尚不能知。或时起世俗心。乃至畜生亦能知。二者亦告他。问曰。佛何故告他耶。答曰。欲现善说法中所言诚谛故。复有说者。欲现三阿僧祇劫所行有果报故。复有说者。欲显憍陈如是世良福田故。复有说者。欲令人天生信敬心故。复有说者。欲现非如世师吝法已破法吝故。复有说者。欲现己身是大人法故。复有说者。欲现己身是聪明人故。如说。有三事是聪明相。谓所思是善。所行是善。所言是善。以是事故告他。三者彼尊者亦起世俗心。问曰。彼尊者何故起世俗心耶。答曰。彼尊者令无始生死今有边故。除无量苦。断恶道因。生决定聚得见真谛故。复有说者。见本所立誓本所立愿本所行事今有果故。起世俗心。四者彼尊者亦告他。问曰。何故告他耶。答曰。欲现善说法中所言诚谛故。复次欲现世尊三阿僧祇劫所行今有果故。复次欲现佛法有大威势故。亦欲现色身为世福田故。复次欲生五人等欣仰心故。复次欲显现如来大功用故。复次欲现佛法是神变出离法故告他。五者从大威德天边闻。问曰。何者是大威德天耶。答曰。或有说者。是净居天。复有说者。是欲界天。见真谛者。复有说者。是欲界天。曾见过去佛者。所以者何。过去诸佛。转法轮时。有如是相。今现是相。知佛欲转法轮。即便告他。从彼得闻

问曰。云何是法轮义。答曰。或有说者。法体法性义。是法轮义。复有说者。选择法义。是法轮义。复有说者。能现见法义。是法轮义。复有说者。净法眼义。是法轮义。复有说者。对治非法轮义。是法轮义。所以者何。如六师自言。是天人师。亦转法轮。然其轮是八邪道。是故对非法轮。是法轮义。问曰。何等是轮义。答曰。速疾义。是轮义。复有说者。舍此趣彼义。是轮义。复次破烦恼义。是轮义

问曰。何故此轮名梵法轮耶。答曰。以梵世在初具圣道故。名梵法轮。第二第三禅不在初。亦不具圣道。第四禅。虽是佛身初得。而不具圣道。复次梵行者。身中可得故。名梵法轮。复次对非梵行故。名梵法轮。复次破非梵烦恼故。名梵法轮。复次如来等正觉是梵。彼分别解说施设显现。名梵法轮。复次以梵音说故。名梵法轮。复次若具有八圣道处。名梵法轮。复次若有三界见道修道所断烦恼对治法可得处。名梵法轮。不善无记。有报无报。能生二果。能生一果。无惭无愧相应。无惭无愧不相应。有聚体。无聚体。忍对治。智对治。可得处。名梵法轮。复次若有九断知果道。名梵法轮。余三禅中。有五断知果道。无色中。有一断知果道。初禅中。俱有九断知果道。故名梵法轮。亦如经说四十法。二十是不善分。二十是善分。若分别解此四十法。名梵法轮(四十法者如十邪道自称胜有十谤十直道十正见等十直亦如是)。问曰。如善法随顺法轮。可是梵法轮。不善法不随顺法轮。云何言是梵法轮耶。答曰。不以善不善体言是法轮。以缘善不善智。名梵法轮。所以者何此是寂静。无有过咎。不害于他。故名梵法轮

问曰。何故说见道是法轮修道非法轮耶。答曰。或有说者。速疾义。是法轮义。见道是速疾道。不起期心道故。复有说者。舍此趣彼。是法轮义。见道舍苦趣集。舍集趣灭。舍灭趣道。复有说者。以四事故名法轮。一舍此。二趣彼。三未选者选。四已选者不舍。舍此者。见道中舍苦。趣彼者。趣集。未选择选择者。是集。已选择不舍者。是苦。复有说者。上下义。是法轮义。犹如轮辐。或时在上。或时在下。见道亦尔。或时智忍缘欲界苦在下。或时智忍缘于有顶在上。缘于有顶已。复缘欲界。是故上下义。是法轮义。复有说者。降伏四方天下义。是法轮义。如转轮王所有轮宝。则能降伏四方天下。行者亦尔。以见道轮降伏四谛四方天下。复有说者。独如辐毂辋法。辐用持辋。毂用持辐。见道苦忍苦智集忍集智如辐。灭忍灭智如毂。道忍道智如辋。所以者何。此忍智缘一切道故。法智缘法智分。比智缘比智分。复有说者。见道所断结。能生非法八邪法轮。见道能对治此法。故名法轮。尊者瞿沙说曰。八圣道一时在此身中转。故名法轮。正见正觉正精进正念如辐。正语正业正命如毂。正定如辋。此八法皆是中道中修。故名法轮

佛在波罗奈国。初转法轮。问曰。菩提树下。已转法轮。何以言波罗奈国初转法轮。答曰。转法轮有二种。一在自身。二在他身。在菩提树下。是自身转法轮。波罗奈国。是他身转法轮。以在波罗奈国他身中初转法轮故。名初转法轮。复有说者。转法轮有二种。有共不共。如声闻辟支佛。是共法轮。佛是不共法转。以转共法轮故。言初转法轮。复有说者。以最初得无我证人故。言初转法轮。复有说者。若是时得胜辟支佛者。言初转法轮。所以者何。辟支佛亦于自身。能转法轮。不能于他身而转法轮。唯佛能于他身而转法轮。复有说者。若于三阿僧祇劫所行得其果处。名初转法轮。所以者何。佛若欲于过去诸佛所般涅槃者。即得随意。所以身心不解。作百千苦行者。但欲利益他故。若我得无上智时。当令无量众生。于生死牢狱。而得解脱。如是愿行。于波罗奈国。而得满足。故名初转法轮。复有说者。能降伏他故名轮。犹如国王降伏城村一切人民故得名为王。不但降伏宫人。彼直名之为王。如是能降伏他身。名为法王。不独己身名为法王。问曰。若圣道所在身中。即自身名转法轮者。何以名佛转法轮耶。答曰。或有说者。以觉悟故。言佛转法轮所以者何。随彼身中有圣道。若不以佛语光照。则圣道不生。若以佛语光照。则彼身中圣道便生。如池水中。虽有波头摩拘物头分陀利华。若日光不照。则不开不敷不香。日光若照。则开敷香。彼亦如是。复有说者。虽有圣道在彼身中。若不以如来言说之手而转之者。则圣道不生。如转轮王。若不以金轮宝置右手中以左手转之。作如是言。我今轮宝。当有所降伏者。是时诸神则不为转行其轮。若以轮宝。置左手中。以右手旋之。是时诸神则为转行其轮。然转其轮者是神。而王受其名。彼亦如是。复有说者。彼身中虽有圣道。若不得如来缘显发者。则圣道不生。犹如仓中有诸种子。若不以缘发者。牙则不生。彼亦如是。复有说者。彼身中虽有圣道。若如来不以善巧方便名句味身除彼身中障碍者。则圣道不生。若除其障碍。则圣道生。复有说者。有二因二缘。生于正见。一从他闻法。二内自思惟。如从他闻法。名佛转法轮。如内自思惟。言身中自有圣道。如是得于人身。成就四法者。名多有所作。如近善知识。从其闻法。名佛转法轮。如内自思惟。如法修行。言身中有圣道

问曰。如住苦法忍时。已转法轮。何以道比智时言转法轮耶。答曰。或有说者。住苦法忍时。虽转法轮。而转义未足。道比智时。转义乃足。复有说者。以道比智时有五事应。一得未曾得道。二舍曾得道。三断烦恼同一味故。四顿得八智。五修十六行。是时名转法轮。憍陈如汝解法耶。乃至广说。问曰。此五人皆是解法者。何以独问憍陈如耶。答曰。或有说者。以憍陈如先见圣谛后乃余者。憍陈如见圣谛时。余者方在达分善根。复有说者。以本愿故。先告憍陈如。汝解法耶。答言已解。乃至广说。问曰。世尊何故。三问憍陈如耶。答曰。或有说者。憍陈如见圣谛已。世尊起于知见。观前后际。为憍陈如应在恶道阴界入多。为我于三阿僧祇劫所经刹那须臾顷多。作是观时。见憍陈如应在恶道阴界入多。非我三阿僧祇劫所种刹那须臾顷多。佛见是已。作是思惟。我于三阿僧祇劫修集无量苦行。今得无上智。但能使憍陈如应在恶道阴界入在不生法中。不更为余事者。于我便足。是以三问。复有说者。憍陈如能缘缚一切众生身。一切众生。亦能缘缚憍陈如身。憍陈如见谛已。佛作是念。我今得阿耨多罗三藐三菩提。更不作余事。但断憍陈如及一切众生展转缘缚者。于我便足。是故三问更相吞啖。更相断命。说亦如是。复有说者。为近诽谤故。佛本为菩萨时。出迦毗罗城。是时迦毗罗诸释遣侍者五人。二人是母亲。三人是父亲。二人言受欲得净。三人言苦行得净。当于菩萨修苦行时。言受欲得净者。即便舍去。言苦行得净者。而故给侍菩萨。菩萨舍苦行处已。酥油涂身。食诸饭食。彼言苦行得净者。心生恼乱。即便舍去。是时菩萨身力转增。诣菩提树。降伏众魔。得阿耨多罗三藐三菩提。成正觉已。遍观世间。谁先应闻法。我当为说。见郁陀迦子。应先得闻。是时有天。即便白言。郁陀迦子。昨日命终。尔时如来亦说知见。知昨日命终。复作是念。谁次应闻法。我当为说见阿兰迦兰。次应得闻。天复白言。阿兰迦兰丧来七日。佛亦说知见。知阿兰迦兰丧来七日。佛作是念。阿兰迦兰。不闻我法。便为大失。问曰。佛已成道。应为彼人说法。而不为说。云何不名教化失时。尊者瞿沙说曰。佛初成道。心爱敬法。不思余食。未观众生谁应得度。复有说曰。如来大悲。未及彼人。而便命终。复有说者。佛未分众生立为三聚。复有说者。受佛化者。必须根熟。彼根未熟。而便命终。又诸根成熟。必由自心。彼人慢意行禅自称是一切智。必须久时诸根乃熟。问曰。若此人根未熟者。佛何以言彼人不闻我法便为大失。答曰。若彼人不命终者。佛能除其自称一切智心。亦生信佛是一切智。心亦可先令憍陈如前诸根得熟而得受化。若彼一人佛得道后。四十二日。有余命者。能令彼人于我法中大得利益。而彼命行尽故。世尊舍之。若有众生应受化者。如来能自住寿。如待须跋陀罗等。若能住他寿命者。无有是处。复有说者。佛本为菩萨时。是彼人弟子。若当彼人不命终者。当示其师法。亦令彼人知佛所得法。非是彼人本所受法。以是事故。言彼人大失。佛作是念。谁次应闻法。天复白言。阿若憍陈如等五人。次应得闻亦起知见。知阿若憍陈如等次应闻法。佛复作是念。今在何所。天复白言。在波罗奈国。佛亦起知见。知在波罗奈国。于时世尊。渐次向波罗奈国。趣彼五人。是时五人。见世尊来。即共立制。如修多罗广说。憍陈如见真谛已。佛告之言。汝于法解耶。乃至广说。汝今观我有懈慢耶。多行法耶。于离欲法有退失耶。我得甘露法耶。是时憍陈如。极生惭愧。而答佛言。今观世尊。无有懈慢。不行多法。于离欲法。亦无退失。得甘露法。我悉证知。以是事故。而三问之。复次欲满本誓愿故。曾闻此贤劫中。有王名恶行。有仙人名忍辱。时王除去男子。将诸伎女。游戏林间。种种快意。时王疲厌而便眠卧。时诸伎女。为花果故。于林树间。处处求觅。是时仙人。于自住处。闲静禅思。时诸伎女。遥见仙人。即诣其所。顶礼足已。在一面坐。是时仙人。为诸伎女。说欲过患。时王眠觉。四方观视。不见侍人。作是思惟。将无有人将我伎女去耶。其王即时嗔恚拔剑。遍林树间。而推求之。见诸伎女坐仙人边。心生是念。今此大鬼将我伎来。前问之言。汝是谁耶。仙人答言。我是仙人。王复问言。汝于此间何所作耶。仙人答言。行忍辱道。王作是念。此人见我嗔恚。自称忍辱。我今当试为实尔不。复更问言。汝得初禅耶。答言不得。汝乃至得非想非非想定耶。答言不得。其王闻已。嗔恚转增。语仙人言。可申汝臂。以刀断之。而问之言。汝是何人。仙人答言。是忍辱人。如是复断一臂。亦断两足。割其耳鼻。令仙人身。使为七分。复问之言。汝是何人。仙人答言。是忍辱人。仙人语王。今何故生疲厌心。汝若以刀割我身体。令如微尘者。我言忍辱。终无有异。尔时仙人。复作是念。如彼今日断我身体使为七分。我得阿耨多罗三藐三菩提时。先以大悲。令汝修七种道断汝七使。时恶行王者。今憍陈如是。忍辱仙人者。今世尊是。憍陈如见真谛已。佛之威力。自见己身。本是恶行王。断仙人身。使为七分。亦忆本誓愿。是时世尊告憍陈如。非我违本誓耶。遵本所愿耶。是时憍陈如。即从座起。极怀惭愧。白佛言。世尊。不违本誓。遵本所愿。我愚小作是罪。今重忏悔。以本愿满故。三问阿若憍陈如

阿毗昙毗婆沙论卷第二十一阿毗昙毗婆沙论卷第二十二

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    杂揵度无义品第七下

地神作如是唱。世尊转圣法轮。乃至广说。问曰。时会亦有余天唱言佛转法轮。何以独言地神唱耶。答曰。或有说者。地神随从世尊。欲令转法轮无诸留难。如来从时。转正法轮。无诸留难。地神自念所有功劳。今已得果。心生欢喜。是以高声先唱。复有说者。时会虽有余天。而闻地神轻躁。是以先唱。如今大众集处性轻躁者。每喜高声先唱。彼亦如是。复有说者。彼深生欢喜故。是以先唱。复有说者。是次第法故。所以者何。地神先唱。次虚空神。经刹那须臾顷。上至梵世。问曰。如处所起声即处所灭。何以言上至梵世耶。答曰。此是转转法。地神唱已。余天复唱。如是转转乃至梵世。犹如一灯转转相然。彼亦如是

问曰。如天亦解法。何故言为人转法轮。答曰。或有说者。以人先见谛天在后故。复有说者。人是现见。天非现见故。复有说者。以人为证。不以天为证故。复有说者。佛所行事业。与人同故。天则不同。复有说者。诸天亦从人中得善利故。复有说者。人中有四众故。复有说者。若于此处灭。亦于此处生。虽有圣人满诸天宫人中有证甘露法者。不名法灭。若无证者。乃名法灭。是故若于此处灭。亦于此处生。若转轮圣王出世。声彻他化自在天宫。憍陈如等声彻梵世。佛声彻阿迦腻吒。问曰。何故转轮圣王声彻自在天宫。憍陈如等声彻梵世。佛声彻阿迦腻吒。答曰。或有说者。众生造业。有下中上。造下业者。声彻自在天宫。造中业者。声彻梵世。造上业者。声彻阿迦腻吒。复有说者。众生造名誉业。有下中上。造下业者。声彻自在天宫。造中业者。声彻梵世。造上业者。声彻阿迦腻吒。复有说者。众生赞叹父母师长。沙门婆罗门。有下中上。若下者声彻自在天宫。中者声彻梵世。上者声彻阿迦腻吒。复有说者。若转轮圣王出世。则以十善教化。于六欲天中。受其果报。若有新生天者。诸天欢喜。我受乐亲属。今已增多。以转轮圣王出世之时诸天欢喜故。声彻自在天宫。梵天请佛转法轮故。声彻梵世。首陀会诸天。觉悟菩萨故。出迦毗罗城。得无上智。是以佛出于世。声彻阿迦腻吒。复有说者。转轮圣王。是爱欲人。是以声彻不离欲处。梵世中有尊卑上下故。憍陈如声彻梵世。佛有最胜大名称故。声彻阿迦腻吒。设当有顶众生有耳识者。世尊声亦应彻彼。世尊广修无量名誉业故。问曰。何故转法轮声彻于梵世。答曰。以梵世是一切人所尊重处。复有说者。以梵世作三千大千世界分齐故。复有说者。以梵世有尊卑上下故。复有说者。以彼地有言语根本觉观法故。如说以觉观心故。而有言语。复有说者。以彼有自地善染污不隐没无记耳识故。复有说者。以彼有自地善染污不隐没无记口有作法故。以是事故。声彻梵世

问曰。诸佛所说法。尽是法轮耶。答曰不也。说见道者。是名法轮。问曰。闻佛说法。入见道者多。何以不名法轮耶。答曰。彼虽是法轮。而不在初。初入法者得名法轮。最后入法。如须跋陀罗者。亦名法轮

问曰。一切诸佛。尽在波罗奈国。转于法轮。此处定不耶。若定者。此说云何通。如说燃灯佛灯光城而转法轮。若不定者。昙摩须菩提所说偈云何通。如偈说

  应念过去佛所依　　迦耶大城施鹿林
  皆于此处善分别　　清净妙法无有上

答曰。或有说者。应作是论有四处定。菩提树转法轮处。天上来下处。大现神变处。何以知菩提树定。曾闻有文陀竭转轮王。与四种兵。飞行空中。到菩提树上。其轮便住。不得前过。时王怖懅。作是思惟。我今将无欲失王位有命难耶。菩提树神。而语王言。大王莫怖。不失王位。亦无命难。王不见下菩提树耶。此中有金刚座。一切菩萨。皆坐此上。得无上智。王欲过者。可避此处。从余道往。时王便下。种种供养菩提树已。从余道去。以是事故。知菩提树定。何以知转法轮处定耶。即以上偈。知其处定。何以知天上来处定耶。曾闻佛去世后。从天上来处。有苦恼事。诸比丘。舍之而去。外道异学。来居其中。后诸比丘。还来其处。语外道言。此是我师天上来处。外道后言。是我天祠常住之处。乃至生大斗诤。时诸比丘。语外道言。今当俱立诚言。应属谁者。当有瑞相。时诸外道皆默。尔时诸比丘。便立诚言。诸神证知。若令此处是过去诸佛为母说法来下处者。当现瑞相。时彼住处。有大石柱。上有石师子。即便大吼。时诸外道。心怀怖懅。舍之而去。口中又出众宝华鬘。绕此石柱。皆悉周遍。以是事故知佛从天上来下处定。何以知现大神变处定。佛在世时。诸外道辈。求佛共捔现神变。经十六大国。佛不现神变。还舍卫国。乃现神变。以是事故。知现大神变处定。问曰。若转法轮处定者。然灯佛于灯光城。转于法轮。此说云何通。答曰。今此波罗奈国。即是昔日灯光城。复有说者。有三处定。谓菩提树。天上来下处。现大神变处。此三处定。如上所说。三处不定。转法轮处。生处。般涅槃处。何以知转法轮处不定。若阿罗郁陀迦子。不命终者。佛不往其所而为说法。从摩伽陀。将至波罗奈国耶。问曰。若转法轮处不定者。昙摩须菩提偈云何通。答曰。此不必须通。所以者何。此非修多罗毗尼阿毗昙。此是造文颂法。凡造文颂者。言必过实。若必欲通者当云何通。答曰。过去亦曾有佛于彼处转法轮。是以作如是说。波罗奈是何义耶。答曰。有河名波罗奈。去其不远。造立王城。故名波罗奈。何以名仙人论处。答曰。若作是说。一切诸佛。皆于波罗奈国转法轮者。诸佛是最胜仙人。始初于彼转法轮故。名仙人论处。若作是说。诸佛不必于彼处转法轮者。佛出世时有阿罗汉大仙。于彼处已住今住当住。若佛不出世。有辟支佛住。若无辟支佛。有五通仙住。以是事故。名仙人论处。亦名仙人住处。施鹿林有何义。众鹿于中游行。名曰鹿林。复次梵摩达王。以此树林。施与众鹿。名施鹿林

又世尊言。此比丘漏尽。三十三天数集会。乃至广说。问曰。何故作此论。答曰。波利质多树喻经。是此论所为根本。或谓三十三天有现前了了智。知比丘漏尽。非是比相知。欲决定说三十三天无现前了了智。是比相智。所以者何。生得慧不知漏尽法。以是事故。而作此论。问曰。若生得慧。不能知漏尽法者。彼诸天云何知耶。答曰。以五事故知。一世尊起世俗心。问曰。何故世尊起世俗心。答曰。以适世尊意故。谁能第一适世尊意。谓能断未来有者。世尊亦说。比丘若起少分未来有者。我不称赞是人。乃至广说。彼比丘断未来有。适世尊意故。起世俗心。复有说者。欲令得他心智者知故以口言告他。二告他。告他义如先说。三彼尊者亦起世俗心。问曰。彼尊者何故起世俗心耶。答曰。彼尊者无始以来。烦恼炽然。今已得冷。舍炽然诸入。得清凉诸入。舍烦恼众生。住清净众生中。舍染污阴重檐得清净阴。生欢喜故。起世俗心。四彼尊者亦告他。问曰。彼尊者何故告他。答曰。欲现法中所言诚谛故。亦令施主施饮食衣服床坐卧具病瘦医药。生欢喜心。亦显出家有果实行故。是以告他。五从大威德天闻。问曰。何者是大威德天耶。答曰。天中得阿罗汉者是也。问曰。一切皆知耶。答曰。若根等者知。问曰。其余天亦称叹此法不耶。答曰。亦称叹。问曰。若然者。此中何故不说耶。答曰。或有说者。若诸天数数集会者。此中说之。三十三天。八日。十四日。十五日。思念人天有行善法者不。复有说者。彼三十三天中。或有以波利质多罗树喻阿罗汉者。是以称叹。复有说者。三十三天。若闻人多行善者。天则欢喜。是以称叹。复有说者。三十三天。常伺察人有行善者。为作拥护。是故称叹。问曰。亦称学人不耶。答曰。亦称叹。如经说。若世间人。孝事父母。诸天称叹。何况学人。问曰。若然者何以但说漏尽者。不说学人耶。答曰。以最胜故。乃至广说。复有说者。以波利质多罗树极盛时开敷为喻。复有说者。以漏尽人应受供养故。不杂过患故。无罪咎故。无嫌恨故。是以称叹。复有说者。若世有阿罗汉。诸天增多。恶道减少。是以称叹。犹如明王治国以正人民增益。彼亦如是。复有说者。若世有阿罗汉。诸人增多。阿修罗众减少。如月满时大海水增。彼亦如是。复有说者。若世有阿罗汉。诸天与阿修罗战时则胜。如见善精进天子诸天战胜。彼亦如是。复有说者。若世有阿罗汉。后生诸天威德。胜前生诸天故。是以称叹。如以米泔施胜于四衢施者。彼亦如是。复有说者。若世有阿罗汉。以少食施。得生天上故。是以称叹。如摩诃迦叶以一器[禾*秀]子饭施。阿泥卢头以一食施。彼亦如是。复有说者。若世有阿罗汉。见者能生信敬心。得生天上故。是以称叹。如虾蟆恶狗气嘘旃陀罗以敬信心故。得生天上。彼亦如是。复有说者。若世有阿罗汉。生死牢狱。得遭大赦。如王生子大赦牢狱。彼亦如是。复有说者。若世有阿罗汉。则能显示善趣恶趣道。如日出时则见平坦崄难之道。彼亦如是。复有说者。若世有阿罗汉。则不失天位。不堕恶道。还得天位故。犹如帝释。彼亦如是。复有说者。若世有阿罗汉。一切世间。常获善利。无空缺时。犹如善师教善弟子常得善利无空缺时。彼亦如是。复有说者。若世有阿罗汉。虽有天乐。而能舍离。思得闲静。如帝释转轮圣王阎罗王思得出家。彼亦如是。复有说者。若世有阿罗汉。一切世间。得闻道品等宝而常丰贱。如海船载宝令天下丰贱。彼亦如是。复有说者。若世有阿罗汉。一切世人受乐。如丰熟时。彼亦如是。问曰。为称叹一切阿罗汉不耶。答曰。或有说者。皆称叹一切阿罗汉。所以者何。诸天常好叹说人善。一切事办者。甚为希有。是故皆叹。复有说者。不必称叹一切阿罗汉。作阿罗汉作名誉业。亦令增益者则称叹。若不作名誉业。虽有作不令增益者。邻比犹无知者。何况诸天。复有说者。若豪贵出家。如释婆陀王等。则称叹之。复有说者。如经中所说阿罗汉者。则称叹之。复有说者。若有大智。有大福报者。若能令诸天众增恶道减少。则称叹之。复有说者。若饶益他。不生疲厌。如舍利弗等。则称叹之。复有说者。若能护持佛法。世所归趣者。则称叹之。问曰。诸天为知增上慢者不耶。答曰。若有增上慢。自言是阿罗汉者。诸天不知。若无增上慢。自言得阿罗汉者。诸天则知。复有说者。若有深厚善根。起增上慢者则不知。若起欲界系不净观。生增上慢者则知。如帝释世无佛时。若见有人闲居无事。即往其所。观察是人有成佛相不。帝释尚尔。何况余天而不知也。问曰。复知犯戒者不耶。答曰。若犯粗戒则知。细者不知

又世尊言。有化法调伏。有如法修行。乃至广说。问曰。何故作此论。答曰。禅那梨师经。是此论所为根本。曾闻摩伽陀国。有大疾病。当是疫时。摩伽陀国。频婆娑罗王辅佐人。多有死者。复有说者。阿阇世王。杀父王时。亦杀父王左右辅佐。诸辅佐亲属。往请阿难。为我问佛。于处处村落。如信乐佛者。命终之后。世尊常悉说其生处。此摩伽陀国。我诸亲属。命终之者。不说生处。汝当为我请问世尊。此诸人等。命终之者。为生何处。尔时阿难。以亲爱故。许作方便。诣世尊所。而白佛言余者人民。有命终者。世尊常说其生处。摩伽陀国辅佐命终。不说生处。以佛不说其生处故。彼诸亲属。生愁恼心。不生信敬。唯愿世尊。说其生处。世尊于摩伽陀国。成等正觉。又频婆娑罗王。深心信佛。得究竟法。敬事众僧。以是事故。应说摩伽陀国诸辅佐等死者生处。尔时世尊。默然许之。即持衣钵。入那提揵城乞食。食已便还精舍。洗足已。于军阇迦房内。敷床而坐。善摄身心。入于禅定。欲观摩伽陀国侍使生处。问曰。世尊有如是知见。欲有所观。应念即知。何以故敷床座。乃至广说。答曰。或有说者。欲说甚深难知难明难见事故。所以者何。一切佛经所说义深远者。莫若于业。十二支缘虽是甚深。莫若二支。体是业者。信是甚深。如来十力。知业力者。最是甚深。四不可思议法中。业不可思议。最是甚深。八揵度中。业揵度最是甚深。以是事故敷床座。乃至广说。复有说者。欲待受化者集故。复有说者。禅那利师。未来集故。禅那利师。若闻佛欲说是事。必来诣佛。复有说者。佛因是事。亦说如来有八如实功德故。一明具足。二戒具足。三说法具足。四于现明了。五善说道。六得善伴。七得善眷属。八于一切众生有饶益心。如是广如经说。复有说者。欲令阿难闻持不忘。益加渴仰尊重心故。复有说者。欲断无有实德轻易心故。有人少有所知。他人来问。以轻易故。所问便答。如来欲现我今虽有如来知见应念即知。而故作方便。何况小智。而不故作方便耶。复有说者。欲现聪明人法故。世尊亦说聪明。有三种相。一善思所思。二善言所言。三善行所行。复有说者。摩伽陀国。诸辅佐等。有种种因。有种种果。有种种业种种报。而遍生六欲天中。欲谛观如是事故敷床座。乃至广说。复有说者。佛时欲入禅定。阿难方问此事。佛未答之。即入禅定。尔时世尊。以日后分。从禅定起。于比丘僧前。敷床而坐。尔时阿难。作是思惟。今者世尊。身心寂静。正是问时。佛知阿难心之所念。告阿难言。此摩伽陀国诸辅佐等。凡八万四千。或过是数。或是化法调伏。或是如法修行。断于三结。得须陀洹道。乃至广说。问曰。云何辅佐。答曰。或有说者。是频婆娑罗王内眷属故。名曰辅佐。复有说者。常侍三宝故。名曰辅佐。复有说者。此是前世时名。所以者何。频婆娑罗王。本曾为转轮圣王。与四种兵游行虚空时。王轮宝忽然不行。广说如上。转法轮中。乃至王八万四千辅佐。供养菩提树已。异道而去。尔时转轮圣王者。今频婆娑罗王是。尔时辅佐八万四千人者。今诸辅佐是。是故知是前世时名。复有说者。此诸辅佐。助王治于二国。使国丰盛。命终之后。二国空虚。故名辅佐。佛经中说。是诸辅佐。有是化法调伏。有是如法修行。而不分别佛经。是此论所为根本。诸经中所不说者。今欲说故。而作此论

云何化法调伏。云何如法修行。答曰。或有说者。诸摩竭辅佐。天身见法者。名化法调伏。人身见法者名如法修行。复有说者。诸摩竭辅佐。不受戒见法者。名化法调伏。受戒见法者。名如法修行。复有说者。若于此种善根。亦令成熟。于彼得解脱者。名化法调伏。于此三事得具足者。名如法修行。如是于此中种达分善根。彼中入见道此中种观谛善根。彼中入见道。此中受假名戒。彼中得真实戒。此中得逮解脱戒禅戒。彼中得无漏戒。此中善学心善学戒。彼中善学慧。此中得须陀洹果。此中得修治善根。彼中得净见。此中得信等五根。彼中得不坏信。当知亦尔。是化法调伏。于此中种达分善根。即此中入见道。此中种观谛善根。即此中入见道。此中入见道。此中受假名戒。即此中得真实戒。此中得逮解脱戒禅戒。即此中得无漏戒。此中善学心善学戒。即此中善学慧。此中得须陀洹。即此中得须陀洹果。此中得修治善根。即此中得净见。此中得信等五根。即此中得不坏信。当知亦尔。是如法修行。问曰。何故天中见法者名化法调伏。人中见法者。名如法修行。答曰。人中习学故。圣道现在前。亦多读诵。兼解其义。初夜后夜。勤修方便。受一七六七法。从日没时至日出时。结跏趺坐。勤行精进。住于山窟岩石之间。顶安禅镇行禅鞠法杖。作如是等精进已。然后圣道乃现在前。天中无有是事故。若于此间。修如是等方便。后生彼中。不多用功。圣道现在前。是故名化法调伏。若于人中。修如是等法。圣道现在前者。名如法修行

云何多欲。云何不知足。乃至广说。问曰。何故作此论。答曰。此二法所行相似。有人性多欲。世人言是人不知足。有人性不知足。世人言是人多欲。此二法相似故。世人谓是一。今欲说其体性亦说差别故。而作此论

云何多欲。答曰。未得色声香味触。此说在家人。衣服饮食床敷卧具。此说出家人。若欲常欲极欲。乃至广说。在家者。求色等境界。四方驰骋。佃种者。求田地园林牛羊等畜种种谷麦资生之具。富贵者求王位国土封邑象马金银琉璃等宝。出家人求衣钵等所须之物。及房舍弟子徒众等。是名多欲。不知足者。已得色声香味触。此说在家人。已得衣服饮食床敷卧具。是说出家人。不知足者不可适所得。乃至广说。在家不知足者。若于一田地不知足。复求二田地。于二田地不知足。乃至求多。亦不知足。园林牛羊等畜。乃至资生之物。说亦如是。富贵者于一王位不知足。求二王位。于二王位不知足。乃至求多王位。乃至求多珍宝。说亦如是。出家人于一衣钵不知足。求于二三。乃至多求不知足。乃至资生之具不知足。说亦如是

多欲不知足。有何差别。问曰。何故复作此论。答曰。此法相似。虽说体性。犹应说差别。云何多欲。云何不知足。多欲者若未得色声香味触。乃至广说。何以知是多欲耶。答曰。以所求故知。若求色等境界时。多作方便。以多方便故知。所以者何。多欲是多方便因。不知足者。已得色声香味触。乃至广说。复欲复求何以知是不知足耶。答曰。若已欲复欲。此必数数多求。以多求故知。所以者何。已欲复欲。是数数多求因。复有说者。不知足是因。多欲是果。此二法更相显现。或以因显果。或以果显因。此二法俱是贪不善根。复有说者。多欲在意地。不知足是在六识身。所以者何。五识缘现在法。多欲缘未来。评曰。此二法俱在六识身。俱是欲界法。如是说者好

云何少欲。云何知足。问曰。何故作此论。答曰。此二法相似。有人性少欲。世人言是知足。有人性知足。世人言是少欲。此二法相似故。世人谓是一。今欲说其体性亦说差别故。而作此论。云何少欲。未得色声香味触。乃至广说。此在家人。未得衣服饮食。乃至广说。此说出家人。若不欲不常欲不极欲。乃至广说。在家佃种者。不求田地等。乃至广说。富贵者不求王位等。乃至广说。出家者不求衣钵等。乃至广说。云何知足。答曰。已得色声香味触。乃至广说。是说在家人。已得衣服饮食等。乃至广说。是说出家人。知足者可适所得。乃至广说。在家知足者于一田地知足。不求二田地。乃至于一资生具知足。不求二。乃至广说。富贵者。于一王位知足。不求二王位。于二王位知足。不求多王位。乃至广说。出家者于一衣钵知足。不求于二。乃至于资生之具。不求多。乃至广说。少欲知足。有何差别。问曰。何故复作此论。答曰。此法相似。虽说体性。犹应说差别。少欲者若未得色声香味触。乃至广说。何以知是少欲耶。答曰。以不求故知。以不求是少欲因故。知足者已得色声香味触。乃至广说。何以知是知足耶。答曰。不数数求故。不多作方便。不多作方便。是知足因。是名差别。或有少求而是多欲。或有多求而是少欲。少求是多欲者。如须一呵梨勒果得已。复欲于二。是名少求而是多欲。多求而是少欲者。如须百千两金资生之物得已。更不复欲。是名多求而是少欲。或有多求是不知足。或有多求是知足。多求是不知足者。得资生之物。足以供身。犹故多求。是名多求而不知足。多求是知足者。得资生之物。不足供身。虽复更求。犹是知足。问曰。何故问少欲。而答不欲耶。如说不欲不常欲不极欲。答曰。资生之物有二种。一如法。二不如法。如法者少欲。不如法者不欲。复有说者。资生之物有二种。一是所应。二非所应。所应者少欲。非所应者不欲。复有说者。受他物有二种。一以愚故。二为止苦。止苦者少欲。愚者不欲。复有说者。于财不欲。于无漏道欲。复有说者。一切阿罗汉。永断欲心。怜愍众生故。受他所须云何难满。云何难养。乃至广说。问曰。何故作此论。答曰此二法所行相似。有人性是难满。世人言是人难养。有人性是难养。世人言是人难满。此二法相似故。世人谓是一。今欲说其体性亦说差别故。而作此论

云何难满。答曰。多饮多食是也。云何难养。答曰。若数数饮食是也。问曰。此二何以不问其差别耶。答曰。应问。应作是说。难满难养。有何差别。答曰。多食是难满。选择食是难养。而不问者。当知此说有余。乃至广说

云何易满。云何易养。乃至广说。问曰。何故作此论。答曰。应如上难满难养。所以中说

云何易满。答曰。不多食不多饮是也。云何易养。答曰。不数数食是也。问曰。此中云何不问差别耶。答曰。应问如上所说。或有少食而是难满。或有多食而是易满。少食是难满者。应食一揣。而食二揣。是名少食而是难满。多食而是易满者。若食一斛。乃足供身。而更不食。是名多食而是易满。曾闻有牸象名曰磨茶。载佛舍利。来入罽宾国。以此善根故。于罽宾国。死生人中。其后出家。得阿罗汉果。日食饭一斛。乃至欲般涅槃时。告诸比丘尼。汝等集会。我当自说所得胜法诸比丘尼。不信其言。作如是说。汝是易满人。云何不自说得胜法耶。复语诸比丘尼言。莫生不信。我有身已来常是易满。亦说前世因缘我本为牸象。舍彼身已。今得此身。能食饭一斛五升。而食一斛。乃至广说。如是等。虽是多食。而是易满。曾闻波斯匿王。能食饭二斛饮浆二斛。是彼功德因缘故。因一根粳米一茎甘蔗。日日长生尔许饮食故。身体肥大。以此大身。往诣佛所。佛便问言。大王身体肥大。得无疲耶时波斯匿王。心生惭愧。具向佛说。尔时世尊便说此偈

  人当有正念　　于食知止足
  亦不遭苦受　　易消而增寿

时波斯匿王。闻佛所说。渐自减食。乃至后时。唯食饭一斛。如是虽复多食。而是易满。或选择食而是难养。或有选择食而是易养。选择食是难养者。粗食足供身。而选择好食是也。选择食是易养者。粗食不能供身。不选择好食是也。或有贪味故数数食所食不多。或有所食多而不贪味数数食。或有所食多贪味数数食。或有所食不多不贪味数数食。初句者乌等是也第二句者象马等是也。第三句者狼狗狸猫等是也。第四句者除上尔所事。问曰。此有何差别耶。答曰。体性即是差别。如前说。难满者所食多。难养者选择食。复有说者。难满者是多欲。难养者是不知足。此二法。俱是欲界法。俱是贪不善根。通六识身。易满易养与上相违是也。问曰。此有何差别耶。答曰。体性即是差别。如前说。所食不多是易满不选择食是易养。复有说者。易满是少欲。易养是知足。此二法。俱是三界法。是不贪善根。对于贪故。通六识身

佛经说。有四圣种。乃至广说。问曰。世尊何故说此经耶。答曰。为止四种业行故而说此经。四种业者。或以佃种为业。或以贩卖为业。或以事官为业。或以尊贵为业。一种业者。以乞求为业。为止四种业行一种业故。世尊说此经。复欲显现业及所应作故。业者应乞求衣服饮食床卧敷具。以自存活。所应作者。应乐断烦恼乐修善法。如是无尽业所应作。无罪业所应作。无害他业所应作。不同外道业所应作。说亦如是。复次欲现圣道及圣道具故。圣道者。谓乐断乐修者是也。圣道具者。谓饮食衣服床敷等是也。沙门果沙门果具婆罗门婆罗门具亦如是。以如是等事故。佛说此经

问曰。圣种体性是何。答曰。对贪故名无贪善根。若取相应共有是四阴五阴性。复有说者。性是不贪精进。初三者是不贪。乐断乐修是精进。评曰。不应作是说。如前说者好。所以者何。乐断乐修。亦是不贪性故。问曰。若然者云何有四。答曰。为断生四种爱故有四。为断因衣生爱。说于衣知足圣种。为食说食知足。为房舍敷具。说房舍敷具知足。为增长有故。说乐断乐修知足圣种。是故为止四种爱故。说四圣种。此是圣种体性。乃至广说

已说体性。所以今当说。何故名圣种。云何为圣。以善故说圣。以无漏故说圣。复有说者。圣人行此法故说圣。复有说者。能生妙好适意果故说圣。此说是依果。复有说。报果者能生妙好适意报果故说圣。云何名种。过去恒河沙数诸佛。及诸佛弟子。从是中生故名种。复有说者。能令佛法久住故说种。所以者何。佛般涅槃后。道法千年。而不坏者。是圣种力。如梁椽持舍使不散坏。彼亦如是。复有说者。相续义。是种义。佛涅槃后。使佛法相续不断。是种义。有如是圣。有如是种。故名圣种

界者有漏是三界系。无漏是不系。问曰。如欲界有四种可尔。以有衣服饮食床敷卧具故。色界无饮食。无色界无衣服饮食床敷卧具。云何有四耶。答曰。彼虽无如是物。有如是功德。复有说者。此间修衣服饮食床敷卧具知足法故。虽生彼间。而犹随从。尊者和须蜜说曰。彼虽无此法。而有此法对治。对治有多种。有断对治。有过患对治。有持对治。有远分对治。色界有此四种对治。无色界有二种。谓持对治。远分对治。尊者佛陀提婆说曰。无无漏衣服饮食床敷卧具。而有无漏圣种。彼虽无衣服饮食床敷卧具等。而有圣种。地者有漏在十一地。无漏在九地。依者。依三界身初者依欲界。行者行十六行。亦行余行。缘者缘一切法。念处者是四念处。智者与十智相应。定者与三定相应。根者与三根相应。谓喜乐舍根。世者。在三世。缘者。缘过去未来现在。亦缘非世法。善不善无记者。是善缘善。不善无记者。缘三种。三界系者如先说。有漏是三界系。无漏是不系。缘三界系及不系者。缘三界系。亦缘不系。是学无学非学非无学者。是三种。缘学无学非学非无学者。三种尽缘。见道断修道断无断者。是修道断无断。缘见道修道无断者。缘三种。缘自身他身非身法者。缘三种。缘名缘义者。缘名缘义。问曰。为是意地。为是六识身。答曰。是意地非五识身。所以者何。五识身是生得法故。复有说者。是五识身。所以者何。一切善心。是圣种故。评曰。不应作是说。如前说者好。为是生得善。为是方便善。答曰。是方便善。非生得善。所以者何。一切闻思修善。皆为解脱。故是圣种。复有说者。是生得善。评曰。不应作是说。所以者何。乃至蚁子。有生得善。可是圣种耶。问曰。若是方便者。外道禅解脱胜处。一切处。为是圣种不耶。答曰不是。所以者何。如先说。闻思修善为解脱。故是圣种。外道不知足。为增长有及有具。故非圣种。问曰。一切善心中尽有少欲知足。所以者何。是对贪无贪善根故。何以说知足是圣种。不说少欲耶。答曰。或有说者。少欲犹是欲名。又是无所欲异名。若说少欲时。犹有所欲。不名无所欲。知足更无所欲。亦无异名。故说是圣种。复有说者。少欲于未得少欲于未来。知足者知足于已得知足于现在。若于现在所得少物能知足者。是为甚难。于未得未来转轮圣王位少欲者。未足为难。以知足难故。说是圣种。复有说者。少欲是欲界。知足是三界。复有说者。少欲是三界系非不系。知足是三界系亦是不系。评曰。不应作是说。此二法。俱是三界系。亦是不系。问曰。若然者。复还生疑。何故说知足是圣种。不说少欲耶。答曰。为异于外道知故。不说少欲是圣种。若说少欲是圣种者。诸外道。当作是言。我等亦是行圣种者。所以者何。汝等犹着粪扫衣。而我等不着衣。汝等犹乞食自活。而我等多不食。汝等犹坐树下。而我等或常举手翘足而立。不坐床座。我等行如此法。非是圣种耶。外道梵志。虽行此法。于有有具。而不知足。是故异外道。故不说少欲是圣种

问曰。何故随病药。圣种中不说耶。答曰。或有说者。此法以入上所说中。所以者何。随病药有二种。一是可食。二不可食。可食者在饮食中摄。不可食者。在衣服床敷卧具中摄。复有说者。若一切人。一切时所用者。说是圣种。随病药非一切人一切时用。如尊者婆拘罗所说。我于佛法中出家。过八十年。不忆此身有病乃至头痛。亦不忆畜随病药乃至畜一呵梨勒果。如此欲界一切人。非一切时畜随病药。况色无色界。复次若受用此法。令人放逸。若能舍者。是名圣种。随病药不能令人放逸故。不说是圣种

问曰。何故逮解脱戒无作。说是圣种。不说有作是耶。答曰。或有说者。有作随刹那灭。无作是相续不断。不断义是圣种。复有说者。无作与无漏道俱得。有作不尔。是故无作是圣种。在家人有四圣种。出家人亦有四。在家者有期心。而不能行。曾闻帝释坐众华座。有千二百那由他侍女六万伎人。常作音乐。以娱乐之。而彼帝释。常有期心圣种。而不受用。出家者亦有期心。亦行圣种。出家者或有随得于衣服饮食等。而不知足。是行圣种。曾闻有一比丘。以日没时。往诣佛所。从佛求房而住。尔时佛告阿难。与此比丘房舍。阿难与之。尔时比丘语阿难言。大德严净此房。除去瓦石粪扫之等。悬缯幡[巾*蓋]。散种种华。烧上妙香。敷细软卧具。安置好枕。尔时阿难。具以是事往白世尊。佛告阿难。如彼比丘所言。尽为办具。是时阿难。悉为具之。时彼比丘。即入房中。坐其床座。于夜初分。起净解脱。次第起余解脱。尽一切漏。得阿罗汉果。兼起神通。于日清旦。以神通力。从彼房舍。忽然而去。尔时阿难。以清旦时。诣彼房舍。见其门开。不见比丘。即往白佛。具说是事。佛告阿难。汝于此比丘。莫生异想。昨夜初分。而彼比丘。起净解脱。乃至修起神通。以神通力。从彼房去。阿难彼比丘者。性乐鲜好。从性意天中。来生此间。若汝不为办具如是鲜好房舍卧具等者。而彼比丘。则不能得胜进之法。如是出家人。虽于衣服床敷卧具等不知足。不随得而用。然能行圣种。过去诸佛。皆称叹粪扫衣而不听着。今佛称叹粪扫衣而听着。问曰。何故过去诸佛称叹粪扫衣而不听着。今佛称叹而听着耶。答曰。或有说者。古昔时人。性不贪爱。虽有价直百千两金衣。惜着之心。不如今人惜着凡衣。复有说者。古昔时人。饶财多宝。若求百千两金衣。未足为难。如今世人财宝俭少。求粪扫衣。犹尚难得。何况价直百千两金衣。复有说者。古昔时人。心好鲜净。于粗弊物不生敬心。是以赞叹而不听用。今世时人。性好粗弊。于受用粗弊物者。能生信敬心。是以赞叹亦听受用。复有说者。古昔时人。身体细软。若受用粗弊物者。不能自存。是以赞叹不听受用。今世时人。身体粗强。受用粗弊。能自存身。是以赞叹亦听受用。尊者佛陀提婆说曰。古昔诸物。若赞叹时。亦听受用。所以者何。佛不无事有所赞叹粪扫衣。轻贱易得。求时无过耶。答曰。或有说者。粪扫衣。无多人着故轻贱。求时易得故轻贱。处处可得故易得。佛所听故求时无过。复次此业无过故。求时无过。复次智人所行故。求时无过。尊者佛陀提婆说曰。少价故言轻贱。不从他得故易得。无生故求时无过

佛以二事故。于知足。说是圣种。一为断贪着衣心。如难陀等。二为赞叹于衣知足。如摩诃迦叶等。以二事故。于食知足。说是圣种。一为断贪食心。如婆陀利等。二为赞叹于食知足。如婆拘罗等。以二事故。于床座知足。说是圣种。一为断贪着床坐心。如愚王比丘等。如说愚王比丘白佛。唯愿世尊。观我床座粗弊如是。二为赞叹床座知足。如离婆多等。以二事故。说乐断乐修是圣种。一为除懈慢者心。如阐陀等。二为赞叹勤行精进。如亿耳等。以四事故。当知是人住圣种者。一不乐谈得利养。二不乐近贪美食人。三不多用资生之物。其所用者。皆是清净。四于诸利养。得与不得。不生憎爱。佛经说此四圣种。是最胜是种性是可乐是不杂。一切世间。若沙门婆罗门。若天魔梵。无能如法说其过者。问曰。云何是最胜。答曰。或有说者。若行此法。堕最胜人中。如佛说。我五百弟子。各有最胜之事。若于资生之物。而知足者。佛亦赞叹。此人是最胜。复次涅槃是最胜。此法能到。故名最胜。复次能知最胜法故。名最胜法。何等是最胜法。谓佛若佛弟子。谁能知此法。谓行圣种。及修圣道者。复次此法于一切满意善根中最胜。故言最胜。所以者何。一切众生。多不意满足而死。若住圣种者。命终之时。其意满足。此法体是最胜。能到最胜。故名最胜。复次能去积聚过故。所以者何。下劣者多积聚。最胜者不积聚。若住圣种者。于诸所须。而不积聚。转轮圣王。王四天下。所有财宝。由是易尽。住圣种业。所用无尽。能除积聚法故。体是最胜。能到涅槃最胜法。故名最胜。云何是种性。答曰。如先说。过去恒河沙数诸佛。及诸弟子。皆从是种中生故。名旧种性。亦令诸佛法常相续不断。故名种性。复有说者。此法能知种性故名种性。如来等正觉善种性。唯此法能知。故名种性。云何名可乐。答曰。所有断乐。及修乐此法能乐。故名可乐。复次此法亦可言知也。所以者何。行此法者。能次第知夜分。故以日没时。结跏趺坐。至日出时乃起。复次此法能知可乐法。故名可乐。复次能入圣法胎。故名最胜。入善法种性。故名种性。住善法时。能知善法气味。故名可乐。云何不杂。答曰。不杂四种业故。谓佃种贩卖事官尊贵不杂。此业淳善功德。故名不杂。沙门婆罗门等。不能如法说其过者。不杂过患。不逼切他人故。如经说比丘当知。我圣弟子。心无憎爱。云何无憎爱。爱名爱恚。圣弟子。降伏爱恚。不为爱恚所伏故。名无憎爱。此经亦说。有乐断乐修。此二有何差别。答曰。无碍道是乐断。解脱道是乐修。复次见道是乐断。修道是乐修。如见道修道忍知未知欲知根知根见地修地。说亦如是

阿毗昙毗婆沙论卷第二十二阿毗昙毗婆沙论卷第二十三

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    杂揵度思品第八上

云何为思。云何为忆乃至广说。如此章及解章义。此中应说忧波提舍。问曰。何故作此论。答曰。此二法所行相似。世人见多思者。言是人多忆。世人见多忆者。言是人多思。今欲说其体性亦说差别故。或有说。此二法是一。所以者何。声论者说。思之与忆。应是一字。唯长一点(此是天竺书法)。为止如是意欲说差别。复有说者。此是心之异名。如譬喻者说。思之与忆。是心异名。更无别体。为止如是说者意。欲说思之与忆是心数法各有别体故。而作此论。云何为思。答曰。思数数思。乃至广说。如是等语。尽是说意业名。云何为忆。答曰。忆数数忆。乃至广说。如是等语。尽是说慧别名。思忆有何差别。问曰。何故复作此论。答曰。此二法相似故。虽说体性。亦应说差别。思忆有何差别耶。答曰。如经本说。思者是业。忆者是慧。复次所作相是思。所知解相是忆。复次以思别业。以忆故别慧。总相别相。思之与忆。是谓差别

问曰。忆若是慧者。慧有三种。谓闻思修。此三体性。是何耶。答曰。从闻生者是闻慧。从思生者是思慧。从修生者是修慧。复有说者。若受持读诵思惟观察十二部经。是闻慧。依此闻慧次生思慧。依此思慧。次生修慧。如依金矿生金依金生金刚。彼亦如是。评曰。不应作是说。如是说者好。受持读诵思惟观察十二部经。是生得慧。依生得慧生闻慧。依闻慧生思慧。依思慧生修慧。如依种生牙依牙生茎叶等。彼亦如是。问曰。此三慧有何差别。答曰。闻慧一切时依名解义。所以者何。行者作是念。和上所说有何义。修多罗毗尼阿毗昙所说。有何义。是名闻慧。思慧者或时依名解义。或时不依名解义。修慧者于一切时。不依名解义。犹如三人于池水中洗浴。一不能浮。二虽能不善。三善能。不能浮者。于一切时。手攀池边所有草木。然后乃浴。能浮而不善者。于一切时。或攀池边草木。或时不攀而浴。善能浮者。于一切时。不攀草木。入中而浴。闻慧如第一人浴。思慧如第二人浴。修慧如第三人浴。复有说者。闻慧为三慧作因。思慧为思慧作因。不为闻慧作因。以下故。不为修慧作因。以界异故。修慧与修慧作因。不为闻慧作因。以下故。不为思慧作因。以界异故。复有说者。闻慧有三慧果。思慧唯有思慧果。修慧唯有修慧果。复有说者。闻慧现在前唯闻慧修。思慧现在前唯思慧修。此修是行修非得修。性劣不及未来故。修慧现在前时。三慧俱修。此是三慧体性。乃至广说

已说体性。所以今当说。何故名闻思修耶。答曰。从闻生故说闻。从思生故说思。从修生故说修

界者闻慧在欲色界。思慧在欲界。修慧在色无色界。问曰。欲界中何故无修慧。答曰。欲界是不定界。非离欲地。非修地。若欲修时。便堕思中。色界何故无思慧。答曰。色界是定地。修地离欲地。欲思时便堕修中。复有说者。欲界中。尽有三慧。问曰。何者是修慧。答曰。见道边等智空空三昧。无愿无愿三昧。无相无相三昧。尽智边所有善根是也。以少故不说。色界有二种。谓闻修。无色界一种谓修。复有说者。欲界有三种。色界有三种。无色界有二种。谓思修。复有说者。欲界有三种。色界有三种。无色界有三种。评曰。不应作是说。如初说者好。地者闻慧在七地。思慧在欲界。修慧是有漏在十地。无漏九地。依者闻慧依欲色界身。思慧依欲界身。修慧依三界身。行者闻思慧。行十六行。亦行余行。修慧行十六行。亦行余行。问曰。若尽行十六行。亦行余行。有何差别。答曰。闻思慧自力不能未来得修。因他力故。未来得修。修慧自力未来得修。缘者俱缘一切法。念处者俱是四念处。智者闻思慧是等智。修慧是十智。根者闻修慧与三根相应。思慧与喜舍根相应。定者闻思慧不与定相应。修慧与三定相应。亦不与定相应。世者是三世法。缘三世者。是缘三世。亦缘非世。善不善无记者。是善缘善。不善无记者。是缘三种。三界系者。闻慧是欲色界系。思慧是欲界系。修慧是色无色界系。亦是不系。缘三界系者。尽缘三界系。亦缘不系。是学无学非学非无学者。闻思慧是非学非无学。修慧是三种。缘学无学非学非无学者。尽缘三种。见道断修道断不断者。闻思慧是修道断。修慧是修道断亦不断。缘见道修道不断者。尽缘三种。缘自身他身非身法者。尽缘三种。缘名缘义者。是缘名义。在意地。在六识身者。尽在意地。非五识身。为是生得。为方便者。尽是方便。佛有几。声闻辟支佛有几。答曰。佛有三种。以修慧为名。所以者何。如来自然成道。有力无畏故。辟支佛亦有三种。以思慧为名。所以者何。以内自思惟。自然成道故。声闻亦有三种。以闻慧为名。所以者何。从闻得生诸善功德故。复有说者。此三慧。尽可言是闻慧。所以者何。如说多闻能知法。乃至广说。亦可言尽是思慧。所以者何。如经本说。思者是业。忆者是慧。亦可言尽是修慧。所以者何。如说云何修法。答曰。有为善法。是世尊亦说三慧。所谓言说究竟慧。禅定究竟慧出要究竟慧。闻慧即是言说究竟慧。思慧即是禅定究竟慧。修慧即是出要究竟慧

云何为觉。云何为观。乃至广说。问曰。何故作此论。答曰。此二法所行相似。世人见多觉者。言是人多观。见多观者。言是人多觉。今欲说其体性亦说差别故。复次譬喻者。作如是说。说觉观是心之异名。为止如是说者意亦明觉观是心数法故。而作此论

云何为觉。答曰。心于缘贯彻。种种贯彻。乃至广说。如是等语。尽显说觉相。云何为观。答曰。若心行缘。种种行缘。乃至广说。如是等说。尽显说观相

觉观有何差别。问曰。何故复作此论。答曰。此二法相似。虽说体性。亦应说差别。觉观有何差别耶。答曰。如经本说。粗心是觉。细心是观。若作是说。明觉观是心。复有说者。若心粗时是觉。心细时是观。若作是说。明觉观不在一心中。复有说者。应作是说。心中粗者是觉。细者是观问曰。云何一心中。有粗细相违法耶。答曰。以所作异故。可得粗所作是觉。细所作是观云何粗以猛利故。云何细不猛利故。如以针刺身生受。觉所作亦尔。如以鸟翅根刺身生受。观所作亦尔。如一两盐和一两水置之口中。盐生舌识则猛利。水生舌识则不猛利。觉所作当知如盐。观所作当知如水。一两水。一两苦酒。喻亦如是。法身经亦说。如天雷时。声有粗细。觉所作当知如粗声。观所作当知如余细声。铜铃铜器。出粗细声。亦如是。亦如鸟飞虚空。鼓其两翼。当知如觉。踊身得去。当知如观。若作是说。明觉观不在一心中。此经所说。明觉观在一心中

分别有三种。有自体分别。有忆念分别。有现观分别。自体分别者。谓觉是也。忆念分别者。谓念是也。现观分别者。谓慧是也。欲界五识身。有一种分别。谓自体分别。虽有念不能忆念。虽有慧不能了了现观。意地有三种分别。初禅地三识身有一种分别。谓自体分别。虽有念不能忆念。虽有慧不能了了现观。意地不入定时。有三种分别。入定有二种分别。除现观分别。第二第三第四禅。不入定时。有二种分别。除自体分别。入定有一种分别。谓忆念分别。无现观分别。以极定故。无色中不入定心。有二种分别。除自体分别。若入定有一种分别。谓忆念分别

云何为掉。云何为心乱。乃至广说。问曰。何故作此论。答曰。此二法相似。有人心掉。世人言是人心乱。有人心乱。世人言是人心掉。或谓此二法是一。今欲决定说其体性亦欲说差别故。而作此论

云何为掉。答曰。心不休息。不寂静。乃至广说。如是等语。尽说掉相。云何心乱。答曰。心观不住。乃至广说。如是等语。尽说心乱相。或有说者。染污三昧是心乱。复有说者。染污三昧所不摄余相应法名心乱。评曰。不应作是说。如前说者好

问曰。掉与心乱有何差别。何故复作此论。答曰。此二法相似。虽说体性。亦应说差别。掉与心乱。有何差别。答曰。不休息相是掉。心不住一缘是心乱。复有说者。发动定心是掉。令心驰散于外是心乱。外者谓色声香味触。掉能发动定心。如泉水初出心乱令心驰散色声等。如水流遍池中。如人坐床。一人来挽臂使起。一人驱驰令行。掉发动定心。如挽臂使起。心乱令心驰散色等缘中。如驱驰令行。若掉是心乱耶。若心乱是掉耶。乃至广作四句。掉非心乱者。若心数数行一缘中是也。心乱非掉者。若心行多缘中。不数数行是也。掉亦是心乱者。若心行多缘中。亦数数行是也。非掉非心乱者。心行一缘。非数数行是也。尊者佛陀提婆说曰。若心是乱。彼亦是掉。或有掉非心散。心行一缘。亦数数行。犹如有人。行一道中。而常驰走。彼亦如是。问曰。三摩提即心乱耶。答曰。染污三摩提是心乱。如先所说。有十大地受乃至慧。有十烦恼大地。谓不信懈怠乱念心乱无明恶慧不正作观邪解脱掉放逸。此十大地。十烦恼大地。名有二十。体有十五。所以者何。如受想思触欲。此名有五。体亦有五。如不信懈怠无明掉放逸。此名有五。体亦有五。如作观解脱念定慧。若不染污是大地。若染污是烦恼大地。是以名有十体有五。是故十大地。十烦恼大地。名有二十。体有十五。复有说者。名有二十。体有十六。所以者何。心乱体异。定体亦异故。若是大地。是烦恼大地耶。若是烦恼大地。是大地耶。乃至广作四句。是大地非烦恼大地者。受想思触欲是也。是烦恼大地非大地者。不信懈怠无明掉放逸是也。是大地亦是烦恼大地者。作观解脱念定慧是也。作观即是耶作观。解脱即是耶解脱。念即是乱念。定即是心乱。慧即是恶慧。非大地非烦恼大地者。除上尔所事。若作是说。体有十六者。是大地非烦恼大地有六。受想思触欲定是。烦恼大地非大地有六。谓不信懈怠心乱无明掉放逸是。大地亦是烦恼大地者。作观解脱念慧。若不染污是大地。若染污是烦恼大地。非大地非烦恼大地者。除上尔所事。评曰。不应作是说。如前说者好。有十小烦恼大地。谓忿嫌覆恨悭嫉诳谄憍害。有十善大地。谓信猗进惭愧不贪不恚不放逸不害舍。有五不善大地。谓无明睡掉无惭无愧。有三隐没无记大地。谓无明睡掉。有十不隐没无记大地。谓受乃至慧。大地一切心中可得。烦恼大地。一切染污心中可得。小烦恼大地。非一切染污心中可得。所以者何。所作各异故。若有一则无二。此是修道所断意地欲界心中可得。是故说小不说大。善大地。一切善心中可得。不善大地。一切不善心中可得。隐没无记大地。一切隐没无记心中可得。不隐没无记大地。一切不隐没无记心中可得

有定缘一缘是散乱。缘一缘非散乱。行一行是散乱。行一行非散乱。缘一缘行一行是散乱。缘一缘行一行非散乱。缘多缘是散乱。缘多缘非散乱。行多行是散乱。行多行非散乱。缘多缘行多行是散乱。缘多缘行多行非散乱。缘一缘是散乱者。如一比丘。缘是法。不净思惟。于缘中未善习。若作青想。若作赤汁想。若作烂想。若作胀想。若作己啖想。若作血涂想。若作散想。若骨想。若琐想。若骨琐想。作如是观时。其心散乱。不作一缘。不作一识。前定已失。后定不进。是名定一缘是散乱

缘一缘非散乱者。如一比丘。缘是法。不净思惟。于缘善习。若作青想。若赤汁想。乃至作骨琐想。作如是观时。心不散乱。作一缘。作一识。前定不失。能进后定。乃至广说

行一行是散乱行者。如一比丘。行无常行。于此行不善修习。复观无常。复观须臾。复观前后不相似。复观前后坏灭。作如是观时。其心散乱。前定已失。后定不进。乃至广说

行一行非散乱者。如一比丘。行无常行。于此行。善修习。复观无常。乃至观于坏灭。作如是观时。心不散乱。前定不失。能进后定。乃至广说

缘一缘行一行是散乱者。如一比丘。观身是无常。于此观不善修习。复观此身是无常。乃至观身是坏灭。作是观时。其心散乱。前定已失。后定不进。乃至广说

缘一缘行一行非散乱者。如一比丘。观此身无常。于此观善修习。复观此身无常。乃至观身坏灭。作是观时。心不散乱。不失前定。能进后定。乃至广说

缘多缘是散乱者。如一比丘。观身是无常。于此观不善修习。复观于受。观心观法。乃至失于前定。不进后定。乃至广说

缘多缘非散乱缘者。如一比丘。观身是无常。于此观善修习。复观受心法。乃至不失前定。能进后定。乃至广说。行多行是散乱者。如一比丘。观无常行。于此观不善修习。复观苦空无我行。乃至失于前定。不进后定。乃至广说

行多行非散乱者。如一比丘。观身是无常。于此观善修习。复观苦空无我行。乃至不失前定。能进后定。乃至广说。缘多缘行多行是散乱者。如一比丘。观身是无常。于此观不善修习。复观受是苦。观心是空。观法是无我。作是观时。其心散乱。失于前定。不进后定。乃至广说

缘多缘行多行非散乱者。如一比丘。观身是无常。于此观善修习。复观受是苦。观心是空。观法是无我。作是观时。心不散乱。不失前定。能进后定乃至广说

云何无明。云何不智。乃至广说。问曰。何故作此论。答曰。不解不了是无明。不智相是不智。或谓此二法是一。欲决定说其体相。亦欲说差别故。而作此论

云何无明。答曰。如经本说。不知三界是也。若作是说。则不摄缘灭道无明使。应作是说。三界中无知是也。则摄缘灭道无明使。云何不智。答曰。无巧便慧是也。问曰。何故问少答多耶。所以者何。不智是染污。无巧便慧是染污不染污。何以知之。如业揵度说。诸意恶行。尽是无巧便意业耶。答言。诸意恶行。尽是无巧便意业。颇有无巧便意业非意恶行耶。答言。有隐没无记意业。不隐没无记无巧便意业是也。答言。此文应如是说。云何不智。答言。染污慧。应作是说。而不说者。有何意耶。答曰。当知此义有余。云何无巧便不智。答曰。染污者。是非不染污。复有说者。无巧便二种。一者假名。二者真实。业揵度说。于假名。此唯说真实。如是汝语。无巧便慧。是不智耶。此说是定言。不定他言。不应说过。答曰。如是。于意云何。汝意有如是欲如是说。诸知故妄语。尽是失念。不知而妄语耶。答曰。如是。我有如是意如是欲如是说诸知故妄语。尽是失念。不智而妄语。于意云何。有无智故妄语耶。答曰。不也。听我说汝违言负处。故作是说。诸知故妄语。尽是失念。不智而妄语。应作是说。无智故妄语。不应作是说。知故妄语。应作是说。不智而妄语。所以者何。从不智生故。若不作是说。不应言不智是无巧便慧。若说有知故妄语。不应作是说。诸知故妄语。尽是失念。不智而妄语。若作是说。此事不然。答曰。虽从不智生。而知故妄语。非不智故妄语。问曰。若然者。何故言知故妄语耶。答曰。知彼事故。而相违说。是故言知故妄语。非不智故妄语。复有说者。若于大众中。问于彼人知此事不。若知言知。不知言不知。彼人实知。而言不知。是故言知故妄语。复有说者。若现前知觉此事时。与此事相违说。是故言知故妄语。复有说者。于彼事了了现见。而违彼事说。是故言知故妄语非不智故妄语。若如汝。说从不智生。故言不智故妄语非知故妄语者。妄语不但从不智生。乃从多法生。谓十大地。十烦恼大地。受乃至慧。不信乃至放逸。何故舍如是等法。但言不智故妄语。于意云何。汝有如是欲如是说。一切无明与不智相应耶。答曰。如是。于意云何。诸知故妄语。尽是无明。愚无明俱失念。不智故而妄语耶。答曰。如是。复于意云何。有无不智故妄语耶。答曰。无也。听我说汝。违言负处。如是汝语知故妄语尽是无明愚无明俱失念不智故而妄语。应作是说。有无不智故妄语。不应但说不智故而妄语。亦应说有无明故妄语。所以者何。从无明生故。若不说无明故妄语。不应作是说。一切无明。与不智相应。若作是说。诸知故妄语。尽是无明。愚无明俱失念。不智故而妄语。如汝所说。虽从无明生。不名无明妄语。我亦如是。虽从不智生。不名不知故妄语。然知故名妄语

云何慢云何憍。乃至广说。问曰。何故作此论。答曰。此二法相似。见慢者。世人言是人憍。见憍者世人言是人慢。或谓此二法是一。今欲决定说其体性。亦欲说差别故。而作此论

云何慢。于卑谓胜。于等谓等。因此起慢。乃至广说。问曰。云何于等谓等。而作慢耶。答曰。犹如有一人。诵半阿含。有余缘故。而更不进。更有一人。始诵阿含。此二后时一齐诵竟。而后诵者。便起于慢。是名于等起慢。云何憍。我生处胜。族姓胜。色胜。种胜。巧胜。财胜。端正胜。因如是等胜故起憍。豪乃至广说。是名憍。慢憍有何差别。问曰。何故复作此论。答曰。此二法相似。虽说体性。亦应说其差别。憍慢有何差别。答曰。缘他故自计胜。是慢相。不缘他。自于法中。心生染污。是憍相。问曰。慢体性是何。答曰。或有说者。体性是憍。问曰。若然者。憍慢有何差别。答曰。慢有二种。一缘他生。二缘自生。缘他生者是慢。缘自生者是憍。复有说者。体性是爱。所以者何。如说自于法中。心生染污。复有说者。有心数法名憍。与心相应在意地。修道所断爱后生。问曰。若然者。憍慢有何差别。答曰。有多差别。慢是烦恼。憍非烦恼。慢是结缚使恼缠。憍非结缚使恼缠。是烦恼垢。复有说者。慢是见道修道所断。憍是修道所断。问曰。无色界慢。见道所断。慢云何缘他生耶。答曰。本于此间。修行广布。后生彼间。以因力故。亦现前行。复有说者。虽生彼间。而不现行。于此间因。入定起慢心。我于定善。他则不善。我能速入。他则不能。我能久住。他则不能。云何见道所断慢。缘他生耶。答曰。如我见者。聚在一处。更相问言。汝我有何相耶。答曰。我我有如是相。他人闻已。作如是念。彼说我相相则不如我。因身见后。生如是慢。复有说者。无始已来。常习此法。不必因他而生。如尊者阿泥卢头。生如是慢。诣尊者舍利弗所。作如是言。我以天眼。观千世界。不多用功。乃至广说。尊者舍利弗而语之言。此是汝慢。如此慢则不因他生。然慢多分因他生故。言因他生。亦有因自生者

若生增上慢我见苦是苦。乃至广说。问曰。何故作此论。答曰。或有说者。慢能缘他界。亦缘无漏。为止如是说者意亦明慢是自界缘缘有漏故。而作此论

若生增上慢。我见苦是苦。此增上慢。何所缘耶。答曰。犹如有一亲近善知识。善知识者。谓佛佛弟子是也从其闻法。闻法者。闻随顺涅槃方便法。内正思惟。正思惟者。谓自修正行。复有说者。正思惟者。观生死是过患。观出要是善利。如法修行。如法修行者。谓次第行法得于顺忍。顺忍者谓顺谛忍也。依此四须陀洹枝故。于苦有忍有欲有说。依如是等法。身心润益。以是忍力。令诸行衰微羸劣。于谛转明。便作是念。我见苦是苦不观故。须臾见疑不行。问曰。此文应如是说。无有正观故。须臾见疑不行。而不说者有何意。答曰。当知此义不观者。即是不正观义须臾见疑不行。见者谓身见戒取。疑者即疑西方沙门。复作是说。见者是戒取。疑即是疑。所以者何。得忍者身见不行。设有行者。亦复不觉。所以者何。以根钝故。所行微细。不久住故。是以不觉。复次见疑行细。行者心粗。是以不觉。复次以五事故。众生烦恼不行。一以定力故。二以慧力故。三依善师故。四以处所好故。五性少烦恼。彼烦恼不行故。作如是念。我见苦是苦。因此起慢。乃至广说。问曰。此增上慢。何缘取。答曰。缘苦能生增上慢者。是顺谛忍。缘集生增上慢。亦如是。若生增上慢。我见灭是灭。此增上慢何缘。犹如有一亲近善知识。广说如上。乃至我见灭是灭。因此起慢。乃至广说。问曰。此增上慢何缘。答曰。即缘彼心心数法。能生增上慢忍者。若作是说。则上慢缘无漏者意亦非他界缘。亦非无缘。若生增上慢。我见道是道。此中应广说如灭。问曰。此慢为是欲界。为是色界耶。若是欲界者。此慢缘忍。欲界无忍善根。若是色界者。离欲者可尔。未离欲者云何可尔。答曰。或有说者。应作是说。是色界慢。所以者何。彼慢缘顺谛忍。欲界中无顺谛忍。问曰。若然者离欲者可尔。未离欲者云何。答曰。经本所说。明离欲者。复有说者。未离欲者。亦能起此慢。所以者何。依未来禅与根本禅相似故。评曰。不应作是说。如前说者好。复有说者。是欲色界。问曰。色界者可尔。所以者何。缘彼忍故。欲界者云何可尔。彼慢不能缘忍。自界缘故。答曰。欲界中虽无忍。有与忍相似善根。为慢所缘。所以者何。欲界中。尽有一切善根种子故。以欲界中有忍相似善根故。慢亦能缘。若生增上慢。我生已尽。乃至广说。此增上慢何缘。乃至广说。问曰。此增上慢。前所说者。有何差别。答曰。或有说者。先所说者。是凡夫增上慢。后所说者。是凡夫圣人增上慢。如凡夫圣人。见谛不见谛。得果不得果。得正决定。不得正决定住决定聚。住不决定聚。住正定不住正定。当知亦如是。复有说。先所说者。因见道生。后所说者。因修道生。复有说者。先所起慢有所因。后所起慢无所因。复有说者。前者是欲色界。后者是三界。若生增上慢。我生已尽。此何缘。答曰。犹如有一作是念。此道此迹。我依此道。依此迹。乃至广说。此道者。随其处作道想。此道迹者。随其处作道迹想。生已尽者。随其处作生想。问曰。此增上慢。何缘耶。答曰。缘生随彼善根。能生增上慢者。是生梵行已立说亦如是。乃至此增上慢何缘。答曰。即缘彼能生慢。心心数法。梵行已立者。阿罗汉。于学道名梵行已立。于无学道名今立。所作已办者。犹如有一作是念。此道此迹。乃至所作已办。我已断烦恼。已害使。已吐结。已制伏缠。如是等语。尽明断义。文虽种种。而无异义。所以者何。若断烦恼。即是断害使吐结。制伏于缠。问曰。此增上慢何缘耶。答曰。即缘能生增上慢。心心数法

若生增上慢。我更不受有。乃至广说。问曰。何故复作此论。答曰。前说是因时解脱增上慢。今说是因不时解脱增上慢。前说是因尽智增上慢。今说是因无生智增上慢故。而作此论

此增上慢何缘。答曰。即缘能生增上慢。有凡夫能起五种增上慢。一于善根。二于须陀洹。三于斯陀含。四于阿那含。五于阿罗汉。须陀洹起三种。斯陀含起二种。阿那含起一种。阿罗汉无慢。复有说者。圣人亦起果间增上慢。如须陀洹于斯陀含向中起慢。斯陀含于阿那含向中起慢。阿那含于阿罗汉向中起慢。诸起色界增上慢者。要得彼根本地。能起彼地增上慢。所以者何。彼地烦恼。属彼地故。若不得根本地。不能起彼地烦恼。复有说者。未至法亦有似根本地。若得彼地者。亦能起彼地慢。评曰。不应作是说。如前说者好。云何卑而起慢。乃至广说。问曰。何故作此论。答曰。慢法自高卑他此慢。自卑高他。或谓此非是慢。今欲决定说是慢故。而作此论。云何卑而起慢。犹如有一见他胜。若生处姓种色工业财富田宅。见他是事作是念。彼少胜我不如彼。谓生处乃至田宅。然彼不如他非百倍千倍。生处者有四种。谓刹利。婆罗门。毗舍。首陀。姓者有四种。一婆瑳。二憍瑳。三舍持罗。四婆罗矬(音在和反)阇。亦更有余姓。一佉尼迦夷那。二舍荼蛇尼那。三拘荼蛇尼那。色者谓白红赤黑。种者谓父种母种。工者谓彩画等。业者于工巧中得利胜。财富者谓色声香味触。及其具。田宅者谓居业是也。见他有如是等事作是念。彼少胜我我少不如彼。色等乃至田宅。然彼非百倍千倍。而彼言一倍二倍胜我。我一倍二倍不如彼。便自高卑他而起于慢

有七慢。一慢。二过慢。三慢过慢。四我慢。五增上慢。六卑慢。七邪慢。问曰。此慢几见道断。几修道断。答曰。三修道断。谓慢过慢增上慢。余见道修道断。复有说者。二见道断。谓我慢邪慢。余是见道修道断。复有说者。一是修道断谓增上慢。二是见道断。谓我慢邪慢。余四见道修道断。复有说者。尽是见道修道断。问曰。若然者。云何我慢邪慢。修道断耶。答曰。身见缘五种断法。计苦谛所断法是我。于此后生我慢。乃至计修道所断是我。于此后生我慢。是名我慢修道所断。云何修道断邪慢。答曰。邪见缘五种所断法。邪见谤苦谛所断法言无。于此后生邪慢。乃至谤修道所断法言无。于此后生慢。是名修道断于邪慢。问曰。七慢几在欲界。几在色无色界耶。答曰。或有说者。三在欲界。谓过慢慢过慢卑慢。余在三界。所以者何。色界无计生处等起慢故。复有说者。尽在三界。问曰。若然者。色无色界。无计生处等起慢。乃至广说。答曰。本于此间。修行广布。以因力故。于彼亦起现前复有说者。彼中虽不现行。于此因是故亦起现行。言我定胜我定少不如彼

又世尊言。有三觉。谓欲觉恚觉害觉。乃至广说。问曰。何故作此论。答曰。此是佛经。佛经有三觉。欲觉恚觉害觉。而不广分别。云何欲觉自害。乃至广说。佛经是此论所为根本。诸经中不说者。今欲说故而作此论

云何欲觉自害。答曰。犹如有一起欲爱缠身热心热。所以者何。欲爱缠如火烧于自身。世尊亦说有三种火。谓贪欲火。嗔恚火。愚痴火。身热心热。是彼依果。长夜起欲爱缠三恶道中。受不爱报。乃至广说。是彼报果。是名欲觉自害。云何欲觉害他。答曰。犹如有一起欲爱缠。眼视他妻。其夫见之。自骂其妇。加诸苦害等。是名欲觉害他。问曰。此亦是俱害。所以者何。彼眼看者。亦受苦害等。答曰。彼看者。其夫不能加害。若加害者。则为他人之所呵责。是以不说。云何欲觉俱害。答曰。犹如有一起欲爱缠。淫犯他妻。俱有过故。而被杀害。是名俱害。问曰。此是三害。何以言俱。所以者何。彼杀者。被杀者。亦受罪故。答曰。彼虽是害。不为世人所呵责。而为世人所誉。云何此人憎恶恶法。是以不说。云何恚觉自害。答曰。犹如有一起于恚缠。身热心热。乃至广说。是彼依果。长夜起恚缠。故于三恶道。受不爱果。乃至广说。若生人天中。形色丑陋。是彼报果是名恚觉自害。云何恚觉害他。犹如有一起于恚觉。断他人命。是名害他。问曰。若断他命。是名俱害。何以但言害他。答曰。虽断他命。不为世人之所呵责。不尽受现世罪。是故不说。云何俱害。犹如有一断他人命。以断他命。还断其命。问曰。还断其命。是名三害。何以言俱。答曰。虽还断他命。不为世人所呵。而受叹美。言是人笃亲里笃亲友。云何害觉自害。答曰。犹如有一起害觉缠。身热心热。乃至广说。是彼依果。长夜起害觉故。乃至广说。是彼报果。是名自害。云何害他。答曰。犹如有一若杖打他。乃至广说。是名害他。此中难答如上。云何俱害。答曰。犹如有一起害觉缠。若手若杖打他。他亦还打。是名俱害。此中问答如上

问曰。此三觉体性是何。答曰。欲觉者是欲界五种断六识身。爱相应觉也。恚觉者是五种断六识身。恚相应觉也。害觉者或有说者。恚觉即是害觉。问曰。若然者恚觉害觉有何差别。答曰。恚觉有二种。或有欲舍众生意。或有但欲打意。若欲舍众生意。是恚觉若欲打意。是害觉。复有说者。恚觉有二种。或有可恚事生恚。或有不可恚事生恚。可恚事生恚相应觉是恚觉。不可恚事生恚相应觉是害觉。复有说者。无明相应觉是害觉。何以知之。如施设经说。以何等故。众生有重愚痴。答言。修行广布害界害想害觉故。有重愚痴。彼相应觉。是名害觉。复有说者。亦非恚相应觉。亦非无明相应觉。自有心数法名害。与心相应。是恚垢依恚。恚后起现在前在意地。是修道所断。此说是真实义

有三善觉。谓离欲觉。无恚觉。无害觉。问曰。此三觉体性是何。答曰。离欲觉者是心数法。是心相应对治欲觉。无恚觉无害觉。说亦如是。一心中不得有三不善觉。得有三善觉。三不善觉。不遍一切不善心中。三善觉遍一切善心中。三不善觉。不与一切不善心相应。三善觉与一切善心相应。三不善觉。不摄一切不善觉。三善觉摄一切善觉。所以者何。三善觉无别体故。问曰。若三善觉无异体者。云何立三觉耶。答曰。以对治故。立三善觉。对治欲觉故。名离欲觉对治恚觉故。名无恚觉。对治害觉故。名无害觉

佛经说。比丘当知。我本勤行精进。而不放逸。欲断烦恼。而犹生欲觉恚觉害觉。问曰。菩萨若不放逸。不应生三不善觉。若生三不善觉。云何名不放逸。尊者和须蜜答曰。菩萨虽起不善觉。勤行精进故。名不放逸。菩萨若起不善觉时。速能自知是不善觉此是烦恼非是好法。复有说者菩萨若生不善觉时。即舍即吐。依其对治。复有说者。菩萨虽生不善觉。不令久住。寻即制伏除去。以是事故。虽生不善觉。是不放逸。复次菩萨虽生不善觉。寻断其因。除其依。觉知所缘。是故名不放逸。复次众生。以三事故。生诸烦恼。一以因力。二境界力。三方便力。菩萨虽生不善觉。非境界力。非方便力。是本因力故。名不放逸。尊者佛陀提婆说曰。菩萨虽生不善觉。不令经久。即时制伏。依其对治。经须臾间。如一渧水堕热铁上。是故名不放逸。问曰。菩萨于何处起欲觉。何处起恚觉。何处起害觉。答曰。或有说者。菩萨舍迦毗罗卫丰乐之国及现在转轮王位。犹如弃唾。而诣多波树林渐次至王舍城。以日初分。手执藕叶。入王舍城乞食。尔时菩萨形容甚妙。百千众生而随逐之。或以偈颂。而赞叹者。或有叹咏而称告者。或有合掌而礼拜者。或有仰观无厌足者。尔时菩萨作如是念。此诸人等。初始见我。生于欢喜。甚为希有。便生爱心。爱相应觉。是名欲觉。尔时菩萨所往之处。多人随逐。当于此日。竟不得食。作是思惟。是诸人等。何故随逐我耶。心生厌患。与厌患相应觉。是名恚觉。依此二法。生于尘秽。是名害觉。复有说者。菩萨出迦毗罗卫。住多波林。是时诸释遣侍者五人。二是母亲。三是父亲。给侍菩萨。是时五人。二以欲是净。三以苦行是净。尔时菩萨勤行苦行。以欲是净。二人便舍之去。以苦行是净。三人而犹随侍。是时菩萨舍苦行处。还受饮食。酥油涂身。暖水澡浴。是时三人作如是念。今观此人。于断结法。便为错乱。即舍之去。是时村主有二女人。一名难陀。二名难陀婆罗。给侍菩萨。时彼二女。成就妙触。或时摩触菩萨手足。是时菩萨便生爱心。与爱相应觉。是名欲觉。是时菩萨复作是念。若彼五人。不舍我者。我则不亲近女人以为给侍。于彼五人。便生恚心。是名恚觉。依此二法。生于尘秽。是名害觉。复有说者。菩萨在家时。输头檀王。取五百玉女。以为其妻。菩萨舍此快乐之处。诣多波林。是时诸王遥闻悉达今已出家。即遣使者。白输头檀王。王子悉达。今已出家。便可悉还我等诸女。输头檀王作如是言。我子悉达虽复舍我出家。今见其妻。如见子无异。云何相还。是时诸王心生忿恚。合集诸军。围迦毗罗城。或有说者。天神往语菩萨。或有说者。输头檀王。遣使往语。今坐汝故。令我苦恼。是时菩萨便于父所。生于爱心。于爱心相应觉。是名欲觉。于彼诸王。生于恚心。是名恚觉。依此二法。生于尘秽。是名害觉。尊者瞿沙说曰。菩萨修苦行时。以根利故。于欲界闻思善根。随意能得。便作是念。此诸善根。随顺于我。虽善积集。欲界善根。犹生烦恼。是时菩萨于此善根。便生爱心。行于爱禅。自于身中。生于爱心。爱相应觉。是名欲觉。菩萨根猛利故。即时自知我今已起爱。即是烦恼所不应为。便生恚心。是名恚觉。依此二法。能生垢秽。是名害觉。复有说者。菩萨行苦行时。是时恶魔于六年中。随逐菩萨。欲求其短。或以好形或以恶形。而现菩萨。若以好形现时。菩萨尔时便生爱心。与爱相应觉是名欲觉。若以恶形现时。菩萨是时便生恚心。是名恚觉。依此二法。生于尘秽。是名害觉。复有说者。菩萨在菩提树下。忆念先所更五欲境界。生于爱心。是名欲觉。闻提婆达入己宫中。便生恚心。是名恚觉。诸释纵之。便生害心。是名害觉。复有说者。菩萨在菩提树下。尔时天魔遣三天女。一名渴爱。二名喜乐。三名喜见。菩萨见之。便生爱心。是名欲觉。魔王复将三十六亿兵众。欲相恼乱菩萨便生恚心。是名恚觉。亦于魔众。而生害心。是名害觉。又世尊言。比丘当知。我本行菩萨道时。起于欲觉自害害他亦俱害乃至害觉亦如是。问曰。云何菩萨欲觉自害害他亦俱害耶。答曰。觉相应尔。若起欲觉。则自害害他亦俱害。复有说者。起欲觉时。舍自利益事。是名自害。舍他利益事。是名害他。舍自利利他事。是名俱害。复有说者。起欲觉时。自于身取果与果。是名自害。令施衣服等者。不得大界。是名害他。自害害他故。是名俱害。依果报果。说亦如是。复有说者。能令自心染污堕邪道中。是名自害。余如上说。复有说者。能令自身远离圣乐。是名自害。令他远离。是名害他。余如上说。复有说者。能令自身远圣定慧。是名自害。令他远离。是名害他。余如上说。复有说者。能令自身远解脱果。是名自害。余如上说。是故尊者瞿沙。作如是说。能令自身远离解脱。是名自害。令阿私陀阿罗荼郁陀迦等。不得圣道。是名害他。余如上说。尊者佛陀提婆说曰。若起烦恼。能令身心远一切智。离于圣乐。为烦恼作依。是名自害。令施者不得大报。是名害他。余如上说。复有说者。能令自身心热。是名自害损他施等。余如上说。复有说者。令自身心不适。是名自害。诸天呵责。是名害他。余如上说

如经说。如来初成道时。多起二种觉。一安隐觉。二寂静觉。问曰。云何名安隐觉寂静觉耶。答曰。或有说者。无恚无害觉是安隐。离欲觉是寂静。复有说者。恚觉害觉对治。是名安隐觉。欲觉对治。是名寂静觉。复有说者。无恚无痴善根相应觉。是名安隐。无贪善根相应觉。是名寂静。复有说者。对治恚痴不善根。是名安隐。对治贪欲不善根是名寂静。复有说者。慈悲相应觉。是安隐。喜舍相应觉。是寂静。复有说者。喜舍相应觉。是安隐。慈悲相应觉。是寂静。复有说者。苦智集智相应觉。是名安隐。灭智道智相应觉是寂静。复有说者。灭道智相应觉是安隐。苦集智相应觉是寂静。复有说者。空苦集无愿相应觉。是名安隐。无相无愿相应觉。是名寂静。复有说者。无相无愿相应觉。是名安隐。空苦集无愿相应觉。是名寂静。复有说者。见增长是过患。是名安隐。见止息是善利是名寂静。是故尊者瞿沙。作如是说。作方便见增长是过患。是安隐觉。行止息乐。是寂静觉。尊者佛陀提婆说曰。如来有无量大悲心怜愍心利益心淳净心。如是等相续善心。是名安隐觉。见增长是过患止息是寂静觉。问曰。何故如来初成道时。多起此二觉耶。答曰。以此二觉能净无上道最在初故。复有说者。菩萨在宫人中。恒患多起欲觉。是以初成佛时。起寂静觉。行苦行时。恒患身疲苦。是以初成佛时。起安隐觉

阿毗昙毗婆沙论卷第二十三阿毗昙毗婆沙论卷第二十四

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    杂干度中思品之二

智多耶。所知多耶。乃至广说。问曰。何故作此论。答曰。欲明善说法中三法等故。谓智所知行所缘觉所觉。恶说法中。此三法不等。为颠倒所覆故。是以欲明善说法三法等故。而作此论。智多耶所知多耶。答曰。所知多非智多。所以者何。所知摄十七界一界少分十一入一入少分四阴一阴少分。智摄一界一入一阴少分。复有说者。智多非所知多。所以者何。如非想非非想处一受。为欲界十种智所缘谓欲界苦集所断五。他界缘见使苦集所断。他界缘疑无明相应智善等智。如是初禅乃至无所有处。尽有十一。一智有九种。十智有九十种。自地则有十一遍智。谓七见苦集所断疑无明相应。四智善等智不隐没无记智如一受。一切受亦尔。如受一切心心数法亦尔。智增益如山。所知不增益。是故智多非所知多。若如是说者。所知多非智多。所以者何。欲界十种智相应法。是所知非智。乃至非想非非想处。十三种智相应法。是所知非智。然智亦是所知。设令智非所知者。所知犹多。所以者何。所知摄十七界一界少分十一入一入少分四阴一阴少分。智摄一界少分一入少分一阴少分。何况智亦是所知。是故所知摄十八界十二入五阴。智摄一界一入一阴少分。是故所知多非智多

智多耶识多耶。乃至广说。问曰。何故作此论。答曰。欲决定重明所知多非智多。所以者何。一切智处尽有识。非一切识处尽有智。何处无智耶。谓忍相应识。一切识处。不必有智。是故识多非智多。智尽与识相应。识不必与智相应。何处不相应。谓忍也。所以者何。忍非智故

问曰。何故忍非智耶。答曰。以不决定故忍非智。忍唯能见。不能知故。忍是初观非毕竟故。忍是求觅非转还故。忍所作不舍方便故。忍虽是疑对治。犹与疑得俱非决定故非智。无碍解脱道。虽同所作。不得俱在一刹那中故。尊者和须密说曰。欲可此事名忍。不可忍时名智。尊者佛陀提婆说曰。所见究竟是智。忍时所见非究竟故非智。复有说者。若以阴界入故。识多非智多。所以者何。识摄七识界。智摄一界少分。识摄一入一阴。智摄一入一阴少分。是故识多非智多

有漏行多。无漏行多。乃至广说。问曰。何故作此论。答曰。为止并义者意。如摩诃僧祇部说。佛生身是无漏。彼何故作如是说。答曰。彼依佛经。佛经说。比丘当知。如来生世住世。出现世间。不为世法所染。以是义故。知如来生身是无漏。为止如是说者意明如来生身是有漏故。而作此论。若如来生身是无漏者。无比女人。不应于如来身生染心。央掘魔罗。不应生恚憍慢。婆罗门不应生慢。优楼频蠡。不应生愚。以如来生身生他爱恚或生慢痴。是故知如来生身非是无漏。问曰。若如来生身。是有漏非无漏者。摩诃僧祇部所说。经云何通。答曰。彼经说如来法身。所以者何。若说如来生世住世。则说如来生身。若说出现世间不为世法所染。则说如来法身。复次不为世法所染者。如来不为世八法所染。世人随顺世八法。世八法亦随顺世人。世八法随顺如来。如来不随顺世八法。已解脱世法故。言不染世法。问曰。如来亦有世八法有利者。如优伽长者。一日中施佛三百万两财。无利者。如于婆罗婆罗门村乞食。空钵而入。空钵而还。有誉者。生时名彻他化自在天。成道时。名彻阿迦腻吒天。转法轮时。名彻梵天。非誉者。旃遮女孙陀利女。谤非誉名彻十六大国。毁者。如婆罗婆阇恶口婆罗门。以五百偈现前骂佛。称者。还以五百偈赞佛。如婆只奢优婆离。以种种偈。赞舍利弗。赞叹佛无上法。阿难赞叹佛希有法。乐者。谓猗乐及得一切世间最胜乐。苦者。如佉陀罗剌剌脚。亦以瓦石伤于足指。头痛背痛。如来亦有如是等世法。云何言不为世法所染。答曰。世尊虽遇有利等四法。而心不高。虽遭无利等四法。而心不下。虽遇有利等四法。心不生爱。虽遭无利等四法。心不生恚。如爱恚欣戚忧喜说亦如是。譬如须弥山王安立在于金轮上。四方猛风不能倾动。佛亦如是。安立戒轮之上。世间八法不能倾动。是故为止他义欲现己义故。而作此论。有漏行多。无漏行多。答曰。有漏行多。非无漏行多。所以者何。有漏行摄十入二入少分。无漏行摄二入少分。复有说者。无漏行多。非有漏行多。所以者何。如欲界系一法。四无漏法缘。谓苦法忍苦法智。集法忍集法智。如欲界一法。余欲界法亦如是。如色界系一法。四无漏法缘。谓苦比忍苦比智。集比忍集比智。如一法。余色界法亦如是。无色界说亦如是。犹有余无漏法。是故无漏行多。非有漏行。复有说者。有漏行多。非无漏行。所以者何。如一无漏法为四种有漏法所缘。谓邪见疑无明善等智。如一无漏法。一切无漏法亦如是。余有漏法犹多。是故有漏行多。非无漏行有为法多。无为法多耶。答曰。或有说者。有为法多。非无为法。所以者何。有为法摄十二入一入少分。无为法。摄一入少分。复有说者无为法多。非有为法。所以者何。随所有有漏法。有尔所数灭法。随所有无漏道。有尔所非数灭法。余无为法者。有有漏法非数灭虚空。是故无为法多。非有为法

云何行具足。云何守具足。乃至广说。问曰。何故作此论。答曰。此是佛经。佛经说。我圣弟子戒具足守具足。乃至行具足守具足。佛经虽说。而不分别。云何行具足。云何守具足。诸佛经中。所不说者。今欲说故。而作此论

云何行具足。答曰。无学身戒口戒命清净。问曰。如学人。非学非无学人。亦有此法。何以唯说无学人耶。答曰。以无学人胜故。广说无学人胜。应如上第三品中。戒具足者。戒言尸罗。亦言行。亦言守信。亦言器。尸罗者。言冷。无破戒热故。破戒者身心热。持戒者身心冷。破戒者三恶道中。热持戒者人天中冷。又尸罗言梦。持戒者身心不热。常得善梦故。又尸罗言习。持戒者善习戒法故。又尸罗言定。住戒者心易定故。又尸罗言池。如佛说偈

  法泉戒水池　　清净无瑕秽
  圣浴身不湿　　必到于彼岸

又尸罗如璎珞。有璎珞严身。有少时好中年老年则不好。有中年好少年老年则不好。有老时好少年中年则不好。戒璎珞严身。三时常好如佛说偈

  戒终老安　　信善安止　　慧为人宝
  福无能盗

又尸罗如镜。如镜明净。像于中现。戒清净者。无我像现。如说依戒立戒。升无上慧堂。又尸罗言威势。如来所以于三千大千世界。有威势者。皆是尸罗力故。曾闻罽宾国有龙。名阿利那。受性暴恶。去其住处不远。有僧伽蓝。其龙数为暴害。时有五百阿罗汉。皆共集会。入于禅定。以神足力。欲驱遣此龙。其大龙大威德。而不能遣。时有一罗汉。次从后至。时诸罗汉。具以是事。向后来者说。时后来者。不入禅定。直弹指语言。贤善远此处去。是时此龙。闻弹指声。即便远去。时诸罗汉。语后来者言。汝以何禅定力。令此龙去耶。后来者而答之言。我不以禅定力。直以谨慎于戒。我守护轻戒。犹如重禁。我以戒力故。令此龙去。是故尸罗名有威势。又尸罗言头。如人有头则能见色闻声嗅香尝味觉触知法。如是行人有尸罗头者。能见苦谛等色。闻名身等义。嗅觉意花香。尝出离无事寂静三菩提味。觉禅定解脱等触。如色阴等法总相别相。是故尸罗言头。何故尸罗名守信。此是世俗言说法。若人善护尸罗者。言是人守信。不能善护尸罗。言是人不。守信。是故世俗言说。尸罗名守信。尸罗言行者。如人有足能行至余方。如是行人有尸罗足者。能行至善道及至涅槃。又尸罗言器者。以是一切功德所依之处。是故尸罗言器。尊者瞿沙说曰。不破义是尸罗义。如人不破于足。能有所至。如是行者不破尸罗故。能至涅槃

云何守具足。答曰。阿罗汉诸根戒是也。此诸根。亦言守亦言根。亦言生亦言泉。亦言白净。亦言所作。守者守境界故言守。复有说者。以念慧等根。守境界故言守。如镰能刈名刈具。彼亦如是。根等余处当广说。此中略故不说。问曰。根戒根非戒体性是何。答曰。是念慧。何以知之。如经说。天神语比丘言。莫生疮疣。比丘答曰。我当覆之。天复问言。疮疣既大。以何覆耶。比丘答言。以念慧覆之。如余偈说

  诸世所有流　　正念能除断
  亦因念慧力　　亭住而不行

是故念慧是根戒体性。乱念恶慧是根非戒体性。问曰。若念慧是根戒体性者。此经云何通。如说念慧满足故。能满足根戒。云何以自体。满自体耶。答曰。不也。所以者何。念慧有因性。亦有果性。因性者。说名念慧。果性说名根戒。复有说者。不放逸是根戒。放逸是根非戒。复有说者。六常住法是根戒。诸烦恼依此六门而生。是根非戒。复有说者。五根若断若知得成就。是根戒。若五根不断不知不得不成就。是根非戒。若作是说。则明成就不成就是根戒。非根戒。复有说者。若成就缘五根烦恼。不成就断缘五根烦恼对治。是名根非戒。若不成就缘五根烦恼。成就断缘五根烦恼对治。是名根戒。若作是说。则明成就不成就是根戒是根非戒。复有说者。染污性是根非戒。不染污性是根戒。复有说者。若五根能生恶行烦恼。是非戒。若五根能生善根善行是戒。世尊亦说。根戒根非戒。若作是说。则明根戒根非戒是五阴性。复有说者。罽宾国有二阿罗汉。作如是说。根戒是不隐没无记性。所以者何。不定故。不说在善中。不说在不善中。问曰。若体性不定者。云何说此是根戒此是根非戒。答曰。不隐没无记体是一行。或时随顺善。或时随顺不善。若随顺善时。是名戒。若随顺不善时。是名非戒

问曰。已说根戒根非戒。断戒云何。答曰。若以世俗道。断欲界结。未至禅所摄九无碍道断对治是也。若依二禅边。断初禅结。第二禅边所摄九无碍道是也。如是乃至非想非非想处边。断无所有处结。非想非非想边所摄九无碍道是也。若以无漏道。断欲界结。未至禅所摄九无碍道是也。断初禅结。三地所摄九无碍道是也。如是次第。第二禅是四地。第三禅五地。断第四禅结。及无色界见道所断是六地。空处修道所断是七地。识处八地。无所有处。非想非非想处。修道所断是九地。九地所摄无碍道是断戒

云何凡夫性。乃至广说。问曰。何故作此论。答曰。为止异义者意故。如犊子部说。欲界见苦所断十种烦恼。是凡夫性。彼说凡夫性。定是欲界系是染污。是见道断。是相应。为止如是说者意明凡夫性是三界系是不染污。是修道所断是不相应法故而作此论。云何凡夫性。答曰。若不得圣法。乃至广说。问曰。为不得一切圣法是凡夫性。为不得苦法忍是凡夫性耶。若不得一切圣法。是凡夫性者。无有圣人得一切圣法者。则无非凡夫性人。佛世尊则非成就一切无漏法。谓声闻辟支佛无漏法。及自身学法。若不得苦法忍。是凡夫性者。道比智已生。舍苦法忍。应是凡夫性。答曰。或有说者。应作是说。不得苦法忍。是凡夫性。问曰。若然者。道比智生舍苦法忍。是凡夫性耶。答曰。苦法忍生时。破凡夫性。永更不生。苦法忍。不得言得。不得言不得。如不得未来眼根。得现在者。以得现在眼根故。破未来眼根。不得未来眼根。不名得。不名不得。彼亦如是。复有说者。道比智生舍苦法忍。体性是不得。如不得未来眼根。得现在眼根。而不得过去眼根。如是得道比智。不得苦法忍。问曰。若然者云何非凡夫性耶。答曰。成就依果故。圣人身中。无有不成就苦法忍。依果时虽不成就苦法忍。而非凡夫。常是圣人。问曰。若不得圣法。是凡夫性者。如说云何凡夫性。三界不染污心不相应行。其义云何。答曰。若说不得圣法是凡夫性者。即明三界不染污心不相应行义。所以者何。不得圣法性。即是三界不染污心不相应行。复有说者。先说是对治。后说是体性。复有说者。凡夫性体是一法。犹如命根。非不得性是不染污心不相应行修道所断。评曰。不应作是说。体性是不得圣法。如是说者好。复有说者。不得一切无漏法。是凡夫性。问曰。若然者。无有圣人尽成就一切无漏法者。则无非凡夫性。答曰。虽无圣人尽成就一切无漏法者。然非凡夫。所以者何。亦有不得圣道。亦有得圣道故。复有说者。若不得是不共。是凡夫性。若不得是共。非凡夫性。复有说者。若不得不破。是凡夫性。若不得破。是非凡夫性。复次亦不得圣暖圣忍圣见圣欲圣慧。乃至广说。问曰。此复显现何义耶。答曰。先是略说。今是广说。先不分别。今则分别。复有说者。此说极下凡夫。不得达分善根者。圣暖者是暖法。圣见者是顶法。圣忍者是下中忍。圣欲者是上忍。圣慧者是世第一法。是故此中说极下凡夫。复有说者。此中唯分别苦法忍。所以者何。苦法忍。亦名暖见忍欲慧。令有种子热故名暖。转行故名见。堪忍故名忍。可谛故名欲。分别故名慧。复有说者。令有种子热故名暖。转行故名见。行忍故名忍。欲解脱故名欲。觉知故名慧。是故此中唯分别苦法忍

凡夫性。当言善耶。乃至广说。答曰。凡夫性。当言无记。所以者何。善法由善方便得。亦由余善法得。由方便者。是方便善根。由此善根。亦令余善未来世修。如见道边等智尽智边所得三界善根。问曰。此中何故不说生得善耶。答曰。应说而不说者。当知此说有余。乃至广说。复有说者。若胜好善。此中则说。彼是下劣。是故不说。复有说者。方便得善说。方便善根。由他得善。说离欲得善。复有说者。方便生善。说达分胜进分善根。由他得善。说住分退分善根。复有说者。此文应如是说。善法若方便得。若得方便者。是方便得。得者是生得。复有说者。得善法若方便。若离欲若得若退。复有说者。方便得者。是方便生。若得者善根断还生时得善根是也。无有作方便求为凡夫。所以者何。无有本非凡夫者。此是下贱法故。无有求者。若凡夫性是善则有大过。断善根时。永灭善法。不成就得。是时应非凡夫。若极恶下贱。非凡夫者。是事不然。欲令无如是过故。凡夫性不当言善。何故非不善耶。答曰。凡夫离欲界欲。不成就不善法。离欲界则非凡夫。以如是说。则止凡夫性。是不善者意。若凡夫性。是不善者。凡夫人离欲界欲者。则不应还生欲界。然还生欲界。是故凡夫性不得言不善

凡夫性当言欲界系耶。乃至广说。答曰。凡夫性。或欲界系。或色无色界系。问曰。凡夫性何故不当言定欲界系耶。答曰。欲界没生无色界。乃至广说。问曰。何故不说欲界没生色界中耶。答曰。欲界没生色界中。虽舍欲界法而不悉舍。生无色界悉舍。所以者何。生色界中犹成就欲界法。谓欲界变化心。生无色界。不成就欲界法。以是事故。不当言定欲界系。何故不当言定色界系。答曰。色界没生无色界中。悉不成就色界系法。问曰。色界没生欲界中。亦舍色界法。此中何以不说耶。答曰。虽舍色界法而不悉舍。生无色界悉舍。是故说色界没生无色界。乃至广说。若当定是色界系者。阿私陀阿罗荼郁陀迦等。则不应还生。复次所以不说色界没生欲界者。色界没生欲界中。成就色界法。生无色界。悉不成就色界法。是以不说。何故凡夫性。不当言定无色界系。答曰。得正决定时。乃至广说。法应如是。若成就彼地凡夫性。先见彼地苦。然圣道生为凡夫性。作对治故。若圣道生。先见无色界凡夫苦者。凡夫性当言定无色界系。但不尔。问曰。若以圣道初生者。凡夫性当言定欲界系。答曰。不应以此设难。彼说不当言定欲界系者。先已说故

凡夫性当言见道断耶。乃至广说。答曰。凡夫性当言修道断。不当言见道断。所以者何。见道所断法悉染污。凡夫性非染污。若是见道断者则是染污。然凡夫性非染污。其事云何。若是见道。如世第一法灭。乃至广说。染污法要断得不成就。随断几种染污法。得不成就彼种。乃至广说。是时未断一种染污法。而不成就凡夫性。若凡夫性是染污法者。行者亦是凡夫。亦是圣人。所以者何。住苦法忍时。成就五种染污法。是时亦是具缚。亦是圣人。问曰无有成就色无色界凡夫性者。何以言是时三界凡夫得不成就耶。答曰。或有说者。此文应如是说。三界中凡夫。得不成就。而不说者有何意耶。答曰。欲令三数满故作如是说。成就欲界凡夫性。不成就色无色界凡夫性。若不成就欲界凡夫性。是人不名成就三界凡夫性。是故欲令三数满故作如是说。复有说者。断其可生处故作如是说。彼有更生之处。令悉断之。令彼法不复得生。复有说者。欲令不成就法复不成就故。云何不成就法复不成就耶。答曰。欲令极远故。复有说者。三界凡夫性。得非数灭故说三界

凡夫性是何等法耶。答曰。三界不染污心不相应行。问曰。何故复作此论。答曰。为止说凡夫性定欲界系是染污是见道断是相应法者意故。而作此论。说三界则止定在欲界。不染污则止染污。修道断则止见道断。不相应则止是相应法者意。问曰。凡夫性体性是何。答曰。如此经说。不得圣道。乃至广说。此中说凡夫性是不成就不隐没无记心不相应行行阴所摄。问曰。凡夫性。非行阴所摄。所以者何。心不相应行法中。不说此法故。答曰。亦说在如是等诸法名心不相应行中。此是凡夫性体性。乃至广说

已说体性。所以今当说。凡夫性是何义。阿毗昙人说曰。凡夫分凡夫性。凡夫身凡夫体。是凡夫性义。尊者瞿沙说曰。与凡夫相似义是凡夫性义。如牛似牛故名牛性。余禽兽等亦如是。尊者和须蜜说曰。多处受身义是凡夫性义。异界生义是凡夫性义。趣异趣义是凡夫性义。更诸生义是凡夫性义。受诸生义是凡夫性义。信异师义是凡夫性义。行异类义是凡夫性义。造异业义是凡夫性义。尊者佛陀提婆说曰。受异界异趣异生增长生死义是凡夫性义。行异类义是凡夫性义

问曰。何故名凡夫耶。尊者和须蜜说曰。受异生异界异生处造异业行异烦恼信异师行异类等诸法故名凡夫。尊者佛陀提婆说曰。异于圣法故名凡夫。问曰。何故说凡夫法耶。答曰。此法是凡夫所有故名凡夫法。犹如圣人所有法名圣法。复次凡夫等得此法。成就在身中。是故名凡夫法。复次凡夫为此法所覆所蔽所缠故。名凡夫法。复有说者。凡夫人。作此法。行此法。随逐此法。故名凡夫。尊者佛陀提婆说曰。此法是凡夫人法。生增长凡夫性故。名凡夫法。问曰。凡夫法。凡夫性。有何差别。答曰。因是凡夫性。果是凡夫法。如因果作已作。广说亦如是。复次无记是凡夫性。善不善无记是凡夫法。无报是凡夫性。有报无报。是凡夫法。如有报无报生一果二果。无惭无愧相应。无惭无愧不相应。说亦如是。复次凡夫性摄一阴少分。凡夫法摄五阴。复次凡夫性是不相应。凡夫法是相应不相应。如相应不相应。有依无依等。说亦如是。复次凡夫性是不染污。凡夫法是染污不染污。尊者佛陀提婆说曰。异趣所行。是凡夫性。异趣所得阴界入法。是凡夫法。如牛羊禽兽所行是牛羊禽兽性牛羊禽兽所得法是牛羊禽兽法。如是等相。是名差别

若凡夫性不断。亦成就凡夫性耶。若成就凡夫性。彼凡夫性不断耶。乃至广作四句。凡夫性不断不成就凡夫性者。生欲界凡夫人。未离初禅欲。从初禅乃至非想非非想处。凡夫性不断亦不成就。离初禅欲未离第二禅欲。从第二禅。乃至非想非非想处。凡夫性不断亦不成就。乃至离无所有处欲。非想非非思处。凡夫性不断亦不成就。生初禅凡夫人未离第二禅欲。第二禅乃至非想非非想处。凡夫性不断亦不成就。离第二禅欲未离第三禅欲。从第三禅乃至非想非非想处。凡夫性不断亦不成就。乃至离无所有处欲。非想非非想处。凡夫性不断亦不成就。如凡夫人生初禅。乃至生识处。说亦如是。凡夫人生无所有处非想非非想处。凡夫性不断亦不成就。凡夫人则尔。圣人云何。圣人未离欲界欲。从欲界乃至非想非非想处。凡夫性不断亦不成就。离欲界欲未离初禅欲。从初禅乃至非想非非想处。凡夫性不断亦不成就。乃至离无所有处欲。未离非想非非想处欲。非想非非想处。凡夫性不断亦不成就。是名不断亦不成就。成就非不断者。凡夫人生欲界。离欲界欲。成就欲界凡夫性非不断。生初禅离初禅欲。乃至广说。无所有处。离无所有处欲。成就无所有处凡夫性非不断。是名成就非不断。不断非不成就者。凡夫人生欲界中。未离欲界欲。欲界凡夫性不断非不成就。生初禅未离初禅欲。乃至生无所有处。未离无所有处欲。说亦如是。生非想非非想处。彼凡夫性不断非不成就。是名不断非不成就。非不断不成就者。凡夫人生欲界中。乃至离无所有处欲。从初禅地。乃至无所有处。凡夫性非不断不成就。生初禅中离无所有处欲。从第二禅。乃至无所有处。凡夫性非不断不成就。乃至生识处。离无所有处欲。无所有处凡夫性非不断不成就。空处乃至欲界。凡夫性非不断不成就。凡夫人生无所有处识处。乃至欲界。凡夫性非不断不成就。生非想非非想处无所有处。乃至欲界。凡夫性非不断不成就。一切阿罗汉。三界凡夫性。非不断不成就。阿那含离无所有处欲。从欲界乃至无所有处凡夫性。非不断不成就。乃至圣人离欲界欲。未离初禅欲。欲界凡夫性。非不断不成就。是名非不断不成就。若凡夫性已断亦不成就耶。若不成就凡夫性已断耶。乃至广作四句。彼初句作此第二句彼第二句作此初句彼第四句作此第三句。彼第三句作此第四句。凡夫性若是数灭。复是非数灭耶。若是非数灭。复是数灭耶。乃至广作四句。是数灭非非数灭者。凡夫人离欲界欲。乃至离无所有处欲是也。是非数灭非是数灭者。圣人未离欲界欲是也。是数灭亦非数灭者。圣人离欲界欲。诸地说亦如是。乃至阿罗汉。三界凡夫性。得数灭亦得非数灭。非数灭非非数灭者。未离欲凡夫人是也。问曰。颇有法一种时舍九种时断耶。答曰有。谓凡夫性是也。一种时舍者。谓苦法忍是也。九种时断者。谓离欲界欲时。乃至离非想非非想处欲时是也。诸法与邪见相应。复与邪觉邪。乃至广说。问曰。何以说凡夫性。次说八邪枝耶。答曰。以此二法展转相扶持故。凡夫性扶持八邪枝。八邪枝扶持凡夫性。复次行者憎恶此八邪法。而修道故。诸法与邪见相应。复与邪觉邪。乃至广作四句。邪见一切地中可得。非一切染污心中可得。邪觉一切染污心中可得。非一切地中可得。此中说谤因果邪见。不尽说五邪见。是以作大四句。与邪见相应非邪觉者。邪觉相应邪见。欲界未至禅地禅地邪见相应聚中邪觉体。与邪见相应非邪觉。所以者何。以三事故。自体不应自体。一者一刹那中无二邪觉。二者前后刹那不俱。三者除其自体。与他一切法作缘。余邪觉不相应邪见相应法。彼是何耶。谓禅中间。乃至无色界。九大地法。九烦恼大地睡心观。如是等法。与邪见相应非邪觉。所以者何。彼地无邪觉故。邪觉相应非邪见者。邪见相应邪觉。欲界未至禅初禅邪见体。应于邪觉。所以者何。以三事故。自体不应自体。如前说。余邪见不相应邪觉相应法。彼是何耶。除欲界未至禅初禅邪见相应法。诸余染污聚邪觉相应法。谓身见边见戒取见取疑爱恚慢不共无明相应聚。如是等法。与邪觉相应非邪见。所以者何。彼聚中无邪见故。邪见相应亦邪觉者。除邪觉应邪见。除邪见应邪觉。余邪见邪觉相应法。彼是何耶。谓欲界未至禅初禅邪见邪觉相应聚。除其自体。除慧余有九大地。余恶慧。余九烦恼大地。心观睡时眠时。如是等法。与邪见相应。亦应邪觉。不与邪见邪觉相应者。邪觉不应邪见。彼是何耶。谓除欲界未至禅初禅邪见相应聚邪觉。诸余染污聚邪觉体。不应邪见。所以者何。聚各异故。亦不应邪觉。所以者何。自体不应自体。以三事故。亦如上说。邪见不应邪觉。彼是何耶。谓禅中间。乃至无色界邪见。不应邪觉不应邪见。所以者何。以三事故。自体不应自体。亦如上说。亦不与邪觉相应。彼地无觉故。诸余心心数法。谓除中间禅乃至无色界邪见相应法。诸余染污聚。不与邪见相应。彼聚中无邪见故。不与邪觉相应。彼地中无邪觉故。善心不隐没无记心。色无为心不相应行。善心无记心不应者。非染污故。色无为心不相应行不应者。非缘法故

诸法与邪见相应。复与邪方便耶。若与邪方便相应。复与邪见耶。乃至广作四句。邪见一切地可得。非一切染污心中可得。邪方便一切地一切染污心中可得故。作中四句。邪见相应非邪方便者。邪方便应邪见。邪见相应邪方便体。应于邪见非邪方便。以三事故。自体不应自体。亦如上说。应邪方便非邪见者。谓邪见邪方便聚中邪见体。应邪方便非邪见。所以者何。以三事故。自体不应自体。亦如上说。余邪见不相应法邪方便相应法。彼是何耶。除邪见相应聚。诸余染污聚。与邪方便相应非邪见。如是等法。与邪方便相应非邪见。所以者何。彼聚中无邪见故。与邪见亦与邪方便相应者。除邪方便应邪见。诸余邪见相应法。除邪方便者。以邪方便多故。除邪见相应聚邪方便体。彼是所除。诸余邪见相应法。亦除邪见体。是为于彼聚中除邪方便体。亦除邪见体。诸余心心数法。彼是何耶。谓除慧余九大地。除恶慧余九烦恼大地。心觉观睡无惭无愧眠应随相说。不与邪见邪方便相应者。邪方便不应邪见。彼是何耶。谓除邪见相应聚。诸余染污聚。彼聚中邪方便体。不应邪见。所以者何。彼聚中无邪见故。不应邪方便。以三事故。自体不应自体。亦如上说。诸余心心数法。谓善不隐没无记。色无为。心不相应行。善心不隐没无记心。非染污故。色无为心不相应行。非缘法故。如邪见邪方便。邪念邪定。说亦如是。邪觉对邪方便邪念邪定亦如是

诸法与邪方便相应。复与邪念相应耶。乃至广作四句。此二法一切地一切染污心中可得。是故作小四句。与邪方便相应不与邪念相应者。谓邪念是也。邪念体应邪方便非邪念。所以者何。以三事故。体不自应。亦如上说。邪念相应非邪方便者。谓邪方便是也。余如上说。亦与邪方便邪念相应者。除邪方便邪念体。诸余染污心心数法。彼是何耶。除念余九大地八烦恼大地睡觉观眠时心。无惭无愧应随相说。非邪方便非邪念相应者。诸余心心数法。谓善心不隐没无记心。色无为心不相应行。所以如前说。如邪方便对邪念。对邪定亦如是。邪念对邪定亦如是

问曰。此八邪枝。几在欲界。几在色无色界。答曰。欲界有八。色界有八。无色界有四。除邪语邪业邪命邪觉。几见道断。几修道断。答曰。一是见道断。谓邪见。三是修道断。谓邪语邪业邪命。四是见道修道断。谓邪觉邪方便邪念邪定。问曰。此中何故最后说诸邪枝耶。答曰。欲显现世第一法功用故。此干度初明出要善法。如世第一法。能入见道。能生圣道。圣道见道。能坏邪见。是故始明圣道。终明邪道

  世第一及智　　人品与爱敬
  无惭色无义　　思品最在后

阿毗昙毗婆沙论卷第二十四宋本此卷首云。智犍度八道品中。若成就见亦成就智耶云云。乃至卷末云。与喜觉支相应非念觉支相应者等。凡二十六纸文。其与国本宋本迥异者何耶。今捡宋本错乱。此文全是此论第四十八卷之文。而重书为此第二十四卷耳。今依二本正之阿毗昙毗婆沙论卷第二十五

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    使揵度不善品第一之一

三结乃至九十八使。尽是佛经。唯除五结九十八使。此非佛经。此章中应除此二论。曾闻尊者瞿沙作如是说。一切阿毗昙论。尽解佛经。因此经故。作如是论。诸经中不说者。皆悉除之。此二论非经所说。是故应除五结说五上分结。所以者何。五上分结。是佛经故。除九十八使。更无所说。非佛经故。复有说者。五结此章中不应除。所以者何。佛于增一阿含五法中说。以经久故。而亡失之。尊者迦旃延子以愿智力。观察于阿毗昙中。还说五结。曾闻增一阿含。从一法至百法。而今唯有从一法至十法者在。余悉亡失。从一法至十法。亡失甚多。在者犹少。如尊者奢那婆秀阿罗汉是尊者耆婆迦和上般泥洹时。是日亡失七万七千本生经一万。阿毗昙论。从是以后更不复行。一论师灭犹失尔所经论。何况佛法中多论师灭。复有说者。此二论虽非佛经。不应除之。问曰。若非佛经何故不除。答曰作经者意欲尔。随其所欲。而造此论。亦不违法相。于此论中。说一切遍。说非一切遍。说一切遍非一切遍。一切遍者。三结是也。非一切遍者。五结是也。一切遍非一切遍者。九结是也。问曰。五结可尔。九十八使。亦非佛经。何故不除。答曰。一切阿毗昙广解佛经义。若广解佛经义者。是阿毗昙。佛经说七使。以界以种以行差别故。有九十八使。是故此二论俱不应除。问曰。彼尊者造论。何故先立章。答曰。欲显现诸门义故。所以者何。若不先立章者。则门义不显。如人不能采画虚空。若欲画时。必有所依。彼亦如是。复次欲令此论久住世故。虽立章门造偈颂制揵度作品名。百千众中。乃有一人能具足诵持阿毗昙者。何况不立章门乃至品名。而能具足诵持此烦乱文。欲令无如是过故。而先立章。问曰。彼尊者何故因佛经而立章耶。答曰。以一切阿毗昙尽广解佛经义故。复次欲显现佛经有无边义故。外道书论有文无义。虽有义而少。如罗摩延书。其文有万二千偈。唯明二事。一明罗摩延劫思陀去。二明罗摩将思陀罗。一切佛经皆是无量无边。无量者有无量义。无边者有无边文。犹如大海无量无边。无量者谓深无量。无边者谓广大无边。复次欲显现佛经堪忍问难转精妙故。外道书论不堪问难。若其问难转不牢固。无有义味。如猿猴子不耐打触。若其打触便失粪秽。佛经堪耐打触。若打触时则出清净戒色及善根触。亦如波罗奈衣堪耐打触。若加打触光色转妙出生妙触。彼亦如是。复次欲显现佛经发则妙故。佛经说有三事。覆则妙发则不妙。谓愚人女人婆罗门书三事。发则妙覆则不妙。谓智人日月佛经。复次欲显现佛经堪耐思求转精妙故。如人观日眼不明净。外道书论思求之时。使慧眼不净。如人观月眼则明净。佛法经论思求之时令慧眼明净。复次先作是说。一切阿毗昙尽广解佛经义。以是事故。如来所说。种种不相似义。立杂揵度。说诸结义。立结使揵度。乃至说见义。立见揵度。一一揵度中。分别一切法。问曰。彼尊者造论。何故先立章后作门。答曰。如人造舍。先平治地然后立舍。彼尊者亦复如是。欲造法舍如平地法。先立于章。如造舍法后立于门。复次如人种树。先治地然后乃种。彼尊者亦复如是。欲种法树如治地法。先立于章。如种树法。后作于门。复次如华鬘师华鬘弟子欲造种种鬘时。先经其缕。然后以种种色华而庄饰之。彼尊者亦复如是。欲造法鬘。如经缕法。先立于章。如以华庄饰之。后作于门。复次如画师画弟子。欲画之时。先摹其像。后布众采。彼尊者亦复如是。如摹像法。先立于章。如布采法。后作于门。复次犹如工匠工匠弟子。先量其木。后刻支体。彼尊者亦复如是。如量木法。先立于章。如刻支体法。后作于门。复次如行者观法。先观四大造色。后观微尘刹那。彼尊者亦复如是。如观四大造色法。先立于章。如观微尘刹那法。后作于门。复次世尊说法亦尔。先说后解。先说者。如说六界六触十八意行四处。比丘当知。是名为人。后解者此名六界乃至四处。彼尊者亦复如是。先立于章。后作于门。复次欲现二种善故。先立于章。现善于文。后作于门。现善于义。如善于文义。于文义有力。于法无碍。于义无碍。法无碍果。义无碍果。当知亦如是。复次欲现己知见不错乱故。若人知见错乱所造经论。亦复错乱。不能善立章门乃至品名。若人知见不错乱者。所造经论亦不错乱。善立于章乃至品名。是故欲显己知见不错乱故。先立于章后作于门

问曰。以何等故。彼尊者作经先立三结为章。后乃至九十八使。答曰。彼作经者有如是欲如是意随其欲意造作此论。亦不违法相。是故先立三结为章。后乃至九十八使。尊者波奢说曰。虽一切处生疑。然不违法相。若先说三不善根。后乃至九十八使。亦有此疑。复次阿毗昙应以相求。不应以次第求。前说后说俱无有过。复次亦可随义说其次第。所以先立三结为章。后乃至九十八使。若一一阿毗昙求其次第。则经文烦乱。谁能具足受持阿毗昙烦乱文者。复次为增法故。先说三结。后说四五六七九。至九十八使。复次为说烦恼树次第增长法故。先说三结。后说四五六七九。至九十八使。复次欲次第说得四沙门果故。若断三结。得须陀洹果。不尽断三不善根及欲漏。得斯陀含果。尽断得阿那含果。永断有漏无明漏。得阿罗汉果。余流扼缚取盖下分结上分结见身爱结使等。皆是有漏差别。广分别漏。是故欲说次第得四沙门果故。先立三结为章。后乃至九十八使

三结身见戒取疑。问曰。此三结体性是何。答曰。体性有二十一种身见三界见苦所断有三种。戒取三界见苦见道所断有六种。疑三界见苦集灭道所断有十二种。此二十一种。是三结体。我物相性分

已说体性。所以今当说。何故名结。结是何义。答曰。缚义是结义。合苦义是结义。杂毒义是结义。缚义是结义者。缚即是结。何以故。知如经说。尊者摩诃拘絺罗往尊者舍利弗所。作如是问。为色缚眼。为眼缚色。乃至意法亦如是问。舍利弗答尊者摩诃拘絺罗。色不缚眼。眼不缚色。其中欲爱。是其缚也。譬如白牛黑牛同一。扼靷而以系之。尊者拘絺罗。于意云何。若有说言黑牛系白牛白牛系黑牛。为是如法说不。答言。不也。然彼扼靷是其缚。如是尊者拘絺罗。色不缚眼。眼不缚色。但于其中。欲爱是缚。乃至意说亦如是。以是事故。知结即是缚。合苦义是结义者。欲界诸结与欲界苦众生合。色界诸结与色界苦众生合。无色界诸结与无色界苦众生合。欲界诸结与苦合相。不与乐合。色无色界诸结与苦合相。不与乐合。以是事故。合苦义是结义。杂毒义是结义者。一切受生妙有漏定。如无量解脱除入一切处定等。圣所远离。以杂烦恼毒故。犹杂毒食。虽复美妙智人远之。彼亦如是。以是事故。缚义合苦义。杂毒义是结义。佛经说。若断三结。名须陀洹。不堕恶趣。决定入究竟道。唯受七有七生天上人中。得尽苦际。问曰。如阿毗昙说。断八十八使。名须陀洹。如池喻经说。断无量苦。名须陀洹。以何等故。世尊说。若断三结。名须陀洹。答曰。或有说者。此是如来有余说。略言要言。为受化者。作如是说。复次为人故。为时众故。为受化者故。为法器故。所以者何。诸佛说法。尽为受化者。智有深浅。亦观其心及与结使。其心者。所谓善根。结使者。谓诸烦恼。观察其心及烦恼已。随其烦恼。说对治法。亦不说少。若说少者。则不能除烦恼之病。亦不说多。若说多者。则是如来无利之说。譬如医师治病。先观其病及病所因。然后投其对治之药。亦不少投。若少投者。其病不愈。亦不多投。若多投者。唐捐其功。随其所应。而投其药。彼亦如是。复次若略说断三结。名须陀洹。若广说则断八十八使及无量苦。名须陀洹。如略说广说不分别分别顿说次第说亦如是。复次为利根者。说断三结名须陀洹。为钝根者。说断八十八结及无量苦名须陀洹。如利根钝根。因力缘力。内力外力。依内思惟力。依外说力。揵智迟智。说亦如是。复次欲说易行法以诱进受化者。如牵他手令其起故。此中应说跋耆子喻。曾闻有跋耆子。于佛法出家。是时已制二百五十戒。令族姓子随其所乐而履行之。彼人闻已。生忧虑心。谁能守护如此诸戒。便诣佛所。头面礼足。而白佛言。世尊。制二百五十戒。令族姓子随其所乐而奉行之。我今不堪守护此戒

尔时世尊。示亲善相而不呵责。以软美言而慰喻之。善哉善哉。跋耆子。汝能善学三戒不耶。谓善学戒。善学心。善学慧。彼人闻已。生大欢喜。作如是言。我能善学此三种戒。学三种戒故。次第能学一切诸戒。若如来说断见道所断八十八使及无量诸苦名须陀洹者。则受化者。心生忧虑。何能拔此八十八烦恼之树。度八十八烦恼大河。干竭八十八烦恼大海。摧破八十八烦恼之山。修此八十八对治之道。若佛说断三结名须陀洹。诸受化者。生大欢喜。若断三结。则是易事。若断三结。则断见道一切诸使。所以者何。同一对治断故。以是事故。说易行法。广说如上。复次欲说最胜法故。一切见道所断结中。此三结最胜。是故尊者瞿沙。作如是说。此三结是一切见道所断烦恼最胜。余随从生。如因见生爱恚慢等复次此三结。是一切见道所断烦恼无首。犹如胜军。常在前行。以彼力故。余烦恼生。复次以此三结是功德怨家。功德者。谓须陀洹果。谁是彼怨家。谓三结是也。复次此三结。是三三昧近对治。身见是空三昧近对治。戒取是无愿三昧近对治。疑是无相三昧近对治复次以此三结是近见道人数数行故。如杂揵度说。行者住忍。见疑不行。设有行者。亦复不觉。以其智劣烦恼微细故。见者谓身见戒取。疑者即是疑。复次以此三结难断难破难过。复次以此三结有增盛过重患多过。身见有何增盛过。答曰。身见是六十二见。根见是诸烦恼根。烦恼是业根。业是报根。依报生善不善无记法。戒取有何增盛过。答曰。从戒取生种种邪苦行。疑有何增盛过。答曰。疑者疑过去未来世。内怀犹豫。此是何。云何有此。谁造此。此当云何。此众生为从何来死至何所。复次以此三结虽断虽知。阿罗汉犹行相似法身见苦比忍永断。虽断虽知。阿罗汉犹行相似法。而作是说。此是我衣我钵。是我同房弟子。是我近住弟子。是我房。是我房中资生之物。似如计我戒取道比忍永断。虽断虽知。阿罗汉犹行相似法。如洗手足住阿练若。但畜三衣。广说十三清净功德。因此得毕竟净想。曾闻。尊者聋摩奢恒耆迦。虽是阿罗汉。亦日日诣水澡浴以为净想。疑道比忍永断。虽断虽知。阿罗汉犹行相似法。见于远物疑。为是人耶。为是杌耶。见于二道疑。为是所趣道耶。非所趣道耶。见二衣二钵疑。为是我衣钵。为非我衣钵耶。复次行者为断三结故。令一切见道所断结亦尽得断。复次行者为断三结故。亦见知觉识见道所断结。复次以是三结通于三界。亦是下分。欲爱嗔。虽是下分。不通三界。边见邪见见取爱慢无明。虽通三界而非下分。复次于七使中。永断无余者是中则说。须陀洹于七使中。永断二使。谓见使疑使。复次于九结中。永断无余。乃至广说。须陀洹于九结中。三结永断。谓见结疑结取结。以是事故。尊者瞿沙作如是说。此经应如是说。断三结得须陀洹。三结者。谓见结疑结取结。复次于十使中。永断无余者。乃至广说。十使者。谓五见爱恚慢无明疑。须陀洹。永断六使。谓五见疑。于六使中。唯说三使。谓身见戒取疑。不说三使。谓边见邪见见取。所以者何。此从彼生故。身见生边见。边见从身见生。戒取生见取。见取从戒取生。疑生邪见。邪见从身见生。戒取生见取。见取从戒取生。疑生邪见。邪见从疑生。已说能生。当知亦说从生。复次此是现初门现略说现始入。此见道所断结。或一种断二种断四种断。若说身见。当知已说一种断者。若说戒取。当知已说二种断。虽更无二种。即戒取名二种。戒取相应共有法。亦名二种。若说疑。当知已说四种断者。复次见道所断结。或是自界一切遍。或他界一切遍。若说身见。当知已说自界一切遍。若说戒取疑。当知已说他界一切遍。问曰。何故自界一切遍说一结。他界一切遍说二结。答曰。以他界缘于有漏亦缘无漏。若说戒取。当知已说有漏缘使。若说疑当知已说无漏缘使。如自界一切遍。他界一切遍。自地一切遍。他地一切遍。自界缘。他界缘。自地缘。他地缘。当知亦如是。复次见道所断结。或有漏缘。或无漏缘。若说身见戒取。当知已说有漏缘使。若说疑。当知已说无漏缘使。问曰。何故说二有漏缘。说一无漏缘。答曰。有漏缘者。或自界缘。或他界缘。若说身见。当知已说自界缘。若说戒取。当知已说他界缘。如有漏缘无漏缘。世缘出世缘。味缘无味缘。住缘出缘。系缘不系缘。结缘非结缘。受缘非受缘。缠缘非缠缘。当知亦如是。复次见道所断结。或有为缘。或无为缘。若说身见戒取。当知已说有为缘。若说疑当知已说无为缘。如有为缘无为缘。有常缘无常缘。有恒缘无恒缘。当知亦如是。复次见道所断结。或性是见。或性非见。若说身见戒取。当知已说见性者。若说疑当知已说非见性者。如见性非见性。视不视。转行不转行。求不求。转其心不转其心。当知亦如是。复次见道所断结。或不善。或无记。若说戒取疑。当知已说不善。若说身见。当知已说无记。如不善无记。有报无报。生一果二果。无惭无愧相应。无惭无愧不相应。当知亦如是。复次见道所断结。有二种。或性欣踊。或性忧戚。若说身见。当知已说欣踊者。若说戒取疑当知已说忧戚者。复次此三结。坏三种身。身见坏戒身。戒取坏定身。疑坏慧身。复次此三结。能坏八正道。身见坏正语正业正命。戒取坏正念正定。疑坏正见正觉正方便。复次欲令疑者得决定故。世人多深着我我所。深着吉不吉。深怀犹豫。佛言。若众生行如是法者。不名须陀洹。若不行如是法者。名须陀洹。问曰。为得初道名须陀洹。为得初果名须陀洹。若得初道名须陀洹者。第八人。应是须陀洹。第八人者。名坚信坚法。所以者何。彼得初道故。若得初果名须陀洹者。若离多分欲。若离欲界欲得正决定道比智时应是须陀洹。所以者何。初得果故。答曰。或有说者。初得道故名须陀洹。问曰。若然者。第八人。应是须陀洹。所以者何。以初得道故。答曰。初得道故名须陀洹。彼所得道。必缘于道者。是须陀洹。第八人。虽初得道。缘于苦故。不名须陀洹。复次初得道故。名须陀洹。彼道要是道比智果所摄道。是须陀洹。复次初得道故。名须陀洹。彼道要有三事。一得未曾得道。二舍曾得道。三断结同一味。得未曾得道者。谓修道是也。舍曾得道者见道是也。断结同一味者。见道所断结。都同一味证。复次初得道故。名须陀洹。彼道要有五事。一得未曾得道。二舍曾得道。三断结同一味证。四顿得八智。五具修十六行。复次初得道故。名须陀洹。住彼道时。见道所断结。永尽无余。永断缘倒结。永断忍对治结。永断邪见。复次初得道故。名须陀洹。住彼道时。其人可共谈说。可施设有相。复次初得道故。名须陀洹。住彼道时。容有生死。复有说者。初得果故。名须陀洹。问曰。若然者。断多分欲尽欲界结。得正决定道比智时。应是须陀洹。所以者何。是初得果故。答曰。初得果故。名须陀洹。要是顺次第具缚非超越人。复次初得道故。名须陀洹。是初得解脱。是初得度。是得初果人。复次初得果故。名须陀洹。要不以世俗道故断一种结。而得果者。复次初得果故。名须陀洹。是四沙门果最初果者。复次初得果故。名须陀洹。要是具四向四果者。复次初得果故。名须陀洹。是八人四双者。复次初得果故。名须陀洹。住彼道时。亦不坏地。亦不坏道。斯陀含果。虽不坏地而坏于道。所以者何。有漏无漏道。俱能得故。阿那含果。亦坏于地。亦坏于道。坏地者。依六地而得。坏道者。有漏无漏道。俱能得故。阿罗汉果。虽不坏道而坏于地。所以者何。依九地得故。须陀洹果地。亦不坏道。亦不坏不坏地者。依未至地。得不坏道者。唯以无漏道。不以有漏道得。复有说者。不以初得道故。名须陀洹。不以初得果故。名须陀洹。然以须陀洹果故。彼人名须陀洹。因法为名。犹如药水。以药为名。酥瓶油瓶。亦复如是。问曰。何故名须陀洹。答曰。须陀名圣道流。洹名为入。入圣道流故。名须陀洹。问曰。若然者。斯陀含阿那含阿罗汉。亦名须陀洹。所以者何。亦入圣道流故。答曰。此初受名。初得道故。余果名者。各自有义

不堕恶趣者。不堕三恶趣。问曰。如斯陀含阿那含阿罗汉。亦不堕恶趣。何故独说须陀洹不堕恶趣耶。答曰。亦应说而不说者。当知此说有余。复次沙门果。各自有义。如须陀洹。不堕恶趣胜故。说不堕恶趣。斯陀含一往来胜故名一往来。阿那含不还欲界胜故名不还。阿罗汉更不受有胜故名更不受有。以沙门果各自有义故。随义立名。问曰。凡夫人亦有不堕恶趣者。何以不说。答曰。应说而不说者。当知此说有余。复次凡夫人。或堕恶趣。或不堕恶趣。是以不说。圣人必定不堕恶趣。是故说之

决定者。住正决定聚故名决定。须陀洹义。应言决定般涅槃。所以者何。有般涅槃因缘故。譬如坏器。于三重屋上。投之于地未至地顷。当言必破。彼亦如是

入究竟道者。尽智无生智名道。彼人有如是欲如是期心如是可如是乐如是意近。转近彼道故。言入究竟道。唯受七有者。问曰。应受十四有若二十八有。若以本有而言。人中有七。天中有七。应有十四。若以本有中有而言。天中本有有七。中有有七。人中本有有七。中有有七。应有二十八。何故但说七有。答曰。此是七数法。不过于七。人中亦七。天上亦七。本有亦七。中有亦七。余经亦说。三说四谛。有十二行。一谛有十二行。四谛应有四十八行。三说苦谛有十二行。乃至三说道谛有十二行。应有四十八行。何故但说有十二行。此是十二数法。不离三转十二行故。余经亦说。比丘七处善。三种观义。速于圣法。能尽有漏。彼不应但七。应有三十五处善若无量处善。何故但说七处善耶。答曰。此是七数法。不离于七观。一色阴有七种。乃至识阴。亦七种故。余经亦说。比丘我今当说二法。云何二法。眼色乃至意法。是名二法。此非一二。应是六二。但是二数法故。不离于二。此七数法。不离于七。亦复如是。广说如上。问曰。何故须陀洹。唯受七有不增减耶。尊者波奢说曰。若增若减。受于有者。皆亦生疑。不以疑故。违于法相。复次有尔许报因。还受尔许报果。复次以业力故。唯受七有。以道力故。不受第八有。如人为七步蛇所螫。以四大力故能行七步。以毒力故不至第八步。复次若受第八有。彼身中应空无圣道。若空无圣道。先是见谛今非见谛。本是得正决定今不得正决定。本是圣人今非圣人。复次若受第八有者。则于过去恒沙诸佛则为外人。非是内亲。犹如世人七世相于有亲。若至八世使为外人。彼亦如是复次住增上忍时。除欲界七生分色无色界一一处生分。余一切生分得非数灭。若法得非数灭。更不复起现在前。复次以唯有七生处故。唯受七有。七生处者。谓人六欲天。是须陀洹生处。而于中生。复次彼于七有中满修七种道。永断七使。以如是事故。唯受七有。不增不减。如是诸具受七有。须陀洹。天上七有。人中七有者。然须陀洹。各有差别。或有天七人六天六人五。天五人四天四人三。天三人二天二人一。或有人七天六乃至人二天一。说亦如是。此中唯说具七有者故。说须陀洹受于七有。问曰。具受七有须陀洹。为在天上。为在人中。受第七有耶。答曰。或有说者。于此生中。得须陀洹。即数此生为七。或有说。不在七数者。若如数者。此说人中得道。天上满七。于彼般涅槃。若天上得果。人中满七。即般涅槃。若不数者。人中得果。还于人中满七有。即般涅槃。天中得果。还于天中满七有。即般涅槃。评曰。不应数初得道生在七有中。所以者何。彼生中有时。是凡夫非是圣人。若数者唯有二十七有。非二十八。若唯二十七有。则违施设经。如说须陀洹经。二十八生。必尽苦际。欲令无如是过故。不说初得道生在七有中。问曰。受七有须陀洹。于前六生中。为起圣道现在前不耶。答曰。或有说者不起。若当起者。应般涅槃。或有说者。起现在前。问曰。若然者。何故不般涅槃。答曰。以业力故不般涅槃。问曰。若满第七有时。世无佛在家而得阿罗汉耶。答曰。或有说者不得。虽无佛法于余法中。要当出家受其法服然后乃得。或有说者。在家亦得。得已不住于家。于余法出家受其法服。如是比有五百辟支佛。住仙人山中。本是声闻

天上人中者。天来人中。人住天中。犹如世人从林至园中从园至林中。彼亦如是。生者。生中有本有中

得尽苦际者。问曰。苦际为在苦中为在苦外。若在苦中。不应言苦际。若在苦外。世间现喻云何通。犹如金筹。初亦是金。中亦是金。后亦是金。苦亦如是。初亦是苦。中亦是苦。后亦是苦。何者是苦际耶。答曰。或有说者。阿罗汉最后阴是苦际。或有说者。灭尽涅槃是苦际。若作是说。阿罗汉最后阴是苦际者。不应言苦际。所以者何。体尽是苦故。答曰。以是事故。应言苦际。所以者何。更不生苦。更不与苦相续。更不造苦因。是故名苦际。若作是说。灭尽涅槃是苦际者。世间金筹现喻云何通。答曰。此不必须通。所以者何。此非修多罗毗尼阿毗昙。不可以世间现喻难贤圣法。所以者何。贤圣法异世间法异

三不善根。贪不善根。恚不善根。痴不善根。问曰。三不善根体性是何。答曰。有十五种。贪不善根。欲界五行所断爱。通六识身。恚不善根。五行所断恚。通六识身。痴不善根。欲界全四种所断无明。四种者。谓集灭道修道。苦谛所断种当分别。苦谛断无明有十种。谓与五见爱恚慢疑相应。及不共法八。是不善根。二非不善根。谓欲界身见边见相应者。问曰。因是根义。身见边见相应无明。是一切不善法因。何故不名根耶。答曰。若法体是不善。为一切不善法。作因者立根。身见边见相应无明。虽是一切不善法因。体非不善。是无记故。是故痴不善根。全是欲界四种。谓集灭道修道所断。及苦谛所断八种。通六识身无明。是此十五种。是三不善根体。乃至广说

已说体性。所以今当说。何故名不善根。不善根是何义。答曰。生义养义增义。是不善根义。充足义饶益义。滋盛义流澍不善义。是不善根义。尊者和须蜜说曰。云何不善根义。答言。不善因义是不善根义。复次不善种子义是不善根义复次发起不善义是不善根义。复次已生不善助生不善增益不善义。是不善根义。尊者浮陀提婆说曰。不善元本能生不善助生不善增益不善义。是不善根义。问曰。若因义是不善根义者。前生不善五阴。与后生不善五阴作因。前生十不善业。与后生十不善业作因。前生三十四不善使。与后生三十四不善使作因。如是等不善法。皆应是不善根。此三有何异相。立不善根耶。尊者和须蜜答曰。此是如来有余之说。略言要言。为受化者。作如是说。尊者波奢说曰。佛决定知法根。亦知势用。余人所不知。若法有不善根相。立不善根。无者不立。尊者瞿沙说曰。佛知此三法于不善法作因。速疾偏重亲近是故此三立不善根。余不善法。无此三相。故不立根。复次此三不善根。于一切不善法为元首。犹如猛将胜军在前而行。以其威力故。余不善法生。复次一切不善法中。谁为最胜。此三法。于一切不善法中。名亦最胜义亦最胜。是故立根。复次贪不善根。是不贪善根近怨对法恚不善根。痴不善根。是不恚不痴善根近怨对法。复次以此三法是功德怨家。功德者谓三善根。复次以此三不善根于一切不善法。作因作根作主作本所作。作势力作缘作增益。作集作起处。作因者犹如种子。作根者令坚牢。余随相说。复次此三不善根。能持不善法。能使来能生能养能增故。复次以此三不善根。离欲界欲时。多作留难作障碍。如守门者不令人入。复次以此三不善根。五种断。通六识身。是使性。能起身口业。断善根时。有牢强方便。五种断者。见苦断种。乃至修道断种。通六识身者。与眼识相应。乃至意识相应。使性者。贪是欲爱使。恚是嗔恚使。痴是无明使。能起身口业者。贪起从贪生身口业。恚起从恚生身口业。痴起从痴生身口业。断善根时牢强方便者。如施设经说。断善根时。云何而断。以何事断。答言。犹如有一贪欲偏重嗔恚偏重愚痴偏重者。能断善根。所以说五种断者。欲除五见及疑。所以说通六识身者。欲除慢。所以说使性者。欲除诸缠。问曰。如邪见能断善根。何故不立不善根。答曰。不善根断善根时。作方便时势胜。事成时亦胜。一切善不善法。方便时势用难。事成时势用易。曾闻。菩萨见世间生老病死苦。初发不退转无上道心。从此以后。于三阿僧祇劫。此心不住不退。无能留难障碍之者。此心甚难。非得尽智时三界善根于未来修者。邪见成时势用胜。非方便时胜。是故不立不善根。复次若法断善根时。能生不善法。助生不善法者。立不善根。贪恚痴。能生不善法。助生不善法邪见虽助生不善法。不能生不善法。复有邪见能断善根者。以诸不善根力故。诸不善根先令善根羸劣微薄。令其困无有势力。然后邪见能断善根。复次先作是说。五种断者。立不善根。邪见非五种断。不通六识身。彼在意地。虽是使性。不能起身口业。所以者何。见道所断心。不与身口业俱起。诸不善根所不摄。不善五阴。无此五事。不善色阴。非五种断。不通六识身。非是使性。不能起身口业。断善根时。无牢强方便。不善受阴想阴识阴。烦恼所不摄相应行阴。此虽五行所断通六识身。非是使性。虽能起身口业。断善根时。无牢强方便。不相应行阴。虽五种断。不通六识身。非是使性。不能起身口业。断善根时。无牢强方便。烦恼中五见及疑。非五种断。不通六识身。虽是使性。不能起身口业。所以者何。见道所断心。不与身口业俱起断善根时。无牢强方便。慢虽五种断。不通六识身。虽是使性。能起身口业。断善根时。无牢强方便。缠有十种。忿缠覆缠睡缠掉缠眠缠悔缠愱缠悭缠无惭缠无愧缠。睡掉无惭无愧。此四虽五种断。非是使性。虽能起身口业。断善根时。无牢强方便。眠虽五种断。不通六识身。非是使性。不能起身口业。断善根时。无牢强方便。余缠非五种断。不通六识身。非是使性。或时起身口业。断善根时。无牢强方便。恨佷谄诳憍害。此六是使垢。依使而生。非根本使。无上五事故。不立不善根。复次此三不善根。说是业本是业集。如说。迦蓝摩当知。贪是众生业本是众生业集。恚痴亦是众生业本。是众生业集。复次此三不善根尽。业亦尽。如说贪尽业亦尽。恚痴尽业亦尽。复次此三不善根。展转相生。展转相助生。如说从贪生恚。从恚生贪。于此二中。亦生无明。复次此三不善根。能使三受。如说贪使乐受。恚使苦受。痴使不苦不乐受。问曰。如此三使尽使三受。何故作是说耶。答曰。从多分故。贪多使乐受。恚多使苦受。痴多使不苦不乐受。复次贪从乐受生。以乐受为根本。多造恶业故。而生多苦。恚从苦受生。以苦受为根本。多造恶业故。而生多苦。痴从不苦不乐受生。以不苦不乐受为根本。多造恶业故。而生多苦。复次此三善根。说是爱憎。以爱憎故众生多起诤讼。天阿修罗常共斗。杀多众生。爱者是贪。憎者是恚。问曰。此中何以不说痴耶。答曰。已说在此二中。若当众生有智者。乃至天欲境界在前。犹不共诤。何况人间恶欲。复次以此现初门要略始入。诸烦恼。尽从三分生。或从爱分生。或从恚分生。或从痴分生。佛经说。婆罗门当知。若人以二十一烦恼。恼于心者。虽修行净心生净想。犹堕恶趣。曾闻尊者昙摩哆罗。一切烦恼。立为三分。谓贪恚痴分。此是贪分此是恚分。此是痴分。若说贪当知已说贪分。若说恚当知已说恚分。若说痴当知已说痴分。如爱恚痴分。亲分怨分。不亲分不怨分。有恩分无恩分。有适意分无适意分。不有适意不无适意。当知亦如是。复次以三不善根起十恶业故。堕十恶处。云何三不善根起十恶业。答曰。佛经说杀生有三种。或从贪生。或从恚生。或从痴生。乃至邪见。亦复如是。施设经亦说。三不善根十恶业因根。广说如上。云何十恶业生十恶处。佛经说。修行广布杀生之业。生地狱畜生饿鬼中。乃至邪见亦如是。施设经亦如是说。修行广布增上杀生之业生阿毗地狱。小轻者生大热地狱。转轻者生热地狱。转轻者生大叫唤地狱。转轻者生叫唤地狱。转轻者生众合地狱。转轻者生黑绳地狱。转轻者生活地狱。转轻者生畜生。转轻者生饿鬼。乃至邪见。说亦如是。是名行十恶业生十恶处。复次此三不善根。说是内垢。如说贪为内垢。恚为内垢。痴为内垢。如内垢。内怨内嫌当知亦如是。复次此三不善根。亦名为增。亦名为减。如说云何贪增。云何恚增。云何痴增。云何贪减。云何恚减。云何痴减。复次此三不善根。能为退者。作重因重缘。如说若比丘比丘尼。自知欲心炽盛恚心炽盛痴心炽盛。不能自制。比丘比丘尼当知。我于善法。便为衰退。复次此三不善根。说是烦恼障。如说。云何烦恼障。答曰。犹如有一贪偏重恚偏重痴偏重。是名烦恼障。复次此三不善根。说名为尘。如说是贪尘恚尘痴尘。如尘秽垢。箭火刺刀毒病。当知亦如是。问曰。此三不善根。云何行耶。答曰。若心有贪。是心无恚。若心有恚。是心无贪。痴则俱有。所以者何。所行各异故。贪行欣踊。恚行忧戚。复次欲心盛时。令身柔软润益。恚心盛时。令身粗强损减。复次欲令身柔软不害前缘。恚令身粗强能害前缘。云何欲令身柔软。答曰。欲心现在前时。自身柔软。云何不害前缘。答曰。若于前人生爱心者。昼夜观之。无有厌足。云何恚心令身粗强。答曰。恚心现在前时。令自身粗强。云何能害前缘。答曰。若于前人生恚心者。乃至不欲以眼视之

此三不善根。是五种断。通六识身。何故五种断。若当见道断非修道断者。修道所断心。便为无根。若当修道所断非见道断者。见道所断心。便为无根。何故通六识身。若在意地不在五识身者。此五识心。便为无根。若在五识身不在意地者。此意地心。便为无根。一切不善心。以此为根。与不善欲俱心。有二种根。谓贪及相应无明。恚俱亦如是。痴俱心。及余烦恼俱心。有一根。有一根谓无明也

问曰。根有多名。或说身见是根。或说世尊是根。或说欲是根。或说不放逸是根。或说自体是根。此诸根名。有何差别。答曰。身见是根者。以是见计我我所。便生诸见。世尊是根者。以所说故。虽此烦恼出要缚解增长寂灭。如是等法。皆从佛出。是故为根。欲是根者。以能集善法故。所以者何。若有欲心。能集善法。若无欲心。不能集善法。是故以欲为根。不放逸是根者。以能守护善法。若放逸者。不能守护善法。若不放逸。则能守护善法。是故不放逸为根。自体是根者。以自体不舍自性。是故自体为根。问曰。若然者。无为法亦是自体根。所以者何。不舍自性故。答曰。若以此义。不舍自性为根者。无为法亦不舍自体为根。复有何过。复有欲去如是过而作是说。自体是根者。以相似因是自体根。能生他故。问曰。若然者。苦法忍及眷属。便为无根。所以者何。无相似因故。答曰。虽不从相似因生。而能与他作相似因。无为法亦不从相似因生。亦不能与他作相似因。评曰。应作是说。以不舍自性故。名自性根。身见根。乃至自体根。是名差别

阿毗昙毗婆沙论卷第二十五阿毗昙毗婆沙论卷第二十六

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    使揵度不善品第一之二

三漏。欲漏有漏无明漏。问曰。此三漏体性是何。答曰。有百八种。欲漏有四十一种。欲爱有五种。恚有五种。慢有五种。见有十二种。疑有四种。缠有十种。此四十一种。是欲漏体。有漏有五十二种。爱有十种。慢有十种。疑有八种。见有二十四种。此五十二种。是有漏体。无明漏有十五种。欲界无明有五。色界无明有五。无色界无明有五此十五种。是无明漏体。此百八种。是三漏体。亦名百八烦恼。波伽罗那经亦说。云何欲漏。答言。除欲界系无明。诸余欲界系结缚使垢缠。是名欲漏。云何有漏。除色无色界系无明。诸余色无色界系结缚使垢缠。是名有漏。云何无明漏。答言。三界无知。是名无明漏。无明漏。是三界无知。如是说者好。若作是说。云何无明漏。答言。缘三界无知。作是说者。则不摄无漏缘使。所以者何。无漏缘使。不缘在三界法。问曰。身口恶行。为是烦恼。为非烦恼。若是烦恼。此中何故不说。若非烦恼。识身经说云何通。如说身口恶行。是不善法结非使非缚是烦恼非缠。应舍应断应知。能生苦报故。或有作是答者。是烦恼体。若然者。识身。经说善通。此中何以不说。答曰。应说身口恶行在欲漏中。欲漏有四十三种。而不说者。有何意耶。答曰。若法体是烦恼体亦是缠。说在欲漏中。身口恶行。虽是烦恼。而体非缠。是故不说在欲漏中。复有说者。身口恶行。体非烦恼。是以不说在欲漏中。问曰。若然者。识身经说云何通。答曰。识身经文。应如是说。身口恶行。是不善非结非缚非使非烦恼非缠。应舍应断应知。生苦报故。而不说者。有何意耶。答曰。身口恶行。虽非烦恼。为烦恼所恼故。说是烦恼。问曰。若非烦恼。为烦恼所恼。说是烦恼者。非结为结所系。何故不说是结。非缚为缚所缚。何故不说是缚。非使为使所使。何故不说是使。非缠为缠所缠。何故不说是缠耶。答曰。应说而不说者。当知此说有余。复次欲现种种说种种文。若以种种说种种文庄严于义。义则易解。复次为现二种门二种略二种始入二种炬二种相貌二种文影二种俱通故。如非烦恼为烦恼所恼。说是烦恼。非结为结所系。说是结。乃至非缠为缠所缠。说是缠。如非结为结所系。不说是结。乃至非缠为缠所缠。不说是缠。如是非烦恼为烦恼所恼。应说非烦恼。是故现二种门。乃至现二种俱通。此是漏体。乃至广说

已说体性。所以今当说。何故名漏。漏是何义。答曰。留住义是漏义。浸渍义是漏义。流出义是漏义。持义是漏义。在内义是漏义。醉义是漏义。放逸义是漏义。留住义是漏义者。谁令众生留住欲色无色界耶。答曰。漏也。浸渍义是漏义者。如于糟中浸渍种子其牙便生。如是众生以业种子。浸渍烦恼糟中。便生未来有牙。流出义是漏义者。如泉出水乳房出乳。如是众生于六入门。流出诸漏。持义是漏义者。如人为他人所持。则不能随意游行四方。如是众生为烦恼所持。于诸界诸趣诸生生死法中。不能自出。在内义是漏义者。如人鬼在身内故。不应说而说。不应作而作。不应取而取。不应触而触。众生亦尔。烦恼鬼在内。不应说而说。不应作而作。不应触而触。醉义是漏义者。如人饮根茎枝叶花果等酒则便醉乱无所觉知。众生亦尔。饮烦恼酒。便无所知。放逸义亦如是。是故留住义是漏义。乃至放逸义是漏义。声论者说曰。漏名阿罗婆。阿亦言分齐。罗婆亦言漏。如说。天雨分齐。至婆吒梨城。布施分齐。至旃陀罗。如是有漏分齐。至于有顶。问曰。若留住义是漏义者。业亦令众生留住生死。如说二因二缘而有生死。亦令增长。谓业烦恼。业与烦恼为生死种子。是以生死难断难坏。而不灭没。若人或八岁。或十岁。得阿罗汉。从是已后。百年寿中。烦恼永断。以业力故。留住生死。何故唯说烦恼是漏。不说业耶。答曰。以烦恼是业根。不可不断烦恼而舍于业。是故说烦恼为漏。不说于业。复次烦恼能造业。犹能生报。如以湿泥团打于壁上。以湿故着。干犹不堕。是湿时力。如是众生有烦恼故造业。烦恼虽断。业犹生报。复次业是坏法业。或令众生留住生死业。或为生死。而作对治烦恼。非是坏法。但为众生。作留住法。复次烦恼尽故。能得涅槃。不必业尽。阿罗汉业。其犹如山。然更不受有。于无余涅槃界。而般涅槃。以是等诸因缘故。说烦恼是漏。不说于业

问曰。何故欲界诸烦恼。除无明立欲漏。色无色界诸烦恼。除无明立有漏。无明立无明漏耶。答曰。先作是说。留住义是漏义。欲界众生。所以留住欲界者。以期心于欲。喜乐于欲。染着于欲。专求于欲。以是事故。欲界诸烦恼。除无明立欲漏。色无色界众生。所以留住色无色界者。以期心于有。乃至专求于有。以是事故。色无色界诸烦恼。除无明立有漏。欲界众生。所以留住。以无明故。色无色界众生。所以留住。以无明故。是故三界无明。立无明漏。复次欲界虽有。然众生多求于欲。以多求欲故。欲界诸烦恼。除无明立欲漏。色无色界无有欲。然彼众生。多求于有。以多求有故。色无色界诸烦恼。除无明立有漏。诸求欲求有。皆因无明。以是事故。三界无明。立无明漏。复次若界有成有坏。是界烦恼。除无明立欲漏。若界有成无坏。是界烦恼除无明立有漏。三禅以下。虽有成有坏。第四禅及无色界。有成无坏。若界有成有坏。众生留住。亦因无明。若界有成无坏。众生留住。亦因无明。是故三界无明。立无明漏。复有别说。有漏者何故名有漏。答曰。以众生于此处求彼有。不于彼处求此有。譬喻者说二漏。谓无明漏。有爱漏。所以者何。以此二结是根本使故。无明是过去缘起因故。有爱是未来缘起因。问曰。若然者。云何具三漏耶。答曰。彼作是说。爱有二种。或不善或无记。或有报或无报。或生一果或生二果。或无惭无愧相应。或不相应。诸不善有报生二果。无惭无愧相应。爱立欲漏。以爱故。诸余烦恼。除无明使。亦名欲漏。诸无记无报生一果。不与无惭无愧相应。爱立有漏。以爱故。诸余色无色界烦恼。除无明使。亦名有漏。问曰。何故以爱故。欲界诸烦恼。除无明使。立欲漏。色无色界。以爱故。色无色界诸烦恼。除无明使。立有漏。答曰。以爱故。界有差别。地有差别。种有差别。生诸烦恼。广解如爱处说。问曰。何故三界无明。立无明漏。尊者波奢说曰。佛决定知法相。亦知势用。余人所不知。若法堪任独立漏者。使独立漏。若法不堪任独立漏者。彼合集为漏。复次留住义是漏义。更无有结留住众生如无明者。尊者瞿沙说曰。佛知速疾偏重亲近。留住众生莫若无明。是故独立无明漏。复次以因无明。有贪有恚有痴。复次无明能令众生。于前际愚。后际愚。前后际愚。于内法愚外法愚内外法愚不知业不知报。不知业报。不知作善行。不知作恶行。不知作善恶行。不知因。不知从因生法。不识佛。不知法。不识僧。不知苦集灭道。不知有过。不知无过。不知亲近处。不知不亲近处。不知好恶白法黑法。不知总别。不知因缘生法。不如实知见六触处法。复次以无明难离是大过患。爱虽难离。而非大过患。恚虽大过患。而非难离。无明是大过患。亦难可离。复次无明说在前法。如说。无明在前为相故。生诸恶不善法。无有惭愧。复次无明自体是重所作。亦重自体。重者与一切使俱。亦有不共者。所作重者。与一切使俱作业。亦有不共作业者。复次无明说是根本。如偈说

  今世若后世　　所以堕恶趣
  无明为根本　　亦因于贪欲

复次无明说名槾只。有蛇名槾只。自身盲生子亦盲。所螫之处。亦令他盲。无明亦尔。自盲亦令相应法盲。于众生身中。亦能令盲。复次无明在三界。缘一界生愚。谓无色界。在九地。缘一地生愚。谓非想非非想处。四阴有九种。缘一种生愚。谓下下种。问曰。如所说余他界一切遍使所作亦尔。如邪见在三界。缘一界谤无色界。谓无色界四阴。见取在三界缘一界计最胜。谓无色界四阴。戒取在三界。缘一界计能净。谓无色界四阴。疑在三界。缘一界生犹豫。谓无色界四阴。地种说亦如是。无明有何异事耶。答曰。虽同是事。而无明更有异义。所以者何。欲界他界缘一切遍。无明使有九种。七与他界缘遍使相应。二是不共。一一无明。复有九种。上上乃至下下。如欲界无明。色无色界无明亦如是。如欲界地。乃至非想非非想处地亦如是。以无明有如是无量门无量处所。令众生愚。是故三界无明。独立无明漏。复次无明在前。普遍通一切处。在前者为。无明所覆。于苦不忍不可。不欲闻说。于集灭道亦尔。犹如饥饿之人食恶食饱。彼虽得美食。而不忍可。如无明恶食。先在众生身中。彼虽遇四谛美妙之食。而不忍可。以不忍可故。于谛便生疑心。为有是苦。为无是苦。乃至为有是道。为无是道。如是因无明生于疑心。必当决定。若遇正说。得正决定。言有苦集灭道。若遇邪说。得邪决定。言无苦集灭道。如是疑心生于邪见。彼作是念。若无苦集灭道。应当有我。如是邪见生于身见。复作是念。此我为断为常。若见我相似相续。便谓是常。是名常见。若我破坏不相续。便谓为断。是名断见。是二见名为边见。如是身见生于边见。于此三见。一一计能净。此见能净。能得解脱。能出要。是名戒取。如是边见生于戒取。彼作是念。此见能净能解脱能出要者。此见便为第一。是名见取。如是戒取生于见取。自可所见生爱。不可他见生恚。于诸见起高是慢。是名无明生使使生缠。缠者十缠。谓忿乃至无愧。忿缠。愱缠依于恚。覆缠或有说依于爱者。所以者何。以爱故覆藏其罪。或有说依无明。所以者何。以无知覆藏其罪。睡缠眠缠无惭缠依无明。掉缠悭缠无愧缠依爱。悔缠依疑。六使垢亦依于使。恨使垢害使垢依恚。佷使垢依见取。诳使垢高使垢依爱。谄使垢依五见。无明生如是等诸烦恼。是故说在前。普遍见从阿毗地狱。上至有顶。于中尽有。通一切处者。不以一刹那顷能为一切五行作因缘。一切五行所断使。一切五行所断。以通一切处故。一切遍中。他地一切遍中。缘有漏中。缘无漏中。缘有为中。缘无为中。如是等处皆有。与一切烦恼共俱共合。如油在麻中腻在抟中。以无明在前。普遍通一切处。是故三界无明。立无明漏

佛经说。以不正思惟。未生欲漏令生。已生欲漏令增广。有漏无明漏亦如是。问曰。有尔所烦恼生即尔所烦恼灭。所以者何。前后不俱生故。云何欲漏生而得增广。答曰。以下中上故。说名增广。下烦恼为中作缘。中为上作缘。以下中上作缘。故名增广。复次与次第缘故。名为增广。若前烦恼未生。则不与后烦恼作次第缘。若生者作缘。复次若前烦恼未生。则不与后烦恼作相似因一切遍因。若生者。作相似因一切遍因。复次若烦恼未生。则不能与果取果。若生则能取果与果。尊者和须蜜说曰。佛经说不正思惟故。便生欲漏。已生欲漏。能令增广。有漏无明漏亦如是。问曰。此烦恼为多不耶。答言。不多。烦恼未生而生。已生复生。故名增广。复次烦恼不多。说名增广。未来有烦恼生已生。不更名未来。故名增广。复次烦恼不多。说名增广。以数数生故。若一烦恼生。不正思惟。不依对治。则二生三生。乃至百生千生。复次烦恼不多。说名增广。但以数数生转重故。生下烦恼。不正思惟。不依对治。便生于中。中便生上。复次烦恼不多。说名增广。但转行境界故。如缘色生烦恼。不正思惟。不依对治。复缘声香味触法生。尊者佛陀提婆说曰。于一生中。多行烦恼。说名增广。具缚之人。烦恼无有增减。一切众生。烦恼悉等。等生阿毗地狱。上至有顶。但诸烦恼。有多行者。有少行者。谁多行耶。诸不正思惟不依对治者。谁少行耶。诸正思惟依对治者。佛经说此七漏。常为损害。能生热恼及诸忧苦。或有漏是见道断。乃至广说。问曰。实义有三漏。谓欲漏有漏无明漏。何故说七漏耶。答曰。世尊以漏具说漏。如处处经中说。彼具是漏。彼广说如上。此亦如是。漏具说漏。尊者波奢说曰。佛说三漏竟。更有异众生来在会中。佛怜愍故。即以此义。更以异句异文。令彼来众堪任受化。故说七漏。复次利根者已解。为钝根者。作如是说。如利根钝根。因力缘力。内力外力。依内正思惟力。依外闻法力。当知亦如是。尊者富那耶奢说曰。佛经实义说二漏。谓见道所断漏。修道所断漏。见道所断即漏自名说。修道所断漏。以对治名说。彼对治有二种。一须臾断。二根本断。初五种说是须臾断对治。后一种说是根本断对治

佛经说若有如是见。于欲漏心解脱。于有漏无明漏心解脱。问曰。如离欲爱时。欲漏心得解脱。离非想非非想处爱时。有漏无明漏心得解脱。佛何故于一时中。说于三漏心得解脱。答曰。已解脱说今解脱。如说。大王从何处来。已来说来。广说如上。复次此二法。是俱一时灭故。更不复现。而作是说。俱者谓欲漏无明漏。有漏无明漏。离欲爱时。虽断其俱而未永灭。离非想非非想处爱时。其俱永灭。复次通证故。作如是说。离欲界欲时。证欲漏断。离非想非非想欲时。通证三漏断。复次同证一味解脱得故。离欲时。证欲漏一味解脱得。离非想非非想爱时。证三漏一味解脱得。复次以灭作证故。而作是说。如说。得阿罗汉果时。证九十八使灭。复次阿罗汉得法智故。而作是说。学人得法智。是欲界对治离非想非非想处欲时。无学得法智。是欲界对治。复次无学人。得无学离缚故。而作是说。离欲界欲时。学人得离缚。离非想非非想处欲时。无学人得离缚。复次断不相续。还相续故。而作是说。众生无有前际。数数断欲漏。还与有漏无明漏相续。若离非想非非想处欲时。相续法。更不相续。复次缘不具故。作如是说。众生不说前际有漏无明漏与欲漏作三缘。谓次第境界威势缘。若离非想非非想处欲时。则缘不具。复次为过患对治故。而作是说。行者离非想非非想处欲时。于欲漏生过患想。言其秽恶。而捐弃之。此漏无始已来。常隐没我常欺诳我。今已脱欲漏有漏无明漏。是故为过患对治。而作是说。问曰。如何阿罗汉五阴得解脱。世尊何以但说心得解脱。答曰。世尊以心为首。说心得解脱。五阴亦得解脱。复次以心名胜义亦胜故。彼聚中何者最胜。心是最胜。犹如王与眷属俱走人但言王走。彼亦如是。复次以心故数法名心数。以心大故。数法名大地。复次证他心智通时。无碍道中唯缘于心。不缘心数。广说如心处说

四流。欲流有流见流无明流。问曰。四流体性是何答曰。有百八种。欲流有二十九种。爱有五种。恚有五种。慢有五种。疑有四种。缠有十种。有流有二十八种。爱有十种。慢有十种。疑有八种。见流有三十六种。欲界有十二种。色界有十二种。无色界有十二种。无明流有十五种。欲界有五种。色界有五种。无色界有五种。此百八种。是四流体。乃至广说。亦名百八烦恼。已说体性。所以今当说。何故名流。有何义。答曰。漂义是流义。流下义是流义。堕义是流义。漂义是流义者。漂诸众生。堕在诸界。诸趣诸生生死中。流下义是流义者。流下诸众生诸界诸趣诸生生死中。堕义是流义者。堕诸众生诸界诸趣诸生生死中。问曰。若漂义流下义堕义是流义者。上分结则无上分义。所以者何。上分结。令诸众生。趣上向上使上生相续。答曰。上分义异。流义异。以界故立上分结。所以者何。此结令诸众生趣上向上使上生相续。以解脱正行圣道善法分故说流。所以者何。众生虽生有顶中。犹为流所漂。不至解脱正行圣道善法分故。是故尊者瞿沙作如是说。虽久生上地。犹为流所漂。为扼所扼。尊者婆摩勒说曰。以数数现行增上烦恼。故名流

问曰。何故诸见流中立见流。扼中立见扼。取中立见取。漏中何故不立见漏。尊者波奢说曰。佛决定知法相。亦知势用。余人所不知。若法堪能别立者。便别立之。若法合集堪能立者。便合集立之。复次诸见轻躁所行猛利。不住一处。留住义是漏义。与诸愚钝久住烦恼合故立漏。诸见随顺漂义。立在流中。漂诸众生。堕在诸界诸趣诸生生死中。是故别立见流。犹如一车驾以二牛性俱躁疾其车必破。若一迟一疾。则相持御其车不破。彼亦如是。复次此诸见。其性躁动。随顺离欲法。不随顺留住法。留住义是漏义。与诸愚钝久住烦恼合故立漏。随顺漂义故立流。问曰。若诸见性躁动。随顺离欲法。何故立见流耶。答曰。为外道故。诸外道。伺求诸见。于生死中。而转覆没。譬如老象堕泥。若欲动身求出。转复覆没。彼亦如是。毗婆阇婆提。立诸见为见漏说有四漏。谓欲漏有漏见漏无明漏。如我等欲流。彼为欲漏。乃至我等无明漏。是彼无明漏。彼虽作是说。亦不须问。亦不须答

四扼。欲扼有扼见扼无明扼。如说。流扼亦如是。体无有异。而义有异。漂义是流义。系义是扼义。众生为流所漂。为扼所系。负生死车。如牛以靷系扼鞅。以杖捶之。然后挽车。彼亦如是。是故诸经论中说流。后次说扼

四取。欲取见取戒取我语取。问曰。四取体性是何。答曰。有百八种。欲取有三十四种。爱有五种。恚有五种。慢有五种。无明有五种。疑有四种。缠有十种。见取有三十种。欲界有十种。色界有十种。无色界有十种。戒取有六种。欲界有二种。色界有二种。无色界有二种。我语取有三十八种。爱有十种。慢有十种。无明有十种。疑有八种。此百八种。是四取体。乃至广说。亦名百八烦恼

已说体性。所以今当说。何故名取。答曰。以三事故名取。一以属故。二以搊持故。三以选择故。复次以二事故名取。一能炽然业。二体性猛利。炽然业者。令五趣众生诸业常然。体性猛利者。以黠慧故。取是何义。薪义是取义。缠裹义是取义。刺害义是取义。薪义是取义者。如缘薪故火炽。众生亦尔。因烦恼故业火燃。缠裹义是取义者。如虫以茧自裹即于中死。如是众生以烦恼自裹。恶趣中死。刺害义是取义者。如利刺入身而为恼害。取荆刺于法身。亦复如是。故薪义缠裹义刺义。是取义。问曰。何故漏中立无明漏。流中立无明流。扼中立无明扼。取中何故不立无明取。尊者波奢说曰。世尊决定知法相。亦知势用。余人所不知。若法堪任独立者。便独立之。若法合集堪任立者。便合集立之。复次先作是说。以三事故。一以属故。二以搊持故。三以选择故。无明虽有属义搊持义无选择义。所以者何。猛利者能选择。无明不猛利。复次先作是说。以二事故名取。一炽然业。二所行猛利。无明虽能炽然业。所行不猛利。以愚小不猛利不决定故

问曰。何故五见中。四见立见取。一见立戒取。尊者波奢说曰。世尊决定知法相。亦知势用。余人所不知。若法堪任独立取者。便独立之。若法合集堪任立者。便合集立之。复次先作是说。以二事故名取。一能炽然业。二所行猛利。戒取一见炽然五趣众生业。与余四见等。尊者瞿沙说曰。佛知戒取一见速疾偏重亲近炽然众生业。非余四见。是故独立戒取

复次以戒取与道竞故。远于解脱。与道竞者。舍八正妙道。行种种苦行。以为净想。如不食卧灰。向日曝身。服气饮水。食果裸行卧柴棘上。着弊衣等。远解脱者。以修邪道故。转远解脱。复次以戒取能欺诳二种人故。谓内道外道。云何欺诳内道。如洗手足行十二头陀以为净想。云何欺诳外道。如自饿卧灰种种苦行以为净想。是以尊者瞿沙作如是说。如是等净行。皆是世间所行现见之法。欺诳内道外道。如欺小儿

问曰。何故说我语取。为以所行故。为以境界故。若以所行为我语取者。身见亦应是我语取。所以者何。行我行故。若以境界者。境界中无我。或有作是答者。不以所行故。亦不以境故。若以所行是我语取者。身见应是我语取。所以者何。行我行故。亦不以境界。境界中无有我故。但欲界诸烦恼。除见余立欲取。色无色界诸烦恼。除见立。我语取。问曰。何故欲界诸烦恼。除见立欲取。色无色界诸烦恼。除见立我语取。答曰。欲界诸烦恼。因欲造自身时。须俱。须境界。须具。色界诸烦恼。造自身时。不因欲。不须俱。不须境界。不须具。复次欲界诸烦恼。因欲故生。因境界故生。因具故生。因他故生乐。色无色界诸烦恼。不因欲。不因境界。不因具。不因他生乐。但因我生。复次欲界诸烦恼。不因定。能造自身。亦因内物。亦因外物。色无色界诸烦恼。因定造自身。因内物。不因外物。复次欲界诸烦恼。不能造广大自身。亦不久远相续。色无色界诸烦恼。能造广大身。久远相续。如阿迦贰吒天。身长万六千由旬。是故欲界诸烦恼。除见立欲取。色无色界诸烦恼。除见立我语取

佛经说此四取皆以无明为本。因无明生。因无明集。问曰。如诸经说。皆爱缘取。此中何故说无明为本。乃至广说。答曰。以近因故。说爱缘取。以远因故。说无明为本因集。如近远。在此在彼。俱不俱。此身他身。说亦如是。复次以相似因故。说爱缘取。以相似因一切遍因故。说无明为本因集。复次为诸外道故。作如是说。诸外道无有居家。亦不积聚。不以贪着境界。作诸恶行故。堕于恶趣。以无明故。漂着诸见。堕于恶道。问曰。如爱摄在趣中。何以说爱缘取耶。答曰。始生爱名。爱增广名取。故名爱缘取。复次下者名爱。上者名取

四缚。贪身缚。恚身缚。戒取身缚。见取身缚。问曰。四缚体性是何。答曰。有二十八种。贪身缚是欲爱有五种。通六识身。恚身缚有五种。通六识身。戒取身缚。三界有六种。见取身缚。三界有十二种。此二十八种。是四缚体。乃至广说

已说体性所以今当说。何故名缚缚有何义。答曰。系义是缚义。相续义是缚义。系义是缚义者。此四缚等系众生。系已复系。集法经亦说。若不断贪。不知贪皆是一切处爱身因缘。等系众生系已复系。譬如善巧系花鬘师花鬘弟子。以种种花。集于前然后经缕。作种种鬘缕。是花因。亦是花缘。等系诸花。系已复系。彼亦如是。恚身缚。戒取身缚。见取身缚。说亦如是。相续义是缚义者。如经说。以三事合故入母胎。一父母俱有染心。二其母无病亦复值时。三爱身者现在前。或有欲心。或有恚心。以是事故。相续义是缚义。问曰。若系义是缚义者。缚所不摄余烦恼。亦系众生。于生死中等缚。缚已复缚。四缚有何异义。世尊别立缚耶。答曰。此是世尊有余之说。乃至广说。尊者波奢说曰。世尊决定知法相。亦知势用。余人所不知。若法有缚相者立缚。无者不立。尊者瞿沙说曰。佛知四缚等系众生系已复系速疾偏重亲近非余烦恼。是故立缚。复次此缚于诸烦恼。偏系在家出家。贪身缚。恚身缠。偏系在家人。戒取身缚。见取身缚。偏系出家人。如在家出家。有家无家。有积聚无积聚。当知亦如是复次四缚。偏重系缚三界众生。贪身缚恚身缚。偏重系缚欲界众生。戒取身缚见取身缚。偏重系缚色无色界众生。复次此四缚是二种使斗诤根本。贪身缚恚身缚。能起爱恚使斗诤根本。戒取身缚见取身缚。能起见使斗诤根本。如经说。执杖持澡[泳-永+盥]婆罗门。往诣尊者迦旃延所。作如是问。何因何缘。刹利还共刹利斗诤。婆罗门还共婆罗门斗。毗舍还共毗舍斗。首陀还共首陀斗。彼尊者答言。婆罗门。彼因贪着欲爱故。刹利还共刹利斗。乃至首陀首陀共斗。又问。出家之人。无有居家。无所积聚。以何因缘。而共斗耶。迦旃延答言。以各于所见而起爱着。如二斗诤根本。二边二箭二戏论二道。当知亦如是。复次此现门现略现始入。诸烦恼。或见道断。或见道修道断。若说戒取身缚见取身缚。当知已说见道所断诸烦恼。若说贪身缚恚身缚。当知已说见道修道所断诸烦恼。复次诸烦恼。或是一切遍。或非一切遍。若说后二身缚。当知已说一切遍烦恼。若说前二身缚。当知已说非一切遍诸烦恼。复次诸烦恼。或是见性。或非见性。若说后二身缚。当知已说见性诸烦恼。若说前二身缚。当知已说非见性诸烦恼。复次诸烦恼。或凡夫人所行。或凡夫圣人所行。若说后二身缚。当知已说凡夫所行诸烦恼。若说前二身缚。当知已说凡夫圣人所行诸烦恼。复次诸烦恼。或性欣踊。或性忧戚。若说恚身缚。当知已说忧戚诸烦恼。若说余身缚。当知已说欣踊性诸烦恼。是故说为现门现略现初入

五盖。欲爱盖。恚盖。睡眠盖。掉悔盖。疑盖。问曰。盖性是何。答曰。有三十种。欲爱盖有五种。通六识身。恚盖有五种。通六识身。睡掉俱在三界五种断。通六识身。是不善无记。不善者立盖。无记者不立。有十种。眠在欲界。五行所断。是意地。是善不善无记。不善者立盖。无记不立。有五种。悔是欲界。修道所断。在意地。是善不善。不善者立盖。善者不立。有一种。疑在三界。四种所断。在意地。是不善无记。不善者立盖。无记不立。有四种。此三十种。是五盖体。盖有何相。尊者和须蜜说曰。体即是相。相即是体。诸法不可离体别说于相。复次专求欲。是欲爱相。于众生生恚害是恚相。令身心覆没是睡相。不动是眠相。不休息是掉相。克心悔是悔相。心于所行不决定是疑相

已说盖体相。所以今当说。何故名盖。盖是何义。答曰。障义是盖义。破义是盖义。坏义是盖义。堕义是盖义。卧义是盖义。障义是盖义者。障于圣道及圣道方便善根。如经说。比丘当知此五种树。名为大树。种子虽小。而枝体大。覆余小树。令余小树破坏堕卧。云何为五。一名千阇那。二名迦毗多罗。三名阿湿婆多。四名优昙跋罗。五名尼拘陀。诸小树为此诸大树所覆。不能生于花果。如是众生欲界心树。为盖所覆。不能生觉意花及沙门果。是故障义是盖义。破义坏义堕义卧义是盖义。问曰。若障圣道及圣道方便善根是盖义者。盖所不摄余烦恼。亦障圣道及圣道方便善根。亦应是盖。此诸烦恼。有何异义。世尊独立盖耶。答曰。或有说者。此是世尊有余之说。乃至为受化者故。尊者波奢说曰。佛决定知法相。亦知势用。余人所不知。乃至广说。尊者瞿沙说曰。佛知此五盖。乃至障众生圣道及圣道方便善根非余烦恼。复次此盖亦障因时。亦障果时。因时障者。五盖一一盖现在前时。则不得生有漏善心及不隐没无记心。何况圣道及圣道方便善根。果时障者。以五盖果故。生恶趣中。则障一切诸善功德。复次此五盖欲界众生数行。数行时微细。欲界所有众生。行慢者甚少。如生地狱中。能起是慢。我受苦胜他耶。畜生中。如虾蟆等以愚痴。故不能起诸见。是故尊者瞿沙作如是说。一切烦恼。尽障圣道。与圣道相违。但五盖数行。数行时微细。世尊立盖。复次此盖为定及为定果。而作留难。复次此盖障三界离欲法。障九断知无漏果。障四沙门果。复次欲爱盖。远离欲爱寂灭法。恚盖远离恚寂灭法。睡眠盖远离慧法。掉悔盖远离定法。远离欲爱恚寂灭定慧故。令疑箭在心中生。为有善恶业报。为无耶。复次爱恚坏于戒身。睡眠坏于慧身。掉悔坏于定身。坏三种身故。疑心犹豫。为有善恶业报不耶。如坏三戒。害三戒亦如是。如三戒三修三净亦如是。复次此现门现略现始入。此诸烦恼。或一种断。或四种断。或五种断。若说悔。当知已说一种断者。若说疑。当知已说四种断者。若说余者。当知已说五种断者。复次此诸烦恼。或见道断。或修道断。或见道修道断。若说疑。当知已说见道断者。若说悔。当知已说修道断者。若说余。当知已说见道修道断者。问曰。盖名有五。体有几耶。答曰。名有五体有七。欲爱盖。名有一体有一。恚盖疑盖亦如是。睡眠盖。名有一体有二。掉悔亦尔。是为五盖名有五体有七。如名体数体。名异体异。名异相体异相。分别名分别体。知名知体。当知亦如是。问曰。何故欲爱盖恚盖疑盖。一体立盖。睡眠掉悔。二体立盖。尊者波奢说曰。佛决定知法相。亦知势用。余人所不知。乃至广说。复次若是使性亦是缠性者。一体立盖。若是缠性非是使性。二体立盖。复次有满足烦恼。不满足烦恼。满足烦恼者。谓结缚使垢缠。与此相违。名不满足。诸满足者。一体立盖。不满足者。二体立盖。复次以三事故立盖。一食一对治一等重担。欲盖。以何为食。答曰。食于净想。以何为对治。答曰。不净以一食一对治故。一体立盖。恚盖以何为食。答曰。以害相为食。以何为对治。答曰。以慈以一食一对治故。一体立盖。疑以何为食。答曰。以于世相犹豫为食。以何为对治。答曰。以观缘起法。以一食一对治故。一体立盖。睡眠以何为食。答曰。以五法为食。一瞪瞢。二愁愦。三欠呿。四食不消化。五心闷。以何为对治。答曰。以慧。以五食一对治故。二体立盖。掉悔以何为食。答曰。以四法为食。一念亲属。二念国土。三念不欲死。四念曾所更喜笑游戏种种乐事。以何为对治。答曰。以定。以四食一对治故。二体立盖。等重担者。欲爱盖恚盖疑盖。一体能负盖义重担。睡眠掉悔盖。二体能负义盖重担。犹如村中事务。一人能办。则立一人。一人不能办者。则立多人。亦如以椽盖屋强者用一。弱者用二。彼亦如是。是故一食一对治一等重担者。立一盖。问曰。何故世尊先说欲爱盖。次说恚盖。后说疑盖。答曰。如是说者。则文随顺。复次若作是说。师授则易。弟子受亦易。复次随顺生时故。盖生时。先生欲爱。后生恚疑。是故世尊后说恚疑。尊者和须蜜说曰。爱着妙境界故。生欲爱盖。失妙境界故。生恚盖失妙境界。心没故。故生睡盖。睡覆心故生眠盖。从眠起生掉盖掉心生悔。随顺疑盖便生

佛经说。五盖或复有十。问曰。五盖云何或时有十。答曰。以三事故。一以缘内缘外。二以体性。三以善不善法。缘内缘外者欲爱体。有缘内生。有缘外生。内外生爱俱亦是盖。亦障于慧。不生菩提。不到涅槃。恚盖亦如是。体性者睡眠掉悔盖。亦障于慧。不生菩提。不到涅槃。以善不善法者。有疑于善法犹豫。有疑于不善法犹豫。俱是疑盖。亦障于慧。不生菩提。不到涅槃。以是三事故。立盖或说有十

七使中。慢使。见使。无明使。一切色无色界使。不立盖。问曰。何故慢使不立盖。答曰。盖覆没于心。慢令心高。问曰。无明何故不立盖。答曰。等负重义是盖义。无明负重偏多。问曰。见使何故不立盖。答曰。盖能灭慧。见体是慧。不可以慧灭慧。如是因论生论。如盖能灭一切善心心数法。此中何以但说灭慧。答曰。以慧名胜义亦胜故。彼聚中。谁为最胜。慧为最胜。若灭于慧。何况余者。犹如健夫能害千人敌者。何况余小者。问曰。何故色无色界使不立盖。答曰。以无盖义故。是以不立。复次盖障碍三界离欲法。色无色界烦恼。不障碍三界离欲法。复次盖障碍九断知果无漏道。色无色界烦恼。不障碍九断知果无漏道。复次盖能障碍四沙门果。色无色界烦恼不能障碍四沙门果。复次盖能为定作留难。色无色界烦恼。不为定作留难。复次盖能障碍三道。谓见道修道无学道。色无色界烦恼。不障碍三道。复次盖能障碍三根。谓未知欲知根知根。已知根。色无色界烦恼。不障碍三根。如三根三种菩提。三种慧。三种戒。三种身。三修三净。当知亦如是。复次盖一向不善。色无色界烦恼非不善。如是因论生论。何故唯立不善为盖。答曰。以对善法聚故。世尊独立不善为盖。如经说。比丘何等是善法聚。应答四念处是。若问谁是其对。应答不善法聚是。若问何者是不善法聚。应答五盖是。是故尊者瞿沙。作如是说。欲界众生。数数行此烦恼行时。微细不觉是过。是故为于众生。说名不善

佛经说。无明覆。爱结缚。愚者所行。聪明亦然。问曰。如无明亦能覆。亦能系爱。亦能覆。亦能系。何故说无明能覆。不说系。说爱能系。不说覆。答曰。应说而不说者。当知此是如来有余之说。复次欲以种种说种种文庄严于义。若以种种说种种文庄严于义。义则易解。复次欲现二门。如说无明是覆。爱亦是覆。如是爱是系。无明亦是系。是故欲现二门。乃至广说。复次先作是说。障义是盖义。更无有使障众生慧眼与无明等。系义是结义。更无有使系于众生如爱结者。如众生为无明所盲爱结所系。以盲以系故。不能得趣涅槃。此中应说二贼喻。是故尊者瞿沙。作如是说。无明盲众生。爱能系。是以不善法得生。是中应说二贼喻。复次从多分故。无明多覆众生。爱多系众生。复次无明覆义多。爱系义多

阿毗昙毗婆沙论卷第二十六阿毗昙毗婆沙论卷第二十七

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    使揵度不善品之三

五结爱结。恚结。慢结。嫉结。悭结。问曰。此五结体性是何。答曰。有三十七种。爱结三界有十五种。慢亦如是。恚结有五种。嫉结悭结。欲界修道所断有二种。此三十七种。是五结体。乃至广说。已说体性。所以今当说。何故名结。结有何义。答曰。系义是结义。广说如三结处五下分结欲爱结恚结身见戒取疑。问曰。五下分结体性是何。答曰。有三十一种。欲爱结有五种。通六识身。恚结有五种。通六识身。身见三界见苦所断有三种。戒取三界见苦见道所断有六种。疑三界见苦集灭道所断有十二种。此三十一种。是五下分结体。乃至广说。已说体性。所以今当说。何故名下分结。下分结有何义。答曰。下界所行故名下。复次下界所结。能令下生相续。能生下报果依果。以是事故。名下分结。下界者是欲界。问曰。若然者一切烦恼。尽下界所行。六十四使。是下界所断。三十六是欲界系。二十八是非想非非想处系。三十六能令下界生相续。三十四能生下界依果报果。二唯生依果。如是等烦恼。皆有下分义。何故世尊唯说五结是下分结。尊者波奢说曰。佛世尊决定知法相。亦知势用。余人所不知。乃至广说。尊者瞿沙说曰。佛知此五下分结速疾偏重亲近下界所行。下界中断令下界生相续。能生下界依果报果。非余烦恼。是故说下分结。复次有二种下。一界下。二众生下。界下者是欲界。众生下者是凡夫分。众生所以不能出下界者。为是何过。皆是欲爱结恚结过。众生所以不能过下凡夫分者。皆是身见戒取疑过。如说下界下地亦如是。复次此五下分结。于欲界众生。犹如狱卒伺捕之人。欲爱结恚结。犹如狱卒。身见戒取疑。犹如伺捕之人。譬如有人。闭在狱中。令二人守之。使不得出。令三人伺捕此人。若以亲友。若以眷属。若以钱财。若以伤害狱卒。而走出者。乃至远去。汝等三人。必当将还闭在狱中。狱如欲界。被闭人如凡夫。二狱卒如欲爱结恚结。身见戒取疑如三伺捕人。或有众生。以不净观。伤害欲爱结。慈观伤害恚结。离欲界欲乃至无所有处欲。生非想非非想处。身见戒取疑。还复将来闭在欲界狱中。是故尊者瞿沙。作如是说。若不断二法。则不出欲界。不断三法。则还生欲界。尊者婆摩勒说曰。以为二种结所缚故。不出欲界。不断三结故。必还生欲界。复次此是现门现略现始入。此诸烦恼。或一种断。或二种断。或四种断。或五种断。若说身见。当知已说一种断者。若说戒取。当知已说二种断者。若说疑。当知已说四种断者。若说爱恚。当知已说五种断者。若问爱恚。何以立下分结中。应答如不善根中。若问何以说三结立下分结中。应答如三结中

佛告诸比丘。汝等受持我所说五下分结耶。尔时长老摩勒迦子。在会中坐。即从座起。偏袒右肩。合掌向佛。而白佛言。我受持世尊所说五下分结。佛问摩勒迦子。汝云何受持我所说五下分结耶。彼答言世尊说欲爱是下分结。我受持之。说恚身见戒取疑是下分结我受持之。佛告之言。愚人汝若如是受持我所说者。外道异学。当呵责汝。如婴孩小儿仰卧床中尚无欲心。况为欲盖所覆。虽不为欲盖所覆。亦不得言不为欲使所使。广说如经。彼婴孩小儿。于色不识欲心。乃至不识法。可言无有使耶。问曰。佛经说五下分结。彼亦如是受持何故呵责摩勒迦子耶。答曰。不以文故。以不解义故。责其义。不责其文。长老摩勒迦子。作如是说。烦恼若行。是下分结。烦恼若不行者。非下分结。世尊说。使若不断。是下分结。不必行与不行。复次摩勒迦子说。使若现前行是五下分结。佛说若成就则是在于三世。不必现在。复次长老摩勒迦子说。使没溺于心是结。佛说有诸使得是结。如说若不善知见。断欲爱所起之处。不名无使恚。乃至疑说亦如是

五上分结。色爱无色爱掉慢无明。问曰。五上分结体性是何。答曰。有八种。色爱色界修道所断有一种。无色爱无色界修道所断有一种。掉慢无明。是色无色界修道所断有六种。此八种是色无色界修道所断。乃至广说。已说体性。所以今当说。何故名上分结。上分结有何义。答曰起上义是上分结义。向上义是上分结义。令上生相续义是上分结义。问曰。若趣上义。向上义。令上生相续义。是上分结义者。彼诸烦恼。不应立流。所以者何。漂义流下义是流义。漂诸众生诸界诸趣诸生生死中故。答曰。流义异上分结义异。亦以界故。立上分结。此诸烦恼。令众生趣上向上。令上生相续。以无解脱正智无漏圣道善法故立流。此诸烦恼众生。虽生有顶。犹为流所漂。不至解脱正智无漏圣道善法中故。是故尊者瞿沙。作如是说。众生虽久生在上。犹为流所漂。问曰。爱何故立二上分结。掉慢无明各立一耶。答曰。掉慢无明。亦应说如爱立二上分结。而不说者。当知此说有余。复次欲以种种文种种说庄严于义。若以种种文种种说庄严于义。义则易解。复次欲现二种门。如爱立二种。掉慢无明。亦应立二种。如掉慢无明立一种。爱亦应说一种。如是上分结体或四或八。如二门二俱通亦如是。复次以爱故。界别地别种别。能生诸烦恼。广说如解爱处

此上分结修道所断。问曰。何故上分结。唯修道所断。答曰。上分结。能令趣上不堕下。见道所断烦恼能令众生趣上。亦令堕下。复次上分结。是圣人所行。非凡夫所行。圣人中是阿那含所行。非斯陀含须陀洹所行。如是因论生论。问曰。何故上分结阿那含所行。非斯陀含须陀洹所行。答曰。以阿那含一向上生。斯陀含须陀洹。亦上生亦下生故。复次若出界得果者。此身中则行上分结。须陀洹斯陀含。虽得果不出界。复次若出界永断不善结者。则行上分结。须陀洹斯陀含。亦不出界。亦不永断不善结。复次若出界永断下分结者。彼身中则行上分结。须陀洹斯陀含。不出界亦不永断下分结。复次此烦恼立各别异。若身中立上分结。则不立下分结。若身中立下分结。则不立上分结。复次更不复行凡夫所行法故。立上分结。须陀洹斯陀含。犹行凡夫所行法。凡夫所行法者。共男女同一床宿。衣憍奢耶衣着华鬘。以栴檀种种香涂身。畜金银。受用金银器。驱使奴婢僮仆。亦以手搏顶头。以琐鞭人。起如是等身业。共妻妇寝宿。摩触骨人生细滑想。如是等凡夫所行法。复次更不入母胎流血中生。不住生藏熟藏。如是身中立上分结。如经说。质多居士。语诸亲里。汝等当知。我更不入母胎。广说如上。是故尊者瞿沙。作如是说。若解脱欲恚。则解脱入母胎。问曰。上分结中掉体。为是结非结。若是结者。波伽罗那所说云何通。如说云何结法。答言九结是。云何非结法。答言除九结余法是也。若非结者。此经云何通。如说云何上分结。答言。色爱无色爱。掉慢无明。答曰。应作是说是结。问曰。若然者此经善通。波伽罗那所说云何通。答曰。西方沙门。诵持波伽罗那经。作如是说。云何结法。答言。九结及五上分结中掉是也。云何非结法。答言。除九结及五上分结中掉。余法是也。罽宾沙门。非如是说。问曰。何故罽宾沙门。非如是说。答曰。罽宾沙门。应如西方沙门所说。而不说者。有何意耶。答曰。以掉是坏想。或少分是结。少分非结。或于一人是结。或于一人非结。或时是结。或时非结。少分是结少分非结者。色无色界是结。欲界非结。或于一人是结。或于一人非结者。于圣人是结。于凡夫人非结。或时是结或时非结者。圣人未离欲界欲非结。离欲界欲是结。以有如是坏相故。罽宾沙门。所以不说。如是因论生论。何故色无色界掉立结。欲界掉不立。答曰。欲界是不定界。非修地。非离欲地。此中无如是定。为掉所乱。是故欲界掉不立于结。色无色界。是定界是修地是离欲地。彼中四枝五枝定。为掉所乱。是故立结。如村落中。若村落边住处。虽有大声。不能作患。阿练若住处。虽复小声。犹以为患。彼亦如是。复次欲界多诸非法想烦恼。如恨佷诳谄高害。如是等烦恼。障覆于掉。不得明了。是故欲界掉不立是结。色无色界无非法想烦恼。彼中掉明了。是故立结。如村落中。村落边住处。多诸行恶比丘。而不可识。若至阿练若住处。远来可识

问曰。如掉睡俱在三界。五种所断。通六识身。一切染污心中可得。何以立掉。为上分结。不立睡耶。答曰。以掉是大过重患多过。以是大过重患多过故。世尊立上分结。波伽罗那经说。是不善大地。以其多过故。作如是说。云何结法。答言。九结及五上分结中掉是也。以其多过故。波伽罗那。复作是说。云何不共无明。云何不共掉缠。以其多过故。施设经。复作是说。凡夫人若生欲爱。则起五法。一欲爱。二欲爱生相。三无明使。四无明使生相。五掉。睡无如是大过重患多故。不立上分结中。复次以掉黠慧所行猛利能乱四枝五枝定。是故立上分结中。睡性愚不黠慧猛利。随顺于定。所行似定。若睡在身者。速能起定。是故不立上分结中。复次以睡覆于无明。无明立上分结。若当立睡为上分结。则为无明所覆

五见。身见边见邪见见取戒取。问曰。五见体性是何。答曰。有三十六种。身见三界见苦所断有三种。边见亦尔。邪见三界见苦集灭道所断。有十二种。见取亦尔。戒取三界见苦见道所断有六种。此三十六使。是五见体。乃至广说。已说体性。所以今当说。何故名见。见是何义。答曰。以四事故名见。一能视。二转行。三所取坚牢。四入缘中猛利。视者能看。问曰。此是邪见。所视颠倒。何所看耶。答曰。所视虽邪颠倒。而性是慧。以性是慧故能看。如人虽看不明了亦复名见。转行者。问曰。一刹那顷。有何转行耶。答曰。以其性猛利故名转行。所取坚牢者。此诸见于缘妄取坚牢。非无漏道力无由可断。若佛佛弟子出世。以无漏道力。乃能截诸见。牙如大海中虫名失兽摩罗。彼所啮若草若木。非刀不解舍。彼亦如是如偈说。愚人所受持。鳣鱼所衔物。失兽摩罗啮。非斧不能解。入缘猛利者。诸见入缘猛利。如针堕泥中。复次以二事故名见。一以能观。二以转行。复次以三事故名见。一与相相应。二成其事。三不害所缘。复次以三事故名见。一有期心。二坚着。三转行。复次以三事故名见。一以期心。二以方便。三以无知。期心者。坏于期心。方便者。坏于方便。无知者。坏期心方便故。复次坏期心者。坏行定人。坏方便者。坏行慧者。无知者。从他边有所闻。谬见法相

已总说诸见。所以今当别说。一一所以何故名身见。答曰。从自身生。亦从有身生。故名身见。问曰。余见亦尽从自身生。可是身见耶。答曰。若见从自身生。不从他身生。不从无身生。此见是身见。余见或从自身生。或从他身生。或从无身生。自身生者。谓缘自界。他身生者。谓缘他界。无身生者。谓缘无漏。问曰。如边见不从他身生。亦不从无身生。何故不名身见。答曰。身见以先受名故。更以余事。立边见名。以见二边故。复次若见从自身生。染着我我所。说身见。余见虽有从自身生者。而不染着我我所故。如我见我所见。已见已所见亦如是。复次若见从自身生。不违戒施修。说身见。余见虽从自身生。无如是事。复次若见从自身生。信所作受。是身见。余见虽从自身生。无有是事。尊者和须蜜说曰。自身名五受阴。此见从自身生。故名身见。问曰。何故说五受阴。名自身耶。答曰。以自作故。复次作故。亦是自烦恼业果故。问曰何故名边见。答曰。此见受二边。若断若常。故名边见。如经说。迦旃延。若以正智。如实知见世间集。则不言无世间。言无世间者。是断见。若见未来阴生作如是念。是众生死此生彼而不断。若以正智。如实知见世间灭。则不言有世间。言有世间者。是常见。若见阴界入相续生。彼作是念。此是灭法非常。复次此是外道边故说边见。外道计我是可呵责下贱之法。况复计我是断常者。而不是边下贱法耶。复次外道计我。是名取边。是名妄取于缘。是名所取愚痴。何况计我。有断有常。而非边耶。复次此见行断常二行故名边见。佛经说。比丘当知我不与世间诤。世间与我诤。问曰。佛何故不与世间诤。尊者和须蜜说曰。佛说有因果故。若与常见外道。共集一处。外道计有果无因。所以者何。无因故常。佛作是说。汝等有者。我亦有之。汝言无者。是愚痴故。若与断见外道。集在一处。彼断见外道。说有因无果。所以者何。断果故。佛作是说。汝等有者我亦有之。汝言无者是愚痴故。佛于一边取因。于一边取果。离于断常。而说中道。以是事故。佛不与世间诤。世间与佛诤。复次佛是法论。世间是非法论。法论者不与非法论者诤。复次佛以制法随顺世间。世间以实法不随顺佛。复次佛是善除斗诤根本。爱之与见。是斗诤根本。佛善除之。世人不除。是故作如是说。我不与世间诤。世间与我诤。尊者佛陀提婆说曰。佛则正论。世间不正论。正论不与不正论者诤。如一马行于邪道言行恶道。如是外道行邪道故。言行诤道。复次佛见义见法见善见好。是故不与世间诤。问曰。何故名邪见。答曰。行邪行故说邪见。问曰。五见尽行邪行。皆是邪见耶。答曰。以名以行故。若五见不立名立行者。五见尽是邪见。所以者何。行邪行故。若五见立名立行。此见名邪见行。无所有行。是名邪见。复次行邪行坏前法是邪见。余见虽行邪行。无如是事。复次若邪行谤一切因果。是名邪见。余见虽行邪行。无如是事。复次行于邪行。与施戒修相违。余见虽行邪行。无如是事。复次若行邪行。谤过去未来现在等正觉道及三漏处。是名邪见。余见虽行邪行。无如是事。复次若行邪行。谤二种恩。谓法恩众生恩。谤法恩者。言无施无祠祀无善恶业果报无今世后世。谤众生恩者。言无父无母无化生众生。言世无阿罗汉无趣正道。乃至广说。余见虽行邪行。无如是事。复次若行邪行。能起二种无恩。谓法无恩众生无恩。起法无恩者。言无施。乃至广说。起众生无恩者。言无父母。乃至广说。是名邪见。余见虽行邪行。无如是事。复次邪见若行邪行。坏现见事。如人堕火坑中。欲令世人生希有想。而作是说。我今快乐。如是众生。堕炽然阴界入中。以邪见故。言无有苦。余见虽行邪行。无如是事。复次若行邪行。说名是恶。如说比丘当知。若人邪见。所有身口意业。及回转法。其所愿求。尽生不爱不好不妙法。所以者何。比丘当知。以见恶故。余见虽行邪行。无如是事。不名邪见。问曰。何故名见取。答曰。取见故名见取。问曰。此见亦取五阴。何以但说见取耶。答曰。因见故取五阴。复次若取见。若取五阴。计第一者。是名见取。问曰。何故名戒取。答曰此见取戒。故名戒取。问曰。此尽取五阴。何以但说取戒耶。答曰。因戒故取五阴。复次以所行故。若取戒。若取阴。以所行净者名戒取。问曰。何故名取。答曰。取他见故名取。如身见计我所。边见计断常。邪见谤言无。见取取此诸见。以为第一。戒取取此诸见。以为净。是故取他见名为取

六爱身。眼触生爱。取鼻舌身意触生爱。应说一爱。如九结中。三界爱立一爱结。应说二爱。如七使中。欲界爱说欲爱使。色无色界爱。说有爱使。应说三爱。如经说。比丘当知。爱说有三。谓欲爱色爱。无色爱。应说四爱。如经说。爱从四事生。若比丘比丘尼因衣服生爱。生便生。成立便成立。善便善。因食生爱。因卧具生爱。因有生爱。若比丘比丘尼。生如是爱。广说如上。应说五爱。谓因苦断爱。乃至修道断爱。应说九爱。如上上乃至下下爱。应说十八爱。如说十八意行。应说三十六爱。如说三十六爱行。应说百八爱。如说百八爱行。若以在身。若以刹那。则有无量无边爱。问曰。以何等故。世尊广一爱说六爱。略无量爱说六爱身。答曰。以所依故。若一若无量爱。尽依此六。依六泉六道六识身相应而生。问曰。恚无明。亦依此六。依乃至与六识相应而生。何故唯说六爱身。不说六恚身六无明身。答曰。应说而不说者。当知此说有余。复次若说爱身。当知亦说恚身无明身。复次以爱在三界通五识身。能自成立。恚虽通五识身。自成立不在三界。无明虽在三界。不通五识身。能自成立。复次爱界别地别种别。广说如解爱处。问曰。何故名身。答曰。以多故说身。不以刹那顷眼触生爱名身。乃至多刹那眼触生爱名身。不以一象名为象军。乃以多象故。名为象军。车马步军。亦复如是。乃至意触生多爱。名为爱身。七使。欲爱使。恚使。有爱使。慢使。无明使。见使。疑使。问曰。七使体性是何。答曰。有九十八种。欲爱使欲界五种。爱通六识身。恚使有五种通六识身。有爱使。色无色界爱。有十种。慢使三界有十五种。在意地。无明使三界有十五种。见使欲界有十二。色界有十二。无色界有十二。合三十六种。疑使三界四种所断。有十二种。此九十八。是七使体。乃至广说

已说体性。所以今当说。何故名使。使是何义。答曰。微义是使义。坚着义是使义。相逐义是使义。微义是使义者。微名细。如七微尘成一细。坚着义是使义者。乃至一刹那顷。使一微尘亦生于着。相逐义是使义者。如空行水行众生逐影法。空行者是鸟。水行者是水中虫。鸟以翅力。欲度大海。海水中虫。取其相已。而作是念。无有飞鸟能过大海。除金翅鸟王。即逐其影。彼鸟疲极堕水。虫便吞之。如是诸使得一切时常住身中。若不正思惟。则生依果报果

复次微者是体。著者是所作。相逐者是得。复次微者是过去使。着是现在使。相逐者是未来使。复次微义着义是相应使义。相逐义是心不相应使义。问曰。无有不相应使。答曰。此中说使得是使。外国法师。说四种义。微义是使义。着义是使义。遍义是使义。相逐义是使义。微义是使义者。此使自性微细。所行亦微细。着义是使义者。彼使于此义坚着。犹如小儿坚着于乳。遍义是使义者。彼使遍在身中。如油在麻中腻在揣中。相逐义是使义者。如空行水行虫逐影法。复次微义是使义者。是使自体。着义是使义者。是所行。遍义是使义者。是相应。相逐义是使义者。是诸得。应以三事知使。一以自体。二以果。三以人。以自体者。欲爱使如食兴渠。恚使如食苦蔘子。有爱使如乳母染污衣。慢使如憍人。无明使如盲人。见使如失道疑使如临岐路人。果者修行广布欲爱使。生雀鸳鸯鸽中。修行广布恚使。生毒蛇中。修行广布有爱使。生色无色界中。修行广布慢使。生卑贱中。修行广布无明使。生盲闇中。修行广布见使。生外道中。修行广布疑使。生于边地。以人者。欲爱使以难陀等知。恚使以气嘘指鬘等知。有爱使以阿私陀阿罗吒优陀迦等知。慢使以摩那答陀等知。无明使以优楼频螺迦叶等知。疑使以摩勒迦子等知

问曰。何故嫉悭不立使耶。答曰。无使相故不立使。复次嫉悭是粗烦恼。微细是使。嫉悭性重。使性轻。嫉悭性迟。使性捷疾。复次嫉悭习气不牢固。使性习气牢固。习气牢固者立使。不牢固者不立。如烧草烧裸皮处。火灭其地即冷。嫉悭习气。亦复如是。如烧佉陀罗木。火虽久灭。其地犹热。使性习气。当知亦如是。九结。爱结。恚结。慢结。无明结。见结。取结。疑结。嫉结。悭结。问曰。九结体性是何。答曰。有百种爱结三界有十五种恚结有五种。慢结三界有十五种。无明结三界有十五种。见结有十八种。身见三界有三种。边见亦尔。邪见三界有十二种。取结有十八种。见取三界有十二种。戒取三界有六种。疑结三界有十二种。嫉悭欲界修道所断有二

已说体性。所以今当说。何故名结。结有何义。答曰。系义是结义。合苦义是结义。杂毒义是结义。余如三结处说。已总说九结所以。一一所以今当说云何爱结。答曰。三界爱立爱结。欲界爱立欲爱使。色无色界爱立有爱使。经说有三爱。欲爱。色爱。无色爱。此三种有何差别。答曰。受佛化者有三种。利根中根钝根。为利根者说爱结。中根者说欲爱使有爱使钝根者说三爱。如利根中根钝根。久行已行初行。乐略乐广乐略。广说亦如是。复次同苦系义故。欲界爱亦同苦系。色无色界爱亦同苦系故。云何恚结。害众生者是也。问曰。如于非众生法中。亦起于害何故但说害众生耶。答曰。于众生数法中起恚多。非众生数起恚少。复次于众生数起恚罪重。于非众生数起恚罪轻。复次因众生数恚。亦恚非众生数。云何慢结。答曰。七种慢。是慢使。一慢。二大慢。三慢大慢。四我慢。五增上慢。六如慢。七邪慢。广说如杂揵度。云何无明结。答曰。三界无知。如是说者好。若作是说。缘三界无知者。则不摄无漏缘使。云何见结。答曰。三见是也。谓身见。边见。邪见。云何取结。答曰。二取是也。谓见取。戒取。广说如波那罗经。问曰。何故五见三见立见结。二见立取结耶。答曰。同苦系义故。身见名女声。是苦系义非乐。如身见。边见邪见亦如是。见取戒取名男声。是苦系义非乐(天竺声论法有男声女声非男非女声)。复次此二结体等摄使亦等。体等者见结体有十八。取结体亦十八。摄亦如是。复次若见行邪行。非取是见结。若见行邪行取。非见是取结。云何疑结。于谛犹豫。何以作此论耶。答曰。欲令疑意得决定故。若远见高物。疑为是人耶为是杌耶。若知是人。疑为是男耶为是女耶。见二道疑为是所趣道。为非所趣道耶。见二衣二钵。疑为是我衣钵耶。为非我衣钵耶。人谓如此是实疑结。欲令此义决定是欲界不隐没无记邪智。若疑为有苦集灭道。为无苦集灭道耶。此是实疑。是名疑结。云何嫉结。答曰。见他善好心不忍。云何悭结。答曰。心悭着。问曰。何故作此论耶。答曰。欲令疑者得决定故。世人于嫉作悭想。于悭作嫉想。若人见他好物。心生嫉者。世人言此人悭。此非是悭乃是嫉。若人见他牢藏己妻。世人言是嫉。而实非嫉乃是悭。为断如是嫉是悭想悭是嫉想亦显嫉悭差别之相。而作此论。云何嫉结。见他善好心不忍。为断如是嫉是悭意此结是不忍相。非悭着相。若见他有好物。便生嫉心。此于我为好。云何悭结。答曰。心悭着。作如是说。已断悭作嫉想。此结是悭着相。非不忍相。善守护己妻。不令出故

问曰。何故于十缠中嫉悭为结。非余缠耶。答曰。无结相者不立。有结相者便立。复次以现其终故。于十缠中。嫉悭是终。复次此二能自成立。无有二相能自成立者。以自力用故成立。无二相者。一向不善故。忿缠覆缠能自成立。无有二相。然外国法师说。此二是使。不说是缠故不应问。睡掉不能自成立。以因他力故立。非不二相。以不善无记故。眠悔虽能自成立亦非不二相。以眠有善不善无记悔善不善故。无惭无愧。虽非二相。而自不成立。因他力故。嫉悭非二相。亦自成立故。复次此二结是下贱可呵责法。复次此是恶人下人所行故。若世人供养他。何故生嫉。虽复积聚百千财宝。不能持五钱至于后世。若当施于他者。有何过。复次世间以此二结故。曾多受毁辱。世人轻毁二法。谓无威势贫穷者。以修行广布嫉结。令无威势。修行广布悭结。令人贫穷。若人贫穷无有威势。父母兄弟亲属僮仆。乃至己妻。而轻贱之。复次此二结。于欲界众生。能为二事。一如狱卒。二如守门人。如人闭在牢狱。以二人守。不令出行。譬如清净庄严园林。以二人守门。不令人入恶道。当知如牢狱嫉悭。当知如狱卒众生。所以不能出恶道狱者。以嫉悭所守故。人天如清净庄严园林。嫉悭如二守门者。众生所以不得人天中乐。以嫉悭故。以是事故。嫉悭立结。如经说释提桓因往至佛所而作是问。世尊人天多行何结。阿修罗揵闼婆。乃至广说。佛告憍尸迦。人天多行嫉结悭结。阿修罗。龙迦楼罗。揵闼婆。紧那罗。摩睺罗伽。如是等众生。亦多行嫉结悭结。问曰。众生或有九结。或有六结。或有三结。或有无结。九结者。具缚凡夫。有六结者。是离欲界欲凡夫。未离欲爱圣人。有三结者。离欲圣人。无结者。是阿罗汉。无有众生成就二结一结者。何故世尊说。人天阿修罗等。多成就二结。答曰。以嫉悭是富贵人所行。帝释于二天中尊。复次以此二结故人天阿修罗。数数共斗。诸天有好食。阿修罗有好女。诸天悭惜于食。不欲令余去。于女生嫉言。于我等好。阿修罗于女悭惜。不欲令出。于食生嫉言。于我等好。诸天为女故。下诣阿修罗城。阿修罗为食故。上诣天城。以是事故。天阿修罗。数数共斗。尔时帝释。从战阵出。心怀恐怖战栗。未久之间。往诣佛所。而白佛言。天人阿修罗等。以何结故。数数共斗。世尊以方便力。而作是说。帝释当知。以嫉悭二结。为汝作患。生恐怖厄难。犹如重担。以是事故。人天阿修罗等。以此二结数数共斗

九十八使。问曰。何故作此论。答曰。欲断著文沙门意故。有著文沙门所说而受持之。复作是言。佛说七使。谁聪明过佛者。说九十八使耶。欲断如是说者意故。亦欲说九十八使体相性分。以是事故。而作此论。佛经说七使。以界以种以行。有九十八使。七使中欲爱使。于九十八使中。以种故有五。恚使亦尔。七使中有爱使。于九十八使中。以界故有二。以种故有五。以界以种故有十。七使中慢使于九十八使中。以界故有三。以种故有五。以界以种。使有十五。无明使亦尔。七使中见使于九十八使中。以界故有三。以行故有五。以种故有十二。以界以种以行故。有三十六。七使中疑使于九十八使中。以界故有三。以种故有四。以界以种故有十二

阿毗昙毗婆沙论卷第二十七阿毗昙毗婆沙论卷第二十八

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    使揵度不善品之四

此三结几不善几无记。乃至九十八使。几不善几无记。问曰。何故作此论。答曰。或有说。一切烦恼。尽是不善。以无巧便所持故。如譬喻者。作如是说。为断如是意亦明烦恼是不善无记故。若无巧便所持是不善者。诸烦恼。应言无巧便。不应言是不善。所以者何。无巧便是无知持是相应。不可以自体还应自体。复次或有说。欲界诸烦恼。尽是不善。色无色界诸烦恼。尽是无记。为断如是说者意。亦明身见边见是无记法故。而作此论。复有说者。所以作论。为何义故。而作论。答曰。欲令此义成立故作此论。是故先作是问。以何义故。彼尊者作论先立章。答曰。欲现门故。今欲现问故作此论。此三结。几不善。几无记。答曰。一是无记。谓身见。问曰。何故身见是无记耶。答曰。若法是无惭无愧。与无惭无愧相应。从无惭无愧生。与无惭无愧作依果者。是不善。身见不与无惭无愧相应。不从无惭无愧生。不与无惭无愧作依果故。是无记。复次此结不一向坏期心。云何不一向坏期心。答曰。即如上义。复次此结不与施戒修相远故。是无记。若人计我。修行布施。欲令我乐。持戒欲令我生天。习修欲令我得解脱。复次此结于自体愚。不逼切他。若人计我。眼见色时。不作是念。眼能见色。色是可见。而作见念。我能见色。我所是可见。乃至意知法。不作是念。意能知法。法是可知。而作是念。我能知法。我所是可知。不逼切他者。如是等颠倒见。不逼切他。复次以身见。不生报故。是无记。尊者和须蜜说曰。何故此见是无记耶。答曰。此见不能起粗身口业。问曰。若然者。不善烦恼。亦有不能起粗身口业者。答曰。贪恚愚痴增盛时能起。复次此见不能令人堕恶道。问曰。若然者不善烦恼。亦有不能令人堕恶道者。答曰。贪恚愚痴增盛时。能令人堕恶道。此见增盛时。不能令人堕恶道。复次此见不能生不爱果。问曰。此见能生后有。即是生不爱果。所以者何。如佛说。比丘若起后有。乃至一刹那者。我不称美。所以者何。起于有者。是苦法故。尊者佛陀提婆说曰。此见所取是颠倒。亦生颠倒。应是不善。若当身见非不善者。谁是不善。世尊亦说。乃至小愚亦是不善。二当分别。问曰。何故言分别。答曰。此义应分别。是不善分。是无记分。复次此义当破故言分别。毗婆阇婆提作是说。此义应解脱分明故言分别。戒取疑若在欲界是不善。若在色无色界是无记。问曰。何故色无色界烦恼是无记耶。答曰。若法是无惭无愧。与无惭无愧相应。从无惭无愧生。与无惭无愧作依果者是不善。色无色界烦恼。与上相远故是无记。复次此烦恼不坏期心。云何不坏期心。以上义故。复次色无色界烦恼。不能生报。以不生报故是无记。所以不能生于报者。以为四枝五枝定所制伏故。犹如毒蛇为咒术制伏则不能螫人。彼亦如是。复次非报器故。色无色界烦恼是无记。若当色无色界能生报者。为生何报。应生苦受。苦受是欲界法。不可以色无色界烦恼于欲界中受报。复次色无色界。非一向能生颠倒。有少相似法。如色无色界邪见。谤言无苦。有少乐分见取见。色无色界阴是第一。彼有少分第一戒取见。色无色界有少分净。亦有能净欲界道。无色界有能净色界道。尊者和须密说曰。何故色无色界诸烦恼是无记。答曰。不能起粗身口业故。问曰。不善烦恼。亦有不能起粗身口业者。答曰。贪恚痴增盛时。能起粗身口业。彼诸烦恼增盛时。不能起粗身口业。复次彼诸烦恼。不能令人堕恶趣

问曰。不善烦恼。亦有不能令人堕恶道者。答曰。贪恚痴增盛时。能令人堕恶道。彼诸烦恼增盛时。不能令人堕恶道。复次彼诸烦恼。不能生不爱果。问曰。若生少后有是不爱果。广说如上。尊者佛陀提婆说曰。若当色无色界烦恼非不善者。谁是不善。世尊亦说。烦恼生业。应是不善。三不善根。即是不善。所以者何。此不善根。是不善烦恼。为不善法。作因作根。作出处作本。作有作缘。作集作生故。三漏。一是无记。二当分别。一无记者。是有漏。所以是无记。应如上说。二当分别者。谓欲漏无明漏。欲漏或不善或无记。云何不善欲漏。是无惭无愧。亦与无惭无愧相应者。是不善无惭无愧。即是自体。与无惭无愧相应者。取三十四种。一向不善者三种。少分谓睡眠掉举。无惭无愧相应者是不善。云何无记欲漏。不与无惭无愧相应。是则说身见边见。亦说三种。少分谓睡眠掉举。身见边见相应者。是名无记。问曰。无惭不与无惭相应。无愧不与无愧相应。可是无记欲漏所摄耶。答曰。此文应如是说。云何无记。无惭无愧所不摄不相应欲漏。无惭无愧不摄。则余无惭无愧不相应。则余无惭无愧相应。而不说者有何意耶。答曰。无惭虽不与无惭相应与无愧相应。无愧虽不与无愧相应而与无惭相应。所以者何。不相离故。是故非无记欲漏所摄。无明漏。或不善或无记。云何不善无明漏。与无惭无愧相应。如是则说欲界四种所断无明。谓集灭道修道所断。及苦谛所断。少分谓三见疑爱恚慢相应无明。及不共无明。云何无记无明漏。不与无惭无愧相应者。如是则说欲界身见边见相应无明。色无色界五种所断无明。问曰。何故十缠中。唯说与无惭无愧相应不说余耶。答曰。彼作经者。有如是欲如是意。随其欲意。而造此论。亦不违法相。复次此二缠一向不善。与一切不善烦恼相应。忿缠覆缠嫉缠悭缠。虽一向不善。而不与一切不善烦恼相应。睡缠掉缠。虽与一切不善烦恼相应。而不一向不善。所以者何。以不善无记故。眠缠悔缠。非一向不善。所以者何。眠有善不善无记。悔有善不善无记故。无惭无愧。一向不善。与一切不善烦恼相应故。随有尔许无惭无愧相应。有尔许不善烦恼。有尔许不善烦恼。有尔许无惭无愧相应。随有尔许函。有尔许盖。彼亦如是。四流。一无记。谓有流。所以者何。以是色无色界法故。如说色无色界烦恼。是无记。此亦如是。三当分别。谓欲流见流无明流欲流。或不善或无记。云何不善。无惭无愧。及相应欲流。无惭无愧。则说无惭无愧体。相应欲流。则说二十四种。一向不善者。及三种少分。谓睡眠掉举。无惭无愧相应者。云何无记。谓不与无惭无愧相应欲流。如是则说睡眠掉少分与欲界身见边见相应者。见流。或不善或无记。云何不善。欲界系三见。谓邪见见取戒取。云何无记。欲界系二见。谓身见边见。色无色界系五见。无明流。或不善或无记。云何不善。谓与无惭无愧相应无明流。云何无记。谓不与无惭无愧相应无明流如流。扼亦如是。四取。一无记。谓我语取。所以者何。以是色无色界法故。如说色无色界烦恼是无记。此亦如是。三当分别。谓欲取见取戒取。欲取。或不善或无记。云何不善。无渐无愧。及相应欲取。无惭无愧则说自体。及相应欲取则说二十八。一向不善者。及四种少分。谓睡眠掉无明。与无惭无愧相应者。云何无记。不与无惭无愧相应欲取。是则说四种少分。谓睡眠掉无明。与欲界系身见边见相应者。见取。或不善。或无记。云何不善。欲界系二见。谓邪见。见取。云何无记。欲界系二见。谓身见边见。色无色界四见。戒取。欲界是不善。色无色界是无记。四缚二缚。是不善。谓贪身缚。恚身缚。二当分别。谓见取身缚。戒取身缚。欲界系者是不善。色无色界系者是无记。五盖唯不善。五结。三不善。谓恚结悭结嫉结。二当分别。谓爱结慢结。欲界系是不善。色无色界系是无记。五下分。二不善。谓欲爱恚结。一无记。谓身见。二当分别。谓戒取疑。欲界系是不善。色无色界系是无记。上分结唯无记。五见。二无记。谓身见边见。三当分别。谓邪见见取戒取。欲界系是不善。色无色界系是无记。六爱身。二不善。谓鼻触生爱身。口触生爱身。四当分别。谓眼触生爱身。耳触生爱身。身触生爱身。欲界系是不善。梵世系是无记。意触生爱身。欲界系是不善。色无色界系是无记。七使二是不善。谓欲爱使恚使。一是无记。谓有爱使。四当分别。谓慢使。无明使。见使。疑使。慢使。疑使。欲界系是不善。色无色界系是无记。无明使。或不善或无记。云何不善。与无惭无愧相应无明使云何无记。不与无惭无愧相应无明使。见使。或不善或无记。云何不善。欲界系三见云何无记。欲界系二见。色无色界系五见。九结。三不善谓恚结悭结嫉结。六当分别。谓爱结。慢结。取结。疑结。欲界系是不善。色无色界系是无记。无明结。或不善或无记。云何不善。与无惭无愧相应无明。云何无记。不与无惭无愧相应无明。见结。或不善或无记。云何不善。欲界系邪见。云何无记。欲界系身见色界系三见。九十八使。三十三不善。六十四无记。一当分别。欲界系见苦所断无明使。或不善或无记。云何不善。与无惭无愧相应者。云何无记。不与无惭无愧相应者。此门毗婆沙优波提舍。是应广分别。问曰。何故名善。何故名不善。何故名无记耶。答曰。若为巧便所持生爱果。安隐故名善。巧便所持者是道谛。生爱果者。是苦集谛少分。安隐者是灭谛。若不为巧便所持。生不爱果。不安隐者是不善。此说苦集谛少分此相违是无记。复次生爱果。生乐受果是善。生不爱果。生苦受果是不善。与此相违是无记。复次生可爱有种子是善。生不可爱有种子是不善。与此相违是无记。复次生可爱趣中是善。生不可爱趣中是不善。与此相违是无记。复次于寂静分中。体性轻举者是善。于增盛分中。体性重没者是不善。与此相违是无记。尊者婆多说曰。以四事故名善。一体。二亲近。三能起。四实义。体者是自体。或有说。惭愧是自体。或有说三善根是自体。亲近者。谓心心数法。能起者。能起身口业及心不相应行。实义者是涅槃。以安隐故说善。是以毗婆阇婆提作如是说。自体善者是智。亲近善者是识。能起善者。能起身口业。实义善者是涅槃。以四事故。名不善。一体。二亲近。三能起。四实义。体者是自体。或有说。无惭无愧是自体。或有说。三不善根是自体。亲近者。是心心数法。能起者。能起身口业及心不相应行。实义者。是生死不安隐故说不善。是以毗婆阇婆提作如是说。自体者是愚痴。亲近者是识。能起者能起身口业。实义者是生死。尊者波奢说曰。若法是正观。与正观相应。从正观生依果解脱果。是名善。若法非正观。乃至不从正观生依果是名不善。与此相违是名无记。如正观不正观。惭愧无惭愧。善根不善根。信等五根五盖。说亦如是。集法经说。何故名善。答曰。有爱果妙果适意果可意果。故名善。报果说亦如是。何故名不善。答曰。有不爱果不妙果不适意果不可意果。故名不善。报果说亦如是。与此相违是无记。问曰。世尊定记苦。定记集。定记灭。定记道。广说十二入施设解说显现。何以言无记耶。答曰。不以不解说。故言无记。但世尊善法记善。不善法记不善。此法非善法所记。非不善法所记。故言无记。复次世尊说。善法有爱果。不善法有不爱果。此法不生爱不爱果。故言无记。复次善以二事故名善。一以自体。二以有报。不善亦尔。无记虽有自体。不生于报。故说无记。世尊或有不解说名无记(天竺音无记是无答)。如经说沙门瞿昙。世界常耶。佛言此不应答。问曰。何故佛不答此问耶。答曰。外道计人是常。彼诸外道。往诣佛所。作如是问。沙门瞿昙。人为是常。为非常耶。佛作是念。无人我。答言无。彼诸外道。当作是说。我不问有无。若当说常无常者。无法云何说有常无常。如问人石女儿为恭敬孝顺不。彼作是念石女无儿。我若答言无彼当作是说。我不问有无。若当说恭敬孝顺。彼当作是说。石女无儿。云何当说恭敬孝顺。彼亦如是。此论非有非实。以非有非实故。世尊不答。四种答如杂揵度智品广说。此三结。几有报几无报。乃至九十八使。几有报几无报。问曰。何故作此论。答曰。如譬喻者说。除思无报因。除受无报果。为断如是说者意亦现五阴是报果。复次何故作此论。答曰。或有说。已受报因则无体。如迦叶维部。彼作是说。因义乃至报未熟。若报熟彼无因义。犹如种子。牙未生时。有种子义若牙生无种子义。彼亦如是。为断如是意亦明报虽熟因故有体。复有说者。何故作此论。答曰。为外道故。外道说善恶业无有果报。为断如是意亦明善恶业有果报。是故为止他义欲显己义。亦说法相相应义故。而作此论。假使莫为止他义莫为显己义。但欲说法相相应义故。而作此论。如初门文所说。此门文亦应如是说。三结若不善者有报。无记者无报。乃至九十八使亦尔。此门是广说优波提舍毗婆沙。问曰。为以自法报俱言有报。为以他法报俱言有报耶。若以自法报俱言有报者。云何因果不并耶。亦违偈说。如说

  作恶不即熟　　如萨遮投乳
  不即烧愚小　　犹如灰底火

有草名萨遮。若磨为散。投之乳中。即便成酪。因果不尔。云何尔耶。答曰。如灰底火。初蹈不热。久住乃热。如是不善业。因时生喜乐。变成果时。生诸恶趣阴界入若以他法报俱言有报者。无漏圣道。亦与他法报俱。应言有报。答曰。应作是说。与自法报俱故言有报。问曰。若然者云何因果不并耶。亦违偈说。答曰。俱有二种。一者有俱。二者并俱。有俱者有因有果有缘有报是也。有因有果者如百亿劫前造因。虽灭为后生法作因。此法于因虽远而名有因。彼法于果虽远而名有果。有缘者如日月。去此四千由旬。眼若缘者。便生眼识。境界虽远而生眼识。名之有缘。有报者百亿劫前所造业。虽灭于今身生报。彼业于此报虽远而言有报。并俱者如有觉有观有喜有用。有觉者觉相应法。有观者观相应法。有喜者喜根相应法。有用者作观相应法。此中以有俱而作论。不以并俱。复次俱有二种。一有俱二不相离俱。有俱者如说。有因乃至有报。不相离俱者如说。有觉乃至有用。此中以有俱而作论。不说不相离俱。复有三种俱。有近俱有远俱有近远俱。近俱者如说。有觉乃至有用。远俱者如说。有因乃至有报。近远俱者如说。有漏有使有缘有体。有漏者有漏法。或与漏相应。或与漏作所缘相应。作缘俱是有漏。如有漏有使亦尔。有缘者缘有近有远。近缘远缘俱是有缘。如有缘者体亦尔。此中以远俱而作论。不以近俱。不以近远俱。问曰。何故名报。答曰。生不相似法故名报。报有二种。有相似。有不相似。相似者。如依善法生善法。依不善法生不善法。依无记法生无记法。不相似者。如善不善法生无记报除余报义。如杂揵度智品广说

此三结。几见道断几修道断。乃至九十八使。几见道断几修道断。问曰。何故作此论。答曰。或有说。凡夫不能离欲。圣人不能以世俗道断结。如譬喻者。尊者佛陀提婆作如是说。若凡夫人。不能断结。而能制缠。如是说者。名不覆说。问曰。彼何故作是说耶。答曰。依佛经故。佛经说。比丘当知。若以圣慧。知见法者。是名为断。凡夫人。无有圣慧。无圣慧故。不名为断。问曰。若然者此经云何通。如说比丘当知。郁头蓝弗。断欲爱色爱。断空处爱。乃至无所有处爱。生非想非非想处。亦说。外道仙人。能离欲爱。彼作是答。此经不断说断。不离欲说离欲。余经亦说。不断是断。不离欲是离欲。不断是断者。如偈说

  人计诸物是我有　　死时皆断不持去
  如是智者不应计　　于诸物中我有想

不离欲说离欲者。如说如村落中童男童女造作土舍。若于此土舍。未离欲时。心生渴爱。修治拥护。计是我有。若离欲时。毁坏舍去。如此经不断说断。彼经亦尔。然凡夫人。不能断结。言凡夫人离欲界欲者。以世俗道。制伏下界烦恼。上缘初禅。如阇楼虫行法。离欲界欲。乃至离无所有处欲。非想非非想处。更无上地而可上缘。得离非想非非想处欲。如人上树从枝至枝。若至树端更无有枝。而便还下。如是凡夫人。缘上地法。能制伏下地烦恼。而不能断。犹如狼狗从麻苇中过。虽能摧卧。而不能断。彼亦如是。为断如是说者意亦明凡夫人能离欲世俗道能断结故。而作此论。复次所以作论者或有说圣人不以世俗道断结。所以者何。彼圣人何为舍无漏道而用世俗道。为断如是说者意亦明圣人以世俗道能断结故。而作此论。复次所以作论者。为止说顿断沙门意故。有沙门说顿断法。如金刚喻定断一切结。无结不断不破不入不得其边故。喻如金刚无物不断不破不入不得其边。谓若铁牙贝珂玉石摩尼等。彼亦如是。彼说有四沙门果金刚喻定断一切结。问曰。若然者何用三沙门果。为彼作是答。三沙门果。已制伏烦恼。后金刚喻定现在前时。断一切结。犹如农夫左手执草右手一时以镰断之。彼亦如是。为断如是说者意亦明烦恼有二种。有二种对治。一见道断。二修道断。见道断者。以见道为对治。修道断者。以修道为对治。复次何故作论者。答曰。或有说。一时见谛。非次第见。为止如是说者意亦明见谛有次第故。若当一时见谛非次第者。则违佛经。如经说给孤独居士。往诣佛所。作如是问。世尊为一时见谛。为次第见耶。佛答言。居士次第见谛。如登梯法。复次所以作论者。欲明烦恼有二种有二种对治。一见道断种。二修道断种。见道为见道断种作对治。修道为修道断种作对治。是故欲止他义欲显己义。亦说法相相应义故。而作此论。假使莫止他义莫显己义。但欲说法相应义故。而作此论。此三结。几见道断。几修道断。见道在前有二种身见在前有二种。或见道断或见道修道断。问曰。在前是何义。答曰。立分义。先答义。是在前义。立分义者。先立见道所断分。后立不定。先答义者。先答见道所断。后答不定。云何见道断。若身见是非想非非想处系。若坚信坚法。以苦忍断。身见在欲界。乃至非想非非想处。可得以世俗道断。欲界身见。乃至无所有处。于非想非非想处世俗道便在。更无势用。而还起见道现在前。断非想非非想处身见。若说身见。则定体。若说非想非非想处系。则定地。若说坚信坚法。则定人。若说苦忍。则定对治。若说断。则定己作事。此则说身见。是不共对治。决定对治。圣人能断。凡夫不能。用无漏道。不用世俗道唯用见道。不用修道。以忍不用智。此中则说如是身见。余身见。若凡夫断。以修道断。世尊弟子。以见道断。何者是余身见。欲界乃至无所有处。若凡夫人。以修道断。圣人以见道断。凡夫人以世俗道断。圣人以无漏道断。凡夫人以智断。圣人以忍断。凡夫人。九种身见。作九时断。圣人九种身见。作一时断。凡夫人断有止息。圣人断无止息。凡夫人断不见谛。圣人断见谛。是故作如是答。余身见。若凡夫人。以修道断。世尊弟子。以见道断。戒取疑见道在前有二种。或见道断。或见道修道断。在前义。如上说。云何见道断。若戒取疑。在非想非非想处系。若坚信坚法。以诸忍断。戒取疑。从欲界乃至非想非非想处。可得世俗道现在前断欲界戒取疑。乃至无所有处世俗道。于非想非非想处便住。更无势用。而还起见道现在前。断非想非非想处戒取疑。若说戒取疑。则定体。若说非想非非想处系。则定地。若说坚信坚法。则定人。若说诸忍。则定对治。若说断。则定己作事。此则说戒取疑是不共对治决定对治。圣人能断。凡夫人不能。用无漏道。不用世俗道。唯以见道。不用修道。以忍不用智。此中则说如是戒取疑。余戒取疑。凡夫人断。以修道断。世尊弟子。以见道断。余如上说。贪恚痴及欲漏修道在前有二种。或修道断。或见道修道断。在前是何义。答曰。立分义。先答义。是在前义。立分义者。先立修道所断分。后立不定。先答义者。先答修道所断。后答不定。云何修道断。答曰。贪恚痴。及欲漏学见迹。以修道断。贪恚痴及欲漏有五种。见苦断种。乃至修道断种。见道现在前断。苦谛所断。乃至道谛所断。贪恚痴及欲漏。于修道所断便生。更无势用。而还起修道现在前。断修道所断贪恚痴及欲漏。若说贪恚痴及欲漏。则定体。若说学见迹。则定人。若说修道。则定对治。若说断。则定己作事。此贪恚痴及欲漏。是不共对治。决定对治。是圣人所断。非凡夫人。是修道断。非见道断。智断非忍断。此中则说如是贪恚痴及欲漏。余者若凡夫人断。修道断。世尊弟子见道断。余何者是耶。答曰。余者有四种。谓见苦所断。乃至见道所断。若凡夫人断。修道断。世尊弟子见道断。余广说如上。以是事故。而作是说。若凡夫人断。是修道断。世尊弟子见道断。问曰。若说学见迹以修道断贪恚痴及欲漏。则说圣人身中修道所断者。余若说凡夫人断以修道断。若圣人断以见道断。是则说凡夫圣人身中见苦集灭道所断贪恚痴及欲漏。此中有何余未称说者。答曰。凡夫人身中修道所断贪恚痴及欲漏。问曰。此何以不说耶。答曰。应说而不说者。当知此说有余。复次已说在先所说中。所以者何。以种故立作烦恼种。不以在身中立烦恼种。齐五种无第六种。圣人以见道断见道所断种。以修道断修道所断种。凡夫人。若见道所断。若修道所断。尽合集以修道断。所以者何。凡夫人于五种所断烦恼。必以修道断此义决定。以是事故。当知已说在前所说中。有漏无明漏见道在前有三种。或见道断。或修道断。或见道修道断。何者是在前义。答曰。立分义。先答义是在前义。先立见道断种。次立修道断种。后立不定。先答者先答见道所断种。次答修道所断种。后答不定。云何见道断。若有漏无明漏。在非想非非想处系。若坚信坚法。以诸忍断有漏。从初禅乃至非想非非想处。可得无明漏。从欲界乃至非想非非想处。可得世俗道现在前断无明漏。从欲界乃至无所有处断有漏。从初禅乃至无所有处。于非想非非想处便住。更无势用。而还起见道现在前。断非想非非想处见道所断有漏无明漏。见道于修道所断便住。更无势用。而还起修道现在前。断修道所断有漏无明漏。若说有漏无明漏。则定体。若说非想非非想处系。则定地。若说坚信坚法。则定人。若说诸忍。则定对治。若说断。则定己作事。有漏无明漏。是不共对治。决定对治。圣人所断。非凡夫人。以无漏道断。非世俗道。以见道断。非修道。以忍断非智。此中则说如是有漏无明漏。云何修道断。答曰。有漏无明漏学见迹。以修道断。有漏无明漏有五种。谓见苦断。乃至修道断。见道断。苦谛所断。乃至道谛所断。有漏无明漏见道。于修道所断便住。更无势用。而还起修道现在前。断修道所断有漏无明漏。若说有漏无明漏。则定体。若说学见迹。则定人。若说修道。则定对治。若说断则定己作事。有漏无明漏。是不共对治。决定对治。是圣人断非凡夫人。是修道断。非见道。是无漏道断。非世俗道。是智断。非忍断。此中则说如是有漏无明漏。余者若凡夫断。以修道断。世尊弟子以见道断。问曰。何者是余耶。答曰。无明漏。欲界有四种。有漏无明漏。从初禅乃至无所有处有四种。此若凡夫断。以修道断。若圣人断。以见道断。余广说如上。在前有三种。一不共。二毕竟。三最初不共在前者。如三结。毕竟在前者。如贪恚痴及欲漏。最初在前者。如有漏无明漏。若烦恼是三界见道所断。应作见道在前二种句。如三结是也。若是欲界五种所断。应作修道在前二种句。如贪恚痴及欲漏是也。若是三界五种所断。应作见道在前三种句。如有漏无明漏是也。此说是略。毗婆沙五盖中。悔是修道断。疑若凡夫断。以修道断。世尊弟子断。以见道断。五上分结。是修道断。五爱身。是修道断。嫉结悭结。是修道断。九十八使。二十八是见道断。十是修道断。余若凡夫断。是修道断。世尊弟子断。是见道断。

问曰。如波伽罗那说九十八使。八十八是见道断。十是修道断。此中何故说二十八是见道断十是修道断耶答曰。此文是了义彼文是未了义。此文无余意彼文有余意。此文无所以彼文有所以。此文是实义谛。彼文是俗谛。复次波伽罗那。说顺次法。说具缚人。非超越人。此中不说顺次法。不说具缚人。不说超越人。复次彼中说凡夫圣人离欲圣道所作世俗道所作。此中说圣人离欲。不说凡夫。说圣道所作。不说世俗道。复次彼中说离欲界欲。乃至离无所有处欲。得正决定者。先以世俗道。断欲界烦恼。乃至无所有处。彼见道断烦恼解脱得差别作证。所以者何。彼解脱得。以见道故。而有差别。以是事故。彼作是说。八十八是见道断。十是修道断。是故尊者瞿沙。作如是说。二十八使是见道断。十是修道断。何故波伽罗那。作如是说。八十八是见道断。十是修道断。彼作是答。二十八决定是见道断。十是修道断。六十不定。不定者。于见道中。而有差别。波伽罗那说。次第故说八十八是见道断十是修道断。此门是广分别毗婆沙。问曰。何故名见道断。何故名修道断耶。如见不离修。修不离见。见道中如实修亦可得。修道中如实见亦可得。见名为慧。修名不放逸。如实是何义耶。答曰。数数义偏重义是如实义。见道中慧多不放逸少。修道中不放逸多慧少。复次等量义是如实义。如见道中慧亦有尔许不放逸。如修道中不放逸亦有尔许慧。是故等量义是如实义。尊者和须蜜说曰。见四真谛。断诸烦恼。云何分别此是见道断此是修道断耶。答曰。以见断。以见制伏。以见吐诸烦恼。故言见道断。复有说者。见道所断烦恼。亦应言修道所断。所以者何。见道中如实修可得故。如我义。以见断。以见制伏。以见吐诸烦恼。名见道断。何故名修道断。答曰。随所得道行广布。断诸生分。断其量。断其种。渐使薄。令究竟断故名修道断。复有作是说者。修道所断烦恼。亦可言见道断。所以者何。修道中亦有如实见故。如我义。随所得道。修行广布。断诸生分。断其量断其种渐使薄。令究竟断故名修道断。此是何义耶。答曰。见道是猛利道。若缘彼时九种烦恼一时断。修道是不猛利道。数数修习九种烦恼。九时而断。譬如利呋之刀以用割物利者一下断。钝者数数乃断。彼亦如是。复次若以见偏多道断者。名见道断。若以修偏多道断者。名修道断。复次若以二相道断者。名见道断。二相者。谓见相慧相。若以三相道断者。名修道断。三相者。谓见相慧相智相。复次若以四相道断者。名见道断。四相者谓眼明觉慧。若以五相道断者。名修道断。五相者。谓眼明觉慧智。复次若以忍断者是见道断。以智断者是修道断。复次九种结一时断者是见道断。九种结九时断者是修道断。复次以未知欲知根断者是见道断。以知根断者是修道断。复次断时如石裂者是见道断。断时如蕅绝者是修道断。复次与发意相违者是见道断。与方便相违者是修道断。复次未曾见谛。而见谛断者是见道断。已曾见谛。而重观断者是修道断。复次以一因道断者是见道断。以二因道断者是修道断。复次如力士着铠断者是见道断。如无足人行断者。是修道断。复次若断时。即彼智所知行修道者是见道断。若断时是余智余所知余行修是修道断。复次若是向人不成就果断者是见道断。若是向成就果断者是修道断。复次若坚信坚法断者。是见道断。若信解脱见到身证断者。是修道断。复次若初出道断者。是见道断。若数数出道断者。是修道断。复次若断是四沙门果摄者。是见道断。若断或三或二或一沙门果摄者。修道断。复次若缘无所有生者。是见道断。若缘有所有生者。是修道断。复次若断已不退者。是见道断。若断已或退不退者。是修道断。复次断已更不缚不系。是见道断。断已或缚或系。是修道断。复次若断时。忍是无碍道智。是解脱道者。是见道断。若断时智。是无碍道智。是解脱道者。是修道断。复次若断时。智作方便道。忍作无碍道。智作解脱道者。是见道断。欲若断时。智作方便无碍解脱道者。是修道断。复次若先得非数灭者。是见道断。或先得非数灭。后得数灭。或先得数灭。后得非数灭。或一时得数灭非数灭者。是修道断。复次若断时。缘一谛道修者。是见道断。若断时。缘四谛道修者是修道断。复次若断时。四行道修者。是见断。若断时。十六行道修者。是修道断。复次若断时。相似道修者。是见道断。若断时。相似不相似道修者。是修道断。复次若断时。若一三昧修者。是见道断。若断时。若三三昧修者。是修道断。复次若断时。不起者是见道断。若断时或起或不起者是修道断

此三结几见苦断。乃至几修道断。乃至九十八使。几见苦断。乃至几修道断。问曰。何故作此论。答曰。前门止说顿断沙门意。不止说一时见谛。亦不明次第见谛。今欲止一时见谛者意亦明次第见谛故。而作此论。复有说者。前门止说一时见谛者意。亦明次第见谛。而不粗现明了。今欲粗现明了。止一时见谛者意。亦明次第见谛故。而作此论。复次欲显现来种断烦恼及五种对治法故。五种断烦恼者。谓见苦断种。乃至修道断种。五种对治法者。谓苦忍苦智。是见苦断对治。乃至道忍道智。是见道断对治。智是修道断对治。以如是事故。而作此论。此三结。几见苦断。乃至广说。答曰。一见苦断。谓身见。问曰。何故身见唯见苦断耶。答曰。缘苦生故。还见苦断。复次此见缘果而生。若以慧观果时。此见即断

复次身见是颠倒性。一切颠倒。尽见苦断。若颠倒断时。此见即断。所以者何。同一对治故。复次此烦恼粗故。以初无碍道断。余细烦恼。后金刚喻定断。譬如尘垢不坚著者。抖捒便堕。若坚著者。乃以淳灰。多用力然后乃净。亦如瓦器。腻不深入。水荡便去。若腻深入。以汤煮之。然后乃去。彼亦如是。复次以此见根不深入所缘地。以不深入故性劣。性劣故最初无碍道断。余烦恼根。深入所缘地。以后无碍道乃至金刚喻定断。譬如树根。不深入者。小风吹时。而能摧卧。其根深入者。大风吹时。不能令卧。彼亦如是。尊者和须蜜说曰。何故身见唯见苦断。答曰。身见缘五阴。后如实见五阴时。身见便断。复次此见从常想乐想净想我想生。若见无常想苦想不净想无我想。此见便断。尊者佛陀提婆说曰。此见从自身生。故名身见。若见自身无我。此见便断。戒取或见苦断。或见道断问曰。何故戒取非见集见灭断耶。答曰。为外道故。外道所行。与苦道相违。不与集灭相违。所以者何。外道计集。如垢计灭。如洗浴处。为求洗浴处故。行种种苦行诸苦行故。烦恼垢益更染心。如人为去垢故。入浊水澡浴。更增其垢。彼亦如是。复次因苦生故。还见苦断。因道生故。还见道断。复次因垢生者。是见苦断。因净生者。是见道断。复次内道所行。是见苦断。外道所行。是见道断

复次非因计因。是见苦断。非道计道。是见道断。疑见苦集灭道断。问曰。何故修道断中无疑耶。答曰。若未见其体。心生犹豫。已见其体。心则决定。是故修道所断无有疑。三不善根三漏。见苦断。乃至修道断。总而言之。五种断。或有一种二种四种五种断者。余门广说如经本。此门是广说优波提舍毗婆沙。问曰。何故名见道断乃至名修道断耶。答曰。若缘决定。对治决定者。名见道断。若缘不决定。对治不决定者名修道断。复次若处所决定。若缘决定。若对治决定者。名见道断。若处所不决定。缘不决定。对治不决定者。名修道断。复次若以苦忍苦智作对治。乃至道忍道智作对治者。名见道断。若以智对治者。名修道断

复次若见苦断者。名见苦断。若见道断者。名见道断。若或见苦。或见集。或见灭。或见道断者。名修道断。复次若违苦者。名见苦断。乃至若违道者。名见道断。若违苦集灭道断者。名修道断

阿毗昙毗婆沙论卷第二十八阿毗昙毗婆沙论卷第二十九

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    使揵度不善品之五

此三结。几是见几非见。乃至九十八使。几是见几非见。问曰。何故作此论。答曰。或有说。一切烦恼皆是见性。问曰。彼何故作如是说耶。答曰。彼作是说。所行猛利。是见性。一切烦恼。名于自分。所行猛利。如身见着我我所。边见着断常。邪见着无所有见取着第一。戒取着净所行猛利爱。亦如是。于染着爱。所行猛利。恚憎恶。慢自高。痴愚痴犹豫。所行亦猛利。为断如是说者意亦明烦恼有是见性有非见性故。而作此论。此三结。几是见性几非见性。答曰二是见性。谓身见戒取。一非见性。谓疑。余门广说如经本。问曰。何故名见耶。答曰。此中应广说。如五见见处

此三结。几有觉有观。几无觉有观。几无觉无观。乃至九十八使。几有觉有观。几无觉有观。几无觉无观。问曰。何故作此论。答曰。或有说。觉观从欲界乃至有顶。如譬喻者说。彼何故作是说。彼依佛经。佛经中说。心粗是觉。心细是观。此粗细相。从欲界乃至有顶中可得。尊者佛陀提婆说曰。阿毗昙者。作如是说。心次第相。方而有粗细。遍三界中。然从欲界乃至梵世。有觉有观。如是说者。则名恶说。汝等作如是说。粗心是觉。细心是观。此粗心细心。乃至有顶可得。然说觉观从欲界乃至梵世中有。是故汝等所说是恶说。非善说。恶受持。非善受持。阿毗昙人。作如是说。我等所说。是善说。善受持。非恶受持。所以者何。我以种种事故。说粗细相。非以一事。如说缠粗使细。是中不说觉粗观细。所以者何。此二法。非觉观相故。如说色阴是粗。四阴是细。如是则说觉之与观俱是细法。所以者何。同行阴摄故。如说欲界是粗。初禅是细。如是亦说觉观是粗是细。所以者何。欲界初禅。俱有觉观故。如说。初禅地粗。二禅地细。如是则说觉观是粗。所以者何。初禅地上。更无觉观故。问曰。彼说初禅地上有觉观者。云何复说三地差别。答曰。彼作是说。欲界初禅。乃至非想非非想处。有三种法。谓善染污不隐没无记。禅中间乃至非想非非想处深染污法。是名有觉有观地。禅中间善不隐没无记法。是名无觉有观地。第二禅已上乃至非想非非想处。善法不隐没无记法。是名无觉。无观地。问曰。若然者。彼云何通佛经。如经说。灭于觉观。定生喜乐。入第二禅。彼作是答。灭善觉观。非染污。问曰。若然者。为因何事。灭善觉观。非染污耶。答应先灭染污。后离地时。乃灭于善。但譬喻者说上地有觉观。当知此说是无明果闇果不勤方便果。然觉观欲界初禅中有故。欲止他义。乃至广说。而作此论。此三结。几有觉有观。几无觉有观。几无觉无观。答曰。三结有三种。或有觉有观。或无觉有观。或无觉无观。云何有觉有观。答曰。在欲界初禅者。云何无觉有观。答曰。在禅中间者。云何无觉无观。答曰。在三禅及四无色者。余门广说如经本。问曰。何故名有觉有观。何故名无觉有观。何故名无觉无观耶。答曰。与觉俱观俱。与觉相应观相应。与觉观俱现在前。是名有觉有观。若不与觉俱。但与观俱。不与觉相应。与观相应。已灭觉与观俱现在前。是名无觉有观。若不与觉观俱。亦不与觉观相应。已灭觉观。是名无觉无观。复次若种种数。若种种观。是名有觉有观。若数观不种数。是名无觉有观。若不种数不种观。是名无觉无观

此三结。几乐根相应。几苦根相应。几喜根相应。几忧根相应。几舍根相应。乃至九十八使亦如是。问曰。何故作此论。答曰。或有说。法生时。次第生。不一时生。如譬喻者尊者佛陀提婆。作如是说法生时。次第生。不一时生。犹如多伴经过侠道。次第而行。不得一时。若欲二人并行。此犹为难。何况多人。如是一切有为法。各各从生相生。何缘众多生法共一时生。阿毗昙者。作如是说。有为法。自有一法和合而生。自有多法和合而生。一法和合生者。于一刹那顷生故。名一法和合生。多法和合生者。如一一数法。各有一生。虽多不相离。故名多法和合生。复次所以作论者。或有说。展转相因力义。是相应义。彼作是说。若法与彼法相因力生者。是相应义。如心因心力故生。心与心相应。数法因心力故生。数法与心相应。数法因数法力故生。数法与数法相应。心不因数法力生。故心不与数法相应。为止如是说者意亦明心与数法相应。数法亦与数法相应。数法与心相应。心不与心相应故。而作此论。复次所以作论者。或有说。自体与自体相应。不与他相应。彼作是说。等相敬义。是相应义。诸法相敬。莫过敬自体者。为止如是说者意亦明与他法相应义故。而作此论。复次所以作论者。或有说。自体于自体。不名相应。不名不相应。不名相应者。一切诸法。不能与自体作缘。不名不相应者。等相敬义。是相应义。所以者何。诸法相敬。莫过敬自体者。为止如是说者意亦明不乱相应法。是故为止他义欲显己义。乃至广说。此三结。几乐根相应。几苦根相应。几喜根相应。几忧根相应。几舍根相应。问曰。何故但问与受相应。不问与余数法耶。答曰。彼作经者意欲尔。乃至广说。复次受不妨成就。或妨现前行。云何不妨成就。如一人成就五受。云何妨现前行。无有二受一时现前行。复次以受一体有诸根相故。复次以受于缘起轮中。犹如车毂法故。复次以受受入一切法故。复次若不问受。更问何耶。若问命等八根。彼一向是不相应法。若问三无漏根。信等五根。彼一向是善。若作是说。何不问意根者。以意根故。名相应法。如以心故。名心相应法。身见戒取。与三根相应。除苦根忧根。所以除苦根者。苦根在五识地。此是意地所以不与忧根相应者。忧根是忧戚行。此是欣踊行。总而言之。与三根相应。此在三界。在欲界初禅二禅者。与二根相应。谓喜根舍根。在第三禅。与二根相应。谓乐根舍根。在第四禅及四无色。与一根相应。谓舍根。是故总而言之。与三根相应。除苦根忧根。疑与四根相应。除苦根。不与苦根相应者。以苦根在五识地。总而言之。与四根相应。疑在三界。在欲界者。与二根相应。谓忧根舍根。若在初禅二禅者。与二根相应。谓喜根舍根。在第三禅者。与二根相应。谓乐根舍根。在第四禅及四无色。与一根相应。谓舍根。是故总而言之。与四根相应。问曰。何故欲界疑。不与喜根相应。初禅二禅。则与相应。答曰。欲界疑喜所行各异故。疑所行非喜所行。喜所行非疑所行。所以者何。疑行忧戚。喜行欣踊。同义是相应义。彼不同故。不与相应。初禅二禅。俱行欣踊行故相应。复次欲界喜粗疑细。粗法不与细法相应。所以者何。等义是相应义故。问曰。喜有何粗义耶。答曰。众生不应起而起。于前物不应起而起。云何众生不应起而起。众生性是苦故。云何于前物不应起而起。见他人若颠若堕若谬误。应起慈愍。而更大笑。在初禅二禅者。俱微细故相应。复次欲界喜轻躁疑居重。轻躁不与居重相应。所以者何。等义是相应义。初禅二禅地。二俱居重。是故相应。复次欲界喜从外法生疑从内法生。从外生法。不与从内生法相应。所以者何。等义是相应义。初禅二禅。俱从内生。是故相应。复次欲界喜是客疑是旧住。客不与旧住相应。所以者何。等义是相应义。初禅二禅。俱是旧住。是故相应。复次欲界疑。虽不与喜根相应。与余受相应。初禅二禅喜。是地性受。若不与喜根相应者。此则名无受心聚。坏相依法。坏相应法。欲令无如是过故。欲界疑不与喜根相应。初禅二禅疑。与喜根相应。贪与三根相应。除苦根忧根。所以者何。贪行欣踊。忧苦行忧戚。恚与三根相应。除喜根乐根。所以者何。恚行忧戚。喜乐行欣踊。痴欲漏无明漏。与五根相应。所以者何。此三通六识身。所行欣踊。亦行忧戚故。有漏与三根相应。除苦根忧根。所以者何。色无色界。无忧苦故。色无色界。无忧苦义。根揵度中。当广说。除邪见。余门义如经本说。邪见与四根相应。除苦根。总而言之。邪见与四根相应。然邪见在三界在欲界者。与三根相应。除苦根乐根。在初禅二禅者。与二根相应。谓喜根舍根在第三禅者。与二根相应。谓乐根舍根。在第四禅及无色定。与一根相应。谓舍根。问曰。欲界邪见。何者与喜根相应。何者与忧根相应。答曰。有人本性。不好布施。不好祠祀。后若与邪见外道。共会一处。而闻是语无施无祠祀。无善恶业报。闻是语时。心生信乐。便生喜心。我所行善好。如是邪见。与喜根相应。有人性好行施祠祀。后若与邪见外道。共会一处。闻作是说。无施无祠祀。无善恶业报。闻是语时。心生信乐。便生忧心。我等所施。便为唐捐。所以者何。无果报故。如是邪见。与忧根相应。此门是广说优波提舍毗婆沙。问曰。何故名相应。相应义如杂揵度相应因中广说

此三结。几欲界系。几色界系。几无色界系。问曰。何故作此论。答曰。或有说。嫉悭在欲界梵世。彼何故作如是说。答曰。彼依佛经。佛经说。梵天王。语诸梵众。我等皆共住此。不往诣沙门瞿昙所。而于此处。自能至老死。彼作是说。梵王以嫉悭故。而作是言。为止如是说者意亦明嫉悭唯在欲界故。而作此论。三结。或欲界系。或色界系。或无色界系。此门义广说如经本。问曰。何故名欲界系。何故名色界系无色界系。答曰。缚欲界法故。名欲界系。缚色无色界法故。名色无色界系。如牛系着柱名柱系牛。彼亦如是。复次欲界足。为欲界法所系故。名欲界系。色无色界足。为色无色界法所系故。名色无色界系。足名烦恼。如偈说

  佛有无量行　　无足谁将去

如人有足。则得自在四方游行。如是有烦恼足者。则能行于诸趣诸生生死中。复次烦恼于欲界作居处想我有想故。名欲界系。色无色界烦恼。于色无色界。作居处想我有想故。名色无色界系。居处是爱。我有是见。以欲界爱润故。见计我我所。以色无色界爱润故。见计我我所。复次能生欲界乐欲故。名欲界系。能生色无色界乐欲故。名色无色界系。乐是爱。欲是见。复次为欲界生死法所系故。名欲界系。为色无色界生死法所系故。名色无色界系。复次为欲界垢所污毒所害患所过故。名欲界系。为色无色界垢所污毒所害患所过故。名色无色界系

诸结是欲界。彼结在欲界耶。是有六种。一界是。二趣是。三人是。四入是。五漏是。六自身是。界是者。如此中说。诸结是欲界。彼结在欲界耶。此中说。法处名是。欲界法。名欲界是。色无色界法。名色无色界是。趣是者。如说。法法施时。而作是言。一切是五趣众。尽生死苦。人是者。如毗尼说。是二人。在僧数中。僧中可得。入是者。如波伽罗那说。云何色阴。十色入。及法入中色是。漏是者。如说。云何漏有漏法是。身是者如四大揵度说。云何大法。答曰。自身是。于六是中。以界是。而作论。不以余是。在有四种。一自体在。二器在。三所行在。四处所在。自体在者。一切诸法。自体自相自性。在自分中。器在者。如果在器中。如提婆达多在舍中。如器在。所行在处所在义亦尔。此中以四在而作论。随相而说。诸结是欲界。彼结在欲界耶。答曰。或结是欲界。彼结不在欲界。或结在欲界。彼结不是欲界。或结是欲界。彼结亦在欲界。或结不是欲界。彼结不在欲界。云何结是欲界彼结不在欲界耶。答曰。为缠所缠。魔波旬。住梵天上。欲与如来语言。问曰。魔波旬。为何缠所缠。欲与如来语言耶。答曰。为忿缠所覆故。欲与如来语言。复有说者。为嫉缠所覆故。欲与如来语言。复有说者。为悭缠所覆故。欲与如来语言。评曰。应作是说。为十缠所覆。起一一缠现在前。欲与如来语言。问曰。何故名魔。答曰。断慧命故名魔(魔秦言杀)。复次常行放逸。而害自身故名魔。何故名波旬。答曰。常有恶意。成就恶法。成就恶慧。故名波旬(波旬秦言恶)。尊者瞿沙说曰。应言波旬踰。所以者何。从波旬踰。生彼中故(波旬秦言恶踰名国)。住梵天上。欲与如来语言。问曰。魔王住梵天上。何所为耶。答曰。梵天诸魔经。是此论本缘。曾闻佛住舍卫国给孤独精舍只陀林中。尔时有一梵天。于梵天上。生如是恶见。而作是言。此处是常不断弃出寂灭之法。更无有常不断弃出寂灭之法胜此处者。尔时世尊。知彼梵天心之所念。譬如壮夫屈申臂顷。从只陀林。忽然不现。至梵天上。去梵天不远。而住其边。尔时梵天。遥见如来。即便请之。而白佛言。善来大仙。此处是常不断弃出寂灭。更无有常胜此处者。而汝能舍欲界烦恼乱种种苦事。而来此间。甚是快事。汝可于此安乐常住。尔时如来。告梵天言。此处非常。而汝说常。此处非是安乐寂静弃出之处。而汝说是安乐寂静弃出之处。汝为无明所覆故。作如是说。汝应忆念过去诸梵堕欲界者。如华果落。尔时梵天。复白佛言。善来大仙。此处常乐。广说如上。第二第三。亦如是说。尔时如来。亦第二第三。告梵天言。此处无常。乃至广说。无明覆。汝应忆念过去诸梵堕欲界者如华果落尔时梵天。心作是念。今者如来。难可亲近。难共语论。然诸梵法。在离欲地。志意闲静。不能与佛竞于言论。复作是念。魔王波旬。常与如来共相违逆。必能与佛竞于言论。是时梵王。即致波旬。到梵天上。化作欲界地。而以安止。尔时梵天。复白佛言。大仙当知。此处是常。乃至更无胜者。尔时如来。复告梵王。此处无常。广说如上。尔时波旬。白佛言。大仙汝莫违逆梵王所说。随其教敕。常奉行之。汝若违逆梵王言者。犹如有人。功德天神。来入其舍。以杖驱之。我不须汝。汝若违逆梵王之言。亦复如是。亦如有人。从高转堕。若其不以手足自御。复当更堕。如人堕树。不坚执枝。则受苦痛。若坚执枝。不受苦痛。如是大仙。汝莫违逆梵王之言。如其所说。当奉行之。复白佛言。大仙今者不见梵众及与我等围绕梵王。随顺梵王不违其言耶。尔时世尊便作是念。今者恶魔。来留难我。知是事已。即告魔言汝非梵王亦非梵王眷属。所言恶魔留难我者。汝身是也。尔时波旬便作是念。沙门瞿昙。今者已知我心所念。心怀恐怖。生厌离意。在一面坐而不能还。尔时梵王。以神足力。能令波旬还自在宫。是故彼经。即是此论本缘亦为缠所缠。色界命终。生欲界中阴。凡夫人。色界命终。当生欲界。欲界中阴。在色界中而现在前。所以者何。法应如是死阴灭处。即生中阴。犹如种子灭处必生萌牙。彼亦如是。从死阴至中阴时。欲界三十六使。若一现在前。令生相续。是名结是欲界彼结不在欲界。此中是者是界是。在者除自体在。是余三在。云何结在欲界彼结不是欲界。为缠所缠。欲界命终。生色界中阴。凡夫圣人。欲界命终。生色界中。色界中阴。在欲界中。所以者何。法应如是。死阴灭处。即生中阴。犹种子灭处即生萌牙。彼亦如是。凡夫人从死阴至中阴时。色界三十一使。若一现在前。令生相续。圣人从死阴至中阴时。色界修道所断三使。若一现在前。令生相续。亦结是色无色界住欲界现在前。住欲界不死不命终。色无色界结现在前。凡夫三十一使。若一现在前。圣人修道所断三使。若一现在前。如是等说因爱行禅者。因慢行禅者。因见行禅者。因疑行禅者。是名结在欲界彼结不是欲界。在者是三在。是者是界是。云何结是欲界亦在欲界。为缠所缠。凡夫圣人。欲界命终。还生欲界中阴。凡夫人。生五趣无碍。圣人生二趣无碍。若生天中。若生人中。凡夫人。从死阴至中阴时。三十六使。若一现在前。令生相续。圣人从死阴至中阴时。欲界修道所断四使。若一现在前。令生相续。如从死阴至中阴。从中阴至生阴。说亦如是。亦结是欲界。住欲界现在前。住欲界不死不命终。起欲界结现在前。凡夫人。三十六使。若一现在前。圣人欲界修道所断四使。若一现在前。是名结是欲界亦在欲界。此中是者是界是。在者是四在。云何结不是欲界亦不在欲界。为缠所缠。色界命终。生色界中阴生阴中。色界命终生色界中者。是凡夫圣人。凡夫人亦生上亦生下。一一处有多生分。圣人生上不生下。一一处有一生分。凡夫人从死阴至中阴时。三十一使。若一现在前。令生相续。圣人修道所断三使。若一现在前。令生相续。从中阴至生阴。说亦如是。色界命终。生无色界中。亦是凡夫圣人。凡夫人一一处有多生分。圣人一一处有一生分。凡夫人。从死阴至生阴时。无色界三十一使若一现在前。令生相续。圣人三使。无色界命终。还生无色界。亦是凡夫圣人。凡夫人。亦生上。亦生下。一一处有多生分。圣人生上不生下。一一处有一生分。凡夫人。从死阴至生阴时。三十一使。若一现在前。令生相续。圣人三使。凡夫人。无色界命终。生色界中。从死阴至中阴时。色界三十一使。若一现在前。令生相续。亦结是。色无色界。住色界现在前。住色界不死不命终。亦是凡夫圣人。凡夫人。三十一使现在前。圣人三使现在前。如是等说因爱行禅者。因慢行禅者。因见行禅者。因疑行禅者。住无色界。不死不命终。起无色界三十一使现在前。亦是凡夫圣人。凡夫人起三十一使现在前。圣人三使。是名结不是欲界亦不在欲界。所以者何。在色无色界故。是者是界是。在者是四在。诸结是色界亦在色界耶。乃至广作四句。前四句初句。作此第二句。前第二句。作此初句。前第三句。作此第四句。前第四句。作此第三句。诸结是无色界。亦在无色界耶。答曰。诸结在无色界。彼结亦是无色界。所以者何。无色界唯有无色界系结故。颇有结是无色界不在无色界耶。答曰有。是无色界结。住欲色界现在前。不死不命终无色界结现在前。亦是凡夫圣人。凡夫人起无色界三十一使现在前。圣人三使。如是等因爱因慢因见因疑行禅者。是名结是。无色界是者。是界是不在无色界。所以者何。在欲色界故。在者除自体在。是余三在。诸结非是欲界亦非在欲界耶。乃至广作四句。前四句初句。作此第二句。前第二句。作此初句。前第三句。作此第四句。前第四句。作此第三句。诸结非是色界。彼结亦非在色界耶。乃至广作四句。如欲界说。诸结非是无色界。彼结亦非在无色界耶。答曰。诸结非是无色界。彼结亦非在无色界。颇结非在无色界。彼结非不是无色界耶。答曰有。诸结非不是无色界。住欲色界现在前。住欲色界不死不命终。起无色界结现在前。亦是凡夫。亦是圣人。凡夫人。起三十一使现在前。圣人三使。此结非在无色界中。所以者何。在欲色界故在者三在。除自体在。非不是无色界。所以者何。是无色界结故。是者是界是。问曰。何故彼尊者立非句而作论耶。答曰。彼作经者意欲尔。乃至广说。复次欲现言论自在故。若人于言论自在。则能以非句而作论。于言论不自在者。于正句犹不能作。何况非句耶。复次欲生弟子觉意故。若以非句作论。则生弟子觉意说法相此亦可尔。彼亦可尔。复次或有作非句而得长养者。如人品中作正句。彼人有四。彼人有三。彼人有二作非句。彼人有五。彼人有六。彼人有四。以是事故。彼尊者以非句而作论。见谛具足。世尊弟子。若色不断。为色所系耶。设为色所系色不断耶。乃至识亦如是。问曰。何故作此论。答曰。或有说。断色有次第断分齐断段段断。如外国法师作是说。如染污心心数法。九种断色亦如是。为断如是说者意故。亦明染污心心数法九种断色善有漏不隐没无记心心数法。于最后无碍道一时断故。而作此论。问曰。何故染污心心数法九种断色善有漏不隐没无记心心数法。最后无碍道一时断耶。答曰。以明无明常相妨。下下明断上上无明。下中断上中。下上断上下。中下断中上。中中断中中。中上断中下。上下断下上。上中断下中。上上断下下。色善有漏不隐没无记法。不妨明。不妨无明。但为明无明作所依处立足处。如灯明不与炷油器相妨与闇相妨。但炷油器。为灯明作所依处立足处。如是色善有漏不隐没无记法。不与明无明相妨。而与明无明作所依处立足处。复次染污心心数法。随几种断。不成就彼种。色是染污者。住方便道时。即不成就。最后无碍道。断色是善不隐没无记者及余善有漏不隐没无记有为法。悉于最后无碍道。一时断此诸法。虽已知已断。离三界欲犹故成就。是故为止他义欲显己义。乃至广说。而作此论。见谛具足。世尊弟子。色爱未断。乃至广说。问曰。为避何事。说见谛具足。为制何事。说世尊弟子。答曰。见谛具足。为避坚信坚法人。世尊弟子。为制愚小凡夫。问曰。何故坚信坚法人。不名见谛具足耶。答曰。若具足见四真谛。永断邪见。是名见谛具足。坚信坚法人。见谛未具足。而当具足。未永断邪见。而当永断。复次若身中无四种无明愚闇。有四种智。名见谛具足坚信坚法人。未舍四种无明愚闇。未具四种智故。复次若裂四种犹豫疑网。生四种决定者。是见谛具足坚信坚法人。未裂四种犹豫疑网。亦未具足四种决定故。复次若身中无如霜雹烦恼邪见颠倒及诸恶行者。名见谛具足坚信坚法人。无是事故。不名见谛具足。犹如苗稼无诸霜雹名为具足。彼亦如是。复次若能降伏四谛方土。是名见谛具足坚信坚法。未能降伏四谛方土故。名不具足。问曰。何故凡夫不名世尊弟子耶。答曰。若闻佛所说。于四谛三宝。心无有异。凡夫不尔。或信佛语。或信外道语。复次若不事余天。唯事于佛。是名世尊弟子。凡夫人。或事于佛。或事自在天等。复次若于佛有不坏信。是名世尊弟子。凡夫人。无于佛不坏信故。不名世尊弟子。复次若于佛法。心不移动。犹如门阃者。是名世尊弟子。凡夫轻躁。犹如树花。复次若有所闻不为邪闻所坏。是名世尊弟子。凡夫若有所闻。则为邪闻所坏。问曰。此中谁是见谛具足世尊弟子耶。答曰。须陀洹。斯陀含。阿那含。阿罗汉。见谛具足世尊弟子。若色不断。为色所系。色若断即时解脱。若解脱。即时断。若先断后得解脱。无有是事。染污心心数法。或有先断后得解脱者。或有俱断亦解脱者。染污心有九种。下下乃至上上。前八种先断后得解脱。后一种亦断亦得解脱。若上上断余八种有缘缚。乃至第八种断下下种缘缚八种。所以者何。尽是一使展转相使故。如是等说。是略毗婆沙。见谛具足世尊弟子。若色未断。为色所系耶。答曰。如是。设为色所系。色不断耶。答曰。如是。所以者何。先作是说。色若断即时解脱。若解脱即时断。若先断后解脱者。无有是事。须陀洹。斯陀含。五地色不断。为色所系。未离初禅欲。阿那含四地色不断。为色所系。乃至离第三禅欲。阿那含未离第四禅欲。一地色不断。为色所系。见谛具足世尊弟子。若受不断。为受所系耶。答曰。若为受所系。彼受不断。须陀洹。斯陀含。三界修道所断。受不断。为受所系。未离初禅欲。阿那含八地。受不断。为受所系。乃至离无所有处欲。阿那含一地。受不断。为受所系。颇为受所系。彼受非不断耶。答曰。有。家家斯陀含一种子。彼欲界修道所断上中结。彼结相应受。为下下结所缚。家家若断三种。若断四种。如彼结断。彼相应受亦断。彼相应受。为若五若六种结所缚。斯陀含已断六种结。如彼结断。相应受亦断。彼相应受。为三种结所缚。一种子若断七种八种结。如彼结断。彼相应受亦断。彼相应受为一种。若二种结所缚。如受想行识说亦如是。见谛具足世尊弟子。若色已断。彼色不系耶。答曰。如是。若色不系。彼色断耶。答曰。如是所以者何。先作是说。若色断即时解脱。若色解脱即时断。若先断后解脱。无有是事。离色爱圣人。断五地色。彼色不系离三禅欲。未离第四禅欲。阿那含四地色断。彼色不系。乃至未离初禅欲。阿那含一地色断彼色不系。见谛具足世尊弟子。若受已断。彼受不系耶。答曰。若受不系。彼受已断。阿罗汉三界见道修道所断受。已断不系。离无所有处欲。阿那含三界见道所断八地修道所断受。断亦不系。乃至未离初禅欲。阿那含三界见道所断一地修道所断受。断亦不系。须陀洹斯陀含三界见道所断受。断亦不系。颇有断非不系耶。答曰。有。家家斯陀含一种子欲界系修道所断上中结断。彼所断结相应受。为下结所系。家家若断三种。若断四种结。如彼结断。受亦断彼相应受。若为五种若六种结所系。斯陀含断六种结如彼结断。受亦断彼相应受。为三种结所系。一种子。若断七种。若八种结。如彼结断。受亦断彼相应受。若为一种。若二种结所系。如受想行识说亦如是。问曰。家家须陀洹所不摄须陀洹。断上上中结者为下。若七若八种结所系。此中何以不说耶。答曰。应说而不说者。当知此说有余。复次此是坏相不定故不说。若是不坏是定相者。此中则说。问曰。如色无色界结亦可尔。如离初禅上上结为八种结所系。乃至八种结断。为一种结所系。乃至非想非非想处结断亦如是。何以但说欲界结。不说色无色界耶。答曰。应说而不说者。当知此说有余。复次此现初义。若说欲界。当知说色无色界亦尔。复次以欲界结断时生种种人名。若断三种四种。名家家。若断六种。名斯陀含。若断七八。名一种子。离色无色结更无如是异人名故。是以不说。问曰。下结断亦可尔。如下上烦恼断。为下中下下结所缚。若下上下中结断。为下下结所缚。何以但说上中。不说下耶。答曰。应说而不说者。当知此说有余。如上上结断。为下八种结所缚若断二种。为七种所缚。如是一一种断。皆为下所缚。但不能一一作文。是故略说。家家是须陀洹差别。一种子是斯陀含差别家家者。若在二家。若在三家。二家者。断四种结。余有二有种子。三家者。断三种结。余有三有种子。家家无有断五种结者。所以者何。若能断五种。必断第六种。得斯陀含果。所以者何。第六种结。性羸劣不能障碍留难斯陀含果。犹如一綖不能制象。彼亦如是。一种子断。若七若八种结。余有一种子。问曰。余有二种结在。何以言一有种子耶。答曰。不以一种结在名一种子。以有一有种子故。名一种子。复有说者。无有尽八种结一种子者。所以者何。若断八种结。必得离欲界九种结。不能障碍留难离欲法故。复有说者。有断八种结一种子者。无有说断五种家家须陀洹。所以者何。若断五种。必断六种。得斯陀含。第六种结。性羸劣不能障碍留难斯陀含果。问曰。第九种结亦性羸劣。不能障碍留难。若一种子。能断第八种者。亦能断第九种。而得离欲。答曰。家家须陀洹。若断六种结。犹在欲界中生所有决定已熟业。应于欲界而受报者。不能障碍留难斯陀含果。一种子断九种结。更无欲界生分所有决定已熟业。应于欲界而受报者。能障碍留难。不得离欲。作如是说者。众生有三时烦恼业。能极障碍留难。一顶向忍时。二圣人离欲界欲时。三得阿罗汉果时。顶向忍时者。诸恶趣决定业。极为障碍留难。若起忍者。我等于谁身中。而受报耶。圣人离欲界欲时者。欲界决定诸业。应受报者。极作障碍留难。若离欲者。我等于谁身中。而受报耶。得阿罗汉果时。决定应受未来有业。极作障碍留难。若得阿罗汉果。我等于谁身中。而受报耶。是故有断八种结。是一种子者。无有断五种。是家家须陀洹。家家有二种。有人中家家。天中家家。天中家家者。天上。若二生若三生。若一天中。若二天中。若三天中。或一天中。一家二家三家。人中家家者。若二生三生分或一天下。或二天下。或三天下。若一天下。或一家二家三家中。生一种子。天中一种子者。天中有一生分。人中一种子者。人中有一生分。以三事故名家家。一以业。二以根。三以断结。以业者。或造二生业报。或造三生业报。以根者。得无漏根故。断结者。若断三种。若断四种结。于此三事。不具一事。不名家家以三事故。名一种子。一以业。二以根。三以断结。以业者。造一生业报以根者。得无漏根故。断结者。若断七种。若断八种结。于此三事。不具者不名一种子。问曰。圣人住欲界受身造业不耶。答曰。或有说者不造。所以者何。以欲界多过患故。虽不作受身造业。而作受身满业。问曰。若圣人不作欲界受身造业者。此云何通如说。尔时世尊。赞说弥勒成佛时事会中有未离欲学人。闻说是已。皆共立愿。使我闻见此好妙事已。然后乃般涅槃。答曰。此须臾时。于所须物。无所乏少。不为苦痛所逼。而有所愿求。若为苦痛所逼。于一切生处。更无愿求我若能如鸟飞于空者。即于今日。而般涅槃。若作是说。圣人不作欲界受身造业者。彼作是说。彼家家。若二生三生造业。于凡夫时造。若断三种四种结。或凡夫时断。或圣人时断一种子。有一生分业。亦凡夫时造。彼若断七种八种结。或凡夫时断。或圣人时断。复有说者。圣人住欲界受身处造业。圣人所造者。清净妙好。无诸苦患。随顺善法。若作是说。圣人住欲界身受身处造业者。家家须陀洹。造二生若三生。必受报业。此业或凡夫时造。或圣人时造。断若三。若四种结。或凡夫时断。或圣人时断。一种子造一生。必受报业。此业或凡夫时造。或圣人时造。断若七若八种结。或凡夫时断。或圣人时断。问曰。若人中得须陀洹斯陀含果。命终已生欲界天中。得阿那含果。彼命终已。为生色无色界中不耶。若生者。增一经说云何通。如说。有五人。此间种子。此间毕竟。五人者。一受七有人。二家家人。三斯陀含人。四一种子人。五现法般涅槃人。此间种子者。此间得正决定。此间毕竟者。此间尽漏。复有五人。此间种子。彼间毕竟。一中般涅槃。二生般涅槃。三有行般涅槃。四无行般涅槃。五上流般涅槃。此间种子者。此间得正决定。彼间毕竟者。彼间得尽漏。若不生者。帝释所问经云何通。如偈说

  若知于此法　　俱生梵世中
  于诸梵中胜　　威德最在前

即此经说。复云何通。如帝释白佛言。世尊如我所行正行。若有为我重解说者。我当胜进得阿罗汉果。能尽苦际。我所行正行。若无有人为我说者。我必生彼妙色摩[少/兔]摩天中。诸根具足。无有缺减。亦不卑陋。有清净色。以爱乐为食。身出光明。飞行虚空。寿命长远。于此命终。当生如是天中。答曰。或有说者。如此圣人不生色无色界中。问曰。若然者。增一经善通。如说。有五种人。此间种子。此间毕竟。帝释所问经云何通。如偈说。若知于此法。乃至广说。答曰。此所说者。不说死。亦不说生。何以知之。曾闻。释女瞿夷。有三比丘。常入其舍。以清净音声。为其呗唱。亦数数为说法要。尔时瞿夷。以闻法故。心生欣乐。厌患女身。愿男子身。命终之后。生三十三天。为帝释子。时彼诸天。即为立字称。瞿夷天子时三比丘。以自爱音声故。生于下处揵闼婆中。揵闼婆。是诸天作乐神也。朝夕常为诸天作乐。尔时瞿夷天子。见便识之。而语之言。我因汝等。生信乐心。厌患女身。成男子身。命终之后。今得生此为帝释子。汝等净修无上梵行。何缘生卑下揵闼婆中。时揵闼婆。闻天子言。心生厌离。得离欲爱。二以神足力。往梵天中。一犹住此。以是事故。知其不死。亦复不生。复有说者。彼二此间死生彼中。本于人中。得达分善根。闻瞿夷天子所言。心生厌患。得正决定。后离欲爱。得阿那含果。命终之后。生梵世中。虽死虽生。非本人中得须陀洹斯陀含者。问曰。若然者。帝释所问经第二说云何通。如说。我所行正行。乃至广说。答曰。帝释虽当得道果。以不知阿毗昙相义故。作如是说。问曰。即于佛前。而作是说。佛何以不呵之耶。答曰。佛知此说。不能障道。后入法时。自当知之。复有说者。如此圣人生色无色界。问曰。若然者。帝释所说经善通。增一经云何通。答曰。圣人不定。或有转行。有不转行。若转行者。如帝释问经说。不转行者。如增一经说。是则二经俱通。评曰。如此圣人不生色无色界。所以者何。圣人易世。必有三事。一不退。二不转根。三不生色无色界。所以者何。圣道于彼身中。以是旧住故

阿毗昙毗婆沙论卷第二十九阿毗昙毗婆沙论卷第三十

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    使揵度不善品之六

五人。坚信。坚法。信解脱。见到。身证。坚信人。于此三结。几成就几不成就。乃至九十八使。几成就几不成就。乃至身证。于此三结。几成就几不成就。乃至九十八使。几成就几不成就。问曰。何故彼尊者。于使揵度中。因五人而作论。智定揵度中。因七人而作论耶。答曰。彼作经者意欲尔。乃至广说。复次此使揵度。因有使人而作论。智定揵度。因有使无使人。但有智定者。而作论。有结说亦如是。复次彼尊者。以人为章。以烦恼为门。慧解脱俱解脱人无结故。不立门。智定揵度。以人为章。以智定为门。慧解脱俱解脱人。有智定故。而立门。以是事故。彼尊者于使揵度中。因五人而作论。智定揵度中。因七人而作论。七人。坚信。坚法。信解脱。见到。身证。慧解脱。俱解脱。云何坚信人。犹如有一。多敬多信多净多爱多随所闻而解了。不好多思不多量不多察不多选择。如好信乃至多随所闻而解了故。若闻佛及佛弟子说法教授为说苦空无常无我。彼作是念。能为我说苦空无常无我。甚是快事。我应修行苦空无常无我。彼修行苦空无常无我时。能生世第一法。次生苦法忍。知欲界诸行是苦空无常无我。乃至未生道比智。是名坚信人。坚信人。或是证须陀洹果向。或是证斯陀含果向。或是证阿那含果向。若是具缚。若断五种结。得正决定。在见道十五心顷。是证须陀洹果向人。若断六种结。乃至断八种结。得正决定。在见道十五心顷。是证斯陀含果向人。离欲界欲。乃至离无所有处欲。得正决定。在见道十五心顷。是证阿那含果向人。云何坚法人。犹如有一性。好多思多量多察多选择。不好多信。乃至不好随所闻而解了。以性好多思乃至多选择故。若闻佛及佛弟子说法教授。乃至广说。如坚信人。是名坚法人。云何信解脱人即彼坚信人。得道比智。舍坚信名。得信解脱名。问曰。为舍何等耶。答曰。舍名得名。舍道得道。舍名者。舍坚信名。得名者。得信解脱名。舍道者。舍见道。得道者。得修道。信解脱人。或是须陀洹。或是斯陀含向。或是斯陀含。或是阿那含向。或是阿那含。或是阿罗汉向。住须陀洹果。更不胜进。名须陀洹。若胜进。名斯陀含向。住斯陀含果。不胜进。名斯陀含果。若胜进名阿那含果向。若住阿那含果。不胜进。名阿那含。若胜进。名阿罗汉果向。云何见到人。坚法人。得道比智。舍坚法名。得见到名。问曰。为舍何等。得何等耶。答曰。舍名得名。舍道得道。乃至广说。如信解脱人云何身证人。答曰。若人以身证八解脱。非以慧尽余漏。是名身证人。云何慧解脱人。若人不以身证八解脱。以慧断余漏。是名慧解脱人。云何俱解脱人。答曰。若人以身证八解脱。以慧尽余漏。是名俱解脱人。问曰。何以名俱解脱耶。答曰。烦恼障是一分解脱障。是一分断。此二障名俱解脱。问曰。若得阿罗汉。后得灭尽定。离于解脱障时。有漏心得解脱耶。无漏心得解脱耶。答曰。或有说者。有漏心得解脱。所以者何。无心定时得解脱。评曰。应作是说。有漏无漏心得解脱。所以者何。身得解脱。世得解脱。若不得灭定时。出定入定心。于彼身不行。若于彼身不行。于世亦不行。若得灭定时。入定出定心。则于身中行。以于身中行故。于世亦行。如说俱解脱人义。余人义亦应说。问曰。何故名坚信人。答曰。此人依信生信。依有漏信。生无漏信。依缚信。生解脱信。依系信。生不系信。如是等人。本性多信。若一语言。男子汝应田作可以自活。彼闻是语。而不思惟应作不应作能作不能作有宜便无宜便。闻已便作。若复语言。男子汝应商估学习兵法亲近王者学书算数以此业自活。彼不思惟应作不应作能作不能作有宜便无宜便。闻已便作。若复语言。男子汝应出家。彼不思惟我应出家不应出家为有宜便为无宜便为能守护梵行为不能守护梵行。闻是语已。即便出家。既出家已。若复语言。比丘汝应劝化。彼不思惟我于劝化有力耶无力耶。能办不能办耶。闻已便作。若复语言。比丘汝应学诵习。彼不思惟我为能办诵习为不能办耶。为当诵习修多罗毗尼阿毗昙耶。闻已诵习。若复语言。比丘汝应住阿练若处习阿练若法亦不思惟能与不能闻已便作。以是因缘。转近圣道。彼于后时。生世第一法。次生苦法忍。乃至未得道比智。于见道十五心顷。是名坚信人。问曰。何故名坚法人。答曰。此人因法生法。因世法。生出世法。因有漏法。生无漏法。因缚法。生不缚法。如是等人。本性好思量。若有人语言。男子汝应田作可以自活。彼便思量。我能不能为有宜便为无宜便。广说如坚信人。皆悉思量。以是因缘。转近圣道。彼于后时。生世第一法。次生苦法忍。乃至未生道比智。于见道十五心顷。是名坚法人。问曰。坚信人。有尔许信。亦有尔许慧。坚法人。有尔许慧。亦有尔许信。何故一名坚信。一名坚法耶。答曰。或信他言入圣道。或有内自思惟入圣道。若信他言入圣道者。名坚信。若内自思惟入圣道者。名坚法。复次或有以定入圣道。或有以慧入圣道。若以定入圣道者。名坚信。若以慧入圣道者。名坚法。如以定以慧。定多慧多。乐定乐慧。钝根利根。从他闻法力。依内思惟力。亲近善知识。闻于正法。内自思惟。如法修行。先以定修心。后得慧解脱。先以慧修心。后得定解脱。或有得内心定不得慧。或有得慧不得内心定。无贪偏多。无痴偏多。说亦如是。问曰。何故名信解脱。答曰。以信观信。从信得信。以信观信者。以见道信。观修道信。从信得信者。从向道信。得果道信。是名信解脱。复次此人以信故。于三结心得解脱。是名信解脱。何故名见到。答曰。此人以见到见。以见道见。到修道见。以向道所摄见。到果道所摄见。复次此人以见故。于三结心得解脱。是名见到。问曰。如信解脱。亦可言信到。如见到亦可言见解脱。何故一说信解脱。一说见到耶。答曰。应说如说信解脱。亦应说信到。如说见到。亦应说见解脱。而不说者。有何意耶。答曰。欲现种种文故。乃至广说。何故名身证。答曰。若信解脱。若见到得灭定。舍信信解脱见到名。得身证名。为舍何等得何等。外国法师。作如是说。舍名得名。舍道得道。舍名者。舍信解脱见到名得名者。得身证名。舍道者。舍信解脱见到道。得道者。得身证道。罽宾沙门。作如是说。舍名得名者。舍信解脱见到名。得身证名。若不得灭定得阿罗汉果。名慧解脱。若得灭定。得阿罗汉果。名俱解脱。问曰。如见道中有二人坚信坚法。修道中有二人信解脱见到。何故无学道中。唯说一人耶。答曰。或有以世俗道。离欲界欲乃至离无所有处欲。或以无漏道。若离非想非非想处欲时。合为一道故。唯说一人。复次或有偏行贪者。或有不者。若离非想非非想处欲时。身中无贪。同一相故。唯说一人。复次或有偏行痴者。或有不者。若离非想非非想处欲时。身中无痴。同一相故。唯说一人。偏行慢者。说亦如是。复次解脱等故。如说。如来等正觉所得解脱漏尽。阿罗汉比丘所得解脱。此二解脱。等无差别复次以俱除三界烦恼螺髻故。俱不欲未来有。俱出最后开要故。复有说者。无学地亦说二种人。一时解脱。二不时解脱。问曰。若然者。圣人则有六。见道有二坚信坚法。修道有二信解脱见到。无学道有二时解脱不时解脱。云何施设有七人耶。答曰。以五事故。施设七人。一以方便。二以根。三以定。四以解脱。五以定以解脱。以方便者。是坚信坚法。以根者。是信解脱见到。以定者。是身证。以解脱者。是慧解脱。以定以解脱者。是俱解脱。应说一坚信人。如七人中。一人以根故应说三坚信人。谓上中下根。以性故应说五坚信人。谓退法乃至必胜进。以道故应说十五坚信人。谓苦法忍。乃至道比忍。以离欲故。应说七十三坚信人。欲界有具缚人。有离一种欲。乃至离九种欲。初禅离九种欲。无具缚人。所以者何。离欲界欲。即是初禅具缚乃至离无所有处一种欲。乃至离九种欲。所依身者。阎浮提有七十三。瞿陀尼有七十三。弗婆提有七十三。四天王乃至他化自在天。各有七十三若在一一身一一刹那。则有无量无边坚信人。此中总说一坚信人。坚法人说亦如是。唯除以性故者。所以者何。彼是不动性故。应说一种信解脱人。如七人中。一人以根故。应说三。以性故应说五。以离欲故应说八十二。欲界具缚。离一种欲。乃至离九种欲。乃至离无所有处欲亦如是。离非想非非想处一种欲。乃至离八种欲。及断第九种欲时。所依身者。欲界有八十二。初禅有七十三。第二禅有六十四。第三禅有五十五。第四禅有四十六。空处有三十七。识处有二十八。无所有处有十九非想非非想处有十具缚。断八种欲。及断第九种欲时。若以在身。以刹那。则有无量无边信解脱。此中总说一信解脱人。如信解脱。见到说亦如是。唯除以性故者。所以者何。彼是不动性故。应说一身证人。如七人中。一人以根故应说三。以性故应说六以离欲故应说十。非想非非想处具缚。离一种欲。乃至离八种欲。及断第九种欲时。所依身者。欲界有九。色界有九。无色界有九。若以在身。以刹那。则有无量无边。此中总说一身证人。应说一慧解脱人。如七人中。一人以根故应说三。以性故应说六。所依身者。有三依欲界身。色界身无色界身。若以在身。以刹那。则有无量无边。此中总说一慧解脱人。俱解脱亦如是。坚信人。于此三结几成就几不成就。先作是说。彼尊者以人为章。以烦恼为门。今欲以烦恼门明人。坚信人。苦比智未生。于此三结。一切成就若生二成就。谓戒取疑。一不成就。谓身见。余广说如经本。乃至离色爱。灭比智。生欲色界。一切不成就及无色界苦集灭所断。一切不成就。余者成就问曰。何故不说道比智耶。答曰。道比智若生。名信解脱。如坚信。坚法亦如是。所以者何。此二。地等。道等。离欲等。所依身等。定等。生处等。唯根有差别。若钝根者名坚信。利根者名坚法。信解脱人。于此三结。一切不成就。广说如经本。如信解脱。见到亦如是。所以者何。此二。地等。道等。离欲等。所依身等。定等。生处等。唯根有差别。若钝根者名信解脱。若利根者名见到。身证人。于此三结。一切不成就。余广说如经本。此中应作论。颇有圣人成就九十八使耶。答曰。有。具缚人。住苦法忍时。颇有人断八十八结不断十结而不得果耶

答曰。有。离色爱人。得正决定。灭比智时。欲界三十六使断。色界三十一使。无色界苦集灭谛所断二十一使。十不断者。无色界道谛所断七使。修道所断三使。彼不得果。所以者何。是向道故。颇有九十八使断而非阿罗汉耶。答曰。有。离无所有处欲。未离非想非非想处欲。欲界三十六使断。色界三十一。无色界空处识处无所有。处三十一使。彼非是阿罗汉。所以者何。凡夫人亦断。阿那含亦断。评曰。不应作此论。所以者何。以界故立烦恼。不以地故

身见于身见有几缘。问曰。何故作此论。答曰。或有说。缘无体。如譬喻者。彼何故作是说耶。答曰。彼依佛经。佛经说。无明缘行。无明是一相行。是若干相。云何一相法。与若干相作缘。尊者佛陀提婆说曰。诸师所说。缘但有名而无体。为止如是说者。意亦明缘有实体。若当缘无体者。一切诸法亦无体。所以者何。一切有为法。尽是因缘次第缘。除过去现在阿罗汉最后心。余过去现在一切心心数法。境界缘。威势缘。一切法是。复次若缘无体者。一切诸法。无甚深义。诸法若不以缘相观察。则浅近易知。若以缘相观察诸法则深过四海。唯佛智能知。非余所知。复次若缘无体者。则不施设有三种菩提。若以上智观于缘相。名佛菩提。若以中智。名辟支佛菩提。若以下智。名声闻菩提。复次若缘无体者。则无上中下觉差别。若下觉者常是下觉。中觉常是中觉。上觉常是上觉。以观缘相故。下觉可令中。中可令上。是故尊者瞿沙。作如是说。若缘无体者。则师不能教授弟子。使觉性增广。以缘有体故。则师教弟子。下觉为中。中觉为上。本是弟子。后便为师。以是事故。当知缘实有体相。问曰。若缘实有体者。譬喻者所说经。云何通。答曰。无明体虽一相。所作有若干。以若干义门。为行作缘。犹如一人有五种能人。虽是一而有五能。彼亦如是。复次所以作论者。欲现一切有为法性羸劣无自力由他不自在无所欲作故。而作此论。或有说。有为法自性羸劣。或有说。由羸劣因缘生。故性羸劣如说。比丘当知。色是无常。能生色因缘。亦是无常。因缘生者。色云何是常。以有为法性羸劣故。或有从四缘生者三缘生者二缘生者。乃至无有从一缘生者。何况无缘。如众多羸病人。或须四人扶者。或须三人。或须二人。乃至无有一人能扶起者。何况无人而能起耶。彼亦如是。无自力者无有自力势用而能生由他者。若无自力名为由他不自在者。莫令我生。莫令我灭。不得自在。无所欲作者。无有如是欲作之心谁作我。我当作何欲现诸法性劣。乃至无所欲作故。而作此论。复次所以作论者。欲止于缘起法过故。或谓。缘起法。唯无明缘行。乃至生缘老死。更无缘起法。欲令此义决定。若法从缘生。即是缘起。此中应说僧伽婆修喻。是故为止他义欲显己义。乃至广说。问曰。身见于身见。有几缘。答曰。或四三二一。问曰。何故彼尊者作论。此中问身见于身见有几缘。答或四三二一。如智揵度问法智于法智有几缘。答因次第缘境界威势缘耶。答曰。彼作经者意欲尔。乃至广说。复次为现二门二略。乃至广说。此身见于身见。有几缘。答或四三二一。法智于法智有几缘。亦应如是答。或四三二一。彼法智于法智有几缘。答因次第境界威势。此中身见于身见有几缘。亦应如是答。因次第境界威势。复次此说是了义。彼说是未了义。乃至广说。此是实谛。彼是世谛。复次此中分别四种法。一分别界。二分别世。三分别刹那。四分别次第。彼但分别次第。身见于身见有几缘。答曰。或四三二一。云何四。身见次第生身见。即缘前生身见。前生身见。与后身见作四缘。谓因次第境界威势。如一身见刹那。后次生第二身见刹那。若后生身见。缘前生身见者。前生身见。与后生身见作四缘。谓因次第境界威势。因缘者。有二因。谓相似因。一切遍因。次第缘者。后生身见。次前身见后生。境界缘者。后生身见。即缘前生身见。因缘者如种子法。次第缘者。如开道法。境界缘者。如执杖起法。威势缘者。是不相障碍法。后生身见。受前身四缘威势故。能行世。能取果。能有所作。能知境界。云何三。答曰。如身见次第生身见。不缘前身见。前生身见。于后身见。因次第威势。无境界。如一身见刹那。次生第二身见刹那。后生身见虽不缘前生身见。或缘色阴。或缘受阴。或缘想阴。或缘识阴。除身见。或缘余行阴。前生身见。与后生身见作三缘。因次第威势无境界。因缘者有二因。谓相似因。一切遍因。次第缘者。后生身见。次前身见后生。无境界。以不缘前身见故。因缘者。如种子法。次第缘者。如开导法。威势缘者。是不障碍法。后生身见。受前身见三缘故。能行世。能取果。能有所。作能知缘。能知境界。复有三缘。如身见次第生不相似心。后还生身见。即缘前身见。前生身见。与后生身见。因境界威势。无次第。如一身见刹那后。不生第二刹那。身见或生边见。或生邪见。或生戒取。或生见取。或生疑。或生爱恚慢无明。或生善有漏不隐没无记心。还生身见。即缘前生身见。前生身见。与后生身见。作三缘。谓因境界威势无次第。以生不相似心故。境界缘者。以缘前身见故。后生身见。受前生身见三缘势故。能行世。乃至广说。云何二。如身见次第生不相似心。后生身见。不缘前身见。前生身见于后生身见。因缘威势缘。无境界缘次第缘。如一身见刹那后。不生第二身见刹那。或生边见。乃至生善不隐没无记心。还生身见。虽不缘前身见。或缘色阴。乃至识阴。除身见。亦缘余行。除前生身见。与后生身见。作二缘。谓因缘威势缘。因缘者。有二因。谓相似因。一切遍因。威势缘者。不障碍故。无境界缘。不缘前身见故。无次第缘。后生身见。不次前身见后生故。后生身见。受前身见二缘势故。能行于世。广说如上。云何一。后生身见。于前生身见。若缘者。境界缘威势缘。若不缘者。一威势缘。问曰。何故问一缘。而答二缘耶。答曰。诸师作论。或有先避过而后答。或有先答而后避过。先避过而后答者如此说。后生身见。于前生身见。若作境界境界威势缘。是名避过。不作境界。一威势缘。是名答。先答而后避过者。如一行品说。若前生不断是系。是名答。若前不生。生者已断。是不系。是名避过。复有说者。此名是答不名避过。身见或有一缘。或有二缘。未来身见。于过去现在身见。若作境界境界威势缘。若不作境界。一威势缘。未来现在身见。于过去身见若作境界境界威势缘。若不作境界。一威势缘。若过去身见。缘未来现在身见故生。未来现在身见。于过去身见作二缘。谓境界威势缘。若过去身见。不缘未来现在身见生者未来现在身见。于过去身见。作一威势缘。问曰。如过去身见。所作已竟。更无所能。何故作是说。若缘作境界威势缘。若不缘一威势缘耶。答曰。过去身见。在现在世时。缘未来身见。缘已灭堕过去。虽灭堕过去。更无所作。即以前所作而说。欲界身见于色界身见。一威势缘。无因缘。所以者何。以地以界。因各异故。无次第缘。所以者何。无染污心命终。生上地者。无境界缘。所以者何。无缘下烦恼故。有威势缘。不相障碍故。色界身见。于欲界身见。若作次第。次第威势缘。若不作次第。一威势缘。住色界身见俱心命终。以欲界身见俱心。令生相续色界身见。于欲界身见作二缘。谓次第缘威势缘。次第缘者。以欲界身见。次色界身见后生故。威势缘者以不相障碍故。无因缘。所以者何。以地以界。因各异故。无境界缘。以身见不缘他界故。若色界中。不住身见。俱心命终。以欲界身见俱心令生相续者。色界身见。于欲界身见。一威势缘。无次第缘。有威势缘。如上说。欲界身见。于无色界身见。一威势缘。无色界身见。于欲界身见。若作次第。次第威势缘。若不作次第。一威势缘。广说如上。色界身见。于无色界身见。一威势缘。无色界身见。于色界身见。若作次第。有次第威势缘。若不作次第。一威势缘。广说如上。如身见于身见。身见于不一切遍。不一切遍于不一切遍。不一切遍于一切遍。不一切遍于一切遍者。下于上。上于下。所以者何。此中说他界缘一切遍是一切遍。总而言之。使有十种。谓五见疑爱恚慢无明。此十使。五是一切遍。五非一切遍。五是一切遍者。谓邪见见取戒取疑无明。五非一切遍者。谓身见边见爱恚慢。此文说他界缘一切遍。身见边见。在不一切遍中。如身见于身见如是。身见于不一切遍者。如身见于边见于爱于恚于慢。是名身见于不一切遍。不一切遍于不一切遍者。如边见于边见于爱于恚于慢于身见。爱于爱。于恚于慢于边见于身见。于恚于慢于爱于身见于边见。慢于慢于身见于边见于爱于恚。是名不一切遍于不一切遍。不一切遍于一切遍者。如身见于邪见于见取于戒取于疑于无明。如身见。边见爱恚慢说亦如是。是名不一切遍于一切遍。身见于戒取有几缘耶。答曰。或四三二一。云何四。如身见次第生戒取。即缘身见。前生身见。于后生戒取。因次第境界威势缘。如一身见刹那后。次第生戒取刹那。若后生戒取。缘前身见者。前生身见。于后生戒取作四缘。谓因次第境界威势缘。因缘者有二因。谓相似因。一切遍因。次第缘者。戒取次身见后生故。境界缘者。后生戒取。缘前身见故生。因缘者如种子法。乃至威势缘。是不相障碍法。后生戒取。受前身见。四缘势故。能行世。广说如上。云何三。答曰。如身见次第生戒取。不缘身见。前生身见。于后生戒取。因次第威势缘。无境界缘。如一身见刹那后。次第生戒取刹那。戒取虽不缘身见。或缘色阴。乃至识阴。或缘阴身见余行阴。前生身见。于后生戒取有三缘。无境界缘。因缘者有二因。谓相似因。一切遍因。次第缘者。后生戒取。次前生身见后生故。威势缘者。不相障碍故。无境界缘。后生戒取。不缘前身见故。后生戒取。受前生身见。三缘势故。能行世。广说如上。复有三缘二缘一缘。广说如身见。欲界身见。于色界戒取。一威势缘。广说如上。色界身见。于欲界戒取。若作次第。不作境界。有次第威势缘。如住色界身见。俱心命终。欲界戒取。俱心令生相续。欲界戒取。不缘色界身见。色界身见。于欲界戒取。有次第威势缘。若作境界。不作次第。有境界威势缘。若不住色界身见。俱心命终。欲界戒取。俱心令生相续。即缘色界身见。色界身见。于欲界戒取。有二缘。谓境界威势缘。若作次第境界威势缘者。则有次第境界威势缘。如住色界身见。俱心命终欲界戒取。俱心令生相续。欲界戒取。即缘色界身见。色界身见。于欲界戒取。有三缘。谓次第境界威势缘。次第缘者。欲界戒取。次色界身见后生。境界缘者。欲界戒取。缘色界身见故生。威势缘者。不相障碍故。无因缘。以界以地。因各异故。若不作次第缘。不作境界缘。一威势缘。若不住色界身见。俱心命终欲界戒取。俱心令生相续。不缘色界身见故生。色界身见。于欲界戒取。一威势缘。无因缘。以界以地。因各异故。无次第缘。以不次色界身见后生故。无境界缘以不缘色界身见故。以不相障碍故。一威势缘。欲界身见。于无色界戒取。一威势缘。无色界身见。于欲界戒取。广说如上。色界身见。于无色界戒取。广说如上。无色界身见。于色界戒取。广说如上。如身见于戒取。于邪见于见取于疑于无明。说亦如是。是名身见于一切遍。一切遍于一切遍者。如邪见于邪见。于见取于戒取于疑于无明。见取于见取于戒取于疑于无明于邪见。戒取于戒。取于疑于无明于邪见于见取。疑于疑于无明于邪见于见取于戒取。无明于无明于邪见于见取于戒取于疑。是名一切遍于一切遍。不一切遍于一切遍者。如身见于戒取。于邪见于见取于疑于无明亦如是。如身见。边见爱恚慢说亦如是。是名不一切遍于一切遍。若问诸法摄。应以入观察。若问智。应以谛观察。若问识。应以界观察。若问烦恼。应以种观察。若如是观察。则法体相。易知易见。此中问烦恼。应以种观察。法有五种。见苦断种。乃至修道断种。见苦所断有二种。一一切遍。二不一切遍。见集所断亦如是见灭所断有二种。一缘有漏。二缘无漏。见道所断亦如是。修道所断非一切遍。见苦所断一切遍。于见苦所断一切遍。因次第境界威势缘。因缘者。有四因。谓相应因。共生因。相似因。一切遍因。次第缘者。见苦所断一切遍。次第生见苦所断一切遍。境界缘者。见苦所断一切遍。即缘见苦所断一切遍。威势缘者。不相障碍故。见苦所断一切遍。于见苦所断。不一切遍。因次第境界威势缘。因缘者。有二因。谓相似因。一切遍因。次第缘者。见苦所断一切遍。次第生见苦所断不一切遍。境界缘者。见苦所断不一切遍。缘见苦所断一切遍。威势缘者。不相障碍故。见苦所断一切遍。于见集所断一切遍。因次第境界威势缘。因缘者一因。谓一切遍因。次第缘者。见苦所断一切遍。次第生见集所断一切遍。境界缘者。见集所断一切遍。缘见苦所断一切遍。威势缘者。不相障碍故。见苦所断一切遍。于见集所断不一切遍。见灭所断见道所断修道所断。因次第威势缘。无境界缘。因缘者一因。谓一切遍因。次第缘者。见苦所断一切遍。次第生彼诸使。境界缘者。彼诸使。缘于自种。不缘他种。威势缘者。不相障碍故。见苦所断不一切遍。于见苦所断不一切遍。因次第境界威势缘。因缘者有三因。谓相应因。相似因。共生因。次第缘者。见苦所断不一切遍。后次第生见苦所断不一切遍。境界缘者。见苦所断不一切遍。缘见苦所断不一切遍。威势缘者。不相障碍故。见苦所断不一切遍。于见苦所断一切遍。因次第境界威势缘。因缘者有一因。谓相似因。次第缘者。见苦所断不一切遍。后次第生见苦所断一切遍境界缘者。见苦所断一切遍。缘见苦所断不一切遍威势缘者。不相障碍故。见苦所断不一切遍。于见集所断一切遍。次第境界威势缘无因缘。次第缘者。见苦所断不一切遍。后次第生见集所断一切遍境界缘者。见集所断一切遍。缘见苦所断不一切遍威势缘者。不相障碍故无因缘。所以者何。不一切遍使。不为他种作因。见苦所断不一切遍。于见集所断不一切遍。见灭所断见道所断修道所断。次第威势缘无因缘。无境界缘。次第缘者。见苦所断不一切遍后次第生彼诸使。威势缘者。不相障碍故无因缘。所以者何。不为他种作因。无境界缘。所以者何。不为他种所缘。如见苦所断一切遍不一切遍。见集所断一切遍不一切遍。说亦如是

见灭所断有漏缘使。于见灭所断有漏缘。因次第境界威势缘。因缘者有三因。谓相应因。共生因。相似因。次第缘者。见灭所断有漏缘使。后次第生见灭所断有漏缘使。境界缘者。见灭所断有漏缘使。缘见灭所断有漏缘使。威势缘者。不相障碍故。见灭所断有漏缘使。于无漏缘使。因次第威势缘。无境界缘。因缘者有一因。谓相似因。次第缘者。见灭所断有漏缘使。后次第生无漏缘使。威势缘者。不相障碍故。无境界缘。所以者何。彼使缘无漏使。是有漏见灭所断。有漏缘使于见苦见集所断一切遍使。次第境界威势缘无因缘。次第缘者。见灭所断有漏缘使。后次第生见苦见集所断一切遍使故。境界缘者。见苦见集所断一切遍使。缘见灭所断有漏缘使故。威势缘者不相障碍故。无因缘者。见灭所断有漏缘使。非一切遍故。于见苦见集所断不一切遍使。于见道所断修道所断一切使有。次第威势缘。次第缘者。见灭所断有漏缘使。后次第生见苦见集所断不一切遍使。见道所断修道所断一切使故。威势缘者。不相障碍使。无因缘者。如上所说。无境界缘者。彼诸使非一切遍故。不缘他种见灭所断无漏缘使。于见灭所断无漏缘使。因次第威势缘。无境界缘。因者。有三因。谓相应因。共生因。相似因。次第缘者。见灭所断无漏缘使。后次第生见灭所断无漏缘使。威势缘者。不相障碍故。无境界缘者。彼使缘无漏使。是有漏故。见灭所断无漏缘使。于见灭所断有漏缘使。因次第境界威势缘。因缘者。有一因。谓相似因。次第缘者。见灭所断无漏缘使。后次第生见灭所断有。漏缘使。境界缘者。见灭所断有漏缘使。缘见灭所断无漏缘使故。威势缘者。不相障碍故。于见苦见集所断一切遍使。次第境界威势缘。无因缘。次第缘者。见灭所断无漏缘使。后次第生见苦见集所断一切遍使故。境界缘者。见苦见集所断一切遍使。缘见灭所断无漏缘使故。威势缘者。不相障碍故。无因缘者。见灭所断无漏缘使。非一切遍故。不缘他种。于见苦见集所断不一切遍使。见道所断修道所断。有次第威势缘。无因缘境界缘。次第缘者。见灭所断无漏缘使。后次第生见苦见集所断不一切遍使。见道所断修道所断一切使。威势缘者。不相障碍故。无因缘者。见灭所断无漏缘使。非一切遍故。不为他种作因。无境界缘者。见苦见集所断不一切遍使。见道修道所断一切使。不缘他种故。如见灭所断有漏缘使无漏缘使。见道所断有漏缘使无漏缘使。说亦如是。修道所断使。于修道所断使。有因次第境界威势缘。因缘因者。有三因。谓相应因。共生因。相似因。次第缘者。修道所断使。后次第生修道所断使。境界缘者。修道所断使。缘修道所断使。威势缘者。不相障碍故。修道所断使。于见苦见集所断一切遍使。有次第境界威势缘。无因缘。次第缘者。修道所断使。后次第生见苦见集所断一切遍使。境界缘者。见苦见集所断一切遍使。缘修道所断使故。威势缘者。不相障碍故。无因缘者。修道所断使。非一切遍故。不为他种作因。于见苦见集所断不一切遍使。见灭见道一切使。有次第威势缘。无因缘。无境界缘。次第缘者。修道所断使。后次第生见苦见集所断不一切遍使。见灭见道所断一切使。威势缘者。不相障碍故。无因缘者。修道所断使。非一切遍故。不为他种作因。无境界缘者。彼诸使。非一切遍故。不缘他种。此中说一切遍因。应如杂揵度智品广说

阿毗昙毗婆沙论卷第三十阿毗昙毗婆沙论卷第三十一

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    使犍度一行品第二上

九结。爱结。恚结。慢结。无明结。见结。取结。疑结。嫉结。悭结。若处所有爱结系。复有恚结系耶。若有恚结系。亦有爱结系耶。如此章及解章义。此中应广说优婆提舍。处所有五种。一自体处所。二缘处所。三系处所。四因处所。五属处所。自体处所者。如见犍度说。若处所有所知。彼处所亦有所断耶。若处所有所断。彼处所亦有所知耶。此中说忍智体名处所。见犍度亦说。若得彼处所成就。彼处所耶。或有说者。此中说一切法自体名处所。复有说者。此中说诸法有得相成就相者名处所。缘处所者。如波伽罗那说。一切诸法。应以智知随其处所。云何名处所。随智所行。随智缘。随智境界。是名处所。经亦说有四十四智处所。有七十七智处所。阿毗昙者。作如是说。此中说自体处所。所以者何。以忍以智。观诸有枝。忍智体名处所。尊者瞿沙。作如是说。此中说缘处所。所以者何。以智以忍。缘于有枝。故名缘处所。系处所者。如此中说。若处所有爱结系。复有恚结系耶。五种法名处所。所以者何。五种烦恼。能系此五种法故。五种法者。谓见苦所断。乃至修道所断。因缘处所者。如波伽罗那所说。云何有处所法。云何无处所法。乃至云何有因法。云何无因法。有因法名有处所法。无因法名无处所法。如说

  比丘心寂静　　能断诸处所
  尽于生死苦　　不受未来有

此中说因是处所。所以者何。有因故有生死。因断故生死断。属处所者。如经说。应舍田舍市肆属我之心。如偈说

  不舍田财　　牛马奴婢　　种种女色
  不得解脱

如世人言。此物属我。此处所属我。于此五种处所中。依系处所而作论。不依余处所。复有说者。有五种处所。一界处所。二入处所。三阴处所。四世处所。五刹那处所。于此十处所中。依系处所而作论。犊子部作如是说。处所是假名法。无有定体。结非假名。众生非假名。各有定体。阿毗昙者。作如是说。处所非假名。结非假名。众生是假名。譬喻者。作如是说。结非假名有定体。处所是假名。众生是假名。而有定体。问曰。彼何故说处所是假名法无有定体。答曰。彼作是说。以于境界中有欲无欲故。犹如有一端严女人。他人见已。或起敬心。或起欲心。或起恚心。或起愱心。或起厌心。或起悲心。或起舍心。起敬心者。如子见母。起欲心者。如多欲者见可爱色。起恚心者。如怨相见。起愱心者。如共夫者见之。起厌心者。如修不净观者。起悲心者。是离欲人。彼作是念。如是好色。不久当坏。起舍心者。得阿罗汉者。以于境界起如是等有欲无欲心故。智处所是假名法。无有定体。此诸烦恼。通五识身。及在意地。通五识身者。过去者系过去处所。现在者系现在处所。未来世必生法。系未来世处所。必不生者。系三世处所。在意地者。过去者系于三世。未来者亦系三世。现在者亦系三世。依眼识生。使系于色。彼相应法。是相应系。彼相应法。是意入法入。乃至依身识生使。亦如是。依意识生使。系十二入。彼相应者。是相应系。相应法者。是意入法入。如是说者。是一行毗婆沙。若处所有爱结系。复有恚结系耶。答曰。若有恚结系。亦为爱系结。颇为爱结所系。不为恚结所系耶。答曰。有色无色界法未断爱结者在三界。有五种缘。有漏非一切遍。恚结在欲界。有五种缘。有漏非一切遍。若是具缚欲界五种处所。为爱结所系。亦为恚结所系。若为恚结所系亦为爱结所系。若非具结则爱结长在三界。是故得作称后句。若处所有爱结系。复有恚结系耶。答曰。若有恚结系。亦有爱结系处所者。是欲界系五种处所。颇为爱结所系。不为恚结所系耶。答曰。有色无色界爱结未断未断者。或有八地爱结未断。或有乃至非想非非想处爱结未断。彼非想非非想处。或有五种爱结未断。或有乃至修道所断者未断。彼非想非非想处修道所断。或有九种爱结未断。或有乃至下下种未断者。以总说故。言色无色界系。法爱结未断是名为爱结所系不为恚结所系。所以者何。色无色界无恚结故。问曰。何故色无色界无有恚结耶。答曰。非其田器。乃至广说。复次众生厌患恚故。愿生色无色界。若色无色界有恚结者。则不为彼处而修方便。若法是下地有上地亦有者。则无次第断法。若无次第断法。则无究竟断法。所以者何。以次第断法能生究竟断法故。若无究竟断法。则无解脱出离。欲令无如是过故。色无色界无有恚结。复次若有苦根忧根。则有恚结。所以者何。众生以忧苦根故。于他生恚。色无色界无忧苦根。复次若有无惭无愧处。则有恚结。因无惭无愧故众生起恚。色无色界无有无惭无愧。如无惭无愧。愱悭男根女根揣食淫爱五盖胜妙五欲。当知亦如是。复次若有怨憎相处。则有恚结。怨憎相者。是九恼法。色无色界无有怨憎相。是故尊者瞿沙作如是说。众生以怨憎故起于恚结。色无色界无有怨憎。复次色界有恚结近对治。近对治者。谓慈是也。犹如毗岚摩风处则无云翳。彼亦如是。若处所有爱结系。复有慢结系耶。答曰。如是。若有慢结系。复有爱结系耶。答曰。如是。所以者何。此二结俱在三界。有五种缘。有漏非一切遍故。若是具结三界五种法。为爱结所系。亦为慢结所系。若为慢结所系。亦为爱结所系。是故得作如是句。若处所有爱结系。复有无明结系耶。爱结在三界。有五种缘。有漏非一切遍。无明结。在三界。有五种缘。有漏无漏。是一切遍。非一切遍。若具缚三界五种法。为爱结所系。亦为无明结所系。若为无明结所系。亦为爱结所系。若非具缚无明使。则长于一切遍无漏缘。是故得作顺前句。若处所有爱结系。亦有无明结系耶。答曰。若有爱结系。则有无明结系。处所者。是三界五种处所。颇为无明结所系。不为爱结所系耶。答曰。有苦智已生集智未生。见苦所断法。见集所断无明使未断。苦智已生。集智未生见苦所断爱结无明结断。见集所断无明结。缘系见苦所断法。所以者何。无明结是一切遍故。爱结不尔。所以者何。自种爱结已断。见集所断爱结。于见苦所断法。不缘系。以非一切遍故。非相应系。以是他聚故。若处所有爱结系。复有见结系耶。爱结在三界。有五种缘。有漏非一切遍。见结在三界。有四种缘。有漏无漏。是一切遍。非一切遍。若是具缚三界五种处所。为爱结所系。亦为见结所系。若为见结所系。亦为爱结所系。若非具缚爱结。则于五种中长。见结于一切遍无漏缘中长。是故得作四句。若处所有爱结系。复有见结系耶。乃至广作四句。为爱结所系不为见结所系者。集智已生灭智未生。见灭所断。见道所断。见不相应法。爱结未断。见灭见道所断见不相应法。何者是耶。答曰。即彼邪见见取戒取爱恚慢疑无明相应法是也。如是见不相应为爱结所系。于自聚中缘系相应系。于他聚中作缘系。非相应系非见。所以者何。见是一切遍。能缘五种者已断。余不断者。于余见不相应法。不缘系缘无漏故。不相应系。以异聚故。自体不与自体相应。修道所断法。爱结未断。或有九地爱结不断者。或有乃至非想非非想处未断者。彼非想非非想处。修道所断爱结。或有九种未断者。或有乃至下下种未断者。总而言之。修道所断法。爱结未断。是名爱结所系不为见结所系。所以者何。见结是一切遍。能缘五种者已断。修道所断。无有见结。灭智已生道智未生。见道所断。见不相应法。爱结缘未断。见道所断。见不相应法。何者是耶。答曰。即彼邪见见取戒取疑爱恚慢无明相应法。如是等见不相应法。为爱结所系。自聚有缘系相应系。他聚有缘系。不为见结所系。所以者何。见结是一切遍。能缘五种者已断。余不断者。于彼法不缘系。以缘无漏故。不相应系。是他聚故。自体不与自体相应。修道所断法。爱结未断如前说。见谛具足世尊弟子。爱结未断。广说如上。为见结所系非爱结者。苦智已生集智未生。见集所断见结未断。苦智已生集智未生见苦所断爱结断。见结亦断。见集所断见结缘系。见苦所断法。为见结所系。非爱结系。所以者何。自种爱结已断。他种者。于见苦所断法。不缘系。非一切遍故。非相应系。是他聚故。二俱系者具缚见道所断法。修道所断法。二俱系

问曰。何故名具缚耶。答曰。为五处所缚。亦能缚五处。故言具缚。能系五处者。五种断结。为五处所缚者。是五种断法。具缚见苦所断法。一种爱结系。二种见结系。见集所断亦如是。见灭所断见相应法。一种爱结系。三种见结系。见不相应法。一种爱结系。二种见结系。见道所断亦如是。修道所断法。一种爱结系。二种见结系。苦智已生集智未生。见集见灭见道修道所断法。二俱系。见集所断。修道所断。一种爱结系。一种见结系。见灭所断。见相应法。一种爱结系。二种见结系。见不相应法。一种爱结系。一种见结系。见道所断亦如是。见苦所断法。惟为见结所系。不为爱结所系。是故不说。集智已生灭智未生。见灭见道所断见相应法。二俱系。见灭所断见相应法。一种爱结系。一种见结系。见灭所断见不相应法。惟为爱结所系。不为见结所系。是故不说。见道所断亦如是。修道所断法。惟为爱结所系。不为见结所系。二俱不系者。集智已生见苦见集所断法。二俱不系。灭智已生道智未生。见苦见集灭所断法。二俱不系。见谛具足世尊弟子。见道所断法。二俱不系。已离欲爱欲界系法。二俱不系。已离色无色界欲。色无色界系法。二俱不系。所以者何。若结断者。处所亦断。此中作是论。颇见灭见道所断见相应法。为爱结所系。不为见结所系。非不为见使所使耶。答曰。有断六种欲者得正决定。集智已生灭智未生。见灭见道所断六种见相应法。为爱结所系。不为见结所系。所以者何。见结是一切遍。缘五种者已断。缘无漏六种见已断。余三种未断。无漏缘见。于六种已断法。无缘系缘无漏故。无相应系。以他聚故。未断三种爱结。于见灭见道所断。六种已断。法作缘系。彼非不为见使所使。所以者何。三见作见结。五见作见使。为见使中见取戒取所使故。如爱结见结。爱结疑结亦如是。所以者何。如见结在三界四种断缘有漏无漏是遍不遍。疑结亦如是。若处所有爱结系。复有取结系耶。爱结在三界。五种断缘有漏。非一切遍。取结在三界。四种断缘有漏是一切遍非一切遍。若是具系三界五种处所爱结系。亦为取结所系。若为取结所系。亦为爱结所系。若非具缚爱结。则长于五种。取结长于一切遍。是故得作四句。或为爱结所系。不为取结所系。乃至广作四句。为爱结所系。不为取结所系者。集智已生灭智未生。修道所断法。爱结未断。或有九地爱结未断。或有乃至非想非非想处爱结未断。彼非想非非想处爱结。或有九种未断。或有乃至下下种未断。总而言之。修道所断法。爱结未断。灭智已生道智未生。修道所断法。爱结未断。广说如上。见谛具足世尊弟子。修道所断法。爱结未断。是名爱结所系非取结所系。取结能缘五种者已断。所以者何。取结是一切遍。能缘五种者已断。取结非修道所断。为取结所系。不为爱结所系者。苦智已生集智未生。见苦所断法。见集所断取结未断。苦智已生集智未生。见苦所断爱结若断。取结亦断。见集所断取结。缘系见苦所断。是名取结所系非爱结所系。所以者何。自种爱结已断。他种爱结。不作缘系。非一切遍故。非相应系。以他聚故。俱系者。具缚见道修道所断法。二俱系具缚。见苦所断法。为一种爱结所系。为二种取结所系。见集所断亦如是。见灭所断。为一种爱结所系。三种取结所系。见道所断亦如是。修道所断。一种爱结所系。二种取结所系。苦智已生集智未生。见集见灭见道修道所断法。二俱系。见集所断修道所断法。为一种爱结所系。亦为一种取结所系。见灭见道所断法。一种爱结系。二种取结系。见苦所断法。惟为取结所系。不为爱结所系。是故不说。集智已生灭智未生。见灭见道所断法二俱系。见灭所断法。为一种爱结所系。一种取结所系。见道所断亦如是。修道所断法。惟为爱结所系。不为取结所系。是以不说。灭智已生道智未生。见道所断法二俱系。见道所断法。为一种爱结所系。一种取结所系。修道所断。广说如上。二俱不系者。集智已生灭智未生。见苦见集所断法二俱不系。灭智已生道智未生。见苦集灭所断法。二俱不系。见谛具足世尊弟子。见道所断法。二俱不系。欲爱已断。欲界系法。二俱不系。色爱已断。色界系法。二俱不系。无色爱已断。一切二俱不系。所以者何。彼结若断。处所亦断。若处所有爱结系。复有愱结系耶。爱结在三界。五种断。缘有漏。非一切遍。愱结在欲界。修道所断缘有漏。非一切遍。若是具缚欲界修道所断法。若为爱结所系。亦为愱结所系。若为愱结所系。亦为爱结所系若非具系爱结。长在三界五种断。是故得作称后句。若处所有爱结系复有愱结系耶。答曰。若为愱结所系。亦为爱结所系。修道所断法。为一种爱结所系。一种愱结所系。颇为爱结系不为愱结所系耶。答曰。欲界见道所断法。爱结未断。或有四种法爱结未断。或有乃至见道所断爱结未断。色无色界系法。爱结未断是名爱结所系不为愱结所系。所以者何。色无色界无愱结。无愱结义如上说。如爱结愱结。爱结悭结说亦如是。如爱结门。慢结门说亦如是。所以者何。此二俱在三界。五种断缘有漏。非一切遍。若处所有恚结系。复有慢结系耶。恚结在欲界。欲界五种断缘有漏。非一切遍。慢结在三界。五种断缘有漏。非一切遍。若是具缚欲界系五种处所。为恚结所系。亦为慢结所系。若为慢结所系。亦为恚结所系。若非具缚慢结。长在三界。是故得作顺前句。若处所有恚结系。复有慢结系耶。答曰。若为恚结所系。亦为慢结所系。处所者是欲界五种所断。颇为慢结所系。不为恚结系耶。答曰。有色无色界慢结未断。或有八地慢结未断。或有乃至非想非非想处慢结未断。彼非想非非想处。或有五种断慢结所系。或有修道所断慢结所系。彼修道所断慢结。或有九种未断。或有乃至下下种未断者。总而言之。色无色界慢结未断。是名慢结所系不为恚结所系。所以者何。色无色界无恚结。色无色界无恚结义。如上说。若处所有恚结系。复有无明结系耶。恚结在欲界。五种所断。缘有漏非一切遍。无明结在三界。五种所断。缘有漏无漏。是一切遍。若是具缚欲界五种处所。为恚结所系。亦为无明结所系。若为无明结所系。亦为恚结所系。若非具缚无明结。长在三界。长一切遍。是故得作顺前句。若处所有恚结系。复有无明结系耶。答曰。若为恚结所系。亦为无明结所系。处所者欲界系。五种处所。颇为无明结所系。不为恚结所系耶。答曰。有苦智已生。集智未生欲界见苦所断法。见集所断无明结未断。苦智已生集智未生。见苦所断法。见集所断无明结缘系。是名为无明结所系不为恚结系。所以者何。自种恚结已断。他种者。于见苦所断非缘系。非一切遍。故非相应系。是他聚故。色无色界系法。无明结未断。或有八地无明结未断。或有乃至非想非非想处无明结未断。彼非想非非想处。或有五种未断。或有乃至修道所断未断。非想非非想处修道所断。或有九种未断。或有乃至下下种未断。总而言之。色无色界系无明结未断。是名无明结所系不为恚结所系。所以者何。色无色界无恚。色无色界无恚结义。如上说。若处所有恚结系。复有见结系耶。恚结在欲界。五种断。缘有漏非一切遍。见结在三界。四种断。缘有漏无漏。一切遍非一切遍。若是具缚欲界五种断。处所有恚结所系。亦为见结所系。若为见结所系。亦为恚结所系。若非具缚恚结。长在五种断。见结长在三界一切遍。是故得作四句。若为恚结所系。不为见结所系耶。乃至广作四句。为恚结所系不为见结所系者。未离欲爱。集智已生灭智未生。欲界系见灭见道所断见不相应法。恚结未断。欲界系见灭见道所断见不相应法。何者是耶。答曰。即彼邪见见取戒取爱恚慢疑无明相应法是也。此法恚结未断。自聚缘系。相应系。他聚缘系。非相应系。不为见结所系。所以者何。见结是一切遍缘。五种者已断。余不断者。于见不相应法。非缘系。缘无漏故。非相应系。以他聚故。自体不应自体故。欲界系修道所断法。恚结未断。或有九种未断。或有乃至下下种未断者。灭智已生道智未生。欲界系见道所断见不相应法。恚结未断。欲界系见道所断见不相应法。何者是耶。答曰。即彼邪见见取戒取爱恚慢无明疑相应法是也。此法恚结未断。自聚中缘系。相应系。他聚作缘系。非见结系。所以者何。见结是一切遍。能缘五种者已断。余不断者。于见不相应法。非缘系。缘无漏故。非相应系。是他聚故。自体不应自体故。欲界修道所断法。恚结未断。广说如上。见谛具足世尊弟子。欲界修道所断恚结未断。广说如上。是名为恚结所系不为见结所系

为见结所系不为恚结所系者。未离欲爱。苦智已生集智未生。欲界见苦所断法。见集所断法。见结未断。苦智已生集智未生。见苦所断恚结。见结已断。见集所断见结缘系。见苦所断法。为见结所系。不为恚结所系。所以者何。自种恚结已断。他种者。于见苦所断法。非缘系。非一切遍。故非相应系。是他聚故。色无色界见结未断。或有八地见结未断。或有乃至非想非非想处见结未断。彼非想非非想处。或有四种断见结未断。或见乃至见道断结未断者。总而言之。色无色界系法见结未断。是名见结系不为恚结所系。所以者何。色无色界无有恚结。广说如上

云何二俱系。具缚欲界见道修道所断法。二俱系。具缚欲界见苦所断法。一种恚结系。二种见结系。见集所断法亦如是。见灭所断见相应法。为一种恚结系。三种见结系。见不相应法。一种恚结系。二种见结系。见道所断法亦如是。欲界系修道所断法。一种恚结系。二种见结系。欲爱未断。苦智已生集智未生。欲界系见集灭道修道所断法二俱系。见集所断法。一种恚结系。一种见结系。见灭所断见相应法。一种恚结系。二种见结系。见不相应法。一种恚结系。一种见结系。见道所断法亦如是。修道所断法一种恚结系。一种见结系。欲界见苦所断法。虽为见结系。不为恚结系。是故不说。集智已生灭智未生。欲界系见灭所断见相应法二俱系。欲界见灭所断见相应法。一种恚结系。一种见结系。见不相应法。虽为恚结所系。不为见结所系。是故不说。见道所断法亦如是。欲界修道所断法。虽为恚结所系。不为见结所系。是故不说。未离欲爱。灭智已生道智未生。欲界系见道所断见相应法二俱系。一种恚结系。一种见结系欲界系见道所断见不相应法。及修道所断。虽为恚结所系。不为见结所系。是故不说。是名二俱系。不系者。集智已生灭智未生。见苦见集所断法。二俱不系。色无色界见灭见道所断见不相应法。二俱不系。色无色界修道所断法。二俱不系。灭智已生道智未生。欲界见苦集灭所断法。二俱不系。色无色界系见不相应法。及修道所断法。二俱不系。见谛具足世尊弟子。见道所断法。二俱不系。色无色界系修道所断法。二俱不系。已离欲爱欲界系法。二俱不系。已离色爱色界系法。二俱不系。已离无色界爱。一切不系。所以者何。彼结断故。处所亦断。如恚结见结。恚结疑结。说亦如是。所以者何。此二结俱在三界。四种断。缘有漏无漏。是一切遍非一切遍故。问曰。欲界中有恚结系不系义可尔。色无色界中无有恚结。云何说言恚结不系耶。答曰。不系有二种。一从系得不系。二性不系。欲界不系。是从系得不系。以有恚结故。色无色界不系。是性不系。以无恚结故。亦如毗尼中说。有二人。名净脱起。一未曾犯戒。二虽有所犯。如法除却。未曾犯戒者。名本净脱起。虽有所犯。如法除却者。名本非净脱起。得净脱起。彼亦如是。若处所有恚结系。复有取结系耶。恚结在欲界。五种断缘有漏非一切遍。取结在三界。四种断缘有漏。是一切遍。非一切遍。若是具缚欲界系。五种处所。若为恚结所系。亦为取结所系。若为取结所系。亦为恚结系。若非具缚恚结。长在五种断。取结长在三界。是一切遍。是故得作四句。若处所有恚结。复有取结系耶。乃至广作四句。为恚结所系。不为取结所系者。未离欲爱。集智已生灭智未生。欲界系修道所断法。恚结未断。或有九种未断。或有乃至下下种未断者。灭智已生道智未生。欲界系修道所断法。恚结未断。见谛具足世尊弟子。欲爱未断。欲界系修道所断法。恚结未断。是名恚结所系不为取结所系。所以者何。取结。是一切遍。能缘五种者已断。修道所断法中。无有取结。为取结所系不为恚结所系者。欲爱未断。苦智已生集智未生。欲界系见苦所断法。见集所断。取结未断。苦智已生集智未生。欲界见苦所断。取结恚结已断。见集所断。取结缘系。见苦所断法。为取结所系。不为恚结所系。所以者何。自种恚结已断。他种者。于见苦所断。非缘系。非一切遍。故非相应系。是他聚故。色无色界系法。取结未断。或有八地取结未断。或有乃至非想非非想处者。彼非想非非想处。或有四种未断。或有乃至一种未断者。总而言之。色无色界系法。取结未断。是名取结所系不为恚结所系。色无色界无有恚结。广说如上。俱系者。具缚欲界系。见道修道所断法。二俱系。具缚欲界见苦所断法。一种恚结系。二种取结系。见集所断。修道所断。说亦如是。欲界系见灭所断法。一种恚结系。二种取结系。见道所断法。说亦如是。欲爱未断。苦智已生集智未生。欲界见集灭道修道所断法。二俱系见集所断修道所断。一种恚结系。一种取结系。欲界见灭所断法。一种恚结系。二种取结系。见道所断法。说亦如是。欲界见苦所断法。虽为取结所系。不为恚结所系。是故不说。欲爱未尽。集智已生灭智未生。欲界系见灭所断法。一种恚结系。一种取结系。见道所断法。说亦如是。修道所断法。虽为恚结所系。不为取结所系。是故不说。欲爱未断。灭智已生道智未生。欲界见道所断法二俱系。一种恚结系。一种取结系。修道所断法如上说。是名二俱系俱不系者。广说如经本。乃至离无色界欲。二俱不系。所以者何。若彼结断。处所亦断。若处所有恚结系。复有愱结系耶。恚结在欲界。如上说。愱结在欲界。修道断缘有漏。非一切遍。若是具缚欲界修道所断处所。若为恚结所系。亦为愱结所系。若为愱结所系。亦为恚结所系。若非具缚恚结。长在五种断。是故得作称后句。若处所有恚结系复有愱结系耶。答曰。若有愱结系。亦有恚结系处所者。谓欲界修道所断处所也

颇为恚结所系。不为愱结所系耶。答曰。有欲界系见道所断恚结未断。或有四种断恚结未断。或有乃至见道所断恚结未断。总而言之。欲界系见道所断法。恚结未断。是名恚结所系不为愱结所系。所以者何。见道所断。无愱结故。如恚结。愱结恚结悭结。说亦如是。所以者何。此二结俱是欲界系。修道所断。缘有漏。非一切遍故

若处所有无明结系。复有见结系耶。无明结在三界五种断。缘有漏无漏。是一切遍。非一切遍。见结在三界。四种断缘有漏无漏。是一切遍。非一切遍。若是具缚三界五种断处所。若为无明结所系。亦为见结所系。若为见结所系。亦为无明结所系。若非具缚无明结。长在五种断。是故得作称后句。若处所有无明结系。复有见结系耶。答曰。若为见结所系。亦为无明结所系。处所者三界五种断处所。颇为无明结所系。不为见结所系耶。答曰有。集智已生灭智未生。见灭见道所断见不相应法无明结未断。见灭见道所断见不相应法何者是也。答曰。即彼邪见见取戒取爱恚慢疑不共无明相应法是也。此法无明结所系。不为见结所系。自聚中。缘系相应系。他聚中。作缘系非相应系。不为见结所系。所以者何。见结是一切遍。能缘五种者已断。余不断者。于见灭见道所断见不相应不缘系。缘无漏故。不相应系。以他聚故。修道所断法。无明结未断。或有九地无明结未断。或有乃至非想非非想处无明结未断。彼非想非非想处。或有九种无明结未断。或有乃至下下种未断者。总而言之。修道所断无明结未断。是名无明结所系非见结所系。所以者何。见结是一切遍能缘五种者已断。修道所断。无有见结。灭智已生道智未生。见道所断。见不相应法。无明结未断。及修道所断法。无明结未断。广说如上。见谛具足世尊弟子。修道所断法。无明结未断。广说如上。如无明结。见结无明结疑结。说亦如是。所以者何。此二结俱在三界。四种断。缘有漏无漏。是一切遍。非一切遍。若处所有无明结系。复有取结系耶。无明结在三界。如上说。取结在三界。亦如上说。若是具缚三界五种断处所。如上说。若非具缚无明结。长在五种断。是故得作称后句。若处所有无明结系。复有取结系耶。答曰。若为取结所系。亦为无明结所系。颇为无明结所系。不为取结所系耶。答曰有。集智已生灭智未生。修道所断法。无明结未断。广说如上。灭智已生道智未生。修道所断法。无明结未断如上说。见谛具足世尊弟子。修道所断法。无明结未断。广说如上。若处所有无明结系。复有结愱系耶。无明结在三界如上说。愱结在欲界如上说。若是具缚欲界系。修道断处所。若为无明结所系。亦为愱结所系。若为愱结所系。亦为无明结所系。若非具缚无明结。长在三界五种断。是故得作称后句。若处所有无明结系。复有愱结系耶。答曰。若为愱结所系。亦为无明结所系。处所者。是欲界系修道所断处所。颇为无明结所系。不为愱结所系耶。答曰有。欲界系见道所断法。无明结未断。或有四种无明结未断。或有乃至见道一种未断。色无色界系法。无明结未断。或有九地无明结未断。或有乃至非想非非想处未断。即彼非想非非想处。或有五种无明结未断。或有乃至修道所断未断。彼修道所断无明结。或有九种未断。或有乃至下下种未断者。总而言之。色无色界无明结未断。如无明结。愱结无明结悭结。说亦如上。所以者何。此二结俱在欲界。如上说

若处所有见结系。复有取结系邪。见结在三界。如上说。取结在三界。亦如上说。若是具缚。如上说。若非具缚取结。长在有漏。是故得作顺前句。若处所有见结系。复有取结系耶。答曰。若为见结所系亦为取结所系。处所者。三界五种断处所。颇为取结所系。不为见结所系耶。答曰有。集智已生灭智未生。见灭见道所断见不相应法。取结未断。灭智已生道智未生。见道所断见不相应法。取结未断。广说如上。若处所有见结系。复有疑结系邪。见结在三界。如上说。疑结在三界。亦如上说。若是具缚三界五种断处所。若为见结所系。亦为疑结所系。若为疑结所系。亦为见结所系。若非具缚。各各长在自聚中。是故得作自根本四句。若处所为见结所系。复为疑结所系耶。乃至广作四句。为见结所系。不为疑结所系者。集智已生灭智未生。见灭见道所断见相应法。见结未断。灭智已生道智未生。见道所断见相应法。见结未断。是名见结所系非疑结所系。所以者何。疑结是一切遍。能缘五种者已断。余不断者于见相应法。非缘系缘无漏故。非相应系。以他聚故。为疑结所系。不为见结所系者。集智已生灭智未生。见灭见道所断疑相应法。疑结未断。灭智已生道智未生。见道所断疑相应法。疑结未断。是名疑结所系不为见结所系。所以者何。见结是一切遍。能缘五种者已断。余不断者。于疑相应法。不缘系。缘无漏故。非相应系。以他聚故。俱系者。具缚见道修道所断法二俱系。具缚见苦所断法。二种见结系。二种疑结系。见集所断修道所断法亦如是。见灭所断见相应法。三种见结系。二种疑结系。疑相应法。三种疑结系。二种见结系。见结疑结不相应法。二种疑结系。二种见结系。见道所断亦如是。苦智已生集智未生。见集见灭见道修道所断法二俱系。苦智已生集智未生。见苦集灭道修道所断法二俱系见苦所断法。一种见结系。一种疑结系。见集所断修道所断亦如是。见灭所断见相应法。二种见结系。一种疑结系。疑相应法。二种疑结系。一种见结系。见结疑结不相应法。一种见结系。一种疑结系。见道所断法亦如是。二俱不系者。广说如经本。乃至离无色界欲。二俱不系。所以者何。彼结若断。处所亦断。若处所有见结系。复有愱结系邪。见结在三界如上说。愱结在欲界。广说如上。若是具缚欲界修道所断法。若为见结所系。亦为愱结所系。若为愱结所系。亦为见结所系。若非具缚见结。长在三界。四种断。愱结长在修道所断。是故得作四句。若处所为见结所系。复为愱结所系耶。乃至广作四句。为见结所系。不为愱结所系者。欲界系见道所断法。见结未断。或有四种未断。或有乃至见道见结未断。色无色界系法见结未断。或有八地见结未断。或有乃至非想非非想处未断。彼非想非非想处。或有四种未断。或有乃至见道见结未断。是名为见结所系不为愱结所系。为愱结所系非见结所系者。欲爱未断。集智已生灭智未生。欲界系修道所断法。愱结未断。乃至见谛具足世尊弟子。欲爱未断。欲界系修道所断法。愱结未断。是名为愱结所系不为见结所系。俱系者。具缚人。欲界系修道所断法二俱系。具系人欲界系修道所断法。一种愱结系。二种见结系。未离欲。苦智已生集智未生。欲界系修道所断法二俱系。一种见结系。一种愱结系。俱不系者。广说如经本。乃至离无色界爱。二俱不系。如见结。愱结见结悭结亦如是。如见结门疑结门亦如是。若处所有取结系。复有疑结系耶。广说应如见结取结。取结疑结亦如是。若处所有取结系。复有愱结系耶。广说如经本。如取结。愱结取结悭结说亦如是

若处所有愱结系。复有悭结系耶。答曰如是。所以者何。此俱在欲界。修道所断。俱缘有漏。俱非一切遍。问曰。如愱因他生。悭因自起。何故。答言。如是耶。答曰。愱缘他亦因他生。缘己不因己生。悭缘己亦因己生。缘他不因他生。复有说者。此二法。缘他亦因他生。缘己亦因己生。问曰。如愱缘他亦因他生可尔。因己亦缘己生。云何可尔耶。答曰。犹如有人。为二比丘。作资生物。一则成好。二不成好。不成好者。便作是念如我所作。或不好使彼所作亦不成好。问曰。如悭缘己亦因己生可尔。缘他亦因他生。云何可尔耶。答曰。悭亦有因他生。犹如有人。见他布施。便生悭心。此人何以施他如是物耶。是故此二亦缘自他生因自他生。若处所有过去爱结系。复有未来爱结系耶。乃至广说。有总相烦恼。有别相烦恼。别相烦恼者。谓爱恚慢愱悭。总相烦恼者。谓无明结见结取结疑结。别相烦恼。系三界五种处所在未来世者。能系三世。过去不定。若前生不断则系。若前不生。生者已断则不系。现在亦不定。若现在前则系。若不现在前则不系。爱结系三界五种处所。未来爱结。系三界五种三世处所。过去不定。若前生不断则系。若前不生。生者已断则不系。现在亦不定。若现在前则系。若不现在前则不系。如爱结。慢结说亦如是。恚结系欲界五种断三世处所。未来恚结系。欲界五种断三世处所。过去不定。若前生不断则系若前不生。生者已断则不系。现在不定。若现在前则系。若不现在前则不系。愱结系欲界修道所断法三世处所。未来愱结。系欲界。系三世修道所断处所。过去不定。若前生不断则系。若前不生。生者已断则不系。现在亦不定。若现在前则系。若不现在前则不系。如愱结。悭结说亦如是。总相烦恼。系三界五种断处所。过去总相烦恼。系三界五种。断三世处所。未来现在说亦如是。此说是历六七人七。略毗婆沙。若处所有过去爱结系。复有未来爱结系耶。答曰。如是取。所以者何。先作是说。未来爱结。系三世处所。设有未来爱结系。复有过去爱结系耶。答曰。若前生不断则系若前不生。生者已断则不系。问曰。若过去爱结断时。即彼时未来爱结亦断。何故未来世定。过去不定。而作是说。若前生不断则系。若前不生生者已断则不系耶。外国法师作如是说。若说前生不断则系。是说中结。若前不生。是说下结。生者已断。是说上结。罽宾沙门复作是说。若说前生不断则系。是说三种结。若说前不生。是说下结。若说生者已断。是说中结上结。如过去上中爱结断。未来亦尔。不生下爱结未来世系处所有未来爱结系。即彼处所。过去前生爱结不断则系。若前不生。生者于余处所生。若前不生若于余处所生。即彼处所生。生者已断则不系

若处所有过去爱结系。复有现在爱结系耶。答曰。现在若现在前。若不起爱结。若起余结现在前。若起善不隐没无记心现在前。若无心。是故说为现在前。设有现在爱结系。复有过去爱结系耶。答曰。若前生不断则系。若前不生。生者已断则不系。若处所有未来爱结系。复有现在爱结系耶。答曰。若现在前。广说如上。设有现在爱结系。复有未来爱结系耶。答曰。如是。所以者何。先作是说。未来爱结系三世法。若处所有过去爱结系。复有未来现在爱结系耶。答曰。未来则系现在。若现在前。广说如上。设有未来现在爱结系。复有过去耶。答曰。若前生不断则系。若前不生生者。已断则不系。前生不断则系者。若处所有未来现在爱结系。即彼处所亦有过去前生爱结者则系。若未来现在爱结处所异。过去已生爱结处所异则不系。若前不生。即于彼处所生者已断则不系。若处所有未来爱结系。复有过去现在爱结系耶。答曰。或有未来爱结系。无过去现在。或有过去。无现在。或有现在。无过去。或有过去现在有未来爱结系无过去现在者。若处所爱结未断。则明未来有爱结系。若前不生。生者已断。则明过去无爱结系。若不现在前。则明现在无爱结系。有过去无现在者。若处所前生爱结未断。则明有过去爱结系。不现在前。则明现在无爱结系。有现在无过去者。若有过去爱结系。则有未来爱结系。有现在无过去者。若处所爱结现在前。则明现在有爱结系。若前不生。生者已断。则明过去无爱结系。若现在爱结系。则有未来爱结系。有过去现在者。若处所有前生爱结系则明有过去爱结系。若处所爱结现在前。则明有现在爱结系。若过去现在有爱结系。未来必有。若处所有现在爱结系。复有过去未来爱结系耶。答曰。未来则系过去。若前生不断则系。若前不生。生者已断则不系。设有过去未来爱结系。复有现在爱结系耶。答曰。若现在前。广说如上。诸别相烦恼。此中略说。如爱结作六句。恚结慢结愱结悭结。非一切遍。无明结作六句亦如是。若处所有过去见结系。复有未来见结系耶。答曰。如是若有未来见结系。复有过去见结系耶。答曰如是。所以者何。先作是说。诸总相烦恼。尽系三世法。未来现在。尽缘三世。广说如经本。见结作六句。诸总相烦恼。此中略说。如见结作六句。取结疑结。是一切遍。无明结作六句亦如是。若处所有过去爱结系。复有过去恚结系耶。答曰。若前生不断则系。若前不生。生者已断则不系。若前生不断则系者。若处所有过去爱结系。即彼处所有过去前生恚结系。若前不生。若于余处生。若生者已断则不系。设有过去恚结系。复有过去爱结系耶。答曰。若前生不断则系。若前不生。生者已断则不系。若前生不断则系者。若处所有过去恚结系。即彼处所有过去前生爱结系。若前不生。若于余处生。若生者已断则不系。若处所有过去爱结系。复有未来恚结系耶。答曰。若不断。云何不断耶。答曰。未离欲爱。设有未来恚结系。复有过去爱结系耶。答曰。若前生不断则系。若前不生。生者已断则不系。若前生不断则系者。若处所有未来恚结系。即彼处所亦有过去前生爱结系。若前不生。若于余处生。若生者已断则不系。若处所有过去爱结系。复有现在恚结系耶。答曰。若现在前。云何现在前。答曰。若不起余结不起善有漏不隐没无记心。若非无心。是名现在前。设有现在恚结系。复有过去爱结系耶。答曰。若前生不断则系。若前不生。生者已断则不系。广说如上

若处所有过去爱结系。复有过去现在恚结系耶。答曰。或有过去爱结系无过去现在恚结系。或有过去无现在。或有现在无过去。或有过去现在有过去爱结系。无过去现在恚结系者。若处所有前生。爱结不断则系。是明有过去爱结系。即彼处所不生前生恚结。生者已断则不系。是明无过去恚结系。不现在前。则明无现在恚结系。或有过去无现在者。若处所前生。恚结爱结不断则系。是明有过去恚结爱结系。无现在则明无现在恚结系。或有现在无过去者。若处所前生。过去爱结不断则系。是明有过去爱结系。即彼处所恚结现在前。则明有现在恚结系。若前不生。生者已断。则明无过去恚结系。或有过去现在者。若处所有过去前生爱结恚结。不断则系则明有过去爱结恚结系。即彼处所恚结现在前。则明有现在恚结系。设有过去现在恚结系。复有过去爱结系耶。答曰。若前生不断则系。若前不生。生者已断则不系广说如上。若处所有过去爱结系。复有未来现在恚结系耶。答曰。余广说如经本。作七句如经本。如爱结恚结。爱结愱结爱结悭结说亦如是。此中差别者应说。欲界系见道所断法。前生爱结。不断则系。爱结慢结爱结无明结。广说如经本。若处所有过去爱结系。复有过去见结系耶。答曰。若不断。云何不断。答曰。若道比智未生。设有过去见结系。复有过去爱结系耶。答曰。若前生不断则系。广说如上。若处所有过去爱结系耶。答曰。若不断。云何不断。答曰。道比智未生。设有未来见结系。复有过去爱结系耶。答曰。广说如经本。作七句亦如经本。如爱结见结作七句。爱结取结爱结疑结作七句。说亦如是

过去爱结。过去恚结。问过去慢结。应作七句。或有说者。七句中。初句应作七句。所以者何。此中问七七句。答曰。七七句故。如先以过去爱结恚结。问过去慢结。次问未来慢结。次问现在。次问过去现在。次问未来现在。次问过去未来。次问过去未来现在。慢结亦应如是说。先以过去爱恚。问未来慢作初句。次问现在。次问过去现在。次问未来现在。次问过去未来。次问过去未来现在。次问过去。作最后句。复以过去爱恚。问现在慢作初句。次问过去现在。次问未来现在。次问过去未来。次问过去未来现在。次问过去。次问未来作最后句。乃至过去爱恚。问过去未来。现在慢作初句。乃至过去爱恚。问过去慢作最后句。若作是说。则有七七句。若作是说。则唐捐其功。于文无益于义无益。亦不成七七句。若欲于文有益于义有益。亦成七七句者。应作是说。如先以过去爱恚。问过去慢作初句。乃至以过去爱恚。问过去未来现在慢作最后句。应以未来爱恚。问未来慢作初句。次问现在。次问过去现在。次问未来现在。次问过去未来。次问过去未来现在。次问过去作最后句。复次现在爱恚。问现在慢作初句。次问过去现在。次问未来现在。次问过去未来。次问过去未来现在。次问过去。次问未来作最后句。乃至以过去未来现在爱恚。问过去未来现在慢作初句。乃至以过去未来现在爱恚。问过去未来现在慢作最后句。若作是说。则于文义有益。七七句成。如爱恚。问慢作七七句。爱恚问无明亦如是。乃至问悭结作七七句亦如是。置爱结。以恚结慢结。问无明结作七七句。乃至问悭结。作七七句亦如是。置恚以慢无明。问见结作七七句。乃至问悭结作七七句亦如是。乃至最后取结。以疑结愱结。问悭结作七七句亦如是。如以二结。问一结作七七句。以三以四以五以六以七以八。问一结作七七句亦如是

问曰。一行历六小七大七。有何差别。答曰。名即差别。复次以一行法作问。名一行。以六句作问名历六。以七句作问名小七。以二结问一结。乃至以八结问一结名大七。复次问不相似法。不以世定。名一行。问相似法。以世定名历六。问不相似法。以世定名小七。以二法问一法。乃至以八法问一法。以世定名大七。一行历六小七大七。是名差别

阿毗昙毗婆沙论卷第三十一阿毗昙毗婆沙论卷第三十二

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    使犍度一行品中

身见摄几使。问曰。何故作此论。答曰。或有说摄法摄他法不摄自法。如毗婆阇婆提。依佛假名所说经。亦依世俗言语法。说摄法摄他法不摄自法。何者是假名所说经。如佛说譬如[怡-台+蓋]斗受入[怡-台+蓋]子。为[怡-台+蓋]子依。以[怡-台+蓋]斗胜故。摄诸[怡-台+蓋]子。彼作是说。[怡-台+蓋]斗异于[怡-台+蓋]子。而摄[怡-台+蓋]子。是故知摄法摄于他法不摄自法。余经亦说。五根慧最胜。为慧所摄。慧异四根。能摄四根。是故知摄他法。余经亦说。如佛问呵德迦居士。汝云何摄眷属。何以复知己摄眷属。居士答言。世尊所说四摄法。布施爱语利益同事。以四法摄于眷属。亦知己摄眷属。彼作是说。居士眷属。及与摄法。各各别异。而能相摄。是故知摄他法不摄自法。余经复说。正见正方便正觉。是慧身所摄。正念正定。是定身所摄。彼作是说。正见是慧。慧身所摄。正定定身所摄可尔。正觉正方便。非慧性。正念非定性。正觉正方便。为慧身所摄。正念为定身所摄者。故知摄法摄于他法。世俗言语法者。世俗亦作是说。户摄户枢。缕能摄衣。索摄薪束。在家之人亦作是说。我能摄我家资财象马僮仆。出家之人亦作是说。我摄衣钵。及摄沙门所用之物。彼以如是假名经所说。及世俗言语所摄法故。知摄法摄他不摄自法。亦明摄法摄于自体。若当摄法。但摄于他不摄自体者。则一法体。与一切法体同。若一法生一切法亦生。一法灭一切法亦灭。复更有过。见苦所断法。则摄修道所断法。见苦所断法若断。修道所断法亦应断。若然者则后生对治。而无有用。欲令无如是过故。说摄法摄于自性不摄他法。问曰。若摄法。但摄自法不摄他者。毗婆阇婆提所引经。及世俗言语法云何通。答曰。彼经是未了义是假名。是有余意

问曰。云何彼经是未了义是假名。是有余意耶。答曰。如经说。[怡-台+蓋]斗受入[怡-台+蓋]子能摄[怡-台+蓋]子者。此中说依持是摄。所以者何。[怡-台+蓋]子依[怡-台+蓋]斗。[怡-台+蓋]斗持[怡-台+蓋]子故。而不散坏如说。五根中慧为最胜。为慧所摄。此中慧是方便说摄。所以者何以慧方便故。五根能有所行。而成大事如说。我以世尊所说四摄法。摄于眷属。乃至广说。此中说不离散是摄。以四摄方便。令眷属不离散故。如说正觉正方便正念。是慧身定身所摄者。此中说随顺是摄。正觉正方便。随顺慧身。正念随顺定身故。如说户摄户枢。缕能摄衣。索摄薪束。此中说持是摄。如说在家出家人。摄田财衣钵等。此中说饶益是摄。摄法摄他法者。或时摄或时不摄。或有所以摄。或有所以不摄如偈说

  因事生于爱　　因事生于恚
  世人起爱恚　　无不因事者

摄法摄自法者。一切时摄皆有所以。一切时摄者。无有不摄自相时皆有。所以者何。自体不待所以故摄法。若观察自相法。还摄自相法时。有何善利耶。答曰。除去我想聚想。能修法想别想。若众生有我想聚想。便生贪恚痴心。生贪恚痴故。于生老病死忧悲苦恼不能得脱。若能除去我想聚想观色。犹如散尘。观无色法。前后不俱总观。有为法离散之相。犹如散沙。便生空解脱门种子。若观诸行空而不乐生死。便生无愿解脱门种子。若不乐生死而求涅槃。便生无相解脱门种子。依下三昧。便生中三昧。依中三昧生上三昧。依上三昧能离三界欲。观察自相法。还摄自相法时。有如是善利。身见摄三使。总而言之。身见摄三使。身见在三界。欲界身见。还摄欲界身见。乃至无色界身见。还摄无色界身见。戒取摄六使。疑摄十二使。余摄如经本说

问曰。云何名摄。答曰。自体于自体。是有是实。是可得故名摄。自体于自体。非异自体。于自体非外。自体于自体非远。自体于自体不相舍。自体于自体非空。自体于自体无盈长。自体于自体。非不已有。非不今有。非不当有。自体还摄自体故名摄。非如手把食指捻衣名摄。以诸法还摄自体名摄。不摄于他

三结摄三不善根耶。三不善根摄三结耶。问曰。何故作此论。答曰。或有说摄法摄于他不摄自体。欲重止如是说者意故。而作此论。三结摄三不善根。三不善根摄三结耶。答曰。各不相摄。余广说如经本

身见令几有相续。问曰。何故作此论。答曰。或有说不染污心。令有相续。如毗婆阇婆提作如是说

问曰。彼何故作此说耶。答曰。依佛经。佛经说菩萨住正智入母胎。住正智住母胎。住正智出母胎。为止如是说者意。欲明唯以染污心令有相续故而作此论。问曰。唯以染污心令有相续者。佛经云何通。答曰。此说不颠倒心名正智。众生皆以颠倒心入母胎唯除菩萨。菩萨入母胎时。有如是念。此是我母。此是我父。于母起母亲爱。于父起父亲敬。以不颠倒心入母胎故名正智

复次所以作此论者

或有说唯以爱恚二结。令有相续。如譬喻者。彼何故作是说耶。答曰。彼依佛经。佛经说三事合故入母胎。一父母有染心共会一处。二其母无病值时。三受身者现在前。当于是时。受身者二种心。展转现在前。若与欲俱。若与恚俱。为止如是说者意。亦明一切结令有相续故。而作此论。问曰。若然者。佛经云何通。答曰。彼说中有心。不说有相续心。或有说。恶道中心。以恚心令有相续。人天中心。以爱心令有相续。为止如是说者意。亦明欲界众生三十六使令有相续。色界三十一使。无色界三十一使令有相续。为止他义乃至广说。而作此论。有亦有多名。如此中说。众生数受身处五阴是有。如说欲界。死生欲界中。一切欲界有相续耶。此中亦说。众生数受身处五阴名有。如说为缠所缠。令地狱有相续。此中亦说。众生数受身处五阴名有。如说欲界有相续时。最初得几业报根。此中亦说。众生数受身处五阴名有。如说有四有。前时有死有中有生有。此中亦如上说。如说舍欲界有。还令欲界有相续时。一切尽灭欲界系法。还起欲界系法现在前。此中亦如上说。如说云何有法。答言。有漏法。是此中说。一切有漏法是有。如说沛仇当知有生时以识为食。此中说。生相续时心眷属名有。如说

佛告阿难。若业能令后生相续是有。是亦名有。此中说造未来有思名有。如说取缘有。阿毗昙者。作如是说。此中说时五阴名有。尊者瞿沙作如是说。造未来有业名有。如说七有。一地狱有二畜生有三饿鬼有四天有五人有六业有七中有。此中说五趣因五趣向。是有五趣有。即是五趣业有。是五趣因中。有是五趣向。如说云何欲有。欲界系取缘。能生未来有业。此中说业业报。不说取缘

问曰。若此中但说业业报。不说取缘者。十门中说。云何通。如说欲有欲界一切使所使。色无色有。色无色界一切使所使。欲界可尔。所以者何。欲界五种断。业尽能生报。色无色界修道所断业能生报。云何可尔。答曰。十门文应如是说。欲有欲界一切使所使。色无色有。色无色界修道所断使。及通一切使所使。而不说者。有何意耶。答曰。此中五种断心。能生有令有相续在有分中。是有眷属而作是说。复有说。十门章中。说业业报。解章义中。说业业报。及说取缘

问曰。若然者。此云何通。如说彼尊者。何故先立章。欲显门义。云何立章义异。解章义异。是故如先说者好

问曰。何故名有。答曰。生灭故名有

问曰。若然者所行道亦生灭可是有耶。答曰。若生灭能令有增广者是有。圣道虽生灭。不令有增广。但令损灭。复次若生灭能令有相续增长生老病死者是有。圣道虽复生灭。能断有相续。不增长生老病死。复次若生灭是苦集道迹是世间生死道迹者是有。圣道虽复生灭。是苦集灭道迹。是世间生死灭道迹。复次若生灭是身见体。是颠倒体。是爱体。是使体。是贪恚痴立足处。杂垢杂毒杂刺杂滓。在有堕苦集谛中者是有。圣道与此相违。不名为有。复次可畏义。是有义

问曰。若然者。涅槃可畏。可是有耶。如说比丘当知。凡夫愚小。闻说涅槃无我无彼无我所须一切诸物。于此法中。生怖畏心。答曰。若畏有者。是正畏涅槃是邪。复次可畏法。凡夫圣人俱畏。涅槃唯凡夫所畏。非圣人所畏。复次是苦器故名有

问曰。此亦是乐器。如说摩诃男当知。若色一向是苦。无有乐分不生喜乐者。众生于色。不应染着。摩诃男。以色非一向苦有少乐分。能生喜乐故众生染着。亦说。有三受。苦受乐受不苦不乐受。亦说。所须是道具。道是涅槃具。亦说所须乐能生道乐。道乐能到涅槃。答曰。生死虽有少乐苦分多。以乐分少故。说名苦分。犹毒瓶。虽一渧蜜堕中。不以一渧蜜故说名蜜瓶。以毒多故。说名毒瓶。身见少分。令欲有相续。少分令色有相续。少分令无色有相续。身见在三界。在欲界者。令欲有相续。在色有者。令色有相续。在无色有者。令无色有相续。戒取疑亦如是。余广说如经本。相续有五种。一中有相续。二生有相续。三时相续。四法相续五刹那相续。中有相续者。死阴灭。次生中阴。中阴续死阴。名中有相续。生有相续者。中阴灭。次生生阴。生阴续中阴。名生有相续。时相续者。迦罗罗时灭。次生阿浮陀时。阿浮陀时。续迦罗罗时。名时相续。乃至中年时灭次生老年时。老年时续中年时。是名时相续。法相续者。善法后次生不善无记法。不善无记法续善法。后不善无记说亦如是。是名法相续。刹那相续者。前生刹那。次生后刹那。后刹那续前刹那。是名刹那相续。此五种相续。悉入二相续相中。谓法相续。刹那相续。所以者何。中有相续。生有相续。时相续。尽是法刹那相续。界中欲界有五种相续。色界有四。除时相续。无色界有三。除中有相续时相续。趣中地狱趣有四。除时相续。余四趣及四生。有五种相续。此中依二种相续而作论。谓中有相续。生有相续。问曰。使能令有相续。非缠是意地。非五识身。何故作如是说。睡眠掉悔鼻触生爱。舌触生爱。令欲有相续。眼触生爱。耳触生爱。身触生爱。令二有相续。少入欲有。少入色有。答曰。此文应如是说。贪欲盖恚盖疑盖。令欲有相续。意触生爱。令三有相续。余盖余触生爱。不能令有相续。若不如是说者。当知此说有余。复次以不断故。说名相续。若不断盖不断鼻触生爱。舌触生爱者。命终还生欲界。若不断眼触生爱耳触生爱身触生爱者。命终生欲界。色界复有三事故。令有相续。一不断。二能生果。三令有相续。使在五识身。不善者有二事。一不断。二能生果。不能令有相续。无记者有一事。不断不能生果。不能令有相续。使在意地。不善者有三事。不断能生果。能令有相续。无记者有二事。不断令有相续。不能生果。缠在意地五识身。不善者有二事。不断能生果。不能令有相续。无记者有一事。不断不能生果。不能令有相续。若有此三事者。能令有相续

身见以何三昧灭。问曰。何故作此论。答曰。欲显佛出世间有如是希有力故。而作此论。施设经。作如是说。阎浮提外。有转轮圣王道。广一由旬。海水覆之。若无转轮圣王时。无有众生能过上者。若转轮圣王出时。海水减一由旬。转轮圣王所行道乃现。以金沙布上。栴檀香水洒之。转轮圣王。欲与四种兵众游巡四天下时。行此道上。如是佛不出世时。无有众生能行根本地。众生虽有离欲者。依于边道。不得根本。若十力转轮法王出世时。根本道尔乃显现。以三十七品金沙布上。以戒定慧栴檀香水。而以洒之。世尊与无量百千万那由他众生。而行其上。至无畏涅槃城。是故欲现佛出世间有如是希有力故。而作此论

身见以何三昧灭。亦可言以何道。亦可言以何对治。亦可言以何正观。如是说者。皆同一义。灭亦可言断。亦可言无欲。亦可言尽。亦可言解脱。如是等说。皆同一义。昔有二大师。一名耆婆罗。二名瞿沙跋摩。尊者耆婆罗。作如是说。此中说毕竟断无余断。一向是圣人。非凡夫人。以无漏道。非世俗道。七依经是此论根本。七依经说根本地。不说边。无有依根本地以世俗道而离欲者。尊者瞿沙跋摩。作如是说。此中说毕竟断无余断。亦有凡夫人亦有圣人。亦世俗道。亦以无漏道。问曰。若然者七依经非此论根本。七依经纯说根本。答曰。以是事故。阿毗昙照明修多罗。其犹如灯。经中所不说者。此中说之。经中所不现者。此中显之。经中有余义者。此中说之。彼二家所说。俱得善通。三结依四依未至。依四依者。依四禅。依未至者。依未至中间。此地名未至问曰。何故名未至耶。答曰。未入根本地。根本地未现在前。而能离欲。名未至地

问曰。未至地不名为依。何故作是说。或依四。或依未至。答曰。此文应如是说。若入四依。若不入四依而灭。而不说者。有何意耶。答曰。欲重说四依名故。如说。或入根本得灭。或不入根本得灭。如人问他男子。汝为入城事得成耶。为不入城事得成耶。三结从欲界。乃至非想非非想处可得。欲界者依未至。初禅者。依初依依未至。二禅者。依二依依未至。三禅者。依三依依未至。四禅及无色。依四依依未至。所以者何。三结是见道所断。必以见道。而毕竟断。见道必在六地。谓未至中间根本四禅。若依未至禅。得正决定三结。则以未至禅灭。若依初禅。得正决定三结。则依初禅灭。若依乃至第四禅。得正决定及无色三结。即依第四禅灭。此中说第四禅及无色三结依四禅及未至贪恚痴及欲漏依未至。所以者何。离欲爱时此法永断。若凡夫人断。依未至断。圣人亦依未至断。世俗道圣道。俱依未至断。有漏或依七。或依未至。七依者。四禅三无色定。未至者。未来中间。有漏从初禅乃至非想非非想处可得。彼非想非非想处。或依未至。而离彼欲。或乃至依无所有处。离彼欲。为无所有处非想非非想处。有漏言七地及未至。初禅地者。或依初依。或依未至。二禅地者。或依二依或依未至。乃至识处。或依六依。或依未至无所有处非想非非想处。或依七依。或依未至。无明漏。或依七依。或依未至七依者。四禅三无色定。未至者。未至中间禅。无明漏。欲界乃至非想非非想处可得。彼非想非非想处无明漏。或依七依。或依未至。总而言之。依七依或依未至。若欲界者依未至。在初禅者依初依。或依未至。乃至识处依六依。依未至。无所有处非想非非想处无明漏。或依七依。或依未至。余广说如经本

诸结过去。彼结已系耶。答曰。若结过去。彼结已系诸结过去。彼得亦过去是也。颇结已系彼结非过去耶。答曰有。未来现在结是也。诸未来现在结。得在过去。诸结生时或如大牛在前而行。或如犊子随后而行。或有俱行。如大牛在前行者。先生结。后生得。如犊子随后行者。先生得。后生结。俱行者。结得俱生。此中说犊子随行法。诸结未来。彼结当系耶。答曰。或结未来。彼结不当系耶。乃至广作四句。云何结在未来。彼结不当系耶。答曰。诸未来结。已断已知已灭已吐。于彼断结心。更不退断者。是断智。知者是智知。灭者是数灭。吐者断不解脱。得解脱。得作证。于彼断结心。更不退者。不退法阿罗汉。未来三界见道修道所断结。已断乃至已吐。彼结更不复系。所以者何。彼是不退法故。若是退法阿罗汉。未来三界见道所断结。已断乃至已吐。彼结更不复系阿那含是不退法者。离无所有处欲。未来三界见道所断结。及修道所断八地结。已断乃至已吐。彼结更不复系。乃至离欲界欲。未离初禅欲。三界见道所断。欲界修道所断法。彼结已断。乃至已吐。更不复系。不退法斯陀含。未来三界见道所断结。及欲界修道所断六种结。已断乃至已吐。更不复系。须陀洹未来三界见道所断结。已断乃至已吐。更不复系。不退法凡夫。如菩萨等离无所有处欲。八地见道修道所断结。已断乃至已吐。更不复系。乃至离欲界欲。一地说亦如是。云何结当系。彼结不在未来耶。答曰。诸结过去已断已知已灭已吐。于彼断结必退。退法阿罗汉。三界过去修道所断结。已断乃至已吐。彼结当系。退法阿那含。离无所有处欲过去八地修道所断结。已断乃至已吐。彼结当系。乃至离欲界欲。未离初禅欲。说亦如是。离无所有处欲。退凡夫人。过去八地见道修道所断结。已断乃至已吐。彼结当系。乃至离欲界欲。未离初禅欲。说亦如上。云何结在未来。彼结当系耶。答曰。诸未来结。已断乃至已吐。彼结必退。广说如过去。云何结不在未来。彼结不当系耶。答曰。诸结过去。已断乃至已吐。彼结必不退。广说如未来。诸结现在。彼结今系耶。答曰。若结现在彼结。今系诸结现在。彼得亦现在。颇结今系。彼结非现在耶。答曰。有诸过去未来结。诸过去未来结。得在现在。系过去者。如大牛行法。现在者。如犊子行法。所可用道断欲界结退。彼道时还得彼结得不耶。问曰。何故作此论。答曰。或有说。无有退法。如毗婆阇婆提。以现喻故。而作是说。今现见瓶破。唯有破瓦。不可还作瓶。如是阿罗汉。以金刚喻定。破诸烦恼。令无有余。不可还成烦恼性。亦如烧木为灰。更无木用。如是阿罗汉。以智慧火。烧诸烦恼。更无烦恼用。以是现喻故。言无退法。为断如是说者意。亦明退法有实体。若言无退法。则违佛经。佛经说有二种阿罗汉。一退法。二不退法。复违余经。如说有五因缘。时解脱阿罗汉退。云何为五。一营事。二多诵。三和斗诤。四远行。五长病。复违余经。如说。尊者瞿醯迦。得阿罗汉。是时解脱。六反退失阿罗汉果。第七反时。畏退此法。以刀自害而死。欲令无如是过故。说退法实有定体

问曰。若退法实有定体者。毗婆阇婆提。说现喻。云何通。答曰。此不必须通。所以者何。此非修多罗毗尼阿毗昙。不可以世间现事过贤圣法。贤圣法异。世间法异。若欲必通。有何意耶。答曰。应说喻过。若喻有过。义亦有过。如瓶破时。有余碎瓦。阿罗汉诸结断时。为有余结。为无有耶。若有余结。是名有结。不名阿罗汉。若无余结。义异喻异。犹如烧木有余灰在。如是阿罗汉诸结尽时为有余结。为无余结。若有余结。不名阿罗汉。若无余结。义异喻异。然木无烧义。木微尘与火微尘作因已灭。火微尘与灰微尘作因已灭。是故作如是说。木是灰因。灰因木生。作烧木想。烧木已有余灰。非无所有。是故喻不似义。如是阿罗汉烦恼尽时。非无本性。在过去未来世中。有相有实体。若与结相违。诸善功德。在彼身中。未生之时。名结不断。若与结相违诸善功德。在彼身中出生之时。彼结名断。如是修圣道时。不令结体使无本性。如是圣道。是希有事。能令阿罗汉断一切结不令此结非无本性。是故尊者瞿沙。作如是说。烦恼不在身中行故名断。如提婆达多。不在舍中。非无提婆达多性。彼亦如是

问曰。毗婆阇婆提。云何通育多婆提所引经耶。答曰。彼作是说。阿罗汉退道不退果。所以者何。果是无为法故。问曰。若然者。虽不退果。而退于道。退于道非是退耶。若退无学道时。为得学道。为不得耶。若得者亦应言退果。若不得者。便有大过。退无学道。不得学道。是时应是凡夫。毗婆阇婆提。复作是说。使是缠种子。使不与心相应。缠与心相应。使能生缠。缠若现在前名退。阿罗汉诸使已断故。不能生缠。云何起缠现在前而退耶。是故彼作是说。言无退法。如是说者好。彼作是说。言无退法者。是无知果。闇果。愚果。不勤方便果。而退法有相有实体。是故为止他义。乃至欲显己义故。而作此论

问曰。退法体性是何。答曰。是不成就性。不隐没无记。心不相应行阴摄。在如是法中。如说。如是等诸法。名心不相应行。退异退法异。退者。是不成就性。如上说。退法是不善法。及隐没无记法。亦如破僧异。破僧罪异。破僧是不和合性。是不隐没无记。心不相应行阴摄。破僧罪是妄语僧。成就不和合破僧人成就罪。如是退异退法异。广说如上。复有说者。若起使若起缠现在前。是退性。若然者。退法性是染污。复有说者。若法随顺退法是退性。若作是说。一切诸法。尽是退性。所以者何。一切诸法。随顺退性故。尊者浮陀提婆。作如是说。退无体性。所以者何。行者本有如是诸善功德。于彼法退失堕落。如人为贼所劫财物。有人问言。汝失财物。体性是何彼答言。无有体性。本有财物。贼劫之去。复有何性。犹如有一人劫衣去。他人问言。汝今失衣。体性是何。彼答言无有体性。所以者何。本有此衣。人劫之去。当有何性。犹如有一人裂其衣。他人问言。汝今衣裂。体性是何。彼答言无有体性。所以者何。衣本是完。他人裂破。当有何性。彼亦如是。评曰。应如上说。退体性是不成就性。乃至广说

问曰。为退已烦恼现在前。为烦恼现在前退耶。若烦恼现在前退者。波伽罗那说云何通。如说。以三事故。起欲爱结。一不断不知欲爱使。二起欲爱具现在前。三不正观。若烦恼现在前退者。此经云何通。如说。有五因缘。时解脱阿罗汉退。若烦恼现在前退者。定犍度说云何通。如说。以非学非无学心退。生学法得。云何是阿罗汉。起烦恼心现在前。何等心次第起烦恼心。若当退已起烦恼者。施设经说云何通。如说或时心远。或时心刚强。以远以刚强故。或时起无色界三缠现在前。谓爱慢无明然多起慢缠。若彼人于无色界。三缠起一一现在前。是人名于无色界欲尽退住色界欲尽中。识身经说复云何通。犹如有一起无色界染污心现在前。是时名舍何善根何善根相续耶。答曰。舍无学善根学善根相续。退无学心。住于学心。波伽罗那经说云何通。如说云何退法。不善隐没无记法。住何等心。烦恼现在前。答曰。应作是论。或有说者。起烦恼现在前退。如是后说善通。波伽罗那说云何通。答曰。此为说烦恼不断者。或有已断烦恼起烦恼现在前。或有未断烦恼起烦恼现在前。此中说烦恼未断现在前者。或有染污心次第起烦恼现在前。或有不染污心次第起烦恼现在前。此中说染污心次第起烦恼现在前者。或有退烦恼现在前。或有不退烦恼现在前。此中说不退烦恼现在前者。复次此中说能起满足烦恼者。以三事故。众生起于烦恼。一以因力。二以境界力。三以方便力。如说不断不知欲爱使者。是说因力。起欲爱具现在前者。是说境界力。不正观者。是说方便力。复次不同外道故。作如是说外道说以境界故烦恼生。若境界坏则无烦恼。为止如是意故。彼尊者说因不正观故烦恼生。佛经云何通。有五因缘。时解脱阿罗汉退。答曰。此中说退具名退。余经亦说。以余法具故说名余法。此亦如是。以退具故名退法。定犍度说云何通。答曰。此中说根退。不说果退。云何阿罗汉起烦恼心。答曰。阿罗汉起烦恼现在前。若起烦恼现在前。便非阿罗汉如凡夫人。起无漏法现在前。若起无漏法现在前。便非凡夫。学人起无学法现在前。若起无学法现在前。便非学人。何等心次第起烦恼心现在前。答曰。毕竟离非想非非想处欲。还起非想非非想处结便退。彼结次第善心后生。若非毕竟离欲者。起非想非非想处结退。彼次第。或起善心。或起染污心。乃至离初禅欲。说亦如是。永断欲界退时。二种心次第生烦恼。谓善心不隐没无记心。若不都离欲界欲。三种心次第生烦恼。谓善染污不隐没无记心。复有说者。退后烦恼现在前。前所说善通。施设经识身经说云何通。答曰。此说不知不觉。而作是说。先退不知不觉。后烦恼起时。乃知乃觉我今退。犹如比丘诵四阿含。不讽诵故。而便忘失。都不觉知。后诵不得。乃知忘失。而非诵时先忘失。诵不得故。而知忘失。彼亦如是。波伽罗那经说。复云何通。答曰。此说减损善法。远于善法。若烦恼数数现在前时。远于善法。住何等心起烦恼现在前。答曰。住不隐没无记心。若威仪。若工巧。非报心。所以者何。报心羸劣故

问曰。羸劣心不能随顺退法耶。答曰。于出要分中心羸劣。烦恼分中心炽盛。是时乃退报心。于二种心中。俱是羸劣。评曰。住威仪功巧报心中尽退。谓欲界不隐没无记心。与三界烦恼心相妨。彼心若现在前时。三界烦恼。不得现在前退。或有与欲色界烦恼相妨。不与无色界烦恼相妨。彼心现在前时。欲色界烦恼不得现在前。若退者。起无色界烦恼现在前。或有与欲界烦恼相妨。不与色无色界烦恼相妨。彼心若现在前。欲界烦恼。不得现在前退。若退者起色无色界烦恼乃退。或有不与三界烦恼相妨者。彼心若现在前时。三界烦恼。展转现在前。若不得净禅净无色得者。谓现前行得。彼不能以色无色界烦恼现前退。若退者起欲界烦恼退。若得净禅得者。谓现前行得。不得净无色定。彼不能起无色界烦恼退。若退者起欲界烦恼退。若得净禅净无色。若得者。谓现前行得。若退者。能起三界烦恼。展转现在前

问曰。退时为住意地退。为住五识身退耶。答曰。住意地退。非五识身。问曰。若住意地非五识身者。优陀延王因缘云何通。曾闻。优陀延王。将诸宫人婇女。诣郁毒波陀山林。除却男子。纯与女人五乐自娱。其音清妙。烧众名香。时诸婇女或有裸形而起舞者。尔时有五百仙人。以神足力。飞腾虚空。经过彼处。时诸仙人眼见色。耳闻声。鼻嗅香。便失神足。犹无翼鸟。堕彼林中。时王见之。而问言。汝等是谁。诸仙答言。我是仙人。王复问言。诸贤。汝得非想非非想处定耶。答言。不得。乃至问言。汝得初禅耶。答言。曾得而今已失。时王嗔恚作如是言。有欲之人。见我宫人婇女。非其所以。便拔利剑。断五百仙人手足。彼诸仙人。或有住眼识退者。或有住耳识退者。或有住鼻识退者。忧陀罗摩子因缘。复云何通。曾闻忧陀罗摩子有王。常施其食。若食时至。以神足力。犹如雁王。飞腾虚空。诣于王宫。时王即时躬自迎。抱坐金床上。以诸仙人所食之味。而供养之。时彼仙人。饭食已竟。除器澡漱。说偈咒愿。飞空而去。是王后时以国事故。欲诣余处。作是念。若我行后。无人如我常法给事仙人。仙人性躁。或起嗔恚而咒咀我。或失王位。或断我命。便问其女。作如是言。仙人若来如我常法。汝能供养不。女答言能。时王重约敕女。尽心奉养。然后乃行。营理国事。后日食时。仙人从空飞行而来。时王女。如父王法。躬身迎抱坐金床上。王女身体细软。仙人离欲。而复鲜薄。相触女时。退失神足。饭食讫除器澡漱。说偈咒愿。欲飞空去而不能飞。时王宫中。有后园林。即入其中。欲修神足。耳闻象马车乘之声而不得修。时彼城中人民恒作是念。若令大仙在地行者。我等当得亲近礼足。尔时仙人。聪明黠慧。善知方便。语王女言。汝今宣告城中人民。今日大仙。当从王宫步行而出。汝等人民。所应作者皆悉作之。时彼王女如其所敕。即便宣告城中人民。是时人民。即时除去城中街陌瓦砾粪秽。悬诸幡盖烧众名香。散种种华。严饰鲜洁。犹如天城。是时仙人步行而出。去城不远入林树间。欲修神足。闻众鸟声。修不能得。便舍林树。复诣河边。以其本法欲修神足。复闻水中鱼鳖回转之声。而不得修。便上山上作是思惟。我今所以退失善法。皆由众生。凡我所有善法净行苦行。使我当作如是众生。能害世间所有地行飞行水性众生。无免我者。发是恶誓愿已。离八地欲生非想非非想有顶处。开甘露门。寂静田中。八万劫中。处闲静乐。业报尽已。还生此间答波树林昙摩阿兰若处。作着翅狸。身广五十由旬。两翅各广五十由旬。其身量百五十由旬。以此大身。杀害空行水陆众生无得免者。身坏命终。生阿毗地狱。如是等住身识时退。帝释因缘复云何通。曾闻佛未出世时。天帝释常往诣提波延那仙人所听法。帝释后时。乘宝饰车。欲诣仙人。是时帝释阿修罗女。舍芝夫人。作是念。今者帝释。舍我欲诣。诸余婇女即隐其形上车上。帝释不知乘。到仙人所。顾视见之。而问言。汝何故来。仙人今者。不欲眼见女人。汝可还宫。尔时舍芝不欲还去。帝释以莲华茎打。时舍芝夫人。以女人软美之音。而谢帝释。仙人闻已。起如是欲爱。而现在前。令其须发。即时落地。如是等住耳识而退。若住意识。不住五识退者。如是等诸因缘云何通。答曰。如是等说。皆先依五识生于意识。然后乃退。尊者僧伽婆修。作如是说。住五识身亦退。所以者何。眼见色能生烦恼。乃至身触触能生烦恼。以其对治羸劣故。眼见色便退。乃至身触触便退。评曰。应作是说。住意地退。不住五识。所以者何。意地有六事。不与五识共。一退。二离欲。三死。四生。五断善根。六还令相续

阿毗昙毗婆沙论卷第三十二阿毗昙毗婆沙论卷第三十三

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    使犍度一行品下

退有三种。一得退。二不得退。三不现前行退。得退者。得诸善功德而退。不得退者。一切众生。若勤方便。皆应得圣慧眼。以贪著名色故。不勤方便。是名不得退。如偈说

  一切天世人　　皆应得慧眼
  贪著名色故　　不得见真谛

又如偈说

  愚小众所敬　　是则名失利
  亡失诸善法　　是名为顶堕

世尊为提婆达多故。而说此偈。彼已起暖善根不久当得顶法。于其中间。贪着利养故。于善法退。如是名不得退。不现前行退者。已得善法。不现前行。如佛不起佛菩提现在前。辟支佛不起辟支佛菩提现在前。声闻不起声闻菩提现在前。是名不现前行退。问曰。此三种退。几是佛几是辟支佛几是声闻。答曰。佛有一种退。谓不现前行退。本得善法。不现前行故。无不得退。所以者何。于一切众生中。得最胜根故无得退。所以者何。非是退法故。辟支佛有二种退。一不得退。二不现前行退。不得退者。不得佛根故。现前行退者。本得善法。不现前行故无得退。非是退法故。声闻是非时解脱者。有二种退。一不得退。二不现前行退。不得退者。不得佛辟支佛根故。不现前行退者。本得善法。不现前行故。无得退者非退法故。时解脱阿罗汉。有三种退。得退者。先得善法而退。不得退者。不得三种根。现前行退者。先得善法。不现前行。复有说者。佛世尊无一种退。无得退。非是退法故。无不得退。以住一切众生中最胜根故。无现前行退。所以者何。佛于无数阿僧祇劫。集诸难行苦行。皆欲为众生说法故。无有少时不为众生。辟支佛有一种退。先得善法。不现前行。无得退。非退法故。无不得退。若于辟支佛。根已定。无求佛根故。非时解脱阿罗汉。有一种退。先得善法。不现前行。无得退。非退法故。无不得退。若于非时解脱根已定。不求辟支佛。佛根故。时解脱。有二种退。得退者。先得善法而退。现前行退者。先得善法。不现前行。无不得退。若于时解脱根已定。则不求上三种根故。评曰。应作是说。佛世尊有一种退。谓现前行退。辟支佛有二种退。谓现前行退。不得退。非时解脱阿罗汉亦如是。时解脱阿罗汉。有三种退。谓得退。现前行退。不得退。问曰。云何知佛世尊有现前行退。答曰。依佛经故。如经说。佛告阿难。如来有四种增上心。受现法乐。于此四心。展转有退。如诸弟子聚会为说法时。若不动法心得解脱。身作证。不说有退。问曰。此中为说现前行退。为说得退。若说现前行退者。不动法心得解脱。亦应有退。所以者何。不能一切时令不动法常现在前。若说得退者。四种增上心。亦不应退。所以者何。如来是不退法。应作此论。是现前行退。问曰。若然者。不动法心得解脱。亦应有退。答曰。不动法心得解脱者。以得为胜。若得彼法。更无所作。增上心。以现前行为胜。若不现在前。便言是退。复有说者。若依未至。是说不动法。若依根本禅。是说增上心。如来依未来现在前多。若食时若食后。为他说法时。说法已。欲入定时。如来虽于禅定速疾。于未至禅速疾。胜根本禅。犹如疾行之人。于行法疾。然近处疾。胜于远疾。复次自利益。是说增上心。利益他。是说不动。如来利益他多。自利益少。复次慈悲是说不动。喜舍是说增上。如来多起慈悲。少起喜舍。复次大悲是说不动。大舍是说增上心。如来多起大悲。少起大舍。尊者瞿沙说曰。永断一切结。是说不动。如来一切时。彼得现在前。问曰。若佛世尊。有现前行退。有现前行退。佛多。辟支佛多。声闻多耶。答曰。如来现前行退多。非声闻辟支佛。所以者何。若如来一刹那顷现前行退。胜辟支佛声闻尽其形寿退。以如来有广大无边甚深明净幽隐之法。譬如王四天下转轮圣王。若于一日。离自国土。胜于小王尽其形寿离自国土

定揵度作如是说。以何等故。阿罗汉果退。阿那含果退。斯陀含果退。非须陀洹果耶。答曰。即彼文说。见谛所断法。缘无所有。云何缘无所有。答曰。因无法起。云何因无法起。答曰。因于我起实义中无有我。修道所断法。缘于有法。云何缘于有法。答曰。因于有起。云何因于有起。答曰。因净故。净有少净。如发爪齿唇形色净。等观此法。作净想故。于不净法退。无有法少分。是我我所。而计于我。观此法时。无有于无我法退。是故不退。复次断三界见道所断烦恼。名须陀洹果。无有能退须陀洹果者。复次断非想非非想处见道所断烦恼名须陀洹果。无有能退非想非非想处见道所断烦恼者。此因论生论。以何等故。无有能退非想非非想处见道所断烦恼。答曰。非想非非想处烦恼。难断难破难过。以难断难破难过故。还令相续亦难。复次以忍作对治。断缘无所有烦恼。名须陀洹果。无有退忍作对治断缘无所有烦恼者。复次以见道。能到须陀洹果。无有能退见道者。如是因论生论。以何等故。无有能退见道耶。答曰。见道是速疾道。不起道。无有势力起彼道者。复次行者入见道名入大法河大法流中。犹不能起善不隐没无记心现在前。何况染污心。譬如有人。堕山间河峻流之中。犹不能据彼此岸。何况能渡。彼亦如是。复次见道是三界。见道所断对治法。无有能退三界见道所断烦恼者。复次见道是非想非非想处见道所断对治。无有能退非想非非想处烦恼者。复次见道。是忍作对治。断缘无所有烦恼。无有能退忍作对治断缘无所有烦恼者。问曰。若退阿罗汉果。住须陀洹果时。当言退斯陀含果阿那含果不耶。答曰。当言退。譬如有人。从三重屋上。堕至于地。当言此人堕三重屋。彼亦如是。问曰。彼二沙门果。本不成就。何以言退。答曰。以不成就。复不成就故。云何以不成就。复不成就。答曰。本远今复远故。复次以断尔所结故。名斯陀含果阿那含果。以退结故。果亦名退。复次诸烦恼。以斯陀含果阿那含果为对治。彼烦恼本得成就。成就烦恼故。彼对治名退。复次以无碍解脱道。能到斯陀含果阿那含果。于彼道退果亦名退。复次斯陀含果。阿那含果。是阿罗汉果。因阿罗汉果。若退彼果。因亦名退。问曰。须陀洹果。亦是阿罗汉果。因阿罗汉果。亦是彼果。何以退彼果时。不退因耶。答曰。须陀洹果前。更无有果。若彼退时。更无住处。若当退须陀洹果者。本是见谛。今非见谛。本是得果。今非得果。本是决定。今非决定。本是圣人。今非圣人。欲令无如是过故。说须陀洹果不退

退根本沙门果不命终。果中间退命终。问曰。何故退根本沙门果不命终。果中间退命终耶。答曰。以易见易施设。谓此是须陀洹果。乃至谓是阿罗汉果。果中间。不易见。不易施设。复次行者是时于果。生大悦适。譬如农夫。于六月中。修治田业后获子实。积聚场上。心大悦适。彼亦如是复次是时有三事故。一得未曾得道。二舍曾得道。三断烦恼。同于一味。复次是时有五事。一得未曾得道二舍曾得道。三断烦恼同于一味。四顿得八智。五修十六行。复次是时是止息处。最胜止息处。复次是时断结事事成。道方便方便成。果中间断结事未成。道方便未成。复次是时容广修道。果中间不容广修道。复次行者是时善知功德过恶。知功德者。是道道果。知过恶者。是生死法。复次行者是时善取相貌。如人道中行时。不能善取四方相貌。若坐一处。则能善取四方相貌。彼亦如是。复次行者是时有随从知见者。犹如有人。于村落中间。为人所劫。无有随从知见者。若在村落。为人所劫。多有随从知见者。复次行者。是时先广修方便道。立足处牢固。须陀洹果。广修方便道者。先为解脱故。修施持戒。闻慧思慧修慧。暖顶忍世第一法。见道中十五心顷是也。斯陀含果广修方便道者。如上说。诸善复更有未曾有者。离欲界欲方便道六无碍道五解脱道是也。阿那含果广修方便道者。如上说。诸善复更有未曾有者。离欲爱时。方便道三无碍道二解脱道是也。阿罗汉果。广修方便道者。如上说。诸善复更有未曾有者。离初禅欲时。方便道九无碍道九解脱道。乃至离无所有处欲。说亦如是。离非想非非想处欲时。方便道九无碍道八解脱道是也。复次行者是时断一切生分。止一切生分。须陀洹除欲界七生分。色无色界一一生处。除一生分。余一切生分。得非数灭。斯陀含除欲界二生分。色无色界一一生处。除一生分。余一切生分。得非数灭。阿那含色无色界一一生处。除一生分。余一切生分。得非数灭。阿罗汉一切生分。得非数灭。复次行者是时顿证三界见道修道所断烦恼。须陀洹顿证三界见道所断烦恼。斯陀含顿证三界见道所断烦恼及欲界修道所断六种烦恼。阿那含顿证三界见道所断烦恼及欲界修道所断九种烦恼。阿罗汉顿证三界见道修道所断烦恼。以如是等事故。根本沙门果。退不命终。果中间退者命终。离欲界欲。乃至离无所有处欲。得正决定。若退者。以上地烦恼退。问曰。何故退上地烦恼。不退下地者耶。答曰。下地烦恼。以为二种对治所害故。不能更生。复次彼烦恼断已。更有重见道法堕上。堕上故不能更生。如人偃卧在地。大山堕上。犹不能动。何况能起。复次彼结断已。生于忍智。无有退忍智者。复次彼结断已。生法智比智。无有毕竟退法智比智者。复次彼结断已。生世第一法。无有退世第一法者。复次彼结断已。生增上忍。无有退增上忍者。复次凡夫人离欲界欲。乃至离无所有处欲。从欲界乃至无所有处。见道修道所断烦恼。合集如刈草法。作九种一时断。后得果时。于对治退。当言成就见道所断结不耶。若成就者。无有圣人退见道所断结者。若不成就者。云何烦恼同一对治断。于彼对治退。或有成就。或不成就。此事云何可尔

当得阿罗汉果住金刚喻定时。成就下下烦恼。若退阿罗汉果时。还成就非想非非想处下下烦恼。为成就金刚喻定不。答曰。不成就。问曰。何故当得阿罗汉果住金刚喻定时。成就下下烦恼。若退阿罗汉果时。成就下下烦恼。不成就金刚喻定耶。答曰。金刚喻定。多用功多用方便。然后乃得。下下烦恼。不多用功。不多用方便。而现在前。复次金刚喻定。胜进时得。下下烦恼。退失时得。复次金刚喻定。与下下烦恼。不妨成就。妨现前行。下下烦恼。与金刚喻定。妨成就妨现前行。如金刚喻定。与下下烦恼。不妨成就。如是住金刚喻定。成就下下烦恼。如下下烦恼。与金刚喻定。妨成就。亦妨现前行。如是住下下烦恼。不成就金刚喻定。复次金刚喻定。是无碍道。无有住无碍道退者。亦无退已住无碍道者。皆住解脱道胜进道而退。得已还住解脱道胜进道

问曰。于何处退。答曰。界者在欲界。非色界。非无色界。趣者在人趣非余趣。问曰。何故六欲天中无退耶。答曰。彼处无退具故。问曰。彼处非不多诸退具耶。答曰。佛经中所说退具。彼中无。然诸天得果者。多是利根。利根者不退。问曰。若钝根者。人中得果。后生六欲天上。在彼退耶。答曰。不退。所以者何。圣人易世。不退不转根。不生色无色界。所以者何。圣道在彼身中。旧住牢固故

问曰。何等人退。何等人不退耶。答曰。或有信他随他。或有自信自欲。若信他随他。入圣道者退。自信欲入圣道者不退。复次或有广因力广方便力广不放逸力。或有不尔。若广者不退。不尔者退。复次或有以信入圣道者。或有以慧入圣道者。若以信入圣道者退。若以慧入圣道者不退。如以信以慧以奢摩他毗婆舍那。可定可慧。修定修慧。得定得慧。得内心定不得慧。得慧不得内心定。住坚信法。住坚法法。钝根利根。缘力因力。内枝力外枝力。内正思惟。从他闻法。当知亦如是。复次或有不贪多者。或有不愚多者。不贪多者退。不愚多者不退。复次或有心善解脱慧善解脱。或有心善解脱慧不善解脱。若心善解脱慧善解脱者不退。若心善解脱慧不善解脱者退

问曰。退者经几时。答曰。经少时不久。乃至不自知退。若自知退。便修胜进方便。复次彼烦恼现在前时。心生惭愧故。速修方便。如明目人昼于平地而便颠蹶。寻即还起。四方顾视。无见我者不耶。如是行者烦恼起时。心生惭愧。若佛若佛弟子。若诸善人。无见我者不耶。复次彼烦恼现在前时。身心生热。欲令烦恼热速灭故。寻修方便。犹如软身体人小火堕上。寻即除却。彼亦如是。复次烦恼臭秽在身。不堪忍故。寻修方便。犹如好净之人。有少不净堕于身上。寻即除却。彼亦如是。复有说者。此事不定。或有久者。乃至令根猛利。信解脱为见到。然后得阿罗汉果

问曰。若退阿罗汉果已。阿罗汉所不应作者。彼人作耶。退阿那含斯陀含果已。阿那含斯陀含所不应作。彼人作耶。答曰不作。所以者何。得果人所作所行。异于凡夫故

阿罗汉有六种。一退法。二忆法。三护法。四等住。五能进。六不动。退法者退。忆法者。心生厌忆。持刀欲自害。护法者于已解脱。心生爱乐。善守护故。等住者。不退不进。能进者能进至不动。不动者住本根不动。问曰。退法阿罗汉。必退耶。忆法者。必忆法耶。护法者。必护法耶。等住者必等住耶。能进者必能进至不动耶。答曰。或有说者。退法必退。乃至能进者必能进至不动。以是事故名退。乃至名能进。若作是说。退法必退。乃至能进者。必能进者。以有六事故。阿罗汉有六。欲界有六。色无色界有二。谓等住不动若作是说。退法阿罗汉不必退乃至能进者。不必能进至不动。问曰。若然者。何故名退。乃至名能进耶。答曰。退阿罗汉不必退若退者。是退性。乃至能进不必能进。若能进者。是能进性。若作是说。退法者不必退。乃至能进者不必能进。以有六性故。有六种阿罗汉。如是说者。欲界有六种。色无色界亦有六

问曰。云何立六种阿罗汉耶。答曰。以根故。问曰。根有九种。上上至下下。先说阿罗汉有六种。云何以根故阿罗汉有九种。答曰。或有说者。退法阿罗汉。成就二种根。下下下中。忆法成就下上根。护法成就中下根。等住成就中中根。能进成就中上根。不动成就上下根。辟支佛成就上中根。佛成就上上根。彼不应作是说。无有一人成就二种根者。利根者尚不能。何况钝根。评曰。应作是说。退法阿罗汉。成就下下根。忆法下中。护法下上。等住中下。能进中中。不动有二种。有从时解脱至不动。有性不动。从时解脱至不动者。中上本性。不动者上下。辟支佛上中。佛上上

退法阿罗汉作一事。唯退。忆法阿罗汉作二事。退法忆法。护法阿罗汉作三事。退法忆法护法。等住阿罗汉作四事。退法忆法护法等住。能进阿罗汉作五事。退法忆法护法等住能进。复有说。退法阿罗汉有三事。一退住学根。二转至胜根。三即住般涅槃。忆法阿罗汉有四事。一退住学根。二退住退法根。三转至胜根。四即住般涅槃。护法阿罗汉有五事。一退住学根。二退住退法根。三退住忆法。四转至胜根。五即住般涅槃。等住阿罗汉有六事。一退住学根。二退住退法根。三退住忆法。四退住护法。五转至胜根。六即住般涅槃。能进罗汉有七事。一退住学根。二退住退法根。三退住忆法。四退住护法。五退住等住。六转至不动。七即住般涅槃。问曰。忆法阿罗汉。退住学根。为得何等学根。为得退法学根。为得忆法学根耶。答曰。得退法学根。非忆法学根。所以者何。彼未曾得忆法学根故。若得者是名为进。不名为退。世尊经说。尊者瞿醯迦。是时解脱阿罗汉六反退。第七反还得时解脱身作证。以刀自害而死。问曰。彼尊者瞿醯迦。为是退法性。为是忆法性。若是退法性者。何故以刀自害。若是忆法性者。何故六反退耶。答曰。应作此论。是退法性。问曰。何故以刀自害。答曰。厌患退故。以刀自害。若不退以刀自害者。是忆法

所可用道。断欲界结。退彼道时。还得彼结得不耶。答曰。还得彼结得。诸结得离欲时断。退时还得彼结得。所可用道。断色无色界结。退彼道时。还得彼结得不耶。答曰。还得彼结得。诸结得离欲时断退时还得彼结得。问曰。所可用断结道。于彼道不退。所可用退道。彼道不能断结。无碍道能断结。无有退无碍道者。住解脱道退。无有以解脱道断结者。何故作是说。所可用道。断欲界结。退彼道时。还得彼结得。广说如上。答曰。无碍道。是解脱道因。解脱道。是无碍道果。若于果退时。亦应言因退。复次烦恼以无碍道对治。若成就彼烦恼时。亦当言退彼对治道。复次以烦恼故。立断烦恼无碍道。若成就烦恼时。亦当言退彼无碍道。尊者僧伽婆修说曰。住无碍道退。住解脱道亦退。所以者何。断五种结。须陀洹退时。彼非是退五无碍道五解脱道耶。评曰。应作是说。无有住无碍道退退已住无碍道者。退解脱道。还住解脱道

九断智。欲界系苦集所断结断一断智。色无色界苦集所断结断二断智。欲界见灭所断结断三断智。色无色界见灭所断结断四断智。欲界见道所断结断五断智。色无色界见道所断结断六断智。五下分结断七断智。色爱断八断智一切结断九断智。问曰。九断智摄一切断智。一切断智摄九断智。广说如经本。断者是无为。问曰。若断者是无为。不能有所缘。何故断是智耶。答曰。断是智果故说智。业果说业。如说。六入是旧业。天眼天耳是通果说通。阿罗汉是智果说智如是智果故说断智。问曰。若然者。修道所断结。以智断故是智果。可言断智。见道所断结。以忍断是忍果。云何言断智耶。答曰。彼是世俗智果故言断智。如先以世俗道。离欲界欲。乃至离无所有处欲。八地中所断结断。是世俗智果。问曰。若然者。世俗道。能有所作处可尔。非想非非想处世俗道。不能有所作。非想非非想处见道所断结断是忍。云何是断智耶。尊者僧伽婆修说曰。此是慧果说断智。断有二种。一是慧果。彼不应作是说。所以者何。佛经说二智。一知智。二断智。不说断慧。评曰。应作是说。实义智者。是金刚喻定。断是彼果。所以者何。得阿罗汉果时。以金刚喻定。断三界见道修道所断结。顿证解脱得故。复有说者。从智种中生故名断智。如瞿昙姓中生故名瞿昙。彼亦如是。复次彼断性相是断智。彼断虽不能有所缘。而性相是断智。说名断智。如过去未来眼根。虽不能见。而性相是眼。彼亦如是。尊者瞿沙说曰应言正断是最胜断相应断毕竟断。尊者波奢说曰。应言弃断。所以者何。弃一切生死。得此断故。此断亦可言断。亦可言无欲。亦可言灭。亦可言谛。亦可言断智。亦可言沙门果亦可言有余涅槃界无余涅槃界。苦法忍灭苦法智生。是时彼断名断名无欲。名灭名谛。不名断智。不名沙门果。不名有余涅槃界无余涅槃界。苦比忍灭苦比智生。是时彼断。名断。乃至名谛。不名断智。不名沙门果。不名有余涅槃无余涅槃界。集法忍灭集法智生。是时彼断。名断名无欲名灭名谛名断智。谓欲界见苦见集所断结尽断智。不名沙门果。不名有余涅槃无余涅槃界。集比忍灭集比智生。是时彼断名断名无欲名灭名谛名断智。谓色无色界见苦见集所断结尽断智。不名沙门果。不名有余涅槃无余涅槃界。灭法忍灭灭法智生。是时彼断。名断名无欲名灭名谛名断智。谓欲界见灭所断结尽断智。不名沙门果。不名有余涅槃无余涅槃界。灭比忍灭灭比智生。是时彼断。名断名无欲名灭名谛名断智。谓色无色界见灭所断结尽断智。不名沙门果。不名有余涅槃无余涅槃界。道法忍灭道法智生。是时彼断。名断名无欲名灭名谛名断智。谓欲界见道所断结尽断智。不名沙门果。不名有余涅槃无余涅槃界。道比忍灭道比智生。是时彼断。名断名无欲名灭名谛名断智。谓色无色界结尽断智。名沙门果。谓须陀洹果。不名有余涅槃无余涅槃界。是时三界见苦见集见灭。及欲界见道所断结同一味。顿证解脱得。是时彼断。名断名无欲名灭名谛名断智。名沙门果。谓须陀洹果。不名有余涅槃无余涅槃界。须陀洹当得斯陀含果。断一种结。乃至五种结。是时彼断。名断名无欲名灭名谛。不名断智不名沙门果。不名有余涅槃无余涅槃界。第六无碍道灭。第六解脱道生。是时彼断。名断名无欲名灭名谛。不名断智名沙门果。谓斯陀含果。不名有余涅槃无余涅槃界。是时三界见道所断。彼断名断。名无欲名灭名断智。谓先所得断智。名沙门果。谓斯陀含果。不名有余涅槃无余涅槃界。欲界修道所断五种结同一味。顿证解脱得。是时彼断名断。名无欲名灭名谛。不名断智名沙门果。谓斯陀含果。不名有余涅槃无余涅槃界。斯陀含当得阿那含果。断第七第八种结时。彼断名断。名无欲名灭名谛。不名断智不名沙门果。不名有余涅槃无余涅槃界。第九无碍道灭。第九解脱道生。是时彼断。名无欲名灭名谛名断智。谓五下分结尽断智。名沙门果。谓阿那含果。不名有余涅槃无余涅槃界。即彼时三界见道所断结。及欲界修道所断九种结同一味。顿证解脱得。是时彼断名无欲。名灭名谛名断智。谓本得断智五下分结尽断智。名沙门果。谓阿那含果。不名有余涅槃无余涅槃界。离初禅欲。断一种结。乃至断九种结。是时彼断。名断名无欲名灭名谛。不名断智。不名沙门果。不名有余涅槃无余涅槃界。乃至离第四禅欲。断一种结。乃至断八种结。说亦如是。第九无碍道灭。第九解脱道生。是时彼断。名断名无欲名灭名谛名断智。谓色爱断断智。不名沙门果不名有余涅槃无余涅槃界。离空处欲。乃至离非想非非想处。断八种结。是时彼断。名断名无欲名灭名谛。不名断智不名沙门果不名有余涅槃无余涅槃界。金刚喻定灭。初尽智生。是时九种结断。彼断名断名无欲名灭名谛名断智。谓一切结尽断智。名沙门果。谓阿罗汉果。名有余涅槃界。不名无余涅槃界。即彼时三界见道所断。八地修道所断。非想非非想处修道所断。八种结同一味。顿证解脱得。是时彼断。名断名无欲名灭名谛名断智。谓一切结尽断智。名沙门果谓阿罗汉果名有余涅槃界。不名无余涅槃界。若阿罗汉阴界入。更不相续。入无余涅槃界。是时彼断。名断名无欲名灭名谛名断智。谓所得断智。名沙门果。谓阿罗汉果。不名有余涅槃界。名无余涅槃界

问曰。诸断是无为。何以有时名断智。有时不名断智。答曰。尔时。或有四事。或有五事者。名断智。四事者。一害俱因。二俱系得解脱。三得无漏解脱得。四害非想非非想处一切遍使。五事者。即上四事。五永断于界。见道中有四事。修道中有五事。苦法忍灭。苦法智生。是时不害俱因。虽害见苦所断不害见集所断。不俱系得解脱。虽见苦所断系得解脱。见集所断不得解脱。虽得无漏解脱不害非想非非想处一切遍使。是时唯有一事无二事。是故彼断。名断不名断智。苦比忍灭。苦比智生。是时不害俱因。虽断见苦所断因。不害见集所断因。不断俱系虽断见苦所断系。不断见集所断系。虽得无漏解脱得。而不毕竟害非想非非想处一切遍使。是时唯有二事。无有三事故。彼断不名断智。集法忍灭。集法智生。是时害俱因。先害见苦所断因。今害见集所断因俱系得解脱。先见苦所断得解脱。今见集所断得解脱。得无漏解脱得。亦害非想非非想处一切遍使。是时得名断智集比忍灭。集比智生。是时害俱因。先害见苦所断因。今害见集所断因。俱系得解脱。先见苦所断系得解脱。今见集所断系得解脱。得无漏解脱得。害非想非非想处一切遍使。是时具四事故。彼断名断智。灭法忍灭。灭法智生。是时害俱因。先害见苦见集所断因。今害见灭所断因俱系得解脱。先见苦见集所断系得解脱。今见灭所断系得解脱。得无漏解脱得。害非想非非想处一切遍使。是时具四事故。彼断名断智。灭比忍灭。灭比智生。道法忍灭。道法智生。道比忍灭。道比智生。说亦如是。如是则说见道断智。修道中有五事名断智。离欲界一种欲。乃至离八种欲。是时不害俱因。虽断八种因。不断下下因。所以者何。九种结展转为因故。俱系不得解脱。虽八种系得解脱。一种系不得解脱。所以者何。九种结展转相系故。虽得无漏解脱得害非想非非想处一切遍使。而不永离界。是时唯有二事无三事。是故彼断不名断智。断第九种结。是时害俱因。先断八种因。今断下下因。俱系得解脱。先八种系得解脱。今下下系得解脱。得无漏解脱得。害非想非非想处一切遍使。毕竟离界。谓离欲界。是时有五事故。彼断名断智。离初禅欲断一种结。乃至断八种结。广说如欲界断第九种时。害俱因。先断八种因。今断下下因。俱系得解脱。先八种系得解脱。今下下系得解脱。得无漏解脱得。害非想非非想处一切遍使。而非毕竟离界。是时唯有四事无五事。是故彼断不名断智。第二第三禅。说亦如是。离第四禅欲。断一种结。乃至断八种结。不害俱因。俱系不得解脱。虽得无漏解脱得害非想非非想处一切遍使。而不毕竟离界。是时唯有二事无三事。是故彼断不名断智。断第九种结。时害俱因。俱系得解脱。得无漏解脱得。害非想非非想处一切遍使。毕竟离界。是时有五事故。彼断名断智。谓色爱尽断智。如离初禅欲。乃至离三禅欲。离空处欲。乃至离无所有处欲。说亦如是。离非想非非想处欲。断一种结乃至断八种结时。不害俱因。俱系不得解脱。虽得无漏解脱得害非想非非想处一切遍使。而不毕竟离界。是时唯有二事而无三事。是故彼断不名断智。断第九种结。是时害俱因。俱系得解脱。得无漏解脱得。害非想非非想处一切遍使。毕竟离界。是时有五事故。彼断名断智。谓一切结尽断智。问曰。为离四禅修道所断爱名断智。为唯离第四禅修道所断爱名断智耶。答曰。或有说。离四禅爱名断智。复有说离第四禅九种爱名断智。复有说唯离第四禅下下种爱名断智。评曰。应作是说。离色界一切修道所断爱名断智。所以者何。若离第四禅下下爱色界一切修道所断爱尽。乃名断智。问曰。断法是最胜法。何故二断得通证。谓阿那含阿罗汉果时。答曰。此二时毕竟离界亦得果。得须陀洹果斯陀含果时。虽得果不毕竟离界。离第四禅欲。虽毕竟离界。而非得果。得阿那含果时。毕竟离界。谓离欲界得果。得阿那含果。得阿罗汉果时。毕竟离界。谓离无色界得果得阿罗汉果时。复次是时毕竟离界。断下分上分结。得须陀洹果斯陀含果时。不毕竟离界。不断下分上分结。离色爱时。虽毕竟离界。谓离色界不毕竟断上分结。得阿那含果时。毕竟离界。谓离欲界。毕竟断下分结。得阿罗汉果时。毕竟离界。谓离无色界。毕竟断上分结。复次是时毕竟离界。毕竟断不善无记烦恼。得须陀洹果斯陀含果时。不毕竟离界。亦不毕竟断不善烦恼离色界时。虽毕竟离界。不毕竟断无记烦恼。得阿那含果时。毕竟离界谓离欲界。毕竟断不善烦恼。得阿罗汉果时。毕竟离界。谓离无色界。毕竟断无记烦恼。如不善无记。有报无报。生二果一果。无惭无愧相应。无惭无愧不相应。当知说亦如是

九断智谁舍几谁得几。答曰。或有无舍无得者。如凡夫人是也。问曰。此中不问凡夫不答凡夫。复有圣人不舍不得者。如住本性者是也。胜进者亦是如苦法忍灭苦法智生。是时不舍不得。苦比忍灭。苦比智生。是时亦不舍不得。集法忍灭。集法智生。是时得一。而无所舍。集比忍灭。集比智生。是时得一。而无所舍。灭法忍灭。灭法智生。是时得一。而无所舍。灭比忍灭。灭比智生。是时得一。而无所舍。道法忍灭。道法智生。是时得一。而无所舍。道比忍灭。道比智生。若非离欲人得一。而无所舍。若是离欲人。舍五得一(谓道比智时所得断智即是五下分结尽断智)。圣人离欲界欲。断一种乃至八种结。无得舍。断第九种结。是时舍六得一。谓五下分结尽断智是也。离初禅欲。断一种乃至九种结。无得无舍。第二第三禅亦如是。离第四禅欲。断一种乃至八种。无得舍。断第九种。得一而无所舍。如初禅二禅三禅。空处识处无所有处亦如是。离非想非非想处欲断一种乃至八种结。亦无得无舍。断第九种时。舍二得一。谓一切结尽断智。是则说胜进时。退时亦有舍有得。阿罗汉起无色界烦恼退时。舍一得二。起色界烦恼退时。舍一得一。起欲界烦恼退时。舍一得六。离色爱阿那含。起色界烦恼退时。舍一而无所得。起欲界烦恼退时。舍二得六。未离色爱阿那含。起欲界烦恼退时。舍一得六。退斯陀含果时。无舍无得

此九断智。几是禅果几是无色定果。几是根本禅果。几是禅边果。几是根本无色定果。几是无色定边果。几是见道果几是修道果。几是忍果几是智果。几是法智果。几是比智果。几是法智分果几是比智分果。几是世俗道果几是无漏道果。几是禅果者。答曰。九是禅。及眷属果。几是无色定果者。答曰。二是无色定。及眷属果。几是根本禅果者。答曰。阿毗昙者作如是说。五是根本禅果。尊者瞿沙作如是说。八是根本禅果。几是禅边果者。答曰。九谓未至依是也。非余禅边。几是根本无色定果者。答曰一。几是无色定边果者。答曰一。谓空处边。非余处无色定边。几是见道果者。答曰七。几是修道果者。答曰三。几是忍果。应说如见道。几是智果者。应说如修道。几是法智果者。答曰三。几是比智果者。答曰二。几是法智分果者。答曰六。几是比智分果者。答曰五。几是世俗道果者。答曰二。几是无漏道果者。答曰九。若离色爱。得正决定。色爱尽断智何时得耶。尊者僧伽婆修说曰。道比智现在前时得。所以者何。道比智亦是向道。亦是果道。不应作是说。住果而言是向。彼未曾起一刹那顷向道现在前。何故说言向道耶。复有说。若离空处欲。是时于未来世。修无漏禅。是时得色爱尽断智。此说亦不应尔。所以者何。是时对治无色界禅未来修。不对治色界禅修。复有说。当得阿罗汉果。住金刚喻定。三界见道修道所断结同一味。通证解脱得。是时得色爱尽断智。评曰。应作是说。彼从果必起胜果道现在前。是时得色爱尽断智。若不从果。更起胜果道现在前者。离三禅欲人依下地。得正决定。彼若命终。生四禅中。若无色界。彼不应成就乐根。若然者则与十门所说相违。如说谁成就乐根。若生遍净。若圣人生遍净上。欲令无如是过故。从果起必起胜果道现在前。是时得色爱尽断智

九断智摄一切断智。一切断智摄九断智耶。答曰。一切摄九非九摄一切。九者如此中说。一切者此九。及诸余断是。一切者多九者少。一切断智摄九断智。余者犹多。譬如大器覆于小器。余者犹多。彼亦如是。不摄何者。答曰。见谛具足世尊弟子。未离欲者。欲界系修道所断九断智所不摄。圣人离欲界欲时。断初种结乃至断八种结。此断非九断智所摄。已离欲爱。未离色爱。色界修道所断结断。非九断智所摄。已断色爱。乃至第四禅。断八种结。彼断非九断智所摄。已离色爱。未离无色爱无色界修道所断结。非九断智所摄。离空处欲。乃至断非想非非想处八种结。彼断非九断智所摄。问曰。苦智已生。集智未生。三界见苦所断结断。彼断非九断智所摄。何故此中不说耶。答曰。应说此文应如是说。一切摄九。非九摄一切。不摄何等。答苦智已生。集智未生。三界见苦所断烦恼断。彼断非九断智所摄。余说如上。而不说者。有何意耶。答曰。此中所说断。是有断智人断。彼虽是断。非是有断智人断。问曰。虽作是说。于义不尽。所以者何。不说凡夫人断故。答曰。此是略说现初入门故。而作是说

八人。向须陀洹果证人住须陀洹果人。向斯陀含果证人住斯陀含果。向阿那含果证人住阿那含果。向阿罗汉果证人住阿罗汉果。问曰。人名有八实体有几。答曰。阿毗昙者作如是说。人名有八实体有五。向须陀洹果证人。阿罗汉果。名有二实体有二。须陀洹果。向斯陀含果证人。名有二实体有一。斯陀含果。向阿那含果证人。名有二实体有一。阿那含果。向阿罗汉果证人。名有二实体有一。尊者瞿沙作如是说。八人名有八。实体有八。彼作是说。须陀洹人。住须陀洹果。不胜进时。名成就。须陀洹果人。若胜进时。名向斯陀含果证人。舍须陀洹果。斯陀含果人住斯陀含果。不胜进时。名成就斯陀含果人。若胜进时。名向阿那含果证人。舍斯陀含果。阿那含人。住阿那含果。不胜进时。名成就阿那含果人。若胜进时。名向阿罗汉果证人。舍阿那含果。所以者何。以根故。说人差别。是故生智论作如是说。向斯陀含果证人。当言成就须陀洹果不耶。答曰。不成就。乃至向阿罗汉果证人。当言成就阿那含果不耶。答曰。不成就。评曰八人名有八实体有五。如是说者好。如名体名数体数。名差别体差别。名异体异。名别体别。知名知义。当知亦如是。问曰。若八人身有八实体有五。云何说八人差别耶。答曰。以行圣道故。须陀洹若于须陀洹果。不胜进时。于须陀洹果。名得名在身。名成就名现前行。若于须陀洹果胜进者。是时住向于须陀洹果名得。不在身中名成就。不现前行于向。名得名在身中。名成就。名现前行。乃至若于阿那含果。不胜进时。于阿那含果。名得名在身中。名成就名现前行。若于阿那含果胜进者。是时住向于阿那含果名得。不在身中名成就。不现前行于向。名得名在身中。名成就名现前行。向须陀洹果证人。于此九断智。成就几。不成就几。此中以人为章。以断智为门。答曰。或不成就。或一二三四五广说如经本

阿毗昙毗婆沙论卷第三十三阿毗昙毗婆沙论卷第三十四

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    使犍度人品第三上

结有二种。谓见道断种。欲修道断种。欲界有二种。色界有二种。无色界有二种。颇欲界系见道所断修道所断结顿得耶。乃至广说。章及解章义。此中应广说优波提舍。问曰。何故作此论。答曰。此诸烦恼。于生死中。作大系缚。无利崄难。犹如怨家藏伏。欲界受大苦恼。于色无色界。受大苦恼。于生死中。数数回转。处在母胎闇冥之处。生藏熟藏之所逼切。不知云何推求此结。如实知见而除断之。欲令知故。犹如怨家藏伏。不知则害。知则可避。彼亦如是。是故应思量观察种种善语。乃至生生之处。而不忘失。如尊者弥多达子初生时。而作是语。结有二种。谓见道断种。修道断种。欲界有二种。色界有二。无色界有二。问曰。何故彼生时。作如是语。答曰。彼在母胎。为众苦所逼。而作是念。众生何故数处母胎。受如是等苦。皆以此二种结故。欲说此二结过患故。生时便作此语。结有二种。欲界有二。乃至广说。问曰。何故名种。答曰。此中说聚是种。如众多比丘聚名比丘种。如婆罗门聚名婆罗门种。彼亦如是。所言种者。亦可言聚。亦可言群。实义是一。名有差别。顿得耶。云何名顿得。答曰。顿得名一时。何以知之。答曰。有经者。波斯匿王。往诣佛所。面共世尊。种种言论。在一面坐。而白佛言。我闻沙门瞿昙。作如是说。于去来今。无有沙门婆罗门能如实知见一切法。若言知见无有是处。沙门瞿昙为忆念有此语不。佛答王言。我不忆念王复言。沙门瞿昙。世或有人。不善受文义闻时异。为他说异。唯愿世尊。忆念此事。而解说之。佛答王言。我曾作是说。于去来今。无有顿得如实知见一切法者。若言顿得知见无有是处。皆从三阿僧祇劫。渐渐修行六波罗蜜。然后乃知。非一时知。以是事故知顿得是一时。颇欲界系见道修道所断结顿得耶。答曰。顿得。离欲凡夫人。于彼无欲退。问曰。谁顿得耶。答曰。凡夫人离欲爱时。欲界系见道修道所断结。总为一聚。如刈草法。九种结一时断。以下下无碍道。断上上结。乃至以上上无碍道。断下下结。凡夫人以下下结。于彼无欲退。顿得欲界系见道修道所断一种结。下中退顿得二种。乃至以上上结退。顿得欲界系见道修道所断九种结。色界无色界命终生欲界时。凡夫以下下结乃至上上结。令生相续顿得欲界系见道修道所断九种结。顿舍耶。答曰舍。凡夫人离欲爱时。问曰。谁顿舍耶。答曰。凡夫人离欲爱时。欲界系见道修道所断九种结。总为一聚。如刈草法。九种结一时断。以下下无碍道。断上上结。乃至以上上无碍道。断下下结。彼欲界系见道修道所断下下。顿舍渐得耶。答曰不得。所以者何。若先得见道所断结。后得修道所断结若先得修道所断结。后得见道所断结。无有是处。渐舍耶。答曰舍。世尊弟子。先舍见道所断结。后舍修道所断结。见道所断结。以见道断修道所断结。以修道断。颇色界系见道修道所断结顿得耶。答曰顿得。离色爱凡夫人。于彼无欲退。问曰。谁顿得耶。答曰。凡夫人离色爱时。色界系见道修道所断结。总为一聚。如刈草法。九种结一时断。以下下无碍道。断上上结。乃至以上上无碍道。断下下结。于彼无欲退。若以色界系下下结退者。彼顿得色界系见道修道所断一种结。下中退顿得二种。乃至以上上结退。顿得色界系见道修道所断九种结。若以欲界下下结乃至上上结退。彼时顿得色界系见道修道所断九种结。复有说者。此文应如是说。离色爱凡夫人。以欲界梵世地结退。不应作是说。所以者何。此中说于界顿得。不说地顿得。若以第四禅结退。乃至以欲界结退。是时顿得色界系见道修道所断结。无色界命终。生欲色界时。顿得色界系见道修道所断结。凡夫人无色界命终。生欲色界中。以下下结乃至上上结。令生相续。顿得色界系见道修道所断九种结顿舍耶。答曰舍。凡夫人离色爱时。问曰谁顿舍耶。答曰。凡夫人离色爱时。色界系见道修道所断结。总为一聚。如刈草法。九种结一时断。以下下无碍道。断上上结。彼顿舍色界系见道修道所断结。乃至以上上无碍道。断下下结。顿舍色界系见道修道所断结。渐得耶。答曰不得。所以者何。无有先得见道所断后得修道所断者。无有先得修道所断后得见道所断者。渐舍耶。答曰舍。世尊弟子。先舍见道所断结。后舍修道所断结。见道舍见道所断。修道舍修道所断。颇顿得无色界系见道修道所断结耶。答曰不得。所以者何。顿得是凡夫人。无有凡夫人能尽断。无色界结。于彼退。顿得无色界见道修道所断结者。顿舍耶。答曰不舍。所以者何。顿舍者是凡夫人。无有凡夫人顿舍。无色界烦恼者渐得耶。答曰不得。所以者何。无有先得见道所断结后得修道所断。先得修道所断。后得见道所断者。渐舍耶。答曰舍。世尊弟子。先舍见道所断结。后舍修道所断结。见道舍见道所断结。修道舍修道所断结

有世俗行。问曰。凡夫人以世俗道离欲时。断九种结。几无碍道舍。几解脱道舍。圣人以无漏道。断九种结。几无碍道舍。几解脱道舍。答曰。或有说者。凡夫人断九种结。以三无碍道三解脱道断。谓下下无碍道。下下解脱道。断上三种结。下中无碍道。下中解脱道。断中三种结。下上无碍道。下上解脱道。断下三种结。圣人亦如是。复有说者。凡夫人断九种结以一无碍道一解脱道断。圣人断九种结。以九无碍道九解脱道断。问曰。何故凡夫人断九种结。以一无碍道一解脱道断。圣人断九种结。以九无碍道九解脱道断耶答曰。凡夫人所用道。钝于前法。不能观察思量一一分别。圣人所用道。猛利于前法。能观察思量一一分别

问曰。若作是说。欲令凡夫人下而说是胜。欲令圣人胜而说是下。所以者何。凡夫人断九种结。以一无碍道一解脱道断。圣人断九种结。以九无碍道九解脱道断。是则凡夫人胜于圣人。如人多服毒药。一时吐出谁不可耶。评曰。应作如是说。凡夫人断九种结。以九无碍道九解脱道断。圣人亦尔。问曰。若凡夫人断九种结。以九无碍道九解脱道断。圣人亦尔者。凡夫圣人。有何差别。答曰。凡夫人。见道所断。修道所断结。总为一聚。如刈草法。九种结一时以九无碍道九解脱道断。圣人见道所断九种结。以一无碍道一解脱道修道所断。九种结以九无碍道九解脱道断。凡夫圣人。是谓差别

问曰。以世俗道断结时。以几方便。以几入定。答曰。以三方便。以三入定。以初方便。以初入定断上三种结。以第二方便。以第二入定。断中三种结。以第三方便。以第三入定。断下三种结。问曰。为起定断耶。为不起定断耶。答曰。或有说者。凡夫人不起定断。圣人或起定。或不起定断。复有说者。凡夫人或起定。不起定断。圣人不起定断。评曰。应作是说。此事不定。凡夫人或不起定。圣人或起定不起定。凡夫人或起定不起定。圣人或不起定而断结。复有说者。断欲界结不起定。断色无色界结。或起定或不起定。复有说者。断欲界结。或起定或不起定。断色无色界结不起定。评曰。此事不定。断欲界结。起定不起定。断色无色界结不起定。断欲界结不起定。断色无色界结。起定不起定。则说胜进时

凡夫人。起下结退时。成就下三种结。起中结退时。成就六种结。起上结退时。成就九种结。圣人起下下结退时。成就下下结。乃至起上上结退时。成就九种结。复有说者。凡夫人起下下结退时。乃至起上上结退时。成就九种结。圣人如前说

问曰。何故凡夫人。起下下结退。乃至起上上结退成就九种结。圣人起下下结退时。成就下下结。起下中结退时。成就二种。乃至起上上结退时。成就九种结。答曰。凡夫人以世俗定自持。彼定性羸劣。圣人无漏定自持。彼定牢固。应作是说。凡夫人不服毒药而死。评曰。应作是说。凡夫人起下下结退。还成就下下结。乃至起上上结退。成就九种结

问曰。若然者凡夫人圣人。有何差别。答曰。凡夫人若起下下结退。成就见道修道所断下下结。乃至起上上结退。成就见道修道所断九种结。圣人起下下结退时。成就修道所断下下结。乃至起上上结退时。成就修道所断九种结。不成就见道所断结。凡夫人圣人。是谓差别

在欲界圣人有三事。一毕竟离欲而命终。二退已而命终。三渐离欲已而命终凡夫人有二事。一毕竟离欲而命终。二退已而命终。在色界圣人。有二事。一毕竟离色爱而命终。二渐离欲而命终不退。所以者何。色界无有退者。凡夫人有一事。毕竟离色爱而命终不退。所以者何。色界无退。无渐离欲而命终者

问曰。何故圣人有渐离欲而命终。凡夫人不尔耶。答曰。圣人以无漏道自持。彼道牢固。凡夫人以世俗道自持。彼道羸劣。复次圣人成就定慧分故。渐断结而命终。凡夫人不成就定慧分故。不能渐断结而命终。复次圣人成就无漏分故。渐断结而命终。凡夫人无无漏分故。不能渐断结而命终。复次圣人有业力道力。以业力故。能渐断结而命终。以道力故。能毕竟离欲而命终。凡夫人无业力。以道力强。能毕竟离欲而命终者则退。复次欲界圣人分中。有渐离欲人。若断三种四种结名家家。若断六种结。名斯陀含。若断七种八种结。名一种子。是故圣人有渐离欲而命终者。凡夫人分中。无渐离欲而命终。是故凡夫人无渐离欲而命终者。尊者僧伽婆修说曰。凡夫人亦有渐离欲而命终者。住相续心。还成就本所断结。评曰。不应作是说。如前说者好

以世俗道。离欲时。无碍道有几行。解脱道有几行。答曰。无碍道有三行。谓粗行。苦行。粗坏行。解脱道有三行。谓止行。妙行。离行

问曰。若无碍道中。有粗行。彼解脱道中有止行耶。若无碍道中有苦行。彼解脱道中有妙行耶。若无碍道中有粗坏行。彼解脱道中。有离行耶。答曰。或有说者如所问。若无碍道有粗行者。彼解脱道必有止行。若无碍道。有苦行者彼解脱道必有妙行。若无碍道有粗坏行者。彼解脱道必有离行。评曰。此事不定。若无碍道中有粗行。彼解脱道中三行。展转现在前。若无碍道中。有苦行粗坏行者。解脱道中三行。展转现在前

问曰。以世俗道离欲爱时。无碍道为缘何法。解脱道为缘何法。答曰。九无碍道缘于欲界。九解脱道缘于初禅。问曰。若然者。根犍度说善通。如说颇思惟色界法。能知欲界耶。答言能知。云何不缘倒错行倒错。若缘行倒错。云何不为离欲法作障碍留难耶。答曰。假令缘行倒错。而不能为离欲法作障碍留难。所以者何。于彼离欲法。已善修习径路已成就。如见道中。缘欲界忍智。后缘色无色界忍智现在前。缘色无色界忍智。后缘欲界忍智现在前。如此虽复缘行倒错。而不为得正决定而作障碍留难。所以者何。于彼见道。已善修习。径路已成就。彼亦如是。复有说者。九无碍道。八解脱道缘于欲界。最后解脱道缘于初禅。如以灭道智离非想非非想处爱。彼九无碍道。八解脱道。缘于灭道。最后解脱道。缘于非想非非想处四阴。彼亦如是。复有说者。若离欲爱时起定。断一种结已。而住彼一无碍道。缘于欲界。一解脱道。缘于初禅。若断二种结已。而住彼二无碍道。一解脱道。缘于欲界。一解脱道。缘于初禅。若乃至断八种结已。而住彼八无碍道。七解脱道。缘于欲界。第八解脱道。缘于初禅。复有说者。九无碍道。九解脱道。尽缘欲界。如以苦集智离欲爱时。九无碍道。九解脱道。缘于欲界。彼亦如是。问曰。若然者。则不行倒错。于离欲法。不作障碍留难。根犍度说云何通耶。如说颇思惟色界法。能知欲界耶。答言能知。答曰。此说先观察分别时行者。先作如是分别观察。欲界是粗。初禅是止

问曰。根犍度次说。复云何通。如说颇思惟无色界法。能知欲界耶。答言不能知。行者是时不先分别观察欲界是粗无色界是止耶。何故言不能知耶。答曰。行者亦分别观察。而所观是远。非于如是远观后而能离欲。复有说者。九无碍道。九解脱道。尽缘初禅。问曰。若然者根犍度说善通。如说颇思惟色界法。能知欲界耶。答言能知。亦非缘行倒错。云何缘于他处。离他处欲耶。答曰。若缘余处。离他处欲。此亦无过。如以灭道智缘于灭道。而离苦集所断欲。彼亦如是。如是所说。尽为生弟子觉意故。然此义最初说。九无碍道。缘于欲界。九解脱道。缘于初禅者好

问曰。无碍道中。为修几行。解脱道中。有修几行。答曰。凡夫人。离欲爱时。无碍道中。修粗等三行。八解脱道中。修六行。谓粗等三行。止等三行。最后解脱道中。即修此六行。亦修未至初禅无量行。乃至离无所有处爱亦如是。圣人离欲爱时。无碍道中。修十九行。谓粗等三行。有漏无漏十六圣行。八解脱道中。修二十二行。谓粗等三行。止等三行。有漏无漏十六圣行。最后解脱道中。即修此二十二行。亦修未至初禅无量行。圣人离初禅欲时。无碍道中。修十九行。谓粗等三行。十六圣行。唯修无漏非有漏。八解脱道中。修二十二行。谓粗等三行。止等三行。十六圣行。唯修无漏非有漏。最后解脱道。即修此二十二行。亦修未至初禅无量行。乃至离无所有处爱亦如是。问曰。何故初禅边修有漏无漏行。上地边唯修无漏不修有漏耶。答曰。初禅边有有漏无漏圣行是故修。上地边唯有有漏行。无有漏无漏圣行。是故唯修无漏行。复有说者。凡夫人离欲爱时。无碍道中修九行。谓粗等三行。慈悲喜舍。不净观安般念。八解脱道中。修十二行。即上九行。及止等三行。最后解脱道中。即修此十二行。亦修未至初禅无量行。圣人离欲爱时。无碍道中。修二十五行。谓粗等三行。慈悲喜舍。不净观安般念。有漏无漏十六圣行。八解脱道中。修二十八行。即此二十五行。及止等三行。最后解脱道中。即修此二十八行。及修未至初禅无量行。上地边如上说

问曰。何故初禅边修如是等诸行。上地边不修耶。答曰。初禅边有种种善根故。修如是等诸行。上地边诸善根少故。不修如是等诸行。复次欲界有种种烦恼故。须种种对治。上地无种种烦恼故。不须种种对治。此中所说诸行。在于现在俱行。负重同。所作同者。所缘如上说。未来世所修行。为何所缘耶。答曰。离欲爱时。九无碍道中。粗等三行修者。缘于欲界。八解脱道中粗等三行修者。缘欲界初禅。止等三行修者。缘于初禅。最后解脱道中。粗等三行修者。缘于三界。止等三行修者。缘于初禅乃至非想非非想处。离初禅欲时。九无碍道中。粗等三行修者。缘于初禅。八解脱道中。粗等三行修者。缘初禅二禅。止等三行修者。缘于二禅。最后解脱道中。粗等三行修者。缘于三界。止等三行修者。缘于二禅乃至非想非非想处。离第二禅欲第三禅欲。应随相说。离第四禅欲时。九无碍道中。粗等三行修者。缘第四禅。八解脱道中。粗等三行修者。缘第四禅及空处。止等三行修者。缘空处。最后解脱道中。粗等三行。止等三行修者。缘于空处乃至非想非非想处。问曰。若离第四禅欲时。八解脱道中。粗等行修者。缘第四禅及空处者。识身经说云何通。如说颇有无色界系心。能知色无色界耶。答言不知。答曰。彼中遮一刹那顷。不遮多相续。若于一刹那顷。能知色无色界者。无有是处。彼解脱道。起现在前者。未来修行者。或缘色界。或缘无色界。是故一刹那顷不知。多相续则知。二说便为善通。离空处欲时。九无碍道中。粗等三行修者。缘于空处。八解脱道中。粗等三行修者。缘于空处识处。止等三行修者。缘于识处。最后解脱道中。粗等三行。止等三行修者。缘于识处。乃至非想非非想处。离识处欲。离无所有处欲。应随相说

问曰。何故禅中所修诸行。缘于三界。无色中所修诸行。唯缘无色界耶。答曰。禅能遍缘。能缘自地。能缘下地。亦缘上地。无色定不能遍缘。唯能缘自地。及缘上地。不缘下地。以是事故。禅中所修诸行。能缘三界。无色中所修诸行。唯缘无色界。欲界系见道所断结种断。为何沙门果摄。问曰。何以作此论。答曰。诸烦恼。先分别在界。未分别种。今欲分别种故。而作此论。欲界系见道所断结种断。为何沙门果摄。答曰。四沙门果摄。或无处所。四沙门果者。须陀洹须陀洹果摄。乃至阿罗汉阿罗汉果摄。无处所者。凡夫人离欲。无处所离欲人得正决定。见道中十五心顷。无处所次第人。见道中见道谛二心顷。无处所。如是等时。欲界见道所断结种断。无处所欲界系修道所断结种断。为何果摄。答曰。阿那含果阿罗汉果摄。阿那含阿那含果摄。阿罗汉阿罗汉界摄。无处所者。凡夫人离欲。无处所离欲人。得正决定。十五心顷。无处所次第人。不得言无处所。所以者何。离欲爱时。最后无碍道。断修道所断结。解脱道生时。即阿那含果所摄。色界系见道所断结种断。为何果摄。答曰。四沙门果摄。或无处所。四沙门果。如上说。或无处所者。凡夫人。离色爱时。无处所离色爱人。得正决定。十五心顷。无处所次第人。不得言无处所。所以者何。道比忍毕竟断此结。道比智生时。彼断即为果摄。色界系修道所断结种断。为何果摄。答曰。阿罗汉果摄。或无处所。阿罗汉阿罗汉果摄。无处所者。凡夫人。离色爱。无处所离色爱人。得正决定。见道中十五心顷。道比智现在前。无处所次第人。离第四禅欲时。最后解脱道无处所。离空处爱时。九无碍道。九解脱道无处所。乃至离无所有处爱时亦如是。离非想非非想处爱时。九无碍道。八解脱道时。及色界系修道所断。已断已知结无处所无色界系。见道所断结种断为何果摄。答曰。四沙门果摄。四沙门果如上说。此中不说凡夫人无处所。所以者何。无有凡夫人能离非想非非想处爱者。次第人亦不得言无处所。所以者何。道比忍毕竟断此结。道比智现在前时。彼断即为果摄。无色界系修道所断结种断。为何果摄。答曰。唯阿罗汉果摄。此中无离欲凡夫人。所以者何。无有凡夫人能离非想非非想处爱者。次第人亦不得言无处所。所以者何。金刚喻定毕竟断此结。初尽智生时。彼断即为果摄。谓阿罗汉果

结有五种。谓见苦所断种。乃至修道所断种。问曰。何故作此论。答曰。先分别烦恼在界有二种。未分别五种。今欲分别故而作此论。见苦所断结种断。为何果摄。答曰。四沙门果摄。或无处所。四沙门果如上说。无处所者。此中不应说凡夫人离欲。次第人见苦时一心顷。见集时四心顷。见灭时四心顷。见道时三心顷。是时见苦所断结种断。彼断非果摄。见集所断结种断。为何果摄。答曰。四沙门果或无处所。四沙门果如上说。无处所者此中无有凡夫人离欲。次第人见集时一心顷。见灭时四心顷。见道时三心顷。是时见集所断结种断。彼断非沙门果摄。见灭所断结种断。彼断何果摄。答曰。四沙门果。或无处所。此中不说凡夫人离欲。次第人见灭一心顷。见道三心顷。是时见灭所断结种断。彼断非沙门果摄。见道所断结种断。彼断为何果摄。答曰。四沙门果。此中不说凡夫人离欲。亦不说次第人。所以者何。道比智忍毕竟断此结。道比智现在前。彼断即为果摄。修道所断结种断。彼断为何果摄。答曰。阿罗汉果摄。此中不说凡夫人离欲。亦不说次第人。所以者何。金刚喻定毕竟断此结。初尽智现在前。彼断即为果摄。谓阿罗汉果

结有九种。苦法智所断结种。苦比智所断结种。集法智所断结种。集比智所断结种。灭法智所断结种。灭比智所断结种。道法智所断结种。道比智所断结种。修道所断结种

问曰。何故复作此论。答曰。先分别烦恼在界。有二种有五种。未分别对治断种。今欲分别故。而作此论。苦法智所断结种断。彼断为何果摄。答曰。四沙门果。或无处所。四沙门果如上说。无处所者。凡夫人离欲。无处所离欲人。得正决定。见道中十五心顷。次第人见苦三心顷。见集四心顷。见灭四心顷。见道三心顷。是时苦法智所断结种断。彼断非沙门果摄。苦比智所断结种断。彼断为何果摄。答曰。四沙门果或无处所。四沙门果如上说。无处所者。此中不说凡夫人离欲。次第人见苦一心顷。见集四心顷。见灭四心顷。见道三心顷。是时苦比智所断结种断。彼断非沙门果摄。集法智所断结种断。彼断为何果摄。答曰。四沙门果或无处所。四沙门果如上说。无处所者。凡夫人离欲。无处所离欲人。得正决定。见道中十五心顷。无处所次第人。见集三心顷。见灭四心顷。见道三心顷。是时集法智所断结种断。彼断非沙门果摄。集比智所断结种断。彼断为何果摄。答曰。四沙门果。或无处所。四沙门果如上说。无处所者。此中不说凡夫人离欲。次第人见集一心顷。见灭四心顷。见道三心顷。是时集比智所断结种断。彼断非沙门果摄。灭法智所断结种断。彼断为何果摄。答曰。四沙门果。或无处所。四沙门果如上说。无处所者。凡夫人离欲。无处所离欲人。得正决定。见道中十五心顷。无处所次第人。见灭三心顷。见道三心顷。是时灭法智所断结种断。彼断非沙门果摄。灭比智所断结种断。彼断为何果摄。答曰。四沙门果。或无处所。四沙门果如上说。无处所者。此中不说凡夫人离欲。次第人见灭一心顷。见道三心顷。是时灭比智所断结种断。彼断非沙门果摄。道法智所断结种断。彼断为何果摄。答曰。四沙门果。或无处所。四沙门果如上说。无处所者。凡夫人离欲。无处所离欲人。得正决定。见道中十五心顷。无处所次第人。见道二心顷。是时道法智所断结种断。彼断非沙门果摄。道比智所断结种断。彼断为何果摄。答曰。四沙门果。四沙门果如上说。此中不说凡夫人离欲。亦不说次第人。所以者何。道比智毕竟断此结。道比智现在前。彼断即为果摄。修道所断结种断。彼断为何果摄。答曰。阿罗汉果摄。此中不说凡夫人离欲。亦不说次第人。所以者何。金刚喻定毕竟断此结。初尽智现在前。彼断即为果摄。谓阿罗汉果。问曰。为无碍道断结。为解脱道断结耶。若无碍道断结者。此文所说云何通。如说苦法智所断结种。乃至道比智所断结种。若解脱道断结者。智揵度说云何通。如说诸结见苦断。彼结苦智断耶。答言。彼结苦忍断。诸结乃至见道断。彼结道智断耶。答言诸结道忍断。答曰。应作是说。诸结无碍道断。问曰。若然者智犍度说善通。此文所说云何通。如说苦法智所断结种。乃至广说。答曰。此文应如是说。结有九种。苦法忍所断结种。乃至道法忍所断结种。而不说者有何意耶。答曰。忍属于智。是智眷属。若忍所断。亦名智断。犹如属王之人。若有所作。亦名王作。彼亦如是。复次无碍道断结。解脱道持令不动。若解脱道不重持者。则烦恼更生而为过患。如人先扑怨家。卧于地上。后一人来。重持令不动。若后来人不重持者。则怨更起而为过患。又如有人从其舍内。逐怨家出。后一人来。牢闭其门。虽复一人逐怨家出。后人若不牢闭门者。则怨家还入而为过患。亦如有人先盛毒蛇。着于瓶中。后一人来牢盖其口。虽复一人先盛。后来之人不牢盖口。则毒蛇还出而为过患。彼亦如是。复次无碍道断结。解脱道功多。如根犍度说。此中复广分别。复次无碍道断结。彼断解脱得。与解脱俱生。以俱生故。解脱道亦名断结。复次无碍道断结。解脱道共无碍道。同作一事。以同作一事故。解脱道亦名断结

结有十五种。欲界见苦所断结种。乃至修道所断结种。色无色界结亦如是。问曰。何故复作此论。答曰。先分别诸烦恼在界二种五种对治种。未分别界种。今欲分别故。而作此论。欲界系见苦所断结种断。为何果摄。答曰。四沙门果。或无处所。四沙门果如上说。无处所者。凡夫人离欲。无处所离欲人。得正决定。见道中十五心顷。无处所次第人。见苦三心顷。见集四心顷。见灭四心顷。见道三心顷。是时欲界见苦所断结种断。彼断非沙门果摄。欲界系见集所断。见灭所断见道所断。修道所断。应随相说。色界系见苦所断结种断。彼断为何果摄。答曰。四沙门果。或无处所。四沙门果如上说。无处所者。凡夫人离色爱。无处所离色爱人。得正决定。见道中十五心顷。无处所次第人。见苦一心顷。见集四心顷。见灭四心顷。见道三心顷。无处所。是时色界系见苦所断结种断。彼断非沙门果摄。色界系见集见灭见道修道所断结种断。应随相说。无色界五种所断结种断。亦应随相说

身见断为何果摄。答曰。四沙门果或无处所。四沙门果如上说。无处所者。是中不说凡夫人离欲。次第人见苦一心顷。见集四心顷。见灭四心顷。见道三心顷。是时身见断。彼断非沙门果摄。如身见断。下分中身见断。见中身见断。说亦如是。戒取疑断。彼断为何果摄。答曰。四沙门果。四沙门果如上说。此中不说凡夫人离欲。亦不说次第人。所以者何。道比忍毕竟断此结。道比智现在前。彼断即为沙门果摄。如戒取疑断见流见扼见取取戒取取戒取身缚见取身缚下分中戒取疑见中邪见见取戒取见使疑使见结取结。广说亦如是。贪恚痴不善根。及欲漏断。彼断为何果摄。答曰。阿那含果阿罗汉果或无处所。广说如欲界系见修道所断结种断。如欲漏有漏无明漏。余烦恼与彼相似者。应随相说。盖中疑盖应广说。如道法智所断结种断。上分结广说。如色无色界修道所断结种断。眼耳身触生爱断为何果摄。答曰。阿罗汉果或无处所。阿罗汉阿罗汉果摄。无处所者。凡夫人离梵世爱无处所。离梵世爱人得正决定。见道中十五心顷。及道比智无处所次第人。断初禅爱时。最后解脱道。断第二禅爱。乃至断无所有处爱。九无碍道。九解脱道。离非想非非想处爱。九无碍道。八解脱道。是时眼耳身触生爱断。彼断非沙门果摄。九十八使断。广说如十五结种断

向须陀洹果证人所断结种断。彼断为何果摄。答曰。无处所。所以者何。须陀洹果前。更无有果。能摄彼断。须陀洹须陀洹果摄。须陀洹果摄三界见道所断结种断。向斯陀含果证人所断结种断。彼断为何果摄。答曰。须陀洹果。或无处所。须陀洹果摄三界见道所断结种断。无处所者。次第人。断欲界系五种结断。彼断非须陀洹果摄。所以者何。彼胜果道证故。如胜果道非果摄。断亦如是。斯陀含斯陀含果摄。斯陀含果。摄三界见道所断结种断。及欲界修道所断六种结断。向阿那含果证人所断结种断。彼断为何果摄。答曰。斯陀含果。或无处所斯陀含果。摄三界见道所断结种断。及欲界修道所断六种结断。无处所者。断欲界修道所断七种八种结断。向阿罗汉果证人所断结种断。彼断为何果摄。答曰。阿那含果。或无处所阿那含果。摄三界见道所断结种断。及欲界修道所断九种结断。无处所者。断初禅九种结乃至无所有处九种结。断非想非非想处八种结。所以者何。彼胜果道证故。如胜果道非果摄。彼断亦尔。阿罗汉阿罗汉果摄。阿罗汉果。摄三界见道修道所断结种尽问曰。如断一种结。乃至断五种结。以得道比智故。名须陀洹。断欲界系五种结非须陀洹果摄。若断七种八种结。得正决定。得道比智时。名斯陀含。彼断七种八种结。非斯陀含果摄。若离初禅爱。乃至离无所有处爱。得正决定。得道比智时。名阿那含果。彼断初禅九种结。乃至无所有处九种结。非阿那含果摄。何以言须陀洹须陀洹果摄斯陀含斯陀含果摄阿那含阿那含果摄。何故不说。或无处所耶答曰。此文应如是说。须陀洹须陀洹果摄。或无处所。斯陀含斯陀含果摄。或无处所。阿那含阿那含果摄。或无处所。而不说者。有何意耶。答曰。此说次第具缚人。不说超越人

见谛具足。世尊弟子。未离欲爱。欲界系修道所断结种断。彼断为何果摄。答曰。斯陀含果。或无处所。斯陀含果。摄欲界修道所断六种结断。无处所者。断七种八种结断。已离欲爱。未离色爱。色界系修道所断结种断。彼断为何果摄。答曰。无处所断初禅九种结乃至第四禅八种结断。无处所已离色爱。未离无色爱。无色界修道所断结种断。彼断为何果摄。答曰。无处所。断空处九种结乃至非想非非想处八种结断无处所

阿毗昙毗婆沙论卷第三十四阿毗昙毗婆沙论卷第三十五

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    使犍度人品中

四沙门果。谓须陀洹果。斯陀含果。阿那含果。阿罗汉果。问曰。何故作此论。答曰。或有说。沙门果惟是无为。如毗婆阇婆提说。问曰。彼何故作是说耶。答曰。彼依佛经。佛经说告诸比丘。我今当说沙门沙门果沙门人。云何名沙门。答曰。八圣道名沙门。云何名沙门果。答曰。须陀洹果。乃至阿罗汉果。何者是须陀洹果。答曰。永断三结是也。何者是斯陀含果。答曰。永断三结。薄爱恚痴是也。何者是阿那含果。答曰。永断五下分结是也。何者是阿罗汉果。答曰。永断爱慢痴一切结是也。何者是沙门人。答曰。成就如是等法。名沙门人。因此经故。说沙门果。惟是无为。为止如是说者意亦明沙门果。是有为无为故。若沙门果。惟是无为。非有为者。违于佛经。经说有四向。有住四果。住果者。住有为沙门果。不住无为沙门果。问曰。是时亦住断中。如施设经说。彼住于断。不求胜法。不得者得。不证者证。不解者解。答曰。言住断者。非如乘象马住象马上。但于断法。不退不进。故言住断。世尊经。亦有一向说有为沙门果者。如说比丘当知于此五根。令增上猛利通达满足。当得俱解脱阿罗汉果。转不如者。得慧解脱乃至坚信。问曰。若沙门果。是有为无为者。佛经云何通。答曰。沙门果。是有为无为。佛经惟说无为。问曰。何故佛经惟说无为沙门果。答曰。佛经惟说沙门果。不说沙门道是沙门亦是沙门果。复次此经惟说婆罗门果。不说婆罗门道是婆罗门亦是婆罗门果。复次佛经说梵行道是梵行亦是梵行果复次佛经说果。更无有果道是果更有果。复次佛经说离更无有离道是离更有离。以是事故。欲止他义欲显已义。乃至广说。而作此论。四沙门果。须陀洹果。乃至阿罗汉果。云何须陀洹果。答曰。如波伽罗那说。须陀洹果。有二种。有为无为。云何有为须陀洹果。答曰。证须陀洹果时。已得今得当得。诸学法。已得是过去。今得是现在。当得是未来。是名有为须陀洹果。云何无为须陀洹果。答曰。证须陀洹果时。诸结断。已得今得当得。广说如上

问曰。道是有为堕世。已得今得当得。此事可尔。断是无为不堕于世。已得今得当得。云何可尔。答曰。波伽罗那经。应如是说。诸结断。今得今解今证。而不说者有何意耶。答曰。此说在身中得已得者。说过去身得今得者。说现在身得当得者。说未来身得。如须陀洹果。斯陀含果。阿那含果。说亦如是。云何阿罗汉果。答曰。阿罗汉果有二种。谓有为无为。云何有为阿罗汉果。答曰。证阿罗汉果时。已得今得当得。诸无学法。广说如上。施设经说。云何须陀洹果。答曰。须陀洹果有二种。谓有为无为。云何有为须陀洹果。答曰。彼果得彼得得果。得者。谓须陀洹果得。得得者。谓彼得得。以得故名果。以得得故名成就。诸学根学力学戒学善根学八法。如是等诸学法。名有为须陀洹果。云何无为须陀洹果。答曰。永断三结。如是等诸结法断。八十八使断。如是等诸使法断。是名无为须陀洹果。云何斯陀含果。答曰。斯陀含果有二种。谓有为无为。广说如上。此中差别者。渐断爱恚痴。及渐断受恚法。云何阿那含果。答曰。阿那含果有二种。谓有为无为有为阿那含果如上说。无为阿那含果者。永断五下分结。永断如是等结法。永断九十二使。永断如是等使法。是名无为阿那含果。云何阿罗汉果。答曰。阿罗汉果有二种。谓有为无为。云何有为阿罗汉果。答曰。阿罗汉果得。及彼得得果。得者。谓阿罗汉得。得得者。谓彼得得。以得故名果。以得得故名成就。诸无学根无学力无学戒无学善根无学十种法。如是等诸无学法。是名有为阿罗汉果。云何无为阿罗汉果答曰。永断爱慢痴一切烦恼。出一切趣。断一切生死道。灭三种火。已过四流。摧灭诸慢。离于渴爱。破散巢窟。无上究竟。无上寂灭。无上安乐。爱尽无欲涅槃。是名无为阿罗汉果。此是沙门果体性。乃至广说

已说体性。所以今当说。何故名沙门果。沙门果是何义。答曰。圣道名沙门。是其果故。名沙门果。问曰。圣道名沙门。彼果是沙门果者。见道中八忍。名沙门八智。是有为沙门果。八种结断。是无为沙门果。离欲爱时。九无碍道。名沙门。九解脱道。是有为沙门果。九种结断。是无为沙门果。乃至离非想非非想处欲。亦如是。是则有八十九有为沙门果八十九无为沙门果。以世分别。八十九在过去。八十九在未来。八十九在现在。波伽罗那经说。云何果法。答曰。一切有为及数灭。随有几许圣道。刹那有尔许。有为沙门果。随有几许解脱法。有尔许沙门果。若以刹那在身分别。则有无量无边沙门果。何故佛经惟说四沙门果。答曰。或有说者。此是如来有余略要。为受化者而作是说尊者波奢说曰。佛决定知法相。亦知势用。余人所不知。若法次第相续立沙门果。彼次第相续。说沙门果。复次是时易见易施设。谓此是须陀洹果。乃至阿罗汉果。果中间不易见。不易施设。复次行者。是时于果生大悦适譬如农夫。于六月中。修治田业。后获子实。积聚场上。心大悦适彼亦如是。复次是时有三事故。一得未曾得道。二舍曾得道。三断烦恼同于一味。复次是时有五事。一得未曾得道。二舍曾得道。三断烦恼同于一味。四顿得八智。五修十六行。复次是时是止息处。复次是时断结事事成。道方便方便成。果中间。断结事未成。道方便未成。复次是时容广修道果中间不容广修道。复次行者是时善知功德过恶。知功德者。是道道果。知过恶者。是生死法。复次行者是时善取相貌。如人道中行时。不能善取四方相貌。若坐一处。则能善取四方相貌。彼亦如是。复次行者是时有随从知见。犹如有人。于村落中间。为人所劫。无有随从知见者。若在村落为人所劫。多有随从知见者。复次行者是时先广修方便道。立足处牢固。须陀洹果。广修方便道者。先为解脱故。修施持戒。闻慧思慧修慧。暖顶忍世第一法。见道中十五心顷是也。斯陀含果。广修方便道者如上说。诸善复更有未曾有者。离欲界方便道六无碍道五解脱道是也。阿那含果。广修方便道者如上说。诸善复更有未曾有者。离欲爱时。方便道三无碍道二解脱道是也。阿罗汉果。广修方便道者。如上说。诸善复更有未曾有者。离初禅欲时。方便道九无碍道九解脱道。乃至离无所有处欲说亦如是。离非想非非想处欲时。方便道九无碍道八解脱道是也。复次行者是时断一切生分。止一切生分。须陀洹。除欲界七生分。色无色界一一生处。除一生分。余一切生分。得非数灭。斯陀含。除欲界二生分。色无色界一一生处。除一生分。余一切生分。得非数灭。阿那含。色无色界一一生处。除一生分。余一切生分。得非数灭。阿罗汉。一切生分。得非数灭。复次行者是时顿证三界见道修道所断烦恼。须陀洹。顿证三界见道所断烦恼斯陀含。顿证三界见道所断烦恼及欲界修道所断六种烦恼。阿那含。顿证三界见道所断烦恼及欲界修道所断九种烦恼。阿罗汉。顿证三界见道修道所断烦恼。复次根本沙门果退者不命终。果中间退者命终。复次对五趣故。说四沙门果。须陀洹果。对地狱畜生饿鬼道。斯陀含果。对人道少分。阿那含果。毕竟对人道。阿罗汉果对于天道。复次对四生故。须陀洹果。对湿生卵生。斯陀含果。对胎生少分。阿那含果。毕竟对胎生。阿罗汉果。对化生。复次对二种思故一断善根思。二造五逆业思。须陀洹果。对断善根思。斯陀含果。对造五逆业思。阿那含果。对彼业报。阿罗汉果。对彼受报阴。所以者何。受报必依阴故。复次对三三法故。须陀洹果。对三结。斯陀含果。对渐薄三不善根及欲漏阿那含果。毕竟对三不善根及欲漏。阿罗汉果。对有漏无明漏。复次对四流故。须陀洹果。对见流。斯陀含果。对欲流少分。阿那含果。毕竟对欲流。阿罗汉果。对有流无明流。对扼亦如是复次对四取故。须陀洹果。对见取取戒取取。斯陀含果。对欲取少分。阿那含果。毕竟对欲取阿罗汉果。对我语取。复次对三五法故。须陀洹果。对疑盖下分中三结。斯陀含果。对余盖下分中二结。少分阿那含果毕竟对。余盖下分中二结。阿罗汉果。对上分结。复次对诸见及六爱身故。须陀洹果。对五见。斯陀含果。对鼻舌触生爱身少分。阿那含果。毕竟对鼻舌触生爱身。阿罗汉果。对余爱身。复次对七使故。须陀洹果。对见使疑使。斯陀含果。对欲爱使恚使少分。阿那含果。毕竟对欲爱使恚使。阿罗汉果。对余使。复次对九结故。须陀洹果。对见结取结疑结斯陀含果。对恚结嫉结悭结少分。阿那含果毕竟对恚结。嫉结悭结。阿罗汉果对余结。复次对九十八使故。须陀洹果。对三界见道所断使。斯陀含果对欲界修道所断少分。阿那含果。毕竟对欲界修道所断。阿罗汉果。对色无色界修道所断。问曰。何故离欲爱时。立二沙门果。谓斯陀含果。阿那含果。离色无色界爱时。立一沙门果。谓阿罗汉果。尊者波奢说曰。皆以离三界爱故。立四沙门果。以断三界见道所断结故。立须陀洹果。以断三界见道所断结及欲界修道所断六种结故。立斯陀含果。以断三界见道所断结及欲界修道所断九种结故立阿那含果。以断三界见道修道所断结故。立阿罗汉果。复次欲界。是不定界非修地非定地。非离欲地。离彼欲时。立二沙门果。色无色界。是修地定地。离欲地离彼爱时。立一沙门果

复次欲界。难断。难坏。难过。离彼欲时。立二沙门果。色无色界。与此相违。离彼爱时。立一沙门果复次欲界多重过患。离彼欲时。立二沙门果。色无色界。与此相违。离彼欲时。立一沙门果。复次欲界。是駚流难度。离彼欲时。立二沙门果。犹如有人。入山间大河。其水深广駚疾。为其所漂。处处止息。然后乃度。如是欲界是流漂界。如经说村主当知。夫流漂者。是上妙五欲。离彼欲时。立二沙门果。色无色界。与此相违。离彼欲时。立一沙门果。复次欲界诸烦恼。重所作业。亦重离彼欲时。立二沙门果。譬如负重担人。上崄难山。必数止息。然后乃到平地。虽复重担犹能远有所至。如是欲界诸烦恼。重所作业。亦重离彼欲时。立二沙门果。色无色界。与此相违。离彼欲时。立一沙门果。复次欲界。是淤泥粪秽界。离彼欲时。立二沙门果。色无色界。与上相违。离彼爱时。立一沙门果。譬如粪秽聚上立堂舍人所不乐。如是色无色界。虽复妙好。以下有不净欲界故。贤圣不乐。是故尊者僧伽婆修。作如是说。欲界多诸过恶。谓父母兄弟姊妹妻子死丧。亡失财物。截劓耳鼻头手等苦头痛等。四百四病。若离此处欲时。立二沙门果。亦无有过。复次以欲界有男身女身。离彼欲时。立二沙门果。色无色界。唯有男身。离彼欲时。立一沙门果。复次欲界有男根女根。离彼欲时。立二沙门果。色无色界。无男女根。离彼欲时。立一沙门果。复次欲界有二种烦恼。谓不善无记。离彼欲时。立二沙门果。色无色界。有一种烦恼。谓无记。离彼欲时。立一沙门果。如不善无记。有报无报生。二果一果。与无惭无愧相应不与无惭无愧相应。当知亦如是。复次以欲界有忧根苦根无惭无愧嫉悭饮食爱淫欲爱诸盖五欲如是等过。离彼欲时。立二沙门果。色无色界。无如是等过。离彼欲时。立一沙门果。问曰。圣道沙门。是彼果故。名沙门果。若以无漏道。得沙门果者可尔。若以世俗道。得斯陀含果阿那含果。云何可尔。答曰。如以无漏道离欲爱。次第立斯陀含果阿那含果。圣人以世俗道离欲爱。亦次第立斯陀含果阿那含果。尊者僧伽婆修说曰。以世俗道断结。无漏道。于未来修二沙门果。是彼道果。不应作如是说。所以者何。未来道。不能有所作。复有说者。以世俗道现在前断结无漏道得。一切时生。无有断绝二沙门果。即是彼果。不应作是说。所以者何。非是彼果。复有说者。金刚喻定。是实义沙门。通证三界。见道修道所断烦恼解脱得。即是彼果。评曰。以从多分故。是沙门果。圣道果多。非有漏道果多。若以世俗道。得斯陀含果。三界见道所断结断。是沙门果。欲界系修道所断六种结。尽是世俗道果。若以世俗道。得阿那含果。三界见道所断结断。是沙门果。欲界系修道所断九种结断。是世俗道果。是故当知从多分故名沙门果

问曰。四沙门果。几是假名。几是实义。答曰。二是假名。谓斯陀含果。阿那含果。二是实义。谓须陀洹果。阿罗汉果。问曰。何故二是假名二是实义。答曰。以此二果或以世俗道得或以无漏道得。须陀洹果。阿罗汉果。悉以无漏道得故。复次斯陀含果。阿那含果。以世俗假名道得故果亦是假名。须陀洹果。阿罗汉果。不以假名道得。故名实义。复次以世俗道无漏道共得故名假名。复有说者。二是实义。谓阿那含果阿罗汉果。所以者何。佛辟支佛声闻。皆得此二果故。问曰。外物或得果多。或得果少。断法不尔。云何言果。答曰。以方便故。言果行者。住于高山闲静房舍。于诸饮食资生之物。皆悉知量受一七六七法。顶安禅镇行禅鞠。法杖坚强精进。生如是法。是时其师。深慰劳言。善哉善哉。汝行正方便。今得此果。譬如农夫。于六月中。修治田业。后获子实。聚置场上。诸旧农夫。慰劳新者。善哉善哉。汝六月劳勤。今获此果。彼亦如是。问曰。此四沙门果。几是禅果。几是无色定果。几是根本禅果。几是禅边果。几是根本无色定果几是无色定边果。几是见道果。几是修道果。几是忍果。几是智果。几是法智果。几是比智果。几是法智分果。几是比智分果。几是有漏道果。几是无漏道果。几是禅果者。答曰。四是禅及眷属果。几是无色定果者。答曰。一是无色定果。谓阿罗汉果。几是根本禅果者。答曰。二谓阿那含果。阿罗汉果。几是禅边果者。答曰。四谓初禅边。非余禅边。几是根本无色定果者。答曰。一谓阿罗汉果。几是无色定边果者。答曰。无几是见道果者。答曰。三除阿罗汉果。几是修道果者。答曰。三除须陀洹果。几是忍果者。答曰。三除阿罗汉果。几是智果者。答曰。三除须陀洹果。几是法智果者。答曰。三除须陀洹果。几是比智果者。答曰。一谓阿罗汉果。几是法智分果者。答曰。三除须陀洹果。几是比智分果者。答曰。四几是世俗道果者。答曰二。谓斯陀含果。阿那含果。几是无漏道果者。答曰四。佛经说摩伽陀国。毗提希子阿阇贳王。往诣佛所。头面礼足。在一面坐。白佛言。世尊。为设有现法沙门果。可得不耶。佛言。可得。佛告王言。我今问汝。随汝意答。于意云何。若王给侍。及诸奴仆。不自在者。见于大王。升高殿堂。五乐自娱。受诸快乐。便作是念。我亦是人。然王多修福故。升高殿堂。五乐自娱。受诸快乐。我等亦应修诸福业。信家非家。剃除须发舍家出家。彼于后时。即便出家。修行十善。不杀乃至正见王余使人。于外见之。若来白王作是言。大王侍使奴仆。不自在者。今已剃除须发。出家学道。修行十善。王今应当将还如前策使。王如其言。还将来耶。答曰。不也。我应往见亲近恭敬。如彼本日礼敬迎送于我。我今亦应礼敬迎送还恭敬之。尽其形寿。施与衣服饮食房舍卧具资生之物。大王当知。如此之事。岂非是现法沙门果耶。王白佛言。实如圣教。问曰。沙门果有四。今者何故说五沙门果耶。答曰。此是出家近功用果。如师子吼经复说。此处有初沙门第二沙门第三沙门第四沙门。非余外道沙门婆罗门空行之者。汝等应当如是作师子吼。此处有初沙门。乃至有第四沙门。初沙门者是须陀洹。第二沙门是斯陀含。第三沙门是阿那含。第四沙门是阿罗汉。尊者波奢说曰。佛世尊先说次第根本法。初沙门者。是阿罗汉。第二沙门者。是阿那含。第三沙门者。是斯陀含。第四沙门者是须陀洹。须跋陀罗经复说。须跋陀罗当知。此处若有八圣道。便有初沙门果乃至第四沙门果。或有说者。此中说四向是沙门。初沙门者是向须陀洹果证。第二沙门者。是向斯陀含果证。第三沙门者是向阿那含果证。第四沙门者是向阿罗汉果证。尊者波奢说曰。此中说四向四果是沙门。如说。须跋陀罗当知。若有八圣道处。当知说向。便有初沙门乃至第四沙门。当知说果。纯陀经复说。有四沙门无第五沙门。四沙门者一胜道沙门。二说道沙门。三道命沙门。四过道沙门。胜道沙门者是佛世尊。所以者何。以佛有自然智故。辟支佛亦尔。说道沙门者如舍利弗等。所以者何。我随佛转法轮故。余无学声闻亦尔。道命沙门者阿难是。所以者何。彼是学亦令他住学法。多闻持戒具足。余学声闻亦尔。过道沙门者如摩诃罗偷盗者是。问曰。师子吼经所说沙门。须跋陀罗经所说沙门。纯陀经所说沙门。有何差别。答曰。或有说者。师子吼经。说住果沙门。须跋陀罗经。说住向沙门。纯陀经说在向住果。沙门。复有说者。师子吼经。须跋陀罗经。说住果沙门。纯陀经。说一切沙门。复有说者。师子吼经。须跋陀罗经。说圣人沙门纯陀经。说圣人凡夫沙门。复有说者。师子吼经。须跋陀罗经。说学无学沙门。纯陀经。说学无学非学非无学沙门。复有说者。师子吼经。须跋陀罗经。说净戒沙门。纯陀经。说净不净戒沙门。复有说者。如师子吼经所说沙门。须跋陀罗经。纯陀经所说亦尔。如须跋陀罗经所说沙门。师子吼经。纯陀经。所说亦尔。如纯陀经所说沙门。师子吼经。须跋陀罗经。所说亦尔。问曰。若然者此说云何通。如说作如此师子吼。我此众中。有初沙门乃至第四沙门。世尊亦说恶戒破诸威仪离于白法之人。而师子吼耶。答曰。亦说。所以者何。彼虽破戒。而不破见。虽破方便。不破期心。若他人问此事为好。为不好耶。答言不好。是沙门所应作所不应作耶。答曰。不应作此事。为有报为无报耶。答言。有报。此报为是可爱为恶道中受。为人天中受。答言。恶道中受。为自身受。为他身受。答言。自身受。非他身受。为是师过。为是经过。答言。非是师过。答言。亦非经过。是我之过如是正见。于因缘中不愚。则九十六种道中所无。是故世尊。于此众中。作师子吼

佛经说世有三人。名多有所作计。其所作不易可报。若尽形寿。衣服饮食随病医药。而供养之。亦不能报。云何为三有人。为他说法。令信家非家。舍家出家。是名初人。多有所作不易可报。次复有人。为他说法。令他能知集法皆是灭相。于诸法中。远尘离垢。得法眼净。是人所作不易可报。乃至广说。次复有人。为他说法。能令他人。尽有漏成无漏心得解脱慧得解脱自身作证。是人所作不易可报。乃至广说。问曰。如教人令受优婆塞戒。是人亦名多有所作。此中何故不说耶。答曰。应说而不说者。当知此说有余。复次以出家戒。是因果故。出家戒。是比丘戒因。是优婆塞戒果。复次若教他出家。则名教他入假名法。入法有二种。一者入假名法。二者入实义法。入假名法者剃除须发出家是也。入实义法者住世第一法。入苦法忍是也。复次若教他出家。则令他人脱多役驱使等种种诸苦。复次若教他出家。则救济他人虽于现苦。不久亦当得离生老病死苦。复次若教他出家。则令他人得现法乐。不久亦当得自在乐。复次若教他出家。则假名佛出世间。不久亦当实义。佛出世间。复次若教他出家。则教他人三戒三身三学三修三净三道三地三根三种菩提。复次若教他出家。则得决定解脱道。如说。若能剃除须发出家者。此人必当决定知见四真谛法。复次若教他出家。则教他人。令身少事。身少事。能生心少事。身远心远。身净心净。身好心好。身端正心端正亦如是。复次若教他出家则教他剃发。着袈裟。剃发则能生牟尼着袈裟则能去离恶。复次若教他出家。则令他人得无尽业无尽财无过业无过财。复次若教他出家。则令他人尽形寿持戒。净修梵行。伤佉诸利。伤佉诸利。是何义耶。尊者和须蜜说曰。有仙人。一名伤佉。二名诸利。净修梵行。威仪具足。在家之人。所不能行。如画珂贝上。非风吹日曝。所能坏灭。在家之人。修行梵行。不能如是如画贝上分明了了。在家之人。修行梵行。不能如是。如阿那含。犹如妻子。畜众生数非众生数物。凡夫圣人。无有差别。复次若教他出家。则示他人。帝释转轮圣王。阎罗王所欲之事。问曰。何故教他出家置二果。唯说须陀洹果阿罗汉果。答曰。已说在此义中。所以者何。远尘离垢。得法眼净。三果可尔。具缚人。渐离欲人。永离欲人。得正决定。悉名远尘离垢得法眼净。复以现始终故。始是须陀洹果。终是阿罗汉果。如始终。始入已度方便毕竟。说亦如是。复次此二果。一向无漏道得。非有漏道。二果无漏有漏道得。如有漏无漏道。解脱道。系缚道。亦如是。复次此果俱过。非想非非想处人得须陀洹果。过非想非非想处见道所断结。乃得阿罗汉果。过非想非非想处修道所断结乃得。复次此现门现略所有沙门果或以见道得。或以修道得。若说须陀洹果。当知已说见道得者。若说阿罗汉果。当知已说修道得者。如见道修道。见地修地。未知欲知根知根。说亦如是。复次有沙门果。或因见道所断结尽而立。或因修道所断结尽而立。如见道所断。缘无所有烦恼。缘所有烦恼。忍对治烦恼。智对治烦恼。亦如是。复次已说在此义中。所以者何。以必得故若得须陀洹果。必得斯陀含果。若得阿罗汉果。必由阿那含果

须陀洹成就诸学法彼法。须陀洹果摄耶

问曰。何故作此论。答曰。先说无为沙门果。今欲说有为无为沙门果故而作此论。须陀洹。成就诸学法。彼法须陀洹果摄耶。答曰。或摄或不摄云何摄。答曰。有为须陀洹果。得已不失。得者信解脱得信解脱诸根。见到得见到诸根。不失者信解脱不转根作见到。不失信解脱诸根。云何不摄。须陀洹。前进得胜妙无漏诸根。前进者方便道。六无碍道。五解脱道。如是等前进道所有学法。须陀洹成就。彼非须陀洹果摄。所以者何。前进道非果所摄。设法须陀洹果摄。彼法是学耶。答曰。或是学。或是非学非无学。云何是学。答曰。有为须陀洹果。谓道比智。及眷属。云何是非学非无学。答曰。无为须陀洹果。谓三界见道所断结断。斯陀含成就诸学法。彼法斯陀含果摄耶。答曰。或摄或不摄。云何摄。答曰。有为斯陀含果。得已不失。得者信解脱得信解脱诸根。见到得见到诸根。不失者信解脱不转根作见到。不失信解脱诸根。云何不摄斯陀含。前进得胜妙无漏诸根。前进者。方便道。三无碍道。二解脱道。如是等前进道所有学法。斯陀含成就。彼非斯陀含果摄。所以者何。前进道非果所摄。设法斯陀含果摄。彼法是学耶。答曰。或是学或是非学非无学。学者有为斯陀含果。若道比智及眷属。若第六解脱道及眷属。云何非学非无学。答曰。无为斯陀含果。谓三界见道所断结断及欲界修道所断六种结断。阿那含成就诸学法。彼法阿那含果摄耶。答曰。或摄或不摄。云何摄。答曰。有为阿那含果。得已不失。得者信解脱得信解脱诸根。见到得见到诸根。不失者信解脱不转根作见到。不失信解脱诸根。云何不摄。阿那含前进。得胜妙无漏诸根。前进者离初禅欲。方便道。九无碍道。九解脱道。乃至离非想非非想处爱方便道。九无碍道。八解脱道。如是等前进道所有学法。阿那含成就。彼非阿那含果摄。所以者何。前进道非阿那含果摄。设法阿那含果摄。彼法是学耶。答曰。或是学或是非学非无学。云何是学。答曰。有为阿那含果若道比智及眷属。若第九解脱及眷属。云何非学非无学。答曰。无为阿那含果。三界见道所断结断。及欲界修道所断九种结断。阿罗汉成就诸无学法。彼法阿罗汉果摄耶。答曰。如是。所以者何。阿罗汉所有方便道。无碍道。解脱道。前进道。尽阿罗汉果摄。设法阿罗汉果摄。彼法是无学耶。答曰。或是无学或是非学非无学。云何是无学。答曰。有为阿罗汉果。尽智无生智。无学等见及眷属。云何非学非无学。答曰。无为阿罗汉果。三界见道修道所断结断

须陀洹成就诸无漏法。彼法须陀洹果摄耶。答曰。或摄或不摄。云何摄。答曰。须陀洹果。得已不失。得者信解脱得信解脱性。须陀洹果。见到得见到性。须陀洹果。三界见道所断结断。不失者信解脱不转根作见到。不失信解脱性须陀洹果。云何不摄。须陀洹果前进。得胜妙诸无漏根。方便道。六无碍道。五解脱道。如是等前进道。及渐断结得作证。谓欲界修道所断五种结断。如前进道非果摄。彼断亦尔。须陀洹所成就非数灭。此灭非是须陀洹果。所以者何。非数灭是无记。须陀洹果是善故。设法须陀洹果摄。彼法是无漏耶。答曰。如是。所以者何。有为须陀洹果无为须陀洹果皆是无漏故。斯陀含成就诸无漏法。彼法斯陀含果摄耶。答曰。或摄或不摄。云何摄。答曰。斯陀含果。得已不失。得者信解脱性得信解脱斯陀含果。见到得见到性斯陀含果。三界见道所断结断。及欲界修道所断六种结断。不失者信解脱不转根作见到。不失信解脱性斯陀含果。云何不摄斯陀含果前进。得胜妙诸无漏根。方便道。三无碍道。二解脱道。如是等道。及渐断结得作证。谓欲界修道所断二种结断。如前进道非斯陀含果摄。断亦如是。斯陀含果所成就非数灭。此灭非是斯陀含果。所以者何。非数灭是无记。斯陀含果是善故。设法是斯陀含果摄。彼法是无漏耶。答曰。如是。所以者何。有为斯陀含果。无为斯陀含果。皆是无漏故。阿那含成就无漏诸法。彼法阿那含果摄耶。答曰。或摄或不摄。云何摄。答曰。阿那含果。已得不失。得者信解脱得信解脱性阿那含果见到得见到性阿那含果。三界见道所断结断。及欲界修道所断九种结断。不失者信解脱不转根作见到。不失信解脱性阿那含果。云何不摄。答曰。阿那含前进。得胜妙无漏诸根。离初禅爱。方便道。九无碍道。九解脱道。如是乃至离非想非非想处爱。方便道。九无碍道。八解脱道。如是等道。及渐断结得作证。谓离七地爱及非想非非想处八种爱。如前进道非果摄。彼断亦尔。阿那含所成就非数灭。广说如上。设法阿那含果摄。彼法是无漏耶。答曰。如是。广说如上。阿罗汉成就无漏诸法。彼法阿罗汉果摄耶。答曰。或摄或不摄。云何摄。答曰。已得阿罗汉果不失。得者时解脱得。时解脱性。非时解脱得。非时解脱性。三界见道修道所断结断。不失者时解脱不转根作非时解脱。不失时解脱性阿罗汉果。云何不摄。答曰。阿罗汉所成就非数灭。于如是法得非数灭。谓欲界色无色界系有漏。及无漏法非数灭。此灭非是阿罗汉果。所以者何。非数灭是无记。阿罗汉果是善故。设法阿罗汉果摄。彼法是无漏耶。答曰。如是。所以者何。有为阿罗汉果。无为阿罗汉果。皆是无漏故

须陀洹成就诸法。彼法须陀洹果摄耶。此中问转增法。先问学次问无漏。今问不定。须陀洹成就诸法。彼法须陀洹果摄耶。答曰。或法须陀洹果成就。彼法非须陀洹果摄。云何法须陀洹成就。彼法非须陀洹果摄。答曰。须陀洹前进。得胜妙无漏诸根及渐断结得作证。须陀洹所成就非数灭。亦成就有漏诸法。谓善染污不隐没无记善者。数方便善。生得善。染污者三界修道所断染污。不隐没无记者威仪工巧报。如是等法。须陀洹成就。非须陀洹果摄。云何法须陀洹果摄。彼法非须陀洹成就。答曰。不得须陀洹果。得已便失。不得者信解脱不得见到性。须陀洹果。见到不得信解脱性须陀洹果。得已便失者。信解脱转根作见到。便失信解脱性须陀洹果。云何法须陀洹成就。彼法亦须陀洹果摄。答曰。得须陀洹果不失。广说如上。云何法须陀洹果不成就。彼法非须陀洹果摄。答曰。除上尔所事。若法已称名已说者。作第一第二第三句。未称未说者。作第四句。彼是何耶。答曰。有三种。谓善染污不隐没无记。善有二种。谓无漏有漏。无漏者一切上下无漏道。有漏者谓方便善。离欲善。生得善。若本不得。若得便失。染污者。三界见道欲界修道所断染污。须陀洹已断者。不隐没无记者。谓威仪工巧报须陀洹所不成就者。一切变化心。如是等诸法。作第四句故。言除上尔所事。如须陀洹。斯陀含亦如是。阿那含成就诸法。彼法阿那含果摄耶。乃至广作四句。云何法阿那含成就。彼法非阿那含果摄。答曰。阿那含前进。得胜妙无漏诸根及所断结得作证。阿那含所成就非数灭。广说如上。阿那含成就。诸余有漏法。彼是何耶。答曰。有三种。谓善染污不隐没无记。善者方便善。生得善。离欲善。染污者。色无色界系修道所断染污。不隐没无记者。威仪工巧报变化心。如阿那含所成就者。云何法阿那含果摄。彼法非阿那含成就。答曰。不得阿那含果。得已便失。不得者。信解脱不得见到性阿那含果见到不得信解脱性阿那含果。得已便失者。信解脱转根作见到。失信解脱性阿那含果。云何法阿那含成就。彼法阿那含果摄。答曰。得阿那含果不失。得者信解脱得信解脱性阿那含果。见到得见到性阿那含果。三界见道所断结断欲界修道所断九种结断。不失者信解脱不转根作见到。不失信解脱性阿那含果。云何法非阿那含成就。彼法亦非阿那含果摄。答曰。除上尔所事。若法已称名已说者。作第一第二第三句。未称未说者。作第四句。彼是何耶。答曰。有三种。谓善染污不隐没无记。善者谓无漏有漏。无漏者上下无漏道。有漏者方便善。生得善。离欲善。若本不得。若得便失。染污者三界见道所断染污。欲界修道所断染污。不隐没无记者。威仪工巧报变化心。本不得得已便失者。如是等诸法。作第四句。故言除上尔所事。阿罗汉成就诸法。彼法阿罗汉果摄耶。乃至广说四句。云何法阿罗汉成就。彼法非阿罗汉摄。答曰。阿罗汉成就非数灭。谓善染污不隐没无记。阿罗汉于此法。得非数灭。阿罗汉所成就有漏法。此法有二种。谓善不隐没无记。善者方便善。生得善。离欲善。若不隐没无记者。威仪工巧报变化心。阿罗汉所成就者。云何法阿罗汉果摄。彼法非阿罗汉成就。答曰。阿罗汉。本不得。得已便失。不得者时解脱不得非时解脱性阿罗汉果。非时解脱不得时解脱性阿罗汉果。得已便失者。时解脱转根作不时解脱。失时解脱性阿罗汉果。云何法阿罗汉成就。彼法阿罗汉果摄。答曰。阿罗汉果。得已不失。得者时解脱得时解脱性阿罗汉果。不时解脱得不时解脱性阿罗汉果。三界见道修道所断结断。不失者。时解脱。阿罗汉。不转根作不时解脱。不失时解脱性阿罗汉果。云何法阿罗汉不成就。彼法非阿罗汉果摄。答曰。除上尔所事。若法已称名已说者。作第一第二第三句。未称未说者。作第四句。彼是何耶。答曰。有三种。谓善染污不隐没无记。善者方便善。离欲善。生得善。阿罗汉。本不得。得已便失者。染污者三界见道修道所断染污。不隐没无记者。威仪工巧报变化心。阿罗汉。本不得。得已便失者。如是等诸法。作第四句故。言除上尔所事

问曰。信解脱为转根作见到不耶。若转者。根揵度中。何以不说。如说若舍无漏根。得无漏根。彼尽从果至果耶。答曰。若从果至果。尽舍无漏根。得无漏根。颇有舍无漏根得无漏根彼非从果至果耶。答曰。有得正决定道。比智现前时。时解脱阿罗汉。转根作不动。彼尊者有何劳惓。不说信解脱转根作见到耶若信解脱。不转根作见到者。此文所说云何通。如说若不得须陀洹果。得已便失。若信解脱。不转根作见到者。云何言得已便失耶。智犍度说复云何通。如说须陀洹。于此三三昧。未来尽成就。过去已灭不失。现在若现在前。若信解脱不转根作见到者。已灭三昧。云何失耶。识身经说。复云何通。如说过去无学心。得作三句。名已知。不名今知。不名当知。此中成就已知名说时解脱阿罗汉。退作信解脱。转根作见到。还得阿罗汉果。今不成就。不当成就时解脱道。答曰。应作是说。信解脱转根作见到

问曰。若然者后所说善通根揵度中。何故不说耶。答曰。彼文应如是说。得正决定。道比智现在前。信解脱转根作见到。时解脱转根作不动。应如是说。而不说者有何意耶。答曰。现始终故。始是道比智。终是时解脱转根作不动。如始终。初入已度方便毕竟亦如是。尊者僧伽婆修说曰。信解脱转根作见到。得斯陀含果时。亦名是得果。亦名转根。得阿那含果时。亦名得果。亦名转根。问曰。若然者。得须陀洹果时。何不名转根。得阿罗汉果时。何不名转根耶。答曰。出过欲界。是数数旧法。无有众生不曾不出过欲界者。是故离彼欲时。得二沙门果。亦名得果。亦名转根。出过非想非非想处。非是数数旧法。无有众生曾出过者。是故离彼欲时。得二沙门果。但名得果。不名转根

问曰。如汝所说。得斯陀含果阿那含果时。亦名得果。亦名转根。是事可尔。退法转根作忆法。乃至等住转根作能进。此中何以不说。彼作是答。已说在此义中。何以知之。退法转根作忆法时。得忆法时根。不舍退法根。乃至等住转根作能进时。得能进根。不舍四种根。能进转根作不动时。得不动根。不舍五种根。彼不应作是说。所以者何。无有一人成就二根者。何况多耶。复有说者。信解脱不转根作见到。是故根揵度不说

问曰。若然者。智揵度说云何通。答曰。彼文应如是说。须陀洹三三昧。未来悉成就现在若现在前。过去已灭。不应言不失。应说而不说者。有何意耶。答曰。诵习错谬故

问曰。此文所说复云何通。答曰。或有说。成就过去未来得。或有说不成就过去未来得。若作是说。不成就过去未来得者。彼作是说。若不得须陀洹果。是说未来。若得已是说现在。便失是说过去。若作是说。成就过去未来得者彼作是说。须陀洹果有三种。谓下中上。若初住下须陀洹果。不得中上须陀洹果。故言不得。得下须陀洹果。故言得已。不应言便失。若初住中须陀洹果。故言得已。不得上须陀洹果。故言不得。失下须陀洹果。故言便失。若初住上须陀洹果。不应言不得。得上须陀洹果。故言得已。便失者。失中下须陀洹果

问曰。本不成就中下须陀洹果。何故言失。答曰。超过二根故名失。所以者何。超彼二根能生之势故作是说。识身经复云何通。答曰。识身经则不可通。评曰。应作是说。信解脱转根作见到。若信解脱不转根作见到者。时解脱亦不转根作不动。所以者何。如学地无止息无救护无学地亦尔

尊者佛陀罗测说曰。信解脱转根作见到。有六事不共。一在欲界不在色无色界。二依禅不依无色定。三用无漏道。不用世俗道。四用法智。不用比智。五退非不退。六住果道。不住胜果道。在欲界不在色无色界者。欲界有说法。人以说法力故。能转根钝作利。依禅不依无色定者。本依何地得学果。即依彼地。信解脱转根作见到。用无漏道。不用世俗道者。以猛利道能转根。世俗道非猛利。用法智不用比智者。生欲界转根者。于法智得自在。不于比智。退非不退者。厌患退故转根。住果道非胜果道者。若住胜果道转根者。则失多道得少道。是名减少。不名增益。阿毗昙者。作如是说信解脱转根作见到。如彼所说。但于六事中。三事不可尔。唯在欲界不在色无色界。此事可尔。依禅不依无色定。此亦可尔。唯以无漏道。不以世俗道者。此亦可尔。唯用法智。不用比智者。此不必尔。所以者何。或有于比智善得自在非法智。退法非不退法者。此不必尔。所以者何。退法亦能转根。不退法亦能转根。不必退法。唯住果道不住胜果道者。此不必尔。所以者何。住果道。亦能转根。住胜果道。亦能转根。问曰。若然者岂非舍多道得少道。是损减非增益耶。答曰。彼求利根。不求多道

尊者瞿沙跋摩说曰。信解脱转根作见到。唯在阎浮提。不在余方。问曰。依何地得学果。即依彼地转根耶。答曰。即依彼地。亦依余地。是胜地非下。须陀洹。斯陀含。必依未至禅。得果转根阿那含依得果地。亦依余地转根。阿那含极少者。成就三地阿那含果。谓初禅未至中间禅。若依未至。若依初禅。若依禅中间。必成就三地道比智阿那含果。若依二禅。得正决定者。必成就四地道比智阿那含果。若依第三禅。成就五地。若依第四禅。成就六地。次第人离欲爱时。最后解脱道。成就三地阿那含果。若依初禅。得正决定。即依初禅转根者。彼舍三地阿那含果。得三地阿那含果。若依初禅。得正决定。依第二禅转根者。彼舍三地得四地。若依初禅。得正决定。依第三禅转根者。彼舍三地得五地。若依初禅。得正决定。依第四禅转根者。彼舍三地得六地若依二禅。得正决定。即依二禅转根者。彼舍四地得四地。若依二禅。得正决定。依第三禅转根者。彼舍四地得五地。若依二禅。得正决定。依第四禅转根者。彼舍四地得六地。若依三禅得正决定。即依三禅转根者。彼舍五地得五地。若依三禅得正决定。依第四禅转根者。彼舍五地得六地。若依第四禅得正决定。即依第四禅转根者。彼舍六地得六地。问曰。颇有依上地得果依下地转根耶。答曰。或有说者无。若有者则舍多道得少道。是损减非增益故。复有说者有。如依第四禅得正决定。依第三禅转根者。舍六得五。依第四禅得正决定。依第二禅转根者。舍六得四。依第四禅得正决定。依初禅转根者。舍六得三。三禅二禅初禅。应随相说

问曰。若然者岂非舍多道得少道。是损减非增益耶。答曰。若尔亦无有过。所以者何。彼求利道。不求多道。颇有离无所有处爱圣人成就一地无漏耶。答曰有。离无所有处爱。依未至禅得正决定。见道中十五心顷是也。颇有离无所有处爱阿那含成就三地无漏耶。答曰有。若依初禅未至中间禅。信解脱转根作见到。颇有身证人不成就无漏无色定耶。答曰有。依禅信解脱转根作见到。未离初禅爱。依初禅转根者。舍三地无漏道。得三地无漏道。离初禅爱。未离二禅爱。依初禅转根者。舍四得三。离第二禅爱。未离第三禅爱。依初禅转根者。舍五得三。离第三禅爱未离第四禅爱。依初禅转根者。舍六得三。离第四禅爱。未离空处爱。依初禅转根者。舍七得三。离空处爱。未离识处爱。依初禅转根者。舍八得三。离识处爱。未离无所有处爱。依初禅转根者。舍九得三。离第二禅爱。乃至离识处爱。依第二禅转根者。舍九得四。离第三禅爱。乃至离识处爱。依第三禅转根者。舍九得五。离第四禅爱。乃至离识处爱。依第四禅转根者。舍九得六

问曰。离无所有处爱信解脱转根作见到。舍无色界对治道。为舍断不。若舍者何不成就结。若不舍者对治已舍。以何事故不舍断耶。答曰。应作是说。不舍。问曰。对治已舍。以何事故。不舍于断。答曰。无色界对治有二种得。虽舍无漏。不舍有漏。以为有漏所持故不舍。问曰。如有漏道。能有所作处可尔。不能有所作处。云何可尔。如渐离非想非非想处爱信解脱。转根作见到。舍非想非非想处修道所断对治道。为舍彼断不。若舍者。云何不成就结。若不舍者。对治已舍。以何事故。不舍于断。答曰。或有说者。无有渐离非想非非想处爱而转根者。若转者。或是退。或毕竟离欲。复有说者。有渐离非想非非想处爱转根者。舍对治道不舍断。评曰。应作是说。舍对治道亦舍断。而不成就结。如离无所有处爱。命终生非想非非想处。从欲界乃至识处所有对治道及断悉舍。而不成就结。彼亦如是

信解脱转根作见到时。用一方便道一无碍道一解脱道。时解脱转根作不动时。或有说以一方便道一无碍道一解脱道。评曰。应作是说。以一方便道九无碍道九解脱道。所以者何。以更得沙门果重用功故。如人坏舍。坏已更作。名重用功。彼亦如是。信解脱转根作见到时。方便道是有漏无漏。未来亦修有漏无漏道。无碍道是无漏。未来亦修无漏道。解脱道亦是无漏。或有说者。未来修有漏无漏道

或有说者。唯修无漏。时解脱转根。作不动时。方便道是有漏无漏。未来修有漏无漏道。九无碍道。八解脱道。唯是无漏。未来修无漏道。最后解脱道是无漏。未来修有漏无漏道。及三界善根。信解脱转根作见到时。方便道。或是曾得。或非曾得。无碍道。解脱道。一向非曾得时。解脱转根作不动时。方便道或是曾得。或非曾得。无碍道解脱道。一向非曾得。是信解脱转根作见到时。方便道无碍道。是信解脱道摄。解脱道是见到道摄。时解脱转根作不动时。方便道。九无碍。八解脱道。是时解脱道摄。最后解脱道。是非时解脱道摄。信解脱转根作见到时。若住果道。而转根者。彼方便无碍解脱道。是果道摄。若住胜果道。而转根者。彼方便无碍道。是胜果道摄。解脱道。是果道摄。时解脱转根作不动时。方便无碍解脱道。是果道摄。所以者何。无胜果道故。信解脱转根作见到时。住果而转根者。是名舍果得果。若住胜果道。而转根者。是名舍果舍胜果道而得果。时解脱转根。作不动时。名舍果得果

六种阿罗汉。谓退法。忆法。护法。等住。能进。不动。若退法转根作忆法时。舍退法根。得忆法根。若忆法转根作护法时。舍忆法根。得护法根。若护法转根作等住时。舍护法根。得等住根。若等住转根作能进时。舍等住根。得能进根。若能进转根作不动时。舍能进根。得不动根。如无学地六种。修道中六种学性亦如是

问曰。退法转根作不动时。为住退。法根得不动。为次等转五种根得不动耶。答曰。或有说者。住退法根转根得不动。无学时异用功多难得。是故次第转学地不尔。评曰。应作是说。一切时次第而转。如修道中有六种性。见道中亦有六种性。谓退法乃至不动。无有转根者。所以者何。见道是速疾不起道故。如见道中有六种性。修行地中。亦有六种性。谓退法乃至不动。若转者退法暖法不现在前。忆法暖法现在前。乃至能进暖法不现在前。不动暖法现在前。声闻性暖法不现在前。辟支佛性暖法现在前。辟支佛性暖法不现在前。佛性暖法现在前。如暖法顶法亦如是。忍差别者。声闻性忍不现在前。辟支佛性忍现在前。无有声闻辟支佛忍不现在前。佛忍现在前。所以者何。忍与恶趣相妨。菩萨以愿力故。当生恶趣。复有说者。声闻暖顶不现在前亦不起。辟支佛暖顶现在前。所以者何。如佛自然无师。彼辟支佛亦尔。如佛一结跏趺坐。生诸善法现在前。从不净乃至尽智无生智。辟支佛亦尔。世第一法。亦有六种性。退法乃至不动。无转根者。所以者何。彼善根一刹那顷。无住相故。须陀洹有六种性退法。乃至不动。是故作如是说。颇有退须陀洹果。不成就见道所断结耶。答曰有。从上根性退下根时

阿毗昙毗婆沙论卷第三十五阿毗昙毗婆沙论卷第三十六

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    使犍度人品下

欲界死还生欲界。尽欲界有相续耶。乃至广作四句有多名此中说有。是受身处众生数五阴有。余有广说。如一行中。云何欲界死。还生欲界。不欲界有相续耶。答曰。如欲界死生色界。中有现在前。欲界死生色界。亦是圣人亦是凡夫。彼色界中有。于欲界现在前。所以者何法应如是。若处所死有灭。即处所中有生。如种子灭处。此处即生于牙。彼亦如是欲界死者。是欲界死者有欲界死者。是色界中有。非欲有相续。色有相续。是色界中有。云何欲有相续。不欲界死。不生欲界。答曰。色界死。欲界中有现在前。凡夫人。于色界死。欲界中有。于色界现在前。法应如是。若处所死有灭。即处所中有生。广说如上。是名欲有相续。是欲界中有。非欲界死。非欲界生。所以者何。色界死是色界死有。色界生是欲界中有。云何欲界死还生欲界。欲界有相续耶。答曰。如欲界死还生欲界。中有生有。欲界死还生欲界。亦是圣人。亦是凡夫。凡夫于诸趣无碍生一一趣中。圣人于诸趣有碍。生人天中。欲界死是欲界死有。欲界生是欲界中有。欲界有相续者。是欲界中有。若从中有。至生有者。欲界死是欲界中有。若欲界生。是欲界生有。欲界有相续者。是欲界生有。云何非欲界死。非欲界生。非欲界有相续。答曰。色界死。生色界。中有生有。色界死生色界。中有生有者。亦是圣人亦是凡夫。若但死有至中有时。不名欲界死。所以者何。是色界死。色界死有。非欲界生。所以者何。色界生。是色界中有。非欲界有相续。所以者何。色界有相续。是色界中有。若从中有。至生有时。非欲界死。所以者何。是色界中有死。非欲界有相续。所以者何。色界有相续。是色界生有。色界死。生无色界。亦是圣人。亦是凡夫。彼非欲界死。所以者何。色界死是色界死有。非欲色界生。无色界生。是无色界生有。非欲界有相续。所以者何。无色界有相续。是无色界生有。无色界死。生无色界亦是圣人。亦是凡夫。凡夫人。生上亦生下。圣人生上不生下。凡夫人。一一处多生。圣人一一处一生。彼非欲界死。所以者何。无色界死。是无色界死有。非欲界生。所以者何。无色界生。是无色界生有。非欲界有相续。所以者何。无色界有相续。是无色界生有无色界死。生色界。是凡夫从死有至中有。彼非欲界死。所以者何。无色界死。是无色界死有。不生欲界。所以者何。无色界生。是色界中有。非欲有相续。所以者何。色有相续。是色界中有。色界死。还生色界。尽色界有相续耶。乃至广作四句。云何色界死。还生色界。非色界有相续耶。答曰。色界死。欲界中有现在前。色界死。生欲界。是凡夫人。欲界中有。于色界现在前。广说如上。色界死。是色界死有。生色界。是欲界中有。非色界有相续。所以者何。欲界有相续。是欲界中有。云何色界有相续。非色界死。非色界生。答曰。如欲界死。色界中有现在前。欲界死。生色界。亦是凡夫。亦是圣人。彼色界中有。于欲界现在前。广说如上。是名色界有相续。色界中有。非色界死。所以者何。欲界死。是欲界死有。非色界生。所以者何。欲界生。是色界中有。云何色界死。还生色界。色界有相续耶。答曰。色界死还生色界。中有生有。色界死。还生色界。亦是凡夫。亦是圣人。凡夫生上亦生下。一一处有多生。圣人生上不生下。一一处有一生。从死有至中有时。色界死。是色界死有。色界生。是色界中有。色界有相续。是色界中有。从中有至生有时。色界死。是色界中有。色界生是色界生有。色界有相续。是色界。生有。云何非色界死。非生色界。非色界有相续。答曰。欲界死。生欲界。中有生有。欲界死。还生欲界。亦是凡夫。亦是圣人。广说如上。从死有至中有时。非色界死。非生色界。所以者何。欲界死。是欲界死有。欲界生。是欲界中有。非色界有相续。所以者何。欲界有相续。是欲界中有。从中有至生有时。非色界死。非色界生。所以者何。欲界死。是欲界中有。欲界生是欲界生有。非色界有相续。所以者何。欲界有相续。是欲界生有。欲界死生无色界。亦是凡夫。亦是圣人。非色界死。所以者何。欲界死是欲界死有。非色界生。所以者何。无色界生。是无色界生有。非色界有相续。所以者何。无色界有相续。是无色界生有。无色界死。生无色界。亦是凡夫。亦是圣人。凡夫生上亦生下。一一处有多生。圣人生上不生下。一一处有一生。非色界死。所以者何。无色界死。是无色界死有。非色界生。所以者何。无色界生。是无色界生有。非色界有相续。所以者何。无色界有相续。是无色界生有。无色界死。生欲界。是凡夫非色界死。所以者何。无色界死。是无色界死有。非色界生。所以者何。欲界生。是欲界中有。非色界有相续。所以者何。欲界有相续。是欲界中有。无色界死。还生无色界。尽无色界有相续耶。答曰。诸无色界死。还生无色界。尽无色界有相续。颇无色界有相续。彼非无色界死。非不无色界生耶。答曰。有如欲色界死。生无色界。亦是凡夫。亦是圣人。非无色界死。所以者何。欲色界死。是欲色界死有。无色界生。是无色界生有。无色界有相续。是无色界生有。欲界死。还生欲界。此人有四。欲界凡夫圣人。色界凡夫圣人。色界死还生色界。此人有三。色界凡夫圣人。欲界凡夫。无色界死。还生无色界。此人有二。无色界凡夫圣人。欲界凡夫。九十八使所使。九结所系。圣人十使所使。六结所系。色界凡夫。六十二使所使。六结所系。圣人六使所使。三结所系。无色界凡夫。三十一使所使。六结所系。圣人三使所使。三结所系。问曰。欲界凡夫。不为色无色界使所使。色界凡夫。不为无色界使所使。何故说欲界凡夫九十八使所使。色界凡夫六十二使所使耶。答曰。此中说得名所使。如欲界凡夫。色无色界使得常现前生。色界凡夫人。无色界使。得常现前生。复次于得不解脱故。名使所使。欲界凡夫。于色无色界使得。不得解脱。色界凡夫。于无色界使得。不得解脱。复次今得得当得得已得得故。作如是说。今得得是现在。当得得是未来。已得得是过去。复次能生彼使故。作是说。能生者生欲界凡夫。以离欲爱。能生色界诸使。色界凡夫。以离色爱。能生无色界诸使。复次现曾所行有余势故。欲界众生。无始以来。无有不曾起色无色界使者。色界众生。无有不曾起无色界使者。问曰。若然者。色界凡夫。曾起欲界使。无色界凡夫。亦曾起欲色界使何故不使耶。答曰。虽复曾起。以离欲故。欲界凡夫。未离色无色界爱。色界凡夫未离无色界爱。圣人十使所使。问曰。欲界圣人。有九十八使所使者。如具缚人。得正决定。苦法忍现在前时。成就九十八使。此中何以不说耶。答曰。以时少故。不久苦智生。是故不说。复次此中说现行烦恼人。入见道人。犹不能起善有漏心。何况染污余处。亦说现行烦恼人。如经说。有一婆罗门。往诣佛所。作如是问。汝当为天人龙阿修罗伽楼罗犍闼婆紧那罗摩睺罗伽耶。佛言。我不当为天乃至摩睺罗伽等。所以者何。婆罗门当知。以诸漏故。为天乃至摩睺罗伽等。如来永断诸漏。是故婆罗门。我不当为天乃至摩睺罗伽等。或有说。报现前故名人。如经说偈

  佛者是人　　自调常定　　行于梵道
  心寂静乐

此中说身受何果报。即名此界众生身受欲界报。即名欲界众生身受。色无色界报。即名色无色界众生。佛受人报故。即名为人。余处亦说。报现前故名人。如十门中说。谁成就眼根。答曰。生色界。若生欲界人。得已不失。如是等报现前故名人。如是受欲界报者。名欲界众生。受色无色界报者。名色无色界众生。非欲界死。非欲界生。尽非欲界有相续耶。乃至广作非四句。前四句初句。作此第二句。前第二句。作此初句。前第三句。作此第四句。前第四句。作此第三句。色界非四句亦如是。非无色界死。非无色界生。尽非无色界有相续耶。广说如经本。非欲界死。非欲界生。此人有五。欲界凡夫。色界凡夫圣人。无色界凡夫圣人。问曰。应有八人。何故说五耶。如色界死。还生色界。凡夫圣人。色界死。生无色界。凡夫圣人。色界死。生欲界。凡夫。无色界死。生无色界。凡夫圣人。无色界死。生色界。凡夫。如是等有八。何故说五。答曰。以相似故说五。亦色界死。生色界。凡夫。无色界死。生色界。凡夫。此二俱是色界凡夫。色界死。生无色界。圣人。无色界死。生无色界。圣人。此二俱是无色界圣人。色界死。生无色界凡夫。无色界死。生无色界凡夫。此二俱是。无色界凡夫。余有欲界凡夫色界圣人。以相似故说五。非色界死。非色界生。此人有六。欲界凡夫圣人。色界凡夫圣人。无色界凡夫圣人。问曰。应有九人。何故说六耶。如欲界死。还生欲界。凡夫圣人。欲界死。生色界。凡夫圣人。欲界死。生无色界。凡夫圣人。无色界死生无色界。凡夫圣人。无色界死。生欲界凡夫。答曰。以相似故说六。欲界死。还生欲界凡夫。无色界死。生欲界凡夫。此二俱是欲界凡夫。欲界死。生无色界凡夫。无色界死。生无色界凡夫。此二俱是无色界凡夫。欲界死。生无色界圣人。无色界死。生无色界圣人。此二俱是无色界圣人。余有欲界圣人色界凡夫圣人。以相似故说六。非无色界死。非无色界生此人有四。欲界凡夫圣人。色界凡夫圣人。问曰。应有七人。何故说四耶。如欲界死还生欲界。凡夫圣人。欲界死。生色界。凡夫圣人。色界死。还生色界。凡夫圣人。色界死。生欲界凡夫。何故说四耶。答曰。以相似故说四。欲界死。还生欲界凡夫。色界死。生欲界凡夫。此二俱是欲界凡夫。欲界死。生色界凡夫。色界死。还生色界凡夫。此二俱是色界凡夫。欲界死。生色界圣人。色界死还生色界圣人。此二俱是色界圣人。余有欲界圣人。以相似故说四。此诸人为向所说使所使向所说结所系

颇欲界死。不生欲界耶。如先说义。今则遮于生有。颇欲界死。不生欲界耶。答曰。不生。生欲色界中有。若生无色界。若般涅槃。余广说如经本。问曰。无色界死。生欲色界。彼中有。于何处现在前。答曰。或有说者。在第四禅。不应作是说。若无色界。有方所者。此说便是。但无色界。无有方所。何为远至第四禅耶。复有说者。是处所死。生无色中。即彼处所中有现在前。如是说者。无色界死。生无色界。是事不尔。评曰。应作是说。欲界色界死。生无色界。即彼所生处。中有现在前

颇欲界死不生欲界。不生色界。不生无色界耶。此中亦遮生有。余广说如经本。问曰。此中何故不问般涅槃耶。答曰。应问而不问者。当知此说有余。复次此中说死而生者。彼虽死而不生。复次此中因人而作论。彼般涅槃者。舍人名法

颇不离欲爱死。不生欲界耶。毗婆阇婆提。于此法中甚愚。谓不离欲爱。不生欲界。复不说有中有。颇有不离欲爱欲界死不生欲界耶。答曰。不生。生欲界中有。颇不离色爱死。不生欲界色界耶。答曰。不生。生欲色界中有。颇不离无色爱死不生欲界色界无色界耶。答曰。不生。生欲色界中有。未离欲爱死。不生欲界。此人有二。欲界凡夫圣人。未离色爱死。不生欲色界。此人有四。欲界凡夫圣人。色界凡夫圣人。问曰。应有七人。欲界死。还生欲界。凡夫圣人。欲界死。生色界。凡夫圣人。色界死。还生色界。凡夫圣人。色界死。生欲界凡夫。何故说四耶。答曰。以相似故说四。欲界死。生欲界凡夫。色界死。生欲界凡夫。此二俱是欲界凡夫。欲界死。生色界凡夫。色界死。生色界凡夫。此二俱是色界凡夫。欲界死。生色界圣人。色界死。生色界圣人。此二俱是色界圣人。余有欲界圣人。以相似故说四。未离无色爱死。不生欲色无色界。此人有四。欲界凡夫圣人。色界凡夫圣人。问曰。应有九人。欲界死。还生欲界中有。凡夫圣人。色界死。还生色界中有。凡夫圣人。色界死生欲界。中有凡夫。无色界死。生色界中有凡夫。无色界死。生欲界中有凡夫。何故说四耶。答曰。以相似故说四。欲界死。还生欲界中有凡夫。色无色界死。生欲界中有凡夫。此三俱是欲界凡夫。欲界死。生色界中有凡夫。色界死。还生色界中有凡夫。无色界死。生色界中有凡夫。此三俱是色界凡夫。欲界死。生色界中有圣人。色界死。还生色界中有圣人。此二俱是色界圣人。余有欲界圣人。以相似故说四。此诸人为向所说使所使向所说结所系。中有为有为无。问曰。何故作此论。答曰。或有说无中有。或有说有中有。毗婆阇婆提说无中有。育多婆提说有中有。问曰。毗婆阇婆提。依何经说。信何事言无中有。答曰。彼依佛经。无经说作五无间业。作已增广。命终无间生地狱中。以生地狱无有间故。言无中有。偈中亦说

  壮年便老病　　当生阎罗边
  中间无息处　　亦不用资粮

以无中息不用资粮故。知无中有亦作种种难。犹如光影无有中间。死有生有。无有中间。亦复如是。问曰。育多婆提。依何经说。信何事。言有中有。答曰。彼依佛经。佛经说三事合故。得入母胎。一父母俱有染心。共会一处。二其母无病值时。三犍闼婆现在前。犍闼婆者即是中有。说犍闼婆现在前故。知有中有。余经亦说。中有般涅槃。以说有中有般涅槃故。知有中有。余经复说。沙门瞿昙。此身已灭。未生彼处。于其中间。摩[少/兔]摩中为施设。有诸取不。佛告婆蹉。于其中间。爱是取。以说此身灭未生彼处在摩[少/兔]摩中故。知有中有。亦作种种难。若于此死。当生郁单越。此间断灭。彼间本无而生。如是则有法而无。无法而有。欲令无如是过故。言有中有。问曰。毗婆阇婆提。云何通育多婆提经耶。答曰。彼经所说是未了义。是假名有余意。问曰。彼以何事。为未了义是假名有余意耶。彼作是答。佛经说三事合故。得入母胎。一父母俱有染心。共会一处。二其母无病值时。三犍闼婆现在前。不应言犍闼婆。若言犍闼婆。彼作乐耶。应言诸阴行。问曰。若说揵闼婆。若说诸阴行。俱非无中有。毗婆阇婆提。复作是问。汝说四生尽有中有。二生有三事合可尔。谓胎生卵生。余二生不尔。答曰。若可尔便说。不可尔不说。然非无中有。通第二经者。有天名中有。于彼天中般涅槃故言中有。般涅槃中有天者。此间死已。应生天中未至顷。于其中间。寿命未尽。便般涅槃。问曰。此天一切经中所不说。佛经说有四天王天乃至非想非非想天。不说中有天。佛经亦说有生般涅槃。复有天名生。于彼生天。而般涅槃。言生般涅槃耶。乃至上流般涅槃。复有天名上流。于彼天中。而般涅槃。言上流般涅槃耶。汝说未到诸天。寿命未尽。而般涅槃。众生多寿命未尽而死。除郁单越人兜率天上最后身菩萨。如是等众生。皆是中有般涅槃耶。婆蹉经。复云何通。彼作是说。摩[少/兔]摩是无色界天彼梵志得天眼离色爱同及死生无色界中。彼梵志以天眼。于欲色界中。遍观不见。而作是念。彼人断灭。行诣佛所作如是问。沙门瞿昙。此身灭已。乃至于其中间。为施设有诸取不。佛告婆蹉。于其中间爱是取。以是义故。知生无色中非是断灭。问曰。佛经说。有种种摩[少/兔]摩。佛经或说。色无色界天是摩[少/兔]摩。或说。劫初人是摩[少/兔]摩。或说。中有是摩[少/兔]摩。何以知唯无色界天是摩[少/兔]摩。彼作是说。何以复知中有是。摩[少/兔]摩耶。答曰。即以此经知。所以者何。经作是说。此身灭已未生彼处。于其中间。在摩[少/兔]摩中。以是事故知。摩[少/兔]摩即是中有。种种难复云何通。答曰。彼作是说。不舍死有。乃至生有相续。如阇楼佉虫。乃至前足未立。不放后足。彼亦如是。若作是说。人间死生地狱中未舍人。趣地狱趣相续。则坏身坏趣。二心俱坏。趣者。亦名人趣。亦名地狱趣。坏身者。亦名人身。亦名地狱身。二心俱者。谓死时心生时心。问曰。育多婆提。云何通毗婆阇婆提所引经耶。答曰。彼经是未了义。是假名有余意。问曰。以何事知是未了义是假名有余意耶。答曰。彼经作五无间业。作已增广。命终无间生地狱中者。此遮余趣余业。遮余趣者。无间之业。必生地狱趣。不生余趣。遮余业者。无间之业。必受生报。非现报后报。此是彼经未了义。若如经文不取其义者。经说作五无间业。作已增广。命终无间。生地狱中。不必具作五业。生地狱中。然有作一二三四及无间业所不摄业生地狱中者。经说命终无间。生地狱中。言无间者。于此刹那。作无间业。即此刹那。生地狱中耶。然有作五无间业已故。有寿命百年者。是故不悉如经文。当依于义偈所说。义通亦如是。种种难事复云何通。答曰。此不必须通。所以者何。此非修多罗。非毗尼。非阿毗昙。不可以世间现喻难贤圣法。贤圣法异。世间法异若必欲通者。有何意耶。答曰。应说喻过。若喻有过。义亦有过。如光影。是无根无心。非众生数法。死有生有。亦无根无心。非众生数法耶。如光影俱生。死有生有。亦俱生耶。然此喻。明有中有。非无中有。如光影无间。死有中有中有生有无间。亦复如是。如是等义。说无中有。如是等义。说有中有。二义之中。何者为胜。说有中有者胜。然毗婆阇婆提。说无中有。是无明果。闇果。不勤方便果。然中有是实有法。是故为止他义欲显己义。乃至广说。而作此论

问曰。中有为是趣摄。为非趣摄。若是趣摄。施设经说云何通。如说。五趣为摄四生。四生为摄五趣。答言。四生摄五趣。非五趣摄四生。不摄何等。不摄中有。法身经说。复云何通。如说云何眼界。答言。四大及清净造色眼眼根眼入眼界。若地狱饿鬼畜生人天眼。若修得眼。若中有眼。若非趣摄者。尊者陀罗达多所说云何通。如说。若向彼趣法即名彼趣。彼趣所摄。如稻牙生时。即名为稻。彼亦如是。答曰。应作是说。中有是趣所摄。尊者陀罗达多所说善通施设经说云何通。答曰。施设经文。应如是说。五趣摄四生。四生摄五趣耶。答曰。展转随种相摄。而不说者。有何意耶。答曰。诵者错谬。法身经说。复云何通。答曰。法身经文。应如是说。地狱饿鬼畜生人天眼。及修得眼。不应说中有眼。而不说者。有何意耶。答曰。以中有是微细法。于诸趣中显现已。复别显现。犹如贼帅。于贼众中总被呵责。亦别呵责。女人亦尔。有二呵责。一以烦恼总被呵责。二以体贱。复别呵责。彼亦如是。复有说者。中有非趣所摄。施设经法身经说善通。尊者陀罗达多所说。复云何通。答曰。此不必须通。所以者何。此非修多罗毗尼阿毗昙。是自造义。或然不然。或有言无。或无言有。若必欲通者。有何意耶。答曰。以相似故。作如是说。如地狱形中有形亦尔。乃至天趣中有说亦如是。评曰。应作是说。中有非趣所摄。所以者何。去到彼是趣义。去未到故非趣所摄。复次中有是趣因。趣是果。因不摄果。果不摄因。如因果。作所作取所取亦如是。复次中有是细。趣是粗。粗不摄细。现见不现见了了不了了。说亦如是。复次中有散乱。趣非散乱。非散乱不摄散乱。复次中有是趣中间法故。非趣所摄。如田中间非田所摄。方土村落中间。非方土村落所摄。彼亦如是

问曰。何处有中有。答曰。欲色界非无色界。问曰。何故无色界无中有耶。答曰。非田非器。乃至广说。复次若处所有受二种报业。则有中有。谓中有报业。生有报业。无色界唯有生有报业。如中有报业。生有报业。初造报业。生有报业。细果粗果业。说亦如是。复次若处所受二种报业。谓色报业。无色报业。是处则有中有。无色界。唯有无色报业。如色报业。无色报业。相应业。不相应业。有所依业。无所依业。有势业。无势业。有缘业。无缘业。说亦如是。复次若处所有三种业。谓身口意业。则有中有。无色界唯有意业。复次若有十善业道处。则有中有。无色界唯有三善业道。复次若有五阴报业处。则有中有。无色界唯有四阴报业。复次若有二种白法。谓白因白果。则有中有。无色界唯有白因。而无白果。复次若有来去处。则有中有。无色界无有来去。问曰。若然者。死已还生自尸中。有何来去耶。答曰。众生或有生恶道者。或有生四天下者。或有生天者。或般涅槃者。生恶道者。识在足下灭。生四天下。者识在脐边灭。生天者。识在面灭。般涅槃者。识在心边灭。众生多于面上生爱。若心识从足下灭。来生面上。岂非来去耶。若识从足灭。还生足中。无色界犹无是事

问曰。中有为有移转不耶。答曰。无有移转。谓于界于趣于处。问曰。若中有于界无移转者。少闻比丘因缘云何通。曾闻有族姓子。于佛法出家。不修多闻方便。住阿练若处。以宿因力故。能起世俗初禅。谓是须陀洹果。乃至起世俗第四禅。谓是阿罗汉果。于一生中。未得谓得。未解谓解。未证谓证。更不求胜进道。未得当得。未解当解。未证后证。后身坏命终。第四禅中有。而现在前。当于尔时。便作是念。我断一切生分。应般涅槃。不应更生。今我中有。何缘而生。定无解脱。若有解脱我应得之。便生谤涅槃邪见。以邪见故。第四禅中有即灭。阿毗地狱中有。而现在前。命终后生阿毗地狱。答曰。此是前有时移转。非中有时。彼死时。第四禅瑞相现在前。见彼相已。便作是念。我断一切生分。应般涅槃。今此瑞相。何缘而生。定无解脱。若有解脱。我应得之。便生谤涅槃邪见。生邪见故。第四禅瑞相便灭。阿毗地狱瑞相。而现在前。身坏命终。生阿毗地狱。以是事故。知于前有时移转。非中有转。问曰。若中有于趣无移转者。善行恶行因缘云何通。曾闻舍卫国有二人。一名善行。二名恶行。善行者。于一身中。常行善行。不行恶行。恶行者于一身中。常行恶行。不行善行。行恶行者。以后报善业故。天中有现在前。当于是时。便作是念。我一生内。常行恶行。不行善行。应生恶趣。不应生天。今我天中有何缘而生。便作是念。定无善恶业报。若有者。我应得之。便生谤因果邪见。以邪见故。天中有便灭。地狱中有即生。身坏命终生地狱中。行善行者。命终时。以后报不善业故。地狱中有。而现在前。便作是念。我一生内常行善行。不行恶行。应生善趣。不应生恶趣。今我地狱中有何缘而生。便作是念。定是我后报不善之业。今生此果。即自忆念所作诸善。生大善心。而现在前。地狱中有便灭。天中有即生。身坏命终。生于天上。答曰。如此皆是前有时移转非中有时。一切众生死时。必有好恶瑞相。若多行善众生。死时多见好堂舍楼观园林浴地游戏之处。多行恶众生。死时多见火焰刀毒狼狗冢墓。行恶行者死时。以后报善业故。天瑞相现在前。见已便作是念。我一生内。常行恶行不行善行。我应生恶趣。不应生天。今此瑞相何缘而生。定无善恶业报。便生谤因果邪见。生邪见故。生天瑞相便灭。地狱瑞相即生。行善行者死时。以后报恶业故。地狱瑞相现在前。见已便作是念。我一生内。常行善行。不行恶行。应生善处。不生恶趣。今此瑞相何缘而生。定是我后报不善业故。今生此果。即自忆念所行诸善。生大善心。而现在前。地狱瑞相便灭。天中瑞相即生。身坏命终。生于天上。以是事故。此二俱是前有时移转。非中有时。问曰。若中有于处无移转者。频婆娑罗王因缘云何通。曾闻频婆娑罗王。兜率天中有现在前。当生兜率天。经须弥山顶。见毗沙门天王所食之食。其色鲜明。香味具足。便作是念。我先生此。后当生兜率天。作是念时。兜率天中有便灭。四天王中有即生。命终生于四天王天。答曰。此亦是前有时移转。非中有时。曾闻。频婆娑罗王。为假名子阿阇贳所缚。闭在狱中。断其饮食。以刀剥足下皮。尔时世尊。住耆阇崛山。以怜愍故。便放光明。从窗牖中。照其身上。遇佛光故。身得安隐。生念佛心。我今遭此厄难。世尊而不见念。尔时世尊知其心念。便告大目揵连。汝诣频婆娑罗王所。作如是言。我于大王。所应作者。皆已作之。济汝恶趣决定报业。如来尚不得免。尔时大目揵连。从佛闻是语已。即入禅定。以禅定力。如其所念。从耆阇崛山灭。如于泉池水中从地而出。住频婆娑罗王前。作如是言。大王当知。如来言无有二。慧眼照净。深见因果。作如是言。我于大王。所应作者。皆已作之。济汝恶趣决定报业。如来尚不得免。作是语已。而为说法。时频婆娑罗王。以饥渴故。而不解了。便作是言。尊者大目揵连。何天揣食。最为美妙。尔时尊者大目揵连。次第叹说四天王食。时频婆娑罗王。闻已身坏命绝。生四天王天。作毗沙门天王太子。名阇那梨沙。以是事故。知是前有时移转。非中有时。譬喻者。作如是说。中有可移转。彼作是说。一切诸业。皆可移转。造五无间业。尚可移转。何况中有。若作无间业不可移转者。则无有能过有顶者。以有能过有顶者故。知五无间业亦可移转。评曰。应作是说。中有不可移转

问曰。住中有为经几时。答曰。经于少时不久所以者何。彼于六入。求受身处。是故速令生有相续

问曰。众生受身法和合。速令生有相续可尔。若受身法不和合者。如父在罽宾。母在真丹。父在真丹。母在罽宾。云何速令生有相续耶。答曰。应观此众生。或于母作业可移转。于父作业不可移转。或于父作业可移转。于母作业不可移转。或于父母作业。俱不可移转。或于父母作业。俱可移转。若于母作业可移转。于父作业不可移转者。若是威仪具足。净修梵行。身持五戒。极善男子。必至他妇女边。令彼生相续。若于父作业可移转。于母作业不可移转者。若是威仪具足。净修梵行。身持五戒。极善女人。必至他男子边。令彼生相续。若于父母。作业俱不可移转者。受身者虽未死。其人虽所求未得。便生去心。于其道路。火不能烧。刃不能伤。毒不能害。必至彼和合。令彼生相续

问曰。若众生常有欲心者可尔。若众生时有欲心者。云何可尔。如狗秋时有欲心。罴冬时有欲心。马春时有欲心。牛夏时有欲心。如是等云何可尔。答曰。以彼众生业力故。非时亦生欲心。而得和合。令彼生相续。复有说者。生相似者中。如狗时有欲心。豺常有欲心。应生狗中者。生于豺中。罴时有欲心。熊常有欲心。应生罴中者。生于熊中。马时有欲心。驴常有欲心。应生马中者。生于驴中。牛时有欲心。野牛常有欲心。应生牛中者。生野牛中。尊者奢摩达多说曰。中有众生。寿七七日。尊者和须密说曰。中有众生。寿命七日。不过一七。所以者何。彼身羸劣故。问曰。若至七日。生处不和合者。彼断灭耶。答曰。不断灭。即于中有。而得久住。尊者佛陀提婆说曰。中有寿命不定。所以者何。生处缘不定故。中有虽得和合。生有不和合故。令久时住

问曰。中有形为大小。答曰。其形如五六岁小儿

问曰。其形若尔。云何生如是颠倒想。于母生爱心。于父生恚心。答曰。其形虽小。诸根猛利。犹如壁上画老人像。其形虽小。而有老相。问曰。菩萨中有其形大小。答曰。如前时有少年形等。亦以三十二相严身。八十种好随形。纯黄金色绕身。圆光一寻。以是事故。菩萨住中有时。其身光明。照百亿四天下

问曰。若然者。法须菩提所说偈云何通。如说

  其形如白象　　四足有六牙
  来入母胎时　　如游园观想

答曰。此不必须通。所以者何。此非修多罗毗尼阿毗昙。是自造义。或然不然。或有言无或无言有。若必欲通者。有何意耶。答曰。彼方土法。以是梦为吉。是故其母梦见是事。欲令占。相者皆言吉善。菩萨于九十一劫。更不堕恶趣。何缘作畜生形来入母胎

问曰。中有为具诸根。为不具诸根。答曰。诸根皆具。所以者何。中有初生时。六入皆求于有。复有说者。不具诸根。问曰。不具何根。答曰。前时有诸根不具者。随中有故。犹如印像似印前时有似。中有亦尔。评曰。应作是说。无不具诸根者。所以者何。中有生时。六入皆求于有

问曰。中有行时云何。答曰。众生应生地狱者。行时头下足上。如偈说

  堕于地狱者　　其身皆倒悬
  诽谤于贤圣　　及诸净行故

生四天下者。则傍行如鸟飞空如壁上画人飞。应生天者。头则上向。如仰射虚空箭

问曰。中有生时。为有衣不。答曰。一切色界中有生时皆有衣。所以者何。色界是多惭愧界。如法身常以衣覆。生身亦尔。欲界众生中有。多无衣而生。唯除菩萨白净比丘尼。复有说者。菩萨中有无衣。白净比丘尼有衣

问曰。何故菩萨中有无衣。白净比丘尼有衣。答曰。白净比丘尼。施四方僧[疊*毛]。问曰。菩萨施四方僧衣段。多于白净比丘尼所施叠缕。答曰。白净比丘尼。施僧[疊*毛]已。发如是愿。使我生生之处。常着衣服。以发愿力故。中有生时着衣。入胎出胎。亦常着衣。其身转大。衣亦随大。于佛法生信。而后出家。即以此衣。作五种衣。勤修方便。得阿罗汉。般涅槃时。即以此衣缠身。而阇维之。菩萨所行善法。皆为回向无上菩提以能生于似因之果。于最后身。得于一切众生最胜之身

问曰。中有众生。为何所食。答曰。或有说者。有饮食处便食饮食。河池水边。饮水自存

问曰。若然者。曾闻。如写囊米着釜镬中。五趣众生中有。散在世间。亦复如是。一切世间所有饮食但狗中有食者。犹不供足。何况余者。然彼身轻微。饮食粗重。若食此食。身应散坏。若然者。云何自活。答曰。以香为食。若众生有福德者。食清净饮食花果香气。以自存济。无福德者。食粪秽不净种种臭气。以自存济

中有名中有。亦名揵闼婆。亦名求有。亦名摩[少/兔]摩

问曰。何故名中有。答曰。二有中间生故名中有

问曰。若然者。余有亦在二有中间。尽名中有耶。答曰。若是二有中间。趣所不摄者名中有。若在二有中间。趣所摄者。不名中有。复次若在二有中间。微细难明难见难了者名中有。余者虽在二有中间。是粗易见易明易了。不名中有。何故名揵闼婆。答曰。以香自活故名揵闼婆。何故名求有。答曰。生时以六入求有故名求有。何故名摩[少/兔]摩。答曰。从意生故名摩[少/兔]摩。众生或有从意生。或有从业生。或有从报生。或有从合会生。从意生者。谓色无色界诸天。及中有。从业生者。谓地狱众生。如说。彼中众生。为业所系。从报生者。谓飞鸟也。从合会生者。谓人六欲天

佛经说。三事合故。得入母胎。一父母俱有染心。共会一处。二其母无病值时。三犍闼婆现在前。三事合故。谓父母犍闼婆。父母有染心者。谓欲心现在前。共会一处者。谓欲共合会。其母无病者。其母欢喜时。毗尼者作如是说。其母以欲浊心。如天雨时。河水皆浊。彼亦如是。亦无风冷热等。诸病值时者。值女人经水时。若经水多薄不成胎。若经水少干不成胎。因父母精血分。然后成胎。是名值时。亦名有身。犍闼婆现住前者。中有现在前。若起爱心。若起恚心。若是男子。于母生爱。于父生恚。彼作是念。若无此男子者。我当与此女人交会。是时便起如是颠倒想。见彼人远去。见于自身。与此女人。而共交会。父母合会。所有精气。见是己有。见已便生喜心。生喜心故。而便迷闷。以迷闷故。中有转重。更不移动。是时自见己身。在母右胁。面向母背而坐。若是女人。于父生爱。于母生恚。彼作是念。若无此女人者。当与此男子交会。是时便起如是颠倒想。见彼女人远去。见于自身。与此男子。而共交会。父母合会。所有精气。见是己有。见已便生喜心。生喜心故。而便迷闷。以迷闷故。中有转重。更不移动。是时自见己身。在母左胁。面向母腹而坐。一切众生。皆有如是颠倒想。而入母胎。唯除菩萨。菩萨入胎时。知此是我母此是我父。于母生母想。于父生父想

问曰。中有于何处入母身。答曰。或有说者。彼无障碍随处得入

问曰。若无障碍者。则不应住母身中。答曰。以业力故。住母身中。评曰。应作是说。中有从生门入母身中。以是事故。双产者后出为大。所以者何。以先入母胎故

施设经说。父母福德等者。乃能受胎。问曰。如富贵男子。近贫贱女人。富贵女人。近卑贱男子。云何乃能受胎。答曰。当于是时。见彼女人。生尊贵想。自见己身。生卑贱想。女人自以为胜。视男为卑。尊贵女人。近卑贱男子。以他为胜。以己为贱。彼男子见己为胜。以他为贱。是时有如是想。福德等故。乃能受胎

一母胎中。有五趣中有。如狗豺鱼虾蟆等。问曰。若地狱中有在彼腹中。云何不烧。答曰。若作业者被烧。不作业者不烧。若有持戒等。着地狱中。亦不能烧。所以者何。以不作业故。众生在地狱前不必被烧。如施设经说。有时活地狱众生。冷风来吹。唱如是言。诸众生活。诸众生活。是时众生便活。以是事故。彼中有不必被烧

问曰。中有若墙壁山林屋舍瓦石所不能碍。还于中有。为相障碍不。答曰。或有说者。相障碍

问曰。若然者云何中有名无障碍。答曰。唯除中有。于余无障碍。复有说者。中有于中有。还不相障碍。所以者何。以无言语故

问曰。所往之处。为中有去疾。为神足去疾。答曰。或有说者。中有去疾。所以者何。业力胜神足力故。评曰。应作是说。神足去疾。非业力疾。问曰。若然者。云何说业力胜神足力。答曰。应知为以何事。言业力胜佛神足力。能留住一切众生。神足力舍利弗。除佛目揵连。除佛舍利弗。彼中有无有众生咒术法药草。佛离辟支佛能留住。使彼生不相续者。以是事故。说业力胜神足力

问曰。中有为展转相见不。答曰。或有说者。相见。为见几所。答曰。地狱见地狱。畜生见畜生。饿鬼见饿鬼。人见人。天见天。复有说者。地狱见地狱。畜生见二趣。饿鬼见三趣。人见四趣。天见五趣。复有说者。中有非人眼境界。是天眼境界

问曰。天眼为见几所。答曰。四天王报天眼。除自地见下地。乃至他化自在天。除自地见下地。复有说者。一切欲界眼。不见中有。色界眼能见

问曰。色界报得眼。能见几所。答曰。初禅报得眼。除自地见下地。乃至第四禅。除自地见下地。若作是说。则无有见第四禅中有者。评曰。应作是说。一切报得眼。不见中有。天眼若清净者。能见中有。若不清净者。则不见中有。何以知之。佛经说若男子女人。破戒行恶。身坏命终。生如是中有。其色如黑缕毼。亦如闇夜。若天眼净者。乃能见之。若男子女人。持戒修梵行。身坏命终。生如是中有。其色白净。犹如白[疊*毛]。亦如明月时夜。若天眼净者。乃能见之

如说毗琉璃王对吒恶魔提婆达多。即以此身。入阿毗地狱

问曰。如是等为有中有不耶。答曰。有在一刹那。死有无间。生于中有。中有无间。生于生有。但在一刹那。如经说。帝释说偈

  大仙应当知　　我于此坐处
  还得天寿命　　唯愿忆持之

问曰。如此为有死生不。若有死生。云何受中有。若无死生。此偈云何通。如说。我于此坐处。还得天寿命。答曰。应作是说。不死不生

问曰。若然者偈云何通。答曰。此以断帝释恶道因缘故。作如是说。佛为帝释说法。得见真谛断恶道因缘。得生人天随意之处。欲还向佛作如是爱语。我于此坐处。还得天寿命。乃至广说。如人于牢狱中。免济他人。住随意处。其人欲还。向彼作如是爱语。今我所以得全命者。皆是汝恩。若无汝者。我则永没。复次除见道所断结病故。作如是说。佛为帝释说法。除其见道所断结病。令住第一无病之处。谓道道果。欲还向佛。作如是爱语。我于此坐处。乃至广说。犹如慈心医师治他人病令得无病安隐之处。其人欲还。向医作如是爱语。若无汝者。我于此处。则为永没。彼亦如是。复次得神足寿命故。作如是说。如经说比丘以何为寿命。谓四神足。是其寿命。佛为彼说法。得神足寿命。欲还向佛。作如是爱语。我于坐处。乃至广说。复次得慧命根故。作如是说。如经说以慧为命者。是则最胜。佛为说法。令其得慧命根。欲还向佛。作如是爱语。我于此坐处。乃至广说

问曰。彼本无慧命根耶。答曰。本虽有慧命。而是有漏。闻佛说法。见四真谛。得无漏慧根故。作如是说。复次除五种似死相故。作如是说。诸天命欲终时。有五似死相。五死相现。云何五似死相。诸天往来之时。身上璎珞。出五乐声。其声便灭。诸天身出光明。自身无影。或有说者。是时身光减少。或有说者。身光悉灭。自身影生。诸天身细软。无有垢秽。入香池水澡。出时乃至无一渧水而着身者。如莲花叶。是时水渧着身。诸天有种种清净妙好境界。漂诸情根。不住一境界。于境界回旋。犹如火轮而不暂住。是时专住于一境界。诸天福德之身。眼不曾瞬。是时便瞬。五死相者。经说。诸天若男若女。命欲终时。先有五死相现。一衣不垢而垢。二华不萎而萎。三腋下本不汗而汗。四身本不臭而臭。五先安本坐。而今不安。五似死相。则可除却。五死相不可除却。尔时帝檡。五似死相现。不久当五死相现。便作是念。谁能济我如是危难。除佛世尊。更无能者。寻诣佛所。尔时世尊。即为说法。以闻法故。除五似死相。欲还向佛。作如是爱语。我于此坐处。乃至广说。若作是说。言造现法报业者。即于坐上。更得命等八根。复有说者。是时亦有死生问曰。若然者。施设经说云何通。如说。三十三天。若男若女。初生之时。其身如五岁小儿。在诸天抱上。忽然化生。尔时诸天。若男若女。作如是言。此是我男。此是我女。化生者亦作是言。此是我父。此是我母。问曰。尔时诸天。为见帝释如是相不。答曰。皆见而作是念。今者帝释。有大神力。于世尊前。现神足力。复次诸天中。有威德者。一名因陀罗。二名夏毗因陀罗。三名伊舍那。四名波阇钵哆。如是等有威德诸天。如前有壮年时。身初生时身亦尔。化生诸天。无有死尸。评曰。彼无死生。如前说者好

施设经说。劫初人有化为腹行虫人。号之为腹行。化为三手者。号之为象。如是等身变者。为有死生不。若有者彼中有云何。若无死生者。人即作畜生耶。答曰。应作是说。无有死生。问曰。若然者。人即作畜生耶。答曰。人非即作畜生。但畜生身。与人身相续。复有说者。劫初时人。其形似人。后以时恶饮食恶。谄曲多故。人形便灭。畜生形现在前。实是人形是畜生。犹如咒术力咒人为驴虽形是驴。其实是人。彼亦如是。复有说者。众生从光音天死。来生此间。实是畜生。其形似人。后以时恶饮食恶。谄曲多故。人形便灭。还作畜生形如虾蟆。前时形具。后时形具。前时形圆黑色。后时形方而壮。复有说者。彼有死生

问曰。若然者。中有云何。答曰。中有微细。劫初时人。化生无有死生。评曰。应作是说。无有死生

阿毗昙毗婆沙论卷第三十六阿毗昙毗婆沙论卷第三十七

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    使犍度十门品第四之一

二十二根。十八界。十二入。五阴。五取阴。六界。二法。谓色法。无色法。可见法。不可见法。有对法。无对法。有漏法。无漏法。有为法。无为法。三法。谓过去未来现在法。善不善无记法。欲色无色界系法。学无学非学非无学法。见道断修道断无断法。四法。谓四谛。四禅。四无量。四无色定。八解脱。八胜处。十一切处。八智。三三昧。三结。乃至九十八使。眼根几使所使。乃至无色界修道所断无明使。几使所使。如此章及解章义。此中应广作优波提舍。二十二根。眼根。耳根。鼻根。舌根。身根。意根。男根。女根。命根。乐根。苦根。喜根。忧根。舍根。信根。精进根。念根。定根。慧根。未知欲知根。知根。知已根。问曰。何故彼尊者。立二十二根而作论。答曰。彼作经者。有如是欲如是意。随其欲意而作论。亦不违法相。彼意欲立二十二根而作论。随其意立二十二根。复有说者。此中不应问彼尊者所以立二十二根。所以者何。佛经说二十二根。佛经是此论所为根本。此论亦说二十二根。彼尊者。不能于二十二根减一根说二十一根。增一根说二十三根。所以者何。佛经不可增减。无减可增。无增可减故。如无增无减。无多无少。无益无损无量无边。亦如是。无量者。谓义无量。无边者。谓文无边。犹如大海无量无边。无量者。谓深无量。无边者。谓广无边。佛经亦如是。如尊者舍利弗等百千万亿那由他论师。为解佛经二句义故。造百千万论。尽其觉性。犹不能知其量得其边际。问曰。置造论者。何故佛经说二十二根。答曰。为受化者故。受化者闻说此法。则得增益。复次此经皆有所以因缘。何者是耶。答曰。生闻婆罗门。往诣佛所。问讯世尊。种种语已。在一面坐。而作是言。说诸根者多。沙门瞿昙。说有几根耶。佛告婆罗门。我说二十二根。谓眼根乃至知已根。如来说二十二根。则摄一切诸根义。婆罗门若有人言。沙门瞿昙所说诸根。我能遮止。更说余根。但有是言。而无有实。若还问者。亦不能知反生愚惑。所以者何。非其境界故。婆罗门问佛。若不应广问。此经所以因缘应问。婆罗门。往至佛所。但问二十二根。而不问阴界入真谛沙门果缘起助道等法耶。答曰。彼婆罗门所疑处便问。不疑者不问。复次此婆罗门。善能旋历。喜试有所问。为问根义故。经历九十六种为欲知一一道为说几根。如尼犍子说一根谓命根。是故彼不饮冷水。不断生草。所以者何。于外物中。计有命根故。问曰。外道于外物中。计有何根。答曰。或有说。计有意根。复有说。计有命根。复有说外道于物中。计有意根。名有根法。计有命根。名有命法。或有计二根者。谓业及意。复有说若眼不见色。耳不闻声。是名圣修根。如波罗奢等。作如是说。问曰。何故名波罗奢耶。答曰。是其人名无有难名者。所以者何。自有不如义而立名。复次波罗奢是其姓。如婆罗门。各有别姓。有姓拘蹉。有姓婆蹉。有姓奢致罗。有姓婆罗堕。波罗奢姓亦如是。复次若从刹利婆罗门姓生者。名波罗奢。犹如从驴马生者名为骡。评曰。此姓波罗奢故。名波罗奢。彼有弟子。名优多罗摩纳婆。往诣佛所。问讯世尊。种种语论。在一面坐。世尊问言。汝师波罗奢。为诸弟子。说修根法不。摩纳答言。我师说之。佛问云何说。摩纳答言。若眼不见色。耳不闻声。是名圣修根。时佛难言。若不见色名圣修根者。盲者便是圣修根人。尔时尊者阿难。侍佛后立。以扇扇佛。复难摩纳言。若汝所说。聋者便是圣修根人。所以者何。以不闻声故。问曰。如尊者舍利弗等百千万亿那由他诸大论师。惟佛一人。能难其义辩及所立言使令不行。何故世尊。作第一难。尊者阿难。作第二难。世尊何故而不制止尊者阿难耶。答曰。佛观阿难。咽喉有相。欲有所问。佛行菩萨道时。不曾断人。乃至弟子亦不断其问。复次佛知阿难所说与我所说等无有异无有增减。无增减故。而不制止。复次若师与弟子俱能伏者。是名善伏。复次欲令外道无余言故。若当世尊作第一难。阿难不作第二难者。彼梵志。还自众中。作如是说。虽为彼师所伏。不为彼弟子所伏。虽伏我等弟子。不伏我等师。若世尊作第一难。阿难作第二难。则破外道憍慢之心。彼作是念。弟子犹能伏我。何况于师。复次为满彼梵志意故。作如是说。彼梵志作是念。沙门瞿昙。一切力士。无能伏者。一切论中。无能报者。一切论中。为最上者。往昔诸大论师无能伏者。何况我等。若彼弟子。共我言论往反。于理乃可。佛于一切时。常欲满化人意。如其所念。而便作之。复次佛以阿难。作证此义人。彼诸外道。于阿难所。生信敬处。阿难形容端正。善知因陀毗陀罗论。是故世尊。欲以阿难作证此义人。令彼外道。于此义中。生信敬故。复次欲现不断弟子问难。外道法不听弟子有所难问。所以者何。若听弟子问难者。或时令师堕负处门。若师堕负处门者。则失利养。如舍利弗等百千万亿诸大论师所立问难。犹无有能共佛等者。何况能胜。是故佛法不断弟子问难。复次为现悭法断故。外道所以不听弟子问难。彼作是念。或能因是事故。多得利养。佛则不尔。若令一切世人。多得利养。乃至无有施佛毫末者。如来终无异相之言。复次欲现善说法中所说具足同于一见无异意故。外道法中。师所说异。弟子所说异。师所

解异。弟子所解异。善说法中。无如是过。如师所说。弟子亦尔。如师所解。弟子亦解。于文句义。终无有异。是故欲现善说法中所说具足同于一见无异意故。世尊作第一难。阿难作第二难。以是事故。不制止阿难所难。问曰。外道自作是说。眼不见色。耳不闻声。是名圣修根。世尊难言。若然者。盲聋之人。是圣修根。则顺他说。云何名难。答曰。佛作是说。是名大难。断他所说。亦名总说诸外道过。若眼不见色。耳不闻声。名圣修根者。汝等何为缘。弃居家。除去饰好。修行梵行。但当害于二根。便是圣人。是故佛说名为大难。断他所说。亦名总说诸外道过。卫施师复说五根。谓眼耳鼻舌身根。如僧佉经。复说十一根。谓五觉根五事根。五觉根者谓眼耳鼻舌身根。五事根者谓语根手根。脚根。大便根小便根。意根第十一。或有说百二十根者。谓两眼根。两耳根。两鼻根。舌根。身根。意根。命根。五受根。信等五根。如是等有二十根。地狱趣有二十。畜生趣有二十。饿鬼趣有二十。人趣有二十。天趣有二十。阿修罗趣有二十。复有说者。诸外道不说百二十根。说有百二十主。如天主龙主阿修罗主人主。如是等上妙之身。经百二十处。然后得般涅槃。彼婆罗门。闻说是语。心转疑惑。不知何者是实为说一根者。为说乃至百二十根者。彼闻释种生太子。有三十二大人相。以自庄严身。有八十种随形好。纯黄金色。圆光绕身一寻。观无厌足。出家求道。得一切知见。能断一切疑。与一切决定。尽一切问难边际。我应往问。即诣佛所。到已问讯世尊。广说如上。尔时生闻婆罗门。白佛言。沙门瞿昙。说诸根者多。为有几根。问曰。何不作如是问。九十六种。一一道中。为说有几根。答曰。彼婆罗门。虽复黠慧。其性谄曲。有如是念。若我作如是问者。沙门瞿昙。当选好者而说。佛告婆罗门。有二十二根。谓眼根。乃至知已根。如来说如是等根。能摄一切根义。汝婆罗门。若有人言。沙门瞿昙。所说诸根。我能遮止。更说余根但有是言。而无有实。若还问者。亦不能知。反生愚惑。所以者何。非其境界故问曰。何故复作是说。若有人言。乃至广说。答曰。欲止彼人先所闻。或说一根者。乃至说百二十根者。皆非如实我。虽有一切知见。不能于二十二根减一根说二十一。增一根说二十三。何况外道小智小见邪慧之者。以是事故。彼婆罗门。往诣佛所。但问诸根。不问阴界入真谛沙门果缘起助道法。问曰。二十二根。名有二十二。实体有几。答曰。阿毗昙者。作如是说。二十二根。名有二十二。实体十七。彼作是说。五根更无别体。谓男根。女根。未知欲知根。知根。知已根。问曰。彼何故说男根女根无别体。答曰。彼说身根外更无男根女根别体如说。云何男根。答曰。身根少分。云何女根。答曰。身根少分。何故三无漏根。无有别体。答曰。九根之外。更无三根别体。九根者。意根。乐根。喜根。舍根。信等五根。此九根。有时名未知欲知根。有时名知根。有时名知已根。在见道时。名未知欲知根。在修道时。名知根。在无学道时。名知已根。复次在坚信坚法身中。名未知欲知根。在信解脱见到身证身中。名知根。在慧解脱俱解脱身中。名知已根。所以者何。九根合聚。名未知欲知根。九根合聚。名知根。九根合聚。名知已根。以是事故。说三无漏根无有别体。是故说根。名有二十二。实体有十七。尊者昙摩多罗。作如是说。二十二根。名有二十二。实体有十四。向说五根无有别体。更说三根亦无别体。谓命根舍根定根。问曰。彼何故说命根无别体。答曰。命根是心不相应行阴。彼说心不相应行阴无有别体。何故说舍根。无别体。答曰。彼说苦受乐受外更无别舍受。诸所受若苦若乐不苦不乐。云何名受。问曰。若然者云何通佛经。佛经说有苦受乐受不苦不乐受。答曰。彼作是说。乐受或时上或时下。或时黠慧。或时不黠慧。或时寂静。或时不寂静。苦受亦尔。若乐受中下者。苦受中下者。乐受中不黠慧者。苦受中不黠慧者。乐受中寂静者。苦受中寂静者。是名不苦不乐受。此不决定在一分中。其犹如疑无有决定。问曰。何故说定根无有别体。答曰。彼作是说。心外无别定根。如说云何定根。答曰。一心是也。是故彼说二十二根。名有二十二。实体有十四。尊者佛陀提婆作如是说。二十二根。名有二十二。实体有一谓意根。彼说有为法作二分。一四大分。二心分。四大之外无别造色。心外更无别数法。彼作是说。诸色是四大差别。诸无色根是心差别。是故说二十二根名有二十二。实体有一谓意根。评曰。如前说者好。名有二十二。实体有十七如名体。名假体假名异相体异相分别名分别体知名知体亦如是。此是根体。乃至广说。已说体性。所以今当说。何故名根。根是何义。答曰。威势义是根义。明义是根义。异义是根义。喜观义是根义。胜义是根义。最义是根义。主义是根义。问曰。若威势义是根义者。一切有为法。展转有威势。无为法于有为法亦有威势。如是一切有为法尽应是根。佛何故独立此二十二法为根。尊者婆奢说曰。佛世尊决定知法相。亦知势用。余人所不知。若法有根相者立根。若法无根相者不立根。复次威势缘。或有下者。或有上者。或有减者。或有增者。若上者增者立根。若减者下者。是非根法。复次虽有为法展转有威势。无为法于有为法亦有威势。不如二十二根威势无明义无异义无喜观义无胜义无最义无主义。如一切众生。展转有威势缘。或有胜者。如阎罗王于地狱众生。师子王于兽中。村主于村中。王于国中。转轮圣王于四天下。自在天王于欲界。梵天王于千世界。佛于三界。佛有如是威势。胜一切众生。如是一切有为法。虽展转有威势。无为法于有为法有威势。不如二十二根威势有明义乃至主义。以是事故。威势义明义。乃至主义是根义

问曰。若威势义是根义者。于何处有威势耶。答曰。眼根于四处作威势缘胜。一自庄严身。二护自身。三为眼识及眼识相应作所依。四独能见色。自庄严身者。虽有妙身一切肢体具足。若无眼根。则无威势。护自身者。眼根能见好不好色。好者从之。恶者避之。令此身久住。为眼识及眼识相应法作所依者。眼识及相应。依眼根生。独能见色者。眼根能见色。余二十一根所不能。耳根于四处。作威势缘胜。一自庄严身。二护自身。三为耳识及耳识相应作所依。四独能闻声。自庄严身者。虽有妙身一切肢体具足。若无耳根则无威势。护自身者。耳根能闻好不好声。好者从之。恶者避之。令此身久住。为耳识及识相应法作所依者。耳识及相应。依耳根生。独能闻声者。耳根能闻声。余二十一根所不能。复有说者。眼根拥护生身。作威势缘胜。如偈说

  譬如眼明人　　能避崄恶道
  世有聪明人　　能远离诸恶

耳根拥护法身。作威势缘胜。如偈说

  多闻能知法　　多闻能远离
  多闻舍无义　　多闻到涅槃

复有说者。此二俱拥护生身法身。作威势缘胜。拥护生身者如上说。拥护法身者。眼根亲近善知识。作威势缘胜。耳根从其闻法。作威势缘胜。亲近善知识。从其闻法。能生内正思惟。如法修行。以是事故。经作是说。梵摩喻婆罗门。二根不坏。谓眼根耳根。问曰。何故于诸根聚中。说二根不坏。答曰。以此二根。佛出世时。能入佛法门故。复次以此二根。能解知佛法。如说比丘当知。若不能如实知他心者。应以二处观察如来。一以眼观色。二以耳听声。鼻舌身根。于四处作威势缘胜。一庄严自身。二护自身。三能为鼻识舌识身识及相应法作所依。四鼻独能嗅香。舌独能知味。身独能觉触。庄严自身者。虽有妙身一切肢体具足。若于此三根。无一一根者则无威势。护自身者。以此三根故。能食揣食。令身久住。所以者何。以揣食是香味触入故。为三识及相应法作所依者。依此三根。能生三识。鼻根独能嗅香者。鼻根能嗅香。余二十一根所不能。舌根独能知味者。舌根独能知味。余二十一根所不能。身根独能觉触者。身根独能觉触。余二十一根所不能。意根于二处。作威势缘胜。一令未来有相续。二自在令他随顺。令未来有相续者。如说佛告阿难。若识不在母身。名色成迦罗罗不。答言不也。自在令他随顺者。如说比丘当知。心能将世间。能生世间。若心生处。皆得自在。复有说者。意根于烦恼出要二处。作威势缘胜。烦恼处胜者。如说心烦恼故。众生烦恼。出要处胜者。如说心出要故。众生出要。男根。女根。于二处作威势缘胜。一异众生。二分别众生。古昔时人。无有男女。以少造色生故。便有男女。广长形异。颜色语言。衣服饮食。皆悉有异。复有说者。男根女根。于烦恼出要二处。作威势缘胜。烦恼处胜者。不以淫欲合会故胜。所以者何。此处应尔。不足生疑。若有男根女根者。能受恶戒。能断善根。令此身中无善种子。能作五无间业。如是等事。黄门般吒。无形二形所不能作。出要处胜者。若此二根不坏。能受逮解脱戒。能生禅戒无漏戒。能离欲爱色无色爱。能生佛种子及声闻辟支佛种子。如是等事。黄门般吒。无形二形。所不能作。命根于二处。作威势缘胜。一言有根。二令诸根不断。随几时活言有根。死已言无根。随几时活诸根相续。死已诸根不相续。复有说者。命根于四处。作威势缘胜。一令此生相续。二拥护此生。三能持此生。四令此生不断。五受根于烦恼分中。作威势缘胜。众生以受故。四方追求。行铁锁道及钩道索道上。登越高山。入于大海。有无量畏难。所谓波浪洄澓难。失兽摩罗难。黑风旋风难。水中伏山难。没水难。漂在沙上难。堕恶龙宫难。堕罗刹国难。如是等种种追求。皆为受因。问曰。无漏受。云何于烦恼分。作威势缘胜。答曰。无漏受。以方便初生时。于烦恼分。作威势缘胜。行者欲生无漏受时。亦须追求衣服饮食资生之物。是故亦于烦恼分中。作威势缘。复有说者。受根于烦恼出要分。作威势缘胜。乐受于烦恼分。作威势缘胜者。如说乐受为爱所使。出要分中作威势缘胜者。如说心乐则定。苦受于烦恼分中作威势缘者。如说恚使使苦受。苦受于出要分中。作威势缘胜者。如说苦能生信。不苦不乐受。于烦恼分中作威势缘胜者。如说无明使使不苦不乐受。不苦不乐受。于出要分中作威势缘胜者。如说依六出要舍观行。信等五根。于出要分中作威势缘胜者。如说有信者。能亲近善人。亦如偈说

  能信度流　　越放逸海　　精进除苦
  慧到彼岸

复如说若我弟子以信为障板则能障不善外敌。修行善法。如佛告阿难。精进能生菩提。若我弟子具足精进身者。能舍不善法。修行善法。如说念是遍法。若我弟子以念守门者。能舍恶法。修行善法。如说定是正道。不定是邪道。定心得清净。非不定心。定能知诸阴生灭。若我弟子能具足三三昧花鬘者。则能舍恶法修行善法。如偈说

  慧为世间上　　能趣厌离者
  亦能如实知　　能尽老死苦

亦说慧于一切法中。为无有上。亦说姊妹当知。我诸弟子以慧力断一切结系使垢缠。复说若我弟子具足智慧城者。能舍恶法修行善法。未知欲知根。于未曾见而见法。作威势缘胜知根。于已曾见法。能除过患。作威势缘胜。知已根。于已除过患。得现法乐。作威势缘胜。如是等诸根。于如是等诸法。作威势缘胜。尊者瞿沙跋摩。作如是说。实义应说一根谓意根。所以者何。意根有三事。一在内。二遍一切处。三能有所缘。在内者。内入所摄。遍一切处者。从阿毗地狱。上至有顶。可得能有所缘者缘一切法。余根不具三事。眼耳鼻舌身根。虽是内入摄。不遍一切处。不能有所缘。命根虽遍一切处。亦不内入摄。不能有所缘。除舍根余受根。虽能有所缘。非内入摄。不能遍一切处。舍根信等五根。虽遍一切处能有所缘。非内入所摄。三无漏根。更无别体。诸根合聚。立此三根如上说。问曰。若然者其余诸根。以何事故。得名为根。答曰。为意根作所依作依作烦恼作出要作出要处。谁作所依。答曰。眼耳鼻舌身根。谁作依。答曰。命根。谁作烦恼。答曰。诸受根。谁作出要。答曰。信等五根。谁作出要处。答曰。见道修道无学道。问曰。男根女根。以何事故。得名为根。答曰。以四事故。一能有所生。二能生欲乐。三能制烦恼。四能为染污识及相应法作所依。能有所生者。生胎生卵生。能生欲乐者。行欲之人。此处生乐遍身中。如圣人眉间生圣乐遍在身中。彼亦如是。制烦恼者。须臾间断。能为染污识及相应作所依者。余所依生三种识。或善不善无记。此二所依。唯生染污。爱相应相亲近识。尊者僧伽婆修说曰。命等六根。是实义根。命等六根者。谓眼耳鼻舌身命根。所以者何。此六是众生根本。问曰。若然者。余根以何事故。得名为根。答曰。此六是众生根本。根本以何为种子。识为种子。谁令其烦恼。谓五受根。谁令其出要。谓信等五根。何处得出要。谓见道修道无学道。男根女根。以何事故。得名为根。答曰。欲界众生。以欲为苗稼种子。从何处而有。皆从男根女根。尊者瞿沙说曰。命等八根。是实义根。命等八根者。谓眼耳鼻舌身男根女根命根。所以者何。此是众生根本。问曰。若然者余根以何事故。得名为根。答曰。此八是众生根本。根本以何为种子。谁令其烦恼。谓五受根。谁令其出要。谓信等五根。何处得出要。谓见道修道无学道。问曰。如身根微尘。从足至顶尽遍。何故此处所身根。名男根女根。非余处所耶。尊者和须蜜说曰。以此处所故。分别是男是女。问曰。若然者二形人亦名男亦名女耶。答曰。此不名男亦不名女。复次此处所。能生增长人寂静人。增长人者。如富兰那等六师。寂静人者。谓佛辟支佛声闻。尊者佛陀提婆说曰。此处所能生诸仙。能生牟尼。能生善调伏者。能生善共住者

已总说诸根所以今当一一别说。云何眼根。答曰。若眼已见色。今见色。当见色。及余彼分眼。已见色是过去眼。今见色是现在眼。当见色是未来眼。及余彼分眼者。广说如界处。乃至意根。说亦如是。云何女根。答曰。身根少分。云何男根。答曰。身根少分。云何命根。答曰。三界中寿。云何乐根。答曰。因触生乐受。若在身。若在心。觉乐能忍。是名乐根。云何苦根。答曰。因触生苦受。在身觉苦不可忍。是名苦根。云何喜根。答曰。因触生喜受。在心觉喜能忍。是名喜根。云何忧根。答曰。因触生忧受。在心觉忧不可忍。是名忧根。云何舍根。答曰。因触生不苦不乐受。若在身。若在心。觉不苦不乐。非可忍。非不可忍。是名舍根。云何信根。答曰。于远离寂静善法生信。若信是法善。信有是分别。受其事。取其相。如是净心。是名信根。精进根念根定根慧根。广说如经本。云何未知欲知根。答曰。不见人。不得决定人。所有觉慧慧根。及诸余根坚信坚法人。未见四谛。当见四谛。是名未知欲知根。不见人者。谓不见诸谛人。不得决定人者。不于诸谛得决定。所有学慧慧根者。则说慧根。诸余根坚信坚法。所用八根。未见四谛。当见四谛。则说八根。如是等九根合聚。名未知欲知根。问曰。彼根聚中。何故再说慧根。一说余根耶。答曰。以名胜义胜故。彼根聚中慧名胜义亦胜。复次慧说名前道。如说比丘当知。种种善法生时。慧为前导。慧为前相。次有惭愧。复次慧于三事得决定。一于见得决定。二于缘得决定。三于事得决定。彼相应法。于二事得决定。于缘得决定。于事得决定。非于见得决定。所以者何。非见性故。非相应共有法。得一决定。谓于事得决定。非见决定。非见相故。非缘决定。非缘法故。复次若以慧见烦恼时。烦恼则不得久住。如穴居众生人若见时便还入穴。彼亦如是。复次若身中有慧照。则烦恼贼不能偷劫。犹如屋中有灯照者。贼则不能偷劫。彼亦如是。复次以慧能照一切法外物。如日月药草摩尼珠。诸天宫能照一界一入一阴一世少分。一界少分者谓色界。一入少分者谓色入。一阴少分者谓色阴。一世少分者。谓现在世。慧能照十八界十二入五阴三世及无为法。复次无慧者缚。有慧者解。复次佛出世时。入佛法者。以慧而自娱乐。佛法以知解为胜。譬如有目之人能至宝处。如是有慧眼者。能至佛法宝处。譬如盲人虽往宝处而无所见。恶慧之人入佛法宝处。亦复如是。复次慧名为将。亦名为眼。亦名为头。亦名为觉。亦名觉支。亦名为道。亦名道支。复次慧名为眼。余助道法。名为盲。如众多盲人。一有目者而奖导之。令行正路。彼亦如是。复次慧断烦恼刀。如说姊妹当知。圣弟子以智慧刀。断一切结缚使垢缠。复次慧说名为堂如。尊者阿尼卢豆所说。我依戒立戒升无上智慧堂。复次慧能立别相总相法。能解别相法。能解总相法。能破自体愚。能破缘中愚。于诸法中得不颠倒。复次慧是诸佛所爱敬。诸佛不爱敬人色族财富。爱敬有慧者。复次诸佛以慧故。而有差别。非以色族财富等。以如是事故。慧则再说。余根一说。云何知根。见人。决定人。所有学慧慧根。及诸余根。信解脱见。到身证。已见四谛。重见四谛是名知根。见人者见诸谛。决定人者。于诸谛决定。所有学慧慧根。则说慧根。余诸根信解脱见到身证所用八根。见四谛重见四谛。则说八根。如是等九根合聚名知根。问曰。如无学人重见四谛。如退法至忆法。忆法至护法。护法至等住。等住至能进。能进至不动。何故唯说学人。不说无学人耶。答曰。应说无学而不说者。当知此说有余。复次若说始。当知亦说终。若始说学。当知终说无学如始终。初入已度方便毕竟。说亦如是。复次断未曾断结。得未曾得果者。说名重见。无学不断未曾断结。不得未曾得果故。不名重见。复次若断未曾断烦恼得。证未曾证解脱得。是名重见。无学虽证未曾证解脱得。而不断未曾断烦恼故。是故不说。如断烦恼得证解脱得。除过患修功德舍秽恶取胜妙。去无义取有义。尽渴爱受无烦恼乐。当知亦如是。复次断未曾断无知。得未曾得智。是名重见。无学虽得未曾得智。不断未曾断无知。谓染污无知。以如是等事故。唯说学重见谛。不说无学。云何知已根。答曰。若漏尽阿罗汉无学所有慧慧根。解脱俱解脱所用诸根。能生现法乐。是名知已根。漏尽阿罗汉。所有慧慧根。则说慧解脱。俱解脱阿罗汉。所用诸根。能生现法乐者。则说八根。如是等九根合聚。名知已根。问曰。学人亦有现法乐。何以但说无学。答曰。应说如说无学现法乐。亦应说学现法乐。复次若说终当知亦说始。说毕竟当知亦说方便。说已度当知亦说初入。复次以名胜义亦胜故。若以法而言。无学法胜于学法。以人而言。无学人胜于学人复。次无学人所有猗乐。不为烦恼所覆。学人虽有猗乐。为烦恼所覆。复次若受猗乐时。宽博广大。是说现法乐。学人有所作故。受猗乐时。不宽博广大。不名现法乐。无学人无有所作。受猗乐宽博广大故。名现法乐。譬如国王于诸怨敌。未尽降伏。所受快乐。不宽博广大。彼亦如是。复次若无烦恼。意语亦满。诸牟尼是说现法乐。复次若受现法乐。不受后乐。是名现法乐。学人受现法乐。亦受后乐故。不名现法乐。以如是等事故。无学猗乐名现法乐。学人猗乐不名现法乐

问曰。为有三明阿罗汉不。若有者此中何以不说。若无者此经云何通。如说尊者舍利弗白佛言。世尊。此五百比丘。几是三明。几是俱解脱。几是慧解脱。问曰。尊者舍利弗。为知是事不。若知者何故问。若不知者云何名得声闻波罗蜜。答曰。应作是说。尊者舍利弗知。问曰。若知者何故问。答曰。自有知而故问。如比尼说。佛世尊知而故问。复次尊者舍利弗为利益他故问。尊者舍利弗虽自知。彼会中有不知者。无无畏故。不能问佛。尊者舍利弗无如是过。欲利益他故而问。复次欲说总相令别异故而问。佛为五百比丘说法。闻佛所说。得阿罗汉果。断未来有。尽可佛意。众生若能得阿罗汉。断未来有。是名第一可世尊意。尊者舍利弗作如是念。此诸尊者虽皆得阿罗汉断未来有。不知谁勤方便。欲说如是总相令别异故而问。复次佛世尊令五百比丘等住于果。舍利弗欲令其道差别故而问。复次佛世尊令五百比丘等住无为解脱。舍利弗欲令有为解脱差别故而问。复次欲显功德宝藏令世知故而问。譬如宝藏覆在土中多人不见。如是以少欲知足土。覆功德宝藏世无知者。复次欲令施主生信心故而问。有诸檀越。于夏四月中。以衣食等所须之物。供给众僧。欲令施主知之。汝等所施。值如是等清净福田故而问。复次彼尊者净行弟子法故。弟子法应问。师应答。复次为现破憍慢求法情深故而问。复次为坏少有所知生于憍慢不喜问人故而问。尊者舍利弗作如是念。我所有智慧有十六。世人所知有一分。我犹问他。何况汝等少知见而不问耶。复次欲现己身法无悭垢故。若人悭于法者。见他人问。犹尚不喜。何况自问。复次为止诽谤故而问。诸外道等。作如是谤。沙门瞿昙夜从优波提舍拘律陀边受法。昼为弟子说。若尊者舍利弗合十爪掌。于大众中而问于佛。彼诽谤便止。复次弟子说善法。欲以如来印印故而问。譬如王家所有符疏。若不以王印印者所经关津而不信用。若以王印印者。所住之处而皆信用。如是弟子所说善法。若不以如来印印者。则于遗法四众无信受者。若以如来印印者。则遗法而四众皆信受。是故弟子所说。欲以如来印印故而问。答曰。应作是说。有三明阿罗汉。问曰。此中何故不说。答曰。应说此文。应如是说。若慧解脱。俱解脱。三明阿罗汉。能生现法乐。复次已说在先说义中。三明阿罗汉。若是慧解脱。若是俱解脱。若说慧解脱。当知已说慧解脱。有三明者。若说俱解脱。当知已说俱解脱。有三明者。昔有二论师。一名时婆罗。二名瞿沙跋摩。尊者时婆罗偏赞叹慧。尊者瞿沙跋摩偏赞叹灭定。尊者时婆罗作如是说。慧胜灭定。所以者何。慧能有所缘。灭定无所缘。尊者瞿沙跋摩说灭定胜慧。所以者何。灭定唯圣人有。慧凡圣俱有。赞叹慧者。作如是说。若有三明。不具八解脱者。是名三明。若有三明。具八解脱者亦名三明。具八解脱。无三明者。是名俱解脱。若有一明二明者。是名慧解脱。所以者何。慧胜灭定故。若赞叹灭定者。作如是说。若具八解脱。无三明者。是名俱解脱。若具八解脱。有三明者。亦名俱解脱。若有三明。不具八解脱者。是名三明。若有一明二明。名慧解脱。所以者何。灭定胜慧故。此二所说。俱唐捐其功。此二所说。于文无益。于义无益。三明。或得灭定。或不得灭定。若得者。名俱解脱三明。若不得者。名慧解脱三明。今当重说未知欲知根知根知已根所以。何故名未知欲知根。答曰。未知当知。未决定当决定。未断当断。是故名未知欲知根。问曰。若未知当知。未决定当决定。未断当断。名未知欲知根者。苦法忍生时。观欲界五阴苦得决定。后生苦法智。亦观欲界五阴苦得决定。是时名知苦已复知苦。何故名未知欲知根。不名知根耶。答曰。苦法忍。始观欲界五阴苦不名已知苦法智名始知。复次苦法忍。观欲界五阴决定是苦。不名为智。苦法智乃知。以智为决定不以忍。复次若后更不生未知欲知道。不为未知欲知学所覆。不以上着下不不得自在。名知根。与此相违故名未知欲知根。何故名知根。答曰。未知已知。未决定已决定。未断已断。问曰。若未知已知。未决定已决定。未断已断。名知根者。道比忍现在前。除自体及相应共有法。余比智分悉得决定。后生道比智。于彼相应共有法。始得决定。名知根。何不名未知欲知根耶。答曰。外国法师说。第十六心。最初道比智刹那。名为见道。问曰。此中不论如是说者。乃论十五心是见道者。尊者僧伽婆修作如是说。道比忍现在前。未来有无量道比忍修。彼未来修者。能于现在道比忍刹那相应共有法得决定。不应作是说。所以者何。未来道不缘有所作。问曰。若然者其义云何。答曰。从多分故。已得决定者多。未得决定者少。已得决定犹如大地。未得决定如一揣土。须弥山芥子。大海一渧。虚空蚊翅处空喻亦如是。复次彼后更无未知欲知道。更不为未知欲知觉所覆。不以上着下。不不得自在。是故不名未知欲知根。何故名知已根。答曰。知已更不知。决定已更不决定。断已更不断。是名知已根

问曰。若知已更不知。决定已更不决定。断已更不断名知已根者。何故于三知已法中。一独名为佛耶。答曰。佛初成道时。觉一切法。作别相观。非总相观。声闻辟支佛。初成道时。觉一切法总相观。非别相观。复次若智自知遍知决定知。是名为佛。辟支佛智。虽自知非遍知。非决定知。声闻智。不名自知。非遍知。非决定知。复次若于一切种。以缘自觉。是名为佛。辟支佛虽以缘自觉。不于一切种。声闻不于一切种以缘自觉。复次若智遍所知。觉遍所觉。行遍所缘。根遍根义所。境界遍境界。是名为佛。声闻辟支佛不尔。复次若所闻不如重担。是名为佛。声闻辟支佛不尔。复次所不应行习气。于此身永断。是名为佛。声闻辟支佛不尔。复次于甚深十二因缘河。能尽其底者。是名为佛。声闻辟支佛不尔。如三兽度河。谓兔马象兔。腾踯乃度马或尽其底。或不尽底而度。香象于一切时。足蹈其底而度。如兔度河。声闻度因缘河亦复如是。如马度河。辟支佛度因缘河。亦复如是。如香象度河。佛度因缘河亦复如是。复次若永断二种无知。谓染污不染污。是名为佛。声闻辟支佛。虽断染污无知。不断不染污者。复次若永断二种疑。谓是人是杌疑及使性疑。是名为佛。声闻辟支佛。虽断使性疑。不断是人是杌疑。复次佛得尽智时。于二种障心得解脱。谓烦恼障解脱障。是名为佛。复次若依所依具足者。是名为佛。或有所依具足依不具足。如转轮圣王。或依具足所依不具足。如辟支佛。佛世尊依所依二俱具足。如依所依器中物器。当知亦尔。复次若三事具足。是名为佛。一色二族三言语。复次若具足三事。是名为佛。一誓愿具足。二功果具足。三恣所问具足。复次若有三不护。有三不共念处。是名为佛。复次若所言无二。有无尽辩。所记无失。是名为佛。复次若善知因。善知时。善知相。善知为他说法。是名为佛。复次若有四种智。一无畏智。二无著智。三无缺失智。四不退智。是名为佛。复次若知种种因。知种种果。知种种性。知种种对治法。是名为佛。复次若于世八法得解脱。其德无有能得边者。能为一切厄难者作救护。是名为佛。复次若于十八不共法十力四无所畏大悲三不共念处。是名为佛。复次若大悲心。深远微细。遍一切处。于一切众生。无怨憎心。深远者。从三阿僧祇劫积聚故。微细者。济众生三苦故。遍一切处者。缘三界众生故。于一切众生无怨憎者。于怨亲中人等不异故。如是等事故。三已作法中。说一为佛

问曰。何故色阴中。眼耳鼻舌身立根。色声香味触不立根耶。答曰。无根故不立根。复次若是内入者立根。外入者不立根。复次若作所依者立根。若作所缘者不立根。复次若是众生数者立根。若或是或非者不立根。复次在自身中者立根。不定者不立根。复次若自所用者立根。不定者不立根。复次不共者立根。共者不立根

问曰。受阴中。乐受立二根。苦受立二根。何故不苦不乐受立一根耶。答曰。应说二根而不说者。当知此说有余。复次欲现种种说种种文。乃至广说。复次欲现二门二略。乃至广说。复次乐受。或有黠慧者。有不黠慧者。或有轻躁者。有不轻躁者。苦受亦尔。乐受中。若不黠慧不轻躁者立乐根。若黠慧轻躁者立喜根。苦受亦尔。不苦不乐受。不黠慧不轻躁故立一根。复次乐受。乐根所作异。喜根所作异。苦受亦尔。不苦不乐受所作无异。复次离相对法故。乐受对苦受。苦受对乐受。不苦不乐受。无相对故立一根

问曰。何故想阴不立根耶。答曰。不立根法多。何故独问想。问曰。所以问者。色阴行阴。少分立根。少分不立根。受阴识阴。尽立根。想阴不尽立根。不少分立根。是故问想阴何故不立根。答曰。无根相故不立根。复次根以自力自功用立。想以他力他功用立。如佣作人。他教则作不教不作。若受有所觉。思有所思。识有所识。然后想有所想。复次为他所覆故。善想为慧所覆。如人忆想不妄世言是人智慧。不善想为颠倒所覆。如无常常想颠倒。尊者和须密说曰。何故想不立根耶。答曰。威势义是根义。想威势少。问曰。想亦有威势。如说一切有为法。展转有威势无为法。于有为法。亦有威势。复次根能害烦恼。想不能害。问曰。想亦能害烦恼。如说比丘修行广布无常想。除一切欲爱色无色爱。尊者佛陀提婆说曰。想取想分别。分别体唯取想。余数法行境界已想然后取想分别

问曰。烦恼何故不立根。答曰。无根相故不立根。复次威势义是根义。烦恼威势少故不立根。问曰。烦恼能没生死远离涅槃。坏诸善法。云何言威势少耶。答曰。以是下贱可呵法故。言威势少。问曰。若然者。染污受何故立根耶。答曰。受于烦恼有威势。烦恼威势少。犹如狱卒。虽所住处下。亦与贵胜交往。诸狱卒守门者。虽复苦切于人无有威势。而不得与贵胜交往。彼亦如是。尊者僧伽婆修说曰。若法有欲无欲身中可得故立根。烦恼唯有欲身中可得故不立根。若作是说。则忧根知已根不尔。所以者何。忧根唯有欲人身中可得。知已根。唯无欲人身中可得。是故如前说者好

问曰。何故受善染污不隐没无记立根。慧唯善立根。染污不隐没无记不立根耶。答曰。受于烦恼分中势用胜。善染污不隐没无记尽立根。慧于出要法中势用胜。善慧能增益出要法。染污慧能断出要法。不隐没无记慧。于出要法无所增益

问曰。俱是不相应行阴。命根立根。受身处何故不立根耶。答曰。无根相故不立根。复次命根是报。一切报从业生。是以命根立根。受身处不定。或有是依。或有是报。是故不立根

问曰。最胜义是根义。灭尽涅槃。于一切有为无为法中最胜。何以不立根耶。答曰。此是根毕竟尽处不立根。譬如瓶衣。毕竟尽处。不名瓶衣。复次若法行世。能取果。能有所作。能知境界者立根。灭尽涅槃。与此相违故不立根。复次若法是生灭有因。是有为相者立根。灭尽涅槃。与此相违故不立根。复次根属因属缘属所作立根。涅槃与此相违故不立根。复次若法为生所生为老所老为坏所坏者立根。涅槃不尔。复次根在阴堕世。与苦相续。有前后相上中下相者立根。涅槃不尔。复次言最胜者。于有为法中最胜故立根。涅槃于有为无为法中最胜故不立根

阿毗昙毗婆沙论卷第三十七阿毗昙毗婆沙论卷第三十八

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    使犍度十门品之二

十八界。眼界色界眼识界乃至意界法界意识界。界名略说亦名广说。略说者于说大经。如大因缘经大涅槃经等。广说者。于说入经入。亦名略说亦名广说。略说者于说界经。广说者于说阴经。阴亦名略说亦名广说。略说者于说入经。广说者如说。若有所受。当知皆苦。于如是等经。名为广说。复有说者。界亦名略说亦名广说。即于界中。不于余法。所以者何。界中心色是广说。心数法是略说。入亦是略说。亦是广说。即于入中。不于余法。所以者何。入中色是广说。心心数是略说。阴亦是略说。亦是广说。即于阴中。不于余法。所以者何。阴中色心是略说。心数是广说。如说若有所受。当知皆苦。此说一向是略。复有说者。界是广说。亦摄一切法。大因缘经大涅槃经。虽是广说。不摄一切法入。虽摄一切法。而非广说。所以者何。是中说法故。阴不摄一切法。所以者何。摄一切有为法。不摄无为法故。亦非广说。所以者何。是略说故。如说若有所受当知皆苦。此一向是略说。佛所说经。广略义如此。非谓如说法施财施是略说。大因缘经大涅槃经是广说。世尊于所知法。先广说十八界。即于彼所知。次略说十二入。于彼十二入。除无为法。略说五阴。是名世尊广略之说。以如是广略所说法。佛告尊者舍利弗。我说诸法。若广若略。能知解者难得。以如是广说略说故。尊者舍利弗。请于世尊。世尊说法若广若略。能有知解法宝者。譬如大海中龙于大海中化作大身。上升虚空兴起大云遍覆虚空放电光。出如是雷音。我今当雨药草树木。闻如是音。皆生恐怖作如是念。大海中龙。若降雨者。我等皆当没灭。是时大地。心无疑惧。又无异色而请之言。汝当降雨经百千岁。我尽能受。世尊亦尔。于主童佛然灯佛迦拘逊陀村佛迦那含牟尼佛。乃至迦叶佛所。长养智身。上升有余涅槃虚空界中。以大悲云遍覆世间。放智电光。出无我师子吼音作如是言。舍利弗我所说。若广若略。知解者难得。是时一切受化者。闻说是言心怀恐惧。唯除尊者舍利弗。世尊以未曾闻名味句身。而说诸法。我等所不能解。尊者舍利弗。于六十劫中。增长如地知见。心无恐惧又无异色。而请于佛。世尊说法。若广若略。能有知解法宝之者

问曰。有法非声闻辟支佛境界。何故尊者舍利弗。作如是请佛。答曰。声闻所知。非佛知。以声闻境界非佛境界。以声闻所行非佛所行。以声闻根非佛根。复次佛听故请。尊者舍利弗作如是念。世尊所说。常以怜愍知量。观其田器。当雨法雨。不唐捐其言。若说一句。前人不受。佛则不说。世尊知我有尔所受法器。则为我说如是法。以是事故。佛听故请

问曰。为何等受化者说界。何等说入。何等说阴。答曰。于界中愚者为说界。于入中愚者为说入。于阴中愚者为说阴。复次受化者。或是初行。或是已行。或是久行。为初行者说界。为已行者说入。为久行者说阴。下根中根上根。乐广乐略乐广略者。说亦如是。复次若恃性憍慢纵逸者为说界。所以者何。性义是界义故。若恃财憍慢纵逸者为说入。所以者何。输门义是入义故。恃命憍慢纵逸者为说阴。所以者何。阴说名杀贼。复次于色心愚者为说界。所以者何。界中广说色心。略说数法。于色愚者为说入。所以者何。入中广说色。略说心心数法。于心数法愚者为说阴。所以者何。阴中广说心数法。略说色心。复次为计我者说界。为于所依缘愚者说入。为我憍者说阴。佛为如是受化众生说阴界入

问曰。十八界。名有十八。实体有几。答曰。十八界。名有十八。实体或十七或十二。若说六识身。则无意界。所以者何。离六识身外。更无意界。是故名有十八。体有十七。若说意界。则无六识身。所以者何。意界之外。更无六识身。是故名有十八。体有十二。如名体。名假体假。乃至知名知体。说亦如是。问曰。十八界体。或有十七。或有十二者。云何立十八界。答曰。以三事故立十八界。一以所依。二以依。三以境界。六界是所依。六界是依。六界是境界。所依者。眼界乃至意界。依者。眼识乃至意识。境界者。色乃至法。问曰。若以所依依境界。立十八界者。阿罗汉最后心。则非意界。所以者何。不能生识故。答曰。彼亦是意界。所以识更不相续者。非以意界。更以余事故。若识生者。亦能作所依。过去有十八。未来现在。亦有十八。问曰。过去有十八界可尔。所以者何。六识次第灭者是意界。未来现在云何有十八界。答曰。以是决定相故。若未来现在识。无意界相者。过去者亦无。以决定相故。过去有十八界。是故以三事说十八界。谓所依依境界。佛经作如是喻。如大树叶聚。比丘当知。无量界性亦复如是。虽说无量界性。而不过十八界。尽以三事故名界。谓所依依境界。佛经又说六十二界。如多界经说。彼亦不过十八。尽以三事故名界

问曰。佛经何故说六十二界。答曰。欲异外道故。外道有六十二见。以身见为本。为对治彼见故。说六十二界。余经又说。憍尸迦。世间有种种无量界众生。各于自界。而起贪着。生牢强想。言我界胜。唯我是实。余者是愚。如是尽在十八界。亦以三事。谓所依依境界。复有说者。此中诸见。以界名说。悉在法界中。以是事故。十八界以三事立界。谓所依依境界。尊者婆摩勒说曰。以四事故故立十八界。一以自体二以事三以所作四以分别阴。以自体者。色界乃至法界事者。眼识乃至意识。所作者。眼界乃至意界。分别阴者。色阴有十界。识阴有七。三阴有一界。此是界体性。乃至广说。已说体性。所以今当说。何故名界。界是何义。答曰。性义是界义。叚义分义别义种种相义不相似义分齐义。是界义。种种所依是界所作。声论者说曰。趣义是界义。持养义是界义。性义是界义者。譬如一山之中多有诸性铁性白镴性铅性铜性银性金性石性白塔性。如是一所依身。有十八界性。叚义是界义者。如诸材叚次第安置。名宫殿楼观。次第安置竹篾。名扇名盖。次第安置肉叚。名为男女。分义是界义者。十八分是男。十八分是女。别义是界义者。男别有十八。女别有十八种种相义是界义者。眼界相异乃至法界相异。不相似义是界义者。眼界于余界不相似。乃至法界。于余界不相似分齐义是界义者。眼界自有分齐。余十七界亦有分齐。乃至法界自有分齐。余十七界。亦有分齐。种种所作是界所作者。眼界所作。乃至非法界所作。法界所作。乃至非眼界所作。声论者说。趣义是界义者。趣诸界诸趣诸生。持养义是界义者。能持自性故。是故性义。乃至持养义是界义

已总说界所以。今当一一别说。云何眼界。若眼已见色今见色。当见色。已见色是过去。今见色是现在。当见色是未来。及诸余彼分眼。外国法师作如是说。彼分眼有四种。过去有彼分眼界。谓眼不见色。灭堕过去者。现在亦有彼分眼界。谓眼不见色今灭者。未来亦有彼分眼界。谓眼不见色。当灭者及未来必不生彼分眼。罽宾沙门说。彼分眼有五种。三种如先说。未来必不生彼分眼。有二种。一与眼识合。二不与眼识合。若以眼见色。于己名自分。于余一切众生。亦名自分。若眼不见色。于己名彼分。于余一切众生。亦名彼分。复有说者。若以眼见色。于己名自分。于余一切众生。名彼分。若眼不见色。于己名彼分。于余一切众生。亦名彼分。复有说者。若以眼见色。于己名自分。于余一切众生。不名自分。亦不名彼分。若眼不见色。于己为彼分。于余一切众生。非自分亦非彼分。不应作是说。云何是眼。不名自分亦非彼分。评曰。如前说者好。若以眼见色。于己为自分。于余众生。亦名自分。若眼不见色。于己名彼分。于余众生。亦名彼分

问曰。无有以他眼见色者。云何己眼于余众生。名为自分耶。答曰。谁说以他眼见色者耶。问曰。若无说以他眼见色者。云何己眼于余众生。名为自分耶。答曰。以所作同故。如己眼见色已灭。于余众生。亦名见色已灭。无有以他眼见色者。问曰。自分眼见色。彼分眼不见色。不见色眼。于见色眼。云何名彼分。答曰。展转为因故。见色眼与不见色眼作因。不见色眼与见色眼作因。复次以展转相生故。见色眼能生不见色眼。不见色眼。能生见色眼。复次展转相续故。见色眼续不见色眼。不见色眼续见色眼。复次见色眼。不见色眼。俱是一界一入一根一见。诸界有如是相者此中略说。如眼界。耳界鼻舌界身界。说亦如是。云何色界。答曰。若色为眼。已见今见当见。已见者是过去色。今见者。是现在色。当见者是未来色。及余彼分色。彼分色有四种。过去有彼分色界。谓不为眼所见已灭者。现在有彼分色界。谓不为眼所见今灭者。未来有彼分色界。谓不为眼所见当灭者。及未来必不生色。有色界于一众生。是自分。于二三乃至百千众生。是自分色界。于一众生乃至百千众生。是自分者。如初生月。若生缘彼眼识。是自分色界。若不生缘。彼眼识。是彼分色界。譬如大会之中有一端正庄严伎女。在中种种舞戏。若生缘。彼眼识。是名自分色界。若不生缘。彼眼识。是名彼分色界。大众之中。升立坐法师说法。亦复如是。有色界于一众生。是彼分。于二三乃至百千万一切众生。是彼分。谓如须弥山中色大海大地中色。问曰。如是色界。非天眼境界耶。答曰。虽是境界以不用故。然有天眼者。不必一切时见所应见色

问曰。彼色不为佛眼所见耶。答曰。是所见以不用故。如今无佛。无佛眼见色。问曰。若以眼见色。于己是自分。于余一切众生。亦是自分。何故色界。若为眼所见是自分。不为眼所见是彼分耶。答曰。一色界。容有一众生。不见二三众生。则见无有一眼二人用见。何况多耶。色界有如是相者。此中略说。如色界。声香味触界说亦如是。以世俗言说故作是说。世俗作如是语。汝所嗅香我亦嗅之。汝所尝味我亦尝之。汝所觉触我亦觉之。实义不尔。若一人已嗅香。第二人所不能嗅。一人已尝味。第二人所不能尝。一人已觉触。第二人所不能触。若世俗言说文说如上。若以实义文应如是说。如眼界。耳界鼻界香界舌界味界身界触界说亦如是。云何眼识界。答曰。眼缘色生眼识。问曰。眼识生时除其自体。余一切法皆作缘。何以但说眼色作缘耶。答曰。此说眼识所依及境界眼。是彼所依色。是彼境界。复次与眼识。作近威势缘者说。眼色与眼识作近威势缘胜。于自体生老无常。是以故说。问曰。眼识亦缘色生。何以但言眼识不言色识。答曰。如外入经说。缘色生识。是名色识。乃至广说

问曰。但一经说色识。余经多说眼识。答曰。若是内法则说。不说外法。如内外所依所缘根根义所境界境界不共共说亦如是。复次识以所依故有别名。从眼生者。名为眼识。乃至从意生者名为意识。如声以所依故有别名。如鼓声依鼓贝声依贝琴声依琴。彼亦如是。问曰。此皆依意。何以不尽依名意识耶。答曰。若依是不共不同别异相。作识别名。云何眼识所依不共不同别异。谓依于眼不依余。乃至身识说亦如是。以是事故而作四句。或作所依。不作次第缘。乃至广作四句。作所依不作次第缘者。谓俱生眼。作次第缘不作所依者。谓前次第灭心数法。作所依作次第缘者谓意界。不作所依不作次第缘者。除上尔所事。乃至身识说亦如是。若为意识作所依。亦为意识作次第缘耶。答曰。若作所依。亦作次第缘。颇有作次第缘不作所依耶。答曰。有前次第灭心数法。尊者和须蜜说曰。亦缘色生识。何故不言色识。但言眼识。答曰。眼为识作所依非色。复次眼所作胜。复次眼在自身中色则不定。复次眼是内入。色则不定。复次眼属内色则不定。复次眼于识有损益。色则不尔。问曰。若然者色亦有损益。答曰。一色虽有损益。余色能生眼识。眼不尔。若一眼坏。更无余眼能生识。余识说亦如是。复次眼有上中下识。亦有上中下色则不尔。复次眼所不共。色则不定。如缘一界中色生二界中识。无有依一界中眼生二界中识。缘一趣中色生五趣中识。无有依一趣中眼生二趣中识。何况多四生说亦如是。复次眼是威势非色。尊者佛陀提婆说曰。若眼无留难。识亦无留难。问曰。色若有留难。识亦有留难。若无色者。识何缘生。答曰不尔。境界常不坏。所依有坏。若所依坏者。识则不生。假令有那由他色若所依坏。缘色识不生者识则住不生法中。问曰。眼识识色。何故言眼识色耶。答曰。或说所依以显依。或说依以显所依。说所依以显依者。如此中说眼能识色。说依以显所依者。如说眼识所更所分别名见。复次以名义胜故。如伎人染衣书法。犹如伎师作伎时。非无伎子伎女及余侍从时会。然伎师于中胜故。但言伎师作乐。如以染染衣。非无人水器等。但染胜故言以染染衣。如以笔作字令字有差别。非无人工纸墨等。但笔于中胜故说笔作字令字差别。如是虽识能识色。以眼胜故说眼识色。复次眼是识色具故言眼识色。如说伴行于道。行者是足非伴。伴是道行之具。彼亦如是。虽识识色。眼是识色具。故言眼识色。有心意识。问曰。心意识。有何差别。答曰。或有说者。无有差别。心即是意。意即是识如是等。皆同一义。无有差别。如火名火亦名炎亦名炽亦名燋薪。如是等十名经说。帝释名因陀罗。亦名憍尸迦。亦名释迦。亦名千眼。一帝释有如是等十名。如阿毗昙说。受名为受。亦名别受。亦名等受。亦名觉受。一受有如是等五名。彼亦如是。一心法有三种名。复有说差别者。名即差别。是名心。是名意。是名识。复次过去名意。未来名心。现在名识。复次说界时名心。说入时名意。说阴时名识。复次远行义。是心义。如偈说

  独行远逝　　不依于身　　能调是者
  解脱畏怖

复次前导义是意义。如偈说

  意为前导　　意尊意驶　　意若念恶
  即言即行　　罪恶报应　　如影随形

生相续义是识义。复次性义是心义。输门义是意义聚义是识义。复次种种杂色义是心义。如说比丘当知。畜生趣所以有种种杂色者。皆由心有种种故。有种种杂色。归属义是意义。如说比丘当知。此五根虽行种种境界。必持意分别。终归属意。分别物体相是识义。复次增积义是心义。解了义是意义。别识义是识义。尊者婆奢说曰。增积义断义是心义。解了义知义是意义。能识义别识义是识义。增积是有漏。断是无漏解了是有漏。知是无漏。能识是有漏。别识是无漏。心意识。是谓差别。若界有如是相者。此中略说。如眼识。耳识鼻识舌识身识说亦如是。云何意界。答曰。若意能识法。已识今识当识。及余彼分意。是名意界。已识是过去意界。今识是现在意界。当识是未来意界。及余彼分意界者。未来必不生意界。无有过去现在彼分意界。如意界。意识界亦如是。问曰。何故不说五识界彼分。答曰。应说而不说者。当知此说有余。复次五识以生为差别。彼分是不生法。复次五识以所作为差别。彼分是无所作。复次若说意识界彼分。当知亦略说五识界彼分。云何法界。答曰。已为意所知。今为意所知。当为意所知。已为意所知是过去法。今为意所知是现在法。当为意所知是未来法。问曰。何故不说法界彼分耶。答曰。无有彼分法界。所以者何。无有如是法非意境界。若生一刹那意界。除其自体相应共生。余一切法尽缘。问曰。十色入亦是意界境界。何故说名彼分耶。答曰。不以意界故。说自分彼分。乃以眼于色有自分彼分。色于眼有自分彼分。乃至身触。亦如是。若以意界。说自分彼分者。则十二入。尽是自分。无有彼分。所以者何。尽是意境界故。以是事故。作如是说。颇有共生法。或是自分。或是彼分耶。答曰。有十色入是彼分。生老无常是自分。所以者何。生老无常是法界所摄故。法界中无有彼分。颇有相应共生法。或是自分或是彼分耶。答曰。有未来必不生意界是彼分。彼相应共生回转是自分。所以者何。是法界摄故。法界中。无有彼分

问曰。颇以一眼界微尘作所依。一色界微尘作境界。能生眼识耶。答曰。不生所以者何五识身依积聚缘积聚。依合聚缘合聚。眼识依自界缘自界他界。耳识亦尔。意识依自界他界。缘自界他界。余三识依自界缘自界。复次眼识。依自缘自缘他。耳识亦尔。意识依自依他。缘自缘他。余三识依自缘自。此中说自他者。即是界自他。复次眼识。依近缘近缘远。耳识亦尔。意识依近依远。缘近缘远。余三识依近缘近。所以者何。根与境界。无间识乃得生。余广说如杂揵度

问曰。若彼系眼。彼系色。即生彼系识。亦生余系识耶。答曰。或即生彼系识。亦生余系识。即生彼系识者。生欲界。欲界眼。见欲界色。生欲界系识。生欲界。初禅眼见初禅色。生初禅眼识。生初禅初禅眼见初禅色。生初禅眼识。是名即生彼系识。生余系识者。生欲界。以初禅眼见欲界色。生初禅识。生欲界。以第二禅眼。见欲界色。生初禅识。以第二禅眼。见初禅色。生初禅识。以第二禅眼。见第二禅色。生初禅识。以第三禅眼。见欲界色。生初禅识。以第三禅眼。见初禅色。生初禅识。以第三禅眼。见第二禅色。生初禅识。以第三禅眼。见第三禅色。生初禅识。以第四禅眼。见欲界色。生初禅识。以第四禅眼。见初禅色。生初禅识。以第四禅眼。见第二禅第三禅第四禅色。生初禅识亦如是。是则说生欲界者生初禅。以初禅眼。见欲界色。生初禅识。余应随相广说。如生欲界者。生第二禅第三禅第四禅。广说亦如是。问曰。彼系身。彼系眼。彼系色。即生彼系识。亦生余系识耶。答曰。即生彼系识。亦生余系识。即生彼系识者。生欲界。以欲界身欲界眼。见欲界色。生欲界识。生初禅。以初禅身初禅眼。见初禅色。生初禅识。是则说即生彼系识。生余系识者。生欲界。以欲界身初禅眼。见初禅色。生初禅识。以欲界身初禅眼。见初禅色。生初禅识。以欲界身以第二禅眼。见欲界色。生初禅识。以欲界身第二禅眼。见初禅色。生初禅识。以欲界身第二禅眼。见第二禅色。生初禅识。以欲界身第三禅眼。见欲界色。生初禅识。以欲界身第三禅眼见初禅色生。初禅识。以欲界身。第三禅眼见第二禅色。生初禅识。以欲界身。第三禅眼。见第三禅色生初禅识。以欲界身第四禅眼。见欲界色。生初禅识。以欲界身第四禅眼。见初禅色。生初禅识。见第二禅。乃至见第四禅色。说亦如是。是则说生欲界者。生初禅。以初禅身初禅眼。见欲界色。生初禅识。以初禅身第二禅眼。见欲界色。见初禅色。见第二禅色。说亦如是。以初禅身第三禅眼。见欲界色。初禅色第二禅色第三禅色。说亦如是。以初禅身第四禅眼。见欲界色。初禅色第二禅色第三禅色第四禅色。说亦如是。如生初禅。生第二第三。第四禅亦应随相。说以是事故。作如是说。颇有余系身余系眼余系色。生余系识耶。答曰有。生欲界以欲界身第三禅眼。见第二禅色生初禅识。以第四禅眼。见第二禅色。以第四禅眼。见第三禅色。说亦如是。生第二禅。以第二禅身第三禅眼。见欲界色。生初禅识亦尔。以第二禅身。以第四禅眼。见欲界色。生初禅识亦尔。以第二禅身第四禅眼。见第三禅色。生初禅识亦尔。生第三禅。以第三禅身第四禅眼。见欲界色。生初禅识亦尔。以第三禅身第四禅眼。见第二禅色。生初禅识亦尔。如眼界色界眼识界。耳界声界耳识界。说亦如是。问曰。若彼系鼻。彼系香。即生彼系识。亦生余系识耶。答曰。即生彼系识。不生余系识。欲界系鼻欲界香。即生欲界系识。如鼻界。香界鼻识界。舌界味界舌识界。说亦如是。问曰。若彼系身。彼系触。即生彼系识。亦生余系识耶。答曰。或生彼系识。亦生余系识。生彼系识者。生欲界。以欲界身欲界触。生欲界识。生初禅。以初禅身初禅触。生初禅识。是则说生彼系识。生余系识者。生第二禅。以第二禅身第二禅触。生初禅识。生第三第四禅亦如是。所以者何。即彼身触。非余身触。问曰。若彼系意。彼系法。即生彼系识。亦生余系识耶。答曰。或生彼系识。或生余系识。生彼系识者。生欲界。以欲界意。知欲界法。生欲界意识。乃至生非想非非想处。以非想非非想处意。知非想非非想处法。生非想非非想处识。是则说即生彼处系识。生余系识者。或有说。欲界善心次第生未至依。未至依次第生欲界善心。复有说者。欲界善心次第生未至依。亦生初禅未至依。初禅次第生欲界善心

复有说者。欲界善心次第生未至依。初禅中间禅。彼三地次第生欲界善心。尊者瞿沙。作如是说。欲界善心次第生未至依。初禅中间禅第二禅。彼四地次第生欲界善心。如行者入超越定。从初禅超二禅及眷属。起第三禅现在前。此亦如是。评曰。应作是说。欲界善心次第生未至依。初禅彼二地次第生欲界善心。欲界善心次第生未至依。初禅者。欲界意次第生初禅意识法。或三界系。或不系。彼二地意次第生欲界善心。初禅意生欲界意识法。或三界系。或不系。初禅次第生第二禅。是顺次定。初禅意生第二禅意识法。或三界系。或不系。第二禅次第生初禅。是逆次定。第二禅意。生初禅意识法或三界系。或不系。乃至第三禅次第生第四禅。是顺次定。第三禅意。生第四禅意识法。或三界系或不系。第四禅次第生第三禅是逆次定。第四禅意。生第三禅意识法。或三界系或不系。第四禅次第生空处。是顺次定。第四禅意。生空处意识法。或无色界系或不系。空处次第生第四禅。是逆次定。空处意。生第四禅意识法。或三界系或不系。空处次第生识处。是顺次定。空处意。生识处意识法。或识处系。或无所有处系。或非想非非想处系。或不系。识处次第生空处。是逆次定。识处意。生空处。意识法。或无色界系或不系。乃至无所有处次第生非想非非想处。是顺次定。无所有处意。生非想非非想处意识法。或非想非非想处系或不系。非想非非想处次第生无所有处。是逆次定。非想非非想处意。生无所有处意识法。或无所有处系。或非想非非想处系或不系。初禅次第生第三禅。是顺超定。初禅意。生第三禅意识法。或三界系或不系。第三禅次第生初禅。是逆超定。第三禅意。生初禅意识法。或三界系或不系。如是乃至识处次第生非想非非想处。是顺超定。识处意。生非想非非想处意识法。或非想非非想处系。或不系。非想非非想处次第生识处。是逆超定。非想非非想处意。生识处意识法。或识处无所有处非想非非想处系或不系。如是等则说定。复有余定亦可尔。欲界有四种变化心。欲界有初禅果变化心。欲界有第二第三第四禅果变化心。此变化心次第生净禅。净禅次第生变化心。净初禅次第生欲界初禅果变化心。初禅意。生欲界意识法。是变化。或四入。或二入。欲界初禅果变化心次第生净初禅。欲界意。生初禅意识法。或三界系或不系。乃至净第四禅次第生欲界第四禅果变化心。第四禅意。生欲界意识法。是变化。若四入。若二入。欲界第四禅果变化心次第生净第四禅。欲界意生第四禅意识法。或三界系或不系。如是则说定。生时亦可尔。欲界命终生初禅。欲界意生初禅意识法。或八地系或不系。初禅命终生欲界。初禅意生欲界意识法。或三界系或不系。欲界命终。乃至生非想非非想处欲界意。生非想非非想处意识法。或非想非非想处系或不系。非想非非想处命终。生欲界。非想非非想处意。生欲界意识法。或三界系或不系。乃至无所有处命终。生非想非非想处。无所有处意。生非想非非想处意识法。或非想非非想处系或不系。非想非非想处命终。生无所有处。非想非非想处意。生无所有处意识法。或无所有处系。或非想非非想处系或不系。是则说生时

若成就眼界。亦成就色界耶。答曰。成就眼界。亦成就色界。颇成就色界。非成就眼界耶。答曰有。生欲界。若不得。设得便失。广说如根揵度。若成就眼界。亦成就眼识界耶。答曰。或成就眼界。不成就眼识界。乃至广作四句。成就眼界。不成就眼识界者。生第二第三第四禅。眼识不现在前。成就眼识界。不成就眼界者。生欲界。不得眼界。设得便失。成就眼界。亦成就眼识界者。生欲界得眼界不失。若生初禅。若生第二第三第四禅。眼识界现在前。不成就眼界。亦不成就眼识界者。生无色界。若成就色界。亦成就眼识界耶。答曰。若成就眼识界。亦成就色界。颇成就色界。不成就眼识界耶。答曰有。生第二第三第四禅。眼识不现在前。若不成就眼界。亦不成就色界耶。答曰。若不成就色界。亦不成就眼界。颇不成就眼界。非不成就色界耶。答曰有。生欲界。不得眼界。设得便失。若不成就眼界。亦不成就眼识界耶。答曰。若不成就眼界。非不成就眼识界。乃至广作四句。不成就眼界非不成就眼识界者。生欲界不得眼界。设得便失。不成就眼识界非不成就眼界者。生第二第三第四禅。眼识不现在前。俱不成就者。生无色界。俱非不成就者。生欲界。得眼界不失。若生初禅第二第三第四禅。眼识现在前。若不成就色界。亦不成就眼识界耶。答曰。若不成就色界。亦不成就眼识界。颇不成就眼识界。非不成就色界耶。答曰有。生第二第三第四禅。眼识不现在前。若成就眼界得。不成就色界亦尔耶。答曰。或成就眼界得。不成就非色界。乃至广作四句。成就眼界。得不成就非色界者。生欲界。失眼界。成就色界得不成就非眼界者。生欲界无眼界。命终生无色界。俱成就得不成就者。生欲界。有眼界。命终生无色界。若色界命终。生无色界。俱不成就不得不成就者。除上尔所事。若成就眼界得。不成就眼识界亦尔耶。乃至广作四句。成就眼界得不成就非眼识界者。若欲界失眼界。第二第三第四禅命终。生无色界。成就眼识界得不成就非眼界者。欲界无眼界。命终生无色界。若第二第三第四禅眼识现在前而灭者。俱成就得不成就者欲界有眼界。命终生无色界。若初禅命终。生无色界。俱不成就不得不成就者。除上尔所事。若成就色界得。不成就眼识界亦尔耶。乃至广作四句。成就色界得不成就非眼识界者。第二第三第四禅命终。生无色界。成就眼识界得不成就非色界者。第二第三第四禅眼识现在前灭者。俱成就得不成就者。欲界初禅命终。生无色界。俱不成就不得不成就者。除上尔所事。若不成就眼界得。成就色界亦尔耶。答曰有。若不成就色界得。成就眼界亦尔。颇不成就眼界得。成就非色界耶。答曰有。生欲界次第得眼界。若不成就眼界得。成就眼识界亦尔耶。乃至广作四句。不成就眼界得成就非眼识界者。无色界命终。生第二第三第四禅。生欲界次第得眼界。不成就眼识界得成就非眼界者。生第二第三第四禅眼识现在前。俱不成就得成就者。无色界命终。生欲界初禅。非俱不成就得成就者。除上尔所事。若不成就色界得。成就眼识界亦尔耶。乃至广作四句。不成就色界得成就非眼识界者。无色界命终。生第二第三第四禅。不成就眼识界得成就非色界者。生第二第三第四禅。眼识现在前。俱不成就得成就者。无色界命终。生欲界初禅。非俱不成就得成就者。除上尔所事。如说眼界色界眼识界。乃至意界法界意识界亦应随相说。是则说相似者。如眼色眼识界。于余不相似作五三句。耳声耳识界作四二句。鼻香鼻识界作三三句。舌味舌识界作二三句。身触身识界作一三句也

阿毗昙毗婆沙论卷第三十八阿毗昙毗婆沙论卷第三十九

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    使犍度十门品之三

十二入。眼入乃至法入。问曰。何故作此论。答曰。此是佛经。佛经说。生闻婆罗门。往诣佛所。到已面共世尊种种语论。问讯已在一面坐。尔时生闻婆罗门。白佛言。世尊。说一切者多。一切有几种。沙门瞿昙。为施设何一切耶。佛告婆罗门。我施设一切者。谓眼入乃至法入。是名一切。如来说如是法名一切。婆罗门若有作是说。我能遮止沙门瞿昙所说一切。更说余一切者。但有是语。而无有实。若还问者。反生疑惑。所以者何。非境界故。佛经虽作是说。而不广分别。佛经是此论所为根本。彼中诸不说者。今欲广说故。而作此论。问曰。若作是说。有说。一切者。谓十八界。有说。一切者。谓五阴及无为法。有说。一切者。谓四谛及虚空非数灭。有说。一切者。谓名色。如是等所说。皆但有是语。而无有实。若还问者。反生愚惑。非其境界耶。答曰。此中遮义不遮于文。若作是说。一切法性。十二入摄。若更有说。余法非十二入摄者。如是说者。但有是语。空无有实。乃至广说。说十二入。是胜说妙说最上说。问曰。说十二入。何故名胜说妙说最上说耶。答曰。说入是中说能摄一切法。说界。虽能摄一切法。而是广说。说阴。不摄一切法。唯摄有为法。不摄无为法。而是略说。说入。是中说亦摄一切法。若欲观一切法者。当以入门。若以入门观者。便生十二智光。现十二义像。如人莹磨十二明镜。在其中立。有十二像现。彼亦如是。一身有十二入可得。问曰。若一身有十二入可得者。云何说有十二入耶。答曰。以所作异故。虽一身中十二入可得。然十二入。所作各异。譬如一屋有十二工巧人居。虽同居一屋。而所作有十二种。彼亦如是。复次以二事故。立十二入。一以所依。二以所缘。复次以三事故。立十二入。一以自体。二以所依。三以所缘。自体者。谓眼入乃至法入。所依者。六所依。谓眼乃至意。所缘者。六所缘。色乃至法。此是入体性。乃至广说

已说体性。所以今当说。何故名入。入是何义。答曰。输门义是入义。输道义是入义。藏义是入义。仓义是入义。经义是入义。杀处义是入义。田义是入义泉义是入义。流义是入义。海义是入义。白义是入义。净义是入义。输门义是入义者。犹如城中及与村落所输之物。众生得已。长养于身。如是以所依及所缘故。令心长养。输道义亦如是。藏义是入义者。犹如藏中有金等宝物可取。如是以所依及所缘故。有心心数法等可取。仓义是入义者。犹如仓中有麦等种种子实可取。如是以所依及所缘故。有心心数法等可取。经义是入义者。犹如织机经缕在于处处。如是以所依及所缘故。心心数法。在于处处。杀处义是入义者。犹如杀处断百千众生头在地。如是以所依及所缘故。令心心数法。为无常灭所灭。田义是入义者。犹如田中有种种苗稼可取。如是以所依及所缘故。有种种心心数法可取。泉义是入义者。如偈说

  何处泉水生　　何处道不通
  世间诸苦乐　　何处得灭尽

佛作是说

  眼耳及与鼻　　舌身及与意
  此处尽名色　　能令无有余

是处能生泉水。乃至广说。流义是入义者。如偈说

  一切皆流出　　以何制此流
  以何为流戒　　令流止不出

佛作是说

  世间所有流　　当以正念制
  亦名为流戒　　慧令流不出

海义是入义者。如经说。比丘当知。眼是人海。色是涛波。若忍受色涛波者。是人能广度眼海。得免洄澓罗刹等难。乃至意说亦如是。白义是入义者。以净故名白。亦名为净。是故输门义是入义。乃至广说。外道书说入名部那(天竺音部那名根亦名为入亦名为作也)。如彼摩犍提梵志。作如是说。沙门瞿昙。心无部那。而不受我女

已总说诸入。所以今当一一别说其体。云何眼入。答曰。若眼已见色。今见色。当见色。及余彼分眼入。已见色是过去。今见色是现在。当见色是未来。及余彼分眼入。广说如界处。乃至意入说亦如是。云何色入。答曰。若色入。已为眼所见。今为眼所见。当为眼所见。广说如界处。问曰。十色入。皆体是色。何故说一入名色。不说余耶。答曰。以此一入是粗了了现见法。复次此入是二眼境界。谓肉眼天眼。复次此入是三眼境界。谓肉眼天眼慧眼。复次此是二入境界。为眼色所缘。是故尊者瞿沙。作如是说。是二眼境界。为眼识所缘。是故此入名为色入。非余。复次此入施设。有粗细长短。在此在彼故。复次此入是大障碍故。复次此入可种可生可长外物。可种者是种子时。可生者是萌牙时。可长者是茎叶华果时。内物可种者。是迦罗罗时。可生者是安浮陀时。可长者是卑尸伽那婆罗奢佉时。复次方体是色。以色故施设诸方。复次由旬体是色。以色故施设由旬。复次此入能覆余入。犹如巾帽。故名色入。复次若说二十种二十一种。是名色入。余色入不尔。声香味入。广说如界处。问曰。触入。为可触故是触入。为体是触故是触入。为触所缘故是触入耶。若可触是触入者。微尘不能触微尘。若体是触名触入者。体是四大造色。非是触体。若为触所缘名触入者。亦为余数法所缘。答曰。应作是说。可触故名触入。问曰。若然者。微尘不能触微尘。答曰。此是世俗言说。世俗作如是说。眼所更事名见。耳所更事名闻。鼻所更事名嗅。舌所更事名味。身所更事名触。复次以缘身缘触故生身识生。彼能缘实义身识故名触。尊者佛陀提婆说曰。应言无触。所以者何。合聚无间色触时。假名为触。无实义触。复次能生余入。增长余入故名触入。云何法入。若法已为意所知。今为意所知。当为意所知。广说如界处。问曰。十二入体性是法。何故说一入名法。非余入耶。答曰。虽十二入体性是法。然法入应名为法。所以者何。如十八界。虽体性是法。独法界名法。如十智虽体性是法。独法智名法。七觉支虽体性是法。择法觉支名法。六念念法名法。四念处法念处名法。四不坏净。于法不坏名法。四无碍法。无碍名法。三归三宝法。归法宝名法。复次余入有二名。此唯有一名。复次余入是不共名。此入是共名。以共为名。复次能生一切诸法。生在彼中故名法入。复次一切诸法印封相。生老无常。在彼中故名法入。复次以名显明诸法。名在彼中故名法入。复次诸法来处。说名法入。如风来处名为风孔。彼亦如是。复次能解空法。在彼中故名法入

问曰。若然者。能计我法。亦在彼中。可言我入耶。答曰。计我非实。解空是实。复次第一实法。谓常住不变。不为生老死所坏。灭尽涅槃。在彼中故名法入。复次能分别总相别相。除物体愚。及余缘中愚。不取虚相。慧在彼中。故名法入。复次彼中有多法故名法入。多法者。谓色无色法。相应不相应法。有依无依法。有行无行法。有缘无缘法。有势用法。无势用法。已别说诸入一一体。今当求其次第。何故世尊。于内入中。先说眼入乃至意入。外入中。先说色入乃至法入。答曰。欲令文义随顺故。复次欲令说者随顺受持者亦随顺故。复次以有粗细故。内六入中。眼入粗故先说。意入细故后说。外六入中。色入粗故先说。法入细故后说。问曰。云何立内六入外六入。为以人故为以法故。若以法者。一切诸法。无有欲心。云何立内外。若以人者。如实义中。毕竟无人。若无人者。云何有内外。答曰。应作是说。以说法故。立内外入。非一切法。若法能与六识作所依是内入。作所缘是外入。复次根者是内入。根义是外入。所境界境界亦尔。然此内外法不定。若我内入是他外入。若他内入是我外入。佛经说此六入。当知是内法。问曰。如一切法。当知皆是内法。何故独说六入是内法耶。答曰。世尊欲教诸弟子于内法行禅故。如说。观察内根心不外缘。复次欲教诸弟子不行虚妄禅故。如说。汝等不应行虚妄禅计常乐我净。应行不虚妄禅计无常无我无乐无净。计因集有缘。当以是八圣行观察于有。复次欲教诸弟子行不共禅故。如说。汝等不应行共禅法。观粗观苦观粗坏观止妙离。应行不共禅法。应观如病如痈如箭入身常是过患无常苦空无我。当以此八法观察于有。复次此经说观察内法。若于内法。计有我便计我所。计已便计已所。于我有爱。于我所亦有爱。若见有我。亦见我所。为长养内我故求外所须物。佛经说六触入。当知是内法。问曰。六入六触入。有何差别。答曰。或有说者。无有差别。若说六触入。若说六入。名虽有异。无差别义。复有说者。名即差别是名触入。是名六入。复次若有所作是名触入。若无所作是名六入。若作是说。现在者是触入。过去未来者是六入。复次若已生六入是触入。若未生六入是六入。若作是说。过去现在是触入。未来是六入。复次若为触作依是名触入。若为数法作依名六入。复次若为心心数法作依是名触入。若空不为心心数法作依是名六入。尊者波奢说曰。体是六入。若为触作依。名六触入。如钵体性是钵。比丘用故。名比丘钵。彼亦如是。尊者富那奢说曰。体性入是六入所作。入是六触入。犹如铁钵。体性是钵。以盛苏故。名盛苏铁钵。问曰。此亦如是。六受入六想六思等入。何故独说六触入耶。答曰。应说六受入乃至六思等入。而不说者。当知此说有余。复次以触名义胜故。若说六触入。当知亦说六受入乃至六思等入。复次触是心心数法。今心心数法。皆从触生。以触力故。而现在前。是故说名触入

佛经说。内六入是此岸。外六入是彼岸。问曰。佛说此岸彼岸。为以何法。答曰。以近远法故。如河于人。近者是此岸。远者是彼岸。如是心心数法。近者是所依。远者是所缘。复次如初入已度法故。如人初入河处是此岸。已度处是彼岸。如是心心数法。初入如所依

已度如所缘。复次灭尽涅槃。是彼岸彼法。外入所摄。以摄彼法故。外入名彼岸。佛经说。身见是此岸。身见灭是彼岸。问曰。此中何者是河。答曰。心心数法。是如河所摄。众生数非众生数。漂入大海。如是所依所缘。所摄众生心心数法。皆漂入生死大海。佛经说。有八胜处十一切处。问曰。此亦是入。何故但说十二入耶。答曰。彼亦在此十二入中。彼相应共有法。当知皆是意入法入。佛经说。四无色定是处。如空处乃至非想非非想处。问曰。何故世尊说四无色定是处耶。答曰。欲异外道故。外道计彼是四种解脱。一无身。二无边意。三净聚。四世塔。无身者是空处。无边意者是识处。净聚者是无所有处。世塔者是非想非非想处。为异外道故。作如是说。此是生处。非是解脱。佛经说二处。一无想众生处。二非想非非想众生处。问曰。何故佛经说此二处名处。答曰。佛欲异外道故。外道计此二处是解脱。佛说此是生处非解脱。复次此处。是退还法。而外道计是解脱。佛说此处是众生退还处。还生诸界诸生诸趣中故。复次此是散法。而外道计是解脱。佛说此二处是散法。众生于此处。散在诸界诸生诸趣中。无想众生。散在欲界。非想非非想处众生。散在下地。复次寿命长远故。外道计是解脱。一切凡夫受身处。寿命长远。莫若无想处寿五百大劫。一切生处。寿命长远。莫若非想非非想处寿八万大劫。佛作是说。此是受生处。非是解脱。复次佛说余处有二名。一是众生居。二是识住。亦以二种名。说此二处。一名众生居。二名处。复次众生居。佛说是识住。若是众生居。非识住。佛说是处

如经说。尊者舍利弗。往诣佛所。作如是说。世尊说入为无有上。所言一切。谓十二入。世尊知此法。更无有余。世尊无余之智。更无有上。无有沙门婆罗门等觉所知过世尊者。问曰。尊者舍利弗。云何能知所言一切谓十二入。答曰。从他闻故。能知是法。佛经说所言一切。谓十二入。尊者舍利弗。得不坏信。于佛所说。生尊重信。问曰。尊者舍利弗。从他闻故。能知是法。非自现智耶答曰。亦自有现智能知。所以者何。尊者舍利弗。于十二入。亦能一一知见。问曰。世尊于十二入。一一知见。尊者舍利弗。于十二入。亦一一知见。世尊。尊者舍利弗。所知有何差别。答曰。世尊一一知见十二入。亦以总相。亦以别相。尊者舍利弗。一一知见十二入。但以总相。不能别相。所以者何。更有无量入义。在十二入中。尊者舍利弗。须他显示。然后乃知。复次尊者舍利弗。一一知见十二入。从他闻故知。世尊所知。独觉无师。复次世尊有一切智一切种智。尊者舍利弗。有一切智。无一切种智复次尊者舍利弗。以识身故知。尊者舍利弗。作是念言。一切者。谓六识所依及缘。复次尊者舍利弗。以所说无余故知。佛说十二入。眼入乃至意入。最后说法入。尊者舍利弗。作如是念。诸法十一入中。所不称说者。应尽在法入中。是故以所说无余故知。五阴。色阴乃至识阴。问曰。何故作此论。答曰。此是佛经。佛经说五阴。乃至广说。佛经虽说五阴。而不广分别。佛经是此论所为根本。今欲广分别故。而作此论。云何色阴。佛经说。诸所有色。尽是四大。及四大造。余经复说。云何色阴诸所有色。过去未来现在。若内若外。若粗若细。若恶若妙。若远若近。如是等。总名色阴。乃至识说亦如是。阿毗昙者。作如是说。云何色阴。谓十色入。及法入中色。是名色阴。此三说有何差别。答曰。各各皆止他义

问曰。如经说。诸所有色。皆是四大。及四大造。此中为止何等他义。答曰。佛为未来世故作是说。佛知未来世中当有作是说者。四大之外。更无造色。如佛陀提婆等。为止如是说者意故。经作是说。诸所有色。尽是四大。及四大造。如说。诸所有色。过去未来现在。若内若外。乃至广说。此中为止何等他义。答曰。时世有梵志。名牢罗尼佉。不说有过去未来。世尊为止彼人意故。作如是说。诸所有色。过去未来现在。若内若外。乃至广说。如说。云何色阴。谓十色入。及法入中色。此中为止何等他义。答曰。为止譬喻者意故。譬喻者不说法入有色。是故尊者达磨多罗。作如是说。诸所有色。尽五识所依。五识所缘。云何名为色。非五识所依五识所缘。为止如是说者意故。彼尊者造阿毗昙论。作如是说。云何色阴。谓十色入。及法入中色。问曰。若法入中色。有实体相者。尊者达磨多罗所说云何通。答曰。可作是说。诸所有色。尽五识所依。六识所缘。法入中色。虽不为五识所依五识所缘。而为意识所缘。复次法入中虽非五识所缘。彼所依是身识所缘。谁是彼所依。谓四大是。云何受阴。谓六受身。眼触生受。耳鼻舌身意触生受。如佛经说。阿毗昙说亦尔。云何想阴。谓六想身。眼触生想。耳鼻舌身意触生想。如佛经说。阿毗昙说亦尔。云何行阴。答曰。佛经说。谓六思身。眼触生思。耳鼻舌身意触生思。阿毗昙者。作如是说。行阴或相应。或不相应。乃至广说。问曰。世尊何故诸相应不相应行阴。但说思是行阴。非余相应不相应法耶。答曰。以思长养行。胜是故世尊说思是行。如爱长养于集胜。是故世尊一切有漏中。说爱是集。彼亦如是。复次造作义是行义。思体造作。云何识阴。谓六识身。眼识身乃至意识身。如经所说。阿毗昙说亦尔。此是阴体。乃至广说。已说体相。所以今当说。何故名阴。阴是何义。答曰。聚义是阴义略义是阴义。[卄/積]义是阴义。总义是阴义。若施设世。即是施设阴。若说多语阴是多语。聚义是阴义者。诸所有色。过去未来现在。若内若外。乃至广说。尽聚为色阴。乃至识阴亦尔。略义说亦如是。[卄/積]义是阴义者。如种种杂物。合为一[卄/積]。如是种种诸色。合为色阴。乃至识阴亦尔。总义是阴义者。识所为色。过去未来现在。若内若外。乃至广说。如是等色。总名色阴。乃至识阴亦尔。问曰。过去未来现在色可合聚不。答曰。可能合聚其名。不合聚其体。乃至识亦如是。施设世即是施设阴者。如色阴施设有三世。乃至识阴亦尔。多语是阴语者。如多财名财阴多谷名谷阴多军名军阴。如是亿万那由他极远多色。总为色阴。乃至识阴亦尔。问曰。一微尘。可立色阴不耶。答曰。或有说。不可立。若欲立者。必须积聚。复有说者。可立。以相故立。若一微尘。不名阴者。众多合聚。亦不名阴。阿毗昙者作如是说。一微尘。不以阴故。是一界一入一阴所摄。若以阴者。是一界一入一阴少分。如人于谷聚上取一粒谷。他人问言。汝取何等。彼人若不以谷聚者。言我取一粒谷。若以谷聚者。言我取谷聚一粒谷

已总说阴所以。今当求其次第。世尊何故先说色阴。后说乃至识阴。答曰。欲令文义随顺故。复次欲令说者随顺。受持者亦随顺故。复次以粗细故。五阴中。色阴粗故先说。四无色阴中。受阴粗故。次色阴说。问曰。如受非色。不住方所。云何施设有粗细耶。答曰。以所行故。如世人言。我手受苦乐。头足身诸分等。皆受苦乐。如是等。说色受亦尔。想转细于受。次受说想。行转细于想。次想说行。识最细在后说。问曰。如五阴是作想作是行阴。世尊何故一阴说名行阴余不说耶。答曰。虽五阴尽是作相。而行阴得名行。如十八界。虽体尽是法。而法界得名法。乃至三宝三归。虽体是法。而法宝法归。得名为法。如是五阴虽体是行。而行得名。复次此阴有一名。余阴有二名。复次此阴是共名。余阴是共不共名。以不共名说。复次以能生一切诸法生在彼中故名行阴。复次一切诸法印封相。生老无常。在彼中故名行阴。复次以名显明诸法名在彼中故名行阴。复次能解空法在彼中故名行阴。问曰。若然者。能计我法。亦在彼中。可言我阴耶。答曰。计我非实。解空是实。复次能分别总相别相。除物体愚及缘中愚。不取虚相。慧在彼中。故名行阴。复次彼中有多法故名行阴。多法者。相应不相应法。有依无依法。有行无行法。有缘无缘法。有势用无势用法。问曰。何故诸心数法中。说想受独立为阴。余心数法立行阴。尊者婆奢说曰。世尊决定知法相。亦知势用。余人不能知。若法堪任独立阴者便立。不堪任者。合集乃立。复次欲以种种说种种文庄严于义。若以种种说种种文庄严于义。义则易解。复次欲见二门二略二入。乃至广说。复次此现门现略现始入所有心数法。若根性若非根性。若说受当知已说根性。若说想当知已说非根性。如根性非根性。明非明。有威势无威势。有力无力。当知亦如是。复次以此二法故。色无色界有差别。以受故说色界差别。以想故说无色界差别。复次行者以此二法故。于二界中。极生苦恼。以受故。于色界中。极生苦恼。以想故。于无色界中。极生苦恼。复次以贪乐受染着颠倒想故。众生于生死中。受大苦恼。复次以此二法是斗诤根本。受是爱斗诤根本。想是见斗诤根本。如二斗诤根本。二烦恼。二边。二箭。二戏论。二见。当知亦如是。复次以此二法独受识住名。余数法在行阴中。受识住名。复次行者增恶此二法故。入灭尽定。如施设经说。以何方便。得灭尽定。云何修方便。得灭尽定。答曰。彼初行者。作如是念。云何令我不思诸行。令想受不生。生者便灭。若想受不生。生者便灭。是名灭定

问曰。无为法。何故不立阴耶。答曰。无阴相故不立阴。复次以是阴究竟处故不立阴。如瓶衣究竟处不名瓶衣。彼亦如是。复次若法是生灭有因有缘。有为相者立阴。无为法无生灭无因无有为相。故不立阴。复次若法属因属缘属和合作者立阴。无为法。不属因。不属缘。不属和合作。故不立阴。复次若法随世行。能取果。能有所作。能知缘者立阴。无为法与上相违。故不立阴。复次阴随世行。无为法。不随世行。阴与苦相续。无为法不与苦相续。阴有前后。无为法无前后。阴有上中下。无为法无上中下。复次无为体非是色。亦不名色。乃至体非是识。亦不名识。复次从他生故立阴。无为法不从他生故不立阴。无为法以如是等事故不立阴

世尊经说五阴。戒阴。定阴。慧阴。解脱阴。解脱知见阴。问曰。如是则有十阴。何故说五阴耶。答曰。此后五阴。即在前五阴中。戒阴在色阴中。余四阴在行阴中。是故说五。经中复说。尊者阿难作如是言。我从佛边。受八万法阴。从比丘边。受二万法阴。问曰。有如是等多阴。世尊何故说五阴耶。答曰。虽有如是多阴。亦在五阴中。或有说。佛语体是口业。或有说体是名。若说体是口业者。是色阴摄。若说体是名者。是行阴摄。是故在五阴中问曰。法阴剂量为几许。答曰。或有说者。如法阴论所说。六千偈是一法阴剂量。余法阴亦尔。复有说者。如世尊种种言辞说四念处。是一法阴剂量。四正断。四如意足。五根五力。七觉八道种。亦如是。尊者瞿沙说曰。五十万五千五百五十偈。是一法阴剂量。评曰。应作是说。众生行有八万佛说对治法。亦有八万。受化者入佛法中。以八万法。即是八万法阴

五取阴色取阴受想行识取阴。问曰。何故作此论。答曰。此是佛经。佛经说五取阴。乃至广说。佛经虽说五取阴。而不广分别。今欲广分别故。而作此论。云何色取阴。答曰。若色是有漏是取彼色在过去未来现在。若缘彼。生欲生爱生恚生痴生怖。生如是等心烦恼法。生欲生爱者是渴爱。生恚者是恚。生痴者是无明。生怖者。或有说者。不应作是说。所以者何。先所说烦恼性。即是怖故。问曰。若然者。怖体性是何。答曰。或有说者。是身见性。所以者何。众生计我者常怖。若说身见。当知已说怖。复有说者。体性是爱。所以者何。行爱者常怖故若说爱当知已说怖。复有说者。体性是无明。所以者何。痴者常怖故。若说痴当知已说怖。评曰。应说怖。所以者何。怖体性异。怖是心数法与心相应。在如是法中。如是等诸余法。是名心数法。问曰。何处有此怖。答曰。在欲界非色无色界。问曰。若色界无怖者。佛经云何通。如说。比丘当知。先生光音众生。见后生者心生恐怖。而慰劳言。大仙莫怖。我等数数曾见烧诸梵宫。于彼即灭。偈义云何通。如偈说

  闻诸长寿天　　有妙色名誉
  心怀恐怖恼　　如鹿畏师子

答曰。此中说厌离是怖。问曰。厌离怖畏。有何差别。答曰。名即差别。是名厌离。是名怖畏。尊者和须蜜说曰。若在欲界名怖。若在色界名厌离。烦恼中间生者是怖。善根中间生者是厌离。尊者佛陀提婆说曰。于无利事生疑欲得远离是怖。已得远离心犹生动。是厌离。怖与厌离。是谓差别。问曰。谁有此怖。为是凡夫。为是圣人。答曰。或有说者。是凡夫非是圣人。所以者何。圣人已离五恐怖故。五恐怖者。一不活怖。二恶名怖。三大众怖。四死怖。五恶道怖。评曰。应作是说。凡夫亦怖。圣人亦怖。问曰。圣人非已离五恐怖耶。答曰。虽无如是等怖。有须臾怖。问曰。何等圣人有怖畏耶。为学人。为无学人。答曰。亦学人亦无学人。学人者。须陀洹斯陀含阿那含。无学人者。阿罗汉辟支佛。唯除佛世尊。所以者何。世尊无有恐怖疑虑毛竖如是等心烦恼法者。谓缘彼色。一切遍使。及修道所断。云何受取阴。答曰。若受是有漏是取。广说如色阴。此中差别者。谓缘彼受。一切遍非一切遍使。如受想行识。说亦如是。此是取阴体。乃至广说已说体性。所以今当说。何故名取阴。取阴是何义。答曰。从取生故名取阴。能生取故名取阴。复次从取转故名取阴能转取故名取阴。复次能从取受故名取阴。能受取故名取阴。复次从取长故名取阴。能长取故名取阴。复次从取广故名取阴能广取故名取阴。复次属取故名取阴。如人属王名为王人。彼亦如是。中无有我。若人问阴。汝属谁耶。阴应答言。我属于取。复次取于阴中。生时生。住时住。使时使。而不衰损。是名取阴。复次取于阴中。生长增广故。是名取阴。复次取于阴中。增长饶益故名取阴。复次取于阴中。生于贪着。犹如尘垢。是名取阴。复次取于阴中。心生乐着。如鱼等乐水。故名取阴。复次取是阴。屋舍立处故名取阴。依此阴故。生爱见慢无明疑恚诸烦恼及垢。与取相似故。彼名取阴。如欲界取名欲界取阴色界取名色界取阴。无色界取名无色界取阴。不坏于界。不坏于地。而坏于身。以我取故。他阴名取阴。以他取故。我阴名取阴若不坏身者。则一切外物。不名取阴。所以者何。彼外物中。无取阴故。问曰。阴取阴有何差别。答曰。名即差别。此是阴。此是取阴。复次阴是有漏无漏。取阴是有漏。复次阴摄三谛。取阴摄二谛。复次阴受呵责时增长人受呵责赞叹时寂静人受赞叹取阴唯受呵责时增长人受呵责。阴取阴是谓差别

六界。地界。水界。火界。风界。虚空界。识界。问曰。何故尊者迦旃延子。因六界而作论。答曰。彼尊者有如是欲如是意。随其欲意而作论。亦不违法相。彼意欲因六界而作论。便因六界而作论复次不应求彼尊者何故因六界而立论。所以者何。此是佛经。佛经说十八界。佛于十八界中说六界。六界摄十八界五界及四界少分。摄五界者。谓眼识界。耳鼻舌身识界。四界少分者。色界触界。意界意识界虚空界摄。色界少分。地水火风界摄触界少分。识界摄意界意识界少分。云何此二少分。答曰。此二界有漏无漏。摄有漏不摄无漏。是故摄少分五界及四界少分摄六界。问曰。佛何故于十八界中说六界。答曰。为受化者。受化者。于智境界。或有全愚。或有少分愚。若少分愚者。为说六界。全愚者。为说十八界。复次受佛化者。根有利钝。利根者为说六界。钝根者为说十八界。复次受佛化者。或有疾有迟。疾者为说六界。迟者为说十八界。复次受佛化者。或有喜略。或有喜广。喜略者为说六界。喜广者为说十八界。复次欲现门故。诸所有界。若色性。若非色性。若说五界当知已说色性诸界。若说识界当知已说无色性诸界。如色无色。可见不可见。有对无对。相应不相应。有依无依。有行无行。有势用无势用。有缘无缘。当知亦如是。复次六界。能生养长色无色身。生者是识界。养者是地水火风界。长者是虚空界。复次此六界。能取持增长色无色身。取者是识界。持者是地水火风界。增长者是虚空界。复次此六界。是众生根本。是一切处众生根本。是无始已来众生根本。是有所分别无所分别众生根本。众生根本者。欲色界众生。从生有乃至死有心。此六界无有无势用时一切处众生根本者。无有欲色界众生从生有乃至死有。此六界。无有无势用时。无始已来众生根本众生无有前际。无有众生从生有乃至死有。此六界无有无势用时。有所分别无所分别众生根本者。众生可分别是男是女。如波罗奢佉时。此六界亦有势用。众生不可分别是男是女。如迦罗罗安浮陀卑尸伽那时。此六界亦有势用。尊者瞿沙说曰。缘此六界故。得入母胎。以如是等事故。于十八界中说六界

云何地界。答曰坚。总而言之。是坚而坚。无量差别。内法中坚异。外法中坚异。内法中坚异者。谓发毛爪齿薄皮厚皮肤肉筋脉骨心脾肾肝肺生藏熟藏胃屎手足等。诸身分坚。内法分中。足坚胜手坚。所以者何。足行众生。若当以手行者。手所有筋血肉。则速坏尽。如是等。身分众生。各自有胜。外法中坚者。谓地山大石小石树木铜铁白镴铅锡。金银琉璃车磲马瑙珂贝等诸物。如是等。内外诸坚。总为坚相。云何水界。答曰湿。总而言之。是湿而湿。无量差别。内法湿异。外法湿异。内法中湿者。谓泪汗涕唾肪髓涎胆脓血脑澹阴尿。如是等内湿。外法中湿者。谓泉池河四海水轮等诸湿。如是等。内外诸湿。总名水界。云何火界。答曰热。总而言之。是热而热。无量差别。内法中热异。外法中热异。内法中热者。能令此身暖。所食饮食能令消熟。使身安隐。若增长时。名为热病。外法中热者。如炬灯烛火烧城烧村火摩尼珠火药草火日光明火诸天宫光明火波多罗火等。或有说。内法火热。非外法火。所以者何。若以饮食着铜铁釜中。然于猛火。不能令其色变如腹中食。如是等。内外法中热。总名火界。云何风界。答曰轻动。总而言之。是轻动而轻动相。无量差别。内法中轻动异。外法中轻动异。内法中轻动者。如上向风下向风住胁风住腹风住背风。如针刺风如截刀风[日*賁]风出入息风诸支节风等。外法中风者。如四方风有尘风无尘风遍风不遍风小风大风毗岚风风轮等风。如是等。内外诸风。总名风界。云何虚空界。答曰。佛经说。眼中间空。耳中间空。鼻中间空。口中间空。咽喉中间空。心中间空。心边空。饮食入处住处。所食饮食。下向在处。是名虚空界。阿毗昙者。作如是说。云何虚空界积聚色边色。积聚色边色者。如墙壁边树木边窗向中行来处指中间色。复有说者。此文应如是说。云何虚空界。答曰。不可却色边色。色有二种。有可却不可却。可却色。是众生数。不可却者。是非众生数。此虚空界。是不可却色边色。谓墙壁边树中间叶中间窗向行来处边色。旧阿毗昙。罽宾沙门。作如是说。骨亦有虚空界。筋肉血皮。昼夜明闇形色。亦有虚空界。问曰。缘彼眼识为生不。答曰。或有说者不生。所以者何。以能缘故名缘。彼识不以生故。复有说者生。问曰。何故不了了现耶。答曰。昼为明所覆。夜为闇所覆。故不了了现。问曰。虚空虚空界。有何差别。答曰。虚空非色。虚空界是色。虚空不可见。虚空界是可见。虚空无对。虚空界是有对。虚空是无为。虚空界是有为。问曰。若虚空是无为者。佛经云何通。佛经说如来以手摩虚空。诸比丘世尊以手摩无为法耶。答曰。此中说虚空界是虚空。如余经说。比丘当知。若画师若画师弟子。作如是言。我能以种种杂色。画虚空中。乃至广说。此中说虚空界是虚空。如偈说

  麋鹿归林　　鸟归虚空　　法归分别
  罗汉归灭

此中亦说虚空界是虚空。又如偈说

  虚空无有迹　　外道无沙门
  愚小有戏论　　如来则无有

此中亦说虚空界是虚空。余处亦问虚空。而答虚空界。如波伽罗那说。云何为虚空。答曰。为虚空不障碍色。令色周遍。问曰。何故问虚空。而答虚空界。答曰。虚空界粗。虚空细。欲以粗法显细法故。问曰。何以知有虚空耶。尊者和须蜜。答曰。佛说故知有虚空。问曰。闻他说故知有虚空。非已现智知。答曰。亦已现智知。若无虚空者。则无容受物处。以有容受物处。知有虚空。以有碍无碍处故。知有虚空。复次以有碍无碍故。知有虚空。若有碍处。则非是虚空。若无碍处。则是虚空。尊者佛陀提婆说曰。虚空不可知。非可知法故。所以者何。空非色。非无色。非彼非此。所言虚空者。是世俗假名分别耳。问曰。虚空何所作。答曰。虚空无为无所作。与种种虚空界。作近威势缘。种种虚空界与四大。作近威势缘。四大与有对造色。作近威势缘。有对造色。与心心数法。作近威势缘。坏如是等展转次第法。言无虚空。然虚空实有体相。云何识界。答曰。五识身反有漏意识。问曰。何故界中不说无漏意识。答曰。若法能令有增长者立界。无漏识。与此相违。故不立界。复次若法能令有相续增长生老病死者立界。无漏意识。与此相违。故不立界。复次若法是苦集道。是有生老病死道者立界。无漏意识。与此相违。故不立界。复次若法体。是身见颠倒。是爱是使。为贪恚痴。作立足处。有垢杂毒刺浊堕有堕苦集谛者立界。无漏识。与此相违。故不立界。尊者和须蜜说曰。以何等故无漏识不立界。答曰。此界从有漏生。无漏识。不从有漏生。复次此界。能生有漏。无漏识。不生有漏。复次计我者。于界中计我。无有于无漏识中计我者。复次六界假名是人。无漏识不假名是人。复次界名有报法。无漏识不名有报法。复次缘是界故。而入母胎。不缘无漏识而入母胎。复次此六界是无始法。无漏识非无始法。尊者佛陀提婆说曰。此六界是身分。无漏识非身分。问曰。阴取阴界。此三有何差别。答曰。名即差别。是名为阴。是名为取阴。是名为界。复次施设有为是阴。施设有漏是取阴。施设众生是界。复次所作胜是阴。增长所作胜是取阴。生相续胜是界。阴取阴界。是谓差别

阿毗昙毗婆沙论卷第三十九阿毗昙毗婆沙论卷第四十

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    使揵度十门品之四

二法。色法无色法。问曰。何故作此论。答曰。为止人见为显智希有故。止人见者。此色无色法。毕竟无人。为显智希有者。为聪明有智人。以此二法。解了诸法。所以者何。此二法。能摄一切法故。以是事故。而作此论。云何色法。答曰。十入一入少分。十入者。眼耳鼻舌身。色声香味触。一入少分者。谓法入。云何无色法。答曰。一入。谓意入。一入少分。谓法入。问曰。云何名色法。云何名无色法。答曰。若法名是色。体是色。是色。若法名非色。体非色。是无色。复次若法。体是四大。及四大造。是色。若法。体非四大。非四大造。是无色。复次若四大为因。体是造色者。是色。若法不以四大为因。体非四大造者。是无色。复次若法可生生增长。是色。与此相违。是无色。尊者和须蜜说曰。此中何者是色相。答曰。渐次来义是色相。渐次坏义是色相。有方所义是色相。障碍义是色相。如与怨俱行常有折减义是色相。复次有三义。是色相有色可见有对。有色不可见有对。有色不可见无对。可取舍相义是色相。复次碍义是色相。问曰。过去未来色微尘。及无作色。应非色。答曰。彼亦是色。有色相故。过去色是已碍。未来色是当碍。微尘虽一不能碍。合聚则能碍。无作色。虽是无碍。所依是碍。何者是所依。谓四大是也。以四大碍故。彼亦有碍。譬如树动影亦随动。复次可除却义。是色相。复次有一相义是色相。眼色相异。乃至法入中色相异。尊者佛陀提婆说曰。障碍可坏义是色相。与此相违是无色相。问曰。何故法入中色。十入中不说耶。答曰。若色经刹那。是微尘性者。在十入中。法入中色。虽经刹那。非微尘性。是故不说。复次若色是五识所依。五识所缘。是十入中说。法入中色。非五识所依。亦非五识所缘。是故不说。问曰。为色界色多。欲界色多。答曰。若以入故。欲界色多。所以者何。欲界色是二入九入少分。色界色是九入少分。若以体分。色界色多。所以者何。如施设经所说。光音天身。转大梵世天身。乃至阿迦腻吒天身。亦复转大

二法可见法不可见法。问曰。何故作此论。答曰。为止人见显智希有故。广说如上。复有说者。所以作此论。为止并义者意故。或有说。一切法。皆是可见。如尊者瞿沙等。瞿沙作如是说。一切法。皆是可见。以是慧眼境界故。为止如是说者意。亦明法是可见不可见故。而作此论。云何可见法。答曰。一入。谓色入。云何不可见法。答曰。十一入。问曰。何故十色入中。说一是可见。余非可见耶。答曰。以色入是粗现见。广说如十二入中。色入有二十种。谓长短方圆好不好高下青黄赤白光影明闇云烟尘雾。复有说。二十一种者。二十种如前说。及虚空一种色。此二十种色。几种有色无形。几种有色有形。答曰。八种有色无形。谓青黄赤白光影明闇。余十二种。有色有形。复有作四句者。或有色无形。或有形无色。乃至广作四句。有色无形者。谓青黄赤白光影明闇。此八种是也。有形无色者。谓身有作色也。有色有形者。谓长短方圆好不好高下云烟尘雾等。十二种是也。无色无形者。若色无有色。亦无有形是也。问曰。云何可见义。云何不可见义。尊者和须蜜说曰。可见在彼此故是可见义。不可见在彼此故是不可见义。尊者佛陀提婆说曰。是眼境界是眼所行处是可见义。与此相违是不可见义。问曰。水器中像。镜中像。为是实为非实耶。譬喻者。说言非实。所以者何。镜不入面中。面不入镜中。云何是实。阿毗昙者。说言是实。所以者何。是色入为眼识所缘故。问曰。面不入镜中镜不入面中。云何是实耶。答曰。说若干种生色为色入。不说一种生色。如缘月缘月光珠缘器故出水。如缘日缘日光珠缘干牛粪故出火而有火用。非无其实。如因火攒火燧人工故出火而有火用。非无其实。如是缘镜缘面。生镜中像。实有像用。能生眼识。非无其实。所闻响声。为是实耶。为非实耶。譬喻者。说言非实。所以者何。如一刹那顷声生时。即彼刹那声灭。何容得及生于响耶。阿毗昙者。说言是实。所以者何。是耳境界。为耳识所识故。问曰。如一刹那顷声生时。即彼刹那声灭。何容得及生响耶。答曰。说若干种生声为声入。不说一种生声。如缘舌齿唇嘘咽喉等相触故出声。能生耳识。非无其实。彼亦如是

二法。有对法。无对法。问曰。何故作此论。答曰。欲止人见显智希有故。广说如上。云何有对法。答曰。十色入。谓五内入五外入。云何无对法。答曰。二入。谓意入法入。有对有三种。一障碍有对。二境界有对。三缘有对。障碍有对者。如以手打手。更相障碍。以石打石。更相障碍。如是等。是名障碍有对。境界有对者。如眼对色等。是名境界有对。缘有对者。如心心数法各自受所缘。是名缘有对。三种有对。此中依障碍有对而作论。问曰。为障碍几入耶。答曰。或有说者。障碍一入谓触入。余入非触复有说者。障碍五入。内入中障碍身入。外入中障碍色香味触若作是说。障碍五入者。以手打手时。以五打五。以手打石等时。以五打四。以石打石时。以四打四。以石打手时。以四打五。复有说者。障碍无色入。除声入。若以手打眼时。岂非碍耶。评曰。应作是说。障碍十入。若不障碍声入者。声则无积聚义。施设经说眼决定对色。色决定对眼。乃至意决定对法。法决定对意。彼尊者造论说境界有对。有眼水中不障碍陆地则障碍。如鱼等。有眼陆地不障碍水中则障碍。如人等。于水不障碍于陆不障碍。如顽跋陀人水生罗叉等。于水障碍于陆障碍者。除上尔所事。有眼夜不障碍昼则障碍。如鸱枭等。昼不障碍夜障碍者。如人等昼夜不障碍者。如鹿马狸猫等。昼夜障碍者。除上尔所事。此中何者是有对。何者是无对。答曰。若积聚微尘是有对。若不积聚微尘是无对。复次种种异相是有对。无种种异相是无对。复次若覆蔽相是有对。无覆蔽相是无对。复次若积聚相是有对。无积聚相是无对。复次若有大形段是有对。无大形段是无对。复次若可除却是有对。不可除却是无对。尊者波奢说曰。若别异相。是则障碍。若有障碍。是则积聚。若有积聚。则是形段。则可除却。若可除却。则是有对。与此相违。则是无对。尊者和须蜜说曰。有别异相。有障碍相。是有对。无别异相。无障碍相。是无对。尊者佛陀提婆说曰。可除却相是有对。不可除却相是无对。尊者瞿沙说曰。若是积聚微尘性有色可施设长短亦能出声者是有对。积聚微尘性。则说八入。有色可施设长短者。则说色入。亦能出声者。则说声入。与上相违是无对。尊者婆摩勒说曰。合集多微尘聚是有对。与此相违。是无对

二法有漏法无漏法。问曰。何故作此论。答曰。欲止人见显智希有故。广说如上。复有说者。所以作论者为止并义者意故。如摩诃僧祇部说。佛身一向无漏。问曰。彼何故作此说。答曰。彼依佛经。佛经说如来于世间生世间长。而出世间。不为世间所染。彼作是说。佛若出世间。不为世间所染。则知佛身一向无漏。为止如是说者意。亦明佛身是有漏。若佛身是无漏者。无比女不应于佛身生爱心。余广说如杂揵度。云何有漏法。答曰。十入二入少分。谓意入法入。云何无漏法。答曰。二入少分。谓意入法入。问曰。何故名有漏法无漏法耶。答曰。若法能增长有是有漏。与此相违。是无漏。复次若法能令有相续。能增长生老病死。是有漏。与此相违。是无漏。乃至广说。若法堕苦集谛。是有漏。与此相违。是无漏。尊者和须蜜说曰。云何有漏相。云何无漏相。答曰。从有漏生。是有漏相。不从有漏生。是无漏相。复次能生有漏相。是有漏。不能生有漏相。是无漏。尊者佛陀提婆说曰。若处所能生漏。是有漏相。若处所不能生。漏是无漏相

二法。有为法无为法。问曰。何故作此论。答曰。为止人见为显智希有。广说如上。云何有为法。答曰。十一入。一入少分。谓法入。云何无为法。答曰。一入少分谓法入。问曰。何故名有为无为法耶。答曰。若法有生灭。有因。有有为相。是有为法。与此相违。是无为法。复次若法属因属缘属所作属和合者是有为法。与此相违。是无为法。复次若法为生所生。为住所住。为老所老。是有为法。与此相违。是无为法。复次若法行世。能聚果。能知缘。能所作。是有为法。与此相违。是无为法。复次若法堕世。在阴。是苦相续。有前后。有上中下。是有为法。与此相违。是无为法。尊者和须蜜说曰。云何是有为相。答曰。世相阴相。是有为相。云何无为相。答曰。非世相非阴相。是无为相。尊者佛陀提婆说曰。若以众生故。有生灭者。是有为相。若不以众生无生灭者。是无为相

三法。过去法未来法现在法。云何过去法。答曰。过去五阴。云何未来法。答曰。未来五阴。云何现在法。答曰。现在五阴。问曰。何故作此论。答曰。为止并义者意故。如譬喻者。作如是说。世是常。行是无常。行行世时。如物从器至器。犹如多人从一舍至一舍。诸行行世。亦复如是。为止如是说者意。亦明行即是世世即是行。是故四大揵度。作如是说。世名何法。答曰。说行之言。复有说者。所以作论者。为止言无过去未来于世中愚说现在是无为法者意故。亦明过去未来是实有相。若无过去未来者。则无成就不成就。如第二头第三手第十三入。无有成就不成就者。若无过去未来。则无成就不成就。若有成就不成就。则知必有过去未来是实有相。若言无过去未来。则应如是说。彼过去。若现在时造因。彼果当言在过去。当言在未来。当言在现在耶。若在过去者。应言有过去。不应言无过去。若言无过去。是事不然。若言在未来。应言有未来。不应言无未来。若言无未来。是事不然。若言在现在。则因果共俱。若因果俱者。则违偈说。如说

  作恶不即受　　不如乳成酪
  愚蹈灰底火　　不即时烧足

若果不在过去未来现在则无果。若无果则无因。如第二头第三手第六阴第十三入。若有因果。不在过去未来现在者。则是常。如无为法。若果在现在时。彼因当言在何处。为在过去。为在未来。为在现在。若在过去。亦如上说。若在未来。亦如上说。若在现在。亦如上说。若不在过去未来现在则无因。若无因则无果。如第二头第三手第六阴第十三入。若有因果。不在三世者。则应是常。如无为法。复次若无过去未来者。则无出家法。如偈说

  若说无过去　　则无过去佛
  若无过去佛　　则无出家法

复次若无过去未来者。则常妄语。如偈说

  若说无过去　　而言有腊数
  则是一切时　　而常故妄语

复次若无过去未来者。则无现在。所以者何。以有过去未来故。施设现在。若无三世。则无有为法。若无有为法。亦无无为法。所以者何。以有有为故。则施设无为。若无有为无为法。则无一切法。若无一切法。则无解脱出离。欲令无如是过故。说过去未来是实有相。是故为止他义欲显己义。亦欲显法相相应义故。而作此论。问曰。世体性是何。答曰。过去五阴。未来现在五阴。此是世体性。乃至广说。已说体性。所以今当说。何故名世。世是何义。答曰。去义是世义。问曰。诸行不来不去。若来者则不去。若去者则不来。若来者则来处应空。所以者何。从彼处来故。若去者则妨碍去处。所以者何。去至彼处故。是故尊者和须蜜。说如是偈

  诸行无来相　　以诸刹那故
  而无有去相　　亦无有住者

若行无来去。云何有三世耶。答曰。以所作故。若诸行无所作。是名未来。若有所作。是名现在。若所作已灭。是名过去。若眼未见色。是未来见色。是现在见色。已灭是过去。问曰。若然者。现在彼分眼。云何有所作。答曰。以作相似因故。若不现在前。则不与未来者作相似因。若现在前。则与未来者作相似因。乃至意亦如是。如色未作障碍是未来。若作障碍是现在。若作障碍已灭是过去。如受未生是未来。受若生是现在。受若生已灭是过去。受乃至想行识亦如是。复次若法未取果与果是未来。若取果与果是现在。若取果与果已灭是过去。复次若法不取不与。依果报果。是未来。若取依果报果未与者是现在。若取依果报果已灭是过去。复次若法未与相似因一切遍因是未来。若与是现在。若与已灭是过去。复次若法未生未灭是未来。若已生未灭是现在。若生已灭是过去。未生未坏。已生未坏。已生已坏。未生未离。已生未离。已生已离。说亦如是。复次若法未作三有为相是未来。若已作一今作二是现在。若已作三是过去。复次若法未作四缘是未来。若作四缘是现在。若作四缘已灭是过去。复次若法与三世作因是过去。若与二世作因是现在。若与一世作因是未来。复次若法是三世果是未来。若是二世果是现在。若是一世果是过去。复次以过去未来故。施设现在。不以现在施设现在。以无第四世故。以过去现在故。施设未来。不以未来施设未来。以无第四世故。以未来现在。施设过去。不以过去施设过去。以无第四世故。诸过去所有。色所有耶。答曰。或是过去所有非色所有。乃至广作四句。过去所有非色所有者。过去四阴是色所有。非过去所有者。未来现在色所有。过去所有亦色所有者。谓过去色所有。非过去所有非色所有者。谓未来现在四阴所有。及无为所有。如色作四句。乃至识亦作四句。如过去作五四句。未来现在。亦作五四句。是则有十五四句。若色所有。尽是方方分所有耶。答曰。若是方方分所有。尽是色所有。颇有色所有非方方分所有耶。答曰有。过去未来色。现在微尘。及无作色。若受所有。彼尽非方方分所有耶。答曰。若受所有。尽非方方分所有。颇非方方分所有非受所有耶。答曰。有。想行识所有过去未来色。现在微尘。无作色。及无为法所有。如受想行识说亦如是。诸所有色。尽障碍耶。答曰。若障碍者。尽是色所有。颇有色非障碍耶。答曰。有。过去未来色。现在微尘及无作色。诸所有受。尽觉耶。答曰。若觉尽是受。颇有受非觉耶。答曰。有。过去未来受。如受。想行识说亦如是。问曰。为已生生。未生生。若已生生。云何诸行非还转耶。若未生生。云何诸行非本无而有耶。答曰。应作是说。以事故已生生。以事故未生生。以事故已生生者。诸法本住自体相故生。以事故未生生者。一切未来法。是未生法故生。问曰。为世生。为世中生。若世生者。云何不一法生时一切法生。若一法生一切法生者。则坏世。若世中生者。云何非行异世耶。答曰。应作是说。以事故世生。以事故世中生。以事故世生者。一刹那生时。即是世故。以事故世中生者。于未来世中。一刹那生。余刹那未生故。问曰。为彼法生即彼法灭耶。为余法生余法灭耶。若彼法生即彼法灭者。未来法生。即未来法灭耶。若余法生余法灭者。色生受灭耶。答曰。应作是说。以事故彼法生。即彼法灭。以事故余法生。余法灭以事故。彼法生彼法灭者色生即色灭乃至识生。即识灭。以事故余法生余法灭者。未来世生。现在世灭。问曰。为自分生。为他分生。若自分生者云何非本无自分而有自分。本无物体而有物体。若他分生者。云何法不舍自体。答曰。应作是说。不自分生。亦不他分生。然如其法体。生已而灭。问曰。未来世减。过去世增。云何不施设二世有增减耶。尊者和须蜜说曰。为增计数过去未来世有增减不。若不增计数过去未来世。何故言过去未来世有增减耶。复次过去未来。无量无边。不说有增减。譬如于海。取百千瓶水不减。投百千瓶水不增。以海水无量故。彼亦如是。复次未来法未生未灭故不减。过去法生已灭故不增。复次未来法未生不坏故不减。过去法生已坏故不增。复次未来法未生未离故不减。过去法生已离故不增。尊者佛陀提婆说曰。若法行世者。何不说有增减。但法因缘和合故生。因缘离散则灭。问曰。过去未来。为有积聚。如现在墙壁树木山岩等。为散在处处。若积聚者。云何施主所作。不唐捐其功。云何不有方所。云何不是常。云何不现见。若散在处处者。云何说有过去。王名善见。城名拘奢跋提。讲堂名善法。亦说。有毗婆尸佛乃至迦叶佛。云何说有未来。城名鸡头。未来佛名弥勒。云何施设宿命智。观过去事。愿智观过去未来事。云何非本无今有已有还无。答曰。应作是说。或有说者。积聚如现在墙壁等。问曰。若然者。云何非檀越所作不唐捐其功。答曰。以他见故。若彼不修功不现。修功则现。问曰。云何不有方所。答曰。若有方所。复有何过。云何非是常耶。答曰。以有刹那无常故。何故不现耶。答曰。若未为五识身作境界则不现。若已作则现。评曰。应作是说。现在者是积聚。未来过去者。散在处处。所以者何。在法数中故。问曰。若然者。云何说有过去。答曰。说过去。如本现在时。云何说有未来。答曰。如未来当现在时。云何宿命智愿智境界过去。答曰。如其所更故。譬如曾所更字。次第立句。以显明义。如是彼次第念曾所更事。生于智见。云何愿智境界未来。答曰。如过去现在比相故知。犹如农夫。以比相故知。云何非本无今有已有还无。答曰。此则不能通。萨婆多中。有四种论师。一说事异。二说相异。三说时异。四说异异。说事异者言。法行世时事异体不异。譬如金银器。破已更作。虽形有异。其色不异。亦如乳成酪时。香味虽异。其色不异。如是未来法。至现在时。虽舍未来法。不舍其体。现在法至过去时。虽舍现在法。不舍其体。说相异者言。法行世时。过去法。有过去相。非不有未来现在相。未来法有未来相。非不有过去现在相。现在法有现在相。非不有过去未来相。如人爱一女色。于余女色。非不有爱。彼亦如是。说时异者言。法行世时。以时异故。生于异名。非其体异。譬如算筹。初下名一。一转名十。复转名百。如是至千万。算筹是一。转其处故。有种种名。彼亦如是。如是说世者。名不娆乱。说以所作故。便有三世。若法未有所作名未来。已作名现在。所作已灭名过去。说异异者言。法行世时。以前后故生异名。犹如一女。亦名为女。亦名为母。以其有母故名女。以其有女故名母。如是法行世时。以前后生于异非时异体异。如是说者。则名娆乱。所以者何。一世则有三世。过去世有三世。过去前后二刹那。名过去未来过去中刹那。名过去现在未来世亦如是。问曰。何者是。萨婆多中四大论师。第一名达摩多罗。第二名瞿沙。第三名和须蜜第四名佛陀提婆

三法。善法不善法无记法。云何善法。答曰。善五阴。及数灭。云何不善法。答曰。不善五阴。云何无记法。答曰。无记五阴。及虚空非数灭。何故名善不善无记。广说如不善品中

三法。欲界系法色界系法无色界系法。云何欲界系法。答曰。欲界系五阴。云何色界系法。答曰。色界系五阴。云何无色界系法。答曰。无色界系四阴。何故名欲界系色界系无色界系法。广说如上

三法。学法无学法非学非无学法。云何学法。答曰。学五阴。云何无学法。答曰。无学五阴。云何非学非无学法。答曰。有漏五阴及无为。何故名学无学非学非无学。答曰。以无贪道学断贪故名学。以无贪道不学断贪名无学。所以者何。先已学故。与此相违。名非学非无学。无恚无痴。说亦如是。复次以无爱道学断爱。彼非爱体是学。以无爱道学断爱。则遮无学道。体非爱者。则遮世俗道。以无爱道不学断爱先已学故。体非是爱是无学。以无爱道。不学断爱。则遮道体非是爱则遮世俗道。与此相违。是非学非无学。复次学断烦恼学见真谛是学不学断烦恼先已断故不学。见真谛先已见故是无学。与此相违。是非学非无学。复次学断二求。谓欲求有求。学断二求。欲满一求。谓梵行。求是学不学。断二求。先已断故不学。满一求先已满故是无学。与此相违。是非学非无学。复次若身中有烦恼得。亦有无漏法可得。学断烦恼是学。若身中无烦恼得。有无漏法可得。不学断烦恼是无学。与此相违。是非学非无学。复次不离爱有无漏法可得。学断爱。是学。已离爱有无漏法可得。不学断爱。是无学。与此相违。是非学非无学。复次见道修道所摄是学。无学道所摄是无学。三地三根说亦如是。复次若无漏法。若五种人身中可得者是学。五种人者。谓坚信坚法信解脱见到身证是学。若无漏法二种人身中可得是无学。二种人者。谓时解脱不时解脱。与此相违。是非学非无学。复次若无漏法七人身中可得。是学。七人者。谓四向住三果人。若无漏法一人身中可得。是无学。一人者。谓住一果人。与此相违。是非学非无学。复次若无漏法十八人身中可得是学。若无漏法无学人身中可得是无学。与此相违。是非学非无学三法。见道断法修道断法无断法。云何见道断法。答曰。若法坚信坚法行诸忍断。彼是何耶。答曰。见道所断八十八使。及相应法。从彼起共生法。是名见道所断法。云何修道断法。答曰。若法学见迹。以修道断。彼是何耶。答曰。修道所断十使。及彼相应法。从彼生身口业共生法。不染污有漏法。是名修道断法。云何不断法。答曰。无漏法。问曰。何故名见道断修道断无断法。答曰。广说如上

四谛。苦谛集谛灭谛道谛。问曰。何故作此论。答曰。此是佛经。佛经说四谛。苦谛乃至道谛。佛经虽说四谛。而不广分别。佛经是此论所为根本。今欲具分别故。而作此论。问曰。谛体性是何。答曰。阿毗昙者。作如是说。五取阴是苦谛。有漏因是集谛。数灭是灭谛。学无学法是道谛。譬喻者作如是说。名色是苦谛。烦恼业是集谛。烦恼业尽是灭谛。定慧是道谛。毗婆阇婆提。作如是说。八苦相是苦是苦谛。余有漏法是苦非苦谛。生后有爱是集是集谛。余爱余有漏法是集非集谛。生后有爱尽是灭是灭谛。余爱余有漏法尽是灭非灭谛。学八道支是道是道谛。余学法一切无学法。是道非道谛。若如所说。阿罗汉则成就二谛。谓苦谛灭谛。不成就集谛。所以者何。生后有爱是集谛阿罗汉。生后有爱已断故。不成就道谛。所以者何。彼说学八道支是道谛。阿罗汉得果时已舍故。尊者瞿沙说曰。若是自身阴。若是他身阴。若是众生数。若非众生数。如是皆是苦是苦谛。行者见苦时。自见身苦。非他身苦。非非众生数。所以者何。逼切义是苦义。他身苦非众生数。不逼切故。以是事故。生智论作如是说。自身中苦逼切。非他身中苦。非不因自身他身然后逼切。若无自身者。他身及非众生数苦。何所逼切。若自身中苦因。他身中众生数非众生数苦因。是集是集谛。行者见集时。见自身苦因。不见他身苦因。不见非非众生数苦因。若自身中苦尽。若他身中苦尽。众生数非众生数苦尽。是灭是灭谛。行者见灭时。见自身中灭。非他身灭。非非众生数灭。若自身对治。若他身。若众生数。非众生数对治。是道是道谛。行者见道时。见自身对治道。非他身非非众生数对治道。阿毗昙者。作如是说。若自身苦。若他身苦。若众生数非众生数苦。行者见苦时。尽见如是苦。问曰。行者见苦时。见逼切苦。他身中苦。非众生数苦非逼切。行者见苦时。何故见耶。答曰。彼苦虽非逼切。而是所愚处。应生于智。而是犹豫处应生决定。而是诽谤处。应生信敬。谁作是说。他身中苦。非众生数苦。非逼切耶。若为他人所打。非逼切耶。若空中木石。堕其身上。非逼切耶。若自身阴因。若他身阴因。若众生数非众生数阴因。尽是集是集谛。行者见集时。尽见是集。若自身苦尽。若他身。若众生数非众生数苦尽。是灭是灭谛。行者见灭时。尽见是灭。若自身阴对治。若他身。若众生数非众生数阴对治尽。是道是道谛。行者见道时尽见是道。此是谛体性。乃至广说。已说体性。所以今当说。何故名谛。谛是何义。答曰。实义是谛义。审义如义不颠倒义不异义。是谛义。问曰。若实义审义如义不颠倒义不异义是谛义者。虚空非数灭亦是实义。乃至是不异义。何故不立谛耶。答曰。若法是苦是苦因是苦尽是苦对治者立谛。虚空非数灭。非苦非苦因。非苦尽。非苦对治。故不立谛。如苦阴病痈箭过患重担。说亦如是。复次若法如此岸彼岸河筏者立谛。虚空非数灭。非此岸彼岸河筏。故不立谛。复次若法是苦是苦因。是道是道果者立谛。虚空非数灭。与上相违。故不立谛。复次若法有因有果故立谛。虚空非数灭。无因果故不立谛。复次虚空非数灭。无漏故非苦集谛。无记故非灭谛。无为故非道谛。复次此法不行世故。不立三谛。无记故不立灭谛。复次此法非阴故不立三谛。非善故不立灭谛。复次此法不与苦相随故不立三谛。非善故不立灭谛。复次若法为邪见无漏正见所缘立谛。此法非邪见无漏正见所缘故不立谛。复次若法为无明明所缘者立谛。此法不为无明明所缘故不立谛。复次若法体是烦恼出要者立谛。此法非烦恼出要故不立谛。复次若法能生厌离随喜者立谛。此法不能生厌离随喜故不立谛。问曰。若不颠倒义是谛义者。颠倒不应为谛所摄。所以者何。体是颠倒故。答曰。以余事故立颠倒。以余事故。为谛所摄。以三事故立颠倒。一者转行。以猛利故。二者虚妄。三者一向是颠倒。以此法实有体性故。为谛所摄。复次无常计常。无乐计乐。不净计净。无我计我。故是颠倒。此法有因有果故。为谛所摄。问曰。若不异义是谛义者。妄语不应为谛所摄。所以者何。妄语欲诳他作异语故。答曰。以余事故立妄语。以余事故。为谛所摄。以异语诳他故立妄语。有实体性故。为谛所摄。复次不见言见。不闻言闻。不知言知。不识言识。故立妄语。此法有因有果故。为谛所摄。是故实义是谛义。乃至广说

问曰。云何立四谛。为以体性。为以因果。为以见时。若以体性。则有三谛。所以者何。离苦无集。离集无苦。灭是第二谛。道是第三谛。若以因果。应有五谛。苦亦可言因。亦可言果。道亦可言因。亦可言果。灭是第五若以见时。应有八谛。行者先见欲界苦。后见色无色界。先见欲界诸行因缘。后见色无色界。先见欲界诸行灭。后见色无色界。先见欲界诸行对治道。后见色无色界。答曰。应作是说。以因果故立谛。问曰。若然者。应有五谛。答曰。以总说故无五谛道。若因若果。总名苦灭道。总名尽生老病死道。问曰。苦若因若果。亦是苦集道。亦是生老病死道。答曰。以所行异故。苦有果义者行四行。谓苦空无常无我。苦有因义者行四行。谓因集有缘。道亦有因义。亦有果果义者。尽行一种四行。谓道如迹乘。复次以三事故立四谛。一以体性。二以因果。三以诽谤生信。以体性者。四谛体性。是有漏无漏。以因果者。有漏体性。有因有果。有果者是苦谛。有因者是集谛。无漏体性。亦有因有果。亦有果无因。有因有果者是道谛。有果无因者是灭谛。问曰。何故有漏体性。有果者立一谛。有因者立一谛。无漏体性。有因有果。立一谛耶。答曰。以诽谤生信故有漏体性生二种诽谤言无苦无集。生二种信。言有苦集道。若因若果。生一种诽谤。言无有道。生一种信。言有道。以此三事故立四谛。复次以见谛时故。立四真谛。问曰。若然者。应有八谛。答曰。若欲界苦。若色无色界苦。见苦时。总是苦等四行。若欲界行因。色无色界行因。见集时。总是集等四行。若欲界行灭。色无色界行灭。见灭时。总是灭等四行。若欲界行对治。色无色界行对治。见道时。总是道等四行。是故见谛时总行故。唯有四谛。无八谛

问曰。苦集灭道有何相。尊者波奢说曰。逼切相是苦相。有相是集相。寂静相是灭相。乘相是道相。尊者和须蜜说曰。转相是苦相。能转相是集相。止相是灭相。住转相是道相。复次转有身是苦相。能转有身是集相。转有身尽是灭相。往转有身是道相。尊者佛陀提婆说曰。物体作谛。名五取阴。体如热铁。久共火合。与火同色。三苦与五取阴合。亦复如是。是苦谛苦。从烦恼生业。能回转。是集谛。烦恼业坏。更不受有。是灭谛。修戒修定。以慧观生灭。能断有因。是道谛。佛经说偈

  一谛无有二　　众生于此疑
  种种说诸谛　　不说有沙门

问曰。有四谛。何故说一谛。尊者波奢说曰。一谛者谓苦谛。无第二苦谛。一集谛无第二集谛。一灭谛无第二灭谛。一道谛无第二道谛。复次一谛者谓灭谛。为对种种解脱故。外道计种种解脱。无身解脱。无边意解脱。净聚解脱。世俗解脱。无身解脱是空处。无边意解脱是识处。净聚解脱是无所有处。世俗解脱是非想非非想处。佛作是说。此是受身处。非是解脱。真解脱者。唯一灭尽涅槃。复次一谛者谓道谛。为对种种道故。外道计多种道。谓不食道。卧灰上道。事日月道。食风食果道。裸形道。卧刺蕀道。着弊衣道。佛作是说。此非是道。此是邪道。非善人所依道。真实道者。谓八圣道。复次一谛者谓灭谛。以能尽身苦故。一谛谓道谛。能尽恶道苦故

佛经说二谛。谓世谛第一义谛。问曰。云何是世谛。云何是第一义谛耶。答曰。或有说者。二谛是世谛谓苦谛。集谛。所以者何。世法在此二谛中故。如男女行来现在所作事。悉在彼中。二谛是第一义谛。谓灭谛道谛。复有说者。三谛是世谛。谓苦集灭谛。所以者何。灭谛佛说是假名彼岸城故。一谛是第一义谛谓道谛。复有说者。道谛亦是世谛。所以者何。佛说道谛。亦是假名。如沙门婆罗门。评曰。应作是说。四谛亦是世谛。亦是第一义谛。苦集谛是世谛者。如先所说。第一义谛者。如苦空无常无我因集有缘是也。灭谛说是世谛者。佛说灭谛。如城如园林。第一义谛者。尽止妙离。道谛是世谛者。佛说道谛如筏如石如山如华如水如梯如楼观。第一义谛者。道如迹乘。若作是说。四谛尽是世谛。第一义谛者。则一切法。尽有世谛第一义谛。世谛摄十八界十二入五阴。第一义谛。亦摄十八界十二入五阴。问曰。世谛中。为有第一义谛不。若有第一义谛者。便是第一义谛。无有世谛。若无者。亦是一谛。谓第一义谛。答曰。应作是说。世谛中。有第一义谛。若世谛中。无第一义谛者。如来说二谛。则不如其实。以如来说二谛。如其实故。世谛中应有第一义谛。问曰。若然者。便有一谛。谓第一义谛。答曰。如是唯有一谛。谓第一义谛。问曰。若然者。佛何故说二谛。答曰。以事故。不以体分。唯有一谛谓第一义谛。以事故而有差别。若以事故。名为世谛。不以此事名第一义谛。若以事故。名第一义谛。不以此事名为世谛。犹如一受。有四缘性。谓因次第境界威势缘。若因事故。名为因缘。不以此事故。乃至名威势缘。若以事故。名威势缘。不以此事故。乃至名因缘。又一受有六因性。谓相应共生相似一切遍报所作因。若以事故。名相应因。不以此事。乃至名所作因。若以事故。名所作因。不以此事。乃至名相应因彼亦如是。问曰。世谛第一义谛。为可得施设别体不。杂合耶。答曰。可得尊者和须蜜说曰。名是世谛。名所显义。是第一义谛。复次随顺世间所说名。是世谛。随顺贤圣所说名。是第一义谛。尊者佛陀提婆说曰。若说众生。如其所念相应之言。是名世谛。若说缘起等法如其所念相应之言。是名第一义谛。尊者陀罗达多说曰。世谛体相。是名苦集谛少分

佛经说。婆罗门梵志有三谛。是婆罗门梵志谛。云何为三。婆罗门梵志。作如是说。不应害众生。如是说者。此言是实。是名婆罗门梵志初谛。婆罗门梵志。复作是说。我非彼所有。彼非我所有。如是说者。此言是实。是名婆罗门梵志第二谛。婆罗门梵志。复作是说。所有集法。皆是灭法。如是说者。此言是实。是名婆罗门梵志第三谛。问曰。此中何者是婆罗门。何者是谛。答曰。佛法外道。是婆罗门。向所说三谛。是名谛。余悉非谛。不害众生者。不杀一切众生。我非彼所有彼非我所有者。我不属彼。彼不属我。所有集法悉是灭法者。所有生法。皆当归灭。复有说者。此佛法内。名婆罗门谛者。向所说三谛。佛为对外道故说此经。外道自言是婆罗门。而逼切他。所以者何。为祠祀故。杀牛羊水牛及余种种众生。佛作是说。若逼切众生。不名婆罗门。实义婆罗门者。谓不恼害一切众生。外道自言。是婆罗门。为天女色故。而修梵行。佛作是说。婆罗门者。不应为天女色而修梵行。实义婆罗门。不为女色。不为居家。无所染着。外道自言。是婆罗门。而贪着断常见。佛作是说。婆罗门者。不应贪着断常。若知集法即是灭法。是实义婆罗门。复次此经说。三解脱门方便。不害一切众生。是空解脱门方便。我非彼所有彼非我所有。是说无作解脱门方便。所有集法悉是灭法。是说无相解脱门方便。如三解脱门。三三昧。三种身。三学。三修。三净说亦如是

佛经说比丘当知。观察四方者是四谛。问曰。世尊何故说方名谛。答曰。为教化故。受化者应闻谛以方名说然后悟解。如余经中说。佛为受化者。说解脱门名方。受化者应闻解脱门以方名说。佛便以方名说解脱门。彼亦如是。问曰。四谛四方。有何相似。答曰。俱是法。方亦有四。谛亦有四。问曰。何方与何谛相似。答曰。东方当知如苦谛。西方如集谛。如行者见谛时。前见苦谛。后见集谛。复有说者。东方是集谛。西方是苦谛。是因果法。前因后果故。南方如道谛。所以者何。道谛是福田故。北方如灭谛。灭谛无有上故

佛经说慧根当知在四谛中。问曰。为以摄故言在中。为以缘故言在中。若以摄故言在中者。慧根不摄四谛。四谛不摄慧根。若以缘者。慧能缘一切法。答曰。应作是说。不以摄故。亦不以缘故。言在中。以慧根分别谛时。势用最胜。说言在中。如信根于四不坏。信势用胜故。佛作是说。信根当知。在四不坏中。如精进根。于四正断中。势用胜故。佛作是说。精进根当知在四正断中。念根于四念处。势用胜故。佛作是说。念根当知在四念处中。定根于四禅中。势用胜故。佛作是说。定根当知在四禅中。复有说者。以缘故作如是说。问曰。若然者慧缘一切法。答曰。此中说缘有漏无漏慧。缘虚空非数灭慧。一向有漏故说缘

尊者舍利弗作如是言。诸长老当知。所有一切善法。皆从四谛生。四谛所摄。在四谛中。问曰。如三谛是有为。能生善法可尔。灭谛是无为。云何能生善法耶。答曰。虽不能生善法。能摄善法。复次生有二种。一有善法。二生善法。灭谛虽不生善法。而是有善法。复次此中说得生。灭谛虽不生善法。而灭谛得善法生。尊者波奢说曰。此中说忍及知缘在缘中。苦忍苦智。道谛所摄。缘在苦谛。集忍集智。道谛所摄。缘在集谛。灭忍灭智。道谛所摄。缘在灭谛。道忍道智。道谛所摄。缘在道谛

佛经说如来等正觉。随宜说法。皆为拔济众生令在胜处。亦为分别显现解说四圣谛法。云何为四。谓苦圣谛。苦集圣谛。苦灭圣谛。苦灭道圣谛。问曰。何故言拔济。答曰。自拔济非以他修道故名拔济。何以知之。答曰。经说。有婆罗门。名度得迦。往诣佛所。而说是偈

  今见婆罗门　　现行在人间
  我今礼遍眼　　愿脱我狐疑

问曰。此偈为说何事。答曰。彼婆罗门。其性懒堕。欲令他人修道断烦恼。是故向佛。作如是爱语。汝实是天。而生人间。愿见矜愍。汝为我故。而修圣道。断我烦恼。佛即说此偈

  我无自在力　　能断汝狐疑
  汝见胜法时　　乃得度大流

佛作是说。婆罗门当知。有他人修道自断烦恼。若当他人修道自断烦恼者。我初在菩提树下修道之时。一切众生烦恼应断。所以者何。我有大悲心。普及一切众生故。但他人修道。自断烦恼。无有是事。若自修道。自断烦恼。可有是事。犹如他人服药自除其病。无有是事。若自服药。自除其病。斯有是事。是故自拔济。名为拔济。不以他修道故。而得拔济。复次言拔济者。如高山崄谷是可畏处。凡夫法亦如是。平坦地无可畏处。圣法亦如是。能拔凡夫高山崄谷可畏之处。安置圣法平坦之地无可畏处。故言拔济。复次等入正法中故言拔济。等者是世第一法。入正法中者。是苦法忍。问曰。何故说谛名拔济。说阴界入。不名拔济耶。答曰。以观谛时。得正决定。能得果。离欲尽漏。复次说谛是胜说。亦为胜受化者说。以近生法。身近得谛故说。界为初行者说。入为已行者说。阴为久行者

问曰。言圣谛者。为以善圣故言圣。为以无漏圣故言圣。为以圣人成就故言圣。若以善圣言圣谛者。二是善谓灭道。二有二种谓苦集。若以无漏圣言圣谛者。二谛是有漏。二谛是无漏。若以圣人成就言圣谛者。非圣亦成就如说谁成就苦集谛。答曰。一切众生。答曰应作是说。圣人成就故言圣。问曰。若然者非圣亦成就谛。答曰。言成就者。成就四谛。凡夫虽成就谛。不具四谛。问曰。圣人亦有不具成就四谛者。如具缚人。入见道。苦法忍现在前。答曰。以时少故。若苦法智生具成就四。复次圣人中有具成就四谛者。凡夫中乃至无有一人具成就四谛者。尊者僧伽婆修说曰。佛在世时。凡夫圣人。共论此事。凡夫人作如是说。诸行是常乐我净。圣人作如是说诸行是无常苦空无我。凡夫人言我所说是实。圣人亦言我所说是实。以是事故。共诣佛所。佛作是言。圣所说是实。所以者何。圣谛是圣人所知见法。是故名圣谛。复次若身中有圣法印者。彼所有谛。名为圣谛。复次若得圣戒。名为圣人。彼所有谛。名为圣谛。复次若得圣慧。名为圣人。彼所有谛。名为圣谛。复次若得圣舍摩他毗婆舍那。名为圣人。广说如上。复次若得圣财。名为圣人。广说如上。复次若得圣觉支。名为圣人。广说如上。复次若得圣胎名为圣人。广说如上

云何苦圣谛。佛经说生苦。老苦。病苦。死苦。不爱会苦。爱别离苦。求不得苦。略说五取阴是苦。生相故是生苦。住变异相故是老苦。逼切相故是病苦。尽相故是死苦。不爱相共会故是不爱会苦。相别离故是爱别离苦。不得自在故是求不得苦。如是等诸苦。皆是有漏五取阴所摄。是故略而言之五取阴苦。复次生是一切苦。立足处一切苦因故名生苦。坏可爱盛年故是老苦。坏不爱无病故是病苦。坏不爱命故是死苦。共不可爱境界会故是不爱会苦。与可爱境界别离故是爱别离苦。一切意所念不果故是求不得苦。如是等诸苦。是有漏取阴所摄。故作是说。略说五取阴是苦。问曰。五取阴是广苦。何故言略说五取阴是苦。答曰。五取阴广亦是苦。略亦是苦。住五取阴。多诸过患。说不可尽。是故佛说略而言之。五取阴是苦。犹如有人。多诸过恶。人作是言。此人过恶。不可具说。略而言之。多过恶人。彼亦如是。问曰。阴中为有乐不耶。若阴中有乐者。何以不言乐谛。但言苦谛。若无者。佛经云何通。如说摩诃男。若色一向是苦无乐。不能生喜乐意。众生则更无余因。能令众生起于爱心。摩诃男色非一向苦故。众生于中起染爱心。乃至识亦如是。又如说三受各有定体。不相杂合。谓苦乐不苦不乐。又如说以所须具。能修于道。以道能到涅槃。以道乐能得涅槃乐。答曰。应作是说。阴中有乐。而乐少苦多。乐法少。苦法多。以乐少故。说在苦分中。譬如毒瓶。一渧蜜堕中。不以一渧蜜故名为蜜瓶。以毒多故名为毒瓶。彼亦如是。复有说者。阴中无乐。以是事故名为苦谛不名乐谛

问曰。若然者佛经云何通。答曰。受上苦时。于中苦作乐想。受中苦时。于下苦作乐想。受地狱苦时。以畜生苦作乐想。受畜生苦时。以饿鬼苦作乐想。受饿鬼苦时。以人苦作乐想。受人苦时。以天苦作乐想。复有说者。如世人所言。阴中有乐。世人饥得饮食。寒时得温。疲时得乘热时得凉。作如是说。我今得乐。如圣人言。阴中无乐。圣人观阿鼻地狱阴界入。如热铁丸。乃至观有顶阴界入。亦如热铁丸

云何苦集圣谛。佛经说生后有爱及喜心俱爱处处喜爱。是名苦集圣谛。问曰。世尊何故舍诸有漏法。但说爱是集谛。非余法耶。答曰。施设集谛。爱增益势用胜。是故佛唯说爱是集谛。非余有漏法。如思于造作法增益势用胜故。佛于一切相应不相应法中。说思是行阴。彼亦如是。复次以爱是过去未来现在苦因根本出处起处因故。复次以爱数数生苦势用胜故。如偈说

  如树不拔根　　虽断而复生
  不拔爱使本　　数数还受苦

复次爱能润泽。亦能烧害。犹如热油渧人身上亦润亦烧。彼亦如是。复次以爱能起受生死尸鬼故。譬如有水处能起死尸鬼。如是有爱水处。能起受生死尸鬼。复次以爱故。爱畜众生数非众生数物。众生以爱故。畜众生数物。谓妻子奴婢。及诸僮仆。象马牛羊等。众生数物。众生以爱故。畜非众生数物。谓宫殿屋舍。种种财宝。及种种谷麦。复次众生以爱故。长养男身女身。众生以爱故。如法供养父母妻子奴婢及诸亲属知识。如鸟以爱故。于一谷中。接取诸虫。于一谷中。自养其子。复次以爱欲故。得未来有身。以欲故追求故得。复次以爱润故。令生死不萎枯。譬如药果树木。以水润故。而不萎枯。彼亦如是。复次以爱润故。后有牙生。以爱故父母精气。在母胎中。为揵闼婆作所依。复次如爱行所依所缘故而生。余烦恼行所依所缘亦生。如大鱼去处小鱼亦随。彼亦如是。以是事故。说爱众生烦恼王。复次若身中有爱着。余烦恼亦着。如衣腻尘垢亦着。彼亦如是。复次若身中有爱水。诸烦恼则乐着此身。譬如有水处鱼等水性则生乐着。彼亦如是。复次爱如碱水难可止足。犹如渴人饮于碱水。饮已转渴。如是未离欲众生得于境界。转生渴爱。复次以爱故。别异众生能令合会。如以水故能令别异土沙而得合会。彼亦如是。复次以爱故。能令众生善根不熟。亦作润湿。令自身相着。譬如蝇着酥油蜜湿草之上则不能飞腾虚空。彼亦如是。复次爱因时所行异。果时所行异。因时所行如亲爱。果时所行如怨家。犹如商人入海与罗刹交。初所行异。后所行异。初作是言。善来贤善。善来大仙愿为我等作主。乃至广说。后若交会。得其意时。掷铁城中。食其血肉。唯有余骨。爱亦如是。因时所行犹如亲爱。果时所行犹如怨家。众生以爱故。造诸恶业。堕恶趣中。受无量苦。复次爱说是受生因。如说业是取生因。爱是受生因。复次爱难断难却。此中应说喻。如有人。为二罗刹所持。一作母形。二作怨形。作母形者。难除难却。作怨形者。易除易却。如是未离欲众生。为二结所因。谓恚结。爱结。恚结易断易却。爱结难断难却。复次以爱结数数微细行。爱行时微细。难可识知。譬如旋师所用利器。有所截断。微细难觉。彼亦如是。复次以爱在三有枝中。初生是爱。增广是取。前次第灭是无明。复次佛经说。爱是前导。如说阿难当知。缘爱故有追求。缘追求故得。缘得故分处。缘分处故生偏爱。缘偏爱故生贪着。缘贪着故生悭。缘悭故受不舍。缘受不舍故生守护。缘守护持刀执杖。生种种斗诤。欺诳妄语。生余种种恶不善法。复次以爱于八处染污定势用胜故。如说味初禅。住时亦味。起时亦味。乃至非想非非想处亦如是。复次佛说爱如缚。如偈说爱系缚众生。如绳系飞鸟。乃至广说。复次佛说爱如网。如说我说爱如网如枝。复次佛说爱是广。如说广无过于爱渴。复次爱说如河。如说比丘当知。三河者谓欲爱色爱无色爱。复次爱难断难过难除故。复次爱多诸过患故。复次以爱故。有界差别地差别种差别。能生一切烦恼。以如是等事故。佛经说爱是集谛。非余有漏法

云何苦灭圣谛。答曰。佛经说生后有爱。及喜心俱爱。处处喜爱。已吐已舍尽无余。是名苦灭圣谛。问曰。集亦灭。何故但说苦灭圣谛。不说集灭圣谛。答曰。应说集灭圣谛。亦应说苦灭圣谛。而不说者。当知此说有余。复次若说苦灭。当知已说集灭。所以者何。苦外更无有集若说苦灭当知已说集灭。复次若说苦灭。受化者。则生喜心。言是灭妙好能灭此弊恶。苦集法不尔。以如是等事故。但说苦灭。不说集灭

云何苦灭道圣谛。答曰。佛经说八圣道是也。正见乃至正定。问曰。此亦是集灭道不。但是苦灭道。何故但说苦灭道。不说集灭道耶。答曰。如说苦灭道圣谛。亦应说集灭道圣谛。而不说者。当知此说有余。复次若说苦灭道圣谛。当知已说集灭道圣谛。所以者何。苦外更无集故。复次若说苦灭道圣谛。受化者则生喜心。言是道妙好能灭此弊恶。苦集法不尔。复次欲现道力令苦不生故。设有人问道。汝能令因非因果非果耶。彼当答言不能。但能令生苦因缘者不生。复次为止诽谤道故。若人年七岁八岁。得阿罗汉道。后寿百年。于其中间身受无量诸苦。如是四百四病等。世人见之。而作是言。此人有道。为无所益。受苦若此。佛作是言。道已于此人。大有所作。此人若身坏命终。更不受诸苦。以如是等事故。说苦灭道圣谛。不说集灭道圣谛

阿毗昙毗婆沙论卷第四十阿毗昙毗婆沙论卷第四十一

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    使犍度十门品第四之五

问曰。世尊何故先说苦谛。乃至后说道谛。答曰。欲令文义随顺故若先说苦谛。后乃至说道谛。则文义随顺。复次若如是说谛。则说者亦易。受者亦易。复次此诸法。或以起处得名。或以随义得名。或以见时得名。以起处得名者。如念处禅无色定等行者。先修身念处。佛先说身念处。后乃至说法念处禅无色定。广说亦尔。随义得名者。如正断神足根力觉道等。见时得名者。如四圣谛行者。先见苦谛。佛先说苦谛。后乃至见道谛。佛后说道谛。问曰。此中因论生论。行者何故先见苦谛。后乃至见道谛。答曰。以粗细故。四谛中苦谛最粗。以苦粗故。行者先见三谛。细故行者后见。如索迦人蛇摩那人兜佉罗人学射之时。先射簸箕草人湿泥团等。箭矢无不着。后渐更学。乃至射一毛。彼亦如是。问曰。应先因后果何故行者先见苦果。后见集因。答曰。先见苦。后断集。是随顺法。云何知苦随顺断集耶。答曰。如树先断其枝后拔根易。如生死树。先知苦枝。后拔集根则易。问曰。道在前灭在后。何故行者先证灭。后修道。答曰。先灭修道。是则随顺。若当先修道后证灭者。不知此道为是谁道。若先证灭后修道者。乃知此道是灭道如人问他示我道处。他人问言。为问至何处道。答言欲至城道。他人答言。此道即是。如彼以城示道。则得随顺。此亦如是。以灭示道。则得随顺。复次行者先以道断缘三谛愚。后起缘道现在前断缘道愚。如人于他面无疑。于自面有疑。若以明镜。照自面像。疑心则除。彼亦如是。复次缘苦愚持缘集愚。缘集愚持缘灭愚。缘灭愚持缘道愚。不得不除缘苦愚。除缘集愚。不得不除缘集愚除缘灭愚。不得不除缘灭愚。除缘道愚。如持生亦如是。复次观苦观能生观集观。观集观能生观灭观。观灭观能生观道观。不可不生观苦观。乃至能生观道观复次观苦观是集观因。是根本是出处是所作。是缘是起处。集观是灭观因。等灭观是道观因等。不可不生观苦观。乃至生观道观。复次观苦观是观集观。方便是门是所依。乃至灭观是观道观。方便是门是所依。余广说如上。复次观苦观。是观集观所依处立足处。乃至观灭观。是观道观所依处立足处。余广说如上。尊者波奢说曰行者先知五取阴如痈。后求其因知集是因。何处能除此因。灭处能除。唯能灭耶。道能灭之。如身体细软之人。色生痈疮受大苦恼。作如是念。此疮何由而生。知从风冷热生。何处能令无此。谓无病处。谁能除此。谓若涂若熟若破。彼亦如是。复次行者知此五取阴是过患。谁是其因。集是其因。何处得除。灭处得除。谁能除之。道能除之。如人有子。作贼行恶。亲近恶友。彼人作是念。谁令我子。作如是恶。知亲恶友。谁能除制。知是善友。彼亦如是

彼见苦时。先见欲界苦。后见色无色界苦。问曰。何故行者先见欲界苦后见色无色界苦耶。答曰。以粗细故。欲界苦粗。色无色界苦细。行者先见欲界粗苦。后见色无色界细苦。问曰。若然者色界苦粗。无色界苦细。何故一时见耶。答曰。以与此身俱不俱故。欲界苦与身俱。色无色界苦。虽有粗细而不与此身俱。故一时见。复次欲界苦。属我是我有。色无色界苦。不属我。不是我有。是故俱见。复次欲界苦。苦痛逼切。如负重担。是以先见色无色界苦。非苦痛逼切。如重担故。是以俱见。复次欲界苦。是近故先见。色无色界苦。是远故俱见。如近远俱不俱。此身他身说亦如是。问曰。行者于色无色界苦为现见不。答曰。现见有二种。一离欲现见。二自身现见。行者于欲界苦。有二种现见。谓自身现见。离欲现见。于色无色界苦。虽有离欲现见。而无自身现见。譬如贾客。有财两担。一自身担。二使他担。于自身担者。有二种现见。一知财现见。二知重现见。于他担者。有一种现见。谓知财现见。复次见欲界苦。是善不善无记。是以先见。色无色界苦。是善无记。是故俱见。复次行者成就欲界凡夫性。是以先见。不成就色无色界凡夫性。是故俱见。复次诽谤时。先谤无欲界苦。是以先于欲界苦生信。后诽谤色无色界苦。是以后生信

问曰。见谛时。为别相见。为总相见。若以别相者。别相有无量。见谛则无竟已。如地有无量别相。若观地别相。不能令尽。而便命终。若以总相者。云何不名一时见谛。别相诸法复云何知。答曰。应作是说。以总相见谛。问曰。若然者云何不名一时见谛。答曰。以总相者。于一谛总相。非四谛总相。为少分相故。分别无量。总相别相。如地有总相。以三大故。地是别相。一切地。皆是坚相是总相。四大是色阴。色阴有总相别相。别相者以四阴故。总相者一切色皆是障碍。五取阴是苦谛。苦谛有别相总相。别相者以三谛故。总相者一切苦。皆是逼切相。以如是总相见谛。以无常苦空无我行见谛。以苦谛故是总相。以余三谛故是别相。以谛故是别相。以阴故是总相。复次一谛非四谛。四谛非一谛。是故不一时见谛。复次一行非四行。四行非一行。是故不一时见谛。复次以觉所觉分明了了故。根根义所境界境界。亦分明了了故。不一时见谛。复次以有漏无漏别故。不一时见谛。复次以有为无为差别故。不一时见谛。复次苦谛不一时见。先见欲界苦。后见色无色界苦。先见欲界诸行因。后见色无色界诸行因。先见欲界诸行灭。后见色无色界诸行灭。先见欲界对治道。后见色无色界对治道。是故非一时见谛。云何知别相法耶。答曰。见谛时不知别相法。一切别相。智所应知者。尽以总相智知。复次若缘谛别相无知。若缘谛总相无知。一时断故。是故总相见谛时。亦知别相所知

佛经说未知苦圣谛。当知阿毗昙说。云何智所知法。答曰。一切法。问曰。一切诸法。是智所知。如阿毗昙说。佛经何故但说知苦耶。答曰。佛经说知苦是出世间智。阿毗昙说。知一切法。是世间出世间智。如世间出世间。有漏无漏缚解系不系。当知亦如是。复次佛经说。知苦是近智。阿毗昙说。知一切法。是近智远智。如近远俱不俱。当知亦如是。复次以总相知故。佛说知苦。以总相别相知故。阿毗昙说知一切法。如总相知。别相知。总相解。别相解。总相观。别相观。当知亦尔。复次佛经说不共智。阿毗昙说共不共智。复次佛经说见苦时。阿毗昙说观行时。复次解有二种。一者假名。二者实义。佛经说假名解知苦。阿毗昙说实义知一切法。问曰。云何假名解。答曰。现见苦是知果。现见集是知因。证灭时知灭。有二功德不在身中。行修道时。为断一切烦恼道。以如是等总相解故。名假名解。尊者波奢说曰。佛经说当知苦。或谓但当知苦。更不知余。是故阿毗昙。作如是说。应知一切法。佛经说当断集。或谓但当断集更不断余。是故阿毗昙作如是说。云何断法。一切有漏法。佛经说当证灭。或谓但当证灭更不证余。是故阿毗昙作如是说。云何证法。答曰。一切善法。佛经说当修道。或谓但当修道更不修余。欲令此事决定故。阿毗昙作如是说。云何修法。答曰。善有为法。复次为断生死根本及道故。佛经说当知苦身见是六十二见根。六十二见是烦恼根。烦恼是业根。业是报根。依报故生善不善无记法。身见知苦时断。是故佛经唯说知苦。复次若知苦时。断五我见十五我所见。是故佛经唯说知苦。复次知苦时断二见谓身见边见。得二三昧。谓空无愿。是故佛经唯说知苦。复次无始已来。众生于阴中。计我想人想念想。谁能断此恶想使住善想。唯知苦能。是故佛经唯说知苦。复次众生无始已来。于此无常无我无乐无净阴中。计有常我乐净。谁能断如是颠倒。唯有知苦。是故佛经唯说知苦。复次为断贪着阴者故。众生无始已来为此阴受苦痛逼切。如负重担受是苦已。复追求阴。以追求故。复更生阴。犹如小儿为乳母所打还复归趣。彼亦如是。为苦所逼。还复归苦。是故佛经唯说知苦。复次行者见苦时。令无始已来谄曲之心邪见颠倒烦恼恶行皆令正直。是故佛经唯说知苦。复次若知苦时。亦名断苦。若断集时。不名知集。是故佛经唯说知苦。复次行者知苦时。住不颠倒想。无有是处。以分别故。说若行者知苦更不知余谛。若有人问。此阴为是常。是无常耶。答言无常。无一刹那住故。是苦是乐耶。答言是苦。如热铁丸。是净不净耶。答言不净。犹如粪秽。有我无我耶。答言中无有人。无作者受者。但是诸行粪秽之聚。复次苦如痈疮。常自困苦。如箭入身。如刀自割。如毒自杀。如火自烧。如怨自害。如住边城多受厄难。复次行者见苦时。名真佛出世间。如法入佛法。得无障碍。受行佛法。复次行者见苦时。舍旧缘得新缘。舍共得不共。舍世间得出世间。复次行者见苦时。未开无漏道门今开。未曾舍凡夫性今舍。未曾得圣道今得。复次行者见苦时。舍名得名。舍界得界。舍性得性。舍名得名者。舍凡夫名得圣人名。舍界得界者。舍凡夫界。得圣人界。舍性得性者。舍凡夫性。得圣人性。复次行者见苦时。得心不得心因。得业不得业因。得明不得明因。复次行者见苦时。得离五人聚入八人聚。五人聚者。谓五逆人。八人聚者。谓四向四果。复次行者见苦时。舍如树华凡夫性。得住如门阃圣性。复次行者见苦时。初得于法不坏信。复次行者见苦时。得无有是处法。如说无有是处。是见谛具足人。不故杀生。不故犯戒。乃至广说。以如是等事故。佛经唯说知苦。佛经说集圣谛应知应断。阿毗昙说。云何断法。谓有漏法。若作是说。生后有爱是。集圣谛者。则生是难。如阿毗昙说。云何断法。一切有漏法。何故佛经但说生彼有爱是集谛耶。答曰。前说爱。所以此中应广说。若作是说一切有漏因是集谛。则生是难。如苦亦应断。何故佛经但说断集。答曰。为不生苦故。佛作是说。汝等若不欲苦。应当断集。若断集者。苦则不生。复次为不生果故。佛作是说。若汝等不欲果者。应当断因。若断因者。果则不生。复次欲断苦流故。犹如水相续流。若不断其源。则水流不止。若断其源。水则不流。如是若不断苦源。苦流不止。若断苦源。苦流则止。复次若断集者。则断俱因。俱系得解。得无漏解脱得。断非想非非想处一切遍因。复次若断因者果亦断。因若灭果亦灭。舍因亦舍果。吐因亦吐果。复次为舍重担。如人身负重担上崄难处。为此重担之所逼切。他人语言。汝若为此重担所逼切者。应断其担索。若担索断。担自当堕。众生亦尔。身负阴担。上于生死险难之山。为此阴担之所逼切。佛作是说。汝等若不欲负阴担者。应断于集若断于集。阴担则堕。复次为对外道故。外道不欲苦果。而不断因。犹如愚狗舍人逐块。外道亦尔。不断苦因。不欲苦果。佛作是说。汝等若不欲苦果。当断其因。若断其因。苦则不生。复次集中已有三界上中下果。佛作是说。汝等若于三界上中下果。不欲求者。应当断集。若断集者。则三界上中下果。更不复生。复次以集能生三苦故。三苦者谓欲界色界无色界苦。佛作是说。汝等不欲三苦者。应当断集。广说如上。复次以集能生四苦故。四苦者谓四生。佛作是说。汝等若不欲四苦者。广说如上。复次以集能生五苦故。五苦者谓五趣。佛作是说。汝等若不欲五苦者。广说如上。以如是等事故。佛经说集应知应断

佛经说苦灭圣谛应知应证。阿毗昙说。云何得作证法。答曰。一切善法。问曰。如阿毗昙说一切善法应证。佛经何故唯说证灭。答曰。此灭是解脱。亦是不系相。复次此灭无处所。无有所依。复次此灭是因无果。是果无因。复次此灭是因非有因。是所作非有所作。是缘非有缘。是离非有离。是果非有果。复次此灭能令阴无非无法体。复次此灭息三摄四舍五。复次此灭是一味种种道果。净于四姓。名无上法。复次此灭是无漏。得是有漏无漏。灭是非学非无学。得是学无学非学非无学。灭是不系。得是系不系。灭是无断。得是修道断或不断。灭是灭谛摄。得是苦谛集谛道谛摄。复次此灭是善是常。是善离阴。是善无有上中下。是无前后际。复次此灭是沙门果非沙门。是婆罗门果非婆罗门。是梵行果非梵行。是道果非道。以如是等事故。佛经说应证灭。佛经说苦灭道圣谛应知应修。阿毗昙说。云何修法。答曰。一切有为善法。问曰。如阿毗昙说一切有为善法皆应修。何故佛经但说修道。答曰。以道应修应习故。复次以道有二种修故。一得修。二行修。世俗道有四种修。谓得修。行修。对治修。除去修。复次此道修时。不断缘爱。世俗道修时。断于缘爱。复次此道修时。其性出而不没。世俗道修时。其性亦出亦没。于欲界而出。于初禅而没。乃至于无所有处而出。于非想非非想处而没。问曰。无漏道亦尔。离欲界欲。而生初禅。乃至离无所有处欲。而生非想非非想处。答曰。世俗道。于彼处生报。非无漏道。复次此道若修。则灭损毁坏于有。世俗道修时。则增益长养于有。复次此道若修则令有不相续断。增长生老病死法。世俗道修时。令有相续增长生老病死法。复次此道若修是灭苦集道。是灭增长生老病死道。世俗道修时。是苦集道。是增长生老病死道。复次此道修时。不为身见作所缘。乃至不堕苦集谛中。世俗道虽修为身见作所缘。乃至堕苦集谛中。复次此道修时。不为界趣生增长生死法作因。世俗道虽修为界趣生增长生死法作因。复次此道修时。能尽界趣生增长生死法。世俗道虽修不能尽界趣生增长生死法。复次此道修时。是沙门是沙门果。是婆罗门是婆罗门果。是梵行是梵行果是有果。以如是等事故。佛经唯说修道。问曰。圣行名有十六种。体有几耶。答曰。或有说者。名有十六体有七。缘苦四行。名有四体亦有四。缘集四行。名有四体有一。缘灭道亦尔。问曰。何故缘苦四行。名有四体亦有四。答曰。缘苦四行。是颠倒近对治。如颠倒。名有四体亦有四。此行亦尔。评曰。应作是说。圣行名有十六。体有十六。如名体。名数体数名相体相名异体异。当知亦如是。问曰。圣行体性是何。答曰。体性是慧。彼慧体是行行余行。亦为行所行彼相应法体。非行行余行。亦为行所行。彼共有法体。非行不行余行。为行所行。复有说者。圣行是心心数法。若作是说。圣行体性。是心心数法者。相应法体性。是行行余行。为行所行。不相应法体。非行不行余行。为行所行。复有说者。圣行体性。是一切法。若作是说。圣行体性是一切法者。相应法体。是行行余行。为行所行。不相应法体。是行不行余行。为行所行。评曰。应作是说。圣行体性是慧。如先所说。此是行体性。乃至广说

已说体性。所以今当说。何故名无常行。乃至名乘行耶。答曰。以二事故。是无常。一以所作。二属于缘。所作者。一切有为法所作。唯一刹那顷。属于缘者。待因缘而生。苦痛逼切。如负重担。是苦对我所见故是空。对我见故是无我。因如种子法。集如出现法。有如相续法。能生故是缘。如泥团杖轮水缕等合集故瓶生。彼亦如是。诸阴尽是灭。无三相故是止。是善是常故。是妙是离。更无所离故是离。对邪道故是道。对不正故是正。能到解脱城故是迹。体性是出。不沉没故是乘。复次非究竟故是无常。如重担故苦。内无人无作者无受者无说者故空。不自在故无我。生故是因。出现故是集。流故是有。作相故是缘。不相续尽相续故是灭。灭三火故是止。无苦恼故是妙。无过患故是离。能去是道相应方便故是正。能到正故名迹。毕竟过生死故是乘

问曰。见苦谛时。见苦四行。谓无常苦空无我。何故但说苦谛。不说无常空无我谛耶。答曰。应说而不说者。当知此说有余。复次若说苦谛。当知已说无常空无我谛。复次此行是不共行。唯在苦谛中。无常行在三谛中。空无我行在一切法中。复次此行与有相违。能弃生死。若有美妙饮食。持与小儿。而语之言。此食是苦。小儿闻已。便生舍心。而不欲食。复次此行是一切所信处。谓愚智内道外道。复次智所知善分别故。佛经说苦智。为知何法。答曰。知苦如智所知。解所解行所行根根义所境界境界。当知亦如是。复次此行是旧法。是旧文句。过去诸佛。说苦谛苦行。今佛亦说苦谛苦行。问曰。见集谛时。见集四行。谓因集有缘。何故但说集谛。不说因有缘谛。答曰。应说而不说者。当知此说有余。复次若说集谛。当知已说因有缘谛。复次智所知善分明故。佛经说集智。为知何法。答曰。知集如智所知。乃至所境界境界。说亦如是。复次此行是旧法。是旧文句。过去诸佛。说集谛集行。今佛亦说集谛集行。问曰。见灭时见灭四行。谓灭止妙离。何故但说灭谛。不说止妙离谛。答曰。应说而不说者。当知此说有余。余如集谛说。道谛随义说亦如是。灭谛名涅槃。名不相似。名非品。名无色。名第一。名胜智果。名阿罗汉不应亲近不应修。名可受。名近名妙名离。广解如杂犍度

佛以圣语。为四天王。说四谛二解二不解。佛欲饶益怜愍故。复作陀毗罗语说四谛。谓伊弥弥祢踰被陀踏被。二不解者。一解一不解。世尊欲饶益怜愍故。作弥梨车语说四谛。谓摩奢兜奢僧奢摩萨婆多毗罗致。是名苦边。四皆得解。问曰。佛能以圣语。为四天王说四谛。令其解不。若能者何故不使他解。不能者偈所说云何通。如偈说

  佛以一音演说法　　而现种种若干义
  众生皆谓独为我　　解说诸法不为他

一音者谓梵音。现种种义者。若会中有真丹人者。谓佛以真丹语。为我说法。如有释迦人夜摩那人陀罗陀人摩罗娑人佉沙人兜佉罗人。如是等人。在会中者。彼各各作是念。佛以我等语。独为我说法。若贪欲多者。佛为我说不净。嗔恚多者。佛为我说慈心。愚痴多者。佛为我说缘起。众生皆谓为我解说。诸法不为他者。时会各谓佛为说法不为他。答曰。应作是说。佛能。问曰。若然者。何故不令他解。答曰。为满足诸天王心所念故。二天王作是念。若佛为我作圣语。说四谛者。我则能解。一天王作是念。若佛以毗罗语。说四谛者。我则能解。一天王作是念。若佛以弥梨车语。说四谛者。我则能解。如其念而为说之。复次欲现知众生语言音声故。或谓如来唯能作圣语不能作余语。欲令如是疑心得决定故。而作是说。复次受化者。或于如来。不变形言。而得受化。或于如来。变异形言。而得受化者。若于如来不变形言得受化者。若变形言而受化者。则不能解。曾闻佛在摩伽陀国。为尊弗迦罗婆罗故。步行经十二由旬。令十万众生皆得见谛。皆以不变形言故。若变形言。彼诸众生则不能见谛。若众生应见如来变现形言而得度者。若不变形言则不得度。复有说者。不能。世尊非境界事。不能为境界。佛虽得自在。不能以耳见色眼听声。问曰。若然者偈义云何通。答曰。此是叹说如来之言。所说大过。如毗婆阇婆提作如是说。如来常定善安住念慧故。如来不眠。以离盖故。如是皆是叹说如来过美之言。复次如来言音。能遍一切声境界。如其所念皆悉能语。如来秦语。胜秦中生者。如来若作弥梨车语。胜弥梨车中生者。复次如来语言。速疾回转。若作秦语。次作释迦语。以速疾回转故。人谓一时

佛经说诸比丘。是苦圣谛。曾从他闻。于法中正观思惟。生眼智明觉。诸比丘是苦圣谛。我应当知。曾从他闻。广说如上。诸比丘是苦圣谛。我已知。曾从他闻。广说如上。集灭道说亦如是。诸比丘是苦圣谛。曾从他闻。广说如上。是说未知欲知根。诸比丘是苦圣谛。我应当知。曾从他闻。广说如上。是说知根。诸比丘是苦圣谛。我已知。曾从他闻。广说如上。是说知已根。如是余一二谛三转生三根亦尔。尊者达磨多罗作如是说。我思惟此所说法。举身毛竖。如来所说。义无相违。不失次第。今此所说。失于次第。所以者何。此中知已根。后说未知欲知根。如是观法。非佛辟支佛声闻所观。所以者何。无有知已根。后起未知欲知根。现在前者。若欲舍是所说。是则不可。所以者何。此是如来最初之说。五比丘八万诸天为证。若欲不舍此所说者。失于次第。彼尊者虽有此念。而不舍此说。但正其文。此经应如是说。诸比丘。是苦圣谛。曾从他闻。于法中正观思惟。生眼智明觉。是集圣谛。是灭圣谛。是道圣谛。广说如上。诸比丘是苦圣谛。我应当知。是苦集谛我应当断。是苦灭谛。我应当证。是苦灭道谛。我应当修。广说如上。诸比丘是苦圣谛。我已知。是苦集谛。我已断。是苦灭谛。我已证。是苦灭道谛。我已修。广说如上。若作是说。则不失次第。随顺见谛时。阿毗昙者作如是说。经文不应正。所以者何。过去诸大论师。利根智慧。不正经文。何况尊者达磨多罗。利根智慧。不如前者。问曰。若然者此所说岂不违次第耶。答曰。有二种随顺。一所说随顺。二见谛随顺。以所说随顺故。世尊作如是说。以随顺见谛故。尊者达磨多罗。作如是说。尊者波奢说曰。此中不说未知欲知根知已根。此中说菩萨欲界闻慧思慧。菩萨坐道树下时。作如是方便观行。问曰。若然者。此说云何通。如说诸比丘。我是时得阿耨多罗三藐三菩提。如来以欲界闻慧思慧。得阿耨多罗三藐三菩提耶。答曰。如来本为菩萨。作如是方便观行时。以欲界闻慧思慧。观于诸法。生智慧光明。除去愚闇义名必得阿耨多罗三藐三菩提。如人先以生皮覆面。除去之后。以沙罗覆面。其所障碍。而甚微少。彼亦如是。诸比丘。我三转四谛十二行。生眼智明觉。问曰。如此三转四谛十二行。应有四十八行。何故但说三转四谛十二行耶。答曰。此是三说十二行法不过十二。余广说如杂揵度

问曰。此四圣谛。若是体断。亦是缘断耶。答曰。或是体断。非缘断。或是缘断。非体断。乃至广作四句。体断非缘断者。谓苦谛集谛无漏缘无缘法。缘断非体断者。谓道谛缘有漏法。体断缘断者。谓苦集谛缘有漏法。非体断非缘断者。谓道谛缘无漏无缘法。一切灭谛。四禅初禅第二禅第三禅第四禅。问曰。何故作此论。答曰。欲令疑者得决定故。波伽罗那说云何初禅。答曰。初禅所摄善五阴。乃至云何第四禅。答曰。答四禅所摄善五阴。彼中说善禅。不说染污不隐没无记。或谓。禅唯是善非染污不隐没无记。今欲决定说禅是善染污不隐没无记故。而作此论。四禅初禅。乃至第四禅。问曰。何故名禅。为以断结故名禅。为以正观故名禅。若以断结故名禅者。无色中亦有定能断结亦应名禅。若以正观故名禅者。欲界亦有定能正观。亦应名禅。答曰。应作是说。断结故名禅。问曰。若然者无色中亦有定能断结。亦应名禅。答曰。若定能断不善无记结者是禅。无色定虽能断无记结。不能断不善结故。不名为禅。问曰。若作是说。唯未至依是禅。所以者何。能断不善无记结故。答曰。此中说过患对治。对治有二种。有过患对治断对治。上地虽无不善结断对治。有过患对治问曰。若作是说。上地灭法智。道法智。一切比智。则不名禅。所以者何。于欲界结。不能作断对治过患对治故。答曰。虽非全界全地。而彼界彼地中。有能与欲界结。作过患对治者。以能者故。不能者亦得名禅。复次禅中遮少分有少分与欲界结作断对治过患对治。无色界悉遮。乃至无一刹那与欲界结作断对治过患对治者。尊者瞿沙。作如是说。此六地尽能与欲界结作断对治过患对治。以未至禅初出故。断欲界结。余者不断。以未至禅断故。如日光初中后时尽与闇相妨然。初出者。能除夜闇。中后者。虽与闇相妨。而不除闇。以初者除故。犹如六人共一怨家。而共议言。我等若先得怨者。必断其命。六人之中。一得怨而杀。余五人虽于彼人是怨。而不杀者。先已杀故。如人持六灯次第入闇室中。初入者除室中闇。余灯虽与闇相妨。而不破闇者。已先破故。如是六地中。虽与欲界结作断对治过患对治。以未至禅初生断欲界结。余地不断者。以未至禅先已断故。若六地作欲界结断对治者。依根本禅。得正决定时。欲界见道所断结。则无分齐。亦不应证解脱得。以依根本禅。得正决定者。于欲界见道所断烦恼。而有分齐。证解脱得。以是事故知六地尽有欲界烦恼断对治过患对治。复次若定能毕竟断见道修道所断结者名禅。无色定虽毕竟断修道所断结。不断见道所断结。复次若定能遍缘能断结者名禅。无色定虽能断结。不能遍缘欲界定。虽能遍缘。不能断结。禅定能遍缘。亦能断结。复次若定与五阴俱生作依者名禅。无色定与四阴俱生作依者。不名为禅。复次若定有四枝五枝者名禅。无色定无四枝五枝故。不名为禅。复次若有乐道处名禅。无色定无乐道故不名禅。复次若定能与道作依者名禅。无色定不能与道作依者不名禅。复次若定有三种示现者名禅。无色定无三种示现故不名禅。复次若定有三无漏根者名禅。无色定不具三无漏根故不名禅。三道亦如是。复次若有二道处名禅。二道者。谓见道。修道。忍道。智道。法智道。比智道。无色中无见道忍道法智道故不名禅。复有说者。以正观名禅。问曰。若然者。欲界亦有正观。应名为禅。答曰。若定能正观亦能断结者名禅。欲界定虽能正观。不能断结。故不名禅。复次若定牢固相续久住出入意不舍者名禅。欲界定与此相违。故不名禅。复次若有定名亦有定用者名禅。欲界定虽有定名。无有定用犹如泥椽。虽有椽名。而无椽用。禅定犹如木椽。亦有椽名。亦有椽用。复次若定不为娆乱风所吹动者名禅。欲界定。为娆乱风所吹动故不名禅。犹如四衢道中灯为风所吹动。禅定不为娆乱风所吹动故名禅。犹室中灯不为风所吹动彼亦如是

禅有十八枝。初禅有五枝。觉观喜乐一心。第二禅有四枝。内信喜乐一心。第三禅有五枝。舍念慧乐一心。第四禅有四枝。不苦不乐舍念一心。问曰。禅枝名十八。体有几。答曰。名有十八。体有十一。初禅有五枝。名有五。体亦有五。第二禅增一枝谓内信。第三禅增四枝。谓舍念慧乐。第四禅增一枝。谓不苦不乐。是故禅枝名有十八。体有十一。复有说禅枝名有十八。体有十。所以者何。初禅第二禅第三禅乐。俱是一乐枝故。不应作是说。所以者何。初禅乐第二禅乐异。第三禅异。初禅第二禅乐是猗乐。第三禅乐是受乐。初禅第二禅乐是行阴摄。第三禅乐是受阴摄。是故如前说者好。如名体名数体数。乃至知名知体。说亦如是。问曰。何者是禅。何者是枝。答曰。一心是禅。余者是枝。问曰。若然者。初禅第三禅有四枝。第二禅第四禅有三枝。答曰。一心是禅。亦是禅枝。余者是枝非禅。如正见是道是道枝。余是道枝。如择法觉是觉是觉枝。余者是觉枝不非时食是斋是斋枝。余者是斋枝。如是一心是禅亦是禅枝。此是禅枝体性。乃至广说。已说体性。所以今当说。何故名枝。枝是何义。答曰。随顺义是枝义。俱负义是枝义。成大事义是枝义。牢坚最胜义是枝义。别异义是枝义。随顺义是枝义者。若法随顺彼地立枝。俱负重成大事牢坚最胜亦如是。别异义是枝义者。如军别异名军枝。如车别异名车枝。如是禅别异故名禅枝。是故随顺义是枝义。乃至广说

问曰。若是初禅枝。亦是二禅枝耶。答曰。或是初禅枝。非二禅枝。乃至广作四句。是初禅枝非二禅枝者。觉观是也。是第二禅枝非初禅枝者。内信是也。是初禅第二禅枝者。喜乐一心是也。非初禅非第二禅枝者。除上尔所事。若是初禅枝。亦是第三禅枝耶。乃至广作四句。是初禅枝非第三禅枝者。觉观喜乐是也。是第三禅枝非初禅枝者。舍念慧乐是也。是初禅枝是第三禅枝者。一心是也。非初禅枝非第三禅枝者。除上尔所事。若是初禅枝。亦是第四禅枝。乃至广作四句。是初禅枝非第四禅枝者。觉观喜乐是也。是第四禅枝。非初禅枝者。不苦不乐舍念是也。是初禅枝亦是第四禅枝者。一心是也。非初禅枝非第四禅枝者。除上尔所事。是第二禅枝。亦是第三禅枝耶。乃至广作四句。是第二禅枝非第三禅枝者。内信喜乐是也。是第三禅枝非第二禅枝者。舍念慧乐是也。是第二禅枝亦是第三禅枝者。一心是也。非第二禅枝非第三禅枝者。除上尔所事。乃至第三禅四句。历第四禅。应随相说

问曰。如猗舍一切地中有。何故初禅二禅。立猗不立舍耶。第三第四禅。立舍不立猗耶。答曰。先作是说。随顺义是枝义。若法随顺彼地者立枝。猗随顺初禅第二禅故立枝。舍随顺第三第四禅故立枝。复次势用胜故。更相覆蔽。如初禅第二禅。猗势用胜。覆蔽于舍。第三第四禅。舍势用胜故。覆蔽于猗。问曰。云何此二法。更相覆蔽。答曰。以所行相违故。如一人一时。亦行亦住。亦眠亦寤。一向相违。彼亦如是。复次对治欲界五识及粗身故。初禅立猗为枝。对治初禅三识及粗身故。第二禅立猗为枝。第二禅无粗身故。第三禅不立猗为枝。第三禅无粗身故。第四禅不立猗为枝。复次以初禅二禅有染污喜。以是事故。佛作是说。应猗不应舍。是故初禅二禅。立猗为枝。第三第四禅。无染污喜。是故诸圣行舍。复次以初禅二禅。猗生有所缘如说。若心喜时。身则生猗。第三第四禅。猗生无所缘。是故诸圣行舍。问曰。内信一切地尽有何故。第二禅地立枝。非初禅耶。答曰。先作是说。随顺义是枝。若法随顺彼地者立枝。内信随顺第二禅地故立枝。复次初禅觉观如火。识身如污泥。令心扰浊。信不明净。如热浊泥中面像不现。第二禅无觉观火识身污泥。信则明净。如清冷水面像则现彼亦如是。复次行者住第二禅。于界离欲。于地离欲。生大信心。行者离不定欲界欲。起初禅现在前。作如是念。我已得离不定界欲。不知定界欲为可离不。后离初禅欲。起二禅现在前。是时于界离欲。于地离欲。生大信心。如初禅地欲可离。当知一切地。乃至非想非非想处欲尽可离。以是事故。二禅信立枝。初禅不立。问曰。念慧一切地中有。何故第三禅地立枝。非余地耶。答曰。先作是说。随顺义是枝。若法随顺彼地者立枝。念慧随顺第三禅故立枝。复次第三禅道。多诸留难。自地亦有留难。他地亦有留难。他地道多诸留难者。第二禅喜漂没轻躁。犹如罗刹。令行者离第三禅欲时。生诸衰退。为对是事故。第三禅立念为枝。是故佛作是说。汝等当正念。莫为第二禅喜之所漂没。自地留难者。第三禅乐受。是一切生死中最胜乐。令行者乐着不能离上地欲。为如是事故。第三禅慧立枝。是故佛作是说。汝等应于是乐莫生贪着。不求上地离欲法。问曰。念慧一切地中有。何故第四禅地立念为枝。不立慧。答曰。先作是说。随顺义是枝。若法随顺彼地者立枝。念随顺第四禅故立枝慧不随顺故不立枝。复次第四禅道。多诸留难。他地有留难。自地无留难者。第三禅地乐受。于一切生死中最胜。行者贪着故。不求离上地欲。是故佛作是说。汝等应当正念。莫为第三禅地乐之所覆没。以自地无留难故。不立慧为枝。复次第四禅地。立不苦不乐受为枝。不苦不乐受。是无明分。慧是明分。明无明。是相违法故

问曰。若是禅枝。亦是助道分耶。答曰。或是禅枝非助道分。乃至广作四句。是禅枝非助道分者。初禅观第三禅乐第四禅不苦不乐是也。是助道分非禅枝者。精进正语正业正命是也。是禅枝亦是助道分者。诸余助道分是也。非禅枝非助道分者。除上尔所事。问曰。初禅观第三禅乐。第四禅不苦不乐。何故不立助道分耶。答曰。以覆蔽故。初禅地观。为觉所覆蔽故。不立助道分。第三禅地乐。为猗乐所覆蔽故。不立助道分。第四禅地。不苦不乐。为行舍所覆蔽故。不立助道分。以如是事故。不立助道分。问曰。精进何故不立禅枝。答曰。禅枝于得地胜。精进于他地胜。初禅地精进。作第二禅地方便胜。乃至无所有处精进。作非想非非想处方便胜。复次精进与生定法相妨。与何生定法相妨。答曰。乐如说乐故。定心生众生行精进者必苦。问曰。何故正语正业正命。不立禅枝耶。答曰。禅枝是相应。是有缘。是有行。是有依。是有势用。正语正业正命。与此相违。故不立禅枝。问曰。若是禅枝。亦是念处耶。若是念处。亦是禅枝耶。若是禅枝。亦是正断神足根力觉道分耶。若是正断神足根力觉道分。亦是禅枝耶。应随相广说。复作是问曰。若是初禅枝。亦是助道分耶。若是助道分。亦是初禅枝耶。乃至第四禅问亦如是。应随相广说。复作是问。若是初禅枝。亦是念处正断神足根力觉道分耶。若是念处。乃至八道分。亦是初禅枝耶。乃至第四禅。问亦如是。应随相广说

问曰。诸边及无色定为立枝不。若立者。此中何故不说。若不立者。施设经云何通。如说颇有空处定于空处定道胜。根胜定胜枝等耶。答曰。有从空处定起次第。还入空处定。答曰。或有说者。诸边及无色定立枝。施设经所说善通。此中何故不说。答曰。应说如初禅。有五枝边。亦有五枝。除喜增不苦不乐受。如根本第二禅。有四枝边。亦有四枝除喜增不苦不乐受。如根本第三禅。有五枝边。亦有五枝除乐增不苦不乐受。如根本第四禅。有四枝边。亦有四枝。如第四禅四无色定亦应尔。评曰。诸边及无色定不立枝。是故此中不说。问曰。施设经所说云何通。答曰。此中说根胜道胜定胜者。以后定用前定为因生故枝等者说觉道枝

问曰。何故初禅第三禅立五枝。第二第四禅立四枝耶。答曰。先作是说。随顺义是枝。若法随顺彼地者立枝。五枝随顺初禅第三禅故立五枝。四枝随顺第二第四禅故立四枝。复次欲界是难断难除难过之界。必须牢强对治。是故彼对治初禅立五枝。第二禅喜。难断难除难过故。必须牢强对治。是故彼对治第三禅立五枝。初禅不难断难除难过故。不须牢强对治。是故彼对治第二禅立四枝。复次为对欲界五种境界爱故。初禅立五枝为对二禅五种喜爱故。第三禅立五枝。初禅无五种境界爱故。第二禅不立五枝。第三禅无五种喜爱故。第四禅不立五枝。复次欲令行者入超越。定得随顺故。起五枝定。入五枝定。起四枝定。入四枝定。问曰。如起第三禅入空处定。若是四枝。或是无枝。此中云何得随顺耶。答曰。一切外法内法所作。初须随顺后事成时。则不须随顺外法所作者。曾闻有王名旃陀掘。臣名遮那伽于十二年。造出金法。始成得一麦粒许。便作师子吼。我今力能造作金山。内法所作者。如行者修神足时。初能举身离地。如半胡麻。转如胡麻。半麦一麦。半指一指。半寸一寸。半尺一尺。半肘一肘。半寻一寻。衣钩衣架。后若成时。举身至阿迦腻吒天。如是外法内法。事未成时。必须随顺。事已成后。不须随顺。彼超越定亦尔。事未成时。起五枝定。入五枝定。起四枝定。入四枝定。事已成后。起五枝定。入四枝定。若无枝定

佛经说有四种胜心数法定。受现法乐。问曰。何故名四种胜心数法定。答曰。彼定有大势力。能成大事。有大功用。是根本禅。是故根本四禅名胜心数法定。复次彼定中。多诸心数法可得故。如无量解脱胜处一切处无碍无诤愿智半多俱置等。是故名胜心数法定。复次行者于彼定。得多种心受乐。如无量解脱乃至空空三昧无相无相三昧无愿无愿三昧。是故名胜心数法定。受现法乐者。问曰。此法亦受后法乐。不但现法乐。何故说言受现法乐。不说受后法乐耶。答曰。应说如说受现法乐。亦应说受后法乐。而不说者。当知此说有余。复次若说现法乐。当知已说后法乐。所以者何。后法乐必因现法乐故。如说先于此修定。后生彼处。复次现法乐。能令后法乐相续。非后法乐能令现法乐相续。是故说现法乐。复次现法乐。是后法乐方便所依门。复次现法乐。是一切所信处。如愚智内道外道。皆信现法乐后法乐。或有信者。或有不信者。不信后法乐者如外道。复次诸凡小。贪着少欲乐。不求离欲。佛作是说。汝等若欲得广大乐者。当断欲爱。起根本禅现在前。当受广大之乐。复次现法乐一切尽受。后法乐。有受者。有不受者。以如是等事故。佛说禅是现法乐。非后法乐

佛经说。诸比丘有四种天道。能令众生。不净者净。净者转更明胜。问曰。云何立天道。为以得正决定。为以尽漏耶。若以得正决定立天道者。则应有六。所以者何。依六地得正决定故。六地者。未至中间根本四禅。若以尽漏者。则应有九。所以者何。行者依九地。得尽漏故。九地者。谓未至中间四禅三无色定。答曰。应作是说。亦以得正决定。亦以尽漏。故立天道。是说则遮无色定。问曰。若然者天道应有六。尊者波奢说曰。此中说禅及眷属故。有四无六。尊者瞿沙。作是说。此中说清净天名天。天有三种。一假名天。二生天。三清净天。假名天者。谓人王等。生天者。从四天王天。乃至非想非非想处天。清净天者。谓阿罗汉。此中说清净天名天。得二种道。谓见道修道。忍道智道。法智道比智道。能令身心清净者。复次于生天道。生怖畏想。欲令安住实义天道故。佛说此经有四种天道。生天者。谓三十三天是也。彼有四种园林。一名质多罗咃。二名颇留沙。三名弥尸迦婆那。四名难陀那。彼园林中。有四种道。种种彩女所游行处。作诸音乐。烧众名香。安置种种肴膳饮食。随意生形。鸟出种种音。能令诸天。游戏园林。受于快乐。诸圣亦尔。灭尽涅槃。为园林四禅为道。种种道品善法。而严饰之。令诸贤圣。受种种快乐。入于涅槃。云何四种天道。如比丘离欲恶不善法。乃至广说。问曰。尽离欲界法。何故佛但说离欲恶不善法耶。答曰。如佛说离欲恶不善法。当知已说尽离欲界法。复次此法体应断。断已则不成就。与圣道相妨。有漏善法。不隐没无记法。不与圣道相妨。欲恶不善法。与圣道相妨。若断欲恶不善法。当知有漏善法不隐没无记法亦断。所以者何。同一对治断故。譬如灯不与炷油器相妨而与闇相妨。若破闇时。亦燋炷尽油令器热。复次以此法难断难除难过故。复次以此法是重恶多诸过患故。复次此法离欲爱时。多作留难。令离欲法不得相续。如守门人。不令他人入。彼亦如是。复次行者为对除此法故。修初禅定道。复次行者以憎恶此法故。尽离欲界。复次此法上地所无所不行故。以如是等事故。佛说离欲恶不善法

阿毗昙毗婆沙论卷第四十一阿毗昙毗婆沙论卷第四十二

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    使犍度十门品之六

问曰。此中何者是欲。何者是恶不善法。答曰。资生欲是欲。烦恼欲是恶不善法。复次欲是五欲。恶不善法是五盖。复次欲是欲爱使。恶不善法是余烦恼。复次欲是欲觉。恶不善法是恚觉害觉。复次欲是欲界。恶不善法是恚界害界。复次欲是欲想。恶不善法是恚想害想。有觉有观者。与觉俱故名有觉。与观俱故名有观。离生者。问曰。如上地离清净妙好。何故但说初禅离。不说上地离。答曰。说始以显终故。世尊或说始以明终。或说终以明始。说始以明终者。如此中说。说终以明始者。如说何处受身。不自害命。不害他命。佛告舍利弗。非想非非想处天受身。不自害命。亦不害他命。如始终初入已度方便毕竟亦如是。复次以此离初入初得故。复次初禅离从离生。从初禅定心生。如因陆生故名陆生。因水生故名水生。彼亦如是。因离生故名离生。复次初禅离。为二种无漏所守护。二种者谓未至中间。复次初禅离。是上地离方便所依门。复次初禅离。能生养增广上地离。复次初禅离。是上地离因根本有。集缘生起处。复次初禅离。对非离法故。欲界非离法。谁是近对治。谓初禅离是。复次欲令疑者得决定故。如欲界有觉观有识身有尊卑有眷属。初禅亦尔。或谓欲界有如是过故非离欲。初禅亦有如是过故非离欲。令此疑得决定故。说初禅有离。复次欲令行者心欢喜故。行者离欲恶不善法。起初禅离。生大欢喜。胜于后时。起上地离。犹如饥人初得蔬食。胜于后时得好美食。复次以初。禅能起诸离现在前。复次以依初禅。能令三种行人。入正决定。得果离欲尽漏。三种行人者。谓具缚。离欲。渐离欲人。复次以依初禅故。令三种信解脱。转根作见到。三种信解脱者。谓次第渐离欲。离欲人。复次以初禅离能对治三界。复次以初禅有得四沙门果道有九断智果道有七觉枝八道枝。是三十七助道法。有七种修道。有苦根忧根无惭无愧男根女根淫欲抟食爱五盖五欲对治法。复次以初禅是五阴十二入十八界对治法。以如是等事故。佛经说初禅是离喜乐者。喜是喜根。乐是猗乐。复次喜是受阴摄。乐是行阴摄。入初禅者。若得成就初禅善五阴。是名入初禅。已灭觉观。乃至广说。问曰。如离初禅欲。尽灭初禅法。何故佛但说灭觉观耶。答曰。如佛说灭觉观。当知已说灭初禅法。复次以觉观难断难除难过故。复次以此法是重多诸过患。复次此法离初禅爱。多作留难。令离欲法不相续。如守门人。不令他入。彼亦如是。复次行者为对治此法故。修二禅定道。复次行者憎恶此法故。尽离初禅。复次此法上地所无不行故。以如是等事故。佛说灭于觉观生内信者。内是心。信是信根。心信此法故名内信。尊者和须蜜说曰。觉观扰乱定心。觉观若灭。心则清净。故名内净。如水不波浪时名为澄清。彼亦如是。染污喜。令定心浊。彼若灭心则清净。譬如浊水澄清则名为净。尊者达摩多罗说曰。行者入第二禅时。于彼禅心。则宽博信乐。堪忍久住。乐观彼法。心不移动。住于一处。有是处所。有是体性。我得第二禅心。住一处者。心唯行一门中故。欲界心行于六门。初禅心行于四门。第二禅心行于一门。故言心住一处。无觉无观者。觉观已灭故。定生者。问曰。如初禅亦有定。何故第二禅说定。初禅不说耶。答曰。以二禅定明净胜妙胜初禅定。复次二禅中定从定生。定所长养定后现在前。定者谓初禅。初禅定是初定。从不定心后现在前。不定心者。谓欲界心。复次初禅有定不定。心有内向心。有外向心。或缘外法。或缘内法。第二禅唯定唯内向心。唯缘内法。复次以第二禅灭声根本。声根本者是觉观。如说有觉观者。能出语声。非无觉观。第二禅中。无有是事。复次第二禅说是贤圣默然法。如佛告目犍连。汝莫轻蔑第二禅。此是贤圣默然法。以如是事故。说二禅定。不说初禅。喜乐者。喜是喜根。乐是猗乐。复次喜是受阴摄。乐是行阴摄。入第二禅者。若得成就第二禅善五阴。名入第二禅。离喜住舍。乃至广说问曰。如离二禅欲时。尽离第二禅法。何故世尊独说离喜。答曰。如佛说离喜。当知已说离二禅法。复次以喜难断难除难过故。复次以喜是重多诸过患故复次此法离二禅爱时。多作留难。令离欲法不相续。如守门人不令他入。彼亦如是。复次行者为对治此法故。修三禅定道。复次行者憎恶此法故。尽离二禅。复次此法上地所无不行故。以如是等事故。佛说离喜住舍。有念慧身受乐者。身者是意身。复次若说意受乐。令四大身亦受乐。是贤圣所说应舍者。所说为他。应舍者是自身。问曰。如一切地尽是贤圣所说应舍。何故佛独说。第三禅应舍。答曰。以第三禅道多诸留难。有自地留难。亦有他地留难。他地道留难者。第二禅喜漂没轻躁。犹如罗刹令行者于离二禅欲法。而便衰退。自地道留难者第三禅地。有一切生死中最胜乐。行者生贪着故。不求上地离欲法。是故说道者。为初行人。说留难处。第三禅道多诸留难。谓第二禅喜。汝等应修正念。离第二禅欲时。莫为喜所漂没。自地留难者。谓一切生死中最胜乐。汝等应以正慧除去贪着。应求上地离欲法。譬如商人。为诸新学商人不知方土过患者。说留难事。此城中多诸淫女聚博饮酒欺诳之处。汝等应远离之。勿令他欺劫夺财物永尽。彼亦如是。住念乐入第三禅者。若得成就第三禅善五阴。是名入第三禅断乐。乃至广说。问曰。离第三禅欲时。尽断第三禅诸法。何故唯说断乐。答曰。如佛说断乐。当知已说断第三禅法。复次以乐难断难除难过故。复次以乐是重多诸过患故。此复次乐离第三禅爱时。多作留难。令离欲法不相续。如守门人。不令他入。彼亦如是。复次行者为对治此法故。修第四禅定道。复次行者憎恶此法故。尽离第三禅。复次此法上地所无不行故。以如是等事故。佛说断乐断苦者。问曰。离欲界欲时。行者已断苦根。何故离三禅欲时。言断苦耶。答曰。此中说已断名断。说远名近。如已来名来。如说大王从何处来。彼已来名来。此中说已来名来。余广说如上。此亦如是。已断名断。远名为近。复次此中说双法毕竟断故。苦乐是双。离欲爱时。虽断苦乐。而乐不毕竟断。离第三禅欲。毕竟断乐。复次断乐者。是第三禅乐。断苦者是彼相应心心数法。复次断乐者。是第三禅。断苦者是第三禅。出入息。贤圣以出入息作苦想。甚于凡夫受阿毗地狱苦。复次断乐者。是第三禅乐。断苦者亦是乐根。如说无常故苦先灭。忧喜者。离欲爱时灭忧根。离二禅欲时灭喜根。故说先灭忧喜。不苦不乐者。说不苦不乐。受舍者说行舍净念者。问曰。下地无漏念亦是净。何故说第四禅念是净耶。答曰。第四禅念。以无八事故名净。谓无苦无乐忧喜觉观出入息。复次彼念无内外留难故。下三禅中。有内外留难。初禅内留难者。有如火觉观。外留难者。为火所烧。第二禅内留难者。有如水喜。外留难者为水所漂。第三禅内留难者。有如风出入息。外留难者。为风所散。第四禅无内外留难。复次以第四禅念不忘失故。三禅为灾所及念有忘失。第四禅念不为灾所及故。无有忘失。复次无烦恼及患故。或有念无烦恼。有患有念。无患有烦恼。有念无烦恼。无患有念。有烦恼有患。无烦恼有患者。三禅中无漏念。无患有烦恼者。第四禅中有漏念。无烦恼无患者。第四禅无漏念。有患有烦恼者。三禅中有漏念。及欲界念。复次以依所依清净故。第四禅所依身明净。犹如灯光。如所依明净故。彼念亦明净。复次第四禅。是满足依。诸依中最胜地。是到彼岸法。复次第四禅是中依。犹如齐上有三地。无漏下有三地无漏。复次第四禅是遍依不动定。复次以第四禅有二事广。一处所广。二善根广。复次第四禅处。恒河沙诸菩萨等。得正决定。成阿耨多罗三藐三菩提。一切菩萨尽依第四禅得正决定。成阿耨多罗三藐三菩提。复次以三种行人尽依第四禅入正决定得果尽漏。三种行人者。谓佛辟支佛声闻。复次以第四禅四大最胜形色最胜故。复次以第四禅中念前世智。从欲界至第四禅。尽能缘以如是等事故。佛说第四禅念名净。入第四禅者。若得成就第四禅善五阴。是名入第四禅

佛经说忧根以初禅灭。苦根以第二禅灭。问曰。二根俱离欲时灭。佛何故说忧根以初禅灭苦根以第二禅灭耶。答曰。佛说过对治法。离欲界欲时。虽断苦彼对治不名过。若离对治初禅欲时。彼对治名过。谁是彼对治。答曰。初禅是。复次此中说性过。离欲爱时。虽断苦根。不过其性。谁是其性。答曰。识身是。复次此中说过所依。离欲爱时。虽断苦根。不过所依。离初禅欲时。过其所依。谁是所依。答曰。识身是。复次此中说觉观是苦。贤圣于觉观作苦想。甚于众生受地狱苦

佛经说均陀当知此胜四心数法定受现法乐。行禅比丘。应知入知起。均陀当知。此四无色寂静解脱。行禅比丘。应当为他解说。问曰。何故说禅言知。说无色言应当为他解说耶。答曰。以禅是粗现见了了法。行禅者。从禅起。复欲入禅。佛作是说。若欲入者。随意复入无色定。微细不现见不了了。行禅者从无色定起。不欲复入。佛作是说。若不欲复入者。出定入定之法。应为他人而解说之。莫忘失此法

复次禅有种种不相似法故。行禅者从禅出已。复还欲入。佛作是说。若欲入者。随意而入。无色定无有种种不相似法。行禅者。出已不欲复入。是故佛作是说。若不欲入者。出定入定之法。应为他人解说。莫忘失此法。复次禅中有多诸功德善利故。行禅者出已复还欲入。是故佛作是说。若欲入者。随意而入。无色定无多功德善利。行禅者从彼定出。不欲复入。是故佛作是说。若不欲入者。应当为他人解说。莫忘失此法。复次禅遍照法。能缘自地。亦缘上下地。行禅者出已复还欲入。佛作是说。若欲入者。随意而入。无色定非遍照法。能缘自地。亦缘上地。不能缘下地。行禅者从彼定起已。不欲复入。是故佛作是说。若不欲入者。应为他人而解说之。莫忘失此法。佛经说四禅有四善利。四无色定有一善利。问曰。佛何故说四禅有四善利说四无色有一善利耶。答曰。先所说诸答此中应广说。更有二不同。答曰。一以禅有三种。谓有觉有观。无觉有观。无觉无观。故有四善利。无色定。唯无觉无观。故有一善利。二以禅有种种根。为喜根乐根舍根。故有四善利。无色定无种种根。唯一舍根故。有一善利。问曰。禅善利有何差别。答曰。名即差别。是名为禅是名善利。复次禅三种。善染污不隐没无记。善利唯善。复次禅有漏无漏。善利唯无漏。复次禅是色界系不系。善利唯不系。复次禅是学无学非学非无学。善利唯学无学。复次禅是见道断修道断无断善利唯无断。禅善利。是谓差别

佛经说四禅是床座。问曰。何故佛说四禅是床座。答曰。以是高摄故。高者高于欲界。摄者摄诸善法。复次为诸圣人疲厌生死道示其座处故。如道行疲厌坐于床座则得休息。如是诸圣疲厌生死道。坐于四禅床座。则得休息

佛经说四禅是凉风。问曰。何故佛说四禅是凉风。答曰。能除止烦恼业热故。以初禅凉。止欲界烦恼业热。以第二禅凉。止初禅热。以第三禅凉。止第二禅热。以第四禅凉。止第三禅热

佛经说四禅是食。问曰。何故佛经说四禅是食。答曰。为满法身故。如村落中所有饮食送向城者。皆为长养城中诸人身故。如是禅中所有善根。皆为长养法身故

佛经说婆罗门当知第四禅是毕竟道。问曰。何故佛舍三禅。说第四禅是毕竟道。答曰。彼婆罗门。闻佛有一切知见。复闻如来以第四禅成阿耨多罗三藐三菩提。说第四禅是毕竟道便作是念。若沙门瞿昙。说第四禅是毕竟道者。必定有一切知见。便诣佛所。到已问如是义。佛知彼心所念。便舍三禅说四禅是毕竟道。彼人闻已。生决定心。必有一切知见。婆罗门是亦名如来所行。亦名如来现行法。譬如野象。于夏中时。见地生青茂华草及诸池水。心生欣踊。以牙掘地。然后安足。如来亦尔。亦以四禅行舍。掘所知地。而安智足。如来道者。是住舍摩陀。如来所行者。是住毗婆舍那。如来现行法者。是二俱住

佛经说四禅是乐住。问曰。何故佛说四禅是乐住耶。答曰。以易生乐故。根本禅以易生故是乐。诸边及无色定。以难生故是苦。有何难生耶。答曰。为欲界烦恼业所缚故。未至禅难生现在前。如人牢固反系其手多用功力。然后自解。如是为欲界烦恼所系缚故。多用功力。生彼地道现在前。或有以不净观起彼地道现在前。或有以阿那波那念者以不净观者。或于十年十二年中修白骨想。或有能起彼地者。或有不能者。以阿那波那念者。或十年十二年中。常数出入息。或有能起彼地现在前者。或不能者。已断欲爱。不多用功力。起初禅现在前。异心灭。起异心现在前。粗心灭。起细心现在前。与觉俱心灭。起与观俱心现在前。如人以木折木。多用功力。然后乃折。如是初禅异心灭。异心现在前。粗心灭。细心现在前。与觉俱心灭。与观俱心现在前。多用功力。亦复如是。若离初禅欲。不多用功力。起第二禅现在前。离第二禅欲。起第三禅现在前。离第三禅欲。起第四禅现在前。亦复如是。问曰。若离第四禅欲。起空处现在前。亦不多用功力

何故不名乐道。答曰。以无色定微细故或有说。无无色定。如梨毗婆居士。往诣尊者阿难所。作如是说。我是在家之人。长夜乐着色声香味触。闻说无色定。心生怖畏。如临深坑。云何众生。而无有色。复次以行时乐故。譬如二人俱欲至一方。一从陆道。二从水道。虽俱到一方。从水道行者乐。从陆道行者苦。如是无边众生。得离欲时。或依根本禅。或依诸边及无色定。虽俱得离欲。依根本禅者乐。依诸边无色定者苦。复次苦处所有二种乐。谓受乐猗乐。三禅中有二种乐。第四禅中。虽无受乐。广有猗乐胜于受乐。复次有二种故。一旧住乐二客乐。旧住乐者如住禅起禅现在前。客乐者如住禅起无色定现在前。复次此中有不恼害众生。乐可得故。如说若不恼害他。是名为乐。复次若起根本禅现在前。则遍身四大柔软。若起诸边现在前。则绕心四大柔软。复有说者。起诸边现在前。亦遍身四大柔软。但不如起根本禅现在前者。譬如二人。同一池澡浴。一在其边。一入其中。虽俱澡浴而入中者。令四大润益胜。彼亦如是。复次以有二法共在一处等俱生故。二法者谓定慧也。未至中间禅。慧多定少。无色定。定多慧少。根本禅生定慧等。复次有二法等俱生故。二法谓定精进。精进虽一切地偏多。以根本禅力故。二法生时俱等。复次断有二种。有多用功。有不多用功。诸边无色定若有所断。则多用功。根本禅。若有所断。不多用功。譬如二人乘马。俱至一方。一乘调者。一乘不调者。虽俱至一方。乘调马者。不多用功。乘不调马者。则多用功。如是诸众生离欲时。或依根本禅。或依诸边无色定。若依根本禅者。不多用功若依诸边无色定者。则多用功。复次以修道时得安乐故。譬如多人渡河。或因草束。或因浮囊。或因船。或因舫。虽从此岸俱渡到彼岸。但乘舫渡者安乐。彼亦如是。以如是等事故。佛经说根本禅是乐住。如乐住。触住乐触住亦如是。四无量。谓慈悲喜舍。问曰。何故禅次第说无量耶。答曰。以无量从禅中生故。复次以无量是禅中余功德故。以是事故。禅次第说无量。问曰。无量体性是何。答曰。慈悲是无恚善根。对治于恚。取其回转相应共有法。体性是四阴五阴。欲界者是四阴。色界者是五阴。问曰。此二俱是无恚善根。对治于恚。慈对治何等恚。悲对治何等恚耶。答曰。恚或有欲杀众生者。或有欲打众生者。若欲杀众生恚。慈为对治。欲打众生恚。悲为对治。复次恚有二种。一者应恚处而恚。二者不应恚处而恚。慈则对治应恚处而恚者。悲则对治不应恚处而恚者。喜是喜根。取其回转相应共有法。体是四阴五阴。欲界是四阴。色界是五阴。问曰。若喜体是喜根者。波伽罗那所说云何通。如说云何为喜。答曰。喜相应受想行识。及从彼起身口业。从彼起心不相应行。是名为喜。为受还应受耶。答曰。波伽罗那文。应如是说。喜相应想行识。乃至广说。不应说受。而不说者。有何意耶。答曰。诵者错谬故。复次波伽罗那说。无量体性是五阴。虽不与受相应。而与余数法相应。复有说者。喜自有体。是心数法。与心相应。或有说者。是喜根。心数聚中可得。或有说者。是喜根。后生舍。是无贪善根。对治于贪取其回转相应共有法。体是四阴五阴。欲界是四阴。色界是五阴。此是无量体性。已说体性。其相云何。答曰。体性即是相。相即是体性。诸法不可舍于体性别更说相。尊者和须蜜说曰。饶益相是慈。除不饶益相是悲。随喜相是喜。放舍相是舍

已说无量体相。所以今当说。何故名无量。无量是何义。答曰。对治戏论故名无量。问曰。若对治戏论是无量者。戏论有二种。一爱戏论。二见戏论。以何等无量。对治何等戏论。答曰。无量不能断结。或以无量对治于爱。或以无量对治于见。若取其近对治者。慈悲是见近对治。所以者何。见行众生。多喜嗔恚。喜舍是爱近对治。所以者何。爱行众生。多喜相亲近。复次对治放逸法故名无量。放逸者。是欲界诸烦恼。谁是其近对治。谓四无量。复次是贤圣所游戏处。名为欢喜。如富贵人。有种种游戏处。如园林彩女游猎等。名欢喜处。彼亦如是

界者在欲色界。地者慈悲舍十地中可得。谓根本四禅四禅边欲界禅中间。喜在三地。欲界初禅二禅。复有说者。初禅第二禅无悲。所以者何。初禅第二禅喜。是自地爱。喜根是欣踊行。悲是忧戚行。若初禅第二禅有悲者。则一心聚中。有欣踊行。亦有忧戚行。问曰。初禅第二禅。无无漏厌行耶。答曰。无漏厌行。是实观。随其实观。心则生喜。随其生喜。则欲更知。如人为宝故掘地。随其掘地。则便得宝。随其得宝。复欲更掘。彼亦如是。非是虚观。评曰。应作是说。初禅第二禅有悲。所依者。依欲界。行者慈是乐行。悲是苦行。喜是欢喜行。舍是放舍行。缘者尽缘欲界。缘聚缘众生。缘欲界五阴二阴。众生若缘住自心众生则缘五阴。若缘住他心及无心众生。是缘二阴。复有说者。初禅无量。缘于欲界。第二禅无量。缘欲界初禅。第三禅无量。缘欲界初禅。第二禅第四禅无量。缘欲界初禅第二第三禅。复有说者。初禅无量。缘欲界初禅。乃至第四禅无量。缘欲界乃至第四禅。复有说者。慈缘欲界初禅第二第三禅。所以者何。慈行乐行。欲界三禅中。有乐受故。悲缘欲界。所以者何悲行苦行。欲界中有苦受故。喜缘欲界初禅第二禅。所以者何。喜行欢喜行。欲界初禅第二禅。有喜根故。舍缘欲界乃至第四禅。所以者何。舍行放舍行。欲界乃至第四禅有舍故。评曰。如前说者好。无量尽缘欲界缘聚缘众生念处者。尽与法念处俱智者。尽与等智俱。三昧者。不与三昧俱。根者。总与三根相应。谓乐根喜根舍根。世者。是过去未来现在。缘三世者。过去缘过去。现在缘现在。未来必不生者缘三世。必生者缘未来。善不善无记者。是善缘善不善。无记者三种尽缘。是三界系不系者。是欲色界系。缘三界系不系者。缘欲界系。学无学非学非无学者。是非学非无学。缘学无学非学非无学者。缘非学非无学。见道断修道断无断者。是修道断。缘见道断修道断不断者。缘见道修道断。缘名缘义者。二俱缘。缘自身他身及非身者。是缘他身。为是离欲得。为是方便得者。是离欲得。亦是方便得。离欲得者。离欲界欲。得初禅者。离初禅欲。得第二禅者。离第二禅欲。得第三禅者。离第三禅欲。得第四禅者。离四禅欲得者。为是新得。为是本得者。亦是新得亦是本得。圣人最后身凡夫。亦是新得亦是本得。余凡夫。唯是本得。方便得者。以方便故起现在前。佛不以方便起现在前。辟支佛以下。方便起现在前。声闻或以中方便。或以上方便起现在前

问曰。云何生起无量耶。答曰。慈因亲分生行者。欲起慈心时。一切众生。尽作三分。一作亲分。二作怨分。三作非亲非怨分。亲分复作三种。谓下中上。怨分亦尔。非亲怨分唯作一种。上亲分中。有重恩者。谓父母和上阿阇梨。及余尊重处智慧梵行者。于彼众生。先作乐观。此诸众生。皆令得乐。此心坚强难调。以从无始以来常习恶心。于诸众生故。虽有如是重恩众生。犹不能令善心使住。复强还回此心。令住彼法。譬如有人。以芥子打于锥锋。甚难可住。习打不已。后乃得住。彼亦如是。若能观此上亲众生。皆令得乐。次观中亲众生。次观下亲。若能都观亲分众生。皆令得乐。次观非亲非怨分者。次观下怨。次观中怨。次观上怨。众生欲令得乐。若能如是观一切众生。皆令得乐。如上亲众生。于上怨众生。等无有异。是则成就。于慈悲喜亦尔。舍因非亲非怨众生起。所以者何。舍亲者生爱心。舍怨者生恚心。是故先舍非亲非怨众生。次舍下怨。次舍中怨。次舍上怨。所以者何。恚心易却。非爱心故。次舍下亲。次舍中亲。次舍上亲。若于一切众生。能作如是舍观者。心则平等。无所分别。其犹如称如观树林无有差别。观诸众生。亦复如是。是则成就舍心

问曰。何等人能起无量。何等人不能起无量。答曰。人有二种。一者喜求人过。二者喜求人善。若喜求人过者。不能起无量。所以者何。乃至于阿罗汉身。犹求其过。为有何破何实何垢。令我呵之。若喜求他善者。则能起无量。所以者何。乃至于断善根人边犹求其善。问曰。断善根人。无有诸善。云何于彼人边。求其善耶。答曰。虽无现善。有过去善业报。令其身端正。生于豪族。言有威德。多闻机辩。取如是等相。生于善念。彼行妙好。有如是果报

问曰。此四无量。为如说而生。为说异生异。答曰。或有说者。如说而生。所以者何。行者先欲饶益众生。饶益众生相是慈。是故世尊先说慈心。次除不饶益。除不饶益相是悲。是故世尊次慈说悲。若与饶益。除不饶益。次生欢喜。欢喜相是喜。是故世尊次悲说喜。次舍众生放舍相是舍。是故世尊最后说舍。复有说者。行者先起慈喜舍悲。后起慈喜舍。所以者何。先除众生不饶益事。后与饶益。次生舍喜。次生舍。尊者僧伽婆修说曰。二无量展转相御若先起悲。次必起喜。所以者何。悲是忧戚。喜是欢喜。若先起喜。次必起悲。所以者何。喜是掉。悲则制之。评曰。应作是说。无量不如说而起。所以者何。行者或有先起慈乃至舍。或有先起舍乃至慈。或有得慈不得余者。或有乃至得舍不得余者。无量无有顺次逆次顺超逆超。如解脱除入一切入。彼亦如是

问曰。慈次第能起悲喜舍不耶。答曰。定犍度说。云何心念慈三昧。答曰。众生乐。乃至云何心念舍三昧。答曰。众生舍。或有说。此文是俱生行。或有说。是次第缘行。若说是俱生行者。慈次第能起悲喜舍。若说是次第缘行者。慈次第不能起悲喜舍。问曰。若不起初禅地无量。能起第二禅地无量不耶。乃至不起第三禅地无量。能起第四禅地无量不耶。答曰。或有说者不能。所以者何。初禅地无量。是第二禅地无量方便门所依。乃至第三禅地无量。是第四禅地无量方便门所依故。复有说者。能若行者于彼地得自在者。即依彼地。能起无量现在前。问曰。为初禅地无量。后生第二禅地无量疾。乃至第三禅地无量。后生第四禅地无量疾耶。为第四禅地无量。后生第三禅地无量疾。乃至第二禅地无量。后生初禅地无量疾耶。答曰。第二禅地无量。后生初禅地无量疾。乃至第四禅地无量。后生第三禅地无量疾。非初禅地无量后生第二禅地无量。疾乃至非第三禅地无量。后生第四禅地无量疾。如人先学梵书。后学佉楼书疾。非先学佉楼书后学梵书疾。问曰。初禅地无量。次第能生第二禅地无量不耶。乃至第三禅地无量。次第能生第四禅地无量不耶。答曰。或有说者。能初禅地无量。次第生第二禅地无量。乃至第三禅地无量。次第生第四禅地无量。复有说者不能。所以者何。无量必须方便。方便必须自地相似。方便起慈乃至起舍

观有三种。一别相观。二总相观。三虚相观。别相观者。如观地是坚相。观水是湿相。观火是热相。观风是动相。总相观者如十六圣行俱观。虚相观者。如不净安那般那无量念解脱胜处一切入俱观无量。于三种观中。是虚相观

问曰。行者观众生乐时。为以何处乐令众生乐耶。答曰。或有说者。以第三禅乐。所以者何。第三禅乐。是一切生死中最胜乐故。若作是说。不起第三禅者。则不能起无量。复有说者。过去世。曾得第三禅乐。以第三禅地念前世智。观彼乐已以彼乐令众生乐。若作是说。若不得第三禅地念前世智。则不能起无量。复有说者。以近所更乐。如饮食乐乘乐。衣裳乐卧具乐。以如是等乐相。令众生乐。尊者和须蜜说曰。行者以何等乐。令众生乐。答曰。众生有乐者。以如是相。令众生乐。若作是说。慈则不能缘一切众生。所以者何。一切众生。不必有乐。复次众生有乐根。以如是相。令众生乐。若作是说慈则不能缘一切众生。所以者何。一切众生。不能于一切时起乐根现在前故。复次众生有饮食乐乘乐衣裳乐卧具乐。以如是乐相。令众生乐。若作是说。慈则不能缘一切众生。所以者何。一切众生。不必尽得如是乐故。尊者佛陀提婆说曰。以所知见乐。取如是相。以怜愍心。令众生乐。如本方便时。若依村住。若依城住。以日前分。若入城村乞食见纯受乐。众生或乘象马车舆而行。或着耳珰珠环。或以种种缨络严身。犹如天子。或见纯受苦者。如无衣裳饮食。头发蓬乱手足坼裂。执破瓦器。从他家乞。取如是乐苦众生相。速还住处洗足。于所坐处。结加趺坐。令身心柔软。身无障碍。心无障碍。观先所取相众生乐者。常令得乐众生苦者。令得先所见乐。问曰。所观众生。不尽得乐。云何此观非颠倒耶。答曰以其善故。非是颠倒。从饶益心起故。从善心起故。从怜愍心起故。从正观心起故。与善根相应故。与惭愧相应故。非是颠倒。颠倒有二种。一体颠倒。二缘颠倒。彼观虽是缘颠倒。非体颠倒。尊者和须蜜说曰。不以住慈故。令众生乐。但以此法作方便。能制恚断结。尊者佛陀提婆说曰。此观当言不颠倒。所以者何。与恚相妨故

佛经说若以无怨无恚无害慈心。善修此心。令广大无量。如是观满一方。二方三方四方上方下方亦复如是。皆以慈心。观一切处一切众生问曰。此慈缘于众生。何以说满于一方耶。答曰。此经文应如是说。若以无怨无恚无害慈心。善修此心。令广大无量。如是观满东方众生。南方西方北方众生。乃至广说。而不说者。有何意耶。答曰。此中众生。以方名说。如以器示器中物。皆以慈心。观一切处一切众生者。问曰。此无量观。为以方段。为以众生。若以方段者。此说云何通。如说。皆以慈心。观一切处一切众生。若以众生者。云何非得众生海边耶。答曰。或有说者。以方段故。问曰。若然者此所说云何通。如说。皆以慈心。观一切处一切众生。答曰。有二种一切。有一切一切。有少分一切。此中说少分一切。复有说者。以众生故。问曰。若然者。云何非不得众生海边耶。答曰。若以此事。得众生海边者。复有何过。但众生海边可得。以总故非别相。如一切众生。皆是四生。四生之外更无众生。复有说者。佛无量尽众生边。声闻辟支佛无量。以方段。复有说者。佛辟支佛无量。尽众生边。声闻无量。以方段。评曰。应作是说。此事不定。所以者何。此是虚相观。或有尽众生边际者。或有以方段者。问曰。为观一众生乐。为观多众生乐。答曰。初起时观多众生。所以者何。无量是缘聚缘众生法。若后成满时。亦缘一众生。亦缘多众生

佛经说诸比丘。我于七岁中。修习慈心故。七经劫成坏。不来生此间。世界坏时。我生光音天。世界成时。我生空梵世中。我曾为大梵天王。诸梵中尊无胜我者。于千世界而得自在。三十六反为帝释。亦于无量世。作转轮圣王。主四种兵。常以正法。降伏众生。成就七宝。乃至广说。七岁中者。谓七雨时。古世好时。菩萨为中国王。彼国多热。去城不远有林。其地高凉。生华果草木及诸流水。皆悉具足。夏热之时。城中村落人民皆舍居处。趣彼林中。各修所业。菩萨亦尔。更以余人。镇守于城。自诣林中。于高显闲静处。离欲界欲。起四无量。于夏雨四月中。游四无量心。夏热已过。天时转凉。是时人民。舍彼树林。还诣居处。各修所业。尔时菩萨。亦舍树林。还诣宫城。以怜愍故。设大法祀。修布施福业。施沙门婆罗门诸贫穷作业者及行道人。有来求者。施其饮食。衣服涂香房舍卧具象马车乘及施灯明。如是六反往彼林中。或有说者。第七反菩萨命行尽。命终生光音天。或有说者。遭世界坏。命终生光音天。是故于七雨中。名为七岁。问曰。若生梵世光音天中可尔。所以者何。是彼果是色界系故。言作帝释转轮王者。云何可尔。无量亦于欲界中受报耶。答曰。菩萨起三地无量。谓欲界地。初禅地。二禅地。受欲界地无量报。作转轮圣王帝释。受初禅地无量报。作大梵王。受第二禅地无量报。生光音天。复次欲界有无量出定入定心。受出入定心报故。作转轮圣王帝释。受无量报故。生梵世光音天中。复次欲界有无量方便。受方便报故。作转轮圣王帝释。受无量报故。生梵世光音天中。复次欲界是一切善根种子界。一切善根。乃至灭定。皆有相似法。受无量善根相似报故。作转轮圣王帝释。受无量报故。生梵世光音天中。复次受法祠祀报故。作转轮圣王。受持戒报故。作帝释。受彼林中修无量报故。生梵世光音天中。复次此经说三种福业。谓布施持戒修定福业。如彼经说。诸比丘我以三业报故。令我有大威势。三业者。谓施定戒。施者是布施福业。定者是修定福业。戒者是修戒福业。以布施福业报故。作转轮圣王。以持戒福业报故。作帝释。以修定福业报故。生梵世光音天中。佛经说有三种福业。谓布施福业。持戒福业。修定福业。云何布施福业。若以物施沙门婆罗门。乃至灯明。是名布施福业。云何持戒福业。不杀于杀。更不欲杀。不盗不淫不妄语不饮酒亦如是。是名持戒福业。云何修定福业。常以无怨无恚无害慈心。广说如上。悲喜舍心说亦如是。是名修定福业。问曰。何故色无色界善根。唯说无量。是修定福业。非余色无色界善根耶。答曰。世人以饶益为福想。一切色无色界善根。欲饶益他。无有如无量者。复次世人以福果为福想。无量能生广福果故。如偈说

  福火不能烧　　风不能吹坏
  能浮大地水　　亦复不能漂
  国王若盗贼　　虽作诸方便
  终不能劫夺　　男子女人福
  福藏最坚牢　　终无有亡失

问曰。如非福火。亦不能烧。何故但说福耶。答曰。非福虽不烧。烧非福果无量果。不已为火烧。不当为火烧。不今为火烧

佛经说诸比丘。苏尼哆弟子。于一切时满足学者。身坏命终。生梵世中。或于一切时不满足学者。身坏命终。生他化自在天。或生化乐天。或生兜率天。或生夜摩天。或生三十三天。或生四天王。或生刹利大姓婆罗门大姓居士大家。或生如是等家饶财多宝仓库盈溢之处。问曰。若然者苏尼哆。则胜佛世尊。所以者何。苏尼哆弟子。于一切时满足学者。身坏命终。生梵世中。于一切时不满足学者。身坏命终。生他化自在天。广说如上。世尊弟子。于一切时满足学者。得生天中。或得涅槃。于一切时不满足学者。身坏命终。生恶道中。答曰。于此事中。不应说佛不如。所以者何。如世尊最小弟子须陀洹。则胜苏尼哆身。此乃是佛行菩萨道。名苏尼哆时事。问曰。世尊行菩萨道时。胜成佛时耶。答曰。应知彼经所以。为以何事。作如是说。苏尼哆为诸弟子。说梵住法。得生梵天。言一切时满足学。苏尼哆弟子。为梵住法。勤行精进。能生起者。身坏命终。生梵世中。为梵住法。勤行精进。不能起者。或生他化自在天。乃至或生人中。然古世时人好。不因无量方便。亦得生天。何况为无量故。勤行精进。最胜善根。不生天人中耶。世尊为诸弟子。说逮解脱戒。令得涅槃。言应学是法。世尊弟子。于此学中。不破不穿。不越制度者。得生天上及到涅槃。世尊弟子。于此学中。破穿越制度者。身坏命终。生恶趣中。以是事故。此经说。无量是满足学。尔时苏尼哆。心生是念。我不应与诸弟子共生一处。我应修上慈生光音天中。时苏尼哆。便修第二禅地上慈。身坏命终。生光音天中。问曰。如苏尼哆。是近佛菩萨。不应有法悭。何以为诸弟子。说生梵世法。自生光音天。答曰。彼观弟子诸根。有齐量故。复次彼诸婆罗门。长夜期心梵天。随顺转近。欲生梵天。是故为说生梵天法。复次世无佛时。无有能起第二第三第四禅地无量者。唯除近佛菩萨。问曰。如上地无量。明净胜好。何故说第二禅地慈。名为上慈耶。答曰。第二禅地慈。于初禅地慈为上故。复次于声闻人边慈胜故为上。复次此慈于旧胜。故为上。复次世无佛时。无有能起第三第四禅地无量者。以佛力故。佛诸弟子。即依彼地。起彼地慈。是故尊者瞿沙。作如是说。彼二地慈。非凡夫人。以佛力故。佛诸弟子。能起彼慈

问曰。何故名梵住。答曰。以梵世在初具有故。未至禅虽在初不具有。第二禅虽具有不在初。初禅在初亦具有。复次对非梵故名梵住。非梵者。谓欲界烦恼。彼是近对治故。复次对非梵行故名梵住。非梵行者。谓欲界淫欲。谁是彼近对治。谓四梵住法。复次梵行者。身中可得故名梵住。复次世尊是梵。彼梵显现解说故名梵住。复次以梵音梵语解说故名梵住。复次诸梵修此法。得生梵世故名梵住。问曰。梵住无量。有何差别。答曰。或有说者。无有差别。所以者何。四梵住即是四无量。四无量即是四梵住。复有说者。名即差别。是名梵住。是名无量。复次对非梵故名梵住。对戏论故名无量。复次梵行者身中可得名梵住。无戏论者身中可得名无量。复次对治非梵行故是梵住。对治放逸故是无量。复次在梵世者是梵住。在上地者是无量。复次在未至。依梵世者是梵住。在上地者是无量。复次在未至梵世者是梵住。亦名无量。在上地者是无量。复次曾所得者是梵住。未曾得者是无量。复次内道中所行者是梵住。亦名无量。外道中所行者是无量。复次共者是梵住。不共者是无量。是故尊者瞿沙作是说。梵住是共法。凡夫圣人共故。无量是不放逸不共法。凡夫圣人不共故。梵住无量。是谓差别

佛经说四种人得梵福。云何为四。若人于未曾起塔坊处。能于此处。以如来舍利起塔。是名初梵福。复次若人于未曾起圣众精舍坊处。能于是处。起圣众精舍。是名第二梵福。复次若如来弟子众破还令和合。是名第三梵福。复次若人能修四梵住法。是名第四梵福。譬喻者。作如是说。此经非如来所说。此四亦非梵福。所以者何。此四果报不等故。若人起大塔。如来生处。得道处。转法轮处。般涅槃处。若人聚小石积为塔。此二福德等无异耶。若人起大精舍。如只桓林竹林多摩沙林精舍。若人起一重房。其福等无异耶。若和合如提婆达所破僧。若和合俱舍弥斗诤僧。其福等无异耶。四梵住是如来经所说。亦是梵福。阿毗昙者。作如是说。此经是如来所说。亦是梵福。问曰。此果报何故不等。答曰。以所为等故。若人于未曾起塔坊处。为如来大梵故起大塔。若人于未曾起塔坊处。为如来大梵故起小塔。以所为同故。其福无异。若无圣众精舍处起圣众精舍。若如来弟子众破。还令和合。此俱为梵行故。是梵福等无有异。是三所为同故。其福等无异。复次以相似故。若人修四无量。欲饶益无量众生。若于未曾起塔坊处。以如来舍利起塔。亦欲饶益无量众生。所以者何。百千万亿众生。以是如来塔故。以香华伎乐末香涂香及幢幡盖种种供具。而供养之。因是事故。生善身口意业种豪族家因缘。有大威德。饶财多宝。形容端正。人所乐见。或种转轮王因缘。或种帝释因缘。或种魔王因缘。或种声闻因缘。或种辟支佛因缘。或种佛因缘。若修无量欲饶益无量众生。若于未曾起圣众精舍坊处。起圣众精舍。亦为饶益无量众生。所以者何。百千众生。以是如来弟子众故。以种种饮食。作一日七日半月一月。作般遮于瑟及与常会。亦以床座随病药资生所须。而给与之。令诸比丘读诵修多罗毗尼阿毗昙。思惟其义。生不净安般念处暖顶忍世第一法。入正决定得果。离欲尽漏。因是事故。种豪族因缘。有大威德。饶财多宝。形容端正。人所乐见。或种转轮王因缘。或种帝释因缘。或种魔王因缘。或种声闻因缘。或种辟支佛因缘。或种佛因缘。如修无量。饶益无量众生。如来弟子众破。还令和合。亦欲饶益无量众生所以者何。若如来弟子众破。应入正决定者。不入正决定。不得果。不离欲。不尽漏。不转教。不受不读诵。是时不能思惟修多罗毗尼阿毗昙。不能种声闻辟支佛佛道因缘。令三千大千世界法轮停止。乃至首陀会天。而有异心。若僧破还令和合。应入正决定者得入。乃至首陀会天。无有异心。以如是相似事故。俱是梵福。复次若于未曾起塔坊处。以如来舍利起塔。有四事故名梵福。一舍多财生大信心。二令多众生得种善根。三都令成竟。四安置如来舍利。若无如来弟子圣众精舍坊处。始立精舍。亦以四事故名梵福。一舍多财生大信心。二令多众生得种善根。三都令成竟。四无所依者。为作所依。无居处者。为作居处。若如来弟子众破。还令和合。亦以四事故名梵福。一离四种口恶业。二行四种口善业。三破非法。四修恭敬法。若修四无量。亦以四事故名梵福。一离憎爱二断诸盖。三有彼果。四是彼系故。问曰。几许名梵福。答曰。或有说者。若福业报。能得转轮圣王身。梵福量亦如是。复有说者。若福业报。能得帝释身。梵福量亦如是。复有说者。若福业报。能得自在天王身。梵福量亦如是。复有说者。若福业报。能得梵王身。梵福量亦如是。复有说者。以一切众生福业威势故。令世界还成。梵福量亦如是。复有说者。除近佛菩萨。余一切众生。所有富贵福业。梵福量亦如是。复有说者。如梵天王请佛所得福业。梵福量亦如是。评曰。梵福量无量无边。如上所说。皆是赞叹梵福之言。问曰。梵天王请佛。何时得梵福。答曰。或有说者。发心欲往请佛时不应作是说。所以者何。云何未作业而得福耶。复有说者。请佛时得梵福。亦不应作是说。所以者何。梵天请佛时。是欲界不隐没无记心。不隐没无记心不能生报。评曰。应作是说。梵天王请佛已。还自本宫。佛以梵天王请故。而转法轮。五比丘及八万诸天。皆得见谛。是声上闻梵天。梵天王闻是声已。心生信敬。我请佛故。佛转法轮。令他得如是利益。是时得梵福

阿毗昙毗婆沙论卷第四十二阿毗昙毗婆沙论卷第四十三

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    使犍度十门品之七

如说若入慈定。火不能烧刀不能伤。毒不能害。水不能漂。不为他所杀。问曰。何故入慈定。不为水火刀毒他人所杀耶。尊者和须蜜说曰。慈定是不害法故。害法无能害者。复次彼定有大威势故。威势诸天皆来拥护。害不能害。复次禅定法。不可思议神足法亦尔。复次入彼定时。不住自心。不住自心者。不死不生。尊者佛陀提婆说曰。行者入慈定时。色界四大。遍此身中。同为一体。其犹若石。是故无能害者。问曰。此悲喜舍定。为害法所害不耶。若害者。何故入慈定。不为害法所害。入悲喜舍定为害法所害。若不害者。此中何故不说耶。答曰。应作是说不害。问曰。若然者此中何以不说。答曰应说而不说者。当知此说有余。复次已说在先所说中。若说慈。当知已说悲喜舍。复次此现始入方便故。如说慈悲喜舍亦如是。复次入悲喜舍定时害法。虽不能害。出定时身有苦痛。慈则不尔。复次入悲喜舍定害法。虽不能害。犹破肌皮。慈则不尔。复次入悲喜舍定时不能害。方便时则害。慈方便时。无能害者。曾闻有人得欲界方便慈。犯于王法时。人缚送于王。而白王言。此人犯王法。应加刑罚。时王乘象执[矛*贊]。欲出城游。即读经。其人所作之罪。王应手害。时王嗔恚。即以[矛*贊]掷其人。彼人见王嗔恚。便起慈心。以慈心故。[矛*贊]还向王身。不远落地。王见是事。心生恐怖。而问彼人。汝有何方道术耶。人答王言。我无方道术。见王嗔故。便起慈心。以慈心故。害不害我。以是事故。知慈方便害不能害

佛经说。修行广布慈心能断恚。修行广布悲心能断苦。修行广布喜心。能断不喜乐修行广布舍心。能断欲爱恚。问曰。无量为能断结不耶。若能断者。定犍度所说云何通。如说。慈断何系结。答曰。无处所悲喜舍断何系结。问曰。无处所若不能断者。此经云何通。答曰。应作是说。无量不能断结。问曰。若然者定犍度所说善通。此经云何通。答曰。此经说须臾断。断有二种。一须臾断。二毕竟断。以须臾断故。佛经说断。以毕竟断故。阿毗昙说不断。是二所说。俱为善通。如须臾断。毕竟断。有片断。无片断。有影断。无影断。有余断。无余断。制断。根本断。当知亦如是。问曰。若无量不断结者。异经说。复云何通。如说。比丘修慈心定。若不胜进余法。必得阿那含果。乃至舍心亦如是。答曰。此中佛说无漏圣道是慈。世尊或说圣道是想。或说是受。或说是意。或说是证。或说是信进念定慧。或说是筏。或说是石。或说是水。或说是华。或说是慈悲喜舍。何处说是想。乃至是华。广说如杂犍度。复次常以慈心。常观慈心。为求慈心故。离于欲爱。或是凡夫。或是圣人。若是凡夫。离欲爱已。得慈心定。彼于后时。入正决定。得阿那含果。若先不离欲。入正决定者。若得须陀洹果。若得斯陀含果。所以得阿那含果者。以慈定力故。若是圣人离于欲爱。得慈心定。亦得阿那含果。以是事故。佛作是说。比丘修慈定得阿那含果。但无量不能断结。如慈悲喜舍亦如是

佛经说修行广布慈心断恚。修行广布舍心。断欲爱恚。问曰。慈断何等恚。舍断何等恚耶。答曰。有欲杀他恚。有欲打他恚。慈断欲杀他恚。舍断欲打他恚。复次恚有二种。或有应恚处而恚。或有不应恚处而恚。慈断应恚处恚。舍断不应恚处恚。如是等恚是慈所断。如是等恚是舍所断

佛经说。修行广布不净想。断欲爱。修行广布舍心。断欲恚。问曰。不净想断何等爱。舍心断何等爱。答曰。爱有二种。一淫欲爱。二境界爱。不净想断淫欲爱。舍心断。境界爱。复次有色爱形爱。不净想断色爱。舍心断形爱。复次有触爱有容仪爱。不净想断触爱。舍心断容仪爱。不净想断如是等爱。舍心断如是等爱。佛经说。修与慈俱念觉枝。能得离得无欲得灭舍生死悲喜舍心俱说亦如是。问曰。无量是有漏。念觉枝是无漏。云何有漏法与无漏法俱耶。尊者和须蜜说曰。无量令心调伏质直任用已。次生觉枝。生觉枝后。复生无量故。而作是说。但有漏法俱

问曰。无量中何者最胜。答曰。或有说者慈胜。所以者何。慈是不害法故。复有说者悲胜。所以者何。佛以悲故。为众生说法复有说者喜心胜。所以者何。喜断不喜乐法故。复有说者舍心胜。所以者何。舍能断欲爱恚故。尊者佛陀提婆说曰。舍心最胜。所以者何。以二事故。一以所作。二以寂静。所作者。修行广布舍心。断欲爱恚。寂静者。不分别众生故

问曰。何故说大悲。不说大慈大喜大舍耶。答曰。应说一切佛身中所有功德。皆应言大。所以者何。佛有无量怜愍。饶益众生心故。但不应作此问。所以者何。若悲即是大悲。可作是问。但悲异大悲异故。不应作是问。问曰。若悲异大悲异者悲与大悲。有何差别。答曰。名即差别。是名悲。是名大悲。复次悲是无恚善根。大悲是无痴善根。复次悲在四禅。大悲在第四禅。复次悲声闻辟支佛佛尽有。大悲唯佛有。复次悲是无量所摄。大悲非无量所摄。复次悲对治恚不善根。大悲对治痴不善根。复次悲缘欲界。大悲缘三界。复次悲缘为欲界苦所苦众生。大悲缘为三界苦所苦众生。复次悲缘为苦苦所苦众生。大悲缘为三苦所苦众生。复次悲缘身苦众生。大悲缘身心苦众生。复次悲悲众生不能救。大悲悲众生能救。譬如二人临河而坐。有人为水所漂。一人举手而言。此人丧失。而不能救。第二人褰衣入水。救济其人。令得出水。悲与大悲。亦复如是。尊者和须密说曰。悲与大悲有何差别。答曰。一名为悲。二名大悲。复次体有差别。一是无恚善根体。二是无痴善根体。复次地有差别。悲在四禅。大悲在第四禅。余广说如上。尊者佛陀提婆说曰。大悲是佛。在第四禅。是不共法。深远微细。遍一切处。一切众生。无有怨亲。声闻辟支佛悲。不能缘色无色界悲大悲。是谓差别。问曰。何故名大悲耶。答曰。拔济大苦众生故名大悲。大苦者。谓地狱饿鬼畜生苦。复次拔济贪欲嗔恚愚痴大污泥众生。安置平坦道果中故名大悲。复次令诸众生生大利益事故。诸众生以身口意善业故。种豪族因缘。有大威势。饶财多宝。形色端正。或种转轮圣王帝释自在天王因缘。或种声闻辟支佛佛道因缘者。皆是大悲力故。复次以大法得故名大悲。非如声闻辟支佛道。或以一斋。或以一说。或以一食等施人故。而得行大布施。于一切处。施一切人。一切可爱物而得故名大悲。复次以大方便得故名大悲。非如声闻道六十劫行方便道而得。辟支佛百劫行方便。佛于三阿僧祇劫。行百千难行苦行而得。故名大悲。复次依大身而住故名大悲。非如声闻辟支佛道依诸根不具身而得。若身有三十二大人相。庄严八十随形好。身光一寻。观无厌足。住如是身中故名大悲。复次与大乐相违故名大悲。佛有甚深净明不共法。舍如是等法乐。经过百千万铁围诸山。为他人说法。皆以大悲力故名大悲。复次令大人作难作事故名大悲。世尊或现作师子像。或现作女人像。或现作力士像。或现作执乐人像。或现作乞人牵难陀臂。遍至五趣。于央掘魔罗前。或近或远。成就增上惭愧众生。为化女人故。示其阴藏。示轻躁相。出舌覆面。乃至发际。示现如是难作之事。皆以大悲力故言大悲。复次能动大舍山故。佛有二种不共住法。一是大悲。二是大舍。若如来住不共大舍时。无有是处。以分别故说。假令一切众生炽然。犹如火烧薪[卄/積]者。如来犹不视之。若如来住不共大悲时。见诸众生受苦恼时。如那罗延坚固之身。战动如芭蕉叶故名大悲

如毗尼说。佛以遍慈。为众生说法。问曰。佛以遍慈。慈于众生。众生为得乐不耶。若得乐者。地狱饿鬼畜生。及诸苦厄众生。何不离苦得乐。若不得乐者。此偈云何通。如偈说

  鬼神以恶心　　而来趣向人
  虽未加毒害　　心已怀恐怖

如鬼以恶心来。尚能生苦。何况如来善心。而不生乐。答曰。应作是说。能令众生乐。问曰。若然者偈义善通。地狱饿鬼畜生。及诸苦厄众生何不离苦得乐。答曰。佛观众生业。有可转者。有不可转者。若可转者。慈则济之。若不可转者。慈不能济。复有说者。不能令众生乐。问曰。若然者毗尼说云何通。如说佛以遍慈。为众生说法。答曰。佛遍慈有种种。或现神足。或现他所爱事。或以药草与他。或以迦陵触触之。或以安乐影覆。以神足者。曾闻佛住王舍城迦兰陀竹林时。有居士。请佛及僧食。尔时世尊以日前分。着衣持钵。与诸比丘。入王舍城。时王阿阇世。亲近恶友提婆达多故。以酒饮陀那波罗象。令其狂逸。欲害如来。尔时如来举右手五指。化作五师子王。时象见之。心怀恐怖。便欲还走。顾视其后。有大深坑。便视左右。有大高舍。仰视空中。有大方石。石出火焰。复四面顾视。皆有猛焰。唯见世尊足边清凉。象见是已。醉心醒悟。尔时世尊灭五师子。即前以鼻摩世尊足。世尊以相好庄严手。摩其顶上。以象语而为说法。诸行无常。诸法无我。涅槃是寂灭法。汝应于我生信敬心。当脱畜生身。象闻是语。不复饮食。即便命终。以清净心故。生三十三天。复以天身。来诣佛所。佛为说法。得见真谛。便还天宫时。世皆言。世尊遍慈。乃至及陀那婆罗。此中遍慈者。谓神足是。余处亦以遍慈。而现神足。曾闻世尊游行力士国。至波卑城。住耆留迦林。波卑城中。诸力士等。闻佛在彼。即共集议。我等皆应尽诣佛所。若不往者。当罚五百两金。尔时有一力士名曰卢遮。无有信心。有大威势。饶财多宝。不欲诣佛。心作是念。我能输五百两金。但违亲属。此事不可。时诸力士。尽共同时往诣佛所。到已顶礼佛足。尔时阿难见卢遮力士。而语之言。汝卢遮善来。见佛世尊。为世福田。不久当于娑罗双树林中而灭。其身质直。少于谄曲。语阿难言。我今来者。不为见佛。但随顺亲属故来。具以前事。向阿难说。尔时阿难牵卢遮臂。前诣佛所。而白佛言。此卢遮力士。不信佛法僧。唯愿世尊。为其说法令于佛法僧生信。尔时世尊作是思惟。是卢遮力士。是爱行人。贪着境界。若直为说法。则不信解。世尊以怜愍心。现神足力。即于彼处。化作一沸屎坑臭秽不净。加有火焰。从其中出。有如是声。而作是言。若卢遮力士。不从佛受法生信心者。身坏命终。当生此中。时彼力士。见闻是事。心大恐怖。在佛前坐。佛为说法。即生信心。归佛归法归比丘僧。时世皆言世尊遍慈。乃至及卢遮力士。此中遍慈者。谓神足是

或现他所爱事者。曾闻佛住弥絺罗国摩诃提婆庵罗林中。时有婆罗门妇。名婆肆吒。一时丧失六子。追念子故。羸形狂走。至摩诃提婆庵罗林中。尔时世尊与无量百千眷属围绕说法。法应如是。狂者见佛必得正念。尔时婆肆吒以见佛故。还得正念。心生惭愧。曲身而坐。尔时世尊告阿难言。汝可与婆肆吒衣。我当为其说法。阿难即与其衣。时婆肆吒着衣已。礼佛而坐。尔时世尊作是思惟。假令恒沙诸佛。为其说法。以愁恼故。终不信解。世尊怜愍故。以神足力。化作六子。彼妇人见诸子已。心作是念。我为此诸子故。心生愁恼。今得见子。无复愁恼。尔时世尊随其所宜。而为说法。得见真谛。世人皆言。世尊遍慈。乃至及婆肆吒。此中遍慈者现他所爱事。余处示现他所爱事。名为遍慈。曾闻佛住舍卫国时。舍卫国有一婆罗门。稻田成熟垂当收刈。令一子守。时天降雹。伤其稻田。又害子命。婆罗门以伤稻田丧失子故裸形狂走至只陀林中。尔时世尊与百千眷属围绕说法。法应如是。狂者见佛必得正念。尔时婆罗门以见佛故。还得正念。在佛前坐。尔时世尊作是思惟。假令恒沙诸佛。为其说法。以愁恼故。终不信解。世尊怜愍故以神足力化作稻田及所爱子。其人见已。心作是念。我为稻田所爱子故。心生愁恼。今得见之无复愁恼。尔时世尊随其所宜。而为说法。得见真谛。世皆人言。世尊遍慈。乃至及婆罗门。此中遍慈者。现他所爱事

以药草与他者。曾闻佛在婆尸国游行。至波罗柰国仙人住处施鹿林中。尔时波罗柰国。有一居士。名摩诃先那。其妇名摩诃先尼。时彼居士夫妇请佛及僧。当施一切所须资产之物。尔时有一比丘。服吐下药。发其风病。医处当服肉汁看病。比丘即以是事。往告摩诃先尼。时摩诃先尼。敕使持钱。买肉作汁。与彼比丘。其日梵摩达王。生子欢喜。宣令不杀。时婢遍波罗柰城。求肉不得。还白大家。尔时摩诃先尼作是念。我请佛及僧。施一切所须资产之物。彼病比丘若不得肉者。或因此病而死。复作是念。世尊本行菩萨道时。数数为他命故。以自身肉布施。今我亦应如菩萨法。以自身肉施他。即入静室。自持利刀。割其髀肉与婢。令办肉汁施病比丘。时婢如敕。成熟肉汁。施病比丘。尔时比丘不忆念故。即便服之。所患即除。尔时摩诃先尼身体苦痛。不安一处。尔时摩诃先那从外来入。不见其妇。问其家人。摩诃先尼今在何所。家人答言。今在舍内。身体苦痛。不安一处。具说上事尔时摩诃先那极生嗔恚。而作是言。沙门释子不知时宜。又无厌足。虽施者无量。受者应当知量。当以是事往白世尊。即诣佛所。尔时世尊百千眷属围绕说法。世尊妙色。见者欢喜。居士以见佛故。恚盖即除。心生欢喜。便作是念。我今不应以是事白佛。当请佛及僧。至我家中。乃当说之。即头面礼佛。在一面坐。佛说法讫。即从座起。正衣服偏袒右肩。合掌白佛。而作是言。唯愿世尊及比丘僧。于我家食。尔时世尊默然受请。摩诃先那知佛许已。礼佛而退。还家即夜办具肴膳种种所须。晨朝敷座。遣使白佛。饮食已具。唯圣知时。尔时世尊以日初分。着衣持钵。将比丘僧。入摩诃先那舍。坐所敷座。佛知故问摩诃先尼。今何所在。其夫答言。今在舍内。身体苦痛。不安其所。佛告居士。往语汝妻。世尊唤汝。世尊善知内缘起法。亦复善知外缘起法。即以神力至香山中。取涂斫创香药。与摩诃先尼。使用涂创。即得除愈。时彼创处。肌毛皮色。平复如故。尔时摩诃先那。往至其妻摩诃先尼所。而语之言。世尊唤汝。妻便答言。居士当知世尊神力不可思议。汝语我言。世尊唤汝。如是时间。我身创苦。平复如故。是时夫妻。倍加信敬。共诣佛所。头面礼佛。在一面坐。尔时世尊随宜说法。俱得见谛。世人皆言。世尊遍慈。乃至及摩诃先尼。是中遍慈者。谓以药草与他。余处亦以药与他。曾闻波斯匿王断贼手足。掷弃堑中。尔时世尊以日初分。着衣持钵。入舍卫城乞食。时贼见佛。举声大唤。我今苦厄。愿见哀愍。世尊善知内缘起法。亦复善知外缘起法。即以神力。至香山中。取涂斫创。香药涂其创上。苦痛即除。亦为彼贼。随宜说法。即得见谛。世人皆言。世尊遍慈。乃至及贼。此中遍慈者。以药草与他。以迦陵伽触触者。曾闻佛住王舍城耆阇崛山如来住山一边。提婆达多住一边。尔时提婆达多患于头痛。昼夜不得眠寐。极用苦恼。尔时阿难具以白佛。尔时如来如申象王鼻臂。穿耆阇崛山。以迦陵伽。触摩提婆达多头。作至诚言。我于罗睺罗提婆达多。心无增减。此言诚实者。提婆达多头痛当除。以诚言故。提婆达多头痛即除。时提婆达多。作如是念。此是谁手。知是佛手。而作是言。快哉悉达。善知医方。可以自活。世人皆言。世尊遍慈。乃至及提婆达多。此中遍慈。以迦陵伽触。余处亦有迦陵伽触。曾闻世尊巡行房舍。至一房内。有一病比丘。不能起居。卧粪秽中。见佛世尊高声而言世尊。我今无依无救。佛告病比丘。汝不以三界世尊故。而出家耶。答言。如是。佛告病比丘。汝以我故出家。何以言无依无救。病比丘。汝不病时。颇曾瞻养病比丘不。答言。不也。佛告病比丘。汝不瞻养他故。今使汝若此。尔时世尊自去身衣。从草敷中起。病比丘复以竹片。刮其身上粪秽以白土泥洗。帝释注水。尔时世尊除其粪秽。更涂房舍。浣所污衣。更敷新草。以所食半食。而以饭之。复以迦陵伽触手。摩其顶上。时病比丘苦痛即除。佛随宜为其说法。即得阿罗汉果。世人皆言。世尊遍慈。乃至及病比丘。此中遍慈者。以迦陵伽触

以安乐影覆者。曾闻佛共尊者舍利弗。一处经行。时有一鸟。为恐怖逼切故。趣舍利弗影。犹故恐怖。举身战栗。复趣佛影中。恐怖即除。止不战栗。尔时尊者舍利弗。合十爪指掌而白佛言。世尊。此鸟在我影中。恐怖战栗。在世尊影中。止不恐怖战栗。佛告舍利弗。汝于六十劫中。习不杀心。我于三阿僧祇劫。习不杀心故。世人皆言。世尊遍慈。乃至及鸟。此中遍慈者。以安乐影覆。余处亦以安乐影覆。曾闻愚痴毗琉璃王毁坏。如天宫迦毗罗城。断诸释命。将五百释女。还舍卫国。共升高楼。向诸释女。而自叹誉。诸释勇健。心怀憍慢。我已杀之。诸女答言。所以为汝杀者。为戒所缚故。时王嗔恚。诸释慢心。而今犹有。即断五百释女手足。掷城堑中。极大苦恼。诸释女等。各作是念。我等苦恼。世尊岂不怜我等。佛知诸女心之所念。亦以大悲心故。往到其所。起世俗心。帝释可以衣覆此诸女。尔时帝释知佛心念。即以天衣。覆此诸女。佛放光明。遍诸女上。佛光触故。苦痛即除。亦随宜为说法。时诸释女皆得见谛。身坏命终。生三十三天。世人皆言。世尊遍慈。乃至及诸释女。此中遍慈者。以安乐光覆

佛经说。修行广布慈心。报不过遍净。修行广布悲心。报不过空处。修行广布喜心。报不过识处。修行广布舍心。报不过无所有处。问曰。慈报不过遍净可尔。所以者何。是彼果是彼系故。余三无量。是色界系善根可于无色界受报耶。答曰。此义味弥勒下生。乃当显说。复有说者。尊者奢摩达多。能知此义时入定故。尊者迦旃延子。不问此义。复有说者。世尊为教化众生故。无色定以无量名说。若以无量名。说无色定者。受化者则易悟解。如受化者应闻解脱。以方名说。而得悟解。佛即以方名说解脱。复有说者。无色定对治觉支以无量名说。第三禅对治觉支以慈名说。空处对治以悲名说。识处对治以喜名说。无所有处对治以舍名说。复有说者。以相似故。慈行乐行乐受。从欲界乃至第三禅可得故。悲行苦行。色处则有断手足耳鼻头苦。空处呵责于色。喜行欢喜。识处起识现在前。心则多喜舍行放舍无所有处。说名舍观。以如是等相似事故。而作是说。复次以乐住是处故。或有乐观慈心。以慈心故求离欲。起初禅现在前。心不喜乐。有余求心。不能住意。离初禅欲起二禅现在前亦如是。若离第二禅欲。起三禅现在前。便生喜乐受无余求。能令意住。或有乐观悲心故。离欲爱。乃至离第三禅爱。起第四禅现在前。广说如上。若离第四禅爱起空处现在前。心不喜乐。广说如上。若离空处爱。起识处现在前。心则喜乐。广说如上。或有乐观于舍心。以舍心故。求离欲爱。乃至离空处爱。起识处现在前。心不喜不乐。广说如上。若离识处爱。起无所有处现在前。心则喜乐。广说如上。是故以乐住彼处故。作如是说。复次随顺故。作如是说。从第三禅。起欲界诸根。四大润益。随顺慈心。从慈心起欲界诸根。四大润益。随顺第三禅。从空处定。起欲界诸根。四大润益。随顺悲心。从悲心起欲界诸根。四大润益。随顺空处定。从识处定。起欲界诸根。四大润益。随顺喜心。从喜心起欲界诸根。四大润益。随顺识处定。从无所有处定。起欲界诸根。四大润益。随顺舍心。从舍心起欲界诸根。四大润益。随顺无所有处定。是故以随顺故。而作是说。复次为对治外道故。外道于无色定。作解脱想。谓无身无边意净聚世塔为对外道。如是想故。无色定。以无量名说。是故尊者瞿沙。作如是说。外道于灭尽法中。愚计无色定以为灭尽。为对外道故。是以佛经说无色定。无量俱非解脱。等无有异

四无色定。无边空处。无边识处。无所有处。非想非非想处。问曰。何故作此论。答曰。为止并义者意故。如毗婆阇婆提说无色界有色。育多婆提说。无色界无色。问曰。毗婆阇婆提。为信何经。言无色界有色耶。答曰。依佛经。佛经说名色缘识。无色界有识故。亦应有名色。余经亦说。寿暖气识。此三法常相随。不相离。无有分散。各在异处。无色界有寿识故。亦应有暖气。余经复说。比丘当知。若除色受想行识。说有来有去有生有死有住者。不应作是说。无色中有识故。亦应有识住处。亦说过难。若当无色界无色者。欲色界命终。生无色界。或经二万劫色断。或经四万劫色断。或经六万劫色断。或经八万劫色断。若无色界命终。还生欲色界。久远断色。还与色相续。如是入无余涅槃界。久远灭行。亦应还与行相续。欲令无如是过故。说无色界有色。问曰。育多婆提。依何经。说无色界无色耶。答曰。依佛经。佛经说。寂静解脱。过于色入。如是无色定身作证。若说过色入无色定。当知无色界无色。余经亦说。以色离欲。以无色离色离一切心法。离一切所作。入灭尽涅槃。若说离色界入无色界。当知无色界无色。如说禅经说若有色。若有受。若有想。若有识。当观此法。如病乃至广说。如说无色定。经说。若有受。若有想。若有行。若有识。当观此法。如病乃至广说。若说禅时说色。若说。无色定时不说色。以是事故。知无色界无色。亦说过难。若无色界有色者。则不应施设次第灭法。若无次第灭法。亦无毕竟灭法。若无毕竟灭法。则无解脱出要。欲令无如是过故。说无色界无色。如是一说无色界有色。一说无色界无色。此二说中。何者为胜。答曰。育多婆提所说。无色界无色者胜。问曰。育多婆提。云何通毗婆阇婆提所依经。答曰。彼经是未了义。是假名有余意。问曰。彼经有何义未了有何义假名有。何余意耶。答曰。佛经或说欲界法。或说色界法。或说无色界法。或说欲色界法。或语色无色界法。或说三界法。或说非三界法。说欲界法者。如说三界。谓欲界恚界害界。三觉。欲觉恚觉害觉。三想。欲想恚想害想。说色界法者。如说四禅。说无色界法者。如说四无色定。说欲色界法者。如此经说。说色无色界法者。如说定。如说摩[少/兔]摩。说三界法者。如欲界色界无色界欲有色有无色有。说非三界法者。如说我今当说涅槃及趣涅槃法。如说名色缘识。当知此说欲色界法。所以者何。欲。色界有色故。名色为识作缘。无色界无色故。名为识作缘。此是通彼经。若如彼经说者。彼经说六入缘触。无色有触。亦应有六入。如经说。寿暖气识。常相随。不相离。乃至广说此经亦说欲色界法。所以者何。欲色界有暖气故。三法常相随。不相离。无色界无暖气。寿识二法。常相随。不相离。此是通彼经。若如彼经说者。彼经说。此三法常相随不相离无有分。散各在异处。而此法可施设在异处。或在阴中。或在界中。或在入中。在阴中者。暖气是色阴。寿是行阴。识是识阴。在界中者。暖气是触界。寿是法界。识是七心界。在入中者。寿是法入。暖气是触入。识是意入。以是事故。彼法可施设。各在异处。是故不应尽依彼经说。应解其义。如经说比丘当知若除色受想行识。说有来有去有生有死有住者。不应作是说者。此经亦说欲色界法。所以者何。欲色界有色故。识依此四法而住。无色界无色故。识依三法而住。此是通彼经。若如经说者。余经亦说。一切众生。皆依食存。色无色界。亦有抟食耶。彼说过难。复云何通。答曰。此不必须通。所以者何。此非修多罗毗尼阿毗昙。若必欲通者。有何意耶。答曰。如我义。色续色。色续无色。无色续无色。无色续色。色续色者。如欲色界命终还生欲色界。色续无色者。如欲色界命终生无色界。无色续无色者。无色界命终。还生无色界。无色续色者。无色界命终。生欲色界。问曰。若然者如欲色界命终生无色界。或经二万劫色断。或经四万劫。或经六万劫。或经八万劫色断。若无色界命终。还生欲色界。久远断色。还与色相续者。如是入无余涅槃界。久远灭行。亦应还与行相续。答曰。断有二种。有须臾断。有毕竟断。若须臾断者还相续。若毕竟断者不相续。问曰。毗婆阇婆提。云何通育多婆提所依经。答曰。彼作是说。彼经是未了义。是假名有余意。问曰。有何义未了。有何假名有何余意。答曰。彼作是说。经说。过色入无色者。过于粗色。入于细色。无色界有色而细。经说。以色界离欲界。而色界有色。以无色界离色界。而无色界亦应有色。问曰。若色界以离欲界色故。名离欲界者。此事可尔。但色界以离欲故。名离欲界。而色界无欲。是故此事不尔。亦非通经说。禅经说无色定。经及说过难。则不能通。然毗婆阇婆提所说。是无明果。闇果。痴果。不勤方便果。说无色界有色。而无色界无色。是故为止他义欲显己义。亦欲说法相相应义故。而作此论。莫止他义。亦莫为显己义。但欲说法相如实义故。而作此论

四无色定。无边空处。无边识处。无所有处。非想非非想处。云何空处。波伽罗那说。云何空处。答曰。空处有二种。谓定生及生。彼中不隐没无记受想行识。是名空处。如空处识处无所有处非想非非想处说亦如是。定者是无色定。生者是无色界生及生。彼中不隐没无记受想行识者。是无色报。佛经说云何空处。过一切色想。灭有对想。无种种想思惟。入无边空处。是名空处。问曰。色想是眼识相应想。离初禅欲时已过。何故此处说过色想。答曰。此中说过所依名过。过有二种。一过依二过所依。离初禅欲时过色想依。离第四禅欲时过色想所依。复次此说过所行。过有二种。一过所断。二过现行。离初禅欲时过所断色想。离第四禅欲时过现行色想。复次此说过住处。过有二种。一过欲爱。二过住处。离初禅欲时过色想欲爱。离第四禅欲时过色想住处。复次生第四禅中。以眼识故。起色爱现在前。以是事故。说过一切色想灭有对想者。问曰。有对想者。是耳鼻舌身识相应想。彼或有离欲时灭者。或有离欲时不灭者。何故言此处灭有对想。答曰。先所说答。此中尽应说之。复有说者。有对想者。名恚相应想。问曰。离欲爱时。灭有对想。何故此处说灭有对想。答曰。灭所为事故。诸所为事。能生恚想者。离第四禅欲时都灭。无种种想思惟者。云何种种想思惟。谓第四禅中诸散想。问曰。何故名种种想。答曰。此想缘种种入故。染污者缘十入。不染污者。缘十二入。问曰。何故说无种种想思惟。答曰。种种想。离第四禅欲时。极作留难。令离欲法不相续。如守门人。不令他入。彼亦如是。是故佛作是说。不应思惟种种相。应离第四禅欲。无边空处者。问曰。何故名无边空处。为以自体。为以所缘。若以自体者。自体是四阴。非无边空。若以缘者。则缘四谛虚空非数灭。答曰。应作是说。非以自体。亦非以缘故。以方便故。如施设经所说。以何方便。求无边空处定。答曰。初行者。若观垣头空。若观树头空。若观屋上空。取如是空相已。观是虚空。作如是想。作如是观察。以缘空故。生于彼定。是故名空处定。复次法应如是。离色初地。必名空处。行者先观上色地。离下色地欲。离第四禅欲时。观空处四阴离第四禅欲。是故彼中作虚空想。如人上树。缘上枝舍下枝。若至树头。更无上枝。便作空想。彼亦如是。复次以依故。说名空处。所以者何。从彼定起。犹有余依。曾闻有一比丘。得空处定。从彼定起。扪摸虚空。余比丘问言。为何所求。答言。我求我身。比丘说言。汝身即在床上。入空处定者。若得成就空处善四阴。是名为入。云何无边识处。过一切空处。入识处定。是名识处。问曰。何故名识处。为以自体。为以所缘。若以自体。体是四阴。若以所缘者。则缘四谛虚空非数灭。答曰。非以自体。亦非以所缘。但以方便故。如施设经说。云何方便求识处定。答曰。初行者。取净眼耳鼻舌身意识。取是相已。思惟观察于识。以方便观识故。生识处定。复次以余依故。从识处定起识则欢喜。入者若得成就识处定善四阴。是名为入。云何无所有处。答曰。过一切识处。更无所有。入无所有定。问曰。有何无所有耶。答曰。彼有无我无我所。问曰。一切地尽无我无我所。答曰。虽一切地无我无我所。见无我令我见。羸劣穿薄。少苦无势。莫如无所有观者。复次彼中无常恒不变故。名无所有。复次无覆无依无救故。名无所有。复次无所有。名无边行。彼中无故。名无所有。尊者和须蜜说曰。此定是无所属法故。名无所有。如说我不属彼。彼不属我。故名无所有。入者。若得成就无所有处善四阴。是名为入。佛经说无所有处是舍。问曰。何故佛经说无所有处是舍。答曰。圣道是舍。彼是最后可得处。是故名舍。尊者和须蜜说曰。无边行是粗观。离彼欢喜。得寂静故名舍。尊者佛陀提婆说曰。更不念无边行。心无势用。而住于舍。云何非想非非想处。答曰。过一切无所有处。入非想非非想处。是名非想非非想处。问曰。何故名非想非非想处。答曰。无了了想相。无了了无想相。无了了想相者。无如七想定相。无了了无想相者。无如灭尽定无想定相。而彼想痴騃不了了不决定故。名非想非非想。入者若得成就非想非非想处善四阴。是名入

欲界非想非非想处无无漏。问曰。何故欲界非想非非想处无无漏耶。答曰。非其田器。乃至广说。复次对治有根本故。有根本有二。一是欲界。二是非想非非想处无漏道。是有根本对治故。不同一处。复次对治二边故。边有二种。一是欲界。二是非想非非想处。无漏道对治二边故。住于中道。复次欲界是不定界。非离欲地。非修地。非想非非想处。是愚騃不了了。不决定。不猛利。圣道是定是猛利。复次欲界掉偏多。非想非非想处定偏多。圣道定慧多。复次非想非非想处。不决定如疑。圣道决定

佛经说禅名入。说无色定名过。问曰。何故佛经说无色定名过。不说禅耶。答曰。佛经亦说禅名过。如优陀耶经说。优陀耶比丘。离欲恶不善法。有觉有观。离生喜乐入初禅。优陀耶。我亦说此法。是不定。是断是过。乃至第四禅说亦如是。问曰。唯一经中。佛说禅是过。诸经中。多说无色定是过。答曰。以禅有种种不相似相故。不名为过。无色定无种种不相似相故说名过。复次禅中多说功德善利。不名为过。无色定中。无多功德善利故说名过。复次禅是粗是现见。不名为过。无色定微细难见故说名过。复次禅是遍照法缘于上地。亦缘下地。亦缘自地。故不名为过。无色定虽缘自地。亦缘上地。不缘下地。故说名过。复次以禅有往来躁动。生欲界中。不死不生。以神足力。到第四禅。第四禅中。亦来欲界。似如不能有所过故。不名为过。无色定无来去故说名过。复次禅有中有扰乱故。欲界中乃至第四禅中有现在前。第四禅乃至欲界中有现在前。无色中无中有故说名过。复次禅中生上起下地心现在前。如识身变化心。不名为过。无色定生上不起下地心现在前故说名过。复次禅生上有下地法相续。如识身变化心。不名为过。无色定生上无下地相续法故说名过。以如是等事故。说无色。定是过。不说于禅。空处寿二万劫。识处寿四万劫。无所有处寿六万劫。非想非非想处寿八万劫。问曰。何故无色界生处。或增倍寿。或不增者。答曰。彼有尔许报因势故。有尔许报。复次空处识处。有无边行。亦有余行。空处无边行报寿万劫。余行报寿万劫。识处二万劫。是无边行报二万劫。是余行报。上地无无边行故无报。复次以空处识处有定有慧。空处定报寿万劫。慧报寿万劫。识处定报寿二万劫。慧报寿二万劫。上地慧少故报亦少。复次无色生处二万劫是定寿。以离欲故。一地增二万劫寿。识处二万劫。是定寿二万劫。是离空处欲寿。无所有处二万劫。是定寿四万劫。是离空处识处欲寿。非想非非想处二万劫。是定寿六万劫。是离空处识处无所有处欲寿

八解脱。观色是色是初解脱。内无色想观外色是第二解脱。净解脱身作证得成就是第三解脱。过一切色想灭有对想无种种想思惟。入无边空处是第四解脱。过一切空处。入无边识处是第五解脱。过一切识处。入无所有处是第六解脱。过一切无所有处。入非想非非想处是第七解脱。过一切非想非非想处。入灭受想身作证得成就是第八解脱。问曰。解脱体性是何。答曰。初解脱第二第三解脱。是无贪善根。对治于贪取。其相应回转。欲界是四阴色界是五阴。空处。识处。无所有处。非想非非想处解脱。是四阴。灭受想解脱。是不相应行阴所摄。此是解脱体性。乃至广说

已说体性所以今当说。何故名解脱。解脱是何义。答曰。背弃义是解脱义。问曰。若背弃义是解脱义者。何等解脱背弃何处心。答曰。初解脱。第二解脱。背弃色爱心。第三解脱。背弃不净心。空处解脱。背弃下地法。乃至非想非非想处解脱。亦背弃下地法。灭受想解脱。背弃一切有缘心。是故背弃义是解脱义。尊者和须蜜说曰。得解义是解脱义。心于烦恼得解得净故名解脱。尊者佛陀提婆说曰。虚想观得解故名解脱

界者初解脱第二第三解脱。在色界空处识处无所有处解脱。有漏者在无色界。无漏者是不系。非想非非想处解脱。灭受想解脱。在无色界。地者初解脱第二解脱。在未至中间。及初禅第二禅上地亦有。与此相似善根。而不立解脱。所以者何。为对治欲界色爱故。立初禅不净解脱。对治初禅色爱故。立第二禅不净解脱。第二禅无色爱故。第三禅不立不净解脱。第三禅无色爱故。第四禅不立不净解脱。净解脱在第四禅。下地亦有。与此相似善根。而不立解脱。所以者何。净解脱对治不净。不为不净所摧伏。若当下地立净解脱者。则为不净所摧伏。空处解脱在。空处。问曰。空处法。何者是解脱。何者非解脱。答曰。离第四禅欲时。九无碍八解脱。死时善空处非解脱。余善空处是解脱。识处解脱在识处。问曰。识处法。何者是解脱。何者非解脱。答曰。虽空处欲时。九无碍八解脱。死时善识处非解脱。余善识处是解脱。无所有处解脱。在无所有处。问曰。无所有处法。何者是解脱。何者非解脱。答曰。若离识处欲时。九无碍八解脱。死时善无所有处非解脱。余善无所有处。是解脱。非想非非想处解脱。在非想非非想处。问曰。非想非非想处法。何者是解脱。何者非解脱。答曰。离无所有处欲时。九无碍八解脱。死时善非想非非想处非解脱。余善非想非非想处是解脱。灭受想解脱。在非想非非想处。所依者。初解脱第二第三解脱。依欲界身。灭受想解脱。依欲色界身。余解脱。依三界身。行者初解脱第二解脱行。不净行。净解脱行净行。四无色解脱行。十六行或行余行灭受想解脱不行行。缘者初解脱第二第三解脱缘欲界。为缘何法。答曰。缘色入。空处解脱。缘四无色及彼因。彼灭一切比智分及比智非数灭。四无色非数灭缘一切虚空。若一相若异相。识处解脱。缘三无色及彼因。彼灭一切比智分及比智非数灭。三无色非数灭。缘一切虚空。若一相若异相。无所有处解脱。缘二无色及彼因。彼灭一切比智分及比智非数灭。二无色非数灭。缘一切虚空。若一相若异相。非想非非想处解脱。缘非想非非想处及彼因。彼灭一切比智分及比智非数灭一无色定非数灭。缘一切虚空。若一相若异相。灭受想解脱。无所缘。念处者。初解脱第二第三解脱。与身念处俱。四无色解脱。与四念处俱。灭受想解脱。若以亲近念处。性念处者。则不与俱。若以缘念处者。是法念处。智者初解脱第二第三解脱。与等智俱。空处识处无所有处解脱。与六智俱。除法智他心智。非想非非想处解脱。与等智俱。灭受想解脱。不与智俱。定者初解脱第二第三解脱。非想非非想处解脱。灭受想解脱。不与定俱。空处识处无所有处解脱。或与定俱。或不与定俱。根者初解脱第二解脱。与喜根舍根相应。灭受想解脱。不与根相应。余解脱。与一舍根相应。世者在三世。缘三世者。初解脱第二第三解脱。过去缘过去。现在缘现在。未来必生者缘未来。不生者缘三世。四无色解脱。缘三世及非世。灭受想解脱。无所缘善不善无记者。是善缘善不善。无记者初解脱第二第三解脱。缘善不善无记。四无色解脱。缘善无记。灭受想解脱。无所缘。三界系及不系者。三是色界系。二是无色界系。余三有漏者。无色界系。无漏者不系。缘三界系及不系者。三缘欲界系。四缘无色界系及不系。一是不缘。学无学非学非无学者。五是非学非无学。三是学无学非学非无学。缘学无学非学非无学者。三缘非学非无学。四缘三种。一无缘。见道断修道断不断者。五是修道断。三若有漏者是修道断。无漏者不断。缘见道修道断不断者。三缘修道断。四缘三种。一无所缘。缘名缘义者。三缘义。四若说无色界有名者。缘名缘义。若说无名者缘义。一无所缘。缘自身他身非身法者。初解脱缘自身他身。第二第三解脱。缘他身。四无色解脱。缘自身他身及非身法。一无所缘。为是方便得为是离欲得者。灭受想解脱。是方便得。余是离欲得。亦是方便得。若在初禅者。离欲界欲时得。乃至若在非想非非想处者。离无所有处欲时。得方便得者。以方便现在前。佛不以方便现在前。辟支佛以下方便。声闻或以中。或以上方便为是本得。为是未曾得者。灭受想解脱。是未曾得。余是本得。亦是未曾得。圣人佛法凡夫。是本得未曾得。余凡夫是本得。八解脱广说如上。观色是色。是初解脱者。现见修内色想。不离内色相。观外色若青若脓。若膖若胀。若骨若骨锁。是名初解脱。初者。次第数在初故名初。随顺次第义在初故名初。复次次第入定时数在初故名初。随顺次第义入定时在初故名初。解脱者入是定时。善色受想行识。是名解脱。内无色想。观外色者。不现见修内色相。离内色想。观外色若青广说如上。是名第二解脱。第二义解脱义亦如上说。问曰。为观外色时亦观内无色想。为观外色已复观内无色想耶。若观外色时亦观内无色想者。云何一心缘于二法。若能缘二法。亦可缘多法。若观外色已复观内无色想者。此中所说云何通。如说。内无色想观外色。答曰。应作是说。若观外色时。是时不观内无色想。问曰。若然者此中所说云何通。如说。内无色相观外色。答曰。行者有如是期心故。作如是说。行者作如是期心我不观内色。但观外色。有如是期心故。佛作是说。复次此中说。行者先分别观察时故佛作是说。复次以义定故。若观内无色想。则定观外色。若观外色。则定观内无色想。复次此中说善根及方便内无色想。是善根方便观外色者。是满足善根。复次内无色想者。是其心观外色。是所缘净解脱身作证得成就。是名第三解脱。问曰。净解脱为观色是色。为内无色想观外色耶。若观色是色者。初解脱第三解脱。有何差别。若内无色想观外色者。第二解脱第三解脱。有何差别。答曰应作是说。内无色想观外色。问曰。若然者第二解脱第三解脱。有何差别。答曰。名即差别。是名第二解脱。是名第三解脱。复次第二解脱在初禅。第二禅第三解脱。在第四禅。复次第二解脱。在内道外道身中。净解脱唯在内道身中。复次第二解脱。行不净行。第三解脱。行净行。复次第二解脱。对治色爱第三解脱。对治不净。复次第二解脱。不多所作不多用功而得。净解脱。多有所作多用功而得。复次第二解脱体明净。缘不明净体。胜妙缘不胜妙。净解脱体胜妙。缘胜妙体。明净缘明净。净解脱缘净。问曰。行者何故净解脱观缘净。答曰。欲试善根故。行者作是念。我作不净观。烦恼不生。未知此善根为满足不。复试观净。烦恼亦复不生。便知善根已得满足。复次行者观不净故心劣。心劣故不能修胜进善根。复次净观令心欣踊。能修胜进善根。犹冢间比丘。常观死尸故。心则劣弱。不能修胜进善根。便从住处。往清净妙好河池园林之中。观世种种胜妙之事。心生欣踊。然后能生胜进善根。彼亦如是。复次行者作不净观。心常愁戚。无欢喜时。则不能修胜进善根。若以净观。舍不净心。能修胜进善根。复次欲现自心坚牢故。彼作是念。我心坚牢。乃至作净观。犹不生烦恼。复次欲现善根有大势用故。复作是念。此善根有大势用。乃至缘净法。犹不生烦恼。复次欲现自心坚牢亦现善根有大势用故。彼作是念。我心坚牢善根有大势用。观净境界。犹不生烦恼。复次净解脱。非凡夫常人能起。若行者好喜净洁。从摩[少/兔]摩天中来。曾闻有一比丘。以日入时。往诣佛所。从佛索房。尔时佛告阿难。汝为此比丘。求住房舍。尔时阿难。示彼比丘房时。彼比丘语阿难言。汝可极净扫洒此房。悬缯幡盖。散种种华。烧众名香。敷软床蓐。安置好枕。尔时阿难。具以是事。往白世尊。佛告阿难。如彼比丘所须。悉办具足。尔时阿难。即为办具。时彼比丘。入此房中。坐其床座。以夜初分。起净解脱因。是次第得尽诸漏。成阿罗汉。获得神通。晨朝以神足力。忽然而去。尔时阿难。晨朝诣彼比丘所入房。但见严正床座。不见其人。见是事已。往诣佛所。而白佛言。彼比丘。严正床座。不知何去。佛告阿难。汝于彼比丘。莫生轻心。彼比丘。昨夜起净解脱。得尽漏。成阿罗汉。获得神通。以神通力。忽然而去。阿难当知。彼比丘者。好喜净洁。从摩[少/兔]摩天中来。若不得如是清净房舍床座卧具者。则不能起是善根。以是事故。知净解脱非凡常人能起居好喜净洁。从摩[少/兔]摩天中来者。则能起净解脱。第三义解脱义如上说。空处识处无所有处非想非非想处解脱。广说如四无色定灭受想解脱。灭尽定处。当广说。第八义解脱义如上说

阿毗昙毗婆沙论卷第四十三阿毗昙毗婆沙论卷第四十四

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    使犍度十门品之八

问曰。何故禅中余善根立解脱。无色定中。尽立解脱耶。答曰。以禅是粗现见了了故。余善根立解脱。无色定是细不现见不了了故。尽立解脱。复次禅中有种种不相似善根故。余善根立解脱。无色定无种种不相似善根故。尽立解脱。复次禅中多诸功德善利故。余善根立解脱。无色定无多功德善利故。尽立解脱。复次禅能遍照缘于上地。亦缘下地缘于自地。余善根立解脱。无色定不能遍照。能缘上地自地。不缘下地。是故尽立解脱。复次禅解脱。是有漏。无色定解脱。是有漏无漏。如是因论生论。何故禅中解脱是有漏。无色定中解脱。是有漏无漏耶。答曰。先所说四答。此中应说。余有一异答。禅解脱是虚观。无色定解脱是实观

佛经说解脱名方。问曰。何故佛说解脱名方。答曰。为教化故。受化者。应闻说解脱名方。乃得悟解。是故佛以方名说解脱。如余经说。谛名方。有受化者。应闻说谛名方。乃得悟解。是故佛说谛名方。此亦如是。问曰。解脱与方有何相似。答曰。八法相似。解脱有八。方亦有八。问曰。方应有十。谓四方四维及上下。何故说八。答曰。如调象法故应有八。调象之法。必向四方及四维。不能令其向于上下。譬如以方故调于龙象。如是以方便故得解脱。尊者瞿沙。作如是说。调象解脱有三事。同三事。异三事。同者一以方故。龙象可调。解脱亦尔。以除障故。众生能得解脱。二如调龙象。趣于一方时。不能复趣余方。佛教众生解脱之法。亦复如是。得一解脱时。无二无多。三如调龙象。趣一方时便远余方。世尊为众生说解脱法。亦复如是。一解脱现在前。余解脱便远。三事异者。一如调龙象。若不趣方。则不能调。佛说解脱法。住一处而无所趣。能令众生得解脱法。二如调龙象。趣一方时。不能复趣余方。佛说解脱法不尔。能于一时。说八解脱法。而令众生皆得悟解。三如调龙象。趣一方时。皆远余方。佛说解脱法不尔。为诸众生。说一解脱法。而作方便。令余解脱法皆近。复次此中说最胜调御法。曾闻拘萨罗王波斯匿。敕捕象人。使捕野象。若得象者。来白于我。时捕象人。闻王教敕。即捕野象。来白王言。大王当知。今已捕得野象。王闻是语。敕调象师。令调野象。若善调伏。便来白我。时调象师。受王教敕。即以种种苦切之事。调于野象。能令调伏。如旧调象。时调象者。知象已调。来白王言。大王当知。先敕调象。今已善调。大王应知是时。尔时波斯匿王。与调象师共乘此象。出田游猎时。象见雌象群。欲心炽盛。而便驰走趣雌象群。时调象者。欲回制之。尽其方便。不能令回。王及调象者。攀树而下。得自济命。还诣宫城。语调象者。汝以不调之象。令我乘之。法应尔耶。时调象者。而白王言。唯愿大王莫见嗔责。此象实调。当使大王后验此事。时象欲心息已。便还王宫。时调象者。将象诣王。烧热铁丸。置其顶上。于其耳中。而语之言。此是最后调汝不动之法。汝若堪忍则善。若不堪忍。当复以前苦切之事。次第调汝。象闻是语。其身不动其犹如山。时热铁丸。烧象顶。如烧桦皮。王见是事。怪未曾有。即敕象师。去铁丸。语调象言。汝今调象。能令如此。前何故尔。调象人答王言。我能调身。不能调心。时王复问调象人言。世间颇有能调心者不。时调象人答王言有。佛世尊住舍卫国只桓精舍。善能调伏众生身心。尔时波斯匿王。作是思惟。欲得见佛。即与调象人。共乘本象。往诣佛所。尔时世尊。与百千眷属。围绕说法。尔时世尊。见波斯匿王来。以随宜方便。为王说法。非声闻辟支佛所知境界。时世尊告诸比丘。如调象人善调象已趣于一方。若东若西若南若北。调牛之人。善调于牛。调马之人。善调于马。趣于一方。广说如上。比丘当知。无上调御师。善调于人。能趣诸方。何者是方。观色是色。乃至广说解脱。以是事故。知此经说最胜调御

经说有一比丘。往诣佛所。头面礼足。却坐一面。而白佛言。世尊有明界。有净界。有空处界。有识处界。有无所有处界。有非想非非想处界。有灭界。世尊为以何故立此诸界。佛告比丘。以闇故立于明界。以不净故立于净界。以色故立空处界。以边故立识处界。以所有故立无所有处界。以实身故立非想非非想处界。以灭实身故立灭界。问曰。彼比丘为问。佛何义。佛答。彼比丘何义。答曰。彼比丘。以覆相问八解脱义。佛亦以覆相答八解脱义。明界者。是初二解脱。净界者。是净解脱。空处界者。是空处解脱。识处界者。是识处解脱。无所有处界者。是无所有处解脱。非想非非想处界者。是非想非非想处解脱。灭界者灭受想解脱。问曰。彼比丘。何故以覆相问佛八解脱义。答曰。彼比丘少欲知足。覆藏善法。不欲以已功德显示他人故。问曰。佛何故以覆相说八解脱。答曰。欲满彼比丘心所愿故。彼比丘心作是念。若佛以覆相为我说八解脱者则善。佛是满他愿者。善知根性者。为彼比丘心所念故。覆相而说。比丘当知。明界是初二解脱。为闇故者。闇者是欲界色爱。初二解脱。是彼对治。以彼色爱故。立二解脱。以不净故立净界者。不净是初二解脱净解脱。是彼对治。以彼故立净解脱。以色故立空处界者。色是第四禅空处解脱。是彼对治。以彼故立空处解脱。以边故立识处界者。边是空处识处解脱。是彼对治。以彼故立识处解脱。问曰。空处何故名边。答曰。色尽处是色边故名边。以所有故立无所有处界者。所有者是识处。以有无边行故。无所有处解脱。是彼对治。以彼故立无所有处解脱。以实身故立非想非非想处界者。实身者。是无所有处。非想非非想处解脱。是彼对治。以彼故立非想非非想处解脱。以灭实身故立灭界者。灭实身名非想非非想解脱灭受想解脱。是彼对治。以彼故立灭受相解脱。问曰。非想非非想处何故名灭实身。答曰。实身是无所有处非想非非想处。是彼对治故言灭时。彼比丘。闻佛所说。欢喜随顺复更问佛。世尊明界。乃至灭界。为以何定而得。佛告比丘。明界乃至灭界。以行定得。或有说者。彼比丘。问次第得。或有说者。彼比丘问断。若作是说。彼比丘问次第得者。行定是初禅边。乃至无所有处边。初禅边者。离欲爱得初二解脱。第四禅边者。离三禅欲。得净解脱。空处边者。离第四禅欲。得空处解脱。识处边者。离空处欲。得识处解脱。无所有处边者。离识处欲。得无所有处解脱。此中余者。非想非非想处解脱。灭受相解脱。佛告比丘。非想非非想处解脱。以胜行定得。胜行定者。是非想非非想处边。以胜行定。离无所有处欲。得非想非非想处解脱。灭界者。以灭受想处定得。灭受想定者。是非想非非想处定。所以者何。入定出定。心在彼处故。若作是说。彼比丘问断者。行定是有漏无漏对治。是故能离欲界。乃至离无所有处欲。此中余者非想非非想处解脱。灭受想解脱。比丘非想非非想处解脱。以胜行定得。胜行定者。是无漏对治。世俗道。于离非想非非想处。衰退转还。是故以无漏对治。离非想非非想处欲。灭界者。以灭实身得。灭实身者。是灭尽涅槃。以灭尽涅槃故。而修灭受想定。比丘以闇故立明界者。闇是境界闇。初二解脱。是彼对治。复有说者。彼比丘。离三界欲。以覆相广略问佛。佛亦以离三界欲覆相广略而答。明界者。是现离欲界欲。方便净界者。是略现离欲界欲。空处界者。是略现离色界欲。识处界。无所有处界。非想非非想处界。是广现离无色界欲。灭界是略现离无色界欲。比丘以闇故立明界者。闇者是胜妙五欲爱。初二解脱。是彼对治。譬喻者。作如是说。彼比丘以覆相问八种定。佛亦以覆相说八种定。解此经者。有增有减。于此经。应作而不作。不应作而作。应说广界而不说是减。不应说减界。而说是增。今当离于增减。而解此经。明界者。是初禅二禅。净界者。是第三第四禅。空处界者。是空处。识处界者。是识处。无所有处界者。是无所有处。非想非非想处界者。是非想非非想处。比丘以闇故立明界者。闇是诸盖。初禅二禅。是彼对治。尔时比丘。闻佛所说。欢喜随顺而去

有灭尽定。问曰。何故作此论。答曰。为止并义者意故。或有说者。灭定有心。彼作是说。无有无色众生无心之定。如尊者佛陀提婆。作如是说。若灭定无心者。不应说有从彼定起者。是名为死。不名为定。为止如是说者意故。亦现离无所有处欲。非想非非想处心。次第起彼定现在前。是故尊者和须蜜。作如是说。云何灭定。答曰。离无所有处欲。作休息想心。令心心数法灭。以是事故。根犍度作如是说。入灭定时。为灭几根。答曰七。谓意根舍根信等五根。何系心心数法灭。答曰。无色界系。总而言之。是无色界系。而是非想非非想处心心数法。灭从灭定起时。几根现在前。答曰。或七或八。有漏心七。无漏心八。若从彼定起心。是非想非非想处心。起七根现在前。谓意根舍根信等五根。若是无所有处心。起八根现在前。上所说七。知根知已根。若一现在前。何系心心数法现在前。答曰。有漏心。是无色界系。无漏心是不系。若出定心。是非想非非想处者是无色界系。心心数法现在前。若出定心是无所有处者。起不系心心数法现在前。以是事故。明灭定无心。所以者何。入定时说灭。出定时不说灭。出定时说现在前不说灭。以是事故。而作此论

问曰。灭定体性是何。答曰。是心不相应行阴。界者在无色界。地者在非想非非想处地。非下地。问曰。何故下地无灭定。答曰。非其田器。乃至广说。复次彼定无心心断起现在前。非想非非想处随顺断心。问曰。云何非想非非想处随顺断心。答曰。若欲入彼定者。欲界善心。次第起初禅心现在前。乃至无所有处心。次第起非想非非想处心现在前。非想非非想处心心数法。有上中下。舍上心。起中心。舍中心。起下心。舍下心。在彼定。是故非想非非想处随顺断心。犹如女人纺毳随转随续毳。若尽时更不转续。彼亦如是。复次二灭心定。俱在二界边。无想定在色界边。灭定在无色界边。复次此二定。俱在二地边。无想定在第四禅地边。灭定在非想非非想处地边。复次无想定在四大造色边。灭定在心心数法边。复次一切地。尽有二种过。一过欲。二过住处。过初禅欲者。以自地无漏。过初禅住处者。以第二禅。乃至过无所有处欲者。以自地无漏。亦以下地。过无所有处住处者。以非想非非想处。过非想非非想处欲者。以下地无漏。过非想非非想处住处者。以灭定。若当下地有灭定者。下地或有二种过。或有三种过。非想非非想处。唯有一种过。欲令无如是过故。不说下地有灭定。复次灭定以二事故立解脱。一以背舍一切缘法。二以灭最后边心。若下地有灭定者。不名背舍一切心。所以者何。不尽背舍一切心法故。亦非灭最后边心。所以者何。灭中心故。复次此定是次第定。非想非非想处心次第生此定。以如是事故。下地无灭定

云何灭定。答曰。佛经说过一切非想非非想处。问曰。灭定是非想非非想处法。何以言过一切非想非非想处。答曰。虽是彼处法。以寂静故言过。犹如村落阿练若处。复次非想非非想处有二种。一有心二无心。过一切非想非非想处者。过于有心非想非非想处。灭受想解脱身作证得成就者。是说无心非想非非想处。如有心无心。相应不相应。有依无依。有行无行。有势用无势用。有缘无缘。当知亦如是。复次非想非非想处有二种。谓染污不染污。过一切非想非非想处者。过染污非想非非想处。灭受想解脱身作证得成就说不染污非想非非想处。如染污不染污。见道断修道断。当知亦如是。复次非想非非想处有二种。谓本得未曾得。过一切非想非非想处者。过本得非想非非想处。灭受想解脱身作证得成就者。是未曾得非想非非想处。如本得未曾得。共不共离欲得方便得。当知亦如是。复次此中说次第过诸地故。先次第过诸地欲。后过有心住非想非非想处。问曰。无学人可尔。所以者何。无学人于非想非非想处。有二种过。一离欲过。二住处过。学人于非想非非想处。无二种过。过一切非想非非想处。云何可尔。答曰。一切有二种。有少分一切。有一切一切。此中说少分一切。复次此中说住处过。学人虽无非想非非想处修道所断欲过。而有住处过。复次此说须臾过。彼须臾灭非想非非想处有心。次生非想非非想处无心灭受想定身作证得成就者。问曰。入彼定时。余心心数法尽灭。何故世尊但说灭受想耶。答曰。譬喻者。说彼定有心。彼作是说。入彼定时。唯此二法灭。问曰。我不问彼我问说此言无心者。何故尔耶。答曰。佛说受想灭。当知余心心数法亦灭。复次以此二法名义胜故。彼心聚中。谁为最胜。此二法最胜故。佛说复次此现初门现略现始入法故。心心数法有二种。或是根性。或非根性。若说受当知已说根性。若说想当知已说非根性者。如根性非根性。明非明。胜不胜。妙不妙。当知亦如是。复次此二法。于二界中。极为行者。而作疲劳。受于色界。想于无色界。是故世尊说此二法。复次以此二法于二界中胜故。受于色界中胜。想于无色界中胜。复次以此二法能生二种恼。谓爱恼见恼。受能生爱恼。想能生见恼。复次此二法。能起二种斗诤根本。受能起贪着欲爱系缚斗诤根本。想能起见爱贪着系缚斗诤根本。如二斗诤根本。二边二箭二戏论二我。当知亦如是。复次因乐受故。生颠倒想。令诸众生。于生死中。受大苦恼。是故世尊说灭此二法。复次行者憎恶此二法故起灭定。如施设经说。行者以何方便求灭定。答曰。初行者。欲令诸行。更无所作。更无所思。令我受想不生。已生者灭。未生受想令不生。已生受想令灭。是灭于此灭法无障碍。不问他得自在。身作证是名定。以是事故。世尊说灭此二法。问曰。灭之与定有何差别。答曰。灭是一刹那。定是久相续。问曰。心不动故名定。此中心断无心云何名定。答曰。不动有二种。一心不动。二四大不动。此中虽断心不动。而四大不动相续生。以四大不动故名定。问曰。二无心定。何故灭定立解脱。无想定不立耶。尊者波奢说曰。佛决定知法相。亦知势用。余人不知。若法有解脱相者立解脱无解脱相者不立。复次若定是内道法立解脱。若定是外道法不立解脱。如内道外道。圣人凡夫。背烦恼起烦恼。背炽然起炽然。说亦如是。复次舍我见起无我见身中可得者立解脱。若起我见舍无我见身中可得者不立。复次若舍身见起空现在前身中可得者立解脱。若不起空现在前起身见者不立。复次先作是说。以二事故。灭定立解脱。一舍一切缘法。二灭最后边心。无想定无此二事故。不立解脱。复次若更不生诸界诸生诸趣身中可得者立解脱。若更生诸界诸生诸趣身中可得者不立。复次背弃义。是解脱义。得灭定者。背舍诸界诸生诸趣。增长生死法。无想定不尔。以如是事故。二无心定。灭定立解脱。无想定不立。问曰。灭定无想定有何差别。答曰。名即差别。是名灭定。是名无想定。复次界亦差别。无想定色界系。灭定无色界系。复次地亦差别。无想定在第四禅地。灭定在非想非非想地。复次身亦差别。无想定在凡夫身。灭定在圣人身。复次凡夫人入无想定作离想。圣人入灭定作休息想。复次凡夫人厌患想入无想定。圣人厌患受想入灭定。复次凡夫人入无想定。欲灭于想。圣人入灭定。欲灭受想。复次凡夫人入无想定。灭色界系心心数法。圣人入灭定。灭无色界系心心数法。复次凡夫人入无想定。灭第四禅地心心数法。圣人入灭定。灭非想非非想地心心数法。复次凡夫人入无想定。得色界报。圣人入灭定。得无色界报。尊者和须蜜说曰。无想定灭定。有何差别。答曰。一是无想定。二是灭定。复次界亦差别。无想定是色界系。灭定是无色界系。余广说如上。复次凡夫人入无想定。得无想果。圣人入灭定。得非想非非想处果。复次凡夫人入无想定。得色界系报。学人入灭定。得无色界系报。无学人入灭定。得余依。无想定灭定。是谓差别。问曰。何故佛经说八解脱二解脱。说身作证耶。答曰。八解脱尽应说身作证如大因缘经说。八解脱身作证得成就。问曰。何故一经说八解脱身作证。多经说二解脱身作证耶。答曰。此二解脱。多有所作。多用功而得故。复次以名义胜故。八解脱中。何者最胜此二解脱。复次此二解脱。俱在界边。净解脱。在色界边。灭受想解脱。在无色界边。复次此二解脱。俱在地边。净解脱。在第四禅地边。灭受想解脱。在非想非非想地边。复次净解脱。尽四大造色而立。灭受想解脱。尽心心数法而立故。复次净解脱。取色净相。而不生烦恼。是故佛说身作证得成就。灭受想解脱。无心在身不在心。以身力起现在前。不以心力。是故佛说身作证得成就。复次经说八解脱身作证者。皆以此二解脱故。得成就者得成就。有多处说。或说色阴少分是得成就。或说善五阴。或说善四阴。或说心不相应行阴少分。或说灭尽涅槃。说色阴少分。得成就者。如偈说

  汝于胜慧法　　得成就于戒
  一切皆贤善　　广有诸珍宝

善五阴者。如说。得成就初禅。乃至第四禅。善四阴者。如说。得成就空处乃至非想非非想处。心不相应行阴少分者。如此中说。灭受想解脱灭尽涅槃者。如说。得成就灭尽涅槃。问曰。灭定有几种。答曰。或有说者。有四种。一具缚人所起灭定。二断上三种结。三断中三种结。四断下三种结。复有说者。此定有四种。非具缚起者。是断六种七种八种九种结起者。复有说者。此定有九种。断上上结起者。乃至断下下结起者。复有说者。此定有十种具缚起者。断上上结起者。乃至断下下结起者。问曰。若具缚人。能起灭定者。凡夫人亦能起。答曰。具缚人有二种。一见道所断具缚。二修道所断具缚。若无非想非非想处见道所断具缚。有修道所断具缚者。能起灭定。若有二具缚者。则不能起。评曰。应作是说。灭定有十一种。具缚人。起灭定者。断上上结起者。乃至断下下结起者。时解脱转根作不动起者。问曰。若具缚者所起灭定。乃至时解脱转根作不动者所起灭定。即是具缚者所起灭定耶。答曰。或有说者。即是。问曰。若然者。云何有十一种。答曰。以十一时起故。有十一种。复有说者。具缚者所起异。乃至不动法所起异。问曰。若然者。具缚者所起。乃至不动者所起。有何差别。答曰。具缚者所起。后断一种结所起者。于前具缚者所起。得不在身中成就。不现前行。断一种结所起者。得在身中成就。现在前行。乃至不动法所起。于时解脱所起。得不在身中成就。不现前行。不动法所起。得在身中成就现在前行

问曰。此定为有上中下不耶。若有上中下者。施设经说云何通。如说。灭法无有差别若无上中下者。佛所有定。即是声闻辟支佛定也。答曰。应作是说。此定无上中下。问曰。若然者。施设经说善通。灭法无差别故。佛所有定。即是辟支佛声闻定也。答曰。如佛心断入此定。辟支佛声闻心断入此定。等无差别。而方便有差别。佛不以方便起此定现在前。辟支佛以下方便。声闻或以中。或以上方便。评曰。应作是说。此定有上中下。问曰。若然者。佛定异。辟支佛声闻定异。此说善通。施设经说云何通。如说。灭法无有差别。答曰。以住心故。施设经说灭法。无有差别。定是有为故。应有上中下。所以者何。一切有为法。有上中下相

问曰。此定体为有几耶。答曰。或有说者。体有一。若灭现在前则无心。问曰。若灭刹那现在前。即彼刹那。名无心耶。答曰。如是。若灭刹那现在前。即彼刹那名无心。如一受刹那。即彼刹那。名为有受。一想刹那。即彼刹那。名为有想。一识刹那。即彼刹那。名为有识。彼亦如是。若一刹那灭。即彼刹那名无心。复有说者。此定体有十一。所以者何。彼灭十大地及心故。复有说者。体有二十一种。所以者何。彼灭十大地十善大地及心。评曰。应作是说。随灭几种心数法。彼定体亦有尔许种。此是定体。定相云何。答曰。体即是相。相即是体。诸法不可离体别说相。尊者和须蜜说曰。心法解脱是其相

问曰。此定不能断结。何故说名心法解脱。答曰。此说须臾断。有缘法令不行名解脱。而此定不能断结。复有说者。若法想微细。为其作因。微微作次第。不与此法俱。而成就是解脱

问曰。此为说何义。答曰。或有说者。此中说定。若作是说。此中说定者想微细。为其作一因。谓相似因。与微微作一因。谓相似因微细。亦作次第缘。若作是说。此中说定若法想微细。为其作因微微为其作次第者。不应说不俱。所以者何。彼人起定现在前故。应说成就。所以者何。彼人成就定故。复有说者。此中说出定心。若作是说。此中说出定心者。想微细。为其作一因。谓相似因。微细亦作次第缘。若作是说。此中说出定心者。若法想微细。为其作因。微微作次第。应说不俱。所以者何。入定时。不起出定心现在前故。应说成就。所以者何。彼人成就出定心故。以是事故。知彼人本得出定心。复有说者。此中说入定心。若作是说。此中说入定心者。想与定作一因。谓相似因。微细与定作一因。谓相似因。亦作次第缘。若作是说。此中说入定心者。应作是说。想微细与定作因。定与微细作次第。应说不俱。所以者何。在定时不起入定心现在前。应说成就。所以者何。在定时成就入定心故。问曰。此中何者是想。何者是微细。何者是微微。答曰。或有说者。空处识处是想。无所有处是微细。非想非非想处是微微。复有说者。空处识处无所有处是想。非想非非想处是微细。若心心数次第入定者是微微。复有说者。非想非非想处。亦是想。亦是微细。亦是微微。所以者何。非想非非想处。有上中下。上者是想。中者是微细。下者是微微。问曰。想微细微微。有何差别。答曰。或有说者。名即差别。是名为想。是名微细。是名微微。复次上者是想。中者是微细。下者是微微。复次想微细。能令未来无漏道修。微微不修。复次想微细现在前时。三念处。若一念处现在前。未来四念处。修微微现在前时。法念处现在前。未来修三念处。除身念处。复次想微细。或曾得或不曾得。微微是曾得。问曰。此中因论生论。何故入定心。或曾得或不曾得。出定心唯曾得。答曰。入定心难得。多有所作多用功乃得。出定心易得。不多有所作不多用功而得。是故唯是曾得。复次入定心。能增益定。令定相续。出定心。不增益定。令定衰退不相续。复次入定心。是有漏。或是曾得。或未曾得。出定心。是有漏无漏故。唯是曾得。此中因论生论。何故入定心有漏。出定心有漏无漏耶。答曰。随顺断心故。入定心。不坚牢羸劣。如腐种子不能生相续法。随顺断心。出定心。坚牢不羸劣。不如腐种子能生相续法。不随顺断心。复次入定心。以定为寂灭。无漏心不计有法是寂灭。复次此是次第定。非想非非想处心。次第起此定。最后无漏。在无所有处

问曰。入定心。为何所缘。出定心。为何所缘。答曰。入定心缘定。出定心亦缘定。问曰。若入定心缘定出心亦缘定者。何不入定时出定。出定时入定耶。答曰。入定时期心欲入。出定时期心欲出。复次入定心缘未来定。出定心缘过去定。问曰。入定心缘未来定时。为何所缘。答曰。或有说者。缘初刹那。复有说者。缘随起几所定现在前。评曰。应作是说。入定心缘未来定。则不可知。为缘何法。为不缘何法。所以者何。未来法是乱法。多刹那无次第。以总缘故。言缘未来定。问曰。出定心缘过去法时。为何所缘。答曰。或有说者。缘最后刹那。复有说者。缘随所起。几所定现在前。评曰。应作是说。出定心缘过去定。则不可知为缘何法为不缘何法。所以者何。过去法有多刹那故

问曰。入灭定时灭何等心。过去耶。未来耶。现在耶。若灭过去者。过去已自灭。若灭未来者。未来未生。若灭现在者。现在不住。若定不灭。彼亦自灭。答曰。应作是说。灭未来者。问曰。未来法未生。云何可灭耶。答曰。行者住现在世。遮住未来心。令不生故言灭。譬如城邑。若断道闭门。竖于高幢。不令人出入。则名为救。彼亦如是。复有说者。灭未来现在心。问曰。行者住现在世。遮住未来心。使不生言灭可尔。现在法不住。若定不灭。彼亦自灭。云何言灭。答曰。先现在灭心心数法。令有缘法相续而灭。今现在灭心心数法。令有缘法不相续而灭。皆是定力

问曰。出定时何心心数法现在前。答曰。或有说者。先所遮住未来心心数法。复有说者。起未来心心数法现在前。先所遮住者。在不生法中。评曰。应作是说。起未来心心数法。但不可知为起何心为不起何心。所以者何。未来法是乱。是多刹那。是无次第

问曰。此定为有过去本得未来修不耶。答曰。或有说者。无过去本得。亦无未来修。如天眼天耳。若作是说。此定无本得无未来修者。定初刹那。成就现在定。第二刹那。等成就过去现在出定。成就过去定。复有说者。此定有过去本得。有未来修。如念前世智他心智。若作是说。此定有过去本得未来修者。定初刹那成就未来现在定。第二刹那。等成就三世出定。成就过去未来定。评曰。应作是说。此定无过去本得。亦无未来修。若此定有过去本得未来修者。若退此定。还起此定。应得本定而不尔。若退此定。还得此定。名得未曾得定。如不破戒而还家者。还复出家。名得未曾得戒。彼亦如是

问曰。于何处起此定。答曰。欲色界。非无色界。初在欲界。若于欲界起灭定。于此定退命终。生色界中。能起此定。余者不能。何以知之。经说。尊者舍利弗。语诸比丘。诸长老当知。若比丘戒具足定具足慧具足者。能数数入出灭受想定。若于现法及死时。不得阿罗汉果。身坏命终。过抟食诸天。生摩[少/兔]摩身天中。复于彼处。数数出入灭受想定。此是实知见。有如此事。尔时长老优陀夷。住彼会中。语尊者舍利弗言。尊者舍利弗。彼比丘生摩[少/兔]摩身天中。数数入出灭受想定。无有是处。第二第三说亦如是。问曰。何故长老优陀夷。三违尊者舍利弗所说耶。答曰。长老优陀夷所疑。非无处所。彼作是念。若得此定者。必离无所有处欲。命终应生非想非非想处。彼处不能起灭定。亦不解尊者舍利弗意。问曰。彼尊者舍利弗有何意耶。答曰。尊者舍利弗。说生色界阿那含。长老优陀夷。说生无色界者。是以违之。尊者舍利弗。说退阿那含。长老优陀夷。说不退阿那含。是以违之。问曰。尊者舍利弗。何故不为长老优陀夷解此义耶。答曰。尊者舍利弗。作是念。我不能除此愚人深着之心。复次尊者舍利弗。有如是心。欲为解说。以优陀夷三违此言故。此心便息。如箭喻经说。尔时有众多增上慢比丘。皆于佛前。自说圣利。我生已尽。乃至广说。佛作是念。我今当为说断慢法。以诸比丘数数自说圣利故。此心便息。佛世尊有遍大悲。欲说法心。犹尚有息。何况尊者舍利弗耶。复次尊者舍利弗。作是念。此所论事。必闻于佛。佛以此事。当呵责优陀夷及长老阿难。当使此辱经历千载。令无智者不违智者之言。尔时舍利弗。作是念。此比丘三违我所说。诸梵行比丘。亦无赞叹我所说者。我今应往诣世尊所。尔时尊者舍利弗。往诣佛所。到已头面礼足。却坐一面。语诸比丘。诸长老当知。若比丘戒具足。乃至广说。尔时长老优陀夷。在彼会中。语尊者舍利弗言。乃至无有是处。尔时尊者舍利弗。作是念。今此比丘。于世尊前。违我所说。诸梵行比丘。亦无称赞我所说者。我今应当默然。尔时舍利弗。即便默然。尔时佛告优陀夷言。汝意以何是摩[少/兔]摩身天耶。以非想非非想天是耶。答言。如是。佛告言。汝愚人无眼。何故与上座比丘。论甚深阿毗昙。尔时世尊。现前呵责优陀夷已。便告长老阿难言。汝见上座比丘为他所恼。无有悲心。于彼愚人。而不呵责。尔时世尊。呵优陀夷已。便还精舍。入于禅定。问曰。长老优陀夷。有过故世尊呵之。长老阿难。复有何过。而被呵耶。答曰。优陀夷是阿难弟子。是故世尊告于阿难。汝应教敕。复次优陀夷是长老阿难摄眷属人。是故世尊告言。汝应教敕。复次长老阿难是维那。佛告阿难。汝为维那。云何不知如法说者非法说者。复次此论说甚深阿毗昙事。非多人所知。唯佛尊者舍利弗能知。长老阿难。以多闻力故能知。以阿难知此法故。不称赞上座比丘所说。不随如法众。有如是过故。世尊责之。以是事知初起灭定必在欲界。若于欲界起灭定。退此定已。生色界中。还起此定。余则不能。问曰。何故生色界中。能初起禅无色定不初起灭定耶。答曰。禅以三事故能起。一以因力。二以业力。三以法应尔力。以因力者。过去近生曾起灭此禅。以业力者。作决定业。必生彼处。法应尔力者。世界坏时。下地众生。必生上地。无色定以二事故能起。一以因力。二以业力。无法应尔力。以因力者。过去近生曾起无色定。以业力者。作决定业。必生彼处。无法应尔力者。无色界中。无世界成坏。灭定以一事故能起。谓解说者。彼解说者。为何处最胜。谓在欲界中。不以因力。所以者何。未曾起此定故。非以业力。所以者何。彼定性非业故。非法应尔力。所以者何。无色界无世界成坏故。问曰。何故欲色界起此定现在前。非无色界耶。答曰。命根依二事存。谓依色依心。此定无心心断故。起现在前。欲色界中。起此定时。心虽断命根。依色而存。无色界无色依心故命存。若无色界起此定者。心断命则断。是名为死。不名为定

问曰。若起此定已。于此定退。命终为生空处识处无所有处不。答曰。不生。所以者何。其所应生。若能起此定处。若能受报处。色界中。虽不受此定报。能起此定。非想非非想处。虽不能起此定。而受此定报处。空处识处无所有处。不能起此定。亦不能受此定报。复有说者。生彼处。但不名身证。不名俱解脱。评曰。应作是说。不生

问曰。住彼定。为经几时。答曰。欲界中。以抟食持诸根四大。欲界虽入定时不令身有患。出定时则有患。是故欲界少时入定。不得久住过于七日。何以知之。曾闻有一僧伽蓝。有一比丘得灭定。食时着衣。诣食堂中。其日彼打揵椎。晚彼比丘。精勤而作是念。我何故空过此时。不观未来。何时当打揵椎。即立誓愿。入于灭定。乃至打揵椎当起。时彼僧伽蓝。有事难起。时诸比丘。皆舍僧伽蓝去。经于三月。难事乃解。时诸比丘。还集会而打揵椎。时彼比丘。起定即死。后有一乞食比丘。获得灭定。以日初分。着衣持钵。欲诣村乞食。时天大雨。彼作是念。若入村者。坏我衣色。若不往者。何故空过此时。不观未来。即立愿入定。乃至雨止当起。或有说者。雨经半月。或有说者。雨经一月乃止。天雨既止。彼比丘起即死。以是事故。知欲界入灭定无患出时有患。是故少时入定。不过七日。色界不以抟食持诸根四大。入此定者。或经半劫一劫。或有过者。问曰。若不立愿入灭定者。云何而起。答曰。如入有心定。法自应起。复次若欲食。若欲大小便。入定虽不作患。出则作患。以是事故。必应自起

问曰。凡夫人。为入灭定不。尊者和须蜜说曰。凡夫人不入此定。所以者何。此是圣人定。非凡夫定。若凡夫人入此定者。亦是凡夫定。复次凡夫人。观上离下地欲。如阇楼虫。非想非非想处。更无上地可缘。离下地欲。是故凡夫人。不入此定。复次凡夫人。数数入定。则数数身猗心猗。以身心猗故。方便则缓。方便缓故。不能起彼定。尊者佛陀提婆说曰。凡夫人不入彼定。所以者何。凡夫人数数入定。我见牢固。畏后边灭法。如畏深坑。是故不能入彼定也。问曰。菩萨为入灭定不。尊者和须蜜说曰。菩萨不入。所以者何。此定是圣人定。若菩萨入此定者。亦应是凡夫定。复次菩萨观上离下地欲。如阇楼虫。非想非非想处。便无上地可缘。离下地欲。是故菩萨不入此定。复次菩萨入灭定。所以者何。菩萨欲求一切智时。作如是念。我应推求一切处相。若菩萨不入灭定者。则于此处不名推求。尊者佛陀提婆说曰。菩萨不入灭定。菩萨虽复摧灭我见。不畏最后灭处。如畏深坑。不欲令慧有留难及断绝故。不欲入灭定非不能入。问曰。菩萨前身时。不曾起灭定。于最后身。而起灭定。为先起灭定后得阿耨多罗三藐三菩提。为先得阿耨多罗三藐三菩提后得灭定。若先起灭定后得阿耨多罗三藐三菩提者。云何不违期心起不相似心。云何名三十四心得一切智。若先得阿耨多罗三藐三菩提后起灭定者。云何名满足学法。得尽智时。云何名所作已竟。外国法师。作如是说。先起灭定。后得阿耨多罗三藐三菩提。问曰。若然者。云何不违期心

答曰。彼作是说。菩萨先离无所有处欲。依第四禅。入正决定。不起此处。乃至得阿那含果。起于灭定。得阿耨多罗三藐三菩提。问曰。云何不名起不相似心耶。答曰。彼作是说。谁言菩萨无不相似心。菩萨有不相似心。问曰。云何名三十四心得一切智。答曰。彼作是说。言三十四心者。说无漏心。不说入定出定心。罽宾沙门。作如是说。先得阿耨多罗三藐三菩提。后起灭定。问曰。若然者。云何名满足学法答曰。言满足者。满足于根。满足于果。不满足于定。问曰。云何得尽智时名所作已竟。答曰。或有说。解脱障是下无知。或有说。是于诸定不自在。或有说。是不得定者。若作是说。解脱障是下无知者。世尊得尽智时。断一切无知。得一切彼对治智。若作是说。解脱障。是于诸定不自在者。世尊得尽智时。于诸禅定解脱三昧。出入皆得自在。若作是说。解脱障是不得定者。世尊得尽智时。得一切定。是故得尽智时。所作已竟。问曰。云何名三十四无漏心。答曰。菩萨先灭无所有处欲。依第四禅。入正决定。见道中有十五心道比智第十六心道比智。即是离非想非非想处欲。方便道无碍道有九。解脱道有九。是名三十四心

如经说。毗舍佉优婆夷。诣昙摩提那比丘尼所。作如是问。阿夷云何入灭定。彼作是说。毗舍佉优婆夷比丘入灭定。不作是念。我今入灭定。当入灭定。已于先时。调柔其心。欲入此定。问曰。行者入房洗足。敷床结跏趺座时。无如是念。我今入灭定。当入灭定耶。答曰。虽有是事。皆是远时。如欲界善心次第起。初禅乃至入灭定。无如是念。我今入灭定。当入灭定。复作是问。阿夷云何起灭定。彼作是说。毗舍佉优婆夷比丘。起灭定时。不作是念。我今起灭定。我当起灭定。然缘此身六入命根故。而起彼定。若为饥渴所逼。若欲大小便。虽在定时不作患。出则作患。以是事故。从彼定起。复问。比丘入灭定时。为先灭何行。身行耶。口行耶。意行耶。彼作是说。毗舍佉优婆夷比丘。入灭定时。先灭口行。次灭身行。次灭意行。问曰。说灭意行。此事可尔。说灭口行身行。云何可尔。所以者何。从初禅起。入第二禅时。灭于口行。从第三禅起。入第四禅时。灭于身行。何故说言。入灭定时灭身口行。答曰。入灭定时。有二种。有近有远。远时则灭身口行。近时则灭意行。复次若入初禅。乃至入非想非非想处。尽名入灭定时。所以者何。为入灭定故。起此诸地现在前。复作是问。阿夷比丘。起灭定时。先起何行现在前。身行耶。口行耶。意行耶。彼作是说。毗舍佉优婆夷比丘。起灭定时。先起意行。次起身行。次起口行。问曰。若作是说。从灭定先起意行。此事可尔。若作是说。起灭定时。起身行口行。云何可尔。所以者何。从第四禅起入第三禅身行。乃至从第二禅起。入初禅口行。乃至生。何故说起灭定时起身口行。答曰。起灭定。有近有远。近者起意行。远者起身口行。复次起于灭定乃至初禅。尽名起灭定时。所以者何。以灭定故。从彼诸地起。复作是问。阿夷比丘。起灭定时。心何所随顺。心何所转近。心何所垂入。彼作是说。毗舍佉优婆夷比丘。从灭定起。心随顺离。心转近离。心垂入离。问曰。此中何者是离。答曰。或有说者。是灭定。若作是说。是灭定者。出定世俗心。有二事随顺离转近离垂入离。一以期心。二以缘。出定无漏心。与苦智集智相应者。有一事随顺离。以缘不以期心。与灭智道智相应者。亦不以缘。亦不以期心。复有说者。离是灭尽涅槃。若作是说。离是灭尽涅槃者。出定世俗心。亦无期心。亦无缘。亦无随顺离转近离垂入离若无漏与苦智集智道智相应者。于离有期心无缘。与灭智相应者。于离有期心亦缘。复有说者。离是灭定。亦是灭尽涅槃。若作是说。离是灭定。亦是灭尽涅槃者。出定世俗心无漏心。与苦集灭智相应者。总而言之。有二事随顺离转近离垂入离。一以期心。二以缘。与道相应者。有一事随顺离转近离垂入离。有期心无缘。复问。阿夷比丘。从灭定起。为触几触。彼作是说。毗舍佉优婆夷。触三触。一不动触。二无所有触。三无相触。问曰。何者是不动触。无所有触。无相触耶。尊者和须蜜说曰。空处识处是不动触。无所有处是无所有触。非想非非想处是无相触。复次空是不动触。无愿是无所有触。无相是无相触。复次无所有处是不动触。是无所有触。是无相触。无漏者是不动触。无所有处摄故。是无所有触。缘涅槃故。是无相触。尊者佛陀提婆说曰。比丘从灭定起。若是非想非非想处心。不起余不相似心。当言触无相触。若是无所有处不相似心。当言触无所有触。若是识处不相似心。当言触不动触。余五有想定说亦如是。问曰。如次第入灭定出灭定时。亦次第出不耶。答曰。如次第入。不如次第出。如次第出。不如次第入。如次第睡。不如次第觉。如次第觉。不如次第睡。彼亦如是

阿毗昙毗婆沙论卷第四十四阿毗昙毗婆沙论卷第四十五

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    使犍度十门品之九

如说。若得此定。依此定立此定。更不受未来生老病死受苦起集。问曰。此定不能断结。何故作是说。若得此定。乃至广说。答曰。应观是事为以何故。若学人入灭定者起定。作如是念。此是须臾灭。须臾心心数法不行。静妙乃尔。何况毕竟灭。毕竟心心数法不行者。以是事故。即断烦恼。入无余涅槃。若无学人。入灭定者起定。作如是念。乃至以是事故。舍诸阴入无余涅槃。以是事故。作如是说。若得此定。乃至广说。更不受苦起集

施设经说。有作愿入定不作愿出定。有不作愿入定作愿出定。有作愿入定作愿出定。有不作愿入定不作愿出定。作愿入定不作愿出定者。犹如有一作如是念。使我入灭定。不作是念。使我出灭定。起四种有想定。若一现在前。得彼定出。四种有想定。若一现在前。是名作愿入定不作愿出定。不作愿入定作愿出定者。犹如有一不作是念。使我入灭定而作是念。使我出灭定。起四种有想定。若一现在前。彼入灭定出灭定。起四种有想定。若一现在前。是名不作愿入定作愿出定。作愿入定作愿出定者。犹如有一作如是念。使我入灭定。使我出灭定。起四种有想定。若一现在前。彼入灭定出灭定。起四种有想定。若一现在前。是名作愿入定作愿出定。有不作愿入定不作愿出定者。犹如有一不作是念。使我入灭定出灭定。起四种有想定。若一现在前。彼入灭定出灭定。起四种有想定。若一现在前。是名不作愿入定不作愿出定。问曰。作愿入定作愿出定可尔。何者是不欲入定出定。而入定出定。答曰。此尽欲入定。尽欲出定。然入定出定。有自在者。有不自在者。是故施设经。作如是说。或有入定心得自在出定心不得自在。或有出定心得自在。入定心不得自在。或有入定出定心得自在。或有入定出定心不得自在。入定心得自在出定心不得自在者。不作愿入定作愿出定。出定心得自在入定心不得自在者。不作愿出定作愿入定。入定心得自在出定心得自在者。不作愿入定不作愿出定。入定心不得自在出定心不得自在者。作愿入定作愿出定。以是事故。作如是说。入定者。尽欲入定。出定者尽欲出定。问曰。此中说。何者四有想定。答曰。是四无色。问曰。何故说四无色是四有想定。答曰。四无色定。于灭定得作逆次定逆超定。若出彼定。起非想非非想处心。次起无所有处心。是逆次定。若起识处心。是逆超定。若出彼定。起无所有处心。次起识处心。是逆次定。若起空处心。是逆超定。以是事故。说四无色是四有想定。经说。入灭定者。火不能烧。水不能漂。刀不能伤。毒不能害。不为他所杀。问曰。何故入灭定者。火不能烧水不能漂。刀不能伤。毒不能害。不为他所杀耶。尊者和须蜜说曰。此定是不害法。若入此定。害不能害。复次此定有大威势故。威德诸天。常守护定。复次禅禅境界神足神足境界。是不可思议。复次此定无心。无心者不死不生。散耆婆经。是此论因缘。曾闻。过去有迦拘孙陀佛。有二大贤弟子。一名毗头罗。二名散耆婆。尔时尊者散耆婆。于一城中。多所教化。于彼城边。多人行处。入于灭定。时牧牛羊者。担薪草者。行道者。见皆作是念。此大德平坐而死。我等应取牛粪干薪烧之而去。如其念。即取干薪牛粪烧已舍去。尔时尊者散耆婆。晨朝从灭定起。速抖擞僧伽梨。以日初分。着衣持钵。入城乞食。时诸牧牛羊担薪草行道人见者。皆作是言。此尊者昨日平坐而死。我等以干薪牛粪烧已舍来。今复还活。时人皆号之为还活。所以不烧身者。以定力护故。所以不烧衣者。以神足力持故。复有说者。所以不烧身不烧衣者。皆以定力故。是故散耆婆经是此论因缘

如因缘中说。施起灭定人。得现世报。问曰。何故施起灭定人。得现世报耶。答曰。此不必须通。所以者何。此说非修多罗毗尼阿毗昙此是因缘。或然不然。若必欲通者。有何意耶。答曰。不得现世报。而受多报。问曰。何故施起灭定者。若得现报。若得多报。答曰。若施灭定者食。便为施起诸禅解脱三昧者食。所以者何。若欲入此定者。先起欲界善心。次第入初禅乃至非想非非想处。次第入灭定。欲起此定。从此定次第起非想非非想处心。乃至初禅。次第起欲界善心。以行者身中修如是等功德故。施食得现世报。若得多报。复次从此定起。出入言说着衣受取饮食。如是等威仪寂静故。信心婆罗门居士。生敬重心。以衣食等施。得现世报。若得多报。复次此定。生人希有想。若人闻彼比丘得于灭定。极生希有想。信心婆罗门居士。以清净心。施其衣食等。得现世报。若得多报。复次若施起灭定者。食便名施。不食人食入有想定者。虽不食抟食。而食有漏触食意思食识食。入无漏定。虽不食四种有漏食。而以无漏触意思识持身。入灭定者。无四种食。亦不以无漏触意思识持身。是故施起灭定者。则施不食人食。得现世报。若得多报。复次若施起灭定者。食便是施。到涅槃还者食。所以者何。此定与涅槃相似故。如入无余涅槃时。一切心心数法不生。灭一切有缘法。此定亦尔。是故施其食者。得现世报。若得多报。不但施灭定人食得现世报。施五种人食。亦得现世报。一从灭定起。二从慈心起。三从无诤起。四从见道起。五从得尽智起。又施五种人食得多报。一施父。二施母。三施病人。四施说法人。五施近佛菩萨

问曰。此定为是受生处造业为是满业耶。答曰。此是满业。非是造业。所以者何。造业必是业性。彼非业性。问曰。此定为得现报。为得生报。为得后报耶。答曰。此定得生报。不得现报。所以者何。非想非非想处。不能起此定。问曰。何处受此定报。答曰。于非想非非想处报四阴。若成就灭定。亦成就灭定报耶。答曰。或成就灭定。不成就灭定报。乃至广作四句。成就灭定不成就灭定报者。生欲色界得灭定。若得灭定不退。生非非想处。未受灭定报。成就灭定报不成就灭定者于此得灭定退。生非想非非想处。受灭定报。成就灭定亦成就灭定报者。于此得灭定不退。生非想非非想处。受灭定报。不成就灭定亦不成就灭定报者。生欲色界中。不得灭定。生空处识处无所有处。若得灭定退。若不得灭定。生非想非非想处。不受灭定报

若退灭定。亦退阿罗汉果耶。答曰。或退灭定。不退阿罗汉果。乃至广作四句。退灭定不退阿罗汉果者。学人退灭定。阿罗汉得灭定退。不得自在。非起结现在前。退阿罗汉果不退灭定者。慧解脱阿罗汉退。学时得灭定。无学时起非想非非想处结。退灭定亦退阿罗汉果者。学时得灭定。无学时起下地结。退无学时得灭定。三界结若起一界结退。不退灭定亦不退阿罗汉果者。除上尔所事。

阿罗汉果者六种。谓退法。忆法。护法。等住。能进。不动。诸退法阿罗汉。尽是俱解脱耶。若是俱解脱阿罗汉。尽是退法耶。乃至不动阿罗汉。尽是俱解脱耶。若是俱解脱阿罗汉。尽是不动耶。答曰。或是退法阿罗汉非是俱解脱。乃至广作四句。是退法阿罗汉非俱解脱者。诸退法阿罗汉不得灭定。是俱解脱阿罗汉非是退法者。忆法乃至不动得灭定。是退法阿罗汉亦是俱解脱者。退法阿罗汉得灭定。非退法阿罗汉亦非俱解脱者。忆法乃至不动不得灭定。如退法阿罗汉作四句。余五种阿罗汉。作五四句亦如是

如无学道有六种阿罗汉。学地亦有六种性。学诸退法学。尽是身证耶。若是身证。尽是退法学耶。乃至不动性学。是身证耶。若是身证。尽是不动性学耶。答曰。或是退法性学非身证。乃至广作四句。是退法性学非身证者。退法性学不得灭定。是身证非退法性学者。忆法乃至不动性学得灭定。是退法性学亦是身证者。退法学得灭定。非退性学亦非得身证者。忆法乃至不动性学不得灭定。如退法性学作四句。余五性学作五四句亦如是。若法与心作次第。亦是无间耶。答曰。或法与心作次第。非是心无间。乃至广作四句。与心作次第非心无间者。除定初刹那及有心时。余定刹那及出定心是也。是心无间非心次第者。定初刹那及有心时生住无常是也。是心次第亦心无间者。定初刹那及有心时是也。非心次第非心无间者。除定初刹那及有心时生住无常。余定刹那及出定心生住无常是也。若法是心次第亦是定无间耶。答曰。或法是心次第非定无间。乃至广作四句。是心次第非定无问者。定初刹那及有心时是也。是定无间非心次第者。除定初刹那及有心时生住无常。余定刹那及出定心生住无常是也。是心次第亦定无间者。除定初刹那及有心时定。余刹那及出定心是也。非心次第非定无间者。定初刹那及余有心生住无常是也。八胜处乃至广说。问曰。胜处体性是何。答曰。是不贪善根。对治于贪。若取相应回转。欲界是四阴。色界是五阴

已说体性。所以今当说。何故名胜处。胜处是何义。答曰。胜于境界。胜于烦恼。故名胜处。虽诸行者不能尽胜境界。然于境界不生烦恼故名胜处。如世尊说。胜此处故名胜处

界者是色界。地者初四胜处。未至中间初禅第二禅地。后四胜处。在第四禅地。所依身者。是欲界身。缘者缘于欲界。为何所缘。答曰。缘色入。尽缘一切欲界色入耶。答曰。尽缘。问曰。若然者经云何通。如说。尊者阿泥卢头。在舍卫国。住一精舍。有四快意天女。来诣尊者阿泥卢头所。作如是言。尊者阿泥卢头。我等是快意天女。于四处得自在意欲。作何等色。随意能作。以自娱乐。若欲须衣服璎珞。随意能作。而自娱乐。尔时尊者阿泥卢头作如是念。我今应观此女作不净想即起初禅不净想。不能胜之。乃至起第四禅不净观。亦不能胜。复作是念。此色杂故。不能胜之。若纯一色。我则能胜。作是念已。而语之言。姊妹汝等。于四处中。得自在者。尽作青色来。即皆青色。亦不能胜。复作是念。若转此色。或能胜之。复语之言。作黄色来。即皆黄色。赤色亦尔。不能胜之。尔时阿泥卢头。复作是念。白色随顺不净想。若作白色。我或能胜。复语之言。作白色来。即皆白色。亦不能胜。尔时尊者阿泥卢头。知此色杂妙不可胜故。闭目而坐。是时天女。作如是念。今此尊者。不能忆念我等。知此事已。忽然不现。尊者阿泥卢头。不胜境界。境界不胜尊者阿泥卢头。譬如二力士。相扑不能相胜。彼亦如是。此说云何通。答曰。尊者阿泥卢头。虽不能胜余利根者。如佛舍利弗目揵连等则胜。问曰。能于佛身作不净观不。答曰。能作唯佛。能非余声闻辟支佛能。所以者何。佛身清净无垢。一切不净观者。不能于佛身作不净想。唯佛世尊。能于自身。作不净观。复次不净观有二种。一观色过患。二观缘起。观色过患不净观。不能于佛身作观色过患。不净观能作缘起观。余广说如杂揵度不净观处。念处者尽与身念处。俱智者尽与等智俱。三昧者不与三昧俱。根者总而言之。与二根相应。谓喜根舍根。过去未来现在者。是三世。缘三世者。过去缘过去。未来必生者缘未来。不生者缘三世。现在者缘现在。善不善无记者。是善缘善。不善无记者尽缘三种。三界系者是色界系。缘三界系及不系者。是缘欲界系。是学无学非学非无学者。是非学非无学。缘学无学非学非无学者。缘非学非无学。是见道断修道断无断者。是修道断。缘见道断修道断无断者。缘修道断。名缘义缘者。是缘义。缘自身他身非身者。初二缘自身他身。余缘他身。是离欲得方便得者。是离欲得。亦是方便得。初禅者。离欲界欲。得二禅者。离初禅欲。得第四禅者。离第三禅欲。得以方便起现在前。是方便得。佛不以方便起现在前。辟支佛以下方便。声闻或以中。或以上方便。是曾得未曾得者。圣人最后身凡夫起曾得。未曾得者。余凡夫起曾得者

八胜处。内有色想观外色。内有色想者。观自身色。修色想。不离色想。观外色者。观少外色。若好若恶。少有二种。一境界少。二自在少。好色者。不弊坏青黄赤白色。恶色者。弊坏青黄赤白。色于此色。生胜知见者。断于欲爱。过于欲爱。缘取前色。皆得自在。是名为胜。犹如大家大家子驱使奴仆皆得自在。彼亦如是。是名初胜处。初者次第数在初故名初。复次次第入彼定时初入故名初。胜处者。若入此定。善色受想行识是名胜处。如初胜处。第二胜处亦尔。异者。先观少今观多。多有二种。一境界多。二自在多。余如上说。内无色想观外色。内无色想者。内不修色想。离色想观外色少。余广说如上。是名第三胜处。如第三胜处。第四胜处亦尔。异者。第三观少好恶色。第四观多内无色想。观外色。如上所说。观青色者。作如是观解。诸所有色。若略若广。尽观是青。如眼识所观眼识所行。次生意识。观青色青光青影。如是内无色想。观外青色青光青影。生胜知胜见者。断于欲爱。过于欲爱。是名胜于色。缘取前色。皆得自在。犹如大家大家子驱使奴仆皆得自在。彼亦如是。有如是想者。起如是想现在前。是名第五胜处。第五义广说如上。如青色。黄色赤色白色说亦如是。一一异者。黄胜处。应说迦那迦华喻。赤色者。应说槃头耆婆迦华喻。白色者应说优师迦星喻。问曰。此四种色。何者最妙。尊者和须蜜说曰。白色最妙。世人亦说是吉色。犹如四方之中东方最胜世人亦称为吉。彼亦如是。尊者佛陀提婆说曰。观白色者。心则清净。不随顺睡眠法

十一切处。乃至广说。问曰。十一切处体性是何。答曰。八是无贪善根。对治于贪。若取相应回转。是四阴五阴性。若是欲界四阴。若是色界五阴。空处识处一切处体性是四阴。此是一切处体性。乃至广说

已说体性。所以今当说。何故名一切处。一切处是何义。答曰。以二事故。名一切处。一以不缺。二以广大。不缺者。无有处所缘地。复缘于水如缘地。若缘水缘火风青黄赤白空处识处不缺亦如是。广大者。普遍缘地。乃至普遍缘识。尊者佛陀提婆说曰。遍缘一切。无有空缺。名一切处

界者。八在色界。二在无色界。地者。八在第四禅地空处一切处在空处地识处一切处在识处地。所以者何。净解脱在第四禅地。能入后四胜处。后四胜处。能入八一切处。净解脱。缘净境界。不能分别若好若恶。青黄赤白胜处。能分别不能令无边一切处。能令青黄赤白无边。此色为何所依。如依四大。是故次观无边地无边水无边火无边风。此广大谁所生。以觉故知色等依空。是故次观无边空处。彼觉何所依。依于识。是故次观无边识。识更无所依故。更不立一切处。所依身者。八依欲界身。后二依三界身。行者不行行。缘者。八缘欲界。缘欲界何法。答曰。缘于色入。二缘无色界。念处者八与身念处俱。后二与法念处俱。智者尽与等智俱。三昧者不与三昧俱。根者与一舍根相应。过去未来现在者。是三世。缘三世者八。过去者缘过去。未来必生者缘未来。必不生者缘三世。现在者缘现在。后二者缘三世。善不善无记者。是善缘善。不善无记者。八缘三种。二缘善无记。是三界系不系者。八是色界系。二是无色界系。缘三界系不系者。八缘欲界系。二缘无色界系。是学无学非学非无学者。是非学非无学。缘学无学非学非无学者。缘非学非无学。是见道断修道断不断者。是修道断。缘见道断修道断不断者。八缘修道断。二缘见道修道断。缘名缘义者是缘义。缘自身他身非身法者。八缘他身。二缘自身他身。是离欲得方便得者。是离欲得是方便得。离欲得者。离欲时得。方便得者。作方便得。佛不以方便起现在前。辟支佛以下方便。声闻或以中。或以上。是本得。未曾得者。是本得亦是未曾得。圣人内道凡夫。亦是本得。亦是未曾得。余凡夫是本得。问曰。一切处方便云何。答曰。四以眼识为方便满足时。缘青黄赤白色入。四以身识为方便满足时。缘地水火风触入。复有说者。七以眼识为方便。除风一切处。复有说者。八以眼识为方便。问曰。风一切处。云何以眼识为方便。答曰。眼识亦取风色入如是相。谓有尘无尘。满一切处。毗岚风等。空一切处。以空为方便。识处一切处。以识为方便

十一切处。云何为十观。上下诸边地无有缺无有量。上者是上方。下者是下方。诸边者是四方四维。无缺者不杂。无量者无有边际。是名初一切处。初者次第数在初故名初。复次顺次入此定时初入故名初。一切处者。入此定时。善色受想行识。此是一切处。乃至识处一切处说亦如是。异者空处一切处。识处一切处。不说色阴。问曰。八一切处。缘上下诸边可尔。所以者何。彼所缘有方所故。空处一切处。识处一切处。所缘无方所。云何有上下诸边。答曰。八一切处。应说有上下诸边。二一切处。无上下诸边。若如是说者。有何意耶。答曰。行此定者。在上下诸边故。如人中修空处一切处。是下四天王天中修。识处一切处是上余方。说亦如是

问曰。何故第三禅。无解脱无胜处无一切处耶。答曰。非其田器。乃至广说。复次对治欲界色爱故。初禅立解脱。对治初禅色爱故。第二禅立解脱。第二禅无色爱故。第三禅不立解脱。以第三禅无解脱故。亦无胜处。亦无一切处。所以者何。以解脱入胜处。以胜处入一切处故。复次以远故不妙故。第三禅于欲界远。于四禅不妙。复次以如第三无色定故。空处识处。有无边行。非想非非想处。有灭定。无所有处。无无边行。亦无灭定。如第三无色定善根减少。第三禅亦如是。复次第三禅。有一切生死最胜受乐。行者多于中着乐故。不能起解脱胜处一切处。问曰。若然者。何故有无量神通等功德。答曰。一切起不必有一切功德。若当彼地。无无量无神通者。彼地便是空无功德地

佛经说入地一切定者。作如是念。地即是我。我即是地。我定与地。无二无别。余一切处亦如是。问曰。若得一切处。必离第三禅欲。若计地是我。必是第四禅地身见。计第四禅地是我。一切处缘欲界。此云何可尔。答曰。此中说不定名定。如非沙门说名沙门非婆罗门说名婆罗门。彼亦如是。复次此说前所得事。譬如国王虽复亡国。富贵之事。犹名为王。此亦如是。先得此定。而退失之。以曾得故。作如是说。复次彼是速入定者。于彼定退。起欲界身见。计欲界地是我。速还离欲。起一切处。复缘欲界。如提婆达多。能速入定。以神足力。自化作小儿。五花剃发。着金璎珞。于太子阿阇世抱上。宛转游戏。复现此相。使太子阿阇世知是大圣提婆达多。时太子阿阇世。抱弄呜之。以唾着其口中。以贪利养故。而咽其唾是故世尊语提婆达多。汝如死尸食唾之人。彼食唾时。退失神足。速入定故。寻得离欲。自化其身。还在太子阿阇世抱上。宛转游戏。复次身见计第四禅地是我。一切处亦观第四禅地。问曰。一切处缘于欲界。答曰。亦有缘第四禅者。若作是说者。一切处亦缘第四禅。问曰。若然者。色界诸天纯是白色。云何观青黄赤色耶。答曰。彼作是说。色界诸天身。纯一白色。诸非众生数物。有青黄赤色。不应作是说。若身见与一切处相应者。有如是过。云何相应共有法。或缘欲界。或缘第四禅身见。不与一切处相应。然一人亦名计我。亦名得定。以起身见故。名为计我。以起一切处故。名为得定。身见计第四禅地是我。一切处缘欲界。非一时故。此经善通

有地定。有地一切处定。乃至有白定。有白一切处定。问曰。地定地一切处定。有何差别。答曰。地定在欲界四禅地。一切处定在第四禅。复次方便是定。满足是一切处。复次因是定。果是一切处。复次少分。是定遍是一切处地定地一切处定。是谓差别

问曰解脱胜处。一切处。有何差别。答曰。名即差别。是名解脱。是名胜处。是名一切处。复次下善根是解脱。中善根是胜处。上善根是一切处。复次少善根是解脱多。中善根是胜处无量。上善根是一切处。复次因是解脱。果是一切处。因果是胜处。复次背舍义是解脱。胜缘义是胜处。遍缘义是一切处。复次心解脱是解脱。胜烦恼义是胜处。无缺遍义是一切处。复次若得解脱。不必得胜处一切处。若得解脱胜处。不必得一切处。若得一切处。必得解脱胜处。所以者何。解脱能入胜处。胜处能入一切处。解脱胜处。一切处。是谓差别

八智法智比智他心智等智苦智集智灭智道智。云何法智。乃至道智。广说如经本。问曰。彼尊者何故于此论中。以八智而作论。答曰。彼尊者有如是欲如是可如是意欲。以八智而作论。随其欲意。亦不违法相。立八智而作论。余处亦立八智而作论。如定智揵度中说。或欲以二智而作论。即立二智。如智揵度中说他心智念前世智。根揵度中立法智比智。定揵度中立尽智无生智。或欲以四智而作论。即立四智。如根揵度中说。若苦智。是苦无漏智耶。乃至若道智。是道无漏智耶。或欲以十智而作论。即立十智。随其所知。譬如陶师以知泥团安置轮上。随其所欲。出种种物。不损所能。彼尊者亦如是。以闻思修慧。除所知过。随其所欲而作论。不违法相亦如是。复次不应求彼尊者何故立八智耶。所以者何。此是佛经。佛经说八智。法智乃至道智。彼尊者以佛经是此论根本因缘故。依八智而作论。彼尊者无力。于八智中。减一智说七智。增一智说九智。所以者何。佛经无有增减。无增者无增可减。无减者无减可增。如无增无减。无益无损。无量无边。无量者。是无量义。无边者。是无边文。犹如大海水无量无边。无量者深无量。无边者广无边。一切佛经。亦无量无边。无量者。义无量。无边者。文无边。如尊者舍利弗等。百千论师。欲解佛经二句义故。造百千那由他论。尽其觉性退还而不能知佛经二句义边际到于彼岸。问曰。若佛经是此论根本因缘者。佛经中多种说智。或说二智。如二法中。或说四智。如四法中。或说八智。如八法中。或说十智。如十法中。何故彼尊者于多种智中。此使揵度依八智而作论。答曰。八智是中说摄一切智。二智虽摄一切智。而是略说。十智虽摄一切智。而是广说。复次若智数数修数数现在前者。依此智而作论。复次此八智。亦是智性。亦是见性。尽智无生智。虽是智性。而非见性。复次若智是有欲无欲人身中可得者。依此智而作论。尽智无生智。是无欲人身中可得。复次若智是学无学人身中可得者。依此智而作论。尽智无生智。是无学人身中可得。如学无学。所作已所作。未弃重担已弃重担。未逮己利已逮己利。有求无求。当知亦尔。彼尊者或依刹那顷一智而作论。如杂揵度说。颇有一智知一切法耶。答曰。不知。若依十智而作论者。此论不成。若依九八七六五四三二智而作论者。此论不成。乃至一智二刹那顷而作论者。此论亦不成。所以者何。初智刹那顷。不知自体相应共有法。第二刹那顷。知前智相应共有法。彼中依刹那顷一智而作论故。答曰。不知。或说一智摄一切智。谓法智非如法智。以体是法故。或说二智摄一切智。如有漏智无漏智缚智解智系智不系智。或说三智摄一切智。如法智比智等智。或说四智摄一切智。前三智更增他心智。或说五智摄一切智。如等智苦集灭道智。或说六智摄一切智。前五智更增他心智。或说七智摄一切智。除他心智。或说八智摄一切智。增他心智。问曰。若八智摄一切智者。复有八智。谓法住智。涅槃智。生死智。漏尽智。念前世智。愿智。尽智。无生智。云何摄耶。答曰。虽更有八智。亦是八智所摄。所以者何。此八智尽在前八智中故。问曰。此八智云何在前八智中。答曰。住名诸法因三界上中下果在因中住。若知此智。名为因智。因智是四智性。等智法智比智集智涅槃智。是灭智。亦是四智性。等智法智比智灭智生死智者。旧阿毗昙者。罽宾沙门。作如是说。是一智。谓等智。尊者婆摩勒。已作如是说。生死智是四智性。谓法智比智等智苦智。评曰。应作是说。是一等智漏尽智。或有说者。是漏尽。人身中可得故。名漏尽智。若作是说。是十智性。或有说者。漏尽智是缘漏尽处智。若作是说。漏尽智是四智性。谓法智比智等智灭智念前世智。旧阿毗昙者罽宾沙门。作如是说。是一等智。尊者瞿沙。作如是说。是六智。除灭智他心智非他心智。所以者何。他心智缘现在法非灭智。所以者何。灭智缘无为法。评曰。应作是说。是一等智愿智。是一等智。或有说是八智性者。除尽智无生智。所以者何。愿智是见性。彼二智非见性。评曰。应作是说。愿智是一等智。尽智无生智是六智。谓法智比智苦集灭道智。以如是等事故。八智摄一切智。尊者僧伽婆修说曰。应说一智。谓决定智。所以者何。决定义是智义。彼决定有有漏有无漏有缚有解有系有不系。有漏者是等智。是缚是系。无漏智。是解是无系。或是欲界对治。或是色无色界对治。或是欲界对治者。是法智。若色无色界对治者。是比智此三智。若知他心心数法。是知他心智无漏决定智。或行苦四行。乃至行道四行。若行苦四行者。是苦智。乃至若行道四行者。是道智。问曰。若然者唯有三智。法智比智等智。答曰。如是唯有三智。谓法智比智等智。问曰。若然者。云何立八智。答曰。以五事故。一以对治。二以方便。三以自体。四以行。五以缘行。对治者。是法智比智。方便者。是他心智。自体者。是等智。行者是苦智集智。所以者何。此智行不同缘。同缘行者。是灭智道智。所以者何。此智缘不同行不同故。以此五事故。立八智。尊者婆摩勒说曰。对治四种愚故立八智。四种愚者。界愚心愚法愚谛愚。对治界愚故说法智比智。对治心愚故说他心智。对治法愚故说等智。对治谛愚故说苦集灭道智。此是智体性。乃至广说。已说体性。所以今当说。何故名智。智是何义。答曰。决定义是智义。问曰。若决定义是智义者。疑相应智则非智。所以者何。不决定故。答曰。疑相应慧亦是智。但疑于聚中有势用故。言是疑聚。如多爱人名为爱行。非无恚痴以爱有势用故名为爱行。彼亦如是。恚行痴行。说亦如是。譬喻者。作如是说。若心有智。则无不智。若心决定。则无犹豫。若心有粗。则无有细。亦为阿毗昙者说过。汝说法相。犹如若干草木杂生一处而无别相。一心中有智无智。非智非不智。犹豫决定。非犹豫非决定。粗细非粗非细。阿毗昙者。复作是说。我法生时。聚生一心中。有智无智。非智非无智。决定犹豫。非决定非犹豫。粗细非粗非细。智者是智。非智者是无明。非智非无智者。是余心心数法。犹豫者是疑。决定者是慧。非决定非犹豫者。是余心心数法。粗是觉细是观。非粗非细是余法。复有说者。以二事故名智。一以决定。二以适可。知苦乃至知道名决定。自适适他意故名适可

已总说诸智。所以今当一一分别说。所以者何。何故名法智。答曰。体是法故名法智。问曰。余智体亦是法。何故不名法智耶。答曰。余智虽体是法。而法智是法。如十八界虽体是法。十二入体亦是法。七觉支体亦是法。四念处体亦是法。四不坏净体亦是法。四无碍体亦是法。三归三宝体亦是法。而法界法入择法觉支念法法念处法不坏净法无碍法归法宝法。而名为法。如是十智体。虽是法而法智名法。复次法智有一名。余智有二名。法智是共名。余智是共不共名。以不共名说。复次以初知法故名法智。后知法故名比智。复次彼智相应。初得信法名法智。后得信法名比智。复次于法中现见故名法智。次现后生故名比智。复次欲界多诸非法烦恼。如忿恨谄诳放逸害等非法。谁是彼近对治。谓法智是也。色无色界。无如是非法烦恼故名比智。复次若智是六地所摄。缘于一地是法智。若智九地所摄缘于八地是比智。复次若智六地所摄缘六地者是法智。若智九地所摄缘九地者是比智。复次若智对治十八界十二入五阴者是法智。若智对治十四界十二入五阴者是比智。复次若智对治善不善无记五阴者是法智。若智对治善无记五阴者是比智。若智对治福非福不动行者是法智。若智对治福不动行者是比智。复次若智对治抟食爱淫欲爱是法智。若智对治定爱是比智。何故名知他心智。答曰。知他心故名知他心智。问曰。亦知他心数法。何故但名知他心智耶。答曰。以期心故。行者期心。作如是念。使我知他心。若知他心。亦知数法。犹如有人作如是念。使我见王。若见王时。亦见王侍者。彼亦如是。复次此法以种种事故得名。或以自体。或以对治。或以方便。或以相应。或以所依。或以行。或以缘。或以行缘。以自体者。如阴如谛如等智。以对治者。如法智比智。若对治欲界名法智。若对治色无色界名比智。以方便者。如空处识处五现三昧他心智。以相应者。如婆伽罗经说。云何乐受法。答曰。若法与乐受相应。云何苦受法。答曰。若法与苦受相应。云何不苦不乐受法。答曰。若法与不苦不乐受相应。以所依者。眼识乃至意识。若依眼生名眼识。乃至依意生名意识以行者是苦智集智。所以者何。此智行不同缘同。或以缘者。念处无相三昧。以行缘者。是灭道智。所以者何。彼行不同。缘亦不同。复次以名义胜故。此聚中。谁为最胜。心为最胜。譬如王来眷属亦来。但言王来。彼亦如是余广说。如杂揵度说心处。何故名等智。答曰。世人等行此智故名等智。如男女来去世人现所行法等。问曰。亦缘第一义法。何故名世智。答曰。从多分故多缘世法。少缘第一义法。复次此智无第一义相。以多人所称故名世智。犹如多人所立之王。虽非王种。以多人所立故。亦名为王。彼亦如是。复次此智是假名。所以者何。一切人一切众生一切处。尽有此智故。复次此智是愚所依处愚立足处。复次此智是所差故。犹如人差上座差维那声。论者说曰。此智为无智所覆故名等智。犹器中物名为覆物。何故名苦智乃至道智。答曰。以对治决定故。所缘决定故。乃至道智亦如是。复次处所决定故。对治决定故。名苦智乃至道智。复次行苦四行故名苦智。乃至行道四行故名道智。问曰。若有漏慧。行苦四行。乃至行道四行。是苦智耶。答曰。若行苦四行。行道四行。于谛有决定者。名苦智道智。善有漏慧。虽行苦四行乃至行道四行。于谛不决定故。不名苦智乃至道智。复次若行苦四行。乃至行道四行。烦恼更生。复次若行苦集灭道四行。见不复名不见。知不复名不知。已得决定处。不为无知犹豫邪见所覆。善有漏慧。虽行苦等四行。见还不见。知还不知。还为无明犹豫邪见所覆。复次若行苦等四行。能减损破坏。于有是苦智乃至道智。善有漏慧。虽行苦四行乃至行道四行。增益长养。于有余。答如杂揵度说。复次若行苦等四行。不行集灭道等四行是苦智。若行集等四行。不行苦灭道等四行是集智。若行灭等四行。不行苦集道等四行是灭智。若行道四行。不行苦集灭等四行是道智。善有漏慧。若行苦等四行。亦行集灭道等四行。或行苦行亦行集行。或行苦行亦行灭行。或行苦行亦行道行。或行集行亦行灭行。或行集行亦行道行。或行灭行。亦行道行。或行苦行亦行集行灭行。或行苦行亦行集行道行。或行苦行亦行灭行道行。或行集行亦行灭行道行。或行苦行亦行集行灭行道行。行如是行时。当言是苦智。乃至当言是道智。复次若行苦集灭道四行。不同苦集一系。善有漏慧。虽行苦集灭道四行。同苦集一系。问曰。灭道不同一系。何故不立灭道智耶。答曰。以始不中立故。终亦不中立。界者他心智。有漏者是色界系。无漏者是不系。等智是三界系。余是不系。地者。法智在六地。谓未至中间根本四禅。比智在九地。上说六地。三无色地。除非想非非想地。他心智在根本四禅地。等智在十一地。欲界未至中间根本四禅四无色地。余若是法智。分在六地。若是比智分在九地。所依身者。法智依欲界身。他心智依欲色界身。比智等智依三界身。余若是法智分依欲界身。若是比智分依三界身。行者。法智比智。行十六行。他心智。若无漏者行道四行。有漏者。不行行等智行十六行。亦有不行行者。苦智行苦等四行。集智行集等四行。灭智行灭等四行。道智行道等四行缘者。法智比智缘四谛。他心智缘心心数法。等智缘一切法。苦智缘苦谛。集智缘集谛。灭智缘灭谛。道智缘道谛。念处者。他心智是三念处。除身念处。灭智是法念处。余智是四念处。智者即智。三昧者。法智比智。与三三昧俱。他心智。若无漏者。与道无愿三昧俱。有漏者。不与三昧俱。等智不与三昧俱。苦智与二三昧俱。集智与集无愿三昧俱。灭智与无相三昧俱。道智与道无愿三昧俱。根者。等智与五根相应。余智总而言之。与三根相应。过去未来现在者。是三世。缘三世及非世者。法智比智等智。缘三世亦缘非世法。他心智。过去者缘过去。现在者缘现在。未来必不生者缘三世。必生者缘未来。灭智缘非世法。余智缘三世。善不善无记者。等智是三种。余智是善。缘善不善无记者。比智缘善无记。灭智道智缘善。余智缘三种。是三界系及不系者。他心智。有漏者是色界系。无漏者是不系。等智是三界系。余智是不系。缘三界系不系者。法智缘欲界系及不系。比智缘色无色界系及不系。他心智缘欲色界系及不系。等智缘三界系及不系。苦智集智缘三界系。灭智道智缘不系。是学无学非学非无学者。他心智是三种。等智是非学非无学。余智是学无学。缘学无学非学非无学者。法智比智等智他心智缘三种。苦集灭智缘非学非无学。道智缘学无学。是见道断修道断不断者。他心智。有漏者修道断。无漏者是不断。等智是见道修道断。余智是不断。缘见道断修道断不断者。法智比智他心智等智缘三种。苦智集智缘。见道断修道断。灭智道智缘不断。缘名缘义者。法智比智等智苦智集智缘名缘义。余智缘义。缘自身他身非身者。法智比智等智缘自身他身及非身。他心智缘他身。苦智集智道智缘自身他身。灭智缘非身。若苦智行苦行耶。若行苦行是苦智耶。答曰。或是苦智非行苦行。乃至广作四句。是苦智非行苦行者。苦智行无常行空行无我行行。苦行非苦智者。行苦行苦智相应法。是苦智亦行苦行者。苦智行苦行。非苦智非行苦行者。若即取此种性者。行无常行空行无我行苦智相应法。若不即取此种性者。除上尔所事。已行苦行。当行苦行。说亦如是。如苦行有三四句。无常行空行无我行。亦有三四句。如苦智有十二四句。集智灭智道智。各十二四句。合四十八四句

有四事故名法智。一以初知法。二以现见法。三是实智。四是舍智。有四事名比智。一以因比相知果。二以果比相知因。三以身口行比相知心。四以所说比相知。佛有四事。名他心智。谓因次第缘威势。如此智有四事。智所缘亦有四事。谓因次第缘威势。有四事名等智。一以名等。二以缚等。三以假等。四以着等。有四事名苦。一以热恼。二以生。三以身受。四以死。若智行此四事。是名苦智。有四事名集。一以业。二以烦恼。三以爱。四以无明。若智行此四事名集智。有四事名灭。初沙门果断三结。第二果断三结薄爱恚痴。第三果断五下分结。第四果断一切结。若智行此四行。是灭智。有四事名道。一从第八乃至一切学诸有所作。二降伏怨敌。三观本所作。四近漏尽。若智行此四行。是名道智。有四事名尽智。一不摄见。二不行空。三除他心智。四方便迟缓。有四事名无生智。一知因。二知果。三知自身。四以人

十智应言一智。谓法智。非如法智以体是法故。十智应言一智。谓决定智。所以者何。决定义是智。十智应言一智。谓智所知。亦是一智。谓于所知审实生着。九智应言一智。谓道智。以道谛摄故。十智应言一智。谓愿智。以满所愿故。十智应言一智。谓尽智。尽诸烦恼。身中可得故。十智应言一智。谓无生智。更不回还故

三三昧。空无愿无相。应说一三昧。如心数法中定。如定根定力定觉枝正定。应说二三昧。谓有漏无漏缚解。应说四三昧。谓欲界系色界系无色界系不系。应说五三昧。谓欲界系色界系无色界系学无学。若以在身。若以刹那。则有无量三昧。云何世尊。于一三昧于无量三昧。立三三昧。答曰。以三事故。一以对治。二以期心。三以所缘。对治者是空三昧。空三昧是身见近对治。身见行我行我所行。空三昧行空无我行。为以何行对治何行。答曰。以无我行。对治我行。以空行。对治我所行。复次无我行。对治五我见行。空行对治十五我所见行。复次无我行。对治己见。空行对治己所见。复次无我行。对治我见爱。空行对治我所见爱。复次阴非我是无我行。阴中无我是空行。复次眼非我。是无我行。眼中无我。是空行。乃至意亦如是。复次性空是无我行。无所行空是空行。期心者。是无愿期心不愿于有。故名无愿。问曰。亦期心不愿于道耶。答曰。不应作是问。亦不期心。不愿于道。然不愿于道。自有所以。圣道虽非有。而依于有。行者期心。不愿于阴。而圣道依阴。不愿于世。而圣道依世。不愿于苦。而圣道与苦相续。问曰。若然者。圣人何故修道。答曰。欲到涅槃故。行者作如是念。除于圣道。更有方便到涅槃。不知更无有是故。欲到涅槃故修道。所缘者是无相缘。无十相法故是无相十相者。谓色声香味触男女相。及三有为相。复次阴是相。彼缘阴灭故是无相。世是相。前后是相。下中上是相。彼不缘世不缘前后。不缘下中上。故是无相。复有说者。三三昧亦行行。空三昧行二行。谓空无我行。无愿三昧行十行。谓集道八行无常苦行。无相三昧行四行。谓灭四行。复有说者。三三昧是对治。空三昧是身见近对治。无愿三昧是戒取近对治。无相三昧是疑近对治。施设经说。空三昧是空非无愿。无相无愿三昧是无愿非空。无相无相三昧是无相非空无愿。所以者何。空三昧所行非无愿无相。无愿无相亦如是。复次说空三昧是无愿。无愿是空三昧。无相即无相非空非无愿。问曰。何故二三昧同一体。一三昧异体耶。答曰。以此二三昧一时得对治一种法。一时得者。若依空三昧。得正决定。见苦四心顷。未来无愿三昧修。若依无愿三昧。得正决定。见苦四心顷。未来空三昧。修对治一种法者。此二三昧俱对治见苦所断法。复次说空三昧是空无愿无相。云何是空。此中无有常不变易空无我无我所。云何是无愿。此三昧。不愿于爱。不愿于恚。不愿于痴。不愿未来有。云何是无相。答曰。此三昧无色声香味触故。是无相无愿。是无愿亦是空。亦是无相。云何是无愿。此三昧。不愿爱恚痴。不愿未来有。云何是空。此三昧空无有常。乃至无我无我所。云何是无相。此三昧。无有色相乃至触相。无相三昧。是无相是空是无愿。云何是无相。此三昧。无色相乃至无触相。云何是空。此三昧。无有常乃至无我无我所。云何是无愿。此三昧。不愿于爱。乃至广说。此是三昧体性。乃至广说

已说体性。所以今当说。何故名三昧。三昧是何义。答曰。以三事故名三昧。一以正。二以摄。三以相续。正者无始以来。烦恼恶行。邪见颠倒。令心心数法娆触。所以令其正直者。皆是三昧力。摄者无始以来。心心数法散乱。于色声香味触法中。所以摄令不散。住一缘中。皆是三昧力。相续者心心数法。生无色定。次第善心。次第生染污无记心。染污心次第生善心无记心。无记心次第生善心染污心。所以能舍二种心。但令善心相续者。皆是三昧力

阿毗昙毗婆沙论卷第四十五阿毗昙毗婆沙论卷第四十六

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    使犍度十门品之十

复有三事故名三昧。一住一缘。二系在一缘。三正思惟。复有三事故名三昧。一自正心。二生种善根。三令心正。直相续。复有三事故名三昧。一于缘中不从。二持种种善法。三能令种种善心住一缘中尊者和须蜜说曰。何故名三昧。答曰。能令种种善心住一缘中。余说如上。尊者佛陀提婆说曰。三昧有多名。有善法三昧。有不善法三昧。有无记法三昧。有九次第三昧。此中说心正三昧名三昧

界者。有漏者。三界系。无漏者不系。地者。有漏者在十一地。无漏者在九地。所依身者。依三界身行者。空有二行。无愿有十行。无相有四行。缘者空三昧。有漏者缘一切。无漏者缘苦谛。无愿缘三谛。无相缘灭谛。念处者空无愿三昧是四念处。无相三昧是法念处。智者空三昧与四智俱。谓法智比智等智苦智。无愿三昧与七智俱。除灭智。无相三昧与四智俱。谓法智比智等智灭智。三昧者即三昧根者总而言之。与三根相应。过去未来现在者。是三世。缘三世法者。空三昧缘三世及非世法。无愿缘三世。无相缘非世。善不善无记者。是善缘善。不善无记者。空无愿缘三种。无相缘善。是三界系不系者。或三界系或不系。缘三界系及不系者。空三昧。有漏者缘三界系及不系。无漏者缘三界系。无愿缘三界系及不系。无相缘不系。是学无学非学非无学者。是三种。缘学无学非学非无学者。空三昧。有漏者。缘三种。无漏者缘非学非无学。无愿缘三种。无相缘非学非无学。是见道断修道断不断者。有漏者是修道断。无漏者不断。缘见道断修道断不断者。空三昧。有漏者缘三种。无漏者缘见道断修道断。无愿缘三种。无相缘不断。缘名缘义者。空无愿缘义缘名。无相缘义。缘自身他身非身者。空三昧。有漏者缘三种。无漏者及无愿缘自身他身。无相缘非身。若空三昧。尽行空行耶。答曰。或空三昧不行空行。乃至广作四句。空三昧不行空行者。空三昧行无我行。行空行非空三昧者。行空行空三昧相应法。空三昧行空行者。行空行空三昧。非空三昧非行空行者。若即取此种性行无我行空三昧相应法。若不即取此种性。除上尔所事。已行当行亦如是。如空三昧空行作四句。空三昧行无我行亦如是。无愿作三十四句。无相作十二四句。合四十八四句。问曰。三昧解脱门。有何差别。答曰。三昧是有漏无漏。解脱门唯无漏。问曰。何故三昧是有漏无漏。解脱门唯无漏耶。答曰。解脱门不应是有漏。不应是系缚。问曰。为以得正决定。为以尽漏立解脱门耶。若以得正决定者。苦法忍相应定。应是解脱门。若以尽漏者。金刚喻定。应是解脱门。答曰。应作是说。以得正决定亦以尽漏故。名解脱门。所以者何。得一切圣道。尽名决定。一切断尽名尽漏。如世第一法次第得苦法忍。苦次第得集。集次第得灭。灭次第得道。尽漏者。或依空三昧。尽三界漏。或依无愿三昧。尽三界漏。或依无相三昧。尽三界漏。问曰。何故名解脱门。答曰。如楯法故。譬如斗人执楯在前断怨敌头。行者尔时持如楯解脱门在前。断烦恼怨家成就头堕着不成就地。如说。定是正道。不定是邪道。定心得解脱非不定心。有定者能知阴生灭

施设经广说空。谓内空。外空。内外空。有为空。无为空。无始空。性空。无所有空。第一义空。空空。问曰。施设经何故广说空耶。答曰。以空是二十身见近对治

佛经说。若圣弟子。具足三三昧鬘者。能断不善法。修行善法。问曰。何故说三三昧名鬘。答曰。以其妙好世人生欣上心故。如少年时首系花鬘。若男若女。生爱敬心。行者亦尔。若系三昧鬘。诸天世人。则生爱敬。复次如人首系华鬘风则不乱其发。诸功德首。若系三昧华鬘者。掉风不能乱。譬如花若系以为鬘。则所用处多。诸功德亦尔。若系以为鬘则多有所用能得正决定。得果离欲尽漏。复次世人于所系华作鬘想。贤圣亦尔。以三三昧。系诸功德。亦作鬘想。亦如世人次第系华而生鬘想。贤圣亦尔。次第系心于一缘中。亦作鬘想

佛经说。空三昧是上座住处。问曰。何故说空三昧是上座住处。答曰。以诸上座多住是处故。三界中佛是有德上座。次辟支佛。彼尊者舍利弗。常住此处故。言上座住处。复次空是内道中不共法。内道一切皆是上座。外道一切皆是年少。内道中年八岁者。皆是上座。所以者何。成就上座法故。外道年八十者。皆是年少。所以者何。成就年少法故。问曰。诸外道有无愿无相耶。答曰。虽无根本者。有相似者。粗行似无愿止行似无相空乃至无相似者。况根本。复次以能生上座法故。空名上座住处。上座法者。是道道果。谁能生者。谓空能生。复次安住审谛法故。空名上座住处。众生若不得空三昧。则情性轻躁躁动。若得空三昧。情性则不动如山。是故尊者瞿沙。作如是说。若知解脱法。则情性审谛。情性审谛。名上座。是故说空是上座住处。复次行者住空法时。适意不适意好不好。有利益事。无利益事。资生乐事。资生苦事。于此事中。心不移动。曾闻。尊者舍利弗。其母命终共住弟子还俗长齿比丘。常于尊者舍利弗。有怨嫌心。作如是念。我今应往告其不吉之事。尔时长齿比丘。便诣尊者舍利弗所。作如是语。长老当知。汝母命过。共住弟子还俗。尊者舍利弗。作如是答。我母命过。此是有身之法。我弟子还俗。此是凡夫之法时长齿比丘。作是念。长老舍利弗。虽作是言。心必有异。尔时尊者舍利弗。以是事故。明朝着衣持钵。入舍卫城。次第乞食饮食讫。还诣住处。举衣钵洗足已。以尼师檀着肩上。从只桓林。诣安乐林。于昼日露处坐一树下。心生是念。世间颇有可爱妙色。变易散灭之时。令我生忧悲苦恼者。不遍观见无有者。尔时尊者舍利弗。以日暮时。从安陀林。还只桓林。尔时长老阿难。于所住精舍门边经行。见尊者舍利弗来。问言。尊者舍利弗。从何处来。舍利弗答言。我从安陀林来复问。尊者舍利弗。汝于安陀林。多住何三昧。舍利弗答言。住觉观三昧。阿难复问。住何觉何观耶。舍利弗言。我昼日于安陀林。有如是觉。世间颇有可爱妙色。乃至广说。阿难问言。尊者舍利弗。于意云何。为有如是色不。舍利弗答言。无也。阿难复语尊者舍利弗言。汝常作是说。若佛不出世。我等便为无目而死。佛是可爱妙色。若当变易散灭。汝不生忧悲苦恼耶。尊者舍利弗答言。若令世尊变易散灭。我亦不生忧悲苦恼。但有是念。世尊速般涅槃。世间眼速灭。尔时长老阿难叹言。善哉善哉。尊者舍利弗。善除我见我所见及与我慢。断其根本。如断多罗树头更不复生。如来虽是可爱色。若当变易散灭者。当有何忧悲苦恼耶。是故行者住彼法时。于适意不适意好不好有利益无利益资生乐事资生苦事。心不移动。是故名空是上座住处。复说。尊者舍利弗。于俱萨罗国。住一林中。尔时有一阿耆婆梵志。亦住彼林。去尊者舍利弗不远。值彼人民。设四月节会时。彼梵志。诣村落中。多饮好酒。饱食猪肉。复持余肉及酒一瓶。还所住林。见尊者舍利弗坐一树下。生轻贱心。彼之与我。俱是出家。我今极乐。而彼比丘极苦。即说偈言

  我饮粳粮酒　　窃持一瓶来
  地上山草木　　视之犹金聚

尔时尊者舍利弗。作如是念。此如死梵志。向我说如是偈。我今亦应说偈。时尊者舍利弗。便说此偈

  我饮无相酒　　复窃持空瓶
  地上山草木　　视之犹唾聚

此偈中尊者舍利弗。以三解脱门。作师子吼。如说。我饮无相酒。是无相解脱门。复窃持空瓶者。是空解脱门。地上山草木视之犹唾聚。是无愿解脱门

说无相有多名。或说空是无相。或说见道是无相。或说不动心解脱是无相。或说非想非非想处是无相。或说无相是无相。说空是无相者。如经说。有一比丘。得无相心定。彼比丘根钝不知是定有何功德有何果报。作是思惟。谁知此定功德果报。复作此念。长老阿难。佛所称誉。诸梵行者之所信敬。必知此定所有功德果报。我今应往问如是事。复作是念。长老阿难。善知物相。若我往问。当还问我。汝得是定耶。若答言得。彼比丘是少欲覆藏。言法者不欲显己功德。若答言不得。是现前妄语。若作余言。不正答者。则是恼乱上座比丘。我由来不曾恼乱上座比丘。我今但应随逐其后。若为他人说是法者。我当得闻。时彼比丘。于六年中。随阿难后。而犹不闻为他解说。尔时比丘。问长老阿难言。若人得无相心定。心无增减。住难得行。犹水停住。已住故解脱。已解脱故住。世尊说是空有何功德有何果报耶。尔时长老阿难。问彼比丘。汝得此定耶。时彼比丘。作如是念。如我所畏。今果问之。即便默然。尔时阿难。作如是说。若比丘于无相心定。无增无减。乃至广说。佛说此定。所有果报。得一切知见。能生智慧。修道尽漏。汝亦不久当得此法。不增者。是断我见。不减者。断我所见。五我见十五我所见亦如是。不增者。是生死。不减者。是涅槃。住难得行者。此行难得多用功多有所作。如水停住者。譬如水从其源出。停住一处。更不余流。如是彼定。住于一缘。更不余缘。住故解脱者。是自体解脱。解脱故住者。是身中解脱。是中说空是无相。余处亦说无相是空。如法印经说。若断色相观色。乃至广说。众生相是境界相。若彼比丘。见于空法则除众生相。于境界不见有男相女相。是故尊者瞿沙。作如是说。众生相是境界相。若有是空行。于境界不见有男相女相。说见道是无相者。如说。目揵连提舍梵志。不说第六人行无相耶。云何第六人行无相。答曰。第六人行无相者。是坚信坚法。所以者何。彼是无相。不可数不可易知。在此在彼。若苦法忍若苦法智。乃至道比忍比智。问曰。何故见道名无相。答曰。此道是速疾道。不起期心道故。不动心解脱是无相者。如说。长老伽婆多贪欲是相恚痴是相不动心解脱。是最胜无相。问曰。何故不动心解脱名无相耶。答曰。烦恼是相。彼心不为烦恼所覆。不为所坏。不以上着下。非不净自在。是故说不动心解脱名无相。非想非非想处。名无相者。如说。我多用功德无相心定。问曰。何故说非想非非想处名无相定。答曰。以非想非非想处愚痴不猛利不决定。犹如疑亦无了了有想相。亦无了了无想相。说无相名无相者。如此中说。经说

佛在舍卫国。住东方精舍弥伽罗母堂。尔时长老阿难。往诣佛所。头面礼足白佛言。世尊。昔于一时。世尊住于释种弥周吒村。我从世尊。闻如是义。我今多住空三昧。我为善受持忆念如是说不。佛告阿难。如汝所言。善受持忆念如我所说。而无有异。问曰。若善受持。不应生疑。若生疑者。不名善受持。答曰。以是事故。名善受持。所以者何。不生邪见。不转教余人。不都忘失故。问曰。如长老阿难。多闻总持一切智所说八万法聚。以正念器盛之。何故于一句中。而生疑心。答曰。闻此法时。心有愁恼。害诸释时。是此论因缘。如愚痴琉璃王杀害诸释。尔时阿难。将一比丘入迦毗罗城。此城本时如诸天城。当是之时。其犹丘冢。所有楼观。却敌睥睨。种种窗牖。皆悉毁坏。清泉诸池。悉皆娆浊。鸿雁鸳鸯孔雀鹦鹉鸲翅罗鸟。为烟火逼。皆飞翔虚空。诸小男女。皆啼哭逐阿难后。作如是言。大德阿难。我母命过。我父命过。我父母命过。尔时长老阿难。复至修迦罗。处梵志精舍。愚痴琉璃王。于其处。埋迦毗罗诸释。半身在于地中。以铁末末之。杀七万七千贤圣。尔时阿难。见是事已。极生愁恼。次复世尊诸根无异。其心安住。不动如山。善御其心。如持油钵制伏五根。如马正视入迦毗罗城。尔时长老阿难观世尊面颜色和悦。见已作是念。如我亲族离别。生处毁坏。世尊不尔。我今苦恼。而世尊心不动如山。尔时世尊知阿难所念。而告之言。我多住空三昧故。汝心住村落想。我住阿兰若想。汝住亲族想处。我住凡人想。汝作众生想处。我作满足法想。尔时世尊知阿难及诸比丘不堪行道。便将诸比丘。渐次游行到舍卫国东方精舍弥迦罗母堂。尔时长老阿难愁恼转灭。往诣佛所头面礼足。而白佛言。广说如上。以是事故。阿难问此事时。心有愁恼。闻佛所说。我常住空三昧。所以生疑。问曰。佛说我多住空。为住何空。答曰。或有说者。住无所行空。所以者何。无所行空随顺四威仪法行时余三威仪空余威仪时亦尔。评曰。应作是说。住性空。所以者何。但观法性故。是故阿难比丘若欲多住空者。当观聚落及众生住阿练若想。时诸比丘皆有是念。此住空法。是佛不共法佛为除。比丘心所疑。而告阿难。若比丘欲多住空三昧者。除聚落及众生想住阿练若想。问曰。何故佛告比丘。除此二想。答曰。以诸比丘于此二想生苦恼故。阿难若比丘除聚落想及众生想。住阿练若想当作地想。乃至作非想非非想处想。问曰。何故世尊一切时除下想说上想。不说其根本耶。答曰。此说是旧法。过去恒沙诸佛说法皆尔。复次欲令所说不乱故。若世尊说不除下想便说上想者。则所说法乱。诸佛说法而无有乱。复次欲离重说法过故。若世尊不除下想。说于上想。则是重说法。佛世尊不重说法。复次定是略要法。若世尊一切时说根本者。则经文多。复次欲现论议道故。论议之道。若有所说。必定其言。若重定前言。则坏论议道。佛是无对论师。善知论议道故。问曰。说村落想。为现何事。乃至说非想非非想处。为现何事。答曰。村落想为现迦毗罗想。众生想者现诸释想。阿练若想者。现尼拘陀精舍想。亦现诸比丘行道处想。地想者现观色是散坏想。所以者何。有色故有截手足耳鼻。苦空想者。现观空想。乃至非想非非想处现观非想非非想处想。复次村落想者。是十五我所见。众生想者。是五我见。阿练若处想者。是空三昧。地想者是所缘。彼诸对治。是无色定。复次村落想者。是欲界器世界。众生想。是欲界众生世界。阿练若想。是初禅二禅地想。是第三第四禅。彼诸对治。是无色定。复次村落想是欲界。所以者何。欲界说名村落。如偈说

  若伏村落刺　　亦无骂系害
  苦乐心不动　　是名为比丘

众生想是初禅。所以者何。彼中有尊卑眷属故。阿练若想。是第二禅。所以者何。第二禅是贤圣默然法故。地想。是第四禅。所以者何。彼中有胜处一切处故。彼诸对治。是无色定。阿难。是名入无上空。所谓尽漏不多用功心得解脱。问曰。云何多用功心得解脱。不多用功心得解脱。答曰。时解脱多用功。非时解脱不多用功。复次五种阿罗汉。名多用功。不动阿罗汉。不多用功。若依未至中间三无色定。所得解脱。名多用功。若依根本禅所得解脱。名不多用功

复有三三昧。谓空空三昧。无愿无愿三昧。无相无相三昧。云何空空三昧。答曰。如施设经说。若比丘观有漏取行是空。此有漏取行空中。无有常不变易法空无我无我所。作如是思惟时。复更生心心数法。观前思惟心是空。中无有常不变易法空无我无我所。譬如有人欲烧十木百木千木聚以为积然火烧之。复捉长竿在边其中。若有堕落不烧者。以长竿聚之知木已烧。所捉长竿亦投火中。行者亦尔。先观有漏取行是空。广说如上。云何无愿无愿三昧。答曰。若比丘观有漏取行是无常是变易法。如是思惟时。复更生心心数法。观前思惟心。亦是无常变易法。如人烧木。广说如上。比丘亦尔观有漏取行是无常。乃至广说。是名无愿无愿。云何无相无相三昧。答曰。若比丘观寂灭法此是妙离。所谓尽爱离欲灭尽涅槃。作是思惟时。复更生心心数法。观前思惟心亦是寂灭。乃至广说如上。是名取阴是空。次生空空三昧。即观空是空。汝空亦空。无愿三昧观五取阴是无常。后生无愿无愿三昧。观前无愿。汝无愿亦是无常。无相三昧。观寂灭涅槃。后生无相无相三昧。观前无相三昧非数寂灭。汝无相三昧非数灭。无三相故。亦是寂灭。譬如旃陀罗烧死尸时。手执长竿绕其边行。若其中有堕落者。当以此竿聚之。知其烧尽。亦以长竿投之火中。空三昧亦尔。观五取阴是空。后生空空三昧。观空三昧。汝亦是空。无愿无相说亦如是。问曰。云何得此三昧。答曰。或有说者。是见道边得。如见道边等智。或有说者。离欲界欲时。如变化心。评曰。应作是说。若应得三昧者。离非想非非想欲时。得作方便现在前

问曰。几智后起此三昧现在前。答曰。四法智比智苦智灭智。总而言之四智后。欲界者三智后法智苦智灭智。色无色界。亦三智后。比智苦智灭智。若是欲界。空空等三昧依未至禅所摄无漏道。后起现在前。非想非非想处者。无所有处所摄无漏道后起现在前。余者即自地无漏道。后起现前

界者在三界。地者在十一地。所依身者依欲界身。行者空有二行空空有一行唯空行。问曰。何故空二行空空唯一行耶。答曰。以在行空。行空三昧后生故。复次此行与有相违。能舍生死。此善根能观无漏是过患。何况生死。问曰。何故不行无我行。答曰。若见诸法无我。不见空者。虽厌离生死。其心不胜。若见诸法空。则厌离生死心胜。如人在道。独行之时。不大愁惘。若共伴行离别之时。则大愁惘。彼亦如是。无愿行十行。无愿无愿唯行无常行。问曰。何故无愿行十行。无愿无愿唯行无常行。答曰。以在行无常行无愿后生故。复次此行与有相违。能舍生死。此善根能观无漏道是过患。何况生死。何故不行苦行。答曰。不观道。作如此行。何故不行习等行。答曰。若行习等行。则观圣道。是有相续法故。何故不行道等四行。答曰。若行道等行。则适可圣道。不名过患。无相行四行。无相无相行止行。问曰。何故无相行四行无相无相行止行。答曰。以在行止行无相后生故。问曰。何故不行灭行。答曰。灭有二种。有非数灭。有无常灭。不知为缘何灭。何故不行妙行。答曰。波伽罗那说。云何妙法。无漏无为法。彼是中法。是故不行妙行。问曰。何故不行离行。答曰。波伽罗那说云何离法。答曰。欲界系善戒。色无色界出要善定。学法无学法及数灭。彼无有是一相缘者。空空无愿无愿。或有说者。缘最后圣道刹那。或有说者。缘最后圣道刹那俱五阴。或有说者。缘一生中圣道。或有说者。缘一生中圣道俱五阴。无相无相缘非数灭。念处者是法念处。智者与等智俱。定者即是定。根者总而言之与三根相应。世者在三世。缘世者空空无愿无愿。若作是说。缘最后圣道刹那者。过去现在缘过去未来。最初当生者缘现在。余未来刹那缘三世。若作是说。缘一生中圣道者。空空无愿无愿二俱缘三世。无相无相缘。非世善不善无记者。是善缘善不善无记者。空空无愿无愿缘善。无相无相缘无记。系者是三界系。缘三界系不系者。缘不系。是学无学非学非无学者。是非学非无学。缘学无学非学非无学者。空空无愿无愿。缘无学无相无相缘非学非无学。是见道断修道断不断者。是修道断。缘见道断修道断不断者。缘不断。缘名缘义者。是缘义。缘自身他身非身者。空空无愿无愿。缘自身。无相无相缘非身。问曰。何处起是三昧。答曰。欲界中非色无色界起者。是人趣中非余趣。人中三天下非郁单越。依男身女身者俱能。瞿沙跋摩作如是说。唯阎浮提非余方。依男身非女身。所以者何。此善根依牢强身。女人身劣弱。评曰。如前说者好。所以者何。男子心得自在。定得自在。女人亦心得自在。定得自在。为是学人为是无学人者。是无学人。时解脱非时解脱者。是非时解脱。所以者何。何等人能起此定。谓于定自在。身中无烦恼信解脱人。不于定得自在。亦不身中无烦恼。见到虽于定得自在。不身中无烦恼。时解脱虽身中无烦恼。于定不得自在。非时解脱身中无烦恼。于定得自在。问曰。何者是三昧。为初刹那是后相续者是。若初者是。余何所为。若后相续者是。识身所说云何通。如说颇法是世俗有漏。是取阴所摄。从内起。因慧生。是善是欲界系。次圣道生缘无漏。是不共法。唯圣人不共凡夫耶。答曰。有欲界系空空无愿无愿无相无相也。答曰。应作是说。初刹那是。问曰。若然者。余刹那为是何耶。答曰。是似彼善根。复有说者。相续者尽是。问曰。若然者。识身所说云何通。答曰。初者是圣道次第缘无漏。余者虽非圣道。次第亦缘无漏

问曰。何时起此三昧现在前。答曰。般涅槃时。阿罗汉。欲般涅槃时。从圣道起已。起此三昧现在前。从此三昧起已。便般涅槃。更不复起。更不复起圣道。评曰。应作是说。得此三昧已。欲用便起现在前。问曰。圣道后起此三昧现在前。此三昧后。复起圣道现在前不耶。答曰。或有说者不起。所以者何。此三昧憎恶圣道故。复有说者能起。问曰。若能起者。云何名憎恶圣道。答曰。此三昧虽复憎恶圣道。不如圣道憎恶。于有圣道后。犹起有漏心。何况此定后不起无漏心耶。然圣道次第起此定。此定次第不起无漏心。此定唯是有漏。问曰。此定何以唯是有漏。答曰。以不断结故

问曰。圣人何故修此定耶。答曰。以四事故修。一欲住现法乐故。二欲游戏故。三欲观本所作故。四受用圣法故。复次此定是胜法圣人欲游此定故

    阿毗昙毗婆沙论智犍度八道品第一

佛说学人成就八种学道迹。漏尽阿罗汉。梵行已立。成就十种无学道。学人八种学道迹。几成就过去。几成就未来现在。漏尽阿罗汉。梵行已立。十种无学道。几成就过去。几成就未来现在。如此章及解章义。此中应广说优波提舍。问曰。何故作此论。答曰。为止于世中愚言无过去未来世成就说现在世是无为法者意故。亦明过去未来行成就是实有法。若过去未来行。非实有者。则无成就不成就。过去未来行者。如第二头第三手第六阴第十三入。无有成就不成就者。以有成就过去未来行故。知过去未来行是实有法。复有说所以作论者。或有说成就非实有法。如譬喻者。尊者佛陀提婆说。成就无体。非实有法。所以者何。若众生不离彼法。名为成就。然不离是分别相待和合法。无有实体。如五指聚。名之为拳。散则非拳。若众生不离彼法名为成就。若离彼法不名成就。问曰。彼何故作如是说。答曰。彼依佛经。佛经说转轮王成就七宝。彼为成就他身法及非众生数法耶。若转轮王成就轮宝神珠宝者。则坏法体。所以者何。亦是众生数。亦非众生数故。若成就象马宝者则坏趣。所以者何。亦是人趣。亦是畜生趣故。若成就玉女宝者则坏身。所以者何。亦是男身。亦是女身故。若成就主藏主兵臣者则坏业。所以者何。亦是尊贵。亦是卑贱故。欲令无如是过故。说成就无有实体。欲止如是说者意。亦明成就有实体。若成就无实体者。则违此经。如说学人成就八种学道迹。漏尽阿罗汉。梵行已立。成就十种无学道。圣人有漏心现在前时。成就过去未来现在。无无漏道故。则不成就。复违余经。如说此人成就善法。亦成就不善无记法。若善法现在前时。则离不善。无记法。不应成就。不善法现在前时。则离善法。无记法。不应成就。无记法现在前时。则离善不善法。不应成就。复违余经。如说比丘成就七法。于现法中。多住喜乐。若修方便。必能尽漏。无有比丘成就七法者。于七法中。若起一一法现在前。则成就一法。若起余法现在前。于七法中。则不成就。复违余经。如说如来成就十力。无有如来成就十力者。若成就一力。若不成就如来。于十力中。若起一一力现在前。则成就一力。所以者何。于一刹那中。无两慧并现在前何况多。若起余法现在前。则不成就力。复有余过。凡夫人可言离三界结。离三界结人可言凡夫人。凡夫人可言离三界结者。凡夫人善不隐没无记心现在前时。则不成就过去未来现在三界结。应是离三界欲人。离三界欲人是凡夫者。阿罗汉起善有漏及不隐没无记心现在前时。则不成就过去未来现在无漏法。以不成就无漏法故。应是凡夫。欲令无如是过故。说成就是实有法。问曰。若成就是实有法者。譬喻者所引经云何通耶。答曰。转轮王于七宝中。得随意自在用故。世尊说名成就。复有说所以作论者。或说成就是实有法不成就非实有法。为止如是说者意。亦明不成就是实有法。若不成就非实有者。成就亦非实有。所以者何。因不成就故。施设成就。如因明有闇因夜有昼因寒有热。因不成就有成就亦尔。复次不成就与成就。是两两近相对法。如贪与不贪恚与不恚痴与不痴。是两两近相对法。彼亦如是。复次若不成就无实体者。则无施设有断烦恼法。所以者何。圣道生时。断于烦恼。非如以石磨香。圣道生时。断烦恼得证解脱得故。名断烦恼。复有说所以作论者。或有说圣道是无为法。如毗婆阇婆提说。圣道是无为法。彼作是说。阿耨多罗三藐三菩提道。是一常住法。诸佛出世。尽觉悟此道。譬如庄严象马之乘。多人更乘人人虽异而乘常一。如是阿耨多罗三藐三菩提道。是一常住。诸佛出世皆悟此道。诸佛虽异。其道常一。问曰。彼何故作如是说。答曰。依于佛经。佛经说。我得过去诸仙所得旧道。以佛说道是旧法故。言是无为。为止如是说者意故亦明道在世中。若道在世。必是有为非是无为。所以者何。无有无为法在于世者。若道是无为法者。则违此经。如说毗舍佉优婆夷。往诣檀摩提那比丘尼所。作如是问。道为是有为为是无为耶。彼作是答。毗舍佉优婆夷道是有为非是无为。问曰。若道是有为非无为者。毗婆阇婆提所说经云何通。答曰。以五事同故。说名旧道。一以方便同。二以地同。三以行同。四以境界同。五以所作同。方便同者。如一佛于三阿僧祇劫满足六波罗蜜。诸佛亦尔。地同者。其道尽在第四禅地。行同者尽行十六行。境界同者尽缘四谛。所作同者。如一佛以道灭烦恼。一切佛亦尔。以此义通彼经。若如经所说。不依义者。即此经中说。我曾过旧城旧村城村。可是无为法耶。虽说城村是旧。而非无为。道亦如是。虽说旧道。而非无为。如偈说

  若断欲无余　　如莲华在水
  比丘离彼此　　如蛇脱旧皮

蛇皮可是无为法耶。如是蛇皮虽说是旧。而非无为。道亦如是。是故为止他义欲显己义。亦欲说法相相应义故。而作此论

八种者。正见乃至正定。成就者。问曰。谁成就。为法成就。为人成就耶。若法成就。一切法无所欲。云何成就。若人成就。于实义中。人不可得。若无有人。云何成就。答曰。应作是说。成就非法非人。实义中有成就不成就。而无成就不成就者。实义中有缚有解。而无缚者解者。有烦恼有出要。而无烦恼者出要者。有生有死。而无生者死者。有业有业报。而无作业受业报者。有道有道果。而无修道证道果者。于实义中。有成就不成就。而无成就不成就者。或有说者法成就。问曰。若然者。眼入成就十一入。十一入亦成就眼入耶。答曰。若作是说。眼入成就十一入。十一入成就眼入而无过。评曰。应作是说。成就非法非人。然四阴五阴生时。有如是相似得。名成就不成就。尊者和须蜜说曰。一切法无所欲。于无所欲法中。有何成就不成就者。问曰。若然者佛经云何通。如说此人成就善不善法。答曰。此是如来随俗言说而无有实。问曰。云何是成就义。尊者和须蜜答曰。不断义是成就义。问曰。若然者。具缚凡夫于一切法。不断尽成就耶。答曰。不也。不得彼法故。复次不弃义是成就义。问曰。若然者。学人不弃无学法。成就彼法耶。答曰。不也。不得彼法故。尊者佛陀提婆说曰。得而不失义。是成就义。若得彼法不失。是名成就。问曰。何故名学为学。学法故名学耶。为得学法故名学耶。若学学法是学者。定犍度所说云何通。如说学住自性。若得学法是学者。佛经云何通。如说佛告尸婆迦。学学法故名学。答曰。应作是说。学学法故名学。问曰。若然者。佛经善通。定犍度所说云何通。答曰。彼中说得学法故名学人。复有说者。得学法故名学。问曰。若然者。定犍度所说善通。佛经云何通。答曰。佛经中说。不舍期心。不舍方便。学人若住善不善无记心。而不舍趣涅槃心故名学。如人在道路中止息。他人问言。欲何所趣。彼人答言。欲趣某方。其人以不舍去心故。虽住言去。彼亦如是学迹者。问曰。无学迹于学迹。明净胜妙。何故但说学迹。不说无学迹耶。答曰。应说而不说者。当知此说有余。复次此说始起初入法者已说学。当知亦说无学。复次以所作各各不同故。学人以道迹所作胜。无学人以解脱所作胜。如王与臣所作各各不同。王以尊贵降伏所作为胜。臣以执仗斗战所作为胜。彼亦如是。复次学道迹。能断烦恼。犹如器仗。能破怨敌。无学不尔。复次学道迹。能作断烦恼方便及断烦恼。无学不尔。复次数数行义是道迹义。无学不数数行故。不名为迹

学人成就八种道迹。几成就过去。几成就未来。几成就现在。答曰。若依有觉有观三昧。有觉有观三昧者。是未至及初禅。问曰。此中何者是依。答曰。或有说者。俱生故是依。复有说者。次第缘是依。评曰。应作是说。依彼二地起此法故名依。初者有四种。一得正决定初。二得果初。三转根初。四离欲初。得正决定初者。依彼二地得正决定。得果初者。依彼二地初得学果。转根初者。依彼二地信解脱转根作见到。离欲初者。以世俗道离欲依彼二地。初起无漏道现在前。此中依四种初而作论。随相而说学见现在前。问曰。学人或起非学非无学见。何故但说学人学见现在前耶。答曰。应作是说。或学见现在前。而不说者。当知学人必起学见。不起非学非无学见。如所说诸初刹那现在前无过去。所以者何。未有一刹那经生灭者。设有生灭。以得果转根故。而舍八未来成就。修八现在成就。若灭已不舍。灭者是无常。灭不舍者。舍圣道有三种。一得果。二退。三转根。若不得果。不退不转根。即依彼地灭已复起现在前。问曰。何故依彼地灭已复起现在前耶。答曰。学人依彼地。共烦恼战得胜。破结怨敌。念其恩故。复起现在前。如人着铠执仗。与怨共斗。既得胜已。其人后时。以念恩故。数数修治器仗。而覆藏之。不令毁坏。彼亦如是。复次以四事故。重起现在前。一欲受现法乐故。二欲游戏故。三欲观先所作故。四欲受用圣法故。学第二刹那顷。八成就过去。是前刹那生灭者。八成就未来。是未来修者。八成就现在。是现在前者。彼灭已不舍。若依无觉无观三昧。学见现在前。八成就过去。是依有觉有观地生灭者。八成就未来是未来修者。七成就现在。是现在前者。除正觉。所以者何。地无正觉故。彼灭已不舍。依无色定。学见现在前。八成就过去。是有觉有观地生灭者。八成就未来。是未来修者。四成就现在。除正觉正语正业正命。彼地无故。彼灭已不舍。若入灭定。若起世俗心现在前。八成就过去。是有觉有观地生灭者。八成就未来是未来修者。现在无。若入灭定。是时无心。有心者能修道。若起世俗心现在前。彼心是有漏。此中但说无漏道种。若依无觉无观三昧。无觉无观三昧。是第二第三第四禅。问曰。此中何故不说中间禅耶。答曰。应说而不说者。当知此说有余。复次已在后所说中故。所以者何。更无异种。与第二第三第四禅种同故。依义如先说。初者有四种。如先说。学见现在前如说。初刹那不成就过去。如先说。八成就未来七现在。如先说。彼灭已不舍。如先说。复依无觉无观三昧。学见现在前。第二刹那顷。七成就过去。是依无觉无观地。生灭者。八成就未来。七现在。如先说。彼灭已不舍。依无色定。学见现在前。七成就过去。是无觉无观地生灭者。八未来四现在成就。如先说。彼灭已不舍。入灭定。若起世俗心。如先说。彼灭已不舍。依有觉有观三昧。学见现在前。七成就过去。是无觉无观地。生灭者。八未来八现在成就。如先说。若依无色定。无色定名空处识处无所有处。依者如先说。初者四种初。如先说。此中依离欲初而作论。非得正决定初。所以者何。无有依无色定得正决定者。非得果初。所以者何。无有依无色定得学果者。非转根初。所以者何。无有依无色定转学根者。以世俗道。离下地欲。后依彼地初起无漏道现在前。最初刹那无过去。八未来四现在成就。如先说。问曰。如世俗无色定非不因世俗禅。无漏无色定非不因无漏禅。世俗禅。是世俗无色定方便所依门。无漏禅是无漏无色定方便所依门。何故说无过去耶。答曰。道种或有在禅地者。或有在无色地者。彼虽起在禅地者。未起在无色地者。是故无过去灭者。是无常灭不舍者舍圣道有三种。如先说。依彼地生灭圣道复起现在前。问曰。何故依彼地生灭圣道复起现在前耶。答曰。以念恩故。广说如上。第二刹那顷。四成就过去。是依无色定生灭者。八成就未来。是未来修者。四成就现在。是起现在前者。除正觉正语正业正命。彼地无故。彼灭已不舍。若入灭定。若起世俗心现在前。四成就过去。八成就未来。现在无。如先说。彼灭已不舍。依有觉有观三昧。学见现在前。四成就过去。是依无色定生灭者。八成就未来。是未来修者。八成就现在。是起现在前者。问曰。无色定次第能起有觉有观三昧耶。答曰。不能。此说说次第。不说定次第。此说说随顺。不说定随顺。彼灭已不舍。依无觉无观三昧。学见现在前。四成就过去。是依无色定生灭者。问曰。过去有八。是依有觉有观三昧生灭者。何故说四耶。答曰。此中一切处唯说最初生灭者。八成就未来。是未来修者。七成就现在。是起现在前者。除正觉。彼地无故。问曰。此中说何等学人。答曰。此中说习学次第入一切定。犹如登石上梯者。先入有觉有观三昧。次入无觉无观三昧。次入无色定。次入灭定。次起世俗心。说如是学人。若先入有觉有观三昧。次入无觉无观三昧。次入无色定。次入灭定。不起世俗心。不说如是学人。余如杂揵度。人品中说十二枝缘端正女人喻

有四种道。一苦迟慧道。二苦速慧道。三乐迟慧道。四乐速慧道。问曰。应说一道。谓尽苦道。尽生死有道。尽老死道。应说二道。一尽色道。二尽名道。应说三道。一尽欲界道。二尽色界道。三尽无色界道。应说五道。谓尽色道。乃至尽识道。应说十一道。谓尽老死道。乃至尽行道。若以在身若在刹那。则有无量无边道。何故世尊于一道广说四道。于无量无边道。略说四道。云何施设立四道耶。答曰。以三事故。一以地。二以根。三以人。总而言之。以三事应以二事。或以地以根。或以地以人。以地以根者。依未至中间三无色定。钝根人所行道。是名苦迟慧。即依此地利根人所行道。是名苦速慧道。依根本禅。钝根人所行道。是名乐迟慧道。即依此禅。利根人所行道。是名乐速慧道。是名以地以根。以地以人者。依未至中间禅三无色定。坚信信解脱时解脱人所行道。是名苦迟慧道。即依此地坚法见到。非时解脱人所行道。是名苦速慧道。依根本禅。坚信信解脱时解脱人所行道。是名乐迟慧道。即依此禅。坚法见到。非时解脱人所行道。是名乐速慧道。是名以地以人

阿毗昙毗婆沙论卷第四十六阿毗昙毗婆沙论卷第四十七

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    智犍度八道品上

问曰。四道体性是何。答曰。是五阴四阴性。若在禅地是五阴。在无色定是四阴。此是四道体性我相物分

已说体性。所以今当说。何故名道。道是何义。趣向正义是道义。趣向涅槃城义是道义。苦迟慧道者。问曰。无漏道非苦受不与苦受相应。何故名苦耶。答曰。诸边无色道难生故名苦。根本禅道易生故名乐。云何诸边无色道难生耶。答曰。欲界烦恼及业系缚故。多用功。乃生未至禅。如人被缚。多用功力。乃能自解。彼亦如是。或有修不净观生彼地者。或有修安那波那念生彼地者。修不净观者。或于十年或十二年中。常观白骨。或有能生彼地者。或不能生者。修安那波那念者。若于十年若十二年中。常数息。或有能生彼地者或不能生者。已离欲爱。不多用功。能起初禅现在前。初禅异心心数法灭。异心心数法生。灭粗心生细心。觉俱心灭。观俱心生。如人以木折木多用功然后乃折。初禅亦尔。异心心数法灭。异心心数法生。粗心灭细心生。觉俱心灭。观俱心生。已离初禅欲。不多用功。起第二禅现在前。第三第四禅亦如是。问曰。离第四禅欲。亦不多用功起无色定现在前。何故名苦道耶。答曰。无色定是微细法。或有言无无色定者。如多毗婆居士。往诣尊者阿难所。作如是问。尊者阿难。我是在家之人。长夜乐着色声香味触。闻说无色众生。心生怖畏。如临大坑。云何名众生而无有色根本禅是乐道。如二人俱至一方。一从水道。一从陆道。虽俱至一方。从水道者乐。非陆道者。诸众生离欲亦如是。或依诸边无色定。或依根本禅。虽俱得离欲。依禅者乐。非诸边无色定。复次有二种乐故名乐。谓受乐猗乐。三禅中有猗乐受乐。第四禅虽无受乐。而猗乐多胜。余地二种乐。复次有二种乐故名乐。谓旧乐客乐。旧乐者。住禅起禅现在前。客乐者。住禅起无色定现在前。余说禅乐相。如上四禅中广说。问曰。何故名迟。答曰。以得此道不能速至涅槃城故名迟。问曰。何故名速。答曰。以得此道能速至涅槃城故名速。问曰。若不速至名迟疾至名速者。有信解脱人速至胜见到者。若信解脱人精勤。见到人不精勤。则信解脱人速有所至。非见到者。如偈说

  不放逸放逸　　睡眠觉寤者
  犹如利钝马　　前发者先至

犹如二人俱至一方。一乘疾马。一乘钝马。虽乘钝马。以前发故。先有所至。如是信解脱人。勤行精进。先至涅槃。见到人不勤精进故。后至涅槃。答曰。此中说等行精进者。若等行精进。见到者则先至。问曰。此四道是四阴五阴性。何故说名慧耶。答曰。此道虽是四阴五阴性。以慧偏多故名慧道。如见道是五阴性以见偏多故名为见道。边等智。是五阴四阴性。以智偏多故名智。金刚喻定是五阴四阴性。以定偏多故名定。四道亦尔。是五阴四阴性。以慧偏多故名慧道。云何苦迟慧道。如经说。比丘厌恶五取阴。是名苦迟慧道。问曰。此道缘四谛。何故世尊唯说缘苦谛耶。答曰。应说缘四谛。而不说者。当知此说有余。复次此说始初入法。为说缘苦谛。当知亦说缘余谛。复次佛经说四道方便。不说四道体。四道方便道中。作如是厌恶观集法。经中复说。云何苦迟慧道。答曰。非根本禅所摄钝五根是也。云何苦速慧道。答曰。非根本禅所摄利五根是也。云何乐迟慧道。答曰。根本禅所摄钝五根是也。云何乐速慧道。答曰。根本禅所摄利五根是也。问曰。此道是五阴四阴性。何故但说是根耶。答曰。此中说最胜者五根性。是巧便能成大事故。问曰。为有中根不。若有者此中何故不说耶。若无者佛经云何通。如说诸众生随世而生。随世而长。有下根者。有中根者。有上根者。其上根者。烦恼微薄易可教化。若不闻法则退失善根。答曰。应作是说。无有中根。所以者何。见道有二种。一坚信道。二坚法道。修道中亦有二种。一信解脱道。二见到道。无学道中亦有二种。一时解脱道。二不时解脱道。以无第三道故。无有中根。问曰。若然者。佛经云何通。答曰。受化见圣谛者。或有在初。或有在中。或有在后。在初者名利根。在中者名中根在后者名下根。复次受化见圣谛者。有近有远。或有不近不远者。近者是利根。如憍陈如等。远者是钝根。如须跋陀罗等。不近不远是中根。如舍利弗目揵连等。复有说者。有中根。问曰。此中何故不说耶。答曰。已说在先所说中。若说下根时。中根则在上根中。若说上根时中根则在下根中。是故尊者瞿沙作如是说。中根为在何处。答曰。在下中。所以者何。上中下者名中。复次在上中。所以者何。下中上者名中。复次俱在二中。评曰。如是说者好。所以者何。佛亦是坚法人。辟支佛亦是坚法人。声闻得波罗蜜者。亦是坚法人。彼根尽等耶。以于一道有三种根故。经作是说。以无第三道故。阿毗昙者。则说无中根。是故二说善通。集法经复说。修行广布苦迟慧道。能满足苦速慧道。修行广布乐迟慧道。能满足乐速慧道。问曰。此说何者满足。为说满足根。为说满足离欲耶。若满足根者。苦迟慧道则满足二速慧道。乐迟慧道亦满足二速慧道。若满足离欲者。则迟道满足迟道。速道满足速道。答曰。应作是说。满足根。所以者何。彼经说相似法满足。不说不相似法满足。苦道与苦道相似。乐道与乐道相似。问曰。谁成就几道。答曰。或一或二。谁一耶。答曰。未离欲界欲钝根者。成就苦迟道。已离欲界欲成就二。谓乐迟道。未离欲界欲利根者。成就一苦速道。已离欲界欲成就二。谓乐速道。尊者僧伽婆修说曰。有尽成就四道者。如依根本禅。转根住无碍道时。不舍二钝道。已得二利道。不应作是说。所以者何。若作是说。则坏根坏人。坏根者。亦是钝根。亦是利根。坏人者。亦是信解脱。亦是见到

问曰。谁以此几道能有所作。答曰。或有以一二三四道者。而不于一时。钝根者。离欲界欲时。以苦迟慧道。而有所作。即此人依根本禅。离禅欲时。以乐迟道。而有所作。信解脱人。依根本禅。转根作见到。复依根本禅。离禅欲以乐速慧道。而有所作。复依无色定。离无色定欲。以苦速道。而有所作。复有以四道而有所作者。钝根人。离欲界欲。乃至离非想非非想处欲时。以苦迟道乐迟道。而有所作。于彼离欲退从信解脱。转根作见到。复离欲界欲时。乃至离非想非非想处欲时。以二速道。而有所作

问曰。谁当得此几道。谁当舍此几道。答曰。或有不当得不当舍者。如一切凡夫人。问曰。此中不应问答凡夫人。答曰。圣人亦有不当得不当舍者。如住本性圣人。若圣人胜进时。乃有当得当舍者。未离欲界欲。得正决定时。苦法忍乃至道法智无所舍。当得一道比忍。当舍一得一。已离欲界欲。依未至禅。得正决定时。苦法忍乃至道法智无所舍。当得一道比忍。当舍一。当得二。若依上地。得正决定时。苦法忍乃至道法智无所舍。当得二道比忍。当舍二。当得二。须陀洹向斯陀含果时。方便道。五无碍道。五解脱道。无所舍。当得一。第六无碍道。当舍一。当得一。斯陀含向阿那含果时。方便道二无碍二解脱道无所舍。当得一第九无碍道。当舍一得二。离初禅欲。乃至离无所有处欲。方便道无碍道解脱道无所舍。当得二。离非想非非想处欲时。方便道八无碍道八解脱道无所舍。当得二第九无碍道。当舍二得二。是说离欲法。转根时未离欲界欲。信解脱转根作见到。方便道无所舍。当得一无碍道。当舍一得一。已离欲界欲。信解脱转根作见到时。方便道无所舍。当得二无碍道。当舍二得二。时解脱阿罗汉。转根作不动时。方便道八无碍道八解脱道无所舍。当得二第九无碍道。当舍二得二。未离欲界欲圣人。起无量初一解脱初四胜处不净安那波那念念处时无所舍。当得一。已离欲界欲圣人。起无量解脱胜处。一切处不净安那波那念念处修熏禅起通时。五无碍道三解脱道。起无碍无诤愿智般多俱置空无愿无相空无愿无相三昧灭定微细想时无所舍。当得二是说胜进时。退时者阿罗汉起色无色界结退当舍二得二起欲界结退时。当舍二得一。离色界结阿那含。起色界结退时。当舍二无所得。即此阿那含。起欲界结退时。当舍二得一。退斯陀含果时。舍一得一

如说有四种人。一现法迟身坏速。二现法速身坏迟。三现法迟身坏迟。四现法速身坏速。问曰。如说。有现法迟身坏亦迟有现法速身坏亦速。此事可尔。若说现法迟身坏速者。此则不然。所以者何。圣人易世尚不退不转根不生色无色界。何况有现法速身坏迟耶。答曰。此中不说退。亦不说转根者。但说精勤不精勤者。若现身精勤身坏不精勤。是说现身速身坏迟。若现身不精勤身坏精勤。是说现身迟身坏速。若现身不精勤身坏亦不精勤。是说现身迟身坏亦迟。若现身精勤身坏亦精勤。是说现身速身坏速

经说有四种道。一不堪忍道。二堪忍道。三调伏道。四寂静道。不堪忍道者不堪忍寒热饥渴蚊虻虱蚤诸虫等他人恶语非理之言。身生种种苦痛。不能堪忍如是等事。是名不堪忍道。堪忍道者。能堪忍寒热等苦。是名堪忍道。调伏道者。是能守护诸根。是名调伏道。寂静道者。无漏圣道。名寂静道。问曰。为前四道摄后四道。后四道摄前四道耶。答曰。后则摄前。非前摄后

问曰。不摄何等

答曰。不摄后三道。谓不堪忍道堪忍道调伏道

经说有四种断。有苦迟慧断苦速慧断乐迟慧断乐速慧断。若断是苦是迟是断以苦以迟故是下。若断是苦是速是断以苦故是下。若断是迟是乐是断以迟故是下。若断是乐是速是断不能利益多人亦不广及人天故是下。世尊所有断。能利益多人。广及人天故。是断最上。问曰。为四道摄四断四断摄四道耶。答曰。展转随相相摄。若断是苦是迟。是苦迟慧道。若断是苦是速。是苦速慧道。若断是乐是迟。是乐迟慧道。若断是乐是速。是乐速慧道。或有说者。四断是无学。四道是学无学。若作是说。四断是无学。四道是学无学者。四道则摄四断。非四断摄四道。不摄何等。不摄学四道。问曰。圣道非下。如波伽罗那说。云何下法。不善隐没无记法。何故说断名下耶。答曰。下有二种。一染污下。二减损下。断虽非染污下。是减损下。是故名下。若断是苦是迟。是说未至禅禅中间三无色定。是说时解脱道。若断是苦是速。是说声闻人。非时解脱道。若断是乐是迟。是说根本禅。时解脱道。若断是乐是速。不利益多人。不广及人天。是说根本禅声闻人。非时解脱道。若断是乐是速。能利益多人。广及人天。是说佛道。是中余者是辟支佛道。为在何分。或有说者。是声闻分。评曰。应作是说。是佛分。所以者何。如佛独觉无师。辟支佛亦尔。复有说者。三断如先。若断是乐是速。不能利益多人广及人天者。说是辟支佛道。若断是乐是速。能利益多人。广及人天。是说佛道。是中余者是根本禅声闻人。非时解脱道。为在何分。或有说者。是辟支佛分。评曰。应作是说。是佛分。所以者何。此根从佛边生故。复有说者。三道是外道法。若断是乐是速。不能利益多人广及人天。是说辟支佛道。若断是乐是速。能利益多人。广及人天。是说佛道。是中余者是声闻道。为在何分耶。答曰。或有说者。在辟支佛分。评曰。应作是说。在佛分。所以者何。此根从佛边生故。复有说者。前三道是外道法。若断是乐是速。不能利益多人广及人天。是说声闻道。若断是乐是速。能利益多人广及人天。是说佛道。是中余者辟支佛道。为在何分。答曰。或有说者。在声闻分。评曰。应作是说。在佛分。所以者何。如佛无师。辟支佛亦尔

问曰。此四道中。世尊为依何道入正决定得果离欲尽漏。辟支佛。为依何道得波罗蜜。声闻人。为依何道耶。答曰。佛世尊依乐速道入正决定得果离欲尽漏。何以知之。经说摩勒迦子。往诣佛所。作如是问。世尊于此四道。为以何道得阿耨多罗三藐三菩提耶。佛答摩勒迦子言。如来依乐速慧道。得阿耨多罗三藐三菩提。时摩勒迦子便作二难言。是乐道

云何行种种苦行。言是速道。云何经六年。佛告摩勒迦子。愚人我不以如是威仪所行得阿耨多罗三藐三菩提。以是事故。知如来以乐速慧道得阿耨多罗三藐三菩提。如渴伽兽角独出辟支佛当知。如佛世尊。为众多出世者。此则不定。尊者舍利弗依苦速慧道。入正决定。依乐速慧道得尽漏。所以者何。依未至禅。入正决定。依第四禅尽漏故。尊者目犍连。依苦速慧道。入正决定。乃至尽漏。所以者何。依未至禅。入正决定。依无色定尽漏故。问曰。何故尊者舍利弗。依第四禅。尊者目犍连。依无色定。得阿罗汉果耶。答曰。尊者舍利弗多行慧故。依第四禅。尊者目犍连多行定故。依无色定。问曰。得波罗蜜声闻人。为尽次第得四沙门果不耶。答曰。尽次第得。所以者何。彼尊者善能解说出入住沙门道果故。问曰。善能解说出入住沙门果道。无有与如来等者。何故不次第得四沙门果耶。答曰。不应于如来作如是问。所以者何。如来本为菩萨时。自在解说四沙门果。胜于尊者舍利弗得尽智时。复有说者。得波罗蜜声闻人。不次第得四沙门果。所以者何。若有先离欲者要退然后得须陀洹果耶。问曰。若然者。云何能善解说四沙门果耶。答曰。此亦无过。如尊者阿难。是钝根人。住于学地。善能解说四沙门果。何况利根住无学地者。评曰。应作是说。得波罗蜜声闻人。尽次第得四沙门果。不以善能解说四沙门果。如恒河沙数得波罗蜜声闻人。尽顺次入正决定。次第得四沙门果法。应如是

漏尽阿罗汉梵行已立。十种无学道。几成就过去。几成就未来。几成就现在。答曰。若依有觉有观三昧。有觉有观三昧者。是未至禅初禅。依者如先说。初者有二种。一得阿罗汉果初。二时解脱转根作不动初。是中因此二初而作论。应随相而说无学初智现在前。如所说。二时初刹那无过去。所以者何。未有刹那生灭故。已有者。以得果转根故舍。十成就未来。是未来修者。九成就现在。是现在前者。除正见。所以者何。彼刹那中无故。若灭已不舍灭者是无常灭。不舍者舍圣道有三种。如先说。彼不得果不退不转根。依彼地复起圣道现在前。所以复起圣道现在前者。如先说。第二刹那顷。九成就过去。是前刹那生灭者。十成就未来。是未来修者。九成就现在。是现在前者。彼灭已不舍。依无觉无观三昧。无学智现在前。九成就过去。是有觉有观地生灭者。十成就未来。是未来修者。八成就现在是现在前者。除正觉。彼地中无故。除正见。彼刹那中无故。彼灭已不舍。依无色定。无学智现在前。九成就过去。是有觉有观地生灭者。十成就未来。是未来修者。五成就现在。是现在前者。除正见。彼刹那中无故。除正觉正语正业正命。彼地中无故。彼灭已不舍。若入灭定。若起世俗心。九成就过去。是有觉有观地生灭者。十成就未来。是未来修者。现在无入灭定者。无心有心者。能修道世俗心。是有漏无学法。是无漏。彼灭已不舍。依有觉有观三昧无学初见现在前。九成就过去。是与智俱生灭者。十成就未来。是未来修者。九成就现在。是现在前者。除正智。彼刹那中无故。彼灭已不舍。依有觉有观三昧。无学若智若见现在前。十成就过去。是与智与见俱生灭者。十成就未来。是未来修者。九成就现在。是现在前者。若智现在前。彼刹那中无见。若见现在前。彼刹那中无智。灭已不舍。依无觉无观三昧。无学若智若见现在前。十成就过去。是有觉有观地生灭者。十成就未来。是未来修者。八成就现在。是现在前者。若智现在前。彼刹那中无见。若见现在前。彼刹那中无智除正觉。彼地中无故。彼灭已不舍。依无色定。无学若智若见现在前。十成就过去。是有觉有观地生灭者。十成就未来。是未来修者。五成就现在。见现在前者。若智现在前。彼刹那中无见。若见现在前。彼刹那中无智。除正觉正语正业正命。彼地中无故。彼灭已不舍。若入灭定。若起世俗心现在前。十成就过去。十成就未来。现在无。如先说。若依无觉无观三昧无学初智现在前。无觉无观三昧者。是第二第三第四禅。问曰。何故不说中间禅耶。答曰。如先说。依者如先说。初者如先说。无学初正智现在前。过去无。如先说。十成就未来。如先说。八成就现在。除正见。彼刹那中无故。除正觉。彼地无故。彼灭已不舍。如先说。复依无觉无观三昧。无学正智现在前。八成就过去。是前刹那俱生灭者。十成就未来。如先说。八成就现在。如先说。彼灭已不舍。依无色定。无学正智现在前。八成就过去。十成就未来。五成就现在。如先说。彼灭已不舍。若入灭定。若起世俗心现在前。八成就过去。十成就未来。现在无。如先说。彼灭已不舍。依有觉有观三昧。无学正智现在前。八成就过去。十成就未来。如先说。九成就现在除正见。彼刹那中无故。彼灭已不舍。依无觉无观三昧。无学初见现在前。八成就过去。与智俱生灭者。十成就未来。如先说。八成就现在除正智。彼刹那中无故。除正觉。如先说。彼灭已不舍。复依无觉无观三昧。无学若智若见现在前。九成就过去。与智与见俱生灭者。十成就未来。八成就现在。如先说。彼灭已不舍。依无色定。无学若智若见现在前。九成就过去。十成就未来。五成就现在。如先说。彼灭已不舍。若入灭定。若起世俗心现在前。九成就过去。十成就未来。现在无。如先说。彼灭已不舍。依有觉有观三昧。无学若智若见现在前。九成就过去。十成就未来。九成就现在。如先说。若依无色定。无学初智现在前。无色定是空处识处无所有处。依者。如先说。初者如先说。无学初智现在前。过去无。十成就未来。五成就现在。如先说。彼灭已不舍。复依无色定。无学正智现在前。五成就过去。是前刹那俱生灭者。十成就未来。五成就现在。如先说。彼灭已不舍。若入灭定。若起世俗心现在前。五成就过去。十成就未来。现在前无。如先说。彼灭已不舍。依有觉有观三昧。无学正智现在前。五成就过去。十成就未来。九成就现在。如先说。彼灭已不舍。依无觉无观三昧。无学正智现在前。五成就过去。十成就未来。八成就现在。如先说。彼灭已不舍。依无色定。无学初见现在前。五成就过去。是与智俱生灭者。十成就未来。如先说。五成就现在。除正智。彼刹那中无故。除正觉正语正业正命。彼地中无故彼灭已不舍。复依无色定。无学若智若见现在前。六成就过去。与智与见俱生灭者。十成就未来。五成就现在。如先说。彼灭已不舍。若入灭定。若起世俗心现在前。六成就过去。十成就未来。现在无。如先说。彼灭已不舍。依有觉有观三昧。无学若智若见现在前。六成就过去。十成就未来。九成就现在如先说。彼灭已不舍。依无觉无观三昧。无学若智若见现在前。六成就过去。十成就未来。八成就现在。如先说。问曰。何故余沙门果见是无碍道见是解脱道。阿罗汉果见是无碍道智是解脱道耶。答曰。得阿罗汉果时。息一切所作。更不施设方便故

问曰。学人为有正智正解脱不耶。若有者此中何故不说。若无者佛经云何通。如说。居士莫怖。凡夫愚小。成就邪智邪解脱故。畏堕地狱畜生饿鬼趣。汝已断邪智邪解脱。成就正智正解脱。答曰。应作是说有。问曰。此中何故不说。答曰。法或有唯是法体者。或有是法体亦是支体者。学人唯有法体而无支体。问曰。何故无学正智正解脱立支学人不立耶。答曰。以名义胜故。若以法而言。无学法胜学法。若以人而言。无学人胜学人。复次以无学正智正解脱名胜。无过患故。复次以无学断一切有根本故。复次无学得二种心解脱。一自性解脱。二在身解脱。是故得作四句。有心自性解脱非在身解脱。有在身解脱非自性解脱。有自性解脱亦在身解脱。有非自性解脱非在身解脱。自性解脱非在身解脱者。学心是也。在身解脱非自性解脱者。无学有漏心是也。自性解脱亦在身解脱者。无学心是也。非自性解脱非在身解脱者。学有漏心一切凡夫人心是也。复次无学正智正解脱无障碍故。学人邪智障碍正智邪解脱障碍正解脱。问曰。邪见能障碍正见。何故学正见立支耶。答曰。学人正见。断于烦恼时。犹如铠仗。故立支。复次无学正智正解脱。无相对法故。学人正智。与邪智相对。正解脱与邪解脱相对。复次无学心一切解脱学心。少分解脱。少分不解脱。少分解脱者。是见道所断烦恼。少分不解脱者。是修道所断烦恼。复次若心一切障碍解脱一切障碍处解脱者立支一切障碍者。是五种断烦恼。一切障碍处者。是五种断烦恼。境界学人不尔。余无学功德。广说如杂犍度。问曰。若如所说学人。则有邪智邪解脱。佛经云何通。如说。居士莫怖。凡夫愚小。成就邪智邪解脱故。畏堕地狱畜生饿鬼趣。汝邪智邪解脱。已断成就正智正解脱。答曰。经说无堕恶趣。邪智邪解脱。学人犹有余邪智邪解脱

佛经说。阿难当知。舍利弗。是聪明比丘。须陀洹所有四支。为须达长者。分别有十种。问曰。云何尊者舍利弗。分别须陀洹四支为十种耶。尊者波奢说曰。一支说有十种。亲近善知识有十种。乃至如法修行有十种。尊者富那耶奢说曰。信是亲近善知识多闻法。正见是正思惟。余是如法修行。尊者瞿沙说曰。信戒是亲近善知识。多闻是闻法。正见是正思惟。余是如法修行。尊者和须蜜说曰。信戒是亲近善知识多闻智慧是闻法。正见是正思惟。余者是如法修行。阿毗昙者。作如是说。信戒施是亲近善知识多闻智慧是闻法。正见是正思惟。余是如法修行。尊者佛陀提婆说曰。须陀洹支者。即是须陀洹支尊者舍利弗为须达长者。分别不坏信有十种。以三事故。一以自体。二以起处。三以所依。以自体者。是信是戒。何者是信戒根本。谓无漏智。无漏善根。以起处者。是正觉依正觉故。长养戒闻施慧所依者是解脱

问曰。何故名阿罗汉。答曰。阿罗名烦恼汉名杀。以智慧刀杀烦恼故。名阿罗汉。复次更不生诸界诸趣诸生死中。名阿罗汉。复次远离恶不善法故。名阿罗汉。如偈说

  远离恶不善　　安住善住中
  应受世上供　　故名阿罗汉

复次应受最胜供养故。名阿罗汉。一切沙门。所应用物。无有不应受者。漏尽者。问曰。如漏处亦尽。何故但说漏尽。答曰。世尊先说漏尽。当知亦说漏处。复次若法是自性断。断已不成就。此法与圣道相妨。圣道不与有漏善不隐没无记法相妨。唯与漏法相妨。若漏断善有漏法。不隐没无记法亦断同一对治故。如灯不与炷油器相妨而与闇相妨。为破闇故。然灯亦燋炷尽油热器。复次以漏难断难除难过。复次以漏是重过患故。复次漏是漏是漏处。流枙缚取使结亦尔。善有漏不隐没无记法不尔

云何为智。云何为见。云何为慧。问曰。何故作此论。答曰。或有说。忍是智。如譬喻者。佛陀提婆作如是说。慧眼初缘境界是忍。后增长是智。是故下智是忍。如人在道行。先生念欲住。然后乃住。慧眼初缘境界时是忍。增长是智是故下智是忍。为止如是说者意。亦明忍非智故而作此论。复次所以作论者。或有说尽智无生智是见性。为止如是说者意。亦明尽智无生智非见性故。而作此论。复次此揵度是智。此中应分别。何者是智性见性慧性法

云何为见。答曰。眼根五见世俗正见学见无学见是也。问曰。眼根何故名见耶。答曰。以四事故名见。一以贤圣人说故。二以世俗人说故。三以经说故。四以世间现见故。贤圣世俗人说者。如说我见是人行住坐卧。若见人颠蹶迷错者。作如是说。如有见邪经说者。佛说。若眼见色。不应分别。是男是女。生于染爱。复说。若眼见色。好不生爱。恶不生恚。复说。若见适意。色不适意。色非适意。色非不适意。色应当观察。复说。若眼见色。不应生爱恚。应生舍心。复说。若见色应当正观是不净法世间现见者。尊者和须蜜说曰。此是世人言说。我现见是事净。现见是事不净。尊者佛陀提婆说曰。经亦说。世人亦说。眼所及识所更。是名为见。五见名见者。以四事故。广说如见揵度见处中所说。世俗正见名见者。以是见性故。学见无学见。所以名见者。以是见性故。如夜有云时见色。染污慧见法亦尔。如夜无云时见色。善有漏慧见亦尔。如昼有云时见色。学慧见法亦尔。如昼无云时见色。无学慧见法亦尔。云何为智。答曰。除见道中忍。余意识相应慧是也。彼有三种。善染污不隐没无记。善有二种。有漏无漏。有漏者。是世俗正见。无漏者。是学无学八智。染污者。是五见及爱恚慢疑无明相应者。不隐没无记者。威仪工巧报生变化心俱者是也。及五识身相应慧。彼亦有三种。善秽污不隐没无记善者是生得善。秽污者。与爱恚俱。不隐没无记者。与报心俱。云何为慧。答曰。意识相应慧是也。彼亦有三种。善秽污不隐没无记善者。有二种。有漏无漏。有漏者。是世俗正见。无漏者。是见道中八忍学无学八智。余如先说。五识相应慧。如先说。已说自体。今当说同异相。若见是智耶。乃至广作四句。是见非智者。眼根见见道中诸忍是也。问曰。何故眼根非智耶。答曰。眼根是色智非是色。复次眼根是非相应非依非行非缘。智是相应是依是行是缘。见道中诸忍。何故非智耶。答曰。是忍非已忍。是观非知是观非已观。是求觅非已足。是施设止息方便。复次忍是疑对治。彼疑得与此忍俱生故。决定义是智义。复次无碍。道解脱道。虽同作一事。不得同在一刹那中生。尊者和须蜜说曰。堪忍故名忍。不可以堪忍是智。尊者佛陀提婆说曰。己见名智忍非己见。是名见非智。智非见者。除五见及世俗正见。诸余意识相应有漏慧。彼有二种。染污不隐没无记。染污者。与爱恚慢疑无明相应者是也。问曰。何故与爱等相应染污慧非见耶。答曰。见所行猛利。彼慧所行不猛利。复次见于缘深入。慧于缘不深入。复次爱相应慧。为二结所覆蔽遍故。二结者。谓爱及相应无明。余亦如是。问曰。不共无明相应慧。不为二结所覆。何以故。不名见耶。答曰。不共无明覆慧重于三结。不隐没无记者。是威仪工巧报生变化心俱者是也。问曰。何故不隐没无记慧非见耶。答曰。见所行猛利。彼慧所行不猛利。复次见于缘深入。彼慧于缘不深入。复次见有势力。彼慧微劣。问曰。如报慧微劣可尔。威仪工巧者。亦有势用。如世尊威仪。毗首羯磨天工巧。乃似愿智所作。答曰。虽极工巧。为邪命所覆。复次虽是极巧。犹为他人所讥言。是处不好五识相应慧。何故非见耶。答曰。见所行猛利。于缘深入。彼慧所行不猛利。于缘不深入。复次见能分别。彼慧不能分别。复次见缘三世及无为。彼慧唯缘现在。复次见缘总相别相。彼慧唯缘别相。复次见于缘数数行。彼慧不尔。复次见于缘筹量观察。彼慧不尔。问曰。尽智无生智。何故非见耶。答曰。见所行猛利。彼智所行不猛利。复次见生时。于施设有所作。彼智生止息方便无所作。如鸟住安隐处。复次见现在前有所求。彼智现前无所求。是故尊者瞿沙作。如是说。于胜法更无所求故。尽智无生智非见。复次一切无漏慧有二种。或对治邪见。或对治无智。复有说者。无漏法三种。或对治邪见非无智。或对治无智非邪见。或对治邪见亦对治无智。若对治邪见非无智者。是见非智。如见道中诸忍。若对治无智非邪见者。是智非见。如尽智无生智。对治邪见亦对治无智者。诸余无漏慧。尊者和须蜜。说曰。尽智无生智。何故非见耶。答曰。若尽智无生智。是见性者。阿罗汉则成就九种道。然佛世尊说阿罗汉成就十种道。问曰。如世俗正见是见性智性。学见是见性智性。无学见是见性智性。若尽智无生智。亦是见性智性者。有何过耶。答曰。若如方便初入法时。世俗正见是见是智。立是正见支。非正智支。学见是见是智。立正见支非正智支。无学见是见是智。立正见支。不立正智支如是尽智无生智体。亦是见是智者。亦应立正见支不立正智支。则阿罗汉成就九种道无十。世尊说阿罗汉成就十种道。尊者佛陀提婆说曰。决定无疑。此智是见所以者何。以猛利故。若作是问。阿罗汉成就九种道。然佛说有十种道。应如是答。十道二在无学地。八在学无学地。亦见亦智者。除见道中诸忍尽智无生智。诸余无漏慧。彼是何耶。谓学八智无学正见五见世俗正见。亦是见相。亦是智相。非智非见者。除上尔所事。若法第一第二第三句已立名已称说。除之诸余法。未立名未称说者。作第四句。彼是何耶。色阴中除眼根。诸余色阴是也。行阴中除一切慧。谓善染污不隐没无记。亦在意地。亦五识地。亦有漏无漏。诸余相应不相应行阴是也。三阴及无为法。如是等作第四句。是名除上尔所事。若见是慧耶。乃至广作四句。见非慧者眼根是也。慧非见者。除五见世俗正见。诸余意识相应有漏慧。五识相应慧。及尽智无生智。余广说如前四句。亦见亦慧者。除尽智无生智。诸余无漏慧彼是何耶。谓见道中诸忍。学八智无学正见五见世俗正见。是诸法有见相慧相。非见非慧者。除上尔所事。如先说。若智是慧耶。答曰。诸智是慧。颇有是慧非智耶。答曰。有见道中诸忍是也。广说摄亦如是

阿毗昙毗婆沙论卷第四十七阿毗昙毗婆沙论卷第四十八

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    智犍度八道品中

若成就见亦成就智耶。答曰如是。若成就智亦成就见耶。答曰如是。若成就见亦成就慧耶。答曰如是。若成就慧亦成就见耶。答曰如是。若成就智亦成就慧耶。答曰如是。若成就慧亦成就智耶。答曰如是。谁成就见智慧耶。答曰。一切众生。总而言之。一切众生。然有多少断善根者。成就三界见道所断见智慧。三界修道所断染污智慧。欲界系不隐没无记智慧。不断善根者。若不得色界善心。成就三界见道所断见智慧。三界修道所断染污智慧。欲界系善见智慧。欲界系不隐没无记智慧。若得色界善心。未离欲界欲。成就三界见道所断见智慧。三界修道所断染污智慧。欲色界善见智慧。欲界系不隐没无记智慧已离欲界欲。若不得无色界善心。成就色无色界见道所断见智慧。修道所断染污智慧。欲色界善见智慧。欲色界不隐没。无记智慧。若得无色界善心。未离色界欲。成就色无色界见道。所断见智慧修道所断染污智慧。三界善见智慧。欲色界不隐没无记智慧。若离色界欲。成就无色界见道所断见智慧修道所断染污智慧三界善见智慧。欲色界不隐没无记智慧。生色界凡夫。不得无色界善心。成就色无色界见道所断见智慧修道所断染污智慧。成就色界系善见智慧。欲色界不隐没无记智慧。若得无色界善心。未离色界欲。成就色无色界见道所断见智慧修道所断染污智慧。色无色界善见智慧。欲色界不隐没无记智慧。已离色界欲。成就无色界见道所断见智慧。修道所断染污智慧。色无色界善见智慧。欲色界不隐没无记智慧。生无色界凡夫。报心不现在前。成就无色界系见道所断见智慧。修道所断染污智慧。无色界善见智慧。若报心现在前。成就无色界见道所断见智慧。修道所断染污智慧。无色界善见智慧。不隐没无记智慧。是则说凡夫人。坚信坚法人者。苦智未生。成就三界见道所断见智慧。修道所断染污智慧。欲色界善见智慧。欲界不隐没无记智慧。无漏见慧苦智已生集智未生。成就三界集灭道所断见智慧。修道所断染污智慧。欲色界善见智慧。欲界不隐没无记智慧。无漏见智慧。乃至灭智已生道智未生。成就三界见道所断见智慧。修道所断染污智慧。欲色界善见智慧。欲界不隐没无记智慧。无漏见智慧。须陀洹斯陀含。成就三界修道所断染污智慧。欲色界善见智慧。欲色界不隐没无记智慧。无漏见智慧。生欲界阿那含。若不得无色界善心。成就色无色界修道所断染污智慧。欲色界善见智慧。欲色界不隐没无记智慧。无漏见智慧。若得无色界善心未离色界欲。成就色无色界修道所断染污智慧。三界善见智慧。欲色界不隐没无记智慧。无漏见智慧。已离色界欲。成就无色界修道所断染污智慧。三界善见智慧。欲色界不隐没无记智慧。无漏见智慧。生色界阿那含。若不得无色界善心。成就色无色界修道所断染污智慧。色界善见智慧。欲色界不隐没无记智慧。无漏见智慧。若得无色界善心未离色界欲。成就色无色界修道所断染污智慧。色无色界善见智慧。欲色界不隐没无记智慧。无漏见智慧。已离色界欲。成就无色界修道所断染污智慧。色无色界善见智慧。欲色界不隐没无记智慧。无漏见智慧。生色界阿罗汉。成就色无色界善见智慧。欲色界不隐没无记智慧。无漏见智慧。生无色界阿那含。报心不现在前。成就无色界修道所断染污智慧。善见智慧无漏见智慧。若报心现在前。成就不隐没无记智慧。余如先说。生无色界阿罗汉。报心不现在前成就无色界善见智慧。无漏见智慧。若报心现在前。成就不隐没无记智慧。余如先说。若见断彼智断耶。答曰如是。若智断彼见断耶。答曰如是。若见断彼慧断耶。答曰。如是。若慧断彼见断耶。答曰。如是。若智断彼慧断耶。答曰如是。若慧断彼智断耶。答曰如是。谁断见智慧耶。答曰。是阿罗汉。余断有多有少者。已离无所有处欲阿那含。断三界见道所断八地修道所断见智慧。乃至未离初禅欲阿那含。断三界见道所断欲界修所道断见智慧须陀洹斯陀含。断三界见道所断见智慧。坚信坚法人。苦智已生集智未生。断三界见苦所断见智慧。乃至灭智已生道智未至。断三界见苦集灭所断见智慧离无所有处欲凡夫人。离八地见道修道所断见智慧。乃至离欲界欲凡夫人。断一地见道修道所断见智慧。诸正见是择法觉支耶。问曰。何故作此论。答曰。前论是此论所为根本。前作是说。云何为见。云何为智。云何为慧。而不作是说。诸正见是择法觉支耶。以前所说。是此论所为根本。今欲广说故而作此论

此阿毗昙中。有是决定相。若觉支后说道支者。当知道支一向无漏。若道支后说觉支者。当知道支是有漏无漏。此中道支。后说觉支故。当知道支是有漏无漏。或有正见非择法觉支。乃至广作四句。是正见非择法觉支者。世俗正见是也。所以者何。觉支一向是无漏故。是择法觉支非正见者。尽智无生智是也。所以者何。彼无见相故。是正见亦是择法觉支者。除尽智无生智。诸余无漏慧是也。彼是何耶。谓见道中诸忍。学八智无学正见是也。所以者何。彼有见相觉相故。非正见非择法觉支者。除上尔所事。若法已立名已称说者。作第一第二第三句。未立名未称说者。作第四句。彼是何耶。行阴作此四句。意识地善慧有漏无漏者。作前三句。余有相应不相应行阴。作第四句。余有四阴及无为法。亦作第四句。是名除上尔所事。诸正智是择法觉支耶。答曰。或正智非择法觉支。乃至广作四句。是正智非择法觉支者。世俗正智是也。所以者何。彼无觉支相故。是择法觉支非正智者。见道中八忍是也。所以者何。彼无智相故。是正智亦是择法觉支者。除见道中诸忍。诸余无漏慧是也。彼是何耶。学无学八智。所以者何。彼有智相觉支相故。非正智非择法觉支者。除上尔所事。如先说。此中异者。尽说一切善慧意地及五识地有漏无漏者。问曰。何故不问余觉支耶。答曰。亦应作是问。若正方便是精进觉支耶。答曰。若是精进觉支。亦是正方便。颇有正方便非精进觉支耶。答曰有。世俗正方便是也。余觉支道支亦应如是问而不问者有何意耶。答曰。应知此彼所说有余。复次此中说始终者始者是正见。终者是正智。如始入时。出时方便毕竟亦如是。复次若满足作四句义者则说。若唯有顺后句者。此中不说。复次此是智揵度。若法是见智慧性者。此中广分别

念觉支现在前时。几觉支道支现在前耶。问曰。何故作此论。答曰。有说。法生时次第非一时。如譬喻者。佛陀提婆作如是说。法生时次第不一时生。犹如多伴狭道中行。一出一入。不得一时二人并行何况多耶。如是有为法。各各从生相而生。有何势力。能一时生耶。问曰。彼何故作是说耶。答曰。彼依佛经。佛经说若心微劣。修三觉支者。便为非时。谓猗定舍觉支。是时应修三觉支。谓择法精进喜觉支。若心掉动修三觉支者。便为非时。谓择法精进喜觉支。是时应修三觉支。谓猗定舍觉支。若佛经说三觉支。是时三觉支非时者。当知法生时。次第而生。非一时生。亦更引余经如尊者舍利弗。作如是说。诸长老当知我得七觉支。随意自在。我于日初分。欲住如是觉支随意得住。以日中分后分。欲住如是觉支随意得住。以此二经所说。知法生时次第而生非一时生。欲止如是说者意。亦明法一时而生。问曰。若法一时而生。非次第生者。佛经云何通。如说修三觉支。是时三是非时。答曰。此经说。法生时一时而生。非不一时。所以者何。若心中有二有三觉支者。已明法一时而生非次第。问曰。此助道法。随其地无减少修者。何故言修三觉支。是时三觉支非时耶。答曰。觉支有二分。一是定分。二是慧分。若定分觉支现在前时。修慧分三觉支便为非时。所以者何。以定分势用偏多故。是时应修三觉支与上相违。说慧分亦如是。复次或有为定入圣道者。或有为慧入圣道者。若为定入圣道者。修定分三觉支。是时修慧分三觉支是非时。若为慧入圣道者。修慧分三觉支。是时修定分三觉支是非时。尊者舍利弗所说经。复云何通。答曰。尊者舍利弗善知出定入定身心相。若欲以日初分入如是觉支。便得随意自在。日中分后分亦如是。故作是说。复次此经说三地觉支。谓有觉有观地。无觉有观地。无觉无观地。若欲以日初分入有觉有观地觉支。以日中分。入无觉有观地觉支。以日后分。入无觉无观地觉支。皆得随意故作是说。复次此中说三根俱觉支。谓乐根喜根舍根俱觉支。若欲以日初分入乐根俱觉支。以日中分入喜根俱觉支。以日后分。入舍根俱觉支。皆得随意。故作是说。空无相无愿俱尽智无生智无学正见俱觉支说亦如是。譬喻者作如是说。此中说七地觉支。谓根本四禅三无色定觉支。在此七地中。若欲以日初分入初禅地觉支。乃至入无所有处地觉支。以日中分。以日后分。入初禅地觉支。乃至入无所有处地觉支。皆得随意。故作是说。复有说者。所以作论者。或有说诸边禅中有喜无戒。或说上地有正觉。或说无色地中有戒。为止如是等说者意故。而作此论

念觉支现在前时。几觉支道支现在前。答曰。若依有觉有观未至禅。学念觉支现在前时。六觉支八道支现在前。无学六。觉支九道支现在前。以是说用止诸边禅中有喜无戒者意。问曰。如未至禅定无有觉有观。何故作是说。依有觉有观未至禅耶。答曰。应作是说。若依未至禅定。应说有觉有观而作是说。有何意耶。答曰。欲令疑者得决定故。如四大揵度说。上地诸边。亦言未至。或有闻说未至。谓是上地未至。若说有觉有观。当知必是初禅未至。若依初禅。学念觉支现在前。七觉支八道支现在前。无学七觉支九道支现在前。若依禅中间。学念觉支现在前时。六觉支七道支现在前。无学六觉支八道支现在前。若作是说。则止说上地有正觉者意。如禅中间第三第四禅亦如是。若依第二禅。学念觉支现在前。七觉支七道支现在前。无学七觉支八道支现在前。若依无色界定。学念觉支现在前时。六觉支四道支现在前。无学六觉支五道支现在前。若作是说。则止说无色界有戒者意。诸觉支道支。一切地一切无漏心中所得者。说亦如念觉支。何者是耶谓择法精进猗定舍觉支正见正方便正念正定喜觉支现在前时。几觉支道支现在前。答曰。若依初禅。学喜觉支现在前时。七觉支八道支现在前。无学七觉支九道支现在前。若依第二禅。学喜觉支现在前时。七觉支七道支现在前。无学七觉支八道支现在前。正觉支现在前时。几觉支道支现在前耶。答曰。若依未至禅。学正觉现在前时。六觉支八道支现在前。无学六觉支九道支现在前。若依初禅。学正觉现在前时。七觉支八道支现在前。无学七觉支九道支现在前

问曰。何故诸边中无喜耶答曰。诸边离欲未离欲。能起现在前故。不能生喜。如人多处被缚。有解不解处。不能生喜。彼亦如是。问曰。何故上地无正觉耶答曰。非其田器故。乃至广说。复次为除正觉故求上地。若上地有觉者则下地不作方便。求于上地。若法下地有上地亦有者。则无次第灭。若无次第灭。则无究竟灭。所以者何。以次第灭。能到究竟灭。若无究竟灭。则无解脱。复次若有身业口业处。有正觉上地。无身业口业故无正觉。问曰。何故无色界无戒耶答曰。无田器故。乃至广说。复次为除戒故。求无色界。若无色界有戒者。则下地众生。不作方便。求无色界。若法下地有上地。亦有者。则无次第灭。若无次第灭。则无究竟灭。所以者何。次第灭能到究竟灭。若无究竟灭。则无解脱。复次戒是色少分。无色中无色戒。是四大造。无色界无四大。问曰。无无漏四大。何故有无漏戒耶。答曰。无漏戒不以四大力故是无漏。以心力故是无漏。复次戒对治恶戒。无色界无恶戒故无戒。所以者何。恶戒在欲界。欲界于无色界。有四事远。一以所依远二以所行远。三以所缘远。四以对治远

三十七助道法。四念处。四正断。四如意足。五根。五力。七觉支。八道支。佛说助道法。无三十七觉支是助道法。何以知之经说有一比丘往诣佛所。到已头面礼足。却住一面。而白佛言。世尊。所言觉支者。何故名觉支耶。佛告比丘。是七助道法故名觉支。谓念觉支。择法觉支。精进觉支。喜觉支。猗觉支。定觉支。舍觉支。以是事故。知觉支是助道法。问曰。助道法有三十七。世尊。何故说七觉支是助道法耶。答曰。随彼比丘所问佛说七觉支是助道法。若彼比丘问四念处者。佛亦说四念处是助道法。复次彼经一向说无漏助道法。余则不定如念处有二种。谓有漏无漏。乃至道支有漏无漏。复有说者。佛说三十七助道法。以经久时故。而亡失之。如陀罗达多所说助道法。应言一支。乃至三十七支。如三十七助道法。如斧柯喻经中亦说。无漏三十七助道法。若取决定修道。则是七觉支。若取不决定。则有六支种。所以者何。念处有二种。或有漏无漏。乃至道支亦如是。问曰。助道法。名有三十七。体有几耶。答曰。助道法。名有三十七。体有十一或十二。若说尽在觉支中。觉支名有七体亦七。四念处慧根慧力正见。尽在择法觉支中。四正断精进根精进力正方便。尽在精进觉支中。四如意足定根定力正定。尽在定觉支中。念根念力正念。尽在念觉支中。余者有信根道支中。有正语正业正命。若尽说在道支中者。若说正语正业外。更无正命者。八道支。名有八体有七。若说正语正业外。别有正命者。道支名有八体有八。四念处慧根慧力择法觉支。尽在正见中。四正断精进根精进力精进觉支。尽在正方便中。四如意足定根定力定觉支。尽在正定中。念根念力念觉支。尽在正念中。余有信根觉支中。有喜猗舍。以是事故。助道法。名有三十七。体有十一或十二。如名体。名数体数。名异体异。名异相体异相。知名知体亦如是。此是助道法体法性。乃至广说

何故名助道法。助道是何义。答曰。尽智无生智是菩提。此诸法随顺彼法。助彼法是彼法分势用胜故。名助道法。已总说助道法所以。今当各各别说所以。何故名念处耶。答曰。分别聚义是念处义。聚名五取阴。若欲分别。应以念处。而烧然义是正断义。积聚义法义是如意足义。增上胜义是根义。不可坏义是力义。觉知义是觉支义。求觅义是道支义

已别说助道法所以。今当别说觉支道支所以。何故名觉支。为以觉故名觉支。为以是觉支故名觉支耶。若以觉故名觉支者。一是六非。若以是觉支故名觉支者。六是一非。答曰。应作是说。以觉故名觉支。问曰。若然者。一是六非。答曰。此诸法尽是彼法分。尽随顺彼法势用胜故名觉支。复有说者。以是觉支故名觉支。问曰。若然者。六是一非。答曰。择法觉支。是觉是觉支。余唯是觉支。何故名道支耶。为以求觅故是道支。为以是求觅支故是道支。若以求觅是道支者。一是七非。若以是求觅支故是道支者。七是一非。答曰。应作是说。以求觅故是道支。问曰。若然者。一是七非。答曰。此诸法尽是彼法分。随顺彼法势用胜故名道支。复有说者。求觅支故是道支。问曰。若然者。七是一非。答曰。正见是求觅是求觅支。余是求觅支。如择法觉支是觉是觉支。如正定是禅。是禅支不非时食是斋是斋支正见亦如是。是求觅是求觅支

已各各别说助道法所以。今当求其次第。何故先说四念处。乃至后说八道支耶。答曰。随顺言说次第法故。复次佛说则随顺。问者则易受。复次四念处如眼见。余助道法如盲。不令堕不如法处。如众多盲人。有目将导。不令堕非道中。彼亦如是。复以念处能了了分别总相别相法。坏物体愚。坏缘中愚。取法实相。不令增减。复次念处从初觉地。乃至尽智无生智。势用常胜正断。从暖法以上。势用常胜如意足。从顶法以上。势用常胜五根。从忍法以上。势用常胜五力。从世第一法以上。势用常胜。道支于见道中胜。觉支于修道中胜。问曰。何故见道中道支胜修道中觉支胜耶。答曰。去义是道义。见道中去极速疾故。觉是觉支义。修道中有九种觉数数觉故。问曰。若见道中是道支修道中是觉支者。世尊何故先说觉支。后说道支耶。答曰。随顺言说次第法故。复次佛说则随顺。问者则易受。复次欲渐次增一支故。先说四法次说五七八法。复次欲渐出要法渐次增益故

已总说助道法次第。今当一一别说觉支道支次第。何故先说念觉支。后乃至舍觉支耶。答曰。随顺言说次第法故。复次佛说则随顺问者则易受。尊者瞿沙说曰。已见谛人。以忆念先所得法力。能满足修觉支。是故佛先说念觉支。如经说。行人正观此法念现在前。不生愚惑。能满足修念觉支。以念力故。于法能分别选择筹量。能满足修择法觉支。以于法能选择分别筹量故。便行精进。能满足修精进觉支。已行精进故。便生不杂味喜。能满足修喜觉支。以喜故身心猗乐。能满足修猗觉支。以定猗乐故心定。能满足修定觉支。以心定故。离贪忧住舍故。能满足修舍觉支。问曰。何故世尊道支中。先说正见。后乃至正定耶。答曰。随顺言说次第法故。复次佛说则随顺问者则易受。尊者瞿沙说曰。已见谛者以正见故。能修道支如说。以正见故。能修道支。如说。以正见故。能生正觉正语正业正命正方便正念正定

已说觉支道支次第。今当说地。何等地有几助道法。答曰。未至禅有三十六除喜。初禅有三十七。中间禅有三十五除喜正觉。第二禅有三十六除正觉。第三第四禅有三十五除喜正觉。无色中有三十二。除喜正觉正语正业正命

已说地。今当说现在前时。何地几助道法一时现在前耶。答曰。依未至禅。有三十六一时现在前。则有三十三。除三念处。所以者何。以所缘各异故。尚不能起二何况多。初禅有三十七。则有三十四一时现在前。亦除三念处。禅中间有三十五。则有三十二。一时现在前。亦除三念处。如中间禅第三第四禅亦如是。第二禅有三十六。则有三十三一时现在前。亦除三念处。无色中三十二。则有二十九现在前。亦除三念处

已说现在前。今当说同异相。若是觉支。亦是道支耶。答曰。或是觉支非道支。乃至广作四句。是觉支非道支者。喜猗舍觉支是也。是道支非觉支者。正觉正语正业正命是也。是觉支亦是道支者。除信诸余助道法是也。非觉支道支者信是也。问曰。何故喜立觉支耶。答曰。觉义是觉支义。喜随顺觉支。问曰。云何喜随顺觉支耶。答曰。若如实数数觉境界则生喜。若数数生喜。则如实觉境界。如人掘地得宝。得宝故更掘。更掘故复得。彼亦如是。问曰。何故喜不立道支耶。答曰。去义是道支义。喜不随顺去。问曰。何故喜不随顺去耶。答曰。若数数喜。则住不去。如人在道行。若数数止息。便欲住不去。彼亦如是。问曰。何故猗舍立觉支耶。答曰。觉义是觉支义。猗舍随顺觉支。问曰。云何猗舍随顺觉支耶。答曰。若于一切事得猗舍。则能如实觉境界。问曰。何故猗舍不立道支耶。答曰。去义是道支义。猗舍不随顺去。问曰。何故猗舍不随顺去耶。答曰。猗舍与去相违。如行住眠寤一向相违。彼亦如是。问曰。何故正觉立道支耶。答曰。去义是道支义。以正觉能发动正见出离生死故。如人以杖捶牛能有所至。彼亦如是。问曰。正觉何故不立觉支耶。答曰。正觉性发动觉支性寂静故。问曰。何故正语正业正命立道支耶。答曰。去义是道支义。正语业命。于道车为毂故。问曰。何故正语业命不立觉支耶。答曰。正语业命。是道支非道。复次正语业命是不相应无依无行无缘。觉支与此相违。问曰。信何故非觉支道支耶。答曰。始入法时。信势用胜故。已入法修觉支道支。复次出要法。有满足不满足。满足出要法者。有根力觉道相者是也。与此相违名不满足。若不满足出要法。有觉支相无道支相者立觉支。如喜猗舍。若无觉支相有道支相者立道支。如正觉正语业命。若满足出要法。有觉支道支相者。立觉支道支。如余觉支道支是也。若不满足出要法。无觉支道支相者。不立觉支道支。如信是也

问曰。何故不立心为助道法耶。答曰。无助道分故。复次心于烦恼出要法中。俱有势用。助道法于出要法中。偏有势用。复次心缘总相别相。助道法唯缘总相。复次如烦恼。是数法非心。彼对治法亦尔。是数法非心。若作是说。心定故名定者。即是助道法中定也

问曰。何故三根中。喜根立助道法。乐根舍根不立助道法耶。答曰。无助道相故不立助道分。复次助道法所行猛利。彼二根迟钝。所行不猛利。复次乐根为猗乐所覆蔽。舍根为行舍所覆蔽。是故不立助道法

问曰。圣种何故不立助道法耶。答曰。亦有立者。如毗婆阇婆提说。有三十一助道法。问曰。我不问如是说者。答曰。助道法于在家出家人中。有二事胜。一期心胜。二受行胜。圣种于出家人中二事胜。一期心胜。二受行胜。于在家人中。有一事胜。谓期心胜非受行胜。如帝释坐众华座上。十二那由他婇女。而自围绕有六万作音乐者。名住圣种。但有期心而不受行。如频婆娑罗王等。须达长者等。亦复如是。若作是说。乐断是精进者。即是精进觉支。波伽罗那经说。云何念觉支。答曰。圣弟子观苦是苦。乃至观道是道。与不坏智相应。为菩提念数数念次第念常不忘不失。是说未知欲知根。复次若圣弟子。见生死是过患。见涅槃是胜妙。为菩提念。乃至广说。是说知根。阿罗汉观解脱心念。是说知已根。乃至舍觉支。说亦如是。云何正见。答曰。若圣弟子。观苦是苦。乃至观道是道。是观察分别。能取其相。觉明见慧。是说未知欲知根。若圣弟子。见生死是过患。见涅槃是胜妙。是观察分别。乃至广说。是说知根。阿罗汉观自心解脱。是观察分别。乃至广说。是说知已根。乃至正定说亦如是

问曰。何故觉支中说为菩提念。道支中不说耶。答曰。应说而不说者。当知此说有余。复次欲现异文异说故。若以种种说庄严于文义则易解。复次欲现二门二略二初入法二影二俱通故。如觉支中说为菩提念。道支中说为菩提正见亦尔。如道支中不说为菩提正见。觉支中亦尔。复次先作是说。尽智无生智是菩提。修道中觉支势用胜。修道近尽智无生智。是故觉支中说为菩提非道支。经说为寂灭为离欲为涅槃故修不净观俱念觉支。乃至舍觉支。问曰。不净观是有漏。觉支是无漏。云何有漏无漏俱耶。尊者和须蜜说曰。先以不净观。令心随从调柔质直堪忍自在。次起觉支现在前。觉支后复起不净观。以觉支动不净观故。作如是说。而无有漏无漏俱者。佛经说。圣弟子一心摄耳听法。能断五盖。具足修七觉支。问曰。如定心能断结。非不定心。是意地非五识身。何故作如是说。一心摄耳听法。乃至广说。答曰。此说转转相生法。耳识次生善意识。善意识次生从闻生意。从闻生意次生从思生意。从思生意次生从修生意。以从修生意。而断烦恼。复次此说相续法。善意识与善耳识相续故。能断烦恼。而作是说。问曰。若无碍道。能断烦恼。不能满足修觉支。若解脱道。能满足修觉支。不能断烦恼。答曰。佛说相近法故。而作是说。诸法与念觉支相应。亦与择法觉支相应耶。答曰。或与念觉支相应。不与择法觉支相应。乃至广作四句。与念觉支相应非择法觉支者。是择法觉支。所以者何。以三事故。自体不与自体相应。一以二慧不得并生。二以前后不俱。三以一切诸法除其自体与余法作缘。与择法觉支相应非念觉支者。是念觉支。所以者何。以求故自体不与自体相应。如先说。与念觉支择法觉支相应者。诸法与念觉支择法觉支相应者。彼是何耶。答曰。与念觉支择法觉支俱聚中。俱除自体。诸余与念觉支择法觉支相应者。彼是何耶。谓八大地十善大地。若在有觉有观地。则有觉观及心非念觉支择法觉支相应者。诸余心心数法色无为心不相应行。此中多说无漏心。更无余者。余有有漏心心数法色无为心不相应行。作第四句。如念觉支。择法觉支念觉支念精进猗定舍觉支正方便正定。说亦如是。诸法与念觉支相应。亦与喜觉支相应耶。乃至广作四句。念觉支在一切地一切无漏心中。喜觉支在一切无漏心中。非在一切地。是故得作一中四句。与念觉支相应非喜觉支者。是喜觉支与念觉支相应聚中。喜觉支体。与念觉支相应。不与喜觉支相应。所以者何。以三事故。自体不与自体相应。如先说。余不与喜觉支相应。与念觉支相应法。彼是何耶。答曰。未至禅中间禅第三第四禅三无色中。与念觉支相应法。彼法不与喜觉支相应。所以者何。彼诸地中无喜故。与喜觉支相应。非念觉支相应者

阿毗昙毗婆沙论卷第四十八阿毗昙毗婆沙论卷第四十九

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    智犍度八道品下

念觉支与喜觉支相应。喜觉支俱聚中。念觉支体。与喜觉支相应。不与念觉支相应。所以者何。以三事故。自体不与自体相应。如先说。与念觉支亦与喜觉支相应者。除念觉支相应者。所以者何。以其多故除之。及念觉支喜觉支俱聚中念觉支喜觉支自体。诸余心数。尽与二相应。彼是何耶。谓八大地。十善大地。有觉观地。则有觉观。及心不与念觉支喜觉支相应者。不与喜觉支相应念觉支。彼是何耶。谓未至中间第三第四禅三无色中念觉支体不与念觉支相应。所以者何。以三事故。自体不与自体相应。如先说。亦不与喜觉支相应。所以者何。彼诸地中无喜故。诸余心心数法者。此中尽说一切无漏心。更无余有余。有漏心心数法。色无为心不相应行。作第四句。如念觉支。喜觉支念觉支正见正觉亦如是。诸法与念觉支相应。亦与正念相应耶。答曰。如是。设与正念相应。亦与念觉支相应耶。答曰。如是。如念觉支择法精进猗定舍觉支正方便正念正定。说亦如是。诸法择法觉支相应。亦与正见相应耶。答曰。若法与正见相应。亦与择法觉支相应。颇法与择法觉支相应。非正见耶。答曰有。正见所不摄择法觉支相应法。彼是何耶。谓尽智无生智相应法。诸法精进觉支相应。亦与正方便相应耶。答曰。如是。若与正方便相应。亦与精进觉支相应耶

答曰。如是。诸法与定觉支相应。亦与正定相应耶。答曰。如是。若与正定相应。亦与定觉支相应耶。答曰。如是诸法与喜觉支相应。亦与猗觉支相应耶。答曰。或与喜觉支相应。不与猗觉支相应。乃至应作四句。喜在一切无漏心中。不在。一切地中。猗在一切无漏心中。亦在一切地中。与喜觉支相应。非猗觉支相应者。猗觉支与喜觉支相应。喜觉支俱聚中。猗觉支体。与喜觉支相应。不与猗觉支相应。所以者何。以三事故。自体不应自体。如先说。与猗觉支相应。非喜觉支相应者。是喜觉支猗觉支俱聚中喜觉支体。与猗觉支相应。所以者何。以三事故。自体不应自体。如先说。余喜觉支不相应。猗觉支相应法彼是何耶。谓未至禅禅中间第三第四禅三无色中。猗觉支相应法。与猗觉支相应。非喜觉支。所以者何。彼地中无喜故。与喜觉支相应。亦与猗觉支相应者。除猗觉支及与猗觉支相应者。所以者何。以多故除之。与喜觉支猗觉支俱聚中者。除自体。诸余心心数法。俱与二相应。彼是何耶。谓九大地。九善大地。在有觉有观地。则有觉观。及心非喜觉支。亦非猗觉支相应者。喜觉支不相应猗觉支。彼是何耶。谓未至禅禅中间第三第四禅三无色中。猗觉支体。不与喜觉支相应。所以者何。彼地中无喜故。亦不与猗觉支相应。所以者何。以三事故。自体不应自体。如先说。诸余心心数法者。此中尽说一切无漏心。更无余有余有漏心心数法。亦色无为心不相应行。如是等诸法。不与喜觉支相应。亦不与猗觉支相应。如喜觉支猗觉支。喜觉支舍觉支正方便正念正定。说亦如是。诸法与喜觉支相应。亦与正见相应耶。喜在一切无漏心中。不在一切地。正见在一切地不在一切无漏心中。是故得作大四句。与喜觉支相应非正见者。正见与喜觉支相应。喜觉支俱聚中正见体。与喜觉支相应。不与正见相应。所以者何。以三事故。自体不应自体。如先说。余正见不相应喜觉支相应法。彼是何耶。初禅第二禅中。尽智无生智。俱聚中喜觉支相应法。不与正见相应。所以者何。是他聚故。与正见相应非喜觉支者。喜觉支与正见相应。正见俱聚中喜觉支体。与正见相应。不与喜觉支相应。所以者何。以三事故。自体不应自体。如先说。余喜觉支不相应。正见相应法。彼是何耶。谓未至禅禅中间第三第四禅三无色中正见相应法。不与喜觉支相应。彼地中无喜故。与喜觉支亦与正见相应者。除正见与喜觉支相应。除喜觉支与正见相应。诸余心心数法。彼是何耶。谓八大地。十善大地。在有觉有观地。则有觉观。及心不与喜觉支。亦不与正见相应者。正见不与喜觉支相应。彼是何耶。未至禅禅中间第三第四禅三无色中正见体。不与喜觉支相应。所以者何。彼地中无喜故。不与正见相应。所以者何。以三事故。自体不应自体。如先说。喜觉支不与正见相应。彼是何耶。初禅第二禅尽智无生智俱中喜觉支体。不与正见相应。所以者何。是他聚集故不与喜觉支相应。所以者何。以三事故。自体不应自体。如先说。余心心数法。彼是何耶。未至禅禅中间第三第四禅三无色中。尽智无生智。俱聚有漏心心数法。色无为心不相应行。如喜觉支。正见喜觉支正觉正觉于正见。说亦如是

云何世俗正见。云何世俗正智。问何故作此论。答曰。前论是此论所为根本。前论作如是说。云何为见。云何为智。云何为慧。而不作是论。云何世俗正见。云何世俗正智。以前论是此论所为根本。今欲广分别故。而作此论。复有说所以作论者。或有说意识相应善慧不尽是见性。如譬喻者说。彼是何耶。谓次五识生者。能起身口业者死时心。问曰。彼何故说次五识生者非见性耶。如五识不能分别彼次生。意识亦不能分别。何故能起身口业者非见性耶。答曰。见行内。彼行于外。何故死时心非见耶。答曰。见有势力。彼慧微劣。问曰。彼作是说。云何通佛经如是说。人欲死时。善心心数法。与正见俱。答曰。彼作是说。佛说死时前相续心非死时心。为止如是说者意亦明一切意识相应有漏善慧尽是见性故。而作此论

云何世俗正见。答曰。意识相应有漏善慧。彼是何耶。谓不净觉相应者。安那般那念念处与暖顶忍世第一法相应者。与禅无量解脱胜处一切处相应者。世俗正见。多于四大海水。此中略说粗者。云何世俗正智。答曰。意识相应有漏善慧。彼是何耶。答曰不净觉相应。乃至世俗正智。多于四大海水。及五识相应善慧。彼是何耶。善眼识相应。乃至善身识相应者。善眼识相应慧。何者是耶。答曰。如见父母佛辟支佛声闻及诸尊重处。生善眼识善耳识相应慧。何者是耶。答曰。如闻佛语及父母诸尊重处语。生善耳识。余善三识。非常人能起。唯除观抟食修行者。能起三善识。已说体性。今当说同异相。若是世俗正见。亦是世俗正智耶。答曰。若是世俗正见。亦是世俗正智。颇是世俗正智。非世俗正见耶。答曰有。五识相应善慧是也。世俗正见摄世俗正智世俗正智摄世俗正见耶。答曰。世俗正智摄世俗正见。非世俗正见摄世俗正智。不摄何等。谓五识相应善慧

若成就世俗正见。亦成就世俗正智耶。答曰。如是。若成就世俗正智。亦成就世俗正见耶。答曰。如是。谁成就世俗正见世俗正智耶。答曰。不断善根者。总而言之。是不断善根者。然有多少。或有但成就欲界善见智者。但成就色界者。或有但成就无色界者。或有成就欲色界者。或成就色无色界者。或有成就欲色无色界见智者。以是事故。总而言之。是不断善根者。然有多少

若断世俗正见。亦断世俗正智耶。答曰。如是。若断世俗正智。亦断世俗正见耶。答曰。如是。谁断世俗正见正智耶。答曰。阿罗汉。总而言之。是阿罗汉。余人则有多少。若离无所有处欲。断八地正见正智。乃至离欲界欲。未离初禅欲。断一地正见正智。是故总而言之。是阿罗汉。余人则有多少

问曰。何故名世俗耶。为以毁坏故言世俗耶。为以是贪立足处言世俗耶。若以毁坏言世俗者。无漏道亦毁坏。应是世俗。若以是贪立足处言世俗者。亦恚痴立足处。答曰。应作是说。以毁坏言世俗。问曰。若然者。无漏道亦毁坏。应是世俗。答曰。若毁坏增长于有无漏道虽毁坏不增长。于有令有损减。复次毁坏能令有相续生老病死相续。无漏道虽毁坏能断有不令生老病死相续。复次若毁坏是苦集道迹生老病死道迹。无漏道虽毁坏是灭苦集道迹灭生老病死道迹。复次若毁坏是身见。爱使所缘处是贪恚痴立足处。杂垢杂毒杂过杂滓坚在苦集性中者。是世俗。圣道与此相违。不名世俗。复次有说者。是贪立足处言世俗。问曰。若然者亦是恚痴立足处。答曰。若说是贪立足处亦是恚痴立足处。问曰。若世俗是毁坏耶。答曰。或是世俗非毁坏。乃至广作四句。是世俗非毁坏者。过去未来二漏。是毁坏非世俗者。现在道谛。是毁坏亦是世俗者。现在二漏。非毁坏亦非世俗者。过去未来道谛。一切无为法。经说长老式蜜提往诣佛所而白佛言。世尊。所言世俗者是何耶。佛告式蜜提。以毁坏故言世俗。复问。何等是毁坏。佛告式蜜提。眼入是毁坏。乃至意入是毁坏。问曰。世尊。何故说入是世俗耶。答曰。为受化者故。受化者应闻入是世俗乃得悟解故。佛说入是世俗。问曰。毁坏有何差别耶。答曰。毁者是刹那顷无常。坏是身坏时无常。复次毁是细无常。坏是粗无常。复次毁是内法无常。坏是外法无常。复次毁是众生数法。坏是非众生数法

云何无漏见。云何无漏智。问曰。何故作此论。答曰。前论是此论所为根本。前论作如是说。云何为见。云何为智。云何为慧。而不作是说。云何无漏见。云何无漏智。以前论是此论根本。今欲广分别故。而作此论。复次欲说近对治法故。先说云何世俗正见云何世俗正智。何法是其近对治。谓无漏见智。故作此论。云何无漏见。答曰。尽智无生智所不摄余无漏慧。彼是何耶。见道中八忍学八智无学正见。云何无漏智。答曰。除见道中诸忍。余无漏慧。彼是何耶。学无学八智是也

已说体性。今当说同异相。诸无漏见。是无漏智耶。答曰。或是无漏见非无漏智。乃至广作四句。是无漏见非无漏智者。见道中诸忍是也。所以者何。彼有见相无有智相。是无漏智非无漏见者。尽智无生智是也。所以者何。彼是智相无有见相。是无漏见亦是无漏智者。除见道中诸忍尽智。无生智余无漏慧是也。彼是何耶。学八智无学正见是也。所以者何。彼是见相亦是智相。非无漏见非无漏智者。除上尔所事。若法已立名已称已说者除之。余未立名未称未说者。作第四句。彼是何耶。行阴作此四句。一切无漏慧。作三句。有见相智相者。余有相应不相应行阴四阴及无为法。作第四句。是名除上尔所事。摄亦如是。若成就无漏见。亦成就无漏智耶。答曰。若成就无漏智。亦成就无漏见。颇成就无漏见。非无漏智耶。答曰。有住苦法忍时

问定理摄成就不说断。问曰。何故不说断耶。答曰。若说于文不烦。彼尊者迦旃延子。乃至不舍一刹那。而作文分别。若所说于文烦者。如四大海水。文义尽略说之。复次以垢故断。无漏法无垢故不断。问曰。若无漏法不断者。佛经云何通。如说。比丘汝若解筏喻法者。法尚应断。何况非法。答曰。断二种。一除爱断。二舍断。此中说舍断。无漏法虽无除爱断。而有舍断。以舍断故。而作是说。诸比丘。舍圣道尽漏。以念恩故。复数数起圣道现在前。而受种种身苦。谓头痛等苦。是故佛作是说。比丘当知。圣道所应作者。皆已作之。应舍此道入于涅槃。如人依筏渡河。以念恩故。犹顶戴肩负。他人语言。汝男子筏所应作皆已作之。汝今应舍随意而去。彼亦如是

云何是法云何非法耶。答曰。内道言说是法。外道言说是非法。内道法随顺空。随顺无我。随顺涅槃。法尚应舍。何况外道言说。令有相续令生老病死相续者耶。复次善受持名句味身者是法。不善受持者是非法。善受持名句味身者尚舍。何况不善受持名句味身者。尊者瞿沙说曰。善受持阿含经者名法。不善受持者名非法。以增长生死故应舍。何况非法。尊者波奢说曰。正观是法。不正观是非法。正观法尚应舍。何况不正观法耶。复次惭愧是法。无惭愧是非法。三善根是法。三不善根是非法。四念处是法。四颠倒是非法。五根是法。五盖是非法。六念是法。六爱身是非法。七觉支是法。七使是非法。八道支是法。八邪支是非法。九次第定是法。九结是非法。十善业道是法。十不善业道是非法。如是等法尚应断。何况非法

    阿毗昙毗婆沙论智犍度他心智品第二

云何他人心智。云何念前世智。如是章及解章义。此中应广说优波提舍。问曰。彼尊者迦旃延子。何故依二智而作论。答曰。彼尊者有如是欲如是意。随其欲意而作论。亦不违法相。彼意欲因二智而作论。即论二智。谓他心智。念前世智。意欲论二智故。余处亦因二智而作论。如根揵度中论法智比智。余处亦因二智而作论。如定揵度论尽智无生智。余处意欲论四智。即因四智而作论。如根犍度论苦集灭道智。如说。若苦智是苦无漏智耶。乃至若道智是道无漏智耶。余处意欲论八智。即因八智而作论。如使犍度定犍度智犍度所说。余处意欲论十智。即因十智而作论。如说。眼根以几智知。犹如善巧陶师。先调柔泥团。安置轮上。随其欲意。作种种器。彼尊者亦尔。以闻思慧。观察法相。断缘中愚故。随其欲意造论。亦不违法相。复次此二智。以离欲得方便得体是修慧亦是通体是四支五支禅果故。复次此二智体。是智性见性。复次以此二智各缘一世。他心智缘现在世。念前世智缘过去世。若作是说。念前世智是有漏无漏者。应作是说。以此二智是有漏无漏故

云何他心智。答曰。若智是修是修果从修生得不失。是修者。体是修。是修果者。是四支五支禅果。从修生者。修习故。得不失者。得不舍。问曰。何故不说已得当得者。但说今得耶。答曰。应说而不说者。当知此说有余。复次若得此智。名得道者。名知他心者。是中说之。非已得当得者。以失故。以此智知他心所觉所观所行。所觉者是欲界初禅。所观者。是中间禅。所行者。是上三禅。复有说者。所觉是欲界初禅。所观者从欲界乃至中间禅。所行者从欲界乃至第四禅。问曰。他人心觉观缘色时他心智。亦知他心所缘色耶。答曰。外国法师经文作如是说。若智知欲色界现前他人心心数法及无漏心。是名他心智。问曰。罽宾沙门。何故不作如是说耶。答曰。亦应作如是说。而不说者。有何意耶。答曰。言所觉所观所行者。说其体。不说所缘处心心数法。如实知之。心者是心数。法者是数法。如实知之者。是说知境界。应说一。知他心智。谓知他心智通。应说二。谓知有漏无漏及缚解系不系。应说三。谓上中下。应说四。谓四禅果。应说六。谓有漏上中下无漏上中下。应说八。谓四禅有漏无漏。应说九。谓下下乃至上上。应说十二。谓四禅中各有三种。谓上中下。应说十八。谓有漏有九无漏有九。应说二十四。初禅有漏有三无漏有三。乃至第四禅亦尔。应说三十六。谓初禅有九种。乃至第四禅有九种。应说七十二。初禅有漏有九种。无漏有九种。乃至第四禅亦尔。若以在身。若在刹那。则有无量无边他心智。此中总说一种他心智而作论

问曰。他心智体是何耶。答曰。体是慧已说体性。所以今当说。何故名知他心智。答曰。知他心故名知他心智。问曰。亦知数法。何故但名知他心耶。答曰。以期心故。行者期心。勤修方便。欲知他心。不期数法。亦知数法故名知他心智。如人求见于王。不求见眷属。若见王时。亦见眷属。彼亦如是。复次诸法立名。各有所以。或以自体。或以对治。或以方便。或以相应。或以所依。或以所行。或以所缘。或以行以缘。以自体者。如五阴四谛等智是也。余解广说如上

界者。有漏是色界系。无漏是不系。问曰。何故无色界无他心智耶。答曰。非其田故。乃至广说。复次他心智因色故生。无色界无色。地者。是四根本禅地。不在诸边无色地。问曰。诸边中何故无知他心智耶。答曰。此是通若有三昧。能生通果。则有此智。诸边中无此定故。问曰。中间禅心。以何知他心智知耶。答曰。或有说者。以初禅地者知。复有说者。以二禅地者知。评曰。应作是说。以初禅地者知。所以者何。是一地法故。所依者依欲色界。身行者无漏者行道等四行。有漏者不行行缘者。初禅地者。缘欲界初禅二禅地者。缘欲界乃至第二禅第三禅地者。缘欲界乃至第三禅第四禅地者。缘欲界乃至第四禅。他心智不知无色界。问曰。何故他心智不知无色界。答曰。他心智不知上地法。初禅他心智。不知第二禅心。乃至第三禅他心智。不知第四禅心。问曰。生欲色界。起无色定现在前。他心智能知彼心心数法不耶。答曰。不知。所以者何。如果时不知。因时亦尔。念处者是三念处。除身念处。智者是四智。谓法智比智道智等智。三昧者无漏者与道无愿相应。有漏者不与相应。根者总与三根相应。谓乐喜舍根。世者在三世。缘三世者。过去者缘过去。现在者缘现在。未来不生者缘三世。必生者缘未来。善不善无记者。是善缘。善不善无记者缘三种。三界系及不系者。有漏是色界系。无漏是不系。缘三界系及不系者。缘欲色界及不系。是学无学非学非无学者。是三种。缘学无学非学非无学者。尽缘三种。见道断修道断不断者。有漏者是修道断。无漏者是不断。缘见道修道不断者。尽缘三种。缘名缘义者是缘义。缘自身他身及非。身者缘他身。是方便得。离欲得者。是方便亦是离欲。初禅者离欲界欲得。乃至第四禅离三禅欲得。方便者以方便现在前。佛不以方便现在前。辟支佛以下方便。声闻或以中。或以上方便。问曰。他心智方便云何。答曰。如施设经说。初行者先取自身相。若身有如是色。则有如是心。若有如是心。则身有如是色。取自身相已。亦取他人身相。若他身有如是色。则有如是心。若有如是心。则身有如是色。取如是相已。作是思惟。今此众生。为何所观何所分别。作是思惟时。如实知之。此众生如是思惟如是分别。是名他心智。满足集法经亦说。他心智方便云何。答曰。观五取阴。是苦空无常无我。作如是观无漏智。问曰。如他心智缘四谛智。何故但说缘苦智者耶。答曰。应说尽缘。而不说者。当知此说有余。复次此说初起入法方便。若说缘苦智。当知亦说缘余智。问曰。前方便此后方便。有何差别耶。答曰。前所说方便。至有漏无漏。此所说方便。一向是无漏。复次后方便。胜妙明净胜前方便。问曰。若眼不见色。为能知他心不耶。答曰。能知。以耳闻其声故。若眼不见色。耳不闻声。为能知他心不。答曰。知。以鼻嗅其香故。若眼耳鼻不见色闻声嗅香。为能知他心不耶。答曰。知。以舌知味故。若不见色闻声嗅香知味。为能知他心不耶。答曰。知。以身触故。若不见色。乃至身不觉触。为能知他心不耶。答曰。或有说者。不知。所以者何。以他心智因色故。评曰。应作是说。方便时不知。满足时能知。问曰。何故他心智方便时因色生耶。答曰。因粗得入细故。他心智方便时缘自己。满足时不缘自己。问曰。何故他心智方便时缘自己。满足时不缘自己耶。答曰。他心智不缘他心所缘所行。若他心智。缘他心所缘所行者。亦可名自心智。本曾所得有漏心心数法十五种。欲界有三种。谓上中下。乃至第四禅亦有三种。初禅地下有漏他心智。知欲界三种心心数法。及知初禅下有漏心心数法。中者。知欲界三种。知初禅下中二种。上者知欲界三种初禅三种。如初禅乃至第四禅。上者知十五种。如本曾起有漏心。有十五种。未曾得有漏心。亦有十五种。无漏心有十二种。初禅地有三种。谓上中下。乃至第四禅亦尔。第二禅地下无漏心。知初禅地下无漏心。亦知二禅下者第二禅。中者知初禅第二禅下中二种。上者知初禅第二禅下中上三种。知第二禅乃至第四禅。上者知十二种无漏心心数法。问曰。何故下有漏他心智。知下地三种及自地下者。无漏下他心智。知下地下心心数法及自地下者。非中上耶。答曰。有漏心心数法异。无漏心心数法异。一身中可有三种有漏心心数法无漏心心数法。以根故别。若是下根则无中上根。乃至若是上根。则无中下根

他心智不知胜地胜根胜人心。胜地者。初禅地他心智。不知第二禅地心心数法。乃至第三禅地。不知第四禅地心心数法。胜根者。下根他心智。不知中上根心心数法。胜人者。学人他心智。不知无学人心心数法。问曰。一切无学人他心智。尽知学人心心数法耶。答曰。不知。时解脱不知见到心。见到不知时解脱心。所以者何。见到于时解脱根胜故。时解脱于见到人胜故。问曰。学人起第二禅心现在前。无学人起初禅心现在前。为展转相知不。答曰。不知。所以者何。无学人于学人人胜。学人于无学人地胜。声闻起第二禅心心数法现在前佛起初禅心心数法现在前。为展转相知不。答曰。不知。所以者何。佛于声闻根胜。声闻于佛地胜。欲界有四种变化心。谓初禅果。乃至第四禅果。初禅地他心智。为知此四种心不。答曰。或有说者知。所以者何。尽是欲界心故。复有说者。唯知初禅果。余则不知所以者何。如不知因。果亦不知

是佛所有无漏心。及未曾得有漏心。无有他心智能知者。已曾得有漏心。佛欲令他知则知。若佛欲令钝根者知。利根者不知。钝根者则知。利根者不知。佛欲令萨波达知舍利弗不知。萨波达则知。舍利弗不知。欲令畜生得知人不知者。畜生则知人不知。何以知之。有经说。佛住那提迦夜城矜迦精舍时。众多比丘。置钵在露地。及世尊钵。亦在露地。尔时有一猕猴。从娑罗树下。往诣众多钵所。时诸比丘。恐破钵故。皆共遮之。尔时世尊告诸比丘。汝等莫遮此猕猴。不破汝等钵也。尔时猕猴取世尊钵。徐还上树。盛满流蜜。以奉世尊。世尊不受。以杂虫故。尔时世尊。起世俗心。欲令去虫。是时猕猴即知佛意却在一面。除蜜中虫。复上世尊。世尊不受。以未作净故。世尊复起世俗心。若此猕猴。以水作净者。我则受之。是时猕猴即知佛心。以水作净。佛便受之。以其净故。尔时猕猴以世尊受其蜜故。心生欢喜。踊跃无量。起舞却行。堕坑而死。得生人中。于佛法出家。得阿罗汉道。名摩头婆肆吒。以是事故。尊者波毗奢。作偈赞佛

  欲令人天知佛心　　随其所念皆能知
  若入诸禅深妙定　　无有能知佛心者

问曰。佛为得知佛心他心智不耶。答曰。或有说者。不得。所以者何。世无二佛故。复有说者得。以能缘故。不以起现在前。辟支佛如渴伽兽角独出世者。与佛无异。若作是说。众多出世者。有缘辟支佛心他心智亦能缘亦能起现在前。声闻有知声闻心他心智亦能缘亦能起现在前。佛所有无漏心。及未曾得有漏心。无色界心。无有他心智。能知此心者

众生或有生有灭。生者。生欲界色界众生。及生无色界凡夫人。为当得他心智不耶。答曰。以二事故当得。一以能缘。二以现前行。灭者。生无色界圣人。若涅槃者。为当得他心智不。答曰。不当得。复有说者。当得。以能缘故。不以现前行。评曰。不应作是说。当得不现前行。宁当说不得。不当说得。不现在前行

有境界。是佛他心智所知。非辟支佛声闻所知有境界。是佛辟支佛他心智所知。非声闻所知有境界。是佛辟支佛声闻他心智所知。如经说。比丘当知。雪山中有如是处。猕猴所不能行。人亦不能行。有处所猕猴能行人不能行。有处所猕猴能行。人亦能行。雪山犹如境界。猕猴如辟支佛。人如声闻。如是之义。今当显现。见道有十五心。他心智知相似法。有漏者知有漏。无漏者知无漏。已曾得者。知已曾得。未曾得者。知未曾得。法智分者知法智分。比智分者知比智分。声闻人他心智。见道中知二心。辟支佛知四心。佛一一次第知。所以者何。辟支佛声闻。以方便现在前。佛不以方便现在前。行者入见道作方便。声闻入为法智分他心智作方便。行者已入见道。声闻起法智分他心智现在前。能知行者二心。谓苦法忍苦法智。行者入比智分。声闻人为比智分他心智作方便。行者已入比智分。声闻人起比智分他心智现在前。欲知苦比忍乃知道比智。行者为见道作方便。辟支佛为法智分他心智作方便。行者已入见道。辟支佛起法智分他心智现在前。知行者二心。谓苦法忍苦法智。行者入比智分。辟支佛为比智分他心智作方便。行者已入比智分。辟支佛起比智分他心智现在前。欲知苦比忍乃知灭比忍灭比智。佛不以方便一切功德现在前。如行者一一次第起见道现在前。世尊以他心智。一一次第而知

佛于三种道。以总相知。亦以别相知。辟支佛亦知三种道。于声闻辟支佛道。以总相别相知。于佛道以总相知。不以别相。声闻亦知三种道。于声闻道。以总相别相知。于辟支佛道。以总相知。不以别相。问曰。声闻见道谛时。为见辟支佛佛道不。若见者。他心智何故不知。若不见者。云何得缘彼不坏信耶。答曰。应作是说见。问曰。若然者。他心智何故不知耶。答曰。以总相智见。他心智是别相知故。一众生所有他心智。知一切众生心心数法。知时为知受体。为知受诸刹那耶。若但知受体者。诸余受不被知者。云何知耶。若知受诸刹那者。云何自身非众多耶。自身众多者。我他心智。体有二十一种。知一众生一刹那受。如一刹那受。余一切刹那受亦尔。如受刹那。余心心数法刹那亦尔。如一众生心心数法。余众生心心数法亦尔。我他心智俱心心数法则多。一切众生。如我心心数法多。所依身亦应多。答曰。应作是说。知受体。问曰。若然者。余所不知受。云何知耶。答曰。若知余受。无有是处。知时唯知所知者。复有说者。知受诸刹那。问曰。若然者。云何自身非众多耶。答曰。多有何过。所以者何。如我他心智体。有二十一种。知一切众生心心数法。一切众生他心智体。亦有二十一种。知我心心数法。是故无过。问曰。他心智。为缘过去缘未来缘现在耶。答曰。缘现在。问曰。若然者经本所说云何通。如说。过去未来法九智知。答曰。经本应作是说。过去未来法八智知。除灭智他心智。而不说者。有何意耶。随缘故说。过去者缘过去。未来者缘未来。若如所说。他心智知三刹那。谓知现在刹那。次前灭者。次当生者。经本应作是说

问曰。他心智为缘一法。为缘多法耶。若缘一法。经所说云何通。如说。有欲心如实知有欲心。若一时知欲亦知心者。岂非知多法耶。余经所说复云何通。如说。当世尊忆念时。遍知众僧心之所念。若缘多法者。云何体是三念处耶。答曰。应作是说。缘于一法。问曰。若然者。佛经云何通。如说。如实知有欲心。答曰。心与欲相应故。名有欲心。若知欲不知心。若知心不知欲。如观垢衣。若观垢则不观衣。若观衣则不观垢。彼亦如是。余经复云何通。如说。世尊当忆念时遍知众僧心之所念。答曰。以比相知。非以他心智。世尊以他心智。观一比丘心住寂静道。次以比相智知诸比丘心亦尔。复有说者。世尊不以他心智知。亦不以比相智知。乃以愿智知。复有说者。世尊不以他心智比相智愿智知。世尊得尽智时。得未曾得欲界不隐没无记心心数法。亦不入禅。亦不起通现在前。当忆念时遍知诸比丘僧心。复有说者。知多法。问曰。若然者。云何体是三念处耶。答曰。初方便时是三念处通。若满足是总缘法念处。评曰。应作是说。一切他心智缘一法。是别相观。缘现在缘他缘心心数法。见道中无。在修道中。不与空无相三昧相应。不摄尽智无生智。无碍道中无他心智。法应如是。云何念前世智。答曰。若智是修是修果。从修生得不失。以此智忆念过去无数生。如是相貌。是名念前世智。是中问答。广说如他心智。云何如是相如是貌。答曰。如是相者是前时有。如是貌者是中有。复有说者。如是相是中有。如是貌是前时有。所以者何。前时有可示此是刹利婆罗门毗舍首陀差别貌。如经说

佛告阿难。若有如是相如是貌施设者。名色身。若无如是相如是貌可施设。有对触不。答言。不也。彼经说。内入是相外入是貌。复有说者。彼经说。内入是貌外入是相。所以者何。以内入故。说诸识相差别。如说除上尔所事。是中无如是相貌。是以除之。如说。若以如是相如是貌入初禅。如是相者是方便。如是貌者是所缘。如偈说

  若成就八智　　十六行相貌
  如阎浮檀金　　无能说其过

是中说慧名相貌。过去无数生者。是说念前世智境界。应说一。念前世智。得念前世智通念前世明念前世力。应说二。谓已曾得未曾得。应说三。谓上中下。应说四。谓初禅果乃至第四禅果。应说六。已曾得有三种。未曾得有三种。谓上中下。应说八。初禅地有二种。谓已曾得未曾得。乃至第四禅地亦如是。应说九。谓下下乃至上上。应说十二。初禅有三种。谓上中下。乃至第四禅亦如是。应说十八。谓已曾得有九种。未曾得有九种。应说二十四。初禅有六种。谓已曾得有三种。未曾得有三种。乃至第四禅亦如是。应说三十六。初禅有九种。乃至第四禅亦如是。应说七十二。初禅已曾得有九种。未曾得有九种。乃至第四禅亦如是。若以在身若在刹那。则有无量无边念前世智。此中因总说一念前世智而作论。问曰。念前世智体性是何。答曰。体性是慧。以念力多故名念前世智。如念处体性是慧。以念力多故名念处。如阿那波那念体性是慧。以念力多故名阿那波那念。忆前生念体性是慧。以念力多故名忆前生念。除色想体性是慧。以想力多故。名除色想。如是念前世智体性是慧。以念力多故名念。前世智。此是念前世智体性。乃至广说

阿毗昙毗婆沙论卷第四十九阿毗昙毗婆沙论卷第五十

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    智犍度他心智品第二之二

已说体性。所以今当说。何故名念前世智。答曰。念前世阴故名念前世智

界者是色界。问曰。何故无色界中。无念前世智。答曰。非其因故。乃至广说。复次念前世智因色生。无色界无色故。无地者。在根本四禅地。非诸边无色中。所以者何。若有通所依定处。是处有念前世智。诸边无色中无通所依定故。无念前世智。问曰。以何地念前世智念中间禅耶。答曰。或有说。以初禅者。复有说。以第二禅者。评曰。应作是说。以初禅者。所以者何。同一地故。所依身者。依欲色界身。行者无所行缘者。初禅念前世智。知初禅及欲界前生五阴。乃至第四禅者知欲界。乃至第四禅前生五阴。不知无色界。问曰。何故念前世智。不知无色界耶。答曰。念前世智不知上地法。初禅者不知第二禅前世五阴乃至第三禅。不知第四禅前世五阴。无色界中则无念前世智。问曰。生欲色界中。起无色定现在前。念前世智为能知不。答曰。不知。所以者何。如不知果。因亦如是。问曰。若念前世智。不知无色界者。佛经云何通。如说世尊于过去处处无数生。若生有色无色有想无想。过去无数生。有如是相貌。尽能忆念。问曰。说何者是色何者非色。答曰。色者是前时有。无色者是中有。问曰。若然者声闻亦能知。与佛有何异。复有说者。色者是欲色界。无色者是无色界。问曰。若然者。世尊云何知无色界耶。答曰。以比相知。问曰。若然者。声闻以比相亦能知。与佛有何异耶。答曰。如外道观前世事。若于欲界色界不见则言断灭。声闻观前世事。若于欲界色界中。过二万劫不见者。言是众生生于空处。而彼众生。或于上地。未尽其寿。若过四万劫不见者。言是众生生于识处。而彼众生。或再生空处。或于上地。未尽其寿。若过六万劫不见者。言是众生生无所有处。而彼众生。或三生空处。或一生半生识处。或于非想非非想处。未尽其寿。若过八万劫不见者。言是众生生非想非非想处。而彼众生。或四生空处。二生识处。一生半生无所有处。世尊若欲观无色界时。众生于欲色界中命终者。观其死时。心知是众生生于空处。是众生生于识处。是众生生无所有处。是众生生非想非非想处。是众生尽寿。是众生不尽寿。若于无色界命终生欲色界者。观生时心知是众生从空处死。乃至从非想非非想处死。是众生尽彼寿。是众生不尽彼寿。外道比相智见于断灭。声闻比相智所知。或如其事。或不如其事。佛世尊比相智。明净妙好。悉如其事。无有虚者。念处者是总缘法念处。尊者瞿沙说。是四念处。如所说念前世苦乐事。若念苦乐。岂非是受念处耶。答曰。前世时。或曾得乐所须具苦所须具。念是事故。作如是说。而实是总缘法念处。智者是等智。尊者瞿沙说是六智。除他心智灭智。所以除他心智者。以缘现在故。所以除灭智者。以缘无为故。评曰。应作是说。是一等智。三昧者不与三昧相应。根者总与三根相应。世者在三世。缘三世者。过去现在者缘过去。未来者缘三世。善不善无记者。是善缘善。不善无记者缘三种。三界系者。是色界系。缘三界系者。缘欲色界是学无学非学非无学者。是非学非无学。缘学无学非学非无学者。缘非学非无学。是见道断修道断不断者。是修道断。缘见道断修道断不断者缘见道修道断。缘名缘义者。缘名缘义。缘自身他身非身者。是缘自身他身。是离欲得方便得者。是离欲得。亦以方便离欲时。得方便起现在前。初禅者离欲界欲得。乃至第四禅者。离三禅欲得。圣人佛法凡夫得本曾得未曾得。念前世智。外道凡夫得本曾得。念前世智离欲时。得方便起现在前。佛不以方便起现在前。辟支佛以下方便。声闻或以中。或以上方便。问曰。念前世智方便云何。答曰。如施设经说。初行始入法者。取次前灭意识相。念已知之。复取久灭意识相。问曰。取久灭意识相。为以时为以刹那耶。答曰。以时。若以刹那者。则不能念半便死。可是方便。无满足者。取此生老时相。念已知之。次取中年时相。次取少年时相。次取童子时相。次取婴孩时相。次取波奢佉时。次取健那时。次取卑尸时。次取阿浮陀时。次取迦罗罗时相。念已知之。次取欲入母胎时心相。念已知之。是名念前世智满足。不应作是说。所以者何。中有中死。次入母胎中有。即属此生。评曰。应作是说。若能念知前世死时最后一刹那者。是名念前世智满足。问曰。欲修念前世智时。为缘自身为缘他身。答曰。或有说者。缘自身。问曰。若然者。无色界命终者。则不可尔。复有说者。缘他身。评曰。应作是说。缘自身。亦缘他身缘自身作方便。若自见从无色界命终者。则缘他身。令得满足。若缘他身作方便。见他从无色界命终者。则缘自身。令得满足。是故缘自身他身。修念前世智。令得满足

问曰。念前世智。为念曾所更事。为念未曾所更事耶。答曰。念曾所更事。问曰。若然者则无念生净居天者。所以者何。无有曾生净居天者。答曰。曾更有二种。谓若见若闻。净居天处。虽不曾见。而得曾闻

问曰。为因欲界生此智耶。为因色界生此智耶。答曰。亦因欲界。亦因色界。或有因欲界作方便。于色界得满足。或有因色界作方便。于欲界得满足。或有因欲界作方便。于欲界得满足。或有因色界作方便。于色界得满足。因欲界作方便。于色界得满足者。与恶性难共住。众生同在一处。作是思惟。如此恶性难共住。众生必是于欲界命终者。观察是时。乃是色界命终者。因色界作方便。于欲界得满足者。与善性易可共住。众生同在一处。作是思惟。如此善性。易可共住。众生必是色界命终者。观察是时。乃是欲界命终者。因欲界作方便。于欲界得满足者。与恶性难共住。众生同在一处。作是思惟。如此恶性难共住。众生必于欲界命终。观察是时。是欲界命终者。因色界作方便。于色界得满足者。与善性易共住。众生同在一处。作是思惟。如此善性。易可共住。众生必是色界命终者。观察是时。是色界命终者

问曰。为观一一世。为观多世耶。答曰。初学时观一一世。满足时观百千万世。世尊初学时。则能观百千万世。问曰。为能舍过百千万世。乃观久远百千万世不耶。答曰。初学则不能。后满足时则能。世尊初学则能舍过百千万世。乃观久远百千万世。问曰。次第观前世乃至久远。若欲止时。各还次第止耶。为一时止耶。答曰。或有说者还次第止。评曰。应作是说。随意而观。亦随意而止。问曰。次第观前世。经久远时。舍已即能观未来世耶。答曰。佛世尊能非余人。所以者何。佛世尊观前世智。次第能生观未来智。观未来智次第能生观前世智。不以方便一切功德悉现前故

问曰。于一刹那中。能观几世耶。答曰。一世。何以知之。如毗尼中说。尊者输毗多。作如是说。我一发意顷。能忆念五百世生事。诸比丘皆言。应驱逐之。所以者何。自称得无有是事。过人法故。佛告诸比丘。不应驱逐是比丘。所以者何。是比丘从无想天来生此间。无想天寿。经五百劫。忆念一生事故。言五百世

问曰。于一时顷。能观几趣耶。答曰。或有说者。能观一趣。复有说者。能观二趣。谓地狱趣畜生趣。或畜生饿鬼趣。或畜生天趣。或畜生人趣。若观转轮王时。则忆念三趣。谓人畜生饿鬼趣。人趣者。王及臣属畜生趣者是象马。饿鬼趣者。是受祭祀鬼神及转轮等诸神。若观顶生王时。则忆念四趣。畜生趣是象马。饿鬼趣是受祭祀神。天趣是帝释及眷属。人趣是顶生及眷属。无有是处。以分别故说。若令五趣共在一处者。亦于一时能忆念五趣

佛经说。常见有三种。有忆念二万劫者。有忆念四万劫者。有忆念六万劫者。问曰。何等常见忆念二万劫事。何等四万劫。何等六万劫耶。答曰。常见者。根有上中下。下者忆念二万劫。中者四万劫。上者六万劫。复次或有忆念火水风劫者。忆念火者二满劫。水者四万劫。风者六万劫。复次或有忆念喜乐舍根坏时。忆念喜根坏者二万劫。乐根四万劫。舍根六万劫。复次或是声闻性。或是辟支佛性。或是佛性。声闻性者忆念二万劫。辟支佛性者忆念四万劫。佛性者忆念六万劫

若是他心智。尽知他心心数法耶。答曰。或是他心智不知他心心数法。乃至广作四句。是知他心智不知他心心数法者。他心智在过去未来。有如是相。不知他心心数法。所以者何。过去者所作已竟。未来者未有所作。是知他心心数法非他心智者。犹如有一。若以相知。若闻其说。若生处得。如是智故能知。问曰。谁能以相知耶。答曰。人能。曾闻。跋难陀释子。至一优婆塞家。其家门边。系一驳犊。时跋难陀释子。语优婆塞言。汝家门边所系犊子。其色斑驳。若以其皮。作敷具者好。时优婆塞。作是思惟。是比丘。欲得是犊子皮。以为敷具。即便杀犊。以皮与之。时跋难陀释子。持其犊皮。往诣祇洹。犊母呜呼而随逐之。如是等名以相知。谁闻说能知耶。曾闻。有一居士。着新衣服。诣祇洹精舍。跋难陀释子。见已而语之言。善哉居士。汝所著衣中。作僧伽梨郁多罗僧安陀会若敷具。是时居士。作是思惟。是比丘欲得我衣。即便与之。复有说者。闻说能知。即是以相知。经文应如是说。若以相知。若卜筮知他心心数法。以相知者。如先说。卜筮知者。如诸外道。或以指卦。或触衣物。若以算术。若逆取相。便能知他心心数法。谁有生处得智耶。答曰。地狱众生。然无定名者。问曰。生处得智。为生时能知中时能知后时能知耶。答曰。初生未受苦知后受苦时。犹不能知自心。何况他心。为住善心时能知。为住秽污无记心时知耶。答曰。住三种心尽能知。为住意识。为住五识身能知耶。答曰。住意识知非五识。为住威仪。为住工巧。为住报心耶。答曰。住威仪心非工巧报心。所以者何。彼众生无工巧故非报心。报心在五识故。畜生中亦有能知他心心数法者。曾闻。有一女人。以儿置一处。有缘余行。时有一狼。取其儿去。时人语言。何故取他儿耶。狼作是言。此儿母常食我子。我今还食其子。若彼能舍怨心。我亦舍之。时人语是女人可舍怨心。女人答言。我今已舍。时狼观女人心。不舍其怨。而口言舍。即杀其儿。舍之而去。问曰。畜生为生时知为中时知为后时知耶。答曰。三时尽知。为住善心染污心不隐没无记心知耶。答曰。三种尽知。为住意识为住五识身知耶。答曰。住意识知非五识身。为住威仪工巧报心知耶。答曰。三种尽知。余鬼亦知他心心数法。曾闻。有鬼入一女人身中。咒师问之。何故触恼他女人耶。彼鬼答言。此女人五百世中。与我作怨。常断我命。我亦断其命。彼若能舍怨心。我亦舍之。时人语是女人。可舍怨心。女人答言。我今已舍。鬼观女心。虽口言舍怨心不除。即断其命。舍之而去。问曰。为生时知为中时知为后时知耶。答曰。三时尽知。为住善心染污心不隐没无记心知耶。答曰。三种尽知。为住意识知为住五识知。答曰。住意识知。为住威仪工巧报心知耶。答曰。三种尽知。天中亦有生处得知。能知他心心数法。然无定名。初中后知者。广说如畜生饿鬼趣。余广说。如杂揵度。是知他心智。亦知他心心数法者。若智是修是修果从修生得不失。此智现在前。知欲色界众生心心数法及无漏心心数法。非知他心智非知他心心数法者。除上尔所事。除上尔所事者。广如先说。行阴作此四句。此中尽说过去未来现在他心智及现相智。闻他说智生得智。作前三句。余相应不相应行阴四阴。及无为法。作第四句。是名除上尔所事

若是念前世智。尽知前世无数生耶。乃至广作四句。是念前世智不知前世无数生者。念前世智。在过去未来。有念前世智相而不知前世无数生事。所以者何。过去所作已竟。未来未有所作。知前世无数生非念前世智者。犹如有一。有自性念生智者。有生处得智者。谁有念生智耶。答曰人有。谁有生处得智耶。答曰。地狱众生。如经说。地狱众生。作如是言。沙门婆罗门。见贪欲未来过患故。为我等说法。应当断欲。我等不用其言。以贪欲因缘故。今受苦痛果报。问曰。地狱众生。为初时知为中后知耶。答曰。初时知非中后。若未受苦时则知。已受苦时。次前灭法。犹尚不知。何况久远灭者。余广说如他心智处。畜生亦有生处得智。如经说。汝若是我父都提耶者。可升此座。广说如杂揵度。问曰。为初时知为中后知耶。答曰。初时知中后亦知。广说如他心智处。饿鬼亦有生处得智。如偈说

  我自聚财物　　以法及非法
  他今受快乐　　而我受苦恼

问曰。为初时知为中后知耶。答曰。初中后尽知。广说如他心智处。天亦有生处得智。如偈说

  今此只陀林　　贤圣僧所居
  法王亦在中　　我心大欢喜

问曰。为初时知为中后知耶。答曰。初中后尽知。广说如他心智处。问曰。人中何故无生处得智耶。答曰。非其因故。广说如上。复次为念生智所覆蔽故。复次人中虽无生处得智。而有胜妙念前世智愿智。是念前世智亦知前世无数生者。若智是修是修果从修生得不失。以此智念前世无数生。有如是相貌。非念前世智亦非念前世无数生者。除上尔所事。除上尔所事。广说如上。此中行阴作四句。三世念前世智及现在念生智生处得智作前三句。余相应不相应行阴四阴及无为法。作第四句。是名除上尔所事。若是念前世智。亦知过去他人阴界入及心耶。乃至广作四句。初句者。是自缘念前世智。第二句者。是愿智方便缘他者。第三句者。是缘他念前世智。第四句者。是愿智方便自缘者。此四句是略毗婆沙。是念前世智。不知过去他人阴界入及心者。若智是修是修果从修生得不失。以此智念前世。生自阴界入及心。是说自缘念前世智。知过去他人阴界入及心。非念前世智者。若智是修。乃至广说。以此智知他此生过去阴界入及心。是说愿智方便缘他身者。言念前世智亦知过去他人阴界入及心者。若智是修。乃至广说。以此智知前生过去他人阴界入及心。是说念前世智缘他者。非念前世智。亦不知过去他人阴界入及心者。若智是修。乃至广说。以此智知此生过去自身阴界入及心。是说愿智方便缘自身者

阿毗昙毗婆沙论卷第五十阿毗昙毗婆沙论卷第五十一

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    智揵度他心智品第二之三

有自性念生智。问曰。自性念生智体性是何。答曰。体性是慧。彼心聚中。以念力多故。名念生智。如念处安那般那念。除去色想亦如是。此是自性念生智体性。乃至广说

已说体性。所以今当说。何故名自性念生智。答曰。生而得此智故。名自性念生智。复次住善心性不善心性无记心性能知故。名自性念生智。复次过去法更不变故名自性。能知此法故名自性念生智

问曰。为作何业得是智耶。答曰。或有说者。常为众生。说欢喜乐闻语。彼业能生如是报。复有说者。若修治狭小处令使宽博。以此业故。在母胎中。而不迫迮。以是业故。能生此报。复有说者。若人以甘美饮食施他。彼业得如此报。评曰。应作是说。此是不恼害他业报。若众生不作恼害他业。在母胎中。则得宽博。不为风热冷病脂血所困苦。若出胎时。亦不为产门所逼切。以是事故。不忘所念一切众生。若于产门不逼切者。皆有念前世智。以为产门所逼切故。皆失所念。问曰。念生智为初时胜为中后时胜耶。答曰。或有初中后尽胜者。或有初胜者。如尸婆罗等。初生之时。作如是说。此家中颇有种种财物及诸谷米。可以施于贫穷者不。或有中时胜者。如赖吒波罗等。或有后时胜者。如庵摩罗吒等

问曰。念生智为念几生耶。答曰。或有说者。念一生。复有说。念二生。乃至七生。曾闻。王舍城中。有屠儿名伽吒。是阿阇贳王少时亲友。而语阿阇贳言。太子。汝若登王位时。与我作何善事耶。阿阇贳答言。与汝从心所愿。阿阇贳害其父命。而登王位时。屠儿伽吒。往诣王所。而白王言。大王往日许我所愿。今正是时。王答之言。随意求索。时伽吒屠儿。便说心愿使我于王舍城内。独得屠杀。不听余人。时王语言。汝今何用是弊恶。愿为更求余愿。是时屠儿。复语王言。善恶诸业。悉无果报。王语之言。何以知之。作是说耶。屠儿答言。大王当知。我自忆念。于七世中。在王舍城。常屠羊自活。命终之后。生三十三天。至闻是语。极生疑怪。即以是事。而往白佛。佛告王言。如其所说。而无有异。此人施辟支佛食。发于邪愿。使我于王舍城中。常独杀羊卖肉。以此业故。七生人中。七生天上。今于此身。业报已尽。却后七日。身坏命终。当生卢腊地狱。以是事故知。念生智忆念七世。复有说者。能念五百世事。曾闻。有一比丘。自念五百世。次第常生饿鬼中。若忆念过去饥渴苦时。则于诸有。而生苦想。断一切缘。独勤行精进。得须陀洹果。作是思惟。我恒得诸比丘所须之物。使我行道。我今应当还求所须施诸比丘。即行劝化。时诸比丘。而语之言。汝先懒惰。今以何故。勤行教化。时彼比丘。即向诸比丘。广说上事。以是事故知。念生智忆念五百世事。复有一比丘。自忆念次第五百世。生地狱中。若忆念受地狱苦时。举身毛孔。血流而出。污身及衣。日日诣水澡浴浣衣。勤行精进。得阿罗汉果。更不澡浴浣衣。时诸比丘。而语之言。汝常澡浴浣衣。以水为净。今何以不。此比丘向诸比丘。广说上事。如此忆念五百世事。复有或忆念世界成时者。曾闻。有旃陀罗王。名多罗蠰佉。善通咒术及诸论。有子名奢头罗。颜貌端正。当于尔时。尊者舍利弗。作婆罗门。名弗伽罗娑罗。善通皮陀及皮陀分经。有女名波翅多。时旃陀罗王。往诣弗伽罗娑罗所而语之言。可以汝女用妻我子。时弗伽罗娑罗婆罗门。便生嗔恚。而语之言。汝于四姓卑下。我于四姓尊贵。何缘以女用妻汝子。时旃陀罗王。语婆罗门言。夫种族姓尊卑。无有常定。汝颇曾闻。谁造梵书耶。婆罗门答言。我闻是瞿频陀罗婆罗门所造。复问。谁造佉卢吒书耶。婆罗门答言。我闻是佉卢吒仙人所造。复问。谁造此皮陀及皮陀分经。而答之言。皆是往昔大婆罗门等之所造作。时旃陀罗言。如是等往昔诸人。皆是我身。时婆罗门。闻是语已。心生欢喜。便以己女。而妻其子。如此忆念世界成时事

经说。佛告村主。我自忆念九十一劫以来。不曾为饮食故。起身口意恶业。问曰。佛为以念前世智。为以自性念生智忆念此事。若以念前世智知者。何以念九十一劫。而不多耶。若以自性念生智知者。何故但说忆念七世或五百世。乃至忆念世界成时。而不说忆念九十一劫者耶。答曰。应作是说。佛以念前世智知。问曰。若然者。何故但说九十一劫。而不多耶。尊者波奢说曰。若说百劫。亦生此疑。但说此不违法相。复次九十一劫中。有七佛出世故。复次从此已来。种相好业故。复有说者。以自性念生智知。问曰。若然者。何故说自性念生智忆念七世。若五百世。乃至劫成时。而不说九十一劫耶。答曰。余人如此。佛则多知。问曰。自性念生智。为忆念中有时不。答曰。或有说者。不知。所以者何。中有微细。非自性念生智境界故。评曰。应作是说。忆念中有。所以者何。若不忆念者。于前生则忆念少多。不忆念少分

问曰。菩萨前身时。有自性念生智。最后身时。为有不耶。若有者。云何缘力胜因力耶。若无者。菩萨云何转衰退耶。答曰。应作是说。最后身有。问曰。若然者。云何现在外缘力。胜过去内因力耶。答曰。不以无外缘力故。名为内因力。乃以利根故。名内因力。菩萨于一切众生。根利最胜。谁作是说。菩萨最后身。无外缘力耶。净居诸天。为现老病死苦。亦因弥伽释王女。为说赞涅槃。偈如说

  安乐以为母　　无忧以为父
  寂静以为妻　　不久汝当得

见闻是事。心生厌患。然后出家。过去诸佛。亦为菩萨。说道具诸法。如是等。岂非外缘力耶。复有说者。最后身无。问曰。若然者。云何菩萨转衰退耶。答曰。菩萨虽无此智。而有胜妙念前世智愿智

云何时心解脱。云何不动心解脱。问曰。何故作此论。答曰。此是佛经。佛经说。佛告阿难。比丘不应乐着聚集种种谈议。所以者何。若乐着聚集种种谈议。欲求身证时心解脱不动心解脱者。无有是处。若比丘不乐着聚集种种谈议。欲求身证时心解脱不动心解脱者。斯有是处。佛经虽作是说。而不广分别。云何是解脱体性。云何得此解脱。根楗度虽说得是二解脱。而不说此二解脱体性。今欲说此二解脱体性故。而作此论。复有说。所以作论者。或说时心解脱是有漏非时心解脱是无漏。欲止如是说者意。亦明此二解脱是无漏。复有说。所以作此论者。或有说时心解脱是有为。非时心解脱是无为。为止如是说者意。亦明此二解脱是有为故。复有说。所以作论者。或有说时心解脱是学。非时心解脱是无学。所以者何。时心解脱有所作故。非时心解脱无所作故。为止如是说者意。亦明此二解脱俱是无学故。而作此论

一切有为无为法中。二法是解脱体性。有为法中是大地中解脱。无为法中是数灭。大地中解脱有二种。谓染污不染污。染污者邪解脱。不染污者是正解脱。正解脱有二种。有漏无漏。有漏者与不净无量等相应者是也。无漏者学无学。学者。与苦法忍乃至金刚喻定相应者是也。无学者是阿罗汉。阿罗汉有二种。谓时心解脱。非时心解脱。时心解脱者。五种阿罗汉。非时心解脱者。是一种阿罗汉。此二种阿罗汉。离欲得无欲。是心解脱。离无明是慧解脱。问曰。若离欲得无欲是心解脱。离无明是慧解脱者。集法经说云何通。如说云何时心解脱。答曰。是不贪善根。对治于贪。云何非时心解脱。答言。是不痴善根。对治于痴。如是解胜是善根性耶。答曰。集法经文应如是说。云何时心解脱。答曰。言与不贪善根相应解脱是也。云何非时心解脱。答言。与不痴善根相应解脱是也。此文应如是说。而不说者。有何意耶。答曰。或有为不贪故而断贪心。或有为不痴故断于痴心。是故作如是说。问曰。何故名时解脱。答曰。待时得故名时。待时者。待于六时。六时者谓衣食卧具说法方人。待衣者得好细软衣。则能得解脱。不得则不得解脱。待食者若得苏蜜肉等美食。能得解脱。不得则不得解脱。待卧具者。若得厚软卧具。能得解脱。不得则不得解脱。待说法者。若闻善方便说法人所说。则能得解脱。不闻则不得解脱。待方者若其方寂静无诸乱闹。则能得解脱。若不寂静。则不得解脱。待人者若得善性易共住人同处者。则能得解脱。不得则不得解脱。何故名非时解脱耶。答曰。不待时而得解脱故。名非时解脱。不待时者。不待六时。谓衣食卧具说法方人等。不待衣时者。着粪扫衣。能修善法。胜时解脱着价直百千两衣。不待食时者。虽食下贱粗食。而能修道。胜时解脱食百味食。不待卧具时者。坐于石上。而能修道。胜时解脱。坐厚软座上。不待说法时者。若闻无方便说法人所说。则速入禅定。不待方时者。若其方多声乱闹。则速入定。不待人时者。若得恶性。难共住人。而共同处。则速入定。复次狭小道。得此法故。名时解脱。问曰。何者是狭小道。答曰。或有于一身中种善根第二身成熟第三身得解脱。若不以狭小道得者。名非时解脱。何者非狭小道。或有于六十劫而修方便。如尊者舍利弗。或有于百劫而修方便。如辟支佛。或有于三阿僧祇劫而修方便。如佛世尊。复次以劣弱道得故。名时解脱。何者是劣弱道。于彼善法。不数数修。不常修一切时修。若于日初分修。中分后分则不修。若于初夜修。中夜后夜则不修。与上相违。名非时解脱。复次以多定道得故。名时解脱。以多慧道得故。名非时解脱。复次行者若为适意不适意利益不利益苦乐所须具作障碍者。名时解脱。与上相违。名非时解脱

时解脱是五种阿罗汉。非时解脱是一种不动法阿罗汉。问曰。何故五种阿罗汉。是时解脱。答曰。各有胜故五种阿罗汉是时解脱。以人多故。一种不动法阿罗汉。是非时解脱。合三乘道故。亦有等义。俱在无过。清净身中生故。复次以下人多故。五种阿罗汉。名时解脱。以上人少故。一种不动法阿罗汉。名非时解脱。如今世间王者。大臣长者居士甚少。卑下人甚多。如是辟支佛。得波罗蜜。声闻甚少。时解脱阿罗汉甚多。复次易得易起故。五种阿罗汉。是时解脱。难得难起故。一种不动法阿罗汉。是非时解脱。如今世人往师子王国及真丹国。还者甚少。若从此村。至彼村。还者甚多。彼亦如是。复次时解脱法。不多用功。不有所作而得故。五种阿罗汉。是时解脱非时解脱法。多用功多有所作而得故。一种不动法阿罗汉。名非时解脱。复次时解脱法。有增有减故。五种阿罗汉。是时解脱。增者是胜进。减者是退。非时解脱。无增减故。一种不动法阿罗汉。是非时解脱。无增者无胜进。无减者无退

如说时解脱是爱法。问曰。何故时解脱是爱法耶。答曰。如经本说。时解脱阿罗汉。守护爱重此法。使我于此法莫退。如人唯有一目。其家眷属。皆共护之。不令冷热风坌而毁坏之。彼亦如是。复次时解脱阿罗汉。于解脱不得自在。多用功乃现在前。起现在故。心生欢喜故。名爱法。非时解脱。于解脱得自在。不多用功。而现在前。起现在故。心不生喜。不名爱法。复次时解脱阿罗汉有退。以畏退故。数数起解脱现在前。非时解脱阿罗汉无退。以不畏退故。不数数起解脱现在前。复次时解脱阿罗汉。多人所爱用故名爱法。与此相违名不爱法。复次时解脱阿罗汉。以多信得道故名爱法。非时解脱阿罗汉。以慧多得道故。名不爱法。复次非时解脱阿罗汉。有憎恶圣道善根。如空空无愿无愿无相无相三昧。以此善根。憎恶圣道故。不爱此法。时解脱阿罗汉。无此善根故。爱护此法。经本虽不说。义应如是。问曰。何故非时解脱阿罗汉。名不动法耶。答曰。以胜妙故。如今世间所有胜妙饮食衣服璎珞所在之处。不动人嗔心彼亦如是。复次烦恼能令人心动。能令人心生。而不熟湿而相着以秽污故。在善心上。无其势力故。不得自在。故名不动。复次已断烦恼。更不复退。故名不动。如善射人正射于的。称言不动。彼亦如是。如经说。佛告舍利弗。若比丘比丘尼。有不动解脱法宝璎珞者。能断不善法。修于善法。问曰。何故不动解脱。名法宝璎珞耶。答曰。以坚牢故。胜妙故。无过故。轻举故。无垢故。清净故。难得故。名宝璎珞。复次譬如泉池之中。若以宝珠投之。则不杂垢秽。若人身中。有不动解脱宝璎珞者。则不杂烦恼垢秽。亦复如是。复次如人屋中有摩尼宝珠者。则无黑闇。若人身中有不动法宝珠者。则无无明黑闇。亦复如是。复次如方宝珠所置之处。即安不动。若人身中有不动解脱方宝珠者。其心不动。亦复如是。复次如人家中。有无价宝珠者。其家毕竟无贫穷之苦。若人身中有不动宝珠者。其人永断圣道贫穷之苦。亦复如是。复次譬如如意宝珠安置幢上。随人意念。雨种种宝。能令百千众生离贫穷苦。佛世尊亦尔。以不动宝珠。安置四无量幢上。随众生所念。雨种种法宝。除去众生贫穷法宝之苦。亦复如是。问曰。若不动心解脱。是胜妙法者。何故经说是不增不减法耶。答曰。行者等得此法故。若满东方有刹利子。若满南方有婆罗门子。若满西方有居士子。若满北方有首陀子。剃除须发。身着法服。信家非家。于正法出家。皆身证不动心解脱。而此法无有增减。复次欲说佛法饶财多宝故。佛法除不动心解脱。更有无量余善法功德。不动心解脱。唯是一法故。复次欲现如来身中有无量功德故。除不动心解脱。更有无量余善功德。不动心解脱。唯是一法故。复次欲令疑者得决定故。经说。尊者目揵连。于僧中摈出瞻婆比丘。诸比丘。咸有是念。今僧减少。佛作是说。若我弟子。得深远胜妙。不动心解脱。于僧中出者。不能令僧有增有减。何况彼犯戒众威仪。远离白净法者。岂能令僧有增减耶。复次此法是无增无减法故。无增者无胜进。无减者不退失。一切时心解脱。尽与尽智相应耶。问曰。何故作此论。答曰。欲令疑者得决定故。时解脱阿罗汉。修二种慧。谓尽智无学正见。非时解脱阿罗汉。修三种慧。谓尽智无生智。无学正见。或谓如时解脱阿罗汉。修二种慧。非时解脱者亦尔。如非时解脱阿罗汉修三种慧。时解脱亦尔。欲决定说时解脱修二种慧。非时解脱修三种慧故而作此论

诸时解脱。尽尽智相应耶。广作四句。如经本说。尽智者。时解脱阿罗汉。金刚喻定一刹那顷现在前。尽智次第相续起现在前。从尽智起。或起无学正见。或起世俗心。非时解脱阿罗汉金刚喻定。尽智俱一刹那顷现在前。次第相续起无生智现在前。从无生智起。或起无学正见。或起世俗心。一切阿罗汉。尽修无学正见。不必尽起现在前。问曰。尽智无生智。有何差别耶。答曰。或有说者。名即差别。是名尽智。是名无生智。复次所作已竟名尽智。从无学因生名无生智。复次或未曾得而得。或曾得而得。名尽智。未曾得而得。名无生智。复次解脱道胜进道所摄名尽智。唯胜进道所摄。名无生智。复次尽智有五种阿罗汉。无生智有一种阿罗汉。谓不动心解脱。尽智无生智。是谓差别。问曰。初尽智为是何智耶。答曰。或有说者。是苦比智。所以者何。行者初入圣道时观果。出亦观果。如以毒箭射兽。毒遍身中。后若死时。毒气还在疮孔彼亦如是。复有说者。是集比智。所以者何。行者入圣道时观果。出圣道时观因故。如是生死法。或是因是果。若知因知果。则生死道断。名为苦边。评曰。应作是说。是苦比智集比智。若是苦比智非集比智。若是集比智非苦比智

阿毗昙毗婆沙论卷第五十一阿毗昙毗婆沙论卷第五十二

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    智揵度他心智品第二之四

我生已尽者。为尽过去生。为尽未来生。为尽现在生。言我生尽耶。若尽过去生。过去生已灭。若尽未来生。未来生未至。若尽现在生。现在生不住。答曰。应作是说。尽三世生。所以者何。此中言生者。是非想非非想处四阴。行者于三世中。尽明见故能离非想非非想处欲。尊者佛陀提婆说曰。佛经说。牟尼见生尽。亦作是问。为见过去生未来生现在生尽言生尽耶。答曰。应作是说。见未来生尽。所以者何。行者修一切梵行苦行。尽为止未来生故。如人有三厄难。一者已受。二者今受。三者当受。已受者受竟。今受者忍受。当受者若以财物。若因亲族力。作诸方便。断当生者。行者亦尔。过去不用功已灭。现在生当忍受竟。未来生以正方便灭。永令不生。生有多种。或说。入母胎时名生。或说。出母胎时名生。或说。时五阴名生。或说。不相应行阴少分名生。或说。非想非非想处四阴名生。何处说入母胎时名生者。如经说。诸家生彼彼处生出现。出母胎时名生者。如说。菩萨已生。行于七步。说时五阴名生者。如说。有缘生。说不相应行阴名生者。如说。一刹那顷。谁起耶。谓生也。说非想非非想处四阴名生者。如此中说。我生已尽。梵行已立者。为立学道。名梵行已立。为立无学道。名梵行已立。答曰。已立学道。名梵行。已立无学道。名今立。所作已办者。已断一切烦恼所作事已竟。复次毕竟尽一切界。毕竟尽一切生。毕竟断一切增长生死法。名所作已办。不受后有者。是明无生智。尊者和须蜜说曰。若不断烦恼。不名生尽。若断烦恼。名为生尽。若不断烦恼。不名梵行已立。若断烦恼。名梵行已立。若不断烦恼。不名所作已办。若断烦恼。名所作已办。若不断烦恼。名受后有。若断烦恼。名不受后有。问曰。一切阿罗汉。不尽得无生智。何以故。一切经中。尽说不受后有耶。答曰。佛说利根。与经相应者。然集经法者。一切经中皆说。复有说者。集法诸尊者。皆有愿智无碍智。以观察之。若利根与经相应者说之。后有不善诵持经者。一切经中。皆作是说。评曰。应作是说。一切阿罗汉。尽不受后有

问曰。何等阿罗汉。修二种慧。何等阿罗汉。修三种慧。答曰。或有阿罗汉。心善解脱。慧善解脱。或有心善解脱慧不善解脱。若心善解脱慧善解脱者。修三种慧。若心善解脱慧不善解脱者。修二种慧。复次或有以苦智集智尽三界结者。或有灭智道智尽三界结者。若以苦智集智尽三界结者。修三种慧。若以灭智道智尽三界结者。修二种慧。复次或以空苦集无愿三昧。尽三界结者。或以无相道无愿三昧。尽三界结者。若以空苦集无愿三昧。尽三界结者。修三种慧。若以无相道无愿三昧。尽三界结者。修二种慧。复次或有为定入圣道。或有为慧入圣道。若为定入圣道者。修三种慧。如定道慧道。定多道。慧多道。欲可定道。欲可慧道。钝根利根。缘力因力。说亦如是。复次或有以定修心以慧得解脱者。修二种慧。或有以慧修心以定得解脱者。修三种慧。复次得内心寂静不得观慧法。或有得内心寂静亦得观慧法。前者。修二种慧。后者。修三种慧。复次若人成就四法。甚为希有。一亲近善知识。二从其闻法。三内正思惟。四如法修行。若成就初二种法者。修二种慧。若成就后二种法者。修三种慧。复次或有从他闻法多。或有内正思惟多。若从他闻法多者。修二种慧。若内正思惟多者。修三种慧。或有无贪善根多。或有无痴善根多。若无贪善根多者。修二种慧。若无痴善根多者。修三种慧

我生已尽。是说尽智。梵行已立。所作已办。不受后有。是说无生智。复有说者。我生已尽。梵行已立。是说尽智。所作已办不受后有。是说无生智。复次我生已尽。梵行已立。所作已办。是说尽智。不受后有。是说无生智。问曰。无有阿罗汉二尽智刹那后起无生智者。何况多。何故作是说。言我生已尽梵行已立所作已办是尽智耶。答曰。虽是一刹那。而有三种义。故作是说。尊者波奢说曰。如是说者。不说尽智。不说无生智。亦不说无学正见。此是赞叹阿罗汉辞言。阿罗汉生已尽。梵行已立。所作已办。不受后有。复次我生已尽。是说尽智。梵行已立。是说道智。所作已办。是说灭智。不受后有。是说无生智。复次我生已尽。是说知集。梵行已立。是说知道。所作已办。是说知灭。不受后有。是说知苦。说尽作证亦如是。复次我生已尽。是说断集。梵行已立。是说修道。所作已办。是说证灭。不受后有。是说知苦。复次我生已尽。是说断因。梵行已立。是说修道。所作已办。是说得果。不受后有。是说知体。复次我生已尽。是说集智。梵行已立。是说道智。所作已办。是说灭智。不受后有。是说苦智。复次我生已尽。是说集无愿。梵行已立。是说道无愿。所作已办。是说无相。不受后有是说空及苦无愿

问曰。何故名尽智。为以缘尽故名尽智。为以烦恼尽身中生故名尽智耶。若以缘尽故名尽智者。灭智应是尽智。若以烦恼尽身中生名尽智者。无生智无学正见。亦应是尽智。答曰。应作是说。烦恼尽身中生故名尽智。问曰。若然者无生智无学正见。应是尽智。答曰。若智在初。一切皆有者。名尽智。无学正见。虽一切皆有。而不在初。无生智不在初。亦非一切皆有。尽智在初。一切皆有故。问曰。十六圣行外。更有无漏慧。不此中问答。广说如杂揵度。云何学明。云何学智。云何无学明。云何无学智。问曰。何故作此论。答曰。世间以种种世俗诸论。以为明想。不识真明。欲止如是说者意。亦明真明义故。而作此论。复有说。所以作此论者。此是佛经。经说。佛告居士。如汝以学智学见学明见四圣谛。今此耶奢童子。亦以无学智无学见无学明。见四圣谛。不复更住居士家受五欲乐。佛经虽作是说。而不广分别。佛经是此论所为根本今欲广分别故。而作此论

云何学明。答曰。学慧是也。云何学智。答曰。学八智是也。云何无学明。答曰。无学慧是也。云何无学智。答曰。无学八智是也。谓四法智四比智。此是明体性。乃至广说

所以今当说。何故名明。明是何义。答曰。觉识了了义是明义。问曰。若觉识了了义是明义者。善有漏慧。亦觉识了了。是明义耶。答曰。若于四真谛。觉识了了。毕竟了了。更不生颠倒。广说如杂揵度。问曰。若善有漏慧。不名明者。佛经云何通。如说。无学有三种明。无学念前世智证明。无学生死智证明。无学漏尽智证明。答曰。有少分明势故名明。何者是少分明。与烦恼相违。亦不杂烦恼故。名少分明。复次此二明。能生能随顺实义无漏明故名明。是故尊者和须蜜。作如是说。第一实义。无漏明者。是漏尽明。余二明。能生此明故名明。复次念前世智证明。知前际增长法。生死智证明。知后际增长法。漏尽智证明。知涅槃寂静法。尊者佛陀提婆。亦作是说。念前世智证明。知此众生从彼处没来生此间过去世因果相续法。生死智证明。知此众生作如是业当生彼处未来因果相续法。漏尽智证明。知此众生以如是道能尽漏因果毕竟法。是名第一实义明。复次念前世智证明。觉识了了过去世事。生死智证明。觉识了了未来世事。漏尽智证明。觉识了了无为涅槃。复次念前世智证明。除过去无知黑闇。生死智证明。除未来无知黑闇。漏尽智证明。除于涅槃无知黑闇。问曰。何故六通中。三立明三不立明耶。答曰。身通是工巧法。天耳通。闻声而已。他心智通。缘别相法。此三明。能随顺厌离法。能弃生死。随顺善法。能到涅槃。问曰。此三明。云何能随顺厌离法能弃生死。随顺善法能到涅槃耶。答曰。念前世智证明。见过去世事。生大厌离。生死智证明。见未来世事。生大厌离。以厌离故。漏尽智证明。能作正观。断于烦恼。复次念前世智证明。知过去相续种种诸因。生死智证明。见诸众生未来阴。如散微尘。生大厌离故。漏尽智证明。能作正观。断于烦恼。复次念前世智证明。知过去自身衰恼事。生大厌离。生死智证明。见未来他身衰恼事。生大厌离。以厌离故。漏尽智证明。能作正观断于烦恼。复次念前世智证明。除于有愚。生死智证明。除众生愚。漏尽智证明。除于法愚。复次念前世智证明。对治常见。生死智证明。对治断见。漏尽智证明。对治二边。住于中道。复次念前世智证明。能生空。生死智证明。能生无愿。漏尽智证明。能生无相。以如是等义故。此三明随顺厌离之法。能弃生死随顺善法。到于涅槃。集法经说。有三种无学明。谓念前世智证明。生死智证明。漏尽智证明。云何无学念前世智证明。答言。知诸众生生死为相续法无学智。云何无学生死智证明。答言。知诸众生自所作业无学智。云何无学漏尽智证明。答言。尽漏无学智。问曰。漏尽智证明。言是无学可尔。余二明是非学非无学。何故说是无学明耶。答曰。集法经。应作是说。无学人有三明。而不说者。有何意耶。答曰。二明虽是非学非无学。以是无学人身中可得故。亦名无学。如施设经说。三昧有二种。一是圣。二非是圣。圣三昧有三种。一善有漏。二无漏。三不隐没无记。善有漏三昧。以善故名圣。不以无漏。无漏三昧。以善故以无漏故名圣。不隐没无记三昧。亦非善亦非无漏。而名圣者。以是圣人身中可得故名圣。彼亦如是。问曰。何故无学人身中立明。学人身中不立明耶。答曰。以明义胜故。若以法而言。无学法胜于学法。若以人而言。无学人胜于学人。复次不杂无明故名明。学人身中慧。杂无明故不名明

如来身中所有漏尽智有四事。一名通。二名明。三名力。四名示现。通者是漏尽通。明者是漏尽明。力者是漏尽力。示现者是说法示现。辟支佛无学声闻所有漏尽智有三事。一是漏尽通。二是漏尽明。三是示现非力。如来身中所有念前世智生死智有三事。一是通。二是明。三是力非示现。辟支佛无学声闻所有念前世智生死智有二事。是通。是明。非力非示现。学人身中所有念前世智生死智有一事。谓是通。非明。非力。非示现。问曰。如来身中所有智立力。非辟支佛声闻身中智耶。答曰。无障碍义是力义。声闻辟支佛智为无智所障碍故非力。曾闻佛世尊。尊者舍利弗。共一处经行。有一众生。来诣其所。佛告舍利弗。汝可观是众生。过去世中。何处与是众生而共同止。时尊者舍利弗。即以初禅念前世智观不知。乃至以第四禅念前世智观亦不知。即从定起。而白佛言。我观是众生。都不能见所从来处。佛告舍利弗。辟支佛所有智见。过于汝等。复过辟支佛所有智见。此众生从某世界来生此间。后时世尊与舍利弗。复在一处经行。时有一人命终。世尊见已。告舍利弗言。汝可观是人。为生何处。时尊者舍利弗。即以初禅天眼观之。而不能见。乃至起第四禅天眼观之。亦不能见。即从定起。而白佛言。我以天眼观察是人。不知为生何处。佛告舍利弗。过辟支佛所知境界。有某国土。此人生于彼中。问曰。如来所有念前世智生死智胜妙可尔。如佛漏尽智声闻辟支佛亦尔。何故佛漏尽智立力。非声闻辟支佛耶。答曰。佛漏尽智亦胜妙。如来身中所有漏尽智。其性猛利。若缘烦恼。烦恼即断。声闻辟支佛漏尽智。不猛利故。数数缘烦恼。烦恼乃断。譬如二人斫树。一人勇健加用利斧。一人性劣又用钝斧。虽俱斫树。而勇健以利斧者疾。非性劣以钝斧斫者。彼亦如是。非以自身所有漏尽智名为力。令彼众生得漏尽故名力。世尊知此众生以苦迟通能尽漏。此众生以乐速通能尽漏。是故名力

阿毗昙毗婆沙论卷第五十二阿毗昙毗婆沙论卷第五十三

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    智揵度他心智品第二之五

问曰。此六通。几是明非示现。几是示现非明。几是明亦是示现。几非是明亦非示现耶。答曰。二是明非示现者。谓念前世智生死智。二是示现非明者。谓身通他心智通是。明亦示现者。谓漏尽通。非明非示现者。谓天耳通。问曰。此六通何故。三是示现。三非示现。答曰。令他信乐生希有想。入于法者。名为示现。三通不尔。若作是说。我天耳闻声。天眼见色。能知过去无数生事。人皆生疑。此事或虚或实。曾闻有一居士。请尼揵陀若提子及弟子众。于其家食。时尼揵陀若提子既入其家。而便微笑。居士问言。大师已离种种调戏。今何故笑。师答之言。今我法中所有妙法。汝可悉得闻耶。是时居士殷勤重问。而便答言。南拔提河侧。有二猕猴。共斗不已。忽然堕河。为水所漂。是以我笑。是时居士。而作是言。大师天眼。甚为希有。明净乃尔。时诸尼揵。各坐其床。次第下食。以饭覆羹。而上其师。余诸尼揵。以羹在上。诸余尼揵。应时皆食。其师而独不食。居士问言。大师。今者何故不食。师答之言。此饭无羹。是以不食。是时居士。便语师言。天眼明净。希有乃尔。见南拔提河侧猕猴堕河。而不见饭底羹耶。以是事故。三通非示现。不能令他信乐生希有想。入于佛法。若以身通。令一身为多。多还为一。种种变化。上至梵世。令多众生生希有想。若有知他心所念法者。语他人言。汝有如是念。作如是思惟。悉如其心。而不相违。令多众生。于佛法中。生希有想。若为他说法。使远尘离垢。得法眼净者。亦令多众生。于佛法中。生希有想。以是事故。三通令他信乐生希有想。入于佛法

问曰。何等人应为现神变。何等人不应为现神变耶。答曰。若一向信。若一向不信者。不应为现神变。若在中不定信不定不信者。应为现神变。令入佛法。何以知之。经说。佛住那迦揵陀城波婆利迦庵罗林。时有居士子。名翅跋多。往诣佛所。头面礼足。却坐一面。而白佛言。世尊。此那迦乾陀城。丰乐炽盛。人民众多。加信敬佛法僧。唯愿世尊。可听一沙门于此国土诸人众前。现上人法种种神变。使那迦揵陀人于佛法僧倍生信敬。佛告居士子。我不为诸弟子作如是说。汝等来往之处。于诸人前。现上人法种种神变。我为诸弟子。而作是说。汝等应覆藏善法发露恶法。尔时居士子。复白佛言。世尊。见何过患。不令诸弟子现神变。而作是说。覆藏善法发露恶法耶。佛告居士子。示现有三种。一神足示现。二知他心示现。三说法示现。云何名神足示现。居士子。若沙门婆罗门。示现种种神变。一身为多身。多身为一身。乃至梵世身得自在。有信者见向不信者说。而作是言。我见沙门婆罗门示现种种神变。一身为多身。多身为一身。乃至梵世身得自在。时不信者。语信者言。汝见此事。有何奇异。有咒名揵陀罗。有人受持读诵。亦能示现种种神变。居士子。于意云何。如是不信者。岂非嫌责诸信者耶。居士子白佛言。世尊。实生嫌责。复次居士子。若沙门婆罗门。说他人心所念。汝有如是念如是思惟。悉如其言。而无虚者。有信者闻向不信者说。而作是言。我见沙门婆罗门知他心所念法。乃至广说。时不信者言。汝见此事。有何奇异。有咒名刹尼迦若有受持读诵之者能知他人心所念法。乃至广说。居士子。当知我以如是过患故。不听诸弟子示现种种神变。而作是说。汝等当覆藏善法发露恶法。以是事故。一向信一向不信。不应为示现种种神变。若在中不定信不定不信者。应为现神变令入佛法。问曰。何故名示现。答曰。如守门者法。故名为示现。如守门人。示现内法。令外人知。示现外法。令内人知。示现内法令外人知者。如说王今在内。澡浴饮食。观种种珍宝。示现外法。令内人知者。如说今某国某村。持如是信物。今在门外。以是事故。如守门者法。故名为示现

佛经说菩萨于夜初分。起通起明。于夜中分。起通起明。于夜后分。起通起明。问曰。菩萨何故初中后夜起通明耶。答曰。是恒河沙等诸菩萨。次第行法。复次初中后夜起通明者。欲令此身成法器故。复次欲令所作了了分明故。复次欲安足故起通。欲远照故起明。复次喻如无碍解脱道故起通明。通如无碍道。明如解脱道。复次喻如见道修道故。通如见道。明如修道。复次喻如善有漏法无漏法有漏无漏无记法故。二通是善有漏。谓身通念前世智通。一通是无漏。谓漏尽智通。一通是有漏无漏。谓他心智通。二通是不隐没无记。谓天眼天耳通。复次次第降魔众故。曾闻菩萨修苦行。知此非道。便从彼起。受难陀难陀婆罗门。姊妹十六种乳糜。令身有力。从吉人边受草。诣菩提树下。躬自敷草。犹如娑修迦龙王结身。交趺而坐。作是誓言。我于此坐不尽漏终不起。是时天地六种震动。如大海中船。亦动自在天宫。如佉陀梨叶。尔时魔王。便作是念。今此宫殿。何故震动。如此观察。乃知是菩萨在菩提树结交趺坐立坚固誓。即从自宫诣菩萨所作是言。可起刹利。今时浊恶众生刚强。汝不能得阿耨多罗三藐三菩提。正应居在转轮王位。我当献汝七宝。尔时菩萨。语恶魔言。汝今所说。犹如小儿。日月星宿。可令堕落。山林大地。住在虚空。欲令我于此坐不尽漏而起者。无有是处。尔时恶魔复语菩萨。今我软美之言。而汝不用。当现大怖畏事。令汝见之。是时恶魔作是语已。便雨众华。还诣自宫。遍告六欲诸天。汝等皆应执持种种器仗斗战之具。我今有怨在菩提树下。恶魔去后。未久之间。尔时菩萨。即作是念。若与常人。有所诤竞。尚不可轻。何况欲界中尊

尔时菩萨。审谛观察离欲之道。速离欲界欲。起初禅神足。化作种种相对之类。魔众作鸟形来者。化作狸猫像。狸猫形来者。化作狗犬像。狗犬形来者。化作豹像。豹形来者。化作虎像虎形来者。化作师子像。师子形来者。化作刀剑。火焰者作雨。雨者作盖。自化其身。在琉璃宫内以用障身。不障其眼。亦化此大地。可令出声。化作如是相对法已。复作是念。我不曾为行道之人作留难耶。便起念前世智。见过去百千万世。不曾为行道之人而作留难。乃以种种行道之具。而饶益之。复作是念我作何善业。恶魔作何善业。见于恶魔作一大无限施会如魔所作会。我复倍是百千万数。恶魔布施福业。尚不如我。何况持戒修定福业

尔时菩萨。以福德力故。端正而坐。是时恶魔。将三十六亿魔军。皆作种种恶貌形色。诣菩提树下。尔时菩萨语恶魔言。汝作一无限施会。如汝所作无限施会。我复倍汝百千万数。魔语菩萨。我之施会。以汝为证。谁证汝耶。尔时菩萨。即以相好庄严之手。按地出大音声。魔军闻声。寻即破坏。是时菩萨。以业报天眼。见一由旬色。不闻其声。便起天耳通。一由旬外。虽闻其声。不见其色。次起天眼通。虽见色闻声。不知其心为何所念。次起他心智通。知帝释眷属心生欢喜。魔王眷属。心生愁恼。尔时菩萨。复作是念。恶魔为以何事。发是恶心。皆因五欲具。贪着五欲。皆由烦恼。以是事故。便起漏尽通。故作是说。欲次第降魔故。初中后夜。起通明现在前

若见苦时先得何等不坏净。见集灭道时。先得何等不坏净。问曰。何故作此论。答曰。或有说。一时见谛。无次第见谛。如毗婆阇婆提。问曰。彼何故作如是说耶。答曰。彼依佛经。佛经说若于苦无疑。亦于集灭道无疑。若说于苦无疑亦于集灭道无疑者。岂非一时见谛非次第耶。为止如是说者意亦明次第见谛。若一时见谛非次第者。则违佛经。如说须达多居士。往诣佛所。作如是问。世尊为一时见谛。为次第见谛耶。佛告居士。次第见谛。非一时见谛。譬如登四桄梯法。问曰。若次第见谛非一时者。毗婆阇婆提所引经云何通耶。答曰。彼经文应如是说。若于道无疑。亦于苦集灭无疑应作是说。而不说者。有何意耶。答曰。佛说得果人。若一人得果。于四谛无疑。复次此经说不行疑人。若人见苦。毕竟不行于疑。故作是说。尊者佛陀提婆。作如是说。行者始入见道。义名于一切处信。问曰。彼尊者说次第见谛。不说一时见谛。何故作是说耶。答曰。应解彼所说。以彼作是说。行者在苦法忍时。更无住时。必得一切信。如持泥器于三重屋上投之于地。未至之顷。义已名破。彼亦如是。是故欲止他义。欲显己义。亦欲说法相。相应义故。而作此论

佛身中无学法。是名佛缘彼无漏信。名于佛不坏信。辟支佛身中所有三根。菩萨身中所有二根三谛名法。若缘彼无漏信。名于法不坏信。声闻身中所有学法无学法。若缘彼无漏信。是名于僧不坏信。无漏戒是圣所爱戒。若见苦时。先得何等信。答曰。得法即于苦法。尊者瞿沙说曰。信过患法于苦谛。信功德法于灭谛。若见集时。先得何等信。答曰。得法即于集法。尊者瞿沙说曰。见过患法于集谛。见功德法于灭谛。若见灭时。先得何等信。答曰。得法即于灭法。问曰。行者见三谛时。得二种不坏净。谓信及戒。何故但说信不说戒耶。答曰。应说而不说者。当知此说有余。复次此中不问有得几不坏净。但问有得缘何不坏净戒。是无缘法故。是以不说。若见道时。先得何等信。答曰。得于佛法僧不坏信。外国法师。作如是说。见道谛三刹那顷。信根现在前时。取其相应回转法。有四不坏净。彼信若缘佛身中无学法。是名于佛不坏信。若缘辟支佛身中三根菩萨二根。名于法不坏信。若缘声闻身中学无学法。是名于僧不坏信。取其回转戒。名圣所爱戒。不应如外国法师所说。罽宾沙门。作如是说。彼信总缘于法。无所分别。名于法不坏信。但信现在前时。未来则有无量信修未来修信。或有缘佛无学法者。是名不共。缘于佛不坏信。或有缘辟支佛三根菩萨二根者。是名不共。缘于法不坏信。或有缘声闻身中学无学法者。是名不共。缘于僧不坏信。或有缘佛身中无学法辟支佛身中三根菩萨身中二根。或有缘佛身中无学法声闻身中学无学法。或有缘辟支佛身中三根菩萨身中二根声闻身中学无学法。或有缘佛身中无学法辟支佛身中三根菩萨身中二根声闻身中学无学法。如是等尽是共缘于法不坏信。亦得回转圣所爱戒。如见道谛时三刹那顷。道比智亦如是。异者行人尔时见道谛三心顷。不得修缘前三谛信。是时顷修。问曰。如灭道体是净处是净处。见时得不坏净可尔。苦集谛体非是净。非是净处。所以者何。是烦恼恶行邪见颠倒法。云何见时得不坏净耶。答曰。以二事故。得不坏净。一是可信。二是可求。于灭道谛。得不坏净。有二事。以是可信。亦是可求。于苦集谛。得不坏净。唯有一事。是可信非是可求。尊者瞿沙说曰。若为苦集所逼。则见灭道是胜。如人为风暴所逼。则见室宅为胜妙。彼亦如是。坚信人于坚信道。以二事故。得不坏净。一是可信。二是可求。于坚法道。亦有二事。坚法人于坚法道。亦以二事。一是可信。二是可求。于坚信道。唯是可信。非是可求。信解脱道。见到道。时解脱道。非时解脱道。声闻道。辟支佛道。佛道。随相而说。问曰。若信舍利弗身中无学法。为是于法不坏信。为是于僧不坏信。若是法者。彼缘声闻身中无学法。若是僧者。舍利弗一人非僧。答曰。应说是僧。问曰。若然者一人云何是僧。答曰。若以法而言是僧。若以人而言非僧

若依未至禅。得未曾得。于佛不坏净现在前时。现在二谓于佛及戒。未来四若起曾得者现在前。现在二未来无。乃至依第四禅说亦如是。若依无色定。得未曾得。于佛不坏净现在前时。现在一谓信佛。未来四若起曾得者现在前。现在一未来无

问曰。云何立不坏净。为以自体。为以所缘。若以自体者。应有二种。谓信及戒。若以所缘者。应有三种。谓佛法僧。所以者何。戒无所缘故。答曰。应作是说。以自体亦以所缘。自体者是戒。所缘者是信。如自体所缘。自体三宝。自体三归。说亦如是。此是不坏净体性。乃至广说。已说体性。所以今当说。何故名不坏。不坏净是何义。答曰。种种观解种种筹量得故名不坏净。复次不可破故名不坏净。若沙门婆罗门。若天若魔若梵。及余世间。无有能如法破者。故名不坏净。复次此信不可断。故名不坏净。无有沙门婆罗门能如法断者。广说如上。尊者瞿沙说曰。若于佛法。不种种观解。不种种筹量。犹如水上不系之船。轻躁易坏。与上相违。则不轻躁易坏。故名不坏净。问曰。世尊何故先说于佛不坏净。乃至后说戒不坏净耶。答曰。若作是说。则文义随顺。说者则易。受者易解。复次佛喻如医。法喻无病。僧喻瞻病人。戒喻良药。复次佛能说法故在初。佛为说何法。所以次信。法为谁说。法为僧说。所以次信僧。为以何事故名僧。以戒故名僧。所以次戒。复次能示众生道故先信佛。能到涅槃城故次信法。犹如善伴故次信僧。如资粮故次戒。复次信佛如船师。信法如彼岸。信僧如同载者。信戒如船

佛经说此圣所爱戒。不破不穿。不杂秽恶。智者所称誉。问曰。圣所爱戒。何故名不破不穿不杂秽恶。广说如杂揵度

阿毗昙毗婆沙论卷第五十三阿毗昙毗婆沙论卷第五十四

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    智揵度他心智品第二之六

佛经说佛告比丘。若有众生。能信乐汝所说者。汝等应以慈愍心为说。四不坏净。令得安住修行此法。广如契经说。问曰。世尊何故说此经耶。答曰。欲为说法者显示应听法缘故。说法者不知应为谁说。谁不应为说。心生怯弱。佛作是说。汝等不应轻有所说。若有众生。能信乐汝所说者。乃可为说。复次欲说报恩法故。佛说此经。经说佛告比丘。若人于百年中。一肩负父。一肩负母。处处游行。犹不名为报父母恩。佛告比丘。若父母不信教令立信。无戒为说善戒。悭吝教令布施无慧教令修慧。尔乃名为报父母恩。问曰。诸佛法中所有善法。尽应教人。何故独说教四不坏净耶。尊者波奢说曰。此中世尊说圣道名不坏净。一切圣道。或是相应法。或是共有法。若说信则说相应法圣道。若说戒则说共有法圣道。复次此说现初门略要始入法一切佛法所有善法。或是色或非色。若说戒。当知已说色性善法。若说信。当知已说非色性善法。如色法非色法。相应不相应。有依无依。有行无行。有势用无势用。有缘无缘。当知亦如是。复次所有善法。或是根性。或非根性。若说信。当知已说根性善法。若说戒。当知已说非根性善法。复次依四不坏净故。施设四沙门果。复次此四不坏净。有二种相。一不坏相。二是净相。不坏相者。无漏信不为非信所坏。无漏戒不为非戒所坏。信于心数法中是净相。戒于四大法中是净相。复次为示止恶道贫穷怖畏方便故。戒能止恶道怖畏。信能止贫穷怖畏。无漏信戒。虽无障非不因有漏信戒。复次欲引道依外道受化者令入佛法故。诸比丘。或有亲属。依外道受化。以亲受故。赞叹佛法。毁訾外道法。令他嗔恚。转远佛法。佛于是说。汝等无力无畏。不知众生诸根心行。汝于彼人。若有怜愍心者。当为说四不坏净。若得四不坏净。心不移动。所以者何。比丘当知。四大可令变异。若人得四不坏净。无有变异。问曰。一切诸法。尽不变异。何以独说四大不变异耶。答曰。以四法明四法故。复次行者先观四大不变异相。然后于一切法。见不变异相。复次外道计四大是常。佛说四大非是常法。假令四大如外道所说是常者。是常法可令变异。若我弟子。成就四不坏净有变异者。无有是处。复次四大能持展转增长生死法

佛经说。信是大象手。问曰。何故佛说信是大象手。答曰。能有所取故。如象有手。能取众生数非众生数物。如是圣弟子。有信手者。能取善法

佛经说若圣弟子。成就于佛不坏净。多住此法时。是时先成就于佛不坏净。诸天心大欢喜。作如是言。如我等成就多住于佛不坏净故。来生此间。诸圣弟子。亦成就于佛不坏净。身坏命终。亦当生此间。与我等同处。成就于法不坏净。于僧不坏净。于戒不坏净。亦如是。问曰。彼诸天先于此间。尽成就四不坏净。何故诸天。或有赞叹于佛不坏净者。或有乃至赞叹于戒不坏净者耶。答曰。众生或有为于佛不坏净。勤修方便入于佛法。或有乃至为于戒不坏净。勤修方便入于佛法。若为于佛不坏净。诸天勤修方便入于佛法者。则赞叹于佛不坏净。乃至为于戒不坏净。诸天勤修方便入于佛法者。则赞叹于戒不坏净。复次诸天或有乐观于佛者。或有乐观于戒者。若乐观于佛者。赞叹于佛不坏净。乃至若乐观于戒者。赞叹于戒不坏净

佛经说阿阇世王。成就无根信。问曰。一切有为法皆有根。何故说阿阇世王信无根耶。答曰。此信以无见道根故。如说不坏智相应信。以见道为根。彼无见道根故言无根。而有与见道相似信为根。复次无无漏智善根故言无根。无漏信以无漏智无漏善根为根。彼不得无漏智。亦不得无漏善根。而得与无漏相似信。复次阿阇世王。不久供养佛。亦不亲近诸有德比丘。而得如是信。若于楼观象马之上。见佛世尊。即前向佛。以身投地。身无苦痛。是无根信力。亦是佛之威神。是故名无根信。复次此信无相似因。无有法与彼信作相似因者。如干树无根。彼信亦尔。故名无根。复次虽有此信。不免恶道。故名无根信

此四颠倒须陀洹。几断几不断。问曰。何故作此论。答曰。如毗婆阇婆提说。有十二颠倒。谓无常有常想颠倒心颠倒见颠倒。苦有乐想颠倒心颠倒见颠倒。无我我想颠倒心颠倒见颠倒。不净净想颠倒心颠倒见颠倒。八是见道断。四是修道断。八见道断者。无常常想颠倒见颠倒。苦有乐想颠倒见颠倒。无我我想颠倒见颠倒不净净想颠倒见颠倒。四是修道断者。无常计常心颠倒。苦计乐心颠倒。无我计我心颠倒。不净计净心颠倒。诸见道断者。苦比忍现在前时毕竟断。诸修道断者。金刚喻定现在前时毕竟断。问曰。彼何故作如是说。答曰。彼依佛经。佛经说佛告比丘。此四颠倒想颠倒心颠倒见颠倒。乃至广说。依此经故。说十二颠倒。以二事止如是说者意。而作问答。若作是问。此四颠倒须陀洹。几断几不断。则止彼说十二者意。若作是答。须陀洹尽断则止彼说是修道断者意。所以者何。修道中无如是法。是须陀洹所断。若颠倒有十二种。亦是修道断者。则违佛经。如说佛告比丘。若有四颠倒。所颠倒者。当知皆是愚小凡夫。所以者何。凡夫观生死法。不见端绪。如观狗肠。佛经若说四。当知则无十二。若说皆是愚小凡夫。当知则非修道所断。问曰。若颠倒但有四者。毗婆阇婆提所引经云何通耶。答曰。想心亲近颠倒故。亦名颠倒。问曰。受等诸数法。亦亲近颠倒法。何故不名颠倒耶。答曰此二是世俗言说法故。世俗皆作是说。此人心颠倒想颠倒。而不说受颠倒思颠倒。问曰。颠倒体性是何。答曰。体性是慧。问曰。若颠倒体性是慧者。此五见几是颠倒。几非颠倒。答曰。二见半是颠倒。二见半非颠倒二见半是颠倒者。谓身见见取边见中常见。二见半非颠倒者。谓邪见戒取边见中断见。问曰。何故二见半是颠倒。二见半非颠倒耶。答曰。以三事故是颠倒。一以猛利。二以妄取。三以一向性颠倒。邪见边见所摄断见。虽是猛利一向性颠倒。而非妄取。所以者何。一向坏物体故。戒取虽是猛利亦是妄取。而非一向性颠倒。所以者何。有少相似故。有色界道。能离欲界。有无色界道。能离色界。此是颠倒体性。乃至广说。已说体性。所以今当说。何故名颠倒。颠倒是何义。答曰。所取颠倒故名颠倒

此颠倒。一向见苦断。问曰。何故颠倒一向见苦断耶。答曰。因苦生故。还见苦断。复次此颠倒。依果生故。还见果断。复次身见是见苦断性。是颠倒以身见。是见苦断故。颠倒亦见苦断。复次苦谛是粗现法。若于粗现法中谬误者。则为贤圣之所呵责。如人昼日谬误人所呵责。彼亦如是。余三谛微细。若于微细法中。有谬误者。贤圣不必呵责。如人于夜有谬误者。不必为人之所呵责。复次行者见苦已。更无颠倒心。无有是处。以分别故。而作是说。假令行者见苦谛已。不见余三谛。他人问言。此阴是常是断。答言是断。无有一刹那住者。为是苦是乐耶。答言是苦。如热铁丸。是净不净耶。答言是不净。粪秽聚。有我无我耶。答言无我。无作无作者

问曰。坚信坚法人。亦断颠倒。何故但说须陀洹耶。答曰。应说而不说者。当知此说有余。复次坚信坚法人。是分别相。于此颠倒。或有断者有不断者。此中一向说不分别相者。复次欲令疑者得决定故。须陀洹行凡夫所行法。与妻子同一处宿。手扪摸骨人。着憍奢耶衣。栴檀涂身。亦着种种璎珞华鬘。亦驱使奴婢仆从。亦以手打搏众生时。人见此事故。谓不断颠倒。欲令此疑得决定故。而作是说。坚信坚法人。尚无有漏善心不隐没无记心现在前。何况染污心耶

问曰须陀洹斯陀含。起染爱时。为是乐想净想。为是苦想不净想。若起乐想净想者。云何不是颠倒耶。若是苦想不净想者。云何起染爱耶。答曰。应作是说。起乐想净想。问曰。若然者云何不是颠倒耶。答曰。先作是说。以三事故是颠倒。一以猛利。二以妄取。三以一向性倒须陀洹染爱。虽是猛利及以妄取。而非一向性倒。复次或有于谛计乐计净。或有于境界计乐计净。于谛计乐计净者。须陀洹永断于境界。计乐计净者。须陀洹未断。复有说。须陀洹起染爱时。计苦计不净。问曰。若然者云何起染爱耶。答曰。从无始已来。学习此法。身心生热。为制伏此心故。起此染爱。犹如自喜婆罗门。指触粪秽。诣鍜师所。求以火净之。时鍜师语言。可以灰土浣草而以净之。婆罗门言。如是等物。不能净于我指。必当以火净之。是时鍜师。烧钳作火色。以钳其指。时婆罗门。为热所苦逼。便振其手。以指着口中。婆罗门审知指不净。但为苦痛所逼。而着口中。彼亦如是。复次为无始已来。久习烦恼所逼切故。为治此法起于染爱。如人身体鲜白软细。而生痈疮极用苦痛。求欲治之医语之言。汝可以湿狗粪而用涂之。其人即涂。审知狗粪不净。为除病故。而以涂之。彼亦如是

此三三昧须陀洹。几过去成就。几未来成就。几现在成就。问曰。何故作此论。答曰。为止言无过去未来行于世中愚故。广说如上

此三三昧须陀洹。几过去成就。几未来成就。几现在成就。答曰。未来悉成就。过去灭已不舍则成就。现在若现在前则成就。道比智最初刹那无过去。所以者何。未有一刹那生已灭者。生已灭者。得果故舍。三未来成就。一现在。谓无愿三昧。彼灭已不舍。若起空三昧现在前。一过去成就。谓无愿三昧。三未来。一现在谓空。彼灭已不舍。若起无相三昧现在前。二过去谓空无愿三昧。三未来。一现在谓无相。若灭已不舍。于此三三昧。若起一现在前。过去未来三。现在一起现在前者。三三昧广如使揵度大章说。信解脱转根作见到。广说如人品中。若道过去。彼道已修已猗耶。乃至广说。修有四种。一得修。二行修。三对治修。四除去修。有为善法。是得修行修。有漏法是对治修除去修。外国法师说。修有六种。四如先说。更有二修。谓戒修分别修。戒修者是修根。如说若此六根。善调伏。善覆藏。善守护。善修者。谓能生乐。分别修者。分别于身。如说此身谓发毛爪齿等。乃至广说。罽宾沙门。作如是说。此二修当知在前二修中。谓对治修除去修。是故修有四种。此中依二种修而作论。谓得修行修。如说若修法智。亦修比智耶。此亦依二修而作论。如说修身修心修戒修慧。此亦依二修而作论。谓对治修除去修。如说云何修眼根。亦依此二修而作论。如说若修世俗初禅。亦修无漏耶。此亦依二修而作论。谓得修行修。如说若修空三昧。亦修无愿耶。亦依此二修而作论。如说若修身念处。亦修受念处耶。亦依此二修而作论。如说若修无常想。亦观无常想耶。此中或有说。是得修者。或有说。是行修者。如说云何可修法。一切善有为法。此中虽有四种修义。亦依得修行修而作论。是故得作四句。有法是得修行修非对治修除去修。有法是对治修除去修非得修行修。有法是得修行修亦是对治修除去修。有法非得修行修亦非对治修除去修。是得修行修非对治修除去修者。无漏有为法是也。是对治修除去修非得修行修者。染污法不隐没无记有为法是也。是得修行修亦是对治修除去修者。善有漏法是也。非得修行修亦非对治修除去修者。无为法是也。问曰修是何义。答曰勋义是修义。学习义是修义。明净义是修义。现前修以行名说。未来修以得名说。现在以现在前故名修。未来以当生故名修。复次现在有所作故名修。未来与欲故名修。复次现在在身中故名修。未来以得故名修

若道过去。彼道已修已猗耶。答曰。若道过去已修已猗修者。谓二种修。得修行修。已猗者已过去故。颇道已修已猗。彼道不过去耶。答曰。有未来道。已修已猗。起不净观现在前。未来有无量刹那修。从第二刹那以后。尽名已修已猗道。谓得修以在未来故。不名过去。乃至起初尽智现在前。未来有无量尽智刹那修。从第二刹那修已后。尽名已修已猗道。谓得修。若道未来。彼道非已修非已猗耶。答曰。或道在未来。彼道非不已修。非不已猗。乃至广作四句。云何道在未来。彼道非不已修。非不已猗。答曰。诸未来道。已修已猗。如上所说。云何道非已修非已猗。彼道非未来耶。答曰。起未曾得道现在前。起不净观。乃至尽智现在前。此道非已修非已猗。此道非未来非已修者。是行修故。非未来者。是现在故。云何道在未来。彼道非已修非已猗。答曰。诸未来道。非已修非已猗者。起不净观乃至尽智现在前。未来无量刹那修。诸未来修。与最初刹那俱者。彼道非已修已猗。所以者何。是今修今猗。谓得修而彼道在未来。云何道不在未来。彼道非不已修。非不已猗。答曰。过去道亦起曾得道现在前。曾得道者。曾得不净观。乃至尽智起现在前。问曰。此道是今修今猗。是行修何故说非不已修非已猗耶。答曰。此文应如是说。过去道是也。不应说起曾得道现在前。若作是说。有何意耶。答曰。此道虽是行修。今修今猗。亦是得修已修已猗。若道现在。彼道今修今猗耶。答曰。若道现在。彼道今修今猗。或具二修。谓得修行修。或有唯行修者。颇道今修今猗。彼道非现在耶。答曰。有起未曾得道现在前未来相似者。修相似有四种。一修相似。二戒相似。三界相似。四性相似。修相似者此中说起未曾得道现在前。未来相似者修此中或有说。有漏道有漏道相似修。无漏道无漏相似修。评曰。应作是说。有漏道有漏道无漏道相似修。无漏道有无漏道有漏道相似。所以者何。以彼力故。起世俗道现在前。有漏无漏道修起无漏道现在前无漏有漏道修。戒相似者。如业揵度说。若成就过去戒。亦成就未来现在相似戒耶。相似戒者。如逮解脱戒。有相似逮解脱戒。禅戒有相似禅戒。无漏戒有相似无漏戒。有作戒有相似有作戒。无作戒有相似无作戒。界相似者。如根揵度说。若成就此相似眼根。亦成就此相似身根耶。若法同在一界可得者名界相似。欲界法与欲界法相似。色界法与色界法相似。无色界法与无色界法相似。性相似者。如毗尼中说。尊者陀婆摩罗子。左手放光。为诸相似比丘分房舍卧具。相似诵修多罗者。同在一处。相似诵毗尼者。同在一处。相似诵阿毗昙者。同在一处。相似行阿练若法者。同在一处。欲令诸比丘同住谈论静默者。各相随顺故。余经亦说。众生种类相似相随。行恶者与行恶者相随。行善者与行善者相随。此中于此四种相似中依修相似而作论。起不净观现在前。未来有无量不净观刹那修。诸未来修。与最初刹那俱者。此是今修。谓得修。彼道非现在在未来故。阿那般那念处。暖顶忍世第一法。见道修道。尽智现在前时。说亦如是。问曰。退阿罗汉果。住须陀洹果时。须陀洹果。但是得亦是修耶。答曰。但是得不修。若还得阿罗汉果时。但是得亦是修耶。答曰。过去者是得非修。未来者是得亦修。问曰。何故过去者是得非修。未来者是得亦修耶。答曰。若有现在因者。有得亦修。若无现在因者。但得非修。问曰。须陀洹果。亦有现在因。何故但得非修耶。答曰。若有现在因。能胜进者。是得亦修。住须陀洹果。虽有现在因。而是退道故。但得非修

阿毗昙毗婆沙论卷第五十四阿毗昙毗婆沙论卷第五十五

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    智揵度修智品第三之一

八智。法智比智他心智等智苦智集智灭智道智。云何法智。乃至道智。如此章及解章义。此中应广说优波提舍。问曰。彼尊者迦旃延子。何故依八智而作论。答曰。此中应广如使揵度大章中说。法智摄几智。乃至道智摄几智。问曰。何故作此论。答曰。为止并义者意故。如毗婆阇婆提说摄他性法不摄自性法。为止如是说者意。而作此论。摄如使揵度一行品中广说

法智摄法智。亦摄五智少分。谓他心智苦集灭道智。总而言之。法智摄法智。然法智在六地。谓未至中间根本四禅。未至禅中者。摄未至禅中者。乃至第四禅中者。摄第四禅中者。又法智是四智。谓是苦智。乃至道智。苦智摄苦法智。乃至道智。摄道法智。又法智在过去未来现在。过去者摄过去者。未来现在者。摄未来现在者。又过去法智。有无量刹那。彼刹那即摄彼刹那。未来现在说亦如是。云何摄他心智少分邪。答曰。他心智是有漏无漏。摄无漏者。不摄有漏者。彼无漏复有二种。谓法智分比智分。摄法智分。不摄比智分。是名少分。云何摄苦智少分邪。答曰。苦智是法智分比智分。摄法智分。不摄比智分。是名少分。乃至道智说亦如是。比智摄比智。亦摄五智少分。广说如法智他心智摄他心智。亦摄四智少分。谓法智比智等智道智。总而言之。他心智摄他心智。然他心智在根本四禅中初禅者。摄初禅者。乃至第四禅者。摄第四禅者。又他心智。是有漏无漏。有漏者摄有漏者。无漏者摄无漏者。又他心智。是法智分比智分。法智分摄法智分者。比智分摄比智分者。在过去未来现在。如先所说。云何摄法智少分邪。法智是四智摄道智不摄余智。是名少分。又道智是总相别相。摄别相者。不摄总相者。道智有缘三世者。有缘现在者。有缘自身。有缘他身者。有缘心心数法者。有缘五阴者。摄缘现在他身心心数法者。不摄缘过去未来自身及五阴者。是名少分。比智亦如是。随相而说。云何摄等智少分邪。答曰。等智在十一地。从欲界乃至非想非非想处。摄在根本四禅地者。不摄余地者。又等智缘总相别相。摄别相者。不摄总相。余广说如上。云何摄道智少分。答曰。道智在九地。谓未至中间根本四禅三无色定。摄根本禅地。不摄余地者。是名少分。又道智缘总相别相。乃至广说。是名少分。等智摄等智。亦摄一智少分。谓他心智。总而言之。等智摄等智。然等智在十一地。谓欲界未至中间根本四禅四无色定。欲界摄欲界者。乃至非想非非想处摄非想非非想处者。又欲界者。有善秽污不隐没无记。善摄善者。秽污摄秽污者。不隐没无记摄不隐没无记者。此三在过去未来现在。过去未来现在。即摄过去未来现在者。又过去。有无量刹那。彼刹那即摄彼刹那者。未来亦如是。如是欲界乃至非想非非想地说亦如是。云何摄他心智少分。答曰。他心智是有漏无漏。摄有漏者。不摄无漏者。是名少分。苦智摄苦智。亦摄二智少分。谓法智比智。总而言之。苦智摄苦智。然苦智在九地。谓未至中间根本四禅三无色定。未至禅摄未至禅者。乃至无所有处摄无所有处者。余广说如上。云何摄法智少分。答曰。法智是四智。谓苦集灭道智。摄苦智分。不摄余智分。是名少分。如法智比智亦如是。如苦智。集灭智亦如是。道智摄道智。亦摄三智少分。谓法智比智他心智。总而言之。道智摄道智。广说如上。苦智异者。摄他心智少分。云何摄他心智少分。答曰。他心智是有漏无漏。摄无漏者。不摄有漏者。是名少分。若成就法智。于此八智。为成就几不成就几。问曰。何故作此论。答曰。为止说无成就者意故。而作此论

若成就法智。于此八智。为成就几。不成就几。答曰。或成就三四五六七八。苦法智时。无他心智三。谓法智苦智等智。有他心智四。苦比忍时。无他心智三。有他心智四。此中增见增慧增道。不增智不增名。苦比智时。无他心智四。谓法智比智等智苦智。有他心智五。此中增见增慧增道增智增名。集法忍时。无他心智四。有他心智五。此中增见增慧增道。不增智不增名。集法智时。无他心智五。谓法智比智等智苦智集智。有他心智六。此中增见增慧增道增智增名。集法忍时。无他心智五。有他心智六。此中增见增慧增道。不增智不增名。集比智时。无他心智五。有他心智六。此中增见增慧增道。不增智不增名。所以者何。苦比智时。已立比智名。集法智时。已立集智名。灭法忍时。无他心智五。有他心智六。此中增见增慧增道。不增智不增名。灭法智时。无他心智六。谓法智比智等智集智灭智。有他心智七。此中增见增慧增道增智增名。灭比忍时。无他心智六。有他心智七。此中增见增慧增道。不增智不增名。灭比智时。无他心智六。有他心智七。此中增见增慧增道。不增智不增名。所以者何。灭法智时。已立灭智名。苦比智时。已立比智名。道法忍时。无他心智六。有他心智七。此中增见增慧增道。不增智不增名。道法智时。无他心智七。谓法智比智等智苦智集智灭智道智。有他心智八。此中增见增慧增道增智增名。道比忍时。无他心智七。有他心智八。此中增见增慧增道。不增智不增名。所以者何。道法智时。已立道智名。苦比智时。已立比智名。乃至成就道智。随相而说

若修法智时。亦修比智邪。修有四种。广说如上。此中因二修而作论。谓得修行修。凡夫人离欲界欲时。方便道。九无碍道。八解脱道中现在修等智。未来亦修等智。第九解脱道中。现在修等智。未来修等智。他心智。离初禅欲时。若即依初禅作方便者。方便道中。现在修等智。未来修等智。他心智。若依第二禅边作方便者。方便道。九无碍道。八解脱道。现在修等智。未来亦修等智。第九解脱道。现在修等智。未来修等智。他心智。乃至离第三禅欲亦如是。离第四禅欲时。若即依第四禅作方便者。方便道。现在修等智。未来修等智。他心智。若依空处边作方便者。方便道。九无碍道。九解脱道。现在修等智。未来亦修等智。离空处欲时。方便道。九无碍道。九解脱道。现在修等智。未来亦修等智。乃至离无所有处欲。说亦如是。未离欲界欲凡夫。起四无量初二解脱初四胜处不净安那般那念念处暖顶忍世第一法时。现在修等智。未来亦修等智。离欲界欲凡夫。起四无量初三解脱八胜处八一切处不净安那般那念念处时。现在修等智。未来修等智。他心智。离欲界欲凡夫。起达分善根时。现在修等智。未来亦修等智。离欲界欲凡夫。起通时。方便道二解脱道中。现在修等智。未来修等智。他心智一解脱道中。现在修他心智。未来修等智。他心智五无碍道中。现在修等智。未来亦修等智。即彼凡夫。起无色界解脱空处一切处识处一切处依无色界念处时。现在修等智。未来亦修等智。此则说凡夫人圣人见道中起如是功德现在前。即是功德未来修。如起忍现在前。即未来修忍。起智现在前。即未来修智。唯除三心顷。未来修世俗道。谓苦比智。集比智。灭比智。修见道边等智。问曰。何故见道中。唯修相似法。修道中修相似不相似法邪。答曰。见道中所缘定对治定故。唯修相似法。不修不相似者。修道中所缘不定对治亦不定故。修相似不相似法余答广说。如杂揵度。若无他心智入见道道比智现在前时。现在修二智。谓道智比智。未来修六智。除等智他心智。若有他心智现在。亦修二智。未来修七智。除等智。圣人以世俗道。离欲界欲时。若以无漏作方便。方便道。于八智中。若一一智现在前。未来修七智。若以世俗道作方便。方便道。九无碍道。八解脱道中。现在修等智。未来修七智。第九解脱道。现在修等智。未来修八智。离初禅欲时。若以无漏作方便。于八智中。若一一智现在前。修未来修八智。若以世俗道作方便。方便道九解脱道中。现在修等智。未来修八智。九无碍道中。现在修等智。未来修七智。乃至离无所有处欲。说亦如是。圣人以无漏道。离欲界欲时。若以世俗作方便。现在修等智。未来修七智。若以无漏作方便。于八智中。若起一一智现在前。修未来修七智。九无碍道。八解脱道。于四智中。若起一一智现在前。修未来修。七智。第九解脱道。于四智中。若一一智现在前。修未来修八智。离初禅欲时。若以世俗道作方便现在修等智。未来修八智。若以无漏作方便。于八智中。若一一智现在前修未来修八智。九无碍道于六智中。若一一智现在前修未来修七智。九解脱道。于六智中。若一一智现在前修未来修八智。乃至离无所有处。欲说亦如是。离非想非非想处欲时。若以世俗作方便。现在修等智。未来修八智。若以无漏作方便。于八智中。若一一智现在前修未来修八智。九无碍道。于六智中。若一一智现在前修未来修六智。八解脱道。于六智中。若一一智现在前修未来修七智。第九解脱道。于二智中。若一智现在前修未来修八智。及三界善根。是则说圣人离欲。未离欲界欲。信解脱转根作见到。若以世俗。作方便道。方便道中。现在修等智。未来修七智。若以无漏作方便。方便道。于八智中。若一一智现在前修未来修七智。无碍道。于八智中。若一一智现在前修未来修六智。解脱道。于八智中。若一一智现在前修未来。或有说者修六智。或有说者修七智。离欲界欲信解脱转根作见到时。若以世俗作方便道中。现在修等智。未来修八智。若以无漏作方便。方便道。于八智中。若一一智现在前修未来修八智。无碍道。于八智中。若一一智现在前修未来修六智。解脱道。于八智中。若一一智现在前修未来。或有说修七智。或有说修八智。时解脱阿罗汉。转根作不动时。若以世俗作方便。方便道中。现在修等智。未来修八智。若以无漏作方便。于八智中。若一一智现在前修未来修八智。九无碍道。于六智中。若一一智现在前修未来修六智。八解脱道。于六智中。若一一智现在前修未来修七智。第九解脱道。于二智中。若一智现在前修未来修八智及三界善根。修勋禅时。初刹那顷。于八智中。若一一智现在前修未来修七智。第二刹那顷现在前修等智。未来修七智。第三刹那顷。于八智中。若一一智现在前修未来修八智。起通时五无碍道中。现在修等智。未来修七智。二解脱道中。现在修等智。未来修八智。起他心智解脱时。现在修他心智。未来修八智。起四无量初三解脱八胜处八一切处不净安那般那念禅中世俗念处世俗无碍无诤愿智半多俱置迦空空三昧无愿无愿三昧无相无相三昧世俗无色解脱空处识处一切处无色界世俗念处入灭定微细想时。现在修等智。未来修八智。起无漏智时。现在修他心智。未来修八智。起禅中无漏念处无漏无碍。于八智中现在。若一一智现在前修未来修八智。起无色界无漏解脱无漏无碍无漏念处。于四智中。若一一智现在前修未来修八智。起出灭定微微心。现在修等智。未来亦修等智。如是等说是略毗婆沙。若修法智时。亦修比智邪。乃至广说。作四句。修法智不修比智者。见道中苦法智集法智灭法智道法智时。不修比智。所以者何。见道中若修此功德。即此功德未来修法智现在前。即修法智比智现在前。即修比智学见迹。若阿罗汉起本得法智现在前。学者是须陀洹斯陀含阿那含迹是圣谛。若有见者。名为见迹。阿罗汉者。若慧解脱。若俱解脱。是时不修比智。所以者何。起本得功德现在前。尚不能令次后刹那修。何况未来远者。修比智不修法智者。见道中苦比智集比智灭比智时。不修法智。如先所说。学见迹。若阿罗汉起本得比智现在前。如上所说。修法智亦修比智者。入见道道比智时。修法智亦修比智。所以者何。是时舍曾得道。得未曾得道。断烦恼同一味证解脱。得具得八智。修十六行学见迹。若阿罗汉。起未曾得无漏智现在前。学人以无漏道。离欲界欲时。若以无漏作方便。方便道。九无碍道。九解脱道。乃至离无所有处欲。得俱修离非想非非想处欲时。若以无漏作方便。方便道。九无碍道。八解脱道。信解脱转根作见到时。若以无漏作方便。方便道。无碍道。解脱道。修勋禅时。前后心刹那。学人起无漏他心智。起无漏念处。起无色无漏解脱。如是等时起未曾得无漏智现在前。得修法智比智。离非想非非想处欲。阿罗汉住最后解脱道时。解脱阿罗汉。转根作不动。若以无漏作方便。方便道。九无碍道。九解脱道。修勋禅时。前后心刹那。起无漏他心智。起无漏念处。起无漏无碍起无漏解脱。如是等时。起未曾得无漏智现在前。得修法智比智。起未曾得世俗智现在前。是时得修法智比智。学人以世俗道。离欲界欲。若以世俗作方便。方便道。九无碍道。九解脱道。乃至离无所有处欲。说亦如是。若为断非想非非想处欲。以世俗。作方便。方便道信解脱。转根作见到时。若以世俗作方便方便道。修勋禅时。中心刹那。起通时方便方便道。五无碍道。三解脱道。起四无量世俗解脱胜处。一切处不净安那般那念世俗念处入灭定微细想时。解脱阿罗汉。转根作不动。若以世俗作方便。方便道。修勋禅时。中心刹那起通时。方便道。五无碍道。三解脱道。起无量世俗解脱胜处一切处。起世俗念。处世俗无碍。起无诤愿智半多俱置迦。入灭定时。微细想。如是等时。起未曾得世俗智现在前未来得修法智比智。不修法智比智者学见迹。若阿罗汉。起已曾得世俗智现在前。已曾得功德现在前。尚不能令次后刹那修。何况未来远者。起未曾得世俗智现在前。谓闻思慧。及出灭定微微心。是时不得修法智比智。一切凡夫人。不修此智。所以者何。此智非凡夫法故。是以不修染污心者。是退分。其性沉重。与懈怠相应。胜妙与精进相应。心能有所修。无记心者。是卑下劣弱。如腐种子。不能有所修坚固牢强心。能有所修入无想定灭定。是无心法有心法。能有所修无想。众生或有说者。一切时不能起善心现在前。或有说者。虽起善心。不能为修作所依。一切忍现在前时。唯修忍不修智。问曰。起已曾得法现在前。何故无未来修邪。答曰。此法已用。已有所作。已与果故。复次此法已修已猗。更无势用。复次起已曾得法现在前时。是行修在未来世时。是得修以经历世故。但有损减。何得更增益邪。如人食用先所聚财物。但有损减。更无增益。彼亦如是

复次多用功多有所作者。欲令未来世。能起已曾得法现在前。不多用功不多有所作故。不能令未来世者修。复次若起已曾得法现在前未来修者。世尊般涅槃时。入一切诸禅三昧。亦应未来世修。若修者。则世尊得尽智时。则不具得一切诸善功德。欲令无如是过故。起已曾得功德。无未来世修。余智修随相广说如经本。有见道边等智。有得尽智时善根。此中应广说如杂揵度

法智当言缘法智邪。问曰。何故作此论。答曰。欲止说境界缘无有体性者意亦明境界缘实有体性故。而作此论。或有说者。此中作如是问。法智缘几智邪。若如其所说。法智不缘比智。尽缘余智。比智不缘法智。尽缘余智。他心智等智。尽缘诸智。苦智集智。缘等智他心智。不缘余智。灭智不缘诸智。道智不缘等智。尽缘余智。复有说者。此中作如是问。法智为几智所缘。若作是说。法智为几智所缘者。若如其所说。苦智集智比智灭智。不缘法智。余智则缘苦智集智法智。灭智不缘比智。余智则缘灭智。不缘他心智。余智则缘灭智。道智不缘等智。余智则缘苦集灭智。各不为苦集灭智所缘。余智则缘苦集灭智。不缘道智。余智则缘。问曰。何故法智比智。各不相缘邪。答曰。法智境界于下。比智境界于上。譬如二人同住一处。一人视地。一人视空。其二人面各不相视。彼亦如是。法智于法智有几缘。乃至于道智有几缘邪。问曰何故作此论。答曰。欲止说四缘无体性者意亦欲明四缘实有体性故。而作此论。法智于法智。有几缘邪。答曰。法智于法智。因次第缘威势。问曰。何故此中说缘异。使揵度不善品中说缘异。如此中说。法智于法智。因次第缘威势。如不善品中说。身见于身见。或四三二一邪。答曰。如此中所说。法智于法智。因次第缘威势。彼中亦应如是说。如彼所说。身见于身见。或四三二一。此中亦应如是说。复次欲现二门二略。广说如使揵度。法智于法智因次第缘威势。因者如种子故。次第者前开导故。境界缘者。如执杖故。威势缘者。不相障碍故。法智于法智。有一因。谓相似因。次第缘者。法智次第起法智现在前。境界缘者。法智缘法智。威势缘者。不相障碍。法智于比智。因次第威势无缘。因者。谓相似因。次第缘者。法智次第起比智现在前。威势缘者。不相障碍故。无缘者。法智比智。各不相缘。法智于他心智。因次第缘威势。如先所说。法智于等智。次第缘威势无因。所以者何。因者如种子。无漏法不为有漏法作种子。法智于苦集灭智。因次第威势无缘。所以者何。苦集智缘有漏法。此智是无漏。灭智缘无为。此智是有为。余广说如上。法智于道智。因次第缘威势。广说如上。比智如法智。随相而说。他心智于他心智。因次第缘威势。如上所说。此中异者。若有因无缘。若有缘无因。有因无缘者。自身于自身。有缘无因者。他身于自身。他心智于等智。因次第缘威势。因者二因。谓相似因报因。余广说如上。他心智于苦集智。因次第缘威势。因者谓相似因。若有因无缘。若有缘无因。有因无缘者。因是无漏。苦集智缘有漏。有缘无因者。苦集智缘有漏。因是无漏故。他心智于灭智。因次第威势无缘。广说如上。他心智于道智法智比智。因次第缘威势。广说如上。等智于等智。因次第缘威势。因者有三因。谓相似因。一切遍因报因。余广说如上。等智于苦集智。次第缘威势无因。所以者何。因如种子。有漏法不为无漏法作种子。等智于灭智道智。次第威势无因无缘。次第者。次第智。次第起灭道智现在前。威势者不相障碍。无因者有漏法不为无漏法作因。无缘者灭道智缘无漏。等智是有漏。等智于法智比智。次第缘威势无因。广说如上。等智于他心智。因次第缘威势。因者谓相似因。余广说如上。苦集灭智。于苦集灭智。因次第威势无缘。因者相似因。次第缘者苦集灭智。次第起苦集灭智。威势缘者。不相障碍无缘。所以者何。苦集智缘有漏。此诸智是无漏灭智缘无为。此诸智是有为。苦集灭智于道智法智比智他心智。因次第缘威势。广说如上。苦集灭智于等智。次第缘威势无因。广说如上。道智于道智法智比智他心智。因次第缘威势。广说如上。道智于等智。次第缘威势无因。广说如上。道智于苦集灭智。因次第威势无缘。所以者何。道智是学无学。此诸智缘非学非无学。诸结欲界系。彼结法智断邪。问曰。何故作此论。答曰。欲令疑者得决定故。法智能断色无色界结。比智不能断欲界结。或谓如法智能断色无色界结。比智亦能断欲界结。或谓如比智不能断欲界结。法智亦不能断色无色界结。欲令此义决定。法智能断色无色界结。比智不能断欲界结故。而作此论

问曰。何故法智能断色无色界结。比智不能断欲界结邪。答曰。法智先断欲界结故。能断色无色界结。比智先不断色无色界结故。不能断欲界结。复有说者。以比智未断色无色界结故。法智能断。以法智已断欲界结故。比智不断。复次若比智能断欲界结者。为已断色无色界结邪。为未断邪。若已断者。无有先断色无色界结后断欲界结者。若未断者。比智则应有如是责。自界结欲未断。乃断他界结。譬如国王不能降伏自国。乃欲降伏他国王。则有如是责。云何不能降伏自国。乃欲降伏他国。彼亦如是。复次道比智时。比智设离欲界欲。最后解脱道。比智乃出。以没不出故。不能断欲界结。复次法智断欲界结已。最后解脱道。其性猛利。以猛利故。能上断色无色界结。比智断非想非非想处结。最后解脱道。其性猛利。以猛利故。欲断欲界结。而欲界结已断。复次邪见能缘三界苦集者。先已断结。次求其对治及灭。而能使色无色界结便断。色无色界邪见。不能缘欲界。不求对治及灭故。不能断欲界结。复以若是他界一切遍能缘三界苦集者。先已断后求其对治及灭。而能使色无色界结便断。犹如负责之人。先杀怨贼。后亦坏其游戏欢娱之处。彼亦如是。复次法智猛利。不多用功。能断不善无记烦恼。何况无记烦恼邪。譬如利刀。能断于铁。何况草木。彼亦如是。比智非猛利智。多用功力。乃能断无记烦恼。何能断不善烦恼。譬如钝刀。多用功力。能断草木。何能断铁邪。彼亦如是。复次法智如千人敌。云何如千人敌。以能对治十八界十二入五阴故。比智非如千人敌。云何非如千人敌。以对治十四界十入五阴四阴故。复次行者为欲界五阴之所逼切。如负重担。求其对治。及灭时能断色无色界结。法智能断色无色界结者。是灭道法智。非苦集法智。问曰。何故非苦集法智。答曰。行者为欲界五阴之所逼切。欲负重担求其对治。及灭时能断色无色界结。复次欲界是不定界。非修地。非离欲地。色无色界。是定地修地离欲地。不可以缘不定界智断定界结。复次欲界是粗界。色界是细界。不可以缘粗界智断细界结。复次欲界是下界。色界是中界。无色界是上界。不可以缘下界智断中上界结。复次若苦集法智。能断色无色界结者。便为于异处修厌异处得解脱。譬如断手系手得解脱断脚系脚得解脱。不可断手系脚得解脱断脚系手得解脱。彼亦如是。若以灭道法智。断色无色界结。必是生欲界者。非生色无色界者。问曰。何故但是生欲界者。非是生色无色界者。答曰。入法智出比智方便心。是欲界系法。以弃彼法生色无色界故。复次与法智回转成是欲界四大造。弃彼四大。生色无色界故。复次法智于欲界。所作已竟。更不作方便。于色无色界。更不起现在前。犹如阿罗汉。更不起三界断对治现在前。彼亦如是

    校正序

宋本此卷首云。智揵度他心智品第二之六。已说体性所以今当说。何故名念前世智(云云乃至)卷末云。是说愿智方便缘自身者等凡十五纸文。其与国本宋本迥异者何耶。今捡宋本错乱。此文即是此论前文。宋丹则第五十卷。国本则五十一卷之全耳。而重书为此五十五卷者错也。今依丹本正之。国本虽与二本不同。但分卷有异耳。序则不乱焉

阿毗昙毗婆沙论卷第五十五阿毗昙毗婆沙论卷第五十六

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    智揵度修智品第三之二

问曰。若然者何故阿罗汉起苦集智现在前耶。答曰。欲观此五阴。犹如重担过患法故。尊者瞿沙。作如是说。生无色界。不能起禅及禅中功德现在前。生色界中。则能此说。是何义耶。答曰。此说灭道法智生色界者。能起此智。断色无色界结。若烦恼已断。更不起此智。评曰。不应作是说。生色界起法智现在前。所以者何。此智非彼界对治故。复次此是不定坏相。或有起少分。谓灭道法智。或有不起少分者。谓苦集法智。或有起者。或不起者。未离欲者起。已离欲者不起。或时起或时不起。离欲道时起。余善根时不起。以是事故。如前说者好。诸结欲界系。彼结法智断耶。答曰。或结是欲界系。彼结非法智断。乃至广作四句。云何结是欲界系。彼结非法智断。答曰。诸结忍断。亦余智断。亦不断。忍者是四法忍。余智者是等智。不断者若已断。若不作方便断。云何结是法智断。彼结非是欲界系。答曰。诸结是色无色界系。法智断法智者是灭道法智。离色无色界结者。云何结是欲界系。彼结法智断。答曰。诸结欲界系。法智断法智者是四法智。离欲界结者。云何结非是欲界系。彼结非是法智断。答曰。诸结色无色界系。彼忍断若余智断亦不断忍者。是四比忍余智断者。若等智断。若比智断。不断者。若已断。若不作方便断。诸结色无色界系。彼结比智断耶。答曰。诸结比智断。彼结色无色界系。颇有结色无色界系彼结非比智断耶。答曰。诸结忍断亦余智断。亦不断忍者。是四比忍。余智者是法智等智不断者若已断若不作方便断。诸结见苦断。彼结苦智断耶。答曰。或结是见苦断。彼结非苦智断诸结忍断。所以者何彼忍是此结对治故。或结是苦智断。彼非见苦断。诸结是修道断。彼结苦智断。所以者何。苦智是修道所断结对治故。如见苦所断结。乃至见道所断结。说亦如是。问曰。为无碍道断烦恼。为解脱断耶。若无碍道断烦恼者。使揵度所说云何通。如说结有九种。苦法智所断种。乃至修道所断种。若解脱道断烦恼者。此文所说云何通。如说或结是见苦断。彼非智断。或结是苦智断。彼结非见苦断。答曰。应作是说无碍道断烦恼非解脱道断。广说如使揵度

诸结法智断法智灭作证耶。问曰。何故作此论。答曰。或有说。无碍道断结得解脱道证解脱得。此是外国法师所说。为止如是说者意。亦明无碍道断结得证解脱得。若当无碍道断结得解脱道证解脱得者。则违此文。如说诸结法智断比智灭作证耶。亦应作如是答。若以灭道法智断非想非非想处结。比智灭作证而不作是答者。当知无碍道断结得。亦得证解脱得

诸结法智断。彼结法智灭作证邪。答曰。诸结法智断。彼结法智灭作证。随断尔所结。即证尔所灭。颇结法智灭作证。彼结非法智断耶。答曰。有诸结忍断亦余智断。须陀洹以世俗道。趣斯陀含果。断一种结乃至五种。若第六无碍道是法智者。是时证三界见道结忍所断者。及欲界修道等智所断五种结。斯陀含趣阿那含果。以世俗道。断二种结。若第九无碍道是法智者。是时证三界见道结忍所断者。及欲界修道等智所断八种结。离初禅欲。乃至离无所有处欲。若以比智等智。离非想非非想处欲。以比智断八种结。第九无碍道。是法智者。是时证三界见道忍所断结。及欲界修道等智所断结。七地中比智等智所断结。非想非非想处比智所断八种结。如是等结。是法智灭作证。诸结比智断。彼结比智灭作证耶。答曰。诸结比智断。比智灭作证。随断尔所结。有尔所灭作证。颇结比智灭作证。彼结非比智断耶。答曰。有诸结忍断亦余智断。比智灭作证。若以法智。若以等智。离欲界欲。乃至离无所有处欲。若以法智。断非想非非想处一种结乃至八种。若第九无碍是比智者。是时证三界见道忍所断结。及八地法智等智所断结。法智所断非想非非想处八种结。诸结苦智断。彼结苦智灭作证耶。答曰。诸结苦智断。彼结苦智灭作证。随断尔所结。有尔所灭作证。颇结苦智灭作证。彼结非苦智断耶。答曰。有诸结忍灭。亦余智灭。苦智灭作证。须陀洹趣斯陀含果。以集灭道智等智。断一种结乃至五种。若第六无碍道是苦智者。是时证三界见道忍所断结。及欲界修道集灭道智等智所断五种结。斯陀含趣阿那含果时。以集灭道智等智。断二种结。若第九无碍是苦智者。是时证三界见道忍所断结。欲界修道集灭道智等智所断结。以集灭道智等智。离初禅欲。乃至离无所有处欲。以集灭道智。断非想非非想处一种结乃至八种。若第九无碍道是苦智者。是时证三界见道忍所断结。八地修道集灭道智等智所断结。非想非非想处修道集灭道智所断八种结。如苦智。乃至道智。说亦如是

问曰。前门所说。此门所说。有何差别。答曰。若作是说。无碍道断结得。解脱道得作证者。前门是无碍道所作。此门是解脱道所作。若作是说。无碍道断结得亦证解脱得。解脱道唯证解脱得者。前门是无碍道断结得证解脱得此门说解脱道证解脱得。如断结得。证解脱得离过患习功德去无利得有利舍卑贱。得胜妙离染爱得寂静乐亦如是。复次断是前门得无为是此门。复次断结及作证是前门。先断结后作证是此门。前门此门。是谓差别。眼根几智知。乃至无色界修道所断无明使几智知。问曰。何故作此论。答曰。或有说。无境界唯有智。或说无智唯有境界。为止如是说者意故。而作此论

诸法若问摄应思界而答。若问识应思入而答。若问使应思种而答。若问智应思谛而答。如是诸法易可显现。此中问智。应思谛而答。法有五种。谓苦集灭道谛所摄。非谛所摄。欲界苦集谛摄。相应不相应法。色无色界苦集谛亦尔。灭谛唯摄不相应法。道谛摄相应不相应法。非谛所摄法。摄不相应法。欲界苦集谛所摄相应法。七智知。除比智灭智道智。不相应法六智知。除比智灭智道智他心智。色界苦集谛所摄相应法。七智知。除法智灭智道智。不相应法六智知。除法智灭智道智他心智。无色界苦集谛所摄相应不相应法。六智知。除法智灭智道智他心智。灭谛所摄法。六智知。除他心智苦智集智道智。道谛所摄相应法。七智知。除苦智集智灭智。不相应法。六智知。除苦智集智灭智他心智。非谛所摄法。一智知。谓等智。问曰。何故名智。答曰。智所知故名智。何故名所知。答曰。为智所知故名所知。如称所称量所量亦如是。量是智所量。是所知。此是略毗婆沙。余门广说如经本。如说修行广布无常想。断欲爱色无色爱掉慢无明。问曰。何故作此论。答曰。此是佛经。佛经说修行广布无常想。乃至广说。佛经虽作是说。而不广分别。佛经是此论所为根本。今欲广分别故。而作此论。问曰。若佛经是此论所为根本者。世尊何故说此经耶。答曰。欲令懈慢不勤精进受化者勤精进故。复次为贪后有弟子。令不更求后有故。世尊说。弥勒佛出世时。有诸比丘。作是愿。使我见。弥勒佛出乃般涅槃。佛作是说。汝等今者有资产所须适意故。作如是念。后若为诸有苦之所逼切者。于诸有中不生愿乐。修行广布无常想。能断欲爱者。此想当言与法智苦智相应。当言有觉有观。所以者何。在有觉有观地故。当言与舍根相应。彼地有舍根故。当言与无愿相应。谓苦无愿。当言缘欲界系缘欲界五阴故。断一切色爱者。彼想当言与比智苦智相应。或有觉有观。在未至初禅者。或无觉有观。在中间禅者。或无觉无观。在三禅者。或乐根相应。在第三禅者。或喜根相应。在初禅第二禅者。或舍根相应。在未至中间第四禅者。无愿相应。谓苦无愿。当言缘色界系。缘色界五阴故。断一切无色爱者。此想当言与比智苦智相应。当言或有觉有观。在未至初禅者。或无觉有观。在禅中间者。或无觉无观。在三禅三无色定者。或乐根相应。在第三禅者。或喜根相应。在初禅二禅者。或舍根相应。在未至中间第四禅三无色定者。与无愿相应。谓苦无愿。当言缘无色界系。缘无色界四阴故。断一切掉慢无明者。此想当言或法智相应苦智相应比智相应。余广说如上

问曰。八圣道尽能断结。何故独称无漏想。答曰。世尊此中圣道以想名说。世尊或说道名想。广说如四无量处

问曰。无常想是七使对治。此中何故作三说耶。答曰。若使在三界是五种断。见疑虽在三界非五种断。恚使虽五种断。不在三界。复次此使在三界。亦是见道修道断。见疑虽在三界。非修道断。恚虽是见道修道断。不在三界。复次此使在三界。是凡夫圣人所行。见疑虽在三界。非圣人所行。恚使虽是凡夫圣人所行。非在三界

问曰。何故三说爱使。一说余使。答曰。余使应说如爱使。而不说者。当知此说有余。复次欲以种种说庄严于文。若以种种说庄严于文义则易解。复次欲现二门故。乃至广说。复次此爱是重恶多众过患欲重观其过患故。广说如上四谛处

问曰。无常想是见苦所断使对治。何故说断一切欲爱使耶。乃至广说。答曰。一切有二种。有少分一切。有一切一切。此中说少分一切。复次此中说圣人以无常想。断三界修道所断一切烦恼

余经复说。修行广布无常想。能断我慢。问曰。无常想是七慢对治。何故但说断我慢耶。答曰。无常想是我慢近对治。如说。无常想能生无我想。若比丘有无常想。无我想者。能断我慢。速于此法。得尽诸漏

如说比丘于七处。善观三种义。速于此法。得尽有漏。问曰。何故作此论。答曰。此是佛经。佛经说。比丘于七处善。乃至广说。佛经是此论所为根本。今欲广分别故。而作此论。问曰。若佛经是此论所为根本者。世尊何故说是经耶。答曰。学人于上沙门果。不作方便。设作方便。而不解知。佛作是说。如汝等入见道方便。不放舍者。不久亦当得尽诸漏。复次已得道者。患于修道所断烦恼。欲说修道对治。令失道者。还得道故。如人猛健患于怨家。他人语言。汝今猛健。何不降伏怨家。彼亦如是。如实知色是苦四智。谓法智比智等智苦智。法智知欲界色。比智知色界色。等智知一切色。苦智知有漏色无常苦空无我。问曰。此则是四善处耶。答曰。此皆观一谛。观苦观果。如实知色。是集四智。谓法智比智等智集智。法智知欲界集。比智知色界集。等智知一切集。集智知有漏色因集有缘。问曰。此则是四善处耶。答曰。此皆观一谛。观集观因。如实知色灭是四智。谓法智比智等智灭智。法智知欲界色灭。比智知色界色灭。等智知一切色灭。灭智知一切有漏色灭止妙离。问曰。此则是四善处耶。答曰。此皆观一谛。观灭观毕竟。如实知色灭道是四智。谓法智比智等智道智。法智知欲界色灭道。比智知色界色灭道。等智知一切色灭道。道智知一切有漏色灭道正迹乘。问曰。此则是四善处耶。答曰。此皆观一谛。观道观对治。如实知色味。此是四智。谓法智比智等智集智。问曰。此则是四善处耶。答曰。此则观一谛。观集观味。如实知色患。此是四智。谓法智比智等智苦智。问曰。此则是四善处耶。答曰。此则观一谛。观苦观患。如实知色离。此是四智。谓法智比智灭智等智。问曰。此则是四善处耶。答曰。此则观一谛。观灭观离。如色阴有七善处。乃至识阴亦有七善处。问曰。若然者则有三十五善处。亦有无量善处。答曰。此是七处法。如色阴有七。乃至识阴亦有七。不过于七。如经说。须陀洹受七有。此是七处法。不过于七。广说如四谛处。尊者波奢说曰。如实知色是苦。乃至如实知识是苦。如实知色是集。知色是灭。知色是灭道。知色是味。知色是患。知色是离。乃至知识亦如是。若如是说。则有七善处。复次若略说。则有七善处。若广说则有三十五善处无量善处。如广略。分别不分别亦如是。复次若为利根者说。则有七善处。若为钝根者说。则有三十五善处无量善处。如利根钝根。因力缘力内支力外支力内思惟力外闻法力闻即能解力广分别力。当知亦如是。复次如在见道时。则有七。如观察时。则有三十五无量善处。复次如贤。圣所行时则有七。如世俗所行。则有三十五无量善处。复次若作总相观。则有七善处。若作别相观。则有三十五无量善处。问曰。此中为说别相观。为说总相观耶。若说别相观者。此文所说云何通。如说。速于此法。得尽有漏。若是总相观者。此文所说复云何通。如说如实知色。乃至如实知识。答曰。应作是说。是别相观

问曰。若然者。如说。速于此法得尽有漏。云何通。答曰。此中说别相观。能生总相观。总相观得尽有漏。复有说者。此中观总相观。问曰。若然者此文所说云何通。如说。如实知色乃至如实知识。答曰。此文应如是说。如实知阴。是苦集灭道味患离。而不说者。有何意耶。答曰。不必说与见道时同。或有说。与见道时同。或说。与见道时异。如世尊为四天王。以圣语说四谛。二解二不解。世尊复以陀毗罗语说四谛。一解一不解。世尊复以弥离车语说四谛。然后乃解。如是观解时以别相。入道时是总相。问曰。七处善观三种义。有何差别。答曰。七处善是无漏。观三种义是有漏。问曰。若然者。此所说云何通。如说。如实知色是四智。谓法智比智等智。答曰。此中数智行于境界。不必尽是无漏。问曰。能以七处善。同观三种义。能以观三种义。同七处善不。答曰。或有说者。不能所以者何。七处善是无漏。观三种义是有漏。复有说者。七处善是有漏无漏。观三种义是有漏。问曰。若然者。能以七处善同观三种义。以观三种义同七处善不。答曰。能但多用功。多有所作。如实知色。乃至知识。如实知色患。乃至知识患。是说观阴。如实知色是集。乃至知识是集。如实知色是味。乃至知识是味。是说观入。如实知色是灭。乃至知识是灭。如实知色是离。乃至知识是离。是说观界。可说如是同相。但多用功。多有所作

问曰。观三种义在前。七处善在后。何故世尊先说七处善。后说观三种义耶。答曰。若作是说。则所说随顺义则易解。受者亦易。复次世尊所说。文义具足。若先说观三种义。义虽具足。文不具足。世尊说法。文义具足。复次若应先说七善处。则说七善处。若应后说观三种义。则说观三种义。所以者何。观三种义。或在见道初。或在修道初。此中说在修道初者。不说在见道初者。如见道修道。见地修地未知欲知根知根亦如是。复次观三种义。或在六地圣道初。或在九地圣道初。此中说九地初者。不说六地初者。尊者波奢说曰。此中说四种地。谓修行地见地修地无学地。如说。比丘七处善。观三种义。是说修行地。如实知色。是说苦集灭道。乃至知识。是苦集灭道。是说见地。观色乃至识是味患离。是说修地。速于此法得尽有漏。是说无学地。问曰。若然者。何故见道中。说四善处。修道中说三善处耶。答曰。见道中未曾见谛而见。修道中已曾见谛而见。复次见道中未曾得见圣性而得。观行于谛。修道中已曾得圣性。观行于谛

问曰。此中何故重说三谛。一说道谛。答曰。此中广说道谛。如说。如实知色是苦。此是道谛。如实知色是集灭道是味患离。乃至知识亦如是。是道谛。复次此所说。为已见谛人。佛作是说。汝等若能如实观察阴者。不久当得尽漏。复次三谛是有边法。如说。五取阴边。五取阴集边。五取阴灭边。问曰。若然者因论生论。何故三谛说有边。道谛不说有边耶。答曰。此中边义。广如说见道边等智处。复次有已生苦。有未生苦。有已生苦因。有未生苦因。有已生苦灭。有未生苦灭。诸已生苦未生苦。已生苦因。未生苦因。已生苦灭。未生苦灭。谁能知断证耶。谓是道谛

问曰。世尊何故广分别智所知耶。答曰。欲令失道者。还知道故。作如是说。复次此所说为爱行人。佛作是说。汝等应观此阴味及过患。若见此阴味及过患者。不久当得尽漏

问曰。何故见道中。先观苦后观集。修道中。先观集后观苦耶。答曰。随顺有二种。一见道随顺。二所说随顺。如见道随顺。先观苦后观集。如所说随顺。先观集后观苦。见道次第所说次第亦如是

问曰。色集色味。有何差别。答曰。名即差别。是名色集。是名色味。复次色集是意地。色味通六识身。复次集是染污不染污。味是染污。复次集在三界。味在欲界。问曰。阴为有多种集。为有一种集。若有多种集者。施设经说云何通。如说。此爱是过去未来现在苦因苦本苦缘。若一种者此经云何通。如说。喜爱集是色集。触集是三阴集。名色集是识集。答曰。应作是说。有所以是多种集。有所以是一种集。为说近因故。是多种集。为说远因故。是一种集。如近因远因。此身他身亦如是。复次此中说三种集。一烦恼集。二苦集。三业集。喜爱集色集。是说烦恼集。触集三阴集。是说苦集。名色集识集。是说业集。此中说名色是业。如烦恼集苦集业集烦恼有苦有业有烦恼道苦道业道烦恼苦业。当知亦如是。复次此中说三时。谓积聚时。受用时。守护时。喜爱集色集。是说积聚时。触集三阴集。是说受用时。名色集识集。是说守护时。复次此中说三时有。谓前时有。中有。生有。喜爱集色集。是说前时有。触集三阴集。是说中有。名色集识集。是说生有。复次喜爱集色集。是说名缘色。触集三阴集。是说名缘名。名色集识集。是说名色缘名。复次爱求未来有。是故佛作是说。喜爱集是色集。心心数法。因触而活。从触生。以触力故。能现在前。佛作是说。触集是三阴集。识因名色立。而得增广。是故佛作是说。名色集是识集。问曰。色灭色离有何差别。答曰。若爱造此色。彼爱若灭。是名色灭。若缘此色。生诸余爱。彼爱若离。是名色离。乃至广说。问曰。何故问色灭。答爱灭耶。答曰。因若断。果亦断。因若灭。果亦灭。舍因亦舍果。若吐因亦吐果。若害因亦害果故。问曰。何故已生爱说灭。未生爱说离耶。答曰。已生爱不可作未生爱。佛作是说。但当灭之。未生爱应令不生。但当离如是有三种衰患。一已受。二今受。三当受。已受者受竟。今受者忍受。当受者或以自力。或眷属力。或财物力。方便求离。彼亦如是。余答广说如杂揵度。如色灭色离。乃至识灭识离说亦如是。问曰。此中何故三说爱不说余烦恼业耶。答曰。以爱是重过患难断难除故。广说如上。如此中及施设经多分别灭谛。问曰。何故此中及施设经。多分别灭谛耶。答曰。以此灭于有为无为法中最胜故

阿毗昙毗婆沙论卷第五十六阿毗昙毗婆沙论卷第五十七

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    智揵度相应品第四之一

七人。坚信。坚法。信解脱。见到。身证。慧解脱。俱解脱人。八智。三三昧。三根。七觉支。八道支。坚信人。于此八智。几成就几不成就。乃至俱解脱人。几成就几不成就。如此章及解章义。此中广说优波提舍。问曰。何故此中及定揵度。依七人而作论。使揵度中。依五人而作论。广说如使揵度不善品中

坚信人。于此八智。几成就几不成就。问曰。何故作此论。答曰。欲止言无成就者意。亦明实有成就故。而作此论。复次欲以七人作章。八智三三昧等立门故。而作此论

坚信人。于此八智。几成就几不成就。答曰。或一二三四五六七八。苦法忍。无知他心智一。有他心智二。苦法智。无他心智三。有他心智四。此中增见增慧增通增智增名。苦比忍无他心智三有他心智四。苦比智无他心智五有他心智六。乃至道比忍无他心智七有他心智八。如坚信。坚法亦如是。所以者何。此二人地等所依身等道等离欲等定等。唯根有差别。坚信是钝根。坚法是利根。信解脱人。于此八智。几成就。几不成就。答曰。无他心智七。有他心智八。如信解脱见到亦如是。所以者何。此二人。地等广说如上。身证人。于此八智。尽成就。如身证人。慧解脱俱解脱人亦如是。坚信人。于此八智。几过去成就。几未来成就。几现在成就。问曰。何故作此论。答曰。为止言无过去未来者意。亦明过去未来是实有法故。而作此论。复次先总明智成就不成就。今欲分别世中成就不成就故而作此论

坚信人。于此八智。几过去成就。几未来成就。几现在成就。答曰。苦法忍。无他心智一过去未来成就。有他心智。二过去未来成就。无有现在。现在是忍故。苦法智。无他心智。一过去成就。谓等智。三未来成就。谓法智等智苦智。二现在成就。谓法智苦智。有他心智。二过去成就。四未来成就。增他心智。二现在成就。如先说。苦比忍。无他心智。三过去未来成就。有他心智。四增他心智。现在无是忍故。苦比智无他心智。三过去成就。四未来成就。增比智二现在成就。谓苦智比智。有他心智。四过去成就。五未来成就。二现在成就。如先说。乃至道比忍现在前。无他心智七。过去未来成就。除他心智。有他心智八。增他心智。现在无是忍故。如坚信。坚法亦如是。所以者何。此二人地等。广说如上。信解脱人。于此八智。几过去成就。几未来成就。几现在成就。广说如经本。坚信人。法智现在前时。几智现在前。答曰。二。法智苦智二。法智集智二。法智灭智二。法智道智二。体性是一以事故异。对治欲界故是法智。以行故是苦集灭道智。比智现在前时。几智现在前。答曰。二。比智苦智二。比智集智二。比智灭智二。体性是一。以事故异。对治色无色界故是比智。以行故是苦集灭智。苦智现在前时。几智现在前。答曰。二。苦智法智二。苦智比智二。体性是一。以事故异。以行故是苦智。以对治故是法智。比智集智灭智说亦如是。道智现在前时。几智现在前。答曰。二。道智法智二。体性是一。以事故异。以行故是道智。以对治故是法智。如坚信坚法亦如是。信解脱人。法智现在前时。几智现在前。答曰。或二或三。法智苦智二。法智集智二。法智灭智二。法智道智。无他心智二。有他心智三。体性是一。以事故异。对治故是法智。以行故是苦集灭道智。以方便故是他心智。如法智。比智亦如是。他心智现在前时。几智现在前。答曰。或二或三。他心智等智二。他心智道智三。体性是一。以事故异。方便故是他心智。对治故是法智比智。以自体故是等智。以行故是道智。等智现在前时。几智现在前。答曰。或一或二。无他心智一。有他心智二。体性是一。以事故异。以自体故是等智。以方便故是他心智。苦智集灭智。如先说。道智现在前时。几智现在前。答曰。或二或三。道智无他心智二。有他心智三。体性是一。以事故异。以行故是道智。以对治故是法智比智。以方便故是他心智。如信解脱。见到身证亦如是。慧解脱人。法智现在前时。几智现在前。答曰。或二或三。法智苦智非尽智无生智二若是尽智无生智三。体性是一。以事故异。对治故是法智。以行故是苦智。以所作竟故是尽智。以从因生故是无生智。集智灭智说亦如是。法智道智非尽智无生智他心智二。若是尽智无生智他心智三。体性是一。以事故异。以对治故是法智。以行故是道智。以所作竟故是尽智。从因生故是无生智。以方便故是他心智。比智亦如是。他心智等智如先说。苦智现在前时。几智现在前。答曰。或二或三。苦智法智非尽智无生智二若是尽智无生智三。苦智比智非尽智无生智二。若是尽智无生智三。体性是一。以事故异。以行故是苦智。以对治故是法智。以所作竟故是尽智。从因生故是无生智。如苦智。集灭智亦如是。道智现在前时。几智现在前。答曰。或二或三。道智法智非尽智无生智他心智二。若是尽智无生智他心智三。道智比智非尽智无生智他心智二。若是尽智无生智他心智三。体性是一。以事故异。广说如上。如慧解脱。俱解脱亦如是。问曰。何故不说尽智无生智摄他心智耶。答曰。他心智。以对治故。是法智比智。以方便故是他心智。他心智但缘他心。尽智无生智。缘自身他身及非身法。复次他心智缘现在。彼二智缘三世及无为。复次他心智缘心心数法。彼二智缘四阴五阴及无为法。复次他心智是见。彼二智非见。坚信人。于此三三昧。几成就。几不成就。答曰。灭法忍未生成就二。谓空无愿。灭法忍生成就三。增无相。如坚信人。坚法人亦如是。信解脱人尽成就。如信解脱。见到身证慧解脱俱解脱亦如是。坚信人。于此三三昧。几过去成就。几未来成就。几现在成就。答曰。若依空三昧得正决定者。苦法忍无过去。二未来成就。谓空无愿。一现在成就。谓空。余广说如经本。依无愿三昧得正决定。说亦如是。问曰。何等人依空三昧得正决定。何等人依无愿耶。答曰。或有见行者。或有爱行者。若见行者。依空三昧。得正决定。若爱行者。依无愿。唯除菩萨。是爱行人。依空三昧。得正决定。见行者有二种。一着我见。二着我所见。爱行者。亦有二种。一行我慢。二多懒堕。着我见者。行无我行。着我所见者。行空行。行我慢者。行无常行。多懒堕者。行苦行。复次若利根者。依空三昧。得正决定。若钝根者。依无愿。如利钝。乃至闻即能解。广分别亦如是。若依无愿得正决定者。或依无愿无相。离三界欲。此身中不离起空三昧现在前。坚信人。空三昧现在前时。几智现在前。答曰。或二或无。苦智法智二。苦智比智二。忍中无。余广说如经本。乃至如慧解脱。俱解脱亦如是。问曰。何故尽智无生智。不与空三昧相应耶。答曰。所行异故。若行是空三昧。所行非尽智无生智。若行是尽智无生智。所行非空三昧。复次空三昧与见相应。彼二智性非见。复次空三昧体。是第一义。所行亦是第一义。彼二智体。虽是第一义。而所行是世谛

坚信人。未知欲知根现在前时。几智现在前。答曰。或二或无。苦智法智二。苦智比智二。乃至道智法智二。忍中无。如未知欲知根。七觉八道支亦如是。如坚信坚法亦如是。余广说如经本。若如此所说。则明慧解脱阿罗汉。能起根本禅现在前。问曰。若慧解脱阿罗汉。能起根本禅现在前者。佛经云何通。如说。苏尸摩问诸比丘。云何起诸禅现在前。诸比丘答苏尸摩。当知我等是慧解脱人。答曰。慧解脱有二种。一是少分。二是满分。少分慧解脱者。能起一禅二禅三禅现在前。满分者。乃至不能起一禅现在前。此中说少分慧解脱。经中说满分慧解脱。是故二俱善通

若法与法智相应。亦与比智相应耶。诸法以三事故共合。或以摄故合。或以相应故合。或以摄以相应故合。以摄合者。如智于智。以相应合者。如智于定。以摄以相应合者。如智于根觉支道支。若法与法智相应。亦与比智相应耶。答曰。若法与法智相应不与比智相应。所以者何。非一心故。若有法智。则无比智。而与他心智相应耶。答曰。或法与法智相应。不与他心智相应。乃至广作四句。与法智相应不与他心智相应者。他心智所不摄法智相应法。彼是何耶。答曰。苦集灭法智他心智所不摄道法智相应法。与他心智相应非法智者。法智所不摄他心智相应法。彼是何耶。答曰。比智他心智世俗他心智。与法智相应亦与他心智相应者。法智所摄他心智相应法。彼是何耶。答曰。法智他心智相应法。谓九大地。十善大地。及以心觉观随地。不与法智相应亦不与他心智相应者。法智他心智。所以者何。自体不应自体。广说如上。及法智他心智所不摄不相应法。不摄者除自体。不相应者除相应。彼是何耶。答曰。苦集灭比智相应聚。他心智所不摄道比智相应聚。诸忍相应。他心智不相应。诸余有漏心心数法。色无为。心不相应行。无缘故不与相应。如他心智。苦集灭道智正见亦如是

若法与法智相应。不与等智相应。所以者何。法智相应聚异。等智相应聚异。与空三昧相应耶。法智与三三昧相应。空三昧与二智相应。谓苦法智苦比智。亦与二忍相应。谓苦法忍苦比忍。是故得作大四句。与法智相应非空三昧者。空三昧应于法智。法智俱聚中。空三昧体。与法智相应。不与空三昧相应。所以者何。自体不应自体。如先说。及空三昧不相应法智相应法。彼是何耶。答曰。无愿无相相应聚。与法智相应者。与空三昧相应非法智者。法智应于空三昧。空三昧俱聚中法智体。与空三昧相应非法智。所以者何。自体不应自体。如先说。及法智不相应空三昧相应法。彼是何耶。答曰。苦比智俱聚中苦忍俱聚空三昧相应法。与法智相应亦与空三昧相应者。除空三昧应于法智。除法智应于空三昧。法智空三昧俱聚中名除自体。余心数法。彼是何耶。答曰。谓八大地。十善大地。及心觉观随地。不与法智相应亦不与空三昧相应者。空三昧不与法智相应者。与苦比智苦忍相应者。空三昧自体。不与法智相应。以是他聚故。亦不与空三昧相应。自体不应自体。如先说。法智不与空三昧相应者。与无愿无相三昧相应者。法智自体。不与空三昧相应。以是他聚故。不与法智相应。自体不应自体。如先说。诸余法智空三昧不相应法。彼是何耶。答曰。法智不相应无愿无相俱聚是也。及有漏心心数法。色无为。心不相应行。如是等法。作第四句。如法智于空三昧。法智于无愿三昧无相三昧喜觉支正觉亦如是

若法与法智相应。亦与未知欲知根相应耶。乃至广作四句。与法智相应不与未知欲知根相应者。未知欲知根所不摄法智相应法。彼是何耶。答曰。知根知已根所摄法智相应法。不与未知欲知根相应。所以者何。以是他聚故。与未知欲知根相应非法智者。未知欲知根所摄法智。未知欲知根俱聚中法智体。与未知欲知根相应非法智。自体不应自体。如先说。及法智不摄不相应未知欲知根相应法。彼是何耶。比智俱聚忍俱聚中。未知欲知根相应法。是名与未知欲知根相应非法智相应。所以者何。是他聚故。与法智相应亦与未知欲知根相应者。未知欲知根所摄法智相应法彼是何耶。答曰。八根及彼相应非根心数法。不与法智相应亦不与未知欲知根相应者。未知欲知根所不摄法智。知根知已根俱聚中法智体。不与法智相应。自体不应自体。广说如上。不与未知欲知根相应。所以者何。以他聚故。及法智未知欲知根所。不摄不相应心心数法。彼是何耶。答曰。法智不摄不相应知根知已根俱聚。及有漏心心数法。色无为心不相应行。如是等法。作第四句。如法智于未知欲知根。法智于知根知已根亦如是

若法与法智相应。亦与念觉支相应耶。乃至广作四句。与法智相应不与念觉支相应者。念觉支应于法智。法智俱聚中念觉支体。与法智相应。不与念觉支相应。所以者何。自体不应自体。如先说。与念觉支相应。不与法智相应者。法智应于念觉支。念觉支俱聚中法智体。与念觉支相应。不与法智相应。所以者何。自体不应自体。如先说。及法智不相应念觉支相应法。彼是何耶。答曰。忍俱聚中。比智俱聚中。念觉支相应法。与法智相应。亦与念觉支相应者。除念觉支应于法智。以多故除。余念觉支法智觉支聚中。各除自体。余心心数法。与二相应。彼是何耶。答曰。谓八大地十善大地。及心觉观随地。不与法智相应。亦不与念觉支相应者。法智不相应念觉支。彼是何耶。答曰。忍俱聚中。比智俱聚中。念觉支体。不与法智相应。是他聚故。自体不应自体。如先说。一切无漏心。更无余。有余有漏心心数法色无为心不相应行。作第四句。如法智于念觉支。法智于精进觉枝猗觉枝定觉枝舍觉支正方便正念正定亦如是

若法与法智相应。亦与择法觉支相应耶。答曰。若法与法智相应亦与择法。觉枝相应。颇与择法觉支相应非法智耶。答曰有。法智所不摄择法觉支相应法。彼是何耶。答曰。忍俱聚中。比智俱聚中。择法觉支相应。如法智。比智说亦如是

阿毗昙毗婆沙论卷第五十七阿毗昙毗婆沙论卷第五十八

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    智揵度相应品第四之二

若法与他心智相应。亦与等智相应耶。乃至广作四句。与他心智相应不与等智相应者。等智所不摄他心智相应法。彼是何耶。答曰。无漏他心智相应法。与等智相应。不与他心智者。他心智所不摄等智相应法。彼是何耶。答曰。他心智所不摄。若染污不隐没无记等智相应法。与他心智相应。亦与等智者。他心智所摄等智相应法。彼是何耶。答曰。九大地。十善大地。及心觉观随地。不与他心智相应亦不与等智者。是等智他心智。所以者何。自体不应自体。如先说。及他心智等智所不摄不相应法。彼是何耶。答曰。苦智苦忍俱聚。集智集忍俱聚。灭智灭忍俱聚。道忍俱聚。及他心智所不摄道智相应法。已说一切有漏心无余余有色无为心不相应行。作第四句。如上他心智于等智。他心智于道智择法觉支正见亦如是

若法与他心智相应。不与苦集灭智。不与空无相相应。与无愿相应耶。答曰。或与他心智相应。不与无愿相应。乃至广作四句。与他心智相应不与无愿者。无愿应于他心智。他心智俱聚中无愿体。与他心智相应。不与无愿。所以者何。自体不应自体。如先说。及无愿不相应他心智相应法。彼是何耶。答曰。有漏他心智相应法。与无愿相应非他心智者。他心智相应于无愿。无愿俱聚中他心智体。与无愿相应。不与他心智。所以者何。自体不应自体。如先说。及他心智不相应无愿相应法。彼是何耶。答曰。苦集无愿不与他心智相应。道无愿相应法。不与他心智相应。以是他聚故与他心智相应亦与无愿者。除无愿应于他心智。除他心智应于无愿。他心智无愿俱聚中。各除自体。诸余心心数法。与他心智无愿相应。彼是何耶。答曰。八大地。十善大地。及心觉观随地。不与他心智相应。亦不与无愿者。他心智不相应无愿。彼是何耶。答曰。苦忍苦智。集忍集智。道忍及他心智不摄道智。俱聚中无愿体。不与他心智相应。以他聚故。不与无愿相应。自体不应自体。如先说。无愿不相应他心智。彼是何耶。有漏他心智俱聚中他心智体。不与无愿相应。以他聚故。不与他心智相应。自体不应自体。如先说。及余心心数法。彼是何耶。答曰。空无相俱聚。不与他心智相应。余有漏心心数法。色无为心不相应行。如是等法。作第四句。如他心智于无愿。他心智于六觉支四道支亦如是

若法与他心智相应。不与未知欲知根相应。亦与知根相应耶。乃至广作四句。与他心智。相应不与知根相应者。知根所不摄他心智相应法。彼是何耶。答曰。知已根俱聚中。及有漏他心智俱聚中。与他心智相应法。与知根相应不与他心智者。知根所摄他心智。及他心智不摄不相应知根相应法。彼是何耶。答曰。苦集灭智俱聚。及他心智所不摄道智俱聚。与知根相应法。与他心智相应亦与知根相应者。知根所摄他心智相应法。彼是何耶。答曰。八根及彼相应非根心心数法。不与他心智相应。亦不与知根者。知根所不摄他心智。彼是何耶。答曰。知已根俱聚有漏中他心智体。不与知根相应。以他聚故。不与他心智相应。自体不应自体。如先说。及他心智知根所不摄不相应。诸余心心数法。彼是何耶。答曰。未知欲知根俱聚他心智不摄不相应。知已根俱聚他心智不摄不相应。有漏心心数法色无为心不相应行。如是等法。作第四句。如他心智于知根。他心智于知已根亦如是知。若法与等智相应。不与苦集灭道智三三昧觉支道支相应。若与苦智相应。不与集灭道智无相相应。亦与空三昧相应耶。乃至广作四句。与苦智相应不与空三昧者。空三昧应于苦智。苦智俱聚中空三昧体。与苦智相应。不与空三昧相应。所以者何。自体不应自体。如先说。及余空三昧不相应苦智相应法。彼是何耶。答曰。无愿俱聚中苦智相应法。与空三昧相应。不与苦智者。苦智应于空三昧。空三昧俱聚中苦智体。与空三昧相应。不与苦智相应。所以者何。自体不应自体。如先说。及余苦智不相应空三昧相应法。彼是何耶。忍俱聚中。与空三昧相应法。与苦智相应。亦与空三昧者。除苦智应于空三昧。俱聚中各除自体。诸余苦智空三昧相应心心数法。彼是何耶。答曰。八大地。十善大地。及心觉观随地。不与苦智相应亦不与空三昧者。苦智不相应空三昧。彼是何耶。苦忍俱聚中空三昧体。不与苦智相应。以他聚故。不与空三昧相应。自体不应自体如先说。空三昧不相应苦智。彼是何耶。答曰。无愿俱聚中苦智体。不与空三昧相应。是他聚故。不与苦智相应。自体不应自体。如先说。及余心心数法。彼是何耶。苦智不相应无愿俱聚无相俱聚有漏心心数法色无为心不相应行。如是等法。作第四句。如苦智于空三昧。苦智于无愿三昧亦如是。余广说如法智

若法与集智相应。不与灭智道智空三昧无相三昧。亦与无愿相应耶。乃至广作四句。与集智相应不与无愿三昧者。无愿应于集智。集智俱聚中无愿三昧体。与集智相应。不与无愿相应所以者何。自体不应自体如先说。与无愿三昧相应。不与集智者。集智应于无愿无愿俱聚中集智体。与无愿相应。不与集智相应。所以者何。以三事故。自体不应自体如先说。及集智不相应无愿相应法。彼是何耶。答曰。苦忍智俱聚中。集忍道忍道智俱聚中。无愿相应法。与集智相应。亦与无愿者。除集智相应无愿。以多故除。诸余集智无愿相应法。彼是何耶。答曰。八大地。十善大地。及心觉观随地。不与集智相应。亦不与无愿三昧者。集智不相应无愿。彼是何耶。苦忍苦智集忍道忍道智俱聚中无愿体。不与集智相应。以他聚故。不与无愿相应。所以者何。自体不应自体如先说。及余心心数法。余者是空三昧无相三昧俱聚一切有漏心心数法色无为心不相应行。如是等法。作第四句。余广说如法智

若法与灭智相应。不与道智空三昧无愿三昧相应。亦与无相三昧相应耶。乃至广作四句。与灭智相应不与无相三昧相应者。无相三昧应于灭智。灭智俱聚中无相三昧体。与灭智相应。不与无相三昧相应。所以者何。以三事故。自体不应自体如先说。与无相三昧相应不与灭智者。灭智应于无相三昧。无相三昧俱聚中灭智体。与无相三昧相应。不与灭智相应。所以者何。自体不应自体如先说。及灭智不相应无相三昧相应法。彼是何耶。灭忍俱聚中无相三昧相应法。与灭智相应亦与无相三昧者。除无相三昧应于灭智。以多故除。诸余灭智无相三昧相应法。彼是何耶。答曰。八大地。十善大地。及心觉观随地。不与灭智相应亦不与无相三昧者。灭智不相应无相三昧。彼是何耶。灭忍俱聚中无相三昧体。不与灭智相应。以他聚故。不与无相三昧相应。所以者何。自体不应自体如先说。诸余灭智无相三昧不相应心心数法。无漏法中。余有空三昧无愿三昧俱聚一切有漏心心数法色无为心不相应行。如是等法。作第四句。余广说如法智

若法与道智相应。不与空三昧无相三昧相应。亦与无愿三昧相应耶。乃至广作四句。与道智相应。不与无愿三昧者。无愿三昧应于道智。道智俱聚中无愿三昧体。与道智相应。不与无愿三昧。所以者何。自体不应。自体如先说。与无愿三昧相应不与道智者。道智应于无愿。无愿俱聚中道智体。与无愿三昧相应。不与道智。所以者何。自体不应自体如先说。及道智不相应无愿相应法。彼是何耶。答曰。苦忍苦智集忍集智道忍俱聚中。与无愿三昧相应法。与道智相应。及与无愿三昧者。除道智相应无愿。以多故除。诸余道智无愿三昧相应法。彼是何耶。答曰。八大地。十善大地。及心觉观随地。不与道智相应亦不与无愿三昧者。道智不相应无愿三昧。彼是何耶。答曰。苦忍苦智集忍集智道忍俱聚中无愿三昧体。不与道智相应。以他聚故。亦不与无愿三昧相应。所以者何。自体不应自体如先说。及余道智无愿三昧不相应心心数法。无漏法中余有空无相俱聚一切有漏心心数法色无为心不相应行。如是等法。作第四句。余广说如法智

若法与空三昧相应。不与无相无愿三昧相应。亦与未知欲知根相应耶。乃至广作四句。与空三昧相应不与未知欲知根相应者。未知欲知根所不摄与空三昧相应法。彼是何耶。答曰。知根知已根中与空三昧相应法。不与未知欲知根相应。以他聚故。与未知欲知根相应。不与空三昧者。未知欲知根所摄空三昧未知欲知根俱聚中空三昧体。与未知欲知根相应。不与空三昧相应。所以者何。自体不应自体如先说。及余空三昧所不摄不相应未知欲知根相应法。彼是何耶。答曰。无愿无相三昧俱聚中。与未知欲知根相应法。与空三昧相应。亦与未知欲知根者。未知欲知根所摄与空三昧相应法。彼是何耶。答曰。八根及余非根心数法。不与空三昧相应亦不与未知欲知根相应者。未知欲知根。所不摄空三昧。彼是何耶。知根知已根俱聚中空三昧体。不与未知欲知根相应以他聚故。不与空三昧相应。所以者何。自体不应自体。如先说。及空三昧未知欲知根所不摄不相应诸余心心数法。彼是何耶。答曰。未知欲知根不摄不相应。与无愿无相三昧相应法。色无为心不相应行。如是等法。作第四句。如空三昧于未知欲知根。空三昧于知根知已根亦如是

若法与空三昧相应。亦与念觉支相应耶。乃至广作四句。与空三昧相应不与念觉支者。念觉支应于空三昧。空三昧俱聚中念觉支体。与空三昧相应。不与念觉支相应。所以者何。自体不应自体如先说。与念觉支相应不与空三昧者。空三昧应于念觉支。念觉支俱聚中空三昧体。与念觉支相应。不与空三昧相应。所以者何。自体不应自体如先说。及余空三昧不相应念觉支相应法。彼是何耶。无愿无相三昧俱聚中。念觉支相应法。与空三昧相应亦与念觉支者。除空三昧相应念觉支。以多故除。诸余空三昧念觉支相应心心数法。彼是何耶。答曰。八大地。十善大地。及心觉观随地。不与空三昧相应亦不与念觉支者。空三昧不相应念觉支无愿无相三昧俱聚中念觉支体。不与空三昧相应。以他聚故。不与念觉支相应。所以者何。自体不应自体如先说。诸余心心数法无漏心无余余有漏心心数法色无为心不相应行。如是等法。作第四句。如空三昧于念觉支。空三昧于择法觉支精进觉支猗觉支舍觉支正见正方便正念亦如是

若法与空三昧相应。亦与喜觉支相应耶。乃至广作四句。与空三昧不与喜觉支者。喜觉支应于空三昧。空三昧俱聚中喜觉支体。与空三昧相应。不与喜觉支相应。所以者何。自体不应自体如先说。及喜觉支不相应空三昧相应法。彼是何耶。未至禅中间禅第三第四禅三无色定中。空三昧相应法。与喜觉支相应非空三昧者。空三昧应于喜觉支。喜觉支俱聚中空三昧体。与喜觉支相应。不与空三昧相应。所以者何。自体不应自体如先说。及空三昧不相应喜觉支相应法。彼是何耶。无愿无相三昧俱聚中喜觉支相应法。与空三昧相应亦与喜觉支者。除喜觉支相应空三昧。除空三昧相应喜觉支。余与空三昧喜觉支相应心心数法。彼是何耶。答曰。八大地。十善大地。及心觉观随地。不与空三昧相应亦不与喜觉支者。空三昧不相应喜觉支无愿无相三昧俱聚中喜觉支体。不与空三昧相应。以他聚故。不与喜觉支相应。所以者何。自体不应自体如先说。喜觉支不相应空三昧。彼是何耶。未至中间禅第三第四禅三无色定俱聚中空三昧体。不与空三昧相应。所以者何。自体不应自体如先说。亦不与喜觉支相应。所以者何。彼地中无喜故。诸余心心数法。余者未至中间第三第四禅三无色定中。无愿无相三昧俱聚中一切有漏心心数法色无为心不相应行。如是等法作第四句。如空三昧于喜觉支。空三昧于正觉亦如是。若法与空三昧相应。亦与定觉支相应耶。答曰。若与空三昧相应。亦与定觉支相应。颇与定觉支相应。不与空三昧相应耶。答曰有。空三昧所不摄定觉支相应法。彼是何耶。无愿无相俱聚中定觉支相应法。如空三昧于定觉支。空三昧于正定亦如是。如空三昧无愿无相三昧说亦如是。异者无愿无相三昧于喜觉支于正见正觉亦如是

若法与未知欲知根相应。不与知根知已根相应。亦与念觉支相应耶。乃至广作四句。与未知欲知根相应不与念觉支者。未知欲知根所摄念觉支未知欲知根聚中念觉支体。与未知欲知根相应。不与念觉支相应。所以者何。自体不应自体如先说。与念觉支相应不与未知欲知根者。未知欲知根所不摄念觉支相应法。彼是何耶。答曰。知根知已根俱聚中念觉支相应法。不与未知欲知根相应。以他聚故。与未知欲知根相应亦与念觉支者。未知欲知根所摄念觉支相应法。彼是何耶。答曰。八根及彼相应非根心数法。不与未知欲知根相应亦不与念觉支者。未知欲知根所不摄念觉支。彼是何耶。答曰。知根知已根俱聚中念觉支体。不与未知欲知根相应。以他聚故。不与念觉支相应行。所以者何。自体不应自体如先说。及余心心数法。更无无漏心。余一切有漏心心数法色无为心不相应行。如是等法。作第四句。如未知欲知根于念觉支。未知欲知根于择法觉支精进觉支定觉支正见正方便正念正定亦如是

若法与未知欲知根相应。亦与喜觉支耶。乃至广作四句。与未知欲知根相应不与喜觉支者。未知欲知根所摄喜觉支。未知欲知根俱聚中喜觉支体。与未知欲知根相应。不与喜觉支相应。所以者何。自体不应自体如先说。及喜觉支不摄不相应未知欲知根相应法。彼是何耶。答曰。未至中间第三第四禅中未知欲知根相应法。不与喜觉支相应。所以者何。彼地无喜故。与喜觉支相应不与。未知欲知根者。未知欲知根不摄喜觉支相应法。彼是何耶。答曰。知根知已根中喜觉支相应法。不与未知欲知根相应。以他聚故。与未知欲知根相应亦与喜觉支者。未知欲知根所摄喜觉支相应法。彼是何耶。答曰。八根及彼相应非根心数法不与未知欲知根相应亦不与喜觉支者。未知欲知根不摄不相应喜觉支彼是何耶。答曰。知根知已根俱聚中喜觉支体。不与未知欲知根相应。以他聚故。亦不与喜觉支相应。所以者何。自体不应自体如先说。及余未知欲知根喜觉支不摄不相应心心数法。彼是何耶。答曰。未至中间第三第四禅三无色中知根知已根俱聚中一切有漏心心数法色无为心不相应行。如是等法。作第四句

若法与未知欲知根相应。亦与猗觉支相应耶。乃至广作四句。与未知欲知根相应不与猗觉支者。猗觉支应于未知欲知根。未知欲知根俱聚中猗觉支体。与未知欲知根相应。不与猗觉支相应。所以者何。自体不应自体如先说。与猗觉支相应不与未知欲知根者。未知欲知根不相应猗觉支相应法。彼是何耶。答曰。知根知已根俱聚中猗觉支相应法。不与未知欲知根相应。是他聚故。与未知欲知根相应亦与猗觉支者。猗觉支未知欲知根相应法。彼是何耶。答曰。十大地。九善大地。及心觉

观随地。不与未知欲知根相应亦不与猗觉支者。未知欲知根不相应猗觉支。彼是何耶。知根知已根俱聚中猗觉支体。不与未知欲知根相应。是他聚故。亦不与猗觉支相应。所以者何。自体不应自体如先说。及余心心数法。更无无漏心。余有漏心心数法。色无为心不相应行。如是等法。作第四句。如未知欲知根于猗觉支。未知欲知根于舍觉支亦如是。若法与未知欲知根相应。亦与正觉相应耶。乃至广作四句。与未知欲知根相应不与正觉者。正觉应于未知欲知根俱聚中正觉体与未知欲知根相应。不与正觉相应。所以者何。自体不应自体如先说。及正觉不相应未知欲知根相应法。彼是何耶。中间禅三禅中未知欲知根相应法。与正觉相应不与未知欲知根者。未知欲知根不相应正觉相应法。彼是何耶。知根知已根俱聚中正觉相应法。不与未知欲知根相应。以他聚故。与未知欲知根相应亦与正觉者。未知欲知根正觉相应法。彼是何耶。答曰。十大地。十善大地。及心观。不与未知欲知根相应亦不与正觉者。未知欲知根不相应正觉。彼是何耶。知根知已根俱聚中正觉体。不与未知欲知根相应。以他聚故。亦不与正觉相应。所以者何。自体不应自体如先说。及余心心数法。余者中间禅三禅三无色定中知根知已根俱聚中一切有漏心心数法色无为心不相应行。如是等法。作第四句。如未知欲知根。知根知已根说亦如是。异者

若法与知已根相应。亦与正见相应耶。乃至广作四句。与知已根相应不与正见者。知已根所摄正见知已根俱聚中正见体。与知已根相应。不与正见相应。所以者何。自体不应自体如先说。及余正见不相应知已根相应法。彼是何耶。答曰。尽智无生智俱聚中与已知根相应。不与正见相应。以他聚故。与正见相应不与已知根者。知已根所不摄正见相应法。未知欲知根知根俱聚中正见相应法。不与已知根相应。以他聚故。与知已根相应。亦不与正见者。知已根正见相应法。彼是何耶。答曰。八根及彼相应非根心心数法。不与已知根相应亦不与正见者。知已根所不摄。正见未知欲知根俱聚中正见体。不与知已根相应。以他聚故。不与正见相应。所以者何。自体不应自体如先说。及余心心数法无漏法无余余有漏心心数法色无为心不相应行。如是等法。作第四句。余相应如先品说

阿毗昙毗婆沙论卷第五十八阿毗昙毗婆沙论卷第五十九

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    智揵度相应品第四之三

有四十四智体。知老死智体。知老死集智体。知老死灭智体。知老死灭道智体。乃至知行亦如是。问曰。何故作此论。答曰。此是佛经。佛经说。佛告比丘。我今当说四十四智体。汝等皆应一心善听。佛说是经。而不广分别。佛经是此论所为根本。欲广分别故。而作此论。问曰。若佛经是此论根本者。何故世尊说此经耶。答曰。世尊以如是方便道门。得阿耨多罗三藐三菩提。今欲以是方便道门示诸弟子。汝等不舍是方便道门者。不久当得尽漏。譬豪富长者。以如是方便积聚财物。复欲以是方便教诸子孙。汝等不应舍离如是方便。不久当得无量财宝。彼亦如是

云何四十四智体。知老死是一智体。知老死集是二智体。知老死灭是三智体。知老死灭道。是四智体。知因老死。有四智体。乃至知行。亦有四智体。十一四则有四十四智体。问曰。何故不说知无明智体耶。答曰。应说而不说者。当知此说有余。复次若是有支有为作因者说智体。无明虽是有支有不为作因。复次有四法者立智体。无明有三法义故不立。知老死智是四智。谓法智比智苦智等智。知老死集智是四智。谓法智比智集智等智。知老死灭智是四智。谓法智比智灭智等智。知老死灭道智是四智。谓法智比智道智等智。如知老死。有十六智乃至知行。亦有十六智。若分别在身。及以刹那。则有无量无边。此中以有支以谛以对治故。有四十四智体

问曰。此四十四智体几在过去。几在未来。几在现在。答曰。或在过去。或在未来。或在现在。几缘过去。几缘未来现在。答曰。三十三缘三世。十一缘非世法。若如杂揵度所说者。三缘过去。谓知行知行集知识集。三缘未来。谓知老死知老死集知生。十六缘现在。谓知生知生集。知有知有集。知取知取集。知爱知爱集。知受知受集。知触知触集。知六入知六入集。知名色知名色集知识。十一缘三世。十一缘非世。几是有漏几是无漏。答曰。或尽是有漏或尽是无漏。几缘有漏几缘无漏。答曰。二十二缘有漏。二十二缘无漏。几是有为几是无为。答曰。尽是有为。无有智是无为者。几缘有为。几缘无为。答曰。三十三缘有为。十一缘无为。此智体不能得正决定。不得果。不离欲。不尽漏。是圣人本所得法。为游戏故。为观本所作故。为受现法乐故。为受用圣法故。起此智现在前

有七十七智体。问曰。何故作此论。答曰。此是佛经。佛经说。我今当说七十七智体。谓知生是老死缘智体。非不缘生有老死智体。乃至广说。佛何故说此经者。如先说

云何七十七智体。答曰。知生是老死缘是一智体。非不缘生有老死是二智体。过去生曾为老死缘是三智体。非不曾缘过去生有老死是四智体。未来生当为老死缘是五智体。非不当缘未来生有老死是六智体。及知法住智此法是无常是有为从因缘生。是尽法是灭法。是无欲法。知如是法者是第七智体。如知老死有七智体乃至知行亦有七智体。十一七智体则有七十七智体。问曰。此中何故不说知无明。缘智体耶。答曰。应说而不说者。当知此说有余。复次若是有支有为作因者说智体。无明虽是有支有不为作因。知生是老死缘。是四智体。谓法智比智等智集智。非不缘生有老死智体。何故复作此说耶。答曰。论有二种。一定自言。二定他言。定自言者。如佛弟子。以佛法义。定于自言。如外道弟子。以外道义。亦定自言。如育多婆提。以育多婆提义。定于自言。如毗婆阇婆提。以毗婆阇婆提义。定于自言。定他言者。如佛弟子定外道弟子言。外道弟子定佛弟子言。如育多婆提定毗婆阇婆提言。如毗婆阇婆提定育多婆提言。或谓。此但为论议故。作如是说。非是实法。欲令此义决定。有如是实事故作是说。非不缘生有此老死。此智是四智。谓法智比智等智集智。通前有八智。如过去生曾为老死缘智体是四智。谓法智比智等智知集智。通前有十二智体。知非不曾缘过去生有老死智体是四智。如先说。通前有十六智体。知未来生当为老死缘智体是四智。如先说。通前有二十智体。知非不当缘未来生有老死智。体是四智。如先说。通前有二十四智体。知法住智。乃至广说。通前有二十五智体。如知老死缘有二十五智体。乃至知行缘有二十五智体。若分别在身及刹那者。则有无量无边智体。此中以有支以世以谛以对治故。立七十七智体。问曰。何故不说知现在智体耶。答曰。或有说者。生是老死缘非不缘生有老死。是说知现在智体。过去者知过去。未来者知未来。复有说者。知生是老死缘非不缘生有老死。是说知三世。过去即知过去。未来即知未来

问曰。此智几在过去。几在未来现在。答曰。或尽在过去。或尽在未来。或尽在现在。几缘过去。几缘未来。几缘现在。答曰。若如所说生是老死缘非不缘生有老死。是说知现在智体者。二十二缘过去。二十二缘未来。二十二缘现在。十一缘三世。若作是说。生是老死缘非不缘生有老死。是说知三世智体者。二十二缘过去。二十二缘未来。三十三缘三世。几是有漏几是无漏。答曰。或尽是有漏。或尽是无漏。几缘有漏几缘无漏。答曰。尽缘有漏。几是有为几是无为。答曰。尽是有为。无有智体。是无为者。几缘有为几缘无为。答曰。尽缘有为。此智体不能得正决定。乃至广说

及法住智。乃至广说。法住智者。是知因智。所以者何。住名为因三界。上中下果。在彼中住故。若知此智。名知法住智。此智是四智。谓法智比智等智集智。复有说者。若欲知法住智。是名知法住智。知彼智是道智。问曰。若然者。此说云何通。如说此是尽法灭法无欲法无漏法。非是无欲法。答曰。此文应如是说。此是尽法灭法。不应言无欲法。而不说者。有何意耶。答曰。欲呵责无漏法故。经说苏尸摩当知。先有法住智。后有涅槃智。问曰。此中何者是法住智。何者是涅槃智耶。答曰。知生死增长智是法住智。知生死增长灭智是涅槃智。复次知十二缘起是法住智。知十二缘起灭是涅槃智。知苦集智是法住智。知灭道智是涅槃智。若作是说则为善通。先有法住智后有涅槃智。复有说者。苦集道智是法住智。灭智是涅槃智。问曰。若然者。先有法住智后有涅槃智。此说云何通。答曰。涅槃智亦有在后者。复次诸边中智是法住智。根本中智是涅槃智。何以知之。经说有众多异学梵志。共集一处作如是谈论。闻有此言。沙门瞿昙未出世时。我等为国王大臣婆罗门居士。而见尊重供养。今沙门瞿昙出世。夺我名称利养。犹如日出令火无光。我等今当作何方便还得名誉利养。乃至广说。复作是念。沙门瞿昙更无异德。但善知经论。颜貌端正我等不假颜貌。但知经论者。便可还得名誉利养。乃至广说。复作是言。今此众中谁能堪任于沙门瞿昙法中出家而窃于法。令我等受持读诵。复作是言。今苏尸摩梵志志念坚固。堪任于沙门瞿昙法中出家窃法。令我等受持读诵。即皆往诣苏尸摩所。具陈上事而以告之。尔时苏尸摩以二事故。而便可之。一以亲爱眷属故。二以善根因缘故。尔时苏尸摩出王舍城。诣于竹林。时有众多比丘。在精舍门边。往反经行。尔时苏尸摩遥见诸比丘。即往其所而作是言。诸比丘。当知我欲于沙门瞿昙法中净修梵行。时诸比丘即将苏尸摩诣世尊所。而白佛言。今此苏尸摩梵志者。欲于世尊法中出家受具足戒行比丘法。佛告诸比丘。汝等可为苏尸摩出家授其具足。时诸比丘即为出家授具足。时苏尸摩聪明智慧。念力坚固。未久之间。读诵三藏。少解其义。便作是念。若欲利我亲属者。今正是时。从竹林出欲诣王舍城。世尊有遍照眼。守护于法。谁能窃者。尔时有五百比丘诣苏尸摩所。或有说者。是诸比丘佛所化作。或有说者。是实比丘。时诸比丘到苏尸摩所。皆作是言。苏尸摩。当知我等生分已尽。所作已办。梵行已立。不受后有。时苏尸摩便问诸比丘言。汝等依于初禅得尽漏耶。答曰。不也。依第二第三第四禅及过色无色寂静解脱得尽漏耶。答言不也。时苏尸摩复作是言。汝等既不依禅定。而得尽漏。谁当信耶。时诸比丘皆作是言。我等是慧解脱。时苏尸摩不识慧解脱。若我亲属问是义者。我则不知。以是事故。还诣佛所。具以上事。向佛说之。佛作是答。苏尸摩。当知先有法住智后有涅槃智。苏尸摩复白佛言。世尊。我今不知何者法住智何者是涅槃智。佛告苏尸摩。汝知与不知。但法应如是。先有法住智后有涅槃智。彼诸比丘。先依未至禅尽漏。后起根本禅。以是事故。知诸边中智是法住智根本中智是涅槃智

若成就法智。亦成就比智耶。答曰。若得。云何为得。若苦比智现在前。设成就比智。亦成就法智耶。答曰。如是。所以者何。以法智在前得故。若成就法智。亦成就他心智耶。答曰。若得不失。云何若得不失。已离欲爱。于彼离欲不退。设成就他心智。亦成就法智耶。答曰。若得。云何为得。若苦法智现在前。若成就法智。亦成就等智耶。答曰。如是。设成就等智。亦成就法智耶。答曰。若得。云何为得。若苦法智现在前。若成就法智。亦成就苦智耶。答曰。如是。设成就苦智。亦成就法智耶。答曰。如是。所以者何。此二智一时得故。若成就法智。亦成就集灭道智耶。答曰。若得。设成就集灭道智。亦成就法智耶。答曰。如是。所以者何。法智在前得故。若成就比智。亦成就他心智耶。答曰。若得不失。云何若得不失。已离欲爱。于彼离欲不退。设成就他心智。亦成就比智耶。答曰。若得。云何为得。若苦比智现在前。若成就比智。亦成就等智耶。答曰。如是。设成就等智。亦成就比智耶。答曰。若得。如先说。若成就比智。亦成就苦智耶。答曰。如是。设成就苦智。亦成就比智耶。答曰。若得。如先说。若成就比智。亦成就集灭道智耶。答曰。若得。如先说。设成就集灭道智。亦成就比智耶。答曰。如是。若成就他心智。亦成就等智耶。答曰。如是。设成就等智。亦成就他心智耶。答曰。若得不失。如先说。若成就他心智。亦成就苦集灭道智耶。答曰。若得。设成就苦集灭道智。亦成就他心智耶。答曰。若得不失。如先说。若成就等智。亦成就苦集灭道智耶。答曰。若得。设成就苦集灭道智。亦成就等智耶。答曰。如是。若成就苦智。亦成就集灭道智耶。答曰。若得。设成就集灭道智。亦成就苦智耶。答曰。如是。所以者何。苦智在前得故。若成就集智。亦成就灭道智耶。答曰。若得。设成就灭道智。亦成就集智耶。答曰。如是。若成就灭智。亦成就道智耶。答曰。若得。设成就道智。亦成就灭智耶。答曰。如是

若成就过去法智。亦成就未来耶。答曰。如是。何等时成就过去未来法智耶。答曰。得正决定。见苦谛时二心顷。见集谛时四心顷。见灭谛时四心顷。见道谛时三心顷。得须陀洹果斯陀含果阿那含果阿罗汉果。信解脱转根作见到时。解脱转根作不动时。已起灭法智。设成就未来法智。亦成就过去耶。答曰。若灭已不失。如先说。时若不灭。设灭便失。则不成就何等时。成就未来法智。不成就过去耶。答答曰。得正决定。见苦谛时一心顷。得须陀洹果。未起灭法智。先起灭者。得果故失。乃至时解脱转根作不动。未起灭法智。先起灭者。得果转根故失。若成就过去法智。亦成就现在耶。答曰。若现在前。云何为现在前。若不起比智等智忍。若非无心时。乃现在前。何等时成就过去现在法智耶。答曰。得正决定。见集谛时一心顷。见灭谛时一心顷。见道谛时一心顷。得须陀洹果。已起灭法智现在前。乃至时解脱转根作不动。已起灭法智现在前。设成就现在法智。亦成就过去耶。答曰。若灭已不失。则成就何等时。成就现在法智。亦成就过去耶。答曰。如先说。时若不灭设灭便失。则不成就何等时。成就现在法智非过去耶。答曰。得正决定。见苦谛时一心顷。得须陀洹时。未起灭法智。先起灭者。得果故失。起法智现在前。乃至时解脱转根作不动。未起灭法智。先起灭者。得果转根故失。起法智现在前。若成就未来法智。亦成就现在耶。答曰。若现在前。何等时成就未来现在法智耶。答曰。得正决定。见苦谛时一心顷。见集谛时一心顷。见灭谛时一心顷。见道谛时一心顷。得须陀洹果时。起法智现在前。乃至时解脱转根作不动。起法智现在前。设成就现在法智。亦成就未来耶。答曰。如是。所以者何。若成就现在法智。必成就未来。若成就过去法智。亦成就未来现在耶。答曰。未来则成就。现在若现在前。何等时成就三世法智耶。答曰。得正决定。见集谛时一心顷。见灭谛时一心顷。见道谛时一心顷。得须陀洹果。已起灭法智现在前。乃至时解脱转根作不动。已起灭法智现在前。设成就未来现在法智。亦成就过去耶。答曰。若灭已不失则成就。如先说时。若不灭。设灭便失。则不成就。何等时成就未来现在法智。不成就过去耶。答曰。得正决定。见苦谛时一心顷。得须陀洹果。未起灭法智。先起灭者得果故失。起法智现在前。乃至时解脱转根作不动。未起灭法智。先起灭者得果转根故失。起法智现在前。若成就未来法智。亦成就过去现在耶。答曰。或成就未来法智。非过去现在。及过去非现在。及现在非过去。及过去现在。成就未来法智。非过去现在者。若得法智未灭。设灭便失。则不现在前。若得法智。是则明有未来。若未灭。设灭便失。则明无过去。不现在前。则明无现在。何等时成就未来法智。不成就过去现在耶。见道中无得须陀洹果未起灭法智。先起灭者。得果故失。不起法智现在前。乃至时解脱转根作不动。未起灭法智。先起灭者。得果转根故失。不起法智现在前。及过去非现在者。若已起灭法智。不起法智现在前。若已起灭法智。则明有过去。不起法智现在前。则明无现在。若成就过去。必成就未来。何等时成就过去未来法智。不成就现在耶。答曰。如先说。成就过去未来法智时。及现在非过去者。起法智现在前。若未灭设灭便失。起法智现在前。则明有现在若未灭设灭便失。则明无过去。若成就现在。必成就未来。何等时成就未来现在法智。非过去耶。答曰。如先说。成就未来现在法智时。及过去现在者。若以起灭法智不失。起法智现在前。若以起灭法智不失。则明有过去。起法智现在前。则明有现在。若成就过去现在。必成就未来。何等时成就三世法智耶。答曰。如先说。成就三世法智时。设成就过去现在法智。亦成就未来耶。答曰。如是。若成就现在法智。亦成就过去未来耶。答曰。未来则成就。过去若灭已不失。若未灭。设灭便失则不成就。何等时成就三世法智耶。答曰。如先说。成就三世法智时。设成就过去未来法智。亦成就现在耶。答曰。若现在前。如先说。如法智作六句。比智苦智集智灭智道智作六句亦如是

阿毗昙毗婆沙论卷第五十九阿毗昙毗婆沙论卷第六十

        迦旃延子造　五百罗汉释

        北凉天竺沙门浮陀跋摩共道泰等译

    智揵度相应品第四之四

若成就过去他心智。亦成就未来耶。答曰。如是。所以者何。若成就过去。必成就未来。何等时成就过去未来他心智耶。答曰。生欲界离欲界欲者。及生色界者。若学人于欲界色界。已起灭无漏他心智。命终生无色界。未得阿罗汉果者。设成就未来他心智。亦成就过去耶。答曰。若灭已不失则成就。如先说时。若未灭。设灭便失。则不成就。生欲界色界。则无是事。若于欲界色界。已起灭他心智。命终生无色界。于彼得阿罗汉果者。是时不起灭他心智。先起灭者。得果故失。若圣人于欲色界。不起灭无漏他心智。命终生无色界者。唯成就未来他心智非过去。若成就过去他心智。亦成就现在耶。答曰。若现在前。云何为现在前。若不起余智。不起忍。若非无心。乃现在前。设成就现在他心智。亦成就过去耶。答曰。如是。何等时成就过去现在他心智耶。答曰。生欲色界。起他心智现在前。若成就未来他心智。亦成就现在耶。答曰。若现在前。云何为现在前。答曰。若不起余智及忍。若非无心。乃现在前。何等时成就未来现在他心智耶。答曰。生欲色界。起他心智现在前。设成就现在他心智。亦成就未来耶。答曰。如是。所以者何。若成就现在。必成就未来。若成就过去他心智。亦成就未来现在耶。答曰。未来则成就。现在若现在前。云何为现在前。如先说。何等时成就三世他心智耶。答曰。生欲色界。起他心智现在前。设成就未来现在他心智。亦成就过去耶。答曰。如是。何等时成就三世他心智耶。答曰。如先说。若成就未来他心智。亦成就过去现在耶。答曰。或成就未来他心智非过去现在。及过去非现在。及过去现在。何等时成就未来他心智。非过去现在耶。答曰。生欲色界中。无有是事。若学人于欲色界中。不起灭无漏他心智。命终生无色界。未得阿罗汉果者。若已起灭他心智。命终生无色界。得阿罗汉果者。是时唯成就未来。及过去非现在者。生欲界离欲爱。不起他心智现在前。生色界不起他心智现在前。若学人已起灭无漏他心智。命终生无色界。未得阿罗汉果者。及过去现在者。生欲色界。起他心智现在前。设成就过去他心智现在他心智。亦成就未来耶。答曰。如是。何等时成就三世他心智耶。答曰。如先说时。若成就现在他心智。亦成就过去未来耶。答曰。如是。何等时成就三世他心智耶。答曰。如先说时。设成就过去未来他心智。亦成就现在耶。答曰。若现在前。云何为现在前。答曰。如先说

若成就过去等智。亦成就未来耶。答曰。如是。所以者何。一切众生。尽成就过去未来等智故。成就未来等智。亦成就过去耶。答曰。如是。若成就过去等智。亦成就现在耶。答曰。若现在前。云何为现在前。若不起无漏智。不起忍。若非无心乃现在前。设成就现在等智。亦成就过去耶。答曰。如是。余广说如经本

若成就过去法智。亦成就过去比智耶。答曰。若灭已不失则成就。何等时成就过去法智比智耶。答曰。得正决定。见集谛时四心顷。见灭谛时四心顷。见道谛时三心顷。得须陀洹果。已起灭法智比智。乃至时解脱转根作不动。已起灭法智比智。若不灭。设灭便失。则不成就。何等时成就过去法智。不成就比智耶。答曰。得须陀洹果阿罗汉果。时解脱转根作不动时。无有是事。所以者何。是时先有比智故。何等时成就过去法智。不成就过去比智耶。答曰。得正决定。见苦谛时二心顷。得斯陀含果时。已起灭法智非比智。先起灭者得果故失。得阿那含果信解脱。转根作见到亦如是。设成就过去比智。亦成就过去法智耶。答曰。若灭已不失则成就。何等时成就过去比智。不成就过去法智耶。答曰。见道中。无有是事。所以者何。见道中。先得法智故。得须陀洹果时。已起灭比智。不起灭法智。先起灭者。得果故失。乃至时解脱转根作不动。已起灭比智。不起灭法智。先起灭者。得果转根故失。若成就过去法智。亦成就未来比智耶。答曰。若得何等时成就过去法智。亦成就未来比智耶。答曰。得正决定。见苦谛时一心顷。见集谛时四心顷。见灭谛时四心顷。见道谛时三心顷。得须陀洹果。已起灭法智。乃至时解脱转根作不动。已起灭法智。设成就未来比智。亦成就过去法智耶。答曰。若灭已不失则成就。何等时成就未来比智。亦成就过去法智耶。答曰。如先说时。若不灭设灭便失。则不成就。何等时成就未来比智。不成就过去法智耶。答曰。见道无有是事。得须陀洹果。乃至时解脱转根作不动。不起灭法智。若成就过去法智。亦成就现在比智耶。答曰。若成就现在前。云何为现在前。若不起余智。不起忍。若非无心。乃现在前。何等时成就过去法智。亦成就现在比智耶。答曰。得正决定。见苦谛时一心顷。见集谛时一心顷。见灭谛时一心顷。得须陀洹果。已起灭法智。起比智现在前。乃至时解脱转根作不动。已起灭法智。起比智现在前。设成就现在比智。亦成就过去法智耶。答曰。若灭不失则成就。如先说时。若不灭设灭便失。则不成就。何等时成就现在比智。不成就过去法智耶。答曰。见道中。无有是事。得须陀洹果。未起灭法智。先起灭法智者。得果故失。起比智现在前。乃至时解脱转根作不动。未起灭法智。先起灭法智者。得果转根故失。起比智现在前。若成就过去法智。亦成就过去现在比智耶。答曰。或成就过去法智。不成就过去现在比智。及过去非现在。及现在非过去。及过去现在。成就过去法智。非成就过去现在比智者。已起灭法智。未起灭比智。不起比智现在前。何等时成就过去法智。不成就过去现在比智耶。答曰。得须陀洹果阿罗汉果。时解脱转根作不动。无有是事。得正决定。见苦谛时一心顷。得斯陀含果阿那含果信解脱转根作见到时。已起灭法智。未起灭比智。先起灭者。得果转根故舍。不起比智现在前。及过去非现在者。已起灭法智比智。不起比智现在前。何等时成就过去法智比智。不成就现在比智耶。答曰。如先说。及现在非过去者。已起灭法智。起比智现在前。若未灭设灭便失。何等时成就过去法智现在比智。非过去比智耶。答曰。如先说。及过去现在者。已起灭法智比智。起比智现在前。何等时成就过去法智及过去现在比智耶。答曰。得正决定。见集谛时一心顷。见灭谛时一心顷。得须陀洹果。已起灭法智比智起比智现在前。乃至时解脱转根作不动。已起灭法智比智起比智现在前。设成就过去现在比智。亦成就过去法智耶。答曰。若灭已不失则成就。何等时成就过去现在比智。亦成就过去法智耶。答曰。如先说。若不灭。设灭便失。则不成就。何等时成就过去现在比智。不成就过去法智耶。答曰。见道中无有是事。得须陀洹果。已起灭比智起比智现在前。未起灭法智。先起灭者。得果故失。乃至时解脱转根作不动。说亦如是。若成就过去法智。亦成就未来现在比智耶。答曰。或成就过去法智。不成就未来现在比智及未来非现在及未来现在。成就过去法智非未来现在比智者。已起灭法智不失。未得比智。何等时成就过去法智。非未来现在比智耶。答曰。得正决定。见苦谛时一心顷。及未来非现在者。已起灭法智不失。得比智不起现在前。何等时成就过去法智及未来比智非现在耶。答曰。如先说。及未来现在者。已起灭法智不失。起比智现在前。何等时成就过去法智。亦成就未来现在比智耶。答曰。得正决定。见苦谛时一心顷。见集谛时一心顷。见灭谛时一心顷。得须陀洹果。已起灭法智。起比智现在前。乃至时解脱转根作不动亦如是。设成就未来现在比智。亦成就过去法智耶。答曰。若灭已不失。则成就。何等时成就未来现在比智。亦成就过去法智耶。答曰。如先说。若不灭。设灭便失。则不成就。何等时成就未来现在比智。不成就过去法智耶。答曰见道中。无有是事。得须陀洹果。乃至时解脱转根作不动时。未起灭法智。先起灭者。得果转根故失。起比智现在前。若成就过去法智。亦成就过去未来比智耶。答曰。或成就过去法智。非过去未来比智。及未来非过去。及过去未来成就过去法智。非过去未来比智者。已起灭法智不失。未得比智。何等时成就过去法智。非过去未来比智耶。答曰。得正决定。见苦谛时一心顷。及未来非过去者。已起灭法智不失。得比智未灭。设灭便失。何等时成就过去法智及未来比智非过去耶。答曰。得正决定。见苦谛时一心顷。得须陀洹果阿罗汉果时解脱转根作不动时。无有是事。所以者何。比智在前得故。得斯陀含阿那含果信解脱转根作见到时。已起灭法智。未起灭比智。先起灭者。得果转根故失及过去未来比智者。已起灭法智。比智不失。何等时成就过去法智及过去未来比智耶。答曰。得正决定。见集谛时四心顷。见灭谛时四心顷见。道谛时三心顷。得须陀洹果。已起灭法智比智。乃至时解脱转根作不动。已起灭法智比智。设成就过去未来比智。亦成就过去法智耶。答曰。若灭已不失则成就。如先说时。若不灭。设灭便失。则不成就。何等时成就过去未来比智。不成就过去法智耶。答曰。见道中。无有是事。所以者何。法智在前得故。得须陀洹果。已起灭比智。未起灭法智。先起灭者。已得果故失。乃至时解脱转根作不动亦如是。若成就过去法智。亦成就过去未来现在比智耶。答曰。是中有五句成就过去法智非过去未来现在比智者。答曰。如先说。及未来非过去现在者。答曰。如先说。及过去未来非现在者。答曰。如先说。及未来现在非过去者。答曰。如先说。及过去未来现在者。已起灭法智比智。起比智现前。何等时成就过去法智。亦成就三世比智耶。答曰。得正决定。见集谛时一心顷。见灭谛时一心顷。得须陀洹果。乃至时解脱转根作不动。已起灭法智比智。起比智现在前。设成就过去未来现在比智。亦成就过去法智耶。答如先说。若成就过去法智。亦成就过去他心智耶。答曰。若灭已不失。则成就过去。何等时成就过去法智他心智耶。答曰。离欲爱人。得正决定。见苦谛时二心顷。见集谛时四心顷。见灭谛时四心顷。见道谛时三心顷。得阿那含果阿罗汉果。离欲爱人。信解脱转根作见到。时解脱转根作不动。已起灭法智他心智。若不灭设灭便失则不成就。何等时成就过去法智。非他心智耶。答曰。未离欲爱人得正决定。见苦谛时二心顷。见集谛时四心顷。见灭谛时四心顷。见道谛时三心顷。得须陀洹果斯陀含果。未离欲爱人。信解脱转根作见到时。已起灭法智。设成就过去他心智。亦成就过去法智耶。答曰。若灭已不失则成就如先说时。若不灭设灭便失则不成就。何等时成就过去他心智非法智耶。答曰。离欲爱人得正决定。见苦谛时二心顷。得阿那含果阿罗汉果。未起灭法智。设起灭者。得果故失。离欲爱信解脱转根作见到。时解脱转根作不动。未起灭法智。设起灭者。转根故失。若于欲界不起灭法智。命终生色界者。若于欲界色界。已起灭无漏他心智。不起灭法智。命终生无色界。未得阿罗汉果者。生欲界离欲爱凡夫。生色界凡夫。若成就过去法智。亦成就未来他心智耶。答曰。若得不失则成就。云何得不失。若离欲爱。于彼离欲不退。何等时成就过去法智。亦成就未来他心智耶。答曰。如先说时。设成就未来他心智。亦成就过去法智耶。答曰。若已灭不失则成就。如先说时。若不灭设灭便失则不成就。何等时成就未来他心智。不成就过去法智耶。答曰。离欲爱人得正决定。见苦谛时二心顷。得阿那含果得阿罗汉果。未起灭法智。设起灭者。得果故失。离欲爱信解脱转根作见到。时解脱转根作不动。未起灭法智。设起灭者。转根故失。若于欲界。未起灭法智。命终生色无色界。设起灭者。即于彼得阿罗汉果。生欲界离欲凡夫。生色界凡夫。若成就过去法智。亦成就现在他心智耶。答曰。若现在前。云何为现在前。若不起余智不起忍。若非无心。乃现在前。何等时成就过去法智成就现在他心智耶。答曰。得阿那含果。乃至时解脱转根作不动。已起灭法智。起他心智现在前。若于欲界。起灭法智。命终生色界。起他心智现在前。设成就现在他心智。亦成就过去法智耶。答曰。若灭已不失则成就。如先说时。若不灭。设灭便失则不成就。何等时成就现在他心智。不成就过去法智耶。答曰。见道中无有是事。得阿那含果。乃至时解脱转根作不动。未起灭法智。设起灭者。得果转根故失。起他心智现在前。若于欲界。不起灭法智。命终生色界。起他心智现在前。设起灭者。即于彼得阿罗汉果。起他心智现在前。生欲色界凡夫。起他心智现在前。若成就过去法智。亦成就过去现在他心智耶。答曰。或成就过去法智。不成就过去现在他心智及过去非现在。及过去现在。成就过去法智非过去现在他心智者。若已起灭法智。不起灭他心智。设起灭者便失。不起他心智现在前。何等时成就过去法智。不成就过去现在他心智耶。答曰。如先说。未离欲爱时。及过去非现在前者。已起灭法智他心智不失。不起他心智现在前。如先说。异者言不起他心智现在前。及过去现在者。已起灭法智他心智不失。起他心智现在前。何等时成就过去法智。亦成就过去现在他心智耶。答曰。见道中无有是事。得阿那含果。已起灭法智。起他心智现在前。乃至时解脱转根作不动。已起灭法智。起他心智现在前。若于欲界。已起灭法智。命终生色界。未得阿罗汉果。起他心智现在前。设成就过去现生他心智。亦成就过去法智耶。答曰。若灭已不失则成就。如先说时。若不灭设灭便失则不成就。何等时成就过去现在他心智。非过去法智耶。答曰。见道中无有是事。阿那含果。未起灭法智。起他心智现在前。乃至时解脱转根作不动。未起灭法智。起他心智现在前。若于欲界不起灭法智。命终生色界。起他心智现在前。设起灭者。生色界得阿罗汉果。起他心智现在前。生欲色界凡夫。起他心智现在前。若成就过去法智。亦成就未来现在他心智耶。答曰。此中有三句。成就过去法智。不成就未来现在他心智者。答如先说。及未来非现在者。已起灭法智不失。得他心智不起现在前。何等时成就过去法智及未来他心智。非现在耶。答曰。离欲爱人。得正决定。见苦谛时二心顷。见集谛时四心顷。见灭谛时四心顷。见道谛时三心顷。得阿那含果。乃至时解脱转根作不动。已起灭法智。不起他心智现在前。若于欲界。起灭法智。命终生色界。未得阿罗汉果。不起他心智现在前。若生无色界。未得阿罗汉果。及未来现在者。已起灭法智不失。起他心智现在前。何等时成就过去法智及未来现在他心智耶。答曰。如先说。成就过去现在他心智时。设成就未来现在他心智。亦成就过去法智耶。答曰。若灭已不失则成就。如先说时。若不灭设灭便失则不成就。如先说。若成就过去法智。亦成就过去未来他心智耶。答曰。此中有三句。成就过去法智。非过去未来他心智者。答如先说。及未来非过去者。已起灭法智他心智。未起灭。设灭便失。何等时成就过去法智及未来他心智耶。答曰。生欲色界。无有是事。若于欲色界。起灭法智。不起灭无漏他心智。命终生无色界。未得阿罗汉果。及过去未来他心智者。答曰。如先说。设成就过去未来他心智。亦成就过去法智耶。答曰。如先说。若成就过去法智。亦成就过去未来现在他心智耶。答曰。此中有四句。随相而说。设成就过去未来现在他心智。亦成就过去法智耶。答曰。若灭已不失则成就。如先说时。若不灭设灭便失则不成就。亦如先说

若成就过去法智。亦成就过去等智耶。答曰如是。何等时成就过去法智。亦成就等智耶。答曰。得正决定。见苦谛时二心顷。见集谛时四心顷。见灭谛时四心顷。见道谛时三心顷。得须陀洹果。乃至时解脱转根作不动。已起灭法智。设成就过去等智。亦成就过去法智耶。答曰。若灭已不失则成就。如先说时。若不灭设灭便失则不成就。何等时成就过去等智。不成就过去法智耶。答曰。一切凡夫人及得正决定。见苦谛时二心顷。得须陀洹果。乃至时解脱转根作不动。未起灭法智。设起灭者。得果转根故失。若成就过去法智。亦成就未来等智耶。答曰如是。何等时成就过去法智及未来等智。答曰。如先说。设成就未来等智。亦成就过去法智耶。答曰。若已灭不失则成就如先说。若不灭。设灭便失则不成就。亦如先说。若成就过去法智。亦成就现在等智耶。答曰。若现在前。云何为现在前若不起无漏智。不起忍。若非无心乃现在前。何等时成就过去法智及现在等智耶。答曰。见道中无有是事。得须陀洹果。乃至时解脱转根作不动时。已起灭法智。起等智现在前。设成就现在等智。亦成就过去法智耶。答曰。若灭已不失则成就。如先说时。若不灭。设灭便失则不成就。何等时成就现在等智。不成就过去法智耶。答曰。见道中无有是事。得须陀洹果。未起灭法智。先起灭者得果故失。起等智现在前。乃至时解脱转根作不动。未起灭法智。先起灭者。得果转根故失起等智现在前。余随相广说作七句

若成就过去法智。亦成就过去苦智耶。答曰。若灭已不失则成就。何等时成就过去法智苦智耶。答曰。得正决定。见苦谛时二心顷。见集谛时四心顷。见灭谛时四心顷。见道谛时三心顷。得须陀洹果。乃至时解脱转根作不动。已起灭法智苦智。若不灭设灭便失则不成就。何等时成就过去法智。不成就过去苦智耶。答曰。见道中无有是事。得须陀洹果。乃至时解脱转根作不动。已起灭集灭道法智。未起灭苦智。先起灭者。得果转根故失。设成就过去苦智。亦成就过去法智耶。答曰。若灭已不失则成就。何等时成就过去苦智法智耶。答如先说。若不灭设灭便失则不成就。何等时成就过去苦智。不成就过去法智耶。答曰。见道中无有是事。得须陀洹果。乃至时解脱转根作不动。已起灭苦比智。未起灭法智。设起灭者。得果转根故失。若成就过去法智。亦成就未来苦智耶。答曰如是。何等时成就过去法智。亦成就未来苦智耶。答曰。得正决定。见苦谛时二心顷。见集谛时四心顷。见灭谛时四心顷。见道谛时三心顷。得须陀洹果。乃至时解脱转根作不动。已起灭法智。设成就未来苦智。成就过去法智耶。答曰。若灭已不失则成就。何等时成就未来苦智。亦成就过去法智耶。答曰。如先说时。若不灭设灭便失。则不成就。何等时成就未来苦智。不成就过去法智耶。答曰。得正决定。见苦谛时一心顷。得须陀洹果。未起灭法智。先起灭者。得果故失。乃至时解脱转根作不动。未起灭法智。先起灭者。得果转根故失。若成就过去法智。亦成就现在苦智耶。答曰。若现在前。云何为现在前若不起余智不起忍。若非无心。乃现在前。何等时成就过去法智。亦成就现在苦智耶。答曰。得正决定。见苦谛时一心顷。得须陀洹果。乃至时解脱转根作不动。已起灭法智起苦智现在前。设成就现在苦智。亦成就过去法智耶。答曰。若灭已不失则成就。如先说时。若不灭设灭便失则不成就。何等时成就现在苦智。不成就过去法智耶。答曰得正决定。见苦谛时一心顷。得须陀洹果。乃至时解脱转根作不动。未起灭法智。先起灭者。得果转根故失。起苦智现在前。若成就过去法智。亦成就过去现在苦智耶。答曰。此中有四句。成就过去法智不成就过去现在苦智者。若已起灭法智不失则成就。未起灭苦智。设起灭者便失。不起苦智现在前。何等时成就过去法智。不成就过去现在苦智耶。答曰。见道中无有是事。得须陀洹果。已起灭法智。未起灭苦智。设起灭者。得果故失。不起苦智现在前。乃至时解脱转根作不动。已起灭法智。未起灭苦智。设起灭者。得果转根故失。不起苦智现在前。及过去非现在者。已起灭法智苦智。不起苦智现在前。何等时成就过去法智苦智。不成就现在苦智耶。答曰。得正决定。见苦谛时一心顷。见集谛时四心顷。见灭谛时四心顷。见道谛时三心顷。得须陀洹果。已起灭法智苦智。不起苦智现在前。乃至时解脱转根作不动。已起灭法智苦智。不起苦智现在前。及现在前非过去者。若已起灭法智不失。未起灭苦智。设起灭者便失。起苦智现在前。何等时成就过去法智及现在苦智非过去耶。答曰。见道中无有是事。得须陀洹果。乃至时解脱转根作不动。已起灭法智。未起灭苦智。先起灭者。得果转根故失。起苦智现在前。及过去现在者。已起灭法智苦智。起苦智现在前。何等时成就过去法智及过去现在苦智耶。答曰。得正决定。见苦谛时一心顷。得须陀洹果。乃至时解脱转根作不动。已起灭法智苦智。起苦智现在前。设成就过去现在苦智。亦成就过去法智耶。答曰。若灭已不失则成就。如先说时。若不灭设灭便失则不成就。何等时成就过去现在苦智。不成就过去法智耶。答曰。见道中无有是事。得须陀洹果。乃至时解脱转根作不动。已起灭苦比智。未起灭法智。先起灭者。得果转根故失。起苦比智现在前。若成就过去法智。亦成就未来现在苦智耶。答曰。未来则成就。现在若现在前。余随相而说。若成就过去法智。亦成就过去未来苦智耶。答曰。未来则成就。过去若灭不失则成就。余随相而说。若成就过去法智。亦成就过去未来现在苦智耶。答曰。此中有四句。随相而说。如法智于苦智作七句。法智于集灭道智作七句亦如是。过去法智过去比智过去他心智作七句。乃至道智作七句亦如是。余广说如使犍度。一行历六七大七有以差别。答亦如使犍度

阿毗昙毗婆沙论卷第六十

    毗婆沙序

        释道挻作

毗婆沙者。盖是三藏之指归。九部之司南。司南既住。则群迷革正。指归既宣。则邪轮辍驾。自释迦迁晖六百余载。时北天竺有五百应真。以为灵烛久潜。神炬落耀。含生昏丧。重梦方始。虽前胜迦旃延撰。阿毗昙以拯颓运。而后进之贤。寻其宗致。儒墨竞构。是非纷如。故乃澄神畜观。搜简法相。造毗婆沙抑正众说。或即其殊辩。或标之铨评。理致渊旷。文蹄艳博。西域胜达之士。莫不资之以镜心。监之以朗识。而冥澜潜洒。将洽殊方。然理不虚运。弘之由人。大沮渠河西王。天怀遐廓。标诚冲寄。虽迹缠纷务。而神栖玄境。用能丘壑廊庙馆第林野。是使渊叟投策。岩逸来庭。息心升堂。玄客入室。诚诣既着。理感不期。有沙门道泰。才敏自天。冲气疏朗。关博奇趣。远参异言。往以汉土方等既备幽宗粗畅。其所未练唯三藏九部。故杖策冒崄爰至葱西。综揽梵文。义承高旨。并获梵本十万余偈。既达凉境。王即欲令宣译。然惧环中之固将或未尽。所以侧席虚衿企属明胜。天竺沙门浮陀摩。周流敷化。会至凉境。其人开悟渊博。神怀渊邃。研味钻仰。俞不可测。以乙丑岁四月中旬。于凉城内苑闲豫官寺请令传译理味。沙门智嵩道朗等三百余人。考文评义。务在本旨。除烦即实。质而不野。王屡回驾陶其幽趣。使文当理诣。片言有寄。至丁卯岁七月都讫。合一百卷。会凉域覆没。沦湮遐境。所出经本。零落殆尽。今凉王信尚发中探练幽趣。故每至新异希仰奇闻。更写已出本六十卷。送至宋台宣布未闻。庶令日新之美。敞于当时。福祚之兴。垂于来叶。挻以微缘豫参听末。欣遇之诚。窃不自默。粗例时事。以贻来哲

如来灭后。法胜比丘造阿毗昙心四卷。又迦旃延子造阿毗昙。有八揵度凡四十四品。后五百应真造毗婆沙。重释八揵度。当沮渠翻时大卷一百。大武破沮渠已后。零落收拾得六十卷。后人分之作一百一十卷。唯释三揵度。五揵度失尽

毗婆沙序


入阿毗达磨论

    No. 1554

入阿毗达磨论卷上

        塞建陀罗阿罗汉造

        三藏法师玄奘奉　诏译

  敬礼一切智　　佛日无垢轮
  言光破人天　　恶趣本心闇
  诸以对法理　　拔除法相愚
  我顶礼如斯　　一切智言藏
  劣慧妄说闇　　覆蔽牟尼言
  照了由明灯　　稽首然灯者

有聪慧者。能具受持诸牟尼尊教之文义。由拘事业有未得退。有劣慧者。闻对法中名义稠林便生怖畏。然俱恒有求解了心。欲令彼于阿毗达磨法相海中深洄复处欣乐易入。故作斯论

谓善逝宗有八句义。一色二受三想四行五识六虚空七择灭八非择灭。此总摄一切义。色有二种。谓大种及所造色。大种有四。谓地水火风。界能持自共相。或诸所造色。故名为界。此四大种如其次第以坚湿暖动为自性。以持摄熟长为业。大而是种故名大种。由此虚空非大种摄。能生自果是种义故。遍所造色故名为大。如是大种唯有四者。更无用故。无堪能故。如床座足。所造色有十一种。一眼二耳三鼻四舌五身六色七声八香九味十触一分十一无表色。于大种有故名所造即是依止大种起义。此中眼者。谓眼识所依。以见色为用净色为体。耳鼻舌身准此应说。色有二种。谓显及形。如世尊说恶显恶形。此中显色有十二种。谓青黄赤白烟云尘雾影光明闇。形色有八种。谓长短方圆。高下正不正。此中雾者。谓地水气。日焰名光。月星火药宝珠电等诸焰名明。障光明生于中。余色可见名影。翻此名闇。方谓畟方。圆谓团圆形平等名正。形不平等名不正。余色易了故今不释。此二十种皆是眼识。及所引意识所了别境。声有二种。谓有执受及无执受。大种为因有差别故。堕自体者名有执受。是有觉义。与此相违名无执受。前所生者名有执受。大种为因。谓语手等声。后所生者名无执受。大种为因。谓风林等声。此有情名非有情名差别为四。谓前声中语声名有情名。余声名非有情名。后声中化语声名有情名。余声名非有情名。此复可意及不可意差别成八。如是八种皆是耳识。及所引意识所了别境。香有三种。一好香二恶香三平等香。谓能长养诸根大种名好香。若能损害诸根大种名恶香。若俱相违名平等香。如是三种皆是鼻识。及所引意识所了别境。味有六种。谓甘酢碱辛苦淡别故。如是六种皆是舌识。及所引意识所了别境。触一分有七种。谓滑性涩性重性轻性及冷饥渴。柔软名滑是意触义。粗强名涩。可称名重翻此名轻。由此所逼暖欲因名冷。食欲因名饥。饮欲因名渴。此皆于因立果名故作如是说。如说诸佛出现乐等。大种聚中水火增故有滑性。地风增故有涩性。地水增故有重性。火风增故有轻性。水风增故有冷。风增故有饥。火增故有渴。无表色者。谓能自表诸心心所转变差别。故名为表。与彼同类而不能表。故名无表。此于相似立遮止言。如于刹帝利等说非婆罗门等。无表相者。谓由表心大种差别。于睡眠觉乱不乱心。及无心位有善不善色相续转不可积集。是能建立苾刍等因。是无表相。此若无者。不应建立有苾刍等。如世尊说。于有依福业事彼恒常福增长。如是无表总有三种。谓律仪不律仪俱相违所摄故。律仪有三种。谓别解脱静虑无漏律仪别故。别解脱律仪复有八种。一苾刍律仪。二苾刍尼律仪。三勤策律仪。四正学律仪。五勤策女律仪。六近事男律仪。七近事女律仪。八近住律仪。如是八种唯欲界系。静虑律仪。谓色界三摩地随转色。此唯色界系。无漏律仪。谓无漏三摩地随转色。此唯不系。不律仪者。谓诸屠儿及诸猎兽捕鸟捕鱼劫盗典狱缚龙煮狗罝弶魁脍。此等身中不善无表色相续转。非律仪非不律仪者。谓造毗诃罗窣堵波僧伽逻摩等。及礼制多烧香散华赞诵愿等。并捶打等所起种种善不善无表色相续转。亦有无表唯一刹那。依总种类故说相续。别解脱律仪由誓愿受得前七至命尽第八一昼夜。又前七种舍由四缘。一舍所学故。二命尽故。三善根断故。四二形生故。第八律仪即由前四及夜尽舍。静虑律仪由得色界善心故得。由舍色界善心故舍。属彼心故。无漏律仪得舍亦尔。随无漏心而得舍故。得不律仪由作及受。由四缘故舍不律仪。一受律仪故。二命尽故。三二形生故。四法尔得。色界善心处中无表。或由作故得。谓殷净心猛利烦恼。礼赞制多及捶打等。或由受故得。谓作是念。若不为佛造曼茶罗终不先食。如是等愿。或由舍故得。谓造寺舍敷具园林施苾刍等。舍此无表。由等起心及所作事俱断怀故。如是无表及前所说。眼等五根唯是意识所了别境。齐此名为初色句义。然诸法相略有三种。一自共相。二分共相。三遍共相。自共相者。如变坏故。或变碍故说名为色。如是即说可恼坏义。如法王说。苾刍当知。由变坏故名色取蕴。谁能变坏。谓手触故即便变坏。乃至广说。如能疾行故名为马。以能行故说名牛等。分共相者。如非常性及苦性等。遍共相者。如非我性及空性等。由此方隅。于一切法。应知三相

受句义者。谓三种领纳。一乐二苦三不苦不乐。即是领纳三随触义。从爱非爱非二触生。身心分位差别所起。于境欢戚非二为相。能为爱因故名受。如世尊说。触缘受受缘爱。此复随识差别有六。谓眼触所生受。乃至意触所生受。五识俱生名身受。意识俱生名心受。由根差别建立五种。谓乐根苦根喜根忧根舍根。诸身悦受。及第三静虑心悦受名乐根。悦是摄益义。诸身不悦受名苦根。不悦是损恼义。除第三静虑。余心悦受名喜根。诸心不悦受名忧根。诸身及心非悦非不悦受名舍根。此广分别如根等处

想句义者。谓能假合相名义解。即于青黄长短等色。螺鼓等声。沉麝等香。碱苦等味。坚软等触。男女等法相名义中假合而解。为寻伺因故名为想。此随识别有六如受。小大无量差别有三。谓缘少境故名小想。缘妙高等诸大法境故名大想。随空无边处等名无量想。或随三界立此三名

行有二种。谓相应行不相应行。相应行者。谓思触欲作意胜解念定慧寻伺信精进惭愧不放逸轻安不害舍欣厌不信懈怠放逸善根不善根无记根结缚随眠随烦恼缠漏。瀑流轭取身系盖及智忍等。诸心所法。此皆与心所依所缘行相时事五义等故说名相应。与此相违名不相应。谓得非得无想定灭定无想事命根众同分生住老无常名身句身文身等。如是相应不相应行总名行蕴。故大仙说。行蕴聚集如芭蕉茎

思谓能令心有造作。即是意业。亦是令心运动为义。此善不善无记异故。有三种别。触谓根境识和合生令心触境。以能养活心所为相。顺乐受等差别有三。欲谓希求。作事业随顺。精进谓我当作如是事业。作意谓能令心警觉。即是引心趣境为义。亦是忆持。曾受等此有三种。谓学无学非学非无学。七有学身中无漏作意名学。阿罗汉身中无漏作意名无学。一切有漏作意名非学非无学。胜解谓能于境印可。即是令心于所缘境无怯弱义。念谓令心于境明记。即是不忘。已正当作谓事业义。定谓令心专注一境。即是制如猿猴心。唯于一境而转义。毗婆沙者作如是说。如蛇在筒行便不曲。心若在定正直而转。慧谓于法能有简择。即是于摄相应成就诸因缘果。自相共相八种法中。随其所应观察为义。寻谓于境令心粗为相。亦名分别思惟。想风所系粗动而转。此法即是五识转因。伺谓于境令心细为相。此法即是随顺意识于境转因

信谓令心于境澄净。谓于三宝因果相属有性等中。现前忍许故名为信。是能除遣心浊秽法。如清水珠置于池内。令浊秽水皆即澄清。如是信珠在心池内。心诸浊秽皆即除遣。信佛证菩提信法是善说信僧具妙行。亦信一切外道所迷。缘起法性是信事业。精进谓于善不善法生灭事中勇悍为性。即是沉溺生死泥者。能策励心令速出义。惭谓随顺正理白法。增上所生违爱等流心自在性。由此势力于诸功德及有德者恭敬而住。愧谓修习功德为先。违痴等流诃毁劣法。由此势力于罪见怖。不放逸谓修诸善法。违害放逸守护心性。心堪任性说名轻安。违害惛沈随顺善法。心坚善性说名不害。由此势力不损恼他。能违于他乐为损事。心平等性说名为舍。舍背非理及向理故。由此势力令心于理。及于非理无向无背。平等而住如持秤缕。欣谓欣尚于还灭品。见功德已令心欣慕。随顺修善。心有此故欣乐涅槃。与此相应名欣作意。厌谓厌患于流转品。见过失已令心厌离。随顺离染。心有此故厌恶生死。与此相应名厌作意。心不澄净名为不信。是前所说。信相违法心心不勇悍名为懈怠。与前所说精进相违。不修善法为放逸。违前所说不放逸性。即是不能守护心义。如是所说不信等三。不立随眠及缠垢者。过失轻故。易除遣故

善根有三种。一无贪是违贪法。二无嗔是违嗔法。三无痴是违痴法。即前所说慧为自性。如是三法是善自性。亦能为根生余善法。故名善根。安隐义是善义。能引可爱有及解脱牙故。或已习学成巧便义是善义。由此能辨妙色像故。如彩画师造妙色像世称为善。不善根有三种。即前所治贪嗔痴三。贪谓欲界五部贪。嗔谓五部嗔。痴谓欲界三十四无明。除有身见及边执见相应无明。如是三法是不善自性。亦能为根生余不善故。名不善根。不安隐义是不善义。能引非爱诸有牙故。或未习学非巧便义是不善义。由此能办恶色像故。如彩画师所造不妙世称不善。无记根有四种。谓爱见慢无明。爱谓色无色界各五部贪。见谓色无色界各十二见。及欲界有身见边执见。慢谓色无色界各五部慢。无明谓色无色界一切无明。及欲界有身见边执见相应无明。此四无记根。是自所许。修静虑者有三种异故。一爱上静虑者。二见上静虑者。三慢上静虑者。此三皆因无明力起。毗婆沙者立无记根唯有三种。谓无记爱无明慧三。疑不坚住慢性高举。非根法故。于善不善义俱不记故名无记。又不能记爱非爱果故名无记。以不能招异熟果故。是无记性亦能生余无记染法或诸无记法。故名无记根

结有九种。谓爱结恚结慢结无明结见结取结疑结嫉结悭结。爱结者。谓三界贪。是染着相如融胶漆。故名为爱。爱即是结故名爱结。恚结者。谓五部嗔。于有情等乐为损苦。不饶益相如辛苦种。故名为恚。恚即是结故是名恚结。慢结者。谓三界慢。以自方他德类差别。心恃举相说名为慢。如傲逸者凌篾于他。此复七种。一慢二过慢三慢过慢四我慢五增上慢六卑慢七邪慢。谓因族姓财位色力持戒多闻工巧等事。若于劣谓。已胜。或于等谓己等。由此令心高举名慢。若于等谓己胜。或于胜谓己等。由此令心高举名过慢。若于胜谓己胜。由此令心高举名慢过慢。若于五取蕴执我我所。由此令心高举名我慢。若于未证得预流果等殊胜德中谓已证得。由此令心高举名增上慢。若于多分族姓等胜中谓己少劣。由此令心高举名卑慢。若实无德谓己有德。由此令心高举名邪慢。如是七慢总名慢结。无明结者。谓三界无知。以不解了为相。如盲瞽者违害明故。说名无明。此遮止言依对治义。如非亲友。不实等言。即说怨家。虚诳语等。无明即是结故名无明结。见结者。谓三见即有身见边执见邪见。五取蕴中无我我所。而执实有我我所相。此染污慧名有身见。身是聚义。有而是身故名有身。即五取蕴于此起见名有身见。即五取蕴非断非常。于中执有断常二相。此染污慧名边执见。执二边故。若决定执无业无业果无解脱无得解脱道。拨无实事。此染污慧名邪见。如是三见名见结。取结者谓二取即见取戒禁取。谓前三见及五取蕴。实非是胜而取为胜。此染污慧名见取。取是推求及坚执义。戒谓远离诸破戒恶禁。谓受持乌鸡鹿狗露形拔发断食卧灰。或于妄执生福灭罪。诸河池中数数澡浴。或食根果草菜药物以自活命。或复涂灰拔头发等皆名为禁。此二俱非能清净道。而妄取为能清净道。此染污慧名戒禁取。诸婆罗门有多闻者。多执此法以为净道。而彼不能得毕竟净。如是二取名为取结。疑结者。谓于四圣谛令心犹豫。如临岐路见结草人踌躇不决。如是于苦心生犹豫。为是为非乃至广说。疑即是结故名疑结。嫉结者。谓于他胜事令心不忍。谓于他得恭敬供养财位多闻及余胜法心生妒忌。是不忍义。嫉即是结故名嫉结悭结者。谓于己法财令心吝惜。谓我所有勿至于他。悭即是结故名悭结。结义是缚义。如世尊说。非眼结色非色结眼。此中欲贪说名为结。如非黑牛结白牛亦非白牛结黑牛。乃至广说。先所说结亦即是缚。以即结义是缚义故。然契经中复说三缚。一贪缚。谓一切贪如爱结相说。二嗔缚。谓一切嗔如恚结相说。三痴缚。谓一切痴如无明结相说

随眠有七种。一欲贪随眠。二嗔随眠。三有贪随眠。四慢随眠。五无明随眠。六见随眠。七疑随眠。此七别相结中已说。然应依界行相部别。分别如是七种随眠。谓贪诸欲故名欲贪。此贪即随眠故名欲贪随眠。此唯欲界五部为五。谓见苦所断。乃至修所断。嗔随眠亦唯欲界五部为五。有贪随眠唯色无色界各五部为十。内门转故。为遮于静虑无色解脱想。故说二界贪名有贪。慢随眠通三界各五部为十五。无明随眠亦尔。见随眠通三界各十二为三十六。谓欲界见苦所断具五见。见集灭所断唯有邪见及见取二。见道所断唯有邪见见取戒禁取三。总为十二。上二界亦尔为三十六。疑随眠通三界各四部为十二。谓见苦集灭道所断。此中欲贪及嗔随眠。唯有部别无界行相别。有贪疑慢无明随眠。有界部别无行相别。见随眠具有界行相部别。行相别者谓我我所。行相转者名有身见。断常行相转者名边执见。无行相转者名邪见。胜行相转者名见取。净行相转者名戒禁取。微细义是随眠义。彼现起时难觉知故。或随缚义是随眠义。谓随身心相缚而转。如空行影水行随故。或随逐义是随眠义。如油在麻腻在抟故。或随增义是随眠义。谓于五取蕴由所缘相应而随增故。言随增者。谓随所缘及相应门而增长故。如是七种随眠。由界行相部差别故。成九十八随眠。谓欲界见苦所断具十随眠。即有身见边执见邪见见取戒禁取疑贪嗔慢无明。见集所断有七随眠。于前十中除有身见边执见戒禁取。见灭所灭所断有七随眠亦尔。见道所断有八随眠。谓即前七加戒禁取。修所断有四随眠。谓贪嗔慢无明。如是欲界有三十六随眠。色界有三十一随眠。谓于欲界三十六中除五部嗔。无色界亦尔。故有九十八随眠。于中八十八见所断。十修所断。三十三是遍行。谓界界中见苦集所断诸见疑。及彼相应不共无明。余皆非遍行。十八是无漏缘。谓界界中见灭道所断邪见疑。及彼相应不共无明。此十八种缘灭道故名无漏缘。余皆有漏缘。此中有漏缘者。由所缘相应故随增。无漏缘者。但于自聚由相应故随增。九是无为缘。谓界中见灭所断邪见疑。及彼相应不共无明。缘灭谛故名无为缘。余皆有为缘。十种随眠次第生者。先由无明于谛不了。谓苦于不欲乃至于道不欲。由不了故次引生疑。谓闻邪正二品便怀犹豫。为苦非苦乃至为道非道。从此犹豫引生邪见。谓恶友由邪闻思生邪决定。无施与无爱乐无祠祀。乃至广说。从此邪见有身见生。谓取蕴中拨无苦理。便执有我或有我所。从有身见边执见生。谓执我有断常边故。从边执见戒禁取生。谓此边执为能净故。从戒禁取引见取生。谓能净者是最胜故。从此见取次引贪生。谓自见中情深爱故。从此贪后次引慢生谓自见中深着己。恃生高举凌篾他故。从此慢后次引嗔生。谓恃己见于他见中情不能忍必憎嫌故。或于自见取舍位中。起。憎嫌故。十种随眠次第如是。由三因缘起诸烦恼。一未断随眠故。二非理作意故。三境界现前故。由因加行境界三力烦恼现前。此说具者。亦有唯依境界力起。烦乱遍恼身心相续。故名烦恼。此即随眠

随烦恼者。即诸烦恼亦名随烦恼。复有随烦恼。谓余一切行蕴所摄染污心所。与诸烦恼同蕴摄故。此复云何。谓诳憍害恼恨谄等有无量种如圣教说。诳谓惑他。憍谓染着自身所有色力族姓净戒多闻巧辩等已。令心傲逸无所顾性。害谓于他能为逼迫。由此能行打骂等事。恼谓坚执诸有罪事。由此不受如理谏诲。恨谓于忿所缘事中。数数寻思结怨不舍。谄谓心曲。如是六种从烦恼生。秽污相粗名烦恼垢。于此六种烦恼垢中。诳憍二种是贪等流。贪种类故。害恨二种是嗔等流。嗔种类故。恼垢即是见取等流。执已见胜者恼乱自他故。谄垢即是诸见等流。诸见增多谄曲故。如说谄曲谓诸恶见。此垢及缠并余染污行蕴所摄。诸心所法从烦恼生。故皆名随烦恼

缠有十种。谓惛沉睡眠掉举恶作嫉悭无惭无愧忿覆。身心相续无堪任性名为惛沈。是昧重义。不能任持。身心相续令心昧略。名为睡眠。此得缠名。唯依染污。掉举谓令心不寂静。恶所作体名为恶作。有别心所缘恶作生立恶作名。是追悔义。此于果体假立因名。如缘空名空缘不净名不净。世间亦以处而说。依处者。如言一切村邑来等。此立缠名。亦唯依染。嫉悭二相结中已说。于诸功德及有德者令心不敬。说名无惭。即是恭敬所敌对法。于诸罪中不见怖畏。说名无愧。能招恶趣。善士所诃说名为罪。除嗔及害。于情非情令心愤发。说名为忿。隐藏自罪说名为覆。此十缠缚身心相续。故名为缠。此中惛沉睡眠无愧是无明等流。恶作是疑等流。无惭悭掉举是贪等流。嫉忿是嗔等流。覆是贪无明等流。诸心所法行相微细。一一相续分别尚难。况一刹那俱时而有。微密智者依佛所说。观果差别知其性异。为诸学者无倒宣说。有劣慧者未亲承事无倒解释佛语诸师。故于心所迷谬诽拨。或说唯三或全非有

漏有三种。谓欲漏有漏无明漏。欲界烦恼并缠除无明名欲漏。有四十一物。谓三十一随眠并十缠。色无色界烦恼并缠除无明名有漏。有五十四物。谓上二界各二十六随眠。并惛沉掉举同无记故。内门转故。依定地故。二界合立一有漏名。三界无明名无明漏。有十五物以无明是诸有本故。别立漏等。稽留有情久住三界。障趣解脱故名为漏。或令流转从有顶天至无间狱。故名为漏。或彼相续于六疮门泄过无穷。故名为漏

瀑流有四。谓欲有见无明瀑流。欲漏中除见名欲瀑流。有二十九物。有漏中除见名有瀑流。有三十物。三界诸见名见瀑流。有三十六物。三界相应不共无明名无明瀑流。有十五物。漂夺一切有情胜事。故名瀑流。如水瀑流。轭有四种。如瀑流说。和合有情令于诸趣诸生诸地受苦。故名为轭。即是和合令受种种轻重苦义

说一切有部入阿毗达磨论卷上入阿毗达磨论卷下

        塞建陀罗阿罗汉造

        三藏法师玄奘奉　诏译

取有四种。谓欲取见取戒禁取我语取。即欲瀑流加无明名欲取。有三十四物。谓贪嗔慢无明各五疑四缠十。即有瀑流加无明名我语取。有四十物。谓贪慢无明各十疑八及惛沉掉举。诸见中除戒禁取余名见取。有三十物。戒禁取名戒禁取。有六物。由此独处圣道怨故。双诳在家出家众故。于五见中此别立取。谓在家众由此诳惑。计自饿服气及坠山岩等为天道故。诸出家众由此诳惑。计舍可爱境受杜多功德为净道故。薪义是取义。能令业火炽然相续而生长故。如有薪故火得炽然。如是有烦恼故有情业得生长。又猛利义是取义。或缠裹义是取义。如蚕处茧自缠而死。如是有情四取所缠。流转生死丧失慧命。身系有四种。谓贪欲身系。嗔恚身系。戒禁取身系。此实执身系。欲界五部贪名初身系。五部嗔名第二身系。六戒禁取名第三身系。十二见取名第四身系。种种缠缚有情自缠故名身系。是等罥网有情身义

盖有五种。谓贪欲盖嗔恚盖惛沉睡眠盖掉举恶作盖疑盖。欲界五部贪名初盖。五部嗔名第二盖。欲界惛沈及不善睡眠名第三盖。欲界掉举及不善恶作名第四盖。欲界四部疑名第五盖。覆障圣道及离欲染并此二种加行善根。故名为盖

前说诸界诸趣。诸生诸地。受苦应说。云何界趣生。地界有三种。谓欲界色界无色界。欲界有二十处。谓八大地狱。一等活。二黑绳。三众合四号叫五大号叫。六炎热七极炎热。八无间。并傍生鬼界为十。有四洲人一赡部洲。二胜身洲。三牛货洲。四俱卢洲。有六欲天。一四大王众天。二三十三天。三夜摩天。四睹史多天五乐变化天。六他化自在天。合二十处。色界有十六处。谓初静虑有二处。一梵众天。二梵辅天。第二静虑有三天。一少光天。二无量光天。三极光净天。第三静虑有三天。一少净天。二无量净天。三遍净天。第四静虑有八天。一无云天。二福生天。三广果天。四无烦天。五无热天。六善现天。七善见天。八色究竟天。合十六处。大梵无想无别处所故非十八。无色界虽无上下处所。而有四种生处差别。一空无边处。二识无边处。三无所有处。四非想非非想处。趣有五种。一奈洛迦。二傍生。三鬼界。四天。五人。生有四种。谓卵胎湿化。地有十一。谓欲界未至静虑中间四静虑四无色为十一地。欲界有顶一向有漏。余九地通有漏及无漏前。界趣生一向有漏

智有十种。谓法智。类智。世俗智。他心智。苦智。集智。灭智。道智。尽智。无生智。于欲界诸行及彼因灭加行无间解脱胜进道。并法智地中所有无漏智名法智。无始时来常怀我执。今创见法故名法智。于色无色界诸行及彼因灭加行无间解脱胜进道。并类智地中所有无漏智名类智。随法智生故名类智。诸有漏慧名世俗智。此智多于瓶衣等世俗事转故。名世俗智。此有二种。一染污。二不染污。染污者复有二种。一见性。二非见性。见性有五。谓有身见。边执见。邪见。见取。戒禁取。非见者。谓疑贪嗔慢无明忿害等相应慧。不染污者。亦有二种。一善。二无覆无记。无覆无记者。非见不推度故。是慧及智。善者若五识俱。亦非见是慧及智。若意识俱。是世俗正见亦慧亦智。诸定生智能了知他欲色界系。一分无漏现在相似心心所法名他心智。此有二种。一有漏。二无漏。有漏者。能了知他欲色界系心心所法。无漏者有二种。一法智品。二类智品。法智品者。知法智品心心所法。类智品者。知类智品心心所法。此智不知色无为心不相应行。及过去未来无色界系。一切根地补特伽罗胜心心所皆不能知。于五取蕴果分有无漏智。作非常苦空非我行相转名苦智。于五取蕴因分有无漏智。作因集生缘行相转名集智。于彼灭有无漏智。作灭静妙离行相转名灭智。于彼对治得涅槃道有无漏智。作道如行出行相转名道智。有无漏智作是思惟。苦我已知。集我已断。灭我已证。道我已修。尽行相转名尽智。有无漏智作是思惟。苦我已知不复更知。乃至道我已修不复更修。无生行相转名无生智。此后二智不推度故非见性。他心智唯见性。余六智通见性非见性。世俗智唯有漏。他心智通有漏及无漏。余八智唯无漏。灭智唯无为缘。他心苦集道智唯有为缘。余五智通有为无为缘。苦集智唯有漏缘。灭道智唯无漏缘。余六智通有漏无漏缘。法智在六地。谓四静虑未至中间。类智在九地。谓前六地下三无色。他心智在四地。谓四静虑。世俗智在一切地。余六智法智品者在六地。类智品者在九地

忍有八种。谓苦集灭道。法智忍及苦集灭道类智忍。此八是能引决定智胜慧。忍可苦等四圣谛理。故名为忍。于诸忍中此八唯是观察法忍。是见及慧非智自性。决定义是智义。此八推度意乐未息。未能审决故不名智。苦法智忍与欲界见苦所断十随眠得俱灭。苦法智与彼断得俱生。忍为无间道。智为解脱道。对治欲界见苦所断十种随眠。如有二人。一在舍内驱贼令出。一关闭门不令复入。苦类智忍与色无色界见苦所断十八随眠得俱灭。苦类智与彼断得俱生。余如前说。如是四心能于三界苦谛现观于集灭道各有四心。应知亦尔。此十六心能于三界四谛现观。断见所断八十八结得预流果。余修所断十种随眠。谓欲界四色无色界各三为十。欲界四种譬如束芦。总分为九。谓从上上乃至下下。彼对治道无间解脱亦有九品。谓下下品道能对治上上品随眠。乃至上上品道能对治下下品随眠。六品尽时得一来果。九品尽时得不还果。如欲界四总分为九。亦有九品无间解脱能对治道。色无色界各有四地。一一地中能治所治。各有九品应知亦然。渐次断彼八地随眠。乃至有顶下下品尽时得阿罗汉果。四果中间所有诸道。及前见道名为四向。随在彼果前。即名彼果向。如是有八补特伽罗。谓行四向及住四果。如是向果由种性别分为六种。谓钝利根种性异生。若入见道十五心须名随信行及随法行。即此二种至修道位。谓从第十六心乃至金刚喻定。名信胜解及名见至。即此二种至无学位。谓从初尽智乃至最后心。名时解脱及不时解脱等。谓心所种类差别有无量种。依心有故名心所法。犹如我所。如是心所名相应行

不相应行与此相违。谓诸得等。得谓称说有法者。因法有三种。一净。二不净。三无记。净谓信等。不净谓贪等。无记谓化心等。若成此法名有法。者称说此定因。名得获成就。得若无者。贪等烦恼现在前时。有学既无。无漏心故。应非圣者。异生若起善无记心。尔时应名已离染者。又诸圣者与诸异生无涅槃得。互相似故应俱名异生。或俱名圣者。如法王说。起得成就十无学法故名圣者。永断五支。乃至广说。又世尊说。苾刍当知。若有成就善不善法。我见如是诸有情类。心相续中善不善得增长无边。作如是说。汝等苾刍。不应校量有情胜劣。不应妄取补特伽罗德量浅深。乃至广说。故知法外定有实得。此有二种。一者未得已失今获。二者得已不失成就。应知非得与此相违。于何法中有得非得。于自相续及二灭中有得非得。非他相续。无有成就他身法故。非非相续。无有成就非情法故。亦非虚空。无有成就虚空者故。彼得无故非得亦无。得有三种。一者如影随形得。二者如牛王引前得。三者如犊子随后得。初得多分如无覆无记法。第二得多分如上地没生欲界结生时欲界善法得。第三得多分如闻思所成慧等。除俱生所余得。此中应作略毗婆娑。谓欲界系善不善色无前生得。但有俱生及随后得。除眼耳通慧及能变化心。并除少分。若威仪路若工巧处极数习者。诸余一切无覆无记法。及有覆无记表色。唯有俱生得。势力劣故无前后得。所余诸法一一容有前后俱得。善法得唯善。不善法得唯不善。无记法得唯无记。欲界法得唯欲界。色界法得唯色界。无色界法得唯无色界。无漏法得通三界及无漏法。无漏法者。谓道谛三无为。俱不系故。道谛得唯无漏非择灭得通三界。择灭得色无色界。道力起者即堕彼界。无漏道力起者是无漏故。无漏法得总说有四种。学法得唯学。无学法得唯无学。非学非无学法得有三种。非学非无学法者。谓诸有漏及无为有漏。及非择灭得唯非学非无学。择灭得学道力起者唯学。无学道力起者唯无学。世间道力起者。唯非学非无学。见所断法得唯见所断。修所断法得唯修所断。非所断法得有三种。谓修所断及非所断。非所断法者。谓道谛及无为。道谛得唯非所断。非择灭得唯修所断。不染污故。是有漏故。故择灭得。世间道力起者。唯修所断。无漏道力起者唯非所断。一切非得皆唯无覆无记性摄。非如前得有差别义。然过去未来法一一各有三世非得。现在法无现在非得。得与非得性相违故。无有现在可成就法。不成就故。然有过去未来非得。欲色无色界及无漏法一一皆有三界非得。无有非得是无漏者。非得中有异生性故。如说。云何异生性。谓不获圣法。不获即是非得异名。又诸非得唯无记性。故非无漏

已离第三静虑染。未离第四静虑染。第四静虑地心心所灭。有不相应法名无想定。虽灭一切心心所法而起此定。专为除想故名无想。如他心智。此无想定是善第四静虑所摄。唯非圣者相续中起求解脱想。起此定故。圣者于此如恶趣想深心厌离。此唯顺定受。谓顺次生受。是加行得非离染得灭定者。谓已离无所有处染。有顶心心所法灭。有不相应法。能令大种平等相续。故名为定灭。是有顶地加行善摄。或顺次生受。或顺后次受。或顺不定受。起此定已未得异熟便般涅槃。故不定受。此定能感有顶地中四蕴异熟。彼无色故。圣者能起非诸异生。由圣道力起此定故。圣者为得现法乐住求起此定。异生于此怖畏断灭。无圣道力故不能起。圣者于此由加行得非离染得。唯佛世尊于此灭定名离染得。初尽智时已于此定能自在起。故名为得。诸佛功德不由加行。随欲即起现在前故。若生无想有情天中。有法能令心心所灭。名无想事。是实有物。是无想定异熟果故。名异熟生。无记性摄。即广果天中有一胜处。如中间静虑名无情天。生时死时俱有心想。中间无故立无想名。彼将死时如久睡觉还起心想。起已不久即便命终。生于欲界。将生彼者必有欲界顺后次受决定业故。如将生彼北俱卢洲。必有能感生天之业

先业所引六处相续无间断因。依之施设四生五趣。是名命根亦名为寿。故对法说。云何命根。谓三界寿。此有实体能持暖识。如伽他言

  寿暖及与识　　三法舍身时
  所舍身僵仆　　如木无思觉

契经亦说。受异熟已名那落迦。乃至非想非非想处应知亦尔。若异命根无别有法。是根性摄。遍在三界。一期相续无间断时。可依施设四生五趣。生无色界起自上地善染污心。或起下地无漏心时依何施设。化生天趣起善染时应名为死若起无记应复名生。拨无命根有斯大过。诸有情类同作事业同乐欲因。名众同分。此复二种。一无差别。二有差别。无差别者。谓诸有情皆有我爱。同资于食乐欲相似。此平等因名众同分。一一身内各别有一。有差别者。谓诸有情界地趣生。种姓男女近事苾刍。学无学等种类差别。一一身内有同事业。乐欲定因名众同分。此若无者。圣非圣等世俗言说应皆杂乱。诸异生性异生同分有何差别。同乐欲等因。说名彼同分。异生性者。能为一切无义利因。如契经说。苾刍当知。我说愚夫无闻异生。无有少分恶不善业。彼不能造。又世尊说。若来人中得人同分。异生性于死生时。有舍得义。故异生性与同分别

诸法生时有内因力。令彼获得各别功能。即此内因说名生相。谓法生因总有二种。一内。二外。内谓生相。外谓六因。或四缘性。若无生相。诸有为法应如虚空等。虽具外因缘亦无生义。或应虚空等亦有可生义成有为性。是大过失。由此故知。别有生相能引别果。暂时住因说名住相。谓有为法于暂住时各有势力。能引别果令暂时住。此引别果势力内因说名住相。若无住相。诸有为法于暂住时。应更不能引于别果。由此故知有别住相。老谓衰损。引果功能令其不能重引别果。谓有为法若无异相。衰损功能何缘不能引别果。已更不重引。引而复引应成无穷。若尔又应非刹那性。由此故知别有异相。无常者谓功能损已。令现在法入过去因。谓有别法名为灭相。令从现在堕过去世。此若无者法应不灭。或虚空等亦有灭义。此四有为之有为相。若有此四有为相者。便名有为。非虚空等。然世尊说。有三有为之有为相。有为之起亦可了知。尽及住异亦可了知。为所化生厌有为故。如示黑耳与吉祥俱。住异二相合说为一。是故定有四有为相。非即所相有为法体。若即所相有为体者。如所相体与能相一。能相亦应展转无异若尔诸法灭时应生。生时应灭。或全不生。此四本相。是有为故。如所相法有四随相。谓名生生乃至灭灭。然非无穷。以四本相各相八法随相唯能各相一故。谓法生时并其自体九法俱起。自体为一相随相八。本相中生。除其自体生余八法。随相中生于九法内唯生本生。势力劣故。住异灭相应知亦尔。本相依法。随相依随相。法因相故得有作因。相因随相得有作用。作用者何。谓生住异灭。所生等者。谓引果功能。故有为法体虽恒有而用非常。假兹四相内外因力。用得成故名身句身。文身等者。谓依语生。如智带义影像而现。能诠自义名名句文。即是想章字之异目。如眼识等依眼等生。带色等义影像而现。能了自境名等亦尔。非即语音亲能诠义。勿说火时便烧于口。要依语故火等名生。由火等名诠火等义。诠者谓能于所显义生他觉慧。非与义合。声有碍故。诸记论者所执常声理不成故。不应离此名句文三。可执有法能诠于义。然四种法似同一相。一声二名三义四智。此中名者。谓色等想。句者谓能诠义究竟。如说。诸恶莫作等颂。世间亦说。提婆达多驱白牛来构取乳等。文者即是[褒-保+可]壹等字。此三各别合集同类说之为身。如大仙说。苾刍当知。如来出世便有名身句身文身可了知者。意说谛实蕴处界。沙门果缘起等法名句文身。又世尊说。如来得彼彼名句文身者。意说如来获得彼彼不共佛法名句文身等。谓此中义类差别诸行句义。齐此应知。识句义者。谓总了别色等境事故名为识。即于色等六种境中。由眼等根伴助而起现在作用。唯总分别色等境事说名为识。若能分别差别相者。即名受等诸心所法。识无彼用但作所依。识用但于现在世有一刹那顷。能有了别。此亦名意。亦名为心。亦是施设有情本事。于色等境了别为用。由根境别说有六种。谓名眼识乃至意识。佛于经中自说彼相。谓能了别故立识名。由此故知了别为相

前于思择有为相中。说法生因总有二种。一内。二外。内谓生相。外谓六因。或四缘性。今应思择。因缘者何。因有六种。一相应因。二俱有因。三同类因。四遍行因。五异熟因。六能作因。心心所法展转相应。同取一境名相应因。如心与受等。受等与受等。受等复与心。各除其自性。诸有为法更互为果。或同一果。名俱有因。如诸大种所相能相。心心随转更互相望。二因别者。如诸商人更相助力能过崄路。是俱有因。诸所饮食展转同义。是相应因。心随转者。谓诸心所及诸静虑无漏律仪诸有为相。以彼与心俱堕一世一起一住一灭一果一等流一异熟因善因不善因无记。由此十因名心随转。自地自部前生诸法。如种子法。与后相似为同类因。自地前生诸遍行法。与后染法为遍行因。一切不善有漏善法。与自异熟为异熟因。诸法生时除其自性。以一切法为能作因。或唯无障。或能生故。如是六因总以一切有为果。为是所生故。谓相应俱有因得士用果。由此势力彼得生故。此名士用。彼名为果。同类遍行因得等流果。果似因故说名为等。从因生故复说为流。果即等流名等流果。异熟因得异熟果。果不似因故说为异熟。谓成熟堪受用故。果即异熟名异熟果。唯有情数摄。无覆无记性。能作因得增上果。此增上力彼得生故。如眼根等于眼识等。及田夫等于稼穑等。由前增上后法得生。增上之果名增上果。择灭无为名离系果。此由道得非道所生。果即离系名离系果。缘有四种。谓因。等无间。所缘。增上缘。除能作余五因名因缘。过去现在心心所法。除阿罗汉最后心等。名等无间缘。一切法名所缘缘。能作因性名增上缘

容有碍物是虚空相。此增上力彼得生故。能有所容受是虚空性故。此若无者。诸有碍物应不得生。无容者故。如世尊说。梵志当知。风依虚空。婆罗门曰。虚空依何。佛复告言。汝问非理。虚空无色无见无对。当何所依。然有光明虚空可了。故知实有虚空无为。此体若无风何依住。说无色等言何所依。因有光明何所了别。了龟毛等。不因比故

众苦永断说名择灭。众苦者何。谓诸生死。如世尊说。苾刍当知。诸有若生即说为苦。诸有即是生死别名。有若不生名苦永断。如堤堰水。如壁障风。令苦不生名为择灭。择谓拣择即胜善慧。于四圣谛数数简择。彼所得灭立择灭名。此随所断体有无量。以所断法量无边故。若体一者初道已得。修后诸道便应无用。若言初证少分非全。即一灭体应有多分。一体多分与理相违。随有漏法有尔所量择灭无为应知亦尔。此说为善。应正理故。此随道别立八十九。随断遍知立有九种。若随五部立有五种。又随果别总立为四。谓预流等。由断离灭界别立三。由断苦集及有余依无余依别总立二种。约生死断总立为一。如是择灭有多异名。谓名尽离灭涅槃等。如人经说。苾刍当知。四无色蕴及眼色等总名为人。于中假想说名有情。亦名意生。亦名为人摩纳婆等。此中自谓我眼等见色等。发起种种世俗言论。谓此具寿有如是名如是族姓。乃至广说。苾刍当知。此唯有想唯有言说。如是诸法皆是无常。有为缘生由此故苦。谓生时苦住等亦苦。于此众苦永断无余。除弃变吐尽离染灭寂静隐没。余不续起名永不生。此极静妙。谓一切依除弃爱尽离灭涅槃。所言一切依除弃者。谓此灭中永舍一切五取蕴苦。言爱尽者。谓此灭中现尽诸爱。得此灭已永离染法故名为离。获此灭已众苦皆息故名为灭。证此灭已一切灾患烦恼火灭故名涅槃

非择灭者。谓有别法毕竟障碍未来法生。但由阙缘非由择得。如眼与意专一色时。余色声香味触等谢。缘彼境界五识身等。由得此灭能永障故。住未来世毕竟不生。缘阙亦由此灭势力。故非择灭决定实有。如世尊说。若于尔时乐受现前二受便灭。彼言灭者。除此是何。定非无常及择灭故。又契经说。苾刍当知。若得预流。已尽地狱。已尽鬼界。已尽傍生。此言尽者是非择灭。尔时异熟法未得择灭故。为初业者爱乐勤学。离诸问答略制斯论。诸未遍知阿毗达磨深密相者。随自意集诸戏论聚置于现前。妄构邪难欲相诽毁。彼即谤佛所说至教。如世尊说。有二种人谤佛至教。一者不信生于憎嫉。二者虽信而恶受持

说一切有部入阿毗达磨论卷下


萨婆多宗五事论

    No. 1556 [cf. No. 1555]

萨婆多宗五事论

        大番国大德三藏法师沙门法成于甘州修多寺道场

法有五种。一者色法。二者心法。三者心所有法。四者心不相应行法。五者无为法。何名色法。谓彼一切从四大种。四大所造所生诸色。何谓四大。地界水界火界风界。何名造色。谓眼根耳根鼻根舌根身根。诸色诸声诸香诸味及触一分兼无表色

何名心法。谓心意识。彼复云何谓眼识耳鼻舌身意识六识之身。何名心所有法。谓与心相应诸法。彼复云何。谓受。相。思。触。作意。欲。胜解。信。精进。念。定。慧。寻。伺。放逸。不放逸。善根。不善根。无记根。诸结。系缚。微广。诸随烦恼。缠绕安住。知。见。所有现观。复有余法。与心相应如是等类。名为心所有法。何名心不相应行法。谓有诸法与心不相应。彼复云何。谓得。无相等至。灭尽等至。无相所有。命根。众同分。得处所。得事。得处。生。老。住。无常性。名身。句身。及以文身。复有余法与心不相应。如是等类。名为心不相应行法

何名无为法。谓三种无为。虚空。非择灭。及以择灭。此名无为法。云何地界。谓坚硬性。云何水界。谓薄润性。云何火界谓热瞹性。云何风界。谓轻动性。云何眼根。谓眼识依清净色。云何耳根。谓耳识依清净色。云何鼻根。谓鼻识依清净色。云何舌根。谓舌识依清净色。云何身根。谓身识依清净色。云何诸色。谓诸好色及非好色。彼二中间所住诸色及显色等。最初一识眼识所知。眼识所受。意识能知。是故诸色眼识意识二识了知。云何诸声。声有二种。谓执受大种因所生。及非执受大种因所生。最初一识耳识所知。耳识所受。意识能知。是故诸声耳识意识二识了知。云何诸香。谓好香恶香平等了香。最初一识鼻识所知。鼻识所受。意识能知。是故诸香鼻识意识二识了知。云何诸味。谓可意及非可意平等尝味。最初一识舌识所知。舌识所受。意识能知。是故诸味舌识意识二识了知。云何所触一分。谓滑性。涩性。轻性。重性。冷饥渴等。最初一识身识所知。身识所受。意识能知。是故诸触一分身识意识二识了知。何等名为诸无表色。谓法处所摄色。于一切时唯一意识之所了知知。云何眼识。依于眼根。各别了色。云何耳识。依于耳根。各别了声。云何鼻识。依于鼻根。各别了香。云何舌识。依于舌根。各别了味。云何身识。依于身根。各别了触。云何意识。依于意根。各别了法

云何为受。谓领纳性。此复三种。谓苦乐不苦不乐。云何为相。谓遍知性。此复三种。小大无量。云何为思。谓心造行意所作业。此复三种。谓善不善及以无记。云何为触。谓三和合。此复三种。受乐受苦。及受不苦不乐。云何作意。谓心所转。此复三种。谓学无学非学非无学。云何为欲。谓乐作性。云何胜解。谓心所乐乐性乐作。云何为信。谓心极净。云何精进。谓心欣乐。云何为念。心明记性。云何为定。心一境性。云何为慧。谓决择法。云何为寻。心廉为性。云何为伺。心细为性。云何放逸。不修诸善。云何不放逸。谓修诸善。诸善根者。谓三善根。无贪善根。无嗔善根。无痴善根。不善根者。三不善根。贪不善根。嗔不善根。痴不善根。无记根者。四无记根。谓无记爱见慢无明。云何无记爱。谓色无色五种所作。云何无记见。谓欲界中所行身见及以边见。色无色中所行五见。云何无记慢。谓色无色五种所行。云何无记无明。谓欲界中所行身见及以边见相应无明。色无色中五种所行。言诸结者。谓九种结。贪结恚结慢结无明结见结胜执结疑结疾结悭结。云何贪结。谓三界贪。云何恚结。依诸有情忿恨为性。云何慢结。谓七种慢名为慢结。谓慢。过慢。慢过慢。我慢。增上慢。卑慢。邪慢。云何为慢于劣计胜于等计等彼以为因。慢持慢性心之高举。心之所骜。心之所执。此名为慢。云何过慢。于等计已。胜或于胜计。已等彼以为因。慢特慢性心之高举。心之所傲。心之所执。此名慢过慢

云何我慢。谓于五取蕴随观为我。或为我所。彼以为因慢恃慢性。心之高举。心之所骜。心之所执。此名我慢。云何增上慢。谓于未得上之殊胜计已谓得上之殊胜或未证触亦未现前上之殊胜计已证明彼以为因。慢恃慢性心之高举。心之所傲。心之所执。此名增上慢。云何卑慢。谓于多分殊胜计已少分下劣。彼以为因。慢恃慢性。心之高举。心之所傲。心之所执。此名卑慢。云何邪慢。谓具非德计已具德彼以为因。慢恃慢性。心之高举。心之所骜。心之所执。此名邪慢。此七种慢名为慢结。云何无明结。谓三界无知。此名无明结。云何见结。谓三种结名为见结。云何为三。一身见。二边执见。三邪见。云何身见。谓于五取蕴随观为我。或为我所。彼以为因。忍乐慧观。及以所见此名身见。云何边执见。谓于五取蕴随观断常。彼以为因。忍乐慧观及以所见此名边执见。云何邪见。谓谤因果及以作用坏有之事彼以为因。忍乐慧观及以所见此名邪见。此三种见名为见结。云何胜执结。二种胜执名胜执结。云何为二。一见胜执。二戒禁胜执。云何见胜执。谓于五取蕴随观。为最为上为胜为极彼以为因。忍乐慧观及以所见此名胜执见。云何戒禁胜取。谓于五取蕴随观为净为解脱为出离彼以为因。忍乐慧观及以所见此名戒禁胜取。此二种胜取名胜执结。云何疑结。谓于诸谛犹豫为性。云何疾结。心乱为性。云何悭结。心执为性。是故说为诸结。言系缚者。所说诸结。彼亦名缚。然缚有三种。谓贪缚嗔缚痴缚故说为缚。言微广者。谓七微广。云何为七。一贪微广。二嗔微广。三有欲微广。四慢微广。五无明微广。六见微广。七疑微广。云何贪微广。五种微广名贪微广。云何为五。谓欲界所系见苦所断所有贪欲。欲界所系见集灭道。及修所断所有贪欲。此五微广名贪微广。云何嗔微广此五种

微广名嗔微广。云何为五。谓见苦所断所有嗔恚。见集灭道及修所断所有嗔恚。此五微广名嗔微广。云何有欲微广。此十微广名有欲微广。云何为十。谓色系五。无色系五。云何名为有贪微广。色界系五。谓色界系见苦所断所有请欲。及色界系见集灭道及修所断所有贪欲。如色系五。无色系五。亦复如是。此十微广名有欲微广。云何慢微广。此十五种微广名慢微广。云何为十五。谓欲系五。色界系五。无色界系五。何等名为欲界所系五种慢微广。谓欲界系见苦所断所有诸慢。欲界所系见集灭道及修所断所有诸慢。如欲系五。色界系五。无色系五。亦复如是。此十五种微广名慢微广。云何无明微广。此十五种微广为无明微广。何等十五。谓欲系五。色界系五。无色系五。云何名为欲界所系五种慢微广。谓欲所系见苦所断所有光明。欲界所系见集灭道及修所断所有光明。如欲系五。色界系五。无色系五。亦复如是。此十五种微广名无明微广。云何见微广。谓三十六微广名见微广。何等为三十六。谓欲系十二。色系十二。无色系十二。何等名为欲界所系十二见微广。谓欲界系身见边见。欲界所系见苦所断所有邪见及以见取。欲界所系见灭所断所有邪见及以见取。欲界所系见道所断所有邪见及以见取执禁戒取。如欲界所系十二。色系十二。无色系十二。亦复如是。此三十六微广名见微广。云何疑微广。十二种微广名疑微广。何等十二。谓欲系四。色界系四。无色系四。云何名为欲界所系四疑微广。谓欲界系见苦断疑

欲界所系见集灭道所断诸疑。如欲界系。色界系四。无色系四。亦复如是。此十二种微广名疑微广。故说名微广。言诸随烦恼者。所有微广彼则名为诸随烦恼。有是随烦恼非微广。谓除微广余心所生。染污行蕴。缠绕安住者。谓八种缠绕安住。云何为八。一惛沈。二睡眠。三掉举。四恶作。五疾妒。六悭吝。七无惭。八无愧。是故说名缠绕安住。言知者谓十种智。何等为十。一法智。二随类智。三他心智。四世俗智。五苦智。六集智。七灭智。八道智。九尽智。十无生智。云何法智。谓欲系诸行了无漏智。欲系行因无漏诸智。欲系行灭无漏诸智。欲界系行断道之中无漏诸智。复次法智。法智地中无漏诸智。此名法智。云何随类智。色无色系诸行之中无漏诸智。色无色系诸行目中无漏诸智。色无色系行灭之中无漏诸智。色无色系行断道中无漏诸智。复次随所了智。随了地中无漏诸智。此等名为随类智。云何他心智。从修生智。所修之果。依于所修所得无退。以其智慧。了欲所行及色所行似他心心法。证得现前了无漏法一分。此等名为了他心智。云何世俗智。谓有漏智此名世俗智。云何苦智。于五取蕴了无常性。苦性。空性。无我之性。作意所生无漏之智。此名苦智。云何集智。于有漏因而起。因集生缘作意无漏之智此名集智。云何灭智。谓于灭中起灭。静妙出离作意。无漏之智此名灭智。云何道智。谓于道中起于道。如行出作意无漏之智此名道智。云何尽智。谓自遍了知若自知断集。自知证灭。自知修道。以为其因。知见觉慧了知分明。现前证得。此名尽智。云何无生智。谓自遍了知诸苦故。更无可知之智自断集故。更无可断之智。自证灭故。更无可证之智。自修道故。更无可修之智。以为其因。知见觉慧了知分明。现前证得此名无生智。言见者。虽则彼智亦是其见亦复有见。非即是智。从现观边所生八忍。谓知苦法忍。知苦随类忍。知集法忍。知集随类忍。知灭法忍。知灭随类忍。知道法忍。知道随类忍。故说名见。言所有现观者。即彼知见亦是现观是故说为现观

云何为得。谓诸法所获。云何无想等至。谓已离遍净贪。未离上贪。由出离想作意。为先心心法灭为性。云何灭尽等至。谓已离无所有处贪。由止息想作意为先心心法灭为性。云何无想所有。谓生无想有情天中心心法灭为性。云何命根。谓三界寿。云何众同分。谓诸有情自类相似。云何得处所。谓获诸境。云何得事。谓获诸蕴。云何得处。谓获内外处。云何为生。谓成就蕴。云何为老。谓诸蕴熟。云何为住。谓诸行不坏。云何无常性。谓诸行坏。云何名身。即彼增语。云何句身。谓文圆满。云何文身。即彼字身。名为文身。云何处空。所行之因。即是虚空。非有障碍。诸色种类不能遍覆。此名虚空。云何非择灭。谓灭非离。云何择灭。谓灭亦离。是故说为法有五种。一者色法。二者心法。三者心所有法。四者心不相应行法。五者无为法

五事论一卷


舍利弗阿毗昙论

    No. 1548

    舍利弗阿毗昙论序

        释道摽撰

阿毗昙。秦言无比法。出自八音。亚圣所述。作之虽简。成命曲备。重微旷济。神要莫比。真祇洹之微风。反众流之宏趣。然佛后闇昧。竞执异津。或有我有法。或无我有法。乖忤纯风。亏曚圣道。有舍利弗。玄哲高悟。神贯翼从。德备左面。智参照来。其人以为是非之起。大猷将隐。既曰像法。任之益滞。是以敢于佛前所闻经法。亲承即集。先巡堤防。遮抑邪流。助宣法化。故其为经也。先立章以崇本。后广演以明义。之体四焉。问分也。非问分也。摄相应分也。序分也。问分者。寄言扣击。明夫应会。非问分者。假韵默通。惟宣法相。摄相应分者。总括自他。释非相无。序分者。远述因缘。以彰性空。性空彰则反迷至矣。非相无则相兴用矣。法相宣则邪观息矣。应会明则极无遗矣。四体圆足。二谛义备。故称无比法也。此经于先出阿毗昙。虽文言融通。而旨各异制。又载自空。以明宗极故。能取贵于当时。而垂轨于千载。明典振于远维。四众率尔同仰。是使殉有者袪妄见之惑。向化者起即隆之勋。迢迢焉。故冥宗之遗绪也。亹亹焉。故归轮之所契也。此经标明曩代。灵液西畛。纯教弥于阆风。玄门扇于东岭。唯秦天王。冲资睿圣。冥根树于既往。实相结于皇极。王德应符。阐扬三宝。闻兹典诰。梦想思揽。虽曰悠邈。感之愈勤。会天竺沙门。昙摩耶舍。昙摩掘多等义学。来游秦土。既契宿心。相与辩明经理。起清言于名教之域。散众微于自无之境。超超然。诚韵外之致。愔愔然。覆美称之实。于是诏令传译。然承华天哲。道嗣圣躬。玄味远流。妙度渊极。持体明旨。遂赞其事。经师本虽闇诵。诚宜谨备。以秦弘始九年。命书梵文。至十年寻应令出。但以经趣微远。非徒开言所契。苟彼此不相领悟。直委之译人者。恐津梁之要。未尽于善。停至十六年。经师渐闲秦语。令自宣译。皇储亲管理味言意兼了。复所向尽。然后笔受。即复内呈。上讨其烦重。领其指归。故令文之者修饰。义之者缀润。并校至十七年讫。若乃文外之功。胜契之妙。诚非所阶。未之能详。并求之众经。考之诸论。新异之美。自宣之于文。惟法住之实。如有表里。然原其大体。有无兼用。微文渊富。义旨显灼。斯诚有部之永涂。大乘之靡趣。先达之所宗。后进之可仰。标以近质。综不及远。情未能已。猥参斯典。悕感之诚。脱复微序。庶望贤哲。以恕其鄙

舍利弗阿毗昙论卷第一

        姚秦罽宾三藏昙摩耶舍共昙摩崛多等译

    问分入品第一

问曰。几入。答曰。十二。何等十二。内六入外六入。何等内六入。眼入耳入鼻入舌入身入意入。是名内六入。何等外六入。色入声入香入味入触入法入。是名外六入。如是内六入外六入。是名十二入。云何眼入。眼根是名眼入。云何眼入。眼界是名眼入。云何眼入。若眼我分摄。去来现在。四大所造净色。是名眼入。云何眼入。若眼我分摄。过去未来现在净色。是名眼入。云何眼入。我分摄。已见色今见色当见色不定。若眼我分摄色光。已来今来当来不定。是名眼入。云何眼入。若眼我分摄色已对眼今对当对不定。若眼无碍。是眼入是眼根是眼界。是田是物。是门是藏。是世是净。是泉是海。是沃燋是洄澓是疮是系。是目是入我分。是此岸。是内入。眼见色。是名眼入。耳鼻舌身入亦如是。云何意入。意根是名意入。云何意入。识阴是名意入。云何意入。心意识六识身七识界。是名意入。云何意入。若识过去未来现在。内外粗细。卑胜远近。是名意入。云何六识身。眼识身耳鼻舌身意识身。云何眼识身。缘眼缘色缘明缘思惟。以此四缘生识。已生今生当生不定。是名眼识身。云何耳鼻舌身意识身。缘意缘法缘思惟。以此三缘识已生今生当生不定。是名意识身。是名六识身。云何七识界。眼识界耳鼻舌身识界意界意识界。云何眼识界。若识眼根主色境界。已生今生当生不定。是名眼识界。云何耳鼻舌身识界。若识身根主触境界。已生今生当生不定。是名身识界。云何意界。意知法念法。若初心已生今生当生不定。是名意界。云何意识界。若识相似。不离彼境界。及余相似心。已生今生当生不定。是名意识界。是名七识界。云何过去识。若识已灭。是名过去识。云何未来识。若识未生未出。是名未来识。云何现在识。若心生未灭。是名现在识。云何内识。若识受是名内识。云何外识。若识不受。是名外识。云何粗识。若识欲界系。是名粗识。云何细识。若识色界系无色界系不系。是名细识。云何卑识。若识不善不善法报。若识非报非报法不适意。是名卑识。云何胜识。若识善善法报。若识非报非报法适意。是名胜识。云何远识。若诸识根远极相远不近不近边。是名远识。云何近识。若诸识相近极相近近边。是名近识。云何色入。色界是名色入。云何色入。随行色相。是名色入。云何色入。若色可见有对眼识所知。是名色入。云何色入。若色入业法烦恼所生报我分摄。身好色非好色。姝妙非姝妙。妍肤非妍肤。严净非严净若善心若不善心若无记心。所起去来屈申回转身教。若外色眼识所知。青黄赤白黑紫。粗细长短方圆。水陆光影烟云尘雾气明闇等。及余外色眼识所知。是名色入。云何声入。声界是名声入。云何声入。若色不可见有对。耳识所知。是名声入。云何声入。若声入业法烦恼所生报我分摄。身好声非好声。众妙声非众妙声。软声非软声。若善心不善心无记心所起集。声音句言语口教。若外声耳识所知。贝声大鼓声小鼓声。筝声箜篌声铜钹声。舞声歌声伎乐声悲声。男声女声。人声非人声。众生声非众生声。去声来声。相触声。风声雨声水声。诸大相触声。及余外声。耳识所知。是名声入。云何香入。香界是名香入。云何香入。若色不可见有对。鼻识所知。是名香入。云何香入。若香入业法烦恼所生报我分摄。身好香非好香。软香非软香。适意香非适意香。若外香鼻识所知。树根香。树心香。树胶香。树皮香。华香叶香果香。好香非好香。及余外香鼻识所知。是名香入。云何味入。味界是名味入。云何味入。若色不可见有对。舌识所知。是名味入。云何味入。若味入业法烦恼所生报我分摄。身甜酢苦辛咸淡涎癊。若外味舌识所知。若甜酢。若苦辛咸淡水汁。及余外味舌识所知。是名味入。云何触入。触界是名触入。云何触入。若色不可见有对。身识所知。是名触入。云何触入。若触入业法烦恼所生报我分摄。身冷热轻重粗细涩滑坚软。若外触身识所知。若冷热轻重粗细涩滑坚软。及余外触身识所知。是名触入。云何法入。法界是名法入。云何法入。受想行阴。若色不可见无对。若无为。是名法入。云何法入。受想思触思惟觉观。见慧解脱无贪无恚无痴。顺信悔不悔悦喜心进心除。信欲不放逸。念定心舍疑怖使。生老死命结。无想定得果灭尽定。身口非戒无教。有漏身口戒无教。有漏身进有漏身除。正语正业正命正身进正身除智缘尽非智缘尽决定法住缘。空处智识处智不用处智。非想非非想处智。是名法入十二入几色几非色。十色一非色。一二分或色或非色。云何十色。眼入耳鼻舌身入。色入声香味触入。是名十色。云何一非色。意入是名一非色。云何一二分或色或非色。法入是名一二分或色或非色。云何法入色。身口非戒无教。有漏身口戒无教。有漏身进有漏身除。正语正业正命正身进正身除。是名法入色。云何法入非色。受想乃至灭尽定智缘尽。乃至非想非非想处智。是名法入非色

十二入几可见。几不可见。一可见十一不可见。云何一可见。色入是名一可见。云何十一不可见。九色入意入法入。是名十一不可见。十二入几有对。几无对。十有对二无对。云何十有对。十色入是名十有对。云何二无对。意入法入。是名二无对

十二入几圣几非圣。十非圣二二分。或圣或非圣。云何十非圣。十色入是名十非圣。云何二二分或圣或非圣。意入法入。是名二二分或圣或非圣。云何意入非圣。若意入有漏。是名意入非圣。云何意入非圣。若意识受阴。是名意入非圣。云何意入非圣。若意入非学非无学眼识乃至意识。是名意入非圣。云何意入圣。若意入无漏。是名意入圣。云何意入圣。若意入信根相应意界意识界。是名意入圣。云何意入圣。若意入学无学。学人离结使。圣心入圣道若坚信坚法。及余趣人见行过患。观涅槃寂灭。如实观苦集尽道。未得欲得。未解欲解。未证欲证。离烦恼修道。见学人若须陀洹斯陀含阿那含观智具足。若智地若观解脱心。即证沙门果。若须陀洹果。斯陀含果阿那含果无学人。欲得阿罗汉果。未得圣法欲得。观智具足。若智地若观解脱心。即证阿罗汉果。若实人若趣若意界若意识界。是名意入圣。云何法入非圣。若法入有漏。是名法入非圣。云何法入非圣。受受阴想受阴行受阴。若色不可见无对有漏。若非圣无为。是名法入非圣。云何法入非圣。法入非学非无学受想乃至无想定。初四色非圣七无为。是名法入非圣。云何法入圣。若法入无漏是名法入圣。云何法入圣。若信根信根相应心数法。若法无缘无漏。是名法入圣。云何法入圣。若法入学无学。学人离结使圣心入圣道。若坚信坚法。及余趣人见行过患。观涅槃寂灭道。如实观苦集灭道。未得欲得。未解欲解。未证欲证。离烦恼修道。见学人若须陀洹斯陀含阿那含。观智具足。若智地若观解脱心。即证沙门果。若须陀洹果斯陀含果。若阿那含果无学人。欲得阿罗汉。未得圣法欲得。观智具足若智地若观解脱心。即证阿罗汉果。若实人若趣若受想思触思惟觉观。见慧解脱无痴顺信悦喜心进心除。信欲不放逸。念定心舍得果灭尽定。正语正业正命正身进正身除智缘尽决定。是名法入圣

十二入几有漏几无漏。十有漏。二二分。或有漏或无漏。云何十有漏。十色入是名十有漏。云何二二分或有漏或无漏。意入法入。是名二二分或有漏或无漏。云何意入有漏。若意入有爱。是名意入有漏。云何意入有漏。识受阴是名意入有漏。云何意入有漏。意入非学非无学。眼识乃至意识。是名意入有漏。云何意入无漏。若意入无爱。是名意入无漏。云何意入无漏。若意入信根相应意界意识界。是名意入无漏。云何意入无漏。若意入学若无学。学人离结使乃至即证阿罗汉果。若实人若趣若意界意识界。是名意入无漏。云何法入有漏。若法入有爱。是名法入有漏。云何法入有漏。受受阴想受阴行受阴。若色不可见无对有爱。是名法入有漏。云何法入有漏。若法入非学非无学受想。乃至无想定初四色。是名法入有漏。云何法入无漏。若法入无爱。是名法入无漏。云何法入无漏。若信根信根相应心数法。若法无缘无爱。是名法入无漏。云何法入无漏。若法入学若无学若无为。学人离结使。乃至即证阿罗汉果。若实人若趣若受想思触思惟觉观。见慧解脱无痴顺信悦喜心进心除。信欲不放逸念定心舍得果灭尽定。正语正业正命正身进正身除。智缘尽非智缘尽。决定法住缘。空处智识处智不用处智非想非非想处智。是名法入无漏。有爱无爱。有求无求。当取非当取。有取无取。有胜无胜亦如是

十二入几受几非受。五受。七二分或受或非受。云何五受。眼入耳鼻舌身入。是名五受。云何七二分或受或非受。色入声香味触入意入法入。是名七二分。或受或非受。云何色入受。若色入若内。是名色入受。云何色入受。若色入业法烦恼所生报我分摄。身好色非好色。姝妙非姝妙。妍肤非妍肤。严净非严净。若受心所起去来屈申回转身教。是名色入受云何色入非受。若色入外。是名色入非受。云何色入非受。色入若善不善无记非我分摄。若善心不善心。非报非报法。心所起去来屈申回转。若外色眼识所知。是名色入非受。云何声入受。若声入内声入。是名声入受。云何声入受。若声入业法烦恼所生报我分摄。身好声非好声。众妙声非众妙声。软声非软声受心所起集声音句语言口教。是名声入受云何声入非受。若声入外。是名声入非受。云何声入非受。若声入若善不善无记非我分摄。若善心不善心非报非报法。心所起集声音句言语口教。若外声耳识所知。是名声入非受。云何香入受。若香入内香入。是名香入受。云何香入受。若香入业法烦恼所生报我分摄。身好香非好香。软香非软香。适意香非适意香。是名香入受。云何香入非受。若香入外若外香。鼻识所知。树根香树心香树胶香树皮香。叶香花香果香。好香非好香。及余外香。鼻识所知。是名香入非受。云何味入受。若味入内味入。是名味入受。云何味入受。若味入业法烦恼所生报我分摄。身甜酢苦辛咸淡涎癊。是名味入受。云何味入非受。若味入外若外味。舌识所知。若甜酢若苦辛若咸淡。若水若汁及余外味。舌识所知。是名味入非受。云何触入受。若触入内。是名触入受。云何触入受。若触入业法烦恼所生报我分摄。身冷热轻重粗细涩滑坚软。是名触入受。云何触入非受。若外触入身识所知。若冷若热。若轻若重。若粗若细。若涩若滑。若坚若软。及余外触身识所知。是名触入非受。云何意入受。若意入内。是名意入受。云何意入受。若意入业法烦恼所生报我分摄。眼识乃至意识。是名意入受。云何意入非受。若意入外。是名意入非受。云何意入非受。若意入善不善无记非我分摄。眼识乃至意识。是名意入非受。云何法入受。若法入内。是名法入受。云何法入受。若法入业法烦恼所生报我分摄。受想思触思惟觉观。见慧解脱悔不悔悦喜心进。信欲念怖生命有漏身进。是名法入受。云何法入非受。若法入外。是名法入非受。云何法入非受。若法入善不善无记非我分摄。除命余法入非受。是名法入非受。内外亦如是

十二入几有报几无报。八无报。四二分或有报或无报。云何八无报。眼入耳鼻舌身入香入味入触入。是名八无报。云何四二分或有报或无报。色入声入意入法入。是名四二分或有报或无报。云何色入有报。若色入报法。是名色入有报。云何色入有报。若色入善不善心。善不善心所起去来屈申回转。是名色入有报。云何色入无报。若色入报。若色入非报。非报法。身好色非好色。姝妙非姝妙。妍肤非妍肤。严净非严净。无记心所起去来屈申回转。若外色眼识所知。是名色入无报。云何声入有报。若声入报法。是名声入有报。云何声入有报。声入若善若不善。善心不善心所起集声音句言语口教。是名声入有报。云何声入无报。若声入报。若声入非报非报法。身好声非好声。众妙声非众妙声。软声非软声。若无记心所起集声音句言语口教。若外声耳识所知。是名声入无报。云何意入有报。若意入报法。是名意入有报。云何意入有报。除意入善报。余意入善不善意界意识界。是名意入有报。云何意入无报。若意入报。若意入非报非报法。眼识乃至意识。是名意入无报。云何法入有报。若法入报法。是名法入有报。云何法入有报。除法入善报。余法入善有为。若不善受想乃至烦恼使结。二定法入一切色。是名法入有报。云何法入无报。若法入报法入非报非报法。除无贪无恚无痴烦恼使结身口非戒无教。余法入无报

十二入几心几非心。一心。十一非心。云何一心。意入是名一心。云何十一非心。除意入余非心。是名十一非心

十二入几心相应几非心相应。十非心相应。一不说心相应非心相应。一二分或心相应或非心相应。云何十非心相应。十色入是名十非心相应。云何一不说心相应非心相应。意入是名一不说心相应非心相应。云何一二分或心相应或非心相应。法入是名一二分或心相应或非心相应。云何法入心相应。若法入心数受想乃至烦恼使。是名法入心相应。云何法入非心相应。若法入非心所生。乃至非想非非想处智。是名法入非心相应。十二入几心数几非心数。十一非心数。一二分或心数或非心数。云何十一非心数。十色入意入。是名十一非心数。云何一二分或心数或非心数。法入是名一二分或心数或非心数。云何法入心数。若法入有缘受想。乃至烦恼使。是名法入心数。云何法入非心数。若法入无缘生。乃至非想非非想处智。是名法入非心数

十二入几缘几非缘。一缘。十非缘。一二分或有缘或非缘。云何一缘。意入是名一缘。云何十无缘。十色入是名十无缘。云何一二分或缘或非缘。法入是名一二分或缘或非缘。云何法入缘。若法入心数受想乃至烦恼使。是名法入缘。云何法入无缘。若法入非心数生。乃至非想非非想处智。是名法入无缘

十二入几共心几非共心。十一非共心。一二分或共心或非共心。云何十一非共心。十色入意入。是名十一非共心。云何一二分或共心或非共心。法入是名一二分或共心或非共心。云何法入共心。若法入随心转。共心生共住共灭。受想乃至烦恼使。有漏身口戒无教。有漏身进有漏身除。正语正业正命正身进正身除。是名法入共心。云何法入非共心。若法入不随心转。不共心生不共住不共灭生。乃至非想非非想处智。是名法入非共心。随心转不随心转亦如是

十二入几业几非业。九非业。三二分或业或非业。云何九非业。眼入耳入鼻入舌入身入意入香入味入触入。是名九非业。云何三二分或业或非业。色入声入法入。是名三二分或业或非业。云何色入业。若善心不善心无记心所起。去来屈申回转身教。是名色入业。云何色入非业。身好色非好色。姝妙非姝妙。妍肤非妍肤。严净非严净。若外色眼识所知。是名色入非业。云何声入业。若善心不善心无记心所起。集声音句言语口教。是名声入业。云何声入非业。若好声非好声。众妙声非众妙声。软声非软声。若外声耳识所知。是名声入非业。云何法入业。思身口非戒无教。有漏身口戒无教。正语正业正命。是名法入业。云何法入非业。除思身口非戒无教有漏身口戒无教正语正业正命。余法入非业。是名法入非业

十二入几业相应几非业相应。一业相应。十非业相应。一三分或业相应或非业相应。或不说业相应非业相应。云何一业相应。意入是名一业相应。云何十非业相应。十色入是名十非业相应。云何一三分或业相应或非业相应。或不说业相应非业相应。法入是名一三分或业相应或非业相应或不说业相应非业相应。云何法入业相应。若法入思相应。除思余受想乃至烦恼使。是名法入业相应。云何法入非业相应。若法入非思相应生乃至非想非非想处智。是名法入非业相应。云何法入不说业相应非业相应。思是名法入不说业相应非业相应

十二入几共业。几不共业。一共业。十非共业。一二分或共业非共业。云何一共业。意入是名一共业。云何十非共业。十色入是名十非共业。云何一二分或共业或非共业。法入是名一二分或共业或非共业。云何法入共业。若法入随业转共业生共住共灭。受想定心思触。乃至烦恼使。无想定灭尽定。有漏身口戒无教。有漏身进有漏身除。正语正业正命正身进正身除。是名法入共业。云何法入非共业。法入若不随业转不共业生不共住不共灭。不定心思。生老死命结得果。身口非戒无教。有漏身口戒无教。有漏身进九无为。是名法入非共业。随业转不随业转亦如是

十二入几因几非因。一因七非因。四二分或因或非因。云何一因。意入是名一因。云何七非因。眼入耳入鼻入舌入身入香入味入。是名七非因。云何四二分或因或非因。色入声入触入法入。是名四二分或因或非因。云何色入因。色入若报法。是名色入因。云何色入因。色入若善心不善心所起去来屈申回转身教。是名色入因。云何色入非因。色入若报。色入若非报非报法。身好色非好色。端严非端严。妍肤非妍肤。严净非严净。无记心所起去来回转屈申身教。若外色眼识所知。是名色入非因。云何声入因。若声入报法。是名声入因。云何声入因。若声入善不善。若善心不善心所起集声音句言语口教。是名声入因。云何声入非因。若声入报。若声入非报非报法。身好声非好声。众妙声非众妙声。软声非软声。无记心所起集声音句言语口教。若外声耳识所知。是名声入非因。云何触入因。四大地大水大风大火大。是名触入因。云何触入非因。除四大余触入法。是名触入非因。云何法入因。法入缘若法入非缘有报。除得果余法入非缘善报。受想乃至烦恼使二定结一切色。是名法入因。云何法入非因。若法入缘无报不共业。生老死命得果有漏身进九无为。是名法入非因

十二入几有因几无因。十一有因。一二分或有因或无因。云何十一有因。十色入意入。是名十一有因。云何一二分或有因或无因。法入是名一二分或有因或无因。云何法入有因。若法入有绪受想乃至正身除。是名法入有因。云何法入无因。若法入无绪智缘尽。乃至非想非非想处智。是名法入无因。有绪无绪有因无因有缘无缘有为无为亦如是

十二入几知几非知。一切知如事知见

十二入几识几非识。一切识意识如事识

十二入几解几非解。一切解如事知见

十二入几了几非了。一切了如事知见

十二入几断智知。几非断智知。八非断智知。四二分或断智知或非断智知。云何八非断智知。眼入耳入鼻入舌入身入香入味入触入。是名八非断智知。云何四二分或断智知或非断智知。色入声入意入法入。是名四二分或断智知或非断智知。云何色入断智知。若色入不善不善心所起去来屈申回转身教。是名色入断智知。云何色入非断智知。色入若善若无记。身好色非好色。妍肤非妍肤。严净非严净。若善心若无记心所起去来屈申回转身教。若外色眼识所知。是名色入非断智知。云何声入断智知。若声入不善不善心所起集声音句言语口教。是名声入断智知。云何声入非断智知。若声善若无记。身好声非好声。众妙声非众妙声。软声非软声。若善心若无记心所起集声音句言语口教。若外声耳识所知。是名声入非断智知。云何意入断智知。若意入不善意界意识界。是名意入断智知。云何意入非断智知。意入若善若无记。眼识乃至意识。是名意入非断智知。云何法入断智知。若法入不善受想思触思惟觉观。见慧解脱悔不悔悦喜心进信欲念疑怖烦恼使结。身口非戒无教有漏身进。是名法入断智知。云何法入非断智知。除使结身口非戒无教。余法入非断智知。是名法入非断智知。断非断亦如是

十二入几修几非修。八非修。四二分或修或非修。云何八非修。眼入耳入鼻入舌入身入香入味入触入。是名八非修。云何四二分或修或非修。色入声入意入法入。是名四二分或修或非修。云何色入修。色入若善心所起去来屈申回转身教。是名色入修。云何色入非修。若色入不善若无记。身好色非好色。端严非端严。妍肤非妍肤严净非严净。若不善心若无记心所起去来屈申回转身教。若外色眼识所知。是名色入非修。云何声入修。声入若善善心所起集声音句言语口教。是名声入修。云何声入非修。若声入不善若无记。身好声非好声。众妙声非众妙声。软声非软声。若不善心若无记心所起集声音句言语口教。若外声耳识所知。是名声入非修。云何意入修。意入若善意界意识界。是名意入修。云何意入非修。意入若不善若无记。眼识乃至意识。是名意入非修。云何法入修。法入若善受想乃至心舍无想定得果灭尽定。有漏身口戒无教。有漏身进有漏身除。正语正业正命正身进正身除智缘尽决定。是名法入修。云何法入非修。若法入不善若无记。受想思触思惟觉观见慧解脱悔不悔悦喜心进信欲念疑怖烦恼使生老死命结身口非戒无教有漏身进非圣七无为。是名法入非修

十二入。几证。几非证。一切证如事知见。十二入。几善。几非善。几无记。八无记。四三分或善或不善或无记。云何八无记。眼入耳入鼻入舌入身入香入味入触入。是名八无记。云何四三分或善或不善或无记。色入声入意入法入。是名四三分或善或不善或无记。云何色入善。若色入修善心所起去来屈申回转身教。是名色入善。云何色入非善。若色入随不善心所起去来屈申回转身教。是名色入非善。云何色入无记。若色入受。色入非报非报法。身好色非好色。端严非端严。妍肤非妍肤。严净非严净。无记心所起去来屈申回转身教。若外色眼识所知。是名色入无记。云何声入善。若声入修善心所起集声音句言语口教。是名声入善。云何声入不善。若声入断不善心所起集声音句言语口教。是名声入不善。云何声入无记。若声入受。若声入非报非报法。身好声非好声。众妙声非众妙声。软声非软声。无记心所起集声音句言语口教。若外声耳识所知。是名声入无记。云何意入善。若意入修意界意识界。是名意入善。云何意入不善。若意入断意界意识界。是名意入不善。云何意入无记。若意入受。若意入非报非报法。眼识乃至意识。是名意入无记。云何法入善。若法入修受想。乃至心舍无想定得果灭尽定。有漏身口戒无教。有漏身进有漏身除。正语正业正命正身进正身除智缘尽决定。是名法入善。云何法入不善。若法入断受想思触思惟觉观。见慧解脱悔不悔悦喜心进信欲念疑怖使结。身口非戒无教。有漏身进。是名法入不善。云何法入无记。若法入受。若法入非报非报法。非圣无为受想思触思惟觉观。见慧解脱悔不悔。悦喜心进信欲念怖生老死命。有漏身进非圣七无为。是名法入无记

十二入几学几无学。几非学非无学。十非学非无学。二三分或学或无学或非学非无学。云何十非学非无学。十色入。是名十非学非无学。云何二三分或学或无学或非学非无学。意入法入。是名二三分或学或无学或非学非无学。云何意入学。若意入圣非无学。是名意入学。云何意入学。若意入学信根相应意界意识界。是名意入学。云何意入学。学人离结使圣心入圣道。若坚信若坚法。及余趣人见行过患。观涅槃寂灭。如实观苦集灭道。未得欲得。未解欲解。未证欲证。离烦恼修道。见学人若须陀洹若斯陀含若阿那含。若观智具足。若智地。若观解脱心。即证沙门果。若须陀洹果。若斯陀含果。若阿那含果。若实人若趣意界意识界。是名意入学。云何意入无学。若意入圣非学。是名意入无学。云何意入无学。若意入无学信根相应意界意识界。是名意入无学。云何意入无学。无学人欲得阿罗汉。未得圣法。欲得修道。观智具足。若智地若观解脱心。即得阿罗汉果。若实人若趣。若意界意识界。是名意入无学。云何意入非学非无学。若意入非圣识受阴眼识乃至意识。是名意入非学非无学。云何法入学。若法入圣非无学。是名法入学。云何法入学。学信根及信根相应心数法。若法非缘无漏非无学。是名法入学。云何法入学。学人离结使圣心入圣道。乃至即得阿那含果。若实人若趣。若受想思触思惟觉观。见慧解脱无痴顺信悦喜心进心除。信欲不放逸念定心舍得果灭尽定。正语正业正命正身进正身除智缘尽决定。是名法入学。云何法入无学。若法入圣非学。是名法入无学。云何法入无学。无学信根及信根相应心数法。若法入若非缘无漏非学。是名法入无学。云何法入无学。无学人乃至即得阿罗汉果。若实人若趣若受想思触思惟觉观。见慧解脱无痴顺信悦喜心进心除。信欲不放逸念定心舍得果灭尽定。正语正业正命正身进正身除智缘尽。是名法入无学。云何法入非学非无学。若法入非圣受阴想受阴行受阴。若色不可见无对。有漏非圣无为受想。乃至无想定。初四色非圣七无为。是名法入非学非无学

十二入几报几报法。几非报非报法。五报三二分。或报或非报非报法。四三分或报或报法。或非报非报法。云何五报。眼入耳入鼻入舌入身入。是名五报。云何三二分或报或非报或非报法。香入味入触入。是名三二分或报或非报非报法。云何四三分或报或报法或非报非报法。色入声入意入法入。是名四三分或报或报法或非报非报法。云何香入报。香入若受是名香入报。云何香入报。香入若业法烦恼所生报我分摄。身好香非好香。软香非软香。适意香非适意香。是名香入报。云何香入非报非报法。若香入外。若外香鼻识所知。树根香树心香树胶香树皮香。叶香花香果香好香。非好香。及余外香鼻识所知。是名香入非报非报法。云何味入报。若味入受。是名味入报。云何味入报。若味入业法烦恼所生报我分摄。身甜酢苦辛咸淡涎癊。是名味入报。云何味入非报非报法。若味入外。若外味入舌识所知。若甜酢苦辛咸淡水汁。及余外味舌识所知。是名味入非报非报法。云何触入报。若触入受。是名触入报。云何触入报。若触入业法烦恼所生报我分摄。身冷热轻重粗细涩滑坚软。是名触入报。云何触入非报非报法。若触入外。若外触身识所知。若冷热轻重粗细涩滑坚软。及余外触身识所知。是名触入非报非报法。云何色入报。若色入受。是名色入报。云何色入报。若色入业法烦恼所生报我分摄。身好色非好色。端严非端严。妍肤非妍肤。严净非严净。受心所起去来屈申回转身教。是名色入报。云何色入报法。若色入有报。是名色入报法。云何色入报法。色入若善不善。若善心若不善心所起去来屈申回转身教。是名色入报法。云何色入非报非报法。若色入无记非我分摄。非报非报法心所起去来屈申回转身教。若外色眼识所知。是名色入非报非报法。云何声入报。若声入受。是名声入报。云何声入报。若声入业法烦恼所生报我分摄。身好声非好声。众妙声非众妙声。软声非软声。受心所起集声音句言语口教。是名声入报。云何声入报法。若声入有报。是名声入报法。云何声入报法。若声入善不善。若善心若不善心所起集声音句言语口教。是名声入报法。云何声入非报非报法。若声入无记非我分摄。非报非报法心所起集声音句言语口教。若外声耳识所知。是名声入非报非报法。云何意入报。若意入受。若意入善报。眼识乃至意识。是名意入报。云何意入报法。若意入有报。是名意入报法。云何意入报法。除意入善报。余意入善。若不善意界意识界。是名意入报法。云何意入非报非报法。若意入无记非我分摄。眼识乃至意识。是名意入非报非报法。云何法入报。若法入受。若法入善报。除无贪无恚。余受想乃至心舍怖生命无想定得果灭尽定。有漏身口戒无教。有漏身进有漏身除。正语正业正命正身进正身除。是名法入报。云何法入报法。若法入有报。是名法入报法。云何法入报法。除法入善报。余法入善有为。若不善受想乃至烦恼使结二定一切色。是名法入报法。云何法入非报非报法。若法入无记非我分摄。若圣无为受想思触思惟觉观。见慧解脱悔不悔悦喜心进信欲念怖生老死。有漏身进九无为。是名法入非报非报法

十二入几见断几思惟断。几非见断非思惟断。八非见断非思惟断。四三分或见断或思惟断或非见断非思惟断。云何八非见断非思惟断。眼入耳入鼻入舌入身入香入味入触入。是名八非见断非思惟断。云何四三分或见断或思惟断或非见断非思惟断。色入声入意入法入。是名四三分或见断或思惟断或非见断非思惟断。云何色入见断。若色入不善非思惟断见断。烦恼心所起去来屈申回转身教。是名色入见断。云何色入思惟断。若色入不善非见断思惟断烦恼心所起去来屈申回转身教。是名色入思惟断。云何色入非见断非思惟断。若色入善若无记。身好色非好色。端严非端严。妍肤非妍肤。严净非严净。若善心若无记心所起去来屈申回转身教。若外色眼识所知。是名色入非见断非思惟断。云何声入见断。若声入不善非思惟断见断。烦恼心所起集声音句言语口教。是名声入见断。云何声入思惟断。若声入不善非见断思惟断。烦恼心所起集声音句言语口教。是名声入思惟断。云何声入非见断非思惟断。若声入善若无记。身好声非好声。众妙声非众妙声。软声非软声。若善心若无记心所起集声音句言语口教。若外声耳识所知。是名声入非见断非思惟断。云何意入见断。若意入不善非思惟断见断。烦恼相应意界意识界。是名意入见断。云何意入思惟断。若意入不善非见断思惟断。烦恼相应心意界意识界。是名意入思惟断。云何意入非见断非思惟断。若意入善若无记。眼识乃至意识。是名意入非见断非思惟断。云何法入见断。若法入不善非思惟断见断。烦恼一时俱断。受想思触思惟觉观。见慧解脱悔不悔悦喜心进信欲念疑怖烦恼使结。身口非戒无教有漏身进。是名法入见断。云何法入思惟断。若法入不善非见断思惟断烦恼一时俱断。受想思触思惟觉观。见慧解脱悔不悔悦喜心进信欲念疑怖烦恼使结。身口非戒无教。有漏身进。是名法入思惟断。云何法入非见断非思惟断。若法入善若无记。除疑烦恼使结身口非戒无教。余法入是名法入。非见断非思惟断

十二入几见断因。几思惟断因。几非见断非思惟断因。一切三分。或见断因或思惟断因或非见断非思惟断因。云何眼入见断因。若眼入见断法报。地狱畜生饿鬼眼入。是名眼入见断因。云何眼入思惟断因。若眼入思惟断法报。地狱畜生饿鬼眼入。是名眼入思惟断因。云何眼入非见断非思惟断因。若眼入善法报。天上人中眼入。是名眼入非见断非思惟断因。耳入鼻入舌入身入亦如是。云何意入见断因。若意入见断若意入见断法报。眼识乃至意识。是名意入见断因。云何意入思惟断因。若意入思惟断法报。眼识乃至意识。是名意入思惟断因。云何意入非见断非思惟断因。若意入善若意入善法报。若意入非报非报法。眼识乃至意识。是名意入非见断非思惟断因。云何色入见断因。若色入见断。若色入见断法报。身非好色非端严非妍肤非严净。见断因心所起去来屈申回转身教。是名色入见断因。云何色入思惟断因。若色入思惟断若思惟断法报。身非好色不端严非妍肤非严净思惟断因。心所起去来屈申回转身教。是名色入思惟断因。云何色入非见断非思惟断因。若色入善若色入善法报。若色入非报非报法。身好色端严妍肤严净。非见断非思惟断。心所起去来屈申回转身教。若外色眼识所知。是名色入非见断非思惟断因。云何声入见断因。若声入见断。若声入见断法报。身不好声。非众妙声非软声。见断法因。心所起集声音句言语口教。是名声入见断因。云何声入思惟断因。若声入若思惟断。若声入思惟断法报。身不好声非众妙声非软声。思惟断因。心所起集声音句言语口教。是名声入思惟断因。云何声入非见断非思惟断因。若声入善若声入善法报。若声入非报非报法。身好声众妙声软声。非见断非思惟断因。心所起集声音句言语口教。若外声耳识所知。是名声入非见断非思惟断因。云何香入见断因。若香入若见断法报。身不好香非软香不适意香。是名香入见断因。云何香入思惟断因。若香入思惟断法报。身不好香非软香不适意香。是名香入思惟断因。云何香入非见断非思惟断因。若香入善法报。若香入非报非报法。身好香软香适意香。若外香鼻识所知。是名香入非见断非思惟断因。云何味入见断因。若味入见断法报。身甜酢苦辛咸淡涎癊。是名味入见断因。云何味入思惟断因。若味入思惟断法报。身甜酢苦辛咸淡涎癊。是名味入思惟断因。云何味入非见断非思惟断因。若味入善法报。若味入非报非报法。身甜酢苦辛咸淡涎癊。若外味舌识所知。是名味入非见断非思惟断因。云何触入见断因。若触入见断法报。身冷热粗重坚涩。是名触入见断因。云何触入思惟断因。若触入思惟断法报。身冷热粗重坚涩。是名触入思惟断因。云何触入非见断非思惟断因。若触入善法报。若触入非报法。身冷热轻细软滑。若外触身识所知。是名触入非见断非思惟断因。云何法入见断因。若法入见断因。若法入若见断法报。受想思触思惟觉观。见慧解脱悔不悔悦喜心进信欲念疑怖烦恼使生命结。身口非戒无教。有漏身进。是名法入见断因。云何法入思惟断因。若法入思惟断。若法入思惟断法报。受想思触思惟觉观。见慧解脱悔不悔悦喜心进信欲念怖烦恼使生命结。身口非戒无教。有漏身进。是名法入思惟断因。云何法入非见断非思惟断因。若法入若善善法报。若法入非报非报法。除疑烦恼使结身口非戒无教。余法入非见断非思惟断因。是名法入非见断非思惟断因

十二入几欲界系。几色界系。几无色界系。几不系。四欲界系。六二分或欲界系或色界系。二四分或欲界系或色界系或无色界系或不系。云何四欲界系。舌入鼻入香入味入。是名四欲界系。云何六二分或欲界系或色界系。眼入耳入身入色入声入触入。是名六二分或欲界系或色界系。云何二四分或欲界系或色界系或无色界系或不系。意入法入。是名二四分或欲界系或色界系或无色界系或不系。云何眼入欲界系。若眼入欲漏有漏眼入。是名眼入欲界系。云何眼入色界系。若眼入色漏有漏眼入。是名眼入色界系。耳入身入亦如是。云何色入欲界系。若色入欲漏有漏。身好色非好色。端严非端严。妍肤非妍肤。严净非严净。欲行心所起去来屈申回转身教。若外色眼识所知欲漏有漏。是名色入欲界系。云何色入色界系若色入色漏有漏。身好色端严妍肤严净。色行心所起去来屈申回转身教。若外色眼识所知色漏有漏。是名色入色界系。云何声入欲界系。若声入欲漏有漏。身好声非好声。众妙声非众妙声。软声非软声。欲行心所起集声音句言语口教。若外声耳识所知欲漏有漏。是名声入欲界系。云何声入色界系。若声入色漏有漏。身好声众妙声软声。色行心所起集声音句言语口教。若外声耳识所知色漏有漏。是名声入色界系。云何触入欲界系。若触入欲漏有漏身冷热轻重粗细涩滑坚软。若外触身识所知欲漏有漏。是名触入欲界系。云何触入色界系。若触入色漏有漏。身冷热轻重粗细软滑。若外触身识所知色漏有漏。是名触入色界系。云何意入欲界系。若意入欲漏有漏。眼识乃至意识。是名意入欲界系。云何意入色界系。若意入色漏有漏。眼识耳识身识意识。是名意入色界系。云何意入无色界系。若意入无色漏有漏意界意识界。是名意入无色界系。云何意入不系。若意入圣无漏意界意识界。是名意入不系。云何法入欲界系。若法入欲漏有漏。受想思触思惟觉观。见慧解脱无贪无恚无痴。顺信悔不悔悦喜心进信欲不放逸念疑怖烦恼使生老死命结。身口非戒无教。有漏身口戒无教。有漏身进。是名法入欲界系。云何法入色界系。若法入色漏有漏。受想思触思惟觉观。见慧解脱无痴顺信悦喜心进心除信欲不放逸念定心舍疑烦恼使。生老死命结无想定。有漏身口戒无教。有漏身进有漏身除。是名法入色界系。云何法入无色界系。若法入无色漏有漏。受想思触思惟见慧解脱无痴顺信心进心除信欲。不放逸念定心舍疑烦恼使生老死命结。有漏身口戒无教。有漏身进有漏身除。是名法入无色界系。云何法入不系。若法入圣无漏无为。受想思触思惟觉观。见慧解脱无痴顺信悦喜心进心除信欲不放逸念。定心舍得果灭尽定。正语正业正命正身进正身除九无为。是名法入不系

十二入几过去几未来几现在。几非过去非未来非现在。十一三分或过去或未来或现在。一四分或过去或未来或现在。或非过去非未来非现在。云何十一三分或过去或未来或现在。眼入乃至触入。是名十一三分或过去或未来或现在。云何一四分或过去或未来或现在。或非过去非未来非现在。法入是名一四分或过去或未来或现在或非过去非未来非现在。云何眼入过去。若眼入生已灭眼入。是名眼入过去。云何眼入未来。若眼入未生未出。是名眼入未来。云何眼入现在。若眼入生未灭眼入。是名眼入现在。乃至触入亦如是。云何法入过去。若法入生已灭。受想乃至正身除。是名法入过去。云何法入未来。若法入未生未出。受想乃至正身除。是名法入未来。云何法入现在。若法入生未灭。受想乃至正身除。是名法入现在。云何法入非过去非未来非现在。若法入无为智缘尽。乃至非有想非无想处智。是名法入非过去非未来非现在

舍利弗阿毗昙论卷第一舍利弗阿毗昙论卷第二

        姚秦罽宾三藏昙摩耶舍共昙摩崛多等译

    问分界品第二

问曰。几界。答曰。十八界。云何十八界。眼界耳界鼻界舌界身界。色界声界香界味界触界。眼识界耳识界鼻识界舌识界身识界意界意识界法界。云何眼界。眼根是名眼界。云何眼界。眼入是名眼界。云何眼界。若眼我分摄四大所造净色。是名眼界。若眼我分摄眼界四大所造。过去未来现在净色。是名眼界。云何眼界。若眼我分摄已见色今见当见不定。若眼我分摄色光已来今来当来不定。是名眼界。云何眼界。若眼我分摄眼已对色今对当对不定。若眼我分摄色已对眼今对当对不定。是名眼界。若眼无碍。是眼是眼入是眼根是眼界。是田是物是门是藏。是世是净是泉是海。是沃燋是洄澓是疮是系是目。是入我分是此岸。是内入眼见色。是名眼界。耳界鼻界舌界身界亦如是。云何色界。色入是名色界。云何色界。若色随行色相。是名色界。云何色界。若色可见有对眼识所知。是名色界。云何色界。若色界业法烦恼所生报我分摄。身好色非好色。端严非端严。妍肤非妍肤。严净非严净。若善心若不善心若无记心所起去来屈申回转身教。若外色眼识所知。青黄赤白紫黑粗细长短方圆。水陆光影烟云尘雾气明闇。及余外色眼识所知。是名色界。云何声界。声入是名声界。云何声界。若色不可见有对。耳识所知。是名声界。云何声界。若声界业法烦恼所生报我分摄。身好声非好声。众妙声非众妙声。软声非软声。若善心若不善心若无记心所起集声音句言语口教。若外声耳识所知。呗声大鼓声小鼓声筝声箜篌声铜钹声。舞声歌声伎乐声哭声。男声女声人声非人声。众生声非众生声。去声来声相触声。风声雨声水声。诸大相触声。及余外声耳识所知。是名声界。云何香界。若香入是名香界。云何香界若色不可见有对鼻识所知。是名香界。云何香界。若香界业法烦恼所生报我分摄。身好香非好香。软香非软香。适意香非适意香。若外香鼻识所知树根香树心香树胶香树皮香叶香花香果香。好香非好香。及余外香鼻识所知。是名香界。云何味界。若味入是名味界。云何味界。若色不可见有对舌识所知。是名味界。云何味界。若味界业法烦恼所生报我分摄。身甜酢苦辛咸淡涎癊。若外味舌识所知。若甜酢苦辛咸淡若水若汁。及余外味舌识所知。是名味界。云何触界。若触入是名触界。云何触界。若色不可见有对身识所知。是名触界。云何触界。若触界业法烦恼所生报我分摄。身冷热轻重粗细。涩滑坚软。若外触身识所知。是名触界。云何眼识界。若识是眼根生色。境界已生今生当生不定。是名眼识界。云何耳鼻舌身识界。若识身根生触境界已生今生当生不定。是名身识界。云何意界意知法思惟法念法。若初心已生今生当生不定。是名意界。云何意识界。若识相似不离彼境界。及余相似心已生今生当生不定。是名意识界。云何法界。若法入是名法界。云何法界。受阴想阴行阴。若色不可见无对若无为。是名法界。云何法界。受想思触思惟觉观。见慧解脱无贪无恚无痴。顺信悔不悔悦喜心进心除信欲不放逸念定心舍疑怖烦恼使生老死命结。无想定得果灭尽定。身口非戒无教。有漏身口戒无教。有漏身进有漏身除。正语正业正命正身进正身除。智缘尽非智缘尽。决定法住。缘空处识处不用处非想非非想处。是名法界

十八界几色几非色。十色七非色。一二分或色或非色。云何十色。眼界耳界鼻界舌界身界色界声界香界味界触界。是名十色。云何七非色。眼识界耳识界鼻识界舌识界身识界意界意识界。是名七非色。云何一二分或色或非色。法界。是名一二分或色或非色。云何法界色。身口非戒无教有漏身口戒无教。有漏身进有漏身除。正语正业正命正身进正身除。是名法界色。云何法界非色。受想乃至灭尽定智缘尽。乃至非想非非想处。是名法界非色

十八界几可见几不可见。一可见十七不可见。云何一可见。色界是名一可见。云何十七不可见。除色界余不可见

十八界几有对几无对。十有对八无对。云何十有对。十色界是名十有对。云何八无对。七识界法界。是名八无对

十八界几圣几非圣。十五非圣。三二分或圣或非圣。云何十五非圣。十色界五识界。是名十五非圣。云何三二分或圣或非圣。意界意识界法界。是名三二分或圣或非圣。云何意界非圣。若意界有漏。是名意界非圣。云何意界非圣。若意界非学非无学意界。是名意界非圣。云何意界圣。若意界无漏。是名意界圣。云何意界圣若意界信根相应意界。是名意界圣。云何意界圣。若意界学若无学。学人离结使圣心入圣道。若坚信若坚法。及余趣人见行过患。观涅槃寂灭。如实观苦集灭道。未得欲得。未解欲解。未证欲证。离烦恼修道。见学人若须陀洹。若斯陀含。若阿那含。观智具足。若智地若观解脱心。即证沙门果。若须陀洹果。若斯陀含果。若阿那含果。无学人欲得阿罗汉。未得圣法。欲得观智具足。若智地若观解脱心。即得阿罗汉果。若实人若趣若意界。是名意界圣。意识界亦如是。云何法界非圣。若法界有漏。是名法界非圣。云何法界非圣。受受阴想受阴行受阴。若色不可见无对有漏。若非圣无为。是名法界非圣。云何法界非圣。若法界若非学非无学。受想乃至无想定。初四色非圣七无为。是名法界非圣。云何法界圣。若法无漏。是名法界圣。云何法界圣。信根及信根相应心数法。若法非缘无漏。是名法界圣。云何法界圣。若法界圣。若法界学若无学。学人离结使。乃至即得阿罗汉果。若实人若趣。若受想思触思惟觉观。见慧解脱无痴顺信悦喜心进心除信欲不放逸念定心舍得果灭尽定。正语正业正命正身进正身除智缘尽决定。是名法界圣

十八界几有漏几无漏。十五有漏。三二分或有漏或无漏。云何十五有漏。十色界五识界。是名十五有漏。云何三二分或有漏或无漏。意界意识界法界。是名三二分或有漏或无漏。云何意界有漏。意界若有爱。是名意界有漏。云何意界有漏。意界若非学非无学意界是名意界有漏。云何意界无漏。若意界无爱。是名意界无漏。云何意界无漏。若意界信根相应意界。是名意界无漏。云何意界无漏。若意界若学无学人离结使。乃至即得阿罗汉果。若实人若趣意界。是名意界无漏。意识界亦如是。云何法界有漏。若法界有爱。是名法界有漏。云何法界有漏。受受阴想受阴行受阴。若色不可见无对有爱。是名法界有漏。云何法界有漏。若法界非学非无学。受想乃至无想定初四色。是名法界有漏。云何法界无漏。若法界无爱。是名法界无漏。云何法界无漏。信根及相应心数法。若法非缘无爱。是名法界无漏。云何法界无漏。若法界若学无学若非圣无为。学人离结使。及至即得阿罗汉果。若实人若趣若受想思触思惟觉观。见慧解脱无痴顺信悦喜心进心除。信欲不放逸念定心舍得果灭尽定。正语正业正命正身进正身除。智缘尽非智缘尽。决定法住。缘空处智识处智不用处智非想非非想处智。是名法界无漏。有爱无爱有求无求当取非当取有取无取有胜无胜亦如是

十八界几受几非受。五受十三二分。或受或非受。云何五受。眼界耳界鼻界舌界身界。是名五受。云何十三二分或受或非受。色界声界香界味界触界。眼识界耳识界鼻识界舌识界身识界意界意识界法界。是名十三二分或受或非受。云何色界受。色界若内。是名色界受。云何色界受。若色界业法烦恼所生报我分摄。身好色非好色。端严非端严。妍肤非妍肤。严净非严净。若受心所起去来屈申回转身教。是名色界受。云何色界非受。若色界外。是名色界非受。云何色界非受。若色界善若不善若无记非我分摄。若善心若不善心若非报非报法。心所起去来屈申回转身教。若外色眼识所知。是名色界非受。云何声界受。若声界是内。是名声界受。云何声界受。若声界业法烦恼所生报我分摄。身好声非好声。众妙声非众妙声。软声非软声。受心所起集声音句言语口教。是名声界受。云何声界非受。若声界外。是名声界非受。云何声界非受。若声界善若不善若无记非我分摄。若善心若不善心若非报非报法。心所起集声音句言语口教。若外声耳识所知。是名声界非受。云何香界受。若香界内。是名香界受。云何香界受若香界业法烦恼所生报我分摄。身好香非好香。软香非软香。适意香非适意香。是名香界受。云何香界非受。若香界外外香鼻识所知。树根香树心香树胶香树皮香。叶香花香果香。好香非好香。及余外香鼻识所知。是名香界非受。云何味界受。若味界内。是名味界受。云何味界受。若味界业法烦恼所生报我分摄。身甜酢苦辛咸淡涎癊。是名味界受。云何味界非受。若味界外外味舌识所知。若甜酢苦辛咸淡。外汁及余外味舌识所知。是名味界非受。云何触界受。若触界内。是名触界受。云何触界受。若触界业法烦恼所生报我分摄。身冷热轻重粗细涩滑坚软。是名触界受。云何触界非受。若触界外。若外触身识所知。若冷热轻重粗细涩滑坚软。及余外触身识所知。是名触界非受。云何眼识界受。若眼识界内。是名眼识界受。云何眼识界受。若眼识界业法烦恼所生报我分摄眼识界。是名眼识界受。云何眼识界非受。若眼识界外眼识界。是名眼识界非受。耳识界鼻识界舌识界身识界亦如是。云何意界受。若意界内。是名意界受。云何意界受。若意界业法烦恼所生报我分摄。是名意界受。云何意界非受。若意界外。是名意界非受。云何意界非受。若意界善不善若无记非我分摄意界。是名意界非受。意识界亦如是。云何法界受。若法界内。是名法界受。云何法界受。若法界业法烦恼所生报我分摄。受想思触思惟觉观。见慧解脱悔不悔悦喜心进信欲念怖生命有漏身进。是名法界受。云何法界非受。若法界外。是名法界非受。云何法界非受。若法界善若不善若无记非我分摄。余法界非受。是名法界非受。内外亦如是

十八界几有报几无报。十三无报。五二分或有报或无报。云何十三无报。八色界五识界。是名十三无报。云何五二分或有报或无报。色界声界意界意识界法界。是名五二分或有报或无报。云何色界有报。若色界报法。是名色界有报。云何色界有报。若色界善若不善若善心若不善心所起。去来屈申回转身教。是名色界有报。云何色界无报。若色界报色界非报非报法。身好色非好色。端严非端严。妍肤非妍肤。严净非严净。无记心所起去来屈申回转身教。若外色眼识所知。是名色界无报。云何声界有报。若声界报法。是名声界有报。云何声界有报。若声界善若不善若善心若不善心所起集声音句言语口教。是名声界有报。云何声界无报。若声界报若声界非报非报法。身好声非好声。众妙声非众妙声。软声非软声。无记心所起集声音句言语口教。若外声耳识所知。是名声界无报。云何意界有报。若意界报法。是名意界有报。云何意界有报。除意界善报。余意界善若不善意界。是名意界有报。云何意界无报。若意界报若意界非报非报法意界。是名意界无报。意识界亦如是。云何法界有报。若法界报法。是名法界有报。云何法界有报。除法界善报。余法界善若有为。若不善受想乃至烦恼使结二定一切色。是名法界有报。云何法界无报。若法界报若法界非报非报法。除无贪无恚无痴烦恼使结身口非戒无教。余法界无报。是名法界无报

十八界几心几非心。七心十一非心。云何七心。七识界是名七心。云何十一非心。十色界法界。是名十一非心

十八界几心相应。几非心相应。十非心相应。七不说心相应非心相应。一二分或心相应或非心相应。云何十非心相应。十色界是名十非心相应。云何七不说心相应非心相应。七识界是名七不说心相应非心相应。云何一二分或心相应或非心相应。法界是名一二分或心相应或非心相应。云何法界心相应。若法界心数受想乃至烦恼使。是名法界心相应。云何法界非心相应。若法界若非心生。乃至非想非非想处智。是名法界非心相应

十八界几心数几非心数。十七非心数。一二分或心数或非心数。云何十七非心数。十色界七识界。是名十七非心数。云何一二分或心数或非心数。法界是名一二分或心数或非心数。云何法界心数。若法界有缘受想乃至烦恼使。是名法界心数。云何法界非心数。若法界非缘生。乃至非想非非想处智。是名法界非心数

十八界几有缘几无缘。七有缘十无缘。一二分或有缘或无缘。云何七有缘。七识界是名七有缘。云何十无缘。十色界是名十无缘。云何一二分或有缘或无缘。法界是名一二分或有缘或无缘。云何法界有缘。若法界心数受想乃至烦恼使。是名法界有缘。云何法界无缘。若法界非心数生。乃至非想非非想处智。是名法界无缘

十八界几共心几不共心。十七不共心。一二分或共心或不共心。云何十七不共心。十色界七识界。是名十七不共心。云何一二分或共心或不共心。法界是名一二分或共心或不共心。云何法界共心。若法界随心转共心生共住共灭。受想乃至烦恼使。有漏身口戒无教。有漏身进有漏身除。正语正业正命正身进正身除。是名法界共心。云何法界不共心。若法界不随心转不共心生不共住不共灭。生乃至非想非非想处智。是名法界不共心。随心转不随心转亦如是

十八界几业几非业。十五非业。三二分或业或非业。云何十五非业。八色界七识界。是名十五非业。云何三二分或业或非业。色界声界法界。是名三二分或业或非业。云何色界业。若善心若不善心若无记心所起。去来屈申回转身教。是名色界业。云何色界非业。身好色非好色。端严非端严。妍肤非妍肤。严净非严净。若外色眼识所知。是名色界非业。云何声界业。若善心若不善心若无记心所起集声音句言语口教。是名声界业。云何声界非业。身好声非好声。众妙声非众妙声。软声非软声。若外声耳识所知。是名声界非业。云何法界业。思身口非戒非教。有漏身口戒无教。正语正业正命。是名法界业。云何法界非业。除思身口非戒无教有漏身口戒无教正语正业正命。余法界非业。是名法界非业

十八界几业相应。几非业相应。七业相应。十非业相应。一三分或业相应或非业相应。或不说业相应非业相应。云何七业相应。七识界是名七业相应。云何十非业相应。十色界是名十非业相应。云何一三分或业相应或非业相应或不说业相应非业相应。法界是名一三分或业相应或非业相应或不说业相应非业相应。云何法界业相应。若法界思相应。除思余受想乃至烦恼使。是名法界业相应。云何法界非业相应。若法界非思相应。生乃至非想非非想处智。是名法界非业相应。云何法界不说业相应非业相应。思是名法界不说业相应非业相应

十八界几共业几非共业。七共业十不共业。一二分或共业或不共业。云何七共业。七识界是名七共业。云何十不共业。十色界是名十不共业。云何一二分或共业或不共业。法界是名一二分或共业或不共业。云何法界共业。若法界随业转共业生共住共灭。受想定心思触乃至烦恼使。二定有漏身口戒无教。有漏身进有漏身除。正语正业正命正身进正身除。是名法界共业。云何法界不共业。若法界不随业转不共业生不共住不共灭。不定心思生老死命结得果。身口非戒无教。有漏身口戒无教。有漏身进九无为。是名法界不共业。随业转不随业转亦如是

十八界几因几非因。七因七非因。四二分或因或非因。云何七因。七识界是名七因。云何七非因。眼界耳界鼻界舌界身界香界味界。是名七非因。云何四二分或因或非因。色界声界触界法界。是名四二分或因或非因。云何色界因。若色界报法。是名色界因。云何色界因。若色界若善不善。若善心若不善心所起。去来屈申回转身教。是名色界因。云何色界非因。若色界报若色界非报非报法。身好色非好色。端严非端严。妍肤非妍肤。严净非严净。无记心所起去来屈申回转身教。若外色眼识所知。是名色界非因。云何声界因。若声界报法。是名声界因。云何声界因。若声界善不善。若善心若不善心所起集声音句言语口教。是名声界因。云何声界非因。若声界报若声界非报非报法。身好声非好声。众妙声非众妙声。软声非软声。无记心所起集声音句言语口教。若外声耳识所知。是名声界非因。云何触界因。四大地大水大火大风大。是名触界因。云何触界非因。除四大余触界所摄法。是名触界非因。云何法界因。若法界缘若法界非缘有报。除得果余法界非缘若报。受想乃至烦恼使结。二定一切色。是名法界因。云何法界非因。若非缘无报不共业生老死命得果。有漏身进九无为。是名法界非因

十八界几有因几无因。十七有因。一二分或有因或无因。云何十七有因。十色界七识界。是名十七有因。云何一二分或有因或无因。法界是名一二分或有因或无因。云何法界有因。若法界有绪受想。乃至正身除。是名法界有因。云何法界无因。若法界无绪智缘尽。乃至非想非非想处智。是名法界无因。有绪无绪有缘无缘有为无为亦如是

十八界几知几非知。一切知如事知见

十八界几可识几非可识。一切识意识如事识

十八界几解几非解。一切解如事知见

十八界几了几非了。一切了如事知见

十八界几断智知。几非断智知。十三非断智知。五二分或断智知或非断智知。云何十三非断智知。八色界五识界。是名十三非断智知。云何五二分或断智知或非断智知。色界声界意界意识界法界。是名五二分或断智知或非断智知。云何色界断智知。若色界不善若不善心所起。去来屈申回转身教。是名色界断智知。云何色界非断智知。若色界善若无记。身好色非好色。端严非端严。妍肤非妍肤。严净非严净。若善心若无记心所起。去来屈申回转身教。若外色眼识所知。是名色界非断智知。云何声界断智知。若声界不善不善心所起集声音句言语口教。是名声界断智知。云何声界非断智知。若声界善若无记。身好声非好声。众妙声非众妙声。软声非软声。若善心若无记心所起集声音句言语口教。若外声耳识所知。是名声界非断智知。云何意界断智知。若意界不善意界。是名意界断智知。云何意界非断智知。若意界善若无记意界。是名意界非断智知。意识界亦如是。云何法界断智知。若法界不善受想思触思惟觉观。见慧解脱悔不悔悦喜心进信欲念疑怖烦恼使结。身口非戒无教。有漏身进。是名法界断智知。云何法界非断智知。若法界善若无记。除疑烦恼使结身口非戒无教。余法界非断智知。断非断亦如是

十八界几修几非修。十三非修。五二分或修或非修。云何十三非修。八色界五识界。是名十三非修。云何五二分或修或非修。色界声界意界意识界法界。是名五二分或修或非修。云何色界修。若色界善若善心所起。去来屈申回转身教。是名色界修。云何色界非修。若色界不善若无记。身好色非好色。端严非端严。妍肤非妍肤。严净非严净。若不善心若无记心所起。去来屈申回转身教。若外色眼识所知。是名色界非修。云何声界修。若声界善若善心所起集声音句言语口教。是名声界修。云何声界非修。若声界不善若无记。身好声非好声。众妙声非众妙声。软声非软声。若不善心若无记心所起集声音句言语口教。若外声耳识所知。是名声界非修。云何意界修。若意界善意界。是名意界修。云何意界非修。若意界不善若无记意界。是名意界非修。意识界亦如是。云何法界修。若法界善受想。乃至心舍无想定得果灭尽定。有漏身口戒无教。有漏身进有漏身除。正语正业正命正身进正身除。智缘尽决定。是名法界修。云何法界非修。法界不善若无记受想思触思惟觉观。见慧解脱悔不悔悦喜心进信欲念疑怖烦恼使生老死命结。身口非戒无教。有漏身进非圣七无为。是名法界非修

十八界几证几非证。一切证如事知见

十八界几善几非善几无记。十三无记。五三分或善或不善或无记。云何十三无记。八色界五识界。是名十三无记。云何五三分或善或不善或无记。色界声界意界意识界法界。是名五三分或善或不善或无记。云何色界善。若色界修善心所起。去来屈申回转身教。是名色界善。云何色界不善。若色界断不善心所起。去来屈申回转身教。是名色界不善。云何色界无记。若色界受若色界非报非报法。身好色非好色。端严非端严。妍肤非妍肤。严净非严净。无记心所起去来屈申回转身教。若外色眼识所知。是名色界无记。云何声界善。若声界修善心所起集声音句言语口教。是名声界善。云何声界不善。若声界断不善心所起集声音句言语口教。是名声界不善。云何声界无记。若声界受若声界非报非报法。身好声非好声。众妙声非众妙声。软声非软声。无记心所起集声音句言语口教。若外声耳识所知。是名声界无记。云何意界善。若意界修。是名意界善。云何意界不善。若意界断意界。是名意界不善。云何意界无记。若意界受若意界非报非报法意界。是名意界无记。意识界亦如是。云何法界善。若法界修受想。乃至心舍无想定得果灭尽定。有漏身口戒无教。有漏身进有漏身除。正语正业正命正身进正身除。智缘尽决定。是名法界善。云何法界不善。若法界断受想思触思惟觉观。见慧解脱悔不悔悦喜心进信欲念疑怖烦恼使结。身口非戒无教。有漏身进。是名法界不善。云何法界无记。若法界受非报非报法非圣无为。受想思触思惟觉观。见慧解脱悔不悔悦喜心进信欲念怖生老死命。有漏身进非圣七无为。是名法界无记

十八界几学几无学。几非学非无学。十五非学非无学。三三分或学或无学或非学非无学。云何十五非学非无学。十色界五识界。是名十五非学非无学。云何三三分或学或无学或非学非无学。意界意识界法界。是名三三分或学或无学或非学非无学。云何意界学若意界圣非无学。是名意界学。云何意界学。若意界学信根相应意界。是名意界学。云何意界学。学人离结使圣心入圣道。若坚信若坚法。及余趣人见行过患。观涅槃寂灭。如实观苦集灭道。未得欲得。未解欲解。未证欲证。离烦恼修道。见学人若须陀洹斯陀含阿那含。观智具足。若智地若观解脱心。即证沙门果。若须陀洹果斯陀含果阿那含果。若实人若趣意界。是名意界学。云何意界无学。若意界圣非学是名意界无学。云何意界无学。若意界无学信根相应意界。是名意界无学。云何意界无学。无学人欲得阿罗汉。未得圣法。欲得修道。观智具足。若智地若观解脱心。即得阿罗汉果。若实人若趣意界。是名意界无学。云何意界非学非无学。若意界非圣意界。是名意界非学非无学。意识界亦如是。云何法界学。若法界圣非无学。是名法界学。云何法界学。学信根及相应心数法。若法界缘无漏非无学。是名法界学。云何法界学。学人离结使圣心入圣道。乃至即得阿那含果。若实人若趣受想思触思惟觉观。见慧解脱无痴顺信悦喜心进心除。信欲不放逸念定心舍得果灭尽定。正语正业正命正身进正身除。智缘尽决定。是名法界学。云何法界无学。若法界圣非学。是名法界无学。云何法界无学。无学信根及相应心数法若法界非缘无漏非学。是名法界无学。云何法界无学。无学人乃至即得阿罗汉果。若实人若趣若受想思触思惟觉观。见慧解脱无痴顺信悦喜心进心除。信欲不放逸念心舍得果灭尽定。正语正业正命正身进正身除智缘尽。是名法界无学。云何法界非学非无学。若法界非圣受受阴想受阴行受阴。若色不可见无对有漏。若非圣无为受想定初四色。非圣七无为。是名法界非学非无学

十八界几报几报法。几非报非报法。五报。八二分或报或非报非报法。五三分或报或报法或非报非报法。云何五报。眼界耳界鼻界舌界身界。是名五报。云何八二分或报或非报非报法。香界味界触界眼识界耳识界鼻识界舌识界身识界。是名八二分或报或非报非报法。云何五三分或报或报法或非报非报法。色界声界意界意识界法界。是名五三分或报或报法或非报非报法。云何香界报。若香界受。是名香界报。云何香界报。若香界业法烦恼所生报我分摄。身好香非好香。软香非软香。适意香非适意香。是名香界报。云何香界非报非报法。若香界外。若外香鼻识所知。树根香树心香树胶香树皮香。叶香花香果香。好香非好香。及余外香鼻识所知。是名香界非报非报法。云何味界报。若味界受。是名味界报。云何味界报。若味界业法烦恼所生报我分摄。身甜酢苦辛咸淡涎癊。是名味界报。云何味界非报非报法。若味界外。若外味舌识所知。若甜酢苦辛咸淡。水汁及余外味舌识所知。是名味界非报非报法。云何触界报。若触界受。是名触界报。云何触界报。若触界业法烦恼所生报我分摄。身冷热轻重粗细涩滑坚软。是名触界报。云何触界非报非报法。若触界外。若外触身识所知。若冷热轻重粗细涩滑坚软。及余外触身识所知。是名触界非报非报法。云何眼识界报。若眼识界受。是名眼识界报。云何眼识界报。若眼识界业法烦恼所生报我分摄眼识界。是名眼识界报。云何眼识界非报非报法。若眼识界外眼识界。是名眼识界非报非报法。耳识界鼻识界舌识界身识界亦如是。云何色界报。若色界受。是名色界报。云何色界报。若色界业法烦恼所生报我分摄。身好色非好色。端严非端严。妍肤非妍肤。严净非严净。若受心所起去来屈申回转身教。是名色界报。云何色界报法。若色界有报。是名色界报法。云何色界报法。若色界善若不善。若善心若不善心所起去来屈申回转身教。是名色界报法。云何色界非报非报法。若色界无记非我分摄。非报非报法心所起去来屈申回转身教。若外色眼识所知。是名色界非报非报法。云何声界报。若声界受。是名声界报。云何声界报。若声界业法烦恼所生报我分摄。身好声非好声。众妙声非众妙声。软声非软声。若受心所起集声音句言语口教。是名声界报。云何声界报法。若声界有报。是名声界报法。云何声界报法。若声界善若不善。若善心若不善心所起集声音句言语口教。是名声界报法。云何声界非报非报法。若声界无记非我分摄。非报非报法心所起集声音句言语口教。若外声耳识所知。是名声界非报非报法。云何意界报。若意界若受若意界善报意界。是名意界报。云何意界报法。若意界有报。是名意界报法。云何意界报法。除意界善报。余意界善若不善意界是名意界报法。云何意界非报非报法。意界若无记识非我分摄意界。是名意界非报非报法。意识界亦如是。云何法界报。若法界善报除无贪无恚。余受想乃至心舍怖生命。无想定得果灭尽定。有漏身口戒无教。有漏身进有漏身除。正语正业正命正身进正身除。是名法界报。云何法界报法。若法界有报。是名法界报法。云何法界报法。除法界善报。余法界善有为。若不善受想。乃至烦恼使结二定一切色。是名法界报法。云何法界非报非报法。若法界无记非我分摄。若圣无为受想思触思惟觉观。见慧解脱悔不悔悦喜心进信欲念怖生老死。有漏身进九无为。是名法界非报非报法

十八界几见断。几思惟断。几非见断非思惟断。十三非见断非思惟断。五三分或见断或思惟断或非见断非思惟断。云何十三非见断非思惟断。八色界五识界。是名十三非见断非思惟断。云何五三分或见断或思惟断或非见断非思惟断。色界声界意界意识界法界。是名五三分或见断或思惟断或非见断非思惟断。云何色界见断。若色界不善非思惟断。见断烦恼心所起去来屈申回转身教。是名色界见断。云何色界思惟断。若色界不善非见断思惟断烦恼心所起去来屈申回转身教。是名色界思惟断。云何色界非见断非思惟断。若色界善若无记。身好色非好色。端严非端严。妍肤非妍肤。严净非严净。若善心若无记心所起去来屈申回转身教。若外色眼识所知。是名色界非见断非思惟断。云何声界见断。若声界不善非思惟断。见断烦恼心所起集声音句言语口教。是名声界见断。云何声界思惟断。若声界不善非见断。思惟断烦恼心所起集声音句言语口教。是名声界思惟断。云何声界非见断非思惟断。若声界善若无记。身好声非好声。众妙声非众妙声。软声非软声。若善心若无记心所起集声音句言语口教。若外声耳识所知。是名声界非见断非思惟断。云何意界见断。若意界不善非思惟断。见断烦恼相应心意界。是名意界见断。云何意界思惟断。若意界不善非见断思惟断烦恼相应意界。是名意界思惟断。云何意界非见断非思惟断。若意界善若无记意界。是名意界非见断非思惟断。意识界亦如是。云何法界见断。若法界不善非思惟断见断烦恼一时俱断。受想思触思惟觉观。见慧解脱悔不悔悦喜心进信欲念疑怖烦恼使结。身口非戒无教有漏身进。是名法界见断。云何法界思惟断。若法界不善非见断思惟断烦恼一时俱断。受想思触思惟觉观。见慧解脱悔不悔悦喜心进信欲念怖烦恼使结。身口非戒无教。有漏身进。是名法界思惟断。云何法界非见断非思惟断。若法界善若无记。除疑烦恼使结身口非戒无教。余法界。是名法界非见断非思惟断

十八界几见断因。几思惟断因。几非见断非思惟断因。一切三分。或见断因或思惟断因或非见断非思惟断因。云何眼界见断因。若眼界见断法报。地狱畜生饿鬼眼界。是名眼界见断因。云何眼界思惟断因。若眼界思惟断法报。地狱畜生饿鬼眼界。是名眼界思惟断因。云何眼界非见断非思惟断因。若眼界善法报。天上人中眼界。是名眼界非见断非思惟断因。耳界鼻界舌界身界亦如是。云何色界见断因。若色界见断。若色界见断法报。身非好色非端严非妍肤非严净。见断因心所起去来屈申回转身教。是名色界见断因。云何色界思惟断因。若色界若思惟断。若思惟断法报。身非好色非端严非妍肤非严净。思惟所断因心所起去来屈申回转身教。是名色界思惟断因。云何色界非见断非思惟断因。若色界善若色界善法报。若色界非报非报法。身好色端严妍肤。非见断非思惟断因心所起去来屈申回转身教。若外色眼识所知。是名色界非见断非思惟断因。云何声界见断因。若声界见断。若声界见断法报。身非好声非众妙声非软声。见断因心所起集声音句言语口教。是名声界见断因。云何声界思惟断因。若声界思惟断。若声界思惟断法报。身非好声非众妙声非软声。思惟断因心所起集声音句言语口教。是名声界思惟断因。云何声界非见断非思惟断因。若声界善法报。若声界非报非报法。身好声众妙声软声。非见断非思惟断因。心所起集声音句言语口教。若外声耳识所知。是名声界非见断非思惟断因。云何香界见断因。若香界见断法报。身非好香非软香非适意香是名香界见断因。云何香界思惟断因。若香界思惟断法报。身非好香非软香非适意香。是名香界思惟断因。云何香界非见断非思惟断因。若香界善法报。若香界非报非报法。身好香软香适意香。若外香鼻识所知。是名香界非见断非思惟断因。云何味界见断因。若味界见断法报。身甜酢苦辛咸淡涎癊。是名味界见断因。云何味界思惟断因。若味界思惟断法报。身甜酢苦辛咸淡涎癊。是名味界思惟断因。云何味界非见断非思惟断因。若味界善法报。若味界非报非报法身。甜酢苦辛咸淡涎癊。若外味舌识所知。是名味界非见断非思惟断因。云何触界见断因。若触界见断法报。身冷热粗重坚涩。是名触界见断因。云何触界思惟断因。若触界思惟断法报。身冷热粗重坚涩。是名触界思惟断因。云何触界非见断非思惟断因。若触界善法报。若触果非报非报法。身冷热轻细软滑。若外触身识所知。是名触界非见断非思惟断因。云何眼识界见断因。若眼识界见断法报。地狱畜生饿鬼眼识界。是名眼识界见断因。云何眼识界思惟断因。若眼识界思惟断法报。地狱畜生饿鬼眼识界。是名眼识界思惟断因。云何眼识界非见断非思惟断因。若眼识界善法报。若眼识界非报非报法。天上人中眼识界。是名眼识界非见断非思惟断因。耳识界鼻识界舌识界身识界亦如是。云何意界见断因。若意界若见断意界若见断法报意界。是名意界见断因。云何意界思惟断因。意界若意界思惟断。若意界思惟断法报。是名意界思惟断因。云何意界非见断非思惟断因。若意界善若意界善法报。若意界非报非报法意界。是名意界非见断非思惟断因。意识界亦如是。云何法界见断因。若法界见断法报。受想思触思惟觉观。见慧解脱悔不悔悦喜心进信欲念疑怖烦恼使生命结。身口非戒无教有漏身进。是名法界见断因。云何法界思惟断因。若法界思惟断法界思惟断法报。受想思触思惟觉观。见慧解脱悔不悔悦喜心进信欲念怖烦恼使生命结。身口非戒无教有漏身进。是名法界思惟断因。云何法界非见断非思惟断因。若法界善若法界善法报。若法界非报非报法。除疑烦恼使结身口非戒无教。余法界非见断非思惟断因。是名法界非见断非思惟断因

十八界。几欲界系。几色界系。几无色界系。几不系。六欲界系。九二分或欲界系或色界系。三四分或欲界系或色界系或无色界系或不系。云何六欲界系。鼻界香界鼻识界舌界味界舌识界。是名六欲界系。云何九二分或欲界系或色界系。眼界耳界身界色界声界触界眼识界耳识界身识界。是名九二分或欲界系或色界系。云何三四分或欲界系或色界系或无色界系或不系。意界意识界法界。是名三四分或欲界系或色界系或无色界系或不系。云何眼界欲界系。若眼界欲漏有漏眼界。是名眼界欲界系。云何眼界色界系。若眼界色漏有漏眼界。是名眼界色界系。耳界身界亦如是。云何色界欲界系。若色界欲漏有漏。身好色非好色。端严非端严。妍肤非妍肤。严净非严净。欲行心所起去来屈申回转身教。若外色眼识所知欲漏有漏。是名色界欲界系。云何色界色界系。若色界色漏有漏。身好色端严妍肤严净。色行心所起去来屈申回转身教。若外色眼识所知色漏有漏。是名色界色界系。云何声界欲界系。若声界欲漏有漏。身好声非好声。众妙声非众妙声。软声非软声。欲行心所起集声音句言语口教。若外声耳识所知欲漏有漏。是名声界欲界系。云何声界色界系若声界色漏有漏。身好声众妙声软声。色行心所起集声音句言语口教。若外声耳识所知色漏有漏。是名声界色界系。云何触界欲界系。若触界欲漏有漏。身冷热轻重粗细涩滑坚软。若外触身识所知欲漏有漏。是名触界欲界系。云何触界色界系。若触界色漏有漏。身冷热轻细软滑。若外触身识所知色漏有漏。是名触界色界系。云何眼识界欲界系。若眼识界欲漏有漏眼识界。是名眼识界欲界系。云何眼识界色界系。若眼识界色漏有漏眼识界。是名眼识界色界系。耳识界身识界亦如是。云何意界欲界系。若意界欲漏有漏意界。是名意界欲界系。云何意界色界系。若意界色漏有漏意界。是名意界色界系。云何意界无色界系。若意界无色漏有漏意界。是名意界无色界系。云何意界不系。若意界圣无漏意界。是名意界不系。意识界亦如是。云何法界欲界系。若法界欲漏有漏。受想思触思惟觉观。见慧解脱无贪无恚无痴。顺信悔不悔悦喜心进信欲不放逸念疑怖烦恼使生老死命结。身口非戒无教。有漏身口戒无教。有漏身进。是名法界欲界系。云何法界色界系。若法界色漏有漏受想思触思惟觉观。见慧解脱无痴顺信悦喜心进心除。信欲不放逸念定心舍疑烦恼使生老死命结无想定。有漏身口戒无教。有漏身进有漏身除。是名法界色界系。云何法界无色界系。若法界无色漏有漏。受想思触思惟觉观。见慧解脱无痴顺信心进心除信欲不放逸念定心舍疑烦恼使生老死命结。有漏身口戒无教。有漏身进有漏身除。是名法界无色界系。云何法界不系。若法界圣无漏无为。受想思触思惟觉观。见慧解脱无痴顺信悦喜心进心除。信欲不放逸念定心舍得果灭尽定。正语正业正命正身进正身除九无为。是名法界不系

十八界。几过去几未来几现在。几非过去非未来非现在。十七三分。或过去或未来或现在。一四分。或过去或未来或现在。或非过去非未来非现在。云何十七三分或过去或未来或现在。眼界乃至意识界。是名十七三分或过去或未来或现在。云何一四分或过去或未来或现在或非过去非未来非现在。法界是名一四分或过去或未来或现在或非过去非未来非现在。云何眼界过去。若眼界生已灭眼界。是名眼界过去。云何眼界未来。若眼界未生未出眼界。是名眼界未来。云何眼界现在。若眼界生未灭眼界。是名眼界现在。乃至意识界亦如是。云何法界过去。若法界生已灭受想乃至正身除。是名法界过去。云何法界未来。若法界未生未出受想乃至正身除。是名法界未来。云何法界现在。若法界生未灭受想乃至正身除。是名法界现在。云何法界非过去非未来非现在。若法界无为智缘尽。乃至非有想非非想处智。是名法界非过去非未来非现在

舍利弗阿毗昙论卷第二舍利弗阿毗昙论卷第三

        姚秦罽宾三藏昙摩耶舍共昙摩崛多等译

    问分阴品第三

问曰。几阴。答曰五阴。何等五。色阴受阴想阴行阴识阴。云何色阴。若色法是名色阴。云何色阴。十色入若法入色。是名色阴。云何色阴。四大若四大所造色是名色阴。云何色阴。三行色。可见有对色。不可见有对色。不可见无对色。是名色阴。云何色阴。若色过去未来现在。内外粗细卑胜远近。是名色阴。云何色法。眼耳鼻舌身入。色声香味触入。身口非戒无教。有漏身口戒无教。有漏身进有漏身除。正语正业正命正身进正身除。是名色法。云何十色入。眼耳鼻舌身入。色声香味触入。是名十色入。云何法入色。身口非戒无教有漏身口戒无教。有漏身进有漏身除。正语正业正命正身进正身除。是名法入色。云何四大。地大水大火大风大。是名四大。云何四大所造色。眼耳鼻舌身色声香味。身口非戒无教。有漏身口戒无教。有漏身进有漏身除。正语正业正命正身进正身除。是名四大所造色

云何可见有对色。色入。是名可见有对色。云何不可见有对色。眼耳鼻舌身声香味触入。是名不可见有对色。云何不可见无对色。身口非戒无教。有漏身口戒无教。有漏身进有漏身除。正语正业正命正身进正身除。是名不可见无对色。云何过去色。若色生已灭。是名过去色。云何未来色。若色未生未出。是名未来色。云何现在色。若色生未灭。是名现在色。云何内色。若色受。是名内色。云何外色。若色非受。是名外色。云何粗色。若色欲界系。是名粗色。云何细色。若色色界系若无色界系若不系。是名细色。云何卑色。若色不善若色不善法报。若色非报非报法不适意。是名卑色云何胜色。若色善若色善法报。若色非报非报法适意。是名胜色。云何远色。若诸色相远极相远不近不近边。是名远色。云何近色。若色相近极相近近边是名近色

云何受阴。一受受阴若心受。是名受阴。云何受阴。二受受阴身受心受。是名受阴。云何受阴。三受受阴乐受苦受非苦非乐受。是名受阴。云何受阴。四受受阴欲界系受色界系受无色界系受不系受。是名受阴。云何受阴。五受受阴乐根苦根喜根忧根舍根。是名受阴。云何受阴。六受受阴眼触受耳鼻舌身意触受。是名受阴。云何受阴。七受受阴眼识界相应受耳鼻舌身意界意识界相应受。是名受阴。云何受阴。十八意行及余意受。是名受阴。云何受阴。三十六尊句及余意受。是名受阴。云何受阴。百八受及余意受。是名受阴。云何受阴。若过去未来现在。内外粗细卑胜远近受。是名受阴。云何身受。若受身识相应。是名身受。云何心受。若受意识相应。是名心受。云何身受。若受五识身相应。眼识耳识鼻识舌识身识。是名身受。云何心受。若受意识相应。是名心受。云何乐受。若身心乐受。是名乐受。云何苦受。若身心苦受是名苦受。云何非苦非乐受。若身心非苦非乐受。是名非苦非乐受。云何欲界系受。若受欲漏有漏。是名欲界系受。云何色界系受。若受色漏有漏。是名色界系受。云何无色界系受。若受无色漏有漏。是名无色界系受。云何不系受。若受圣无漏。是名不系受。云何乐根。若身乐受眼触乐受。耳鼻舌身触乐受乐界。是名乐根。云何苦根。若身苦受眼触苦受。耳鼻舌身触苦受苦界。是名苦根。云何喜根。若身心乐受意触乐受喜界。是名喜根。云何忧根。若身心苦受意触苦受忧界。是名忧根。云何舍根。若身心非苦非乐受。眼触非苦非乐受。耳鼻舌身意触非苦非乐受舍界。是名舍根。云何眼触受。若受眼识相应。是名眼触受。云何耳鼻舌身意触受。若受意识相应。是名意触受。云何眼触受。缘眼缘色生眼识。三法和合触缘触受。名眼触受。云何耳鼻舌身意触受。缘意缘法生意识。三法和合触缘触受。是名意触受。云何眼识界相应受。若受眼识界共生共住共灭。是名眼识界相应受。云何耳鼻舌身意界意识界相应受。若受意识界共生共住共灭。是名意识界相应受。云何十八意行。六喜行六忧行六舍行。如是六喜行六忧行六舍行。是名十八意行云何除十八意行余意受。除十八意行余意受。是名除十八意行余意受。云何三十六尊句。依六贪喜。依六出喜。依六贪忧。依六出忧。依六贪舍。依六出舍。云何依六贪喜。眼知色爱喜适意爱色欲染相应。今得当得已得。过去变灭忆念生喜。如是喜是名依贪喜。耳鼻舌身意。知法爱喜适意爱法欲染相应。今得当得已得。过去变灭忆念生喜。如是生喜是名依贪喜。是名依六贪喜。云何依六出喜。色无我知无常变异离欲灭。如实观过去如此色无常苦变。如实观生喜。如是喜名依出喜。声香味触法无我。知无常变异离欲灭。如实观过去如此法无常苦变。如实观生喜。如是喜是名依出喜。是名依六出喜。云何依六贪忧。眼知色爱喜适意爱色欲染相应。今未得当未得。已得变灭忆念生忧。如是忧是名依贪忧。耳鼻舌身意知法爱喜适意爱法欲染相应。今未得当未得。已得变灭忆念生忧。如是忧是名依贪忧。是名依六贪忧。云何依六出忧。色无我知无常变异离欲灭。如实观过去如此色无常苦变。如实观已。于寂灭解脱胜法悕求。何时当入。如诸圣人所成就行。缘此生忧。如是忧是名依六出忧。声香味触法无我知无常变异离欲灭。如实观过去如此法无常苦变。如实观已。于寂灭解脱胜法希求。何时当入。如诸圣人所成就行。缘此生忧。如是忧是名依出忧。是名依六出忧。云何依六贪舍。眼见色凡夫人生舍。痴如小儿不见过患不知报。如是不知得舍。于色无方便。是名依贪舍。耳鼻舌身意知法凡夫人生舍。痴如小儿不见过患不知报。如是不知得舍。于法无方便。是名依贪舍。是名依六贪舍。云何依六出舍。色无我知无常变异离欲灭。如实观过去色如此色无常苦变异。如实观已生舍。如是知得舍。于色有方便。是名依出舍。声香味触法无我知无常变异离欲灭。如实观过去如此法无常苦变异。如实观已生舍。如是知得舍。于法有方便。是名依六出舍。如是依六贪生喜。依六出生喜。如是依六贪忧。依六出忧。如是依六贪舍。依六出舍。如是和合。是名三十六尊句。云何除三十六尊句余意受。除三十六尊句余意受。是名除三十六尊句余意受。云何百八受。过去三十六尊句。未来三十六尊句。现在三十六尊句。如是和合。是名百八受。云何除百八受余意受。除百八受余意受。是名除百八受余意受。云何过去受。若受生已灭。是名过去受。云何未来受。若受未生未出。是名未来受。云何现在受。若受生未灭。是名现在受。云何内受。若受受。是名内受。云何外受。若受非受。是名外受。云何粗受。若受欲界系。是名粗受。云何细受。若受色界系无色界系不系。是名细受。云何卑受。若受不善若受不善法报。若受非报非报法不适意。是名卑受。云何胜受。若受善法报若受非报非报法适意。是名胜受。云何远受。若受诸受相远极相远不近不近边是名远受。云何近受。若受相近极相近近边。是名近受。云何想阴。一想想阴若想识想究竟识想。是名想阴。云何想阴。二想想阴身受相应想心受相应想。是名想阴。云何想阴。三想想阴乐受相应想苦受非苦非乐受相应想。是名想阴。云何想阴。四想想阴欲界系想色界系想无色界系想不系想。是名想阴。云何想阴。五想想阴乐根相应想苦根喜根忧根舍根相应想。是名想阴。云何想阴。六想想阴色想声香味触法想。是名想阴。云何想阴。七想想阴眼识界相应想耳鼻舌身意界意识界相应想。是名想阴。云何想阴。十八意行相应想及余想识想究竟识想。是名想阴。云何想阴。三十六尊句相应想。及余想识想究竟识想。是名想阴。云何想阴。百八受相应想。及余想识想究竟识想。是名想阴。云何想阴。若想过去未来现在内外粗细卑胜远近。是名想阴。云何身受相应想。若想身受共生共住共灭。是名身受相应想。云何心受相应想。若想心受共生共住共灭。是名心受相应想。云何乐受相应想。若想乐受共生共住共灭。是名乐受相应想。云何苦受非乐非苦受相应想。若想苦受非乐非苦受共生共住共灭。是名非乐非苦受相应想。云何欲界系想。若想欲漏有漏。是名欲界系想。云何色界系想。若想色漏有漏。是名色界系想。云何无色界系想。若想无色漏有漏。是名无色界系想。云何不系想。若想圣无漏。是名不系想。云何乐根相应想。若想乐根共生共住共灭。是名乐根相应想。云何苦根喜根忧根舍根相应想。若想舍根共生共住共灭。是名非苦非乐根相应想。云何色想。若想眼识相应想。是名色想。云何声香味触法想。若想意识相应想。是名法想。云何色想。色境界思惟色。若想识想究竟识想。是名色想。云何声香味触法想。法境界思惟法。若想识想究竟识想。是名法想。云何眼识界相应想。若想眼识界共生共住共灭。是名眼识界相应想。云何耳鼻舌身意界意识界相应想。若想意识界共生共住共灭。是名意识界相应想。云何十八意行相应想。若想十八意行共生共住共灭。是名十八意行相应想。云何除十八意行相应想。余想识想究竟识想。除十八意行相应想余想。是名除十八意行相应想余想识想究竟识想。云何三十六尊句相应想。若想三十六尊句共生共住共灭。是名三十六尊句相应想。云何除三十六尊句相应想。余想识想究竟识想。除三十六尊句相应想余想。是名除三十六尊句相应想余想识想究竟识想。云何百八受相应想。若想百八受共生共住共灭。是名百八受相应想。云何除百八受相应想。余想识想究竟识想。除百八受相应想余想。是名除百八受相应想余想识想究竟识想。云何过去想。若想生已灭。是名过去想。云何未来想。若想未生未出。是名未来想。云何现在想。若想生未灭。是名现在想。云何内想。若想受。是名内想。云何外想。若想非受。是名外想。云何粗想。若想欲界系。是名粗想。云何细想。若想色界系若无色界系若不系。是名细想。云何卑想。若想不善若想不善法报。若想非报非报法不适意。是名卑想。云何胜想。若想善若想善法报。若想非报非报法适意。是名胜想。云何远想。若想诸想相远极相远不近不近边。是名远想。云何近想。若想相近极相近近边。是名近想

云何行阴。除受阴想阴识阴。余法非色有为。是名行阴。云何行阴。思触思惟觉观见慧解脱。无贪无恚无痴。顺信悔不悔悦喜心进心除。信欲不放逸念定心舍疑怖烦恼使生老死命结。无想定得果灭尽定。是名行阴

云何识阴。意入是名识阴。云何识阴。意根是名识阴。云何识阴。若心意识六识身七识界。是名识阴。云何识阴。若识过去未来现在。内外粗细卑胜远近。是名识阴。云何六识身。眼识身耳鼻舌身意识身。云何眼识身。缘眼缘色缘明缘思惟。以此四缘识已生今生当生不定。是名眼识身。云何耳鼻舌身意识身。缘意缘法缘思惟。以此三缘识已生今生当生不定。是名意识身。是名六识身。云何七识界。眼识界耳鼻舌身识界意界意识界。云何眼识界。若识眼根生色境界。已生今生当生不定。是名眼识界。云何耳鼻舌身识界。若识身根生触境界。已生今生当生不定。是名身识界。云何意界。意知法思惟法。若初心已生今生当生不定。是名意界。云何意识界。若识相似不离彼境界。及余相似心已生今生当生不定。是名意识界。是名七识界。云何过去识。若识生已灭。是名过去识云何未来识。若识未生未出。是名未来识。云何现在识。若识生未灭。是名现在识。云何内识。若识受。是名内识。云何外识。若识非受。是名外识。云何粗识。若识欲界系。是名粗识。云何细识。若识色界系无色界系若不系。是名细识。云何卑识。若识不善若识不善法报。若识非报非报法不适意。是名卑识。云何胜识。若识善若识善法报。若识非报非报法适意。是名胜识。云何远识。若识诸识相远极相远不近不近边。是名远识。云何近识。若识相近极相近近边。是名近识。五阴几色几非色。一色四非色。云何一色。色阴是名一色。云何四非色。受阴想阴行阴识阴。是名四非色

五阴几可见几不可见。四不可见。一二分。或可见或不可见。云何四不可见。受阴想阴行阴识阴。是名四不可见。云何一二分或可见或不可见。色阴是名一二分或可见或不可见。云何色阴可见。色入。是名色阴可见。云何色阴不可见。除色入余色阴不可见。是名色阴不可见

五阴几有对几无对。四无对。一二分或有对或无对。云何四无对。受阴想阴行阴识阴。是名四无对。云何一二分或有对或无对。色阴是名一二分或有对或无对。云何色阴有对。十色入是名色阴有对云何色阴无对。法入色是名色阴无对

五阴几圣几非圣。一切二分。或圣或非圣。云何色阴非圣。若色阴有漏。是名色阴非圣。云何色阴非圣。色受阴是名色阴非圣。云何色阴非圣。若色阴非学非无学十色入初四色。是名色阴非圣。云何色阴圣。若色阴无漏。是名色阴圣。云何色阴圣。若色阴学若无学。学人离结使圣心入圣道。若坚信若坚法。及余趣人见行过患。观涅槃寂灭。如实观苦集灭道。未得欲得。未解欲解。未证欲证。离烦恼修道。见学人若须陀洹斯陀含阿那含。观智具足。若智地若观解脱心。即证沙门果。若须陀洹果斯陀含果阿那含果。无学人欲得阿罗汉果。未得圣法。欲得修道。观智具足。若智地若观解脱心。即得阿罗汉果。若实人若趣正语正业正命正身进正身除。是名色阴圣。云何受阴非圣。若受阴有漏。是名受阴非圣。云何受阴非圣。若受受阴。是名受阴非圣。云何受阴非圣。若受阴非学非无学。眼触受耳鼻舌身意触受。是名受阴非圣。云何受阴圣。若受阴无漏。是名受阴圣。云何受阴圣。信根相应意触受。是名受阴圣。云何受阴圣。若受阴学若无学。学人离结使。乃至欲得证阿罗汉果。若实人若趣若意触。是名受阴圣。云何想阴非圣。若想阴有漏。是名想阴非圣

云何想阴非圣。想受阴。是名想阴非圣。云何想阴非圣。若想阴非学非无学。色想声香味触法想。是名想阴非圣。云何想阴圣。若想阴圣无漏。是名想阴圣。云何想阴圣。若想阴信根相应法想。是名想阴圣。云何想阴圣。若想阴学若无学。学人离结使。乃至即证阿罗汉果。若实人若趣若法想。是名想阴圣。云何行阴非圣。若行阴有漏。是名行阴非圣。云何行阴非圣。若行受阴。是名行阴非圣。云何行阴非圣。若行阴非学非无学。思乃至无想定。是名行阴非圣。云何行阴圣。若行阴无漏。是名行阴圣。云何行阴圣。若信根信根相应心数法。若缘无漏行阴所摄。是名行阴圣。云何行阴圣。若行阴学若无学。学人离结使。乃至即得阿罗汉果。若实人若趣若思触思惟觉观。见慧解脱无痴顺信悦喜心进心除。信欲不放逸念定心舍得果灭尽定。是名行阴圣。云何识阴非圣。若识阴有漏。是名识阴非圣。云何识阴非圣。识受阴是名识阴非圣云何识阴非圣。若识阴非学非无学。眼识乃至意识。是名识阴非圣。云何识阴圣。若识阴无漏。是名识阴圣。云何识阴圣。若识阴信根相应意识界。是名识阴圣。云何识阴圣。若识阴学若无学。学人离结使。乃至即得阿罗汉果。若实人若趣若意界意识界。是名识阴圣。有漏无漏有爱无爱有求无求当取非当取有取无取有胜无胜亦如是。五阴几受几非受。一切二分。或受或非受。云何色阴受。若色阴内。是名色阴受。云何色阴受。若色阴业法烦恼所生报我分摄。眼入耳鼻舌身入。身好色非好色。端严非端严。妍肤非妍肤。严净非严净。身好声非好声。众妙声非众妙声。软声非软声。身好香非好香。软香非软香。适意香非适意香。身甜酢苦辛咸淡涎癊。身冷热轻重粗细涩滑坚软。受心所起去来屈申回转身教。集声音句言语口教有漏身进。是名色阴受。云何色阴非受。若色阴外。是名色阴非受。云何色阴非受。若色阴善若不善若无记非我分摄。若善心若不善心若非报非报法。心所起去来屈申回转身教。集声音句言语口教。若外色眼识所知。若声香味触。若外触身识所知。身口非戒无教。有漏身口戒无教。有漏身进有漏身除。正语正业正命正身进正身除。是名色阴非受。云何受阴受。若受阴内。是名受阴受。云何受阴受。若受阴业法烦恼所生报我分摄。眼触受耳鼻舌身意触受。是名受阴受。云何受阴非受。受阴若外。是名受阴非受。云何受阴非受。受阴若善若不善若无记非我分摄。眼触受耳鼻舌身意触受。是名受阴非受。云何想阴受。若想阴内。是名想阴受。云何想阴受。若想阴业法烦恼所生报我分摄。色想声香味触法想。是名想阴受。云何想阴非受。若想阴外。是名想阴非受。云何想阴非受。若想阴善若不善若无记非我分摄。色想声香味触法想。是名想阴非受。云何行阴受。若行阴内。是名行阴受。云何行阴受。若行阴业法烦恼所生报我分摄。思触思惟觉观。见慧解脱悔不悔悦喜心进信欲念怖生命。是名行阴受。云何阴非受。若行阴外。是名行阴非受。云何行阴非受。若行阴善若不善若无记非我分摄。除命余行阴非受。是名行阴非受。云何识阴受。若识阴内。是名识阴受。云何识阴受。若识阴业法烦恼所生报我分摄。眼识乃至意识。是名识阴受。云何识阴非受。若识阴外。是名识阴非受。云何识阴非受。若识阴善若不善若无记非我分摄。眼识乃至意识。是名识阴非受。内外亦如是

五阴几有报几无报。一切二分。或有报或无报。云何色阴有报。若色阴报法。是名色阴有报。云何色阴有报。除色阴善报。余色阴善不善。若善心若不善心所起去来屈申回转身教。集声音句言语口教。身口非戒无教。有漏身口戒无教。有漏身进有漏身除。正语正业正命正身进正身除。是名色阴有报。云何色阴无报。若色阴非报非报法。眼入耳鼻舌入身入。香入味入触入。身好色非好色。端严非端严。妍肤非妍肤。严净非严净。身好声非好声。众妙声非众妙声。软声非软声。无记心所起去来屈申回转身教。集声音句言语口教。若外色眼识所知。若外声耳识所知。有漏身口戒无教。有漏身进有漏身除。正语正业正命正身进正身除。是名色阴无报。云何受阴有报。若受阴报法。是名受阴有报。云何受阴有报。除受阴善报。余受阴善若不善意触受。是名受阴有报。云何受阴无报。若受阴报若受阴非报非报法。眼触受耳鼻舌身意触受。是名受阴无报。云何想阴有报。想阴若报法。是名想阴有报。云何想阴有报。除想阴善报。余想阴善若不善法想。是名想阴有报。云何想阴无报。想阴若报想阴若非报非报法。色想声香味触法想。是名想阴无报。云何行阴有报。行阴若报法。是名行阴有报。云何行阴有报。除行阴善报。余行阴善若不善思乃至烦恼使结二定。是名行阴有报。云何行阴无报。行阴若报行阴若非报非报法。除无贪无恚痴烦恼使结。余行阴无报。是名行阴无报。云何识阴有报。识阴若报法。是名识阴有报。云何识阴有报。除识阴善报。余识阴善若不善意界意识界。是名识阴有报。云何识阴无报。识阴若报识阴若非报非报法。眼识乃至意识。是名识阴无报

五阴几心几非心。一心四非心。云何一心。识阴是名一心。云何四非心。色阴受阴想阴行阴。是名四非心

五阴几心相应。几非心相应。二心相应。一非心相应。一不说心相应非心相应。一二分或心相应或非心相应。云何二心相应。受阴想阴。是名二心相应。云何一非心相应。色阴是名一非心相应。云何一不说心相应非心相应。识阴是名一不说心相应非心相应。云何一二分或心相应或非心相应。行阴是名一二分或心相应或非心相应。云何行阴心相应。行阴若心数思乃至烦恼使。是名行阴心相应。云何行阴非心相应。行阴若非心数生乃至灭尽定。是名行阴非心相应

五阴几心数几非心数。二心数二非心数。一二分或心数或非心数。云何二心数。受阴想阴。是名二心数。云何二非心数。色阴识阴。是名二非心数。云何一二分或心数或非心数。行阴是名一二分或心数或非心数。云何行阴心数。行阴若缘思乃至烦恼使。是名行阴心数。云何行阴非心数。行阴若非缘生乃至灭尽定。是名行阴非心数

五阴几有缘几非缘。三缘一非缘。一二分或缘或非缘。云何三缘。受阴想阴识阴。是名三缘

云何一非缘。色阴是名一非缘。云何一二分或缘或非缘。行阴是名一二分或缘或非缘。云何行阴缘。行阴若心数思乃至烦恼使。是名行阴缘。云何行阴非缘。行阴若非心数生乃至灭尽定。是名行阴非缘

五阴几共心几非共心。二共心。一非共心。二二分或共心或非共心。云何二共心。受阴想阴。是名二共心。云何一非共心。识阴是名一非共心。云何二二分或共心或非共心。色阴行阴。是名二二分或共心或非共心。云何色阴共心。若随心转共心生共住共灭。有漏身口戒无教。有漏身进有漏身除。正语正业正命正身进正身除。是名色阴共心。云何色阴不共心。若不随心转不共心生。不共住不共灭。十色入一切法入色。是名色阴非共心。云何行阴共心。行阴若随心转共心生共住共灭。思乃至烦恼使。是名行阴共心。云何行阴不共心。行阴若不随心转不共心。生不共住不共灭。生乃至灭尽定。是名行阴不共心。随心转不随心转亦如是

五阴几业几非业。三非业。二二分或业或非业。云何三非业。受阴想阴识阴。是名三非业。云何二二分或业或非业。色阴行阴。是名二二分或业或非业。云何色阴业。若善心若不善心若无记心所起去来屈申回转身教。集声音句言语口教。身口非戒无教。有漏身口戒无教。正语正业正命。是名色阴业。云何色阴非业。眼入耳入鼻舌身入香味触入。身好色非好色。端严非端严。妍肤非妍肤。严净非严净。身好声非好声。众妙声非众妙声。软声非软声。若外色眼识所知。若外声耳识所知。有漏身进有漏身除。正身进正身除。是名色阴非业。云何行阴业。思是名行阴业。云何行阴非业。除思余行阴。是名行阴非业

五阴几业相应。几非业相应。三业相应。一非业相应。一三分或业相应或非业相应。或不说业相应非业相应。云何三业相应。受阴想阴识阴。是名三业相应。云何一非业相应。色阴是名一非业相应。云何一三分或业相应或非业相应。或不说业相应非业相应。行阴是名一三分或业相应或非业相应。或不说业相应非业相应。云何行阴业相应。行阴若思相应触乃至烦恼使。是名行阴业相应。云何行阴非业相应。行阴若非思相应。生乃至灭尽定。是名行阴非业相应。云何行阴不说业相应非业相应。思是名行阴不说业相应非业相应

五阴几共业几不共业。三共业。二二分或共业或不共业。云何三共业。受阴想阴识阴。是名三共业。云何二二分或共业或不共业。色阴行阴。是名二二分或共业或不共业。云何色阴共业。色阴若随业转共业生共住共灭。有漏身口戒无教。有漏身进有漏身除。正语正业正命正身进正身除。是名色阴共业。云何色阴不共业。色阴若不随业转不共业生不共住不共灭。十色入初三色。是名色阴不共业。云何行阴共业。行阴若随业转共业生共住共灭。又定心思触乃至烦恼使无想定灭尽定。是名行阴共业。云何行阴不共业。若行阴不随业转不共业生不共住不共灭。不定心思生老死命结得果。是名行阴不共业。随业转不随业转。亦如是

五阴几因几非因。三因。二二分或因或非因。云何三因。受阴想阴识阴。是名三因。云何二二分或因或非因。色阴行阴。是名二二分或因或非因。云何色阴因。色阴若报法。是名色阴因。云何色阴因。色阴善若不善及四大善心若不善心所起去来屈申回转身教。集声音句言语口教。地水火风大。身口非戒无教。有漏身口戒无教。有漏身进有漏身除。正语正业正命正身进正身除。是名色阴因。云何色阴非因。若色阴报色阴非报非报法。眼入耳鼻舌入身入香味入。身好色非好色。端严非端严。妍肤非妍肤。严净非严净。身好声非好声。众妙声非众妙声。软声非软声。无记心所起去来屈申回转身教。集声音句言语口教。若外色眼识所知。若外声耳识所知。除四大余触入所摄有漏身进。是名色阴非因。云何行阴因。行阴缘行阴非缘有报。除得果余行阴非缘善报。思乃至烦恼使结二定。是名行阴因。云何行阴非因。行阴缘无报不共业生老死命得果。是名行阴非因

五阴几有因几无因。一切有因。一切有结。一切有缘。一切有为

五阴几知几非知。一切知如事知见。一切识意识如事识。一切解如事知见。一切了如事知见

五阴几断智知。几非断智知。一切二分。或断智知或非断智知。云何色阴断智知。色阴不善不善心所起去来屈申回转身教。集声音句言语口教。身口非戒无教。有漏身进。是名色阴断智知。云何色阴非断智知。色阴善无记。眼入耳入鼻入舌入身入香入味入触入。身好色非好色。端严非端严。妍肤非妍肤。身好声非好声。众妙声非众妙声。软声非软声。善心若无记心所起。去来屈申回转身教。集声音句言语口教。若外色眼识所知。若外声耳识所知。有漏身口戒无教。有漏身进有漏身除。正语正业正命正身进正身除。是名色阴非断智知。云何受阴断智知。受阴不善思触思惟觉观。见慧解脱悔不悔悦喜心进信欲念疑怖烦恼使结。是名受阴断智知。云何受阴非断智知。受阴善无记眼触受耳鼻舌身意触受。是名受阴非断智知。云何想阴断智知。想阴不善法想。是名想阴断智知。云何想阴非断智知。想阴善无记色想声香味触法想。是名想阴非断智知。云何行阴断智知。行阴不善思触思惟觉观。见慧解脱悔不悔悦喜心进信欲念疑怖烦恼使结。是名行阴断智知。云何行阴非断智知。行阴善无记。除疑烦恼使结。余行阴非断智知。是名行阴非断智知。云何识阴断智知。识阴不善意界。是名识阴断智知。云何识阴非断智知。识阴善无记。眼识乃至意识是名识阴非断智知。断非断亦如是

五阴几修几非修。一切二分。或修或非修。云何色阴修。色阴若善心所起去来屈申回转身教。集声音句言语口教。有漏身口戒无教。有漏身进有漏身除。正语正业正命正身除。是名色阴修。云何色阴非修。色阴不善无记。眼入耳入鼻入舌入身入香入味入触入。身好色非好色。端严非端严。妍肤非妍肤。严净非严净。身好声非好声。众妙声非众妙声。软声非软声。不善心无记心所起。去来屈申回转身教。集声音句言语口教。若外色眼识所知。若外声耳识所知。身口非戒无教有漏身进。是名色阴非修。云何受阴修。受阴善意触受。是名受阴修。云何受阴非修。受阴不善无记眼触受耳鼻舌身意触受。是名受阴非修。云何想阴修。想阴善法想。是名想阴修。云何想阴非修。想阴不善无记色想声香味触法想。是名想阴非修。云何行阴修。行阴善思乃至心舍无想定得果灭尽定。是名行阴修。云何行阴非修。行阴不善无记思触思惟觉观。见慧解脱悔不悔悦喜心进信欲念疑怖烦恼使生老死命。是名行阴非修。云何识阴修。识阴善意界意识界。是名识阴修。云何识阴非修。识阴不善无记。眼识乃至意识。是名识阴非修

五阴几证几非证。一切证如事知见

五阴几善几不善几无记。一切三分。或善或不善或无记。云何色阴善。若色阴修善心所起。去来屈申回转身教。集声音句言语口教。有漏身口戒无教。有漏身进有漏身除。正语正业正命正身除。是名色阴善。云何色阴不善。若色阴断不善心所起。去来屈申回转身教。集声音句言语口教。身口非戒无教。有漏身进。是名色阴不善。云何色阴无记。色阴受色阴非报非报法。眼入耳入鼻入舌入身入香入味入触入。身好色非好色。端严非端严。妍肤非妍肤。严净非严净。身好声非好声。众妙声非众妙声。软声非软声。无记心所起去来屈申回转身教。集声音句言语口教。若外色眼识所知。外声耳识所知。有漏身进。是名色阴无记。云何受阴善。若受阴修意触受。是名受阴善。云何受阴不善。受阴断意触受。是名受阴不善。云何受阴无记。受阴受受阴若非报非报法眼触受耳鼻舌身意触受。是名受阴无记。云何想阴善。若想阴修法想。是名想阴善。云何想阴不善想阴断。法想是名想阴不善。云何想阴无记。想阴受想阴非报非报法色想声香味触法想。是名想阴无记。云何行阴善。行阴修思乃至心舍无想定得果灭尽定。是名行阴善。云何行阴不善行阴断思触思惟觉观。见慧解脱悔不悔悦喜心进信欲念疑怖烦恼使结。是名行阴不善。云何行阴无记。行阴受行阴非报非报法思触思惟觉观见慧解脱悔不悔悦喜心进信欲念怖生老死命。是名行阴无记。云何识阴善。识阴修意界意识界。是名识阴善。云何识阴不善。识阴断意界意识界。是名识阴不善。云何识阴无记。识阴受识阴非报非报法眼识乃至意识。是名识阴无记

五阴几学几无学。几非学非无学。一切三分。或学或无学或非学非无学。云何色阴学。色阴若圣非无学。是名色阴学。云何色阴学。学人离结使圣心入圣道。若坚信若坚法。及余趣人见行过患观涅槃寂灭。如实观苦集灭道。未得欲得。未解欲解。未证欲证。离烦恼修道。见学人若须陀洹斯陀含阿那含观智具足。若智地若观解脱心。即证沙门果。若须陀洹果若斯陀含果若阿那含果。若实人若趣正语正业正命正身进正身除。是名色阴学。云何色阴无学。色阴若圣非学。是名色阴无学。云何色阴无学。无学人欲得阿罗汉。未得圣法欲得修道观智具足。若智地若观解脱心。即得阿罗汉果。若实人若趣正语。正业正命正身进正身除。是名色阴无学。云何色阴非学非无学。色阴非圣色受阴十色入初四色。是名色阴非学非无学。云何受阴学。受阴圣非无学。是名受阴学。云何受阴学。受阴学信根相应意触受。是名受阴学。云何受阴学。学人离结使乃至即证阿那含果若实人若趣意触受。是名受阴学。云何受阴无学。受阴圣非学。是名受阴无学。云何受阴无学。受阴无学信根相应意触受。是名受阴无学。云何受阴无学。无学人欲得阿罗汉乃至即得阿罗汉果。若实人若趣意触受。是名受阴无学。云何受阴非学非无学。受阴非圣受受阴眼触受耳鼻舌身意触受。是名受阴非学非无学。云何想阴学想阴圣非无学。是名想阴学。云何想阴学。想阴学信根相应法想。是名想阴学。云何想阴学。学人离结使乃至即得阿那含果。若实人若趣法想。是名想阴学。云何想阴无学。想阴圣非学。是名想阴无学。云何想阴无学。想阴无学信根相应法想。是名想阴无学。云何想阴无学。无学人欲得阿罗汉。乃至即得阿罗汉果。若实人若趣法想。是名想阴无学。云何想阴非学非无学。想阴非圣想受阴色想声香味触法想。是名想阴非学非无学。云何行阴学。行阴圣非无学。是名行阴学。云何行阴学。行阴学信根相应心数法。若法非缘无漏行阴所摄非无学。是名行阴学。云何行阴学。学人离结使乃至即得阿那含果。若实人若趣若思触思惟觉观。见慧解脱无痴顺信悦喜心进心除。信欲不放逸念定心舍得果灭尽定。是名行阴学。云何行阴无学。行阴圣非学。是名行阴无学。云何行阴无学。无学信根相应心数法。若法非缘无漏行阴所摄非学。是名行阴无学。云何行阴无学。无学人欲得阿罗汉。乃至即得阿罗汉果。若实人若趣思触思惟觉观。见慧解脱无痴信顺悦喜心进心除。信欲不放逸念定心舍得果灭尽定。是名行阴无学。云何行阴非学非无学。行阴若非圣受阴思乃至无想定。是名行阴非学非无学。云何识阴学。识阴若圣非无学。是名识阴学。云何识阴学。识阴学信根相应意界意识界是名识阴学。云何识阴学。学人离结使。乃至即得阿那含果。若实人若趣若意界意识界。是名识阴学。云何识阴无学。识阴若圣非学。是名识阴无学。云何识阴无学。识阴无学信根相应意界意识界。是名识阴无学。云何识阴无学。无学人欲得阿罗汉。乃至即得阿罗汉果。若实人若趣若意界意识界。是名识阴无学。云何识阴非学非无学。识阴非圣识受阴眼识乃至意识。是名识阴非学非无学

五阴几报几报法。几非报非报法。一切三分。或报或报法或非报非报法。云何色阴报。色阴若受色阴善报。眼入耳入鼻入舌入身入。身好色非好色。端严非端严。妍肤非妍肤。严净非严净。身好声非好声。众妙声非众妙声。软声非软声。身好香非好香。软香非软香。适意香非适意香。身甜酢苦辛咸淡涎癊。身冷热轻重粗细涩滑坚软。受心所起去来屈申回转身教。集声音句言语口教。有漏身口戒无教。有漏身进有漏身除。正语正业正命正身进正身除。是名色阴报。云何色阴报法。色阴若有报。是名色阴报法。云何色阴报法。除色阴善报。余色阴善不善若善心若不善心所起去来屈申回转身教。集声音句言语口教。身口非戒无教。有漏身口戒无教。有漏身进有漏身除。正语正业正命正身进正身除。是名色阴报法。云何色阴非报非报法。色阴若无记非我分摄。非报非报法心所起去来屈申回转身教。集声音句言语口教。若外色眼识所知。若外声香味触。若外触身识所知。有漏身进。是名色阴非报非报法。云何受阴报。受阴若受受阴善报眼触受耳鼻舌身意触受。是名受阴报。云何受阴报法。受阴有报。是名受阴报法。云何受阴报法。除受阴善报。余受阴善不善意触受。是名受阴报法。云何受阴非报非报法。受阴无记非我分摄。眼触受耳鼻舌身意触受。是名受阴非报非报法。云何想阴报。想阴若受想阴善报色想声香味触法想。是名想阴报。云何想阴报法。想阴若有报。是名想阴报法。云何想阴报法。除想阴善报。余想阴善不善法想。是名想阴报法。云何想阴非报非报法。想阴无记非我分摄。色声香味触法想。是名想阴非报非报法。云何行阴报。行阴受行阴善报除无贪无恚。余思乃至心舍怖生老死命无想定得果灭尽定。是名行阴报。云何行阴报法。行阴有报。是名行阴报法。云何行阴报法。除行阴善报。余行阴善不善思乃至烦恼使结二定。是名行阴报法。云何行阴非报非报法。行阴无记非我分摄。思触思惟觉观。见慧解脱悔不悔悦喜心进信欲念疑怖生老死。是名行阴非报非报法。云何识阴报。识阴若受识阴善报眼识乃至意识。是名识阴报。云何识阴报法。识阴有报。是名识阴报法。云何识阴报法。除识阴善报。余识阴善不善意界意识界。是名识阴报法。云何识阴非报非报法。识阴无记非我分摄眼识乃至意识是名识阴非报非报法

五阴几见断几思惟断。几非见断非思惟断。一切三分。或见断或思惟断或非见断非思惟断。云何色阴见断。色阴不善非思惟断见断。烦恼心所起去来屈申回转身教。集声音句言语口教。身口非戒无教。有漏身进。是名色阴见断。云何色阴思惟断。色阴不善非见断思惟断。烦恼心所起去来屈申回转身教。集声音句言语口教。身口非戒无教。有漏身进。是名色阴思惟断。云何色阴非见断非思惟断。色阴善无记。眼入耳入鼻入舌入身入香入味入触入。身好色非好色。端严非端严。妍肤非妍肤。身好声非好声。众妙声非众妙声。软声非软声。善心无记心所起去来屈申回转身教集声音句言语口教。外色眼识所知。外声耳识所知。有漏身口戒无教。有漏身进有漏身除。正语正业正命正身进正身除。是名色阴非见断非思惟断。云何受阴见断。受阴不善非思惟断。见断烦恼相应意触受。是名受阴见断。云何受阴思惟断。受阴不善非见断。思惟断烦恼相应意触受。是名受阴思惟断。云何受阴非见断非思惟断。受阴善无记眼触受耳鼻舌身意触受。是名受阴非见断非思惟断。云何想阴见断。想阴不善非思惟断。见断烦恼相应法想。是名想阴见断。云何想阴思惟断。想阴不善非见断。思惟断烦恼相应法想。是名想阴思惟断。云何想阴非见断非思惟断。想阴善无记色想声香味触法想。是名想阴非见断非思惟断。云何行阴见断。行阴不善非思惟断。见断烦恼。一时俱断。思触思惟觉观。见慧解脱悔不悔悦喜心进信欲念疑怖烦恼使结。是名行阴见断。云何行阴思惟断。行阴不善非见断。思惟断烦恼一时俱断。思触思惟觉观。见慧解脱悔不悔悦喜心进信欲念疑怖烦恼结使。是名行阴思惟断。云何行阴非见断非思惟断。行阴善无记。除疑烦恼使结。余行阴非见断非思惟断。是名行阴非见断非思惟断。云何识阴见断。识阴若不善非思惟断。见断烦恼相应意界意识界。是名识阴见断。云何识阴思惟断。识阴不善非见断思惟断烦恼相应意界意识界。是名识阴思惟断。云何识阴非见断非思惟断。识阴善无记眼识乃至意识是名识阴非见断非思惟断

五阴几见断因。几思惟断因。几非见断非思惟断因。一切三分。或见断因或思惟断因或非见断非思惟断因。云何色阴见断因。色阴见断法报。眼入耳鼻舌身入。身非好色非端严。非妍肤非严净。身非好声非众妙声非软声身非众妙香非好香非软香非适意香。身甜酢苦辛咸淡涎癊。身冷热粗重坚涩。见断因心所起去来屈申回转身教集声音句言语口教。身口非戒无教。有漏身进。是名色阴见断因。云何色阴思惟断因。色阴思惟断法报。眼入耳入鼻入舌入身入。身非好色非端严非妍肤非严净。身非好声非众妙声非软声。身非好香非软香非适意香。身甜酢苦辛咸淡涎癊。身冷热粗重坚涩。思惟断因心所起去来屈申回转身教。集声音句言语口教。身口非戒无教。有漏身进。是名色阴思惟断因。云何色阴非见断非思惟断因。色阴善色阴善法报。色阴非报非报法。眼入耳入鼻入舌入身入。身好色端严妍肤严净。身好声众妙声软声。身好香软香适意香。身甜酢苦辛咸淡涎癊。身冷热轻细软滑。非见断非思惟断因。心所起去来屈申回转身教。集声音句言语口教。外色眼识所知。外声香味外触身识所知。有漏身口戒无教。有漏身进有漏身除。正语正业正命正身进正身除。是名色阴非见断非思惟断因。云何受阴见断因。受阴若见断受阴见断法报。眼触受耳鼻舌身意触受。是名受阴见断因。云何受阴思惟断因。受阴思惟断受阴思惟断法报。眼触受耳鼻舌身意触受。是名受阴思惟断因。云何受阴非见断非思惟断因。受阴善受阴善法报。受阴非报非报法。眼触受耳鼻舌身意触受。是名受阴非见断非思惟断因。云何想阴见断因。想阴不善非思惟断相应。见断烦恼相应法想。是名想阴见断因。云何想阴思惟断因。想阴不善非见断。思惟断烦恼相应法想。是名想阴思惟断因。云何想阴非见断非思惟断因。若想阴善想阴善法报想阴若非报非报法色想声香味触法想。是名想阴非见断非思惟断因。云何行阴见断因。行阴见断行阴见断法报。思触思惟觉观。见慧解脱悔不悔悦喜心进信欲念疑怖烦恼使生老死命结。是名行阴见断因。云何行阴思惟断因。行阴若思惟断。行阴思惟断法报。思触思惟觉观。见慧解脱悔不悔悦喜心进信欲念疑怖烦恼使生命结。是名行阴思惟断因。云何行阴非见断非思惟断因。行阴若行阴善善法报。行阴非报非报法。除疑烦恼使结。余行阴非见断非思惟断因。是名行阴非见断非思惟断因。云何识阴见断因。识阴若见断识阴见断法报。眼识乃至意识。是名识阴见断因云何识阴思惟断因。识阴思惟断识阴思惟断法报。眼识乃至意识。是名识阴思惟断因。云何识阴非见断非思惟断因。识阴善识阴善法报识阴非报非报法眼识乃至意识。是名识阴非见断非思惟断因

五阴。几欲界系。几色界系。几无色界系。几不系。一切四分或欲界系或色界系或无色界系或不系。云何色阴欲界系。色阴欲漏有漏。眼入耳鼻舌身入香入味入。身好色非好色。端严非端严。妍肤非妍肤。严净非严净。身好声非好声。众妙声非众妙声。软声非软声。身冷热轻重粗细涩滑坚软。欲行心所起去来屈申回转身教。集声音句言语口教。外色眼识所知。欲漏有漏。外声外触身识所知。欲漏有漏身口非戒无教。有漏身口戒无教有漏身进。是名色阴欲界系。云何色阴色界系。色阴色漏。眼入耳入。身好色端严妍肤严净。身好声众妙声软声。身冷轻细软滑色行心所起去来屈申回转身教。集声音句言语口教。外色眼识所知。色漏有漏。外声外触身识所知。色漏有漏。有漏身口戒无教。有漏身除。是名色阴色界系。云何色阴无色界系。色阴无色漏有漏。有漏身口戒无教。有漏身进有漏身除。是名色阴无色界系。云何色阴不系。色阴若圣无漏正语正业正命正身进正身除是名色阴不系。云何受阴欲界系。受阴欲漏有漏眼触受耳鼻舌身意触受。是名受阴欲界系。云何受阴色界系。受阴色漏有漏眼触受耳鼻舌身意触受。是名受阴色界系。云何受阴无色界系。受阴无色漏有漏意触受。是名受阴无色界系。云何受阴不系。受阴圣无漏意触受。是名受阴不系。云何想阴欲界系。想阴欲漏有漏色想声香味触法想。是名想阴欲界系。云何想阴色界系。想阴色漏有漏色想声香味触法想。是名想阴色界系。云何想阴无色界系。想阴无色漏有漏法想。是名想阴无色界系。云何想阴不系。想阴圣无漏法想。是名想阴不系。云何行阴欲界系。若行阴欲漏有漏思触思惟觉观见慧解脱无贪无恚无痴顺信悔不悔悦喜心进信欲不放逸念疑怖烦恼使生老死命结。是名行阴欲界系。云何行阴色界系。若行阴色漏有漏思触思惟觉观见慧解脱无痴顺信悦喜心进心除信欲不放逸念定心舍疑烦恼使生老死命结无想定。是名行阴色界系。云何行阴无色界系。若行阴无色漏有漏思触思惟见慧解脱无痴顺信心进心除信欲不放逸念定心舍疑烦恼使生老死命结。是名行阴无色界系。云何行阴不系。行阴圣无漏思触思惟觉观。见慧解脱无痴顺信悦喜心进心除。信欲不放逸念定心舍得果灭尽定。是名行阴不系。云何识阴欲界系。识阴若欲漏有漏眼识乃至意识。是名识阴欲界系。云何识阴色界系。识阴色漏有漏。眼识耳识身识意识。是名识阴色界系。云何识阴无色界系。识阴无色漏有漏意界意识界。是名识阴无色界系云何识阴不系。识阴圣无漏意界意识界。是名识阴不系

五阴。几过去。几未来。几现在。几非过去非未来非现在。一切三分或过去或未来或现在。云何色阴过去。色阴生已灭。是名色阴过去。云何色阴未来。色阴未生未出。是名色阴未来。云何色阴现在。生未灭色阴。是名色阴现在。受阴想阴行阴识阴亦如是

舍利弗阿毗昙论卷第三舍利弗阿毗昙论卷第四

        姚秦罽宾三藏昙摩耶舍共昙摩崛多等译

    问分四圣谛品第四

问曰。几圣谛。答曰四。何等四。苦圣谛。苦集圣谛。苦灭圣谛。苦灭道圣谛。云何苦圣谛。生苦老苦。病苦死苦。不爱会苦。爱别离苦。所求不得苦。除爱总五受阴苦。是名苦圣谛。此苦圣谛。真实如尔。非不如尔。不异不异物。如如来正说圣人谛故。是名圣谛。云何生。若诸众生诸众中生重生增长生阴得诸入众和合。是名生。云何老。若诸众生。诸众中衰寝战掉诸根熟命减行故。是名老。云何病。若诸众生诸众中病作病客病苦病因热生病因冷因风自地时变诸大增减不等业报杂病。是名病。云何死。若诸众生诸众中终没死时过阴坏舍身变灭离众。是名死云何不爱会。若不爱不喜不适意。若恶兽毒虫等。若棘刺秽陋坑岸山崄等。若不适意色声香味触法。众生若彼居亲近不独共杂不离不离不异相应不别。是名不爱会。云何爱别离。若爱喜适意。若父母兄弟姊妹妻子。若亲厚诸臣眷属。适意色声香味触法。众生若不共彼居不亲近独不杂异不相应别离。是名爱别离。云何所求不得苦。若欲希望定得未得。若色声香味触法。众生若不得彼重。不得不贵。不自在。不自由。所欲不成就。是名所求不得苦。云何除爱总五受阴苦。色受阴受想行识受阴。云何色受阴。若一切色有漏取。是名色受阴。云何受想行识受阴。若一切识有漏取。是名识受阴。是名除爱总五受阴苦。云何苦集圣谛。此爱复有喜欲彼彼染。是名苦集圣谛。云何苦集圣谛二爱。内爱外爱。是名苦集圣谛。云何苦集圣谛三爱。欲爱有爱非有爱。是名苦集圣谛。云何苦集圣谛四染。欲染色染无色染见染。是名苦集圣谛。云何苦集圣谛六爱。色爱声香味触法爱。是名苦集圣谛。云何苦集圣谛三十六爱行。十八爱行内所造。十八爱行外所造。是名苦集圣谛。此苦集圣谛。真实如尔。非不如尔。不异不异物。如如来正说圣人谛故。是谓圣谛。云何内爱。内法中欲染重欲染怜不逆乐乐欲可重可究竟可不足不满着重着津漏亲近爱支网能生苦根生希望渴宅耽忍能广创爱。是名内爱。云何外爱。外法中欲染重欲染怜不逆乐乐欲可重可究竟可不足不满着重着津漏亲近爱支网能生苦根希望渴宅耽忍能广创爱。是名外爱。云何欲爱。欲界法中欲染重欲染怜不逆乐乐欲可重可究竟可不足不满着重着津漏亲近爱支网能生苦根希望渴宅耽忍能广创爱。是名欲爱。云何有爱。色界无色界法中欲染。乃至广创爱。是名有爱。云何非有爱。若有人强言有我若杖怖苦病等逼便希望我断坏非有。彼法中欲染乃至广创爱。是名非有爱。云何欲染。若欲欲腻欲喜欲爱欲支欲耽欲态欲渴欲燋欲网。是名欲染。云何色染。若色欲色腻色喜色爱色支色耽色态色渴色燋色网。是名色染。云何无色染。若无色欲无色腻无色喜无色爱无色支无色耽无色态无色渴无色燋无色网。是名无色染。云何见染。若见欲见腻见喜见爱见支见耽见态见渴见燋见网。是名见染。云何色爱。眼知色彼法中若欲染乃至广创爱。是名色爱。云何声香味触法爱。意知法彼法中若欲染乃至广创爱。是名法爱。云何十八爱行内所造。如世尊说。因此有此因彼而有如是因有异因有常因有不常因有我当有彼我当有如是我当有异我当有因得彼得如是得异得希望当有希望彼当有希望如是当有希望异当有。是名十八爱行内所造。云何十八爱行外所造。如世尊说。是因此有此是因彼而有是如是因有是异因有是当因有是不当因有是我当有是彼我当有是如是我当有是异我当有是因得是彼得是如是得是异得是希望当有是希望彼当有是希望如是当有是希望异当有。是名十八爱行外所造。云何苦灭圣谛。彼爱无余离欲灭舍出解脱无宅已断不复生。是名苦灭圣谛。云何苦灭圣谛。智缘尽。是名苦灭圣谛。是苦灭圣谛。真实如尔。非不如尔。不异不异物。如如来正说圣人谛。是谓圣谛。云何智缘尽。若法智尽彼法尽。是名智缘尽。云何智缘尽。若法得圣道灭彼法灭。是名智缘尽。云何智缘尽。数谓知彼智若知法灭彼结灭。是名智缘尽。云何智缘尽。四沙门果。须陀洹果。斯陀含果。阿那含果。阿罗汉果。是名智缘尽。云何须陀洹果。若见断三烦恼断身见疑戒盗。是名须陀洹果。云何须陀洹果。见断三烦恼断身见疑戒盗。若得甘露。是名须陀洹果。云何须陀洹果。若见断三烦恼断身见疑戒盗。圣道一时俱断烦恼。是名须陀洹果。云何须陀洹果。见断三烦恼身见疑戒盗。圣道一时俱断烦恼。若得甘露。是名须陀洹果。云何斯陀含果。若见断三烦恼断身见疑戒盗。烦恼思惟断。欲爱嗔恚烦恼分断。是名斯陀含果。云何斯陀含果。若见断三烦恼身见疑戒盗思惟断欲爱嗔恚分断。若得甘露。是名斯陀含果。云何斯陀含果。若见断三烦恼身见疑戒盗。圣道一时俱断。烦恼思惟断。欲爱嗔恚烦恼分断。圣道一时俱断烦恼。是名斯陀含果。云何斯陀含果。见断三烦恼身见疑戒盗。圣道一时俱断。烦恼思惟断。欲爱嗔恚烦恼分断。圣道一时俱断烦恼。若得甘露。是名斯陀含果。云何阿那含果。若五下分烦恼断身见疑戒盗欲爱嗔恚。是名阿那含果。云何阿那含果。五下分烦恼断身见疑戒盗欲爱嗔恚。若得甘露。是名阿那含果。云何阿那含果。五下分烦恼断身见疑戒盗欲爱嗔恚。圣道一时俱断烦恼。是名阿那含果。云何阿那含果。五下分烦恼断身见疑戒盗欲爱嗔恚圣道一时俱断烦恼。若得甘露。是名阿那含果。云何阿罗汉果。若思惟断色界无色界烦恼断无余。是名阿罗汉果。云何阿罗汉果。思惟断色界无色界烦恼断无余。若得甘露。是名阿罗汉果。云何阿罗汉果。若一切烦恼尽。是名阿罗汉果。云何阿罗汉果。若一切烦恼尽。若得甘露。是名阿罗汉果。云何苦灭道圣谛。此八支圣道正见正觉正语正业正命正进正念正定。是名苦灭道圣谛。是苦灭道圣谛苦实如尔。非不如尔。不异不异物。如如来正说。圣人谛是谓圣谛。云何正见。学人离结使圣心入圣道。若坚信坚法。及余趣人。见行过患。观涅槃寂灭。如实观苦集灭道。未得欲得。未解欲解。未证欲证。修道离烦恼见学人。若须陀洹。斯陀含。阿那含。若观智具足。若智地若观解脱心。即得沙门果。若须陀洹果。斯陀含果。阿那含果。无学人欲得阿罗汉。未得圣法。欲得修道观智具足。若智地若观解脱心。即得阿罗汉果。若实人若趣若法中泽重泽究竟泽法泽思惟觉了达自相他相共相思持辩观进辩慧智见解射方便术焰光明昭炬慧眼慧根慧力择法正觉不痴。是名正见。云何正觉。学人离结使。乃至即得阿罗汉果。若实人若趣若觉重觉正忆想攀缘心了。是名正觉。云何正语。学人离结使。乃至即得阿罗汉果。若实人若趣若口四不善不乐尽离见过戒慎不作不容断根尽无余彼不善法中堪行善。是名正语。云何正业。学人离结使。乃至即得阿罗汉果。若实人若趣若身三不善。不乐远离见过戒慎不作不容断根尽无余彼不善法中堪行善。是名正业。云何正命。学人离结使。乃至即得阿罗汉果。若实人若趣除身口不善余邪命不乐远离见过戒慎不作不容断根尽无余彼不善法中堪行善。是名正命。云何正进。学人离结使。乃至即得阿罗汉果。若实人若趣若身心发出度堪忍不退勤力进不离不懈不缓不懒堕进根进力进觉是名正进。云何正念。学人离结使。乃至即得阿罗汉果。若实人若趣若念忆念微念慎念住不忘如语相续念不失不夺不钝不钝根念根念力念觉。是名正念。云何正定。学人离结使。乃至即得阿罗汉果。若实人若趣若心住正住专住心一向心一乐心不乱依意心独定定根定力定觉。是名正定四圣谛。几色。几非色。二非色。二二分或色或非色。云何二非色。集圣谛灭圣谛。是名二非色。云何二二分或色或非色。苦圣谛道圣谛。是名二二分或色或非色。云何苦圣谛色。眼入耳鼻舌身入色入声香味触入身口非戒无教有漏身口戒无教有漏身进有漏身除。是名苦圣谛色。云何苦圣谛非色。受想思触思惟觉观见慧解脱无贪无恚无痴顺信悔悦喜心进心除信欲不放逸念定心舍疑怖烦恼使生老死命结无想定眼识乃至意识。是名苦圣谛非色。云何道圣谛色。正语正业正命正身进。是名道圣谛色。云何道圣谛非色。正见正觉正心进正念正定。是名道圣谛非色

四圣谛。几可见。几不可见。三不可见。一二分或可见或不可见。云何三不可见。集圣谛灭圣谛道圣谛。是名三不可见。云何一二分或可见或不可见。苦圣谛是名一二分或可见或不可见。云何苦圣谛可见。色入是名苦圣谛可见。云何苦圣谛不可见。除色入余苦圣谛不可见。是名苦圣谛不可见

四圣谛。几有对。几无对。三无对。一二分或有对或无对。云何三无对。集圣谛灭圣谛道圣谛。是名三无对。云何一二分或有对或无对。苦圣谛是名一二分或有对或无对。云何苦圣谛有对。十色入是名苦圣谛有对。云何苦圣谛无对。初四色受想乃至无想定眼识乃至意识。是名苦圣谛无对

四圣谛。几圣。几非圣。二圣。二非圣。云何二圣。灭圣谛道圣谛。是名二圣。云何二非圣。苦圣谛集圣谛。是名二非圣。有漏无漏有爱无爱有求无求当取非当取有取无取有胜无胜亦如是

四圣谛。几受。几非受。三非受。一二分或受或非受。云何三非受。集圣谛灭圣谛道圣谛。是名三非受。云何一二分或受或非受。苦圣谛。是名一二分或受或非受。云何苦圣谛受。苦圣谛若内。是名苦圣谛受。云何苦圣谛受。苦圣谛业法烦恼所生报我分摄。眼入耳入鼻入舌入身入。身好色非好色。端严非端严。妍肤非妍肤。严净非严净。身好声非好声。众妙声非众妙声。软声非软声。身好香非好香。软香非软香。适意香非适意香。身甜酢苦辛咸淡涎癊。身冷热轻重粗细涩滑坚软。受心所起。去来屈申回转身教集。声音句言语口教有漏身集。受想思触思惟觉观见慧解脱悔不悔悦喜心进信欲念怖生命。眼识乃至意识。是名苦圣谛受。云何苦圣谛非受。苦圣谛外。是名苦圣谛非受。云何苦圣谛非受。苦圣谛善若不善无记。非我分摄。若善心不善心。非报非报法。心所起去来屈申回转身教集。声音句言语口教。若外色眼识所知。声香味若外触身识所知。身口非戒无教。有漏身口戒无教。有漏身进。有漏身除。除命余受想乃至。无想定眼识乃至意识。是名苦圣谛非受。内外亦如是

四圣谛。几有报。几无报。一有报。一无报。二二分或有报或无报。云何一有报。集圣谛是名一有报。云何一无报。灭圣谛是名一无报。云何二二分或有报或无报。苦圣谛道圣谛。是名二二分或有报或无报。云何苦圣谛有报。苦圣谛报法。是名苦圣谛有报。云何苦圣谛有报。除苦圣谛善报余苦圣谛善不善。不善善心所起。去来屈申回转身教集。声音句言语口教身口非戒无教。有漏身口戒无教。有漏身进有漏身除。受想乃至烦恼使结无想定意界意识界。是名苦圣谛有报。云何苦圣谛无报。苦圣谛若报。苦圣谛非报非报法。眼入耳鼻舌身入。香入味入触入。身好色非好色。端严非端严。妍肤非妍肤。严净非严净。身好声非好声。众妙声非众妙声。软声非软声。无记心所起。去来屈申回转身教集。声音句言语口教。外色眼识所知。外声耳识所知。有漏身口戒无教。有漏身进有漏身除。除无贪无恚痴烦恼使结。余受想乃至无想定。眼识乃至意识。是名苦圣谛无报。云何道圣谛有报。道圣谛报法。是名道圣谛有报。云何道圣谛有报。学人离结使。圣心入圣道。若坚信坚法及余趣人。见行过患。观涅槃寂灭。如实观苦集灭道。未得欲得。未解欲解。未证欲证。修道离烦恼无学人。欲得阿罗汉未得圣法。欲得修道。若实人若趣若正见正觉正语正业正命正进正念正定。是名道圣谛有报。云何道圣谛无报。道圣谛无报。是名道圣谛无报。云何道圣谛无报。见学人若须陀洹斯陀含阿那含观智具足。若智地若观解脱心即得沙门果。若须陀洹果斯陀含果阿那含果无学人阿罗汉观智具足。若智地若观解脱心即得阿罗汉果。若实人若趣正见乃至正定。是名道圣谛无报

四圣谛。几心。几非心。三非心。一二分或心或非心。云何三非心。集圣谛灭圣谛道圣谛。是名三非心。云何一二分或心或非心苦圣谛。是名一二分或心或非心。云何苦圣谛心。眼识乃至意识。是名苦圣谛心。云何苦圣谛非心。十色入初四色受想乃至无想定。是名苦圣谛非心

四圣谛。几心相应。几非心相应。一心相应。一非心相应。一二分或心相应或非心相应。一三分或心相应或非心相应或不说心相应非心相应。云何一心相应。集圣谛是名一心相应。云何一非心相应。灭圣谛是名一非心相应。云何一二分或心相应或非心相应。道圣谛是名一二分或心相应或非心相应。云何一三分或心相应或非心相应或不说心相应非心相应。苦圣谛是名一三分或心相应或非心相应或不说心相应非心相应。云何道圣谛心相应。道圣谛若心数正见正觉正心进正念正定。是名道圣谛心相应。云何道圣谛非心相应。道圣谛非心数正语正业正命正身进是名道圣谛非心相应。云何苦圣谛心相应。苦圣谛若心数受想乃至烦恼使。是名苦圣谛心相应。云何苦圣谛非心相应。苦圣谛若非心数十色入初四色生乃至无想定。是名苦圣谛非心相应。云何苦圣谛不说心相应非心相应。眼识乃至意识。是名苦圣谛不说心相应非心相应

四圣谛。几心数。几非心数。一心数。一非心数。二二分或心数或非心数。云何一心数。集圣谛是名一心数。云何一非心数。灭圣谛是名一非心数。云何二二分或心数或非心数。苦圣谛道圣谛。是名二二分或心数或非心数。云何苦圣谛心数。除心余苦圣谛缘受想乃至烦恼使。是名苦圣谛心数。云何苦圣谛非心数。苦圣谛若非缘及心十色入初四色生乃至无想定眼识乃至意识。是名苦圣谛非心数。云何道圣谛心数。若道圣谛缘正见正觉正心进正念正定。是名道圣谛心数。云何道圣谛非心数。若道圣谛非缘正语正业正命正身进。是名道圣谛非心数

四圣谛。几缘。几非缘。一有缘。一非缘。二二分或有缘或无缘。云何一有缘。集圣谛是名一有缘。云何一无缘。灭圣谛是名一无缘。云何二二分或有缘或无缘。苦圣谛道圣谛。是名二二分或有缘或无缘云何苦圣谛有缘。苦圣谛若心数及心。受想乃至烦恼使眼识乃至意识。是名苦圣谛缘。云何苦圣谛非缘。除心余苦圣谛非心数十色入初四色生乃至无想定。是名苦圣谛非缘。云何道圣谛缘道圣谛心数正见正觉正进正念正定。是名道圣谛缘。云何道圣谛非缘。道圣谛若非心数正语正业正命正身进。是名道圣谛非缘

四圣谛。几共心。几不共心。一共心。一不共心。二二分或共心或不共心。云何一共心。集圣谛是名一共心。云何一不共心。灭圣谛是名一不共心。云何二二分或共心或不共心。苦圣谛道圣谛。是名二二分或共心或不共心。云何苦圣谛共心。苦圣谛若随心转共心生共住共灭有漏身口戒无教有漏身进有漏身除受想乃至烦恼使。是名苦圣谛共心。云何苦圣谛不共心。苦圣谛不随心转不共心生不共住不共灭十色入初四色生乃至无想定眼识乃至意识。是名苦圣谛不共心。云何道圣谛共心。道圣谛随心转共心生共住共灭正见乃至正定。是名道圣谛共心。云何道圣谛不共心。道圣谛不随心转。不共心生。不共住不共灭。正语正业正命正身进。是名道圣谛不共心。随心转不随心转亦如是

四圣谛几业。几非业。二非业。二二分或业或非业。云何二非业。集圣谛灭圣谛。是名二非业。云何二二分或业或非业。苦圣谛道圣谛。是名二二分或业或非业。云何苦圣谛业。善心不善心无记心。所起去来屈申回转身教集。声音句言语口教。身口非戒无教。有漏身口戒无教思。是名苦圣谛业。云何苦圣谛非业。眼入耳入鼻入舌入身入香入味入触入。身好色非好色。端严非端严。妍肤非妍肤。严净非严净身。好声非好声。众妙声非众妙声。软声非软声。外色眼识所知。外声耳识所知。有漏身进。有漏身除。除思余受想乃至无想定。眼识乃至意识。是名苦圣谛非业。云何道圣谛业。正语正业正命。是名道圣谛业。云何道圣谛非业。正见正觉正进正念正定。是名道圣谛非业

四圣谛。几业相应。几非业相应。一业相应。一非业相应。一二分或业相应或非业相应。一三分或业相应。或非业相应或不说业相应非业相应。云何一业相应。集圣谛是名一业相应。云何一非业相应。灭圣谛是名一非业相应。云何一二分或业相应或非业相应。道圣谛是名一二分或业相应或非业相应。云何一三分或业相应或非业相应。或不说业相应非业相应。苦圣谛是名一三分或业相应或非业相应或不说业相应非业相应。云何道圣谛业相应。道圣谛若思相应正见正觉正进正念正定。是名道圣谛业相应。云何道圣谛非业相应。道圣谛若非思相应正语正业正命正身进。是名道圣谛非业相应。云何苦圣谛业相应。苦圣谛若思相应除思受想乃至烦恼使眼识乃至意识。是名苦圣谛业相应。云何苦圣谛非业相应。苦圣谛若非思相应十色入初四色生乃至无想定。是名苦圣谛非业相应。云何苦圣谛不说业相应非业相应思。是名苦圣谛不说业相应非业相应

四圣谛。几共业。几非共业。二共业。一不共业。一二分或共业或非共业。云何二共业。集圣谛道圣谛。是名二共业。云何一不共业。灭圣谛是名一不共业。云何一二分或共业或不共业。苦圣谛是名一二分或共业或不共业。云何苦圣谛共业。苦圣谛若随业转共业生共住共灭有漏身口戒无教有漏身进有漏身除受想定心思触乃至烦恼使无想定眼识乃至意识。是名苦圣谛共业。云何苦圣谛不共业。苦圣谛不随业转。不共业生。不共住不共灭。十色入身口非戒无教。有漏身口戒无教。有漏身进。不定心思生老死命结。是名苦圣谛不共业。随业转不随业转亦如是

四圣谛。几因。几非因。二因。一非因。一二分或因或非因。云何一因。集圣谛道圣谛。是名二因。云何一非因。灭圣谛是名一非因。云何一二分或因或非因。苦圣谛是名一二分或因或非因。云何苦圣谛因。苦圣谛缘。苦圣谛非缘有报。苦圣谛非缘善报。四大善心不善心所起。去来屈申回转身教集。声音句言语口教。地大水火风大。身口非戒无教。有漏身口戒无教。有漏身进。有漏身除。受想乃至烦恼使。无想定。眼识乃至意识。是名苦圣谛因。云何苦圣谛非因。苦圣谛非缘无报不共业。眼入耳入鼻入舌入身入香入味入。身好色非好色。端严非端严。妍肤非妍肤。严净非严净。身好声非好声。众妙声非众妙声。软声非软声。无记心所起。去来屈申回转身教集。声音句言语口教。外色眼识所知。外声耳识所知。除四大余触入所摄及有漏身进生老死命。是名苦圣谛非因

四圣谛。几有因。几无因。三有因。一无因。云何三有因。苦圣谛集圣谛道圣谛。是名三有因。云何一无因。灭圣谛是名一无因。有绪无绪。有缘无缘。有为无为。亦如是

四圣谛。几知。几非知。一切知如事知见

四圣谛。几识。几非识。一切识意识如事识

四圣谛。几解。几非解。一切解如事解

四圣谛。几了。几非了。一切了如事了

四圣谛。几断智知。几非断智知。一断智知。二非断智知。一二分或断智知或非断智知。云何一断智知。集圣谛是名一断智知。云何二非断智知。灭圣谛道圣谛。是名二非断智知。云何一二分或断智知或非断智知。苦圣谛是名一二分或断智知或非断智知。云何苦圣谛断智知。苦圣谛不善不善心所起。去来屈申回转身教集。声音句言语口教。身口非戒无教。有漏身进。受想思触思惟觉观见慧解脱悔不悔悦喜心进信欲念疑怖烦恼使结意界意识界。是名苦圣谛断智知。云何苦圣谛非断智知。苦圣谛善无记。眼入耳入鼻入舌入身入香入味入触入身好色非好色。端严非端严。妍肤非妍肤。严净非严净。身好声非好声。软声非软声。善心若无记心所起。去来屈申回转身教集。声音句言语口教。外色眼识所知。外声耳识所知。有漏身口戒无教。有漏身进。有漏身除疑烦恼使结。余受想乃至无想定眼识乃至意识。是名苦圣谛非断智知。断非断亦如是

四圣谛。几修。几非修。二修。一非修。一二分或修或非修。云何二修。灭圣谛道圣谛。是名二修。云何一非修。集圣谛是名一非修。云何一二分或修或非修。苦圣谛是名一二分或修或非修。云何苦圣谛修。苦圣谛善善心所起。去来屈申回转身教集。声音句言语口教。有漏身口戒无教。有漏身进有漏身除。受想乃至疑除。无想定意界意识界。是名苦圣谛修。云何苦圣谛非修。苦圣谛不善无记。眼入耳入鼻入舌入身入香入味入触入。身好色非好色。端严非端严。妍肤非妍肤。严净非严净。身好声非好声。众妙声非众妙声。软声非软声。不善心无记心所起。去来屈申回转身教集。声音句言语口教。外色眼识所知。外声耳识所知。身口非戒无教。有漏身进。受想思触思惟觉观见慧解脱悔不悔悦喜心进信欲念疑怖烦恼使生老死命结眼识乃至意识。是名苦圣谛非修

四圣谛。几证几非证。一切证知如事见

四圣谛。几善。几不善。几无记。二善。一不善。一三分或善或不善或无记。云何二善。灭圣谛道圣谛。是名二善。云何一不善。集圣谛是名一不善。云何一三分或善或不善或无记。苦圣谛是名一三分或善或不善或无记。云何苦圣谛善。苦圣谛修善心所起。去来屈申回转身教集。声音句言语口教。有漏身口戒无教。有漏身进有漏身除。乃至心舍无想定意界意识界是名苦圣谛善。云何苦圣谛不善。苦圣谛断受想思触思惟觉观。见慧解脱悔不悔悦喜心进。若不善心所起去来屈申回转身教集。声音句言语口教。身口非戒无教。有漏身进信欲念疑怖烦恼使结意界意识界。是名苦圣谛不善。云何苦圣谛无记。苦圣谛受苦圣谛非报非报法。眼入耳入鼻入舌入身入香入味入触入。身好色非好色。端严非端严。妍肤非妍肤。严净非严净。身好声非好声。众妙声非众妙声。软声非软声。无记心所起。去来屈申回转身教集。声音句言语口教。外色眼识所知。外声耳识所知。有漏身进。受想思触思惟觉。观见慧解脱悔不悔悦喜心进信欲念怖生老死命眼识乃至意识。是名苦圣谛无记

四圣谛。几学。几无学。几非学非无学。二非学非无学。二二分或学。或无学。云何二非学非无学。苦圣谛集圣谛。是名二非学非无学。云何二二分或学或无学。灭圣谛道圣谛。是名二二分或学。或无学。云何灭圣谛学。须陀洹果斯陀含果阿那含果。是名灭圣谛学。云何灭圣谛无学。阿罗汉果。是名灭圣谛无学。云何道圣谛学。学人离结使圣心入圣道。若坚信若坚法。及余趣人见行过患观涅槃寂灭。如实观苦集灭道。未得欲得。未解欲解。未证欲证。修道离烦恼见。学人若须陀洹斯陀含阿那含观智具足。若智地若观解脱心。即得沙门果。若须陀洹果。若斯陀含果阿那含果。若实人若趣正见乃至正定。是名道圣谛学。云何道圣谛无学无学人欲得阿罗汉。未得圣法欲得修道观智具足。若智地若观解脱心即得阿罗汉果。若实人若趣正见乃至正定。是名道圣谛无学

四圣谛。几报。几报法。几非报非报法。一报法。一非报非报法。一二分或报或报法。一三分或报或报法或非报非报法。云何一报法。集圣谛是名一报法。云何一非报非报法。灭圣谛是名一非报非报法。云何一二分或报或报法。道圣谛是名一二分或报或报法。云何一三分或报或报法。或非报非报法。苦圣谛是名一三分或报或报法或非报非报法。云何道圣谛报。道圣谛无报。是名道圣谛报。云何道圣谛报。见学人若须陀洹斯陀含阿那含观智具足。若智地若观解脱心即得沙门果。若须陀洹果斯陀含果阿那含果无学人观智具足。若智地若观解脱心即得阿罗汉果。若实人若趣正见乃至正定。是名道圣谛报。云何道圣谛报法。道圣谛善报。是名道圣谛报法。云何道圣谛报法。学人离结使圣心入圣道。若坚信坚法及余趣人。见行过患观涅槃寂灭。如实观苦集灭道。未得欲得。未解欲解。未证欲证。修道离烦恼。无学人欲得阿罗汉。未得圣法欲得修道。若实人若趣正见乃至正定。是名道圣谛报法。云何苦圣谛报。苦圣谛善报。眼入耳入鼻入舌入身入。身好色非好色。端严非端严。妍肤非妍肤。严净非严净。身好声非好声。众妙声非众妙声。软声非软声。身好香非好香。软香非软香。适意香非适意香。身甜酢苦辛咸淡涎癊。身冷热轻重粗细涩滑坚软。受心所起去来屈申回转身教集。声音句言语口教。有漏身口戒无教。有漏身进有漏身除。除无贪无恚。余受想乃至心舍怖生命无想定。眼识乃至意识。是名苦圣谛报。云何苦圣谛报法。苦圣谛有报。是名苦圣谛报法。云何苦圣谛报法。除苦圣谛善报。余苦圣谛善不善。善心若不善心所起。去来屈申回转身教集。声音句言语口教。身口非戒无教。有漏身口戒无教。有漏身进有漏身除。受想乃至烦恼使结无想定意界意识界。是名苦圣谛报法。云何苦圣谛非报非报法。苦圣谛无记非我分摄。非报非报法心所起。去来屈申回转身教集。声音句言语口教。外色眼识所知。外声香味。外触身识所知。有漏身进。受想思触思惟觉观见慧解脱悔不悔悦喜心进信欲念怖生老死。眼识乃至意识。是名苦圣谛非报非报法

四圣谛。几见断。几思惟断。几非见断非思惟断。二非见断非思惟断。一二分或见断或思惟断。一三分或见断或思惟断。或非见断非思惟断。云何二非见断非思惟断。灭圣谛道圣谛。是名二非见断非思惟断。云何一二分或见断或思惟断。集圣谛是名一二分或见断或思惟断。云何一三分或见断或思惟断。或非见断非思惟断。苦圣谛是名一三分或见断或思惟断。或非见断非思惟断。云何集圣谛见断。集圣谛若见断名集圣谛。是名集圣谛见断。云何集圣谛思惟断。集圣谛思惟断名集圣谛。是名集圣谛思惟断。云何苦圣谛见断。苦圣谛不善非思惟断见断。烦恼心所起去来屈申回转身教集声音句言语口教。身口非戒无教。有漏身进。受想思触思惟觉观见慧解脱悔不悔悦喜心进信欲念疑怖烦恼使结意界意识界。是名苦圣谛见断。云何苦圣谛思惟断。苦圣谛不善非见断思惟断。烦恼心所起去来屈申回转身教集。声音句言语口教。身口非戒无教。有漏身进。受想思触思惟觉观见慧解脱悔不悔悦喜心进信欲念怖烦恼使结意界意识界。是名苦圣谛思惟断。云何苦圣谛非见断非思惟断。苦圣谛善无记。眼入耳鼻舌入身入香入味入触入。身好色非好色。端严非端严。妍肤非妍肤。严净非严净。身好声非好声。众妙声非众妙声。软声非软声。若善心若无记心所起去来屈申回转身教集。声音句言语口教。外色眼识所知。外声耳识所知。有漏身口戒无教。有漏身进有漏身除。除疑烦恼使结余受想乃至无想定眼识乃至意识。是名苦圣谛非见断非思惟断

四圣谛。几见断因。几思惟断因。几非见断非思惟断因。二非见断非思惟断因。一二分或见断因或思惟断因。一三分或见断因或思惟断因。或非见断非思惟断因。云何二非见断非思惟断因。灭圣谛道圣谛。是名二非见断非思惟断因。云何一二分或见断因或思惟断因。集圣谛是名一二分。或见断因或思惟断因。云何一三分或见断因或思惟断因。或非见断非思惟断因。苦圣谛是名一三分。或见断因或思惟断因。或非见断非思惟断因。云何集圣谛见断因。集圣谛见断集圣谛。是名集圣谛见断因。云何集圣谛思惟断因。集圣谛思惟断集圣谛。是名集圣谛思惟断因。云何苦圣谛见断因。苦圣谛见断。苦圣谛见断法报。眼入耳入鼻舌身入。身非好色非端严非妍肤非严净。身非好声非众妙声非软声。身非好香非软香非适意香。身甜酢苦辛咸淡涎癊。身冷热粗重坚涩见断因。心所起去来屈申回转身教集。声音句言语口教。身口非戒无教。有漏身进。受想思触思惟觉观见慧解脱。悔不悔悦喜心进信欲念疑怖烦恼使生命结眼识乃至意识。是名苦圣谛见断因。云何苦圣谛思惟断因。苦圣谛思惟断。苦圣谛思惟断法报。眼入耳入鼻入舌入身入。身非好色非端严非妍肤非严净。身非好声非众妙声非软声。身非好香非软香非适意香。身甜酢咸淡苦辛涎癊。冷热粗重坚涩思惟断因。心所起去来屈申回转身教集。声音句言语口教。身口非戒无教。有漏身进。受想思触思惟觉观见慧解脱悔不悔悦喜心进信欲念怖烦恼使生命结眼识乃至意识。是名苦圣谛思惟断因。云何苦圣谛非见断非思惟断因。苦圣谛善苦圣谛善法报。苦圣谛非报非报法。眼入耳入鼻入舌入身入。身好色端严妍肤严净。身好声众妙声软声。身好香软香适意香。身甜酢苦辛咸淡涎癊身冷热轻细软滑。非见断非思惟断因。心所起去来屈申回转身教集。声音句言语口教。外色眼识所知。外声香味外触身识所知。有漏身口戒无教。有漏身进有漏身除。除疑烦恼使结。余受想乃至无想定眼识乃至意识。是名苦圣谛非见断非思惟断因

四圣谛。几欲界系。几色界系。几无色界系。几不系。二不系。二三分或欲界系。或色界系。或无色界系。云何二不系。灭圣谛道圣谛。是名二不系。云何二三分或欲界系。或色界系。或无色界系。苦圣谛集圣谛。是名二三分。或欲界系。或色界系。或无色界系。云何苦圣谛欲界系。苦圣谛欲漏有漏。眼入耳入鼻入舌入身入香入味入。身好色非好色。端严非端严。妍肤非妍肤。严净非严净。身好声非好声。众妙声非众妙声。软声非软声。身冷热轻重粗细坚软涩滑。欲行心所起去来屈申回转身教集。声音句言语口教。外色眼识所知。欲漏有漏为外触身识所知。欲漏有漏身口非戒无教。有漏身口戒无教。有漏身进。受想思惟触见慧解脱无痴顺信悔不悔悦喜心进信欲不放逸念疑怖烦恼使生老死命结眼识及色三二识。是名苦圣谛欲界系。云何苦圣谛色界系。苦圣谛色漏有漏眼入耳入身入。身好色端严妍肤严净。身好声众妙声软声。身冷热轻细软滑。色行心所起去来屈申回转身教集。声音句言语口教。外色眼识所知。色漏有漏。若声若外触身识所知。色漏有漏身口戒无教有漏。有漏身进有漏身除。受想思触思惟觉观见慧解脱无痴顺信悦喜心进心除信欲不放逸念定心舍疑烦恼使。生老死命结无想定眼识耳识身识意识。是名苦圣谛色界系。云何苦圣谛无色界系。苦圣谛若无色漏有漏。有漏身口戒无教。有漏身进有漏身除。受想思触思惟见慧解脱无痴顺信心进心除信欲不放逸念定心舍疑烦恼使生老死命结意界意识界。是名苦圣谛无色界系。云何集圣谛欲界系。集圣谛欲漏有漏欲行爱。是名集圣谛欲界系。云何集圣谛色界系。集圣谛色漏有漏色行爱。是名集圣谛色界系。云何集圣谛无色界系。集圣谛无色漏有漏。无色行爱。是名集圣谛无色界系

四圣谛。几过去。几未来。几现在。几非过去非未来非现在。一非过去非未来非现在。三三分或过去或未来或现在。云何一非过去非未来非现在。灭圣谛是名一非过去非未来非现在。云何三三分或过去或未来或现在。苦圣谛集圣谛道圣谛。是名三三分或过去或未来或现在。云何苦圣谛过去。苦圣谛生已灭苦圣谛。是名苦圣谛过去。云何苦圣谛未来。苦圣谛未生未出苦圣谛。是名苦圣谛未来。云何苦圣谛现在。苦圣谛生未灭苦圣谛。是名苦圣谛现在。集圣谛道圣谛亦如是

舍利弗阿毗昙论卷第四舍利弗阿毗昙论卷第五

        姚秦罽宾三藏昙摩耶舍共昙摩崛多等译

    问分根品第五

问曰。几根。答曰二十二根。何等二十二根。眼根耳根鼻根舌根身根女根男根命根乐根苦根喜根忧根舍根意根信根进根念根定根慧根未知欲知根知根已知根。云何眼根。眼入名眼根。云何眼根。眼界名眼根。云何眼根。若眼我分摄四大所造净色名眼根。云何眼根。若眼我分摄四大所造过去未来现在净色名眼根。云何眼根。若眼我分摄已见色今见当见不定若眼我分摄色光已来今来当来不定名眼根。云何眼根。若眼我分摄已对色今对当对不定若眼我分摄色已对今对当对不定名眼根。若眼无碍。是眼是眼入。是眼根。是眼界。是田是物。是门是藏。是世是净。是泉是海。是沃燋。是洄澓。是疮是系。是目是入我分。是此岸。是内入眼见色。是名眼根。耳根鼻根舌根身根亦如是。云何女根。若女女性女形女相。是名女根。云何男根。若男男性男形男相。是名男根。云何命根。寿是名命根。云何命根。若众生住。是名命根。云何命根。诸众生诸众生中不终不退不丧不死时未过行在护持名命根。云何乐根。若身乐受眼触乐受耳鼻舌身触乐受乐界名乐根。云何苦根。若身苦受眼触苦受耳鼻舌身触苦受苦界名苦根。云何喜根。若心乐受意触乐受喜界名喜根。云何忧根。若心苦受意触苦受忧界。是名忧根。云何舍根。若身心不苦不乐受眼触不苦不乐受耳鼻舌身意触不苦不乐受舍界名舍根。云何意根。意入名意根。云何意根。识阴名意根。云何意根。若心意识六识身七识界名意根。云何意根。若识过去未来现在内外粗细卑胜远近。是名意根。云何六识身。眼识身耳鼻舌身意识身。云何眼识身。缘眼缘色缘明缘思惟。以四缘识生已生今生当生不定。是名眼识身。云何耳鼻舌身意识身。缘意缘法缘思惟。以三缘识已生今生当生不定。名意识身。是名六识身。云何七识界。眼耳鼻舌身识界意界意识界。云何眼识界。若识眼根生色境界已生今生当生不定。名眼识界。云何耳鼻舌身识界。若识身根。生触境界已生今生当生不定名身识界。云何意界。意知法念法。若初心已生今生当生不定。是名意界。云何意识界。若识相似不离彼境界。及余相似心识已生今生当生不定名意识界。是名七识界。云何过去识。若识生已灭。名过去识。云何未来识。若识未生未出名未来识。云何现在识。若识生未灭。名现在识。云何内识。若识受名内识。云何外识。若识非受名外识。云何粗识。若识欲界系名粗识。云何细识。若识色界系无色界系若不系名细识。云何卑识。若识不善若识不善法报若识非报非报法不适意名卑识。云何胜识。若识善若识善法报。若识非报非报法适意名胜识。云何远识。若识相远极相远不近不近边名远识云何近识。若识相近极相近近边名近识。云何信根。学人离结使。圣心入圣道。若坚信坚法。及余趣人。见行过患。观涅槃寂灭。如实观苦集灭道。未解欲解。未得欲得。未证欲证。修道离烦恼见学人。若须陀洹。斯陀含。阿那含。观智具足。若智地。若观解脱心。即得沙门果。若须陀洹果。斯陀含果。阿那含果。无学人欲得阿罗汉果。未得圣法。欲得修道离烦恼观智具足。若智地若观解脱心。即得阿罗汉果。若实人若趣。若信入信究竟入信真信心净。是名信根。云何进根。学人离结使。乃至即得阿罗汉果。若实人若趣身心发出度堪忍不退勤力进不离不懈不缓不窳惰进进力进觉正进。是名进根。云何念根。学人离结使。乃至即得阿罗汉果。若实人若趣若念忆念微念顺念住不忘相续念不失不夺不钝不钝根念念力念觉正念。是名念根。云何定根。学人离结使。乃至即得阿罗汉果。若实人若趣。若心住正住专住心一向心一乐心不乱依念独定定力定觉正定。是名定根。云何慧根。学人离结使。乃至即得阿罗汉果。若实人若趣若法中择重择究竟择择法思惟觉了达自相他相共相思持辩进辩慧智见解脱方便术焰光明照炬慧眼慧力择法正觉不薄。是名慧根。云何未知欲知根。坚信坚法人。若法圣无漏非根得名根除未知欲知根中思想触思惟觉观解脱悦喜心除欲不放逸心舍正语正业正命正身除。是名未知欲知根。云何知根。见学人若法圣无漏非根得名根除知根中想思触思惟觉观解脱悦喜心除欲不放逸心舍得果灭尽定正语正业正命正身除。是名知根云何已知根。无学人阿罗汉果。若法圣无漏非根得名根除已知根中想思触思惟觉观解脱悦喜心除欲不放逸心舍得果灭尽定正语正业正命正身除。是名已知根

二十二根。几色。几非色。七色。十一非色。四二分或色或非色。云何七色。眼根耳根鼻根舌根身根女根男根名七色。云何十一非色。命根乐根苦根喜根忧根舍根意根信根念根定根慧根。名十一非色。云何四二分或色或非色。进根未知欲知根知根已知根。名四二分或色或非色。云何进根色。身发出度。名进根色。云何进根非色进根非色心发出度。名进根非色。云何未知欲知根色。正语正业正命正身除名未知欲知根色。云何未知欲知根非色。想思触思惟觉观。解脱悦喜心除欲不放逸心舍。名未知欲知根非色。云何知根色。正语正业正命正身除。名知根色。云何知根非色。想思触思惟觉观解脱悦喜心除欲不放逸心舍得果灭尽定。名知根非色。云何已知根色。正语正业正命正身除。名已知根色。云何已知根非色。想思触思惟觉观解脱悦喜心除欲不放逸心舍得果灭尽定。名已知根非色

二十二根。几可见。几不可见。一切不可见

二十二根。几有对。几无对。七有对。十五无对。云何七有对。眼根乃至男根。名七有对。云何十五无对。命根乃至已知根。名十五无对

二十二根。几圣。几非圣。八圣。十一非圣。三二分或圣或非圣。云何八圣。信根乃至已知根名八圣。云何十一非圣。眼根乃至苦根及忧根。名十一非圣。云何三二分或圣或非圣。喜根舍根意根。名三二分或圣或非圣。云何喜根非圣。喜根有漏。名喜根非圣。云何喜根非圣。喜根非学非无学意触乐受。名喜根非圣。云何喜根圣。喜根无漏。名喜根圣。云何喜根圣。喜根信根相应意触乐受。名喜根圣。云何喜根圣。喜根学若无学学人离结使圣心入圣道。若坚信坚法。及余趣人。见行过患。观涅槃寂灭。如实观苦集灭道。未得欲得。未解欲解。未证欲证。修道离结使见学人。若须陀洹斯陀含阿那含。观智具足。若智地。若观解脱心。即得沙门果。若须陀洹果。斯陀含果。阿那含果。无学人欲得阿罗汉。未得圣法。欲得修道观智具足。若智地若观解脱心。即得阿罗汉果。若实人若趣若意触乐受。名喜根圣。云何舍根非圣。舍根有漏。名舍根非圣。云何舍根非圣。舍根非学非无学。眼触不苦不乐受。耳鼻舌身意触不苦不乐受。名舍根非圣。云何舍根圣。舍根无漏名舍根圣。云何舍根圣。舍根信根相应意触不苦不乐受。名舍根圣。云何舍根圣。舍根学无学学人离结使。乃至即得阿罗汉果。若实人若趣若意触不苦不乐受名舍根圣。云何意根非圣。意根有漏。名意根非圣。云何意根非圣识受阴。名意根非圣。云何意根非圣。意根非学非无学眼识乃至意识。名意根非圣。云何意根圣意。根无漏。名意根圣。云何意根圣。意根信根相应意界意识界。名意根圣。云何意根圣。意根学无学学人离结使。乃至即得阿罗汉果若实人若趣若意界意识界。名意根。圣有漏无漏。有爱无爱有求无求当取非当取有取无取有胜无胜亦如是

二十二根。几受。几非受。八受。八非受。六二分或受或非受。云何八受。眼根乃至命根名八受。云何八非受。信根乃至已知根。名八非受。云何六二分或受或非受。乐根苦根喜根忧根舍根意根。名六二分或受或非受。云何乐根受。乐根内名乐根受。云何乐根受。乐根业法烦恼所生报我分摄眼触乐受耳鼻舌身触乐受。名乐根受。云何乐根非受乐根外眼触乐受耳鼻舌身触乐受。名乐根非受。云何苦根受。苦根内名苦根受。云何苦根受。苦根业法烦恼所生报我分摄眼触苦受耳鼻舌身触苦受。名苦根受。云何苦根非受。苦根外眼触苦受耳鼻舌身触苦受。名苦根非受。云何喜根受。喜根内名喜根受。云何喜根受。喜根业法烦恼所生报我分摄意触乐受。名喜根受。云何喜根非受。喜根外名喜根非受。云何喜根非受。喜根善不善若无记非我分摄意触乐受。名喜根非受。云何忧根受。忧根内名忧根受。云何忧根受。忧根业法烦恼所生报我分摄意触苦受。名忧根受。云何忧根非受。忧根外名忧根非受。云何忧根非受。忧根善不善若无记非我分摄意触苦受。名忧根非受。云何舍根受。舍根内名舍根受。云何舍根受。业法烦恼所生报我分摄眼触不苦不乐受。耳鼻舌身意触不苦不乐受。名舍根受。云何舍根非受。舍根外名舍根非受。云何舍根非受。舍根若无记善不善非我分摄眼触不苦不乐受。耳鼻舌身意触不苦不乐受。名舍根非受。云何意根受。意根内名意根受。云何意根受。意根业法烦恼所生报我分摄眼识乃至意识。名意根受。云何意根非受。意根若外名意根非受。云何意根非受。意根善不善无记非我分摄眼识乃至意识。名意根非受。内外亦如是

二十二根。几有报。几无报。一有报。十无报。十一二分或有报或无报。云何一有报。未知欲知根。名一有报。云何十无报。眼根乃至苦根。名十无报。云何十一二分或有报或无报。除未知欲知根。余喜根乃至已知根。名十一二分或有报或无报。云何喜根有报。喜根报法。名喜根有报。云何喜根有报。喜根除善报。余喜根善不善意触乐受。名喜根有报。云何喜根无报。喜根若报喜根非报非报法意触乐受。名喜根无报。云何忧根有报。忧根报法。名忧根有报。云何忧根有报。忧根善不善意触苦受。名忧根有报。云何忧根无报。忧根若报忧根非报非报法意触苦受。名忧根无报。云何舍根有报。舍根报法。名舍根有报。云何舍根有报。舍根除善报。余舍根善不善意触不苦不乐受。名舍根有报。云何舍根无报。舍根若报舍根非报非报法眼触非苦非乐受。耳鼻舌身意触不苦不乐受。名舍根无报。云何意根有报。意根报法。名意根有报。云何意根有报。除意根善报。余意根善不善意界意识界。是名意根有报。云何意根无报。意根报意根非报非报法眼识乃至意识。名意根无报。云何信根有报信根报法。名信根有报。云何信根有报。学人离结使圣心入圣道坚信坚法。及余趣人见行过患。观涅槃寂灭。观苦集灭道。未得欲得。未解欲解。未证欲证。修道离烦恼无学人。欲得阿罗汉果。未得圣法。欲得修道。若实人若趣信入信究竟入信真信心净。名信根有报。云何信根无报。信根报名信根无报。云何信根无报。见学人须陀洹斯陀含阿那含观智具足。若智地若观解脱心即得沙门果。须陀洹果斯陀含果阿那含果。无学人欲得阿罗汉观智具足。若智地若观解脱心即得阿罗汉果。若实人若趣信入信究竟入信真信心净。名信根无报。进根念根定根慧根亦如是。云何知根有报。知根报法。名知根有报。云何知根有报。见学人见行过患。观涅槃寂灭。观苦集灭道。未得欲得。未解欲解。未证欲证。修道离烦恼。若实人若趣若想思触思惟觉观解脱悦喜心除欲不放逸心舍灭尽定正语正业正命正身除。名知根有报。云何知根无报知根报名知根无报。云何知根无报。见学人须陀洹斯陀含阿那含观智具足。若智地若观解脱心。即得沙门果须陀洹果斯陀含果阿那含果。若实人若趣若想思触思惟觉观解脱悦喜心除欲不放逸心舍得果灭尽定正语正业正命正身除。名知根无报。云何已知根有报。已知根报法。名已知根有报。云何已知根有报。无学人欲得阿罗汉。未得圣法欲得修道。若实人若趣想思触思惟觉观解脱悦喜心除欲不放逸心舍灭尽定正语正业正命正身除。名已知根有报。云何已知根无报。已知根报。名已知根无报。云何已知根无报。无学人欲得阿罗汉果观智具足。若智地若观解脱心即得阿罗汉果。若实人若趣若想思触思惟觉观解脱悦喜心除欲不放逸心舍得果灭尽定正语正业正命正身除。名已知根无报

二十二根。几心。几非心。一心。二十一非心。云何一心。意根名一心。云何二十一非心。除意根余一切非心

二十二根。几心相应。几非心相应。九心相应。八非心相应。一不说心相应非心相应。四二分或心相应或非心相应。云何九心相应。除意根进根余乐根乃至慧根。是名九心相应。云何八非心相应。眼根乃至命根。名八非心相应。云何一不说心相应非心相应。意根是名一不说心相应非心相应。云何四二分或心相应或非心相应。进根未知欲知根知根已知根。名四二分或心相应或非心相应。云何进根心相应。进根心数心发出度。名进根心相应。云何进根非心相应。进根非心数身发出度。名进根非心相应。云何未知欲知根心相应。未知欲知根。若心数想思触思惟觉观解脱悦喜心除欲不放逸心舍名未知欲知根心相应。云何未知欲知根非心相应。未知欲知根非心数正语正业正命正身除。名未知欲知根非心相应。云何知根心相应。知根若心数想思触思惟觉观解脱悦喜心除欲不放逸心舍。名知根心相应。云何知根非心相应。知根非心数得果灭尽定正语正业正命正身除。名知根非心相应。已知根亦如是

二十二根。几心数。几非心数。九心数。九非心数。四二分或心数或非心数。云何九心数。除意根进根。余乐根乃至慧根。名九心数。云何九非心数。眼根乃至命根意根。名九非心数。云何四二分或心数或非心数。进根未知欲知根知根已知根。名四二分或心数或非心数。云何进根心数。进根若缘心发出度。是名进根心数。云何进根非心数。进根非缘身发出度。名进根非心数。云何未知欲知根心数。未知欲知根缘想思触思惟觉观解脱悦喜心。除欲不放逸心舍。名未知欲知根心数。云何未知欲知根非心数。未知欲知根非缘正语正业正命正身除。名未知欲知根非心数。云何知根心数。知根缘想思触思惟觉观解脱悦喜心除欲不放逸心舍。名知根心数。云何知根非心数。知根非缘得果灭尽定正语正业正命正身除。名知根非心数。已知根亦如是

二十二根。几缘。几非缘。十缘。八非缘。四二分或缘或非缘。云何十缘除进根余乐根乃至慧根及意根。名十缘。云何八非缘。眼根乃至命根名八非缘。云何四二分或缘或非缘。进根未知欲知根知根已知根。名四二分或缘或非缘。云何进根缘。进根心数发出度。名进根缘。云何进根非缘。进根非心数身发出度。名进根非缘。云何未知欲知根缘。未知欲知根若心数想思触思惟觉观解脱悦喜心除欲不放逸心舍。名未知欲知根缘。云何未知欲知根非缘。未知欲知根非心数正语正业正命正身除。名未知欲知根非缘。云何知根缘。知根心数想思触思惟觉观解脱悦喜心除欲不放逸心舍。名知根缘。云何知根非缘。知根非心数得果灭尽定正语正业正命正身除。是名知根非缘。已知根亦如是

二十二根。几共心。几不共心。十共心。九不共心。三二分或共心或不共心。云何十共心。除意根进根余乐根乃至未知欲知根。名十共心。云何九不共心。眼根乃至命根及意根。名九不共心。云何三二分或共心或不共心。进根知根已知根。名三二分或共心或不共心。云何进根共心。进根若随心转共心生共住共灭心发出度。名进根共心。云何进根不共心。进根不随心转不共心生不共住不共灭身发出度。名进根不共心。云何知根共心。知根随心转共心生共住共灭想思触思惟觉观解脱悦喜心除欲不放逸心舍正语正业正命正身除。是名知根共心。云何知根不共心。知根若不随心转不共心生不共住不共灭得果灭尽定正语正业正命正身除。名知根不共心已知根亦如是。随心转不随心转亦如是

二十二根。几业。几非业。十九非业三二分或业或非业。云何十九非业。眼根乃至慧根。名十九非业。云何三二分或业或非业。未知欲知根知根已知根。名三二分或业或非业。云何未知欲知根业。思正语正业正命。名未知欲知根业。云何未知欲知根非业。想触思惟觉观解脱悦喜心除欲不放逸心舍正身除。名未知欲知根非业。云何知根业。思正语正业正命名知根业。云何知根非业。想触思惟觉观解脱悦喜心除欲不放逸心舍得果灭尽定正身除。名知根非业已知根亦如是

二十二根。几业相应。几非业相应。十业相应。八非业相应。一二分或业相应或非业相应。三三分或业相应或非业相应。或不说业相应非业相应。云何十业相应。除进根余乐根乃至慧根及意根。名十业相应。云何八非业相应。眼根乃至命根。名八非业相应。云何一二分或业相应或非业相应。进根名一二分或业相应或非业相应。云何三三分或业相应或非业相应或不说业相应非业相应未知欲知根知根已知根名三三分或业相应或非业相应或不说业相应非业相应。云何进根业相应。进根思相应心发出度。名进根业相应。云何进根非业相应。进根非思相应身发出度。名进根非业相应。云何未知欲知根业相应。未知欲知根思相应想触思惟觉观解脱悦喜心除欲不放逸心舍。名未知欲知根业相应。云何未知欲知根非业相应。未知欲知根非思相应正语正业正命正身除。名未知欲知根非业相应云何未知欲知根不说业相应非业相应。思名未知欲知根不说业相应非业相应。云何知根业相应。知根思相应想触思惟觉观解脱悦喜心除欲不放逸心舍。名知根业相应。云何知根非业相应。知根非思相应得果灭尽定正语正业正命正身除。名知根非业相应。云何知根不说业相应非业相应。思是名知根不说业相应非业相应。已知根亦如是

二十二根。几共业。几不共业。十二共业。八不共业。二二分或共业。或不共业。云何十二共业。乐根乃至未知欲知根。名十二共业。云何八不共业。眼根乃至命根。名八不共业。云何二二分或共业或不共业。知根已知根。名二二分或共业或不共业。云何知根共业。知根随业转共业生共住共灭想思触思惟觉观解脱悦喜心除欲不放逸心舍灭尽定正语正业正命正身除。名知根共业。云何知根不共业。知根不随业转不共业生不共住不共灭得果。名知根不共业。已知根亦如是。随业转不随业转亦如是

二十二根。几因。几非因。十二因。八非因。二二分或因或非因。云何十二因。乐根乃至未知欲知根。名十二因。云何八非因。眼根乃至命根。名八非因。云何二二分或因或非因。知根已知根。名二二分或因或非因。云何知根因。知根缘知根非缘有报除得果余知根报想思触思惟觉观解脱悦喜心除欲不放逸心舍灭尽定正语正业正命正身除。名知根因。云何知根非因。知根非缘无报不共业得果。名知根非因已知根亦如是

二十二根。几有因。几无因。一切有因。一切有绪。一切有缘。一切有为

二十二根。几知。几非知。一切知知见如事

二十二根。几识。几非识。一切识意识如事

识二十二根。几解。几非解。一切解如事知见

二十二根。几了几非了一切了知。见如事

二十二根。几断智知。几非断智知。十八非断智知。四二分或断智知或非断智知。云何十八非断智知。眼根乃至苦根信根乃至已知根。名十八非断智知。云何四二分或断智知或非断智知。喜根忧根舍根意根。是名四二分或断智知或非断智知。云何喜根断智知。喜根不善意触乐受。名喜根断智知。云何喜根非断智知。喜根善无记意触乐受。名喜根非断智知。云何忧根断智知忧根不善意触苦受。名忧根断智知。云何忧根非断智知。忧根善无记意触苦受。是名忧根非断智知。云何舍根断智知。舍根不善意触不苦不乐受。名舍根断智知。云何舍根非断智知。舍根善无记眼触不苦不乐受。耳鼻舌身意触不苦不乐受。名舍根非断智知。云何意根断智知。意根不善意界意识界。名意根断智知。云何意根非断智知。意根善无记眼识乃至意识。名意根非断智知。断非断亦如是

二十二根。几修。几非修。八修。十非修。四二分或修或非修。云何八修。信根乃至已知根。名八修。云何十非修。眼根乃至苦根。名十非修。云何四二分或修或非修。喜根忧根舍根意根。名四二分或修或非修。云何喜根修。喜根若善意触乐受。名喜根修。云何喜根非修。喜根非善无记意触乐受。名喜根非修。云何忧根修。忧根善意触苦受。名忧根修。云何忧根非修。忧根不善无记意触苦受。名忧根非修。云何舍根修。舍根善意触不苦不乐受。名舍根修。云何舍根非修。舍根不善无记眼触不苦不乐受。耳鼻舌身意触不苦不乐受。名舍根非修。云何意根修。意根善意界意识界。名意根修。云何意根非修。意根不善无记眼识乃至意识。名意根非修

二十二根。几证。几非证。一切证知见如事

二十二根。几善。几不善。几无记。八善。十无记。四三分或善或不善或无记。云何八善。信根乃至已知根。名八善。云何十无记。眼根乃至苦根。名十无记。云何四三分或善或不善或无记。喜根忧根舍根意根。名四三分或善或不善或无记。云何喜根善。喜根若修意触乐受。是名喜根善云何喜根不善。喜根断意触乐受。名喜根不善。云何喜根无记。喜根受喜根非报非报法意触乐受。名喜根无记。云何忧根善。忧根若修意触苦受。名忧根善。云何忧根不善。忧根断意触苦受。名忧根不善。云何忧根无记。忧根受忧根非报非报法意触苦受名忧根无记。云何舍根善。舍根修意触不苦不乐受。名舍根善。云何舍根不善。舍根断意触不苦不乐受。名舍根不善。云何舍根无记。舍根受舍根非报非报法。眼触不苦不乐受。耳鼻舌身意触不苦不乐受。名舍根无记。云何意根善。意根修意界意识界。是名意根善。云何意根不善。意根断意界意识界。是名意根不善。云何意根无记。意根若受意根非报非报法眼识乃至意识。名意根无记

二十二根几学。几无学。几非学非无学。二学。一无学。十一非学非无学。五二分或学或无学。三三分或学或无学或非学非无学。云何二学。未知欲知根知根名二学。云何一无学。已知根名一无学。云何十一非学非无学。眼根乃至苦根忧根。名十一非学非无学。云何五二分或学或无学。信根进根念根定根慧根名五二分或学或无学。云何三三分或学或无学或非学非无学。喜根舍根意根。名三三分或学或无学或非学非无学。云何信根学。学人分离结使圣心入圣道。若坚信坚法。及余趣人。见行过患。观涅槃寂灭。如实观苦集灭道未得欲得。未解欲解。未证欲证。修道离烦恼见学人。若须陀洹斯陀含阿那含观智具足。若智地若观解脱心。即得沙门果须陀洹果斯陀含果阿那含果。若实人若趣若信入信究竟入信真信入真信心净。名信根学。云何信根无学。学人欲得阿罗汉。未得圣法。欲得修道。观智具足。若智地若观解脱心。即得阿罗汉果。若实人若趣若信入信究竟入信真信入真信心净。名信根无学。进根念根定根慧根亦如是。云何喜根学。喜根若圣法非无学。名喜根学。云何喜根学。喜根学信根相应意触乐受。名喜根学。云何喜根学。学人离结使圣心入圣道。若坚信若坚法。及余趣人。见行过患。观涅槃寂灭。如实观苦集灭道。未得欲得。未解欲解。未证欲证。修道离烦恼见学人。若须陀洹斯陀含阿那含。观智具足。若智地若观解脱心。即得沙门果。若须陀洹果。斯陀含果。阿那含果若实人若趣意触乐受。名喜根学。云何喜根无学。喜根若圣非学。名喜根无学。云何喜根无学。喜根无学信根相应意触乐受。名喜根无学。云何喜根无学。无学人欲得阿罗汉果。未得圣法。欲得修道。观智具足。若智地若观解脱心。即得阿罗汉果。若实人若趣若意触乐受。名喜根无学。云何喜根非学非无学。喜根非圣意触乐受。名喜根非学非无学。云何舍根学。舍根若圣非无学。名舍根学。云何舍根学。舍根学信根相应意触不苦不乐受。名舍根学。云何舍根学。学人离结使。乃至即得阿那含果。若实人若趣若意触不苦不乐受。名舍根学。云何舍根无学。舍根圣非学。名舍根无学。云何舍根无学。舍根无学信根相应意触不苦不乐受。名舍根无学。云何舍根无学。无学人欲得阿罗汉果乃至即得阿罗汉果。若实人若趣若意触不苦不乐受。名舍根无学。云何舍根非学非无学。舍根非圣眼触不苦不乐受。耳鼻舌身意触不苦不乐受。是名舍根非学非无学。云何意根学。意根圣非无学。是名意根学。云何意根学意根学信根相应意界意识界。名意根学。云何意根学。学人离结使。乃至即得阿那含果。若实人若趣若意界意识界。是名意根学。云何意根无学。意根圣非学。名意根无学。云何意根无学。意根无学信根相应意界意识界。名意根无学。云何意根无学。无学人欲得阿罗汉果。乃至即得阿罗汉果。若实人若趣意界意识界。名意根无学。云何意根非学非无学。意根非圣识受阴眼识乃至意识。名意根非学非无学

二十二根几报。几报法。几非报非报法。八报。一报法。七二分或报或报法。二二分或报或非报非报法。四三分或报或报法。或非报非报法。云何八报。眼根乃至命根。名八报。云何一报法。未知欲知根。名一报法。云何七二分或报或报法。除未知欲知根余信根乃至已知根。名七二分或报或报法。云何二二分或报或非报非报法。乐根苦根。名二二分或报或非报非报法云何四三分或报或报法或非报非报法。喜根忧根舍根意根。名四三分或报或报法或非报非报法云何信根报。信根无报。名信根报。云何信根报。见学人若须陀洹斯陀含阿那含。观智具足。若智地若观解脱心。即得沙门果须陀洹果斯陀含果阿那含果。无学人欲得阿罗汉果。观智具足。若智地若观解脱心。即得阿罗汉果。若实人若趣若信入信究竟入信真信入真信心净。名信根报。云何信根报法。信根有报。名信根报法。云何信根报法。学人离结使圣心入圣道坚信坚法。及余趣人。见行过患。观涅槃寂灭。如实观苦集灭道。未得欲得。未解欲解。未证欲证。修道离烦恼无学人。欲得阿罗汉果。未得圣法。欲得修道。若实人若趣若信入信究竟入信真信入真信心净。是名信根报法。进根念根定根慧根亦如是云何知根报。知根无报。名知根报。云何知根报。见学人须陀洹斯陀含阿那含。观智具足若智地若观解脱心。即得沙门果须陀洹果斯陀含果阿那含果。若实人若趣若想思触思惟觉观解脱喜悦心除欲不放逸心舍得果灭尽定正语正业正命正身除。是名知根报。云何知根报法。知根有报。名知根报法。云何知根报法。学人见行过患。观涅槃寂灭。如实观集苦灭道。未得欲得。未解欲解。未证欲证。修道离烦恼。若实人若趣若想思触思惟觉观解脱悦喜心除欲不放逸心舍灭尽定正语正业正命正身除。名知根报法。云何已知根报。已知根无报。名已知根报。云何已知根报。无学人欲得阿罗汉果。观智具足若智地若观解脱心。即时得阿罗汉果。若实人若趣若想思触思惟觉观解脱悦喜心除欲不放逸心舍得果灭尽定正语正业正命正身除名已知根报。云何已知根报法。已知根有报。名已知根报法。云何已知根报法。无学人欲得阿罗汉果。未得圣法。欲得修道。若实人若趣若想思触思惟觉观解脱悦喜心除欲不放逸心舍灭尽定正语正业正命正身除。名已知根报法。云何乐根报。乐根受名乐根报。云何乐根报。乐根业法烦恼所生报我分摄眼触乐受。耳鼻舌身触乐受。名乐根报。云何乐根非报非报法。乐根无记非我分摄眼触乐受。耳鼻舌身触乐受。名乐根非报非报法。云何苦根报。苦根受名苦根报。云何苦根报。苦根业法烦恼所生报我分摄眼触苦受。耳鼻舌身触苦受。是名苦根报。云何苦根非报非报法。苦根无记非我分摄眼触苦受。耳鼻舌身触苦受。是名苦根非报非报法。云何喜根报。喜根受喜根善报意触乐受。名喜根报。云何喜根报法。喜根有报。名喜根报法。云何喜根报法。除喜根善报。余喜根善不善意触乐受。名喜根报法。云何喜根非报非报法。喜根无记非我分摄意触乐受。名喜根非报非报法。云何忧根报。忧根受名忧根报。云何忧根报。忧根业法烦恼所生报我分摄意触苦受。名忧根报。云何忧根报法。忧根有报。名忧根报法。云何忧根报法。忧根善不善意触苦受。是名忧根报法。云何忧根非报非报法。忧根无记非我分摄意触苦受。名忧根非报非报法。云何舍根报。舍根受舍根善报眼触不苦不乐受。耳鼻舌身意触不苦不乐受。名舍根报。云何舍根报法。舍根有报。名舍根报法。云何舍根报法。除舍根善报。余舍根善不善意触不苦不乐受。名舍根报法。云何舍根非报非报法。舍根无记非我分摄眼触不苦不乐受。耳鼻舌身意触不苦不乐受。名舍根非报非报法。云何意根报。意根受意根善报眼识乃至意识。名意根报。云何意根报法。意根有报。名意根报法。云何意根报法。除意根善报。余意根善不善意界意识界。名意根报法。云何意根非报非报法。意根若无记非我分摄眼识乃至意识。名意根非报非报法

二十二根。几见断。几思惟断。几非见断非思惟断。十八非见断非思惟断。四三分或见断或思惟断或非见断非思惟断。云何十八非见断非思惟断。眼根乃至苦根。信根乃至已知根。名十八非见断非思惟断。云何四三分或见断或思惟断或非见断非思惟断。喜根忧根舍根意根。名四三分或见断或思惟断或非见断非思惟断。云何喜根见断喜根不善非思惟断见断烦恼相应意触乐受。名喜根见断。云何喜根思惟断。喜根不善非见断思惟断烦恼相应意触乐受。名喜根思惟断。云何喜根非见断非思惟断。喜根善无记意触乐受。名喜根非见断非思惟断。云何忧根见断。忧根不善非思惟断见断烦恼相应意触苦受。名忧根见断。云何忧根思惟断。忧根不善非见断思惟断烦恼相应意触苦受。名忧根思惟断。云何忧根非见断非思惟断。忧根善无记意触苦受。名忧根非见断非思惟断。云何舍根见断。舍根不善非思惟断见断烦恼相应意触不苦不乐受。名舍根见断。云何舍根思惟断。舍根不善非见断思惟断烦恼相应意触不苦不乐受。名舍根思惟断。云何舍根非见断非思惟断。舍根善无记眼触不苦不乐受。耳鼻舌身意触不苦不乐受。名舍根非见断非思惟断。云何意根见断。意根不善非思惟断见断烦恼相应意界意识。界。是名意根见断。云何意根思惟断。意根相应不善非见断思惟断烦恼相应意界意识界。名意根思惟断。云何意根非见断非思惟断。意根善无记眼识乃至意识。名意根非见断非思惟断

二十二根。几见断因。几思惟断因。几非见断因非思惟断因。九非见断因非思惟断因。十三三分或见断因或思惟断因或非见断因非思惟断因。云何九非见断因非思惟断因。乐根信根乃至已知根。名九非见断因非思惟断因。云何十三三分或见断因或思惟断因或非见断非思惟断因。除乐根。余眼根乃至意根。名十三三分或见断因或思惟断因或非见断非思惟断因。云何眼根见断因。眼根见断法报地狱畜生饿鬼眼根。名眼根见断因。云何眼根思惟断因。眼根思惟断法报地狱畜生饿鬼眼根。名眼根思惟断因。云何眼根非见断非思惟断因。眼根善法报天上人中眼根。名眼根非见断非思惟断因。耳鼻舌身根女根男根亦如是。云何苦根见断因。苦根见断法报眼触苦受。耳鼻舌身触苦受。名苦根见断因。云何苦根思惟断因。苦根若思惟断法报眼触苦受。耳鼻舌身触苦受。名苦根思惟断因。云何苦根非见断非思惟断因。苦根善法报苦根非报非报法眼触苦受。耳鼻舌身触苦受。名苦根非见断非思惟断因。云何喜根见断因。喜根若见断意触乐受。名喜根见断因。云何喜根思惟断因。喜根思惟断意触乐受。名喜根思惟断因。云何喜根非见断非思惟断因。喜根善法报喜根若非报非报法意触乐受。名喜根非见断非思惟断因。云何忧根见断因。忧根见断忧根见断法报意触苦受。名忧根见断因。云何忧根思惟断因。忧根思惟断忧根思惟断法报意触苦受。名忧根思惟断因。云何忧根非见断非思惟断因。忧根善忧根善法报忧根非报非报法。意触苦受。名忧根非见断非思惟断因。云何舍根见断因。舍根见断舍根见断法报。眼触不苦不乐受。耳鼻舌身意触不苦不乐受。名舍根见断因。云何舍根思惟断因。舍根思惟断舍根思惟断法报。眼触不苦不乐受。名舍根思惟断因。云何舍根非见断非思惟断因。舍根善舍根善法报舍根非报非报法眼。触不苦不乐受。耳鼻舌身意触不苦不乐受。名舍根非见断非思惟断因。云何意根见断因。意根见断意根见断法报。眼识乃至意识。名意根见断因。云何意根思惟断因。意根思惟断意根思惟断法报。眼识乃至意识。名意根思惟断因。云何意根非见断非思惟断因。意根善意根善法报意根非报非报法。眼识乃至意识。名意根非见断非思惟断因

二十二根。几欲界系。几色界系。几无色界系。几不系。六欲界系。八不系。四二分或欲界系或色界系。一三分或欲界系或色界系或无色系。复一三分或欲界系或色界系或不系。二四分或欲界系或色界系或无色界系或不系。云何六欲界系鼻根舌根女根男根苦根忧根。名六欲界系。云何八不系。信根乃至已知根。名八不系。云何四二分或欲界系或色界系。眼根耳根身根乐根。名四二分或欲界系或色界系。云何一三分或欲界系或色界系或无色界系。命根名一三分或欲界系或色界系或无色界系。云何复一三分或欲界系或色界系或不系。喜根名复一三分或欲界系或色界系或不系。云何二四分或欲界系或色界系或无色界系或不系。舍根意根。名二四分或欲界系或色界系或无色界系或不系。云何眼根欲界系。眼根欲漏有漏眼根。名眼根欲界系。云何眼根色界系眼根色漏有漏眼根。名眼根色界系。耳根身根亦如是。云何乐根欲界系。乐根欲漏有漏眼触乐受。耳鼻舌身触乐受。名乐根欲界系云何乐根色界系。乐根色漏有漏眼触乐受。耳身触乐受。名乐根色界系。云何命根欲界系。命根欲漏有漏欲行寿。名命根欲界系。云何命根色界系。命根色漏有漏色行寿。名命根色界系。云何命根无色界系。命根无色漏有漏无色行寿。名命根无色界系。云何喜根欲界系。喜根欲漏有漏意触乐受。名喜根欲界系。云何喜根色界系。喜根色漏有漏意触乐受。名喜根色界系。云何喜根不系。喜根圣无漏意触乐受。名喜根不系。云何舍根欲界系。舍根欲漏有漏眼触不苦不乐受。耳鼻舌身触不苦不乐受。名舍根欲界系。云何舍根色界系。舍根若色漏有漏眼触不苦不乐受。耳身触意触不苦不乐受。名舍根色界系。云何舍根无色界系。舍根无色漏有漏意触不苦不乐受。名舍根无色界系。云何舍根不系。舍根圣无漏。意界意识界意触不苦不乐受。名舍根不系。云何意根欲界系。意根欲漏有漏眼识乃至意识。名意根欲界系。云何意根色界系。意根色漏有漏眼识耳识身识意识。是名意根色界系。云何意根无色界系。意根无色漏有漏意界意识界。是名意根无色界系。云何意根不系。意根圣无漏意界意识界。是名意根不系

二十二根。几过去。几未来。几现在。几非过去非未来非现在。一切三分或过去或未来或现在。云何眼根过去。眼根生已灭名过去。云何眼根未来。眼根未生未出名未来。云何眼根现在。眼根生未灭名现在。乃至已知根亦如是

舍利弗阿毗昙论卷第五舍利弗阿毗昙论卷第六

        姚秦罽宾三藏昙摩耶舍共昙摩崛多等译

    问分七觉品第六

问曰。几觉。答曰。七。何等七。念觉择法觉喜觉进觉除觉定觉舍觉。云何念觉。学人离结使。圣心入圣道。若坚信坚法。及余趣人。见行过患。观涅槃寂灭。如实观苦集灭道。未得欲得。未解欲解。未证欲证。修道离烦恼见学人。若须陀洹斯陀含阿那含观智具足。若智地若观解脱心。即得沙门果。若须陀洹果斯陀含果阿那含果。无学人欲得阿罗汉。未得圣法。欲得修道观智具足。若智地若观解脱心。即得阿罗汉果。若实人若趣若念忆念微念顺念住不忘相续念不失不夺不钝不钝根念念根念力正念。是名念觉。云何择法觉。学人离结使。乃至即得阿罗汉果。若实人若趣若法中。择重择究竟择择法思惟觉了达自相他相共相思持辩观进辩慧智见解脱方便术焰光明照耀慧眼慧根慧力无痴正见。是名择法觉。云何进觉。学人离结使。乃至即得阿罗汉果。若实人若趣若身心发出度堪忍不退勤力进不离不懈不缓不惰进进根进力正进。是名进觉。云何喜觉。学人离结使。乃至即得阿罗汉果。若实人若趣欢喜踊跃重踊跃究竟踊跃治净满足心欢喜。是名喜觉。云何除觉。学人离结使。乃至即得阿罗汉果。若实人若趣若身乐心乐身柔心柔身轻心轻身软心软身除心除。是名除觉。云何定觉。学人离结使。乃至即得阿罗汉果。若实人若趣心住正住专住心一向心一乐心不乱依意心独定定根定力正定。是名定觉。云何舍觉。学人离结使。乃至即得阿罗汉果。若实人若趣若舍不着心等心直不谄心不贵非受。是名舍觉

七觉。几色。几非色。五非色。二二分或色或非色。云何五非色。念觉择法觉喜觉定觉舍觉。是名五非色。云何二二分或色或非色。进觉除觉。名二二分或色或非色。云何进觉色。身发出度。名进觉色。云何进觉非色。心发出度。名进觉非色。云何除觉色。身乐身柔身轻身软身除。是名除觉色。云何除觉非色。心乐心柔心轻心软心除。是名除觉非色

七觉。几可见。几不可见。一切不可见

七觉。几有对。几无对。一切无对

七觉。几圣。几非圣。一切圣

七觉。几有漏。几无漏。一切无漏。一切无受。一切无求。一切非当趣。一切无取。一切无胜

七觉。几受。几非受。一切非受一切外

七觉。几有报。几无报。一切二分或有报或无报。云何念觉有报。念觉报法。名念觉有报。云何念觉有报。学人离结使圣心入圣道。若坚信坚法。及余趣人。见行过患。观涅槃寂灭。如实观苦集灭道。未得欲得。未解欲解。未证欲证。修道离烦恼。无学人欲得阿罗汉果。未得圣法。欲得修道。若实人若趣若念忆念微念顺念住念住不忘相续念不失不夺不钝不钝根念念根念力正念。名念觉有报。云何念觉无报。念觉报名念觉无报。云何念觉无报。见学人须陀洹斯陀含阿那含观智具足。若智地若观解脱心。即得沙门果。若须陀洹果斯陀含果阿那含果。无学人欲得阿罗汉果观智具足。若智地若观解脱心。即得阿罗汉果。若实人若趣若念忆念微念顺念住不忘相续念不失不夺不钝不钝根念念根念力正念。是名念觉无报。择法进喜除定舍觉亦如是

七觉。几心。几非心。一切非心

七觉。几心相应。几非心相应。五心相应。二二分或心相应或非心相应。云何五心相应。念觉择法觉喜觉定觉舍觉。名五心相应。云何二二分或心相应或非心相应进觉除觉。名二二分或心相应或非心相应。云何进觉心相应。进觉若心数发出度。名进觉心相应。云何进觉非心相应。进觉若非心数身发出度。是名进觉非心相应。云何除觉心相应。除觉若心数心乐心柔心轻心软心除。是名除觉心相应。云何除觉非心相应。除觉若非心数身乐身柔身轻身软身除。是名除觉非心相应。七觉。几心数。几非心数。五心数。二二分或心数或非心数。云何五心数。念觉择法觉喜觉定觉舍觉。是名五心数。云何二二分或心数或非心数。进觉除觉。是名二二分或心数或非心数。云何进觉心数。进觉若缘心发出度。名进觉心数。云何进觉非心数。进觉若非缘身发出度。名进觉非心数。云何除觉心数。除觉若缘心乐心柔心轻心软心除。是名除觉心数云何除觉非心数。除觉若非缘身乐身柔身轻身软身除。名除觉非心数

七觉。几缘。几非缘。五缘。二二分或缘或非缘。云何五缘念觉择法觉喜觉定觉舍觉。是名五缘。云何二二分或缘或非缘。进觉除觉。名二二分或缘或非缘。云何进觉缘。进觉若心数发出度。名进觉缘。云何进觉非缘。进觉若非心数身发出度。名进觉非缘。云何除觉缘。除觉若心数心乐心柔心轻心软心除。名除觉缘。云何除觉非缘。除觉若非心数身乐身柔身轻身软身除。名除觉非缘

七觉。几共心。几不共心。五共心。二二分或共心或不共心。云何五共心。念觉择法觉喜觉定觉舍觉。名五共心。云何二二分或共心或不共心。进觉除觉。名二二分或共心或不共心。云何进觉共心。进觉随心转共心生共住共灭心发出度。名进觉共心。云何进觉不共心。进觉若不随心转不共心生不共住不共灭身发出度。名进觉不共心。云何除觉共心。除觉若随心转共心生共住共灭身乐心乐身柔心柔身轻心轻身软心软身除心除。名除觉共心。云何除觉不共心。除觉若不随心转不共心生不共住不共灭身乐身柔身轻身软身除。名除觉不共心。随心转不随心转亦如是

七觉。几业。几非业。一切非业

七觉。几业相应。几非业相应。五业相应。二二分或业相应或非业相应。云何五业相应。念觉择法觉喜觉定觉舍觉。名五业相应。云何二二分或业相应或非业相应。进觉除觉。名二二分或业相应或非业相应。云何进觉业相应。进觉思相应心发出度。名进觉业相应。云何进觉非业相应。进觉若非思相应身发出度。名进觉非业相应。云何除觉业相应。除觉若思相应心乐心柔心轻心软心除。是名除觉业相应。云何除觉非业相应。除觉若非思相应身乐身柔身轻身软身除。名除觉非业相应七觉。几共业。几非共业。一切共业。一切随业转七觉。几因。几非因。一切因

七觉。几有因。几无因。一切有因。一切有绪。一切有缘。一切有为

七觉。几知。几非知。一切知如事知见

七觉。几识。几非识。一切意识如事识

七觉。几解。几非解。一切解如事知见

七觉。几了。几非了。一切了如事知见

七觉。几断智知。几非断智知。一切非断智知

七觉。几修。几非修。一切修

七觉。几证。几非证。一切证如事知见

七觉。几善。几非善。几无记。一切善

七觉。几学。几无学。几非学非无学。一切二分或学或无学。云何念觉学。学人离结使。圣心入圣道。若坚信坚法。及余趣人。见行过患。观涅槃寂灭。如实观苦集灭道。未得欲得。未解欲解。未证欲证。修道离烦恼见学人。若须陀洹斯陀含阿那含。若观智具足。若智地若观解脱心。即证沙门果。若须陀洹果斯陀含果阿那含果。若实人若趣若念忆念微念顺念住不忘相续念不失不夺不钝不钝根念念根念力正念。名念觉学。云何念觉无学。无学人欲得阿罗汉果。未得圣法。欲得修道观智具足。若智地若观解脱心。即得阿罗汉果。若实人若趣若念忆念微念顺念住不忘相续念不失不夺不钝不钝根念念根念力正念。名念觉无学。择法进喜除定舍觉亦如是

七觉几报几报法。几非报非报法。一切二分或报或报法。云何念觉报。念觉无报。名念觉报。云何念觉报。见学人若须陀洹斯陀含阿那含观智具足。若智地若观解脱心即得沙门果。若须陀洹果斯陀含果阿那含果无学人。欲得阿罗汉果。若实人若趣若念忆念微念顺念住不忘相续念不失不夺不钝不钝根念念根念力正念。名念觉报。云何念觉报法。念觉有报。名念觉报法。云何念觉报法。学人离结使。圣心入圣道。若坚信坚法。及余趣人。见行过患。观涅槃寂灭。如实观苦集灭道。未得欲得。未解欲解。未证欲证。修道离烦恼无学人。欲得阿罗汉果。未得圣法。欲得修道。若实人若趣若念忆念微念顺念住不忘相续念不失不夺不钝不钝根念念根念力正念。名念觉报法。择法进喜除定舍觉亦如是

七觉。几见断。几思惟断。几非见断非思惟断。一切非见断非思惟断

七觉。几见断因。几思惟断因。几非见断非思惟断因。一切非见断非思惟断因

七觉。几欲界系。几色界系。几无色界系。几不系。一切不系

七觉。几过去。几未来。几现在。几非过去非未来非现在。一切三分或过去或未来或现在。云何念觉过去。念觉若生已灭名过去。云何念觉未来。念觉未生未出。名念觉未来。云何念觉现在。念觉生未灭。名念觉现在。择法觉乃至舍觉亦如是

    舍利弗阿毗昙论问分不善根品第七

问曰。几不善根。答曰三。何等三。贪不善根恚不善根痴不善根。云何贪不善根。悕望名贪不善根。云何贪不善根。五欲中喜爱适意爱色欲染相续。眼识色喜爱适意爱色欲染相续。耳鼻舌身识触喜爱适意爱色欲染相续。他欲他色他财他妇他童女他所须悕望得。若贪贪着心相应贪悕望爱心欲染重欲染究竟欲染及余可贪法。若贪重贪究竟贪悕望爱心欲染重欲染究竟欲染。是名贪不善根。云何恚不善根。忿怒名恚不善根。云何恚不善根。若少众生。若多众生。伤害系缚。作种种困苦。若嗔恚重嗔恚。究竟嗔恚。相应嗔恚。忿怒横嗔。憎恶恼心。相憎无慈。无怜愍。无利益众生。及余所嗔恚法。若恚重恚究竟恚。相应嗔。忿怒横嗔。憎恶恼心。嗔恚相憎无慈。无怜愍。无利益法。名嗔恚不善根。云何痴不善根。无明是名痴不善根。云何痴不善根。不知苦集灭道。不知过去。不知未来。不知过去未来。不知内。不知外。不知内外。六触入集灭味过患。不知如实出。不知如尔。不知业报。不知缘善不善无记黑白有缘无缘有光无光作不作亲不亲。彼法中若痴夺心应夺心。碍覆盖暗冥。荒秽缠心痴浊无明无明流。无明渊。无明使。无知无见。无解无脱。无方便。及余法中痴若痴夺心应夺心碍覆盖闇冥。乃至无知无见无解无脱无方便。名痴不善根三不善根。几色。几非色。一切非色。三不善根。几可见。几不可见。一切不可见。三不善根。几有对。几无对。一切无对。三不善根。几圣。几非圣。一切非圣。三不善根。几有漏几无漏。一切有漏。一切有爱。一切有求。一切当求。一切有取。一切有胜。三不善根。几受。几不受。一切不受。一切外。三不善根。几有报。几无报。一切有报。三不善根。几心。几非心。一切非心。三不善根。几心相应。几非心相应。一切心相应。三不善根。几心数。几非心数。一切心数。三不善根。几缘。几非缘。一切缘。三不善根。几共心。几不共心。一切共心。一切随心转。三不善根。几业。几非业。一切非业。三不善根。几业相应。几非业相应。一切业相应。三不善根。几共业。几不共业。一切共业。一切随业转。三不善根。几有因。几无因。一切有因。一切有绪。一切有缘。一切有为。三不善根。几知。几非知。一切知知见如事。一切识意识如事。一切解一切了。三不善根。几断智知。几非断智知。一切断智知。一切断。三不善根。几修。几非修。一切非修。三不善根。几证。几非证。一切证知见如事。三不善根。几善。几不善。几无记。一切不善。三不善根。几学。几无学。几非学非无学。一切非学非无学。三不善根。几报。几报法。几非报非报法。一切报法。三不善根。几见断。几思惟断。几非见断非思惟断。一切二分或见断或思惟断。云何贪不善根见断。贪不善根见断因。贪不善根。是名贪不善根见断。云何贪不善根思惟断。贪不善根思惟断因贪不善根。名贪不善根思惟断。恚痴亦如是。三不善根。几欲界系。几色界系。几无色界系。二欲界系。一三分或欲界系或色界系或无色界系。云何二欲界系。贪不善根。恚不善根。名二欲界系。云何一三分或欲界系或色界系或无色界系痴不善根。名一三分或欲界系或色界系或无色界系。云何痴不善根欲界系。欲漏有漏痴不善根名欲界系。云何痴不善根色界系。色漏有漏痴不善根。名色界系。云何痴不善根无色界系。无色漏有漏痴不善根。名无色界系。三不善根。几过去。几未来。几现在。几非过去非未来非现在。一切三分或过去或未来或现在。云何贪不善根过去。贪不善根生已灭名过去。云何贪不善根未来。贪不善根未生未出名未来。云何贪不善根现在。贪不善根生未灭名现在。恚痴亦如是

    舍利弗阿毗昙论问分善根品第八

问曰。几善根。答曰三。何等三。无贪善根无恚善根无痴善根。云何无贪善根。不悕望名无贪善根。云何无贪善根。心堪忍离贪。是名无贪善根。云何无贪善根。五欲中喜爱适意爱色欲染相续。眼识色爱喜适意爱色欲染相续。耳鼻舌身识触爱喜适意爱色欲染相续。他欲他色他财他妻女他童女他所须。不悕望得。不贪不着心。不贪悕望。不爱不欲染。不重欲染心。究竟不欲染。及余法不贪不重贪究竟。不贪不悕望。不爱不欲染。不重欲染。究竟不贪。不悕望不爱。不欲染不重欲染。究竟不欲染。名无贪善根。云何无恚善根。不忿怒是名无恚善根。云何无恚善根。心堪忍离恚。名无恚善根。云何无恚善根。若少众生多众生。此众生。不伤害。不系缚。不缚闭。不作种种苦。不嗔不重嗔。究竟不嗔心。不应嗔。不忿怒。不横嗔。不憎恶。不恼乱心。不相憎恶。怜愍利益众生。及余法不嗔不恚不重恚究竟不恚心不应恚不忿怒不横嗔不憎恶不恼乱心不嗔恚不相憎恶怜愍利益法。是名不恚善根。云何无痴善根。离无明名无痴善根。云何无痴善根心堪忍离痴。名无痴善根。云何无痴善根。知苦集灭道。知过去。知未来。知过去未来。知内知外。知内外。知六触入集灭味过患。知如实出。知如尔。知业报。知缘知善不善无记。知黑白有缘无缘有光无光作不作亲不亲。过去法中。无痴不夺不夺心不相应无碍无覆盖无暗冥无荒乱无缠心不痴不浊明焰光照照知见解脱方便慧眼慧根慧力择法正觉正见。及余法中。无痴不夺不夺心相应无碍无覆盖无闇冥。乃至正觉正见。名无痴善根。三善根。几色。几非色。一切非色。三善根。几可见。几不可见。一切不可见。三善根。几有对。几无对。一切无对。三善根。几圣。几非圣。二非圣。一二分或圣或非圣。云何二非圣。无贪无恚。名二非圣。云何一二分或圣或非圣。无痴善根。是名一二分或圣或非圣。云何无痴善根非圣。无痴善根有漏。名无痴善根非圣。云何无痴善根非圣。非学非无学无痴善根。是名无痴善根非圣。云何无痴善根圣。无痴善根无漏。是名无痴善根圣。云何无痴善根圣。信根相应无痴善根。名无痴善根圣。云何无痴善根圣。学人离结使圣心入圣道坚信坚法。及余趣人。见行过患。观涅槃寂灭。如实观苦集灭道。未得欲得。未解欲解。未证欲证。修道离烦恼见学人须陀洹斯陀含阿那含观智具足。若智地若观解脱心即得沙门果须陀洹果斯陀含果阿那含果。无学人欲得阿罗汉未得圣法。欲得圣法欲得修道观智具足。若智地若观解脱心即得阿罗汉果。若趣若无痴。名无痴善根圣。有漏无漏有爱无爱有求无求当取非当取有取无取有胜无胜亦如是。三善根。几受。几非受。一切非受。一切外。三善根。几有报。几无报。二有报。一二分或有报或无报。云何二有报。无贪无恚。名二有报。云何一二分或有报或无报。无痴善根。名一二分或有报或无报。云何无痴善根有报。无痴善根报法。名无痴善根有报。云何无痴善根有报。学人离结使圣心入圣道若坚信坚法。及余趣人。见行过患。观涅槃寂灭。如实观苦集灭道。未得欲得。未解欲解。未证欲证。修道离烦恼。无学人欲得阿罗汉。未得圣法。欲得修道。若实人若趣若无痴。名无痴善根有报。云何无痴善根无报。无痴善根报。名无痴善根无报。云何无痴善根无报。见学人须陀洹斯陀含阿那含观智具足。若智地若观解脱心即得沙门果须陀洹果斯陀含果阿那含果。无学人欲得阿罗汉。观智具足。若智地若观解脱心即得阿罗汉果。若实人若趣无痴。名无痴善根无报。三善根。几心。几非心。一切非心。三善根。几心相应几非心相应。一切心相应。三善根。几心数几非心数。一切心数。三善根。几缘。几非缘。一切缘。三善根几共心。几不共心。一切共心。一切随心转。三善根。几业。几非业。一切非业。三善根。几业相应。几非业相应。一切业相应。三善根。几共业。几非共业。一切共业。一切随业转。三善根。几因。几非因。一切因。三善根。几有因。几无因。一切有因。一切有绪。一切有缘。一切有为。三善根。几知。几非知。一切知如事知见。三善根。几识。几非识。一切识意识如事识。一切解。一切了。三善根。几断智知。几非断智知。一切非断智知。一切非断。三善根。几修。几非修。一切修。三善根。几证。几非证。一切证知见如事。三善根。几善。几非善。几无记。一切善。三善根。几学。几无学。几非学非无学。二非学非无学。一三分或学或无学或非学非无学。云何二非学非无学。无贪无恚。名二非学非无学。云何一三分或学或无学。或非学非无学。无痴善根。名一三分或学或无学或非学非无学。云何无痴善根学。无痴善根圣非无学。名无痴善根学。云何无痴善根学。学信根相应无痴善根。名无痴善根学。云何无痴善根学。学人离结使圣心入圣道。若坚信坚法。及余趣人。见行过患。观涅槃寂灭。如实观苦集灭道。未得欲得。未解欲解未证欲证。修道离烦恼。见学人若须陀洹斯陀含阿那含观智具足。若智地若观解脱心即得沙门果须陀洹果斯陀含果阿那含果。若实人若趣无痴善根。名无痴善根学。云何无痴善根无学。无痴善根若圣非学。名无痴善根无学。云何无痴善根无学。无学信根相应无痴善根。名无痴善根无学。云何无痴善根无学。无学人欲得阿罗汉。未得圣法。欲得圣法修道观智具足。若智地若观解脱心即得阿罗汉果。若实人若趣无痴。名无痴善根无学。云何无痴善根非学非无学。无痴善根非圣无痴。名无痴善根非学非无学。三善根。几报。几报法。几非报非报法。二报法。一二分或报或报法。云何二报法。无贪无恚。名二报法。云何一二分或报或报法。无痴善根。名一二分或报或报法。云何无痴善根报。无痴善根无报。名无痴善根报。云何无痴善根报。见学人须陀洹斯陀含阿那含观智具足。若智地若观解脱心即得沙门果。若须陀洹果斯陀含果阿那含果。无学人欲得阿罗汉。观智具足。若智地若观解脱心即得阿罗汉果。若实人若趣无痴。名无痴善根报。云何无痴善根报法。无痴善根有报。名无痴善根报法。云何无痴善根报法。学人离结使。圣心入圣道坚信坚法。及余趣人。见行过患。观涅槃寂灭。如实观苦集灭道。未得欲得。未解欲解。未证欲证。修道离烦恼。无学人欲得阿罗汉未得圣法。欲得修道。若实人若趣无痴。是名无痴善根报法。三善根。几见断。几思惟断。几非见断非思惟断。一切非见断非思惟断三善根。几见断因。几思惟断因。几非见断非思惟断因。一切非见断非思惟断因。三善根。几欲界系。几色界系。几无色界系。几不系。二欲界系。一四分或欲界系或色界系或无色界系或不系。云何二欲界系。无贪无恚。名二欲界系。云何一四分或欲界系或色界系或无色界系或不系。无痴善根。名一四分或欲界系或色界系或无色界系或不系。云何无痴善根欲界系。欲漏有漏无痴善根。名欲界系。云何无痴善根色界系。色漏有漏无痴善根。名色界系。云何无痴善根无色界系。无色漏有漏无痴善根。名无色界系。云何无痴善根不系。圣无漏无痴善根名不系。三善根。几过去。几未来。几现在。几非过去非未来非现在。一切三分或过去或未来或现在。云何无贪善根过去。无贪善根生已灭名过去。云何无贪善根未来。无贪善根未生未出名未来。云何无贪善根现在。无贪善根生未灭名现在。无恚无痴亦如是

    舍利弗阿毗昙论问分大品第九

问曰。几大。答曰四。何等四。地水火风大。云何地大。二地大。内地大。外地大。云何内地大。若身内别坚受坚。骨齿爪发毛妍肤肌皮筋脾肾肝肺心肠胃大肠小肠大腹小腹粪秽。此身及余内受坚。名内地大。云何外地大。外非受坚。铜铁铅锡白镴金银真珠琉璃珂贝璧玉珊瑚钱性宝贝珠沙石土碱卤石粪扫灰土地草木枝叶茎节。及余外非受坚。名外地大。如是内地大外地大名地大

云何水大。二水大。内水大。外水大。云何内水大。身内受。水腻涎癊胆肝肪髓脑脂[月*冊]涕唾脓血小便。及余身内受水润等。名内水大

云何外水大。若外水腻非受。苏油生酥蜜黑石蜜乳酪酪浆醪酒甘蔗酒蜜酒。及余外水腻非受。名外水大。如是内水大外水大名水大

云何火大。二火大。内火大。外火大。云何内火大。身内火受热。若热能令热。身热内燋。若服食饮等消。及余身内别受火。名内火大。云何外火大。外火非受热火热日热珠热舍热墙热山热谷气热草热木热牛屎粪热。及余外火热非受。名外火大。如是内火大外火大名火大

云何风大。二风大。内风大。外风大。云何内风大。身受风。上风下风依节风挛躄风骨节游风出息入息风。余内别受风。名内风大。云何外风大。外风非受。东风南风西风北风杂尘风不杂尘风冷风热风黑风旋岚风动地风。及余外风非受。名外风大。如是内风大外风大名风大

四大。几色。几非色。一切色。四大。几可见。几不可见。一切不可见。四大。几有对。几无对。一切有对。四大。几圣。几非圣。一切非圣。四大。几有漏。几无漏。一切有漏。一切有爱。一切有求。一切当取。一切有取。一切有胜。四大。几受。几非受。一切二分或受或非受。云何地大受。地大若内名地大受。云何地大受。地大业法烦恼所生报我分摄。名地大受。云何地大非受外地大名地大非受。水火风大亦如是。四大。几有报。几无报。一切无报。四大几心。几非心。一切非心。四大。几心相应。几非心相应。一切非心相应。四大。几心数。几非心数。一切非心数。四大。几缘。几非缘。一切非缘。四大。几共心。几不共心。一切不共心。一切不随心转。四大。几业。几非业。一切非业。四大。几业相应。几非业相应。一切非业相应。四大。几共业。几非共业。一切不共业。一切不随业转。四大。几因。几非因。一切因。四大。几有因。几无因。一切有因。一切有绪。一切有缘。一切有为。四大。几知。几非知。一切知如事知见。四大。几识。几非识。一切识如事识。一切了如事知见。四大。几断智知。几非断智知。一切非断智知。四大。几修。几非修。一切非修。四大。几证。几非证。一切证如事知见。四大。几善。几不善。几无记。一切无记四大。几学。几无学。几非学非无学。一切非学非无学。四大。几报。几报法。几非报非报法。一切二分或报或非报非报法。云何地大报。地大受名地大报。云何地大报。地大业法烦恼所生报我分摄。名地大报。云何地大非报非报法。外地大名地大非报非报法。水火风大亦如是

四大。几见断。几思惟断。几非见断非思惟断。一切非见断非思惟断。四大。几见断因。几思惟断因。几非见断非思惟断因。一切三分或见断因或思惟断因或非见断非思惟断因。云何地大见断因。若见断法报地大。名地大见断因。云何地大思惟断因。思惟断因法报地大。是名地大思惟断因。云何地大非见断非思惟断因。善法报地大非报非报法。名地大非见断非思惟断因。水火风大亦如是。四大。几欲界系。几色界系。几无色界系。几不系。一切二分或欲界系或色界系。云何地大欲界系。欲漏有漏地大。名欲界系。云何地大色界系。色漏有漏地大。名色界系。水火风大亦如是。四大。几过去。几未来。几现在。一切三分或过去或未来或现在。云何地大过去。地大生已灭名过去。云何地大未来。地大未生未出名未来。云何地大现在。地大生未灭名现在。水火风大亦如是

    舍利弗阿毗昙论问分优婆塞品第十

问曰。是优婆塞耶。答曰是。谁优婆塞。是佛优婆塞。何等佛。释迦牟尼佛。何所勋是优婆塞。谓法。何等法。离欲。何等离欲灭尽。何等灭尽。涅槃。齐几名为优婆塞。若人诸根男相具足。心无错乱。不为苦所逼。欲作优婆塞。向尊上心。向彼为主依于舍彼喜乐彼法轮未转。未有众僧。口受二教。归依佛。归依法。受此二语已。即名优婆塞。如偈说

  离垢烦恼使　　证第一常寂
  降伏称无量　　为彼提谓说
  归佛及归法　　离垢无上宝
  未有第三宝　　教令依二宝
  非为欲损彼　　大仙无所吝
  此法义应尔　　大仙不毁僧

法轮既转。便有圣众。即说三语。口受三教。归依佛。归依法。归依僧。受此三语已。即名优婆塞。如佛说

  归依处众多　　山岩及树木
  园林及神寺　　斯由苦所逼
  此归非安隐　　此归非为上
  非归依此处　　能离一切苦
  若归佛法僧　　正观四真谛
  苦由于集生　　能灭于苦集
  八正安隐道　　必至甘露处
  此归最为安　　此归最为上
  归依于此处　　能离一切苦

问曰。优婆塞几戒。答曰五。何等五尽寿不杀生。是优婆塞戒。尽寿不盗。是优婆塞戒。尽寿不邪淫。是优婆塞戒。尽寿不妄语。是优婆塞戒。尽寿不饮酒。是优婆塞戒。如是优婆塞五戒。尽寿受持。不得违犯。齐几为持戒优婆塞。若优婆塞。于此五戒中。常持戒护行近行。不缺行。不乱行。不浊行。不杂行。随顺戒行。齐是名持戒优婆塞。如偈说

  智人能持戒　　悕望于三乐
  尊重得利益　　终受天上乐
  见如是等处　　智者能离恶
  利根持净戒　　常得第一乐

云何杀生若生众生想。故断众生命。死时未到。到时未死。教令杀害断命勿令活。彼语闻已过彼时已灭彼生已仆地。如此身业口业。是众生故断众生命。当断不定断。彼是杀生业。若行彼业者。是名杀生人。云何不杀生优婆塞戒。若于彼业不乐。远离不作。护不犯。断根舍不善堪忍行善。名不杀生。是优婆塞戒。如佛说

  不杀亦不教　　亦不劝他杀
  诸定及惊怖　　及与大名称
  于一切众生　　尽舍诸刀杖

云何不与取。若有人不与取。若村中若山泽不与盗心取他物。若共他行若共相交劫取他物。想起盗心悕望爱护作己有。如是身业口业取去取来。离本家移处坏封帜出界彼业是不与取。若行彼业者。名不与取人。云何不盗是优婆塞戒。于彼业不乐。远离不作。护戒不犯。断根舍不善根。堪忍行善。是名不盗优婆塞戒。如佛说

  不盗亦不教　　不取不持去
  亦不劝他取　　离诸不与取

云何邪淫。若有邪行人。若有母护父护兄护弟护姊护妹护自护法护姓护亲里护信要护乃至花鬘护。若共如此宿。共行欲法。若自妻非道行。彼业是邪行。若行彼业者。是名邪行人。云何不邪淫是优婆塞戒。若于彼业不乐。远离不作。护戒不犯。断根舍不善。堪忍行善。是名不邪淫。是优婆塞戒。如佛说

  离淫不净行　　观欲如火坑
  虽未能离欲　　足不犯他妻

云何妄语。若有人妄语。若伴中众中亲里中贵人中国主前若人倩人为证。如所知说。彼人不知言知。知言不知。见言不见。不见言见。若自为为他。若为财于众中故作妄语。隐所忍隐所欲隐所觉隐所想隐心知。不见言见。见言不见。不闻言闻。闻言不闻。不觉言觉。觉言不觉。不识言识。识言不识。先欲妄语。语时知妄语。语竟知妄语。如是虚诳意以为财故。若集声音句言语口教是妄语业。若行彼业者是名妄语人。云何不妄语。是优婆塞戒。于彼业不乐。远离不作。护戒不犯。断根舍不善。堪忍行善。是名不妄语。是优婆塞戒。如佛说

  若伴若众中　　一一不妄语
  不说不劝教　　离一切虚妄

云何饮酒放逸处。若有饮酒放逸处。若酒醪酒甘蔗酒蒲桃酒蜜酒。及余物酒。若饮酒若爱乐酒。洒身乃至草叶一渧。彼业是饮酒放逸处。若行彼业者。是名饮酒放逸人。云何不饮酒不放逸。是优婆塞戒。若于彼业不乐。远离不作。护戒不犯断根舍不善根。堪忍行善。名不饮酒不放逸处。是优婆塞戒。如佛说

  圣言当离酒　　亦勿与他酒
  不饮不劝乐　　知此放逸处
  知此不善门　　憍骜愚者然
  知此处不善　　戒德自防护
  不杀亦不盗　　实语不饮酒
  不淫断欲法　　不夜非时食
  谦卑不高床　　息听止观乐
  不花鬘涂香　　如是名八斋
  随彼时持斋　　智人随食施
  饮食供养僧　　不放逸贪着
  供养于父母　　如法求财物
  以自修家业　　得生日光天

五戒。几色几非色。一切色。五戒。几可见。几不可见。一切不可见。五戒。几有对。几无对。一切无对。五戒。几圣。几非圣。一切非圣。五戒。几有漏。几无漏。一切有漏。一切有爱。一切有求。一切当取。一切有取。一切有胜。五戒几受。几非受。一切非受。一切外五戒。几有报。几无报。一切有报。五戒。几心。几非心。一切非心。五戒。几心相应。几非心相应。一切非心相应。五戒。几心数。几非心数。一切非心数。五戒。几缘。几非缘。一切非缘。五戒。几共心。几不共心。一切不共心。一切不随心转。五戒。几业。几非业。一切业。五戒。几业相应。几非业相应。一切非业相应。五戒。几共业。几非共业。一切不共业。一切不随业转。五戒。几因。几非因。一切因。五戒。几有因。几无因。一切有因。一切有绪。一切有缘。一切有为。五戒。几知。几非知。一切知如事知见。五戒。几识。几非识。一切识意识如事识。一切解。一切了。五戒。几断智知。几非断智知。一切非断智知。五戒。几修。几非修。一切修。五戒几证。几非证。一切证知见如事。五戒。几善。几不善。几无记。一切善。五戒。几学。几无学。几非学非无学。一切非学非无学。五戒。几报。几报法。几非报非报法。一切报法。五戒。几见断几思惟断。几非见断非思惟断。一切非见断非思惟断。五戒。几见断因。几思惟断因。几非见断非思惟断因。一切非见断非思惟断因。五戒。几欲界系。几色界系。几无色界系。几不系。一切欲界系。五戒几过去。几未来。几现在。几非过去非未来非现在。一切三分或过去或未来或现在。云何不杀戒过去。不杀戒生已灭名过去。云何不杀戒未来。不杀戒未生未出名未来。云何不杀戒现在。不杀戒生未灭名现在。乃至不饮酒不放逸戒亦如是

舍利弗阿毗昙论卷第六(问分第一十品竟)舍利弗阿毗昙论卷第七

        姚秦罽宾三藏昙摩耶舍共昙摩崛多等译

    非问分界品第一

色界。非色界。可见界。不可见界。有对界。无对界。圣界。非圣界。有漏界。无漏界。有爱界。无爱界。有求界。无求界。当取界。非当取界。有取界。无取界。有胜界。无胜界。有受界。非受界。内界。外界。有报界。无报界。心界。非心界。心相应界。非心相应界。心数界。非心数界。缘界。非缘界。共心界。非共心界。随心转界。不随心转界。业界。非业界。业报界。非业报界。业相应界。非业相应界。非业相应非非业相应界。共业界。不共业界。随业转界。非随业转界。因界。非因界。有因界。无因界。有绪界。无绪界。有缘界。无缘界。有为界。无为界。智界。非智界。识界。非识界。解界。非解界。了界。非了界。断智知界。非断智知界。断界。非断界。修界。非修界。证界。非证界。有余涅槃界。无余涅槃界。善界。不善界。无记界。学界。无学界。非学非无学界。报界。报法界。非报非报法界。见断界。思惟断界。非见断非思惟断界。见断因界。思惟断因界。非见断非思惟断因界。卑界。中界胜界。粗界。细界。微界。发界。出界。度界。勤界。持界。出界。断界。离欲界。灭界。欲界。色界。无色界。色界。非色界。灭界。三出界。过去界。未来界。现在界。非过去非未来非现在界。过去境界界。未来境界界。现在境界界。非过去非未来非现在境界界。欲界系界。色界系界。无色界系界。不系界。色界。受界。想界。行界。识界。五出界。六出界。地界。水界。火界。风界。空界。识界。乐界。苦界。喜界。忧界。舍界。无明界欲界。恚界。害界。出界。不恚界。不害界。光界。净界。色界。空处界。识处界不用处界。非想非非想处界。十八界

云何色界法。若色是名色界。云何非色界法。非色是名非色界。云何可见界。色入是名可见界。云何不可见界。除色入余法。是名不可见界

云何有对界。十色入是名有对界。云何无对界。意入法入。是名无对界

云何圣界。若法无漏。是名圣界。云何非圣界。若法有漏。是名非圣界

云何有漏界。若法有爱。是名有漏界。云何无漏界。若法无爱。是名无漏界

云何有爱界。若法有求。是名有爱界。云何无爱界。若法无求。是名无爱界

云何有求界。若法当取。是名有求界。云何无求界。若法非当取。是名无求界

云何当取界。若法有取。是名当取界。云何非当取界。若法无取。是名非当取界

云何有取界。若法有胜。是名有取界。云何无取界。若法无胜。是名无取界

云何有胜界。若法有取。是名有胜界。云何无胜界。若法无取。是名无胜界。云何有胜界。若法界有余界胜妙过上。是名有胜界。云何无胜界。若法界无余界胜妙过上。是名无胜界

云何受界。若法内。是名受界。云何非受界。若法外。是名非受界

云何内界。若法受。是名内界。云何外界。若法非受。是名外界

云何有报界。若法报法。是名有报界。云何无报界。若法报若非报非报法。是名无报界

云何心界。意入是名心界。云何非心界。除意入余法。是名非心界

云何心相应界。若法心数。是名心相应界。云何非心相应界。若法非心数。是名非心相应界

云何心数界。除心余缘法。是名心数界。云何非心数界。若法非缘及心。是名非心数界

云何缘界。若法取相及心。是名缘界。云何非缘界。除心余非心数法。是名非缘界

云何共心界。若法随心转共心生共住共灭。是名共心界。云何非共心界。若法不随心转不共心生不共住不共灭。是名不共心界

云何随心转界。若法共心生共住共灭。是名随心转界。云何不随心转界。若法不共心生不共住不共灭。是名不随心转界

云何业界。身业口业意业。是名业界。云何非业界。除身业口业意业余法。是名非业界云何业报界。若法爱若法善报。是名业报界。云何非业报界。若法报若非报非报法。是名非业报界

云何业相应界。若法界思相应。是名业相应界。云何非业相应界。若法非思相应。是名非业相应界。云何非业相应非非业相应界。思是名非业相应非非业相应界

云何共业界。若法随业转共业生共住共灭。是名共业界。云何不共业界。若法不随业转不共业生不共住不共灭。是名不共业界

云何随业转界。若法共业生共住共灭。是名随业转界。云何不随业转界。若法不共业生不共住不共灭。是名不随业转界

云何因界。若法缘。若法非缘有报。若法非缘。除得果余善报及四大。是名因界。云何非因界。若法非缘无报不共业得果。是名非因界

云何有因界。若法有绪。是名有因界。云何无因界。若法无绪。是名无因界

云何有绪界。若法有缘。是名有绪界。云何无绪界。若法无缘。是名无绪界

云何有缘界。若法有为。是名有缘界。云何无缘界。若法无为。是名无缘界

云何有为界。若法有缘。是名有为界。云何无为界。若法无缘。是名无为界

云何知界。一切法知如事知见。是名知界。云何非知界。无非知界。复次说。一切法非知如事知见是名非知界

云何识界。一切法识意识如事识。是名识界。云何非识界。无非识界。复次说。一切法非识意识如事识。是名非识界

云何解界。一切法解如事知见。是名解界。云何非解界。无非解界。复次说。一切法非解如事知见。是名非解界

云何了界。一切法了如事知见。是名了界。云何非了界。无非了界。复次说。一切法非了如事知见。是名非了界

云何断智知界。若法不善。是名断智知界。云何非断智知界。若法善若无记。是名非断智知界

云何断界。若法不善。是名断界。云何非断界。若法善若无记。是名非断界

云何修界。若法善。是名修界。云何非修界。若法不善无记。是名非修界

云何证界。一切法证如事知见。是名证界。云何非证界。无非证界。复次说。一切法非证如事知见。是名非证界

云何有余涅槃界。如世尊说。云何彼是二涅槃界。何等二有余涅槃界无余涅槃界。云何有余涅槃。谓此比丘阿罗汉。诸漏尽。所作竟。舍于重担。逮得己利。是尽有烦恼正智。得解诸阴界入。以宿业缘住故。以心受诸苦乐。有适意不适意是名有余涅槃界。云何无余涅槃界。谓比丘五阴灭。未来五阴不复续生。是名无余涅槃界

云何善界。若法修是名善界。云何不善界。若法断是名不善界。云何无记界。若法受若法非报非报法。是名无记界

云何学界。若法圣非无学。是名学界。云何无学界。若法圣非学。是名无学界。云何非学非无学界。若法非圣。是名非学非无学界

云何报界。若法受若法善报。是名报界。云何报法界。若法有报。是名报法界。云何非报非报法界。若法无记非我分摄。是名非报非报法界

云何见断界。若法不善非思惟断。是名见断界。云何思惟断界。若法不善非见断。是名思惟断界云何非见断非思惟断界。若法善无记。是名非见断非思惟断界

云何见断因界。若法见断法报。是名见断因界。云何思惟断因界。若法思惟断。若法思惟断法报。是名思惟断因界。云何非见断非思惟断因界。若法善若法善法报。若法报非报非报法。是名非见断非思惟断因界

云何卑界。若法不善。是名卑界。云何中界。若法无记。是名中界。云何胜界。若法善是名胜界。云何卑界。若法不善若无记。是名卑界。云何中界。若法非圣善。是名中界。云何胜界。若法圣无漏。是名胜界

云何粗界。若法欲界系色界系。是名粗界。云何细界。若法空处系识处系不用处系若不系。是名细界。云何微界。若法非想非非想处系。是名微界。复次粗界。若法欲界系。若色界系。若空处系。若识处系。若不用处系。是名粗界。复次细界。若法不系。是名细界。云何微界。若法非想非非想处系。是名微界

云何发界。进若发正发生起触证。是名发界。云何出界。进若广进未度。是名出界。云何度界。进若广已度。是名度界云何勤界。力勤界。是名勤界。云何持界。总持持界。是名持界。云何出界。出出界。是名出界。复次勤界。谓勤精进。何等精进。若身心发出度。用心不退转。勤力正进。是名勤界。复次持界。谓念。何等念。如所闻所习法。持彼法。正持令住。不忘想念念续。是名持界。复次出界。舍一切漏尽爱灭涅槃。是名出界。云何断界。若比丘。树间空处。如是观身行恶恶报今世报后世报舍身恶行修身善行。如是观口意行恶恶报今世报后世报舍口意恶行修口意善行。是名断界。云何离欲界。爱尽离欲涅槃。是名离欲界。云何灭界。爱尽离灭涅槃。是名灭界

云何欲界。从阿鼻大地狱。上至他化自在天。若色受想行识分。是名欲界。云何色界。从梵天至阿迦尼吒天。若色受想行识分。是名色界。云何无色界。从空处天至非想非非想处天。若受想行识分。是名无色界

云何色界。若法色。是名色界。云何非色界。除二灭余非色法界。是名非色界

云何灭界。二灭智缘灭非智缘灭。是名灭界。云何三出界。如世尊说。三出界。何等三出界。谓出欲至色。出色至无色。若所作所集灭。是谓出。何谓出欲至色。若缘欲生有漏燋热彼色中无。是谓出欲至色。何谓出色至无色。若缘色生有漏燋热彼无色中无。是谓出色至无色。何谓所作所集灭。若缘行生有漏燋热彼涅槃无。是谓所作所集灭。是谓出。是名三出界

云何过去界。若法生已灭。是名过去界。云何未来界。若法未生未出。是名未来界。云何现在界。若法未灭。是名现在界。云何非过去非未来非现在界。若法无为。是名非过去非未来非现在界

云何过去境界界。思惟过去。若法生。是名过去境界界。云何未来境界界。思惟未来。若法未生。是名未来境界界。云何现在境界界。思惟现在法。若法生。是名现在境界界。云何非过去非未来非现在境界界。思惟非过去非未来非现在。若法生。是名非过去非未来非现在境界界

云何欲界系界。若法欲漏有漏。是名欲界系界。云何色界系界。若法色漏有漏。是名色界系界。云何无色界系界。若法无色漏有漏。是名无色界系界。云何不系界。若法界圣无漏。是名不系界

云何色界。色阴是名色界。云何受界。受阴是名受界。云何想界。想阴是名想界。云何行界。行阴是名行界。云何识界。识阴是名识界

云何五出界。如世尊说五出界。何等五。谓比丘念欲时。心不向欲不清。不住不解。念出心出。心向清住解。心善至善调善修心。若于欲出解起。缘欲生有漏燋热出解离。不受是痛。是名出欲界。复次比丘念嗔恚时。心不向嗔恚不清。不住不解。念不嗔心不恚。心向清住解。心善至善调善修心。若于嗔恚出解起。缘嗔恚生有漏燋热。出解离不受是痛。是名出嗔恚界。复次比丘念害念害时。心不向害不清。不住不解。念不害不害心。向清住解。心善至善调善修心。若于害出解起。缘害生有漏燋热。彼出解离。不受是痛。是名出害界。复次比丘念色时。心不向色不清。不住不解。念无色无色。心向清住解。心善至善调善修心。于色出解起。缘色生有漏燋热。出解离。不受是痛。是名出色界。复次比丘念自身。心不向自身不清。不住不解。念自身灭。灭自身心向清住解。心善至善调善修心。若于自身出解起。缘自身生有漏燋热。出解离。不受是痛。是名出自身界。是名五出界

云何六出界。如世尊说六出界。如比丘向彼比丘如是说。比丘我慈解心亲近多修学。作乘作物。谨慎识善进。我为嗔恚心所覆。彼比丘责此比丘。比丘莫如是说。莫谤世尊。谤世尊不善。世尊不如是说。比丘此非悕望处。若慈解心亲近多修学已。作乘作物已。谨慎已。识已。善进已。若嗔恚覆心者。无有是处。世尊说。比丘出嗔恚心。善慈解心若修多学无量。复次比丘向彼比丘如是说。比丘我悲解心亲近多修学。作乘作物。谨慎识善进。我故为害心所覆。彼比丘责此比丘。比丘莫如是说。莫谤世尊。谤世尊非善。世尊不如是说。比丘此非悕望处。若悲解心亲近多修学已。作乘作物已。谨慎已。识已。善进已。为害覆心者。无有是处。世尊说。比丘出害心。若悲解心。若修多学无量。复次比丘向彼比丘如是说。我喜解心亲近多修学。作乘作物。谨慎识善进。我故为不乐心所覆。彼比丘责此比丘。比丘莫如是说。莫谤世尊。谤世尊非善。世尊不如是说。比丘此非悕望处。若喜解心亲近已。多修学已。作乘作物已。谨慎已。识已。善进已。为不乐心所覆。无有是处。世尊说。比丘出不乐心。若喜解心善修多学无量。复次比丘向彼比丘如是说。我舍解心亲近多修学。作乘作物。谨慎识善进。我故为爱恚心所覆。彼比丘责此比丘。莫如是说。莫谤世尊。谤世尊非善。世尊不如是说。比丘此非悕望处。若舍解心亲近已。多修多学已。作乘作物已。谨慎已。识已。善进已。若有爱恚覆心。无有是处。世尊说。比丘出爱恚心。若舍解心善修多学无量。复次比丘向彼如是说。我无想定心亲近多修学。作乘作物。谨慎识善进。我故有念想识。彼比丘责此比丘。比丘莫如是说。莫谤世尊。谤世尊非善。世尊不如是说。比丘此非悕望处。若无想定心亲近已。多修学已。作乘作物已。谨慎已。识已。善进已。若有念想识。无有是处。世尊说。比丘出一切想。若无想定心善修多学无量。复次比丘向彼比丘如是说。我灭我及我所故。有疑惑箭覆心。彼比丘责此比丘。比丘莫如是说。莫谤世尊。谤世尊非善。世尊不如是说。比丘此非悕望处。若灭我及我所故。如有疑惑箭覆心者。无有是处。世尊说。比丘出疑惑箭。若断我慢。是名六出界

云何地界。二地界。内地界外地界。云何内地界。若此身内受坚。骨齿发毛薄皮肤肌肉筋脉脾肾肝肺心胃大肠小肠大腹小腹。此身及余内受坚。是名内地界。云何外地界。若外非受坚。铜铁铅锡白镴金银真珠琉璃珂贝璧玉珊瑚钱性宝贝珠沙石草木枝叶茎节。及余外非受坚。是名外地界。如是内地界外地界。是名地界。云何水界。二水界。内水界外水界。云何内水界。若此身内受。水涎癊胆汗肪髓脑脂[腊*ㄆ]涕唾脓血小便。及余此身内受水润等。是名内水界。云何外水界。若外水界非受。苏油蜜石。蜜黑石蜜乳酪酪浆醪酒甘蔗酒蜜酒。及余外水非受。是名外水界。如是内外水界是名水界。云何火界。二火界。内火界。外火界。云何内火界。若此身内受火热。若热能令热令身热令内燋。若服食饮等消。及余此身内受火。是名内火界。云何外火界。若外火非受热。若火热日热珠热舍热墙热山热谷气热草热木热牛粪热。及余外火热非受。是名外火界。如是内火界外火界。是名火界。云何风界。二风界。内风界。外风界。云何内风界。若此身内受风。上风下风。依节间风挛躄风骨节游风出息入息风。及余内受风。是名内风界。云何外风界。若外风非受。若东西风南北风杂尘风不杂尘风冷风热风黑风毗岚风动地风。及余外风非受。是名外风界。如是内风外风。是名风界。云何空界。二空界。内空界外空界。云何内空界。若此身内受空。非四大所覆。若耳鼻孔口门。若食饮所由处。若食饮住处。若食饮出处。及余此身内受空。非四大所覆。是名内空界云何外空界。若外空非受。非四大所覆。若丘井瓶瓮坎谷。及余外空非受。非四大所覆。是名外空界。如是内空界外空界。是名空界

云何识界。六识身。眼识身耳鼻舌身意识身。是名识界

云何乐界。眼触乐受耳鼻舌身触乐受乐根。是名乐界。云何苦界。眼触苦受耳鼻舌身触苦受苦根。是名苦界。云何喜界。若心乐受喜根。是名喜界。云何忧界。若心苦受忧根。是名忧界。云何舍界。身心非苦非乐受。谓眼触非苦非乐受。耳鼻舌身触非苦非乐受舍根。是名舍界

云何无明界。痴不善根。是名无明界。云何欲界。欲欲界。是名欲界。云何恚界。恚恚界。是名恚界。云何害界。害害界。是名害界。云何欲界。若欲欲欲腻。欲爱欲喜。欲支欲定。欲肯欲渴。欲燋欲网。是名欲界。云何恚界。若欺恼众生。侵陵悕望。非断命根。是名恚界。云何害界。若欺害众生。悕望侵陵断命根。是名害界。云何欲界。五欲爱喜适意爱色欲染相续。眼识色爱喜适意爱色欲染相续。耳鼻舌身识触爱喜适意爱色欲染相续。若他欲他封邑他妇女他物令我得。若贪重贪究竟贪相应悕望爱欲染重欲染究竟欲染。及余可贪法。若贪重贪究竟贪悕望爱欲染重欲染究竟欲染。是名欲界。云何恚界。若少众生。若多众生。伤害此众生。系缚令得种种苦。若恚重恚究竟恚相应忿怒憎恶恼心佷戾不慈不愍不利益。是名恚界。云何害界。若恼众生。以手拳瓦石刀仗。及余诸恼。如是欺害众生侵恼悕望断命。是名害界

云何出界。除慈悲余善出法。是名出界。云何不恚界。慈是名不恚界。云何不害界。悲是名不害界

云何光界。色光。慧光。云何色光。火光。日光。月光。珠光星宿光。佛光众生光。及余四大所造光明照明。是名色光。云何慧光。三慧思慧闻慧修慧。是名慧光。如是色光慧光。是名光界。云何净界。净解脱及余净色。能净色适意见无厌。是名净界

云何色界。色入色阴。是名色界

云何空处界。二空处界。或有为空处界。或无为空处界。云何有为空处界。空处定空处生。云何空处定。若比丘。离一切色想。灭嗔恚想不思惟若干想。成就无边空处。云何空处生。若亲近此定多修学故。空处天四种我分摄受想行识。是名空处生。如是空处定。如是空处生。是名有为空处界。云何无为空处界。若以智断。空处界若断。是名空处。无为识处界不用处界非想非非想处界亦如是

云何十八界。眼界色界眼识界。耳界声界耳识界。鼻界香界鼻识界。舌界味界舌识界。身界触界身识界。意界法界意识界。是名十八界

    舍利弗阿毗昙论非问分业品第二

思业。思已业。故作业。非故作业。受业。非受业。少受业。多受业。熟业。非熟业。色业。非色业。可见业。不可见业。有对业。无对业。圣业。非圣业。有漏业。无漏业。有爱业。无爱业。有求业。无求业。当取业。非当取业。有取业。无取业。有胜业。无胜业。受业。非受业。内业。外业。有报业。无报业。心相应业。非心相应业。心数业。非心数业。缘业。非缘业。共心业。不共心业。随心转业。不随心转业。非业。相应业。非业。相应非非业。相应业。共业。非共业。随业。转业。不随业。转业。因业。非因业。有因业。有绪业。有缘业。有为业。知业。非知业。识业。非识业。解业。非解业。了业。非了业。断智知业。非断智知业。断业。非断业。修业。非修业。证业。非证业。教业。非教业。身有教无教业。口有教无教业。身业。口业。意业。戒业。无戒业。非戒非无戒业。身戒无戒非戒非无戒业。口戒无戒非戒非无戒业。意戒无戒非戒非无戒业。善业。不善业。无记业。学业。无学业。非学非无学业。报业。报法业。非报非报法业。见断业。思惟断业。非见断非思惟断业。见断因业。思惟断因业。非见断非思惟断因业。卑业。中业。胜业。粗业。细业。微业。乐受业。苦受业。舍受业。乐受业。苦受业。非苦非乐受业。喜处业。忧处业。舍处业。喜处业。忧处业。非喜非忧处业。现法受业。生受业。后受业。与乐业。与苦业。与不苦不乐业。乐果业。苦果业。不苦不乐果业。乐报业。苦报业。不苦不乐报业。过去业。未来业。现在业。过去境界业。未来境界业。现在境界业。非过去非未来非现在境界业。欲界系业。色界系业。无色界系业。不系业。四业。四受业。五怖五怨五无间业。五戒越五戒因贪业。因恚业。因痴业。因不贪业。因不恚业。因不痴业。趣地狱业。趣畜生业。趣饿鬼业。趣人业。趣天业。趣涅槃业。七不善法。七善法。八圣语。非八圣语。因贪身业。口业。意业。因恚身业。口业意业。因痴身业。口业。意业。因不贪身业。口业。意业。因不恚身业。口业。意业。因不痴身业。口业。意业。十不善业道。十善业道。十法成就堕地狱速若[矛*(替-曰+貝)]矛。十法成就生天速如[矛*(替-曰+貝)]矛。二十法成就堕地狱速如[矛*(替-曰+貝)]矛。二十法成就生天速如[矛*(替-曰+貝)]矛。三十法成就堕地狱速如。[矛*(替-曰+貝)]矛。三十法成就生天速如[矛*(替-曰+貝)]矛。四十法成就堕地狱速如[矛*(替-曰+貝)]矛。四十法成就生天速如[矛*(替-曰+貝)]矛

云何思业。意业是名思业。云何思已业。身业口业。是名思已业

云何故作业。若业故作受报。是名故作业。云何不故作业。若业不作不受报。是名不故作业

云何受业。若业有报。是名受业。云何非受业。若业无报。是名非受业。复次受业。若业有报。及无报思。是名受业。复次非受业。若业无报身业口业。是名非受业

云何少受业。若业受少报。是名少受业。云何多受业。若业不受少报。是名多受业

云何熟业。若业近受报。是名熟业。云何非熟业。若业非近受报。是名非熟业

云何色业。身业口业。是名色业。云何非色业。意业是名非色业

云何可见业。若业色入摄。是名可见业。云何不可见业。若业法入摄。是名不可见业

云何有对业。若业声入色入摄。是名有对业。云何无对业。若业法入摄。是名无对业

云何圣业。若业无漏。是名圣业。云何非圣业。若业有漏。是名非圣业

云何有漏业。若业有爱。是名有漏业。云何无漏业。若业无爱。是名无漏业

云何有爱业。若业有求。是名有爱业。云何无爱业。若业无求。是名无爱业

云何有求业。若业当取。是名有求业。云何无求业。若业非当取。是名无求业

云何当取业。若业有取。是名当取业。云何非当取业。若业无取。是名非当取业云何有取业。若业有胜。是名有取业。云何无取业。若业无胜。是名无取业

云何有胜业。若业有取。是名有胜业。云何无胜业。若业无取。是名无胜业。复次有胜业。若此业有余业胜妙过上。是名有胜业。复次无胜业。若此业无余业胜妙过上。是名无胜业

云何受业。若业内。是名受业。云何非受业。若业外。是名非受业

云何内业。若业受。是名内业。云何外业。若业非受。是名外业云何有报业。若业有报。是名有报业。云何无报业。若业非报。是名无报业

云何心相应业。若业心数。是名心相应业

云何非心相应业。若业非心数。是名非心相应业

云何心数业。若业缘。是名心数业。云何非心数业。若业非缘。是名非心数业

云何缘业。若业心数。是名缘业。云何非缘业。若业非心数。是名非缘业

云何共心业。若业随心转共心生共住共灭。是名共心业。云何非共心业。若业不共心转不共心生不共住不共灭。是名不共心业

云何随心转业。若业共心生共住共灭。是名随心转业。云何不随心转业。若业不共心生不共住不共灭。是名不随心转业

云何非业相应业。若业非思相应。是名非业相应业云何非业相应非非业相应业。思是名非业相应非非业相应业

云何共业。若业随业转共业生共住共灭。是名共业云何不共业。若业不随业转不共业生不共住不共灭。是名不共业

云何随业转业。若业共业生共住共灭。是名随业转业。云何不随业转业。不共业生不共住不共灭。是名不随业转业。云何因业若业缘业若业非缘善有。是名因业。云何非因业。若业非缘无报报不共业。是名非因业

云何有因业。若业有绪。是名有因业

云何有绪业。若业有缘转业若业共业。是名有绪业

云何有缘业。若业有为。是名有缘业

云何有为业。业若有缘。是名有为业

云何知业。一切业知如事知见。是名知业云何非知业。无非知业。复次说一切业非知如事知见。是名非知业

云何识业。一切业识意识如事识。是名识业。云何非识业。无非识业。复次说一切业非识意识如事识。是名非识业

云何解业。如事知见。是名解业。云何非解业。无非解业。复次说一切业非解如事知见。是名非解业

云何了业。一切业了如事知见。是名了业。云何非了业。无非了业

云何断智知业。业若不善。是名断智知业。云何非断智知业。若业善若无记。是名非断智知业

云何断业。若业不善。是名断业。云何非断业。若业善若无记。是名非断业

云何修业。若业善。是名修业。云何不修业。若业不善无记。是名非修业

云何证业。一切业证如事知见。是名证业。云何非证业。无非证业。复次说一切业非证如事知见。是名非证业

云何教业。身业口业。是名教业。云何无教业。意业是名无教业。云何身教业。若身业色入摄。是名身教业。云何身无教业。若身业法入摄。是名身无教业云何口教业。若口业声入摄。是名口教业。云何口无教业。若口业法入摄。是名口无教业。云何身业。若业非缘非口业。是名身业。云何口业。若业非缘。非身业。是名口业。云何意业。若业缘。是名意业云何戒业。若业善心所起去来屈申回转身教集声音句言语口教有漏身口戒无教正语正业正命及善思。是名戒业。云何无戒业。若业不善不善心所起去来屈申回转身教集声音句言语口教身口作非戒无教及不善思。是名无戒业。云何非戒非无戒业。若业无记心所起去来屈申回转身教集声音句言语口教及无记思。是名非戒非无戒业。云何身戒业。若身业善善心所起去来屈申回转身教有漏身戒无教正业身正命。是名身戒业。云何身无戒业。若身业不善不善心所起去来屈申回转身教身非戒无教。是名身无戒业。云何身非戒非无戒业。若身业无记无记心所起去来屈申回转身教。是名身非戒非无戒业。云何口戒业。若口业善善心所起集声音句言语口教有漏口戒无教正语口正命。是名口戒业

云何口无戒业。若口业不善不善心所起集声音句言语口教口非戒无教。是名口无戒业。云何口非戒非无戒业。若口业无记无记心所起集声音句言语口教。是名口非戒非无戒业。云何意戒业。若意业善善心相应思。是名意戒业。云何意无戒业。若意业不善不善心相应思。是名意无戒业。云何意非戒非无戒业。若意业无记无记心相应思。是名意非戒非无戒业

云何善业。若业修。是名善业。云何不善业。若业断。是名不善业。云何无记业。若受若业非报非报法。是名无记业

云何学业。若业圣非无学。是名学业。云何无学业。若业圣非学。是名无学业。云何非学非无学业。若业非圣。是名非学非无学业

云何报业。若业受若业善报。是名报业。云何报法业。若业有报。是名报法业。云何非报非报法业。若业无记非我分摄。是名非报非报法业。云何见断业。若业不善非思惟断。是名见断业。云何思惟断业。若业不善非见断。是名思惟断业。云何非见断非思惟断业。若业善无记。是名非见断非思惟断业。云何见断因业。若业见断。若见断法报。是名见断因业。云何思惟断因业。若业思惟断。若思惟断法报。是名思惟断因业。云何非见断因非思惟断因业。若业善若业善法报。若业报非报非报法。是名非见断因非思惟断因业。云何卑业。若业不善。是名卑业。云何中业。若业无记。是名中业。云何胜业。若业善。是名胜业。复次卑业。若业不善无记。是名卑业。复次中业。若业非圣善。是名中业。复次胜业。若业圣无漏。是名胜业

云何粗业。若业欲界系。是名粗业。云何细业。若业色界系不系。是名细业。云何微业。若业无色界系。是名微业。复次粗业。若业欲界系色界系。是名粗业。复次细业。若业空处系识处系不用处系若不系。是名细业。复次微业。若业非想非非想处系。是名微业。复次粗业。若业欲界系色界系空处系识处系不用处系。是名粗业。复次细业。若业不系。是名细业。复次微业。若业非想非非想处系。是名微业。云何受乐业。若业乐受相应。是名受乐业。云何受苦业。若业苦受相应。是名受苦业

云何受舍业。若业不苦不乐受相应。是名受舍业

云何乐受业。若业受乐报。是名乐受业。云何苦受业。若业受苦报。是名苦受业。云何舍受业。若业受不苦不乐报。是名舍受业

云何乐受业。除苦受不苦不乐受业余业。若善有报。是名乐受业。云何苦受业。若业不善。是名苦受业。云何非苦非乐受业。除乐受苦受业若余业。是名非苦非乐受业

云何喜处业。若业发已生喜。是名喜处业。云何忧处业。若业发已生忧。是名忧处业。云何舍处业。若业发已出舍。是名舍处业。复次喜处业。除舍处业余处业。若善有报。是名喜处业。复次忧处业。若业不善。是名忧处业。复次舍处业。除喜处业余业。若善有报。是名舍处业。复次喜处业。若业善有报。是名喜处业。复次忧处业。若业不善有报。是名忧处业。复次非喜处非忧处业。除喜处忧处业。若余业是名非喜处非忧处业

云何现法受业。若业生我分。若长幼所作。成就此业。于此生我长幼身受报。是名现法受业

云何生受业。若业生我分。长幼所作。成就此业。生受报。是名生受业。云何后受业。若业生我分。若长幼所作。成就此业。第三第四生受报或多。是名后受业

云何与乐业。若业与乐果。是名与乐业。云何与苦业。若业与苦果。是名与苦业。云何非与乐非与苦业。除与乐与苦业若余业。是名非与乐与苦业

云何乐果业。若业善有乐报。是名乐果业。云何苦果业。若业不善。是名苦果业。云何非乐果非苦果业。除乐果苦果业若余业。是名非乐果非苦果业

云何乐报业。若业乐果。是名乐报业。云何苦报业。若业苦果。是名苦报业。云何非乐非苦报业。除乐报苦报业若余业。是名非乐报非苦报业。云何乐报业。若业善有报。是名乐报业。云何苦报业。若业不善。是名苦报业。云何非乐非苦报业。除乐报苦报业若余业。是名非乐非苦报业

云何过去业。若业生已灭。是名过去业。云何未来业。若业未生未出。是名未来业。云何现在业。若业生未灭。是名现在业

云何过去境界业。思惟过去法若业生。是名过去境界业。云何未来境界业。思惟未来法若业生。是名未来境界业。云何现在境界业。思惟现在法若业生。是名现在境界业。云何非过去非未来非现在境界业。思惟非过去非未来非现在法若业生。是名非过去非未来非现在境界业

云何欲界系业。若业欲漏有漏。是名欲界系业。云何色界系业。若业色漏有漏。是名色界系业。云何无色界系业。若业无色漏有漏。是名无色界系业。云何不系业。若业圣无漏。是名不系业

云何四业。黑业黑报。白业白报。黑白业黑白报。非黑非白业非黑非白报。云何黑业黑报。若业不善有报。是名黑业黑报。云何白业白报。若业善有报。是名白业白报。云何黑白业黑白报。无一业若黑白黑白报。彼若黑业黑报。若白业白报。是名黑白业黑白报。云何非黑非白业非黑非白报。若圣有报断烦恼。是名非黑非白业非黑非白报。云何黑业黑报。若业不善有报。此业报是名黑业黑报。云何白业白报。若业善有报此业报。是名白业白报。云何黑白业黑白报。无一业黑白黑白报。彼若黑业黑报此业报。若白业白报此业报。是名黑白业黑白报。云何非黑非白业非黑非白报。若法圣有报断烦恼。是名非黑白业非黑白报。云何黑业黑报。如世尊说。我自正知说四业。何等四。黑业黑报。白业白报。黑白业黑白报。非黑非白业非黑非白报业能尽业。云何黑业黑报。若人作不清净身行。作不清净口行。作不清净意行。成就不清净业。彼行不清净身口意行。已成就不清净业。已生不清净处。彼生不清净处已。触不清净触。触不清净触已。受不清净受。一向苦切。一向受苦燋。一向不善。一向不爱喜适意。一向所憎恶。非天人所悕望。如地狱众生。此众生往生。随所作业生。生已触触。我知众生由业与苦。是名黑业黑报。云何白业白报。若人作清净身行。作清净口行。作清净意行。成就清净业行清净身口意行已。成就清净业已。生清净处。生清净处已。触清净触。触清净触已。受清净受。一向乐爱喜适意。一向所不憎恶。天人所悕望。犹如遍净天众生。若众生往生。随所作业生。生已触触。我知众生由业与乐。是名白业白报。云何黑白业黑白报。若人行清净不清净身行。行清净不清净口行。行清净不清净意行。成就清净不清净业。彼行清净不清净身口意行已。成就清净不清净业已。生清净不清净处。生清净不清净处已。触清净不清净触。触清净不清净触已。受清净不清净受。杂受苦乐。如人如天。若众生往生。随所作业生。生已触触。我知众生由业与苦乐是名黑白业黑白报。云何非黑白业非黑白报业能尽业。若黑业黑报。若断思。若白业白报。若断思。若黑白业黑白报。若断思。是名非黑白业非黑白报业能尽业。是名四业

云何四受业。如世尊说四受业。何等四。有业现苦后有苦报。有业现乐后有苦报。有业现苦后有乐报。有业现乐后有乐报。云何受业现苦后有苦报。若人忍忧忍苦。杀生缘杀生故。以种种心受忧苦忍忧忍苦。窃盗邪淫妄言两舌恶口绮语贪欲嗔恚邪见缘邪见故。以种种心受忧苦。身坏命终堕恶道地狱。此受业现苦后有苦报。云何受业现乐后有苦报。若人忍喜忍乐。杀生缘杀生故。以种种心受喜乐忍喜忍乐。窃盗邪淫妄言两舌恶口绮语贪欲嗔恚邪见缘邪见故。以种种心受喜乐。身坏命终堕恶道地狱。此受业现乐后有苦报。云何受业现苦后有乐报。若人忍忧忍苦。不杀生缘不杀生故。以种种心受忧苦忍忧忍苦。不窃盗不邪淫不妄言不两舌不恶口不绮语不贪不欲不嗔恚正见缘正见故。以种种心受忧苦。身坏命终生善道天上。此受业现苦后有乐报。云何受业现乐后有乐报。若人忍喜忍乐。不杀生缘不杀生故。以种种心受喜乐忍喜忍乐。不窃盗不邪淫不妄言不两舌不恶口不绮语不贪欲不嗔恚正见缘正见故。以种种心受喜乐。身坏命终生善道天上。此受业现乐后有乐报。是名四受业

云何五怖。若杀生缘杀生故。今身生怖。后身生怖。窃盗邪淫妄语饮酒放逸处缘饮酒放逸处故。今身生怖。后身生怖。是名五怖

云何五怨。若杀生缘杀生故。今身生怨。后身生怨。窃盗邪淫妄言饮酒放逸处缘饮酒放逸处故今身生怨。后身生怨。是名五怨

云何五无间。害母无间。害父无间。害阿罗汉无间。坏僧无间。于如来身恶心出血无间。云何害母无间。若母母想故断命。是名害母无间。云何害父无间。若父父想故断命。是名害父无间。云何害阿罗汉无间。故断阿罗汉声闻命。是名害阿罗汉无间。云何坏僧无间。一面请四比丘。或多第二面请四比丘。或多行筹唱令。是名坏僧无间。云何于如来身恶心出血无间。若故于如来身恶心出血成就业。乃至伤如发端。是名于如来恶心出血无间。是名五无间

云何五戒。不杀生。不窃盗。不邪淫。不妄言。不饮酒。放逸处。是名五戒。云何越五戒。杀生窃盗邪淫妄言饮酒放逸处。是名越五戒

云何因贪业。业若贪因贪绪贪集贪缘身业口业意业。是名因贪业。云何因恚业。业若恚因恚绪恚集恚缘身业口意业。是名因恚业云何因痴业。业若痴因痴绪痴集痴缘身业口意业。是名痴因业云何不贪因业。若不贪因不贪绪不贪集不贪缘身业口业意业。是名不贪因业。云何不恚因业。若不恚因不恚绪不恚集不恚缘身业口业意业。是名不恚因业。云何不痴因业。若不痴因不痴绪不痴集不痴缘身业口业意业。是名不痴因业

云何趣地狱业。若业不善增。能令生地狱。是名趣地狱业。云何趣畜生业若业不善中能令生畜生。是名趣畜生业。云何趣饿鬼业。若业不善软。能令生饿鬼。是名向饿鬼业。云何趣人业。若业善不增。能令生人中。是名趣人业。云何趣天业。若业善增。能令生天上。是名趣天业。云何趣涅槃业。若业圣有报。能断烦恼。是名趣涅槃业

云何七不善法。杀生窃盗邪淫妄言两舌恶口绮语。是名七不善法。云何七善法。不杀生不窃盗不邪淫不妄言不两舌不恶口不绮语。是名七善法

云何八非圣语。不见言见。见言不见。不闻言闻。闻言不闻。不觉言觉。觉言不觉。不识言识。识言不识。是名八非圣语。云何八圣语。不见言不见。见言见。不闻言不闻。闻言闻。不觉言不觉。觉言觉。不识言不识。识言识。是名八圣语

云何因贪身业。若身业不善因贪不离贪贪覆心所起去来屈申回转身教身非戒无教。是名因贪身业云何因贪口业。若口业不善因贪不离贪贪覆心所起集声音句言语口业教口非戒无教。是名因贪口业。云何因贪意业。若意业不善因贪不离贪贪覆心相应思。是名因贪意业。云何因恚身业。若身业不善因恚不离恚恚覆心所起去来屈申回转身教身非戒无教。是名因恚身业。云何因恚口业。若口业不善因恚不离恚恚覆心所起集声音句言语口教口非戒无教。是名因恚口业。云何因恚意业。若意业不善因恚不离恚恚覆心相应思。是名因恚意业。云何因痴身业。若身业不善因痴不离痴痴覆心所起去来屈申回转身教身非戒无教。是名因痴身业。云何因痴口业。若口业不善因痴不离痴痴覆心所起集声音句言语口教口非戒无教。是名因痴口业。云何因痴意业。若意业不善因痴不离痴痴覆心相应思。是名因痴意业。云何因不贪身业。若身业善因不贪离贪非贪覆心所起去来屈申回转身教有漏身戒无教。是名因不贪身业

云何因不贪口业。若口业善因不贪离贪非贪覆心所起集声音句言语口教有漏口戒无教。是名因不贪口业。云何因不贪意业。若意业善因不贪离贪非贪覆心相应思。是名因不贪意业。云何因不恚身业。若身业善因不恚离恚非恚覆心所起去来屈申回转身教有漏身戒无教。是名因不恚身业。云何因不恚口业。若口业善因不恚离恚非恚覆心所起集声音句言语口教有漏口戒无教。是名因不恚口业。云何因不恚意业。若意业善因不恚离恚非恚覆心相应思。是名因不恚意业。云何因不痴身业。若身善业因不痴离痴非痴覆心所起去来屈申回转身教有漏身戒无教正业身正命。是名因不痴身业云何因不痴口业。若口业善因不痴离痴非痴覆心所起集声音句言语口教有漏口戒无教正语口正命。是名因不痴口业。云何因不痴意业。若意业善因不痴离痴非痴覆心相应思。是名因不痴意业

云何十不善业道。杀生窃盗邪淫妄语两舌恶口绮语贪欲嗔恚邪见是名十不善业道。云何十善业道。不杀生不窃盗不邪淫不妄言不两舌不恶口不绮语不贪欲不嗔恚正见行。是名十善业道

云何十法成就堕地狱速如[矛*(替-曰+貝)]矛杀生乃至邪见。十法成就堕地狱速如[矛*(替-曰+貝)]矛云何十法成就生善处速如[矛*(替-曰+貝)]矛。不杀生乃至正见行。是十成就生善处速如[矛*(替-曰+貝)]矛。云何二十法成就堕地狱速如[矛*(替-曰+貝)]矛。自杀生教他杀生。乃至自邪见。教他邪见。是名二十法成就堕地狱速如[矛*(替-曰+貝)]矛

云何二十法成就生善处速如[矛*(替-曰+貝)]矛。自不杀生。教他不杀生。乃至自正见。教他正见行。是二十法成就生善处速如[矛*(替-曰+貝)]矛

云何三十法成就堕地狱速如[矛*(替-曰+貝)]矛。自杀生教他杀生。赞叹杀生。乃至自邪见。教他邪见。赞叹邪见。是三十法成就堕地狱速如[矛*(替-曰+貝)]矛

云何三十法成就生善处速如[矛*(替-曰+貝)]矛。自不杀生教他不杀生。赞叹不杀生乃至自正见。教他正见。赞叹正见行。是名三十法成就生善处速如[矛*(替-曰+貝)]矛。云何四十法成就堕地狱速如[矛*(替-曰+貝)]矛。自杀生教他杀生。赞叹杀生。愿乐杀生乃至自邪见。教他邪见。赞叹邪见。愿乐邪见。是四十法成就堕地狱速如[矛*(替-曰+貝)]矛

云何四十法成就生善处速如[矛*(替-曰+貝)]矛。自不杀生。教他不杀生。赞叹不杀生。不愿乐杀生。乃至自正见。教他正见。赞叹正见。愿乐正见行。是四十法成就生善处速如[矛*(替-曰+貝)]矛(业品竟)

舍利弗阿毗昙论卷第七舍利弗阿毗昙论卷第八

        姚秦罽宾三藏昙摩耶舍共昙摩崛多等译

    非问分人品第三

凡夫人。非凡夫人。性人。声闻人。菩萨人。缘觉人。正觉人。趣须陀洹果证人。须陀洹人。趣斯陀含果证人。斯陀含人。趣阿那含果证人。阿那含人。趣阿罗汉果证人。阿罗汉人。自足人他足人。学人无学人。非学人非无学人。正定人邪定人不定人。盲人一眼人二眼人。慈行人悲行人。喜行人舍行人空行人。无相行人。无愿行人。不恼行人。胜入行人。一切入行人。修八解脱人。六通人。五此竟人。五彼竟人。一分解脱人。二分解脱人。慧解脱人。身证人。见得人。信解脱人。坚信人。坚法人。断五支人。六支成就人。一护人。四依人。灭异缘实人。求最胜人。不浊想人。除身行人。心善解脱人。慧善解脱人。共解脱人。非共解脱人。有退人。无退人。思有人。微护人。思不退不思退人。护不退不护退人。有缘射人。法不发起人。住劫人。首等人。度堑人。坏堑人。乘进人。无沾污人。惰慢人。云何凡夫人。若人未上正决定。是名凡夫人。云何非凡夫人。若人上正决定。是名非凡夫人。复次凡夫人。若人未得正决定。是名凡夫人。复次非凡夫人。若人得正决定。是名非凡夫人。复次凡夫人。若人未得圣。五根未曾得。是名凡夫人。复次非凡夫人。若人得圣五根曾得。是名非凡夫人

云何性人。若人次第住凡夫胜法。若法即灭。上正决定。是名性人。云何性人。若人成就性法。何等性法。若无常苦空无我。思惟涅槃寂灭不定心。未上正决定如实人。若受想思触思惟觉观。见慧解脱无痴顺信悦喜心进信欲不放逸念意识界意界若如实身戒口戒。是名性法。若人此法成就。是名性人

云何声闻人。若人从他闻。受他教请他说听他法。非自思非自觉非自观。上正决定。得须陀洹果斯陀含果阿那含果阿罗汉果。是名声闻人

云何菩萨人。若人三十二相成就。不从他闻。不受他教。不请他说。不听他法。自思自觉自观。于一切法知见无碍。当得自力自在豪尊胜贵自在。当得知见无上正觉。当成就如来十力四无所畏。成就大慈转于法轮。是名菩萨人。云何缘觉人。若人三十二相不成就彼不从他闻。不受他教。不请他说。不听他法。自思自觉自观。上正决定。得须陀洹果斯陀含果阿那含果阿罗汉果。于一切法非无碍知见。非得自在。非得由力自在。非豪尊胜贵自在。非知见无上最胜正觉。非成就如来十力四无所畏大慈转于法轮。是名缘觉人

云何缘觉人。若人三十二相不成就。亦不从他闻。不受他教。不请他说。不听他法。自思自觉自观。上正决定。得须陀洹果斯陀含果阿那含果阿罗汉果。于一切法心无碍知见心得自在心得由力自在心豪尊胜贵自在。非知见无上最胜正觉。非成就如来十力四无所畏大慈转于法轮。是名缘觉人

云何正觉人。若人三十二相成就。不从他闻。不受他教。不请他说。不听他法。自思自觉自观。于一切法。知见无碍得由力自在豪尊胜贵自在知见。无上最胜正觉成就。如来十力四无所畏成就。大慈成就。自在转于法轮。是名正觉人

云何趣须陀洹果证人。若人得证须陀洹果道。未得须陀洹果。未触未证。是名趣须陀洹果证人。云何须陀洹人。若人须陀洹果触证已于果住。未得上道趣斯陀含果是名须陀洹人。云何趣斯陀含果证人。若人得证斯陀含果道。未得斯陀含果触证。是名趣斯陀含果证人。云何斯陀含人。若人得斯陀含果触证已。于彼果住。未得上道趣阿那含果。是名斯陀含人。云何趣阿那含果证人。若人得证阿那含果道。未得阿那含果未触证。是名趣阿那含果证人。云何阿那含人。若人得阿那含果触证已于果住。未得上道趣阿罗汉果。是名阿那含人。云何趣阿罗汉果证人。若人得证阿罗汉果道。未得阿罗汉未触证。是名趣阿罗汉果证人。云何阿罗汉人若人得阿罗汉果道触证已。是名阿罗汉人。复次趣须陀洹果证人。坚信坚法。是名趣须陀洹果证人。云何须陀洹人。若人见断三烦恼身见疑戒取。以圣道一时俱断彼烦恼。于彼断住。未得上道思惟断欲爱嗔恚烦恼分断。是名须陀洹人。复次趣斯陀含果证人。若人见断三烦恼身见疑戒取。以圣道一时俱断彼烦恼已。得上道思惟断。欲爱嗔恚烦恼分断未断。是名趣斯陀含果证人。复次斯陀含人。若人见断三烦恼身见疑戒取。以圣道一时俱断已。思惟断欲爱嗔恚烦恼分断。以圣道一时俱断。于彼断住。未得上道余思惟断欲爱嗔恚无余断未断。是名斯陀含人。复次趣阿那含果证人。若人见断三烦恼身见疑戒取。以圣道一时俱断。思惟断欲爱嗔恚烦恼。圣道一时俱断。得上道余思惟断欲爱嗔恚无余断未断。是名趣阿那含果人。复次阿那含人。若五下分烦恼断身见疑戒取欲爱嗔恚。以圣道一时俱断。于彼断住。未得上道思惟断色行无色行烦恼无余断未断。是名阿那含人。复次趣阿罗汉果证人。若人五下分烦恼断。身见疑戒取欲爱嗔恚。以圣道一时俱断。得上道思惟断色行。无色行烦恼无余断未断。是名趣阿罗汉果证人。复次阿罗汉人。若人思惟断色行烦恼无色行烦恼无余断。是名阿罗汉人。复次阿罗汉人。若人一切烦恼断。是名阿罗汉人。一切烦恼尽阿罗汉果。若人得触证。是名阿罗汉人。云何自足人。如世尊说。世二人难得。何等二。自足他足。云何他足。若人施沙门婆罗门贪无厌人贫穷乞丐人。饮食车乘衣服香花涂香床褥卧具舍宅依止灯明。是名他足人。云何自足人。若比丘有漏尽。乃至所作已办更不还有。是名自足人。如是二人谁所说。如来性因曰

  称自足他足　　世间甚希有
  施者如清池　　常住净戒身
  又能施饮食　　是人甚难得
  离欲断嗔恚　　灭痴得无漏
  圣法以自足　　是人甚难得

云何学人。趣须陀洹果证人。须陀洹人。趣斯陀含果证人。斯陀含人。趣阿那含果证人。阿那含人。趣阿罗汉果证人。是名学人。云何无学人。阿罗汉。是名无学人。云何非学非无学人。凡夫人。是名非学非无学人

云何正定人。若人上正决定。是名正定人。云何邪定人。若人入邪定。是名邪定人。云何不定人。若人不上正决定。不入邪定。是名不定人。云何正定人。若人得正决定。是名正定人。云何邪定人。若人得邪定。是名邪定人。云何不定人。若人不得正决定。不得邪定。是名不定人。云何正定人。若人得圣五根已曾得。是名正定人。云何邪定人。若人作五无间业。成就已未受报。于五无间业成就。若一若二未受报。是名邪定人。云何不定人。若人未得圣五根未曾得。不作五无间业。不成就不受报。于五无间业不成就。若一若二不受报是名不定人

云何盲人。若人成就眼。未得财宝。能得得已弘广。无如是眼。若人成就眼。未生善法。能生生已弘广。无如是眼。是名盲人。云何一眼人。如人成就眼。未得财宝。能得得已弘广。有如是眼。如人成就眼。未生善法。能生生已弘广。无如是眼。是名一眼人。云何二眼人。若人成就眼。未得财宝。能得得已弘广。有如是眼。如人成就眼。未生善法。能生生已弘广。有如是眼。是名二眼人

云何慈行人。若人得慈解心。多行是行。是名慈行人。云何悲行人。若人得悲解心。多行是行。是名悲行人。云何喜行人。若人得喜解心。多行是行。是名喜行人。云何舍行人。若人得舍解心。多行是行。是名舍行人。复次慈行人。若人得慈解调心已。修行柔软已。次第上正决定。得须陀洹果斯陀含果阿那含果阿罗汉果。是名慈行人。复次悲行人。若人得悲解调心已。修行柔软已。次第上正决定。得须陀洹果斯陀含果阿那含果得阿罗汉果。是名悲行人。复次喜行人。若人得喜解调心已。修行柔软已。次第上正决定。得须陀洹果斯陀含果阿那含果阿罗汉果。是名喜行人。云何舍行人。若人得舍解调心已。修行柔软已。次第上正决定。得须陀洹果斯陀含果阿那含果阿罗汉果。是名舍行人

云何空行人。若人得空定多行是行。是名空行人。云何无相行人。若人得无相定。多行是行。是名无相行人。云何无愿行人。若人得无愿定。多行是行。是名无愿行人。复次空行人。若人得空行。上正决定。得须陀洹果斯陀含果阿那含果阿罗汉果。是名空行人。复次无相行人。若人得无相定上正决定。得须陀洹果斯陀含果阿那含果阿罗汉果。是名无相行人。云何无愿行人。若人得无愿定上正决定。得须陀洹果斯陀含果阿那含果阿罗汉果。是名无愿行人

云何无恼行人若人得无恼法。何等无恼法。谓若人知劝赞。知不劝赞。知劝赞不劝赞已。非劝赞非不劝赞。说法明了知法明了。知法已内乐精进。背不说恶。面不赞善。称满说法。非不称满。不必顾方语。不是非人礼。随方说法。复次修根力觉禅解脱定修已。得圣无漏舍。若舍则应法律。不行欲乐凡夫卑行。不行非圣无义苦行。常舍二边入应中道行。知劝赞知不劝赞。知劝赞非不劝赞已。不劝赞非不劝赞。说法明了知法明了。知法已内乐精进背。处不说恶面。前不赞善称满说法非不称满。不必顾方语不是非人礼。随方而说法。无恼害离恼。于恼解脱入无恼法。复次此是彼人数共制名无恼。是名无恼行人

云何胜入行人。若人得八胜入。多行是行。是名胜入行人。云何一切入行人。若人得十一切入。多行是行。是名一切入行人。云何修八解脱人。若人得八解脱。多行是行。是名修八解脱人。云何六通人。若人六通成就。多行是行。是名六通人

云何五此竟人。七生人。家家人。斯陀含人。一种人。若现身得阿罗汉人。云何七生人。须陀洹是名七生人。复次七生人。若人见断三烦恼断。身见疑戒盗。圣道一时俱断。于彼断住。未得上道思惟断欲爱嗔恚烦恼分断。作业必当生受七天七人身。受行七天七人身已尽苦边。是名七生人。云何家家人。若人见断三烦恼断。身见疑戒盗。圣道一时俱断。得上道思惟断欲爱嗔恚烦恼分断。未断作业。必当生或受二三人身。彼或受行二三人身已尽苦边。是名家家人。复次家家人。若人见断三烦恼断身见疑戒盗。圣道一时俱断。思惟断欲爱嗔恚烦恼分断。未如斯陀含作业。必当生或受二三人身。受行二三人身已尽苦边。是名家家人。云何斯陀含人。若人见断三烦恼断。身见疑戒盗。以圣道一时俱断。思惟断欲爱嗔恚烦恼分断。以圣道一时俱断。于彼断住。未得上道余思惟断欲爱嗔恚无余断作业。必当生受一天一人身。受行一天一人身已尽苦边。是名斯陀含人。复次斯陀含人。若人见断三烦恼身见疑戒盗。以圣道一时俱断。思惟断欲爱嗔恚烦恼分断。过家家人。非如一种人作业。必当生受一天一人身。受行一天一人身已尽苦边。是名斯陀含人。云何一种人。若人见断三烦恼断身见疑戒盗。以圣道一时俱断。思惟断欲爱嗔恚烦恼分断。以圣道一时俱断得上道余思惟断。欲爱嗔恚无余断。未断作业。必当生受一人身。受行一人身已尽苦边。是名一种人。复次一种人。若人见断三烦恼断身见疑戒盗。圣道一时俱断。思惟断欲爱嗔恚多断过斯陀含。非如阿那含作业。必当生受一人身。受行一人身已尽苦边。是名一种人。云何现身得阿罗汉人。若人以我分身。若长若幼上正决定。此人此生我分身此长此幼。得须陀洹果斯陀含果阿那含果。得阿罗汉果。是名现身得阿罗汉果人。是名五此竟人

云何五彼竟人。中般涅槃人。速般涅槃人。无行般涅槃人。有行般涅槃人。上流般涅槃人。云何中般涅槃人。若人五下。分烦恼断。身见疑戒盗欲爱嗔恚。以圣道一时俱断。彼圣五根利用最胜。信根进根念根定根慧根。若此道乐速解。若修彼道已。得阿罗汉果。彼有留难现身。不得阿罗汉果。或多诸缘行慈愍亲属。宿业必当生受一天身。于彼有不适意。生不适意。住不适意。行不适意。于彼天身中般涅槃。何谓中般涅槃。于欲界命终。若生色界天上。于彼天寿中。于彼断法中般涅槃。是名中般涅槃。复次此是彼人数共制。名中般涅槃。是名中般涅槃人。云何速般涅槃人。若人五下分烦恼断。身见疑戒盗欲爱嗔恚。以圣道一时俱断。此圣五根利。不如中般涅槃。何等五。信根进根念根定根慧根。若此道若速解。若修彼道得阿罗汉果。彼有留难现身。不得阿罗汉果。以多诸缘行慈愍亲属。由宿业必受一天身。于彼有不适意。生不适意。住不适意。行不适意。于彼天身速般涅槃。何谓速般涅槃。欲界命终生色界天上。彼天寿少乐多离速般涅槃。是名速般涅槃。复次此是彼人数共制。名速般涅槃人。是名速般涅槃人。云何无行般涅槃人。若人五下分烦恼断。身见疑戒盗欲爱嗔恚。以圣道一时俱断。此圣五根软。何等五。信根进根定根慧根念根。若此道乐难。解若修彼道得阿罗汉果。彼有留难。现身不得阿罗汉果。以多诸缘行慈愍亲属。由宿业必当生受一天身。彼有适意生适意。住不适意。行不适意。于彼天身无行般涅槃。何谓无行般涅槃。欲界命终。若生色界天上。于彼无行得无间道。得已即于彼间般涅槃。是名无行般涅槃。复次此是彼人数共制。名无行般涅槃。是名无行般涅槃人。云何有行般涅槃人。若人五下分烦恼断。身见疑戒盗欲爱嗔恚。以圣道一时俱断。若此圣五根软。何等五。信根进根念根定根慧根。若此道苦难解。若修彼道已。得阿罗汉果。彼有留难。现身不得阿罗汉果。以多诸缘业行慈愍亲属。由宿业必当生受一天身。彼有适意生适意。住适意。行不适意。于彼天身有行般涅槃。何谓有行般涅槃。欲界命终。若生色界天上。彼有行难得无间道。得已便于彼般涅槃。是名有行般涅槃。复次此是。彼人数共制。名有行般涅槃。是名有行般涅槃人。云何上流至阿迦腻吒人。若人五下分烦恼断。身见疑戒盗欲爱嗔恚。以圣道一时俱断。此圣五根最软。何等五。信根进根念根定根慧根。若此道或乐难解。或苦难解。修彼道已。得阿罗汉果。彼有留难。现身不得阿罗汉果。以多诸缘行慈愍亲属。由宿业必当生受五天身。于彼天上有适意生适意。住适意行适意。此若命终上流。至阿迦腻吒。何谓上流至阿迦腻吒。于欲界命终。生色界无胜天中。如彼天寿住彼天寿。住已彼命终转生无热天中。生无热天中已。彼命终转生善见天中。生善见天中已。彼命终转生如妙善见天中。生如妙善见天中已。彼命终转生阿迦腻吒天中。如彼天寿住。如彼天寿住已。逮无间道得阿罗汉果。得阿罗汉果已。即于彼般涅槃。是名上流至阿迦腻吒。复次此是彼人数共制。名上流至阿迦腻吒。是名上流至阿迦腻吒人。是名五彼竟人。云何一分解脱人。若人先学时得八解脱灭尽定。非后无学时得八解脱灭尽定。后无学时得八解脱灭尽定。非学时得八解脱灭尽定。是名一分解脱人。云何二分解脱人。若人学时得八解脱灭尽定。后无学时亦得八解脱灭尽定。是名二分解脱人。复次一分解脱人。若人尽智生非无生智。是名一分解脱人。复次二分解脱人。若尽智生无生智生。是名二分解脱人。云何慧解脱人。若人寂静解脱过色无色。彼非身触行见慧断有漏。是名慧解脱人。云何身证人。若人寂静解脱过色无色。修身触行非慧见断有漏。是名身证人。云何见得人。若人寂静解脱过色无色。彼非身触行。非慧见断有漏。如世尊所流布法。多用慧择行。是名见得人。云何信解脱人。若人寂静解脱过色无色。彼非身触行。非慧见断有漏。如世尊所流布法。以慧择行不及见得。是名信解脱人。云何见得人。若人得坚法上正决定。得须陀洹果。得斯陀含果。得阿那含果。未得八解脱灭尽定。是名见得人。云何信解脱人。若人得坚信上正决定。得须陀洹果。得斯陀含果。得阿那含果。未得八解脱灭尽定是名信解脱人。云何坚信人。若人寂静解脱过色无色。彼非身触行。非慧见断有漏。彼信受于世尊。是名坚信解脱人。云何坚法人。若人寂静解脱过色无色。彼非身触行。非慧见断有漏。如世尊所流布法。慧观而堪忍。是名坚法人。云何坚信人。若人性好信多信上正决定。未得四沙门果一一触证。若须陀洹果。若斯陀含果。若阿那含果。若阿罗汉果。彼于五根信根多。余四根少。未得八解脱灭尽定。是名坚信人。云何坚法人。若人性好择法多择法上正决定。未得四沙门果一一触证。若须陀洹果若斯陀含果。若阿那含果。若阿罗汉果。彼于此五根慧根多。余四根少。未得八解脱灭尽定。是名坚法人

云何断五支人。若人五盖断欲爱盖嗔恚睡眠掉悔疑盖。是名断五支人。复次断五支人。若人五下分烦恼断。身见疑戒盗欲爱嗔恚。是名断五支人

云何六支成就人。若人六舍成就。彼眼见色无忧无喜舍行念知。耳闻声鼻嗅香舌尝味。身觉触意知法。无忧无喜舍行念知。是名六支成就人

云何一护人。若人以念护心成就。是名一护人

云何四依人。若人知堪忍知亲近知离知舍。是名四依人

云何灭异缘实人。若人于此外或有沙门婆罗门异缘见。我世常此见实余虚妄。我世非常此实余虚妄。我世常非常此实余虚妄。我世非常非非常此实余虚妄。我世有边此实余虚妄。我世无边此实余虚妄。我世有边无边此实余虚妄。我世非有边非无边此实余虚妄。身是命此实余虚妄。命是身此实余虚妄。身异命异此实余虚妄。无命无身此实余虚妄。有如去涅槃此实余虚妄。无如去涅槃此实余虚妄。有如去不如去涅槃此实余虚妄。有如去非不如去涅槃。此实余虚妄。于彼一切灭害舍解吐出离尽已。是名灭异缘实人。云何求最胜人。若人欲求断有求断。求梵净行所作已竟。何谓欲求。欲界未觉未知。欲界未断法若欲界阴界入。若色声香味触。若众生若法。若求彼悕望聚集尽求爱求已。悕望已聚集尽求已。是名欲求。云何有求。色界无色界未觉未知。色界无色界未断。若色界无色界阴界入。若禅若解脱。若定若三摩跋提。若求此悕望聚集尽求爱求已。悕望已聚集尽求已。是名有求。云何求梵净行。谓八圣。若求彼悕望聚集尽求爱求已悕望已。聚集尽求已。是名求梵净行人。若人欲求断有求断。求梵净行所作已竟。是名求最胜人

云何不浊想人。浊想谓欲想嗔想害想不浊想。谓出想不嗔恚想非害想若人舍欲想忆念出想。舍嗔恚想忆念非嗔恚想。舍害想忆念非害想。是名不浊想人

云何除身行人。身谓出息入息。彼若入于寂静灭除。是名除身行人。复次除身行人。若此比丘断苦断乐。先灭忧喜想不苦不乐舍念清净。成就于四禅行。是名除身行人

云何心善解脱人。若人于欲心解脱。嗔恚愚痴心解脱。是名心善解脱人。云何慧善解脱人。若人自知法。我欲断必不生。嗔恚愚痴断必不生。是名慧善解脱人。云何心善解脱人。若人心解脱欲无欲得触证已。是名心善解脱人。云何慧善解脱人。若人离无明慧解脱得触证已。是名慧善解脱人。云何心善解脱人。若人尽智生非无生智。是名心善解脱人。云何慧善解脱人。若人尽智生及无生智。是名慧善解脱人。云何共解脱人。若人于共解脱心住发起。是名共解脱人。云何不共解脱人。若人不共解脱心住不发起。是名不共解脱人。云何有退人。若人于共解脱心住发起。彼有共解脱心退变。是名有退人。云何无退人。若人于不共解脱心住不变起。彼非有共解脱心不退变。是名无退人。云何思有人。若人于共解脱心住发起。彼有思有于共解脱心令我不终不退不变。是名思有人。云何有微护人。若人于共解脱心住发起。彼若护令我于共解脱心不退不变。彼于共解脱心不退不变。是名微护人。云何或有人若思不退不思便退。若人于共解脱心住发起。彼若思害我。令我于共解脱心不退不变。彼于共解脱心不退不变不思害我。令我于共解脱心不退不变。彼于共解脱退变。是名或有人思不退不思便退人。云何或有人若微护不退不微护便退。若人于共解脱心住发起。彼若护令我于共解脱心不退不变。便于共解脱心不退不变。若不护令我于共解脱心不退不变。彼于共解脱心不退不变。彼于共解脱心退变。是名或有人微护不退不微护便退。云何有缘射人。若人尽智生非无生智。必当生无生智当缘射。于解脱心终不发起。是名有缘射人

云何法不发起人。若人心解脱于欲嗔恚愚痴。是名法不发起人。何谓法不发起人。欲不发起。嗔恚愚痴不发起。是名法不发起人

云何住劫人。若坚信坚法。若复有善行。若人现世得阿罗汉。是名住劫人。何谓住劫。乃至一切世界烦恼不坏。必令彼人得四沙门果得三触证。若须陀洹果。若斯陀含果。若阿那含果。若阿罗汉果。是名住劫人

云何首等人。若人未行道。若有漏若寿命一时俱断。复次断漏无间命得断。是名首等人

云何度堑人。若人无明断。是名度堑人。云何坏堑人。若人生死断。是名坏堑人。云何乘进人。若人有爱断。是名乘进人。云何无沾污人。若人五下分烦恼断。是名无沾污人

云何惰慢人。若人我慢断。是名惰慢人

舍利弗阿毗昙论卷第八舍利弗阿毗昙论卷第九

        姚秦罽宾三藏昙摩耶舍共昙摩崛多等译

    非问分智品第四之一

正见。正智。慧根。慧力。择法正觉。解脱智。正觉智。邪智。圣智。非圣智。有漏智。无漏智。有爱智。无爱智。有求智。无求智。当取智。非当取智。有取智。无取智。有胜智。无胜智。受智。非受智。内智。外智。有报智。无报智。凡夫共智。凡夫不共智。非凡夫共智。非凡夫不共智。声闻共智。声闻不共智。非声闻共智。非声闻不共智。如电智。如金刚智。不定得智。定得智。有行胜持智。无行胜持智。一分修智。二分修智。尽智无生智。法住智。涅槃智。界方便。思惟方便。非法方便。除非法方便。入定方便。出定方便。有觉智。无觉智。有观智。无观智。有喜智。无喜智。有味智有。共舍智。有光智。无光智。善智。不善智。无记智。学智。无学智。非学非无学智。报智。报法智。非报非报法智。见断智。思惟断智。非见断非思惟断智。见断因智。思惟断因智。非见断因智。非思惟断因智。卑智。中智。胜智。粗智。细智。微智。三明。三慧。三眼。内身观身智。外身观身智。内外身观身智。内受观受智。外受观受智。内外受观内外受智。内心观心智。外心观心智。内外心观内外心智。内法中观内法智。外法中观外法智。内外法中观内外法智。内境界智。外境界智。内外境界智。众生境界智。色境界智。非色境界智。众生境界智。有为境界智。无为境界智。众生境界智。法境界智。无境界智。众生境界智。少智。中智。无量智。少境界智。中境界智。无量境界智。少智。少境界少智。中境界少智。无量境界中智。少境界中智。中境界中智。无量境界无量智。少境界无量智。中境界无量智。无量境界少住智。中住智。无量住智。少智。少住少智。中住少智。无量住中智。少住中智。中住中智。无量住无量智。少住无量智。中住无量智。无量住善道方便。恶道方便。善方便。恶方便。勤方便。寂静方便。取方便。舍方便。过去智。未来智。现在智。过去境界智。未来境界智。现在境界智。非过去非未来非现在境界智。欲界系智。色界系智。无色界系智。不系智。苦智。集智。灭智。道智。法智。比智。世智。他心智。法辩义辩辞辩应辩。作智非离智。离智非作智。作离智。非作非离智。非取非出智。有染智。非杂非杂染智。非有染有染有离染智。非有染非离染智。扼智。非离扼离扼智。非离扼离扼智。非扼非离扼智。智果智。非断果智。断果智。非智果智。智果断果智。非智果非断果智智果智。非得果得果智。非智果智。果得果智。非智果非得果智。尽智非觉觉智。非尽尽觉智。非尽非觉智。解智非脱脱智。非解解脱智。非解非脱智。退分智。住分智。增长分智。解分智。退分智。非住分住分智。非退分住分退分智。非退分非住分智。退分智。非增长分增长分智。非退分退分增长分智。非退分非增长分智。退分智。非解分解分智。非退分退分解分智。非退分非解分智。住分智。非增长分增长分智。非住分住分增长分智。非住分非增长分智。住分智。非解分解分智。非住分住分解分智。非住分非解分智。增分智。非解分解分智。非增分增分解分智。非增分非解分智。五智。六通。七方便。苦法智。苦比智。集法智。集比智。灭法智。灭比智。道法智。道比智。九方便。如来十力。十智性。四十四智性。七十七智性

云何正见。见若善顺不逆。是名正见。云何正智。智若善顺不逆。是名正智。云何正见。若忍善顺不逆。是名正见。云何正智。智若善顺不逆。是名正智。云何正见。除尽智。无生智。若余见善顺不逆。是名正见。云何正智。尽智无生智。是名正智

云何慧根。学人离结使。圣心入圣道。若坚信若坚法。及余趣人见行过患。观涅槃寂灭。如实观苦集灭道。未得欲得。未解欲解。未证欲证。修道离烦恼。见学人若须陀洹。若斯陀含。若阿那含。观智具足。若智地若观解脱心。即证一一沙门果。若须陀洹果。若斯陀含果。若阿那含果。无学人欲得阿罗汉。未得圣法。欲得修道。观智具足。若智地若观解脱心。即得阿罗汉果。若实人若趣若法择重择究竟。择择法思惟。觉了达自相他相共。相思念辨观生自在智慧智见解射方便术焰光明照曜。慧眼慧根慧力择法正觉无痴正见。是名慧根。云何慧力。慧根是名慧力

云何择法正觉。慧力是名择法正觉

云何解脱智。若于解脱中智见解脱方便。心于贪欲嗔恚解脱。我心解脱。于贪欲嗔恚。即智见彼解脱方便。是名解脱智(此论智见解脱之脱丹藏皆作射)

云何觉。如来若智生。于一切法中无碍智见。得自在自由力尊自在胜贵自在知见。无上正觉如来十力。成就四无所畏大慈。成就自在转法轮法。是名觉

云何正智。智若善顺不逆。是名正智。云何邪智。智若不善不顺逆。是名邪智

云何圣智。智若无漏。是名圣智。云何非圣智。智若有漏。是名非圣智

云何有漏智。智若有爱。是名有漏智。云何无漏智。智若无爱。是名无漏智

云何有爱智。智若有求。是名有爱智。云何无爱智。智若无求。是名无爱智

云何有求智。智若当取。是名有求智。云何无求智。智若非当取。是名无求智

云何当取智。智若有取。是名当取智。云何非当取智。智若无取。是名非当取智

云何有取智。智若有胜。是名有取智。云何无取智。智若无胜。是名无取智

云何有胜智。智若有取。是名有胜智。云何无胜智。智若无取。是名无胜智。云何有胜智。若于此智有余智胜妙过上是名有胜智。云何无胜智。于此智于余智胜妙过上。是名无胜智

云何有胜智。如来若生智。于一切法中无碍智见。得自在自由力豪尊自在胜贵自在智见。无上最胜正觉如来十力成就四无所畏大慈自在成就转法轮。除彼智若余智。是名有胜智。云何无胜智。若前所余智。是名无胜智

云何受智。智若智内。是名受智。云何非受智。智若智外。是名非受智

云何内智。若智受。是名内智。云何外智若智非受。是名外智

云何有报智。若智报法。是名有报智。云何无报智。若智非报非报法。是名无报智

云何凡夫共智。智非凡夫生得。凡夫亦生得。是名凡夫共智。云何凡夫不共智。若智非凡夫生得。凡夫不生不得。是名凡夫不共智。云何非凡夫共智。若智凡夫得非凡夫亦生得。是名非凡夫共智。云何非凡夫不共智。若智凡夫生得。非凡夫不生不得。是名非凡夫不共智

云何声闻共智。若智非声闻生得。声闻亦生得。是名声闻共智。云何声闻不共智若智非声闻生得。声闻不生不得。是名声闻不共智。云何非声闻共智。若智声闻生得。非声闻亦生得。是名非声闻共智。云何非声闻不共智。若智声闻生得。非声闻不生不得。是名非声闻不共智

云何如电智。若智少少住少间住。如电少少住少间住。智亦如是。少少住少间住。是名如电智。云何如金刚智。若智无量无量住无量间住。犹如金刚无量无量住无量间住。智亦如是。无量无量住无量间住。是名如金刚智。复次如电智。若智生断少烦恼分。犹如电云间出照少分速灭。智亦如是。断少烦恼分。是名如电智。复次如金刚智。若智生断一切烦恼。无余微细。无不尽速断。如金刚投于珠石无不破坏摧折。智亦如是。若生已断一切烦恼。无有粗细不断不尽者。是名如金刚智。复次如电智。谓智生得须陀洹果斯陀含果阿那含果。是名如电智。复次如金刚智。若智生得阿罗汉果。是名如金刚智。复次如电智。谓智生得须陀洹果斯陀含果阿那含果得阿罗汉果辟支佛。是名如电智。复次如金刚智。如来谓智生于一切法。无碍知见。得自在自由力尊贵胜自在智见无上觉如来十力。成就四无所畏大慈。成就自在转法轮。如是智是名如金刚智

云何不定得智。若智得不定得难得。是名不定得智

云何定得智。若智得定得不难得。是名定得智

云何行进护持智若智得非定得难得。非自由力非尊非自在。非所欲处。不如所欲。不尽所欲。行进生难得。犹如船逆流难。若得如此智。非定得难得。非由力非尊自在。非所欲处不如所欲。不尽所欲。行进生难得。是名行进护持智。云何非行进护持智。若智得定得。非难得自由力尊自在。所欲处如所欲尽所欲。易行不难生得。犹如船顺流不难。若得如此智。定智不难智自由力尊自在。所欲处如所欲尽所欲行非难生得。是名非行进护持智

云何一分修智。若智生想有光明不见色。若见色不想有光明。是名一分修智。云何二分修智。若智生想有光明亦见色。是名二分修智。复次一分修智。若智不断烦恼。若断烦恼非生智。是名一分修智。复次二分修智。若智生亦断烦恼。是名二分修智。复次一分修智。若智是尽智生非无生智。是名一分修智。复次二分修智。若智生尽智无生智。是名二分修智

云何尽智。贪欲嗔恚愚痴尽已。我贪欲嗔恚愚痴尽。即于彼智见解脱方便。是名尽智。云何无生智。贪欲嗔恚愚痴灭已不复生。我贪欲嗔恚愚痴尽不复生。即于彼智见解脱方便。是名无生智

云何法住智。若智圣有为境界。是名法住智。云何涅槃智。若智圣涅槃境界。是名涅槃智。复次法住智。除缘如尔。若余法如尔非不如尔。非异非异物。常法实法。法住法定非缘。是名法住智。复次涅槃智。彼涅槃寂静。是舍是护。是证是依。是不没是度。是不热是不燋。是无忧是无恼。是无苦痛。及余行观涅槃若智生。是名涅槃智

云何方便界。众界比界触界思惟界。此色界此无色界。此可见界此不可见界。此有对界此无对界。此圣界此非圣界。此界即于彼界解脱方便。是名方便界。云何思惟方便界。若思惟众思惟比思惟。触忆念思惟。此善思惟。此不善思惟正忆念。此邪忆念。此忆念即于彼知见方便解脱。是名思惟方便。云何非法方便。非法众。非法比。非法触思惟非法。此轻罪此重罪此有余罪此无余罪。此作恶此非作恶。此众罪。即于彼知见解脱方便。是名非法方便。云何除非法方便。除非法方便众。除非法方便比。除非法方便触思惟。除非法方便。如是得除非法轻罪。如是除重罪。如此除有余无余罪。如是除作恶如是除非作恶罪。如是除诸罪。如是除诸罪已。如是胜法除罪。则于彼知见解脱方便。是名除非法方便。云何入定方便。入定众入定比。入定触入定思惟。此入想定无想定。此入随想定不随想定。此入离色定。此入胜入定。此入一切入定。如是入诸定如是入诸定已。如是胜法入定。即于知见解脱方便。是名入定方便。云何出定方便。出定众出定比。出定触出定思惟。如是出想定无想定。如是随想定出不随想定。如是出离色定出不离色定。如是出胜入定入一切入定。如是出诸定。如是出诸定已。如是胜法出定。即于彼知见解脱方便。是名出定方便

云何有觉智。若智觉相应共生共住共灭。是名有觉智。云何无觉智。若智非觉相应不共觉生不共住不共灭。是名无觉智。云何有观智。若智观相应共生共住共灭。是名有观智。云何无观智。若智非观相应不共生不共住不共灭。是名无观智

云何有喜智。若智喜相应共生共住共灭。是名有喜智。云何无喜智。若智非喜相应不共生不共住不共灭。是名无喜智

云何有味智。若智乐受相应。是名有味智。云何舍智。若智不苦不乐受相应。是名舍智

云何有用智。若智有境界。是名有用智。云何无用智。若智生无境界。是名无用智。复次若智生断无明。是名无用智

云何善智。若智修。是名善智。云何不善智。若智断。是名不善智。云何无记。智若智受若智非报非报法。是名无记智

云何学智。若智圣非无学。是名学智。云何无学智。若智圣非学。是名无学智。云何非学非无学智。若智非圣。是名非学非无学智

云何报智。若智受若智善报。是名报智。云何报法智。若智有报。是名报法智。云何非报非报法智。若智无记非我分摄。是名非报非报法智

云何见断智。若智不善非思惟断。是名见断智。云何思惟断智。若智不善非见断。是名思惟断智。云何非见断非思惟断智。若智无记。是名非见断非思惟断智

云何见断因智。若智见断。若智见断法报。是名见断因智。云何思惟断因智。若智思惟断。若智思惟断法报。是名思惟断因智。云何非见断非思惟断因智。若智善若智善法报。若智非报非报法。是名非见断非思惟断因智。云何卑智。若智不善。是名卑智。云何中智。若智无记。是名中智。云何胜智。若智善。是名胜智。复次卑智。若智不善若无记。是名卑智。复次中智。若智非圣善。是名中智。复次胜智。若智圣无漏。是名胜智

云何粗智。若智欲界系。是名粗智。云何细智。若智色界系若不系。是名细智。云何微智。若智无色界系。是名微智。复次粗智。若智欲界系。若色界系。是名粗智。复次细智。若智空处识处不用处系若不系。是名细智。复次微智。若智非想非非想处系。是名微智。复次粗智。若智欲界系若色界系。若空处识处不用处系。是名粗智。复次细智。若智非想非非想处系。是名细智。复次微智若智不系是名微智。云何三明。忆念宿命证智明。众生生死证智明。漏尽证智明。云何忆念宿命证智明。若智生忆念无量宿命。忆念一生二三四五十二十三十四十五十百生千生万生十万生无量百生无量千生无量万生。或无量劫坏。或无量劫成。我本在彼。如此名如此姓如此生。如此食如此命。如此命短。如此命久住。如此处苦乐。从彼终生从彼。于彼终复生彼。如此具足忆念若干宿命。是名忆念宿命智证明。云何众生生死智证明。若智生天眼清净过于人眼。见众生生死好色恶色恶道善道卑胜。知众生如所造业。此众生身恶行成就。口恶行成就。意恶行成就。谤圣人邪见行邪见业。身坏命终生恶道地狱畜生饿鬼。此众生身善行成就。口善行成就。意善行成就。不谤圣人。正见行正见因业。身坏命终生善道天上人中。如此天眼清净过人眼见是名众生生死好色恶色善道恶道卑微。知众生如所造业。是名众生生死智证明。云何漏尽智证明。若智生漏尽生无漏解脱。心解脱慧解脱。现身自证知成就行。生已尽梵行已立。名称远闻。所作已办更不还有。是名漏尽证智明。是名三明。云何三慧。思慧闻慧修慧。云何思慧。不由他闻。不受他教。不请他说。不听他法。自思自觉自观。若智生非修行。是名思慧。云何闻慧。从他闻受他教。请他说听他法。非自思非自觉非自观。若智生。是名闻慧。云何修慧。若修根力觉禅解脱定入定。若修已修若智生是名修慧。是名三慧

云何三眼。肉眼天眼慧眼。云何肉眼。若眼我分摄四大所造净。是名肉眼。云何天眼。若天眼我分摄。是名天眼。云何慧眼。三慧思慧闻慧修慧。是名慧眼。复次肉眼除天眼我分摄。若余眼四大所造净。是名肉眼。复次天眼若天眼我分摄。及修天眼。是名天眼。复次慧眼除修天眼。若余三慧思慧闻慧修慧。是名慧眼。是名三眼

云何内身观内身智。一切内四大色身摄法一处内四大色身摄法。观无常苦空无我若智生。是名内身观内身智。云何外身观外身智。一切外四大色身摄法。一处外四大色身摄法。观无常苦空无我若智生。是名外身观外身智。云何内外身观内外身智。一切内外四大色身摄法。一处内外四大色身摄法。观无常苦空无我。若智生是名内外身观内外身智。云何内受观内受智。一切内受一处内受。观无常苦空无我若智生是名内受观内受智。云何外受观外受智。一切外受一处外受。观无常苦空无我若智生。是名外受观外受智。云何内外受观内外受智。一切内外受。一处内外受。观无常苦空无我若智生。是名内外受观内外受智。云何内心观内心智。一切内心。一处内心。观无常苦空无我若智生。是名内心观内心智。云何外心观外心智。一切外心一处外心。观无常苦空无我。若智生是名外心观外心智。云何内外心观内外心智。一切内外心。一处内外心。观无常苦空无我若智生。是名内外心观内外心智。云何内法观内法智。除四大色身摄法受心。余一切内法。一处内法。观无常苦空无我若智生。是名内法观内法智。云何外法观外法智。除四大色身摄法受心。余一切外法。一处外法。彼如事观无常苦空无我若智生。是名外法观外法智。云何内外法观内外法智。除四大色身摄法受心。余一切内外法处内外法。如事观无常苦空无我。若智生。是名内外法观内外法智

云何内境界智。思惟内法。若智生。是名内境界智。云何外境界智。思惟外法智生。是名外境界智。云何内外境界智。思惟内外法智生。是名内外境界智

云何众生境界智。无众生境界智。复次众生慈行悲喜舍行思惟智生。是名众生境界智。云何色境界智。思惟色法智生。是名色境界智。云何无色境界智。思惟无色法智生。是名无色境界智。云何众生境界智。无众生境界智。复次众生慈行悲喜舍行智生。是名众生境界智。云何有为境界智。思惟有为法智生。是名有为境界智。云何无为境界智。思惟无为法智生。是名无为境界智。云何众生境界智。无众生境界智。复次众生慈行悲喜舍行思惟智生。是名众生境界智。云何法境界智。思惟法智生。是名法境界智。云何无境界智。无境无境界智。复次思惟过去未来法智生是名无境界智。云何众生境界智。无众生境界智。复次众生。慈行悲喜舍行。是名众生境界智。云何少智。若少少住少间住。是名少智。云何中智。若智中中住中间住。是名中智。云何无量智。若智无量无量住无量间住。是名无量智。复次少智。若智少住少软少境界是名少智。复次中智。若智中住中软中境界。是名中智。复次无量智。若智无量住无量利无量境界。是名无量智

云何少境界智。若智一众生。若一法若一行始生。除如来涅槃。是名少境界智。云何中境界智。若智数众生。若法始生。除如来涅槃。是名中境界智。云何无量境界智。若智无量众生。若法始生。若如来涅槃。是名无量境界智。云何少智少境界。若智少住少软若一众生若一法若一行始生。除如来涅槃。是名少智少境界。云何少智中境界。若智少住少软若数众生若法始生。除如来涅槃。是名少智中境界。云何少智无量境界。智若少住少软。若无量众生法始生。若如来涅槃。是名少智无量境界。云何中智少境界。智若智中住中软。若一众生。若一法一行始生。非如来涅槃。是名中智少境界。云何中智中境界。若智中住中软。数众生若法始生。非如来涅槃。是名中智中境界。云何中智无量境界。若中住中软。若无量众生法始生。如来涅槃。是名中智无量境界。云何无量智少境界。智若无量住无量利。若一众生一法一行始生。除如来涅槃。是名无量智少境界。云何无量智中境界。若智无量住无量利。若数众生若法始生。除如来涅槃。是名无量智中境界。云何无量智无量境界。智若无量住无量利。若无量众生法始生。如来涅槃。是名无量智无量境界。云何少住智。若智少间住。一弹指顷或多。作[穀-禾+牛]牛顷或多。是名少住智。云何中住智。若智中间住。[穀-禾+牛]牛顷或多。非七日或多。是名中住智。云何无量住智。若智无量间住。七日或多。是名无量住智。云何少智少住。若境界少软。若少间住。弹指顷或多。非[穀-禾+牛]牛顷或多。是名少智少住。云何少智中住。智若少境界少软。若中住[穀-禾+牛]牛顷或多。是名少智中住。云何少智无量住。若智少境界少软。若无量间住。七日或多。是名少智无量住。云何中智少住。智若中境界中软。若少间住。弹指顷。或非[穀-禾+牛]牛顷或多。是名中智少住。云何中智中住。若智中境界中软。中间住[穀-禾+牛]牛顷或多。非七日或多。是名中智中住。云何中智无量住。智若中境界中软。若无量间住。七日或多。是名中智无量住。云何无量智少住。智若无量境界无量利若少间住。弹指顷或多。非[穀-禾+牛]牛顷或多。是名无量智少住。云何无量智中住。若智无量境界无量利。若中间住。[穀-禾+牛]牛顷或多。非七日或多。是名无量智中住云何无量智无量住。若智无量境界无量利。若无量间住七日或多。是名无量智无量住

云何善道方便。善道谓善法及人天。若智见解脱方便。是名善道方便。云何恶道方便。恶道谓不善法。及地狱畜生饿鬼。若智见解脱方便。是名恶道方便

云何善方便。此因此缘色。此因此缘受想行识。此因此缘入初禅定。入第二第三第四禅定。断恶不善法成就善法。若智见解脱方便。是名善方便。云何寂静方便。寂静谓定。若智见解脱方便。是名寂静方便。云何取方便。取谓进。若智见解脱方便。是名取方便。云何舍方便。二舍舍根心。若智见解脱方便。是名舍方便。复次寂静方便。心过掉如是寂静如相灭。若智见解脱方便。是名寂静方便。复次取方便。若软进当如是勤取随缘取正取。劝勉正劝勉正欢喜。若智见解脱方便。是名取方便。复次舍方便。定心如是舍贪欲嗔恚愚痴尽。若智见解脱方便是名舍方便

云何过去智。若智生已灭。是名过去智。云何未来智。若智未生未出。是名未来智。云何现在智。若智生未灭。是名现在智

云何过去境界智。思惟过去法智生。是名过去境界智。云何未来境界智。思惟未来法智生。是名未来境界智。云何现在境界智。思惟现在法智生。是名现在境界智。云何非过去非未来非现在境界智。思惟非过去非未来非现在法智生。是名非过去非未来非现在境界智

云何欲界系智。若智欲漏有漏。是名欲界系智。云何色界系智。若智色漏有漏。是名色界系智。云何无色界系智。若智无色漏有漏是名无色界系智。云何不系智。若智圣无漏。是名不系智

云何苦智。此苦圣谛。若智见解脱方便。是名苦智。云何集智。此集圣谛。若智见解脱方便。是名集智。云何灭智。此灭圣谛。若智见解脱方便。是名灭智。云何道智。此道圣谛。若智见解脱方便。是名道智。复次苦智。生苦老苦病苦死苦。不爱会苦爱别离苦所求不得苦。除爱总五受阴苦。若智见解脱方便。是名苦智。复次集智。此爱复有欲染相续处处悕望。若智见解脱方便。是名集智。云何灭智。若爱欲离灭尽舍出解脱。无有依止永断无余。若智见解脱方便。是名灭智。复次道智。八圣道。正见正觉正语正业正命正精进正念正定。若智见解脱方便。是名道智。复次苦智。一切有为有漏苦谛所摄法。若一处有为有漏苦谛所摄法。见苦见无我思惟苦。若智见解脱方便。是名苦智。复次集智。一切苦因苦集。若一处苦因苦绪苦集。见集见无我思惟集。此因此缘成就一切苦。若智见解脱方便。是名集智。复次灭智。尽一切苦。尽烦恼尽漏法。若一切处尽苦尽烦恼尽漏法。见灭见无我思惟灭。若智见解脱方便。是名灭智。复次道智。一切圣道出要正灭苦。若一处圣道出要正灭苦。见道见无我思惟道。此因此缘尽一切苦。若智见解脱方便。是名道智。云何法智。若智圣无漏非比类智一切相。是名法智。云何比智。若智圣无漏比类智一切相无余。是名比智。云何世智。若知诸众生。若知法名字语言。若知过去语未来语现在语男女非男女语一语二语三语众语无量语一切语。若智见解脱方便。是名世智。云何他心智。若以智知他心。若智见解射方便。是名他心智。复次法智。若有为有漏苦谛所摄法。见苦见无我思惟苦。若苦因苦绪苦集。见集见无我思惟集。尽苦尽烦恼尽有漏。见漏见无我思惟灭。若圣道见无我思惟道。及思惟余法。若于彼圣无漏智非比类智一切相。是名法智。复次比智。若人已行法中生法智。彼于余法中。如彼彼生如彼相。如彼比类。此如彼彼如此。若圣无漏智比类智一切相。是名比智。复次世智。若知诸众生。若知法数。若知共施设语言名字。若色受想行识。若苦集灭道。若地狱畜生饿鬼人天。若智见解脱方便。是名世智。复次他心智。若以智知他众生他人心数及心。有爱心如实知有爱心。无爱心如实知无爱心。有嗔恚心如实知有嗔恚心。无嗔恚心如实知无嗔恚心。有愚痴心如实知有愚痴心。无愚痴心如实知无愚痴心。嫉心如实知嫉心。乱心如实知乱心。少心如实知少心。实心如实知实心。不定心如实知不定心。定心如实知定心。非解脱心如实知非解脱心。解脱心如实知解脱心。有胜心如实知有胜心。无胜心如实知无胜心。若智见解脱方便。是名他心智

云何法辩。法众法比法触。若圣智无余。是名法辩。云何义辩。义众义比义触。若圣智无余。是名义辩。云何辞辩。辞众辞比辞触。若圣智无余。是名辞辩。云何应辩。应众应比应触。若圣智无余。是名应辩。复次法辩。除辞辩应辩。若余圣无漏智非比类智知相无余。是名法辩。复次义辩。除辞辩应辩。若余圣无漏智比类智知相无余。是名义辩。复次辞辩。若色受想行识。若苦集灭道。若地狱畜生饿鬼人天。若当如是说如是辞如是分别。若智见解脱方便。是名辞辩。复次应辩。应谓智。以如是智知。若智见解脱方便。是名应辩。复次法辩。若色受想行识。若苦集灭道。非义触。非因触。非绪触。非缘触。若于圣无漏智非比类智知相无余。是名法辩

复次义辩。义触因触绪触缘触。以此义若色受想行识。若苦集灭道。若于无漏智比类智知相无余。是名义辩。复次辞辩。以得三辩法辩义辩辞辩。若言语开解无碍无缠无滞。若契明了。若知见解脱方便。是名辞辩

复次应辩。以得三辩法辩义辩辞辩。若随开无碍无缠无边无量无尽不可思议不可计数。若知见解脱方便。是名应辩

复次法辩。法智是名法辩。复次义辩。比智是名义辩。复次若分别法不可思议。是名法辩。复次义辩。若思分别思义。是名义辩。何谓辩。辩谓缘。智谓智力智。谓胜智。谓金刚智。谓无余智如此四辩成就法方便。义方便。经方便。辞方便。应方便。过去方便。未来方便。过去未来方便。若彼成就此四辩。若有人欲尽此经义。无有是处。是名四辩

云何作智非离智。若非圣有报。是名作智非离智。云何离智非作智。若圣有报能断烦恼。是名离智非作智。云何作离智。无一智若作若离。彼若作智非离智离智非作是名作离智。云何非作非离智。除作离智。若余智是名非作非离智。复次作智非离。若欲界有报。是名作智非离。云何离智非作。若圣有报。能断烦恼。是名离智非作。复次作离智。若智生断欲界烦恼。受色界无色界有。是名作离智。复次非作非离智。若智无报。若智圣有报非断烦恼。是名非作非离智。有染无染有扼无扼亦如是

云何智果智非断果智。若智生已生智非断烦恼。是名智果智非断果智。云何断果智非智果。若智生断烦恼非智生。是名断果智非智果。云何智果断果智。若智生已智生断烦恼。是名智果断果智。云何非智果非断果智。除智果断果智。若余智。是名非智果非断果智。复次智果智非断果。若智生得非圣五通。若非圣五通。或得若一若二。是名智果智非断果。复次断果智非智果。若智生得斯陀含果。是名断果智非智果。复次智果断果智。若智生得须陀洹果斯陀含果阿那含果阿罗汉果。是名智果断果智。复次非智果非断果智。若智无报。若智有报。非智生非能断烦恼。是名非智果非断果智。智果得果亦如是

云何尽智非觉。若智生尽烦恼非觉智。除尽智若余智。是名尽智非觉。云何觉智非尽若智生得非圣五通或若一若二。是名觉智非尽。云何尽觉智。若智生得须陀洹果斯陀含果阿那含果阿罗汉果。是名尽觉智。云何非尽非觉智。若无报。若智有报。非能断烦恼非生智。是名非尽非觉智。解脱亦如是

舍利弗阿毗昙论卷第九舍利弗阿毗昙论卷第十

        姚秦罽宾三藏昙摩耶舍共昙摩崛多等译

    非问分智品第四之二

云何退分智。若智不善。是名退分智。云何住分智。若智无记。是名住分智。云何增长分智。若智非圣善。是名增长分智。云何解分智。若智圣有报能断烦恼。是名解分智。云何退分智。若智生退于非圣善法非住非增长。是名退分智。云何住分智。若智生于非圣善法住不退不增长。是名住分智。云何增长分智。若智生增长非圣善法不退不住。是名增长分智。云何解分智。若共解解相应。是名解分智。云何退分智非住分智。若有退非住。是名退分智非住分。云何住分智非退分智。若有住非退。是名住分智非退。云何退分住分智。无一智退分住分智。彼若住分智非退分。若退分者非住分。是名退分住分智。云何非退非住分智。除退分住分智。若余智见。名非退非住分智。云何退分智非增长分智。若有退非增长。是名退分智非增长。云何增长分智非退。智若增长非退。是名增长分智非退。云何退分增长分智。无一智退分增长分。彼若退分非增长分智。增长分智非退分。是名退分增长分智。云何非退分非增长分智。除退分增长分智。若余智是名非退分非增长分智。云何住分智非解分智。若有住分非解。是名住分智非解。云何解分智非住分智。若有解非住。是名解分智非住。云何住分解分智无一智。若住分解分。若住分智非解分解分智非住分。是名住分解分智。云何非住分非解分智。除住分解分智。若余智。是名非住分非解分智。云何增长分智非解分智。若有增长非解。是名增长分智非解分。云何解分智非增长分智。若有解非增长。是名解分智非增长分。云何增长分解分智。无一智若增长分解分。若增长分智非解分解分智非增长分。是名增长分解分智。云何非增长分非解分智。除增长分解分智。若余智。是名非增长分非解分智

云何五智。如世尊说。修无量义定心等明照。比丘修此定已。无量义定心等明照已。内五智生。何等五。此定现世乐后受乐报内生智。此定圣无染内生智。此定圣人亲近内生智。此定寂静胜妙圣心得解脱得除恶法内生智。忆念入此定忆念出此定内生智。修定无量无量心等明照。比丘修定已。无量心等明照生此五智。是名五智

云何六通。神足智证通。天耳智证通。观心心数法智证通。忆念宿命智证通。众生生死智证通。漏尽智证通。云何神足智证通。若智生受无量神足动大地。以一为多以多为一。近处远处墙壁山崖通达无碍如虚空。结加趺坐。往来空中如飞鸟。入地如水履水如地。身出烟焰如大火聚。日月神力威德难量手能扪摸。乃至梵天身得自在。是名神足智证通。云何天耳智证通。若智生天耳过于人耳。闻二种声。人非人声。是名天耳智证通。云何观心心数法智证通。若智生知他众生他人心心数。若有欲心如实知有欲心。无欲心如实知无欲心。有恚心如实知有恚心。无恚心如实知无恚心。有痴心如实知有痴心。无痴心如实知无痴心。疾心如实知疾心。乱心如实知乱心。少心如实知少心。贵心如实知贵心。不定心如实知不定心。定心如实知定心。非解脱心如实知非解脱心。解脱心如实知解脱心。有胜心如实知有胜心。无胜心如实知无胜心。是名观心心数智证通。云何忆念宿命智证通。若智生忆念无量若干宿命。忆念一生二三四五十二十三十四十五十百千生万生十万生无量十生无量百生无量千生无量百千万生。乃至若劫成劫坏若劫成坏。无量劫成无量劫坏无量劫成坏。我本在彼。如是名如是姓如是生。如是食如是命。如是久寿如是短寿。如是受苦乐。从彼死生彼。从彼死生彼已后从死生彼。从死生此。如是有行成就。忆念若干宿命。是名宿命智证通。云何众生生死智证通。若智生天眼清净过人。见众生生死好色恶色善道恶道卑胜。知众生如所造业。众生身恶行成就。口恶行成就。意恶行成就。谤圣人邪见行。缘邪见故。身坏命终生恶道地狱畜生饿鬼。众生身善行口善行意善行成就。不谤圣人正见行。缘正见故。身坏命终生善道天上人中。如是天眼清净过人。是名众生生死智证通。云何漏尽智证通。若智生有漏尽得无漏心解脱慧解脱。现世自证知成就行。我生已尽梵行已立。所作已办不复还有。是名漏尽智证通。是名六通

云何七方便。如世尊说。比丘七处方便三种观。此法中纯善远闻。谓尊丈夫。云何比丘有七处方便。如比丘。知色知色集知色灭知色灭道。知色味。知色过患知色出。知受知受集知受灭知受灭道。知受味知受过患知受出。知想知想集知想灭知想灭道。知想味知想过患知想出。知行知行集知行灭知行灭道。知行味知行过患知行出。知识知识集知识灭知识灭道。知识味知识过患知识出云何比丘知色。如比丘四大四大所造色如实知。比丘如是知色。云何比丘知色集。如比丘以爱集知色。如是比丘知色知色集。云何比丘知色灭。如比丘爱灭以爱灭知色灭。比丘如是知色灭。云何比丘如实知色灭道。如比丘如实知八圣道正见正觉正语正业正命正精进正念正定。如是比丘如实知色灭道。云何比丘知色味。若缘色生喜乐是色味。如是比丘知色味。云何比丘知色过患。若色无常苦变异法是色过患。如是比丘知色过患。云何比丘知色出。若色欲染调伏欲染断灭是出。如是比丘知色出。若有沙门婆罗门。如是知色知色集知色灭知色灭道。知色味知色过患知色出。若厌色离欲灭趣道。若善趣若善趣人。于是法中明了。及余沙门婆罗门。如是知色知色集知色灭知色灭道。知色味知色过患知色出。若厌色离欲证灭解脱不复生。善解脱若善解脱人。纯善若纯善人。无复生处云何比丘知受。六受身。眼触受耳鼻舌身意触受。是名六受身。比丘如是知受。云何比丘知受集。如比丘以触集知受集。如是知受集。云何比丘知受灭。如比丘以触灭知受灭。如是比丘知受灭。云何比丘知受灭道。如比丘如实知八圣道正见正觉正语正业正命正进正念正定。如是比丘知受灭道。云何比丘知受味。若缘受生喜乐是受味。如是比丘知受味。云何比丘知受过患。受无常苦变异法是受过患。如是比丘知受过患。云何比丘知受出。受欲染调伏欲染断灭是受出。如是比丘知受出。若有沙门婆罗门。如是知受知受集知受灭知受灭道。知受味知受过患知受出。厌受离欲证灭趣道。善趣若善趣人。于是法中明了。及余沙门婆罗门。如是知受知受集知受灭知受灭道。知受味知受过患知受出。厌受离欲证灭解脱不复生。善解脱若善解脱人。纯善若纯善人。无复生处

云何比丘知想。六想身。色想声香味触法想。是名六想身。如是比丘知想。云何比丘知想集。如比丘以触集知想集。如是比丘知想集。云何比丘知想灭。比丘以触灭知想灭。如是比丘知想灭。云何比丘知想灭道。如比丘如实知八圣道正见乃至正定。如是比丘知想灭道。云何比丘知想味。若缘想生喜乐是想味。如是比丘知想味。云何比丘知想过患。想无常苦变异法是想过患。如是比丘知想过患。云何比丘知想出。若想欲染调伏欲染断灭是想出。如是比丘知想出。若有沙门婆罗门。如是知想知想集知想灭知想灭道。知想味知想过患知想出。厌想离欲证灭趣道。善趣若善趣人。于是法中明了。及余沙门婆罗门。如是知想知想集知想灭知想灭道。知想味知想过患知想出。厌想离欲证灭解脱不复生。善解脱若善解脱人。纯善若纯善人。无复生处

云何比丘知行。六思身。色思声香味触法思。是名六思身。如是比丘知行。云何比丘知行集。如比丘以无明集知行集。如是比丘知行集。云何比丘知行灭。如比丘以无明灭知行灭。如是比丘知行灭。云何比丘知行灭道。如比丘如实知八圣道正见乃至正定。如是比丘如实知行灭道。云何比丘知行味。若缘行生喜乐是行味。如是比丘知行味。云何比丘知行过患。行无常苦变异法。是行过患。如是比丘知行过患。云何比丘知行出。若行欲染调伏欲染断灭。如是比丘知行出。若有沙门婆罗门。如是知行知行集知行灭知行灭道。知行味知行过患知行出。厌行离欲证灭趣道。善趣若善趣人。于是法中明了。及余沙门婆罗门。如是知行知行集知行灭知行灭道。知行味知行过患知行出。厌行离欲证灭解脱不复生。善解脱若善解脱人。纯善若纯善人。无复生处

云何比丘知识。六识身。眼识身耳鼻舌身意识身。是六识身。如是比丘知识。云何比丘知识集。如比丘以名色集知识集。如是比丘知识集。云何比丘知识灭。如比丘以名色灭知识灭。如是比丘知识灭。云何比丘知识灭道。如比丘如实知八圣道正见乃至正定。如是比丘知识灭道。云何比丘知识味。缘识生喜乐是识味。如是比丘知识味。云何比丘知识过患。识无常苦变异法。是识过患。如是比丘知识过患。云何比丘知识出。若识欲染调伏欲染断灭。是识出。如是比丘知识出。若有沙门婆罗门。如是知识知识集知识灭知识灭道。知识味知识过患知识出。厌识离欲证灭趣道。善趣若善趣人。于是法中明了。及余沙门婆罗门。如是知识知识集知识灭知识灭道。知识味知识过患知识出。厌识离欲。证灭解脱不复生。善解脱若善解脱人。纯善若纯善人。无复生处。如是比丘七处方便。云何比丘三种观。如比丘观界观入观缘。如是比丘三种观。七处方便三种观。比丘于是法中纯善远闻。谓尊丈夫。是名七处方便

云何苦法智。若有漏有为苦谛所摄法。若见苦若见无我思惟苦。于圣无漏智非比类智相无余。是名苦法智。云何苦比智。若人已行生苦法智。及余苦谛所摄法中。如彼生如彼相。如彼比类。此如彼彼如此。若于彼圣无漏智比类智相无余。是名苦比智。云何集法智。若苦因苦绪苦集。若见集见无我思惟集。于圣无漏智非比类智相无余。是名集法智云何集比智。若人以行生集法智。及余集谛所摄法中。如彼生如彼相。如彼比类。此如彼彼如此。于圣无漏智比类智相无余。是名集比智。云何灭法智。若尽苦尽烦恼尽漏法中。若见灭见无我思惟灭。于圣无漏智非比类智相无余。是名灭法智。云何灭比智。若人已行生灭法智。及余灭谛所摄法中。如彼生如彼相。如彼比类。此如彼彼如此。若于圣无漏智比类智相无余。是名灭比智。云何道法智。若圣道出要正灭苦法中。见道见无我思惟道。于圣无漏智非比类智相无余。是名道法智。云何道比智。若人以法行生道法智。及余道谛所摄法中。如彼生如彼相如彼比类。此如彼彼如此。于圣无漏智比类智相无余。是名道比智

云何九方便。定定方便。定入定方便。定住方便。出定方便。定境界方便。定行处方便。定乐方便。转定方便。顺不顺法善法相善思惟善解。云何定定方便。定定众。定定名字。定定触定定思惟。是有觉有观定。是无觉有观定。是无觉无观定。是空定是无相定是无愿定。是定若知见解射方便。云何定入定方便。入定众。入定名字。入定触。入定思惟。是有觉有观。是无觉有观。是无觉无观定。是空无相无愿定。入定入是定。入是定已是法胜入定。若知见解射方便。是名定入定方便。云何定住方便。定住众。定住名字。定住触。定住思惟。是定住有觉有观。是无觉有观。是无觉无观。是空无相无愿定。是定住定住已。是法胜定住。若知见解射方便。是名定住方便。云何出定方便。出定众。出定名字。出定触。出定思惟。是出定有觉有观。是无觉有观。是无觉无观。是空是无相是无愿。是出定。是出定已。是法胜出定。若知见解射方便。是名出定方便。云何定境界方便。若思惟法定生。若法是定境界。若知见解射方便。名定境界方便。云何定行处方便。定行谓四念处。若知见解射方便。是名定行处方便。云何定乐方便。定乐谓除乐众。定乐名字。定乐触。定乐思惟。是有觉有观定乐。是无觉有观。是无觉无观。是空是无相是无愿定。是定乐。是法胜定乐。若知见解射方便。是名定乐方便。云何转定方便。于初禅心起入二禅心住。于初禅心起入三禅心住。于初禅心起入四禅心住。于二禅心起入三禅心住。于二禅心起入四禅心住。于三禅心起入四禅心住。若知见解射方便。是名转定方便。何谓善取。顺不顺法相善思惟善解。云何非定顺法若法不善。是名非定顺法。云何定顺法。若法善。是名定顺法。复次非定顺法。若法有胜。是名非定顺法。复次定顺法。若法无胜。是名定顺法。复次非定顺法。若思惟法定不生。是名非定顺法。复次定顺法。若思惟法定生。是名定顺法。善取法相善思惟善解。是谓善取顺不顺法。相善思惟善解。是名九方便

云何如来十力。处非处智如来力。过去未来现在业受业处因报智如来力。他众生他人根胜非胜智如来力。他众生他人若干解智如来力。若干界无量世界智如来力。一切道至处智如来力。禅解脱定入定垢净起智如来力。忆念宿命证智如来力。众生生死证智如来力。有漏尽智如来力。何谓处非处如来力。云何处非处。非处谓身行恶口行恶意行恶。谓受爱喜适意报非处。若身行恶口行恶意行恶。受不喜不爱不适意报有是处。非处谓身行善口行善意行善。谓受不爱不喜不适意报非处。若身行善口行善意行善。受爱喜适意报有是处。非处谓身行不善口行不善意行不善。成就谤圣人邪见业。故彼因缘身坏命终。生善道人天中非处。若身行不善口行不善意行不善。成就谤圣人邪见行。缘邪见业故彼因缘故身坏命终。生恶道地狱中有是处。非处若身善行口善行意善行。成就不谤圣人正见行。缘正见业因缘故。身坏命终生恶道地狱中非处。若身善行口善行意善行。成就不谤圣人正见行。缘行正见业因缘故。身坏命终。生善道人天中有是处。非处若见具足人故断母命无有是处。是处若凡夫人故断母命有是处。非处若见具足人。故断父命。无有是处。是处若凡夫人故断父命有是处。非处若见具足人。故断罗汉声闻命无是处。是处若凡夫人。故断罗汉命有是处。非处若见具足人破众僧。无有是处。是处若凡夫人破众僧有是处。非处若见具足人。于如来身恶心出血无有是处。是处若凡夫人。于如来身恶心出血有是处。非处若见具足人。于是法外求余尊胜。无有是处。是处若凡夫人。于是法外求余尊胜有是处。非处若见具足人。于是法外求余受供养者。无有是处。是处若凡夫人。于是法外求余受供养者有是处。非处若见具足人。于是法外求余沙门婆罗门说正见。无有是处。是处若凡夫人。于是法外求余沙门婆罗门说正见有是处。非处若见具足人。于是法外若余沙门婆罗门说法。赞言此一切智一切见。无有是处。是处若凡夫人。于是法外若余沙门婆罗门说法。赞言此一切智一切见有是处。非处若见具足人。若于是法外若有沙门婆罗门。异缘实我世常。此实余虚妄。我世非常。此实余虚妄。我世常非常。此实余虚妄。我世非常非无常。此实余虚妄。我世有边。此实余虚妄。我世无边。此实余虚妄。我世有边无边。此实余虚妄。我世非有边非无边。此实余虚妄。命是身。此实余虚妄。身是命。此实余虚妄。身命异。此实余虚妄。无命无身。此实余虚妄。有如去涅槃。此实余虚妄。无如去涅槃。此实余虚妄。有如去无如去涅槃。此实余虚妄。非有如去非无如去涅槃。此实余虚妄。异缘实为真实。无有是处。是处若凡夫人。若于是法外。若沙门婆罗门有异缘实我世常。此实余虚妄。乃至非有如去非无如去涅槃。异缘实为真实有是处。非处

舍利弗阿毗昙论卷第十舍利弗阿毗昙论卷第十一

        姚秦罽宾三藏昙摩耶舍共昙摩崛多等译

    非问分智品第四之余

若见具足人。若以戒盗为净。邪缘求吉。堕地狱畜生饿鬼。受第八人身无有是处。是处若凡夫人。以戒盗为净。邪缘求吉。堕地狱畜生饿鬼。受第八人身有是处。非处未曾有二转轮圣王出世。有者无是处。是处。曾有一转轮圣王出世。有是处。非处若转轮圣王生边国。无有是处。是处若转轮圣王生于中国。有是处。非处若转轮圣王生于卑贱家若旃陀罗家及诸工师家。若聋盲喑哑挛躄跛蹇。偏枯身不具足及余病。无有是处。是处若转轮圣王生尊贵家。若刹利大姓家。若婆罗门大姓家。若长者大姓家。若端正姝妙。身相成就有是处。非处若转轮圣王生贫贱家。多所乏少无有财产饮食衣服。无有是处。是处若转轮圣王生多财家。有金银钱财玉贝珊瑚摩尼真珠琉璃象马车乘僮使谷帛仓库盈满有是处。非处未曾有二如来无所著等正觉出世。无有是处。是处若一如来无所著等正觉出世有是处。非处若如来无所著等正觉生于边国。无有是处。是处若如来无所著等正觉。生于中国。有是处。非处若如来无所著等正觉。生于卑贱家。若旃陀罗家。及诸工师家。聋盲喑哑挛躄跛蹇。偏枯不具足及余病。无有是处。是处若如来无所著等正觉。生尊贵家。若刹利大姓家。婆罗门大姓家。端正姝妙颜色第一。身相成就有是处。非处若如来无所著等正觉生贫贱家。多有所乏饮食衣服。无有是处。是处若如来。无所著等正觉生多财宝家。金银钱财玉贝珊瑚摩尼真珠琉璃象马车乘僮使谷帛仓库盈溢有是处。非处若女人为转轮圣王。无有是处。是处若男子为转轮圣王有是处。非处若女人为如来无所著等正觉。无有是处。是处若男子为如来无所著等正觉有是处。非处若女人为天帝释为魔王为梵王无有是处。是处若男子为天帝释为魔王为梵王。有是处。非处如无因如无门。如无物。如无悕望如无有。如是非处。知因门物悕望如有有。如是处非处。如来如实知。如是如来处非处。如实分别。如实解。如是缘慧知见解射方便。是名处非处智如来力。何谓如来力。如来此处由智力。尊自在胜尊最上无胜善人大人。如来如此力成就。所欲处如所欲尽所欲入定出定。是谓如来力

何谓过去未来现在业受业处因报智如来力。云何过去业。若业生已灭。是名过去业。何等未来业。若业未生未出。是名未来业。何等现在业。若业生未灭。是名现在业。何等业。思业思已业。故作业非故作业。受业非受业。少受业多受业熟业非熟业。色业非色业。可见业不可见业。有对业无对业。圣业非圣业。是名业。云何受业。如世尊说。四受业。有受业现苦后有苦报。有受业现在乐后有苦报。有受业现苦后有乐报。有受业现乐后有乐报。何等受业现苦后有苦报。若有人忍忧忍苦杀生。缘杀生故。以种种心受忧苦忍忧忍苦。窃盗邪淫妄言两舌恶口绮语。贪着嗔恚邪见。缘邪见故以种种心受忧苦。身坏命终生恶道地狱。此受业现苦后有苦报。何等受业现乐后有苦报。若人忍喜忍乐杀生。缘杀生故。以种种心忍喜忍乐。乃至邪见。缘邪见故。以种种心忍喜忍乐。身坏命终堕恶道地狱。此受业现乐后有苦报。何等受业现苦后有乐报。若人忍忧忍苦不杀生。缘不杀生故。以种种心受忧苦。忍忧忍苦。不窃盗不邪淫不妄语不两舌不恶口不绮语。不贪着不嗔恚正见。缘正见行故。以种种心受忧苦。身坏命终生善道天上。此受业现苦后有乐报何等受业现乐后有乐报。若人忍喜忍乐。不杀生。缘不杀生故。以种种心受喜乐。忍喜忍乐乃至正见缘。正见故。以种种心忍喜乐。身坏命终生善道天上。此受业现乐后有乐报。是名受业。复次以业受业教取教取已受报。是谓过去未来现在业受业何谓处。若身恶行口恶行意恶行。受不爱不喜不适意报。是谓处。若身善行口善行意善行。受爱喜适意报。是谓处。若身恶行口恶行意恶行。成就谤圣人邪见行。缘邪见业因缘故。身坏命终堕恶道地狱。是谓处。若身善行口善行意善行。成就不谤圣人正见行。缘正见业因缘故。身坏命终生善道天上。是谓处。若凡夫人故断母命。故断父命罗汉声闻命。故破众僧。故于如来身恶心出血。是谓处。若凡夫人。于是法外求余尊胜。求余受供养。求余沙门婆罗门说正见。赞余沙门婆罗门言。是一切智一切见。是谓处。若凡夫人。于是法外若有沙门婆罗门异缘实我世常。此实余妄语。乃至非有如去非无如去涅槃。以异缘实为真实。是谓处。若凡夫人以戒盗为净。以邪缘求吉。堕地狱畜生饿鬼。受第八人身。是谓处。若一转轮圣王。若转轮圣王生于中国。若转轮圣王生尊贵家。若刹利大姓家。若婆罗门大姓家。若长者大姓家。若端正姝妙身相成就。若转轮圣王生多财宝金银珂贝珊瑚摩尼真珠琉璃象马车乘僮使谷帛仓库盈满。是谓处。若一如来无所著等正觉出世。若如来无所著等正觉生于中国。若如来无所著等正觉生尊贵家刹利大姓家婆罗门大姓家。端正姝妙身相成就。若如来无所著等正觉生多财宝家。有金银钱财玉贝象马车乘僮使谷帛仓库盈满。是谓处。若男子为转轮圣王。若男子为如来无所著等正觉。若男子为天帝释为魔王为梵王。是谓处。复次如来说。如此时地狱中住。如此时畜生中住。如此时饿鬼中住。如此时人中住。如此时天上住。是谓处。何谓因。若业因贪。若业因恚。若业因痴。若业因不贪。若业因不恚。若业因不痴。是谓因。复次色有此因此方便。受想行识有此因此方便。入初禅定。有此因此方便。入第二第三第四禅定。断恶法成就善法。是谓因。何谓报。若业受业五道中受报。地狱畜生饿鬼人天色受想行识是谓报。彼过去未来现在业受业处因报。如来如实知。如是如来过去未来现在受业处因报如实知。如实分别如实解。如是缘慧知见解射方便。是名过去未来现在业受业处因报智如来力。何谓如来力。如来此处由智力尊自在胜尊最上无胜善人大人。如来如此力成就。所欲处如所欲尽所欲。入定出定。是谓如来力

何谓他众生他人根胜非胜智如来力。云何他众生他人。除诸佛世尊。若余众生。是名他众生他人。云何根。二十二根。眼根耳根鼻根舌根身根男根女根。命根乐根苦根喜根忧根舍根意根信根进根念根定根慧根未知欲知根知根已知根。是名根。云何非胜根。若根不善。是名非胜根。云何胜根。若根善。是名胜根。复次非胜根。若根非是圣。是名非胜根。复次胜根。若根圣。是名胜根。复次非胜根。若根圣软。是名非胜根。复次胜根。若根圣利。是名胜根。如来于他众生他人根胜非胜如实知。此众生利根软根善敬善解。恐后沉没如金刚。以不闻法便退。当有知法者。譬如优钵罗花池波头摩华池拘头摩华池分陀利华池。若优钵罗华波头摩华拘头摩华分陀利华。有优钵罗华钵头摩华拘头摩华分陀利华。从泥出未出水。有优钵罗华钵头罗华拘头摩华分陀利华。从泥出与水等。有优钵罗华钵头摩华拘头摩华分陀利华。已出水空中住不着水。如是如来他众生他人根胜非胜如实知。此众生利根软根善敬善解。恐后沉没如金刚。以不闻法便退。当有知法者。此众生若根成就有断母命。有断父命。有断阿罗汉声闻命。有破众僧。有于如来身恶心出血。此众生若根成就。有于是法外若求余尊胜。有求余受供养者。谓余沙门婆罗门能说正见。有赞叹余沙门婆罗门。此是一切智一切见。此众生若根成就。有于是法外。若有余沙门婆罗门。异缘实我世常余虚妄。乃至非有如去非无如去涅槃。比实余虚妄。谓异缘实为真实。此众生若根成就。有以戒盗为净邪缘求吉。堕地狱畜生饿鬼。受第八人身。此众生若根成就。有生刹利大姓家婆罗门大姓家居士大姓家。此众生若根成就。有生四天王三十三天焰天兜率天化乐天他化自在天。此众生若根成就。有生梵天梵辅天梵众天大梵天。此众生若根成就。生光天少光天无量光天光音天。此众生若根成就。生净天少净天无量净天遍净天。此众生若根成就。生实天少实天无量实天果实天。此众生若根成就。有生无想天。此众生若根成就。有生无胜天无热天善见天妙善见天阿迦腻吒天。此众生若根成就。有生空处天识处天不用处天非想非非想处天。此众生若根成就。有离欲恶不善法有觉有观。离生喜乐。成就初禅行。此众生若根成就。有灭觉观。内正信一心。无觉无观定生喜乐。成就二禅行。此众生若根成就。有离喜舍行念智身受乐。如诸圣人说舍念乐行。成就第三禅行。此众生若根成就。有断苦乐先灭忧喜。不苦不乐舍念清净。成就四禅行。此众生若根成就。有离一切色想灭嗔恚想。不思惟若干想。成就无边空处行。此众生若根成就。有离一切空处。成就无边识处行。此众生若根成就。有离一切识处。成就不用处行。此众生若根成就。有离一切不用处。成就非想非非想处行。此众生若根成就。有受无量若干神足能动大地。如以一为多以多为一。乃至梵天身得自在。此众生若根成就。有天耳清净过人闻二种声。人声非人声。此众生若根成就。有知他众生他人心。有欲心如实知有欲心。无欲心如实知无欲心。乃至知有胜心如实知有胜心。无胜心如实知无胜心。此众生若根成就。有忆念若干宿命。念一生二生三生。乃至成就此行。此众生若根成就。天眼清净过人。见众生生死好色恶色善道恶道卑胜。乃至如实知众生所造业。此众生若根成就。有上正决定得须陀洹果斯陀含果阿那含果得阿罗汉果。此众生若根成就。有力由有力自在成就行。此众生若根成就。无有断母命。乃至由力自在成就行。如来如此他众生他人根胜非胜。如实选择分别缘慧。知见解射方便。是名他众生他人根胜非胜智如来力。何谓如来力。彼如来此处由智力尊自在。力胜力最胜最上无过者。善人大人。如来此力成就。所欲处如所欲尽所欲。出定入定。是谓如来力。何谓他众生他人若干解智如来力。云何他众生他人。除诸佛世尊。若余众生。是名他众生他人。云何解。若心向彼心至彼。尊上彼解彼。是名解。如来他众生他人。如实知若干解。此众生有解卑有解胜。众生有解恶有解善有解生死。有解涅槃。众生有解色。有解声香味触法。众生有解刹利大姓婆罗门大姓居士大家。众生有解四大天王天三十三天焰天兜率天化乐天他化自在天。众生有解梵天梵辅天梵众天大梵天。众生有解光天少光天无量光天光音天。众生有解净天少净天无量净天遍净天。众生有解实天少实天无量实天果实天。众生有解无想天。众生有解无胜天无热天善见天妙善见天阿迦腻吒天。众生有解空处天识处天不用处天非想非非想处天。众生有解入初禅第二第三第四禅。众生有解入空处定识处定不用处定入非想非非想处定。众生有解神足证智。有解天耳证智。有解心择证智。有解忆念宿命证智。有解众生生死证智。众生有解上正决定得须陀洹果斯陀含果阿那含果阿罗汉果。众生有解由力尊自在。众生若能解见断母命。有断父命。有断阿罗汉声闻命。有破坏于僧。有于如来身恶心出血。众生若解有于是法外求余尊胜求堪受供养者。有赞余沙门婆罗门能说正见。赞余沙门婆罗门。此是一切智一切见。众生若能有于是法外有沙门婆罗门。异缘实我世常。此实余虚妄。乃至非有如去非无如去涅槃。此实余虚妄。众生若解有以戒盗为净。邪缘求吉。堕地狱畜生饿鬼。受第八人身。众生若解有生刹利大姓家婆罗门大姓家居士大家。众生若解生四天王天三十三天焰天兜率天化乐天他化自在天。众生若解有生梵天梵辅天梵众天大梵天。众生若解有生光天少光天无量光天光音天。众生若解有生净天少净天无量净天遍净天。众生若解有生实天少实天无量实天果实天。众生若解有生无想天。众生若解有生无胜天无热天善见天妙善见天阿迦腻吒天。众生若解有生空处天识处天不用处天非想非非想处天。众生若解有离欲恶不善法有觉有观离生喜乐成就初禅行。众生若解有灭觉观内净信一心无觉无观定生喜乐成就二禅行。众生若解有离喜舍行念知身受乐。如诸圣人解舍念乐行成就三禅行。众生若解有断苦乐先灭忧喜。不苦不乐舍念净成就四禅行。众生若解有离一切色想灭嗔恚想。不思惟若干想成就无边空处行。有离一切空处成就无边识处行。有离一切识处成就不用处行。有离一切不用处成就非想非非想处行。众生若解有获若干神足能动大地。以一为多以多为一。乃至梵天身自在。众生若解有天耳清净过人。闻二种声人非人声。众生若解有他众生他人知他众生心。有欲心如实知有欲心。无欲心如实知无欲心。乃至有胜心如实知有胜心。无胜心如实知无胜心。众生若解有忆念若干宿命。忆念一身二身三身。乃至此成就行。众生若解有天眼清净过人。见众生生死好色恶色善道恶道卑胜。乃至知众生如所造业。众生若解有上正决定得须陀洹果斯陀含果阿那含果阿罗汉果。众生若解由力尊自在。众生若解无有断母命。众生若解无有乃至由力尊自在。如是如来他众生他人若干解。如实选择分别缘慧。知见解射方便。是名他众生他人若干解智如来力。何谓如来力。如来此处由智力尊自在力胜力最胜最上无过者。善人大人。如来此力成就。所欲处如所欲尽所欲。出定入定。是谓如来力

何谓若干界无量界及世智如来力。云何若干界。色界非色界。乃至十八界。如界品说。是名无量界。云何世。有二种世。众生世行世。云何众生世。众生谓五道中生地狱畜生饿鬼人天中。是名众生世。云何行世。行谓五受阴。色受阴受想行识受阴。是名行世。如来于此若干无量界世如实知。如是如来若干界无量界及世。如实选择分别缘慧知见解射方便。是名若干界无量界世智如来力。何谓如来力。如来此处智由力尊自在力胜力最胜最上无有过者。善人大人。如来成就此力。所欲处如所欲尽所欲。出定入定。是谓如来力。何谓至一切道智如来力。云何至一切道无有一众生一法一智一道能至一切道。唯有如来报法。得名至一切道。如来如实知至一切道。若成此道行。能牵至短命久命。若成此道行。能牵至多病少病。若成此道行。能牵至卑贱尊贵。若成此道行。能牵至丑陋姝妙。若成此道行。能牵至少贱多贱。若成此道行。牵至少威德多威德。若成此道行。牵至无智慧有智慧。若成此道行。能牵至刹利大姓婆罗门大姓居士大家。若成此道行。牵至四天王天三十三天焰天兜率天化乐天他化自在天。多修行此道。牵至于梵天梵辅天梵众天大梵天。多修行此道行。牵至于光天少光天无量光天光音天。多修行此道。牵至于净天少净天无量净天遍净天。多修行此道。牵至实天少实天无量实天果实天。多修行此道。牵至无想天。多修行此道。牵至无胜天无热天善见天妙善见天阿迦腻吒天。多修行此道。牵至空处天识处天不用处天非想非非想处天。多修行此道。能入初禅定二禅三禅四禅定。多修行此道。能入空处定识处不用处非想非非想处定。多修行此道。得神足证智。得天耳证智。得心择证智。得忆念宿命证智。得众生生死证智此道苦难解。此道苦速解。此道乐难解。此道乐速解。多修行此道。能上正决定。得须陀洹果斯陀含果阿那含果阿罗汉果。多修行道。得由力尊自在。众生若行。有断母命。有断父命。有断阿罗汉声闻命。有破众僧有于如来身恶心出血。众生有于是法外求余尊胜。有求余供养者。有求余沙门婆罗门能说正见者。有赞余沙门婆罗门言是一切智一切见众生。若行有于是法外求余沙门婆罗门。异缘实我世常。此实余虚妄。我世非常。此实余虚妄。乃至非有如去非无如去涅槃。此实余虚妄。谓异缘实为真实。众生若行有以戒盗为净。邪缘求吉。堕地狱畜生饿鬼。受第八人身。众生若行有生刹利大姓家婆罗门大姓家居士大家。众生若行有生四天王天三十三天焰天兜率天化乐天他化自在天。众生若行有生梵天梵辅天梵众天大梵天。有生光天少光天无量光天光音天。众生若行有生净天少净天无量净天遍净天。众生若行有生实天少实天无量实天果实天。有生无想天。此众生若行有生无胜天无热天善见天妙善见天阿迦腻吒天。众生若行有生空处天识处天不用处天非想非非想处天。众生若行有离欲恶不善法。有觉有观离生喜乐。成就初禅行。有灭觉观内净信一心。无觉无观定生喜乐。成就二禅行。有离喜舍行念知身受乐。如诸圣人解舍念乐行。成就三禅行。有断苦乐先灭忧喜。不苦不乐舍念净。成就四禅行。众生若行有离一切色想灭嗔恚想。不思惟若干想成就无边空处行。有离一切空处成就无边识处行。有离一切识处成就不用处行。众生若行有离一切不用处成就非想非非想处行。众生若行有受无量若干神足能动大地。以一为多以多为一。乃至梵天身得自在。有天耳清净过人闻二种声。人非人声。有知他众生他人心。有欲心如实知有欲心。无欲心如实知无欲心。乃至有胜心如实知有胜心。无胜心如实知无胜心。若忆念无量若干宿命。一生二生三生。乃至成就法行。若天眼清净过人。观众生生死好色恶色善欲恶欲卑胜。乃至知众生如所造业。众生若行有得上正决定。得须陀洹果斯陀含果阿那含果阿罗汉果。众生若行为得由力尊自在。众生若行无有断母命。乃至无有得由力尊自在。如是如来至一切处道。如实选择分别缘慧知见解射方便。是名至一切处道智如来力。何谓如来力。如来此处由智力尊自在力胜力最胜最上无过者。善人大人。如来此力成就。所欲处如所欲尽所欲。出定入定。是谓如来力

何谓禅解脱定入定垢净起智如来力。云何禅。如比丘离欲恶不善法有觉有观离生喜乐。成就初禅行。灭觉观内净信一心。无觉无观定生喜乐。成就二禅行。离喜舍行念知身受乐。如诸圣人解舍念乐行。成就三禅行。断苦乐先灭忧喜。不苦不乐舍念净。成就四禅行。是名禅。云何解脱。色观色。初解脱。内无色想外观色二解脱。净解脱。三解脱。离一切色想。灭嗔恚想不思惟若干想。成就无边空处行。四解脱。离一切空处。成就无边识处行。五解脱。离一切识处。成就无所有处行。六解脱。离一切不用处。成就非想非非想处行。七解脱。离一切非想非非想处。成就灭受想行。八解脱。是名解脱。云何定。有觉有观定。无觉有观定。无觉无观定。空定无相定无愿定。是名定。云何入定。入想定无想定随想定不随想定不共色定共色定无胜定。一切入定。是名入定。云何垢。欲垢嗔恚垢愚痴垢烦恼垢障盖系缚恶行垢。及余垢法。若禅解脱定入定垢。不净不起不清不妙污染业无光明。是名垢。云何净。若欲尽嗔恚尽愚痴尽烦恼尽障盖系缚恶行尽。及余垢法尽。若禅解脱定入定无垢净。起清妙不污染业有光明。是名净。云何起。如初禅起心入二禅。如初禅起心入三禅。如初禅起心入四禅。如二禅起心入三禅。如二禅起心入四禅。如三禅起心入四禅。是名起。复次若净即是起。若起即是净。是谓净起。彼如来于禅解脱定入定垢净起如实知。如是如来于禅解脱定入定垢净起。选择分别缘慧知见解射方便。是名禅解脱定入定垢净起智如来力。何谓如来力。如来此处智力由尊自在力胜力最胜最上无过者。善人大人。如来此力成就。所欲处如所欲尽所欲。出定入定。是谓如来力

何谓忆念宿命智证如来力。如来忆念自及他若干宿命。忆念若一生二生三生四生五生。若十二十三十四十五十百生。若千生。百千生无量百生无量千生。若劫成若劫坏。若劫成坏。若无量劫成。无量劫坏。无量劫成坏。我本在彼。如是名如是姓如是生。如是饮食如是命。如是命长短。如是受苦乐。从彼终生彼。从彼终生此。成就行。忆念若干宿命。如人从自聚落至他聚落。在彼聚落。若行若住若坐若语若默。从彼聚落至余聚落在彼聚落。若行若住若坐若语若默。从彼聚落至余聚落。若行若住若坐若语若默。此人后时来至自聚落。忆念前一切聚落不以为难。我从自聚落至他聚落。我在彼聚落。如是行如是住如是坐。如是语如是默。我从彼聚落至余聚落。我在彼聚落。如是行如是住如是坐。如是语如是默。我从彼聚落复至余聚落。如是行如是住如是坐。如是语如是默。我还至自聚落。如是如来忆念自及他无量若干宿命。忆念若一生二生三生。乃至此成就行。如是如来忆念宿命智证。如实选择分别缘慧知见解射方便。是名忆念宿命智证如来力。何谓如来力。如来此处由智力尊自在力胜力最胜最上无过者。善人大人。此如来力成就。所欲处如所欲尽所欲。出定入定。是谓如来力。何谓众生生死智证如来力。如是如来以天眼清净过人。见众生生死好色恶色善道恶道卑胜。知众生如所造业。众生身恶行口恶行意恶行。成就谤圣人邪见行。缘邪见业故。身坏命终堕恶道地狱畜生饿鬼。此众生身善行口善行意善行。成就不谤圣人正见行。缘正见业故。身坏命终生善道天上人中。如是天眼清净过人。见众生生死好色恶色善道恶道卑胜。知众生如所造业。如聚落城邑中有高台。清净眼人在台上住。见东方众生西方往来周旋。见西方众生东方往来周旋。见南方众生北方往来周旋。见北方众生南方往来周旋。自见台边人出入往反周旋。如是如来天眼清净过人。见众生生死好色恶色善道恶道卑胜。乃至知众生如所造业。如是如来众生生死智证。如实选择分别缘慧知见解射方便。是名众生生死智证如来力。何谓如来力。如来此处由智力尊自在力胜力最胜最上无过者。善人大人如来此力成就。所欲处如所欲尽所欲出定入定。是谓如来力

何谓有漏尽智如来力。何谓有漏。七漏。见断漏。忍断漏。亲近断漏。远离断漏。调伏断漏。戒断漏。思惟断漏。是名漏。云何尽漏。若漏尽缘尽调伏缘调伏离正离舍吐断出。是名漏尽。如是如来身及他漏尽如实知如泉水清净不浊。若彼若有沙石螺蚌鼋龟鱼鳖于中游行。于泉水边。清净眼人。见彼明了。若沙石螺蚌鼋龟鱼鳖于中游行。彼人见此沙石螺蚌鼋龟鱼鳖于中游行。如是如来自及他漏尽如实知。如是如来漏尽智。如实选择分别缘慧知见解射方便。是名有漏尽智如来力。何谓如来力。此处由智力尊自在力胜力最胜最上无过者。善人大人如来此力成就。所欲处如所欲尽所欲出定入定。是谓如来力。此是如来十力

云何十二智性。如世尊说。诸比丘。当说十二智性。谛听谛听。善受善思惟。我当说。比丘言如是。诸比丘至心听。世尊如是说。何等十二智。比丘。此苦圣谛。先未闻法。我生智生眼生觉生明生术生慧生解。诸比丘当知。此苦圣谛。先未闻法。生智生眼生觉生明生术生慧生解。比丘。我知此苦圣谛已。先未闻法。生智生眼生觉生明生术生慧生解。比丘。此集圣谛。先未闻法。我生智生眼生觉生明生术生慧生解。诸比丘当知。此集圣谛当断。先未闻法。生智生眼生觉生明生术生慧生解。比丘。我断此集圣谛已。先未闻法。生智生眼生觉生明生术生慧生解。比丘。此灭圣谛。先未闻法。我生智生眼生觉生明生术生慧生解。诸比丘。当证此灭圣谛。先未闻法。生智生眼生觉生明生术生慧生解。比丘。我证此灭圣谛已。先未闻法。生智生眼生觉生明生术生慧生解。比丘。此道圣谛。先未闻法。我生智生眼生觉生明生术生慧生解。诸比丘。当修此道圣谛。先未闻法。生智生眼生觉生明生术生慧生解。比丘。我修此道圣谛已。先未闻法。生智生眼生觉生明生术生慧生解。比丘。此四圣谛三分十二行。我若不如实知者。不得无上正觉。亦不说言得。比丘。此四圣谛三分十二行。我如实知故。今得无上正觉。亦说言得。是名十二智性

云何四十四智性。如世尊说。比丘。我当说四十四智性。谛听谛听。善受善思惟。我当说。比丘言。如是世尊。诸比丘。至心听。世尊如是说。何等四十四智。如是比丘。知老死知老死集。知老死灭知老死灭道。生有取爱受触六入名色识。知行知行集。知行灭知行灭道。云何比丘知老死。云何老。谓诸众生。诸众中衰耗战掉面皱诸根熟命促行故是名老。云何死。谓诸众生。诸众生终没死尽除坏舍阴。此物变异离世。是名死。比丘。如是知老死。云何比丘知老死集。如比丘以生集知老死集。如是比丘知老死集。云何比丘知老死灭。如比丘以生灭知老死灭。如是比丘知老死灭。云何比丘知老死灭道。如比丘如实知八圣道。正见正觉正语正业正命正进正念正定。如是比丘知老死灭道。比丘若知老死知老死集。知老死灭知老死灭道。此是法智。比丘于现在智。明了常解以过去未来而取比类。如过去沙门婆罗门。已知老死。已知老死集。已知老死灭。已知老死灭道。彼一切已知。如我自知。如未来沙门婆罗门。当知老死苦。当知老死集。当知老死灭。当知老死灭道。彼一切当知如我自知。此是比智。比丘。若二智明了。谓法智比智。是谓比丘见解具足得堪忍得胜法得无畏。向此法调伏。知此法调伏。见此法调伏。学知学术流向法。于梵净行必能常住。于甘露门解射自在。云何比丘生有取爱受触六入名色识知行。云何行。三行。身行口行意行。是名行。如是比丘知行。云何比丘知行集。如比丘以无明集知行集。如是比丘知行集。云何比丘知行灭。如比丘以无明灭知行灭。如是比丘知行灭。云何比丘知行灭道。如比丘如实知八圣道。正见正觉正语正业正命正进正念正定。如是比丘知行灭道。比丘。如是知行知行集知行灭知行灭道。是谓法智。比丘。于现在智明了常解。以过去未来而取比类。如过去沙门婆罗门。已知行已知行集。已知行灭已知行灭道。彼一切已知如我自知。如未来沙门婆罗门。当知行当知行集。当知行灭。当知行灭道。若一切当知如我自知。是名比智。比丘。若二智明了。谓法智比智。是谓比丘见解具足得堪忍得胜法得无畏。向此法调伏。知此调伏。见此法调伏。学知学术成就流向法。于梵净行法必能常住。于甘露门解射自在。是名四十四智性

云何七十七智性。如世尊说。诸比丘。我当说七十七智性。谛听谛听。善受善思惟。我当说。比丘言。如是世尊。诸比丘。至心听。世尊如是说。云何七十七智。无明缘行智。无无明无行智。如过去无明缘行智。无无明无行智。如未来无明缘行智。无无明无行智。若法住智。彼亦尽法变法离欲法灭法。乃至生缘老死智。无生无老死智。如过去生缘老死智。无生无老死智。未来生缘老死智。无生无老死智。若彼法住智。亦尽法变法离欲法灭法。是名七十七智性(智品竟)

舍利弗阿毗昙论卷第十一舍利弗阿毗昙论卷第十二

        姚秦罽宾三藏昙摩耶舍共昙摩崛多等译

    非问分缘品第五

善缘方便善缘解有缘方便。圣忍非智有缘方便。圣智非忍有缘方便。受问答因俱生法若因此有此。若无因无此。若此生有此生。若此灭有此灭。若无明缘行。乃至生缘老死。忧悲苦恼苦聚成就。如是纯苦具足。无明灭则行灭。乃至生灭则老死忧悲苦恼聚灭。如是苦聚灭。是缘方便成就。若彼于过去缘疑惑。我过去有。我非过去有。何姓过去有。何因过去有。若于未来缘疑惑。我未来有。乃至何因未来有。若彼因缘疑惑。我云何有。我云何非有。何因有何生处。此众生从何来去至何处。若于佛疑惑。是佛世尊非佛世尊。世尊善说法。世尊不善说法。世尊声闻众善趣。世尊声闻众不善趣。行常行无常。行苦行非苦行。我法非我法。寂静涅槃非寂静涅槃。有与无与。有施无施。有祀无祀。有善恶业果报。无善恶业果报。有今世无今世。有后世无后世。有父母无父母。有天无天。众生有化生。众生无化生。世有沙门婆罗门正趣正至。若今世后世自证知说。世无沙门婆罗门正趣正至。若今世后世自证知说。若于法疑惑心不决定。犹豫二心疑心不了。无量疑不尽非解脱。彼时无有。若有沙门婆罗门。异缘实我世常。此实余虚妄。乃至如去不如去。彼时亦无有。何况圣缘方便成就。终无此烦恼垢

云何缘。如佛告诸比丘。我当说缘缘生法。云何缘。无明缘行。若诸佛出世若不出世。法住法界。住彼法界。如来正觉正解已。演说开示分别显现。说无明缘行乃至生缘老死。若如此法。如尔非不如尔。不异不异物。常法实法法住法定。如是缘是名缘。云何缘生法。老死无常。有为缘生尽法变异法。离欲法灭法。乃至无明无常有为缘生法尽法变异法。离欲法灭法。是名缘生法。云何缘方便。若彼缘若此缘生法。若见解射方便。是名缘方便。比丘。齐几名善缘方便。彼缘此缘生法。如实知如实见。齐是名善缘方便。云何无明。痴不善根。是名无明。云何无明缘行。无明缘福行非福行不动行。云何非福行。不善身行。不善口行。不善意行。云何不善身行。若人无慧无明不断。行杀盗淫。及余不善身行。是名不善身行。云何不善口行。若人无慧无明未断。行妄语两舌恶口绮语。及余不善口行。是名不善口行。云何不善意行。若人无慧无明未断。起贪欲嗔恚邪见。是名不善意行。此身口意不善行。名非福行无明缘现世行。云何福行。身善行口善行意善行。云何身善行。若人无慧无明未断。不杀盗淫。及余身善行。是名身善行。云何口善行。若人无慧无明未断。不妄语两舌恶口绮语。及余口善行。是名口善行。云何意善行。若人无慧无明未断。无贪无恚正见。是名意善行。此身口意善行。是名福行无明缘现世行。复次若人无慧无明未断。离欲恶不善法。有觉有观离生喜乐。成就初禅行。彼身业无教戒法入摄意识所知。口业无教戒法入摄意识所知。意业由意生受想思触思惟。如是身口意善行。是名福行无明缘现世行。复次若人无慧无明未断。灭觉观内信心。无觉无观定生喜乐。成就二禅行。彼身业无教戒法入摄意识所知。口业无教戒法入摄意识所知。意业由意生受想思触思惟。如是身口意业善行。是名福行无明缘现世行。复次若人无慧无明未断。离喜舍行念知身受乐。如诸圣人解舍念乐行。成就三禅行。彼身业无教戒法入摄意识所知。口业无教戒法入摄意识所知意业由意生受想思触思惟。如是身口意善行。是名福行无明缘现世行。复次若人无慧无明未断。断苦乐先灭忧喜。不苦不乐舍念净。成就四禅行。彼身业无教戒法入摄意识所知。口业无教戒法入摄意识所知。意业由意生受想思触思惟。如是身口意善行。是名福行无明缘现世行。是名福行。云何不动行。若人无慧无明未断。离一切色想。灭嗔恚想。不思惟若干想。成就无边空处行。彼身业无教戒法入摄意识所知。口业无教戒法入摄意识所知。意业由意生受想思触思惟。如是身口意善行。是名不动行无明缘现世行。复次若人无慧无明未断。离一切空处。成就无边识处行。彼身业无教戒法。入摄意识所知。口业无教戒法入摄意识所知。意业由意生受想思触思惟。如是身口意善行。是名不动行无明缘现世行。复次若人无慧无明未断。离一切识处。成就无所有处行。彼身业无教戒法。入摄意识所知。口业无教戒法。入摄意识所知。意业由意生受想思触思惟。如是身口意善行。是名不动行无明缘现世行。复次若人无慧无明未断。离一切无所有处。成就非有想非无想处行。彼身业无教戒法。入摄意识所知。口业无教戒法。入摄意识所知。意业由意生受想思触思惟。如是身口意善行。是名不动行无明缘现世行。是名不动行。复次若人无慧无明未断。作不善身口意行。作不善行故。身坏命终。堕地狱畜生饿鬼。以因绪缘故。堕地狱畜生饿鬼受五阴身。如是缘现世行受未来行。是名无明缘未来行。复次若人无慧无明未断。作有漏身善行。当受欲界生。作有漏口善行意善行。当受欲界生。作善行已身坏命终。若生人中欲界天上。以因绪缘故。人中欲界天上受五阴身。如是缘现世行受未来行。是名无明缘未来行。复次若人无慧无明未断。作有漏身善行。当受色界生。作有漏口善行意善行。当受色界生。作善行已身坏命终。生色界天上。以因绪缘故。色界天上受五阴身。如是缘现世行受未来行。是名无明缘未来行。复次若人无慧无明未断。作有漏身口意善行。当受无色界生。作善行已身坏命终生无色界天上。以因绪缘故。无色界天上受四阴身。如是缘现世行受未来行。是名无明缘未来行。如佛说。阿难。行有缘。如是阿难问已有答。行何缘。无明缘行。此是答。阿难。若无无明者有行不。世尊。无也。阿难。以因绪缘故行。若无明缘行。如向所说。以是故说

云何行缘识。有缘共欲思生共欲识。如是缘现在行生现在识。名行缘现在识。有共嗔恚。有共愚痴。无共欲无共嗔恚无共愚痴。善不善有缘无记思。有生无记识。如是缘现在行生现在识。是名行缘现在识缘眼缘色生识。彼眼行色行若缘识。如是缘现在行生现在识。是为现在行缘现在识。耳鼻舌身缘意缘法生识。彼意行法行若缘识。如是缘现在行生现在识。是名现在行缘现在识。复次若人无慧无明未断。起不善身行不善口行不善意行。作不善行已。身坏命终。堕地狱畜生饿鬼。以因绪缘故。生地狱畜生饿鬼。初识以业。因绪集缘。生眼识乃至意识及后了识。如是缘现在行生未来识。是为行缘未来识。复次若人无慧无明未断。作有漏身善行。当受欲界生。作有漏口意善行。当受欲界生。作善行已身坏命终。若生人中。若生欲界天上。以因绪缘故。若生人中。若生欲界六天。初识以业。因绪集缘。生眼识乃至意识及后了识。如是缘现在行生未来识。是为行缘识。复次若人无慧无明未断。行有漏身善行。当受色界生。作有漏口意善行。当受色界生。作善行已身坏命终。生色界天上。以因绪缘故。色界天上受初识业。因绪集缘。生眼识乃至意识及后了识。如是缘现在行生未来识。是名行缘未来识。复次若人无慧无明未断。作有漏身善行。当受无色界生。作有漏口意善行。当受无色界生。作善行已身坏命终。生无色界天上。以因绪缘故。无色界天上受初识业。因绪集缘。生意界意识界及后了识。如是缘现在行生未来识。是名行缘未来识。复次若人无慧无明未断。作身口意恶行。作恶行已身坏命终。堕地狱畜生饿鬼。以因绪缘故。地狱畜生饿鬼有不善思共彼思识。如是缘未来行受未来识。是名行缘未来识。复次若人无慧无明未断。作有漏身善行。当受欲界生。作有漏口意善行。当受欲界生。作善行已身坏命终。若生人中生欲界天上。由因绪缘故。若人中欲界天上。有善思共彼思识。如是缘未来行受未来识。是名行缘未来识。复次若人无慧无明未断。作有漏身善行。当受色界生。作有漏口意善行。当受色界生。作善行已身坏命终。生色界天上。以因绪缘故。生色界天上。有思共思识。如是缘未来行生未来识。是名行缘未来识。复次若人无慧无明未断。作有漏身善行。当受无色界生。作有漏口意善行。当受无色界生。作善行已身坏命终。生无色界天上。以因绪缘故。无色界天上有不动思共彼思识。如是缘未来行生未来识。是名行缘未来识。复次若最后行未知而灭。若无间行灭已。识续余道生。彼行彼缘无间缘。若因识续余道生。彼行缘彼识因缘。若思行彼识续余道生。彼行缘彼识境界缘。若彼行识续余道生。彼行缘彼识依缘。若报行识续余道生。彼行缘彼识报缘。若起行识续余道生。彼行缘彼识起缘。若行相应识续余道生。彼行缘彼识异缘。若行增上识续余道生。彼行缘彼识增上缘。此最后识灭。初识续余道生。最后识灭已。初识即生。无有中间。喻如影移日续日移影续。影之与日无有中间。如是最后识灭。初识续余道生。后识灭已。即受初识。无有中间。若最初识。若最后识相应法。不至后识。喻如眼识灭已生耳识。耳识灭已生眼识。眼识相应法不至耳识。耳识相应法不至眼识。如是最后识最后识相应法。不至初识。初识相应法不至后识。后识灭已即生初识。谓此时过。谓此灭彼生。谓此终彼始。非彼命彼身。非异命异身。非常非断。非去非来非变。非无因非无作。非此作此受。非异作异受。知有去来。知有生死。知有业相续。知有说法。知有缘。无有从此至彼者。无有从彼至此者。何以故。业缘相续生。如佛说阿难。识有缘。如是阿难问已有答。识有何缘行缘。此是答。阿难。若无行者当有识不。世尊。无也。以是阿难。此因绪缘识若行缘识。如向所说。以此故说

云何识缘名色。有缘共欲识生。有欲身业生。有欲口业生。有欲意业生。共有欲身业口业是谓色。共有欲意业。由意生受想思触思惟谓名。如是现在识生现在名色。是名识缘现在名色。共有嗔恚共有愚痴。无共欲无共嗔恚无共愚痴。善不善有缘无记识。无记身业口业意业。无记身业口业谓色。无记意业由意生受想思触思惟谓名。如是缘现在识生现在名色。是名现在识缘现在名色。复次若人无慧无明未断。作不善识。彼作不善识已。身坏命终堕地狱畜生饿鬼。以因绪缘故。生地狱畜生饿鬼名色。四大四大所造色。是色由意生受想思触思惟谓名。是名缘现在识生未来名色。是为识缘未来名色。复次若人无慧无明未断。作有漏善识。当受欲界生。作善识已。身坏命终若生人中。若生欲界天上。以因绪缘故。受人中若欲界天上名色。四大四大所造色。是色由意生受想思触思惟。是名如是缘现在识生未来名色。复次若人无慧无明未断。离欲恶不善法。有觉有观离生喜乐。成就初禅行彼喜乐。初禅尊上堪忍住喜乐。初禅尊上堪忍住已。识依乐取。彼身坏命终生色界天上。以因绪缘故。生色界天上名色。四大四大所造色。是色由意生受想思触思惟。是名如是缘现在识生未来名色。是名识缘未来名色。乃至复次若人无慧无明未断。离一切无所有处。成就非有想非无想处行喜乐。彼非有想非无想处尊上堪忍住喜乐。非有想非无想处尊上堪忍多住已。识依取乐多修行。身坏命终生非有想非无想处天上。以因绪缘故。生非想非非想处天上。名由意生受想思触思惟谓名。如是缘现在识生未来名是名识缘未来名。复次若人无慧无明未断。作不善身行不善口行不善意行。作不善行已。身坏命终生地狱畜生饿鬼。以因绪缘故。生地狱畜生饿鬼。初识共彼识名色。四大四大所造色。是色由意生受想思触思惟。是名如是缘未来识生未来名色。是名识缘未来名色。复次若人无慧无明未断。作有漏身口意善行。当受欲界生。作善行已。身坏命终若生人中欲界天上。以因绪缘故。生人中若欲界天上。初识共彼识名色。四大四大所造色。是色由意生受想思触思惟。谓名如是缘未来识生未来名色。是名识缘未来名色。复次若人无慧无明未断。作有漏身善行。当生色界。作有漏口善行意善行。当生色界。作善行已。身坏命终生色界天上。以因绪缘故生色界。初识共彼识名色。四大四大所造色。是色由意生受想思触思惟。是名如是缘未来识生未来名色。是名识缘未来名色。复次若人无慧无明未断。作有漏身善行。当生无色界。作有漏口善行意善行。当生无色界。作善行已。身坏命终生无色界天上。以因绪缘故。生无色界天上。初识共彼识名。由意生受想思触思惟。是名如是缘未来识生未来名。是名识缘未来名。如佛说。阿难。名色有缘。如是阿难问已有答。名色何缘。识缘名色此是答。阿难。识不入胎有名色生不。世尊。无也。阿难。识入胎不出有名色集不。世尊。无也。阿难。若婴儿识断坏非有。彼有名色增长广大不。世尊。无也。阿难。无一切识者。有名色不。世尊。无也。以是阿难以因绪缘名色。阿难。若识缘名色。如向所说。以是故说

云何名色缘六入缘抟食。现在眼根润益增长。耳鼻舌身意根润益增长。抟食谓色。由意生受想思触思惟谓名。如是缘现在名色生现在六入。是名名色缘现在六入。缘衣服洗浴调身。现在眼根润益增长。耳鼻舌身意根润益增长。衣服洗浴调身抟食谓色。由意生受想思触思惟谓名。如是缘现在名色生现在六入。是名名色缘现在六入。缘喜处色。现在眼根润益增长。耳鼻舌身意根润益增长。喜处色谓色。由意生受想思触思惟谓名。如是色缘现在六入。复次若有比丘阿罗汉。诸漏已尽所作已办。舍于重担己利具足。有烦恼尽正解脱已。受胜业成就。彼现在眼根润益增长。耳鼻舌身意根润益增长。若实人身业口业谓色。意业由意生受想思触思惟谓名。如是缘现在名色生现在六入。是名名色缘现在六入。复次若有比丘大神足大威力。于自身起心化作余色身。一切支节诸根成就。现在润益增长。眼根耳鼻舌身意根润益增长。若实人身业口业谓色。若实人意业由意生受想思触思惟谓名。如是缘现在名色生现在六入。是名名色缘现在六入。复次若有比丘得神足心得自在命。行住若一劫若减一劫。彼现在眼根润益增长。耳鼻舌身意根润益增长。若实人身业口业谓色。若实人意业由意生受想思触思惟谓名。如是缘现在名色生现在六入。是名名色缘现在六入。复次若人无慧无明未断。作不善身口意行。不善身行口行谓色。不善意行由意生受想思触思惟谓名。作不善名色已。身坏命终生地狱畜生饿鬼。以因绪缘故。生地狱畜生饿鬼眼耳鼻舌身意根。如是缘现在名色生未来六入。是名名色缘未来六入。复次若人无慧无明未断。作有漏身善行。当受欲界生。作有漏口善行意善行。当受欲界生。身善行口善行谓色。意善行由意生受想思触思惟谓名。作善名色已。身坏命终若生人中欲界天上。以因绪缘故。生人中欲界天上。眼耳鼻舌身意根。如是缘现在名色生未来六入。是名名色缘未来六入。复次若人无慧无明未断。离欲恶不善法。有觉有观离生喜乐。成就初禅行。若行人身业口业谓色。若行人意业由意生受想思触思惟谓名。彼作善名色已。身坏命终生色界天上。以因绪缘故。生色界天上眼耳身意根。如是缘现在名色生未来六入。是名名色缘未来六入。复次若人无慧无明未断。灭觉观内净信心。无觉无观定生喜乐。成就二禅行。若行人身口业谓色。若行人意业由意生受想思触思惟谓名。彼作善名色已。身坏命终生色界天上。以因绪缘故。生色界天上眼耳身意根。如是缘现在名色生未来六入。是名名色缘未来入。复次若人无慧无明未断。离喜舍行念智身受乐。如诸圣人能舍念乐行。成就三禅行。若行人身业口业谓色。若行人意业由意生受想思触思惟谓名。彼作善名色已。以因绪缘生色界天上眼耳身意根。如是缘现在名色生未来入。是名名色缘未来入。复次若人无慧无明未断。断苦乐先灭忧喜。不苦不乐舍念净。成就四禅行。若行人身业口业谓色。若行人意业由意生受想思触思惟谓名。作善名色已。身坏命终生色界天上。由因绪缘故。生色界天上眼耳身意根。如是缘现在名色生未来入。是名名色缘未来入。复次若人无慧无明未断。如是思惟。想是我患是痈箭。无想是寂静妙。能成就无。想定行。若行人身业口业谓色。无想定谓名。彼作善名色已。身坏命终生无想天上。以因绪缘故。生无想天上身根。如是缘现在名色生未来入。是名名色缘未来入。复次若人依圣共觉。离欲恶不善法。有觉有观离生喜乐。成就初禅行。若实人身业口业谓色。若实人意业由意生受想思触思惟谓名。彼作善名色已。身坏命终生净居天上。以因绪缘故。生净居天上眼耳身意根。如是缘现在名色生未来入。是名名色缘未来入。复次若人依圣共觉。灭觉观内净信心。无觉无观依定生喜乐。成就二禅行。若实人身业口业谓色。若实人意业由意生受想思触思惟谓名。彼作善名色已。身坏命终生净居天上。以因绪缘故。得净居天上眼耳身意根。如是缘现在名色生未来入。是名名色缘未来入。复次若人依圣共觉。离喜舍行念知身受乐。如诸圣人能舍念乐行。成就三禅行。若实人身业口业谓色。若实人意业由意生受想思触思惟谓名。彼作善名色已。身坏命终生净居天上。以因绪缘得净居天上眼耳身意根。如是缘现在名色生未来入。是名名色缘未来入。复次若人依圣共觉。断苦乐先灭忧喜。不苦不乐舍念净。成就四禅行。若实人身业口业谓色。若实人意业由意生受想思触思惟谓名。彼作善名色已。身坏命终生净居天上。以因绪缘得净居天上眼耳身意根。如是缘现在名色生未来入。是名名色缘未来入。复次若人无慧无明未断离一切色想。灭嗔恚想。不思惟若干想。成就无边空处行。若行人身业口业谓色。若行人意业由意生受想思触思惟谓名。彼作善名色已。身坏命终生空处天上。以因绪缘得空处天上意根。如是缘现在名色生未来入。是名名色缘未来入。复次若人无慧无明未断。离一切空处。成就无边识处行。若行人身业口业谓色。若行人意业由意生受想思触思惟谓名。彼作善名色已。身坏命终生识处天上。以因绪缘得识处天上意根。如是缘现在名色生未来入。是名名色缘未来入。复次若人无慧无明未断。离一切识处。成就无所有处行。若行人身业口业谓色。若行人意业由意生受想思触思惟谓名。彼作善名色已。身坏命终生无所有处天上。以因绪缘得无所有处天上意根。如是缘现在名色生未来入。是名名色缘未来入。复次若人无慧无明未断。离一切无所有处。成就非有想非无想处行。若行人身业口业谓色。若行人意业由意生受想思触思惟谓名。彼作善名色已。身坏命终生非有想非无想处天上。以因绪缘得非有想非无想处天上意根。如是缘现在名色生未来入。是名名色缘未来入。复次若人无慧无明未断。作不善身口意行。作不善行已。身坏命终堕地狱畜生饿鬼。以因绪缘得地狱畜生饿鬼名色。四大四大所造色。由意生受想思触思惟谓名。名色增长。得地狱畜生饿鬼眼耳鼻舌身意根。如是缘未来名色生未来六入。是名名色缘未来六入。复次若人无慧无明未断。作有漏身善行。当受欲界生。作有漏口善行意善行。当受欲界生。作善行已。身坏命终若生人中若欲界天上。以因绪缘得人中欲界天上名色。四大四大所造色。由意生受想思触思惟谓名。名色增长。得人中若欲界天上眼耳鼻舌身意根。如是缘未来名色生未来六入。是名名色缘未来六入。复次若人无慧无明未断。作有漏身善行。当受色界生。作有漏口善行意善行。当受色界生作善行已。身坏命终生色界天上。以因绪缘得色界天上名色。四大四大所造谓色。由意生受想思触思惟谓名。名色增长。得色界天上眼耳身意根。如是缘未来名色生未来入。是名名色缘未来入。复次若人无慧无明未断。作有漏身善行。当受无色界生。作有漏口善行意善行。当受无色界生。作善行已。身坏命终生无色界天上。以因绪缘得无色界天上名。由意生受想思触思惟谓名。名增长得无色界天上意根。如是缘未来名色生未来入。是名名色缘未来入。如佛说。阿难。六入有缘。如是阿难问已有答。六入何缘。名色缘六入此是答。阿难。无一切名色者。有六入不。世尊。无也。如是阿难。以因绪缘六入。阿难。名色缘六入。如向所说。以是故说

云何六入缘触。六入缘二触。身触心触。是名六入缘触。复次六入缘三触。乐触苦触不苦不乐触。是名六入缘触。复次六入缘三触。欲界系触色界系触无色界系触。是名六入缘触。复次六入缘五触五受根相应触。是名六入缘触复次六入缘六触。眼触耳鼻舌身意触。是名六入缘触。复次六入缘七触。眼识界相应触。耳鼻舌身意界意识界相应触。是名六入缘触。复次六入缘十八触。眼乐触苦触不苦不乐触。耳鼻舌身意乐触苦触不苦不乐触。是名六入缘触。如佛说。阿难。触有缘。如是阿难问已有答。触有何缘。六入缘触。此是答。阿难。若无六入者。有触不。世尊。无也。阿难。以因绪缘触。阿难。六入缘触。如向所说。以是故说

云何触缘受。触缘二受。身受心受。是名触缘受。复次触缘三受。乐受苦受不苦不乐受。是名触缘受。乃至触缘十八受。如上说。是名触缘受。如佛说。阿难。受有缘。阿难问已有答。受有何缘。触缘受此是答。阿难。若无一切触者有受不。世尊。无也。阿难。以因绪缘受。阿难。触缘受如向所说。以是故说

云何受缘爱。缘眼触乐受。生眼触乐受。彼触眼触乐受已。彼眼触乐受喜乐爱着堪忍住。是名受缘爱。复次缘眼触乐受。生眼触乐受。彼触眼触乐受已。于异眼触乐受悕望。若相似若胜妙。是名受缘爱。乐受彼触眼触乐受已。于眼触不苦不乐受悕望。是名受缘爱。复次缘眼触苦受。生眼触苦受。彼触眼触苦受已。于眼触乐受悕望。是名受缘爱。复次缘眼触苦受。生眼触苦受。若触眼触苦受已。悕望令我断坏无有。是名受缘爱。复次缘眼触苦受。生眼触苦受。若触眼触苦受已。于眼触不苦不乐受悕望。是名受缘爱。复次缘眼触不苦不乐受。生眼触不苦不乐受。彼触眼触不苦不乐受已。于眼触乐受喜乐爱着住。是名受缘爱。复次缘眼触不苦不乐受。生眼触不苦不乐受。若触眼触不苦不乐受已。于异眼触不苦不乐受。悕望若相似若胜妙。如是受缘爱。复次缘眼触不苦不乐受。生眼触不苦不乐受。若触眼触不苦不乐受已。于眼触乐受悕望。是名受缘爱。复次耳鼻舌身意。缘意触乐受。生意触乐受已。意触乐受喜乐爱着堪忍住。是名受缘爱。复次缘意触乐受喜乐爱着堪忍住。是名受缘爱。复次缘意触乐受。生意触乐受。若触意触乐受已。于异意触乐受。悕望若相似若胜妙。是名受缘爱。复次缘意触乐受。生意触乐受。彼触意触乐受已。于不苦不乐受悕望。是名受缘爱。复次缘意触苦受。生意触苦受。彼触意触苦受已。于意触乐受悕望。是名受缘爱。复次缘意触苦受。生意触苦受。彼触意触苦受已。悕望令我断坏无有。是名受缘爱。复次缘意触苦受。生意触苦受。彼触意触苦受已。于意触不苦不乐受悕望。是名受缘爱。复次缘意触不苦不乐受。生意触不苦不乐受。若意触不苦不乐受已。于意触不苦不乐受悕望堪忍住。是名受缘爱。复次缘意触不苦不乐受。生意触不苦不乐受。若受意触不苦不乐受已。于意触不苦不乐受。悕望若相似若胜妙。是名受缘爱。复次缘意触不苦不乐受。生意触不苦不乐受。若缘意触不苦不乐受已。于意触乐受悕望。是名受缘爱。如佛说。阿难。爱有缘。阿难问已有答。爱何缘受缘爱此是答。阿难。若无一切受者有爱不。世尊。无也。阿难。以因绪缘爱阿难受缘爱。如向所说。以是故说

云何爱缘取。爱未断爱欲取见取戒取我取。是名爱缘取。云何欲取。除欲界爱初触。若余欲界爱广。是名欲取。云何见取。除戒取若余见取。云何戒取。戒道是名戒取。云何我取。除色无色界爱初触。若余色无色界爱广。是名我取。云何欲界取。除欲界爱初触见取戒取。若余欲界烦恼是名欲取。云何见取。六十二见及邪见。是名见取。云何戒取。戒净道净二俱净解脱无依尽苦边。若于彼堪忍欲爱。戒谓身口戒。道谓邪缘求吉。养发入水事火事日月。牛行鹿行狗行默行。求力行求大人行。种种苦行。及余求邪吉。是名道。若彼戒此道。求觅重求觅究竟求觅。齐是谓净。谓解脱。谓戒净。谓我解脱。谓圣。谓阿罗汉。谓般涅槃。若于彼欲重欲究竟欲堪忍。是名戒取。云何我取。除色无色界初触爱戒取见取。若余色无色界烦恼。是名我取。如佛说。阿难。取有何缘。如是阿难问已有答取由何缘。爱缘取此是答。阿难。若无一切爱者有取不。世尊。无也。阿难。以是因绪缘取。阿难。爱缘取如向所说。以是故说

云何取缘有。欲取见取戒取我取缘未断。若作欲行色行无色行。有报身口意业。是名取缘有。复次取缘三有。欲有色有无色有。云何欲有。二种欲有。或欲有即业有。或欲有即生有。云何欲有即业有。欲行未竟未知未断。若作欲行有报身口意业。是名欲有即业有。云何欲有即生有。若作业成就已。欲界天上受五种我分身。色受想行识。是名欲有即生有。此谓受有。此谓报有。此谓复有。如是欲行业有。如是欲行生有。是名欲有。云何色有。二种色有。或色有即业有。或色有即生有。云何色有即业有。色行未竟未知未断。若作色行有报身口意业。是名色有即业有。云何色有即生有。若作业成就已。色界天上若受五种我分。色受想行识。是名色有即生有。此谓受有。此谓报有。此谓复有。如是色行业有。如是色行生有。是名色有云何无色有。二种无色有。或无色有即业有。或无色有即生有。云何无色有即业有。无色行未竟未知未断。若作无色行有报身口意业。名无色有即业有。云何无色有即生有。若作业成就已。无色界天上受四种我分身。受想行识。是名无色有即生有。此谓受有。此谓报有。此谓复有。如是无色行业有。如是无色行生有。是名无色有。如佛说。阿难。有有缘。如是阿难问已有答。有何缘。取缘有此是答。阿难。若无一切取者有有不。世尊。无也。阿难。以因绪缘。阿难。取缘有如向所说。以是故说

云何有缘生。若诸众生众中生重生住胎出胎得生。阴具诸入众和合。是名生。如佛说。阿难。生有缘。阿难问已有答。生何缘。有缘生。此是答。阿难。若无一切有者有生不。世尊。无也。阿难。以因绪缘有缘生。如向所说。以是故说。云何生缘老死忧悲苦恼大苦聚。云何老。谓众生衰老战掉诸根熟念减行。故是名老。云何死。若诸众生终没死尽。时过阴坏舍身此阴变异众别离。是名死

云何忧。众生触若干苦法。若忧重忧究竟忧。内热内心忧。是名忧。云何悲。忧缠逼迫忧煎具足忧恼心乱。穷叹啼哭追忆并语。或自扑乱语。是名悲。云何苦。若身觉苦。眼触苦受乃至身触苦受。是名苦。云何恼。若心觉苦。意触苦受。是名恼。云何大苦聚。若众苦若骂辱苦若心不定。是名大苦聚。如佛说。阿难。老死忧悲苦恼大苦聚有缘。阿难问已有答。老死忧悲苦恼大苦聚有何缘。生缘老死忧悲苦恼大苦聚。此是答。阿难。若无生有老死忧悲苦恼大苦聚不。世尊。无也。阿难。以因绪缘故。老死忧悲苦恼大苦聚。若生缘老死忧悲苦恼大苦聚。如上说

云何如是纯苦聚集。谓七苦法。老死忧悲苦恼大苦聚。是名纯苦阴。复次十一苦法。无明行识名色六入触受爱取有生。是名纯苦阴。复次亦十八苦法。无明行识名色六入触受爱取有生老死忧悲苦恼大苦聚。是名纯苦阴。如是纯苦阴有集和合生俱生。生已俱生已。出俱出。出已俱出已得成就是谓纯苦阴集。云何无明灭则行灭。若无明生则行生。若无明灭则行灭。是谓无明灭则行灭。乃至若有生则有老死。若生灭则老死灭。是谓生灭则老死灭。云何纯苦阴灭。纯苦阴者。谓七苦法。老死忧悲苦恼大苦聚。是名纯苦阴。复次十一苦。是名纯苦阴。复次十八苦法。无明乃至大苦聚。是名纯苦阴。如是纯苦阴尽变异。寂静灭没。名纯苦阴灭

舍利弗阿毗昙论卷第十二舍利弗阿毗昙论卷第十三

        姚秦罽宾三藏昙摩耶舍共昙摩崛多等译

    非问分念处品第六

行一道。众生清净。远离忧悲。灭尽苦恼。得证涅槃。断除五盖。修四念处。何谓一道。独处闲静乐于精勤。不乐诸业。不乐非业。不行无义语。不乐无义语。不行睡眠。不乐睡眠。不行集语。不乐集语。不行依止。不乐依止。不行放逸。不乐放逸。不行亲近。不乐亲近。如是道生正生起正起触证。是名一道。复次独远离舍恶。远离不杂垢秽。离诸欲恶。如是道生正生起正起触证。是名一道。复次不共贪欲嗔恚愚痴烦恼。不共障碍覆盖系缚恶行。如是道生正生起正起触证。是名一道。复次独不放逸。精进念知修远离行。如是道生正生起正起触证。是名一道。复次独处闲静。亲近随坐。或旷野空处山谷崖窟。露处草坐处。在林薮冢间水侧远离聚落。如是道生正生起正起触证。是名一道。复次心独住正住正止一入定。是名一道。复次一向柔软调伏清净。是名一道。复次贪欲嗔恚愚痴烦恼障碍覆盖系缚恶行尽。是名一道。复次离欲寂静修正觉灭恶得涅槃。是名一道。何谓道一枝道。乃至十一枝道。是名道。是道是桥。是因是门。是根是起。是胜是绪是办。生正生起正起出正出。善法和合成就。是名道

何谓众生清净。众生谓五道生也。为人天众生故。说亲近四念处修行多学。得戒清净心清净见清净。授记度疑清净知见道非道清净。趣道知见清净得知见清净。如见令不清净众生清净。令垢秽众生无垢秽。是谓众生清净

何谓远离忧悲。云何忧。众生触若干苦法。若忧重忧。内燋热内心热。是名忧。云何悲。谓众生忧缠逼迫。忧箭具足。忧恼心乱。穷叹啼哭。追忆并语。或自堆扑。口出乱语。是名悲。四念处亲近修学远离忧悲。是名远离忧悲。何谓灭尽苦恼。苦谓若身觉苦。眼触苦受乃至身触苦受。是名苦。云何恼。若心觉苦。意触苦受。是名恼。四念处亲近修学苦恼灭。是谓灭苦恼

何谓得涅槃。涅槃谓四沙门果。四念处亲近修学。得四沙门果。是谓得涅槃

何谓断五盖。若灭五盖。是谓断五盖。何谓修四念处。谓内身观身行勤精进。应正智念除世间贪忧。外身观身行勤精进。应正智念除世间贪忧。内外身观身行勤精进。应正智念除世间贪忧。受心法亦如是。云何身观身行。身谓四大色身。父母因缘饮食长养。衣服调适涂油润身。无常破坏变异之法。是名身。复次名身。色身是名身。复次地身水火风身。是名身。复次象众马众车众步众。是名身。复次六识身六触身六受身六想身六思身六爱身六觉身六观身。是名身。云何内身观身行。若比丘一切内四大色身所摄法。若内一处四大色身所摄法。思惟无常知无常解无常受无常。如是不放逸观。得定心住正住。是名内身观身行。复次比丘。一切内身四大色身所摄法。若内一处四大色身所摄法。思惟苦患痈箭贪味病依缘坏法不定不满可坏苦空无我。思惟缘知缘解缘受缘。即无明缘行。乃至名色缘六入。乃至是名内身观身行。复次比丘。一切内身四大色身所摄法。若内一处四大色身所摄法。思惟灭知灭解灭受灭。即无明灭则行灭。乃至名色灭则六入灭。乃至是名内身观身行。复次比丘。行乐知行乐。乃至卧乐知卧乐。身住乐如实知。乃至是名内身观身行。复次比丘。去来屈申回转正知行。乃至眠觉语默正知行。乃至是名内身观身行。复次比丘。出息长知长。入息长知长。出息短知短。入息短知短。如旋师挽绳。绳长知长绳短知短。乃至是名内身观身行。复次比丘。从顶至足从足至顶。见诸不净。观身中有发毛爪齿薄皮厚皮。血肉筋脉脾肾心肺。大小秽藏便利涕唾脓血脂肪脑膜泪汗髓骨。如净眼人于二门仓观见诸谷。胡麻大豆小豆豍豆大麦小麦。如是比丘观身中。从顶至足从足至顶。具诸不净。乃至是名内身观身行。复次比丘。观身诸大此身中唯有地水火风大。如巧屠牛师屠牛师弟子屠牛为四分。若坐立行住但见四分。如是比丘。观此诸大。此身唯有地大水火风大。然此诸大但依水火生各相违。饮食长养羸劣无力。不坚无强念念不住。乃至是名内身观身行。复次比丘。观身食住食集。缘食得住无食无住。如火缘薪得燃无薪则灭。如是比丘。观身食住食集。缘食得住无食不住。如佛说

  观身所集苦　　一切皆缘食
  若能除灭食　　则无是诸苦
  如是知过患　　食是成就苦
  比丘灭食已　　必定得涅槃

是名内身观身行。复次比丘。观身尽空俱空以念遍知解行。乃至是名内身观身行。复次比丘。观身是痈疮。此身有九疮津漏门。若所出津漏皆是不净。乃至如摩诃迦叶说。四大色身是衰耗相违津漏。乃至寿命短促。乃至是名内身观身行。及余诸行一切内四大色身所摄法。一处内四大色身所摄法。思惟得定心住正住。是名内身观身行。云何内。身身若受。谓若内缘生自性己分。是名内。云何观。谓如实人微观正觉缘观解。是名观。云何行。如是微观成就不违法护持行微行。是名行。云何勤精进。谓如实人若顺法多行精进。是名勤精进。复次若身心发起显出越度不退。是名勤精进。云何正智。谓如实人知见解射方便。是名正知。云何念。谓如实人忆念。微念缘念住不忘相续念不失不集。是名念。云何世间。有二种世间。众生世间行世间。五道受生。是名众生世间。五受阴。是名行世间。云何贪。贪不善根。是名贪。云何忧。意触苦受。是名忧。云何除。覆背解断吐出。是名除

云何外身观身行。若比丘外一切四大色身摄法。若外一处四大色身摄法。思惟无常知无常解无常受无常。如是不放逸观。得定心住正住。是名外身观身行。复次比丘。一切外四大色身所摄法。若一处外四大色身所摄法。若观苦痛痈箭着味病依缘坏法不定不满可坏苦空无我。思惟缘知缘解缘受缘。即无明缘行。乃至名色缘六入。乃至是名外身观身行。复次比丘。外一切四大色身所摄法。外一处四大色身所摄法。思惟灭知灭解灭受灭。无明灭则行灭。乃至名色灭则六入灭。乃至是名外身观身行。及余诸行外一切四大色身所摄法。若外一处色身所摄法。思惟得定心住正住。是名外身观身行。云何外身。谓身非受非内非缘生非自性非己分。是名外。余义如上说

云何内外身观身行。如比丘一切内外四大色身摄法。若一处内外四大色身摄法。观无常知无常解无常受无常。如是不放逸观。得定心住正住。是名内外身观身行。复次比丘。一切内外四大色身摄法。若一处内外四大色身摄法。若观苦痛痈箭着味病依缘坏法不定不满可坏苦空无我。思惟缘知缘解缘受缘。无明缘行乃至触缘受。乃至是名内外身观身行。复次比丘。一切内外四大色身摄法。若一处内外四大色身摄法。思惟灭知灭解灭受灭。无明灭则行灭。乃至名色灭则六入灭。乃至是名内外身观身行。复次比丘。若见死尸弃在冢间。若一日至三日。乃至是名内外身观身行。复次比丘。若见死尸弃在冢间。若一日至三日膖胀青瘀。乃至是名内外身观身行。复次比丘。若见死尸弃在冢间。若一日至三日。为乌鸟虎狼若干诸兽之所食啖。乃至是名内外身观身行。复次比丘。若见死尸骨节相连。青赤烂坏脓血不净臭秽可恶。乃至是名内外身观身行。复次比丘。若见死尸骨节相连。余血皮所覆筋脉未断。乃至是名内外身观身行。复次比丘。若见死尸骨节相连。血肉已离筋脉未断。乃至是名内外身观身行。复次比丘。若见死尸骨节已坏未离本处。乃至是名内外身观身行。复次比丘。若见死尸骨节断坏远离本处。脚胫膞脾臗脊胁肋手足肩臂项髑髅诸骨各自异处。乃至是名内外身观身行。复次比丘。若见死尸骨节久故色白如贝色青如鸽朽败碎坏。乃至是名内外身观身行。复次比丘。若见死尸在火聚上。烧发毛皮肤血肉筋脉骨髓。一切发毛乃至骨髓渐渐消尽。观此法不至东方南西北方四维上下处住。此法本无而生。已生还灭。乃至是名内外身观身行。及余一切诸行四大色身摄法。若一处内外四大色身摄法。思惟得定心住正住。是名内外身观身行。云何内外身若受若非受。是名内外身。余义如上说。比丘观身法缘起行。观身法缘灭行。比丘如是观身法缘起缘灭行。有身起内念。以智以明识不依身。无所依行不受于世。如是比丘。内身观身行勤精进正智正念。除世贪忧。外身内外身亦如是

云何受观受行。受谓六受。眼触受乃至意触受。是名受。云何内受观受行。如比丘一切内受。若一处内受。思惟无常知无常解无常受无常。如是不放逸观。得定心住正住。是名内受观受行。复次比丘。一切内受若一处内受。思惟苦患痈箭味病依缘坏法不定不满可坏苦空无我。思惟缘知缘解缘。受缘即无明缘行。乃至触缘受。乃至是名内受观受行。复次比丘。若一切内受。若一处内受。思惟灭知灭解灭受灭。即无明灭则行灭。乃至触灭则受灭。乃至是名内受观受行。及余诸行一切内受一处内受。思惟得定心住正住。是名内受观受行。何谓内。受谓内。是内是缘是自性是己分。是名内。余义如上说

云何比丘外受观受行。如比丘一切外受。若一处外受。思惟无常知无常解无常受无常如是不放逸观。得定心住正住。是名外受观受行。复次比丘。一切外受。若一处外受。思惟苦患痈箭味病依缘坏法不定不满可坏苦空无我。思惟缘知缘解缘受缘。无明缘行乃至触缘受。乃至是名外受观受行。复次比丘。一切外受。若一处外受。思惟灭知灭解灭受灭。即无明灭则行灭。乃至触灭则受灭。是名外受观受行。及余诸行一切外受。若一处外受。思惟得定心住正住。是名外受观受行。云何外。受行受非受。谓外非内非缘非自性非己分。是名外。余义如上说

云何内外受观受行。如比丘一切内外受。若一处内外受。思惟无常知无常。解无常受无常。如是不放逸观。得定心住正住。是名内外受观受行。复次比丘。若一切内外受。若一处内外受。思惟苦患痈箭着味病依缘坏法不定不满可坏苦空无我。思惟缘知缘解缘受缘。即无明缘行乃至触缘受。乃至是名内外受观受行。复次比丘。一切内外受。若一处内外受。思惟灭知灭解灭受灭。即无明灭。乃至触灭则受灭。乃至是名内外受观受行。复次比丘。若受乐受知我乐受。苦受不苦不乐受亦如是。若受有染乐受。知我有染乐受。若受无染乐受。知我无染乐受。苦受不苦不乐受亦如是。是名内外受观受行。及余诸行。一切内外受。若一处内外受。思惟得定心住正住。是名内外受观受行。云何内外受。受若非受。是名内外。余义如上说。如是比丘。观受法缘起行。观受法缘灭行。如是比丘。观受法起灭行有受念内以智以明识不依受无所依行不受一切世。如是比丘。内受观受行勤精进正智正念。除世贪忧。外受内外受亦如是

云何心观心行。云何心。若心意识六识身七识界。是名心。云何内心观心行。如比丘一切内心。若一处内心。思惟无常知无常解无常受无常。如是不放逸观。得定心住正住。是名内心观心行。复次一切内心。若一处内心。思惟苦患痈箭味病依缘坏法不定不满可坏苦空无我。思惟缘知缘解缘受缘。即无明缘行行缘识。乃至是名内心观心行。复次比丘。一切内心若一处内心思惟灭知灭解灭受灭。即无明灭则行灭。行灭则识灭。是名比丘内心观心行。及余法行一切内心。若一处内心。思惟得定心住正住。如是比丘内心观心行。云何内。心若心受谓内。是内是缘是自性是己分。是名内。余义如上说

云何比丘外心观心行。如比丘一切外心。若一处外心。思惟无常知无常解无常受无常。如是不放逸观。得定心住正住。是名外心观心行。复次比丘。一切外心。若一处外心。思惟苦患痈箭味病依缘坏法不定不满可坏苦空无我。思惟缘知缘解缘受缘。即无明缘行行缘识。乃至是名外心观心行。复次比丘。一切外心。一处外心。思惟灭知灭解灭受灭。即无明灭则行灭。行灭则识灭。乃至是名外心观心行。及余心行一切外心。一处外心。思惟得定心住正住。是名外心观心行。云何外。心心非受谓外。非内非缘非自性非己分。是名外。余义如上说

云何比丘。内外心观心行。如比丘一切内外心。一处内外心。思惟无常知无常解无常受无常。如是不放逸观。得定心住正住。是名内外心观心行。复次比丘。若一切内外心一处内外心。观苦患痈箭味病依缘坏法不定不满可坏苦空无我。思惟缘知缘解缘受缘。即无明缘行行缘识。乃至是名内外心观心行。复次比丘。一切内外心一处内外心。思惟灭知灭解灭受灭。即无明灭则行灭。行灭则识灭。乃至是名内外心观心行。复次比丘。有欲心如实知有欲心无欲心。如实知无欲心。乃至有胜心如实知有胜心。无胜心如实知无胜心。如是不放逸观。得定心住正住。是名内外心观心行。及余诸行一切内外心。若一处内外心。思惟得定心住正住。是名内外心观心行。云何内外心。心若受非受。余义如上说。如是比丘。观心法缘起行。如是缘灭心行。比丘缘起灭心行。有心起内念。以智以明识不依心。无所依行不受于世。如是比丘。内心观心行勤精进。正智正念除世贪忧。外心内外心亦如是

云何法观法行。法谓除四大色身摄法受心。及余若色非色可见不可见有对无对圣非圣。是谓法。云何比丘内法观法行。若比丘除四大色身摄法受心。若余一切内法。若一处内法。思惟无常知无常解无常受无常。如是不放逸观。得定心住正住。是名内法观法行。复次比丘。除四大色身摄法受心。若余一切内法。若一处内法。思惟苦忧患痈箭味病依缘坏法不定不满可坏苦空无我。思惟缘知缘解缘受缘。即无明缘行。乃至生缘老死忧悲苦恼众苦聚集。乃至是名内法观法行。复次比丘。除四大色身摄法受心。及余一切内法。若一处内法。思惟灭知灭解灭受灭。即无明灭则行灭。乃至生灭则老死忧悲苦恼众苦聚灭乃至是名内法观法行。及余诸行。除四大色身所摄法受心。若一切内法若一处内法。思惟得定心住正住。是名内法观法行。云何内法。法受谓内。是内是缘是自性是己分。是名内。余义如上说

云何比丘外法观法行。如比丘除四大色身摄法受心。若外一切法。若外一处法。如事思惟无常知无常解无常受无常。如是不放逸观。得定心住正住。是名外法观法行。复次比丘。除四大色身摄法受心。余外一切法。若一处外法。如事思惟苦恼痈箭味患依缘坏法不定不满可坏苦空无我。思惟缘知缘解缘受缘。即无明缘行。乃至生缘老死忧悲苦恼众苦聚集。乃至是名外法观法行。复次比丘。除四大色身摄法受心。及余外一切法。若一处外法。如事思惟灭知灭解灭受灭。即无明灭则行灭。乃至生灭则老死忧悲苦恼众苦聚集灭。乃至是名外法观法行。及余诸行。除四大色身摄法受心。余一切外法。若一处外法。如事思惟得定心住正住。是名外法观法行。云何外法。法非受谓外。非内非缘非自性非己分。是名外。余义如上说

云何比丘。内外法观法行。如比丘除四大色身摄法受心。一切内外法。若一处内外法。如事思惟无常知无常解无常受无常。如是不放逸观。得定心住正住。是名内外法观法行。复次比丘。除四大色身摄法受心。余一切内外法。若一处内外法。如事思惟苦恼痈箭味患依缘坏缘法不定不满可坏苦空无我。思惟缘知缘解缘受缘。即无明缘行。乃至生缘老死忧悲苦恼众苦聚集。乃至是名内外法观法行。复次比丘。除四大色身摄法受心。及余一切内外法。若一处内外法。如事思惟灭知灭解灭受灭。即无明灭则行灭。乃至生灭则老死忧悲苦恼众苦聚集灭。乃至是名内外法观法行。复次比丘。我内有欲如实知我内有欲。我内无欲如实知我内无欲。如欲未生如实知欲未生。如欲当生如实知欲当生。如欲现生如实知当断。如欲断已如实知不复生。嗔恚愚痴睡眠掉悔疑亦如是。乃至是名内外法观法行。复次比丘。我内有眼识色欲恚。如实知我内有眼识色欲恚。我内无眼识色欲恚。如实知我内无眼识色欲恚。如眼识色未生欲恚。如实知未生。如眼识色未生欲恚。如实知当生。如眼识色现在生欲恚。如实知当断。如眼识色已断欲恚。如实知不复生。耳鼻舌身意亦如是。乃至是名内外法观法行。复次比丘。我内有念觉。如实知我内有念觉。我内无念觉。如实知我内无念觉。如念觉未生。如实知未生。如念觉未生。如实知当生。如念觉生已。如实知有具足。修余六觉亦如是。乃至是名内外法观法行。复次比丘。如实知苦苦集苦灭苦灭道。如实知漏漏集漏灭漏灭道。乃至是名内外法观法行。复次比丘。厌离一切行入甘露界。是寂静此胜。灭一切行。爱灭涅槃。乃至是名内外法观法行。及余诸行。除四大色身摄法受心。及余一切内外法。若一处内外法。如事思惟定心住正住。是名内外法观法行。云何内外法。法若受若不受。是名内外法。余义如上说。如是比丘。观法缘起法行。观法缘灭法行。如是比丘。观起灭法行。有法起内念。以智以明识不依法。无所依行不受于世。如是比丘。内法观法行勤精进。正智正念除世贪忧。外法内外法亦如是。如实修学四念处。当有是怖。于一切世常无我行。心不高不下亦无住处。若有我想众生想命想人想。无有是处。常应第一空行。若得此后心不作无益。不受不着色声香味触。于三世无碍。于欲界解脱。色界无色界解脱灭不复生。此是苦际。如春末月极盛热时无有云雾。少水在瓦器便速煎灭。如是比丘。若得后心不作无益。不受不着色声香味触。乃至灭不复生。此是名苦际

  如风吹猛焰　　灭时不移处
  以觉扇名色　　尽亦无所至
  如工锻热铁　　流星灭无象
  陶冶渐归无　　求相信难得
  如雨投海中　　本渧岂复存
  解脱亦何有　　空故湛然乐
  舍身离于想　　诸受无所觉
  所行尽寂静　　识亦自然灭

    舍利弗阿毗昙论非问分正勤品第七

问曰。几正勤。答曰四。何谓四。若比丘。恶不善法未生欲令不生。起欲自勉胜进摄心正断。恶不善法已生必当断。起欲自勉胜进摄心正断。善法未生欲令生。起欲自勉。胜进摄心正断。善法已生欲令住。具足修不忘增广。起欲自勉胜进摄心正断。云何恶法未生欲令不生。身口意恶行。是名恶不善法。复次十不善业道。是名恶不善法。复次不善根不善根相应。不善根所起非缘非受。是名恶不善法。复次贪欲嗔恚愚痴忿怒怨嫌妄嗔嫉妒悭惜谀谄欺伪匿恶无惭无愧自高诤讼强毅放逸我慢增上慢等。是名恶不善法。复次十邪法。是名恶不善法。如是恶不善法。未生未起未和合。令我不生不起不和合。是名恶不善法未生欲令不生。何谓起欲。若欲重欲欲作欲起欲显出欲越度欲得欲触欲证。是名起欲。何谓自勉。堪忍力厉未得欲得未解欲解未证欲证。是名自勉。何谓胜进。身心发起显出越度堪忍不退勤力修进。是名进。此进起正起正生触证。是名胜进。何谓摄心。心意识六识身七识界。是名心。是心摄正摄缘摄劝厉正劝勉。踊跃欢喜。是名摄心。何谓正。正因正思惟正方便。是名正。何谓断。舍恶法生善法清白法现世乐行。知见慧分别断漏尽一切苦际。是名断。恶不善法已生必当断。起欲自勉胜进摄心。正断亦如是说。但已生为异。何谓善法未生欲令生。身口意善行。是名善法。乃至何谓断。舍恶法生善法清白法现世乐行。知见慧分别断漏尽一切苦际。是名断。何谓善法生已欲令住。身口意行善。是名善法。乃至复次十正法正见乃至正智及余随正法。是名善法。如此善法生和合。令我住不失不忘。令我究竟。是名善法生已住。何谓具足。戒众未具足欲令具足。乃至解脱知见众未具足欲令具足。是名具足。何谓修。若善法亲近正亲近。依正依勤行修学。是名修。何谓不忘。欲令善法不失不夺相续念不忘。是名不忘。何谓增广。欲令善法增长广进。是名增广。乃至何谓断。舍恶法生善法清白法现世乐行。知见慧分别断诸漏尽一切苦际。是谓断

    舍利弗阿毗昙论非问分神足品第八

问曰。几神足。答曰四。谓欲定断行成就修神足精进定心定慧定断行成就修神足

云何欲。谓欲重欲作。欲发起欲显出欲越度。欲得欲触。欲解欲证是名欲

云何定。若心住正住。是名定。如是欲如是定。是名欲定。复次贵欲向欲。依欲趣欲增上欲。以欲为主得定。心住正住。是名欲定。复次善欲发起得定。心住正住。不善欲发起得定。心住正住。无记欲发起得定。心住正住。是名欲定。复次不欲行善。即自思惟。此非我所善。非所好非所应非所行非我行时。我何故不欲行善。便以欲为尊上得定。心住正住。是名欲定。复次欲行善法。即自思惟。是我所善。是所好是所应。是所行是我行时。我欲行善。以欲为尊上得定。心住正住。是名欲定。复次善欲不生。善欲不生已不善欲生。共贪欲嗔恚愚痴行。即自思惟。此非我所善。非所好非所应非所行非我行时。我何故不欲行善。乃共贪欲嗔恚愚痴行。尊上善欲得定。心住正住。是名欲定。复次不善欲不生。不善欲不生已善欲生。不共贪欲嗔恚愚痴行。即自思惟。是我所善是所好是所应是所行。是我行时。我欲行善。不共贪欲嗔恚愚痴行。以善欲为尊上得定。心住正住。是名欲定

云何断。以善法引心引正引调正调止正止不失不移。是名断。复次身心发起显出越度堪忍勤力进不退。是名断。复次修四正断。是名断。复次舍恶不善法生善法现世乐行。知见慧分别。断诸漏尽一切苦际。是名断

云何断行。悦喜信舍念正智。是名断行。复次欲定断行成就修神足。除欲精进心慧。余所随法受想思触思惟觉观。解脱顺信悦喜心随信不放逸念心舍除身进。及余所随色。是名断行

云何成就。欲定断及断行共起正共起受正受生正生具足。是名成就

云何修。此欲定断行成就神足。亲近正亲近依正依勤行修学。是谓修

云何神。如意通如意化如意自在作种种变。是名神。复次如比丘有大神力。能无量变化震动大地。以一为多以多为一。若近物远物。若墙壁高山。彻过无碍如行虚空。结跏趺坐。陵虚如鸟入出地中如出没水。履水如地。身出烟焰如大火聚。日月威德以手扪摸乃至梵天身得自在。是名神

何谓足。如欲定断行。是足是齐是因是门是用是道是至是缘是绪是势。神生正生起正起。出正出如意正如意。是谓足

若比丘。欲定断行成就修神足。令我欲不高不下不没不散。前后常想行。前如后后如前。昼如夜夜如昼。其心开悟无有覆盖。修行明了以身定心。以心定身。乐想轻想举身行。云何下欲。若欲共懈怠相应。不勤进不自勉。废善退法。是名下欲。云何懈怠。窳堕[夢-夕+登]懵于善法废退。是名懈怠。若欲共懈怠相应。不勤进不自勉废退善法。是名下欲

云何高欲。若欲共掉相应。不共寂静相应。成就乱行。是名高欲。云何掉。若心乱不寂静。是名掉。若欲共掉相应。不共寂静相应。成就乱行。是名高欲

云何没欲。若欲共睡眠相应。不共灭念慧。不成就不别善法。是名没欲。云何睡眠。烦恼未断。身不乐不调不轻不软不除。是名睡。云何眠。烦恼未断。心[夢-夕+登]懵覆蔽。是名眠。若欲共睡眠相应。灭念不相应。慧不成就。不别善法。是名没欲

云何散欲。起欲染共欲染相应。多欲见净不观过患。于外五欲心散。着色声香味触。是名散欲。云何欲染。若欲欲欲腻欲爱欲喜欲支欲网欲忍欲得欲集欲悕望。是名欲染。若欲向欲染共欲染欲染相应。多欲见净不观过患。于外五欲心散。着色声香味触是名散欲。云何前后常想行。若比丘。且行如事思惟入善法。出世间入涅槃。离欲定相。应且行已。日中行。日中行已晡行。晡行已上经行。上经行已下经行。下经行已入室。入室已初夜行。初夜行已后夜行。后夜行已如事思惟入善法。出世间入涅槃。离欲定相应。是名前后常想行

云何前如后后如前。如比丘。如事根力觉禅解脱定入定前行。如事根力觉禅解脱定入定后行。如事根力觉禅解脱定入定后行。已如事根力觉禅解脱定入定前后行是谓前如后后如前

云何昼如夜夜如昼。如比丘。若取明想善受昼想。后如昼思惟明想。夜亦如是。如夜昼亦如是。是名昼如夜夜如昼

云何其心开悟无有覆盖。若贪欲嗔恚愚痴垢。烦恼垢。障碍覆盖系缚。不善行垢。是障碍心。不开心。覆盖心。是蔽心。是起向缚不净心。是不白不明了心。是名覆盖心。若心无贪欲嗔恚愚痴垢。乃至明了心。是谓其心开悟无有覆盖

云何修有明心。若比丘。修共慧光明心。修有明心。修共明想心。修有明心。云何共慧光明心。若三慧照明。谓闻思修慧是名共慧光明心。若亲近正亲近勤行修学。是谓修共慧光明心修有明心。云何共明想心。若比丘取诸明相。若火光日月光珠光星宿光。取诸光明相已。若树下露处思惟光明。知光明解光明受光明。如实人若想忆想知想。是名光明想心。若共想生共住共灭。是名共明想心。若亲近正亲近勤行修学。是名修共明想心修有明心。复次比丘。若于树下露处。以清净心遍解行有明心胜。如实人若想忆想知想。是名明想心。若共想生共住共灭。是名共明想心。若亲近正亲近勤行修学。是名修共明想心修有明心。复次比丘。若一树下若二若三乃至十树。以清净心遍解行有明心胜。乃至是名修共明想心修有明心。复次比丘。若于一园以清净心遍解行。乃至是名修共明想心修有明心。复次比丘。于一园若二若三乃至十园。以清净心遍解行乃至。是名修共明想心修有明心。复次比丘。一聚落若二若三乃至十聚落。以清净心遍解行乃至。是名修共明想心修有明心。复次比丘乃至水陆周匝。以清净心遍解行。乃至是名修共明想心修有明心

云何以身定心以心定身。若比丘以心身上正上举正举。如人持钵。乞食以络盛钵。盛正盛举正举。如是比丘以心身上正上举正举。云何比丘。以身定心。若比丘思惟身无常知无常解无常受无常。如是不放逸观。得定心住正住身乐身调身轻身软身除。是名以身定心。复次比丘。身苦恼痈箭味患依缘。坏法不定不满可坏苦空无我。思惟缘知缘解缘受缘。即无明缘行。乃至名色缘六入。如是不放逸观得定心住正住。身乐身调身轻身软身除。是名以身定心。复次比丘。思惟身灭知灭解灭受灭。即无明灭则行灭。乃至名色灭则六入灭。如是不放逸观得定。心住正住。身乐身调身轻身软身除。是名以身定心。复次比丘。行知行乐。住知住乐。坐知坐乐。取知取乐。如是身住乐如实知住乐。如是不放逸观得定。心住正住。身乐身调身轻身软身除。是名以身定心。乃至复次比丘。若见死尸在火聚上烧。发毛皮肤血肉筋脉骨髓渐渐消尽。观此法不至东西南北四维上下。不至余处住。此法本无而生。已有还灭。观身如是法不放逸观得定。心住正住。得身乐身调身轻身软身除。是名以身定心(此章乃有三十四科复次释以身定心不异一支道说故略之)

云何比丘以心定身。如比丘思惟心无常。知心无常解心无常受心无常。如是不放逸观得定。心住正住。得心乐心调心轻心软心除。是名以心定身。复次比丘。观心苦恼痈箭味患依缘坏法不定不足可坏苦空无我。思惟缘知缘解缘受缘即无明缘行行缘识。如是不放逸观得定。心住正住。得心乐心调心轻心软心除。是名以心定身。复次比丘。思惟心灭知灭解灭受灭。即无明灭则行灭。行灭则识灭。如是不放逸观得定。心住正住。得心乐心调心轻心软心除是名以心定身。复次比丘。有欲心如实知有欲心。无欲心如实知无欲心。乃至有胜心无胜心如实知。如是不放逸观得定。心住正住。得心乐心调心轻心软心除。是名以心定身

云何乐想忆想上身行。云何乐想。若比丘离欲恶不善法。有觉有观离生喜乐。成就初禅行。若身离生喜乐。津液遍满。此身尽离生喜乐。津液遍满无有减少。如善澡浴师善澡浴师弟子。以细澡豆盛着器中。以水洒已调适作抟。抟此抟津液遍满。不干不湿内外和润。如是比丘。身离生喜乐津液遍满。此身尽离生喜乐。津液遍满无有减少。如实人若想忆想知想。是名乐想。此想身微受正微受。缘微受。以何身受意身受。是名乐想上身行。复次比丘。灭觉观内净信心。无觉无观定生喜乐。成就二禅行。若此身定生喜乐津液遍满。身尽定生喜乐。津液遍满。无有减少。如大陂湖以山围绕。水从底涌出。水不从东西南北方来。陂水自从底涌而出。此陂津液遍满无有减少。如是比丘。此身定生喜乐津液遍满。此身尽定生喜乐。津液遍满无有减少。如实人若想忆想。是名乐想。此想身微受正微受缘微受。以何身受。意身受。是谓乐想上身行。复次比丘。离喜乐舍行念正智身受乐。如诸圣人解舍念乐行。成就三禅行。若此身无喜乐津液遍满。此身无喜乐尽。津液遍满无有减少。如优钵罗池波头摩池拘牟头池分陀利池。若优钵罗花乃至分陀利花。从泥涌出。未能出水。此花若根若头。水津液遍满。从根至头从头至根。津液遍满无有减少。如是比丘。若此身无喜乐。津液遍满。此身尽津液遍满。无有减少。如实人若想忆想知想。是名乐想。若想身微受正微受缘微受。以何身受意身受。是名乐想上身行。复次比丘。断苦乐先灭忧喜不苦不乐舍念净。成就四禅行。若此身以清净心遍解行。此身清净无不遍处。如男子女人。着白净衣。上下具足。从头至足。从足至头。无不覆处。如比丘。若此身以清净心遍解行。此身清净。无不遍处。如实人若想忆想知想。是名乐想。此想身微受正微受缘微受。以何身受意身受。是名乐想上身行

云何轻想。若比丘思惟身轻知轻解轻受轻。如兜罗绵轻。如劫钵轻。布着平地。微风来吹。便得离地。如是比丘。思惟身轻知轻解轻受轻。如是不放逸观得定。心住正住。即得定已。离地四寸上行。如实人若想忆想知想。是名轻想。此想身微受正微受缘微受。以何身受以意身受。是名轻想上身行。若比丘此定亲近多修学。若离地一尺上行。若二尺上行。如实人若想忆想知想。是名轻想。此想身微受正微受缘微受。以何身受意身受是谓轻想上身行。若比丘若此定亲近多修学。离地半人身上行。若一人身二人身。乃至七人身上行。如实人若想忆想知想。是名轻想。若此想身微受正微受缘微受。以何身受意身受。是谓轻想上身行。若比丘此定亲近多修学。若离地半多罗树上行。若一多罗树乃至七多罗上行。如实人若想忆想知想。是名轻想。此想身微受正微受缘微受。以何身受意身受。是谓轻想上身行。若比丘此定亲近多修学。如意所欲。离地上行。无有限量。近远尽能住至。如实人若想忆想知想。是名轻想。若此想身微受正微受缘微受。以何身受意身受。是谓轻想上身行

若比丘彼乐想轻想亲近正亲近多修学。欲令我心调伏寂静由力自在。如意所欲。成就种种神足。若彼乐想轻想亲近正亲近多修学已。心调寂静。由力自在。如意所欲。得成就种种神足。彼受种种无量神足。能动大地。以一为多。以多为一。若近若远。高出墙壁。彻过无碍。如行虚空。结加趺坐。游空如鸟。于地出没。犹出入水。履水如地。身出烟焰。如大火聚。日月有大威德。手能扪摸。乃至梵天。身得自在。如定品广说。是名欲定断行成就修神足。精进定心定慧定断行。成就修神足。亦如是广说

舍利弗阿毗昙论卷第十三舍利弗阿毗昙论卷第十四

        姚秦罽宾三藏昙摩耶舍共昙摩崛多等译

    非问分禅品第九

因缘具足。则能得定。因缘不具。不能得定修定有如此因缘。谓比丘爱护解脱戒。成就威仪行。已行处。爱护微戒惧如金刚。受持于戒。断邪命。行正命。善知识。善亲厚。善众。摄诸根门。饮食知足。勤行精进。初不睡眠。离障碍法。如此比丘。知断五盖心垢损智慧法。离欲恶不善法有觉有观。离生喜乐。成就初禅行。乃至断苦乐先灭忧喜不苦不乐舍念净。成就第四禅行。云何爱护解脱戒。若随顺戒。不行放逸。以戒为门为足为因。能生善法。具足成就。以此戒故。名为持戒。以此顺不放逸名持戒。护持威仪行。是谓爱护解脱戒

云何成就威仪行。一切身不善行。一切口不善行。一切意不善行。是名非威仪行。身一切善行。口一切善行。意一切善行。是名成就威仪行。复次恭敬和尚及和尚同学。恭敬阿阇梨及阿阇梨同学。恭敬上下坐。是名威仪行。云何已行处。有六非已行处。若淫女处。寡妇处。大童女处。不能男处。比丘尼处。沽酒处。是名六非已行处。又如佛说比丘莫至他国非已行处。若至他国非已行处。魔得其便。比丘何谓他国非已行处。谓五欲也。是名至五欲非已行处。云何已行处。若彼非威仪行。此非已行处。舍离正舍离缘舍离。不亲近。正不亲近。缘不亲近。是名已行处。又如佛说。行于自国已行处。若比丘自国已行处。魔不得便。比丘何谓自国已行处。谓四念处也。是自国已行处。若以此威仪行。起正起受正受。是谓威仪已行成就

云何爱护微戒惧如金刚。若微细戒。若念作起意作欲和合作。若于彼多起恐畏相令我莫犯。是谓惧微戒如金刚

何谓受持于戒。若比丘不离一切戒。常持一切戒。常住一切戒。亲近于戒。持戒不瑕。不秽不垢。不懈不缺。受持一切戒。是谓受持于戒

云何舍邪命行正命。云何邪命。若沙门婆罗门。邪命自活。谓谀谄诈称。占相吉凶。为他使命现相激动以利求利。以此非法。得衣钵医药卧具所须受用食啖。以此系染贪着陵篾他人。堪忍非法。不见过患。不知出世。若比丘离如是等邪命。如法得衣钵医药卧具所须受用食啖。不以此系染贪着不陵篾他人。不堪忍非法深见过患。知出世。是谓断邪命行正命

云何善知识。谓沙门婆罗门。持戒贤善。断贡高放逸。忍辱成就。自调自灭。自入涅槃。欲离欲欲尽。乃至欲离痴痴尽。应染处不染。乃至应痴处不痴。应止处不止。应受处不受。身口意业清净。正命清净。行信惭愧。多闻精进。念慧修行。八道具足。戒定慧解脱解脱知见。衣食知足。是谓善知。何谓识。若识善识知共行慈重行慈究竟行慈常敬不离。是名善知识。云何善亲厚。凡夫持戒人。是凡夫持戒人善亲厚。坚信人。是坚信人善亲厚。坚法人是坚法人善亲厚。乃至阿罗汉。是阿罗汉善亲厚。如是等自共亲厚。是名亲厚。若善知识若善亲厚随顺不离相亲近。是谓善知识善亲厚

云何善众。若依持戒人学持戒。心向彼。尊上彼。倾向彼。解彼。若依定人学定。乃至彼解脱知见人。学解脱知见。心向彼。尊上彼。倾向彼。解彼。是谓善众

云何摄诸根门。若比丘。眼见色不取色相。能起眼根者。摄令不放逸。断恶不善法及悕望世。爱顺持戒。守护眼根得眼根戒。乃至意识法不取法相。能起意根者。摄令不放逸。断恶不善法及悕望世。爱顺持戒守护意根。如此六触入。护微念解射念善成就行。见欲过患常自护意。是谓摄诸根门

云何饮食知足。知量而食。不掉。不生贡高。不为养身。不为严饰身。唯欲安身。不起嗔恚。欲修梵行。断故受。不生新受。为活命故。舍憎爱金刚。常处中行。不求利。勤力乐行。如人患疮以药涂之为欲令愈。比丘亦尔。知量而食。不起掉。不生贡高。乃至不求利勤力乐行

云何掉食。若作是念。我食此食已。当作身口意掉。是名掉食

云何贡高食。若作是念。我食此食已。当增长放逸。是名贡高食

云何养身食。若作是念。我食此食已。当益于身。是名养身食

云何严饰身食。若作是念。我食此食。当端正姝好妙相成就。是名严饰身食。若比丘不作是念。我食此食。当作身口意掉。当作贡高。当养身。当严饰身。是谓不掉食不贡高不养身不严身食

云何但欲令身住。应作是念。我食此食。但欲令身住。不终不没。是名但欲令身住

云何不起嗔恚。若饥。缘饥故。生身心苦受。若食过度。缘过度故。生身心苦受。若比丘。知足而食。善思量食。则嗔恚灭。不生不起。是名不起嗔恚

云何欲修梵行。梵行谓八圣道也。应作是念。我食此食已。能修梵行。令梵行久住。为尽苦际。是名欲修梵行

云何断故受不生新受。若饥缘饥故。生身心苦受。是名故受。何谓新受。若食过度缘过度故。生身心苦受。是名新受。若比丘。知足而食。善思量食。是名断故受不生新受

云何为活命故食。应作是念。我食此食。为住命根护持戒行故。是名为活命故食

云何舍憎爱金刚。若饥缘饥故。生爱烦恼金刚。忆念我憎如是饮食。若食过量缘过量故。生憎烦恼金刚。我不忆念如是过度饮食。若比丘。知足善思量食。舍离憎爱烦恼金刚。是名舍离憎爱金刚

云何不求利。若不以粗食为足。多食嗜味贪味勤求悕望饮食。是名求利。若比丘。以粗食为足。量食嗜味不贪味不勤求不悕望饮食。是名不求利

云何勤力。若作是念。我食此食。欲身勤进自勉。是谓勤力

云何乐行。若饥缘饥故。生身心苦受。若食过度缘过度故。生身心苦受。是名不乐。若比丘知足。善思量食。无有不乐。是名乐行

云何勤精进不睡眠。若比丘。于昼或结加趺坐思惟。或经行心离障碍法。初夜若经行。若思惟心离障碍法。中夜右胁着床累脚而眠。思惟起觉想。后夜若思惟经行心离障碍法。是名勤精进不睡眠

云何离障碍法。障碍法谓五盖也。如佛说五盖。是心烦恼损智慧法。又如佛次说。若在家出家人。有五盖覆心。若自知义。若知他义。若知自他义。若过人法。若离欲知见增进。若知若见。无有是处。五盖遮碍善法。缠缚污染。生起结使。故名障碍。若修行清净去障碍法清白明了。是名离障碍法

云何断五盖。离灭没除。是谓断五盖。何谓心垢。五盖是心烦恼垢腻不明。是名心垢

云何损智慧法。五盖覆心。慧力羸劣。是名损智慧法

云何离欲恶不善法。欲谓五欲。复次尘非欲圣法中谓是求那。若忆想染着此是欲。如佛说

  种种色非欲　　众生想欲染
  世间色常住　　健者离欲染

若此五欲中。贪重贪堪忍系着。是名欲。云何恶不善法。身口意恶行。是名恶不善法。复次十不善业道。是名恶不善法。复次不善根相应法。不善根所起无缘非受法。是名恶不善法。复次贪欲嗔恚愚痴忿怒怨嫌妄语嫉妒悭惜谀谄欺伪匿恶无惭无愧贡高诤讼及我慢等。是名恶不善法。复次邪见邪觉邪语邪业邪命邪进邪念邪定邪解脱邪智及余随邪法。是名恶不善法。如是欲恶不善法。若远离不近不杂纯净别处。是名离欲恶不善法。云何有觉有观。若行觉观。是谓有觉有观。云何离生喜乐。若离欲恶不善法生喜乐。是名离生喜乐。云何成就初禅行。初禅有五支。觉观喜乐一心。云何觉。重觉究竟觉诸所忆念法明来至思惟心。是名觉。云何观。心行顺行微行津液微观心微转。是名观。云何喜。欢喜踊跃。是名喜。云何乐。心忍受乐意触乐受。是名乐。云何一心。心住正住是名一心。此五支。是名初禅。何谓初。若此四禅。以次顺不逆。以次入定门。此是始。此是初。此是一。是名初。何谓禅。谓舍心垢正舍缘舍。是谓名禅。复次烦恼未断能断。是名禅。复次烦恼断已得现世乐行。是名禅。复次如是善法成就。入禅明了。炽盛清净。是名禅。复次如是定住甚深妙义专著智慧。是名禅。复次行人。行觉观意喜心定如行人若受想思惟觉观见慧解脱无痴顺信悦喜心进心除信欲不放逸念心舍意界意识界。及余随色。是名禅。复次随法非禅是随禅法。若心住正住。此名禅。得是定已。护持威仪住行微行。是名成就初禅行。若比丘身离生喜乐。津液遍满。此身尽离生喜乐。津液遍满。无有减少。如善洗浴师善洗浴师弟子。以细澡豆。盛着器中。以水洒已。调适作揣。此揣津液遍满。不干不湿。内外和润。如是比丘。此身离生喜乐。津液遍满。无有减少。云何津。云何液。云何遍。云何满。如比丘住禅时。离生喜乐。初生正生起正起触证。身离生喜乐尔时名津住禅时。离生喜乐。渐开微行。未能增广。身离生喜乐。尔时名液住禅时。离生喜乐。能增广未至彼岸。身离生喜乐。尔时名遍住禅时。离生喜乐。能到彼岸。齐是谓身离生喜乐。尔时名满。如农夫初以水溉田地。始津润名津。润已水渐开微行未能增广名液。液已水渐增广未到彼岸名遍。遍已水到彼岸。一切高下尽满。满时水还攘水口名满。比丘亦如是。住禅时离生喜乐。初生正生起正起触证。身离生喜乐。尔时名津。离生喜乐。渐开微行未能增广身离生喜乐。尔时名液。离生喜乐。能增广未到彼岸。身离生喜乐。尔时名遍。离生喜乐。能至彼岸。齐是谓离生喜乐。尔时名身满。复次津液遍满。如是诸句。义一名异。如佛说。何谓觉。若觉重觉。究竟觉。诸所忆念法明来至思惟心语。是名觉诸比丘。此义不应如是说。觉异重觉异。究竟觉异。诸所忆念异法明来至异思惟心语异。如觉诸句义一名异。津液遍满亦如是。义一名异。如比丘修慈心。遍解东方南西北方四维上下。慈心普广。无异无量。无怨无恚。遍解一切世间行。尔时以众生为境界。如是比丘身离生喜乐。津液遍满。时以身为境界。不应如是说。如比丘应思惟无常行。离欲不善法。有觉有观。离生喜乐。成就初禅行。便离生喜乐。遍满身得离生喜乐已。除身炙心炙。身暖心暖。身热心热。身然心然。身燋心燋。身恶心恶。身不乐心不乐。身不调心不调。身不轻心不轻。身不暖心不暖。身不除心不除。如比丘除身炙心炙。乃至身不除心不除已。得身不炙不暖不热不然不燋。得乐则无烦恼金刚。不求利勤力乐行。齐是谓离生喜乐遍满身

云何灭觉观。若觉观寂静正寂静灭没除。是名灭觉观。云何内净信。内有信正胜信生。具足成就。是名内净信。云何一心。心独住正住正独处入定。是名一心。云何无觉无观。若除觉观已。定心喜乐。具足成就。是名无觉无观。云何定生喜乐成就二禅行。云何二禅。二禅有四支。内信喜乐一心。云何内净信。若比丘离欲恶不善法。有觉有观。离生喜乐。成就初禅行。如比丘思惟觉观粗我觉观粗内净信寂静胜。比丘思惟觉观粗已觉观寂静正寂静舍灭没除尽觉观寂静正寂静舍灭没除尽已内净信具足成就。是名内净信。如比丘若以行若受教若法相若方便若专心若思惟若触。离欲恶不善法。有觉有观。离生喜乐。成就初禅行。如比丘行若受教。乃至亲近多修学已。心向寂静尊上寂静。倾向寂静心向寂静。尊上寂静倾向寂静已。觉观寂静正寂静灭没除尽。觉观寂静正寂静灭没除尽已。内净信生。具足成就。是名内净信。复次比丘思惟觉观是粗法灭粗法心清净清净人心。是名内净行。复次比丘思惟觉观是粗法离粗法心清白清白心。是名内净信。复次比丘思惟觉观是粗法除粗法心明了明了。是名内净信。复次比丘思惟觉观是粗法无觉无观地寂静胜妙。是名内净信。复次比丘。思惟有觉观其心不软不调不清净不清白不明了。无觉观其心软调清净清白明了。其心软乃至明了。是名内净信。复次比丘。思惟无觉无观心喜心定如行人若信入信究竟入信胜信淳信心信。是名内净信。何谓喜。如行人欢喜踊跃。是名喜。何谓乐。如行人心忍受乐乐意触乐受。是名乐。何谓一心。如行人心信正信。是名一心。如是四支名二禅。何谓二。如四禅次顺不逆以次入定行二与初无有中间。是谓二。何谓禅。禅谓舍心垢正舍缘舍。是名禅。乃至复次无觉观行意喜心定如行人若受想思触思惟乃至及余所随色。是名禅。复次随法非禅是随禅法。若心住正住。是名禅。得是定已。护持威仪住行微行。是名成就二禅行。若比丘定生喜乐。津液遍满。此身尽定生喜乐。津液遍满。无有减少。如大陂湖。以山围绕。水从底涌出。不从东方南西北方来。自从底涌出。此陂津液遍满。无有减少。如是比丘。身定生喜乐。津液遍满。无有减少。云何津。云何液。云何遍。云何满。如比丘住禅时身定生喜乐生正生起正起重证身定生喜乐。尔时名津住禅时。定生喜乐。渐开微行。未能增广。身定生喜乐。尔时名液住禅时。身定生喜乐。能增广未到彼岸。定生喜乐。尔时名遍住禅时。定生喜乐。能至彼岸。齐是谓定生喜乐。尔时名身满。如农夫初以水溉田。始津润尔时名津。津润已水渐开微行。未能增广尔时名液。液已水遂增广。未到彼岸。尔时名遍。遍已水到彼岸。地一切高下尽满。满时水还攘水口。尔时名满。比丘亦如是。住禅时身定生喜乐生正生起正起触禅定生喜乐。尔时名津。乃至住禅时。定生喜乐能至彼岸。齐是谓定生喜乐。尔时名身满。复次津液遍满。如是诸句义一名异。如佛说。云何触。缘眼缘色生眼识。三法和合触。眼非触色非触。若此法共和合聚集。是谓触。诸比丘。此义不应如是说。共异和合异集异聚异。如此诸句。义一名异。津液遍满。亦复如是。义一名异。如比丘。修悲遍解东方南西北方四维上下。悲心普广。无异无量。无怨无恚。遍解一切世间行。尔时以众生为境界。比丘住禅时。身定生喜乐。津液遍满。以身为境界。不应如是说。如比丘应思惟苦行灭觉观内净信心。独无觉观。定生喜乐。成就二禅行。便定生喜乐。身遍满得定生喜乐已。除身炙心炙。乃至身不除心不除。得身不炙不暖不热不然不燋得乐则无烦恼金刚。不求利勤力乐行。齐是谓定生喜乐遍满身

云何离。喜灭没除尽。是谓离。云何舍行。谓共舍定得正得护持威仪住行微行。是名舍行。云何念正智。念正智成就。是名念正智。云何身受乐。乐谓忍乐意触乐受。是名乐。此乐身受正受微受缘受以何身受意身受。是名身受乐。云何如诸圣人解。圣人谓佛及声闻。知自地善法现世乐行。入定出定已。显示教化流布开解演说分别显现。是名如诸圣人解舍念乐行。云何成就三禅行。三禅有五支。共味舍念正智无喜乐一心。云何共味舍。如比丘。灭觉观内净信心触。无觉无观。定生喜乐。成就二禅行。如比丘。观喜粗我喜粗心踊跃共味舍胜寂静。如比丘观喜粗喜寂静正寂静灭没除尽。喜寂静正寂静灭没除尽已。共味舍生正生起正起。具足成就。是名共味舍。如比丘。若行乃至触灭觉观内净信心触无觉观。定生喜乐。成就二禅行。如比丘。行乃至触亲近正亲近多修学。如比丘行乃至触亲近正亲近多修学已。心向寂静心向寂静已。尊上寂静尊上寂静已。倾向寂静。倾向寂静已。喜寂静正寂静灭没除尽。喜寂静正寂静灭没除尽已。共味舍生正生起正起具足成就。是名共味舍。复次比丘离喜乐修无喜共味定。如行人舍胜舍心调正亲调心无作非受。是名共味舍。云何念。行人念忆念。是名念。云何正智。如行人智见解射方便。是名正智。云何无喜乐。如行人心不忍受苦乐意触不苦不乐受。是名无喜乐。云何一心。如行人心住正住。是名一心。如是五支。是名三禅。何谓三。如四禅次顺不逆。以次入定行三与二无有中间。是名三。云何禅。谓舍心垢正舍缘舍。是名禅。乃至复次离喜乐修无喜共味定。如行人受想思触思惟。乃至及余随色。是名禅。复次随法。非禅是随禅法。若心住正住。是名禅。得是定护持威仪住行微行。是名成就三禅行。如比丘。身无喜乐。津液遍满。无有减少。如优钵罗池波头摩池拘勿头池分陀利池花从埿涌出。未能出水。此花若根若头。水津液遍满。无有减少。如是比丘。身无喜乐。津液遍满。无有减少。云何津。云何液。云何遍。云何满。如比丘。住禅时无喜乐。初生正生起正起触证。如比丘住禅时。身无喜乐。尔时名津。乃至住禅时无喜乐。能到彼岸。齐是名无喜乐。尔时名身满。如农夫初以水溉田地。始津润尔时名津。津润已水渐开微行。未能增广。尔时名液。液已水遂增广。未到彼岸。尔时名遍。遍已水广。到彼岸。地一切高下。尽满满时。水还攘水口。如农夫放水处。齐是名满比丘亦如是。住禅时身无喜乐。生正生起正起触证。身无喜乐。尔时名津。乃至住禅时无喜乐。能到彼岸。齐是名无喜乐。尔时名身满。复次津液遍满。如是诸句。义一名异。如佛说此苦圣谛法未曾闻自思惟。生智生眼生觉生明生通生慧生解。诸比丘此不应如是说。谓智异眼异觉异明异通异慧异解异。如此诸句。义一名异。津液遍满。亦复如是。义一名异。如比丘。修喜心遍解东方南西北方四维上下。喜心普广。无异无量无怨无恚。遍解一切世间行。尔时以众生为境界。比丘住禅时。身无喜乐。津液遍满。以身为境界。不应如是说。如比丘应思惟无我法离喜舍行念正智身乐。如诸圣人解舍念乐行。成就三禅行。便无喜乐满身。得无喜乐已。除身炙心炙。乃至身不除心不除。如比丘。除身炙心炙乃至身不除心不除已。得身不炙乃至不燋得心不炙乃至不燋得乐则无烦恼金刚。不求利勤力乐行。齐是名无喜乐遍满身。云何断苦乐。如比丘断苦乐。是名断。云何先灭忧喜。如比丘忧喜已灭。寂静正寂静是名先灭忧喜。云何不苦不乐舍。如佛告舍利弗。如圣人离欲恶不善法成就喜行。尔时无有五法。谓共欲染相续喜乐。共欲染相续忧苦。共不善喜乐。共不善忧苦。共善忧苦。舍利弗如圣人离欲恶不善法。成就喜行。如是五法尽。无如圣人离欲恶不善法。得成就喜行共欲染相续喜乐乃至共善忧苦。尔时已灭。及余共善忧乐亦灭。是谓入第四禅。云何第四禅。第四禅有四支。不苦不乐舍念净一心。云何不苦不乐舍。如比丘。离喜舍行念正智身受乐。如诸圣人解舍念乐行。成就三禅行。如比丘。观无喜乐粗心。犹有作若不苦不乐舍。胜寂静观无喜乐粗无喜乐寂静正寂静灭没除尽已。不苦不乐舍生正生起正起具足成就。是名不苦不乐舍。如比丘若行乃至触离喜舍行念正智身受乐。如诸圣人解舍念乐行。成就三禅行。如比丘行乃至触亲近多修学已。向寂静已向寂静。尊上寂静尊上寂静。倾向寂静倾向寂静已。无喜乐寂静。无喜乐寂静灭没除没除尽已。不苦不乐舍。生正生起正起具足成就。是名不苦不乐舍。复次比丘。虽无喜乐。修不苦不乐舍定。如行人身心不忍受苦乐眼触不苦不乐受乃至意触不苦不乐受。是名不苦不乐舍。云何念。如行人念忆念。是名念。云何净。如行人念离欲染清净。离恶不善法清净。离觉清净。离观清净。离喜清净。离乐清净。离苦清净。离忧清净。及离余烦恼法清净。是名净。云何一心。如行人若心住正住。是名一心。此四支。是名第四禅。何谓四禅。次顺不逆。以次入定行四与三无有中间。是名四。何谓禅。舍心垢正舍缘舍。是名禅。乃至复次离无喜乐修不苦不乐舍定。如行人受想思触思惟。乃至及余随色。是名禅。复次随法非禅是修禅法心住正住。是名禅。得如是定。护持威仪住行微行。是名成就四禅行。如比丘。修清净深心。身遍解行。无不遍处。如男子女人。着白净衣。上下具足。从头至足。从足至头。无不遍处。比丘亦尔。修清净心。身遍解行。无不遍处

比丘入第四禅。心不高不下不憎不爱定住不动。犹如静室埿治内外户牖俱闭无有风尘。于其室内。然以油灯。若人非人。若风若鸟。无有触者。然焰不高不下不倾不曲定住不动。比丘入第四禅。亦复如是。心不高不下。乃至定住不动。云何高心。共掉相应心。是名高心。云何下心。共懈怠相应心。是名下心。复次共七慢相应心。是名高心。共我相应心。是名下心。云何爱心。共染相应心。是名爱心。云何憎心。共嗔恚相应心。是名憎心。此四禅中。心不共掉不掉相应。乃至不共嗔恚相应。是名不高不下不憎不爱。云何住。若心住正住独处定。是名住。云何不动处。不动谓第四禅。如佛语优陀夷。若比丘。离欲恶不善法。有觉有观。离生喜乐。成就初禅行。我说是动。此有何动。谓觉观不灭。若比丘。灭觉观内净信一心无觉无观。定生喜乐。成就二禅行。我说是动。此有何动。谓喜未灭。若比丘离喜舍行念正智身受乐。如诸圣人解舍念乐行。成就三禅行。我说是动此有何动。谓舍乐未灭。若比丘断苦乐先灭忧喜不苦不乐舍心净。成就四禅行。我说是不动。若比丘离欲恶不善法入初禅。从初禅起入二禅。从二禅起入三禅。从三禅起入四禅。是谓到不动处

比丘如是修学四禅。欲证通法。随心所欲。即能得证。自在无碍。如四衢平处有善调驾驷有善御者随意自在。如是比丘亲近四禅多修学已。欲证通法。随心即得。自在无碍。如盛水瓶。坚牢不漏。盛以净水。平满为饮。随人取用。如意自在。如是比丘亲近四禅多修学已。欲证通法。随心所欲。自在无碍。如陂泉遮水。平满为饮。随人决用。如意自在。如是比丘亲近四禅。多修学已。欲证通法。随心所欲。即能得证。自在无碍。若比丘欲以神足动地。能以一为多。以多为一。乃至梵天身。得自在随所欲入。若欲受天耳清净过人。能闻二声。人非人声。随所能入。若欲知他众生。能知有欲心。如实知有欲心无欲心。如实知无欲心。随所能入。若欲忆念无量宿命能忆一生。乃至成就此行。随所能入。若欲受天眼清净过人。能见众生生死。乃至如所造业。随所能入。若欲尽有漏成无漏。得心解脱慧解脱。现世自知证成就行。我生已尽。梵行已立。所作已办。不受后有。随所能入。如是四禅亲近多修学。得如是果报

舍利弗阿毗昙论卷第十四舍利弗阿毗昙论卷第十五

        姚秦罽宾三藏昙摩耶舍共昙摩崛多等译

    非问分道品第十之一

有人出世。如来无所著等正觉。说种种因种种门种种道种种向道。今当集诸道门。有一支道二支道三支道四支道五支道六支道七支道八支道九支道十支道十一支道。云何一支道。身念处。是名一支道。云何二支道。定慧。是名二支道。云何三支道。有觉有观定。无觉有观定。无觉无观定。空定无想定。无愿定是名三支道。云何四支道。四念处。四正断四神足四禅四无量四无色定四向道四修定四断。是名四支道。云何五支道。五根五力五解脱入五出界五观定五生解脱法。是名五支道。云何六支道。六念六向六出界六明分法六悦因法六无喜正觉。是名六支道。云何七支道。七觉七想七定因缘法。是名七支道。云何八支道。八圣道八解脱八胜入。是名八支道。云何九支道。九灭九次第定九想。是名九支道。云何十支道。十想十直法十一切入。是名十支道。云何十一支道。十一解脱入。是名十一支道

何谓身念处一支向涅槃道。谓念至身依身以身始观。是名身念处。此念亲近多修学得须陀洹果乃至阿罗汉果。是名身念处一支向涅槃道。复次比丘思惟身无常。知无常解无常受无常。如实人念忆念是名身念处。此念亲近多修学得须陀洹果乃至阿罗汉果。是名身念处一支向涅槃道。复次比丘身苦恼痈箭味患依缘坏法不定不满可坏苦空无我。思惟缘。知缘受缘。即无明缘行。行缘识。识缘名色。名色缘六入。如实人念忆念。是名身念处。此念亲近多修学得须陀洹果乃至阿罗汉果。是名身念处一支向涅槃道。复次比丘思惟身灭。知灭解灭受灭。即无明灭。无明灭则行灭。行灭则识灭。识灭则名色灭。名色灭则六入灭。如实人念忆念。是名身念处。此念亲近多修学得须陀洹果乃至阿罗汉果。是名身念处一支向涅槃道。复次比丘。行知行乐住知住乐坐知坐乐卧知卧乐。如是身住乐。如实人念忆念是名身念处。此念亲近多修学得须陀洹果乃至阿罗汉果。是名身念处一支向涅槃道。复次比丘。去来屈伸应正智行。执持衣钵。如法饮食。病瘦医药除疲极睡眠。及大小便利于行住坐卧觉悟说法默然。应正智行。如实人念忆念。是名身念处。此念亲近多修学得须陀洹果乃至阿罗汉果。是名身念处一支向涅槃道。复次比丘。出息长知出息长。入息长知入息长。出息短知出息短。入息短知入息短。如旋师旋师弟子绳长知长绳短知短。如是比丘。出息长知长。入息长知长。出息短知短。入息短知短。如实人念忆念。是名身念处。此念亲近多修学得须陀洹果乃至阿罗汉果。是名身念处一支向涅槃道。复次比丘。从顶至足。皆是不净。此身中有爪齿发毛薄皮厚皮肉筋脉脾肾心肺大小秽处涕唾脓血脂肪脑膜泪汗骨髓。如净眼人。于一门仓。观见诸谷。胡麻米豆小豆豍豆大麦小麦。如是比丘。观此身中。从顶至足。皆是不净。此身中但有爪齿乃至骨髓。如实人念忆念。是名身念处。此念亲近多修学得须陀洹果乃至阿罗汉果。是名身念处一支向涅槃道。复次比丘。观四大。此身有地大水大火大风大。如屠牛师屠师弟子屠牛为四分若坐若立观此四分。如是比丘。观此身地大水大火大风大。观此诸大。各各相违。有此诸大依于外大饮食长养羸劣不坚念念磨灭暂住不久。如实人念忆念。是名身念处。此念亲近多修学得须陀洹果乃至阿罗汉果。是名身念处一支向涅槃道。复次比丘。如是观此身依食住依食长养。缘食住无食不住。如火依薪得然无薪则灭。如是比丘观此身依食住依食长养。缘食住无食不住。如世尊说

  观身所集苦　　一切皆缘食
  若能除灭食　　则无是诸苦
  如是知过患　　食是成就苦
  比丘灭食已　　决定得涅槃

如是人念忆念实名身念处。此念亲近多修学。得须陀洹果乃至阿罗汉果。是名身念处一支向涅槃道。复次比丘观身尽空俱空。以念遍知解行。如竹苇尽空俱空。如是比丘观身尽空俱空。以念遍知解行。如实人念忆念。是名身念处。此念亲近多修学。得须陀洹果乃至阿罗汉果。是名身念处一支向涅槃道。复次比丘。观身是痈疮。身中有九疮津漏门。所出津漏。皆是不净津漏。是胎始膜。是腐败。是臭秽。是可恶津漏。眼出眵泪脓血津漏。耳出耵[月*寧]脓血津漏。鼻出涕痰脓血津漏。口出涕唾脓血津漏。二处出便利脓血津漏。如人痈疮干痂久住。如是九疮津漏门所出。皆是不净津漏。是胎始膜。是腐败。是臭秽。是可恶津漏。比丘如是观身是痈疮。此身九入九疮九津九漏。眼耳鼻口一一处所出津漏皆是不净津漏。是胎始膜。是腐败。是臭秽。是可恶津漏。眼出眵泪脓血津漏。耳出耵[月*寧]脓血津漏。鼻出涕痰脓血津漏。口出涕唾脓血津漏。二处出便利脓血津漏。如摩诃迦叶所说。四大身是衰耗相违津漏。众病所居处。众苦所依处。爱护身者。如爱护死尸。寿命短促。如实人念忆念。是名身念处。此念亲近多修学。得须陀洹果乃至阿罗汉果。是名身念处一支向涅槃道。复次比丘。观三根集业。贪根集业。恚根集业。痴根集业。若贪作业贪共贪绪贪集贪因贪缘身口意是非圣业。是有漏业。是集业非灭垢业。嗔恚愚痴。亦复如是。若成就此业。父母具足有漏心向阴欲受生。彼阴灭处母胎生初识有色共彼识四大所造色。谓色由意生受想思触谓名如是名色共生共起。彼不从东方南西北方四维上下来。不从父母出。不从业出。亦非余处出。因众缘和合。因集因业因父母出。如春后月无有云雾。日中时有人持火珠。以干牛粪坋上。便有火生有光出。如是观火。不从东方乃至牛粪中出。如是众缘和合有火生光出。比丘如是观名色。不从东方。乃至不从业出。众缘和合因集因父母生。便有色名。七日时。是胎始膜。复七日如云。复七日初肉。复七日始坚。乃至四十九日。身肢节具足。帝释问世尊。诸佛不以色为我。云何身有觉。云何水中生骨。复云何能住胎。问已有答。世尊为决疑。一切行生灭。世尊。如实知一切行生灭。帝释谛听。我今当说。初有胎始膜。因胎始膜。便有如云。因如云便有初肉。因初肉便有始坚。因始坚便有支节诸入爪发。因母饮食便住。帝释复问

  众生不知何法　　众生不觉何法
  众生何法染贪　　众生何法系缚

世尊答

  众生不知生法　　众生不觉灭法
  众生身法染贪　　众生爱法系缚
  帝释宜实谛听　　知因法则能离
  慧者能度死流　　度已终不复还

若母怀妊。或九月。或十月。身重自爱护。若九月若十月爱护重身已。便生子。生已母以血养。圣法中。以母乳为血。后便能食能食已。诸根增长。诸根增长已诸根具足。后则衰变。骨节离解。皮缓面皱。气力微弱。齿落发白。身体偻曲。拄杖羸劣。气息转少。不耐苦痛。壮时已过。血肉渐消。多诸苦患。死命迫促。如尸婆罗所说

  人命去不还　　日夜常衰损
  如鱼处热水　　生苦死复逼

以如是方便。知法无常有为缘生。尽法变法。离法灭法。我所非我有。我非我所有。我我所。皆无有我。如是慧者。正观不放逸。勤念正慧寂静行。若依贪妄想断。断已内心正住正止。独处得定。如实人念忆念是名身念处。此念亲近多修学得须陀洹果乃至阿罗汉果。是名身念处一支向涅槃道。复次比丘。如是思惟。人有眼耳鼻舌身意。假名为人。眼耳鼻舌身意非人。离眼耳鼻舌身意亦非人。若如是法。正生正成就正出。假名为人。如舍有梁椽墙壁假名为舍。梁椽墙壁非舍。离梁椽墙壁亦非舍。若如是法。正生正成就正出。假名为舍。比丘如是思惟。人有眼耳鼻舌身意假名为人。眼耳鼻舌身意非人。离眼耳鼻舌身意亦非人。比丘若如是法。正生正成就正出。假名为人。如象经所说。比丘缘木缘竹缘绳索缘泥围绕虚空。假名为舍。比丘如是缘骨缘筋缘血肉缘皮肤围绕虚空。假名为我。以如是方便。知此法无常有为缘生。尽法变法。离法灭法。我所非我有。我非我所有。我所我皆无有我。如是正慧见。如是不放逸。勤念正智寂静行依贪妄想断。断己内心正住正止独处定。如实人念忆念。是名身念处。此念亲近多修学得须陀洹果乃至阿罗汉果。是名身念处一支向涅槃道。复次比丘。如是思惟。缘有眼。假名为我。无眼亦不假名为我。眼非我离眼。若是我眼。应当有异。以眼非我故。眼无有异。若无眼亦不假名为我。以眼非我离眼亦非我。以是故。缘眼假名为我。无眼亦不假名为我。耳鼻舌身。心缘心假名为我。无心亦不假名为我。心非我离心非我心。若是我心。应当有异。以心非我故。心无有异。若无心亦不假名为我。以心非我离心亦非我。以是故。缘心假名为我。无心亦不假名为我。如世尊说。若说眼为我者非也。眼有生灭。若生灭者。我亦应生灭。则有此负。是故非也。若说眼为我者此事不然。耳鼻舌身心亦复如是。如是方便知此法无常。有为缘生。尽法变法。离法灭法。我所非我有。我非我所有。我所我。皆无有我。如是正慧见。如是不放逸勤念正智寂静行。依贪妄想断。断已内心正住正止独处定。如实人念忆念。是名身念处。此念亲近多修学得须陀洹果乃至阿罗汉果。是名身念处一支向涅槃道。复次比丘。如是思惟。若见色是我。受想行识是我。此见共欲共嗔恚共愚痴共取共忍住共苦共虚妄共众恼共燋热。不解射。不离欲。不灭。不寂静。不正觉。不得沙门果。不得涅槃。若此见成就。于生老病死苦本。则聚集和合。若见色无我。受想行识无我。此见不共嗔恚。不共愚痴。不共取。不共忍住。不共苦。不共虚妄。不共众恼。不共燋热。解射离欲灭。寂静正觉。得沙门果得涅槃。若此见成就。于生老病死苦本。则不聚集和合。如世尊说。诸比丘。有人如是见缘有我有我所缘有我所有。我言有我有我所。若实若有。尽不可得。诸比丘此非纯愚法也。世尊是也。诸比丘。如愚者计有常。不异不异物不变法。常定住有是也。世尊有也。诸比丘。若计有常。不异不异物不变法。常当定住也。世尊无也。若愚者计有我。若我常不异不异物不变法。常定住有是也。世尊有也。诸比丘。计有我。若当不异不异物不变法。常当定住也。世尊无也。诸比丘。若愚者依止。若依常见。不异不异物不变法。常当定住也。世尊有也。诸比丘。若依止。若依常见。不异不异物不变法。常当定住也。世尊无也。以是故。诸比丘若一切色。过去未来现在。内外粗细。卑胜远近。如是一切色。我非我所有。我所非我有。我所我。皆无有我。是谓正慧观。受想行识观亦如是。复次比丘。若作是见。我乐世乐当乐常不异不异物不变法常定住。但我所非我有。我非我所有。我我所皆无有我。是谓正慧观。若作是见。我断灭。但我所非我有。我非我所有。我我所皆无有我。是谓正慧观。若作是见。我能见闻觉知思惟分别。但我所非我有我非我所有。我我所皆无有我。是谓正慧观。圣人若如是见如是闻。有我有我所。终无惊恐。复次如世尊说。色非我。若色是我。色不应受苦患。色应得自在。如是有如是非有。以色非我故。色受苦患。色不得自在。如是非有。受想行识非我。我非识。若识是我。识不应受苦患。识应得自在。如是有如是非有。以识非我故。识受苦患。识不得自在。如是有。如是非有。是故当知此法无常有。为缘生。尽法变法离法。我所非我有。我非我所有。我我所。皆无有我。是谓正慧观。如是不放逸勤念正智寂静行。依贪妄想断。断已内心正住正止独处定。如实人念忆念。是名身念处。此念亲近多修学。得须陀洹果乃至阿罗汉果。是名身念处一支向涅槃道。复次比丘。如是思惟世间种种苦。此苦何因何绪何集何生何尊上。如是思惟世间种种苦阴。因阴绪阴集阴生阴尊上缘阴。有丧父母兄弟姊妹妻子亲属苦。有衰耗众病苦。有诸不适意触。若手拳触。鞭杖触。瓦石触。刀杖触。寒热触。饥渴触。风日触。蚊虻触。有国王大臣。枷锁系闭縺缚。肉断骨出如贝骑利木刀。以石锤脚。五车磔裂。以绳拘结。火鬘烧身。身为火[火*(十/甲/寸)]。以刀削身。以钩钩肉。剥皮蜜涂。令虫唼食。草裹火烧。扇车吹身令破。铁鍱缠身。断手足耳鼻。驱上标头。以箭射杀。最后斩杀。有如是等苦。如世尊说

  无有如欲火　　无有如恚毒
  无有如痴网　　无有如阴苦
  如实知此已　　涅槃第一乐

是故当知。此法无常有。为缘生。尽法变法离法灭法。我所非我有。我非我所有。我我所皆无有我。是谓正慧观。如是不放逸勤念正智寂静行。依贪妄想断。断已心正住正止独处定。如实人念忆念。是名身念处。此念亲近多修学得须陀洹果乃至阿罗汉果。是名身念处一支向涅槃道。复次比丘。如是思惟身多苦多失多恼多悲多众苦。观身生正生起正起出正出成就具足生种种病。若因热生病。因阴生病。因风生病。因自力生病。因他恼生病。因时变生病。因诸大相违生病。因食不消生病。因业报生病。因集生病。眼病耳鼻舌身病。头痛肩痛。牙齿咽项。脑痛蛇肌。气逆呼呷咽塞謦欬呕吐下利绞痛热病腹痛。疮癣疥[癈-(弓*殳)+虫]皮肤[病-丙+習][病-丙+習]如虫行。侵淫疮癞疮痈疮白癞枯燥瘨狂病痔病赤肿病。外为种种虫啖蚤虱壁虱蚊虻蟆子。内乃至一毛处。无不有虫。如世尊说。色生住出生病居苦出老死。若受想行识生住出生病居苦出老死。复次如世尊说。三苦。行苦。苦苦。变苦。是故当知。此法无常有。为缘生。尽法变法离法灭法。我所非我有。我非我所有。我我所皆无有我。是谓正慧观。如是不放逸勤念正智寂静行依贪妄想断。断已内心正住正止独处定。如实人念忆念。是名身念处。念亲近多修学。得须陀洹果。乃至阿罗汉果。是名身念处一支向涅槃道。复次比丘。如是思惟。何因何住何非因何非住。如是思惟。因脚骨住膞骨。因膞骨住髀骨。因髀骨住臗骨。因臗骨住脊骨。因脊骨住肋骨。因手骨住臂骨。因臂骨住肩骨。因肩骨住项骨。因项骨住头骨。因髓住骨因骨住筋。因筋住肉。因肉住血。因血住皮。因皮住薄皮。因薄皮住毛。如因空住风因风住水因水住地因地住诸作业及种子聚落。众生聚落。药草丛林。比丘如是思惟。因脚骨住膞骨。因膞骨乃至头骨。因髓住骨。因骨乃至住毛。若无脚骨膞骨不住。无膞骨髀骨不住。无髀骨臗骨不住。无臗骨脊骨不住。无脊骨肋骨不住。无手骨臂骨不住。无臂骨肩骨不住。无肩骨项骨不住。无项骨头骨不住。无髓骨不住。无骨筋不住。无筋肉不住。无肉血不住。无血皮不住。无皮薄皮不住。无薄皮毛不住。如无虚空风不住。如无风水不住。若无水地不住。如无地诸作业及种子畴类众生聚落药草丛林不住。比丘如是思惟。若无脚骨膞骨不住。无膞骨乃至头骨不住。无髓骨不住。无骨乃至毛不住。以骨盛髓筋缠骨肉覆筋血涂肉皮裹血薄皮膜厚皮毛衣薄皮。如世尊说。若法生灭。因行住行。是故当知。此法无常有。为缘生。尽法变法离法灭法。我所非我有。我非我所有。我我所皆无有我。是谓正慧观。如是不放逸勤念正智寂静行依贪妄想断。断已内心正住正止独处定。如实人念忆念。是名身念处。此念亲近多修学。得须陀洹果乃至阿罗汉果。是名身念处一支向涅槃道。复次比丘。如是思惟。何因何假。何非因何非假。如是思惟。因身有假身业。无身无假身业。因口有假口业。无口无假口业。因意有假意业。无意无假意业。若身作业。若口说业。业触身去来屈伸回转身教。集声音句言语口教。若因意作业。无意无作业。如巧匠巧匠弟子。刻作木人。动作机关。能令去来坐卧。如是若身作业。若口说业。业触身去来屈伸回转身教。集声音句言语口教。若因意作业。无意无作业。如世尊说

  心为法本　　心尊心使　　中心念恶
  即言即行　　罪苦自追　　车轹于辙
  心为法本　　心尊心使　　中心念善
  即言即行　　福乐自追　　如影随形

是故当知。此法无常有。为缘生。尽法变法离法灭法。我所非我有。我非我所有。我我所皆无有我。是谓正慧观。如是不放逸勤念正智寂静行依贪妄想断。断已内心正住正止独处定。如实人念忆念。是名身念处。念亲近多修学得须陀洹果乃至阿罗汉果。是名身念处一支向涅槃道。复次比丘。如是思惟。若最后行。未知而灭。若无间行灭已。识续余道生。彼行缘彼识。名无间缘。若因行彼识续余道生。彼行缘彼识。名因缘。若思惟行识。续余道生。彼行缘彼识。名缘缘。若依行识续余道生。彼行缘彼识。名依缘。若报行识续余道生。彼行缘彼识。名报缘。若行起识续余道生。彼行缘行识。名起缘。若相应行识续余道生。彼行缘彼识。名异缘。若增上趣彼识增上续余道生。彼行缘彼识。名增上缘。此最后识灭初识续余道生。最后识灭已。初识即生。无有中间。如影移日。续日移影。续影与日。无有中间。如是最后识灭。初识续余道生。后识灭已。即生初识。无有中间。如此最后识。若最后识相应法。不至初识。若初识初识相应法。不至后识。如眼识灭已生耳识。耳识灭已生眼识。眼识相应法。不至耳识。耳识相应法。不至眼识。如是后识后识相应法。不至初识。初识初识相应法。不至后识。若后识灭已即生初识。谓此时过。谓此灭后生。谓此终彼始。非命是身。非身是命。非命异身。非身异命。非命非断。非生非住。非有变。非无因。非天所作。非此作此受。非异作异受。知有去来。知有生死。知有业相续。知有说法。知有缘。无有从此至彼者。无有从彼至此者。但行相续生。以业缘故。如世尊说。我所空。我于我所。不应疑我我所。不应说于一切法不应疑。是故当知。此法无常有为缘生尽法变法灭法离法。我所非我有。我非我所有。我所我皆无有我。是谓正慧观。如是不放逸勤念正智寂静行依贪妄想断。断已内心正住正止独处定。如实人念忆念。是名身念处。念亲近多修学得须陀洹果乃至阿罗汉果。是名身念处一支向涅槃道。复次比丘。若见婴儿。心愚痴无识。眠卧秽处。如是思惟。我亦如是法如是相。未离是法。我身亦是有生法。有生过患。如实人念忆念。是名身念处。念亲近多修学得须陀洹果乃至阿罗汉果。是名身念处一支向涅槃道。复次比丘。若见男子女人。年老衰熟。发白齿落皮缓面皱身体偻曲柱杖羸步气息不调。如是思惟。我身亦如是法如是相。未离是法。我身亦是有老法。有过患。如实人念忆念是名身念处。念亲近多修学得须陀洹果乃至阿罗汉果。是名身念处一支向涅槃道。复次比丘。若见男子女人。身患苦有。眠卧秽处。羸劣无力。动止须人。如是思惟。我身亦如是法如是相。未离是法。我身亦有病。有病过患。如实人念忆念。是名身念处。念亲近多修学得须陀洹果乃至阿罗汉果。是名身念处一支向涅槃道。复次比丘。若见男子女人身坏时过。若是亲属若非亲属。弃其死尸。如草粪土。如是思惟。我身如是法如是相。未离是法。我身亦坏法。有死过患。如实人念忆念。是名身念处。念亲近多修学得须陀洹果乃至阿罗汉果。是名身念处一支向涅槃道。复次比丘。见死尸弃在冢间。一日至三日。观自身。如是法如是相。未离是法。如实人念忆念。是名身念处。念亲近多修学得须陀洹果乃至阿罗汉果。是名身念处一支向涅槃道。复次比丘。见死尸弃在冢间。一日至三日。膖胀青瘀。观自身。如是法如是相。未离是法。如实人念忆念。是名身念处。念亲近多修学得须陀洹果乃至阿罗汉果。是名身念处一支向涅槃道。复次比丘见死尸弃在冢间。一日至三日。若乌鸟虎狼。为若干诸兽所食啖。观自身。如是法如是相。未离是法。如实人念忆念是名身念处。念亲近多修学得须陀洹果乃至阿罗汉果。是名身念处一支向涅槃道。复次比丘。见死尸骨节相连青赤烂坏脓血不净臭秽可恶。观自身。如是法如是相。未离是法。如实人念忆念。是名身念处。念亲近多修学得须陀洹果乃至阿罗汉果。是名身念处一支向涅槃道。复次比丘。见死尸骨节相连血肉所覆筋脉未断。观自身。如是法如是相。未离是法。如实人念忆念。是名身念处。念亲近多修学得须陀洹果乃至阿罗汉果。是名身念处一支向涅槃道。复次比丘。见死尸骨节相连血肉已离筋脉未断。观自身。如是法如是相。未离是法。如实人念忆念。是名身念处。念亲近多修学得须陀洹果乃至阿罗汉果。是名身念处一支向涅槃道。复次比丘。见死尸骨节已坏未离本处。观自身如是法如是相。未离是法。如实人念忆念。是名身念处。念亲近多修学得须陀洹果乃至阿罗汉果。是名身念处一支向涅槃道。复次比丘。见死尸骨节已坏远离本处脚髀膊臗脊胁肋手足肩臂项髑髅各自异处。观自身如是法如是相。未离是法。如实人念忆念。是名身念处。念亲近多修学得须陀洹果乃至阿罗汉果。是名身念处一支向涅槃道。复次比丘。见死尸骨节久故色白如贝色青如鸽朽败碎坏。观自身如是法如是相。未离是法。如实人念忆念。是名身念处。念亲近多修学得须陀洹果乃至阿罗汉果。是名身念处一支向涅槃道。复次比丘。见死尸在火聚上。一切发毛。皮肤血肉。筋脉骨髓。一切发毛。乃至骨髓渐渐消尽。观此身法。不至东方南西北方四维上下住。此身法本无而生已有还灭。如实人念忆念。是名身念处。念亲近多修学得须陀洹果乃至阿罗汉果。是名身念处一支向涅槃道。何谓身念。身发起生。是名身念。思惟身生。是名身念。身境界生。是名身念。依身生。是名身念。身分别生。是名身念处。何谓定慧二支向涅槃道。何谓定。心住正住。是名定。何谓慧。智分别是名慧。如是定如是慧。是名定慧。亲近多修学已得须陀洹果斯陀含果阿那含果阿罗汉果。是名定慧二支向涅槃道。复次比丘。若一切有为法。若一处有为法。思惟无常知无常解无常受无常。如是不放逸观。得定心住正住。是名定。如实人若智分别。是名慧。如是定如是慧。是名定慧。定慧亲近多修学得须陀洹果乃至阿罗汉果。是名定慧二支向涅槃道。复次比丘。若一切有为法。若一处有为法。思惟苦患痈箭着味。依缘坏法。不定不满。变灭可坏。苦空无我。思惟缘知缘解缘受缘。即无明缘行。行缘识。识缘名色。名色缘六入。六入缘触。触缘受。受缘爱。爱缘取。取缘有。有缘生。生缘老死忧悲苦恼纯苦聚集。如是不放逸观。得定心住正住。是名定。如实人若智分别。是名慧。如是定如是慧。是名定慧。定慧。亲近多修学得须陀洹果乃至阿罗汉果。是名定慧二支向涅槃道。复次比丘。若一切有为法。一处有为法。思惟灭知灭解灭受灭。即无明灭。无明灭则行灭。乃至纯苦聚集灭。如是不放逸观。得定心住正住。是名定。如实人若智分别。是名慧。如是定。如是慧。是名定慧。定慧亲近多修学得须陀洹果乃至阿罗汉果。是名定慧二支向涅槃道。复次比丘。行知行乐住知住乐坐知坐乐卧知卧乐。如身行住坐卧乐。如实知不放逸观。得定心住正住。是名定。如实人若智分别。是名慧。如是定。如是慧。是名定慧。定慧亲近多修学得须陀洹果乃至阿罗汉果。是名定慧二支向涅槃道。乃至若见死尸在火聚上。亦如上说。复次比丘。如是思惟。我内有欲染。如实知内有欲染。若内无欲染。如实知内无欲染。如欲染未生。如实知未生。如欲染生。如实知生。如欲染生已断。如实知断。如欲染断已。如实知更不复生。内有嗔恚睡眠掉悔疑亦如是。如是不放逸观。得定心住正住。是名定。如实人若智分别。是名慧。如是定。如是慧。是名定慧。定慧亲近多修学得须陀洹果乃至阿罗汉果。是名定慧二支向涅槃道。复次比丘。如是思惟。我内眼识色有欲染嗔恚。如实知内眼识色有欲染嗔恚。内眼识色无欲染嗔恚。如实知内眼识色无欲染嗔恚。如未生眼识色欲染嗔恚。如实知未生。如未生眼识色欲染嗔恚生。如实知生。如生眼识色欲染嗔恚已断。如实知断。如眼识色欲染嗔恚断已。如实知更不复生。耳识声鼻识香舌识味身识触意识法亦如是。不放逸观得定心住正住。是名定。如实人若智分别。是名慧。如是定。如是慧。是名定慧。定慧亲近多修学得须陀洹果乃至阿罗汉果。是名定慧二支向涅槃道。复次比丘。如是思惟。我内有念正觉。如实知内有念正觉。内无念正觉。如实知内无念正觉。如念正觉未生。如实知未生。如念正觉未生生。如实知生。如念正觉已生具足修。如实知具足修。择法正觉精进正觉除正觉定正觉舍正觉亦如是。如是不放逸观。得定心住正住。是名定。如实人若智分别。是名慧。如是定。如是慧。是名定慧。定慧亲近多修学得须陀洹果乃至阿罗汉果。是名定慧二支向涅槃道。复次比丘。如实知苦苦集苦灭苦灭道。如实知漏漏集。漏灭漏灭道。如是不放逸观。得定心住正住。是名定。如实人若智分别。是名慧。如是定。如是慧。是名定慧。定慧亲近多修学得须陀洹果乃至阿罗汉果。是名定慧二支向涅槃道。复次比丘。心畏怖故。出一切有为。入甘露界。此寂静胜离一切有为爱尽涅槃。如是不放逸观。得定心住正住。是名定。如实人若智分别。是名慧。如是定。如是慧。是名定慧。定慧亲近多修学得须陀洹果乃至阿罗汉果。是名定慧二支向涅槃道。何谓定。烦恼未断者。欲染断正断寂静。嗔恚愚痴烦恼障碍覆盖诸缚恶行灭正灭寂静。如秋时多起尘土云雾即时雨堕灭尘土云雾。灭正灭寂静。如是定如烦恼未断者。欲染断正灭寂静。嗔恚愚痴障碍覆盖诸缚恶行灭正灭寂静是名定。何谓慧。如实人若智分别。色如实分别色。受想行识亦如是。如明眼人。上高山顶。若观东方。如实分别。若南西北方。如实分别。如是慧。如实分别色受想行识。是名慧

云何有觉有观定。若定觉观。相应觉观。共生共住共灭。是名有觉有观定。复次有觉有观定。若定觉观得正得缘得。是名有觉有观定。复次有觉有观定。比丘离欲恶不善法。有觉有观。离生喜乐。成就初禅行。比丘有觉有观。喜乐一心。若入此定者。得五支正得缘得觉观喜乐一心。是名初禅有觉有观定。复次比丘。若得有觉有观定。有喜共味定。比丘观喜粗心有悲无喜乐胜寂静。比丘观喜粗已。喜寂静正寂静灭没除。喜寂静正寂静灭没除已故。有觉观无喜乐一心。若入此定者。得四支正得缘得觉观。无喜乐一心。是名非禅非禅间有觉有观定。如比丘。若行若受教若法相若方便若专心若思惟若触得有觉有观有喜共味定。如比丘行受教法相方便专心思惟触亲近多修学。如比丘行乃至触亲近多修学已。心向寂静。心向寂静已。尊上寂静。尊上寂静倾向寂静。倾向寂静已。喜寂静。喜寂静正寂静。正寂静灭没除。灭没除已。有觉观无喜乐一心。若入此定者。得四支正得缘得觉观无喜乐一心。是名非禅非禅间有觉有观定。复次比丘。若得有觉有观无喜乐共味定。此比丘观无喜乐粗心有作不苦不乐舍寂静胜。此比丘观无喜乐粗已。无喜乐寂静。寂静正寂静。正寂静灭没除。灭没除已故。有觉有观不苦不乐舍一心。若入此定者。得四支正得缘得觉观不苦不乐舍一心。是名非禅非禅间有觉有观定。如比丘若行若受教若法相。若方便若专心。若思惟若触得。有觉有观无喜乐共味定。如比丘行乃至触亲近多修学已。心向寂静。心向寂静尊上寂静。尊上寂静倾向寂静。倾向寂静已。无喜乐寂静。寂静正寂静。正寂静灭没除。灭没除已。有觉有观不苦不乐舍一心。若入此定者。得四支正得缘得觉观不苦不乐舍一心。是名非禅非禅间有觉有观定。云何无觉有观定。若定离觉。观相应不共觉生不共住不共灭。观共生共住共灭。是名无觉有观定。复次无觉有观定。若定不得觉不正得不缘得。观得正得缘得。是名无觉有观定。复次无觉有观定。若比丘。得有觉有观有喜共味定。此比丘观觉粗。无觉有观定寂静胜。此比丘观觉粗已觉寂静。觉寂静正寂静。正寂静灭没除。灭没除已。故有观喜乐一心。若入此定者。得四支正得缘得观喜乐一心。是名禅间无觉有观定。如比丘若行若受教若法相若方便若专心用意。若思惟若触得有觉有观有喜共味定。此比丘彼行乃至触亲近多修学。如比丘行乃至触亲近多修学已。心向寂静尊上寂静倾向寂静。心向寂静尊上寂静倾向寂静已。觉寂静正寂静灭没除。觉寂静正寂静灭没除已。故有观喜乐一心。若入此定者。得四支正得缘得观喜乐一心。是名禅间无觉有观定。何谓禅间。是初禅二禅间。从初禅趣二禅时。复次比丘。得无觉有观有喜共味定。比丘观喜粗喜心。犹有悲无喜。乐寂静胜。比丘观喜粗已。喜寂静正寂静灭没除。喜寂静正寂静灭没除已。故有观无喜乐一心。若入此定者。得三支正得缘得观无喜乐一心。是名非禅非禅间无觉有观定。如比丘。若行。若受教。若法相。若方便。若专心。若思惟。若触。得无觉有观有喜共味定。如比丘。行乃至触。亲近多修学。亲近多修学已。心向寂静。心向寂静已。尊上寂静。尊上寂静。倾向寂静。倾向寂静已。喜寂静灭没除已。故有观无喜乐一心。若入此定者。得三支正得缘得观无喜乐一心。是名非禅非禅间无觉有观定。复次比丘。得无觉有观无喜共味定。比丘观无喜乐粗。无喜乐心。犹有作不苦不乐舍寂静时。比丘观无喜乐粗已。无喜乐寂静寂静正寂静。正寂静灭没除。灭没除已。故有观不苦不乐舍一心。若入此定者。得二支正得缘得不苦不乐舍一心。是名非禅非禅间无觉有观定。如比丘若行。若受教。若法相。若方便。若专心。若思惟。若触。得无觉有观无喜乐共味定。如比丘。行乃至触。亲近多修学。行乃至触亲近多修学已。心向寂静。尊上寂静。倾向寂静。倾向寂静已。无喜乐寂静正寂静灭没除。灭没除已。故有观不苦不乐舍一心。若入此定者。得三支正得缘得观不苦不乐舍一心。是名非禅。非禅间无觉有观定。是名无觉有观定。何谓无觉无观定。若定离觉观觉观不共生不共住不共灭。是名无觉无观定。复次无觉无观定。若定于觉观不得不正得不缘得。是名无觉无观定

舍利弗阿毗昙论卷第十五舍利弗阿毗昙论卷第十六

        姚秦罽宾三藏昙摩耶舍共昙摩崛多等译

    非问分道品第十之二

复次无觉无观定。如比丘。灭觉观内净信一心无觉无观定生喜乐。成就二禅行。此比丘。故有内净信喜乐一心。若入此定者。得四支正得缘得内净信喜乐一心。是名第二禅无觉无观定。复次比丘。得有觉有观有喜共味定。如比丘观觉观粗。无觉无观定寂静胜。比丘观觉观粗已。觉观寂静正寂静灭没除。灭没除已。故有内净信喜乐一心。若入此定者。得四支正得缘得内净信喜乐一心。是名第二禅无觉无观定。如比丘若行若受教。若法相。若方便。若专心。若思惟若触。得有觉有观有喜共味定。如比丘。行乃至触。亲近多修学。修学已。心向寂静。尊上寂静。倾向寂静。倾向寂静已。觉观寂静正寂静灭没除。灭没除已。故有内净信喜乐一心。若入此定者。得四支正得缘得内净信喜乐一心。是名第二禅无觉无观定。复次比丘。得无觉无观有喜共味定。比丘观喜粗喜心。犹有悲无喜乐寂静胜。比丘观喜粗已。喜寂静正寂静灭没除。灭没除已。故有内净信无喜乐一心。此入初禅舍心。不及入第三禅定舍心。若入此定者。得三支正得缘得内净信无喜乐一心。是名禅间无觉无观定。第二第三禅间从二禅趣三禅。复次比丘。得无觉无观无喜乐共味定。比丘观无喜乐粗无喜乐心。犹有作不苦不乐舍寂静胜。比丘观无喜乐粗已。无喜乐寂静正寂静灭没除。灭没除已。故有内净信不苦不乐舍一心。若入此定者。得三支正得缘得内净信不苦不乐舍一心。是名非禅非禅间无觉无观定。如比丘。若行。若受教。若法相。若方便。若专心。若思惟。若触。得无觉无观无喜乐共味定。如比丘。行乃至触。亲近多修学。多修学已。心向寂静。心向寂静。尊上寂静。尊上寂静。倾向寂静。倾向寂静已。喜乐寂静正寂静灭没除。灭没除已。故有内净信不苦不乐舍一心。是名非禅非禅间无觉无观定。复次比丘。离喜舍行念正智身受乐。如诸圣人。解舍念乐行。成就三禅行。比丘故有共味定舍念正智无喜乐一心。若入此定者。得五支正得缘得共味舍念正智无喜乐一心。是名第三禅无觉无观定。如比丘。若行。若受教。若法相。若方便。若专心。若思惟。若触。得无觉无观有喜乐共味定。如比丘。行乃至触。亲近多修学。多修学已。心向寂静。尊上寂静。倾向寂静。倾向寂静已。喜寂静正寂静灭没除。灭没除已。故有共味舍念正智无喜乐一心。若入此定者。得五支正得缘得共味舍念正智无喜乐一心。是名第三禅无觉无观定。复次比丘。得无觉无观无喜乐共味定。如比丘。观无喜乐粗无喜乐心。犹有作不苦不乐舍寂静胜。比丘观无喜乐粗已。无喜乐寂静正寂静灭没除。灭没除已。舍念正智一心。此人出息入息灭。不及入第四禅者。若入此定者。得四支正得缘得不苦不乐舍念正智一心。是名禅间无觉无观定。第三第四禅间。从三禅趣第四禅。如比丘。若行。若受教。若法相。若方便。若专心。若思惟。若触。得无觉无观无喜乐共味定。比丘行乃至触。亲近多修学。多修学已。心向寂静。尊上寂静。倾向寂静。倾向寂静已。无喜乐寂静正寂静灭没除。灭没除已。有不苦不乐舍念正智一心。此人出息入息灭。不及入第四禅者。若入此定者。得四支正得缘得不苦不乐舍念正智一心。是名禅间无觉无观定。第三第四禅间。从第三禅趣第四禅。复次比丘。断苦断乐。先灭忧喜。不苦不乐舍念净。成就四禅行。如比丘。有喜不苦不乐舍念净一心。若入此定者。得四支正得缘得不苦不乐舍念净一心。是名第四禅无觉无观定。复次比丘。得无觉无观无喜乐共味定。比丘观无喜乐粗无喜乐心。犹有作不苦不乐舍寂静胜。比丘观无喜乐粗已。无喜乐寂静正寂静灭没除。灭没除已。故有不苦不乐舍念净一心。若入此定者。得四支正得缘得不苦不乐舍念净一心。是名第四禅无觉无观定。如比丘。若行。若受教。若法相。若方便。若专心。若思惟。若触。得无觉无观无喜乐共味定。如比丘。行乃至触。亲近多修学。多修学已。心向寂静。尊上寂静。倾向寂静。倾向寂静已。无喜乐寂静正寂静灭没除。灭没除已。有不苦不乐舍念净一心。若入此定者。得四支正得缘得不苦不乐舍念净一心。是名第四禅无觉无观定。复次比丘。离一切色想。灭嗔恚想。不思惟若干想。成就无边空处行。如比丘。有空处想不苦不乐舍一心。若入此定者。得三支正得缘得空处想不苦不乐舍一心。是名空处无觉无观定。复次比丘。离一切空处想成就无边识处行。如比丘。有识处想不苦不乐舍一心。若入此定者。得三支正得缘得识处想不苦不乐舍一心。是名识处无觉无观定。复次比丘。离一切识处想。成就无所有处行。如比丘。有无所有处想不苦不乐舍一心。若入此定者。得三支正得缘得无所有处想不苦不乐舍一心。是名不用处无觉无观定。复次比丘。离一切不用处。成就非想非非想处行。如比丘。有非想非非想处想不苦不乐舍一心。若入此定者。得三支正得缘得非想非非想处想不苦不乐舍一心。是名非想非非想处无觉无观定。何谓空定。如比丘。一切法。若一处法。思惟空知空解空受空。以何义空。以我空。我所亦空。如是不放逸观。得定心住正住。是名空定。复次空定六空。内空。外空。内外空。空空。大空。第一义空。何谓内空。如比丘。一切内法。若一处内法。思惟空知空解空受空。以何义空。以我空。我所亦空。常空不变易空。如是不放逸观。得定心住正住。是名内空。何谓外空。如比丘。一切外法。若一处外法。思惟空知空解空受空。以何义空。以我空。我所亦空。如是不放逸观。得定心住正住。是名外空。云何内外空。如比丘。一切内外法。若一处内外法。思惟空知空解空受空。以何义空。以我空。我所亦空。如是不放逸观。得定心住正住。是名内外空。何谓空空。如比丘。成就空定行。比丘思惟空知空解空受空。以何义空。以我空。我所亦空。常空不变易空。如是不放逸观。得空定心住正住。是名空空。何谓大空。如比丘。一切法。思惟空知空解空受空。以何义空。以我空。我所亦空。如是不放逸观。得定心住正住。是名大空。何谓第一义空。第一谓涅槃。如比丘。思惟涅槃空知空解空受空。以何义空。以我空。我所亦空。常空不变易空。如是不放逸观。得定心住正住。是名第一义空。如是六空。是名空定。何谓无相定。除空定。若余定。以圣涅槃为境界。是名无相定。复次无相定。行有相。涅槃无相。行有三相。生住灭。涅槃无三相。不生不住不灭。如是行有相。涅槃无相。涅槃是寂灭。是舍宅。是救护。是灯明。是依止。是不终没。是归趣。是无燋热。是无忧恼。是无忧悲苦恼。及余诸行。思惟涅槃。得定心住正住。是名无相定。何谓无愿定。除空定若余定。以圣有为为境界。是名无愿定。复次无愿定。愿有二种。爱着见着。比丘思惟行苦患痈箭着味。依缘坏法不定不足可坏众苦不思惟空无我。得定心。住正住。比丘爱断见断。此定能断爱见。是名无愿定。何谓四念处。如比丘。内身观。身行勤念正智调希望世忧。外身观。身行勤念正智调希望世忧。内外身观。身行勤念正智调希望世忧。受心法亦如是。是名四念处。何谓四正断。如比丘。恶不善法未生欲令不生。起欲自勉胜进。摄心正断。恶法已生欲令断。起欲自勉胜进。摄心正断善法未生欲令生。起欲自勉胜进。摄心正断。善法已生欲令住。具足修不忘广大增长。起欲自勉胜进。摄心正断是名四正断。何谓四神足。如比丘。断行成就修神足。精进定心定念定慧定断行成就修神足。是名四神足。四禅如禅品所说。何谓四无量。慈悲喜舍。何谓慈。如比丘。思惟众生乐知乐解乐受乐。或有众生。曾侵恼比丘。比丘于是众生心障碍。不清净不亲近不解。比丘如是思惟。众生已侵恼我。众生虽侵损我。我法不应报。我若嗔恼众生。则为自损。他已侵恼我。若我还报。自损甚彼比丘如是思惟已。于众生堪忍。除灭嗔恼。心思惟欲令众生乐知乐解乐受乐。或有众生。先未曾侵恼比丘。今侵恼比丘。于众生心障碍不清净不亲近不解。比丘如是思惟。众生先未曾侵恼我。今现侵恼。众生虽现侵恼我。或是我宿业报。非我能遮。我若嗔恼众生。则为自损。他已侵我。若我还报自损甚。彼比丘如是思惟已。于众生堪忍。除灭嗔恼心。思惟欲令众生乐知乐解乐受乐。或有众生。先未曾侵恼比丘。今不侵恼。当欲侵恼。比丘于众生心障碍不清净不亲近不解。比丘如是思惟。众生先未曾侵恼我。今不侵恼。当欲侵恼我。众生虽当欲侵恼。或不作。或因缘不集。我若嗔恼众生。则为自损。他虽欲侵恼我。若我还报自损甚。彼比丘如是思惟已。于众生堪忍。除灭嗔恼心。思惟欲令众生乐知乐解乐受乐。或有众生。先未曾侵恼比丘。今不侵恼。当不侵恼。先未曾侵我爱喜适意者。今现侵恼我爱喜适意者。比丘于众生心障碍不清净不亲近不解。比丘如是思惟。众生先未曾侵恼我。今不侵恼。当不侵恼我所爱喜适意者。曾侵恼众生。虽侵恼我爱喜适意者。我不应侵恼彼。我若嗔恼众生。则为自损。他已侵恼。若我还报自损甚。彼比丘如是思惟已。于众生堪忍。除灭嗔恼心。思惟欲令众生乐知乐解乐受乐。或有众生。先未曾侵恼比丘。今不侵恼。当不侵恼。先未曾侵恼我爱喜适意者。今现侵恼我爱喜适意者。比丘于众生心障碍。不清净不亲近不解。比丘如是思惟。众生先未曾侵我。今不侵。当不侵我爱喜适意者。先未曾侵我爱喜适意者。今现侵众生。虽侵我爱喜适意者。或是宿业报。非我能遮他宿业。我若嗔恼众生。则为自损。他以侵我。我若还报。自损甚。于彼比丘。如是思惟已。于众生堪忍。除灭嗔恼心。思惟欲令众生乐知乐解乐受乐。或有众生。先未曾侵恼比丘。今不侵恼。当不侵恼。若我爱喜适意者。先未曾侵恼。今不侵恼。若我爱喜适意者。当欲侵恼。比丘于众生心障碍不清净不亲近不解。比丘如是思惟。众生先未曾侵恼我。今不侵恼。当不侵恼。若我爱喜适意者。先未曾侵恼。今不侵恼。若我爱喜适意者。当欲侵恼。众生虽欲侵恼我爱喜适意者。或不作。或因缘不集。我若嗔恼众生。则为自损。他已侵恼我。若还报自损甚。彼比丘如是思惟已。于众生堪忍。除灭嗔恼心。思惟欲令众生乐知乐解乐受乐。或有众生。先未曾侵恼比丘。今不侵恼。当不侵恼。若我爱喜适意者。先未曾侵恼。今不曾侵恼。当不曾侵恼。若我不爱喜适意者。已曾利益。比丘于众生心障碍不清净不亲近不解。比丘如是思惟。众生先未曾侵恼我。今不侵恼。当不侵恼。若我爱喜适意者。先未曾侵恼。今不曾侵恼。当不侵恼。若我不爱喜适意者。已曾利益。若众生虽已利益我不爱喜适意者。我不应侵恼彼。我若嗔恼众生。则为自损。他已损我。我若还报自损甚。彼比丘如是思惟已。于众生堪忍。除灭嗔恼心。思惟欲令众生乐知乐解乐受乐。或有众生。先未曾侵恼比丘。今不侵恼。当不侵恼。若我爱喜适意者。先未曾侵恼。今不侵恼。当不侵恼。若我不爱喜适意者。先未曾利益。若我不爱喜适意者。今利益。比丘于众生心障碍不清净不亲近不解。比丘如是思惟。众生先未曾侵恼我。今不侵恼。当不侵恼。若我爱喜适意者。先未曾侵恼。今不侵恼。当不侵恼。若我不爱喜适意者。先未曾利益。若我不爱喜适意者。今利益。众生虽利益我不爱喜适意者。或是宿业报。非我能遮他宿业报。我若嗔恼众生。则为自损。他已损我。我若还报自损甚。彼比丘如是思惟已。于众生堪忍。除灭嗔恼心。思惟欲令众生乐知乐解乐受乐。或有众生。先未曾侵恼比丘。今不侵恼。当不侵恼。若我爱喜适意者。先未曾侵恼。今不侵恼。当不侵恼。若我不爱喜适意者。先未曾利益。今不利益。若我不爱喜适意者。当欲利益。比丘于众生心障碍不清净不亲近不解。比丘如是思惟。众生先未曾侵恼我。今不侵恼。当不侵恼。若我爱喜适意者。先未曾侵恼。今不侵恼。当不侵恼。若我不爱喜适意者。先未曾利益。今不利益。当欲利益。若我不爱喜适意者。当欲利益。众生虽欲利益我不爱喜适意者。或不作。或因缘不集。我若嗔恼众生。则为自损。他已损我。我若还报自损甚。彼比丘如是思惟已。于众生堪忍。除灭嗔恼心。思惟欲令众生乐知乐解乐受乐。或有众生。先未曾侵恼比丘。今不侵恼。当不侵恼。若我爱喜适意者。先未曾侵恼。今不侵恼。当不侵恼。若我不爱喜适意者。先未曾利益。今不利益。当不利益。如是比丘无因缘。便横嗔众生。比丘于众生心障碍不清净不亲近不解。比丘如是思惟。众生先未曾侵恼。今不侵恼。当不侵恼。若我爱喜适意者。先未曾侵恼。今不侵恼。当不侵恼。若我不爱喜适意者。先未曾利益。今不利益。当不利益。我无因缘。便横嗔众生。我于众生心障碍不清净不亲近不解。我若嗔恼众生。则为自损。他已损我。我若还报自损甚。彼比丘如是思惟已。于众生堪忍除嗔恼心。思惟欲令众生乐知乐解乐受乐。如比丘。若于东方众生。灭嗔恼心。思惟欲令众生乐知乐解乐受乐。南西北方于众生。灭嗔恼心。思惟欲令众生乐知乐解乐受乐。如比丘。以慈心遍解一方行。第二第三第四。四维上下。一切以慈心广大尊胜。无二无量。无怨无嗔恚。遍解诸世间行。是名慈。何谓悲。如比丘。不思惟众生乐不知乐不解乐不受乐。比丘见众生苦受苦。若父母。若兄弟姊妹妻子亲属知识大臣地狱畜生饿鬼。若人中贫贱。鬼神中贫贱。怜彼众生起悲心。或有众生。已侵恼比丘。比丘于众生心障碍不清净不亲近不解。比丘如是思惟。众生曾侵恼我。众生虽侵恼我。我不应侵恼彼。我若嗔恼众生。则为自损。他已损我。若我还报自损甚。彼比丘如是思惟已。于众生堪忍。除灭嗔恼心。于众生怜愍起悲心。或有众生。先未曾侵恼比丘。乃至无因缘横嗔。如上所说。如比丘。若于东方众生。灭嗔恼心。于众生怜愍起悲心。南西北方众生。灭嗔恼心。于众生怜愍起悲心。比丘以悲心遍解一方行。第二第三第四。四维上下。一切以悲心广大尊胜。无二无量。无怨无恚。遍解诸世间行。是名悲。何谓喜。如比丘。不思惟众生乐不知乐不解乐不受乐。比丘于众生。不得怜愍。不起悲心。如比丘。若见众生快乐受乐。若父母兄弟姊妹妻子亲属知识大臣。若诸天。若诸天子。若佛。若佛弟子。于彼众生得悦喜。不依欲染想。或有众生。已曾侵恼比丘。比丘于众生心障碍不清净不解。比丘如是思惟。众生已曾侵恼我。众生虽侵恼我。我不应侵恼彼。我若侵恼众生。则为自损他已损我。若我还报自损甚。彼比丘如是思惟已。于众生堪忍。除灭嗔恼心。于众生得悦喜。不依欲染想。或有众生。先未曾侵恼比丘。乃至无因缘横嗔。如上所说。比丘若于东方众生。除灭嗔恼心。于众生得悦喜心。不依欲染想于南西北方众生。灭嗔恼心。于众生得悦喜心。不依欲染想。比丘以喜心遍解一方行。第二第三第四。四维上下。一切以喜心广大尊胜。无二无量。无怨无恚。遍解诸世间行。是名喜。何谓舍。如比丘。不思惟众生乐不知乐不解乐不受乐。不得怜愍。不起悲心。不得悦喜。不依欲染想。如比丘。但缘众生故得舍。如人入丛林中。不分别此是钵多树。尼居陀树。毗梨叉树。优头披罗树。家枝树。加毗耶树。若毗耶罗树。家尼柯罗树。弥陀树。伊陀伽树。但见丛林。不分别诸树。如是比丘。不思惟众生乐不知乐不解乐不受乐。不得怜愍。不起悲心。不得悦喜。不依欲染想。但缘众生故得舍。或有众生。已曾侵恼比丘。比丘于众生心障碍不清净不观不解。比丘如是思惟。众生已曾侵恼我。众生虽侵恼我。我不应侵恼。我若嗔恼众生。则为自损。他已损我。若我还报自损甚。于彼比丘。如是思惟已。于众生堪忍。除灭嗔恼心。但缘众生故得舍。或有众生。先未曾侵恼比丘。乃至无因缘横嗔。如上所说。如比丘。若于东方众生。灭嗔恼心。但缘众生故得舍。于南西北方众生。除灭嗔恼心。但缘众生故得舍。如比丘。以舍心遍解一方行。第二第三第四。四维上下一切但以舍心广大尊胜。无二无量。无怨无恚。遍解诸世间行。是名舍。是名四无量

何谓四无色定。如比丘。离一切色想。灭嗔恚想。不思惟若干想。成就无边空处行。离一切空处。成就识处行。离一切识处。成就不用处行。离一切不用处。成就非想非非想处行。是名四无色定。何谓四向道。向苦道难行。向苦道速行。向乐道难行。向乐道速行。何谓向苦道难行。如比丘。性多贪欲。性多嗔恚。性多愚痴。是比丘行道。防欲染故。数受忧苦。防嗔恚故。数受忧苦。防愚痴故。数受忧苦。是比丘圣五根钝行。何等五信根。精进念定慧根。比丘五根钝行故。证无间定尽诸漏。是名向苦道难行。何谓向苦道速行。如比丘。性多贪欲。性多嗔恚。性多愚痴。是比丘行道。防欲染故。数受忧苦。防嗔恚故。数受忧苦。防愚痴故。数受忧苦。是比丘圣行五根利行。何等五信根。精进念定慧根。比丘五根利行速证无间定尽诸漏。是名向苦道速行。何谓向乐道难行。如比丘。性欲染少。性嗔恚少。性愚痴少。是比丘缘欲染少故。不数受忧苦。缘嗔恚少故。不数受忧苦。缘愚痴少故。不数受忧苦。是比丘圣五根钝行。何等五信根。精进念定慧根。比丘五根钝行证无间定尽诸漏。是名向乐道难行。何谓向乐道速行。如比丘。性少贪欲。性少嗔恚。性少愚痴。是比丘行道。缘欲染少故。不数受忧苦。缘嗔恚少故。不数受忧苦。缘愚痴少故。不数受忧苦。是比丘圣五根最利行。何等五信根。精进念定慧根。比丘五根利行证无间定尽诸漏。是名向乐道速行。是名四向道。何谓四修定。如世尊说。四修定。何等四有修定亲近多修学得现世乐行。有修定亲近多修学得知见。有修定亲近多修学得慧分别。有修定亲近多修学得漏尽。何谓修定亲近多修学得现世乐行。如比丘。离欲恶不善法。离生喜乐。成就初禅行。灭觉观内净信一心无觉无观定生喜乐。成就二禅行。离喜舍行念正智身受乐。如诸圣人解舍念乐行。成就三禅行。断苦乐先灭忧喜不苦不乐舍念净。成就四禅行。如是修定亲近多修学得现世乐行。何谓修定亲近多修学得知见。如比丘善取明想善持昼想。比丘如昼修明想。夜亦如是。如夜修明想昼亦如是。以心开悟。不覆盖心。心修有明此定亲近多修学得知见。何谓修定亲近多修学得慧分别。如比丘。知受生。知受住。知受灭。知想生。知想住。知想灭。知觉生。知觉住。知觉灭。此定亲近多修学得慧分别。何谓修定亲近多修学得漏尽。如比丘。知五受阴生灭。知色知色集。知色灭。知受想行识。知识集。知识灭。此定亲近多修学得漏尽如波罗延经所问。断一切欲想。灭忧恼舍睡眠遮掉悔舍念净先灭觉知觉解脱断无明。是名四修定。何谓四断。戒断微护断。修断。知缘断。何谓戒断。如比丘。眼见色。不取相。不分别。令发眼根。常自摄行。莫依希望世忧恶不善法慎护眼根。得眼根戒耳鼻舌身意。意知法。不取相。分别令起意根。常自摄行。莫依希望世忧恶不善法。慎护意根。得意根戒。是名戒断。何谓微护断。如比丘。取善相生微护若骨节。若肿胞。若膖胀若青瘀。若赤黑。若烂坏离散。如是观善相生微护。是名微护断。何谓修断。如比丘。修念正觉依离欲依无染依灭爱择法正觉进正觉喜正觉除正觉定正觉修舍正觉依离欲依无染依灭爱。是名修断。何谓智缘断。如比丘。或在树下露处。如是思惟。身不善恶行报。今世及后世。如比丘。堪忍断身恶行。修身善行。口不善行报。今世及后世。如比丘。堪忍断口恶行。修口善行。意不善行恶报。今世及后世。如比丘。堪忍断意不善行。修意善行。是名智缘断

  戒护缘修断　　自性如来说
  比丘行是法　　一切苦际尽
  是名四断智

何谓五根。信根进根念根定根慧根。是名五根。五力亦如是。何谓五解脱处。谓比丘不放逸勤念正智寂静行。心未解脱得解脱。诸漏未尽得漏尽。未得无上安隐得安隐。何谓五。若世尊为比丘说法。若师说。若慧梵净行者说。随顺如来说。若师若慧梵净行者说。听已受法受义。受法受义已生悦。悦已生喜。喜已得身除。身除已受乐。受乐已心定。心定已如实知见。如比丘不放逸。勤念正智寂静行。心未解脱得解脱。诸漏未尽得漏尽。未得无上安隐得安隐。是名初解脱处。复次比丘。非世尊非师非慧梵净行者说时。如先所闻法。广读诵通利。如比丘先所闻法广读诵通利。受法受义。如比丘受法受义已生悦。悦已生喜。喜已得身除。身除已受乐。受乐已心定。心定已如实知见。比丘如是不放逸勤念正智寂静行。心未解脱得解脱。诸漏未尽得漏尽。未得无上安隐得安隐。是名第二解脱处。复次比丘。非世尊非师非慧梵净行者说时。非先所闻法。广读诵通利时。如比丘先所闻法通利。广为他说。如比丘随彼所闻法通利。广为他说。受法受义。比丘受法受义已生悦。悦已生喜。喜已得身除。身除已受乐。受乐已心定。心定已如实知见。比丘如是不放逸勤念正智寂静行。心未解脱得解脱。诸漏未尽得漏尽。未得无上安隐得安隐。是名第三解脱处。复次如比丘。非世尊非师非慧梵净行者说时。非先所闻法。广读诵通利时。非先所闻法通利。广为他。分别时。如比丘。先所闻法通利自心分别。如比丘随所闻法通利。自心分别。受法受义。比丘受法受义已生悦。悦已生喜。喜已得身除。身除已受乐。受乐已心定。心定已如实知见。比丘如是不放逸勤念正智寂静行。心未解脱得解脱。诸漏未尽得漏尽。未得无上安隐得安隐。是名第四解脱处。复次比丘。非世尊非师非慧梵净行者说时。非先所闻法。广读诵通利时。非先所闻法通利。广为他分别时。非先所闻法通利。自心分别时。如比丘善取定相善思惟善解射。比丘善取定想善思惟善解射已。受法受义。受法受义已生悦。悦已生喜。喜已得身除。身除已受乐。受乐已心定。心定已如实知见。比丘如是不放逸勤念正智寂静行。心未解脱得解脱。诸漏未尽得漏尽。未得无上安隐得安隐。是名第五解脱处。是名五解脱处。五出界如界品说。云何五观定。如正信经。舍利弗白佛言。世尊。复有无胜法。如世尊说法入定观。世尊。有此入定观。或有沙门婆罗门。勤精进勇猛。正思惟多学行心。如法思惟入定。入定已观身。从顶至足。从足至顶。乃至薄皮。皆是不净。是名初入定观。复次或有沙门婆罗门。勤精进勇猛。正思惟多学行心。如法思惟入定。入定已不观皮血肉。但观人骨。此身中有骨齿爪。是名第二入定观。复次或有沙门婆罗门。勤精进勇猛。正思惟多学行心。如法思惟入定。入定已不观皮血肉骨。但观人识。识住此世。住他世。识未断。不离二世。是名第三入定观。复次或有沙门婆罗门。勤进勇猛。正思惟多学行心。如法思惟入定。入定已不观皮血肉骨。复观人识。识不住此世。不住他世。识断离此世。未断离他世。是名第四入定观。复次或有沙门婆罗门。勤进勇猛。正思惟多学行心。如法思惟入定。入定已不观内血肉皮骨。复观人识。识不住此世。不住他世。识善断离二世。是名第五入定观。如是无胜入定观。世尊善知无胜。世尊善通达。无有能过者。如我意所知。或有沙门婆罗门。能称出世尊知者。无有是处。是名第五入定观。何谓五起解脱法。如世尊说。五法亲近多修学已得解脱。何谓五。如比丘。观身不净想。观食不净想。观诸行无常想。观世不乐想。观身死想。如是五法。亲近多修学。能得解脱。是名五起解脱法。云何六念。念佛乃至念天。何谓念佛。以佛为境界。念善顺不逆。是名念佛。何谓念法。以法为境界。念善顺不逆。是名念法。何谓念僧。以僧为境界。念善顺不逆。是名念僧。何谓念戒。戒谓身口戒。以戒为境界。念善顺不逆。是名念戒。何谓念施。施有二种。财施法施。以施为境界。念善顺不逆。是名念施。何谓念天。若过抟食化生天。彼天不观宿业。不分别宿业。以天为境界。念善顺不逆。是名念天。是名六念。六空如空三昧说。六出界如界品说。何谓六明分法。如世尊说。六法亲近多修学生明得明分。能令明广大。何谓六。无常想。无常苦想。苦无我想。食不净想。一切世间不乐想。死想。何谓无常想明分法。如比丘。或树下露处。作是思惟。色无常。受想行识无常。若如是五受阴。观无常行。如世尊说。有为法三相。生住灭。如是比丘。思惟生住灭。调心修令柔软。柔软已思惟色无常受想行识无常。行人若想忆想。是名无常想。亲近多修学。亲近多修学已。生明得明得明分。能令明广大。是名无常想明分法。何谓无常苦想明分。如比丘。或在树下露处。如是思惟色无常。若无常则是苦。受想行识无常。若无常则是苦。如是五受阴观苦行。如世尊说。若色生住。即是生苦。有病有老死。若受想行识生住。即是生苦。有病有老死。复次如世尊说三苦。行苦苦苦变易苦。何谓行苦。五受阴行自性苦形或苦自相苦。是名行苦。何谓苦苦。五受阴行自性苦。生等生起等起出等出。具足成就。生种种病。因热生病。因痰癊。因风因过力。因他恼。因时变。因诸大相违。因食饮不消。因宿业报。因诸大不调生病。生眼病。耳鼻舌身病生。头痛面痛。口齿咽痛。胸痛病。生蛇身病。呼嗐痛。謦欬病。呕吐病。生绞病。身热腹痛病。生癣胞疥[癈-(弓*殳)+虫]微风侵淫疮痈蛆白癞干枯癫狂病生痔病[病-丙+帶]下赤肿虫食病等。蚤螕虱蚊虻蚁子。此身乃至一毛处。无不有虫。如人痈肿上生毒肿五受阴行性苦亦如是。生等生起等起出等出。具足成就。生种种病。因热生病。乃至一毛处。无不有虫。是名苦苦。何谓变易苦。如五受阴行。转变衰熟。坏败尽灭。终没离灭。是名变易苦。如比丘于彼行苦苦苦变易苦。调心修令柔软。柔软已思惟色苦。思惟受想行识苦。如行人若想忆想。是名无常苦想。亲近多修学。生明得明得明分。能令明广大。是名无常苦想明分法。何谓苦无我想明分法。如比丘。在树下露处。如是思惟色无常。若无常即是苦。若苦即无我。受想行识无常。若无常即是苦。若苦即是无我。若于此想。五受阴观无我行。如世尊说色无我。色若是我。色应不受苦患。色应得自在。如是有。如是非有。以色非我故。色受苦患。色不得自在。如是有。如是非有。受想行识无我。受想行识若是我。识不应受苦患。识应得自在。如是有。如是非有。如比丘。如是调心修令柔软。柔软已思惟。色无我。受想行识无我。如行人若想忆想。是名苦无我想。亲近多修学。生明得明得明分。能令明广大。是名苦无我想明分法。何谓食不净想明分法。何等食。食有四种。谓抟食触食思食识食。如世尊说。众生有四种食。食此食。能令众生住。能令阴和合。能有利益。何等四。一谓抟食。二触食三思食。四识食。何等谓抟食。抟食有二种。粗细。何谓粗。除天净食天香食。除衣服澡浴调身食。苦余抟食。是名粗抟食。何谓细抟。食。天净食。天香食。衣服澡浴。调身食。是名细抟食。复次粗抟食。除天香食。除衣服澡浴食。若余抟食。是名粗抟食。复次细抟食。天香食。衣服澡浴调身食。是名细抟食。何谓触食。六触。眼触。耳鼻舌身意触。是名触食。何谓思食。六思身。色思。声香味触法思。是名六思身。是名思食。何谓识食。六识身。眼识。耳鼻舌身意识。是名六识身。是名识食。抟食。或是食。或非食。触思识食。或是食。或非食。何谓抟食是食。若缘抟食。得诸根增长。不损坏不减寿。是名抟食食。云何抟食非食。若缘抟食。诸根不增长。损坏减寿。是名抟食非食。何谓触思识食是食。若缘识食。诸根增长。不损坏不减寿。是名识食是食。何谓识食非食。若缘识食。诸根不增长。损坏减寿。是名识食非食。比丘受抟食如食子肉。观不净想。触思识食。有解射想。思惟灭依离欲染。如行人若想忆想。是名食不净想。亲近多修学已。生明得明得明分。能令明广大。是名食不净想明分法。何谓一切世间不乐想明分法。如比丘。于一切世间。厌离不乐。地狱世畜生世饿鬼世人世天世众生世行世。厌离不乐。如比丘。于此世间。有取心者。必执所见。如比丘。断离不受。如是诸见如行人。若想忆想。是名一切世间不乐想。亲近多修学已。生明得明得明分。能令明广大。是名一切世间不乐想明分法。何谓死想明分法。如比丘。或在树下露处。如是思惟。我是死法。有死过患。若余众生。亦有死法。有死过患。若地狱畜生饿鬼人天及一切众生。往来生死。得名众生者。皆有死法。有死过患。比丘思惟阴坏舍身忆念死。比丘思惟死知死解死觉死。如行人若想忆想。是名死想。亲近多修学已。生明得明得明分。能令明广大。是谓死想明分法。是名六明分法。何谓六悦因法。如比丘悦已生喜。喜已得身除。身除已受乐。受乐已心定。心定已如实知见。是名六悦因法。何谓无喜六正觉。念正觉乃至舍正觉。是名无喜六正觉。何谓七觉。念正觉乃至舍正觉。是名七正觉。何谓七想。如世尊说。七想。亲近多修学。得大功德。得至甘露。何谓七不净想食。厌想一切世间不乐想死想无常想无常苦想苦无我想。谓不净想。亲近多修学。多修学已。得大果报。得大功德。得至甘露。以何缘故作是说。如比丘。心知分别不净想。令欲心退没不展。当渐渐除尽。背舍厌离已正住。如筋如鸟羽。如头罗草投于火中燋卷不展。后便消尽。比丘如是心知分别不净想。令欲心退没不展。后便消尽。背舍厌离已正住。如比丘。或有心知分别不净想。心于欲想犹生津漏。如本无异。心不背舍。不厌离。不正住。比丘如实自知。我便为未修不净想。我未增益异名色。我未得修果报。如是比丘有正智。如比丘心知分别不净想于欲想心不生津漏。于本有异。背舍厌离正住。比丘如实正知。我已修不净想。我有增益异名色。我得修果报。此比丘有正智。行不净想。亲近多修学已。得大果报。得大功德。得至甘露。以是因缘故。说如食不净想。亲近多修学已。得大果报。得大功德。得至甘露

舍利弗阿毗昙论卷第十六舍利弗阿毗昙论卷第十七

        姚秦罽宾三藏昙摩耶舍共昙摩崛多等译

    非问分道品第十之三

以何因故作是说。如比丘。心知分别食不净想。于揣食心退没不进。渐当除尽背舍厌离已正住。如筋如鸟羽。如头罗草投于火中燋卷不展。后便消灭。比丘如是。心知分别揣食不净想。令揣食净想退没不进。渐当除尽背舍厌离已正住。如比丘。或有心知分别揣食不净想。心于揣食犹生津漏。如本无异。心不背舍不厌离不正住。比丘如实自知。我便为未修揣食不净想。我未增益异名色我未得修果报。如是比丘。有正智。如比丘。心知分别揣食不净想。于揣食心不生津漏。于本有异。背舍厌离正住。比丘如实正知。我已修揣食不净想。我有增益于异名色。我得修果报。此比丘有正智揣食不净想亲近多修学已。得大果报。得大功德。得至甘露。以是因缘故。说如一切世间不乐想。亲近多修学已。得大果报。得大功德。得至甘露。以何因缘故作是说。如比丘。心知分别一切世间不乐想。世间种种想。心退没不进。渐当除尽背舍厌离已正住。如筋如鸟羽。如头罗草投于火中燋卷不展。后便消灭。比丘如是心知分别一切世间不乐想。令世间种种想退没不进。渐当除尽背舍厌离已正住。如比丘。或有心知分别一切世间不乐想世间种种想。心犹生津漏。如本无异。不背舍不厌离不正住。比丘如实自知。我便为未修一切世间不乐想。我未增益异名色。我未得修果报。如是比丘有正智。如比丘。心知分别一切世间不乐想。于世间种种想。心不生津漏。于本有异。背舍厌离正住。比丘如实正知。我已修一切世间不乐想。我有增益异名色。我得修果报。此比丘有正智。一切世间不乐想亲近多修学。多修学已。得大果报。得大功德。得至甘露。以是因缘故。说如死想。亲近多修学已。得大果报。得大功德。得至甘露。以何因缘故作是说。如比丘。心知分别死想。倚恃命根。而自贡高。以命根决定堪忍常住。心贪着命根。如是尽断无余。如比丘。或有心知分别死想。倚恃命根。而自贡高。以命根决定堪忍常住。心贪着命根。如是未断。比丘如实自知。我便为未修死想。我未增益异名色。我未修果报。如是比丘有正智。如比丘。心知分别死想。倚恃命根。而自贡高。以命根决定堪忍常住。心贪着命根。如是尽断无余。如比丘。如实自知。我已修死想增益异名色。我得果报。如是比丘。有正智死想。亲近多修学已。得大果报。得大功德。得至甘露。以是因缘故。说如无常想。亲近多修学已。得大果报。得大功德。得至甘露。以何因缘故作是说。如比丘。心知分别无常想。于利养名誉恭敬心。退没不进。渐当除尽背舍厌离已正住。如筋如鸟羽。如头罗草投于火中燋卷不展。后便消尽。比丘如是心知分别无常想。于利养名誉恭敬。心退没不进。渐当除尽背舍厌离已正住。如比丘。或有心知分别无常想。于利养名誉恭敬。心犹生津漏。如本无异。不背舍不厌离不正住。比丘如实自知。我便为未修无常想。我未增益异名色。我未得修果报。如是比丘。如实自知。如比丘。心知分别无常想。于利养名誉恭敬。心不生津漏。于本有异。背舍厌离正住。比丘如实正知。我已修无常想。我有增益异名色。我得修果报。比丘有正智无常想。亲近多修学。多修学已。得大果报。得大功德。得至甘露。以是因缘故。说如无常苦想。亲近多修学已。得大果报。得大功德。得至甘露。以何因缘故作是说。如比丘心知分别无常苦想。于懈怠窳惰不信放逸不勤不观等。生恐怖大畏切逼想。如临死举刀观无常苦想。比丘或有心知分别无常苦想。于窳惰懈怠不信放逸不勤不观等。不生恐怖大畏切逼想。非如临死举刀如比丘如实自知。我便为未修无常苦想。我未增益异名色。我未得修果报。如是比丘。如实自知。如比丘。心知分别则无常苦想。于窳惰懈怠不信放逸不勤不观等。生恐怖大畏切逼想。如临死举。刀观无常苦想。如比丘。如实正知。我以修无常苦想。我增益异名色。我得果报。此比丘有正智无常苦想。亲近多修学已。得大果报。得大功德。得至甘露。以是因缘故。说如苦无我想。亲近多修学已。得大果报。得大功德。得至甘露。以何缘故作是说。如比丘。心知分别苦无我想。于诸有识身及诸外物。计我我所。生憍慢等。俱离寂静正解脱。如比丘。或有心分别苦无我想。于诸有识身及诸外物。计我我所。生憍慢等。心犹不离不寂静不解脱。如比丘。如实自知。我便为未修苦无我想。未增益异名色。我未得修果报。如是比丘。如实自知。如比丘。心知分别苦无我想。于诸有识身及诸外物。计我我所。生憍慢等。心俱离寂静正解脱。如是比丘。如实知我已。修苦无我想。我增益异名色。得修果报。此比丘有正智苦无我想。亲近多修学已。得大果报。得大功德。得至甘露。以是因缘故说。是名七想。何谓七定因缘法。正见正觉正语正业正命正进正念是名七定因缘法

何谓八圣道。正见乃至正定。是名八圣道何谓八解脱。色观色解脱。是名初解脱。内无色想观外色。是名第二解脱。净解脱。是名第三解脱。离一切色想。灭嗔恚想不思惟若干想。成就无边空处。是名第四解脱。离一切空处。成就无边识处行。是名第五解脱离一切识处。成就无所有处。是名第六解脱。离一切无所有处。成就非想非非想处。是名第七解脱。离一切非想非非想处。成就灭受想行。是名第八解脱。何谓色观色初解脱。如比丘。不灭内色想。取外色想。比丘以外色调心。修令柔软。修令柔软已。得色解脱。如比丘。心知分别外色想。心向彼。尊上彼。倾向彼。以彼解脱。何谓色。如比丘。未分别内色。未灭不没不除。是名色。何谓观。若外色以眼识曾见。如实见微见缘见。以意识分别。如实分别微分别缘分别。是名观。何谓初。八解脱次顺不逆。以次入定行。是初是始是前。是名初。何谓得解脱。心向彼。尊上彼。倾向彼。以彼为解脱。是名解脱。何谓内无色想观外色第二解脱。如比丘。灭内色想已。取外色相。以外色调心。修令柔软。修令柔软已得解脱。知比丘。心知分别外色相。心向彼。尊上彼。倾向彼。以彼解脱。何谓内无色想。如比丘。内色想分别灭没除已。是名内无色想。何谓观。若外色以眼识曾见。如实见微见缘见。以意识分别。如实分别微分别缘分别。是名观。何谓第二八解脱。以次顺不逆。以次入定行。第二与初。无有中间。是名第二。何谓解脱。心向彼。尊上彼。倾向彼。以彼得解脱。是名解脱。何谓第三净解脱。如比丘。取一净色相。若火相。日月星宿摩尼珠七宝宫殿彩色衣被华果金银铜环琉璃真珠珂贝珊瑚玉石。及余宝性。比丘取是诸净色相已。得净解脱。比丘心知分别净色相。心向彼。尊上彼。倾向彼。以彼为解脱。何谓净。诸色好展转相照适意观无厌。是名净。何谓解。心向彼。是名解脱。何谓第三八解脱。以次顺不逆。以次入定行。第三与二。无有中间。是名第三。何谓解脱。心向彼。尊上彼。倾向彼。以彼解脱。是名解脱。何谓离一切色想。灭嗔恚想不思惟若干想。成就无边空处行。第四解脱。何谓色想。若眼识相应想。是名色想。何谓嗔恚想。若忿怒相应想。是名嗔恚想。何谓若干想。若外秽浊非善分想。是名若干想。复次色想若不离色界想及眼识相应想。是名色想。复次嗔恚想。若五识身相应想。及忿怒相应想。是名嗔恚想。复次若干想。若诸众生。诸物诸境界诸清净诸烦恼。是名若干想。如比丘。离一切色想。灭嗔恚想不思惟若干想。如比丘。身中孔。若耳孔鼻孔口门。饮食入处。饮食住处。饮食出处。思惟空知空解空受空。如比丘。知身有饮。犹如蒜皮。思惟渐令薄。知薄解薄受薄。思惟渐令破散。知破散解破散受破散。如是比丘。知内色想已。若外物中孔。若地中孔穴井盆坑谷坎窟。思惟空知空解空受空。如比丘。分别内外色想已。观空处寂静。思惟无边空知无边空解无边空受无边空。如行人若想忆想。是名空处想。此想与定共生共住共灭。是名入空处定。复次比丘。大地及须弥山作火聚想。思惟烟知烟解烟受烟。思惟然知然解然受然。思惟烧知烧解烧受烧已。比丘思惟无边空处寂静胜。思惟无边空处。知解受无边空处寂静胜。如行人若想忆想。是名空处想。此想与定共生共住共灭。是名入空处定。复次比丘。如是思惟。若现世欲想。未来欲想现世色想。未来色想。此想粗空处想寂静胜微细善净。比丘思惟无边空处寂静胜处。知解受无边空处寂静胜。如行人若想忆想。是名空处想此想与定共生共住共灭。是名入空处定。复次比丘。如是思惟现世欲想。未来欲想。现在色想。未来色想。此想粗。但无边空处。永灭无余寂静胜。比丘思惟无边空处寂静知解。受无边空处。如行人若想忆想。是名空处想。此想与定共生共住共灭。是名入空处定。何谓第四八解脱。以次顺不逆。以次入定行。第四与三。无有中间。是名第四。何谓解脱。心向彼。尊上彼。倾向彼。以彼解脱。是名解脱。何谓离一切空处。成就无边识处行。是第五解脱。如比丘。如是思惟。我已成就无边空处行。颇有法胜无边空处不。比丘便作是念。唯有空处行。如人以大器覆小器。如是思惟。此器胜彼器。此器以何因故胜。我以此器覆彼器故。如比丘。如是思惟。我已遍解无边空处行。颇有法胜无边空处不。比丘便作是念。唯有识胜无边空处行。识以何因故胜。我以识遍解无边空处故。如比丘思惟无边识处寂静知解受无边识处寂静。如行人若想忆想。是名识处想。此想与定共生共住共灭。是名入识处定。复次比丘如是思惟。若现在欲想。未来欲想。现在色想。未来色想。空处想等粗识处想寂静胜。比丘思惟无边识处寂静胜知解受无边识处寂静胜。如行人若想忆想。是名识处想。此想与定共生共住共灭是名入识处定。复次比丘。如是思惟。若现在欲想。未来欲想。现在色想。未来色想。空处想等。但识处永灭无余。唯识处寂静胜。如比丘思惟无边识处寂静胜知解受无边识处寂静胜。如行人若想忆想。是名识处想。此想与定共生共住共灭。是名入识处定。复次比丘。如是思惟。无边空处入粗无边识处入寂静胜微细善净。如比丘。思惟无边识处寂静胜知解受无边识处寂静胜。如行人若想忆想。是名识处想。此想与定共生共住共灭。是名入识处定。复次比丘。如是思惟。若入空处定粗。若入识处定寂静胜微细善净。如比丘思惟无边识处寂静胜知解受无边识处寂静胜。如行人若想忆想。是名识处想。此想与定共生共住共灭。是名入识处定。何谓第五八解脱。以次顺不逆。以次入定行。第五与四无有中间。是名五。何谓解脱。心向彼。尊上彼。倾向彼。以彼解脱。是名解脱。何谓离一切识处成就无所有处行。是第六解脱。如比丘。如是思惟。我已遍解无边识处行。颇有法胜无边识处不。比丘便作是念。唯有识无所有处胜。如比丘。思惟无所有处寂静胜知解受无所有处寂静胜。如行人若想忆想。是名无所有处想。此想与定共生共住共灭。是名入无所有处定。复次比丘。如是思惟。我非我所有我所非我有。如比丘思惟无所有处寂静胜知解受无所有处寂静胜。如行人若想忆想。是名无所有处想。此想与定共生共住共灭。是名入无所有处定。复次比丘。观一切世间空。世间空已想无依止处。如比丘。思惟无所有处寂静胜知解受无所有处寂静胜。如行人若想忆想。是名无所有处想。此想与定共生共住共灭。是名入无所有处定。复次比丘。以大地须弥山。作火聚想。思惟烟知解受烟。思惟然知解受然。思惟烧知解受烧烧已。比丘思惟无所有处寂静胜。知解受无所有处想寂静胜。如行人若想忆想。是名无所有处想。此想与定共生共住共灭。是名入无所有处定。复次比丘。如是思惟。若现在欲想。未来欲想。现在色想。未来色想。空处想。识处想。此想粗。无所有处想寂静胜微细善净。如比丘。思惟无所有处寂静胜。知解受无所有处寂静胜。如行人若想忆想。是名无所有处想。此想与定共生共住共灭。是名入无所有处定。复次比丘。如是思惟。若现在欲想。未来欲想。现在色想。未来色想。空处想识处想无余寂静胜。如比丘。思惟无所有处寂静胜。知解受无所有处寂静胜。如行人若想忆想。此想与定共生共住共灭。是名入无所有处定。复次比丘。如是思惟。无边空处入粗。识处入粗。无所有处入寂静胜微细善净。如比丘。思惟无所有处寂静胜。知解受无所有处寂静胜。如行人若想忆想。是名无所有处想。此想与定共生共住共灭。是名入无所有处定。复次比丘。如是思惟。若入空处定识处定粗。若入无所有处定寂静胜微细善净。如比丘。思惟无所有处寂静胜。知解受无所有处寂静胜。如行人若想忆想。是名无所有处想。此想与定共生共住共灭。是名入无所有处定。何谓第六八解脱。以次顺不逆。以次入定行。第六与五。无有中间。是名六。何谓解脱。心向彼。尊上彼。倾向彼。以彼解脱。是名解脱。何谓离一切无所有处。成就非想非非想处行。是第七解脱。如比丘。如是思惟。想是我过患。想是痈疮想是我箭。非想非非想处寂静胜。比丘思惟非想非非想处寂静胜知。解受非想非非想处寂静胜。如行人若想忆想。是名非想非非想处想。此想与定共生共住共灭。是名入非想非非想处定。复次比丘。如是思惟。若现在欲想。未来欲想。现在色想。未来色想。空处想。识处想。无所有处想等粗。非想非非想处想寂静胜微细善净。比丘思惟非想非非想处寂静胜。知解受非想非非想处寂静胜。如行人若想忆想。是名非想非非想处想。此想与定共生共住共灭。是名入非想非非想处定。复次比丘。如是思惟。若现在欲想。未来欲想。现在色想。未来色想。空处想。识处想。无所有处想。但非想非非想处永灭无余寂静胜。比丘思惟非想非非想处寂静胜。知解受非想非非想处寂静胜。如行人若想忆想。是名非想非非想处想。此想与定共生共住共灭。是名入非想非非想处定。复次比丘。如是思惟。若无边空处入无边识处入无所有处入粗。非想非非想处入寂静胜微细善净。比丘思惟非想非非想寂静胜。知解受非想非非想处寂静胜。如行人若想忆想。是名非想非非想处想。此想与定共生共住共灭。是名入非想非非想处定。复次比丘。如是思惟。若入无边空处定。若入识处定。若入无所有处定粗。若非想非非想处寂静胜微细善净。比丘思惟非想非非想处寂静胜。知解受非想非非想寂静胜。如行人若想忆想。是名非想非非想处想。此想与定共生共住共灭。是名入非想非非想处定。何谓第七八解脱。以次顺不逆。以次入定行。第七与六。无有中间。是名七。何谓解脱。心向彼。尊上彼。倾向彼。以彼解脱。是名解脱。何谓离一切非想非非想处成就灭受想定。是第八解脱。如比丘。依戒住戒。增修二法定慧。依定慧灭受想。若灭受想。是名灭尽定。复次比丘。住触证胜想。住触证胜想时。如是思惟。我有思犹恶。无思便善。我有思则有作。有作则为有乐想。有乐想则有余地粗想生。比丘如是思惟。若我无思无作。无作已则乐想不生。乐想不生。余地粗相亦不生。如比丘。无思惟无作。无作已则乐想灭乐想灭余地粗想亦灭。得触证灭尽定。何谓第八解脱。次顺不逆。以次入定行。第八与七。无有中间。是名八。何谓解脱。心向彼。尊上彼。倾向彼。以彼解脱。是名解脱。是名八解脱。云何八胜入内色想。观外色少。好色非好色。胜知胜见。有如是想。内色想观外色无量。好色非好色。胜知胜见。有如是想。内无色想观外色少。好色非好色。胜知胜见。有如是想。内无色想观外色无量。好色非好色。胜知胜见。有如是想。内无色想观外色青。青色青光。如优摩华青青色青光。如波罗奈衣善染青青色青光。观如是妙色青青色青光。胜知胜见。有如是想。内无色想观外色黄。黄色黄光。如迦尼伽罗华黄黄色黄光。如波罗捺善染衣黄黄色黄光。观如是妙色黄黄色黄光。胜知胜见。有如是想。内无色想。观外色赤。赤色赤光。如槃头华赤赤色赤光。如波罗捺善染衣赤赤色赤光。观如是妙色赤赤色赤光。胜知胜见。有如是想。内无色想。观外色白。白色白光。如卤土星白。白色白光。如波罗捺善浣衣白白色白光。观如是妙色白白色白光。胜知胜见。有如是想。何谓内色想观外色少好色非好色胜知胜见有如是想。谓比丘未灭内色想。取外少色。好色非好色。适意不适意。可恶不可恶。比丘以外少色调心。修令柔软。修令柔软已。得色胜解脱。比丘知见分别外少色。心向彼。尊上彼。倾向彼。以彼胜解。何谓内色想。比丘未灭内色想。不灭不没不除。是名内色想。何谓观外色。若外少色。眼识曾见。如实见缘见。意识分别。如实分别缘分别。是名观外色何谓少。若可计数量。非无边无量。非阿僧祇。非无边无际。是谓少。何谓好色非好色。净不净。是名好色非好色。何谓胜知胜见。彼胜解。是名胜知胜见。何谓有如是想。若有不分散不相离一向少色想。是名有如是想。何谓内色想观外色无量好色非好色胜知胜见有如是想。谓比丘不灭少色想。取外无量色想。好色非好色。适意非适意。可恶不可恶。比丘以彼外无量色调心。修令柔软。修令柔软已。得色胜解。比丘知见分别外无量色。心向彼。尊上彼。倾向彼。于彼胜解。何谓内色想。比丘未灭内色想。未没未除。是名内无色想。何谓观外色。若外无量色。眼识曾见。如实见缘见。意识分别。如实分别缘分别。是名观外色。何谓无量。非少非可称量。无边无量阿僧祇。无边无际。是名无量。何谓好色非好色。若净不净。是名好色非好色。何谓胜知胜见。若于彼法胜受已。知见分别。是名胜知胜见。何谓有如是想。若想不分散不相离一定无量色想。是名有如是想。何谓内无色想。观外色青。青色青光。若于是色。胜知见。有如是想。如比丘。灭内色想已。取外青色想。比丘以外青色调心。修令柔软。柔软已得色胜解。比丘知见分别外青色。心向彼。尊上彼。倾向彼。于彼胜解。何谓内无色想。内色想灭没除。是名内无色想。何谓观外色。若外青色。眼识曾见。如实见缘见。意识分别。如实分别缘分别。是名观外色。何谓青。青有二种。有性青染青。是名青。何谓胜知见。若于彼色胜受已。知见分别。心向彼。尊上彼。倾向彼。于彼胜解。是谓胜知见。何谓有如是想。若有想不分散不相离一定青想。是名有如是想。何谓内无色想。观外色黄黄光。于是色。胜知见。有如是想。如比丘。灭内色想。取外黄色想。比丘以外黄色调心。修令柔软。柔软已得黄胜解。比丘知见分别外黄色。心向彼。尊上彼。倾向彼。于彼胜解。何谓内无色。比丘内色想灭没除。是名内无色想。何谓观外色。若外黄色。眼识曾见。如实见缘见。意识分别。如实分别缘分别。是名观外色。何谓黄。黄有二种。有性黄染黄。是谓黄。何谓胜知见。若于彼色胜受已。知见分别。心向彼。尊上彼。倾向彼。于彼胜解。是名胜知见。何谓有如是想。若有想不分散不相离想一定黄。是谓有如是想。何谓内无色想。观外色赤赤光。若于是色胜知见。有如是想如比丘。灭内色已。取外赤色想。比丘以外赤色调心修令柔软。柔软已比丘得赤胜解。比丘知见分别赤色。心向彼。尊上彼。倾向彼。于彼胜解。何谓内无色想。比丘内色想灭没除。是谓内无色想。何谓观外色。若外赤色。眼识曾见。如实见缘见。意识分别。如实分别缘分别。是谓观外色。何谓赤。赤有二种。有性赤有染赤。是名赤。何谓胜知见。若于彼色胜受已。知见分别。心向彼。尊上彼。倾向彼。于彼胜解。是谓胜知见。何谓有如是想。若有想不分散不相离一定赤。是名有如是想。何谓内无色想。观外色白白光。若于是色胜知见。有如是想。如比丘。内色想灭取外白色想。比丘取外白色调心。修令柔软。柔软已得白胜解。比丘知见分别白色。心向彼。尊上彼。倾向彼。于彼胜解。何谓内无色想。比丘内色灭没除。是谓内无色想。何谓观外色。若外白色。眼识曾见。如实见缘见。意识分别。如实分别缘分别。是名观外色。何谓白。白有二种。有性白染白。是名白。何谓胜知见。若于彼色胜受已。知见分别。心向彼。尊上彼。倾向彼。于彼胜解。是名胜知见。何谓有如是想。若有想不分散不相离一定白色。是谓有如是想。是名八胜处

何谓九灭。若入初禅定。言语刺灭。若入二禅定。觉观刺灭。若入三禅定。喜刺灭。若入四禅定。出息入息刺灭。若入空处定。色想刺灭。若入识处定。空处刺灭。若入无所有处定。识处刺灭。若入非想非非想定。无所有处刺灭。若入灭尽定。受想刺灭。是名九灭。何谓九次第定。如比丘。离欲恶不善法。有觉有观。离生喜乐。成就初禅行。乃至离非想非非想处。成就灭受想定。是名九次第定。何谓九想。不净想。食厌离想。一切世间不乐想。死想。无常想。无常苦想。苦无我想。断想。离欲想。是名九想。何谓十想。不净想。食厌想。一切世间不乐想。死想。无常苦想。苦无我想。断想。离欲想。灭想。是名十想。何谓十直。正见正觉正语正业正命正进正念正定正解脱正智。是名十直。何谓十一切入。地一切入以一想上下纵广无二无量。水一切入。火一切入。风一切入。青一切入。黄一切入。赤一切入。白一切入。空一切入。识一切入。以一想知上下纵广无二无量。何谓地一切入。以一想上下纵广无二无量。何谓地。地谓地界地大。是名地。何谓一切。若尽无余方便。是名一切。何谓一。若独非余界。如人入地一切入。是名一。何谓想。若想不分散不相离一向地想。是名想。何谓上下纵广。上谓虚空。下谓地。纵广谓四方。如人若上下纵广。皆思惟地知解受地。是名上下纵广。何谓无二无量。上无二。下无二。纵广无二。上无量。下无量。纵广无量。无二想。唯有地想。无量无边。阿僧祇。无边无际。于地无异想。是名无量。何谓水一切入。一想上下纵广。何谓水。水界水大。是名水。何谓一切。若尽无余方便。是名一切。何谓一。若独非余界。如人入水一切入。是名一。何谓想。若想不分散不相离一向水想。是谓想。何谓上下纵广。上谓虚空。下谓地。纵广谓四方。如人若上下纵广。皆思惟水知解受水。是名上下纵广。何谓无二无量。上无二。下无二。纵广无二。上无量。下无量。纵广无量。无二想。唯有水想。无量无边。阿僧祇。无边无际。于水无异想。是名无二无量。何谓火一切入。一想上下纵广。何谓火。火界火大。是名火。何谓一切。若尽无余方便。是名一切。何谓一。若独非余界。如人入火一切入。是名一。何谓想。若想不分散不相离。一向火想。是名想。何谓上下纵广。上谓虚空。下谓地。纵广谓四方。如人若上下纵广。何谓无二无量。上无二。下无二。纵广无二。上无量。下无量。纵广无量。无二想。唯有火想。无量无边。阿僧祇。无边无际。于火无异想。是名无二无量。何谓风一切入。一想上下纵广。何谓风。风界风大。是名风。何谓一切。若尽无余方便。是名一切。何谓一。若独非余界。如人入风一切入。是名一。何谓想。若想不分散不相离。一向风想。是名想。何谓上下纵广。上谓虚空。下谓地。纵广谓四方。如人上下纵广。皆思惟风知解受风。是谓上下纵广。何谓无二无量。上无二。下无二。纵广无二。上无量。下无量。纵广无量。无二想。唯有风想。无量无边。阿僧祇。无边无际。于风无异想。是名无二无量。何谓青一切入。一想上下纵广无二无量。何谓青。青有二种。性青染青。是名青。何谓一切。若尽无余方便。是名一切。何谓一。若独非余。如人入青一切入。是名一。何谓想。若想不分散不相离。一向青想是名想。何谓上下纵广。上谓虚空。下谓地。纵广谓四方。如人上下纵广。皆思惟青知解受青。是谓上下纵广。何谓无二无量。上无二。下无二。纵广无二。上无量。下无量。纵广无量。无二想。唯有青想。无量无边。阿僧祇。无边无际。于青无异想。是名无二无量。何谓黄一切入。一想上下纵广无二无量。何谓黄。黄有二种。性黄染黄。是名黄。何谓一切。若尽无余方便。是名一切。何谓一。若独非余。如人入黄一切入。是名一。何谓想。若想不分散不相离。一向黄想。是名想。何谓上下纵广。上谓虚空。下谓地。纵广谓四方。如人上下纵广。皆思惟黄知解受黄。是名上下纵广。何谓无二无量。上无二。下无二。纵广无二。上无量。下无量。纵广无量。无二想。唯有黄想。无量无边。阿僧祇。无边无际。于黄无异想。是名无二无量。何谓赤。一切入一想上下纵广无二无量。何谓赤。赤有二种。性赤染赤。是名赤。何谓一切。若尽无余方便。是名一切。何谓一。若独非余。如人入赤一切入。是名一。何谓想。若想不分散不相离。一向赤想。是名想。何谓上下纵广。上谓虚空。下谓地。纵广谓四方。如人上下纵广。皆思惟赤知解受赤。是名上下纵广。何谓无二无量。上无二。下无二。纵广无二。上无量。下无量。纵广无量。无二想。唯有赤想。无量无边。阿僧祇。无边无际。于赤无异想。是名无二无量。何谓白一切入。一想上下纵广无二无量。何谓白。白有二种。性白染白。是名白。何谓一切。若尽无余方便。是名一切。何谓一。若独非余。如人入白一切入。是名一。何谓想。若想不分散不相离。一向白想。是名想。何谓上下纵广。上谓虚空。下谓地。纵广谓四方。如人上下纵广。皆思惟白知解受白。是名上下纵广。何谓无二无量。上无二。下无二。纵广无二。上无量。下无量。纵广无量。无二想。唯有白想。无量无边。阿僧祇。无边无际。于白无异想。是名无二无量。何谓空一切入。一想上下纵广无二无量。何谓空。空有二种。内空界。外空界。是名空。何谓一切。若尽无余方便。是名一切。何谓一。若独非余。如人入空一切入。是名一。何谓想。若想不分散不相离。一向空想。是名想。何谓上下纵广。上谓虚空。下谓地。纵广谓四方。如人上下纵广。皆思惟空知解受空。是名上下纵广。何谓无二无量。上无二。下无二。纵广无二。上无量。下无量。纵广无量。无二想。唯有空想。无量无边。阿僧祇。无边无际。于空无异想。是名无二无量。何谓识一切入。一想上下纵广无二无量。何谓识。六识身。眼识耳鼻舌身意识身。是名识。何谓一切。若尽无余方便。是名一切。何谓一。若独非余。如人入识一切入。是名一。何谓想。若想不分散不相离。一向识想。是名想。何谓上下纵广。上谓虚空。下谓地。纵广谓四方。如人上下纵广。思惟识知解受识。是名上下纵广。何谓无二无量。上无二。下无二。纵广无二。上无量。下无量。纵广无量无二想。唯有识想。无量无边。阿僧祇。无边无际。于识无异想。是名无二无量。是名十一切入。何谓十一解脱入。如陀舍长者诣阿难所稽首毕。却坐一面。问尊者阿难言。颇有一法。如比丘。不放逸勤念正智寂静行心未解脱得解脱诸漏未尽得漏尽未得无上安隐得安隐不。尊者阿难答陀舍长者言。有也。长者问言。何者是。阿难谓长者言。如比丘。离欲恶不善法。有觉有观。离生喜乐。成就初禅行。比丘如是思惟。此定正学正生。若一切正学正生已。尽知是无常灭法。比丘如实知见。断一切诸漏。心得解脱。虽未断诸漏。比丘以法欲法乐故。断五下分烦恼。于彼化生。而般涅槃。不还此世。长者此是一法。如比丘不放逸勤念正智寂静行心未解脱得解脱诸漏未尽得漏尽未得无上安隐得安隐。复次长者。如比丘灭觉观内正信一心无觉无观定生喜乐。成就二禅行。比丘如是思惟。此定正学正生。若一切正学正生已。尽知是无常灭法。比丘如实知见。断一切诸漏。心得解脱。虽未断诸漏。比丘以法欲法乐故。断五下分烦恼。于彼化生。而般涅槃。不还此世。长者此是一法。如比丘不放逸勤念正智寂静行心未解脱得解脱诸漏未尽得漏尽未得无上安隐得安隐。复次长者。如比丘。离喜舍行念正智身受乐。如诸圣人解舍念乐行。成就三禅行。比丘如是思惟。此定正学正生。若一切正学正生已。尽知是无常灭法。比丘如实知见。断一切诸漏。心得解脱。虽未断诸漏。比丘以法欲法乐故。断五下分烦恼。于彼化生。而般涅槃。不还此世。长者此是一法。如比丘不放逸勤念正智寂静行心未得解脱得解脱诸漏未尽得漏尽未得无上安隐得安隐。复次长者。如比丘断苦乐先灭忧喜不苦不乐舍念净。成就四禅行。比丘如是思惟。此定正学正生。若一切正学正生已。尽知是无常灭法。比丘如实知见。断一切诸漏。心得解脱。虽未断诸漏。比丘以法欲法乐故。断五下分烦恼。于彼化生。而般涅槃。不还此世。长者此是一法。如比丘不放逸勤念正智寂静行心未得解脱得解脱诸漏未尽得漏尽未得无上安隐得安隐。复次长者。如比丘慈解心遍解一方行。南西北方四维上下。一切慈解心广大尊胜。无二无量。无怨无恚。遍解诸世间行。比丘如是思惟。此慈解心正学正生。若一切正学正生已。尽知是无常灭法。比丘如实知见。断一切诸漏。心得解脱。虽未断诸漏。比丘以法欲法乐故。断五下分烦恼。于彼化生。而般涅槃。不还此世。长者此是一法。如比丘不放逸勤念正智寂静行心未得解脱得解脱诸漏未尽得漏尽未得无上安隐得安隐。复次长者。如比丘悲心遍解一方南西北方四维上下。一切悲心。广大尊胜。无二无量。无怨无恚。遍解诸世间行。比丘如是思惟。此悲解心正学正生。若一切正学正生已。尽知是无常灭法。比丘如实知见。断一切诸漏。心得解脱。虽未断诸漏。比丘以法欲法乐故。断五下分烦恼。于彼化生。而般涅槃。不还此世。长者此是一法。如比丘不放逸勤念正智寂静行心未得解脱得解脱诸漏未尽得漏尽未得无上安隐得安隐。复次长者。如比丘喜心遍解一方行。南西北方四维上下。一切喜心。广大尊胜。无二无量。无怨无恚。遍解世间行。比丘如是思惟。此喜解心正学正生。若一切正学正生已。尽知是无常灭法。比丘如实知见。断一切诸漏。心得解脱。虽未断诸漏。比丘以法欲法乐故。断五下分烦恼。于彼化生。而般涅槃。不还此世。长者此是一法。如比丘不放逸勤念正智寂静行心未得解脱得解脱诸漏未尽得漏尽未得无上安隐得安隐。复次长者。如比丘舍心遍解一方行。南西北方四维上下。一切舍心。广大尊胜。无二无量。无怨无恚。遍解世间行。比丘如是思惟。舍解心正学正生。若一切正学正生已。尽知是无常灭法。比丘如实知见。断一切诸漏。心得解脱。虽未断诸漏。以法欲法乐故。断五下分烦恼。于彼化生。而般涅槃。不还此世。长者此是一法。如比丘不放逸勤念正智寂静行心未得解脱得解脱诸漏未尽得漏尽未得无上安隐得安隐。复次长者。如比丘离一切色想。灭嗔恚想。不思惟若干想。成就无边空处行。比丘如是思惟入此定正学正生。若一切正学正生已。尽知是无常灭法。比丘如实知见。断一切诸漏心得解脱。虽未断诸漏。比丘以法欲法乐故。断五下分烦恼。于彼化生。而般涅槃。不还此世。长者此是一法。如比丘不放逸勤念正智寂静行心未得解脱得解脱诸漏未尽得漏尽未得无上安隐得安隐。复次长者。如比丘。离一切空处。成就无边识处行。比丘如是思惟。入此定正学正生。若一切正学正生已。尽知是无常灭法。比丘如实知见。断一切诸漏。心得解脱。虽未断诸漏。比丘以法欲法乐故。断五下分烦恼。于彼化生而般涅槃。不还此世。长者此是一法。如比丘不放逸勤念正智寂静行心未得解脱得解脱诸漏未尽得漏尽未得无上安隐得安隐。复次长者。如比丘。离一切识处。成就无所有处行。比丘如是思惟。入此定正学正生。若一切正学正生已。尽知是无常灭法。比丘如实知见。断一切诸漏心得解脱。虽未断诸漏。比丘以法欲法乐故。断五下分烦恼。于彼化生。而般涅槃。不还此世。此是一法。如比丘不放逸勤念正智寂静行心未得解脱得解脱诸漏未尽得漏尽未得无上安隐得安隐。阿难说已。陀舍长者言。如人求一宝藏得十一宝藏。尊者阿难。我亦如是。求一解脱入。得十一解脱入。尊者阿难。如长者子舍。有十一门。为火所烧。猛焰炽盛。长者长者子。意欲出时。于诸门中。自在得出。尊者阿难。我亦如是。于十一法门中。所欲出处。随意得出。尊者阿难。如邪见婆罗门。犹为师求财供养师。况闻正见而不供养。时陀舍长者请毗耶离众僧波多离众僧。请已作种种肴膳以饭众僧。食充足已。或以履屣。或以白[疊*毛]万张。以施众僧。别以三衣及好房舍。奉上阿难。是名十一解脱入

舍利弗阿毗昙论卷第十七舍利弗阿毗昙论卷第十八

        姚秦罽宾三藏昙摩耶舍共昙摩崛多等译

    非问分烦恼品第十一之一

有一人出世。如来无所著等正觉。断恶不善法。生诸善法。断苦法。得乐法。寂静诸漏灭诸漏。除诸所作业。能得寂静第一义清凉。究竟尽究竟梵行。究竟安乐究竟苦际得涅槃。以是因缘故。今当集诸不善法门

恃生。恃姓。恃色恃财。恃贵。恃尊胜。恃豪族。恃无病。恃年壮。恃命。恃功巧。恃多闻。恃辩才。恃得利养。恃得恭敬。恃尊重。恃备足。恃师范恃戒。恃徒众。恃党侣。恃长宿。恃力。恃神足恃禅。恃无求。恃知足。恃独处。恃阿兰若。恃乞食。恃粪扫衣。恃我能离荒食。恃一受食。恃冢间。恃露处。恃树下。恃常端坐。恃随敷坐。恃但三衣。谀谄。邪敬。现相求利。依使。叹索。以利求利。我胜。嗜味。不护戒嗔相变。忿尊教。违尊教。戾尊教。欺陵。捶打。斛斗欺。称欺。财物欺。伤害。系闭。[打-丁+此]摸。侵夺。故作。长语。横语。轻谤。迫胁。欺善。隐藏。共畜。好说官事。世间事。兵诤事。斗战事。大臣事。车乘事。妇女事。华鬘事。酒肉事。淫欲事。床卧事。衣服事。饮食事。沽酒处事。亲里事。若干语。思惟世间事。说海事。不知法。不知义。不知时。不知足。不知自身。不知众生。不知人。不知胜劣人。如邪见。边见。倒见。求觅见。求觅戒。求觅戒道。身见躁动。自赞。无信。不觉。悭惜。面誉。遮惜。不信业报。毁施。毁学。自叹。誉怨。虚叹。不自在。属他。事他。不怨憎。怨憎。沉没。心悲。不厌足。不勤进。不忍辱。非威仪。不受教。近恶知识。恶亲厚。取恶行。恶行。亲近怯弱者。受怯弱法。知怯弱。持怯弱法。不顺思惟。亲近怯弱道。心乱。喜诤。宽禁戒。敬邪法。退善法。掉。严身。险。耐耻。狂言。不记。外念。随忧喜。自高。毁他。不敬。不自卑。不实敬。难满。难养。窳惰。懈怠。中退。后善。欲勤。苦勤。贪。贪勤缠。恼。悲。苦。忧念。众苦。恐怖。弱颜。强颜。疑惑。无亲。善障碍。不相可。善妨。边实。不亲近。近离。卑下。自强。耐辱。随贪。自举。自放。无持。离禅。不悔。含忿。吝惜。邪教。诤讼。非逊。敬失。灾喜。求失。非行。求禅。无益禅。不知恩。不知己恩。轻毁。嗔恚。性恶。刚强。断修学。呵谏反责。呵已乱说横生嗔恚。所呵不成。呵不自明。取身。见身。见饿。举身。见憧。忧身见。求身见。亲近身见。身慢见。游戏。惜身见。我身见。欲染共欲染。悲。不亲。增。乐欲。悕望。不足重悕望。究竟悕望。不足不满。碍着洒散。如水津流。沉没爱支。能生苦本。欲得嗜着。燋渴。居宅。堪忍。尘疮。爱法。失念。不正智。不护诸根门。食不知足。无明。有爱。有见。非有见。欲漏。有漏。欲求。有求。害戒。害见。戒衰。见衰。衰命。衰仪。衰行。作恶。不作善。亲近在家。亲近出家。以二缘生欲染。以二缘生邪见。嗔恚。伺怨。怀恨。燋热。嫉妒。悭惜。幻变。多奸。无惭。无愧。矜高。诤讼。贡高。放逸。慢。增上慢。二法内和合。外和合。内外合。悕望。大悕望。恶悕望。贪。恶贪。非法欲染。三不善根。三难伏。三闇。三荒。三缠。三动。内三垢。内三竞。内三怨。内三网力。内三害。内三憎。三毒。三胜。三闇聚。三力。复有三力。三爱。三不摄。三恶行。身三恶行。意三恶行。三不净。三不觉。三不直。三痰阴。三欲。三想。三觉。三求。三火。三熅。三暖。三炙。三热。三燋。三恶。三有。三漏。三不轻。三不软。三不除(三法竟)。四流。四扼。四取。四染。口四恶行。四结。四箭。四识住处。四缘生爱。四爱和合。四恶道行。四业烦恼。四颠倒。四怖。复有四怖。复有四退转(四法竟)。五欲。五盖。五下分烦恼。五上分烦恼五道。五心荒。五心缠。五怖。五怨。五无间。五犯戒。五非法语。五不乐。五相憎。五嗔恨法。五忧根法。五嫉妒。五缘生。睡眠犯戒。五过患缘犯戒故。复有五过患。不敬父母。不敬沙门婆罗门。不敬亲长(五法竟)。六依贪喜。六依贪忧。六依贪舍。六染。六乐。复有六乐。六爱。六恚。六钩。六不护。六诤根(六法竟)。七共染。七共欲染。七识住处。七慢。七不敬。七漏。七御弱法。七动。七自恃。七求。七摸。七作。七生(七法竟)。八世间法。八非圣语。八懈怠事。八难处妨修梵行(八法竟)。九若干法。九爱根法。九众生居。九犯戒过患(九法竟)。十烦恼使。十烦恼结。十想十觉十邪十恼事。十不善业道。十法成就堕地狱速如[矛*(替-曰+貝)]鉾(十法竟)。十一心妒。二十种身见。二十法成就堕地狱速如[矛*(替-曰+貝)]鉾。二十一心垢。三十法成就堕地狱速如[矛*(替-曰+貝)]鉾。三十六爱行。三十法成就堕地狱。四十法成就堕地狱速如[矛*(替-曰+貝)]鉾。六十二见

何谓恃生。众生贵生。以生自高。以生为境界。若心忆念。谓生妙好而以自高。是名恃生。复次恃生。我生。胜彼中生。彼生卑。世间诸生中我生最胜。众生重于生。常敬于生。若心忆念诸生妙好而以自高。是名恃生。恃姓恃色恃财贵恃尊胜恃豪族恃无病恃年壮恃命壮恃功巧恃多闻恃辩才恃得利养恃得恭敬恃尊重恃备足恃师范恃徒众恃党侣恃长宿恃力恃神足恃禅恃无求恃知足恃独处恃阿兰若恃乞食恃粪扫衣恃我能离荒食恃一受食恃冢间恃露处恃树下恃常端坐恃随敷坐恃但三衣。亦如上广说

何谓谀谄。若依他求利。改变仪式现摄诸根。是名谀谄。何谓邪敬。若依他求利。饰辞美言。将顺他意诈现巧便。以是行敬。是名邪敬

何谓现相求利。若依他求利。见有衣食卧具医药诸物。心希欲得现相称好。是名现相求利何谓依使。为人役使虽复轻贱。以利故随逐不息。是名依使。何谓叹索。若依他求利。见有衣服饮食卧具汤药诸物。心希欲得先叹其善。复言我须。是名叹索。何谓以利求利。心希欲得。若从彼人得利。以示此人。若从此人得利。以示彼人。此所得利。向彼叹誉此施主。彼所得利。向此叹誉彼施主。若如是得利。是名以利求利

何谓我胜。若以慢自高谓身胜。是名我胜。何谓嗜味。贪食多求种种味。是名嗜味。何谓不护戒。若舍出家威仪。是名不护戒。何谓嗔相变。若起不善心。令诸根变异。若以十恼一一发起。令诸根变异。是名嗔相变

何谓忿尊教。尊谓佛佛弟子。若教授便拒违嗔忿。或多语或嚬蹙现嗔。若教令慎护重禁。便拒逆嗔忿。或多说或复嚬蹙现嗔。是名忿尊教。何谓违尊教。尊谓佛佛弟子。若教授令顺护重禁违返。是名违尊教。何谓戾尊教。若世尊所制。莫作是说。莫作是作。莫作是言。莫作是分别。彼不作是说故说。不应作是作故作。不应作是言故言。不应作是分别故分别。是名戾尊教

何谓欺陵。若于众生触恼轻蔑。不欲断害其命。是名欺陵。何谓捶打。若轻易手拳捶打。是名捶打。何谓斗欺。若不等心受出多少。是名斗欺。何谓称欺。若不等心受出轻重。是名称欺。何谓财物欺。若好物中杂恶物。若分种种物。若以绳界定移本处。是名财物欺。何谓伤。若侵破他人身。是名伤。何谓侵害。若轻蔑众生。嗔恚希害。欲断其命。是名侵害。何谓系闭。若众生为生死缠缚常处幽闇。是名系闭。何谓[打-丁+此]摸。若起不善心以手求觅。是名[打-丁+此]摸。何谓侵夺。若起不善心。于他财物侵欺劫夺。是名侵夺。何谓故作。若心起不寂静行。心知而造。是名故作。何谓长语。若横言轻谤。是名长语。何谓横言。若无义语。是名横言。何谓轻谤。若无实诳他。是名轻谤。何谓迫胁。若国王国王臣吏。若蹴蹋困苦取他财物。是名迫胁。何谓诈善。若欲欺诳若取财物。而现亲附。是名诈善。何谓隐藏。若人共物未分。私取好者覆匿。是名隐藏。何谓共畜。若人已行筹分物。以物不善强择取好者。是名共畜。何谓好说官事。常以官法言首。或言筹算。或言长短。染乐其事。是名好说官事。世间事。兵甲事。斗战事。车乘妇女事。华鬘事。酒肉事。淫欲事。床卧事。衣服事。饮食事。沽酒事。亲里事。亦复如是。若染乐其事。何谓若干语。除上乐说事。若余事众生异物异境界异自然异。是名若干语。何谓思惟世间事。若忆念为首。思惟世间成坏。是名思惟世间事。何谓说海事。若以海为言首。或说诸宝。或说真伪。染乐其事。是名说海事

何谓不知法。若于善不善无记法。不知自相不观相不分别相。是名不知法。何谓不知义。若于诸法今世后世义。不知自相不观相不分别相。是名不知义。何谓时不知。若不知时节应入聚落。应出聚落。应诵读应受学应思惟。于此时不知自相不观相不分别相。是名不知时。何谓不知足食。不知足言。不知足不知自相。不观相不分别相。是名不知足。何谓不知自身。不知我应有如是信如是戒如是学问如是施如是慧如是应答。若于此法不知自相不观相不分别相。是名不知自身。何谓不知众生。刹利众婆罗门众。居士沙门众。应如是往反。应如是坐起。应如是言默。若于众中不知自相。不观相不知分别相。是名不知众。何谓不知人。若持戒毁戒人。若可观人。若于此人不知自相。不观相不分别相。是名不知人。何谓不知胜劣人。若尊卑人不知自相。不观相不分别相。是名不知胜劣人

何谓邪见。或有人起如是见。无施无与无祠。无善恶业报。无今世后世。无父母无天。无化生众生。无世间沙门婆罗门正趣正至。若今世后世自知证分别说。是名邪见。何谓边见。若见一切有见一切无。见一切一见一切异。若见一切种种。是名边见。何谓倒见。若见正觉谓非正觉。若非正觉谓是正觉。若见善法谓非善法。若见不善法谓是善法。若见正趣沙门婆罗门谓非正趣。若非正趣沙门婆罗门谓是正趣。若有作是见。我乐世乐后生当乐恒常不断不变易法常当定住。是名倒见。何谓求觅见。若于诸见中选择选择己。是名求觅见。何谓求觅戒。若以戒为净。若贪求[打-丁+此]摸。是名求觅戒。何谓求觅道。若以道为净。贪求[打-丁+此]摸。是名求觅道。何谓求觅戒道。若俱以为净。若贪求[打-丁+此]摸。是名求觅戒道。何谓身见。若我见。何谓我见。或有人谓色是我。色中有我。色是我有。我是色有。见受想行识亦如是。是名身见

何谓躁。若动止轻速疾。是名躁。何谓自称。若叹美过能。是名自称。何谓无信。若不信不入信不胜信不真信。若心不信。是名无信。何谓不觉。若无慧。是名不觉。何谓悭惜。若贪不舍。是名悭惜。复次悭惜憎他施与利养所须。是名悭惜。何谓面誉。不求他财利。随顺他意对称其善。是名面誉。何谓遮惜。若悭吝财物。令人防护门户。恐沙门婆罗门得入乞求。是名遮惜

何谓不信业。若于善不善无记业中不解重不解究竟不解。是名不信业。何谓不信业报。善不善业有报。若于此报不解重不解究竟不解。是名不信业报。何谓毁施。若非法行施者。是名毁施。何谓毁学。若非学者。是名毁学。何谓自胜。若自高我有信戒施闻智慧辩才。是名自胜。何谓誉怨。若人有怨家。欲现其恶反称其善。有信戒施闻慧辩才。是名誉怨。何谓虚叹。心有邪悔。若无信戒施闻慧辩才。叹说言有。是名虚叹

何谓不自在。若烦恼心起所作众善不得随意。是名不自在。何谓属他。若业不净。若欲现亲。或作奴仆侍从。是名属他。何谓事他。若与贵胜遨游戏笑。恃为形势。是名事他。何谓不怨憎。若爱喜。是名不怨憎。何谓怨憎。若嗔忿是名怨憎。何谓沉没。若善法废退。是名沉没。何谓心悲。若心不善悲。是名心悲。何谓无厌。若于生活具多欲不止。是名无厌。何谓不勤进。若于善法意不专乐。是名不勤进。何谓不忍辱。若于善法不能堪忍受。是名不忍辱。复次不忍辱。或有不耐饥渴寒热风雨蚊虻蟆子。不适意语。若身心苦痛酸楚。终时刀风解形。不能堪忍受。是名不忍辱。何谓非威仪。若毁佛结戒。是名非威仪。何谓不受教。若如法教授心不敬顺。是名不受教

何谓近恶知识。若杀生盗窃邪淫妄语饮酒放逸处。若近此人作知识重知识究竟知识相敬念。是名近恶知识。何谓恶亲厚。若杀生盗窃邪淫妄语饮酒放逸处。若共此人亲厚重亲厚究竟亲厚相敬不离。是名恶亲厚。何谓取恶行。依杀生者学杀生。心向彼尊上彼倾向彼以彼为解。依盗窃者学盗窃。依邪淫者学邪淫。依妄语者学妄语。依饮酒放逸处者。学饮酒放逸处。心向彼尊上彼。倾向彼以彼为解。是名取恶行。何谓恶行。若不善境界行。是名恶行

何谓亲近怯弱者。若不信者无惭无愧者。不学问者懈怠者。失念者无慧者。若亲近此人恭敬承事。是名亲近怯弱。何谓受怯弱法。若怯弱者所说法恭敬受行。是名受怯弱法。何谓知怯弱。若怯弱者所说法。恶法善听受心能分别。是名知怯弱法。何谓持怯弱法。若怯弱者所说法。若持此法正持住不忘相续念不失。是名持怯弱法

何谓不顺思惟。若不顺善思惟。是名不顺思惟。何谓亲近怯道。谓邪见乃至邪定。若亲近多修学。是名亲近于怯道。何谓劣心。若心懈怠。是名劣心。何谓乱心。若心散在五欲色声香味触。是名乱心。何谓喜诤。若诤讼若系闭。常相违返。是名喜诤。何谓宽禁戒。若缺若荒若垢离禁戒。是名宽禁戒。何谓敬邪法。若恶不善法。以此为尊能得定。是名敬邪法。何谓退善法。若出世间法。于此法废退。是名退善法。何谓掉。若掉动心乱不寂静不正寂静。是名掉。何谓严身。若自扪饰。是名严身。何谓险。若身口意业起动不顺。是名险。何谓耐耻。若在众不问妄说。是名耐耻。何谓狂言。若纵语不摄。是名狂言。何谓不记。若失念善。是名心不记。何谓外念。若念在五欲色声香味触。是名外念。复次外念。若念外道。若敬念外道。心在彼法。是名外念。何谓随忧喜。若俗间有种种喜乐种种忧苦。心有希求随顺和同。是名随忧喜。何谓自高。若叹身相是多能。是名自高。何谓毁他。若说他长短。是名毁他。何谓不敬。若轻慢尊长无有敬畏。是名不敬。何谓不自卑。若不下人。是名不自卑。何谓不实敬。若于净行者种种称美虚伪不真。是名不实敬。何谓难满。若饮食无厌。是名难满。何谓难养。求美味是名难养。何谓窳惰。若懈怠。是名窳惰。何谓懈怠。若窳惰。是名懈怠。何谓中止。若求上利则易缘。懈怠故便息。是名中止。何谓后善。若于善法中失灭没。是名后善。何谓欲勤。若乐着于欲。是名欲勤。何谓勤苦。若种种苦身。但非圣法无仪无益无义。是名勤苦。何谓贪。若爱广大极于彼岸。是名贪。何谓贪缠。若爱广大极于彼岸。是名贪缠。何谓恼。若众生若干苦所逼。若恼重恼究竟恼。内燋热内心[夢-夕+登]瞢。是名恼。何谓悲心。若众生为苦恼所逼恼箭入心。若哭泣口说追忆不舍。是名悲心。何谓苦。若身不忍受眼触苦受耳鼻舌身触苦受。是名苦。何谓忧。若心不忍受苦。是名忧。何谓众苦。若为种种苦所逼。心无停息。是名众苦。何谓恐怖。若心惊动。是名恐怖。何谓弱颜。若作善法耽闇喜着。是名弱颜。何谓强颜。如小儿言无忌难。是名强颜。何谓疑惑。二心犹豫不能断结。是名疑惑。何谓无亲。若远离善法。是名无亲。何谓善障碍。若背善法。是名障碍。何谓不相可。若喜斗诤系缠共相言讼。是名不相可。何谓善妨。若作善法因生自高。是名善妨。何谓边实。若边见者执所见为坚实。是名边实。何谓不亲近。若不亲近佛佛弟子。不供养恭敬礼拜。是名不亲近。何谓近离。若曾亲近佛佛弟子供养恭敬礼拜后便废退不复亲近供养恭敬礼拜。是名近离。何谓卑下。身口意业作欺诡不实卑劣法。是名卑下。何谓自强。若起不善心现身口意。是名自强。何谓耐辱。若贪着世俗法希求往来不息。是名耐辱。何谓随贪。若贪逐利养不息。失善人相。是名随贪。何谓自举。若身口意业共掉。是名自举。何谓自放。若心涌散不摄。是名自放。何谓无持。若手足烦恼。无有定操。纵横画地。是名无持。复次无持。若好行来。是名无持。何谓离禅。若不亲近寂静处。是名离禅。何谓不悔。若起不善心欢喜踊跃。无有变失。是名不悔。何谓含忿。若有不可常使不息因增烦恼。是名含忿。何谓吝惜。若于财法护念不舍。是名心吝惜。何谓邪教。若说邪法。是名邪教。若邪见者。集声音句言语口教。是名邪教。何谓诤讼。求他长短不生和顺。是名诤讼。何谓非逊。若所作业心高无有敬顺。是名非逊。何谓敬失。若敬自下非法。是名敬失。何谓灾喜。若见他衰失反生喜快。是名灾喜。何谓求失。若有怨嫌常伺缺漏。是名求失。何谓非行。若比丘犯失威仪作非威仪行。是名非行。何谓求禅。若人聚集处心求名利。便现坐禅相。是名求禅。何谓无益禅。若人坐禅无仪。是名无益禅。何谓不知。恩若从他得财施法施。不知分别正分别不缘分别。是名不知恩。何谓不知己恩。若曾从他得财物施法施不受恩。是名不知己恩。何谓轻毁。若说他过失心不忌难。是名轻毁。何谓嗔恚。若忿怒不。护他意。是名嗔恚。何谓性恶。若身口意卒暴。是名性恶。何谓[鑼-維+(正*寸)][革*卬]。若无有忍辱行。是名[鑼-維+(正*寸)][革*卬]。何谓断修学。若遮他作善。是名断修学。何谓呵谏反生讥责。若人作恶善谏不受。是名呵谏反生讥责。何谓呵谏。乱语生恚。何谓呵谏不成。何谓呵谏不明。皆如上说

何谓取身见。缘身见故取身见。身见恶故取身见。如险难道有草木丛林覆上。趣彼道者不知高下深浅。如是取身见者。不识是非好恶。是名取身见。何谓身见饿。缘身见故身见饿。身见恶故身见饿。令众生处诸苦难。如是中渴饿禽兽恶虫饿人非人饿。如是趣彼道者。受无量种种苦。如是取身见。受诸苦痛不至彼岸。是名身见饿。何谓立身见幢。若乐起身见。是名立身见幢。何谓忧身见。若缘身见故生忧恼。重生究竟生忧恼。是名忧身见。何谓求身见。若缘身见故邪求色受想行识。是名求身见。何谓亲近身见。若缘身见故。亲近色受想行识。是名亲近身见。何谓身慢见。若缘身见故。身慢严饰己身。是名身慢见。何谓游戏身见。若缘身见。若缘身见故取爱色受想行识。是名惜身见。若缘身见故取我受想行识。是名我身见

何谓欲染。若欲界欲色无色界欲。是名欲染。共欲染悲不亲增乐欲亦如是。何谓悕望。若爱初触。是名悕望。何谓重悕望爱。若广大未极彼岸。是名重悕望。何谓究竟悕望爱。若广大以极彼岸。是名究竟悕望。何谓难足。若欲界不足。色无色界不足。是名难足。难满着洒津流没枝网生本希嗜燋渴宅忍尘疮受。亦如上说(一法竟)

何谓失念。若舍善念。是名失念。何谓不正知。或有比丘。不以正知去来屈伸回转。服僧伽梨。执衣持钵。饮食便利。解息睡眠行住坐卧。眠时觉时默时不自护行。是名不正知。何谓不护根门。若见色取。是名不护根门。何谓食不知足。若不量食。是名食不知足

何谓无明。若痴不善根。是名无明。何谓有爱。若色无色界爱。是名有爱。何谓有见。若常见。是名有见。何谓非有见。若断见。是名非有见。何谓欲漏。若贪着欲界法。是名欲漏。何谓有漏。若贪着色无色界法。是名有漏。何谓欲求。若欲界未度。欲界未知。欲界未断。欲界阴界入色声香味触法。若求觅聚集。是名欲求。何谓有求。若色界无色界未度。色无色界未知。色无色界未断。色无色界阴界。入禅解脱定入定。若求觅聚集。是名有求。何谓不持戒。若破戒。若不持戒。是名不持戒。何谓害见。若六十二见及邪见。是名害见。何谓戒衰。若毁戒不护持。是名戒衰。何谓见衰。若六十二见及邪见。是名见衰。何谓衰命。若邪命。是名衰命。何谓衰仪。若非威仪行。是名衰仪。何谓衰行。若比丘非自境界行。是名衰行。何谓作恶。不善法成就。是名作恶。何谓不作善。出世间善法若不作不成就。是名不作善。何谓亲近在家。若顺世间违于正行。是名亲近在家。何谓亲近出家。若不顺在家法违于世行。是名亲近出家。何谓二缘欲染。若缘净色缘不顺思惟生欲染。是名二缘欲染。何谓二缘嗔恚。缘怨憎缘不顺思惟。是名二缘生嗔恚。熏如烟荒。何谓二缘生邪见。缘他邪说缘不顺思惟生邪见。是名二缘生邪见。何谓嗔恚。若忿怒重忿怒。是名嗔恚。何谓伺怨。若欲报仇缠究竟缠心行痴业究竟忿怒若嗔恚。是名伺怨。何谓怀恨。若心垢秽烦恼所污。是名怀恨。何谓燋热。若不适意。而生忧恼。是名燋热。何谓嫉妒。若他得利养尊重恭敬礼拜。而生嫉妒重嫉妒究竟嫉妒。是名嫉妒。何谓悭惜。若财施法施贪吝。不舍聚集乐着。是名悭惜。何谓幻变。若于尊胜及余人前。为名闻虚誉故。自覆过失。诡谲他人。何谓奸欺。若心邪曲不正。是名奸欺。何谓无惭。若自作恶内心不悔。是名无惭。复次无惭。若人无惭。于可耻法不耻。于恶不善法不耻。是名无惭。何谓无愧。若自作恶不羞他人。是名无愧。复次无愧。若人不愧。于可羞法不羞。于恶不善法不羞。是名无愧。何谓矜高。慢他自誉。是名矜高。何谓诤讼。若起身口意不善掉动粗言忿恼。是名诤讼。何谓贡高。若起不善心。严饰己身称叹己善。意不开解。是名贡高。何谓放逸。若不摄乱念。是名放逸。何谓慢。若言我胜。是名慢。何谓增上慢。言我与胜等。是名增上慢(二法竟)

舍利弗阿毗昙论卷第十八舍利弗阿毗昙论卷第十九

        姚秦罽宾三藏昙摩耶舍共昙摩崛多等译

    非问分烦恼品第十一之二

何谓内集。若于内法中。欲染共欲染。非不增乐欲。悕望重悕望究竟悕望。难足难满。贪洒津漏没枝网生本希嗜着焦渴宅忍尘疮爱。是名内集。何谓外集。若于法欲染共欲染。乃至尘疮爱。是名外集。何谓内外集。若于内外法欲染共欲染。乃至尘疮爱。是名内外集。何谓悕望。若自有善法悕望故欲令他知。是名悕望。何谓大悕望。若多悕望。是名大悕望。何谓恶悕望。若自无善法悕望故。欲令他知有善。是名恶悕望。何谓贪。若于自物财赂妻子等贪欲染贪着。是名贪。何谓恶贪。若于他物财赂妻子等。欲令我有贪欲染贪着。是名恶贪。何谓非法欲染。若母师妻等作欲染行。是名非法欲染。何谓三不善根。贪不善根恚不善根痴不善根。是名三不善根。何谓三难伏。欲难伏恚难伏痴难伏。是名三难伏。何谓三闇。贪闇恚闇痴闇。是名三闇。何谓三荒。欲荒恚荒痴荒。是名三荒。何谓三缠。欲缠恚缠痴缠。是名三缠。何谓三动。欲动恚动痴动。是名三动。何谓内三垢。欲垢恚垢痴垢。是名内三垢。何谓内三竞。欲竞恚竞痴竞。是名内三竞。何谓内三怨。欲怨恚怨痴怨。是名内三怨。何谓内三网。欲网恚网痴网。是名内三网。何谓内三害。欲害恚害痴害。是名内三害。何谓内三憎。欲憎恚憎痴憎。是名内三憎。何谓内三毒。欲毒恚毒痴毒。是名内三毒。何谓三胜。我慢不如慢增上慢。是名三胜。何谓三闇聚。疑惑我过去有我过去无。何姓过去有何因过去有。疑惑我当来有我当来无何姓当来有何因当来。有疑惑我现在有现在无何姓现在有何因现在有。是名三闇聚。何谓三刀。欲刀恚刀痴刀。是名三刀。何谓复有三刀身刀口刀意刀。是名复有三刀。何谓三爱。欲爱有爱非有爱。是名三爱。何谓三不摄。身不摄口不摄意不摄。是名三不摄。何谓三恶行。身恶行口恶行意恶行。是名三恶行。何谓身三恶行。杀盗邪淫。是名身三恶行。何谓意三恶行。贪恚邪见。是名意三恶行。何谓三不净。身口意不净。是名三不净。何谓三不觉。身口意不觉。是名三不觉。何谓三曲。身口意不直。是名三曲。何谓三痰癊。欲痰癊恚痰癊痴痰癊。是名三痰癊。何谓三欲。欲欲恚欲害欲。是名三欲。何谓三想。欲想恚想痴想。是名三想。何谓三觉。欲觉恚觉害觉。是名三觉。何谓三求。身求口求意求。是名三求。何谓三火。欲火恚火痴火。是名三火。何谓三熅。欲熅恚熅痴熅。是名三熅。何谓三暖。欲暖恚暖痴暖。是名三暖。何谓三炙。欲炙恚炙痴炙。是名三炙。何谓三热。欲热恚热痴热。是名三热。何谓三焦。欲焦恚焦痴焦。是名三焦。何谓三恶。身恶口恶意恶。是名三恶。何谓三有。欲有色有无色有。是名三有。何谓三漏。欲漏有漏无明漏。是名三漏。何谓三浊。身口意浊。是名三浊。何谓三不软。身不软口不软意不软。是名三不软。何谓三不除。身不除口不除意不除。是名三不除(三法竟)

何谓四流。欲流有流见流无明流。是名四流。何谓四扼。欲扼有扼见扼无明扼。是名四轭。何谓四取。欲取有取戒取我取。是名四取

何谓四染欲染色染无色染见染。是名四染何谓口四恶行。妄语绮语两舌恶口。是名口四恶行。何谓四结。悕望身结嗔恚身结戒道身结见实身结。是名四结。何谓四箭。欲箭嗔箭慢箭见箭。是名四箭

何谓四识住处。比丘识依色作色为境界。色中止爱相续。得增长广大。受想行住处亦如是。是名四识住处

何谓四缘生爱。若比丘缘衣生爱缘食生爱缘卧具生爱缘医药生爱。是名四缘生爱。何谓四爱相缘。若缘爱生爱缘爱生憎缘憎生憎缘憎生爱。是名四爱相缘

何谓四恶道行。欲恶道行恚恶道行畏恶道行痴恶道行。是名四恶道行。何谓四业烦恼。杀生业烦恼窃盗业烦恼邪淫业烦恼妄语业烦恼。是名四业烦恼

何谓四颠倒。无常谓常。想颠倒心颠倒见颠倒。苦谓乐。想颠倒心颠倒见颠倒。无我谓我。想颠倒心颠倒见颠倒。不净谓净。想颠倒心颠倒。见颠倒。是名四颠倒

何谓四怖。王法怖贼盗怖火怖水怖。是名四怖。何谓复有四怖。老怖病怖死怖恶趣怖。何谓复有四怖。波怖涛涌怖洄澓怖失收摩罗怖(秦言[魚*曷]鱼)。何谓复有四怖。自衰怖诽谤怖孤遗怖无子怖。是名复有四怖

何谓四退转法。如世尊说四退转法。何谓四。比丘尊重嗔恚不尊重正法。尊重憎嫉不尊重正法。尊重利养不尊重正法。尊重恭敬不尊重正法

  嗔恚憎嫉　　利养恭敬　　如是尊重
  比丘失道　　良田败种　　善法不生

是名四退转法(四法竟)

何谓五欲。眼识色爱喜适意爱色欲染相续。耳鼻舌身识触亦如是说。是名五欲

何谓五盖。欲染盖嗔恚睡眠掉悔疑盖。是名五盖。何谓五下分烦恼。身见疑戒盗欲染恚。是名五下分烦恼。何谓五上分烦恼。色染无色染无明慢掉。是名五上分烦恼

何谓五道。地狱畜生饿鬼人天。是名五道

何谓五心荒。如比丘疑惑世尊。不信不度不解。比丘心疑惑世尊。心不信不度不解已。比丘心不向世尊不信不亲近不解已。此谓初心荒。法僧亦如是。复次比丘戒有缺行荒行垢行。比丘戒缺行荒行垢行已。比丘心不向戒不信不亲近不解。比丘不向戒不信不亲近不解已。是名四心荒。复次比丘心恼害诸净梵行者。心荒不信。毁骂恶言轻谤诸梵净行者。比丘恼害诸梵净行。诸恼害心荒于不信。毁骂恶言轻谤诸梵净行者已。比丘心不向诸梵净行者。不信不亲近不解。比丘心不向诸梵净行者。不信不亲近不解已。是名五心荒

何谓五心缠。如比丘身不离染不离欲不离爱不离渴不离燋热。比丘不离染不离欲不离爱不离渴不离燋热已。比丘心不向勤进信寂静断结。比丘不向勤精进信寂静断结已。此谓初心缠。复次比丘勤行色欲等乐。勤行卧具睡眠乐。比丘勤行色欲等乐。勤行卧具睡眠已。比丘心不向勤精进正信寂静行断结。比丘心不向勤精进正信寂静行断已。是名第二第三心缠。复次比丘得少进便住不上求。未得欲得。未解欲解。未证欲证。比丘得少进便住不上求。未得欲得未解欲解未证欲证已。比丘不向勤精进正信寂静行断结。比丘心不向勤精进正信寂静行断结已。是名第四心缠。复次比丘悕望生种种天上故。行梵净行。我以此戒道苦行梵净行。令我作天王或作辅臣。比丘悕望生种种天上故。行梵净行。我以此戒道苦行梵净行。令我作天王。或作辅臣已。比丘心不向勤精进正信寂静行断结。比丘心不向勤精进正信寂静行断结已。是名五心缠

何谓五怖。若杀生缘杀生故于现世怖未来世怖。窃盗邪淫妄语饮酒放逸处怖亦如是。是名五怖。五怨亦如是

何谓五无间。杀父无间。杀母无间。杀阿罗汉无间。破众僧无间。恶心出佛身血无间。是名五无间

何谓五犯戒。杀生盗窃邪淫妄语饮酒放逸。是名五犯戒

何谓五非法语。非时语无实语无义语非法语不调顺语。是名五非法语。何谓五不乐。不乐独处不乐出世不乐寂静不乐梵行不乐诸善法。是名五不乐

何谓五憎恶。不亲自亲不应呵横呵数到白衣家常喜多语好行乞求。是名五憎恶

何谓五嗔恚本法。作碍触恼嗔恚诤讼专执是名五嗔恚本法

何谓五忧本法。忧悲苦恼众苦。是名五忧本法

何谓五嫉妒。舍宅嫉妒豪族嫉妒利养嫉妒名闻嫉妒是名五嫉妒

何谓五缘睡眠。欠呿[夢-夕+登]懵不乐身重心沉没。是名五缘睡眠

何谓犯戒五过患。自招衰损他为呵责恶名流布死时有悔后堕恶道。是名犯戒五过患。何谓复有犯戒五过患。缘犯戒故。未得财物。不得已得财物欺夺。若至刹利众婆罗门众居士众沙门众中。心怀恐惧。为沙门婆罗门。远称过恶。身坏命终。便堕恶道。是名犯戒五过患

何谓五不敬顺。不敬顺父母沙门婆罗门尊长不敬顺(五法竟)

何谓六依贪喜。眼识色爱喜适意爱色欲染相续。现得希望。当得曾得。忆念过去变灭生喜。此谓初依贪喜。耳鼻舌身意亦如是。是名六依贪喜。何谓六依贪忧。眼识色爱喜适意爱色欲染相续。现在不得恐未来不得曾得。忆念过去变灭生忧。是名初依贪忧。耳鼻舌身意亦如是。是名六依贪忧。何谓六依贪舍。凡夫人眼见色生舍。痴如小儿不观过患。不知果报。如是不知。不分别色便舍。是名初依贪舍。耳鼻舌身意亦如是。是名六依贪舍。何谓六染。于色中染。声香味触法中染。是名六染

何谓六乐。于色中乐。声香味触法中乐。是名六乐。何谓复有六乐。乐诸业。乐语。乐睡眠。乐聚集。乐居宅。乐调戏。是名复有六乐

何谓六爱。色声香味触法中爱。是名六爱

何谓六恚。色声香味触法中恚。是名六恚

何谓六钩。色声香味触法中钩。是名六钩

何谓六不护。于色声香味触法中不护。是名六不护

何谓六诤根。如世尊说。诸比丘有六诤根。应当解解已勤修令断。何谓六。比丘嗔恚。常念怨嫌。于世尊不恭敬尊重赞叹。不以香花供养法僧亦如是。于戒缺行荒行垢行。告诸比丘。若比丘嗔恚。常念怨嫌。于众僧中。起嗔恚共诤缘诤。令多众生损减。使多众生受苦。天人衰耗。告诸比丘。如是不善诤根。观自他未断。当共和合勤精进。勇猛应断不善诤根。告诸比丘。如是不善诤根。观自他断已。自心专念。令不复生。如是便知得断不善诤根。复次比丘。若怀恨燋热。若嫉妒悭惜。若诡欺奸非。若求诸见他人诽谤。常忆不舍。若邪见边见亦如是。是名六诤根(六法竟)

何谓七共染。若女人自思惟。女身女形女相女服饰女欲女音声女璎珞。女人乐染此物。乐染此物已。思惟外男身男形男相男服饰男欲男音声男璎珞。女人乐染此物。乐染此物已。思惟和合。缘和合故生喜乐贪着。爱乐女身。乐和合已。以如是故。常不欲转女身。男子自思惟。若男身乃至常不欲转男身亦如是。是名七共染。何谓欲染。有一好种姓婆罗门。往至如来所。到已问讯。却坐一面。问世尊曰。瞿昙沙门。自是梵净行不。世尊答婆罗门。若言正梵净行者我是也。以何缘故。婆罗门我梵净行。不缺不荒不垢秽。婆罗门复问。瞿昙沙门。梵净行荒缺垢秽耶。世尊答曰。梵净行有荒缺垢秽。婆罗门复问。云何梵净行有荒缺垢秽。世尊答。或有人言。我是梵净行者。虽不与女人交通。然受女人澡浴衣服按摩调身。以为喜乐。以为气味。告婆罗门言。是谓共欲染。非清净梵行。有荒缺垢秽。未脱生老病死忧悲苦恼。众苦聚集。我谓此未脱于苦。复次婆罗门。或有人言。我是梵净行者。不与女人交通。不受女人澡浴衣服按摩调身。然亲近女人言说戏笑调弄。以为喜乐。以为气味。告婆罗门言。是谓共欲染非清净梵行。有荒缺垢秽。未脱于生老病死忧悲苦恼。众苦聚集。我谓此未脱于苦。复次婆罗门。或有人言。我是梵净行者。不与女人交通。不受女人澡浴衣服按摩调身。不亲近女人言说戏笑调弄。然与女人。对目相视以为喜乐。以为气味。告婆罗门言。是谓共欲染。非清净梵行者。有荒缺垢秽。未脱于生老病死忧悲苦恼。众苦聚集。我谓此未脱于苦。复次婆罗门。或有人言。我是梵净行者。不与女人交通。不受女人澡浴衣服按摩调身。不亲近女人言说戏笑调弄。不与女人对目相视。然障外闻女人音声歌舞语笑啼哭。以为喜乐。以为气味。告婆罗门言。是谓共欲染。非清净梵行。有荒缺垢秽。未脱于生老病死忧悲苦恼。众苦聚集。我谓此未脱于苦。复次婆罗门。或有人言。我是梵净行者。不与女人交通。不受女人澡浴衣服按摩调身。不亲近女人言说戏笑调弄。不与女人对目相视。不于障外闻女人音声歌舞语笑啼哭。然忆念女人曾共从事戏笑言语相娱乐时。以为喜乐。以为气味。告婆罗门言。是名共欲染。非清净梵行者。有荒缺垢秽。未脱于生老病死忧悲苦恼。众苦聚集我。谓此未脱于苦。复次婆罗门。或有人言。我是梵净行者。不与女人交通。不受女人澡浴衣服按摩调身。不亲近女人言说戏笑调弄。不与女人对目相视。不于障外闻音声歌舞语笑啼哭。不忆念女人曾共从事戏笑言语相娱乐时。然见长者或长者子以五欲具足相娱乐时。以为喜乐。以为气味。告婆罗门言。是名共欲染。非梵净行者。有荒缺垢秽。未脱于生老病死忧悲苦恼。众苦聚集。我谓此未脱于苦。复次婆罗门。或有人言。我是梵净行者。不与女人交通。不受女人澡浴衣服按摩调身。亦不亲近女人言说戏笑调弄。不与女人对目相亲。不于障外闻女人音声歌舞啼哭。不忆念女人曾共从事戏笑言语相娱乐时。不见长者及长者子以五欲具足相娱乐时。然愿生天上故。行梵净行。我以此戒。以此道。以此苦梵净行。令我作天王。或作辅臣。以为喜乐。以为气味。告婆罗门言。是谓共欲染。非清净梵行者。有荒缺垢秽。未脱生老病死忧悲苦恼。众苦聚集。我谓此未脱于苦。复次婆罗门。此七共欲染。我观于内心。设当七共欲染未断我亦不自说有正梵净行婆罗门。以我七共欲染断故。说有正梵净行得无所畏。是名七共欲染

何谓七识住处或有众生若干身若干想欲界人或天。此谓初识住处。若有众生若干身一想。若初生梵天。是名第二识住处。若有众生一身若干想光音天。是名第三识住处。或有众生一身一想遍净天。是名第四识住处。若有众生无边空处。此名第五识住处。若有众生无边识处。此谓第六识住处。若有众生无所有处。此谓第七识住处。是名七识住处。何谓七慢慢。不如慢。胜慢。增上慢。我慢。邪慢。慢中慢。何谓慢。若我胜心。于彼贡高。是名慢。何谓不如慢。彼不如我心于彼贡高。是名不如慢。何谓胜慢。我与胜者等心于彼贡高是名胜慢。何谓增上慢。未得起得想心于彼贡高。是名增上慢。何谓我慢。我有善法心于彼贡高。是名我慢。何谓邪慢。若无善法心于彼贡高。是名邪慢。何谓慢中慢。若见他慢生慢心于彼贡高。是名慢中慢。复次我慢。若有身者。心于彼生贡高。是名我慢。复次邪慢。若有邪见者。心于彼生贡高。是名邪慢。复次慢中慢。我于胜中胜贵中贵心于彼生贡高。是名慢中慢。是名七慢

何谓七不敬。若不恭敬佛。不恭敬法。不恭敬僧。不恭敬戒。不恭敬定。不恭敬慧。不恭敬善法。是名七不敬

何谓七漏。见断漏。忍辱断漏。亲近断漏。离断漏。调伏断漏。戒断漏。思惟断漏。是名七漏

何谓七怯弱法。杀生窃盗邪淫妄语两舌恶口绮语。是名七怯弱法

何谓七动。我当有。我当无。我色当有。我色当无。我想当有。我想当无。我非有想非无想当有。是名七动。七自恃七求七撗七作七生亦如是(七法竟)

何谓世间八法。利衰毁誉称讥苦乐。是名世八法

何谓八非圣语。若不见言见。见言不见。不闻言闻。闻言不闻。不觉言觉。觉言不觉。不识言识。识言不识。是名八非圣语

何谓八懈怠事。若有懈怠比丘。如是思惟。我今日入聚落乞食已。我得粗细食不充足。以不足故。令我羸瘦。不乐经行坐禅。我欲眠卧。懈怠比丘。即便眠卧。不能勤进。为未得欲得未解欲解未证欲证。是名初懈怠事。复次比丘如是思惟。我今日入聚落中乞食。得粗细食充足身体重妨。如肉囊盛钱。不乐经行坐禅。我欲眠卧。懈怠比丘。即便眠卧。不能勤进。为未得欲得未解欲解未证欲证。此谓第二懈怠事。复次懈怠比丘。如是思惟。我今日有作务疲懈。不乐经行坐禅。我欲眠卧。懈怠比丘。即便眠卧。不能勤进。为未得欲得未解欲解未证欲证。此谓第三懈怠事。复次懈怠比丘。如是思惟。我明日当作务身当疲懈。便不乐经行坐禅。我今豫眠卧懈怠比丘。即便眠卧。不能勤进。为未得欲得未解欲解未证欲证。此谓第四懈怠事。复次懈怠比丘。如是思惟。我今日行来。身体疲极。不乐经行坐禅。我欲眠卧。懈怠比丘。即便眠卧。不能勤进。为未得欲得未解欲解未证欲证。此谓第五懈怠事。复次懈怠比丘。如是思惟。我明日当行身必疲极。便不乐经行坐禅。我欲眠卧。懈怠比丘。即便眠卧。不能勤进。为未得欲得未解欲解未证欲证。此谓第六懈怠事。复次懈怠比丘。如是思惟。我今患苦。不乐经行坐禅。我欲眠卧。懈怠比丘即便眠卧。不能勤进。为未得欲得未解欲解未证欲证。此谓第七懈怠事。复次懈怠比丘。如是思惟。我患差未久。我身羸弱。不乐经行坐禅。我欲眠卧。懈怠比丘。即便眠卧。不能勤进。为未得欲得未解欲解未证欲证。是名八懈怠事。何谓八难处妨修梵行。有佛出世。如来无所著等正觉明行足为善逝世间解无上士调御丈夫天人师佛世尊。说寂静灭尽离欲法正趣至涅槃道。或有众生在地狱处。是名初难处妨修梵行。复次佛出世如来无所著乃至佛世尊。说寂静灭尽离欲法正趣至涅槃道。或有众生。在畜生处饿鬼处长寿天处。若边地愚痴人。若比丘比丘尼优婆塞优婆夷所不至处。是名乃至第五难处妨修梵行。复次佛出世如来无所著乃至佛世尊。说寂静离欲法正趣至涅槃道。或有众生共生国中。然邪见倒见。邪见倒见果报纯熟故。毕生地狱。是名第六难处妨修梵行。复次佛出世如来无所著乃至佛世尊。说寂静灭尽离欲法正趣至涅槃道。或有众生共生国中。然聋盲喑哑。如羊手现语相。不知说善恶业报。是名第七难处妨修梵行。复次佛不出世。不名如来乃至佛世尊。不说寂静灭尽离欲法正趣至涅槃道。或有众生在国中。不聋盲喑哑。亦能分别善恶业报。然不值佛世。是名八难处妨修梵行(八法竟)

何谓九若干法。缘若干界故生若干触。缘若干触故生若干受。缘若干受故生若干想。缘若干想故生若干觉。缘若干觉故生若干欲。缘若干欲故生若干利养。缘若干利养故生若干求。缘若干求故生若干燋热。是名九若干法

何谓九爱本法。缘爱故生求。缘求故生利养。缘利养故生所作。缘所作故生欲染。缘欲染故生堪忍。缘堪忍故生悭惜。缘悭惜故生积聚。缘积聚故。生爱护伤害捶打相系闭共斗诤。是名九爱本法

何谓九众生居。或有众生。若干身若干想欲界人天。此谓初众生居。或有众生。若干身一想。谓初生梵天。此谓第二众生居处。或有众生。一身若干想。谓光音天。此谓第三众生居处。或有众生。一身一想。谓遍净天。此谓第四众生居处。或有众生。无受无想。谓无想天。此谓第五众生居处。或有众生。无边空处。此谓第六众生居处。或有众生。无边识处。此谓第七众生居处。或有众生。无所有处。此谓第八众生居处。或有众生。非想非非想处。是名第九众生居

何谓犯戒九过患。悔不悦不喜不除心苦散乱不如实知见不解射不方便。是名犯戒九过患(九法竟)

舍利弗阿毗昙论卷第十九舍利弗阿毗昙论卷第二十

        姚秦罽宾三藏昙摩耶舍共昙摩崛多等译

    非问分烦恼品第十一之三

何谓十烦恼使。见烦恼使。疑烦恼使。戒道烦恼使。爱烦恼使。嗔恚烦恼使。嫉妒烦恼使。悭惜烦恼使。无明烦恼使。憍慢烦恼使。掉烦恼使。是名十烦恼使

何谓十烦恼结。见烦恼结。疑烦恼结。戒盗烦恼结。欲染烦恼结。嗔恚烦恼结。色染烦恼结。无色染烦恼结。无明烦恼结。慢烦恼结。掉烦恼结。是名十烦恼结

何谓十想。欲想。嗔恚想。害想。贪想。讥论想。此内外想。国土想。卑想。不善想。若干想。依贪想。是名十想

何谓十觉。嗔恚觉。害觉。亲里觉。国土觉。不死觉。他不觉。识相应觉。无慈相应觉。依利养觉。依贪觉。是名十觉。何谓十邪法。邪见。邪觉。邪语。邪业。邪命。邪进。邪定。邪慧。邪解脱。邪智。是名十邪法

何谓十恼。若已侵生恼心。今侵生恼心。当欲侵生恼心。若我不爱喜适意者。已利益生恼心。今利益生恼心。当欲利益生恼心。横嗔生恼心。是名十恼。何谓十不善业道。杀生窃盗邪淫妄言恶口两舌绮语贪恚邪见。是名十不善业道。何谓十法成就堕地狱速如[矛*(替-曰+貝)]鉾。杀生乃至邪见。此十法成就堕地狱速如[矛*(替-曰+貝)]鉾(十法竟)

何谓十一心垢。疑是心垢。不思惟是心垢。怖是心垢。悲是心垢。恶是心垢。睡眠是心垢。过精进是心垢。软精进是心垢。无能是心垢。若干想是心垢。着色是心垢。何谓疑是心垢。或有人缘过去疑。或我过去有。我过去非有。何姓我过去有。何因我过去有。若缘未来疑惑。我未来有。我未来非有。何姓我未来有。何因我未来有。若缘现在疑惑。我现在有。我现在非有。何姓现在有。何因现在有。诸众生从何处来。去至何处。若缘现在疑惑。我现在有。我现在非有。何姓现在有。何因现在有。诸众生从何处来。去至何处。若彼于佛世尊疑惑。是佛世尊非佛。世尊善说法。世尊非善说法。世尊声闻众善趣。世尊声闻众非善趣行。常行非常行。苦行非苦。无我法非无我法。寂灭涅槃。非寂灭涅槃。有与无与。有施无施。有祀无祀。有善恶业果报。无善恶业果报。有今世无今世。有后世无后世。有父母无父母。有天无天。众生有化生。众生非化生。世有沙门婆罗门正趣正至。若今世后世自证知说。世无沙门婆罗门正趣正至。若今世后世自证知说。若于彼法。疑惑重疑惑。究竟疑惑。心不决定。犹豫二心疑。不了无量疑。不尽非解脱。犹豫重犹豫。究竟犹豫。是名疑是心垢。何谓不思惟是心垢。若色声香味触法。若众生及法。不正计校分别筹量忆念。是名不思惟是心垢。何谓怖是心垢。色声香味触法。若众生及法。缘此畏怖究竟。畏怖惊愕。毛竖色变。是名怖是心垢。何谓悲是心垢。若不善心起悲。是名悲是心垢。何谓恶是心垢。身口意恶。是名恶是心垢。何谓睡眠是心垢。若烦恼未断。沉没在睡。身不乐。身不调。身不轻。身不软。身不除。是名睡。若睡若烦恼未断。沉没在睡。若欲睡瞪瞢眠镇心。是名眠。如是睡眠。是名睡眠是心垢。何谓过精进是心垢。若精进掉。是名过精进是心垢。何谓软精进是心垢。若精进没。是名软精进是心垢。何谓无能是心垢。若心怯弱。是名无能是心垢。何谓若干想是心垢。若众生异事异境界异初生异。是名若干想是心垢。何谓着色是心垢。若见色专著。是名著色是心垢。是名十一心垢

何谓二十种身见。或有人谓。色是我。色中有我。我是色有。色是我有。受想行识亦如是。是名二十种身见

何谓二十法成就堕地狱速如[矛*(替-曰+貝)]鉾。自杀生教他杀生。乃至自邪见教他邪见此二十法成就堕地狱速如[矛*(替-曰+貝)]鉾

何谓二十一心垢。希望是心垢。嗔恚睡眠掉悔疑恼害常念怨嫌怀恨燋热嫉妒悭惜诡诈奸欺无惭无愧矜高诤讼自高放逸慢增上慢。是名二十一心垢

何谓三十法成就堕地狱速如[矛*(替-曰+貝)]鉾。自杀生教他杀生赞叹杀生。乃至自邪见教他邪见赞叹邪见。是名三十法成就堕地狱速如[矛*(替-曰+貝)]鉾

何谓三十六爱行。内生十八爱行。外生十八爱行。何谓内生十八爱行。如世尊说。因此有此。因彼而有。如是因有异因有。当因有不当因有。我当有彼我当有。如是我当有异我当有。因得彼得。如是得异得。悕望当有。悕望彼当有。悕望如是当有。悕望异当有。是名内生十八爱行

何谓外生十八爱行。如世尊说。是因此有此。是因彼而有。是如是因有。是异因有。是当因有。是不当因有。是我当有。是彼我当有。是如是我当有。是异我当有。是因得是如得。是如是得是异得。是希望当有。是希望彼当有。是希望如是当有。是希望异当有。是名外生十八爱行。如是内生十八爱行。如是外生十八爱行。是名三十六爱行

何谓四十法成就堕地狱速如[矛*(替-曰+貝)]鉾。自杀生教他杀生。赞叹杀生。见他杀随其欢喜。乃至自邪见。教他邪见。赞叹邪见。见他邪见随其欢喜。是名四十法成就堕地狱速如[矛*(替-曰+貝)]鉾

何谓六十二见。如梵网经说。佛告诸比丘。更有余法。甚深微妙大法光明。唯有贤圣弟子。能以此法赞叹如来。何等是甚深微妙大法光明。贤圣弟子。能以此法赞叹如来。诸沙门婆罗门。于本劫本见末劫末见种种无数随意所说。尽入六十二见。本劫本见末劫末见种种无数随意所说。尽不能出过六十二见。彼沙门婆罗门。以何等缘。于本劫本见末劫末见种种无数各随意说。尽入此六十二见。无有能过。诸沙门婆罗门。于本劫本见种种无数各随意说。尽入十八见中。本劫本见种种无数各随意说。尽皆不能过十八见中。诸沙门婆罗门。以何等缘。于本劫本见种种无数各随意说。尽入十八见中无有能过。诸沙门婆罗门。于本劫本见。起常论言。我及世间常存。此尽入四见中。于本劫本见言。我及世间常存。尽入四见中无有能过。诸沙门婆罗门。以何等缘。于本劫本见。起常论言。我及世间常存。此尽入四见中无有能过。或有沙门婆罗门。种种方便入定意三昧。以三昧心。忆二十成劫败劫。彼作是说。我及世间是常。此实余虚妄。所以者何。我以种种方便。入定意三昧以三昧心。忆二十成劫败劫。其中众生。不增不减。常聚不散我以此知我及世间是常。此实余虚妄。此是初见。诸沙门婆罗门。因此于本劫本见计我及世间是常。于四见中。无有能过。或有沙门婆罗门。种种方便入定意三昧。以三昧心。忆四十成劫败劫。彼作是说。我及世间是常。此实余虚妄。所以者何。我以种种方便入定意三昧。以三昧心。忆四十成劫败劫。其中众生。不增不减。常聚不散。我以此知我及世间是常。此实余虚妄。此是二见。诸沙门婆罗门。因此于本劫本见。计我及世间是常。于四见中无有能过。或有沙门婆罗门。以种种方便。入定意三昧。以三昧心。忆八十成劫败劫。彼作是言。我及世间是常。此实余虚妄。所以者何。我以种种方便。入定意三昧。以三昧心。忆八十成劫败劫。其中众生。不增不减。常聚不散。我以此智。我及世间是常。此实余虚妄。此是三见。诸沙门婆罗门。因此于本劫本见。计我及世间是常。于四见中无有能过。或有沙门婆罗门。有捷疾相智。善能观察。以捷疾相智方便观察。谓为审谛。以己所见。以己辩才。作是说言。我及世间是常。此实余虚妄。此是四见。诸沙门婆罗门。因此于本劫本见。计我及世间是常。于四见中无有能过。此沙门婆罗门。于本劫本见。计我及世间是常。如是一切尽入四见中。我及世间是常。于此四见中无有能过。唯有如来。知是见处。如是持。如是执。亦知报应。如来所知。又复过是。虽知不着。以不着则得寂灭。知爱集灭味过出要。以平等观无余解脱故名如来。是名余甚深微妙大法光明。使贤圣弟子。真实平等赞叹如来

复有余甚深微妙大法光明。使贤圣弟子。真实平等赞叹如来。何等法是。诸沙门婆罗门。于本劫本见起论言。我及世间。亦常亦无常。诸沙门婆罗门。因此于本劫本见。计我及世间。半常半无常。于四见中无有能过。或有是时。此劫始成。有余众生。福尽命尽行尽。从光音命终。生空梵宫中。便于彼处。生爱着心。复愿余众生共生此处。此众生。既生爱着愿已。复有余众生。命行福尽。于光音命终。来生此空梵宫中。其先生众生。便作是念我于此处。是梵大梵。我自然有。无能造我者。我尽知诸义。典千世界。于中自在最为尊贵。能为变化微妙第一。为众生父。我独先有。余众生后来。后来众生我所化成。其后众生。复作是念。彼是大梵。彼能自造无造彼者。尽知诸义。典千世界。于中自在最为尊贵。能为变化微妙第一。为众生父母。彼独先有。后有我等。我等众生彼所化成。彼梵众生。命行尽已来生此间。渐已长大。剃除须发。出家被法服。修梵志行。入定意三昧。随三昧心自识本生。便作是言。彼大梵者。能自造作无造彼者。尽知诸义。典千世界。于中自在最为尊贵。能为变化微妙第一。为众生父。常住不变。而彼梵化作我等。我等无常变易。不得久住。是故当知。我及世间。亦常亦无常。此实余虚妄。是谓初见。诸沙门婆罗门。因本劫本见起论。亦常亦无常。于此四见中。无有能过。或有众生。喜戏笑懈怠。数数戏笑。以自娱乐戏笑。娱乐时身体疲极。便自失意。以失意故。便命终来生此间。渐已长大。剃除须发。出家被法服。修梵志行。入定意三昧。以三昧力自识本生。便作是言。彼余众生不数数戏笑娱乐。常在彼处。常住不变。由我数数戏笑故。致此无常变易法。是故知我及世间亦常亦无常。此实余虚妄。是名第二见。诸沙门婆罗门。因本劫本见起论。我及世间。亦常亦无常。于此四见中。无有能过。或有众生。展转相视。相视已便自失意。由此命终来生此间。渐已长大。剃除须发。出家被法服。修梵志行入定意三昧。以三昧力识本所生。便作是言。如彼众生。以不展转相视。不失意故。常住不变。由我等数数相视故便失意致此无常变易法我以是知我及世间。亦常亦无常。此实余虚妄。是名第三见。诸沙门婆罗门。因本劫本见起论。我及世间。亦常亦无常。于此四见中无有能过。或有沙门婆罗门。捷疾相智。善能观察。以捷疾相智。观察已言。我及世间。亦常亦无常。此实余虚妄。是名第四见。诸沙门婆罗门。因本劫本见起论。我及世间。亦常亦无常。于此四见中无有能过。诸沙门婆罗门。于本劫本见起论。我及世间。亦常亦无常。尽入四见中无有能过。唯佛能知此见处。如是持如是执。亦知报应。如来所知。复过于是。虽知不着。以不着则得寂灭。知爱集灭味过出要。以平等观无余解脱故名如来。是名余甚深微妙大法光明。使贤圣弟子。赞叹如来

复有余甚深微妙大法光明。使贤圣弟子。真实平等赞叹如来。何等是法。诸沙门婆罗门。于本劫本见起论。我及世间。有边无边。诸沙门婆罗门。因本劫本见起论。我及世间有边无边。于此四见中无有能过。或有沙门婆罗门。种种方便入定意三昧。以三昧力。观世间起边想。彼作是说。此世间有边。是实余虚妄。所以者何。我以种种方便入定意三昧。以三昧力。观世间有边。是故知世间有边。此实余虚妄是名初见。诸沙门婆罗门。因本劫本见起论。我及世间有边。于四见中无有能过。或有沙门婆罗门。种种方便入定意三昧。以三昧力。观世间起无边想。彼作是言。世间无边。此实余虚妄。所以者何。我以种种方便入定意三昧。以三昧力。观世间无边。是故知世间无边。此实余虚妄。是名第二见。诸沙门婆罗门。因本劫本见起论。我及世间无边。于此四见中无有能过。或有沙门婆罗门。种种方便入定意三昧。以三昧力观世间。观上方有边。四方无边。彼作是言。世间有边无边。此实余虚妄。所以者何。我以种种方便入定意三昧。以三昧力。观上方有边四方无边。是故我知世间有边无边。此实余虚妄。是名第三见。诸沙门婆罗门。因本劫本见起论。我及世间。有边无边。于此四见中无有能过。或有沙门婆罗门。有捷疾相智。善能观察。彼以捷疾相智观察已言。我及世间。非有边非无边。此实余虚妄。是名第四见。诸沙门婆罗门。因本劫本见起论。我及世间。非有边非无边。此实余虚妄。于此四见中无有能过。诸沙门婆罗门。于本劫本见起论。我及世间。有边无边。尽入四见中无有能过。唯佛能知此见处。如是持如是执。亦知报应。如来所知。又复过是。虽知不着以不着则得寂灭。知爱集灭味过出要。以平等观无余解脱故名如来

复有余甚深微妙大法光明。使贤圣弟子。真实平等赞叹如来。何等是余甚深微妙大法光明。使贤圣弟子。真实平等赞叹如来。诸沙门婆罗门。于本劫本见异问异答。诸沙门婆罗门。因本劫本见。异问异答。于此四见中无有能过。或有沙门婆罗门。作如是论作如是见。我不知有善恶业报耶。无善恶业报耶。我不见不知故。若言有善恶业报。若言无善恶业报者。世有沙门婆罗门。广博多闻。聪明智慧。常乐闲静。机辩精微。世所尊重。能以智慧。善分别诸见。设当问我诸见深妙义者。我不能答。则有惭愧。我心怀恐怖。当以是答。以为归依为洲为舍为究竟道。若彼问者。当以是答。此事如是非也。此事实非也。此事异非也。此事非异非。不异非也。是名初见。诸沙门婆罗门。因此问异答异。于此四见中。无有能过。或有沙门婆罗门。作如是论作如是见。我不见不知。为有他世耶无他世耶。世间有诸沙门婆罗门。以天眼及他心智。在远处能见我。我若近。犹不能见。如是人。能知有他世无他世。我不知不见有他世无他世。若我说者。则为妄语我畏妄语故。以为归依。为洲为舍为究竟道。彼设问者。当以是答。此事如是非也。此事实非也。此事异非也。此事非异非。不异非也。是名第二见诸沙门。婆罗门因此问异答异。于此四见中。无有能过。或有沙门婆罗门。作如是见作如是论。我不知不见。何者善何者不善。我不知不见故。若言是善是不善。我则生爱。从爱生恚。有爱有恚。则有受生我欲灭受恶畏受故。以为归依。以为洲为舍为究竟道。彼设问者。当以是答。此事如是非也。此事实非也。此事异非也。此事非异非。不异非也。是名第三见。诸沙门婆罗门。因此问异答异。于此四见中。无有能过。或有沙门婆罗门。愚冥闇钝。愚冥闇钝故。他有问者。便随他言答。此事如是非也。此事实非也。此事异非也。此事非异非。不异非也。是名四见。诸沙门婆罗门。因此异问异答。于此四见中。无有能过。诸有沙门婆罗门。于本劫本见。异问异答。尽入四见中。无有能过。唯佛能知此见处。如是持如是执。亦知报应。如来所知。复过于是。虽知不着。以不着则得寂灭。知受集灭味过出要。以平等观无余解脱故名如来。是为甚深微妙大法光明。使贤圣弟子真实平等赞叹如来

复有余甚深微妙大法光明。使贤圣弟子真实平等赞叹如来。何等是余甚深微妙大法光明。使贤圣弟子真实平等赞叹如来。诸沙门婆罗门。于本劫本见。谓无因而有此世间。彼尽入二见中。诸沙门婆罗门。因本劫本见。无因而有此世间。于此二见中。无有能过。彼诸沙门婆罗门。以何因缘。于本劫本见。谓无因而有。于此二见中。无有能过。或有众生。无想无受。若彼众生起想。则便命终。来生世间。渐以长大。剃除须发。出家被法服。修梵志行。入定意三昧。以三昧力。见本想生。便作是念。我本无有想。自然有此。是无因而有。世间此实余虚妄。是名初见。诸沙门婆罗门。因本劫本见。谓无因而有。于此二见中。无有能过。或有沙门婆罗门。有捷疾相智。善能观察。彼以捷疾相智观察已。如是说。此世间无因而有。此实余虚妄。是名第二见。诸沙门婆罗门。因本劫本见。无因而有。此世间于此二见中。无有能过。诸沙门婆罗门。于本劫本见。无因而有。尽入二见中。无有能过。唯佛能知此见处。乃至无余解脱故名如来。亦如上所说。诸沙门婆罗门。于本劫本见中。无数种种随意所说。彼尽入十八见中。诸沙门婆罗门。因本劫本见。无数种种随意所说。于此十八见。无有能过。唯佛能知此见处。乃至无余解脱故名如来。亦如上所说

复有余甚深微妙大法光明。唯有贤圣弟子。能以此法赞叹如来。何等是甚深微妙大法光明。贤圣弟子。能以此法赞叹如来。诸沙门婆罗门。于末劫末见。无数种种随意所说。彼尽入四十四见中。末劫末见。种种无数随意所说。于四十四见。无有能过。诸沙门婆罗门。以何因缘。于末劫末见。种种无数随意所说。于四十四见。无有能过。诸有沙门婆罗门于末劫末见。有想论。谓想是我是世。尽入十六见中。于末劫末见。有想论。谓想是我是世。于十六见中。无有能过。诸沙门婆罗门。以何因缘。于末劫末见。有想论。谓想是我是世。尽入十六见中。无有能过。或有沙门婆罗门。作如是论。色是我想是世。命终已我不复有。此实余虚妄。是名初见。诸沙门婆罗门。因末劫末见。有想论。谓想是我是世。于十六见中。无有能过。复有言。非色是我想是世。命终已我不复有。此实余虚妄。是名二见。复有言。有色无色是我想是世。命终已我不复有。此实余虚妄。是名三见。复有言。非有色非无色是我想是世。命终已我不复有。此实余虚妄。是名四见。复有言。我是有边想是世。命终已我不复有。此实余虚妄。是名五见。复有言。我是无边想是世。命终已我不复有。此实余虚妄。是名六见。复有言。我有边无边想是世。命终已我不复有。此实余虚妄。是名七见。复有言。我非有边非无边想是世。命终已我不复有。此实余虚妄。是名八见。复有言。我一向乐想是世。命终已我不复有。此实余虚妄。是名九见。复有言。我一向苦想是世。命终已我不复有。此实余虚妄。是名十见。复有言。苦乐是我想是世。命终已我不复有。此实余虚妄。是名十一见。复有言。不苦不乐。是我想是世。命终已我不复有。此实余虚妄。是名十二见。复有言。一想是我想是世。命终已我不复有。此实余虚妄。是名十三见。复有言。若干想是我想是世。命终已我不复有。此实余虚妄。是名十四见。复有言。少想是我想是世。命终已我不复有。此实余虚妄。是名十五见。复有言。无量想是我想是世。命终已我不复有。此实余虚妄。是名十六见。诸沙门婆罗门。于末劫末见。有想论。谓是我想是世。于此十六见中。无有能过。唯佛能知此见处。乃至无余解脱故名如来。亦如上所说。复有余甚深微妙大法光明。唯有贤圣弟子。能以此法赞叹如来。何等是甚深微妙大法光明。贤圣弟子。能以此法赞叹如来。诸沙门婆罗门。于末劫末见。有无想论。谓无想是我是世。彼尽入八见中。于末劫末见。有无想论。谓无想是我是世。彼尽入八见中。无有能过。或有沙门婆罗门。作如是论。色是我无想是世。命终已我不复有。此实余虚妄。是名初见。诸沙门婆罗门。因末劫末见。有无想论。谓无想是我是世。于此八见中。无有能过。复有言。非色是我无想是世。命终已我不复有。此实余虚妄。是名二见。复有言。有色无色。是我无想是世。命终已我不复有。此实余虚妄。是名三见。复有言。非有色非无色。是我无想是世。命终已我不复有。此实余虚妄。是名四见。复有言。我是有边无想是世。命终已我不复有。此实余虚妄。是名五见。复有言。我非是有边无想是世。命终已我不复有。此实余虚妄。是名六见。复有言。我有边无边无想是世。命终已我不复有。此实余虚妄。是名七见。复有言。我非有边非无边无想是世。命终已我不复有。此实余虚妄。是名八见。诸沙门婆罗门。因末劫末见。有无想论。谓无想是我是世。彼尽入八见中。唯佛能知此见处。乃至无余解脱故名如来。亦如上所说

复有余甚深微妙大法光明。唯有贤圣弟子。能以此法赞叹如来。何等是甚深微妙大法光明贤圣弟子。能以此法赞叹如来。诸沙门婆罗门。因末劫末见。有非想非无想论。谓非想非无想是我是世。彼尽入八见中。因末劫末见。有非想非无想论。谓非想非无想是我是世。彼尽入八见中。无有能过。或有沙门婆罗门。作如是论。色是我非想非无想是世。命终已我不复有。此实余虚妄。是名初见。诸沙门婆罗门。因末劫末见。有非想非无想论。谓非想非无想是我是世。于八见中。无有能过。复有言。非色是我非想非无想是世。命终已我不复有。此实余虚妄。是名二见。复有言。有色无色是我非想非无想是世。命终已我不复有。此实余虚妄。是名三见。复有言。非有色非无色。是我非想非无想是世。命终已我不复有。此实余虚妄。是名四见。复有言。我是有边非想非无想是世。命终已我不复有。此实余虚妄。是名五见。复有言。我非是有边非想非无想是世。命终已我不复有。此实余虚妄。是名六见。复有言。我有边无边非想非无想是世。命终已我不复有。此实余虚妄。是名七见。复有言。我非有边非无边非想非无想是世。命终已我不复有。此实余虚妄。是名八见。诸沙门婆罗门。因末劫末见。有非想非无想论。谓非想非无想是我是世。彼尽入八见中。无有能过。唯佛能知此见处。乃至无余解脱故名如来。亦如上所说

复有余甚深微妙大法光明。唯有贤圣弟子。能以此法赞叹如来。何等是甚深微妙大法光明贤圣弟子。能以此法赞叹如来。诸沙门婆罗门。因末劫末见。有断灭论说。众生断灭无余。彼尽入七见中。因末劫末见。有断灭论说众生尽无余。于七见中。无有能过。诸沙门婆罗门。以何因缘。于末劫末见。有断灭论说众生断灭无余。于七见中。无有能过。或有沙门婆罗门。作如是论作如是见。我身四大入。从父母生乳哺衣食长养摩扪拥护。然是无常必归磨灭。齐是我断灭。是名初见。诸沙门婆罗门。因末劫末见。有断灭论说众生断灭。于七见中。无有能过。或有沙门婆罗门。作是论。此不得名断灭。我欲界天断灭无余齐是我断灭。是名二见。复有沙门婆罗门。作是论。此不名断灭。色界化身诸根具足断灭。齐是谓我断灭无余。是名三见。复有言。此不名断灭无色空处断灭。齐是谓我断灭无余。是名四见。复有言。此不名断灭无色识处断灭。齐是谓我断灭无余。是名五见。复有言。此不名断灭无色不用处断灭。齐是谓我断灭无余。是名六见。复有言。此不名断灭。无色非有想非无想处断灭。齐是谓我断灭无余。是名七见。诸沙门婆罗门。因此于末劫末见。言此众生类断灭无余。于此七见中。无有能过。唯佛能知此见处。乃至无余解脱故名如来。亦如上说

复有余甚深微妙大法光明。唯有贤圣弟子。能以此法赞叹如来。何等是甚深微妙大法光明。贤圣弟子。能以此法赞叹如来。诸沙门婆罗门。因末劫末见。现在有泥洹。论说众生现在有泥洹。彼尽入五见中。因末劫末见。说现在有泥洹。于五见中。无有能过。诸沙门婆罗门。何因缘于末劫末见。说众生现在有泥洹。于五见中。无有能过。或有沙门婆罗门。作是见作是论。我尽现在五欲自恣。齐是我得现在涅槃。是名初见。诸沙门婆罗门。因末劫末见。谓我现世得涅槃。谓众生现在有涅槃论。于五见中。无有能过。复有诸沙门婆罗门。作是说。此不名现在涅槃。复有现在涅槃。微妙第一。汝所不知。独我能知。如离欲恶不善法。有觉有观离生喜乐成就初禅行。齐是谓我得现在涅槃。是名二见。复有沙门婆罗门。作如是说。此不名现在涅槃。复有现在涅槃。微妙第一汝所不知。独我能知。如灭有觉观。内净信一心。无觉无观。定生喜乐。成就二禅行。齐是谓我现在得涅槃。是名三见。复有沙门婆罗门。作是说。此不名现在涅槃。复有现在涅槃微妙第一汝所不知。独我能知。如离喜舍行念正智身受乐。如诸圣人解舍念乐行。成就三禅行。齐是现在得涅槃。是名四见。复有沙门婆罗门。作是说。此不名现在涅槃。复有现在涅槃微妙第一。汝所不知。独我能知。如能断乐断苦先灭忧喜。不苦不乐。舍念清净。成就四禅行。齐是谓我现在得涅槃。是名五见。诸沙门婆罗门。因末劫末见。有现在涅槃论。于此五见中。无有能过。唯佛能知此见处。乃至无余解脱故名如来。亦如上说。是诸沙门婆罗门。因末劫末见。种种起见随意所说。于此四十四见中。无有能过。唯佛能知此见处。乃至无余解脱故名如来。亦如上说。诸沙门婆罗门。因本劫本见末劫末见种种起见随意所说。尽入此六十二见中。因本劫本见末劫末见种种起见随意所说。于六十二见中。无有能过。唯佛能知此见处。乃至无余解脱故名如来。亦如上说。诸沙门婆罗门。因于本劫本见有常论说我世间是常。诸沙门婆罗门于此生智。谓异信异欲异闻异缘异觉异见异定异忍。因此生智。彼以布施。则得名受。乃至现在涅槃。亦复如是。诸沙门婆罗门。生常论世间是常彼因受缘受生爱。而不自觉知染着。于爱为爱所伏。乃至现在涅槃。亦复如是。诸沙门婆罗门。因本劫本见。言世间是常。彼缘触故。若离触缘。而立论者。无有是处。乃至现在涅槃。亦复如是诸沙门婆罗门。因本劫本见末劫末见。各随意所见说。尽入六十二见中。各随所见说。尽依在中。无有能过。如捕鱼师。以细网覆小池上。当知池中水性之类。皆入网内。无有避处。诸沙门婆罗门亦如是。因本劫本见末劫末见种种所说。尽入六十二见中。无有能过。是名六十二见。此是烦恼结使。系缚众生。取于生老病死忧悲苦恼众苦。聚集法不得解脱(非问分竟)

舍利弗阿毗昙论卷第二十舍利弗阿毗昙论卷第二十一

        姚秦罽宾三藏昙摩耶舍共昙摩崛多等译

    摄相应分摄品之一

一切摄非摄法。当知若立摄门便知。阴界入摄一切法。阴界入不摄一切法。阴界入如事摄一切法少分。阴界入不摄一切法少分。自性自性摄。自性非他性摄自性系于自性。自性非他性系。亦摄非摄亦非摄非不摄

摄门者。谓苦谛系法。非苦谛系法乃至道谛系法。非道谛系法。诸圣谛系法。非诸圣谛系法。根法非根法。苦谛系根法。非苦谛系根法。乃至道谛系根法。非道谛系根法。诸圣谛系根法。非诸圣谛系根法。苦谛系非根法。非苦谛系非根法。乃至道谛系非根法。非道谛系非根法。诸圣谛系非根法。非诸圣谛系非根法。眼入法。非眼入法。乃至意入法。非意入法。色入法。非色入法。乃至法入法。非法入法。受法非受法。想法非想法。思法非思法。触法非触法。思惟法非思惟法。觉法非觉法。观法非观法。见法非见法。慧法非慧法。解脱法非解脱法。无贪法非无贪法。无嗔法非无嗔法。无痴法非无痴法。顺信法非顺信法。悔法非悔法。无悔法非无悔法。悦法非悦法。喜法非喜法。心进法非心进法。心除法非心除法。信法非信法。欲法非欲法。不放逸法非不放逸法。念法非念法。定法非定法。心舍法非心舍法。疑法非疑法。怖法非怖法。烦恼使法非烦恼使法。见使法非见使法。疑使法非疑使法。戒道使法非戒道使法。爱使法非爱使法。嗔恚使法非嗔恚使法。嫉妒使法非嫉妒使法。悭惜使法非悭惜使法。无明使法非无明使法。憍慢使法非憍慢使法。掉使法非掉使法。生法非生法。老法非老法。死法非死法。命法非命法。烦恼法非烦恼法。无想定法非无想定法。灭尽定法非灭尽定法。得果法非得果法。戒法非戒法。无戒法非无戒法。有漏身进法非有漏身进法。有漏身除法非有漏身除法。正语法非正语法。正业法非正业法。正命法非正命法。正身进法非正身进法。正身除法非正身除法。智缘尽法非智缘尽法。非智缘尽法非非智缘尽法。决定法非决定法。法住法非法住法。缘法非缘法。空处法非空处法。乃至非想非非想法非非想非非非想法。眼界法非眼界法。乃至法界法非法界法。色阴法非色阴法。乃至识阴法非识阴法。苦圣谛法非苦圣谛法。乃至道圣谛法非道圣谛法。眼根法非眼根法。乃至已知根法非已知根法。念觉法非念觉法。乃至舍觉法非舍觉法。贪不善根法非贪不善根法。乃至痴不善根法非痴不善根法。无贪善根法非无贪善根法。乃至无痴善根法非无痴善根法。地大法非地大法。乃至风大法非风大法。不杀生戒法。非不杀生戒法。乃至不饮酒放逸处法。非不饮酒放逸处法。色法非色法。乃至过去未来现在法。非过去未来现在法

何谓苦谛系法。除爱余非圣有为法。是名苦谛系法。何谓非苦谛系法。爱及圣非圣无为法。是名非苦谛系法。何谓集谛系法。爱是名集谛系法。何谓非集谛系法。除爱若余法。是名非集谛系法。何谓灭谛系法。智缘尽。是名灭谛系法。何谓非灭谛系法。除智缘尽若余法。是名非灭谛系法。何谓道谛系法。八圣道。是名道谛系法。何谓非道谛系法。除八圣道若余法。是名非道谛系法。何谓诸圣谛系法。非圣有为法苦集灭道。是名诸圣谛系法。何谓非诸圣谛系法。除苦集灭道。若余圣法。及非圣无为。是名非诸圣谛系法。何谓根法非圣根。及圣有为法。是名根法。何谓非根法非圣非根。及圣无为法。是名非根法。何谓苦谛系根法。若根非圣。是名苦谛系根法。何谓非苦谛系根法。若根圣。是名非苦谛系根法。何谓集谛系根法。无集谛系根法也。何谓非集谛系根法。一切根。是名非集谛系根法。何谓灭谛系根法。无灭谛系根法也。何谓非灭谛系根法。一切根。是名非灭谛系根法。何谓道谛系根法。八圣道。是名道谛系根法。何谓非道谛系根法。除八圣道。若余根。是名非道谛系根法。何谓诸圣谛系根法。若非系根。及余八圣道。是名诸圣谛系根法。何谓非诸圣谛系根法。除八圣道若余圣根。是名非诸圣谛系根法。何谓苦谛系非根法。除爱若余非根法非根有为。是名苦谛系非根法。何谓非苦谛系非根法。爱及一切无为。是名非苦谛系非根法。何谓集谛系非根法。爱是名集谛系非根法。何谓非集谛系非根法。除爱若余非根。是名非集谛系非根法。何谓灭谛系非根法。智缘尽。是名灭谛系非根法。何谓非灭谛系非根法。除智缘尽若余非根。是名非灭谛系非根法。何谓道谛系非根法。无道谛系非根法也。何谓非道谛系非根法。一切非根。是名非道谛系非根法。何谓诸圣谛系非根法。若非圣非根苦集灭。是名诸圣谛系非根法。何谓非诸圣谛系非根法。除苦集灭若余非根。是名非诸圣谛系非根法。何谓眼入法。眼入。是名眼入法。何谓非眼入法。除眼根若余法。是名非眼入法。耳鼻舌身意亦如是。何谓色入法。色界。是名色入法。何谓非色入法。除色界若余法。是名非色入法。声香味触法入亦如是。何谓受法。若意所受。是名受法。何谓非受法。除受若余法。是名非受法。何谓想法。若想忆想。是名想法。何谓非想法。除想若余法。是名非想法。何谓思法。若思正思。是名思法。何谓非思法。除思若余法。是名非思法。何谓触法六触。是名触法。何谓非触法。除触若余法。是名非触法。何谓思惟法。若计挍分别筹量忆念。是名思惟法。何谓非思惟法。除思惟若余法。是名非思惟法。何谓觉法。若觉忆想。是名觉法。何谓非觉法。除觉若余法。是名非觉法。何谓观法。若心行微行顺行。是名观法。何谓非观法。除观若余法。是名非观法。何谓见法。见慧无痴见使戒道使。是名见法。何谓非见法。除见若余法。是名非见法。慧法亦如是。何谓解脱法。若解脱重解脱究竟解脱。是名解脱法何谓非解脱法。除解脱法若余法。是名非解脱法。何谓无贪法。若法不希望。是名无贪法。何谓非无贪法。除无贪若余法。是名非无贪法。何谓无恚法。若无恼。是名无恚法。何谓非无恚法。除无恚若余法。是名非无恚法。何谓无痴法。善见善慧无痴。是名无痴法。何谓非无痴法。除无痴若余法。是名非无痴法。何谓顺信法。善信信根顺信。是名顺信法。何谓非顺信法。除顺信若余法。是名非顺信法。何谓悔法。于作非作处作非作已。若悔心燋热。是名悔法。何谓无悔法。除悔若余法。是名无悔法。何谓非悔法。于作非作处作非作已。若不悔心不燋热。是名非悔法。何谓非无悔法。除非悔若余法。是名非无悔法。何谓悦法。若心悦豫。是名悦法。何谓非悦法。除悦法若余法。是名非悦法。何谓喜法。若喜踊跃重踊跃寂静心欢。是名喜法。何谓非喜法。除喜法若余法。是名非喜法。何谓心进法。若心发起显出越度。是名心进法。何谓非心进法。除心进若余法。是名非心进法。何谓心除法。若心乐心调心轻心软。是名心除法。何谓非心除法。除心除若余法。是名非心除法。何谓信法。若信入信。是名信法。何谓非信法。除信法若余法。是名非信法。何谓欲法。若悕望欲作。是名欲法何谓非欲法。除欲若余法。是名非欲法。何谓不放逸法。若护心。是名不放逸法。何谓非不放逸法。除不放逸若余法。是名非不放逸法。何谓念法。若念忆念。是名念法。何谓非念法。除念若余法。是名非念法。何谓定法若一心。是名定法。何谓非定法。除定若余法。是名非定法。何谓心舍法。若舍胜舍顺舍心无作非受。是名心舍法。何谓非心舍法。除心舍若余法。是名非心舍法。何谓疑法。若不到所断烦恼处。是名疑法。何谓非疑法。除疑若余法。是名非疑法。何谓怖法。若惊畏是名怖法。何谓非怖法。除怖若余法。是名非怖法。何谓烦恼使法。若十使。是名烦恼使法。何谓非烦恼使法。除十使若余法。是名非烦恼使法。何谓见使法。不善见不善慧若见使分见使。是名见使。法何谓非见使法。除见使若余法。是名非见使法。何谓疑使法。如上说。何谓非疑使法。除疑使若余法。是名非疑使法。何谓戒道使法。不善见不善慧若戒道分戒道。是名戒道使法。何谓非戒道使法。除戒道使若余法。是名非戒道使法。何谓爱使法。欲染。是名爱使法。何谓非爱使法。除爱使若余法。是名非爱使法。何谓嗔恚使法。恼害。是名嗔恚使法。何谓非嗔恚使法。除嗔恚使若余法。是名非嗔恚使法。何谓嫉妒使法。若他得利养尊重恭敬。于彼憎嫉重憎嫉究竟憎嫉。是名嫉妒使法。何谓非嫉妒使法。除嫉妒使若余法。是名非嫉妒使法。何谓悭惜使法。若于财物。不施不与。心吝不舍。是名悭惜使法。何谓非悭惜使法。除悭惜使若余法。是名非悭惜使法。何谓无明使法。痴不善根是名无明使法。何谓非无明使法。除无明使法若余法。是名非无明使法。何谓憍慢使法。若以慢自高。是名憍慢使法。何谓非憍慢使法。除憍慢使若余法。是名非憍慢使法。何谓掉使法。若掉重掉究竟掉动不定奔逸心不寂静。是名掉使法。何谓非掉使法。除掉使若余法。是名非掉使法。何谓生法。若阴起。是名生法。何谓非生法。除生若余法。是名非生法。何谓老法。若阴衰。是名老法。何谓非老法。除老若余法。是名非老法。何谓死法。若阴坏是名死法。何谓非死法。除死若余法。是名非死法。何谓命法。若众生住。是名命法。何谓非命法。除命若余法。是名非命法。何谓烦恼结法。十结。是名烦恼结法。何谓非烦恼结法。除结若余法。是名非烦恼结法。何谓无想定法。若离果实天。若心心数法。寂静入定。是名无想定法。何谓非无想定法。除无想定若余法。是名非无想定法。何谓得果法。若证果。是名得果法。何谓非得果法。除得果若余法。是名非得果法。何谓灭尽定法。若离非想非非想处。若心心数法寂静出世法。是名灭尽定法。何谓非灭尽定法。除灭尽定若余法。是名非灭尽定法。何谓非戒法。七种非戒。是名非戒法。何谓无戒法。除非戒法若余法。是名无戒法。何谓戒法。七种戒。是名戒法。何谓无戒法。除戒若余法。是名无戒法。何谓有漏身进法。若以有漏身。发起显出越度。是名有漏身进法。何谓非有漏身进法。除有漏身进若余法。是名非有漏身进法。何谓有漏身除法。若有漏身乐身调身轻身软身除。是名有漏身除法。何谓非有漏身除法。除有漏身除若余法。是名非有漏身除法。何谓正语法。若法于口四过。远离不乐。守护摄行。是名正语法。何谓非正语法。除正语若余法。是名非正语法。何谓正业法。若身三恶。远离不乐。守护摄行。是名正业法。何谓非正业法。除正业若余法。是名非正业法。何谓正命法。除身口恶行。若余邪命。不作不乐。守护摄行。是名正命法。何谓非正命法。除正命若余法。是名非正命法。何谓正身进法。若无漏身发起显出越度。是名正身进法。何谓非正身进法。除正身进若余法。是名非正身进法。何谓正身除法。无漏身乐身调身轻身软身除是名正身除法。何谓非正身除法。除正身除若余法。是名非正身除法。何谓智缘尽法。若诸因尽无余。是名智缘尽法。何谓无智缘尽法除智缘尽若余法。是名无智缘尽法。何谓非智缘尽法。若有为法众缘不会。是名非智缘尽法。何谓非非智缘尽法。除非智缘尽若余法。是名非非智缘尽法。何谓决定法。若法毕定。是名决定法。何谓非决定法。除决定若余法。是名非决定法。何谓法住法。除缘如尔若余法。如尔不变不异。非异物。常法实法。法住法定非缘。是名法住法。何谓非法住法。除法住法若余法。是名非法住法。何谓缘法。若缘如尔。是名缘法。何谓非缘法。除缘若余法。是名非缘法。何谓空处法。空处二种。或有为或无为。何谓有为空处。若空处定空处生。何谓空处定。若比丘离一切色想。灭嗔恚想。不思惟若干想。成就无边空处行。是名空处定。何谓空处生若定亲近多修学已。空处天上受四种我分。受想行识。是名空处生。如是空处定空处生。是名有为空处。何谓无为空处。若以智断空处。是名无为空处。识处不用处非想非非想处亦如是。何谓眼界法。眼入。是名眼界法。何谓非眼界法。除眼界若余法。是名非眼界法。乃至意识界亦如是。何谓色阴法。若十色入及法入色。是名色阴法。何谓非色阴法。除色阴若余法。是名非色阴法。何谓受阴法。若六受。是名受阴法。何谓非受阴法。除受阴若余法。是名非受阴法。何谓想阴法。若六想。是名想阴法。何谓非想阴法。除想阴法若余法。是名非想阴法。何谓行阴法。六思。是名行阴法。何谓非行阴法。除行阴若余法。是名非行阴法。何谓识阴法。六识是名识阴法。何谓非识阴法。除识阴若余法。是名非识阴法。何谓苦圣谛法。八苦。是名苦圣谛法。何谓非苦圣谛法。除苦圣谛若余法。是名非苦圣谛法。何谓集圣谛法。谓爱复有欲染喜乐。是名集圣谛法。何谓非集圣谛法。除集圣谛若余法。是名非集圣谛法。何谓灭圣谛法。爱离舍出解脱灭尽无余。是名灭圣谛法。何谓非灭圣谛法。除灭圣谛若余法。是名非灭圣谛法。何谓道圣谛法。八圣道。是名道圣谛法。何谓非道圣谛法。除八圣道若余法。是名非道圣谛法。何谓眼根法。眼入。是名眼根法。何谓非眼根法。除眼根若余法。是名非眼根法。耳鼻舌身根亦如是。何谓女根法。女身女性女相女形。是名女根法。何谓非女根法。除女根若余法。是名非女根法。何谓男根法。男身男性男相男形。是名男根法。何谓非男根法。除男根若余法。是名非男根法。何谓命根法。若寿。是名命根法。何谓非命根法。除命根若余法。是名非命根法。何谓乐根法。受阴中乐根。是名乐根法。何谓非乐根法。除乐根若余法。是名非乐根法。苦根忧根喜根舍根亦如是。何谓意根法。意入。是名意根法。何谓非意根法。除意根若余法。是名非意根法。何谓信根法。圣信圣顺信信根。是名信根法。何谓非信根法。除信根若余法。是名非信根法。何谓进根法。圣心进正身进进根。是名进根法。何谓非进根法。除进根若余法。是名非进根法。何谓念根法。圣念念根。是名念根法。何谓非念根法。除念根若余法。是名非念根法。何谓定根法。圣定根法。是名定根法。何谓非定根法。除定根若余法。是名非定根法。何谓慧根法。圣见圣慧圣无痴根。是名慧根法。何谓非慧根法。除慧根若余法。是名非慧根法。何谓未知欲知根法坚信坚法人。圣无漏法。非根得名根。谓想思等分。是名未知欲知根法。何谓非未知欲知根法。除未知欲知根若余法。是名非未知欲知根法。知根知已根亦如是。何谓念觉法。圣念觉。是名念觉法。何谓非念觉法。除念觉若余法。是名非念觉法。何谓择法觉法。圣见圣慧圣无痴择法觉。是名择法觉法。何谓非择法觉法。除择法觉若余法。是名非择法觉法。何谓进觉法。圣心进正身进觉。是名进觉法。何谓非进觉法。除进觉若余法。是名非进觉法。何谓喜觉法。圣喜喜觉。是名喜觉法。何谓非喜觉法。除喜觉若余法。是名非喜觉法。何谓除觉法。圣心除除觉。是名除觉法。何谓非除觉法。除除觉若余法。是名非除觉法。何谓定觉法。圣定定觉是名定觉法。何谓非定觉法。除定觉若余法。是名非定觉法。何谓舍觉法。圣心舍舍觉。是名舍觉法。何谓非舍觉法。除舍觉若余法。是名非舍觉法。何谓贪不善根法。若希望。是名贪不善根法。何谓非贪不善根法。除贪不善根若余法。是名非贪不善根法。恚痴亦如是。何谓无贪善根法。若不希望。是名无贪善根法。何谓非无贪善根法。除无贪善根若余法。是名非无贪善根法。无恚无痴亦如是。何谓地大法。触入中地大。是名地大法。何谓非地大法。除地大若余法。是名非地大法。水火风大亦如是。何谓不杀生戒法。不杀戒。是名不杀生戒法。何谓非不杀生戒法。除不杀生戒若余法。是名非不杀生戒法。乃至不饮酒不放逸亦如是。何谓色法。若法色。是名色法。何谓非色法。除色若余法。是名非色法。何谓可见法。色入。是名可见法。何谓不可见法。除色入若余法。是名不可见法。何谓有对法。十色入。是名有对法。何谓无对法。意入法入。是名无对法。何谓圣法。若法无漏。是名圣法。何谓非圣法。若法有漏。是名非圣法。有漏无漏有染无染有求无求当取非当取有取无取有胜无胜亦如是。何谓受法。若法内。是名受法。何谓非受法。若法外。是名非受法。何谓内法。若法受。是名内法。何谓外法。若法非受。是名外法。何谓有报法。若法报法。是名有报法。何谓无报法。若法报若非报非报法。是名无报法。何谓心法。意入。是名心法。何谓非心法。除心若余法。是名非心法。何谓心相应法。若法心数。是名心相应法。何谓无心相应法。若法非心数及心。是名无心相应法。何谓非心相应法。若法非心数。是名非心相应法。何谓非不心相应法。若法心数。是名非不心相应法。何谓非心相应非心不相应法。意入。是名非心相应非心不相应法。何谓非非心相应。非非不心相应法。若法心数非心数。是名非非心相应非非不心相应法。何谓心数法。除心若余有缘法。是名心数法。何谓非心数法。若法无缘及心。是名非心数法。何谓有缘法。若法心数及心。是名有缘法。何谓无缘法。除心若余非心数法。是名无缘法。何谓共心法。若法随心转共心生共住共灭。是名共心法。何谓不共心法。若法不随心转不共心生不共住不共灭。是名不共心法。随心转亦如是。何谓业法。身口意业。是名业法。何谓非业法。除身口意业若余法。是名非业法。何谓业相应法。若法思相应。是名业相应法。何谓无业相应法。若非思相应及思。是名无业相应法。何谓非业相应法。若法非思相应。是名非业相应法。何谓非无业相应法。若法思相应。是名非无业相应法。何谓非业相应非不业相应法。思是名非业相应非不业相应法。何谓非非业相应非非不业相应法。若思相应若非思相应。是名非非业相应非非不业相应法。何谓共业法。若法随业转共业生共住共灭。是名共业法。何谓非共业法。若法不随业转不共生不共住不共灭。是名不共业法。随业转不随业转亦如是。何谓因法。若法有缘。若无缘有报。除得果若法无缘善报及四大。是名因法。何谓无因法。若法无缘无报不共业得果。是名无因法。何谓有因法。若法有绪。是名有因法。何谓无因法。若法无绪。是名无因法。有绪无绪有缘无缘有为无为亦如是。何谓知法。一切法知如相知见。是名知法。何谓非知法无非知法。复次一切法不如相知见。是名非知法。识非识了非了解非解亦如是。何谓断智知法。若法不善。是名断智知法。何谓非断智知法。若法善无记。是名非断智知法。断非断亦如是。何谓修法。若法善。是名修法。何谓非修法。若法不善无记。是名非修法。何谓证法。一切法证如相知见。是名证法。何谓非证法无非证法。复次一切法非证不如相知见。是名非证法。何谓善法。若法修。是名善法。何谓无善法。若法不善无记。是名无善法。何谓不善法。若法断。是名不善法。何谓无不善法。若法善无记。是名无不善法。何谓无记法。若法受。若非报非报法。是名无记法。何谓无无记法。若法善不善。是名无无记法。何谓学法。若法圣非无学。是名学法。何谓非学法。若法非圣若无学。是名非学法。何谓无学法。若法圣非学。是名无学法。何谓非无学法。若法非圣若学。是名非无学法。何谓非学非无学法。若法非圣。是名非学非无学法。何谓非非学非非无学法。若法圣。是名非非学非非无学法。何谓报法。若受若善报。是名报法。何谓非报法。若不善若善有报。若非报非报法。是名非报法。何谓报法法。若法有报。是名报法法。何谓非报法法。若报若非报非报法。是名非报法法。何谓非报非报法法。若法无记非我分摄圣无为。是名非报非报法法。何谓非非报非非报法法。若报若报法。是名非非报非非报法法。何谓见断法。若法不善非思惟断。是名见断法。何谓非见断法。若法善无记若思惟断。是名非见断法。何谓思惟断法。若法不善非见断。是名思惟断法。何谓非思惟断法。若法善若无记见断。是名非思惟断法。何谓非见断非思惟断法。若法善无记。是名非见断非思惟断法。何谓非非见断非非思惟断法。若法不善。是名非非见断非非思惟断法。何谓见断因法。若法见断若见断法报。是名见断因法。何谓非见断因法。若法善若善法报。若思惟断。若思惟断法报。若非报非报法。是名非见断因法。何谓思惟断因法。若法思惟断。若思惟断法报。是名思惟断因法。何谓非思惟断因法。若法善若善法报若见断法报。若非报非报法。是名非思惟断因法。何谓非见断非思惟断因法。若法善若善法报。若非非报报法。是名非见断非思惟断因法。何谓非非见断非非思惟断因法。若法不善。若不善法报。是名非非见断非非思惟断因法。何谓欲界系法。若法欲漏有漏。是名欲界系法。何谓非欲界系法。若法色无色界系法若不系。是名非欲界系法。何谓色界系法。若法色漏有漏。是名色界系法。何谓非色界系法。若欲界无色界系若不系。是名非色界系法。何谓无色界系法。若法无色漏有漏。是名无色界系法。何谓非无色界系法。若法欲界若色界系若不系。是名非无色界系法。何谓不系法。若圣无漏无为。是名不系法。何谓非不系法。若三界系。是名非不系法。何谓过去法。若法生已灭。是名过去法。何谓非过去法。若未来现在非过去非未来非现在。是名非过去法。何谓未来法。若法未生未出。是名未来法。何谓非未来法。若过去现在。若非过去非未来非现在。是名非未来法。何谓现在法。若法生未灭。是名现在法。何谓非现在法。若法过去未来非过去非现在。是名非现在法。何谓非过去非未来非现在法。若法无为。是名非过去非未来非现在法。何谓非非过去未来现在法。若法过去未来现在。是名非非过去未来现在法(性门竟)

苦谛系法。几阴界入摄。问何等法。问苦谛系法。除余法。除何等法。除非苦谛系法。非苦谛系法。几阴界入摄。问何等法。问非苦谛系法。除余法。除何等法。除苦谛系法。集谛系法。几阴界入摄。问何等法。问集谛系法。除余法。除何等法。除非集谛系法。非集谛系法。几阴界入摄。问何等法。问非集谛系法。除余法。除何等法。除集谛系法。灭谛系法。几阴界入摄。问何等法。问灭谛系法。除余法。除何等法。除非灭谛系法。非灭谛系法。几阴界入摄。问何等法。问非灭谛系法。除余法。除何等法。除灭谛系法。道谛系法。几阴界入摄。问何等法。问道谛系法。除余法。除何等法。除非道谛系法。非道谛系法。几阴界入摄。问何等法。问非道谛系法。除余法。除何等法。除道谛系法。诸圣谛系法。几阴界入摄。问何等法。问诸圣谛系法。除余法。除何等法。除非诸圣谛系法。非诸圣谛系法。几阴界入摄。问何等法。问非诸圣谛系法。除余法。除何等法。除诸圣谛系法。根法几阴界入摄。问何等法。问根法。除余法。除何等法。除非根法。非根法几阴界入摄。问何等法。问非根法。除余法。除何等法。除根法。苦谛系根法。几阴界入摄。问何等法。问苦谛系根法。除余法。除何等法。除非苦谛系根法。除苦谛系非根法。非苦谛系根法。几阴界入摄。问何等法。问非苦谛系根法。除余法。除何等法。除苦谛系法。除非苦谛系非根法。集谛系根法。几阴界入摄。问何等法。问集谛系根法。无集谛系根法。非集谛系根法几阴界入摄。问何等法。问非集谛系根法。除余法。除何等法。除集谛系法。除非集谛系非根法。灭谛系根法几阴界入摄。问何等法。问灭谛系根法。无灭谛系根法。非灭谛系根法几阴界入摄。问何等法。问非灭谛系根法。除余法。除何等法。除灭谛系法。除非灭谛系非根法。道谛系根法几阴界入摄。问何等法。问道谛系根法。除余法。除何等法。除非道谛系法。除道谛系非根法。无非道谛系非根法。非道谛系根法几阴界入摄。问何等法。问非道谛系根法。除余法。除何等法。除道谛系根法。除非道谛系非根法。诸圣谛系根法几阴界入摄。问何等法。问诸圣谛系根法。除余法。除何等法。除非诸圣谛系根法。除诸圣谛系非根法。非诸圣谛系根法几阴界入摄。问何等法。问非诸圣谛系根法。除余法。除何等法。除诸圣谛系根法。除非诸圣谛系非根法。苦谛系非根法几阴界入摄。问何等法。问苦谛系非根法。除余法。除何等法。除非苦谛系法。除苦谛系根法。非苦谛系非根法。几阴界入摄。问何等法。问非苦谛系非根法。除余法。除何等法。除苦谛系法。除非苦谛系根法。集谛系非根法几阴界入摄。问何等法。问集谛系非根法。除余法。除何等法。除非集谛系法。除集谛系根法无也。非集谛系非根法几阴界入摄。问何等法。问非集谛系非根法。除余法。除何等法。除集谛系法。除非集谛系根法。灭谛系非根法几阴界入摄。问何等法。问灭谛系非根法。除余法。除何等法。除非灭谛系法。除灭谛系根法无也。非灭谛系非根法几阴界入摄。问何等法。问非灭谛系非根法。除余法。除何等法。除灭谛系法。除非灭谛系根法。道谛系非根法几阴界入摄。问何等法。问道谛系非根法无也。非道谛系非根法几阴界入摄。问何等法。问非道谛系非根法。除余法。除何等法。除道谛系法。除非道谛系根法。诸圣谛系非根法几阴界入摄。问何等法。问诸圣谛系非根法。除余法。除何等法。除非诸圣谛系法。除诸圣谛系根法。非诸圣谛系非根法几阴界入摄。问何等法。问非诸圣谛系非根法。除余法。除何等法。除诸圣谛系法。除非诸圣谛系根法。眼入法几阴界入摄。问何等法。问眼入法。除余法。除何等法。非眼入法。非眼入法几阴界入摄。问何等法。问非眼入法。除余法。除何等法。除眼入法。乃至法入亦如是。眼界法几阴界入摄。问何等法。问眼界法。除余法。除何等法。除非眼界法。非眼界法几阴界入摄。问何等法。问非眼界法。除余法。除何等法。除眼界法。乃至法界亦如是。色阴法几阴界入摄。问何等法。问色阴法。除余法。除何等法。除非色阴法。非色阴法几阴界入摄。问何等法。问非色阴法。除余法。除何等法。除色阴法。乃至识阴亦如是。苦圣谛法几阴界入摄。问何等法。问苦圣谛法。除余法。除何等法。除非苦圣谛法。非苦圣谛法几阴界入摄。问何等法。问非苦圣谛法。除余法。除何等法。除苦圣谛法。乃至道圣谛法亦如是。眼根法几阴界入摄。问何等法。问眼根法。除余法。除何等法。除非眼根法。非眼根法几阴界入摄。问何等法。问非眼根法。除余法。除何等法。除眼根法。乃至知已根法亦如是。念觉法几阴界入摄。问何等法。问念觉法。除余法。除何等法。除非念觉法。非念觉法几阴界入摄。问何等法。问非念觉法。除余法。除何等法。除念觉法。乃至舍觉法亦如是。贪不善根法几阴界入摄。问何等法。问贪不善根法。除余法。除何等法。除非贪不善根法。非贪不善根法几阴界入摄。问何等法。问非贪不善根法。除余法。除何等法。除贪不善根法。恚痴亦如是。无贪善根法几阴界入摄。问何等法。问无贪善根法。除余法。除何等法。除非无贪善根法。非无贪善根法几阴界入摄。问何等法。问非无贪善根法。除余法。除何等法。除无贪善根法。无恚无痴亦如是。地大法几阴界入摄。问何等法。问地大法。除余法。除何等法。除非地大法。非地大法几阴界入摄。问何等法。问非地大法。除余法。除何等法。除地大法。水火风大亦如是。不杀生戒法几阴界入摄。问何等法。问不杀生戒法。除余法。除何等法。除非不杀生戒法。非不杀生戒法几阴界入摄。问何等法。问非不杀生戒法。除余法。除何等法。除不杀生戒法。乃至不饮酒不放逸处亦如是。色法几阴界入摄。问何等法。问色法。除余法。除何等法。除非色法。非色法几阴界入摄。问何等法。问非色法。除余法。除何等法。除色法。乃至过去未来现在法亦如是(单门竟)

舍利弗阿毗昙论卷第二十一舍利弗阿毗昙论卷第二十二

        姚秦罽宾三藏昙摩耶舍共昙摩崛多等译

    摄相应分摄品第一之二

色苦谛系法几阴界入摄。问何等法。问色苦谛系法。除余法。除何等法。除非色法。除色非苦谛系法。色非苦谛系法几阴界入摄。问何等法。问色非苦谛系法。除余法。除何等法。除非色法。除色苦谛系法。色集谛系法几阴界入摄。问何等法。问色集谛系法无也。色非集谛系法几阴界入摄。问何等法。问色非集谛系法。除余法。除何等法。除非色法。除色集谛系法无也。色灭谛系法几阴界入摄。问何等法。问色灭谛系法无也。色非灭谛系法几阴界入摄。问何等法。问色非灭谛系法。除余法。除何等法。除非色法。除色灭谛系法无也。色道谛系法几阴界入摄。问何等法。问色道谛系法。除余法。除何等法。除非色法。除色非道谛系法。色非道谛系法几阴界入摄。问何等法。问色非道谛系法。除余法。除何等法。除非色法。除色道谛系法。色诸圣谛系法几阴界入摄。问何等法。问色诸圣谛系法。除余法。除何等法。除非色法。除色非诸圣谛系法。色非诸圣谛系法几阴界入摄。问何等法。问色非诸圣谛系法。除余法。除何等法。除非色法。除色诸圣谛系法。色根法几阴界入摄。问何等法。问色根法。除余法。除何等法。除非色法。除色非根法。色非根法几阴界入摄。问何等法。问色非根法。除余法。除何等法。除非色法。除色根法。色苦谛系根法几阴界入摄。问何等法。问色苦谛系根法。除余法。除何等法。除非色法。除色非苦谛系法。除色苦谛系非根法。色非苦谛系根法几阴界入摄。问何等法。问色非苦谛系根法。除余法。除何等法。除非色法。除色苦谛系法。除色非苦谛系非根法无也。色集谛系根法几阴界入摄。问何等法。问色集谛系根法无也。色非集谛系根法几阴界入摄。问何等法。问色非集谛系根法。除余法。除何等法。除非色法。除色集谛系法无也。除色非集谛系非根法。色灭谛系根法几阴界入摄。问何等法。问色灭谛系根法无也。色非灭谛系根法几阴界入摄。问何等法。问色非灭谛系根法。除余法。除何等法。除非色法。除色灭谛系法无也。除色非灭谛系非根法。色道谛系根法几阴界入摄。问何等法。问色道谛系根法。除余法。除何等法。除非色法。除色法非道谛系法。除色道谛系非根法无也。色非道谛系根法几阴界入摄。问何等法。问色非道谛系根法。除余法。除何等法。除非色法。除色非道谛系非根法。色诸圣谛系根法。几阴界入摄。问何等法。问色诸圣谛系根法。除余法。除何等法。除非色法。除色非诸圣谛系法。除色非诸圣谛系非根法。色非诸圣谛系根法几阴界入摄。问何等法。问色非诸圣谛系根法。除余法。除何等法。除非色法。除色诸圣谛系法。除色非诸圣谛系非根法无也。色苦谛系非根法几阴界入摄。问何等法。问色苦谛系非根法。除余法。除何等法。除非色法。除色非苦谛系法。除色苦谛系根法。色非苦谛系非根法几阴界入摄。问何等法。问色非苦谛系非根法无也。色集谛系非根法几阴界入摄。问何等法。问色集谛系非根法无也。色非集谛系非根法几阴界入摄。问何等法。问色非集谛系非根法。除余法。除何等法。除非色法。除色集谛系法无也。除色非集谛系根法。色灭谛系非根法几阴界入摄。问何等法。问色灭谛系非根法无也。色非灭谛系非根法几阴界入摄。问何等法。问色非灭谛系非根法。除余法。除何等法。除非色法。除色灭谛系法无也。除色非灭谛系根法。色道谛系非根法几阴界入摄。问何等法。问色道谛系非根法无也。色非道谛系非根法几阴界入摄。问何等法。问色非道谛系非根法。除余法。除何等法。除非色法。除色道谛系法。除色非道谛系根法。色诸圣谛系非根法几阴界入摄。问何等法。问色诸圣谛系非根法。除余法。除何等法。除非色法。除色非诸圣谛系法。除色诸圣谛系根法。色非诸圣谛系非根法几阴界入摄。问何等法。问色非诸圣谛系非根法无也。非色法。如色法说。乃至过去未来现在法亦如是(二重竟)

善色苦谛系法几阴界入摄。问何等法。问善色苦谛系法。除余法。除何等法。除无善法。除善非色法。除善色非苦谛系法。善色非苦谛系法几阴界入摄。问何等法。问善色非苦谛系法。除余法。除何等法。除无善法。除善非色法。除善色苦谛系法。善色集谛系法几阴界入摄。问何等法。问善色集谛系法无也。善色非集谛系法几阴界入摄。问何等法。问善色非集谛系法。除余法。除何等法。除无善法。除善非色法。除善色集谛系法。问善色灭谛系法几阴界入摄。问何等法。问善色灭谛系法无也。善色非灭谛系法几阴界入摄。问何等法。问善色非灭谛系法。除余法。除何等法。除无善法。除善非色法。除善色灭谛系法无也。善色道谛系法几阴界入摄。问何等法。问善色道谛系法。除余法。除何等法。除无善法。除善非色法。除善色非道谛系法。善色非道谛系法几阴界入摄。问何等法。问善色非道谛系法。除余法。除何等法。除无善法。除善非色法。除善色道谛系法。善色诸圣谛系法几阴界入摄。问何等法。问善色诸圣谛系法。除余法。除何等法。除无善法。除善非色法。除善色非诸圣谛系法。善色非诸圣谛系法几阴界入摄。问何等法。问善色非诸圣谛系法。除余法。除何等法。除无善法。除善非色法。除善色诸圣谛系法。善色根法几阴界入摄。问何等法。问善色根法。除余法。除何等法。除无善法。除善非色法。除善色非根法。善色非根法几阴界入摄。问何等法。问善色非根法。除余法。除何等法。除无善法。除善非色法。除善色根法。善色苦谛系根法几阴界入摄。问何等法。问善色苦谛系根法。除余法。除何等法。除无善法。除善非色法。除善色苦谛系法。除善色非苦谛系非根法无也。善色集谛系根法。无也。善色非苦谛系根法几阴界入摄。问何等法。问善色非苦谛系根法。除余法。除何等法。除无善法。除善非色法。除善色苦谛系法。除善色非苦谛系非根法无也。善色集谛系根法。几阴界入摄。问何等法。问善色集谛系根法无也。善色非集谛系根法。几阴界入摄。问何等法。问善色非集谛系根法。除余法。除何等法。除无善法。除善非色法。除善色集谛系法无也。除善色非集谛系非根法。善色灭谛系根法几阴界入摄。问何等法。问善色灭谛系根法无也。善色非灭谛系根法几阴界入摄。问何等法。问善色非灭谛系根法。除余法。除何等法。除无善法。除善非色法。除善色灭谛系法无也。除善色非灭谛系根法。善色道谛系根法几阴界入摄。问何等法。问善色道谛系根法。除余法。除何等法。除无善法。除善非色法。除善色非道谛系法。除善色道谛系非根法无也。善色非道谛系根法几阴界入摄。问何等法。问善色非道谛系根法。除余法。除何等法。除无善法。除善非色法。除善色道谛系法。除善色非道谛系非根法。善色诸圣谛系根法几阴界入摄。问何等法。问善色诸圣谛系根法。除余法。除何等法。除无善法。除善非色法。除善色非诸圣谛系法。除善色诸圣谛系非根法。善色非诸圣谛系根法几阴界入摄。问何等法。问善色非诸圣谛系根法。除余法。除何等法。除无善法。除善非色法。除善色诸圣谛系法。除善色非诸圣谛系非根法无也。善色苦谛系非根法几阴界入摄。问何等法。问善色苦谛系非根法。除余法。除何等法。除无善法。除善非色法。除善色非苦谛系法。除善色苦谛系根法无也。善色非苦谛系非根法几阴界入摄。问何等法。问善色非苦谛系非根法无也。善色集谛系非根法几阴界入摄。问何等法。问善色集谛系非根法无也。善色非集谛系非根法几阴界入摄。问何等法。问善色非集谛系非根法。除余法。除何等法。除无善法。除善非色法。除善色集谛系法无也。除善色非集谛系根法。善色灭谛系非根法几阴界入摄。问何等法。问善色灭谛系非根法无也。善色非灭谛系非根法几阴界入摄。问何等法。问善色非灭谛系非根法。除余法。除何等法。除无善法。除善非色法。除善色灭谛系法无也。除善色非灭谛系根法。善色道谛系非根法。几阴界入摄。问善色道谛系非根法无也。善色非道谛系非根法几阴界入摄。问何等法。问善色非道谛系非根法。除余法。除何等法。除无善法。除善非色法。除善色道谛系法。除善色非道谛系根法。善色诸圣谛系非根法几阴界入摄。问何等法。问善色诸圣谛系非根法。除余法。除何等法。除无善法。除善非色法。除善色非诸圣谛系根法。除善色诸圣谛系根法。善色非诸圣谛系非根法几阴界入摄。问何等法。问善色非诸圣谛系非根法无也。善非色亦如是。乃至过去未来现在法亦如是(三重竟)

善学色苦谛系法几阴界入摄。问何等法。问善学色苦谛系法无也。善学色非苦谛系法几阴界入摄。问何等法。问善学色非苦谛系法。除余法。除何等法。除无善法。除善非无学法。除善学非色法。除善学色苦谛系法无也。善学色集谛系法几阴界入摄。问何等法。问善学色集谛系法无也。善学色非集谛系法几阴界入摄。问何等法。问善学色非集谛系法。除余法。除何等法。除无善法。除善非无学法。除善学非色法。除善学色集谛系法无也。善学色灭谛系法几阴界入摄。问何等法。问善学色灭谛系法无也。善学色非灭谛系法几阴界入摄。问何等法。问善学色非灭谛系法。除余法。除何等法。除无善法。除善非无学法。除善学非色法。除善学色灭谛系法无也。善学色道谛系法几阴界入摄。问何等法。问善学色道谛系法。除余法。除何等法。除无善法。除善非无学法。除善学非色法。除善学色非道谛系法。善学色非道谛系法几阴界入摄。问何等法。问善学色非道谛系法。除余法。除何等法。除无善法。除善非无学法。除善学非色法。除善学色道谛系法。善学色诸圣谛系法几阴界入摄。问何等法。问善学色诸圣谛系法。除余法。除何等法。除无善法。除善无学法。除善学非色法。除善学色非诸圣谛系法。善学色非诸圣谛系法几阴界入摄。问何等法。问善学色非圣谛系法。除余法。除何等法。除无善法。除善非无学法。除善学非色法。除善学色诸圣谛系法。善学色根法几阴界入摄。问何等法。问善学色根法。除余法。除何等法。除无善法。除善非无学法。除善学非色法。除善学色非根法无也。善学色非根法几阴界入摄。问何等法。问善学色非根法无也。善学色苦谛系根法几阴界入摄。问何等法。问善学色苦谛系根法无也。善学色非苦谛系根法几阴界入摄。问何等法。问善学色非苦谛系根法。除余法。除何等法。除无善法。除善非无学法。除善学非色法。除善学色苦谛系法无也。除善学色非苦谛系非根法无也。善学色集谛系根法几阴界入摄。问何等法。问善学色集谛系根法无也。善学色非集谛系根法几阴界入摄。问何等法。问善学色非集谛系根法。除余法。除何等法。除善非无学法。除善学非色法。除善学色集谛系法无也。除善学色非集谛系非根法无也。善学色灭谛系非根法无也。善学色灭谛系根法几阴界入摄。问何等法。问善学色灭谛系根法无也。善学色非灭谛系根法几阴界入摄。问何等法。问善学色非灭谛系根法。除余法。除何等法。除无善法。除善非无学法。除善学非色法。除善学色灭谛系法无也。除善学色非灭谛系非根法无也。善学色道谛系根法几阴界入摄。问何等法。问善学色道谛系根法。除余法。除何等法。除无善法。除善非无学法。除善学非色法。除善学色非道谛系法。除善学色道谛系非根法无也。善学色非道谛系根法几阴界入摄。问何等法。问善学色非道谛系根法。除余法。除何等法。除无善法。除善非无学法。除善学非色法。除善学色道谛系法。除善学色非道谛系非根法无也。善学色诸圣谛系根法几阴界入摄。问何等法。问善学色诸圣谛系根法。除余法。除何等法。除无善法。除善非无学法。除善学非色法。除善色非诸圣谛系法。除善学色诸圣谛系非根法无也。善学色非诸圣谛系根法。几阴界入摄。问何等法。问善学色非诸圣谛系根法。除余法。除何等法。除无善法。除善非疑善法。除善非学法。除善学非色法。除善学色诸圣谛系法。除善学色非诸圣谛系非根法无也。善学色苦谛系非根法几阴界入摄。问何等法。问善学色苦谛系非根法尽无也。善非色亦如上色法说。乃至过去未来现在法亦如是(四重竟摄事竟)

苦谛系法几非阴界入摄。问何等法。问非苦谛系法。除余法。除何等法。除苦谛系法。非苦谛系法几非阴界入摄。问何等法。问苦谛系法。除余法。除何等法。除非苦谛系法。集谛系法几非阴界入摄。问何等法。问非集谛系法。除余法。除何等法。除集谛系法。非集谛系法几非阴界入摄。问何等法。问集谛系法。除余法。除何等法。除非集谛系法。灭谛系法几非阴界入摄。问何等法。问非灭谛系法。除余法。除何等法。除灭谛系法。非灭谛系法几非阴界入摄。问何等法。问灭谛系法。除余法。除何等法。除非灭谛系法。道谛系法几非阴界入摄。问何等法。问非道谛系法。除余法。除何等法。除道谛系法。非道谛系法几非阴界入摄。问何等法。问道谛系法。除余法。除何等法。除非道谛系法。诸圣谛系法几非阴界入摄。问何等法。问非诸圣谛系法。除余法。除何等法。除诸圣谛系法。非诸圣谛系法几非阴界入摄。问何等法。问诸圣谛系法。除余法。除何等法。除非诸圣谛系法。根法几非阴界入摄。问何等法。问非根法。除余法。除何等法。除根法。非根法几非阴界入摄。问何等法。问根法。除余法。除何等法。除非根法。苦谛系根法几非阴界入摄。问何等法。问非苦谛系法。问苦谛系非根法。除余法。除何等法。除苦谛系根法。非苦谛系根法几非阴界入摄。问何等法。问苦谛系法。问非苦谛系非根法。除余法。除何等法。除非苦谛系根法。集谛系根法几非阴界入摄无也。非集谛系根法几非阴界入摄。问何等法。问集谛系法。问非集谛系非根法。除余法。除何等法。除非集谛系根法。灭谛系根法几非阴界入摄无也。非灭谛系根法几非阴界入摄。问何等法。问灭谛系法。问非灭谛系非根法。除余法。除何等法。除非灭谛系根法。道谛系根法几非阴界入摄。问何等法。问非道谛系法。问道谛系非根法无也。除余法。除何等法。除道谛系根法。非道谛系根法几非阴界入摄。问何等法。问道谛系法。问非道谛系非根法。除余法。除何等法。除非道谛系根法。诸圣谛系根法几非阴界入摄。问何等法。问非诸圣谛系法。问诸圣谛系非根法除余法。除何等法。除诸圣谛系根法。非诸圣谛系根法几非阴界入摄。问何等法。问诸圣谛系法。问非诸圣谛系非根法。除余法。除何等法。除非诸圣谛系根法。苦谛系非根法几非阴界入摄。问何等法。问非苦谛系法。问苦谛系根法。除余法。除何等法。除苦谛系非根法。非苦谛系非根法几非阴界入摄。问何等法。问苦谛系法。问非苦谛系根法。除余法。除何等法。除非苦谛系非根法。集谛系非根法几非阴界入摄。问何等法。问非集谛系法。问集谛系根法无也。除余法。除何等法。除集谛系非根法。非集谛系非根法几非阴界入摄。问何等法。问集谛系法。问非集谛系根法。除余法。除何等法。除非集谛系非根法。灭谛系非根法几非阴界入摄。问何等法。问非灭谛系法。问灭谛系根法无也。除余法。除何等法。除灭谛系非根法。非灭谛系非根法几非阴界入摄。问何等法。问灭谛系法。问非灭谛系根法。除余法。除何等法。除非灭谛系非根法。道谛系非根法几非阴界入摄无也。非道谛系非根法几非阴界入摄。问何等法。问道谛系法。问非道谛系根法。除余法。除何等法。除非道谛系非根法。诸圣谛系非根法几非阴界入摄。问何等法。问非诸圣谛系法。问诸圣谛系根法。除余法。除何等法。除诸圣谛系非根法。非诸圣谛系非根法几非阴界入摄。问何等法。问诸圣谛系法。问非诸圣谛系根法。除余法。除何等法。除非诸圣谛系非根法。眼入法几非阴界入摄。问何等法。问非眼入法。除余法。除何等法。除眼入法。乃至法入亦如是。眼界法几非阴界入摄。问何等法。问非眼界法。除余法。除何等法。除眼界法。非眼界法几非阴界入摄。问何等法。问眼界法。除余法。除何等法。除非眼界法。乃至法界亦如是。色阴法几非阴界入摄。问何等法。问非色阴法。除余法。除何等法。除色阴法。非色阴法几非阴界入摄。问何等法。问色阴法。除余法。除何等法。除非色阴法。乃至识阴亦如是。苦圣谛法。几非阴界入摄。问何等法。问非苦圣谛法。除余法。除何等法。除苦圣谛法。非苦圣谛法几非阴界入摄。问何等法。问苦圣谛法。除余法。除何等法。除非苦圣谛法。乃至道圣谛亦如是。眼根法几非阴界入摄。问何等法。问非眼根法。除余法。除何等法。除眼根法。非眼根法几非阴界入摄。问何等法。问眼根法。除余法。除何等法。除非眼根法。乃至知已根亦如是。念觉法几非阴界入摄。问何等法。问非念觉法。除余法。除何等法。除念觉法。非念觉法几非阴界入摄。问何等法。问念觉法。除余法。除何等法。除非念觉法。乃至舍觉法亦如是。贪不善根法几非阴界入摄。问何等法。问非贪不善根法。除余法。除何等法。除贪不善根法。非贪不善根法几非阴界入摄。问何等法。问贪不善根法。除余法。除何等法。除非贪不善根法。恚痴不善根法亦如是。无贪善根法几非阴界入摄。问何等法。问非无贪善根法。除余法。除何等法。除无贪善根法。非无贪善根法几非阴界入摄。问何等法。问无贪善根法。除余法。除何等法。除非无贪善根法。无恚无痴亦如是。地大法几非阴界入摄。问何等法。问非地大法。除余法。除何等法。除地大法。非地大法几非阴界入摄。问何等法。问地大法。除余法。除何等法。除非地大法。水火风大亦如是。不杀生戒法几非阴界入摄。问何等法。问非不杀生戒法。除余法。除何等法。除不杀生戒法。非不杀生戒法几非阴界入摄。问何等法。问不杀生戒法。除余法。除何等法。除非不杀生戒法。乃至不饮酒不放逸处亦如是。色法几非阴界入摄。问何等法。问非色法。除余法。除何等法。除色法。非色法几非阴界入摄。问何等法。问色法。除余法。除何等法。除非色法。乃至过去。未来现在亦如是

舍利弗阿毗昙论卷第二十二舍利弗阿毗昙论卷第二十三

        姚秦罽宾三藏昙摩耶舍共昙摩崛多等译

    摄相应分相应品第二之上

心心数法。当知相应。当知不相应。当知无相应。当知非无相应相应。当知亦有相应不相应无相应非无相应不相应。当知亦有相应不相应无相应非无相应。无相应。当知亦有相应不相应无相应非无相应无相应。当知亦有相应不相应无相应非无相应。相应者。谓心与数法相应。数法与心相应。数法数法与数法相应。除自性自性自性不相应非无相应。心心数法相应正问。今当说

眼识界乃至意界意识界。身触心触名触对触爱触憎触明触无明触。明分触无明分触。乐根苦根喜根忧根舍根。受想思触思惟觉观。忍见智解脱。无贪无恚无痴。顺信悔不悔悦喜心进心除。信欲不放逸念舍怖。烦恼使见使疑使戒道使爱使恚使嫉妒使悭惜使无明使慢使掉使。有觉有观定。无觉有观定。无觉无观定。空定无相定无愿定。信根乃至慧根。是名相应。问

何谓眼识界。若识眼根因色境界。已生今生当生不定。是名眼识界。耳鼻舌身识界亦如是。何谓意界。若意知法念法。若初心已生今生当生不定。是名意界。何谓意识界。不离彼境界。若余心似彼。已生今生当生不定。是名意识界。何谓身触。若触身识相应。是名身触。复次身触若触五识身相应。眼识耳鼻舌身识。是名身触。何谓心触。若触意识相应。是名心触。何谓名触。若心触。是名名触。何谓对触。若身触。是名对触。何谓爱触。若触欲染相应。是名爱触。何谓恚触。若触嗔恚相应。是名恚触。何谓明触。若触圣智相应。是名明触。何谓无明触。若触不善非智相应。是名无明触。何谓明分触。若触明分生明得明能令明广大。是名明分触。何谓无明分触生无明得无明能令无明广大。是名无明分触。复次明分触。若触圣忍相应。是名明分触。复次无明分触。若触非圣非烦恼相应。是名无明分触。复次明分触。若触圣能得智果是名明分触。复次无明分触。若触非圣。若善无记是名。无明分触。何谓乐根。若身忍受乐。眼触乐受。耳鼻舌身。触乐受乐界。是名乐根。何谓苦根。若身不忍受苦。眼触苦受。耳鼻舌身。触苦受苦界。是名苦根。何谓喜根。若心忍受乐。意触乐受喜界。是名喜根。何谓忧根。若心不忍受苦。意触苦受忧界。是名忧根。何谓舍根。若身心不忍受苦乐。眼触不苦不乐。耳鼻舌身意。触不苦不乐受舍界。是名舍根。何谓受。若心受。是名受。复次受六受。眼触受。耳鼻舌身意触受。何谓眼触受。若受眼识相应。是名眼触受。乃至意受亦如是。复次眼触受。缘眼缘色生眼识。三法和合触缘受。是名眼触受。乃至意受亦如是。何谓想。若想忆想胜想。是名想。复次想六想。色想声香味触法想。何谓色想。若想眼识相应。是名色想。声香味触法亦如是。复次色想。色境界思惟色。若想忆想胜想是名色想。声香味触法想亦如是。何谓思。若思正思缘思。若心有作是名思。复次思六思。色思声香味触法思。何谓色思。若思眼识相应。是名色思。声香味触法思亦如是。复次色思色境界思惟色。若思正思缘思。若心有作。是名色思。声香味触法思亦如是。何谓触。若触正触。是名触。复次触六触。眼触耳鼻舌身意触。何谓眼触。若触眼识相应。是名眼触。耳鼻舌身意触亦如是。复次眼触缘眼缘色生眼识。三法和合触。是名眼触。耳鼻舌身意触亦如是。何谓思惟。若心分别计挍筹量忆念。是名思惟。复次思惟六思惟。色声香味触法思惟。何谓色思惟。若思惟眼识相应。是名色思惟。声香味触法思惟亦如是。复次色思惟。色境界思惟。色若心分别计挍筹量忆念。是名色思惟。声香味触法思惟亦如是。何谓觉。若觉重觉忆想缘境界心语。是名觉。复次六觉。色声香味触法觉。云何色觉。若以色境界思惟色觉重觉忆想缘境界心语。是名色觉。声香味触法觉亦如是。何谓观。若心行微行微津微分别心随微转。是名观。复次六观。色观声香味触法观。何谓色观。若以色境界思惟色。若心行微行微津微分别心随微转。是名色观。声香味触法观亦如是。何谓忍。贪嗜欲得。若于顺不顺法。堪任忍辱。是名忍。何谓见。见有二种。或见忍。或见智。何谓见忍。若贪嗜欲得。若于顺不顺法。堪任忍辱。是名见忍。何谓见智。若必执于法。是名见智。何谓智。若必执于善法。是名智。复次智有四智。法智比智世智他心智。是名智。何谓解脱。若解重解。究竟解。心向彼尊上彼倾向彼以彼解脱。是名解脱。复次解脱六解脱。色解脱声香味触法解脱。云何色解脱。若解脱眼识相应。是名色解脱。声香味触法解脱亦如是。复次色解脱。若以色境界思惟色。若解重解究竟解心向彼尊上彼倾向彼以彼解脱。是名色解脱。声香味触法解脱亦如是。何谓无贪。若不悕望。是名无贪。复次若堪忍离贪心。是名无贪。复次若于五欲中。爱喜适意爱色欲染相续。眼识色爱喜适意爱色欲染相续。耳鼻舌身识触爱喜适意爱色欲染相续。若于他欲他财他所须他妇女。不欲贪取。若不贪重。不贪究竟。不贪心。不着不悕望。不爱着。不欲染。及余可贪法。若不贪重。不贪究竟。不贪心。不贪着。不悕望。不爱着。不欲染。是名无贪。何谓无恚。若无诤讼。是名无恚。复次若堪忍离恚心。是名无恚。复次若于少众生。若多众生。欲令此众生。不系不闭不伤害。莫令为若干苦加。若无恚重。无恚究竟。无恚心离恚。无诤讼。不憎害。无恼缘心。不怨憎。慈重慈究竟。慈矜愍欲。利益众生。及余可恚法。若不恚重。不恚究竟。不恚心离恚。无诤讼。不憎害。无恼缘心。不怨憎。慈重慈究竟。慈矜愍欲利益法。是名无恚。何谓无痴。若明。是名无痴。复次无痴。若堪忍离痴心。是名无痴。复次若知苦集灭道。知前际后际。知前后际。知内知外。知六触入集灭大过患出要。知因缘。知业报。知缘生善不善无记黑白有缘无缘有明无明可作不可作可亲近不可亲近。若于彼法。无痴无闇。无忘无失。正念无障碍。无覆盖。无闇蔽。无荒无缠。无浊。明焰术光昭知见解射方便。慧眼慧根慧力择法觉正见。及余痴法中。无痴无闇无忘无失。正念无障碍无覆盖无闇蔽。无荒无缠无浊明焰术光昭知见解射方便。慧眼慧根慧力择法觉正见。是名无痴。何谓顺信。若信善顺不逆。是名顺信。何谓悔。若可作不可作处。若作不作已。若于彼心。燋热重燋热。究竟燋热。是名悔。何谓不悔。若可作不可作处。若可作不可作已。若于彼不燋不热重不燋不热究竟不燋不热。是名不悔。何谓悦。若心悦豫欢乐爱乐未喜。是名悦。何谓喜。若欢喜踊跃正踊跃。离恚寂静。是名喜。何谓心进。若心发起显出越度。是名心进。何谓心除。若心乐心调心轻心软是名心除。何谓信。若信入信胜信。是名信。何谓欲。若欲重欲悕望欲作欲发起欲显出欲度欲得欲触欲解射欲证。是名欲。何谓不放逸。若覆护心念欲令我心不染于染法。不恚于恚法。不痴于痴法。不着垢秽法。不顺于色欲法。不贡高于贡高法。不放逸于放逸法。是名不放逸。何谓念。若念忆念。是名念。何谓心舍。若舍胜舍心等心均心清净心无作非受。是名舍。何谓怖。若于色声香味触法。若众生。若怖重怖究竟怖。心惊毛竖。是名怖。何谓烦恼使。十使见使疑使戒道使爱使恚使嫉妒使悭惜使无明使憍慢使掉使。是名烦恼使。何谓见使。除戒道见。若余见。是名见使。复次见使。六十二见。及邪见。是名见使。何谓疑使。若有人缘过去疑惑。我过去有。我非过去有。以何性过去有因。何过去有缘。未来疑惑。我未来有。我非未来有。以何性未来有因。何未来有缘。现在疑惑。我现在有。我现在非有。以何性我现在有因。何现在有谓我生处。此众生从何处来。去至何处。若世尊疑惑。是佛世尊非佛世尊。世尊善说法。世尊非善说法。世尊声闻众善趣。世尊声闻众非善趣。行常行非常。行苦行非苦。无我法非无我法。寂静涅槃。非寂静涅槃。有与无与。有施无施。有祀无祀。有善恶业果报。无善恶业果报。有今世无今世。有后世无后世。有父母无父母。有天无天。众生有化生。众生无化生。世有沙门婆罗门正趣正至。若今世后世自证知说。世无沙门婆罗门正趣正至。若今世后世身证知说。若于彼法疑惑重疑惑究竟疑惑。心不决定。犹豫二心疑心不了。无量疑不尽不解脱。犹豫重犹豫究竟犹豫。是名疑使。何谓戒道使。若戒道见。是名戒道使。复次以戒为净。以戒道为净。解脱无依尽一切苦际。若忍欲觉触证戒谓护身口。道谓邪。吉养发敬事水火日月。持牛鹿狗默然等戒求。为力士报人天中尊。如是勤行苦行邪行。此谓道。若戒若道求觅。求觅已以是为净。为净已为解脱。为解脱已以是为圣人为罗汉为涅槃。若于彼忍欲堪任乐着。是名戒道使。何谓爱使。若欲染。是名爱使。何谓嗔恚使。若憎恚。是名嗔恚使。何谓嫉妒使。若他得利养恭敬尊重赞叹礼拜。憎嫉嗔恚忿怒心嫉。是名嫉妒使。何谓悭惜使。若财物吝惜不舍心贪。是名悭惜使。何谓无明使。痴不善根。是名无明使。何谓憍慢使。若以慢自高。是名憍慢使。何谓掉使。若掉动不定发奔逸不寂静不正寂静心不息。是名掉使。有觉有观定无觉有观定。无觉无观定。空无相无愿定。如道品三支道中广说。何谓信根。学人离烦恼圣心趣圣道。若坚信坚法。及余趣人。见行过患。观涅槃寂灭。如实观苦集灭道。未得欲得。未解欲解。未证欲证。修道离烦恼见学人。若须陀洹斯陀含阿那含。观行具足。若智地。若观解脱心即得沙门果须陀洹果斯陀含果阿那含果。无学人阿罗汉未得圣法。欲得修道。观行具足。若智地若观解脱心即得阿罗汉果。如实人如趣人。若信入信胜信真信心净是名信根。进念定慧根亦如是

舍利弗阿毗昙论卷第二十三舍利弗阿毗昙论卷第二十四

        姚秦罽宾三藏昙摩耶舍共昙摩崛多等译

    摄相应分相应品下

七十二相应门分。今当说。五识界。各十二。二识界。各六十。身触十三。心触名触。各五十三。对触亦十三。身触爱触二十五。恚触二十三。明触三十五。无明触三十四。明分触三十五。无明分触三十。乐根十三。苦根亦如是。喜根五十一。忧根三十七。舍根五十六。受六十五。想思触思惟。各除自性。余数觉五十九。观六十。忍五十三。见五十四。智三十五解脱。六十九。无贪二十九。无恚亦如是。无痴四十二。顺信四十四。悔三十四。不悔三十六。悦五十二。喜亦如是。心进六十。心除四十一。信五十八。欲六十一。不放逸四十六。念五十九。心舍四十一。怖二十七。烦恼使四十九。见使二十八。疑使十九。戒道使二十八。爱使二十九。憎使二十七。嫉妒二十四。悭惜使亦如是。无明三十九。慢掉亦如是有觉有观。定三十五。无觉有观定三十四。无觉无观定三十三。空定三十四。无相无愿亦如是。信根三十八。进根三十九。念根亦如是。定根三十四。慧根三十六。何谓眼识界分。若法眼识界相应。谓身触对触无明分触乐根苦根舍根受想思触思惟解脱。是名眼识界分。耳鼻舌身识界分亦如是

何谓意界分。若法意界相应谓心触名触爱触憎触明触无明触明分触无明分触。喜根乃至慧根。是名意界分。意识界分亦如是

何谓身触分。若法身触相应。谓眼识界耳识界鼻识界舌识界身识界乐根苦根舍根受想思惟解脱。是名身触分

何谓心触分。若法心触相应。谓意界意识界除触喜根乃至慧根。是名心触分。名触分亦如是

何谓对触分。若法对触相应。谓眼识界耳鼻舌身识界。乐根苦根舍根受想思思惟解脱。是名对触分

何谓爱触分。若法爱触相应。谓意界意识界喜根舍根受想思。思惟觉观忍见解脱不悔悦喜心进信欲念烦恼使爱使无明慢掉使。是名爱触分

何谓恚触分。若法恚触相应。谓意界意识界忧根受想思思惟。觉观忍见解脱悔心进信欲念怖烦恼使恚使无明慢掉使。是名恚触分

何谓明触分。若法明触相应。谓意界意识界。喜根舍根受想思。思惟觉观见智解脱无痴顺信悦喜心进心除。信欲不放逸念心舍。有觉有观定。无觉有观定。无觉无观定。空定无相定无愿定。信根乃至慧根。是名明触分

何谓无明触分。若法无明触相应。谓意界意识界喜根忧根舍根受想思。思惟觉观忍见解脱悔不悔悦喜心进信欲念怖烦恼使及十烦恼使。是名无明触分

何谓明分触。若法明分触相应。谓意界意识界。喜根舍根受想思。思惟觉观忍见解脱无痴顺信悦喜心进心除。信欲不放逸念心舍。有觉有观定。乃至慧根。是名明分触

何谓无明分触。若法无明分触相应。谓眼耳鼻舌身识界。意界意识界。乐根苦根喜根忧根舍根。受想思思惟觉观。忍见解脱无贪无恚无痴。顺信悔不悔悦喜心进信欲不放逸念心除怖。有觉有观定。无觉有观定。无觉无观定。是名无明分触

何谓乐根分。若法乐根相应。谓眼识界耳鼻舌身识界。身触对触无明分触想思触思惟解脱。是名乐根分

何谓苦根分。若法苦根相应。谓眼识界耳鼻舌身识界。身触对触无明分触想思触思惟解脱。是名苦根分

何谓喜根分。若法喜根相应。谓意界意识界。心触名触爱触明触无明触明分触无明分触想思触。思惟觉观忍见智解脱。无贪无恚无痴。顺信不悔悦喜心进心除。信欲不放逸念心舍。烦恼使见使戒道使爱使无明慢掉使。有觉有观定乃至慧根。是名喜根分

何谓忧根分。若法忧根相应。谓意界意识界。心触名触恚触无明触无明分触想思触。思惟觉观忍见解脱。无贪无恚无痴。顺信悔心进信欲不放逸念怖。烦恼使见使疑使戒道使恚使嫉妒悭惜使无明慢掉使。是名忧根分

何谓舍根分。若法舍根相应。谓眼识界耳鼻舌身识界。意界意识界。眼耳鼻舌身触心触名触对触爱触明触无明触明分触无明分触。痴顺信心除。信欲不放逸念舍。烦恼使见使疑使戒道使爱使无明慢掉使。有觉有观定乃至慧根。是名舍根分

何谓受分。若法受相应。何谓非分。谓诸自性。是名非受分

何谓想分。若法想相应。何谓非分。谓诸自性。是名非想分

何谓思分。若法思相应。何谓非分。谓诸自性。是名非思分

何谓触分。若法触相应。何谓非分。谓诸自性。是名非触分。思惟分如想说

何谓觉分。若法觉相应。何谓非分。谓五识界身触对触乐根苦根自性。无觉有观定无觉无观定。是名非觉分

何谓观分。若法观相应。何谓非分。谓五识界身触对触乐根苦根自性。无觉无观定。是名非观分

何谓忍分。若法忍相应。何谓非分。谓身无明触十五自性忍见智无痴慧根。见断三烦恼身见疑戒道。是名非忍分

何谓见分。若法见相应。何谓非分。九一向身五自性忍智无痴慧根见断三烦恼身见疑戒道。是名非见分

何谓智分。若法智相应。谓意界意识界。心触名触明触喜根舍根受想触思惟觉观解脱顺信悦喜心进心除。信欲不放逸念心舍。有觉有观定乃至定根。是名智分

何谓解脱分。若法解脱相应。何谓非分。谓自性疑使。是名非解脱分

何谓无贪分。若法无贪相应。谓意界意识界。心触名触无明分触。喜根忧根舍根受想思触思惟觉观。忍见解脱无痴顺信悔不悔悦喜心进信欲不放逸念。是名无贪分

何谓无恚分。若法无恚相应。谓意界意识界。心触名触无明分触喜根忧根舍根。受想思触思惟觉观。忍见解脱无痴顺信悔不悔悦喜心进信欲不放逸念。是名无恚分

何谓无痴分。若法无痴相应。谓意界意识界。心触名触明触明分触无明分触喜根忧根舍根。受想思触思惟觉观。解脱无贪无恚顺信悔不悔悦喜心进心除信欲不放逸念心舍。有觉有观定乃至定根。是名无痴分

何谓顺信分。若法顺信相应。谓意界意识界。心触名触明触明分触无明分触。喜根忧根舍根。受想思触思惟觉观。忍见智解脱。无贪无恚无痴。悔不悔悦喜心进心除。欲不放逸念心舍除信根。有觉有观定乃至慧根。是名顺信分

何谓悔分。若法悔相应。谓意界意识界。心触名触恚触无明触无明分触。忧根受想思触思惟觉观。忍见解脱无贪无恚无痴。顺信心进信欲不放逸念烦恼使见使戒道使恚使无明憍慢掉使。是名悔分

何谓非分。若法非悔相应。谓意界意识界。心触名触爱触无明触无明分触。喜根受想思触思惟觉观。忍见解脱无贪无恚无痴。顺信悦喜心进信欲不放逸念。烦恼使见使戒道使爱无明慢掉使。是名非悔分

何谓悦分。若法悦相应。何谓非分。谓身九恚触忧根舍根悔自性怖疑恚嫉妒悭惜。是名非悦分

何谓喜分。若法喜相应。何谓非分。谓身九恚触忧根舍根悔自性喜怖疑恚嫉妒悭惜。是名非喜分

何谓心进分。若法心进相应。何谓非分。谓身九。自性进根。是名非心进分

何谓心除分。若法心除相应。谓意界意识界心触名触明触明分触无明分触。喜根舍根受想思触思惟觉观。忍见智解脱无痴。顺信悦喜心进信欲不放逸念心舍有觉有观定乃至慧根。是名心除分

何谓信分。若法信相应。何谓非分。谓身九顺信信根疑。是名非信分

何谓欲分。若法欲相应。何谓非分。谓身九自性疑。是名非欲分

何谓不放逸分。若法不放逸相应。谓意界意识界。心触名触明触明分触无明分触。喜根忧根舍根。受想思触思惟觉观。忍见智解脱无贪无恚无痴。顺信悔不悔悦喜心进心除信欲念舍。有觉有观定乃至定根。是名不放逸分

何谓念分。若法念相应。何谓非分。谓身九自性念根疑。是名非念分

何谓心舍分。若法心舍相应。谓意界意识界。心触名触明触明分触无明分触。喜根舍根受想思触思惟觉观。忍见智解脱无痴顺信悦喜心进心除信欲不放逸念。有觉有观定乃至慧根。是名心舍分

何谓怖分。若法怖相应。谓意界意识界。心触名触恚触无明触无明分触。忧根受想思触思惟觉观。忍见解脱心进信欲念。烦恼使恚使无明慢掉使。是名怖分

何谓烦恼使分。若法烦恼使相应。谓意界意识界。心触名触爱触恚触无明触。喜根忧根舍根受想思触思惟觉观。忍见解脱悔不悔悦喜心进信欲念怖见使乃至掉使。是名烦恼使分

何谓见分。若法见使相应。谓意界意识界。心触名触无明触。喜根忧根舍根。受想思触思惟觉观解脱悔不悔悦喜心。进信欲念。烦恼使无明慢掉使。是名见使分

何谓疑使分。若法疑使相应。谓意界意识界。心触名触无明触。忧根舍根受想。思触思惟觉观心进。烦恼使无明慢掉使。是名疑使分

何谓戒道使分。若法戒道使相应。谓意界意识界。心触名触无明触喜根忧根舍根受想思触思惟觉观解脱悔不悔悦喜心进信欲念。烦恼使无明慢掉使。是名戒道使分

何谓爱使分。若法爱使相应。谓意界意识界。心触名触爱触无明触。喜根舍根受想思触思惟觉观。忍见解脱不悔悦喜心进信欲念。烦恼使无明慢掉使。是名爱使分

何谓恚使分。若法恚使相应。谓意界意识界。心触名触恚触无明触。忧根受想思触思惟觉观。忍见解脱悔心进信欲念怖。烦恼使无明慢掉使。是名恚使分

何谓嫉妒使分。若法嫉妒使相应。谓意界意识界心触名触无明触忧根受想思触思惟觉观忍见解脱心进信欲念烦恼使无明慢掉使。是名嫉妒使分

何谓悭惜使分。若法悭惜使相应。谓意界意识界。心触名触无明触。忧根受想思触思惟觉观。忍见解脱心进信欲念。烦恼使无明慢掉使。是名悭惜使分

何谓无明使分。若法无明使相应。谓意界意识界。心触名触爱触恚触无明触。喜根忧根舍根受想思触思惟觉观。忍见解脱悔不悔悦喜心进信欲念怖。烦恼使见使疑使戒道使爱使恚使嫉妒使悭惜使慢使掉使。是名无明使分

何谓慢使分。若法慢使相应。谓意界意识界。心触名触爱触恚触无明触。喜根忧根舍根受想思触思惟觉。忍见解脱悔不悔悦喜心进信欲念怖。烦恼使见使疑使戒道使爱使恚使嫉妒使悭惜使无明使掉使。是名慢使分

何谓掉使分。若法掉使相应。谓意界意识界。心触名触爱触恚触无明触。喜根忧根舍根。受想思触思惟觉观。忍见解脱悔不悔悦喜心进信欲念怖。烦恼使见使疑使戒道使爱使恚使嫉妒使悭惜使无明使慢使。是名掉使分。何谓有觉有观定分。若法有觉有观定相应。谓意界意识界。心触名触明触明分触无明分触。喜根舍根受想思触思惟觉观。忍见智解脱无痴顺信悦喜心进心除。信欲不放逸念心舍信根进根念根慧根。是名有觉有观定分

何谓无觉有观定分。若法无觉有观定相应。谓意界意识界。心触名触明触明分触无明分触。喜根忧根舍根受想思触思惟觉观。忍见智解脱无痴顺信悦喜心进心除。信欲不放逸念心舍信根进根念根慧根。是名无觉有观定分

何谓无觉无观定分。若法无觉无观定相应。谓意界意识界。心触名触明触明分触无明分触。喜根舍根受想思触思惟觉观。忍见智解脱无痴顺信悦喜心进心除。信欲不放逸念心舍信根念根慧根。是名无觉无观定分

何谓空定分。若法空定相应。谓意界意识界。心触名触明触明分触。喜根舍根受想思触思惟觉观。忍见智解脱无痴顺信悦喜心进心除。信欲不放逸念心舍。信根进根念根慧根。是名空定分

何谓无相定分。若法无相定相应。谓意界意识界。心触名触明分触。喜根舍根受想思触。思惟觉观。忍见智解脱无痴顺信悦喜心进心除。信欲不放逸念心舍。信根进根念根慧根。是名无相定分

何谓无愿定分。若法无愿定相应。谓意界意识界。心触名触明触明分触。喜根舍根受想思触思惟觉观。忍见智解脱无痴顺信悦喜心进心除。信欲不放逸念心舍信根进根念根慧根。是名无愿定分

何谓信根分。若法信根相应。谓意界意识界。心触名触明触明分触。喜根舍根受想思触思惟觉观。忍见智解脱无痴悦喜心进心除。信欲不放逸念心舍。除信根从有觉有观定乃至慧根。是名信根分

何谓进根分。若法进根相应。谓意界意识界。心触名触明分触。喜根舍根受想思触思惟觉观。忍见智解脱无痴顺信悦喜心除。信欲不放逸念心舍。除进根从有觉有观定乃至慧根。是名进根分

何谓念根分。若法念根相应。谓意界意识界。心触名触明触明分触。喜根舍根受想思触思惟觉观。忍见智解脱无痴顺信悦喜心进心除。信欲不放逸念心舍。除念根从有觉有观定乃至慧根。是名念根分

何谓定根分。若法定根相应。谓意界意识界。心触名触明触明分触。喜根舍根受想思触思惟觉观。忍见智解脱无痴顺信悦喜心进心除。信欲不放逸念心舍信根进根念根慧根。是名定根分

何谓慧根分。若法慧根相应。谓意界意识界。心触名触明触明分触。喜根舍根受想思触思惟觉观。解脱顺信悦喜心进心除。信欲不放逸念心舍。从有觉有观定乃至定根。是名慧根分

眼识界。几法相应。问何等法。问眼识界相应法。除余法。除何等法。除非眼识界相应法。眼识界。谓无缘法意识分。身四识界。耳鼻舌身识界亦如是。意界几法相应。问何等法。问意界相应法。除余法。除何等法。除非意界相应法。意界。谓无缘法身分。意界。意识界。几法相应。问何等法。问意识界相应法。除余法。除何等法。除非意识界相应法。意识界。谓无缘法身分。身触几法相应。问何等法。问身触相应法。除余法。除何等法。除非身触相应法。身触。谓无缘法意识分。心触几法相应。问何等法。问心触相应法。除余法。除何等法。除非心触相应法。心触。谓无缘法身分。名触几法相应。问何等法。问名触相应法。除余法。除何等法。除非名触相应法。名触。谓无缘法身分。对触几法相应。问何等法。问对触相应法。除余法。除何等法。除非对触相应法。对触。谓无缘法意识分。爱触几法相应。问何等法。问爱触相应法。除余法。除何等法。除非爱触相应法。爱触。谓无缘法身分。意识善无记分。不善非爱触相应诸烦恼相应分。恚触几法相应。问何等法。问恚触相应法。除余法。除何等法。除非恚触相应法。恚触。谓无缘法身分。意识善无记分。若不善非恚触相应诸烦恼相应分。明触几法相应。问何等法。问明触分相应法。除余法。除何等法。除非明触相应法。明触分。谓无缘法身分。意识非圣分。圣智分。无明触几法相应。问何等法。问无明触相应法。除余法。除何等法。除非无明触相应法。无明触。谓无缘法身分。意识善无记分。明分触几法相应。问何等法。问明分触相应法。除余法。除何等法。除非明分触相应法。明分触。谓无缘法身分。意识非圣分。圣智分。无明分触几法相应。问何等法。问无明分触相应法。除余法。除何等法。除非无明分触相应法。无明分触。谓无缘法意识善无记分。圣分。乐根几法相应。问何等法。问乐根相应法。除余法。除何等法。除非乐根相应法。乐根。谓无缘法意识分。身苦根舍根分。苦根几法相应。问何等法。问苦根相应法。除余法。除何等法。除非苦根相应法。苦根。谓无缘法意识。分身乐根舍根分。喜根几法相应。问何等法。问喜根相应法。除余法。除何等法。除非喜根相应法。喜根。谓无缘法身分。意识忧根舍根分。忧根几法相应。问何等法。问忧根相应法。除余法。除何等法。除非忧根相应法。忧根。谓无缘法身分。意识喜根舍根分。舍根几法相应。问何等法。问舍根相应法。除余法。除何等法。除非舍根相应法。舍根。谓无缘法身分。乐根苦根分。意识喜根忧根分。受法几法相应。问何等法。问受相应法。除余法。除何等法。除非受相应法。受谓无缘法。想思触思惟亦如是。觉几法相应。问何等法。问觉相应法。除余法。除何等法。除非觉相应法。觉谓无缘法身分。意识无觉有观分。观几法相应。问何等法。问观相应法。除余法。除何等法。除非观相应法。观谓无缘法身分。意识无觉无观分。忍几法相应。问何等法。问忍相应法。除余法。除何等法。除非忍相应法。忍谓无缘法身分意识智疑分。见几法相应。问何等法。问见相应法。除余法。除何等法。除非见相应法。见谓无缘法身分。意识疑分。智几法相应。问何等法。问智相应法。除余法。除何等法。除非智相应法。智谓无缘法身分。意识非圣分圣忍分。解脱几法相应问何等法。问解脱相应法。除余法。除何等法。除非解脱相应法。解脱谓无缘法意识疑分。无贪几法相应。问何等法。问无贪相应法。除余法。除何等法。除无贪相应法。无贪。谓无缘法身分。意识不善无记分善非欲界分。若欲界无恚分。复有欲界非无贪相应无恚无痴相应分。无恚几法相应。问何等法。问无恚相应法。除余法。除何等法。除非无恚相应法。无恚。谓无缘法身分。意识不善无记分。善非欲界分。欲界无贪分。复有欲界非无恚相应。无贪无痴相应分。无痴几法相应。问何等法。无痴相应法。除余法。除何等法。除非无痴相应法。无痴。谓无缘法身分。意识不善无记分。顺信几法相应。问何等法。问顺信相应法。除余法。除何等法。除非顺信相应法。顺信。谓无缘法身分。意识不善若无记分。悔几法相应。问何等法。问悔相应法。除余法。除何等法。除非悔相应法。悔谓无缘法身分意识喜根舍根分。非悔相应忧根相应分。不悔几法相应。问何等法。问不悔相应法。除余法。除何等法。除非不悔相应法。不悔。谓无缘法身分。意识忧根舍根分。非不悔相应喜根相应分。悦几法相应。问何等法。问悦相应法。除余法。除何等法。除非悦相应法。悦谓无缘法身分。意识忧根舍根分。非悦相应喜根相应分。喜几法相应。问何等法。问喜相应法。除余法。除何等法。除非喜相应法。喜谓无缘法身分。意识忧根舍根分。非喜相应悦相应分。心进几法相应。问何等法。问心进相应法。除余法。除何等法。除非心进相应法。心进。谓无缘法身分。心除几法相应。问何等法。问心除相应法。除余法。除何等法。除非心除相应法。心除谓无缘法身分。意识不定分。信几法相应。问何等法。问信相应法。除余法。除何等法。除非信相应法。信谓无缘法身分意识疑分。欲几法相应。问何等法。问欲相应法。除余法。除何等法。除非欲相应法。欲谓无缘法身分。意识疑分。不放逸几法相应。问何等法。问不放逸相应法。除余法。除何等法。除非不放逸相应法。不放逸。谓无缘法身分。意识不善无记分。念几法相应。问何等法。问念相应法。除余法。除何等法。除非念相应法。念谓无缘法身分。意识疑分。心舍几法相应。问何等法。问心舍相应法。除余法。除何等法。除非心舍相应法。心舍。谓无缘法身分。意识不定分。怖几法相应。问何等法。问怖相应法。除余法。除何等法。除非怖相应法。怖谓无缘法身分。意识喜根舍根分。非怖相应忧根相应分。烦恼使几法相应。问何等法。问烦恼使。相应法除余法除。何等法。除非烦恼使相应法。烦恼使。谓无缘法身分。意识善无记分。见使几法相应。问何等法。问见使相应法。除余法。除何等法。除非见使相应法。见使。谓无缘法身分。意识善无记分不善非见使相应诸烦恼相应分。疑使几法相应。问何等法。问疑使相应法。除余法。除何等法。除非疑使相应法。疑使谓无缘法身分意识善无记分。不善非疑使相应诸烦恼相应分。戒道使几法相应。问何等法。问戒道使相应法。除余法。除何等法。除非戒道使相应法。戒道使。谓无缘法身分。意识善无记分。不善非戒道使相应诸烦恼相应分。爱使几法相应。问何等法。问爱使相应法。除余法。除何等法。除非爱使相应法。爱使谓无缘法身分。意识无记分。不善非爱使相应诸烦恼相应分。恚使几法相应。问何等法。问恚使相应法。除余法。除何等法。除非恚使相应法。恚使谓无缘法身分。意识善无记分。不善非恚使相应诸烦恼相应分。嫉妒使几法相应。问何等法。问嫉妒使相应法。除余法。除何等法。除非嫉妒使相应法。嫉妒使。谓无缘法身分。意识善无记分。不善非嫉妒使相应诸烦恼相应分。悭惜使几法相应。问何等法。问悭惜使相应法。除余法。除何等法除非悭惜使相应法。悭惜使。谓无缘法身分意识善无记分。不善非悭惜使相应诸烦恼使相应分。无明使几法相应。问何等法。问无明使相应法。除余法。除何等法。除非无明使相应法。无明使。谓无缘法身分。意识善无记分。慢掉亦如是。有觉有观定几法相应。问何等法。问有觉有观定相应法。除余法。除何等法。除非有觉有观定相应法。有觉有观定。谓无缘法身分意识不定分二定相应分。无觉有观定几法相应。问何等法。问无觉有观定相应法。除余法。除何等法。除非无觉有观定相应法。无觉有观定。谓无缘法身分意识不定二定相应分。无觉无观定几法相应。问何等法。问无觉无观定相应法。除余法。除何等法。除非无觉无观定相应法。无觉无观定。谓无缘法身分意识不定分二定相应分。空定几法相应。问何等法。问空定相应法。除余法。除何等法。除非空定相应法。空定谓无缘法身分。意识非圣分。无相无愿相应分。无相定几法相应。问何等法。问无相定相应法。除余法除何等法。除非无相定相应法。无相定。谓无缘法身分。意识非圣分。圣空无愿相应分。无愿定几法相应。问何等法。问无愿定相应法。除余法。除何等法。除非无愿定相应法。无愿定谓无缘法身分。意识非圣分。圣空无相相应分。信根几法相应。问何等法。问信根相应法。除余法。除何等法。除非信根相应法。信根。谓无缘法身分。意识非圣分。进根念根定根慧根亦如是

舍利弗阿毗昙论卷第二十四此卷经解射字他本并是解脱字。勘第十九卷并二十一卷。解射是无漏观也。意云。结使烦恼犹如矢射有伤害故。无漏之观解彼无伤故立此名。恐后人见古来多本并是解脱字。反生疑惑故以指之呈讫指之舍利弗阿毗昙论卷第二十五

        姚秦罽宾三藏昙摩耶舍共昙摩崛多等译

    绪分遍品第一

十缘正法门遍绪七转十行解一切法等入。十缘。谓因缘无间缘境界缘依缘业缘报缘起缘异缘相续缘增上缘

何谓因缘。若法因。是名因缘。复次因缘。若法共非共有报是名因缘。复次因缘。若法有缘。若法无缘有报。除得果。若余法无缘善报及四大。是名因缘

何谓无间缘。若法生灭。是名无间缘。复次无间缘。若法已灭若未灭。若阴界入法。各自性即生。若先已灭于现在。是名无间缘

何谓境界缘。一切法境界缘。如相生心心数法。是名境界缘

何谓依缘。若法有猗。是名依缘。复次依缘。若法依法生。此法于彼法依缘。依身有身业。依口有口业。依意有意业。依四大有身口意业。依地有稼穑业种子聚落众生聚落药草丛林。依恶知识便生恶不善法。依善知识便生善法。依眼依色生眼识及眼识相应法。耳鼻舌身意亦如是。依内大生内大。依内大生外大。依内大生内外大。依外大生内大。依外大生外大。依外大生内外大。依内外大生内大。依内外大生外大。依内外大生内外大。灭亦如是。是名依缘

何谓业缘。业是业缘。若非业是业缘。若业异业因生业。是名业缘

何谓报缘。若法有报。是名报缘

何谓起缘。若法能起所起。是名起缘。复次起缘。若法自起。能起他流津增长。谓专杀结善根不善根意识想思觉四大。是名起缘

何谓异缘。若法共有。是名异缘

何谓相续缘。若法增益不断。是名相续缘。复次相续缘。若法初生软。次生中后生上。软法于上法是相续缘。是名相续缘

何谓增上缘。若法胜是名增上缘。复次增上缘。若法所增上所向所归所倾向而生。若以欲增上。以精进增上。以心增上以思惟增上。以贪增上。以嗔恚增上。以愚痴增上。以无贪增上。以无恚增上。以无痴增上。以戒增上。以定增上。以慧增上。以我增上。以世间增上。以法增上。以眼根增上。以耳鼻舌身意根增上。以增上为增上。以境界增上。以依增上。何谓以欲增上。若法以欲胜而生。彼欲于法为增上缘。精进增上心进于思惟贪嗔恚愚痴。无贪无恚无痴戒定慧增上亦如是。何谓我增上。如佛经说。三增上。何谓三。我增上。世间增上。法增上。何谓我增上。如比丘或在树下露处。心生恶不善法想。比丘如是思惟。我设在屏处。作恶不善业。作恶不善业已。心自退毁。比丘如是思惟。我欲护持禁戒成就威仪。若犯微戒畏如金刚顺学戒行。是名我增上。比丘为我增上故。断恶不善法修行善法。是故名我增上。何谓世间增上。如比丘或在树下露处。心生恶不善法想。比丘如是思惟。世间一切处居止有天。天眼见知他心。天远见我。我近不见天。自相谓言。观此善男子。以信出家离行恶不善法。复有诸沙门婆罗门。天眼见知他心。远见我我近不见。诸沙门婆罗门自相谓言。观此善男子。以信出家。离行恶不善法。比丘如是思惟。我欲护持禁戒成就威仪。若犯微戒畏如金刚顺学戒行。是名世间增上。比丘为世间增上故。断恶不善法修行善法。是故名世间增上。何谓法增上。如比丘或在树下露处。如是思惟。世尊善随时说法。有慧者能受趣向涅槃。此法非悕望者嗔恚者睡眠者掉悔者疑惑者能受。比丘如是思惟。我欲护持禁戒成就威仪。若犯微戒畏如金刚顺学戒行。是名法增上。比丘为法增上故。断恶不善法修行善法。是故名法增上。如偈说

  世间无屏处　　可以作恶业
  唯人自证知　　若虚若是实
  言无虚者胜　　是则不自毁
  若以有违犯　　而知不覆藏
  贤者及与天　　见世作恶时
  以此我胜行　　世间胜比丘
  法胜者顺行　　不退于实法
  降魔威力胜　　自证胜寂灭
  远离舍六情　　灭苦不受有
  已没不复还　　永离于生死

是名三增上。何谓眼根增上。眼见色思惟色。眼根生色境界。若生心数。此法眼根胜。是名眼根增上。耳鼻舌身根增上亦如是。何谓意根增上。意知法思惟法。意根主以法为境界。若法生心数。此法意根胜。是名意根增上。何谓增上为增上。若法初起至后法随用。是名增上为增上。何谓境界增上。若一切境界如事中胜。是名境界增上。何谓依增上。若一切法依如事依胜。是名依增上

因有几缘。四何等四。共起增长报。是名因有四缘。谓因生义如母子。无间谓补处义如代坐。境界谓的义如箭射的。依谓物义如舍宅。业谓作义如使作。报谓津漏义如树生果。起谓生义如种芽。异谓不相离义。如眷属。相续谓增长义如长财。增上谓自在义如人王因缘无间缘。或因缘即无间缘。或因缘非无间缘。何谓因缘即无间缘。若法因生灭。是名因缘即无间缘。何谓因缘非无间缘。若法因非生灭若未灭。是名因缘非无间缘。非因缘无间缘。或非因缘即无间缘。或非因缘非无间缘。何谓非因缘即无间缘。若法非因生灭。是非因缘即无间缘。何谓非因缘非无间缘。若法非因非生灭若未灭。是名非因缘非无间缘因缘境界缘。或因缘即境界缘。或因缘非境界缘。何谓因缘即境界缘。若法因有境界。是名因缘即境界缘。何谓因缘非境界缘。若法因无境界。是名因缘非境界缘非因缘境界缘。或非因缘即境界缘。或非因缘非境界缘。何谓非因缘即境界缘。若法非因有境界。是名非因缘即境界缘。何谓非因缘非境界缘。若法非因不境界。是名非因缘非境界缘因缘依缘一切因缘。是依缘非因缘是依缘无也

因缘业缘。或因缘即业缘。或因缘非业缘。何谓因缘即业缘。若法因是业能生业。是名因缘即业缘。何谓因缘非业缘。若法因非业若业不能生业。是名因缘非业缘。非因缘是业缘无也

因缘报缘。或因缘即报缘。或因缘非报缘。何谓因缘即报缘。若法因此有报。是名因缘即报缘。何谓因缘非报缘。若法因无报。是名因缘非报缘。非因缘是报缘无也

因缘起缘。或因缘即起缘。或因缘非起缘。何谓因缘即起缘。若法因是起。是名因缘即起缘。何谓因缘非起缘。若法因非起。是名因缘非起缘。非因缘是起缘无也

因缘异缘。或因缘即异缘。或因缘非异缘。何谓因缘即异缘。若法因是共。是名因缘即异缘。何谓因缘非异缘。若法因非共。是名因缘非异缘。非因缘是异缘无也

因缘相续缘。或因缘即相续缘。或因缘非相续缘。何谓因缘即相续缘。若因有增长。乃至生第三。是因缘即相续缘。何谓因缘非相续缘。若因无缘增长。设增长不能乃至生第三。是名因缘非相续缘。非因缘是相续缘无也

因缘增上缘。或因缘即增上缘。或因缘非增上缘。何谓因缘即增上缘。若法因是增上。是因缘是增上缘。何谓因缘非增上缘。若法因非增上。是名因缘非增上缘。非因缘增上缘。或非因缘是增上缘。或非因缘非增上缘。何谓非因缘是增上缘。若法非因是增上。是名非因缘即增上缘。何谓非因缘非增上缘。若法非因非增上。是名非因缘非增上缘

无间缘境界缘。或无间缘即境界缘。或无间缘非境界缘。何谓无间缘是境界缘。若法生灭有境界。是名无间缘是境界缘。何谓无间缘非境界缘。若法生灭无境界。是名无间缘。非境界缘。非无间缘境界缘。或非无间缘即境界缘。或非无间缘非境界缘。何谓非无间缘是境界缘。若法非生灭若未灭有境界。是名非无间缘是境界缘。何谓非无间缘非境界缘。若法非生灭若未灭彼无境界缘。是名非无间缘非境界缘

无间缘依缘。无间缘是依缘。非无间缘是依缘无也

无间缘业缘。或无间缘即业缘。或无间缘非业缘。何谓无间缘即业缘。若法生灭是业。若业能生业。是名无间缘即业缘。何谓无间缘非业缘。若法生灭彼非业若业不能生业。是名无间缘非业缘。非无间缘业缘。或非无间缘即业缘。或非无间缘非业缘。何谓非无间缘是业缘。若法非生灭若未灭。是业能生业。是名非无间缘是业缘。何谓非无间缘非业缘。若法非生灭若未灭彼非业。若业不能生业。是名非无间缘非业缘

无间缘报缘。或无间缘是报缘。或无间缘非报缘。何谓无间缘是报缘。若法生灭有报。是名无间缘即报缘。何谓无间缘非报缘。若法生灭彼无报。是名无间缘非报缘。非无间缘报缘。或非无间缘即报缘。或非无间缘非报缘。何谓非无间缘是报缘。若法非生灭若未灭有报。是名非无间缘是报缘。何谓非无间缘非报缘。若法非生灭若未灭彼无报。是名非无间缘非报缘

无间缘是起缘无也。非无间缘起缘。或非无间缘是起缘。或非无间缘非起缘。何谓非无间缘是起缘。若法非生灭未灭而能起。是名非无间缘是起缘。何谓非无间缘非起缘。若法非生灭若未灭非起。是名非无间缘非起缘

无间缘是异缘无也。非无间缘是异缘。或非无间缘是异缘。或非无间缘非异缘。何谓非无间缘是异缘。若法非生灭若未灭此共。是名非无间缘是异缘。何谓非无间缘非异缘。若法非生灭若未灭彼非共。是名非无间缘非异缘

无间缘是相续缘无也。非无间缘相续缘。或非无间缘是相续缘。或非无间缘非相续缘。何谓非无间缘是相续缘。若法非生灭若未灭此增长。乃至能生第三。是名非无间缘是相续缘。何谓非无间缘非相续缘。若法非生灭。若未灭彼非增长。若增长不能乃至生第三。是名非无间缘非相续缘

无间缘是增上缘无也。或非无间缘是增上缘。或非无间缘非增上缘。何谓非无间缘是增上缘。若法非生灭若未灭是增上。是名非无间缘即增上缘。何谓非无间缘非增上缘。若法非生灭若未灭彼非增上。是非无间缘非增上缘

无间缘因缘。或无间缘是因缘。或无间缘非因缘。何谓无间缘是因缘。若法生灭是因。是名无间缘是因缘。何谓无间缘非因缘。若法生灭彼非因。是名无间缘非因缘。非无间缘因缘。或非无间缘是因缘。或非无间缘非因缘。何谓非无间缘是因缘。若法非生灭若未灭。是名非无间缘是因缘。何谓非无间缘非因缘。若法非生灭若未灭彼非因。是名非无间缘非因缘

境界缘依缘。境界缘是依缘无。非境界缘是依缘无也

境界缘业缘。或境界缘是业缘。或境界缘非业缘。何谓境界缘是业缘。若法有境界是业若业能生业。是名境界缘是业缘。何谓境界缘非业缘。若法有境界彼非业若业不能生业。是名境界缘非业缘。非境界缘业缘。或非境界缘是业缘。或非境界缘非业缘。何谓非境界缘是业缘。若法无境界是业若业能生业。是名非境界缘是业缘。何谓非境界缘非业缘。若法无境界彼非业若业不能生业。是名非境界缘非业缘城

境界缘报缘。或境界缘是报缘。或境界缘非报缘。何谓境界缘是报缘。若法有境界有报。是名境界缘是报缘。何谓境界缘非报缘。若法有境界彼无报。是名境界缘非报缘。非境界缘报缘。或非境界缘是报缘。或非境界缘非报缘。何谓非境界缘是报缘。若法无境界缘有报。是名非境界缘是报缘。何谓非境界缘非报缘。若法无境界彼无报。是名非境界缘非报缘

境界缘起缘。或境界缘是起缘。或境界缘非起缘。何谓境界缘是起缘。若法有境界是起。是名境界缘是起缘何谓境界缘非起缘。若法有境界彼非起。是名境界缘非起缘。非境界缘起缘。或非境界缘是起缘。或非境界缘非起缘。何谓非境界缘是起缘。若法无境界是起。是名非境界缘是起缘。何谓非境界缘非起缘。若法无境界彼非起。是名非境界缘非起缘

境界缘异缘。或境界缘是异缘。或境界缘非异缘。何谓境界缘是异缘。若法有境界是共。是名境界缘是异缘。何谓境界缘非异缘。若法有境界彼非共。是名境界缘非异缘。非境界缘异缘。或非境界缘是异缘。或非境界缘非异缘。何谓非境界缘是异缘。若法无境界是共。是名非境界缘是异缘。何谓非境界缘非异缘。若法无境界彼非共。是名非境界缘非异缘

境界缘相续缘。或境界缘是相续缘。或境界缘非相续缘。何谓境界缘是相续缘。若法有境界是增长乃至能生第三是名境界缘是相续缘。何谓境界缘非相续缘。若法有境界彼不增长。若增长不能乃至生第三。是名境界缘非相续缘。非境界缘相续缘。或非境界缘是相续缘。或非境界缘非相续缘。何谓非境界缘是相续缘。若法无境界是增长。乃至能生第三。是名非境界缘是相续缘。何谓非境界缘非相续缘。若法无境界彼不增长。若增长不能乃至生第三。是名非境界缘非相续缘

境界缘增上缘。或境界缘是增上缘。或境界缘非增上缘。何谓境界缘是增上缘。若法有境界是增上。是名境界缘是增上缘。何谓境界缘非增上缘。若法有境界彼非增上。是名境界缘非增上缘。非境界缘增上缘。或非境界缘是增上缘。或非境界缘非增上缘。何谓非境界缘是增上缘。若法无境界是增上。是名非境界缘是增上缘。何谓非境界缘非增上缘。若法无境界彼非增上。是名非境界缘非增上缘

境界缘因缘。或境界缘是因缘。或境界缘非因缘。何谓境界缘是因缘。若法有境界是因。是名境界缘是因缘。何谓境界缘非因缘。若法有境界彼非因。是名境界缘非因缘。非境界缘因缘。或非境界缘是因缘。或非境界缘非因缘。何谓非境界缘是因缘。若法无境界。是名非境界缘是因缘。何谓非境界缘非因缘。若法无境界彼非因。是名非境界缘非因缘

境界缘无间缘。或境界缘是无间缘。或境界缘非无间缘。何谓境界缘是无间缘。若法有境界是生灭。是名境界缘无间缘。何谓境界缘非无间缘。若法有境界彼非生灭若未灭。是名境界缘非无间缘。非境界缘无间缘。或非境界缘是无间缘。或非境界缘非无间缘。何谓非境界缘是无间缘。若法无境界是生灭。是名非境界缘是无间缘。何谓非境界缘非无间缘。若法无境界彼非生灭若未灭。是名非境界缘。非无间缘

依缘业缘。或依缘是业缘。或依缘非业缘。何谓依缘是业缘。若法依是业若业能生业。是名依缘是业缘。何谓依缘非业缘。若法依彼非业若业不能生业。是名依缘非业缘非依缘是业缘无也

依缘报缘。或依缘是报缘。或依缘非报缘。何谓依缘是报缘。若法依有报。是名依缘是报缘。何谓依缘非报缘。若法依非报。是名依缘非报缘。非依缘是报缘无也

依缘起缘。或依缘是起缘。或依缘非起缘。何谓依缘是起缘。若法依是起。是名依缘是起缘。何谓依缘非起缘。若法依非起。是名依缘非起缘。非依缘是起缘无也

依缘异缘。或依缘是异缘。或依缘非异缘。何谓依缘是异缘。若法依是共。是名依缘是异缘。何谓依缘非异缘。若法依彼非共。是名依缘非异缘。非依缘是异缘无也

依缘相续缘。或依缘是相续缘。或依缘非相续缘。何谓依缘是相续缘。若法依增长。乃至能生第三。是名依缘是相续缘。何谓依缘非相续缘。若法依彼生非增长若增长。不能乃至生第三。是名依缘非相续缘。非依缘是相续缘无也

依缘增上缘。或依缘是增上缘。或依缘非增上缘。何谓依缘是增上缘。若法依是增上。是名依缘是增上缘。何谓依缘非增上缘。若法依彼非增上。是名依缘非增上缘。非依缘是增上缘无也

依缘因缘。或依缘是因缘。或依缘非因缘。何谓依缘是因缘。若法依是因。是名依缘是因缘。何谓依缘非因缘。若法依非因。是名依缘非因缘。非依缘是因缘无也

依缘无间缘。或依缘是无间缘。或依缘非无间缘。何谓依缘是无间缘。若法依是生灭。是名依缘是无间缘。何谓依缘非无间缘。若法依彼非生灭若未灭。是名依缘非无间缘。非依缘是无间缘无也

依缘境界缘。或依缘是境界缘。或依缘非境界缘。何谓依缘是境界缘。若法依有境界。是名依缘是境界缘。何谓依缘非境界缘。若法依无境界。是名依缘非境界缘。非依缘是境界缘无也

业缘报缘。或业缘是报缘。或业缘非报缘。何谓业缘是报缘。若法业能生业有报。是名业缘是报缘。何谓业缘非报缘。若法业能生业无报。是名业缘非报缘。非业缘报缘。或非业缘是报缘。或非业缘非报缘。何谓非业缘是报缘。若非业若业不能生业有报。是名非业缘是报缘。何谓非业缘非报缘。若法非业若业不能生业无报。是名非业缘非报缘

业缘起缘。或业缘是起缘。或业缘非起缘。何谓业缘是起缘。若法业能生业。是名业缘是起缘。何谓业缘非起缘。若业不能生业彼非起缘。是名业缘非起缘。非业缘起缘。或非业缘是起缘。或非业缘非起缘。何谓非业缘是起缘。若法非业若业不能生业。是名业缘是起缘。何谓非业缘非起缘。若法非业若业不能生业生起。是名非业缘非起缘

业缘异缘。或业缘是异缘。或业缘非异缘。何谓业缘是异缘。若法业能生业是共。是名业缘是异缘。何谓业缘非异缘。若法业能生业非共。是名业缘非异缘非业缘异缘。或非业缘是异缘。或非业缘非异缘。何谓非业缘是异缘。若法非业若业不能生业。是名非业缘是异缘。何谓非业缘非异缘。若法非业若业不能生业非业。是名非业缘非异缘

业缘相续缘。或业缘是相续缘。或业缘。非相续缘。何谓业缘是相续缘。若法业能生业。是谓增长乃至能生第三。是名业缘是相续缘。何谓业缘非相续缘。若法业生业非增长。若增长不至生第三。是名业缘非相续缘。非业缘相续缘。或非业缘是相续缘。或非业缘非相续缘。何谓非业缘是相续缘。若法非业若业生非业是增长乃至生第三。是名非业缘是相续缘。何谓非业缘非相续缘。若法非业若生业非增长若增长不至生第三。是名非业缘非相续缘

业缘增上缘。或业缘是增上缘。或业缘非增上缘。何谓业缘是增上缘。若法业生业是增上。是名业缘是增上缘。何谓业缘非增上缘。若法业生业非增上。是名业缘非增上缘。非业缘增上缘。或非业缘是增上缘。或非业缘非增上缘。何谓非业缘是增上缘。若法非业若业生非业是增上。是名非业缘是增上缘。何谓非业缘非增上缘。若法业若业生非业非增上。是名非业缘非增上缘

业缘因缘业缘。是因缘非业缘因缘。或非业缘是因缘。或非业缘非因缘。何谓非业缘是因缘。若法非业若业生非业是因。是名非业缘是因缘。何谓非业缘非因缘。若法非业若业生非业非因。是名非业缘非因缘

业缘无间缘。或业缘是无间缘。或业缘非无间缘。何谓业缘是无间缘。若法生业是生灭。是名业缘是无间缘。何谓业缘非无间缘。若法业生业非生灭若未灭。是名业缘非无间缘。非业缘是无间缘。或非业缘是无间缘或非业缘非无间缘。何谓非业缘是无间缘。若法非业若业生非业是生灭。是名非业缘是无间缘。何谓非业缘非无间缘。若法非业若业生非业非生灭若未灭。是名非业缘非无间缘。业缘境界缘。或业缘是境界缘。或业缘非境界缘。何谓业缘是境界缘。若法业生业有境界。是名业缘是境界缘。何谓业缘非境界缘。若法业生业无境界。是名业缘非境界缘。非业缘境界缘。或非业缘是境界缘。或非业缘非境界缘。何谓非业缘是境界缘。若法非业若业生非业有境界。是名非业缘是境界缘。何谓非业缘非境界缘。若法非业若业生非业无境界。是名非业缘非境界缘

业缘依缘业缘是依缘非业缘是依缘报缘是起缘无也。非报缘起缘。或非报缘是起缘或非报缘非起缘。何谓非报缘是起缘。若法非报是起。是名非报缘是起缘。何谓非报缘非起缘。若法非报非起。是名非报缘非起缘

报缘是异缘无也。非报缘异缘。或非报缘是异缘。或非报缘非异缘。何谓非报缘是异缘。若法非报是共。是名非报缘是异缘。何谓非报缘非异缘。若法非报非共。是名非报缘非异缘。报缘是相续缘无也。非报缘相续缘。或非报缘是相续缘。或非报缘非相续缘。何谓非报缘是相续缘。若法非报是增长至生第三。是名非报缘是相续缘。何谓非报缘非相续缘。若法非报非增长若增长不至生第三。是名非报缘非相续缘

报缘是增上缘无也。非报缘增上缘。或非报缘是增上缘。或非报缘非增上缘。何谓非报缘是增上缘。若法非报是增上。是名非报缘是增上缘。何谓非报缘非增上缘。若法非报非增上。是名非报缘非增上缘

报缘因缘报缘。是因缘非报缘因缘。或非报缘是因缘。或非报缘非因缘。何谓非报缘是因缘。若法非报是因。是名非报缘是因缘。何谓非报缘非因缘。若法非报非因。是名非报缘非因缘

报缘无间缘。或报缘是无间缘。或报缘非无间缘。何谓报缘是无间缘。若法有报是生灭。是名报缘是无间缘。何谓报缘非无间缘。若法有报非生灭若未灭。是名报缘非无间缘。非报缘无间缘。或非报缘是无间缘。或非报缘非无间缘。何谓非报缘是无间缘。若法非报是生灭。是名非报缘是无间缘。何谓非报缘非无间缘。若法非报非生灭若未灭。是名非报缘非无间缘

报缘境界缘。或报缘是境界缘。或报缘非境界缘。何谓报缘是境界缘。若法有报有境界。是名报缘是境界缘。何谓报缘非境界缘。若法有报无境界。是名报缘非境界缘。非报缘境界缘。或非报缘是境界缘。或非报缘非境界缘。何谓非报缘是境界缘。若法非报有境界。是名非报缘是境界缘。何谓非报缘非境界缘。若法非报无境界。是名非报缘非境界缘。

报缘依缘报缘。是依缘非报缘。是依缘无也。

报缘业缘。或报缘是业缘。或报缘非业缘。何谓报缘是业缘。若法有报是业若业生。是名报缘是业缘。何谓报缘非业缘。若法有报非业若业生非业。是名报缘非业缘非报缘业缘。或非报缘是业缘。或非报缘非业缘。何谓非报缘是业缘。若法非报是业若业生业。是名非报缘是业缘。何谓非报缘非业缘。若法非报非业若业生非业。是名非报缘非业缘

起缘异缘。或起缘是异缘。或起缘非异缘。何谓起缘是异缘。若法起是共。是名起缘是异缘。何谓起缘非异缘。若法起非共。是名起缘非异缘。非起缘异缘或非起缘是异缘。或非起缘非异缘。何谓非起缘是异缘。若法非起是共。是名非起缘是异缘。何谓非起缘非异缘若法非起非共。是名非起缘非异缘

起缘是相续缘无也。非起缘相续缘。或非起缘是相续缘。或非起缘非相续缘。何谓非起缘是相续缘。若法非起是增长至生第三。是名非起缘是相续缘。何谓非起缘非相续缘。若法非增长不至生第三。是名非起缘非相续缘

起缘增上缘。或起缘是增上缘。或起缘非增上缘。何谓起缘是增上缘。若法起是增上。是名起缘是增上缘。何谓起缘非增上缘。若法起非增上。是名起缘非增上缘。非起缘增上缘。或非起缘是增上缘。或非起缘非增上缘。何谓非起缘是增上缘。若法非起是增上。是名非起缘是增上缘。何谓非起缘非增上缘。若法非起非增上。是名非起缘非增上缘。

起缘因缘起缘是因缘非起缘因缘。或非起缘是因缘。或非起缘非因缘。何谓非起缘是因缘。若法非起是因。是名非起缘是因缘。何谓非起缘非因缘。若法非起非因。是名非起缘非因缘

起缘是无间缘无也。非起缘无间缘。或非起缘是无间缘。或非起缘非无间缘。何谓非起缘是无间缘。若法非起是生灭。是名非起缘是无间缘。何谓非起缘非无间缘。若法非起非生灭若未灭。是名非起缘非无间缘。

起缘境界缘。或起缘是境界缘。或起缘非境界缘。何谓起缘是境界缘。若法起有境界。是名起缘是境界缘。何谓起缘非境界缘。若法起无境界。是名起缘非境界缘。非起缘境界缘。或非起缘是境界缘。或非起缘非境界缘。何谓非起缘是境界缘。若法非起有境界。是名非起缘是境界缘。何谓非起缘非境界缘。若法非起无境界。是名非起缘非境界缘。起缘是依缘非起缘是依缘起缘业缘。或起缘是业缘。或起缘非业缘。何谓起缘是业缘。若法起是业生业。是名起缘是业缘。何谓起缘非业缘。若法起非业若业生非业。是名起缘非业缘。非起缘业缘。或非起缘是业缘。或非起缘非业缘。何谓非起缘是业缘。若法非起是业生业。是名非起缘是业缘。何谓非起缘非业缘。若法非起非业若业生非业。是名非起缘非业缘

起缘是报。缘无也。非起缘报缘。或非起缘是报缘。或非起缘非报缘。何谓非起缘是报缘。若法非起有报。是名非起缘是报缘。何谓非起缘非报缘。若法非起非报。是名非起缘非报缘

异缘是相续缘无也。非异缘相续缘。或非异缘是相续缘。或非异缘非相续缘。何谓非异缘是相续缘。若法非共是增长至生第三。是名非异缘是相续缘。何谓非异缘非相续缘。若法非共非增长若增长不至生第三。是名非异缘非相续缘

异缘增上缘。或异缘是增上缘。或异缘非增上缘。何谓异缘是增上缘。若法共是增上。是名异缘是增上缘。何谓异缘非增上缘。若法共非增上。是名异缘非增上缘。非异缘增上缘。或非异缘是增上缘。或非异缘非增上缘。何谓非异缘是增上缘。若法非共是增上。是名非异缘是增上缘。何谓非异缘非增上缘。若法非共非增上。是名非异缘非增上缘异缘因缘。异缘是因缘。非异缘因缘。或非异缘是因缘。或非异缘非因缘。何谓非异缘是因缘。若法非共是因。是名非异缘是因缘。何谓非异缘非因缘。若法非共非因。是名非异缘非因缘

异缘是无间缘无也。非异缘无间缘。或非异缘是无间缘。或非异缘非无间缘。何谓非异缘是无间缘。若法非共是生灭。是名非异缘是无间缘。何谓非异缘非无间缘。若法非共非生灭若未灭。是名非异缘非无间缘。异缘境界缘。或异缘是境界缘。或异缘非境界缘。何谓异缘是境界缘。若法共有境界。是名异缘是境界缘。何谓异缘非境界缘。若法共无境界。是名异缘非境界缘。非异缘境界缘。或非异缘是境界缘。或非异缘非境界缘。何谓非异缘是境界缘。若法非共有境界。是名非异缘是境界缘。何谓非异缘非境界缘。若法非共无境界。是名非异缘非境界缘

异缘依缘。异缘即是依缘。非异缘是依缘。异缘业缘。或异缘是业缘。或异缘非业缘。何谓异缘是业缘。若法共是业生业。是名异缘是业缘。何谓异缘非业缘。若法共非业若业生非业。是名异缘非业缘。非异缘业缘。或非异缘是业缘。或非异缘非业缘。何谓非异缘是业缘。若法非共是业生业。是名非异缘是业缘。何谓非异缘非业缘。若法非共非业若业生非业。是名非异缘非业缘

异缘是报缘无也。非异缘报缘。或非异缘是报缘。或非异缘非报缘。何谓非异缘是报缘。若法非共有报。是名非异缘是报缘。何谓非异缘非报缘。若法非共非报。是名非异缘非报缘

异缘起缘。或异缘是起缘。或异缘非起缘。何谓异缘是起缘。若法共是起。是名异缘是起缘。何谓异缘非起缘。若法共非起。是名异缘非起缘。非异缘起缘。或非异缘是起缘。或非异缘非起缘。何谓非异缘是起缘。若法非共是起。是名非异缘是起缘。何谓非异缘非起缘。若法非共非起。是名非异缘非起缘

相续缘是增上缘无也。非相续缘增上缘。或非相续缘是增上缘。或非相续缘非增上缘。何谓非相续缘是增上缘。若法非增长若增长不至生第三是增上。是名非相续缘是增上缘。何谓非相续缘非增上缘。若法非增长若增长。不至生第三非增上。是名非相续缘非增上缘

相续缘因缘。相续缘因缘无也。非相续缘是因缘。或非相续缘是因缘。或非相续缘非因缘。何谓非相续缘是因缘。若法非增长若增长不至生第三是因。是名非相续缘是因缘。何谓非相续缘非因缘。若法非增长若增长不至生第三非因。是名非相续缘非因缘

相续缘是无间缘无也。非相续缘无间缘。或非相续缘是无间缘。或非相续缘非无间缘。何谓非相续缘是无间缘。若法非增长若增长不至生第三是生灭。是名非相续缘是无间缘。何谓非相续缘非无间缘。若法非增长若增长不至生第三非生灭若未灭。是名非相续缘非无间缘

何谓相续缘境界缘。或相续缘是境界缘。或相续缘非境界缘。何谓相续缘是境界缘。若法增长至生第三有境界。是名相续缘是境界缘。何谓相续缘非境界缘。若法增长至生第三无境界。是名相续缘非境界缘非相续缘境界缘。或非相续缘是境界缘。或非相续缘非境界缘。何谓非相续缘是境界缘。若法非增长若增长不至生第三有境界。是名非相续缘是境界缘。何谓非相续缘非境界缘。若法非增长若增长不至生第三无境界。是名非相续缘非境界缘

相续缘是依缘非相续缘是依缘

舍利弗阿毗昙论卷第二十五舍利弗阿毗昙论卷第二十六

        姚秦罽宾三藏昙摩耶舍共昙摩崛多等译

    绪分遍品之二

相续缘业缘。或相续缘是业缘。或相续缘非业缘。何谓相续缘是业缘。若法增长至生第三是业生业。是名相续缘是业缘。何谓相续缘非业缘。若法增长至生第三非业若业生非业。是名相续缘非业缘。非相续缘业缘。或非相续缘是业缘。或非相续缘非业缘。何谓非相续缘是业缘。若法非增长若增长不至生第三是业若业生业。是名非相续缘是业缘。何谓非相续缘非业缘。若法非增长若增长不至生第三非业若业生非业。是名非相续缘非业缘

相续缘是报缘无也。非相续缘报缘。或非相续缘是报缘。或非相续缘非报缘。何谓非相续缘是报缘。若法非增长若增长不至生第三有报。是名非相续缘是报缘。何谓非相续缘非报缘。若法非增长若增长不至生第三非报。是名非相续缘非报缘

相续缘是起缘无也。非相续缘起缘。或非相续缘是起缘。或非相续缘非起缘。何谓非相续缘是起缘。若法非增长若增长不至生第三。是名非相续缘是起缘。何谓非相续缘非起缘。若法非增长若增长若不至生第三非起。是名非相续缘非起缘

相续缘是异缘无也。非相续缘异缘。或非相续缘是异缘。或非相续缘非异缘。何谓非相续缘是异缘。若法不增长若增长不至生第三是共。是名非相续缘是异缘。云何非相续缘非异缘。若法非增长若增长不至生第三非共。是名非相续缘非异缘

增上缘因缘。或增上缘是因缘。或增上缘非因缘。何谓增上缘是因缘。若法胜是因。是名增上缘是因缘。何谓增上缘非因缘。若法胜非因。是名增上缘非因缘。非增上缘因缘。或非增上缘是因缘。或非增上缘非因缘。何谓非增上缘是因缘。若法非胜是因。是名非增上缘是因缘。何谓非增上缘非因缘。若法非胜非因。是名非增上缘非因缘

增上缘是无间缘无也。非增上缘无间缘。或非增上缘是无间缘。或非增上缘非无间缘。何谓非增上缘是无间缘。若法非胜是生灭。是名非增上缘是无间缘。何谓非增上缘非无间缘。若法非胜非生灭若未灭。是名非增上缘非无间缘

增上缘境界缘。或增上缘是境界缘。或增上缘非境界缘。何谓增上缘是境界缘。若法胜有境界。是名增上缘是境界缘。何谓增上缘非境界缘。若法胜无境界。是名增上缘非境界缘。非增上缘境界缘。或非增上缘是境界缘。或非增上缘非境界缘。何谓非增上缘是境界缘。若法非胜有境界。是名非增上缘是境界缘。何谓非增上缘非境界缘。若法非胜无境界。是名非增上缘非境界缘

增上缘依缘。增上缘是依缘。非增上缘是依缘

增上缘业缘。或增上缘是业缘。或增上缘非业缘。何谓增上缘是业缘。若法胜是业生业。是名增上缘是业缘。何谓增上缘非业缘。若法胜非业若业生非业。是名增上缘非业缘。非增上缘业缘。或非增上缘是业缘。或非增上缘非业缘。何谓非增上缘是业缘。若法非胜是业生业。是名非增上缘是业缘。何谓非增上缘非业缘。若法非胜非业若业生非业。是名非增上缘非业缘

增上缘是报缘无也。非增上缘报缘。或非增上缘是报缘。或非增上缘非报缘。何谓非增上缘是报缘。若法非胜有报。是名非增上缘是报缘。何谓非增上缘非报缘。若法非胜无报。是名非增上缘非报缘

增上缘起缘。或增上缘是起缘。或增上缘非起缘。何谓增上缘是起缘。若法胜是起。是名增上缘是起缘。何谓增上缘非起缘。若法胜非起。是名增上缘非起缘。非增上缘起缘。或非增上缘是起缘。或非增上缘非起缘。何谓非增上缘是起缘。若法非胜是起。是名非增上缘是起缘。何谓非增上缘非起缘。若法非胜非起。是名非增上缘非起缘

增上缘异缘。或增上缘是异缘。或增上缘非异缘。何谓增上缘是异缘。若法胜是共。是名增上缘是异缘。何谓增上缘非异缘。若法胜非共。是名增上缘非异缘。非增上缘异缘。或非增上缘是异缘。或非增上缘非异缘。何谓非增上缘是异缘。若法非胜是共是名非增上缘是异缘。何谓非增上缘非异缘。若法非胜非共。是名非增上缘非异缘

增上缘是相续缘无也。非增上缘相续缘。或非增上缘是相续缘。或非增上缘非相续缘。何谓非增上缘是相续缘。若法非胜是增长至生第三。是名非增上缘是相续缘。何谓非增上缘非相续缘。若法非胜非增长若增长不生至第三。是名非增上缘非相续缘

善法。不善法。无记法。善不善法。善无记法。不善无记法。善不善无记法

缘善法生善法。生不善法。生无记法。生善不善法。生善无记法。生不善无记法。生善不善无记法。缘不善法生善法。生不善法。生无记法。生善不善法。生善无记法。生不善无记法。生善不善无记法。缘无记法生善法。生不善法生无记法。生善不善法。生善无记法。生不善无记法。生善不善无记法。缘善不善法生善法。生不善法。生无记法。生善不善法。生善无记法。生不善无记法。生善不善无记法。缘善无记法生善法。生不善法。生无记法。生善不善法。生善无记法。生不善无记法。生善不善无记法。缘不善无记法生善法。生不善法。生无记法。生善不善法。生善无记法。生不善无记法。生善不善无记法。缘善不善无记法。生善法。生不善法。生无记法。生善不善法。生善无记法。生不善无记法。生善不善无记法

    舍利弗阿毗昙论绪分因品第二

因有因由因生法。谓因义因有四事。当知一切有为法有因义。绪集诸因正门

因因。无间因。境界因。依因。业因。报因。起因。异因。相续因。增上因。名因。色因。无明因。行因。识因。名色因。六入因。触因。受因。爱因。取因。有因。生因。老因。死因。忧因。悲因。苦因。恼因。众苦因。食因。漏因。复有因

非因因。非无间因。非境界因。非依因。非业因。非报因。非起因。非异因。非相续因。非增上因。非名因。非色因。非无明因。非行因。非识因。非名色因。非六入因。非触因。非受因。非爱因。非取因。非有因。非生因。非老因。非死因。非忧因。非悲因。非苦因。非恼因。非众苦因。非食因。非漏因。非复有因

何谓因因。若法因。是法因。是名因因。何谓无间因。若法过去现在因。是名无间因。何谓境界因。一切法境界如事因若有因法因。是名境界因。何谓依因。一切法是因。若有为法因。是名依因。何谓业因。若法身口意业因。是名业因。何谓报因。若法受及善报因。是名报因。何谓起因。若法起因。是名起因。何谓异因。若法共因。是名异因。何谓相续因。若法增长因。是名相续因。何谓增上因。若法胜因。是名增上因。何谓名因。一切忆想假称制名。是谓名因。复次由忆想假称生受想思触思惟。是谓名。复次触首五法受想思触思惟。是谓名。复次若法非色有为。是谓名。若如是法因。是名名因。云何色因。若法色是谓色。复次十色入及法入色。是谓色。复次四大及四大造色。是谓色。复次色有三种。可见有对。不可见有对。不可见无对。是谓色。若如是法因。是名色因。云何无明因。若痴不善根法因。是名无明因。云何行因。身行口行意行此谓行。复次福行非福行不动行此谓行。复次五受阴此谓行。复次行阴此谓行。若如是法因。是名行因。云何识因。眼识身耳鼻舌身意识身因。是名识因。云何法色因。若忆想假称制名此谓名。若法色此谓色。复次若由忆想假称制名。生受想思触思惟此谓名。十色入及法入色此谓色。复次触首五法此谓名。四大及四大造色此谓色。复次若法非色有为此谓名。色有三种。可见有对。不可见有对。不可见无对。若如是名色法。是谓名色因。云何六入因。若眼入耳鼻舌身意入法因。是名六入因。云何触因。若眼触耳鼻舌身意身触触法因。是名触因。云何受因。若苦受乐受不苦不乐受法因。是名受因。云何爱因。若欲爱有爱断爱法因。是名爱因。云何取因。若欲取见取戒取我取法因。是名取因。云何有因。若欲有色有无色有法因。是名有因。云何生因。若诸众生中生正生入胎出阴成就阴入法因。是名生因。云何老因。若诸众生中头白齿落皮皱身体战掉诸根衰熟行朽命促法因。是名老因。云何死因。若诸众生中终没死丧时过阴舍身形于彼变异离本身众法因。是名死因。云何忧因。若众生为种种苦逼。若忧重忧究竟忧。若内燋热忧悴此法因是名忧因。云何悲因。众苦若众生忧为忧所逼忧箭入心。若追忆啼哭狂言口教法因。是名悲因。云何苦因。若身不忍受苦。眼触苦受耳鼻舌身触苦受法因。是名苦因。云何恼因。若心不忍受苦。意触苦受法因。是名恼因。云何众苦因若身心苦重苦究竟苦心恼乱法因。是名众苦因。云何食因。有四种食。揣食粗细触食意思食识食。如是法因。是名食因。云何漏因。欲漏有漏无明漏法因。是名漏因。云何复有因。若法初阴界入法因。是名复有因

云何非因因。若法非因。是名非因因。云何非无间因。若法非无间因。是名非无间因。云何非境界因。无非境界因无非依因。云何非业因。若法非业因。是名非业因。云何非报因。若法非报因。是名非报因。云何非起因。若法非起因。是名非起因。云何非异因。若法非共因。是名非异因。云何非相续因。若法非增长因。是名非相续因。云何非增上因。若法非胜因。是名非增上因。云何非名因。若法非名因。是名非名因。云何非色因。若法非色因。是名非色因。云何非无明因。若法非无明因。是名非无明因。云何非行因。若法非行因。是名非行因。云何非识因。若法非识因。是名非识因。云何非名色因。若法非名色因。是名非名色因。云何非六入因。若法非六入因。是名非六入因。云何非触因。若法非触因。是名非触因。云何非受因。若法非受因。是名非受因。云何非爱因。若法非爱因。是名非爱因。云何非取因。若法非取因。是名非取因。云何非有因。若法非有因。是名非有因。云何非生因。若法非生因。是名非生因。云何非老因。若法非老因。是名非老因。云何非死因。若法非死因。是名非死因。云何非忧因。若法非忧因。是名非忧因。云何非悲因。若法非悲因。是名非悲因。云何非苦因。若法非苦因。是名非苦因。云何非恼因。若法非恼因。是名非恼因。云何非众苦因。若法非众苦因。是名非众苦因。云何非食因。若法非食因。是名非食因。云何非漏因。若法非漏因。是名非漏因。云何非复有因。若法非初阴界入因。是名非复有因

因法非有因。有因法。非因。因有因法。非因非有因法。因法非和合因和合因法。非因因因和合法。非因亦非和合因法

云何因法非有因。因法无非因。复次善根不善根专敬结。是名因法非有因

云何有因法非因。若法非因有为。是名有因法非因

云何因有因法。除善根不善根专敬结。若余法是名因有因法

云何非因非有因法。除因有因法若余法。是名非因非有因法。因法非和合因和合因法。非因因和合法。非因亦非和合因法亦如是。前因法非共因。共因法非前因。前因共因法。亦非前因非共因法。前因法非后因。后因法非前因。前因后因法。亦非前因非后因法。共因法非后因。后因法非共因。共因后因法。亦非共因非后因法

云何前因法非共因。若法生是前因非共因。是名前因法非共因

云何共因法非前因。若法生是共因非前因。是名共因法非前因

云何前因共因法。若法生是前因共因。是名前因共因法

云何非前因非共因法。除前因共因法若余法。是名非前因非共因法。复次前因法非共因。若法初生非报。是名前因法非共因

云何共因法非前因。若法非因有为。是名共因法非前因

云何前因共因法。除初生非报。若余共法。是名前因共因法

云何非前因非共因法。除前因共因法若余法。是名非前因非共因法。前因法非后因。后因法非前因。前因后因法。非前因非后因法亦如是

云何共因法非后因。若法生是共因非后因。是名共因法非后因

云何后因法非共因。后因生法即是共因。复次得初禅已得第二禅。得后因初禅清净游力尊自在。得第二禅已得第三禅。得后因二禅清净游。力尊自在。得第三禅已。得第四禅。得后因三禅清净游力尊自在。若菩萨得通明已当觉彼通明时。便生后因观达无边。得神足住寿。便生后因。若住一劫若劫余。是名后因法非共因

云何共因后因法。若法生是共因后因。是名共因后因法

云何非共因非后因法。除共因后因法若余法。是名非共非后因法(因非因解各三十二句此最后二四句)

    舍利弗阿毗昙论绪分名色品第三

有人出世。名如来无所著等正觉。说名色。解射名色。断名色。云何名色。若忆想假称制名此谓名。何谓色。若法色此谓色。复次由忆想假称生受想思触思惟。此谓名。十色入及法入色此谓色。复次触首五法此谓名。四大及四大造此谓色。复次若法非色有为此谓名。色有三种。可见有对。不可见有对。不可见无对。此谓色。如是名色。是谓名色。何故说名色。欲令此名色应正说开解分别显现假称是故说名色。云何解射名色。若于名色知见解射方便。是名解射名色。云何断名色。若于名色调伏欲染断欲染。是名断名色。今当集名色正门

因起报共增上依食。长养持微摄所依所须。始胎住住处。生道所向。津液遍满。不调不坚不护不摄不修。调坚护摄修。不解不证不断不尽不灭。解证断尽灭。喜处忧处舍处。善不善无记。学无学。非学非无学。报报法非报非报法。见断思惟断。非见断非思惟断。见断因。思惟断因。非见断因。非思惟断因。欲界系色界系无色界系不系。过去未来现在。此谓名色正门

因谓因缘。起谓因缘。报谓因缘。共谓因缘。增上谓依缘。依谓因缘。食谓依缘。长养持微摄所依所须亦如是。始胎谓因缘。住处谓依缘。生谓因缘。道谓因缘。求向谓因缘。津谓依缘。液遍满亦如是。不调谓不知世间不断世间。不坚不护不摄不修亦如是。调谓知世间断世间。坚护摄修亦如是。不解谓未智知。未以断智知。不证谓未证知见。不断谓未系断。不尽谓未究竟尽。不灭谓未智缘灭。非智缘灭。解谓智知断智知。证谓知见断。断谓暂断。尽谓究竟尽。灭谓智缘灭。非智缘灭尽。喜处谓喜起因及受报。忧处谓忧起因及受报。舍处谓舍起因及受报。善谓所修名色。不善谓所断名色。无记谓所受名色及非报法。学谓圣名色非无学。无学谓圣名色非学。非学非无学谓非圣名色。报谓受名色及善报。报法谓有报名色。非报非报法谓名色无记非我分摄。见断谓名色不善。非思惟断。思惟断谓名色不善非见断。非见断非思惟断。谓名色若善若无记。见断因谓名色若见断若见断法报。思惟断因谓名色若思惟断若思惟断法报。非见断非思惟断因。谓名色若善若善法报。若非报非报法。欲界系谓名色若欲漏有漏。色界系谓名色若色漏有漏。无色界系谓名色若无色漏有漏。不系谓名色若圣无漏。过去谓名色已生已灭。未来谓名色未生未出。现在谓名色生未灭

名名因。名色因。名名色因。色名因。色色因。色名色因。名色名因。名色色因。名色名色因。名起。名名起。色名起。名色色起。名色起。色色起。名色名色起。名名色起。色名色起。名色

名名报。名色报。名名色报。色名报。色色报。色名色报。名色名报。名色色报。名色名色报。名共名名共色。名共名色。色共名色共色。色共名色。名色共名。名色共色。名色共名色

名名增上。名色增上。名名色增上。色名增上。色色增上。色名色增上。名色名增上。名色色增上。名色名色增上

名依名名依色。名依名色色依名。色依色色依名色。名色依名。名色依色。名色依名色

名名食名色食。名名色食。色名食。色色食。色名色食。名色名食。名色色食。名色名色食。长养持微摄所依所须亦如是

名名始胎。名色始胎。名名色始胎。色名始胎。色色始胎。色名色始胎。名色名始胎。名色色始胎。名色名色始胎。住处亦如是

名生名名生色。名生名色。色生名色生色。色生名色。名色生名。名色生色。名色生名色名名道名色道。名名色道。色名道。色色道。色名色道。名色名道。名色色道。名色名色道所向亦如是

名名津名色津。名名色津。色名津。色色津。色名色津。名色名津。名色色津。名色名色津。液遍满亦如是

名不调名不调。名不调色不调。名不调名色不调。色不调名不调。色不调色不调。色不调名色不调。名色不调名不调。名色不调色不调。名色不调名色不调。不坚不护不摄不修亦如是。名调名调。名调色调。名调名色调。色调名调。色调色调。色调名色调。名色调名调。名色调色调。名色调名色调。坚护摄修亦如是

名未解名未解。名未解色未解。名未解名色未解。色未解名未解。色未解色未解。色未解名色未解。名色未解名未解。名色未解色未解。名色未解名色未解。未证未断未尽未灭。亦如是

名解名解。名解色解。名解名色解。色解名解色解。色解色解名色解。名色解名解名色解。色解名色解名色解。证断尽灭亦如是

缘喜处名生喜处名。喜处色喜处名色。缘喜处色生喜处名。喜处色喜处名色。缘喜处名色生喜处名。喜处色喜处名色。忧处舍处亦如是

    舍利弗阿毗昙论绪分假结品第四

结诸使根。诸烦恼行习微气行结未灭未尽。转受生老死众苦聚集。今当集假结正门。十结十二入十八界五阴。四谛二十二根。五道三界法人人法

云何十结。见结疑结戒道结。欲染结嗔恚结色染结无色染结。无明结慢结掉结。云何见结。若见烦恼非心相应。不共心生不共住不共灭。由是因缘故生见使。是名见结。乃至若掉烦恼非心相应。不共心生不共住不共灭。由是因缘故生掉使。是名掉结。复次于在所处眠没微细坚着。由是因缘故生见使。是名见结。乃至于在所处眠没微细坚着。由是因缘故生掉使。是名掉结。十二入十八界五阴。四谛二十二根三界。如上说。云何五道。地狱畜生饿鬼人天。云何地狱。无间有间。是名地狱。云何畜生。水陆空行。是名畜生。云何饿鬼。少食无食等。是名饿鬼。云何人。四天下人。是名人。云何天。欲色无色天。是名天。云何法。色法非色法。乃至过去法未来法现在法。非过去非未来非现在法。是谓法。云何人。未生智人。欲界未竟色界未竟无色界未竟。已生智人。欲界未竟色界无色界未竟。复次已生智人。欲界已竟。色界无色界未竟。是谓人。如是法如是人。是谓法人人法

十结几见断。几思惟断。三见断。七二分或见断。或思惟断。云何三见断。见疑戒道。是名三见断。云何七二分或见断或思惟断。欲染嗔恚色染无色染无明慢掉。是名七二分或见断或思惟断

十结几见断。一切见断。几思惟断。七思惟断。除见疑戒道

十结几欲界系。几色界系。几无色界系。二欲界系。一色界系。一无色界系。一二分或欲界系或色界系。五三分或欲界系。或色界系。或无色界系。何等二欲界系。欲染嗔恚。此二欲界系。何等一色界系。色染此一色界系。何等一无色界系。无色染此一无色界系。何等一二分或欲界系或色界系。戒道此一二分或欲界系。或色界系。何等五三分或欲界系或色界系或无色界系。见疑无明慢掉。此五三分或欲界系或色界系或无色界系

十结几欲界系。八除色染无色染。十结几色界系。七除欲染嗔恚无色染。十结几无色界系六谓见疑无色染无明慢掉

欲界系结。几见断。几思惟断。三见断。五二分或见断或思惟断。何等三见断。见疑戒道此三见断。何等五二分或见断或思惟断。欲染嗔恚无明慢掉。此五二分或见断或思惟断。八欲界系结几见断。一切见断。几思惟断。五思惟断。除见疑戒道。七色界系结。几见断几思惟断。三见断。四二分或见断或思惟断。何等三见断。见疑戒道。此三见断。何等四二分或见断或思惟断。色染无明慢掉。此四二分或见断或思惟断。七色界系结几见断。一切见断。几思惟断。四思惟断。除见疑戒道。六无色界系结几见断。几思惟断。二见断。四二分或见断或思惟断。何等二见断。见疑此二见断。何等四二分或见断或思惟断。无色染无明慢掉。此四二分或见断或思惟断。六无色界系结几见断。一切见断。几思惟断。四思惟断。谓无色染无明慢掉

见结眠没。几结中眠没。八结中除自性及疑眠没。九结中除自性戒道结不眠没诸结欲染结眠没。五结中见戒道无明慢掉嗔恚结眠没。六结中见疑戒道无明慢掉色染结眠没。五结中见戒道无明慢掉无色染结眠没。四结中见无明慢掉无明结眠没。九结中除自性慢掉结亦眠没。九结除自性

几结眠没。见结中八。除自性及戒道。四结眠没疑结中嗔恚无明慢掉。八结眠没。戒道中除自性及无色染五结眠没。欲染结中见疑无明慢掉五结眠没。嗔恚结中见结疑无明慢掉。五结眠没。色染结中见结疑无明慢掉。五结眠没。无色染结中见结疑无明慢掉。八结眠没。无明结中除自性及戒道。八结亦眠没。慢掉结中除自性及戒道

八结眠没眼入耳入。除戒道及无色染。七结眠没鼻入舌入。除戒道色染无色染。八结眠没身入。除戒道无色染。九结眠没意入。中除戒道。九结眠没色入声入。除无色染。七结眠没香味入。除戒道色染无色染。八结眠没于触入。除戒道无色染。十结眠没法入

八结眠没眼界耳界。除戒道无色染。七结眠没鼻界舌界。除戒道色染无色染。八结眠没于身界。除戒道无色染。九结眠没色界声界。除无色染。七结眠没香界味界。除戒道色染无色染。八结眠没触界。除戒道无色染八结眠没眼识界耳识界。除戒道无色染。七结眠没。鼻识界舌识界。除戒道色染无色染。八结眠没身界。除戒道无色染。九结眠没意界意识界。除戒道。十结眠没法界

十结眠没色阴。九结眠没受想行识阴。除戒道。十结眠没苦谛。五结眠没集谛。见疑无明慢掉。灭道谛无也

八结眠没眼根耳根。除戒道无色染。七结眠没鼻根舌根。除戒道色染无色染。八结眠没身根。除戒道无色染。七结眠没男根女根。除戒道色染无色染。九结眠没命根。除戒道。七结眠没乐根。除戒道嗔恚无色染。六结眠没苦根。见疑嗔恚无明慢掉。七结眠没喜根。除戒道嗔恚无色染。六结眠没忧根。疑嗔恚无明慢掉。八结眠没舍根。除戒道嗔恚。九结眠没意根。除戒道。诸圣根无也

地狱或六或七。六结眠没无间地狱。见疑嗔恚无明慢掉。七结眠没有间地狱。见疑欲染嗔恚无明慢掉。八结眠没畜生。除色染无色染。八结眠没饿鬼。除色染无色染。八结眠没人。除色染无色染。十结眠没诸天。八结眠没欲界天。除色染无色染。七结眠没色界天。除欲染嗔恚无色染。六结眠没无色界天。见疑无色染无明慢掉八。结眠没欲界除。色染无色染七。结眠没色界除。欲染嗔恚无色染。六结眠没无色界。见疑无色染无明慢掉

十结眠没色法。九结眠没。非色法。除戒道。九结眠没可见法。除无色染。十结眠没不可见法。九结眠没有对法。除无色染。十结眠没无对法。圣法无也。十结眠没非圣法。十结眠没有漏法。无漏法无也。有染法十。无染法无。有求法十。无求法无。当取法十。非当取法无。有取法十。无取法无。有胜法十。无胜法无。九结眠没受法。除戒道。十结眠没非受法。九结眠没内法。除戒道。十结眠没外法。十结眠没有报法。十结眠没无报法。九结眠没心法。除戒道。十结眠没非心法。九结眠没心相应法。除戒道。十结眠没非心相应法。九结眠没心数法。除戒道。十结眠没非心数法。九结眠没有缘法。除戒道。十结眠没无缘法。十结眠没共心法。十结眠没不共心法。随心转法不随心转法亦如是。十结眠没业法。非业法亦如是。九结眠没业相应法。除戒道。十结眠没非业相应法。十结眠没共业法。十结眠没非共业法。随业转法不随业转法亦如是。十结眠没因法。十结眠没非因法。十结眠没有因法。无因法无也。有绪法无绪法。有缘法无缘法。有为法无为法亦如是。十结眠没知法。十结眠没非知法。识法非识法。解法非解法了法非了法亦如是。九结眠没断智知法。除戒道。十结眠没非断智知法。断法非断法亦如是。十结眠没修法。十结眠没非修法。十结眠没证法。十结眠没非证法。十结眠没善法。九结眠没不善法。除戒道。十结眠没无记法。学法无学法无也。十结眠没非学非无学法。十结眠没报法。十结眠没报法法。十结眠没非报非报法法。九结眠没见断法。除戒道。九结眠没思惟断法。除戒道。十结眠没非见断非思惟断法。九结眠没见断因法。除戒道。九结眠没思惟断因法。除戒道。十结眠没非见断非思惟断因法。八结眠没欲界系法。除色染无色染。七结眠没色界系法。除欲染嗔恚无色染。六结眠没无色界系法。见疑无色染无明慢掉。不系法无也。十结眠没过去法。十结眠没未来法。十结眠没现在法。非过去非未来非现在法无也

未生智人。欲界未竟。色界未竟。无色界未竟。几结眠没十。欲界八。除色染无色染。色界七。除欲染嗔恚无色染。无色界六。见疑无色染无明慢掉

已生智人。欲界未竟。色界未竟。无色界未竟。几结眠没七。欲界五。除色染无色染。色界四。色染无明慢掉。无色界四。无色染无明慢掉。复有生智人欲界已竟色界未竟无色界未竟。几结眠没。五欲界疑。色界四。色染无明慢掉。无色界四。无色染无明慢掉

未生智人。欲界未竟。色界未竟。无色界未竟。几结眠没。见结中八。除自性及戒道。四结眠没疑中。嗔恚无明慢掉。八结眠没戒道。除自性及无色染五结眠没欲染结。见疑无明慢掉。五结眠没嗔恚结中。见疑无明慢掉。五结眠没色染结中。见疑无明慢掉。五结眠没无色染结中。见疑无明慢掉。八结眠没无明结中。除自性及戒道。八结亦眠没慢掉结中。除自性及戒道。八结眠没眼入耳入中。除戒道及无色染。从鼻入舌入。乃至过去未来现在。亦如上说。非过去非未来非现在无也

生智人欲界未竟。色界未竟。无色界未竟。几结眠没。见结中无也。疑戒道亦无。三结眠没欲染结中。无明慢掉。三结眠没嗔恚结中。无明慢掉。三结眠没色染结中。无明慢掉。三结眠没无色染结中。无明慢掉。六结眠没无明结中。除自性。六结眠没慢掉结。除自性。六结眠没眼入耳入。除无色染。五结眠没鼻入舌入。除色染无色染。六结眠没身入。除无色染。七结眠没意入。六结眠没色入声入。除无色染。五结眠没香入味入。除色染无色染。六结眠没触入。除无色染。七结眠没法入。六结眠没眼界耳界。除无色染。五结眠没鼻界舌界。除色染无色染。六结眠没身界。除无色染。六结眠没色界声界。除无色染。五结眠没香界味界。除色染无色染。六结眠没触界。除无色染。六结眠没眼识界耳识界。除无色染五结眠没鼻识界舌识界。除色染无色染。六结眠没身识界。除无色染。七结眠没意界意识界法界。七结眠没色阴。受想行识阴亦如是。七结眠没苦谛。三结眠没集谛无明慢掉。灭谛道谛无也。六结眠没眼根耳根。除无色染。五结眠没鼻根舌根。除色染无色染。六结眠没身根。除无色染。五结眠没男根女根。除色染无色染。七结眠没命根。五结眠没乐根。除嗔恚结无色染。四结眠没苦根。嗔恚无明慢掉。五结眠没喜根。除嗔无色染。四结眠没忧根。嗔恚无明慢掉。六结眠没舍根。除嗔恚。七结眠没意根。圣根无也。地狱畜生饿鬼无也。五结眠没人中。除色染无色染。天上通七结。五结眠没欲界天。除色染无色染。四结眠没色界天。色染无明慢掉。四结眠没无色界天。无色染无明慢掉。五结眠没欲界。除色染无色染。四结眠没色界。色染无明慢掉。四结眠没无色界。无色染无明慢掉。七结眠没色法。非色法亦如是。六结眠没可见法。除无色染。七结眠没不可见法。六结眠没有对法。除无色染。七结眠没无对法。圣法无。七结眠没非圣法。有漏法七。无漏法无。有染法七无染法无。有求法七无求法无。当取法七非当取法无。有取法七无取法无。有胜法七无胜法无。受法七非受法七。内法七外法七。有报法七无报法七。心法七非心法七。心相应法七非心相应法七。心数法七非心数法七。有缘法七无缘法七。共心法七非共心法七。随心转法七不随心转法七。业法七非业法七。业相应法七非业相应法七。共业法不共业法七。随业转法七不随业转法七。因法七非因法七。有因法七无因法七。有绪法七无绪法七。有缘法七无缘法七。有为法七无为法七。知法七非知法七。识法七非识法七。解法七非解法七。了法七非了法七。断智知法七非断智知法七。断法非断法亦如是七。修法七不修法七。证法七非证法七。善法七不善法七。无记法七。学法无学法无非学非无学法七。报法七报法法七。非报法非报法法七。见断法无思惟断法七。非见断非思惟断法七。见断因法无思惟断因法七。非见断非思惟断因法七。欲界系法五。除色染无色染。色界系法四。色染无明慢掉。无色界系法四。无色染无明慢掉。不系法无。过去法七未来法七现在法七。非过去非未来非现在无也

生智人欲界已竟。色界未竟。无色界未竟。几结眠没。见结中无也。疑戒道欲染嗔恚无也。三结眠没色染结中。无明慢掉。三结眠没无色染。无明慢掉。四结眠没无明结。除自性。四结眠没慢掉结。除自性。四结眠没眼入耳入。除无色染。鼻入舌入无。四结眠没身入。除无色染。五结眠没意入。四结眠没色入声入。除无色染。香入味入无四。结眠没触入除。无色染五结眠没法入。四结眠没眼界耳界。除无色染。鼻界舌界无。四结眠没身界。除无色染。四结眠没色界声界。除无色染。鼻界舌界无。四结眠没触界。除无色染。四结眠没眼识界耳识界。除无色染。鼻识界舌识界无四。结眠没身识界。除无色染。五结眠没意界意识界法界。五结眠没色阴。受想行识阴亦如是。五结眠没苦谛。三结眠没集谛。无明慢掉。灭谛道谛无。四结眠没眼根耳根。除无色染。鼻根舌根无。四结眠没身根。除无色染。男根女根无。五结眠没命根。四结眠没乐根喜根。除无色染。苦根忧根无。五结眠没舍根喜根。诸无漏根无。地狱畜生饿鬼人中无。五结眠没通天上。欲界天无。四结眠没色天上。除无色染。四结眠没无色天上。除色染。欲界无。四结眠没色界。除无色染。四结眠没无色界。除色染。四结眠没色法。无色法亦如是。四结眠没可见法。除无色染。五结眠没不可见法。四结眠没有对法。除无色染。五结眠没无对法中。圣法无非圣。有漏法五无漏法无。有染法五无染法无。有求法五无求法无。当取法五非当取法无。有取法五无取法无。有胜法五无胜法无。受法五非受法五。内法五外法五。有报法五无报法五。心法五非心法五。心相应法五心不相应法五。心数法五非心数法五。有缘法五无缘法五。共心法五不共心法五。随心转法五不随心转法五。业法五非业法五。业相应法五非业相应法五。共业法五非共业法五。随业转法五不随业转法五。因法五非因法五。有因法五无因法五。有绪法五无绪法五。有为法五无为法五。知法五非知法无。识法非识法。解法非解法。了法不了法。亦如是。断智知法五。非断智知法五。断法非断法亦如是。五修法五非修法五。证法五非证法五。善法五不善法五。无学法五学法五。非学非无学法五。解法五报法法五。非报非报法法五。见断法无思惟断法五。非见断非思惟断法五。见断因法无思惟断因法五。非见断非思惟断因法五。欲界系法无色界系法四。除无色染。色界系法四。除色染。不系法无。过去法五未来法五。现在法五。非过去非未来非现在法无

舍利弗阿毗昙论卷第二十六舍利弗阿毗昙论卷第二十七

        姚秦罽宾三藏昙摩耶舍共昙摩崛多等译

    绪分假结品之二

若人眠没见疑戒道结中。此人有几结。有十。若人眠没欲染嗔恚结中。此人有几结。或十或七。若人眠没色染无色染无明慢掉结中。此人有几结。或十或五。若见结疑结眠没法中。此法中有几结。或十或九或八或七或六或五。若戒道结眠没法中。此法中有几结。或十或九或八或七。若欲染结眠没法中。此法中有几结。或十或九或八或七或六。若嗔恚结眠没法中。此法中有几结。或十或九或八或七或六或五。若色染无色染结眠没法中。此法中有几结。或十或九或八或七或六。若无明慢掉结眠没法中。此法中有几结。或十或九或八或七或六或五或四(法人竟)

若见结疑眠没人法中。此人法有几结。或十或九或八或七或六或五。若戒道结眠没人法中。此人法有几结。或十或九或八或七。若欲染结眠没人法中。此人法有几结。或十或九或八或七或六。若嗔恚结眠没人法中。此人法有几结。或十或九或八或七或六或五或四。若色染无色染结眠没人法中。此人法有几结。或十或九或八或七或六。若无明结慢掉结眠没人法中。此人法有几结。或十或九或八或七或六或五或四

若欲终非欲终终非终欲生非欲生生非生。欲终谓最后心。非欲终谓除最后心。终谓最后心。非终谓在此阴。欲生谓初心。非欲生谓除初心。生谓在此阴。非生谓未在此阴。如是地狱畜生饿鬼人中天上。欲界色界无色界。若众生于地狱中欲终眠没几结中。若众生于地狱中非欲终。眠没几结中。若众生于地狱中终。眠没几结。若众生于地狱中非终眠没几结中。若众生于地狱中始生。眠没于几结。若众生于地狱中非始生。眠没几结。若众生于地狱中生。眠没几结。若众生于地狱中非生。眠没几结。畜生饿鬼人中天上欲界色界无色界亦如是

若众生于地狱中欲终。始生畜生眠没几结。若众生于地狱中欲终。非始生畜生中眠没几结。若众生于地狱中欲终。生畜生中眠没几结。若众生于地狱中欲终。非生畜生中眠没于几结。若众生于地狱中非欲终。始生畜生时眠没几结。若众生于地狱中非欲终。非始生畜生中眠没几结。若众生于地狱中非欲终。生畜生中眠没几结。若众生于地狱中非欲终。始非生畜生眠没几结。若众生于地狱中终。始生畜生中眠没几结。若众生于地狱中终。非始生畜生中眠没几结。若众生于地狱中终。生畜生中眠没几结。若众生于地狱中终。非生畜生中眠没几结。若众生于地狱中非终。非始生畜生中眠没几结。若众生于地狱中非终。非始生畜生中眠没几结。若众生于地狱中非终。非生畜生中眠没几结。从地狱至饿鬼。从地狱至人中。从地狱至天上亦如是。从畜生至饿鬼。从畜生至人中。从畜生至天上。从畜生至地狱。从饿鬼至人中。从饿鬼至天上。从饿鬼至地狱。从饿鬼至畜生。从人中至天上。从人中至地狱。从人中至畜生。从人中至饿鬼。从天上至地狱。从天上至畜生。从天上至饿鬼。从天上至人中。从欲界至色界。从欲界至无色界。从色界至无色界。从色界至欲界。从无色界至欲界。从无色界至色界亦如是

    舍利弗阿毗昙论绪分行品第五

身行口行意行地。云何身行。谓出入息。是名身行。云何口行。谓觉观。是名口行。云何意行。谓想思。是名意行。身行地。从有出入息身乃至第四禅。是名身行地。云何非身行地。从非出入息身第四禅若过。是名非身行地。云何口行地。欲界意识。若色界不定。若初禅及初禅间。是名口行地。云何非口行地。五识身若二禅若过。是名非口行地。云何意行地。除二定及一生若余处。是名意行地。云何非意行地。二定及一生。是名非意行地。身行于何处生不灭。从非出入息身至有出入息身。若于第四禅起。于此处身行生不灭。身行于何处灭不生。从出入息身至非出入息身。若入第四禅。于此处身行灭不生。身行于何处生灭。若有出入息处。于此处身行生灭。身行于何处行不生不灭。于非出入息身中。若第四禅若过。是名身行不生不灭。口行于何处生不灭。从离五识身至意识。从第二禅起。于此处口行生不灭。口行于何处灭不生。从离意识至五识身。若入第二禅。于此处口行灭不生。口行于何处生灭。若有觉观处。于此处口行生灭。口行于何处。不生不灭。于五识身中若第二禅若过。于此处口行不生不灭。意行于何处生不灭。于二定起。若一生处命终。于此处意行生不灭。意行于何处灭不生。若入二定及一生处。于此处意行灭不生。意行于何处生灭。若意行于此处意行生灭。意行于何处不生不灭。若于二定至一生处是。于此处意行不生不灭

    舍利弗阿毗昙论绪分触品第六

愚者无明覆。爱烦恼和合。由是法故聚集成身。彼名色缘二法生触。今当集假触正门

身触心触乃至十八触。是名触法

云何身触。若触身识相应。是名身触。云何心触。若触意识相应。是名心触。复次若五识相应眼耳鼻舌身识。是名身触。若心意识相应是名心触

云何名触。若触心触。是名名触。云何对触。若触身触。是名对触

云何爱触。若触欲染相应。是名爱触。云何恚触。若触恼相应。是名恚触。云何明触。若触圣智相应。是名明触。云何无明触。若触不善非智相应。是名无明触。云何明分触若触明分生明能令广大。是名明分触。云何无明分触。若触无明分生无明能令广大。是名无明分触。复次若触圣忍相应。是名明分触。若触非圣烦恼相应。是名无明分触。复次若触圣得智果。是名明分触。若触非圣若善无记。是名无明分触

云何圣触。若触无漏。是名圣触。云何非圣触。若触有漏。是名非圣触

云何有漏触。若触有染。是名有漏触。云何无漏触。若触无染。是名无漏触

云何有染触。若触有求。是名有染触。云何无染触。若触无求。是名无染触

云何有求触。若触当取。是名有求触。云何无求触。若触非当取。是名无求触

云何当取触。若触有取。是名当取触。云何非当取触。若触无取。是名非当取触

云何有取触。若触有胜。是名有取触。云何无取触。若触无胜。是名无取触

云何有胜触。若触有取。是名有胜触。云何无胜触。若触无取。是名无胜触。复次若此触有余胜妙。是名有胜触。若此触更无余胜妙。是名无胜触。复次若如来所生触。于一切法无碍知见。乃至自在成就。除此触若余触。是名有胜触。若上所除触。是名无胜触。云何受触。若触内。是名受触。云何非受触。若触外。是名非受触

云何内触。若触受。是名内触。云何外触。若触非受。是名外触

云何有报触。若触报法。是名有报触。云何无报触。若触报若非报非报法。是名无报触

云何凡夫共触。若触非凡夫生得。凡夫亦生得。是名凡夫共触。云何凡夫不共触。若触非凡夫生得。凡夫不能生得。是名凡夫不共触云何非凡夫共触。若触凡夫生得。非凡夫亦生得。是名非凡夫共触。云何非凡夫不共触。若触凡夫生得。非凡夫不生不得。是名非凡夫不共触

云何声闻共触。若触非声闻生得。声闻亦生得。是名声闻共触。云何声闻不共触。若触非声闻生得。声闻不生不得。是名声闻不共触。云何非声闻共触。若触声闻生得。非声闻亦生得。是名非声闻共触。云何非声闻不共触。若触声闻生得。非声闻不生不得。是名非声闻不共触

云何如电触。若触少少住少时住。如电少少住少时住。触亦如是。是名如电触。云何如金刚触。若触无量住无量时住。如金刚无量住无量时住。触亦如是。是名如金刚触。复次若触生已断少烦恼分。如电从云中出昭少闇分速灭。触亦如是。是名如电触。若触生已断一切烦恼。无余烦恼。若粗若微无不断灭。如金刚投于珠石破坏摧折无不自在。触亦如是。是名如金刚触。复次若触生已得须陀洹乃至阿那含果。是名如电触。若触生已得阿罗汉。是名如金刚触。复次若触生已得须陀洹乃至阿那含。得声闻辟支佛阿罗汉果。是名如电触。若触生已。若如来所生触。于一切法无碍知见。乃至自在成就。是名如金刚触。云何不定得触。若触得不定得难得难持。是名不定得触。云何定得触。若触得决定得不难得易持。是名定得触

云何有行难持触。若触得不定得难得难持。无由力尊自在。不如所欲。不随所欲。不尽所欲。有行难生难得。如船逆水难行。触亦如是。是名有行难持触。云何无行易持触。若触得决定得不难得易得。乃至如船顺水易行。触亦如是。是名无行易持触

云何一分修触。若触生已想有光明然未见色。若见色不想有光明。是名一分修触。云何二分修触。若触生已想有光明亦见色。是名二分修触。复次若触生已生智。然不断烦恼。若断烦恼非生智。是名一分修触。若触生已智生能断烦恼。是名二分修触。复次若触生已尽智生非无生智。是名一分修触。若触生已尽智生及无生智。是名二分修触

云何有欲触。若触有欲人欲染相应。是名有欲触。云何无欲触。若触离欲人非欲染相应。是名无欲触。云何恚触。若触有恚人憎相应。是名有恚触。云何无恚触。若触离恚人非恚相应。是名无恚触。云何有痴触。若触有痴人痴相应。是名有痴触。云何无痴触。若触离痴人非痴相应。是名无痴触

云何没触。若触睡眠相应。不共内灭念相应。慧未成就不能分别善法。是名没触。云何散触。若触想欲染共欲染。欲染相应多欲见净。于外五欲中彼染着。是名散触

云何少触。若触不定。是名少触。云何多触。若触定。是名多触

云何不定触。若触不定人非定相应。是名不定触。云何定触。若触定人定相应。是名定触。云何不解脱触。若触不解脱人非解脱相应。是名不解脱触。云何解脱触。若触解脱人解脱相应。是名解脱触

云何有胜触。若触有胜人有胜法相应。是名有胜触。云何无胜触。若触无胜人无胜法相应。是名无胜触

云何有觉触。若触有觉觉相应。共觉共生共住共灭。是名有觉触。云何无觉触。若触非觉相应。不共觉生不共住不共灭。是名无觉触。云何有观触。若触观相应。共观生共住共灭。是名有观触。云何无观触。若触非观相应。不与观共生不共观住不共灭。是名无观触

云何有喜触。若触喜相应共喜生共住共灭。是名有喜触。云何无喜触。若触非喜相应不共喜生不共喜住不共灭。是名无喜触。云何共味触。若触乐受相应。是名共味触。云何共舍触。若触不苦不乐受相应。是名共舍触

云何忍相应触。若触忍共生共住共灭。是名忍相应触。云何非忍相应触。若触非忍共生共住共灭。是名非忍相应触。云何智相应触。若触共智生共住共灭。是名智相应触。云何非智相应触。若触非智共生共住共灭。是名非智相应触。云何初忍触。若触圣无漏坚信坚法人所修。是名初忍触。云何初智触。若触圣无漏见道人所修。是名初智触

云何欲终触。若触最后识相应。是名欲终触。云何始生触。若触初识相应。是名始生触云何善触。若触修。是名善触。云何不善触。若触断。是名不善触。云何无记触。若触受若非报非报法。是名无记触

云何学触。若触圣非无学。是名学触。云何无学触。若触圣非学。是名无学触。云何非学非无学触。若触非圣。是名非学非无学触

云何报触。若触受善报。是名报触。云何报法触。若触有报。是名报法触。云何非报非报法触。若触无记非我分摄。是名非报非报法触。云何见断触。若触不善非思惟断。是名见断触。云何思惟断触。若触不善非见断。是名思惟断触。云何非见断非思惟断触。若触善无记。是名非见断非思惟断触

云何见断因触。若触见断若见断法报。是名见断因触。云何思惟断因触。若触思惟断若思惟断法报。是名思惟断因触。云何非见断因非思惟断因触。若触善若善法报若非报非报法。是名非见断非思惟断因触

云何软触。若触不善。是名软触。云何中触。若触无记。是名中触。云何上触。若触善。是名上触。复次若触不善若无记。是名软触。若触非圣善。是名中触。若触圣无漏。是名上触

云何粗触。若触欲界系。是名粗触。云何细触。若触色界系若不系。是名细触。云何微触。若触无色界系。是名微触。复次若色界系。是名粗触。若空处系识处系不用处系若不系。是名细触。若非想非非想处系。是名微触。复次若触欲界系色界系空处系识处系不用处系。是名粗触。若触不系。是名细触。若触非想非非想处系。是名微触

云何乐受触。若触乐受相应。是名乐受触。云何苦受触。若触苦受相应。是名苦受触。云何不苦不乐受触。若触不苦不乐受相应。是名不苦不乐受触。复次若触受乐报。是名乐受触。若触受苦报。是名苦受触。若触受不苦不乐报。是名不苦不乐受触。复次除不苦不乐受触。若余触善有报。是名乐受触。若触不善。是名苦受触。除乐受触。若余触善有报。是名不苦不乐受触。复次若触善有报。是名乐受触。若触不善。是名苦受触。除乐受苦受触若余触。是名非苦非乐受触

云何喜处触。若触始起已生喜。是名喜处触。云何忧处触。若触始起已生忧。是名忧处触云何舍处触。若触始起已生舍。是名舍处触。复次除舍处触若余触善有报。是名喜处触若触不善。是名忧处触。除喜处触。若余触善有报。是名舍处触。复次若触善有报。是名喜处触。若触不善。是名忧处触。除喜处忧处触若余触。是名非喜处非忧处触

云何有觉有观触。若触有觉有观定相应。是名有觉有观触。云何无觉有观触。若触无觉有观定相应。是名无觉有观触。云何无觉无观触。若触无觉无观定相应。是名无觉无观触。云何空相应触。若触空定共生共住共灭。是名空相应触。云何无相相应触。若触无相定共生共住共灭。是名无相相应触。云何无愿相应触。若触无愿定共生共住共灭。是名无愿相应触

云何现报触。若触即生我分摄若触所起作成就即生我分摄受报。是名现报触。云何生报触。若触生我分摄若触所起作成就无间生受报。是名生报触。云何后报触若触生我分摄若触所起作成就第三第四生受报或过。是名后报触

云何与乐触。若触乐果。是名与乐触。云何与苦触。若触苦果。是名与苦触。云何不与乐不与苦触。除与乐与苦触若余触。是名不与乐不与苦触。复次若触善有报。是名与乐触。若触不善。是名与苦触。除与乐与苦触若余触。是名非与乐非与苦触

云何乐果触。若触乐报。是名乐果触。云何苦果触。若触苦报。是名苦果触。云何非乐果非苦果。触除乐果苦果触若余触。是名非乐果非苦果触。复次若触善有报。是名乐果触。若触不善有报。是名苦果触。除乐果苦果触若余触。是名非乐果非苦果触。乐报触苦报触非乐报非苦报触亦如是

云何过去触。若触生已灭。是名过去触。云何未来触。若触未生未起。是名未来触。云何现在触。若触生未灭。是名现在触

云何过去境界触。思惟过去法若生触。是名过去境界触。云何未来境界触。思惟未来法若生触。是名未来境界触。云何现在境界触思惟现在法若生触。是名现在境界触。云何非过去非未来非现在境界触。思惟非过去非未来非现在法若生触。是名非过去未来现在境界触

云何欲界系触。若触欲漏有漏。是名欲界系触。云何色界系触。若触色漏有漏。是名色界系触。云何无色界系触。若触无色漏有漏。是名无色界系触。云何不系触。若触圣无漏。是名不系触

云何共慈触若触。慈解心共生共住共灭。是名共慈触。共悲触共喜触共舍触亦如是云何乐根相应触。乐根共生共住共灭。是名乐根相应触。苦根喜根忧根舍根相应触亦如是

云何眼触。若触眼识相应。是名眼触。耳鼻舌身意亦如是。复次缘色生眼识三法和合生触。是名眼触。耳鼻舌身意亦如是

云何眼识界相应触。若触眼识界共生共住共灭。是名眼识界相应触。耳鼻舌身识界亦如是。云何意界相应触。若触意识共生共住共灭。是名意界相应触。意识界相应触亦如是

云何十八触。眼触乐受眼触苦受眼触不苦不乐受。耳鼻舌身意亦如是。是名十八触

    舍利弗阿毗昙论绪分假心品第七

心性清净。为客尘染。凡夫未闻故。不能如实知见。亦无修心。圣人闻故。如实知见。亦有修心。心性清净。离客尘垢。凡夫未闻故。不能如实知见。亦无修心。圣人闻故。能如实知见。亦有修心。今当集假心正门

圣心非圣心。乃至六识界七识界心

云何圣心。若心无漏。是名圣心。云何非圣心。若心有漏。是名非圣心

云何有漏心。若心有染。是名有漏心。云何无漏心。若心无染。是名无漏心

云何有染心。若心有求。是名有染心。云何无染心。若心无求。是名无染心

云何有求心。若心当取。是名有求心。云何无求心。若心非当取。是名无求心

云何当取心。若心有取。是名当取心。云何非当取心。若心无取。是名非当取心

云何有取心。若心有胜。是名有取心。云何无取心。若心无胜。是名无取心

云何有胜心。若心有取。是名有胜心。云何无胜心。若心无取。是名无胜心。复次若于此心有余心过胜妙。是名有胜心。若于此心更无余心过胜妙。是名无胜心。复次若如来所生心。于一切法无碍知见。乃至自在成就。除此心若余心。是名有胜心。若无所余心。是名无胜心

云何受心。若心内。是名受心。云何非受心。若心外。是名非受心

云何内心。若心受。是名内心。云何外心。若心非受。是名外心

云何有报心。若心报法。是名有报心。云何无报心。若心非报非报法。是名无报心。云何凡夫共心。若心凡夫生得凡夫亦生得。是名凡夫共心。云何凡夫不共心。若心非凡夫生得凡夫不能生得。是名凡夫不共心。云何非凡夫共心。若心凡夫生得非凡夫亦生得。是名非凡夫共心。云何非凡夫不共心。若心凡夫生得非凡夫不生不得。是名非凡夫不共心

云何声闻共心。若心声闻生得声闻亦生得。是名声闻共心。云何声闻不共心。若心非声闻生得声闻不生得。是名声闻不共心。云何非声闻共心。若心声闻生得非声闻亦生得。是名非声闻共心。云何非声闻不共心。若心声闻生得非声闻不生不得。是名非声闻不共心

云何如电心。若心少少住少时住如电少少住少时住。是名如电心。云何如金刚心。若心无量住无量时住如金刚无量住无量时住。是名如金刚心。复次若心生已断少烦恼分如电从云中出昭少闇分速灭。心亦如是。是名如电心。若心生已断一切烦恼无余烦恼。若粗若微无不断灭。如金刚投于珠石无不破坏摧折。是名如金刚心。复次若心生已得须陀洹果乃至阿那含果。是名如电心。若心生已得阿罗汉果。是名如金刚心。复次若心生已得须陀洹果乃至阿那含果。得声闻辟支佛阿罗汉果。是名如电心。若心生已。若如来所生心。于一切法无碍知见。乃至自在成就。是名如金刚心

云何不定得心。若心得不定得难得难持。是名不定得心。云何定得心。与上相违。是名得定心

云何有行难持心。若心得不定得难得难持无由力尊自在不如所欲不随所欲不尽所欲有行难生难行如船逆水难行心亦如是。是名有行难持心。云何无行易持心。与上相违。是名无行易持心

云何一分修心。若心生已想有光明然不见色若见色不想有光明。是名一分修心。云何二分修心。若心生已想有光明亦见色。是名二分修心。复次若心生已生智然不断烦恼若断烦恼不生智。是名一分修心。若心生已智生能断烦恼。是名二分修心。复次若心生已尽智非无生智。是名一分修心。若心生已尽智生及无生智。是名二分修心

云何有欲心。若心有欲人欲染相应。是名有欲心。云何无欲心。若心离欲人非欲染相应。是名无欲心。云何有恚心。若心有恚人恚相应。是名有恚心。云何无恚心。若心离恚人非恚相应。是名无恚心。云何有痴心。若心有痴人痴相应。是名有痴心。云何无痴心。若心离痴人非痴相应。是名无痴心

云何没心。若心睡眠相应不共内灭念相应慧未成就不能分别善法。是名没心。云何散心。若心欲染共欲染欲染相应多欲见净于外五欲中彼彼染着。是名散心

云何少心。若心不定。是名少心。云何多心。若心定。是名多心

云何不定心。若心不定人非定相应。是名不定心。云何定心。若心定人定相应。是名定心。云何不解脱心。若心不解脱人非解脱相应。是名不解脱心。云何解脱心。若心解脱人解脱相应。是名解脱心

云何有胜心。若心有胜人有胜法相应。是名有胜心。云何无胜心。若心无胜人无胜法相应。是名无胜心

云何有觉心。若心觉相应共觉生共住共灭。是名有觉心。云何无觉心。若心非觉相应不共觉生不共住不共灭。是名无觉心。云何有观心。若心观相应共观生共住共灭。是名有观心。云何无观心。若心非观相应不共观生不共住不共灭。是名无观心

云何有喜心。若心喜相应共喜生共住共灭。是名有喜心。云何无喜心。若心非喜相应不共喜生不共住不共灭。是名无喜心。云何共味心若心乐受相应。是名共味心。云何共舍心。若心不苦不乐受相应。是名共舍心

云何忍相应心。若心忍共生共住共灭。是名忍相应心。云何非忍相应心。若心非忍共生共住共灭。是名非忍相应心

云何智相应心。若心共智生共住共灭。是名智相应心。云何非智相应心。若心非智共生共住共灭。是名非智相应心

云何忍为始心。若心圣无漏坚信坚法所修。是名忍为始心。云何智为始心。若心圣无漏见道人所修。是为智为始心

云何欲终心。若最后识。是名欲终心。云何始生心。若心初识。是名始生心

云何善心。若心修。是名善心。云何不善心。若心断。是名不善心。云何无记心。若心受。若心非报非报法。是名无记心

云何学心。若心圣非无学。是名学心。云何无学心。若心圣非学。是名无学心。云何非学非无学心。若心非圣。是名非学非无学心

云何报心。若心受若善报。是名报心。云何报法心。若心有报。是名报法心。云何非报非报法心。若心无记非我分摄。是名非报非报法心

云何见断心若心不善非思惟断。是名见断心。云何思惟断心。若心不善非见断。是名思惟断心。云何非见断非思惟断心。若心善若无记。是名非见断非思惟断心

云何见断因心。若心见断若见断法报。是名见断因心。云何思惟断因心。若心思惟断若思惟断法报。是名思惟断因心。云何非见断非思惟断因心。若心善法报若心非报非报法。是名非见断非思惟断因心

云何软心。若心不善。是名软心。云何中心。若心无记。是名中心。云何上心。若心善。是名上心。复次若心不善若无记。是名软心。若心非圣善。是名中心。若心圣无漏。是名上心

云何粗心。若心欲界系。是名粗心。云何细心。若心色界系若不系。是名细心。云何微心。若心无色界系。是名微心。复次若心欲界系。若色界系。是名粗心。若心空处系识处系不用处系若不系。是名细心。若心非想非非想处系。是名微心。复次若心欲界系若色界系若空处系识处系不用处系。是名粗心。若心不系。是名细心。若心非想非非想处系。是名微心。云何乐受心。若心乐受相应。是名乐受心。云何苦受心。若心苦受相应。是名苦受心

云何不苦不乐受心。若心不苦不乐受相应。是名不苦不乐受心。复次若心受乐报。是名乐受心。若心受苦报。是名苦受心。若心受不苦不乐报。是名不苦不乐受心。复次除不苦不乐受心。若余心善有报。是名乐受心。若心不善。是名苦受心。除乐受心。若余心善有报。是名不苦不乐受心。复次若心善有报。是名乐受心。若心不善。是名苦受心。除苦受乐受心苦余心。是名非苦非乐受心

云何喜处心。若心始起生喜。是名喜处心。云何忧处心。若心始起生忧。是名忧处心。云何舍处心。若心始起生舍。是名舍处心。复次除舍处心。若余心善有报。是名喜处心。若心不善。是名忧处心。除喜处心。若余心善有报。是名舍处心复次若心善有报。是名喜处心。若心不善。是名忧处心。除喜处忧处若余心。是名非喜处非忧处心

云何有觉有观心。若心有觉有观定相应。是名有觉有观心。云何无觉有观心。若心无觉有观定相应。是名无觉有观心。云何无觉无观心。若心无觉无观定相应。是名无觉无观心。云何空相应心。若心空定共生共住共灭。是名空相应心。云何无相相应心。若心无相定共生共住共灭。是名无相相应心。云何无愿相应心。若心无愿定共生共住共灭。是名无愿相应心

云何现报心。若心即生我分摄若心起作成就即生我分摄此所起作受报。是名现报心。云何生报心。若心生报我分摄若所起作成就无间生受报。是名生报心。云何后报心。若心生我分摄若所起作成就第一生乃至第四生受报或过。是名后报心

云何与乐心。若心乐果。是名与乐心。云何与苦心。若心苦果。是名与苦心。云何不与乐不与苦心。除与乐与苦心若余心。是名不与苦不与乐心。复次若心善有报。是名与乐心。若心不善有报。是名与苦心。除与苦乐若余心。是名不与苦不与乐心

云何乐果心。若心乐报。是名乐果心。云何苦果心。若心苦报。是名苦果心。云何非乐果非苦果心。除苦果乐果心若余心。是名非乐果非苦果心。复次若心善有报。是名乐果心。若心不善有报。是名苦果心。除乐果苦果心若余心。是名非乐果非苦果心。乐报心苦报心非乐非苦报心亦如是

云何过去心。若心生已灭。是名过去心。云何未来心。若心未生未起。是名未来心。云何现在心。若心生未灭。是名现在心

云何过去境界心。思惟过去法若生心。是名过去境界心。云何未来境界心。思惟未来法若心生。是名未来境界心。云何现在境界心。思惟现在法若生心。是名现在境界心。云何非过去非未来非现在境界心。思惟非过去非未来非现在法若生心。是名非过去非未来非现在境界心

云何欲界系心。若心欲漏有漏。是名欲界系心。云何色界系心。若心色漏有漏。是名色界系心。云何无色界系心。若心无色漏有漏。是名无色界系心。云何不系心。若心圣无漏。是名不系心

云何共慈心。若心慈解心共生共住共灭。是名共慈心。共悲心共喜心共舍心亦如是。云何乐根相应心。若心乐根共生共住共灭。是名乐根相应心。苦根喜根忧根舍根相应心亦如是

云何六识身。眼识身乃至意识身。云何眼识身。缘眼缘色缘明缘思惟。以此四缘和合识已生今生当生不定。是名眼识身。耳鼻舌身意识身亦如是。是名六识身

云何七识界。眼识界乃至意识界。云何眼识界。若识眼根生色境界。已生今生当生不定。是名眼识界。耳鼻舌身识界亦如是。云何意界。意生法思惟法。若初心已生今生当生不定。是名意界。云何意识界。不离彼境界若余心。似彼已生今生当生不定。是名意识界

    舍利弗阿毗昙论绪分十不善业道品第八

问曰。几不善业道。答曰十。杀生乃至邪见。云何杀生。若人以恶心杀生。无有慈愍专在杀害。是名杀生。云何盗窃。若人于聚落中及山野间。盗他财物。是名盗窃。云何邪淫。若女人为父母护兄弟姊妹护自护法护姓护。亲里及诸知识乃至受花鬘护。若犯此等。是名邪淫。云何妄语。若人不知言知。知言不知。不见言见。见言不见。或为己身。或为他人。或为财物故作妄语。是名妄语。云何两舌。若人在此闻至彼说。欲坏此人故。在彼闻至此说。欲坏彼人故。未破者令破。已破者欲使尽散乐别离他。是名两舌。云何恶口。若人出言粗犷苦切。他人闻已。不喜不悦。是名恶口。云何绮语。若人出非时言无义语非法语非调伏语不寂静语。是名绮语。云何贪欲。若人于他村邑他财物生悕望心。欲令他物作己有。是名贪欲。云何嗔恚。若人嗔恚。欲令前众生得系闭伤害为种种苦加。是名嗔恚。云何邪见。若人邪见言无施无祠祀无善恶业报无此世他世无父母无天无化生众生无沙门婆罗门。是名邪见

杀生以何因。杀生为谁因。杀生以贪因以嗔因以痴因。以心心数法因。杀生是地狱畜生饿鬼因。是鬼神人中贫贱因。若余报生人中短寿。窃盗以何因。窃盗为谁因。窃盗以贪因。乃至以心心数法因。盗窃是地狱畜生饿鬼因。是鬼神人中贫贱因。若余报生人中财物消秏。邪淫以何因。邪淫为谁因。邪淫以贪因。乃至以心心数法因。邪淫是地狱畜生饿鬼因。是鬼神人中贫贱因。若余报生人中诤竞。妄语以何因。妄语为谁因。妄语以贪因。乃至以心心数法因。妄语是地狱畜生饿鬼因。是鬼神人中贫贱因。若余报生人中常被诽谤。两舌以何因。两舌为谁因。两舌以贪因。乃至以心心数法因。两舌为谁因。是地狱畜生饿鬼因。是鬼神人中贫贱因。若余报生人中眷属亲厚相憎嫉破坏。恶口以何因。恶口为谁因。恶口以贪因。乃至以心心数法因。恶口为谁因。恶口是地狱畜生饿鬼因。是鬼神人中贫贱因。若余报生人中闻不适意声。绮语以何因。绮语为谁因。绮语以贪因。乃至以心心数法因绮语为谁因。是地狱畜生饿鬼因。是鬼神人中贫贱因。若余报生人中言不贵重。贪欲以何因。贪欲为谁因。贪欲以结因以使因。以心心数法因。贪欲为谁因。是地狱畜生饿鬼因。是鬼神人中贫贱因。若余报生人中多诸缘事。嗔恚以何因。嗔恚为谁因。嗔恚以结因以使因。以心心数法因。嗔恚为谁因。是地狱畜生饿鬼因。是鬼神人中贫贱因。若余报生人中多有怨憎。邪见以何因。邪见为谁因。邪见以结因以使因。以心心数法因。邪见为谁因。是地狱畜生饿鬼因是鬼神人中贫贱因。若余报生人中以邪为吉

    舍利弗阿毗昙论绪分十善业道品第九

问曰。几善业道。答曰十。何等十。不杀生乃至正见。云何不杀生。若人离杀生。弃舍刀杖。惭愧慈悲哀愍一切众生。是名不杀生。云何不盗窃。若人离窃盗。不盗他物。是名不盗窃。云何不邪淫。若人离邪淫。他所护女终不淫犯。是名不邪淫。云何不妄语。若人离妄语。不知言不知。知言知。不见言不见。见言见。不为己身。不为他人。不为财物而作妄语。是名不妄语。云何不两舌。若人离两舌。在此闻不至彼说不欲坏此。在彼闻不至此说不欲坏彼。若破坏者欲令和合。已和合者欲令增欢喜共相娱乐。是名不两舌。云何不恶口。若人离恶口离粗犷言。语言柔软众人爱喜。是名不恶口。云何不绮语。若人应时语。真实语。有义语。调伏语。寂静语顺时善语。是名不绮语。云何无贪。若人离贪。不悕望他村邑财物令是我有。是名无贪。云何无嗔若人离嗔恚。心不欲令此众生伤害系闭受种种苦。是名无嗔。云何正见若人正见信有施有祠祀。乃至世有沙门婆罗门正见正趣。有证知今世后世者。是名正见

不杀生以何因。不杀生为谁因。不杀生以无贪因。以无恚因。以无痴因。以心心数法因。不杀生为谁因。是天上人中受乐因。若余报生人中长寿。不窃盗以何因不窃盗为谁因。不窃盗以无贪因。乃至以心心数法因。不窃盗是天上人中受乐因。若余报生人中财物不消耗。不邪淫以何因。不邪淫为谁因。不邪淫以无贪因。乃至以心心数法因。不邪淫是天上人中受乐因。若余报生人中不诤竞。不妄语以何因。不妄语为谁因。不妄语以无贪因。乃至以心心数法因。不妄语是天上人中受乐因。若余报生人中不被诽谤。不两舌以何因。不两舌为谁因。不两舌以无贪因。乃至以心心数法因。不两舌是天上人中受乐因。若余报生人中眷属亲厚。不相憎嫉破坏。不恶口以何因。不恶口为谁因。不恶口以无贪因。乃至以心心数法因不恶口是天上人中受乐因。若余报生人中闻适意声。不绮语以何因。不绮语为谁因。不绮语以无贪因。乃至以心心数法因。不绮语是天上人中受乐因。若余报生人中言为贵重。无贪以何因。无贪为谁因。无贪以专敬因。专敬以善根因。以心心数法因。无贪是天上人中受乐因。若余报生人中无诸缘事。无恚以何因。无恚为谁因。无恚以专敬因。乃至以心心数法因。无恚是天上人中受乐因。若余报生人中无多怨憎。正见以何因正见为谁因。正见以专敬因。乃至以心心数法因。正见是天上人中受乐因。若余报生人中不以邪为吉

舍利弗阿毗昙论卷第二十七舍利弗阿毗昙论卷第二十八

        姚秦罽宾三藏昙摩耶舍共昙摩崛多等译

    绪分定品第十之一

五支定。五智定。共念出息入息定。共不净想定。入火定。共证知神足定。共证知天耳定。共证知他心定。共证知宿命定共明想定。无间定。根定。力定正觉定正定邪定圣定非圣定。有漏定无漏定。有染定无染定。有求定无求定。当取定非当取定。有取定无取定。有胜定无胜定。受定非受定。内定外定。有报定无报定。凡夫共定。凡夫不共定。非凡夫共定。非凡夫不共定。声闻共定。声闻不共定。非声闻共定。非声闻不共定。如电定如金刚定。不定得定定得定。有行难持定。无行易持定。一分修定。二分修定。有想定无想定。如事定。忆想定离色想定不离色想定。无胜入定遍入定。有觉定无觉定。有观定无观定。有喜定无喜定。共味定。共舍定。忍相应定。非忍相应定。智相应定。非智相应定。忍为始定。智为始定欲终定。始生定。善定不善定无记定。学定无学定非学非无学定。报定报法定。非报非报法定。见断定。思惟断定。非见断非思惟断定。见断因定。思惟断因定非见断非思惟断因定。下定中定上定。粗定细定微定。有觉有观定。无觉有观定。无觉无观定。空定无相定无愿定。三愿得定。非三愿得定。内身观内身定。外身观外身定。内外身观内外身定。内受观内受定。外受观外受定。内外受观内外受定。内心观内心定。外心观外心定。内外心观内外心定。内法观内法定。外法观外法定。内外法观内外法定。内境界定。外境界定。内外境界定。内定境界定。外定境界定。众生境界定。色境界定。无色境界定。众生境界定。有为境界定。无为境界定。众生境界定。法境界定。无境界定。众生境界定。少定中定。无量定少境界定。中境界定。无量境界定。少定少境界。少定中境界。少定无量境界。中定少境界。中定中境界。中定无量境界。无量定少境界。无量定中境界。无量定无量境界。少住定。中住定。无量住定。少定少住。少定中住。少定无量住。中定少住。中定中住。中定无量住。无量定少住。无量定中住。无量定无量住。过去定。未来定。现在定。过去境界定。未来境界定。现在境界定。非过去非未来非现在境界定。欲界系定。色界系定。无色界系定。不系定。作定非离离定。非作作离定。亦非作离定。取定非出出定。非取取出定。亦非取非出定。有染定。非离染离染定。非有染有染离染定。亦非有染非离染定。有枙定非离枙。离枙定。非有枙有枙离枙定。亦非有枙非离枙定。智果定非断果。断果定非智果。智果断果定。亦非智果非断果定。智果定非得果。得果定非智果。智果得果定。亦非智果非得果定。尽定非觉。觉定非尽。尽觉定。亦非尽非觉定。射定。非解解定。非射射解定。亦非射非解定。退分定。住分定。增长分定。射分定。退分定。非住分。住分定。非退分。退分住分定。亦非退分非住分定。退分定非增长分。增长分定非退分。增长分定。亦非退分非增长分定。退分定非射分。射分定非退分射分定。亦非退分射分定。住分定非增长分。增长分定非住分。住分增长分定。亦非住分非增长分定。住分定非射分。射分定非住分。住分射分定。亦非住分非射分定。增长分定非射分。射分定非增长分。增长分射分定。亦非增长分非射分定。四念处四正断四神足四禅。四无量四无色定。四向道四果。四修定四断。五根五力。五解脱入五出界。五观定五生解脱法。六念六定。六出界。六明分法。六悦根法。六无喜正觉。七觉七想七定所须八圣道八解脱八胜入。九灭九次第灭定九想。十正法十遍入。十一解脱入

云何五支定。如佛告诸比丘。谛听谛听。善思念之。吾当为汝说圣五支定。诸比丘言。唯然受教。云何得修圣五支正定。如比丘离欲恶不善。有觉有观离生喜乐。成就初禅行。身离生喜乐津液遍满此身。尽离生喜乐。津液遍满无有减少。如善澡浴师。若善澡浴师弟子。以细澡豆盛着器中。以水洒之调适作抟。此抟津液遍满。不干不湿内外和调。如是比丘。身离生喜乐。津液遍满无有减少。是名修圣五支初支定。复次比丘。灭觉观内正信一心。无觉无观定生喜乐。成就二禅行。此身定生喜乐津液遍满。此身尽定生喜乐。津液遍满无有减少。如陂湖水底涌出。不从东方南西北方来。此水从底涌出。能令池津液遍满无有减少。如是比丘。此身定生喜乐津液遍满。此身定生喜乐津液遍满无有减少。是谓修圣五支第二支定。复次比丘。离喜舍行念正智身受乐。如诸圣人。解舍念乐行。成就三禅行。此身无喜乐津液遍满。此身无喜乐津液遍满无有减少。如优波罗华池鸠头摩华池钵头摩华池分陀利华池。从泥中出未能出水。此华从根至头。从头至根。皆津液遍满无有减少。如是比丘。此身无量喜乐津液遍满此身。津液遍满无有减少。是谓圣五支第三支定。复次比丘。断苦乐先灭忧喜。不苦不乐舍念净。成就四禅行。此身以清净心遍解行。此身以清净心遍解行无有减少。如男子女人着白净衣。从头至足从足至头无不覆处。如是比丘。以清净心遍解行。此身以清净遍解行无有减少。是谓修圣五支第四支定。复次比丘。善取观相。善思惟善解。如立人观坐者。如坐人观卧者。如是比丘。善取观相善思惟善解。是谓修圣五支第五支定。如是比丘。修圣五支定。亲近多修学已。欲证通法。悕望欲证。随心所欲即能得证。自知无碍。如四衢处有善调马善驾已。有善御乘者。乘已随意自在。如是比丘。亲近圣五支定多修学已。欲证通法。悕望欲证。随心所欲即能得证自在无碍。如盛水瓶坚牢不漏。盛以净水。平满为欲随人倾用。如意自在。如是比丘。亲近圣五支定多修学已。欲证通法悕望欲证。随心所欲自在无碍。如比丘如陂泉遍水平满为饮。如人决用如意自在。随所决即出。如是比丘。亲近圣五支定多修学已。欲证通法。悕望欲证随心所欲。即能得证自在无碍。如比丘欲受无量若干神足动地。能以一为多以多为一。乃至梵天身得自在随所能入。如智品说。如比丘欲受天耳清净过人能闻人非人声随所能入。如比丘欲受知他众生心能知。有欲心如实知有欲心。无欲心如实知无欲心。乃至无胜心如实知无胜心。随所能入。如智品说。如比丘欲受忆念无量宿命。能忆一生二生三生四生五生。乃至成就此行。随所能入。如智品说。如贤比丘。欲受天眼清净过人。能见众生生死。乃至如所业报随所能入。如智品说。如贤比丘。欲受尽有漏成无漏。得心解脱慧解脱。现世自智证成就行。我生已尽梵行已立。所作已办更不受有。随所能入。如是修圣五支定。亲近多修学已。得如是果报。云何比丘。离欲恶不善法。有觉有观离生喜乐。成就初禅行。如比丘一切有为法。若一处有为法。思惟无常。知无常解无常受无常。如是不放逸观。离欲恶不善法。有觉有观离生喜乐。成就初禅行。如是比丘。离欲恶不善法。有觉有观离生喜乐。成就初禅行。如是乃至见死尸在火聚上观。如道品一支道广说。复次比丘。如是思惟。我内有欲染。如实知内有欲染。若内无欲染。如实知内无欲染。如欲染未生。如实知未生。如欲染未生生。如实知生。如欲染生已断。如实知断。如欲染断已。如实知更不复生。内有嗔恚睡眠掉悔疑亦如是。如是不放逸观。离欲恶不善法。有觉有观离生喜乐。成就初禅行。比丘如是离欲恶不善法。有觉有观离生喜乐。成就初禅行。复次比丘。如是思惟。我内眼识色。有欲染嗔恚。如实知内眼识色有欲染嗔恚。内眼识色无欲染嗔恚。如未生眼识色欲染嗔恚。如实知未生。如未生眼识色欲染嗔恚生。如实知生。如生眼识色欲染嗔恚断已。如实知断。如眼识色欲染嗔恚断已。如实知更不复生。耳识声鼻识香舌识味身识触意识法亦如是。不放逸观离欲恶不善法。有觉有观离生喜乐。成就初禅行。比丘如是离欲恶不善法。有觉有观离生喜乐。成就初禅行。复次比丘。如是思惟。我内有念正觉。如实知内有念正觉。内无念正觉。如实知内无念正觉。如念正觉未生。如实知未生。如念正觉未生生。如实知生。如念正觉生已具足修。如实知具足。修择法正觉精进正觉喜正觉除正觉定正觉舍正觉亦如是。如是不放逸观。离欲恶不善法。有觉有观离生喜乐。成就初禅行。比丘如是离欲恶不善法。有觉有观离生喜乐。成就初禅行。复次比丘如实知苦苦集苦灭苦灭道。如实知漏漏集漏灭漏灭道。如是不放逸观。离欲恶不善法。有觉有观离生喜乐。成就初禅行。比丘如是。谓离欲恶不善法。有觉有观离生喜乐。成就初禅行。复次比丘心畏怖故。出一切有为。入甘露界。此寂静妙胜离一切有为。爱尽涅槃。如是不放逸观。离欲恶不善法。有觉有观离生喜乐。成就初禅行。比丘如是离欲恶不善法。有觉有观离生喜乐。成就初禅行。第二禅第三禅第四禅亦如是说。云何比丘。善取观相。善思惟善解。如比丘一切有为法。若一处有为法思惟无常。知无常解无常受无常。如是不放逸观。离欲恶不善法。有觉有观离生喜乐。成就初禅行。如比丘若行若法相。离欲恶不善法。有觉有观离生喜乐。成就初禅行。若法相善取相善思惟善解。善识顺识缘识。分别顺分别缘分别。比丘如是善取观相善思惟善解。复次比丘。若一处有为法。思惟是苦患痈箭味过依缘坏法不定不满可坏苦空无我。思惟缘知缘受缘。即无明缘行。行缘识。识缘名色。名色缘六入。六入缘触。触缘受。受缘爱。爱缘取。取缘有。有缘生。生缘老死忧悲苦恼众苦聚集。如是不放逸观。离欲恶不善法。有觉有观离生喜乐。成就初禅行。如比丘若法相。离欲恶不善法。有觉有观离生喜乐。成就初禅行。若行若法相。善取相善思惟善解。善识顺识缘识。分别顺分别缘分别。比丘如是善取观相善思惟善解。复次比丘一切有为法。若一处有为法。思惟法灭知灭解灭受灭。无明灭则行灭。行灭则识灭。识灭则名色灭。名色灭则六入灭。六入灭则触灭。触灭则受灭。受灭则爱灭。爱灭则取灭。取灭则有灭。有灭则生灭。生灭则老死忧悲苦恼众苦聚集灭。如是不放逸观。离欲恶不善法。有觉有观离生喜乐。成就初禅行。如比丘若行法相。离欲恶不善法。有觉有观离生喜乐。成就初禅行。若行若法相善取相善思惟善解。善识顺识缘识。分别顺分别缘分别。比丘如是善取观相善思惟善解。复次比丘。行知行乐。住知住乐。坐知坐乐。卧知卧乐。如是身住乐如实知住乐。如是不放逸观。离欲恶不善法。有觉有观离生喜乐。成就初禅行。如比丘若行若法相。离欲恶不善法。有觉有观离生喜乐。成就初禅行。若行若法相。善取相善思惟善解。善识顺识缘识。分别顺分别缘分别。比丘如是善取观相善思惟善解。复次比丘。从去来屈伸。乃至心怖畏故。出一切有为入甘露界。亦如是说。第二禅第三禅第四禅。亦如是说

何谓善取观相善思惟善解。如比丘一切有为法。若一处有为法。思惟无常知无常解无常受无常。如是不放逸观。离欲恶不善法。有觉有观离生喜乐。成就初禅行。如比丘若有色受想行识。善取法相善思惟善解。善识顺识缘识。分别顺分别缘分别。比丘如是善取观相善思惟善解。复次比丘一切有为法。若一处有为法。从思惟是苦患痈箭。乃至心畏怖故。出一切有为入甘露界。此寂静此妙胜。离一切有为爱尽涅槃。如是不放逸观。离欲恶不善法。有觉有观离生喜乐。成就初禅行。如比丘。若有色受想行识。善取法相善思惟善解。善识顺识缘识。分别顺分别缘分别。比丘如是善取观相善思惟善解。第二禅第三禅第四禅。亦如上说。如是五支。是名五支定

云何五智定。如世尊说。诸比丘修定无量明了。诸比丘若修定无量明了已。缘生五种智。何等五。若有定现乐后乐报缘此生智。若有定圣无染缘此生智。若有定不怯弱者能亲近缘此生智。若有定寂静胜妙独修除得缘此生智。若有定念入正念起缘此生智。云何定现乐后乐报缘此生智。云何现乐定。如比丘。离欲恶不善法。有觉有观离生喜乐。成就初禅行。若身离生喜乐津液遍满。此身尽离生喜乐。津液遍满无有减少。如善澡浴师。若善澡浴师弟子。以细澡豆盛着器中。以水洒已调适作抟。此抟津液遍满。不燥不湿内外和润。如是比丘身离生喜乐津液遍满。身尽离生喜乐。津液遍满无有减少。如比丘增益受离生喜乐出世乐寂静乐灭乐正觉乐沙门果乐涅槃乐。此定如是谓现乐。复次比丘。灭觉观内净信一心。无觉无观定生喜乐。成二禅行。若身定生喜乐津液遍满。此身尽定生喜乐。津液遍满无有减少。如大陂湖以山围绕。水从底涌出。不从东方南西北方来。此陂水津液遍满。此陂尽津液遍满无有减少。如是比丘身定生喜乐津液遍满。此身尽津液遍满无有减少。如比丘增益受无喜乐。出世乐寂静乐灭乐正觉乐沙门果乐涅槃乐。此定如是谓现乐。复次比丘离喜舍行念正智身受乐。如诸圣人。解舍念乐行。成就三禅行。若身无喜乐。津液遍满身无喜乐。津液遍满无有减少。如优钵罗花池波头摩花池鸠头摩花池分陀利花池。从泥稍出未能出水。此花若根若头。水津液遍满。从根至头从头至根。津液遍满无有减少。如是比丘。若身无喜乐津液遍满。此身尽津液遍满无有减少。如比丘增益受无喜乐出世乐寂静乐灭乐正觉乐沙门果乐涅槃乐。此定如是谓现乐。复次比丘断苦断乐先灭忧喜不苦不乐舍念净。成就四禅行。若身以清净心遍解行。此身清净无不遍处。如男子女人身着白净衣上下具足。从头至足从足至头无不覆处。如是比丘。若身以清净心遍解行。此身清净无不遍处。如比丘增益受寂静妙乐出世乐寂静乐灭乐正觉乐沙门果乐涅槃乐。如是定谓现乐。云何定后乐报。如比丘。思惟无常苦空无我。思惟涅槃寂静。得定心住正住。如比丘得定已。即得初圣五根。得初圣五根已。上正决定舍凡夫地。若不得须陀洹果而中命终。无有是处。不得须陀洹果。作恶作恶业已。命终堕三涂。无有是处。如比丘亲近此定多修学。多修学已。见断三烦恼。得须陀洹果触证。触证已。断地狱畜生饿鬼苦。受七生人天报。断余生天人中苦。如是定谓后乐报。如比丘亲近此定。多修学。多修学已。思惟断欲染嗔恚烦恼分。断欲染嗔恚烦恼分已。得斯陀含果触证。触证已断地狱畜生饿鬼苦。受天上人中生。断余生天上人中苦。如是定谓后乐报。如比丘亲近此定多修学。多修学已。思惟断欲染嗔恚尽无余。无余已得阿那含果触证。触证已断地狱畜生饿鬼人中苦。若受一天生若五生。余天上苦皆断。如是定谓后乐报。如比丘亲近此定多修学。多修学已。思惟断色界无色界烦恼尽无余。无余已得阿罗汉果触证。触证已断地狱畜生饿鬼人中天上苦。一切有一切道一切生一切系缚一切结使烦恼苦。皆断无余。如是定谓后乐报。何谓缘此生智。若内分别若外分别。知见觉证。此谓缘此生智。何谓有定圣无。染缘此生智。何谓非圣定。若定有漏。此谓非圣定。复次非圣定若定非学非无学。此谓非圣定。复次非圣定。除空无相无愿定。若余定谓非圣定。何谓圣定。若定无漏。是名圣定。复次圣定。若定学无学。此谓圣定。复次圣定。空无相无愿定。此谓圣定。以何义谓圣。以断离贪欲嗔恚愚痴诸结烦恼故谓圣定。云何有染定。若定有求。此谓有染定。复次有染定。若定非学非无学。此谓有染定。复次有染定。除空无相无愿定若余定。此谓有染定。以何义有染。染谓爱。爱于此定中得正得缘得。定亦于爱中得正得缘得。是谓有染定。云何无染定。若定无求。此谓无染定。复次无染定。若定学无学。此谓无染定。复次无染定。空无相无愿定。此谓无染定。以何义无染。染谓爱。爱定中不得不正得不缘得定爱中不得不正得不缘得。是谓无染定。何谓缘此生智。若内分别若外分别。知见觉证。此谓缘此生智。云何有定不怯弱者亲近缘此生智。云何怯弱者。若无信心无惭无愧。不学问懈怠失念无慧。此谓怯弱者。复次怯弱是凡夫。以何义故名怯弱。以未知身见未断身见。以是义谓怯弱者。云何非怯弱者。不怯弱谓有信惭愧。多闻勤进专念多慧。此谓不怯弱者。复次不怯弱。若佛及佛声闻弟子。以何义故名不怯弱。以知身见以断身见。以是义谓不怯弱者。如是不怯弱者。得定亲近多修学。以是义故谓非怯弱者亲近。何谓缘此生智。若内分别若外分别。知见觉证。是谓缘此生智。何谓有定寂静胜妙独修除得。缘此生智。云何寂静。若定共果报。是名寂静。云何胜妙定。若定圣有报。能断烦恼。是名胜妙定。复次寂静定。若定圣有报能断烦恼。是名寂静定。复次胜妙定。若定共果报。是名胜妙定。复次寂静即胜妙。胜妙即是寂静。是谓寂静胜妙。何谓独修。若心一向定住正止独处定。是谓独修。何谓除得。云何不除得定。若定得不定得难得。是名不除得定。云何除得定。若定得决定得不难得。是谓除得定。何谓缘此生智。若内分别若外分别。知见觉证。是谓缘此生智。何谓有定正念入正念起缘此生智。若正智入正智起。正智入正智起已。是故谓正念入正念起。专身念入专身念起。专身念入专身念起已。是谓正念入正念起。何谓缘此生智。若内分别若外分别。知见觉证。是谓缘此生智。如是五智。是五智定

何谓共念出息入息定。如世尊说。诸比丘。修出息入息念亲近多修学。多修学已得大果报。乃至得甘露。云何修出息入息念亲近多修学得大果报乃至得甘露。如比丘住寂静处。林中树下或在空处。在山窟中露处敷草。或在冢间岩岸。如比丘朝诣村乞食。食已日过中。举衣钵洗足。洗足已比丘结加趺坐。端身系念思惟断悕望。心无悕望贪着行。于悕望贪着得清净。断嗔恚。行慈心。心离嗔恚得清净。断睡眠无睡眠。正知明想。心离睡眠得清净。断掉悔无掉悔行。内心寂静。离掉悔得清净。断疑无疑行。一定善法心离疑得清净。如比丘断五盖。是心垢损。智慧正念出息。正念入息。如比丘出息长知出息长。入息长知入息长。出息短知出息短。入息短知入息短。学一切身觉知入息。学一切身觉知出息。学除身行出息。学除身行入息。学喜出息觉知。学喜入息觉知。学乐出息觉知。学乐入息觉知。学心行出息觉知。学心行入息觉知。学除心行出息觉知。学除心行入息觉知。学心出息觉知。学心入息觉知。学悦心出息。学悦心入息。学定心出息。学定心入息。学解脱心出息。学解脱心入息。学无常观出息。学无常观入息。学离欲观出息。学离欲观入息。学灭观出息。学灭观入息。学出世观出息。学出世观入息

何谓正念出息正念入息。若正知出息正知入息。正知出息正知入息已。是谓正念出息正念入息。专念身出息专念身入息。专念身出息专念身入息已。是谓正念出息正念入息。何谓比丘出息长知出息长入息长知入息长。如比丘思惟法生长出息入息。善取法相善思惟善解。若思惟法不生长出息入息。善取法相善思惟善解。若法胜非胜能生长出息入息。善取法相善思惟善解。比丘思惟法生长出息入息觉知。善取法相善思惟善解。若思惟法不生长出息入息觉知。善取法相善思惟善解。若法胜非胜能生长出息入息觉知。善取法相善思惟善解。如比丘思惟法生长出息入息思惟法。若不生不思惟彼法。亲近胜法不亲近不胜法。比丘思惟法生长出息入息觉知思惟法。若不生不思惟法。亲近胜法不亲近不胜法。比丘思惟应所修法。亲近胜法不亲近不胜法。长出息入息。及长出息入息觉知得悦喜心。是谓比丘出息长知出息长入息长知入息长。何谓出息入息长。若无量出息无量入息。无量出息无量入息已。是故谓出息长入息长。不疾出息不疾入息。不疾出息不疾入息已。是故谓出息长入息长。不连速出息入息。不连速出息入息已。是故谓出息入息长。不力厉身出息。不力厉身入息。不力厉身出息不力厉身入息已。是故谓出息入息长。不续出息入息。不续出息入息已。是故谓出息入息长。是名出息入息长(一事竟)

何谓出息短知出息短入息短知入息短。如比丘思惟法生短出息入息。善取法相善思惟善解。若思惟法不生短出息入息。善取法相善思惟善解。若法胜非胜能生短出息入息。善取法相善思惟善解。比丘思惟法生短出息入息觉知。善取法相善思惟善解。若思惟法不生短出息入息觉知。善取法相善思惟善解。若法胜非胜生短出息入息觉知。善取法相善思惟善解。比丘思惟法生短出息入息思惟法。若不生不思惟法。亲近胜法不亲近不胜法。如比丘思惟法生短出息入息觉知思惟法。若不生不思惟法。亲近胜法不亲近不胜法。比丘不思惟不应所修法。思惟应所修法。亲近胜法不亲近不胜法。短出息入息。及短出息入息觉知得悦喜。是谓出息短知出息短入息短知入息短。何谓出息入息短。有量出息有量入息。有量出息有量入息已。是故谓出息入息短。疾出息疾出息已。是故谓出息入息短。连速出息连速出息已。是故谓出息入息短。力厉身出息入息。力厉身出息入息已。是故谓出息入息短。续出息入息。续出息入息已。是故谓出息入息短。不身除出息入息。不身除出息入息已。是故谓出息入息短。是名出息入息短(二事竟)

何谓学一切身出息觉知学一切身入息觉知。如比丘以息满一切身出息。若一切身内空已入息。如巧[夢-夕+棐]师[夢-夕+棐]师弟子。令[夢-夕+棐]囊满已。按使气出。若[夢-夕+棐]囊空已。还开其口使气得满。比丘如是。令一切身中息满已出息。若一切身内空已入息。若思惟法一切身生出息入息。善取法相善思惟善解。若思惟法一切身中不生出息入息。善取法相善思惟善解。若法胜非胜。一切身中能生出息入息。善取法相善思惟善解。如比丘思惟法生一切身中出息入息觉知。善取法相善思惟善解。若思惟法一切身中不生出息入息觉知。善取法相善思惟善解。若法胜非胜。能生一切身中出息入息觉知。善取法相善思惟善解。如比丘思惟法生一切身中出息入息思惟法。若不生不思惟法。亲近胜法不亲近不胜法。比丘思惟法生一切身中出息入息觉知思惟法。若不生不思惟法。亲近胜法不亲近不胜法。比丘思惟应所修法。不思惟不应所修法。亲近胜法不亲近不胜法。一切身中出息入息。及一切身中出息入息觉知得悦喜。是谓学一切身出息觉知。学一切身入息觉知(三事竟)

何谓学除身行出息学除身行入息身行。谓出息入息有粗有细。云何粗身行。若掉动是名粗身行。云何细身行。若寂静是名细身行如比丘以细身行调伏粗。身行降胜除出如巧匠。巧匠弟子。以小楔出大楔。如是比丘。以细身行。调伏粗身行。如人驰走自思惟。我以何故走。我当安徐行。便安详行。此人复如是思惟。我何以安详行。我应当住便住。此人复思惟。我何故住。我当坐便坐。此人复如是思惟。我何故坐。我当卧便卧。此人如是除粗身行亲近细身行。比丘如是除粗身行亲近细身行。比丘思惟法生粗身行。善取彼法相善思惟善解。若思惟法不生粗身行。善取法相善思惟善解。若法胜非胜能生粗身行。善取法相善思惟善解。比丘思惟法生细身行。善取法相善思惟善解。若思惟法不生细身行。善取法相善思惟善解。若法胜非胜能生细身行。善取法相善思惟善解。比丘若思惟法除粗身行。善取法相善思惟善解。若思惟法不除粗身行。善取法相善思惟善解。若法胜非胜能除粗身行。善取法相善思惟善解。比丘思惟法生除身行。出息入息。善取法相善思惟善解。若思惟法不生除身。行出息入。息善取法相善思惟善解。若法胜非胜能生除身行。出息入息善取法相善思惟善解。比丘思惟法生除身行出息入息。觉知。善取法相善思惟善解。若思惟法不生除身行。出息入息觉知。善取法相善思惟善解。若法胜非胜能生除身行。出息入息觉知。善取法相善思惟善解比丘思惟法生粗身行不思惟法。若不生思惟法。亲近胜法不亲近不胜法。比丘思惟法生细身行思惟彼法。若不生不思惟彼法。亲近胜法不亲近不胜法。比丘思惟法除粗身行思惟法。若不除不思惟法。亲近胜法不亲近不胜法。比丘思惟法生除身行。出息入息思惟法。若不生不思惟法。亲近胜法不亲近不胜法。比丘思惟法生除身行。出息入息觉知思惟法。若不生不思惟法。亲近胜法不亲近不胜法。比丘不思惟不应所修法。思惟应所修法。亲近胜法不亲近不胜法。除身行出息入息。及除身行出息入息。觉知得悦喜。是谓学除身行出息入息(四事竟)

何谓学喜出息觉知学喜入息觉知。云何喜。若心欢喜踊跃。是名喜。比丘思惟法生喜。善取法相善思惟善解。若思惟法不生喜。善取法相善思惟善解。若法胜非胜能生喜。善取法相善思惟善解。比丘思惟法生喜。出息入息善取法相善思惟善解。若思惟法不生喜。出息入息善取法相善思惟善解。若法胜非胜能生喜。出息入息善取法相善思惟善解。比丘思惟法生喜。出息入息觉知。善取法相善思惟善解。若思惟法不生喜。出息入息觉知。善取法相善思惟善解。若法胜非胜能生喜。出息入息觉知。善取法相善思惟善解。比丘思惟法生喜。思惟法。若不生不思惟法。亲近胜法不亲近不胜法。比丘思惟法生喜。出息入息思惟法。若不生不思惟法。亲近胜法不亲近不胜法。比丘思惟法生喜。出息入息觉知思惟法。若不生不思惟法。亲近胜法不亲近不胜法。比丘思惟应所修法。不思惟不应所修法。亲近胜法不亲近不胜法。喜出息入息。及喜出息入息觉知得悦喜。是谓学喜出息觉知学喜。入息觉知(五事竟)

何谓学乐出息觉知学乐入息觉知。云何乐。若心忍受乐意触乐受。是名乐。如比丘思惟法生乐。善取法相善思惟善解。若思惟不生乐。善取法相善思惟善解。若法胜非胜能生乐。善取法相善思惟善解。比丘思惟法生乐出息入息善取法相。善思惟善解。若思惟法不生乐。出息入息善取法相善思惟善解。若法胜非胜能生乐。出息入息善取法相善思惟善解。比丘思惟法生乐。出息入息觉知。善取法相善思惟善解。若思惟法不生乐。出息入息觉知。善取法相善思惟善解。若法胜非胜能生乐。出息入息觉知。善取法相善思惟善解。比丘思惟法生乐。出息入息思惟法。若不生不思惟法。亲近胜法不亲近不胜法。比丘思惟法生乐。出息入息思惟法。若不生不思惟法。亲近胜法不亲近不胜法。比丘思惟法生乐。出息入息觉知思惟彼法。若不生不思惟法。亲近胜法不亲近不胜法。比丘思惟应所修法。不思惟不应所修法。亲近胜法不亲近不胜法。乐出息入息及乐出息入息觉知得悦喜。是谓学乐出息觉知学乐入息觉知(六事竟)

何谓学心行出息觉知学心行入息觉知心行。谓想思有粗细。云何粗心行。若心行掉动。是名粗心行。云何细心行。若心行寂静。是名细心行。如比丘细心行粗心行。以细心行调伏粗心行。降胜除出。如巧匠巧匠弟子。以小楔出大楔。如是比丘。以细心行调伏粗心行。比丘思惟法生粗心行。善取法相善思惟善解。若思惟法不生粗心行。善取法相善思惟善解。若法胜非胜能生粗心行。善取法相善思惟善解。比丘思惟法生细心行。善取法相善思惟善解。若思惟法不生细心行。善取法相善思惟善解。若法胜非胜能生细心行。善取法相善思惟善解。比丘思惟法生心行。出息入息善取法相善思惟善解。若思惟法不生心行。出息入息善取法相善思惟善解。若法胜非胜能生心行。出息入息善取法相善思惟善解。比丘思惟法生心行。出息入息觉知。善取彼法相善思惟善解。若思惟法不生心行。出息入息觉知。善取法相善思惟善解。若法胜非胜能生心行。出息入息觉知。善取法相善思惟善解。比丘思惟法生粗心行。不思惟法。若不生思惟。亲近胜法不亲近不胜法。比丘思惟法生细心行思惟法。若不生不思惟法。亲近胜法不亲近不胜法。比丘思惟法。生心行。出息入息觉知思惟法。若不生不思惟法。亲近胜法不亲近不胜法。比丘不思惟不应所修法。思惟应所修法。亲近胜法不亲近不胜法。心行出息入息及心行出息入息觉知得悦喜。是谓学心行出息觉知学心行入息觉知(第七竟)

舍利弗阿毗昙论卷第二十八舍利弗阿毗昙论卷第二十九

        姚秦罽宾三藏昙摩耶舍共昙摩崛多等译

    绪分定品之二

何谓学除心行出息学除心行入息心行。谓想思有粗细。云何粗心行。若掉动。是名粗心行。若心行寂静。是名细心行。如比丘以细心行调伏粗心行。降胜除出。如巧匠巧匠弟子以小楔出大楔。如是比丘以细心行调伏粗心行。如人驰走自思惟。我何故走。我当安徐行。便安徐行。自思惟。我何故安徐行。我当住便住。自思惟。我何故住。我当坐便坐。自思惟。我何故坐。我当卧便卧。如是除粗心行亲近细心行。比丘如是除粗心行亲近细心行。比丘思惟法生粗心行。善取法相善思惟善解。若思惟法不生粗心行。善取法相善思惟善解。若法胜非胜能生粗心行。善取法相善思惟善解。比丘思惟法生细心行。善取法相善思惟善解。若思惟法不生细心行。善取法相善思惟善解。若法胜非胜能生细心行。善取法相善思惟善解。比丘思惟法除粗心行。善取法相善思惟善解。若思惟法不除粗心行。善取法相善思惟善解。若法胜非胜能除粗心行。善取法相善思惟善解。比丘思惟法知除心行。出息入息。善取法相善思惟善解。若思惟法不生心除行。出息入息。善取法相善思惟善解。若法胜非胜能生心除行。出息入息善取法相善思惟善解。比丘思惟法生心除行。出息入息觉知。善取法相善思惟善解。若思惟法不生心除行。出息入息觉知。善取法相善思惟善解。若法胜非胜能生心除行。出息入息觉知。善取法相善思惟善解。比丘思惟法生粗心行。不思惟法若不生思惟法。亲近胜法不亲近不胜法。比丘思惟法生细心行思惟法。若不生不思惟法。亲近胜法不亲近不胜法。比丘思惟法除粗心行思惟法。若不除不思惟法。亲近胜法不亲近不胜法。比丘思惟法生心除行。出息入息思惟法。若不生不思惟法。亲近胜法不亲近不胜法。比丘思惟法生心除行。出息入息觉知思惟法。若不生思惟法。亲近胜法不亲近不胜法。比丘不思惟不应所修法。思惟应所修法。亲近胜法不亲近不胜法。心除行。出息入息。及心除行。出息入息觉知得悦喜。是谓学除心行出息学除心行入息(八事竟)

何谓学心出息觉知学心入息觉知。心谓心意识六识身七识界。是名心。彼心有善不善。如比丘思惟法生不善心。善取法相善思惟善解。若思惟法不生不善心。善取法相善思惟善解。若法胜非胜。能生不善心。善取法相善思惟善解。比丘思惟法生善心。善取法相善思惟善解。若思惟法不生善心。善取法相善思惟善解。若法胜非胜能生善心。善取法相善思惟善解。比丘思惟法生心。出息入息善取法相善思惟善解。若思惟法不生心。出息入息善取法相善思惟善解。若法胜非胜能生心。出息入息善取法相善思惟善解。比丘思惟法生心。出息入息觉知。善取法相善思惟善解。若思惟法不生心。出息入息觉知。善取法相善思惟善解。若法胜非胜能生心。出息入息觉知。善取法相善思惟善解。比丘思惟法生不善心。不思惟法若不生不思惟法。亲近胜法不亲近不胜法。比丘思惟法生善心思惟法。若不生不思惟法。亲近胜法不亲近不胜法。比丘思惟法生心。出息入息思惟法。若不生不思惟法。亲近胜法不亲近不胜法。比丘思惟法生心。出息入息觉知思惟法。若不生不思惟法。亲近胜法不亲近不胜法。比丘不思惟不应所修法。思惟应所修法。亲近胜法不亲近不胜法。心出息入息。及心出息入息觉知得悦喜。是谓学心出息觉知学心入息觉知(九事竟)

何谓学悦心出息学悦心入息。悦心谓悦豫重悦豫究竟悦豫。但非喜是名悦。比丘思惟法生悦。善取法相善思惟善解。若思惟法不生悦。善取法相善思惟善解。若法胜非胜能生悦。善取法相善思惟善解。比丘思惟法生悦心。善取法相善思惟善解。若思惟法不生悦心。善取法相善思惟善解。若法胜非胜能生悦心。善取法相善思惟善解。比丘思惟法生悦心。出息入息善取法相善思惟善解。若思惟法不生悦心。出息入息善取法相善思惟善解。若法胜非胜能生悦心。出息入息善取法相善思惟善解。此比丘若思惟法生悦心。出息入息觉知善取法相善思惟善解。若思惟法不生悦心。出息入息觉知。善取法相善思惟善解。若法胜非胜能生悦心。出息入息觉知。善取法相善思惟善解。比丘思惟法生悦心思惟法。若不生不思惟法。亲近胜法不亲近不胜法。比丘思惟法生悦心。出息入息思惟法。若不生不思惟法。亲近胜法不亲近不胜法。比丘思惟法生悦心。出息入息觉知思惟法。若不生不思惟法。亲近胜法不亲近不胜法。比丘思惟应所修法。不思惟不应所修法。亲近胜法不亲近不胜法。悦心出息入息。及悦心出息入息觉知得悦喜。是谓学悦心出息学悦心入息(十事竟)

何谓学定心出息学定心入息。定谓心住正住。是名定。如比丘思惟法生定心。善取法相善思惟善解。若思惟法不定生心。善取法相善思惟善解。若法胜非胜能生定心。善取法相善思惟善解。比丘思惟法生定心。善取法相善思惟善解。若思惟法不生定心。善取法相善思惟善解。若法胜非胜能生定心。善取法相善思惟善解。比丘思惟法生定心。出息入息善取法相善思惟善解。若思惟法不生定心。出息入息善取法相善思惟善解。若法胜非胜能生定心。出息入息善取法相善思惟善解。比丘思惟法生定心。出息入息觉知。善取法相善思惟善解。若思惟法不生定心。出息入息觉知。善取法相善思惟善解。若法胜非胜能生定心。出息入息觉知。善取法相善思惟善解。比丘思惟法生定心思惟法。若不生不思惟法。亲近胜法不亲近不胜法。比丘思惟法生定心。出息入息思惟法。若不生不思惟法。亲近胜法不亲近不胜法。比丘思惟法生定心。出息入息觉知思惟法。若不生不思惟法。亲近胜法不亲近不胜法。比丘思惟法生定心。出息入息觉知思惟法。若不生不思惟法。亲近胜法不亲近不胜法。比丘思惟应所修法。不思惟不应所修法。亲近胜法不亲近不胜法。定心出息入息及定心出息入息觉知得悦喜。是谓学定心出息学定心入息(十一事竟)

何谓学解脱心出息学解脱心入息。解脱谓心向彼尊上彼倾向彼。以彼解脱。是名解脱。如比丘思惟法生解脱。善取法相善思惟善解。若思惟法不生解脱心。善取法相善思惟善解。若法胜非胜能生解脱心。善取法相善思惟善解。比丘思惟法生解脱心。善取法相善思惟善解。若思惟法不生解脱心。善取法相善思惟善解。若法胜非胜能生解脱心。善取法相善思惟善解。比丘思惟法生解脱心。出息入息善取法相善思惟善解。若思惟法不生解脱心。出息入息善取法相善思惟善解。若法胜非胜能生解脱心。出息入息善取。法相善思惟善解。比丘思惟法生解脱心。出息入息觉知善取法相善思惟善解。若思惟法不生解脱心。出息入息觉知。善取法相善思惟善解。若法胜非胜能生解脱心。出息入息觉知。善取法相善思惟善解。比丘思惟法生解脱心思惟法。若不生不思惟法。亲近胜法不亲近不胜法。比丘思惟法生解脱心。出息入息思惟法。若不生不思惟法。亲近胜法不亲近不胜法。比丘思惟法生解脱心。出息入息觉知思惟法。若不生不思惟法。亲近胜法不亲近不胜法。比丘思惟应所修法。不思惟不应所修法。亲近胜法不亲近不胜法。解脱心出息入息。及解脱心出息入息觉知得悦喜。是谓学解脱心出息学解脱心入息(十二事竟)

何谓学无常观出息学无常观入息。何谓无常想。如比丘或在树下露。处如是思惟。色无常受想行识无常。如实人若想忆想。是名无常想。云何观。知实人若观正观微观分别解射。是名观。比丘思惟法生无常想。善取法相善思惟善解。若思惟法不生无常想。善取法相善思惟善解。若法胜非胜能生无常想。善取法相善思惟善解。比丘思惟法生无常想。善取法相善思惟善解。若思惟法不生无常观。善取法相善思惟善解。若法胜非胜能生无常观。善取法相善思惟善解。比丘思惟法生无常观。出息入息善取法相善思惟善解。若思惟法不生无常观。出息入息善取法相善思惟善解。若法胜非胜能生无常观。出息入息善取法相善思惟善解。比丘思惟法生无常观。出息入息觉知。善取法相善思惟善解。若思惟不生无常观。出息入息觉知。善取法相善思惟善解。若胜非胜能生无常观。出息入息觉知。善取法相善思惟善解。比丘思惟法生无常想。思惟法若不生无常观。若不生思惟法。亲近胜法不亲近不胜法。比丘生无常观思惟。若不生思惟。亲近胜法不亲近不胜法。比丘思惟生无常观。出息入息思惟法。若不生不思惟。不亲近胜法。不亲近不胜法。比丘思惟法生无常观。出息入息觉知思惟法。若不生不思惟。亲近胜法不亲近不胜法。比丘思惟应所修法。不思惟不应所修法。亲近胜法不亲近不胜法。无常观出息入息。无常观出息入息觉知得悦喜。是谓学无常观出息学无常观入息(十三事竟)

何谓学离欲观出息学离欲观入息。何谓离欲想。如比丘或在树下露处。如是思惟。若爱尽离欲涅槃寂静妙胜。如实人若想忆想。是名离欲想。何谓观。如实人若观正观微观分别解射。是名观。比丘思惟法生涅槃离欲想。善取法相善思惟善解。若思惟法不生离欲想。善取法相善思惟善解。若思惟法不生离欲想。善取法相善思惟善解。若法胜非胜能生离欲想。善取法相善思惟善解。比丘思惟法生离欲观。善取法相善思惟善解。若思惟法不生离欲观。善取法相善思惟善解。若法胜非胜能生离欲观。善取法相善思惟善解。比丘思惟法生离欲观。出息入息善取法相善思惟善解。若思惟法不生离欲观。出息入息善取法相善思惟善解。若法胜非胜能生离欲观。出息入息善取法相善思惟善解。比丘思惟法生离欲观。出息入息觉知。善取法相善思惟善解。若思惟法不生离欲观。出息入息觉知。善取法相善思惟善解。若法胜非胜能生离欲观。出息入息觉知。善取法相善思惟善解。比丘思惟法生离欲想思惟法。若不生不思惟法。亲近胜法不亲近不胜法。比丘思惟法生离欲观思惟法。若不生不思惟法。亲近胜法不亲近不胜法。比丘思惟法生离欲观。出息入息思惟法。若不生不思惟法。亲近胜法不亲近不胜法。比丘思惟法生离欲观。出息入息觉知思惟法。若不生不思惟。亲近胜法不亲近不胜法。比丘思惟应所修法。不思惟不应所修法。亲近胜法不亲近不胜法。离欲观出息入息。及离欲观出息入息觉知得悦喜。是谓学离欲观出息。学离欲观入息(十四事竟)

何谓学灭观出息学灭观入息。何谓灭想。如比丘或在树下露处。如是思惟。若爱尽涅槃寂静妙胜。如实人若想忆想。是名灭想。何谓观。如实人观正观微观分别解射。是名观。比丘思惟法生灭想。善取法相善思惟善解。若思惟不生灭想。善取法相善思惟善解。若法胜非胜能生灭想。善取法相善思惟善解。比丘思惟法生灭观。善取法相善思惟善解。若思惟法不生灭观。善取法相善思惟善解。若法胜非胜能生灭观。善取法相善思惟善解。比丘思惟法生灭观。出息入息善取法相善思惟善解。若思惟法不生灭观。出息入息善取法相善思惟善解。若法胜非胜能生灭观。出息入息善取法相善思惟善解。比丘思惟法生灭观。出息入息觉知。善取法相善思惟善解。若思惟法不生灭观。出息入息觉知。善取法相善思惟善解。若法胜非胜能生灭观。出息入息觉知。善取法相善思惟善解。比丘思惟法生灭想思惟法。若不生不思惟法。亲近胜法不亲近不胜法。比丘思惟法生灭观思惟法。若不生不思惟法。亲近胜法不亲近不胜法。比丘思惟法生灭观。出息入息思惟法。若不生不思惟法。亲近胜法不亲近不胜法。比丘思惟应所修法。不思惟不应所修法。亲近胜法不亲近不胜法。灭观出息入息。及灭观出息入息觉知得悦喜。是名学灭观出息学灭观入息(十五事竟)

何谓学出世观出息学出世观入息。何谓出世想。如比丘或在树下露处。如是思惟。舍一切流爱尽涅槃寂静妙胜。如实人若想忆想。是名出世想。云何观。如实人若观正观微观分别解射。是名观。比丘思惟法生出世想。善取法相善思惟善解。若思惟法不生出世想。善取法相善思惟善解。若法胜非胜能生出世想。善取法相善思惟善解。比丘思惟法生出世观。善取法相善思惟善解。若思惟法不生出世观。出息入息善取法相善思惟善解。若法胜非胜能生出世观。出息入息善取法相善思惟善解。比丘思惟法生出世观。出息入息觉知。善取法相善思惟善解。若思惟法不生出世观。出息入息觉知。善取法相善思惟善解。若法胜非胜能生出世观。出息入息觉知。善取法相善思惟善解。比丘思惟法生出世想思惟。若不生不思惟。亲近胜法不亲近不胜法。比丘思惟法生出世观思惟法。若生不思惟法。亲近胜法不亲近不胜法。比丘思惟生出世观。出息入息思惟法。若不生不思惟法。亲近胜法不亲近不胜法。比丘思惟法生出世观。出息入息觉知思惟法。若不生不思惟法。亲近胜法不亲近不胜法。比丘思惟应所修法。不思惟不应所修法。亲近胜法不亲近不胜法。出世观出息入息。及出世观出息入息觉知得悦喜。是谓学出世观出息学出世观入息。是名共念出息入息定。何谓共念出息入息。出谓出息。入谓入息。若以出息为境界念。若以入息为境界念。定共住共灭。若有系念于出息系念于入息心得共住。是名共念出息入息(十六事竟)

何谓共不净想定。如比丘观察自身。从顶至足从足至顶。乃至皮肤皆是不净。谓骨齿爪发薄皮厚皮。血肉筋脉脾肾心肺。大小便利涕唾脓血。膏肪脑膜泪汗骨髓。如明眼人观仓中谷胡麻麦豆种种别异。如是比丘观自身。从顶至足皆是不净。如实人若想忆想。是谓不净想。若定此想共生共住共灭。是名共不净想定。复次比丘。思惟骨知骨解骨受骨。乃至思惟泪汗知泪汗解泪汗受泪汗。如实人若想忆想。是名共不净想定。复次比丘观四大身。此身有地大水火风大。如屠牛师屠师弟子。屠牛四分。若坐若立观此四分。如是比丘观四大身。有地大水火风大。观此诸大各各相违。此身诸大依于外大。饮食长养羸劣不坚。念念摩灭暂住不久。如实人若想忆想。乃至是名共不净想定。复次比丘观身尽空俱空。以念遍知解行。犹如竹[竺-二+韋]尽空俱空。如是比丘观身尽空俱空。以念遍知解行。如实人若想忆想。乃至是名共不净想定。复次比丘观身如痈疮。身有九疮津漏门。所出津漏皆是不净津漏。是胎始膜是腐败是臭秽。是可恶津漏。眼出眵泪脓血津漏耳出耵聍脓血津漏。鼻出涕唾脓血津漏。口出涎唾脓血津漏。二处出便利脓血津漏。如人痈疮干痂久住。如是九疮津漏门所出。皆是不净津漏。是胎始膜是腐败。是臭秽是可恶津漏。乃至如摩诃迦叶所说。四大身是衰耗相违津漏。众病居处众苦依处。爱护身者如爱护死尸。寿命短促。如实人若想忆想。乃至是名共不净想定。复次比丘若见死尸弃在冢间。若一日至三日。观自身如是法如是相未离是法。如实人若想忆想。乃至是名共不净想定。复次比丘若见死尸弃在冢间。若一日二日膖胀青瘀。观自身如是法如是相。未离是法。如实人若想忆想。乃至是名共不净想定。复次比丘若见死尸弃在冢间。若一日至三日。为乌鸟虎狼若干诸兽之所食啖。观自身如是法如是相。未离是法。如实人若想忆想。乃至是名共不净想定。复次比丘若见死尸。骨节相连青赤烂坏。脓血不净臭秽可恶。观自身如是法如是相。未离是法。如实人若想忆想。乃至是名共不净想定。复次比丘若见死尸。骨节相连血肉已离筋脉未断。观自身如是法如是相。未离是法。如实人若想忆想。乃至是名共不净想定。复次比丘若见死尸。骨节已坏未离本处。观自身如是法如是相。未离是法。如实人若想忆想。乃至是名共不净想定。复次比丘若见死尸。骨节已坏远离本处。脚髀膊臗脊胁肋手足肩臂项髑髅各各异处。观自身如是法如是相。未离是法。如实人若想忆想。乃至是名共不净想定。复次比丘若见死尸。骨节久故色白如贝。色青如鸽朽败碎坏。观自身如是法如是相。未离是法。如实人若想忆想。乃至是名共不净想定。复次比丘观骨胞膖胀青瘀。上有赤烂相离散。如实人若想忆想。乃至是名共不净想定。复次比丘知骨解骨受骨。乃至思惟散知散解散受散。如实人若想忆想。乃至是名共不净想定。何谓共不净想定。若比丘从顶至足从足。至顶乃至皮肤皆是不净。谓骨齿爪发薄皮厚皮。乃至泪汗骨髓。如明眼人观仓中谷胡麻麦豆种种别异。如是比丘观见自身。从顶至足皆是不净。如实人若想忆想。是名不净想。以此想调伏心。修令柔软令定心住。是名共不净想定。复次比丘观身四大。乃至思惟骨解骨受骨。乃至思惟散知散解散受散。如实人若想忆想。是谓不净想。以此想调伏心修令柔软。得定心住正住。是名不净想定

何谓入火定。如比丘内火大受为火。内地水风大受为薪。比丘以内火大内地水风大。思惟烟知烟解烟受烟。思惟炎知炎解炎受炎。比丘如是不放逸观。烟炎如大火聚。若修此定已。烟炎如大火聚。是名入火定。复次比丘内火大受为火。外地水风大草木枝叶受为薪。比丘以内火大外地水风大草木枝。叶思惟烟知烟解烟受烟。乃至是名入火定。复次比丘内火大受为火。内外地水风大草木枝叶受为薪。比丘以内火大内外地水风大草木枝叶。思惟烟知烟解烟受烟。乃至是名入火定。复次比丘外火大受为火。内地水风大受为薪。比丘以外火大内地水风大。思惟烟知烟解烟受烟。乃至是名入火定。复次比丘外火大受为火。外地水风大草木枝叶受为薪。比丘以外火大外地水风大草木枝叶。思惟烟知烟解烟受烟。乃至是名入火定。复次比丘外火大受为火。内外地水风大草木枝叶受为薪。比丘以外火大内外地水风大草木枝叶。思惟烟知烟解烟受烟。乃至是名入火定。复次比丘内外火大受为火。内地水风大受为薪。比丘以内外火大受为火。内地水风大。思惟烟知烟解烟受烟。乃至是名入火定。复次比丘内外火大受为火。外地水风大草木枝叶受为薪。比丘以内外火大外地水风大草木枝叶。思惟烟知烟解烟受烟。乃至是名入火定。复次比丘内外火大受为火。内外地水风大草木枝叶受为薪。比丘以内外火大内外地水风大草木枝叶。思惟烟知烟解烟受烟。乃至是名入火定

何谓共证知神足定。欲定断行成就修神足。精进定心定慧定断行成就修神足。受种种神足震动大地。以一为多以多为一。若近若远。高山墙壁彻过无阂。如行虚空。结加趺坐陵空如鸟。出入地中如出没水。履水如地。身出烟炎如大火聚。日月威德以手扪摸。乃至梵天身得自在。云何动地。如比丘受少地想。受无量水想。若欲动地动正动。如所欲随所欲尽所欲。如沽酒师沽酒师弟子压酒已。以囊投大水中。手执两角抬举随意牵挽自在。如所欲随所欲尽所欲。如是比丘受少地想。受无量水想。若欲动地动正动。如所欲随所欲尽所欲。是名地动定。云何以一为多。如比丘定亲近多修学已。于自身起心化为余色身。支节具足诸根无缺。如陶师陶师弟子治成调泥为种种器。悉能成办能得财利。如是比丘于自身起心。化为余色身。支节具足诸根无缺。如是思惟。此四大色身所化色身。四大色身异。所化色身异。于此四大色身起心。化为余色身。支节具足诸根无缺。如人出箱中衣。如是思惟。此是箱此是衣。箱异衣异。以箱故出衣。如是比丘思惟此四大色身此所化身色。四大色身异。所化色身异。于此四大色身起化心。化为余色身。支节具足诸根无缺。若化为二身三身乃至百身千身。随所欲化为种种身。是名以一为多定。云何以多为一。如比丘定亲近多修学已。以神足化无量身还为一身。如人散种种谷子布地还摄为一聚。如是比丘以神足化作无量身。还摄为一身。是名以多为一定。云何彻过无阂。如比丘定亲近多修学已。若近若远高山墙壁。彻过无碍如游虚空。近谓光明来至于眼。现在已前。不灭不没不除不尽。远谓光明不来至眼。不现在前。灭没除尽。山有二种。土山石山严窟沙石。是名山。墙壁二种。木墙壁土墙壁。若近若远高山墙壁。思惟一切高山墙壁皆空。如比丘于此地山岸棘刺处幽险深河。悉不思惟。但思惟平等如地。如磔牛皮钉布平地无有襵皱。比丘如是不放逸观故。能近物远物。高山墙壁彻过无阂如游虚空。是名彻过无阂定。云何结加趺坐陵虚如鸟。如比丘定亲近多修学已。上升空虚结加趺坐。游于东方南西北方四维上下。犹如飞鸟离地至空。如是比丘不放逸观故。结加趺坐游空如鸟。是名游空定。云何出入地中如出没水。如比丘定亲近多修学已。出入地中如出没水。比丘思惟地为水知水解水受水。如是比丘不放逸观故。出入地如水。是名出入地如水定。云何履水如地。如比丘定亲近多修学已。履水如地。比丘思惟水为地知地解地受地。比丘如是不放逸观故。履水如地。是名履水如地定

云何身出烟炎如大火聚。如比丘定亲近多修学已。身出烟炎如大火聚。比丘受内火大为火。内地水风大为薪。以内火大地水风大。思惟出烟知烟解烟受烟。思惟出炎知炎解炎受炎。比丘如是不放逸观故。身出烟炎如大火聚。是名身出烟炎如大火聚定。云何日月威德以手扪摸。如比丘定亲近多修学已。日月威德以手扪摸。比丘思惟日月为近知近解近受近。比丘住阎浮提。能舒右手扪摸日月。复次比丘自身起心。化为余色身。支节具足诸根无缺。以此化身至四天王上。以手扪摸日月。又以此四大色身。至四天王上。以手扪摸日月。是名日月威德以手扪摸定。云何乃至梵天身得自在。如比丘定亲近多修学已。乃至梵天身得自在。比丘从自身起心。化为余色身。支节具足诸根无缺。以此化身至梵天上亲近梵天。共住共坐共去来共入定。知见共言说。又以此四大色身。飞到梵天亲近梵天。共住共坐共去来共入定。知见共言说。是名乃至梵天身得自在定。若比丘定亲近多修学已。得报定若入定不入定。能作种种无量神足。谓动地乃至梵天身得自在。是名共证知神足定

何谓共证知天耳定。如比丘若取野雚荻声想。比丘心离于野粗雚荻声。令心入细野雚荻声。比丘以细野雚荻声调心柔软。令心入于天耳智证。如是不放逸观。得共证知天耳。得定心住正住。比丘得定已。令心向于人声。人何所论何所说。比丘如是不放逸观。得闻人声。如人所论所说悉皆闻之。如比丘定亲近多修学已。令心向于地狱。畜生饿鬼天声。天何所论何所说。比丘如是不放逸观。得闻天声。如所论所说悉皆闻之。如比丘定亲近多修学已。以天耳清净过人。一时闻二种声。人非人声。若比丘定亲近多修学已。得报定若入定不入定。以天耳清净过人。一时闻二声。人非人声。是名共证知天耳定

何谓共证知他心定。如比丘取自心相。我心何因生何由灭。何亲近何远离。比丘如是取自心相已。令心向他心证知。比丘如是不放逸观。得共证知他心定心住正住。比丘得定已。欲知人心何所思何所觉何所思惟。比丘如是不放逸观。能知人心如所思如所觉如所思惟。悉皆知之。如比丘定亲近多修学已。欲知地狱畜生饿鬼天心何所思何所觉何所思惟。比丘如是不放逸观。能知地狱饿鬼畜生天心如所思如所觉如所思惟。悉皆知之。如比丘定亲近多修学已。能知他人他众生心。有欲心如实知有欲心。无欲心如实知无欲心。有恚心如实知有恚心。无恚心如实知无恚心。有痴心如实知有痴心。无痴心如实知无痴心。没心如实知没心。散心如实知散心。少心如实知少心。多心如实知多心。不定心如实知不定心。定心如实知定心。不解脱心如实知不解脱心。解脱心如实知解脱心。有胜心如实知有胜心。无胜心如实知无胜心。若比丘定亲近多修学已。得报定若入定不入定。能知他人他众生心。有欲心如实知有欲心。乃至有胜心无胜心。如实知有胜心无胜心。是名共证知他心定

何谓共证知宿命定。如比丘思惟无间心。后心前心渐渐无间。比丘如是思惟无间心。得证知共心无间定心住正住。比丘得定已。忆念一心二心三心四心五心十心乃至百心千心若过或有母腹中生初识。比丘如是思惟。何心灭已母腹中生初识。比丘令心向宿命证知。比丘如是不放逸观。得共宿命证知定。心住正住。比丘得定忆念不难。彼本生本有本居处本所起本我分。若欲终心。若心灭已。母腹中受初识。若修此定忆念不难。比丘如是思惟我本何名何姓何生何食何寿命何究竟住受何苦乐。比丘若修此定。知我本如是名如是姓如是生如是食如是寿命如是究竟住如是受苦乐。是名共证宿命定。如比丘定亲近多修学已。忆念一生二生乃至百生千生若过。或曾在无想天上住。知无间心障碍。以凡夫未闻故。言我本不曾在彼忽然自生。以圣人闻故。如是思惟我宿命。始由心证知有如是天。是色无想无受无心住处。比丘如是思惟。我若忆念宿命色。比丘思惟无间色。后色前色渐渐无间。比丘如是思惟无间。色得共证知宿命色无间定。心住正住。比丘得定已忆念不难。是名共证知宿命定如比丘定想。亲近多修学已。忆念一生二生乃至百生千生若过。或有曾在无色天上。以无间色障阂。以凡夫未闻故。言我本不曾在彼忽然自生。以圣人闻故。如是思惟我宿命。由色证知有如是无色有想有受。若无色地。比丘如是思惟。我若忆念宿命心。比丘思惟后心前心渐渐无间。比丘如是思惟无间心。得共宿命心无间定。心住正住。比丘得定已。忆念不难。是名共证知宿命定。如比丘定亲近多修学已。忆念种种无量宿命。若忆念一生二生乃至百生千生。若劫成若劫坏若劫成坏。我本曾在彼。如是名如是姓乃至如是受苦乐。我此命终生彼。彼命终生此。于此成就行。忆念种种无量宿命。若比丘定亲近多修学已得报定若入定不入定。忆念种种无量宿命。从一生乃至于此成就行。是名共证知宿命定

舍利弗阿毗昙论卷第二十九舍利弗阿毗昙论卷第三十

        姚秦罽宾三藏昙摩耶舍共昙摩崛多等译

    绪分定品下

何谓共明想定。如比丘取诸明相。谓火光日月星宿光摩尼珠光。取诸光明相已。若树下露处。思惟光明知光明受光明。如实人若想忆想。是名光明想。若定此想共生共住共灭。是名共明想定。如比丘定亲近多修学已。若树下露处。以清净心遍解行有明胜心。如实人若想忆想。是名明想。若定此想共生共住共灭。是名共明想定。如比丘定亲近多修学已。若一树下。若二三乃至十树下。以清净心遍解行有明胜心。如实人若想忆想。是名明想。若定此想共生共住共灭。是名共明想定。如比丘定亲近多修学已。若一园二三乃至十园。以清净心遍解行有明胜心。如实人若想忆想。是名明想。若定此想共生共住共灭。是名共明想定。如比丘定亲近多修学已。若一园二三乃至十园。以清净心遍解行有明心胜。如实人若想忆想。是名明想。若定此想共生共住共灭。是名共明想定。如比丘定亲近多修学已。若一聚落二三乃至十聚落。以清净心遍解行有明心胜。如实人若想忆想。是名明想。若定此想共生共住共灭。是名共明想定。如比丘定亲近多修学已。若一园二三乃至十园。以清净心遍解行有明心胜。如实人若想忆想。是名明想。若定此想共生共住共灭。是名共明想定。如比丘定亲近多修学已。水陆周匝。以清净心遍解行有明心胜。如实人若想忆想。是名明想。若定此想共生共住共灭。是名共明想定。如比丘定亲近多修学已。以天眼清净过人。见众生生死好色恶色善道恶道卑胜。知众生造业。此众生身恶行成就。口意恶行成就。谤贤圣邪见造邪见业。身坏命终堕地狱畜生饿鬼。此众生身善行成就。口意善行成就。不谤贤圣正见。造正身业。身坏命终生天上人中。如是以天眼清净过人。见众生生死好色恶色善道恶道。知众生造业。修此定已。以天眼清净过人。见众生生死。乃至知所造业。是名共明想定。若比丘定亲近多修学已。得报定。若入定不入定。以天眼清净过人。见众生生死。乃至知众生所造业。是名共明想定

何谓无间定。比丘思惟无常苦空无我涅槃寂静。得定心住。得定已得初圣五根。以得初圣五根故。上正决定。离凡夫地未得须陀洹果。若中命终。无有是处。若未得须陀洹果。堕地狱畜生饿鬼。无有是处。若比丘定亲近多修学已。得无间定向须陀洹果。若此定无间灭已。得须陀洹果。是名无间定。若比丘定亲近多修学已。得无间定向斯陀含果。若此定无间灭已。得斯陀含果。是名无间定。若比丘定亲近多修学已。得无间定。向阿那含果。若此定无间灭已。得阿那含果。是名无间定。若比丘定亲近多修学已。得无间定。向阿罗汉果。若此定无间灭已。得阿罗汉果。是名无间定。云何定根。学人离烦恼。圣心入圣道。若坚信坚法。是名定根。云何定根学人离烦恼。圣心入圣道若坚信坚法。及余趣人见行过患。观涅槃寂灭。若实人观苦集灭道。未得欲得。未解欲解。未证欲证。修道离烦恼。见学人若须陀洹斯陀含阿那含观智具足。若智地若观解脱心。若得四沙门果。若须陀洹果斯陀含果阿那含果。无学人阿罗汉。未得圣法。欲得修道。观智具足。若智地若观解脱心。得阿罗汉果已。如实人如趣人。若心住正住专住缘住。心一定一乐。不分散不舍。心依意心独处定力定觉正定。是名定根。云何定力。定根是名定力。云何定觉。定力是名定觉。云何正定。若定善顺不逆。是名正定。云何邪定。若定不善不顺逆。是名邪定

云何圣定。若定无漏。是名圣定。云何非圣定。若定有漏。是名非圣定

云何有漏定。若定有染。是名有漏定。云何无漏定。若定无染。是名无漏定

云何有染定。若定有求。是名有染定。云何无染定。若定无求。是名无染定。云何有求定。若定当取。是名有求定。云何无求定。若定非当取。是名无求定

云何当取定。若定有取。是名当取定。云何非当取定。若定无取。是名非当取定

云何有取定。若定有胜。是名有取定。云何无取定。若定无胜。是名无取定

云何有胜定。若定有取。是名有胜定。云何无胜定。若定不取。是名无胜定。复次若定有余定胜妙过。是名有胜定。若定无余定胜妙过是名无胜定复次若修定已如来于一切法无碍知见得由力尊胜无上正觉如来十力成就四无所畏。大慈大悲转于法轮。自在成就。除此定若余定。是名有胜定。若上所除定。是名无胜定

云何受定。若定内是名受定。云何非受定。若定外是名非受定

云何内定。若定受是名内定。云何外定。若定非受。是名外定

云何有报定。若定报法。是名有报定。云何无报定。若定报若非报非报法。是名无报定

云何共凡夫定。若定非凡夫入出凡夫亦入出。是名共凡夫定。云何不共凡夫定。若定非凡夫入出。是名不共凡夫定。云何非凡夫共定。若定凡夫入出非凡夫亦入出。是名非凡夫共定。云何非凡夫不共定。若定凡夫入出非凡夫不入出。是名非凡夫不共定

云何共声闻定。若定非声闻入出声闻亦入出。是名共声闻定。云何不共声闻定。若定非声闻入出声闻不入出。是名不共声闻定。云何非声闻共定。若定声闻入出非声闻亦入出。是名非声闻共定。云何非声闻不共定。若定声闻入出非声闻不入出。是名非声闻不共定。云何如电定。若定少少住少时住。如电少少住少时住定亦如是。是名如电定。云何如金刚定。若定无量无量住无量时住。如金刚无量无量住无量时住定亦如是。是名如金刚定。复次若定修已。渐少烦恼分。如电从云中出昭少闇分便速灭。定亦如是。是名如电定。若定修已断一切烦恼。若粗若微无不断灭。无不断灭。如金刚投于珠石无不破坏摧折。定亦如是。是名如金刚定。复次若修定得须陀洹果斯陀含果阿那含果。是名如电定。若修定得阿罗汉果。是名如金刚定。复次若修定得须陀洹果乃至阿罗汉果辟支佛道。是名如电定。若修定若如来所修定。于一切法无碍知见得。由力尊胜无上正觉。如来十力成就四无所畏。大慈大悲转于法轮。自在成就。是名如金刚定

云何不定得定。若定得不定得难得难持。是名不定得定。云何定得定。若定得决定得不难得易持。是名定得定

云何有行难持定。若定得不定得。难得难持。无由力尊自在。不如所欲。不随所欲。不尽所欲。有行难入出。如船逆水难行。定亦如是。是名有行难持定。云何无行易持。定若定得决定得不难得易得。由力尊自在如所欲随所欲尽所欲。无行入出。如船顺水易行。定亦如是。是名无行易持定

云何一分修定。若修定已。想有光明但不见色。若见色不想有光明。是名一分修定。云何二分修定。若修定已。想有光明亦见色。是名二分修定。复次若修定已。生智但不断烦恼。若断烦恼不生智。是名一分修定。若修定已。智生能断烦恼。是名二分修定。复次若修定已尽智生。非无生智。是名一分修定。若修定已。尽智生及无生智。是名二分修定

云何有想定。若定有境界。是名有想定。云何无想定。若定无境界。是名无想定。复次除无想定灭尽定。若余定是名有想定。若无想定灭尽定。是名无想定

云何如事定。若法如法如状貌如自性如随缘所起如相入出。是名如事定

云何忆想定。若法如法相如状貌如自性如随缘起。若如法相。若非如法相入出。是名忆想定

云何离色想定。若定离色想入。若离色想入定。是名离色想定。云何不离色想定。若定不离色想入。若不离色想入定。是名不离色想定。复次若定无色界。是名离色想定。若定色界及圣。是名不离色想定

云何胜入定。若八胜入。是名胜入定

云何一切入定。若十一切入。是名一切入定

云何有觉定。若定觉相应共觉生共住共灭。是名有觉定。云何无觉定。若定非觉相应不共觉生不共住不共灭。是名无觉定

云何有观定。若定观相应共观生共住共灭。是名有观定。云何无观定。若定非观相应不共观生不共住不共灭。是名无观定

云何有喜定。若定喜相应共喜生共住共灭。是名有喜定。云何无喜定。若定非喜相应不共喜生不共住不共灭。是名无喜定

云何共味定。若定染污相应。是名共味定

云何共舍定。若定不苦不乐受相应。是名共舍定

云何忍相应定。若定忍共生共住共灭。是名忍相应定。云何非忍相应定。若定非忍共生共住共灭。是名非忍相应定

云何智相应定。若定共智生共住共灭。是名智相应定。云何非智相应定。若定非智共生共住共灭。是名非智相应定

云何忍始定。若定圣无漏。坚信坚法所修。是名忍始定。云何智始定。若定圣无漏见道人所修。是名智始定

云何欲终定。若定最后识相应。是名欲终定。云何始生定。若定初识相应。是名始生定

云何善定。若定修是名善定。云何不善定。若定断是名不善定。云何无记定。若定受非报非报法。是名无记定

云何学定。若定圣非无学。是名学定。云何无学定。若定圣非学。是名无学定。云何非学非无学定。若定非圣。是名非学非无学定。云何报定。若定受若定善报。是名报定。云何报法定。若定有报。是名报法定。云何非报非报法定。若定无记非我分摄是名非报非报法定

云何见断定。若定不善非思惟断。是名见断定。云何思惟断定。若定不善非见断。是名思惟断定。云何非见断非思惟断定。若定善无记。无名非见断非思惟断定

云何见断因定。若定见断若见断法报。是名见断因定。云何思惟断因定。若定思惟断。若思惟断法报。是名思惟断因定。云何非见断非思惟断因定。若定善若善法报。若非报非报法。是名非见断非思惟断因定

云何下定。若定不善。是名下定。云何中定。若定无记。是名中定。云何上定。若定善。是名上定。复次若定不善无记。是名下定。若定非圣善。是名中定。若定圣无漏。是名上定

云何粗定。若定欲界系。是名粗定。云何细定。若定色界系若不系。是名细定。云何微定。若定无色界系。是名微定。复次若定欲界系色界系。是名粗定。若定空处系识处系不用处系若不系。是名细定。若定非想非非想处系。是名微定。复次若定欲界系色界系空处系识处系不用处系。是名粗定。若定不系。是名细定。若定非想非非想处系。是名微定

云何有觉有观定。无觉有观定。无觉无观定。空定无相定无作定。如道品三支道中广说

云何三愿得定。若愿果得定。若愿得定。若寂静愿得定。若比丘得一二定。若空无相无作定。比丘如是思惟。我应亲近多修学此定。愿欲得四沙门果故。比丘定亲近多修学。愿欲得四沙门果故。比丘定亲近修学。愿得四沙门果。若如是得定。是名愿果得定。若比丘勤进行。或有欲无欲有进无进。比丘如是思惟。我应修此欲及进亲近多修学。比丘欲及进亲近多修学。应勤进定心。若如是得定。是名愿得定。若比丘得一二定。不得定难得难持。比丘如是思惟。我应亲近多修学此定。令我得由力尊自在。比丘定亲近多修学。令我得由力尊自在。若如是得定。是名不寂静愿得定。是名三愿得定。云何非三愿得定。不得果得定。不愿得定。不寂静愿得定。若比丘得一二定。若空无相无作定。比丘不如是思惟。我应亲近多修学此定。不愿欲得四沙门果故。比丘定亲近多修学。不愿欲得沙门果故。比丘定亲近多修学已。得沙门果。若如是得定。是名不愿果得定。若比丘勤进行。或有欲无欲有进无进。比丘不如是思惟。我应修欲及进亲近多修学。比丘欲及进亲近多修学。应勤进定心。若如是得定。是名不愿得定。若比丘近得一二定。不定得难得难持。比丘不如是思惟。我应亲近多修学此定。令我得定由力尊自在。比丘定亲近多修学。令我得定由力尊自在。若如是得定。是名不寂静愿得定。是名非三愿得定

云何内身观内身定。若比丘一切内四大色身摄法。若一处内四大色身摄法。观无常苦空无我。得定心住正住。是名内身观内身定

云何外身观外身定。若比丘一切外四大色身摄法。若一处外四大色身摄法。观无常苦空无我。得定心住正住。是名外身观外身定。云何内外身观内外身定。若比丘一切内外四大色身摄法。若一处内外四大色身摄法。观无常苦空无我。得定心住正住。是名内外身观内外身定。云何内受观内受定。若比丘一切内受。若一处内受。观无常苦空无我。得定心住正住。是名内受观内受定。云何外受观外受定。若比丘一切外受。若一处外受。观无常苦空无我。得定心住正住是名外受观外受定。云何内外受观内外受定。若比丘一切内外受若一处内外受。观无常苦空无我。得定心住正住。是名内外受观内外受定

云何内心观内心定。若比丘一切内心。若一处内心。观无常苦空无我。得定心住正住。是名内心观内心定。云何外心观外心定。若比丘一切外心。若一处外心。观无常苦空无我。得定心住正住。是名外心观外心定。云何内外心观内外心定。若比丘一切内外心。若一处内外心。观无常苦空无我。得定心住正住。是名内外心观内外心定。云何内法观内法定。若比丘除四大色身摄法。及受心余一切内法。若一处内法。观无常苦空无我。得定心住正住。是名内法观内法定。云何外法观外法定。若比丘除四大色身摄法。及受心余一切外法。若一处外法。观无常苦空无我。得定心住正住。是名外法观外法定。云何内外法观内外法定。若比丘除四大色身摄法及受心。余一切内外法。若一处内外法观无常苦空无我。得定心住正住。是名内外法观内外法定

云何内境界定。思惟内法若定生。是名内境界定。云何外境界定。思惟外法若定生。是名外境界定。云何内外境界定。若思惟内外法若定生。是名内外境界定

云何众生境界定。无众生境界定。复次若以慈悲喜舍思惟众生若生定。是名众生境界定

云何色境界定。思惟色法若定生。是名色境界定。云何无色境界定。思惟无色法若定生。是名无色境界定

云何众生境界定。如上说。云何有为境界定。思惟有为法若定生。是名有为境界定。云何无为境界定。思惟无为法若定生。是名无为境界定

云何众生境界定。如上说。云何法境界定。思惟法若定生。是名法境界定。云何无境界定。无无境界定。复次思惟过去未来法若定生。是名无境界定

云何少定。若定少少住少间住。是名少定。云何中定。若定中中住中间住。是名中定。云何无量定。若定无量无量住无量间住。是名无量定。复次若定少住少软少境界。是名少定。若定中住中软中境界。是名中定。若定无量住无量胜无量境界。是名无量定

云何少境界定。若定缘一众生一法一行故生。除如来及涅槃。是名少境界定。云何中境界定。若定缘有量众生有量法故生。除如来及涅槃。是名中境界定。云何无量境界定。若定缘无量众生无量法如来及涅槃故生。是名无量境界定

云何少定少境界。若定缘少住少软一众生一法一行故生。除如来及涅槃。是名少定少境界。云何少定中境界。若定缘少住少软有量众生有量法故生除如来及涅槃。是名少定中境界。云何少定无量境界。若定缘少住少软无量众生无量法如来及涅槃故生。是名少定无量境界。云何中定少境界。若定缘中住中软一众生一法一行故生。除如来及涅槃。是名中定少境界。云何中定中境界若定缘中住中软有量众生有量法故生。除如来及涅槃。是名中定中境界。云何中定无量境界。若定缘中住中软无量众生无量法如来及涅槃故生。是名中定无量境界

云何无量定少境界。若定缘无量住无量胜一众生一法一行。除如来及涅槃。是名无量定少境界。云何无量定中境界。若定缘无量住无量胜有量众生有量法故。除如来及涅槃。是名无量定中境界。云何无量定无量境界。若定缘无量住无量胜无量众生无量法如来及涅槃。是名无量定无量境界

云何少住定。若定少间住。如弹指顷或多。非如构牛顷或多。是名少住定。云何中住定。若定中间住。如构牛顷或多。非七日或多。是名中住定。云何无量住定。若定无量间住七日或多。是名无量住定。云何少定少住。若定少境界少软。若少间住。如弹指顷或多。非如构牛顷或多。是名少定少住。云何少定中住。若定少境界少软。若中间住。如构牛顷或多。非七日或多。是名少定中住。云何少定无量住。若定少境界少软若无量间住。七日或多。是名少定无量住。云何中定少住。若定中境界中软。若少间住。弹指顷或多。非如构牛顷或多。是名中定少住。云何中定中住。若定中境界中软。若中间住。如构牛顷或多。非七日或多。是名中定中住。云何中定无量住。若定中境界中软。若无量间住。七日或多。是名中定无量住。云何无量定少住。若定无量境界无量胜。若少间住。如弹指顷或多。非如构牛顷或多。是名无量定少住。云何无量定中住。若定无量境界无量胜少间住。如构牛顷或多。非七日或多。是名无量定中住。云何无量定无量住。若定无量境界无量胜无量间住。七日或多。是名无量定无量住

云何过去定。若定生已灭。是名过去定。云何未来定。若定未生未出。是名未来定。云何现在定。若定生未灭。是名现在定。云何过去境界定。思惟过去法若定生。是名过去境界定。云何未来境界定。思惟未来法若定。生是名未来境界定。云何现在境界定。思惟现在法若定生。是名现在境界定。云何非过去非未来非现在境界定。思惟非过去非未来非现在法若定生。是名非过去非未来非现在境界定

云何欲界系定。若定欲漏有漏。是名欲界系定。云何色界系定。若定色漏有漏。是名色界系定。云何无色界系定。若定无色漏有漏。是名无色界系定。云何不系定。若定圣无漏。是名不系定

云何作定非离。若定非圣有报。是名作定非离。云何离定非作。若定圣有报能断烦恼。是名离定非作。云何作离定。无一定若作若离。若作定非离。若离定非作。是名作离定。云何非作非离定。除作离定若余定。是名非作非离定。复次作定非离。若定欲界有报。是名作定非离。若定圣有报。能断烦恼。是名离定非作。若修定断欲界烦恼。受色无色界有。是名作离定。若定无报。若定圣有报。非断烦恼。是名非作非离定。取定非出出定。非取出取定。非取非出定。有染定。非离染离染定。非有染有染离染定。非有染非离染定。有扼定。非离扼离扼定。非有扼有扼离扼定。非有扼非离扼定。亦如是

云何智果定非断果。若修定生智非能断烦恼。是名智果定非断果。云何断果定非智果。若修定断烦恼不生智。是名断果定非智果。云何智果断果定。无一定若智果若断果。若智果定非断果。若断果定非智果。是名智果断果定。云何非智果非断果定。除智果断果定。若余定。是名非智果非断果定。复次智果定非断果。若修定得非圣五通。或一或二。是名智果定非断果。若修定得斯陀含果。是名断果定非智果。若修定得须陀洹果阿那含果阿罗汉果。是名智果断果定。若定无报若定有报。非生智非能断烦恼。是名非智果非断果定。智果定非得果定。得果定非智。果智果得果定。非智果非得果定。亦如是

云何尽定非觉。若修定断烦恼不生智。是名尽定非觉。云何觉定非尽。若修定生智不断烦恼。是名觉定非尽。云何尽觉定。无一定若尽若觉。若尽定非觉若觉定非尽。是名尽觉定。云何非尽非觉定。除尽觉定若余定。是名非尽非觉定。复次若修定得斯陀含果。是名尽定非觉。若修定得非圣五通或一或二。是名觉定非尽。若修定得须陀洹果阿那含果阿罗汉果。是名尽觉定。若定非报若定有报。非能断烦恼非生智。是名非尽非觉定。射定非解。解定非射。射解定。非射解定亦如是

云何退分定。若定不善。是名退分定。云何住分定。若定无记。是名住分定。云何增长分定。若定非圣善。是名增长分定。云何射分定。若定圣有报能断烦恼。是名射分定。复次若修定退非圣善法非住不增长。是名退分定。若修定非圣善法住不退不增长。是名住分定。若定共射相应。是名射分定。云何退分定。非住分。若定有退非住。是名退分定非住分。云何住分定非退分。若定住非有退。是名住分定非退分。云何退分住分定。无一定退分住分。若退分非住分若住分非退分。是名退分住分定。云何非退分非住分定。除退分住分定若余定。是名非退分非住分定。云何退分定非增长分。若定有退非增长。是名退分定非增长分。云何增长分定非退分。若定增长非退。是名增长分定非退分。云何退分增长分定。无一定退分增长分。若退分非增长分。若增长分非退分。是名退分增长分定。云何非退分非增长分定。除退分增长分若余定。是名非退分非增长分定。云何退分定非射分。若定有退非射。是名退分定非射分。云何射分定非退分。若定有射非退。是名射分定非退分。云何退分射分定。无一定退分射分。若退分定非射分定。若射分定非退分。是名退分射分定。云何非退分非射分定。除退分射分定若余定。是名非退分非射分定。云何住分定非增长分。若定有住非增长。是名住分定非增长分

云何增长分定非住分。若定有增长。是名增长分定非住分。云何住分增长分定。无一定住分增长分。若住分定非增长分定。若增长分非住分。是名住分增长分定。云何非住分非增长分定。除住分增长分定若余定。是名非住分非增长分定。云何有住分定非射分。若定有住非射。是名住分定非射分。云何射分定非住分定。若射非住。是名射分定非住分。云何住分射分定。无一定若住分射分。若住分定非射分。若射分定非住分。是名住分射分定。云何非住分非射分定。除住分射分定。若余定。是名非住分非射分定。云何增长分定非射分。若定有增长非射。是名增长分定非射分。云何射分定非增长分。若定有射非增长。是名射分定非增长分。云何增长分射分定。无一定若增长分射分。若增长分定非射分。若射分定非增长分。是名增长分射分定。云何非增长分非射分定。除增长分射分定。若余定。是名非增长分非射分定。四念处。四正勤。四神足。四禅。四无量心。四无色定。四向四果。四修定四断。五根五力五解脱入。五出界五观定。五生解脱法。六念六空六出界。六明分法。六悦根法。六无喜正觉。七觉七想七定所须。八圣道八解脱八胜处。九灭九次第灭定九想。十想十正法。十一切入十一解脱入。如上道品广说

舍利弗阿毗昙论卷第三十


施设论卷

    No. 1538

施设论卷第一

        西天译经三藏朝散大夫试光禄卿传梵大师赐紫沙门臣法护等奉　诏译

    对法大论中世间施设门第一(按释论有此门梵本元阙)

    对法大论中因施设门第二

论中问曰。有何所因。转轮圣王。所有女宝。妙色端严。众所乐见。超人状貌。如天色相。答转轮圣王彼女宝者。往昔修因。其事广大。能以清净诸物布施。所谓清净众庄严具。并余饮食衣服。涂香粖香。床座舍宇。及灯明等。以如是因故。轮王女宝。妙色端严。众所乐见。超人状貌。如天色相

又问。何因轮王女宝。不白不黑。肤色中均。不长不短。不肥不瘦。身分亭等。答彼女宝者。往昔修因。其事广大。能行布施。谓以诸色香味皆具足者。饮食等物。自手持奉。起无慢心。行于布施。以如是因故。所有女宝。不白不黑。肤色中均。不长不短。不肥不瘦。身分亭等

又问。何因轮王女宝。寒时温暖。适意快乐。答彼女宝者。往昔修因。其事广大。谓若有时。冬际严凝。大风吹击。境色极寒。人所惶畏。女宝是时。于其父母知识。及师尊所。并余沙门婆罗门众。不生恼害。而复爱乐不恼害者。即以温暖事用所摄。所谓衣服卧具。涂香粖香。床座舍宇。炉炭火具。并余温暖。应用等物。广行布施。以如是因故。轮王女宝。寒时温暖。适意快乐

又问。何因轮王女宝。热时清凉。适悦快乐。答彼女宝者。往昔修因。其事广大。谓若有时。热际炎燠。日光炽逼。随热生虫。人极增恼。女宝是时。于其父母知识及师尊所。并余沙门婆罗门众。不生恼害。而复爱乐不恼害者。即以清凉事用所摄。谓持衣服卧具。涂香粖香。床座舍宇。承足宝机。宝严环钏。多摩罗香。及多罗香所成众具。并余应用等物。广行布施。以如是因故。轮王女宝。热时清凉。适悦快乐

又问。何因轮王女宝。身诸毛孔。有旃檀香。口中常出优钵罗花香。答彼女宝者。往昔修因。其事广大。谓于父母知识及师尊所。并余沙门婆罗门众。不生恼害。而复爱乐不恼害者。即以沉水薰陆郁金多摩罗等。及余上妙诸香。广行布施。以如是因故。身诸毛孔。有旃檀香。口中常出优钵罗花香

又问。何因轮王女宝。侍从转轮圣王。先起后坐。不失规仪。随何所作。悉能承奉。勤力无慢。而复爱语。答转轮圣王。于长时中。随所作用。善业增强。长养成熟。现前胜报。以如是因故。获感女宝爱语承顺

又问。何因轮王女宝。能令转轮圣王。悦意称顺。然无染心况乎身语无不调柔。答转轮圣王。具大威德。于彼彼众生。曾无异心。超人意表。以如是因故。所感女宝。悦意称顺。然无染心

又问。何因轮王女宝。王欲行时。或坐立时。而悉先知。即向王前。作是白言。快哉圣王。所欲行邪。或坐立邪。悉当随从。答彼女宝者。往昔修因。其事广大。谓具慈心。于欲界中。观诸众生。于义所欲。于利所欲。及安乐欲。或若众生。起无利欲。不安乐欲。悉起慈心。慈眼观视。以如是因故。轮王女宝。于王进止。而悉先知

又问。何因轮王女宝。超胜世间。常品女人。如星中月。答彼女宝者。往昔修因。其事广大。谓自不杀生。复教他人。持不杀戒。自不偷盗。不邪染。不妄语。不饮酒。复教他人。一一修持。以如是因故。轮王女宝。超胜诸女。如星中月。又问。何因轮王女宝。不乳产邪。答一切女人。共所病者。谓即胎藏乳产之苦。彼女宝者。于长时中。少病少恼。作诸善业。长养成熟。现前胜妙。果报克成。以如是因故。轮王女宝。而不乳产

又问。何因轮王女宝。先于轮王。而趣命终。答彼女宝者。修诸善业。长时不断。现前胜妙。果报克成。以如是因故。轮王女宝。先于转轮圣王。而趣命终。又问。何因轮王女宝。于诸女中。独得生天。答彼女宝者。本性贤善。而复广修十善业道。以如是因故。轮王女宝。于诸女中。独得生天

又问。何因转轮圣王。得有主藏臣宝。答转轮圣王。往昔修因。其事广大。谓若有时。极寒极热。王于彼等寒热时中。于其父母知识。及师尊所。及余沙门婆罗门众。不生恼害。而复爱乐不恼害者。随时应用妙好医药。及所爱乐上味饮食。并余所须。承事供给。彼等受已。身无不洁。衣无不覆。于昼夜中。常受快乐。以如是因故。转轮圣王。而能获得主藏臣宝。彼主藏臣宝者。大富自在。广多眷属。库藏珍宝。财谷丰盈。受用增积。善业报生。而具天眼。能见伏藏。若有主宰。若无主宰。若水若陆。若近若远。来诣转轮王所。乃至种种丰足供给。勤力无倦。恭白王言。天子所须财宝等事。悉能奉上。过去一时。有转轮圣王。意欲试验主藏臣宝。即命宝船。涉水游行。乃召主藏臣宝。而谓之曰。汝今宜应以财宝等。供我所须。时主藏臣宝。白彼转轮圣王言。圣王就岸。我当奉上王之所须。若不就岸。事应难作。时王即当回以宝船安泊岸侧。彼主藏臣宝。前诣王所。右膝着地。肃恭严奉。作洁净已。二手捧持四金所成上妙宝瓶。满盛众宝。献奉王前。白言圣王。受我所奉上妙众宝。即说颂曰

  清阴细雨从天降　　俯近炎天盛夏时
  举以众宝奉轮王　　及施余诸贫匮者
  彼等受已皆快乐　　丐者咸生欢喜心
  由斯业报广无穷　　获得最胜大财富
  有大神力具天眼　　当为转轮圣王尊

又问。何因主藏臣宝。获得大富。广多库藏。受用增积。答主藏臣宝。往昔修因。其事广大。谓能布施一切沙门婆罗门众。诸贫穷者。诸往来者。诸乞丐者。授以饮食衣服。花鬘涂香。床座舍宇。灯明等物。以如是因故。主藏臣宝。获得大富。广多库藏。受用增积

又问。何因主藏臣宝。胜业报生。能具天眼。于诸伏藏。若有主宰。若无主宰。若水若陆。若近若远。而悉观见。答主藏臣宝。往昔修因。其事广大。谓于父母知识。及师尊所。并余沙门婆罗门众。不生恼害。而复爱乐不恼害者。又于世间。普为一切。痴黑暗冥。作光明照。授与灯明。及然灯具。破诸冥暗。悉使明亮。以如是因故。主藏臣宝胜业报生。能具天眼。水陆远近。悉见伏藏

复次颂曰

  饮食衣服花鬘等　　往昔曾兴清净心
  自手持奉开施门　　复以灯明照诸暗
  得为主藏大臣宝　　近侍名称转轮王
  广多富盛具大财　　能获天眼见伏藏

又问。何因转轮圣王。得有主兵臣宝。答转轮圣王。往昔修因。其事广大。谓于父母知识。及师尊所。并余沙门婆罗门众。不生恼害。而复爱乐不恼害者。于诸昏黑暗冥。作光明照。施以灯具。悉使明亮。以如是因故。转轮圣王。得有主兵臣宝。彼主兵臣宝者。聪睿明利。善喻善察。智慧具足。至于王所。以现世事。正法义利。辅赞于王。于他世事。正法义利。亦悉辅赞。于兵众中。知其王意。存者存之。去者去之。不劳王力。亦复不假四兵运用。无使疲懈。而彼一切自然归伏

复次颂曰

  世间昏黑暗冥者　　普作灯明为照曜
  施诸灯具及光明　　悉使广大皆明亮
  又于父母及知识　　并余沙门婆罗门
  广作灯明普照明　　咸得破暗而焕曜
  由斯善业施安乐　　并余善作诸胜事
  轮王以此胜报因　　获得大智主兵宝

又问。何因主兵臣宝。聪睿明利。善喻善察。具有智慧。答彼主兵臣宝。往昔生中。昔因建立。乃至极远生生之前。已尽已灭。得为人时。于诸沙门婆罗门。聪睿明利。具有智慧。善伺察者。故往亲近恭敬请问。何者是善。何者不善。何者有罪。何者无罪。何者所作。当得胜上。离诸罪业。随所闻已。依法修行。常善伺察。常善思惟。若事若因。勤求请益。作极拔事。行普救因。增极恪志。逼切而行。以如是因故。聪睿明利。具有智慧

复次颂曰

  往昔亲近诸智者　　勤求伺察众善因
  发起最上利益心　　于一切处无退倦
  主兵臣宝由斯力　　今得聪睿具智明
  迅疾发兴精进心　　今为轮王主兵宝

    对法大论中因施设门第三

总说颂曰

  转轮圣王而具有　　轮宝象马并珠宝
  女宝主藏及主兵　　长寿无病具色相
  适意自在复多子　　广如第三蕴中说

如论中说。转轮圣王。即同如来应供正等正觉

复次颂曰

  如论所说转轮王　　即同无上大法王
  于此大地境界中　　转大法轮作善利
  以彼转轮圣王者　　应观即同佛如来
  咸起悲心愍世间　　广利一切大寂默

如转轮圣王有轮宝者。应知即同如来应供正等正觉出现世间所说圣八正道法。以佛所说八正道者。能破世间一切烦恼。于诸法中。得无障碍

复次颂曰

  转轮圣王轮宝者　　于此大地能摧伏
  如佛开演八正门　　解除一切魔怨缚

如转轮圣王有象宝者。应知即同如来应供正等正觉所说四神足法。以佛所说四神足者。能破世间一切烦恼。于诸法中。得无障碍

复次颂曰

  转轮圣王白龙象　　腾空来往悉自在
  如来神足亦复然　　瞿昙名称广神化

如转轮圣王有马宝者。应知即同如来应供正等正觉所说四正断法。以佛所说四正断者。能破世间一切烦恼。于诸法中。得无障碍

复次颂曰

  轮王青身妙马宝　　圆具调驯迅若风
  如佛四正断法门　　速证无为寂静果
  马相严好头顶黑　　而彼马宝轮王乘
  四正断法亦复然　　瞿昙名称广自在

如转轮圣王有珠宝者。应知即同如来应供正等正觉天眼具足。以佛如来具天眼者。随诸众生有所乐欲。佛以天眼悉能观察

复次颂曰

  轮王琉璃妙珠宝　　普遍照曜悉光明
  如来天眼亦复然　　普遍观照悉无碍

如转轮圣王有女宝者。应知即同如来应供正等正觉喜觉。支法

复次颂曰

  转轮圣王妙女宝　　众所乐观复悦意
  喜觉支法亦复然　　瞿昙名称善适悦

如转轮圣王有主藏臣宝者。应知即同如来应供正等正觉四姓亲近。谓刹帝利婆罗门吠舍首陀。于佛世尊现所恭敬持以饮食衣服及余床座病缘医药。奉上世尊

复次颂曰

  如彼转轮大圣王　　最上大富具大财
  瞿昙圣主大名称　　四姓恭敬亦如是

如转轮圣王有主兵臣宝者。应知即同如来应供正等正觉具大胜慧。以佛大慧。能破世间一切烦恼。解除魔缚。于诸法中。得无障碍

复次颂曰

  主兵臣宝善伺察　　复能决择诸义利
  如来大慧亦复然　　解除魔怨诸结缚

如转轮圣王寿命长远久住世者。应知即同如来应供正等正觉。久住世间随诸众生。所有愿求悉令圆满。若住一劫或过一劫。是谓长寿。转轮圣王。正法化世。住寿一劫。亦复如是

如转轮圣王少病恼者。应知即同如来应供正等正觉。无诸损恼病苦不生

复次颂曰

  转轮圣王少病恼　　最上正法化世间
  世尊大师具名称　　无病无恼常安乐

如转轮圣王妙色端严具三十二大丈夫相。一切人众倾渴瞻仰者。应知即同如来应供正等正觉。三十二相。清净圆满。一切众生。瞻仰无厌

复次颂曰

  轮王正法化于世　　相好端严众乐观
  亦如世尊妙相严　　最胜功德皆具足

如转轮圣王众所瞻睹生悦意者。应知即同如来应供正等正觉。一切众生欣乐瞻仰。睹者咸生适悦之心

复次颂曰

  轮王正法化世间　　见者咸生欣悦意
  如来大师最上尊　　众生瞻睹皆欣庆

如转轮圣王千子圆满色相妙好勇猛无畏善伏他军者。应知即同如来应供正等正觉。善化一切众生。修行得果。勇猛无畏。摧烦恼力。趣真实道

复次颂曰

  转轮圣王有千子　　勇猛无畏色相严
  能摧他军具力能　　正法真实而治化
  如来大师化众生　　悉使修行住果位
  四向四果无畏尊　　此等是谓八人地

施设论卷第一施设论卷第二

        西天译经三藏朝散大夫试光禄卿传梵大师赐紫沙门臣法护等奉　诏译

    对法大论中因施设门第四

总说颂曰

  二瑞相出现　　作护胎无染
  完具无欲心　　快乐及不坐
  鹿皮以承接　　七步观四方
  语言并二龙　　及阿难往事
  天花与天药　　床座舍庄严
  受草见法衣　　悲心现神化

又问。何因菩萨。最初于兜率天宫殁已。降母胎时。一切大地。皆悉振动。答龙威力故。以诸龙王得闻菩萨大士大威德者。兜率天宫殁已。降神母胎。乃从水中。跳跃而出。心生欢喜。适悦庆快。乘空盘旋。往返游泳。乐欲瞻睹菩萨圣相。龙出水故。水即大动。以水动故。大地振动。又复菩萨决定当成如来应供正等正觉。已勤为众生宣说出要离生善法。是故上鼓于风。中摇于水。下振于地。此是菩萨。先现瑞相。又问。何因菩萨。最初从兜率天宫殁已。降母胎时。有大光明。普照世界。所有一切黑暗昏冥。悉得明亮。日月威光。映蔽不现。是时所有一切众生。蒙光照已。互得相见。咸作是言。奇哉仁者。有异大士。生此界邪。答以菩萨大士大威德者。最初从彼兜率天宫殁已。降母胎时。有欲色界诸天子众。闻其菩萨大威德者。从兜率天。降神母胎。诸天欢喜。适悦庆快。乘空盘旋。往返游泳。乐欲瞻睹菩萨圣相。而彼诸天。当往返时。有大光明。普照世界。黑暗昏冥。悉使明亮。日月威光。映蔽不现。是时所有一切众生。蒙光照已。互得相见。咸作是言。奇哉仁者。有异大士。生此界邪。奇哉仁者。有异大士。生此界邪。又复菩萨。决定当成如来应供正等正觉已。出现广大胜慧光明。普照世间。此是菩萨先现瑞相

又问。何因菩萨最初从兜率天宫殁已。降母胎时。有四天子。自四方来。随方而住。为菩萨母。密作卫护。答以彼三十三天子众。长时安慰。守护善法。咸作是言。大哉世间无光明者。无归向者。如来应供正等正觉。当出世间。悉为化度。彼诸天子。以利益誓愿为胜缘故。是故来为菩萨圣母。密作卫护

又问。何因菩萨。住母胎中。而能不染胎藏诸垢。无血肉垢无杂秽垢。乃至余诸不净垢等。而悉不染。答菩萨往昔修因。其事广大。谓于父母知识及师尊所。并余沙门婆罗门众。不生恼害。而复爱乐不恼害者。即以清净事用所摄。谓持清净卧具。衣服饮食。涂香粖香。及妙花鬘床座舍宇。灯明等物。广行布施。以清净法。普照众生。由斯善业同分因故。住母胎中。不染诸垢

又问。何因菩萨。住母胎中。身相完具。母亦复见清净圆满。答菩萨往昔修因。其事广大。谓于父母知识。及师尊所。并余沙门婆罗门众。不生恼害。而复爱乐不恼害者。即以完具舍宇衣服饮食受用等物。完无缺者。内心清净。广行布施。由斯善业。同分因故。在母胎中。身相完具

又问。何因菩萨在母胎时。而菩萨母。不于男子起彼欲染和合之意。答菩萨往昔修因。其事广大。谓自能持清净梵行。无非法行。离诸恶香。超越女人染污之法。自能精持诸梵行已。复教他人。如理修持。由斯善业同分因故。而菩萨母。无染欲意

又问。何因菩萨。在母胎时。其菩萨母。奉持五戒。所谓乃至尽寿。不杀不盗。不染不妄。及不饮酒。以不饮酒故。离诸放逸。答菩萨往昔修因。其事广大。谓自断杀生。离杀生业。复教他人断离亦然。自行不盗不染不妄。及不饮酒。复教他人断离亦然。由斯善业同分因故。而菩萨母。奉戒清净

又问。何因菩萨。在母胎时。其菩萨母。身无疲倦。心得快乐。答菩萨大士。具大威德。有胜光明。使菩萨母。大种坚牢。而无增损。以如是因故。而菩萨母。无倦快乐

又问。何因菩萨。出母胎时。大地振动。答菩萨大士。具大威德。广如前说

又问。何因菩萨。出母胎时。有大光明。普照世界。答广如前说

又问。何因菩萨出母胎时。其菩萨母。不坐不卧。安然而立。有刹帝利上族同时所生。答菩萨圣母。少病少恼。作诸善业。胜妙果报。现前克成。故不坐卧。离诸苦受

又问。何因菩萨出母胎时。有四天子。自四方来。以妙鹿皮。承接菩萨。答菩萨长时。少病少恼。作诸善业。胜妙果报。现前克成。故使天来承接菩萨。免致堕地。离诸苦受

又问。何因菩萨初生。即行七步。答菩萨大士。于长时中。正念出离。亲近修习。广多施作。复善记说。又复菩萨决定当成如来应供正等正觉已。广为众生。说七觉支法

又问。何因菩萨初生。观察四方。答菩萨长时。与毗钵舍那所俱正念亲近修习。广多施作。复善记说。又复菩萨决定当成如来应供正等正觉已。观察四圣谛法。广为众生。开示演说。此是菩萨先现瑞相

又问。何因菩萨初生。即作是言。今我此身。是最后有。是边际生。答菩萨在母胎中。常生悲恼。念救众生。既出胎已。乃作是言。今我此身。是最后有。是边际生。又复菩萨。决定当成如来应供正等正觉已。广为众生。说法化度。此是菩萨先现瑞相

又问。何因菩萨初生。于虚空中。天降二水。一冷一暖。用沐菩萨无垢之身。答龙威力故。以彼天龙。于其菩萨。深生净信故现斯相

又问。何因菩萨初生。于圣母前。大水涌现。随菩萨母所欲受用。答龙威力故。以彼诸龙。于菩萨母。深生净信。故现斯相

又问。何因菩萨初生。空中自然奏天音乐。答天威力故。以彼诸天。于其菩萨。深生净信。又复菩萨决定当成如来应供正等正觉已。声闻十方。此是菩萨先现瑞相

又问。何因菩萨初生。空中自然天雨众花。所谓优钵罗花。钵纳摩花。奔拏利伽花。俱母那花。曼陀罗花等。又复雨彼众妙沉水薰陆旃檀香粖。及散天中殊妙之衣。答天威力故。以彼诸天。于其菩萨。深生净信。又复菩萨决定当成如来应供正等正觉已。具大福力。一切衣服饮食床座病缘医药。并余受用。皆悉丰足。此是菩萨先现瑞相

又问。何因菩萨生后。始经七日。其菩萨母。即趣命终。答菩萨大士大威德者。降母胎时。三十三天子众。于其菩萨。极大尊重。即以天胜威光。授菩萨母。其后菩萨出母胎已。母不复有天之威光。但具人中威光色相。众妙饮膳。随宜资养。故菩萨母。速趣命终

如经所说。菩萨能知入胎住胎出胎等事。云何是为菩萨能知入胎住胎出胎等事。答菩萨昔于迦叶如来应供正等正觉法中。最初为菩提故。勤修梵行。正念具足。亲近修习。广多施作。发大誓愿。愿我当成如来应供正等正觉已。所有世间痴暗众生。无救护者。无归向者。广为化度。以是因故。我于迦叶如来法中。最初为菩提故。修梵行已。得生兜率陀天。生彼天已。乃作是念。我当得成如来应供正等正觉已。正念具足。亲近修习。广多施作。以是因故。生彼天中。未久之间。即得彼天三事所摄。一天寿命。二天色相。三天名称。菩萨作是念时。兜率陀天诸天子众。悉知菩萨决定当成如来应供正等正觉。以是缘故。皆生恭敬尊重供养。正念具足。亲近修习。广多施作。乃至菩萨。随彼天子寿量而住。正念具足。亲近修习。广多施作。菩萨即能了知入母胎事。又作是念。我当得成如来应供正等正觉已。正念具足。亲近修习。广多施作。菩萨即能了知出母胎事。住胎亦然

如经所说。佛告尊者阿难言。我念往昔。于彼迦叶如来应供正等正觉法中。最初为菩提故。勤修梵行正念具足。亲近修习。广多施作。发大誓愿。愿我当成如来应供正等正觉已。所有世间痴暗众生。无救护者。无归向者。广为化度。以是因故。我于迦叶如来法中。最初为菩提故。修梵行已。得生兜率陀天。生彼天已。乃至得彼天中三事所摄。即作是念。我当成正觉已。正念具足。修习施作。以是因故。作是念时。彼天子众。悉知菩萨当成正觉。皆生恭敬尊重供养。正念具足。修习施作。以是缘故。乃至菩萨随彼天子寿量而住。修习施作菩萨即能了知从兜率天宫殁已入母胎事。又作是念。我当成正觉已。正念具足。修习施作。菩萨即能了知住母胎事。菩萨又作是念。我当成正觉已。正念具足。修习施作。即能了知出母胎事

复次阿难。我以正念具足修习施作故。未久之间。出母胎藏即行七步

阿难当知。此如是等。一一皆是我昔思念。当成如来应供正等正觉已。广为众生。宣说七觉支法。此是菩萨先现瑞相

施设论卷第二施设论卷第三

        西天译经三藏朝散大夫试光禄卿传梵大师赐紫沙门臣法护等奉　诏译

    对法大论中因施设门第四之二

又复阿难。我出母胎。未久之间。即观四方。乃作是念。我当得成如来应供正等正觉已。当为众生演说四圣谛法。此是菩萨先现瑞相

又复阿难。我出胎未久。即作是言。今我此身。是边际生。乃作是念。我当得成如来应供正等正觉已。当为一切众生。普尽生死边际。此是菩萨先现瑞相

又复阿难。我出胎未久。空中自然雨众天花。谓优钵罗花。俱母陀花。钵讷摩花。奔拏利伽花等。又雨众妙沉水薰陆旃檀香粖。及散天花。乃作是念。我当得成如来应供正等正觉已。具大智慧。具大福德。饮食衣服。床座医药。诸受用具。悉皆丰足。此是菩萨先现瑞相

又复阿难。我出胎未久。空中自然奏天音乐。乃作是念。我当得成如来应供正等正觉已。声闻十方

又复阿难。我昔宫中。与诸宫属同处床座。乃作是念。从今已往。我不复处王宫之座。今我此座。是即最后所处之座。作是念已。从床座起。诣王宫门志欲求出。时有圣贤。密开其门。我于是时。出宫门已。渐次前诣重重宫禁。一一门首。皆有圣贤。为开其门。我于尔时。即作是念。我当得成如来应供正等正觉已。普为众生。开甘露门。此是菩萨先现瑞相

又复阿难。我时乘彼迦蹉迦马王。出王城已。至于他邦。即时下马。乃作是念。今此是我最后所乘王宫宝马。我时所有众庄严具。及迦蹉迦马王而悉不受。还其驭者。乃起是念。今此是我最后所有世间严具。而悉弃置不复受之。阿难当知。我时即持妙色宝剑。自断顶髻。断已复念。今此是我最后自断顶发宝髻。不复重生。即时见一被袈裟衣者。仪相调善。见已欢喜。前诣彼所。而谓之曰。我今奉汝迦尸迦衣。汝可授我袈裟法衣。即作是念。今此是我最后所弃王宫之服。不复重以俗服被体

又复阿难。其后我于吉祥长者所。受吉祥草。诣菩提树下。自敷其草。端身正念。加趺而坐。作是念言。我若不成阿耨多罗三藐三菩提果。誓愿不起于座。又作是念。我今快得善利。何以故。一切众生。处无明中。住着无明。无明卵[穀-禾+卵]。障覆慧眼。我当破无明卵。令诸众生。吉祥安乐

又复阿难。我成佛未久。观见众生世间所生。亦世间老。有利根者。有中根者。有下根者。其下根者。随其行相。而调伏之。乃至不闻正法诸缺减者。彼等众生。我观见已。于彼彼所。起大悲心。为说正法。而化度之

又复阿难。我复作是念。我今快得善利。我于世间杂染中生。而无杂染心意所行

    对法大论中因施设门第五

总说颂曰

  如子下族并贫族　　贼难劫初至十岁
  牛货胜身俱卢洲　　无我及彼欲色界
  佛从定起入涅槃　　最后大衣不焚爇

又问。何因菩萨于一切众生中。最上最胜。有不发大菩提心。而能正信出家者邪。答菩萨长时。观诸众生。等同一子。勤修善业。长养成熟胜妙果报。现前克成。法尔如是。殑伽沙等诸菩萨众。未有不发大菩提心。而能正信出家之者。如其所说。即是不能受欲乐故

又问。何因菩萨不于下族中生。答下族生者。习近慢心。菩萨长时。远离诸慢。亲近善法。修习施作。是故菩萨决定于其上族中生。又若菩萨下族生者。即起谤讪

又问。何因菩萨不于贫族中生。答贫族生者。习近悭吝。菩萨长时。离悭吝垢。亲近修习。广多施作。无悭吝法。是故菩萨。决定于其富族中生。谓以菩萨诸有所得色声香味触等诸境。不历艰苦。自他平等。而受用之。又若菩萨生贫族者。即起谤讪

又问。何因菩萨不生极边国土。及多贼难鄙恶之方。答边恶国土。于戒于见。而悉艰苦。不与菩萨相似同等。而菩萨者。勤修诸善。长养成熟。现前胜妙果报克成。是故菩萨。决定于其大国中生。设有利根清净众生。值遇菩萨大威德者。然亦不能发起最上无漏善法。所谓无上正等菩提缘觉菩提声闻菩提到彼岸法。及余最上无漏善根

又问。何因菩萨不于劫初时生。彼时人寿。始八万岁。答劫初时人。软品根性。所行愚钝。朴质种类。不与菩萨相似同等。菩萨大士大威德者。于长时中。勤修善法。长养成熟。设有利根清净众生。值遇菩萨大威德者。然亦不能发起最上无漏善法

又问。何因菩萨不于人寿最后十岁时生。答人寿十岁之时。广多罪业。广多烦恼。不与菩萨相似同等。是故菩萨大威德者。不于人寿十岁时生

又问。何因菩萨不生西瞿陀尼洲。答西瞿陀尼洲人。软品根性。所行愚钝。朴质种类。不与菩萨相似同等。菩萨大士大威德者。勤修善法。长养成熟。现前胜妙果报克成。是故菩萨。决定于其大国中生。设有利根清净众生。值遇菩萨大威德者。然亦不能发起最上无漏善法。所谓无上正等菩提缘觉菩提声闻菩提到彼岸法。及余最上无漏善根

又问。何因菩萨不生东胜身洲。答如西瞿陀尼洲。其事广说

又问。何因菩萨不生北俱卢洲。答北俱卢洲人。软品根性。所行愚钝。朴质种类。随作艰辛。不与菩萨相以同等。菩萨大士大威德者。于长时中。勤修诸善。长养成熟。现前胜妙果报克成。是故菩萨。决定于其大国中生。设有利根清净众生。值遇菩萨大威德者。然亦不能于一切处发起最上无漏善根。而北俱卢洲人。无我所执。此中问言。北俱卢洲人。何故无我所执邪。答谓以众生数多境界广大所受境界。咸皆悦意。平等无差。故无我所

又问。何因菩萨不生欲界诸天。答谓。欲界中诸天子众。着诸境界。爱乐放逸。不与菩萨相似同等。虽能修持少分梵行。不能广为比丘比丘尼优婆塞优婆夷等四众。广大宣演梵行。令诸天人。各获利益。以是缘故。不生欲界诸天

又问。何因菩萨不生色界诸天。答谓。色界中诸天子众。虽能修持少分梵行。而亦不能广为四众。别别开演所有梵行。令诸天人。各获利益。又复菩萨。不于色界诸天趣证涅槃

此中应问。何故色界天中。不入涅槃。答谓。无色相正受处故。但作意已。正入涅槃

又问。若如此说者。不善心入邪。无记心入邪。答此说应知无记心入

又问。何因诸佛世尊。住世教化。何故贤上大声闻众。先入涅槃。佛乃后入。答以诸声闻。长时无间。勤修善法。长养成熟。现前胜妙果报克成。若见世尊入涅槃者。彼诸声闻。所有胜报。即不圆成。又复法尔殑伽沙数等。诸佛世尊。所有贤上大声闻众。皆先涅槃。佛乃后入。如其所说入涅槃者。诸佛世尊。于第四禅不动地中。现前证入。此中应问。云何世尊。入涅槃邪。或复起邪。答若有所起。即无所入

又问。何因如来世尊。入涅槃已。圣体既焚。大衣如故。若内若外。都无所损。答天威力故。谓以诸天于佛世尊。极生净信。又复二种制止不烧。一者内身。二者外财。当知皆是佛神力故

    对法大论中因施设门第六之一

总说颂曰

  二缘及彼二众出　　声闻三千大千界
  大慈大悲二种心　　不思议及随顺法
  众中差别所行中　　如象王住地狱等

又问。何因佛及轮王。皆具三十二大丈夫相。一谓如来应供正等正觉。二谓转轮圣王。答转轮圣王者。往昔修因。其事广大。于长时中。常起是念。我当广行布施。植诸胜福。长养一切众生。净持戒行。世间痴暗。无归救者。悉为救度。如来应供正等正觉者。随诸所作一切善法。普施世间一切众生。广发大愿。如愿所行。舍家出家。成等正觉。以是因故。转轮圣王。如来应供正等正觉。皆具大丈夫相

又问。何因佛与缘觉。于一时中。不相值遇。答诸缘觉众。于长时中。修缘觉法。胜妙果报现前克成。无所愿求。于最上法。无复施作。亦不乐欲亲近恭敬瞻睹如来。由是因故。佛与缘觉。不同时出

又问。何因二转轮王。不同时出。答转轮圣王。往昔修因。其事广大。谓于长时。勤修诸善。同一妙盖。普覆一切。一轮王出。观诸众生。同一子想。一轮王出。同一境界。尊重供养。随所应作一切善业。胜愿果报现前克成。由是因故。二转轮王。不同时出

又问。何因二佛如来应供正等正觉。不同时出。答菩萨往昔修因。其事广大。谓于长时。唯一师教。一种修习。作诸善法。随其所作。同一解脱。唯一所尊。唯一大智。作诸善业。长养成熟。于一时中。无二果报现前所起。此复云何。答二难并故以是因故。于一时中。二佛如来应供正等正觉。不同出世

又问。何因女人不作转轮圣王。不成帝释。不成梵王。不成魔王。不证缘觉菩提。不证无上正等菩提。答谓。诸女人善力劣弱。男子胜善乐欲根力之所建立。以其极生善欲心故。女无势力。皆是男子善业因作。又复女人。无其利根。唯彼男子善力成故。又彼男子善力增极。乃能获得利根胜业。以如是因故。女人不作转轮圣王。不成帝释。不成梵王。不成魔王。不证缘觉菩提。不证无上正等菩提

又问。何因佛世尊者。具无边智。具无边慧无边辩才。答菩萨长时。于其三慧。亲近修习。广多施作。谓闻所成慧。思所成慧。修所成慧。增极勤勇。以如是因故。佛世尊具无边智慧无边辩才

又问。何因佛世尊。出清净妙音。普闻三千大千世界。悉令晓了。答以佛世尊成道未久。住梵界已。普令亲近得闻解脱。颂句

颂曰

  安住诸佛正教中　　发起精进求出离
  能破生死大力军　　犹如狂象在草舍
  今此清净正法律　　不放逸心善所行
  即能断灭生死轮　　乃尽一切苦边际

如是颂句。一一世界。一一众生。普皆得闻。分明晓了。此是如来清净妙音。普闻三千大千世界

施设论卷第三施设论卷第四

        译经三藏朝散大夫试光禄卿光梵大师赐紫沙门臣惟净等奉　诏译

    对法大论中因施设门第六之二

论中问曰。有何所因。而能了知正觉。世尊于诸众生。大悲超胜。答世尊为见世间众生。染烦恼病。烦恼逼迫。种种烦恼。而生损害。无救无归。无所趣向。以如是因故。世尊不久。乃成正觉。为诸众生。而作救度。是故大悲超胜

又问。何因菩萨入慈心定时。而菩萨身。火不能烧。水不能溺。刀杖不伤。毒不能害。复无中间趣灭。答无恼害定。无定所入。无彼无恼害触亦无。不同分心趣灭。以如是因故。菩萨入慈心定时。水火刀杖毒不能害。复无中间趣灭

又问。何因入无想定。及灭尽定时。水火刀杖毒不能害。复无中间趣灭。答无恼害定。无定所入。亦无无恼害之触。无心趣灭。由此因故。其事如是

又问。何因菩萨在母胎时。而菩萨母。不为水火刀杖毒所恼害。亦无中间趣灭。答菩萨大威力故。以其菩萨胜力。令菩萨母无诸恼害

又问。何因菩萨之身。无水火刀杖毒所恼害。亦无中间趣灭。答菩萨于一切众生中。而得最胜。设于同等类中。亦复最胜

又问。何因彼焰摩王身。无水火刀杖等害。亦无中间趣灭。答焰摩王者。于焰摩界众生类中。而得最胜。由此因故。其事如是

又问。何因爱啰嚩拏象王。及善住象王。身无水火刀杖等害。亦无中间趣灭。答彼于傍生类中。而得最胜。出诸趣类。由此因故。其事如最

又问。何因地狱趣中诸众生类。受极苦楚。而无中间趣灭。答业报炽然故。以其苦受业报未尽。由此因故。其事如是

    对法大论中因施设门第七

复次一时佛在舍卫国。告苾刍众言。苾刍当知。有三种法。为内垢染。内含藏。内怨恶。何等为三。谓贪嗔痴。诸苾刍。此中云何名内垢染内含藏内怨恶。谓若有人。恶友所作。侵他受用。及诸种类。乃至害命。以其贪爱增盛。于身口意。广行诸恶。行诸恶已。由此因缘。身坏命终。堕于恶趣地狱中。生嗔痴亦然。诸苾刍。是故贪嗔痴法。名内垢染内含藏内怨恶

世尊善逝。如是说已

复次总略。而说颂曰

  不能了知贪爱法　　于贪爱法不谛观
  是人与其贪爱俱　　彼即入于黑暗处
  贪染之人无义利　　由贪染心生爱着
  中间生起怖畏心　　当知彼人不觉了
  若能断除于贪爱　　彼即爱尘不能染
  由其贪爱不转时　　如莲不住于渧水
  不能了知嗔恚法　　于嗔恚法不谛观
  是人与其嗔恚俱　　彼即入于黑暗处
  嗔恚之人无义利　　由嗔恚心生过失
  中间生起怖畏心　　当知彼人不觉了
  若能断除于嗔恚　　即于嗔境不生嗔
  由其嗔法坠堕时　　如彼果熟而自落
  不能了知痴冥法　　于痴冥法不谛观
  是人与其痴冥俱　　彼即入于黑暗处
  痴冥之人无义利　　由痴暗心故痴迷
  中间生起怖畏心　　当知彼人不觉了
  若能断除痴冥者　　不为痴境所痴迷
  彼痴冥法若破时　　其犹日光破诸暗
  若能了知此三法　　决定不堕于恶趣
  如断多罗大树心　　彼所断已不复生
  是故贪法及嗔法　　痴等三法皆离着
  行人明慧发生时　　即能尽于苦边际

又问。何因有极贪者。答谓。若有人于贪不善根中。近习修作。于无贪善根中。不近习修作。于其欲想欲因欲寻。而乃近习。亦复修作。于出离想出离因出离寻。不能修作。于诸世间庄严受用。以爱着心。勤行修作。于不庄严受用。不勤修作。于诸善法所应作处。而不能作。复不思惟。不修三摩地行。不能守护诸根隐密之门。食不知量。初夜后夜。常不睡眠。勤行诸恶。不修奢摩他毗钵舍那。于不如理作意中。而乃修作。此等之人。故极贪爱。至谢灭已。当复云何。谓作歌舞倡伎戏笑之人。及为女人。设得生天。即生欲界天中。由此因故。其事如是

又问。何因有极嗔者。答谓。若有人于嗔不善根中。近习修作。于无嗔善根中。不近习修作。于其嗔想嗔因嗔寻。而乃近习。亦复修作。于不嗔想不嗔因不嗔寻。不能修作。于非处起嗔勤行修作。于慈心三摩地。不能修作。于杀害事。勤行修作。于不杀害事。不能修作。于彼诸根隐密之门。不能守护。食不知量。初夜后夜。常不睡眠。勤行诸恶。不修奢摩他毗钵舍那。于不如理作意中。而乃修作。此等之人。故极嗔恚。至谢灭已。当复云何。谓作蝎蜂三目虫百足虫等。由此因故。其事如是

又问。何因有极痴者。答谓。若有人于痴不善根中。近习修作。于无痴善根中。不近习修作。于其害想害因害寻。而乃近习。亦复修作。于不害想不害因不害寻。不能修作。于诸见中。而常修作。及于怪异不祥等事。亦复修作。由是缘故。而不能于缘生法门内心伺察。不能于五取蕴中谛观生灭无常之行。所谓此法是色所成。是色所集。从色所灭。如是受想行识所成。是识所集。从识所灭。此人于诸根隐密之门。不能守护。食不知量。初夜后夜。常不睡眠。勤行诸恶。不修奢摩他毗钵舍那。于不如理作意中。而乃修作。此等之人。故极痴冥。至谢灭已。当复云何。谓作象马驼驴羊鹿牛及猪等。由此因故。其事如是

又问。何因有不极贪者。答谓。若有人于无贪善根中。近习修作。于贪不善根中。不近习修作。于出离想出离因出离寻。而乃近习。亦复修作。于其欲想欲因欲寻。不勤修作。于诸世间不庄严受用。勤行修作。于庄严受用。不勤修作。于诸善法。常所思惟。于三摩地。勤行修作。于不善法。而不修作。守护诸根隐密之门。饮食知量。初夜后夜。常不睡眠。勤行诸善。修奢摩他毗钵舍那。于如理作意中。勤行修作。于不如理作意中。而不修作。此等之人。不极贪爱。至谢灭已。当复云何。谓作仙人及出家人诸长者等。或生色界天中。由此因故。其事如是

又问。何因有不极嗔者。答谓。若有人于无嗔善根中。近习修作。于嗔不善根中。不近习修作。于无嗔想无嗔因无嗔寻。而乃近习。亦复修作。于其嗔想嗔因嗔寻。不勤修作。常修慈心三摩地行。于非处起嗔而亦不作。于不害法。勤行修作。于损害法。而不修作。守护诸根隐密之门。饮食知量。初夜后夜。常不睡眠。勤行诸善。修奢摩他毗钵舍那。于如理作意中。勤行修作。于不如理作意中。而不修作。此等之人。不极嗔恚。至灭谢已。当复云何。谓作仙人。及出家人诸长者等。或生色界天中。由此因故。其事如是

又问。何因有不极痴者。答谓。若有人于无痴善根中近习修作。于痴不善根中不近习修作。于无害想无害因无害寻。而乃近习。亦复修作。于诸见中及怪异不祥等事。悉不修作。以是缘故。而于缘生法门。内心伺察。于五取蕴中。谛观生灭无常之行。所谓此法是色所成。是色所集。从色所灭。如是受想行识所成。是识所集。从识所灭。此人于诸根隐密之门。而常守护。饮食知量。初夜后夜。常不睡眠。勤行诸善。修奢摩他毗钵舍那。于如理作意中。勤行修作。此等之人。不极痴冥。至谢灭已。当复云何。谓作仙人及出家人诸长者等。或生色无色界天中。由此因故。其事如是

    对法大论中因施设门第八之一

总说颂曰

  先际秽气及坚重　　秽气上风而飘散
  充满出息入息俱　　昼夜鱼龟陆中等

如佛所说

佛告诸苾刍言。汝诸苾刍。不能了知先际。皆因有爱二法。于先际中。若无有爱。即后无所起。若能了知如是法者。即自思惟。于后际法。有爱为缘为有相续不了知邪。为无相续邪。或有答言。此无相续。何所以邪。谓不了知故。于无明中。诸众生类。乃起是念。我过去世。为有为无。若过去世有。此即是常。若过去世无。此即是断。而乃诸行或有因邪。若彼诸行先有因者。然亦诸行先无有因。是故若能了知先际。即诸行本来。而无有因

又问。何因未离欲者。当趣灭已。火焚身时。而有秽气。周遍充塞。已离欲者。火焚身时。而无秽气周遍充塞。答未离欲者。谓以身中精血不净。而有流散。以流散故。火焚身时。风飘秽气。而有充塞故。使大威力诸天。不来勤勇作供养事。何以故。秽气未散故。已离欲者。当趣灭已。身无精血。不净流散。以不流散故。火焚身时。而无秽气。是故大威力诸天。悉来勤勇作供养事。何以故。无秽气故

又问。何因未离欲者。当趣灭已。身体坚重。而不调畅。已离欲者。当趣灭已。身体调畅。而不坚重。答未离欲者。上风吹鼓。内入其身。是故坚重。而不调畅。已离欲者。当趣灭已。止摄外风。身得调畅。而无坚重。由此因故。其事如是

施设论卷第四施设论卷第五

        译经三藏朝散大夫试光禄卿光梵大师赐紫沙门臣惟净等奉　诏译

    对法大论中因施设门第八之二

又问。何因未离欲者。当趣灭时。上风吹鼓。内入其身。已离欲者。当趣灭时。无上风吹鼓内入其身。答未离欲者。当趣灭时。外心生起。住着奔流。风吹目开心周遍故。其风不止。是故上风吹鼓内入其身。已离欲者。当趣灭时。无外心生起住着奔流。无风所吹。目不开合。无心周遍。其风乃止。是故无上风吹鼓内入其身。由此因故。其事如是

又问。何因人命存活。身体轻安。而复调畅。命既终殁。身体坚重。而不调畅。答其终殁者。边际分位。火界风界。二界俱灭是故坚重。而不调畅。彼存活者。中间分位。火界风界。二界不灭。是故轻安。而复调畅。由此因故。其事如是。又问。何因人命存活。现住世间。饮食销散。既终殁已。食不销散。答人命存活。现住世者。中间分位。火界水界风界不灭。由彼水界流润。火界成熟。风界吹鼓。故其所食。而乃销散。彼终殁者。边际分位。水界火界风界俱灭。以其所食。水不流润。火不成熟。风不吹鼓。故不销散。由此因故。其事如是

又问。何因人命存活。现住世间。身无秽气既终殁已。秽气充盈。答人命存活。现住世者。中间分位。火界风界。二界不灭。随逐水界。而得盈满。是故彼身。无诸秽气。既终殁已。边际分位。火界风界。二界俱灭。不随水界而得盈满。是故彼身乃有秽气。由此因故。其事如是

又问。何因人命存活。现住世间。出息入息。而常随转。彼终殁者。其事不然。答命存活者。以思惟发悟故。依止于思。是故存活出入息转。既终殁者。无所思故。其事如是

又问。何因彼训狐鸟。夜见昼不见。答彼训狐鸟。目中瞳人。其状赤色。夜中无障。昼即有障。是故夜见而昼不见。又问。何因人能昼见夜乃不见。答人之目中瞳人。其状黑色。昼乃无障。夜即有障。是故昼见而夜不见

又问。何因犬马夜见昼亦能见。答犬马目中瞳人黄色。昼夜无障。是故俱见

又问。何因鱼于水中能见。陆中不见。答诸鱼者目中瞳人。眵泪所覆。水中无障。陆中有障。故水中见。陆中不见。又问。何因人之两目。陆中无障。水中有障。答人之目中瞳人。水泡所成。是故陆中无障。水中有障

又问。何因龟鳖虾蟆。及水蛭等。水陆俱见。答龟鳖虾蟆。及水蛭等。目中瞳人。骨之所成。陆中水中。俱无障碍。是故俱见

    对法大论中因施设门第九

总说颂曰

  睡眠恶戾及棹举　　多舌语言并暗钝
  念慧而复烦恼增　　不颖利于禅定等

又问。何因世间有多睡眠之者。答谓。若有人常所近习。多睡眠者。于光明法中。而不近习。彼人至谢灭已。当复云何。谓作蟒蛇龙等。由此因故。其事如是

又问。何因有少睡眠者。答谓。若有人于光明法中。作光明想。多所近习。于昏沉睡眠法中。而不近习。彼人至谢灭已。当复云何。谓作仙人及出家人诸长者等。或生色无色界天中。由此因故。其事如是

又问。何因有恶戾者。答谓。若有人常所近习。运用执行刀杖器械。诸恶戾人。不能近习。不行刀杖。不恶戾者。彼人至谢灭已。当复云何。谓作屠宰魁脍。畋猎渔捕。调制象马。杻械系缚。诸不律者由此因故。其事如是

又问。何因有不恶戾者。答谓。若有人常所近习。不行刀杖。不恶戾人。而不近习诸恶戾者。彼人至谢灭已。当复云何。谓作仙人及出家人诸长者等。或生色无色界天中。由此因故。其事如是

又问。何因有掉举者。答谓。若有人常所近习。多掉举者。不能近习。诸寂止者。彼人至谢灭已。当复云何。谓作歌舞戏笑之人。或生欲界天中。由此因故。其事如是

又问。何因有不掉举者。答谓。若有人常所近习。诸寂止者。而不近习掉举之人。彼人至谢灭已。当复云何。谓作仙人及出家人诸长者等。或生色无色界天中。由此因故。其事如是

又问。何因世有多舌多语之者。答谓。若有人常所近习多语之人。不能近习少语之者。彼人至谢灭已。当复云何。谓作鹦鹉鹙鹭拘枳罗燕雁等诸飞鸟。由此因故。其事如是

又问。何因有不多舌多语者。答谓。若有人常所近习少语之人。不能近习多语之者。彼人至谢灭已。当复云何。谓作仙人及出家人。诸长者等。或生色无色界天中。由此因故。其事如是

又问。何因有暗钝者。答谓。若有人不能近习多闻之人。不以各各方处之言。说释义理。由此因故。其事如是

又问。何因有不暗钝者。答谓。若有人常所近习多闻之人。不能近习寡闻之者。能以各各方处之言。说释义理。彼人至谢灭已。谓作婆罗门中善说法者。或作沙门中善说法者。由此因故。其事如是

复次当知。少语之人。有其二种。一者卑贱二者尊高何等是为。卑贱少语。谓若有人。虽复卑贱。以有智故。常能依止父母师长名称尊者。及余有智之人。故虽卑贱。而能少语。何等是为尊高少语。谓若有人。本性尊高。而复有智。常能依止父母师长名称尊者。及余有智之人。故能少语

又问。何因世有有行无慧之者。答谓。若有人多求正法。心无厌足。然于理趣。不能伺察。由此因故。其事如是

又问。何因世有有慧无行之者。答谓。若有人于法理趣。能谛伺察。然于正法。不能多求。少以为足。由此因故。其事如是

又问。何因世有无慧无行之者。答谓。若有人不能多求正法。复于理趣。不能伺察。由此因故。其事如是

又问。何因世有有行有慧之者。答谓。若有人多求正法。复于理趣。能谛伺察。由此因故。其事如是

又问。何因。而能住持正法。答谓。若有人能于诸法行相之中依止。十二处法。而善摄受。由此因故。其事如是

又问。何因世有失念之者。答谓。若有人于不善法。积集而转。近习修作。广多恶行。彼人身坏命终。堕在恶趣地狱中。生地狱殁已。设欲来生人同分中。纵得为人。寿量短促。人中殁已。当生还复无多记念。所为忘失。由此因故。其事如是

又问。何因世有多记念者。答谓。若有人于诸善法。积集而转。近习修作。广多善行。彼人身坏命终。堕在善趣天界中。生天趣殁已。若欲来生人同分中。即得为人。寿量长远。人中殁已。当生还复广多记念。所为不忘。由此因故。其事如是

又问。何因世有深极烦恼之者。答谓。若有人于其欲想嗔想害想欲因嗔因害因欲寻嗔寻害寻。近习修作。于极烦恼。随应而转。由此因故。其事如是。又问。何因世有不极烦恼之者。答谓。若有人于出离想不嗔想不害想出离因不嗔因不害因出离寻不嗔寻不害寻。近习修作。于极烦恼。不随应转。由此因故。其事如是

又问。何因世有不能速成禅定忍辱二善法者。答谓。若有人于其诸法行相决定义中不善摄受。由此因故。不能速成禅定忍辱二种善法

又问。何因有能速成禅定忍辱二种善法者。答谓。若有人于其诸法行相决定义中。能善摄受。由此因故。即能速成禅定忍辱二种善法

    对法大论中因施设门第十之一

总说颂曰

  须弥大地及方处　　山有广多草木者
  多树及彼枝叶多　　花果丰盈茂盛等

又问。何因一切山中。须弥山王。最高最胜。答世界成。时彼须弥山。界地最上。处迳最上。殊妙最上。轮围最上。总聚方处。而成其山。由此因故。须弥山王。最高最胜

又问。何因北方地界。多树多草。答世界成时。北面风吹。界地最上。处迳最上。殊妙最上。总聚方处。是故北方多树多草

又问。何因于大地中。一类地高。一类地下。答此大地中。一类地方。土界高涌。得少天雨流润澍渧。其下低陷。故彼地下。又此大地。一类地方。而有诸宝。谓铁白铜白镴黑镴。及金银等。并余所有坚硬之物。藏伏地中。虽天雨澍渧。其下不陷。故彼地高。由此因故。大地方处。有高有下

又问。何因众山之中。一类山高。一类山低。答谓。世界成时。有极猛风。鼓地大种。总聚而高。若复微风吹鼓少聚地种。故彼山低。又复诸山地界高涌。得少天雨流润澍渧。其下低陷。故彼山低。有一类山。而有诸宝。谓铁白铜白镴黑镴。及金银等。并余所有坚硬之物。藏伏山下。虽天雨澍渧。其地不陷。故彼山高。由此因故。大地方处。山有高低

施设论卷第五施设论卷第六

        译经三藏朝散大夫试光禄卿光梵大师赐紫沙门臣惟净等奉　诏译

    对法大论中因施设门第十之二

又问。何因有一类山。多树多草。有一类山。少树少草。答谓。一类山下有龙宫。故多树草。有一类山。下无龙宫。故少树草

又复有山土界高涌。故多树草。又复有山多诸宝物。谓金银铜铁。赤土白土。藏伏山下。故少树草。又复有山。下有各别地狱居处。故少树草

又复山下无别地狱。故多树草。由此因故。其事如是

又问。何因有一类树。其状极大。一类不大。答谓。有地方。地界温暖。水界增涌。火界调顺。风界稳平。故树极大。谓有地方。地不温暖。水不增涌。火不调顺。风不稳平。故树不大。由此因故。其事如是

又问。何因有一类树。其叶极大。一类不大。答谓。有树木。地界温暖。水界增涌。火界调顺。风界稳平。故树叶大。谓有树木。地不温暖。水不增涌。火不调顺。风不稳平。故叶不大。由此因故。其事如是

又问。何因有一类树。其花茂盛。一类无花。答谓。一类树殊妙高耸。故花茂盛。有一类树。状不殊妙。复不高耸。故彼无花。由此因故。其事如是

又复何因有一类树。有其果实。一类无果。答谓。一类树。味界增盛。彼即有果。有一类树。味界不增。故无其果。由此因故。其事如是

又问。何因有一类树。花有妙香。一类无香。答有一类花。本状殊妙。不为火损。故有妙香。有一类花。本非殊妙。复为火损。故无妙香。由此因故。其事如是。又问。何因有一类果。足其嘉味。一类无味。答有一类果。味为火损。其果无味。有一类果。不为火损。其果有味。由此因故。其事如是

余诸花果色香味等。有无亦然

    对法大论中因施设门第十一

总说颂曰

  佛世尊及声闻众　　化人所食四大种
  隐没烟及火炽然　　最后如空无表现

又问。何因佛世尊者。善能化彼所化之人。妙色端严。人所乐见。具大人相。庄严其身。若佛语言。化人即默。若化人语。佛即默然。彼声闻弟子。亦能化彼所化之人。色相端严。剃发被衣。作沙门相。何故能化之者语言。所化之者亦言。能化之者若默。所化之者亦默。答佛世尊者。常住三摩地。心自在故。若入若出。速疾无碍。于一切时。不舍所缘。声闻即不然。不同世尊具一切智。智心得自在。已到彼岸。由此因故。佛所化人妙色端严。语时能默。默时能语。而彼声闻所化之人。虽复色相端严剃发被衣。然能化之者。语即能语。默即还默。不自在故

或有问言。若佛所化如声闻所化。声闻所化如佛所化者。可说具四大种。或不具邪。答具四大种

又问。所化之者。说所造色。或不说邪。答说所造色

又问。所化之者。有思惟邪。无思惟邪。答此有二种所起。一者缘持。二者想成。若缘持所起者。即有思惟。若想成所起者。即无思惟

又问。彼所化者。如何得心自在。答此有二种所起。一者缘持。二者想成。若缘持所起。彼所化者。即心自在。若想成所起。彼所化者。心不自在。

又问。所化之者。中间分位。说具四大种。或不具邪。答说具四大种

又问。中间分位。说所造色。或不说邪。答说所造色

又问。中间分位。有思惟邪。无思惟邪。答此有思惟

又问。中间分位。如何得心自在。答随能化者。自心自在故

又问。所化之者。食于藏腹。如何销散。以是化故。答此有二种所起。一者缘持。二者想成。若缘持所起者。食即销散。若想成所起者。食即不散

又问。彼所化人。何时即隐。答此有二种所起。一者缘持。二者想成。若想成所起者。彼即能隐。若缘持所起者。或隐不隐

问至何时隐。答随能化者。若天若人。若阿修罗。或善相。或恶相。彼隐即隐。何故不隐邪。答中间最后相去悬远。乃至还归自相而住。此即不隐

又问。何因圣人化火之时。为有烟不。答能化之者。心自在故。随其所化。而即有烟。由此因故。其事如是

又问。何因化火之时。火炽焰不。答能化之者。心自在故。随其所化。火即炽焰。由此因故。其事如是

又问。何因化火之时。唯烧自身及自衣饰。不烧他者。答随能化者。其心自在。意所乐故。唯烧自身及自衣饰。由此因故。其事如是

又问。何因圣人化火爇其身时。但观虚空。外无所有影像。及余悉无表现。答圣人化火之时。地方分位。行坐等处。悉以化所成火。混一火界。普皆焚爇。但观虚空。外无所有影像。及余悉无表现。由此因故。其事如是

    对法大论中因施设门第十二

总说颂曰

  大海次第及深广　　海居众生同碱味
  不宿死尸珍宝多　　大身众生注雨等

如经所说。大海次第从小增广。亦非本来而自深险。今问。何因其事如是。答非大海次第从小增广。亦非本来而自深险。随其大洲分位如是。如谷麦聚次第分位。由此因故。其事如是。如经所说大海深广难彻源底。今问。何因其事如是。答非大海深广难彻源底。但以海水。若出若入。或用一器。或百或千。或复百千。而汲海水。随其所取。不能度量海之分量。由此因故。其事如是

如经所说。大海中水。潮不失时。今问。何因其事如是。答时有二种。一旦暮时。二大时。何名旦暮时。谓大海中。所居众生。有其饥虚羸劣之者。少得饮食。为伺求故。从水出陆。以所食因。依时伺求。由此名为旦暮之时。何名大时。谓大海中。所居众生。以海居人。每至八日十四日十五日。及余神通月分日。是等之日。自船登岸。有信向宗事月天之人。有事日天之人。有事童子天人。有尊重信向事佛优婆塞依法不食。广作祠祭乞欢喜事。彼海居众生。以伺求食故。从海出陆。故曰大时

如经所说。大海中水。同一碱味。今问。何因其事如是。答谓。有海居众生。大海中生。大海中老。大海中殁。其未殁者。彼身之垢。身之秽恶。在大海中。故海碱味。又复海中有众山居。经久销镕。亦成碱味。又复大洲之中。近海居人。以其草木枝叶茎[卄/幹]等物。弃置海中。亦成碱味。由此因故。其事如是

如经所说。大海之中。众宝充满。今问。何因其事如是。答以其大海世界成时。界地最上。处径最上。轮围最上。总聚方分。成须弥山王。安止其中。有七金山。周匝围绕。彼大海中。有大威力诸龙王宫。是故大海有众珍宝。由此因故其事如是

如经所说。大海之中。有大身众生。居止于彼。今问。何因其事如是。答彼大身众生者。往昔为人。作诸非法。广积受用。子息眷属。奴婢饮食。但自资身。不行惠施。由斯罪业。乃至最后身坏命终。堕在恶趣地狱中。生地狱殁已。以彼宿造余业未尽故。生海中为彼极大畜类之身。身相大故。令多众生共所食啖。陆地大洲不能容受。皆以宿昔不善业报故。于海中受斯极苦。由此因故。其事如是

如经所说。大海之中。不宿死尸。今问。何因其事如是。答谓。大海中。有洁净行诸大龙宫。若彼最上龙王宫中。有死尸者。即于夜分。弃置第二龙王宫中。乃至第四宫中。如是次第。出置岸上。由此因故。其事如是

如经所说。大海中。有大阎浮树。枝叶繁茂。树汁涌渧。于虚空中。如恶叉聚。流注于彼大海之中。而其海水。不增不减。今问。何因其事如是。答彼大海中。所居众生。共所受用。余即热风吹荡而尽。是故海水。不增不减

如经所说。大海之中。有其种种形显色相种种音声众生居止。非一种类色相音声。今问。何因其事如是。答彼诸众生往昔为人。广造多种罪不善业。谓身语意起诸恶行。乃至最后身坏命终。堕在恶趣地狱中。生地狱殁已余业未尽。堕大海中。受畜类报。故有种种形显色相种种音声。非一种类色相音声。由此因故。其事如是

施设论卷第六施设论卷第七

        译经三藏朝散大夫试光禄卿光梵大师赐紫沙门臣惟净等奉　诏译

    对法大论中因施设门第十三

如经所说。一性所成。有多种类。今问。何因其事如是。答谓。如苾刍引世间定。先得离欲。次不艰苦。复不流散。由彼发起生长积集。后起化事。其所发起生长积集。作化事已。随其意乐。或化人身。或化象身。或化马身。或化牛身。或化飞禽身。或化车相。或化树相。或墙壁相。若来若去。若出若入。往返自在。由此因故。其事如是

如经所说。有多种类。还归一性。今问。何因其事如是。答谓。如苾刍随诸状貌形质事相。或化人身。或化象身。或化马身。或化牛身。或化飞禽身。或化车相。或化树相。或墙壁相。若来若去。若出若入。随诸化事。功用轻捷。彼等化功种种事相。化已隐没。而悉不现。由此因故。其事如是

如经所说。诸变化中。若来若去。随其知见。各各有异。今问。何因其事如是。答谓。若有人欲化来相。先自起念。云何令人不能见我不能知我。念已即当入于定中。腾越墙壁。随意而来。此即来相。人不能见

云何去相。人不能见。谓若有人。欲化去相。先自起念。云何令人不能见我不能知我。念已即当入于定中。腾越墙壁。随意而去。由如是故。去相不见。谓以定中所化来相。即是去相。所化去相。即是来相。如是知见。随其所起。各各有异。各各了知。智者随应。以明慧性。于无相中。而起有相。广大利智。普遍开晓。由此因故。其事如是

如经所说。腾越墙壁。或越山石。其身不着。随意而去。如在空中。今问。何因其事如是。答谓。如苾刍入于空定。于其定中。腾越墙壁。或越山石。其身不着。随意而去。如在空中。所越一切山石墙壁。犹如虚空。悉无障碍

如经所说。有能入地如水履水如地。今问。何因其事如是。答谓。如苾刍入水定时。自地升沉。起伏无碍。如履水中。升沉亦然。不断其流。随意而往。在地如水。履水如地。由此因故。其事如是

如经所说。有能空中先盘结坐。即坐而行。状若飞禽。履空自在。今问。何因其事如是。答谓。如苾刍引世间定。先得离欲。次不艰苦。复不流散。由彼发起生长积集。后起化事。随处地方。能于空中。或坐或行。及于空中。化大火聚。猛焰炽盛。或化烟相。或烟幢相。或化风轮。空中吹鼓。或风轮中。乘象而行。或化车相。或马或人。或化墙壁。或化树相。或化飞禽。随诸化相。人所共见。咸皆起念。惊怪叹异。各各了知。神通之力。其状如是。此乃善修神足智力。由此因故。其事如是

如经所说。或有人。能于虚空中。举手扪触日月二相。今问。何因其事如是。答谓。如苾刍在于定中。以其日从日轮中出。以其月从月轮中出。乃从定中。起神通事。即以手扪虚空。摩触日月。定通力故。随意无碍

如经所说。有人能于梵界往来。随意自在。今问。何因其事如是。答谓。有苾刍引世间定。先得离欲。次不艰苦。复不流散。由彼发起生长积集。后起化事。身心和融。混而为一。心即于身。身即于心。身心相即。运用和融。譬如世间酥蜜水油混融一处。在定苾刍。亦复如是。身心和融。轻安柔软。心想自在。随意能往。梵天界中。高下腾越。悉无障碍。譬如造箧笥人。持以箧笥。腾举运用。随意无碍。又如乞食苾刍。得所施食。堕在钵中。腾举运用。亦无障碍。在定苾刍亦复如是。身心柔软。轻安想生。腾举运用。悉无障碍。乃至梵天宫殿举心即到。色力增盛。势用坚强于梵天界。往来自在

如经所说。佛于一时。谓尊者阿难言。汝可知不。我以如是意所成身。以神通力。随意能往梵天宫殿。阿难白佛言。如是如是。我知世尊即以如是四大所成粗重色身。随意能往梵天宫殿。佛言。阿难。我知如是色身粗重四大和合父母不净羯逻蓝等众缘所成。虽假以饮食衣服澡沐资养种种治事。终归磨灭。破散之法。颇能往彼梵天宫殿。阿难白佛言。能往世尊。能往善逝。如世间铁。及耕犁具。当在鼓铸。炎火炽盛。未出火时。而彼铁具。即皆轻利。加复柔软。易为舒卷。遇凉冷时。彼诸铁具。厚重坚硬。而难舒卷。阿难。如来亦复如是。若时身心和融。轻安想生。加复柔软。调畅安适。随意能往梵天宫殿。又复当知。若心不相续。即心无依止。心无系属。以心无依止无系属故。身即自在

又问。何因所化之人。能于空中随意而行。答能化自在。所化亦然。以化力故。在空如地。由此因故。空中能行

又问。何因所化之人。空中能住。答能化自在。所化亦然。以化力故。化空如地。由此因故。空中能住

又问。何因所化之人。空中能坐。答能化自在。所化亦然。故于空中。化坐分位。由此因故。空中能坐

又问。何因所化之人。能于空中。安布床位。随意而卧。答能化自在。所化亦然。故于空中布设床位。由此因故。空中能卧

此如是等。余诸神通功力化事。如其所说随意。应知

    因施设门第十四

问曰。有何分量。知天降雨。答有八种云。彼第一云。高一由旬半。第二云。高五俱卢舍。第三云。高一由旬量。第四云。高三俱卢舍第五云。高半由旬量。第六云。高一俱卢舍。第七云。高半俱卢舍。第八云。高俱卢舍中四分之一。诸云住已。天雨不雨。其复不定

又问。何因劫初时人。乘云高起一由旬半。一切地中。而悉降雨。答劫初时人。具大威德。彼大力龙。而悉尊仰故。能乘云高由旬半。一切地中。而悉降雨。今时人者。威德减少。大力势龙。不生尊仰。是故今时乘云。能起半俱卢舍。天中降雨。由此因故。其事如是

又问。何因或时天中不降其雨。答有八种因。天不降雨。何等为八

一者合降雨时。电光闪烁。大云振吼。四方冷风。飘扬吹鼓。占候之人。不能明了。但自说言。天将降雨。或复大地火界增勇。即以此缘。天雨隐息。如是乃名第一种因。天不降雨

二者合降雨时。电光闪烁。大云振吼四方冷风。飘扬吹鼓占候之人。不能明了。但自说言。天将降雨。或复空中猛风吹鼓。乃使其雨堕彼辽迥。旷野空舍如是。乃名第二种因天不降雨

三者合降雨。时电光闪烁。大云振吼。四方冷风。飘扬吹鼓。占候之人。不能明了。但自说言。天将降雨。或复罗睺阿修罗王。二手执障使雨堕于大海之中。如是乃名第三种因天不降雨

四者合降雨时。电光闪烁。大云振吼。四方冷风。飘扬吹鼓。占候之人。不能明了。但自说言。天将降雨。或复行雨。天官迷醉放逸。以放逸故。不能降雨。如是乃名第四种因天不降雨

五者合降雨时。电光闪烁。大云振吼。四方冷风。飘扬吹鼓。占候之人。不能明了。但自说言。天将降雨。或复人民多行非法险恶之行。以行非法险恶行故。天不降雨。如是乃名第五种因天不降雨

六者合降雨时。或有神通天子。以彼神通威力。随雨分量。而悉制止。如是乃名第六种因天不降雨

七者以其人民业障法合如是。于此界中。天不降雨。如是乃名第七种因天不降雨

八者或复愆雨泽时。精实祈求。以彼神通威力天子制而不降。如是乃名第八种因天不降雨

又问。何因能使上天依时降雨。答有八种因。能降天雨。何等为八

一者龙威力故。天即降雨。二者夜叉威力故。天即降雨。三者鸠盘茶威力故。天即降雨。四者天威力故。天即降雨。五者人威力故。天即降雨。六者神通力故。天即降雨。七者法合依时。而自降雨。八者精实祈求。天即降雨

又问。何因盛夏热时。及雨际时。广多天雨。答彼二时者。诸龙欢喜。以为节令。自空腾跃。适悦而来。龙喜悦故。于彼二时多降天雨。或复民行正法。修营善业。善力所资。自然二时多降天雨

又问。何因天降雨时。结而成渧。答二方猛风。吹归一聚。故降澍时。结以成渧。或复人造恶业。恶力所资。非人动乱。如斯相者。大无义利。由此因故。其事如是

又问。何因大雨之中。而有其雹。答二方冷风。吹雨一聚。成渧堕地。地复坚硬。下风所吹。或时作雪。或作猛雨。由此因故其事如是

又问。何因有电光出。答二方猛恶热风所吹。二风相击。故有电光。自风而出。由此因故。其事如是

又问。何因雨中有其霹雳振举。答谓。以下方有大猛火。色状炽炎。即火界增勇。火增勇故。即风增勇。风增勇故。有水来去。由此因故。其事如是

又问。何因云有青色。答谓。以水界流润性故

又问。何因有黄有赤。答谓。以火界温燥性故

又问。何因有其白色。答谓。以诸界和合性故。由此应知云相有其青黄赤白

又问。何因世间诸味。有其苦醋及辛咸淡。答谓以诸界互违害故。由此因故。其事如是

又问。何因有其甘味。答谓。以诸界和合性故。由此因故。其事如是

又问。何因世诸物中。有其粗重及坚硬者。答谓。以地界坚强性增

又问。何因有其软滑及调适者。答谓。以水界流润性增。由此因故。其事如是

施设论卷第七


五事毗婆沙论

    No. 1555 [cf. No. 1556]

五事毗婆沙论卷上

        尊者法救造

        三藏法师玄奘奉　诏译

    分别色品第一

  敬礼佛法僧　　我今随自力
  欲于对法海　　探少贞实义
  哀愍弟子等　　当释能生慧
  灭愚五事论　　令彼觉开发

尊者世友为益有情制五事论。我今当释。问何用释此五事论耶。答为欲开发深隐义故。若未开发此深隐义。如有伏藏未开发时。世间无能欢喜受用。若为开发此深隐义。如有伏藏已开发时。世间便能欢喜受用。又如日月虽具威光云等翳时不得显照。若除彼翳显照事成。本论文词应知亦尔。虽已略辩种种胜义。若不广释便不光显。为令光显故我当释。问已知须释五事论因。尊者何缘制造斯论。答有弟子等怖广闻持。欲令依略觉自共相。谓彼尊者常作是思。云何当令诸弟子等于一切法自相共相依止略文起明了觉。以明了觉喻金刚山。诸恶见风不能倾动。不明了觉如芦苇花。为恶见风之所飘鼓。旋还飘扬犹豫空中。如是欲令诸弟子等起坚固觉。故作斯论。问何谓诸法自相共相。答坚湿暖等是诸相自法。无常苦等是诸法共相。世间虽于诸法自相有能知者。然于共相皆不能知。如是欲令诸弟子辈于二相法能如实知。故造斯论。问已知须造五事论缘。此复为何名五事论。答由此论中分别五事。是故此论得五事名。依处能生事义无异。阿毗达磨诸大论师咸作是言。事有五种。一自性事。二所缘事。三系缚事。四所因事。五摄受事。当知此中唯自性事。问若尔何故说有五法。答事之与法义亦无异。问何故此论唯辩五法。有作是说。此责非理。若减若增俱有难故。有说此论略显诸法体类差别不相杂乱摄一切法。故唯说五。若总于五立一法名。虽是略说摄诸法尽。而不能显心等五法体类差别不相杂乱。若说有漏无漏等二。有学无学非二等三。欲色无色不系等四。应知亦尔。问岂不列名即知有五。何故论首先标五数。答如缕系花易受持故。谓如以缕连系众花。易可受持庄严身首。如是数缕连系义花。易可受持庄严心慧。或先标数后列其名。是制作者旧仪式故。应知法声义有多种。谓或有处所说名法。如契经说。汝应谛听。吾当为汝宣说妙法。或复有处功德名法。如契经说。苾刍当知。法谓正见。邪见非法。或复有处无我名法。如契经说诸法无我。当知此中无我名法。法谓能持。或能长养。能持于自长养望他

问何故此中先辩色法。答一切法中色最粗故。是一切识所缘境故。与入佛法为要门故。谓入佛法者。有二甘露门。一不净观。二持息念。依不净观入佛法者观所造色。依持息念入佛法者观能造风。问依何义故说之为色。答渐次积集。渐次散坏。种植生长。会遇怨亲。能坏能成皆是色义。佛说变坏故名为色。变坏即是可恼坏义。有说变碍故名为色。问过去未来极微无表皆无变碍。应不名色。答彼亦是色。得色相故。过去诸色虽无变碍。而曾变碍故立色名。未来诸色虽无变碍。而当变碍故立色名。如过未眼虽不能见。而曾当见故立眼名。得彼相故此亦应尔。一一极微虽无变碍。而可积集变碍义成。诸无表色虽无变碍。随所依故得变碍名。所依者何。谓四大种。由彼变碍无表名色。如树动时影亦随动。或随多分如名段食。或表内心故名为色。或表先业故立色名。色云何者。问尊者何故复说此言。答前所略说今欲广辩。若有见有对色。若无见有对色。若无见无对色。总摄名为诸所有色。言一切者。谓此诸色摄色无余。四大种者。问何故大种唯有四耶。胁尊者曰。此责非理。若减若增俱有疑故。不违法相说四无失。有作是说。为遮外道大种有五。故唯说四。彼执虚空亦是大种。问何故虚空不名大种。答虚空无有大种相故。谓大虚空是大非种。以常住法无造作故。大德妙音亦作是说。虚空大种其相各异。虚空虽大而体非种。又诸大种若能成身。多是有情业异熟摄。虚空无彼业异熟相。是故虚空定非大种。问所说大种其义云何。答亦种亦大故名大种。如世间说大地大王。问此中所说种是何义。答能多积集能大障碍。能办大事故名为种。问此四大种作何事业。答此四能造诸所造色。谓依此四诸积集色。大障碍色皆得生长。如是名为大种事业。问造是何义为因为缘。若是因义此四大种。于所造色五因皆无。如何可言造是因义。若是缘义诸所造色。除自余法皆增上缘。是则不应唯四能造。有作是说。造是因义。虽四大种于所造色无相应等五种因义。而更别有生等五因。即是生依立持养五。复有说者。造是缘义。虽所造色除其自性。余一切法皆增上缘。而四大种是所造色。近增上缘非所余法。如说眼色。为眼识缘。彼说胜缘此亦应尔。问颇有是色非四大种。亦非大种所造色耶。答有。谓一或二或三大种。此一二三不名四故。又诸大种非所造故。问何故大种非所造耶。答因色果色相各异故。或诸大种若所造摄。为四造一三造一耶。若诸大种四能造一。地等亦应还造地等。是则诸法应待自性。然一切法不待自性。但藉他缘而有作用。若诸大种三能造一。因数既阙应不能造。如所造色因必具四

问已总了知大种所造。复欲闻此二种别相。何谓大种。其相云何。答地等界名大种。坚等性是其相。问若坚性等是地等相。所相能相岂不成一。答许此成一亦有何过。故毗婆沙作如是说。自性我物相本性等。名言虽殊而义无别。不可说诸法离自性有相。如说涅槃寂静为相。非离寂静别有涅槃。此亦应然。故无有过。此中坚性即坚分坚体约种类说。坚性是地界。然此坚性差别无边。谓内法中爪发等异。外法中有铜锡等殊。又内法中手足等坚异。外法亦尔。故坚性无边。问若尔坚性应共相摄。云何说为地等自相。答坚性虽多而总表如。地多变碍总表色蕴。所表既一故非共相。有说坚性通二相摄。观三大种则成自相。若观坚类有内外等无边差别。复成共相。如变碍性通二相摄。观余四蕴则成自相。若观色性有十一种品类差别。复成共相。又如苦谛其相逼迫观三谛时此成自相。若观有漏五蕴差别。即此逼迫复成共相。坚性亦然故通二种。问若如是者。云何建立自共相别不相杂乱。答以观待故无杂乱失。谓若观彼立为自相。未尝观彼立为共相。若复观此立为共相。未尝观此立为自相故自共相观待而立。问已知大种相各有异。大种作业差别云何。答地界能持住行二类令不坠落。水界能摄性乖违事令不离散。火界能熟不熟物类令不朽败。风界能令诸物增长或复流引。是谓大种各别事业。问地水火风各有二性。谓坚等性及色性摄。云何一法得有二相。答一法多相斯有何失。如契经说。一一取蕴有如病等无量种相。或坚等性是地界等自相所摄。其中色性是地界等共相所摄。故于一法有二种相。一自二共。亦不违理。问如是四界可相离不。答此四展转定不相离。云何知然。契经说故。入胎经说。羯赖蓝时若有地界无水界者。其性干燥则应分散。既不分散故知定有水界能摄。若有水界无地界者。其性融释则应流泒。既不流泒。故知定有地界能持。若有水界无火界者。其性润湿则应朽败。既不朽败故知定有火界能熟。若有火界无风界者。其性则应无增长义。既渐增长故知定有风界动摇。问若尔经说当云何通。如契经说。苾刍当知。于此身中火界若发。或即令舍命。或生近死苦。答经依增盛不增盛说。不言火体身中本无。问地界与地有何差别。答地界坚性地谓显形。地界能造地谓所造。地界触处身识所识。地谓色处眼识所识。是谓地界与地差别。水火亦然风或风界

问已具了知坚湿暖动四大种相展转乖违。如四毒蛇居一身箧。复欲闻彼所造色相。且何名为彼所造色。答彼所造色。谓眼根等。眼即根故说名眼根。如青莲华余根亦尔。问眼等五种亦界处摄。何故此中独标根称。答为欲简别色等外境。谓若说为眼等界处。则根根义差别难知。是故此中独标根称。此则显示所造色中内者名根外名根义。问此中所说根义云何。答增上最胜现见光明。喜观妙等皆是根义。问若增上义是根义者。诸有为法展转增上。无为亦是有为增上。则一切法皆应是根。答依胜立根故无斯过。谓增上缘有胜有劣。当知胜者建立为根。问何根于谁有几增上。答五根各于四事增上。一庄严身。二导养身。三生识等。四不共事。先辩眼根。庄严身者。谓身虽具众分余根若阙眼根便丑陋故。导养身者。谓眼能见安危诸色避危就安。身久住故。生识等者。谓依眼根一切眼识及相应法皆得生故。不共事者。谓见色用唯属眼根。二十一根无斯用故。次辩耳根。庄严身者。谓耳聋者不可爱故。导养身者。谓耳能闻好恶声别避恶就好。身久住故。生识等者。谓依耳根一切耳识及相应法皆得生故。不共事者。谓闻声用唯属耳根。二十一根无斯用故。鼻舌身根。庄严身者。如眼耳说。导养身者。谓此三根受用段食。身久住故。生识等者。谓依三根。鼻舌身识及相应法皆得生故。不共事者。谓嗅尝觉香味触用属鼻舌身。非余根故。问如是五根有何胜德。谁为自性。业用云何。答眼根德者。谓与眼识及相应法为所依故。眼根自性即是净色。能见诸色是眼业用。余根三事类眼应知。此中且说有业用根。非一切根识所依故。此色澄净故名净色。或复此中与眼识等为所依者。显同分根。说净色言显彼同分。问何谓同分彼同分。根如是二名所目何别。答有业用者名同分根。无业用根名彼同分。如能见色名同分眼。不见色者名彼同分。彼同分眼差别有四。一有过去彼同分眼。谓不能见诸色已灭。二有现在彼同分眼。谓不能见诸色今灭。三有未来彼同分眼。谓不能见诸色当灭。四有未来定不生眼。其同分眼差别唯三。谓除未来定不生眼。耳根等四如眼应知。或复五识各二所依。一俱时生。谓眼等五。二无间灭。谓即意根。唯说识依滥无间意。但言净色五体应同。故净色言简无间意。与眼等识。为所依言。显眼等根差别有五。由斯故说五识所依与等无间缘差别各四句。俱生眼等根为第一句。无间灭心所为第二句。无间灭心为第三句。除前余法为第四句。问谁能见色。为眼根见。为眼识。见为与眼识相应慧见。为心心所和合见耶。汝何所疑一切有过。若眼根见余识行时宁不见色。何不俱取一切境耶。若眼识见。诸识但以了别为相。非见为相岂能见色。若与眼识相应慧见。应许耳识相应慧闻。彼既非闻此云何见。若心心所和合能见。诸心心所和合不定。谓善眼识与二十二心所相应。不善眼识与二十一心所相应。有覆无记眼识与十八种心所相应。无覆无记眼识与十二种心所相应。既不决定云何和合。答眼根能见。然与眼识合位非余。譬如眼识了别色用依眼方有。又如受等领纳等用必依于心。此亦应尔。由斯理趣余识行时。眼既识空不能见色。亦无俱取一切境失。以一相续中无二心转故。问何故具六所依所缘。而一相续中无六识俱转。答等无间缘唯有一故。复有余义。若眼识见谁复能识。若慧见者谁复能知。若心心所和合能见。诸法一一业用不同。于中定无和合见义。又应一体有二作用谓许能见及领纳等。复有余义。若识见者识无对故。则应能见被障诸色。慧及和合应知亦然。是故眼根独名能见。问已知见用唯属眼根。眼见色时为二为一。答此不决定。若开两眼观诸色时则二俱见。以开一眼按一眼时。便于现前见二月等。闭一按一此事则无。是故有时二眼俱见。又发智论说俱见因。谓双开时见分明等。两耳两鼻应知亦然。问何缘二眼二耳二鼻。虽各两处而立一根。答二处眼等体类一故。二所取境一界摄故。二能依识一识摄故。又二俱时能取境故。虽有两处而立一根。女根男根即身根摄。是故于此不别立根。眼根极微布眼精上。对境而住如香菱花。耳根极微在耳穴内。旋环而住如卷桦皮。鼻根极微居鼻頞内。背上面下如双爪甲。舌根极微布在舌上形如半月。然于舌中如毛发量无舌根微。身根极微遍诸身分

五事毗婆沙论卷上五事毗婆沙论卷下

        尊者法救造

        三藏法师玄奘奉　诏译

    分别色品第一之余

问所造色内根所摄者我已了知。今复欲闻非根摄者愿说其相。答色声香味所触无表。此中色谓好显色等。若青黄等色不变坏名好显色。此若变坏名恶显色。若平等者名二中间。似显处色。问色处有二。一显二形。何故此中唯辩显色。答今于此中应作是说。色有二种。一显二形。显色谓青黄等。形色谓长短等。而不说者有何意耶。谓显色粗及易知故。如是诸色于六识中二识所识。谓眼及意先用眼识唯了自相。后用意识了自共相。谓彼诸色住现在时。眼识唯能了彼自相。眼识无间起分别意识。重了前色自相或共相。然此所起分别意识。依前眼识缘前色境。如是意识正现在时。所依所缘并在过去。由斯五境住现在时。意识不能了彼自相。是故色境二识所识。谓诸眼识现在前时。唯了现在自相非共。若诸意识现在前时。通了三世自相共相。以诸意识境界遍故。有分别故。眼识无间非定起意识。于六识身容随起一种。若眼识无间定起意识者。则苦根不应为苦等无间。苦根唯在五识身故。若尔便违根蕴所说。如说苦根与苦根为因等无间增上。然依眼识了别色已。无间引起分别意识。故作是言。眼识先识眼识受已。意识随识声有二种。乃至广说。有执受大种者。谓诸大种现在刹那有情数摄。无执受大种者。谓诸大种过去未来有情数摄。及三世非有情数摄。此中有执受大种所生声。名有执受大种为因。有执受大种与此所生声。为前生等五种因故。无执受大种为因声亦尔。若从口出手等合生。名有执受大种因声。若从林水风等所生。名无执受大种因声。余如前释。诸所有香。乃至广说。诸悦意者说名好香。不悦意者说名恶香。顺舍受处名平等香。鼻所嗅者谓鼻根境。余如前释。诸所有味。乃至广说。诸悦意者名可意味。不悦意者名不可意味。与二相违名顺舍处味。舌所尝者谓舌根境。余如前释。问若尝味时为先起舌识先起身识耶。答若冷暖等增则先起身识。若碱醋等增则先起舌识。若触味平等亦先起舌识。味欲胜故。所触一分。乃至广说。滑性者谓柔软。涩性者谓粗强。轻性者谓不可称。重性者谓可称。冷者谓彼所逼便起暖欲。饥者谓食欲。渴者谓饮欲。如是七种是触处摄。以所造色而为自性。前四大种虽触处摄。非所造色而为自性。是故触处有十一种。今七所造故名一分。身所触者谓身根境。余如前释。问何大种增故有滑性。广说乃至。何大种增故有渴耶。有作是说。无偏增者。然四大种性类差别。有能造滑性。广说乃至有能造渴。复有说者。水火界增故能造滑。地风界增故能造涩。火风界增故能造轻。地水界增故能造重。水风界增故能造冷。唯风界增故能造饥。唯火界增故能造渴。此言增者。谓业用增非事体增。如心心所。无表云何。乃至广说。堕法处色者。堕有六种。一界堕。二趣堕。三补特伽罗堕。四处堕。五有漏堕。六自体堕。界堕者。如结蕴说。诸结堕欲界。彼结在欲界等。趣堕者。谓若摄属如是趣者名堕是趣。补特伽罗堕者。如毗柰耶说。有二补特伽罗。堕僧数中令僧和合。处堕者如此中说。无表色云何。谓堕法处色。有漏堕者如此论说。云何堕法。谓有漏法。自体堕者。如大种蕴说。有执受是何义。答此增语所显堕自体法。无表色者。谓善恶戒相续不断。此一切时一识所识。谓意识者。以无对故。色等五境于现在时五识所识。于三世时意识所识。此于恒时意识所识。眼等五根亦一切时意识所识。此无表色总有二种。谓善不善。无无记者。以强力心能发无表。无记心劣不发无表。诸善无表总有二种。一者律仪所摄。二者律仪所不摄。不善无表亦有二种。一者不律仪所摄。二者不律仪所不摄。律仪所摄无表复有四种。一者别解脱律仪。二者静虑律仪。三者无漏律仪。四者断律仪。别解脱律仪。谓七众戒。静虑律仪。谓色界戒。无漏律仪。谓学无学戒。断律仪者。依二律仪一分建立。谓静虑律仪无漏律仪。离欲界染九无间道随转摄者。名断律仪。以能对治一切恶戒。及能对治起恶戒烦恼。故名为断。前八无间道随转摄者。唯能对治起恶戒烦恼。第九无间道随转摄者。能对治恶戒。及能对治起恶戒烦恼。问别解脱律仪何缘故得何缘故舍。答由他教得四缘故舍。何等为四。一舍所学戒。二二形生。三善根断。四失众同分。问静虑律仪何缘故得何缘故舍。答色界善心若得便得。若舍便舍。此复二种。一由退故。二由界地有转易故。问无漏律仪何缘故得何缘故舍。答与道俱得无全舍者。若随分舍则由三缘。一由退故。二由得果故。三由转根故。问断律仪何缘故得。何缘故舍。答静虑律仪所摄者。如静虑律仪说。无漏律仪所摄者。如无漏律仪说。律仪所摄善无表者。若强净心所发善表得此无表。若劣净心所发善表不得此无表。舍此无表由三种缘。一意乐息。二舍加行。三限势过。不律仪所摄不善无表者。谓屠羊等诸不律仪。此不律仪由二缘得。一由作业。二由受事。此不律仪由四缘舍。一由受别解脱戒。二由得静虑律仪。三由二形生。四由失众同分。然一切色略有四种。一者异熟。二者长养。三者等流。四者刹那。此中眼处唯有二种。一者异熟。二者长养。无别等流。以离前二更不别有。等流性故。耳鼻舌身处应知亦尔。色处唯有三种。一者异熟。二者长养。三者等流。香味触处应知亦尔。声处唯有二种。于前三除异熟。堕法处色唯有二种。初无漏心俱者刹那所摄。余等流摄

    分别心品第二

问已知色相诳惑愚夫不可撮摩。犹如聚沫。欲闻心法。其相云何。答谓心意识不应说心。是所问故。问心意识三有何差别。答此无差别如世间事。一说为多多说一故。一说多者。如说。士夫为人儒童等。多说一者。如说。鸟豆等同名再生。应知此中同依一事说。心意识亦复如是。复有说者。亦有差别。过去名意。未来名心。现在名识。复次界施设心。处施设意。蕴施设识。复次依远行业说名为心。依前行业说名为意。依续生业说名为识。复次由采集义说名为心。由依趣义说名为意。由了别义说名为识。此复云何。谓六识身者。问此何唯六非减非增。答所依等故。谓识所依唯有六种。若减识至五则一所依无识。若增识至七则一识无所依等。六所缘应知亦尔。然说识异唯约所依等识。为身者一识有多故。非一眼识名眼识身。要多眼识名眼识身。如非一象可名象身。要有多象乃名象身。此亦如是。眼识云何。谓依眼根者显眼识所依。各了别色者显眼识所缘。复次谓依眼根者说眼识因。色者说眼识缘。如世尊说。苾刍当知。因眼缘色眼识得生。问眼与眼识为何等因。答此为依因。譬如大种与所造色为依因义。各了别者说眼识相。识以了别为其相故。此中意说。依眼缘色有了别相。名为眼识。广说乃至依意缘法有了别相。名为意识。问何不但说谓依眼根等。或不但说各了别色等。答若随说一义不成故。谓若但说依眼根等。则彼相应受等诸法。亦依眼根等。应名眼等识。若复但说各了别色等。既有意识亦了别色等。则应意识名眼等识。然此中说依眼根等。遮能了别色等意识。复说各能了别色等。遮眼等识相应受等。问眼色明作意为缘生眼识。何故但说眼识非余。答眼根胜故。如舞染书。眼不共故。如某种芽眼所依故。如鼓声等眼邻近故。如说觉支。眼耳身识各有四种。谓善不善有覆无记无覆无记。不善者唯欲界。有覆无记唯在梵世。善无覆无记通欲界梵世。非在上地。有寻伺故。鼻舌二识各有三种。除有覆无记。唯在欲界。缘段食故。意识有四种。通三界不系。问若初静虑以上诸地无三识身。生彼如何有见闻触。答以修力故。初静虑地三识现前。令彼三根有见闻触。依如是义故有问言。颇有余地身余地眼余地色余地眼识生耶。答有。谓生第二静虑地者。用第四静虑地眼。见第三静虑地色。彼第二静虑地身。第四静虑地眼。第三静虑地色。初静虑地眼识生此中。五识身各有二种。一者异熟。二者等流。意识身有三种。一者异熟。二者等流。三者刹那。此中刹那。谓苦法智忍相应意识。问颇有一因道现在前。一刹那顷所舍之心。或有是同类因。自性非有同类因。或有。有同类因非同类因自性。或有是同类因自性亦有同类因。或有非同类因自性亦非有同类因。答道类智忍时应作四句。第一句者。谓已生苦法智忍相应心。第二句者。谓未来见道相应心。第三句者。谓除已生苦法智忍相应心。诸余已生见道相应心。第四句者。谓除前说。问颇有一因道现在前。一刹那顷所舍之心。或有是有漏有漏缘。或有是有漏无漏缘。或有是无漏无漏缘。或有是无漏有漏缘耶。答有。道类智忍时应作四句。第一句者。谓色无色界系见道所断有漏缘随眠相应心。第二句者。谓色无色界系见道所断无漏缘随眠相应心。第三句者。谓灭道忍智相应心。第四句者。谓苦集忍智相应心。问颇有无事烦恼对治道现在前。一刹那顷所舍之心。或有无漏缘非无漏缘缘。或有无漏缘缘非无漏缘。或有无漏缘亦无漏缘缘。或有非无漏缘亦非无漏缘缘。如是四句准义应思。问颇有刹那心现在前所灭之心。或有非定非定缘。或有非定是定缘。或有是定是定缘。或有是定非定缘。如是四句准义应思。问颇有刹那心现在前所灭之心。或有已生非已生心为因。或有已生心为因非已生。或有已生亦已生心为因。或有非已生亦非已生心为因。如是四句准义应思

    分别心所法品第三

问已知非一所依所缘行相流转犹如幻事。极难调伏如恶象马。由有贪等差别之心。今复欲闻心所法相。何谓心所法如何知别有。答所有受等名心所法。经为量故知别有体。如世尊说。眼色二缘生于眼识。三和合故。触与触俱起有受想思。乃至广说。萨他筏底契经中言。复有思惟。诸心所法依心而起系属于心。又舍利子问俱胝罗。何故想思说名意行。俱胝罗言。此二心所法依心起属心。乃至广说。由如是等无量契经。知心所法定别有体。又心所法若无别体。则奢摩他毗钵舍那。善根识住诸食念住诸蕴六六觉支道支诸结学法。及有支等契经应减。又不应立大地法等。然经所说法门无减。大地法等实可建立。故知别有诸心所法。问宁知心所与心相应。答经为量故。如世尊说。见为根信证智相应。故知心所有相应义。问言相应者是何义耶。答阿毗达磨诸大论师咸作是说。言相应者是平等义。问有心起位心所法多。有心生时心所法少。云何平等是相应义。答依体平等作如是说。若一心中二受一想。可非平等。是相应义。然一心中一受一想。思等亦尔。故说平等是相应义。复次等不乖违。是相应义。等不离散。是相应义。平等运转。是相应义。如车众分故名相应。复次同一时分同一所依同一行相同一所缘同一果同一等流同一异熟。是相应义。此复云何。谓受想思乃至广说。问何故先说受非先说想等。答行相粗故。受虽无碍不住方所。而行相粗如色施设。故世间说。我今手痛足痛头痛。乃至广说。想思触等无如是事。受云何。谓领纳性。有领纳用名领纳性。即是领受所缘境义。此有三种。谓乐受苦受不苦不乐受者。若能长养诸根大种。平等受性名为乐受。若能损减诸根大种。不平等受性名为苦受。与二相违非平等非不平等受性名不苦不乐受。复次若于此受令贪随眠二缘随增。谓所缘故。或相应故。是名乐受。若于此受令嗔随眠二缘随增。谓所缘故。或相应故。是名苦受。若于此受令痴随眠二缘随增。谓所缘故。或相应故。名不苦不乐受。虽痴随眠于一切受二缘随增。而不共痴自依而起。自力而转。多与不苦不乐受俱。余明了故不作是说。由可意不可意顺舍境有差别故。建立如是三领纳性。是故但说有三种受。而实受性有无量种。有余欲令无实乐受及不苦不乐受。问彼何缘说无实乐受。答经为量故为契经说。诸所有受无非是苦。又契经说。汝应以苦观于乐受。若乐受性是实有者。如何世尊教诸弟子观乐为苦。又契经言。于苦谓乐名颠倒故。若有乐受应无于苦。谓乐想倒心倒见倒。又契经说。诸有漏受苦谛摄故。此中摄者。是自性摄。非实乐受。是苦自性。云何可言是苦谛摄。既说苦谛摄故无实乐受。又相异故。谓逼迫相说名为苦。非实乐受有逼迫相。如何可言诸有漏受皆苦谛摄。又现观故。谓观一切有漏皆苦。说名现观。若乐受性是实有者。观乐为苦成颠倒见。应非现观。是故定知无实乐受。阿毗达磨诸论师言。实有乐受经为量故。谓契经说。佛告大名。若色一向是苦非乐。非乐所随有情不应贪着诸色。乃至广说。又契经言。并乐并喜于四圣谛我说现观。又契经说。有三种受。谓乐受苦受不苦不乐受。又契经言。诸乐受生时乐住时。乐由无常有过患。诸苦受生时苦住时。苦由无常有过患。若乐受性非实有者。应非如苦作一类说。应于乐受作别类说。应于苦受作别类说。又若乐受非实有性。应无轻安。以无因故。如契经说。由有喜故身心轻安。若无轻安亦应无乐。展转乃至应无涅槃无渐次因果非有故。彼师于此作救义言。如上地中虽无有喜。而非无有身心轻安。故引证言。非为决定。彼救非理。所以者何。以上地中都无喜故。应观此义。如健达缚三事和合。食名色经。如契经言。父母交会有健达缚正现在前。而见有时无父母会。有健达缚亦现在前。如受湿生及化生者。非受胎卵二生有情离父母合有入胎义。又如经言。三事和合谓寿暖识。然无色界虽无有暖而有寿识。非欲色界寿识离暖。又如经说。身依食住。非上二界住由三食。欲界亦然。非欲界中住由四食。上界亦尔。又如经言。名色缘识识缘名色。非无色界虽无有色而名与识展转相缘。令欲色中亦有此义。此中亦尔。若有喜处。由有喜故得有轻安。若处喜无轻安亦有。由余缘故不应为责。何谓余缘。谓先欲界有胜喜受。引未至定轻安令起。初二静虑有胜喜受。引上地中轻安令起。若全无喜则无轻安。由此证知定有乐受。又如初果在上二界。虽不能得而彼能得阿罗汉果。先力引故。此亦应然不应为责。又如以杖先击于轮。后舍杖时其轮犹转。此亦应尔。由先喜力引后轻安。是故轻安定由有喜。喜即喜受乐受所摄。是故定知实有乐受。又由乐受有希望故。如契经说。若有乐者于法希望。乐受若无则应于法无希望者。是故定知实有乐受。又可爱业应无果故。若无乐受诸可爱业应空无果。诸可爱业定以乐受为其果故。亦不应言诸可爱业以诸乐具为异熟果。乐具但是增上果故。谓诸乐具是增上果非异熟果。所以者何。所有乐具可有与他共受用故。自命终已不失坏故。谓诸乐具与他有情可共受用。诸异熟果定无与他共受用义。堕自相续不共他故。又诸乐具自命终已。如象马等犹不失坏。诸异熟果与身命俱。身命若无彼定失坏。故可爱业若无乐受应空无果。其理决定。又摄益故。若无乐受诸根大种应无摄益。若谓摄益。由诸有情分别境界非由乐受。理亦不然。应知摄益如由苦受有损害故。又正加行必有果故。若无乐受则正加行应空无果。正加行者。应以苦受为异熟果。无乐受故。如邪如行必以苦受为异熟果故。正加行应以乐受为异熟果。更相违故。如明与闇影与光等。又由乐受起恶行故。若无乐受恶行应无。由诸有情贪着乐受。起诸恶行感苦受果。恶行若无应无苦受。苦受既有恶行非无。既有恶行定有乐受。又法受故。如契经说。有四法受。或有法受现乐后苦。或有法受现苦后乐。或有法受现乐后乐。或有法受现苦后苦。若无乐受法受应一。不应有四。由如是等种种因缘定有乐受。问若有乐受。世尊所说违乐受经有何理趣。答有别理趣。且初经说。诸所有受无非苦者。当知彼经依三苦说。何谓三苦。一者苦苦。二者坏苦。三者行苦。若诸苦受由苦苦故。说名为苦。若诸乐受由坏苦故。说名为苦。若诸不苦不乐受由行苦故。说名为苦。如契经说。无常故苦。应知彼经有此理趣

五事毗婆沙论卷下


杂阿毗昙心论

    No. 1552 [cf. Nos. 1550, 1551]

杂阿毗昙心论卷第一

        尊者法救造

        宋天竺三藏僧伽跋摩等译

    序品第一

  古昔诸大师　　于诸甚深法
  多闻见圣迹　　已说一切义
  精勤方便求　　未曾得异分
  阿毗昙心论　　多闻者已说
  或有极总略　　或复广无量
  如是种种说　　不顺修多罗
  光显善随顺　　唯此论为最
  无依虚空论　　智者尚不了
  极略难解知　　极广令智退
  我今处中说　　广说义庄严

(广说梵音云毗婆沙以毗婆沙中义庄严处中之说诸师释法胜阿毗昙心义广略不同法胜所释最为略也优婆扇多有八千偈释又有一师万二千偈释此二论名为广也和修槃头以六千偈释法宏远玄旷无所执着于三藏者为无依虚空论也)

  敬礼尊法胜　　所说我顶受
  我达摩多罗　　说彼未曾说
  弟子咸劝请　　毗昙毗婆沙
  专精思惟义　　贤众所应学
  正要易解了　　离恼济群生

复次为显现清净烦恼对治。依阿毗昙毗婆沙所应故。大德法胜及我达摩多罗。共庄严杂阿毗昙心。离诸广略说真实义。问且置真实义。云何名阿毗昙。云何名毗婆沙。答于牟尼所说等谛第一义谛甚深义味。宣畅显说真实性义。名阿毗昙。又能显现修多罗义。如灯照明。是惠根性若取自相则觉法。是阿毗昙若取众具是五阴性。名者诸论中胜。趣向解脱是名阿毗昙

复次毗婆沙者。于牟尼所说性真实义。问答分别究畅真要。随顺契经开悦众心。所谓性相名字地依行缘念智根定世善。及界学。见谛断义。缘方便得亦离欲得。何处初起摄相应因缘果有果等。无量诸法种种义。生说种种类种种说。是名毗婆沙论。如佛世尊略说二智法智比智。毗婆沙说无量分别。所谓彼法智者。是无漏惠性。是智相。名者初知法故。是名法智。在六地依欲界十六行境界四谛四念处智即智相三根三三昧相应(三根者喜乐舍也三三昧谓有觉有观无觉有观无觉无观)。堕三世缘三世及离世。是善缘三种(谓善不善无记)。是不系缘欲界及不系。是学无学缘三种(谓学无学非学非无学也)。是不断缘三种(谓见谛断修道断不断也)。名缘及义缘方便得离欲得欲界起法界法。入行阴所摄。意界法界意识界相应。三因自性三因所生四缘。自性四缘所生。是初生无漏依果及功用果。俱生者唯功用果。有果者三果。谓前二及解脱果。不说增上果。如是一切法应当知。问已知久远缘起根本阿毗昙毗婆沙说彼对治。何故说真实义。答为知真实义故。若不分别诸论难可了知。以不知故实智不生。实智不生故不知真实。不知真实故不见烦恼诸行过恶。以不见过故堕于恶趣。与彼相违则生天解脱。问已说所以说。当说真实义。答是论于诸论中最为殊胜。具足显示一切境界。于阿毗昙论增广智惠。五浊世增。时命智慧念皆悉损减。观察是等于广大论闻持恐怖。为利自他略说真实三时善说。哀愍外道邪论诸师。远慕前胜正论法主及诸圣众。普于是中生大敬信。开发众生佛法僧念故。显示三宝真实功德。方造论端故说是偈

    杂阿毗昙心论界品第一

  顶礼前最胜　　离恼安教尊
  所说悉具足　　罗汉见真谛

顶礼者。起善心转爱果举体敬礼也。前者先也。何者为先谓最胜也。示供养处故。最胜有何义。伏诸烦恼故名最胜。如偈所说。忧波伽当知。如我等诸佛悉已离诸漏。是故名最胜。离恼者。烦恼诸缠烧其身心。世尊旷劫悉安众生。炽然永尽故名离恼。安乐说故当知离恼。是故次说安教。安者谓安隐也。教谓言说。教有所安故曰安教。略说自安安他。离恼者自安也。安教者安他也。不颠倒故故知安教。是故次说所说悉具足。说者言说也。即是安教。具足者。辩正深妙显现决断。说不颠倒到真实义。不违二谛故曰具足。是故礼彼名供养法。阿罗汉者。到究竟处法相满足。是故次说阿罗汉。真实福田应彼供养故名阿罗汉。此一向说无学。说无学已次说学见真实。真实者。四圣谛不颠倒。谓已学八忍八智见彼真谛故名见真实。虽住见道未周四谛必当见故亦名见真实。问何故敬礼。答

  牟尼尊悉知　　法聚二种相
  亦为他显现　　我今说少分

牟尼者。身口意满故曰牟尼。悉者。凡一切智所说修多罗毗尼阿毗昙流布至今。知者。知见觉义也。法者持也。持自性故名法。法有积聚故名法聚。彼善法善法聚。不善无记法亦如是。二者数名。相者相貌也。问云何二相。答自相及共相。自相者不共。即此非余。如碍相是色。如是比。共相者共。此及余。如色无常。如是比。问若碍相是色自相者亦是共相。观四阴故是自相。观十种色故是共相。如是自相即共相观故。二种自相共相则为不成。答一自故。碍者是色相故。名色自相众色差别故说十种。汝言观故自相共相不成者不然。何以故。不坏故。如父子。如果种。如苦集谛。如听制。若观自相则非共相。若观共相则非自相。如一人亦名父亦名子。以父故名子。以子故名父。若观父则不观子。若观子则不观父。若言不成者不然。何以故。已成故。是为父子义成。若善若恶正见邪见于中广说起无间业。若无父义亦无无父邪见及有父正见。此若无者净秽亦无。净秽无者解脱亦无。若无无间业者亦无因果。因果无者一切法亦无。莫言非过。是故父子义成不可已成更成。若已成更成此则无穷。是故自相共相义成。问佛所知法一切当说耶。答不也。问何所说。答亦为他显现。我今说少分。显现者开示义也。他者受化人也。若义饶益随顺梵行。如申恕林契经说。于彼为他说法中我今说少分。如来所知深广无量。如舍利弗等尚不能尽说。况复余人。问世尊说何法。答有漏无漏如是一切

  一切有漏行　　离我乐常净
  不见有漏故　　计我等妄受

此诸有漏行。不自在故离我。三苦成故离乐。缘力故离常。烦恼处故离净。问何等是有漏行。答诸烦恼所生五阴。问若有漏行离我乐常净者。云何众生而于中受。答不见有漏故计我等妄受众生于有漏行不知相已便受我乐常净。作业所覆故不知非我。威仪所覆故不知是苦。相似相续覆故不知非常。薄皮覆故不知不净。如是不知故受我乐常净。问何相为有漏行。答

  若增诸烦恼　　是圣说有漏
  以彼漏名故　　惠者说烦恼

若依若缘增长身见等诸烦恼。如使品说。彼诸行从漏生故。生漏故。漏处故。是说有漏法。无漏缘不增长。软中上者不然。增依故非不增。增依不增缘。问何故。答

  以彼漏名故　　惠者说烦恼

烦恼者说名漏。一切入处常漏故。心漏连注故。是故增烦恼诸行当知是有漏。问彼更有名耶。答

  亦名为烦恼　　受阴及与诤
  烦受诤起故　　是诸贤圣说

即此有漏行。名为烦恼受阴诤。何以故。烦受诤起故是诸圣贤说。身见等诸烦恼恼众生故名烦恼。受自身故名受。扰乱心故名诤。诤有三种。烦恼诤。阴诤。斗诤。烦恼诤者。百八烦恼。阴诤者死。斗诤者。各各相违。当知此中说烦恼诤。身见等诸烦恼生诸有漏行。从烦恼生故说烦恼。从受生故说受阴。从诤生故说诤。已说受阴相。阴相今当说

  若行离烦恼　　亦解脱诸漏
  此及前受阴　　是阴圣所说

若行离身见等诸烦恼及诸漏故。当知是无漏行。此诸无漏行及前说受阴。是名为阴相。阴受阴差别者。转不转合是阴。转者是受阴。问何者是。答

  所谓色受阴　　想行及与识
  是五阴次第　　粗细随顺说

是五阴谓色阴受想行识阴。云何色阴。一切诸色过去未来现在。如是广说。彼起已灭是说过去。未起未灭是说未来。已起未灭是说现在。在自身名为内。在他身及非众生数名为外。复次内外义如入处说。粗者名有对。细者名无对。若言不成是则不然。观故观故不成者不然。若观粗则非细。染污名恶色。不染污名好色。过去未来名为远。现在名为近。远义四种。如行品说。彼一切一向略说。色阴此名略非事略。如色阴。受想行识亦如是。于中差别者。自身受名为内。他身受名为外。内缘外缘方便力起境界力起。粗者五识身。细者意地。染污不染污界地亦如是。乃至识阴亦如是。行是行阴。外者众生非众生数当知。问色乃至识有何相。答碍相是色相。随觉是受相。顺知是想相。造作是行相。分别是识相。彼过去色虽不碍曾碍故。当来色虽未碍当碍故。极微一一虽不碍众微集则碍。无作虽不碍以作色是碍故彼亦碍。如树动影亦动。如色阴过去未来。余四阴亦如是。问何故前说色阴乃至识阴。答是五阴次第粗细随顺说。彼五阴中色阴最粗。五识依故。六识境界故。是故前说。受阴虽非色行粗故如色说如我首足等痛受随转如是乃至识阴最细是故后说。复次从不可知本际已来。男为女色女为男色。染着处故。是故前说。乐受贪故起色欲。想颠倒故起乐受贪。烦恼故起想颠倒。依意故起烦恼。复次二种色观故入佛法中为甘露门。谓不净观及安般念。彼不净观者观造色。安般念者观四大。是故前观色阴。观色已见受过。见受过已想不颠倒。想不颠倒已烦恼不行。烦恼不行已心则堪忍。此则顺说五阴。今当逆说。净秽之生以心为本。故前观识阴。观识已烦恼薄。烦恼薄已起法想。起法想已则贪受不生。贪受不生故观察色。是故先说色阴乃至识阴。问云何分别说色阴。答

  十种谓色入　　及无作假色
  是分别色阴　　牟尼之所说

十种谓色入者。眼色耳声鼻香舌味身触。无作假色者。如业品说。是诸色一一说色阴

  所名为识阴　　此即是意入
  于十八界中　　亦复说七种

谓识阴即是意入。十八界中说七心界

  余则有三阴　　无作三无为
  是则说法入　　亦复说法界

余三阴者。受阴想阴行阴。无作三无为者。虚空数灭非数灭。此七法说法入亦说法界。问以何等故受想别立阴。余心法立一行阴。答

  轮转于生死　　当知二诤根
  是故别受想　　建立二种阴

二事故众生轮转生死。谓乐受贪及颠倒想。乐受贪故行爱。倒想计着故行见。二诤根者。习欲爱贪欲缚从受生。见欲缚从想生。受修诸禅想修无色。复次心法或根或非根。根法是受非根法是想。是故随义说。问五阴一切是行。何故说一行阴。答

  五阴虽是行　　而一受行名
  有为法多故　　说行阴非余

以行阴中有相应不相应等有为行多。相应者思愿等。不相应者谓得等。问一切悉是行阴。何故契经说一思为行阴非余。答胜故增上故前故。作相是行相。彼思是作性。若有余阴悉入五阴中。今当如实说

  广说诸法阴　　其数有八万
  戒等及余阴　　悉是五阴摄

八万法阴皆色阴摄。以佛说语性故。有说。名性者行阴摄。余戒等五阴。彼戒阴色阴摄。定惠解脱解脱知见阴皆行阴摄。若有余阴名悉入五阴中。问齐何当言法阴。答

  法阴谓经论　　如是一一说
  及诸对治行　　悉名法阴数

有说。一一经论名为法阴。如是经论数有六千。复有说。一一阴处是法阴处。又说。阴处界处等为法阴数。如是说者谓众生有八万行。是故世尊随彼所行为说对治。悉是法阴数。问前说十种谓色入。亦无作假色是名色阴。何等为入。答

  所谓眼耳鼻　　舌身及与意
  色声香味触　　余则说法入

彼眼入者。眼识所依。四大所造净色。不可见有对。耳鼻舌身亦如是。差别者。随识所依。意入者。是心意识。名义业世施设。彼名等所作差别应当知。名者。名为心。名为意。名为识。义者。集起是心义。思量是意义。别知是识义。业者。远知是心前知是意。续生是识。世者。过去世是意。当来世是心。现在世是识。施设者。界施设心。入施设意。阴施设识。复次贪恚痴等分别则无量境界。定心名不乱。此相违染污心名为乱。懈怠相应心名为下。精进相应心名为举。少习净心及染污心名为少。多习净心名为多。少根易得少对治少随转。诸染污心名为小。此相违善心名为大。于彼得修习修不修习。如是染污心名不修。此相违善心名为修。自性解脱及在解脱。于彼染污心名不解脱。此相违善心名解脱。或有心自性解脱非在解脱。或有心在解脱非自性解脱。或有心自性解脱。亦在解脱或有心非自性解脱亦非在解脱。自性解脱非在解脱者。是学无漏心。在解脱非自性解脱者。是无学有漏心。自性解脱亦在解脱者。是无学无漏心。非自性解脱亦非在解脱者。是学有漏心及凡夫心。色入者三种。谓色处俱。色者青黄赤白。如是广说。处者身作色。俱者如造画等。声入者三种。谓因受四大声。因不受四大声。因俱声。因受四大者。谓咽喉唇舌因缘发声。因不受四大者。谓风铃树等因缘发声。因俱声者。谓击鼓吹贝因缘发声。彼声一一有二种。谓可意不可意。香入者三种。谓好香恶香非好恶香。味入者六种。谓辛酸甜苦咸淡。问若尝味时。别味者为舌识。先觉为身识耶。答若先觉冷暖则先身识后舌识。若先别辛等味者则先舌识后身识。触入者十一种。谓四大及七种造色。七种造色。谓涩滑轻重冷暖饥渴。涩者粗强。滑者细软。轻者不可称重者淳厚。冷者求暖。饥者欲食。渴者欲饮。问何大增故涩滑乃至饥渴。答或有说无偏增者。彼业报先得涩。四大果乃至饥渴。复有说。水火增故滑。地风增故涩。地水增故重。风火增故轻。水风增故冷。风增故饥。火增故渴。问几触能起身识。答有说。从涩至渴一一能起。又说。五触能起四大与涩。如是乃至饥渴。复有说者。十一种起身识等。是身识境界故无过。有二种自相。事自相及入处自相。事自相者等境界。入处自相者自相境界故。此十一种。二种欲界系。饥及渴非色界系。九种欲界色界系。色界衣虽不可称。余亦可称亦可积聚。虽无冷暖之患。而有长养调适。饥渴者。或说依果以饮。食能断故。阿毗昙者说。报色不可断已更续。罽宾者说。饥渴是善不善报障故不可知。食消已还复可知。是故富者饥渴是善报。贫者饥渴是不善报。法入者。四种无作色。如业品说。心法如行品说。心不相应行如杂品说。无为此品后当说。内入中眼入境界粗故前说。外入中色入自性粗故前说。苦乐所入门故说入处。又杀义是入处义。心心法于此中灭。问入处触入处何差别。答触入处即是入处。或入处非触入处。外入是也。若内入处非分者。是入处。非触入处(缘差不起触者名非分也)。触所住故名触入处。触空者唯是入处。触所入门故如窗牖(天竺为窗牖为风入)

触所住故如圣住。亦应说受入处触长养心心法触所持来触所转故触力故现在前。是故说触入(圣住者中国名圣住边地地名弥离车住也)。问云何一身具十二入。答

  虽于一身中　　所作事各异
  依缘自性故　　十二种分别

于一身中具十二入。但事各异。若事是眼入。此事乃至非法入。若事是法入。此事乃至非眼入。问何等为眼入事乃至法入事。答眼以见色为事。色以眼所行为事。如是乃至法入。譬如一室十二人止事业各异。彼亦如是。又依缘差别说十二。谓六识身有六依六缘。又自性分别说十二。若眼自性乃至非法自性。若法自性乃至非眼自性。问十入处及法入少分。是色何故独说一入处为色入。答

  虽有众多色　　但说一色入
  当知一色入　　三眼境界故

于彼入中。三眼境界者名为色入。肉眼天眼圣惠眼。以色粗故说二十种。所谓青黄赤白长短正不正方圆高下烟云尘雾光影明闇。彼长等八事三种分别。余悉无记。问一切十二入尽是法性。何故但说一法入。答

  彼一切诸法　　虽尽是法入
  法中众多故　　一法入非余

彼一切虽尽是法入。但一入中众多法故。谓色法无色法。相应不相应法。有为无为法。是故但说一法入。复次三有为相。彼法相不相违。彼入法入中。是故但说一法入。又一切诸法以名显现。彼名入法入中。法者真实相。谓空解脱门。以前法觉法故。是空入法入中。身见能自觉者不然。颠倒转故。法者第一义。谓寂灭涅槃。是法入法入中。问世尊说契经无量入。何故但说十二入。答

  彼十一切入　　八入二四入
  及五解脱入　　皆悉十二摄

十一切入中。前八入及八胜处。是无贪善根性。悉入法入中。若取眷属则五阴性悉入意入法入中。十一切入中。后二入及四无色入。是四阴性悉入意入法入中。二入者。谓无相众生入及非想众生入。无想众生入十入性。除香味入。说四无色则已说非想入。五解脱入是慧性。眷属是五阴性。悉入三入中。声入意入法入(五解脱入者一者佛说即得解脱二者闻已思惟得三者因自诵经得四者因为他说法得五者因缘得也)。问所说十八界为种有十八名有十八。答

  界种说十七　　或说为十二
  境界依者依　　分别十八种

十八界。或十七种。或十二种。若取意界则失六识。若取六识则失意界。譬如别取树则失林。若取林则失树。指卷等譬亦如是。若取意界则失六识。若取六识则失意界。问若然者云何说十八界。答

  境界依者依　　分别十八种

三事故说十八界。依故。依者故。境界故。依谓六依。眼界乃至意界。依者谓六识界。眼识界乃至意识界。境界谓六外界。若言阿罗汉最后心不生后识非意界者。此则不然。以余缘故后识不续如地无种。复次因触故立十八界。眼触三因缘生。谓眼色识。如是乃至意。器故。食故。食者故。器谓眼界。食谓色界。食者谓眼识界。问应说二十一界。二眼二耳二鼻为六。舌界身界七心界六外界。答

  二眼说一界　　以二一自故
  耳鼻亦如是　　二共说一界
  为令身端严　　彼皆不一一

虽有二眼而说一界。以一自故。共一四大造故。一自见故。非一自有二根。一识所依故。二眼眼识依亦不应二根。一识依一入处故。一入境界亦俱受一入境界故。二眼共取一色。以一眼见色则不明了。二眼见色则明了。二耳二鼻成一界亦如眼说。为庄严身故生二眼二耳二鼻。以一眼者人不爱敬故。是故眼等生二。身舌生一。如佛世尊虽说种种界。悉入十八界中。今当次第说

  若有诸余界　　世尊契经说
  各随其自性　　悉入十八界

若世尊说余界悉入十八界中。以三事故。依故。依者故。缘故。如世尊说。憍尸迦。世有种种界。谓诸见以界名说。彼悉入法界中。若彼说六十二界。如多界经说及余契经。以界名说者。各随其义入十八界中。问界入阴何差别。答

  界说一切法　　彼即十二入
  除三无为法　　余则说五阴

一切法说十八界。以不离依故。依者故缘故。彼一切法即说十二入。七心界为意入。此即义差别。除三无为余法说五阴。积聚势故。问若一切法说界。界即是入。除三无为说阴。何故世尊三种说。答

  牟尼观众生　　欲解根不同
  性行愚差别　　故说阴界入

众生三种欲解。广略中。广者为说界。中者为说入。略者为说阴。软中上根亦如是。恃性憍逸为说界。性义是界义。恃财憍逸为说入。输门义是入义。恃命憍逸为说阴。以阴死法故。始行者为说界。少行者为说入。已行者为说阴。愚于色心为说界。愚于色为说入。愚于心法为说阴。问阴入界有何义。答

  聚积是阴义　　输门义说入
  种性义说界　　是三种差别

十一种无量色等。总说色阴。如库藏如军众。譬如四种军其类各别名为军众。色亦如是。虽有十一同一色相名为色阴。如阿毗昙说。善观色阴者。一极微摄一界一入一阴少分。不善观者言。一极微摄一界一入一阴。如色阴。受想行识阴亦如是。输门义说入者。通苦乐故。种性义说界者。如一山中多有诸性。金性银性等。如是一身中种种性各异故说十八界。问以何等故说十八界十二入五阴不增不减。答

  境界依者依　　度量法所应
  是故界入阴　　不增亦不减

界度量所应者六依。六依者六缘。彼依若增则非依以无依者故。若减则依者无所依故。如是一切入亦以依缘为量。阴者何故染着色。乐受着故。何故乐受着。想颠倒故。何故想颠倒。烦恼相应故。烦恼依意意即依意。如所说意缘法生意识。离是依更无余依故。已说界入阴自性及因缘。今当广说界

  界中一可见　　又说一切界
  无记谓八种　　余则善不善

界中一可见者。十八界中色界可见可视。在此在彼是故可见。复次示人心行是故可见。复次自现故。谓眼所行。当知十七不可见无行相故。又说。一切界皆可见。慧眼境界故。如所说偈。彼一切诸法。慧者见无我。如阿毗昙说。学见迹见四真谛迹故。是故十八界一切皆可见。无记谓八种者。八界无记。谓五情香味触。无爱不爱果可记故说无记。余十界可记。善及不善故。谓色声法七心界。善身动是善色。不善身动是不善色。余色无记。如是声口动净心七识界是善。无惭无愧相应心是不善。余则无记法界。若心相应如心说。若不相应如杂品说。善有四种。自性相应共起第一义。自性善者。惭愧及三善根。相应者。即彼相应心心法。共起者。即彼所起身口业及心不相应行。第一义者。谓涅槃。是为四种善。自性不善者。无惭无愧三不善根。相应者。即彼相应心心法。共起者。即彼所起身口业及心不相应行。第一义者。轮转危崄。俱相违者是无记。问一切法十二入。即是世尊所记。何故说无记。答不以一向不说故名无记。善者记为善。不善者记为不善。不记善不善故说无记。若因果时则记因果异则无记。或有不说名无记。如记论契经说

  一切皆当死　　是论一向记
  一切死复生　　是名分别论
  若问生殊胜　　是名诘问论
  众生五阴异　　是名止记论

一向记论者。若有问一切众生悉当死耶。应一向答。一切众生皆悉当死。分别论者。若有问一切皆当死死复生耶。应分别答。有烦恼者死而复生。无烦恼者死已不生。诘问记论者。若有问人生殊胜不。应反问汝方何趣故问。若言方天趣应答言劣。若言方恶趣应答言胜。止记论者。若有问阴与众生为异为同耶。应当止。何以故。以不应故。譬如有问石女儿善恭敬不。石女无儿何得答言恭敬不恭敬。如是有阴而无众生。何得有同异耶。以不应故不答。阿毗昙者说。一向记论者。若有问如来无所著等正觉耶。善说教法耶。世尊弟子善向耶。色无常受想行识无常耶。善分别苦集灭道耶。应一向答。义饶益故。分别论者。若言为我说法。应问言。法有众多。若过去若未来若现在。欲说何法。若言为我说过去法。应问。过去法亦多。或色阴。或受想行识阴。为说何者。若言色阴。应问。色阴亦多。或善不善无记。为说何者。若言善色。应问。善色有七种。不杀生乃至不绮语。为说何者。若言不杀。应问。不杀有三种。不贪不恚不痴。为说何者。若言不贪。应问言。不贪有二种。作及无作。为说何者。如是等论名为分别记论。诘问论者。若有问法。应反诘。法有众多。汝问何者。不为分别若过去未来现在乃至作无作。若软心者为分别说。若谄曲者则还反问令彼自答。是名诘问论。止记论者。若有问言世有边耶世无边耶。如是等如虚空花鬘不可记言香与不香。是名止记论。已说记无记。十二有对今当说

  十二界有对　　一界说少分
  十界七有对　　一少分亦然
  说境界有对　　障碍及与缘

眼耳鼻舌身界及七心界。此十二界说有对。法界中少分亦说有对。谓心法。又十色界说有对。七心界及法界少分亦说有对。问此中说何等有对。答

  说境界有对　　障碍及与缘

三种有对。境界有对。障碍有对。缘有对。境界有对者。如施设经所说。眼与色对。乃至意与法对。已说意界当知。已说七心界法界少分是故当知。十二界一界少分是有对。五外界法界少分是无对。如彼经等说。若观陆则不观水。如是广说。障碍有对者。谓各各相对。各各处障碍。若彼有一则无第二住。极微聚故。障碍故。可分故。据处所故当知。八无对此中应广说。缘有对者。心心法于境界转。应如是言。若法境界有对。彼法障碍有对耶。应作四句。或境界有对非障碍有对者。七心界及心相应法界。或障碍有对非境界有对者。五外界。或境界亦障碍有对者。五内界。或非境界亦非障碍有对者。法入所摄色无为心不相应行。若法境界有对。彼缘有对耶。谓缘有对是境界有对。或境界有对非缘有对。谓五内界

  有漏有十五　　余二三三有
  欲有中有四　　十一在二有

十五界一向有漏。五内界五外界五识界。漏所生故。生漏故。漏处故。漏于中起故说有漏。如前有怖畏。与漏俱故说有漏。如杂毒食。余二者。意界法界意识界。此三界二种。或有漏或无漏。若漏所生是有漏。相违则无漏。三三有者。意界法界意识界。三有中可得。欲有色有无色有。无漏者是不系。虽三界身中得。非自性得故。欲界中有四者。香界味界及此境界识。非色无色界。离揣食欲故。三入是揣食性。彼亦应无触者。此则不然。触入性有二种。或是揣食性。或非非揣食者。在色界彼无揣食性以身微妙故。香味一向揣食性。是故彼无。境界无故。彼识亦无。问彼无香味亦无彼识者。鼻界舌界亦应无。答具诸根故。诸根展转相持故十一在二有者。欲有色有。五内界色声触界及此境界识。此十一非无色界。离色性故

  有觉有观五　　三行三余无
  有缘当知七　　法入说少分

有觉有观五者。五识界有觉有观粗故。乃至梵世非上地。三行三者。三界三种。意界意识界心相应法界。欲界及初禅有觉有观。禅中间无觉有观。上地及一切不相应法无觉无观。问有觉有观地法有四种。或有觉有观。无觉有观。无觉无观。非有觉有观非无觉有观非无觉无观。云何有觉有观。答曰。欲界及初禅。除觉观诸余心心法。云何无觉有观。答曰觉。云何无觉无观。答色心不相应行。云何非有觉有观非无觉有观非无觉无观。答曰。观余无者。谓余非有觉非有观。无缘故。有缘当知七法入说少分者。七心界说有缘。有此缘故故曰有缘。如人有子谓之有子。法界少分有缘者。心法少分无缘者。非心法。谓眼识及相应法。缘色乃至身识及相应法。触缘意识及相应法一切法缘(谓以一切法为境界耳非攀缘义上眼身识亦同此)

  九不受余二　　为无为共一
  一向是有为　　当知十七界

九不受者。九界不受受名。若色现在根数及不离根。若此断坏破裂逼迫。心心法受。于彼止住故。异则不受。谓九界不受。七心界声界法界无断坏故。余二者。五内界现在是受。起断等知故。过去未来是不受。心心法不住故色香味触若现在及不离根是受。如心心法根中止住彼中亦尔。不离根故。为无为共一者。一法界有为无为。于中三种。常故无为。余法无常故有为。是故为无为共一。一向是有为当知十七界者。十七界无常故。一向有为生灭故。三有为相所成故。有因故。堕阴故堕世故。软中上故。与上相违是无为

  有罪及有报　　染污及隐没
  修习则有十　　一界中有见
  亦说有心法　　一界是见性

七心界色声法界二种。或有罪或无罪。秽污是有罪。不秽污是无罪。如有罪如无罪。如是秽污隐没亦如是。五识界色界声界若善不善是有报。若无记是无报。意界意识界法界若不善善有漏是有报。若无记无漏是无报。问以何等故不善善有漏是有报无记无漏是无报。答譬如外种三事和合生有种坚实。溉之以水。覆以草土。自性众具力故牙叶得生。有种虽坚实。不以水溉。不草土覆。众缘不具故牙叶不生。有种不实。虽溉以水覆以草土。自性不实故牙叶不生。如外种三事差别。如是内缘起亦三事差别。如初种如是不善善有漏法坚固。溉以爱水。覆以余结。以自性众缘力故有牙得生。如第二种如是无漏法坚固。无爱水溉及余结覆。因缘不具故有牙不生。如第三种如是无记法。虽溉以爱水覆以余结。自性不实有牙不生。修习则有十者。七心界色声界善者修。不善无记者不修。法界善有为修。不善无记及数灭不修。问以何等故不善无记及数灭是不修。答为爱果故修。不善无记无爱果故不修。数灭性是果不相续生故不修。当知八界无罪无报无染污无隐没不修。一界中有见者。法界中有八种见。身见等五见。世俗等见。学见。无学见。见者观视故。决定故。坚受故。缘深入故。如阴夜见色秽污慧见法亦如是。如晴夜见色。世俗等见亦如是。如阴昼见色。学见亦如是。如晴昼见色。无学见亦如是。亦说有心法者。即此法界有心法。谓受相等。有此心法故说有心法。当知十七界及一界少分非心法。一界是见性者。一界是见性。谓眼界能视故。当知十六界及一界少分非见。问云何见。为眼见。为眼识见。为眼识相应慧见。为和合见。彼何所疑一切有过。若言眼见者。余识俱时何故不见。何故不俱得一切境界。若言眼识见者。识相非见相。无眼者亦应见。若言眼识相应慧见者。复以耳识相应慧闻耶。若言和合见者。此则不定。或时眼识二十二法。或二十一。或十二。答

  自分眼见色　　非彼眼识见
  非慧非和合　　不见障色故

自分眼见色。是故余识俱时则不见。以余识俱空眼现在前非自分故。以是因故不俱得一切境界自分诸根不俱识住根故名自分。无有二识俱行。无第二次第缘故。问若眼离识不见色者。是则识见非眼见。眼复何用。答识成彼则成彼。非分则因非分故。如受不离想想不离受。彼亦如是。若眼识见者谁复识耶。若慧见者谁复知耶。若和合见者此等诸法事业各异其义。有间则无和合。若和合见者则应有二决定自法。是义不然。若复眼识见者应见障色。以无对故。慧及和合亦复如是。以眼识无对不识障色。谓不见者不然。应分别故。分别者应言何故眼识不识障色。应说眼一境界转故是故眼识。不识障色。眼有对有对故不见障色。是故眼识不识。识应有二自性。若识若见余亦如是。又复眼识见者何故不识。已知眼识不识障色。复应知眼一境界转故。当复说碍有对依故不识障色者不然。有无对依故眼识二种依眼及次第灭意。若有对依故不见障色者。无对依故应见障色。异说有过。眼是不共依意是共依不见障色者不然。依者于色等相非分。亦非眼是色故。眼识是色。亦非眼无缘故。无缘亦非眼不相应故。不相应如是等皆有过。复次意亦是不共依若依意眼识生。未曾依彼余识生。心一一相续转故。是故意亦是不共依。见识无间识即见者不然。四种不坏故。世尊说见闻觉识四种不坏。若识即见者。唯闻觉识三种见即识故不如是。是故当知眼见识用分别建立四种者不然。不见障色先已说过。识见有间名义各异。眼光照名为见。心随分别名为识。若复言眼见彼应称眼量者。彼自生过。识无限量故。识无限量世尊所说。如世尊说眼有见。而谓识见者不然。如言意识法。复有余法于中识耶。若言即意识法者。当知眼亦如是。如所说梵志眼是门为见色故。此见之异名。汝于所说妄解。心心法无方处而言出入者不然。即彼契经说。意是门为识法故。更无异法于中识法。是故眼中即见(从眼识非见至此凡七章初诘问辩非余六章辩析释识等非见物异人异叙其所执终则检实罚违以成己义)

  极微数有十　　九界四大造
  二界说少分　　内界说十二
  此即是根性　　一界中有根

极微数有十者。十色界是极微聚。有分故。覆障故。大碍故。据处所故。当知八界非极微聚。九界四大造者。除触界。余九色界四大造。四大所生故。四大因故。四大与此诸界五因生。生因依因建立因养因长因。二界说少分者。二界当分别触界法界。或四大造。或非四大造。触界中四大性非四大造。七种造色四大造。法界中身业口业四大造。余法界非四大造。七心界非四大造。十一种四大。眼入所依。乃至法入所依。非意入。造色亦十一种。眼入乃至法入。非意入。或有说。眼入所依四大生眼入。余亦如是。复有说者。眼入所依四大生三入。眼入身入触入。如是乃至舌入所依。是中差别者。说自根身入所依生二入。身入触入。色声香味入所依亦如是。触入所依唯生触入。彼又作是说。一切四大生色声。一切欲界色不离香味。法入所依亦如是。眼入所依生七入。眼入身入及五境界。如是乃至舌入所依身入所依生六入。除眼等四根。法入所依亦如是。色入所依生五入。乃至触入所依亦如是。复有说者。眼入所依生十一入。乃至法入所依亦如是。于此四大因缘分别异相四大起异相造色。应作四句。有同相四大起异相造色。有异相四大起同相造色。有异相四大起异相造色。有同相四大起同相造色。云何同相四大起异相造色。谓触相四大起十一种造色。云何异相四大起同相造色。谓坚湿暖动相四大起触相造色。云何异相四大起异相造色。谓坚湿暖动相四大起十一种造色。云何同相四大起同相造色。谓触相四大起触相造色。问四大造色何差别。答四大是因。造色是果。坚湿暖动相是四大。若色因四大而无四大相。彼是造色。复次不可见者四大。可见不可见者造色。如是等说。内界说十二者。内五色及七心界。此十二是内界。当知六界是外。问法故说内人故说内耶。若法故说内者。一切法无自。若人故说内者。法无有人。答法故说内。但非一切法。心心法所依故说内彼意界亦依亦依者彼五色界是依。非依者心法虽是依者而非依。余非依亦非依者。此即是根性者。即此十二说根。一界中有根者。法界中十一法是根。余者非根。当知五界及一界少分非根

  分余分十七　　一界说有分
  十七界堕世　　一少分三业

分余分十七者。除法界。余界说有分及余有分。彼眼界有分者。三种世分别故。过去已见色。现在今见色。未来当见色。余有分者四种。过去不见色已灭。现在不见色而灭。未来世二种。谓不生法及生法。生法者不见色当灭。余色界亦如是。七心界若未来不生法彼余有分。余者是有分。一界说有分者。法界一向是有分。非余有分。以一切法界意识境界故。若言余界亦应非余有分者。此则不然。彼不以意识故立有分余有分。谓眼见色是有分。不见色是余有分。谓色眼所见是有分。所不见是余有分。差别者。若眼是一有分。余一切亦有分。若一余有分。余一切亦余有分。色若见者是有分非余。耳鼻舌身声香味触亦如是。第一义如眼说。俗数如色说。问颇共有法或有分或余有分耶。答有。十色入或余有分。彼生等相是有分。法界摄故。若不生法意是余有分。彼相应共有法是有分。法界摄故。问有分余有分有何义。答有分时说有分。眼界有二种。有业及无业分。彼有业分为无业分。所分故说有分。彼无业分亦为有业分。所分亦说有分。二分俱得有分相。问何等分数名分。答无业分为有业分。所分故说余有分。何以故。得有业分力故。如人有子彼亦如是。十七界堕世者。十七界堕三世事故说三世。或过去或未来或现在。若起已灭是过去。若未起是未来。已起未灭是现在。复次若未作是说未来。若作是说现在。若作已灭是说过去。一界当分别者。法界若有为堕三世。若无为则不堕三世。业者。三界有业。谓色声法。色界身作是业谓色界非业。声界口作是业。余声非业。法界身口业及思是业。余法界非业业相。业品当广说

  非学非无学　　当知十五界
  彼悉修道断　　余界俱三种
  于彼三界中　　说持戒犯戒

非学非无学当知十五界者。十色界五识界。是非学非无学。有漏故。即此诸界。修道断智对治故。余界俱三种者。余三界。意界法界意识界。俱三种。或学或无学或非学非无学。或见断或修断或无断。学相应意是学。谓苦法忍。乃至金刚三昧相应意是学。无学相应意是无学。谓尽智无生智。及无学等见相应意是无学。非学非无学相应意是非学非无学。谓善染污无记。善有三种。方便得离欲得生得。染污有二种。不善及隐没无记。无记有四种。威仪工巧报生变化。如意界。意识界亦如是。法界或学或无学或非学非无学。谓学身口业受想行阴是学此即无学。法界所摄有漏身口业受想行阴及无为是非学非无学。学无学义。业品当广说。此三界忍对治是见断。智对治是修断。智无漏是无断。见断修断义。使品当广说。于彼三界中说持戒犯戒者。谓色界善身作是持戒。不善身作是犯戒。声界是口作。法界唯无作。持戒犯戒相。业品当广说

  十七说有上　　一界说二种
  果有果十七　　一三觉所说

十七说有上者。除法界。彼十七界有上。有为故。一界说二种者。法界或有上或无上。有为法界及虚空非数灭是有上数灭。善故常故说无上。果有果十七者。除法界。余十七界是果有果。以有为法性劣展转相因生故。一三觉所说者。法界有三种。或果非有果。或果有果。或非果非有果。果非有果者数灭。果有果者有为法界。非果非有果者。虚空非数灭

  三界三种缘　　一依亦复然
  五一或分别　　余缘唯说一

三界三种缘者。眼耳意识界三种缘。善不善无记。一依亦复然者。意识界所依亦三种。善不善无记。五一者。五识依一种。或分别者。谓俱起五根及次第灭意。若取俱起依则一无记。以五根唯无记故。若取次第灭意则三种。以意界善不善无记故。复次眼识依分次第缘分应作四句。或依分非次第缘分。或次第缘分非依分。或依分亦次第缘分。或非依分非次第缘分。依分非次第缘分者。眼识俱起眼根。次第缘分非依分者。彼次第灭心法。依分亦次第缘分者。次第灭意。非依分非次第缘分者。除上尔所事。乃至身识依亦如是。问意识依是次第缘耶。答曰如是。意识依是次第缘。颇次第缘非意识依耶。答意识依相应心法。问若眼识以意界为依者。何故名眼识不名意识耶。答眼是不共依故。如种牙如鼓声。眼是眼识不共依。意是共依。以六识身展转次第缘生故。余缘唯说一者。鼻识舌识身识唯缘无记。以香味触一向无记故。意界即六识身。离是无余故不说法界。若心相应如心说

  若眼随生见　　耳界随生闻
  三界随生觉　　意界随生识

若眼随生名为见。耳随生名为闻。三事随生名为觉。意随生名为识。彼三界以方便得离欲得。修得神通性四支五支定果。是故彼随生各别建立。余三随生无彼相分故共建立一。问觉有何义。答

  境界唯无记　　觉心于中转
  随生三种识　　是则名为觉

香味触一向无记。无记故说觉。是故随生三识名为觉

  二境不近受　　远近境界一
  余一向近受　　依及境界等

二境不近受者。眼识耳识不近受境界。如逼眼色不见故。耳亦如是逼则不闻。虽深在内而远闻外声。若言远亦不见闻者。此则不论意识者远近境界悉受。除自己及相应共有。余一切法悉受。余一向近受者。鼻舌身识近受境界依缘无间故。依及境界等者。谓鼻舌识身识。此三识依取等境界。鼻根香微均而生识。舌身根微亦如是(谓根尘合处乃生着)

  二界说不定　　一界境亦然
  五界依或俱　　一界依说远

二界说不定者。眼识耳识依缘俱不定。眼识界。或依大而缘小如见毛端。或依小而缘大如见山。或依缘等如见蒱桃果。耳识亦如是。一界境亦然者。意识境界不定境界或大或小。一切法境界故。依无形故。大小不可说故。离意界六识无别体故。不说心法如心说。五界依或俱者。五识身或与依俱。俱者。谓五根。远者次第灭意。一界依说远者。意识界依说远。谓彼次第灭意

  十一界有二　　六三一四种
  事及长养报　　刹那与依种

十一界有二者。五内界声界五识界二种。六三者。色香味触意界意识界。此六界三种。一四种者。法界四种。问云何种说二三四。答事及长养报刹那与依种。彼眼界二种报及长养。彼报生者。善不善业报果。三恶道是不善业果。人天是善业果。眼及众具。梵行正受所长养故。是长养无别依性故不说。依刹那事亦尔。如眼。耳鼻舌身界亦如是。声界亦二种。长养及依。问何故声非报。答现在方便生故。声者。现在方便生。报者。前业所起。声者。随欲生。报非随欲生。复次声声有间报报无间。若声是报者。应如色一切时不断。而声有断。是故非报。五识界报及依。色香味触界三种报依长养。意界三种报依刹那。刹那者。苦法忍俱生意界。意识界亦如是。法界四种。报刹那依事。彼报者。善不善业报果。刹那者。苦法忍眷属。依者。除苦法忍眷属。余善有为法界。除报余不隐没无记有为法界染污法界。无为法界唯有事

  生身眼色界　　自地及他地
  若彼眼识生　　自他地亦然

生欲界。欲界身。欲界眼。欲界色。欲界眼识生。如是生初禅地。初禅地身。初禅地眼。初禅地色。初禅地眼识生。是名自地。他地者。生欲界。初禅地眼见欲界色。彼欲界身初禅地眼欲界色初禅地眼识生。见初禅者。彼欲界身初禅地眼色初禅地眼识生。生欲界。二禅地眼见欲界色。彼欲界身二禅地眼欲界色初禅地眼识生。见初禅地者。彼欲界身二禅地眼初禅地色初禅地眼识生。见二禅者。彼欲界身二禅地眼色初禅地眼识生。生欲界。三禅地眼见欲界色。彼欲界身三禅地眼见欲界色初禅地眼识生。见初禅者。彼欲界身三禅地眼初禅地色初禅地眼识生。见二禅者。彼欲界身三禅地眼二禅地色初禅地眼识生。见三禅者。彼欲界身三禅地眼色初禅地眼识生。生欲界。四禅地眼见欲界色。彼欲界身四禅地眼见欲界色。初禅地眼识生。见初禅者。彼欲界身四禅地眼初禅地色初禅地眼识生。见二禅者。彼欲界身四禅地眼二禅地色初禅地眼识生。见三禅者。彼欲界身四禅地眼三禅地色初禅地眼识生。见四禅者。彼欲界身四禅地眼色初禅地眼识生。如说生欲界。乃至生第四禅亦如是。有差别者。谓下地眼不见上地色。生上地下地眼不现在前

  耳界如前说　　鼻舌界自地
  身触即地说　　意识则众多

耳界如前说者。如前说眼识。耳识亦如是。鼻界说自地者。生欲界。欲界身欲界鼻欲界香欲界鼻识生。舌界亦如是。身触即地说者。身识有差别故。生欲界。欲界身欲界触欲界身识生。初禅亦如是。生二禅。二禅身触初禅地身识生。以觉自地触故。非他地生。第三第四禅亦如是。意识则众多者。或自地意自地法自地意识生。或他地。彼自地者。生欲界。欲界意欲界法欲界意识生。乃至生有想无想处亦如是。他地者。生欲界正受时。欲界善心次第初禅正受。起彼欲界意初禅地意识生法。或三界系或不系。初禅次第欲界善心现在前。彼初禅意欲界意识生法。或三界系或不系。初禅次第二禅正受。彼初禅意二禅意识生法。或三界系或不系。如是第二禅初禅。初禅第二禅。初禅第三禅。第三禅初禅。乃至有想无想处。逆顺次第超越应广说。有差别者。此正受为意界。彼正受为意识。若禅为意识者法。或三界系。或不系。若无色为意识者。彼法自地上地及不系。又复正受净初禅次第欲界初禅果变化心现在前。彼初禅意欲界意识生。法者欲界化。即彼欲界初禅果次第净初禅现在前。彼欲界意初禅意识生法。或三界系(或不系乃至)。第四禅亦如是。生者。彼欲界没生初禅地。彼欲界意初禅地意识生法。或色无色界系或不系。初禅地没生欲界彼初禅地意欲界意识生法。或三界系或不系。乃至有想无想处亦如是。彼没者是意受。生者是意识。但彼法自地上地及不系

  若彼得眼界　　或彼所依识
  二俱得不得　　亦色及与舍

若彼得眼界者。或眼界不成就。得成就。非眼识界。谓无色界没生第二第三第四禅。生欲界渐得眼根。或彼所依识者。或眼识界不成就得成就非眼界。谓上三禅地没生欲界及初禅。若即住彼眼识现在前。二俱得者。或眼及眼识界俱得。谓无色界没生欲界及初禅。俱不可得者。非眼界不成就得成就。亦非眼识界不成就得成就。谓生欲界不失眼根及梵天上若命终生梵天及欲界。第二第三第四禅没生第二第三第四禅。无色界没生无色界。亦色者。若色界不成就得成就。彼即眼界不成就得成就。或眼界非色界者。生欲界渐得眼界。若色界不成就得成就。彼眼识界耶。应作四句。色界不成就得成就非眼识界者。无色界没生上三禅中。眼识界不成就得成就非色者。即彼三禅没生欲界及初禅若即住彼眼识现在前色界不成就得成就。亦眼识界者。无色界没生欲界及初禅。非色界亦非眼识界者。除上尔所事。及与舍者。如说得舍亦如是广说

  色界二识识　　乃至触亦然
  诸余十三界　　一向意识缘

色界二识识者。谓色界二识识。眼识及意识。眼识界自相意识界自相及共相。乃至触亦然者。声界二识识。耳识及意识。耳识界自相意识界自相及共相。乃至触界二识识。身识及意识。身识自相意识自相及共相。以五识身自相境界故。不思惟故。现在境界故。一念故。诸余十三界一向意识缘者。五色根七心界及法界。此十三界一向意识。识自相及共相。此意识二种坏缘及不坏缘。不坏缘者。即此十三界缘。坏缘者。十三与五境界一一合缘。乃至十八界总缘

  思惟识三种　　是意欲有中
  色无色分别　　一种谓余界

思惟识三种是意欲有中者。欲界意识有三种思惟。自性思惟。随忆思惟。分别思惟。彼自性思惟者。谓觉也。随忆思惟者。意地念也。分别思惟者。意地不定慧也。此三思惟。欲界意识思惟也。色无色分别者。色无色界意识或三种。谓初禅地不定。入定者二。不定者三。三禅意识不定者二。除自性思惟。若定者一。随忆思惟。有说。无色界无不定者。彼惟一种。随忆思惟。若说有不定者。定者一。不定者二。一种谓余界者。五识身说余唯有自性思惟不利故。问如是分别法相已。云何摄法为自性为他性。答自性。何以故

  诸法离他性　　各自住己性
  故说一切法　　自性之所摄

诸法离他性者。眼界离十七界异性故。余界亦如是。不应说若离性是摄以异相故。故说自性之所摄非他性。各自住己性者。一切性各住自相。此性非他相故。应说若住者是摄非余故。说一切法自性之所摄义。谓自性自性不空。非余自色色不空。又复说相持义是摄。如契经说。如楼观中心众材所依为楼观之最。如所说。如綖持衣。如户枢持扇。如斧持薪。或说方便摄。如所说。此五根慧为首。谓摄故。或说和合摄。谓四摄事能摄众生。或说随顺摄。如所说。等见等至等方便是慧身。或摄取故名摄。谓和上以财法摄。此等世俗言说非究竟摄。自性自性摄者。是究竟第一义。三段摄。此中说者是自性摄。如是自性摄不舍第一义故。已说自性摄。眼界摄一界一入一阴。不摄十七界十一入五阴。复次右眼摄右眼。左眼摄左眼。眼二种。长养及报。长养摄长养。报摄报。报复二种。善业报不善业报。善业摄善业报。不善业报摄不善业报。不善业报三种。谓三恶趣。畜生摄畜生。饿鬼地狱亦如是。善业报二种。谓人天。人摄人天摄天。过去摄过去。未来现在乃至刹那摄刹那

  界中说一界　　阴入亦复然
  如是阴入界　　则摄一切法

一界者法界。一入者意入。一阴者色阴也(界品竟)

杂阿毗昙心论卷第一杂阿毗昙心论卷第二

        尊者法救造

        宋天竺三藏僧伽跋摩等译

    行品第二

已说诸法自相住。法生今当说。若以诸法摄自性。谓以自力生者不然。何以故

  至竟无能生　　用离等侣故
  一切众缘力　　诸法乃得生

至竟无能生用离等侣故者。诸行自性羸劣不能自生。问若不自生当云何生。答

  一切众缘力　　诸法乃得生

如人船相假得度彼岸。彼心心法展转力生。摄受境界亦如是。先当说心心法由伴生

  若彼心起时　　是心必有俱
  诸心法等聚　　及不相应行

诸行展转相因生彼心。若依若缘若刹那生。彼心法等聚生。问云何心法等聚。答

  想欲及触慧　　念思与解脱
  忆定及与受　　此说心等聚

想者。于境界取像貌。欲者。于缘欲受。触者。于依缘心和合生触境界。慧者。于缘决定审谛。念者。于缘记不忘。思者。功德恶俱相违造作转心。解脱者。于缘作想受彼限量是事必尔。忆者。于缘发悟。定者。受缘不乱。受者。可乐不可乐俱相违于境界受

  一切心生时　　是生圣所说
  同共一缘行　　亦复常相应

此十法一切善不善无记心。俱生大地可得故说大地。同共一缘行者。一切心同一缘转。不相离无二决定。亦复常相应者。展转共俱及与心俱常相应办一事故。问相应有何义。答等义是相应义。问心法或多或少。云何等义是相应义。答事等故。若一心中一想二受者。非相应义。以一心一想生。余心法亦尔。以是故等义是相应义。复次时依行缘等义是相应义。时等者。一刹那时生故。依等者。若心依眼生心法亦尔。行等者。若心行青生心法亦尔。缘等者。若心缘色生彼亦缘色。是故说常相应。已说心法通一切。不通今当说

  诸根有惭愧　　信猗不放逸
  不害精进舍　　一切善心俱

诸根者。谓二善根。不贪不恚。于生及资生具坏贪著名不贪。于众生数及非众生数坏嗔恚名不嗔恚。于诸过恶自厌名为惭。于诸过恶羞他名为愧。于三宝四谛净心名为信。身心离恶名为猗息。作善方便离恶不作名不放逸。不逼迫他名不害。断起未起恶生起未起善欲方便勤修不息名精进。心平等名为舍。此善十法通一切善心中。若有漏无漏五识相应意识相应故说善大地。已说善大地。烦恼大地今当说

  邪解不正忆　　不顺智失念
  不信懈怠乱　　无明掉放逸

颠倒解名邪解脱。邪受境界名不正忆。颠倒决定名不顺智。邪记妄受名失念。于三宝四谛不净心名不信。不断起未起恶不生起未起善不勤方便名懈怠。境界所牵散随诸缘名为乱。前际等不知名无明。心躁动不息名为掉。离作善方便名放逸

  烦恼大地十　　一切秽污心
  无惭及无愧　　说不善大地

烦恼大地十一切秽污心者。此邪解脱等十法。一切染污心俱。谓欲界色界无色界。五识身意识地。是故说烦恼大地。问睡亦一切秽污心俱。何故不立烦恼大地。答顺正受故。谓众生睡速发定。是故不立。若大地彼烦恼大地。应作四句。或有大地非烦恼大地。谓受想思触欲。或烦恼大地非大地。谓不信懈怠无明掉放逸。或大地亦烦恼大地。谓忆解脱念定慧。或非大地非烦恼大地。除上尔所事。已说烦恼大地。不善大地今当说

  无惭及无愧　　说不善大地

谓于诸过恶不自厌名无惭。于诸过恶不羞他名无愧。此二法一向不善。一切不善心相应。是故立不善大地中。已说不善大地。小烦恼大地今当说

  忿恨诳悭嫉　　恼谄覆高害
  如此诸烦恼　　说为小大地

于饶益不饶益应作不作非作反作。嗔相续生名为忿。于可欲不可欲应作不作非作反作。忿相续生名为恨。为欺彼故现承事相名为诳。于财法惜著名为悭。于他利养恭敬名誉功德不忍心忌名为嫉。不欲事会所欲事乖思惟心热名为恼。覆藏自性曲顺时宜名为谄。为名利故自隐过恶名为覆。方他性族财富色力梵行持戒智慧正业心自举恃名为高。欲逼迫他名为害。此十法说小烦恼大地。不通有故。修道断非见道断。在意地非五识。非一心俱生行各异故。有一则无二。问大地善大地烦恼大地不善大地小烦恼大地何差别。答大地四种。善不善隐没无记不隐没无记。善大地唯善。烦恼大地二种。不善及隐没无记。不善大地唯不善。小烦恼大地中。诳谄高二种不善及隐没无记。余一向不善

  不善心品中　　心法二十一
  欲三见一减　　二见除三种

不善心品中心法二十一者。不善。谓欲界烦恼相应除身见边见。转成不爱果故名不善。不善有八种。贪恚慢疑邪见见取戒取不共及彼相应无明。彼贪恚慢疑心二十一法共生十大地及懈怠等十法。谓懈怠无明不信放逸掉睡觉观无惭无愧。欲三见一减者。欲界邪见见取戒取。彼相应心二十法共生除慧。二见除三种者。欲界身见边见。彼相应心十八法共生。除慧及无惭无愧。余如前说。除无惭无愧一向不善故。无两慧使见即慧故

  欲善二十二　　不共有二十
  无记说十二　　悔眠俱即增

欲善者。谓欲界净心转成爱果有三种。生得及闻思。彼心二十二法共生十大地十善大地觉观。不共有二十者。不共名彼心独一。无明烦恼有二十心法共生。除一烦恼。无记说十二者。欲界不隐没无记心四种。报生威仪工巧变化心。彼四种无记心。十二心法。共生十大地觉观。悔眠俱即增者。心追变名为悔。是善不善无记。彼心品中憎悔。余如前说。当知悔三种。善不善及不隐没无记。非余自力故。毗婆沙者说。不欲令悔有无记。以悔捷利故。眠名身心昏昧。略缘境界名为眠。彼一切五品心俱生。即彼心品增眠若悔眠俱生。于三品中增二。问此说欲界心。色界复云何。答

  初禅离不善　　余知如欲有
  禅中间除觉　　于上观亦然

初禅无不善。彼有四品心。善不共隐没无记不隐没无记。此诸心品。除无惭无愧。余如欲界说。彼善品二十二。爱慢疑俱生十九。五见及不共俱生有十八。不隐没无记十二。无惭无愧一向不善故。彼色界无色界无悔眠亦尔。禅中间除觉。余如初禅说。于上观亦然者。第二第三第四禅及无色界无观。已说心心法伴力生。色今当说

  极微在四根　　十种应当知
  身根九余八　　谓是有香地

极微在四根十种应当知者。四根十种极微共生四大色香味触。眼根身根耳鼻舌根亦尔。身根九者。谓余身根有九种。彼唯有身根种。余如前说。余八者。离根色香味触极微八种。问此诸极微何界说。答谓是有香地。欲界中极微与香合。香味不相离。有香则有味。色界极微非揣食性故离香味。色界四根极微八种。余身根极微七种。外极微六种。问若眼根极微十种者。云何不眼即是色即是余种。如是则法性杂乱与阿毗昙相违。阿毗昙说。眼根一界一入一阴摄。答二种极微。事极微。聚极微。事极微者。谓眼根极微。即眼根微余极微皆说自事。以事极微故。阿毗昙说。眼根一界一入一阴摄。聚极微者。众多事此中说聚极微。住自相故法相不杂乱。如心相应法其相各异。非为杂乱。彼亦如是。四种远义。此品后当说。问前说若心生必心法共生。及不相应行。于中已说心法。心不相应行云何。答

  一切有为法　　生住及异灭
  此亦有四相　　展转更相为

一切有为法生住及异灭者。一切有为法有四相。生住异灭。世中起故生。已起自事立故住。已住势衰故异。已异势坏故灭。此相说心不相应行。问若一切有为法有四相者。应相复有相。答此亦有四相。即此相俱生。生生住住异异灭灭。问若尔者便无穷。答展转更相为。相随相展转相生非无穷。前生生生生生生生前生。如是住住住各各相住。异异异各各相异。灭灭灭各各相灭。问相随相展转相为前相为几法。答

  当知前四相　　相各为八法
  随相亦应知　　相相唯相一

前四相一一为八法。前生。除自己生八法。三相四随相及彼法。住者除自己住八法。异者除自己异八法。灭者除自己灭八法。三相四随相。及彼法自性不自为故。自性不自灭如指端不自触。问随相为几法。答随相亦应如相相唯相一。此四随相各为一法。随生生前生。随住住前住。随异异前异。随灭灭前灭。已说诸行展转相生。谓一时生不乱今当说

  异性相说远　　处所时亦然
  戒种及大地　　诸识性分别

异性相说远处所时亦然者。远有四种。所谓异性远相远处所远时远问何等远法。答戒种及大地诸识性分别。彼异性远者。谓如一身中善戒恶戒无作相续生。虽于一身中一时起同无作性。而性各异故说远。相远者。谓四大种展转相养共一处住合为一体。其相各异故说远。处所远者。谓天竺振旦地虽一时生合成一体。然彼处异故说远。时远者。谓眼生眼识。彼后生前生时间远故说远。已说诸行一时生不乱。诸行从因生彼因今当说

  所作共自分　　一切相应报
  从是六种因　　转生有为法

谓所作因。共有因自分因。一切遍因。相应因。报因。此六因摄一切因。此六因生一切有为行。已说因名。一一相今当说

  相似不相似　　各除其自性
  一切是作因　　生时无障故

相似不相似各除其自性一切是作因者。若相似不相似法。除自性展转为因。说所作因。何以故。生时无障故。法生时除自性一切性各自住异分等生不障碍。如因地故作净不净业因空故得往来。如眼识生时十七界不障碍。故生如是一切界。问何以故自性于自性非所作因。答自性不自为故。不自依故。自性于自性不养不损不受不害不持不坏不增不减不成不败不障碍名所作因。自性于自性无不障碍故不立所作因。问若不障碍是所作因者。以何等故。不一切法一时生耶。一时灭耶。生时灭耶。灭时生耶。答不和合故。虽有所作因。要须和合生。亦非一切法一时和合生和合灭亦非一和合二果。问若如是者有一杀众生余众生不为障碍。何故杀者有罪。非余众生耶。答无恶心分。又不作业故。盗等亦如是。问若外物是一切众生增上所生者。何以故。不与取。不于一切众生边得盗罪。答无受分故。无人功果故。若一切众生于彼悉有受分及人功果者。取者于彼则得盗罪。亦非一物一切众生受及人功果三种增上。自增上法增上世增上。自增上者。彼起烦恼境界现在前。能自守护不为罪业。莫令我受苦。法增上者。如有多闻者。彼起烦恼境界现在前。为护法故而不为罪。世增上者。如有一名闻大德。彼起烦恼境界现在前。护世间故而不为罪。已说所作因。共有因今当说

  一起性有依　　亦复说无依
  当知共有因　　展转为因果

一起性有依亦复说无依。当知共有因者。一时生心心法随心转心不相应行道共定共戒及共生四大。此诸法说共有因。展转为因果者。若一时起展转为果。是共有因。十一入虽一时生。彼不展转为果。自分因者。异时共一果。共有因者。诸行展转力一时生。谓心于心法随心转心不相应行。随心转色此亦于心也。眼于生等生等于眼。及四大种展转共有因。有对造色非展转果故非共有因。问随转有何义。答若有心则有彼法。谓下则下中则中上则上。如是比。彼有十随转。所谓一起一住一灭一果一依一报。善则善不善则不善无记则无记堕一世生已说十种随转。于中有漏断结道八种随转。除不善无记。世俗方便道解脱道胜进道及余善有漏心七种随转。除不善无记及解脱果。无漏断结道七种随转。除不善无记及报。无漏方便道解脱道胜进道六种随转。除不善无记解脱果及报。不善心七种随转。除善无记及解脱果。无记心六种随转。除善不善解脱果及报。有共有亦共有因。有共有非共有因。彼眼于八法共有亦共有因。谓四相四随相。相于眼共有共有因。随相于眼共有非共有因。生于八法共有共有因。除生自性。眼及余相随相生。此五法于生共有共有因。余随相共有非共有因。如是余相随相亦如是。乃至触入亦如是。意入于五十八入相随相。八法于余共有非共有因。有五十四法于意入共有共有因。除四随相。又说。十四法于意入共有共有因。谓十大地心相四。余八十四法共有非共有因。大地亦如是说。五十四法于心共有共有因。除心随相。是说为善。若异此者。与众事分。阿毗昙相违故如彼说。除身见等法生住异灭诸余秽污苦谛。如是一切法尽当知。已说共有因。自分因今当说

  前生与后生　　亦说彼未生
  自地相似因　　或说于他地

前生与后生者。谓过去前生。于过去后生及现在自分因。问为已生已生因复未生因耶。答亦说彼未生未生者。谓未来如是前生后生因。当知过去现在于未来自分因。未来于未来无自分因。无前后故。问云何一切前生于后生未生自分因为不。答自地欲界欲界因非他地乃至非想非非想。非想非非想地因非他地。何以故。因果断地故。问云何一切自地一切自地因为不。答相似自分因。自地亦相似自分因。非不相似。如善善因秽污秽污因无记无记因。以相似相似法相续。谓习善生善。习不善生不善。习工巧生工巧。习威仪生威仪。是说内分外分随种生亦如是。问一向自地自分因。复为他地耶。答或说于他地。他地当分别。若无漏法一切九地展转因。离爱故不堕界故。下与胜因非胜下因。有漏者。爱缚故堕界故唯自地。已说种种自分因。谓善法非一切善法因今当说

  秽污有九种　　展转更相因
  谓受生所得　　方便生非下

秽污有九种者。此染污九种。下下乃至上上。展转更相因。以展转相续现在前故。及彼彼受生。一切顿得故。问秽污九种。展转相因。余者复云何。答谓受生所得。若受生得善彼亦九种展转相因。问方便生者复云何。答方便生非下。若方便生。谓闻思修生。彼于等及增因非下。谓下下因乃至上上因。上上唯上上因乃至非下下因。复次闻闻因思因修因。复次思思因及修因。非闻因以下故。修唯修因。非余以下故。复次修慧四种。暖顶忍世间第一法。彼暖法四种因顶三。忍二。世间第一法唯世间第一法因非余。此说善有漏法。不隐没无记四种。报生威仪工巧变化心。彼报生四种因。威仪三。工巧二。化心唯化因。是说有漏。无漏法者。苦法忍苦法忍因。乃至无生智因。无生智唯无生智因非余。已说自分因。谓此因受果与果今当说

  善等自分因　　受果而不与
  或与而不受　　或俱不俱说

有善自分因受果而不与。应作四句。受而不与者。谓善根断时最后舍得。或与而不受者。谓善根续生时最生初得。或俱者。不断善根余自性住。俱非者。除上尔所事。复次秽污受而不与者。谓当得阿罗汉果时秽污得。最后舍与而不受者。阿罗汉果退时最初得。得俱者。未离欲余自性住。俱非者。除上尔所事。已说无缘有缘法受而不与者。善心次第秽污及无记心现在前。与而不受者。秽污及无记心次第善心现在前。俱者。善心次第善心现在前。俱非者。除上尔所事。秽污及无记心亦如是说。已说自分因。一切遍因今当说

  苦集于自地　　疑见及无明
  说一切遍因　　诸烦恼前起

苦集于自地疑见及无明说一切遍因者。长养境界故。一向决定故。二种使故。一切烦恼苦集谛摄故。见苦集所断烦恼种见疑。即彼相应无明及不共无明。此诸使不勤方便亦炽然故。及遍烦恼故说一切遍因。断知分别故。界分别故。自地非他地。问为谁遍因。为何分是遍因。答诸烦恼前起过去现在未来一切遍因。现在未来一切遍因。又复诸烦恼心相续生。如我见审尔计着以见力故。起常审尔计着谤真谛相受第一及清净。于谛犹豫贪恚痴慢等诸过差别生。如是一切一切遍应当知。一切遍使品当说。已说一切遍因。相应因今当说

  谓同一行法　　一依亦一时
  及一境界转　　是说相应因

若行若依若时若境界心转。即彼行彼依彼时彼境界受等心法转。若彼心法转。即彼心转性羸劣故。展转力生如束芦。是故说心于心法相应因。心法于心法及心因。非心于心因。何以故。三事故。无一刹那二心俱生。前心不待后心。一切诸法自性不自顾。色心不相应行无相应因。无缘故。已说相应因。报因今当说

  不善善有漏　　三世之所摄
  以彼有报故　　说名为报因

若善有漏及不善堕三世行。于生死中生生相续果报生。谓善爱果不善不爱果。有业一入果报生。谓命根。若得意入则二入。谓意入法入。触入亦如是。若得身入则三入。谓身入触入法入。色香味入亦如是。若得眼入则四入。谓眼入身入触入法入。耳鼻舌入亦如是。有业或五六七八九十十一入报。以业种种故。当知果报亦种种。如外种种果亦种种。如稻甘蔗蒲桃等。非种种者如[麩-夫+黃]麦等。当知内缘起亦如是。有一世业三世报。无三世业一世报。果不减因故。如是一刹那业多刹那果。非多刹那业一刹那果。欲界一阴报因得一果。谓得也。二阴报因得一果。谓身业口业。四阴报因得一果。谓善不善心心法。色界一阴报因得一果。谓得及无想正受。二阴报因得一果。谓初禅作色。四阴报因得一果。谓无随转业善心心法。五阴报因得一果。谓有随转业善心心法。无色界一阴报因得一果。谓得及灭尽正受。四阴报因得一果。谓善心心法一业种一身种类非多。谓现报业等各别故。与阿那律陀契经相违者不然。彼说初故如是说。一施报故生大性家生识宿命。自见施果已更增净业。果报增广乃至漏尽。说彼根本如一粒种子。又复说彼一施时有众多行。于一缘中发愿。或愿天上或愿人中。已说因自性如此。因受果与果今当说

  五中世受果　　亦说二与果
  已尽与果一　　二因当分别

五中世受果者。现在名中世五因。住现在世受果。亦说二与果者。若相应因共有因。住现在世与果。于此时受果。即于此时与果。故说二与果。已尽与果一者。已尽名过去报因。于过去世住与果二因当分别者。谓自分因及遍因。或住现在世与果。或过去世所作因。不说以乱故。已说因受果与果。世建立今当说

  作因一切法　　二因说二世
  余三说三世　　增依报功果

作因一切法二因说二世余三说三世者。有为无为一切法说作因。自分因一切遍因说过去现在。余三因说三世。已分别三世诸因。若果因有果今当说。增依报功果。作因有增上果。自分因遍因有依果。报因有报果。相应因共有因有功用果。已分别诸因。诸法从因生今当说

  报生心心法　　及与诸烦恼
  悉从五因生　　是义应当知

报生心心法及与诸烦恼悉从五因生者。彼报生心心法及烦恼心心法从五因生。报生心心法五因。所作共有自分相应报因。所作因者。彼法生时相似不相似法住不障碍共有因者。展转力生展转为伴及心不相应行伴生。自分因者。彼前生自分法相应因者。彼俱一缘中转。报因者。彼善不善此则彼果除遍因。报无记故。烦恼心心法除报因。染污故。从遍因生。余四因如前说

  若彼不相应　　诸余相应法
  除其初无漏　　是从四因生

报色及心不相应行从四因生。除遍因。无记故。除相应因。无缘故。秽污色及心不相应行从四因生。除相应因。无缘故。除报因。染污故。诸余相应法除其初无漏者谓善有漏心心法。威仪工巧变化心心法。除苦法忍相应。诸余无漏心心法从四因生。除遍因报因

  谓余不相应　　自分当知三
  及诸余相应　　初生无漏法

谓报生秽污余若有自分因。除初无漏。从三因生。所作因其有因自分因。非相应因。无缘故。二因前已除。及诸余相应初生无漏法者。如苦法忍相应法亦三因生。所作因共有因相应因。无前生无漏故无自分因。亦无遍因报因

  于中不相应　　是从于二因
  若从一因生　　当知必无有

于中不相应是从二因生者。初无漏品中色心不相应行从二因生。所作因共有因。已说一切有为法。于彼广说中从一因生者必无有。何以故。自性羸劣故。乃至一极微生亦除自己。诸余一切法所作因。及共生生住异灭亦共有因。此总说义略说四种。法报生秽污。除报及初无漏。诸余不秽污。彼初无漏彼报生相应不相应乃至初无漏法。彼报生相应从五因生。除遍因。报生不相应。从四因生。除遍因相应因。如是秽污相应不相应差别者。唯除报因。从一切遍因生。除报及初无漏。诸余不染污相应四因生。除遍因报因。不相应三因生。除遍因相应因报因。初无漏相应三因生。相应因共有因所作因。不相应二因生。所作因共有因。已说诸因。如此因世尊教化力及觉真实相力故说。缘今当说

  次第亦缘缘　　增上及与因
  法从四缘生　　世尊之所说

一切法性缘力境界力摄受生。性羸劣故。一切缘皆四缘摄。彼与开道方便是次第缘。任杖方便是缘缘。不障碍分是增上缘。种子法方便是因缘

  除罗汉后心　　诸余心心法
  常有行已生　　是说次第缘

除阿罗汉最后心相应。诸余过去现在心心法一一相续生。彼诸心一一生相续无间故名次第缘。彼阿罗汉最后心相应非次第缘。无余心相续故。未来心心法未起故。无余心相续。亦无次第缘。亦非未来先后次第方便立。若未来先后次第方便立者。坏正方便修义。正方便修邪方便修应随分次第生。若言一心次第建立二心善及秽污。若正思惟时。善心生秽污心非数灭。若邪方便思惟时。秽污心生善心非数灭。如种子亦为牙亦为糜。若牙具和合牙则生糜则不生。若糜具和合糜则生牙则不生此则不然。何以故。前已说先后非分故。以阿罗汉最后心是意界故。应是次第缘者不然。缘分异故。若言阿罗汉最后心不为意识依亦名意界者。得依相故。如是阿罗汉最后心无间相续亦名次第缘。此亦不然。何以故。缘分异故。相故立界。如无分眼不见色。以眼识空故。亦名眼界。亦得依相故。阿罗汉最后心如前说。缘者业故建立阿罗汉最后心作次第缘业事。无间相续生非分心法亦如是说。常者非如自分因遍因。问以何等故。色心不相应行非次第缘。答以乱故。不乱者说。次第缘色心不相应行乱故非次第缘。以一时善不善无记漏无漏异界行现在前故。欲界三种思惟闻慧。思慧生慧非修慧。不定故。彼欲界闻慧思慧次第圣道现在前。圣道次第三种思惟现在前。色界三种思惟闻慧。修慧生慧非思慧。色界定故。彼闻慧修慧次第圣道现在前。圣道次第闻慧修慧现在前。无色界二种思惟修慧生慧。彼修慧次第圣道现在前。圣道次第修慧现在前。此义择品当广说

  或法心次第　　非彼心无间
  无间非次第　　俱不俱当知

或法心次第非彼心无间者。除初正受刹那。诸余正受刹那相续。及起定心无间非次第者。初正受刹那彼生住异无常及诸相续心。彼生住异无常俱者。初正受刹那。除起定心诸余相续心。不俱者。除初正受刹那。彼生住异无常诸余相续正受刹那等。彼生住异无常。若法心次第。彼正受无间应作四句。或法心次第非正受无间者。初正受刹那除起定心诸余相续心。正受无间非心次第者。除初正受刹那。彼生住异无常诸余相续正受等。彼生住异无常俱者。除初正受刹那诸余相续正受及起定心。不俱者。初正受刹那彼生住异无常除起定心。彼生住异无常诸余相续心。彼生住异无常灭尽正受。心所牵心所作故。心次第心相违故。非心次第缘。起定心前虽有定无间相续。以非心故还以心为次第缘。已说次第缘缘缘今当说

  境界于一切　　心及诸心法
  是故一切法　　说名为缘缘

一切法是心心法缘随其事。谓眼识及相应。以色为缘。乃至意识及相应。以一切法为缘。于一色眼识生一决定知言并见众色者。此则不然。以速故。非俱见言。俱者。增上慢如旋火轮。非轮轮想增上慢。若不了了见色差别者则可总受。如观丛林。声香味触亦应如是知。已说缘缘。增上缘今当说

  若彼所作因　　此即增上缘
  所谓因缘者　　当知余因说

前说所作因。当知即是增上缘。除自性。一切性不障碍故。法生时自作己事以胜故名增上缘。已说增上缘。因缘今当说。所谓因缘者。当知余因说。除所作因余因说因缘。已说缘。诸法随缘生今当说

  心及诸心法　　是从四缘生
  二正受从三　　谓余说于二

心及诸心法是从四缘生者。心心法从四缘生。前开导故生。是彼次第缘境界。是彼缘缘除自己余一切法。是彼增上缘余因随其所应说因缘。二正受从三者。无想正受灭尽正受从三缘生。二正受前心心法是彼次第缘。自地前生善法及彼共起四相。是彼因缘增上缘如前说。谓余说于二者。除无想定灭尽定。余心不相应行及色。此诸法二缘生。谓因缘增上缘。已说诸法从缘生。有为法分齐今当说

  分齐有三种　　名色及与时
  初分说一字　　极微刹那余

分齐有三种名色及与时者。一切有为法立三种分齐。随其事名分齐。色分齐时分齐。问此云何。答初分说一字极微刹那余。少名者。谓一字。名之至少极于一字。故说一字为名分齐。少色者。谓一极微。若真实行智分析色相。色之至细极于一微。故说一微为色分齐。少时者。谓一刹那。时之至少极于一念。故说刹那为时分齐。刹那量者。有说。如壮夫疾回历观众星。随其所历一星一刹那。如是一切。又说。如壮夫弹指顷经六十四刹那。又说。如壮夫以极利刀断迦尸细缕。断一缕一刹那。如是一切。又说。世尊不说刹那。如所说。比丘当知。四善射夫执弓俱射。如彼广说。已说极微如是。色增长今当说

  七微成阿耨　　七耨成铜尘
  水兔羊毛尘　　当知从七起

七极微成一阿耨。彼是最细色。天眼能见。及菩萨转轮王见。七阿耨为铜上尘。七铜上尘为水上尘。七水上尘为一兔毫上尘。七兔毫上尘为一羊毛上尘

  牛毛户向尘　　虮虱[麩-夫+廣]麦等
  小大是转增　　皆从七数起

七羊毛尘成一牛毛尘。七牛毛尘成一向游尘。七向游尘成一虮。七虮成一虱。七虱成一[麩-夫+廣]麦

  如是七[麩-夫+廣]麦　　转增为一指
  二十四指量　　名之为一肘

七[麩-夫+廣]麦为一指。二十四指为一肘

  四肘为一弓　　五百拘屡舍
  去村拘屡舍　　是名为空处

如是应当知。彼数即身量四肘为一弓。去村五百弓名为空处。是摩竭提一拘屡舍。北方名拘屡舍半。问已知刹那乃至拘屡舍。八拘屡舍名一由旬。当说身量。以何为身量。答彼数即身量。前所说肘量及拘屡舍。当知即是身量。彼人间肘作身量。阎浮提人长三肘半或四肘。弗婆提人长八肘。瞿陀尼人十六肘。郁单越人三十二肘。以前说拘屡舍为天身量。四天王身。拘屡舍四分之一。三十三天半拘屡舍。帝释身一拘屡舍。夜摩天身拘屡舍四分之三。兜率陀天身一拘屡舍。化自在天身一拘屡舍及拘屡舍四分之一。他化自在天身一拘屡舍半。此是欲界天身量。色界梵天身半由延。梵福楼天身一由延。大梵天身一由延半。少光天身二由延。无量光天身四由延。光音天身八由延。少净天身十六由延。无量净天身三十二由延。遍净天身六十四由延。福爱天身百二十五由延。福生天身二百五十由延。广果天身五百由延。无想天身亦尔。无希望天身千由延。无热天身二千由延。善见天身四千由延。善现天身八千由延。色究竟天身万六千由延。此说色界天身量。此名色分齐。问如前说时分齐一刹那。余时今当说。答

  刹那百二十　　说名怛刹那
  六十名罗婆　　三十摩睺罗

百二十刹那名一怛刹那。六十怛刹那名一罗婆。七千二百刹那也。三十罗婆名一摩睺罗多。二十一万六千刹那也

  三十摩睺罗　　说名一日夜
  欲界或昼夜　　于上以劫数

三十摩睺罗多为一日一夜。有六百四十八万刹那也。已知日夜刹那数。寿命今当说。欲界或昼夜于上以劫数者。欲界众生寿即以上昼夜数为欲界寿量。或劫数阎浮提人寿或无量或十岁。弗婆提人二百五十岁。瞿陀尼人五百岁。郁单越人千岁。人间五十岁为四天王天上一日一夜。即以是日三十日为一月。十二月为一岁。如是日月岁数。四天王天寿五百岁人间九百万岁。是等活地狱一日一夜。即以是日三十日为一月。十二月为一岁。如是日月岁数。等活地狱寿五百岁人间百岁。为三十三天一日一夜。如是日月岁数。三十三天寿千岁人间三亿六百万岁。是黑绳大地狱一日一夜。如是日月岁数。黑绳大地狱寿千岁人间二百岁。为焰摩天上一日一夜。如是日月岁数。焰摩天寿二千岁人间十四亿四百万岁。是众合大地狱一日一夜。如是日月岁数。众合大地狱寿二千岁人间四百岁。为兜率陀天上一日一夜。如是日月岁数。兜率陀天寿四千岁人间五十七亿六百万岁。是呼地狱一日一夜。如是日月岁数。呼地狱寿四千岁人间八百岁。为化乐天上一日一夜。如是日月岁数。化乐天寿八千岁人间二百三十亿四百万岁。是大呼地狱一日一夜。如是日月岁数。大呼地狱寿八千岁人间千六百岁。为他化自在天一日一夜。如是日月岁数。他化自在天寿一万六千岁人间九百二十一亿六百万岁。是热大地狱一日一夜。如是日月岁数。热大地狱寿一万六千岁。众热大地狱寿半劫。无择大地狱寿一劫。畜生趣极长寿亦一劫。如持地龙王。饿鬼极长寿五百岁。问已说欲界寿。上界复云何。答于上以劫数。彼色界梵身天寿半劫。梵福楼天寿一劫。大梵天寿一劫半。少光天二劫。无量光天四劫。光音天八劫。少净天十六劫。无量净天三十二劫。遍净天六十四劫。福爱天一百二十五劫。福生天二百五十劫。广果天五百劫。无想天亦如是。无希望天千劫。无热天二千劫。善见天四千劫。善现天八千劫。色究竟天万六千劫。无色界空处二万劫。识处四万劫。无所有处六万劫。非想非非想处八万劫。一切三界皆有中夭。唯除郁单越及兜率天最后身菩萨及无想天。问以何等故。此诸法说行。答

多法生一法。一亦能生多。缘行所作行。是行应当知。无有法自力生。一法以多法力故生。多法亦以一法力故生。如是一切有为法。是故说缘行所作行。是行应当知。缘彼行故有所作故说缘行。行所作故作彼行故说作行

杂阿毗昙心论卷第二杂阿毗昙心论卷第三

        尊者法救造

        宋天竺三藏僧伽跋摩等译

    业品第三

已说诸行展转因缘力生。彼诸行所起种种生生生差别胜者唯业。彼业今当说

  业能庄饰世　　趣趣各处处
  是以当思业　　求离世解脱

业能庄饰世趣趣各处处者。如是一切五趣种种性生种种业庄饰。以业为种。彼有芽生业差别故生差别。如种差别故芽差别。是以当思业求离世解脱。业于受生胜故。是故欲背生死者当善观察。问谁业。答

  身口意集业　　在于有有中
  彼业为诸行　　严饰种种身

身口意集业在于有有中者。身业口业意业。此三业生种种果。众生住于本有死有中有生有中。修集诸业。问云何立三业。为自性故。为依故。为等起故。若自性者。应一业。谓语业。若依者。一切依身亦应一业。谓身业。若等起者。一切从意起亦应一业。谓意业。答此亦如是。三事故。彼自性者语业。以语即业故。依者身业。以业依身故。身作故。身合故。身运故。等起者意业。虽身业口业意业所起。然不共受名如眼识。问如所说业何所为。答彼业为诸行及受种种身。此说一切众生增上果。谓外众具名为行。若众生形相寿命等是彼业果。问若彼内外分种种相者。此云何为四大种种相。为造色种种相。为业种种相。答三种悉有生因依因建立因养因长因故。是四大种种相。自分因故。是造色种种相。报因故。是业种种相。虽外分无报因。然众生作善行彼得好色好处。若作恶行得恶色恶处。以业种种故内外分亦种种。是业相今当略说

  身业当知二　　谓作及无作
  口业亦如是　　意业当知思

身业当知二谓作及无作者。身业二种作性及无作性。作者。身动身方便身作。无作者。身动灭已与余识俱彼性随生。如善受戒秽污无记心现在前善戒随生。如恶戒人善无记心现在前恶戒随生。口业亦如是者。口业二种作无作性如前说。意业当知思者。意业是思自性。有欲令意业是无作性。此则不然。意非作性。非色故。及三种故。无作亦名不乐亦名离。亦名舍。亦名不作。以不作之名是无作。言非业者不然。何以故。作故。若善不作不善。若不善不作善。亦名作。如舍觉支。不以名舍故舍修道。止余事故名为舍。彼亦如是。又复作因故作果故。见因说果。如世尊说。形质故是色。无作亦非色。以作是色故彼亦名色。彼亦如是。已说五业。如此业种种差别今当说

  作当知三种　　善不善无记
  意业亦如是　　余不说无记

作当知三种善不善无记者。身作及口作。三种善不善无记。彼善者。净心身口动。如施戒等。不善者。不善心身口动。如杀生等。无记者。无记心身口动。意业亦如是者。意业亦三种。善心相应是善。不善心相应是不善。无记心相应是无记。余不说无记者。余二业身无作及口无作。彼二种善不善。无记何以故。无记心羸劣故。强力心能起身口业。余心俱行相续生。如手执香华。虽复舍之余气续生。非如执木石等。问已知五业思非色性。大地中已说故。余业有何性。答

  色性染不染　　不染污五地
  隐没系在色　　不善在欲界

色者一切身业口业是色性。因四大故。彼身作可见有对。口作不可见有对。无作俱不可见无对。问身口业几种。答染污不染污。彼色二种。染污不染污。染污者。烦恼所起。彼有二种。隐没无记及不善。隐没无记者。无报无惭无愧不相应一果烦恼等起。不善者。有报无惭无愧相应二果烦恼等起。不染污亦二种。善及不隐没无记。善者。得爱果。彼亦二种。有漏及无漏。此品后当广说。不隐没无记者。不隐没无记心等起。谓威仪工巧非报生。强力心能起身口业。报生心羸劣故不起。是故身口业非报性。若报生心能起身口业者。彼身口业亦应是报。但不尔。现在方便生故。若报生心。不应名。威仪工巧。是故身口业非报。问几地所摄。答不染污五地。欲界及四禅。此则总说。若善作唯至初禅非上地。问何故善身口作至初禅非上地。答粗心起身口作业。彼心细故外向心起作业彼心。内向故觉观起作业彼地无故。善无作者。五地欲界及四禅有无作禅律仪无漏律仪。不隐没无记身作亦五地如前说。差别者。欲界作威仪工巧心等起。色界作威仪心等起。彼无工巧心。问已说上地无起作心。云何有作。答彼初禅力起作心现在前故起。若说善亦应尔者不然以。生上地下地善心不现在前。以彼劣故。隐没系在色者。若隐没无记身口业在色界初禅非上地无起作心故。非生上地下地染污心现在前离欲故。亦不在欲界修道断烦恼等起身口业。而欲界修道断烦恼一向不善故。见道断心不起身口业。此品后当说。不善在欲界者。若染污中不善者。在欲界非色界。何以故。彼善心易得故。正受长养故。无无惭无愧故。无苦受故。不善者受苦受眷属报。色无色界无。无有色界业受欲界报界异故。因果断界故。已说身口业自性种地。谓无作律仪差别今当说

  若作无作戒　　略说有三种
  无漏及禅生　　依别解脱戒

若作无作戒略说有三种者。无作戒若律仪所摄。略说当知三种。问何者是。答无漏及禅生依别解脱戒。彼无漏戒与道一果道俱行。谓学无学禅生者。彼禅戒与禅一果禅俱行。正语正业正命。正命者。建立身业口业。无别体故。身业口业从无贪无恚无痴生。无恚无痴生者。名正语正业。无贪生者。名正命。虽一心中有三善根。以增上故说如贪等。行如动风药如字音。依别解脱戒者。谓受戒式叉尸罗随转亦有断律仪。契经品当广说。问是身业口业何等不随心转。何等随心转。答

  无作在欲界　　作依于二有
  当知非心俱　　谓余心俱说

欲界无作不随心转。谓受戒已不善无记心亦随转。亦不与善不善无记心随转异相故。又复覆恶戒故。由作故。不定故。作者欲色界亦不随心转。由身故。非心一果故。谓余心俱说者。禅律仪无漏律仪是余。彼随心转。心一果故。由心故。已说建立业。成就戒今当说

  无漏戒律仪　　得道则成就
  禅生若得禅　　持戒生欲界

无漏戒律仪得道则成就者。得道谓一切圣道。从苦法忍乃至无生智。成就无漏律仪。此无漏律仪在六地。未来中间根本四禅。彼须陀洹斯陀含向及果。成就一地无漏戒。阿那含向或成就一地或六地。阿那含果或三地乃至六地。阿罗汉六地。禅生若得禅者。若得禅成就禅律仪。谓得不失此亦六地。持戒生欲界者。若受戒则成就别解脱律仪。此律仪谓欲界人非余。无受分故。已略说成就戒。世分别今当说

  谓住别解脱　　无作于转时
  当知恒成就　　尽不舍过去

谓住别解脱无作于转时当知恒成就者。别解脱律仪现在无作戒常成就。念念得未曾得。尽不舍过去者。住别解脱律仪无作若灭而不舍。则成就过去。舍事。此品后当说

  若有作于作　　即时立中世
  已尽而不舍　　当知成过去

若有作于作即时立中世者。中世。谓现在住身口求受戒。尔时成就现在身口作。已尽而不舍。当知成过去者。若作尽不舍。尔时成就过去作。非现在。以作不念念相续生故

  若得禅无作　　成就灭未至
  中若入正受　　作亦如前说

若得禅无作成就灭未至者。若得禅彼则成就过去未来禅律仪。若初得禅彼无始生死灭过去者今悉得之。中若入正受者。如禅正受现在。彼无作亦尔。随心生故。作亦如前说者。如前别解脱作求时成就现在。若灭已不舍。尔时成就过去非现在。住禅者作亦如是。问若生色界。云何成就作。答世尊到色界。色界诸天礼敬右绕。乃至未究竟。尔时成就过去作

  悉成就当知　　得道若未生
  中间道在心　　尽不舍前世

悉成就当知得道若未生者。一切圣人一切时成就未来无漏律仪。中间道在心者。若道现在尔时成就无漏无作律仪。尽不舍前世者。前世是过去。若彼无作灭已不舍。是成就过去

  若作不善业　　立戒成就二
  至彼缠所缠　　尽已尽当知

若作不善业立戒成就二者。谓住别解脱禅生无漏律仪。若以不善极恼缠。起加卷等不善作无作。此则成就作无作。此说未离欲行不善故。问几时成就。答至彼缠所缠。乃至缠未舍住非律仪。尽已尽当知者。若彼缠尽。作无作亦尽

  若住不律仪　　无作成就中
  能受不爱果　　或复尽不舍

若住不律仪无作成就中能受不爱果者。住不律仪。谓屠脍等。彼一切时现在成就不善无作。不善无作念念生故。或复尽不舍者。彼无作灭不舍。则成就过去

  若刹那住作　　即时说中世
  已尽而不舍　　善于上相违

若刹那住作即时说中世者。彼住不律仪者。受不律仪时。成就现在作。已尽而不舍者。彼作灭而不失。则成就过去非现在。不相续故。善于上相违者。如住律仪说不善。住不律仪说善

  若处中所作　　是则立中世
  若尽而不舍　　或二亦复一

若处中所作是则立中世者。处中。谓非律仪非不律仪。若受善时心不淳净。成就现在善作。若住不善时不极恼缠。成就现在不善作。若尽而不舍者。灭已不舍。彼成就过去作非现在。不相续生故。或二者。若善淳净心。不善极恼缠。受彼现在成就作及无作。亦复一者。谓第二刹那起唯无作现在。若过去现在分别。若善不善分别亦尔

  隐没不隐没　　二作俱非尽
  及净不净等　　一切无生说

隐没不隐没二作俱非尽者。若隐没无记及不隐没无记作不成就。过去羸劣心等起故。余势不强故。若现在受作时则成就现在。刹那成就故亦不说无作。以无记无俱故。及净不净等一切无生说者。若善不善隐没无记及不隐没无记作悉不成就。未来以无住。未来世受作故。问何等为律仪不律仪。答

  流注相续成　　善及不善戒
  于一切众生　　律仪不律仪

彼别解脱律仪者。谓受戒于一切众生一切时戒不断。或十二种或二十一种随转。不律仪者。谓住不律仪于一切众生一切时恶戒不断。问何等住不律仪。答十二种住不律仪。所谓屠羊养鸡养猪捕鸟捕鱼猎师作贼魁脍守狱咒龙屠犬司猎。屠羊者。谓杀羊。以杀心若养若卖若杀。悉名屠羊。养鸡养猪亦如是。捕鸟者。杀鸟自活。捕鱼猎师亦如是。作贼者。常行劫害。魁脍者。主杀人自活。守狱者。以守狱自活。咒龙者。习咒龙蛇戏乐自活。屠犬者。旃陀罗。司猎者。王家猎主。若屠羊者。虽不杀余众生。而于一切众生所得不律仪。何以故。若一切众生为羊像在前者。于彼一切悉起害心。一切众生有作羊理故。若复无作羊理者。于彼亦有害心故得不律仪。如住慈心仁想普周。当知住余不律仪亦如是。若王若典刑若听讼官有害心者。悉堕不律仪义。问得律仪斋何时。答

  谓受律仪戒　　尽寿或日夜
  不律仪尽寿　　二俱无增受

谓受律仪戒尽寿或日夜者。受别解脱律仪有二种。或尽寿者。谓七众。七众者。比丘比丘尼式叉摩尼沙弥沙弥尼优婆塞优婆夷。日夜者。谓受斋有二种时分斋。日夜及尽寿。问不律仪复云何。答不律仪尽寿。谓不律仪尽形寿。非日夜。问以何等故律仪得日夜非不律仪。答彼无受性故。无有言我日夜受不律仪者。以可羞厌故。善律仪有受性可欣庆故。二俱无增受者。律仪不律仪俱无增受。半月一月六月。善恶希望不究竟舍。日夜戒亦如是。过者不然。无分斋性故。二种分斋前已说。彼因缘故不律仪无日夜受。是因缘前已说。问别解脱律仪云何得。答

  受别解脱戒　　当知从他教
  随心下中上　　得三品律仪

受别解脱戒当知从他教者。别解脱律仪从他教得。若众若人若法。众者。谓白四羯磨受具足。人者。谓善来。法者。谓佛及五比丘等。又问乐。谓须陀耶律毗婆沙说十种受具足。所谓自起。谓佛超升离生。谓五比丘善来。谓耶舍等师受。谓摩诃迦叶问乐者谓须陀耶受重法。谓摩诃波阇波提遣使。谓法与律师第五人。谓边地十众。谓中国三归三说。问何等种得律仪。答随心下中上得三品律仪。若下心受别解脱戒。彼得下戒。下心果故。若极方便行善。乃至离色无色界欲。种三乘种子。众生种类相续。彼犹下品随转。若中心受戒得中律仪。若极方便行善。若不舍戒作诸恶行。彼犹中品随转。若增上心受戒得上律仪。乃至种类相续。犹增上随转。或有年少比丘得增上律仪。虽复阿罗汉犹成就下戒。有别解脱戒从下中从中上。谓先以下心受优婆塞律仪。次以中心受沙弥律仪。后以上心受比丘律仪。从中下上从上下中。谓住律仪。有于一切众生起非一切支非一切因。有于一切众生起一切支非一切因。有于一切众生起一切支一切因。有于一切众生起一切因非一切支者无也。彼众生者。谓蠕动类。枝者。不杀生乃至不绮语。因者。下中上心。又说。无贪无恚无痴有于一切众生起非一切支非一切因者。谓下心受优婆塞戒。下心受沙弥戒。有于一切众生起一切支非一切因者。谓下心受三种戒。或中或上或二。有于一切众生起一切支一切因者。谓三种心受三种戒。是故于一切众生起一切因非一切支者无有也。若以初下心受日夜戒。次中心受优婆塞戒。后上心受沙弥戒。谓言应说于一切众生起一切因非一切支者。此义不然。彼为尽寿故说。问住何等心得别解脱律仪答。于一切众生起慈心若言我于此受不于彼受不得律仪。恶心随故。如言我受不猎兽。以少分故是善业不得律仪。以别解脱戒普于一切。能不能所得律仪故。若异此者律仪应有增减。以能者生不能处不能者生能处故。如是有何过。谓非舍时应舍别解脱律仪应顿得别舍应不受而得别解脱律仪。于现在阴界入得众生处所得故。非过去未来堕法数故。以是故应作四句。有阴界入得别解脱律仪。非禅无漏律仪者。谓于现在起前后眷属及制罪。有阴界入得禅无漏律仪。非别解脱律仪者。谓于过去未来起根本业道。有阴界入得别解脱律仪亦禅无漏律仪者。谓于现在起根本业道。有阴界入不得别解脱律仪及禅无漏律仪者。谓于过去未来起前后眷属。于生草等得于时舍者不然。生草处起故。谓能不能如是说者不然。众生前后同性。生草等后非性。于此论阿罗汉般涅槃同此说。后非性故。此义择品当广说。问已说别解脱律仪。禅律仪云何得。答

  得色界善心　　得禅律仪戒
  是舍彼亦舍　　无漏有六心

得色界善心得禅律仪戒者。若有得色界善心彼得禅律仪。以色界善心戒常随故。除六心。初禅三识身心。闻慧心。起作业心。命终心。以不定故。定心戒常随转。以三识身心外向起故。起作业心亦如是。闻慧心名处起故。死时心羸劣故。第二禅第三禅第四禅有二不定心。谓闻慧心命终心。问无色界何故无戒耶。答彼无色性故。戒者是色。彼中无色无四大性故。若彼有四大者应有戒。无色界无四大故。戒者恶戒对治。非无色界恶戒对治。恶戒者在欲界。无色界四远远故。所谓依远行远缘远对治远。根本禅一切比智品。虽非断对治。然有持对治及远分对治。若苦法智集法智有坏对治。根本禅摄故。未来禅有断对治。若灭道法智根本禅摄者非坏对治。无漏缘故。问云何舍。答是舍彼亦舍。若失色界心。彼律仪亦失。由心故。问无漏律仪云何得。答无漏有六心。无漏律仪六地心共得。禅未来乃至第四禅。以六地有见道非上地。上地不广境界故。若依未来超升离生修一地。见道无间等边修二地等智。谓禅未来所摄及欲界乃至依第四禅超升离生修六地。见道无间等边修七地等智。问何故。无色界无见道耶。答无忍及法智性故。无拘舍罗善根故(拘舍罗者言业行也)。无戒故。不缘欲界故。问禅律仪无漏律仪有何差别。答禅律仪有垢。无漏律仪离垢。又说禅律仪是根本禅戒。无漏律仪一切无漏戒。此应作四句。或禅律仪非无漏者。谓根本禅世俗戒。无漏律仪非禅者。谓未来中间无漏戒。亦禅无漏律仪者。谓根本禅无漏戒。非禅无漏律仪者。谓未来中间世俗戒。得四句亦如是。问不律仪云何得。答

  若作及受事　　而得不律仪
  随心下中上　　三品恶戒生

若作及受事而得不律仪者。有二因缘得不律仪。谓作及受事。作者。谓不律仪家生。乃至未杀生未得不律仪。若杀生彼得不律仪。受事者。若生余家作是言。我当作此业以自活。彼即得不律仪。问以何名住不律仪。为具耶不具耶。答有说。不具亦名住不律仪。谓不律仪家生。彼性不能语而杀生。得身业性非口业。毗婆沙者说。如律仪不具足不名住律仪。不律仪亦如是。但以恶希望具故生不律仪家。虽性不能语。而以身表语义故从。彼得不律仪。问若住不律仪而受日夜律仪法。尔时得律仪舍不律仪。至明相出彼复舍律仪还得不律仪耶。答有说。得。舍不律仪得律仪。舍律仪得不律仪。有说不得。若一身种类不杀生。乃至身种类尽不得不律仪。无作无受故。舍不律仪得律仪。舍律仪得不律仪。亦非不律仪。问云何得不律仪。答随心下中上三品恶戒生。若初以下心杀众生。若受事彼得下杀生无作及下不律仪。谓于余一切众生得不律仪所摄。彼后若以中上心杀生。彼得中上杀生无作不律仪。先已得从中上起亦如是。有住不律仪于一切众生起非一切支非一切因。有于一切众生起一切支非一切因。有于一切众生起一切因非一切支。有于一切众生起一切因一切支。有于一切众生起非一切支非一切因者。谓以下缠杀众生。若中若上而不作余业道。有于一切众生起一切支非一切因者。谓以下缠杀众生。乃至绮语非中上。有于一切众生起一切因非一切支者。谓以下中上缠杀众生。非余业道。有于一切众生起一切因一切支者。谓以下中上缠杀众生。乃至绮语。彼说不具足不律仪。不名住不律仪者。彼说于一切众生起及一切支而因不定。问诸律仪几时舍。答

  别解脱调伏　　是舍于四时
  若舍及命终　　断善二根生

别解脱调伏是舍于四时者。别解脱调伏当知四时舍。问何时。答若舍及命终断善二根生。谓舍戒身种类灭善根断二形生。持律者云。法没尽时彼说戒结界羯磨一切息。阿毗昙者说。法没尽时先所受律仪相续生不舍。未曾得律仪不得。是故说一切息。有说。犯初众罪名舍律仪。此则不然。若舍律仪者犯根本罪已还俗应得更出家。以舍律仪故。佛言非比丘者。以非第一义比丘故。此说无过也。犯初众罪于别解脱律仪是比丘。于无漏律仪非比丘。尽寿律仪有四时舍。斋律仪至明相起时舍。谓住律仪而犯律仪者。是犯戒非舍戒。当知彼人住持戒犯戒也。彼若悔者。即舍犯戒住持戒也。如富人负债名富者亦名负债者。若还债已唯名富者。彼亦如是

  谓禅生律仪　　当知二时舍
  若起烦恼退　　生上及下地

禅律仪二时舍。问何时。答若起烦恼退生上及下地。谓禅退时舍彼律仪。由禅故及生上生下时

  无漏戒律仪　　是说三时舍
  退及得圣果　　增益根当知

无漏律仪三时舍。问何时。答退及得圣果增益根。当知退者失胜功德。得果者。谓得须陀洹果乃至阿罗汉果。增益根者。谓信解脱得见到时解脱得不动。问不律仪云何舍。答

  不律仪四时　　受戒及命终
  逮得诸禅定　　二根生亦然

不律仪四时舍。受戒时。舍身种类时。得禅律仪时。二根生时。问住不律仪若舍杀具名舍不律仪不。答名为止业。若不受律仪不名舍。不律仪非对治故。如不服药而舍病因病则随生。问已知律仪不律仪舍时。彼俱离者作善戒恶戒。舍时云何。答

  谓彼限势过　　及与希望止
  亦舍于方便　　是说善恶舍

彼俱离者。若善戒恶戒三时舍。谓限势过。希望止。舍方便。限势过者。若欲作善戒恶戒事时先作齐限。限过则止。如陶家轮势极则住。希望止者。彼发心念言。后更不作。舍方便者。息身口行。彼俱离者作善行恶行。尽身种类无作随生。谓作是誓言。不供养佛终不先食。若以香华赞叹敬礼。及余种种日日供养。尽身种类无作随生。有作是誓言。不施他乃至一揣终不先食。彼亦尽身种类无作随生。若作定期施。若日若月若岁。作是誓言。我尽寿作。即出少物以供彼用。彼尽身种类无作随生。若起塔。若四方僧舍。若僧舍。若别房。若园观浴池。若桥船。如是等有三因缘。无作不断。若希望若身若事。恶戒者彼亦作是誓言。我当日日于彼怨家常作不饶益事。若一打若一恶言。彼尽寿不善无作随生。已说舍色业。无色今当说

  善无色舍时　　断退生诸地
  秽污唯离欲　　当知是意业

善无色舍时断退生诸地者。若善有漏无色法三时舍。谓断善根时。退时。生诸地时。秽污唯离欲者。秽污无色法离欲时舍。若此品对治生即舍此品。已说诸业自性及成就。如此业世尊种种分别。今当说

  若业与苦果　　当知是恶行
  复有意恶行　　贪嗔恚邪见

若业与苦果当知是恶行者。若身口业及思不爱报果生故。当知是恶行。问唯此恶行耶。答复有意恶行。谓贪嗔恚邪见不善思。是意恶行如前说。复有贪恚邪见

  是相违妙行　　最胜之所说
  若于中增上　　说名十业道

是相违妙行最胜之所说者。恶行相违悉是妙行。若身善业悉是身妙行。若口善业悉是口妙行。若意善业及无贪无恚正见悉是意妙行。隐没不隐没无记业。无报故非恶行非妙行。若彼不隐没无记巧便者。如行行如说说。与此相违不隐没无记及隐没名不巧便。问一切善行恶行皆业道所摄耶。答若于中增上说名十业道。此诸善行恶行中增上业胜者是业道。彼妙行增者说善业道。恶行增者说不善业道。若言不定者不然。以根本业道多增上极逼迫故。极恐怖故。事究竟故。是故说增上者是根本业道。问何等为业道。答杀生乃至邪见。彼杀生今当说

  有欲杀生心　　众生想杀生
  是名为杀生　　盗淫亦如是

有欲杀生心众生想杀生者。谓欲杀他众生。定不定众生起众生想。杀彼众生名作无作。或复一向名无作。是身业杀生非余不具自在者。口语及仙人意所嫌而杀。谓是口意业自性者不然。业自性异故。事不究竟故。若谓有心无心杀彼众生俱应得杀罪。如触火食毒者不然。非譬故。若手执刀若手掷刀。若有心若无心。触火不烧。若咒毒若药杂毒服者。若有心若无心不死。杀生不如是。是故非譬。若复谓于火毒得不烧不死因缘而杀生不得不杀因缘者不然。得不恶心故。如彼刀咒众药等是不烧不死因缘。不恶心是不杀因缘亦如是。以不恶心杀生则非杀生。如执刀触火不烧。问无心害众生不死耶。答死。虽杀生不得杀罪。无恶心故。虽逼迫他不得杀罪。谓此非说者不然。如不逼迫不摄他而罪福长养故。谓断善根得慈心。是故不非说盗者物他所有他物想知不与欲取。取作己有想名作无作。或一向名无作。是身业盗。邪淫者。父母等护起护想道非道行无护者非处非时。是不应行而行名作无作。是身业邪淫

  谓彼异想说　　别离不软语
  无义不诚说　　是则口业道

见闻等事颠倒不颠倒覆藏想起名作无作。或一向名无作。是口业妄语。或身动或默然。谓布萨事。是亦名妄语。若言身意业性者不然。业性异故。着身口业故。譬如着身。若身放作者是身业。譬如曾眼更后身触得长等。譬如受戒时口作得身业。譬如受具足时若默然若无心得身业。别离者。若坏若不坏欲坏想。若已坏不令和合。名作无作。或一向名无作。是口业两舌。不软语者恼乱心。若恼不恼名作无作。或一向名无作。是口业恶口。无义不诚语者。不善心非义非时不应法言。随入一切口恶行。如无明随烦恼。如音声随字

  众生相违害　　是名为嗔恚
  他物己想贪　　邪见谓何见

众生相违害是名为嗔恚者。于他众生恶心欲杀欲打。与慈悲相违。是名嗔恚。他物己想贪者。爱他物欲为己有想名为贪。是一切欲界贪。邪见谓何见者。于施等作无见名为邪见。问何业道谁究竟。答

  杀生与恶口　　及嗔恚业道
  皆由嗔恚成　　众生处所起

杀生与恶口及嗔恚业道皆由嗔恚成者。杀生恶口嗔恚当知从嗔恚成。究竟时要与嗔恚俱。问从何处生。答众生处所起。此三业道当知从众生处所起

  身二业及贪　　贪欲所究竟
  皆由贪欲成　　众具处所起

身二业及贪贪欲所究竟皆由贪欲成者。偷盗邪淫及贪。是三业道当知贪究竟。问此复何处起。答众具处所起。此三业道当知从众具处所起

  谓有余口业　　是皆三所成
  从名处所起　　明智之所说

谓有余口业是皆三所成者。妄语两舌绮语当知从贪欲嗔恚愚痴究竟。问彼复从何处起。答从名处所起明智之所说。此三口业道当知从名起

  邪见名色起　　亦从愚痴成
  一切诸业道　　三种为方便

邪见名色起亦从愚痴成者。谓邪见从名色处所起。问此谁究竟。答亦从愚痴成。此邪见当知从愚痴究竟。问一切业道方便如根本究竟为有异耶。答一切诸业道三种为方便。一切十不善业道。贪欲嗔恚愚痴悉为作方便。贪杀者。为皮肉筋骨等故杀。为己故或为亲友故。嗔恚杀者。杀怨家及怨亲友。令其忧恼。愚痴杀者。言杀诸毒虫等因缘无罪。以害人故。杀诸禽兽等因缘无罪。为人食故。波私国说。如父母老。若恶病应杀因缘无罪。贪盗者。盗所须物为己他故。嗔盗者。若盗怨若怨亲物令其忧恼。痴盗者。如婆罗门说一切地所生物悉施婆罗门。婆罗门弱劣故刹利等受用。是故婆罗门言自取己物无罪。而彼取时作他物想。故名盗。贪邪淫者。于众生所贪心方便。若他所受及自所受。若为财利非贪方便则嗔恚起。谓于怨家及怨亲所受。痴邪淫者。如说桥船野田华果道路女人。一切众生悉共受用。如婆罗门说婆罗门应有四妇。刹利应三。鞞舍应二。首陀罗唯一。口业若贪起当知从贪生。若恚起当知从恚生。若痴起当知从痴生。贪者若贪次第起是即从贪生。若嗔所起是从嗔恚生。愚痴所起是从愚痴生。嗔恚邪见亦如是。问云何业道定是作无作非耶。答

  根本业无作　　或复说有作
  方便终则异　　贪不贪等起

根本业无作或复说有作者。色自性七业道定无作。或复作邪淫定有作。以自究竟故。非他余业道不定。若自作则有作。若使他作者一向无作。问颇非身作而得杀生耶。答有。谓口作。颇非口作而得妄语耶。答有。谓身作。颇非身口作而得二罪耶。答有。谓仙人起恶心。谓布萨事。若欲界色性善业道定有作及无作。禅无漏律仪唯无作非作。由心故。方便者有作。若淳净心及极利缠作有无作。若不淳净心及不极利缠作者唯有作无无作。终则异者。业道终唯无作。作业已息故。问何等为业道方便。何等为终。答杀方便。谓屠羊者若捉若买若牵来一打三打。乃至命未尽悉名方便。当断命时刹那顷作及无作。是根本业道。后乃至于是处不善身所作及无作。是杀生终。乃至绮语亦如是。是名为终。贪恚邪见无方便现在前则是根本起。有说。身口业道一切十业为方便及终。此云何。如欲杀彼众生杀此众生为因然后杀彼。谓杀生祈请助力杀彼。或劫他财以资杀事。或淫彼所受令杀其主。或于彼知友妄语恶口两舌绮语以离其亲。或贪彼财。或复嗔彼。或起邪见长养杀法后杀彼子。复淫彼妇。次第乃至十不善业道。当知是终。如是一切尽当知。贪不贪等起者。不善业道贪恚痴为方便亦为终。善业道以不贪不恚不痴起。舍不善业道方便即是善业道方便。舍根本即是根本。舍终即是终。问此云何。答如沙弥受具足入戒场周匝礼僧求和上受衣钵白一羯磨乃至二羯磨。皆是方便。第三羯磨彼刹那顷作及无作。是根本业道。次说四依。如是乃至于是处身口所作及无作。是名为终。问何处有几业道。答

  地狱五业道　　郁单曰后四
  余方具有十　　及余恶趣天

地狱五业道者。地狱众生有五不善业道。恶口绮语贪恚邪见。无相杀故无杀业道。无受财故无盗。无执受女人故无邪淫。异想说故名妄语。彼无异想故无妄语。常离故无两舌。为苦所逼故有恶口。不时说故有绮语。贪及邪见成就而不行。嗔恚者俱有。郁单曰后四者。有后四不善业道。寿分定故无杀生。无受财故无盗。无执受女人故无邪淫。欲行欲时将彼女人往诣树下。树自曲枝而覆其上。然后行欲去已还复。若树不覆并愧而离。无欺他故无妄语。常和故无两舌。柔软故无粗言。有歌叹故有绮语。意业道虽成就而不行余方具有十者。除郁单曰。余三方有十业道。或不律仪所摄。或离不律仪所摄。及余恶趣天者。畜生饿鬼及欲界天有十业道。离不律仪虽天不害。天而害余趣。又说天亦有截手足断而还生。若斩首若中截则死。展转相夺等。乃至十业道一切悉有。色无色天无有不善业道。问何处有几善业道。答

  地狱郁单曰　　有三善业道
  等现于无色　　彼圣成就十

地狱郁单曰有三善业道者。地狱有无贪无恚正见。郁单曰亦尔。等现于无色者。无色界即此三现在前行。彼圣成就十者。无色界圣人。成就无漏十善业道

  如此亦复异　　谓色界律仪
  畜生饿鬼异　　余如是亦异

如此亦复异谓色界律仪者。色界禅律仪所摄具十善业道。亦成就亦现在前。圣人生彼则有无漏业道。畜生饿鬼异者。畜生饿鬼亦有十善业道。离律仪亦离不律仪。余如是亦异者。阎浮提弗婆提瞿陀尼及欲界天说余。彼有十善业道。是律仪所摄。或离律仪。谓欲界天唯有禅无漏律仪。问几不善业道一时与思俱转。答

  不善业道起　　一与思俱转
  二三乃至八　　当知次第增

此身自性三不善业道。彼一一与思俱转。谓杀生偷盗邪淫。二俱转者。杀他众生而盗取。三俱转者。遣二使已自行邪淫。以此行自究竟非他故。若彼种类和合者则一切俱究竟。口业道一俱转者。谓绮语。二俱转者。摄妄语非时说绮语。摄欲别离说非时说绮语。摄恶口说非时说绮语。三俱转者。摄欲别离说妄语非时说绮语。摄恶口妄语非时说绮语。摄恶口欲别离说非时说绮语。四俱转者。摄欲别离妄语恶口非时说绮语。意业道者。一一俱转。行别故不二。如是五六七八俱转。遣六使自行邪淫。不由他故。若彼种类和合者则一时俱究竟及贪现在前。如是八不善业道与思俱转。问几善业道一时与思俱转。答

  所谓善业道　　二三及与四
  六七九与十　　一时思俱转

欲界善五识身现在前。初禅地三识及依无色尽智无生智。此二善业道与思俱转。谓无贪无恚。欲界善意识现在前。色界不定心及无色界。又依无色无漏正见三事与思俱转。优婆塞及沙弥染污及无记心受律仪。四即此善五识住。六即此善意识住及比丘染污无记心非心。七比丘善五识住。若依禅尽智无生智俱心。九即此比丘善意识住及色界定心依禅无漏正见现在前。十善业道与思俱转。问何业道有几果。答

  一一果有三　　所谓为报果
  依果及增上　　是名业道果

一一业道皆有三果。谓报果依果增上果。彼业道修习多修习生地狱中是报果。从地狱出来生人中受相似果。谓杀生者短寿。盗者失财。邪淫者妻不贞良。妄语者恶名讥论。两舌者亲友乖离。恶口者常闻恶声。绮语者言语不正。贪者增贪。嗔者增嗔。邪见者增痴。是为依果。此诸业道增上果者。谓众具粗悴无有光泽。多遭霜雹尘垢污浊臭秽不净。居处崄曲茨棘恶刺果实零落鲜少微细极大苦恼无有华果。问云何果相似。答

  苦他恶道苦　　伤寿则短寿
  外具不光泽　　坏彼光泽故

苦他恶道苦者。谓杀生令彼受苦得恶道苦。此是相似。问杀何等阴。为色阴耶为五阴耶。答有说。色阴以色可断坏故。四阴非触。有说。五阴四阴虽非触。彼依色阴转。杀色阴亦杀彼。如瓶破则失乳。问为杀无记为三种耶。答有说。无记以无记受刀杖故。余二非触。又说。一切三种如前说。问杀何阴过去耶未来现在耶。若过去者彼已灭。若未来者不可得。若现在者彼刹那顷不住。答有说。未来现在世住坏未来和合。又说。未来现在以现在受刀杖不相续阴灭。伤寿则短命者。谓彼杀者断彼命故而得短寿。外具不光泽坏彼光泽故者。谓彼杀者坏彼光泽故。所得众具悉不光泽。一切业道随其所应当知。盗及邪淫虽不令彼苦。以坏希望故。如不别离亦名两舌。彼虽不恼亦名恶口。已说业道分。差别今当说

  谓现法果业　　次受于生果
  后果亦复然　　当知分各定

三业现受生受后受。现法受业者。若业此生作即此生熟。名为现受。若第二生熟者。名为生受。第二生后熟者。名为后受。或有欲令四业前三及不定受。前三者不转。不定者转。转者谓持戒等护故。譬喻者说。一切业转乃至无间。彼说。若无间不转者。亦无有越第一有。若越第一有者。故知无间业亦转。彼有说现法业不必现报熟。若熟者现法受非余。如是说者。说八业现法报。或定不定乃至不定受业亦如是。是故彼说分定熟不定应作四句。或分定熟不定。或熟定分不定。或分定熟亦定。或非分定亦非熟定。问此四业几一身种类种。答三。除现法受。欲界四种业种。色无色界亦如是。地狱趣四种不善业种。善者三种。除现受业。余趣俱四种。生欲界凡夫欲爱未尽。欲界四种。若欲爱尽梵天爱未尽。若不退种性法者。欲界三种。除生受。梵天亦三种。除现受。若退种性法者梵天如前说。欲界四种善业种。如是随其义一切地生凡夫圣人亦如是说。已说现受等。乐受今当说

  欲界中善业　　及色界三地
  说名为乐受　　此亦定不定

欲界中善业及色界三地说名为乐受者。欲界善业得乐受及众具报。色界乃至第三禅业皆得乐报。问禅中间业得何等报。答有说。初禅乐报。此非说。以阿毗昙说。或业得心受非身耶。答有。善无觉业。又说。禅中间业不得受报。唯有色心不相应行。问此分亦定耶。答此亦定不定。若定若不定此四地中善皆有乐报

  得不苦不乐　　是说为上善
  若受于苦报　　是说不善业

得不苦不乐是说为上善者。第四禅地善业及无色地善业说不苦不乐报。以彼得不苦不乐受及众具故。问下地何故无不苦不乐报耶。答有说。下地粗而彼受细故。下地不寂静而彼受寂静故。若下地作善业皆为乐受故。无有求不苦不乐受者。虽不求苦报。以求乐故作恶行。是故虽不求而受苦报。若受于苦报是说不善业者。不善业说苦报。苦受果故。非独业受报。四阴五阴亦受报。但业胜故说业受报。当知此亦定不定。问几种受。答

  所谓自性受　　相应与报受
  现前及境界　　是说五种受

五种受。谓自性受。相应受。报受。现前受。境界受。自性受者。受也。相应受者。受相应法。报受者。乐受等业。现前受者。现在受。如大因经说。若乐受现在前时。二受则灭。境界受者。眼触生觉。受色是攀缘义。此五种受中当知说报受非余。问世尊说黑报等四业。云何建立。答

  色有中善业　　是白有白报
  黑白在欲中　　俱黑说不净

色有中善业是白有白报者。色界善业一向无嗔恚离黑。问无色界业胜非色界。何故不说。答二报故。色界受中阴及生阴。无色界唯有生阴。如是色无色可见不可见有对无对受报。又彼有三业五阴十善业道受报故说。黑白在欲中者。欲界善业杂不善业故。是故说黑白。又一身中二种业可得。亦二种报。是故如是说。非黑即是白。黑异相故。俱黑说不净者。不善业说黑。彼有黑报。彼因秽污。秽污故说黑。及鄙贱可恶故说黑报。唯鄙贱黑非秽污黑。不染污故

  若有思能坏　　彼诸业无余
  此说无阂道　　谓是第四业

若道能灭彼三业。彼道相应思是第四业。此业不染污故。不黑不可乐故。不白不堕界故无报。问何业几思断。答

  说有十二思　　断于黑报业
  四思能断白　　一思二俱离

说有十二思断于黑报业者。黑业十二思断见道四法忍相应思。及离欲界欲八无阂道相应思。四思能断白者。四思断白业。初禅离欲第九无阂道相应思。乃至第四禅离欲亦尔。以善有漏法最后无阂道断故。一思二俱离者。欲界离欲第九无阂道相应思。灭黑业及黑白业问世尊说曲秽浊。此云何。答

  曲者从谄起　　秽从嗔恚生
  欲生谓为浊　　世尊之所说

曲者从谄起者。谄者说曲。于曲相法所起业名为曲。彼曲果故。谄者以不直故名为曲。以谄所阂难出生死难入涅槃。譬如曲木。秽从嗔恚生者。二种秽。秽自身及他身故。嗔恚者名为秽。于秽相法所起业名为秽。彼果故。欲生谓为浊。世尊之所说者。欲者染性故名为浊。若业欲所起名为浊。彼果故果似因说。问几种等起。答

  等起有二种　　因及彼刹那
  如前所回转　　此亦随回转

等起有二种因。及彼刹那者。有二种等起因等起者。我当作所作。彼刹那等起者。若心住作彼业。问此二等起何等为转何等为随转。答转者。谓彼前若彼因等起者名转。后者说随转。彼刹那等起说随转。问六识身何等为转何等为随转。答

  若识修道断　　在意有二种
  五种心说一　　余则说有漏

若识修道断在意有二种者。修道所断意识亦转亦随转以彼俱能起业故。彼亦善不善无记。彼善转即善随转。不善无记亦如是。无记者威仪工巧。彼威仪心转即彼随转。善秽污心现在前去者不然。以速起故。如旋火轮。工巧心亦如是。前已说报生心不起身口业。五种心说一者。五识身说随转受自作故。非转无思惟故。余则说有漏者。见道断心说余。彼是转能为因等起故非随转。不以见道断心等起身口业。以微细故。内向故。若复见道断心等起身口业者。彼业为见道断为修道断为俱道断。若言见道断者。无有色见道断。明无明相违故。若言修道断者。修道断法而见道断心等起者。此则不应。若言俱断者。则有可分。此亦不然。如契经说。邪见人身口业说是见。彼亦说因等起。问何等为净。答

  一切妙行净　　无学身口满
  所谓意满者　　即是无学心

一切妙行净者。若所有妙行一切说净。若身妙行是说身净。如是比。问有漏法有垢。云何说净。答烦恼相违故。引导第一义净故。问云何满。答无学身口满。无学身口妙行说满。所谓意满者即是无学心。无学心说意满。牟尼相故。问以何等故色阴识阴说满非余。答粗细故。心者第一义满。以身口业比知止息增广故。烦恼热不损故。意语不坏故。是故说阿罗汉满非余。问妙行净满何差别。答所作善故说妙行。清净故说净。牟尼故说满。复次爱果故说妙行。离烦恼故说净。离痴故说满。已说业。业果今当说

  相似说依果　　报则不相似
  净及不净果　　是则说为报

依果者。谓善生善。如是比当知说自分因。报果者。谓净不净果如前说。报因与果相似者。谓依果。不相似者。善不善因无记果

  所谓解脱果　　离欲见真说
  以功力所得　　是说功用果

所谓解脱果离欲见真说者。解脱果谓断也。以功力所得是说功用果者。若果以功力所招及断。是说功用果

  种种相诸法　　其果唯一相
  是说增上果　　除前所起法

若多相诸法相似不相似唯一果。谓增上果。谓所作因。除前所起法者。除前生于后生非果。问增上果功用果何差别。答所作事成为功用果。受用为增上果。谓种殖者有二果。受用者有增上果。已总说果。若彼果是业有今当说

  有漏断结业　　五果是有果
  无漏断结道　　彼则有四果

有漏断结业五果是有果者。世俗断结道彼业有五果。彼后相似及增上是依果。彼业报是报果。彼结断是解脱果。彼所招及断是功用果。除自己余一切法是增上果。无漏断结道彼则有四果者。无漏断结道彼业有四果。除报果。余果如前说

  不善业四果　　亦余善有漏
  余无漏有三　　无记业亦然

不善业四果亦余善有漏者。不善业四果。除断结道。诸余善有漏业。谓方便道解脱道胜进道及闻等慧。此诸业亦有四果。除解脱果。余无漏有三无记业亦然者。除断结无漏。诸余无漏业。及无记业有三果。除报果及解脱果

  四二及三果　　三四亦复二
  三二三净等　　是说为业果

善业者。以善法为四果。除报果。以不善为二果。功用及增上果。以无记为三果。除依果及解脱果。不善业者以不善法为三果。除报果解脱果。以无记法为四果。除解脱果。自分因遍因以欲界身见边见无记法为依果。以善为二果。功用及增上果。无记业者以无记法为三果。依果功用果增上果。以善为二果。功用果及增上果。以不善为三果。除报果解脱果

  过去一切四　　中未来亦然
  中于中说二　　未生未生三

过去一切四者。过去业以一切三世法为四果。除解脱果。不堕世故。中未来亦然者。现在业以未来法为四果。如前说。中于中说二者。现在业以现在法为二果。功用果及增上果。未生未生三者。未来业以未来法为三果。报果功用果增上果

  自地自地四　　或以他地二
  若正思惟地　　亦有解脱果

自地自地四者。自地业以自地法为四果。除解脱果。如欲界系以欲界系。乃至非想非非想亦如是。或以他地二者。他地业以他地法为二果。功用果增上果。若无漏业以他地无漏为依果。若正思惟地亦有解脱果者。定地或有解脱果谓无阂道所摄

  皆以一切三　　三二一复五
  二二次第说　　谓是学等业

学业以学为三果。依果功用果增上果。以无学为三果亦如是。以非学非无学为三果。解脱果功用果增上果。无学业以无学为三果。依果功用果增上果。以非学非无学为二果。功用果增上果。以学为一果。增上果。非学非无学业以非学非无学为五果。以学为二果。功用果增上果。以无学为二果亦如是

  谓说三四一　　四三及与二
  四复一亦二　　是说见等业

见道断业以见道断法为三果。依果功用果增上果。以修道断法为四果。除解脱果。以无断法为一果。增上果。修道断业以修道断法为四果。除解脱果。以无断法为三果。解脱果功用果增上果。以见断法为二果。功用果增上果。无断业以无断法为四果。除报果。以见断法为一果。增上果。以修道断法为二果。功用果增上果。已说业有果。身业口业四大造。今当说

  自地若有大　　身口业所依
  无漏随力得　　此即是彼果

自地若有大身口业所依者。若欲界身口业即欲界四大造。色界初禅地身口业即初禅四大造。乃至第四禅亦如是。以堕界故。烦恼合故。无漏随力得此即是彼果者。无漏身口业随所依力得。即彼地四大造。若生欲界无漏初禅正受。乃至第四禅彼身口业即欲界四大造。一切地生亦如是。不堕界故。非烦恼合故。若须陀洹斯陀含阿那含果及向佛辟支佛声闻波罗蜜道法智比智品。依欲界身现在前。彼一切业欲界四大造。若依色界身现在前。彼一切业色界四大造。学生无色界依五地未来戒成就。若先彼地起无漏道。即依彼地过去。若彼得阿罗汉果。彼舍学戒得无学未来依五地戒。问世尊说三障。此云何。答

  无间无救业　　广生诸烦恼
  恶道受恶报　　障阂应当知

三障。业障烦恼障报障。谓障阂圣道及圣道方便故说障。除此三障。余法虽为障。然此三障五因缘易见易知。所谓处趣生果人。彼业障者五无间业。所谓害父害母害阿罗汉坏僧出佛身血。此业报无间必生地狱中。是故说无间。有二因缘故得无间。背恩义及坏福田。彼害父母是背恩无间。余者坏福田无间。罪最大者所谓坏僧。次出佛身血。次害阿罗汉。次害母次害父。彼义杂品当广说。烦恼障者。谓勤及利烦恼。有众生烦恼勤而不利。应作四句。勤而不利者。数行软烦恼。利而不勤者。增上烦恼不数行。亦勤亦利者。数行增上烦恼。不勤不利者。不数行软烦恼。彼软烦恼不利者。此说烦恼障。以依软结便有中依中便增故。若利烦恼不勤者非障。以不数行故。若俱者一切恶。不俱者一切胜。当知善根亦如是。以行烦恼故建立障非成就者。以一切众生等成就烦恼故。随其所应。彼烦恼障者。当知黄门气嘘富兰那等。又复说难陀央掘魔郁鞞罗迦叶。如是比以说力故彼得见谛。舍利弗等非其境界。报障者。恶道处郁单曰无想天处。问此障何者最大恶。答

  所谓烦恼障　　是说最大恶
  无间业为中　　报障则为软

三障中烦恼障最大恶。次业障次报障。以烦恼障能转业障业障转报障故。又说报障最大恶。以一切因时可转果时不可转故。此则不然。彼或有烦恼障成就。或业障或报障或烦恼业障。或烦恼障报障无业障报障俱成就。以因果不俱故。彼业障者三方。烦恼障报障者五趣。问如所说无间业其罪最大。谓坏僧。僧坏有何性。答

  谓不和合性　　当知是僧坏
  不隐没无记　　是不相应行

僧坏者。是不和合性。不隐没无记不相应行阴摄。坏僧罪是妄语。问何等谁成就。答

  坏者则是僧　　罪则坏僧人
  彼受一劫报　　无择地狱中

坏者则是僧罪则坏僧人者。僧成就坏。坏僧人成就罪。彼受一劫报无择地狱中者。坏僧罪无择地狱中受一劫报。若作余恶行种余地狱报。彼或无择。彼后不能坏僧。坏僧后作余恶行。彼一切皆无择地狱果。若多行恶行者所受身。广大而柔软多受众苦。余无间业后不能坏僧者。要族姓端正戒闻才辩。如是之人乃能坏僧。以彼自立为大师故。犯戒者非增上。问云何坏僧。答

  大师及是道　　诸比丘异忍
  破坏和合僧　　所谓见行增

大师及是道诸比丘异忍破坏和合僧者。谓比丘起如是希望。提婆达多是我大师非瞿昙。彼所制五法是道非八正。当知是坏僧。又说受筹见闻俱增。问何等人破僧。答谓见行增上者。见行人坏僧。恶希望故。非爱行人。轻动故。问为在家人坏僧为出家。答比丘受具足比丘坏僧非在家非沙弥非比丘尼。若彼心住坏僧。即彼心是果。六识身一一现在前。坏僧觉亦如是。问何处坏僧为几人。答

  三方极少八　　是则羯磨坏
  阎浮提至九　　是则法轮坏

三方极少八是则羯磨坏者。三天下羯磨僧坏。极少者至八。以四人名僧非三故。若于一住处界内。二部僧各别作布萨羯磨。当知是僧坏。问何处坏法轮为几人。答阎浮提至九是则法轮坏。阎浮提法轮坏非余处。以此有道则有异道。若此有大师则有异师。极少至九人。乃至二部各别。有一人僧所同者教僧者僧随顺者教无惭无愧部。谓提婆达也。问为坏圣僧为凡夫僧。答凡夫坏非圣人。以正定聚故。不坏净故。又说得忍凡夫亦不坏。已入决定圣僧世尊不坏眷属故。问住何分僧不坏。答

  不结界前后　　牟尼已涅槃
  息肉未起时　　及无第一双
  于此六时中　　则无坏法轮

有六时僧不坏。谓不结界。结界因缘前已说。亦非前亦非后。以此二分中僧一味故。亦非大师般涅槃后。无异师故。亦非未起恶戒恶见息肉。亦非未建立第一双。以僧坏不经一宿别住第一双还和合故。或有欲令七因缘不坏。谓大师在众彼无威光故。非一切诸佛悉有坏僧由行故。问此五无间业何等最大恶。答

  妄语破坏僧　　于诸业最恶
  第一有中思　　是说最大果

妄语破坏僧于诸业最恶者。坏僧妄语是为最恶。以转法身故。法者佛所重。以彼广方便转故。坏僧者恼乱大众故。若僧坏未超升离生者。不超升离生亦无得果亦无坐禅学问思惟业生。大千世界法轮不转。若僧还和合者未超升离生者。超升离生及得果。离欲漏尽坐禅学问思惟业生。大千世界法轮复转。问此说妄语最大罪。又余处说。意业及邪见是诸大罪有何差别。答五无间罪中妄语为最大。三业中意业为最大。五见中邪见为最大。复次报广故妄语最大罪。恼大众故意业最大罪。断善根故邪见最大罪。问何等业最大果。答第一有中思是说最大果。以彼思于非想非非想处八万劫寿以报果故说。解脱果者金刚三昧相应思最大。以彼思永断一切烦恼得果故。又说一思种八万劫。然后多思成满。如画师先以一色作摸后布众彩。又说一时正受一行一缘。众多思现在前。于中或有思受十千劫寿。有三十千劫四十千劫寿者。此说大劫数

杂阿毗昙心论卷第三杂阿毗昙心论卷第四

        尊者法救造

        宋天竺三藏僧伽跋摩等译

    使品第四

已广说业。彼业伴烦恼受种种生。非离烦恼。烦恼今当说

  一切有根本　　业侣生百苦
  谓彼有七使　　牟尼说当思

谓欲有色有无色有。此有贪欲等七使为种。以烦恼故业。业故受生。彼烦恼业伴生百苦。不离于业。烦恼转时作十事。所谓根坚固分相续起于田生依果种业有执自具愚于缘引识流越善业急缚义不令作越界方便。彼智者当知此义。如此七使为九十八。今当说

  界行种分别　　说有九十八
  十种修道灭　　余则见道断

此七使界行种分别为九十八使。彼七使中贪欲使于九十八使中以种分别为五。恚使亦如是。有爱使界种分别为十。慢使界种分别为十五。无明使亦如是。见使行分别为五。行种分别为十二。界行种分别为三十六。疑使界种分别为十二。是为七使分别为九十八。问此九十八使几见断几修断。答十种修道灭。余则见道断。爱慢无明界分别为九。嗔恚为十。余八十八使见道断。彼于谛暂见则断。故曰见道。若数习道而断。故曰修道。若见道所断。是说见断。若修道所断。是说修断。如是不觉心觉心九种一种九种九种。破石方便断。藕丝方便。未见尔炎观。已见尔炎观。彼断时修四行道。是见道断。彼断时修十六行道。是修道断。对无事对有事亦如是。已说使对治差别。谓种差别。今当说

  使有二十八　　是障于见苦
  彼当见苦时　　永尽无有余

见断八十八使中二十八障。见苦故见苦断。断义此品后当说

  见集断十九　　当知灭亦然
  增三见道断　　十说修道灭

见集断十九使障。见集故见集断。当知灭亦然者。见灭断十九使亦如是。增三见道断者。二十二使见道断。十说修道灭者。十使修道断如前说。已说使种差别。界差别今当说

  第一烦恼种　　在欲当知十
  二种种有七　　余八见道断

第一烦恼种在欲当知十者。如前说。初见苦断烦恼种。彼十使欲界系。二种种有七者。见集见灭断各七使欲界系。余八见道断者。见道断八使欲界系

  欲界应当知　　四是修道断
  谓余上二界　　当知同可得

欲界应当知四是修道断者。若修道断烦恼四是欲界系。如是说欲界三十六使。谓余上二界者。余六十二使在色无色界。问几色界系几无色界系。答当知同可得。彼三十一使色界系。三十一使无色界系。已说界种差别。使自相今当说

  所谓有身见　　受边见邪见
  二取应当知　　是五说名见

诸行从缘起而无知乱心。愚夫于五受阴若自若共起我我所审尔计着。是名有身见。于诸行受断常审尔计着。是名受边见。无施等审尔计着。是名邪见。于有漏法受第一审尔计着。取见等除等故是名取见见。于有漏行受净等审尔计着。取戒等除等故是名取戒见。此五烦恼决断故说见。此一邪见邪决断故。以行差别故说五见(二取梵音中亦可言摩亦可言此并有窃取义选择义虽实与理乖而意存求宗故言选择所受非道故言窃取)

  贪欲疑嗔恚　　慢痴说非见
  境界差别转　　建立种种名

贪欲疑嗔恚慢痴说非见者。于彼境界乐著名贪欲。于谛。或名为疑。众生非众生数忿怒名嗔恚。族姓色力富势伎术等方他卑等上起意自高名为慢。于谛愚名为痴。此五烦恼非慧性故非见。是为十使。境界差别转建立种种名者。此十使境界差别转故建立种种名。此诸使若障见苦说见苦断。如是障见集灭道说见道断

  下苦说一切　　二行离三见
  道除于二见　　上界不行恚

下苦说一切者。下苦谓欲界苦。彼一切十使与见苦相违故见苦断。二行离三见者。除身见边见戒取。余七使与见集灭相违故见集灭断。道除于二见者。除身见边见余八使与见道相违故见道断。问何故身见边见见苦断非余耶。答苦处转故。果处转故。见彼则断不远随至根。此见不随根故初见谛则断。问何故戒取见苦见道断非集灭耶。答彼处起故异学于彼二谛相违非集灭。彼垢处故于集谛欲。洗浴处故于灭谛欲。若内法者见苦断。外法者见道断。问疑使何故不修道断。答于事不见故疑。于事见故断。彼方起见故无有见修道断。上界不行恚者。色无色界除恚余如欲界说。彼色界见苦断九。见集灭断六。见道断七。修道断三。无色界亦如是。问上二界何故无恚耶。答彼无有无惭无愧悭嫉忧苦性故。寂止养身故。得慈心故。无九恼性故。离不饶益相故。离一向不善故。二果故是嗔恚。已说使界建立。一切遍今当说

  普遍在苦因　　疑见及无明
  是使一切种　　谓在于一地

见苦集所断疑见。彼相应无明及不共。此十一使当知地地一切遍。广境界故。自地如是缘使五种。上不使下。非境界故。离欲故。断知故。下不使上。劣非所使事故。依果不可得故。当知见谛所断是一切秽污法因。彼应如是。何以故。圣人不起无有爱嗔恚缠慢种现在前者。应说转非分故。无有爱者断见所长养随断见起。彼断见灭故。嗔缠者邪见所长养随邪见起。彼邪见灭故。慢种者身见所长养随身见起。彼身见灭故。已说自地一切遍他地今当说

  他地为境界　　除二见如前
  地地九遍使　　非想则不然

前说十一一切遍。除身见边见余九一切遍。从欲界乃至无所有处。是他地一切遍。彼欲界见苦断邪见。若自若共谤色无色界果。见取受第一。戒取受净。起疑或无明不了。欲界见集断邪见。若自若共谤色无色界阴因。见取于因受第一。疑或无明不了。如是初禅见苦集所断邪见。若自若共谤七地苦集。如是广说。乃至无所有处见苦集所断邪见。若自若共谤一地苦集。如是广说。非想非非想处地无他地一切遍。无上地故。界亦如是说。无色界无他界一切地遍。无上界故。问一切遍有何义。答一切有漏种普缘义是一切遍义。缘力持义是一切遍义。一切起一切众生一切事故名一切遍。无有凡夫于有漏法本来不取我等行。问何故身见边见说自地一切遍。非他地耶。答见现境界故。此见见现境界。非下地生见上地。虽上地生见下地。前已说上地使不缘下地爱恚慢自相起故。不缘他种。况缘他地。未离欲者虽乐上地。是欲非贪

  若缘苦邪见　　是违于见苦
  一地缘九地　　缘集亦复然

若缘苦邪见是违于见苦。一地缘九地者。欲界见苦断邪见缘九地苦。从欲界乃至非想非非想处非一时。谓欲界非色界。若异者则断知坏及界坏。初禅缘八地。二禅七地。乃至非想非非想缘非想非非想。缘集亦复然者。如说见苦断邪见。见集断邪见亦如是。问云何唯使是一切遍。复余法耶。答

  若一切遍使　　同一果诸行
  当知一切遍　　非为诸得等

若一切遍使相应受等法及共有生等。彼亦一切遍。同一果故。和合故。相随行故。前后无不合故。是名一切遍。一果等非性故。得非一切遍一切遍使。三事故。五种因缘五种使五种。彼相应法五种因缘五种不使五种。非使性故。彼共有法五种因。不缘五种不使五种。是故说。若一切遍使一切遍因作四句。一切遍使非一切遍因者。未来一切遍使也。一切遍因非一切遍使者。过去现在一切遍使相应共有法也。一切遍使一切遍因者。过去现在一切遍使也。非一切遍使非一切遍因者。除上说

  邪见疑相应　　及不共无明
  灭道之所断　　当知无漏缘

见灭见道断邪见疑相应无明及不共无明。此六使当知界界无漏缘。彼见灭断邪见谤于灭。疑惑无明不了于灭处转。如是见道断于道处转。问见灭断邪见为见灭谤耶不见耶。若见者。不应谤以见故。若不见者。不应无漏缘。答见谤。但邪见如有处人想谤处。彼亦如是。问如欲界见苦断邪见缘九地苦乃至非想非非想处缘一地。见灭断亦然耶。答不然。问云何。答

  若灭境界见　　自地诸行灭
  是境界非余　　灭尽非因故

若灭境界见自地诸行灭是境界非余者。欲界见灭断邪见。缘欲界诸行灭。非余初禅。初禅乃至非想非非想处亦如是。问何故非他地。答灭尽非因故。灭尽者无为故非展转因。非展转因故自地诸行灭为邪见境界故非余。谓善知亦如是者不然何以故。转生相违故。善智者行谛与转生相违。是故彼转异秽污亦异。以有漏地因果断故。谓见苦断邪见亦自地苦为境界者不然。展转相牵故。若生若依若立若因。展转因故。问见道断邪见云何转。如见苦集断耶。如见灭断耶。答异转。问云何。答

  若道境界见　　彼见则缘道
  展转相因故　　六地及九地

道者展转相因故。欲界见道断邪见缘六地。法智品。色界无色界八地。见道断邪见缘九地未知智品唯法智。未知智展转相因。若彼法欲界爱所润见我我所受。彼诸对治应欲界见道断邪见缘。非此烦恼他地缘。如此论未知智亦如是说。问灭道法智非色无色界法对治耶。是故彼智应为色无色界见道断邪见境界。若非境界者亦不应说。若法色无色界爱所润见我我所受。彼诸对治应色无色界见道断邪见缘。答俱不全故无过。非全法智为彼界对治。虽灭道法智非苦集法智。亦非灭道法智全为色无色界对治。唯修道法智对治非见道。彼初非分故。是故汝所说不然。譬如乐根意行(忧喜舍在意地因六识故立十八意行欲界乐根不在意地故不立意行)。问何故贪恚慢见取戒取非无漏缘耶。答

  贪缘不应责　　不为不饶益
  寂静第一净　　彼非无漏缘

智者见贪过。若无漏缘者不应见过。若不见过亦不应断。若欲涅槃者。是善法欲则非贪爱。不饶益故起嗔。彼非不饶益。不寂静故起慢。而彼寂静。见取者第一行转无漏法第一。若彼无漏缘者。应是正见非烦恼。不颠倒故。戒取亦如是。问诸使何所使。答

  欲界一切种　　一切遍使使
  缘缚于自地　　上地亦复然

欲界一切种一切遍使使缘缚于自地者。欲界一切遍使缘使欲界五种。问色无色界云何。答上地亦复然。如是色无色界自地一切遍使缘使自地五种

  谓彼诸余使　　当知缘自种
  缘使自境界　　一切所依品

谓彼诸余使当知缘自种缘使自境界者。余不一切遍及一切遍使。自相境界故。缘使自种法一切所依品者。若一切遍及不一切遍。若有漏缘若无漏缘。彼各使自品相应法

  若使无漏缘　　他地缘烦恼
  自品相应使　　境界解脱故

若使无漏缘他地缘烦恼自品相应使者。若使无漏缘及他地缘自品相应使非缘使。何以故。境界解脱故。此使境界解脱。以无漏法解脱一切烦恼。上地诸法解脱下地烦恼故。问一一使几使使。答

  彼使身见者　　见苦所断种
  见集一切遍　　见苦余亦然

彼使身见者见苦所断种。见集一切遍者。谓身见为见。苦断。一切使所使。以自种故。及见集断一切遍所使。广境界故。问见苦断余使云何。答见苦余亦然。如说身见。当知见苦断余使亦如是

  如苦集亦尔　　灭道有漏缘
  尽使于自种　　修道断亦然

如苦集亦尔者。如说见苦断。见集断亦如是。灭道有漏缘尽使于自种修道断亦然者。如是见灭见道。修道断亦如是。差别者。见灭见道断使自种有漏缘。使尽使自种及一切遍使使。亦无漏缘相应使使。问已知使诸使使所。使诸使使。谁为缘使使。非相应使使。乃至谁非缘使使。亦非相应使使。答

  见苦使自品　　缘使及相应
  见相应无明　　缘使余亦然

彼身见身见相应无明二种使使缘及相应。余见苦断使及见集断一切遍缘使非相应使。不同品故。余使亦非缘使亦非相应使。身见相应非使。法身见及相应无明相应使亦缘使。余见苦断使及见集断一切遍使缘使非相应使。余使亦非相应亦非缘。如身见如是。边见见苦断邪见见取戒取疑贪恚慢亦如是。见苦断无明于见苦断无明及见集断一切遍缘使非相应。余见苦断使亦缘亦相应使。余亦非缘亦非相应使。如见苦断见集断亦如是。见灭见道断有漏缘及修道断亦如是。差别者。若使相应可得。即彼使相应使及缘使

  若灭境界见　　彼俱生无明
  诸一切遍使　　有漏缘相违

若灭境界见彼俱生无明者。见灭断邪见彼相应无明相应使。彼无明邪见相应使。彼相应法二俱相应使。问余使复云何。答诸一切遍使有漏缘相违。若一切遍及见灭断种有漏缘使缘使。余非相应使亦非缘使。以是义故当知余无漏缘使亦如是。不共无明差别者。彼无相应使使

  彼使与微入　　随入亦随逐
  是从三事起　　当知不断等

彼使与微入随入亦随逐者。彼使者作也。微入者性也。随入者相应也。随逐者得也。复次使者如乳婴儿。微入者微细行也。随入者如麻中油。随逐者如空行影水行随。问云何起彼使。答是从三事起当知不断等。三事故起贪使。因力境界力方便力。彼贪欲使不断不知是因力。贪欲缠所缘是境界力。彼不正思惟是方便力。此说烦恼具足因缘不必要具三事。若必具三事起者不应退。当知一切使亦如是。问诸使为不善为无记耶。答

  身见受边见　　彼相应无明
  欲界中无记　　色无色一切

身见受边见彼相应无明欲界中无记者。欲界身见边见及相应无明是无记。何以故。于施戒修不相违故。若计我者行施令我后世得乐。亦持戒令我生天。亦修道令我得解脱。断灭见者顺解脱。复次此见于自事中愚故起。不为逼迫他起。彼计我者眼见色言。我见非眼见。不以我见色逼迫他。是故非不善。余欲界烦恼是不善。色无色一切者。色界无色界使一切无记。正受坏故。无苦受性故。不善者苦受报。彼色无色界无。非色无色界有欲界报。果报断地故。问何使何处转。答

  贪欲嗔恚慢　　过去或缘起
  未来说一切　　余二世尽缚

贪欲嗔恚慢过去或缘起者。过去贪恚慢是自相烦恼故。不能于一切有漏法起。贪者不能不见不闻不思惟境界起。由方便故炽然。或时有人于眼起爱非余身分。恚慢亦如是。未来说一切者。未来贪恚慢缘缚三世。一切有漏法以三世缘故。余二世尽缚者。见疑无明是余。彼共相起故。若过去未来缚三世有漏法。现在使不定故不说。若有者若自相烦恼现在前。即彼现在未来缚过去。若于彼起已灭不断。问非为过去使断。即彼未来断耶。何故说过去起已灭不断耶。答不以等种故说。有时增上中种先起。彼若过去断即彼未来断。于彼事中未来软烦恼缚。是故无过。若共相烦恼现在前缚三世一切有漏法。此则总说。若五识身烦恼过去缚过去。现在缚现在。未来若生法缚未来。若不生法缚三世事。若意地者过去未来现在尽缚三世事。问云何缚。答若眼识身烦恼缚所缚缘色。彼相应法相应缚。彼相应法意入及法入。如是乃至身识身烦恼缚所缘触。彼相应法相应缚。若意地烦恼缚所缘十二入。彼相应法相应缚。彼相应法意入及法入。彼婆蹉部说。人成结成事成。阿毗昙者说。人不成结成事成。譬喻者说。结成人不成事不成。境界不定有欲无欲故。有时于彼起欲起恚起慢起嫉起厌起悲起舍。已说使世建立。次第今当说

  烦恼次第起　　自地于自地
  上地亦生下　　当知随次生

烦恼次第起自地于自地者。自地一切使于自地一切。烦恼次第转一一次第生一切。上地亦生下当知随次生者。上地烦恼次第生下地烦恼。彼染污心命终起下地中阴生阴。彼非想非非想地次第生八地。乃至梵世次第生欲界。问此诸烦恼世尊说扼流取受漏缚。彼云何。答

  有扼漂流取　　泄漏与结缚
  以是义故说　　扼流取漏缚

苦所扼故说扼。故彼四种。欲扼有扼见扼无明扼。问何故五见说见扼。一无明立一扼耶。答等担故。问何故色无色界结除见无明。余立一有扼耶。答等正定地故。及隐没无记故。漂众生故说流。彼亦四种。如扼说。取有故说取。极执故。彼亦四种。欲取见取戒取说我取。问何故无明说扼流。而不说取耶。答非捷疾行故。执受义是取义。捷疾行。彼无明非捷疾行。以愚故不说取。问何故四见说见取。一取说戒取耶。答等担故。谓彼能炽然业及违道故。内外可得故。外道不食等苦作道想。内道粪扫衣等作道想。问何故色无色界结说我取。非欲界耶。答内处起故。色无色界结内向起自己缘故。欲界结外向起故。是故说欲取。一切入处漏故。心漏连注故说漏。彼三种。欲漏有漏无明漏。问何故说见流见扼。不说见漏耶。答住义是漏义。此见捷疾于住不顺。是故余不捷疾。烦恼杂已说。漏漂义是流义。见于漂顺。是故建立流苦。系义是缚义。问扼流取漏缚有何性。答

  数有二十九　　亦说二十八
  三十六十五　　欲等扼流性

彼欲扼性二十九。贪五恚五慢五疑四十缠。缠此品后当说。有扼二十八。爱十慢十疑八。见扼三十六。五见界行种分别三十六。无明扼界种分别有十五。流亦如是

  谓前三十四　　次种说三十
  第三者说六　　第四三十八

欲取性三十四。贪五恚五慢五无明五疑四十缠。见取三十。除戒取。戒取性六。戒取界种分别有六。说我取性三十八。爱十慢十无明十疑八。色无色界有二缠。睡及掉缠。非界种分别。前已说故。此中不说

  说彼欲漏性　　当知四十一
  有漏五十二　　无明漏十五

欲漏性四十一。贪五恚五慢五疑四见十二十缠。有漏性五十二。爱十慢十疑八见二十四。无明漏性十五。此百八烦恼。扼义故说扼漂义故说流。取义故说取。为漏义故说漏。问诸烦恼种云何起。答

  无知故犹预　　犹预故邪见
  因此邪见故　　转生诸身见

初以无知故苦不欲。乃至道不欲是名无明。无明故犹预。苦非苦耶。乃至道非道耶。是无明转生疑。疑故求决定。若得正方便生正决定。则有苦集灭道。若邪方便生邪决定。则无苦集灭道。是疑转生邪见。若此非苦者则是我。是邪见转生身见

  从是起边见　　戒取戒想取
  于彼决定已　　次第生见取

彼于我见变坏便见断。若见相似相续便见常。是身见转生边见。若见一边净。是边见转生戒取。若净者是为第一。是戒取转生见取

  自见则生欲　　他见则起恚
  自见举名慢　　从使转生缠

彼自见生染。他见起恚。自见举慢。是从见起贪恚慢从使生上烦恼缠。问何者是。答

  无惭与无愧　　睡悔悭嫉掉
  眠忿及与覆　　是上烦恼缠

十缠。所谓无惭无愧睡悔悭嫉掉眠忿覆。此相行品已说。谓此是使依(依者梵音腻山地腻山地义言津液谓缠是使之津液如苏蜜瓶津液流出也)。问何缠何使依。答

  无愧睡与眠　　此三无明依
  掉悭及无惭　　是从贪欲生

无愧睡与眠此三无明依者。无愧睡眠当知无明依。问若彼缠是无明依者。以无明相应耶。答若无明依即无明相应。或无明相应非无明依者。余七缠是。掉悭及无惭是从贪欲生者。掉悭无惭缠是贪欲依。问若缠是贪欲依。即彼相应耶。答作四句依不相应者。悭缠是。相应不依者。无愧睡眠是。亦依亦相应者。掉及无惭是。非依非相应者除上说

  覆缠二使依　　悔则因犹豫
  忿嫉嗔恚依　　明智之所说

覆缠二使依者。或说覆缠是爱依。以爱力故覆藏。有说。是无明依。以无知力故覆藏。悔则因犹豫者。悔缠是疑依忿嫉嗔恚依。明智之所说者。忿缠嫉缠是嗔恚依。问此烦恼垢有六。何依。答(急缚是缠义轻系是垢义是十缠六垢差别义也)

  所谓烦恼垢　　害恨嗔恚依
  诳高依贪欲　　是义应当知

所谓烦恼垢害恨嗔恚依者。害及恨是嗔恚依。诳高依贪欲是义应当知者。诳高垢是贪欲依

  所谓五邪见　　谄依由是生
  说依见取果　　是恼应当知

所谓五邪见谄依由是生者。五见起谄依。健疾故。说依见取果是恼应当知者。恼垢是见取依。问何缠与何烦恼相应。答

  一切烦恼俱　　说睡及与掉
  无惭不善俱　　无愧亦复然

一切烦恼俱说睡及与掉者。此二缠一切烦恼相应。一切秽污心不寂静故当知掉。烦恼现在前心无所堪。故当知睡。虽掉掉不相应及睡睡不相应。自性故以少故不说。当知使即烦恼。彼缠一切烦恼俱故。五种六识身三界不善及无记。无惭不善俱无愧亦复然者。此二缠一切不善使相应。一切不善心现在前。坏恭敬不畏罪。是故彼缠说五种六识身。不善故欲界系

  悔在于意苦　　修道之所断
  眠唯在欲意　　余各自建立

悔在于意苦者。悔在意地。捷疾故。以愁戚起故。忧相应故。苦受所摄故在欲界。问此何断。答修道之所断。善行恶行中生故修道断。眠唯在欲意者。眠在欲界意地。眠时一切烦恼共行。是故欲界一切烦恼相应。余各自建立者。余缠上烦恼各自建立。所谓忿覆悭嫉不与余使相应。除无明当知悔亦自建立。余烦恼行非性故。问何故悭嫉立九结中。非余耶。答

  所谓悭与嫉　　独立离于二
  是故此二缠　　立于九结中

悭嫉二缠自力起故。独立一向不善故离于二。以是故立于九结中。睡掉者一切烦恼俱故不独立。不善及无记故不离二。眠亦与余使相应故不独立。善不善无记故不离二。无惭无愧虽离二而不独立。悔虽独立而不离二。善不善故。忿及覆虽独立亦离二。或有欲令是使性彼记有八缠悔眠。若善者当知非缠。缠一向秽污故。问爱何故立一结而二使或三或六耶。答得一缚相故立一结。正定地不定地故说二使。界别故说三。依别故说六。问何故三见立见结。二见立他取结耶。答名等故。事等故。身见边见邪见是女。名十八使自性。是故立一结。他取结是男。名彼亦十八使自性。是故立一结。是故如是说。若见相应法爱结系。非见结亦非不见使使。若集智生灭智未生见灭见道。断(见取戒取)相应法爱结系。以爱结有漏缘故非见结。以彼一切遍见结断故。虽自种见结不断。而不缘彼无漏缘故。非相应异品故。非见使不使。以五见为见使。三见为见结故。已说烦恼自性。根相应今当说

  诸使在三界　　尽舍根相应
  随地诸根使　　相应至色有

诸使在三界尽舍根相应者。三界一切使舍根相应。何以故。随顺一切。烦恼故。与欣戚及俱烦恼转行故。以一切烦恼皆处中而息故。若异者无离烦恼。是故舍根得五种六识身三界。随地诸根使相应至色有者。谓喜根乐根乃至梵世。彼诸使喜根乐根相应。光音天亦有喜根。彼地使喜根相应。遍净天有乐根。彼地使乐根相应。果实天有一舍根。彼诸使舍根相应。非余(爱等是欣烦恼恚痴是戚烦恼邪见是俱烦恼舍根悉与彼相应同共一缘行也)

  邪见及无明　　欲界中乐苦
  嗔恚疑唯苦　　谓余一向乐

邪见及无明欲界中乐苦者。邪见起恶业则喜。净业则忧。无明一切根相应。嗔恚疑唯苦者。欲界疑不决定故不喜。是故苦受相应。初禅二禅无余根性。与喜根相应。欲界喜根粗故。众生不应起而起。如贫贱人常戏笑随彼事不应起而起。欲界疑微细故不与喜根相应。嗔恚忧戚行起故苦受相应。谓余一向乐者。欲界余烦恼乐行起故乐受相应

  谓勋二相应　　见断唯应意
  欲界诸烦恼　　说诸根相应

谓勋二相应者修道断烦恼名为勋。身受相应及心受若六识身者。彼五根相应如所起随其义说彼苦根欲界乐根。五识身喜根忧根意地舍根。六识身一切身受修道断意俱有见断。唯应意者。见道断烦恼在意地。意识诸根相应非随事起故。欲界诸烦恼说诸根相应者。此说欲界诸烦恼。上地随地根相应亦如是说。问诸缠何根相应。答睡掉无惭无愧五根相应。眠三根。除乐根苦根。忿悔嫉恨害恼忧根。及舍根覆诳谄三根。除乐根苦根悭喜根及舍根高三根。除苦根忧根。以高意地故。三界喜行转故。问诸使几识相应。答

  贪欲嗔恚痴　　当知六识俱
  谓欲随道断　　上地随所得

贪欲嗔恚痴当知六识俱谓欲修道断者。欲界修道断欲恚无明六识相应。上地随所得者。色无色界无嗔恚。爱无明随有识身即彼相应。谓梵世四识身可得。即彼地二使四识相应

  无色界一切　　非事慢意地
  当知彼七使　　自性果及人

无色界一切者。谓使无色界见道断及修道断。非事慢意地者。欲色界见道断及慢。此诸使在意地。虽上三禅亦意地。以界分别故不说地。问云何知使。答当知彼七使自性果及人。三事故知使。谓自性果及人。彼自性者。贪欲使如兴渠勋。嗔恚使如苦种子。有爱使如婴儿衣。慢使如憍人。无明使如愚痴人。见使如迷失道。疑使如惑二道。果者。贪欲使修习多修习生鸳鸯雀等众鸟中。嗔恚使修习多修习生虺蛇中。有爱使修习多修习生色无色界。慢使修习多修习生卑贱中。无明使生闇冥中。谓世界中间。见使生邪见家。疑使生边地。及人者。贪欲使当观如难陀等。嗔恚使如央掘魔等。有爱使如阿私多阿罗兰郁头蓝子等。慢使如慢高儿等。无明使如郁鞞罗迦叶等。见使如须那刹多罗等。疑使如摩诃迦叶等。以此三事知使者则能远离。如知崄道。满烦恼为使。不满烦恼为缠。是故缠不立使。烦恼垢亦如是。以是五事具故名满烦恼五事者。谓诸结缚使上烦恼缠。若一一不具名不满烦恼。已说烦恼建立。断烦恼今当说

  一时断烦恼　　正智之所说
  如此诸解脱　　亦非一时得

一时断烦恼正智之所说者。此诸烦恼顿断不渐渐。谓自分对治起时。而苦法忍起。欲界见苦所断十使顿断。苦未知忍。色无色界十八使顿断。如是乃至道未知忍。十四使顿断。修道渐渐圣道起。上上四使顿断。乃至上上圣道起。渐渐四使顿断。如是一切地。问见道一时断应尔。以一种道断九种结故。修道断者。以九种道断九种结。云何一时断。答修道断者。若此种对治起。即此种顿断不渐渐。初已断故。如此诸解脱亦非一时得者。彼诸解脱数数得。谓欲界见苦谛断。及色无色界见苦集灭断。六时得。谓自分对治时。及四沙门果时。及增益根时。色无色界见道断五时得。除自分对治。以道未知智初得故。欲界修道断五种五时。除须陀洹果。三种四时。软软

种三时。色无色界七地及非想非非想地八种三时。除前三沙门果。软软种二时。阿罗汉果及增益根。问诸烦恼云何断。答

  谓彼缘中觉　　及说彼缘断
  亦说得对治　　又复彼缘灭

四事断烦恼。谓知缘。缘断。得对治。彼缘灭。知缘者。见苦见集断自界缘及无漏缘。缘断者。见灭见道断有漏缘。得对治者。修道断。彼缘灭者。他界缘。复次五事断烦恼。谓因永灭。得断。转依。知缘。得对治。已说断烦恼因缘建立。断知今当说

  欲界中解脱　　圣说四断知
  离色无色界　　当知五断知

九断知欲界烦恼断立。四断知色无色界烦恼断立。五断知虽智知而断。是智果故说断知。如业果亦名业

  苦集烦恼尽　　总说一断知
  灭道断各一　　如欲上亦三

彼欲界见苦集断烦恼尽立一断知。见灭断二。见道断三。如欲界。色无色界见苦见集断亦立一。见灭断二。见道断三。此品后广说

  修道断当知　　界界断说一
  三断是智果　　余则说忍果

欲界修道断一断知。色界断二。无色界断。此三当知是智果。问以何等故色无色界见道断立一断知。修道断立二耶。答见道断同对治故。修道断不同故。问余断知何果。答余则说忍果。见道断尽六断知。说忍果。忍对治故。见道断尽若言忍果非断知者不然。谓忍智眷属故。与智同一果故。是故见道修道断俱得名智果。已说断知是智果。谓若地若道。若法智未知智。若彼同品果今当说

  初地说一切　　禅五亦复八
  无色说一果　　眷属果亦然

初地说一切者。未至依具九断知果。彼三界对治故。禅五亦复八者。阿毗昙者说。根本禅五断知果。谓色无色界烦恼断。如前说。尊者瞿沙说。有八除五下分结尽断知。是未至依果故。彼欲令欲界见谛断尽。是禅果禅中间如禅说。无色说一果者。三无色定说一断知果。一切结尽是。眷属果亦然者。如色空处眷属亦说一断知果。色爱尽是。虽四地修道断尽建立断知。但第四禅软软种尽得断知名。是故说是空处眷属果

  世俗道果二　　圣九法智三
  未知智说二　　彼品果六五

世俗道果二者。五下分结尽及色爱尽。是世俗道果。谓圣人以世俗道断二界结故。圣九者。一切九断知是圣道果。以圣道对治一切烦恼故。法智三者。三断知是法智果。五下分结尽色爱尽及一切结尽。是以修道法智断三界结故。未知智说(二者二断)。知是未知智果。色爱尽及一切结尽。是以色无色界修道果故。彼品果六五者。法智品果有六断知。欲界见道断三。及前说法智果三。未知智品五断知果色无色见道断三。及前说未知智果二。问谁成就几断知。答

  或有诸圣人　　未成就断知
  或成一二三　　四五及与六

见道五心顷不成就断知。集法智集未智忍一。集未知智灭法忍二。灭法智灭未知忍三。灭未知智道法忍四。道法智道未知忍五。须陀洹六。向斯陀含果者。若倍欲尽超升离生如前说。若次第向成就六。斯陀含果亦六。向阿那含果。若欲爱尽超升离生如前说。若次第向成就六得阿那含果一。下分结尽是向阿罗汉果者。若色爱未尽一。色爱尽二阿罗汉果一。一切结尽断知是。问谁舍几断知。答

  舍一二五六　　如舍得亦然
  得果及度界　　二处断知集

舍一二五六者。阿罗汉果退舍一断知。色爱尽阿那含色界缠退舍一。若色爱未尽欲界缠退舍一。色爱尽阿那含果欲界缠退舍二。得阿罗汉果舍二。若欲爱尽超越阿那含舍五。次第舍六。问谁得几断知。答如舍得亦然。或有得一断知。见道第六第八第十第十二第十四。乃至道未知智心一一得一次第。阿那含果得一。五下分结尽是圣人色爱尽一。色爱尽是阿罗汉果一。一切结尽是得二者。阿罗汉无色界缠退得六者。若阿罗汉若阿那含欲界缠退无有得五者。是故经中无。问此断知何处集。答得果及度界二处断知集。此断知二处集。阿那含果阿罗汉果。以彼处得果。即彼度界。是故下分结上分结断时得道未知智生。六种断虽得果非度界。色爱尽虽度界非得果。余非度界亦非得果。是故此诸断知处不名为集。已说建立自性果成就舍得集。若因缘彼断得断知名。今当说

  谓彼二因灭　　离系及度界
  得于无漏得　　及缺第一有

以四因缘故。或五彼断得断知名见道。四因缘。谓俱因灭。俱系离。得无漏解脱得。及缺第一有。彼苦法忍苦法智苦未知忍生非俱因灭。虽见苦断因灭非见集断。以是义故非俱系离。虽得无漏解脱得。未缺第一有故。如是一因缘合。三因缘不合。苦未知智集法忍生。虽得无漏解脱得及缺第一有。余二因不具。是故此处不立断知。集法智生俱因灭。谓先见苦断因灭。今见集断因灭。当知亦是俱系离得无漏解脱得。苦未知智生时。已缺第一有。是故此处建立断知。集未知智生一切因缘具。是故此处建立断知。如是灭法智第三。灭未知智第四。道法智第五。道未知智第六。此说见道也。修道断五因缘。前四及界永断是为五。欲界修道断烦恼九种展转相缚。乃至非相非非想地亦如是。彼欲界一种断。乃至八种具二因缘。谓得无漏解脱得及缺第一有。三因缘不具。第九种灭具五因缘。是故此处建立断知。初禅一种断。乃至八种具二因缘非余。如前说。第九种断具四因缘。一因缘不具。谓度界。第二第三禅及三无色亦如是。第四禅地乃至八种断具二因缘非余。第九种断具五因缘。是故此处建立断知。非想非非想亦如是。以是义故凡夫离欲不立断知。以彼不得无漏解脱得亦不缺第一有故。已说断知。三种境界五种爱生今当说

  好境俱不俱　　彼二种爱生
  恶境二亦然　　一则谓为舍

好境俱不俱彼二种爱生者。好名可爱乐境界。若得彼境界不离爱生。云何令我于此事不离。若未得者想得爱生。云何当得。恶境二亦然者。恶名不可爱乐境界。彼亦二种。爱生俱者离想爱生。不俱者不得想爱生。一则谓为舍者。舍名境界非可爱乐非不可爱乐。一向愚爱生。问彼使为心相应为不相应。此何所疑。二师异说故。毗婆阇婆提。欲令不相应。育多婆提。欲令相应。于此有疑。答相应何者

  谓使烦恼心　　障碍不违净
  妙善心可得　　非不相应使

使有二事故恼心缘及相应。若使心不相应者。不应于缘中恼心。以彼无缘故。一切心不相应法。无缘亦不相应。非有相应法故。心为使所恼。如所说。贪欲恼心故心不解脱。以此说故知使心相应。障碍者。若使心不相应者。道生时不应障碍。不违心相续故。以障碍故非不相应。不违净者。若使心不相应。不应与善心相违。与善心一时俱生。不应作过。作过故是故非不相应。复次善妙心可得。功德相违故名使。若使心不相应者。彼常行故。善心应无生处。善心生故当知非不相应。复次说着相等故。云何贪使。谓染着相。云何嗔使。谓心法恼。云何慢使。谓心法举。如是比。是故使心非不相应。若缠善心相违非使者不然。何以故。得使相故。贪欲缠故名贪欲缠。如是比。不说差别因。俱是贪欲。而言缠相应使不相应者。但有言说。竟不说差别因缘。若言缠以使为种子者。所说不成。因不相应果相应故有过。是使非不相应

杂阿毗昙心论卷第四杂阿毗昙心论卷第五

        尊者法救造

        宋天竺三藏僧伽跋摩等译

    贤圣品第五

已说诸烦恼。修行今当说

  初则名始业　　次则已习行
  思惟已度者　　当知第三种

三种修行。谓始业已习行思惟已度。始业者。不净转。未曾得境界意解思惟分。已习行者。受自相念处转。未曾得决定分善根。此上当知思惟已度。以此上一乘道故。复次不净观亦三种修行。谓从足指起乃至顶。除去皮血肉意解思惟。是名始业。于此骨琐不作想生周遍大地。又观骨琐不作想。彼骨琐展转相对大风飘抟消为雪聚。是名已习行。略观骨琐还至自身。于其所缘清净寂静唯观一色。是名思惟已度。如是乃至略境界。当知善根渐增。当知一切余方便善根亦如是。已说修行。余今当说

  若此烦恼怖　　远离诸贤圣
  如实正具足　　方便应善听

若者。若种若方便若分别。此者。次第说示烦恼烦恼者。热恼故。亦离一切有漏。但烦恼过如毒饭。是故说离烦恼众恐怖本者。起种种业种种生。远离者。数灭灭。贤圣者。正定聚。谓七人及真实凡夫。如实正具足者。谓住真实道。方便应善听者。彼方便道当一心听。方便者。一切善法方便。向解脱行施等起非唯道。三苦所逼迫世间不能觉。欲令修定故

  始于自身分　　系缚心令定
  欲缚于识足　　为尽智慧怨

始者。先也。自身分者。自身中一处也。若眉间鼻端及足指。系缚者。安立缘中令不散。何所安立。谓自心定力故起智慧。问何故。答欲缚于识足。心流转不住故缚一缘中。一心故知真实不乱。问何故缚一缘中。答为尽智慧怨。智慧怨者。谓诸烦恼彼应断。虽观他身如观死尸。契经说。以彼远因故。此说近因观。又随顺一切度门故。谓观白骨身分随顺三度门。观死尸唯随顺一不净度门。三度门者。谓不净观安般念界方便观。彼贪欲者以不净观度。觉观者以安般念度。见行者以界方便观度。如师所授随乐修行。不净观安般念。契经品广说。界方便观今当说。此以愚夫不正思惟障蔽慧眼。不观真实缘起之法。宿业烦恼种无量法。积聚五阴起积聚想。以愚惑故。于缘起所作中。计我作等诸邪见缚。或时修行近善知识。得闻正法起正思惟已。能于自身界方便。观此身种种自性种种业种种相。谓地等六界。彼地界为水界润故不相离。水界为地界持故不流散。火界成熟故不淤坏。风界动摇故得增长。空界空故食等入出。识界合故有所造作。又观此身从足至顶种种不净秽恶充满。观察此色犹如猛风飘散积沙。于无色法先后相续异分观察。如是观者。得空解脱门种子。于彼生死厌离不乐。得无愿解脱门种子。于生死不乐已正向涅槃。得无相解脱门种子。若于此得不作想觉已。观一切有为皆悉散坏。是名界方便满。问如是观已复云何。答

  是方便于身　　真实相决定
  诸受及自心　　法亦如是观

彼修行者不净观安般念界方便观。一一住已。身受心法各观真实。真实者不颠倒。相者二种。谓自相及共相。色相是身。自相四种。及所造随觉相是受自相。识相是心目相。法念处有种种法种种各异相。随知是想相。为作是思相。如是比。共相后当说。问此念处如大地建立应说一。有漏无漏分别应说二。软中上分别应说三。即此有漏无漏分别应说六。身等有漏无漏分别应说八。九品分别应说九。身等若内若外若内外分别应说十二。九品有漏无漏分别应说十八。身等软中上有漏无漏分别应说二十四。身等若内若外若内外若厌离若不乐若观察分别应说三十六。身等九品有漏无漏分别应说七十二。若念念分别应说无量。何故说四念处耶。答四倒四念四识住及阴。以四种修所治故。说四种随修法。彼治不净净想颠倒故说身念处。治苦乐想颠倒故说受念处。治无常常想颠倒故说心念处。治无我我想颠倒故说法念处。如是余种随所应说。问此念处云何满。答以二因缘满。谓坏境界及善根增。坏境界者。以极微刹那坏境界随其义。善根增者。谓依软善根中依中增。是名为满。问何故前说身念处。后乃至法念处耶。答起随顺故。世尊说三种随顺。起随顺。说随顺。无间等随顺。起随顺者。谓念处及禅。无色修行者。前起身念处乃至后起法念处。是故世尊前说身念处乃至法念处。当知禅无色亦如是。说随顺者。正断如意足根力觉道枝乘。一刹那起精进具四正断说易故。已生恶不善法方便令断。乃至已生善法方便令住。如是广说。如是正断。以所作故说四正断。非自性故。无间等随顺者。说真谛修行者先入苦无间等故。是故前说。广说如是。问何故修行者先起身念处乃至法念处耶。答粗故。五阴何者粗。谓四种及所造。是故先观受。虽非色以行粗故次说。谓手足等痛受则随转。虽想行阴粗非识。而与涅槃合施设。法念处故彼最细。是故先观心后观法。虽一切悉是法。此于法想满故建立。是故说一法念处非余。如界品中说。法入此中亦尔(想满者于声是想于义是名满)。问几种念处。答

  三种说念处　　自性及与共
  亦说名为缘　　闻等慧亦然

三种说念处自性及与共亦说名为缘者。三种念处。谓自性念处。共念处。缘念处。自性念处者。说不颠倒惠。何以故。如说顺身观身观者。是惠念者所作事。不忘授缘故。除自性过故说念处。共念处者。与正慧一果法。如世尊说。比丘善法积聚。谓四念处。是为正说。缘念处者。一切法如所说。比丘一切法说四念处。是为正说也摄受具故。及略缘故。共念处断烦恼非余。自性念处虽有略境界。彼具不足故。摄受具道断烦恼。缘念处虽摄众具。然境界普散故。略境界道断烦恼。问唯此念处三种。余亦然耶。答闻等慧亦然。余亦三种。谓闻思修。闻者常于名处起。从师受契经律阿毗昙思者或思处起。或离思。修者一向离名起。如三人学浮。一始学二半学三善学。始学者近岸。半学者或近或离。善学者离岸。初人者譬闻慧。第二者譬思慧第三者譬修慧。修慧能断烦恼永离名故。及正定故。谓二种无义者不然。何故。趣修慧故。修慧者具四念处。身受心法。彼法念处断烦恼非余。总境界故。非余。事境界故。起法念处故亦非无义。法念处二种。坏缘不坏缘。若慧缘色是身念处。若缘受是受念处。若缘心是心念处。若缘想行及无为是不坏缘。法念处余今当说

  入法中总观　　得法真实相
  此四是无常　　空无我非乐

入法中总观得法真实相者。修行者入不坏缘法念处。修一一念处。遍观一切法自相共相已。入坏缘法念处。色受缘念处色想缘色行缘色识缘。如是三四五阴缘。是法念处。成一切身受心法念处。一觉总观度此云何。此四是无常空无我非乐。以无常等行总观一切有漏法。彼念念灭故无常。离常等故空。不自在故无我实逼迫故苦

  从是名为暖　　于法觉而生
  十六行等起　　观察四圣谛

从是名为暖于法觉而生者。彼修行者于坏缘法念处次第生善根名为暖。问几行何境界。答十六行等起观察四圣谛。彼暖法行苦谛等十六行。彼苦圣谛四行。乃至道圣谛四行。行义智品当广说。彼暖法生。缘三谛法念处现在修未来四。一行现在修未来四。自分非不自分。缘灭谛法念处现在修即此未来修。非初离阴观得修缘阴道。一行现在修未来四。缘三谛增进四念处。一一念处现在修未来四。一行现在修未来十六。缘灭谛增进法念处现在修未来四。一行现在修未来十六。修未增善根。修自分行曾善根。现在修修自分不自分行。暖法是慧自在随转法则五阴性。暖者生圣智火故。暖为种故说暖法

  是法增长已　　生顶及于忍
  得世第一法　　依于一刹那

是法增长已生顶及于忍者。修行者正方便正忆念增长。得随顺善业众具故。暖法得增长。次生善根名为顶。缘四圣谛行十六行。彼顶法缘四谛缘灭谛增进法念处现在修未来四。一行现在修未来十六。缘三谛增进四。念处一一现在修未来四。一行现在修未来十六。此善根亦慧性随转法五阴性。顶法者在暖上故曰顶。劣于忍名为下。或时世尊说。信如为波罗延说。或说慧如为诸年少比丘说受事。于此顶退名顶退名顶堕。暖亦应有堕但不说。顶堕者以多忧恼故有。三处起大忧恼如失大宝。谓非想非非想离欲退离欲界欲。及顶法退者名不成就性。彼修行者于此正方便成就顶善根。增进生谛顺忍。缘四谛行十六行。初忍及增进法念处现在修未来四。一行现在修未来十六。忍者于四圣谛堪忍欲乐。暖顶亦堪忍者不然。忍不退故。违恶趣故。近圣道故。是故说谛顺忍非暖顶。问忍增长生何善根。答得世第一法依于一刹那。谓增上忍次第缘生。凡夫所得最胜善根。名世间第一法。此亦五阴性。彼有漏故名世间。胜暖等故说第一。此亦凡夫所修最上功德。一刹那不住故。似见道故。暖顶忍相续故。有说。彼慧修一切总观法念处。次第生决定分世间行善根。彼建立九品彼软软软中软上名暖法。中软中中名顶法。中上上软上中名忍法。上上名世间第一法。若观阴无常等善根名暖法。观三宝功德名顶法。观察圣谛名忍法。观苦圣谛次第圣道名世间第一法。彼得暖法已。若退舍若命终舍若度界地舍。亦起无间业断善根生恶趣中。缘此福故要得涅槃。顶法退亦如是。唯除断善根。忍则不退。有命终舍及度界地舍。不作无间业不断善根不堕恶趣。以忍大力故。如师子王群兽远避。忍力如是。一切恶心非数灭亦如大王之所住处。人天恶行心皆柔软。问世间第一法何缘几行。答

  下苦有四行　　说摄依六地
  忍法亦如是　　谓余或依七

下苦有四行者。欲界苦说下。彼世间第一法所缘。无常苦空。无我行转非余。似见道故。有二种修行者。爱行及见行。爱行有二种。我慢行及懈怠增。见行亦二种。我及我所计着。我慢者。修无常行世间第一法。懈怠增者。修苦行。我行计著者。修非我行。我所计著者。修空行。问几地所摄。答谓摄依六地。未来中间根本四禅。非欲界。无定故。非无色界。无见道故。问余决定分善根几地摄。答忍法亦如是。谓忍六地摄。如世间第一法。谓余或依七者。暖顶亦六地。尊者瞿沙。欲令欲界亦有。问已说决定分次第起。圣道次第起复云何。答

  世间第一法　　次生苦法忍
  忍次生于智　　俱观于下苦

世间第一法次生苦法忍者。世间第一法次第生苦法忍。欲界见苦断十使对治。是则初无漏无碍道。复次世间第一法次第不作不向不行。舍邪业邪趣邪见。邪业者五无间业。邪趣者恶趣。邪见者五见。又世间第一法分苦法忍作五种定。谓地定行定缘定刹那定次第缘定。地定者。若此地世间第一法。即此地苦法忍。行定者。若此行世间第一法。即此行苦法忍。缘定者。必同缘故。刹那定者。若此刹那背。即此刹那生。次第缘定者。世间第一法次第必生苦法忍。增上忍分作三种定。除刹那及次第缘。以是故缘苦忍。后得超升离生。彼思惟欲界苦及色无色界苦乃至色无色界行对治。是名下忍。彼复思惟欲界苦乃至欲界行对治。舍色无色界行对治。是中忍。彼一一谛观察舍还。乃至欲界苦相续修。然后复舍。相续乃至欲界苦一刹那思惟。是增上忍。然后生世间第一法。忍次生于智者。苦法忍次第生苦法智。解脱道自性。问此忍智何缘。答俱观于下苦。下苦是欲界苦。彼苦俱观

  谓色无色苦　　集灭道亦然
  此法无间等　　说是十六心

谓色无色苦者。色无色界苦亦如是。苦比忍无碍道。苦比智解脱道。集灭道亦然者。集灭道谛亦以二忍为无碍道。二智为解脱道。此法无间等是说十六心者。此十六心顷为法无间等。无间等是见义。此十五心顷是见道。最后一心是修道。问何故三谛忍及智见道摄。道谛最后心修道摄耶。答修十六行道故。道比智相应修十六行。非见道修十六行道比智相续故。果道所摄。谓不应者不然。如尽智成者此则成。若此非分者无学道亦非分。略说三地。见地修地无学地。于此诸地建立人。如是义今当说

  随法行利根　　此在十五意
  随信行钝见　　当知亦在中

随法行利根此在十五意者。见道十五心人。若利根说随法行。随法行故说随法行。不从他信故。随信行钝见当知亦在中者。即此十五心人。若钝根者说随信行。信他得度故。随信行者少观察。随法行者多观察

  随信随法行　　若具烦恼缚
  乃至五种断　　当知向始果

此随信随法行人。若具烦恼缚。若一二三四五种断名向须陀洹果。烦恼上上等分别故立九品。彼若凡夫时未曾断一品名具缚。若断一品名不具缚。若断五品超升离生。欲界见苦断五品断苦法智得解脱证。乃至见道断五品断道法智得解脱证。欲界修道断五品断斯陀含果得解脱证

  六断乃至八　　是向第二果
  离欲至八地　　是则第三向

六尽乃至八是向第二果者。此随信行随法行者。若已六七八品断。此说向斯陀含果。离欲至八地是则第三向者。此随信行随法行者。若离欲乃至无所有处尽。彼俱向阿那含果

  若至十六心　　是名住于果
  软见信解脱　　利见名见到

若至十六心是名住于果者。第十六心名道比智相应彼起俱说住果。若须陀洹若斯陀含若阿那含。软见信解脱者。若软见入见道名随信行。彼住三果时名信解脱。利见名见到者。若利根入见道名随法行。彼住三果时名见到。见到信根胜信解脱。但以慧所勋故说见到

  非事诸烦恼　　谓彼一切尽
  乃至未进行　　是名须陀洹

若见道断八十八结尽。是须陀洹果。乃至未集行。是名住须陀洹果。若方便断上上种。是名向斯陀含果。即此种乃至五品断超升离生道比智起名须陀洹。非向斯陀含。以向彼果道。未一念现在前故。问断众多烦恼。何故世尊说三结尽耶。答十使是根本。五见疑爱恚慢无明。彼见道断六。五见及疑。彼见道断六使永尽。彼三转三随转。彼身见是转。边见是随转。戒取是转。见取是随转。疑是转。邪见是随转。已说转。当知已说随转。是故世尊说。三结尽是须陀洹。复次此诸烦恼。或一种二种四种。已说身见当知已说一种。已说戒取当知已说二种。已说疑当知已说四种。如是一切遍不一切遍有漏缘无漏缘尽当知。此结已尽已知。乃至阿罗汉。犹有相似随转故

  未尽修道种　　受生生死七
  当知彼所说　　极满须陀洹

彼须陀洹修道种未尽。彼极满当知七有。七生人间中阴生阴及欲界天。此总说七有。不过七故。如七叶树。问何故说七有。不增不减耶。答如七步蛇所螫。四大力故至七步。毒力故不至八。如是业力故七生。道力故不至八。彼住增上忍时。除欲界七生。余一切生。得非数灭至竟不现在前。若人间超升离生人间满七天上者还天上满。中间圣道虽现在前。业力持故不般涅槃。问若满七生。佛不出世。彼云何得阿罗汉果。答有说。在家得阿罗汉果。得果已不住家。又说。即彼形自出家。成就不坏净故。希望具足故。见恶行过故。是故须陀洹法不堕恶趣。又佛种性中生故。智火明净故。见境界过故。止观具足故。圣道药所勋故。如王大子。如内火增人。如巧便鱼。是故须陀洹不堕恶趣。凡夫虽不堕恶趣。以少及不定故不说。住正定聚故说定。必得涅槃故说趣正觉。七有者如前说。住者中阴。生者生阴。故说住生。更不受余生故名住苦边。不必一切须陀洹满七有也

  若断三四种　　成就彼对治
  余二生三生　　是说名家家

三因缘故建立家家。谓烦恼断成就根及受生。烦恼断者。欲界修道断烦恼。三品四品断无有五品断名家家。若能断五品者。势力故必断六品成斯陀含。非第六品力能障令不至果。成就根者。得彼对治无漏诸根。受生者。或更受欲界。余二生三生。若三因缘一一不具非家家。有二种家家。若天若人。天家家者。谓欲界天。或受二生三生。或受一天处种类身。或二或三。人家家者。谓人间身。或一天下或二或三。或一家或二或三。问家家有何义。答从家至家而般涅槃故曰家家。须陀洹胜者名家家

  六品烦恼断　　见道断一切
  是说斯陀含　　谓彼未进行

若欲界修道断上三品中三品。及见道断一切尽住果未进行。名斯陀含。问斯陀含有何义。答于此命终生欲界天。一来人间而般涅槃

  若七八品断　　成就对治根
  余则受一生　　是名一种子

若欲界修道断七品八品。及见道断一切尽。得彼对治无漏根。欲界余一生名一种子。三因缘一一不具非一种子。若天一种子受天一身而般涅槃。人间亦尔。余一生种子故说一种子。问何故八品断名一种子。五品断不名家家耶。答正使六品断为家家者犹生欲界。是故欲界业烦恼不为障碍。一种子九品尽生色界。是故欲界业烦恼极作障碍。以是故说三处众生业极作恼乱。三处后当说。一种子者是上斯陀含

  九品尽不还　　当知有多种
  或五及七八　　或复说众多

九品尽不还者。见道断一切及欲界修道断九品结尽当知阿那含。问有尔所烦恼断。何故世尊说五下分结尽为阿那含耶。答一二四五种。如是一切五下分悉摄故。可恶卑下同义。复次二种下。界下及众生下。界下者欲界。众生下者凡夫。贪恚系故。下界者难度故。身见戒取疑系故。众生下如守门防逻故。圣人或先断二结或三结。集断故说五。不还欲界名阿那含。此亦多种。或五及七八或复说众多。是说阿那含五种者。谓中般涅槃。生般涅槃。行般涅槃。无行般涅槃。上流般涅槃。七者。中般涅槃有三种。如契经说(中般涅槃三种者一如小迸木火二如小小迸热铁三如迸烧铁丸此即契经说)。四如前说。八者。五种如前说。又现法般涅槃无色界阿那含及不定人。色界五种根建立则十五。中般涅槃上中下根。乃至上流亦如是。地建立则二十。初禅有五。乃至第四禅亦五。种性建立则三十。中般涅槃有六种。谓退法种性。思法护法住法升进法不动法种性。如是乃至上流亦如是。处所建立则八十。梵身天五。如是乃至阿迦腻吒天。种性根建立则九十。地种性建立则百二十。地种性根建立则三百六十。种性处建立则四百八十。种性处根建立则一千四百四十。记曰

  十五有二十　　三十与八十
  九十百二十　　及三百六十
  四百八十种　　千四百四十
  如是广略说　　摄受阿那含
  根地及种性　　处所广建立
  随彼烦恼断　　今当次第说

复次一阿那含谓中般涅槃。根建立三。地四。种性六。处所十六。种性根十八。地种性二十四。地离欲三十六。地种性根七十二。处种性九十六。地种性离欲二百一十六。处种性根二百八十八。地种性根离欲六百四十八。处种性离欲八百六十四。处种性根离欲建立二千五百九十二。当知是中般涅槃数。乃至上流亦如是。此一切摄受万二千九百六十。记曰

  一三四与六　　十六及十八
  谓说二十四　　复说三十六
  七十有二种　　九十有六种
  二百一十六　　二百八十八
  六百四十八　　八百六十四
  及复说二千　　五百九十二

如是阿那含。其数有五倍(即上二千五百九十二五倍为一万二千九百六十)。已说一切阿那含。五阿那含相今当说

  利根软烦恼　　住于一种业
  是中般涅槃　　分别六种性

利根软烦恼住于一种业是中般涅槃者。此人利根及软烦恼。作中阴业增长不作生阴业。彼于欲界没住色界中阴得无漏道。以此道舍余结而般涅槃。是名中般涅槃。度欲界难故非欲界中阴般涅槃。若欲令般涅槃者。彼应断不善无记二种结。得若二若三沙门果。越度三界。而欲界中阴于此无能。若色界没者上流品所摄。问此人几种性。答分别六种性。中般涅槃当知六种性。退法乃至不动。若说利根不应退种性者不然。彼亦建立九品根故

  精进勤方便　　修习速进道
  是生般涅槃　　彼亦有二说

精进勤方便修习速进道是生般涅槃者。生般涅槃人作中阴生阴业。命终受色界天中阴及生阴。彼初生起有行道。谓勤方便及速进道。疾断余结。初生便般涅槃故说生般涅槃。彼亦有二说者。有说。若初生断烦恼般涅槃者不然。无舍寿行分故。无有舍寿行者。乃至尽寿住。此义为胜

  第三勤方便　　离于速进道
  第四不勤求　　三俱说六种

第三勤方便离于速进道者。彼行般涅槃若差别者。不行速进道。余如前说。名者。起有行道断余烦恼而般涅槃。是行般涅槃。复次依有为缘三昧断烦恼而般涅槃。亦是行般涅槃。第四不勤求者。此无行般涅槃亦不勤求亦不行速进道。余如前说。名者。起无行道断余烦恼而般涅槃。是无行般涅槃。复次依无为缘三昧断烦恼而般涅槃。亦是无行般涅槃。三俱说六种者。行与无行及生般涅槃。当知俱说六种性。此三种虽皆是生般涅槃。义差别故说三无过

  超半超处处　　是名为上流
  此亦六种性　　当知进不进

超半超处处是名为上流者。上流有二种。或先得勋禅或不得。彼先得者。先勋修三禅而后退住初禅。初禅味相应命终生梵天中。彼亦三种。超半超及一切处没彼超者。生初禅乃至离第三禅。欲勋修满超第四禅。彼命终生阿迦腻吒天。半超者。从梵天没或生一二三处。然后生阿迦腻吒天。一切处没者。生一一处。乃至阿迦腻吒天。先不得勋者。不生净居天生无色界。余如前说。问此几种性。答此亦六种性。上流亦六种性。退法乃至不动此非初住不动种性根。谓退法种性于勋修禅退后得见到。当知进不进者。上流者当知有进不进。应作四句。当进修非不进者。谓住欲界梵天。不进非当进者。谓住阿迦腻吒天。亦进亦不进者。谓住余天。非进非不进者。无也。若向无色界者非勋修。是故说生无色界。问世尊说七士夫趣。彼云何建立七士夫趣。答

  谓生根烦恼　　是说有三种
  不生亦复然　　及二上流一

一阿那含四因缘故七种建立。所谓根建立。烦恼建立。生不生建立。及上进建立。彼生者。初利根软烦恼。第二中根中烦恼。第三软根上烦恼。如生三不生亦三。上流者说上进。凡夫转还故非上流。无色界上流有五事胜。谓界胜地胜正受胜阴减烦恼断。虽有五事胜。不得勋修。故不建立士夫趣

  如是九烦恼　　在于上八地
  谓彼双道灭　　世尊之所说

如是九烦恼在于上八地者。如欲界修道断烦恼有九品。从软软至上上。上八地亦如是。谓四禅四无色。彼初见道起以一种道断九种烦恼。问若色无色界烦恼亦九种。彼何故不建立离欲人耶。答一处中二生非分故。欲界有如是天如是方如是家圣人二生。非色无色界圣人二生。若二生者无生般涅槃乃至上流。谓彼双道灭世尊之所说者。此三界烦恼当知无碍解脱道灭。无碍道能断烦恼。得解脱道得解脱证。无碍道断烦恼。解脱道不失所作故说双道灭。若言解脱道断烦恼者。云何为起耶未起耶。若起者彼初尽智生时应有烦恼。此则非究竟。若未起者不应未来道断烦恼耶。问为何道断烦恼耶。答

  有垢无垢道　　俱能离八地
  住彼说身证　　谓得灭正受

有垢无垢道俱能离八地者。有垢者世俗道。无垢者圣道。除第一有余地离欲时。当知有漏无漏道。离第一有唯无漏。有漏于彼非分故。世俗道攀上地故。离下地烦恼如折楼虫。非想非非想处无有上地可攀。能离彼结。自地系缚故不能离自地结。如人被缚不能自解。彼世俗无碍道三行。若粗若苦若粗障。彼现故说粗。三苦成故说苦。易观故说粗障。解脱道亦三行。谓止妙出。一一行无碍道。下缘解脱道上缘圣行后当说。住彼说身证。谓得灭正受者。住八地见道修道断。一地见道断。中住得灭正受说名身证。是故学人于第一有一一离欲中起灭正受。彼或具结所缚得灭正受。或八品尽得。世尊以度诸正受故说言。度一切非想非非想。想知灭身作证具足住法。以涅槃与身合故说身证。灭正受定品当广说

  金刚喻定次　　必生于尽智
  生意我生尽　　应供离诸漏

金刚喻定次必生于尽智者。非想非非想地离欲第九无碍道名金刚三摩提。无一不坏故名金刚。此义择品当广说。金刚定次第必生尽智。此初二智。或苦比智或集比智。谓彼尽智起已起自己行。生意我生尽。彼非想非非想处四阴缘有根本故。应供离诸漏者。彼尽智生一切有漏尽名为应供。应一切供养故。害一切烦恼故。更不于有田种识种子故。不动阿罗汉尽智次第无生智起。彼尽智一刹那。无生智或一刹那。若次第等见现在前一刹那。若无生智现在前则相续。时意解脱。尽智或一刹那。若次第等见现在前一刹那。若复尽智现在前则相续。问阿罗汉几种。答

  阿罗汉六种　　随信行生五
  彼得于二智　　当知时解脱

阿罗汉六种者。谓退法思法护法住法必升进法不动法。若初学地不常方便不顿方便是名退法。思法亦如是堪能思愿护法者。常方便不顿方便以随护故不退。住法者。顿方便不常方便不退亦不进。必升进者。常方便顿方便是钝根能得不动。不动法者。常顿方便是利根。有说。若退法者必退。乃至得必升进。必升进者必升进。彼说六种。是欲界阿罗汉。色无色界有二种。住法及不动法有说。退法不必退。若退者唯此种性非余。彼说三界悉有六种阿罗汉。随信行生五者。此六种阿罗汉中。前五种是信种性。彼成就二智。谓尽智及无学等见。彼或时退故不说无生智。世尊以更不受生故一切契经说更不受后有知如真。当知时解脱者。当知此是时解脱。衣食床卧具处所说法及人随顺故。善根增进不能一切时随所欲进故。说时解脱

  不动法利根　　是不时解脱
  彼得于三智　　自解脱成就

不动法利根是不时解脱者。若不动法一向利根。能一切时随所欲进修善业。不待众具。是不时解脱彼得于三智者。彼成就三智。尽智无生智及无学等见。是不退法。自解脱成就者。当知彼自已相似名解脱成就。时意解脱者。待时故。时意解脱成就不动法者。不动故。不为烦恼所动故说不动。是不退义。问何故时意解脱名为爱非不动耶。答彼极自护故。犹如一目不自在故。畏退故。如借他物彼相系善根非分故。不动解脱有相系善根。谓彼有余三摩提故。是故不名爱(谓空空无愿无愿无作无作以定舍定名相系)

  慧解脱当知　　不得灭尽定
  若得灭尽定　　当知俱解脱

慧解脱当知不得灭尽定者。此六种阿罗汉不得灭尽定者说慧解脱。以慧力解脱烦恼障故名慧解脱。若得灭尽定当知俱解脱者。此六种阿罗汉得灭尽定者说俱解脱。彼慧力离烦恼障心得解脱。灭正受力离解脱障得解脱。是故名俱解脱。若复退法一切俱解脱作四句。退法非俱解脱者。谓退法不得灭尽定。俱解脱非退法者。谓五种罗汉得灭尽定。亦退法亦俱解脱者。谓退法得灭尽定。亦非退法亦非俱解脱者。谓五种罗汉不得灭尽定乃至不动解脱亦如是

  诸根说九种　　亦说九种人
  七种诸声闻　　缘觉及如来

此说九种根。谓软软乃至上上。阿罗汉人亦九种。谓前五种及二不动解脱。或因时解脱得不动。或始得不动。此七种声闻及缘觉如来是名九种人。已说根建立人。若人成就根今当说

  软中最软根　　是为初种人
  乃至增上上　　第九人当知

彼退法成就软软根。思法软中。护法软上。住法中软。升进中中。因时解脱种性不动法中上。初不动解脱上软。缘觉上中。如来上上

  谓以学种性　　得彼无学果
  或即彼种性　　或进不退转

六种阿罗汉。或以学地如是种性得阿罗汉。即彼种性罗汉。或增益根得不退转。彼种性修习根故。彼退法有三事后当说。不动法唯一事。即住彼般涅槃。余阿罗汉有二事。已说根本种性阿罗汉。增进根今当说

  所谓三四五　　六七次第增
  是诸退法等　　说五罗汉等

彼退法有三事。谓退住学法退法根。若住彼般涅槃若上增进根。思法有四事。谓退住学根退即住退法根。若异者应进不退。前说彼种性不退故。住退法根即住彼般涅槃上增进根。护法有五事。谓护法退住学根住退法根住思法根。即住彼般涅槃上增进根。住法六种。必升进七。随其义说。已说建立贤圣人相。建立法今当说

  谓随信行法　　若随法行法
  及与见谛道　　是尽同一相

随信行法随法行法及见谛道。此三种法尽同一相。差别者。随信行者钝根。随法行者利根

  于中诸根法　　是名未知根
  谓余有学法　　佛说已知根

于中诸根法是名未知根者。彼见谛所摄根数有九法。谓意根乐根喜根舍根信等五根。是名未知根。此诸根。随信行随法行所成就。名者。未知当知故说未知根。问苦法忍生观欲界五阴。后苦法智生非于五阴。已知当知耶。若言未知当知此则不然。答忍非智非智性故无过。忍是见非智性故。以智知故非不然。谓余有学法佛说已知根者。除见道学法余学法。即此根数九法说已知根。此根信解脱见到身证所成就。虽道比智生观道比忍。是未知当知以少故不说。如大海一渧须弥一尘虚空蚊处

  当知无学法　　是说无知根
  得果舍前道　　无碍智所说

当知无学法是说无知根者。当知无学法即此根数九法说无知根。此根慧解脱俱解脱所成就。彼见道六地四禅未来中间。非上地方便善根。非分及非广境界故。修道学法九地。此六地及三无色五阴性。得果舍前道无碍智所说者。得果时当知舍前无漏道得须陀洹果。舍见得斯陀含果。若先倍欲尽亦舍见道。若次第者。舍须陀洹果及须陀洹进向道得阿那含果。若先欲爱尽亦舍见道。若次第者。舍斯陀含果及斯陀含进向道得阿罗汉果。舍阿那含果及阿那含进向道。问世尊说随信行等七人。云何建立耶。答

  方便及诸根　　正受解脱俱
  当知贤圣七　　事则说有六

方便及诸根正受解脱俱当知贤圣七者。五因缘故说七人名七非事七。五因缘者。谓方便根正受解脱正受解脱。方便者。随信行随法行。随信行者。信多故说随信行。先种诸业信他故作。后得道已以本名说。随法行者。先自思惟兴造诸业。后得道已以本名说。根者。信解脱见到。钝根说信解脱。利根说见到。正受者。是身证。解脱者。是慧解脱。正受解脱者。是俱解脱。事则说有六者。此诸圣人有六。见道有二。谓随信行随法行。修道有二。谓信解脱见到。无学道有二。谓时解脱不时解脱。随信行人应说一。谓七人根故。应说三。谓软中上种性故。应说五。谓退法乃至必升进道故。应说十五。住苦法忍乃至道比忍。离欲者应说七十三。欲界离欲十。谓具缚乃至九品尽。初禅九。乃至无所有处。复次根种性道依建立增亦应广说。如是随信行人有十四万七千八百二十五。彼所摄受

  一三五十五　　及与七十三
  谓根种性道　　离烦恼当知
  三倍次五倍　　十五及九倍
  如是众多种　　唯说随信行

当知余圣人随其义亦应如是说。问如契经说向须陀洹等八人此云何。答

  以有五事故　　说有八人名
  先后事各一　　中间则有三

此四向四果说八人。名事有五。向须陀洹及阿罗汉此名一事。亦一须陀洹及向斯陀含此名二事。一斯陀含及向阿那含阿那含及向阿罗汉亦如是。彼前四人成就一地圣道。即此亦说家家及一种。向阿那含果或一地乃至六地。阿那含果或三地乃至六地。向阿罗汉或三地乃至九地。阿罗汉成就九地。彼沙门果道坏地坏应作四句。道坏非地坏者。斯陀含果。地坏非道坏者。阿罗汉果。道坏地坏者。阿那含果。道不坏地不坏者。须陀洹果(杂有漏无漏名道坏杂依诸禅名地坏)

  已尽为解脱　　得依于一果
  不秽污第九　　灭尽应当说

已尽为解脱得依于一果者。向道中诸解脱道得解脱得果时。法智品所断尽得一解脱。得比智品所断尽得二解脱。得道不坏故。故说一得果时。说五因缘。得未曾道舍曾道。顿得八智。一时修十六行。得一味解脱果。问秽污断前已说。不秽污云何断。答不秽污第九灭尽应当说。前已说烦恼眷属九品断。不秽污者。住第九无碍顿断非渐渐。不秽污者。世俗善及不隐没无记。五阴秽污色亦第九无碍断。以少故不说。问何故烦恼九品断。不秽污第九无碍断耶。答烦恼圣道相违故。圣道与烦恼相违。不秽污不相违。是故彼如是。如是道起随所应断烦恼断。软软道起上上烦恼断。乃至上上道起软软烦恼断。如小明灭粗闇大明灭微闇。彼亦如是。以秽污者自性断不成就。不秽污者舍烦恼过如难毒

  无著相似名　　彼能获不动
  信解脱种性　　升进亦增道

无著相似名彼能获不动者。非彼一切阿罗汉能得不动。唯功德名相似者得。谓必升进于彼五种中增进根者得。谓退法进至思法。如是次第尽当知。又得不动有九无碍及九解脱道。如得阿罗汉也。九无碍道八解脱道时解脱摄。第九解脱道不时解脱摄。彼一切果道所摄彼方便道。若无漏者果道所摄。有漏者不摄。信解脱种。性升进亦增道者。彼信解脱若必升进种性能得见到非余性。是故学地五种亦增进根。增进道者谓炽然根。增进根者人中增非余趣。圣道增非世俗道。学者依禅无学者依禅及无色。须陀洹斯陀含。依未来增进根。即彼舍一地得一地。阿那含若先依初禅及眷属超升离生及次第未得第二禅。彼增进根者舍三地果得三地果。若得第二禅非第三禅。后依初禅增进根者。彼舍三地果及四地胜果道。即得三地果。如是乃至得无漏无所有处。舍三地果及舍九地胜果道。得三地果。若谓舍多道得少道应退者不然。何以故。得胜道故。彼人意解故。问舍道亦舍断耶。答世俗道断者不舍。若非想非非想处烦恼一一种断。得见到时彼非想非非想修道断舍断及对治。而不成就烦恼得。如凡夫生上地时。又复若先依初禅超升离生。后依第二禅增进根者。彼舍三地果及四地胜果道。得四地果。如是一切地应广说。若住果而增进根者。彼方便无碍及解脱道果所摄若住胜果道增进根者。若彼方便无碍道胜果道所摄。若解脱道果所摄。一方便道一无碍道亦一解脱道。如是见道亦六种性。而无增进根。以速道故。如是决定分善根亦六种性。修行者次第增进根。唯世间第一法无增进根以一念故。已说诸根满。谓学满非满今当说

  或有学果满　　或根或正受
  或复三俱满　　无学二亦然

彼学有三事满。或果满或根满或正受满。若信解脱阿那含不得灭尽定者。唯果满非根满。软根故。非正受满。不得灭尽定故。见到须陀洹斯陀含。唯根满非果满非正受满。信解脱阿那含得灭尽定。果满及正受满非根满。见到阿那含不得灭尽定者。果满及根满非正受满。见到得灭尽定者。三事满。无学二亦然者。一切无学果满。无二果性故。慧解脱软根者。果满非根满。利根者。果满及根满。俱非正受满。俱解脱软根者。果满及正受满非根满。利根者三事满。问三种满谓善观谛云何观谛为顿耶。为渐渐耶。答

  建立功德恶　　渐渐见真谛
  无碍道力得　　有为无为果

建立功德恶渐渐见真谛者。于此真谛见过恶故立苦集谛。见功德故立灭道谛。是故非见过恶时见功德。亦非见功德时见过恶。体异故。亦非不如实见谛。名谛无间等。亦非一智总观谛。谛众多性故。是故渐渐见真谛。有说。无我行顿无间等。彼如是说无我行缘一切法应顿无间等者不然。何以故。颠倒众多故。自性相应共有法非境界故。谛异相故。无我等于此谛众多门。颠倒非一。无我起断众多自性惑。是故非一。无间等渐渐。无间等择品当广说。问谛无间等得沙门果。云何为有为果耶无为果耶。答无碍道力得有为无为果。烦恼数灭及解脱道俱无碍道力得。是故俱说沙门果。烦恼灭是解脱果及功用果。解脱道是功用果及依果。问此无间等有几种。答

  谓三无间等　　缘事见无间
  当知有三种　　或二亦复一

三种无间等。谓缘无间等。事无间等。见无间等。彼慧三种无间等。缘无间等者。有缘故。事无间等者。能成事故。见无间等者。见性故。慧相应法二种无间等。缘无间等及事无间等。彼共有法唯一。事无间等。彼苦忍苦智于苦谛三种无间等。于灭谛道谛事无间等。当知集忍集智于集谛亦如是。灭忍灭智于灭谛三无间等。于苦集道谛事无间等。道忍道智于道谛三无间等。于苦集灭谛事无间等。修道随其义当知如是。见谛无间等。以是因缘当知渐次无间等

杂阿毗昙心论卷第五杂阿毗昙心论卷第六

        尊者法救造

        宋天竺三藏僧伽跋摩等译

    智品第六

已说建立贤圣人。智今当说

  若智性能了　　明照一切有
  有无有涅槃　　彼诸相今说

若者若其事。智者决定义。了者分别也。明照者观察也。一切有者极三有际。谓苦集谛。有者有性也。有无有者有尽也。涅槃者诸烦恼灭。此说灭谛。彼诸中亦示道谛相者。自性自然性。今说者显示自性也。问何等为智。答

  三智佛所说　　最上第一觉
  谓法智比智　　及世俗等智

此三智摄一切智。法智者。若智境界欲界苦集灭道无漏智也。此初受法相故说法智。比智者。若智境界色无色界苦集灭道无漏智也。若此行法智转。即此行随转。是比智以比类智故说比智。等智者。若智境界一切法有漏智也。等者多受俗数。谓男女长短等。故说等智(等者众事聚会义也)

  苦集及灭道　　二智从谛生
  是名与四智　　牟尼随谛说

此法智比智随谛转。世尊随彼谛声说。境界苦谛说苦智。境界集灭道谛说道智

  若智观他心　　是从三中说
  尽无生智二　　境界在四门

若智观他心是从三中说者。三智观他心。以法智品为境界说法智。以比智品为境界说比智。以有漏心心法为境界说等智。尽无生智二者。尽智无生智是二智。谓法智比智。彼所作究竟决定转是尽智。不复当作

决定转是无生智。问何谛境界。答境界在四门。谓彼缘四谛。问若世尊说三智。云何说十。答

  对治及方便　　自性行行缘
  已作因长养　　是故说十智

七因缘故说十智。谓对治方便自性行行缘已作因长养。彼对治者。法智比智是无漏智。欲界对治说法智。色无色界对治说比智法智。虽色无色界对治。而非一切亦非全种。是故不说。方便者。他心智亦智心法。但彼方便欲知彼心故。自性者。等智多取俗数如前说。行者。苦智集智。此二智行不坏缘坏。一缘故。此二智共一缘。是故于彼缘无常行转。是苦智亦应说无常。智以苦极增厌故名苦智复次不共故苦行一向有漏缘。无常行者。若有漏三谛缘。若无漏有漏缘。空无我行者。若有漏一切法缘。若无漏有漏缘。是故苦智苦行应作四句。或苦智非苦行者。谓苦智行余行。或苦行非苦智者。谓苦智相应法。或苦智亦苦行者。谓苦智行苦行。或非苦智亦非苦行者。谓苦智行余行诸相应法。如行已行当行亦如是。如苦行无常空无我亦如是。如苦智十二乃至道智亦如是。行缘者。谓灭智道智。以彼智缘不坏行亦不坏。已作者。谓尽智。所作已作故因长养者。谓无生智。因一切无漏智故。住不动身故。已说因缘建立十智。善等分别今当说

  九智唯说善　　一智三分别
  一见二非见　　余则有二种

九智唯说善者。除等智余九智说善爱果故。一知三分别者。等智或善或不善无记。一见者。他心智。是见分别性故。二非见者。尽智无生智。非见非分别性故。余则有二种者。余七智或见或非见。若法智比智苦集灭道智尽智无生智所不摄者是见。摄者非见。等智或见或非见。五见世俗正见。是见以捷疾故。疑爱恚慢无明相应慧非见。何以故。二使覆故。无明相应慧虽无二使。一能极覆非余烦恼。何以故。非观察方便故。不隐没无记慧非见。不捷疾故。五识相应慧非见。非思量性故

  学与无学六　　二智说无学
  非学无学一　　当知一三种

学与无学六者。谓法智比智苦集灭道智。或学或无学。若学人所得是学。若无学人所得是无学。二智说无学者。尽智无生智是无学。离烦恼住故。非学非无学一者。谓等智是非学非无学。有漏故。当知一三种者。谓他心智或学或无学非学非无学。若唯以学心心法为境界是学。若以无学心心法为境界是无学。若唯以有漏心心法为境界。是非学非无学

  八智性不断　　二知二种说
  有漏无漏一　　一则说有漏

八智性不断者。除他心智及等智。余八智不断。离垢故。二智二种说者。他心智若有漏是修道断。若无漏是不断等智。若忍对治是见断。若智对治是修断。有漏无漏一者。他心智或有漏或无漏。以有漏心心法为境界是有漏。以无漏心心法为境界是无漏。一则说有漏者。等智一向有漏。烦恼住处故。当知八智不断说无漏

  四智有为缘　　有常缘则一
  五智二境界　　明智之所说

四智有为缘者。谓他心智苦集道智有为缘。以阴为境界故。有常缘则一者。谓灭智无为缘。以涅槃为境界故。五智二境界者。谓法智比智尽智无生智。以三谛为境界是有为缘。以灭谛为境界是无为缘。等智亦以三谛为境界是有为缘。以数灭及虚空为境界是无为缘

  法智应当知　　是从六地起
  比智则九地　　他心智在禅

法智应当知是从六地起者。法智六地可得。自性得也。谓四禅未来中间非无色。无色不缘欲界故。比智则九地者。比智九地可得。谓未来中间四禅三无色。他心智在禅者。谓根本禅有他心智。是四支五支定果故

  等智应当知　　在于十一地
  谓彼诸余智　　品品如前说

等智应当知在于十一地者。等智在十一地。谓欲界未来中间四禅四无色。谓彼诸余智品品如前说者。谓苦集灭道智尽智无生智。若法智品在六地如法智。若比智品在九地如比智

  若说诸念处　　一智当知后
  三则说一智　　余四明智说

若说诸念处一智当知后者。谓灭智是法念处。无为缘故。三则说一智者。谓他心智。他心心法缘故。是三念处。除身念处。余四明智说者。谓余八智是四念处。五阴缘故

  一智欲界依　　二界依有一
  二智三界依　　余六一或三

一智欲界依者。法智唯欲界依。以法智随生。或欲界四大造故。二界依有一者。他心智欲色界依。依色故。二智三界依者。比智等智三界依。余六一或三者。苦智等六智。若法智品欲界依。比智品三界依(依者身之别名)

  名则十六行　　事或说十六
  离于十六行　　除闇非无漏

名则十六行者。谓无常苦空非我因集有缘灭止妙出道正迹乘。众缘所持故无常。逼迫故苦。我所见对治故空。我见对治故非我。种子法故因。等起故集。相续故有。相成熟故缘。诸阴尽故灭。三火息故止。离内恼故妙。离外恼故出。趣向故道。巧便故正。等趣故迹。至究竟故乘。复次非究竟故无常。重担故苦。内离人故空。不自在故非我。来方便故因。出生方便故集。增长故有。与依故缘。不相续离相续故灭。离三有为相故止。善故常故妙。第一休息故离邪径对治故道。不正对治故正。登涅槃城故足。一切有对治故乘。问事有几行。答事或说十六。此名十六行。有说。事有七。谓苦行名四。事亦四。颠倒对治故。集行名四。事一。灭道亦如是。如是说者名十六事。亦十六者善。问离十六行更有无漏慧耶。答离于十六行余闇非无漏。离十六行无有无漏慧。如契经说。我生已尽。此亦是苦。等行生尽。如言我斫木为谁斫谓斧斫此亦如是。问此诸智各有几行。答

  二智十六行　　法智及比智
  如是行或非　　是说为等智

二智十六行法智及比智者。如所说十六行一切法智比智转。如是行或非是说为等智者。等智行十六行亦非十六行。十六行者。谓暖等善根。是十六行及余不定闻思慧亦非者。如病如痈等行。是名为非。问若等智是十六行者。何故不说名苦智乃至道智。答坏境界故。无漏行不坏境界。别谛缘故。有漏行坏境界。有漏无常行三谛。缘空非我行一切法缘

  四智有四行　　决定行所说
  若智知他心　　如是行或非

四智有四行决定行所说者。苦智有四行。乃至道智亦如是。若智知他心如是行或非者。若无漏他心智是道四行。有漏智非自相境界故

  尽智无生智　　离空无我行
  说有十四行　　谓近于等故

尽智无生智离空无我行说有十四行者。尽智无生智十四行。除空无我行。问何故非空无我行耶。答谓近于等故。尽智无生智第一义而近等。空无我行第一义近第一。问彼诸行为谁能行。亦为他所行耶。为何等性。答

  谓慧行能行　　亦为他所行
  余有依二种　　无依他所行

谓慧行能行亦为他所行者。慧自性是行。能于彼尔炎中行无常等行。彼亦为无常等行所行余有依二种者。除慧余相应等法是亦能行。有缘故。亦为他所行。他所缘故。非行非慧性故。无依他所行者。若彼不相应法。谓色无为心不相应行。是他所行。非慧性故。非能行。无缘故。已说建立行。建立得今当说

  谓初无漏心　　或有成就一
  二或成就三　　四时各增一

谓初无漏心或有成就一者。谓初苦法忍相应心。若未离欲成就一等智。若离欲成就他心智。二或成就三者。第二苦法智相应心。若未离欲成就三智。苦智法智等智。若离欲成就他心智。四时各增一者。于上四时一一增苦比智。若未离欲四智法智比智苦智等智若离欲得他心智。集法智增集智。灭法智增灭智。道法智增道智忍中不得智。非智性故。集灭道比智不增智。以苦比智得名故。已说成就智。修今当说

  若得修于智　　谓在圣见道
  即彼当来修　　诸忍亦如是

若得修于智谓在圣见道即彼当来修者。见道诸智现在修。即彼未来修。谓苦法智现在修。未来修苦法智非忍非余智。如是乃至道法智。诸忍亦如是者。苦法忍现在修。即彼未来修。非智非余忍。一切忍亦如是。问何故见道唯修自分修道修自分及非自分耶。答彼初得种性故。见道初见谛故。唯修自分非余。又不杂道故。捷疾故。不觉道故

  于彼三心中　　得修于等智
  当知最后心　　或修七或六

于彼三心中得修于等智者。见道三心无间等边修等智。谓苦集灭比智。若依禅未来超升离生。彼修一地见道二地等智。谓禅未来及欲界。若依初禅超升离生修二地见道三地等智。乃至第四禅修六地见道七地等智。问道比智边何故不修等智耶。答边非分故。谛无间等边修故名无间等边。无能修一切道及佛边际而知一切苦集灭。复次世俗智于彼谛曾无间等故。修见道眷属故。无间等边等智是见道眷属。道比智是修道。所以无色界不修。以无见道故。问法智何故不修。答谛无间不究竟故。若修者应说无间等中。若欲界者则四阴性以不定故。若色界者五阴性以定故(有定则有定共色故有色阴是以有五阴)智增故说修等智。若苦无间等边有四事。欲界缘欲界苦。色界缘色无色界苦。集灭无间等边亦如是。是不生法依随信行随法行故。彼随信行随法行成就而不现在前。或修七或六当知最后心者。若离欲得道比智未来修七智。除等智尽智无生智。若未离欲修六智。除他心智。修非想非非想处对治道等智。非彼对治故不修

  于彼上修道　　十七无漏心
  当知修于七　　增益根或六

于彼上修道十七无漏心当知修于七者。若未离六种欲。从须陀洹果进九无碍道八解脱道修七智。此道禅未来摄故。无他心智尽智无生智。是无学故不修。余七智必修。若世俗智离欲。彼现在修一等智。未来修七。若无漏者四法智。一一现在修未来七。增益根或六者。谓信解脱求见到。彼无碍道修六智非他心智。无碍道相违故。非等智。似见道故。非尽智。无生智无学故。若未离欲解脱道亦修此六若离欲修七智。是故说或升进得不动者。九无碍道修七智非他心智。无碍道相违故。非等智。非第一有对治故。非无生智。未得故。八解脱道修八智亦得他心智故。第九解脱道修十智。是故说或

  得不还果时　　及离上七地
  勋修诸神通　　解脱修习八

得阿那含果必得根本禅故修八智。除尽智无生智及四禅三无色。此七地离欲时九解脱道修八智。若世俗道离欲时等智现在修未来八。若无漏道离欲者是苦等六智一一现在修未来八。六智者。谓苦比智集灭道比智及灭道法智也勋修禅一解脱道学修八智。无学修十智。神足他心智宿命通一解脱道亦修八智。根本禅摄故。天眼天耳解脱道无记故不修(上三通得时及后用时悉是解脱道解脱道悉是善神足降伏众生故余二所见微远故眼耳无此故无记)

  此诸无碍道　　及灭第一有
  即彼八解脱　　当知修于七

七地离欲无碍道。及对修禅二无碍道。学诸通五无碍道(七地离欲及熏修以一等智一无漏智为无碍道二念故言二五通各有一无碍故言五)修七智。除他心智。无碍道相违故。第一有离欲八解脱道修七智。除等智。非对治故

  第一有离欲　　无碍道修六
  上乘应当知　　修习于下地

第一有离欲无碍道修六者。第一有离欲九无碍道修六智。除他心智及等智。一切方便道有漏无漏修八智。上乘应当知修习于下地者。若此地离欲即修此地无漏智及下地。谓初禅离欲即修初禅功德及未来。如是乃至第一有离欲。修一切地无漏功德。上对治名为上乘

  无学初心中　　修于一切地
  无学相似修　　或苦习比智

无学初心中修于一切地者。无学初尽智相应心修九地功德。问修何等种无学功德。答谓无学相似修。若退法者修九地软软功德。乃至如来地修上上功德。问无学初心何智。答或苦集比智。或苦比智。或集比智。生缘故作如是念。我生已尽。此非想非非想处。四阴生缘最后尽故。已说修无漏功德。有漏今当说

  尽智心俱修　　善有漏功德
  九地至一地　　次第修亦减

得阿罗汉果时。或修九地善有漏功德。乃至成一地。问何故九地乃至一地也。答谓生于欲界修九地有漏。若生第一有则修于一地。若生欲界得阿罗汉果

得尽智所修九地善根。若生初禅修八地。除欲界。如是乃至非想非非想处。即修彼地善根。问何故于此处修三界善根。答一切缚解永苏息故。如三等缚解。如降伏烦恼力士众咸称善。如王登祚解脱灌顶一切皆献珍奇宝物。先虽得下地功德。以上地烦恼故智光不明。得阿罗汉果一切功德增修照明。修义择品当广说。问世尊说见智慧。为一为异耶。答

  诸忍则非智　　尽无生非见
  余一切圣慧　　当知三种性

诸忍则非智者。八无间等忍非智。不决定故。自品对治疑得缚故。决定义是智义故。复次忍者希望求。智者希望息。复次忍是见非智性智性。尽无生非见者。尽智无生智非见。息求故。中平故。背生死故。余一切圣慧当知三种性者。除忍及尽智无生智。余慧种能求故见决定故智。问何者是。答学八智及无学等见

  若善有漏智　　在意则是见
  烦恼见是智　　此及余说慧

善有漏意地智能求故见。有说。非一切意识相应善有漏智是见性。谓从不思量识身所起故非见(五识次生意识此非见也)。命终心非见。羸劣故。起作心非见。外向故。如是好谓初说(凡说得理者名如是说)烦恼见是智者。若见自性。谓身见等。从思量生故说见。亦说智决定故。此及余说慧者。此说若智若见及余未说者。谓意识相应无记。除五见诸余意地染污及一切五识相应。当知一切是慧。谓彼说未说者。若无记慧非见。不捷疾故。工巧慧虽捷疾而非见。求生所障故。染污前已说。五识相应慧非见。不分别故不捷疾故。一往故。问一一智几智缘。答

  法智及比智　　观察于九智
  因智及果智　　境界于二智

法智及比智观察于九智者。法智缘九智。除比智。比智亦缘九智。除法智。问何故不展转相缘。答下上境界故。法智缘下比智缘上。是故不展转相缘。如二人同止。一人观下一人观上地空异观故不相见面。若言不自缘如不自见面者不然。续观故。因智及果智境界于二智者。苦集智缘有漏。他心智及等智苦集谛所摄故

  道智缘九智　　解脱智无缘
  余一切境界　　决定智所说

道智缘九智者。道智缘九智。除等智余九。智缘道谛所摄故。解脱智无缘者。灭智不缘。智缘无为故。余一切境界决定智所说者。余四智。他心智等智尽智无生智缘十智。问如前说若欲界对治是法智。虽色无色界对治非一切亦非全。何等法智为色无色界对治。答

  谓彼灭及道　　法智之所行
  是三界对治　　非欲界比智

谓彼灭及道法智之所行是三界对治者。有修道灭法智道法智。是三界修道所断对治。彼于欲界极见过患。思惟欲界行灭及对治。得离三界欲。问何故非苦集法智。答下劣上胜故。非观劣能离胜处欲。灭道俱胜。是故观此灭三界欲。复次若缘欲界离色无色界者。是为异厌异不乐异解脱。此则不然。问颇比智离欲界也。答非欲界比智无比智。欲界对治自事未究竟故。如王降伏自界怨已然后伏他。法智亦如是。无有比智先灭色无色界后灭欲界也。又法智是极利智。尚灭不善。况无记也问神通几智性。答

  神足天眼耳　　是说一等智
  或六智宿命　　五说他心智

神足天眼耳是说一等智者。神足天眼天耳一等智。无漏智不以此行。神足者。种种示现。天耳通是天耳识相应慧。生死通是天眼识相应慧。神足余品当说。天耳方便思惟大声。彼方便渐增得色界四大所造清净天耳。随声远近一切悉闻。天眼方便思惟明相。彼方便渐增于眼周圆。得色界四大所造清净天眼。处于一方遍睹十方。一切悉见而非一时。或六智宿命者。尊者瞿沙说。六智非他心智。缘现在故。非灭智。缘无为故。非尽智无生智。非见性故。阿毗昙者说。一等智缘众生名姓等故。方便者。或于自身或于他身。于是处方便即于是处究竟。或复余也。声闻缘觉从前身起乃至究竟随其所欲。唯有如来随意自在。若前若后随所闻见皆悉忆念五说他心智者。五智知他心。谓法智知他法智品心心法自分境界故。比智亦如是。道智知他无漏心心法。等智知他世俗心心法。他心智五也。方便者。或从自身或从自心取其相貌。如是相身有如是相心。以是方便善根渐增。乃至知他心心法。是名成就于色方便及自心起至成就时。不缘色及自心。离于行缘知他心智根地。人度不知根度者。软不知中上根。谓乃至第四禅地软知下地软。无漏非余。有漏者知有漏不知无漏。地度者初禅不知二禅。人度者学人不知无学人。是故佛心心法非一切他心智境界一切他心智事境界自相境界心心法境界现在境界他境界。除见道是修道得故空无相不相应尽智无生智不摄离无碍道。问神通云何如说而生为异也。答或有说。如说而生。如世尊先说神足。是故前生。乃至后说生死智。是故后生。尊者瞿沙说。谓欲界处起神通如说而生。若色界则异此。修行者闻说色界天而不见。欲见故起天眼。见而不能往故起神足。往而不闻说故起天耳。虽闻而不知心云何往故起他心智。知他心而不自知先所从来故起宿命智。如是说者。神通无有次第正受。亦无超越正受。亦无顺正受。亦无逆正受。当知神通解脱道所摄。非无碍道。问力无所畏一一几智性。答

  处非处智力　　及第一无畏
  此是佛十智　　余此中差别

处非处智力及第一无畏此是佛十智者。处非处力及初无畏。此十智性普境界故。问余力无畏何智性也。答余此中差别。处非处力差别有余力。初无畏差别有余无畏。世尊观受化者希望故。建立多种。问何故世尊自说功德也。答为求佛道者修念佛三昧故。复次于等解脱现差别故。乐说辩才故。无尽无滞无缺。乃至降伏醉象等中有疑者不知谁力。为彼故显示自力故。复次为受化者说实功德。不过量故。离非大人法故

  净业有爱果　　不净果不爱
  此说为是处　　异则说非处
  应当如是知　　是处非处力

净业有爱果不净不爱果此说为是处者。因果决定彼无障碍智。知此是彼决定因。谓净业有爱果不净业不爱果。犹如外种因果随类。异则说非处者。与是相违名非处。应当如是知是处非处力者。等起容受义。是处义也。与是相违名非处义也。不伏不屈故。无胜无动故。说力

  彼十智自性　　在于十一地
  决定说如来　　谓阎浮提依

彼十智自性者。如前说。普境界故。十智自性缘一切法。是十六行或离行。四念处三正受三根相应。在于十一地者。谓欲界四禅未来中间四无色。决定说如来者。说建立如来力。非声闻缘觉。以如来除二种无知故。谓染污不染污。是故佛智不为非智所屈。是无学及非学非无学非是学。声闻缘觉虽除染污。不除不染污。如来除二种疑。使处疑处非处疑。谓阎浮提依者。谓阎浮提身现在前非余。余方无佛出世故。阎浮提人利根易觉。是故佛阎浮提出世非余

  第二力八智　　于彼事业转
  及法受烦恼　　余则如前说

第二力八智者。自业智力八智。除灭智道智。无漏缘故。是故说八。行或离行。空无愿相应。问何缘。答于彼事业转及法受烦恼。彼事者是业果。身口业及思是业。法受者有四法受。有法受现世乐后世乐。如是比。烦恼者是业因。于此转缘此起。余则如前说者。余如处非处力说

  诸禅及背舍　　正受三摩提
  第三力回转　　九智余如前

诸禅及背舍正受三摩提第三力回转者。禅者四禅。背舍者八背舍。正受者。无想定灭尽定及四无色。三摩提者。空无相无愿。第三力者。于此禅背舍正受三摩提中转缘此起。问此力何性。答九智性。除灭智。及灭四行无相三昧无为缘故。余如前者。余如自业智力说

  于上下诸根　　第四力回转
  第五说解力　　第六于界缘

于上下诸根者。上者胜下者劣。根者主。第四力者。上下诸根力也。回转者缘也。谓缘三谛。从缘根方便起故说上下诸根力如他心智。第五说解力者。解者欲也。彼亦二种。有胜有劣。胜者善欲劣者恶欲。复次欲道及道果者胜。欲生死者劣此亦缘三谛。从欲方便起故说欲力。第六于界缘者。界者自性也。有二种如前说

  于彼种种趣　　第七力回转
  当知已说四　　余皆如前说

于彼种种趣第七力回转者。趣者道也。彼亦种种。向地狱乃至涅槃。彼缘趣及众具故名趣力。当知已说四余皆如前说者。已说根解界趣力。余因缘当知如禅背舍正受三昧说或有说。趣智力是十智性

  知宿命有行　　是说第八力
  谓禅有烦恼　　余则如前说

知宿命有行是说第八力者。宿命力于宿命所受若所行所受。种种悉知。彼所行者谓中阴。所受者谓本有。以本有有所受。若刹利若婆罗门。如是比悉知。是宿命力。说一智。谓宿命智有二种。谓曾得今得。上中下说三地。建立说四。软中上曾得今得说六地。曾得今得说八。下下至上上说九地。及下中上分别说十二。下下等曾得今得说十八地。下中上曾得今得说二十四地。下下等分别说三十六地。下下等曾得今得说七十二。此总说一宿命智。谓禅者。根本禅非眷属。非无色无神通所依三摩提故。四支五支所摄三摩提神通所依。唯禅非余。若依彼禅得宿命通。即知彼禅及下地。若依初禅得神通。知初禅及中间。同一地故。有烦恼者。前已说。是等智是故无无漏事是法念处。余则如前说者。如趣智力说

  第九力当知　　远离于所缘
  命终及受生　　行于众生数

第九力当知远离于所缘者。生死智力除缘。余如宿命智说。声闻不方便见千世界。方便者见二千世界。缘觉不方便见二千世界。方便见三千世界。佛不方便见三千世界。方便见无量无边亿百千三千世界。问何缘。答命终及受生行于众生数。彼缘色入。如所说随业受法如实智。当知彼说眷属。生死智此则内法

  第十力十智　　或六一切地
  示现力明通　　余皆如前说

第十力十智或六者。若说漏尽人所得为漏尽智者。彼说十智性。若以漏尽缘故为漏尽智者。彼说六智。除他心智苦集道智。一切地者。漏尽智在十一地。摄受生故。示现力明通者。彼漏尽智说名示现。谓教诫示现。令彼欢喜不倾动故说力。永离无明故说明。通种性故说通。宿命智力生死智力是说通明力。非示现。问此非非学非无学耶。何故契经说。三明一向无学。答无学身中得故。导第一义明故。问六通何故三通建立明。非余耶。答三种愚对治故。彼初明灭前际愚。第二灭后际愚。第三灭真谛愚。导三解脱门故。六通中二通是示现非明。谓神足他心智。二是明非示现。谓宿命智及生死智。漏尽通俱有。天耳通俱无。余皆如前说者。余所未说者因缘如前说。已说力。无畏今当说

  初则如初力　　第二如第十
  余二如二七　　是名无畏安

初则如初力者。言我等正觉此初无畏。即处非处力。第二如第十者。言我诸漏已尽。此即漏尽力。余二如二七是名无畏安者。言我为诸弟子说障道法。彼言不障道者。无此畏也。此即自业智力。言我为诸弟子说道是贤圣出离。言不出离者。无此畏也。当知此即趣力。问世尊何故说此契经。答制善星及婆罗婆诽谤故说此契经。善星言。沙门瞿昙无过人法。为制彼故说前二无畏。婆罗婆言。沙门释种子法我悉知见。为制彼故说后二无畏。复次前二无畏是说自安。后二无畏是说安他。不屈伏义是无畏义。离恐怖故。问力无畏何差别。答有说。无差别。又说。智是力。智光普照是无畏。安住是力。勇猛是无畏。智无尽是力。辩无尽是无畏。如是等。复次一一力摄四无畏。一一无畏摄十力。此十四法。又三不共念处及大悲。是佛十八不共法。不共一切声闻缘觉故不共。念处及大悲是慧性。问无诤何地云何行何处现在前。何缘何等人起何等自性也。答

  第四禅有垢　　无诤三方依
  缘欲未生恼　　依不动智慧

第四禅者。无诤在第四禅非余。普境界故。于一切依最胜故。是有垢离圣行故。无诤者。烦恼相违故。三方依者。三方现在前非余。说力所起故。缘欲未生恼者。缘欲界未来烦恼。谓贪恚痴慢自相烦恼非总相。总相是普境界。是故得四念处舍根相应。依不动者。依离烦恼身得故三昧力故。唯不动法者所能起非余。智慧者。是智慧自性也。彼阿罗汉不行五因缘故。则能令彼不起烦恼。谓正威仪及正说分别应受不应受观察住处及观察人。正威仪者。于一方正身坐。若有人来即观其心。观察彼心何等威仪令不起结。若此威仪令彼不起。即时便住如是威仪。正说者。若有人来即观其心。若说而起彼结则不为说。不说而起则便为说。分别应受不应受者。他施众具即观察之。若受其施而起彼结。虽须不受。不受而起虽不须而受。观察住处者。若住此处而起彼结。虽众具丰足则便舍去。观察人者。先观察人然后入里。若舍若巷有起结者则便不入。云何于彼复作恶缘。为摄他故作是思惟。我于往昔烦恼身时。彼等于我起烦恼故受不爱果。况今离欲。当作方便令彼于我必不起恼。佛及波罗蜜诸声闻等。得无诤满而不数入(为令众生因恼得度故有时不入无诤三昧也)

  所谓妙愿智　　远离彼境界
  于彼最后得　　六智自在性

所谓妙愿智远离境界者。妙愿智亦在第四禅。是有漏依。三方不动者所得。是智惠性缘一切法。普境界故。无色依者(上云无色依者此依是津腻义谓欲色界是无色界气分故名为依此释愿智因依果知无色界也)。观行差别如田夫。是故说四念处。如愿而知故说。愿智欲知而知是其义。于彼最后得者。若起彼智时。谓欲界善心次第初禅现在前。如是次第乃至非想非非想处。如是逆次第乃至欲界善心。复顺次第乃至第四禅现在前。彼复于第四禅从软至中从中至增。于彼增上第四禅后起愿智。六智自在性者。此智六种自性。谓三无碍智除辞无碍。又无诤智后边智及妙愿智。此智三因缘故起。摄他故。摄教法故。觉世间安不安故

  义辩漏无漏　　在于一切地
  佛说为方便　　余则如前说

义辩漏无漏者。此辩十智性。以一切法第一义故。有说。六智性。除他心智苦集道智。以灭谛最第一义故。是故说行念处三昧缘。在于一切地者。此辩在十一地。自性得故。佛说为方便者。义辩以佛所说为方便。若先无佛说则无能起者。不知义故。余则如前说者。余所未说者。如愿智说

  所谓为应辩　　境界道及说
  因明论方便　　或三余如前

所谓为应辩境界道及说者。应辩缘道及言说。是故九智自性除灭智有十二行。因明论方便者。此辩不以因明论为方便。则无能起者。不知应不应故。是故说阿毗昙为方便。以因明论无如阿毗昙者。以智具足故。或三者。此辩三智性。谓辩及愿智最后智。有说。知一切法第一义。彼亦义辩。余如前者。余所未说者。如义辩说

  法辩缘施设　　在于五地中
  以数为方便　　余如无诤说

法辩缘施设者。法辩缘名分齐。在于五地中者。谓欲界及四禅。非上地。以无色界不缘名及下地。非分故。以数为方便者。法辩以数论为方便。余如无诤说者。余所未说者。如前无诤说

  声明论方便　　是则为辞辩
  境界于言说　　二地余如前

声明论方便是则为辞辩者。辞辩以声明论为方便。若先不习声明论。则不能起离种子故。境界于言说者。此辩缘言说。是故是身念处。二地者。欲界及初禅。非上地。离觉观故。余如前说者如法辩说。问辩云何。如说生耶为异耶。答有说。如说生。谓先于法起名巧便。知名未知义故次第起义辩。虽知义不知辞故次起辞辩。知辞辩已不能连注说故次起应辩。又说。先起义辩。知义不知名故次起法辩。知名不知辞故次起辞辩。知辞不能连注说故次起应辩。应辩如前说。又说。名随说转。是故先起辞辩后起法辩。义依名转。是故次起义辩。此三辩导应辩。问此辩云何。为一一得也。答不然。若得一则具四。如四圣种一时得。此亦如是

杂阿毗昙心论卷第六杂阿毗昙心论卷第七

        尊者法救造

        宋天竺三藏僧伽跋摩等译

    定品第七

已说智。定今当说

  智依于诸定　　安不动而转
  是故当思定　　勤求见真实

决定义名智。彼善心正性相续名定。建立义名依。依有二种。共起及次第缘。彼二说名依。依定而立故说依诸定智有八种。四法智四比智。安不动者。不动摇故说不动。转者取缘义。如灯依净油炷离风处光焰甚明。如是智依诸定离于乱风则不动而转。是故者说因缘也。定者智所依后当说。思者知见义。勤求者求欲时也。真实者不颠倒。谓四真谛。见者谓无间等。是说真实见。以不离定而起实智故。问有几种三昧。答

  决定说四禅　　及与无色定
  是中一一说　　味净及无漏

决定说四禅及与无色定者。谓决定智者。略说八种。三昧摄一切三昧。谓世尊知差别三昧正受。一切声闻缘觉不知其名。如修多罗广说。是中一一说味净及无漏者。一一三昧说三种。味净无漏

  善有漏是净　　无漏离炽然
  味则爱相应　　最上无无漏

善有漏是净者。若善有漏当知是净。问善有漏有垢云何说净耶。答烦恼相违故。烦恼不杂故。引导无漏故。无漏离炽然者。离烦恼炽然当知是无漏。彼虽永离烦恼。第一义净当知为差别故立名。味则爱相应者。若爱相应定者当知是味相应。问何故爱相应说禅。非余烦恼耶。答相似故。一向勋着缘是三昧。余烦恼无有着缘如彼爱者。复次已说爱当知已说余烦恼。是烦恼足故。最上无无漏者。彼总说故言一一三种。当知第一有唯二种无无漏。不捷疾故。有二边谓欲界及第一有。圣道离二边名为中道。离二有根本亦如是。若味相应著者名味正受。若不味著者名净正受。若无漏思惟五阴无常等行。当知是无漏正受。问净有几种。答

  净者有四分　　退分及住分
  胜进决定分　　随顺诸功德

退分者顺烦恼。住分者顺自地。胜分者顺上地。决定分者顺圣道。复次退分者若住彼则退。住分者若住彼不进亦不退。胜分者若住彼能胜进。决定分者。若住彼则能次第超升离生。复次退分者为烦恼所陵所杂。从禅次第烦恼现在前。烦恼次第禅现在前。住分者彼能厌下地粗等行。受自地寂静等行。胜分者能厌自地过。受上地功德。决定分者暖顶忍世间第一法。如禅无色亦如是。唯除暖等功德。问禅何等性。答

  五支有觉观　　亦复有三受
  种种及四心　　是说为初禅

五支者五支所成。分义是支义。如车有众分。众具义是支义。如王有将士。支者若异若即。若异者。如毗陀六支(四毗陀经一者亿力毗陀二者阿他毗陀三者耶训毗陀四者三摩毗陀毗陀者智也有六支所成一学二欲三想四辞五记六缘历也)。比丘五胜支(比丘五胜支所成一信二不谄三不病四精进五智)。若即者如十六支散八支圣道。彼支者。谓觉观喜乐一心正受时。先粗心法作想名为觉。粗心法相续随转名为观。正受时心悦名为喜。身心离恶故快乐名为乐。是猗息乐非受乐。于缘心心法不散名一心。有觉有观者。初禅有觉有观。问已说五支。何故别说有觉有观耶。答支者谓善。秽污亦有觉观故别说。亦复有三受者。彼有三受。谓三识身有乐根。意地有喜根。四识身有舍根。种种者。谓梵天有种种身。有胜有劣。以觉观力生故。有尊长眷属处。及四心者。彼有四心。眼识耳识身识意识。是说为初禅者。此诸法说初禅。胜一切烦恼故。正观一切境界故说禅

  第二有四支　　种种及二受
  第三说五支　　此禅亦二受

第二有四支者。内净喜乐一心。种种者。彼无种种身。觉观非分故。有种种心。谓根本有喜根。喜息已眷属舍根现在前。舍息已复入喜根。及二受者谓喜根及舍根。此诸法说第二禅。第三说五支者。谓念正知乐行舍(行舍此行如常行等行也此是行舍非根舍也)一心。念者。于缘不忘记。正知者。止举舍时分别知。乐者。于缘随顺受。行舍者。乐着乐故不受余求。一心者。于缘不散。此禅亦二受者。彼亦二受。乐根及舍根。此诸法说第三禅

  离息入息出　　第四有四枝
  枝者谓说善　　随事如先说

离息入息出第四有四枝者。第四禅无入息出息。彼正受身毛孔合四大极密故。四支者。不苦不乐行舍净念一心。不苦不乐者。已离苦乐故。行舍者。不求余事故。净念者。护善根故念。离八上烦恼故净。八上烦恼者。谓四根觉观出入息离内外乱故。乱义择品当广说。一心者。于缘心不散。问初禅二禅何故不立正智耶。答喜及觉观乱故不立支种。以是故亦不立念。又不立行舍。猗乐与行舍相违故(乐动舍沉静)。问第三禅何故不立不苦不乐耶。答随顺无明品故。明无明相违。以是义故第四禅不立正智。问味相应等三种禅悉成就支耶。答支者唯说善。当知善禅与支相应非秽污。问秽污无何等。答初禅无。离生喜乐烦恼相应故。第二禅无。内净烦恼浊乱故。第三禅无。念及正知烦恼乐所迷故。第四禅无。净念及行舍烦恼相违故。复次初禅二禅无。猗乐一向善故。三禅四禅亦无。行舍随事如先说者。若事彼禅先已说。余禅复说者非未曾事增益。如初禅二禅说喜乐。当知此二枝非四。如是一切地。问此禅支有几。答

  禅支名十八　　事则有十一
  无色无有支　　禅眷属亦然

禅支名十八者。禅支名有十八。初禅有五支。第三禅亦尔。第二禅四支。第四禅亦尔。支前已说。事则有十一者。初禅五支名五。事亦五。第二增内净。第三增行舍念乐正智。第四增不苦不乐。初禅支非二禅支作四句。初禅支非二禅支者谓觉观。第二非初者。谓内净。亦初亦第二者。谓喜乐一心。非初非第二者。除上说。如是乃至第四禅展转说。无色无有支禅眷属亦然者。四无色及禅眷属不立支。以苦行故。支所摄禅是乐行。是故说彼地为苦道。若彼立支者。应一切地名乐道

  有觉亦有观　　是说未来禅
  禅中间有观　　明智之所说

有觉亦有观是说未来禅者。未至依有觉有观。未至者。是初禅眷属。禅中间有观明智之所说者。禅中间有观而无觉。修行者转寂静故。问何故初禅二禅立中间依非上地耶。答彼升降可得故。初禅有觉有观第二禅无。彼中间有观无觉故别立依。上地无此升降故不立

  未来或二种　　谓离味相应
  禅中间三种　　亦俱说一受

未来或二种谓离味相应者。有说。禅未来二种性。净及无漏。非味相应。彼虽有连锁缚(以爱力令未来禅受梵天生生死相连由初禅爱琐除此则二取此则三)。彼无正受爱。不除受生爱无过如是说者有味相应。禅中间三种者。禅中间有三种性味相应净无漏亦有味相应如余地。亦俱说一受者。未来及中间俱有一受谓舍受。未来者有畏故无乐受。近欲界故。修行者有畏故乐受不起。事未究竟故。修行者向离欲而未得故乐受不起。忧随生故。欲界缚有余故。如人被缚有解有余犹生疑畏不起乐受。彼亦如是。寂静劣故。如未来禅中间亦如是。随其义说已说地。所起功德今当说

  三摩提与通　　无量一切处
  胜处及诸智　　背舍于中起

彼三摩提者。三三摩提。空无愿(无愿应言无实)无相。彼善心平正故说三摩提。彼空者二种。谓有漏无漏。若有漏者一切法缘。无漏者有漏缘。此复九种。谓内空外空内外空有为空无为空有为无为空无事空第一义空空空。内空者。谓内入空作无我思惟。外空内外空有为空无为空有为无为空亦如是。无事空者。谓无彼彼物。第一义空者。谓眼起时无所从来。灭时无所至。如是比说。空空者。谓有漏空于无漏空作空空思惟。无愿亦二种。谓有漏无漏。俱二种缘。随其义说。彼复五种。谓内等三种及有为无愿无愿无愿。有为无愿者。于有为法以有漏无漏无愿。作无常等行思惟。余如空说。无相者。无相有二种。谓有漏无漏。彼复四种。谓于内入数灭以有漏无漏作灭止妙出无相思惟如是外及内外无相亦无相。无相三摩提修多罗品当广说。重三昧杂品当广说。通者六通智品已说。问若修神通作证道(证者显现义也谓不失所作则所作显也)。彼成神通时为起耶不起耶。答若解脱是无记者。彼则起(出定名为起。若解脱是无记者。则出三昧也。若是善即三昧也)。若善者不起无量者

  二无量无恚　　最后说无贪
  第三说喜根　　谓彼欲界依

二无量无恚者。谓慈及悲。是无恚善根性。嗔恚对治故。是处恚者以慈对治。非处恚者以悲对治。复次为舍众生命起恚以慈对治。为楚罚众生起恚以悲对治。是故求功德者。能起无量非求过恶。彼乃至断善根所亦求功德。谓见本净业。求过恶者。乃至阿罗汉所亦求过恶。谓见本不净业。最后说无贪者。舍无量是无贪善根性。谓无贪非欲爱嗔恚对治者不然。何以故。不绝无恚故。问舍是贪欲对治。不净观亦贪欲对治。何贪以舍对治。何贪以不净观对治耶。答色贪以不净观对治。淫贪以舍对治。第三说喜根者。喜无量是喜根性。随生法是五阴性。相者。以安饶益是慈相。除不安是悲相。随喜是喜相。任放是舍相。谓彼欲界依者(依者身也)。欲界现在前非余。何以故。乐饶益转故。谓见欲界众生苦。欲令得乐饶益。以除苦故。色无色界无苦。复次嗔恚对治故。慈无量者嗔恚过对治。如所说慈修习多修习除嗔恚。悲除害。喜除不乐。舍除欲爱嗔恚。色无色界无此诸过。又欲界有三方。除郁单越。问无量正受何等思惟。答

  乐苦喜众生　　众生无余想
  随其所应转　　无量众生缘

于彼众生欲令得乐。如是思惟入慈正受。于苦众生叹言苦哉欲令脱苦。如是思惟入悲正受。欣彼众生如是思惟入喜正受。惟彼众生无有余想。如是思惟入舍正受。问慈力不能令苦众生得乐。何故非颠倒耶。答善故。安希望所起故。正思惟相应故。嗔恚相违故。众生缘者。缘欲界众生。如所说若思惟满一方成就住者。此说器及器中。以是义故当知无量是有漏众生缘故。周遍总缘一切众生。谓四生离此更无有余众生。离欲得方便得离欲得者离欲时得后方便现在前。问云何方便。答慈者从亲起。谓欲起慈心时于一切众生立为三品。谓亲怨中。亲复分别下中上品。先于上亲品起真实希望。谓父母及余尊重者。谓彼久习恶希望故饶益心不至。还复摄心作饶益想。如是上亲乃至上怨得平等住。是名成就慈心正受。悲喜亦如是。舍从中品起。如是广说。名者。缘无量众生故说无量

  胜处说有八　　前三色背舍
  及八一切处　　无贪善根性

此诸善根当知无贪性。贪对治故。是有漏意解思惟故。问此非无贪善根性。何以故说观说想故。如契经说。内色想外观色。如是广说。观者是慧。是故胜处是慧性(阿毗昙解脱处云胜知胜见见即慧也)。背舍亦说色观。色是初背舍。是故前三背舍是慧性。如是一切处说地普一想。是故一切处是想性。而说无贪性者不然。答此诸善根无贪性。慧想增故。彼说见及想如宿命念及胜色想。是故无过。如曾灭处随念智念增故。言彼忆念曾所更无量事。彼亦是智。如胜色想是慧性。以想增故说胜色想。复次想近故说是故说。想无过无贪慧想不相离。一依一行一缘一果一依果(依果此依亦是津腻义也津腻果凡三种一从遍因生二从自分因生三从报因余势生谓杀生得短寿也)。是故说一。当知说余。云何知无贪性。贪对治故。此善根当知贪对治。若是无痴性者。应说痴对治慧。虽一切烦恼对治。痴最近故非贪。若一切处是想自性者。非烦恼对治。不决定故。是故当知此善根是无贪性

  若说彼眷属　　是则五阴性
  此说三方依　　境界欲界色

若说彼眷属是则五阴性者。当知此诸善根及眷属是五阴性。此说三方依者。此诸善根于三方身起。除郁单越。亦非余。何以故。此诸善根贪欲对治故。非色无色界有贪欲。郁单越虽有贪欲。慧力劣故是故不能起此善根。欲界诸天虽有贪欲。以着乐故亦不能起此诸善根。境界欲界色者。此诸善根缘欲界色。初二背舍前四胜处。作青瘀等行于色入处转。不净行转故。余者净行转。是故得为身念处。问何故彼修行者于缘受净相耶。答为试不净故。为成不成耶。观不净者懈怠心生。欲令摄持故。又欲自观知所堪能。作是念。以不净观不起烦恼未足为奇。净观不起乃为奇特。又现善根有所堪能故

  背舍中最后　　心不相应行
  是说二界依　　先从欲界起

背舍中最后心不相应行者。想受灭背舍是心不相应行性。问一切心心法灭何故说想受灭耶。答以此二力故令修行者于二界极生疲劳。受力故于禅疲劳。想力故于无色疲劳。受想义如阴中说。是说二界依者。欲界色界身现在前非无色。何以故。非心故。欲色界有色。是故彼心心法灭。命根依色转。无色中无色。若彼正受时。心心法灭命根应断。无所依故。应死非正受是事不然。先从欲界起者。灭尽正受先从欲界起。于彼退生色界。复离彼欲而现在前。问何故色无色界得初起禅无色非灭尽正受耶。答禅以三事故起。谓因力业力法方便力。因力者。谓彼于禅曾已近起。业力者。谓已作受业长养(有四法受业已作而长养)法方便力者。如劫成败时。无色界二事起。因力及业力。无法方便力。以彼无成败故。灭尽正受从说力起。说者欲界。谓佛及波罗蜜声闻说。是故彼欲界身能初起非余。欲界一入正受不过七日。揣食身故。若过者出则融消。色界一入正受时经劫住

  余则四阴性　　说彼三界依
  或无色境界　　及以无漏缘

余则四阴性者。余功德谓四背舍二。一切处四阴性除色阴。彼无色故。说彼三界依者。此功德三界现在前。空处背舍空处一切处。初从欲色界起(为舍色故修空故初从色处起也)。或无色境界及以无漏缘者。空处一切处空处地四阴缘。识处一切处识处地四阴缘。空处背舍缘四无色。及彼因。彼灭一切比智品。识处背舍缘三无色。余如上说。无所有处背舍缘二无色。余如上说。非想非非想处背舍即缘彼地及彼因。彼灭一切比智品。已说善根自性。谓成就功德今当说

  当知或有说　　成就四无量
  或复成就三　　减者则不然

若生欲界离欲界欲。及生初禅二禅成就四无量。若生第三第四禅成就三无量。除喜。喜根性在二禅非上地故。减此者无有

  或一乃至八　　成就于背舍
  或四亦复八　　成就于胜处

或一乃至八成就于背舍者。或有成就一背舍。或有成就乃至八。成就一者。若生遍净天。于彼爱尽果实爱未尽。若生果实。于彼爱未尽。若生空处。于彼爱未尽。成就二者。若生欲界。及生初禅二禅。于彼爱尽遍净爱未尽。若生三禅四禅。色爱尽空处爱未尽。若生空处。空处爱尽识处爱未尽。若生识处。即彼爱未尽。成就三者。若生欲界及初禅二禅。遍净爱尽果实爱未尽。若生遍净及果实。空处爱尽上爱未尽。若生空处识处(无漏生上不失下故生识处成就空处背舍如是一切也)。识处爱尽上爱未尽。若生无所有处即彼爱未尽。成就四者若生欲界及初禅二禅。色爱尽空处爱未尽。若生三禅四禅。识处爱尽上爱未尽。若生空处识处无所有处。无所有处爱尽。若生非想非非想处。不得灭尽三昧。成就五者。若生欲界及初禅二禅。空处爱尽识处爱未尽。若生遍净天及果实。无所有处爱尽不得灭尽三昧。若生非想非非想处。得灭尽三昧。成就六者。若生欲界及初禅二禅。识处爱尽上爱未尽。若生遍净及果实。得灭尽三昧。成就七者。若生欲界及初禅二禅。无所有处爱尽不得灭尽三昧。成就八者。若生欲界及初禅二禅。得灭尽三昧。此是总说。若有漏背舍者。下地离欲未生上地则皆成就。若无漏者生上地亦成就。或四亦复八成就于胜处者。或有成就四胜处或八。成就四者。若生欲界及初禅二禅。于彼爱尽遍净爱未尽。若生遍净。于彼爱尽及生果实。成就八者。若生欲界及初禅二禅。遍净爱尽

  或一亦复二　　八九及与十
  当知彼修行　　成就一切处

或有成就一一切处。或二或八或九或十。成就一者。若生空处。即彼爱未尽及生识处。成就二者。若生空处。于彼爱尽。成就八者。若生欲色界。遍净爱尽果实爱未尽。成就九者。若生欲色界。果实爱尽空处爱未尽。成就十者。若生欲色界空处爱尽。已说成就。谓随地功德今当说

  五通在四禅　　根本非余地
  诸智如前说　　三无量或六

五通在四禅根本非余地者。四根本禅成就五通非余地。除漏尽通。何以故。摄受支三摩提故。诸智如前说者。如前智品说。随地所得。三无量或六者。除喜余无量在六地。未来中间根本四禅。或有不欲令在未来。或复说初禅二禅不起悲喜。根相违故。喜根者是自性受喜行转。悲者忧行转。是故彼不相应。如苦集忍智者不然。何以故。真实行转故。若言苦集忍智极厌而与喜根相应悲行亦如是者。彼说有过彼真实思惟故。欢喜生悲者意解思惟。是故有过。如是说者。导真实思惟故无过。悲虽非真实思惟。而能导真实思惟。是故无过(欣于除苦故悲与喜俱也)。问悲大悲何差别。答悲者无恚性。大悲者无痴性。复次悲者共声闻缘觉。大悲者不共。复次悲者能悲不能度。大悲者能悲能度。复次悲者缘苦苦众生。大悲者缘三苦众生。悲者缘身苦。大悲者缘身心苦。问何故名大悲。答度大苦众生故名大悲。大贾得故名大悲。摄受大聚众生故名大悲。大士入大崄难故名大悲

  彼前四胜处　　及与喜无量
  亦初二背舍　　在于初二禅

前四胜处及喜等初二背舍在初禅二禅中。非余也第三第四禅虽有初二背舍相似善根而不建立。是故亦有初四胜处相似善根。如修多罗说。慈极至遍净。悲极至空处。喜极至识处。舍极至无所有处。有说。此经以无量名说圣道。彼受化者以无量名入圣道故。复次彼对治觉支以无量名说。谓第三禅对治觉支以慈名说。如是乃至无所有处对治觉支以舍名说。复次以相似名说者。谓慈者乐行乐受乃至第三禅。悲者苦行空处呵责色转喜者欣悦行识处者悦识住。舍者舍行无所有处说舍

  余有四胜处　　及与一背舍
  亦八一切处　　说在最上禅

后四胜处净背舍前八一切处在第四禅。非余下地。亦有净背舍相似善根而不建立。不净所坏故。是故亦有后四胜处相似善根。说地正受及地一切处。彼地正受在欲界及四禅。地一切处在第四禅非余。何以故。离八事恼乱故。欲界色欲有二种(身欲心欲也)。对治彼故。初禅立二背舍四胜处。初禅色欲亦有二种故。二禅立二背舍。二禅无二种色欲故。三禅不立背舍。乐胜乐故。不能起此等善根。及一切处以彼背舍入胜处。以胜处入一切处。以初背舍入初二胜处。以第二背舍入第三第四胜处。以净背舍入后四胜处。以后四胜处复入一切处

  余即名背舍　　二一切亦然
  灭尽最在后　　余无漏九地

余即名背舍者。除空处九无阂道及命终心。余善尽说空处背舍。无阂道向第四禅命终心向生是故不立背舍。当知余无色亦如是。二一切亦然者。空处识处一切处亦即名说。问识处上何故不立一切处耶。答修行者先入背舍观而不能胜。然后入胜处而不能无边意解观。然后入一切处无边青意解观。如是黄赤白复如是。思惟此色何所依。观依地大种然后入无边地意解观。余大亦如是。彼复如是思惟。云何升进。谓觉知。即先入空处一切处。彼觉知何依观依意识。彼即入无边识处一切处。此依更无所依。是故上不立一切处。灭尽最在后者。灭尽正受第一有中摄。何以故。随顺灭心故。次第渐微故易灭。问灭尽定不应第一有摄。何以故。如所说度一切非想非非想处想受灭成就住。答第一有摄。世尊以彼度诸正受及爱欲故说也。学者度正受住故说。无学者度爱欲故说。复次度一切非想非非想处者。此说见道断。想受灭者。此说修道断。如是曾习未曾习共不共离欲得及方便得尽当知。以胜故。不共故。界地究竟故。二背舍说身作证识灭尽正受。及入定心是有漏随顺灭心故。出定心有漏无漏。彼正受方便得非离欲得。若退而更起者。得未曾得非已曾得。余无漏九地者。若余无漏功德。谓三三昧漏尽通在九地。谓四禅三无色未来中间。有漏三昧在十一地。谓此九及欲界亦第一有

  三背舍当知　　有漏及无漏
  定智通已说　　其余悉有漏

三背舍当知有漏及无漏者。空处识处无所有处背舍。当知有漏亦无漏。定智通已说者。定前已说。诸智神通如智品说其余悉有漏者。余三通似工巧故。受色声自相故。无量者缘众生故。一切处胜处初三背舍得解思惟故。第一有正受不捷疾故。想受灭心相违故。皆悉有漏。问背舍胜处一切处何差别。答

  谓彼性背舍　　能胜所缘处
  无闇普周满　　名如所度说

不向故说背舍。胜彼处故说胜处。以胜处故世尊说胜处。虽非一切修行者能胜彼处。但于缘中烦恼不起亦名胜处。无边意解故说一切处。复次软善根说背舍。中者说胜处。上者说一切处。复次因说背舍。果说一切处因果说胜处。已说诸功德自性成就地有漏无漏。谓禅无色三种成就今当说

  未离欲当知　　成就味相应
  离下未至上　　成就净诸定

未离欲当知成就味相应者。若彼地未离欲。成就彼地味相应。离下未至上成就净诸定者。谓离欲界欲非梵天彼成就净初禅及初禅地余功德。凡夫人成就味相应及净。圣人成就三种

  住上应当知　　成就下无漏
  方便生功德　　当知非离欲

住上应当知成就下无漏者。圣人生梵天上。成就无漏初禅及余无漏三昧神通等诸功德。有漏诸功德生处缚。无漏不缚。是故离生处舍有漏功德非无漏。方便生功德当知非离欲者。已说离下地欲成就诸功德。当知得非现在。现在前者彼非离欲方便得者。谓天眼天耳智此无记性故。不入净无漏味相应。是故得彼三种禅时。不得作方便已乃现在前。六通二是无记。解脱道所摄故。余四是善。问此诸方便所得功德。何等断烦恼。何等不断烦恼耶。答

  根本净初禅　　是亦同一缚
  不能断烦恼　　无量亦复然

根本净初禅是亦同一缚不能断烦恼者。根本净初禅。自地烦恼一缚所缚故不能断烦恼。他地世俗道现在前时乃能舍离。如人被缚不能自解。彼亦如是。自地味所味故不能舍离。如人亲友虽劣不舍。彼亦如是。若诸烦恼根本禅对治者彼断得。若不断得彼非对治。是故无漏禅烦恼对治有漏者方便断。如是乃至非想非非想处。无量亦复然者。无量不断烦恼。缘众生故。法相者断烦恼。复次解脱道摄故无阂道摄者断烦恼。复次缘现在故缘三世者断烦恼以须臾治故。世尊修多罗说。慈断嗔恚。须臾治者。诸结暂息如负债宽期

  当知五背舍　　及与八胜处
  亦十一切处　　不能断烦恼

空处识处一切处及非想非非想背舍。此法根本所摄不断烦恼如前说。想受灭背舍心相违故不断烦恼。色背舍胜处一切处亦不断烦恼。自相境界故。共相道断烦恼非自相。复次意解思惟故。真实思惟断烦恼非意解。复次假想思惟故。不假想思惟断烦恼。复次事境界故。非事思惟断烦恼。复次解脱道摄故。无阂道所摄断烦恼。二十三种正受八味相应八净七无漏。问此三昧一一几种因。答

  所谓无漏定　　一一七种因
  味相应因一　　谓彼净亦然

所谓无漏定一一七种因者。无漏初禅于无漏初禅相应共有自分因。于无漏三禅三无色定自分因。如是乃至无所有处。此则总说。初禅所摄道有六种。随信行。随法行。信解脱。见到。时解脱。不时解脱。随信行道六种因。随法行道三种因。信解脱道四种因。见到道二种因。时解脱道亦二种因。不时解脱即不时解脱因。味相应因一者。味相应初禅味相应初禅因非余。初禅因不相似故非他地因。因果断故。彼味相应五种。见苦断乃至修道断。见苦断见苦断因。如是一切。谓彼净亦然者。净初禅净初禅因。非味相应非无漏。不相似故。非他地净因。自地系缚故。净初禅四种。退分住分胜分决定分。彼退分四种因。住分三昧。胜分二。决定分唯决定分非余。以劣故。当知余地亦如是。问一一次第生几种。答

  无漏禅无色　　逆顺超次第
  次第生六种　　七八九与十

无漏初禅次第生六种。自地净。及无漏第二第三禅亦如是。无漏无所有处次第生七。自地二上地一下地四。无漏第二禅次第生八。自地二下地二上地四。无漏识处次第生九。自地二上地三下地四。余无漏次第生十。比智品所摄。禅次第无色现在前非法智品所摄。法智品者下地依下地缘。是故次第无色不现在前

  从六至十一　　谓净次第生
  次生二至十　　味相应非三

从六至十一谓净次第生者。净非想非非想处次第生六种。自地味相应及净。下地四净及无漏非味相应。离欲故。净初禅次第生七。自地三上地四。净及无漏净无所有处次第生八。自地三上地一下地四。净第二禅次第生九。净识处次第生十。余十一此说方便得离欲得非生得。是故不说上下地味相应生得。净命终时次第生一切地味相应。问何等净初禅次第生圣道耶。答谓决定分。若异者不应建立四种。次生二至十味相应非三者。味相应初禅次第生二种。自地味相应及净。非无漏。烦恼相违故。非上地。未离欲故。非三者不生三。若说三者不然。第二禅味相应次第生四。自地二。除无漏。下地二味相应及生得净。谓第二禅爱畏故依。净初禅自护。如修多罗说。宁依初禅厌离俱思惟正受。不依第二禅劣思惟。第三禅生五。自地二第二禅二初禅一。味相应第四禅生六。空处七。识处八。无所有处九。非想非非想处十。自地二。无所有处二。下地味相应六。谓受生烦恼故。问一一缘几种。答

  净与无漏禅　　缘于一切地
  自地有漏法　　味相处所缘

净与无漏禅缘于一切地者。净及无漏禅缘一切地一切种。广境界故。彼无漏比智品缘八地。法智品缘一地。方便善根缘四谛。自地有漏法味相应所缘者。味相应初禅缘自地味相应及净非余。此义使品已广说。不缘无漏及他地

  无色则不缘　　下地有漏种
  谓根本善有　　秽污如味禅

无色则不缘下地有漏种谓根本善有者。无色根本净及无漏。不缘下地有漏法。离色相故。缘自地及上地故说非下。比智品缘下无漏故说非有漏种。以方便所摄无阂道缘下地故说根本(世俗道断结无碍下缘解脱上缘也)。味相应缘自地故说善有。秽污如味禅者。如味相应禅缘自地味相应。无色亦如是

  谓色界有余　　无量诸功德
  是则缘欲界　　最胜之所说

四无量等诸功德缘欲界前已说。除神通故说无量等诸功德。彼五神通缘欲色界。谓初禅者缘初禅及欲界非上地。余亦如是随其义说。净禅三种。一烦恼勋。二道勋。三不勋。烦恼勋者退分(有漏有烦恼气故名烦恼勋也)。道勋者道所勋。谓勋修。余者非勋。问彼何等禅能勋。答

  若能勋诸禅　　是依第四禅
  三地爱尽故　　净居唯果实

依第四禅勋初禅。何以故。离八事恼乱故。于一切依最胜故。有五种勋。软中上上中上上。此生五种净居。下地亦有五种勋。第三禅爱尽故。下地不生净居。彼所依或起不起勋(起不起是出定不出定也)方便者。以无漏第四禅流注具足正受。然后有漏次复无漏。于彼流注渐略。乃至无漏二刹那次第有漏二刹那现在前。此则有漏无漏勋禅方便成。若一刹那无漏一刹那有漏复一刹那无漏。是名勋禅成有十五心。五有漏心十无漏心。问何故勋禅。答

  或有念正受　　或畏诸烦恼
  或复乐受生　　是各随义说

勋禅有三因缘。念正受者。谓修行者爱念正受为现法乐住故。畏烦恼者。畏退故。乐受生者。乐生净居故。彼信解脱具三因缘正受。见到有二。不畏烦恼不退法故。时解脱亦二。不乐生背一切生故。不时解脱唯一。爱念正受不畏烦恼不退法故。不乐生背一切生故。勋禅五阴性。有漏及无漏缘四谛(以无漏散有漏如花散支提义言勋也)。如是广说。无漏心勋有漏心如花散支提。问已说三种正受彼云何得。答

  离欲及受生　　而得于净禅
  秽污退及生　　无漏唯离欲

离欲及受生而得于净禅者。净初禅二时得离欲界欲及上地没生梵天。问退时亦得。谓初禅离欲退得初禅退分善根。何故不说耶。答此中说一切净。先不得而得。退时退分善根虽先不得而得。余三种先成就(先失一得三今失三得一非先都无故非一切不得而得也)。是故不说。颇净初禅离欲得离欲舍退及受生亦如是耶。答有退分初禅。欲界离欲时得。梵天离欲时舍(梵天离欲时得胜分等故舍退分)。梵天离欲退时得。欲界离欲退时舍。上地没生梵天时得。梵天没生欲界时舍。乃至无所有处亦如是非想非非想离欲得非生。得无上地故。秽污退及生者。味相应初禅退时得。谓初禅离欲欲界及梵天缠退。生得者。谓上地没生欲界。及梵天如是。乃至无所有处非想非非想唯退得。无漏唯离欲者。无漏初禅离欲得。谓圣人离欲界欲。此说次第人。若依初禅超升离生亦得。乃至一切地亦如是。问此诸功德何等断烦恼。答

  无漏除烦恼　　及正受中间
  一切定中间　　相应于舍根

无漏除烦恼者。无漏根本初禅八地烦恼对治。乃至无所有处二地烦恼对治。及正受中间者。正受中间名方便道。谓断下地烦恼。乃至未离下地欲。不得根本正受。余非对治。一切定中间相应于舍根者。一切方便道舍根相应。未得故不生欢悦。问如所说上地无身识。若上地欲眼见耳闻身触时。彼云何见闻触耶。答梵世识现在前。问上地何故无此识耶。答前已说。上地觉观非分故无此三识身。上地欲见欲闻欲触。初禅识现在前则见闻触。非欲界非修果故。问何时成就。答

  随识现在前　　上地则成就
  舍则不成就　　心力羸劣故

乃至此识现在前。若眼识若耳识若身识。尔时成就。心羸劣不隐没无记故。是故刹那成就。从彼起已不随转。问已知善秽污正受得时及诸识成就。彼化心云何得一时得几心。答

  受生及离欲　　得是诸化心
  二三及与四　　亦五一时得

有二因缘得化心。受生及离欲。或顿得二三四五受生者。上地没生梵天。尔时得初禅果二心。一欲界。二初禅。若生二禅得三心。一欲界。二初禅。三即自地。生三禅得四心。下地三自地一。若生四禅得五心。下地四自地一。是说受生得。离欲者。离欲界欲得二心。如前说。初禅离欲得三心。二禅离欲得四心。三禅离欲得五心。是故说。或一刹那得化心而不断。欲界离欲时最后无阂道作四句。得而不断者。谓初禅地初禅果化心(离欲界欲时得初禅果化心此心为初禅结所缚故不断)。断而不得者。谓欲界第二第三第四禅果化心(三地化心是欲界法故为欲界烦恼缚离欲界欲缚断初禅未离欲故不得也)。亦得亦断者。谓欲界初禅果化心。不得不断者。谓余化心。乃至第三禅离欲随义说。于此十四化心。欲界四色界十。彼欲界化心化作欲界化。色界化心化作色界化。自分故。彼化八种。生欲界化欲界化。自身及他身如是。色界生色界亦如是。欲界化四入。色界化二入。何以故。不化根故。是故化无心一心一化或多。但一地也。住神足能令住。虽涅槃化随转。如尊者陀骠涅槃已化火烧身。尊者大迦叶全身久住。世尊化教化非分佛事竟故。般涅槃不留化。问为修慧化亦生慧耶。答亦生慧(退生得化心故是先离欲所得修惠也魔天化心是生慧也)。如魔化为佛身。魔天女化身诣佛所。若化人所食之食。若彼化主本欲自养身者。彼食现在。化主身中消也。若本不欲养身者。则彼食但聚在化人处也。问成就几种化心。答

  或有二三四　　五七及与九
  增三或亦五　　如是成化心

若生欲界欲爱尽。梵天爱未尽。及生梵天于彼爱未尽。是成就二。若生第二禅于彼爱未尽。是成就三。若生第三禅于彼爱未尽。是成就四。若生第四禅是成就五。若生欲界及梵天。梵天爱尽二禅爱未尽。是亦成就五。若生二禅二禅爱尽三禅爱未尽。是成就七。如是广说(应说九及增三五第四禅爱尽生第三禅生第二禅更增三生初禅更增五也)。问若欲界化初禅果。及初禅地化初禅果有何差别。答色界界胜故胜。又欲界第二禅果。色界初禅果欲界去胜(能至二禅故言去胜)色界界胜。一切化皆如是说(离欲得化心及方便得化心各有十四种上地下生时得先离欲所得十四种)

杂阿毗昙心论卷第七杂阿毗昙心论卷第八

        尊者法救造

        宋天竺三藏僧伽跋摩等译

    修多罗品第八

已说定。修多罗今当说

  一切智所说　　修多罗妙义
  我今当少说　　修行宜善听

知一切故说一切智。一切者。谓十二入。于彼自相共相一切悉知。所说者。一切智人亲自演说。妙义者。谓甚深性相微妙义也。此微妙义是修多罗说故言修多罗妙义。今者。谓此论。少说者。以牟尼所说无量无边故言少说。修多罗者。凡有五义。一曰出生。出生诸义故。二曰泉涌。义味无尽故。三曰显示。显示诸义故。四曰绳墨。辨诸邪正故。五曰结鬘。贯穿诸法故。如是五义。是修多罗义。虽义不在说而因说显现。故言说义。谓因说名转因名显义。善听者。宜一其心决定善听。问世尊说施戒修。彼一一有几种。答

  惠施持净戒　　是各有四种
  修禅则有二　　说名为功德

畏三种畏。欲方便令度三畏故。世尊略说此三种功德。彼畏贫穷畏者方便令度是故说施。畏恶道畏者方便令度是故说戒。畏生死畏者。方便令度是故说修。问何等为施性。答

  无贪相应思　　俱起同一果
  众具处所生　　此则是施性

无贪善根相应思。施物处所生。及随转身口业。是五阴施自性。以说色香味等具足故。言思愿等非施者不然。何以故。于物说施名世尊开发施主心故令思愿坚牢故。于物说施名即是施物处所生。问前说四种施。何等为施种。答

  所谓自摄受　　亦复摄受他
  或有二俱摄　　或二俱不摄

有自摄故施。有摄他故施。有摄自他故施。有报恩故不为摄自他施(谓阿罗汉供养佛为报恩故不为自他)。彼自摄者

  若未离欲者　　供养于支提
  及凡夫离欲　　是名自安施

圣人未离欲。及凡夫离欲。供养支提。则自摄施。以施受欲界报故。谓未离欲者生欲界故。凡夫虽离欲生色无色界。后还受欲界后报及不定报。是名自摄不摄他。何以故。支提非众生故

  离欲非凡夫　　除其现法果
  施与诸众生　　是名为摄他

若阿罗汉。若阿那含。除起现法果施。若余施为众生者。是名摄他非自摄。阿罗汉生非分故。阿那含虽受生在色无色界。而不受施果。以因果断故建立界

  未离欲界欲　　已离欲凡夫
  施与诸众生　　当知二俱摄

谓圣人未离欲。及离欲凡夫施与众生。当知二俱摄

  离欲非凡夫　　除其现法果
  供养于支提　　是则俱不摄

若阿罗汉。若阿那含。除起现法果施而供养支提。此非自摄亦非摄他。阿罗汉无生故。阿那含虽有生而欲界非分故不自摄。支提非众生故不摄他。彼忆念本恩。为报恩故佛虽般涅槃犹供养支提。复次

  或有为摄他　　供养于支提
  无量众见闻　　皆生随喜心

或供养支提亦为摄他。以幢幡花盖烧香散花供养支提。令无量众生见者随喜生天解脱因。是故世尊修多罗说。于未曾立处建立支提能生梵福。以摄无量众生故名梵福。问齐何当言梵福。答有说。除近佛地菩萨。诸余一切众生能生大富大力等增上果业。是梵福量。复有说者。世界成时一切众生。器世界生。此能生器世界业。是名梵福量。又复此施

  谓彼希望等　　七种施非上
  第八庄严心　　是名最胜施

世尊说八种施。谓希望施。怖畏施。反报施。期报施。家法施。生天施。求名施。为庄严心为调伏心为顺修行为得最上义故施。希望施者。选择福田欲求多果故施来求者。施来求者施是旧阿毗昙说希望施。怖畏施者。方于亡失施故施。谓见有失想宁施不失。反报施者。曾得彼利云何不报。期报施者。若施于彼期彼还报。家法施者。习先人施非自信施。生天施者。求生天故施。求名施者。为称誉故施。此七种施。慧所鄙故非上。不求生死乐施是名庄严心施。此道方便施故于财施中最为第一。是名上施。已说施。施果今当说

  寿色力安乐　　辩才等五种
  施报百千等　　施主之所获

布施如上说。五种如世尊施五德修多罗中说。食已寿非不食。是故施寿。乃至辩才亦复如是。相似因生相似果。谓得长寿乃至辩才报。如种外种随类收实。此亦如是。寿者。谓人天非恶趣。此以持因故说施寿。如说。离杀生修习多修习得长寿。此以招引因故说。譬如二种母。生母及养母。离杀生者如生母。施食者如养母。施畜生五种报得百倍福。谓和合者得。如是广说。见道中虽不食而能受施。已说施及果。谓即施即果今当说

  慈无诤灭定　　见道及无学
  从彼正受起　　施者得即果

慈心无诤三昧。灭尽三昧。见道阿罗汉果从此起已。若有施者得即果。何以故。于无量众生以安饶益相。是慈以慈熏身故。从此起已施者得即果。无诤三昧令无量众生烦恼不起。以广摄功德熏身故。从此起已施者得即果。灭尽三昧以广功德熏身故。似涅槃故。从此起已施者得即果。见道所断结永尽。以圣道熏身故。从此起已施者得即果。修道断结永尽心得自在住阿罗汉果。从此起已施者得即果。已说即果大果今当说

  父母若病人　　及与说法师
  近佛诸菩萨　　施者得大果

施此五种人得大果。何以故。父母长育生身恩故施者得大果。病者无所依怙增悲心故施者得大果。说法者增长法身故示人善恶故施者得大果。近佛地者积集功德广摄众生故施者得大果。问为思愿胜令施清净。为福田胜耶。若思愿胜者。何故世尊赞叹福田。若福田胜者。何故施一福田而果不得等耶。答思愿胜故施清净。福田因力故。是故先说思愿及眷属名布施福。以淳净心离身财求随智慧行。如是施者则获大果。若异者彼求名称施胜福田。非大人施。若以田力生罪福者。不成田力等。应得无间业而不得故。当知思愿力也。功德福田能起胜思愿。是故世尊赞叹福田。问已知长养生身施。长养法身施复云何。答

  善说诸经法　　远离诸颠倒
  不谤于牟尼　　是说为法施

于修多罗毗尼阿毗昙。真实分别不著名利广摄众生。是名法施。彼虽无想着而颠倒说。诽谤如来真实因缘。而作异想。当知此则乱心因缘。虽说不颠倒而心染着。如彼商人。是故偈说。不知牟尼说。如刀火及毒。于此善分别犹如食甘露。复次三种颠倒。谓法颠倒。人颠倒。时颠倒。法颠倒者。如有说。修习净想断贪欲。人颠倒者。谓贪欲者而为说慈。时颠倒者。人根未熟为说真谛。如是比与此相违名不颠倒说法。已说法施。无畏施今当说

  以离等受说　　安慰诸恐惧
  是名无畏施　　能坏贫穷怖

若见众生今世后世及俱恐怖。以离受戒。说慈心安慰言。众生勿怖。我当为汝所作。令得无畏。是名无畏施。彼恐怖如贫穷。与彼真实对治名无畏施已。说无畏施。大施今当说

  普于群生类　　等受戒律仪
  功德流增广　　是则为大施

世尊说五戒为大施。摄无边众生故。起无边乐故。财施者。不能摄一切众生。唯受戒则能。已受持五戒已。于一切众生尽形寿。念念中得十二种未曾得律仪(三善根二起身口作无作)。彼戒流注相续不断。问已知四种施。前四种戒云何。答

  欲界及禅生　　无漏戒律仪
  断律仪从二　　是说律仪种

四种律仪。谓别解脱律仪。禅律仪。无漏律仪。断律仪。别解脱律仪者。谓七众所受戒。禅律仪者。谓有漏随生戒。无漏律仪者。谓学无学戒。断律仪者。谓离欲界欲九无阂道随生戒。若有漏是禅戒。若无漏是无漏戒。此律仪。业品已说。已说四种戒。谓余四今当说

  或以希望受　　或以恐怖持
  有顺菩提支　　及与清净戒

有四种戒。所谓希望戒。恐怖戒。顺觉支戒。清净戒。希望戒者。谓求生天及余处故持戒。恐怖戒者。畏自责畏他责畏罚畏恶趣畏不活畏恶名故持戒。顺觉支戒者。为庄严心故为方便众具故求最胜义故持戒。清净戒者。谓无漏戒。离垢故。问云何净持戒。答

  根本眷属净　　不为觉所坏
  摄受于正念　　随顺般涅槃

有五因缘。戒清净。所谓根本净。眷属净。不为觉所坏。摄受正念。正向解脱。根本净者。离越根本业道。眷属净者。离杀生等方便。不为觉所坏者。离欲恚害三觉恼乱。摄受正念者。摄受佛法僧念。以是故亦离诸无记心。正向解脱者。为解脱持戒。不为身财及余所作。是故亦说随顺觉支。此五因缘。戒清净。世尊说得大果。离一切恼乱故。问已知一切正行所依戒如天德瓶。云何二种修。答

  禅无色无量　　得修及习修
  不净安般念　　二修义亦然

此诸禅等功德熏心。如熏衣如花熏麻如融金。是故如是说。如熏衣修。如熏麻修。如融金修。现在者习修。未来者得修。现在者用故。未来者起故。现在者作所作。未来者当作。现在者生故。未来者得故。现在者现前分。未来者成就分。禅无色无量。定品已广说。不净观者无贪性。贪对治故。又对治四种贪故复说四种。谓断威仪贪故修死尸观。断色贪故修青瘀等观。断触贪故去皮肉修骨琐观。断处所贪故修骨节分离观。此不净观复有四种。谓退分住分胜分决定分。退分者。住彼则退。住分者。住彼不进不退。胜分者。住彼必升进。决定分者。住彼顺圣道。界者欲色界。地者十地。欲界禅中间根本四禅及四眷属。依者欲界行者非行。缘者缘欲界。念处者身念处。智者等智。非三昧受生故三根相应堕三世。过去者缘过去。现在者缘现在。未来者若生法缘未来。若不生法缘三世。是善缘无记。是非学非无学缘非学非无学。是修道断缘修道断。当言缘义。问为方便得离欲得。答亦方便得亦离欲得。若离欲界欲得初禅。乃至离三禅欲得第四禅。后方便现在前。问不净观云何方便。答彼修不净观者。至冢间极善取彼相。取已还至坐处洗足安坐。柔软其身心离诸盖。取彼外缘以方己身。系心在足骨胫骨[跳-兆+專]骨髀骨臗骨膫骨脊骨胁骨手骨臂骨肩骨颈骨颐骨牙骨齿骨髑髅骨。若系心眉间。若乐略观者。先从身念处度。若乐广观者。从眉间观髑髅乃至足骨。从此一座一房一堂一僧伽蓝一村一乡一国。若但从想起者。非有是处。若周遍大地至眼光者。能观彼处白骨充满。若复略者。次第还至眉间系心眉间。是名不净观成。或有不净观。缘少非自在少。作四句。缘少非自在少者。谓于自身数数入不净观。自在少非缘少者。谓周满四海大地不净一时观察不能数数入不净观。缘少亦自在少者。谓一时观察自身不净而不能数数入不净观。非缘少亦非自在少者。周满四海大地不净亦能数数入不净观。复次不净观。缘无量非自在无量。作四句。缘无量非自在无量者。谓周满四海大地不清净而不能数数入不净观。自在无量非缘无量者。谓于自身数数入不净观。缘无量亦自在无量者。谓周满四海大地不净亦能数数入不净观。非缘无量亦非自在无量者。谓于自身不能数数入不净观。已说不净观。安般念今当说。安那者持来。般那者持去。亦名阿湿波裟婆湿波裟。念者忆念。于安那般那审谛系念心不虚妄。修习彼念故说修。安般念是慧性。于彼品念增故说安般念。如念处如念宿命。初起者。于母胎中脐处所业生风起。或向下或向上。向下者。造下身分身诸毛孔。向上者。造上身分身诸毛孔毛孔成已出息最初。乃至命终出息最后。正受亦尔。谓出初入定入初出定。六因缘得六种安般念。所谓数随止观还净。数者。修行者巧便系念数出入息。无一出入息而不觉知。若心乱者。或时减数。或时增数。或时乱数。减数者以二为一。增数者以一为二。乱数者出作入想入作出想。心不乱者名为等数。五出息五入息。此名十数。若修行者数时于十中间心乱者。还从一数起。若十数满已。若乱不乱。要还从一起。畏心散故不过十。畏心聚故不减十。于上无未曾数故。随者。出入息去无所行。而随为长为短耶。为遍身耶。为在一处耶。入为远为近。齐何转还耶。止者。随心所乐于身一分。系心令住而观察之。彼息于身为益为损为冷为暖。如是等。观者。修习极修习。如忆自己名。随其所欲而现在前。还者。若依欲觉者少行依出离觉者勤行。净者。净诸盖。彼修行者于出入息作一想。观身如竹筒。观息如穿珠。出入息不动。于身不发身识。是名安般念成。有说。亦起身识但不伤于身。又修行者于出入息以极微坏。是名身观。受出入息是名受即观。彼受是名受观。识出入息是名识即观。彼识是名识观。想出入息是名想即观。彼想是名想观(谓极微坏色色尽灭尽然后以喜及想识起令现前便即观彼三以为三念处方便种子)。非入息未灭而有出息生。非出息未灭而有入息生。是名因安般无常行度。入息逼迫故出息灭。是名苦行度。此名得方便无愿解脱门种子。出入息生住灭不自在。是名因出入息无我行度观。出入息离常等因彼故空行度。是名得方便空解脱门种子。于出入息生厌心向涅槃。是名得方便无相解脱门种子。依彼软三三昧中依中增。如是次第暖法乃至尽智无生智。问世尊说界。此云何。答

  二十说欲界　　色界或十六
  无色界有四　　处所次第说

二十说欲界者。谓八大地狱畜生饿鬼四天下六欲天。此二十说欲界。此诸众生以欲受身众具及第二。是故说欲界。色界或十六者。谓梵身梵富楼少光无量光光音少净无量净遍净无阴福生果实无烦无热善见善现色究竟。此十六处说色界。有欲令十七如前十六及大梵。彼众生受色身。非众具非第二。是故说色界。无色界有四者。谓空处识处无所有处非想非非想处。此处众生不受色身。离色欲故名无色界。问云何立三界。为爱断故。为处所故。若爱断者应有九。谓欲界爱断欲界。如是初禅乃至非想非非想处。若处所故立者。应有四十。如前说。答总爱断故说。谓欲界爱断欲界。如是色界爱断无色界爱断无色界。欲界不定故一使。色无色界定故不一使。问云何建立界。答处所次第说。有说。从下次第上。谓最下无择地狱。次大热地狱。如是次第乃至色究竟。色究竟上复有无择地狱。次第乃至色究竟。若离一欲界欲。则离一切欲界欲若得初禅神足。能到一欲界及一梵世。复有欲令周遍傍立界。问世尊说七识住。此云何。答

  善趣在欲界　　及色界三地
  无色三亦然　　是说为识住

欲界善趣。谓天及人。色界前三地。无色前三地。此七地说识住。有色众生者成就色身。种种身者种种形。种种想者苦乐不苦不乐想。是名初识住。复次种种身者如前说。一想者染污想。彼梵身天初生作是念。我从大梵天生。大梵天作是念。我能生彼尊卑处所故及觉观识身故。梵天有种种身。是名第二识住。一身者色身形处量等。种种想者乐及不苦不乐想。根本喜疲厌眷属舍根现在前。舍疲厌已喜复现在前。是名第三识住。一身一想者。一身如前说。一想者乐。是名第四识住。无色众生者不成就色身。离色欲故。度一切色想者。行离色故说。以色想眼识相应故。若离初禅欲度欲爱行。离第四禅欲度行色行。以是义故。说灭有对想。五识身相应故。不念种种想者。彼种种想。谓第四禅地普散以缘种种入故。若染污者缘十入。不染污者缘十二入。离欲扰乱故说。不念无量者。无量行故方便思惟空入。空正受故说空处入。空处入成就者。得成就彼地四阴。是名第五识住。方便思惟识入识处。是名第六识住。无量行非分故说无所有处。是名第七识住。问何以故。立七识住。答若识于彼乐住故说识住。恶道苦逼迫故识不乐住。净居天向涅槃故识不乐住。无想众生无心故。余第四禅或求无色或求净居或求无想故识不乐住。第一有不捷疾故识不乐住。复次若彼有坏识法故不立识住。恶道者苦根坏故。第四禅无想三昧坏故。第一有灭尽三昧坏故不立识住。问九众生居云何。答

  第一有无想　　是说众生居
  谓有漏四阴　　是说四识住

第一有无想是说众生居者。前说七识住及无想天第一有是说九众生居。问恶道何故不说众生居耶。答乐住非分故多苦故不乐住。净居天疾向涅槃故不乐住。余第四禅如前说。问四识住云何。答谓有漏四阴是说四识住。除识阴余有漏四阴说识住。有说。众生数阴说识住者不然。何以故。依行缘相应分义故名为住(依者识所依缘者能缘非所缘分者胡音云何婆他耶义云流注谓受生胎分相续过去未来虽非众生数亦有此五义故得为识住乎)。无漏法亦说。识住者不然。何以故。坏染污识故不立识住。识阴非识住。二非分故。先后不俱故。不顾自性故。自分识住自分阴。谓欲界住欲界如是比。不异界不异地不异身。问何故自分阴说识住非不自分。答以自分阴摄识故。问不自分心阴及非心阴云何名识住(他界心住时名非自分心阴无心法住时名非心阴)。答得相故。彼亦识住相成就。若彼自分识生者。彼则随转。彼有住识义。中间因缘碍故识不生非识住非分。问世尊说缘起。彼有何相。答

  烦恼及业事　　彼随次第生
  当知是有支　　众生一切生

三分缘起支。谓烦恼业事。此烦恼业及事。于彼彼生次第起名缘起支。当知是缘起支

  此诸分建立　　谓众生受生
  过二及未生　　中间说于八

此诸分建立。谓众生受生者。于此三分缘起说十二支。问此云何。答过二及未生中间说于八。彼过去生时诸烦恼分说无明。过去生时业说行。现在相续说识。彼相续已六入分未满说名色。诸根满分说六入。未能分别苦乐不苦不乐根尘识合说触。分别苦乐分齐而未能分别。烦恼分齐说受。乐受于可爱不可爱。若离若合愚爱生说爱。现在广生烦恼说取。更生后有说有。现在有种未来阴生说生。未来阴熟说老。未来阴舍说死

  三有支烦恼　　二业事则七
  七名前有支　　五则说后分

三有支烦恼二业事则七者。谓无明爱及取三有支。是烦恼行。及有二支是业余支说事。七名前有支五则说后分者。当知从无明至受七支。是名前缘起。余五支说后缘起

  前支五说果　　余二则为因
  后支三说因　　余二则为果

前缘起从识乃至受是果。无明行是因。后缘起前三支说因。后二支说果。问有支前后得展转合耶。答得。此云何

  前痴后爱取　　行有合亦然
  名色入触受　　是说同老死
  谓初受身识　　是则未来生

问已知有支。前后展转相摄。彼云何起。答

  烦恼起烦业　　彼业转生事
  事亦生于事　　亦复生烦恼

缘烦恼生烦恼者。谓缘爱生取。缘烦恼生业者。谓缘取生有。缘业生事者。谓缘有生生。缘事生事者。谓缘生生老死。缘事复生烦恼者前说名色六入触受即是后支老死。以是故说缘受生爱。亦说缘老死无明。是名为无始有轮。问有四种缘起。何等为四。答

  谓彼相续转　　刹那与连缚
  及前谓分段　　此则说缘起

相续转者是无始义。因果展转相缚故说缘起轮犹如满月始不可知。是故修多罗说。有爱本际不可知。应说无不应说不可知自有。有而不可知者不然。何以故。无言说因故。言说无者。若有问言。何故无则不容言说因说言不可知者。若问何故不可知。则答言无何等如满月轮始不可知。如是因缘相续缘起。满月轮始不可知。是故言不可知。一刹那顷一切有支现在前故说刹那。如识身论说于庄严事。无知故起贪。无知者是无明。贪者是行。于事知者是识识共起四阴是名色。名色建立诸根是六入。六入所著是触。触随觉是受。受所喜乐是爱。爱俱生缠是取。受当来生业是有。未来阴起是生。阴熟故是老。舍阴是死。展转相缚故说连缚因缘。根本展转久远义。非唯十二支说缘起。若生若所生一切有为法说缘起。尊者富那耶舍说。或缘起非已缘起者。谓未来法。已缘起非缘起者。谓过去现在阿罗汉命终五阴。缘起已缘起者。除过去现在阿罗汉命终五阴。诸余过去现在法。非缘起非已缘起者。谓无为法。分段间可得故说分段。彼过去生时烦恼。分说无明余如前说。问世尊说生及趣。为生摄趣为趣摄生耶。答

  生摄一切趣　　非趣摄于生
  谓生中阴增　　当知非趣摄

生摄趣非趣摄生。问何故。答谓生中阴增。中阴者。生所摄非趣摄。以到故说趣。中阴者。是去非到。是故非趣。生者谓四生。卵生胎生湿生化生。欲界具四生。色无色界一切化生。地狱化生。畜生四种。饿鬼化生。亦有胎生。人四种天化生。化生最广。以全二趣三趣少分故此亦最胜。问若最胜世尊何故不化生耶。答时不俱故。若有化生时则无佛出。佛出世时则无化生人。复次一切胜故。世尊一切胜所生种性于一切众生最胜。说法信受故。及断种性贡高慢故。趣者五趣。谓地狱畜生饿鬼人天。不可乐故说地狱。身横行故说畜生。从他希求故说饿鬼。意寂静故说人。光明故说天。有欲令阿修罗与天同趣。是故说言。汝先是天。问若然者何故不见谛耶。答谄曲所覆故。有说。是大力饿鬼。天趣不说故。问若尔者。释天云何与相习近耶。答贪色故。负多究槃荼勒叉。亦饿鬼趣摄紧那罗毗舍遮醯鲁娑迦阇罗颇求罗。畜生趣摄。问世尊说六界。此云何。答

  所谓四大种　　及诸有漏识
  亦色中间相　　此界说生本

所谓四大种及诸有漏识亦色中间相者。四大五识身及有漏意识亦色中间。谓眼所受是空界数。是名六界。问已说十八界。何故别说六界耶。答此界说生本。此界说士夫数建立生根本故。是故无漏法不立六界中。四大如界品说。问谛有何相。答

  谓性果诸行　　有漏是说苦
  因性则为集　　灭谛众苦尽

谓性果诸行有漏是说苦者。一切有漏行有因及缚性故说苦。因性则为集者。此有漏行是因性者说集谛。是故苦集是一物。因果故立二谛。灭谛众苦尽者。一切有漏法究竟寂灭。是说灭谛

  若无漏诸行　　是说为道谛
  此二因缘故　　粗细次第现

若无漏诸行是说为道谛者。一切无漏行说道谛。有相违故。问何故说名谛。答此二因缘故。有二因缘说谛。谓自性不虚及见。彼得不颠倒觉。虚空非数缘灭虽自性不虚。无记故无漏故不说谛。若法是苦。苦因离苦。苦对治故彼立谛。彼无漏故非苦非苦因。无记故非离苦。无为故非苦对治。是故说四谛病。病因无病药亦如是说。问圣谛有何义。答圣于此诸谛起真实觉及显示他故说圣谛。此逼迫相说苦。生相说集。寂止相说灭。出离相说道。问应前因后果。何故世尊前说果耶。答粗细次第现。虽如是。以随顺无间等故前说果苦粗故先无间等。如是比。灭虽微非道先施设说谛求灭粗非道。复次易度义故。从粗次第立粗者。欲界苦彼先无间等。后色无色界苦。色界苦虽粗。非无色界定故不定故是一无间等。问真谛无间等云何。为自相为共相耶。答谛故自相。阴故共相。问世尊说四沙门果为几事。答

  圣果事有六　　最胜在九地
  第三在六地　　二种依未来

圣果事有六者。六事说沙门果。谓无漏五阴及数灭。圣道说沙门。彼是此果。沙门果择品当广说。问此果何地摄。答最上在九地。阿罗汉果九地摄。谓未来中间根本四禅及三无色。第三在六地者。阿那含果六地摄。除无色。二果依未来者。须陀洹斯陀含果依未来。未离欲故。问道有何相。答

  随信行行法　　离烦恼迟相
  随法行行法　　离烦恼速相

随信行行法离烦恼迟想者。随信行所行无漏法。软根品所摄故当知是迟。若随信行所受当知信解脱时解脱。亦受同软根故。随法行行法。离烦恼速相者。随法行所行无漏法。利根品所摄。当知是速道。若随法行所。受当知见到不时解脱。亦受同利根故

  根本禅地中　　当知是乐道
  减及难得故　　当知是说苦

根本禅地中。当知是乐道者。谓根本四禅地软根法及利根法说乐道。止观等故。彼地道乐行。减及难得故。当知是说苦者。依余地道说苦道。以减故。谓未来中间止道减。无色定观道减。是以方便难得故说苦。非圣道是苦受性。亦非苦受相应。虽苦尽道亦无量分别。此地及根建立故说四。彼根本禅地。若利根说乐道及速道。若钝根说乐道及非速道。余地道。若利根说苦道及速道。若钝根说苦道及非速道。正升进故说道。正向解脱故说道。问云何不坏净。答

  佛及声闻法　　解脱亦余因
  清净无垢信　　圣戒谓决定

佛及声闻法解脱亦余因清净无垢信者。若于佛所得无学法起无漏信。是名于佛不坏净。若于僧所行学无学法起无漏信。是名于僧不坏净。若于涅槃起无漏信。除前所说法。谓于余苦集谛及菩萨无漏功德辟支佛无漏功德起无漏信。是名不坏缘法不坏净(别缘法宝故定不坏缘也)。若于佛法辟支佛法声闻法起无漏信。是名坏缘法不坏净(杂缘三宝故曰坏缘也)。圣戒者无漏戒。是四大净(信是心净戒是四大净也)。问何故无漏说不坏净。答谓决定故。真实智俱生无漏信。戒决定有漏信。为不信所坏。有漏戒为恶戒所坏。无漏者经生不坏。是以决定故无漏立不坏净。此义择品当广说

问修定有何相。答

  初禅若有善　　说名现法乐
  谓得生死智　　是说名知见

初禅若有善说名现法乐者。净无漏初禅现法安乐住。是名修定得现法乐。当知第四禅亦如是。初禅亦说后世乐住。然不一切。若退若生上地若般涅槃。后世乐不定故世尊说现法现法安乐住。谓得生死智是说名知见者。生死智通是名修定得。知见如力处说尽当知

  当知分别慧　　方便生功德
  金刚喻四禅　　是名为漏尽

当知分别慧方便生功德者。若方便生诸功德。从善法欲闻思修三界善及无漏。是一切说名修定得分别慧。金刚喻四禅是名为漏尽者。金刚喻定名最后学心相应。依第四禅。是名修定得漏尽。此世尊自已说第四禅一切菩萨无所有处爱尽。依第四禅超升离生乃至漏尽。问如意足何等自性。答

  善有为诸法　　方便之所起
  佛说如意足　　是亦说正断

善有为诸法方便之所起佛说如意足者。前所说方便所生功德。彼一切如意器故说如意足。自心自在起种种功德故说如意。彼如意足故说如意足。足支俱同一义。问何者是。答谓三昧。彼复四种增上分别。若欲增上起三昧名欲定。精进心慧增上起三昧亦如是。彼先欲故欲增上。欲生已求成故精进增上。精进方便已随顺求故心增上。于欲精进心正向如意足究竟故慧增上。若无慧者余则失。问何等为如意。何等为足。答定为如意。欲等为足。虽有受等诸法生。但取此生定故说此为足。此义杂品当广说。是亦说正断者。即此诸功德说正断。以正智火烧诸烦恼草故说正烧。此亦断诸烦恼故说正断。复次灭烦恼最胜故说正胜。彼过恶功德舍离长养。若防若增堪能故说正断。彼复四种。事分别故。如一刹那灯作四事。谓烧炷油尽器热破闇。如是一刹那精进现在前。作四事已生恶法等。如修多罗广说。息烦恼种道根断过去未来烦恼得。烦恼得断说过去灭未来不起。虽断一切有漏。以恶法极恶故。圣道相违故。唯说恶法断生。一果故说恶生。二果故说不善。已生善法相续住故说住。软中上增长故说重修增广。阿罗汉虽无不善法及断对治。而有坏对治(毁呰呵责是坏对治)持对治远分对治故。亦说四正断。色无色界亦如是

  此说四念处　　四圣种亦然
  如其增上生　　是皆随名说

此说四念处者。谓前说功德亦说念处。谓身受心法。内外俱自相共相随顺观故说念处。如贤圣品说。四圣种亦然者。谓前所说功德亦说四圣种。圣以此为种故说圣种。圣从彼生故说圣种。问圣种何等性。答无贪善根性。若眷属是五阴性。四种爱取对治故说四因。衣生爱因。乞食因。床卧具因。有无有生爱(无有爱者爱断灭上三及此也余爱总名有爱也)。随彼次第对治立四圣种。衣乞食摄药故。又不一切不一切时故药不别立圣种现在境界起故。知足立圣种非少欲知足于现在处起少欲于未来处起现在不取一钱难非未来转轮王圣种者。于出家者有二种胜。谓希望及受用。在家者唯希望。种者是故持义。是故别解脱律仪以无作为圣种。非作色无色界。虽无衣食然有圣种。谓无漏律仪。问何故此诸功德说如意足乃至圣种耶。答如其增上生。是皆随名说此诸功德。定增上生故说如意足。精进增上生故说正断。念增上生故说念处。知足增上生故说圣种。问世尊说三十七觉品有几种性。答

  净信精进念　　智慧及喜猗
  觉品相应舍　　思戒三摩提

如所说十事。余觉品分悉入其中。此云何。谓信是信根信力。精进是正断精进根精进力精进觉支。正方便念是念根念力念觉支。正念慧是念处慧根慧力择法觉支正见。喜是喜觉支。猗是猗觉支。舍是舍觉支。思是正思惟。戒是正语正业正命。三摩提是如意足定根定力定觉支正定。鞞婆娑欲令戒有二种身口业不坏故说十一事。问何故此诸法多种建立。答

  处方便自在　　软及利亦然
  见道亦修道　　故说三十七

处者正缘。处建立故说念处。方便者正方便故说正断。自在者自在功德故说如意足。软者信等五法软者说根。及利亦然者。此诸根若增上者说力。是故增上义说根。难伏故说力。问何者是根云何次第。答信精进念定慧。是根次第者。信因果能为一切善法根本。是故前说信。信已舍恶修善故精进方便。精进方便已心于境界念住。心住已于缘不乱。不乱已堪能观察。复次于法观察已心定。心定已随正念住。正念住已正堪能。正堪能已信业果。是说逆次第。问云何立五根。答地故建立彼初业地信修。导一切胜法故。见地精进修见道速进故。薄地说念。修念住令贪恚痴薄故。离欲地说定。修定修根本禅故。无学地说慧。修慧永离无明故。说力亦如是。见道者。见道道支修见道速进故。正见乃至正定。彼于法显示自相共相故说正见。思量正义故说正思惟。邪命所不摄口四恶行数灭离故说正语。邪命所不摄身三恶业数灭离故说正业。邪命数灭离故说正命。正方便堪能故说正方便。正念缘不忘故说正念。执正一心念故说正定。次第如修多罗说。正见者。彼正见是道亦道支。余者是道支非道。如定是禅亦禅支。余者是禅支非禅。如说。定八种亦如是。修道者。修道觉支修道所断烦恼种九品断顿极觉故。以觉义故说觉支。彼择法觉是觉亦觉支。余者是觉支非觉。次第如修多罗说。问何故喜猗舍立觉支非道支。正思正语正业正命立道支非觉支。信俱非耶。答随顺觉故。乃至知缘常生喜。乃至生喜常生觉。谓息一切事及舍常生觉。于进不随顺故非道支。进去是道义。喜者不去。乐住处故。猗舍与去一向相违故不说道支。戒者于道轮为毂故立道轮支非相应故非觉支。正思策正见故于进去随顺非觉故。立道支非觉支。信者始习度。觉道者已度。是故俱不立。是说三十七者。此十法各别。事分别故世尊说三十七。彼初业地说念处于身等分别修故。暖法说正方便。生圣智火暖故。顶法说如意足。得顶法功德自在故。忍法说根。彼于进增上故。世间第一法说力住。彼势不可伏故。见道说道支。速进故。修道说觉支。觉悟故。以数渐增故。先觉支次道支。四乃至八。此诸觉品

  二禅三十六　　未来亦复然
  三四及中间　　是悉三十五

二禅三十六者。除正思地无思故。未来亦复然者。未来禅亦三十六。除喜难起故(未来难生喜)。三四及中间是悉三十五者。第三第四及中间禅三十五。除喜及正思

  初禅说一切　　无色三十二
  最上二十二　　欲界亦复然

初禅说一切者。初禅具三十七品。无色三十二者。三无色三十二。除喜正思正语正业正命。最上二十二者。非想非非想处无道支及觉支。道支虽有漏在觉支后说。当知是无漏。是故修多罗说。三十七觉品一向无漏故。如修多罗说。修不净观俱念觉支。彼以不净观调心故。然后觉支现在前。欲界亦复然者。欲界二十二。问四食在何地有何性。答

  诸食中抟食　　欲界说三入
  识食思及触　　是食说有漏

诸食中抟食欲界说三入者。抟食是欲界中三入处。谓香味触。事则有十三。谓十一触及香味。随其所应彼或以草或以木或以根或以果或以五谷或以汁或以香或以温暖。如是比。识食思及触是食说有漏者。谓识思触若有漏者。持生相续及招有故。是故说食。无漏触等虽摄持诸根四大而不招有。断有故。是故非食。问何故色非食。答色粗故非食。坏色故不名食。色不能极摄诸根四大。摄义是食义。此义择品当广说。问三三昧一一有几行转。答

  无愿有十行　　二行是空定
  四行说无相　　是说为正行

无愿有十行者。无愿三昧十行转。所谓无常行苦行集四行道四行。二行是空定者。空三昧空行及无我行转。四行说无相是说为圣行者。无相三昧灭谛四行转定品已广说。问四颠倒云何。断何等性。答

  谓彼四颠倒　　当知见苦断
  三见自性增　　见实者分别

谓彼四颠倒当知见苦断者。一切四颠倒不远寻根本故苦处起故见苦断。毗娑阇婆提欲令有十二颠倒。所谓无常常倒想倒见倒心倒。余亦如是。彼八种见道断无常无我六(此二各有心想见故六也)。苦有乐见倒不净净见倒四。见道修道断苦。及不净想倒心倒(乐净见一向见谛断乐净想心见道修道断以见谛者见断而想心不尽)。如是说者此义不然。何以故。颠倒是见性故。想心为见所乱故。说想心颠倒受等。虽为见所乱非世所傅故不说。若问须陀洹云何染著者。烦恼不断故。如在家须陀洹我倒断。犹起男女结。非法想起男女结彼亦如是。三见自性增见实者分别者此四颠倒。是三见自性但说少分。见真实者所建立。问何故。答以增上故。若彼见增上分建立颠倒。谓如身见中立我见是倒。非我所见边见中立常见是颠倒。非断见见取中立乐净见是倒非余(计恶为好计劣为胜如是一切不立倒也)。悉是见取但以轻故。问何故余见不立倒。答三事故说倒。所谓决断妄置一向倒(一向倒谓正反如转下为上)。谓彼邪见及边见所摄断见。虽决断及一向倒。而非妄置。从坏事生故。戒取虽决断及妄置。不一向倒。谓少实于少实处起故。阿毗昙说。身见见取全倒。无始久习倒。烦恼断已。须陀洹斯陀含犹染着境界。问世尊说多见何见摄。答五见摄。问此云何。答

  诽谤于真实　　此见是邪见
  不实而妄置　　是二见及置

诽谤于真实此见是邪见者。若见诽谤真实。谓无有(无有谤施戒等)无苦等是说邪见。不实而妄置是二见及智者。于阴不实妄置我我所是身见。妄置乐净是见取。若于余处所不实而妄置士夫等。如是一切是邪智非见

  非因而见因　　是说为戒取
  若摄受边见　　依断灭有常

非因而见因是见说戒取者。谓于彼无因而见因。是戒取。如为自在天故。断食等求生天。能辨性及士夫得解脱性者(世性谓能知世性与士夫异者得解脱也)。若摄受边见依断灭有常者。若相似相续隐覆无常行而见常是常见。不识因果分相续而见断是断见。除此五见更无余见。是故说一切见五见摄。问此见云何断。答

  诽谤及妄置　　因见及二边
  于此诸事转　　或见彼则断

诽谤者。说邪见若谤苦。当知见苦断苦处起故。见集等亦如是。如见灭道断见取戒取异处生见异处断。以此义故欲界上缘烦恼亦如是说。不实而妄置者说二见。彼身见苦处起故见苦断。见取者若于果不实而妄置者见苦断。于因起者见集断。于见灭所断起者见灭断。见道所断起亦如是。非修断决断故。戒取者非因见因。若于有漏处起者见苦断。若见道所断处起者见道断。断常见见苦处起苦者见苦断。问世尊说二十二根彼云何。答

  谓眼等四根　　身根有三种
  意根及与命　　是根生死依

谓眼等四根者。如界品说。身根有三种者。身根说三种。谓身根男根女根。意者意根前已说。以意界即意根故。及与命者。寿说命根。是根生死依者。此诸根生死依故立根。问根有何义。答

  增上是根义　　五根说四种
  当知余四根　　各有二增上

增上是根义者。彼增上义是根义。端严义是根义。胜义是根义。上义是根义。主义是根义。虽一切有为法各各增上。然或劣或胜。当知胜者立根如人主天主。问增上义有几种。答眼等四种增上。谓眼等五根四种增上缘。所谓令身端严。导养己身。依生识不共事。彼眼根令身端严者。若眼根不具人不喜见。多所憎恶不为增上。导养己身者。若眼见安危去危就安令身久住。依生识者。依眼生眼识及相应法。不共事者。唯眼见色非余。耳根令身端严导养己身如前说。依生识者。依耳生耳识及相应法。不共事者。唯耳闻声非余。余根令身端严如前说。导养己身。此三根通抟食令身久住。依生识者。此三根各各生自分识。不共事者。各行境界。当知余四根各有二增上。男根女根有二事增上缘故胜。谓众生别相别始者。一众生二根生已。众生别及众生相别。复次烦恼清净故。谓此二根具足能作不律仪。乃至能作五无间业断善根。清净者。谓受律仪得果离欲种三乘种子。若无形二形不能起如是善恶。命根者。种类相续及持。意根者。续当来有自在随转。有相续者。如所说香阴有二心展转现在前。若爱若恚自在者。如所说心牵世间。如是广说

  受或烦恼分　　信等依清净
  九根若无漏　　此三依于道

受或烦恼分者。苦乐喜忧舍受。随顺烦恼分。为增上缘。谓受熏诸烦恼。以受乐着故。烦恼乐着。复次受为烦恼清净增上缘。烦恼分者。如所说乐受贪使。苦受恚使。舍受痴使。清净分者。如所说乐己心定因。苦集信依六出离。舍行信等。信等依清净者。随顺清净故。信等五根修清净分。九根若无漏是三依于道者。信等五根喜乐舍及意根。此九根有漏无漏。若无漏者。依道故立三根。若随信行随法行道所摄。是未知根。若信解脱见到道所摄。是已知根。若无学道所摄。是无知根。已说诸根。余因缘择品当说。问此诸根何界系。答

  欲界四善八　　色种根有七
  心法则有十　　一心三根二

欲界四者。谓男根女根苦根忧根欲界系。余色根及意根。如界品说。如意根。信等及舍根亦如是。乐根喜根。若有漏欲色界系。无漏则不系。命根杂品当说。三无漏根不断故不系。问几善。答善八。谓信等五根三无漏根。是善爱果故。命根及诸受有报果当说。余如界品说。色种根有七者。眼等七根是色。余者非色。问几性心。几性心法。几非心。几非心法。答心法则有十。谓信等五根五受根。此是心法。心相应故。一心者意根。是心自性。得心相故。命根等八。非心非心法。无缘故。三根二者。无漏三根有二种。谓心法及心。性多集故。问几有报几无报。答

  于此诸根中　　一及十有报
  十二中是报　　命根唯是报

于此诸根中一及十有报者。忧根一向有报。彼善不善有漏故。现在方便生故。非报生。非威仪。非工巧。非学习法故。亦非无漏。从烦恼生故。意根不善善有漏是有报。无漏无记是无报。三受亦如是。苦根善不善是有报。无记是无报。信等五根若有漏是有报。若无漏是无报余命根等八是无报。无记性故。三无漏是无报。问几是报几非报。答十二中是报。谓色根七有是报有非报如界品说。意根及四受或是报或非报。若善不善果是报。命根唯是报者。命根一向是报有欲令是正受果。问初生时得几根报。答

  二或六七八　　最初生时得
  当知欲界报　　色六无色一

二或六七八最初生时得。当知欲界报者。此诸根渐渐生。谓胎生卵生湿生。彼初生刹那得二根。谓身根命根。彼刹那意根。是秽污非不秽污。心相续受生故。舍根亦如是。余根亦得而不说。非报故。化生无形六。谓五色根及命根一形七二形八。此一向说欲界。色六无色一者。色界得六根。一向化生故无男女前已说。无色界唯一命根。问命终时几根最后舍。答

  舍四八与九　　或复舍于十
  渐终及顿没　　善舍各增五

舍四八与九。或复舍于十渐终及顿没者。无记心渐命终舍四根。谓身意命舍。若无形无记心一时命终舍八根。谓眼等五根意命及舍根。无记心一形九二形十。不善心亦尔。问善心舍几根。答善舍各增五。若善心命终各增信等五根。是说欲界没还生欲界者欲界没生上界者。除无形二形。离欲俱非分故。色无色界命终。随所得根亦如是说无渐命终。此说诸根现在前舍非成就舍。不隐没无记说得舍。善者于此命终即此生说行舍。若生余处则得舍。问几见断几修断几不断。答

  二断无断四　　六根则二种
  三无漏不断　　余则修道断

二断无断四者。谓意根乐根喜根舍根有三种。或见断或修断或不断。彼随信行随法行道断说见断。信解脱见到道断说修断。无漏说不断。六根则二种者。谓忧根见断及修断。信等五根修断及不断非见断。不染污故。三无漏不断者。一向无漏故。余则修道断者。谓余九根修道断。命根等八不隐没无记故非见断。堕生故非无断。苦根五识身相应故非见断。从烦恼生故非不断。问若成就根彼成就几根。答

  或成就三四　　五七及与八
  十一与十三　　是说定成就

若成就意根必成就三根。谓意命舍。余或成就。或不成就。眼耳鼻舌根若生色界必成就。若生欲界得而不失则成就。若生无色界及生欲界。处胎渐厚诸根未满及得而失则不成就。身根若生欲色界必成就。生无色界不成就。乐根生遍净天若下及圣人生上必成就。凡夫生上不成就。喜根生光音天必成就。余如乐根说。苦根生欲界必成就。生上界不成就。忧根未离欲必成就。离欲不成就。信等五根不断善根必成就。断则不成就。三无漏根随地圣人必成就(见地修地无学地也)。凡夫不成就。如意根。命根舍根亦如是。若成就身根必成就四根。谓身意命舍。余如前说若成就乐根亦成就四根。谓命意乐舍。若成就眼根必成就五根。谓身意命舍及眼根。耳鼻舌根亦如是。若成就喜根亦成就五根。谓喜乐意命舍。若成就苦根必成就七根。谓身意命四受除忧根。若成就男根必成就八根。谓前七及一形。女根亦如是。若成就忧根亦成就八根。谓身意命及五受。若成就信根亦成就八根。谓信等五根及意命舍。精进念定慧根亦如是。若成就已知根必成就十一根。谓意命喜乐舍信等五根及已知根。无知根亦如是。若成就未知根必成就十三根。谓身意命苦乐喜舍信等五根及未知根。问几根得沙门果。答

  九根得初果　　或获二沙门
  谓以十一根　　究竟第四果

九根得初果者。九根得须陀洹果。谓意根舍根信等五根未知已知根。未知根无碍道。已知根解脱道。俱有七根。或获二沙门者。若倍欲尽得斯陀含果。九根如前说。若欲爱尽得阿那含果。亦九根八根如前说。三受随所用说。若次第得斯陀含果。世俗道七。谓意舍及信等五根。无漏道八。前七及已知根。次第得阿那含果亦如是。谓以十一根究竟第四果者。十一根得阿罗汉果。谓意根及三受信等五根已知根无知根。已知根无碍道无知根解脱道。问此云何为分定为用定耶。若分定者阿那含果亦有三受。若用定者无此三用。尚无二受一时行。何况三耶。答用定身故。非刹那故。谓以乐根得阿罗汉果。于彼退已复从喜根得。若复退已复从舍根得。而阿那含果以此受得。若彼退者还从此受得非余。问世尊修多罗说六识身。此诸识识何境界。答

  若取诸根义　　五种心境界
  若取一切法　　是则说意识

若取诸根义五种心境界者。色等五境界五识所取。眼识取色乃至身识取触。受自相故。及现在境界故。若取一切法是则说意识者。意识缘一切法。共相境界故。思惟故。数数念故。此义广说如界品已说。识境界智境界今当说

  欲色界诸阴　　无色与无漏
  有依无依八　　及彼二无为

有十法欲界相应不相应。色无色界亦如是。有为无漏相应不相应二种无为善及无记。问此十法智所知一一智几法为境界。答

  五法应当知　　法智之境界
  比智七为缘　　他心境界三

五法应当知法智之境界者。谓欲界相应不相应无漏相应不相应无为善。比智七为缘者。谓色无色界及无漏相应不相应无为善。他心境界三者。谓欲色界及无漏相应心心法境界故

  有漏当知十　　因果智有六
  解脱一道二　　余二境界九

有漏当知十者。等智行一切十法。广境界故。因果智有六者。苦集智知六法。谓三界相应不相应有漏境界故。法智比智故。解脱一者。灭智缘一法。谓无为善数灭境界故。道二者。道智缘二法。谓有为无漏相应不相应学无学境界故。余二境界九者。尽智无生智缘九法。除无记无为四谛境界故。问诸使何所使。答

  自地诸烦恼　　定使于自地
  自种一切遍　　随使于彼种

自地诸烦恼定使于自地者。彼欲界烦恼即使欲界法。乃至第一有亦如是。胜故对治故下不使上。离欲身行故上不使下。自种一切遍随使于彼种者。自种诸法自种使所使一切遍亦他种。五种境界故

  若定三界法　　三界使所使
  二界生当知　　一界亦复然

若定三界法三界使所使者。三界所摄五种法。彼三界一切使所使。如是一切法随所应说。二界生当知者。二界所摄法。二界烦恼所使随其所应。谓觉观欲。色界五种。彼欲色界一切使所使。谓意根。三界五种。彼三界一切使所使。如是一切法随其所应。一界亦复然者。若定一界法彼一界使所使。谓忧根。欲界五种。彼欲界一切使所使。如是一切法随其所应

  此经牟尼说　　其性已分别
  识知及诸使　　当知是三门

此佛所说修多罗。我已具分别。当以三门通。所谓识门智门使门。如施欲界修道断五阴性。彼七智知。除比智灭智道智。欲界故除比智。有漏故除灭智道智。三识识。谓眼识耳识意识。四入摄故。欲界一切遍及修道所断使所使戒八智知。除他心智灭智。三识识。谓眼识耳识意识。欲色界一切遍及修道所断使所使。修者不放逸性九智知。除灭智。意识识三界一切遍及修道所断使所使。一切修多罗皆如是说。随其所应。若总说义。欲知摄者当观界建立。欲知智门者当观谛建立。欲知识门者当观入建立。欲知使门者当观种建立。如是说者此则易知(修多罗品竟)

杂阿毗昙心论卷第八杂阿毗昙心论卷第九

        尊者法救造

        宋天竺三藏僧伽跋摩等译

    杂品第九

  已分别诸法　　一一定相续
  于上众杂义　　是今当略说

已分别诸法一一定相续者。已说诸法展转相续种种品类。于上众杂义(谓决定应相续说者已说竟即此义上众杂义于此品说)。是今当略说

  有缘亦相应　　有行及有依
  心及诸心法　　是同一义说

此是诸心心法。名差别有彼缘故说有缘。于境界转故时依行缘事俱转故说相应。有行者是慧。智品已说。彼于缘作行故说有行。依他转故说有依

  从缘生亦因　　有因亦有为
  说处及与道　　有果应当知

此是诸有为法名差别。彼彼缘和合等生故说从缘生。生余法故说因。由因力故说有因。因缘等作故说有为。能生说故名说处。过去未来现在道所摄故说道。彼有果故说有果

  有罪亦隐没　　秽污下贱黑
  善有为说习　　亦复说名修

有罪亦隐没秽污下贱黑者。此是不善及隐没无记诸名差别。与罪俱故说有罪。是可恶厌义烦恼上烦恼所覆故说隐没。是漏所覆义烦恼垢所污故说秽污。极鄙故说下贱。闇冥故说黑。黑者有二种。秽污黑及不可意黑。此说秽污黑。不说不可意黑。以不可意黑亦有不善报黑故。善有为说习亦复说名修者。此是善有为法诸名差别。彼善法所摄及爱果故说善。增长功德故说习及修。此说得修及习修(亲近是习义种义是修义现在名习未来名修)。故说善有为。对治修断修者。一切有漏法亦说修。问何等为心不相应行。答

  无想二正受　　亦众生种类
  句味与名身　　命根与法得

无想者。彼无想众生受生心心法灭。有说。无想正受果。有说。名第四禅眷属果。有说。乃至有心是有心果。无心是无心果。问为前心多为后心多。答有说。后心多前心。乐欲速入无想。如是说者此不定。或前多或后多。若以此威仪入无想正定。即以此威仪入无想住。从彼起已谤涅槃乘。后报业生欲界。彼报业尽不起余业故。二正受者。无想正受灭尽正受。无想正受者。遍净爱尽上爱未尽。先作出离想。思惟心心法灭。从欲界起非余。此根利故。凡夫起非圣人。无有圣人于有作出有想。方便得非离欲不退转。问无想正受无想何差别。答无想正受是因。无想是果。此善彼无记。此有报彼是报。此有行彼无行。灭尽正受者。离无所有处欲先止息想思惟心心法灭。问此正受云何。答心心法灭相续中间心不相应行随流四大诸根住。是说灭尽正受。余如定品说。种类者。众生身诸根支节事业饮食相似。彼种类有六种。所谓界种类趣种类生种类处所种类自身种类性种类。界种类者。欲界众生欲界众生种类。色无色界亦如是。趣种类者。于一趣生一趣种类。生种类者。受一生一生种类。处所种类者。生无择狱无择狱种类。乃至第一有亦如是。自身种类者。同生一界一趣一生(一生者四生中一)。而有种种自身如众鸟。如是比。性种类者。所禀性同是性种类。若六种类相似者。是名种类。句者。集诸名味究竟显义。味身者是字身(味者是字胡音中有味声谓是字之模法非今形色字也)。名者名诸法。以名显义。如名男女。命者寿。谓得阴界入不坏。问命行寿行何差别。答有说。无差别。有说。宿业果名寿。修果名命。问世尊何故舍第五分寿。答善究竟佛事故。余事声闻究竟故。复次住四圣种故。有及众具尽无余故。得者得诸法。得成就同一义。后当广说

  谓彼凡夫性　　及诸法四相
  非色不相应　　说是有为行

凡夫性者。谓不得圣法。四相者。谓生住老无常。行品已说。非色者。此诸法非色性。四种及造色非分故。不相应者。无缘故。说是有为行者。他为故。为他故。问此诸行几善几不善几无记。答

  二善五种三　　当知七无记
  二在于色中　　一在无色地

二善者。无想正受灭尽正受。是善修性故。五种三者。得生住老无常善中善不善中不善无记中无记。生等与法一果故。得者非不自分故。当知七无记者。无想种类句味名命根凡夫性。问此诸法几欲界系几色界系几无色界系。答二在于色中。谓无想天无想正受色界系。无想天第四禅果故。无想正受第四禅摄故。一在无色地者。灭尽正受无色界系。第一有摄故

  二界说有三　　余在于三界
  有漏无漏五　　余则尽有漏

二界说有三者。句味名身在欲色界。非无色界。语非分故。余在于三界者。种类得命根凡夫性诸得相在三界。普遍故。问几有漏几无漏。答有漏无漏五。谓四有为相在无漏法中则无漏。有漏法中则有漏。与法一果故。得者若得有为亦如是。若得数灭或有漏或无漏。共凡夫故。若得非数灭是有漏。无记故。即以此义说系不系。余则尽有漏者。无想天无想正受灭尽正受众生种类命根句味。名凡夫性。一向有漏。有摄故。问离圣法名凡夫性。云何舍云何断。答

  初无漏心中　　当知舍不得
  凡夫流诸界　　离欲时灭尽

初无漏心中当知舍不得者。圣人初无漏心生时舍凡夫性。初无漏心谓苦法忍相应。彼生时舍凡夫性。若言起已舍者。彼住苦法忍时。应非圣人。不舍凡夫故。是故说生时。是故佛说二法生时究竟其事。内事谓苦法忍眷属。外事谓诸光明。凡夫流诸界者。凡夫流诸界时。若此地命终即舍此地。若生彼地即得彼地。不隐没无记故。非究竟舍。不得圣法故。离欲时灭尽者。若离此地欲若凡夫及圣人。尔时断此地凡夫性。不隐没无记故。问三无为有何相。答

  烦恼断离系　　是名为数灭
  无诸障阂相　　是说为虚空

烦恼断离系是名为数灭者。以智慧断身见等烦恼及眷属。得于此得离系。此诸离系名数灭(谓药病种数相对也)有说。唯一灭事无自分故有众多得。若此得灭得证即此涅槃。是故涅槃不共。毗婆沙说。于此系事即此离系事。若异者见苦所断结种断。余烦恼亦应断。作证一事故。若尔者后诸对治则应无用。但未究竟故。是故事各别无自分因故说无自分。此无自分因亦不与他苦法忍及眷属虽无自分因而与他自分因。彼品非分故说非品。烦恼灭故说涅槃。无边说故言非说。胜一切法故说最胜。智果故说智。不动故说无生。在解脱道边故说边。出一切法故说出。离无常等过故说妙。无诸障阂相是说为虚空者。谓不障阂种种色。以有来去等故说虚空。譬喻者说虚空非色亦非非色。言虚空者。随顺世间故说。有说。非无虚空容有故。若无虚空者。不应容有。容有故是故有虚空事

  依于诸缘法　　有依及境界
  不具则不生　　此灭非是明

一切有为法依缘及境界力生。羸劣故。彼非分则不生。如眼识依眼色明空及彼忆念和合故生。一一不具则不生。余识现在前时念念顷余眼灭余眼生。众缘不具故眼识不得生。若眼识应依彼眼生者则不生。依等已灭故至竟不生。以先无方便而灭故说非数灭。如眼识一切识身亦如是。又无漏者随信行道进得。随法行道非数灭。一切道亦如是。随其义尽当知。问若此胜进道得何故非道果摄。答为余事故。断烦恼故。勤方便不为非数灭故。是故非道果摄。问一切有为法说因谁为谁因。答

  前因相似增　　或俱依倚生
  二因及一缘　　一向已生说

前因相似增者。前法为后相似法因及增因。非软因。谓修法时。若住若增非减。或俱依倚生者。谓相应因及共有因。二因及一缘一向已生说者。谓自分因已生说。非未生。前者后因。未生者无前后故。一切遍因亦如是。次第缘亦已生说。因缘义行品已说。问报当言众生数非众生数耶。答

  报谓众生数　　有为解脱果
  有缘说俱行　　谓于他相转

报谓众生数者。报说众生数。不共故。不以他眼见。亦不成就。余报义亦如是。衣食等众具当知是功用果增上果。非众生数。以共故。问果云何。答

  有为解脱果　　一切有为法
  说果有因生　　故及数缘灭

亦说道果。果义业品已说。问心心法云何于缘转。答有缘说俱行。若有缘法俱于缘中转。办一事故。问于何缘转。答谓于他相转。心心法缘他法非自性。何以故。无二决定不自行故。亦不缘相应一行一缘故。亦不缘共有同一果故。此义择品当广说。问心心法为有方处为无方处。答

  普因无方处　　生时心解脱
  烦恼在道心　　乃至灭时舍

普因无方处者。心心法普因生。谓因二眼生一识。耳鼻识亦如是。若有方处所者。应于一眼中转。若然者应一眼见色。不应俱见。此义界品已说。若言二识俱生者不然。何以故。第二次第缘非分故。一识住二眼见色者不然。无分故。若一识住二眼中者。应有分生。若住左眼者非右眼。方处别故。此则非说。无色无分故。若复一识住二眼者。彼二眼间身根中亦应生。若尔者眼识即身识。若中间不生者。应断作二分。非一前已说。无二识俱生故。问何世心解脱。答生时心解脱。道生时是烦恼灭时。是故道生时心解脱。如坻塘漏近水先出。彼亦如是。又说。一切未来心解脱非独生时。但以初解脱故说生时。问道生时断烦恼为不。答烦恼在道心。乃至灭时舍。道灭时灭。烦恼事究竟故。生时是未来。云何未来道能究竟事。是故说无阂道灭时断烦恼。问有爱有几种。答

  有爱有五种　　无有唯一相
  爱事余烦恼　　灭尽是三界

有爱有五种者。有爱贪于有有五种。谓见苦集灭道修道断。以五行种有贪故。无有唯一相者。无有爱谓见断。已于自报断生乐着。是修道断。何以故。见贪见道断。此贪随报。无常起报者修道断。不隐没无记故。报无常亦如是。与报同一果故非见道断。贪缘修道断。非一切遍故。此无有爱。须陀洹斯陀含不断而不行。断见所长养故。如悔疑所长养。须陀洹斯陀含亦不行。问世尊说三界。断界无欲界灭界。此云何。答爱事余烦恼灭尽是三界。彼爱尽是无欲界。事尽是灭界。余烦恼尽是。断界。取近对治故。论者如是说。世尊修多罗说。一切行尽名断界。无欲界灭界亦如是问十二法欲界善不善隐没无记不隐没无记。色界三除不善。无色界三亦如是及学无学。此十二法几秽污心中得几善心中得几无记心中得。答

  若得九种法　　当知秽污心
  善心得六种　　无记即无记

若得九种法当知秽污心者。界及地来还时。欲色界得七心(上界没还生色界时得欲界化无记心及色界三心)。及欲界善。善根续时得退时。得三界秽污及学心。余不得者。谓无色界善不隐没无记及无学。虽无色界善少有退得。谓退分。但此中说悉不成就而得。此则通说。非一人一心中得九法。善心得六种者。善心中得六心。欲界不隐没无记。色界善不隐没无记。无色界善及学无学亦通说。非一时得。无记即无记者。不隐没无记即得无记非余。羸劣故。问道品十法几根性几非根性。答

  道品有六法　　当知是根性
  诸法若相应　　是说为他性

道品有六法当知是根性者。信等五根及喜觉支。当知是根性。得根相故。余者非根性。问相应者为自性为他性。答诸法若相应是说为他性。诸法他性相应。非自性。无有一性二刹那俱起故。前与后不合故。自性不自为故。此义行品已广说。问于何解脱。答

  缘中得解脱　　大仙之所说
  亦有断而缚　　见道及修道

缘中得解脱大仙之所说者。当知缘中得解脱。不能于相应解脱。一刹那故。心与烦恼俱生故。众生于缘中愚。即彼起不愚烦恼解脱。问断即解脱耶。答若解脱即是断。亦有断而缚。有少断非解脱。谓苦智生。集智未生。见苦所断烦恼断。见集所断一切遍使缚。彼缘未断故。及修道一品断。余八品缚乃至八品断。第九品缚一使故。彼八品先断后解脱。第九品即断。即解脱。余一切亦如是。问见谛云何得不坏净。答

  二解于三谛　　四由见正道
  而得不坏净　　修习于二世

二解于三谛四由见正道而得不坏净者。苦集灭无间等得法不坏净及圣戒。道无间等得四不坏净。此义择品当广说。问何等世修。答修习于二世。现在者习修现在前故。未来者得修不现前故。得随续故。过去非修。现在因非分故。问何等法随心俱转。答

  一切诸心法　　说与心俱转
  亦此心诸相　　余相及所作

一切诸心法说与心俱转者。一切心法与心俱转。与心同一果故。亦此心诸相者。此心生等相亦与心俱转。亦与心同一果故。余相者。此心法相亦与心俱转。及所作者。作名无作戒由心故。亦与心俱转。亦与心同一果故。问断法云何。答

  断法谓有漏　　知者亦无垢
  灭未来说远　　余则说于近

断法谓有漏者。有过故。如衣有垢则浣非无垢。彼亦如是。问知法云何。答知者亦无垢。若有漏无漏法一切说知随其事。何以故。除无知故。问远法云何。答灭未来说远。过去未来法说远。远现在识故。此说时远。四远义行品已说。余则说于近者。现在说近。与识身俱故。无为说近。不系方处故。随彼彼方得灭。由道故。非数灭。离勤求故。世义界品已广说。问定法云何。答

  所谓无间业　　及诸无漏道
  慧说名为定　　见处谓有漏

所谓无间业及诸无漏道慧说名为定者。无间业说邪定。定趣地狱故。无漏行说正定。定趣解脱果故。余者不定。问世尊于菩提树下于一切众生建立三聚。为建立众生分齐耶。为建立法分齐耶。若众生分齐者。云何说不得众生边而众生无边。若法分齐者。声闻亦应建立。云何说如来不共耶。答有说。众生分齐总相非自相。谓说四生。除此更无众生。问若然者声闻亦应建立。如来声闻何差别。答有差别。如来自力建立。声闻从佛闻。此则差别。又说。如来建立众生分齐。声闻缘觉建立法分齐。世尊建立三聚众生已。今犹安乐众生大悲故。昼夜三时以佛眼观察众生。问见处云何。答见处谓有漏。一切有漏法是见处所秽污见俱。若法秽污见缘使及相应使。彼说见处。又说。缘自界见力故。有漏法得见处名。非余缘使。非分故。如是好者谓前说。问若众生成就根。彼成就几根。答

  说有十九根　　谓成就极多
  极少成就八　　晓了根所说

说有十九根谓成就极多者。圣人极多成就十九根。谓未离欲具诸根。若住见道除已知无知根及一形。若住修道除未知无知根及一形。凡夫不断善根具诸根及二形。除三无漏根。极少成就八晓了根所说者。极少成就八根谓余(谓身根渐死余有少分也)身根善根断渐命终生无择地狱大山所迫。唯有身根命根意根及五受根。若生无色界凡夫。意命舍信等五根问有几种触。答

  增语(以多名故说增语)及有对　　明无明处中
  所谓得果者　　是则双道事

增语及有对明无明处中者。增语者。若意识身相应触。缘一切法故说增语。又缘多名故说增语。虽第五触亦缘多名。彼五识初得名故无过。若五识身相应触。依有对根故说有对。无漏者说明。触明相应故。秽污者说无明。触无明生故。不秽污有漏者说非明非无明。触俱不相应故。此五触随顺不随顺相应依分别故说十六种。随顺不随顺建立者。谓爱恚相应触相应分别故说苦乐不苦不乐触。依分别故说眼耳鼻舌身意触。问得果者为无阂道为解脱道。答所谓得果者是则双道事。双道俱得果。无碍道及解脱道。无碍道断烦恼。得解脱道得解脱证。又说无碍道得果。解脱道护彼所作事令不失故。如是说。问世尊说厌已离欲。云何厌云何离欲。答

  若智在苦因　　及忍说为厌
  能离贪欲故　　说四为离欲

若智在苦因及忍说为厌者。缘苦集智及忍说厌。缘可厌事故。苦集谛恶行烦恼所依故。说为厌事。能离贪欲故说四为离欲者。若忍及智于四谛转尽说为离欲。坏贪欲故。虽离一切烦恼。但贪欲是诸烦恼足。是故说离欲。彼憎不乐背恶。此厌之差别。离欲灭解脱断尽。此离欲之差别。问阿罗汉住何心般涅槃。答

  罗汉住报生　　及与威仪心
  随顺心灭故　　趣向般涅槃

阿罗汉住报生及威仪心而般涅槃。何以故。随顺心灭故。善心坚住于心灭不随顺。无记心羸劣。羸劣故于心灭随顺。复次少过故善心依果报。果门过生故。无记唯有依果门无报果门。复次背诸趣故。若向诸趣者彼必善心勤现在前。莫令我生恶趣中。是故彼背一切趣故住常性心。有时彼身分中善心空如断善根。不善心亦空如离欲界欲。复次渐离生死故。谓于欲界离欲离不善心第一有离欲离染污心。无记心现在前离善心。命终心现在前离无记心。尊者说曰(此达摩多罗以古昔达摩多罗为尊者)。勤相续者善心。彼命终时不随转也。有说。欲令下地有不苦不乐报者。彼说欲界。乃至第四禅报生及威仪心般涅槃。无色界唯报生非威仪。色非分故。有欲令下地无不苦不乐报者。彼说欲界。乃至第三禅唯住威仪心般涅槃。余如上说。问几种有。答

  生有及坏有　　本有亦复中
  当知二刹那　　一染三有二

生有及坏有本有亦复中者。生有者谓生分。五阴与生俱故名生有。相续心俱生义。坏有者死边。五阴与死俱故名死有。没心俱起义。本有者。除生分死分五阴。彼中间有。本业所种久住故故名本有。中有者。死已乃至未得余生有。于其中间向受生有。五阴趣所不摄。于二中间起故名中有。问此诸有几刹那几久住。答当知二刹那。死有及生有。各刹那顷。不久住故。以此义当知本有中有久住。问几染污几不染污。答一染三有二。生有一向染污。以染污心故生相续非不染污。彼欲界凡夫三十六使。一一使令生相续。圣人修道断四使。一一亦如是。色界凡夫三十一使。一一使令生相续。圣人三使。无色界亦如是。使令生相续非缠垢。余有染污不染污。问修行者几时极为业所障碍。答

  若离欲界欲　　越度第一有
  及与起忍法　　极为业障碍

于此三时修行者。业极作障碍。谓圣人离欲界欲时。彼欲界业极作障碍。义言汝若离欲。我于何处受报。以圣人离欲界欲不受欲界生死永得苏息故。以不退果命终故。谓取阿罗汉果时。彼受后生报。业极作障碍。义言汝度第一有无复生处。我于何处受报。谓住顶法起忍时。彼受恶趣报。业极作障碍。以起忍法永离恶趣故。余如前说。问事有几种。答

  当知有五种　　自性及与因
  系缚若摄受　　一切境界事

五种事。所谓自性事。因事。系事。摄受事。境界事。自性事者。若法自己性以事名说。如所说若得事是成就彼事。因事者。如所说云何有事法。答言有因。系事者。如所说若此事爱结系。即彼事嗔恚系耶。彼五种法以事(五种法是五行也)。名说摄受事者(如受取之受也)。如所说田事家事。如是比。境界事者。如所说一切法智所知随其事。若法彼法缘以事名说。复有异五种事

  说阴即为事　　界入事亦然
  及与世刹那　　是名五种事

若说阴即以阴为事。非余种。如是乃至说刹那即以刹那为事。非余种。如是略说。同实异名尽当知。问如业品说五种果云何。唯此果复有余耶。答有欲令更有四果

  育多婆提说　　安立及方便
  亦说和合修　　是名为四果

安立果者。如水住风轮。水轮是风轮安立果。如是一切。方便果者。谓从不净观方便。乃至起尽智无生智。彼尽智无生智是不净观方便果。如是一切方便(此是以因求果趣向方便也)尽当知。和合果者。谓眼色明念和合眼识生。如是法和合生法。此法是和合果。修果者。谓色界道欲界化化及作欲界语。彼化及语是色界修道果。如是一切。问神足几种(胡言栗地或言神足或言如意足或言自在或言富满皆义出耳悉不全得本名)。答

  运身及意解　　意念自在通
  意念唯如来　　当知二则共

三种自在。运身自在。意解自在。意念自在。运身自在者。举身陵虚犹若鸟飞。意解自在者。远作近解。屈申臂顷至色究竟。意念自在者。如眼识至色顷随意即至。此意念自在者唯佛非余。一切智所知到彼岸故。当知二则共者。运身自在及意解自在。如来缘觉声闻共。是禅果故。问一切阿那含入色无色界不。一切信解脱得见到不。一切退法者必退不。答

  入色无色界　　亦复增益根
  及与贤圣退　　生中间定无

圣人还受生者。如前所说。余因缘定无(还受生者定不至上二界亦不增进根亦复不退)。还受生者。谓欲界得果还生欲界者。厌于处胎见有之过。不入色无色界。以寿长故也。久修圣道故。不能增进根。如下亲友不能舍离。彼亦如是。生中间修习圣道故不退。问何时佛出世。何时转轮圣王出世。何时辟支佛出世。答

  劫减佛兴世　　增时转轮王
  二时辟支佛　　如是应当知

劫减时佛兴于世。顺解脱师故。佛是解脱师。为舍生死出世说法。增时众生向生死见转胜乐故。若尔时佛出世者则为空出。以众生不能舍生死极着乐故。减时众生背生死见。烦恼恶行极增上故能舍生死。是故乃至百岁众生时佛乃出世。非减也。若减者尔时众生非法贪不正贪。谓乐生天悉行邪法。勤利烦恼非善法器故。转轮圣王多于增时出于世间。能以十善建立众生。是故减时不出。以彼众生向恶行故。是故增时易化。时淳故。初减时转轮圣王亦出。于世犹淳故。辟支佛二时出世。作自事故。问得为有得得为无。若得复有得者。此得复应有余得。云何非无穷。若无得得者。得云何成就。答

  若彼诸法生　　二得共俱起
  二得俱生者　　当知有得得

若诸法生。即彼法二得。俱生得及得得。彼得力故成就法及得得。得力故成就得以得及得得故。俱一心中展转相得。是故非无穷。彼色阴行阴一得。余阴亦如是(初得能得一阴及小得)。有为无为一得(初得能得无为及小得)。欲界善戒恶戒。若过去者三世得。若现在者现在未来得。若未来者即未来得。欲界善及秽污四阴。色界善五阴及秽污四阴。无色界善及秽污四阴。无漏五阴。变化心共生四阴。三世三世得随其类得。威仪四阴。多以世断及刹那断得。若彼善修者三世得。工巧亦如是。无记色及报生四阴。以世断及刹那断得。过去过去未来未来现在现在。问苦法忍有几得。乃至道比忍有几得。答

  诸得有十五　　得于苦法忍
  其余见增道　　当知一一减

诸得有十五得于苦法忍者。苦法忍有十五得。以见道十五心故。一切心彼得生一得。与彼忍俱生。十四后生。其余见增道当知一一减者。见道名见增。惠增上故。余见道渐度一一心中得转减。苦法智十四得一俱生十三后生。无前生未曾得故(苦法智俱生得今始起故无前生故十四余无前生故渐少)。苦比忍十三得一俱生十二后生。苦比智十二得一俱生十一后生。乃至道比忍一得俱生无后生者。见道究竟故。无前生未曾得忍故(既无后起又无前生故唯一也)。问解脱得何地摄。答

  若于彼地中　　断及坏对治
  即摄解脱得　　法智比智品

若于彼地中断及坏对治即摄解脱得者。有说。若彼地断对治。彼解脱得。即彼地摄。由断对治故。如是说者。谓欲界见道修道断解脱得禅未来摄。初禅地未来初禅及中间摄第二禅四地摄。即前三地及第二禅。第三禅五地摄。即前四地及第三禅。第四禅见道修道断及无色见道断六地摄。即前五地及第四禅。空处修道断七地摄。即前六地及空处识处。修道断八地摄。即前七地及识处无所有处及非想非非想处。修道断解脱得九地摄。未来中间根本四禅及三无色。又有说者。若彼地摄断对治及坏对治。此说欲色界见道修道断无色界见道断解脱得六地摄。无色界修道断如前说。法智比智品者。又复有说。若地法智品。欲界见道修道断解脱得即彼地摄。若地比智品。色无色界见道修道断解脱得即彼地摄。此说欲界解脱得六地摄色无色界解脱得九地摄。问若道俱起得。彼得是俱起道因不(唯除所作因余通问)。答

  与道俱起得　　俱起而非因
  道亦非彼因　　后起或有无

与道俱起得俱起而非因者(俱起道与得既非共因又无余因故相与无因也)。道俱起得彼非道因。不一果故。不一果则无共因义。道亦非彼因者。得俱起道亦非得因。亦不一果故。问后起得云何。答后起或有无。前起道于后起得或有因或无因。与后相似增道得相似增解脱得因。非软道得软道解脱得因(此是自然因故不为中上因非上下因)。谓苦法忍一得俱生。彼得非忍因。忍亦非得因。苦法智三得俱生。二道得一解脱得。苦法智非彼诸得因。彼诸得亦非苦法智因。彼苦法忍三得因。苦比忍四得俱生。三道得一解脱得。苦比忍非彼诸得因。彼诸得亦非忍因。苦法智三得因。非苦法忍得因。以忍劣故(比忍比智及解脱得)。苦比智六得俱生。四道得二解脱得。苦比智非彼诸得因。彼诸得亦非智因。苦比忍三得因非三得因。谓法智品中得乃至道比忍二十二得俱生十五道得七解脱得。道比忍非彼诸得因。彼诸得亦非忍因。道法智三得因(法智自于未来得解脱得及比忍得作自然因下诸得劣故非因)。非余因。问空空何行何自性何缘何地摄耶。答

  空行有垢住　　是说为空空
  说无学境界　　在于十一地

空行生已空空后起。空行观五盛阴空。彼空空起于彼空思惟空。如人烧死尸时执杖转侧然后烧杖。彼亦如是。有垢者。谓有漏义。击圣道故。空空击圣道。不以圣道击圣道。以无漏厌行不缘无漏故。住者。三昧自性。空空者。于空行空义。无学境界者。以无学为缘义。谓无学空行是彼缘。又说。缘空行俱生五阴。十一地者。有漏故。普境界空。空空十一地。欲界乃至非想非非想处。问云何无愿无愿。答

  行于无常行　　是无愿无愿
  俱在于不动　　欲界余如前

行于无常行是无愿无愿者。无常行相应无愿。观五盛阴无常。于彼后起无愿无愿。思惟无愿无常。若苦行者则为颠倒。圣道非苦性故。亦非因等行与圣道相违故(以无愿无愿与圣道相违故不作因等行)。若作因等行者。应顺圣道。然彼击圣道。以违圣道故亦不道等行。以道等行乐道故。俱在于不动者。谓前说空空及无愿无愿。此二是不动法阿罗汉能现在前三昧。有势力故。离烦恼故。见到者虽利根得自在三昧。然未离烦恼故。时解脱虽离烦恼。不得自在三昧。钝根故。不时解脱者得自在三昧。利根故。离三界欲故。是故能现在前非余。欲界者。欲界现在前多从说力起故非余。除郁单曰余三方。余如前者。余事如空空说

  谓无相无相　　彼行于寂止
  行于无记灭　　余则如前说

谓无相无相彼行于寂止者。无相者。于数灭观寂止。于彼后起无相无相行。义言汝非数灭亦寂止。问彼何缘。答行于无记灭非数灭。是彼缘是无记。亦不起非数灭。不起如前说。以是义故不说灭行。以有二种灭。谓非数灭无常灭。若言灭行者。不知何等灭。亦非妙出行。以无记非妙非出故。非三相所成故。止余如前说者。余如空空说。又彼三昧。利根者尽智生时得后方便现在前。佛不方便辟支佛少方便声闻或中或上。空空无愿无愿法智比智苦智后现在前。无相无相法智比智灭智后现在前。若欲界三昧禅未来所摄圣道后起。若非想非非想地无所有处圣道后起。余者自地次第。问超越三昧云何正受。答

  超越三摩提　　上下至第三
  及不念思惟　　于缘超亦然

超越三摩提上下至第三者。谓超越三昧正受时。有漏初禅次第。有漏第二禅现在前。如是次第乃至非想非非想处。然后次第还至初禅。于此诸地善修习已起无漏初禅。次第乃至无所有处。又复次第还至初禅。又此地善修习已。复起有漏初禅正受。从初禅起超入有漏第三禅。第三禅起已入空处。空处起已入无所有处。逆超亦如是。此地善修习已。然后起无漏超正受。是名超越方便。然后能有漏初禅起。次第入无漏第三禅正受。无漏第三禅次第有漏空处。有漏空处次第无漏无所有处。逆超亦如是。是名超越正受成就也。相远故不超第四正受也。三方不时解脱能起非余。何以故。离烦恼故。自在三昧势力故。如前说。及不念思惟于缘起亦然者。若不秽污而断境界者。彼因不忆念思惟(境界有间名为断或有染心而缘断境界故举不染以别之因不念思惟者率尔能缘超至三也)。亦至第三。谓初禅缘欲界。次第上缘初禅二禅而正受(此中明境界超而也文言唯次第将先后超如上三昧中故举始以明终耳)。缘初禅次第下缘欲界。次第上缘第二第三禅也。初禅缘二禅。次第下缘欲界及初禅。上缘第三第四禅如是。一切地尽当知。无色不缘下。前已说。虽苦法智次第苦比忍生乃至缘第一有。此不断境界故(相接不断故虽远非超也)。净背舍次第虽缘自地心起。或缘上地。但彼染污。问佛语当言善为无记耶。答

  佛语善无记　　如彼初心转
  究竟亦复然　　无记或清净

佛语善无记者。若调伏处方便而说是善。如说一切行无常一切法无我涅槃永灭。如是比。若彼不方便说是无记。如问阿难何故园中高声大声。如是比。如彼初心转究竟亦复然。无记或清净者。世尊以善心发语。即以善心究竟。无记心发语。或无记心究竟。或善心究竟。无有善心发语无记心究竟。说时转增不减故。问声闻云何。答

  声闻则不定　　究竟及与转
  说时不退减　　唯是佛世尊

声闻则不定究竟及与转者。声闻善心发语或善心究竟或无记心究竟。无记心发语或善心究竟或无记心究竟。问何故世尊善心发语善心究竟。声闻善心发语无记心究竟耶。答说时不退减唯是佛世尊。唯佛世尊说时不退。声闻者舍利弗等说时犹退。问几入可烧几入能烧。答

  诸入中有四　　可烧亦能烧
  可称亦能称　　断能断无惑

诸入中有四可烧亦能烧者。色香味触可烧亦能烧。不相离故。有说。此四入可烧不相离故。更有一入能烧。谓火大得烧相故。可称亦能称者。即前说四入可称亦能称不相离故。有说。四入能称一种可称得重相故。断能断无惑者。即前说四入可断亦能断。此中无惑说。问地地界何差别。答

  地谓色形处　　坚相说地界
  余二亦二种　　风即风或异

地谓色形处者。色形处是地。色入所摄眼识识此世闻名。地界说坚相者。坚相是地界。触入摄身识识。此则第一义。余二亦二种者。水及火亦二种。色形处是水。湿润是水界。色形处是火。熅热是火界。余如前说。风即风或异者。有说。风即风种。以非世间立名故。有说。此亦世间立名。有尘风无尘风。如是比。问善根有几种。答

  福分说一种　　及与解脱分
  于福决定分　　第四离诸漏

福分说一种者。若欲界闻思慧胜进施戒等俱生。得转轮王帝释及余欲界大力自在身报。及色无色界胜进善根能得有果者。是名福分。及与解脱分者。解脱分亦是欲界闻思施戒等俱生。背诸有向解脱。殖此诸善根者。中间虽断善根犹名逆流。何以故。必得涅槃故。是故如是说。宁为调达。不为外道郁头蓝子。调达虽造三逆断诸善根灭善种子入无间地狱(阿毗至阿者无毗至者择也间也以因无善种子故果名无种余二义如旧)。地狱罪毕。于四万岁寿人中。得辟支佛。证诸根猛利。胜舍利弗等。郁头蓝子虽离八地生第一有。于彼报尽命终。来生于法林中。作着翅飞狸。残害一切水陆众生。死堕无间地狱。世尊不记得解脱时种解脱种者有如是相处听法坐。若闻法时悲泣流泪身毛为竖。见生死过涅槃善利。敬信正法及说法者。于福决定分者。观察真谛暖等善根。于谛决定故。于谛满足故。顺向圣道故。名决定分。彼贤圣品已说。第四离诸漏者。无漏善根。谓学无学彼前已说。问云何于恶趣得非数灭。答

  当知布施等　　能转于恶趣
  必定与忍俱　　施等同或异

当知布施等能转于恶趣者。或有施不堕恶道。或戒或闻或思或暖或顶。若见生死过涅槃善利故。背生死向涅槃而行布施。如此施者能转恶道。余善根亦如是。布施能转恶道而非顶。若谓不尔者不能。何以故。背生死故。或有未得决定善根而能极厌生死非得决定善根者。复次施与恶趣烦恼业极相违非顶。是故无过。问若诸善根不必定离恶趣者。何者必定。答必定与忍俱。顿舍恶道必在于忍。忍与一切恶趣烦恼业相违故。舍忍者。恶趣烦恼业尚不起。况不舍。施等同或异者。从施乃至顶。或时离恶趣。或不离。以非一切施能违恶趣烦恼业故。余善根亦如是。已说转恶趣因缘。谓意识不共今当说(意识有六事不与五识共)

  离欲及退时　　受生亦命终
  断善及相续　　当知是意识

此六事说住意识。思惟故。普缘故。世尊虽说眼见色耳闻声身觉触退。彼亦牵意识现在前故退。问住何等受命终及生。答

  谓一切众生　　悉住于舍受
  命终及受生　　以不捷疾故

谓一切众生悉住于舍受命终及受生者。一切众生住不苦不乐受命终及受生。问何故。答以不捷疾故。一切分中生分死分不明了不觉悟故。于诸受中不苦不乐受最不捷疾不明了故。是故一切众生住不苦不乐受命终及受生。问若然者不苦不乐受应无无漏圣道捷疾故。答非不苦不乐受无无漏圣道力。能令利故。如水在辛则辛在苦则苦。甜酢咸淡亦如是

杂阿毗昙心论卷第九杂阿毗昙心论卷第十

        尊者法救造

        宋天竺三藏僧伽跋摩等译

    择品第十之一

  虽已说多法　　决定众杂义
  于彼无量处　　当复择其要
  牟尼说见道　　疾故名法轮
  或说学八支　　转至于他心

牟尼说见道疾故名法轮者。灭二种痴故说牟尼。寂灭满足故说牟尼。说者显示也。彼见增故说见道。以慧增故。求尔炎故。至非品故说道。疾者速进也。见道是捷疾道。不起定故。一品道顿断九品结。是法故说法。离众生故。舍此至彼故说轮。谓舍苦至集。乃至舍灭至道。复次似轮故说轮。如轮下转至上上转至下。如是见道轮。下忍转至上智。复转至忍。复次上下义故说轮。如轮下至上上至下。如是见道轮。缘欲界已上缘第一有。缘第一有已下缘欲界。复次降伏谛方故说轮。如圣王轮。或说学八支转至于他心者。尊者瞿沙说。学八支转至他心名转法轮。是故说如来于波罗奈仙人住处转法轮。以是义故别于二乘声闻辟支佛自力转法轮。虽拘邻等自转法轮自修道非他。然由开悟因缘故说世尊转法轮。虽苦法忍起已转。但道比智起说名为转。以彼处具五因缘故。所谓舍曾道。得未曾道。结尽得一味。顿得八智。一时修十六行。拘邻等五人及八万四千诸天见谛。彼先见谛故以拘邻为因缘。世尊及拘邻起世俗心。地神知故。于大力尊天所闻故。踊跃欢喜故。本常守护故。近住地神举声大唱。远住地神展转宣告。非彼自力知见。是常胜心非劣心境界故。如是须臾顷。虚空神天展转唱声乃至梵天不至上地。以彼自地耳识非分故。有说。以梵名名阿迦腻吒天声。虽念念灭而相续起故言声至梵天。转轮王出世以十善业道化导众生。以十善业道欲界受报。是故转轮王出世声至他化自在天。以未离欲故不至离欲地。梵天劝请世尊转法轮故。是故声至梵天。净居天劝发成无上道故。是故声至净居天。成称业故声有齐限。问云何为梵轮。答

  佛说具足道　　广大名梵轮
  齐辐辋具足　　对治非梵行

一切八圣道共依广大故名为梵轮。彼正语正业正命不坏故名为齐。齐毂也。正见正思惟正方便依戒立故广缘故名为辐。正念正定摄正见正思惟正方便辐故名为辋。烦恼名非梵。不爱果故。道者对治非梵烦恼是故名梵轮。已说梵轮。贤圣八支成就齐(本音优波婆素如下释)。今当说

  谓优波婆素　　受时他二说
  具足一日夜　　离严饰威仪

优波者近。婆素者住。近尽寿三婆逻住故说近住。三者等。婆逻者护。谓等护一切众生(一切经论中言律仪者悉应言等护)。是故说随一切众生慈心住得律仪。彼若作是念。于此受不于彼受。不得律仪。心不净故别受。不得律仪。律仪离增减故。受者受取由作故。非发心而得。时者谓明相出时受。他者从他人受。从众生故不从非众生数。不言语故。非婴孩非眠非痴非狂不解斋法故。彼此和合故得受。若得犯戒及烦恼起能见过者从彼受。二俱说者。授者受者二皆说授者。先说受者随说。若授者不说则不成授。授不成故受亦不成。若受者不说则不成受。无受说故。非无说而作业生。作不生故无作亦不生。无作不生故则无余识俱生功德。若二人一时说者亦不成受。无授故。具足者。圣八支成就。如比丘不具足律仪则非比丘。此亦如是。一日一夜者。第三分齐非分故有二分齐如前说。斋律仪得日夜分齐。余律仪得尽寿分齐。离严饰威仪者。谓缨络被服为严饰故。著者悉应舍离住威仪受。以庄严为放逸足故。调伏住则不放逸。放逸者不应作而作。坏威仪者不恭敬故不得律仪。黄门时黄门无形二形不生律仪。何以故。贪欲增故。无惭愧增故。在人趣依三方非余。捷疾知觉故。五种清净因缘修多罗品已说。问斋几是尸罗支。几是不放逸支。几是持支。答

  尸罗支有四　　不放逸支一
  余则是持支　　斋支慧所说

前四是尸罗支(尸罗译言修习亦言正顺三昧亦言清凉亦言安眠)。舍性罪自性戒故。不饮酒是不放逸支。饮酒是放逸支。令心失念故。是故离彼名不放逸支。余则是持支者。随顺戒故。有说。离非时食是斋。余者斋支。复有说。离非时食是斋亦斋支。余者是支。如等见是道亦道支。择法觉是觉亦觉支。彼亦如是。若说九支者不然。何以故。离高床大床涂身香华。共立一支。俱庄严处起故。如老死立一有支。俱熟故。彼亦如是。问离两舌恶口绮语等是离性罪。何故不立斋律仪耶。答难护故。常习近故。出家者尚难护。以常行故。况复在家。如是难护者诸威仪。除不饮酒。余遮罪亦不立斋支。问已知恶戒热所烧。斋律仪栴檀涂今当说。何故无不具足律仪优婆塞何所疑俱见其过。若有不具足优婆塞律仪。优婆塞者。何故无不具足沙弥律仪沙弥耶。若无者何故说一行等优婆塞。何得所说非无义。答

  具律优婆塞　　比丘律仪一
  以彼缺减义　　牟尼说少分

具律优婆塞比丘律仪一者。有一说具足优婆塞律仪名优婆塞。非不具足沙弥。比丘亦如是。如说我某甲归依佛两足尊归依法离欲尊归依僧诸众尊我是优婆塞。当证知尽寿舍众生受归依心清净。乃至第三口作得优婆塞律仪。问此是离杀生口作。云何得余律仪耶。答当知除等故。应说我尽寿舍众生等。如戒等取除等故名戒取。彼亦如是。复次舍众生者。谓舍自众生故。从今乃至舍自众生所受戒。终不毁犯。复次波罗提木叉律仪于众生处得。彼作是说。我从今日不杀众生。亦于彼不盗不邪淫不妄语。以护彼故不饮酒。是故一切遮罪中。离饮酒立优婆塞律仪。以饮酒一切放逸足故。自所受难护故。是故说离他淫。当知两舌恶口绮语亦如是说。以彼圣人经生犹故知而不说犯。若言无一行等优婆塞者不然。实有一行等优婆塞建立此云何。以彼缺减义牟尼说少分。佛以缺戒者故说少分优婆塞。彼具戒优婆塞。若持一不持四。是名一行。持二不持三。是名少分。余亦如是。谓所得戒令知故为说非无义。问若人九岁若十岁受优婆塞律仪。然后取妻。以彼女人为妻分。先于彼女人所为得律仪不。若得者云何不犯戒。若不得者何得非少分。答得支非具足得。不他淫处不得离非梵行处。谓为妻分已不起他淫。所不应作亦如是。优婆塞受沙弥戒。不舍优婆塞戒得沙弥戒。以胜为名故不名优婆塞。若彼沙弥还俗时。说言我作优婆塞。当证知即是优婆塞。若异者应更受优婆塞律仪。比丘亦如是。已说律仪。律仪比类今当说

  二律仪妙行　　业道初解脱
  说业及尸罗　　如是七种名

波罗提木叉律仪作时。即彼刹那无作。凡有七种名。一名律仪。二名波罗提木叉律仪。三名妙行。四名业道。五名波罗提木叉。六名业。七名尸罗。彼一切恶戒对治故名律仪。防护恶戒故。入七众具故名波罗提木叉律仪。于一切众生所得故。善作故名妙行。得爱果故。思愿道故名业道。思愿从彼道转故。彼最初随顺解脱故名波罗提木叉。随一切众生慈心得故。业者作。所起作故。言是思者不然。是说波罗提木叉故。以此当知亦非后三业道。尸罗者淳善义。不害心起故。后诸无作有五种名。除波罗提木叉及业道。除波罗提木叉者。非前故。除业道者。在起业思愿后故。已说律仪类名。谓身身业成就不成就今当说

  成就身非业　　或说业非身
  或有身业俱　　或亦不俱说

成就身非业者。谓或有凡夫人处卵胎迦罗罗胞肉段坚厚。前身作已。舍此身未成未能起作。无粗心现在前故。粗心现在前能起身业。而彼细心现在前。如是内向外向内事外事尽当知。复次彼分中极苦逼迫故不能动转。何能起作。若生欲界不住律仪。亦非不律仪处身无作。若眠若狂若醉。无求无方便舍作因缘。业品已说。或说业非身者。谓圣人生无色界。彼成就道共身业非身。彼色非分故。或有身业俱者。圣人处母胎迦罗罗胞肉段坚厚。若生欲界。处律仪波罗提木叉禅无漏。住不律仪不住律仪。亦非不律仪身有作。有作不失。若生色界。此诸身色众生居故。身业者。或有说律仪。或说不律仪。或不舍作故。或亦不俱说者。无色界凡夫非身无色故。非身业凡夫故。口业亦如是。问世尊说四种入胎此云何。答

  谓入不正知　　及住与出胎
  乃至入正知　　住出亦复然

彼少福众生入母胎。颠倒想转颠倒解。所谓风飘雨雪大寒大闇。多众扰乱声。入华间林中草窟华窟树下墙间。住于母胎。亦颠倒想及颠倒解。所见如前说。出胎亦颠倒想解。所见如前。多福众生见园林浴池殿堂楼阁跏趺端坐。余如前说。是名第一入胎。第二入胎者。自知入胎。不颠倒想不颠倒解。而住出颠倒。如前说。第三入胎者。自知我如是入胎如是住胎。出则颠倒如前说。第四入胎者。自知我如是入胎。住时自知我如是住胎。出时自知我如是出胎。问此诸入胎者说何等人。答

  初者不净业　　亦复不求智
  中二各成一　　第四俱成就

彼初者善业不清净亦不求智。第二者业清净而不求智。第三者求智业不清净。第四者俱成就。又说。初入胎者一切众生。第二转轮王。第三辟支佛。第四如来。问须陀洹有不善业邪。若有者何故不堕恶趣。若无者应离欲。离欲者无有是处。答

  住于初果者　　一种不净业
  而不堕恶趣　　业不具足故

须陀洹虽有修道断不净业。无见道断业。无对事故。是故不堕恶趣。具不具足故。如车二轮具能有所运。一轮坏则无所堪。彼亦如是。鸟譬亦然。愚者堕恶趣非智者。凡夫堕恶趣非圣人。犯戒堕恶趣非持戒。恶心堕恶趣非善心。如修多罗品说。食择品当说今当说

  四食在欲界　　四生趣亦然
  三食上二界　　抟食彼则无

四食在欲界者。欲界有四食。四生趣亦然者。四生五趣亦有四食。地狱中铁丸洋铜。虽复增苦坏。饥渴故名食。及冷风触身亦名为食。三食上二界抟食彼则无者。色无色界无抟食。身轻微故。无色故。问诸趣一一趣何食增。答

  于彼饿鬼趣　　意思食为增
  及与诸卵生　　三无色亦然

于彼饿鬼趣意思食为增者。饿鬼趣意思食增。以彼意行多故。及与诸卵生者。彼亦意思食增。以彼处卵生常念母故。得不烂坏。三无色亦然者。除非想非非想。余三无色亦意思食增。意行多故

  胎生抟食增　　谓彼人趣中
  地狱识食增　　第一有亦然

胎生抟食增谓彼人趣中者。胎生者人趣中抟食增多。以抟食持身故。地狱识食增第一有亦然者。地狱识食增。识持名色故。非想非非想亦识食增。以识持名故

  欲天如人趣　　色界触食增
  及与畜生趣　　湿生亦复然

欲天如人趣者。欲界天抟食增。色界触食增者。色界天触食增。受修禅故。及与畜生趣湿生亦复然者。畜生趣中湿生者触食增。持义是食义。如榰持瓶安住不坏。如是以食持身。身则不坏。牵有故说食。问若然者一切有漏法是食。牵有故。答增上故说力。能牵有故说食。有二事故名食。谓前方便牵。牵已复长养。问何故说四是食。答此不应问一切难起。但随量所应故说四。彼抟食者。长养诸根四大故说食。触者长养心心法故说食。意思者长养当来有故说食。识者长养名色故说食。是故说四食。问若归依佛法僧者(梵音中三宝名覆护归依趣向义应云归趣佛覆护法僧亦如是)。为何所归。三宝各二种。佛有二种身。谓生身及法身。法亦二种。谓第一义涅槃法及一切无我法。僧亦二种。谓第一义僧及等僧。为归何等。答

  归依彼诸佛　　所得无学法
  涅槃无上法　　僧学无学法

诸佛所成就无学法名为佛。归者归佛所得无学法名归佛。不归佛所成就无诤等诸有漏法。自性不解脱故。以是故当知亦除生身。若言于如来所起恶心伤足出血不得无间罪者不然。何以故。起恶心故。谓于佛所得无学法起恶心而伤足故得无间罪。复次坏佛所得无学功德所依故。所依坏故依者亦坏。如瓶坏乳亦坏。归依爱尽名归法。善故常故。当知除余法。以余法无善及常故。归依僧所得学无学法名归僧。不归僧所成就非学非无学法及生身。以有漏故。亦非等僧可坏故。问归依以何为自性。答有说。口业自性。言说假合故。复有说亦身口业自性。戒自性故。问归依有何义。答覆护义是依义。安慰义是依义。以是因缘故归依。是受律仪门。修多罗品说四不坏净言。择品当广说今当说

  缘觉菩萨道　　及与三真谛
  于彼无垢信　　是法不坏净

辟支佛所得三根及眷属。一切菩萨所修行道及苦集灭谛。缘此诸法起无漏信。是名不坏缘法。不坏净坏缘后当说

  随生清净戒　　佛僧如归说
  此事有二种　　说有四种名

随生清净戒者。谓无漏随生身口业。是贤圣所重戒。是名戒不坏净。佛僧如归说者。佛及僧当知如前归依说。彼缘佛法无漏信。是于佛不坏净缘。僧法无漏信。是于僧不坏净。若缘佛所得无漏法及菩萨所得学法。是名坏缘法不坏净。如是缘佛辟支佛法声闻法乃至一切学无学法。是亦名坏缘法不坏净。问不坏净有几事。答此事有二种。谓信及戒。信者心净。戒者四大净。说有四种名者。事缘建立故有四。以信缘别故为三种。知净者。若知若得若持清净。问何所知。答四真谛。复有说者名不坏净。如首罗长者。复次勇猛故不断。有说者名不坏净。如依长者(此二长者皆得初道魔不能坏不能断各依己自说为名)。问云何次第。答佛知净在前。佛是根本。以说故。问佛何所能。答曰觉法。问谁持法。答曰僧。问彼僧云何得一味。答曰圣戒。复次能说者为佛。何所说。谓法为谁说。谓僧谁持法。谓戒。复次良医者佛。治病者法。看病者僧。药者圣戒。是名次第说。彼于苦集谛及下根。于道谛一因缘得不坏净。谓信也(三根于苦集尽生信厌下根于道未能爱乐唯信也)。彼于灭谛及中上根。于道谛二因缘得不坏净。谓信及欲乐(三根于灭悉皆爱乐中上根于道乃能爱乐信俱有)。修多罗品说沙门果。择品当广说今当说

  所谓沙门果　　无为亦有为
  有为学果三　　无学果第四

二种沙门果。有为及无为。有为学果有三。有为无学果第四。一切无为悉非学非无学

  八十九圣人　　沙门无为果
  亦说于有为　　一切沙门道

彼见道八忍。是沙门八智。是沙门有为果。八种烦恼断。是沙门无为果。欲界修道离欲九无碍道。是沙门九解脱道。是沙门有为果。九种烦恼断。是沙门无为果。如是乃至非想非非想离欲尽当知。显现故世尊说四。以此处五因缘具故。谓舍曾道得未曾道。结尽。得一味解脱。顿得八智。一时修十六行。以此处道决定及决定究竟故。若断者所作及所作究竟。问颇一念顷一智知一切法邪。答无也。何以故

  虽知一切空　　而非知一切
  除其共相应　　自性亦复然

若此智生知一切法空及无我。而不知自己自性。不自顾如指端不自触。此亦如是。又无二决定故。无有一智二决定。自知知他亦不知相应法共。一行一缘故。一切相应品法同行同缘。不知共有法。一果故。同决定转故。此智闻慧思慧非修慧。何以故。修慧者分段缘故。是故说欲界色界。以无色界闻思非分故。问对治几种。答

  所谓断对治　　坏持及远分
  此四应当知　　是名对治种

有四种对治。所谓断对治。坏对治。持对治。远分对治。断对治者。无碍道断烦恼得故。坏对治者。于缘中作过行故。谓无常苦空非我等。如是比。持对治者。与烦恼断得合。谓解脱道及后诸余与烦恼断得合。远分对治者。解脱道为首。苦法忍是见苦所断烦恼。断对治及坏对治。于余欲界系法。坏对治。若欲爱尽超升离生苦法忍。亦是远分对治。如是一切道随其义尽当知。修多罗品说修义。择品当广说今当说

  初得若习行　　对治及断修
  当知此四种　　是名为修义

四种修。谓得修。行修。对治修。断修。得修者。谓初得未曾得有为功德。习修者。谓曾得善法相续生。对治修者。谓修四种对治名为对治修。是有漏法敌对治道。断修者。谓断烦恼故。修道是断烦恼得义(上取能治能断为修今取所治所断为修依下四句可知也)。有法得修及习修非对治修断修。作四句。初句无漏有为法。第二句不善法无记有为法。第三句善有漏法。第四句无为法。有说。六种修。前四及分别修防护修。分别修者。如修多罗说。谓此身发毛爪齿。如是比。防护修者。谓根如所说善调御六根。如是广说。如是好者。谓四种修。如前说。此二种修。断修对治修所摄。已说见道修道决定相。差别义今当说

  烦恼通三界　　若见断二种
  二断则三种　　俱见道前行

若烦恼三界系。见道断。谓五见及疑。此见道前行二种(五见疑定见道前断爱慢无明与见俱灭实虽未尽名已悉摄随见受名名为前行下修道不待见道故修道前行)。或见道断。或见道修道断。云何见道断。若结非想非非想处系。随信行随法行无间忍断。彼非想非非想处系此以地定故说。随信行随法行此以人定故说。无间忍此以对治定故说。断者此以所作定故说。云何见道修道断。谓八地。若凡夫断修道断。若圣人断见道断。问何故凡夫断烦恼一向修道邪。答凡夫不能部分舍烦恼。如是见断如是修断。复次凡夫不能一种道断九种故。若三界五种。谓爱慢无明。此见道前行三种。或见道断或修道断。或见道修道断。若彼烦恼非想非非想处系。随信行随法行无间忍断。是见道断。若九地学见迹修道断。是修道断。余八地。若凡夫断修道断。若圣人断见道断

  若欲界烦恼　　五行有二种
  彼修齐限故　　说修道前行

若欲界五行。彼修道前行二种。或修道断。或见道修道断。若学见迹修道断是修道断。余若凡夫断修道断。若圣人断见道断。彼决定前断是故说前行。问前说缘此诸缘何时作事。答

  次第缘所作　　说彼法生时
  缘缘所作业　　彼法灭时说

次第缘所作说彼法生时者。生时是未来。与转俱故。亦应说转时彼法生时。次第缘为作业。与处义故名次第缘。彼法生者得处故。若言色及一切心不相应行亦得处而生。应说次第缘者不然。彼事行品已说。缘缘所作业彼法灭时说者。法灭时缘缘为作业。以法灭时是现在能摄受境界。非未来未起故。非过去已灭故

  三因所作业　　谓彼法生时
  二因之所作　　当知灭时说

三因所作业谓彼法生时者。法生时三因作业。所谓自分因。一切遍因。报因。自分因力故法生相似相续。是故法生时自分因作业。一切遍因报因随顺建立生法故。彼法生时作业。总说故说法生时三因作业。除初无漏余善。除报余不隐没无记。自分因作业染污者。自分因一切遍因作业。报者自分因报因作业。二因之所作当知灭时说者。有缘法灭时。相应因共有因作业。业同故。一果故。不相应法共有因无缘故。增上缘者一切时不障碍住。是故不说。不待说故。所作因亦如是。问云何一切众生等心起等心住等心灭为不邪。所以问者。有众生身或大或小。为身大则心大。身小则心小邪。为一切等。又众生进止迟速不同。为迟行心迟。速行心速。为悉等邪。复次众生或有安静知觉如山。或有不住动若飞尘。为静者心迟动者心速。为悉等邪。答

  一切众生类　　心起住灭等
  贪欲等相应　　不相应亦然

一切众生类心起住灭等者。一切众生心等起等住等。灭时无多少。何以故。刹那故。亦无大小。非色故。四大差别故身有大小。身轻者速。身重者迟。心转多缘故则觉飘动。心止一缘则念安静。贪欲等相应不相应亦然者。若心有贪无贪彼一切心俱起俱住俱灭。刹那故。贪心不作业故现重。无贪心作业故现轻。乃至有解脱无解脱尽当知。有贪无贪如界品说

问已说有心分一切众生心俱起俱住俱灭。无心分复云何等。谓入无想灭尽正受者。此心灭。余众生心起。还从定觉此心生。余众生心灭。云何等。答当知此说有心者然。无心者亦同。谓入无想灭尽正受者。彼余众生心起。此初正受刹那亦起。从定觉时余众生心灭。此后正受亦灭。若住定时余众生心亦起亦灭。此正受亦起亦灭。复有说言。一切心起不必同。或有心起不灭。作四句。初句从无想灭尽正受起。第二句入正受时。第三句有心者。第四句住正受时。此无有小大。无形故。已说诸心起灭。广心义今当说

  欲界中有四　　色无色各三
  亦学无学心　　说此次第生

欲界中有四色无色界各三亦学无学心者。有十二心。所谓欲界系善心不善心隐没无记心不隐没无记心。色界系善心隐没无记心不隐没无记心。无色界亦如是。及学心无学心。问十二心云何建立。答系不系界种建立。系及不系立二心。系者界种分别立十心。不系者种分别立二心。是故说十二心。说此次第生者。此诸心一一次第生。诸心今当说

  欲界善生九　　亦复从八起
  二秽污生四　　亦从十心生

欲界善生九者。欲界善心次第生九心。欲界四自地故。色界善心。谓初方便入正受时彼随顺故。此则总说。非色界一切。有说。未来禅摄非余。又说。未来及初禅。又复说中间禅。尊者瞿沙说。乃至第二禅。如超越正受从初禅起超第二禅及眷属第三禅现在前。此亦如是。色界秽污心。谓受生时此善心命终。彼秽污心相续生。无色界秽污心亦如是。及学无学心。彼亦随顺故。色无色界不隐没无记心。不次第现在前。心缚自地故。无色界善亦不现在前。极相远故。此亦从八起者。欲界善心亦从八心次第生。欲界四自地故。色界善及秽污。善心如前说。秽污者。谓初禅地烦恼所恼。即依欲界善心防护。故从学无学心起。欲界善心现在前。二秽污生四者。欲界不善心及隐没无记心次第生自界四心。非上地。相违故。亦从十心生者。彼欲界二种秽污心。从十心次第生自界四色。无色界六谓受生时

  无记次生七　　亦复从五起
  色界善十一　　亦从九心生

无记次生七者。欲界不隐没无记心次第生七心。自界四。色界善。谓变化心次第生隐没无记。谓受生时。无色界亦隐没无记心。亦复从五起者。欲界不隐没无记心从五心次第生。自界四。色界善次第生。谓变化心。色界善十一者。色界善心次第生十一心。除无色界不隐没无记心。亦从九心生者。色界善心从九心次第生。除欲界二秽污心。及无色界不隐没无记心

  色界秽污六　　亦从八心起
  无记次生六　　从三次第生

色界秽污六者。色界隐没无记心次第生六心。自界三欲界三。除欲界不隐没无记。亦从八心起者。色界隐没无记心从八心次第生。除欲界二秽污及二无漏。无记次生六者。色界不隐没无记心次第生六心。自界三欲界二秽污无色界秽污。从三次第生者。从自界三心次第生

  无色善生九　　亦从六心起
  秽污心生七　　彼亦从七生

无色善生九者。无色界善心次第生九心。除欲界善不隐没无记心及色界不隐没无记心。亦从六心起者。无色界善心亦从六心次第生。自界三色界善及二无漏。秽污心生七者。无色界隐没无记心次第生七心。自界三色界善心及秽污欲界二秽污心。彼亦从七生者。无色界隐没无记心亦从七心次第生。自界三。欲色界善及不隐没无记心

  无记心生六　　亦复从三起
  学心生于五　　亦从四心生

无记心生六者。无色界不隐没无记心次第生六心。自界三下界秽污三。亦复从三起者。无色界不隐没无记心从自界三心次第生。非余。报数故。学心生于五者。学心次第生五心。二无漏及三界善心。非秽污。性相违故。非不隐没无记。性不捷疾故。亦从四心生者。学心亦从四心次第生。即学心及三界善心非无学。是因故。亦非余。如前说

  无学心生四　　亦从五心生
  已说十二心　　二十应当说

无学心生四者。无学心次第生四心。即无学心及三界善心。非学。是果故。非余如前说。亦从五心生者。无学心从五心次第生。二无漏及三界善心。已说十二心二十应当说者。已说十二心次第生。如此十二心分别为二十。今当说

  二善二秽污　　报生及威仪
  工巧诸禅果　　欲界中八心

欲界八心。谓方便生善心及生得善不善及隐没无记不隐没。无记者有四种。报生威仪工巧变化心

  除不善工巧　　余则在色界
  离禅果威仪　　余四在无色

除不善工巧余则在色界者。色界有六心。除不善及工巧。余如前说。离禅果威仪余四在无色者。无色界有四心。除威仪及变化心。色无色界除工巧。无事业故。除不善。离无惭无愧故。无色界除威仪。往来非分故。除变化心。支所摄禅非分故

  学与无学心　　此则为二十
  彼心次第生　　各随其义说

学与无学心此则为二十者。学与无学心及前十八。是为二十心。系不系界种分别。此差别者前总说。善及不隐没无记今亦种分别。彼心次第生各随其义说者。谓此心展转次第生今当说

  欲方便生十　　亦从八心起
  生得次生九　　亦从十一生

欲方便生十者。欲界方便善心次第生十心。自界七。除变化心。以彼净禅次第生故。色界方便善心及学无学心。亦从八心生者。彼欲界方便善心从八心次第生。自界二善心及二秽污心。色界方便善心秽污心。及学无学心。生得次生九者。欲界生得善心次第生九心。自界七。除变化心色无色界秽污心。亦从十一生者。欲界生得善心从十一心次第生。自界七。如前说。色界方便善心秽污心及学无学心

  二秽污生七　　亦从十四起
  报生威仪八　　是亦从七生

二秽污生七者。欲界不善及隐没无记次第生自界七心。除变化心。亦从十四起者。此二秽污从十四心次第生自界七。除变化心。色界四种。除方便善心及变化心。无色界三。除方便善心。报生威仪八者。欲界报生及威仪次第生八心。自界六。除方便善心及变化心色无色界秽污心。是亦从七生者。此欲界报生及威仪心亦从自界七心次第生。除变化心

  工巧心生六　　亦复从七起
  变化心生二　　亦即从二生

工巧心生六者。欲界工巧心次第生自界六心。除方便善心及变化心。亦复从七生者。彼亦从自界七心次第生。除变化心。变化心生二者。欲界变化心次第生二心。欲界变化心及色界方便善心。亦即从二生者。亦即从此二心次第生

  色方便十二　　是亦从十起
  生得次生八　　亦从五心生

色方便十二者。色界方便善心次第生十二心。自界六欲界三。方便善心及生得善心变化心。无色界方便善心及学无学心。是亦从十起者。色界方便善心从十心次第生。自界四。除威仪及报生。欲界二方便善心及变化心。无色界三方便善心秽污心及学无学心。生得次第生八者。色界生得善心次第生八心。自界五。除变化心。欲界二秽污心无色界秽污心。亦从五心生者。色界生得善心从自界五心次第生。除变化心

  色秽污生九　　亦从十一起
  威仪心生七　　从五次第生

色秽污生九者。色界秽污心次第生九心。自界五。除变化心。欲界四二善二秽污心。亦从十一起者。色界秽污心从十一心次第生。自界五。除变化心。欲界三。生得善威仪及报生。无色界三。除方便善心。威仪心生七者。色界威仪心次第生七心。自界四。除方便善心及变化心。欲界二秽污无色界秽污。从五次第生者。色界威仪心从自界五心次第生。除变化心

  当知色报生　　亦如威仪说
  谓彼诸禅果　　当知如欲界

当知色报生亦如威仪说者。色界报生心次第生七心。亦从五心生。如威仪说。谓彼诸禅果当知如欲界者。色界变化心次第生二心。色界方便善心及变化心。亦即从此二心次第生

  无色初生七　　是亦从六生
  生得亦生七　　当知从四起

无色初生七者。无色界方便善心次第生七心。自界四。色界方便善心及学无学心。是亦从六生者。无色界方便善心从六心次第生。自界三。除报生。色界方便善心及学无学心。生得亦生七者。无色界生得善亦次第生七心。自界四。下界三秽污。当知从四起者。彼从自界四心次第生

  秽污生八心　　是从十心起
  报心生于六　　是亦从四生

秽污生八心者。无色界秽污心次第生八心。自界四欲界二秽污色界方便善心及秽污心。是从十心起者。无色界秽污心从十心次第生。自界四欲界三生得善威仪及报生。色界亦如是。报心生于六者。无色界报生心次第生六心。自界三。除方便善心下地三秽污心。是亦从四生者。彼报生心从自界四心次第生

  学心次生六　　从四次第起
  无学心生五　　是亦从五生

学心次生六者。学心次第生六心。三界方便善心欲界生得善(欲界生得善强而利二界弱而钝也)。及学无学心。从四次第起者。学心从四心次第生。三界方便善心及学心。无学心生五者。无学心次第生五心。三界方便善心欲界生得善及无学心。亦从五心生者。三界方便善心及学无学心。问何故方便善心次第生。威仪工巧及报生心。此诸心何故不次第生方便善心邪。答威仪工巧自乐所作故。报生心羸劣故。无所作故。谓威仪心乐习威仪故。是故次第不起。方便善心。出心不勤方便故。方便善心次第生。威仪心工巧心亦如是。报生心羸劣。无所作故。本业所种故。是故入彼心者。不能出心不勤方便故。从方便善心次第生。若言秽污心乐着境界及羸劣故不应从秽污心境界次第生方便善心者不然。何以故。境界不异故。见过故。不羸劣故。于彼境界过恶转。即彼起功德。是故彼境界不异于彼行。烦恼疲厌故。即彼境界观察生长夜习烦恼故。秽污心不羸劣。是故彼应次第生方便善心。欲界生得善心虽捷疾而非方便。以捷疾故。从彼色界方便善心及学无学心次第生。以非方便故不能次第生。彼诸心色界生得善心不捷疾。亦非方便。不捷疾故。不从学无学心及无色界方便善心次第生。非方便故。故不次第生。彼诸心无色界亦如是。色界秽污心次第生。欲界生得善心以捷疾故。无色界秽污心不次第生。色界生得善心不捷疾故。问云何正法。答

  经律阿毗昙　　是名俗正法
  三十七觉品　　是说第一义

经律阿毗昙是名俗正法者。修多罗律阿毗昙。是言说正法。依名处起故。前已说。佛语是语自性。语则依名转。以他处转故。是故名俗数。显第一义故名正法。以名显义故。三十七觉品是说第一义者。三十七觉品是第一义正法。离名起故。有漏修慧虽离名转。有垢故不说第一义正法。如正法有二种。行法者亦二种。修法及修。修法者谓诵习。修者谓修禅。彼俗数。正法者是修。法是持义。第一义正法是修。是故说修行法者住则正法住。修行者灭则正法灭。世尊劝发修行者故不说分齐如前说。金刚三昧择品当广说。今当说

  五十二及余　　亦复说八十
  或有说十三　　是金刚三昧

有说。五十二金刚三昧。禅未来所摄。若依禅未来苦比智得阿罗汉果。于非想非非想处四阴无常苦空非我思惟。若集比智得者。集谛四行一一行思惟。若灭法智。欲界系行灭。灭谛四行思惟。若道法智。断欲界系行道。道谛四行思惟。若灭比智。或初禅地系行灭思惟。或乃至非想非非想系行灭思惟。若道比智。于彼九地比智品道四行思惟得阿罗汉果。如是智行缘分别则五十二(苦异故灭异情隔故观别是以八地灭有三十二行道则类尔通异地同性情无碍故观通通观九地唯有四行合前四谛十六行为五十二)。如禅未来。乃至第四禅亦如是。空处二十八(自地苦集八行四空灭谛十六行九地道四行于上灭渐少故随处灭四)。识处二十四。无所有处二十。以无色无法智。法智缘欲界故非无色。下地行灭缘。下地苦非境界故。下地对治缘展转因故。有说。禅未来八十金刚三昧。是中差别者说道比智。亦一一地对治缘。得阿罗汉果(观七地道比智地各四行有二十八合前五十二为八十也)。如禅未来。乃至第四禅亦如是。空处四十。识处三十二。无所有处二十四。尊者瞿沙说。禅未来所摄金刚三昧。十三见道四比忍相应四三昧修道非想非非想离欲九无碍道相应九三昧。彼一切第一有对治。金刚三昧世俗道非境界故。乃至第四禅亦如是。空处九乃至无所有处亦如是。此是总说。若说忍智行种缘分别禅未来所摄。则有一千四百九十二金刚三昧。乃至第四禅亦如是。空处四百六十八。识处三百二十四。无所有处二百一十六。问彼智品所说神通彼神通为一切善为非。答

  三通则说善　　余二是无记
  当知依欲色　　世尊说慧性

三通则说善者。神是智他心智宿命智。此三通说善。何以故。爱果故。极方便所起故。调伏他故。不信乐者令信乐故。此三通令他极调伏故欢喜。欢喜心相应慧是善。信心相应故。余二是无记者。谓天眼天耳。此二神通是无记。爱果及极方便非分故。又受色声起。是故无记。问何处现在前何等性。答当知依欲色世尊说慧性。此神通欲色界现在前非余。依色故。彼先欲界起故。后色界能现在前。彼非初业堪能非分故。是智慧性从分别起故。依成依者故(此释通有眼名由眼起故)。如施设经说。尔时色界四大造眼处周圆。天眼净。如修多罗品说。诸根事言择品当广说。今当说

  当知彼诸根　　慧者善分别
  名有二十二　　事则说十七

佛说诸根。名有二十二。事有十七。以男女根及三无漏根无别事故不立事。余根摄故。男女根离身根更无故。是故说。云何男根。身根少分。女根亦如是。又一识依故。若识依身根起。即依男女根。无异相根共生。一识三无漏根九根合成故。九根者。意根乐根喜根舍根信等五根。此九根。道及人分别故立三根。道分别者。见道说未知根。修道说已知根。无学道说无知根。人分别者。随信行随法行说未知根。信解脱见到身证说已知根。慧解脱俱解脱说无知根。问等及第一义有何相。答

  若事分别时　　舍名则说等
  分别无所舍　　是则第一义

若事分别时舍名则说等者。若事分别时舍名者。此则等事(等事梵音云三比栗提译言等集亦言等积聚凡会有三无者名等集)。非第一义决定事不可得故。如瓶分别色香味触时舍瓶名。亦非舍色香味触别有瓶名。是故名等事。如是一切分别无所舍。是则第一义者。若事分别时不舍名者。是第一义。如五盛阴名苦谛。若分别五时亦不舍苦名。以色是苦故。乃至识亦如是。彼色复十一种。一一入皆苦。乃至刹那及极微分别时亦不舍苦名。彼得相故。如是一切如杂品说。中阴择品当广说。问为定为不定。答

  界趣地必定　　中阴五无碍
  说名为香食　　求有乘意行

界趣地必定者。中阴界趣地不转。欲界中阴必生欲界。色界生色界。如是地狱趣生地狱。乃至人趣生人。四天王生四天王。乃至阿迦腻吒天亦如是。中阴五者。中阴五阴性。有去来故。非离色有去来。是故欲色界有中阴非无色界。色非分故。无碍者。极微故。一切形障所不能碍。业力故住母胎。若异者不应住胎。说名为香食。求有乘意行者。以香为食故说香食。若薄福者食诸秽香。若大力者食诸净香。求于生有故说求有。从意生故说乘意行。此诸众生或业生。谓地狱如所说彼诸众生业所缚。或烦恼生。谓人及欲界天。或报生。谓飞鸟。或从意生。谓色无色界天及劫初人。化及中阴二有中间起离趣故。是故说中阴。问中阴几时住。答

  七日或七七　　乃至彼和合
  或裸形食香　　诸根悉具足

七日者。有说。中阴七日住。身羸劣故。问若和合者应尔。若彼父母异处者。是人命终当云何。答当观是众生业转不转。若于母可转于父不可转者。彼父则从他女人令中阴会。于父缘可转者亦如是。若二俱不可转者。此人未死而彼先和合此说常行欲者。若时节行者。彼众生业因缘故。令彼非时亦行。有说。或于相似处生。谓若应生时行处者非彼时故。则于相似常行处生。随其类说。七七者。有说。七七日住。乃至彼和合者。复有说。不定乃至未和合间常住。问中阴有衣无衣。答或裸形。色界中阴有衣。色界惭愧增故。如彼法身不裸形。生身亦尔。欲界菩萨及白净比丘尼中阴有衣。余众生无衣。无惭愧增故。问中阴何食。答香食。欲界中阴以香为食。前已说。色界离抟食。贪身极微故。唯三种食。问具诸根不。答诸根悉具足。中阴具诸根。何以故。中阴报淳故。又彼众生求有故。于六入门常求有。问形为云何。答

  随行量不定　　或有见不见
  入则从生门　　或生颠倒想

随行者各如其趣。地狱中阴如地狱形。乃至人天如人天形。问中阴云何行身量云何。答行量不定。中阴行及身量不定。地狱中阴足上头下而行。天中阴上升如箭射空。余中阴侧身傍去。如画人飞。量者。色界中阴量如本有。欲界菩萨中阴亦如本有。三十二相庄严其身。是故菩萨中阴光明彻照百亿天下。言白象身入母胎者不然。已离畜生故。菩萨从九十一劫来常离畜生。顺相书故。令菩萨母见如是梦。欲界余众生中阴身量。如有知小儿形。诸根猛利故。以颠倒想入胎。问中阴中阴为相见不。答或有见不见。或中阴以中阴为境界。不一切。有说。地狱中阴见地狱中阴。如是一切。又说。地狱中阴见地狱中阴。畜生见二趣。饿鬼见三趣。人见四趣。天见五趣。生阴眼则不见。若天眼极清净者能见。问从何处入胎。答入则从生门。彼从生门入。是故双生者后生为长。问以何想入胎。答或生颠倒想。非一切众生颠倒想入母胎。除近佛地菩萨。彼近佛地菩萨。于母母想于父父想。余众生悉颠倒想入胎。若男中阴者。于母染想于父恚想。彼作是念。若无此男者与此女会。想见男去而与女会。见彼精时而谓己有即生欢喜。生欢喜故阴则渐厚。阴渐厚已依母右胁向背蹲坐。女则相违说。中阴因缘后当说

杂阿毗昙心论卷第十杂阿毗昙心论卷第十一

        尊者法救造

        宋天竺三藏僧伽跋摩等译

    择品下

问知法识法明法此云何。答

  知者一切法　　识明亦复然
  知及意识明　　彼各随事说

彼苦智知苦。乃至道智知道。无漏智分段缘故善等智者亦知苦。乃至虚空数非数灭。普缘一切法故。识者亦识一切法。彼眼识识色。乃至身识识触。摄受自相故。意识识眼色眼识。如是一切普缘故。明者亦明一切法随其事。彼苦忍苦智明苦。乃至道忍道智明道。分段缘故。善有漏慧亦明。苦乃至虚空非数灭。问劫云何过。答

  刀兵病饥馑　　说名中劫过
  除地余三种　　说名大劫过

刀兵病饥馑说名中劫过者。三种中劫过。谓刀兵病疫饥馑。刀兵劫者。谓乃至人寿十岁时。贪粗恶境界。行诸邪法各住害心。手执草木皆成刀剑。更相杀害。如是经七日。刀兵中劫过。疾疫劫者。亦寿十岁时。多诸疾病。无有医师方药瞻病。薄福德故。遇病辄死。如是经七月七日。疾疫中劫过。饥馑劫者。亦寿十岁时。饥渴增上体极羸劣。普天亢旱种殖不收数米而食。煎煮人骨以饮其汁。如是经七年七月七日。饥馑中劫过。如是说者。若于今世一日一夜持不杀戒。终不生彼刀兵劫中。一呵黎勒果施僧福田。终不生彼疾疫劫中。若以一食施僧福田。终不生彼饥馑劫中。此阎浮提恶劫互起。余方则少有相似。如此间刀兵劫起。彼唯嗔恚增上。如此间疾疫劫起。彼唯羸劣少力。如此间饥馑劫起。彼唯增饥渴。问云何大劫过。答除地余三种。是名大劫过。三大种说大劫过。谓火水风非地种。何以故。不利故。利者坏大劫。复次地种坏劫者。坏劫应至第四禅。而未曾至第四禅。问何故坏劫不至第四禅。答净居天故。彼无上地生。即彼般涅槃故。亦不下生。下地非数灭故。若彼住经坏劫者亦不然。增上福力生彼处故。内扰乱非分故。若彼地内有扰乱者。则外有灾患。彼初禅内有觉观。火扰乱故外为火灾所烧。第二禅内有喜。水扰乱故外为水灾所漂。第三禅内有出入息。风扰乱故外为风灾所坏。问第四禅未曾有扰乱者何得不常。答刹那无常所坏故。如是说者。第四禅地不定相续。随彼天生宫殿俱起。若天命终彼亦俱没。问何等劫尽最初。答

  七火次第过　　然后一水灾
  七七火七水　　复七火后风

七火次第起者。谓最初火劫起。如是说言。若火劫将起。尔时人寿八万岁地狱命终者不复还生。当知劫尽。乃至地狱无有一众生住。是名地狱劫尽。如地狱劫尽。畜生饿鬼亦如是。若畜生于人有用者与人俱尽。是时阎浮提唯有一人。无有教者能入初禅。从初禅起已举声唱言。离生喜乐甚为快乐。如是音声展转相告遍阎浮提。诸余众生亦无师教悉入初禅。乃至阎浮提无一众生住。是名阎浮提劫尽。唯除郁单曰。欲界一切善趣亦复如是。郁单曰命终无得禅者。离欲非分故。又于彼时初禅一众生无有教者而入第二禅。从禅起已举声唱言。定生喜乐甚为快乐。如是音声遍至梵天。余诸众生亦复如是。乃至初禅无一众生住。是名众生世劫尽。是时世界久远虚空。乃至七日出。问曰。从何处出。答有说。劫成时由乾陀山后有七日轮住从彼而出。有说。一日分为七分。复有说。一日七倍热。复有说。从无间地狱火出。如是说者。众生业力故。增上果器世界起。彼业尽如是扰乱生。乃至梵天烧然如是。七火次第过然后一水灾者。七火灾过已然后一水灾。乃至坏第二禅。问水从何处起。答有说。从第三禅际雨热灰水。复有说。水轮涌出。扰乱起如前说。七七火七水者。七火灾次第过然后一水灾。如是七七火灾一七水灾。复七火后风者。复七火灾过然后一风灾。水灾风灾从火灾次第起。此则善说。是遍净天六十四劫寿也。水灾所漂乃至第二禅风灾所坏。乃至第三禅百亿四天下一时俱坏。十九中劫世间空。一中劫器世界坏。一中劫器世界成。十九中劫渐次第住。若处最初空是处最后住。若处最后空是处最前住。问云何心乱。答

  错乱本业报　　恐怖及伤害
  若彼解支节　　圣说水火风

错乱本业报怖畏及伤害者。四因缘心乱。谓四大错乱本业报。恐怖及伤害身。四大错乱者。饮食不适故四大错乱。四大错乱故令彼心乱。本业报者。本造心乱业报已熟。问何者是。答好传衰祸令他愁苦。或复骂言。汝痴狂心乱。驱迫众生令堕崄处。焚烧山泽强与人酒。或以妄想倒说佛语。如是比业得心乱果。恐怖者。见非人形来惊畏。恐怖故彼心则乱伤害身者。为非人所打故。彼以不净污大众会处及佛僧塔故彼处非人嗔。即打故彼则心乱。此说凡夫人。圣人无本业行报心乱。若先种定报业者。先受报已然后超升离生。若种不定报业者若超胜离生彼业则灭。心乱者在欲界。彼地狱不心乱。常乱故。畜生饿鬼及人则心乱。除郁单曰。欲界天亦有心乱。问何等圣人心乱。答须陀洹斯陀含阿那含阿罗汉辟支佛。唯佛心不乱。声不坏。发不白。面不皱。不渐般涅槃

世尊扰乱业久已灭尽。行妙行故。乱者意识非五识心。不分别故。有漏心乱非无漏。真实行故。是故若说心狂乱是散乱耶。作四句。初句谓狂者善有漏心不隐没无记心。第二句谓自相住者秽污心。第三句谓狂者秽污心。第四句谓自相住善心及不隐没无记心。问何等大能解支节耶。答若能解支节圣说水火风。三大能解支节非地大。不利故。火大解支节者。谓命终时火大增遍烧筋。烧筋已节节解。节节解已不久命终。水大解支节者。谓节节解时先令筋烂。筋烂已余如前说。风大解支节者。令筋碎。筋碎已余如前说。支节解已不过日夜命终。四大错乱故。地狱无解支节。支节常解故。业报故不死。畜生饿鬼及三方解支节。除郁单曰。无罪业故。天亦如是。凡夫圣人解支节。唯除佛。罪报者解支节。佛无罪报故。已说解支节。退今当说

  退法有三种　　得未得习行
  或一人一退　　未得退说二
  谓彼习行退　　三圣俱亦然

退法有三种。得退未得退习行退。得退者。所得功德遇退因缘则退。未得退者。应得功德放逸故不得。习行退者。已得功德。有因缘故不得习行。问何等人何事退。答或一人一退。若得退者是钝根声闻非利根。利根者三昧力故是故说。或云何知有得退。答以说二种阿罗汉故。谓退法不退法。若言道退果不退者不然。何以故。断得与道合故。得者道谛摄。是故道退非断者不然。若言离烦恼种云何生者。应说如初无漏心无前因而生。彼亦如是。复次有自分因分故。从无际生死烦恼自分因分生。言烦恼于三处起非说者不然。何以故。为起烦恼具满故说众生起。烦恼具有三因缘。谓因力境界力方便力。彼欲爱使未断未知是因力(断者无碍知者解脱)。欲爱缠所著法是境界力。彼不正思惟是方便力。是彼说意。若从彼说不正思惟者。前不正思惟非分则不起。若有前不正思惟此则无穷。又复善无记心至竟不生(若不正思惟相续无穷则余念不得生也)。若不生者解脱亦非分。烧诸烦恼不应还生。如火烧木为灰至竟为灰不复为木。如是阿罗汉以智火烧烦恼薪不应复为烦恼。彼不应如是。何以故。譬不合故。云何如烧薪有灰。若如是阿罗汉烦恼有余如灰耶。若有余者非阿罗汉。有烦恼故。若无者不如上譬。然非彼圣道如火烧薪。但圣道起断烦恼得解脱得作证。彼若离圣道亦舍解脱得系得还起。如诸退相违经说。当知说不时解脱故。未得退说二者。若彼未得退者。谓声闻辟支佛非佛。住一切最胜根故。声闻者不得佛辟支佛胜根。辟支佛不得佛胜根。是故有未得退。略说一切众生若修行皆应得圣慧眼。若不修行入名色者是为未得退。问云何知有未得退。答信佛说故。如世尊说。诸天及世人退于智慧者。染着于名色。不见圣谛故。谓彼习行退三圣俱亦然者。若习行退者。谓声闻辟支佛如来。三圣悉有。以中间诸因缘故。所得功德不能常现在前。问云何知有习行退。答说心心法退故。如世尊说。于此四种心心法得现法安乐住。我说彼一一退。如修多罗广说。又复说。不动意解脱身作证成就游者彼不退。以是故知世尊亦有习行退。是故说。世尊多游未至。非根本地。何以故。近欲界故。虽不动意解脱有习行退。然彼成就得修故。彼一切现在时。得常随转。彼心心法者现在修。谓不现在前者名为退。习行退最多者谓世尊。何以故。功德无边故。如转轮圣王广受境界。又说。摄他故名不动。自摄故名心心法。世尊多摄他少自摄。如是世尊大悲大舍。问何处不退。答

  诸天则不退　　果退终不死
  亦不造彼业　　住果所不为

诸天则不退者。诸天不退。以利根天得果故。利根者则不退。若钝根人得果然后生天亦不退。无生故。圣人无生不退。此前已说。退具非分故。世尊说五退具。多事业等。五退法彼天则无。是故不退。以天不退故。当知退者必人中。以退具可得故。果退终不死者。果退者终不死。要还得果。何以故。下地生非数灭故。非数灭法终不更现在前。不生法故。以果所摄道决定及决定究竟故。以果道苏息处故。彼人得苏息。又果处善自护故。以果处具三因缘及五因缘故。前已说。彼三果退非须陀洹果。见道断烦恼非对治事故。见道断烦恼依我处转。而无有我。修道断烦恼是对事。修道断烦恼净处转。彼有净想不净想。彼思惟诸行不净。得离欲净思惟。于见不净退。无有法我我所思惟。于非我见退。复次须陀洹果方便广前施戒修等向解脱。如是比。又须陀洹果见道得故无有见道退。速道故。利故。非想非非想处对治故。若阿罗汉果退至须陀洹果。当知退三果。彼对治烦恼得成就故。亦不造诸业如彼住于果者。若得果人所不为。彼退果人亦不作。何以故。得不作律仪故。圣道已灭恶行故。如曾服药。复次希望具足故。彼人希望灭果。对治恶行故。问齐何当言菩萨。答

  若修诸相好　　方便起彼业
  从是转增进　　说名为菩萨

若有众生。以一食施。起决定心。发无畏言。我当作佛。能起相报增长彼业。齐是名菩萨。以能从此作相似相续业故。若不如是但有空名。菩萨虽有初起不退心。是则菩提决定非趣(趣应言到与趣同名)决定。谓造相报业已。是则俱决定。是故齐相报业为名。以彼离四因缘故。谓离恶趣。离非男。离卑姓。离不具根。得一因缘。谓生性识宿命。以生识宿命故闻即受持。眷属信受离众生过。度三阿僧祇劫。于百劫中种相报业。除释迦牟尼。释迦牟尼菩萨精进故。除九劫余九十一劫。有说。二三阿僧祇非劫阿僧祇。谓劫阿僧祇。生阿僧祇。善行阿僧祇。问相报业为何等性。答身业口业增上意业。又是思慧性非闻慧。以劣故。非修慧。欲界不定故。阎浮提种非余方。男子非女人。佛出世非不出世。见佛非不见佛。缘造业非缘余。有说。一思愿种三十二相业。后种种业满。又复说。一定心一行一缘。众多思愿现在前。有愿足下安平住果。有愿乃至肉髻。彼一一相百福眷属。福量者。有说。一转轮圣王福。是名一福量。又复说。一帝释福。有说。劫成时一切众生业增上器世界生。是名福量。有说。除近佛地菩萨。诸余众生福乐自在业。是名一福量。佛无学法是菩提。谓尽智无生智。萨埵求此智故名菩提。萨埵得此菩提觉一切法故名为佛。虽相报业后得转轮圣王。而圣王相者当知是余业报。问几种萨婆多。答

  一种异分别　　或有说相异
  或说分分异　　或复说异异

此四种萨婆多。一种异分别者。彼说诸法随世转时。分异非事异。如乳变为酪舍味力饶益不舍色。如金银器破已更作余器舍形不舍色。法从未来至现在亦如是。当知此是转变萨婆多。相异者。过去法与过去相合。不离未来现在相。如人着一色非不着余。彼亦如是。此说有过。若过去诸法不离未来现在相者。竟何所成。亦成合义。若尔者则世乱。如人着一色于一色爱着亦行亦成就于余成就而不行。是故彼说世乱。譬亦相违。分分异者。说诸法随世转时。分分异非事异。此则不乱建立世。何以故。业别故。谓法未作业说未来。作业说现在。作业已说过去。彼异者彼说诸法随世转时。前后相待非事异亦非分异。如一女人亦名女亦名母。前后相待故。谓观女则知母。观母则知女。此最乱建立世。彼说过去世一刹那有三世。说言观前起相名未来。观后起相名现在。问诸师说谛无间等各各异。萨婆多及婆蹉部说次第谛无间等。昙无得等说一无间等。何者为实。答今当以五支如实说(五支者一曰宗二曰因三曰譬四曰合五曰结六曰义如下偈说)

  次第无间等　　智谛异相故
  见瓶不见衣　　是故彼亦然

修行者先苦无间等。后乃至道。问何故。答智谛异相故。苦集灭道智各异相行别故。若行是苦智。此行非余智。若不尔者无四智建立。谛亦异相。彼逼迫是苦相。生起是集相。寂灭是灭相。出离是道相。非不异智异相谛一无间等。譬如见瓶时不见衣。以瓶衣异相故。以异相故见瓶不见衣见衣不见瓶。彼亦如是。于异相谛见苦时不见余。如是一切。是故次第无间等说一无间等者。彼说于谛一无间等。何以故。信圣贤故。如世尊说。比丘于苦无疑。集亦无疑。灭道亦如是。如灯俱作四事。热器烧炷油尽破闇。如是一智知苦乃至修道。是故一无间等。彼说智谛异相者不然。一相故。一切慧一智相于一切法境界作无我行。如世尊说。一切法无我。智慧者能见。彼厌于苦时是即道清净。谛相亦如是说。瓶衣异相者此亦不然。何以故。自相无间等非分故。共相境界无间等非自相。谓色等五阴坏相(坏相即无常相)。共境界智一无间等。若异者则自生过次第无间者言。汝言贤圣说者。此则密语。此说有余义。如世尊说。若苦无疑于一切无疑。为彼疑行故说。若彼苦无间等生。彼疑至竟不行。非数灭故。为除有余说故世尊说。给孤独修多罗如是说言。长者于四圣谛次第无间等。如是广说。所说如灯者。灯有多性多业过。我不取灯事。若分别时灯舍自名。前已说。彼明色入摄力能破闇。彼热触入摄能作余事。若不尔者坏决定义。慧不如是。若言同者则有过。若言一相者此亦不然。行别故。无常行智异。苦空无我等行智亦各异如是比。若不尔者无解脱门。不坏行是解脱门(杂观名为坏三脱异观故不坏)。如汝说缘一切法作无我行。以顿观一切法故。此则不定思惟分定思惟行各别谛缘。是故不应说彼厌于苦时是即道清净。不可以厌行缘于灭道。灭道是可乐事故。一切缘者不通一切。相违故。以无我行不即行。此无我行故。自性不自观故。亦无二决定性。亦不观相应共一行一缘故。亦不观共有共。一果一决定故。又说。一切行无常者亦非无常行。作灭无间等。灭者常故。当知彼行远以向真谛故说。如所说观此众生长夜成就身口意恶行。言此众生即是地狱及余恶趣。实非此人即是地狱。以向地狱故说。彼亦如是。又复是空无间等者则非无愿无相。彼一切法境界非分故。莫言有过。是故一切法无我行是不定思惟。定思惟者有漏缘。若不尔者解脱门减。若言自相无间等非分者不然。何以故。以观故。是自相共相。谓逼迫相是苦相。观三谛故是自相。观阴故是共相。如是一切当知。皆以观故说自相共相。言不尔者不然。何以故。以不坏观故。前已说。前说中阴后当说今当说。问为有中阴为无。答

  当知有中阴　　世尊之所说
  譬如村间道　　彼则有俱过

此说有中阴。何以故。世尊所说故。如世尊说。七士夫趣有中般涅槃。若无中阴者则无中般涅槃。若言有中夭从彼般涅槃者不然。天趣中不说故。世尊修多罗说。四天王天乃至非想非非想处不说有中夭。余亦有过。若说生般涅槃。复有名生天耶。如是一切。阿那含亦应如是说过。是故彼是妄想说。若言寿命中间般涅槃者不然。除郁单曰及后边菩萨。多有众生不尽寿而死。此皆是中般涅槃耶。是故此皆有过。问此云何。答譬如村间道。如从一村至一村。如是死阴生阴。从死阴趣生阴亦如是。如阿湿波罗延经说。若彼处来。如是广说。若无中阴者则无去来。是故应有中阴。若言为除有余说修多罗故。世尊说修多罗及偈言。五无间罪作已。次第生无间地狱中。又复为梵志说偈言。少为老病漂到于阎王所。梵志无住处亦无有资粮。是故无中阴者此不然。何以故。业趣无间故说修多罗及偈。谓作无间业已必先受无间报。然后受余业报。亦必生地狱趣中。非余趣。如汝所解。世尊说修多罗五无间业作已次第生地狱中。为要五无间生地狱中。为二三四耶。为更余罪生地狱中耶。当知此经及偈意

若言如影者。如月极远影现水中。非彼月来至水中。如是死阴生阴如影。众生生何用中阴为者。此亦不然。何以故。彼则有俱过。月及水俱。死阴生阴不俱。是故有过。眼识足下身识譬亦如是。若先取生阴而舍死阴。如折楼虫者不然。何以故。趣不别及二识合过故。是故说有中阴。如所说四种萨婆多。问为有一切有为无。答

  当知一切有　　非有一切相
  一切无一切　　无有他相法

此有是萨婆多所立。一切者。谓十二入。彼诸入有自相非余。一切相所作别故。作业别前已说。一切无一切者。谓学法中有学法无无学法。无学法中有无学法亦无学法。如空中亦无有迹。如是比。问此说有云何无有。答无有他相法。如眼相是眼入。无余入相。相别故。以是故说一切法不杂

  一切世悉有　　不违其所应
  牟尼之所说　　声闻僧无佛

有三世萨婆多。此萨婆多所立。问何故。答现在世者观过去未来故施设。若无过去未来者则无现在世。现在世无者亦无有为法。是故有三世。莫言有咎。若言久远是过去当有是未来非是有唯有现在者此不然。何以故。有业报故。世尊说有业有报。非是业报俱现在。若业现在当知报在未来。若报现在当知业已过去。若言俗数说者。亦说作者不可得。若言俗数说有业有报者此亦不然。世尊亦说作者不可得。此亦俗数说耶。神口所说第一义空修多罗。而汝妄想说此有故彼有。如是比。当知如汝说久远是过去当有是未来非是有唯现在是有者。莫作是说。我亦能说现在者于既往是未来。于当有是过去。此非智者说。如所说若无信等五根。我说是凡夫辈。若学人缠所缠信等五根不现在前道与烦恼不俱故。是故应知有过去未来。若异者圣人应是凡夫。若言得随生此亦不然。无法得非分故。依处非分故。声闻僧无佛者。声闻僧不摄佛。何以故。三宝不减故。若世尊声闻所摄。应有三宝非三佛。无别体故。归依及不坏净念等亦如是。莫言有过。是故声闻僧不摄佛。如世尊修多罗说。憍昙弥。施僧亦是供养我。当知是说比丘僧圣僧福田僧。世尊者彼三僧所摄。破烦恼故。圣故。第一义福田故。非声闻僧自觉故

  设令广章句　　群生大恐怖
  无胜甚深相　　我今但略说

若广说者众生怖畏。是故我今不广说。章句深达。阿毗昙明净智慧所解。诸论音声妙义于此略说

  古昔诸大师　　演说无量义
  我今随所解　　分别说少分

我今于尊者法胜所说中。以少智慧思量撰集造立章句。将以申述助宣遗法。非欲憍慢求名称故。如彼所说。若生诸烦恼是圣说。有漏灭道亦生烦恼。而非有漏增。烦恼非分故。无漏缘烦恼灭而不增。前已说。是故我说增也。无漏缘软中上不增者不然。依增故

  决定知此论　　章句微妙义
  于彼智慧众　　勇猛无所畏

于此论章句义味。能决定知善分别说者。于诸智慧众中心无怯畏。善解法相故

  我今增益论　　其心无所贪
  为令智者乐　　疾得寂灭乐

经本至略义说。深广难可受持。如虚空论难可了知。前已说。是故增益论本。随顺修多罗义。令易了知。以知义故烦恼则断

    杂阿毗昙心论品第十一

已说择品。今当略说诸论。令智者欣乐

  离律不律仪　　而得于律仪
  不因彼致胜　　能决定者说

答有。谓无色界没生色界时。无色界凡夫名非律仪非不律仪。无色界善恶律仪非分故。从彼命终生色界时得善律仪。色界律仪与心俱故。非胜进。无色界界胜故

  颇得沙门果　　贤圣离诸过
  得有为善法　　不名为修习

答有。谓果所摄圣道灭已。然后退。不增进根还得。彼先过去果所摄道先灭故非修。现在因非分故。离诸过者非世俗故。有为者非无为故。善者非不善无记故

  道未兴起时　　远离诸过咎
  解脱时离恶　　能决定者说

答有。谓修行者住金刚三昧。除初尽智诸余无学法。是未起时不向故。解脱时者。一切无学道顿解脱初尽智生时。是生时是解脱时。离诸过恶者。非有漏故

  颇光音缠起　　是彼定相应
  清净初禅退　　而得于退法

答有。谓阿罗汉第二禅缠退时。尽智所得。初禅退与尽智合故。有退熏修。初禅与第四禅合故。阿那含亦尔。言净者明所退。非无学故

  颇于见谛道　　得彼诸善法
  彼法是有缘　　圣智不见缘

答有。谓与苦比智俱。欲界等智苦无间等边修亦不见彼智缘。以彼缘欲界。而苦比智不缘欲界故。集灭无间等边亦如是。道比忍得缘三谛智而不观彼谛。住异境界故。如住学法得无学法得无学法非学法。如是从法智品至比智品。比智品复至法智品

  颇果有漏慧　　无漏慧所断
  彼果所因起　　谓不离欲慧

答有。谓圣人离欲界欲。未离初禅欲。欲界初禅果化心离欲。欲界爱尽故。初禅慧未离欲。彼爱未尽故。一切化心亦如是。随其义除自地果

  颇住无碍道　　而得于诸灭
  此相违烦恼　　非彼无漏见

答有。谓凡夫人修神通时。无碍道断神通相违烦恼而得诸灭。非无漏见相违。何以故。圣人离欲时。法忍现在前。得忍相违烦恼灭故

  颇诸烦恼灭　　离欲者获得
  不断于烦恼　　而得无垢尽

答有。谓上地命终生梵天时。得欲界烦恼灭。而不断彼烦恼。先已断故。余一切地亦如是

  颇无垢净地　　未曾得而得
  非离欲非退　　不依于见道

答有。谓初禅离欲。依初禅及眷属超升离生。道比智生成就三地阿那含果。从彼定起入第二禅。得第二禅无漏。得彼无漏时。非离欲。先离欲故。非退。胜进故。非见道。见道究竟故。当知上地及增益诸根亦如是

  颇护未曾得　　而得于寂灭
  不舍彼不得　　若能知者说

答有。谓除苦法忍眷属得。余无漏道得。彼初无漏舍。一切凡夫性不得。余不舍。先已舍故

  若成就八忍　　亦成就七智
  此诸无漏见　　不见何无漏

答有。谓此人住道比忍。成就一切见道慧。见一切灭一切道。唯除道比忍眷属。彼忍不见自性不自观故。无二性故。亦不见相应一行一缘故。不见共有一果一决定故

  颇法未曾得　　有漏边境界
  唯有不动者　　彼能击善法

答有。谓无相无相于无穷生死未曾得。而得空圣道故说有漏缘。非数灭故说边境界。余非分故说唯不动。空圣道故说击善法

  已起无漏慧　　于彼未起者
  前生非后因　　若能知者说

答有。谓前增非后软因。彼果相似及增故

  颇离六地欲　　圣亦成彼果
  不成无漏禅　　若能知者说

答有。谓空处离欲依禅未至超升离生。苦法忍生道比智未生。以八十九沙门果故。故言成彼果。以苦法智是苦法忍依果及功用果。见苦所断烦恼尽是解脱果及功用果。而不成无漏禅。未得故

  颇诸无漏法　　而为界所摄
  能生彼法者　　不入彼界中

答有。谓无漏戒彼界所摄。非漏所摄。戒者四大所造。彼果故。四大者触界所摄。身识境界故

  颇一大种灭　　于禅地不起
  二大种在前　　若能知者说

答有。谓圣人生欲界无漏初禅。次第有漏初禅现在前。一种四大灭。谓欲界四大以无漏随转。若于彼生现在前。即彼地四大造故。二种四大现在前者。谓欲界及初禅地四大(道共戒名无漏随转若于彼欲界生即彼欲界四大造故此四大与无漏俱起灭也)

  颇法因三道　　是三种自性
  谓三种一地　　亦复在三地

答有。谓无学慧。以彼见道修道无学道为因。尽智无生智无学等见是自性。软中上分别故说三种。无学地所摄故说一地。有觉有观等分别故在三地

  颇有有漏受　　二成一不成
  二根二种成　　是说为身证

答有。谓身证人依初禅初禅眷属及第二禅增进根。上地不现在前成就苦根有漏乐根。此人先得第三禅地无漏乐。以转根故舍复未更得。以依下地增进根故。不修上地学道。如得学果一忧根不成就。离欲故。喜根舍根各有二种。谓有漏无漏。是悉成就。以禅未至中间摄舍根。是故得舍根。初禅二禅摄喜根。是故得喜根

  九地烦恼灭　　而得于诸禅
  不得无色定　　或复得当说

答有。谓阿罗汉能得禅定非无色。诸禅亦得亦现在前。无色者成就而不行

  一法众多性　　或一三有无
  彼是无学法　　因力所长养

答有。谓无知根。建立一根故说言一。九根和合故说众多性。以众多性故说非一。一无学地故说一地。觉观分别故说三地。有者谓有名。无者无别事。无学得故说无学法。三因成故说因长养

  颇法是有分　　与彼余有分
  相似生住坏　　若能知者说

答有。谓色入是余有分。彼相与入俱生住灭。共一果故。色入者不作业故说余有分。彼相者法入摄故。是有分

  颇诸相应法　　或说余有分
  或复说有分　　若能知者说

答有。谓未来不生法意入。是余有分。不作业故。余心法是有分。法入摄故

  颇二阿那含　　共生于一地
  第一法或成　　俱得一地果

答有。谓一阿那含依第二禅超升离生。第二阿那含依第三禅。彼命终俱生第三禅。彼依二禅超升离生者。增进禅故。舍世间第一法即依第三禅者。成就不舍。上诸地亦如是。得一地果者。谓无觉无观禅

  颇有不动法　　俱受于一有
  一成就九地　　善有漏一无

答有。谓一生欲界一生初禅。生欲界者。九地有漏法成就。生初禅者。八地。除欲界地。增舍俱受一有故说一有。有漏者。以无漏生上成就下故说有漏

  颇住一刹那　　得舍三脱门
  或复舍于二　　一舍还复得

答有。谓生无色界当得阿罗汉住金刚三昧。得无学三昧门。舍学三脱门。舍灭受想定及非想非非想处。舍一切退分。得一切胜分(一念中亦舍亦得故言一念灭受想定及非想得断知言舍二舍退得胜故舍一得一也)

  颇成沙门果　　成就圣非圣
  而不得断知　　若能知者说

答有。谓无间等苦智生集智未生。尔时于八十九沙门果分成就。于四沙门果不成就。亦不得断知

  度彼无胜海　　少力所不任
  今我随所能　　宣说甚深义
  世间贫穷人　　彼可卒令富
  无智则不然　　要须大方便
  世间宝易得　　慧宝甚难获
  是故应勤学　　渐入甚深智
  正解涅槃路　　邪惑生死径
  慧能灭痴闇　　如日除幽冥
  为求解脱故　　当勤修智慧

萨婆多比丘。庄严阿毗昙偈。愿令一切众生。智慧渐增疾得解脱

杂阿毗昙心论卷第十一


众事分阿毗昙论

    No. 1541 [No. 1542]

众事分阿毗昙论卷第一

        尊者世友造

        宋天竺三藏求那跋陀罗共菩提耶舍译

    五法品第一五法

问云何五。答谓色心心法心不相应行无为。云何色。谓四大及四大造色。云何四大。谓地界水火风界。云何造色。谓眼根耳鼻舌身根色声香味触入少分。及无作色。是名色法。云何心。谓意及六识。云何六。谓眼识耳鼻舌身意识。是名心法。云何心法。谓若法心相应。谓受想思触忆欲解脱念定慧信精进觉观放逸不放逸善根不善根无记根一切结缚使烦恼上烦恼缠若智若见若无间等。此及余心相应共起者。是名心法法。云何心不相应行。谓若法不与心相应。谓诸得无想定灭尽定无想天命根种类处得事得入得生老住无常名身句身味身。此及余不与心相应共起者。是名心不相应行法

云何无为。谓三无为。虚空。数灭。非数灭。是名无为法

云何地界。谓坚。云何水界。谓湿润。云何火界。谓温暖。云何风界。谓飘动

云何眼根。谓眼识所依净色。云何耳根。谓耳识所依净色。云何鼻根。谓鼻识所依净色。云何舌根。谓舌识所依净色。云何身根。谓身识所依净色

云何色。谓色。若好若丑。若中间。彼二识识。先眼识。后意识。是名为色。云何声。声有二种。谓因受四大起。因不受四大起。彼二识识。先耳识。后意识。是名为声。云何香。谓香。若好若恶。若中间。彼二识识。先鼻识。后意识。是名为香。云何味。谓味若可喜。若不可喜。若中间。彼二识识。先舌识。后意识。是名为味。云何触入少分。谓涩滑轻重冷饥渴。彼二识识。先身识。后意识。是名触入少分

云何无作色。谓法入所摄色。彼一识识。谓意识。是名无作色

云何眼识。谓依眼根行于色。云何耳识。谓依耳根行于声。云何鼻识。谓依鼻根行于香。云何舌识。谓依舌根行于味。云何身识。谓依身根行于触。云何意识。谓依意根行于法

云何受。有三受。谓苦受。乐受。不苦不乐受。云何想。有三想。谓少想。多想。无量想。云何思。心所造作。三种业生。谓善不善无记。云何触。谓三事和合生三种触。谓苦触。乐触。不苦不乐触。云何忆。谓心发悟有三种。学无学非学非无学。云何欲。谓心欲作。云何解脱。谓心解已解当解。云何念。谓心不忘。云何定。谓一心。云何慧。谓于法决断。云何信。谓心净。云何精进。谓心堪能勇猛。云何觉。谓心粗。云何观。谓心细。云何放逸。谓不修善法。云何不放逸。谓修善法。云何善根。有三善根。谓无贪无恚无痴。云何不善根。有三不善根。谓贪恚痴。云何无记根。有四无记根。谓无记爱。无记见。无记慢。无记无明。云何结。有九结。谓爱结。恚结。慢结。无明结。见结。他取结。疑结。嫉结。悭结。云何爱结。谓三界贪。云何恚结。谓于众生相违。云何慢结。有七慢。谓慢。增慢。慢慢。我慢。增上慢。不如慢。邪慢。云何慢。于卑谓胜。于胜谓相似。于彼起轻心。自举自高。是名慢。云何增慢。于等谓胜。于胜谓等。于彼起轻心。自举自高。是名增慢。云何慢慢。于胜谓胜。于彼起轻心。自举自高。是名慢慢。云何我慢。于五受阴。计我我所有。于彼起轻心。自举自高。是名我慢。云何增上慢。未得胜法谓得。未到谓到。未触谓触。未证谓证。于彼起轻心。自举自高。是名增上慢。云何不如慢。于彼极胜。谓小不如。于彼起轻心。自举自高。是名不如慢。云何邪慢。非德谓德。于彼起轻心。自举自高。是名邪慢。如是七慢。名慢结。云何无明结。谓三界无知。云何见结。有三见。谓身见。边见。邪见。云何身见。谓五受阴。见我我所有。于彼起欲起忍起见。是名身见。云何边见。谓五受阴。或见常。或见断。于彼起欲起忍起见。是名边见。云何邪见。谓谤因果。于彼起欲起忍起见。是名邪见。如是三见。名见结。云何他取结。有二见。谓见取戒取。云何见取。谓五受阴第一胜妙。于彼起欲起忍起见。是名见取。云何戒取。谓五受阴。清净解脱出要。于彼起欲起忍起见。是名戒取。如是二见。名他取结。云何疑结。谓惑谛不了。云何嫉结。谓心嗔增广。云何悭结。谓心坚着。是名九结

云何缚。谓结即是缚。复有三缚。谓贪欲缚。嗔恚缚。愚痴缚

云何使。有七使。谓贪欲使。嗔恚使。有爱使。慢使。无明使。见使。疑使。云何贪欲使。有五种。谓欲界系见苦所断贪。欲界系见集灭道修道所断贪。如是五种。名贪欲使。云何嗔恚使。有五种。谓欲界系见苦所断嗔。欲界系见集灭道修道所断嗔。如是五种。名嗔恚使。云何有爱使。有十种。谓色界系五种。无色界系五种。云何色界系五种。谓色界系见苦所断爱。色界系见集灭道修道所断爱。如色界系五种。无色界系亦如是。如是十种。名有爱使。云何慢使。有十五种。谓欲界系五种。色界系五种。无色界系五种。云何欲界系五种。谓欲界系见苦所断慢。欲界系见集灭道修道所断慢。如欲界系五种。色无色界系亦如是。如是十五种。名慢使。云何无明使。有十五种。谓欲界系五种。色界系五种。无色界系五种。云何欲界系五种。谓欲界系见苦所断无明。欲界系见集灭道修道所断无明。如欲界系五种。色无色界系亦如是。如是十五种。名无明使。云何见使。有三十六种。谓欲界系十二种。色界系十二种。无色界系十二种。云何欲界系十二种。谓欲界系见苦所断身见边见邪见见取戒取。欲界系见集所断邪见见取。欲界系见灭所断邪见见取。欲界系见道所断邪见见取戒取。如欲界系十二种。色无色界系亦如是。如是三十六种。名见使。云何疑使。有十二种。谓欲界系四种。色界系四种。无色界系四种。云何欲界系四种。谓欲界系见苦所断疑。欲界系见集灭道所断疑。如欲界系四种。色无色界系亦如是。如是十二种。名疑使

云何烦恼上烦恼。所谓烦恼。即是上烦恼。复有上烦恼非烦恼。谓除烦恼。若余染污行阴。云何缠。有八缠。谓睡眠掉悔悭嫉无惭无愧(于十缠中无忿覆也)

云何智。有十智。谓法智比智知他心智等智苦智集智灭智道智尽智无生智

云何法智。谓知欲界系行苦无漏智。知欲界系行因无漏智。知欲界系行灭无漏智。知断欲界系行道无漏智。复次法智亦缘法智地无漏智。是名法智

云何比智。谓知色无色界系行苦无漏智。知色无色界系行因无漏智。知色无色界系行灭无漏智。知断色无色界系行道无漏智。复次比智亦缘比智地无漏智。是名比智

云何知他心智。谓若智修果修得不失。知欲界色界他众生现在心心法。亦知无漏心心法。是名知他心智

云何等智。谓有漏慧。是名等智

云何苦智。谓无漏智。思惟五受阴无常苦空非我。是名苦智

云何集智。谓无漏智。思惟有漏因因集有缘。是名集智

云何灭智。谓无漏智。思惟灭灭止妙离。是名灭智

云何道智。谓无漏智。思惟道道如迹乘。是名道智

云何尽智。谓我已知苦。我已断集。我已证灭。我已修道。于彼起智见明觉慧无间等。是名尽智

云何无生智。谓我已知苦。不复当知。我已断集。不复当断。我已证灭。不复当证。我已修道。不复当修。于彼起智见明觉慧无间等。是名无生智

复次我欲漏已尽。是名尽智。不复当生。是名无生智。我有漏无明漏已尽。是名尽智。不复当生。是名无生智

云何见。谓智即是见。或有见非智。所谓八无间忍。谓苦法忍。苦比忍。集法忍。集比忍。灭法忍。灭比忍。道法忍。道比忍。是名见。若智若见。即是无间等。云何得。谓得法。云何无想定。谓遍净天离欲。上地未离欲。作出要想思惟先方便。心及心法灭。是名无想定。云何灭尽定。谓无所有处离欲。上地未离欲。作止息想先方便。心及心法灭。是名灭尽定。云何无想天。谓众生生无想天。心及心法灭。是名无想天。云何命根。谓三界寿。云何种类。谓众生种类。云何处得。谓得方处。云何事得。谓得阴。云何入得。谓得内外入。云何生。谓转阴。云何老。谓阴熟。云何住。谓行起未坏。云何无常。谓行起坏。云何名身谓增语。云何句身。谓字满。云何味身。谓字身说味身。云何虚空。谓虚空无满。容受诸色。来去无碍。云何数灭。谓数灭灭是解脱。云何非数灭。谓非数灭灭非解脱

    众事分阿毗昙论分别智品第二

十智。云何十。谓法智比智知他心智等智苦智集智灭智道智尽智无生智

云何法智缘。谓法智欲界系行缘。及无漏缘。云何比智缘。谓比智色无色界系行缘。及无漏缘。云何知他心智缘。谓知他心智欲界色界系现在他心心法缘。及无漏缘。云何等智缘。谓等智一切法缘。云何苦智缘。谓苦智五受阴缘。云何集智缘。谓集智有漏因缘。云何灭智缘谓灭智数灭缘。云何道智缘。谓道智学法无学法缘。云何尽智缘。谓尽智一切有为法缘。及数灭缘。云何无生智缘。谓无生智一切有为法缘。及数灭缘

问以何等故。法智欲界系行缘。及无漏缘。答谓法智知欲界系行苦。知欲界系行因。知欲界系行灭。知断欲界系行道。是故说法智欲界系行缘及无漏缘

以何等故。比智色无色界系行缘。及无漏缘。谓比智知色无色界系行苦。知色无色界系行因。知色无色界系行灭。知断色无色界系行道。是故比智色无色界系行缘及无漏缘

以何等故。知他心智欲界色界系现在他心心法

及无漏缘。谓知他心智。知欲界色界现在他心心法及无漏缘。是故知他心智欲界色界系现在他心心法及无漏缘

以何等故。等智一切法缘。谓等智知一切法巧便不巧便非巧便非不巧便。是故等智一切法缘

以何等故。苦智五受阴缘。谓苦智知五受阴无常苦空非我。是故苦智五受阴缘

以何等故。集智有漏因缘。谓集智知有漏因因集有缘。是故集智有漏因缘

以何等故。灭智数灭缘。谓灭智知数灭灭止妙离。是故灭智数灭缘

以何等故。道智学无学法缘。谓道智知道道如迹乘。是故道智学无学法缘。以何等故。尽智一切有为法及数灭缘。谓尽智知我已知苦已断集已证灭已修道。是故尽智一切有为法及数灭缘

以何等故。无生智一切有为法及数灭缘。谓无生智知我已知苦不复当知。已断集不复当断。已证灭不复当证。已修道不复当修。是故无生智一切有为法及数灭缘

问法智。是几智。几智少分。答法智。即法智。七智少分。谓知他心智。苦智。集智。灭智。道智。尽智。无生智

问比智。是几智。几智少分。答比智。即比智。七智少分。谓知他心智。苦智。集智。灭智。道智。尽智。无生智

问知他心智。是几智。几智少分。答知他心智。即知他心智。四智少分。谓法智。比智。等智。道智

问等智。是几智。几智少分。答等智。即等智。一智少分。谓知他心智

问苦智是几智。几智少分。答苦智。即苦智。四智少分。谓法智。比智尽智。无生智。如苦智。集智灭智亦如是

问道智。是几智。几智少分。答道智。即道智。五智少分。谓法智。比智。知他心智。尽智。无生智。问尽智。是几智。几智少分。答尽智。即尽智。六智少分。谓法智。比智。苦集灭道智。如尽智。无生智亦如是

云何法智。即法智。谓法智知欲界系行苦。知欲界系行因。知欲界系行灭。知断欲界系行道。是故法智。即法智。云何法智知他心智。谓法智。知他断欲界系行道无漏心心法。是故法智知他心智

云何法智苦智。谓法智。知欲界系五受阴无常苦空非我。是故法智苦智。云何法智集智。谓法智知欲界系行因因集有缘。是故法智集智

云何法智灭智。谓法智。知欲界系行灭灭止妙离。是故法智灭智

云何法智道智。谓法智知断欲界系行道道如迹乘。是故法智道智

云何法智尽智。谓法智。知我已知欲界系行苦。知我已断欲界系行集。知我已证欲界系行灭。知我已修断欲界系行道。是故法智尽智

云何法智无生智。谓法智知我已知欲界系行苦不复当知。知我已断欲界系行集不复当断。知我已证欲界系行灭不复当证。知我已修断欲界系行道不复当修。是故法智无生智。云何比智。即比智。谓比智。知色无色界系行苦。知色无色界系行因。知色无色界系行灭。知断色无色界系行道。是故比智。即比智

云何比智知他心智。谓比智。知他断色无色界系行道无漏心心法。是故比智知他心智

云何比智苦智。谓比智。知色无色界系五受阴无常苦空非我。是故比智苦智

云何比智集智。谓比智。知色无色界系行因因集有缘。是故比智集智

云何比智灭智。谓比智。知色无色界系行灭灭止妙离。是故比智灭智

云何比智道智。谓比智。知断色无色界系行道道如迹乘。是故比智道智。云何比智尽智。谓比智。知我已知色无色界系行苦。知我已断色无色界系行集。知我已证色无色界系行灭。知我已修断色无色界系行道。是故比智尽智

云何比智无生智。谓比智。知我已知色无色界系行苦不复当知。知我已断色无色界系行集不复当断。知我已证色无色界系行灭不复当证。知我已修断色无色界系行道不复当修。是故比智无生智

云何知他心智。即知他心智。谓知他心智。知他欲界色界系现在心心法及无漏心心法。是故知他心智。即知他心智

云何知他心智法智。谓知他心智。知他断欲界系行道无漏心心法。是故知他心智法智

云何知他心智比智。谓知他心智。知他断色无色界系行道无漏心心法。是故知他心智比智

云何知他心智等智。谓知他心智。知他有漏心心法。是故知他心智等智。云何知他心智道智。谓知他心智。知他无漏心心法。是故知他心智道智。云何等智即等智。谓等智知一切法巧便不巧便非巧便非不巧便。是故等智即等智

云何等智知他心智。谓等智。知他有漏心心法。是故等智知他心智

云何苦智即苦智。谓苦智。知五受阴无常苦空非我。是故苦智即苦智

云何苦智法智。谓苦智。知欲界系五受阴无常苦空非我。是故苦智法智。云何苦智比智。谓苦智。知色无色界系五受阴无常苦空非我。是故苦智比智

云何苦智尽智谓苦智。知我已知苦。是故苦智尽智

云何苦智无生智。谓苦智。知我已知苦不复当知。是故苦智无生智

云何集智即集智。谓集智知有漏因因集有缘。是故集智即集智

云何集智法智。谓集智知欲界系行因因集有缘。是故集智法智

云何集智比智。谓集智。知色无色界系行因因集有缘。是故集智比智

云何集智尽智。谓集智。知我已断集。是故集智尽智

云何集智无生智。谓集智。知我已断集不复当断。是故集智无生智

云何灭智即灭智。谓灭智知灭灭止妙离。是故灭智即灭智

云何灭智法智。谓灭智。知欲界系行灭灭止妙离。是故灭智法智

云何灭智比智。谓灭智。知色无色界系行灭灭止妙离。是故灭智比智

云何灭智尽智。谓灭智。知我已证灭。是故灭智尽智

云何灭智无生智。谓灭智。知我已证灭不复当证。是故灭智无生智

云何道智即道智。谓道智。知道道如迹乘。是故道智即道智

云何道智法智。谓道智。知断欲界系行道道如迹乘。是故道智法智

云何道智比智。谓道智。知断色无色界系行道道如迹乘。是故道智比智。云何道智知他心智。谓道智。知他无漏心心法。是故道智知他心智

云何道智尽智。谓道智。知我已修道。是故道智尽智

云何道智无生智。谓道智。知我已修道不复当修。是故道智无生智

云何尽智即尽智。谓尽智。知我已知苦我已断集我已证灭我已修道。是故尽智即尽智

云何尽智法智。谓尽智。知我已知欲界系行苦。我已断欲界系行集。我已证欲界系行灭。我已修断欲界系行道。是故尽智法智

云何尽智比智。谓尽智知我已知色无色界系行苦。我已断色无色界系行集。我已证色无色界系行灭。我已修断色无色界系行道。是故尽智比智

云何尽智苦智。谓尽智。知我已知苦。是故尽智苦智

云何尽智集智。谓尽智。知我已断集。是故尽智集智

云何尽智灭智。谓尽智。知我已证灭。是故尽智灭智

云何尽智道智。谓尽智。知我已修道。是故尽智道智

云何无生智即无生智。谓无生智。知我已知苦不复当知。我已断集不复当断。我已证灭不复当证。我已修道不复当修。是故无生智即无生智

云何无生智法智谓无生智。知我已知欲界系行苦不复当知。我已断欲界系行集不复当断。我已证欲界系行灭不复当证。我已修断欲界系行道不复当修。是故无生智法智

云何无生智比智。谓无生智。知我已知色无色界系行苦不复当知。我已断色无色界系行集不复当断。我已证色无色界系行灭不复当证。我已修断色无色界系行道不复当修。是故无生智比智

云何无生智苦智。谓无生智。知我已知苦不复当知。是故无生智苦智

云何无生智集智。谓无生智。知我已断集不复当断。是故无生智集智

云何无生智灭智。谓无生智。知我已证灭不复当证。是故无生智灭智

云何无生智道智。谓无生智。知我已修道不复当修。是故无生智道智

问此十智。几有漏。几无漏。答一有漏。八无漏。一当分别。知他心智。或有漏。或无漏。云何有漏。谓知他心智。知他有漏心心法。云何无漏。谓知他心智。知他无漏心心法

问此十智。几有漏缘。几无漏缘。答二有漏缘。谓苦智集智。二无漏缘。谓灭智道智。六当分别。法智。或有漏缘。或无漏缘。云何有漏缘。谓法智苦缘集缘。云何无漏缘。谓法智灭缘道缘。如法智。比智尽智无生智亦如是。知他心智。或有漏缘。或无漏缘。云何有漏缘谓知他心智。知他有漏心心法。云何无漏缘谓知他心智。知他无漏心心法。等智。或有漏缘。或无漏缘。云何有漏缘。谓等智苦缘集缘。云何无漏缘。谓等智灭缘道缘。及虚空非数灭缘。问此十智。几有为。几无为。答谓十智一切是有为无无为

问此十智。几有为缘。几无为缘。答四有为缘。谓知他心智。苦智集智。道智。一无为缘。谓灭智。五当分别。法智。或有为缘。或无为缘。云何有为缘。谓法智。苦缘。集缘。道缘。云何无为缘。谓法智灭缘。如法智。比智尽智无生智亦如是。等智。或有为缘。或无为缘。云何有为缘。谓等智。苦缘。集缘。道缘。云何无为缘。谓等智二种。灭缘及虚空缘

众事分阿毗昙论卷第一众事分阿毗昙论卷第二

        尊者世友造

        宋天竺三藏求那跋陀罗共菩提耶舍译

    分别诸入品第三

如世尊为阇谛输卢那婆罗门说。一切婆罗门。当知。一切者。谓十二入。云何十二。谓眼入色入耳入声入鼻入香入舌入味入身入触入意入法入。问此十二入。几色。几非色。答十是色。一非色。一分别。法入。或色。或非色。云何色。谓法入所摄身口业是色。余非色。此十二入。几可见。几不可见。谓一可见。十一不可见

此十二入。几有对。几无对。谓十有对。二无对。此十二入。几有漏。几无漏。谓十有漏。二分别。意入。或有漏。或无漏。云何有漏。谓有漏意行相应意入。云何无漏。谓无漏意行相应意入。法入。或有漏。或无漏。云何有漏。谓法入所摄有漏身口业。有漏受阴想阴行阴。云何无漏。谓无漏身口业。无漏受阴想阴行阴。及无为法

此十二入。几有为。几无为。谓十一有为。一分别。法入或有为或无为。云何有为。谓法入所摄身口业。受阴想阴行阴。云何无为。谓虚空数灭非数灭。此十二入。几有诤。几无诤。谓十有诤。二分别。二若有漏有诤。二若无漏无诤。如有诤无诤如是。世间出世间。有过无过。依家依出要。使非使。受非受。缠非缠。亦如是

此十二入几有记。几无记。谓八无记。四分别。色入。或有记。或无记。云何有记。谓善不善色入。云何无记。谓除善不善色入。诸余色入。如色入。声入意入法入亦如是

此十二入。几隐没。几不隐没。谓八不隐没。四分别。色入。或隐没。或不隐没。云何隐没。谓秽污。云何不隐没。谓不秽污。如色入。声入意入法入亦如是

此十二入。几应修。几不应修。谓八不应修。四分别。色入。或应修。或不应修。云何应修。谓善色入。云何不应修。谓不善无记色入。如色入。声入意入亦如是。法入。或应修。或不应修。云何应修。谓善有为法入。云何不应修。谓不善无记法入。及数灭

此十二入。几秽污。几不秽污。谓八不秽污。四分别。色入。或秽污。或不秽污。云何秽污。谓隐没。云何不秽污。谓不隐没。如色入。声入意入法入亦如是。此十二入。几有罪。几无罪。谓八无罪。四分别。色入。或有罪。或无罪。云何有罪。谓不善色入。及隐没无记。云何无罪。谓善色入。及不隐没无记。如色入。声入意入法入亦如是

此十二入。几有报。几无报。谓八无报。四分别。色入。或有报。或无报。云何有报。谓善不善色入。云何无报。谓无记色入。如色入。声入亦如是。意入。或有报或无报。云何有报。谓不善善有漏意入。云何无报。谓无记无漏意入。如意入。法入亦如是

此十二入。几见。几非见。谓一是见。十非见。一分别。法入。或见。或非见。云何见。谓八见名见。谓五邪见。世俗正见。学见。无学见。余非见。此十二入。几内。几外。谓六内。六外

此十二入。几受。几不受。谓三不受。九分别。眼入。或受。或不受。云何受谓自性受。云何不受。谓非自性受。如眼入。色入耳入鼻入香入舌入味入身入触入亦如是

此十二入。几心。几非心。谓一是心。十一非心

此十二入。几有缘。几无缘。谓一有缘。十无缘。一分别。法入。或有缘。或无缘。云何有缘。谓心法。云何无缘。谓非心法。此十二入。几心法。几非心法。谓十一非心法。一分别。法入。或心法。或非心法。云何心法。谓有缘。云何非心法。谓无缘

此十二入。几业。几非业。谓九非业。三分别色入。或业。或非业。云何业。谓身作是业。余非业。声入。或业。或非业。云何业。谓口作是业。余非业。法入。或业。或非业。云何业。谓法入所摄身口业及思是业。余非业

此十二入。几善不善无记。谓八无记。四分别。色入。或善不善无记。云何善。谓善身作。云何不善。谓不善身作。云何无记。谓除善不善身作色。余身作色。声入。或善不善无记。云何善。谓善口声。云何不善。谓不善口声。云何无记。谓除善不善口声。诸余口声。意入。或善不善无记。云何善。谓善意思惟相应意入。云何不善。谓不善意思惟相应意入。云何无记。谓无记意思惟相应意入。法入。或善不善无记。云何善。谓法入所摄善身口业善受阴想阴行阴及数灭。云何不善。谓法入所摄不善身口业不善受阴想阴行阴。云何无记。谓法入所摄无记受阴想阴行阴及虚空非数灭

此十二入。几见断。几修断。几不断。谓十修断。二分别。意入。或见断。或修断。或不断。云何见断。若意入随信行随法行人无间忍等断。彼云何断。谓见断八十八使相应意入。云何修断。若意入学见迹修断。彼云何断。谓修断十使相应意入。及不秽污有漏意入。云何不断。谓无漏意入。法入。或见断。或修断。或不断。云何见断。若法入随信行随法行人无间忍等断。彼云何断。谓见断八十八使彼相应法入。彼所起心不相应行。云何修断。若法入学见迹修断。彼云何断。谓修断十使彼相应法入。彼所起身口业彼所起心不相应行。及不秽污有漏法入。云何不断。谓无漏法入

此十二入。几学。几无学。几非学非无学。谓十非学非无学。二分别。意入。或学。或无学。或非学非无学。云何学。谓学意思惟相应意入。云何无学。谓无学意思惟相应意入。云何非学非无学。谓有漏意思惟相应意入。法入。或学。或无学。或非学非无学。云何学。谓学身口业学受阴想阴行阴。云何无学。谓无学身口业无学受阴想阴行阴。云何非学非无学。谓法。入所摄有漏身口业有漏受阴想阴行阴。及无为法。此十二入。几欲界系。几色无色界系。几不系。谓二欲界系。十分别。眼入。或欲界系。或色界系。云何欲界系。谓眼入欲界系四大所造。云何色界系。谓眼入色界系四大所造。如眼入。色入耳入声入鼻入。舌入身入亦如是。触入。或欲界系。或色界系。云何欲界系。谓触入欲界系四大所造。云何色界系。谓触入色界系四大所造。意入。或欲界系。或色界系。或无色界系。或不系。云何欲界系。谓欲界系意思惟相应意入。云何色界系。谓色界系意思惟相应意入。云何无色界系。谓无色界系意思惟相应意入。云何不系。谓无漏意思惟相应意入。法入。或欲界系。或色界系。或无色界系。或不系。云何欲界系。谓法入欲界系。彼所摄身口业彼所摄受阴想阴行阴。云何色界系。谓法入色界系。彼所摄身口业。彼所摄受阴想阴行阴。云何无色界系。谓法入无色界系。彼所摄受阴想阴行阴。云何不系。谓无漏所摄身口业无漏所摄受阴想阴行阴。及无为法。此十二入。几过去。几未来。几现在。谓十一。或过去。或未来。或现在。一分别。法入。若有为。或过去。或未来。或现在。若无为。非过去。非未来。非现在

此十二入。几苦谛摄。几集谛摄。几灭谛摄。几道谛摄。几非谛摄。谓十苦集谛所摄。二分别。意入。若有漏。苦集谛所摄。若无漏。道谛所摄法入。若有漏。苦集谛所摄。若无漏。有为道谛所摄。若数灭。灭谛所摄。虚空非数灭。非谛所摄

此十二入。几见苦断。几见集断。几见灭断。几见道断。几修断。几不断。谓十修断。二分别。意入。或见苦断。或见集断。或见灭断。或见道断。或修断。或不断。云何见苦断。若意入随信行随法行人苦无间忍等断。彼云何断。谓见苦断二十八使相应意入。云何见集断。若意入随信行随法行人集无间忍等断。彼云何断。谓见集断十九使相应意入。云何见灭断。若意入随信行随法行人灭无间忍等断。彼云何断。谓见灭断十九使相应意入。云何见道断。若意入随信行随法行人道无间忍等断。彼云何断。谓见道断二十二使相应意入。云何修断。若意入学见迹修断。彼云何断。谓修断十使相应意入。及不秽污有漏意入。云何不断。谓无漏意入。法入。或见苦断。或见集断。或见灭断。或见道断。或修断。或不断。云何见苦断。若法入随信行随法行人苦无间忍等断。彼云何断。谓见苦断二十八使彼相应法入。彼所起心不相应行。云何见集断。若法入随信行随法行人集无间忍等断。彼云何断。谓见集断十九使彼相应法入。彼所起心不相应行。云何见灭断。若法入随信行随法行人灭无间忍等断。彼云何断。谓见灭断十九使彼相应法入。彼所起心不相应行。云何见道断。若法入随信行随法行人道无间忍等断。彼云何断。谓见道断二十二使彼相应法入。彼所起心不相应行。云何修断。若法入学见迹修断。彼云何断。谓修断十使彼相应法入。彼所起身口业彼所起心不相应行。及不秽污有漏法入。云何不断。谓无漏法入

问五阴十二入。为五阴摄十二入。为十二入

摄五阴。答十二入摄五阴。非五阴摄十二入。何所不摄。谓无为法入

问五阴十八界。为五阴摄十八界。为十八界摄五阴。答十八界摄五阴。非五阴摄十八界。何所不摄。谓无为法界。问五阴二十二根。为五阴摄二十二根。为二十二根摄五阴。答二阴。及二阴少分。摄二十二根。二十二根亦摄二阴及二阴少分。何所不摄。谓一阴。及二阴少分

问五阴九十八使。为五阴摄九十八使。为九十八使摄五阴。答一阴少分摄九十八使。九十八使亦摄一阴少分。何所不摄。谓四阴。及一阴少分

问十二入十八界。为十二入摄十八界。为十八界摄十二入。答展转相摄。随其所应

问十二入二十二根。为十二入摄二十二根。为二十二根摄十二入。答六内入。及一外入少分。摄二十二根。二十二根亦摄六内入及一外入少分。何所不摄。谓五外入。及一外入少分。问十二入九十八使。为十二入摄九十八使。为九十八使摄十二入。答一外入少分。摄九十八使。九十八使亦摄一外入少分。何所不摄。谓十一入。及一外入少分

问十八界二十二根。为十八界摄二十二根。为二十二根摄十八界。答十二内界。及一外界少分。摄二十二根。二十二根亦摄十二内界及一外界少分。何所不摄。谓五外界。及一外界少分

问十八界九十八使。为十八界摄九十八使。为九十八使摄十八界。答一外界少分摄九十八使。九十八使亦摄一外界少分。何所不摄。谓十七界。及一外界少分

问二十二根九十八。使为二十二根摄九十八。使为九十八使摄二十二。根答展转不相摄

    众事分阿毗昙论分别七事品第四

十八界。十二入。五阴。五盛阴。六界。十大地法。十烦恼大地法。十小烦恼大地法。五烦恼。五触。五见。五根。五法。六识身。六触身。六受身。六想身。六思身。六爱身

云何十八界。谓眼界色界眼识界。耳界声界耳识界。鼻界香界鼻识界。舌界味界舌识界。身界触界身识界。意界法界意识界

云何十二入。谓眼入色入耳入声入鼻入香入舌入味入身入触入意入法入

云何五阴。谓色阴受阴想阴行阴识阴。云何五盛阴。谓色盛阴受盛阴想盛阴行盛阴识盛阴

云何六界。谓地界水界火界风界虚空界识界

云何十大地法。谓受想思触忆欲解脱念定慧。云何十烦恼大地法。谓不信懈怠忘念乱无明邪慧邪忆邪解脱掉放逸。云何十小烦恼大地法。谓忿恨覆恼嫉悭诳谄憍害

云何五烦恼。谓欲贪色贪无色贪嗔恚痴。云何五触。谓对触增上语触明触无明触非明非无明触。云何五见。谓身见边见邪见取见见取戒见。云何五根。谓乐根苦根喜根忧根舍根。云何五法。谓觉观识无惭无愧

云何六识身。谓眼识耳识鼻识舌识身识意识。云何六触身。谓眼触耳触鼻触舌触身触意触。云何六受身。谓眼触生受耳鼻舌身意触生受。云何六想身。谓眼触生想耳鼻舌身意触生想。云何六思身。谓眼触生思耳鼻舌身意触生思。云何六爱身。谓眼触生爱耳鼻舌身意触生爱

云何眼界。若眼于色。已见今见当见。随彼一一有分。云何色界。若色于眼。已见今见当见。随彼有分。云何眼识界。若眼见色起眼识。眼增上见色。若眼识于色。若识分别知色。是名眼识界。云何耳界。若耳于声。已闻今闻当闻。随彼一一有分。云何声界。若声于耳。已闻今闻当闻。随彼有分。云何耳识界。若耳闻声起耳识。耳增上闻声。若耳识于声。若识分别知声。是名耳识界云何。鼻界若鼻于香。已觉今觉。当觉随彼一。一有分云何香界。若香于鼻已。觉今觉当觉。随彼有分云何。鼻识界若鼻觉香起鼻识。鼻增上觉香。若鼻识于香。若识分别知香。是名鼻识界。云何舌界。若舌于味。已尝今尝当尝。随彼一一有分。云何味界。若味于舌。已尝今尝当尝。随彼有分。云何舌识界。若舌尝味起舌识。舌增上尝味。若舌识于味。若识分别知味。是名舌识界。云何身界。若身于触。已觉今觉当觉。随彼一一有分。云何触界。若触于身。已觉今觉当觉。随彼有分。云何身识界。若身觉触起身识。身增上觉触。若身识于触。若识分别知触。是名身识界。云何意界。若意于法。已识今识当识。随彼一一有分。云何法界。若法于意。已识今识当识。随彼有分。云何意识界。若意缘法起意识。意增上缘法。若意识于法。若识分别知法。是名意识界。眼入乃至法入。广说亦如是

云何色阴。谓十种色入。及法入所摄色。云何受阴。谓六受身。云何六。谓眼触生受。乃至意触生受。云何想阴。谓六想身。云何六。谓眼触生想。乃至意触生想。云何行阴。行阴有二种。谓心相应。心不相应。云何心相应行阴。谓思触忆欲解脱念定慧信精进觉观放逸不放逸善根不善根无记根一切结缚使烦恼上烦恼缠一切智一切见一切无间等。如是比心相应法。是名心相应行阴。云何心不相应行阴。谓诸得无想正受灭尽正受无想天命根身种类处得事得入得。生住异灭名身句身味身。如是比心不相应法。是名心不相应行阴。彼二法。总为行阴数。云何识阴。谓六识身。云何六。谓眼识身。乃至意识身。云何色盛阴。若色有漏盛受。谓此色。若于过去未来现在起欲。已起当起。或贪或恚或痴。彼一一心数烦恼。已起当起。是名色盛阴。受想行盛阴亦如是。云何识盛阴。若识有漏盛受。谓此识。若于过去未来现在起欲。已起当起。或贪或恚或痴。彼一一心数烦恼。已起当起。是名识盛阴

云何地界。谓坚相乃至风界。如五法品说。云何虚空界。谓空边色。云何识界。谓五识身。及有漏意识身

云何受。谓受觉知痛等苦乐俱非三境界转。云何想。谓想等想增上想。于像貌转。云何思。谓思等思增上思。思起心行于业。云何触。谓触等触增上触。依缘心和合转。云何忆。谓心发悟。忆念思惟心行境界。云何欲。谓欲于缘坚持深着。为作欲乐。云何解脱。谓心解脱。意于缘解。云何念。谓念随。念不舍。于缘不废乱忘。云何定。谓心等住。不动移境。不散不乱。摄受止一。云何慧。谓心于法。起选择相决断觉知照了观察。云何不信。谓心不信受。不正思惟。不修德本。不种善行。不造胜业。意不清净。云何懈怠。谓心下劣。不勤勇猛。意不捷疾。云何忘念。谓念虚妄。外向邪记。云何乱。谓心乱散。飘驰转动。缘不止一。云何无明。谓愚三界闇无知。云何邪慧。谓不顺正念。邪解决断。云何邪忆。谓秽污意行。曲受境界。不正思惟。云何邪解脱。谓秽污意行。解脱于缘。云何掉。谓心躁动。不依寂静。云何放逸。谓舍正方便。作不应作。于诸善法。不勤修习。云何忿。谓于不饶益事。于嗔相续起心忿。云何恨。谓若事不顺所欲起心恨。云何覆。谓覆藏自罪。云何恼。谓若心热烧。云何嫉。谓于所嫌。不欲彼利。起心妒忌。云何悭。谓心所受坚着不舍。云何诳。谓欺伪他。云何谄。谓起心曲行。云何憍。谓心醉举迷。云何害。谓恼切众生。起心逼迫

云何欲贪。若欲贪等贪。结聚贪室。坚着爱乐。云何色贪。若色贪等贪。结聚贪室。坚着爱乐。云何无色贪。若无色贪等贪。结聚贪室。坚着爱乐。云何嗔恚。谓于彼众生。起损害心。诽谤苦切。云何疑。谓惑谛不了。云何对触。谓五识身相应触。云何增上语触。谓意识身相应触。云何明触。谓无漏触。云何无明触。谓秽污触。云何非明非无明触。谓不秽污有漏触。云何身见。谓于五盛阴。起我我所有见。于彼堪忍乐着。云何边见。谓于五盛阴。或断常见。于彼堪忍乐着。云何邪见。谓诽谤因果。毁所应作。于彼堪忍乐着。云何取见见。谓于五盛阴起第一见最上最胜。于彼堪忍乐着。云何取戒见。谓于五盛阴。起见清净解脱出要。于彼堪忍乐着。云何乐根。若乐受触所触。若起身意乐。起觉知想。云何苦根。若苦受触所触。苦起身等苦。起觉知想。云何喜根。若喜受触所触。若起心喜想觉受生。云何忧根。若忧受触所触。若起心苦想觉受生。云何舍根。若不苦不乐受触所触。若起身心。非觉受。非不觉受生。云何觉。若心觉遍觉。色觉增上色觉。觉数觉觉等思惟粗心转。云何观。若心行少行随微行。随顺细心转。云何识。谓六识身。眼识乃至意识。云何无惭。若心无惭。不厌患过。不极厌离。不恭敬。不柔软。不自畏。不自差。恣心自在。云何无愧。若无愧于他。于罪无畏。于罪无怖。于罪不见。于诸过恶。不羞耻他

云何眼识。谓眼缘色起眼识。眼增上缘色。眼识于色。若识若分别色。是名眼识。乃至意识是亦如

云何眼触。谓眼缘色起眼识。三和合生触。眼增上缘色。眼识于色。若触等触。是名眼触。耳鼻舌身亦如是。云何意触。谓意缘法起意识。三和合生触。意增上缘法。意识于法。若触等触。是名意触

云何眼触生受。谓眼缘色起眼识。三和合生触。触缘受。眼增上缘色。眼触。因眼触。集眼触。生眼触。有眼触。意思惟相应。眼识于色。若觉受等受。是名眼触生受。耳鼻舌身亦如是

云何意触生受。谓意缘法起意识。三和合生触。触缘受。意增上缘法。意触。因意触。集意触。生意触。有意触。思惟相应。意识于法。若觉受等受。是名意触生受

云何眼触生想。谓眼缘色起眼识。三和合生触。触缘想。眼增上缘色。眼触。因眼触。集眼触。生眼触。有眼触。意思惟相应。眼识于色。若想等想。增上想。分别想。是名眼触生想。耳鼻舌身亦如是

云何意触生想。谓意缘法起意识。三和合生触。触缘想。意增上缘法。意触。因意触。集意触。生意触。有意触。思惟相应。意识于法。若想等想。增上想。分别想。是名意触生想

云何眼触生思谓眼缘色起眼识。三和合生触。触缘思。眼增上缘色。眼触。因眼触。集眼触。生眼触。有眼触。意思惟相应。眼识于色。若思等思。增上思。思转心行于业。是名眼触生思。耳鼻舌身亦如是

云何意触生思。谓意缘法起意识。三和合生触。触缘思。意增上缘法。意触。因意触。集意触。生意触。有意触。思惟相应。意识于法。若思等思。增上思。思转心行于业。是名意触生思

云何眼触生爱。谓眼缘色起眼识。三和合生触。触缘受。受缘爱。眼增上缘色。眼识于色。若贪贪聚贪室。坚着爱乐。是名眼触生爱。耳鼻舌身亦如是。云何意触生爱。谓意缘法起意识。三和合生触。触缘受。受缘爱。意增上缘法。意识于法。若贪贪聚贪室。坚着爱乐。是名意触生爱

问眼界。几界。几入。几阴摄。眼界摄法。几界。几入。几阴摄。眼界不摄法。几界。几入。几阴摄眼界摄不摄法。几界。几入。几阴摄。除眼界摄法。余法。几界。几入。几阴摄。除眼界不摄法。余法。几界。几入。几阴摄。除眼界摄不摄法。余法。几界。几入。几阴摄。如眼界。乃至意触生爱亦如是

答眼界。一界。一入。一阴摄。不摄十七界十一入五阴。如眼界。眼界摄法亦如是

眼界不摄法。十七界十一入五阴摄。不摄一界一入一阴。眼界摄不摄法。十八界十二入五阴摄。除眼界摄法。余法。十七界十一入五阴摄。不摄一界一入一阴。除眼界不摄法。余法。一界一入一阴摄。不摄十七界十一入五阴。除眼界摄法。余法。如眼界不摄。除眼界不摄法。余法。如眼界。除眼界摄不摄法。若问余法虚空无事无论。如眼界。九色界十色入亦如是

眼识界。一界一入一阴摄。不摄十七界十二入五阴。如眼识界。耳鼻舌身意识界六识身亦如是

意界。七界一入一阴摄。不摄十一界十一入四阴。如意界。意入识阴识法亦如是

法界。一界一入四阴摄。不摄十七界十一入二阴。如法界。法入亦如是

色阴。十一界十一入一阴摄。不摄八界二入四阴

受阴。一界一入一阴摄。不摄十八界十二入四阴。如受阴。想阴行阴受大地想大地亦如是

色盛阴。十一界十一入一阴摄。不摄八界二入五阴

受盛阴。一界一入一阴摄。不摄十八界十二入五阴。如受盛阴。想盛阴行盛阴五色界八大地法十烦恼大地法十小烦恼大地法五烦恼五触五见五根四法五六。亦如是

识盛阴。七界一入一阴摄。不摄十三界十二入五阴。如识盛阴。识界亦如是。眼识界。一界一入三阴相应。不相应者。十八界十二入五阴。如眼识界。耳鼻舌身意识界识盛阴识界六识身亦如是

意界。一界一入三阴相应。不相应者。十八界十二入三阴。如意界。意入识阴识法亦如是。法界。八界二入四阴相应。不相应者。十一界十一入二阴。如法界。法入行阴八大地法亦如是。受阴。八界二入三阴相应。不相应者。十一界十一入三阴。如受阴。想阴受大地想大地亦如是

受盛阴。八界二入三阴相应。不相应者。十三界十二入五阴。如受盛阴。想盛阴亦如是

行盛阴。八界二入四阴相应。不相应者。十三界十二入五阴。如行盛阴。觉观法亦如是

不信。八界二入四阴相应。不相应者。十八界十二入五阴。如不信。余烦恼大地法亦如是。欲贪嗔恚无明触非明非无明触无惭无愧亦如是

忿三界二入四阴相应。不相应者十八界十二入五阴。如忿。余小烦恼大地法无色界贪疑明触五见六受身亦如是

色贪。六界二入四阴相应。不相应者。十八界十二入五阴

对触。七界二入四阴相应。不相应者。十三界十二入五阴

增上语触。三界二入四阴相应。不相应者。十七界十二入五阴。如增上语触。六触身六思身亦如是

乐根。八界二入三阴相应。不相应者。十八界十二入五阴。如乐根。舍根亦如是

苦根。七界二入三阴相应。不相应者。十八界十二入五阴

喜根。三界二入三阴相应。不相应者。十八界十二入五阴。如喜根。忧根亦如是

眼触生受。三界二入三阴相应。不相应者。十七界十二入五阴。如眼触生受。耳鼻舌身意触生受六想身亦如是

众事分阿毗昙论卷第二众事分阿毗昙论卷第三

        尊者世友造

        宋天竺三藏求那跋陀罗共菩提耶舍译

    分别诸使品第五

问九十八使。几界系。答三界系。谓欲界。色界。无色界。问此九十八使。几欲界系。几色界系。几无色界系。答三十六欲界系三十一色界系。三十一无色界系。问此九十八使。几见断。几修断。答八十八见断。十修断

问此欲界系三十六使。几见断。几修断。答三十二见断。四修断。问此色界系三十一使。几见断。几修断。答二十八见断。三修断。如色界系。无色界系亦如是

问此九十八使。几见苦断。几见集断。几见灭断。几见道断。几修断。答二十八见苦断。十九见集断。十九见灭断。二十二见道断。十修断。问此欲界系三十六使。几见苦断。几见集断。几见灭断。几见道断。几修断。答十见苦断。七见集断。七见灭断。八见道断。四修断。问此色界系三十一使。几见苦断。几见集断。几见灭断。几见道断。几修断。答九见苦断。六见集断。六见灭断。七见道断。三修断。如色界系。无色界系亦如是

问使是何义。答微细是使义。使是使义。随入是使义。随逐是使义。谓彼使不断不知二事使。使缘使及相应使彼自界非他界。十二使。贪使。恚使。色贪使。无色贪使。慢使。无明使。身见使。边见使。邪见使。见取使。戒取使。疑使。云何欲贪使使。谓爱染念着。悦乐可意。云何恚使使。谓不爱不乐。不念不悦。不可意。云何色贪使使。谓爱乐净。可乐可意。云何无色贪使使。谓爱乐可意。云何慢使使。谓贡高自举。云何无明使使。谓无照闇愚。云何身见使使。谓计我我所有。云何边见使使。谓所计或断或常。云何邪见使使。谓无作无得。起见诽谤。云何见取使使。谓上胜第一。云何戒取使使。谓清净解脱。起出要见。云何疑使使。谓惑谛不了。三处起欲爱使。此欲爱使。不断不知。欲爱缠所缠法。乐着境界。恶意思惟行。如是乃至三处起疑使。此疑使。不断不知。疑缠所缠法。乐着境界。恶意思惟行

问七使十二使。为七使摄十二使。为十二使摄七使。答展转相摄随其事。云何随其事。彼欲贪使。欲贪使摄。嗔恚使。嗔恚使摄。有贪使。二使摄。慢使。慢使摄。无明使。无明使摄。见使。五见使摄。疑使。疑使摄。是七使摄十二使。十二使亦摄七使。是故说展转相摄随其事

问七使。九十八使。为七使摄九十八使。为九十八使摄七使。答展转相摄随其事。云何随其事。彼欲贪使摄五嗔恚使摄五。有贪使摄十。慢使摄十五。无明使摄十五。见使摄三十六。疑使摄十二。是七使摄九十八使。九十八使亦摄七使。是故说展转相摄随其事

问十二使。九十八使。为十二使摄九十八使。为九十八使摄十二使。答展转相摄随其事。云何随其事。彼欲贪使摄五。嗔恚使摄五。色贪使摄五。无色贪使摄五。慢使摄十五。无明使摄十五。身见使摄三。边见使摄三。邪见使摄十二。见取使摄十二。戒取使摄六。疑使摄十二。是十二使摄九十八使。九十八使亦摄十二使。是故说展转相摄随其事

问此九十八使。几一切遍。几不一切遍。答二十七一切遍。六十五不一切遍。六分别。见苦集断无明使。或一切遍。或不一切遍。云何一切遍。谓见苦集断。不一切遍使不相应无明。云何不一切遍。谓见苦集断。不一切遍使相应无明

问此欲界系三十六使。几一切遍。几不一切遍。答九一切遍。二十五不一切遍。二分别。欲界系见苦集断无明使。或一切遍。或不一切遍。云何一切遍。谓欲界系见苦集断。不一切遍使不相应无明。云何不一切遍。谓欲界系见苦集断。不一切遍使相应无明

问此色界系三十一使。几一切遍。几不一切遍。答九一切遍。二十不一切遍。二分别。色界系见苦集断无明使。或一切遍。或不一切遍。云何一切遍。谓色界系见苦集断。不一切遍使不相应无明。云何不一切遍。谓色界系见苦集断。不一切遍使相应无明。如色界系。无色界系亦如是

问此九十八使。几一切遍修断。几不一切遍非修断。答三十七一切遍修断。五十五不一切遍非修断。六分别。见苦集断无明使。或一切遍。或不一切遍。云何一切遍。谓见苦集断。不一切遍不相应无明使。云何不一切遍。谓见苦集断。不一切遍相应无明使。问此欲界系三十六。使几一切遍修断。几不一切遍非修断。答十三一切遍修断。二十一不一切遍非修断。二分别。欲界系见苦集断无明使。或一切遍。或不一切遍。云何一切遍。谓欲界系见苦集断。不一切遍使不相应无明使。云何不一切遍。谓欲界系见苦集断。不一切遍使相应无明使

问此色界系三十一使。几一切遍修断。几不一切遍非修断。答十二一切遍修断。十七不一切遍非修断。二分别见苦集断无明使。或一切遍。或不一切遍。云何一切遍。谓色界系见苦集断。不一切遍使不相应无明使。云何不一切遍谓色界系见苦集断。不一切遍使相应无明使。如色界系。无色界系亦如是

问此九十八使。几有漏缘。几无漏缘。答八十有漏缘。十二无漏缘。六分别。见灭见道断无明使。或有漏缘。或无漏缘。云何有漏缘。谓见灭见道断。有漏缘使相应无明使。云何无漏缘。谓见灭见道断。有漏缘使不相应无明使。问此欲界系三十六使。几有漏缘。几无漏缘。答三十有漏缘。四无漏缘。二分别。欲界系见灭见道断无明使。或有漏缘。或无漏缘。云何有漏缘。谓欲界系见灭见道断有漏缘使相应无明使。云何无漏缘。谓欲界系见灭见道断有漏缘使不相应无明使

问此色界系三十一使。几有漏缘。几无漏缘。答二十五有漏缘。四无漏缘二分别。色界系见灭见道断无明使。或有漏缘。或无漏缘。云何有漏缘。谓色界系见灭见道断有漏缘使相应无明使。云何无漏缘。谓色界系见灭见道断有漏缘使不相应无明使。如色界系。无色界系亦如是

问此九十八使。几有为缘。几无为缘。答八十九有为缘。六无为缘。三分别。见灭断无明使。或有为缘。或无为缘云何有为缘。谓见灭断有为缘使相应无明使。云何无为缘。谓见灭断有为缘使不相应无明使

问此欲界系三十六使。几有为缘。几无为缘。答三十三有为缘二无为缘一分别。欲界系见灭断无明使。或有为缘。或无为缘。云何有为缘。谓欲界系见灭断有为缘使相应无明使云何无为缘谓欲界系见灭断有为缘使不相应无明使

问此色界系三十一使。几有为缘。几无为缘。答二十八有为缘二无为缘一分别。色界系见灭断无明使。或有为缘。或无为缘。云何有为缘

谓色界系见灭断有为缘使相应无明使。云何无为缘。谓色界系见灭断有为缘使不相应无明使。如色界系。无色界系亦如是

问此九十八使。几缘使非相应使。几相应使非缘使。几缘使亦相应使。几非缘使亦非相应使。答缘使非相应者无。相应使非缘者。无漏缘使。缘使亦相应使者。有漏缘使非缘使。亦非相应使者无

问此欲界系三十六使。几缘使非相应使。答作四句。缘使非相应者无相应使非缘者。欲界系无漏缘使。缘使亦相应使者。欲界系有漏缘使。非缘使亦非相应使者无。此色界系三十一使。几缘使非相应使。作四句。缘使非相应者无。相应使非缘者。色界系无漏缘使。缘使亦相应使者。色界系有漏缘使。非缘使亦非相应使者无。如色界系。无色界系亦如是。二十法。见苦断法。见集断法。见灭断法。见道断法。修断法。如不定欲界系。色无色界系亦如是

问彼见苦断法。几使使。答见苦断一切。见集断一切遍。问彼见集断法。几使使。答见集断一切。见苦断一切遍。问彼见灭断法。几使使。答见灭断一切。及一切遍。问彼见道断法。几使使。答见道断一切。及一切遍。问彼修断法。几使使。答修断一切。及一切遍。如不定欲界系。色无色界系亦如是。问彼见苦断法。几使缘使非相应使。答作四句。缘使非相应者。见集断一切遍使。相应使非缘者无。缘使亦相应使者。见苦断一切。非缘使亦非相应使者。见集断不一切遍。及见灭见道断修断一切

问彼见集断法。几使缘使非相应使。答作四句。缘使非相应者。见苦断一切遍。相应使非缘者无。缘使亦相应使者。见集断一切。非缘使亦非相应使者。见苦断不一切遍。及见灭见道断修断一切

问彼见灭断法。几使缘使非相应使。答作四句。缘使非相应者。一切遍。相应使非缘者。见灭断无漏缘使。缘使亦相应使者。见灭断有漏缘使。非缘使亦非相应使者。见苦集断不一切遍。见道断及修断一切

问彼见道断法。几使缘使非相应使。答作四句。缘使非相应者。一切遍相应使非缘者。见道断无漏缘使。缘使亦相应使者。见道断有漏缘使。非缘使亦非相应使者。见苦集断不一切遍。见灭断及修断一切

问彼修断法。几使缘使非相应使。答作四句。缘使非相应者。一切遍。相应使非缘者无。缘使亦相应使者。修断一切。非缘使亦非相应使者。见苦集断不一切遍。及见灭见道断一切。如不定欲界系。色无色界系亦如是

即此二十法。即此见苦断法。即此见集断法。即此见灭断法。即此见道断法。即此修断法。如不定欲界系。色无色界系亦如是

问即此见苦断法。几使使。答即此见苦断不一切遍。问即此见集断法。几使使。答即此见集断不一切遍。问即此见灭断法。几使使答即此见灭断一切。问即此见道断法。几使使。答即此见道断一切。问即此修断法。几使使。答即此修断一切。如不定。欲界系。色无色界系亦如是

问即此见苦断法。几使缘使非相应使。答作四句。缘使非相应者无。相应使非缘者无。缘使亦相应使者。见苦断不一切遍。非缘使亦非相应使者无

问即此见集断法。几使缘使非相应使。答作四句缘使非相应者无。相应使非缘者无。缘使亦相应使者。见集断不一切遍。非缘使亦非相应使者无。问即此见灭断法。几使缘使非相应使。答作四句。缘使非相应者无。相应使非缘者。见灭断无漏缘。缘使亦相应使者。见灭断有漏缘。非缘使亦非相应使者无

问即此见道断法。几使缘使非相应使。答作四句。缘使非相应者无。相应使非缘者。见道断无漏缘。缘使亦相应使者。见道断有漏缘。非缘使亦非相应使者无

问即此修断法。几使缘使非相应使。答作四句。缘使非相应者无。相应使非缘者无。缘使亦相应使者。即修断一切。非缘使亦非相应使者无。如不定欲界系。色无色界系亦如是。二十心者。见苦断心见集断心。见灭断心。见道断心。修断心。如不定欲界系。色无色界系亦如是

问见苦断心。几使使。答见苦断一切。见集断一切遍。彼相应法。见苦断一切。见集断一切遍。彼所起心不相应行。见苦断一切。见集断一切遍

问见集断心几使使。答见集断一切。见苦断一切遍。彼相应法。见集断一切。见苦断一切遍。彼所起心不相应行。见集断一切。见苦断一切遍

问见灭断心。几使使。答见灭断一切。及一切遍。彼相应法。见灭断一切。及一切遍。彼所起心不相应行。见灭断有漏缘。及一切遍

问见道断心。几使使。答见道断一切。及一切遍。彼相应法。见道断一切。及一切遍。彼所起心不相应行。见道断有漏缘。及一切遍

问修断心。几使使。答修断一切。及一切遍。彼相应法。修断一切。及一切遍。彼所起心不相应行。修断一切。及一切遍。如不定欲界系。色无色界系亦如是

问见苦断心。几使缘使非相应使。答作四句。缘使非相应者。见集断一切遍。相应使非缘者无。缘使亦相应使者。见苦断一切。非缘使亦非相应使者。见集断不一切遍。见灭见道。及修断一切。彼相应法。四句即如心说。彼所起心不相应行。见苦断一切。见集断一切遍。此使缘使非相应使余非缘使亦非相应使

问见集断心。几使缘使非相应使。答作四句。缘使非相应者。见苦断一切遍。相应使非缘者无。缘使亦相应使者。见集断一切。非缘使亦非相应使者。见苦断不一切遍。见灭见道。及修断一切。彼相应法。四句即如心说。彼所起心不相应行。见集断一切。见苦断一切遍。此使缘使非相应使。余非缘使亦非相应使。问见灭断心。几使缘使非相应使。答作四句。缘使非相应者。一切遍。相应使非缘者。见灭断无漏缘。缘使亦相应使者。见灭断有漏缘。非缘使亦非相应使者。见苦集断不一切遍。见道及修断一切。彼相应法。四句即如心说。彼所起心不相应行。见灭断有漏缘。及一切遍。此使缘使非相应使。余非缘使亦非相应使。如见灭断。见道断亦如是

问修断心。几使缘使非相应使。答作四句。缘使非相应者。一切遍。相应使非缘者无。缘使亦相应使者。修断一切。非缘使亦非相应使者。见苦集断不一切遍。及见灭见道断一切彼相应法。四句即如心说。彼所起心不相应行。修断一切及一切遍。此使缘使非相应使。余非缘使亦非相应使。如不定欲界系。色无色界系亦如是

四十八心者。见灭断邪见相应心。见灭断疑相应心。见灭断邪见疑相应心。见灭断邪见不相应心。见灭断疑不相应心。见灭断邪见疑不相应心。如见灭断。见道断亦如是。如不定欲界系。色无色界系亦如是

问见灭断邪见相应心。几使使。答见灭断邪见相应无明。见灭断有漏缘。及一切遍。彼相应法见灭断邪见相应无明。见灭断有漏缘。及一切遍。彼所起心不相应行。见灭断有漏缘。及一切遍

问见灭断疑相应心。几使使。答见灭断疑相应无明。见灭断有漏缘。及一切遍。彼相应法。见灭断疑相应无明。见灭断有漏缘。及一切遍。彼所起心不相应行。见灭断有漏缘。及一切遍。问见灭断邪见疑相应心几使使。答见灭断邪见疑相应无明。见灭断有漏缘。及一切遍彼相应法。见灭断邪见疑相应无明。见灭断有漏缘。及一切遍。彼所起心不相应行。见灭断有漏缘。及一切遍

问见灭断邪见不相应心。几使使。答除见灭断邪见彼相应无明。余见灭断一切。及一切遍。彼相应法。除见灭断邪见相应无明。余见灭断一切。及一切遍彼所起心不相应行。见灭断有漏缘。及一切遍

问见灭断疑不。相应心。几使使。答除见灭断疑相应无明。余见灭断一切。及一切遍。彼相应法。除见灭断疑相应无明。余见灭断一切。及一切遍。彼所起心不相应行。见灭断有漏缘。及一切遍

问见灭断邪见疑不相应心。几使使。答除见灭断邪见疑相应无明。余见灭断一切。及一切遍。彼相应法。除见灭断邪见疑相应无明。余见灭断一切。及一切遍。彼所起心不相应行。见灭断有漏缘。及一切遍。如见灭断。见道断亦如是。如不定欲界系。色无色界系亦如是

问见灭断邪见相应心。几使缘使非相应使。答作四句。缘使非相应者。见灭断有漏缘。及一切遍。相应使非缘者。见灭断邪见相应无明。缘使亦相应使者无。非缘使亦非相应使者。除见灭断邪见相应无明。余见灭断无漏缘。见苦集断不一切遍。见道及修断一切。彼相应法。四句即如心说。彼所起心不相应行。见灭断有漏缘。及一切遍。此使缘使非相应使。余非缘使亦非相应使

问见灭断疑相应心。几使缘使非相应使。答作四句。缘使非相应者。见灭断有漏缘。及一切遍。相应使非缘者。见灭断疑相应无明。缘使亦相应使者无。非缘使亦非相应使者。除见灭断疑相应无明。余见灭断无漏缘。见苦集断不一切遍。见道及修断一切。彼相应法。四句即如心说。彼所起心不相应行。见灭断有漏缘。及一切遍。此使缘使非相应使。余非缘使亦非相应使

问见灭断邪见疑相应心。几使缘使非相应使。答作四句。缘使非相应者。见灭断有漏缘。及一切遍。相应使非缘者。见灭断邪见疑相应无明。缘使亦相应使者无。非缘使亦非相应使者。除见灭断邪见疑相应无明。余见灭断无漏缘。见苦集断不一切遍。见道及修断一切。彼相应法。四句即如心说。彼所起心不相应行。见灭断有漏缘。及一切遍。此使缘使非相应使。余非缘使亦非相应使

问见灭断邪见不相应心。几使缘使非相应使。答作四句。缘使非相应者。一切遍。相应使非缘者。除见灭断邪见相应无明。余见灭断无漏缘。缘使亦相应使者。见灭断有漏缘。非缘使亦非相应使者。见灭断邪见相应无明。见苦集断不一切遍。见道及修断一切。彼相应法。四句即如心说。彼所起心不相应行。见灭断有漏缘。及一切遍。此使缘使非相应使。余非缘使亦非相应使

问见灭断疑不相应心。几使缘使非相应使。答作四句。缘使非相应者。一切遍。相应使非缘者。除见灭断疑相应无明。余见灭断无漏缘。缘使亦相应使者。见灭断有漏缘。非缘使亦非相应使者。见灭断疑相应无明。见苦集断不一切遍。见道及修断一切。彼相应法。四句即如心说。彼所起心不相应行。见灭断有漏缘。及一切遍。此使缘使非相应使。余非缘使亦非相应使

问见灭断邪见疑不相应心。几使缘使非相应使。答作四句。缘使非相应者。一切遍。相应使非缘者。除见灭断邪见疑相应无明。余见灭断无漏缘。缘使亦相应使者。见灭断有漏缘。非缘使亦非相应使者。见灭断邪见疑相应无明。见苦集断不一切遍。见道及修断一切。彼相应法。四句即如心说。彼所起心不相应行。见灭断有漏缘。及一切遍。此使缘使非相应使。余非缘使亦非相应使。如见灭断。见道断亦如是。如不定欲界系。色无色界系亦如是

问此欲界系三十六使。十见苦断。七见集断。七见灭断。八见道断。四修断。云何见苦断十使。答谓身见边见见苦断邪见见取戒取疑贪恚慢无明。云何见集断七使。谓见集断邪见见取疑贪恚慢无明。云何见灭断七使。谓见灭断邪见见取疑贪恚慢无明。云何见道断八使。谓见道断邪见见取戒取疑贪恚慢无明。云何修断四使。谓修断贪恚慢无明

问身见。几使使。答见苦断一切。见集断一切遍。彼相应法。见苦断一切。见集断一切遍。彼所起心不相应行。见苦断一切。见集断一切遍。如身见。边见见苦断邪。见见取戒取疑贪恚慢无明亦如是。问见集断邪见。几使使。答见集断一切。见苦断一切遍。彼相应法。见集断一切。见苦断一切遍。彼所起心不相应行。见集断一切。见苦断一切遍。如见集断。邪见见取疑贪恚慢无明亦如是

问见灭断邪见。几使使。答见灭断邪见相应无明。见灭断有漏缘。及一切遍。彼相应法。见灭断邪见相应无明。见灭断有漏缘。及一切遍。彼所起心不相应行。见灭断有漏缘。及一切遍。如见灭断。邪见疑亦如是

问见灭断见取。几使使。答见灭断见取相应无明。见灭断有漏缘。及一切遍。彼相应法。见灭断见取相应无明。见灭断有漏缘。及一切遍。彼所起心不相应行。见灭断有漏缘。及一切遍。如见灭断。见取贪恚慢亦如是

问见灭断无明。几使使。答见灭断无明。除无漏缘。余见灭断一切。及一切遍。彼相应法。见灭断一切。及一切遍。彼所起心不相应行。见灭断有漏缘。及一切遍。如见灭断。见道断亦如是。问修断贪。几使使。答修断一切。及一切遍。彼相应法。即如贪说。彼所起心不相应行。亦如是说。如贪恚慢。无明亦如是

问身见。几使缘使非相应使。答作四句。缘使非相应者。除身见相应无明。余见苦断一切。及见集断一切遍。相应使非缘者无。缘使亦相应使者。身见相应无明。非缘使亦非相应使者。见集断不一切遍。见灭见道。及修断一切。彼相应法。缘使非相应者。除身见相应无明。余见苦断一切。及见集断一切遍。相应使非缘者无。缘使亦相应使者。身见相应无明。非缘使亦非相应使者。见集断不一切遍。见灭见道及修断一切。彼所起心不相应行。见苦断一切。见集断一切遍。此使缘使非相应使。余非缘使亦非相应使。如身见。边见见苦断邪见见取戒取疑贪恚慢亦如是

问见苦断无明。几使缘使非相应使。答作四句。缘使非相应者。见苦断无明。及见集断一切遍。相应使非缘者无。缘使亦相应使者。除见苦断无明。余见苦断一切。非缘使亦非相应使者。见集断不一切遍。见灭见道及修断一切。彼相应法。缘使非相应者。见集断一切遍。相应使非缘者无缘使亦相应使者。见苦断一切。非缘使亦非相应使者。见集断不一切遍。见灭见道。及修断一切。彼所起心不相应行。见苦断一切。及见集断一切遍。此使缘使非相应使。余非缘使亦非相应使

问见集断邪见几使缘使非相应使。答作四句。缘使非相应者。除邪见相应无明。余见集断一切。及见苦断一切遍。相应使非缘者无。缘使亦相应使者。见集断邪见相应无明。非缘使亦非相应使者。见苦断不一切遍。见灭见道。及修断一切。彼相应法。缘使非相应者。除见集断邪见相应无明。余见集断一切。及见苦断一切遍。相应使非缘者无。缘使亦相应使者。见集断邪见相应无明。非缘使亦非相应使者。见苦断不一切遍。见灭见道及修断一切。彼所起心不相应行。见集断一切。及见苦断一切遍。此使缘使非相应使。余非缘使亦非相应使。如见集断。邪见见取疑贪恚慢亦如是。问见集断无明。几使缘使非相应使。答作四句。缘使非相应者。见集断无明。及见苦断一切遍。相应使非缘者无。缘使亦相应使者。除见集断无明。余见集断一切。非缘使亦非相应使者。见苦断不一切遍。见灭见道。及修断一切。彼相应法。缘使非相应者。见苦断一切遍。相应使非缘者无。缘使亦相应使者。见集断一切。非缘使亦非相应使者。见苦断不一切遍。见灭见道。及修断一切。彼所起心不相应行。见集断一切。及见苦断一切遍。此使缘使非相应使。余非缘使亦非相应使。问见灭断邪见。几使缘使非相应使。答作四句。缘使非相应者。见灭断有漏缘。及一切遍。相应使非缘者。见灭断邪见相应无明。缘使亦相应使者无。非缘使亦非相应使者。除见灭断邪见相应无明。余见灭断无漏缘。及见苦集断不一切遍。见道及修断一切。彼相应法。缘使非相应者。见灭断有漏缘。及一切遍。相应使非缘者。见灭断邪见相应无明。缘使亦相应使者无。非缘使亦非相应使者。除见灭断邪见相应无明。余见灭断无漏缘。见苦集断不一切遍。见道及修断一切。彼所起心不相应行。见灭断有漏缘。及一切遍。此使缘使非相应使。余非缘使亦非相应使。如见灭断。邪见疑亦如是

问见灭断见取。几使缘使非相应使。答作四句。缘使非相应者。除见灭断见取相应无明。余见灭断有漏缘。及一切遍。相应使非缘者无。缘使亦相应使者。见灭断见取相应无明。非缘使亦非相应使者。见灭断无漏缘。见苦集断不一切遍。见道及修断一切。彼相应法。缘使非相应者。除见灭断见取相应无明。余见灭断有漏缘。及一切遍。相应使非缘者无。缘使亦相应使者。见灭断见取相应无明。非缘使亦非相应使者。见灭断无漏缘。见苦集断不一切遍。见道及修断一切。彼所起心不相应行。见灭断有漏缘。及一切遍。此使缘使非相应使。余非缘使亦非相应使。如见灭断。见取贪恚慢亦如是

问见灭断无明。几使缘使非相应使。答作四句。缘使非相应者。见灭断有漏缘无明。及一切遍。相应使非缘者。除见灭断无漏缘无明。余见灭断无漏缘。缘使亦相应使者。除见灭断有漏缘无明。余见灭断有漏缘。非缘使亦非相应使者。见灭断无漏缘无明。见苦集断不一切遍。见道及修断一切。彼相应法。缘使非相应者。一切遍。相应使非缘者。见灭断无漏缘。缘使亦相应使者。见灭断有漏缘。非缘使亦非相应使者。见苦集断不一切遍。见道及修断一切。彼所起心不相应行。见灭断有漏缘。及一切遍。此使缘使非相应使。余非缘使亦非相应使。如见灭断。见道断亦如是

问修断贪。几使缘使非相应使。答作四句。缘使非相应者。除修断贪相应无明。余修断一切。及一切遍。相应使非缘者无。缘使亦相应使者。修断贪相应无明。非缘使亦非相应使者。见苦集断不一切遍。及见灭见道断一切。彼相应法。缘使非相应者。除修断贪相应无明。余修断一切。及一切遍。相应使非缘者无。缘使亦相应使者。修断贪相应无明。非缘使亦非相应使者。见苦集断不一切遍。及见灭见道断一切。彼所起心不相应行。修断一切。及一切遍。此使缘使非相应使。余非缘使亦非相应使。如贪恚慢亦如是

问修断无明。几使缘使非相应使。答作四句。缘使非相应者。修断无明。及一切遍。相应使非缘者无。缘使亦相应使者。除修断无明。余修断一切。非缘使亦非相应使者。见苦集断不一切遍。及见灭见道断一切。彼相应法。缘使非相应者。一切遍。相应使非缘者无。缘使亦相应使者。修断一切。非缘使亦非相应使者。见苦集断不一切遍。及见灭见道断一切。彼所起心不相应行。修断一切。及一切遍。此使缘使非相应使。余非缘使亦非相应使。四十八无明。见灭断邪见相应无明。见灭断疑相应无明。见灭断邪见疑相应无明。见灭断邪见不相应无明。见灭断疑不相应无明。见灭断邪见疑不相应无明。如见灭断。见道断亦如是。如不定欲界系。色无色界系亦如是

问见灭断邪见相应无明。几使使。答见灭断邪见见灭断有漏缘。及一切遍。彼相应法。见灭断邪见相应无明。见灭断有漏缘。及一切遍。彼所起心不相应行。见灭断有漏缘。及一切遍。问见灭断疑相应无明。几使使。答见灭断疑。见灭断有漏缘。及一切遍。彼相应法。见灭断疑相应无明。见灭断有漏缘。及一切遍彼所起心不相应行。见灭断有漏缘。及一切遍

问见灭断邪见疑相应无明。几使使。答见灭断邪见疑见灭断有漏缘。及一切遍。彼相应法。见灭断邪见疑相应无明。见灭断有漏缘。及一切遍。彼所起心不相应行。见灭断有漏缘。及一切遍

问见灭断邪见不相应无明。几使使。答见灭断疑。见灭断有漏缘。及一切遍。彼相应法。除见灭断邪见相应无明。余见灭断一切。及一切遍。彼所起心不相应行。见灭断有漏缘。及一切遍。问见灭断疑不相应无明。几使使。答见灭断邪见。见灭断有漏缘。及一切遍。彼相应法。除见灭断疑相应无明。余见灭断一切。及一切遍。彼所起心不相应行。见灭断有漏缘。及一切遍。问见灭断邪见疑不相应无明。几使使。答见灭断有漏缘及一切遍。彼相应法。除见灭断邪见疑相应无明。余见灭断一切。及一切遍。彼所起心不相应行。见灭断有漏缘。及一切遍。如见灭断。见道断亦如是。如不定欲界系。色无色界系亦如是

问见灭断邪见相应无明。几使缘使非相应使。答作四句。缘使非相应者。见灭断有漏缘及一切遍。相应使非缘者。见灭断邪见。缘使亦相应使者无。非缘使亦非相应使者。除见灭断邪见。余见灭断无漏缘。见苦集断不一切遍。见道及修断一切。彼相应法。缘使非相应者。见灭断有漏缘。及一切遍。相应使非缘者。见灭断邪见相应无明缘使亦相应使者无。非缘使亦非相应使者。除见灭断邪见相应无明。余见灭断无漏缘。见苦集断不一切遍见道及修断一切。彼所起心不相应行。见灭断有漏缘。及一切遍。此使缘使非相应使。余非缘使亦非相应使

问见灭断疑相应无明。几使缘使非相应使。答作四句缘使非相应者。见灭断有漏缘。及一切遍相应使非缘者。见灭断疑。缘使亦相应使者无非缘使亦非相应使者。除见灭断疑。余见灭断无漏缘。及见苦集断不一切遍。见道及修断一切。彼相应法。缘使非相应者。见灭断有漏缘。及一切遍。相应使非缘者。见灭断疑相应无明。缘使亦相应使者无。非缘使亦非相应使者。除见灭断疑相应无明。余见灭断无漏缘及见。苦集断不一切遍。见道及修断一切。彼所起心不相应行。见灭断有漏缘。及一切遍。此使缘使非相应使。余非缘使亦非相应使。问见灭断邪见疑相应无明。几使缘使非相应使。答作四句。缘使非相应者。见灭断有漏缘。及一切遍。相应使非缘者见灭断邪见疑。缘使亦相应使者无。非缘使亦非相应使者。除见灭断邪见疑。余见灭断无漏缘。及见苦集断不一切遍。见道及修断一切。彼相应法。缘使非相应者。见灭断有漏缘。及一切遍。相应使非缘者。见灭断邪见疑相应无明。缘使亦相应使者无。非缘使亦非相应使者。除见灭断邪见疑相应无明。余见灭断无漏缘。及见苦集断不一切遍。见道及修断一切。彼所起心不相应行。见灭断有漏缘。及一切遍。此使缘使非相应使。余非缘使亦非相应使

问见灭断邪见不相应无明。几使缘使非相应使。答作四句。缘使非相应者。见灭断有漏缘无明。及一切遍。相应使非缘者。见灭断疑。缘使亦相应使者。除见灭断有漏缘无明。余见灭断有漏缘。非缘使亦非相应使者。除见灭断疑。余见灭断无漏缘。见苦集断不一切遍。见道及修断一切。彼相应法。缘使非相应者。一切遍。相应使非缘者。除见灭断邪见相应无明。余见灭断无漏缘。缘使亦相应使者。见灭断有漏缘。非缘使亦非相应使者。见灭断邪见相应无明。见苦集断不一切遍。见道及修断一切。彼所起心不相应行。见灭断有漏缘。及一切遍。此使缘使非相应使。余非缘使亦非相应使

问见灭断疑不相应无明。几使缘使非相应使。答作四句。缘使非相应者。见灭断有漏缘无明。及一切遍。相应使非缘者。见灭断邪见。缘使亦相应使者。除见灭断有漏缘无明。余见灭断有漏缘。非缘使亦非相应使者。除见灭断邪见。余见灭断无漏缘。及见苦集断不一切遍。见道及修断一切。彼相应法。缘使非相应者。一切遍。相应使非缘者。除见灭断邪见相应无明。余见灭断无漏缘。缘使亦相应使者。见灭断有漏缘。非缘使亦非相应使者。见灭断疑。彼相应无明。见苦集断不一切遍。见道及修断一切。彼所起心不相应行。见灭断有漏缘。及一切遍。此使缘使非相应使。余非缘使亦非相应使

问见灭断邪见疑不相应无明。几使缘使非相应使。答作四句。缘使非相应者。见灭断有漏缘无明。及一切遍。相应使非缘者无。缘使亦相应使者。除见灭断有漏缘无明。余见灭断有漏缘。非缘使亦非相应使者。见灭断。无漏缘。见苦集断不一切遍。见道及修断一切。彼相应法。缘使非相应使者。一切遍。相应使非缘者。除见灭断邪见疑相应无明。余见灭断无漏缘。缘使亦相应使者。见灭断有漏缘。非缘使亦非相应使者。见灭断邪见疑相应无明。见苦集断不一切遍。见道及修断一切。彼所起心不相应行。见灭断有漏缘。及一切遍。此使缘使非相应使。余者非缘使亦非相应使。如见灭断。见道断亦如是。如不定欲界系。色无色界系亦如是

问若有漏缘使。缘使相应使耶。若缘使。相应使。有漏缘使耶。答有。若使缘使相应使。彼有漏缘使。或使有漏缘。非彼缘使相应使。云何有。谓他界一切遍。谓使欲界系缘色界系。欲界系缘无色界系。色界系缘无色界系。欲界系缘色无色界系

问若无漏缘使。相应使耶。若相应使。无漏缘使耶。答有。若使相应使。彼无漏缘使。或使相应使。非彼无漏缘使。云何有。谓他界一切遍使。谓使欲界系缘色界系。欲界系缘无色界系。色界系缘无色界系。欲界系缘色无色界系(分别诸使品第五竟)

众事分阿毗昙论卷第三众事分阿毗昙论卷第四

        尊者世友造

        宋天竺三藏求那跋陀罗共菩提耶舍译

    分别摄品第六初

尔炎法。识法。通尔炎法。缘法。增上法。色法。非色法。可见法。不可见法。有对法。无对法。有漏法。无漏法。有为法。无为法。有诤法。无诤法。世间法。出世间法。入法。不入法。染污法。不染污法。依家法。依出要法。心法。非心法。心法法。非心法法。心相应法。心不相应法。心共有法。非心共有法。心随转法。非心随转法。心因法。非心因法。心次第法。非心次第法。缘心法。非缘心法。心增上法。非心增上法。心果法。非心果法。心报法。非心报法。业法。非业法。业相应法。非业相应法。业共有法。非业共有法。业随转法。非业随转法。业因法。非业因法。业次第法。非业次第法。缘业法。非缘业法。业增上法。非业增上法。业果法。非业果法。业报法。非业报法。有法。非有法。有相应法。非有相应法。有共有法。非有共有法。有随转有因法。非有随转非有因法。有次第法。非有次第法。缘有法。非缘有法。有增上法。非有增上法。有果法。非有果法。有报法。非有报法。断知法。智所知法。非智所知法。断知所断法。非断知所断法。修法。非修法。证法。非证法。习法。非习法。有罪法。无罪法。黑法。白法。退法。不退法。隐没法不隐没法。记法。无记法。已起法。不起法。今起法。非今起法。已灭法。非已灭法。今灭法。非今灭法。缘起法。非缘起法。缘生法。非缘生法。因法。非因法。有因法。非有因法。因起法。非因起法。因相应法。非因相应法。结法。非结法。生结法。非生结法。取法。非取法。受法。非受法。取生法。非取生法。烦恼法。非烦恼法。秽污法。不秽污法。有秽污法。非有秽污法。缠法。非缠法。缠住法。非缠住法。缠生法。非缠生法。有缘法。无缘法。有觉法。非有觉法。有观法。非有观法。可乐法。非可乐法。受用法。非受用法。有事有缘法。无事无缘法。有上法。无上法。远法。近法。有量法。无量法。见法。非见法。见处法。非见处法。见相应法。非见相应法。凡夫法。非凡夫法。凡夫共法。非凡夫共法。定法。非定法。恼法。非恼法。根法。非根法。圣谛摄法。非圣谛摄法。共有法。非共有法。相应法。非相应法。果法。非果法。有果法。非有果法。报法。非报法。有报法。非有报法。因缘法。非因缘法。有因缘法。非有因缘法。出法。非出法。有出法。非有出法。相续法。非相续法。有相续法。非有相续法(二法有二百一十六种竟)

善法。不善法。无记法。学法。无学法。非学非无学法。见断法。修断法。不断法。见断因法。修断因法。不断因法。可见有对法。不可见有对法。不可见无对法。报法。非报法。非报非非报法。下法中法。上法。小法。大法。无量法。意乐法。非意乐法。非意乐非不意乐法。乐俱法。苦俱法。不苦不乐俱法。俱起法。俱住法。俱灭法。非俱起法。非俱住法。非俱灭法。心俱起法。心俱住法。心俱灭法。非心俱起法。非心俱住法。非心俱灭法。三界。欲界。嗔界。害界。又三界。出要界。无嗔界。无害界。又三界。欲界。色界。无色界。又三界。色界。无色界。灭界。三有。欲有。色有。无色有。三漏。欲漏。有漏。无明漏。三世。过去世。未来世。现在世。三说事。过去说事。未来说事。现在说事。三苦。苦苦苦。变苦苦。行苦苦。三法。有觉有观法。无觉有观法。无觉无观法。三地。有觉有观地。无觉有观地。无觉无观地。三业。身业。口业。意业。又三业。善业。不善业。无记业。又三业。学业。无学业。非业非无学业。又三业。见断业。修断业。不断业。又三业。现法受业。生法受业。后法受业。又三业。乐受业。苦受业。不苦不乐受业(三法有九十三种竟)

四念处。谓身念处。受念处。心念处。法念处。四正勤。谓已起恶不善法方便令断正勤。未起恶不善法方便令不起正勤。未生善法方便令生正勤。已生善法方便勤修令住使不忘失满足修习增广智证正勤。四如意足。谓欲定净行成就如意足。精进定净行成就如意足。心定净行成就如意足。慧定净行成就如意足。四禅。谓初禅。二禅。三禅。四禅。四圣谛。谓苦圣谛。苦集圣谛。苦灭圣谛。苦灭道圣谛。四无量。谓慈悲喜舍。四无色。谓空入处。识入处无所有入处。非想非非想入处。四圣种。谓随乞得衣知足圣种。谓随乞得食知足圣种。谓随得眠卧具等知足圣种。谓乐闲静乐修圣种。四沙门果。谓须陀洹沙门果。斯陀含沙门果。阿那含沙门果。阿罗汉无上沙门果。四智。谓法智。比智。知他心智。等智。又四智。谓苦智。集智。灭智。道智。四辩。谓义辩。法辩。辞辩。随应辩。四缘。谓因缘。次第缘。缘缘。增上缘。四食。谓粗抟食。细触食。意思食。识食。四流。谓欲流。有流。见流。无明流。四扼。谓欲扼。有扼。见扼。无明扼。四取。谓欲取。见取。戒取。我取。四法。谓过去法。未来法。现在法。非过去未来现在法。又四法。谓欲界系法。色界系法。无色界系法。不系法。又四法。谓善因法。不善因法。无记因法。非善因非不善因非无记因法。又四法。谓有缘缘法。无缘缘法。有缘缘无缘缘法。非有缘缘非无缘缘法(四法有八十四种竟)

五阴。谓色阴。受阴。想阴。行阴。识阴。五盛阴。谓色盛阴。受想行识盛阴。五趣。谓地狱趣。畜生趣。饿鬼趣。天趣。人趣。五烦恼身。谓见苦断烦恼身。见集断烦恼身。见灭断烦恼身。见道断烦恼身。修断烦恼身。五法。谓色法。心法。心法法。心不相应行法。无为法(五法有二十五种竟)

六界。谓地界。水界。火界。风界。虚空界。识界。六法。谓见苦断法。见集断法。见灭断法。见道断法。修断法。不断法(六法有十二种竟)

七使。谓贪欲使。嗔恚使。有爱使。慢使。无明使。见使。疑使

七识住。谓有色众生。种种身。种种想。谓人及天。是名初识住处。有色众生。种种身。一种想。谓梵天身彼初所转。是名第二识住处。有色众生一种身。种种想。谓光音天。是名第三识住处。有色众生。一种身。一种想。谓遍净天。是名第四识住处。无色众生。已离一切色想障阂想究竟不种种想。思惟无量空处。入无量空入处。谓空入处天。是名第五识住处。无色众生。已离一切空入处。无量识入无量识入处。谓识入处天。是名第六识住处。无色众生。已离一切识入处。无所有入无所有入处。谓无所有入处天。是名第七识住处

七觉支。谓念觉支。择法觉支。精进觉支。喜觉支。猗觉支。定觉支。舍觉支(七法有二十一种竟)

八解脱处。谓内有色想外观色。是名初解脱处。内无色想外观色。是名第二解脱处。净身证解脱处。是名第三解脱处。已离一切色想障阂想究竟无种种想。思惟无边空处。入无边空入处。是名第四解脱处。离一切空入处。无量识入无量识入处。是名第五解脱处。离一切识入处。无所有入无所有入处。是名第六解脱处。离一切无所有入处。非想非非想入非想非非想入处。是名第七解脱处。已离一切非想非非想入处想受灭身证住。是名第八解脱处

八胜处。谓内有色想。外观少色。好色恶色。谓彼色胜处生观想。是名初胜处入。内有色想。外观多色。好色恶色。谓彼色胜处生观想。是名第二胜处入。内无色想。外观少色。好色恶色。谓彼色胜处生观想。是名第三胜处入。内无色想。外观多色。好色恶色。谓彼色胜处生观想。是名第四胜处入。内无色想。外观色青色青观青光。譬如鸠牟迦华色成就婆罗奈衣青青色青观青光。如是比丘。内无色想。外观色青青色青观青光。谓彼色胜处生观想。是名第五胜处入。内无色想。外观色黄。黄色黄观黄光。譬如迦梨那华色成就婆罗奈衣黄黄色黄观黄光。如是比丘内无色想。外观色黄。黄色黄观黄光。谓彼色胜处生观想。是名第六胜处入。内无色想。外观色赤。赤色赤观赤光。譬如槃头嗜婆迦华色成就婆罗奈衣赤赤色赤观赤光。如是比丘。内无色想。外观色赤。赤色赤观赤色。谓彼色胜处生观想。是名第七胜处入。内无色想。外观色白。白色白观白光。譬如优私多罗华色成就婆罗奈衣白白色白观白光。如是比丘。内无色想。外观色白。白色白观白光。谓彼色胜处生观想是名第八胜处。八道支。谓正见。正思惟。正语。正业。正命。正方便。正念。正定(八法有二十四种竟)

九结。谓贪欲结。嗔恚结。慢结。无明结。见结。他取结。疑结。嫉结。悭结

九众生居处。谓有色众生种种身种种想。谓人及天。是名初众生居处。有色众生种种身一种想。谓梵天身。彼初所转。是名第二众生居处。有色众生一种身种种想。谓光音天。是名第三众生居处。有色众生一种身一种想。谓遍净天。是名第四众生居处。有色众生无有想。谓无想天众生。是名第五众生居处。无色众生。已离一切色想障碍想究竟不种种想。思惟无量空处入无量空处住。所谓空处天。是名第六众生居处。无色众生。离一切空处。入无量识处住。所谓识处天。是名第七众生居处。无色众生。离一切识处。入无所有处住。所谓无所有处天。是名第八众生居处。无色众生。离一切无所有处。入非想非非想处住。所谓非想非非想处天。是名第九众生居处(九法有十八种竟)

十一切入。谓地一切入。一相生上下诸方。无二无量。是名初一切入处。水火风入青黄赤白空一切入处。识一切入处。一相生上下诸方。无二无量。是名十一切入处

十无学法。谓无学正见。乃至无学解脱。无学解脱知见(十法有二十种竟)

十一法。谓色有漏无漏。受想行识有漏无漏。及无为法(十一法有十一种竟)

十二入。谓眼入色入。乃至意入法入(十二法有十二种竟)

十八界。广说如前分别七事品(十八法有十八种竟)

二十二根。谓眼根耳根鼻根舌根身根男根女根命根意根乐根苦根喜根忧根舍根信根精进根念根定根慧根未知当知根已知根无知根(二十二法有二十二种竟)

九十八使(九十八法有九十八种竟)

云何尔炎法。谓一切法尔炎智所知。随其所应。云何随其所应。谓彼苦智知。苦集智知。集灭智知。灭道智知。道及善等智亦知。苦集灭道虚空数灭非数灭。此一切法尔炎智所知。随其所应。是名尔炎法

云何识法。谓一切法识所识识分别。随其所应。云何随其所应。谓彼眼识识色。耳识识声。鼻识识香。舌识识味。身识识触。意识识法。眼色亦识眼识识。耳声亦识耳识识。鼻香亦识鼻识识。舌味亦识舌识识。身触亦识身识识。意法亦识意识识。此一切法识分别。随其所应。是名识法

云何通尔炎。谓通尔炎者。谓慧彼一切法通尔炎。随其所应。云何随其所应。谓彼苦忍苦智通苦尔炎。集忍集智通集尔炎。灭忍灭智通灭尔炎。道忍道智通道尔炎。及善有漏慧。亦通苦尔炎。集灭道虚空数灭非数灭通尔炎。此一切法通尔炎。随其所应。是名通尔炎法。云何缘法。谓一切法缘。谓心心法。随其所应。云何随其所应。谓彼眼识眼识相应法缘色。耳识耳识相应法缘声。鼻识鼻识相应法缘香。舌识舌识相应法缘味。身识身识相应法缘触。意识意识相应法缘眼色及眼识缘。耳声及耳识缘。鼻香及鼻识缘。身触及身识缘。意法及意识一切法缘。谓心心法。是名缘法。云何增上法。谓一切有为法。展转增上。及无为法。为有为法增上。是名增上法。云何色法。谓十种色入。及一入少分。云何非色法。谓一入及一入少分。云何可见法。谓一入。云何不可见法。谓十一入。云何有对法。谓十入。云何无对法。谓二入。云何有漏法。谓十入及二入少分。云何无漏法。谓二入少分。云何有为法。谓十一入。及一入少分。云何无为法。谓一入少分。云何有诤法。谓十入及二入少分。云何无诤法。谓二入少分。如有诤法。无诤法世间法出世间法入法不入法染污法不染污法依家法依出要法亦如是

云何心法。谓一入。云何非心法。谓十一入。云何心法法。谓若法心相应。彼复云何。谓受阴想阴。彼相应行阴。云何非心法法。谓若法心不相应。彼复云何。谓色心心不相应行。及无为。如心法法。非心法法心相应法心不相应法亦如是

云何心共有法。谓若心共有十一入少分。除意入。云何非心共有法。谓意入若非心共有十一入少分。云何心随转法。谓若法心共一起一住一灭。彼复云何。谓一切心法法。及道共定共戒。彼心及彼法生住异灭。是名心随转法。云何非心随转法。谓若法心不共一起不一住不一灭。彼复云何。谓除心法法及道共定共戒。若余色。除心随转心不相应行。若余心不相应行心及无为。云何心因法。谓若入超升离生人。除彼初无漏心。若余心。及余凡夫。决定趣向。超升离生。除彼未来初无漏心。若余心。若心因十一入少分。云何非心因法。谓若入超升离生人。彼初无漏心。及余凡夫。决定趣向。超升离生。彼初未来无漏心。及非心。若非心因十一入少分。云何心次第法。谓若心次第。余心心法。已生当生。若无想定。灭尽定。已起当起。是名心次第法。云何非心次第法。谓除心次第心心法。若余心心法。除心次第心不相应行。若余心不相应行色及无为云何缘心法。谓若意识相应缘心。云何非缘心法。谓除缘心意识相应。余非缘心意识相应。及五识相应色。及无为心不相应行。云何心增上法。谓有为法。云何非心增上法。谓无为法。云何心果法。谓一切有为法。及数灭。云何非心果法。谓虚空非数灭。云何心报法。谓若心报得十一入少分。除声入。云何非心报法。谓声入若非心报得十一入少分

云何业法。谓身业口业思业。云何非业法。谓除身口业。若余色。除思业。若余行。除余受等三阴。及无为。云何业相应法。谓若法思相应。彼复云何。谓一切心心法除思。云何非业相应法。谓若法思不相应。彼复云何。谓色思心不相应行。及无为。云何业共有法。谓意入。若业共有十一入少分。除思。云何非业共有法。谓思业。除意入及非业共有十一入少分。云何业随转法。谓若法与思俱一起一住一灭。彼复云何。谓一切心心法。除思。若道共定共戒。若彼思业。及彼法生住异灭。是名业随转法。云何非业随转法。谓若法不与思俱一起一住一灭。彼复云何。谓除心心法及业随转身口业。若余色。除业随转心不相应行。若余心不相应行思。及无为。云何业因法。谓若入超升离生人除彼初无漏思业。若余思。及余凡夫。决定趣向。超升离生。除彼初未来无漏思业。若余思。及意入。若业因十一入少分。云何非业因法。谓若入超升离生人。彼初无漏思。及余凡夫。决定趣向。超升离生。彼未来初无漏思。若非业因十一入少分。除意入。云何业次第法。谓若法心次第。云何非业次第法。谓若法非心次第。云何缘业法。谓若眼耳意等。彼三识身相应缘业。云何非缘业法。谓若除眼等缘业三识身相应。若眼等。余缘非业三识身相应。及鼻舌身等三识身相应色。及无为心不相应行。云何业增上法。谓有为法。云何非业增上法。谓无为法。云何业果法。谓一切有为法。及数灭。云何非业果法。谓虚空。非数灭。云何业报法。谓若业报得十一入少分。除声入。云何非业报法。谓声入。若非业报得十一入少分。云何有法。谓有漏法。云何非有法。谓无漏法。云何有相应法。谓有漏心心法。云何非有相应法。谓无漏心心法色。及无为心不相应行。云何有共有法。谓有漏法。若无漏法。有漏法俱起。云何非有共有法。谓除有漏法及共有无漏法。若余无漏法。云何有随转有因法。谓有漏法。云何非有随转非有因法。谓无漏法。云何有次第法。谓彼有漏心心法次第生余心心法。已起当起。及无想正受。灭尽正受。已起当起。是名有次第法。云何非有次第法。谓除有次第心心法。若余心心法。除有次第心不相应行。若余心不相应行色及无为。云何缘有法。谓五识相应。及缘有意识相应。云何非缘有法。谓除五识相应及缘有意识相应。若余意识相应色。及无为心不相应行。云何有增上法。谓有为法。云何非有增上法。谓无为法。云何有果法。谓有漏法。若世俗道断诸结证。云何非有果法。谓除有漏法及有果无漏法。若余无漏法。云何有报法。谓若有报得十一入少分。除声入。云何非有报法。谓声入。若非有报得十一入少分。云何断知法。谓二智法智比智。云何智所知法。谓一切法智所知。云何非智所知法。谓若求如是法者。不可得也

云何断知所断法。谓有漏法。云何非断知所断法。谓无漏法。云何修法。谓善有为法。云何非修法。谓不善无记法。及数灭。云何证法。谓有二证法智证及得证。云何智证法。谓一切法智所证。云何非智证法。谓若求如是法。不可得也

云何得证法。谓善法依正。受证不隐没无记天眼天耳。是名得证。云何非得证法。谓除不隐没无记天眼天耳。若余无记及不善法。云何习法。谓善有为法。云何非习法。谓不善无记法。及数灭。云何有罪法。谓不善法。及隐没无记。云何无罪法。谓善法。及不隐没无记。如有罪法。无罪法黑法白法退法不退法亦如是

云何隐没法。谓秽污法。云何不隐没法。谓不秽污法。云何记法。谓善法及不善法。云何无记法。谓除善不善。若余法是。云何已起法。谓过去现在法。云何不起法。谓未来不生法。及无为法。云何今起法。谓若未来法现前必起。云何非今起法。谓除未来法现前必起。若余未来法。过去现在法。及无为法。云何已灭法。谓过去法。云何非已灭法。谓未来现在法。及无为法。云何今灭法。谓若法现在灭。云何非今灭法。谓除现在现前灭法。若余现在法。及过去未来法。及无为法。云何缘起法。谓有为法。云何非缘起法。谓无为法。如缘起法非缘起法。缘生法非缘生法因法非因法有因法非有因法因起法非因起法亦如是

云何因相应法。谓一切心心法。云何非因相应法。谓色及无为心不相应行。云何结法。谓九结。云何非结法。谓除九结。若诸余法。云何生结法。谓有漏法。云何非生结法。谓无漏法。云何取法。谓四取法。云何非取法。谓无漏法。云何受法。谓若法自性所摄。云何非受法。谓若法非自性所摄。云何取生法。谓有漏法。云何非取生法。谓无漏法。云何烦恼法。谓若法缠所起。云何非烦恼法。谓若法非缠所起。云何秽污法。谓不善法。及隐没无记。云何不秽污法。谓善法及不隐没无记。云何有秽污法。谓有漏法。云何非有秽污法。谓无漏法。云何缠法。谓诸烦恼法。云何非缠法。谓非诸烦恼法。云何缠住法。谓秽污心心法。云何非缠住法。谓不秽污心心法色。及无为心不相应行。云何缠生法。谓有漏法。云何非缠生法。谓无漏法。云何有缘法。谓一切心心法。云何无缘法。谓色无为及心不相应行

云何有觉法。谓若法觉相应。云何非有觉法。谓若法觉不相应。云何有观法。谓若法观相应。云何非有观法。谓若法观不相应。云何可乐法。谓若法喜根相应。云何非可乐法。谓若法喜根不相应。云何受用法。谓若法意思惟相应。云何非受用法。谓若法意思惟不相应。云何有事有缘法。谓有为法。云何无事无缘法。谓无为法。云何有上法。谓一切有为法。及虚空非数灭。云何无上法。谓数灭法。云何远法。谓过去未来法。云何近法。谓现在法。及无为法。云何有量法。谓若法有量果。及报量所得称。云何无量法。谓若法无量果。及报量所不称。云何见法。谓眼根。及五邪见。世俗正见。学见无学见。云何非见法。谓除眼根。若余色。除八见。若余行阴所摄法。受等三阴。及无为法。云何见处法。谓有漏法。云何非见处法。谓无漏法。云何见相应法。谓八见相应法。云何非见相应法。谓非八见相应法

云何凡夫法。谓地狱众生入。畜生入。饿鬼入。郁单越人入。无想天入。若由业生彼。是名凡夫法。云何非凡夫法。谓四迹。四辩。四沙门果。无诤愿智大悲灭尽正受空空无愿无愿无相无相熏修禅无间等智净居天人。由业生彼。是名非凡夫法。云何凡夫共法。谓若道共定共。生彼有处容。凡夫及圣人。若正受若生。是名凡夫共法。云何非凡夫共法。谓如非凡夫法。云何定法。谓五无间业。学法无学法。云何非定法。谓除五无间业及二学法。诸余有漏法。及无为。云何恼法。谓不善法。及隐没无记。云何非恼法。谓善法。及不隐没无记。云何根法。谓六内入。及法入中根所摄法。云何非根法。谓五外入。及法入中根所不摄法

云何圣谛摄法。谓一切有为法。及数灭。云何非圣谛摄法。谓虚空非数灭。云何共相法。谓有为法。云何非共有法。谓无为法。云何相应法。谓一切心心法。云何非相应法。谓色无为及心不相应行。云何果法。谓一切有为法。及数灭。云何非果法。谓虚空非数灭。云何有果法。谓有为法。云何非有果法。谓无为法。云何报法。谓若报得十一入少分。除声入。云何非报法。谓声入。若非报得十一入少分。云何有报法。谓不善善有漏法。云何非有报法。谓无记无漏法。云何因缘法。谓一切法。云何非因缘法。谓如是法。不可得也。云何有因缘法。谓有为法。云何非有因缘法。谓无为法。云何出法。谓欲界系善戒。色无色界系。出要寂静善正受。学法无学法。及数灭。云何非出法。谓除欲界系善戒。余欲界系法。除色无色界系出要寂静善正受。余色无色界系法。及虚空非数灭。云何有出法。谓有为法。云何非有出法。谓无为法。云何相续法。谓若彼法分段。已起当起。彼复云何。谓过去现在法。若未来法。现前必起。后法与前法相续。是名相续法。云何非相续法。谓除过去现在法及未来现前必起法。若余未来法及无为法。云何有相续法。谓若彼法分段已起。彼复云何。谓过去现在。除阿罗汉最后命终五阴。若余过去现在法。前法招后相续。是名有相续法。云何非有相续法。谓过去现在阿罗汉最后命终五阴。若未来法及无为法(二法竟)

众事分阿毗昙论卷第四众事分阿毗昙论卷第五

        尊者世友造

        宋天竺三藏求那跋陀罗共菩提耶舍译

    分别摄品第六之二

云何善法。谓善五阴。及数灭。云何不善法。谓不善五阴。云何无记法。谓无记五阴。及虚空非数灭。云何学法。谓学五阴。云何无学法。谓无学五阴。云何非学非无学法。谓有漏五阴。及无为。云何见断法。谓若法随信行随法行人。无间忍等断。彼云何断。谓见断八十八使。彼相应法。彼所起心不相应行。云何修断法。谓若法学见迹修断。彼云何断。谓修断十使。彼相应法。彼所起身口业。彼所起心不相应行。及不秽污有漏法。云何不断法。谓无漏法。云何见断因法。谓秽污法。若见所断法报。云何修断因法。谓修所断法。即如是法断。云何不断因法。谓无漏有为法。云何可见有对法。谓一入。云何不可见有对法。谓九入。云何不可见无对法。谓二入。云何报法。谓若报得十一入少分。除声入。云何非报法。谓不善善有漏法。及声入。云何非报非非报法。谓除报无记法。若余无记。及无漏法

云何下法。谓不善法隐没无记法。云何中法。谓善有漏及不隐没无记法。云何上法。谓无漏有为法。及数灭。云何小法。谓少信少欲少意解。彼相应法。彼共有法。彼色法。谓少微不多不广。是名小法。云何大法。谓大信大欲大意解。彼相应法。彼共有法。彼色法。谓多广无边无际无量。及虚空非数灭。是名大法。云何无量法。谓无量信。无量欲。无量意解。彼相应法。彼共有法。彼色法。谓多广无边无际无量。及虚空数灭非数灭。是名无量法。云何意乐法。谓若法意所乐。云何非意乐法。谓若法非意所乐。云何非意乐非非意乐法。谓若意于法舍。云何乐俱法。谓若法乐受相应。云何苦俱法。谓若法苦受相应。云何不苦不乐俱法。谓若法不苦不乐受相应。云何俱起法。谓一切有为法生相故。云何俱住法。谓一切有为法住相故。云何俱灭法。谓一切有为法灭相故。云何非俱起法。谓无为法非生相故。云何非俱住法。谓无为法非住相故。云何非俱灭法。谓无为法非灭相故。云何心俱起法。谓若心俱起十一入少分。除意入。云何心俱住法。谓若法心随转。云何心俱灭法。谓若心俱灭十入少分。除声入及意入。云何非心俱起法。谓意入。若非心俱起十一入少分。云何非心俱住法。谓若法非心随转。云何非心俱灭法。谓声入意入。若非心俱灭十入少分。云何欲界。谓欲贪欲贪相应。若受想行识。彼所起身口业。彼所起心不相应行。云何嗔恚界。谓嗔恚。嗔恚相应。若受想行识。彼所起身口业。彼所起心不相应行。云何害界。谓害害相应。若受想行识。彼所起身口业。彼所起心不相应行。云何出要界。谓出要。出要相应。若受想行识。彼所起身口业。彼所起心不相应行。及数灭。云何无嗔恚界。谓无嗔恚。无嗔恚相应。若受想行识。彼所起身口业。彼所起心不相应行。云何无害界。谓无害无害相应。若受想行识。彼所起身口业。彼所起心不相应行。云何欲界。谓若法欲贪使所使。云何色界。谓若法色贪使所使。云何无色界。谓若法无色贪使所使。云何色界。谓欲界色界。是名色界。云何无色界。谓四无色。是名无色界。云何灭界。谓数灭及非数灭。是名灭界

又复一切色法。是名色界。除数灭非数灭。余一切非色法。是名无色界。数灭及非数灭。是名灭界。云何欲有。谓若业欲界系受缘转起未来彼业报。云何色有。谓若业色界系受缘转起未来彼业报。云何无色有。谓若业无色界系受缘转起未来彼业报。云何欲漏。谓除欲界系无明。余欲界系相应结缚使烦恼缠。是名欲漏。云何有漏。谓除色无色界系无明。余色无色界系相应结缚使烦恼缠。是名有漏。云何无明漏。谓愚三界闇无知

云何过去世。谓若行。已起等起。生等生。转已转。已有已过去。已尽变过去。过去究竟。过去世所摄。是名过去世。云何未来世。谓若行。未起未等起。未生未等生。未转未已转。未有未现在未来。未来究竟。未来世所摄。是名未来世。云何现在世。谓若行。今起等起。生等生。转已转。已有已现在住。未尽变现在。现在究竟。现在世所摄。是名现在世。云何过去说事。谓过去行。云何未来说事。谓未来行。云何现在说事。谓现在行。云何苦苦苦。变苦苦。行苦苦。谓欲界苦苦苦。色界变苦苦。无色界行苦苦。复次苦受苦苦苦。乐受变苦苦。不苦不乐受行苦苦。复次非意乐行苦苦苦。意乐行变苦苦。非意乐非非意乐行行苦苦。云何有觉有观法。谓若觉观相应。云何无觉有观法。谓若法觉不相应观相应。云何无觉无观法。谓若法觉观不相应。云何有觉有观地。谓欲界至梵世及无漏法。云何无觉有观地。谓修禅中间已。能得至大梵及无漏法。云何无觉无观地。谓一切光音。一切遍净。一切果实。一切无色。及无漏法

云何身业。谓身作及无作。云何口业。谓口作。及无作。云何意业。谓思业。云何善业。谓善身口业。及善思业。云何不善业。谓不善身口业。及不善思业。云何无记业。谓无记身口业。及无记思业。云何学业。谓学身口业。及学思业。云何无学业。谓无学身口业。及无学思业。云何非学非无学业。谓有漏身口业。及有漏思业。云何见断业。谓若业随信行随法行人无间忍等断。彼云何断。谓见断八十八使相应思业。云何修断业。谓若业学见迹修断。彼云何断。谓修断十使相应思业彼所起身口业。及不秽污有漏业。云何不断业。谓无漏身口业。及无漏思业。云何现法受业。谓若业此生作长养。彼业即此生受现法报。非余生受。是名现法受业。云何生受业。谓若业此生作长养。彼业第二生受报是名生受业。云何后受业。谓若业此生作长养。彼业至第三第四生。方受其报。或复经众多生然后受报。是名后受业。云何乐受业。谓欲界相应善业。乃至第三禅善业。云何苦受业。谓不善业。云何不苦不乐受业。谓第四禅地善业。乃至无色界相应善业(三法竟)

云何身念处。谓十色入。及法入中所摄色。是名身念处。云何受念处。谓六受身眼触生受。如是耳鼻舌身意触生受。云何心念处。谓六识身。眼识耳鼻舌身意识身。是名心念处。云何法念处。谓受所不摄非色法法入摄。是名法念处。复次身增上。彼道生善有漏及无漏。是名身念处受心法增上。彼道生善有漏及无漏。是名法念处。复次缘身慧。是身念处。缘受心法慧。是法念处

云何已起恶不善法。方便令断正勤。谓已起恶不善法修令断。增上道生善有漏及无漏。是名已起恶不善法方便令断正勤。云何未起恶不善法。方便令不起正勤。谓未起恶不善法。修令不起。增上道生善有漏及无漏。是名未生恶不善法方便令不生正勤。云何未生善法。方便令生正勤。谓未生善法。勤修令生。增上道生善有漏及无漏。是名未生善法勤修令生正勤。云何已生善法。方便勤修令住。使不忘失。满足修习增广智证正勤。谓已起善法。勤修令住。使不忘失。满足修习增广智证。增上道生善有漏及无漏。是名已生善法勤修令住使不忘失满足修习增广智证正勤

云何欲定净行成就如意足。谓欲增上彼道生善有漏及无漏。是名欲定净行成就如意足。云何精进心慧定净行成就如意足。谓慧等增上彼道生善有漏及无漏。是名慧定净行成就如意足

云何初禅。谓初禅所摄善五阴。云何第二第三第四禅。谓乃至第四禅所摄善五阴

云何苦圣谛。谓五盛阴。云何集圣谛。谓有漏因。云何苦灭圣谛。谓数灭灭。云何苦灭道圣谛。谓学法无学法

云何慈。谓慈慈相应。若受想行识。彼所起身口业。及彼所起心不相应行。悲喜亦如是。云何舍。谓舍舍相应。若受想行识彼所起身口业。及彼所起心不相应行

云何虚空入处。谓虚空入处有二种。谓正受及受生彼相应法。若受想行识。如虚空入处。识入处无所有入处亦如是。云何非想非非想入处。谓非想非非想入处有二种。谓正受及受生彼相应法。若受想行识。是名非想非非想入处

云何随乞得衣知足圣种。谓随乞得衣知足业。增上彼道生善有漏及无漏。是名随乞得衣知足圣种。云何随乞得食及眠卧具等及乐闲静乐修圣种。谓随乞得食眠卧具等乐闲静乐修业。增上彼道生善有漏及无漏。是名随乞得食及眠卧具等及乐闲静乐修圣种

云何须陀洹沙门果。谓须陀洹果有二种。有为及无为。云何须陀洹有为果。谓证须陀洹果。若学法。已得今得当得。是名须陀洹有为果。云何须陀洹无为果谓证须陀洹果。若结使断。已得今得当得。是名须陀洹无为果。如须陀洹沙门果。斯陀含沙门果阿那含沙门果亦如是。云何阿罗汉沙门果。谓阿罗汉果有二种。有为及无为。云何阿罗汉有为果。谓证阿罗汉果。若无学法。已得今得当得。是名阿罗汉有为果。云何阿罗汉无为果。谓证阿罗汉果。若诸结断。已得今得当得。是名阿罗汉无为果

云何法智。谓知欲界系行无漏智。广说如前五法品。乃至无生智亦如是。云何义辩。谓不动智。于彼第一义。善能分别。云何法辩。谓不动智。于彼名味句身。善能分别。云何辞辩。谓不动智。于彼言说不生阂想。云何随应辩。谓不动智不断不散决定自在。云何因缘。谓有为法。云何次第缘。谓过去现在。除阿罗汉最后命终心心法。若余过去现在心心法。云何缘缘增上缘。谓境界一切法。云何粗抟食。谓抟食性。因彼食故。诸根增长。四大增长。随养随护。充足清明。是名抟食。云何触食。谓缘有漏触。诸根增长。四大增长。养育诸根。随护长养。亦如前说。云何意思食。谓缘有漏思。诸根增长。四大增长。如前广说。云何识食。谓缘有漏识。诸根增长。四大增长。如前广说。云何欲流。谓除欲界系五见及无明。余欲界系结缚使烦恼缠。是名欲流。云何有流。谓除色无色界系五见及无明。余色无色界系结缚使烦恼缠。是名有流。云何见流。谓五见。是名见流。云何无明流。谓愚三界暗无知。如流轭亦如是

云何欲取。谓除欲界系五见。余欲界系结缚使烦恼缠。是名欲取。云何见取。谓四见。除一见。谓身见边见邪见取见见。是名见取。云何戒取。谓一见。除四见。谓取戒见。彼复云何。谓若人邪取戒相。以为清净。即是解脱。起见起忍。是名戒取。云何我取。谓除色无色界系五见。余色无色界系结缚使烦恼缠。是名我取。云何过去法。谓过去五阴。云何未来法。谓未来五阴。云何现在法。谓现在五阴。云何非过去未来现在法。谓无为法

云何欲界系法。谓欲界系五阴。云何色界系法。谓色界系五阴。云何无色界系法。谓无色界系四阴。云何不系法。谓无漏五阴及无为。云何善因法。谓善有为法。及善法报。云何不善因法。谓欲界系秽污法。及不善法报。云何无记因法。谓无记有为法。及不善法。云何非善因非不善因非无记因法。谓无为法

云何有缘缘法。谓意识相应心心法缘。云何无缘缘法。谓五识相应。若意识相应色无为心不相应行缘。云何有缘缘无缘缘法。谓若意识相应心心法缘。色无为心不相应行缘。云何非有缘缘非无缘缘法。谓色无为心不相应行(四法竟)

云何五阴五盛阴。谓广说如前分别七事品。云何地狱趣。谓地狱众生。若一性一种类一身自分。得处得事得入。若地狱众生。生彼处不隐没无记色受想行识。是名地狱趣。畜生饿鬼趣亦如是。云何天趣人趣。谓若天若人。一性一种类一身自分。得处得事得入。若天若人。生彼此处不隐没无记色受想行识。是名人天趣

云何见苦断烦恼身。谓烦恼身。若随信行随法行人苦无间忍等断。彼云何断。谓见苦断二十八使。彼相应烦恼身。云何见集断烦恼身。谓烦恼身。若随信行随法行人集无间忍等断。彼云何断。谓见集断十九使彼相应烦恼身。云何见灭断烦恼身。谓烦恼身。若随信行随法行人灭无间忍等断。彼云何断。谓见灭断十九使。彼相应烦恼身。云何见道断烦恼身。谓烦恼身。若随信行随法行人道无间忍等断。彼云何断。谓见道断二十二使。彼相应烦恼身。云何修断烦恼身。谓烦恼身。若学见迹修断。彼云何断。谓修断十使彼相应烦恼身。云何色法。谓一切四大。及四大所造。云何心法。谓六识身眼识身。乃至意识身。云何心法法。谓若法心相应。彼复云何谓受想思触忆欲解脱念定慧信精进觉观。乃至烦恼结缠。如前五法品广说。云何心不相应行。谓若法心不相应。彼复云何。谓诸得。乃至名句味身。如前五法品广说。云何无为法。谓三无为。虚空数灭非数灭(五法竟)

云何地界。谓坚相。云何水界。谓湿相。云何火界。谓热相。云何风界。谓轻动相。云何虚空界。谓空边色。云何识界。谓五识身。及有漏意识。云何见苦断法。谓随信行随法行人苦无间忍等断。广说如前分别诸入品。集灭道修亦如是。云何不断法。谓无漏法(六法竟)

云何欲贪使。谓如欲贪说。云何嗔恚使。谓恼害众生。云何有爱使。谓色无色爱。云何慢使。谓慢心高下受。云何无明使。谓愚三界暗无知。云何见使。谓五邪见。云何疑使谓惑谛不了。云何初识住。谓有色众生种种身种种想。谓人及天。是名初识住处。云何初次第相续数。谓初识住彼相应不相应。若色受想行识。是名初识住。有色众生种种身一种想。谓梵天身。彼初所转。是名第二识住处。云何第二次第相续数。谓第二识住。彼相应不相应。若色受想行识。是名第二识住。有色众生一种身种种想。谓光音天。是名第三识住处。乃至是名第三识住。广说如上。有色众生一种身一种想。谓遍净天。是名第四识住处。乃至是名第四识住。广说如上。无色众生。离一切色想离阂想阂想究竟无种种想。思惟无边空处。住无边空入处。谓空入处天。是名第五识住。云何第五次第相续数。谓第五识住彼相应。若受想行识。是名第五识住。无色众生。已离一切虚空入处。无量识住。无量识入处。谓识入处天。是名第六识住。乃至是名第六识住。广说如上。无色众生。已离一切识入处。无所有住无所有入处。谓无所有入处天。是名第七识住。乃至是名第七识住。广说如上

云何念觉支。谓贤圣弟子。于苦思惟苦。于集思惟集。于灭思惟灭。于道思惟道。无漏意思惟相应。若念随念。念不忘失不散忘。常不废忘。是名念觉支。云何择法觉支。谓贤圣弟子。于苦思惟苦。于集思惟集。于灭思惟灭。于道思惟道。无漏意思惟相应。于法简择选择。择相等择相。决定相。慧觉聪明。慧行观察。是名择法觉支。云何精进觉支。谓贤圣弟子。于苦思惟苦。乃至于道思惟道。无漏意思惟相应。若欲精进方便出要。勇健心摄受。捷疾无间。是名精进觉支。云何喜觉支。谓贤圣弟子。乃至无漏意思惟相应。若心欢喜踊跃。增上欢喜。决定心乐。所堪能喜所喜。是名喜觉支。云何猗觉支。谓贤圣弟子。乃至无漏意思惟相应。若身猗心猗。乐猗所猗。是名猗觉支。云何定觉支。谓贤圣弟子。乃至无漏意思惟相应。若心住等住。乐住所住。不散不乱。摄受一心。是名定觉支。云何舍觉支。谓贤圣弟子。于苦思惟苦。于集思惟集。于灭思惟灭。于道思惟道。无漏意思惟相应。若心平等。等摄受心。无受用住。是名舍觉支(七法竟)

云何初解脱处。谓内有色想外观色。是名初解脱处。云何初次第相续数次第正受。谓初解脱处。若入正受善色受想行识是名初解脱处。内无色想外观色。是名第二解脱处。云何第二次第相续数次第正受。谓第二解脱处。若入正受善色受想行识。是名第二解脱处。净解脱处身证住。是名第三解脱处。乃至第三次第正受。广说如上。离一切色想离阂想阂想。究竟思惟无边空处。入无边空处。是名第四解脱处。云何第四次第相续数次第正受。谓第四解脱处。若入正受。若善受想行识。是名第四解脱处。离一切空入处。入无边识处。是名第五解脱处。乃至第五次第正受。广说如上。无所有处非想非非想处。乃至第七正受。广说如上。是名第七解脱处。离一切非想非非想处想受灭身证住。是名第八解脱处。云何第八次第相续数次第正受。谓第八解脱处。若入正受。若解脱得脱若法想。微因想。微次第想。不相续。不成就。是名第八解脱处

云何初胜处。谓内有色想。外观少色。若好色。若恶色。谓彼胜处生观想。是名初胜处入。云何初胜处次第相续数次第正受。谓初胜处。若入正受。善色受想行识。是名初胜处入。内有色想。外观多色。若好色。若恶色。谓彼胜处生观想。是名第二胜处入。乃至第二正受。广说如上。乃至第七胜处正受。广说如上。是名第七胜处入。内无色想。外观色白。白色白观白光。譬如优私多罗华色成就如婆罗奈衣白白色白观白光。如是比丘。内无色想。外观色白。白色白观白光。谓彼胜处生观想。是名第八胜处入。云何第八次第相续数次第正受。谓第八胜处若入正受。善色受想行识。是名第八胜处入

云何正见。谓贤圣弟子。于苦思惟苦。于集思惟集。于灭思惟灭。于道思惟道。无漏意思惟相应。于法简择选择择相等择相。决定相。慧觉聪明。慧行观察。是名正见。云何正思惟。谓贤圣弟子。乃至于道思惟道。无漏意思惟相应。若心觉随觉色觉增上色觉。觉数觉。觉思惟。等思惟。是名正思惟。云何正语。谓贤圣弟子。于苦思惟苦。乃至于道思惟道。无漏意思惟相应。除邪命口四过。余口恶行。无漏数灭。不作不为收摄律仪等护自防。不作恶行。不作过罪。坚固堤塘住。坚固不犯住。是名正语。云何正业。谓贤圣弟子。乃至于道思惟道。无漏意思惟相应。除邪命身三恶。余身恶行。无漏数灭。不作不为。乃至坚固不犯住。如前正语说。是名正业。云何正命。谓贤圣弟子。乃至于道思惟道。无漏意思惟相应。如前所除。邪命身口恶。无漏数灭。不作不为。如上广说。是名正命。云何正方便说。谓贤圣弟子。乃至于道思惟道。无漏意思惟相应。广说如精进觉支。是名正方便。正命广说如念觉支。是名正念。云何正定。谓贤圣弟子。于苦思惟苦。乃至于道思惟道。无漏意思惟相应。广说如正定觉支(八法竟)

云何贪欲结。谓三界贪。云何嗔恚结。谓恼害众生。云何慢结。谓七慢。云何无明结。谓愚三界暗无知。云何见结。谓三见。身见边见邪见。云何他取结。谓二见见取戒取。云何疑结。谓惑谛不了。云何嫉结。谓心妒增广。云何悭结。谓心摄受坚着

云何初众生居处。谓有色众生。种种身。种种想。谓天及人。是名初众生居处。是名初次第相续数。云何名众生居处。谓众生于中止住。于中受生入。是名众生住处。云何第二第三第四众生居处。谓如识住处广说。云何第五众生居处。谓有色众生无想。所谓无想天。是名第五众生居处。第五次第相续数。如上广说。云何第六众生居处。谓无色众生。离一切色想离阂想阂想。究竟乃至第八众生居处。广说如后三识住处。云何第九众生居处。谓无色众生。离一切无所有处。入非想非非想处住。所谓非想非非想天。是名第九众生居处。次第相续数。如上广说。是名九众生居处(九法竟)

云何初一切入处。谓地一切入。一相生。上下诸方。无二无量。是名初一切入处。云何初次第相续数次第正受。谓初一切入处。若入正受善色受想行识。是名地一切入处。如地一切入。水火风青黄赤白一切入处亦如是。空一切入处。识一切入处。一相生上下诸方无二无量。是名十一切入处。云何十一切入次第相续数次第正受。谓十一切入处。若入正受善色受想行识。是名十一切入处

无学正见。乃至无学正定。如道支说。云何无学正解脱。谓贤圣弟子。乃至于道思惟道。无学意思惟相应。若心已解脱当解脱。云何无学解脱正知见。谓尽智无生智(十法竟)

云何有漏色。谓若色有漏从取生。谓此色过去未来现在。起欲今起当起。若恚若痴。一一心数。起诸烦恼。今起当起。是名有漏色。乃至有漏识亦如是

云何无漏色。谓若色无漏。不从取生。谓此色过去未来现在。若欲应生不生。若恚若痴。及余心数烦恼。应生不生。是名无漏色。如是乃至无漏识亦如是

云何无为法。谓三无为。虚空数灭非数灭(十一法竟)

云何十二入十八界。谓如前分别七事品广说(十二法十八法竟)

云何眼根。谓如眼入。如是乃至身根如身入。云何女根。谓身根少分。男根亦如是

云何命根。谓三界中命。云何意根。谓若心意识。彼复云何。谓六识身。所谓眼识。乃至意识。乐根苦根喜根忧根舍根。如前分别七事品广说

云何信根。谓依出要寂静。生信善法。增上信正思惟种种行种种作种种思惟心清净。是名信根

云何精进根。谓出要寂静生于善法。若欲精进方便。勇猛摄心。常不懈息。是名精进根

云何念根。谓出要寂静生于善法。若念随念。是名念根

云何定根。谓出要寂静。生于善法。若心离乱。善住等住。是名定根

云何慧根。谓出要寂静。生于善法。择法照察。决断审了。是名慧根

云何未知当知根。所谓超升离生人。若学慧根。谓彼根随信行随法行未无间等四圣谛。而无间等生。是名未知当知根

云何已知根。所谓见谛人无间等。若学慧根。谓彼根信解脱。见到身证。已无间等四圣谛。增上无间生。是名已知根

云何无知根所谓阿罗汉。尽诸漏结。若无学慧根。谓彼根慧解脱俱解脱。现法乐住。增上无间生。是名无知根(二十二法竟)

云何九十八使。谓三十六使欲界系。三十一使色界系。三十一使无色界系(九十八法竟)

众事分阿毗昙论卷第五众事分阿毗昙论卷第六

        尊者世友造

        宋天竺三藏求那跋陀罗共菩提耶舍译

    分别摄品第六之三

尔焰法。识法。通尔焰法。缘法。增上法。十八界。十二入五阴摄。十智知。六识识。一切使使。色法。十一界十一入一阴摄。八智知。除知他心智及灭智。六识识。欲色二界一切。遍使使。及修断使使。非色法。八界二入四阴摄。十智知。一识识。一切使使

可见法。一界一入一阴摄。七智知。除知他心智及灭道智。二识识。欲色二界一切。遍使使。及修断使使。不可见法。十七界十一入五阴摄。十智知。五识识。一切使使

有对法。十界十入一阴摄。七智知。除知他心智及灭道智。六识识。欲色二界一切。遍使使。及修断使使。无对法。八界二入五阴摄。十智知。一识识。一切使使

有漏法。十八界十二入五阴摄。八智知。除灭道智。六识识。一切使使。无漏法三界二入五阴摄。八智知。除苦集智。一识识。使所不使

有为法。十八界十二入五阴摄。九智知。除灭智。六识识。一切使使。无为法。一界一入阴所不摄。六智知。除知他心智及苦集道智。一识识。使所不使有诤法。十八界十二入五阴摄。八智知。除灭道智。六识识。一切使使。无诤法。三界二入五阴摄。八智知。除苦集智。一识识。使所不使。如有诤法。无诤法世间法出世间法入法不入法染污法不染污法依家法依出要法亦如是。心法。七界一入一阴摄。九智知。除灭智。一识识。一切使使。非心法。十一界十一入四阴摄。十智知。六识识。一切使使

心法法。一界一入三阴摄。九智知。除灭智。一识识。一切使使。非心法法。十八界十二入三阴摄。十智知。六识识。一切使使。如心法法。非心法法。心相应法心不相应法亦如是。心共有法十一界十一入四阴摄。九智知。除灭智。六识识。一切使使。非心共有法。十八界十二入三阴摄。十智知。六识识。一切使使。心随转法。一界一入四阴摄。九智知。除灭智。一识识。一切使使。非心随转法。十八界十二入三阴摄。十智知。六识识。一切使使。心因法。十八界十二入五阴摄。九智知。除灭智。六识识。一切使使。非心因法。十三界十二入五阴摄。十智知。六识识。三界一切遍使使。及修断使使。心次第法。八界二入四阴摄。九智知。除灭智。一识识。一切使使。非心次第法。十八界十二入五阴摄。十智知。六识识。一切使使缘心法。三界二入四阴摄。九智知。除灭知。一识识。有为缘使使。非缘心法。十八界十二入五阴摄。十智知。六识识。一切使使。心增上法。十八界十二入五阴摄。九智知。除灭智。一切使使。非心增上法。一界一入阴所不摄。六智知。除知他心智及苦集道智。一识识。使所不使。心果法。十八界十二入五阴摄。十智知六识识。一切使使。非心果法。一界一入阴所不摄。一智知。谓等智。一识识。使所不使。心报法。十七界十一入五阴摄。八智知。除灭道智。五识识。三界一切遍使使。及修断使使。非心报法。十八界十二入五阴摄。十智知。六识识。一切使使

业法。三界三入二阴摄。九智知。除灭智。三识识。谓眼耳及意一切使使。非业法。十八界十二入五阴摄。十智知。六识识。一切使使。业相应法。八界二入四阴摄。九智知。除灭智。一识识。一切使使。非业相应法。十一界十一入二阴摄。十智知。六识识。一切使使。业共有法。十八界十二入五阴摄。九智知。除灭智。六识识。一切使使非业共有法。十一界十一入二阴摄。十智知。六识识。一切使使。业随转法。八界二入五阴摄。九智知。除灭智。一识识。一切使使。非业随转法。十一界十一入二阴摄。十智知。六识识。一切使使。业因法。十八界十二入五阴摄。九智知。除灭智。六识识。一切使使。非业因法。十一界十一入二阴摄。十智知。六识识。三界一切遍使使。及修断使使。业次第法。八界二入四阴摄。九智知。除灭智。一识识。一切使使。非业次第法。十八界十二入五阴摄。十智知。六识识。一切使使。缘业法。五界二入四阴摄。九智知。除灭智。一识识。有为缘使使。非缘业法。十八界十二入五阴摄。十智知。六识识。一切使使。业增上法。十八界十二入五阴摄。九智知除灭智。六识识。一切使使。非业增上法。一界一入阴所不摄。六智知。除知他心智及苦集道智。一识识。使所不使。业果法。十八界十二入五阴摄。十智知。六识识。一切使使。非业果法。一界一入阴所不摄。一智知。谓等智。一识识。使所不使。业报法。十七界十一入五阴摄。八智知。除灭道智。五识识。三界一切遍使使。及修断使使。非业报法。十八界十二入五阴摄。十智知。六识识。一切使使

有法。十八界十二入五阴摄。八智知。除灭道智。六识识。一切使使。非有法。三界二入五阴摄。八智知。除苦集智。一识识。使所不使。有相应法。八界二入四阴摄。八智知。除灭道智。一识识。一切使使。非有相应法。十三界十二入五阴摄。十智知。六识识。有漏缘使使。有共有法。十八界十二入五阴摄。九智知。除灭智。六识识。一切使使。非有共有法。三界二入五阴摄。八智知。除苦集智。一识识。使所不使。有随转有因法。十八界十二入五阴摄。八智知。除灭道智。六识识。一切使使。非有随转非有因法。三界二入五阴摄。八智知。除苦集智。一识识。使所不使。有次第法。八界二入四阴摄。九智知。除灭智。一识识。一切使使。非有次第法。十八界十二入五阴摄。十智知。六识识。一切使使。缘有法。八界二入四阴摄。九智知。除灭智。一识识。有漏缘使使。非缘有法。十三界十二入五阴摄。十智知。六识识。一切使使。有增上法。十八界十二入五阴摄。九智知。除灭智。六识识。一切使使。非有增上法。一界一入阴所不摄。六智知。除知他心智及苦集道智。一识识。使所不使。有果法。十八界十二入五阴摄。九智知。除灭智六识识。一切使使。非有果法。三界二入五阴摄。八智知。除苦集智。一识识。使所不使。有报法。十七界十一入五阴摄。八智知。除灭道智。五识识。三界一切遍使使。及修断使使。非有报法。十八界十二入五阴摄。十智知。六识识。一切使使

智所知法。十八界十二入五阴摄。十智知。六识识。一切使使。非智所知法。界入及阴所不摄。智所不知。识所不识。使所不使

断知所断法。十八界十二入五阴摄。八智知。除灭道智。六识识。一切使使。非断知所断法。三界二入五阴摄。八智知。除苦集智。一识识。使所不使

修法。十界四入五阴摄。九智知。除灭智。三识识。三界一切遍使使。及修断使使。非修法。十八界十二入五阴摄。九智知。除道智。六识识。一切使使

智证法。十八界十二入五阴摄。十智知。六识识。一切使使。非智证法。界入及阴所不摄。智所不知。识所不识。使所不使

得证法。十二界六入五阴摄。十智知。三识识。三界一切遍使使。及修断使使。非得证法。十八界十二入五阴摄。八智知。除灭道智。六识识。一切使使。习法。十界四入五阴摄。九智知。除灭智。三识识。三界一切遍使使。及修断使使。非习法。十八界十二入五阴摄。九智知。除道智。六识识。一切使使

有罪法。十界四入五阴摄。八智知。除灭道智。三识识。一切使使。无罪法。十八界十二入五阴摄。十智知。六识识。三界一切遍使使。及修断使使如有罪法。无罪法黑法白法退法不退法隐没法不隐没法亦如是

记法。十界四入五阴摄。十智知。三识识。欲界一切使使。色无色界一切遍使使。及修断使使。无记法。十八界十二入五阴摄。八智知。除灭道智。六识识。色无色界一切。欲界二身见集断一切遍使使

已起法十八界十二入五阴摄。九智知。除灭智。六识识。一切使使。不起法。十八界十二入五阴摄。十智知。六识识。一切使使。如已起法。不起法今起法非今起法。已灭法非已灭法今灭法非今灭法亦如是

缘起法。十八界十二入五阴摄。九智知。除灭智。六识识。一切使使。非缘起法。一界一入阴所不摄。六智知。除知他心智及苦集道智。一识识。使所不使。如缘起法。非缘起法缘生法非缘生法因法非因法有因法非有因法因起法非因起法亦如是

因相应法。八界二入四阴摄。九智知。除灭智。一识识。一切使使。非因相应法。十一界十一入二阴摄。九智知。除知他心智。六识识。有漏缘使使

结法。一界一入一阴摄。八智知。除灭道智。一识识。除无漏缘独无明。余一切使使。非结法。十八界十二入五阴摄。十智知。六识识。一切使使。生结法。十八界十二入五阴摄。八智知除灭道智。六识识。一切使使。非生结法。三界二入五阴摄。八智知。除苦集智。一识识。使所不使

取法。一界一入一阴摄。八智知。除灭道智。一识识。一切使使。非取法。三界二入五阴摄。八智知。除苦集智。一识识。使所不使

受法。九界九入一阴摄。七智知。除知他心智及灭道智。五识识。欲色二界一切。遍使使。及修断使使。非受法。十八界十二入五阴摄。十智知。六识识。一切使使

取生法。十八界十二入五阴摄。八智知除灭道智。六识识。一切使使。非取生法。三界二入五阴摄。八智知。除苦集智。一识识。使所不使。烦恼法。一界一入一阴摄。八智知。除灭道智。一识识。一切使使。非烦恼法。十八界十二入五阴摄。十智知。六识识。一切使使。秽污法。十界四入五阴摄。八智知。除灭道智。三识识。一切使使。不秽污法。十八界十二入五阴摄。十智知。六识识。一切使使。有秽污法。十八界十二入五阴摄。八智知。除灭道智。六识识。一切使使。非有秽污法。三界二入五阴摄。八智知。除苦集智。一识识。使所不使

缠法。一界一入一阴摄。八智知。除灭道智。一识识。一切使使。非缠法。十八界十二入五阴摄。十智知。六识识。一切使使。缠住法。八界二入四阴摄。八智知。除灭道智。一识识。一切使使。非缠住法。十八界十二入五阴摄。十智知。六识识。有漏缘使使。缠生法。广说如有漏法。非缠生法。广说如无漏法。有缘法。八界二入四阴摄。九智知。除灭智。一识识。一切使使。无缘法。十一界十一入二阴摄。九智知。除知他心智。六识识。有漏缘使使。有觉法。八界二入四阴摄。九智知。除灭智。一识识。欲色二界一切使使。非有觉法。十三界十二入五阴摄。十智知。六识识。一切使使。如有觉法。非有觉法有观法非有观法亦如是。可乐法。三界二入三阴摄。九智知。除灭智。一识识。色界一切使使。除欲界无漏缘疑相应无明余欲界一切使使。非可乐法。十八界十二入五阴摄。十智知。六识识。一切使使

受用法。八界二入四阴摄。九智知。除灭智。一识识。一切使使。非受用法。十一界十一入二阴摄。十智知。六识识。一切使使

有事有缘法。十八界十二入五阴摄。九智知。除灭智。六识识。一切使使。无事无缘法。一界一入阴所不摄。六智知。除知他心智及苦集道智。一识识。使所不使

有上法。十八界十二入五阴摄。九智知。除灭智。六识识。一切使使。无上法。一界一入阴所不摄。六智知。除知他心智及苦集道智。一识识。使所不使。远法。十八界十二入五阴摄。九智知。除灭智。六识识。一切使使。近法。十八界十二入五阴摄。十智知。六识识。一切使使。如远法。近法有量法无量法亦如是

见法。二界二入二阴摄。九智知。除灭智。一识识。有漏缘使使。及无漏缘见。彼相应无明。非见法。十七界十一入五阴摄。十智知。六识识。一切使使。见处法。十八界十二入五阴摄。八智知。除灭道智。六识识。一切使使。非见处法。三界二入五阴摄。八智知。除苦集智。一识识。使所不使。见相应法。三界二入四阴摄。九智知。除灭智。一识识。有漏缘使使。及无漏缘见。彼相应无明。非见相应法。十八界十二入五阴摄。十智知。六识识。除无漏缘见。余一切使使

凡夫法。十八界十二入五阴摄。八智知。除灭道智。六识识。三界一切使使。非凡夫法。十一界十入五阴摄。十智知。四识识。三界一切遍使使。及修断使使。凡夫共法。十八界十二入五阴摄。八智知。除灭道智。六识识。三界一切使使。非凡夫共法。十一界十入五阴摄。十智知。四识识。三界一切遍使使。及修断使使

定法。五界四入五阴摄。九智知。除灭智。三识识。欲界一切遍使使。及修断使使。非定法。十八界十二入五阴摄。九智知。除道智。六识识。一切使使

恼法。十界四入五阴摄。八智知。除灭道智。三识识。一切使使。非恼法。十八界十二入五阴摄。十智知。六识识。三界一切遍使使。及修断使使

根法。十三界七入四阴摄。九智知。除灭智。一识识。一切使使。非根法。六界六入三阴摄。十智知。六识识。一切使使。圣谛摄法。十八界十二入五阴摄。十智知。六识识。一切使使。非圣谛摄法。一界一入阴所不摄。一智知。谓等智。一识识。使所不使

共有法。十八界十二入五阴摄。九智知。除灭智。六识识。一切使使。非共有法。一界一入阴所不摄。六智知。除知他心智及苦集道智。一识识。使所不使。相应法。八界二入四阴摄。九智知。除灭智。一识识。一切使使。非相应法。十一界十一入二阴摄。九智知。除知他心智。六识识。有漏缘使使

果法。十八界十二入五阴摄。十智知。六识识。一切使使。非果法。一界一入阴所不摄。一智知。谓等智。一识识。使所不使。有果法。十八界十二入五阴摄。九智知。除灭智。六识识。一切使使。非有果法。一界一入阴所不摄。六智知。除知他心智及苦集道智。一识识。使所不使。报法。十七界十一入五阴摄。八智知。除灭道智。五识识。三界一切遍使使。及修断使使。非报法。十八界十二入五阴摄。十智知。六识识。一切使使。有报法。十界四入五阴摄。八智知。除灭道智。三识识。欲界一切使使。色无色界一切遍使使。及修断使使。非有报法。十八界十二入五阴摄。十智知。六识识。色无色界一切。欲界二身见集断一切。遍使使。及修断使使。因缘法。广说如智所知法。非因缘法。广说如非智所知法。有因缘法。广说如有果法。非有因缘法。广说如非有果法

出法。五界四入五阴摄。十智知。三识识。三界一切遍使使。及修断使使。非出法。十八界十二入五阴摄。八智知。除灭道智。六识识。一切使使。有出法。十八界十二入五阴摄。九智知。除灭智。六识识。一切使使。非有出法。一界一入阴所不摄。六智知。除知他心智及苦集道智。一识识。使所不使

相续法。十八界十二入五阴摄。九智知。除灭智。六识识。一切使使。非相续法。十八界十二入五阴摄。十智知。六识识。一切使使。如相续法。非相续法有相续法非有相续法亦如是(二法竟)。善法。十界四入五阴摄。十智知。三识识。三界一切遍使使。及修断使使。不善法。十界四入五阴摄。七智知。除比智及灭道智。三识识。欲界一切使使。无记法。十八界十二入五阴摄。八智知。除灭道智。六识识。色无色界一切。欲界二身见集断一切。遍使使。及修断使使。学法。三界二入五阴摄。七智知。除苦集灭智。一识识。使所不使。无学法亦如是。非学非无学法。十八界十二入五阴摄。九智知。除道智。六识识。一切使使

见断法。三界二入四阴摄。八智知。除灭道智。一识识。见断一切使使。修断法。十八界十二入五阴摄。八智知。除灭道智。六识识。修断一切使使。及一切遍使使。不断法。三界二入五阴摄。八智知。除苦集智。一识识。使所不使。见断因法。十八界十二入五阴摄。八智知。除灭道智。六识识。一切使使。修断因法。十八界十二入五阴摄。八智知。除灭道智。六识识。修断一切使使。及一切遍使使。不断因法。三界二入五阴摄。七智知。除苦集灭智。一识识。使所不使

可见有对法。一界一入一阴摄。七智知。除知他心智及灭道智。二识识。欲色二界一切。遍使使。及修断使使。不可见有对法。九界九入一阴摄。七智知。除知他心智及灭道智。五识识。欲色二界一切。遍使使。及修断使使。不可见无对法。八界二入五阴摄。十智知一识识。一切使使

报法。十七界十一入五阴摄。八智知。除灭道智。五识识。三界一切遍使使。及修断使使。非报法。十界四入五阴摄。八智知。除灭道智。三识识。欲界一切使使。色无色界一切遍使使。及修断使使。非报非非报法。十八界十二入五阴摄十智知。六识识。色无色界一切。欲界二身见集断一切。遍使使。及修断使使

下法。十界四入五阴摄。八智知。除灭道智。三识识。一切使使。中法。十八界十二入五阴摄。八智知。除灭道智。六识识。三界一切遍使使。及修断使使。上法。三界二入五阴摄。八智知。除苦集智。一识识。使所不使

小法。及大法。十八界十二入五阴摄。九智知。除灭智。六识识。一切使使

无量法。意乐法。非意乐法。非意乐非不意乐法。十八界十二入五阴摄。十智知。六识识。一切使使

乐俱法。八界二入三阴摄。九智知。除灭智。一识识。色界一切使使。除欲界无漏缘疑彼相应无明。余欲界一切使使。苦俱法。八界二入三阴摄。七智知。除比智及灭道智。一识识。欲界一切使使。不苦不乐俱法。八界二入三阴摄。九智知。除灭智。一识识。一切使使。俱起法。俱住法。俱灭法。十八界十二入五阴摄。九智知。除灭智。六识识。一切使使。非俱起法。非俱住法。非俱灭法。一界一入阴所不摄。六智知。除知他心智及苦集道智。一识识。使所不使。心俱起法。十一界十一入四阴摄。九智知。除灭智。六识识。一切使使。心俱住法。一界一入四阴摄。九智知。除灭智。一识识。一切使使。心俱灭法。十界十入四阴摄。九智知。除灭智。五识识。一切使使。非心俱起法。非心俱住法。非心俱灭法。十八界十二入三阴摄。十智知。六识识。一切使使

欲界十界四入五阴摄。七智知。除比智及灭道智。三识识。欲界有漏缘使使。如欲界。嗔恚界亦如是。害界。五界。四入五阴摄。七智知。除比智及灭道智。三识识。欲界一切遍使使。及修断使使

出要界。十界四入五阴摄。十智知。三识识。三界一切遍使使。及修断使使。无嗔界。无害界。十界四入五阴摄。九智知。除灭智。三识识。三界一切遍使使。及修断使使

欲界十八界十二入五阴摄。七智知。除比智及灭道智。六识识。欲界一切使使。色界。十四界十入五阴摄。七智知。除法智及灭道智。四识识。色界。一切使使。无色界。三界二入四阴摄。六智知。除法智知他心智及灭道智。一识识。无色界。一切使使

欲界色界。是名色界者。十八界十二入五阴摄。八智知。除灭道智。六识识。欲色二界一切使使。四无色。是名无色界者。三界二入四阴摄。六智知。除法智知他心智及灭道智。一识识。无色界一切使使。数灭及非数灭。是名灭界者。一界一入阴所不摄。六智知。除知他心智及苦集道智。一识识。使所不使。一切色法。是名色界者。十一界十一入一阴摄。八智知。除知他心智及灭智。六识识。欲色二界一切遍使使。及修断使使。除数灭及非数灭。余一切非色法。是名无色界者。八界二入四阴摄。九智知。除灭智。一识识。一切使使。数灭及非数灭。是名灭界者。一界一入阴所不摄。六智知。除知他心智及苦集道智。一识识。使所不使。欲有。十八界十二入五阴摄。七智知。除比智及灭道智。六识识。欲界一切使使。色有。十四界十入五阴摄。七智知。除法智及灭道智。四识识。色界一切使使。无色有。三界二入四阴摄。六智知。除法智知他心智及灭道智。一识识。无色界一切使使

欲漏。一界一入一阴摄。七智知。除比智及灭道智。一识识。欲界一切使使。有漏。一界一入一阴摄。七智知。除法智及灭道智。一识识。色无色界一切使使。无明漏。一界一入一阴摄八智知。除灭道智。一识识。除无漏缘无明。余一切使使

众事分阿毗昙论卷第六众事分阿毗昙论卷第七

        尊者世友造

        宋天竺三藏求那跋陀罗共菩提耶舍译

    分别摄品第六之四

三世及三世说事。十八界十二入五阴摄。九智知。除灭智。六识识。一切使使。欲界苦苦。十八界十二入五阴摄。七智知。除比智及灭道智。六识识。欲界一切使使。色界变苦苦。十四界十入五阴摄。七智知。除法智及灭道智。四识识。色界一切使使。无色界行苦苦。三界二入四阴摄。六智知。除法智知他心智及灭道智。一识识。无色界一切使使。复次苦受苦苦。一界一入一阴摄。七智知。除比智及灭道智。一识识。欲界一切使使。乐受变苦苦。一界一入一阴摄。九智知。除灭智。一识识。色界一切使使。除欲界无漏缘疑及彼相应无明。余欲界一切使使。不苦不乐受行苦苦。一界一入一阴摄。九智知。除灭智。一识识。一切使使

有觉有观法。八界二入四阴摄。九智知。除灭智。一识识。欲色二界一切使使。无觉有观法。三界二入四阴摄。九智知。除灭智。一识识。欲色二界一切使使。无觉无观法。十三界十二入五阴摄。十智知。六识识。色无色界一切使使。欲界有漏缘使使。有觉有观地。十八界十二入五阴摄。九智知。除灭智。六识识。欲色二界一切使使。无觉有观地。三界二入五阴摄。九智知。除灭智。一识识。色界一切遍使使。及修断使使。无觉无观地。十一界十入五阴摄。九智知。除灭智。四识识。色无色界一切使使。身业。二界二入一阴摄。八智知。除知他心智及灭智。二识识。欲色二界一切遍使使。及修断使使。如身业。口业亦如是。意业。一界一入一阴摄。九智知。除灭智。一识识。一切使使

善业。三界二入二阴摄。九智知。除灭智。三识识。三界一切遍使使。及修断使使。不善业。三界三入二阴摄。七智知。除比智及灭道智。三识识。欲界一切使使。无记业。三界三入二阴摄。八智知。除灭道智。三识识。色无色界一切。欲界二身见集断一切遍使使。及修断使使。学业。一界一入二阴摄。七智知。除苦集灭智。一识识。使所不使如学业。无学业亦如是。非学非无学业。三界三入二阴摄。八智知除灭道智。三识识。一切使使

见断业。一界一入一阴摄。八智知。除灭道智。一识识。见断一切使使。修断业。三界三入二阴摄。八智知。除灭道智。三识识。修断一切使使。及一切遍使使。不断业。一界一入二阴摄。七智知。除苦集灭智。一识识。使所不使

现法受业。生受业。后受业。三界三入二阴摄。八智知。除灭道智。三识识。欲界一切使使。色无色界一切遍使使。及修断使使

乐受业。三界三入二阴摄。八智知。除灭道智。三识识。欲色二界一切遍使使。及修断使使。苦受业。三界三入二阴摄。七智知。除比智及灭道智。三识识。欲界一切使使。不苦不乐受业。一界一入二阴摄。七智知。除法智及灭道智。一识识。色无色界一切遍使使。及修断使使(三法竟)

身念处。十一界十一入一阴摄。八智知。除知他心智及灭智。六识识。欲色二界一切遍使使。及修断使使。受念处。一界一入一阴摄。九智知。除灭智。一识识。一切使使。心念处。七界一入一阴摄。九智知。除灭智。一识识。一切使使。法念处。一界一入二阴摄。十智知。一识识。一切使使。复次身增上。彼道生善有漏及无漏。受心法增上。彼道生善有漏及无漏。四正勤。四神足。三界二入五阴摄。九智知。除灭智。一识识。三界一切遍使使。及修断使使。禅。三界二入五阴摄。九智知。除灭智。一识识。色界一切遍使使。及修断使使。苦谛十八界十二入五阴摄。八智知。除灭道智。六识识。一切使使。如苦谛。集谛亦如是。灭体。一界一入阴所不摄。六智知。除知他心智及苦集道智。一识识。使所不使。道谛。三界二入五阴摄。七智知。除苦集灭智。一识识。使所不使

慈悲喜舍。三界二入五阴摄。七智知。除法智及灭道智。一识识。色界一切遍使使。及修断使使

空八处。识入处。无所有入处。三界二入四阴摄。七智知。除法智知他心智灭智。一识识。无色界一切使使。非想非非想入处。三界二入四阴摄。六智知。除法智知他心智及灭道智。一识识。无色界一切使使

四圣种。三界二入五阴摄。九智知。除灭智。一识识。三界一切遍使使。及修断使使

有为沙门果。三界二入五阴摄。七智知。除苦集灭智。一识识。使所不使。无为沙门果。一界一入阴所不摄。六智知。除知他心智及苦集道智。一识识。使所不使

法智。一界一入一阴摄。六智知。除比智及苦集灭智。一识识。使所不使。比智。一界一入一阴摄。六智知。除法智及苦集灭智。一识识。使所不使。知他心智。一界一入一阴摄。九智知。除灭智。一识识。色界一切遍使使。及修断使使。等智。一界一入一阴摄。八智知。除灭道智。一识识。除见无漏缘。余一切使使。余智。一界一入一阴摄。七智知。除苦集灭智。一识识。使所不使

义辩及应辩。一界一入一阴摄。九智知。除灭智。一识识。三界一切遍使使。及修断使使。法辩及辞辩。一界一入一阴摄。八智知。除灭道智。一识识。欲色二界一切遍使使。及修断使使

因缘。十八界十二入五阴摄。九智知。除灭智。六识识。一切使使。次第缘。八界二入四阴摄。九智知。除灭智。一识识。一切使使。所缘缘。及增上缘。十八界十二入五阴摄。十智知。六识识。一切使使

抟食。三界三入一阴摄。六智知。除比智知他心智及灭道智。四识识。欲界一切遍使使。及修断使使。触食及意思食。一界一入一阴摄。八智知。除灭道智。一识识。一切使使。识食。七界一入一阴摄。八智知。除灭道智。一识识。一切使使

欲流。一界一入一阴摄。七智知。除比智及灭道智。一识识。欲界一切使使。有流。一界一入一阴摄。七智知。除法智及灭道智。一识识。色无色界一切使使。见流。一界一入一阴摄。八智知。除灭道智。一识识。见断有漏缘使使。除见相应无漏缘。无明无明流。一界一入一阴摄。八智知。除灭道智。一识识。除无漏缘无明。余一切使使。如流。轭亦如是

欲取。一界一入一阴摄。七智知。除比智及灭道智。一识识。欲界一切使使。见取。一界一入一阴摄。八智知。除灭道智。一识识。见断有漏缘使使。除见相应无漏缘无明。戒取。一界一入一阴摄。八智知。除灭道智。一识识。见苦断一切使使。见集断一切遍使使。乃至见道断有漏缘使使。我取广说如有流

过去法。未来法。现在法。十八界十二入五阴摄。九智知。除灭智。六识识。一切使使。非过去未来现在法。一界一入一阴所不摄。六智知。除知他心智及苦集道智。一识识。使所不使。欲界系法。十八界十二入五阴摄。七智知。除比智及灭道智。六识识。欲界一切使使。色界系法。十四界十入五阴摄。七智知。除法智及灭道智。四识识。色界一切使使。无色界系法。三界二入四阴摄。六智知。除法智知他心智及灭道智。一识识。无色界一切使使。不系法。三界二入五阴摄。八智知。除苦集智。一识识护。使所不使

善因法。十八界十二入五阴摄。九智知。除灭智。六识识。三界一切遍使使。及修断使使。不善因法。十八界十二入五阴摄。七智知。除比智及灭道智。六识识。欲界一切使使。无记因法。十八界十二入五阴摄。八智知。除灭道智。六识识。一切使使。非善因非不善因非无记因法。一界一入阴所不摄。六智知。除知他心智及苦集道智。一识识。使所不使

有缘缘法。三界二入四阴摄。九智知。除灭智。一识识。有为缘使使。无缘缘法。八界二入四阴摄。九智知。除灭智。一识识。一切使使。有缘缘无缘缘法。三界二入四阴摄。九智知。除灭智。一识识。一切使使。非有缘缘非无缘缘法。十一界十一入二阴摄。九智知。除知他心智。六识识。有漏缘使使(四法竟)

色阴。十一界十一入一阴摄。八智知。除知他心智及灭智。六识识。欲色二界一切遍使使。及修断使使。受阴想阴行阴。一界一入三阴摄。九智知。除灭智。一识识。一切使使。识阴。七界一入一阴摄。九智知。除灭智。一识识。一切使使。色盛阴。十一界十一入一阴摄。七智知。除知他心智及灭道智。六识识。欲色二界一切遍使使。及修断使使。受盛阴想盛阴行盛阴。一界一入三阴摄。八智知。除灭道智。一识识。一切使使。识盛阴。七界一入一阴摄。八智知。除灭道智。一识识。一切使使。地狱趣。畜生饿鬼。及人趣。十八界十二入五阴摄。七智知。除比智及灭道智。六识识。欲界一切使使。天趣。十八界十二入五阴摄。八智知。除灭道智。六识识。三界一切使使

见苦断烦恼身。一界一入一阴摄。八智知。除灭道智。一识识。见苦断一切使使。及见集断一切遍使使。见集断烦恼身。一界一入一阴摄。八智知。除灭道智。一识识。见集断一切使使。及见苦断一切遍使使。见灭断烦恼身。一界一入一阴摄。八智知。除灭道智。一识识。见灭断有漏缘使使。及一切遍使使。见道断烦恼身。一界一入一阴摄。八智知。除灭道智。一识识。见道断有漏缘使使。及一切遍使使。修断烦恼身。一界一入一阴摄。八智知。除灭道智。一识识。修断一切使使。及一切遍使使

色法如色阴。心法如识阴。心法法。一界一入三阴摄。九智知。除灭智。一识识。一切使使。心不相应行。一界一入一阴摄。八智知。除知他心智及灭智。一识识。有漏缘使使。无为法广说如果非果法(五法竟)

地界。一界一入一阴摄。七智知。除知他心智及灭道智。二识识。欲色二界一切遍使使。及修断使使。如地界。水界火界风界虚空界亦如是

识界。七界一入一阴摄。八智知。除灭道智。一识识。一切使使

见苦断法。三界二入四阴摄。八智知。除灭道智。一识识。见苦断一切使使。及见集断一切遍使使。见集断法。三界二入四阴摄。八智知。除灭道智。一识识。见集断一切使使。及见苦断一切遍使使。见灭断法。三界二入四阴摄。八智知。除灭道智。一识识。见道断一切使使。及一切遍使使。见道断法。三界二入四阴摄。八智知。除灭道智。一识识。见道断一切使使。及一切遍使使。修断法。十八界十二入五阴摄。八智知。除灭道智。六识识。修断一切使使。及一切遍使使。不断法。三界二入五阴摄。八智知。除苦集智。一识识。使所不使(六法竟)

贪欲使。及嗔恚使。一界一入一阴摄。七智知。除比智及灭道智。一识识。欲界有漏缘使使。有爱使。一界一入一阴摄。七智知。除法智及灭道智。一识识。色无色界有漏缘使使。慢使。一界一入一阴摄。八智知。除灭道智。一识识。三界有漏缘使使。无明使。一界一入一阴摄。八智知。除灭道智。一识识。除无漏缘无明。余一切使使。见使。一界一入一阴摄。八智知。除灭道智。一识识。见断有漏缘使使。及见相应无漏缘无明。疑使。一界一入。一阴摄。八智知。除灭道智。一识识。见断有漏缘使使。及疑相应无漏缘无明

初识住处。十八界十二入五阴摄。七智知。除比智及灭道智。六识识。欲界一切使使。第二识住处。十四界十入五阴摄。七智知。除法智及灭道智。四识识。色界一切使使。第三第四识住处。十一界十入五阴摄。七智知。除法智及灭道智。一识识。色界一切使使。第五第六第七识住处。三界二入四阴摄。六智知。除法智知他心智及灭道智。一识识。无色界一切使使

七觉支品。一界一入二阴摄。七智知。除苦集灭智。一识识。使所不使(七法竟)

初解脱处。及第二第三解脱处。三界二入五阴摄。七智知。除法智及灭道智。一识识。色界一切遍使使。及修断使使。空入处解脱。识入处解脱。无所有入处解脱。三界二入四阴摄。七智知。除法智知他心智及灭智。一识识。无色界一切遍使使。及修断使使。非想非非想入处解脱。三界二入四阴摄。六智知。除法智知他心智及灭道智。一识识。无色界一切遍使使。及修断使使。想受灭入处解脱。一界一入一阴摄。六智知。除法智知他心智及灭道智。一识识。无色界一切遍使使。及修断使使。八胜处入。及八一切入处。三界二入五阴摄。七智知。除法智及灭道智。一识识。色界一切遍使使。及修断使使

道支中正语正业正命。一界一入一阴摄。六智知。除知他心智及苦集灭智。一识识。使所不使。诸余道支。一界一入一阴摄。七智知。除苦集灭智。一识识。使所不使(八法竟)

贪欲结。及慢结。一界一入一阴摄。八智知。除灭道智。一识识。三界有漏缘使使。嗔恚结。一界一入一阴摄。七智知。除比智及灭道智。一识识。欲界有漏缘使使。无明结。如无明使。见结。如见使。他取结。一界一入一阴摄。八智知。除灭道智。一识识。见断有漏缘使使。疑结。一界一入一阴摄。八智知。除灭道智。一识识。见断有漏缘使使。及疑相应无漏缘无明。悭嫉二结。一界一入一阴摄。七智知。除比智及灭道智。一识识。欲界一切遍使使。及修断使使。初众生居处。如初识住处。第二众生居处。如第二识住处。第三第四第五众生居处。如第三第四识住处。余众生居处。如余识住处(九法竟)

空一切入处。及识一切入处。三界二入四阴摄。六智知。除法智知他心智及灭道智。一识识。无色界。一切遍使使。及修断使使

无学法中正语正业正命。一界一入一阴摄。六智知。除知他心智及苦集灭智。一识识。使所不使。余无学法。如余道支(十法竟)

有漏色。十一界十一入一阴摄。七智知。除知他心智及灭道智。六识识。欲色二界一切遍使使。及修断使使。有漏受想行。一界一入三阴摄。八智知。除灭道智。一识识。一切使使。有漏识。如识界。无漏色。一界一入一阴摄。六智知。除知他心智及苦集灭智。一识识。使所不使。无漏受想行。一界一入三阴摄。七智知。除苦集灭智。一识识。使所不使。无漏识。二界一入一阴摄。七智知。除苦集智及灭智。一识识。使所不使。无为法广说如果非果法(十一法竟)

眼入。一界一入一阴摄。七智知。除知他心智及灭道智。一识识。欲色二界一切遍使使。及修断使使。如眼入。耳入鼻入舌入身入眼界耳界鼻界舌界。身界眼根耳根鼻根舌根身根亦如是

色入。一界一入一阴摄。七智知。除知他心智及灭道智。二识识。欲色二界一切遍使使。及修断使使。如色入。声入触入色界声界触界亦如是

香入。一界一入一阴摄。六智知。除比智知他心智及灭道智。二识识。欲界一切遍使使。及修断使使。如香入味入。香界味界亦如是

意入。七界一入一阴摄。九智知。除灭智。一识识。一切使使。如意入。意界意根亦如是

法入一界。一入四阴摄十智知。一识识。一切使使。如法入。法界亦如是(十二法竟)

眼识界。二界一入一阴摄。八智知。除灭道智。一识识。欲色二界一切遍使使。及修断使使。如眼识界。耳识界身识界亦如是

鼻识界。二界一入一阴摄。七智知。除比智及灭道智。一识识。欲界一切遍使使。及修断使使。如鼻识界。舌识界亦如是

意识界。二界一入一阴摄。九智知。除灭智。一识识。一切使使(十八法竟)

女根。一界一入一阴摄。六智知。除比智知他心智及灭道智。一识识。欲界一切遍使使。及修断使使。如女根。男根亦如是

命根。一界一入一阴摄。七智知。除知他心智及灭道智。一识识。三界一切遍使使。及修断使使。乐根。一界一入一阴摄。九智知。除灭智。一识识。色界一切使使。欲界一切遍使使。及修断使使。苦根。一界一入一阴摄。七智知。除比智及灭道智。一识识。欲界一切遍使使。及修断使使。喜根。一界一入一阴摄。九智知。除灭智。一识识。色界一切使使。除欲界无漏缘疑及彼相应无明。余欲界一切使使。忧根。一界一入一阴摄。七智知。除比智及灭道智。一识识。欲界一切使使。舍根。一界一入一阴摄。九智知。除灭智。一识识。一切使使。信根。一界一入一阴摄。九智知。除灭智。一识识。三界一切遍使使。及修断使使。如信根。精进根念根定根慧根亦如是

未知当知根。三界二入三阴摄。七智知。除苦集灭智。一识识。使所不使。如未知当知根。已知根无知根亦如是(二十二法竟)

欲界系见苦断使。一界一入一阴摄。七智知。除比智及灭道智。一识识。欲界系见苦断一切使使。及见集断一切遍使使。欲界系见集断使。一界一入一阴摄。七智知。除比智及灭道智。一识识。欲界系见集断一切使使。及见苦断一切遍使使。欲界系见灭断使。一界一入一阴摄。七智知。除比智及灭道智。一识识。除欲界系见灭断无漏缘不共无明。余欲界系见灭断一切使使。及一切遍使使。欲界系见道断使。一界一入一阴摄。七智知。除比智及灭道智。一识识。除欲界系见道断无漏缘不共无明。余欲界系见道断一切使使。及一切遍使使。欲界系修断使。一界一入一阴摄。七智知。除比智及灭道智。一识识。欲界系修断一切使使。及一切遍使使。如欲界系。色界系无色界系亦如是。色界差别者。除法智。无色界差别者。六智知。除法智知他心智灭道智。余如上说(九十八使竟)

众事分阿毗昙论卷第七众事分阿毗昙论卷第八

        尊者世友造

        宋天竺三藏求那跋陀罗共菩萨提耶舍译

    千问论品第七之一

戒净果通种断如意足念谛

戒者。谓优婆塞五戒。问云何五。答谓。优婆塞受尽形寿不杀生。是优婆塞学迹。尽形寿。不偷盗。不邪淫。不妄语。不饮酒。是优婆塞学迹。问此优婆塞五戒。几色几非色。几可见几不可见。几有对几无对。几有漏几无漏。几有为几无为。几有报几无报。几因缘生世所摄。几非因缘生非世所摄。几色摄几名摄。几内入摄几外入摄。几智知几非智知。几断知知几非断知知。几断几不断。几应修几不应修。几秽污几不秽污。几果几非果。几有果几非有果。几果亦有果。几非果亦非有果。几受几不受。几四大造几非四大造。几有上几无上。几是有几非是有。几因相应几因不相应

有六处善摄。谓善色。善受想行识及数灭。问为善处摄五戒为五戒摄善处。有五处不善摄。谓不善色。不善受想行识。问为不善处摄五戒。为五戒摄不善处

有七处无记摄。谓无记色无记受想行识及虚空非数灭。问为无记处摄五戒为五戒摄无记处

有三处漏摄。谓欲漏。有漏。无明漏。问为漏处摄五戒。为五戒摄漏处

有五处有漏摄。谓有漏色。有漏受想行识。问为有漏处摄五戒。为五戒摄有漏处

有六处无漏摄。谓无漏色。无漏受想行识及数灭。问为无漏处摄五戒。为五戒摄无漏处

问此五戒。几过去。几未来。几现在。几非过去非未来非现在。几善。几不善。几无记。几欲界系。几色界系。几无色界系。几不系。几学。几无学。几非学非无学。几见谛断。几修断。几不断。几心。几心法。几非心。几非心法。几心相应。几惟心。几心随转非受相应。几受相应非心随转。几心随转。亦受相应。几非心随转亦非受相应。几心随转非想行相应。几想行相应非心随转。几心随转亦想行相应。几非心随转。亦非想行相应几觉随转非观相应。几观相应非觉随转。几觉随转亦观相应。几非觉。随转亦非观相应。几见非见处。几见处非见。几见亦见处。几非见亦非见处。几身见因非身见。几身见非身见因。几身见因亦身见。几非身见因亦非身见。几业非业报。几业报非业。几业亦业报。几非业亦非业报。几业非业随转。几业随转非业。几业亦业随转。几非业亦非业随转。几造色色非可见色。几可见色非造色色。几造色色亦可见色。几非造色色亦非可见色。几造色色非有对色。几有对色非造色色。几造色色亦有对色。几非造色亦非有对色。几甚深难了。几难了甚深

几善非善因。几善因非善。几善亦善因。几非善亦非善因。几不善非不善因。几不善因非不善。几不善亦不善因。几非不善亦非不善因。几无记非无记因。几无记因非无记。几无记亦无记因。几非无记亦非无记因。几因缘缘非有因。几有因非因缘缘。几因缘缘亦有因。几非因缘缘亦非有因。几次第缘缘非次第。几次第非次第缘缘。几次第缘缘亦次第几非次第缘缘亦非次第。几缘缘缘非有缘。几有缘非缘缘缘。几缘缘缘亦有缘。几非缘缘缘亦非有缘。几增上缘缘非增上。几增上非增上缘缘。几增上亦增上缘缘。几非增上缘缘亦非增上。几流非随流。几随流非流。几流亦随流。几非流亦非随流。如是一切修多罗广问

问此优婆塞五戒。几色几非色者。今当答。谓一切是色。一不可见。四分别。谓四作可见无作不可见。彼一切作有对无作无对。一切是有漏。一切是有为。一切是有报。一切从因缘生世所摄。一切是色所摄。一切是外入所摄。一切是智知。一切是断知知。一切是断一切是应修。一切不秽污。一切是果亦有果。一切是不受。一切是四大造。一切是有上。一切是有。一切因不相应

善一处少分摄五戒。五戒亦摄善一处少分。不善处所不摄。无记处所不摄。漏处所不摄。有漏一处少分摄五戒。五戒亦摄有漏一处少分。无漏处所不摄。一切或过去或未来或现在。一切是善。一切是欲界系。一切是非学非无学。一切是修断。一切是非心非心法非心相应。一切是非心随转非受相应。一切是非心随转非想行相应。一切是非学随转非观相应。一切是见处非见。一切非身见因身见亦非彼因。一切是业非业报。一切是业非业随转。一是造色色非可见色。四分别。谓四若作是造色色可见色。若无作是造色色非可见色。一切若作是造色色有对色。若无作是造色色非有对色。一切是甚深难了难了甚深

一切是善亦善因。一切非不善亦非不善因。一切非无记亦非无记因。一切是因缘缘亦有因。一切非次第亦非次第缘缘。一切是缘缘缘非有缘。一切是增上缘缘及有增上。一切是随流非流

净者。谓四不坏净。问云何四。答谓佛不坏净法不坏净。僧不坏净。圣戒不坏净

问此四不坏净。几色几非色。答一是色。三非色。一切不可见。一切是无对。一切是无漏。一切是有为一切是无报。一切从因缘生世所摄。一是色所摄。三是名所摄。一切是外入所摄。一切是智知。一切非断知知。一切是不断。一切是应修。一切不秽污。一切是果及有果。一切是不受。一是四大造。三非四大造。一切是有上。一切是非有。一因不相应。三因相应。善二处少分摄四不坏净。四不坏净亦摄善二处少分不善处所不摄。无记处所不摄。漏处所不摄。有漏处所不摄。无漏一处。及一处少分。摄四不坏净。四不坏净亦摄无漏一处及一处少分。一切或过去或未来或现在。一切是善。一切是不系

问不坏净。几学几无学。几非学非无学。答一切应分别。佛不坏净。或学。或无学。云何学。谓学意思惟相应佛不坏净。云何无学。谓无学意思惟相应佛不坏净。如佛不坏净。法僧不坏净亦如是

圣戒不坏净。或学。或无学云何学。谓学身口业。云何无学。谓无学身口业。一切是不断。一非心非心法非心相应。三心法心相应。一心随转非受相应。三心随转亦受相应。一心随转非想行相应。三心随转亦想行相应。除其自性

问不坏净。几觉随转非观相应。答一切应分别佛不坏净。或有觉有观。或无觉有观。或无觉无观。云何有觉有观。谓有觉有观意思惟相应佛不坏净。云何无觉有观。谓无觉有观意思惟相应佛不坏净。云何无觉无观。谓无觉无观意思惟相应佛不坏净。如佛不坏净。法僧不坏净亦如是

圣戒不坏净。或觉随转非观相应。或非觉随转亦非观相应。云何觉随转非观相应。谓觉随转身口业。余非觉随转亦非观相应。一切非见亦非见处。一切非身见因身见亦非彼因。一是业非业报。三非业亦非业报。一是业亦业随转。三业随转非业。一是造色色非可见色。三非造色色亦非可见色。一是造色色非有对色。三非造色色亦非有对色。一切是甚深难了难了甚深

一切是善亦善因。一切非不善亦非不善因。一切非无记亦非无记因。一切是因缘缘亦有因

问不坏净。几次第非次第缘缘。答一非次第亦非次第缘缘。三分别。佛不坏净。或次第非次第缘缘。作三句。次第非次第缘缘者。谓未来现前必起佛不坏净。次第亦次第缘缘者。谓过去现在佛不坏净非次第亦非次第缘缘者。谓除未来现前必起佛不坏净。若余未来佛不坏净。如佛不坏净。法僧不坏净亦如是

一是缘缘缘非有缘。二是缘缘缘亦有缘。一切是增上缘缘。及有增上。一切非流亦非随流

果者。谓四沙门果。问云何四。答谓须陀洹果。乃至阿罗汉果

问此四沙门果。几色。几非色。答谓沙门果所摄身口业是色。余非色。一切不可见。一切是无对。一切是无漏

问沙门果。几有为。几无为。答一切应分别。谓须陀洹果。或有为。或无为。云何有为。谓须陀洹果有为五阴。云何无为。谓须陀洹果所摄数灭。如须陀洹果。乃至阿罗汉果亦如是

一切是无报沙门果。若有为从因缘生世所摄。若无为非因缘生非世所摄。沙门果所摄身口业。是色所摄。余是名所摄沙门果所摄心意识。是内入所摄。余是外入所摄。一切是智知。一切非断知知及不断。若有为是应修。若无为是不应修。一切不秽污。若有为是果及有果。若无为是果非有果。一切是不受。沙门果所摄身口业。是四大造。余非四大造。若有为是有上。若无为是无上。一切是非有。沙门果所摄身口业。及心不相应行。及数灭。因不相应。余因相应

善六处少分摄四沙门果。四沙门果亦摄善六处少分。不善处所不摄。无记处所不摄。漏处所不摄。有漏处所不摄。无漏六处少分摄四沙门果。四沙门果亦摄无漏六处少分。若有为或过去或未来或现在。若无为非过去非未来非现在。一切是善。一切是不系

问沙门果。几学。几无学。几非学非无学。答一切应分别。谓须陀洹果。或学。或非学非无学。云何学。谓须陀洹有为果。云何非学非无学。谓须陀洹无为果。如须陀洹果。斯陀含果阿那含果亦如是

阿罗汉果。或无学。或非学非无学。云何无学。谓阿罗汉有为果。云何非学非无学。谓阿罗汉无为果。一切是不断。沙门果所摄身口业。心不相应行。及数灭。非心非心法非心相应。沙门果所摄受阴想阴。彼相应行阴。是心法心相应。心意识即心也

问须陀洹果。几心随转非受相应。答作四句。心随转非受相应者。谓心随转身口业。心随转心不相应行及受。受相应非心随转者。谓心意识。心随转亦受相应者。谓想阴彼相应行阴。非心随转亦非受相应者。谓除心随转心不相应行。若余心不相应行。及数灭。如须陀洹果。乃至阿罗汉果亦如是。如受想行亦如是。除其自性

问须陀洹果。几觉随转非观相应。答作四句。觉随转非观相应者。谓觉随转身口业。觉随转心不相应行。及觉相应观。观相应非觉随转者。谓觉。觉随转亦观相应者。谓觉观相应心心法。非觉随转亦非观相应者。谓除觉随转心不相应行。若余心不相应行。及数灭。如须陀洹果。斯陀含果亦如是。阿那含果。或觉随转非观相应作四句。觉随转非观相应者。谓觉随转身口业。觉随转心不相应行。及觉相应观。观相应非觉随转者。谓觉。若觉不相应观相应心心法。觉随转亦观相应者。谓觉观相应心心法。非觉随转亦非观相应者。谓除觉随转身口业。若余身口业。除觉随转心不相应行。若余心不相应行。及觉不相应观。及非觉观相应心心法。及数灭。如阿那含果。阿罗汉果亦如是

须陀洹果所摄慧。是见非见处。余非见亦非见处。如须陀洹果。斯陀含果阿那含果亦如是

阿罗汉果。所摄尽智。无生智所不摄无漏慧。是见非见处。余非见亦非见处。一切非身见因身见亦非彼因。沙门果所摄身口业。及思。是业非业报。余非业亦非业报

问须陀洹果。几业非业随转。答作四句。业非业随转者。谓思业。业随转非业者。谓受阴想阴识阴。若思所不摄业随转行阴。业亦业随转者。谓业随转身口业。非业亦非业随转者。谓除业随转心不相应行。若余心不相应行。及数灭。如须陀洹果。乃至阿罗汉果亦如是。沙门果所摄身口业。是造色色非可见色。余非造色色亦非可见色。沙门果所摄身口业。是造色色非有对色。余非造色色亦非有对色。一切是甚深难了难了甚深

沙门果。若有为是善亦善因。若无为是善非善因。一切非不善亦非不善因。一切非无记亦非无记因。沙门果。若有为是因缘缘及有因。若无为非因缘缘及非因

问沙门果。几次第非次第缘缘。答一切应分别。沙门果。若有为或次第非次第缘缘。作三句。次第非次第缘缘者。谓未来现前必起心心法。次第亦次第缘缘者。谓过去现在心心法。非次第亦非次第缘缘者。谓除未来现前必起心心法。若余未来心心法。及身口业心不相应行。及数灭。沙门果。若有为所摄身口业心不相应行。及数灭。是缘缘缘非有缘。余者是缘缘缘亦有缘。沙门果。若有为是增上缘缘。及有增上。若无为是增上缘缘非有增上。一切非流亦非随流

通者。谓四通。问云何四。答谓。有苦迟通。有苦速通。有乐迟通。有乐速通。云何苦迟通。谓未来禅。中间禅。及三无色。若钝根道。云何苦速通。谓未来禅。中间禅。及三无色。若利根道。云何乐迟通。谓根本四禅。若钝根道。云何乐速通。谓根本四禅。若利根道

问此四通。几是色。几非色。答通所摄身口业是色。余非色。一切不可见。一切是无对。一切是无漏。一切是有为。一切是无报。一切从因缘生世所摄。通所摄身口业。是色所摄余是名所摄。通所摄心意识。是内入所摄。余是外入所摄。一切是智知。一切非断知知。及不断。一切是应修。一切不秽污。一切是果。及有果。一切是不受。通所摄身口业。是四大造。余非四大造。一切是有上。一切是非有。通所摄身口业。及心不相应行。因不相应。余因相应。善五处少分摄四通。四通亦摄善五处少分。不善处所不摄。无记处所不摄。漏处所不摄。有漏处所不摄。无漏五处少分摄四通。四通亦摄无漏五处少分。一切或过去或未来或现在。一切是善。一切是不系

问四通。几学。几无学。答一切应分别。通或学。或无学。云何学。谓通所摄学五阴。云何无学。谓通所摄无学五阴。一切是不断。通所摄身口业。心不相应行。非心非心法非心相应。通所摄受阴想阴。彼相应行阴。是心法心相应心意识即心也

问四通。几心随转非受相应。答作四句。心随转非受相应者。谓心随转身口业。心随转心不相应行及受。受相应非心随转者。谓心意识。心随转亦受相应者。谓想阴。彼相应行阴。非心随转亦非受相应者。谓除心随转心不相应行。若余心不相应行。如受。想行亦如是。除其自性

问苦迟通。几觉随转非观相应。答作四句。觉随转非观相应者。谓觉随转身口业。觉随转心不相应行。及觉相应观。观相应非觉随转者。谓觉。若觉不相应观相应心心法。觉随转亦观相应者。谓觉观相应心心法。非觉随转亦非观相应者。谓除觉随转身口业。若余身口业。除觉随转心不相应行。若余心不相应行。及觉不相应观。及非觉观相应心心法。如苦迟通。苦速通亦如是

乐迟通。或觉随转非观相应。作四句。觉随转非观相应者。谓觉随转身口业。觉随转心不相应行。及觉相应观。观相应非觉随转者。谓觉。若觉不相应观相应心心法。觉随转亦观相应者。谓觉观相应心心法。非觉随转亦非观相应者。谓除觉随转身口业。若余身口业。除觉随转心不相应行。若余心不相应行。及觉不相应观。及非觉观相应心心法。如乐迟通。乐速通亦如是

通所摄尽智无生智。所不摄无漏慧。是见非见处。余非见亦非见处。一切非身见因。身见亦非彼因。通所摄身口业及思。此是业非业报。余非业亦非业报

问四通。几业非业随转。答作四句。业非业随转者。谓思业。业随转非业者。谓受阴想阴识阴。若思所不摄业随转行阴。业亦业随转者。谓业随转身口业。非业亦非业随转者。谓除业随转心不相应行。若余心不相应行

通所摄身口业。是造色色非可见色。余非造色色亦非可见色。通所摄身口业。是造色色非有对色。余非造色色亦非有对色。一切是甚深难了难了甚深

一切是善亦善因。一切非不善亦非不善因。一切非无记亦非无记因。一切是因缘缘亦有因

问四通。几次第非次第缘缘。答一切应分别。通或次第非次第缘缘。作三句。次第非次第缘缘者。谓未来现前必起心心法。次第亦次第缘缘者。谓过去现在心心法。非次第亦非次第缘缘者。谓除未来现前必起心心法。若余未来心心法。及身口业心不相应行。通所摄身口业心不相应行。是缘缘缘非有缘。余者是缘缘缘亦有缘。一切是增上缘缘及有增上。一切非流亦非随流

种者。谓四圣种。问云何四。答一谓随乞得衣知足圣种。二谓随乞得食知足圣种。三谓随得眠卧具等知足圣种。四谓乐闲静乐修圣种

问此四圣种。几色。几非色。答圣种所摄身口业是色。余非色。一切是不可见。一切是无对

问圣种。几有漏。几无漏。答一切应分别。圣种。或有漏或无漏。云何有漏。谓圣种所摄有漏五阴。云何无漏。谓圣种所摄无漏五阴。一切是有为。若有漏。彼有报。若无漏。彼无报一切从因缘生世所摄。圣种所摄身口业。是色所摄。余是名所摄。圣种所摄心意识。是内入所摄。余是外入所摄。一切是智知。若有漏断知知及断。若无漏。非断知知及不断。一切是应修。一切不秽污。一切是果及有果一切是不受。圣种所摄身口业。是四大造。余非四大造。一切是有上。圣种。若有漏。彼是有。若无漏。彼非有。圣种所摄身口业。及心不相应行。因不相应。余因相应善五处少分摄四圣种。四圣种亦摄善五处少分。不善处所不摄。无记处所不摄。漏处所不摄。或有漏处摄非圣种。作四句。有漏处摄非圣种者。谓圣种所不摄有漏五阴。圣种摄非有漏处者。谓圣种所摄无漏五阴。有漏处摄亦圣种者。谓圣种所摄有漏五阴。非有漏处摄亦非圣种者谓虚空。及数灭非数灭。或无漏处摄非圣种。作四句。无漏处摄非圣种者。谓虚空。及数灭非数灭。圣种摄非无漏处者。谓圣种所摄有漏五阴。无漏处摄亦圣种者。谓圣种所摄无漏五阴。非无漏处摄亦非圣种者。谓圣种所不摄有漏五阴。一切或过去。或未来。或现在。一切是善

圣种或欲界系。或色界系。或无色界系或不系。云何欲界系。谓圣种所摄欲界系五阴。云何色界系。谓圣种所摄色界系五阴。云何无色界系。谓圣种所摄无色界系四阴。云何不系。谓无漏四圣种

问圣种。几学。几无学。几非学非无学。答一切应分别。圣种。或学。或无学。或非学非无学。云何学。谓圣种所摄学五阴。云何无学。谓圣种所摄无学五阴。云何非学非无学。谓圣种所摄有漏五阴。圣种。若有漏彼修断。若无漏。彼不断。圣种所摄身口业。及心不相应行。非心非心法非心相应。圣种所摄受阴想阴。彼相应行阴。是心法心相应心意识即心也

问圣种几心随转非受相应。答作四句。心随转非受相应者。谓心随转身口业。心随转心不相应行及受。受相应非心随转者。谓心意识。心随转亦受相应者。谓想阴彼相应行阴。非心随转亦非受相应者。谓除心随转身口业若余身口业。除心随转心不相应行。若余心不相应行。如受想行亦如是除其自性

问圣种。几觉随转非观相应。答作四句。觉随转非观相应者谓觉随转身口业。觉随转心不相应行。及觉相应观。观相应非觉随转者。谓觉。若觉不相应观相应心心法。觉随转亦观相应者。谓觉观相应心心法。非觉随转亦非观相应者。谓除觉随转身口业。若余身口业。除觉随转心不相应行。若余心不相应行。及觉不相应观。及非觉观相应心心法

问圣种。几见非见处。答作四句。见非见处者。谓圣种。所摄尽智无生智。所不摄无漏慧。见处非见者。谓见所不摄有漏四圣种。见亦见处者。谓世俗正见。非见亦非见处者。谓见所不摄无漏四圣种

一切非身见因。身见亦非彼因。圣种所摄身口业及思。此是业非业报。余非业亦非业报

问圣种。几业非业随转。答作四句。业非业随转者。谓除业随转身口业。若余身口业。及思业。业随转非业者。谓受阴想阴识阴。若思所不摄业随转行阴。业亦业随转者。谓业随转身口业。非业亦非业随转者。谓除业及业随转心不相应行。若余心不相应行。圣种所摄身口业。是造色色非可见色。余非造色色亦非可见色

圣种所摄身口业。是造色色非有对色。余非造色色亦非有对色。一切是甚深难了难了甚深

一切是善亦善因。一切非不善亦非不善因。一切非无记亦非无记因。一切是因缘缘亦有因

问圣种。几次第非次第缘缘。答一切应分别。圣种。或次第非次第缘缘。作三句。次第非次第缘缘者。谓未来现前必起心心法。次第亦次第缘缘者。谓过去现在心心法。非次第亦非次第缘缘者。谓除未来现前必起心心法。若余未来心心法及身口业心不相应行

圣种所摄身口业。心不相应行。是缘缘缘非有缘。余者是缘缘缘亦有缘。一切是增上缘缘。及有增上。圣种。若有漏。彼随流非流。若无漏非流亦非随流

如四圣种。四正勤四如意足善聚修多罗亦如是

念者。谓四念处。问云何四。答谓身念处。乃至法念处。云何身念处。谓缘身慧。云何受念处。谓缘受慧。云何心念处。谓缘心慧。云何法念处。谓缘法慧。问此四念处。几色。几非色。答一切非色一切不可见。一切是无对

问念处。几有漏。几无漏。答一切应分别。缘身慧或有漏。或无漏。云何有漏。谓有漏意思惟相应缘身慧。云何无漏。谓无漏意思惟相应缘身慧。如缘身慧。乃至缘法慧亦如是

一切是有为念处。若有漏。彼有报若无漏。彼无报。一切从因缘生世所摄。一切是名所摄。一切是外入所摄。一切是智知。若有漏。断知知及断。若无漏。非断知知及不断。一切是应修。一切不秽污。一切是果及有果。一切是不受。一切非四大造。一切是有上。念处。若有漏。是有。若无漏。非是有。一切因相应

善一处少分摄四念处。四念处亦摄善一处少分。不善处所不摄。无记处所不摄。漏处所不摄

或有漏处摄非念处。作四句。有漏处摄非念处者。谓有漏色阴。有漏受阴想阴识阴。念处所不摄。有漏行缘。念处摄非有漏处者。谓无漏四念处。有漏处摄亦念处者。谓有漏四念处。非有漏处摄亦非念处者。谓无漏色阴受阴想阴识阴。念处所不摄无漏行阴。及无为。或无漏处摄非念处。作四句。无漏处摄非念处者。谓无漏色阴受阴想阴识阴。念处所不摄无漏行阴。及无为。念处摄非无漏者。谓有漏四念处。无漏处摄亦念处者。谓无漏四念处。非无漏处摄亦非念处者。谓有漏色阴受阴想阴识阴。念处所不摄有漏行阴。一切或过去。或未来。或现在。一切是善

问念处。几界系。答一切应分别。缘身慧。或欲界系。或色界系。或无色界系。或不系。云何欲界系。谓欲界系意思惟相应缘身慧。云何色界系。谓色界系。意思惟相应缘身慧。云何无色界系。谓无色界系意思惟相应缘身慧。云何无系。谓无漏意思惟相应缘身慧。如缘身慧。乃至缘法慧亦如是

问念处。几学。几无学。几非学非无学。答一切应分别缘身慧。或学。或无学。或非学非无学。云何学。谓学意思惟相应缘身慧。云何无学。谓无学意思惟相应缘身慧。云何非学非无学谓有漏意思惟相应缘身慧。如缘身慧乃至缘法慧亦如是

念处。若有漏。彼修断。若无漏。彼不断。一切是心法心相应。一切心随转受相应。一切心随转想行相应。除其自性。问念处。几有觉有观。答一切应分别。缘身慧。或有觉有观。或无觉有观。或无觉无观。云何有觉有观。谓有觉有观意思惟相应缘身慧。云何无觉有观。谓无觉有观意思惟相应缘身慧。云何无觉无观。谓无觉无观意思惟相应缘身慧。如缘身慧。乃至缘法慧亦如是

问念处。几见非见处。答一切应分别。缘身慧。或见非见处。作四句。见非见处者。谓尽智无生智所不摄无漏缘身慧。见处非见者。谓见所不摄有漏缘身慧。及五识身相应缘身慧。见亦见处者。谓世俗正见。非见亦非见处者。谓见所不摄无漏缘身慧

缘受慧。或见非见处。作四句。见非见处者。谓尽智无生智所不摄无漏缘受慧。见处非见者。谓见所不摄有漏缘受慧。见亦见处者。谓世俗正见。非见亦非见处者。谓见所不摄无漏缘受慧。如无漏缘受慧。缘心慧缘法慧亦如是

一切非身见因身见亦非彼因。一切非业亦非业报。一切是业随转非业。一切非造色色非可见色。一切非造色色非有对色。一切是甚深难了难了甚深

一切是善亦善因一切非不善亦非不善因。一切非无记亦非无记因。一切是因缘缘亦有因

问念处。几次第非次第缘缘。答一切应分别。缘身慧或次第非次第缘缘。作三句。次第非次第缘缘者。谓未来现前必起缘身慧。次第亦次第缘缘者。谓过去现在缘身慧。非次第亦非次第缘缘者。谓除未来现前必起缘身慧。若余未来缘身慧。如缘身慧。乃至缘法慧亦如是

一切是缘缘缘亦有缘。一切是增上缘缘及有增上。若有漏。彼随流非流。余非流亦非随流

众事分阿毗昙论卷第八众事分阿毗昙论卷第九

        尊者世友造

        宋天竺三藏求那跋陀罗共菩提耶舍译

    千问论品第七之二

四念处。问云何四。答谓身念处。受念处。心念处。法念处。问此四念处。几色。几非色。答一是色。三非色。三不可见。一分别身念处。或可见。或不可见。云何可见。谓一入。云何不可见。谓九入。及一入少分。三无对。一分别。身念处。或有对。或无对。云何有对。谓十入。云何无对。谓一入少分。问四念处。几有漏。几无漏。答一切应分别。身念处。或有漏。或无漏。云何有漏。谓十入。及一入少分。云何无漏。谓一入少分。受念处。或有漏。或无漏。云何有漏。谓有漏意思惟相应受念处。云何无漏。谓无漏意思惟相应受念处。如受念处。心念处亦如是

法念处。或有漏。或无漏。云何有漏。谓有漏想阴行阴。云何无漏。谓无漏想阴行阴。及无为。三有为。一分别。法念处。或有为。或无为。云何有为。谓想阴行阴。云何无为。谓虚空数灭非数灭。问四念处。几有报几无报。答一切应分别身念处。或有报。或无报。云何有报。谓不善。及善有漏身念处。云何无报。谓无记无漏身念处。如身念处。受心法念处亦如是

三从因缘生世所摄。一分别。法念处。若有为。从因缘生世所摄。若无为。非因缘生非世所摄

一是色所摄。三是名所摄。一是内入所摄。二是外入所摄。一分别。身念处。或内入所摄。或外入所摄。云何内入所摄。谓五内入。云何外入所摄。谓五外入。及一外入少分。一切是智知。若有漏。彼断知知。及断。若无漏彼非断知知。及不断

问四念处几应修。几不应修。答一切应分别。身念处。或应修。或不应修。云何应修。谓善身念处。云何不应修。谓不善无记身念处。如身念处。受心念处亦如是。法念处。或应修。或不应修。云何应修谓善有为法念处。云何不应修。谓不善无记法念处。及虚空数灭非数灭

问四念处。几秽污。几不秽污。答一切应分别。身念处。或秽污。或不秽污。云何秽污。谓隐没。云何不秽污。谓不隐没。如身念处。受心法念处亦如是

三是果及有果。一分别。法念处。或果非有果。作三句。果非有果者。谓数灭。果亦有果者。谓有为法念处。非果亦非有果者。谓虚空及非数灭

三不受一分别。身念处。或受。或不受。云何受。谓内入自性受。云何不受。谓非自性受

三非四大造。一分别。身念处。或四大造。或非四大造。云何四大造。谓九入。及二入少分。云何非四大造。谓一入少分

三有上。一分别法念处。或有上。或无上。云何有上。谓想阴行阴虚空非数灭。云何无上。谓数灭。若有漏。彼是有。若无漏。彼非有。一因不相应。二因相应。一分别。法念处。若心法因相应。若非心法因不相应

善处少分摄四念处少分。四念处少分亦摄善处少分。不善处少分摄四念处少分。四念处少分亦摄不善处少分。无记处少分摄四念处少分。四念处少分亦摄无记处少分。漏处少分摄一念处少分。一念处少分亦摄漏处少分。有漏处少分摄四念处少分。四念处少分亦摄有漏处少分。无漏处少分摄四念处少分。四念处少分亦摄无漏处少分。三或过去或未来或现在。一分别。法念处。若有为或过去。或未来。或现在若无为。非过去。非未来。非现在

问四念处。几善。几不善。几无记。答一切应分别。身念处。或善。或不善。或无记。云何善。谓三入少分。云何不善。谓三入少分。云何无记谓八入。及三入少分

受念处。或善。或不善。或无记。云何善。谓善意思惟相应受念处。云何不善。谓不善意思惟相应受念处。云何无记。谓无记意思惟相应受念处。如受念处。心念处亦如是

法念处。或善。或不善。或无记。云何善。谓善想阴行阴。及数灭。云何不善。谓不善想阴行阴。云何无记。谓无记想阴行阴。虚空非数灭

问四念处。几界系。答一切应分别。身念处。或欲界系。或色界系。或不系。云何欲界系。谓二入及九入少分。云何色界系。谓九入少分。云何不系。谓一入少分

受念处。或欲界系。或色界系。或无色界系。或不系。云何欲界系。谓欲界系意思惟相应受念处。云何色界系。谓色界系意思惟相应受念处。云何无色界系。谓无色界系意思惟相应受念处。云何不系。谓无漏意思惟相应受念处。如受念处。心念处亦如是

法念处。或欲界系。或色界系。或无色界系。或不系。云何欲界系。谓欲界系想阴行阴。云何色界系。谓色界系想阴行阴。云何无色界系。谓无色界系想阴行阴。云何不系。谓无漏想阴行阴。及无为

问四念处。几学。几无学。几非学非无学。答一切应分别。身念处。或学。或无学。或非学非无学。云何学。谓一入处少分。云何无学。谓一入处少分。云何非学非无学。谓十入。及一入少分

受念处。或学。或无学。或非学非无学。云何学。谓学意思惟相应受念处。云何无学。谓无学意思惟相应受念处。云何非学非无学。谓有漏意思惟相应受念处。如受念处。心念处亦如是。法念处。或学。或无学。或非学非无学。云何学。谓学想阴行阴。云何无学。谓无学想阴行阴。云何非学非无学。谓有漏想阴行阴。及无为

问四念处。几见断。几修断。几不断答一切应分别。身念处。或修断。或不断。云何修断。谓十入。及一入少分。云何不断。谓一入少分

受念处。或见断。或修断或不断。云何见断。谓受念处随信行随法行人无间等忍断。彼云何断。谓见断八十八使相应受念处。云何修断。谓受念处学见迹修断。彼云何断。谓修断十使相应受念处。及不秽污有漏受念处。云何不断。谓无漏受念处如受念处。心念处亦如是

法念处。或见断。或修断。或不断。云何见断。谓法念处随信行随法行人无间等忍断。彼云何断。谓见断八十八使彼相应法念处。彼所起心不相应行。云何修断。谓法念处学见迹修断。彼云何断。谓修断十使。彼相应法念处。彼所起身口业。彼所起心不相应行。及不秽污有漏法念处。云何不断。谓无漏法念处。一非心非心法非心相应。一心法心相应。一惟心。一分别法念处。若有缘彼心法。及心相应。若无缘。彼非心非心法非心相应

一心随转非受相应。一受相应非心随转二。分别身念处。或心随转非受相应。或非心随转亦非受相应。心随转非受相应者。谓心随转身口业。余非心随转亦非受相应

法念处。或心随转非受相应。作三句。心随转非受相应者。谓心随转心不相应行。心随转亦受相应者。谓想阴。彼相应行阴非心随转亦非受相应者。谓除心随转心不相应行。若余心不相应行。及无为。如受。想行亦如是。除其自性

问四念处。几觉随转非观相应。答一切应分别。身念处。或觉随转非观相应。或非觉随转亦非观相应。觉随转非观相应者。谓觉随转身口业。余非觉随转亦非观相应

受念处。或有觉有观。或无觉有观。或无觉无观。云何有觉有观。谓有觉有观意思惟相应受念处。云何无觉有观。谓无觉有观意思惟相应受念处。云何无觉无观。谓无觉无观意思惟相应受念处。如受念处。心念处亦如是。法念处。或觉随转非观相应。作四句。觉随转非观相应者。谓觉随转心不相应行。及觉相应观。观相应非觉随转者。谓觉。若觉不相应观相应心法法念处。觉随转亦观相应者。谓觉观相应心法法念处。非觉随转亦非观相应者。谓除觉随转心不相应行。余心不相应行。及觉不相应观。及非觉观相应心法法念处。及无为

问四念处。几见非见处。答一切应分别。身念处。或见处非见。作三句。见处非见者。谓九入。及一入少分。见亦见处者。谓一入。非见亦非见处者。谓一入少分

受念处。若有漏。彼见处非见。若无漏。非见亦非见处。如受念处。心念处亦如是

法念处。或见非见处。作四句。见非见处者。谓尽智无生智所不摄无漏慧。见处非见者。谓见所不摄有漏法念处。见亦见处者。谓五见世俗正见。非见亦非见处者。谓见所不摄无漏法念处

问四念处。几身见是彼因彼非身见因。答一切应分别。身念处。若秽污。身见是彼因彼非身见因。若不秽污。身见非彼因彼亦非身见因。受念处。或身见是彼因彼非身见因。或身见是彼因彼亦身见因。或身见非彼因彼亦非身见因。身见是彼因彼非身见因者。谓除过去现在见苦断使彼相应受念处。除过去现在见集断一切遍使彼相应受念处除未来身见相应受念处除身见生住异灭及彼相应法生住异灭。若诸余秽污受念处。身见是彼因彼亦身见因者。谓前所除尔所法者。是身见非彼因彼亦非身见因者。谓不秽污受念处。如受念处。心念处亦如是

法念处。或身见是彼因彼非身见因。作三句。身见是彼因彼非身见因者。谓除过去现在见苦断使彼相应法念处。除过去现在见集断一切遍使彼相应法念处。除未来身见相应法念处。除身见生住异灭及彼相应法生住异灭。若诸余秽污法念处。身见是彼因彼亦身见因者谓前所除尔所法者。是身见非彼因彼亦非身见因者。谓不秽污法念处

问四念处。几业非业报答一切应分别。身念处。或业非业报。作三句。业非业报者。谓身口业。业报非业者。谓报生身念处。非业亦非业报者。谓除业及业报身念处。余身念处

受念处。或业报非业。或非业亦非业报。业报非业者。谓报生受念处。余非业亦非业报。如受念处。心念处亦如是。法念处。或业非业报。作四句业。非业报者。谓报所不摄思业。业报非业者。谓若思所不摄报生法念处业亦业报者。谓报生思业。非业亦非业报者。谓除业及业报法念处。若余法念处。二业随转非业。二分别。身念处。或业非业随转。作三句。业非业随转者。谓除业随转身口业。若余身口业。业亦业随转者。谓业随转身口业。非业亦非业随转者。谓除非业随转身口业及业随转身念处。若余身念处

法念处。或业非业随转。作三句。业非业随转者。谓思业。业随转非业者。谓想阴。若思所不摄业随转行阴。非业亦非业随转者。谓除业及业随转法念处。若余法念处

三非造色色非可见色。一分别。身念处。或造色色非可见色。作三句。造色色非可见色者。谓八入。及二入少分。造色色亦可见色者。谓一入。非造色色亦非可见色者。谓一入少分。三非造色色非有对色。一分别。身念处。或造色色非有对色。作三句。造色色非有对色者。谓一入少分。有对色非造色色者。谓一入少分。造色色亦有对色者。谓九入。及一入少分。一切是甚深难了难了甚深

问四念处。几善因非善。答一切应分别。身念处。或善因非善。作三句。善因非善者。谓善报生身念处。善亦善因者。谓善身念处。非善亦非善因者。谓除善报生身念处。若余无记。及不善身念处。如身念处。受心念处亦如是。法念处。或善非善因。作四句。善非善因者。谓数灭。善因非善者。谓善报生法念处。善亦善因者。谓善有为法念处。非善亦非善因者。谓除善报生法念处。若余无记及不善法念处

问四念处。几不善不善因。答一切应分别。身念处。或不善因非不善。作三句。不善因非不善者。谓不善报生身念处。不善亦不善因者。谓不善身念处。非不善亦非不善因者。谓除不善报生身念处。若余无记及善身念处。受念处。或不善因非不善。作三句。不善因非不善者。谓不善报生受念处。及欲界身见边见相应受念处。不善亦不善因者。谓不善受念处。非不善亦非不善因者。谓除不善报生受念处及除欲界身见边见相应受念处。若余无记。及善受念处。如受念处。心念处亦如是

法念处。或不善因非不善。作三句。不善因非不善者。谓不善报生法念处。及欲界身见边见相应法念处。不善亦不善因者。谓不善法念处。非不善亦非不善因者。谓除不善报生法念处。及除欲界身见边见相应法念处。若余无记及善法念处

问四念处。几无记非无记因。答一切应分别。身念处。或无记因非无记。作三句。无记因非无记者。谓不善身念处。无记亦无记因者。谓无记身念处。非无记亦非无记因者。谓善身念处。如身念处。受心念处亦如是

法念处。或无记非无记因。作四句。无记非无记因者。谓虚空非数灭。无记因非无记者。谓不善法念处。无记亦无记因者。谓无记有为法念处。非无记亦非无记因者。谓善法念处。三是因缘缘。及有因。一分别。法念处。若有为。彼因缘缘。及有因。若无为。非因缘缘。及非有因。一非次第亦非次第缘缘。三分别

受念处。或次第非次第缘缘。作三句。次第非次第缘缘者。谓未来现前必起受念处。过去及现在阿罗汉最后命终受念处。次第亦次第缘缘者。谓除过去现在阿罗汉最后命终受念处。若余过去及现在受念处。非次第亦非次第缘缘者。谓除未来现前必起受念处。若余未来受念处。如受念处。心念处亦如是。法念处或次第非次第缘缘。作三句。次第非次第缘缘者。谓未来现前必起心法法念处。过去及现在阿罗汉最后命终心法法念处。及无想正受。灭尽正受。已起当起。次第亦次第缘缘者。谓除过去现在阿罗汉最后命终心法法念处。若余过去及现在心法法念处。非次第亦非次第缘缘者。谓除未来现前必起心法法念处。若余未来心法法念处。除次第心不相应行。若余心不相应行。及无为一是缘缘缘非有缘。二是缘缘缘及有缘法念处。若心法缘缘缘及有缘。若非心法缘缘缘非有缘

三是增上缘缘及有增上。一分别。法念处。若有为。彼是增上缘缘及有增上。若无为。是增上缘缘非有增上

问四念处。几流。几随流。答一切应分别。身念处。若有漏。彼随流非流。若无漏。彼非流亦非随流。如身念处。受心念处亦如是

法念处。或随流非流。作三句。随流非流者。谓流所不摄有漏法念处。流亦随流者。谓四流。非流亦非随流者。谓无漏法念处

谛者。谓四圣谛。问云何四。答谓苦圣谛。集圣谛。灭圣谛。道圣谛

问此四圣谛。几色。几非色。答一非色。三分别苦谛。或色。或非色。云何色。谓十入。及一入少分。云何非色。谓一入。及一入少分。如苦谛。集谛亦如是。道谛所摄身口业是色。余非色。二不可见。二分别苦谛。或可见。或不可见。云何可见。谓一入。云何不可见。谓十一入。如苦谛。集谛亦如是

二无对。二分别。苦谛。或有对。或无对。云何有。对谓十入。云何无对。谓二入。如苦谛。集谛亦如是

二有漏。二无漏。三有为。一无为。二无报。二分别苦谛。或有报。或无报。云何有报。谓善不善苦谛。云何无报。谓无记苦谛。如苦谛。集谛亦如是

三从因缘生世所摄。一非因缘生非世所摄。一名所摄。三分别苦谛。或色所摄。或名所摄。云何色所摄。谓十入。及一入少分。云何名所摄。谓一入。及一入少分。如苦谛。集谛亦如是。道谛所摄身口业。是色所摄。余是名所摄。一是外入所摄。三分别苦谛。或内入所摄。或外入所摄。云何内入所摄。谓六内入。云何外入所摄。谓六外入。如苦谛。集谛亦如是

道谛所摄心意识。此内入所摄。余外入所摄。一切是智知。二断知知及断。二非断知知及不断

一应修。一不应修。二分别苦谛。或应修。或不应修。云何应修。谓善苦谛。云何不应修。谓不善无记苦谛。如苦谛。集谛亦如是

二不秽污。二分别苦谛。或秽污或不秽污。云何秽污。谓隐没。云何不秽污。谓不隐没。如苦谛。集谛亦如是。一果非有果。三果及有果。二不受。二分别苦谛。或受。或不受。云何受。谓自性受。云何不受。谓非自性受。如苦谛。集谛亦如是

一非四大造。三分别苦谛。或四大造。或非四大造。云何四大造。谓九入。及二入少分。云何非四大造。谓一入。及二入少分。如苦谛。集谛亦如是

道谛所摄身口业四大造。余非四大造。三有上。一无上。二是有。二非有。一因不相应。三分别苦谛所摄色心不相应行。因不相应。余因相应。如苦谛。集谛亦如是

道谛所摄身口业。心不相应行。因不相应。余因相应

善处摄二谛及二谛少分。二谛及二谛少分亦摄善处不善处摄二谛少分。二谛少分亦摄不善处

或无记处摄非谛。作四句。无记处摄非谛者。谓虚空非数灭。谛摄非无记处者。谓二谛。及二谛少分。无记处摄亦谛者。谓二谛少分。非无记处摄亦非谛者。是事不可得也

漏处摄二谛少分。二谛少分亦摄漏处。有漏处摄二谛。二谛亦摄有漏处。或无漏处。摄非谛。作四句。无漏处摄非谛者。谓虚空及非数灭。谛摄非无漏处者。谓二谛。无漏处摄亦谛者。谓二谛。非无漏处摄亦非谛者。是事不可得也

三或过去。或未来。或现在。一非过去。非未来。非现在

二善。二分别苦谛。或善。或不善。或无记。云何善。谓苦谛所摄善五阴。云何不善。谓苦谛所摄。不善五阴。云何无记。谓苦谛所摄无记五阴。如苦谛。集谛亦如是

二不系。二分别苦谛。或欲界系。或色界系。或无色界系。云何欲界系。谓苦谛所摄欲界系五阴。云何色界系。谓苦谛所摄色界系五阴。云何无色界系。谓苦谛所摄无色界系四阴。如苦谛。集谛亦如是

三非学非无学。一分别。道谛。或学。或无学。云何学。谓学五阴。云何无学。谓无学五阴

二不断。二分别苦谛。或见断。或修断。云何见断。若苦谛随信行随法行人无间忍等断。彼云何断。谓见断八十八使彼相应苦谛。彼所起心不相应行。云何修断。若苦谛学见迹修断。彼云何断。谓修断十使彼相应苦谛。彼所起身口业。彼所起心不相应行。及不秽污苦谛。如苦谛。集谛亦如是

一非心非心法非心相应。三分别苦谛所摄色心不相应行。非心非心法非心相应受阴想阴。彼相应行阴。心法心相应心意识。即心也。如苦谛。集谛亦如是

道谛所摄身口业。心不相应行。非心非心法非心相应受阴想阴。彼相应行阴。心法心相应心意识。即心也

一非心随转非受相应。三分别苦谛。或心随转非受相应。作四句。心随转非受相应者。谓心随转身口业。心随转心不相应行及受。受相应非心随转者。谓心意识。心随转亦受相应者。谓想阴。彼相应行阴。非心随转亦非受相应者。谓除心随转身口业。若余色。除心随转心不相应行。若余心不相应行。如苦谛。集谛亦如是

道谛。或心随转非受相应。作四句。心随转非受相应者。谓心随转身口业。心随转心不相应行及受。受相应非心随转者。谓心意识。心随转亦受相应者。谓想阴。彼相应行阴。非心随转亦非受相应者。谓除心随转心不相应行。若余心不相应行。如受。想行亦如是。除其自性。一非觉随转非观相应。三分别苦谛。或觉随转非观相应。作四句。觉随转非观相应者。谓觉随转身口业。觉随转心不相应行。及觉相应观。观相应非觉随转者。谓觉若觉不相应观相应心心法苦谛。觉随转亦观相应者。谓觉观相应心心法苦谛。非觉随转亦非观相应者。谓除觉随转身口业。若余色。除觉随转心不相应行。若余心不相应行。及觉不相应观。及非觉观相应心心法苦谛。如苦谛。集谛亦如是

道谛。或觉随转非观相应。作四句。觉随转非观相应者。谓觉随转身口业。觉随转心不相应行。及觉相应观。观相应非觉随转者。谓觉若觉不相应观相应心心法。觉随转亦观相应者。谓觉观相应心心法。非觉随转亦非观相应者。谓除觉随转身口业。若余身口业。除觉随转心不相应行。若余心不相应行。及觉不相应观。及非觉观相应心心法

一非见亦非见处。三分别苦谛。或见亦见处。或见处非见。见亦见处者。谓眼根。及五见世俗正见。余见处非见。如苦谛。集谛亦如是。道谛所摄尽智无生智所不摄无漏慧。此是见非见处。余非见亦非见处

二身见非彼因彼亦非身见因。二分别苦谛。或身见是彼因彼非身见因。或身见是彼因彼亦身见因。或身见非彼。因彼亦非身见因。身见是彼因彼非身见因者。谓除过去现在见苦断使彼相应苦谛。除过去现在见集断一切遍使彼相应苦谛。除未来身见相应苦谛。除身见生住异灭及彼相应法生住异灭。若诸余秽污苦谛。身见是彼因彼亦身见因者。谓前所除尔所法者。是身见非彼因彼亦非身见因者。谓不秽污苦谛。如苦谛。集谛亦如是

一非业非业报。三分别。苦谛。或业非业报。作四句。业非业报者。谓身口业及报所不摄思业。业报非业者。谓若思所不摄报生苦谛业亦业报者。谓报生思业。非业亦非业报者。谓除业及业报苦谛。若余苦谛。如苦谛。集谛亦如是

道谛所摄身口业及思。是业非业报。余非业亦非业报

一非业亦非业随转。三分别苦谛。或业非业随转。作四句。业非业随转者。谓除业随转身口业。若余身口业。及思业。业随转非业者。谓受阴想阴识阴。若思所不摄业随转行阴。业亦业随转者。谓业随转身口业。非业亦非业随转者。谓除业及业随转苦谛。若余苦谛。如苦谛。集谛亦如是

道谛。或业非业随转。作四句。业非业随转者。谓思业。业随转非业者。谓受阴想阴识阴。若思所不摄业随转行阴。业亦业随转者。谓业随转身口业。非业亦非业随转者。谓除业随转心不相应行。若余心不相应行

一非造色色非可见色。三分别。苦谛。或造色色非可见色。作三句。造色色非可见色者。谓八入及二入少分。造色色亦可见色者。谓一入。非造色色亦非可见色者。谓一入及二入少分。如苦谛。集谛亦如是

道谛所摄身口业。是造色色非可见色。余非造色色。亦非可见色

一非造色色亦非有对色。三分别。苦谛。或造色色非有对色。作四句。造色色非有对色者。谓一入少分。有对色非造色色者。谓一入少分。造色色亦有对色者。谓九入及一入少分。非造色色亦非有对色者。谓一入及一入少分。如苦谛。集谛亦如是

道谛所摄身口业。是造色色非有对色。余非造色色亦非有对色。一切是甚深难了难了甚深

一是善非善因。一善亦善因。二分别苦谛。或善因非善。作三句。善因非善者。谓善报生苦谛。善亦善因者。谓善苦谛。非善亦非善因者。谓除善报生苦谛。若余无记。及不善苦谛。如苦谛。集谛亦如是

二非不善因亦非不善。二分别苦谛。或不善因非不善。作三句。不善因非不善者。谓不善报生苦谛。及欲界身见边见。彼相应苦谛。不善亦不善因者。谓不善苦谛。非不善亦非不善因者。谓除不善报生苦谛。除欲界身见边见。彼相应苦谛。若余无记。及善苦谛。如苦谛。集谛亦如是

二非无记亦非无记因。二分别苦谛。或无记因非无记。作三句。无记因非无记者。谓不善苦谛。无记亦无记因者。谓无记苦谛。非无记亦非无记因者。谓善苦谛。如苦谛。集谛亦如是

一非因缘缘非有因。三因缘缘及有因。一非次第亦非次第缘缘。三分别苦谛。或次第非次第缘缘。作三句。次第非次第缘缘者。谓未来现前必起心心法苦谛。过去及现在阿罗汉最后命终心心法苦谛。及无想正受。灭尽正受。已起当起。次第亦次第缘缘者。谓除过去现在阿罗汉最后命终心心法苦谛。若余过去及现在心心法苦谛。非次第亦非次第缘缘者。谓除未来现前必起心心法苦谛。若余未来心心法苦谛。除次第心不相应行。若余心不相应行及色。如苦谛。集谛亦如是

道谛。或次第非次第缘缘。作三句。次第非次第缘缘者。谓未来现前必起心心法道谛。次第亦次第缘缘者。谓过去现在心心法道谛。非次第亦非次第缘缘者。谓除未来现前必起心心法道谛。若余未来心心法道谛。及身口业心随转心不相应行

一缘缘缘非有缘。三分别。苦谛。所摄色心不相应行。缘缘缘非有缘。余缘缘缘及有缘。如苦谛。集谛亦如是

道谛所摄身口业。缘缘缘非有缘。余缘缘缘亦有缘

三是增上缘缘及有增上。一是增上缘缘非有增上。二非流非随流。二分别苦谛。或流亦随流。或随流非流。流亦随流者。谓四流。余随流非流。如苦谛。集谛亦如是

众事分阿毗昙论卷第九众事分阿毗昙论卷第十

        尊者世友造

        宋天竺三藏求那跋陀罗共菩提耶舍译

    千问论品第七之三

禅无量无色三摩提定菩提品根入阴界。禅者。谓四禅。问云何四。答谓初禅。二禅。三禅。四禅

问此四禅。几色。几非色。答禅所摄身口业。此是色。余非色。一切不可见。一切是无对

问禅几有漏。几无漏。答一切应分别。禅或有漏。或无漏。云何有漏。谓禅所摄有漏五阴。云何无漏。谓禅所摄无漏五阴。一切是有为。若有漏。彼有报。若无漏。彼无报。一切从因缘生世所摄。禅所摄身口业。是色所摄。余是名所摄。禅所摄心意识。是内入所摄。余是外入所摄。一切是智知。若有漏。断智知。及断。若无漏。非断智知。及不断。一切是应修。一切不秽污。一切是果及有果。一切是不受。禅所摄身口业。是四大造余非四大造。一切是有上。禅若有漏。彼是有。若无漏。彼非有。禅所摄身口业。及心不相应行。因不相应。余因相应

善五处少分摄四禅。四禅亦摄善五处少分。不善处所不摄。无记处所不摄。漏处所不摄。或有漏处摄非禅。作四句。有漏处摄非禅者。谓禅所不摄有漏五阴。禅摄非有漏处者。谓无漏四禅。有漏处摄亦禅者。谓有漏四禅。非有漏处摄亦非禅者。谓禅所不摄无漏五阴及无为

或无漏处摄非禅。作四句。无漏处摄非禅者。谓禅所不摄无漏五阴。及无为。禅摄非无漏处者。谓有漏四禅。无漏处摄亦禅者。谓无漏四禅。非无漏处摄亦非禅者。谓禅所不摄有漏五阴。一切或过去。或未来。或现在一切。若有漏。是色界系。若无漏。是不系

问禅几学。几无学。几非学非无学。答一切应分别。禅或学。或无学。或非学非无学。云何学。谓禅所摄学五阴。云何无学。谓禅所摄无学五阴。云何非学非无学。谓禅所摄有漏五阴。禅若有漏。彼修断。若无漏。彼不断。禅所摄身口业。及心不相应行。非心非心法非心相应。禅所摄受阴想阴。彼相应行阴。是心法心相应心意识。即心也。问禅几心随转非受相应。答作四句。心随转非受相应者。谓心随转身口业。心随转心不相应行及受。受相应非心随转者。谓心意识。心随转亦受相应者。谓想阴。彼相应行阴。非心随转亦非受相应者。谓除心随转心不相应行。若余心不相应行。如受想行亦如是。除其自性。三非觉非观。一分别初禅。或觉随转非观相应。作四句。觉随转非观相应者。谓觉随转身口业。觉随转心不相应行。及觉相应观。观相应非觉随转者。谓觉。觉随转亦观相应者。谓觉观相应心心法。非觉随转亦非观相应者。谓除觉随转心不相应行。若余心不相应行

问禅几见非见处。答作四句。见非见处者。谓禅所摄尽智无生智。所不摄无漏慧。见处非见者。谓见所不摄有漏四禅见亦见处者。谓世俗正见。非见亦非见处者。谓见所不摄无漏四禅。一切非身见因身见亦非彼因。禅所摄身口业及思。此是业非业报。余非业亦非业报

问禅几业非业随转。答作四句。业非业随转者。谓思业。业随转非业者。谓受阴想阴识阴。若思所不摄业随转行阴。业亦业随转者。谓业随转身口业。非业亦非业随转者。谓除业随转心不相应行。若余心不相应行

禅所摄身口业。是造色色非可见色。余非造色色亦非可见色。禅所摄身口业。是造色色非有对色。余非造色色亦非有对色。一切是甚深难了难了甚深

一切是善亦善因。一切非不善亦非不善因。一切非无记亦非无记因。一切是因缘缘亦有因

问禅几次第非次第缘缘。答一切应分别。初禅。或次第非次第缘缘。作三句。次第非次第缘缘者。谓未来现前必起心心法。次第亦次第缘缘者。谓过去现在心心法。非次第亦非次第缘缘者。谓除未来现前必起心心法。若余未来心心法。及身口业心不相应行。如初禅。第二第三禅亦如是

第四禅。或次第非次第缘缘。作三句。次第非次第缘缘者。谓未来现前必起心心法。及无想正受。已起当起。次第亦次第缘缘者。谓过去现在心心法。非次第亦非次第缘缘者。谓除未来现前必起心心法。若余未来心心法。除次第心不相应行。若余心不相应行。及身口业

禅所摄身口业心不相应行。是缘缘缘非有缘余者。是缘缘缘亦有缘。一切是增上缘缘及有增上。禅若有漏。彼随流非流。若无漏。彼非流亦非随流。无量者。谓四无量。问云何四。答谓慈悲喜舍

问此四无量。几色。几非色。答无量所摄身口业。此是色。余非色一切是不可见。一切是无对。一切是有漏。一切是有为。一切是有报。一切从因缘生世所摄。无量所摄身口业。此是色所摄。余是名所摄。无量所摄心意识。是内入所摄。余是外入所摄。一切是智知。一切是断智知及断。一切是应修。一切不秽污。一切是果及有果。一切是有上。一切是不受。无量所摄身口业。是四大造。余非四大造。一切是有无量所摄身口业。及心不相应行。因不相应。余因相应

善五处少分摄四无量。四无量亦摄善五处少分。不善处所不摄。无记处所不摄漏处所不摄。无漏处所不摄。有漏五处少分摄四无量。四无量亦摄有漏五处少分一切。或过去。或未来。或现在。一切是善。一切是色界系。一切是非学非无学。一切是修断。无量所摄身口业。心不相应行。非心非心法非心相应受阴想阴。彼相应行阴。心法心相应心意识。即心也

问无量。几心随转非受相应。答一切应分别。慈或心随转非受相应。作四句。心随转非受相应者。谓心随转身口业。心随转心不相应行及受。受相应非心随转者。谓心意识。心随转亦受相应者。谓想阴。彼相应行阴。非心随转亦非受相应者。谓除心随转心不相应行。若余心不相应行。如慈悲喜舍亦如是。如受想行亦如是。除其自性

问无量。几觉随转非观相应。答一切应分别慈心。或觉随转非观相应。作四句。觉随转非观相应者。谓觉随转身口业。觉随转心不相应行及觉相应观。观相应非觉随转者谓觉。若觉不相应观相应心心法。觉随转亦观相应者。谓觉观相应心心法。非觉随转亦非观相应者。谓除觉随转身口业。若余身口业。除觉随转心不相应行。若余心不相应行。及觉不相应观。及非觉观相应心心法如慈悲舍亦如是

喜或觉随转非观相应。作四句。觉随转非观相应者。谓觉随转身口业。觉随转心不相应行及觉相应观。观相应非觉随转者。谓觉。觉随转亦观相应者。谓觉观相应心心法。非觉随转亦非观相应者。谓除觉随转身口业。若余身口业。除觉随转心不相应行。若余心不相应行。及非觉观相应心心法

无量。或见亦见处。或见处非见。见亦见处者。谓世俗正见。余是见处非见。一切非身见因。身见亦非彼因。无量所摄身口业及思。是业非业报。余非业亦非业报

问无量几业非业随转。答作四句。业非业随转者。谓思业。业随转非业者。谓受阴想阴识阴。若思所不摄业随转行阴。业亦业随转者。谓业随转身口业。非业亦非业随转者。谓除业随转心不相应行。若余心不相应行

无量所摄身口业。是造色色非可见色。余非造色色亦非可见色

无量所摄身口业。是造色色非有对色。余非造色色亦非有对色。一切是甚深难了难了甚深

一切是善亦善因。一切非不善亦非不善因。一切非无记亦非无记因。一切是因缘缘亦有因

问无量几次第非次第缘缘。答作三句。次第非次第缘缘者。谓未来现前必起心心法。次第亦次第缘缘者。谓过去现在心心法。非次第亦非次第缘缘者。谓除未来现前必起心心法。若余未来心心法。及身口业心不相应行

无量所摄身口业。心不相应行。缘缘缘非有缘。余缘缘缘亦有缘。一切是增上缘缘及有增上。一切随流非流。无色者。谓四无色。问云何四。答谓。空入处。识入处。无所有入处。非想非非想入处

问此四无色。几色几非色。答一切是非色一切不可见。一切是无对。一有漏。三分别空处。或有漏或无漏。云何有漏。谓空处所摄有漏四阴。云何无漏。谓空处所摄无漏四阴。如空处。识处无所有处亦如是。一切是有为

问无色。几有报几无报。答一切应分别。空处。或有报或无报。云何有报。谓善有漏空处。云何无报。谓无记无漏空处。如空处。识处无所有处亦如是。非想非非想处。或有报或无报。云何有报。谓善非想非非想处。云何无报。谓无记非想非非想处

一切从因缘生世所摄。一切是名所摄。无色所摄心意识。是内入所摄。余是外入所摄。一切是智知。一断智知及断三分别。三若有漏。彼断智知及断。若无漏。非断智知及不断

问无色。几是应修几是不应修。答一切应分别空处。或应修或不应修。云何应修。谓善空处。云何不应修。谓无记空处。如空处。识处无所有处非想非非想处亦如是

问无色。几秽污几不秽污。答一切应分别无色。或秽污或不秽污。云何秽污。谓隐没。云何不秽污。谓不隐没。一切是果及有果。一切是不受。一切非四大造。一切有上。一是有。三分别。三若有漏。彼是有若无漏。彼非有。无色所摄心不相应行。因不相应。余因相应。或善处摄非无色。作四句。善处摄非无色者。谓善色阴。无色所不摄善四阴。及数灭。无色摄非善处者。谓无记四无色。善处摄亦无色者。谓善四无色。非善处摄亦非无色者。谓不善五阴。无记色阴。无色所不摄无记四阴。及虚空非数灭。不善处所不摄。或无记处摄非无色。作四句。无记处摄非无色者。谓无记色阴。无色所不摄无记四阴。虚空及非数灭。无色摄非无记者。谓善四无色。无记处摄亦无色者。谓无记四无色。非无记处摄亦非无色者。谓善五阴。及数灭。或漏处摄非无色。作四句。漏处摄非无色者。谓一漏处。及二漏处少分。无色摄非漏处者。谓漏处所不摄四无色。漏处摄亦无色者。谓二漏处少分。非漏处摄亦非无色者。谓色阴。漏处所不摄四阴。及无为

或有漏处摄非无色。作四句。有漏处摄非无色者。谓有漏色阴。无色所不摄有漏四阴。无色摄非有漏处者。谓三无色少分。有漏处摄亦无色者。谓一无色。及三无色少分。非有漏处摄亦非无色者。谓无漏色阴。无色所不摄无漏四阴。及无为

或无漏处摄非无色。作四句。无漏处摄非无色者。谓无漏色阴。无色所不摄无漏四阴。及无为。无色摄非无漏处者。谓一无色。及三无色少分。无漏处摄亦无色者。谓三无色少分。非无漏处摄亦非无色者。谓有漏色阴。及无色所不摄有漏四阴。一切。或过去。或未来。或现在

问无色。几善几无记。答一切应分别无色。或善或无记。云何善。谓无色所摄善四阴。云何无记。谓无色所摄无记四阴。一无色界系。三分别。三若有漏。彼无色界系。若无漏。彼不系。一非学非无学。三分别

空处。或学。或无学。或非学非无学。云何学。谓空处所摄学四阴。云何无学。谓空处所摄无学四阴。云何非学非无学。谓空处所摄有漏四阴。如空处。识处无所有处亦如是

问无色。几见断。几修断。几不断。答一切应分别空处。或见断。或修断。或不断。云何见断。谓空处随信行随法行人无间忍等断。彼云何断。谓见断二十八使。彼相应空处。彼所起心不相应行

云何修断。谓空处学见迹修断。彼云何断。谓修断三使。彼相应空处。彼所起心不相应行。及不秽污有漏空处。云何不断。谓无漏空处。如空处。识处无所有处亦如是

非想非非想处。或见断。或修断。云何见断。谓非想非非想随信行随法行人。无间忍等断。彼云何断。谓见断二十八使。彼相应非想非非想处。彼所起心不相应行

云何修断。谓非想非非想处学见迹修断。彼云何断。谓修断三使。彼相应非想非非想处。彼所起心不相应行。及不秽污有漏非想非非想处

无色所摄心不相应行。非心非心法非心相应受阴想阴。彼相应行阴。心法心相应心意识。即心也

问无色。几心随转非受相应。答作四句。心随转非受相应者。谓心随转心不相应行及受。受相应非心随转者。谓心意识。心随转亦受相应者。谓想阴。彼相应行阴。非心随转亦非受相应者。谓除心随转心不相应行。若余心不相应行。如受想行亦如是。除其自性。一切非觉随转非观相应

问无色。几见非见处。答一切应分别。空处。或见非见处。作四句。见非见处者。谓空处所摄尽智无生智。所不摄无漏慧。见处非见者。谓见所不摄有漏空处。见亦见处者。谓五见。世俗正见。非见亦非见处者。谓见所不摄无漏空处如空处。识处无所有处亦如是。非想非非想处。或见亦见处。或见处非见。见亦见处者。谓五见。世俗正见。余见处非见。四无色。几身见因广说如苦集谛

问无色。几业非业报。答一切应分别。空处。或业非业报。作四句。业非业报者。谓报所不摄思业。业报非业者。谓思所不摄。报生空处。业亦业报者。谓报生思业。非业亦非业报者。谓除业业报空处。若余空处。如空处。乃至非想非非想处亦如是

问无色。几业非业随转。答作三句。业非业随转者。谓思业。业随转非业者。谓受阴想阴识阴。若思所不摄业随转行阴。非业亦非业随转者。谓除业随转心不相应行。若余心不相应行。一切非造色色非可见色。一切非造色色非有对色。一切是甚深难了难了甚深

问无色。几善因非善。答作三句。善因非善者。谓善报生四无色。善亦善因者。谓善四无色。非善亦非善因者。谓除善报生四无色。若余无记四无色。一切非不善亦非不善因

问无色。几无记非无记因。答一切应分别。无色。或无记亦无记因。或非无记亦非无记因。无记亦无记因者。谓无记四无色。非无记亦非无记因者。谓善四无色。一切因缘缘及有因

问无色几次第非次第缘缘。答一切应分别。空处或次第非次第缘缘。作三句。次第非次第缘缘者。谓未来现前必起心心法空处。过去现在阿罗汉最后命终心心法空处。次第亦次第缘缘者。谓除过去现在阿罗汉最后命终心心法空处。若余过去现在心心法空处。非次第亦非次第缘缘者。谓除未来现前必起心心法空处。若余未来心心法空处。及心不相应行。如空处。识处无所有处亦如是。非想非非想处。或次第非次第缘缘。作三句。次第非次第缘缘者。谓未来现前必起心心法非想非非想处。过去现在阿罗汉最后命终心心法非想非非想处。及灭尽正受。已起当起。次第亦次第缘缘者。谓除过去现在阿罗汉最后命终心心法非想非非想处。若余过去现在非想非非想处。非次第亦非次第缘缘者。谓除未来现前必起心心法非想非非想处。若余未来心心法非想非非想处。除次第心不相应行。若余心不相应行

无色所不摄心不相应行。缘缘缘非有缘余缘缘缘及有缘。一切是增上缘缘及有增上

问无色。几流几随流。答一切应分别。空处。或随流非流。作三句。随流非流者。谓除流。若余有漏空处。流亦随流者。谓三流少分。非流亦非随流者。谓无漏空处。如空处。识处无所有处亦如是。非想非非想处。或流亦随流。或随流非流。流亦随流者。谓三流少分。此是流亦随流。余随流非流

三摩提定者。谓四三昧修。问云何四。答谓有三昧修广修习住现法乐转。有三昧修广修习知见转。有三昧修广修习慧分别转。有三昧修广修习漏尽转

问此四三昧修。几色。几非色。答三昧修所摄身口业是色。余非色。一切是不可见。一切是无对。一有漏。一无漏。二分别

住现法乐三昧修。或有漏。或无漏。云何有漏。谓住现法乐三昧修所摄有漏五阴。云何无漏。谓住现法乐三昧修所摄无漏五阴

慧分别三昧修。或有漏。或无漏。云何有漏。谓慧分别三昧修所摄有漏五阴。云何无漏。谓慧分别三昧修所摄无漏五阴

一切是有为。一有报。一无报。二分别。三若有漏。彼有报。若无漏。彼无报一切从因缘生世所摄。三昧修所摄身口业。是色所摄。余是名所摄。三昧修所摄心意识。是内入所摄。余是外入所摄。一切是智知。一是断智知及断。一非断智知及不断。二分别。二若有漏。断智知及断。若无漏。非断智知及不断。一切是应修。一切不秽污。一切是果及有果。一切是不受。三昧修所摄身口业。是四大造。余非四大造。一切是有上。一是有。一非有。二分别。二若有漏。彼是有。若无漏。彼非有。三昧修所摄身口业。及心不相应行。因不相应。余因相应

善五处少分摄四三昧修。四三昧修亦摄善五处少分。不善所不摄。无记所不摄。漏所不摄

或有漏处摄非三昧修。作四句。有漏处摄非三昧修者。谓三昧修所不摄有漏五阴。三昧修摄非有漏处者。谓一三昧修。及二三昧修少分。有漏处摄亦三昧修者。谓一三昧修。及二三昧修少分。非有漏处摄亦非三昧修者。谓虚空及数灭非数灭

或无漏处摄非三昧修。作四句。无漏处摄非三昧修者。谓虚空及数灭非数灭。三昧修摄非无漏者。谓一三昧修。及二三昧修少分。无漏处摄亦三昧修者。谓一三昧修。及二三昧修少分。非无漏处摄亦非三昧修者。谓三昧修所不摄有漏五阴

一切。或过去。或未来。或现在。一切是善。一色界系。一不系。二分别。住现法乐三昧修。若有漏。色界系。若无漏。不系。慧分别三昧修。或欲界系。或色界系。或无色界系。或不系。云何欲界系。谓慧分别三昧修所摄欲界系五阴。云何色界系。谓慧分别三昧修所摄色界系五阴。云何无色界系。谓慧分别三昧修所摄无色界系四阴。云何不系。谓慧分别三昧修所摄无漏五阴。一无学。一非学非无学。二分别。住现法乐三昧修。或学。或无学。或非学非无学。云何学。谓住现法乐三昧修所摄学五阴。云何无学。谓住现法乐三昧修所摄无学五阴。云何非学非无学。谓住现法乐三昧修所摄有漏五阴。慧分别三昧修。或学。或无学。或非学非无学。云何学。谓慧分别三昧修所摄学五阴。云何无学。谓慧分别三昧修所摄无学五阴。云何非学非无学。谓慧分别三昧修所摄有漏五阴。一修断。一不断。二分别。二若有漏。彼修断。若无漏。彼不断。三昧修所摄身口业。及心不相应行。非心非心法非心相应。三昧修所摄受阴想阴。彼相应行阴。心法心相应。心意识。即心也。问三昧修。几心随转非受相应。答一切应分别。住现法乐三昧修。或心随转非受相应。作四句。心随转非受相应者。谓心随转身口业。心随转心不相应行及受。受相应非心随转者。谓心意识。心随转亦受相应者。谓想阴。彼相应行阴。非心随转亦非受相应者。谓除心随转心不相应行。若余心不相应行。如住现法乐三昧修。知见三昧修漏尽三昧修亦如是

慧分别三昧修。或心随转非受相应。作四句。心随转非受相应者。谓心随转身口业。心随转心不相应行及受。受相应非心随转者。谓心意识。心随转亦受相应者。谓想阴。彼相应行阴。非心随转亦非受相应者。谓除心随转身口业。若余身口业。除心随转心不相应行。若余心不相应行。如受。想行亦如是。除其自性

一无觉无观。三分别。住现法乐三昧修或觉随转非观相应。作四句。觉随转非观相应者。广说如喜心。知见三昧修亦如是。意分别三昧修。广说如慈心

问三昧修。几见非见处。答一切应分别。住现法乐三昧修。或见非见处。作四句。见非见处者。谓住现法乐三昧修所摄尽智无生智。所不摄无漏慧。见处非见者。谓见所不摄有漏住现法乐三昧修。见亦见处者。谓世俗正见。非见亦非见处者。谓见所不摄无漏住现法乐三昧修

知见三昧修。或见亦见处。或见处非见。见亦见处者。谓知见三昧修所摄世俗正见。余见处非见

慧分别三昧修。或见非见处。作四句。见非见处者。谓慧分别三昧修所摄尽智无生智。所不摄无漏慧。见处非见者。谓见所不摄有漏慧分别三昧修。见亦见处者。谓世俗正见。非见亦非见处者。谓见所不摄无漏慧分别三昧修

漏尽三昧修所摄慧。是见非见处。余非见亦非见处

一切非身见因身见亦非彼因。三昧修所摄身口业及思。此是业非业报。余非业亦非业报

问三昧修。几业非业随转。答一切应分别。住现法乐三昧修。知见三昧修。漏尽三昧修。广说四句。如禅修多罗中分别。慧分别三昧修。广说四句如圣种修多罗中分别

三昧修所摄身口业。是造色色非可见色。余非造色色亦非可见色。三昧修所摄身口业。是造色色非有对色。余非造色色亦非有对色。一切是甚深难了难了甚深

一切是善亦善因。一切非不善亦非不善因。一切非无记亦非无记因。一切是因缘缘及有因

问三昧修。几次第非次第缘缘。答一切应分别。三昧修。或次第非次第缘缘。作三句。次第非次第缘缘者。谓未来现前必起心心法。次第亦次第缘缘者。谓过去现在心心法。非次第亦非次第缘缘者。谓除未来现前必起心心法。若余未来心心法。及身口业心不相应行

三昧修所摄身口业。是缘缘缘非有缘。余是缘缘缘亦有缘。一切是增上缘缘及有增上。一随流非流。一非流亦非随流。二分别。二若有漏。彼随流非流。若无漏。非流亦非随流。菩提品者。谓七觉支。问云何七。答谓念觉支。乃至舍觉支

问此七觉支几色几非色。答一切非色。一切不可见。一切是无对。一切是无漏。一切是有为。一切是无报。一切从因缘生世所摄。一切是名所摄。一切是外入所摄。一切是智知。一切非断智知及不断。一切是应修。一切不秽污。一切是果及有果。一切是不受。一切非四大造。一切是有上。一切非有。一切因相应

善二处少分摄七觉支。七觉支亦摄善二处少分。不善处所不摄。无记处所不摄。漏处所不摄。有漏处所不摄。无漏二处少分摄七觉支。七觉支亦摄无漏二处少分。一切。或过去。或未来。或现在。一切是善。一切是不系

问觉支几学几无学。答一切应分别。念觉支。或学。或无学。云何学。谓学意思惟相应念觉支。云何无学。谓无学意思惟相应念觉支。如念觉支。余一切亦如是

一切是不断。一切是心法心相应。一心随转非受相应。六心随转亦受相应。一切心随转想行相应。除其自性。问觉支。几觉随转非观相应。答一切应分别。念觉支。或有觉有观。或无觉有观。或无觉无观。云何有觉有观。谓有觉有观意思惟相应念觉支。云何无觉有观。谓无觉有观意思惟相应念觉支。云何无觉无观。谓无觉无观意思惟相应念觉支。如念觉支。择法精进猗定舍觉支亦如是

喜觉支。或有觉有观。或无觉无观。云何有觉有观。谓有觉有观意思惟相应喜觉支。云何无觉无观。谓无觉无观意思惟相应喜觉支。亦非见亦非见处。一分别。择法觉支所摄尽智无生智。所不摄无漏慧。是见非见处。余非见亦非见处

一切非身见因身见亦非彼因。一切非业亦非业报。一切是业随转非业。一切非造色色非可见色。一切非造色色非有对色。一切是甚深难了难了甚深

一切是善亦善因。一切非不善亦非不善因。一切非无记亦非无记因。一切是因缘缘亦有因

问觉支。几次第非次第缘缘。答一切应分别。念觉支。或次第非次第缘缘。作三句。次第非次第缘缘者。谓未来现前必起念觉支。次第亦次第缘缘者。谓过去现在念觉支。非次第亦非次第缘缘者。谓除未来现前必起念觉支。若余未来念觉支。如念觉支

余一切亦如是。一切是缘缘缘。亦有缘。一切是增上缘缘及有增上。一切非流亦非随流

众事分阿毗昙论卷第十众事分阿毗昙论卷第十一

        尊者世友造

        宋天竺三藏求那跋陀罗共菩提耶舍译

    千问论品第七之四

根者。谓二十二根。问此二十二根。几色。几非色。答七是色。十五非色。一切不可见。七有对。十五无对。十有漏。三无漏。九分别。意根。或有漏。或无漏。云何有漏。谓有漏意思惟相应意根。云何无漏。谓无漏意思惟相应意根。如意根。乐根喜根舍根信精进念定慧根亦如是。一切是有为

一有报。十一无报。十分别。意根。或有报。或无报。云何有报。谓不善善有漏意根。云何无报。谓无记无漏意根。如意根。乐根喜根舍根亦如是

苦根。或有报。或无报。云何有报。谓善不善苦根。云何无报。谓无记苦根。信精进念定慧根。若有漏。彼有报。若无漏。彼无报

一切从因缘生世所摄。七是色所摄。十五是名所摄。八是内入所摄。十一是外入所摄。三分别。未知当知根已知根无知根所摄心意识。是内入所摄。余是外入所摄

一切是智知。十是断智知。及断三非断智知。及不断。九分别。九若有漏。彼断智知。及断。若无漏。非断智知。及不断。八应修八不应修。六分别。意根。或应修。或不应修。云何应修。谓善意根。云何不应修。谓不善无记意根。如意根乐根苦根喜根舍根亦如是

忧根或应修。或不应修。云何应修。谓善忧根。云何不应修。谓不善忧根

十六不秽污。六分别。意根。或秽污。或不秽污。云何秽污。谓隐没。云何不秽污。谓不隐没。如意根。乐根苦根喜根忧根舍根亦如是

一切是果。及有果。十五不受。七分别。眼根。或受。或不受。云何受。若自性受。云何不受。若非自性受。如眼根。耳根鼻根舌根身根男根女根亦如是

七四大造。十五非四大造。一切是有上。十是有。三非有。九分别。九若有漏。彼是有。若无漏。彼非有。八因不相应。十四因相应

或善处摄非根。作四句。善处摄非根者。谓善色阴想阴。根所不摄善行阴。及数灭。根摄非善处者。谓八根六根少分。善处摄亦根者。谓八根六根少分。非善处摄亦非根者。谓不善色阴想阴。根所不摄不善行阴。根所不摄无记色阴想阴。根所不摄无记行阴。及虚空非数灭

或不善处摄非根。作四句。不善处摄非根者。谓不善色阴想阴。根所不摄不善行阴。根摄非不善处者。谓十六根六根少分。不善处摄亦根摄者。谓六根少分。非不善处摄亦非根者。谓善色阴想阴。根所不摄善行阴。及数灭根所不摄无记色阴想阴。根所不摄无记行阴。及虚空非数灭

或无记处摄非根。作四句。无记处摄非根者。谓根所不摄无记色阴想阴。根所不摄无记行阴。虚空及非数灭。根摄非无记处者。谓九根及五根少分。无记处摄亦根者。谓八根及五根少分。非无记处摄亦非根者。谓善色阴想阴。根所不摄善行阴。及数灭。及不善色阴想阴。根所不摄不善行阴。漏处所不摄。或有漏处摄非根。作四句。有漏处摄非根者。谓根所不摄有漏色阴想阴。根所不摄有漏行阴。根摄非有漏处者。谓三根及九根少分。有漏处摄亦根者。谓十根及九根少分。非有漏处摄亦非根者。谓无漏色阴想阴。根所不摄无漏行阴。及无为。或无漏处摄非根。作四句。无漏处摄非根者。谓无漏色阴想阴根所不摄无漏行阴。及无为。根摄非无漏处者。谓十根及九根少分。无漏处摄亦根摄者。谓三根及九根少分。非无漏处摄亦非根者。谓根所不摄有漏色阴想阴。根所不摄有漏行阴

一切。或过去。或未来。或现在。八善。八无记。六分别。意根。或善。或不善。或无记。云何善。谓善意思惟相应意根。云何不善。谓不善意思惟相应意根。云何无记。谓无记意思惟相应意根。如意根。乐苦喜舍根亦如是。忧根。或善。或不善。云何善。谓善意思惟相应忧根。云何不善。谓不善意思惟相应忧根。四欲界系三不系。十五分别。眼根。或欲界系。或色界系云何欲界系。谓眼根欲界系。四大所造。云何色界系。谓眼根色界系四大所造。如眼根。耳鼻舌身根亦如是

命根。或欲界系。或色界系。或无色界系云何欲界系。谓欲界系命。云何色界系。谓色界系命。云何无色界系。谓无色界系命

意根。或欲界系。或色界系。或无色界系。或不系。云何欲界系。谓欲界系意思惟相应意根。云何色界系。谓色界系意思惟相应意根。云何无色界系。谓无色界系意思惟相应意根。云何不系。谓无漏意思惟相应意根。如意根。舍根信精进念定慧根亦如是

乐根。或欲界系。或色界系。或不系。云何欲界系。谓欲界系意思惟相应乐根。云何色界系。谓色界系意思惟相应乐根。云何不系。谓无漏意思惟相应业根。如乐根。喜根亦如是

二学。一无学。十非学非无学。九分别。意根。或学。或无学。或非学非无学。云何学。谓学意思惟相应意根。无学即无学意思惟相应亦如是

云何非学非无学。谓有漏意思惟相应意根。如意根。乐喜舍根信精进念定慧根亦如是

九修断。三不断。十分别。意根。或见断。或修断。或不断。云何见断。若意根随信行随法行人无间忍等断。广说如分别诸入品。云何修断。谓如前广说。云何不断。谓无漏意根。如意根。舍根亦如是

乐根。或见断。或修断。或不断。云何见断。若乐根随信行随法行人无间忍等断。彼云何断。谓见断二十八使相应乐根。云何修断。若乐根学见迹修断。彼云何断。谓修断五使相应乐根。及不秽污有漏乐根。云何不断。谓无漏乐根(二十八者三禅四谛二十八五者三禅思惟三欲界思惟贪及无明二也)

喜根。或见断。或修断。或不断。云何见断。若喜根随信行随法行人无间忍等断。彼云何断。谓见断五十二使相应喜根。云何修断。若喜根学见迹修断。彼云何断。谓修断六使相应喜根。及不秽污有漏喜根。云何不断。谓无漏喜根(五十二者二禅四谛二十八欲界四谛身见一边见一邪见四戒盗二见盗四贪四慢四无明四六者二禅思惟三欲界思惟贪慢无明三也)

忧根。或见断。或修断。云何见断。若忧根随信行随法行人无间忍等断。彼云何断。谓见断十六使相应忧根。云何修断若忧根学见迹修断。彼云何断。谓修断二使相应忧根。及不秽污忧根(十六者欲界四谛邪见四疑四嗔恚四无明四二者欲界思惟嗔恚无明二也)

信精进念定慧。若有漏。彼修断。若无漏。彼不断。八非心非心法非心相应。十心法心相应一即心。三分别。未知当知根已知根无知根所摄九根八根。心法及心相应。一根即心也。八非心随转非受相应。一受相应非心随转。五心随转非受相应。五心随转亦受相应。三分别。未知当知根已知根无知根所摄三根。心随转非受相应。一受相应非心随转。五心随转亦受相应

八非心随转非想行相应。一想行相应非心随转。十心随转及想行相应。除其自性。三分别。未知当知根已知根无知根所摄九根八根。心随转亦想行相应。除其自性。一根想行相应非心随转

二有觉有观。八无觉无观。十二分别。意根。或有觉有观。或无觉有观。或无觉无观。云何有觉有观。谓有觉有观意思惟相应意根。云何无觉有观。谓无觉有观意思惟相应意根。云何无觉无观。谓无觉无观意思惟相应意根。如意根。舍根信精进念定慧根未知当知根已知根无知根亦如是

乐根。或有觉有观。或无觉无观。云何有觉有观。谓有觉有观意思惟相应乐根。云何无觉无观。谓无觉无观意思惟相应乐根。如乐根。喜根亦如是。一见亦见处九见处非见。十二分别。意根。若有漏。彼见处非见。若无漏。彼非见亦非见处。如意根。乐根喜根舍根信精进念定根亦如是

慧根。或见非见处。作四句。见非见处者。谓尽智无生智所不摄无漏慧根。见处非见者。谓见所不摄有漏慧根。见亦见处者。谓世俗正见。非见亦非见处者。谓见所不摄无漏慧根。未知当知根已知根所摄。见非见处。余非见亦非见处。无知根所摄尽智无生智。所不摄无漏慧根。是见非见处。余非见亦非见处。十六非身见因身见亦非彼因。六分别。意根乐根喜根舍根。广说如受念处。苦根。若秽污。彼身见因身见非彼因。若不秽污。彼非身见因。身见亦非彼因

忧根。或身见因身见非彼因。作三句。身见因身见非彼因者。谓除过去现在见苦断使相应忧根。除过去现在见集断一切遍使相应忧根。若余秽污忧根。身见因身见亦彼因者。谓前尔所所除者是。非身见因身见亦非彼因者。谓不秽污忧根

九非业非业报。一业报非报。十二分别。眼根。或业报非业。或非业亦非业报。业报非业者。谓报生眼根。余非业亦非业报。如眼根。耳根鼻根舌根身根男根女根意根乐根喜根舍根苦根亦如是

八非业非业随转。十四业随转非业。七是造色色非可见色。十五非造色色非可见色。七是造色色有对色。十五非造色色非有对色。一切是甚深难了难了甚深

八是善亦善因。十四分别。眼根。或善因非善。或非善因亦非善。善因非善者。谓善报生眼根。余非善因亦非善。如眼根。耳根鼻根舌根身根男根女根。命根亦如是

意根。或善因非善。作三句。善因非善者。谓善报生意根。善亦善因者。谓善意根。非善亦非善因者。谓除善报生意根及善意根。若余不善无记意根。如意根。乐根喜根舍根亦如是。苦根。或善亦善因。或非善亦非善因。善亦善因者。谓善苦根。非善亦非善因者。谓不善及无记苦根

忧根。或善亦善因。或非善。亦非善因。善亦善因者。谓善忧根。非善亦非善因者。谓不善忧根

八非不善非不善因。十四分别。眼根或不善因。非不善。或非不善因亦非不善。不善因非不善者。谓不善报生眼根。余非不善因亦非不善。如眼根。耳根鼻根舌根身根男根女根命根亦如是

意根。或不善因非不善。作三句。不善因非不善者。谓不善报生意根。及欲界身见边见相应意根。不善亦不善因者。谓不善意根非不善亦非不善因者。谓除不善报生意根。除欲界身见边见相应意根及除不善意根。若余无记及善意根

乐根。或不善非不善因。或非不善亦非不善因。不善非不善因者。谓不善乐根。非不善亦非不善因者。谓善及无记乐根

苦根。或不善因非不善。作三句。不善因非不善者。谓不善报生苦根。不善亦不善因者。谓不善苦根。非不善亦非不善因者。谓除不善报生苦根及不善苦根。若余无记及善苦根。喜根。或不善因非不善。作三句。不善因非不善者。谓欲界身见边见。彼相应喜根。不善亦不善因者。谓不善喜根。非不善亦非不善因者。谓除欲界。身见边见彼相应喜根。及除不善喜根。若余无记及善喜根。如喜根舍根亦如是。忧根。或不善亦不善因。或非不善亦非不善因。不善亦不善因者。谓不善忧根。非不善亦非不善因者。谓善忧根

八非无记亦非无记因。八无记亦无记因。六分别。意根。或无记因非无记。作三句。无记因非无记者。谓不善意根。无记亦无记因者。谓无记意根。非无记亦非无记因者。谓善意根。如意根。乐根苦根喜根舍根亦如是

忧根。或无记因非无记。或非无记亦非无记因无记因非无记者。谓不善忧根。非无记亦非无记因者。谓善忧根。一切因缘缘及有因。八非次第亦非次第缘缘。十四分别。意根。或次第非次第缘缘。广说如受念处。舍根亦如是

乐根。或次第非次第缘缘。作三句。次第非次第缘缘者。谓未来现前必起乐根。次第亦次第缘缘者。谓过去现在乐根。非次第亦非次第缘缘者。除未来现前必起乐根。若余未来乐根。如乐根。苦根喜根忧根信精进念定慧根未知当知根已知根无知根亦如是

八缘缘缘非有缘。十四缘缘缘及有缘。一切是增上缘缘亦有增上。十随流非流。三非流亦非随流。九分别。九若有漏。彼随流非流。若无漏。彼非流亦非随流

入者。谓十二入。问云何十二。答广说如前

问此十二入。几色。几非色。答谓十色。一非色。一分别。法入中。或色。或非色。云何色。谓法入中身口业是色。余非色。一可见。十一不可见。十有对。二无对。十有漏。二分别。意入。或有漏。或无漏。云何有漏。谓有漏意思惟相应意入。云何无漏。谓无漏意思惟相应意入。法入。或有漏。或无漏。云何有漏。谓有漏身口业。有漏受阴想阴行阴。云何无漏。谓无漏身口业。无漏受阴想阴行阴。及无为。十一有为。一分别。法入。或有为。或无为。云何有为。谓法入中身口业。受阴想阴行阴。云何无为。谓虚空数灭及非数灭。八无报。四分别。色入。或有报。或无报。云何有报。谓善不善色入。云何无报。谓除善不善色入。若余色入。如色入。声入亦如是

意入或有报。或无报。云何有报。谓不善善有漏意入。云何无报。谓无记及无漏意入。如意入。法入亦如是。十一从因缘生世所摄。一分别。法入。若有为因缘生世所摄。若无为非因缘生非世所摄。十是色所摄。一是名所摄。一分别。法入中身口业。是色所摄。余是名所摄。六是内入所摄。六是外入所摄。一切是智知。十断知知及断。二分别。二若有漏。彼断知知及断。若无漏。彼非断知知及不断。八不应修。四分别。色入。或应修。或不应修云何应修。谓善色入。云何不应修。谓不善及无记色入。如色入。声入意入亦如是

法入。广说如分别诸入品。八不秽污四分别。广说如上。十一是果及有果。一分别。法入中。或果非有果。作三句。果非有果者。谓数灭。果亦有果者。谓有为法入。非果亦非有果者。谓虚空及非数灭三不受。九分别。眼入。或受。或不受。云何受。谓自性受。云何不受。谓非自性受。如眼入。耳入鼻入舌入。身入色入香入味入触入亦如是

十二入。或四大造。或非四大造。云何四大造。谓九入。及二入少分。云何非四大造。谓一入。及二入少分。十一有上。一分别。法入。或有上。或无上。云何有上。谓法入中身口业。及受阴想阴行阴虚空。及非数灭。云何无上。谓数灭。十是有。二分别。二若有漏。彼是有。若无漏。彼非有。十因不相应。一因相应。一分别。法入。若心法因相应。若非心法因不相应

善处摄四入少分。四入少分亦摄善处不善处摄四入少分。四入少分亦摄不善处。无记处摄八入及四入少分。八入及四入少分亦摄无记处。漏处摄一入少分。一入少分亦摄漏处。有漏处摄十入及二入少分。十入及二入少分亦摄有漏处。无漏处摄二入少分。二入少分亦摄无漏处

十一。或过去。或未来。或现在。一分别。法入。若有为。或过去。或未来。或现在。若无为。非过去。非未来。非现在。八无记。四分别。广说如分别诸入品。二欲界系。十分别。广说如分别诸入品

问十二入。几学。几无学。几非学非无学。答广说如分别诸入品。十修断。二分别。广说如分别诸入品。十非心非心法非心相应。一即心。一分别。法入。若有缘心法心相应。若无缘非心法非心相应

十非心随转非受相应。一受相应非心随转一分别。法入。或心随转非受相应。作三句。心随转非受相应者。谓心随转身口业。心随转心不相应行及受。心随转亦受相应者。谓想阴彼相应行阴。非心随转亦非受相应者。谓除心随转身口业。若余身口业。除心随转心不相应行。若余心不相应行。及无为。如受。想行亦如是。除其自性。十非觉随转亦非观相应。二分别。意入。或有觉有观。或无觉有观。或无觉无观。云何有觉有观。谓有觉有观意思惟相应意入。云何无觉有观。谓无觉有观意思惟相应意入。云何无觉无观。谓无觉无观意思惟相应意入。法入。或觉随转非观相应。作四句。觉随转非观相应者。谓觉随转身口业。觉随转心不相应行。及觉相应观。观相应非觉随转者。谓觉。若觉不相应观相应心心法。觉随转亦观相应者。谓觉观相应心心法。非觉随转亦非观相应者。谓除觉随转身口业。若余身口业。除觉随转心不相应行。若余心不相应行。及觉不相应观。及非觉观相应心心法法入。及无为

一见亦见处。九见处非见。二分别。意入。若有漏。见处非见。若无漏。非见亦非见处。法入。或见非见处。作四句。见非见处者。谓法入所摄尽智无生智。所不摄无漏慧。见处非见者。谓见所不摄有漏法入。见亦见处者。谓五见。世俗正见。非见亦非见处者。谓见所不摄无漏法入

八非身见因身见亦非彼因。四分别。色入。若秽污。身见因身见非彼因。若不秽污非身见因身见亦非彼因。如色入。声入亦如是。意入。广说如受念处。法入广说如法念处。问十二入。几业非业报。答一切应分别。眼入。或业报非业。或非业报亦非业。业报非业者。谓报生眼入余非业报亦非业。如眼入。耳入鼻入香入舌入味入身入触入意入亦如是。色入。或业非业报。作三句。业非业报者。谓身作色。业报非业者。谓报生色入。非业亦非业报者。谓除业色及业报生色入。若余色入。声入。或业非业报。或非业亦非业报。业非业报者。谓口作。余非业亦非业报

法入。或业非业报。作四句。业非业报者。谓身口业。及报所不摄思业。业报非业者。谓思所不摄报生法入。业亦业报者。谓报生思业。非业亦非业报者。谓除业及业报生法入。若余法入。八非业非业随转。一业随转非业。三分别。色入。或业非业随转。或非业亦非业随转。业非业随转者。谓身作色。余非业亦非业随转。声入亦如是

法入。或业非业随转。作四句。业非业随转者。谓除业随转身口业。若余身口业。及思业。业随转非业者。谓受阴想阴。若思所不摄业随转行阴。业亦业随转者。谓业随转身口业。非业亦非业随转者。谓除业及业随转。法入。若余法入

十二入。或造色色非可见色。作三句。造色色非可见色者。谓八入。及二入少分造色色亦可见色者。谓一入。非造色色亦非可见色者。谓一入。及二入少分

十二入。或造色色非有对色。作四句。造色色非有对色者。谓一入少分。有对色非造色色者。谓一入少分。造色色亦有对色者。谓九入。及一入少分。非造色色亦非有对色者。谓一入。及一入少分。一切是甚深难了难了甚深。问十二入。几善亦善因。答一切应分别。眼入。或善因非善。或非善亦非善因。善因非善者。谓善报生眼入。余非善因亦非善。如眼入。耳入鼻入香入舌入味入身入触入亦如是

色入。或善因非善。作三句。善因非善者。谓善报生色入。善亦善因者。谓善色入。非善亦非善因者。谓无记及不善色入。如色入。意入亦如是

声入。或善亦善因。或非善亦非善因。善亦善因者。谓善声入。余非善亦非善因。法入。或善非善因。广说如法念处。问十二入。几不善亦不善因答一切应分别。眼入。或不善因非不善。或非不善亦非不善因。不善因非不善者。谓不善报生眼入。余非不善因亦非不善。如眼入。耳入鼻入香入舌入味入身入触入亦如是

色入。或不善因非不善。作三句。不善因非不善者。谓不善报生色入。不善亦不善因者。谓不善色入。非不善亦非不善因者。谓无记及善色入

声入。或不善亦不善因。或非不善亦非不善因。不善亦不善因者。谓不善声入。余非不善亦非不善因。意入。如意根。法入。如法念处。八无记亦无记因。四分别。色入。或无记因非无记。作三句。无记因非无记者。谓不善色入无记因亦无记者。谓无记色入。非无记因亦非无记者。谓善色入。如色入。声入意入亦如是

法入。或无记非无记因。作四句。无记非无记因者。谓虚空及非数灭。无记因非无记者。谓不善法入。无记亦无记因者。谓无记有为法入。非无记亦非无记因者。谓善法入

十一因缘缘及有因。一分别。法入。若有为因。缘缘及有因。若无为。非因缘缘非有因

十非次第亦非次第缘缘。二分别。意入。或次第非次第缘缘。作三句。次第非次第缘缘者。谓未来现前必起意入。过去现在阿罗汉最后命终意入。次第亦次第缘缘者。谓除过去现在阿罗汉最后命终意入。若余过去及现在意入。非次第亦非次第缘缘者。谓除未来现前必起意入。若余未来意入

法入。或次第非次第缘缘。作三句。次第非次第缘缘者。谓未来现前必起心法法入。过去及现在阿罗汉最后命终心法法入。及无想正受。灭尽正受。已起当起法入。次第亦次第缘缘者。谓除过去现在阿罗汉最后命终心法法入。若余过去及现在心法法入。非次第亦非次第缘缘者。谓除未来现前必起心法法入。若余未来心法法入。除次第心不相应行。若余心不相应行身口业。及无为

十缘缘缘非有缘。一缘缘缘亦有缘。一分别。缘法入。若心法。彼缘缘缘亦有缘。余非缘缘缘亦非有缘

十一是增上缘缘及有增上。一分别。法入。若有为。彼增上缘缘及有增上。若无为。增上缘缘非有增上

十随流非流。二分别。意入。若有漏。彼随流非流。若无漏。非流亦非随流。法入。或随流非流。作三句。随流非流者。谓流所不摄有漏法。入流亦随流者。谓四流。非流亦非随流者。谓流所不摄无漏法入

众事分阿毗昙论卷第十一众事分阿毗昙论卷第十二

        尊者世友造

        宋天竺三藏求那跋陀罗共菩提耶舍译

    千问论品第七之余

阴者。谓五阴。问云何五。答广说如上。问此五阴。几色。几非色。答一是色。四非色。四是不可见。一分别。色阴。或可见。或不可见。云何可见谓一入。云何不可见。谓九入。及一入少分。四无对。一分别。色阴。或有对。或无对。云何有对。谓十入。云何无对。谓一入少分。色阴。或有漏。或无漏。云何有漏。谓有漏。十入。及一入少分。云何无漏。谓一入少分。受阴。或有漏。或无漏。云何有漏。谓有漏意思惟相应受阴。云何无漏。谓无漏意思惟相应受阴。如受阴。想阴识阴亦如是

行阴。或有漏。或无漏。云何有漏。谓若有漏心相应。及有漏心不相应行阴。云何无漏。谓无漏心相应。及无漏心不相应行阴。一切是有为

问阴。几有报。几无报。答一切应分别。色阴。或有报或无报。云何有报。谓不善色阴。乃善有漏色阴。云何无报。谓无记及无漏色阴如色阴。受阴想阴行阴识阴亦如是

一切从因缘生世所摄。一是色所摄。四是名所摄一是内入所摄。三是外入所摄。一分别。色阴。或内入所摄。或外入所摄。云何内入所摄。谓五内入。云何外入所摄。谓五外入。及一外入少分。一切是智知。若有漏。彼断知知及断。若无漏。彼非断知知及不断

问阴。几应修。几不应修。答一切应分别。色阴。或应修。或不应修。云何应修。谓善色阴。云何不应修。谓不善及无记色阴。如色阴。受阴想阴识阴行阴亦如是

问阴。几秽污几非秽污。答一切应分别。色阴。或秽污。或非秽污。云何秽污。谓不善色阴及隐没无记色阴。云何非秽污。谓善色阴。及不隐没无记色阴。如色阴。受阴想阴识阴行阴亦如是

一切是果及有果。四不受。一分别。色阴。或受。或不受。云何受。若自性受。云何不受。若非自性受。四非四大造。一分别。色阴。或四大造。或非四大造。云何四大造。谓九入。及二入少分。云何非四大造。谓一入少分。一切有上问阴。几是有。几非有。答一切应分别。阴若有漏。彼是有。若无漏。彼非有。一因不相应。二因相应。一分别。行阴。若心法。因相应。若非心法。因不相应

或善处摄非阴。作四句。善处摄非阴者。谓数灭。阴摄非善处者。谓不善及无记五阴。善处摄亦阴者。谓善五阴。非善处摄亦非阴者。谓虚空非数灭。不善处摄五阴少分。五阴少分亦摄不善处

或无记处摄非阴。作四句。无记处摄非阴者。谓虚空及非数灭。阴摄非无记处者。谓善不善五阴。无记处摄亦阴者。谓无记五阴。非无记处摄亦非阴者。谓数灭。漏处摄一阴少分。一阴少分亦摄漏处。有漏处摄五阴少分。五阴少分亦摄有漏处

或无漏处摄非阴。作四句。无漏处摄非阴者。谓虚空数灭。非数灭阴摄非无漏处者。谓有漏五阴。无漏处摄亦阴者。谓无漏五阴。非无漏处。摄亦非阴者。是事不可得也

阴或过去。或未来。或现在。阴或善。或不善或无记。云何善。谓善五阴。云何不善。谓不善五阴。云何无记。谓无记五阴。阴或欲界系。或色界系。或无色界系。或不系。云何欲界系。谓欲界系五阴。云何色界系。谓色界系五阴。云何无色界系谓无色界系四阴。云何不系。谓无漏五阴

问阴。几学。几无学。几非学非无学。答一切应分别。阴或学。或无学。或非学非无学。云何学。谓学五阴。云何无学。谓无学五阴。云何非学非无学。谓有漏五阴

问阴。几见断。几修断。答一切应分别。色阴。若有漏。彼修断。若无漏彼不断。云何修断。谓十入。及一入少分。云何不断。谓一入少分。受阴。或见断。或修断。或不断。云何见断。若受阴随信行随法行人无间忍等断。彼云何断。谓见断八十八使相应受阴。云何修断。若受阴学见迹修断。彼云何断。谓修断十使相应受阴。及不秽污有漏受阴。云何不断。谓无漏受阴。如受阴。想阴识阴亦如是

行阴。或见断。或修断。或不断。云何见断。若行阴随信行随法行人无间忍等断。彼云何断。谓见断八十八使。彼相应行阴。彼所起心不相应行。云何修断。若行阴学见迹修断。彼云何断。谓修断十使。彼相应行阴。彼所起身口业。彼所起心不相应行。及不秽污有漏行阴。云何不断。谓无漏行阴。一非心非心法非心相应。二心法亦心相应。一唯心。一分别。行阴。若心不相应。彼非心非心法非心相应。余心法亦心相应。一心随转非受相应。一心随转亦受相应。二分别

色阴。或心随转非受相应。或非心随转。亦非受相应。心随转非受相应者。谓心随转身口业。余非心随转亦非受相应

行阴。或心随转非受相应。作三句。心随转非受相应者。谓心随转心不相应行阴。心随转亦受相应者。谓心相应行阴。非心随转亦非受相应者。谓除心随转心不相应行阴。若余心不相应行阴。如受。想亦如是。除其自性。问阴。几觉随转非观相应。答一切应分别。色阴。或觉随转非观相应。或非觉随转亦非观相应。觉随转非观相应者。谓觉随转身口业。余非觉随转亦非观相应

受阴。或有觉有观。或无觉有观。或无觉无观。云何有觉有观。谓有觉有观意思惟相应受阴。云何无觉有观。谓无觉有观意思惟相应受阴。云何无觉无观。谓无觉无观意思惟相应受阴。如受阴。想阴识阴亦如是

行阴。或觉随转非观相应。作四句。觉随转非观相应者。谓觉随转心不相应行阴。及觉相应观。观相应非觉随转者。谓觉。若觉不相应观相应心法行阴。觉随转亦观相应者。谓觉观相应心法行阴。非觉随转亦非观相应者。谓除觉随转心不相应行阴。若余心不相应行阴。及觉不相应观。及非觉观相应心法行阴

问阴。几见非见处答一切应分别。色阴。或见处非见。作三句。见处非见者。谓九入。及一入少分。见亦见处者。谓一入。非见亦非见处者。谓一入少分。受阴想阴识阴。若有漏。彼见处非见。若无漏。彼非见亦非见处

行阴。或见非见处。作四句。见非见处者。谓行阴所摄尽智无生智所不摄无漏慧。见处非见者。谓见所不摄有漏行阴。见亦见处者。谓五见。及世俗正见。非见亦非见处者。谓见所不摄无漏行阴

问阴。几身见非彼因彼非身见因。答一切应分别。色阴。如色入。受阴想阴识阴。如受念处。行阴。如法念处

问阴。几业非业报。答一切应分别。色阴。如身念处。受阴想阴识阴。如受念处。行阴。如法念处。三业随转非业。二分别。色阴。如身念处。行阴。如法念处。四阴非造色色非可见色。一分别。色阴。如身念处。四非造色色非有对色。一分别。色阴。如身念处。一切是甚深难了难了甚深

问阴。几善因非善。答一切应分别。阴或善因非善。作三句。善因非善者。谓善报生五阴。善亦善因者。谓善五阴。非善亦非善因者。谓不善及无记五阴

问阴。几不善非不善因。答一切应分别。色阴如身念处。受阴想阴识阴如受念处。行阴如法念处

问阴。几无记因非无记。答一切应分别。阴或无记因非无记。作三句。无记因非无记者。谓不善五阴。无记亦无记因者。谓无记五阴。非无记亦非无记因者。谓善五阴。一切因缘缘及有因。一非次第。亦非次第缘缘。四分别。受阴想阴识阴。如受念处

行阴。或次第非次第缘缘。作三句。次第非次第缘缘者。谓未来现前必起心法行阴。过去及现在阿罗汉最后命终心法行阴。及无想正受。灭尽正受。已起当起心法行阴。次第亦次第缘缘者。谓除过去现在阿罗汉最后命终心法行阴。若余过去及现在心法行阴。非次第亦非次第缘缘者。谓除未来现前必起心法行阴。若余未来心法行阴。除次第心不相应行阴。若余心不相应行阴

一缘缘缘非有缘。三缘缘缘及有缘。一分别行阴。若心法。彼缘缘缘及有缘。若非心法。缘缘缘非有缘。一切是增上缘缘及有增上

问阴。几流亦随流。答一切应分别。色阴受阴想阴识阴。若有漏。彼随流非流。若无漏。彼非流亦非随流。行阴。或随流非流。作三句。随流非流者。谓流所不摄有漏行阴。流亦随流者。谓四流。非流亦非随流者。谓流所不摄无漏行阴

界者。谓十八界。问云何十八。答广说如前

问此十八界。几色。几非色。答十是色。七非色。一分别。法界中身口业是色。余非色。一可见。十七不可见。十有对。八无对。十五有漏。三分别。意界。或有漏。或无漏。云何有漏。谓有漏意思惟相应意界。云何无漏。谓无漏意思惟相应意界。如意界。识界亦如是

法界。如法入。十七有为。一分别。法界。如法入。八无报。十分别。色界。或有报。或无报。云何有报。谓善不善色界。云何无报。谓无记色界。如色界。声界眼识界耳识界鼻识界舌识界身识界亦如是

意界。或有报。或无报。云何有报。谓不善及善有漏意界。云何无报。谓无记及无漏意界。如意界。意识界法界亦如是

十七从因缘生世所摄。一分别。法界如法入。十是色所摄。七是名所摄。一分别。法界中身口业是色所摄。余是名所摄。十二是内入所摄。六是外入所摄。一切是智知。十五断知知及断。三分别。三若有漏。断知知及断。若无漏。非断知知及不断。八不应修。十分别。色界。或应修。或不应修。云何应修。谓善色界。云何不应修。谓不善及无记色界。如色界。声界眼识耳识鼻识舌识身识界意界意识界亦如是。法界。或应修。或不应修。云何应修。谓善有为法界。云何不应修。谓不善无记法界及数灭。八不秽污。十分别。色界。或秽污。或不秽污。云何秽污。谓不善色界。及隐没无记色界。云何不秽污。谓善色界。及不隐没无记色界。如色界。声界眼识耳识鼻识舌识身识界意界意识界法界亦如是

十七是果及有果。一分别。法界如法入。九不受。九分别。眼界。或受。或不受。云何受。若自性受。云何不受。若非自性受。如眼界。色界耳界鼻界香界舌界味界身界触界亦如是。十八界。或四大造。或非四大造。云何四大造。谓九界。及二界少分。云何非四大造。谓七界。及二界少分。十七界是有上。一分别。法界如法入。十五是有。三分别。三若有漏。彼是有。若无漏彼非有。十因不相应。七因相应。一分别。法界是法入

善处摄十界少分。十界少分亦摄善处。不善处摄十界少分。十界少分亦摄不善处。无记处摄八界及十界少分。八界及十界少分亦摄无记处。漏处摄一界少分。一界少分亦摄漏处。有漏处摄十五界及三界少分。十五界及三界少分亦摄有漏处无漏处摄三界少分。三界少分亦摄无漏处。十七界。或过去。或未来。或现在。一分别。法界如法入。八无记。十分别。色界。或善。或不善。或无记。云何善。谓善身作。云何不善。谓不善身作。云何无记谓除善不善身作。若余色界。声界亦如是

眼识界。或善。或不善。或无记。云何善。谓善意思惟相应眼识界。云何不善。谓不善意思惟相应眼识界。云何无记。谓无记意思惟相应眼识界。如眼识。耳识鼻识舌识身识意界意识界亦如是

法界如法入。四欲界系。十四分别。眼界色界耳界声界鼻界舌界身界触界。如分别诸入品广说。眼识界或欲界系。或色界系。云何欲界系。谓欲界意思惟相应眼识界。云何色界系。谓色界意思惟相应眼识界。如眼识界。耳识身识界亦如是

意界意识界如意入。法界如法入。十五非学非无学。三分别。意界法界意识界。如分别诸入品广说。十五修断。三分别。意界法界意识界。如分别诸入品广说。十非心非心法非心相应。七即心。一分别。法界如法入。十非心随转非受相应七受相应非心随转。一分别。法界如法入。如受想行亦如是。除其自性。十非有觉有观。五有觉有观三分别。意界及意识界如意入。法界如法入

一见亦见处。十四见处非见。三分别。意界意识界如意入。法界如法入。八非身见因身见亦非彼因。十分别。色界。若秽污。身见因身见非彼因。若不秽污。非身见因身见亦非彼因。如色界声界眼识耳识鼻识舌识身识界亦如是。意界及意识界如意入。法界如法入

问十八界。几业非业报。答一切应分别。眼界或业报非业。或非业亦非业报。业报非业者。谓报生眼界。余非业界鼻界香界鼻识界舌界味界舌识界身界触界身识界意界意识界亦如是

色界如色入。声界如声入。法界如法入。八非业亦非业随转。七业随转非业。三分别。色界如色入。声界如声入。法界如法入

十八界。或造色色非可见色。作三句。造色色非可见色者。谓八界及二入少分。造色色亦可见色者。谓一界。非造色色非可见色者。谓七界及二界少分

十八界。或造色色非有对色。作四句。造色色非有对色者。谓一界少分。有对色非造色色者。谓一界少分。造色色亦有对色者。九界及一界少分。非造色色亦非有对色者。谓七界及一界少分。一切是甚深难了难了甚深。问十八界。几善非善因。答一切应分别。眼界。或善因非善。或非善因亦非善。善因非善者。谓善报生眼界。余非善亦非善因。如眼界。耳鼻香舌味身触界亦如是

色界如色入。眼识界耳识界鼻识界舌识界身识界意界意识界亦如是。声界。或善亦善因。或非善亦非善因。善亦善因者。谓善声界。余非善亦非善因。法界如法入

问十八界。几不善亦不善因。答一切应分别。眼界广说如眼入。如眼界。耳界鼻界香界舌界味界身界触界亦如是

色界如色入。如色界。眼识界耳识鼻识舌识身识界亦如是

声界如声入。意界如意根。意识界如喜根。法界如法入。八无记亦无记因。十分别色界。或无记因非无记。作三句。无记因非无记者。谓不善色界。无记亦无记因者。谓无记色界。非无记亦非无记因者。谓善色界。如色界。眼识界声界耳识界鼻识界舌识界身识界意界意识界亦如是

法界如法入。十七因缘缘及有因。一分别。法界如法入。十界非次第。亦非次第缘缘。八分别。眼识界。或次第非次第缘缘。作三句。次第非次第缘缘者。谓未来现前必起眼识界。次第亦次第缘缘者。谓过去现在眼识界。非次第亦非次第缘缘者。谓除未来现前必起眼识界。若余未来眼识界。如眼识界。耳识鼻识舌识身识界亦如是。意界及意识界如意入。法界如法入。十缘缘缘非有缘。七缘缘缘亦有缘。一分别。法界如法入。十七界是增上缘缘及有增上。一分别。法界如法入。十五随流非流。三分别。意界意识界如意入。法界如法入

    众事分阿毗昙择品第八

色法。十一界十一入一阴摄。八智知。除知他心智及灭智。六识识。欲色二界一切遍使使。及修断使使。即色法。十界十入一阴摄。非智知。五识识。非使使

非色法八界二入四阴摄。十智知。一识识。一切使使。即非色法。七界一入四阴摄。二智知。谓知他心智及灭智。非识识。无色界一切。欲色二界。二身见苦集断。不一切遍使使

可见法。一界一入一阴摄。七智知。除知他心智及灭道智。二识识。欲色二界一切遍使使。及修断使使。即可见法。一界一入非阴摄。非智知。一识识。非使使

不可见法。十七界十一入五阴摄。十智知。五识识。一切使使。即不可见法。十七界十一入四阴摄。三智知。谓知他心智及灭道智。四识识。无色界一切。欲色二界。二身见苦集断。不一切遍使使

有对法。十界十入一阴摄。七智知。除知他心智及灭道智。六识识。欲色二界一切遍使使。及修断使使。即有对法。十界十入非阴摄。非智知。五识识。非使使

无对法。八界二入五阴摄。十智知。一识识。一切使使。即无对法。八界二入四阴摄。三智知。谓知他心智及灭道智。非识识。无色界一切。欲色二界。二身见苦集断。不一切遍使使

有漏法。十八界十二入五阴摄。八智知。除灭道智。六识识。一切使使。即有漏法。十五界十入非阴摄。二智知。谓苦集智。五识识。一切使使

无漏法。三界二入五阴摄。八智知。除苦集智。一识识。使所不使。即无漏法。非界非入非阴摄。二智知。谓灭道智。非识识。非使使

有为法。十八界十二入五阴摄。九智知。除灭智。六识识。一切使使。即有为法。十七界十一入五阴摄。四智知。谓知他心智苦智集智道智。五识识。一切使使

无为法。一界一入阴所不摄。六智知。除知他心智及苦集道智。一识识。使所不使。即无为法。非界非入非阴摄。一智知。谓灭智。非识识。非使使

有诤无诤法。如有漏无漏法。如有诤无诤。世间出世间入不入染污不染污依家依出要结非结受非受缠非缠法亦如是

记法。十界四入五阴摄。十智知。三识识。欲界一切色无色界一切遍使使。及修断使使即记法。非界非入非阴摄。二智知。谓灭道智。非识识。欲界二身见集断。不一切遍使使

无记法。十八界十二入五阴摄。八智知。除灭道智。六识识。色无色界一切。欲界二身见集断一切遍使使。即无记法。八界八入非阴摄。非智知。三识识。色无色界二身见苦集断。不一切遍使使

隐没法。十界四入五阴摄。八智知。除灭道智。三识识。一切使使。即隐没法。非界非入非阴摄。非智知。非识识。三界二身见苦集断。不一切遍使使

不隐没法。十八界十二入五阴摄。十智知。六识识。三界一切遍使使。及修断使使。即不隐没法。八界八入非阴摄。二智知。谓灭道智。三识识。非使使。修法。十界四入五阴摄。九智知。除灭智。三识识。三界一切遍使使。及修断使使。即修法非界非入非阴摄。一智知。谓道智。非识识非使使

非修法。十八界十二入五阴摄。九智知。除道智六识识。一切使使。即非修法。八界八入非阴摄。一智知。谓灭智。二识识。三界二身见苦集断。不一切遍使使

秽污法。十界四入五阴摄。八智知。除灭道智。三识识。一切使使。即秽污法。非界非入非阴摄。非智知。非识识。三界二身见苦集断。不一切遍使使

非秽污法。十八界十二入五阴摄。十智知。六识识。一切使使。即非秽污法。八界八入非阴摄。二智知。谓灭道智。三识识。非使使。如秽污法。非秽污有罪无罪亦如是

有报法。十界四入五阴摄。八智知。除灭道智。三识识。欲界一切。色无色界一切遍使使。及修断使使。即有报法。非界非入非阴摄。非智知。非识识。欲界二身见集断。不一切遍使使

非有报法。十八界十二入五阴摄。十智知。六识识。色无色界一切。欲界二身见集断一切遍使使。即非有报法。八界八入非阴摄。二智知。谓灭道智。三识识。色无色界二身见苦集断。不一切遍使使

见法。二界二入二阴摄。九智知。除灭智。一识识。有漏缘使使。及无漏缘见相应无明使使。即见法。一界一入非阴摄。非智知。非识识。无漏缘见相应无明使使

非见法。十七界十一入五阴摄。十智知。六识识。一切使使。即非见法。十六界十入三阴摄。一智知。谓灭智。五识识。除无漏缘见相应无明。若余无漏缘使使

内法。十二界六入二阴摄。九智知。除灭智。一识识。一切使使。即内法。十二界六入一阴摄。非智知。非识识。非使使。外法。六界六入四阴摄。十智知。六识识。一切使使。即外法。六界六入三阴摄。一智知。谓灭智。五识识。非使使

受法。九界九入一阴摄。七智知。除知他心智及灭道智。五识识。欲色二界一切遍使使。及修断使使。即受法。非界非入非阴摄。非智知。非识识。非使使

非受法。十八界十二入五阴摄。十智知。六识识。一切使使。即非受法。九界三入四阴摄。三智知谓知他心智及灭道智。一识识。无色界一切。欲色二界二身见苦集断。不一切遍使使。心法。七界一入一阴摄。九智知。除灭智。一识识。一切使使。即心法。七界一入一阴摄。非智知。非识识。非使使

有缘法。八界二入四阴摄。九智知。除灭智。一识识。一切使使。即有缘法。七界一入三阴摄。一智知。谓知他心智。非识识。无漏缘使使。无缘法。十一界十一入二阴摄。九智知。除知他心智。六识识。有漏缘使使。即无缘法。十界十入一阴摄。一智知。谓灭智。五识识。非使使。心法法。一界一入三阴摄。九智知。除灭智。一识识。一切使使。即心法法。非界非入二阴摄。非智知。非识识。非使使

非心法法。十八界十二入三阴摄。十智知。六识识。一切使使。即非心法法。十七界十一入二阴摄。一智知。谓灭智。五识识。非使使

业法。三界三入二阴摄。九智知。除灭智。三识识。一切使使。即业法。非界非入非阴摄。非智知。非识识。非使使

非业法。十八界十二入五阴摄。十智知。六识识。一切使使。即非业法。十五界九入三阴摄。一智知。谓灭智。三识识。非使使

善法。十界四入五阴摄。十智知。三识识。三界一切遍使使。及修断使使。即善法。非界非入非阴摄。二智知。谓灭道智。非识识。非使使。不善法。十界四入五阴摄。七智知。除比智及灭道智。三识识。欲界一切使使。即不善法。非界非入非阴摄。非智知。非识识。欲界二身见集断。不一切遍使使

无记法。十八界十二入五阴摄。八智知。除灭道智。六识识。色无色界一切。欲界二身见集断一切遍使使。即无记法。八界八入非阴摄。非智知。三识识。色无色界二身见苦集断。不一切遍使使

见断法。三界二入四阴摄。八智知。除灭道智。一识识。见断一切使使。即见断法。非界非入非阴摄。非智知。非识识。三界二身见苦集断。不一切遍使使。修断法。十八界十二入五阴摄。八智知。除灭道智。六识识。修断一切。及一切遍使使。即修断法。十五界十入非阴摄。非智知。五识识。修断一切使使。无断法。三界二入五阴摄。八智知。除苦集智。一识识。使所不使。即无断法。非界非入非阴摄。二智知。谓灭道智。非识识。非使使

学法。三界二入五阴摄。七智知。除苦集智及灭智。一识识。使所不使。即学法。非界非入非阴摄。非智知。非识识。非使使。如学法。无学法亦如是

非学非无学法。十八界十二入五阴摄。九智知。除道智。六识识。一切使使。即非学非无学法。十五界十入非阴摄。三智知。谓苦集灭智。五识识。一切使使

欲界系法。十八界十二入五阴摄。七智知。除比智及灭道智。六识识。欲界一即使使。即欲界系法。四界二入非阴摄。非智知。二识识。欲界一切使使

色界系法。十四界十入五阴摄。七智知。除法智及灭道智。四识识。色界一切使使。即色界系法。非界非入非阴摄。非智知。非识识。色界一切使使

无色界系法。三界二入四阴摄。六智知。除法智知他心智及灭道智。一识识。无色界一切使使。即无色界系法。非界非入非阴摄。非智知。非识识。无色界一切使使

无系法。三界二入五阴摄。八智知。除苦集智。一识识。使所不使。即无系法。非界非入非阴摄。二智知。谓灭道智。非识识。非使使

过去法。十八界十二入五阴摄。九智知。除灭智。六识识。一切使使。即过去法。非界非入非阴摄。非智知。非识识。非使使。如过去法。未来现在法亦如是。非过去未来现在法。一界一入阴所不摄。六智知。除知他心智及苦集道智。一识识。使所不使。即非过去未来现在法。非界非入非阴摄。一智知。谓灭智。非识识。非使使

苦谛所摄法。广说如苦谛。即苦谛所摄法。非界非入非阴摄。非智知。非识识。非使使。如苦谛。集谛所摄法亦如是

灭谛所摄法。如灭谛。即灭谛所摄法。非界非入非阴摄。一智知。谓灭智。非识识。非使使。道谛所摄法如道谛。即道谛所摄法。非界非入非阴摄。一智知。谓道智。非识识。非使使。谛所不摄法。一界一入非阴摄。一智知。谓等智。一识识。非使使。即谛所不摄法。非界非入非阴摄。非智知。非识识。非使使。见苦断法。三界二入四阴摄。八智知。除灭道智。一识识。见苦断一切。及见集断一切遍使使。即见苦断法。非界非入非阴摄。非智知。非识识。即见苦断不一切遍使使

如是见集断差别者。即见集断不一切遍使使。见灭断差别者。谓见灭断一切使使。如是见道断差别者。见道断一切使使

修断法。十八界十二入五阴摄。八智知。除灭道智。六识识。修断一切使使。及一切遍使使。即修断法。十五界十入非阴摄。非智知。五识识。修断一切使使

无断法。三界二入五阴摄。八智知。除苦集智。一识识。使所不使。即无断法。非界非入非阴摄。二智知。谓灭道智。非识识。非使使

色阴。十一界十一入一阴摄。八智知。除知他心智及灭智。六识识。欲色二界一切遍使使。及修断使使。即色阴。十界十入一阴摄。非智知。五识识。非使使

受阴。一界一入一阴摄。九智知。除灭智。一识识。一切使使。即受阴。非界非入一阴摄。非智知。非识识。非使使。如受阴。想阴行阴亦如是。识阴。七界一入一阴摄。九智知。除灭智。一识识。一切使使。即识阴。七界一入一阴摄。非智知。非识识。非使使

眼入。一界一入一阴摄。七智知。除知他心智及灭道智。一识识。欲色二界一切遍使使。及修断使使。即眼入。一界一入非阴摄。非智知。非识识。如眼入。耳入鼻入舌入身入眼界耳鼻舌身界眼根耳鼻舌身根亦如是

色入。一界一入一阴摄。七智知。除知他心智及灭道智。二识识。欲色二界一切遍使使。及修断使使。即色入。一界一入非阴摄。非智知。一识识。非使使。如色入。声入触入色界声界触界亦如是

香入。一界一入一阴摄。六智知。除比智知他心智及灭道智。二识识。欲界一切遍使使。及修断使使即香入。一界一入非阴摄。非智知。一识识。非使使。如香入。味入香界味界亦如是

意入。七界一入一阴摄。九智知。除灭智。一识识。一切使使。即意入。七界一入一阴摄。非智知。非识识。非使使。如意入。意界意根亦如是。法入。一界一入四阴摄。七智知。一识识。一切使使。即法入。一界一入三阴摄。一智知。谓灭智。非识识。非使使。如法入。法界亦如是

眼识界。二界一入一阴摄。八智知。除灭道智。一识识。欲色二界一切遍使使。及修断使使。即眼识界。一界非入非阴摄。非智知。非识识。非使使。如眼识界。耳识界身识界亦如是

鼻识界。二界一入一阴摄。七智知。除比智及灭道智。一识识。欲界一切遍使使。及修断使使。即鼻识界。一界非入非阴摄。非智知。非识识。非使使。如鼻识界。舌识界亦如是

意识界。二界一入一阴摄。九智知。除灭智。一识识。一切使使。即意界。一界非入非阴摄非智知。非识识。非使使。女根。一界一入一阴摄。六智知。除比智知他心智及灭道智。一识识。欲界一切遍使使。及修断使使。即女根。非界非入非阴摄。非智知。非识识。非使使。如女根。男根亦如是

命根。一界一入一阴摄。七智知。除知他心智及灭道智。一识识。三界一切遍使使。及修断使使。即命根。非界非入非阴摄。非智知。非识识。非使使

乐根。一界一入一阴摄。九智知。除灭智。一识识。色界一切使使。欲界一切遍使使。及修断使使。即乐根。非界非入非阴摄。非智知。非识识。非使使

喜根。一界一入一阴摄。九智知。除灭智。一识识。色界一切使使。除欲界无漏缘疑及彼相应无明。余欲界一切使使。即喜根。非界非入非阴摄。非智知。非识识。非使使

忧根。一界一入一阴摄。七智知。除比智及灭道智。一识识。欲界一切使使。即忧根。非界非入非阴摄。非智知。非识识。非使使

舍根。一界一入一阴摄。九智知。除灭智。一识识。一切使使。即舍根。非界非入非阴摄。非智知。非识识。非使使

信根。一界一入一阴摄。九智知。除灭智。一识识。三界一切遍使使。及修断使使。即信根。非界非入非阴摄。非智知。非识识。非使使。如信根。精进根念根定根慧根亦如是

苦根。一界一入一阴摄。七智知。除比智及灭道智。一识识欲界一切遍使使。及修断使使。即苦根。非界非入非阴摄。非智知。非识识。非使使

未知当知根。三界二入三阴摄。七智知。除苦集智及灭智。一识识。非使使。即未知当知根。非界非入非阴摄。非智知。非识识。非使使。如未知当知根。已知根无知根亦如是

欲界系见苦断使。一界一入一阴摄。七智知。除比智及灭道智。一识识。欲界系见苦断一切使使。及见集断一切遍使使。即欲界系见苦断使。非界非入非阴摄。非智知。非识识。非使使。欲界系见集断使。一界一入一阴摄。七智知。除比智及灭道智。一识识。欲界系见集断一切使使。及见苦断一切遍使使。即欲界系见集断使。非界非入非阴摄。非智知。非识识。非使使。欲界系见灭断使。一界一入一阴摄。七智知。除比智及灭道智。一识识。除欲界系见灭断无漏缘不共无明。若余欲界系见灭断一切使使。及一切遍使使。即欲界系见灭断使。非界非入非阴摄。非智知。非识识。非使使。如见灭断。见道断亦如是

欲界系修断使。一界一入一阴摄。七智知。除比智及灭道智。一识识。欲界系修断一切使使。及一切遍使使。即欲界系修断使。非界非入非阴摄。非智知。非识识。非使使。如欲界系。色界系无色界系差别者。色无色界系见苦集灭道修断使。六智知。除法智知他心智及灭道智。余如前说

  敬礼最真觉　　无为第一尊
  敬礼最寂灭　　及三乘妙道
  敬礼最息心　　净戒清凉僧
  今归凭三宝　　欲有所微通
  愿加垂威神　　必流无滞塞
  古昔诸尊人　　于妙甚深义
  究竟无障碍　　结集为众典
  助圣扬法化　　谨顺三藏宝
  于彼佛游国　　流宣长贤众
  兹土文不传　　壅理在叶墨
  我释迦比丘　　求那跋陀罗
  于此众事分　　真定胡文本
  请释迦比丘　　师菩提耶舍
  于彼胡文典　　专精宋辞译
  执笔录心受　　一一从义书
  句味粗已定　　谨呈旧学僧
  实不为名称　　每存增学徒
  愿以此微缘　　善了诸法相
  明达四真谛　　永处涅槃乐

众事分阿毗昙论卷第十二